Xtreme Toolkit Pro Overview

CommandBars, DockingPanes, Report Control, TabManager, Property Grid, Skin Framework, Task Panel, Syntax Edit, Controls, Common Files
Xtreme Toolkit Pro v12.0
Xtreme Toolkit Pro Overview

Xtreme Toolkit Professional Edition extends MFC to give you the ability to quickly and easily create professional applications that have the latest visual styles and advanced features that are seen in such products as Microsoft® Office and Microsoft® Visual Studio .NET.

Supported Environments
Visual C++ 5.0
Visual C++ 6.0
Visual C++ 7.0 (.NET 2002)
Visual C++ 7.1 (.NET 2003)
Visual C++ 8.0 (.NET 2005)
Supported Operating Systems
Windows NT 4.0, 2000, XP, 2003
Windows 95, 98, 98SE, ME
Minimum Requirements
Windows 95/NT
Copyright (c) 1998-2008 Codejock Software. All rights reserved.
What do you think about this topic? Send feedback!


Class Hierarchy Overview

Links
Previous | Up | Next
Class Hierarchy Overview

Group

Xtreme Toolkit Pro v12.0


Command Bars

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Functions, Macros, Structs, Records, Enums, Types, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Command Bars

Codejock Software's Xtreme Command Bars provides Windows developers with a sophisticated Office style Command Bars, Menus and One Note style MDI tab windows.

Group

Xtreme Toolkit Pro v12.0

Legend
Template
Method
Structure
Enumeration
Classes
Class | Description
CXTPCommandBar | CXTPCommandBar is a CWnd derived class. It represents the parent class for command bars.
CXTPCommandBarKeyboardTip | CXTPCommandBarKeyboardTip is CWnd derived class, represents Keyboard tip single window
CXTPCommandBarList | CXTPCommandBarList is a CList derived class. It is used as a collection of CXTPCommandBar classes.
CXTPCommandBars | CXTPCommandBars is standalone class. It allows developer manipulate toolbars and popupbars
CXTPCommandBarsContextMenus | CXTPCommandBarsContextMenus is CXTPCommandBarList derived class, represents collection of context menus
CXTPCommandBarsOptions | Options of the command bars.
CXTPCommandBarsSiteBase | CXTPCommandBarsSiteBase is a stand alone class. It represents site for Command Bars object
CXTPControl | CXTPControl is a CCmdTarget derived class. It represents the parent class for the command bar's controls.
CXTPControlAction | CXTPControlAction is a CCmdTarget derived class. It represents the single action of controls.
CXTPControlActions | CXTPControlActions is a CCmdTarget derived class. It represents a collection of the actions.
CXTPControlBitmap | CXTPControlBitmap is a CXTPControlLabel derived class. It can be used to add bitmap to toolbar.
CXTPControlButton | CXTPControlButton is a CXTPControl derived class. It represents a button control.
CXTPControlButtonColor | CXTPControlButtonColor is a CXTPControlButton derived class. It represents a text button in the color picker popup.
CXTPControlCheckBox | CXTPControlCheckBox is a CXTPControlButton derived class. It represents a checkbox control.
CXTPControlColorSelector | CXTPControlColorSelector is a CXTPControl derived class. It represents a color selector control.
CXTPControlComboBox | CXTPControlComboBox is a CXTPControl derived class. It represents a combo box control.
CXTPControlComboBoxEditCtrl | Inplace Edit control of the combo.
CXTPControlComboBoxList | CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class. It represents a list box of CXTPControlComboBox control.
CXTPControlComboBoxPopupBar | CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class. It represents base class for combo popups.
CXTPControlCustom | CXTPControlCustom is a CXTPControlButton derived class. It represents the control with some child window.
CXTPControlEdit | CXTPControlEdit is a CXTPControl derived class. It represents an edit control.
CXTPControlEditCtrl | Inplace Edit control of CXTPControlEdit.
CXTPControlFontComboBox | CXTPControlFontComboBox is a CXTPControlComboBox derived class. It represents the font picker control.
CXTPControlFontComboBoxList | CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class. It represents the font picker popup.
CXTPControlGallery | CXTPControlGallery is a CXTPControlPopup derived class. It represents gallery control of toolbar.
CXTPControlGalleryItem | CXTPControlGalleryItem is a CCmdTarget derived class. It represents single item of gallery object.
CXTPControlGalleryItems | CXTPControlGalleryItems is a CCmdTarget derived class. It represents a collection of the items for gallery control.
CXTPControlGalleryPaintManager | CXTPControlGalleryPaintManager is standalone class used to draw CXTPControlGallery object
CXTPControlHyperlink | CXTPControlHyperlink is a CXTPControl derived class. It can be used to add hyperlink text.
CXTPControlLabel | CXTPControlLabel is a CXTPControl derived class. It represents a label control.
CXTPControlListBox | CXTPControlComboBox is a CXTPControl derived class. It represents a list box control.
CXTPControlMarkupLabel | CXTPControlMarkupLabel is a CXTPControlLabel derived class. It can be used to draw markup text
CXTPControlOleItems | CXTPControlOleItems is a CXTPControlButton derived class. It is used internally to create ole items.
CXTPControlPopup | CXTPControlPopup is a CXTPControl derived class. It represents a popup-able control.
CXTPControlPopupColor | CXTPControlPopupColor is a CXTPControlPopup derived class. It represents a color picker control.
CXTPControlRadioButton | CXTPControlRadioButton is a CXTPControlButton derived class. It represents a radio button control.
CXTPControlRecentFileList | CXTPControlRecentFileList is a CXTPControlButton derived class. It is used internally to create recent items list.
CXTPControls | CXTPControls is a CCmdTarget derived class. It represents a collection of the controls.
CXTPControlSelector | CXTPControlSelector is a CXTPControl derived class that represents a control selector.
CXTPControlSizeComboBox | CXTPControlSizeComboBox is a CXTPControlComboBox derived class. It represents the size picker.
CXTPControlStatic | CXTPControlStatic is a CXTPControl derived class. It represents a static text control.
CXTPControlToolbars | CXTPControlToolbars is a CXTPControlButton derived class. It is used internally to create toolbars list items.
CXTPControlWindowList | CXTPControlWindowList is a CXTPControlButton derived class. It is used internally to create window list items.
CXTPControlWorkspaceActions | CXTPControlWorkspaceActions is a CXTPControlButton derived class. It used internally to add workspace actions to window menu.
CXTPCustomizeCommandsListBox | List of the commands
CXTPCustomizeCommandsPage | CXTPCustomizeCommandsPage is a CPropertyPage derived class. It represents the Commands page of the Customize dialog.
CXTPCustomizeKeyboardPage | CXTPCustomizeKeyboardPage is a CPropertyPage derived class. It represents the Keyboard page of the Customize dialog.
CXTPCustomizeOptionsPage | CXTPCustomizeOptionsPage is a CPropertyPage derived class. It represents the Options page of the Customize dialog.
CXTPCustomizeSheet | CXTPCustomizeSheet is a CPropertySheet derived class. It represents the Customize dialog.
CXTPCustomizeToolbarsPage | CXTPCustomizeToolbarsPage is a CPropertyPage derived class. It represents the Toolbars page of the Customize dialog.
CXTPDefaultTheme | The CXTPDefaultTheme class is used to enable an Office 2000 style theme for Command Bars
CXTPDialog | CXTPDialog is a CXTPDialogBase derived class. Use this class in your dialog base application.
CXTPDialogBar | CXTPDialogBar is a CXTPToolBar derived class. It represents dockable container for child window
CXTPDialogBase | CXTPDialogBase is a TBase derived class. It represents the parent class for a CXTPDialog class .
CXTPDockBar | CXTPDockBar is a CWnd derived class. It is used internally by CXTPCommandBars.
CXTPDockContext | CXTPDockContext is a stand alone class. It is used internally by CXTPToolBar.
CXTPDockState | CXTPDockState is a stand alone class. It is used internally by CXTPToolBar.
CXTPEdit | CXTPEdit is a CEdit derived class. It is for internal usage only.
CXTPFrameWnd | CXTPFrameWnd is a CXTPFrameWndBase derived class.
CXTPFrameWndBase | CXTPFrameWndBase is a stand alone class. It represents the parent class for a CXTPMDIFrameWnd and CXTPFrameWnd classes .
CXTPGroupLine | CXTPGroupLine is a CStatic derived class. It used in CXTPCustomizeOptionsPage page to draw group line static control.
CXTPImageEditorDlg | CXTPImageEditorDlg is a CDialog derived class. It represents the dialog for icons edition.
CXTPMDIFrameWnd | CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.
CXTPMenuBar | CXTPMenuBar is a CXTPToolBar derived class. It represents menu bar of frame window.
CXTPMenuBarMDIMenuInfo | CXTPMenuBarMDIMenuInfo structure used to describe parameters of application MDI menus.
CXTPMenuBarMDIMenus | CXTPMenuBarMDIMenus represents collection of MDI menus for CXTPMenuBar
CXTPMouseManager | CXTPMouseManager is standalone class. It used in CommandBars to manage mouse.
CXTPNativeXPTheme | The CXTPNativeXPTheme class is used to enable a Windows XP style theme for Command Bars
CXTPNewToolbarDlg | CXTPNewToolbarDlg is CDialog derived class. It used internally in customization sheet.
CXTPOffice2007Theme | The CXTPOffice2007Theme class is used to enable an Office 2007 style theme for Command Bars
CXTPOfficeTheme | The CXTPOfficeTheme class is used to enable an Office XP style theme for Command Bars
CXTPPaintManager | Paint manager of the command bars.
CXTPPaintManagerFont | PaintManagers used CFont wrapper.
CXTPPopupBar | CXTPPopupBar is a CXTPCommandBar derived class. It represents submenu of menu bar.
CXTPPopupToolBar | CXTPPopupToolBar is a CXTPPopupBar derived class.
CXTPReBar | The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring of band layouts.
CXTPReBarPaintManager | The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars
CXTPRibbonBar | CXTPRibbonBar is a CXTPMenuBar derived class, It represents Ribbon control from Office 2007.
CXTPRibbonControls | CXTPRibbonControls is a CXTPControls derived class. It represents a collection of the controls for Ribbon Bar.
CXTPRibbonControlTab | CXTPRibbonControlTab is a CXTPTabManager derived class, It represents tabs of the ribbon bar
CXTPRibbonCustomizeQuickAccessPage | CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class. It represents the Quick Access page of the Customize dialog.
CXTPRibbonGroup | Represents a single group that is added to a CXTPRibbonTab.
CXTPRibbonGroups | Represents a collection of CXTPRibbonGroup objects.
CXTPRibbonQuickAccessControls | CXTPRibbonQuickAccessControls is a CXTPControls derived class. It represents a collection of the controls for quick access controls for Ribbon Bar.
CXTPRibbonTab | Represents a tab in the Ribbon Bar.
CXTPRibbonTheme | Standalone class used by the CXTPRibbonBar as a paint manager.
CXTPShortcutManager | CXTPShortcutManager is standalone class used to manipulate accelerators of frame.
CXTPSoundManager | CXTPSoundManager is standalone class. It used to play system sound.
CXTPStatusBar | CXTPStatusBar is a CControlBar derived class.
CXTPStatusBarPane | CXTPStatusBarPane is a CCmdTarget derived class. It represents single pane of status bar
CXTPStatusBarProgressPane | CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class. CXTPStatusBarProgressPane works with CXTStatusBar and allows you to create progress bar in your status bar area.
CXTPStatusBarScrollBarPane | CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class. CXTPStatusBarScrollBarPane works with CXTStatusBar and allows you to create themed ScrollBar in your status bar area.
CXTPStatusBarSliderPane | CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class. CXTPStatusBarSliderPane works with CXTStatusBar and allows you to create themed Slider in your status bar area.
CXTPStatusBarSwitchPane | CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class. CXTPStatusBarSwitchPane works with CXTStatusBar and allows you to create switches in your status bar area.
CXTPTabClientWnd | CXTPTabClientWnd is a CWnd derived class. It represents a tabbed workspace.
CXTPTabToolBar | CXTPTabToolBar is a CXTPToolBar derived class. It represents tabbable toolbar
CXTPToolBar | CXTPToolBar is a CXTPCommandBar derived class.
Files
File | Description
XTPCommandBar.h | XTPCommandBar.h : interface for the CXTPCommandBar class.
XTPCommandBars.h | XTPCommandBars.h : interface for the CXTPCommandBars class.
XTPCommandBarsDefines.h | XTPCommandBarDefines.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControl.h | XTPControl.h : interface for the CXTPControl class.
XTPControlButton.h | XTPControlButton.h : interface for the CXTPControlButton class.
XTPControlComboBox.h | XTPControlComboBox.h : interface for the CXTPControlComboBox class.
XTPControlComboBoxExt.h | XTPControlComboBoxExt.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlCustom.h | XTPControlCustom.h : interface for the CXTPControlCustom class.
XTPControlEdit.h | XTPControlEdit.h : interface for the CXTPControlEdit class.
XTPControlExt.h | XTPControlExt.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlGallery.h | XTPControlGallery.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlListBox.h | XTPControlListBox.h : interface for the CXTPControlListBox class.
XTPControlPopup.h | XTPControlPopup.h : interface for the CXTPControlPopup class.
XTPControlPopupColor.h | XTPControlPopupColor.h : interface for the CXTPControlPopupColor class.
XTPControls.h | XTPControls.h : interface for the CXTPControls class.
XTPCustomizeCommandsPage.h | XTPCustomizeCommandsPage.h : interface for the CXTPCustomizeCommandsPage class.
XTPCustomizeKeyboardPage.h | XTPCustomizeKeyboardPage.h : interface for the CXTPCustomizeKeyboardPage class.
XTPCustomizeOptionsPage.h | XTPCustomizeOptionsPage.h : interface for the CXTPCustomizeOptionsPage class.
XTPCustomizeSheet.h | XTPCustomizeSheet.h : interface for the CXTPCustomizeSheet class.
XTPCustomizeToolbarsPage.h | XTPCustomizeToolbarsPage.h : interface for the CXTPCustomizeToolbarsPage class.
XTPCustomizeTools.h | XTPCustomizeTools.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPDialogBar.h | XTPToolBar.h : interface for the CXTPToolBar class.
XTPDialogBase.h | XTPFrameWnd.h : interface for the CXTPFrameWnd and CXTPMDIFrameWnd classes.
XTPDockBar.h | XTPDockBar.h : interface for the CXTPDockBar class.
XTPDockContext.h | XTPDockContext.h : interface for the CXTPDockContext class.
XTPDockState.h | XTPDockState.h : interface for the CXTPDockState class.
XTPFrameWnd.h | XTPFrameWnd.h : interface for the CXTPFrameWnd and CXTPMDIFrameWnd classes.
XTPImageEditor.h | XTPImageEditor.h : interface for the CXTPImageEditorDlg class.
XTPMenuBar.h | XTPMenuBar.h : interface for the CXTPMenuBar class.
XTPMouseManager.h | XTPMouseManager.h : interface for the CXTPMouseManager class.
XTPOffice2007Theme.h | XTPOffice2007Theme.h : interface for the CXTPOffice2007Theme class.
XTPPaintManager.h | XTPPaintManager.h : interface for the CXTPPaintManager class.
XTPPopupBar.h | XTPPopupBar.h : interface for the CXTPPopupBar class.
XTPReBar.h | XTPReBar.h : header file This file is a part of the XTREME COMMANDBARS MFC class library.
XTPRibbonBar.h | XTPRibbonBar.h: interface for the CXTPRibbonBar class.
XTPRibbonControlTab.h | XTPRibbonControlTab.h: interface for the CXTPRibbonControlTab class.
XTPRibbonCustomizeQuickAccessPage.h | XTPRibbonCustomizeQuickAccessPage.h: interface for the CXTPRibbonCustomizeQuickAccessPage class.
XTPRibbonGroup.h | XTPRibbonGroup.h: interface for the CXTPRibbonGroup class.
XTPRibbonGroups.h | XTPRibbonGroups.h: interface for the CXTPRibbonGroups class.
XTPRibbonQuickAccessControls.h | XTPRibbonQuickAccessControls.h: interface for the CXTPRibbonQuickAccessControls class.
XTPRibbonTab.h | XTPRibbonTab.h: interface for the CXTPRibbonTab class.
XTPRibbonTheme.h | XTPRibbonTheme.h: interface for the CXTPRibbonTheme class.
XTPShortcutManager.h | XTPShortcutManager.h : interface for the CXTPShortcutManager class.
XTPSoundManager.h | XTPSoundManager.h : interface for the CXTPSoundManager class.
XTPStatusBar.h | XTPStatusBar.h : interface for the CXTPStatusBar class.
XTPTabClientWnd.h | XTPTabClientWnd.h : interface for the CXTPTabClientWnd class.
XTPTabToolBar.h | XTPTabToolBar.h : interface for the CXTPTabToolBar class.
XTPToolBar.h | XTPToolBar.h : interface for the CXTPToolBar class.
Functions
Function | Description
XTPPaintManager | Call this function to access CXTPPaintManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPPaintManager.
XTPSoundManager | Call this function to access CXTPSoundManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSoundManager.
Macros
Macro | Description
DECLARE_XTP_COMMANDBAR | This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be serialized.
DECLARE_XTP_CONTROL | This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serialized.
IMPLEMENT_XTP_COMMANDBAR | This macro generates the C++ code necessary for a CXTPCommandBar-derived class that can be serialized.
IMPLEMENT_XTP_CONTROL | This macro generates the C++ code necessary for a CXTPControl-derived class that can be serialized.
ON_XTP_AFTERCREATECONTROL | The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after new CXTPControl object is created.
ON_XTP_CREATECOMMANDBAR | The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when new CXTPCommandBars object is created.
ON_XTP_CREATECONTROL | The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when new CXTPControl object is created.
ON_XTP_EXECUTE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
ON_XTP_EXECUTE_RANGE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
ON_XTP_INITCOMMANDSPOPUP | The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active
ON_XTP_UNINITCOMMANDSPOPUP | The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.
XTP_IDS_AUTOMATIC | Obsolete define
xtpComboLabel | Deprecated style for Combo control
xtpComboNormal | Deprecated style for Combo control
Structs, Records, Enums
Struct, Record, Enum | Description
NMXTPCHARHDR | Structure used as parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages.
NMXTPTABCHANGE | Structure used as parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when Ribbon tab is changed
XTP_COMMANDBARS_CATEGORYINFO | This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages
XTP_COMMANDBARS_ICONSINFO | This structure collect icons options for command bars.
XTP_COMMANDBARS_PROPEXCHANGE_PARAM | XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings. This is a set of State options that will be used to change how and what will be saved and loaded when loading and saving XML files.
XTPAnimationType | Enumerated type used to determine the animation effect of popup bars.
XTPBarPosition | Position of the command bar
XTPBarType | Type of the command bar.
XTPButtonStyle | Button's styles
XTPControlCustomVerticalOptions | Vertical options enumerator.
XTPControlFlags | Flags of the control.
XTPControlHideFlags | Control's hide flags, these are flags that specify why a control is hidden.
XTPControlType | Type of the control.
XTPIdleFlags | Flags for idle routine
XTPKeyboardCuesShow | Enumerated type used to determine menu underlines.
XTPKeyboardCuesUse | Enumerated type used to determine if menu underlines execute popups.
XTPMenuBarFlags | Menubar system button flags.
XTPPaintTheme | Paint themes used by command bars.
XTPPopupDirection | Docking direction enumerator.
XTPRibbonTabContextColor | Ribbon Tab context color
XTPSoundManagerState | Enumeration used to play system sound.
XTPSpecialControl | Special control with extended drawing.
XTPSpecialKey | Special keys enumerator.
XTPToolBarFlags | Docking flags.
XTPWorkspaceActivateTab | XTPWorkspaceActivateTab enumerator, used to determine which tab will become active after the currently active tab is closed.
XTPWorkspaceButtons | Workspace buttons enumerator, used to indicate which tab navigation buttons to display in the TabWorkspace.
XTPWorkspaceNewTabPosition | XTPWorkspaceNewTabPosition enumerator, used to determine where new tab will appear
LPCREATEBARSTRUCT | Create bar structure
LPCREATECONTROLSTRUCT | Create control structure.
LPNMXTPCONTROL | This structure is passed as parameter in CBN_XTP_EXECUTE message.
NMXTPCONTROL | This structure is passed as parameter in CBN_XTP_EXECUTE message.
XTP_COMMANDBARS_CREATEBAR | Create bar structure
XTP_COMMANDBARS_CREATECONTROL | Create control structure.
Types
Type | Description
CXTPCommandBarsCategoryArray | This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_CATEGORYINFO structures.
Variables
Variable | Description
CBN_XTP_EXECUTE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
WM_XTP_AFTERCREATECONTROL | The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after new CXTPControl object is created.
WM_XTP_BEFORECREATECONTROL | The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when new CXTPControl object is created.
WM_XTP_COMMANDBARKEYDOWN | The WM_XTP_COMMANDBARKEYDOWN is sent to the CXTPCommandBars site when user press key
WM_XTP_COMMANDBARS_BASE | Base message for CommandBars
WM_XTP_CONTROLRBUTTONUP | The WM_XTP_CONTROLRBUTTONUP is sent to the CXTPCommandBars site when menu user press right button in command bar control.
WM_XTP_CONTROLSELECTED | The WM_XTP_CONTROLSELECTED is sent to the CXTPCommandBars site when the user selects a CXTPCommandBar item
WM_XTP_CREATECOMMANDBAR | The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when new CXTPCommandBars object is created.
WM_XTP_DRAGCONTROLCHANGED | The WM_XTP_DRAGCONTROLCHANGED is sent to the CXTPCommandBars site when user select button of toolbar in customization mode
WM_XTP_GETTABICON | The WM_XTP_GETTABICON message is sent to MDI child window to retrieve icon will be used for tabbed interface.
WM_XTP_GETWINDOWTEXT | The WM_XTP_GETWINDOWTEXT message is sent to MDI child window to retrieve text will be used for tabbed interface.
WM_XTP_GETWINDOWTOOLTIP | The WM_XTP_GETWINDOWTOOLTIP message is sent to MDI child window to retrieve tooltips for CXTPTabClientWnd's tabs.
WM_XTP_INITCOMMANDSPOPUP | The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active
WM_XTP_INITMENU | The WM_XTP_INITMENU is sent to the CXTPCommandBars site when menu is about to become active. It occurs when the user clicks an item on the menu bar or presses a menu key. This allows the application to modify the menu before it is displayed.
WM_XTP_NEWTABITEM | The WM_XTP_NEWTABITEM message is sent to owner window when new tab was created
WM_XTP_PRETRANSLATEMOUSEMSG | The WM_XTP_PRETRANSLATEMOUSEMSG message is sent to owner window to pre-translate mouse messages.
WM_XTP_TOOLBARCONTEXTMENU | The WM_XTP_TOOLBARCONTEXTMENU is sent to the CXTPCommandBars site when context menu is about to become visible
WM_XTP_TOOLBARVISIBLECHANGED | The WM_XTP_TOOLBARVISIBLECHANGED is sent to the CXTPCommandBars site when the user show/hide a toolbar object
WM_XTP_UNINITCOMMANDSPOPUP | The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.
XTP_FN_GETFORMAT | The XTP_FN_GETFORMAT notification sent by CXTPControlFontComboBox to get current RichEdit selection format
XTP_FN_SETFORMAT | The XTP_FN_SETFORMAT notification sent by CXTPControlFontComboBox to set current RichEdit selection format
XTP_LBN_POPUP | The XTP_LBN_POPUP is sent to active view when the CXTPControlListBox is about to become visible.
XTP_LBN_SELCHANGE | The XTP_LBN_SELCHANGE is sent to active view when the selection of CXTPControlListBox is changed
XTP_SLN_SELCHANGE | XTP_SLN_SELCHANGE is sent to the parent commandbar when the number of selected items has changed in the control selector.


Command Bars Hierarchy

Command Bars
Command Bars Hierarchy

Module

Command Bars


Classes

Classes, Legend, Command Bars, Templates
Classes
Classes
Class | Description
CXTPCommandBar | CXTPCommandBar is a CWnd derived class. It represents the parent class for command bars.
CXTPCommandBarKeyboardTip | CXTPCommandBarKeyboardTip is CWnd derived class, represents Keyboard tip single window
CXTPCommandBarList | CXTPCommandBarList is a CList derived class. It is used as a collection of CXTPCommandBar classes.
CXTPCommandBars | CXTPCommandBars is standalone class. It allows developer manipulate toolbars and popupbars
CXTPCommandBarsContextMenus | CXTPCommandBarsContextMenus is CXTPCommandBarList derived class, represents collection of context menus
CXTPCommandBarsOptions | Options of the command bars.
CXTPControl | CXTPControl is a CCmdTarget derived class. It represents the parent class for the command bar's controls.
CXTPControlAction | CXTPControlAction is a CCmdTarget derived class. It represents the single action of controls.
CXTPControlActions | CXTPControlActions is a CCmdTarget derived class. It represents a collection of the actions.
CXTPControlBitmap | CXTPControlBitmap is a CXTPControlLabel derived class. It can be used to add bitmap to toolbar.
CXTPControlButton | CXTPControlButton is a CXTPControl derived class. It represents a button control.
CXTPControlButtonColor | CXTPControlButtonColor is a CXTPControlButton derived class. It represents a text button in the color picker popup.
CXTPControlCheckBox | CXTPControlCheckBox is a CXTPControlButton derived class. It represents a checkbox control.
CXTPControlColorSelector | CXTPControlColorSelector is a CXTPControl derived class. It represents a color selector control.
CXTPControlComboBox | CXTPControlComboBox is a CXTPControl derived class. It represents a combo box control.
CXTPControlComboBoxEditCtrl | Inplace Edit control of the combo.
CXTPControlComboBoxList | CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class. It represents a list box of CXTPControlComboBox control.
CXTPControlComboBoxPopupBar | CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class. It represents base class for combo popups.
CXTPControlCustom | CXTPControlCustom is a CXTPControlButton derived class. It represents the control with some child window.
CXTPControlEdit | CXTPControlEdit is a CXTPControl derived class. It represents an edit control.
CXTPControlEditCtrl | Inplace Edit control of CXTPControlEdit.
CXTPControlFontComboBox | CXTPControlFontComboBox is a CXTPControlComboBox derived class. It represents the font picker control.
CXTPControlFontComboBoxList | CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class. It represents the font picker popup.
CXTPControlGallery | CXTPControlGallery is a CXTPControlPopup derived class. It represents gallery control of toolbar.
CXTPControlGalleryItem | CXTPControlGalleryItem is a CCmdTarget derived class. It represents single item of gallery object.
CXTPControlGalleryItems | CXTPControlGalleryItems is a CCmdTarget derived class. It represents a collection of the items for gallery control.
CXTPControlGalleryPaintManager | CXTPControlGalleryPaintManager is standalone class used to draw CXTPControlGallery object
CXTPControlHyperlink | CXTPControlHyperlink is a CXTPControl derived class. It can be used to add hyperlink text.
CXTPControlLabel | CXTPControlLabel is a CXTPControl derived class. It represents a label control.
CXTPControlListBox | CXTPControlComboBox is a CXTPControl derived class. It represents a list box control.
CXTPControlMarkupLabel | CXTPControlMarkupLabel is a CXTPControlLabel derived class. It can be used to draw markup text
CXTPControlOleItems | CXTPControlOleItems is a CXTPControlButton derived class. It is used internally to create ole items.
CXTPControlPopup | CXTPControlPopup is a CXTPControl derived class. It represents a popup-able control.
CXTPControlPopupColor | CXTPControlPopupColor is a CXTPControlPopup derived class. It represents a color picker control.
CXTPControlRadioButton | CXTPControlRadioButton is a CXTPControlButton derived class. It represents a radio button control.
CXTPControlRecentFileList | CXTPControlRecentFileList is a CXTPControlButton derived class. It is used internally to create recent items list.
CXTPControls | CXTPControls is a CCmdTarget derived class. It represents a collection of the controls.
CXTPControlSelector | CXTPControlSelector is a CXTPControl derived class that represents a control selector.
CXTPControlSizeComboBox | CXTPControlSizeComboBox is a CXTPControlComboBox derived class. It represents the size picker.
CXTPControlStatic | CXTPControlStatic is a CXTPControl derived class. It represents a static text control.
CXTPControlToolbars | CXTPControlToolbars is a CXTPControlButton derived class. It is used internally to create toolbars list items.
CXTPControlWindowList | CXTPControlWindowList is a CXTPControlButton derived class. It is used internally to create window list items.
CXTPControlWorkspaceActions | CXTPControlWorkspaceActions is a CXTPControlButton derived class. It used internally to add workspace actions to window menu.
CXTPCustomizeCommandsListBox | List of the commands
CXTPCustomizeCommandsPage | CXTPCustomizeCommandsPage is a CPropertyPage derived class. It represents the Commands page of the Customize dialog.
CXTPCustomizeKeyboardPage | CXTPCustomizeKeyboardPage is a CPropertyPage derived class. It represents the Keyboard page of the Customize dialog.
CXTPCustomizeOptionsPage | CXTPCustomizeOptionsPage is a CPropertyPage derived class. It represents the Options page of the Customize dialog.
CXTPCustomizeSheet | CXTPCustomizeSheet is a CPropertySheet derived class. It represents the Customize dialog.
CXTPCustomizeToolbarsPage | CXTPCustomizeToolbarsPage is a CPropertyPage derived class. It represents the Toolbars page of the Customize dialog.
CXTPDefaultTheme | The CXTPDefaultTheme class is used to enable an Office 2000 style theme for Command Bars
CXTPDialog | CXTPDialog is a CXTPDialogBase derived class. Use this class in your dialog base application.
CXTPDialogBar | CXTPDialogBar is a CXTPToolBar derived class. It represents dockable container for child window
CXTPDockBar | CXTPDockBar is a CWnd derived class. It is used internally by CXTPCommandBars.
CXTPDockContext | CXTPDockContext is a stand alone class. It is used internally by CXTPToolBar.
CXTPDockState | CXTPDockState is a stand alone class. It is used internally by CXTPToolBar.
CXTPEdit | CXTPEdit is a CEdit derived class. It is for internal usage only.
CXTPFrameWnd | CXTPFrameWnd is a CXTPFrameWndBase derived class.
CXTPGroupLine | CXTPGroupLine is a CStatic derived class. It used in CXTPCustomizeOptionsPage page to draw group line static control.
CXTPImageEditorDlg | CXTPImageEditorDlg is a CDialog derived class. It represents the dialog for icons edition.
CXTPMDIFrameWnd | CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.
CXTPMenuBar | CXTPMenuBar is a CXTPToolBar derived class. It represents menu bar of frame window.
CXTPMenuBarMDIMenuInfo | CXTPMenuBarMDIMenuInfo structure used to describe parameters of application MDI menus.
CXTPMenuBarMDIMenus | CXTPMenuBarMDIMenus represents collection of MDI menus for CXTPMenuBar
CXTPMouseManager | CXTPMouseManager is standalone class. It used in CommandBars to manage mouse.
CXTPNativeXPTheme | The CXTPNativeXPTheme class is used to enable a Windows XP style theme for Command Bars
CXTPNewToolbarDlg | CXTPNewToolbarDlg is CDialog derived class. It used internally in customization sheet.
CXTPOffice2007Theme | The CXTPOffice2007Theme class is used to enable an Office 2007 style theme for Command Bars
CXTPOfficeTheme | The CXTPOfficeTheme class is used to enable an Office XP style theme for Command Bars
CXTPPaintManager | Paint manager of the command bars.
CXTPPaintManagerFont | PaintManagers used CFont wrapper.
CXTPPopupBar | CXTPPopupBar is a CXTPCommandBar derived class. It represents submenu of menu bar.
CXTPPopupToolBar | CXTPPopupToolBar is a CXTPPopupBar derived class.
CXTPReBar | The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring of band layouts.
CXTPRibbonBar | CXTPRibbonBar is a CXTPMenuBar derived class, It represents Ribbon control from Office 2007.
CXTPRibbonControls | CXTPRibbonControls is a CXTPControls derived class. It represents a collection of the controls for Ribbon Bar.
CXTPRibbonControlTab | CXTPRibbonControlTab is a CXTPTabManager derived class, It represents tabs of the ribbon bar
CXTPRibbonCustomizeQuickAccessPage | CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class. It represents the Quick Access page of the Customize dialog.
CXTPRibbonGroup | Represents a single group that is added to a CXTPRibbonTab.
CXTPRibbonGroups | Represents a collection of CXTPRibbonGroup objects.
CXTPRibbonQuickAccessControls | CXTPRibbonQuickAccessControls is a CXTPControls derived class. It represents a collection of the controls for quick access controls for Ribbon Bar.
CXTPRibbonTab | Represents a tab in the Ribbon Bar.
CXTPRibbonTheme | Standalone class used by the CXTPRibbonBar as a paint manager.
CXTPShortcutManager | CXTPShortcutManager is standalone class used to manipulate accelerators of frame.
CXTPSoundManager | CXTPSoundManager is standalone class. It used to play system sound.
CXTPStatusBar | CXTPStatusBar is a CControlBar derived class.
CXTPStatusBarPane | CXTPStatusBarPane is a CCmdTarget derived class. It represents single pane of status bar
CXTPStatusBarProgressPane | CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class. CXTPStatusBarProgressPane works with CXTStatusBar and allows you to create progress bar in your status bar area.
CXTPStatusBarScrollBarPane | CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class. CXTPStatusBarScrollBarPane works with CXTStatusBar and allows you to create themed ScrollBar in your status bar area.
CXTPStatusBarSliderPane | CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class. CXTPStatusBarSliderPane works with CXTStatusBar and allows you to create themed Slider in your status bar area.
CXTPStatusBarSwitchPane | CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class. CXTPStatusBarSwitchPane works with CXTStatusBar and allows you to create switches in your status bar area.
CXTPTabClientWnd | CXTPTabClientWnd is a CWnd derived class. It represents a tabbed workspace.
CXTPTabToolBar | CXTPTabToolBar is a CXTPToolBar derived class. It represents tabbable toolbar
CXTPToolBar | CXTPToolBar is a CXTPCommandBar derived class.
Module

Command Bars

Templates
Template | Description
CXTPCommandBarsSiteBase | CXTPCommandBarsSiteBase is a stand alone class. It represents site for Command Bars object
CXTPDialogBase | CXTPDialogBase is a TBase derived class. It represents the parent class for a CXTPDialog class .
CXTPFrameWndBase | CXTPFrameWndBase is a stand alone class. It represents the parent class for a CXTPMDIFrameWnd and CXTPFrameWnd classes .
CXTPReBarPaintManager | The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars
Legend
Template


CXTPCommandBar Class

XTPCommandBar.h, Classes, Legend, Members, Topics, CXTPCommandBar Data Members, CXTPCommandBar Methods, CXTPCommandBar Constructors, CXTPCommandBar Destructors, CXTPCommandBar Constructors, CXTPCommandBar Data Members, CXTPCommandBar Destructors, CXTPCommandBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar Class

CXTPCommandBar is a CWnd derived class. It represents the parent class for command bars.

Class Hierarchy

class CXTPCommandBar : public CWnd, public CXTPHookManagerHookAble;
File

XTPCommandBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCommandBar Constructors
CXTPCommandBar Constructors | Description
CXTPCommandBar | Constructs a CXTPCommandBar object
CXTPCommandBar Data Members
CXTPCommandBar Data Members | Description
m_bAnimatePopup | TRUE to animate popup bar.
m_barPosition | Position of the command bar.
m_barType | Type of the command bar.
m_bCloseable | TRUE if the CommandBar can be closed andor Hidden
m_bComboBar | TRUE if it is combo box list
m_bCustomizable | TRUE if command bar is customizable.
m_bCustomizeDialogPresent | TRUE if the command bar is present in Customize dialog.
m_bExecOnRButton | TRUE if the control button is executed on a right-click
m_bGrabFocus | TRUE to grab current focus.
m_bIgnoreUpdateHandler | TRUE to skip update handler for all child controls
m_bKeyboardSelect | TRUE if last item was selected by keyboard.
m_bMultiLine | True if multi line commandbar
m_bRecursePopup | TRUE if popup bar was opened recursively.
m_bTextBelow | TRUE if text is shown below the CommandBar buttons.
m_bTracking | TRUE if the command bar is in tracking mode.
m_bTrackOnHover | TRUE to select item if mouse stay over control
m_buttonStyle | Default button Style
m_bVerticalMarker | TRUE to draw marker vertically.
m_bVisible | TRUE if the command bar is visible.
m_dwData | The 32-bit value associated with the command bar.
m_dwFlags | Command bar's flags.
m_dwStyle | Command bar's styles.
m_hwndFocus | The handle of the window that currently has focus.
m_nBarID | Command bar's identifier.
m_nIdleFlags | Idle flags.
m_nLockRecurse | TRUE if another popup bar is opened recursively.
m_nLockRedraw | TRUE if all drawing routines skipped
m_nMRUWidth | Recent width.
m_nPopuped | Popuped control index.
m_nSelected | Selected control index.
m_nStateFlags | State of the command bars.
m_pAnimation | Animation context
m_pCommandBars | parent command bars class.
m_pControls | A pointer to controls collection.
m_pImageManager | Selected image manager for command bar
m_pOwner | Owner window.
m_pPaintManager | Selected paint manager for command bar
m_pReturnCmd | Return command holder.
m_pSite | Command bar's site.
m_pToolTipContext | Tool tip Context.
m_rcMarker | Marker position.
m_strTitle | Command bar's caption.
m_szButtons | Size of the command bar's icons.
m_szIcons | Size of the command bar's icons.
s_nExpandDelay | Expand delay time
s_nExpandHoverDelay | Expand hover delay
s_nHoverDelay | Hover delay time
CXTPCommandBar Destructors
CXTPCommandBar Destructors | Description
~CXTPCommandBar | Destroys a CXTPCommandBar object, handles cleanup and deallocation
CXTPCommandBar Methods
CXTPCommandBar Methods | Description
CalcDynamicLayout | This method is called to get the size of the command bar.
Copy | This method makes a copy of the command bar.
CreateKeyboardTips | This method is called to create keyboard tips collection for commandbar
DelayLayout | Call this member to recalculate the layout.
DelayRedraw | Call this member to redraw the command bar.
DoPropExchange | Reads or writes this object from or to an archive.
DrawCommandBar | This method is called to draw the command bar in the given context.
EnableAnimation | Call this method to enable animation for CommandBar
EnableCustomization | Call this method to enable/disable customization of the command bar.
EnableDoubleBuffer | Call this method to enable double buffer for toolbar drawing
EnsureVisible | Call this method to be sure control is visible on toolbar
FillCommandBarEntry | This method is called to draw background of command bar
FindAccel | Call this method to get the index of control with specified accelerator character.
FindAccelEx | Call this method to get the index of the control with specified accelerator character.
GenerateCommandBarList | This method is called to assign self identifiers for serialization process.
GetActiveDocTemplate | Retrieves active MDI document template
GetBarID | Call this method to retrieve the identifier of the command bar.
GetBorders | This method is called to get borders margins of commandbar
GetButtonSize | Call this function to get the size of the command bar button.
GetCommandBarData | This method retrieves the application-supplied 32-bit value associated with the command bar.
GetCommandBars | Call this member to get the command bar's object.
GetControl | Call this member to return the control at the specified index.
GetControlCount | Call this member to get the count of the controls
GetControls | Call this member to get the controls collection.
GetDefaultButtonStyle | Call this method to retrieve default style of buttons of the commanbar
GetFlags | Call this method to retrieve the current behavior modification flags of the command bar.
GetFrameSite | Call this member to get the command bar's site as CFrameWnd.
GetIconSize | Call this member function to get the size of a toolbar icon.
GetImageManager | Call this method to retrieve the image manager
GetLargeIconSize | Call this method to get Large icon size of toolbar
GetOwnerSite | Call this method to retrieve the owner window of the command bar.
GetPaintManager | Call this method to retrieve the paint manager.
GetParentCommandBar | This method retrieves the parent command bar.
GetPosition | Call this member to get the position of the command bar.
GetRootParent | Call this method to retrieve the top-level parent command bar.
GetShowGripper | Determines if gripper is visible for the commandbar
GetSite | Call this member to get the command bar's site.
GetTextOrientation | Call this member to get text orientation.
GetTitle | Call this member to get a title for this command bar.
GetTrackFocus | Call this method to retrieve the current focused control.
GetType | Call this member to get the type of the command bar.
GetWidth | Call this member to get the width of the floated or popup toolbar.
HideKeyboardTips | Call this method to hide
InvalidateParents | Call this method to redraw all parent command bars.
IsAnimationEnabled | Determines if animation is enabled for specified command bar
IsCustomizable | Call this method to retrieve the customizable property of the command bar.
IsCustomizeMode | Call this method to retrieve the customize mode of the command bars.
IsDialogBar | Call this member function to determine if the CommandBar is a CXTPDialogBar.
IsHelpMode | Determines if parent frame in help mode
IsKeyboardCuesVisible | Determines if underlines is visible in command bar control. Return: Returns TRUE if underlines is visible; otherwise FALSE;
IsKeyboardTipsVisible | Call this method to check if keyboard tips are visible for the commandbar
IsLayoutRTL | Call this member function to determine if the CommandBar layout is Right-to-Left (RTL).
IsPopupBar | Call this member function to determine if the CommandBar is a CXTPPopupBar.
IsRibbonBar | Call this member function to determine if the CommandBar is a CXTPRibbonBar.
IsTextBelowIcons | Returns a Boolean value that indicates whether the caption is below the control's icon.
IsTrackingMode | Call this member to get the tracking state.
IsVisible | Returns a Boolean value that indicates whether the command bar is visible or hidden
LoadMenu | Call this member to convert menu items to command bar controls.
LoadToolBar | Call this member function to load the toolbar specified by nIDResource.
LockRedraw | Call this method to freeze redrawing until UnlockRedraw call
OnControlsChanged | This method is called when the controls array is changed.
OnControlSelected | This method is called when a child control becomes selected.
OnCustomizeDragEnter | This member is called when a control is entered into the command bar.
OnCustomizeDragLeave | This method is called when a control leaves the command bar.
OnCustomizeDragOver | This member is called when control is over the command bar.
OnCustomizeDrop | This method is called when control is dropped to the command bar.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnHookMessage | This member function is called by WindowProc, or is called during message reflection.
OnKeyboardTip | This method is called when keyboard tip was found for the commandbar
OnKeyboardTipChar | This method is called when user press key while keyboard tips are visible
OnMouseHitTest | This method is called to determine mouse hit code
OnRecalcLayout | This method is called to recalculate command bar layout.
OnRemoved | This method is called then toolbar removed from commandbars collection
OnTrackEnter | Call this method to track the command bar.
OnTrackLost | Call this method to remove the tracking state of the command bar.
Popup | This method is called to popup the command bar.
ProcessSpecialKey | This method is called to process special keys.
Redraw | The framework calls this member function to redraw the CommandBars.
RestoreCommandBarList | This method is called in serialization process.to restore popups from list of command bars.
SetBarID | Call this method to set the identifier.
SetButtons | Call this member to set the controls from the button array.
SetButtonSize | Sets the size of the buttons in the command bar.
SetCommandBarData | This method sets the 32-bit value associated with the command bar.
SetCommandBars | Call this member to set the command bar's object.
SetControls | This method called to set controls collection to commandbar
SetDefaultButtonStyle | Call this method to set default style for commanbar buttons.
SetFlags | Call this member to set the command bar's flags.
SetGrabFocus | This method is called internally to prevent command bar to grab edit focus.
SetIconSize | Call this function to set the size of the actual bitmapped images to be added to a toolbar.
SetImageManager | Call this member to set the specified image manager
SetPaintManager | Call this member to set the specified paint manager
SetPopuped | Call this member to popup the specified control.
SetPosition | Call this member function to set the position of the command bar
SetSelected | Call this member to select the specified control.
SetShowGripper | Call this method to show gripper for the commandbar
SetStatusText | This method is called to set the description context.
SetTextOrientation | Call this member to change text orientation.
SetTitle | Call this member to set a title for this command bar.
SetTrackFocus | Call this method to set focus to the window.
SetTrackingMode | Call this member to change the tracking state.
SetVisible | Call this method to set the visibility state of the control.
SetWidth | Call this member to set the width of the floated or popup toolbar.
ShowTextBelowIcons | Call this member to show the caption below control's icon.
UnlockRedraw | Call this method to unfreeze redrawing.
UpdateShortcuts | Updates the control's shortcuts.


CXTPCommandBar Data Members

CXTPCommandBar Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar Data Members
Class

CXTPCommandBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAnimatePopup | TRUE to animate popup bar.
m_barPosition | Position of the command bar.
m_barType | Type of the command bar.
m_bCloseable | TRUE if the CommandBar can be closed andor Hidden
m_bCustomizable | TRUE if command bar is customizable.
m_bCustomizeDialogPresent | TRUE if the command bar is present in Customize dialog.
m_bExecOnRButton | TRUE if the control button is executed on a right-click
m_bGrabFocus | TRUE to grab current focus.
m_bIgnoreUpdateHandler | TRUE to skip update handler for all child controls
m_bKeyboardSelect | TRUE if last item was selected by keyboard.
m_bMultiLine | True if multi line commandbar
m_bRecursePopup | TRUE if popup bar was opened recursively.
m_bTextBelow | TRUE if text is shown below the CommandBar buttons.
m_bTracking | TRUE if the command bar is in tracking mode.
m_buttonStyle | Default button Style
m_bVerticalMarker | TRUE to draw marker vertically.
m_bVisible | TRUE if the command bar is visible.
m_dwData | The 32-bit value associated with the command bar.
m_dwFlags | Command bar's flags.
m_dwStyle | Command bar's styles.
m_hwndFocus | The handle of the window that currently has focus.
m_nBarID | Command bar's identifier.
m_nIdleFlags | Idle flags.
m_nLockRecurse | TRUE if another popup bar is opened recursively.
m_nLockRedraw | TRUE if all drawing routines skipped
m_nMRUWidth | Recent width.
m_nPopuped | Popuped control index.
m_nSelected | Selected control index.
m_pAnimation | Animation context
m_pCommandBars | parent command bars class.
m_pControls | A pointer to controls collection.
m_pImageManager | Selected image manager for command bar
m_pOwner | Owner window.
m_pPaintManager | Selected paint manager for command bar
m_pReturnCmd | Return command holder.
m_pSite | Command bar's site.
m_pToolTipContext | Tool tip Context.
m_rcMarker | Marker position.
m_strTitle | Command bar's caption.
m_szButtons | Size of the command bar's icons.
m_szIcons | Size of the command bar's icons.
Public Data Members
Public Data Member | Description
m_bComboBar | TRUE if it is combo box list
m_bTrackOnHover | TRUE to select item if mouse stay over control
m_nStateFlags | State of the command bars.
s_nExpandDelay | Expand delay time
s_nExpandHoverDelay | Expand hover delay
s_nHoverDelay | Hover delay time


CXTPCommandBar::m_bAnimatePopup Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bAnimatePopup Data Member

TRUE to animate popup bar.

BOOL m_bAnimatePopup;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_barPosition Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_barPosition Data Member

Position of the command bar.

XTPBarPosition m_barPosition;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_barType Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_barType Data Member

Type of the command bar.

XTPBarType m_barType;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bCloseable Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bCloseable Data Member

TRUE if the CommandBar can be closed andor Hidden

BOOL m_bCloseable;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bComboBar Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bComboBar Data Member

TRUE if it is combo box list

BOOL m_bComboBar;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bCustomizable Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bCustomizable Data Member

TRUE if command bar is customizable.

BOOL m_bCustomizable;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bCustomizeDialogPresent Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bCustomizeDialogPresent Data Member

TRUE if the command bar is present in Customize dialog.

BOOL m_bCustomizeDialogPresent;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bExecOnRButton Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bExecOnRButton Data Member

TRUE if the control button is executed on a right-click

BOOL m_bExecOnRButton;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bGrabFocus Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bGrabFocus Data Member

TRUE to grab current focus.

BOOL m_bGrabFocus;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bIgnoreUpdateHandler Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bIgnoreUpdateHandler Data Member

TRUE to skip update handler for all child controls

BOOL m_bIgnoreUpdateHandler;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bKeyboardSelect Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bKeyboardSelect Data Member

TRUE if last item was selected by keyboard.

BOOL m_bKeyboardSelect;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bMultiLine Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bMultiLine Data Member

True if multi line commandbar

BOOL m_bMultiLine;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bRecursePopup Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bRecursePopup Data Member

TRUE if popup bar was opened recursively.

BOOL m_bRecursePopup;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bTextBelow Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bTextBelow Data Member

TRUE if text is shown below the CommandBar buttons.

BOOL m_bTextBelow;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bTracking Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bTracking Data Member

TRUE if the command bar is in tracking mode.

BOOL m_bTracking;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bTrackOnHover Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bTrackOnHover Data Member

TRUE to select item if mouse stay over control

BOOL m_bTrackOnHover;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_buttonStyle Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_buttonStyle Data Member

Default button Style

XTPButtonStyle m_buttonStyle;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bVerticalMarker Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bVerticalMarker Data Member

TRUE to draw marker vertically.

BOOL m_bVerticalMarker;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_bVisible Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_bVisible Data Member

TRUE if the command bar is visible.

BOOL m_bVisible;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_dwData Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_dwData Data Member

The 32-bit value associated with the command bar.

DWORD_PTR m_dwData;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_dwFlags Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_dwFlags Data Member

Command bar's flags.

DWORD m_dwFlags;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_dwStyle Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_dwStyle Data Member

Command bar's styles.

DWORD m_dwStyle;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_hwndFocus Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_hwndFocus Data Member

The handle of the window that currently has focus.

HWND m_hwndFocus;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_nBarID Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_nBarID Data Member

Command bar's identifier.

UINT m_nBarID;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_nIdleFlags Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_nIdleFlags Data Member

Idle flags.

DWORD m_nIdleFlags;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_nLockRecurse Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_nLockRecurse Data Member

TRUE if another popup bar is opened recursively.

int m_nLockRecurse;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_nLockRedraw Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_nLockRedraw Data Member

TRUE if all drawing routines skipped

BOOL m_nLockRedraw;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_nMRUWidth Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_nMRUWidth Data Member

Recent width.

int m_nMRUWidth;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_nPopuped Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_nPopuped Data Member

Popuped control index.

int m_nPopuped;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_nSelected Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_nSelected Data Member

Selected control index.

int m_nSelected;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_nStateFlags Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_nStateFlags Data Member

State of the command bars.

int m_nStateFlags;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pAnimation Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pAnimation Data Member

Animation context

CXTPCommandBarAnimation* m_pAnimation;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pCommandBars Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pCommandBars Data Member

parent command bars class.

CXTPCommandBars* m_pCommandBars;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pControls Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pControls Data Member

A pointer to controls collection.

CXTPControls* m_pControls;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pImageManager Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pImageManager Data Member

Selected image manager for command bar

CXTPImageManager* m_pImageManager;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pOwner Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pOwner Data Member

Owner window.

CWnd* m_pOwner;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pPaintManager Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pPaintManager Data Member

Selected paint manager for command bar

CXTPPaintManager* m_pPaintManager;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pReturnCmd Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pReturnCmd Data Member

Return command holder.

UINT* m_pReturnCmd;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pSite Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pSite Data Member

Command bar's site.

CWnd* m_pSite;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_pToolTipContext Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_pToolTipContext Data Member

Tool tip Context.

CXTPToolTipContext* m_pToolTipContext;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_rcMarker Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_rcMarker Data Member

Marker position.

CRect m_rcMarker;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_strTitle Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_strTitle Data Member

Command bar's caption.

CString m_strTitle;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_szButtons Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_szButtons Data Member

Size of the command bar's icons.

CSize m_szButtons;
Group

CXTPCommandBar Data Members


CXTPCommandBar::m_szIcons Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::m_szIcons Data Member

Size of the command bar's icons.

CSize m_szIcons;
Group

CXTPCommandBar Data Members


CXTPCommandBar::s_nExpandDelay Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::s_nExpandDelay Data Member

Expand delay time

int s_nExpandDelay;
Group

CXTPCommandBar Data Members


CXTPCommandBar::s_nExpandHoverDelay Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::s_nExpandHoverDelay Data Member

Expand hover delay

int s_nExpandHoverDelay;
Group

CXTPCommandBar Data Members


CXTPCommandBar::s_nHoverDelay Data Member

CXTPCommandBar Data Members, CXTPCommandBar Class
CXTPCommandBar::s_nHoverDelay Data Member

Hover delay time

int s_nHoverDelay;
Group

CXTPCommandBar Data Members


CXTPCommandBar Methods

CXTPCommandBar Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar Methods
Class

CXTPCommandBar Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalcDynamicLayout | This method is called to get the size of the command bar.
Copy | This method makes a copy of the command bar.
GenerateCommandBarList | This method is called to assign self identifiers for serialization process.
GetActiveDocTemplate | Retrieves active MDI document template
IsHelpMode | Determines if parent frame in help mode
OnControlsChanged | This method is called when the controls array is changed.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnMouseHitTest | This method is called to determine mouse hit code
OnRemoved | This method is called then toolbar removed from commandbars collection
ProcessSpecialKey | This method is called to process special keys.
RestoreCommandBarList | This method is called in serialization process.to restore popups from list of command bars.
UpdateShortcuts | Updates the control's shortcuts.
Public Methods
Public Methods
Public Method | Description
CreateKeyboardTips | This method is called to create keyboard tips collection for commandbar
DelayLayout | Call this member to recalculate the layout.
DelayRedraw | Call this member to redraw the command bar.
DoPropExchange | Reads or writes this object from or to an archive.
DrawCommandBar | This method is called to draw the command bar in the given context.
EnableAnimation | Call this method to enable animation for CommandBar
EnableCustomization | Call this method to enable/disable customization of the command bar.
EnableDoubleBuffer | Call this method to enable double buffer for toolbar drawing
EnsureVisible | Call this method to be sure control is visible on toolbar
FillCommandBarEntry | This method is called to draw background of command bar
FindAccel | Call this method to get the index of control with specified accelerator character.
FindAccelEx | Call this method to get the index of the control with specified accelerator character.
GetBarID | Call this method to retrieve the identifier of the command bar.
GetBorders | This method is called to get borders margins of commandbar
GetButtonSize | Call this function to get the size of the command bar button.
GetCommandBarData | This method retrieves the application-supplied 32-bit value associated with the command bar.
GetCommandBars | Call this member to get the command bar's object.
GetControl | Call this member to return the control at the specified index.
GetControlCount | Call this member to get the count of the controls
GetControls | Call this member to get the controls collection.
GetDefaultButtonStyle | Call this method to retrieve default style of buttons of the commanbar
GetFlags | Call this method to retrieve the current behavior modification flags of the command bar.
GetFrameSite | Call this member to get the command bar's site as CFrameWnd.
GetIconSize | Call this member function to get the size of a toolbar icon.
GetImageManager | Call this method to retrieve the image manager
GetLargeIconSize | Call this method to get Large icon size of toolbar
GetOwnerSite | Call this method to retrieve the owner window of the command bar.
GetPaintManager | Call this method to retrieve the paint manager.
GetParentCommandBar | This method retrieves the parent command bar.
GetPosition | Call this member to get the position of the command bar.
GetRootParent | Call this method to retrieve the top-level parent command bar.
GetShowGripper | Determines if gripper is visible for the commandbar
GetSite | Call this member to get the command bar's site.
GetTextOrientation | Call this member to get text orientation.
GetTitle | Call this member to get a title for this command bar.
GetTrackFocus | Call this method to retrieve the current focused control.
GetType | Call this member to get the type of the command bar.
GetWidth | Call this member to get the width of the floated or popup toolbar.
HideKeyboardTips | Call this method to hide
InvalidateParents | Call this method to redraw all parent command bars.
IsAnimationEnabled | Determines if animation is enabled for specified command bar
IsCustomizable | Call this method to retrieve the customizable property of the command bar.
IsCustomizeMode | Call this method to retrieve the customize mode of the command bars.
IsDialogBar | Call this member function to determine if the CommandBar is a CXTPDialogBar.
IsKeyboardCuesVisible | Determines if underlines is visible in command bar control. Return: Returns TRUE if underlines is visible; otherwise FALSE;
IsKeyboardTipsVisible | Call this method to check if keyboard tips are visible for the commandbar
IsLayoutRTL | Call this member function to determine if the CommandBar layout is Right-to-Left (RTL).
IsPopupBar | Call this member function to determine if the CommandBar is a CXTPPopupBar.
IsRibbonBar | Call this member function to determine if the CommandBar is a CXTPRibbonBar.
IsTextBelowIcons | Returns a Boolean value that indicates whether the caption is below the control's icon.
IsTrackingMode | Call this member to get the tracking state.
IsVisible | Returns a Boolean value that indicates whether the command bar is visible or hidden
LoadMenu | Call this member to convert menu items to command bar controls.
LoadToolBar | Call this member function to load the toolbar specified by nIDResource.
LockRedraw | Call this method to freeze redrawing until UnlockRedraw call
OnControlSelected | This method is called when a child control becomes selected.
OnCustomizeDragEnter | This member is called when a control is entered into the command bar.
OnCustomizeDragLeave | This method is called when a control leaves the command bar.
OnCustomizeDragOver | This member is called when control is over the command bar.
OnCustomizeDrop | This method is called when control is dropped to the command bar.
OnHookMessage | This member function is called by WindowProc, or is called during message reflection.
OnKeyboardTip | This method is called when keyboard tip was found for the commandbar
OnKeyboardTipChar | This method is called when user press key while keyboard tips are visible
OnRecalcLayout | This method is called to recalculate command bar layout.
OnTrackEnter | Call this method to track the command bar.
OnTrackLost | Call this method to remove the tracking state of the command bar.
Popup | This method is called to popup the command bar.
Redraw | The framework calls this member function to redraw the CommandBars.
SetBarID | Call this method to set the identifier.
SetButtons | Call this member to set the controls from the button array.
SetButtonSize | Sets the size of the buttons in the command bar.
SetCommandBarData | This method sets the 32-bit value associated with the command bar.
SetCommandBars | Call this member to set the command bar's object.
SetControls | This method called to set controls collection to commandbar
SetDefaultButtonStyle | Call this method to set default style for commanbar buttons.
SetFlags | Call this member to set the command bar's flags.
SetGrabFocus | This method is called internally to prevent command bar to grab edit focus.
SetIconSize | Call this function to set the size of the actual bitmapped images to be added to a toolbar.
SetImageManager | Call this member to set the specified image manager
SetPaintManager | Call this member to set the specified paint manager
SetPopuped | Call this member to popup the specified control.
SetPosition | Call this member function to set the position of the command bar
SetSelected | Call this member to select the specified control.
SetShowGripper | Call this method to show gripper for the commandbar
SetStatusText | This method is called to set the description context.
SetTextOrientation | Call this member to change text orientation.
SetTitle | Call this member to set a title for this command bar.
SetTrackFocus | Call this method to set focus to the window.
SetTrackingMode | Call this member to change the tracking state.
SetVisible | Call this method to set the visibility state of the control.
SetWidth | Call this member to set the width of the floated or popup toolbar.
ShowTextBelowIcons | Call this member to show the caption below control's icon.
UnlockRedraw | Call this method to unfreeze redrawing.


CXTPCommandBar::CalcDynamicLayout Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::CalcDynamicLayout Method

This method is called to get the size of the command bar.

virtual CSize CalcDynamicLayout(
    int nLength,
    DWORD dwMode
);
Parameters

nLength
The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode
see CControlBar::CalcDynamicLayout for list of supported flags.

Returns

Size of the command bar.

Body Source
CSize CXTPCommandBar::CalcDynamicLayout(int, DWORD /*nMode*/) {
    return CSize(0, 0);
}
Group

CXTPCommandBar Methods


CXTPCommandBar::Copy Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::Copy Method

This method makes a copy of the command bar.

virtual void Copy(
    CXTPCommandBar* pCommandBar,
    BOOL bRecursive = FALSE
);
Parameters

pCommandBar
Command bar needed to be copied.
bRecursive
TRUE to copy recursively.

Group

CXTPCommandBar Methods


CXTPCommandBar::CreateKeyboardTips Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::CreateKeyboardTips Method

This method is called to create keyboard tips collection for commandbar

virtual void CreateKeyboardTips();
See Also

IsKeyboardTipsVisible

Group

CXTPCommandBar Methods


CXTPCommandBar::DelayLayout Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::DelayLayout Method

Call this member to recalculate the layout.

void DelayLayout();
Body Source
void CXTPCommandBar::DelayLayout() {
    m_nIdleFlags |= xtpIdleLayout;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::DelayRedraw Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::DelayRedraw Method

Call this member to redraw the command bar.

virtual void DelayRedraw();
Body Source
void CXTPCommandBar::DelayRedraw() {
    m_nIdleFlags |= xtpIdleRedraw;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::DoPropExchange Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPCommandBar Methods


CXTPCommandBar::DrawCommandBar Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::DrawCommandBar Method

This method is called to draw the command bar in the given context.

virtual void DrawCommandBar(
    CDC* pDC,
    CRect rcClipBox
);
Parameters

pDC
Pointer to a valid device context
rcClipBox
The rectangular area of the control that is invalid

Group

CXTPCommandBar Methods


CXTPCommandBar::EnableAnimation Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::EnableAnimation Method

Call this method to enable animation for CommandBar

void EnableAnimation(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable animation; FALSE to disable

Group

CXTPCommandBar Methods


CXTPCommandBar::EnableCustomization Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::EnableCustomization Method

Call this method to enable/disable customization of the command bar.

void EnableCustomization(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable customization.

Body Source
void CXTPCommandBar::EnableCustomization(BOOL bEnable) {
    if (!IsDialogBar()) m_bCustomizable = bEnable;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::EnableDoubleBuffer Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::EnableDoubleBuffer Method

Call this method to enable double buffer for toolbar drawing

void EnableDoubleBuffer(
    BOOL bEnable = TRUE
);
Parameters

bEnable
True to enable double buffer for drawing.

See Also

EnableAnimation

Group

CXTPCommandBar Methods


CXTPCommandBar::EnsureVisible Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::EnsureVisible Method

Call this method to be sure control is visible on toolbar

virtual void EnsureVisible(
    CXTPControl* pControl
);
Parameters

pControl
CXTPControl child that need to check

Group

CXTPCommandBar Methods


CXTPCommandBar::FillCommandBarEntry Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::FillCommandBarEntry Method

This method is called to draw background of command bar

virtual void FillCommandBarEntry(
    CDC* pDC
);
Parameters

pDC
POinter to device context to draw

See Also

DrawCommandBar

Group

CXTPCommandBar Methods


CXTPCommandBar::FindAccel Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::FindAccel Method

Call this method to get the index of control with specified accelerator character.

int FindAccel(
    TCHAR chAccel
) const;
Parameters

chAccel
Character to find.

Returns

Index of the control contained character as accelerator.

Group

CXTPCommandBar Methods


CXTPCommandBar::FindAccelEx Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::FindAccelEx Method

Call this method to get the index of the control with specified accelerator character.

int FindAccelEx(
    UINT chAccel,
    BOOL& bSelectOnly
) const;
Parameters

chAccel
Character to find
bSelectOnly
TRUE to select only.

Returns

Index of the control contained character as accelerator.

Group

CXTPCommandBar Methods


CXTPCommandBar::GenerateCommandBarList Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GenerateCommandBarList Method

This method is called to assign self identifiers for serialization process.

virtual void GenerateCommandBarList(
    DWORD& nID,
    CXTPCommandBarList* pCommandBarList,
    XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam
);
Parameters

nID
Identifier to assign
pCommandBarList
List of CommandBars.
pParam
Address of a XTP_COMMANDBARS_PROPEXCHANGE_PARAM structure.

Group

CXTPCommandBar Methods


CXTPCommandBar::GetActiveDocTemplate Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::GetActiveDocTemplate Method

Retrieves active MDI document template

UINT GetActiveDocTemplate() const;
Returns

Active document template identifier.

Remarks

This method call CXTPCommandBars::GetActiveDocTemplate.

See Also

CXTPCommandBars::GetActiveDocTemplate

Group

CXTPCommandBar Methods


CXTPCommandBar::GetBarID Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::GetBarID Method

Call this method to retrieve the identifier of the command bar.

UINT GetBarID() const;
Returns

Identifier of the command bar.

Body Source
UINT CXTPCommandBar::GetBarID() const {
    return m_nBarID;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetBorders Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetBorders Method

This method is called to get borders margins of commandbar

virtual CRect GetBorders();
Returns

Rectangle contains border margins

Group

CXTPCommandBar Methods


CXTPCommandBar::GetButtonSize Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetButtonSize Method

Call this function to get the size of the command bar button.

virtual CSize GetButtonSize() const;
Returns

The width and height values of the command bar button.

Group

CXTPCommandBar Methods


CXTPCommandBar::GetCommandBarData Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::GetCommandBarData Method

This method retrieves the application-supplied 32-bit value associated with the command bar.

DWORD_PTR GetCommandBarData() const;
Returns

The 32-bit value associated with the command bar.

See Also

SetCommandBarData

Body Source
DWORD_PTR CXTPCommandBar::GetCommandBarData() const {
    return m_dwData;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetCommandBars Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetCommandBars Method

Call this member to get the command bar's object.

CXTPCommandBars* GetCommandBars() const;
Returns

A CXTPCommandBars pointer (can be NULL).

Group

CXTPCommandBar Methods


CXTPCommandBar::GetControl Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::GetControl Method

Call this member to return the control at the specified index.

CXTPControl* GetControl(
    int nIndex
) const;
Parameters

nIndex
An integer index.

Returns

The CXTPControl pointer currently at this index.

See Also

GetControls, CXTPControls::GetAt

Group

CXTPCommandBar Methods


CXTPCommandBar::GetControlCount Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetControlCount Method

Call this member to get the count of the controls

int GetControlCount() const;
Returns

The count of the controls.

Group

CXTPCommandBar Methods


CXTPCommandBar::GetControls Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::GetControls Method

Call this member to get the controls collection.

CXTPControls* GetControls() const;
Returns

A CXTPControls pointer.

Body Source
CXTPControls* CXTPCommandBar::GetControls() const {
    return m_pControls;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetDefaultButtonStyle Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::GetDefaultButtonStyle Method

Call this method to retrieve default style of buttons of the commanbar

XTPButtonStyle GetDefaultButtonStyle() const;
Returns

XTPButtonStyle represents default style of buttons

See Also

SetDefaultButtonStyle

Body Source
XTPButtonStyle CXTPCommandBar::GetDefaultButtonStyle() const {
    return m_buttonStyle;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetFlags Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::GetFlags Method

Call this method to retrieve the current behavior modification flags of the command bar.

DWORD GetFlags() const;
Returns

Flags of the command bar that are currently in effect.

Body Source
DWORD CXTPCommandBar::GetFlags() const {
    return m_dwFlags;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetFrameSite Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetFrameSite Method

Call this member to get the command bar's site as CFrameWnd.

CFrameWnd* GetFrameSite() const;
Returns

The command bar's site (can be NULL).

Group

CXTPCommandBar Methods


CXTPCommandBar::GetIconSize Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::GetIconSize Method

Call this member function to get the size of a toolbar icon.

virtual CSize GetIconSize() const;
See Also

GetLargeIconSize

Group

CXTPCommandBar Methods


CXTPCommandBar::GetImageManager Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetImageManager Method

Call this method to retrieve the image manager

CXTPImageManager* GetImageManager() const;
Returns

A pointer to a CXTPImageManager object

Group

CXTPCommandBar Methods


CXTPCommandBar::GetLargeIconSize Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::GetLargeIconSize Method

Call this method to get Large icon size of toolbar

CSize GetLargeIconSize(
    BOOL bAutoSize
) const;
Parameters

bAutoSize
TRUE to adjust size using current DPI mode.

Returns

CSize value contained size of large toolbar icons.

See Also

GetIconSize

Group

CXTPCommandBar Methods


CXTPCommandBar::GetOwnerSite Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetOwnerSite Method

Call this method to retrieve the owner window of the command bar.

CWnd* GetOwnerSite() const;
Returns

A pointer to a CWnd object

Group

CXTPCommandBar Methods


CXTPCommandBar::GetPaintManager Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetPaintManager Method

Call this method to retrieve the paint manager.

CXTPPaintManager* GetPaintManager() const;
Returns

A pointer to a CXTPPaintManager object

Group

CXTPCommandBar Methods


CXTPCommandBar::GetParentCommandBar Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::GetParentCommandBar Method

This method retrieves the parent command bar.

virtual CXTPCommandBar* GetParentCommandBar() const;
Returns

A pointer to a CXTPCommandBar object

Body Source
CXTPCommandBar* CXTPCommandBar::GetParentCommandBar() const {
    return NULL;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetPosition Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::GetPosition Method

Call this member to get the position of the command bar.

XTPBarPosition GetPosition() const;
Returns

The position of the command bar.

See Also

XTPBarPosition, GetType

Body Source
XTPBarPosition CXTPCommandBar::GetPosition() const {
    return m_barPosition;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetRootParent Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetRootParent Method

Call this method to retrieve the top-level parent command bar.

CXTPCommandBar* GetRootParent() const;
Returns

A pointer to the top-level CXTPCommandBar object

Group

CXTPCommandBar Methods


CXTPCommandBar::GetShowGripper Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::GetShowGripper Method

Determines if gripper is visible for the commandbar

BOOL GetShowGripper() const;
Returns

TRUE if gripper is visible

See Also

SetShowGripper

Group

CXTPCommandBar Methods


CXTPCommandBar::GetSite Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetSite Method

Call this member to get the command bar's site.

CWnd* GetSite() const;
Returns

Command bar's site (cannot be NULL).

Group

CXTPCommandBar Methods


CXTPCommandBar::GetTextOrientation Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::GetTextOrientation Method

Call this member to get text orientation.

XTPBarTextOrientation GetTextOrientation() const;
Body Source
XTPBarTextOrientation CXTPCommandBar::GetTextOrientation() const {
    return m_nTextOrientation;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetTitle Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::GetTitle Method

Call this member to get a title for this command bar.

CString GetTitle() const;
Returns

The title of the command bar.

Body Source
CString CXTPCommandBar::GetTitle() const {
    return m_strTitle;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetTrackFocus Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::GetTrackFocus Method

Call this method to retrieve the current focused control.

HWND GetTrackFocus() const;
Returns

Window handle of the focused control.

Body Source
HWND CXTPCommandBar::GetTrackFocus() const {
    return m_hwndFocus;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetType Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::GetType Method

Call this member to get the type of the command bar.

XTPBarType GetType() const;
Returns

The type of the command bar. It can be one of the following:

  • xtpBarTypeMenuBar Indicates the command bar is menu bar (CXTPMenuBar)
  • xtpBarTypeNormal Indicates the command bar is simple toolbar (CXTPToolBar)
  • xtpBarTypePopup Indicates the command bar is popupbar (CXTPPopupBar)
See Also

XTPBarType, GetPosition

Body Source
XTPBarType CXTPCommandBar::GetType() const {
    return m_barType;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::GetWidth Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::GetWidth Method

Call this member to get the width of the floated or popup toolbar.

int GetWidth() const;
Returns

The width, in pixels, of the floated or popup toolbar.

Group

CXTPCommandBar Methods


CXTPCommandBar::HideKeyboardTips Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::HideKeyboardTips Method

Call this method to hide

void HideKeyboardTips();
See Also

IsKeyboardTipsVisible

Group

CXTPCommandBar Methods


CXTPCommandBar::InvalidateParents Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::InvalidateParents Method

Call this method to redraw all parent command bars.

void InvalidateParents();
Group

CXTPCommandBar Methods


CXTPCommandBar::IsAnimationEnabled Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::IsAnimationEnabled Method

Determines if animation is enabled for specified command bar

BOOL IsAnimationEnabled() const;
Returns

TRUE if animation is enabled

See Also

EnableAnimation

Group

CXTPCommandBar Methods


CXTPCommandBar::IsCustomizable Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::IsCustomizable Method

Call this method to retrieve the customizable property of the command bar.

virtual BOOL IsCustomizable() const;
Returns

TRUE if the command bar is customizable; otherwise returns FALSE

Body Source
BOOL CXTPCommandBar::IsCustomizable() const{
    return m_bCustomizable;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::IsCustomizeMode Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::IsCustomizeMode Method

Call this method to retrieve the customize mode of the command bars.

BOOL IsCustomizeMode() const;
Returns

TRUE if command bars are in customized mode; otherwise returns FALSE

Group

CXTPCommandBar Methods


CXTPCommandBar::IsDialogBar Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::IsDialogBar Method

Call this member function to determine if the CommandBar is a CXTPDialogBar.

virtual BOOL IsDialogBar() const;
Returns

Returns TRUE if the CommandBar is a CXTPDialogBar, otherwise FALSE

See Also

CXTPToolBar, CXTPDialogBar

Body Source
BOOL CXTPCommandBar::IsDialogBar() const {
    return FALSE;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::IsHelpMode Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::IsHelpMode Method

Determines if parent frame in help mode

BOOL IsHelpMode() const;
Group

CXTPCommandBar Methods


CXTPCommandBar::IsKeyboardCuesVisible Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::IsKeyboardCuesVisible Method

Determines if underlines is visible in command bar control. Return: Returns TRUE if underlines is visible; otherwise FALSE;

virtual BOOL IsKeyboardCuesVisible() const;
Group

CXTPCommandBar Methods


CXTPCommandBar::IsKeyboardTipsVisible Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::IsKeyboardTipsVisible Method

Call this method to check if keyboard tips are visible for the commandbar

BOOL IsKeyboardTipsVisible() const;
Returns

TRUE if keyboard tips are visible

See Also

CreateKeyboardTips

Group

CXTPCommandBar Methods


CXTPCommandBar::IsLayoutRTL Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::IsLayoutRTL Method

Call this member function to determine if the CommandBar layout is Right-to-Left (RTL).

BOOL IsLayoutRTL() const;
Returns

Returns TRUE if the Commandbar layout is RTL, otherwise FALSE.

Group

CXTPCommandBar Methods


CXTPCommandBar::IsPopupBar Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::IsPopupBar Method

Call this member function to determine if the CommandBar is a CXTPPopupBar.

virtual BOOL IsPopupBar() const;
Returns

Returns TRUE if the CommandBar is a CXTPPopupBar, otherwise FALSE

See Also

CXTPCommandBar, CXTPPopupBar

Body Source
BOOL CXTPCommandBar::IsPopupBar() const {
    return FALSE;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::IsRibbonBar Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::IsRibbonBar Method

Call this member function to determine if the CommandBar is a CXTPRibbonBar.

virtual BOOL IsRibbonBar() const;
Returns

Returns TRUE if the CommandBar is a CXTPRibbonBar, otherwise FALSE

See Also

CXTPCommandBar, CXTPRibbonBar

Body Source
BOOL CXTPCommandBar::IsRibbonBar() const {
    return FALSE;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::IsTextBelowIcons Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::IsTextBelowIcons Method

Returns a Boolean value that indicates whether the caption is below the control's icon.

BOOL IsTextBelowIcons() const;
Returns

TRUE if successful, otherwise returns FALSE

Group

CXTPCommandBar Methods


CXTPCommandBar::IsTrackingMode Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::IsTrackingMode Method

Call this member to get the tracking state.

int IsTrackingMode() const;
Returns

TRUE if the command bar is in the tracking mode.

Body Source
int CXTPCommandBar::IsTrackingMode() const{
    return m_bTracking;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::IsVisible Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::IsVisible Method

Returns a Boolean value that indicates whether the command bar is visible or hidden

virtual BOOL IsVisible() const;
Returns

TRUE if successful; otherwise returns FALSE

Body Source
BOOL CXTPCommandBar::IsVisible() const {
    return FALSE;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::LoadMenu Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::LoadMenu Method

Call this member to convert menu items to command bar controls.

virtual BOOL LoadMenu(
    CMenu* pMenu,
    BOOL bRemoveControls = TRUE
);
Parameters

pMenu
Menu to be converted.
bRemoveControls
TRUE to remove all controls first.

Returns

TRUE if the method was successful; otherwise FALSE.

Group

CXTPCommandBar Methods


CXTPCommandBar::LoadToolBar Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::LoadToolBar Method

Call this member function to load the toolbar specified by nIDResource.

virtual BOOL LoadToolBar(
    UINT nIDResource,
    BOOL bLoadIcons = TRUE
);
Parameters

nIDResource
Resource ID of the toolbar to be loaded.
bLoadIcons
TRUE if the toolbar icons are to be used by CXTPImageManager.

Returns

Nonzero if successful; otherwise 0.

See Also

LoadMenu, SetButtons.

Group

CXTPCommandBar Methods


CXTPCommandBar::LockRedraw Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::LockRedraw Method

Call this method to freeze redrawing until UnlockRedraw call

void LockRedraw();
See Also

UnlockRedraw

Body Source
void CXTPCommandBar::LockRedraw() {
    m_nLockRedraw ++;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::OnControlsChanged Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnControlsChanged Method

This method is called when the controls array is changed.

virtual void OnControlsChanged();
Group

CXTPCommandBar Methods


CXTPCommandBar::OnControlSelected Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnControlSelected Method

This method is called when a child control becomes selected.

virtual void OnControlSelected(
    BOOL bSelected,
    CXTPControl* pControl
);
Parameters

bSelected
TRUE when control becomes selected.
pControl
Points to a CXTPControl object

Group

CXTPCommandBar Methods


CXTPCommandBar::OnCustomizeDragEnter Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnCustomizeDragEnter Method

This member is called when a control is entered into the command bar.

virtual DROPEFFECT OnCustomizeDragEnter(
    CXTPControl* pDataObject,
    CPoint point
);
Parameters

pDataObject
Points to a CXTPControl object
point
Point to test.

Returns

DROPEFFECT enumerator.

Group

CXTPCommandBar Methods


CXTPCommandBar::OnCustomizeDragLeave Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnCustomizeDragLeave Method

This method is called when a control leaves the command bar.

virtual void OnCustomizeDragLeave();
Group

CXTPCommandBar Methods


CXTPCommandBar::OnCustomizeDragOver Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnCustomizeDragOver Method

This member is called when control is over the command bar.

virtual DROPEFFECT OnCustomizeDragOver(
    CXTPControl* pDataObject,
    CPoint point
);
Parameters

pDataObject
Points to a CXTPControl object
point
Point to test

Returns

DROPEFFECT enumerator.

Group

CXTPCommandBar Methods


CXTPCommandBar::OnCustomizeDrop Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnCustomizeDrop Method

This method is called when control is dropped to the command bar.

virtual void OnCustomizeDrop(
    CXTPControl* pDataObject,
    DROPEFFECT& dropEffect,
    CPoint ptDrop,
    CPoint ptDrag
);
Parameters

pDataObject
Points to a CXTPControl object
dropEffect
DROPEFFECT enumerator.
ptDrop
Point where user drops the control.
ptDrag
Point where user starts drag the control.

Group

CXTPCommandBar Methods


CXTPCommandBar::OnHookKeyDown Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnHookKeyDown Method

The framework calls this member function when a non-system key is pressed.

virtual BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE

Group

CXTPCommandBar Methods


CXTPCommandBar::OnHookMessage Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnHookMessage Method

This member function is called by WindowProc, or is called during message reflection.

virtual int OnHookMessage(
    HWND hWnd,
    UINT nMessage,
    WPARAM& wParam,
    LPARAM& lParam,
    LRESULT& lResult
);
Parameters

hWnd
Window handle message belongs to.
nMessage
Specifies the message to be sent.
wParam
Specifies additional message-dependent information.
lParam
Specifies additional message-dependent information.
lResult
The return value of WindowProc. Depends on the message; may be NULL.

Group

CXTPCommandBar Methods


CXTPCommandBar::OnKeyboardTip Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::OnKeyboardTip Method

This method is called when keyboard tip was found for the commandbar

virtual void OnKeyboardTip(
    CXTPCommandBarKeyboardTip* pTip
);
Parameters

pTip
Keyboard tip was found for commandbar

See Also

OnKeyboardTipChar

Group

CXTPCommandBar Methods


CXTPCommandBar::OnKeyboardTipChar Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::OnKeyboardTipChar Method

This method is called when user press key while keyboard tips are visible

void OnKeyboardTipChar(
    UINT chAccel
);
Parameters

chAccel
Virtual key

See Also

OnKeyboardTip

Group

CXTPCommandBar Methods


CXTPCommandBar::OnMouseHitTest Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnMouseHitTest Method

This method is called to determine mouse hit code

virtual int OnMouseHitTest(
    CPoint pt
);
Parameters

pt
Position to test

Returns

HTCLIENT if pointer belongs client area; HTNOWHERE otherwise.

Group

CXTPCommandBar Methods


CXTPCommandBar::OnRecalcLayout Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::OnRecalcLayout Method

This method is called to recalculate command bar layout.

virtual void OnRecalcLayout();
Body Source
void CXTPCommandBar::OnRecalcLayout() {

}
Group

CXTPCommandBar Methods


CXTPCommandBar::OnRemoved Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnRemoved Method

This method is called then toolbar removed from commandbars collection

virtual void OnRemoved();
Group

CXTPCommandBar Methods


CXTPCommandBar::OnTrackEnter Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnTrackEnter Method

Call this method to track the command bar.

virtual void OnTrackEnter();
Group

CXTPCommandBar Methods


CXTPCommandBar::OnTrackLost Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::OnTrackLost Method

Call this method to remove the tracking state of the command bar.

virtual void OnTrackLost();
Group

CXTPCommandBar Methods


CXTPCommandBar::Popup Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::Popup Method

This method is called to popup the command bar.

virtual BOOL Popup(
    CXTPControlPopup* pControlPopup,
    BOOL bSelectFirst = FALSE
);
Parameters

pControlPopup
Points to a CXTPControlPopup object.
bSelectFirst
TRUE to select the first item.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPCommandBar Methods


CXTPCommandBar::ProcessSpecialKey Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::ProcessSpecialKey Method

This method is called to process special keys.

virtual BOOL ProcessSpecialKey(
    XTPSpecialKey key
);
Parameters

key
Special keys enumerator. Can be any of the values listed in the Remarks section.

Returns

TRUE if key handled, otherwise returns FALSE

Remarks

CXTPCommandBar maps key passed as parameter of OnKeyDown to XTPSpecialKey enumerator and call ProcessSpecialKey.

key parameter can be one of the following:

  • xtpKeyNext Indicates the RIGHT or DOWN key was pressed Next control must be selected
  • xtpKeyPrev Indicates the LEFT or UP key was pressed. Previous control must be selected.
  • xtpKeyBack Indicates the LEFT key was pressed for popup bar. Current submenu must be closed
  • xtpKeyPopup Indicates the RIGHT key was pressed for popup bar. Submenu must be opened.
  • xtpKeyEscape Indicates the ESCAPE key was pressed.
  • xtpKeyReturn Indicates the RETURN key was pressed
  • xtpKeyHome Indicates the HOME key was pressed. First control must be selected.
  • xtpKeyEnd Indicates the END key was pressed. Last control must be selected.
Group

CXTPCommandBar Methods


CXTPCommandBar::Redraw Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::Redraw Method

The framework calls this member function to redraw the CommandBars.

virtual void Redraw(
    LPCRECT lpRect = 0,
    BOOL bAnimate = TRUE
);
Parameters

lpRect
The rectangular area of the bar that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Group

CXTPCommandBar Methods


CXTPCommandBar::RestoreCommandBarList Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::RestoreCommandBarList Method

This method is called in serialization process.to restore popups from list of command bars.

virtual void RestoreCommandBarList(
    CXTPCommandBarList* pCommandBarList
);
Parameters

pCommandBarList
List of CommandBars.

Group

CXTPCommandBar Methods


CXTPCommandBar::SetBarID Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetBarID Method

Call this method to set the identifier.

void SetBarID(
    UINT nID
);
Parameters

nID
Identifier to set.

Body Source
void CXTPCommandBar::SetBarID(UINT nID) {
    m_nBarID = nID;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetButtons Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::SetButtons Method

Call this member to set the controls from the button array.

BOOL SetButtons(
    UINT* pButtons,
    int nCount
);
Parameters

pButtons
Pointer to an array of command Ids. It cannot be NULL.
nCount
Number of elements in the array pointed to by pButtons.

Returns

Nonzero if successful; otherwise 0.

See Also

LoadToolBar, LoadMenu.

Group

CXTPCommandBar Methods


CXTPCommandBar::SetButtonSize Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetButtonSize Method

Sets the size of the buttons in the command bar.

void SetButtonSize(
    CSize size
);
Parameters

size
Width and height, in pixels, of the buttons.

Remarks

The button size must always be at least as large as the bitmap size it encloses. This function must be called only before adding any bitmaps to the command bar. If the application does not explicitly set the button size, it is set to the default size.

Body Source
void CXTPCommandBar::SetButtonSize(CSize size) {
    m_szButtons = size;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetCommandBarData Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::SetCommandBarData Method

This method sets the 32-bit value associated with the command bar.

void SetCommandBarData(
    DWORD_PTR dwData
);
Parameters

dwData
Contains the new value to associate with the command bar.

See Also

GetCommandBarData

Body Source
void CXTPCommandBar::SetCommandBarData(DWORD_PTR dwData) {
    m_dwData = dwData;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetCommandBars Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetCommandBars Method

Call this member to set the command bar's object.

void SetCommandBars(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
CXTPCommandBars to be set.

Body Source
void CXTPCommandBar::SetCommandBars(CXTPCommandBars* pCommandBars){
    m_pCommandBars = pCommandBars;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetControls Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::SetControls Method

This method called to set controls collection to commandbar

void SetControls(
    CXTPControls* pControls
);
Parameters

pControls
New controls to be set

See Also

GetControls

Group

CXTPCommandBar Methods


CXTPCommandBar::SetDefaultButtonStyle Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::SetDefaultButtonStyle Method

Call this method to set default style for commanbar buttons.

void SetDefaultButtonStyle(
    XTPButtonStyle buttonStyle
);
Parameters

buttonStyle
Button style to set

See Also

GetDefaultButtonStyle

Body Source
void CXTPCommandBar::SetDefaultButtonStyle(XTPButtonStyle buttonStyle) {
    m_buttonStyle = buttonStyle;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetFlags Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::SetFlags Method

Call this member to set the command bar's flags.

void SetFlags(
    DWORD dwFlagsAdd,
    DWORD dwFlagsRemove = 0
);
Parameters

dwFlagsAdd
Flags to be added.
dwFlagsRemove
Flags to be removed.

Remarks

dwFlagsAdd and dwFlagsRemove can be combination of XTPToolBarFlags and XTPMenuBarFlags

Use the bitwise-OR (|) operator to combine the flags.

  • xtpFlagAlignTop - Allows docking at the top of the client area.
  • xtpFlagAlignBottom - Allows docking at the bottom of the client area.
  • xtpFlagAlignLeft - Allows docking on the left side of the client area.
  • xtpFlagAlignRight - Allows docking on the left side of the client area.
  • xtpFlagAlignAny - Allows docking on any side of the client area.
  • xtpFlagFloating - Allows floating.
  • xtpFlagHideWrap - Allow to hide wrapped controls.
  • xtpFlagStretched - Bar is stretched.
  • xtpFlagStretchedShared - Bar is stretched, but not fill whole row
  • xtpFlagSmartLayout - Smart layout is enabled

  • xtpFlagHideMinimizeBox - To hide minimize box.
  • xtpFlagHideMaximizeBox - To hide maximize box.
  • xtpFlagIgnoreSetMenuMessage - To ignore MDI menus.
  • xtpFlagHideClose - To hide close button.
  • xtpFlagHideMDIButtons - Specifies to hide all MDI buttons displayed on the Command Bar.
  • xtpFlagAddMDISysPopup - To add system MDI popup bar. Specifies to add system MDI popup menu to the Menu Bar. This will appears as an icon to the far left of the Menu Bar and will display the MDI menu bar options when clicked.
See Also

XTPMenuBarFlags, XTPToolBarFlags

Group

CXTPCommandBar Methods


CXTPCommandBar::SetGrabFocus Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetGrabFocus Method

This method is called internally to prevent command bar to grab edit focus.

void SetGrabFocus(
    BOOL bGrabFocus
);
Parameters

bGrabFocus
FALSE to prevent grab focus.

Body Source
void CXTPCommandBar::SetGrabFocus(BOOL bGrabFocus) {
    m_bGrabFocus = bGrabFocus;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetIconSize Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetIconSize Method

Call this function to set the size of the actual bitmapped images to be added to a toolbar.

void SetIconSize(
    CSize size
);
Parameters

size
Width and height, in pixels, of the toolbar's icons.

Body Source
void CXTPCommandBar::SetIconSize(CSize size) {
    m_szIcons = size;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetImageManager Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::SetImageManager Method

Call this member to set the specified image manager

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Points to a CXTPImageManager object to be set

Group

CXTPCommandBar Methods


CXTPCommandBar::SetPaintManager Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::SetPaintManager Method

Call this member to set the specified paint manager

void SetPaintManager(
    CXTPPaintManager* pPaintManager
);
Parameters

pPaintManager
Points to a CXTPPaintManager object to be set

Group

CXTPCommandBar Methods


CXTPCommandBar::SetPopuped Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::SetPopuped Method

Call this member to popup the specified control.

BOOL SetPopuped(
    int nPopuped,
    BOOL bKeyboard = FALSE
);
Parameters

nPopuped
An integer index of the item to be popped.
bKeyboard
TRUE if the item is popped by the keyboard.

Returns

TRUE if the method was successful; otherwise FALSE.

Group

CXTPCommandBar Methods


CXTPCommandBar::SetPosition Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetPosition Method

Call this member function to set the position of the command bar

virtual BOOL SetPosition(
    XTPBarPosition barPosition
);
Parameters

barPosition
Position of the command bar

Returns

TRUE if successful; otherwise returns FALSE

Body Source
BOOL CXTPCommandBar::SetPosition(XTPBarPosition /*barPosition*/) {
    return FALSE;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetSelected Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::SetSelected Method

Call this member to select the specified control.

virtual BOOL SetSelected(
    int nSelected,
    BOOL bKeyboard = FALSE
);
Parameters

nSelected
An integer index of the item to be selected.
bKeyboard
TRUE if the item was selected using the keyboard.

Returns

TRUE if the method was successful; otherwise FALSE.

Group

CXTPCommandBar Methods


CXTPCommandBar::SetShowGripper Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::SetShowGripper Method

Call this method to show gripper for the commandbar

void SetShowGripper(
    BOOL bShow
);
Parameters

bShow
TRUE to show; FALSE to hide

See Also

GetShowGripper

Group

CXTPCommandBar Methods


CXTPCommandBar::SetStatusText Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::SetStatusText Method

This method is called to set the description context.

BOOL SetStatusText(
    const CString& strDescription
);
Parameters

strDescription
Description string.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPCommandBar Methods


CXTPCommandBar::SetTextOrientation Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetTextOrientation Method

Call this member to change text orientation.

void SetTextOrientation(
    XTPBarTextOrientation nTextOrientation
);
Parameters

nTextOrientation
xtpBarTextHorizontal to draw text horizontal and xtpBarTextVertical to draw text vertical.

Body Source
void CXTPCommandBar::SetTextOrientation(XTPBarTextOrientation nTextOrientation) {
    m_nTextOrientation = nTextOrientation;
    DelayLayout();
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetTitle Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetTitle Method

Call this member to set a title for this command bar.

void SetTitle(
    LPCTSTR lpszTitle
);
Parameters

lpszTitle
Title to be set.

Body Source
void CXTPCommandBar::SetTitle(LPCTSTR lpszTitle) {
    m_strTitle = lpszTitle;
    Redraw();
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetTrackFocus Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetTrackFocus Method

Call this method to set focus to the window.

void SetTrackFocus(
    HWND hwnd
);
Parameters

hwnd
Window handle of the focused control

Body Source
void CXTPCommandBar::SetTrackFocus(HWND hwnd) {
    m_hwndFocus = hwnd;
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetTrackingMode Method

CXTPCommandBar Methods, CXTPCommandBar Class, See Also
CXTPCommandBar::SetTrackingMode Method

Call this member to change the tracking state.

virtual BOOL SetTrackingMode(
    int bMode,
    BOOL bSelectFirst = TRUE,
    BOOL bKeyboard = FALSE
);
Parameters

bMode
TRUE to set the tracking mode; otherwise FALSE.
bSelectFirst
TRUE to select the first item.
bKeyboard
TRUE if the item is popped by the keyboard.

Returns

TRUE if the method was successful.

See Also

IsTrackingMode.

Group

CXTPCommandBar Methods


CXTPCommandBar::SetVisible Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source
CXTPCommandBar::SetVisible Method

Call this method to set the visibility state of the control.

virtual void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to set control visible.

Body Source
void CXTPCommandBar::SetVisible(BOOL /*bVisible*/) {
}
Group

CXTPCommandBar Methods


CXTPCommandBar::SetWidth Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::SetWidth Method

Call this member to set the width of the floated or popup toolbar.

void SetWidth(
    int nWidth
);
Parameters

nWidth
Width of the floated or popuped toolbar.

Group

CXTPCommandBar Methods


CXTPCommandBar::ShowTextBelowIcons Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::ShowTextBelowIcons Method

Call this member to show the caption below control's icon.

void ShowTextBelowIcons(
    BOOL bTextBelow = TRUE
);
Parameters

bTextBelow
TRUE to show the caption below the icon.

Group

CXTPCommandBar Methods


CXTPCommandBar::UnlockRedraw Method

CXTPCommandBar Methods, CXTPCommandBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBar::UnlockRedraw Method

Call this method to unfreeze redrawing.

void UnlockRedraw();
See Also

LockRedraw

Body Source
void CXTPCommandBar::UnlockRedraw() {
    m_nLockRedraw --;
    if (m_nLockRedraw == 0 && (m_nIdleFlags & xtpIdleRedraw))
        Redraw();
}
Group

CXTPCommandBar Methods


CXTPCommandBar::UpdateShortcuts Method

CXTPCommandBar Methods, CXTPCommandBar Class
CXTPCommandBar::UpdateShortcuts Method

Updates the control's shortcuts.

virtual void UpdateShortcuts();
Group

CXTPCommandBar Methods


CXTPCommandBar Constructors

CXTPCommandBar Class, Legend, Protected Methods
CXTPCommandBar Constructors
Class

CXTPCommandBar Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPCommandBar | Constructs a CXTPCommandBar object


CXTPCommandBar::CXTPCommandBar Constructor

CXTPCommandBar Constructors, CXTPCommandBar Class
CXTPCommandBar::CXTPCommandBar Constructor

Constructs a CXTPCommandBar object

CXTPCommandBar();
Group

CXTPCommandBar Constructors


CXTPCommandBar Destructors

CXTPCommandBar Class, Legend, Protected Methods
CXTPCommandBar Destructors
Class

CXTPCommandBar Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPCommandBar | Destroys a CXTPCommandBar object, handles cleanup and deallocation


CXTPCommandBar::~CXTPCommandBar Destructor

CXTPCommandBar Destructors, CXTPCommandBar Class
CXTPCommandBar::~CXTPCommandBar Destructor

Destroys a CXTPCommandBar object, handles cleanup and deallocation

virtual ~CXTPCommandBar();
Group

CXTPCommandBar Destructors


CXTPCommandBarKeyboardTip Class

XTPCommandBars.h, Classes, Legend, Members, Topics, CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Constructors, CXTPCommandBarKeyboardTip Constructors, CXTPCommandBarKeyboardTip Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip Class

CXTPCommandBarKeyboardTip is CWnd derived class, represents Keyboard tip single window

Class Hierarchy

class CXTPCommandBarKeyboardTip : public CWnd;
File

XTPCommandBars.h

Group

Classes

Legend
Data Member
Constructor
CXTPCommandBarKeyboardTip Constructors
CXTPCommandBarKeyboardTip Constructors | Description
CXTPCommandBarKeyboardTip | Constructs a CXTPCommandBarKeyboardTip object
CXTPCommandBarKeyboardTip Data Members
CXTPCommandBarKeyboardTip Data Members | Description
m_bEnabled | Enabled flag
m_bVisible | TRUE if visible
m_dwAlign | Tip align
m_pCommandBars | Parent CXTPCommandBars object
m_pOwner | Owner object
m_pt | Client coordinates
m_strCaption | Caption
m_strPrefix | Caption
m_strTip | Tooltip


CXTPCommandBarKeyboardTip Data Members

CXTPCommandBarKeyboardTip Class, Legend, Public Data Members
CXTPCommandBarKeyboardTip Data Members
Class

CXTPCommandBarKeyboardTip Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bEnabled | Enabled flag
m_bVisible | TRUE if visible
m_dwAlign | Tip align
m_pCommandBars | Parent CXTPCommandBars object
m_pOwner | Owner object
m_pt | Client coordinates
m_strCaption | Caption
m_strPrefix | Caption
m_strTip | Tooltip


CXTPCommandBarKeyboardTip::m_bEnabled Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_bEnabled Data Member

Enabled flag

BOOL m_bEnabled;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip::m_bVisible Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_bVisible Data Member

TRUE if visible

BOOL m_bVisible;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip::m_dwAlign Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_dwAlign Data Member

Tip align

DWORD m_dwAlign;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip::m_pCommandBars Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_pCommandBars Data Member

Parent CXTPCommandBars object

CXTPCommandBars* m_pCommandBars;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip::m_pOwner Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_pOwner Data Member

Owner object

CCmdTarget* m_pOwner;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip::m_pt Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_pt Data Member

Client coordinates

CPoint m_pt;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip::m_strCaption Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_strCaption Data Member

Caption

CString m_strCaption;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip::m_strPrefix Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_strPrefix Data Member

Caption

CString m_strPrefix;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip::m_strTip Data Member

CXTPCommandBarKeyboardTip Data Members, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::m_strTip Data Member

Tooltip

CString m_strTip;
Group

CXTPCommandBarKeyboardTip Data Members


CXTPCommandBarKeyboardTip Constructors

CXTPCommandBarKeyboardTip Class, Legend, Public Methods
CXTPCommandBarKeyboardTip Constructors
Class

CXTPCommandBarKeyboardTip Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarKeyboardTip | Constructs a CXTPCommandBarKeyboardTip object


CXTPCommandBarKeyboardTip::CXTPCommandBarKeyboardTip Constructor

CXTPCommandBarKeyboardTip Constructors, CXTPCommandBarKeyboardTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarKeyboardTip::CXTPCommandBarKeyboardTip Constructor

Constructs a CXTPCommandBarKeyboardTip object

CXTPCommandBarKeyboardTip(
    CXTPCommandBars* pCommandBars,
    CCmdTarget* pOwner,
    LPCTSTR lpszCaption,
    CPoint pt,
    DWORD dwAlign,
    BOOL bEnabled
);
Parameters

pCommandBars
CXTPCommandBars parent object
pOwner
Owner object
lpszCaption
Caption of control
pt
Client coordinates
dwAlign
Align of tip
bEnabled
TRUE if keyboard tip is enabled

Group

CXTPCommandBarKeyboardTip Constructors


CXTPCommandBarList Class

XTPCommandBar.h, Classes, Legend, Members, Topics, CXTPCommandBarList Data Members, CXTPCommandBarList Methods, CXTPCommandBarList Constructors, CXTPCommandBarList Destructors, CXTPCommandBarList Constructors, CXTPCommandBarList Data Members, CXTPCommandBarList Destructors, CXTPCommandBarList Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarList Class

CXTPCommandBarList is a CList derived class. It is used as a collection of CXTPCommandBar classes.

Class Hierarchy

class CXTPCommandBarList;
File

XTPCommandBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCommandBarList Constructors
CXTPCommandBarList Constructors | Description
CXTPCommandBarList | Constructs a CXTPCommandBarList object
CXTPCommandBarList Data Members
CXTPCommandBarList Data Members | Description
m_arrBars | Array of CommandBars
m_pCommandBars | Parent CXTPCommandBars object
CXTPCommandBarList Destructors
CXTPCommandBarList Destructors | Description
~CXTPCommandBarList | Destroys a CXTPCommandBarList object, handles cleanup and deallocation
CXTPCommandBarList Methods
CXTPCommandBarList Methods | Description
Add | Call this method to add new commandbar to the list
FindCommandBar | Call this member to find the CommandBar with the specified identifier.
GetAt | Returns CommandBar in list by its index
GetCommandBars | Returns Commandbars object attached to list
GetCount | Return count of commanbars in list
Lookup | Call this method to check if CommandBar exists in the list
Remove | Call this method to remove CommandBar from the list
RemoveAll | Call this method to clean the list


CXTPCommandBarList Data Members

CXTPCommandBarList Class, Legend, Protected Data Members
CXTPCommandBarList Data Members
Class

CXTPCommandBarList Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrBars | Array of CommandBars
m_pCommandBars | Parent CXTPCommandBars object


CXTPCommandBarList::m_arrBars Data Member

CXTPCommandBarList Data Members, CXTPCommandBarList Class
CXTPCommandBarList::m_arrBars Data Member

Array of CommandBars

CArray<CXTPCommandBar*, CXTPCommandBar*> m_arrBars;
Group

CXTPCommandBarList Data Members


CXTPCommandBarList::m_pCommandBars Data Member

CXTPCommandBarList Data Members, CXTPCommandBarList Class
CXTPCommandBarList::m_pCommandBars Data Member

Parent CXTPCommandBars object

CXTPCommandBars* m_pCommandBars;
Group

CXTPCommandBarList Data Members


CXTPCommandBarList Methods

CXTPCommandBarList Class, Legend, Public Methods
CXTPCommandBarList Methods
Class

CXTPCommandBarList Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Add | Call this method to add new commandbar to the list
FindCommandBar | Call this member to find the CommandBar with the specified identifier.
GetAt | Returns CommandBar in list by its index
GetCommandBars | Returns Commandbars object attached to list
GetCount | Return count of commanbars in list
Lookup | Call this method to check if CommandBar exists in the list
Remove | Call this method to remove CommandBar from the list
RemoveAll | Call this method to clean the list


CXTPCommandBarList::Add Method

CXTPCommandBarList Methods, CXTPCommandBarList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarList::Add Method

Call this method to add new commandbar to the list

virtual CXTPCommandBar* Add(
    CXTPCommandBar* pCommandBar
);
Parameters

pCommandBar
CommandBar to be added

Returns

Pointer to just added CommandBar

See Also

GetAt, GetCount

Group

CXTPCommandBarList Methods


CXTPCommandBarList::FindCommandBar Method

CXTPCommandBarList Methods, CXTPCommandBarList Class
CXTPCommandBarList::FindCommandBar Method

Call this member to find the CommandBar with the specified identifier.

CXTPCommandBar* FindCommandBar(
    UINT nBarID
) const;
Parameters

nBarID
Identifier CommandBar to find.

Returns

A pointer to a CXTPCommandBar object.

Group

CXTPCommandBarList Methods


CXTPCommandBarList::GetAt Method

CXTPCommandBarList Methods, CXTPCommandBarList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarList::GetAt Method

Returns CommandBar in list by its index

CXTPCommandBar* GetAt(
    int nIndex
) const;
Parameters

nIndex
Index of the commandbar to return

Returns

CommandBar in list by its index

See Also

GetCount

Group

CXTPCommandBarList Methods


CXTPCommandBarList::GetCommandBars Method

CXTPCommandBarList Methods, CXTPCommandBarList Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarList::GetCommandBars Method

Returns Commandbars object attached to list

CXTPCommandBars* GetCommandBars() const;
Returns

Pointer to CXTPCommandBars parent object

See Also

CXTPCommandBars, CXTPCommandBar

Body Source
CXTPCommandBars* GetCommandBars() const { return m_pCommandBars; }
Group

CXTPCommandBarList Methods


CXTPCommandBarList::GetCount Method

CXTPCommandBarList Methods, CXTPCommandBarList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarList::GetCount Method

Return count of commanbars in list

int GetCount() const;
Returns

Commanbars count

See Also

GetAt

Group

CXTPCommandBarList Methods


CXTPCommandBarList::Lookup Method

CXTPCommandBarList Methods, CXTPCommandBarList Class
CXTPCommandBarList::Lookup Method

Call this method to check if CommandBar exists in the list

BOOL Lookup(
    CXTPCommandBar* pCommandBar
) const;
Parameters

pCommandBar
CommandBar to test

Returns

TRUE if CommandBar exists in the list

Group

CXTPCommandBarList Methods


CXTPCommandBarList::Remove Method

CXTPCommandBarList Methods, CXTPCommandBarList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarList::Remove Method

Call this method to remove CommandBar from the list

void Remove(
    CXTPCommandBar* pCommandBar
);
Parameters

pCommandBar
CommandBar to be removed

See Also

RemoveAll

Group

CXTPCommandBarList Methods


CXTPCommandBarList::RemoveAll Method

CXTPCommandBarList Methods, CXTPCommandBarList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarList::RemoveAll Method

Call this method to clean the list

void RemoveAll();
See Also

Remove

Group

CXTPCommandBarList Methods


CXTPCommandBarList Constructors

CXTPCommandBarList Class, Legend, Public Methods
CXTPCommandBarList Constructors
Class

CXTPCommandBarList Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarList | Constructs a CXTPCommandBarList object


CXTPCommandBarList::CXTPCommandBarList Constructor

CXTPCommandBarList Constructors, CXTPCommandBarList Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarList::CXTPCommandBarList Constructor

Constructs a CXTPCommandBarList object

CXTPCommandBarList(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
Parent CXTPCommandBars pointer

Body Source
CXTPCommandBarList(CXTPCommandBars* pCommandBars)
{
    m_pCommandBars = pCommandBars;
}
Group

CXTPCommandBarList Constructors


CXTPCommandBarList Destructors

CXTPCommandBarList Class, Legend, Public Methods
CXTPCommandBarList Destructors
Class

CXTPCommandBarList Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCommandBarList | Destroys a CXTPCommandBarList object, handles cleanup and deallocation


CXTPCommandBarList::~CXTPCommandBarList Destructor

CXTPCommandBarList Destructors, CXTPCommandBarList Class
CXTPCommandBarList::~CXTPCommandBarList Destructor

Destroys a CXTPCommandBarList object, handles cleanup and deallocation

virtual ~CXTPCommandBarList();
Group

CXTPCommandBarList Destructors


CXTPCommandBars Class

XTPCommandBars.h, Classes, Legend, Members, Topics, CXTPCommandBars Structures, CXTPCommandBars Data Members, CXTPCommandBars Methods, CXTPCommandBars Constructors, CXTPCommandBars Destructors, CXTPCommandBars Constructors, CXTPCommandBars Data Members, CXTPCommandBars Destructors, CXTPCommandBars Methods, See Also, CXTPCommandBars Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBars Class

CXTPCommandBars is standalone class. It allows developer manipulate toolbars and popupbars

Class Hierarchy

class CXTPCommandBars;
File

XTPCommandBars.h

See Also

CXTPCommandBar, CXTPToolBar, CXTPCommandBarsOptions

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTPCommandBars Constructors
CXTPCommandBars Constructors | Description
CXTPCommandBars | Constructs a CXTPCommandBars object
CXTPCommandBars Data Members
CXTPCommandBars Data Members | Description
m_arrBars | Toolbars list.
m_bCustomizeAvail | TRUE if customize available.
m_bCustomizeMode | Customize mode.
m_bDesignerMode | TRUE if command bars in designer mode.
m_bEnableActions | True if actions was enabled
m_bIgnoreShiftMenuKey | if set menus will ignore Shift+Alt key combinations
m_bKeyboardCuesVisible | TRUE if menu underlines is currently visible
m_bQuickCustomizeMode | TRUE if command bars in quick customization mode
m_keyboardTips | Keyboard tips information
m_nDefaultMenuID | Default menu resource.
m_nIDHelpTracking | Selected control.
m_pActions | Actions collection
m_pContextMenus | Context menu collection
m_pDesignerControls | Designer controls if used.
m_pDockBarClass | Default dockbar class
m_pDocks | DockBars list
m_pDragSelected | Customize control.
m_pDropSource | Customize helper class.
m_pFrame | Parent frame of command bars
m_pImageManager | Image manager
m_pKeyboardManager | Keyboard manager of command bars
m_pMenuBarClass | Default menubar class
m_pMouseManager | Mouse manager of command bars
m_pOptions | Command bars' options
m_pPaintManager | Paint manager.
m_pPopupBarClass | Default popupbar class
m_pPopupToolBarClass | Default popupbar class
m_pShortcutManager | Shortcut Manager of command bars.
m_pToolBarClass | Default toolbar class
m_pToolTipContext | Tooltip Context.
m_strControlsFileName | File name to be used to store user customization.
CXTPCommandBars Destructors
CXTPCommandBars Destructors | Description
~CXTPCommandBars | Destroys a CXTPCommandBars object, handles cleanup and deallocation
CXTPCommandBars Methods
CXTPCommandBars Methods | Description
Add | Call this member to add a new toolbar.
AddCustomBar | This method is called to add custom toolbar.
CanDock | Call this member to retrieve dock bar in specified point.
ClosePopups | Call this member to close all popup windows
ContextMenu | This method shows the context menu for toolbars.
CreateAction | Call this method to add new action for specified id.
CreateCommandBars | This member creates command bars.
DockCommandBar |
DoPropExchange | Reads or writes this object from or to an storage.
EnableActions | Call this method to let command bars automatically add actions for new commands
EnableCustomization | Call this member to disabled/enable customization.
EnableDocking | This member is called to create dock bars.
FindAction | Call this method to find action for specified id.
FindControl | Call this member to find the specified control.
FindIndex | Call this member to find index of the specified toolbar
FloatCommandBar | Call this member function to float a CXTPToolBar.
GetActions | Call this method to get actions list for command bars
GetActiveDocTemplate | Retrieves active MDI document template
GetAddOrRemovePopup | Call this method to create customized controls.
GetAt | Call this member to retrieve a toolbar with the specified index.
GetCommandBarsOptions | Call this member to retrieve the options of the command bars.
GetContextMenus | Retrieves list of available context menus
GetCount | Call this member to get toolbars count.
GetDockBar | Call this member to get the dock bar at the specified position.
GetDockState | Call this member function to store state information about the frame window's control bars in a CXTPDockState object.
GetDragControl | Call this member to retrieve the current customized control.
GetDropSource | Call this member to retrieve the CXTPCustomizeDropSource helper class for customization.
GetFrameReBar | This method finds rebar of the frame
GetHelpTrackingId | Determines Help identifier of control under mouse cursor
GetHiddenControls | Call this method to create an expand bar.
GetImageManager | Call this member to retrieve the image manager of the command bars.
GetKeyboardManager | Call this method to get GetKeyboardManager pointer of command bars
GetMenuBar | Call this member to get the active menu bar.
GetMouseManager | Call this method to get CXTPMouseManager pointer of command bars
GetPaintManager | Call this member to retrieve the paint manager of the command bars.
GetShortcutManager | Call this function to get ShortcutManager class pointer
GetSite | Call this member to get the site of the command bars.
GetToolBar | Call this member to get the toolbar with the specified identifier.
GetToolbarsPopup | This method creates a context menu for toolbars.
GetToolTipContext | Call this method to get tooltip context pointer.
HideCommand | This member function adds the specified command to the list of menu items to hide until activated by clicking on the chevron.
HideCommands | This member function adds the specified commands to the list of menu items to hide until activated by clicking on the chevron.
HideKeyboardTips | Removes all keyboard tips
InvalidateCommandBars | Call this member to invalidate the command bars.
IsActionsEnabled | Determines if EnableActions method was called
IsCommandHidden | Call this member function to retrieve if the command is hidden until activated by clicking on the chevron. I.e. Infrequently used commands.
IsControlHidden | Call this member function to retrieve if the control is hidden and of type CXTPControlPopup when bAutoHideUnusedPopups is TRUE.
IsCustomizeAvail | Call this member to retrieve if the customize is avail.
IsCustomizeMode | Call this member to retrieve the customize mode of the command bars.
IsLayoutRTL | Determines if right-to-left mode was set.
IsQuickCustomizeMode | Call this member to retrieve the customize mode of the command bars.
LoadBarState | Call this function to retrieve state information from the registry or .INI file.
LoadDesignerBars |
LoadOptions | Call this function to restore the options of the command bars.
OnFrameAccel | This method is called when user press Alt + char
OnFrameWndMsg | Call this method to process frame messages. CXTPFrameWndBase derived classes call this method automatically.
OnSetPreviewMode | Call this member function to set the application's command bars into and out of print-preview mode.
OnToolBarAdded | This method is called when new toolbar was added.
OnToolBarRemoved | This method is called when new toolbar was removed
OnTrackingModeChanged | This method is called when tracking mode of commandbar was changed
PreTranslateFrameMessage | Call this method to process frame messages. CXTPFrameWndBase derived classes call this method automatically.
RecalcFrameLayout | Call this member to recalculate site layout.
RedrawCommandBars | Call this member to redraw the command bars.
Remove | Call this member to remove the toolbar.
RemoveAll | Call this member to remove all toolbars.
ResetUsageData | Call this member function to restore the state of the hidden commands.
SaveBarState | Call this function to save the state information to the registry or .INI file.
SaveOptions | Call this function to save the command bars options.
SerializeBarState | Call this function to either read or write command bars from or to an archive.
SetCommandUsed | Call this member function to set the command activated by user.
SetCustomizationDataFileName | Call this method to set customization file path
SetCustomizeMode | Call this member to set customize mode of the command bars.
SetDockBarClass | Call this method to set default dockbar class
SetDockState | Call this member function to apply state information stored in a CXTPDockState object to the frame window's control bars.
SetDragControl | This method is called when customized control changed.
SetImageManager | Call this member to set the specified image manager.
SetLayoutRTL | Call this member to set right-to-left mode.
SetMenu | Call this member to create menu bar.
SetMenuBarClass | Call this method to set default menubar class
SetPaintManager | Call this member to set the specified paint manager.
SetPopupBarClass | Call this method to set default popupbar class
SetPopupToolBarClass | Call this method to set default popup toolbar class
SetQuickCustomizeMode | Call this member to set customize mode of the command bars.
SetShortcutManager | Call this function to set custom shortcut manager class.
SetSite | This method is called to set the site window.
SetTheme | Call this member to set the specified paint manager.
SetToolBarClass | Call this method to set default toolbar class
SetToolBarFocus | This method is called to activate toolbar.
ShowKeyboardCues | This method is called to show keyboard cues of controls
ShowKeyboardTips | This method is called to show keyboard tips for the commandbar
ToggleVisible | Call this member to show/hide the toolbar.
TrackPopupMenu |
TrackPopupMenuEx | Call this member to display a floating pop-up menu at the specified location.
UpdateCommandBars | Sends WM_IDLEUPDATECMDUI message to all tool bars.
CXTPCommandBars Structures
CXTPCommandBars Structures | Description
KEYBOARDTIPS | Keyboard tips information


CXTPCommandBars Structures

CXTPCommandBars Class, Legend, Structures
CXTPCommandBars Structures
Class

CXTPCommandBars Class

Legend
Structure
Structures
Structure | Description
KEYBOARDTIPS | Keyboard tips information


CXTPCommandBars::KEYBOARDTIPS Structure

XTPCommandBars.h, CXTPCommandBars Structures
CXTPCommandBars::KEYBOARDTIPS Structure

Keyboard tips information

struct KEYBOARDTIPS {
  CArray<CXTPCommandBarKeyboardTip*, CXTPCommandBarKeyboardTip*> arr;
  CXTPCommandBar* pBar;
  int nLevel;
  int nKey;
};
File

XTPCommandBars.h

Members

arr
Keyboard tips collection
pBar
Owner of keyboard tips
nLevel
Keyboard tip level (for RibbonBar)
nKey
Keys was pressed already.

Group

CXTPCommandBars Structures


CXTPCommandBars Data Members

CXTPCommandBars Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBars Data Members
Class

CXTPCommandBars Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrBars | Toolbars list.
m_bCustomizeAvail | TRUE if customize available.
m_bCustomizeMode | Customize mode.
m_bEnableActions | True if actions was enabled
m_bKeyboardCuesVisible | TRUE if menu underlines is currently visible
m_bQuickCustomizeMode | TRUE if command bars in quick customization mode
m_nDefaultMenuID | Default menu resource.
m_nIDHelpTracking | Selected control.
m_pActions | Actions collection
m_pContextMenus | Context menu collection
m_pDockBarClass | Default dockbar class
m_pDocks | DockBars list
m_pDragSelected | Customize control.
m_pDropSource | Customize helper class.
m_pFrame | Parent frame of command bars
m_pImageManager | Image manager
m_pKeyboardManager | Keyboard manager of command bars
m_pMenuBarClass | Default menubar class
m_pMouseManager | Mouse manager of command bars
m_pOptions | Command bars' options
m_pPaintManager | Paint manager.
m_pPopupBarClass | Default popupbar class
m_pPopupToolBarClass | Default popupbar class
m_pShortcutManager | Shortcut Manager of command bars.
m_pToolBarClass | Default toolbar class
m_pToolTipContext | Tooltip Context.
m_strControlsFileName | File name to be used to store user customization.
Public Data Members
Public Data Member | Description
m_bDesignerMode | TRUE if command bars in designer mode.
m_bIgnoreShiftMenuKey | if set menus will ignore Shift+Alt key combinations
m_keyboardTips | Keyboard tips information
m_pDesignerControls | Designer controls if used.


CXTPCommandBars::m_arrBars Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_arrBars Data Member

Toolbars list.

CArray<CXTPToolBar*, CXTPToolBar*> m_arrBars;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_bCustomizeAvail Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_bCustomizeAvail Data Member

TRUE if customize available.

BOOL m_bCustomizeAvail;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_bCustomizeMode Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_bCustomizeMode Data Member

Customize mode.

BOOL m_bCustomizeMode;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_bDesignerMode Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_bDesignerMode Data Member

TRUE if command bars in designer mode.

BOOL m_bDesignerMode;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_bEnableActions Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_bEnableActions Data Member

True if actions was enabled

BOOL m_bEnableActions;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_bIgnoreShiftMenuKey Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_bIgnoreShiftMenuKey Data Member

if set menus will ignore Shift+Alt key combinations

BOOL m_bIgnoreShiftMenuKey;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_bKeyboardCuesVisible Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_bKeyboardCuesVisible Data Member

TRUE if menu underlines is currently visible

BOOL m_bKeyboardCuesVisible;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_bQuickCustomizeMode Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_bQuickCustomizeMode Data Member

TRUE if command bars in quick customization mode

BOOL m_bQuickCustomizeMode;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_keyboardTips Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_keyboardTips Data Member

Keyboard tips information

struct KEYBOARDTIPS {
  CArray<CXTPCommandBarKeyboardTip*, CXTPCommandBarKeyboardTip*> arr;
  CXTPCommandBar* pBar;
  int nLevel;
  int nKey;
} m_keyboardTips;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_nDefaultMenuID Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_nDefaultMenuID Data Member

Default menu resource.

int m_nDefaultMenuID;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_nIDHelpTracking Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_nIDHelpTracking Data Member

Selected control.

int m_nIDHelpTracking;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pActions Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pActions Data Member

Actions collection

CXTPControlActions* m_pActions;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pContextMenus Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pContextMenus Data Member

Context menu collection

CXTPCommandBarsContextMenus* m_pContextMenus;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pDesignerControls Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pDesignerControls Data Member

Designer controls if used.

CXTPControls* m_pDesignerControls;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pDockBarClass Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pDockBarClass Data Member

Default dockbar class

CRuntimeClass* m_pDockBarClass;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pDocks Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pDocks Data Member

DockBars list

CXTPDockBar* m_pDocks[4];
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pDragSelected Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pDragSelected Data Member

Customize control.

CXTPControl* m_pDragSelected;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pDropSource Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pDropSource Data Member

Customize helper class.

CXTPCustomizeDropSource* m_pDropSource;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pFrame Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pFrame Data Member

Parent frame of command bars

CWnd* m_pFrame;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pImageManager Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pImageManager Data Member

Image manager

CXTPImageManager* m_pImageManager;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pKeyboardManager Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pKeyboardManager Data Member

Keyboard manager of command bars

mutable CXTPKeyboardManager* m_pKeyboardManager;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pMenuBarClass Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pMenuBarClass Data Member

Default menubar class

CRuntimeClass* m_pMenuBarClass;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pMouseManager Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pMouseManager Data Member

Mouse manager of command bars

mutable CXTPMouseManager* m_pMouseManager;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pOptions Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pOptions Data Member

Command bars' options

CXTPCommandBarsOptions* m_pOptions;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pPaintManager Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pPaintManager Data Member

Paint manager.

CXTPPaintManager* m_pPaintManager;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pPopupBarClass Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pPopupBarClass Data Member

Default popupbar class

CRuntimeClass* m_pPopupBarClass;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pPopupToolBarClass Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pPopupToolBarClass Data Member

Default popupbar class

CRuntimeClass* m_pPopupToolBarClass;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pShortcutManager Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pShortcutManager Data Member

Shortcut Manager of command bars.

CXTPShortcutManager* m_pShortcutManager;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pToolBarClass Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pToolBarClass Data Member

Default toolbar class

CRuntimeClass* m_pToolBarClass;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_pToolTipContext Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_pToolTipContext Data Member

Tooltip Context.

CXTPToolTipContext* m_pToolTipContext;
Group

CXTPCommandBars Data Members


CXTPCommandBars::m_strControlsFileName Data Member

CXTPCommandBars Data Members, CXTPCommandBars Class
CXTPCommandBars::m_strControlsFileName Data Member

File name to be used to store user customization.

CString m_strControlsFileName;
Group

CXTPCommandBars Data Members


CXTPCommandBars Methods

CXTPCommandBars Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBars Methods
Class

CXTPCommandBars Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
AddCustomBar | This method is called to add custom toolbar.
FloatCommandBar | Call this member function to float a CXTPToolBar.
GetDockState | Call this member function to store state information about the frame window's control bars in a CXTPDockState object.
OnToolBarAdded | This method is called when new toolbar was added.
OnToolBarRemoved | This method is called when new toolbar was removed
OnTrackingModeChanged | This method is called when tracking mode of commandbar was changed
SetDockState | Call this member function to apply state information stored in a CXTPDockState object to the frame window's control bars.
Public Methods
Public Methods
Public Method | Description
Add | Call this member to add a new toolbar.
CanDock | Call this member to retrieve dock bar in specified point.
ClosePopups | Call this member to close all popup windows
ContextMenu | This method shows the context menu for toolbars.
CreateAction | Call this method to add new action for specified id.
CreateCommandBars | This member creates command bars.
DockCommandBar |
DoPropExchange | Reads or writes this object from or to an storage.
EnableActions | Call this method to let command bars automatically add actions for new commands
EnableCustomization | Call this member to disabled/enable customization.
EnableDocking | This member is called to create dock bars.
FindAction | Call this method to find action for specified id.
FindControl | Call this member to find the specified control.
FindIndex | Call this member to find index of the specified toolbar
GetActions | Call this method to get actions list for command bars
GetActiveDocTemplate | Retrieves active MDI document template
GetAddOrRemovePopup | Call this method to create customized controls.
GetAt | Call this member to retrieve a toolbar with the specified index.
GetCommandBarsOptions | Call this member to retrieve the options of the command bars.
GetContextMenus | Retrieves list of available context menus
GetCount | Call this member to get toolbars count.
GetDockBar | Call this member to get the dock bar at the specified position.
GetDragControl | Call this member to retrieve the current customized control.
GetDropSource | Call this member to retrieve the CXTPCustomizeDropSource helper class for customization.
GetFrameReBar | This method finds rebar of the frame
GetHelpTrackingId | Determines Help identifier of control under mouse cursor
GetHiddenControls | Call this method to create an expand bar.
GetImageManager | Call this member to retrieve the image manager of the command bars.
GetKeyboardManager | Call this method to get GetKeyboardManager pointer of command bars
GetMenuBar | Call this member to get the active menu bar.
GetMouseManager | Call this method to get CXTPMouseManager pointer of command bars
GetPaintManager | Call this member to retrieve the paint manager of the command bars.
GetShortcutManager | Call this function to get ShortcutManager class pointer
GetSite | Call this member to get the site of the command bars.
GetToolBar | Call this member to get the toolbar with the specified identifier.
GetToolbarsPopup | This method creates a context menu for toolbars.
GetToolTipContext | Call this method to get tooltip context pointer.
HideCommand | This member function adds the specified command to the list of menu items to hide until activated by clicking on the chevron.
HideCommands | This member function adds the specified commands to the list of menu items to hide until activated by clicking on the chevron.
HideKeyboardTips | Removes all keyboard tips
InvalidateCommandBars | Call this member to invalidate the command bars.
IsActionsEnabled | Determines if EnableActions method was called
IsCommandHidden | Call this member function to retrieve if the command is hidden until activated by clicking on the chevron. I.e. Infrequently used commands.
IsControlHidden | Call this member function to retrieve if the control is hidden and of type CXTPControlPopup when bAutoHideUnusedPopups is TRUE.
IsCustomizeAvail | Call this member to retrieve if the customize is avail.
IsCustomizeMode | Call this member to retrieve the customize mode of the command bars.
IsLayoutRTL | Determines if right-to-left mode was set.
IsQuickCustomizeMode | Call this member to retrieve the customize mode of the command bars.
LoadBarState | Call this function to retrieve state information from the registry or .INI file.
LoadDesignerBars |
LoadOptions | Call this function to restore the options of the command bars.
OnFrameAccel | This method is called when user press Alt + char
OnFrameWndMsg | Call this method to process frame messages. CXTPFrameWndBase derived classes call this method automatically.
OnSetPreviewMode | Call this member function to set the application's command bars into and out of print-preview mode.
PreTranslateFrameMessage | Call this method to process frame messages. CXTPFrameWndBase derived classes call this method automatically.
RecalcFrameLayout | Call this member to recalculate site layout.
RedrawCommandBars | Call this member to redraw the command bars.
Remove | Call this member to remove the toolbar.
RemoveAll | Call this member to remove all toolbars.
ResetUsageData | Call this member function to restore the state of the hidden commands.
SaveBarState | Call this function to save the state information to the registry or .INI file.
SaveOptions | Call this function to save the command bars options.
SerializeBarState | Call this function to either read or write command bars from or to an archive.
SetCommandUsed | Call this member function to set the command activated by user.
SetCustomizationDataFileName | Call this method to set customization file path
SetCustomizeMode | Call this member to set customize mode of the command bars.
SetDockBarClass | Call this method to set default dockbar class
SetDragControl | This method is called when customized control changed.
SetImageManager | Call this member to set the specified image manager.
SetLayoutRTL | Call this member to set right-to-left mode.
SetMenu | Call this member to create menu bar.
SetMenuBarClass | Call this method to set default menubar class
SetPaintManager | Call this member to set the specified paint manager.
SetPopupBarClass | Call this method to set default popupbar class
SetPopupToolBarClass | Call this method to set default popup toolbar class
SetQuickCustomizeMode | Call this member to set customize mode of the command bars.
SetShortcutManager | Call this function to set custom shortcut manager class.
SetSite | This method is called to set the site window.
SetTheme | Call this member to set the specified paint manager.
SetToolBarClass | Call this method to set default toolbar class
SetToolBarFocus | This method is called to activate toolbar.
ShowKeyboardCues | This method is called to show keyboard cues of controls
ShowKeyboardTips | This method is called to show keyboard tips for the commandbar
ToggleVisible | Call this member to show/hide the toolbar.
TrackPopupMenu |
TrackPopupMenuEx | Call this member to display a floating pop-up menu at the specified location.
UpdateCommandBars | Sends WM_IDLEUPDATECMDUI message to all tool bars.


CXTPCommandBars::Add Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::Add Method

Call this member to add a new toolbar.

CXTPToolBar* Add(
    LPCTSTR lpszName,
    XTPBarPosition barPosition,
    CRuntimeClass* pToolbarClass = NULL
);
Parameters

lpszName
Title of toolbar.
barPosition
Position of toolbar to be created.
pToolbarClass
Runtime class of toolbar to create

Returns

A CXTPToolBar object if successful; otherwise NULL.

Remarks

CommandBars will create new toolbar with pToolbarClass runtime class if it specified, if not m_pToolBarClass will be used.

Call SetToolBarClass to set default runtime class for toolbars.

See Also

SetMenu, SetToolBarClass

Group

CXTPCommandBars Methods


CXTPCommandBars::AddCustomBar Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::AddCustomBar Method

This method is called to add custom toolbar.

virtual CXTPToolBar* AddCustomBar(
    LPCTSTR lpcstrCaption,
    UINT nID,
    BOOL bTearOffBar = FALSE
);
Parameters

lpcstrCaption
Title of toolbar.
nID
Toolbar id
bTearOffBar
TRUE if toolbar is tear-off

Returns

A CXTPToolBar object if successful; otherwise NULL.

See Also

Add

Group

CXTPCommandBars Methods


CXTPCommandBars::CanDock Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::CanDock Method

Call this member to retrieve dock bar in specified point.

CXTPDockBar* CanDock(
    CPoint pt,
    CXTPDockBar* pMainDock = NULL
) const;
Parameters

pt
Point needed to test.
pMainDock
CXTPDockBar class currently docked in.

Returns

A pointer to a CXTPDockBar object.

Group

CXTPCommandBars Methods


CXTPCommandBars::ClosePopups Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::ClosePopups Method

Call this member to close all popup windows

void ClosePopups() const;
Group

CXTPCommandBars Methods


CXTPCommandBars::ContextMenu Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::ContextMenu Method

This method shows the context menu for toolbars.

virtual void ContextMenu(
    CXTPToolBar* pToolBar,
    CPoint point
);
Parameters

pToolBar
Points to a CXTPToolBar object
point
Position of the menu to show.

Group

CXTPCommandBars Methods


CXTPCommandBars::CreateAction Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::CreateAction Method

Call this method to add new action for specified id.

CXTPControlAction* CreateAction(
    int nId
);
Parameters

nId
Identifier of action to create

Group

CXTPCommandBars Methods


CXTPCommandBars::CreateCommandBars Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::CreateCommandBars Method

This member creates command bars.

static CXTPCommandBars* CreateCommandBars();
Returns

A pointer to a CXTPCommandBars object

Group

CXTPCommandBars Methods


DockCommandBar Method

CXTPCommandBars Methods
DockCommandBar Method
Overload List
Methods
Method | Description
CXTPCommandBars::DockCommandBar (CXTPToolBar*, LPRECT, CXTPDockBar*) | Call this member to dock a toolbar to the specified dockbar.
CXTPCommandBars::DockCommandBar (CXTPToolBar*, XTPBarPosition) | Call this member to dock a toolbar to the specified dockbar.
Group

CXTPCommandBars Methods


CXTPCommandBars::DockCommandBar Method (CXTPToolBar*, LPRECT, CXTPDockBar*)

DockCommandBar Method, CXTPCommandBars Class
CXTPCommandBars::DockCommandBar Method (CXTPToolBar*, LPRECT, CXTPDockBar*)

Call this member to dock a toolbar to the specified dockbar.

BOOL DockCommandBar(
    CXTPToolBar* pBar,
    LPRECT lpRect,
    CXTPDockBar* pDockBar
);
BOOL DockCommandBar(
    CXTPToolBar* pBar,
    XTPBarPosition barPosition
);
Parameters

pBar
Points to a CXTPToolBar object
lpRect
Position to dock.
pDockBar
Dock bar needed to be docked.
barPosition
Position to dock

Returns

TRUE if the toolbar was successfully docked, FALSE if the bar could not be docked.

Group

DockCommandBar Method


CXTPCommandBars::DoPropExchange Method

CXTPCommandBars Methods, CXTPCommandBars Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBars::DoPropExchange Method

Reads or writes this object from or to an storage.

void DoPropExchange(
    CXTPPropExchange* pPX,
    XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam = NULL
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
pParam
Exchange options.

See Also

CXTPPropExchange, XTP_COMMANDBARS_PROPEXCHANGE_PARAM

Example
XTP_COMMANDBARS_PROPEXCHANGE_PARAM param;
param.bSerializeControls = TRUE;
// Serialize to XML
CXTPPropExchangeXMLNode px(FALSE, 0, _T("Settings"));
CXTPPropExchangeSection pxCommandBars(px.GetSection(_T("CommandBars")));
GetCommandBars()->DoPropExchange(&pxCommandBars, &param);
px.SaveToFile(m_strIniFileName);
Group

CXTPCommandBars Methods


CXTPCommandBars::EnableActions Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::EnableActions Method

Call this method to let command bars automatically add actions for new commands

void EnableActions();
Group

CXTPCommandBars Methods


CXTPCommandBars::EnableCustomization Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::EnableCustomization Method

Call this member to disabled/enable customization.

void EnableCustomization(
    BOOL bCustomizeAvail
);
Parameters

bCustomizeAvail
TRUE to allow customization; FALSE to disable.

Body Source
void CXTPCommandBars::EnableCustomization(BOOL bCustomizeAvail) {
    m_bCustomizeAvail = bCustomizeAvail;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::EnableDocking Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::EnableDocking Method

This member is called to create dock bars.

void EnableDocking();
Group

CXTPCommandBars Methods


CXTPCommandBars::FindAction Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::FindAction Method

Call this method to find action for specified id.

CXTPControlAction* FindAction(
    int nId
) const;
Parameters

nId
Identifier of action to find

Group

CXTPCommandBars Methods


CXTPCommandBars::FindControl Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::FindControl Method

Call this member to find the specified control.

CXTPControl* FindControl(
    XTPControlType type,
    UINT nId,
    BOOL bVisible,
    BOOL bRecursive
) const;
Parameters

type
Type of the control to find.
nId
Control's identifier.
bVisible
Control is visible.
bRecursive
To find in the nested command bars.

Returns

The CXTPControl object if successful; otherwise NULL.

Group

CXTPCommandBars Methods


CXTPCommandBars::FindIndex Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::FindIndex Method

Call this member to find index of the specified toolbar

int FindIndex(
    CXTPToolBar* pToolBar
) const;
Parameters

pToolBar
Pointer to a CXTPToolBar object.

Returns

The index of the matching item.

Group

CXTPCommandBars Methods


CXTPCommandBars::FloatCommandBar Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::FloatCommandBar Method

Call this member function to float a CXTPToolBar.

BOOL FloatCommandBar(
    CXTPToolBar* pBar
);
Parameters

pBar
Pointer to a valid CXTPToolBar object.

Returns

TRUE if the CXTPToolBar was successfully floated, otherwise FALSE.

Group

CXTPCommandBars Methods


CXTPCommandBars::GetActions Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::GetActions Method

Call this method to get actions list for command bars

CXTPControlActions* GetActions() const;
Body Source
CXTPControlActions* CXTPCommandBars::GetActions() const {
    return m_pActions;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetActiveDocTemplate Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetActiveDocTemplate Method

Retrieves active MDI document template

virtual UINT GetActiveDocTemplate();
Returns

Active document template identifier.

Group

CXTPCommandBars Methods


CXTPCommandBars::GetAddOrRemovePopup Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetAddOrRemovePopup Method

Call this method to create customized controls.

virtual void GetAddOrRemovePopup(
    CXTPToolBar* pToolBar,
    CXTPCommandBar* pExpandBar
);
Parameters

pToolBar
Points to a CXTPToolBar object
pExpandBar
Points to a CXTPCommandBar object

Group

CXTPCommandBars Methods


CXTPCommandBars::GetAt Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetAt Method

Call this member to retrieve a toolbar with the specified index.

CXTPToolBar* GetAt(
    int nIndex
) const;
Parameters

nIndex
Index of the toolbar.

Returns

A pointer to a CXTPToolBar object

Group

CXTPCommandBars Methods


CXTPCommandBars::GetCommandBarsOptions Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::GetCommandBarsOptions Method

Call this member to retrieve the options of the command bars.

CXTPCommandBarsOptions* GetCommandBarsOptions() const;
Returns

Command Bars options.

Body Source
CXTPCommandBarsOptions* CXTPCommandBars::GetCommandBarsOptions() const {
    return m_pOptions;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetContextMenus Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::GetContextMenus Method

Retrieves list of available context menus

CXTPCommandBarsContextMenus* GetContextMenus() const;
Returns

Command Bars context menus.

Body Source
CXTPCommandBarsContextMenus* CXTPCommandBars::GetContextMenus() const {
    return m_pContextMenus;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetCount Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::GetCount Method

Call this member to get toolbars count.

int GetCount() const;
Returns

Number of the toolbars.

Body Source
int CXTPCommandBars::GetCount() const {
    return (int)m_arrBars.GetSize();
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetDockBar Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::GetDockBar Method

Call this member to get the dock bar at the specified position.

CXTPDockBar* GetDockBar(
    XTPBarPosition barPosition
) const;
Parameters

barPosition
Position of the dockbar.

Returns

A CXTPDockBar pointer.

Body Source
CXTPDockBar* CXTPCommandBars::GetDockBar(XTPBarPosition barPosition) const {
    ASSERT(barPosition >= 0 && barPosition < 4);
    return barPosition >= 0 && barPosition < 4 ? m_pDocks[barPosition] : NULL;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetDockState Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetDockState Method

Call this member function to store state information about the frame window's control bars in a CXTPDockState object.

void GetDockState(
    CXTPDockState& state
);
Parameters

state
Contains the current state of the frame window's control bars upon return.

Group

CXTPCommandBars Methods


CXTPCommandBars::GetDragControl Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::GetDragControl Method

Call this member to retrieve the current customized control.

CXTPControl* GetDragControl() const;
Returns

A pointer to a CXTPControl object

Body Source
CXTPControl* CXTPCommandBars::GetDragControl() const {
    return  m_pDragSelected;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetDropSource Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::GetDropSource Method

Call this member to retrieve the CXTPCustomizeDropSource helper class for customization.

CXTPCustomizeDropSource* GetDropSource() const;
Returns

A pointer to a CXTPCustomizeDropSource object

Body Source
CXTPCustomizeDropSource* CXTPCommandBars::GetDropSource() const {
    return m_pDropSource;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetFrameReBar Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetFrameReBar Method

This method finds rebar of the frame

CXTPReBar* GetFrameReBar() const;
Returns

CXTPReBar pointer if rebar was found; NULL otherwise.

Group

CXTPCommandBars Methods


CXTPCommandBars::GetHelpTrackingId Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBars::GetHelpTrackingId Method

Determines Help identifier of control under mouse cursor

int GetHelpTrackingId() const;
Returns

Identifier of control under mouse cursor

See Also

CXTPControl::SetHelpId

Body Source
int CXTPCommandBars::GetHelpTrackingId() const {
    return m_nIDHelpTracking;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetHiddenControls Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetHiddenControls Method

Call this method to create an expand bar.

virtual void GetHiddenControls(
    CXTPToolBar* pToolBar,
    CXTPCommandBar* pExpandBar
);
Parameters

pToolBar
Points to a CXTPToolBar object
pExpandBar
Points to a CXTPCommandBar object

Group

CXTPCommandBars Methods


CXTPCommandBars::GetImageManager Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetImageManager Method

Call this member to retrieve the image manager of the command bars.

CXTPImageManager* GetImageManager() const;
Returns

A pointer to a CXTPImageManager object

Group

CXTPCommandBars Methods


CXTPCommandBars::GetKeyboardManager Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::GetKeyboardManager Method

Call this method to get GetKeyboardManager pointer of command bars

CXTPKeyboardManager* GetKeyboardManager() const;
Returns

Pointer to GetKeyboardManager object

See Also

CXTPMouseManager

Group

CXTPCommandBars Methods


CXTPCommandBars::GetMenuBar Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetMenuBar Method

Call this member to get the active menu bar.

virtual CXTPMenuBar* GetMenuBar() const;
Returns

A CXTPMenuBar pointer associated with the menu bar.

Group

CXTPCommandBars Methods


CXTPCommandBars::GetMouseManager Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::GetMouseManager Method

Call this method to get CXTPMouseManager pointer of command bars

CXTPMouseManager* GetMouseManager() const;
Returns

Pointer to CXTPMouseManager object

See Also

GetKeyboardManager

Group

CXTPCommandBars Methods


CXTPCommandBars::GetPaintManager Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetPaintManager Method

Call this member to retrieve the paint manager of the command bars.

CXTPPaintManager* GetPaintManager() const;
Returns

A pointer to a CXTPPaintManager object

Group

CXTPCommandBars Methods


CXTPCommandBars::GetShortcutManager Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::GetShortcutManager Method

Call this function to get ShortcutManager class pointer

CXTPShortcutManager* GetShortcutManager() const;
Returns

Pointer to current shortcut manager.

See Also

SetShortcutManager

Group

CXTPCommandBars Methods


CXTPCommandBars::GetSite Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::GetSite Method

Call this member to get the site of the command bars.

CWnd* GetSite() const;
Returns

A CFrameWnd pointer representing the site of the command bars.

Body Source
CWnd* CXTPCommandBars::GetSite() const {
    return m_pFrame;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::GetToolBar Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetToolBar Method

Call this member to get the toolbar with the specified identifier.

CXTPToolBar* GetToolBar(
    UINT nID
) const;
Parameters

nID
An integer identifier.

Returns

The CXTPToolBar pointer

Group

CXTPCommandBars Methods


CXTPCommandBars::GetToolbarsPopup Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetToolbarsPopup Method

This method creates a context menu for toolbars.

virtual CXTPPopupBar* GetToolbarsPopup();
Returns

A CXTPPopupBar object containing list of toolbars.

Group

CXTPCommandBars Methods


CXTPCommandBars::GetToolTipContext Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Group

CXTPCommandBars Methods


CXTPCommandBars::HideCommand Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::HideCommand Method

This member function adds the specified command to the list of menu items to hide until activated by clicking on the chevron.

void HideCommand(
    UINT nCommand
);
Parameters

nCommand
The command ID of a menu item to hide.

Group

CXTPCommandBars Methods


CXTPCommandBars::HideCommands Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::HideCommands Method

This member function adds the specified commands to the list of menu items to hide until activated by clicking on the chevron.

void HideCommands(
    const UINT* pCommands,
    int nCount
);
Parameters

pCommands
An array of command IDs, of menu items, to hide.
nCount
Size of the array passed in.

Remarks

The command will not be displayed in popup menus until the user clicks on the "expand menu" chevron or after a short delay when bShowFullAfterDelay is TRUE. Note: bAlwaysShowFullMenus must set to FALSE to hide the hidden commands

Group

CXTPCommandBars Methods


CXTPCommandBars::HideKeyboardTips Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::HideKeyboardTips Method

Removes all keyboard tips

void HideKeyboardTips();
See Also

ShowKeyboardTips

Group

CXTPCommandBars Methods


CXTPCommandBars::InvalidateCommandBars Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::InvalidateCommandBars Method

Call this member to invalidate the command bars.

void InvalidateCommandBars();
Group

CXTPCommandBars Methods


CXTPCommandBars::IsActionsEnabled Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::IsActionsEnabled Method

Determines if EnableActions method was called

BOOL IsActionsEnabled() const;
Body Source
BOOL CXTPCommandBars::IsActionsEnabled() const {
    return this == NULL ? FALSE : m_bEnableActions;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::IsCommandHidden Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::IsCommandHidden Method

Call this member function to retrieve if the command is hidden until activated by clicking on the chevron. I.e. Infrequently used commands.

virtual BOOL IsCommandHidden(
    UINT nCommand
);
Parameters

nCommand
Command id to check.

Returns

TRUE if the command item is hidden; otherwise returns FALSE.

Remarks

The command will not be displayed in popup menus until the user clicks on the "expand menu" chevron or after a short delay when bShowFullAfterDelay is TRUE. Note: bAlwaysShowFullMenus must set to FALSE to hide the hidden commands

Group

CXTPCommandBars Methods


CXTPCommandBars::IsControlHidden Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::IsControlHidden Method

Call this member function to retrieve if the control is hidden and of type CXTPControlPopup when bAutoHideUnusedPopups is TRUE.

virtual BOOL IsControlHidden(
    CXTPControl* pControl
);
Parameters

pControl
Control pointer to check.

Returns

TRUE if the control item is hidden; otherwise returns FALSE.

Remarks

If bAutoHideUnusedPopups is FALSE, then this member performs the same action as IsCommandHidden. Override this member to provide custom intelligent menu scheme.

Group

CXTPCommandBars Methods


CXTPCommandBars::IsCustomizeAvail Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::IsCustomizeAvail Method

Call this member to retrieve if the customize is avail.

BOOL IsCustomizeAvail() const;
Returns

TRUE if customize avail; otherwise returns FALSE

Body Source
BOOL CXTPCommandBars::IsCustomizeAvail() const {
    return m_bCustomizeAvail;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::IsCustomizeMode Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::IsCustomizeMode Method

Call this member to retrieve the customize mode of the command bars.

BOOL IsCustomizeMode() const;
Returns

TRUE if command bars in customize mode; otherwise returns FALSE

Body Source
BOOL IsCustomizeMode() const { return m_bCustomizeMode;}
Group

CXTPCommandBars Methods


CXTPCommandBars::IsLayoutRTL Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::IsLayoutRTL Method

Determines if right-to-left mode was set.

BOOL IsLayoutRTL() const;
Returns

TRUE if text is displayed using right-to-left reading-order properties.

Group

CXTPCommandBars Methods


CXTPCommandBars::IsQuickCustomizeMode Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBars::IsQuickCustomizeMode Method

Call this member to retrieve the customize mode of the command bars.

BOOL IsQuickCustomizeMode() const;
Returns

TRUE if command bars in customize mode; otherwise returns FALSE

See Also

SetQuickCustomizeMode

Body Source
BOOL IsQuickCustomizeMode() const { return m_bQuickCustomizeMode;}
Group

CXTPCommandBars Methods


CXTPCommandBars::LoadBarState Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::LoadBarState Method

Call this function to retrieve state information from the registry or .INI file.

void LoadBarState(
    LPCTSTR lpszProfileName,
    BOOL bSilent = FALSE
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
bSilent
TRUE to disable user notifications when command bars are restore to their original state.

See Also

SaveBarState, DoPropExchange

Group

CXTPCommandBars Methods


LoadDesignerBars Method

CXTPCommandBars Methods
LoadDesignerBars Method
Overload List
Methods
Method | Description
CXTPCommandBars::LoadDesignerBars (CArchive&) | Call this member function to load designer command bars from an archive.
CXTPCommandBars::LoadDesignerBars (CXTPPropExchange*) | Call this member function to load designer command bars from an archive.
Group

CXTPCommandBars Methods


CXTPCommandBars::LoadDesignerBars Method (CArchive&)

LoadDesignerBars Method, CXTPCommandBars Class
CXTPCommandBars::LoadDesignerBars Method (CArchive&)

Call this member function to load designer command bars from an archive.

void LoadDesignerBars(
    CArchive& ar
);
void LoadDesignerBars(
    CXTPPropExchange* pPX
);
Parameters

ar
A CArchive object to serialize to or from.
pPX
A CXTPPropExchange object to serialize to or from.

Group

LoadDesignerBars Method


CXTPCommandBars::LoadOptions Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::LoadOptions Method

Call this function to restore the options of the command bars.

void LoadOptions(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

See Also

SaveOptions, DoPropExchange

Group

CXTPCommandBars Methods


CXTPCommandBars::OnFrameAccel Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::OnFrameAccel Method

This method is called when user press Alt + char

BOOL OnFrameAccel(
    UINT chAccel
);
Parameters

chAccel
Character was pressed

Returns

TRUE if command bars processed this character

Group

CXTPCommandBars Methods


CXTPCommandBars::OnFrameWndMsg Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::OnFrameWndMsg Method

Call this method to process frame messages. CXTPFrameWndBase derived classes call this method automatically.

BOOL OnFrameWndMsg(
    UINT message,
    WPARAM wParam,
    LPARAM lParam,
    LRESULT* pResult
);
Parameters

message
Specifies the message to be sent.
wParam
Specifies additional message-dependent information.
lParam
Specifies additional message-dependent information.
pResult
The return value of WindowProc. Depends on the message; may be NULL.

Returns

TRUE if the message was handled; otherwise FALSE.

Group

CXTPCommandBars Methods


CXTPCommandBars::OnSetPreviewMode Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::OnSetPreviewMode Method

Call this member function to set the application's command bars into and out of print-preview mode.

void OnSetPreviewMode(
    BOOL bPreview
);
Parameters

bPreview
Specifies whether or not to place the application in print-preview mode. Set to TRUE to place in print preview, FALSE to cancel preview mode.

Group

CXTPCommandBars Methods


CXTPCommandBars::OnToolBarAdded Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::OnToolBarAdded Method

This method is called when new toolbar was added.

virtual void OnToolBarAdded(
    CXTPToolBar* pToolBar
);
Parameters

pToolBar
Pointer to new toolbar.

Group

CXTPCommandBars Methods


CXTPCommandBars::OnToolBarRemoved Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::OnToolBarRemoved Method

This method is called when new toolbar was removed

virtual void OnToolBarRemoved(
    CXTPToolBar* pToolBar
);
Parameters

pToolBar
Pointer to toolbar was removed.

Group

CXTPCommandBars Methods


CXTPCommandBars::OnTrackingModeChanged Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::OnTrackingModeChanged Method

This method is called when tracking mode of commandbar was changed

virtual void OnTrackingModeChanged(
    CXTPCommandBar* pCommandBar,
    int bMode
);
Parameters

pCommandBar
Pointer to commandbar who's mode has changed
bMode
new mode the commandbar changed to.

Group

CXTPCommandBars Methods


CXTPCommandBars::PreTranslateFrameMessage Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::PreTranslateFrameMessage Method

Call this method to process frame messages. CXTPFrameWndBase derived classes call this method automatically.

BOOL PreTranslateFrameMessage(
    MSG* pMsg
);
Parameters

pMsg
Points to an MSG object

Returns

TRUE if the message was handled; otherwise FALSE.

Group

CXTPCommandBars Methods


CXTPCommandBars::RecalcFrameLayout Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::RecalcFrameLayout Method

Call this member to recalculate site layout.

virtual void RecalcFrameLayout(
    BOOL bDelay = FALSE
);
Parameters

bDelay
TRUE to delay dock site layout until remaining framework items have been initialized completely.

Group

CXTPCommandBars Methods


CXTPCommandBars::RedrawCommandBars Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::RedrawCommandBars Method

Call this member to redraw the command bars.

void RedrawCommandBars();
Group

CXTPCommandBars Methods


CXTPCommandBars::Remove Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::Remove Method

Call this member to remove the toolbar.

void Remove(
    CXTPToolBar* pToolBar
);
Parameters

pToolBar
Points to a CXTPToolBar object to remove.

Group

CXTPCommandBars Methods


CXTPCommandBars::RemoveAll Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::RemoveAll Method

Call this member to remove all toolbars.

void RemoveAll();
Group

CXTPCommandBars Methods


CXTPCommandBars::ResetUsageData Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::ResetUsageData Method

Call this member function to restore the state of the hidden commands.

void ResetUsageData();
Group

CXTPCommandBars Methods


CXTPCommandBars::SaveBarState Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::SaveBarState Method

Call this function to save the state information to the registry or .INI file.

void SaveBarState(
    LPCTSTR lpszProfileName,
    BOOL bOnlyCustomized = TRUE
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
bOnlyCustomized
TRUE to save only the state for customized command bar items.

See Also

LoadBarState, DoPropExchange

Group

CXTPCommandBars Methods


CXTPCommandBars::SaveOptions Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::SaveOptions Method

Call this function to save the command bars options.

void SaveOptions(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

See Also

LoadOptions, DoPropExchange

Group

CXTPCommandBars Methods


CXTPCommandBars::SerializeBarState Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::SerializeBarState Method

Call this function to either read or write command bars from or to an archive.

void SerializeBarState(
    CArchive& ar,
    BOOL bSerializeControls = FALSE,
    BOOL bOnlyCustomized = TRUE,
    BOOL bSilent = FALSE
);
Parameters

ar
A CArchive object to serialize to or from.
bSerializeControls
TRUE to store controls information.
bOnlyCustomized
TRUE to store each commandbar only if it was customized by user.
bSilent
TRUE to disable user notifications when command bars are restore to their original state.

See Also

DoPropExchange

Group

CXTPCommandBars Methods


CXTPCommandBars::SetCommandUsed Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetCommandUsed Method

Call this member function to set the command activated by user.

void SetCommandUsed(
    UINT nCommand
);
Parameters

nCommand
Command id to set

Group

CXTPCommandBars Methods


CXTPCommandBars::SetCustomizationDataFileName Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBars::SetCustomizationDataFileName Method

Call this method to set customization file path

void SetCustomizationDataFileName(
    LPCTSTR lpszFile
);
Parameters

lpszFile
Path to customization file information

Remarks

CommandBars can't store to registry customization information greater than 16kb, so it creates file with user customization information. If file not specified current directory will be used to save customization.

Example
if (GetAppDataFolder(strAppDataFolder))
{
    CreateDirectory(strAppDataFolder + _T("\") + AfxGetApp()->m_pszAppName, NULL);

     // Set customization path as "\Documents and Settings\user\Application Data\CustomThemes\CommandBars"
     GetCommandBars()->SetCustomizationDataFileName(strAppDataFolder + _T("\") + AfxGetApp()->m_pszAppName + _T("\") + lpszProfileName);
}
Body Source
void CXTPCommandBars::SetCustomizationDataFileName(LPCTSTR lpszFile) {
    m_strControlsFileName = lpszFile;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::SetCustomizeMode Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetCustomizeMode Method

Call this member to set customize mode of the command bars.

void SetCustomizeMode(
    BOOL bMode
);
Parameters

bMode
TRUE to set customize mode.

Group

CXTPCommandBars Methods


CXTPCommandBars::SetDockBarClass Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::SetDockBarClass Method

Call this method to set default dockbar class

static void SetDockBarClass(
    CRuntimeClass* pDockBarClass
);
Parameters

pDockBarClass
Runtime class of dockbar will be added.

Body Source
void CXTPCommandBars::SetDockBarClass(CRuntimeClass* pDockBarClass) {
    m_pDockBarClass = pDockBarClass;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::SetDockState Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetDockState Method

Call this member function to apply state information stored in a CXTPDockState object to the frame window's control bars.

void SetDockState(
    CXTPDockState& state
);
Parameters

state
Apply the stored state to the frame window's control bars.

Group

CXTPCommandBars Methods


CXTPCommandBars::SetDragControl Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetDragControl Method

This method is called when customized control changed.

void SetDragControl(
    CXTPControl* pControl
);
Parameters

pControl
Points to a CXTPControl object

Group

CXTPCommandBars Methods


CXTPCommandBars::SetImageManager Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetImageManager Method

Call this member to set the specified image manager.

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Points to a CXTPPaintManager object

Group

CXTPCommandBars Methods


CXTPCommandBars::SetLayoutRTL Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetLayoutRTL Method

Call this member to set right-to-left mode.

void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPCommandBars Methods


CXTPCommandBars::SetMenu Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::SetMenu Method

Call this member to create menu bar.

CXTPMenuBar* SetMenu(
    LPCTSTR lpszName,
    UINT nID
);
Parameters

lpszName
Title of menu bar.
nID
menu identifier to be loaded.

Returns

A CXTPMenuBar object if successful; otherwise NULL.

See Also

Add

Group

CXTPCommandBars Methods


CXTPCommandBars::SetMenuBarClass Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::SetMenuBarClass Method

Call this method to set default menubar class

static void SetMenuBarClass(
    CRuntimeClass* pMenuBarClass
);
Parameters

pMenuBarClass
Runtime class of menu will be added.

Body Source
void CXTPCommandBars::SetMenuBarClass(CRuntimeClass* pMenuBarClass) {
    m_pMenuBarClass = pMenuBarClass;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::SetPaintManager Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetPaintManager Method

Call this member to set the specified paint manager.

void SetPaintManager(
    CXTPPaintManager* pPaintManager
);
Parameters

pPaintManager
Points to a CXTPPaintManager object

Group

CXTPCommandBars Methods


CXTPCommandBars::SetPopupBarClass Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::SetPopupBarClass Method

Call this method to set default popupbar class

static void SetPopupBarClass(
    CRuntimeClass* pPopupBarClass
);
Parameters

pPopupBarClass
Runtime class of popups will be added.

Body Source
void CXTPCommandBars::SetPopupBarClass(CRuntimeClass* pPopupBarClass) {
    m_pPopupBarClass = pPopupBarClass;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::SetPopupToolBarClass Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source
CXTPCommandBars::SetPopupToolBarClass Method

Call this method to set default popup toolbar class

static void SetPopupToolBarClass(
    CRuntimeClass* pPopupToolBarClass
);
Parameters

pPopupToolBarClass
Runtime class of popups will be added.

Body Source
void CXTPCommandBars::SetPopupToolBarClass(CRuntimeClass* pPopupToolBarClass) {
    m_pPopupToolBarClass = pPopupToolBarClass;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::SetQuickCustomizeMode Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::SetQuickCustomizeMode Method

Call this member to set customize mode of the command bars.

void SetQuickCustomizeMode(
    BOOL bMode
);
Parameters

bMode
TRUE to set customize mode.

See Also

IsQuickCustomizeMode

Group

CXTPCommandBars Methods


CXTPCommandBars::SetShortcutManager Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::SetShortcutManager Method

Call this function to set custom shortcut manager class.

void SetShortcutManager(
    CXTPShortcutManager* pShortcutManager
);
Parameters

pShortcutManager
New ShortcutManager to be set

See Also

GetShortcutManager

Group

CXTPCommandBars Methods


CXTPCommandBars::SetSite Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetSite Method

This method is called to set the site window.

void SetSite(
    CWnd* pFrame
);
Parameters

pFrame
Points to a CWnd object

Group

CXTPCommandBars Methods


CXTPCommandBars::SetTheme Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetTheme Method

Call this member to set the specified paint manager.

void SetTheme(
    XTPPaintTheme paintTheme
);
Parameters

paintTheme
Visual theme to be set

Group

CXTPCommandBars Methods


CXTPCommandBars::SetToolBarClass Method

CXTPCommandBars Methods, CXTPCommandBars Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBars::SetToolBarClass Method

Call this method to set default toolbar class

static void SetToolBarClass(
    CRuntimeClass* pToolBarClass
);
Parameters

pToolBarClass
Runtime class of toolbars will be added.

See Also

SetMenuBarClass, SetPopupBarClass

Example
class CSystemToolBar : public CXTPToolBar
{
    DECALRE_DYNCREATE(CSystemToolBar)

    ....

}

pCommandBars->SetToolBarClass(RUNTIME_CLASS(CSystemToolBar));

CXTPToolBar* pToolBar = pCommandBars->Add("New ToolBar", xtpBarTop);
ASSERT_KINDOF(CSystemToolBar, pToolBar);
Body Source
void CXTPCommandBars::SetToolBarClass(CRuntimeClass* pToolBarClass) {
    m_pToolBarClass = pToolBarClass;
}
Group

CXTPCommandBars Methods


CXTPCommandBars::SetToolBarFocus Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::SetToolBarFocus Method

This method is called to activate toolbar.

BOOL SetToolBarFocus(
    CXTPToolBar* pCommandBar,
    BOOL bNext = FALSE
);
Parameters

pCommandBar
Toolbar to activate
bNext
TRUE to set foucs to the next toolbar.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPCommandBars Methods


CXTPCommandBars::ShowKeyboardCues Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::ShowKeyboardCues Method

This method is called to show keyboard cues of controls

void ShowKeyboardCues(
    BOOL bShow
);
Parameters

bShow
TRUE to show keyboard cues

Group

CXTPCommandBars Methods


CXTPCommandBars::ShowKeyboardTips Method

CXTPCommandBars Methods, CXTPCommandBars Class, See Also
CXTPCommandBars::ShowKeyboardTips Method

This method is called to show keyboard tips for the commandbar

void ShowKeyboardTips(
    CXTPCommandBar* pCommandBar,
    int nLevel = 1
);
Parameters

pCommandBar
Owner of keyboard tips
nLevel
Keyboard tip level (for RibbonBar)

See Also

HideKeyboardTips

Group

CXTPCommandBars Methods


CXTPCommandBars::ToggleVisible Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::ToggleVisible Method

Call this member to show/hide the toolbar.

void ToggleVisible(
    int nIndex
);
Parameters

nIndex
Index of the toolbar to show or hide.

Group

CXTPCommandBars Methods


TrackPopupMenu Method

CXTPCommandBars Methods
TrackPopupMenu Method
Overload List
Methods
Method | Description
CXTPCommandBars::TrackPopupMenu (CMenu*, UINT, int, int, CWnd*, LPCRECT, CWnd*, CXTPCommandBars*) | Call this member to display a floating pop-up menu at the specified location.
CXTPCommandBars::TrackPopupMenu (CXTPPopupBar*, UINT, int, int, CWnd*, LPCRECT, CWnd*) | Call this member to display a floating pop-up menu at the specified location.
CXTPCommandBars::TrackPopupMenu (UINT, UINT, int, int, LPCRECT) | Call this member to display a floating pop-up menu at the specified location.
Group

CXTPCommandBars Methods


CXTPCommandBars::TrackPopupMenu Method (CMenu*, UINT, int, int, CWnd*, LPCRECT, CWnd*, CXTPCommandBars*)

TrackPopupMenu Method, CXTPCommandBars Class, Example
CXTPCommandBars::TrackPopupMenu Method (CMenu*, UINT, int, int, CWnd*, LPCRECT, CWnd*, CXTPCommandBars*)

Call this member to display a floating pop-up menu at the specified location.

static BOOL TrackPopupMenu(
    CMenu* pMenu,
    UINT nFlags,
    int xPos,
    int yPos,
    CWnd* pWnd,
    LPCRECT rcExclude = NULL,
    CWnd* pWndOwner = NULL,
    CXTPCommandBars* pCommandBars = NULL
);
static BOOL TrackPopupMenu(
    CXTPPopupBar* pPopupBar,
    UINT nFlags,
    int xPos,
    int yPos,
    CWnd* pWnd,
    LPCRECT rcExclude = NULL,
    CWnd* pWndOwner = NULL
);
BOOL TrackPopupMenu(
    UINT nBarID,
    UINT nFlags,
    int x,
    int y,
    LPCRECT rcExclude = NULL
);
BOOL TrackPopupMenuEx(
    CMenu* pMenu,
    UINT nFlags,
    int xPos,
    int yPos,
    CWnd* pWndOwner = NULL,
    LPTPMPARAMS lptpm = NULL
);
Parameters

pMenu
Menu to be popped up
nFlags
Reserved, currently not used
xPos
Specifies the horizontal position in screen coordinates of the popup menu.
yPos
Specifies the vertical position in screen coordinates of the top of the menu on the screen.
pWnd
Identifies the window that owns the popup menu. This window receives all WM_COMMAND messages from the menu.
rcExclude
Reserved, currently not used.
pWndOwner
Points to a CWnd object
pCommandBars
Points to a CXTPCommandBars object.
pPopupBar
Points to a CXTPPopupBar object
lptm
Pointer to a TPMPARAMS structure that specifies an area of the screen the menu should not overlap. This parameter can be NULL.

Returns

TRUE if successful; otherwise returns FALSE

Example
    void CCustomThemesView::OnRButtonDown(UINT /*nFlags*/, CPoint point)
{
ClientToScreen(&point);

CMenu menu;
VERIFY(menu.LoadMenu(IDR_MAINFRAME));

// get a pointer to the application window.
CXTPMDIFrameWnd* pMainWnd = DYNAMIC_DOWNCAST(
    CXTPMDIFrameWnd, AfxGetMainWnd());

if (!pMainWnd)
    return;

// get a pointer to the CXTPCommandBars object.
CXTPCommandBars* pCommandBars = pMainWnd->GetCommandBars();

if (!pCommandBars)
    return;

// display context menu.
CXTPCommandBars::TrackPopupMenu(&menu, TPM_RIGHTBUTTON,
    point.x, point.y, pMainWnd, 0, 0, pCommandBars);
}
Group

TrackPopupMenu Method


CXTPCommandBars::UpdateCommandBars Method

CXTPCommandBars Methods, CXTPCommandBars Class
CXTPCommandBars::UpdateCommandBars Method

Sends WM_IDLEUPDATECMDUI message to all tool bars.

void UpdateCommandBars() const;
Group

CXTPCommandBars Methods


CXTPCommandBars Constructors

CXTPCommandBars Class, Legend, Protected Methods
CXTPCommandBars Constructors
Class

CXTPCommandBars Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPCommandBars | Constructs a CXTPCommandBars object


CXTPCommandBars::CXTPCommandBars Constructor

CXTPCommandBars Constructors, CXTPCommandBars Class
CXTPCommandBars::CXTPCommandBars Constructor

Constructs a CXTPCommandBars object

CXTPCommandBars();
Group

CXTPCommandBars Constructors


CXTPCommandBars Destructors

CXTPCommandBars Class, Legend, Protected Methods
CXTPCommandBars Destructors
Class

CXTPCommandBars Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPCommandBars | Destroys a CXTPCommandBars object, handles cleanup and deallocation


CXTPCommandBars::~CXTPCommandBars Destructor

CXTPCommandBars Destructors, CXTPCommandBars Class
CXTPCommandBars::~CXTPCommandBars Destructor

Destroys a CXTPCommandBars object, handles cleanup and deallocation

virtual ~CXTPCommandBars();
Group

CXTPCommandBars Destructors


CXTPCommandBarsContextMenus Class

XTPCommandBars.h, Classes, Legend, Members, Topics, CXTPCommandBarsContextMenus Methods, CXTPCommandBarsContextMenus Constructors, CXTPCommandBarsContextMenus Constructors, CXTPCommandBarsContextMenus Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsContextMenus Class

CXTPCommandBarsContextMenus is CXTPCommandBarList derived class, represents collection of context menus

Class Hierarchy

class CXTPCommandBarsContextMenus : public CXTPCommandBarList;
File

XTPCommandBars.h

Group

Classes

Legend
Method
CXTPCommandBarsContextMenus Constructors
CXTPCommandBarsContextMenus Constructors | Description
CXTPCommandBarsContextMenus | Constructs a CXTPCommandBarsContextMenus object
CXTPCommandBarsContextMenus Methods
CXTPCommandBarsContextMenus Methods | Description
Add |


CXTPCommandBarsContextMenus Methods

CXTPCommandBarsContextMenus Class, Legend, Public Methods
CXTPCommandBarsContextMenus Methods
Class

CXTPCommandBarsContextMenus Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add |


Add Method

CXTPCommandBarsContextMenus Methods
Add Method
Overload List
Methods
Method | Description
CXTPCommandBarsContextMenus::Add (CXTPCommandBar*) | Call this method to add new context menu to collection
CXTPCommandBarsContextMenus::Add (UINT) | Call this method to add new context menu to collection
CXTPCommandBarsContextMenus::Add (UINT, LPCTSTR, CMenu*) | Call this method to add new context menu to collection
Group

CXTPCommandBarsContextMenus Methods


CXTPCommandBarsContextMenus::Add Method (UINT)

Add Method, CXTPCommandBarsContextMenus Class
CXTPCommandBarsContextMenus::Add Method (UINT)

Call this method to add new context menu to collection

CXTPCommandBar* Add(
    UINT nIDBar
);
CXTPCommandBar* Add(
    CXTPCommandBar* pCommandBar
);
CXTPCommandBar* Add(
    UINT nIDBar,
    LPCTSTR lpszTitle,
    CMenu* pSubMenu
);
Parameters

nIDBar
Menu resource identifier
pCommandBar
CmmandBar to be added
lpszTitle
Caption of context menu
pSubMenu
Context menu to convert

Returns

Pointer to added context menu.

Group

Add Method


CXTPCommandBarsContextMenus Constructors

CXTPCommandBarsContextMenus Class, Legend, Public Methods
CXTPCommandBarsContextMenus Constructors
Class

CXTPCommandBarsContextMenus Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarsContextMenus | Constructs a CXTPCommandBarsContextMenus object


CXTPCommandBarsContextMenus::CXTPCommandBarsContextMenus Constructor

CXTPCommandBarsContextMenus Constructors, CXTPCommandBarsContextMenus Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsContextMenus::CXTPCommandBarsContextMenus Constructor

Constructs a CXTPCommandBarsContextMenus object

CXTPCommandBarsContextMenus(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
Parent CXTPCommandBars object

Group

CXTPCommandBarsContextMenus Constructors


CXTPCommandBarsOptions Class

XTPCommandBars.h, Classes, Legend, Members, Topics, CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Methods, CXTPCommandBarsOptions Constructors, CXTPCommandBarsOptions Constructors, CXTPCommandBarsOptions Data Members, Example, CXTPCommandBarsOptions Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions Class

Options of the command bars.

Class Hierarchy

class CXTPCommandBarsOptions;
File

XTPCommandBars.h

See Also

CXTPCommandBars::GetCommandBarsOptions

Example
pCommandBars->GetCommandBarsOptions()->animationType = xtpAnimateFade;
Group

Classes

Legend
Data Member
Method
CXTPCommandBarsOptions Constructors
CXTPCommandBarsOptions Constructors | Description
CXTPCommandBarsOptions | Constructs an CXTPCommandBarsOptions object
CXTPCommandBarsOptions Data Members
CXTPCommandBarsOptions Data Members | Description
animationType | Animation type.
bAltDragCustomization | Allows users to change a toolbar button's position by dragging it while holding down ALT.
bAlwaysShowFullMenus | TRUE to show full menus always.
bAutoHideUnusedPopups | TRUE to hide unused popup controls.
bAutoUpdateShortcuts | TRUE to update shortcuts from accelerator table
bDblClickFloat | TRUE to make toolbar floating be double-clicking.
bDirtyState | TRUE if the user has done any type of customization to menus or toolbars.
bDisableCommandIfNoHandler | TRUE to disable commands if no handler presented
bFlyByStatus | Status bar displays information about the button
bLargeIcons | TRUE to use large toolbars icons.
bShowExpandButtonAlways | TRUE to show expand buttons always.
bShowFullAfterDelay | TRUE to show full menus after short delay.
bShowKeyboardTips | TRUE to use keyboard tips.
bShowPopupBarToolTips | TRUE to display ToolTips for controls in popup menus.
bShowTextBelowIcons | TRUE to show captions below icons.
bSyncFloatingBars | TRUE to hide floating bars when site frame deactivated.
bToolBarAccelTips | TRUE to add accelerators to tooltips.
bToolBarScreenTips | TRUE to show toolbar's tooltips
bUseAltNumPadKeys | TRUE to allow activate menu with Alt + num pad key.
bUseSystemSaveBitsStyle | TRUE to use CS_SAVEBITS class style for popups and shadows
bWrapLargePopups | Wrap controls for large popups instead scroll them.
keyboardCuesUse | Keyboard cues using
m_mapHiddenCommands | Hidden command array.
m_mapUsedCommands | Used commands array.
szIcons | Size of the normal icons.
szLargeIcons | Size of the large icons.
szPopupIcons | Size of icons displayed in popup menus.
CXTPCommandBarsOptions Methods
CXTPCommandBarsOptions Methods | Description
DoPropExchange | Reads or writes options from or to an archive.
GetShowKeyboardCues | Call this method to get menu underlines state
Serialize | Reads or writes options from or to an archive.
ShowKeyboardCues | Call this method to enable/disble menu underlines.


CXTPCommandBarsOptions Data Members

CXTPCommandBarsOptions Class, Legend, Public Data Members
CXTPCommandBarsOptions Data Members
Class

CXTPCommandBarsOptions Class

Legend
Data Member
Public Data Members
Public Data Member | Description
animationType | Animation type.
bAltDragCustomization | Allows users to change a toolbar button's position by dragging it while holding down ALT.
bAlwaysShowFullMenus | TRUE to show full menus always.
bAutoHideUnusedPopups | TRUE to hide unused popup controls.
bAutoUpdateShortcuts | TRUE to update shortcuts from accelerator table
bDblClickFloat | TRUE to make toolbar floating be double-clicking.
bDirtyState | TRUE if the user has done any type of customization to menus or toolbars.
bDisableCommandIfNoHandler | TRUE to disable commands if no handler presented
bFlyByStatus | Status bar displays information about the button
bLargeIcons | TRUE to use large toolbars icons.
bShowExpandButtonAlways | TRUE to show expand buttons always.
bShowFullAfterDelay | TRUE to show full menus after short delay.
bShowKeyboardTips | TRUE to use keyboard tips.
bShowPopupBarToolTips | TRUE to display ToolTips for controls in popup menus.
bShowTextBelowIcons | TRUE to show captions below icons.
bSyncFloatingBars | TRUE to hide floating bars when site frame deactivated.
bToolBarAccelTips | TRUE to add accelerators to tooltips.
bToolBarScreenTips | TRUE to show toolbar's tooltips
bUseAltNumPadKeys | TRUE to allow activate menu with Alt + num pad key.
bUseSystemSaveBitsStyle | TRUE to use CS_SAVEBITS class style for popups and shadows
bWrapLargePopups | Wrap controls for large popups instead scroll them.
keyboardCuesUse | Keyboard cues using
m_mapHiddenCommands | Hidden command array.
m_mapUsedCommands | Used commands array.
szIcons | Size of the normal icons.
szLargeIcons | Size of the large icons.
szPopupIcons | Size of icons displayed in popup menus.


CXTPCommandBarsOptions::animationType Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::animationType Data Member

Animation type.

XTPAnimationType animationType;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bAltDragCustomization Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bAltDragCustomization Data Member

Allows users to change a toolbar button's position by dragging it while holding down ALT.

BOOL bAltDragCustomization;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bAlwaysShowFullMenus Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bAlwaysShowFullMenus Data Member

TRUE to show full menus always.

BOOL bAlwaysShowFullMenus;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bAutoHideUnusedPopups Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bAutoHideUnusedPopups Data Member

TRUE to hide unused popup controls.

BOOL bAutoHideUnusedPopups;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bAutoUpdateShortcuts Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bAutoUpdateShortcuts Data Member

TRUE to update shortcuts from accelerator table

BOOL bAutoUpdateShortcuts;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bDblClickFloat Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bDblClickFloat Data Member

TRUE to make toolbar floating be double-clicking.

BOOL bDblClickFloat;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bDirtyState Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bDirtyState Data Member

TRUE if the user has done any type of customization to menus or toolbars.

BOOL bDirtyState;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bDisableCommandIfNoHandler Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bDisableCommandIfNoHandler Data Member

TRUE to disable commands if no handler presented

BOOL bDisableCommandIfNoHandler;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bFlyByStatus Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bFlyByStatus Data Member

Status bar displays information about the button

BOOL bFlyByStatus;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bLargeIcons Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bLargeIcons Data Member

TRUE to use large toolbars icons.

BOOL bLargeIcons;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bShowExpandButtonAlways Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bShowExpandButtonAlways Data Member

TRUE to show expand buttons always.

BOOL bShowExpandButtonAlways;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bShowFullAfterDelay Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bShowFullAfterDelay Data Member

TRUE to show full menus after short delay.

BOOL bShowFullAfterDelay;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bShowKeyboardTips Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bShowKeyboardTips Data Member

TRUE to use keyboard tips.

BOOL bShowKeyboardTips;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bShowPopupBarToolTips Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bShowPopupBarToolTips Data Member

TRUE to display ToolTips for controls in popup menus.

BOOL bShowPopupBarToolTips;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bShowTextBelowIcons Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bShowTextBelowIcons Data Member

TRUE to show captions below icons.

BOOL bShowTextBelowIcons;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bSyncFloatingBars Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bSyncFloatingBars Data Member

TRUE to hide floating bars when site frame deactivated.

BOOL bSyncFloatingBars;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bToolBarAccelTips Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bToolBarAccelTips Data Member

TRUE to add accelerators to tooltips.

BOOL bToolBarAccelTips;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bToolBarScreenTips Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bToolBarScreenTips Data Member

TRUE to show toolbar's tooltips

BOOL bToolBarScreenTips;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bUseAltNumPadKeys Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bUseAltNumPadKeys Data Member

TRUE to allow activate menu with Alt + num pad key.

BOOL bUseAltNumPadKeys;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bUseSystemSaveBitsStyle Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bUseSystemSaveBitsStyle Data Member

TRUE to use CS_SAVEBITS class style for popups and shadows

BOOL bUseSystemSaveBitsStyle;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::bWrapLargePopups Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::bWrapLargePopups Data Member

Wrap controls for large popups instead scroll them.

BOOL bWrapLargePopups;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::keyboardCuesUse Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::keyboardCuesUse Data Member

Keyboard cues using

DWORD keyboardCuesUse;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::m_mapHiddenCommands Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::m_mapHiddenCommands Data Member

Hidden command array.

CMap<UINT, UINT, BOOL, BOOL> m_mapHiddenCommands;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::m_mapUsedCommands Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::m_mapUsedCommands Data Member

Used commands array.

CMap<UINT, UINT, BOOL, BOOL> m_mapUsedCommands;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::szIcons Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::szIcons Data Member

Size of the normal icons.

CSize szIcons;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::szLargeIcons Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::szLargeIcons Data Member

Size of the large icons.

CSize szLargeIcons;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions::szPopupIcons Data Member

CXTPCommandBarsOptions Data Members, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::szPopupIcons Data Member

Size of icons displayed in popup menus.

CSize szPopupIcons;
Group

CXTPCommandBarsOptions Data Members


CXTPCommandBarsOptions Methods

CXTPCommandBarsOptions Class, Legend, Public Methods
CXTPCommandBarsOptions Methods
Class

CXTPCommandBarsOptions Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Reads or writes options from or to an archive.
GetShowKeyboardCues | Call this method to get menu underlines state
Serialize | Reads or writes options from or to an archive.
ShowKeyboardCues | Call this method to enable/disble menu underlines.


CXTPCommandBarsOptions::DoPropExchange Method

CXTPCommandBarsOptions Methods, CXTPCommandBarsOptions Class
CXTPCommandBarsOptions::DoPropExchange Method

Reads or writes options from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX,
    BOOL bUserOptionsOnly = FALSE
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
bUserOptionsOnly
TRUE to serialize user's options only.

Group

CXTPCommandBarsOptions Methods


CXTPCommandBarsOptions::GetShowKeyboardCues Method

CXTPCommandBarsOptions Methods, CXTPCommandBarsOptions Class
CXTPCommandBarsOptions::GetShowKeyboardCues Method

Call this method to get menu underlines state

XTPKeyboardCuesShow GetShowKeyboardCues() const;
Returns

Returns one of the following:

  • xtpKeyboardCuesShowAlways - Show keyboard cues always
  • xtpKeyboardCuesShowNever - Show keyboard cues always
  • xtpKeyboardCuesShowWindowsDefault - System defined
Group

CXTPCommandBarsOptions Methods


CXTPCommandBarsOptions::Serialize Method

CXTPCommandBarsOptions Methods, CXTPCommandBarsOptions Class
CXTPCommandBarsOptions::Serialize Method

Reads or writes options from or to an archive.

void Serialize(
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.

Group

CXTPCommandBarsOptions Methods


CXTPCommandBarsOptions::ShowKeyboardCues Method

CXTPCommandBarsOptions Methods, CXTPCommandBarsOptions Class
CXTPCommandBarsOptions::ShowKeyboardCues Method

Call this method to enable/disble menu underlines.

void ShowKeyboardCues(
    XTPKeyboardCuesShow keyboardCues
);
Parameters

keyboardCues
determines if menu underlines is enabled.

Remarks

keyboardCues parameter can be one of the following:

  • xtpKeyboardCuesShowAlways - Show keyboard cues always
  • xtpKeyboardCuesShowNever - Show keyboard cues always
  • xtpKeyboardCuesShowWindowsDefault - System defined
Group

CXTPCommandBarsOptions Methods


CXTPCommandBarsOptions Constructors

CXTPCommandBarsOptions Class, Legend, Public Methods
CXTPCommandBarsOptions Constructors
Class

CXTPCommandBarsOptions Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarsOptions | Constructs an CXTPCommandBarsOptions object


CXTPCommandBarsOptions::CXTPCommandBarsOptions Constructor

CXTPCommandBarsOptions Constructors, CXTPCommandBarsOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsOptions::CXTPCommandBarsOptions Constructor

Constructs an CXTPCommandBarsOptions object

CXTPCommandBarsOptions();
Group

CXTPCommandBarsOptions Constructors


CXTPCommandBarsSiteBase Template

XTPFrameWnd.h, Classes, Legend, Members, Topics, CXTPCommandBarsSiteBase Methods, CXTPCommandBarsSiteBase Constructors, CXTPCommandBarsSiteBase Destructors, CXTPCommandBarsSiteBase Constructors, CXTPCommandBarsSiteBase Destructors, CXTPCommandBarsSiteBase Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsSiteBase Template

CXTPCommandBarsSiteBase is a stand alone class. It represents site for Command Bars object

Class Hierarchy

template <class TBase>
class CXTPCommandBarsSiteBase : public TBase;
File

XTPFrameWnd.h

Group

Classes

Legend
Method
CXTPCommandBarsSiteBase Constructors
CXTPCommandBarsSiteBase Constructors | Description
CXTPCommandBarsSiteBase | Constructs a CXTPCommandBarsSiteBase object
CXTPCommandBarsSiteBase Destructors
CXTPCommandBarsSiteBase Destructors | Description
~CXTPCommandBarsSiteBase | Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation
CXTPCommandBarsSiteBase Methods
CXTPCommandBarsSiteBase Methods | Description
DockRightOf | This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
GetCommandBars | Call this member to retrieve a pointer to the CommandBars object.
InitCommandBars | Creates command bars.
LoadCommandBars | Call this function to retrieve state information from the registry or .INI file.
SaveCommandBars | Call this function to save the state information to the registry or .INI file.


CXTPCommandBarsSiteBase Methods

CXTPCommandBarsSiteBase Template, Legend, Public Methods
CXTPCommandBarsSiteBase Methods
Template

CXTPCommandBarsSiteBase Template

Legend
Method
Public Methods
Public Methods
Public Method | Description
DockRightOf | This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
GetCommandBars | Call this member to retrieve a pointer to the CommandBars object.
InitCommandBars | Creates command bars.
LoadCommandBars | Call this function to retrieve state information from the registry or .INI file.
SaveCommandBars | Call this function to save the state information to the registry or .INI file.


CXTPCommandBarsSiteBase::DockRightOf Method

CXTPCommandBarsSiteBase Methods, CXTPCommandBarsSiteBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsSiteBase::DockRightOf Method

This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.

void DockRightOf(
    CXTPToolBar* pBarToDock,
    CXTPToolBar* pBarOnLeft
);
Parameters

pBarToDock
A CXTPToolBar pointer to the toolbar to be docked.
pBarOnLeft
A CXTPToolBar pointer to the already docked toolbar.

Body Source
void DockRightOf(CXTPToolBar* pBarToDock, CXTPToolBar* pBarOnLeft)
{
    RepositionBars(AFX_IDW_CONTROLBAR_FIRST, AFX_IDW_CONTROLBAR_LAST, AFX_IDW_PANE_FIRST);

    CXTPWindowRect rcBar(pBarOnLeft);

    if (IsVerticalPosition(pBarOnLeft->GetPosition())) rcBar.OffsetRect(0, rcBar.Height());
        else rcBar.OffsetRect(rcBar.Width(), 0);

    GetCommandBars()->DockCommandBar(pBarToDock, rcBar, pBarOnLeft->GetDockBar());
}
Group

CXTPCommandBarsSiteBase Methods


CXTPCommandBarsSiteBase::GetCommandBars Method

CXTPCommandBarsSiteBase Methods, CXTPCommandBarsSiteBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsSiteBase::GetCommandBars Method

Call this member to retrieve a pointer to the CommandBars object.

CXTPCommandBars* GetCommandBars() const;
Returns

Retrieves Command Bars object.

Body Source
CXTPCommandBars* GetCommandBars() const { return m_pCommandBars; }
Group

CXTPCommandBarsSiteBase Methods


CXTPCommandBarsSiteBase::InitCommandBars Method

CXTPCommandBarsSiteBase Methods, CXTPCommandBarsSiteBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsSiteBase::InitCommandBars Method

Creates command bars.

BOOL InitCommandBars(
    CRuntimeClass* pCommandBarsClass = RUNTIME_CLASS(CXTPCommandBars)
);
Parameters

pCommandBarsClass
Custom runtime class of CommandBars. It can be used if you want to override some methods of CXTPCommandBars class.

Returns

Nonzero if successful; otherwise 0.

Body Source
BOOL InitCommandBars(CRuntimeClass* pCommandBarsClass = RUNTIME_CLASS(CXTPCommandBars))
{
    ASSERT(pCommandBarsClass->IsDerivedFrom(RUNTIME_CLASS(CXTPCommandBars)));
    m_pCommandBars =  (CXTPCommandBars*) pCommandBarsClass->CreateObject();
    ASSERT(m_pCommandBars);
    if (!m_pCommandBars)
        return FALSE;
    m_pCommandBars->SetSite(this);
    m_pCommandBars->EnableDocking();
    return TRUE;
}
Group

CXTPCommandBarsSiteBase Methods


CXTPCommandBarsSiteBase::LoadCommandBars Method

CXTPCommandBarsSiteBase Methods, CXTPCommandBarsSiteBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsSiteBase::LoadCommandBars Method

Call this function to retrieve state information from the registry or .INI file.

void LoadCommandBars(
    LPCTSTR lpszProfileName,
    BOOL bSilent = FALSE
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
bSilent
TRUE to disable user notifications when command bars are restore to their original state.

Body Source
void LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent = FALSE)
{
    if (m_pCommandBars)
    {
        m_pCommandBars->LoadOptions(lpszProfileName);
        m_pCommandBars->LoadBarState(lpszProfileName, bSilent);
        m_pCommandBars->GetShortcutManager()->LoadShortcuts(lpszProfileName);
    }
}
Group

CXTPCommandBarsSiteBase Methods


CXTPCommandBarsSiteBase::SaveCommandBars Method

CXTPCommandBarsSiteBase Methods, CXTPCommandBarsSiteBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsSiteBase::SaveCommandBars Method

Call this function to save the state information to the registry or .INI file.

void SaveCommandBars(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

Body Source
void SaveCommandBars(LPCTSTR lpszProfileName)
{
    if (m_pCommandBars)
    {
        m_pCommandBars->SaveOptions(lpszProfileName);
        m_pCommandBars->SaveBarState(lpszProfileName);
        m_pCommandBars->GetShortcutManager()->SaveShortcuts(lpszProfileName);
    }
}
Group

CXTPCommandBarsSiteBase Methods


CXTPCommandBarsSiteBase Constructors

CXTPCommandBarsSiteBase Template, Legend, Public Methods
CXTPCommandBarsSiteBase Constructors
Template

CXTPCommandBarsSiteBase Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarsSiteBase | Constructs a CXTPCommandBarsSiteBase object


CXTPCommandBarsSiteBase::CXTPCommandBarsSiteBase Constructor

CXTPCommandBarsSiteBase Constructors, CXTPCommandBarsSiteBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsSiteBase::CXTPCommandBarsSiteBase Constructor

Constructs a CXTPCommandBarsSiteBase object

CXTPCommandBarsSiteBase();
Body Source
CXTPCommandBarsSiteBase()
{
    m_pCommandBars = 0;
}
Group

CXTPCommandBarsSiteBase Constructors


CXTPCommandBarsSiteBase Destructors

CXTPCommandBarsSiteBase Template, Legend, Public Methods
CXTPCommandBarsSiteBase Destructors
Template

CXTPCommandBarsSiteBase Template

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCommandBarsSiteBase | Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation


CXTPCommandBarsSiteBase::~CXTPCommandBarsSiteBase Destructor

CXTPCommandBarsSiteBase Destructors, CXTPCommandBarsSiteBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCommandBarsSiteBase::~CXTPCommandBarsSiteBase Destructor

Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation

~CXTPCommandBarsSiteBase();
Body Source
~CXTPCommandBarsSiteBase()
{
    if (m_pCommandBars)
    {
        m_pCommandBars->InternalRelease();
    }
}
Group

CXTPCommandBarsSiteBase Destructors


CXTPControl Class

XTPControl.h, Classes, Legend, Members, Topics, CXTPControl Data Members, CXTPControl Methods, CXTPControl Constructors, CXTPControl Destructors, CXTPControl Constructors, CXTPControl Data Members, CXTPControl Destructors, CXTPControl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl Class

CXTPControl is a CCmdTarget derived class. It represents the parent class for the command bar's controls.

Class Hierarchy

class CXTPControl;
File

XTPControl.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControl Constructors
CXTPControl Constructors | Description
CXTPControl | Constructs a CXTPControl object
CXTPControl Data Members
CXTPControl Data Members | Description
m_bBeginGroup | TRUE if the control starts new group.
m_bChecked | TRUE if the control is checked.
m_bCloseSubMenuOnClick | TRUE is sub-menus are closed as soon as a control is clicked.
m_bDefaultItem | TRUE if the item is default popup item;
m_bEnabled | TRUE if the control is enabled.
m_bExpanded | TRUE if the control is expanded.
m_bPressed | TRUE if the control is pushed.
m_bSelected | TRUE if the control is selected.
m_bTemporary | TRUE if the control is temporary.
m_buttonCustomStyle | User defined style of button.
m_buttonRibbonStyle | User defined style of button.
m_buttonStyle | Button Style.
m_bWrap | TRUE if the control is wrapped.
m_controlType | Type of the control.
m_dwFlags | Flags of the control.
m_dwHideFlags | Hidden flags.
m_mapDocTemplatesAssigned | Assigned templates.
m_mapDocTemplatesExcluded | Excluded templates.
m_nCustomIconId | Identifier of the control's custom image.
m_nExecuteOnPressInterval | Delay between each message when control is pressed.
m_nHeight | Height of the control.
m_nHelpId | Help identifier
m_nIconId | Identifier of the control's image.
m_nId | Identifier of the control.
m_nIndex | Index of the control.
m_nTag | Control tag.
m_nWidth | Width of the control.
m_pAction | Action of the control.
m_pControls | Parent control collection
m_pParent | The Parent command bar.
m_pRibbonGroup | Ribbon group of control
m_rcControl | Bounding rectangle of the control.
m_rcRow | Bounding rectangle of the control's row.
m_strCaption | Caption of the control.
m_strCategory | Category of the control.
m_strCustomCaption | User defined caption.
m_strDescriptionText | Description text.
m_strKeyboardTip | Keyboard tip
m_strParameter | Parameter text.
m_strShortcutText | Shortcut text.
m_strShortcutTextAuto | Shortcut text.
m_strTooltipText | Tooltip text.
CXTPControl Destructors
CXTPControl Destructors | Description
~CXTPControl | Destroys a CXTPControl object, handles cleanup and deallocation
CXTPControl Methods
CXTPControl Methods | Description
AssignDocTemplate | Call this method to assign a document template to the control. Assigned control will be shown only when the child MDI window is activated with the assigned document template.
ClickToolBarButton | This helper method is called when the user clicks to the toolbar's button.
Compare | Call this member to compare controls.
Copy | This method is called to copy the control.
CustomizeStartDrag | This member is called when the user starts to drag the control in customize mode.
CustomizeStartResize | This method is called when user starts resize control in customize mode
DelayLayoutParent | Call this method to recalculate the parent command bar size.
DelayRedrawParent | Call this method to redraw the parent command bar.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
ExcludeDocTemplate | Call this method to exclude the document template from control. Control will be shown only when the child MDI window is activated with the document template different from excluded.
FromUI | Call this member to retrieve CXTPControl from CCmdUI structure.
GenerateCommandBarList | This method is called from SaveCommandBars to save all child commandbars
GetAction | Call this method to retrieve action associated with control
GetBeginGroup | Call this member to determine if the control has a separator.
GetButtonSize | Call this function to get the size of the command bar button.
GetCaption | Call this member to get the control's caption.
GetCategory | Call this method to retrieve the category of the control.
GetChecked | Call this member to get the state of the control.
GetCloseSubMenuOnClick | Call this member function to determine if sub menus will close as soon as a control is clicked.
GetCommandBar | Call this member to get the child command bar.
GetControls | Call this member to get the parent controls collection.
GetCustomizeMinWidth | Retrieves available minimum width of control.
GetDescription | Call this member to get the control's description.
GetEnabled | Call this member to get the state of the control.
GetExecuteOnPressInterval | Determines if SetExecuteOnPressInterval was called
GetExpanded | Call this member to retrieve if the control is expanded.
GetFlags | Call this member to retrieve control special flags.
GetHeight | Call this member to get the height of the control
GetHelpId | Call this member to get the help identifier.
GetHideFlags | Call this method to retrieve hidden flags.
GetIconId | Call this member to get the icon's identifier.
GetIconSize | Call this member function to get the size of a toolbar icon.
GetID | Call this member to get the control's identifier.
GetImage | Call this method to retrieve the image of the control.
GetImageManager | Call this method to retrieve the image manager.
GetIndex | Call this member to get the index of the control.
GetKeyboardTip | Call this member to get the keyboard tip.
GetPaintManager | Call this method to retrieve the paint manager.
GetParameter | Call this member to get the control's parameter.
GetParent | Call this member to get the parent command bar.
GetPopuped | Call this member to get the control's popup state.
GetPressed | Call this member to get the state of the control.
GetRect | Call this member to get the bounding rectangle of the control.
GetRibbonGroup | Returns the ribbon group the control belongs to.
GetRowRect | Call this method to retrieve the position of the control's row.
GetSelected | Call this member to get the state of the control.
GetShortcutText | Call this member to get the control's shortcut.
GetSize | This method is called to determine the size of the control.
GetStyle | Call this member to get the control's style.
GetTag | This method retrieves the application-supplied 32-bit value associated with the control.
GetTooltip | Call this member to get the control's tooltip.
GetType | Call this member to get the control's type
GetWidth | Call this member to get the width of the control
GetWrap | Call this method to retrieve if the control is wrapped.
HasDwmCompositedRect | This method is called to determine if control has Vista DWM transparent area
IsCaptionVisible | Call this member to determine if the caption of the control is visible
IsCursorOver | Call this member to determine if the mouse pointer is over the control.
IsCustomizeDragOverAvail | This member checks if the user can drop the control.
IsCustomizeMode | Call this method to determine if command bars is in customize mode.
IsCustomizeMovable | This method is called to determine if control can be reposition in customize mode.
IsCustomizeResizeAllow | This member checks if the user can resize control.
IsFocusable | This method is called to check if control accept focus
IsFocused | Call this member to get the focused state of the control.
IsItemDefault | Call this method to retrieve if control is default menu item.
IsTemporary | Call this method to determine if control is temporary. Temporary controls will not be saved to the system registry when the application is closed (If the CommandBars layout is saved).
IsTransparent | Determines if control need to draw its background
IsVisible | Call this member to determine if the control is visible.
NotifySite | This method is called to sent message code to parent site window.
OnActionChanged | This method is called when action property was changed
OnActionChanging | This method is called when action property is about to be changed
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnCustomizeDragOver | This member is called when the user moves the mouse over the control.
OnCustomizeMouseMove | This member is called when the mouse cursor moves in customized mode
OnExecute | This method is called when the control is executed.
OnHookKeyDown | This method is called when a non-system key is pressed.
OnHookMouseWheel | This method is called when user rotates the mouse wheel.
OnIdleUpdate | This virtual method is called in idle-time processing
OnLButtonDblClk | This member is called when the user double-clicks the left mouse button.
OnLButtonUp | This member is called when the user releases the left mouse button.
OnMouseHover | Called after the mouse hovers over the control.
OnMouseMove | This member is called when the mouse cursor moves.
OnRButtonDown | This member is called when the user press the right mouse button.
OnRButtonUp | This member is called when the user releases the right mouse button.
OnRemoved | This method is called when control was removed from parent controls collection
OnSetPopup | This method is called to popup the control.
OnSetSelected | This method is called when the control becomes selected.
OnThemeChanged | This method is called when paint manager theme was changed
OnToolHitTest |
OnUnderlineActivate | This method is called when the user activate control using its underline.
RedrawParent | This method is called to redraw the parent command bar.
Reset | Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
RestoreCommandBarList | This method is called from LoadCommandBars to restore controls and its child commandbars
ScreenToClient | The ScreenToClient function converts the screen coordinates of a specified point on the screen
SetAction | Call this method to manually assign action for control
SetBeginGroup | Call this member to begin a new group using a separator.
SetCaption |
SetCategory | Call this method to set the category of the control.
SetChecked | Call this member to check the control. If the control does not have xtpFlagManualUpdate flag, you must call the SetCheck member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetCloseSubMenuOnClick | Call this member function to enable or disable closing of the sub menus when a control is clicked in the menu.
SetCustomIcon | Call this member to set a custom icon to this control.
SetDescription | Call this member to set the description of the control.
SetEnabled | Call this member to enable or disable the control. If the control does not have xtpFlagManualUpdate flag, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetExecuteOnPressInterval | Call this method to make button send WM_COMMAND messages while it pressed by user
SetExpanded | This method is called to assign expanded state to the control.
SetFlags | Call this member to set the flags of the control.
SetFocused | Call this member to set focus to the control.
SetHeight | Call this member to set the height of the control
SetHelpId | Call this member to set the control help identifier.
SetHideFlag | Call this member to set/remove hide flags.
SetHideFlags | This method is called to hide the control.
SetHideWrap | This method is called to hide the control.
SetIconId | Call this member to set the control icon's identifier.
SetIconSize | Call this member function to set the size of a icon for individual control.
SetID | Call this member to set the identifier of the control.
SetIndex | This method is called to assign the order of the control in the controls list.
SetItemDefault | Call this method to set the default menu item.
SetKeyboardTip | Call this member to set the keyboard tip to the control.
SetParameter | Call this member to set the parameter of the control.
SetParent | This method is called to assign a parent command bar object.
SetPressed | Call this member to press the control.
SetPrompt | Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
SetRect | This member is called to set the bounding rectangle of the control.
SetRowRect | Call this method to set the row of the control.
SetShortcutText | Call this member to set the shortcut string to the control.
SetStyle | Call this member to set the style of the control.
SetTag | This method sets the 32-bit value associated with the control.
SetTooltip | Call this member to set the tooltip of the control.
SetVisible | Call this member to change the state of the control.
SetWidth | Call this member to set the width of the control
SetWrap | Call this member to set the wrap.


CXTPControl Data Members

CXTPControl Class, Legend, Protected Data Members
CXTPControl Data Members
Class

CXTPControl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bBeginGroup | TRUE if the control starts new group.
m_bChecked | TRUE if the control is checked.
m_bCloseSubMenuOnClick | TRUE is sub-menus are closed as soon as a control is clicked.
m_bDefaultItem | TRUE if the item is default popup item;
m_bEnabled | TRUE if the control is enabled.
m_bExpanded | TRUE if the control is expanded.
m_bPressed | TRUE if the control is pushed.
m_bSelected | TRUE if the control is selected.
m_bTemporary | TRUE if the control is temporary.
m_buttonCustomStyle | User defined style of button.
m_buttonRibbonStyle | User defined style of button.
m_buttonStyle | Button Style.
m_bWrap | TRUE if the control is wrapped.
m_controlType | Type of the control.
m_dwFlags | Flags of the control.
m_dwHideFlags | Hidden flags.
m_mapDocTemplatesAssigned | Assigned templates.
m_mapDocTemplatesExcluded | Excluded templates.
m_nCustomIconId | Identifier of the control's custom image.
m_nExecuteOnPressInterval | Delay between each message when control is pressed.
m_nHeight | Height of the control.
m_nHelpId | Help identifier
m_nIconId | Identifier of the control's image.
m_nId | Identifier of the control.
m_nIndex | Index of the control.
m_nTag | Control tag.
m_nWidth | Width of the control.
m_pAction | Action of the control.
m_pControls | Parent control collection
m_pParent | The Parent command bar.
m_pRibbonGroup | Ribbon group of control
m_rcControl | Bounding rectangle of the control.
m_rcRow | Bounding rectangle of the control's row.
m_strCaption | Caption of the control.
m_strCategory | Category of the control.
m_strCustomCaption | User defined caption.
m_strDescriptionText | Description text.
m_strKeyboardTip | Keyboard tip
m_strParameter | Parameter text.
m_strShortcutText | Shortcut text.
m_strShortcutTextAuto | Shortcut text.
m_strTooltipText | Tooltip text.


CXTPControl::m_bBeginGroup Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bBeginGroup Data Member

TRUE if the control starts new group.

BOOL m_bBeginGroup;
Group

CXTPControl Data Members


CXTPControl::m_bChecked Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bChecked Data Member

TRUE if the control is checked.

BOOL m_bChecked;
Group

CXTPControl Data Members


CXTPControl::m_bCloseSubMenuOnClick Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bCloseSubMenuOnClick Data Member

TRUE is sub-menus are closed as soon as a control is clicked.

BOOL m_bCloseSubMenuOnClick;
Group

CXTPControl Data Members


CXTPControl::m_bDefaultItem Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bDefaultItem Data Member

TRUE if the item is default popup item;

BOOL m_bDefaultItem;
Group

CXTPControl Data Members


CXTPControl::m_bEnabled Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bEnabled Data Member

TRUE if the control is enabled.

BOOL m_bEnabled;
Group

CXTPControl Data Members


CXTPControl::m_bExpanded Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bExpanded Data Member

TRUE if the control is expanded.

BOOL m_bExpanded;
Group

CXTPControl Data Members


CXTPControl::m_bPressed Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bPressed Data Member

TRUE if the control is pushed.

BOOL m_bPressed;
Group

CXTPControl Data Members


CXTPControl::m_bSelected Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bSelected Data Member

TRUE if the control is selected.

BOOL m_bSelected;
Group

CXTPControl Data Members


CXTPControl::m_bTemporary Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bTemporary Data Member

TRUE if the control is temporary.

BOOL m_bTemporary;
Group

CXTPControl Data Members


CXTPControl::m_buttonCustomStyle Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_buttonCustomStyle Data Member

User defined style of button.

XTPButtonStyle m_buttonCustomStyle;
Group

CXTPControl Data Members


CXTPControl::m_buttonRibbonStyle Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_buttonRibbonStyle Data Member

User defined style of button.

XTPButtonStyle m_buttonRibbonStyle;
Group

CXTPControl Data Members


CXTPControl::m_buttonStyle Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_buttonStyle Data Member

Button Style.

XTPButtonStyle m_buttonStyle;
Group

CXTPControl Data Members


CXTPControl::m_bWrap Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_bWrap Data Member

TRUE if the control is wrapped.

BOOL m_bWrap;
Group

CXTPControl Data Members


CXTPControl::m_controlType Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_controlType Data Member

Type of the control.

XTPControlType m_controlType;
Group

CXTPControl Data Members


CXTPControl::m_dwFlags Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_dwFlags Data Member

Flags of the control.

DWORD m_dwFlags;
Group

CXTPControl Data Members


CXTPControl::m_dwHideFlags Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_dwHideFlags Data Member

Hidden flags.

DWORD m_dwHideFlags;
Group

CXTPControl Data Members


CXTPControl::m_mapDocTemplatesAssigned Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_mapDocTemplatesAssigned Data Member

Assigned templates.

CDocTemplateMap m_mapDocTemplatesAssigned;
Group

CXTPControl Data Members


CXTPControl::m_mapDocTemplatesExcluded Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_mapDocTemplatesExcluded Data Member

Excluded templates.

CDocTemplateMap m_mapDocTemplatesExcluded;
Group

CXTPControl Data Members


CXTPControl::m_nCustomIconId Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nCustomIconId Data Member

Identifier of the control's custom image.

int m_nCustomIconId;
Group

CXTPControl Data Members


CXTPControl::m_nExecuteOnPressInterval Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nExecuteOnPressInterval Data Member

Delay between each message when control is pressed.

int m_nExecuteOnPressInterval;
Group

CXTPControl Data Members


CXTPControl::m_nHeight Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nHeight Data Member

Height of the control.

int m_nHeight;
Group

CXTPControl Data Members


CXTPControl::m_nHelpId Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nHelpId Data Member

Help identifier

int m_nHelpId;
Group

CXTPControl Data Members


CXTPControl::m_nIconId Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nIconId Data Member

Identifier of the control's image.

int m_nIconId;
Group

CXTPControl Data Members


CXTPControl::m_nId Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nId Data Member

Identifier of the control.

int m_nId;
Group

CXTPControl Data Members


CXTPControl::m_nIndex Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nIndex Data Member

Index of the control.

int m_nIndex;
Group

CXTPControl Data Members


CXTPControl::m_nTag Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nTag Data Member

Control tag.

DWORD_PTR m_nTag;
Group

CXTPControl Data Members


CXTPControl::m_nWidth Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_nWidth Data Member

Width of the control.

int m_nWidth;
Group

CXTPControl Data Members


CXTPControl::m_pAction Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_pAction Data Member

Action of the control.

CXTPControlAction* m_pAction;
Group

CXTPControl Data Members


CXTPControl::m_pControls Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_pControls Data Member

Parent control collection

CXTPControls* m_pControls;
Group

CXTPControl Data Members


CXTPControl::m_pParent Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_pParent Data Member

The Parent command bar.

CXTPCommandBar* m_pParent;
Group

CXTPControl Data Members


CXTPControl::m_pRibbonGroup Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_pRibbonGroup Data Member

Ribbon group of control

CXTPRibbonGroup* m_pRibbonGroup;
Group

CXTPControl Data Members


CXTPControl::m_rcControl Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_rcControl Data Member

Bounding rectangle of the control.

CRect m_rcControl;
Group

CXTPControl Data Members


CXTPControl::m_rcRow Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_rcRow Data Member

Bounding rectangle of the control's row.

CRect m_rcRow;
Group

CXTPControl Data Members


CXTPControl::m_strCaption Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strCaption Data Member

Caption of the control.

CString m_strCaption;
Group

CXTPControl Data Members


CXTPControl::m_strCategory Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strCategory Data Member

Category of the control.

CString m_strCategory;
Group

CXTPControl Data Members


CXTPControl::m_strCustomCaption Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strCustomCaption Data Member

User defined caption.

CString m_strCustomCaption;
Group

CXTPControl Data Members


CXTPControl::m_strDescriptionText Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strDescriptionText Data Member

Description text.

CString m_strDescriptionText;
Group

CXTPControl Data Members


CXTPControl::m_strKeyboardTip Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strKeyboardTip Data Member

Keyboard tip

CString m_strKeyboardTip;
Group

CXTPControl Data Members


CXTPControl::m_strParameter Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strParameter Data Member

Parameter text.

CString m_strParameter;
Group

CXTPControl Data Members


CXTPControl::m_strShortcutText Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strShortcutText Data Member

Shortcut text.

CString m_strShortcutText;
Group

CXTPControl Data Members


CXTPControl::m_strShortcutTextAuto Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strShortcutTextAuto Data Member

Shortcut text.

CString m_strShortcutTextAuto;
Group

CXTPControl Data Members


CXTPControl::m_strTooltipText Data Member

CXTPControl Data Members, CXTPControl Class
CXTPControl::m_strTooltipText Data Member

Tooltip text.

CString m_strTooltipText;
Group

CXTPControl Data Members


CXTPControl Methods

CXTPControl Class, Legend, Protected Methods, Public Methods
CXTPControl Methods
Class

CXTPControl Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
ClickToolBarButton | This helper method is called when the user clicks to the toolbar's button.
CustomizeStartDrag | This member is called when the user starts to drag the control in customize mode.
CustomizeStartResize | This method is called when user starts resize control in customize mode
GenerateCommandBarList | This method is called from SaveCommandBars to save all child commandbars
GetCustomizeMinWidth | Retrieves available minimum width of control.
IsCustomizeDragOverAvail | This member checks if the user can drop the control.
IsCustomizeMode | Call this method to determine if command bars is in customize mode.
IsCustomizeMovable | This method is called to determine if control can be reposition in customize mode.
IsCustomizeResizeAllow | This member checks if the user can resize control.
IsFocusable | This method is called to check if control accept focus
OnActionChanged | This method is called when action property was changed
OnActionChanging | This method is called when action property is about to be changed
OnCustomizeDragOver | This member is called when the user moves the mouse over the control.
OnCustomizeMouseMove | This member is called when the mouse cursor moves in customized mode
OnHookKeyDown | This method is called when a non-system key is pressed.
OnHookMouseWheel | This method is called when user rotates the mouse wheel.
OnIdleUpdate | This virtual method is called in idle-time processing
OnLButtonDblClk | This member is called when the user double-clicks the left mouse button.
OnLButtonUp | This member is called when the user releases the left mouse button.
OnMouseHover | Called after the mouse hovers over the control.
OnMouseMove | This member is called when the mouse cursor moves.
OnRButtonDown | This member is called when the user press the right mouse button.
OnRButtonUp | This member is called when the user releases the right mouse button.
OnRemoved | This method is called when control was removed from parent controls collection
OnSetPopup | This method is called to popup the control.
OnSetSelected | This method is called when the control becomes selected.
OnToolHitTest |
RestoreCommandBarList | This method is called from LoadCommandBars to restore controls and its child commandbars
ScreenToClient | The ScreenToClient function converts the screen coordinates of a specified point on the screen
SetExpanded | This method is called to assign expanded state to the control.
SetIndex | This method is called to assign the order of the control in the controls list.
SetParent | This method is called to assign a parent command bar object.
Public Methods
Public Methods
Public Method | Description
AssignDocTemplate | Call this method to assign a document template to the control. Assigned control will be shown only when the child MDI window is activated with the assigned document template.
Compare | Call this member to compare controls.
Copy | This method is called to copy the control.
DelayLayoutParent | Call this method to recalculate the parent command bar size.
DelayRedrawParent | Call this method to redraw the parent command bar.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
ExcludeDocTemplate | Call this method to exclude the document template from control. Control will be shown only when the child MDI window is activated with the document template different from excluded.
FromUI | Call this member to retrieve CXTPControl from CCmdUI structure.
GetAction | Call this method to retrieve action associated with control
GetBeginGroup | Call this member to determine if the control has a separator.
GetButtonSize | Call this function to get the size of the command bar button.
GetCaption | Call this member to get the control's caption.
GetCategory | Call this method to retrieve the category of the control.
GetChecked | Call this member to get the state of the control.
GetCloseSubMenuOnClick | Call this member function to determine if sub menus will close as soon as a control is clicked.
GetCommandBar | Call this member to get the child command bar.
GetControls | Call this member to get the parent controls collection.
GetDescription | Call this member to get the control's description.
GetEnabled | Call this member to get the state of the control.
GetExecuteOnPressInterval | Determines if SetExecuteOnPressInterval was called
GetExpanded | Call this member to retrieve if the control is expanded.
GetFlags | Call this member to retrieve control special flags.
GetHeight | Call this member to get the height of the control
GetHelpId | Call this member to get the help identifier.
GetHideFlags | Call this method to retrieve hidden flags.
GetIconId | Call this member to get the icon's identifier.
GetIconSize | Call this member function to get the size of a toolbar icon.
GetID | Call this member to get the control's identifier.
GetImage | Call this method to retrieve the image of the control.
GetImageManager | Call this method to retrieve the image manager.
GetIndex | Call this member to get the index of the control.
GetKeyboardTip | Call this member to get the keyboard tip.
GetPaintManager | Call this method to retrieve the paint manager.
GetParameter | Call this member to get the control's parameter.
GetParent | Call this member to get the parent command bar.
GetPopuped | Call this member to get the control's popup state.
GetPressed | Call this member to get the state of the control.
GetRect | Call this member to get the bounding rectangle of the control.
GetRibbonGroup | Returns the ribbon group the control belongs to.
GetRowRect | Call this method to retrieve the position of the control's row.
GetSelected | Call this member to get the state of the control.
GetShortcutText | Call this member to get the control's shortcut.
GetSize | This method is called to determine the size of the control.
GetStyle | Call this member to get the control's style.
GetTag | This method retrieves the application-supplied 32-bit value associated with the control.
GetTooltip | Call this member to get the control's tooltip.
GetType | Call this member to get the control's type
GetWidth | Call this member to get the width of the control
GetWrap | Call this method to retrieve if the control is wrapped.
HasDwmCompositedRect | This method is called to determine if control has Vista DWM transparent area
IsCaptionVisible | Call this member to determine if the caption of the control is visible
IsCursorOver | Call this member to determine if the mouse pointer is over the control.
IsFocused | Call this member to get the focused state of the control.
IsItemDefault | Call this method to retrieve if control is default menu item.
IsTemporary | Call this method to determine if control is temporary. Temporary controls will not be saved to the system registry when the application is closed (If the CommandBars layout is saved).
IsTransparent | Determines if control need to draw its background
IsVisible | Call this member to determine if the control is visible.
NotifySite | This method is called to sent message code to parent site window.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnExecute | This method is called when the control is executed.
OnThemeChanged | This method is called when paint manager theme was changed
OnUnderlineActivate | This method is called when the user activate control using its underline.
RedrawParent | This method is called to redraw the parent command bar.
Reset | Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
SetAction | Call this method to manually assign action for control
SetBeginGroup | Call this member to begin a new group using a separator.
SetCaption |
SetCategory | Call this method to set the category of the control.
SetChecked | Call this member to check the control. If the control does not have xtpFlagManualUpdate flag, you must call the SetCheck member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetCloseSubMenuOnClick | Call this member function to enable or disable closing of the sub menus when a control is clicked in the menu.
SetCustomIcon | Call this member to set a custom icon to this control.
SetDescription | Call this member to set the description of the control.
SetEnabled | Call this member to enable or disable the control. If the control does not have xtpFlagManualUpdate flag, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetExecuteOnPressInterval | Call this method to make button send WM_COMMAND messages while it pressed by user
SetFlags | Call this member to set the flags of the control.
SetFocused | Call this member to set focus to the control.
SetHeight | Call this member to set the height of the control
SetHelpId | Call this member to set the control help identifier.
SetHideFlag | Call this member to set/remove hide flags.
SetHideFlags | This method is called to hide the control.
SetHideWrap | This method is called to hide the control.
SetIconId | Call this member to set the control icon's identifier.
SetIconSize | Call this member function to set the size of a icon for individual control.
SetID | Call this member to set the identifier of the control.
SetItemDefault | Call this method to set the default menu item.
SetKeyboardTip | Call this member to set the keyboard tip to the control.
SetParameter | Call this member to set the parameter of the control.
SetPressed | Call this member to press the control.
SetPrompt | Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
SetRect | This member is called to set the bounding rectangle of the control.
SetRowRect | Call this method to set the row of the control.
SetShortcutText | Call this member to set the shortcut string to the control.
SetStyle | Call this member to set the style of the control.
SetTag | This method sets the 32-bit value associated with the control.
SetTooltip | Call this member to set the tooltip of the control.
SetVisible | Call this member to change the state of the control.
SetWidth | Call this member to set the width of the control
SetWrap | Call this member to set the wrap.


CXTPControl::AssignDocTemplate Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::AssignDocTemplate Method

Call this method to assign a document template to the control. Assigned control will be shown only when the child MDI window is activated with the assigned document template.

void AssignDocTemplate(
    UINT nIDResource
);
Parameters

nIDResource
document template identifier.

See Also

AssignDocTemplate

Body Source
void CXTPControl::AssignDocTemplate(UINT nIDResource) {
    m_mapDocTemplatesAssigned.SetAt(nIDResource, TRUE);
}
Group

CXTPControl Methods


CXTPControl::ClickToolBarButton Method

CXTPControl Methods, CXTPControl Class
CXTPControl::ClickToolBarButton Method

This helper method is called when the user clicks to the toolbar's button.

void ClickToolBarButton(
    CRect rcActiveRect = CRect(0, 0, 0, 0)
);
Parameters

rcActiveRect
Rectangle of the control.

Group

CXTPControl Methods


CXTPControl::Compare Method

CXTPControl Methods, CXTPControl Class
CXTPControl::Compare Method

Call this member to compare controls.

virtual BOOL Compare(
    CXTPControl* pOther
);
Parameters

pOther
The control need compare with.

Returns

TRUE if the controls are identical.

Group

CXTPControl Methods


CXTPControl::Copy Method

CXTPControl Methods, CXTPControl Class
CXTPControl::Copy Method

This method is called to copy the control.

virtual void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControl Methods


CXTPControl::CustomizeStartDrag Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::CustomizeStartDrag Method

This member is called when the user starts to drag the control in customize mode.

virtual void CustomizeStartDrag(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

See Also

IsCustomizeMode, CustomizeStartResize

Group

CXTPControl Methods


CXTPControl::CustomizeStartResize Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::CustomizeStartResize Method

This method is called when user starts resize control in customize mode

virtual BOOL CustomizeStartResize(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Returns

TRUE if control process this event.

See Also

IsCustomizeMode, CustomizeStartDrag, GetCustomizeMinWidth

Group

CXTPControl Methods


CXTPControl::DelayLayoutParent Method

CXTPControl Methods, CXTPControl Class
CXTPControl::DelayLayoutParent Method

Call this method to recalculate the parent command bar size.

void DelayLayoutParent();
Group

CXTPControl Methods


CXTPControl::DelayRedrawParent Method

CXTPControl Methods, CXTPControl Class
CXTPControl::DelayRedrawParent Method

Call this method to redraw the parent command bar.

void DelayRedrawParent();
Group

CXTPControl Methods


CXTPControl::DoPropExchange Method

CXTPControl Methods, CXTPControl Class
CXTPControl::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControl Methods


CXTPControl::Draw Method

CXTPControl Methods, CXTPControl Class
CXTPControl::Draw Method

This method is called to draw the control.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControl Methods


CXTPControl::ExcludeDocTemplate Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::ExcludeDocTemplate Method

Call this method to exclude the document template from control. Control will be shown only when the child MDI window is activated with the document template different from excluded.

void ExcludeDocTemplate(
    UINT nIDResource
);
Parameters

nIDResource
document template identifier.

See Also

ExcludeDocTemplate

Body Source
void CXTPControl::ExcludeDocTemplate(UINT nIDResource) {
    m_mapDocTemplatesExcluded.SetAt(nIDResource, TRUE);
}
Group

CXTPControl Methods


CXTPControl::FromUI Method

CXTPControl Methods, CXTPControl Class
CXTPControl::FromUI Method

Call this member to retrieve CXTPControl from CCmdUI structure.

static CXTPControl* FromUI(
    CCmdUI* pCmdUI
);
Parameters

pCmdUI
Address of a CCmdUI structure.

Returns

CXTPControl from CCmdUI structure.

Group

CXTPControl Methods


CXTPControl::GenerateCommandBarList Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::GenerateCommandBarList Method

This method is called from SaveCommandBars to save all child commandbars

virtual void GenerateCommandBarList(
    DWORD& nID,
    CXTPCommandBarList* pCommandBarList,
    XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam
);
Parameters

nID
Current Identifier counter
pCommandBarList
List of saved commandbars
pParam
Serialize parameters.

See Also

RestoreCommandBarList

Group

CXTPControl Methods


CXTPControl::GetAction Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetAction Method

Call this method to retrieve action associated with control

CXTPControlAction* GetAction() const;
See Also

CXTPControlAction, SetAction

Body Source
CXTPControlAction* CXTPControl::GetAction() const {
    return m_pAction;
}
Group

CXTPControl Methods


CXTPControl::GetBeginGroup Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetBeginGroup Method

Call this member to determine if the control has a separator.

BOOL GetBeginGroup() const;
Returns

TRUE if the control starts a new group; otherwise FALSE.

Body Source
BOOL CXTPControl::GetBeginGroup() const {
    return m_bBeginGroup;
}
Group

CXTPControl Methods


CXTPControl::GetButtonSize Method

CXTPControl Methods, CXTPControl Class
CXTPControl::GetButtonSize Method

Call this function to get the size of the command bar button.

virtual CSize GetButtonSize() const;
Returns

The width and height values of the command bar button.

Group

CXTPControl Methods


CXTPControl::GetCaption Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetCaption Method

Call this member to get the control's caption.

virtual CString GetCaption() const;
Returns

The caption of the control.

Body Source
CString CXTPControl::GetCaption() const {
    return !m_strCustomCaption.IsEmpty() ? m_strCustomCaption : !m_strCaption.IsEmpty() ? m_strCaption : m_pAction ? m_pAction->GetCaption() : _T("");
}
Group

CXTPControl Methods


CXTPControl::GetCategory Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetCategory Method

Call this method to retrieve the category of the control.

CString GetCategory() const;
Returns

Category of the control.

Body Source
CString CXTPControl::GetCategory() const {
    return !m_strCategory.IsEmpty() ? m_strCategory : m_pAction ? m_pAction->GetCategory() : _T("");
}
Group

CXTPControl Methods


CXTPControl::GetChecked Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetChecked Method

Call this member to get the state of the control.

BOOL GetChecked() const;
Returns

TRUE if the control is checked; otherwise FALSE.

Body Source
BOOL CXTPControl::GetChecked() const {
    return m_bChecked == -1 && m_pAction ? m_pAction->GetChecked() : m_bChecked;
}
Group

CXTPControl Methods


CXTPControl::GetCloseSubMenuOnClick Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetCloseSubMenuOnClick Method

Call this member function to determine if sub menus will close as soon as a control is clicked.

BOOL GetCloseSubMenuOnClick() const;
Returns

TRUE if the sub menu will close when a control is clicked, FALSE if the menu will remain open after a control is clicked.

See Also

SetCloseSubMenuOnClick

Body Source
BOOL CXTPControl::GetCloseSubMenuOnClick() const {
    return m_bCloseSubMenuOnClick;
}
Group

CXTPControl Methods


CXTPControl::GetCommandBar Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetCommandBar Method

Call this member to get the child command bar.

virtual CXTPCommandBar* GetCommandBar() const;
Returns

A pointer to the child command bar.

Body Source
CXTPCommandBar* CXTPControl::GetCommandBar() const {
    return NULL;
}
Group

CXTPControl Methods


CXTPControl::GetControls Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetControls Method

Call this member to get the parent controls collection.

CXTPControls* GetControls() const;
Returns

A CXTPControls pointer to the parent controls.

Body Source
CXTPControls* CXTPControl::GetControls() const {
    return m_pControls;
}
Group

CXTPControl Methods


CXTPControl::GetCustomizeMinWidth Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetCustomizeMinWidth Method

Retrieves available minimum width of control.

virtual int GetCustomizeMinWidth() const;
Returns

Returns zero by default.

Remarks

This method is called in CustomizeStartResize to retrieve dimension of available rectangles of resized control.

See Also

CXTPControlComboBox::GetCustomizeMinWidth, CXTPControlEdit::GetCustomizeMinWidth

Body Source
int CXTPControl::GetCustomizeMinWidth() const {
    return 0;
}
Group

CXTPControl Methods


CXTPControl::GetDescription Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetDescription Method

Call this member to get the control's description.

virtual CString GetDescription() const;
Returns

The description of the control.

Body Source
CString CXTPControl::GetDescription() const {
    return !m_strDescriptionText.IsEmpty() ? m_strDescriptionText : m_pAction ? m_pAction->GetDescription() : _T("");
}
Group

CXTPControl Methods


CXTPControl::GetEnabled Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetEnabled Method

Call this member to get the state of the control.

BOOL GetEnabled() const;
Returns

TRUE if the control is enabled; otherwise FALSE.

Body Source
BOOL CXTPControl::GetEnabled() const {
    return m_bEnabled == -1 && m_pAction ? m_pAction->GetEnabled() : m_bEnabled;
}
Group

CXTPControl Methods


CXTPControl::GetExecuteOnPressInterval Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetExecuteOnPressInterval Method

Determines if SetExecuteOnPressInterval was called

int GetExecuteOnPressInterval() const;
Body Source
int CXTPControl::GetExecuteOnPressInterval() const {
    return m_nExecuteOnPressInterval;
}
Group

CXTPControl Methods


CXTPControl::GetExpanded Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetExpanded Method

Call this member to retrieve if the control is expanded.

BOOL GetExpanded() const;
Returns

TRUE if the control is expanded; otherwise returns FALSE

Body Source
BOOL CXTPControl::GetExpanded() const {
    return m_bExpanded;
}
Group

CXTPControl Methods


CXTPControl::GetFlags Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::GetFlags Method

Call this member to retrieve control special flags.

DWORD GetFlags() const;
Returns

Controls special flags.

See Also

SetFlags, XTPControlFlags

Group

CXTPControl Methods


CXTPControl::GetHeight Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetHeight Method

Call this member to get the height of the control

int GetHeight() const;
Returns

Height of the control in pixels

See Also

GetWidth

Body Source
int CXTPControl::GetHeight() const {
    return m_nHeight;
}
Group

CXTPControl Methods


CXTPControl::GetHelpId Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetHelpId Method

Call this member to get the help identifier.

int GetHelpId() const;
Returns

Help identifier of the control.

Body Source
int CXTPControl::GetHelpId() const {
    return m_nHelpId > 0 ? m_nHelpId : m_pAction ? m_pAction->GetHelpId() : m_nId;
}
Group

CXTPControl Methods


CXTPControl::GetHideFlags Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetHideFlags Method

Call this method to retrieve hidden flags.

DWORD GetHideFlags() const;
Returns

Flags of the control visibility.

Remarks

HideFlags will tell how a control was hidden if it is hidden or why it is not visible. Most of these flags are read only and should not be set be the developer. There is only one situation where you should set these flags manually. The xtpHideCustomize is the only flag that should ever be manually set. you would do this when you want the control to initially be hidden but still exist in customize popup of toolbar. This will cause the control to appear in the Add and Remove Buttons popup without a check mark indicating that it is currently hidden. This flag will automatically be set when a command is hidden this way.

See Also

XTPControlHideFlags

Body Source
DWORD CXTPControl::GetHideFlags() const {
    return m_dwHideFlags;
}
Group

CXTPControl Methods


CXTPControl::GetIconId Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetIconId Method

Call this member to get the icon's identifier.

int GetIconId() const;
Returns

An icon's identifier of the control.

Body Source
int CXTPControl::GetIconId() const {
    return m_nCustomIconId != 0 ? m_nCustomIconId : m_nIconId > 0 ? m_nIconId : m_pAction ? m_pAction->GetIconId() : m_nId;
}
Group

CXTPControl Methods


CXTPControl::GetIconSize Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::GetIconSize Method

Call this member function to get the size of a toolbar icon.

virtual CSize GetIconSize() const;
See Also

GetButtonSize

Group

CXTPControl Methods


CXTPControl::GetID Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetID Method

Call this member to get the control's identifier.

int GetID() const;
Returns

The identifier of the control.

Body Source
int CXTPControl::GetID () const {
    return m_nId;
}
Group

CXTPControl Methods


CXTPControl::GetImage Method

CXTPControl Methods, CXTPControl Class
CXTPControl::GetImage Method

Call this method to retrieve the image of the control.

virtual CXTPImageManagerIcon* GetImage(
    int nWidth = 16
) const;
Parameters

nWidth
Width of the image to retrieve.

Returns

A pointer to a CXTPImageManagerIcon object.

Group

CXTPControl Methods


CXTPControl::GetImageManager Method

CXTPControl Methods, CXTPControl Class
CXTPControl::GetImageManager Method

Call this method to retrieve the image manager.

CXTPImageManager* GetImageManager() const;
Returns

A pointer to a CXTPImageManager object.

Group

CXTPControl Methods


CXTPControl::GetIndex Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetIndex Method

Call this member to get the index of the control.

long GetIndex() const;
Returns

The index of the control.

Body Source
long CXTPControl::GetIndex() const {
    return m_nIndex;
}
Group

CXTPControl Methods


CXTPControl::GetKeyboardTip Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetKeyboardTip Method

Call this member to get the keyboard tip.

CString GetKeyboardTip() const;
Returns

The keyboard tip of the control.

Body Source
CString CXTPControl::GetKeyboardTip() const {
    return !m_strKeyboardTip.IsEmpty() ? m_strKeyboardTip : m_pAction ? m_pAction->GetKeyboardTip() : _T("");
}
Group

CXTPControl Methods


CXTPControl::GetPaintManager Method

CXTPControl Methods, CXTPControl Class
CXTPControl::GetPaintManager Method

Call this method to retrieve the paint manager.

CXTPPaintManager* GetPaintManager() const;
Returns

A pointer to a CXTPPaintManager object.

Group

CXTPControl Methods


CXTPControl::GetParameter Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetParameter Method

Call this member to get the control's parameter.

CString GetParameter() const;
Returns

The parameter of the control.

See Also

GetTag, SetParameter

Body Source
CString CXTPControl::GetParameter() const {
    return m_strParameter;
}
Group

CXTPControl Methods


CXTPControl::GetParent Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetParent Method

Call this member to get the parent command bar.

CXTPCommandBar* GetParent() const;
Returns

The parent command bar object.

Body Source
CXTPCommandBar* CXTPControl::GetParent() const {
    return m_pParent;
}
Group

CXTPControl Methods


CXTPControl::GetPopuped Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetPopuped Method

Call this member to get the control's popup state.

virtual BOOL GetPopuped() const;
Returns

TRUE if the control is a popup.

Body Source
BOOL CXTPControl::GetPopuped() const {
    return FALSE;
}
Group

CXTPControl Methods


CXTPControl::GetPressed Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetPressed Method

Call this member to get the state of the control.

virtual BOOL GetPressed() const;
Returns

TRUE if the control is pressed; otherwise FALSE.

Body Source
BOOL CXTPControl::GetPressed() const {
    return m_bPressed;
}
Group

CXTPControl Methods


CXTPControl::GetRect Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetRect Method

Call this member to get the bounding rectangle of the control.

CRect GetRect() const;
Returns

The bounding rectangle of the control.

Body Source
CRect CXTPControl::GetRect() const {
    return m_rcControl;
}
Group

CXTPControl Methods


CXTPControl::GetRibbonGroup Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetRibbonGroup Method

Returns the ribbon group the control belongs to.

CXTPRibbonGroup* GetRibbonGroup() const;
Returns

If the control belongs to a ribbon group, then the CXTPRibbonGroup that the control belongs to is returned. If the control does not belong to a ribbon group NULL is returned.

See Also

CXTPRibbonBar::RebuildControls

Body Source
CXTPRibbonGroup* CXTPControl::GetRibbonGroup() const {
    return m_pRibbonGroup;
}
Group

CXTPControl Methods


CXTPControl::GetRowRect Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetRowRect Method

Call this method to retrieve the position of the control's row.

CRect GetRowRect() const;
Returns

Bounding rectangle of the control's row.

Body Source
CRect CXTPControl::GetRowRect() const {
    return m_rcRow;
}
Group

CXTPControl Methods


CXTPControl::GetSelected Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetSelected Method

Call this member to get the state of the control.

virtual int GetSelected() const;
Returns

TRUE if the control is selected; otherwise FALSE.

Body Source
int CXTPControl::GetSelected() const {
    return m_bSelected;
}
Group

CXTPControl Methods


CXTPControl::GetShortcutText Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetShortcutText Method

Call this member to get the control's shortcut.

CString GetShortcutText() const;
Returns

The shortcut of the control.

Body Source
CString CXTPControl::GetShortcutText() const {
    return !m_strShortcutText.IsEmpty() ? m_strShortcutText :
    m_pAction && !m_pAction->GetShortcutText().IsEmpty()  ? m_pAction->GetShortcutText() : m_strShortcutTextAuto;
}
Group

CXTPControl Methods


CXTPControl::GetSize Method

CXTPControl Methods, CXTPControl Class
CXTPControl::GetSize Method

This method is called to determine the size of the control.

virtual CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControl Methods


CXTPControl::GetStyle Method

CXTPControl Methods, CXTPControl Class
CXTPControl::GetStyle Method

Call this member to get the control's style.

XTPButtonStyle GetStyle() const;
Returns

The style of the control.

Group

CXTPControl Methods


CXTPControl::GetTag Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetTag Method

This method retrieves the application-supplied 32-bit value associated with the control.

DWORD_PTR GetTag() const;
Returns

The 32-bit value associated with the control.

Body Source
DWORD_PTR CXTPControl::GetTag() const {
    return m_nTag;
}
Group

CXTPControl Methods


CXTPControl::GetTooltip Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetTooltip Method

Call this member to get the control's tooltip.

virtual CString GetTooltip() const;
Returns

Tooltip of the control.

Body Source
CString CXTPControl::GetTooltip() const {
    return !m_strTooltipText.IsEmpty() ? m_strTooltipText : m_pAction ? m_pAction->GetTooltip() : _T("");
}
Group

CXTPControl Methods


CXTPControl::GetType Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::GetType Method

Call this member to get the control's type

XTPControlType GetType() const;
Returns

The type of the control. It can be one of the following:

  • xtpControlButton Indicates the control is simple button (CXTPControlButton)
  • xtpControlPopup Indicates the control is simple popup button. (CXTPControlPopup)
  • xtpControlButtonPopup Indicates the control is popup button with icon (CXTPControlPopup)
  • xtpControlSplitButtonPopup Indicates the control is split button popup.(CXTPControlPopup)
  • xtpControlComboBox Indicates the control is combo box (CXTPControlComboBox)
  • xtpControlEdit Indicates the control is edit control (CXTPControlEdit)
  • xtpControlLabel Indicates the control is label (CXTPControlLabel)
Body Source
XTPControlType CXTPControl::GetType() const {
    return m_controlType;
}
Group

CXTPControl Methods


CXTPControl::GetWidth Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetWidth Method

Call this member to get the width of the control

int GetWidth() const;
Returns

Width of the control in pixels

See Also

GetHeight

Body Source
int CXTPControl::GetWidth() const {
    return m_nWidth;
}
Group

CXTPControl Methods


CXTPControl::GetWrap Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::GetWrap Method

Call this method to retrieve if the control is wrapped.

BOOL GetWrap() const;
Returns

TRUE if the control is wrapped; otherwise returns FALSE

See Also

SetWrap

Body Source
BOOL CXTPControl::GetWrap() const {
    return m_bWrap;
}
Group

CXTPControl Methods


CXTPControl::HasDwmCompositedRect Method

CXTPControl Methods, CXTPControl Class
CXTPControl::HasDwmCompositedRect Method

This method is called to determine if control has Vista DWM transparent area

BOOL HasDwmCompositedRect() const;
Group

CXTPControl Methods


CXTPControl::IsCaptionVisible Method

CXTPControl Methods, CXTPControl Class
CXTPControl::IsCaptionVisible Method

Call this member to determine if the caption of the control is visible

virtual BOOL IsCaptionVisible() const;
Returns

TRUE if the caption is visible.

Group

CXTPControl Methods


CXTPControl::IsCursorOver Method

CXTPControl Methods, CXTPControl Class
CXTPControl::IsCursorOver Method

Call this member to determine if the mouse pointer is over the control.

BOOL IsCursorOver() const;
Returns

TRUE if the mouse cursor is over the control; otherwise returns FALSE

Group

CXTPControl Methods


CXTPControl::IsCustomizeDragOverAvail Method

CXTPControl Methods, CXTPControl Class
CXTPControl::IsCustomizeDragOverAvail Method

This member checks if the user can drop the control.

virtual BOOL IsCustomizeDragOverAvail(
    CXTPCommandBar* pCommandBar,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pCommandBar
Points to a CXTPCommandBar object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Returns

TRUE if successful, otherwise returns FALSE

Group

CXTPControl Methods


CXTPControl::IsCustomizeMode Method

CXTPControl Methods, CXTPControl Class
CXTPControl::IsCustomizeMode Method

Call this method to determine if command bars is in customize mode.

BOOL IsCustomizeMode() const;
Returns

TRUE if command bars is in Customize mode; otherwise returns FALSE

Group

CXTPControl Methods


CXTPControl::IsCustomizeMovable Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::IsCustomizeMovable Method

This method is called to determine if control can be reposition in customize mode.

virtual BOOL IsCustomizeMovable() const;
See Also

xtpFlagNoMovable

Group

CXTPControl Methods


CXTPControl::IsCustomizeResizeAllow Method

CXTPControl Methods, CXTPControl Class
CXTPControl::IsCustomizeResizeAllow Method

This member checks if the user can resize control.

virtual BOOL IsCustomizeResizeAllow() const;
Returns

TRUE if resize available.

Group

CXTPControl Methods


CXTPControl::IsFocusable Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::IsFocusable Method

This method is called to check if control accept focus

virtual BOOL IsFocusable() const;
See Also

SetFocused, IsFocused

Body Source
BOOL CXTPControl::IsFocusable() const {
    return FALSE;
}
Group

CXTPControl Methods


CXTPControl::IsFocused Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::IsFocused Method

Call this member to get the focused state of the control.

virtual BOOL IsFocused() const;
Returns

TRUE if the control has focus; otherwise FALSE.

Body Source
BOOL CXTPControl::IsFocused() const{
    return FALSE;
}
Group

CXTPControl Methods


CXTPControl::IsItemDefault Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::IsItemDefault Method

Call this method to retrieve if control is default menu item.

BOOL IsItemDefault() const;
Returns

TRUE if control is default menu item.

See Also

SetItemDefault

Group

CXTPControl Methods


CXTPControl::IsTemporary Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::IsTemporary Method

Call this method to determine if control is temporary. Temporary controls will not be saved to the system registry when the application is closed (If the CommandBars layout is saved).

BOOL IsTemporary() const;
Returns

TRUE if control is temporary.

Body Source
BOOL CXTPControl::IsTemporary() const {
    return m_bTemporary;
}
Group

CXTPControl Methods


CXTPControl::IsTransparent Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::IsTransparent Method

Determines if control need to draw its background

virtual BOOL IsTransparent() const;
Returns

TRUE if paint manager must skip filling background of control

Body Source
virtual BOOL IsTransparent() const { return FALSE;}
Group

CXTPControl Methods


CXTPControl::IsVisible Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::IsVisible Method

Call this member to determine if the control is visible.

virtual BOOL IsVisible(
    DWORD dwSkipFlags = 0
) const;
Parameters

dwSkipFlags
combination of XTPControlHideFlags that can be ignored

Returns

TRUE if the control is visible.

See Also

XTPControlHideFlags, GetHideFlags

Body Source
BOOL CXTPControl::IsVisible(DWORD dwSkipFlags) const {
    if (m_pAction && !m_pAction->IsVisible()) return FALSE;
    return (m_dwHideFlags & ~dwSkipFlags) == xtpNoHide;
}
Group

CXTPControl Methods


CXTPControl::NotifySite Method

CXTPControl Methods, CXTPControl Class
CXTPControl::NotifySite Method

This method is called to sent message code to parent site window.

LRESULT NotifySite(
    UINT code
);
Parameters

code
Message to be sent.

Group

CXTPControl Methods


CXTPControl::OnActionChanged Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::OnActionChanged Method

This method is called when action property was changed

virtual void OnActionChanged(
    int nProperty
);
Parameters

nProperty
Property of the action

See Also

OnActionChanging

Group

CXTPControl Methods


CXTPControl::OnActionChanging Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::OnActionChanging Method

This method is called when action property is about to be changed

virtual void OnActionChanging(
    int nProperty
);
Parameters

nProperty
Property of the action

See Also

OnActionChanged

Body Source
void CXTPControl::OnActionChanging(int /*nProperty*/) {

}
Group

CXTPControl Methods


CXTPControl::OnCalcDynamicSize Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Body Source
void CXTPControl::OnCalcDynamicSize(DWORD /*dwMode*/) {
}
Group

CXTPControl Methods


CXTPControl::OnClick Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnClick Method

This method is called when the user clicks the control.

virtual void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Body Source
void CXTPControl::OnClick(BOOL /*bKeyboard = FALSE*/, CPoint /*pt = CPoint(0, 0)*/) {
}
Group

CXTPControl Methods


CXTPControl::OnCustomizeDragOver Method

CXTPControl Methods, CXTPControl Class
CXTPControl::OnCustomizeDragOver Method

This member is called when the user moves the mouse over the control.

virtual void OnCustomizeDragOver(
    CXTPControl* pDataObject,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pDataObject
Points to a CXTPControl object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Group

CXTPControl Methods


CXTPControl::OnCustomizeMouseMove Method

CXTPControl Methods, CXTPControl Class
CXTPControl::OnCustomizeMouseMove Method

This member is called when the mouse cursor moves in customized mode

void OnCustomizeMouseMove(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControl Methods


CXTPControl::OnExecute Method

CXTPControl Methods, CXTPControl Class
CXTPControl::OnExecute Method

This method is called when the control is executed.

virtual void OnExecute();
Group

CXTPControl Methods


CXTPControl::OnHookKeyDown Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnHookKeyDown Method

This method is called when a non-system key is pressed.

virtual BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE

Body Source
BOOL CXTPControl::OnHookKeyDown(UINT /*nChar*/, LPARAM /*lParam*/) {
    return FALSE;
}
Group

CXTPControl Methods


CXTPControl::OnHookMouseWheel Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnHookMouseWheel Method

This method is called when user rotates the mouse wheel.

virtual BOOL OnHookMouseWheel(
    UINT nFlags,
    short zDelta,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down.
zDelta
Indicates distance rotated.
point
Specifies the x- and y-coordinate of the cursor.

Returns

TRUE if key handled, otherwise returns FALSE

Body Source
BOOL CXTPControl::OnHookMouseWheel(UINT /*nFlags*/, short /*zDelta*/, CPoint /*pt*/) {
    return FALSE;
}
Group

CXTPControl Methods


CXTPControl::OnIdleUpdate Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnIdleUpdate Method

This virtual method is called in idle-time processing

virtual void OnIdleUpdate();
Body Source
void CXTPControl::OnIdleUpdate() {

}
Group

CXTPControl Methods


CXTPControl::OnLButtonDblClk Method

CXTPControl Methods, CXTPControl Class
CXTPControl::OnLButtonDblClk Method

This member is called when the user double-clicks the left mouse button.

virtual BOOL OnLButtonDblClk(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinates of the cursor.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControl Methods


CXTPControl::OnLButtonUp Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnLButtonUp Method

This member is called when the user releases the left mouse button.

virtual void OnLButtonUp(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Body Source
void CXTPControl::OnLButtonUp(CPoint /*point*/) {
}
Group

CXTPControl Methods


CXTPControl::OnMouseHover Method

CXTPControl Methods, CXTPControl Class
CXTPControl::OnMouseHover Method

Called after the mouse hovers over the control.

virtual void OnMouseHover();
Group

CXTPControl Methods


CXTPControl::OnMouseMove Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnMouseMove Method

This member is called when the mouse cursor moves.

virtual void OnMouseMove(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Body Source
void CXTPControl::OnMouseMove(CPoint /*point*/) {
}
Group

CXTPControl Methods


CXTPControl::OnRButtonDown Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnRButtonDown Method

This member is called when the user press the right mouse button.

virtual BOOL OnRButtonDown(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Body Source
BOOL CXTPControl::OnRButtonDown(CPoint /*point*/) {
    return FALSE;
}
Group

CXTPControl Methods


CXTPControl::OnRButtonUp Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnRButtonUp Method

This member is called when the user releases the right mouse button.

virtual BOOL OnRButtonUp(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Body Source
BOOL CXTPControl::OnRButtonUp(CPoint /*point*/) {
    return FALSE;
}
Group

CXTPControl Methods


CXTPControl::OnRemoved Method

CXTPControl Methods, CXTPControl Class
CXTPControl::OnRemoved Method

This method is called when control was removed from parent controls collection

virtual void OnRemoved();
Group

CXTPControl Methods


CXTPControl::OnSetPopup Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnSetPopup Method

This method is called to popup the control.

virtual BOOL OnSetPopup(
    BOOL bPopup
);
Parameters

bPopup
TRUE to set popup.

Returns

TRUE if successful; otherwise returns FALSE

Body Source
BOOL CXTPControl::OnSetPopup(BOOL /*bPopup*/) {
    return FALSE;
}
Group

CXTPControl Methods


CXTPControl::OnSetSelected Method

CXTPControl Methods, CXTPControl Class
CXTPControl::OnSetSelected Method

This method is called when the control becomes selected.

virtual BOOL OnSetSelected(
    int bSelected
);
Parameters

bSelected
TRUE if the control becomes selected.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControl Methods


CXTPControl::OnThemeChanged Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnThemeChanged Method

This method is called when paint manager theme was changed

virtual void OnThemeChanged();
Body Source
void CXTPControl::OnThemeChanged() {

}
Group

CXTPControl Methods


CXTPControl::OnToolHitTest Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::OnToolHitTest Method
virtual INT_PTR OnToolHitTest(
    CPoint point,
    TOOLINFO* pTI
) const;
Body Source
INT_PTR CXTPControl::OnToolHitTest(CPoint /*point*/, TOOLINFO* /*pTI*/) const {
    return -1;
}
Group

CXTPControl Methods


CXTPControl::OnUnderlineActivate Method

CXTPControl Methods, CXTPControl Class
CXTPControl::OnUnderlineActivate Method

This method is called when the user activate control using its underline.

virtual void OnUnderlineActivate();
Group

CXTPControl Methods


CXTPControl::RedrawParent Method

CXTPControl Methods, CXTPControl Class
CXTPControl::RedrawParent Method

This method is called to redraw the parent command bar.

void RedrawParent(
    BOOL bAnimate = TRUE
);
Parameters

bAnimate
TRUE to animate changes

Group

CXTPControl Methods


CXTPControl::Reset Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::Reset Method

Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.

void Reset();
Remarks

The caption and icon of a control is customized while in customization mode.

See Also

SetCustomIcon, m_strCustomCaption

Group

CXTPControl Methods


CXTPControl::RestoreCommandBarList Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::RestoreCommandBarList Method

This method is called from LoadCommandBars to restore controls and its child commandbars

virtual void RestoreCommandBarList(
    CXTPCommandBarList* pCommandBarList
);
Parameters

pCommandBarList
CommandBars collection contains all commandbars was restored

See Also

GenerateCommandBarList

Group

CXTPControl Methods


CXTPControl::ScreenToClient Method

CXTPControl Methods, CXTPControl Class
CXTPControl::ScreenToClient Method

The ScreenToClient function converts the screen coordinates of a specified point on the screen

void ScreenToClient(
    CPoint* point
);
Parameters

point
Pointer to a CPoint object that specifies the screen coordinates to be converted.

Group

CXTPControl Methods


CXTPControl::SetAction Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::SetAction Method

Call this method to manually assign action for control

virtual void SetAction(
    CXTPControlAction* pAction
);
Parameters

pAction
Action to assign

See Also

CXTPControlAction, GetAction

Group

CXTPControl Methods


CXTPControl::SetBeginGroup Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetBeginGroup Method

Call this member to begin a new group using a separator.

virtual void SetBeginGroup(
    BOOL bBeginGroup
);
Parameters

bBeginGroup
TRUE if the control starts a new group.

Body Source
void CXTPControl::SetBeginGroup(BOOL bBeginGroup) {
    if (m_bBeginGroup != bBeginGroup) {m_bBeginGroup = bBeginGroup; DelayLayoutParent();}
}
Group

CXTPControl Methods


SetCaption Method

CXTPControl Methods
SetCaption Method
Overload List
Methods
Method | Description
CXTPControl::SetCaption (LPCTSTR) | Call this member to set the caption of the control.
CXTPControl::SetCaption (UINT) | Call this member to set the caption of the control.
Group

CXTPControl Methods


CXTPControl::SetCaption Method (LPCTSTR)

SetCaption Method, CXTPControl Class, See Also
CXTPControl::SetCaption Method (LPCTSTR)

Call this member to set the caption of the control.

void SetCaption(
    UINT nIDCaption
);
void SetCaption(
    LPCTSTR lpszCaption
);
void SetCaption(
    UINT nIDCaption
);
Parameters

nIDCaption
Caption resource identifier.
lpszCaption
Caption to be set.

See Also

SetPrompt, SetDescription, SetTooltip

Group

SetCaption Method


CXTPControl::SetCategory Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetCategory Method

Call this method to set the category of the control.

void SetCategory(
    LPCTSTR lpszCategory
);
Parameters

lpszCategory
Category of the control.

Body Source
void CXTPControl::SetCategory(LPCTSTR lpszCategory) {
    m_strCategory = lpszCategory;
}
Group

CXTPControl Methods


CXTPControl::SetChecked Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetChecked Method

Call this member to check the control. If the control does not have xtpFlagManualUpdate flag, you must call the SetCheck member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.

void SetChecked(
    BOOL bChecked
);
Parameters

bChecked
TRUE if the control is checked.

See Also

GetChecked, SetEnabled

Body Source
void CXTPControl::SetChecked(BOOL bChecked) {
    if (m_bChecked != bChecked) {m_bChecked = bChecked; RedrawParent();}
}
Group

CXTPControl Methods


CXTPControl::SetCloseSubMenuOnClick Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetCloseSubMenuOnClick Method

Call this member function to enable or disable closing of the sub menus when a control is clicked in the menu.

void SetCloseSubMenuOnClick(
    BOOL bCloseOnClick
);
Parameters

bCloseOnClick
TRUE if the sub menu will close when a control is clicked, FALSE if the menu will remain open after a control is clicked.

See Also

GetCloseSubMenuOnClick

Body Source
void CXTPControl::SetCloseSubMenuOnClick(BOOL bCloseOnClick) {
    m_bCloseSubMenuOnClick = bCloseOnClick;
}
Group

CXTPControl Methods


CXTPControl::SetCustomIcon Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::SetCustomIcon Method

Call this member to set a custom icon to this control.

void SetCustomIcon(
    HICON hIcon
);
Parameters

hIcon
HICON object containing icon to set to control.

See Also

Reset

Group

CXTPControl Methods


CXTPControl::SetDescription Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetDescription Method

Call this member to set the description of the control.

void SetDescription(
    LPCTSTR lpszDescription
);
Parameters

lpszDescription
Description to be set.

See Also

SetCaption, SetPrompt, SetTooltip

Body Source
void CXTPControl::SetDescription(LPCTSTR lpszDescription) {
    m_strDescriptionText = lpszDescription;
}
Group

CXTPControl Methods


CXTPControl::SetEnabled Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetEnabled Method

Call this member to enable or disable the control. If the control does not have xtpFlagManualUpdate flag, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.

virtual void SetEnabled(
    BOOL bEnabled
);
Parameters

bEnabled
TRUE if the control is enabled.

See Also

GetEnabled, SetChecked

Body Source
void CXTPControl::SetEnabled(BOOL bEnabled) {
    if (m_bEnabled != bEnabled) {m_bEnabled = bEnabled; RedrawParent();}
}
Group

CXTPControl Methods


CXTPControl::SetExecuteOnPressInterval Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetExecuteOnPressInterval Method

Call this method to make button send WM_COMMAND messages while it pressed by user

void SetExecuteOnPressInterval(
    int nExecuteOnPressInterval
);
Parameters

nExecuteOnPressInterval
Ms delay between each message.

See Also

GetExecuteOnPressInterval

Body Source
void CXTPControl::SetExecuteOnPressInterval(int nExecuteOnPressInterval) {
    m_nExecuteOnPressInterval = nExecuteOnPressInterval;
}
Group

CXTPControl Methods


CXTPControl::SetExpanded Method

CXTPControl Methods, CXTPControl Class
CXTPControl::SetExpanded Method

This method is called to assign expanded state to the control.

void SetExpanded(
    BOOL bExpanded
);
Parameters

bExpanded
TRUE if the control is expanded.

Group

CXTPControl Methods


CXTPControl::SetFlags Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::SetFlags Method

Call this member to set the flags of the control.

void SetFlags(
    DWORD dwFlags
);
Parameters

dwFlags
control flags.

Remarks

Flags to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • xtpFlagRightAlign Indicates the control is right aligned.
  • xtpFlagSkipFocus Indicates the control does not have focus.
  • xtpFlagLeftPopup Indicates the child bar should pop-up on the left.
  • xtpFlagManualUpdate Indicates the control is manually updated.
  • xtpFlagNoMovable Indicates the control's customization is disabled.
  • xtpFlagControlStretched Indicates the control is stretched in the parent command bar.
See Also

GetFlags, XTPControlFlags

Group

CXTPControl Methods


CXTPControl::SetFocused Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetFocused Method

Call this member to set focus to the control.

virtual void SetFocused(
    BOOL bFocused
);
Parameters

bFocused
TRUE to set focus

Body Source
void CXTPControl::SetFocused(BOOL /*bFocused*/) {
}
Group

CXTPControl Methods


CXTPControl::SetHeight Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetHeight Method

Call this member to set the height of the control

virtual void SetHeight(
    int nHeight
);
Parameters

nHeight
The height of the control

Body Source
void CXTPControl::SetHeight(int nHeight) {
    if (m_nHeight != nHeight) {
        m_nHeight = nHeight;
        DelayLayoutParent();
    }
}
Group

CXTPControl Methods


CXTPControl::SetHelpId Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetHelpId Method

Call this member to set the control help identifier.

void SetHelpId(
    int nId
);
Parameters

nId
Help identifier to be set.

Body Source
void CXTPControl::SetHelpId(int nId) {
    m_nHelpId = nId;
}
Group

CXTPControl Methods


CXTPControl::SetHideFlag Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetHideFlag Method

Call this member to set/remove hide flags.

BOOL SetHideFlag(
    XTPControlHideFlags dwFlag,
    BOOL bSet
);
Parameters

dwFlag
XTPControlHideFlags type of flag to be set/remove
bSet
TRUE to set flag; FALSE to remove.

Returns

TRUE if flags was changed

Remarks

SetHideFlag will tell how a control was hidden if it is hidden or why it is not visible. Most of these flags are read only and should not be set be the developer.

See Also

XTPControlHideFlags, SetHideFlags

Body Source
BOOL CXTPControl::SetHideFlag(XTPControlHideFlags dwFlag, BOOL bHide) {
    DWORD dwHideFlags = m_dwHideFlags;
    if (bHide) SetHideFlags (m_dwHideFlags | dwFlag); else SetHideFlags(m_dwHideFlags & ~dwFlag);
    return dwHideFlags != m_dwHideFlags;
}
Group

CXTPControl Methods


CXTPControl::SetHideFlags Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetHideFlags Method

This method is called to hide the control.

virtual void SetHideFlags(
    DWORD dwFlags
);
Parameters

dwFlags
Reasons to hide.

Remarks

HideFlags will tell how a control was hidden if it is hidden or why it is not visible. Most of these flags are read only and should not be set be the developer. There is only one situation where you should set these flags manually. The xtpHideCustomize is the only flag that should ever be manually set. you would do this when you want the control to initially be hidden but still exist in customize popup of toolbar. This will cause the control to appear in the Add and Remove Buttons popup without a check mark indicating that it is currently hidden. This flag will automatically be set when a command is hidden this way.

See Also

XTPControlHideFlags

Body Source
void CXTPControl::SetHideFlags(DWORD dwFlags) {
    m_dwHideFlags = dwFlags;
}
Group

CXTPControl Methods


CXTPControl::SetHideWrap Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetHideWrap Method

This method is called to hide the control.

void SetHideWrap(
    BOOL bHide
);
Parameters

bHide
TRUE to set hide state.

Body Source
void CXTPControl::SetHideWrap(BOOL bHide) {
    SetHideFlag(xtpHideWrap, bHide);
}
Group

CXTPControl Methods


CXTPControl::SetIconId Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetIconId Method

Call this member to set the control icon's identifier.

void SetIconId(
    int nId
);
Parameters

nId
Icon's identifier to be set.

Body Source
void CXTPControl::SetIconId(int nId) {
    if (m_nIconId != nId) {m_nIconId = nId; RedrawParent(FALSE);}
}
Group

CXTPControl Methods


CXTPControl::SetIconSize Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetIconSize Method

Call this member function to set the size of a icon for individual control.

void SetIconSize(
    CSize szIcon
);
See Also

GetIconSize, GetButtonSize

Body Source
void CXTPControl::SetIconSize(CSize szIcon) {
    m_szIcon = szIcon; RedrawParent(FALSE);
}
Group

CXTPControl Methods


CXTPControl::SetID Method

CXTPControl Methods, CXTPControl Class
CXTPControl::SetID Method

Call this member to set the identifier of the control.

void SetID(
    int nId
);
Parameters

nId
Identifier to be set.

Group

CXTPControl Methods


CXTPControl::SetIndex Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetIndex Method

This method is called to assign the order of the control in the controls list.

void SetIndex(
    int nIndex
);
Parameters

nIndex
Index of the control.

Body Source
void SetIndex(int nIndex) { m_nIndex = nIndex; }
Group

CXTPControl Methods


CXTPControl::SetItemDefault Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::SetItemDefault Method

Call this method to set the default menu item.

void SetItemDefault(
    BOOL bDefault
);
Parameters

bDefault
TRUE to set control default menu item.

Remarks

A default menu item will appear in bold text.

See Also

IsItemDefault

Group

CXTPControl Methods


CXTPControl::SetKeyboardTip Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetKeyboardTip Method

Call this member to set the keyboard tip to the control.

void SetKeyboardTip(
    LPCTSTR lpszKeyboardTip
);
Parameters

lpszKeyboardTip
Keyboard tip to be set.

Body Source
void CXTPControl::SetKeyboardTip(LPCTSTR lpszKeyboardTip) {
    m_strKeyboardTip = lpszKeyboardTip;
}
Group

CXTPControl Methods


CXTPControl::SetParameter Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetParameter Method

Call this member to set the parameter of the control.

void SetParameter(
    LPCTSTR lpszParameter
);
Parameters

lpszParameter
Parameter to be set.

Remarks

This method sets CString value associated with the control, use SetTag to set numeric parameter.

See Also

SetTag, GetParameter

Body Source
void CXTPControl::SetParameter(LPCTSTR lpszParameter) {
    m_strParameter = lpszParameter;
}
Group

CXTPControl Methods


CXTPControl::SetParent Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetParent Method

This method is called to assign a parent command bar object.

virtual void SetParent(
    CXTPCommandBar* pParent
);
Parameters

pParent
Points to a CXTPCommandBar object

Body Source
virtual void SetParent(CXTPCommandBar* pParent) { m_pParent = pParent;}
Group

CXTPControl Methods


CXTPControl::SetPressed Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetPressed Method

Call this member to press the control.

void SetPressed(
    BOOL bPressed
);
Parameters

bPressed
TRUE if the control is pressed.

Body Source
void CXTPControl::SetPressed(BOOL bPressed) {
    m_bPressed = bPressed;
}
Group

CXTPControl Methods


CXTPControl::SetPrompt Method

CXTPControl Methods, CXTPControl Class, See Also
CXTPControl::SetPrompt Method

Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.

void SetPrompt(
    LPCTSTR lpszPrompt
);
Parameters

lpszPrompt
String from resource file that contains the tooltip and description of the item. The Caption will be set to use the tooltip text. The tooltip and description must be separated by "n" if both are included. You can omit the description and both the tooltip and description will be set to the same value.

Remarks

Resource strings are in the format "DescriptionnToolTip".

Notes

The caption is set to the value of the tooltip when this member is called.

See Also

SetCaption, SetDescription, SetTooltip

Group

CXTPControl Methods


CXTPControl::SetRect Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetRect Method

This member is called to set the bounding rectangle of the control.

virtual void SetRect(
    CRect rcControl
);
Parameters

rcControl
Bounding rectangle of the control.

Body Source
void CXTPControl::SetRect(CRect rcControl) {
    m_rcControl = rcControl;
}
Group

CXTPControl Methods


CXTPControl::SetRowRect Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetRowRect Method

Call this method to set the row of the control.

void SetRowRect(
    CRect rcRow
);
Parameters

rcRow
Rectangle of the control's row.

Body Source
void CXTPControl::SetRowRect(CRect rcRow) {
    m_rcRow = rcRow;
}
Group

CXTPControl Methods


CXTPControl::SetShortcutText Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetShortcutText Method

Call this member to set the shortcut string to the control.

void SetShortcutText(
    LPCTSTR lpszShortcutText
);
Parameters

lpszShortcutText
Shortcut to be set.

Body Source
void CXTPControl::SetShortcutText(LPCTSTR lpszShortcutText) {
    m_strShortcutText = lpszShortcutText;
}
Group

CXTPControl Methods


CXTPControl::SetStyle Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetStyle Method

Call this member to set the style of the control.

void SetStyle(
    XTPButtonStyle buttonStyle
);
Parameters

buttonStyle
The style to be set. Can be any of the values listed in the Remarks section.

Remarks

buttonStyle parameter can be one of the following:

  • xtpButtonAutomatic Indicates the default style.
  • xtpButtonCaption Indicates caption drawing only.
  • xtpButtonIcon Indicates icon drawing only.
  • xtpButtonIconAndCaption Indicates icon and caption drawing.
Body Source
void CXTPControl::SetStyle(XTPButtonStyle buttonStyle) {
    if (m_buttonStyle != buttonStyle)
    {
        m_buttonStyle = buttonStyle;
        DelayLayoutParent();
    }
}
Group

CXTPControl Methods


CXTPControl::SetTag Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetTag Method

This method sets the 32-bit value associated with the control.

void SetTag(
    DWORD_PTR dwTag
);
Parameters

dwTag
Contains the new value to associate with the control.

Body Source
void CXTPControl::SetTag(DWORD_PTR dwTag) {
    m_nTag = dwTag;
}
Group

CXTPControl Methods


CXTPControl::SetTooltip Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetTooltip Method

Call this member to set the tooltip of the control.

void SetTooltip(
    LPCTSTR lpszTooltip
);
Parameters

lpszTooltip
Tooltip to be set.

See Also

SetCaption, SetDescription, SetPrompt

Body Source
void CXTPControl::SetTooltip(LPCTSTR lpszTooltip) {
    m_strTooltipText = lpszTooltip;
}
Group

CXTPControl Methods


CXTPControl::SetVisible Method

CXTPControl Methods, CXTPControl Class
CXTPControl::SetVisible Method

Call this member to change the state of the control.

void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE if the control is visible.

Group

CXTPControl Methods


CXTPControl::SetWidth Method

CXTPControl Methods, CXTPControl Class, Body Source
CXTPControl::SetWidth Method

Call this member to set the width of the control

virtual void SetWidth(
    int nWidth
);
Parameters

nWidth
The width of the control

Body Source
void CXTPControl::SetWidth(int nWidth) {
    if (m_nWidth != nWidth) {
        m_nWidth = nWidth;
        DelayLayoutParent();
    }
}
Group

CXTPControl Methods


CXTPControl::SetWrap Method

CXTPControl Methods, CXTPControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControl::SetWrap Method

Call this member to set the wrap.

void SetWrap(
    BOOL bWrap
);
Parameters

bWrap
TRUE to set wrap.

See Also

GetWrap

Body Source
void CXTPControl::SetWrap(BOOL bWrap) {
    m_bWrap = bWrap;
}
Group

CXTPControl Methods


CXTPControl Constructors

CXTPControl Class, Legend, Protected Methods
CXTPControl Constructors
Class

CXTPControl Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPControl | Constructs a CXTPControl object


CXTPControl::CXTPControl Constructor

CXTPControl Constructors, CXTPControl Class
CXTPControl::CXTPControl Constructor

Constructs a CXTPControl object

CXTPControl();
Group

CXTPControl Constructors


CXTPControl Destructors

CXTPControl Class, Legend, Protected Methods
CXTPControl Destructors
Class

CXTPControl Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPControl | Destroys a CXTPControl object, handles cleanup and deallocation


CXTPControl::~CXTPControl Destructor

CXTPControl Destructors, CXTPControl Class
CXTPControl::~CXTPControl Destructor

Destroys a CXTPControl object, handles cleanup and deallocation

virtual ~CXTPControl();
Group

CXTPControl Destructors


CXTPControlAction Class

XTPControl.h, Classes, Legend, Members, Topics, CXTPControlAction Data Members, CXTPControlAction Methods, CXTPControlAction Constructors, CXTPControlAction Destructors, CXTPControlAction Constructors, CXTPControlAction Data Members, CXTPControlAction Destructors, CXTPControlAction Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction Class

CXTPControlAction is a CCmdTarget derived class. It represents the single action of controls.

Class Hierarchy

class CXTPControlAction;
File

XTPControl.h

Group

Classes

Legend
Data Member
protected
Method
CXTPControlAction Constructors
CXTPControlAction Constructors | Description
CXTPControlAction | Constructs a CXTPControlAction object
CXTPControlAction Data Members
CXTPControlAction Data Members | Description
m_arrControls | Associated controls
m_bChecked | TRUE if the action is checked.
m_bEnabled | TRUE if the action is enabled.
m_bVisible | TRUE if action is visible
m_nHelpId | Help identifier
m_nIconId | Identifier of the action's image.
m_nId | Identifier of the action.
m_nTag | Action tag.
m_pActions | Parent actions object
m_pTarget | Parameter of action
m_strCaption | Caption of the action.
m_strCategory | Category of the action.
m_strDescriptionText | Description text.
m_strEditHint | Edit Hint for Combo and Edit Controls
m_strKey | Key
m_strKeyboardTip | Keyboard tip
m_strShortcutText | Shortcut text
m_strTooltipText | Tooltip text.
CXTPControlAction Destructors
CXTPControlAction Destructors | Description
~CXTPControlAction | Destroys a CXTPControlAction object, handles cleanup and deallocation
CXTPControlAction Methods
CXTPControlAction Methods | Description
AddControl | This method is called when new control attached to the Action
DoPropExchange | Reads or writes this object from or to an archive.
GetCaption | Call this member to get the action's caption.
GetCategory | Call this method to retrieve the category of the action.
GetChecked | Call this member to get the state of the action.
GetCommandBars | Call this member to get pointer to owner CommandBars
GetControl | Call this member to get control associated with action
GetCount | Call this member to get number of controls associated with the action
GetDescription | Call this member to get the action's description.
GetEditHint | Call this member to get grayed-out text displayed in the edit and combo controls that displayed a helpful description of what the control is used for.
GetEnabled | Call this member to get the state of the action.
GetHelpId | Call this member to get the help identifier.
GetIconId | Call this member to get the icon's identifier.
GetID | Call this member to get the action's identifier.
GetKeyboardTip | Call this member to get the action's keyboard tip.
GetShortcutText | Call this member to get the action's shortcut.
GetTag | This method retrieves the application-supplied 32-bit value associated with the action.
GetTooltip | Call this member to get the action's tooltip.
IsVisible | Call this member to determine if the action is visible.
OnChanged | This method is called when property of action was changed
OnChanging | This method is called when property of action is about to be changed
OnRemoved | This method called before action removed
RedrawControls | Call this member to redraw all controls associated with actions
RemoveControl | This method is called to remove control from actions list
RepositionControls | Call this member to reposition all controls associated with actions
SetCaption |
SetCategory | Call this method to set the category of the action.
SetChecked | Call this member to check the action.
SetDescription | Call this member to set the description of the action.
SetEditHint | Call this member to set grayed-out text displayed in the edit and combo controls that displayed a helpful description of what the control is used for.
SetEnabled | Call this member to enable or disable the action.
SetHelpId | Call this member to set the action help identifier.
SetIconId | Call this member to set the action icon's identifier.
SetKeyboardTip | Call this member to set the keyboard tip to the action.
SetPrompt | Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a action.
SetShortcutText | Call this member to set the shortcut string to the action.
SetTag | This method sets the 32-bit value associated with the action
SetTooltip | Call this member to set the tooltip of the action.
SetVisible | Call this member to change the state of the action.


CXTPControlAction Data Members

CXTPControlAction Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction Data Members
Class

CXTPControlAction Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrControls | Associated controls
m_bChecked | TRUE if the action is checked.
m_bEnabled | TRUE if the action is enabled.
m_bVisible | TRUE if action is visible
m_nHelpId | Help identifier
m_nIconId | Identifier of the action's image.
m_nId | Identifier of the action.
m_nTag | Action tag.
m_pActions | Parent actions object
m_strCaption | Caption of the action.
m_strCategory | Category of the action.
m_strDescriptionText | Description text.
m_strEditHint | Edit Hint for Combo and Edit Controls
m_strKey | Key
m_strKeyboardTip | Keyboard tip
m_strShortcutText | Shortcut text
m_strTooltipText | Tooltip text.
Public Data Members
Public Data Member | Description
m_pTarget | Parameter of action


CXTPControlAction::m_arrControls Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_arrControls Data Member

Associated controls

CArray<CXTPControl*, CXTPControl*> m_arrControls;
Group

CXTPControlAction Data Members


CXTPControlAction::m_bChecked Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_bChecked Data Member

TRUE if the action is checked.

BOOL m_bChecked;
Group

CXTPControlAction Data Members


CXTPControlAction::m_bEnabled Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_bEnabled Data Member

TRUE if the action is enabled.

BOOL m_bEnabled;
Group

CXTPControlAction Data Members


CXTPControlAction::m_bVisible Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_bVisible Data Member

TRUE if action is visible

BOOL m_bVisible;
Group

CXTPControlAction Data Members


CXTPControlAction::m_nHelpId Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_nHelpId Data Member

Help identifier

int m_nHelpId;
Group

CXTPControlAction Data Members


CXTPControlAction::m_nIconId Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_nIconId Data Member

Identifier of the action's image.

int m_nIconId;
Group

CXTPControlAction Data Members


CXTPControlAction::m_nId Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_nId Data Member

Identifier of the action.

int m_nId;
Group

CXTPControlAction Data Members


CXTPControlAction::m_nTag Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_nTag Data Member

Action tag.

DWORD_PTR m_nTag;
Group

CXTPControlAction Data Members


CXTPControlAction::m_pActions Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_pActions Data Member

Parent actions object

CXTPControlActions* m_pActions;
Group

CXTPControlAction Data Members


CXTPControlAction::m_pTarget Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_pTarget Data Member

Parameter of action

CCmdTarget* m_pTarget;
Group

CXTPControlAction Data Members


CXTPControlAction::m_strCaption Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_strCaption Data Member

Caption of the action.

CString m_strCaption;
Group

CXTPControlAction Data Members


CXTPControlAction::m_strCategory Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_strCategory Data Member

Category of the action.

CString m_strCategory;
Group

CXTPControlAction Data Members


CXTPControlAction::m_strDescriptionText Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_strDescriptionText Data Member

Description text.

CString m_strDescriptionText;
Group

CXTPControlAction Data Members


CXTPControlAction::m_strEditHint Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_strEditHint Data Member

Edit Hint for Combo and Edit Controls

CString m_strEditHint;
Group

CXTPControlAction Data Members


CXTPControlAction::m_strKey Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_strKey Data Member

Key

CString m_strKey;
Group

CXTPControlAction Data Members


CXTPControlAction::m_strKeyboardTip Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_strKeyboardTip Data Member

Keyboard tip

CString m_strKeyboardTip;
Group

CXTPControlAction Data Members


CXTPControlAction::m_strShortcutText Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_strShortcutText Data Member

Shortcut text

CString m_strShortcutText;
Group

CXTPControlAction Data Members


CXTPControlAction::m_strTooltipText Data Member

CXTPControlAction Data Members, CXTPControlAction Class
CXTPControlAction::m_strTooltipText Data Member

Tooltip text.

CString m_strTooltipText;
Group

CXTPControlAction Data Members


CXTPControlAction Methods

CXTPControlAction Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction Methods
Class

CXTPControlAction Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
AddControl | This method is called when new control attached to the Action
OnChanged | This method is called when property of action was changed
OnChanging | This method is called when property of action is about to be changed
OnRemoved | This method called before action removed
RemoveControl | This method is called to remove control from actions list
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Reads or writes this object from or to an archive.
GetCaption | Call this member to get the action's caption.
GetCategory | Call this method to retrieve the category of the action.
GetChecked | Call this member to get the state of the action.
GetCommandBars | Call this member to get pointer to owner CommandBars
GetControl | Call this member to get control associated with action
GetCount | Call this member to get number of controls associated with the action
GetDescription | Call this member to get the action's description.
GetEditHint | Call this member to get grayed-out text displayed in the edit and combo controls that displayed a helpful description of what the control is used for.
GetEnabled | Call this member to get the state of the action.
GetHelpId | Call this member to get the help identifier.
GetIconId | Call this member to get the icon's identifier.
GetID | Call this member to get the action's identifier.
GetKeyboardTip | Call this member to get the action's keyboard tip.
GetShortcutText | Call this member to get the action's shortcut.
GetTag | This method retrieves the application-supplied 32-bit value associated with the action.
GetTooltip | Call this member to get the action's tooltip.
IsVisible | Call this member to determine if the action is visible.
RedrawControls | Call this member to redraw all controls associated with actions
RepositionControls | Call this member to reposition all controls associated with actions
SetCaption |
SetCategory | Call this method to set the category of the action.
SetChecked | Call this member to check the action.
SetDescription | Call this member to set the description of the action.
SetEditHint | Call this member to set grayed-out text displayed in the edit and combo controls that displayed a helpful description of what the control is used for.
SetEnabled | Call this member to enable or disable the action.
SetHelpId | Call this member to set the action help identifier.
SetIconId | Call this member to set the action icon's identifier.
SetKeyboardTip | Call this member to set the keyboard tip to the action.
SetPrompt | Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a action.
SetShortcutText | Call this member to set the shortcut string to the action.
SetTag | This method sets the 32-bit value associated with the action
SetTooltip | Call this member to set the tooltip of the action.
SetVisible | Call this member to change the state of the action.


CXTPControlAction::AddControl Method

CXTPControlAction Methods, CXTPControlAction Class, See Also
CXTPControlAction::AddControl Method

This method is called when new control attached to the Action

void AddControl(
    CXTPControl* pControl
);
Parameters

pControl
Control to be attached

See Also

RemoveControl

Group

CXTPControlAction Methods


CXTPControlAction::DoPropExchange Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlAction Methods


CXTPControlAction::GetCaption Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetCaption Method

Call this member to get the action's caption.

CString GetCaption() const;
Returns

The caption of the control.

Body Source
CString CXTPControlAction::GetCaption() const {
    return m_strCaption.IsEmpty() ? m_strTooltipText : m_strCaption;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetCategory Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetCategory Method

Call this method to retrieve the category of the action.

CString GetCategory() const;
Returns

Category of the action.

Body Source
CString CXTPControlAction::GetCategory() const {
    return m_strCategory;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetChecked Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetChecked Method

Call this member to get the state of the action.

BOOL GetChecked() const;
Returns

TRUE if the action is checked; otherwise FALSE.

Body Source
BOOL CXTPControlAction::GetChecked() const {
    return m_bChecked;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetCommandBars Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::GetCommandBars Method

Call this member to get pointer to owner CommandBars

CXTPCommandBars* GetCommandBars() const;
Returns

The pointer to CXTPCommandBars object

Group

CXTPControlAction Methods


CXTPControlAction::GetControl Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::GetControl Method

Call this member to get control associated with action

CXTPControl* GetControl(
    int nIndex
) const;
Parameters

nIndex
Index of control to retrieve

Returns

The pointer to CXTPCommandBars object

Group

CXTPControlAction Methods


CXTPControlAction::GetCount Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::GetCount Method

Call this member to get number of controls associated with the action

int GetCount() const;
Returns

Total number of controls associated with action

Group

CXTPControlAction Methods


CXTPControlAction::GetDescription Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetDescription Method

Call this member to get the action's description.

CString GetDescription() const;
Returns

The description of the control.

Body Source
CString CXTPControlAction::GetDescription() const {
    return m_strDescriptionText;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetEditHint Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetEditHint Method

Call this member to get grayed-out text displayed in the edit and combo controls that displayed a helpful description of what the control is used for.

CString GetEditHint() const;
Returns

Edit hint of the control

Body Source
CString CXTPControlAction::GetEditHint() const {
    return m_strEditHint;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetEnabled Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::GetEnabled Method

Call this member to get the state of the action.

BOOL GetEnabled() const;
Returns

TRUE if the action is enabled; otherwise FALSE.

Group

CXTPControlAction Methods


CXTPControlAction::GetHelpId Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetHelpId Method

Call this member to get the help identifier.

int GetHelpId() const;
Returns

Help identifier of the action.

Body Source
int CXTPControlAction::GetHelpId() const {
    return m_nHelpId <= 0 ? m_nId : m_nHelpId;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetIconId Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetIconId Method

Call this member to get the icon's identifier.

int GetIconId() const;
Returns

An icon's identifier of the action.

Body Source
int CXTPControlAction::GetIconId() const {
    return m_nIconId <= 0 ? m_nId : m_nIconId;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetID Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetID Method

Call this member to get the action's identifier.

int GetID() const;
Returns

The identifier of the control.

Body Source
int CXTPControlAction::GetID () const {
    return m_nId;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetKeyboardTip Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetKeyboardTip Method

Call this member to get the action's keyboard tip.

CString GetKeyboardTip() const;
Returns

The keyboard tip of the control.

Body Source
CString CXTPControlAction::GetKeyboardTip() const {
    return m_strKeyboardTip;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetShortcutText Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetShortcutText Method

Call this member to get the action's shortcut.

CString GetShortcutText() const;
Returns

The shortcut of the control.

Body Source
CString CXTPControlAction::GetShortcutText() const {
    return m_strShortcutText;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetTag Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetTag Method

This method retrieves the application-supplied 32-bit value associated with the action.

DWORD_PTR GetTag() const;
Returns

The 32-bit value associated with the action.

Body Source
DWORD_PTR CXTPControlAction::GetTag() const {
    return m_nTag;
}
Group

CXTPControlAction Methods


CXTPControlAction::GetTooltip Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::GetTooltip Method

Call this member to get the action's tooltip.

CString GetTooltip() const;
Returns

Tooltip of the control.

Body Source
CString CXTPControlAction::GetTooltip() const {
    return m_strTooltipText;
}
Group

CXTPControlAction Methods


CXTPControlAction::IsVisible Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::IsVisible Method

Call this member to determine if the action is visible.

BOOL IsVisible() const;
Returns

TRUE if the action is visible.

Body Source
BOOL CXTPControlAction::IsVisible() const {
    return m_bVisible;
}
Group

CXTPControlAction Methods


CXTPControlAction::OnChanged Method

CXTPControlAction Methods, CXTPControlAction Class, See Also
CXTPControlAction::OnChanged Method

This method is called when property of action was changed

void OnChanged(
    int nProperty
);
Parameters

nProperty
Property identifier

See Also

OnChanging

Group

CXTPControlAction Methods


CXTPControlAction::OnChanging Method

CXTPControlAction Methods, CXTPControlAction Class, See Also
CXTPControlAction::OnChanging Method

This method is called when property of action is about to be changed

void OnChanging(
    int nProperty
);
Parameters

nProperty
Property identifier

See Also

OnChanged

Group

CXTPControlAction Methods


CXTPControlAction::OnRemoved Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::OnRemoved Method

This method called before action removed

void OnRemoved();
Group

CXTPControlAction Methods


CXTPControlAction::RedrawControls Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::RedrawControls Method

Call this member to redraw all controls associated with actions

void RedrawControls();
Group

CXTPControlAction Methods


CXTPControlAction::RemoveControl Method

CXTPControlAction Methods, CXTPControlAction Class, See Also
CXTPControlAction::RemoveControl Method

This method is called to remove control from actions list

void RemoveControl(
    CXTPControl* pControl
);
Parameters

pControl
Control to be removed

See Also

AddControl

Group

CXTPControlAction Methods


CXTPControlAction::RepositionControls Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::RepositionControls Method

Call this member to reposition all controls associated with actions

void RepositionControls();
Group

CXTPControlAction Methods


SetCaption Method

CXTPControlAction Methods
SetCaption Method
Overload List
Methods
Method | Description
CXTPControlAction::SetCaption (LPCTSTR) | Call this member to set the caption of the action.
CXTPControlAction::SetCaption (UINT) | Call this member to set the caption of the control.
Group

CXTPControlAction Methods


CXTPControlAction::SetCaption Method (LPCTSTR)

SetCaption Method, CXTPControlAction Class, See Also
CXTPControlAction::SetCaption Method (LPCTSTR)

Call this member to set the caption of the action.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
Caption to be set.
nIDCaption
Caption resource identifier.

See Also

SetPrompt, SetDescription, SetTooltip

Group

SetCaption Method


CXTPControlAction::SetCategory Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetCategory Method

Call this method to set the category of the action.

void SetCategory(
    LPCTSTR lpszCategory
);
Parameters

lpszCategory
Category of the action.

Body Source
void CXTPControlAction::SetCategory(LPCTSTR lpszCategory) {
    m_strCategory = lpszCategory;
}
Group

CXTPControlAction Methods


CXTPControlAction::SetChecked Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetChecked Method

Call this member to check the action.

void SetChecked(
    BOOL bChecked
);
Parameters

bChecked
TRUE if the action is checked.

See Also

GetChecked, SetEnabled

Body Source
void CXTPControlAction::SetChecked(BOOL bChecked) {
    if (m_bChecked != bChecked) {m_bChecked = bChecked; OnChanged(1); RedrawControls();}
}
Group

CXTPControlAction Methods


CXTPControlAction::SetDescription Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetDescription Method

Call this member to set the description of the action.

void SetDescription(
    LPCTSTR lpszDescription
);
Parameters

lpszDescription
Description to be set.

See Also

SetCaption, SetPrompt, SetTooltip

Body Source
void CXTPControlAction::SetDescription(LPCTSTR lpszDescription) {
    m_strDescriptionText = lpszDescription;
}
Group

CXTPControlAction Methods


CXTPControlAction::SetEditHint Method

CXTPControlAction Methods, CXTPControlAction Class
CXTPControlAction::SetEditHint Method

Call this member to set grayed-out text displayed in the edit and combo controls that displayed a helpful description of what the control is used for.

void SetEditHint(
    LPCTSTR lpszEditHint
);
Parameters

lpszEditHint
Edit hint to be set

Group

CXTPControlAction Methods


CXTPControlAction::SetEnabled Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetEnabled Method

Call this member to enable or disable the action.

void SetEnabled(
    BOOL bEnabled
);
Parameters

bEnabled
TRUE if the action is enabled.

See Also

GetEnabled, SetChecked

Body Source
void CXTPControlAction::SetEnabled(BOOL bEnabled) {
    if (m_bEnabled != bEnabled) {m_bEnabled = bEnabled; OnChanged(0); RedrawControls();}
}
Group

CXTPControlAction Methods


CXTPControlAction::SetHelpId Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetHelpId Method

Call this member to set the action help identifier.

void SetHelpId(
    int nId
);
Parameters

nId
Help identifier to be set.

Body Source
void CXTPControlAction::SetHelpId(int nId) {
    m_nHelpId = nId;
}
Group

CXTPControlAction Methods


CXTPControlAction::SetIconId Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetIconId Method

Call this member to set the action icon's identifier.

void SetIconId(
    int nId
);
Parameters

nId
Icon's identifier to be set.

Body Source
void CXTPControlAction::SetIconId(int nId) {
    if (m_nIconId != nId) {m_nIconId = nId; RedrawControls();}
}
Group

CXTPControlAction Methods


CXTPControlAction::SetKeyboardTip Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetKeyboardTip Method

Call this member to set the keyboard tip to the action.

void SetKeyboardTip(
    LPCTSTR lpszKeyboardTip
);
Parameters

lpszKeyboardTip
Keyboard tip to be set.

Body Source
void CXTPControlAction::SetKeyboardTip(LPCTSTR lpszKeyboardTip) {
    m_strKeyboardTip = lpszKeyboardTip;
}
Group

CXTPControlAction Methods


CXTPControlAction::SetPrompt Method

CXTPControlAction Methods, CXTPControlAction Class, See Also
CXTPControlAction::SetPrompt Method

Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a action.

void SetPrompt(
    LPCTSTR lpszPrompt
);
Parameters

lpszPrompt
String from resource file that contains the tooltip and description of the item. The Caption will be set to use the tooltip text. The tooltip and description must be separated by "n" if both are included. You can omit the description and both the tooltip and description will be set to the same value.

Remarks

Resource strings are in the format "DescriptionnToolTip".

Notes

The caption is set to the value of the tooltip when this member is called.

See Also

SetCaption, SetDescription, SetTooltip

Group

CXTPControlAction Methods


CXTPControlAction::SetShortcutText Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetShortcutText Method

Call this member to set the shortcut string to the action.

void SetShortcutText(
    LPCTSTR lpszShortcutText
);
Parameters

lpszShortcutText
Shortcut to be set.

Body Source
void CXTPControlAction::SetShortcutText(LPCTSTR lpszShortcutText) {
    m_strShortcutText = lpszShortcutText;
}
Group

CXTPControlAction Methods


CXTPControlAction::SetTag Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetTag Method

This method sets the 32-bit value associated with the action

void SetTag(
    DWORD_PTR dwTag
);
Parameters

dwTag
Contains the new value to associate with the action.

Body Source
void CXTPControlAction::SetTag(DWORD_PTR dwTag) {
    m_nTag = dwTag;
}
Group

CXTPControlAction Methods


CXTPControlAction::SetTooltip Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetTooltip Method

Call this member to set the tooltip of the action.

void SetTooltip(
    LPCTSTR lpszTooltip
);
Parameters

lpszTooltip
Tooltip to be set.

See Also

SetCaption, SetDescription, SetPrompt

Body Source
void CXTPControlAction::SetTooltip(LPCTSTR lpszTooltip) {
    m_strTooltipText = lpszTooltip;
}
Group

CXTPControlAction Methods


CXTPControlAction::SetVisible Method

CXTPControlAction Methods, CXTPControlAction Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlAction::SetVisible Method

Call this member to change the state of the action.

void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE if the action is visible.

Body Source
void CXTPControlAction::SetVisible(BOOL bVisible) {
    if (m_bVisible != bVisible) { m_bVisible = bVisible; OnChanged(2); RepositionControls();}
}
Group

CXTPControlAction Methods


CXTPControlAction Constructors

CXTPControlAction Class, Legend, Protected Methods
CXTPControlAction Constructors
Class

CXTPControlAction Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPControlAction | Constructs a CXTPControlAction object


CXTPControlAction::CXTPControlAction Constructor

CXTPControlAction Constructors, CXTPControlAction Class
CXTPControlAction::CXTPControlAction Constructor

Constructs a CXTPControlAction object

CXTPControlAction(
    CXTPControlActions* pActions
);
Parameters

pActions
Owner actions collection.

Group

CXTPControlAction Constructors


CXTPControlAction Destructors

CXTPControlAction Class, Legend, Protected Methods
CXTPControlAction Destructors
Class

CXTPControlAction Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPControlAction | Destroys a CXTPControlAction object, handles cleanup and deallocation


CXTPControlAction::~CXTPControlAction Destructor

CXTPControlAction Destructors, CXTPControlAction Class
CXTPControlAction::~CXTPControlAction Destructor

Destroys a CXTPControlAction object, handles cleanup and deallocation

~CXTPControlAction();
Group

CXTPControlAction Destructors


CXTPControlActions Class

XTPControl.h, Classes, Legend, Members, Topics, CXTPControlActions Data Members, CXTPControlActions Methods, CXTPControlActions Constructors, CXTPControlActions Destructors, CXTPControlActions Constructors, CXTPControlActions Data Members, CXTPControlActions Destructors, CXTPControlActions Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlActions Class

CXTPControlActions is a CCmdTarget derived class. It represents a collection of the actions.

Class Hierarchy

class CXTPControlActions;
File

XTPControl.h

Group

Classes

Legend
Data Member
protected
Method
CXTPControlActions Constructors
CXTPControlActions Constructors | Description
CXTPControlActions | Constructs a CXTPControlActions object
CXTPControlActions Data Members
CXTPControlActions Data Members | Description
m_arrActions | Actions array
m_pCommandBars | Parent CommandBars object
CXTPControlActions Destructors
CXTPControlActions Destructors | Description
~CXTPControlActions | Destroys a CXTPControlActions object, handles cleanup and deallocation
CXTPControlActions Methods
CXTPControlActions Methods | Description
Add |
CreateFromMenu | Call this method to create actions using menu commands
DoPropExchange | Reads or writes this object from or to an archive.
FindAction | Call this member to find the specified action.
GetAt | Call this member to return the action at the specified index.
GetCount | Call this member to get the count of the actions
RemoveAll | Call this member to remove all actions.


CXTPControlActions Data Members

CXTPControlActions Class, Legend, Protected Data Members
CXTPControlActions Data Members
Class

CXTPControlActions Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrActions | Actions array
m_pCommandBars | Parent CommandBars object


CXTPControlActions::m_arrActions Data Member

CXTPControlActions Data Members, CXTPControlActions Class
CXTPControlActions::m_arrActions Data Member

Actions array

CArray<CXTPControlAction*, CXTPControlAction*> m_arrActions;
Group

CXTPControlActions Data Members


CXTPControlActions::m_pCommandBars Data Member

CXTPControlActions Data Members, CXTPControlActions Class
CXTPControlActions::m_pCommandBars Data Member

Parent CommandBars object

CXTPCommandBars* m_pCommandBars;
Group

CXTPControlActions Data Members


CXTPControlActions Methods

CXTPControlActions Class, Legend, Public Methods
CXTPControlActions Methods
Class

CXTPControlActions Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add |
CreateFromMenu | Call this method to create actions using menu commands
DoPropExchange | Reads or writes this object from or to an archive.
FindAction | Call this member to find the specified action.
GetAt | Call this member to return the action at the specified index.
GetCount | Call this member to get the count of the actions
RemoveAll | Call this member to remove all actions.


Add Method

CXTPControlActions Methods
Add Method
Overload List
Methods
Method | Description
CXTPControlActions::Add (int) | Call this member to add a new action.
CXTPControlActions::Add (int, CXTPControlAction*) | Call this member to add a new action.
Group

CXTPControlActions Methods


CXTPControlActions::Add Method (int)

Add Method, CXTPControlActions Class
CXTPControlActions::Add Method (int)

Call this member to add a new action.

CXTPControlAction* Add(
    int nId
);
CXTPControlAction* Add(
    int nId,
    CXTPControlAction* pAction
);
Parameters

nId
Identifier of the control to be added.
pAction
Action to add

Returns

A pointer to the added action.

Group

Add Method


CXTPControlActions::CreateFromMenu Method

CXTPControlActions Methods, CXTPControlActions Class
CXTPControlActions::CreateFromMenu Method

Call this method to create actions using menu commands

void CreateFromMenu(
    CMenu* pMenu
);
Parameters

pMenu
Menu pointer to convert from

Group

CXTPControlActions Methods


CXTPControlActions::DoPropExchange Method

CXTPControlActions Methods, CXTPControlActions Class
CXTPControlActions::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlActions Methods


CXTPControlActions::FindAction Method

CXTPControlActions Methods, CXTPControlActions Class
CXTPControlActions::FindAction Method

Call this member to find the specified action.

CXTPControlAction* FindAction(
    int nId
) const;
Parameters

nId
The action's identifier.

Returns

Pointer to the CXTPControlAction object if successful; otherwise returns NULL.

Group

CXTPControlActions Methods


CXTPControlActions::GetAt Method

CXTPControlActions Methods, CXTPControlActions Class
CXTPControlActions::GetAt Method

Call this member to return the action at the specified index.

CXTPControlAction* GetAt(
    int nIndex
) const;
Parameters

nIndex
An integer index.

Returns

The CXTPControlAction pointer currently at this index.

Group

CXTPControlActions Methods


CXTPControlActions::GetCount Method

CXTPControlActions Methods, CXTPControlActions Class
CXTPControlActions::GetCount Method

Call this member to get the count of the actions

int GetCount() const;
Returns

The count of the actions.

Group

CXTPControlActions Methods


CXTPControlActions::RemoveAll Method

CXTPControlActions Methods, CXTPControlActions Class
CXTPControlActions::RemoveAll Method

Call this member to remove all actions.

void RemoveAll();
Group

CXTPControlActions Methods


CXTPControlActions Constructors

CXTPControlActions Class, Legend, Protected Methods
CXTPControlActions Constructors
Class

CXTPControlActions Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPControlActions | Constructs a CXTPControlActions object


CXTPControlActions::CXTPControlActions Constructor

CXTPControlActions Constructors, CXTPControlActions Class
CXTPControlActions::CXTPControlActions Constructor

Constructs a CXTPControlActions object

CXTPControlActions(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
Parent commandbars object

Group

CXTPControlActions Constructors


CXTPControlActions Destructors

CXTPControlActions Class, Legend, Protected Methods
CXTPControlActions Destructors
Class

CXTPControlActions Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPControlActions | Destroys a CXTPControlActions object, handles cleanup and deallocation


CXTPControlActions::~CXTPControlActions Destructor

CXTPControlActions Destructors, CXTPControlActions Class
CXTPControlActions::~CXTPControlActions Destructor

Destroys a CXTPControlActions object, handles cleanup and deallocation

~CXTPControlActions();
Group

CXTPControlActions Destructors


CXTPControlBitmap Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlBitmap Methods, CXTPControlBitmap Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlBitmap Class

CXTPControlBitmap is a CXTPControlLabel derived class. It can be used to add bitmap to toolbar.

Class Hierarchy

class CXTPControlBitmap : public CXTPControlLabel;
File

XTPControlExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlBitmap Methods
CXTPControlBitmap Methods | Description
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.


CXTPControlBitmap Methods

CXTPControlBitmap Class, Legend, Protected Methods
CXTPControlBitmap Methods
Class

CXTPControlBitmap Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.


CXTPControlBitmap::Draw Method

CXTPControlBitmap Methods, CXTPControlBitmap Class
CXTPControlBitmap::Draw Method

This method is called to draw the control.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlBitmap Methods


CXTPControlBitmap::GetSize Method

CXTPControlBitmap Methods, CXTPControlBitmap Class
CXTPControlBitmap::GetSize Method

This method is called to determine the size of the control.

virtual CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlBitmap Methods


CXTPControlButton Class

XTPControlButton.h, Classes, Legend, Members, Topics, CXTPControlButton Methods, CXTPControlButton Constructors, CXTPControlButton Destructors, CXTPControlButton Constructors, CXTPControlButton Destructors, CXTPControlButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlButton Class

CXTPControlButton is a CXTPControl derived class. It represents a button control.

Class Hierarchy

class CXTPControlButton : public CXTPControl;
File

XTPControlButton.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlButton Constructors
CXTPControlButton Constructors | Description
CXTPControlButton | Constructs a CXTPControlButton object
CXTPControlButton Destructors
CXTPControlButton Destructors | Description
~CXTPControlButton | Destroys a CXTPControlButton object, handles cleanup and deallocation
CXTPControlButton Methods
CXTPControlButton Methods | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
OnClick | This method is called when the user clicks the control.
OnLButtonUp | This member is called when the user releases the left mouse button.


CXTPControlButton Methods

CXTPControlButton Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlButton Methods
Class

CXTPControlButton Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
OnClick | This method is called when the user clicks the control.
OnLButtonUp | This member is called when the user releases the left mouse button.
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Reads or writes this object from or to an archive.


CXTPControlButton::Copy Method

CXTPControlButton Methods, CXTPControlButton Class
CXTPControlButton::Copy Method

This method is called to copy the control.

virtual void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlButton Methods


CXTPControlButton::DoPropExchange Method

CXTPControlButton Methods, CXTPControlButton Class
CXTPControlButton::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlButton Methods


CXTPControlButton::OnClick Method

CXTPControlButton Methods, CXTPControlButton Class
CXTPControlButton::OnClick Method

This method is called when the user clicks the control.

virtual void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlButton Methods


CXTPControlButton::OnLButtonUp Method

CXTPControlButton Methods, CXTPControlButton Class
CXTPControlButton::OnLButtonUp Method

This member is called when the user releases the left mouse button.

virtual void OnLButtonUp(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlButton Methods


CXTPControlButton Constructors

CXTPControlButton Class, Legend, Public Methods
CXTPControlButton Constructors
Class

CXTPControlButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlButton | Constructs a CXTPControlButton object


CXTPControlButton::CXTPControlButton Constructor

CXTPControlButton Constructors, CXTPControlButton Class
CXTPControlButton::CXTPControlButton Constructor

Constructs a CXTPControlButton object

CXTPControlButton();
Group

CXTPControlButton Constructors


CXTPControlButton Destructors

CXTPControlButton Class, Legend, Public Methods
CXTPControlButton Destructors
Class

CXTPControlButton Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlButton | Destroys a CXTPControlButton object, handles cleanup and deallocation


CXTPControlButton::~CXTPControlButton Destructor

CXTPControlButton Destructors, CXTPControlButton Class
CXTPControlButton::~CXTPControlButton Destructor

Destroys a CXTPControlButton object, handles cleanup and deallocation

virtual ~CXTPControlButton();
Group

CXTPControlButton Destructors


CXTPControlButtonColor Class

XTPControlPopupColor.h, Classes, Legend, Members, Topics, CXTPControlButtonColor Methods, CXTPControlButtonColor Constructors, CXTPControlButtonColor Constructors, CXTPControlButtonColor Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlButtonColor Class

CXTPControlButtonColor is a CXTPControlButton derived class. It represents a text button in the color picker popup.

Class Hierarchy

class CXTPControlButtonColor : public CXTPControlButton;
File

XTPControlPopupColor.h

Group

Classes

Legend
Method
protected
CXTPControlButtonColor Constructors
CXTPControlButtonColor Constructors | Description
CXTPControlButtonColor | Constructs a CXTPControlButtonColor object
CXTPControlButtonColor Methods
CXTPControlButtonColor Methods | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetColor | Call this member to retrieve the color of the control.
GetSize | This method is called to determine the size of the control.
SetColor | Call this method to set the color of the control.


CXTPControlButtonColor Methods

CXTPControlButtonColor Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlButtonColor Methods
Class

CXTPControlButtonColor Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
Public Methods
Public Methods
Public Method | Description
GetColor | Call this member to retrieve the color of the control.
SetColor | Call this method to set the color of the control.


CXTPControlButtonColor::Copy Method

CXTPControlButtonColor Methods, CXTPControlButtonColor Class
CXTPControlButtonColor::Copy Method

This method is called to copy the control.

void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlButtonColor Methods


CXTPControlButtonColor::DoPropExchange Method

CXTPControlButtonColor Methods, CXTPControlButtonColor Class
CXTPControlButtonColor::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlButtonColor Methods


CXTPControlButtonColor::Draw Method

CXTPControlButtonColor Methods, CXTPControlButtonColor Class
CXTPControlButtonColor::Draw Method

This method is called to draw the control.

void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlButtonColor Methods


CXTPControlButtonColor::GetColor Method

CXTPControlButtonColor Methods, CXTPControlButtonColor Class
CXTPControlButtonColor::GetColor Method

Call this member to retrieve the color of the control.

COLORREF GetColor() const;
Returns

Color of the selector.

Group

CXTPControlButtonColor Methods


CXTPControlButtonColor::GetSize Method

CXTPControlButtonColor Methods, CXTPControlButtonColor Class
CXTPControlButtonColor::GetSize Method

This method is called to determine the size of the control.

CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlButtonColor Methods


CXTPControlButtonColor::SetColor Method

CXTPControlButtonColor Methods, CXTPControlButtonColor Class
CXTPControlButtonColor::SetColor Method

Call this method to set the color of the control.

void SetColor(
    COLORREF clr
);
Parameters

clr
Color to set.

Group

CXTPControlButtonColor Methods


CXTPControlButtonColor Constructors

CXTPControlButtonColor Class, Legend, Public Methods
CXTPControlButtonColor Constructors
Class

CXTPControlButtonColor Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlButtonColor | Constructs a CXTPControlButtonColor object


CXTPControlButtonColor::CXTPControlButtonColor Constructor

CXTPControlButtonColor Constructors, CXTPControlButtonColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlButtonColor::CXTPControlButtonColor Constructor

Constructs a CXTPControlButtonColor object

CXTPControlButtonColor();
Group

CXTPControlButtonColor Constructors


CXTPControlCheckBox Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlCheckBox Constructors, CXTPControlCheckBox Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlCheckBox Class

CXTPControlCheckBox is a CXTPControlButton derived class. It represents a checkbox control.

Class Hierarchy

class CXTPControlCheckBox : public CXTPControlButton;
File

XTPControlExt.h

Group

Classes

Legend
Constructor
CXTPControlCheckBox Constructors
CXTPControlCheckBox Constructors | Description
CXTPControlCheckBox | Constructs a CXTPControlCheckBox Object.


CXTPControlCheckBox Constructors

CXTPControlCheckBox Class, Legend, Public Methods
CXTPControlCheckBox Constructors
Class

CXTPControlCheckBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlCheckBox | Constructs a CXTPControlCheckBox Object.


CXTPControlCheckBox::CXTPControlCheckBox Constructor

CXTPControlCheckBox Constructors, CXTPControlCheckBox Class
CXTPControlCheckBox::CXTPControlCheckBox Constructor

Constructs a CXTPControlCheckBox Object.

CXTPControlCheckBox();
Group

CXTPControlCheckBox Constructors


CXTPControlColorSelector Class

XTPControlPopupColor.h, Classes, Legend, Members, Topics, CXTPControlColorSelector Methods, CXTPControlColorSelector Constructors, CXTPControlColorSelector Constructors, CXTPControlColorSelector Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector Class

CXTPControlColorSelector is a CXTPControl derived class. It represents a color selector control.

Class Hierarchy

class CXTPControlColorSelector : public CXTPControl;
File

XTPControlPopupColor.h

Group

Classes

Legend
Method
protected
CXTPControlColorSelector Constructors
CXTPControlColorSelector Constructors | Description
CXTPControlColorSelector | Constructs a CXTPControlColorSelector object
CXTPControlColorSelector Methods
CXTPControlColorSelector Methods | Description
Draw | This method is called to draw the control.
GetColor | Call this member to retrieve the color of the selector control.
GetSize | This method is called to determine the size of the control.
OnClick | This method is called when the user clicks the control.
OnExecute | This method is called when the control is executed.
OnLButtonUp | This member is called when the user releases the left mouse button.
OnMouseMove | This member is called when the mouse cursor moves.
OnSetSelected | This method is called when the control becomes selected.
SetColor | Call this method to set the color of the control.


CXTPControlColorSelector Methods

CXTPControlColorSelector Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector Methods
Class

CXTPControlColorSelector Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
OnClick | This method is called when the user clicks the control.
OnExecute | This method is called when the control is executed.
OnLButtonUp | This member is called when the user releases the left mouse button.
OnMouseMove | This member is called when the mouse cursor moves.
OnSetSelected | This method is called when the control becomes selected.
Public Methods
Public Methods
Public Method | Description
GetColor | Call this member to retrieve the color of the selector control.
SetColor | Call this method to set the color of the control.


CXTPControlColorSelector::Draw Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::Draw Method

This method is called to draw the control.

void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlColorSelector Methods


CXTPControlColorSelector::GetColor Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::GetColor Method

Call this member to retrieve the color of the selector control.

COLORREF GetColor() const;
Returns

Color of the selector.

Group

CXTPControlColorSelector Methods


CXTPControlColorSelector::GetSize Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::GetSize Method

This method is called to determine the size of the control.

CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlColorSelector Methods


CXTPControlColorSelector::OnClick Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::OnClick Method

This method is called when the user clicks the control.

void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlColorSelector Methods


CXTPControlColorSelector::OnExecute Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::OnExecute Method

This method is called when the control is executed.

void OnExecute();
Group

CXTPControlColorSelector Methods


CXTPControlColorSelector::OnLButtonUp Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::OnLButtonUp Method

This member is called when the user releases the left mouse button.

void OnLButtonUp(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlColorSelector Methods


CXTPControlColorSelector::OnMouseMove Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::OnMouseMove Method

This member is called when the mouse cursor moves.

void OnMouseMove(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlColorSelector Methods


CXTPControlColorSelector::OnSetSelected Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::OnSetSelected Method

This method is called when the control becomes selected.

BOOL OnSetSelected(
    int bSelected
);
Parameters

bSelected
TRUE if the control becomes selected.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlColorSelector Methods


CXTPControlColorSelector::SetColor Method

CXTPControlColorSelector Methods, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::SetColor Method

Call this method to set the color of the control.

void SetColor(
    COLORREF clr
);
Parameters

clr
Color to set.

Group

CXTPControlColorSelector Methods


CXTPControlColorSelector Constructors

CXTPControlColorSelector Class, Legend, Public Methods
CXTPControlColorSelector Constructors
Class

CXTPControlColorSelector Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlColorSelector | Constructs a CXTPControlColorSelector object


CXTPControlColorSelector::CXTPControlColorSelector Constructor

CXTPControlColorSelector Constructors, CXTPControlColorSelector Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlColorSelector::CXTPControlColorSelector Constructor

Constructs a CXTPControlColorSelector object

CXTPControlColorSelector();
Group

CXTPControlColorSelector Constructors


CXTPControlComboBox Class

XTPControlComboBox.h, Classes, Legend, Members, Topics, CXTPControlComboBox Data Members, CXTPControlComboBox Methods, CXTPControlComboBox Constructors, CXTPControlComboBox Destructors, CXTPControlComboBox Constructors, CXTPControlComboBox Data Members, CXTPControlComboBox Destructors, CXTPControlComboBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox Class

CXTPControlComboBox is a CXTPControl derived class. It represents a combo box control.

Class Hierarchy

class CXTPControlComboBox : public CXTPControlPopup;
File

XTPControlComboBox.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControlComboBox Constructors
CXTPControlComboBox Constructors | Description
CXTPControlComboBox | Constructs a CXTPControlComboBox object
CXTPControlComboBox Data Members
CXTPControlComboBox Data Members | Description
m_bAutoComplete | TRUE if Auto Complete enabled
m_bDelayDestroy | TRUE if need to recreate control.
m_bDelayReposition | Need to reposition control.
m_bDropDown | TRUE if the combo is dropdown.
m_bEditChanged | TRUE if Edit Text was changed.
m_bFocused | TRUE if control is focused
m_bIgnoreAutoComplete | TRUE to disable auto complete till next key event.
m_bSelEndOk | TRUE if user selects a list item.
m_comboStyle | Style of the combo box.
m_dwEditStyle | Edit style
m_dwShellAutoCompleteFlags | Shell auto complete flags.
m_nDropDownItemCount | Maximum drop down items
m_nEditIconId | Edit Icon identifier
m_nLabelWidth | Width of the label.
m_nLastSel | Last user selected index, (used during display of list box)
m_nThumbWidth | Width of the thumb area.
m_pAutoCompleteWnd | Auto Complete hook window.
m_pEdit | Child edit control.
m_strEditHint | Grayed-out text displayed in the edit control that displayed a helpful description
m_strEditText | Edit text.
m_strLastText | Last Text before user select focus and change it.
CXTPControlComboBox Destructors
CXTPControlComboBox Destructors | Description
~CXTPControlComboBox | Destroys a CXTPControlComboBox object, handles cleanup and deallocation
CXTPControlComboBox Methods
CXTPControlComboBox Methods | Description
AddString | Call this member function to add a string to a list box.
Compare | Call this member to compare controls.
Copy | This method is called to copy the control.
CreateEditControl | This method create edit control. Override it to use inherited edit control.
DeflateEditRect | This method is called to get real rect of edit control of Combo Box
DeleteItem | Call this member function to delete a string.
DoPropExchange | Reads or writes this object from or to an archive.
DrawEditText | This method draw text of control if style is CBS_DROPDOWNLIST
EnableAutoComplete | This member function enables or disables auto completion.
EnableShellAutoComplete | This member function enables or disables shell auto completion.
FindString | This method finds the first string in a list box that contains the specified prefix, without changing the list-box selection
FindStringExact | Call the FindStringExact member function to find the first list-box string (in a combo box) that matches the string specified in str.
GetComboBoxPopupBar | Returns child popup bar
GetCount | Call this member to retrieve the number of items in a list box.
GetCurSel | Call this member function to determine which item in the combo box is selected.
GetCustomizeMinWidth | This member returns the minimum width that the combo box can be sized by the user while in customization mode.
GetDefaultCharFormat | This method is called to get default char format of rich edit text
GetDropDownListStyle | Call this member to determine if the combo box has an edit control.
GetDropDownWidth | Call this member to retrieve the dropdown list width.
GetDroppedState | Call the GetDroppedState member function to determine whether the list box of a drop-down combo box is visible (dropped down).
GetEditCtrl | Call this member to get the edit control of the combo box control.
GetEditHint | Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
GetEditIconId | Call this member to get the edit icon's identifier.
GetEditStyle | Call this member to get the style of edit control.
GetEditText | Call this member to get the edit text.
GetItemData | This method retrieves the application-supplied 32-bit value associated with the specified combo box item.
GetLabelWidth | Call this method to get with of label.
GetLBText | Call this member to retrieve a string from the list box of a combo box control.
GetListBoxCtrl | Retrieves list box window.
GetListBoxText | Call this member to get the currently selected item's text
GetListIconId | Call this member to get the combo list icon's identifier.
GetThumbWidth | Call this method to get with of thumb button.
HasFocus | Call this method to determine if control has focus
InsertString | Call this member function to insert a string into the list box of a combo box control
IsCaptionVisible | Call this member to determine if the caption of the control is visible
IsCustomizeResizeAllow | This member checks if the user can resize control.
IsFocusable | This method is called to check if control accept focus
IsFocused | Call this member to get the focused state of the control.
IsImageVisible | Determines if icon is visible for combo box control
ModifyListBoxStyle | Call this member to modify style of list box
OnActionChanged | This method is called when action property was changed
OnActionChanging | This method is called when action property is about to be changed
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnEditChanged | This method is called then edit control text was changed
OnExecute | This method is called when the control is executed.
OnHookKeyDown | This method is called when a non-system key is pressed.
OnKillFocus | This method is called, then the edit control loses the focus.
OnMouseHover | Called after the mouse hovers over the control.
OnMouseMove | This member is called when the mouse cursor moves.
OnRemoved | This method is called when control was removed from parent controls collection
OnSelChanged | This method is called, then the selected string is changed.
OnSetFocus | This method is called, then edit control gets the focus.
OnSetPopup | This method is called to popup the control.
OnSetSelected | This method is called when the control becomes selected.
OnUnderlineActivate | This method is called when the user activate control using its underline.
ResetContent | Call this member to removes all items from the list box of a combo box control.
SetCurSel | Call this member to select a string in the list box of a combo box.
SetDropDownItemCount | Call this member to set the count of items in the dropdown list.
SetDropDownListStyle | Call this member to insertdelete an edit box in the combo box when the control has focus.
SetDropDownWidth | Call this member to set the width of the dropdown list.
SetEditHint | Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
SetEditIconId | Call this member to set the edit icon's identifier.
SetEditStyle | Call this member to set the style of edit control
SetEditText | Call this member to set the edit control text.
SetEnabled | Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetFocused | Call this member to set focus to the control.
SetHideFlags | This method is called to hide the control.
SetItemData | This method sets the 32-bit value associated with the specified item in a combo box.
SetLabelWidth | This method is called to set width of the label.
SetListIconId |
SetParent | This method is called to assign a parent command bar object.
SetRect | Call this member to set the bounding rectangle of the control.
SetThumbWidth | This method is called to set width of thumb button.


CXTPControlComboBox Data Members

CXTPControlComboBox Class, Legend, Protected Data Members
CXTPControlComboBox Data Members
Class

CXTPControlComboBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoComplete | TRUE if Auto Complete enabled
m_bDelayDestroy | TRUE if need to recreate control.
m_bDelayReposition | Need to reposition control.
m_bDropDown | TRUE if the combo is dropdown.
m_bEditChanged | TRUE if Edit Text was changed.
m_bFocused | TRUE if control is focused
m_bIgnoreAutoComplete | TRUE to disable auto complete till next key event.
m_bSelEndOk | TRUE if user selects a list item.
m_comboStyle | Style of the combo box.
m_dwEditStyle | Edit style
m_dwShellAutoCompleteFlags | Shell auto complete flags.
m_nDropDownItemCount | Maximum drop down items
m_nEditIconId | Edit Icon identifier
m_nLabelWidth | Width of the label.
m_nLastSel | Last user selected index, (used during display of list box)
m_nThumbWidth | Width of the thumb area.
m_pAutoCompleteWnd | Auto Complete hook window.
m_pEdit | Child edit control.
m_strEditHint | Grayed-out text displayed in the edit control that displayed a helpful description
m_strEditText | Edit text.
m_strLastText | Last Text before user select focus and change it.


CXTPControlComboBox::m_bAutoComplete Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_bAutoComplete Data Member

TRUE if Auto Complete enabled

BOOL m_bAutoComplete;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_bDelayDestroy Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_bDelayDestroy Data Member

TRUE if need to recreate control.

BOOL m_bDelayDestroy;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_bDelayReposition Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_bDelayReposition Data Member

Need to reposition control.

BOOL m_bDelayReposition;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_bDropDown Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_bDropDown Data Member

TRUE if the combo is dropdown.

BOOL m_bDropDown;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_bEditChanged Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_bEditChanged Data Member

TRUE if Edit Text was changed.

mutable BOOL m_bEditChanged;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_bFocused Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_bFocused Data Member

TRUE if control is focused

BOOL m_bFocused;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_bIgnoreAutoComplete Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_bIgnoreAutoComplete Data Member

TRUE to disable auto complete till next key event.

BOOL m_bIgnoreAutoComplete;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_bSelEndOk Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_bSelEndOk Data Member

TRUE if user selects a list item.

BOOL m_bSelEndOk;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_comboStyle Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_comboStyle Data Member

Style of the combo box.

XTPButtonStyle m_comboStyle;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_dwEditStyle Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_dwEditStyle Data Member

Edit style

DWORD m_dwEditStyle;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_dwShellAutoCompleteFlags Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_dwShellAutoCompleteFlags Data Member

Shell auto complete flags.

DWORD m_dwShellAutoCompleteFlags;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_nDropDownItemCount Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_nDropDownItemCount Data Member

Maximum drop down items

int m_nDropDownItemCount;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_nEditIconId Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_nEditIconId Data Member

Edit Icon identifier

int m_nEditIconId;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_nLabelWidth Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_nLabelWidth Data Member

Width of the label.

int m_nLabelWidth;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_nLastSel Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_nLastSel Data Member

Last user selected index, (used during display of list box)

int m_nLastSel;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_nThumbWidth Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_nThumbWidth Data Member

Width of the thumb area.

int m_nThumbWidth;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_pAutoCompleteWnd Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_pAutoCompleteWnd Data Member

Auto Complete hook window.

CXTPControlComboBoxAutoCompleteWnd* m_pAutoCompleteWnd;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_pEdit Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_pEdit Data Member

Child edit control.

CXTPControlComboBoxEditCtrl* m_pEdit;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_strEditHint Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_strEditHint Data Member

Grayed-out text displayed in the edit control that displayed a helpful description

CString m_strEditHint;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_strEditText Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_strEditText Data Member

Edit text.

mutable CString m_strEditText;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox::m_strLastText Data Member

CXTPControlComboBox Data Members, CXTPControlComboBox Class
CXTPControlComboBox::m_strLastText Data Member

Last Text before user select focus and change it.

CString m_strLastText;
Group

CXTPControlComboBox Data Members


CXTPControlComboBox Methods

CXTPControlComboBox Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox Methods
Class

CXTPControlComboBox Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
CreateEditControl | This method create edit control. Override it to use inherited edit control.
DeflateEditRect | This method is called to get real rect of edit control of Combo Box
GetCustomizeMinWidth | This member returns the minimum width that the combo box can be sized by the user while in customization mode.
IsCustomizeResizeAllow | This member checks if the user can resize control.
IsFocusable | This method is called to check if control accept focus
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnHookKeyDown | This method is called when a non-system key is pressed.
OnKillFocus | This method is called, then the edit control loses the focus.
OnMouseHover | Called after the mouse hovers over the control.
OnMouseMove | This member is called when the mouse cursor moves.
OnRemoved | This method is called when control was removed from parent controls collection
OnSetFocus | This method is called, then edit control gets the focus.
OnSetPopup | This method is called to popup the control.
OnSetSelected | This method is called when the control becomes selected.
OnUnderlineActivate | This method is called when the user activate control using its underline.
SetParent | This method is called to assign a parent command bar object.
SetRect | Call this member to set the bounding rectangle of the control.
Public Methods
Public Methods
Public Method | Description
AddString | Call this member function to add a string to a list box.
Compare | Call this member to compare controls.
DeleteItem | Call this member function to delete a string.
DoPropExchange | Reads or writes this object from or to an archive.
DrawEditText | This method draw text of control if style is CBS_DROPDOWNLIST
EnableAutoComplete | This member function enables or disables auto completion.
EnableShellAutoComplete | This member function enables or disables shell auto completion.
FindString | This method finds the first string in a list box that contains the specified prefix, without changing the list-box selection
FindStringExact | Call the FindStringExact member function to find the first list-box string (in a combo box) that matches the string specified in str.
GetComboBoxPopupBar | Returns child popup bar
GetCount | Call this member to retrieve the number of items in a list box.
GetCurSel | Call this member function to determine which item in the combo box is selected.
GetDefaultCharFormat | This method is called to get default char format of rich edit text
GetDropDownListStyle | Call this member to determine if the combo box has an edit control.
GetDropDownWidth | Call this member to retrieve the dropdown list width.
GetDroppedState | Call the GetDroppedState member function to determine whether the list box of a drop-down combo box is visible (dropped down).
GetEditCtrl | Call this member to get the edit control of the combo box control.
GetEditHint | Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
GetEditIconId | Call this member to get the edit icon's identifier.
GetEditStyle | Call this member to get the style of edit control.
GetEditText | Call this member to get the edit text.
GetItemData | This method retrieves the application-supplied 32-bit value associated with the specified combo box item.
GetLabelWidth | Call this method to get with of label.
GetLBText | Call this member to retrieve a string from the list box of a combo box control.
GetListBoxCtrl | Retrieves list box window.
GetListBoxText | Call this member to get the currently selected item's text
GetListIconId | Call this member to get the combo list icon's identifier.
GetThumbWidth | Call this method to get with of thumb button.
HasFocus | Call this method to determine if control has focus
InsertString | Call this member function to insert a string into the list box of a combo box control
IsCaptionVisible | Call this member to determine if the caption of the control is visible
IsFocused | Call this member to get the focused state of the control.
IsImageVisible | Determines if icon is visible for combo box control
ModifyListBoxStyle | Call this member to modify style of list box
OnActionChanged | This method is called when action property was changed
OnActionChanging | This method is called when action property is about to be changed
OnEditChanged | This method is called then edit control text was changed
OnExecute | This method is called when the control is executed.
OnSelChanged | This method is called, then the selected string is changed.
ResetContent | Call this member to removes all items from the list box of a combo box control.
SetCurSel | Call this member to select a string in the list box of a combo box.
SetDropDownItemCount | Call this member to set the count of items in the dropdown list.
SetDropDownListStyle | Call this member to insertdelete an edit box in the combo box when the control has focus.
SetDropDownWidth | Call this member to set the width of the dropdown list.
SetEditHint | Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
SetEditIconId | Call this member to set the edit icon's identifier.
SetEditStyle | Call this member to set the style of edit control
SetEditText | Call this member to set the edit control text.
SetEnabled | Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetFocused | Call this member to set focus to the control.
SetHideFlags | This method is called to hide the control.
SetItemData | This method sets the 32-bit value associated with the specified item in a combo box.
SetLabelWidth | This method is called to set width of the label.
SetListIconId |
SetThumbWidth | This method is called to set width of thumb button.


CXTPControlComboBox::AddString Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::AddString Method

Call this member function to add a string to a list box.

int AddString(
    LPCTSTR lpsz
);
Parameters

lpsz
The string that is to be added.

Returns

The zero-based index of the string in the list box. The return value is LB_ERR if an error occurs.

Body Source
int CXTPControlComboBox::AddString(LPCTSTR lpsz) {
    return GetListBoxCtrl()->AddString(lpsz);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::Compare Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::Compare Method

Call this member to compare controls.

virtual BOOL Compare(
    CXTPControl* pOther
);
Parameters

pOther
The control need compare with.

Returns

TRUE if the controls are identical.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::Copy Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::Copy Method

This method is called to copy the control.

void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::CreateEditControl Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::CreateEditControl Method

This method create edit control. Override it to use inherited edit control.

virtual CXTPControlComboBoxEditCtrl* CreateEditControl();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::DeflateEditRect Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::DeflateEditRect Method

This method is called to get real rect of edit control of Combo Box

virtual void DeflateEditRect(
    CRect& rcControl
);
Parameters

rcControl
Rectangle of Combo Box area.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::DeleteItem Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::DeleteItem Method

Call this member function to delete a string.

void DeleteItem(
    long nIndex
);
Parameters

nIndex
Contains a zero-based index of the item to delete.

Body Source
void CXTPControlComboBox::DeleteItem(long nIndex) {
    if (nIndex < GetCount()) GetListBoxCtrl()->DeleteString(nIndex);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::DoPropExchange Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::DrawEditText Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::DrawEditText Method

This method draw text of control if style is CBS_DROPDOWNLIST

virtual void DrawEditText(
    CDC* pDC,
    CRect rcText
);
Parameters

pDC
Pointer to a valid device context
rcText
Rectangle to draw.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::EnableAutoComplete Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::EnableAutoComplete Method

This member function enables or disables auto completion.

void EnableAutoComplete(
    BOOL bAutoComplete = TRUE
);
Parameters

bAutoComplete
TRUE to enable auto completion, otherwise FALSE.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::EnableShellAutoComplete Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::EnableShellAutoComplete Method

This member function enables or disables shell auto completion.

void EnableShellAutoComplete(
    DWORD dwFlags = SHACF_FILESYSTEM | SHACF_URLALL
);
Parameters

dwFlags
Flags that will be passed to SHAutoComplete function.

Remarks

Flags can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • SHACF_FILESYSTEM This includes the File System as well as the rest of the shell (DesktopMy ComputerControl Panel)
  • SHACF_URLALL Include the URL's in the users History and Recently Used lists. Equivalent to SHACF_URLHISTORY | SHACF_URLMRU.
  • HACF_URLHISTORY URLs in the User's History
  • SHACF_URLMRU URLs in the User's Recently Used list.
  • SHACF_FILESYS_ONLY Include only the file system. Do not include virtual folders such as Desktop or Control Panel.
Group

CXTPControlComboBox Methods


CXTPControlComboBox::FindString Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::FindString Method

This method finds the first string in a list box that contains the specified prefix, without changing the list-box selection

int FindString(
    int nStartAfter,
    LPCTSTR lpszItem
) const;
Parameters

nStartAfter
Contains the zero-based index of the item before the first item to be searched. When the search reaches the bottom of the list box, it continues from the top of the list box back to the item specified by nStartAfter. If nStartAfter is -1, the entire list box is searched from the beginning.
lpszItem
Points to the null-terminated string that contains the prefix to search for. The search is case independent, so this string may contain any combination of uppercase and lowercase letters.

Returns

The zero-based index of the matching item, or LB_ERR if the search was unsuccessful.

See Also

FindStringExact

Body Source
int CXTPControlComboBox::FindString(int nStartAfter, LPCTSTR lpszItem) const {
    return GetComboBoxPopupBar()->FindString(nStartAfter, lpszItem);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::FindStringExact Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::FindStringExact Method

Call the FindStringExact member function to find the first list-box string (in a combo box) that matches the string specified in str.

int FindStringExact(
    int nIndexStart,
    LPCTSTR lpsz
) const;
Parameters

nIndexStart
Specifies the zero-based index of the item before the first item to be searched.
lpsz
The string to search for.

Returns

The zero-based index of the matching item, or CB_ERR if the search was unsuccessful.

See Also

FindString

Body Source
int CXTPControlComboBox::FindStringExact(int nIndexStart, LPCTSTR lpsz) const {
    return GetComboBoxPopupBar()->FindStringExact(nIndexStart, lpsz);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetComboBoxPopupBar Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetComboBoxPopupBar Method

Returns child popup bar

CXTPControlComboBoxPopupBar* GetComboBoxPopupBar() const;
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetCount Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetCount Method

Call this member to retrieve the number of items in a list box.

int GetCount() const;
Returns

The number of items in the list box, or LB_ERR if an error occurs.

Body Source
int CXTPControlComboBox::GetCount() const{
    return GetListBoxCtrl()->GetCount();
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetCurSel Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetCurSel Method

Call this member function to determine which item in the combo box is selected.

int GetCurSel() const;
Returns

The zero-based index of the currently selected item in the list box of a combo box, or CB_ERR if no item is selected.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetCustomizeMinWidth Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetCustomizeMinWidth Method

This member returns the minimum width that the combo box can be sized by the user while in customization mode.

virtual int GetCustomizeMinWidth() const;
Returns

Width of label + Width of Dropdown button + 5

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetDefaultCharFormat Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetDefaultCharFormat Method

This method is called to get default char format of rich edit text

virtual CHARFORMAT2 GetDefaultCharFormat();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetDropDownListStyle Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetDropDownListStyle Method

Call this member to determine if the combo box has an edit control.

BOOL GetDropDownListStyle() const;
Returns

TRUE is the combo box has an edit control, FALSE otherwise.

See Also

SetDropDownListStyle

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetDropDownWidth Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetDropDownWidth Method

Call this member to retrieve the dropdown list width.

int GetDropDownWidth() const;
Returns

Width of the dropdown list.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetDroppedState Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetDroppedState Method

Call the GetDroppedState member function to determine whether the list box of a drop-down combo box is visible (dropped down).

BOOL GetDroppedState() const;
Returns

Nonzero if the list box is visible; otherwise 0.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetEditCtrl Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetEditCtrl Method

Call this member to get the edit control of the combo box control.

CXTPControlComboBoxEditCtrl* GetEditCtrl() const;
Returns

A pointer to the CEdit control.

Body Source
CXTPControlComboBoxEditCtrl* CXTPControlComboBox::GetEditCtrl() const {
    return m_pEdit;
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetEditHint Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetEditHint Method

Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.

CString GetEditHint() const;
Returns

Edit hint of the control

See Also

SetEditHint

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetEditIconId Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetEditIconId Method

Call this member to get the edit icon's identifier.

int GetEditIconId() const;
Body Source
int CXTPControlComboBox::GetEditIconId() const{
    return m_nEditIconId;
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetEditStyle Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetEditStyle Method

Call this member to get the style of edit control.

DWORD GetEditStyle() const;
Returns

The style of the edit control.

See Also

SetEditStyle

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetEditText Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetEditText Method

Call this member to get the edit text.

CString GetEditText() const;
Returns

The Edit control text.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetItemData Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetItemData Method

This method retrieves the application-supplied 32-bit value associated with the specified combo box item.

DWORD_PTR GetItemData(
    int nIndex
) const;
Parameters

nIndex
Contains the zero-based index of an item in the combo box's list box.

Returns

The 32-bit value associated with the item, or CB_ERR if an error occurs.

Body Source
DWORD_PTR CXTPControlComboBox::GetItemData(int nIndex) const {
    return (DWORD_PTR)GetListBoxCtrl()->GetItemData(nIndex);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetLabelWidth Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetLabelWidth Method

Call this method to get with of label.

int GetLabelWidth() const;
Returns

Width of label of edit control.

See Also

SetLabelWidth, SetStyle, GetStyle

Body Source
int CXTPControlComboBox::GetLabelWidth() const {
    return m_nLabelWidth;
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetLBText Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetLBText Method

Call this member to retrieve a string from the list box of a combo box control.

void GetLBText(
    int nIndex,
    CString& str
) const;
Parameters

nIndex
Contains the zero-based index of the list-box string to be copied.
str
A reference to a CString.

Body Source
void CXTPControlComboBox::GetLBText(int nIndex, CString& str) const{
    GetComboBoxPopupBar()->GetText(nIndex, str);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetListBoxCtrl Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetListBoxCtrl Method

Retrieves list box window.

CListBox* GetListBoxCtrl() const;
Body Source
CListBox* CXTPControlComboBox::GetListBoxCtrl() const {
    return ((CListBox*)m_pCommandBar);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetListBoxText Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetListBoxText Method

Call this member to get the currently selected item's text

virtual CString GetListBoxText() const;
Returns

The text that is currently selected.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetListIconId Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::GetListIconId Method

Call this member to get the combo list icon's identifier.

int GetListIconId() const;
Group

CXTPControlComboBox Methods


CXTPControlComboBox::GetThumbWidth Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::GetThumbWidth Method

Call this method to get with of thumb button.

int GetThumbWidth() const;
Returns

Width of thumb button of combo box.

See Also

SetThumbWidth

Body Source
int CXTPControlComboBox::GetThumbWidth() const {
    return m_nThumbWidth;
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::HasFocus Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::HasFocus Method

Call this method to determine if control has focus

BOOL HasFocus() const;
Group

CXTPControlComboBox Methods


CXTPControlComboBox::InsertString Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::InsertString Method

Call this member function to insert a string into the list box of a combo box control

int InsertString(
    int nIndex,
    LPCTSTR lpsz
);
Parameters

nIndex
Contains the zero-based index to the position in the list box that will receive the string.
lpsz
The string that is to be inserted.

Body Source
int CXTPControlComboBox::InsertString(int nIndex, LPCTSTR lpsz) {
    return GetListBoxCtrl()->InsertString(nIndex, lpsz);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::IsCaptionVisible Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::IsCaptionVisible Method

Call this member to determine if the caption of the control is visible

virtual BOOL IsCaptionVisible() const;
Returns

TRUE if the caption is visible.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::IsCustomizeResizeAllow Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::IsCustomizeResizeAllow Method

This member checks if the user can resize control.

virtual BOOL IsCustomizeResizeAllow() const;
Returns

TRUE if resize available.

Body Source
BOOL CXTPControlComboBox::IsCustomizeResizeAllow() const {
    return TRUE;
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::IsFocusable Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::IsFocusable Method

This method is called to check if control accept focus

virtual BOOL IsFocusable() const;
See Also

SetFocused

Group

CXTPControlComboBox Methods


CXTPControlComboBox::IsFocused Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::IsFocused Method

Call this member to get the focused state of the control.

virtual BOOL IsFocused() const;
Returns

TRUE if the control has focus; otherwise FALSE.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::IsImageVisible Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::IsImageVisible Method

Determines if icon is visible for combo box control

BOOL IsImageVisible() const;
Returns

TRUE if control has icon

Group

CXTPControlComboBox Methods


CXTPControlComboBox::ModifyListBoxStyle Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::ModifyListBoxStyle Method

Call this member to modify style of list box

void ModifyListBoxStyle(
    DWORD dwRemove,
    DWORD dwAdd
);
Parameters

dwRemove
Styles to remove.
dwAdd
Styles to add.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnActionChanged Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::OnActionChanged Method

This method is called when action property was changed

virtual void OnActionChanged(
    int nProperty
);
Parameters

nProperty
Property of the action

See Also

OnActionChanging

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnActionChanging Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::OnActionChanging Method

This method is called when action property is about to be changed

virtual void OnActionChanging(
    int nProperty
);
Parameters

nProperty
Property of the action

See Also

OnActionChanged

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnCalcDynamicSize Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControl, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnClick Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnClick Method

This method is called when the user clicks the control.

void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnEditChanged Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnEditChanged Method

This method is called then edit control text was changed

virtual void OnEditChanged();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnExecute Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnExecute Method

This method is called when the control is executed.

virtual void OnExecute();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnHookKeyDown Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnHookKeyDown Method

This method is called when a non-system key is pressed.

BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnKillFocus Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnKillFocus Method

This method is called, then the edit control loses the focus.

virtual void OnKillFocus();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnMouseHover Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnMouseHover Method

Called after the mouse hovers over the control.

void OnMouseHover();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnMouseMove Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnMouseMove Method

This member is called when the mouse cursor moves.

virtual void OnMouseMove(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnRemoved Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnRemoved Method

This method is called when control was removed from parent controls collection

virtual void OnRemoved();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnSelChanged Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnSelChanged Method

This method is called, then the selected string is changed.

virtual void OnSelChanged();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnSetFocus Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnSetFocus Method

This method is called, then edit control gets the focus.

virtual void OnSetFocus(
    CWnd* pOldWnd
);
Parameters

pOldWnd
Points to a CWnd object

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnSetPopup Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnSetPopup Method

This method is called to popup the control.

virtual BOOL OnSetPopup(
    BOOL bPopup
);
Parameters

bPopup
TRUE to set popup.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnSetSelected Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnSetSelected Method

This method is called when the control becomes selected.

BOOL OnSetSelected(
    int bSelected
);
Parameters

bSelected
TRUE if the control becomes selected.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlComboBox Methods


CXTPControlComboBox::OnUnderlineActivate Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::OnUnderlineActivate Method

This method is called when the user activate control using its underline.

virtual void OnUnderlineActivate();
Group

CXTPControlComboBox Methods


CXTPControlComboBox::ResetContent Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::ResetContent Method

Call this member to removes all items from the list box of a combo box control.

void ResetContent();
Body Source
void CXTPControlComboBox::ResetContent() {
    GetListBoxCtrl()->ResetContent();
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetCurSel Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::SetCurSel Method

Call this member to select a string in the list box of a combo box.

void SetCurSel(
    int nIndex
);
Parameters

nIndex
Specifies the zero-based index of the string to select.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetDropDownItemCount Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetDropDownItemCount Method

Call this member to set the count of items in the dropdown list.

void SetDropDownItemCount(
    int nDropDownItemCount
);
Parameters

nDropDownItemCount
The count of items in the dropdown list.

Body Source
void CXTPControlComboBox::SetDropDownItemCount(int nDropDownItemCount) {
    m_nDropDownItemCount = nDropDownItemCount;
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetDropDownListStyle Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetDropDownListStyle Method

Call this member to insertdelete an edit box in the combo box when the control has focus.

void SetDropDownListStyle(
    BOOL bSet = TRUE
);
Parameters

bSet
TRUE if the combo box has an edit control.

Remarks

If bSet is TRUE, when the combo box control is click an edit control is used to display the text and the user can edit or copy the text.

See Also

GetDropDownListStyle

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetDropDownWidth Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetDropDownWidth Method

Call this member to set the width of the dropdown list.

void SetDropDownWidth(
    int nWidth
);
Parameters

nWidth
The width of the dropdown list.

Body Source
void CXTPControlComboBox::SetDropDownWidth(int nWidth) {
    m_pCommandBar->SetWidth(nWidth);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetEditHint Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetEditHint Method

Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.

void SetEditHint(
    LPCTSTR lpszEditHint
);
Parameters

lpszEditHint
Edit hint to be set

See Also

GetEditHint

Example
pCombo->SetEditHint(_T("Click to find a contact");
Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetEditIconId Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetEditIconId Method

Call this member to set the edit icon's identifier.

void SetEditIconId(
    int nId
);
Parameters

nId
Icon's identifier to be set.

Body Source
void CXTPControlComboBox::SetEditIconId(int nId) {
    if (m_nEditIconId != nId) {m_nEditIconId = nId; RedrawParent();m_bDelayReposition = TRUE;}
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetEditStyle Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetEditStyle Method

Call this member to set the style of edit control

void SetEditStyle(
    DWORD dwStyle
);
Parameters

dwStyle
The style to be set

See Also

GetEditStyle

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetEditText Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetEditText Method

Call this member to set the edit control text.

void SetEditText(
    const CString& lpszText
);
Parameters

lpszText
New text of the edit control.

See Also

FindStringExact, FindString

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetEnabled Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetEnabled Method

Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.

void SetEnabled(
    BOOL bEnabled
);
Parameters

bEnabled
TRUE if the control is enabled.

See Also

GetEnabled, SetChecked

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetFocused Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::SetFocused Method

Call this member to set focus to the control.

virtual void SetFocused(
    BOOL bFocused
);
Parameters

bFocused
TRUE to set focus

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetHideFlags Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetHideFlags Method

This method is called to hide the control.

virtual void SetHideFlags(
    DWORD dwFlags
);
Parameters

dwFlags
Reasons to hide.

See Also

XTPControlHideFlags

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetItemData Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetItemData Method

This method sets the 32-bit value associated with the specified item in a combo box.

int SetItemData(
    int nIndex,
    DWORD_PTR dwItemData
);
Parameters

nIndex
Contains a zero-based index of the item to set.
dwItemData
Contains the new value to associate with the item.

Returns

CB_ERR if an error occurs.

Body Source
int CXTPControlComboBox::SetItemData(int nIndex, DWORD_PTR dwItemData) {
    return GetListBoxCtrl()->SetItemData(nIndex, dwItemData);
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetLabelWidth Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetLabelWidth Method

This method is called to set width of the label.

void SetLabelWidth(
    int nLabelWidth
);
Parameters

nLabelWidth
Width of label to be set

See Also

GetLabelWidth, SetStyle, GetStyle

Body Source
void CXTPControlComboBox::SetLabelWidth(int nLabelWidth) {
    if (m_nLabelWidth != nLabelWidth)
    {
        m_nLabelWidth = nLabelWidth;
        m_bDelayReposition = TRUE;
    }
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetListIconId Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::SetListIconId Method
void SetListIconId(
    int nId
);
Parameters

nId
Icon's identifier to be set.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetParent Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::SetParent Method

This method is called to assign a parent command bar object.

void SetParent(
    CXTPCommandBar* pParent
);
Parameters

pParent
Points to a CXTPCommandBar object

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetRect Method

CXTPControlComboBox Methods, CXTPControlComboBox Class
CXTPControlComboBox::SetRect Method

Call this member to set the bounding rectangle of the control.

void SetRect(
    CRect rcControl
);
Parameters

rcControl
Bounding rectangle of the control.

Group

CXTPControlComboBox Methods


CXTPControlComboBox::SetThumbWidth Method

CXTPControlComboBox Methods, CXTPControlComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBox::SetThumbWidth Method

This method is called to set width of thumb button.

void SetThumbWidth(
    int nThumbWidth
);
Parameters

nThumbWidth
Width of the thumb button to be set.

See Also

GetThumbWidth

Body Source
void CXTPControlComboBox::SetThumbWidth(int nThumbWidth) {
    if (m_nThumbWidth != nThumbWidth)
    {
        m_nThumbWidth = nThumbWidth;
        m_bDelayReposition = TRUE;
    }
}
Group

CXTPControlComboBox Methods


CXTPControlComboBox Constructors

CXTPControlComboBox Class, Legend, Public Methods
CXTPControlComboBox Constructors
Class

CXTPControlComboBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlComboBox | Constructs a CXTPControlComboBox object


CXTPControlComboBox::CXTPControlComboBox Constructor

CXTPControlComboBox Constructors, CXTPControlComboBox Class
CXTPControlComboBox::CXTPControlComboBox Constructor

Constructs a CXTPControlComboBox object

CXTPControlComboBox(
    CXTPCommandBars* pCommandBars = NULL
);
Parameters

pCommandBars
Pointer to parent CommandBars class.

Group

CXTPControlComboBox Constructors


CXTPControlComboBox Destructors

CXTPControlComboBox Class, Legend, Public Methods
CXTPControlComboBox Destructors
Class

CXTPControlComboBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlComboBox | Destroys a CXTPControlComboBox object, handles cleanup and deallocation


CXTPControlComboBox::~CXTPControlComboBox Destructor

CXTPControlComboBox Destructors, CXTPControlComboBox Class
CXTPControlComboBox::~CXTPControlComboBox Destructor

Destroys a CXTPControlComboBox object, handles cleanup and deallocation

virtual ~CXTPControlComboBox();
Group

CXTPControlComboBox Destructors


CXTPControlComboBoxEditCtrl Class

XTPControlComboBox.h, Classes, Legend, Members, Topics, CXTPControlComboBoxEditCtrl Data Members, CXTPControlComboBoxEditCtrl Methods, CXTPControlComboBoxEditCtrl Data Members, CXTPControlComboBoxEditCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxEditCtrl Class

Inplace Edit control of the combo.

Class Hierarchy

class CXTPControlComboBoxEditCtrl : public CXTPEdit;
File

XTPControlComboBox.h

Group

Classes

Legend
Data Member
protected
Method
CXTPControlComboBoxEditCtrl Data Members
CXTPControlComboBoxEditCtrl Data Members | Description
m_pControl | Parent Combo Box.
CXTPControlComboBoxEditCtrl Methods
CXTPControlComboBoxEditCtrl Methods | Description
GetControlComboBox | Retrieves parent CXTPControlComboBox object.
UpdateCharFormat | This method is called to refresh char format of edit control


CXTPControlComboBoxEditCtrl Data Members

CXTPControlComboBoxEditCtrl Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxEditCtrl Data Members
Class

CXTPControlComboBoxEditCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pControl | Parent Combo Box.


CXTPControlComboBoxEditCtrl::m_pControl Data Member

CXTPControlComboBoxEditCtrl Data Members, CXTPControlComboBoxEditCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxEditCtrl::m_pControl Data Member

Parent Combo Box.

CXTPControlComboBox* m_pControl;
Group

CXTPControlComboBoxEditCtrl Data Members


CXTPControlComboBoxEditCtrl Methods

CXTPControlComboBoxEditCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxEditCtrl Methods
Class

CXTPControlComboBoxEditCtrl Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
UpdateCharFormat | This method is called to refresh char format of edit control
Public Methods
Public Methods
Public Method | Description
GetControlComboBox | Retrieves parent CXTPControlComboBox object.


CXTPControlComboBoxEditCtrl::GetControlComboBox Method

CXTPControlComboBoxEditCtrl Methods, CXTPControlComboBoxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxEditCtrl::GetControlComboBox Method

Retrieves parent CXTPControlComboBox object.

CXTPControlComboBox* GetControlComboBox() const;
Returns

Pointer to parent CXTPControlComboBox.

Body Source
CXTPControlComboBox* CXTPControlComboBoxEditCtrl::GetControlComboBox() const {
    return m_pControl;
}
Group

CXTPControlComboBoxEditCtrl Methods


CXTPControlComboBoxEditCtrl::UpdateCharFormat Method

CXTPControlComboBoxEditCtrl Methods, CXTPControlComboBoxEditCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxEditCtrl::UpdateCharFormat Method

This method is called to refresh char format of edit control

void UpdateCharFormat();
Group

CXTPControlComboBoxEditCtrl Methods


CXTPControlComboBoxList Class

XTPControlComboBox.h, Classes, Legend, Members, Topics, CXTPControlComboBoxList Methods, CXTPControlComboBoxList Constructors, CXTPControlComboBoxList Constructors, CXTPControlComboBoxList Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList Class

CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class. It represents a list box of CXTPControlComboBox control.

Class Hierarchy

class CXTPControlComboBoxList : public CXTPControlComboBoxPopupBar;
File

XTPControlComboBox.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlComboBoxList Constructors
CXTPControlComboBoxList Constructors | Description
CXTPControlComboBoxList | Constructs a CXTPControlButton object
CXTPControlComboBoxList Methods
CXTPControlComboBoxList Methods | Description
Copy | This method makes a copy of the command bar.
CreateListBox | Creates list box.
DoPropExchange | Reads or writes this object from or to an archive.
DrawCommandBar | This method is called to draw the command bar in the given context.
GetListBoxCtrl | Retrieves list box window.
IsCustomizable | Call this member to retrieve the customize mode of the command bars.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnHookMessage | This member function is called by WindowProc, or is called during message reflection.
Popup | This method is called, then PopupBar becomes visible.
ProcessHookKeyDown | This method is called to process key down event
SetTrackingMode | Call this member to change the tracking state.


CXTPControlComboBoxList Methods

CXTPControlComboBoxList Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList Methods
Class

CXTPControlComboBoxList Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method makes a copy of the command bar.
DoPropExchange | Reads or writes this object from or to an archive.
DrawCommandBar | This method is called to draw the command bar in the given context.
IsCustomizable | Call this member to retrieve the customize mode of the command bars.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnHookMessage | This member function is called by WindowProc, or is called during message reflection.
Popup | This method is called, then PopupBar becomes visible.
ProcessHookKeyDown | This method is called to process key down event
SetTrackingMode | Call this member to change the tracking state.
Public Methods
Public Methods
Public Method | Description
CreateListBox | Creates list box.
GetListBoxCtrl | Retrieves list box window.


CXTPControlComboBoxList::Copy Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::Copy Method

This method makes a copy of the command bar.

virtual void Copy(
    CXTPCommandBar* pCommandBar,
    BOOL bRecursive = FALSE
);
Parameters

pCommandBar
Command bar needed to be copied.
bRecursive
TRUE to copy recursively.

Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::CreateListBox Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::CreateListBox Method

Creates list box.

virtual void CreateListBox();
Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::DoPropExchange Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::DrawCommandBar Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::DrawCommandBar Method

This method is called to draw the command bar in the given context.

virtual void DrawCommandBar(
    CDC* pDC,
    CRect rcClipBox
);
Parameters

pDC
Pointer to a valid device context.
rcClipBox
The rectangular area of the control that is invalid

Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::GetListBoxCtrl Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::GetListBoxCtrl Method

Retrieves list box window.

CListBox* GetListBoxCtrl() const;
Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::IsCustomizable Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::IsCustomizable Method

Call this member to retrieve the customize mode of the command bars.

virtual BOOL IsCustomizable() const;
Returns

TRUE if command bars are in customized mode; otherwise returns FALSE.

Body Source
virtual BOOL IsCustomizable() const { return FALSE; }
Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::OnHookKeyDown Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::OnHookKeyDown Method

The framework calls this member function when a non-system key is pressed.

virtual BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE

Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::OnHookMessage Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::OnHookMessage Method

This member function is called by WindowProc, or is called during message reflection.

int OnHookMessage(
    HWND hWnd,
    UINT nMessage,
    WPARAM& wParam,
    LPARAM& lParam,
    LRESULT& lResult
);
Parameters

hWnd
Window handle that the message belongs to.
nMessage
Specifies the message to be sent.
wParam
Specifies additional message-dependent information.
lParam
Specifies additional message-dependent information.
lResult
The return value of WindowProc. Depends on the message; may be NULL.

Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::Popup Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::Popup Method

This method is called, then PopupBar becomes visible.

virtual BOOL Popup(
    CXTPControlPopup* pControlPopup,
    BOOL bSelectFirst = FALSE
);
Parameters

pControlPopup
Points to a CXTPControlPopup object
bSelectFirst
TRUE to select the first item.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::ProcessHookKeyDown Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::ProcessHookKeyDown Method

This method is called to process key down event

BOOL ProcessHookKeyDown(
    CXTPControlComboBox* pComboBox,
    UINT nChar,
    LPARAM lParam
);
Parameters

pComboBox
Owner combo box pointer
nChar
Specifies the virtual key code of the given key.
lParam
keystroke-message information

Returns

TRUE if message was processed.

Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList::SetTrackingMode Method

CXTPControlComboBoxList Methods, CXTPControlComboBoxList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::SetTrackingMode Method

Call this member to change the tracking state.

virtual BOOL SetTrackingMode(
    int bMode,
    BOOL bSelectFirst,
    BOOL bKeyboard = FALSE
);
Parameters

bMode
TRUE to set the tracking mode; otherwise FALSE.
bSelectFirst
TRUE to select the first item.
bKeyboard
TRUE if the item is popuped by the keyboard.

Returns

TRUE if the method was successful.

See Also

IsTrackingMode.

Group

CXTPControlComboBoxList Methods


CXTPControlComboBoxList Constructors

CXTPControlComboBoxList Class, Legend, Public Methods
CXTPControlComboBoxList Constructors
Class

CXTPControlComboBoxList Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlComboBoxList | Constructs a CXTPControlButton object


CXTPControlComboBoxList::CXTPControlComboBoxList Constructor

CXTPControlComboBoxList Constructors, CXTPControlComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxList::CXTPControlComboBoxList Constructor

Constructs a CXTPControlButton object

CXTPControlComboBoxList();
Group

CXTPControlComboBoxList Constructors


CXTPControlComboBoxPopupBar Class

XTPControlComboBox.h, Classes, Legend, Members, Topics, CXTPControlComboBoxPopupBar Constructors, CXTPControlComboBoxPopupBar Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxPopupBar Class

CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class. It represents base class for combo popups.

Class Hierarchy

class CXTPControlComboBoxPopupBar : public CXTPPopupBar;
File

XTPControlComboBox.h

Group

Classes

Legend
Constructor
CXTPControlComboBoxPopupBar Constructors
CXTPControlComboBoxPopupBar Constructors | Description
CXTPControlComboBoxPopupBar | Constructs a CXTPControlComboBoxPopupBar object


CXTPControlComboBoxPopupBar Constructors

CXTPControlComboBoxPopupBar Class, Legend, Public Methods
CXTPControlComboBoxPopupBar Constructors
Class

CXTPControlComboBoxPopupBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlComboBoxPopupBar | Constructs a CXTPControlComboBoxPopupBar object


CXTPControlComboBoxPopupBar::CXTPControlComboBoxPopupBar Constructor

CXTPControlComboBoxPopupBar Constructors, CXTPControlComboBoxPopupBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlComboBoxPopupBar::CXTPControlComboBoxPopupBar Constructor

Constructs a CXTPControlComboBoxPopupBar object

CXTPControlComboBoxPopupBar();
Group

CXTPControlComboBoxPopupBar Constructors


CXTPControlCustom Class

XTPControlCustom.h, Classes, Legend, Members, Topics, CXTPControlCustom Data Members, CXTPControlCustom Methods, CXTPControlCustom Constructors, CXTPControlCustom Destructors, CXTPControlCustom Constructors, CXTPControlCustom Data Members, CXTPControlCustom Destructors, CXTPControlCustom Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlCustom Class

CXTPControlCustom is a CXTPControlButton derived class. It represents the control with some child window.

Class Hierarchy

class CXTPControlCustom : public CXTPControlButton, public CXTPHookManagerHookAble;
File

XTPControlCustom.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControlCustom Constructors
CXTPControlCustom Constructors | Description
CXTPControlCustom | Constructs a CXTPControlCustom object
CXTPControlCustom Data Members
CXTPControlCustom Data Members | Description
m_bControlVisible | TRUE if child window is visible.
m_hwndControl | The child window.
m_nControlID | Id of the custom control
m_rcBorders | Borders.
m_szControl | Size of the control.
m_verticalOptions | Vertical options.
CXTPControlCustom Destructors
CXTPControlCustom Destructors | Description
~CXTPControlCustom | Destroys a CXTPControlCustom object, handles cleanup and deallocation
CXTPControlCustom Methods
CXTPControlCustom Methods | Description
Copy | This method is called to copy the control.
CreateControlCustom | Call this method to create new CXTPControlCustom object with pWndChild as child window,
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetControl | Call this method to retrieve the child window of the control.
GetSize | This method is called to determine the size of the control.
IsCustomizeDragOverAvail | Call this method to check if the user can drop the control.
OnActionChanged | This method is called when action property was changed
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnHookMessage | This member function is called by WindowProc, or is called during message reflection.
OnRemoved | This method is called when control was removed from parent controls collection
SetBorders | This method sets the margins of the child window.
SetControl | Call this method to attach the window to the control.
SetEnabled | Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetHideFlags | This method is called to hide the control.
SetRect | Call this member to set the bounding rectangle of the control.
SetSize | This method sets the child window size.
SetVerticalPositionOption | Call this method to set vertical options to the control.


CXTPControlCustom Data Members

CXTPControlCustom Class, Legend, Protected Data Members
CXTPControlCustom Data Members
Class

CXTPControlCustom Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bControlVisible | TRUE if child window is visible.
m_hwndControl | The child window.
m_nControlID | Id of the custom control
m_rcBorders | Borders.
m_szControl | Size of the control.
m_verticalOptions | Vertical options.


CXTPControlCustom::m_bControlVisible Data Member

CXTPControlCustom Data Members, CXTPControlCustom Class
CXTPControlCustom::m_bControlVisible Data Member

TRUE if child window is visible.

BOOL m_bControlVisible;
Group

CXTPControlCustom Data Members


CXTPControlCustom::m_hwndControl Data Member

CXTPControlCustom Data Members, CXTPControlCustom Class
CXTPControlCustom::m_hwndControl Data Member

The child window.

HWND m_hwndControl;
Group

CXTPControlCustom Data Members


CXTPControlCustom::m_nControlID Data Member

CXTPControlCustom Data Members, CXTPControlCustom Class
CXTPControlCustom::m_nControlID Data Member

Id of the custom control

int m_nControlID;
Group

CXTPControlCustom Data Members


CXTPControlCustom::m_rcBorders Data Member

CXTPControlCustom Data Members, CXTPControlCustom Class
CXTPControlCustom::m_rcBorders Data Member

Borders.

CRect m_rcBorders;
Group

CXTPControlCustom Data Members


CXTPControlCustom::m_szControl Data Member

CXTPControlCustom Data Members, CXTPControlCustom Class
CXTPControlCustom::m_szControl Data Member

Size of the control.

CSize m_szControl;
Group

CXTPControlCustom Data Members


CXTPControlCustom::m_verticalOptions Data Member

CXTPControlCustom Data Members, CXTPControlCustom Class
CXTPControlCustom::m_verticalOptions Data Member

Vertical options.

XTPControlCustomVerticalOptions m_verticalOptions;
Group

CXTPControlCustom Data Members


CXTPControlCustom Methods

CXTPControlCustom Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlCustom Methods
Class

CXTPControlCustom Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
IsCustomizeDragOverAvail | Call this method to check if the user can drop the control.
OnActionChanged | This method is called when action property was changed
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnHookMessage | This member function is called by WindowProc, or is called during message reflection.
OnRemoved | This method is called when control was removed from parent controls collection
SetHideFlags | This method is called to hide the control.
SetRect | Call this member to set the bounding rectangle of the control.
Public Methods
Public Methods
Public Method | Description
CreateControlCustom | Call this method to create new CXTPControlCustom object with pWndChild as child window,
GetControl | Call this method to retrieve the child window of the control.
SetBorders | This method sets the margins of the child window.
SetControl | Call this method to attach the window to the control.
SetEnabled | Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetSize | This method sets the child window size.
SetVerticalPositionOption | Call this method to set vertical options to the control.


CXTPControlCustom::Copy Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::Copy Method

This method is called to copy the control.

virtual void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlCustom Methods


CXTPControlCustom::CreateControlCustom Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::CreateControlCustom Method

Call this method to create new CXTPControlCustom object with pWndChild as child window,

static CXTPControlCustom* CreateControlCustom(
    CWnd* pWndChild
);
Parameters

pWndChild
Pointer to the child window.

Returns

Pointer to new CXTPControlCustom object.

Group

CXTPControlCustom Methods


CXTPControlCustom::DoPropExchange Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlCustom Methods


CXTPControlCustom::Draw Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::Draw Method

This method is called to draw the control.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlCustom Methods


CXTPControlCustom::GetControl Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::GetControl Method

Call this method to retrieve the child window of the control.

CWnd* GetControl();
Returns

A pointer to a CWnd object.

Group

CXTPControlCustom Methods


CXTPControlCustom::GetSize Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::GetSize Method

This method is called to determine the size of the control.

virtual CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlCustom Methods


CXTPControlCustom::IsCustomizeDragOverAvail Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::IsCustomizeDragOverAvail Method

Call this method to check if the user can drop the control.

virtual BOOL IsCustomizeDragOverAvail(
    CXTPCommandBar* pCommandBar,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pCommandBar
Points to a CXTPCommandBar object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Returns

TRUE if successful, otherwise returns FALSE

Group

CXTPControlCustom Methods


CXTPControlCustom::OnActionChanged Method

CXTPControlCustom Methods, CXTPControlCustom Class, See Also
CXTPControlCustom::OnActionChanged Method

This method is called when action property was changed

virtual void OnActionChanged(
    int nProperty
);
Parameters

nProperty
Property of the action

See Also

OnActionChanging

Group

CXTPControlCustom Methods


CXTPControlCustom::OnCalcDynamicSize Method

CXTPControlCustom Methods, CXTPControlCustom Class, See Also
CXTPControlCustom::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControl, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Group

CXTPControlCustom Methods


CXTPControlCustom::OnClick Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::OnClick Method

This method is called when the user clicks the control.

virtual void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlCustom Methods


CXTPControlCustom::OnHookMessage Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::OnHookMessage Method

This member function is called by WindowProc, or is called during message reflection.

int OnHookMessage(
    HWND hWnd,
    UINT nMessage,
    WPARAM& wParam,
    LPARAM& lParam,
    LRESULT& lResult
);
Parameters

hWnd
Window handle that the message belongs to.
nMessage
Specifies the message to be sent.
wParam
Specifies additional message-dependent information.
lParam
Specifies additional message-dependent information.
lResult
The return value of WindowProc. Depends on the message; may be NULL.

Group

CXTPControlCustom Methods


CXTPControlCustom::OnRemoved Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::OnRemoved Method

This method is called when control was removed from parent controls collection

virtual void OnRemoved();
Group

CXTPControlCustom Methods


CXTPControlCustom::SetBorders Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::SetBorders Method

This method sets the margins of the child window.

void SetBorders(
    int cxRight,
    int cxTop,
    int cxLeft,
    int cxBottom
);
Parameters

cxRight
Right border gap.
cxTop
Top border gap.
cxLeft
Left border gap.
cxBottom
Bottom border gap.

Group

CXTPControlCustom Methods


CXTPControlCustom::SetControl Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::SetControl Method

Call this method to attach the window to the control.

void SetControl(
    CWnd* pWnd
);
Parameters

pWnd
Points to a child CWnd object.

Group

CXTPControlCustom Methods


CXTPControlCustom::SetEnabled Method

CXTPControlCustom Methods, CXTPControlCustom Class, See Also
CXTPControlCustom::SetEnabled Method

Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.

virtual void SetEnabled(
    BOOL bEnabled
);
Parameters

bEnabled
TRUE if the control is enabled.

See Also

GetEnabled, SetChecked

Group

CXTPControlCustom Methods


CXTPControlCustom::SetHideFlags Method

CXTPControlCustom Methods, CXTPControlCustom Class, See Also
CXTPControlCustom::SetHideFlags Method

This method is called to hide the control.

virtual void SetHideFlags(
    DWORD dwFlags
);
Parameters

dwFlags
Reasons to hide.

See Also

XTPControlHideFlags

Group

CXTPControlCustom Methods


CXTPControlCustom::SetRect Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::SetRect Method

Call this member to set the bounding rectangle of the control.

virtual void SetRect(
    CRect rcControl
);
Parameters

rcControl
Bounding rectangle of the control.

Group

CXTPControlCustom Methods


CXTPControlCustom::SetSize Method

CXTPControlCustom Methods, CXTPControlCustom Class
CXTPControlCustom::SetSize Method

This method sets the child window size.

void SetSize(
    CSize szControl
);
Parameters

szControl
Size of the child window.

Group

CXTPControlCustom Methods


CXTPControlCustom::SetVerticalPositionOption Method

CXTPControlCustom Methods, CXTPControlCustom Class, See Also
CXTPControlCustom::SetVerticalPositionOption Method

Call this method to set vertical options to the control.

void SetVerticalPositionOption(
    XTPControlCustomVerticalOptions options
);
Parameters

options
XTPControlCustomVerticalOptions type to be set Can be any of the values listed in the Remarks section.

Remarks

Vertical options refer to how the control will be displayed when the toolbar it docked vertically. It can be one of the following:

  • xtpVerticalHide To hide control
  • xtpVerticalShow To show control
  • xtpVerticalButton To show control as button.
See Also

XTPControlCustomVerticalOptions

Group

CXTPControlCustom Methods


CXTPControlCustom Constructors

CXTPControlCustom Class, Legend, Public Methods
CXTPControlCustom Constructors
Class

CXTPControlCustom Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlCustom | Constructs a CXTPControlCustom object


CXTPControlCustom::CXTPControlCustom Constructor

CXTPControlCustom Constructors, CXTPControlCustom Class
CXTPControlCustom::CXTPControlCustom Constructor

Constructs a CXTPControlCustom object

CXTPControlCustom();
Group

CXTPControlCustom Constructors


CXTPControlCustom Destructors

CXTPControlCustom Class, Legend, Public Methods
CXTPControlCustom Destructors
Class

CXTPControlCustom Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlCustom | Destroys a CXTPControlCustom object, handles cleanup and deallocation


CXTPControlCustom::~CXTPControlCustom Destructor

CXTPControlCustom Destructors, CXTPControlCustom Class
CXTPControlCustom::~CXTPControlCustom Destructor

Destroys a CXTPControlCustom object, handles cleanup and deallocation

~CXTPControlCustom();
Group

CXTPControlCustom Destructors


CXTPControlEdit Class

XTPControlEdit.h, Classes, Legend, Members, Topics, CXTPControlEdit Data Members, CXTPControlEdit Methods, CXTPControlEdit Constructors, CXTPControlEdit Destructors, CXTPControlEdit Constructors, CXTPControlEdit Data Members, CXTPControlEdit Destructors, CXTPControlEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEdit Class

CXTPControlEdit is a CXTPControl derived class. It represents an edit control.

Class Hierarchy

class CXTPControlEdit : public CXTPControl;
File

XTPControlEdit.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControlEdit Constructors
CXTPControlEdit Constructors | Description
CXTPControlEdit | Constructs a CXTPControlEdit object
CXTPControlEdit Data Members
CXTPControlEdit Data Members | Description
m_bDelayDestroy | Need to reposition control.
m_bDelayReposition | Need to reposition control.
m_bEditChanged | TRUE if Edit Text was changed.
m_bFocused | TRUE if edit has focus
m_bLabel | TRUE if label is visible.
m_bReadOnly | TRUE if edit is readonly
m_bShowSpinButtons | TRUE to show spsin buttons
m_dwEditStyle | Edit style
m_dwShellAutoCompleteFlags | Shell auto complete flags.
m_nEditIconId | Edit Icon identifier
m_nLabelWidth | Width of the label.
m_pAutoCompleteWnd | Auto complete window hook.
m_pEdit | Inplace edit control.
m_strEditHint | Edit hint of the controls
m_strEditText | Edit text.
m_strLastText | Last entered text
CXTPControlEdit Destructors
CXTPControlEdit Destructors | Description
~CXTPControlEdit | Destroys a CXTPControlEdit object, handles cleanup and deallocation
CXTPControlEdit Methods
CXTPControlEdit Methods | Description
Compare | Call this member to compare controls.
Copy | This method is called to copy the control.
CreateEditControl | This method creates an edit control. Override it to use inherited edit control.
DeflateEditRect | This method is called to get real rect of edit control of CEdit
DoPropExchange | Reads or writes this object from or to an archive.
DrawEditText | This method draw text of control
EnableShellAutoComplete | This member function enables or disables shell auto completion.
GetCustomizeMinWidth | This member returns the minimum width that the edit control can be sized by the user while in customization mode.
GetDefaultCharFormat | This method is called to get default char format of rich edit text
GetEditCtrl | Call this member to get the edit control.
GetEditHint | Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
GetEditStyle | Call this member to get the style of edit control.
GetEditText | Call this member to get the edit control text.
GetLabelWidth | Call this method to get with of label.
GetReadOnly | Retrieves a boolean value indicating whether the edit control is read-only.
GetSpinButtonsRect | Returns spin buttons bounding rectangle.
HasFocus | Call this method to determine if edit control has focus
IsCaptionVisible | Call this member to determine if the caption of the control is visible
IsCustomizeResizeAllow | This member checks if the user can resize control.
IsFocusable | This method is called to check if control accept focus
IsFocused | Call this member to get the focused state of the control.
IsImageVisible | Determines if icon is visible for edit control
IsLabeled | Call this member to determine if the control has a visible label.
IsSpinButtonsVisible | Determines if edit control has spin buttons
OnActionChanged | This method is called when action property was changed
OnActionChanging | This method is called when action property is about to be changed
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnEditChanged | This method is called then edit control text was changed
OnHookKeyDown | This method is called when a non-system key is pressed.
OnKillFocus | This method is called, then the edit control loses the focus.
OnMouseHover | Called after the mouse hovers over the control.
OnMouseMove | This member is called when the mouse cursor moves.
OnRemoved | This method is called when control was removed from parent controls collection
OnSetFocus | This method is called, then the edit control gets the focus.
OnSetSelected | This method is called when the control becomes selected.
OnUnderlineActivate | This method is called when the user activate control using its underline.
SetEditHint | Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
SetEditStyle | Call this member to set the style of edit control
SetEditText | Call this member to set the edit control text.
SetEnabled | Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetFocused | Call this member to set focus to the control.
SetHideFlags | This method is called to hide the control.
SetLabelWidth | This method is called to set width of the label.
SetParent | This method is called to assign a parent command bar object.
SetReadOnly | Calls this function to set the read-only state of an edit control.
SetRect | Call this member to set the bounding rectangle of the control.
ShowLabel | Call this member to show the label of the control.
ShowSpinButtons | Call this method to show spin buttons for edit control


CXTPControlEdit Data Members

CXTPControlEdit Class, Legend, Protected Data Members
CXTPControlEdit Data Members
Class

CXTPControlEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bDelayDestroy | Need to reposition control.
m_bDelayReposition | Need to reposition control.
m_bEditChanged | TRUE if Edit Text was changed.
m_bFocused | TRUE if edit has focus
m_bLabel | TRUE if label is visible.
m_bReadOnly | TRUE if edit is readonly
m_bShowSpinButtons | TRUE to show spsin buttons
m_dwEditStyle | Edit style
m_dwShellAutoCompleteFlags | Shell auto complete flags.
m_nEditIconId | Edit Icon identifier
m_nLabelWidth | Width of the label.
m_pAutoCompleteWnd | Auto complete window hook.
m_pEdit | Inplace edit control.
m_strEditHint | Edit hint of the controls
m_strEditText | Edit text.
m_strLastText | Last entered text


CXTPControlEdit::m_bDelayDestroy Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_bDelayDestroy Data Member

Need to reposition control.

BOOL m_bDelayDestroy;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_bDelayReposition Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_bDelayReposition Data Member

Need to reposition control.

BOOL m_bDelayReposition;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_bEditChanged Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_bEditChanged Data Member

TRUE if Edit Text was changed.

mutable BOOL m_bEditChanged;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_bFocused Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_bFocused Data Member

TRUE if edit has focus

BOOL m_bFocused;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_bLabel Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_bLabel Data Member

TRUE if label is visible.

BOOL m_bLabel;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_bReadOnly Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_bReadOnly Data Member

TRUE if edit is readonly

BOOL m_bReadOnly;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_bShowSpinButtons Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_bShowSpinButtons Data Member

TRUE to show spsin buttons

BOOL m_bShowSpinButtons;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_dwEditStyle Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_dwEditStyle Data Member

Edit style

DWORD m_dwEditStyle;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_dwShellAutoCompleteFlags Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_dwShellAutoCompleteFlags Data Member

Shell auto complete flags.

DWORD m_dwShellAutoCompleteFlags;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_nEditIconId Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_nEditIconId Data Member

Edit Icon identifier

int m_nEditIconId;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_nLabelWidth Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_nLabelWidth Data Member

Width of the label.

int m_nLabelWidth;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_pAutoCompleteWnd Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_pAutoCompleteWnd Data Member

Auto complete window hook.

CXTPControlComboBoxAutoCompleteWnd* m_pAutoCompleteWnd;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_pEdit Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_pEdit Data Member

Inplace edit control.

CXTPControlEditCtrl* m_pEdit;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_strEditHint Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_strEditHint Data Member

Edit hint of the controls

CString m_strEditHint;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_strEditText Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_strEditText Data Member

Edit text.

mutable CString m_strEditText;
Group

CXTPControlEdit Data Members


CXTPControlEdit::m_strLastText Data Member

CXTPControlEdit Data Members, CXTPControlEdit Class
CXTPControlEdit::m_strLastText Data Member

Last entered text

CString m_strLastText;
Group

CXTPControlEdit Data Members


CXTPControlEdit Methods

CXTPControlEdit Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEdit Methods
Class

CXTPControlEdit Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
DeflateEditRect | This method is called to get real rect of edit control of CEdit
GetCustomizeMinWidth | This member returns the minimum width that the edit control can be sized by the user while in customization mode.
GetDefaultCharFormat | This method is called to get default char format of rich edit text
IsCustomizeResizeAllow | This member checks if the user can resize control.
IsFocusable | This method is called to check if control accept focus
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnEditChanged | This method is called then edit control text was changed
OnHookKeyDown | This method is called when a non-system key is pressed.
OnKillFocus | This method is called, then the edit control loses the focus.
OnMouseHover | Called after the mouse hovers over the control.
OnMouseMove | This member is called when the mouse cursor moves.
OnRemoved | This method is called when control was removed from parent controls collection
OnSetFocus | This method is called, then the edit control gets the focus.
OnSetSelected | This method is called when the control becomes selected.
OnUnderlineActivate | This method is called when the user activate control using its underline.
SetParent | This method is called to assign a parent command bar object.
SetRect | Call this member to set the bounding rectangle of the control.
Public Methods
Public Methods
Public Method | Description
Compare | Call this member to compare controls.
CreateEditControl | This method creates an edit control. Override it to use inherited edit control.
DoPropExchange | Reads or writes this object from or to an archive.
DrawEditText | This method draw text of control
EnableShellAutoComplete | This member function enables or disables shell auto completion.
GetEditCtrl | Call this member to get the edit control.
GetEditHint | Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
GetEditStyle | Call this member to get the style of edit control.
GetEditText | Call this member to get the edit control text.
GetLabelWidth | Call this method to get with of label.
GetReadOnly | Retrieves a boolean value indicating whether the edit control is read-only.
GetSpinButtonsRect | Returns spin buttons bounding rectangle.
HasFocus | Call this method to determine if edit control has focus
IsCaptionVisible | Call this member to determine if the caption of the control is visible
IsFocused | Call this member to get the focused state of the control.
IsImageVisible | Determines if icon is visible for edit control
IsLabeled | Call this member to determine if the control has a visible label.
IsSpinButtonsVisible | Determines if edit control has spin buttons
OnActionChanged | This method is called when action property was changed
OnActionChanging | This method is called when action property is about to be changed
SetEditHint | Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
SetEditStyle | Call this member to set the style of edit control
SetEditText | Call this member to set the edit control text.
SetEnabled | Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetFocused | Call this member to set focus to the control.
SetHideFlags | This method is called to hide the control.
SetLabelWidth | This method is called to set width of the label.
SetReadOnly | Calls this function to set the read-only state of an edit control.
ShowLabel | Call this member to show the label of the control.
ShowSpinButtons | Call this method to show spin buttons for edit control


CXTPControlEdit::Compare Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::Compare Method

Call this member to compare controls.

virtual BOOL Compare(
    CXTPControl* pOther
);
Parameters

pOther
The control need compare with.

Returns

TRUE if the controls are identical.

Group

CXTPControlEdit Methods


CXTPControlEdit::Copy Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::Copy Method

This method is called to copy the control.

void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlEdit Methods


CXTPControlEdit::CreateEditControl Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::CreateEditControl Method

This method creates an edit control. Override it to use inherited edit control.

virtual CXTPControlEditCtrl* CreateEditControl();
Returns

A pointer to the newly created CXTPControlEditCtrl.

Group

CXTPControlEdit Methods


CXTPControlEdit::DeflateEditRect Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::DeflateEditRect Method

This method is called to get real rect of edit control of CEdit

virtual void DeflateEditRect(
    CRect& rcControl
);
Parameters

rcControl
Rectangle of Edit area.

Group

CXTPControlEdit Methods


CXTPControlEdit::DoPropExchange Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlEdit Methods


CXTPControlEdit::DrawEditText Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::DrawEditText Method

This method draw text of control

virtual void DrawEditText(
    CDC* pDC,
    CRect rcText
);
Parameters

pDC
Pointer to a valid device context
rcText
Rectangle to draw.

Group

CXTPControlEdit Methods


CXTPControlEdit::EnableShellAutoComplete Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::EnableShellAutoComplete Method

This member function enables or disables shell auto completion.

void EnableShellAutoComplete(
    DWORD dwFlags = SHACF_FILESYSTEM | SHACF_URLALL
);
Parameters

dwFlags
Flags that will be passed to SHAutoComplete function.

Remarks

Flags can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • SHACF_FILESYSTEM This includes the File System as well as the rest of the shell (DesktopMy ComputerControl Panel)
  • SHACF_URLALL Include the URL's in the users History and Recently Used lists. Equivalent to SHACF_URLHISTORY | SHACF_URLMRU.
  • HACF_URLHISTORY URLs in the User's History
  • SHACF_URLMRU URLs in the User's Recently Used list.
  • SHACF_FILESYS_ONLY Include only the file system. Do not include virtual folders such as Desktop or Control Panel.
Group

CXTPControlEdit Methods


CXTPControlEdit::GetCustomizeMinWidth Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source
CXTPControlEdit::GetCustomizeMinWidth Method

This member returns the minimum width that the edit control can be sized by the user while in customization mode.

virtual int GetCustomizeMinWidth() const;
Returns

Width of label + 10 if the edit control's label is visible, if label is hidden, then it returns 10.

Body Source
int CXTPControlEdit::GetCustomizeMinWidth() const {
    return m_nLabelWidth + 10;
}
Group

CXTPControlEdit Methods


CXTPControlEdit::GetDefaultCharFormat Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::GetDefaultCharFormat Method

This method is called to get default char format of rich edit text

virtual CHARFORMAT2 GetDefaultCharFormat();
Group

CXTPControlEdit Methods


CXTPControlEdit::GetEditCtrl Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source
CXTPControlEdit::GetEditCtrl Method

Call this member to get the edit control.

CEdit* GetEditCtrl() const;
Returns

A pointer to the CEdit control.

Body Source
CEdit* CXTPControlEdit::GetEditCtrl() const {
    return m_pEdit;
}
Group

CXTPControlEdit Methods


CXTPControlEdit::GetEditHint Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::GetEditHint Method

Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.

CString GetEditHint() const;
Returns

Edit hint of the control

See Also

SetEditHint

Group

CXTPControlEdit Methods


CXTPControlEdit::GetEditStyle Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::GetEditStyle Method

Call this member to get the style of edit control.

DWORD GetEditStyle() const;
Returns

The style of the edit control.

See Also

SetEditStyle

Group

CXTPControlEdit Methods


CXTPControlEdit::GetEditText Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::GetEditText Method

Call this member to get the edit control text.

CString GetEditText() const;
Returns

The Edit control text.

Group

CXTPControlEdit Methods


CXTPControlEdit::GetLabelWidth Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEdit::GetLabelWidth Method

Call this method to get with of label.

int GetLabelWidth() const;
Returns

Width of label of edit control.

See Also

SetLabelWidth, ShowLabel, IsLabeled

Body Source
int CXTPControlEdit::GetLabelWidth() const {
    return m_nLabelWidth;
}
Group

CXTPControlEdit Methods


CXTPControlEdit::GetReadOnly Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::GetReadOnly Method

Retrieves a boolean value indicating whether the edit control is read-only.

BOOL GetReadOnly() const;
Returns

Returns TRUE if the control is read-only; otherwise, returns FALSE.

See Also

SetReadOnly

Group

CXTPControlEdit Methods


CXTPControlEdit::GetSpinButtonsRect Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::GetSpinButtonsRect Method

Returns spin buttons bounding rectangle.

CRect GetSpinButtonsRect() const;
Group

CXTPControlEdit Methods


CXTPControlEdit::HasFocus Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::HasFocus Method

Call this method to determine if edit control has focus

BOOL HasFocus() const;
Group

CXTPControlEdit Methods


CXTPControlEdit::IsCaptionVisible Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::IsCaptionVisible Method

Call this member to determine if the caption of the control is visible

virtual BOOL IsCaptionVisible() const;
Returns

TRUE if the caption is visible.

Group

CXTPControlEdit Methods


CXTPControlEdit::IsCustomizeResizeAllow Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source
CXTPControlEdit::IsCustomizeResizeAllow Method

This member checks if the user can resize control.

virtual BOOL IsCustomizeResizeAllow() const;
Returns

TRUE if resize available.

Body Source
BOOL CXTPControlEdit::IsCustomizeResizeAllow() const {
    return TRUE;
}
Group

CXTPControlEdit Methods


CXTPControlEdit::IsFocusable Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::IsFocusable Method

This method is called to check if control accept focus

virtual BOOL IsFocusable() const;
See Also

SetFocused

Group

CXTPControlEdit Methods


CXTPControlEdit::IsFocused Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::IsFocused Method

Call this member to get the focused state of the control.

virtual BOOL IsFocused() const;
Returns

TRUE if the control has focus; otherwise FALSE.

Group

CXTPControlEdit Methods


CXTPControlEdit::IsImageVisible Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::IsImageVisible Method

Determines if icon is visible for edit control

BOOL IsImageVisible() const;
Returns

TRUE if control has icon

Group

CXTPControlEdit Methods


CXTPControlEdit::IsLabeled Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source
CXTPControlEdit::IsLabeled Method

Call this member to determine if the control has a visible label.

BOOL IsLabeled() const;
Returns

TRUE if the control has a visible label ; otherwise returns FALSE

Body Source
BOOL CXTPControlEdit::IsLabeled() const {
    return IsCaptionVisible();
}
Group

CXTPControlEdit Methods


CXTPControlEdit::IsSpinButtonsVisible Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEdit::IsSpinButtonsVisible Method

Determines if edit control has spin buttons

BOOL IsSpinButtonsVisible() const;
Returns

TRUE if control has spin buttons

See Also

ShowSpinButtons

Body Source
BOOL CXTPControlEdit::IsSpinButtonsVisible() const {
    return m_bShowSpinButtons;
}
Group

CXTPControlEdit Methods


CXTPControlEdit::OnActionChanged Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::OnActionChanged Method

This method is called when action property was changed

virtual void OnActionChanged(
    int nProperty
);
Parameters

nProperty
Property of the action

See Also

OnActionChanging

Group

CXTPControlEdit Methods


CXTPControlEdit::OnActionChanging Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::OnActionChanging Method

This method is called when action property is about to be changed

virtual void OnActionChanging(
    int nProperty
);
Parameters

nProperty
Property of the action

See Also

OnActionChanged

Group

CXTPControlEdit Methods


CXTPControlEdit::OnCalcDynamicSize Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControl, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Group

CXTPControlEdit Methods


CXTPControlEdit::OnClick Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnClick Method

This method is called when the user clicks the control.

void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlEdit Methods


CXTPControlEdit::OnEditChanged Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnEditChanged Method

This method is called then edit control text was changed

virtual void OnEditChanged();
Group

CXTPControlEdit Methods


CXTPControlEdit::OnHookKeyDown Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnHookKeyDown Method

This method is called when a non-system key is pressed.

BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE

Group

CXTPControlEdit Methods


CXTPControlEdit::OnKillFocus Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnKillFocus Method

This method is called, then the edit control loses the focus.

virtual void OnKillFocus();
Group

CXTPControlEdit Methods


CXTPControlEdit::OnMouseHover Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnMouseHover Method

Called after the mouse hovers over the control.

virtual void OnMouseHover();
Group

CXTPControlEdit Methods


CXTPControlEdit::OnMouseMove Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnMouseMove Method

This member is called when the mouse cursor moves.

virtual void OnMouseMove(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlEdit Methods


CXTPControlEdit::OnRemoved Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnRemoved Method

This method is called when control was removed from parent controls collection

virtual void OnRemoved();
Group

CXTPControlEdit Methods


CXTPControlEdit::OnSetFocus Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnSetFocus Method

This method is called, then the edit control gets the focus.

virtual void OnSetFocus(
    CWnd* pOldWnd
);
Parameters

pOldWnd
Points to a CWnd object

Group

CXTPControlEdit Methods


CXTPControlEdit::OnSetSelected Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnSetSelected Method

This method is called when the control becomes selected.

BOOL OnSetSelected(
    int bSelected
);
Parameters

bSelected
TRUE if the control becomes selected.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlEdit Methods


CXTPControlEdit::OnUnderlineActivate Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::OnUnderlineActivate Method

This method is called when the user activate control using its underline.

virtual void OnUnderlineActivate();
Group

CXTPControlEdit Methods


CXTPControlEdit::SetEditHint Method

CXTPControlEdit Methods, CXTPControlEdit Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEdit::SetEditHint Method

Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.

void SetEditHint(
    LPCTSTR lpszEditHint
);
Parameters

lpszEditHint
Edit hint to be set

See Also

GetEditHint

Example
pEdit->SetEditHint(_T("Click to find a contact");
Group

CXTPControlEdit Methods


CXTPControlEdit::SetEditStyle Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::SetEditStyle Method

Call this member to set the style of edit control

void SetEditStyle(
    DWORD dwStyle
);
Parameters

dwStyle
The style to be set

See Also

GetEditStyle

Group

CXTPControlEdit Methods


CXTPControlEdit::SetEditText Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::SetEditText Method

Call this member to set the edit control text.

void SetEditText(
    const CString& strText
);
Parameters

strText
New text of the edit control.

Group

CXTPControlEdit Methods


CXTPControlEdit::SetEnabled Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::SetEnabled Method

Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.

void SetEnabled(
    BOOL bEnabled
);
Parameters

bEnabled
TRUE if the control is enabled.

See Also

GetEnabled, SetChecked

Group

CXTPControlEdit Methods


CXTPControlEdit::SetFocused Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::SetFocused Method

Call this member to set focus to the control.

virtual void SetFocused(
    BOOL bFocused
);
Parameters

bFocused
TRUE to set focus

Group

CXTPControlEdit Methods


CXTPControlEdit::SetHideFlags Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::SetHideFlags Method

This method is called to hide the control.

virtual void SetHideFlags(
    DWORD dwFlags
);
Parameters

dwFlags
Reasons to hide.

See Also

XTPControlHideFlags

Group

CXTPControlEdit Methods


CXTPControlEdit::SetLabelWidth Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEdit::SetLabelWidth Method

This method is called to set width of the label.

void SetLabelWidth(
    int nLabelWidth
);
Parameters

nLabelWidth
Width of label to be set

See Also

GetLabelWidth, ShowLabel, IsLabeled

Body Source
void CXTPControlEdit::SetLabelWidth(int nLabelWidth) {
    if (m_nLabelWidth != nLabelWidth)
    {
        m_nLabelWidth = nLabelWidth;
        m_bDelayReposition = TRUE;
    }
}
Group

CXTPControlEdit Methods


CXTPControlEdit::SetParent Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::SetParent Method

This method is called to assign a parent command bar object.

void SetParent(
    CXTPCommandBar* pParent
);
Parameters

pParent
Points to a CXTPCommandBar object

Group

CXTPControlEdit Methods


CXTPControlEdit::SetReadOnly Method

CXTPControlEdit Methods, CXTPControlEdit Class, See Also
CXTPControlEdit::SetReadOnly Method

Calls this function to set the read-only state of an edit control.

void SetReadOnly(
    BOOL bReadOnly = TRUE
);
Parameters

bReadOnly
Specifies whether to set or remove the read-only state of the edit control. A value of TRUE sets the state to read-only; a value of FALSE sets the state to read/write.

See Also

GetReadOnly, SetEnabled

Group

CXTPControlEdit Methods


CXTPControlEdit::SetRect Method

CXTPControlEdit Methods, CXTPControlEdit Class
CXTPControlEdit::SetRect Method

Call this member to set the bounding rectangle of the control.

void SetRect(
    CRect rcControl
);
Parameters

rcControl
Bounding rectangle of the control.

Group

CXTPControlEdit Methods


CXTPControlEdit::ShowLabel Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source
CXTPControlEdit::ShowLabel Method

Call this member to show the label of the control.

void ShowLabel(
    BOOL bShow
);
Parameters

bShow
TRUE to show the label.

Body Source
void CXTPControlEdit::ShowLabel(BOOL bShow) {
    SetStyle(bShow ? xtpButtonCaption : xtpButtonAutomatic);
}
Group

CXTPControlEdit Methods


CXTPControlEdit::ShowSpinButtons Method

CXTPControlEdit Methods, CXTPControlEdit Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEdit::ShowSpinButtons Method

Call this method to show spin buttons for edit control

void ShowSpinButtons(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE to show spin buttons

See Also

IsSpinButtonsVisible

Body Source
void CXTPControlEdit::ShowSpinButtons(BOOL bShow) {
    if (m_bShowSpinButtons != bShow) {m_bShowSpinButtons = bShow; m_bDelayReposition = TRUE; DelayLayoutParent();}
}
Group

CXTPControlEdit Methods


CXTPControlEdit Constructors

CXTPControlEdit Class, Legend, Public Methods
CXTPControlEdit Constructors
Class

CXTPControlEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlEdit | Constructs a CXTPControlEdit object


CXTPControlEdit::CXTPControlEdit Constructor

CXTPControlEdit Constructors, CXTPControlEdit Class
CXTPControlEdit::CXTPControlEdit Constructor

Constructs a CXTPControlEdit object

CXTPControlEdit();
Group

CXTPControlEdit Constructors


CXTPControlEdit Destructors

CXTPControlEdit Class, Legend, Public Methods
CXTPControlEdit Destructors
Class

CXTPControlEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlEdit | Destroys a CXTPControlEdit object, handles cleanup and deallocation


CXTPControlEdit::~CXTPControlEdit Destructor

CXTPControlEdit Destructors, CXTPControlEdit Class
CXTPControlEdit::~CXTPControlEdit Destructor

Destroys a CXTPControlEdit object, handles cleanup and deallocation

virtual ~CXTPControlEdit();
Group

CXTPControlEdit Destructors


CXTPControlEditCtrl Class

XTPControlEdit.h, Classes, Legend, Members, Topics, CXTPControlEditCtrl Data Members, CXTPControlEditCtrl Methods, CXTPControlEditCtrl Data Members, CXTPControlEditCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEditCtrl Class

Inplace Edit control of CXTPControlEdit.

Class Hierarchy

class CXTPControlEditCtrl : public CXTPEdit;
File

XTPControlEdit.h

Group

Classes

Legend
Data Member
protected
Method
CXTPControlEditCtrl Data Members
CXTPControlEditCtrl Data Members | Description
m_pControl | Parent edit control
CXTPControlEditCtrl Methods
CXTPControlEditCtrl Methods | Description
GetControlEdit | Retrieves the parent CXTPControlEdit object.
UpdateCharFormat | This method is called to refresh char format of edit control


CXTPControlEditCtrl Data Members

CXTPControlEditCtrl Class, Legend, Protected Data Members
CXTPControlEditCtrl Data Members
Class

CXTPControlEditCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pControl | Parent edit control


CXTPControlEditCtrl::m_pControl Data Member

CXTPControlEditCtrl Data Members, CXTPControlEditCtrl Class
CXTPControlEditCtrl::m_pControl Data Member

Parent edit control

CXTPControlEdit* m_pControl;
Group

CXTPControlEditCtrl Data Members


CXTPControlEditCtrl Methods

CXTPControlEditCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEditCtrl Methods
Class

CXTPControlEditCtrl Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
UpdateCharFormat | This method is called to refresh char format of edit control
Public Methods
Public Methods
Public Method | Description
GetControlEdit | Retrieves the parent CXTPControlEdit object.


CXTPControlEditCtrl::GetControlEdit Method

CXTPControlEditCtrl Methods, CXTPControlEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlEditCtrl::GetControlEdit Method

Retrieves the parent CXTPControlEdit object.

CXTPControlEdit* GetControlEdit() const;
Returns

Pointer to parent CXTPControlEdit.

Body Source
CXTPControlEdit* CXTPControlEditCtrl::GetControlEdit() const {
    return m_pControl;
}
Group

CXTPControlEditCtrl Methods


CXTPControlEditCtrl::UpdateCharFormat Method

CXTPControlEditCtrl Methods, CXTPControlEditCtrl Class
CXTPControlEditCtrl::UpdateCharFormat Method

This method is called to refresh char format of edit control

void UpdateCharFormat();
Group

CXTPControlEditCtrl Methods


CXTPControlFontComboBox Class

XTPControlComboBoxExt.h, Classes, Legend, Members, Topics, CXTPControlFontComboBox Methods, CXTPControlFontComboBox Constructors, CXTPControlFontComboBox Destructors, CXTPControlFontComboBox Constructors, CXTPControlFontComboBox Destructors, CXTPControlFontComboBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBox Class

CXTPControlFontComboBox is a CXTPControlComboBox derived class. It represents the font picker control.

Class Hierarchy

class CXTPControlFontComboBox : public CXTPControlComboBox;
File

XTPControlComboBoxExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlFontComboBox Constructors
CXTPControlFontComboBox Constructors | Description
CXTPControlFontComboBox | Constructs a CXTPControlFontComboBox object
CXTPControlFontComboBox Destructors
CXTPControlFontComboBox Destructors | Description
~CXTPControlFontComboBox | Destroys a CXTPControl object, handles cleanup and deallocation
CXTPControlFontComboBox Methods
CXTPControlFontComboBox Methods | Description
OnExecute | This method is called when the control is executed.
SetCharFormat | Call this method to set current font of the picker.


CXTPControlFontComboBox Methods

CXTPControlFontComboBox Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBox Methods
Class

CXTPControlFontComboBox Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnExecute | This method is called when the control is executed.
Public Methods
Public Methods
Public Method | Description
SetCharFormat | Call this method to set current font of the picker.


CXTPControlFontComboBox::OnExecute Method

CXTPControlFontComboBox Methods, CXTPControlFontComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBox::OnExecute Method

This method is called when the control is executed.

virtual void OnExecute();
Group

CXTPControlFontComboBox Methods


CXTPControlFontComboBox::SetCharFormat Method

CXTPControlFontComboBox Methods, CXTPControlFontComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBox::SetCharFormat Method

Call this method to set current font of the picker.

void SetCharFormat(
    CHARFORMAT& cf
);
Parameters

cf
CHARFORMAT structure contains information about character formatting in a rich edit control.

Group

CXTPControlFontComboBox Methods


CXTPControlFontComboBox Constructors

CXTPControlFontComboBox Class, Legend, Public Methods
CXTPControlFontComboBox Constructors
Class

CXTPControlFontComboBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlFontComboBox | Constructs a CXTPControlFontComboBox object


CXTPControlFontComboBox::CXTPControlFontComboBox Constructor

CXTPControlFontComboBox Constructors, CXTPControlFontComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBox::CXTPControlFontComboBox Constructor

Constructs a CXTPControlFontComboBox object

CXTPControlFontComboBox(
    DWORD dwStyleListBox = 1
);
Parameters

dwStyleListBox
Flags to be used in list box. Currently not supported, must be default.

Group

CXTPControlFontComboBox Constructors


CXTPControlFontComboBox Destructors

CXTPControlFontComboBox Class, Legend, Public Methods
CXTPControlFontComboBox Destructors
Class

CXTPControlFontComboBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlFontComboBox | Destroys a CXTPControl object, handles cleanup and deallocation


CXTPControlFontComboBox::~CXTPControlFontComboBox Destructor

CXTPControlFontComboBox Destructors, CXTPControlFontComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBox::~CXTPControlFontComboBox Destructor

Destroys a CXTPControl object, handles cleanup and deallocation

virtual ~CXTPControlFontComboBox();
Group

CXTPControlFontComboBox Destructors


CXTPControlFontComboBoxList Class

XTPControlComboBoxExt.h, Classes, Legend, Members, Topics, CXTPControlFontComboBoxList Data Members, CXTPControlFontComboBoxList Methods, CXTPControlFontComboBoxList Data Members, CXTPControlFontComboBoxList Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBoxList Class

CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class. It represents the font picker popup.

Class Hierarchy

class CXTPControlFontComboBoxList : public CXTPControlComboBoxList;
File

XTPControlComboBoxExt.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControlFontComboBoxList Data Members
CXTPControlFontComboBoxList Data Members | Description
m_dwStyleListBox | Style of the control.
CXTPControlFontComboBoxList Methods
CXTPControlFontComboBoxList Methods | Description
Copy | Call this method to make a copy of the command bar.
CreateListBox | Creates a list box.
DoPropExchange | Reads or writes this object from or to an archive.
EnumFontFamiliesEx | This method is called to add all fonts to list.


CXTPControlFontComboBoxList Data Members

CXTPControlFontComboBoxList Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBoxList Data Members
Class

CXTPControlFontComboBoxList Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dwStyleListBox | Style of the control.


CXTPControlFontComboBoxList::m_dwStyleListBox Data Member

CXTPControlFontComboBoxList Data Members, CXTPControlFontComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBoxList::m_dwStyleListBox Data Member

Style of the control.

DWORD m_dwStyleListBox;
Group

CXTPControlFontComboBoxList Data Members


CXTPControlFontComboBoxList Methods

CXTPControlFontComboBoxList Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBoxList Methods
Class

CXTPControlFontComboBoxList Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | Call this method to make a copy of the command bar.
CreateListBox | Creates a list box.
DoPropExchange | Reads or writes this object from or to an archive.
Public Methods
Public Methods
Public Method | Description
EnumFontFamiliesEx | This method is called to add all fonts to list.


CXTPControlFontComboBoxList::Copy Method

CXTPControlFontComboBoxList Methods, CXTPControlFontComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBoxList::Copy Method

Call this method to make a copy of the command bar.

void Copy(
    CXTPCommandBar* pCommandBar,
    BOOL bRecursive = FALSE
);
Parameters

pCommandBar
Command bar needed to be copied.
bRecursive
TRUE to copy recursively.

Group

CXTPControlFontComboBoxList Methods


CXTPControlFontComboBoxList::CreateListBox Method

CXTPControlFontComboBoxList Methods, CXTPControlFontComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBoxList::CreateListBox Method

Creates a list box.

void CreateListBox();
Group

CXTPControlFontComboBoxList Methods


CXTPControlFontComboBoxList::DoPropExchange Method

CXTPControlFontComboBoxList Methods, CXTPControlFontComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBoxList::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlFontComboBoxList Methods


CXTPControlFontComboBoxList::EnumFontFamiliesEx Method

CXTPControlFontComboBoxList Methods, CXTPControlFontComboBoxList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlFontComboBoxList::EnumFontFamiliesEx Method

This method is called to add all fonts to list.

void EnumFontFamiliesEx(
    BOOL dwStyleListBox = 1
);
Parameters

dwStyleListBox
Flags to be used in EnumFontFamiliesEx. Currently not supported.

Group

CXTPControlFontComboBoxList Methods


CXTPControlGallery Class

XTPControlGallery.h, Classes, Legend, Members, Topics, CXTPControlGallery Structures, CXTPControlGallery Data Members, CXTPControlGallery Methods, CXTPControlGallery Constructors, CXTPControlGallery Destructors, CXTPControlGallery Constructors, CXTPControlGallery Data Members, CXTPControlGallery Destructors, CXTPControlGallery Methods, CXTPControlGallery Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery Class

CXTPControlGallery is a CXTPControlPopup derived class. It represents gallery control of toolbar.

Class Hierarchy

class CXTPControlGallery : public CXTPControlPopup, public CXTPScrollBase;
File

XTPControlGallery.h

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTPControlGallery Constructors
CXTPControlGallery Constructors | Description
CXTPControlGallery | Constructs a CXTPControlGallery object
CXTPControlGallery Data Members
CXTPControlGallery Data Members | Description
m_arrRects | bounding rectangles
m_bHideSelection | TRUE to hide selection
m_bKeyboardSelected | TRUE if item was selected using keyboard
m_bPressed | TRUE if item is pressed
m_bPreview | TRUE if control in preview mode
m_bShowBorders | TRUE to show borders
m_bShowLabels | TRUE to show labels
m_bShowScrollBar | TRUE to show scrollbars
m_nChecked | Checked id
m_nScrollPos | Scroll position
m_nScrollPosTarget | Scroll position
m_nSelected | Index of Selected item
m_nTotalHeight | Total height of items
m_ptPressed | Position of pressed item
m_rcMargin | Margins of gallery items
CXTPControlGallery Destructors
CXTPControlGallery Destructors | Description
~CXTPControlGallery | Destroys a CXTPControlGallery object, handles cleanup and deallocation
CXTPControlGallery Methods
CXTPControlGallery Methods | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
DrawItems | This method is called to draw all items
EnsureVisible | Call this member to make sure that an item is visible in the gallery. This will scroll the gallery until the item is visible.
GetBorders | Determines total borders width for gallery
GetCheckedItem | Call this method to get checked item identifier
GetGalleryPaintManager | Retrieves CXTPControlGalleryPaintManager pointer to draw gallery
GetItem | Call this method to retrieve item by its index
GetItemCount | Call this method to get count of items in gallery
GetItemDrawRect | Determines bounding rectangle of the item
GetItems | Call this method to get items associated with the gallery
GetItemsRect | Determines bounding rectangle of the items
GetScrollPos | Determines position of scroll bar of gallery control
GetSelectedItem | Call this method to get selected item in the gallery
HitTestItem | This method determines where a point lies in a specified item.
InvalidateItems | Redraw items
IsItemSelected | Determines if there is selection in gallery
IsResizable | Determines if control can be resized by user
IsShowBorders | Call this method to determine if borders are visible
OnSelectedItemChanged | This method is called when selection was changed by user
Reposition | This method is called to set position of all items
SetCheckedItem | Call this method to set checked item identifier for the gallery
SetControlSize | Call this method to set size of the control
SetItems | Call this method to set items for gallery
SetItemsMargin | Call this method to set margins around items
SetResizable | Call this method to allow user resize gallery
SetScrollPos | Call this method to set scroll position of gallery
SetSelectedItem | Call this method to set selected item in the gallery
SetTopIndex | Call this method to scroll gallery for specified top item
ShowBorders | Call this method to draw borders around gallery
ShowLabels | Call this method to show/hide labels of the gallery
ShowScrollBar | Call this method to show/hide scrollbar of the gallery
CXTPControlGallery Structures
CXTPControlGallery Structures | Description
GALLERYITEM_POSITION | Structure contains item position description


CXTPControlGallery Structures

CXTPControlGallery Class, Legend, Structures
CXTPControlGallery Structures
Class

CXTPControlGallery Class

Legend
Structure
Structures
Structure | Description
GALLERYITEM_POSITION | Structure contains item position description


CXTPControlGallery::GALLERYITEM_POSITION Structure

XTPControlGallery.h, CXTPControlGallery Structures
CXTPControlGallery::GALLERYITEM_POSITION Structure

Structure contains item position description

struct GALLERYITEM_POSITION {
  RECT rcItem;
  CXTPControlGalleryItem* pItem;
  BOOL bBeginRow;
};
File

XTPControlGallery.h

Members

rcItem
Bounding rectangle of the item
pItem
Item pointer
bBeginRow
TRUE it item starts new row

Group

CXTPControlGallery Structures


CXTPControlGallery Data Members

CXTPControlGallery Class, Legend, Protected Data Members
CXTPControlGallery Data Members
Class

CXTPControlGallery Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrRects | bounding rectangles
m_bHideSelection | TRUE to hide selection
m_bKeyboardSelected | TRUE if item was selected using keyboard
m_bPressed | TRUE if item is pressed
m_bPreview | TRUE if control in preview mode
m_bShowBorders | TRUE to show borders
m_bShowLabels | TRUE to show labels
m_bShowScrollBar | TRUE to show scrollbars
m_nChecked | Checked id
m_nScrollPos | Scroll position
m_nScrollPosTarget | Scroll position
m_nSelected | Index of Selected item
m_nTotalHeight | Total height of items
m_ptPressed | Position of pressed item
m_rcMargin | Margins of gallery items


CXTPControlGallery::m_arrRects Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_arrRects Data Member

bounding rectangles

CArray<GALLERYITEM_POSITION, GALLERYITEM_POSITION&> m_arrRects;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_bHideSelection Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_bHideSelection Data Member

TRUE to hide selection

BOOL m_bHideSelection;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_bKeyboardSelected Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_bKeyboardSelected Data Member

TRUE if item was selected using keyboard

BOOL m_bKeyboardSelected;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_bPressed Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_bPressed Data Member

TRUE if item is pressed

BOOL m_bPressed;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_bPreview Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_bPreview Data Member

TRUE if control in preview mode

BOOL m_bPreview;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_bShowBorders Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_bShowBorders Data Member

TRUE to show borders

BOOL m_bShowBorders;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_bShowLabels Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_bShowLabels Data Member

TRUE to show labels

BOOL m_bShowLabels;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_bShowScrollBar Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_bShowScrollBar Data Member

TRUE to show scrollbars

BOOL m_bShowScrollBar;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_nChecked Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_nChecked Data Member

Checked id

int m_nChecked;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_nScrollPos Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_nScrollPos Data Member

Scroll position

int m_nScrollPos;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_nScrollPosTarget Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_nScrollPosTarget Data Member

Scroll position

int m_nScrollPosTarget;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_nSelected Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_nSelected Data Member

Index of Selected item

int m_nSelected;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_nTotalHeight Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_nTotalHeight Data Member

Total height of items

int m_nTotalHeight;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_ptPressed Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_ptPressed Data Member

Position of pressed item

CPoint m_ptPressed;
Group

CXTPControlGallery Data Members


CXTPControlGallery::m_rcMargin Data Member

CXTPControlGallery Data Members, CXTPControlGallery Class
CXTPControlGallery::m_rcMargin Data Member

Margins of gallery items

CRect m_rcMargin;
Group

CXTPControlGallery Data Members


CXTPControlGallery Methods

CXTPControlGallery Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery Methods
Class

CXTPControlGallery Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
DrawItems | This method is called to draw all items
Reposition | This method is called to set position of all items
Public Methods
Public Methods
Public Method | Description
EnsureVisible | Call this member to make sure that an item is visible in the gallery. This will scroll the gallery until the item is visible.
GetBorders | Determines total borders width for gallery
GetCheckedItem | Call this method to get checked item identifier
GetGalleryPaintManager | Retrieves CXTPControlGalleryPaintManager pointer to draw gallery
GetItem | Call this method to retrieve item by its index
GetItemCount | Call this method to get count of items in gallery
GetItemDrawRect | Determines bounding rectangle of the item
GetItems | Call this method to get items associated with the gallery
GetItemsRect | Determines bounding rectangle of the items
GetScrollPos | Determines position of scroll bar of gallery control
GetSelectedItem | Call this method to get selected item in the gallery
HitTestItem | This method determines where a point lies in a specified item.
InvalidateItems | Redraw items
IsItemSelected | Determines if there is selection in gallery
IsResizable | Determines if control can be resized by user
IsShowBorders | Call this method to determine if borders are visible
OnSelectedItemChanged | This method is called when selection was changed by user
SetCheckedItem | Call this method to set checked item identifier for the gallery
SetControlSize | Call this method to set size of the control
SetItems | Call this method to set items for gallery
SetItemsMargin | Call this method to set margins around items
SetResizable | Call this method to allow user resize gallery
SetScrollPos | Call this method to set scroll position of gallery
SetSelectedItem | Call this method to set selected item in the gallery
SetTopIndex | Call this method to scroll gallery for specified top item
ShowBorders | Call this method to draw borders around gallery
ShowLabels | Call this method to show/hide labels of the gallery
ShowScrollBar | Call this method to show/hide scrollbar of the gallery


CXTPControlGallery::Copy Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::Copy Method

This method is called to copy the control.

void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlGallery Methods


CXTPControlGallery::DoPropExchange Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlGallery Methods


CXTPControlGallery::DrawItems Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::DrawItems Method

This method is called to draw all items

void DrawItems(
    CDC* pDC
);
Parameters

pDC
Pointer to device context to draw

Group

CXTPControlGallery Methods


CXTPControlGallery::EnsureVisible Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::EnsureVisible Method

Call this member to make sure that an item is visible in the gallery. This will scroll the gallery until the item is visible.

void EnsureVisible(
    int nIndex
);
Parameters

nIndex
Item index that should be visible.

Group

CXTPControlGallery Methods


CXTPControlGallery::GetBorders Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::GetBorders Method

Determines total borders width for gallery

virtual CRect GetBorders() const;
Group

CXTPControlGallery Methods


CXTPControlGallery::GetCheckedItem Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::GetCheckedItem Method

Call this method to get checked item identifier

int GetCheckedItem() const;
See Also

SetCheckedItem

Group

CXTPControlGallery Methods


CXTPControlGallery::GetGalleryPaintManager Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::GetGalleryPaintManager Method

Retrieves CXTPControlGalleryPaintManager pointer to draw gallery

CXTPControlGalleryPaintManager* GetGalleryPaintManager() const;
Group

CXTPControlGallery Methods


CXTPControlGallery::GetItem Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::GetItem Method

Call this method to retrieve item by its index

CXTPControlGalleryItem* GetItem(
    int nIndex
) const;
Parameters

nIndex
Index of the item to be retrieved

Returns

Item in specified index; NULL if failed

See Also

SetItems, GetItemCount

Group

CXTPControlGallery Methods


CXTPControlGallery::GetItemCount Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::GetItemCount Method

Call this method to get count of items in gallery

int GetItemCount() const;
Returns

Count of items in the gallery

See Also

SetItems, GetItem

Group

CXTPControlGallery Methods


CXTPControlGallery::GetItemDrawRect Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::GetItemDrawRect Method

Determines bounding rectangle of the item

CRect GetItemDrawRect(
    int nIndex
);
Parameters

nIndex
Item index.

Group

CXTPControlGallery Methods


CXTPControlGallery::GetItems Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::GetItems Method

Call this method to get items associated with the gallery

CXTPControlGalleryItems* GetItems() const;
See Also

SetItems

Group

CXTPControlGallery Methods


CXTPControlGallery::GetItemsRect Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::GetItemsRect Method

Determines bounding rectangle of the items

CRect GetItemsRect() const;
Group

CXTPControlGallery Methods


CXTPControlGallery::GetScrollPos Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::GetScrollPos Method

Determines position of scroll bar of gallery control

int GetScrollPos() const;
See Also

SetScrollPos

Group

CXTPControlGallery Methods


CXTPControlGallery::GetSelectedItem Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::GetSelectedItem Method

Call this method to get selected item in the gallery

int GetSelectedItem() const;
See Also

SetSelectedItem

Group

CXTPControlGallery Methods


CXTPControlGallery::HitTestItem Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::HitTestItem Method

This method determines where a point lies in a specified item.

int HitTestItem(
    CPoint point,
    LPRECT lpRect = NULL
) const;
Parameters

point
Specifies the point to be tested.
lpRect
Retrieves rectangle where item is located. Can be NULL

Returns

An index of CXTPControlGalleryItem that occupies the specified point or NULL if no control occupies the point.

Group

CXTPControlGallery Methods


CXTPControlGallery::InvalidateItems Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::InvalidateItems Method

Redraw items

void InvalidateItems(
    LPCRECT lpRect = NULL,
    BOOL bAnimate = TRUE
);
Parameters

lpRect
Rectangle to redraw
bAnimate
TURE to animate changes

Group

CXTPControlGallery Methods


CXTPControlGallery::IsItemSelected Method

CXTPControlGallery Methods, CXTPControlGallery Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::IsItemSelected Method

Determines if there is selection in gallery

BOOL IsItemSelected() const;
See Also

GetSelectedItem

Body Source
BOOL CXTPControlGallery::IsItemSelected() const {
    return !m_bHideSelection && GetSelectedItem() != -1;
}
Group

CXTPControlGallery Methods


CXTPControlGallery::IsResizable Method

CXTPControlGallery Methods, CXTPControlGallery Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::IsResizable Method

Determines if control can be resized by user

BOOL IsResizable() const;
See Also

SetResizable

Body Source
BOOL CXTPControlGallery::IsResizable() const {
    return !IsShowAsButton() && GetItems() ? m_nResizable : FALSE;
}
Group

CXTPControlGallery Methods


CXTPControlGallery::IsShowBorders Method

CXTPControlGallery Methods, CXTPControlGallery Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::IsShowBorders Method

Call this method to determine if borders are visible

BOOL IsShowBorders() const;
See Also

ShowBorders

Body Source
BOOL CXTPControlGallery::IsShowBorders() const {
    return m_bShowBorders;
}
Group

CXTPControlGallery Methods


CXTPControlGallery::OnSelectedItemChanged Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::OnSelectedItemChanged Method

This method is called when selection was changed by user

virtual void OnSelectedItemChanged();
Group

CXTPControlGallery Methods


CXTPControlGallery::Reposition Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::Reposition Method

This method is called to set position of all items

void Reposition();
Group

CXTPControlGallery Methods


CXTPControlGallery::SetCheckedItem Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::SetCheckedItem Method

Call this method to set checked item identifier for the gallery

void SetCheckedItem(
    int nId
);
Parameters

nId
Item id

See Also

GetCheckedItem

Group

CXTPControlGallery Methods


CXTPControlGallery::SetControlSize Method

CXTPControlGallery Methods, CXTPControlGallery Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::SetControlSize Method

Call this method to set size of the control

void SetControlSize(
    CSize szControl
);
Parameters

szControl
New control size to be set

Body Source
void CXTPControlGallery::SetControlSize(CSize szControl) {
    m_nWidth = szControl.cx;
    m_nHeight = szControl.cy;
}
Group

CXTPControlGallery Methods


CXTPControlGallery::SetItems Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::SetItems Method

Call this method to set items for gallery

void SetItems(
    CXTPControlGalleryItems* pItems
);
Parameters

pItems
Pointer to items to be set

Group

CXTPControlGallery Methods


CXTPControlGallery::SetItemsMargin Method

CXTPControlGallery Methods, CXTPControlGallery Class
CXTPControlGallery::SetItemsMargin Method

Call this method to set margins around items

void SetItemsMargin(
    int nLeft,
    int nTop,
    int nRight,
    int nBottom
);
Parameters

nLeft
Left margin to be set
nTop
Top margin to be set
nRight
nRight margin to be set
nBottom
Bottom margin to be set

Group

CXTPControlGallery Methods


CXTPControlGallery::SetResizable Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::SetResizable Method

Call this method to allow user resize gallery

void SetResizable(
    BOOL bResizeWidth = TRUE,
    BOOL bResizeHeight = TRUE
);
Parameters

bResizeWidth
Allow change width
bResizeHeight
Allow change height

See Also

IsResizable

Group

CXTPControlGallery Methods


CXTPControlGallery::SetScrollPos Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::SetScrollPos Method

Call this method to set scroll position of gallery

void SetScrollPos(
    int nScrollPos
);
Parameters

nScrollPos
New scrollbar position to be set

See Also

GetScrollPos

Group

CXTPControlGallery Methods


CXTPControlGallery::SetSelectedItem Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::SetSelectedItem Method

Call this method to set selected item in the gallery

void SetSelectedItem(
    int nSelected
);
Parameters

nSelected
Item to select

See Also

GetSelectedItem

Group

CXTPControlGallery Methods


CXTPControlGallery::SetTopIndex Method

CXTPControlGallery Methods, CXTPControlGallery Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::SetTopIndex Method

Call this method to scroll gallery for specified top item

int SetTopIndex(
    int nIndex
);
Parameters

nIndex
Item to be scrolled to.

See Also

SetScrollPos

Group

CXTPControlGallery Methods


CXTPControlGallery::ShowBorders Method

CXTPControlGallery Methods, CXTPControlGallery Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::ShowBorders Method

Call this method to draw borders around gallery

void ShowBorders(
    BOOL bShowBorders
);
Parameters

bShowBorders
TRUE to show borders around gallery

See Also

IsShowBorders

Body Source
void CXTPControlGallery::ShowBorders(BOOL bShowBorders) {
    m_bShowBorders = bShowBorders;
}
Group

CXTPControlGallery Methods


CXTPControlGallery::ShowLabels Method

CXTPControlGallery Methods, CXTPControlGallery Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::ShowLabels Method

Call this method to show/hide labels of the gallery

void ShowLabels(
    BOOL bShowLabels
);
Parameters

bShowLabels
TRUE to show labels

Body Source
void CXTPControlGallery::ShowLabels(BOOL bShowLabels) {
    m_bShowLabels = bShowLabels;
}
Group

CXTPControlGallery Methods


CXTPControlGallery::ShowScrollBar Method

CXTPControlGallery Methods, CXTPControlGallery Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGallery::ShowScrollBar Method

Call this method to show/hide scrollbar of the gallery

void ShowScrollBar(
    BOOL bShowScrollBar
);
Parameters

bShowScrollBar
TRUE to show scrollbar

Body Source
void CXTPControlGallery::ShowScrollBar(BOOL bShowScrollBar) {
    m_bShowScrollBar = bShowScrollBar;
}
Group

CXTPControlGallery Methods


CXTPControlGallery Constructors

CXTPControlGallery Class, Legend, Public Methods
CXTPControlGallery Constructors
Class

CXTPControlGallery Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlGallery | Constructs a CXTPControlGallery object


CXTPControlGallery::CXTPControlGallery Constructor

CXTPControlGallery Constructors, CXTPControlGallery Class
CXTPControlGallery::CXTPControlGallery Constructor

Constructs a CXTPControlGallery object

CXTPControlGallery();
Group

CXTPControlGallery Constructors


CXTPControlGallery Destructors

CXTPControlGallery Class, Legend, Public Methods
CXTPControlGallery Destructors
Class

CXTPControlGallery Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlGallery | Destroys a CXTPControlGallery object, handles cleanup and deallocation


CXTPControlGallery::~CXTPControlGallery Destructor

CXTPControlGallery Destructors, CXTPControlGallery Class
CXTPControlGallery::~CXTPControlGallery Destructor

Destroys a CXTPControlGallery object, handles cleanup and deallocation

~CXTPControlGallery();
Group

CXTPControlGallery Destructors


CXTPControlGalleryItem Class

XTPControlGallery.h, Classes, Legend, Members, Topics, CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Methods, CXTPControlGalleryItem Constructors, CXTPControlGalleryItem Constructors, CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem Class

CXTPControlGalleryItem is a CCmdTarget derived class. It represents single item of gallery object.

Class Hierarchy

class CXTPControlGalleryItem;
File

XTPControlGallery.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControlGalleryItem Constructors
CXTPControlGalleryItem Constructors | Description
CXTPControlGalleryItem | Constructs a CXTPControlGalleryItem object
CXTPControlGalleryItem Data Members
CXTPControlGalleryItem Data Members | Description
m_bLabel | TRUE if item is label
m_dwData | 32-bit data
m_nId | Identifier
m_nImage | Image index
m_nIndex | Index of the item
m_pItems | Parent items collection
m_strCaption | Caption of the item
m_strDescriptionText | Description of the item
m_strToolTip | Tooltip of the item
m_szItem | Size of the item; CSize(0, 0) - to use default value
CXTPControlGalleryItem Methods
CXTPControlGalleryItem Methods | Description
Draw | This method is called to draw the item
GetCaption | Retrieves caption of the item
GetData | This method retrieves the application-supplied 32-bit value associated with the item.
GetDescription | Call this member to get the item's description.
GetID | Call this member to get the item's identifier.
GetImage | This method is called to get image for item
GetIndex | Retrieves index of the item
GetSize | This method is called to get size of the item.
GetToolTip | Retrieves tooltip of the item
IsLabel | Call this method to determine if the item is label
SetCaption | Call this method to set caption of the item
SetData | This method sets the 32-bit value associated with the item.
SetDescription | Call this member to set the description of the item.
SetID | Call this member to set the identifier of the item.
SetSize | Call this method to set size of the individual item. You can call CXTPControlGalleryItems::SetItemSize to set default size for items
SetToolTip | Call this method to set tooltip of the item


CXTPControlGalleryItem Data Members

CXTPControlGalleryItem Class, Legend, Protected Data Members
CXTPControlGalleryItem Data Members
Class

CXTPControlGalleryItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bLabel | TRUE if item is label
m_dwData | 32-bit data
m_nId | Identifier
m_nImage | Image index
m_nIndex | Index of the item
m_pItems | Parent items collection
m_strCaption | Caption of the item
m_strDescriptionText | Description of the item
m_strToolTip | Tooltip of the item
m_szItem | Size of the item; CSize(0, 0) - to use default value


CXTPControlGalleryItem::m_bLabel Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_bLabel Data Member

TRUE if item is label

BOOL m_bLabel;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_dwData Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_dwData Data Member

32-bit data

DWORD_PTR m_dwData;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_nId Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_nId Data Member

Identifier

int m_nId;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_nImage Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_nImage Data Member

Image index

int m_nImage;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_nIndex Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_nIndex Data Member

Index of the item

int m_nIndex;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_pItems Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_pItems Data Member

Parent items collection

CXTPControlGalleryItems* m_pItems;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_strCaption Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_strCaption Data Member

Caption of the item

CString m_strCaption;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_strDescriptionText Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_strDescriptionText Data Member

Description of the item

CString m_strDescriptionText;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_strToolTip Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_strToolTip Data Member

Tooltip of the item

CString m_strToolTip;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem::m_szItem Data Member

CXTPControlGalleryItem Data Members, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::m_szItem Data Member

Size of the item; CSize(0, 0) - to use default value

CSize m_szItem;
Group

CXTPControlGalleryItem Data Members


CXTPControlGalleryItem Methods

CXTPControlGalleryItem Class, Legend, Public Methods
CXTPControlGalleryItem Methods
Class

CXTPControlGalleryItem Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Draw | This method is called to draw the item
GetCaption | Retrieves caption of the item
GetData | This method retrieves the application-supplied 32-bit value associated with the item.
GetDescription | Call this member to get the item's description.
GetID | Call this member to get the item's identifier.
GetImage | This method is called to get image for item
GetIndex | Retrieves index of the item
GetSize | This method is called to get size of the item.
GetToolTip | Retrieves tooltip of the item
IsLabel | Call this method to determine if the item is label
SetCaption | Call this method to set caption of the item
SetData | This method sets the 32-bit value associated with the item.
SetDescription | Call this member to set the description of the item.
SetID | Call this member to set the identifier of the item.
SetSize | Call this method to set size of the individual item. You can call CXTPControlGalleryItems::SetItemSize to set default size for items
SetToolTip | Call this method to set tooltip of the item


CXTPControlGalleryItem::Draw Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class
CXTPControlGalleryItem::Draw Method

This method is called to draw the item

virtual void Draw(
    CDC* pDC,
    CXTPControlGallery* pGallery,
    CRect rcItem,
    BOOL bEnabled,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked
);
Parameters

pDC
Pointer to valid device context
pGallery
Parent gallery of the item
rcItem
Bounding rectangle of the item
bEnabled
TRUE to draw item enabled; FALSE - disabled
bSelected
TRUE to draw item selected
bPressed
TRUE to draw item pressed
bChecked
TRUE to draw item checked

Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::GetCaption Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::GetCaption Method

Retrieves caption of the item

CString GetCaption() const;
See Also

SetCaption, SetToolTip, GetToolTip

Body Source
CString CXTPControlGalleryItem::GetCaption() const {
    return m_strCaption;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::GetData Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::GetData Method

This method retrieves the application-supplied 32-bit value associated with the item.

DWORD_PTR GetData() const;
Returns

The 32-bit value associated with the item.

Body Source
DWORD_PTR CXTPControlGalleryItem::GetData() const {
    return m_dwData;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::GetDescription Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::GetDescription Method

Call this member to get the item's description.

CString GetDescription() const;
Returns

The description of the control.

Body Source
CString CXTPControlGalleryItem::GetDescription() const {
    return m_strDescriptionText;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::GetID Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::GetID Method

Call this member to get the item's identifier.

int GetID() const;
Returns

The identifier of the item.

Body Source
int CXTPControlGalleryItem::GetID() const {
    return m_nId;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::GetImage Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class
CXTPControlGalleryItem::GetImage Method

This method is called to get image for item

CXTPImageManagerIcon* GetImage();
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::GetIndex Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class
CXTPControlGalleryItem::GetIndex Method

Retrieves index of the item

int GetIndex() const;
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::GetSize Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::GetSize Method

This method is called to get size of the item.

virtual CSize GetSize();
Returns

Size of the item

See Also

SetSize, CXTPControlGalleryItems::SetItemSize

Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::GetToolTip Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::GetToolTip Method

Retrieves tooltip of the item

CString GetToolTip() const;
See Also

SetToolTip, SetCaption, GetCaption

Body Source
CString CXTPControlGalleryItem::GetToolTip() const {
    return m_strToolTip;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::IsLabel Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::IsLabel Method

Call this method to determine if the item is label

BOOL IsLabel() const;
Body Source
BOOL CXTPControlGalleryItem::IsLabel() const {
    return m_bLabel;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::SetCaption Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::SetCaption Method

Call this method to set caption of the item

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
Caption of the item to be set

See Also

GetCaption, SetToolTip, GetToolTip

Body Source
void CXTPControlGalleryItem::SetCaption(LPCTSTR lpszCaption) {
    m_strCaption = lpszCaption;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::SetData Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::SetData Method

This method sets the 32-bit value associated with the item.

void SetData(
    DWORD_PTR dwData
);
Parameters

dwData
Contains the new value to associate with the item.

Body Source
void CXTPControlGalleryItem::SetData(DWORD_PTR dwData) {
    m_dwData = dwData;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::SetDescription Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::SetDescription Method

Call this member to set the description of the item.

void SetDescription(
    LPCTSTR lpszDescription
);
Parameters

lpszDescription
Description to be set.

See Also

SetCaption, SetTooltip

Body Source
void CXTPControlGalleryItem::SetDescription(LPCTSTR lpszDescription) {
    m_strDescriptionText = lpszDescription;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::SetID Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::SetID Method

Call this member to set the identifier of the item.

void SetID(
    int nId
);
Parameters

nId
Identifier to be set.

Body Source
void CXTPControlGalleryItem::SetID(int nId) {
    m_nId = nId;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::SetSize Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class
CXTPControlGalleryItem::SetSize Method

Call this method to set size of the individual item. You can call CXTPControlGalleryItems::SetItemSize to set default size for items

void SetSize(
    CSize szItem
);
Parameters

szItem
Size of the item to be set

Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem::SetToolTip Method

CXTPControlGalleryItem Methods, CXTPControlGalleryItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::SetToolTip Method

Call this method to set tooltip of the item

void SetToolTip(
    LPCTSTR lpszToolTip
);
Parameters

lpszToolTip
Tooltip of the item to be set

See Also

GetToolTip, SetCaption, GetCaption

Body Source
void CXTPControlGalleryItem::SetToolTip(LPCTSTR lpszToolTip) {
    m_strToolTip = lpszToolTip;
}
Group

CXTPControlGalleryItem Methods


CXTPControlGalleryItem Constructors

CXTPControlGalleryItem Class, Legend, Public Methods
CXTPControlGalleryItem Constructors
Class

CXTPControlGalleryItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlGalleryItem | Constructs a CXTPControlGalleryItem object


CXTPControlGalleryItem::CXTPControlGalleryItem Constructor

CXTPControlGalleryItem Constructors, CXTPControlGalleryItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItem::CXTPControlGalleryItem Constructor

Constructs a CXTPControlGalleryItem object

CXTPControlGalleryItem();
Group

CXTPControlGalleryItem Constructors


CXTPControlGalleryItems Class

XTPControlGallery.h, Classes, Legend, Members, Topics, CXTPControlGalleryItems Data Members, CXTPControlGalleryItems Methods, CXTPControlGalleryItems Constructors, CXTPControlGalleryItems Destructors, CXTPControlGalleryItems Constructors, CXTPControlGalleryItems Data Members, CXTPControlGalleryItems Destructors, CXTPControlGalleryItems Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems Class

CXTPControlGalleryItems is a CCmdTarget derived class. It represents a collection of the items for gallery control.

Class Hierarchy

class CXTPControlGalleryItems;
File

XTPControlGallery.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControlGalleryItems Constructors
CXTPControlGalleryItems Constructors | Description
CXTPControlGalleryItems | Constructs a CXTPControlGalleryItems object.
CXTPControlGalleryItems Data Members
CXTPControlGalleryItems Data Members | Description
m_arrItems | Array of items
m_bClipItems | TRUE to clip items
m_pAction | Action of the items
m_pImageManager | Image manager of items
m_szItem | Size of the items
CXTPControlGalleryItems Destructors
CXTPControlGalleryItems Destructors | Description
~CXTPControlGalleryItems | Destroys a CXTPControlGalleryItems object, handles cleanup and deallocation
CXTPControlGalleryItems Methods
CXTPControlGalleryItems Methods | Description
AddItem |
AddLabel |
ClipItems | Call this member to enable/disable clipping items if selection was changed
CreateItems | Creates new items collection for gallery control
GetImageManager | Retrieves image manager of the items
GetItem | Call this member to return the item at the specified index.
GetItemCount | Call this member to get the count of the items
GetItemSize | Determines default size of the items
InsertItem | Call this member to insert a new item.
OnItemsChanged | This method is called if items was added or removed in collection
PreDrawItem | This method is called to draw the item
Remove | Call this member to remove item.
RemoveAll | Call this method to remove all items in collection
SetImageManager | Call this method to set image manager for items
SetItemSize | Call this method to set size of the item


CXTPControlGalleryItems Data Members

CXTPControlGalleryItems Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems Data Members
Class

CXTPControlGalleryItems Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrItems | Array of items
m_bClipItems | TRUE to clip items
m_pAction | Action of the items
m_pImageManager | Image manager of items
m_szItem | Size of the items


CXTPControlGalleryItems::m_arrItems Data Member

CXTPControlGalleryItems Data Members, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::m_arrItems Data Member

Array of items

CArray<CXTPControlGalleryItem*, CXTPControlGalleryItem*> m_arrItems;
Group

CXTPControlGalleryItems Data Members


CXTPControlGalleryItems::m_bClipItems Data Member

CXTPControlGalleryItems Data Members, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::m_bClipItems Data Member

TRUE to clip items

BOOL m_bClipItems;
Group

CXTPControlGalleryItems Data Members


CXTPControlGalleryItems::m_pAction Data Member

CXTPControlGalleryItems Data Members, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::m_pAction Data Member

Action of the items

CXTPControlAction* m_pAction;
Group

CXTPControlGalleryItems Data Members


CXTPControlGalleryItems::m_pImageManager Data Member

CXTPControlGalleryItems Data Members, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::m_pImageManager Data Member

Image manager of items

CXTPImageManager* m_pImageManager;
Group

CXTPControlGalleryItems Data Members


CXTPControlGalleryItems::m_szItem Data Member

CXTPControlGalleryItems Data Members, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::m_szItem Data Member

Size of the items

CSize m_szItem;
Group

CXTPControlGalleryItems Data Members


CXTPControlGalleryItems Methods

CXTPControlGalleryItems Class, Legend, Public Methods
CXTPControlGalleryItems Methods
Class

CXTPControlGalleryItems Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AddItem |
AddLabel |
ClipItems | Call this member to enable/disable clipping items if selection was changed
CreateItems | Creates new items collection for gallery control
GetImageManager | Retrieves image manager of the items
GetItem | Call this member to return the item at the specified index.
GetItemCount | Call this member to get the count of the items
GetItemSize | Determines default size of the items
InsertItem | Call this member to insert a new item.
OnItemsChanged | This method is called if items was added or removed in collection
PreDrawItem | This method is called to draw the item
Remove | Call this member to remove item.
RemoveAll | Call this method to remove all items in collection
SetImageManager | Call this method to set image manager for items
SetItemSize | Call this method to set size of the item


AddItem Method

CXTPControlGalleryItems Methods
AddItem Method
Overload List
Methods
Method | Description
CXTPControlGalleryItems::AddItem (CXTPControlGalleryItem*, int, int) | Call this member to add a new item.
CXTPControlGalleryItems::AddItem (LPCTSTR, int) | Call this member to add a new item.
CXTPControlGalleryItems::AddItem (int, int) | Call this member to add a new item.
Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::AddItem Method (int, int)

AddItem Method, CXTPControlGalleryItems Class
CXTPControlGalleryItems::AddItem Method (int, int)

Call this member to add a new item.

CXTPControlGalleryItem* AddItem(
    int nId,
    int nImage
);
CXTPControlGalleryItem* AddItem(
    CXTPControlGalleryItem* pItem,
    int nId = -1,
    int nImage = -1
);
CXTPControlGalleryItem* AddItem(
    LPCTSTR lpszCaption,
    int nImage = -1
);
Parameters

nId
Identifier of the item
nImage
Image of the item
pItem
Item to be added
lpszCaption
Caption of the item to be added

Returns

A pointer to the added item.

Group

AddItem Method


AddLabel Method

CXTPControlGalleryItems Methods
AddLabel Method
Overload List
Methods
Method | Description
CXTPControlGalleryItems::AddLabel (LPCTSTR) | Call this member to add a new label item.
CXTPControlGalleryItems::AddLabel (int) | Call this member to add a new label item.
Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::AddLabel Method (int)

AddLabel Method, CXTPControlGalleryItems Class
CXTPControlGalleryItems::AddLabel Method (int)

Call this member to add a new label item.

CXTPControlGalleryItem* AddLabel(
    int nId
);
CXTPControlGalleryItem* AddLabel(
    LPCTSTR lpszCaption
);
Parameters

nId
Identifier of the item
lpszCaption
Caption of the item to be added

Returns

A pointer to the added item.

Group

AddLabel Method


CXTPControlGalleryItems::ClipItems Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::ClipItems Method

Call this member to enable/disable clipping items if selection was changed

void ClipItems(
    BOOL bClipItems
);
Parameters

bClipItems
TRUE to enable clipping; FALSE to disable

Remarks

By default clipping is enabled

Body Source
void CXTPControlGalleryItems::ClipItems(BOOL bClipItems) {
    m_bClipItems = bClipItems;
}
Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::CreateItems Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::CreateItems Method

Creates new items collection for gallery control

static CXTPControlGalleryItems* CreateItems(
    CXTPCommandBars* pCommandBars,
    int nId
);
Parameters

pCommandBars
Parent Commandbars.
nId
Identifier of the items

Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::GetImageManager Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::GetImageManager Method

Retrieves image manager of the items

CXTPImageManager* GetImageManager() const;
Body Source
CXTPImageManager* CXTPControlGalleryItems::GetImageManager() const {
    return m_pImageManager;
}
Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::GetItem Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::GetItem Method

Call this member to return the item at the specified index.

CXTPControlGalleryItem* GetItem(
    int nIndex
) const;
Parameters

nIndex
An integer index.

Returns

The CXTPControlGalleryItem pointer currently at this index.

Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::GetItemCount Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::GetItemCount Method

Call this member to get the count of the items

int GetItemCount() const;
Returns

The count of the items in collection.

Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::GetItemSize Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::GetItemSize Method

Determines default size of the items

CSize GetItemSize() const;
See Also

SetItemSize

Body Source
CSize CXTPControlGalleryItems::GetItemSize() const {
    return m_szItem;
}
Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::InsertItem Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::InsertItem Method

Call this member to insert a new item.

CXTPControlGalleryItem* InsertItem(
    int nIndex,
    CXTPControlGalleryItem* pItem,
    int nId = -1,
    int nImage = -1
);
Parameters

nIndex
Index to insert new item
pItem
Item to be added
nId
Identifier of the item
nImage
Image of the item

Returns

A pointer to the added item.

Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::OnItemsChanged Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::OnItemsChanged Method

This method is called if items was added or removed in collection

virtual void OnItemsChanged();
Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::PreDrawItem Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::PreDrawItem Method

This method is called to draw the item

virtual BOOL PreDrawItem(
    CDC* pDC,
    CXTPControlGallery* pGallery,
    CXTPControlGalleryItem* pItem,
    CRect rcItem,
    BOOL bEnabled,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked
);
Parameters

pDC
Pointer to valid device context
pGallery
Parent gallery of the item
pItem
Item to be drawn
rcItem
Bounding rectangle of the item
bEnabled
TRUE to draw item enabled; FALSE - disabled
bSelected
TRUE to draw item selected
bPressed
TRUE to draw item pressed
bChecked
TRUE to draw item checked

Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::Remove Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::Remove Method

Call this member to remove item.

void Remove(
    int nIndex
);
Parameters

nIndex
Index of the item to be removed.

Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::RemoveAll Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::RemoveAll Method

Call this method to remove all items in collection

void RemoveAll();
Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::SetImageManager Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::SetImageManager Method

Call this method to set image manager for items

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
new image manager to be set

Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems::SetItemSize Method

CXTPControlGalleryItems Methods, CXTPControlGalleryItems Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::SetItemSize Method

Call this method to set size of the item

void SetItemSize(
    CSize szItem
);
Parameters

szItem
New size to be set

See Also

GetItemSize

Body Source
void CXTPControlGalleryItems::SetItemSize(CSize szItem) {
    m_szItem = szItem;
}
Group

CXTPControlGalleryItems Methods


CXTPControlGalleryItems Constructors

CXTPControlGalleryItems Class, Legend, Protected Methods
CXTPControlGalleryItems Constructors
Class

CXTPControlGalleryItems Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPControlGalleryItems | Constructs a CXTPControlGalleryItems object.


CXTPControlGalleryItems::CXTPControlGalleryItems Constructor

CXTPControlGalleryItems Constructors, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::CXTPControlGalleryItems Constructor

Constructs a CXTPControlGalleryItems object.

CXTPControlGalleryItems(
    CXTPControlAction* pAction
);
Parameters

pAction
Action for gallery control to link with.

Remarks

Protected constructor, use CreateItems to create items for gallery

Group

CXTPControlGalleryItems Constructors


CXTPControlGalleryItems Destructors

CXTPControlGalleryItems Class, Legend, Protected Methods
CXTPControlGalleryItems Destructors
Class

CXTPControlGalleryItems Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPControlGalleryItems | Destroys a CXTPControlGalleryItems object, handles cleanup and deallocation


CXTPControlGalleryItems::~CXTPControlGalleryItems Destructor

CXTPControlGalleryItems Destructors, CXTPControlGalleryItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryItems::~CXTPControlGalleryItems Destructor

Destroys a CXTPControlGalleryItems object, handles cleanup and deallocation

~CXTPControlGalleryItems();
Group

CXTPControlGalleryItems Destructors


CXTPControlGalleryPaintManager Class

XTPControlGallery.h, Classes, Legend, Members, Topics, CXTPControlGalleryPaintManager Data Members, CXTPControlGalleryPaintManager Methods, CXTPControlGalleryPaintManager Constructors, CXTPControlGalleryPaintManager Constructors, CXTPControlGalleryPaintManager Data Members, CXTPControlGalleryPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager Class

CXTPControlGalleryPaintManager is standalone class used to draw CXTPControlGallery object

Class Hierarchy

class CXTPControlGalleryPaintManager : public CXTPScrollBarPaintManager;
File

XTPControlGallery.h

Group

Classes

Legend
Data Member
Method
virtual
CXTPControlGalleryPaintManager Constructors
CXTPControlGalleryPaintManager Constructors | Description
CXTPControlGalleryPaintManager | Constructs a CXTPControlGalleryPaintManager object
CXTPControlGalleryPaintManager Data Members
CXTPControlGalleryPaintManager Data Members | Description
m_cxPopup | Width of arrows of in place scrollbar
m_cyPopupDown | Height of Down arrow of in place scrollbar
m_cyPopupUp | Height of Up arrow of in place scrollbar
CXTPControlGalleryPaintManager Methods
CXTPControlGalleryPaintManager Methods | Description
DrawLabel | This method is called to draw label control
DrawPopupScrollBar | This method called to draw scrollbar of inplace gallery
DrawScrollBar | This method is called to draw scrollbar of the gallery
FillControl | This method is called to draw background of the gallery
RefreshMetrics | Recalculates gallery metrics


CXTPControlGalleryPaintManager Data Members

CXTPControlGalleryPaintManager Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager Data Members
Class

CXTPControlGalleryPaintManager Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_cxPopup | Width of arrows of in place scrollbar
m_cyPopupDown | Height of Down arrow of in place scrollbar
m_cyPopupUp | Height of Up arrow of in place scrollbar


CXTPControlGalleryPaintManager::m_cxPopup Data Member

CXTPControlGalleryPaintManager Data Members, CXTPControlGalleryPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::m_cxPopup Data Member

Width of arrows of in place scrollbar

int m_cxPopup;
Group

CXTPControlGalleryPaintManager Data Members


CXTPControlGalleryPaintManager::m_cyPopupDown Data Member

CXTPControlGalleryPaintManager Data Members, CXTPControlGalleryPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::m_cyPopupDown Data Member

Height of Down arrow of in place scrollbar

int m_cyPopupDown;
Group

CXTPControlGalleryPaintManager Data Members


CXTPControlGalleryPaintManager::m_cyPopupUp Data Member

CXTPControlGalleryPaintManager Data Members, CXTPControlGalleryPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::m_cyPopupUp Data Member

Height of Up arrow of in place scrollbar

int m_cyPopupUp;
Group

CXTPControlGalleryPaintManager Data Members


CXTPControlGalleryPaintManager Methods

CXTPControlGalleryPaintManager Class, Legend, Public Methods
CXTPControlGalleryPaintManager Methods
Class

CXTPControlGalleryPaintManager Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawLabel | This method is called to draw label control
DrawPopupScrollBar | This method called to draw scrollbar of inplace gallery
DrawScrollBar | This method is called to draw scrollbar of the gallery
FillControl | This method is called to draw background of the gallery
RefreshMetrics | Recalculates gallery metrics


CXTPControlGalleryPaintManager::DrawLabel Method

CXTPControlGalleryPaintManager Methods, CXTPControlGalleryPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::DrawLabel Method

This method is called to draw label control

virtual void DrawLabel(
    CDC* pDC,
    CXTPControlGalleryItem* pLabel,
    CRect rc
);
Parameters

pDC
Pointer to device context
pLabel
Label item
rc
Bounding rectangle of the label

Group

CXTPControlGalleryPaintManager Methods


CXTPControlGalleryPaintManager::DrawPopupScrollBar Method

CXTPControlGalleryPaintManager Methods, CXTPControlGalleryPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::DrawPopupScrollBar Method

This method called to draw scrollbar of inplace gallery

virtual void DrawPopupScrollBar(
    CDC* pDC,
    CXTPControlGallery* pGallery
);
Parameters

pDC
Pointer to device context
pGallery
CXTPControlGallery object to draw

See Also

DrawScrollBar

Group

CXTPControlGalleryPaintManager Methods


CXTPControlGalleryPaintManager::DrawScrollBar Method

CXTPControlGalleryPaintManager Methods, CXTPControlGalleryPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::DrawScrollBar Method

This method is called to draw scrollbar of the gallery

virtual void DrawScrollBar(
    CDC* pDC,
    CXTPScrollBase* pScrollBar
);
Parameters

pDC
Pointer to device context
pScrollBar
ScrollBar to draw

Group

CXTPControlGalleryPaintManager Methods


CXTPControlGalleryPaintManager::FillControl Method

CXTPControlGalleryPaintManager Methods, CXTPControlGalleryPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::FillControl Method

This method is called to draw background of the gallery

virtual void FillControl(
    CDC* pDC,
    CXTPControlGallery* pGallery,
    CRect rc
);
Parameters

pDC
Pointer to device context
pGallery
CXTPControlGallery object to draw
rc
Bounding rectangle of gallery object

Group

CXTPControlGalleryPaintManager Methods


CXTPControlGalleryPaintManager::RefreshMetrics Method

CXTPControlGalleryPaintManager Methods, CXTPControlGalleryPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::RefreshMetrics Method

Recalculates gallery metrics

virtual void RefreshMetrics();
Group

CXTPControlGalleryPaintManager Methods


CXTPControlGalleryPaintManager Constructors

CXTPControlGalleryPaintManager Class, Legend, Public Methods
CXTPControlGalleryPaintManager Constructors
Class

CXTPControlGalleryPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlGalleryPaintManager | Constructs a CXTPControlGalleryPaintManager object


CXTPControlGalleryPaintManager::CXTPControlGalleryPaintManager Constructor

CXTPControlGalleryPaintManager Constructors, CXTPControlGalleryPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlGalleryPaintManager::CXTPControlGalleryPaintManager Constructor

Constructs a CXTPControlGalleryPaintManager object

CXTPControlGalleryPaintManager(
    CXTPPaintManager* pPaintManager
);
Parameters

pPaintManager
PaintManager of commandbars

Group

CXTPControlGalleryPaintManager Constructors


CXTPControlHyperlink Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlHyperlink Methods, CXTPControlHyperlink Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlHyperlink Class

CXTPControlHyperlink is a CXTPControl derived class. It can be used to add hyperlink text.

Class Hierarchy

class CXTPControlHyperlink : public CXTPControl;
File

XTPControlExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlHyperlink Methods
CXTPControlHyperlink Methods | Description
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
OnClick | This method is called when the user clicks the control.


CXTPControlHyperlink Methods

CXTPControlHyperlink Class, Legend, Protected Methods
CXTPControlHyperlink Methods
Class

CXTPControlHyperlink Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
OnClick | This method is called when the user clicks the control.


CXTPControlHyperlink::Draw Method

CXTPControlHyperlink Methods, CXTPControlHyperlink Class
CXTPControlHyperlink::Draw Method

This method is called to draw the control.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlHyperlink Methods


CXTPControlHyperlink::GetSize Method

CXTPControlHyperlink Methods, CXTPControlHyperlink Class
CXTPControlHyperlink::GetSize Method

This method is called to determine the size of the control.

virtual CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlHyperlink Methods


CXTPControlHyperlink::OnClick Method

CXTPControlHyperlink Methods, CXTPControlHyperlink Class
CXTPControlHyperlink::OnClick Method

This method is called when the user clicks the control.

virtual void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlHyperlink Methods


CXTPControlLabel Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlLabel Methods, CXTPControlLabel Constructors, CXTPControlLabel Constructors, CXTPControlLabel Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlLabel Class

CXTPControlLabel is a CXTPControl derived class. It represents a label control.

Class Hierarchy

class CXTPControlLabel : public CXTPControl;
File

XTPControlExt.h

Group

Classes

Legend
Method
virtual
CXTPControlLabel Constructors
CXTPControlLabel Constructors | Description
CXTPControlLabel | Constructs a CXTPControlLabel Object.
CXTPControlLabel Methods
CXTPControlLabel Methods | Description
GetSelected | Call this member to get the state of the control.
OnClick | This method is called when the user clicks the control.


CXTPControlLabel Methods

CXTPControlLabel Class, Legend, Public Methods
CXTPControlLabel Methods
Class

CXTPControlLabel Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetSelected | Call this member to get the state of the control.
OnClick | This method is called when the user clicks the control.


CXTPControlLabel::GetSelected Method

CXTPControlLabel Methods, CXTPControlLabel Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlLabel::GetSelected Method

Call this member to get the state of the control.

int GetSelected() const;
Returns

TRUE if the control is selected; otherwise FALSE. Controls of type CXTPControlLabel can not receive focus so this will always return FALSE.

Body Source
int GetSelected() const {
    return FALSE;
}
Group

CXTPControlLabel Methods


CXTPControlLabel::OnClick Method

CXTPControlLabel Methods, CXTPControlLabel Class
CXTPControlLabel::OnClick Method

This method is called when the user clicks the control.

virtual void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlLabel Methods


CXTPControlLabel Constructors

CXTPControlLabel Class, Legend, Public Methods
CXTPControlLabel Constructors
Class

CXTPControlLabel Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlLabel | Constructs a CXTPControlLabel Object.


CXTPControlLabel::CXTPControlLabel Constructor

CXTPControlLabel Constructors, CXTPControlLabel Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlLabel::CXTPControlLabel Constructor

Constructs a CXTPControlLabel Object.

CXTPControlLabel();
Body Source
CXTPControlLabel()
{
    m_dwFlags = xtpFlagSkipFocus | xtpFlagNoMovable | xtpFlagManualUpdate;
    m_controlType = xtpControlLabel;
}
Group

CXTPControlLabel Constructors


CXTPControlListBox Class

XTPControlListBox.h, Classes, Legend, Members, Topics, CXTPControlListBox Data Members, CXTPControlListBox Methods, CXTPControlListBox Constructors, CXTPControlListBox Destructors, CXTPControlListBox Constructors, CXTPControlListBox Data Members, CXTPControlListBox Destructors, CXTPControlListBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlListBox Class

CXTPControlComboBox is a CXTPControl derived class. It represents a list box control.

Class Hierarchy

class CXTPControlListBox : public CXTPControl;
File

XTPControlListBox.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControlListBox Constructors
CXTPControlListBox Constructors | Description
CXTPControlListBox | Constructs a CXTPControlListBox object
CXTPControlListBox Data Members
CXTPControlListBox Data Members | Description
m_bMouseLocked | TRUE to lock mouse events.
m_bMultiplSel | Multiple selection style.
m_nListBoxLinesMax | Maximum lines.
m_nListBoxLinesMin | Minimum lines.
m_pListBox | List box control.
CXTPControlListBox Destructors
CXTPControlListBox Destructors | Description
~CXTPControlListBox | Destroys a CXTPControlListBox object, handles cleanup and deallocation
CXTPControlListBox Methods
CXTPControlListBox Methods | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetListCtrl | Call this member to retrieve a pointer to the list control.
GetSize | This method is called to determine the size of the control.
IsFocused | Call this member to get the focused state of the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnSetSelected | This method is called when the control becomes selected.
SetEnabled | Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetLinesMinMax | Call this member to set the total minimum and maximum lines.
SetMultiplSel | Call this member to set the multiple selection style of the control.
SetParent | This method is called to assign a parent command bar object.
SetRect | Call this member to set the bounding rectangle of the control.
SetWidth | Call this member to set the width of the control


CXTPControlListBox Data Members

CXTPControlListBox Class, Legend, Protected Data Members
CXTPControlListBox Data Members
Class

CXTPControlListBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bMouseLocked | TRUE to lock mouse events.
m_bMultiplSel | Multiple selection style.
m_nListBoxLinesMax | Maximum lines.
m_nListBoxLinesMin | Minimum lines.
m_pListBox | List box control.


CXTPControlListBox::m_bMouseLocked Data Member

CXTPControlListBox Data Members, CXTPControlListBox Class
CXTPControlListBox::m_bMouseLocked Data Member

TRUE to lock mouse events.

BOOL m_bMouseLocked;
Group

CXTPControlListBox Data Members


CXTPControlListBox::m_bMultiplSel Data Member

CXTPControlListBox Data Members, CXTPControlListBox Class
CXTPControlListBox::m_bMultiplSel Data Member

Multiple selection style.

BOOL m_bMultiplSel;
Group

CXTPControlListBox Data Members


CXTPControlListBox::m_nListBoxLinesMax Data Member

CXTPControlListBox Data Members, CXTPControlListBox Class
CXTPControlListBox::m_nListBoxLinesMax Data Member

Maximum lines.

int m_nListBoxLinesMax;
Group

CXTPControlListBox Data Members


CXTPControlListBox::m_nListBoxLinesMin Data Member

CXTPControlListBox Data Members, CXTPControlListBox Class
CXTPControlListBox::m_nListBoxLinesMin Data Member

Minimum lines.

int m_nListBoxLinesMin;
Group

CXTPControlListBox Data Members


CXTPControlListBox::m_pListBox Data Member

CXTPControlListBox Data Members, CXTPControlListBox Class
CXTPControlListBox::m_pListBox Data Member

List box control.

CXTPControlListBoxCtrl* m_pListBox;
Group

CXTPControlListBox Data Members


CXTPControlListBox Methods

CXTPControlListBox Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlListBox Methods
Class

CXTPControlListBox Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
IsFocused | Call this member to get the focused state of the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnClick | This method is called when the user clicks the control.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnSetSelected | This method is called when the control becomes selected.
SetParent | This method is called to assign a parent command bar object.
SetRect | Call this member to set the bounding rectangle of the control.
Public Methods
Public Methods
Public Method | Description
GetListCtrl | Call this member to retrieve a pointer to the list control.
SetEnabled | Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.
SetLinesMinMax | Call this member to set the total minimum and maximum lines.
SetMultiplSel | Call this member to set the multiple selection style of the control.
SetWidth | Call this member to set the width of the control


CXTPControlListBox::Copy Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::Copy Method

This method is called to copy the control.

virtual void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlListBox Methods


CXTPControlListBox::DoPropExchange Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlListBox Methods


CXTPControlListBox::Draw Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::Draw Method

This method is called to draw the control.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlListBox Methods


CXTPControlListBox::GetListCtrl Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::GetListCtrl Method

Call this member to retrieve a pointer to the list control.

CListBox* GetListCtrl() const;
Returns

Retrieves list control.

Group

CXTPControlListBox Methods


CXTPControlListBox::GetSize Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::GetSize Method

This method is called to determine the size of the control.

virtual CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlListBox Methods


CXTPControlListBox::IsFocused Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::IsFocused Method

Call this member to get the focused state of the control.

virtual BOOL IsFocused() const;
Returns

TRUE if the control has focus; otherwise FALSE.

Group

CXTPControlListBox Methods


CXTPControlListBox::OnCalcDynamicSize Method

CXTPControlListBox Methods, CXTPControlListBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlListBox::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControl

Group

CXTPControlListBox Methods


CXTPControlListBox::OnClick Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::OnClick Method

This method is called when the user clicks the control.

virtual void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlListBox Methods


CXTPControlListBox::OnHookKeyDown Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::OnHookKeyDown Method

The framework calls this member function when a non-system key is pressed.

virtual BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE

Group

CXTPControlListBox Methods


CXTPControlListBox::OnSetSelected Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::OnSetSelected Method

This method is called when the control becomes selected.

virtual BOOL OnSetSelected(
    int bSelected
);
Parameters

bSelected
TRUE if the control becomes selected.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlListBox Methods


CXTPControlListBox::SetEnabled Method

CXTPControlListBox Methods, CXTPControlListBox Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlListBox::SetEnabled Method

Call this member to enable or disable the control. If the control does not have flags xtpFlagManualUpdate, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.

virtual void SetEnabled(
    BOOL bEnabled
);
Parameters

bEnabled
TRUE if the control is enabled.

See Also

GetEnabled, SetChecked

Group

CXTPControlListBox Methods


CXTPControlListBox::SetLinesMinMax Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::SetLinesMinMax Method

Call this member to set the total minimum and maximum lines.

void SetLinesMinMax(
    int nMin,
    int nMax
);
Parameters

nMin
Minimum lines to be used.
nMax
Maximum lines to be used

Group

CXTPControlListBox Methods


CXTPControlListBox::SetMultiplSel Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::SetMultiplSel Method

Call this member to set the multiple selection style of the control.

void SetMultiplSel(
    BOOL bMultiplSel
);
Parameters

bMultiplSel
TRUE to set multiple selection style.

Group

CXTPControlListBox Methods


CXTPControlListBox::SetParent Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::SetParent Method

This method is called to assign a parent command bar object.

virtual void SetParent(
    CXTPCommandBar* pParent
);
Parameters

pParent
Points to a CXTPCommandBar object

Group

CXTPControlListBox Methods


CXTPControlListBox::SetRect Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::SetRect Method

Call this member to set the bounding rectangle of the control.

virtual void SetRect(
    CRect rcControl
);
Parameters

rcControl
Bounding rectangle of the control.

Group

CXTPControlListBox Methods


CXTPControlListBox::SetWidth Method

CXTPControlListBox Methods, CXTPControlListBox Class
CXTPControlListBox::SetWidth Method

Call this member to set the width of the control

void SetWidth(
    int nWidth
);
Parameters

nWidth
The width of the control

Group

CXTPControlListBox Methods


CXTPControlListBox Constructors

CXTPControlListBox Class, Legend, Public Methods
CXTPControlListBox Constructors
Class

CXTPControlListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlListBox | Constructs a CXTPControlListBox object


CXTPControlListBox::CXTPControlListBox Constructor

CXTPControlListBox Constructors, CXTPControlListBox Class
CXTPControlListBox::CXTPControlListBox Constructor

Constructs a CXTPControlListBox object

CXTPControlListBox();
Group

CXTPControlListBox Constructors


CXTPControlListBox Destructors

CXTPControlListBox Class, Legend, Public Methods
CXTPControlListBox Destructors
Class

CXTPControlListBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlListBox | Destroys a CXTPControlListBox object, handles cleanup and deallocation


CXTPControlListBox::~CXTPControlListBox Destructor

CXTPControlListBox Destructors, CXTPControlListBox Class
CXTPControlListBox::~CXTPControlListBox Destructor

Destroys a CXTPControlListBox object, handles cleanup and deallocation

virtual ~CXTPControlListBox();
Group

CXTPControlListBox Destructors


CXTPControlMarkupLabel Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlMarkupLabel Methods, CXTPControlMarkupLabel Constructors, CXTPControlMarkupLabel Constructors, CXTPControlMarkupLabel Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlMarkupLabel Class

CXTPControlMarkupLabel is a CXTPControlLabel derived class. It can be used to draw markup text

Class Hierarchy

class CXTPControlMarkupLabel : public CXTPControlLabel;
File

XTPControlExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlMarkupLabel Constructors
CXTPControlMarkupLabel Constructors | Description
CXTPControlMarkupLabel | Constructs a CXTPControlMarkupLabel Object.
CXTPControlMarkupLabel Methods
CXTPControlMarkupLabel Methods | Description
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.


CXTPControlMarkupLabel Methods

CXTPControlMarkupLabel Class, Legend, Protected Methods
CXTPControlMarkupLabel Methods
Class

CXTPControlMarkupLabel Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.


CXTPControlMarkupLabel::Draw Method

CXTPControlMarkupLabel Methods, CXTPControlMarkupLabel Class
CXTPControlMarkupLabel::Draw Method

This method is called to draw the control.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlMarkupLabel Methods


CXTPControlMarkupLabel::GetSize Method

CXTPControlMarkupLabel Methods, CXTPControlMarkupLabel Class
CXTPControlMarkupLabel::GetSize Method

This method is called to determine the size of the control.

virtual CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlMarkupLabel Methods


CXTPControlMarkupLabel Constructors

CXTPControlMarkupLabel Class, Legend, Public Methods
CXTPControlMarkupLabel Constructors
Class

CXTPControlMarkupLabel Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlMarkupLabel | Constructs a CXTPControlMarkupLabel Object.


CXTPControlMarkupLabel::CXTPControlMarkupLabel Constructor

CXTPControlMarkupLabel Constructors, CXTPControlMarkupLabel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlMarkupLabel::CXTPControlMarkupLabel Constructor

Constructs a CXTPControlMarkupLabel Object.

CXTPControlMarkupLabel();
Group

CXTPControlMarkupLabel Constructors


CXTPControlOleItems Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlOleItems Methods, CXTPControlOleItems Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlOleItems Class

CXTPControlOleItems is a CXTPControlButton derived class. It is used internally to create ole items.

Class Hierarchy

class CXTPControlOleItems : public CXTPControlButton;
File

XTPControlExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlOleItems Methods
CXTPControlOleItems Methods | Description
IsCustomizeDragOverAvail | Call this member to check if the user can drop the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.


CXTPControlOleItems Methods

CXTPControlOleItems Class, Legend, Protected Methods
CXTPControlOleItems Methods
Class

CXTPControlOleItems Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
IsCustomizeDragOverAvail | Call this member to check if the user can drop the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.


CXTPControlOleItems::IsCustomizeDragOverAvail Method

CXTPControlOleItems Methods, CXTPControlOleItems Class
CXTPControlOleItems::IsCustomizeDragOverAvail Method

Call this member to check if the user can drop the control.

virtual BOOL IsCustomizeDragOverAvail(
    CXTPCommandBar* pCommandBar,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pCommandBar
Points to a CXTPCommandBar object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Returns

TRUE if successful, otherwise returns FALSE

Group

CXTPControlOleItems Methods


CXTPControlOleItems::OnCalcDynamicSize Method

CXTPControlOleItems Methods, CXTPControlOleItems Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlOleItems::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControl, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Group

CXTPControlOleItems Methods


CXTPControlPopup Class

XTPControlPopup.h, Classes, Legend, Members, Topics, CXTPControlPopup Data Members, CXTPControlPopup Methods, CXTPControlPopup Constructors, CXTPControlPopup Destructors, CXTPControlPopup Constructors, CXTPControlPopup Data Members, CXTPControlPopup Destructors, CXTPControlPopup Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlPopup Class

CXTPControlPopup is a CXTPControl derived class. It represents a popup-able control.

Class Hierarchy

class CXTPControlPopup : public CXTPControlButton;
File

XTPControlPopup.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControlPopup Constructors
CXTPControlPopup Constructors | Description
CXTPControlPopup | Constructs a CXTPControlPopup object
CXTPControlPopup Data Members
CXTPControlPopup Data Members | Description
m_bPopup | TRUE if popuped.
m_bShowShadow | TRUE to show shadow
m_dwCommandBarID | Child popup id.
m_pCommandBar | Child popup bar.
CXTPControlPopup Destructors
CXTPControlPopup Destructors | Description
~CXTPControlPopup | Destroys a CXTPControlPopup object, handles cleanup and deallocation
CXTPControlPopup Methods
CXTPControlPopup Methods | Description
AdjustExcludeRect | Updates rectangle to set position where child popup bar become visible.
Compare | Call this member to compare controls.
Copy | This method is called to copy the control.
CreateControlPopup | Creates a CXTPControlPopup object with the specified type.
DoPropExchange | Reads or writes this object from or to an archive.
ExpandCommandBar | Call this member to expand the parent popup bar.
GetCommandBar | Call this member to get the child command bar.
GetPopuped | Call this member to get the control's popup state.
IsContainPopup | This method is called to check if pControlPopup contains in the control recursively.
IsCustomizeDragOverAvail | This member checks if the user can drop the control.
OnClick | This method is called when the user clicks the control.
OnCustomizeDragOver | This method is called when the user moves the mouse over the control.
OnLButtonDblClk | This member is called when the user double-clicks the left mouse button.
OnLButtonUp | This member is called when the user releases the left mouse button.
OnMouseHover | This method is called after the mouse hovers over the control.
OnMouseMove | This member is called when the mouse cursor moves.
OnSetPopup | This method is called to popup the control.
OnSetSelected | This method is called when the control becomes selected.
OnUnderlineActivate | This method is called when the user activate control using its underline.
RestoreCommandBarList | This method is called from LoadCommandBars to restore controls and its child commandbars
SetCommandBar |
UpdateShadow | Call this member to update the shadow of the control.


CXTPControlPopup Data Members

CXTPControlPopup Class, Legend, Protected Data Members
CXTPControlPopup Data Members
Class

CXTPControlPopup Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bPopup | TRUE if popuped.
m_bShowShadow | TRUE to show shadow
m_dwCommandBarID | Child popup id.
m_pCommandBar | Child popup bar.


CXTPControlPopup::m_bPopup Data Member

CXTPControlPopup Data Members, CXTPControlPopup Class
CXTPControlPopup::m_bPopup Data Member

TRUE if popuped.

BOOL m_bPopup;
Group

CXTPControlPopup Data Members


CXTPControlPopup::m_bShowShadow Data Member

CXTPControlPopup Data Members, CXTPControlPopup Class
CXTPControlPopup::m_bShowShadow Data Member

TRUE to show shadow

BOOL m_bShowShadow;
Group

CXTPControlPopup Data Members


CXTPControlPopup::m_dwCommandBarID Data Member

CXTPControlPopup Data Members, CXTPControlPopup Class
CXTPControlPopup::m_dwCommandBarID Data Member

Child popup id.

DWORD m_dwCommandBarID;
Group

CXTPControlPopup Data Members


CXTPControlPopup::m_pCommandBar Data Member

CXTPControlPopup Data Members, CXTPControlPopup Class
CXTPControlPopup::m_pCommandBar Data Member

Child popup bar.

CXTPCommandBar* m_pCommandBar;
Group

CXTPControlPopup Data Members


CXTPControlPopup Methods

CXTPControlPopup Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlPopup Methods
Class

CXTPControlPopup Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Compare | Call this member to compare controls.
ExpandCommandBar | Call this member to expand the parent popup bar.
IsContainPopup | This method is called to check if pControlPopup contains in the control recursively.
IsCustomizeDragOverAvail | This member checks if the user can drop the control.
OnClick | This method is called when the user clicks the control.
OnCustomizeDragOver | This method is called when the user moves the mouse over the control.
OnLButtonDblClk | This member is called when the user double-clicks the left mouse button.
OnLButtonUp | This member is called when the user releases the left mouse button.
OnMouseHover | This method is called after the mouse hovers over the control.
OnMouseMove | This member is called when the mouse cursor moves.
OnSetPopup | This method is called to popup the control.
OnSetSelected | This method is called when the control becomes selected.
RestoreCommandBarList | This method is called from LoadCommandBars to restore controls and its child commandbars
UpdateShadow | Call this member to update the shadow of the control.
Public Methods
Public Methods
Public Method | Description
AdjustExcludeRect | Updates rectangle to set position where child popup bar become visible.
Copy | This method is called to copy the control.
CreateControlPopup | Creates a CXTPControlPopup object with the specified type.
DoPropExchange | Reads or writes this object from or to an archive.
GetCommandBar | Call this member to get the child command bar.
GetPopuped | Call this member to get the control's popup state.
OnUnderlineActivate | This method is called when the user activate control using its underline.
SetCommandBar |


CXTPControlPopup::AdjustExcludeRect Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::AdjustExcludeRect Method

Updates rectangle to set position where child popup bar become visible.

virtual void AdjustExcludeRect(
    CRect& rc,
    BOOL bVertical
);
Parameters

rc
CRect object specifying size of area.
bVertical
TRUE if control is located vertically in its parent.

Group

CXTPControlPopup Methods


CXTPControlPopup::Compare Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::Compare Method

Call this member to compare controls.

virtual BOOL Compare(
    CXTPControl* pOther
);
Parameters

pOther
The control needed to compare with.

Returns

TRUE if the controls are identical.

Group

CXTPControlPopup Methods


CXTPControlPopup::Copy Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::Copy Method

This method is called to copy the control.

void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlPopup Methods


CXTPControlPopup::CreateControlPopup Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::CreateControlPopup Method

Creates a CXTPControlPopup object with the specified type.

static CXTPControlPopup* CreateControlPopup(
    XTPControlType controlType
);
Parameters

controlType
XTPControlType type of popup control. Can be any of the values listed in the Remarks section.

Returns

A pointer to a CXTPControlPopup object

Remarks

Popup type can be one of the following:

  • xtpControlPopup Popup type.
  • xtpControlButtonPopup Button popup.
  • xtpControlSplitButtonPopup Split button popup.
Group

CXTPControlPopup Methods


CXTPControlPopup::DoPropExchange Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlPopup Methods


CXTPControlPopup::ExpandCommandBar Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::ExpandCommandBar Method

Call this member to expand the parent popup bar.

void ExpandCommandBar();
Group

CXTPControlPopup Methods


CXTPControlPopup::GetCommandBar Method

CXTPControlPopup Methods, CXTPControlPopup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlPopup::GetCommandBar Method

Call this member to get the child command bar.

CXTPCommandBar* GetCommandBar() const;
Returns

A pointer to the child command bar.

Body Source
CXTPCommandBar* CXTPControlPopup::GetCommandBar() const {
    return m_pCommandBar;
}
Group

CXTPControlPopup Methods


CXTPControlPopup::GetPopuped Method

CXTPControlPopup Methods, CXTPControlPopup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlPopup::GetPopuped Method

Call this member to get the control's popup state.

BOOL GetPopuped() const;
Returns

TRUE if the control is a popup.

Body Source
BOOL CXTPControlPopup::GetPopuped() const{
    return m_bPopup;
}
Group

CXTPControlPopup Methods


CXTPControlPopup::IsContainPopup Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::IsContainPopup Method

This method is called to check if pControlPopup contains in the control recursively.

BOOL IsContainPopup(
    CXTPControlPopup* pControlPopup
);
Parameters

pControlPopup
Points to a CXTPControlPopup object needed to check.

Returns

TRUE if contains; otherwise returns FALSE

Group

CXTPControlPopup Methods


CXTPControlPopup::IsCustomizeDragOverAvail Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::IsCustomizeDragOverAvail Method

This member checks if the user can drop the control.

virtual BOOL IsCustomizeDragOverAvail(
    CXTPCommandBar* pCommandBar,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pCommandBar
Points to a CXTPCommandBar object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Returns

TRUE if successful, otherwise returns FALSE

Group

CXTPControlPopup Methods


CXTPControlPopup::OnClick Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnClick Method

This method is called when the user clicks the control.

void OnClick(
    BOOL bKeyboard = FALSE,
    CPoint pt = CPoint(0, 0)
);
Parameters

bKeyboard
TRUE if the control is selected using the keyboard.
pt
Mouse cursor position.

Group

CXTPControlPopup Methods


CXTPControlPopup::OnCustomizeDragOver Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnCustomizeDragOver Method

This method is called when the user moves the mouse over the control.

void OnCustomizeDragOver(
    CXTPControl* pDataObject,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pDataObject
Points to a CXTPControl object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Group

CXTPControlPopup Methods


CXTPControlPopup::OnLButtonDblClk Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnLButtonDblClk Method

This member is called when the user double-clicks the left mouse button.

virtual BOOL OnLButtonDblClk(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinates of the cursor.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlPopup Methods


CXTPControlPopup::OnLButtonUp Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnLButtonUp Method

This member is called when the user releases the left mouse button.

virtual void OnLButtonUp(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlPopup Methods


CXTPControlPopup::OnMouseHover Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnMouseHover Method

This method is called after the mouse hovers over the control.

void OnMouseHover();
Group

CXTPControlPopup Methods


CXTPControlPopup::OnMouseMove Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnMouseMove Method

This member is called when the mouse cursor moves.

virtual void OnMouseMove(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlPopup Methods


CXTPControlPopup::OnSetPopup Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnSetPopup Method

This method is called to popup the control.

virtual BOOL OnSetPopup(
    BOOL bPopup
);
Parameters

bPopup
TRUE to set popup.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlPopup Methods


CXTPControlPopup::OnSetSelected Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnSetSelected Method

This method is called when the control becomes selected.

BOOL OnSetSelected(
    int bSelected
);
Parameters

bSelected
TRUE if the control becomes selected.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlPopup Methods


CXTPControlPopup::OnUnderlineActivate Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::OnUnderlineActivate Method

This method is called when the user activate control using its underline.

virtual void OnUnderlineActivate();
Group

CXTPControlPopup Methods


CXTPControlPopup::RestoreCommandBarList Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::RestoreCommandBarList Method

This method is called from LoadCommandBars to restore controls and its child commandbars

virtual void RestoreCommandBarList(
    CXTPCommandBarList* pCommandBarList
);
Parameters

pCommandBarList
CommandBars collection contains all commandbars was restored

Group

CXTPControlPopup Methods


SetCommandBar Method

CXTPControlPopup Methods
SetCommandBar Method
Overload List
Methods
Method | Description
CXTPControlPopup::SetCommandBar (CMenu*) | Call this member to set the child command bar.
CXTPControlPopup::SetCommandBar (CXTPCommandBar*) | Call this member to set the child command bar.
Group

CXTPControlPopup Methods


CXTPControlPopup::SetCommandBar Method (CMenu*)

SetCommandBar Method, CXTPControlPopup Class
CXTPControlPopup::SetCommandBar Method (CMenu*)

Call this member to set the child command bar.

void SetCommandBar(
    CMenu* pMenu
);
void SetCommandBar(
    CXTPCommandBar* pBar
);
Parameters

pMenu
The menu to be loaded as a child.
pBar
The child command bar.

Group

SetCommandBar Method


CXTPControlPopup::UpdateShadow Method

CXTPControlPopup Methods, CXTPControlPopup Class
CXTPControlPopup::UpdateShadow Method

Call this member to update the shadow of the control.

virtual void UpdateShadow();
Group

CXTPControlPopup Methods


CXTPControlPopup Constructors

CXTPControlPopup Class, Legend, Public Methods
CXTPControlPopup Constructors
Class

CXTPControlPopup Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlPopup | Constructs a CXTPControlPopup object


CXTPControlPopup::CXTPControlPopup Constructor

CXTPControlPopup Constructors, CXTPControlPopup Class
CXTPControlPopup::CXTPControlPopup Constructor

Constructs a CXTPControlPopup object

CXTPControlPopup();
Group

CXTPControlPopup Constructors


CXTPControlPopup Destructors

CXTPControlPopup Class, Legend, Public Methods
CXTPControlPopup Destructors
Class

CXTPControlPopup Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlPopup | Destroys a CXTPControlPopup object, handles cleanup and deallocation


CXTPControlPopup::~CXTPControlPopup Destructor

CXTPControlPopup Destructors, CXTPControlPopup Class
CXTPControlPopup::~CXTPControlPopup Destructor

Destroys a CXTPControlPopup object, handles cleanup and deallocation

virtual ~CXTPControlPopup();
Group

CXTPControlPopup Destructors


CXTPControlPopupColor Class

XTPControlPopupColor.h, Classes, Legend, Members, Topics, CXTPControlPopupColor Methods, CXTPControlPopupColor Constructors, CXTPControlPopupColor Destructors, CXTPControlPopupColor Constructors, CXTPControlPopupColor Destructors, CXTPControlPopupColor Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlPopupColor Class

CXTPControlPopupColor is a CXTPControlPopup derived class. It represents a color picker control.

Class Hierarchy

class CXTPControlPopupColor : public CXTPControlPopup;
File

XTPControlPopupColor.h

Group

Classes

Legend
Method
protected
CXTPControlPopupColor Constructors
CXTPControlPopupColor Constructors | Description
CXTPControlPopupColor | Constructs a CXTPControlPopupColor object
CXTPControlPopupColor Destructors
CXTPControlPopupColor Destructors | Description
~CXTPControlPopupColor | Destroys a CXTPControlPopupColor object, handles cleanup and deallocation
CXTPControlPopupColor Methods
CXTPControlPopupColor Methods | Description
Copy | This method is called to copy the control.
GetColor | Call this member to retrieve the control color.
SetColor | Call this member to set the picker color.


CXTPControlPopupColor Methods

CXTPControlPopupColor Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlPopupColor Methods
Class

CXTPControlPopupColor Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
Public Methods
Public Methods
Public Method | Description
GetColor | Call this member to retrieve the control color.
SetColor | Call this member to set the picker color.


CXTPControlPopupColor::Copy Method

CXTPControlPopupColor Methods, CXTPControlPopupColor Class
CXTPControlPopupColor::Copy Method

This method is called to copy the control.

void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlPopupColor Methods


CXTPControlPopupColor::GetColor Method

CXTPControlPopupColor Methods, CXTPControlPopupColor Class
CXTPControlPopupColor::GetColor Method

Call this member to retrieve the control color.

COLORREF GetColor() const;
Returns

Color of the color picker.

Group

CXTPControlPopupColor Methods


CXTPControlPopupColor::SetColor Method

CXTPControlPopupColor Methods, CXTPControlPopupColor Class
CXTPControlPopupColor::SetColor Method

Call this member to set the picker color.

void SetColor(
    COLORREF clr
);
Parameters

clr
Color to set.

Group

CXTPControlPopupColor Methods


CXTPControlPopupColor Constructors

CXTPControlPopupColor Class, Legend, Public Methods
CXTPControlPopupColor Constructors
Class

CXTPControlPopupColor Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlPopupColor | Constructs a CXTPControlPopupColor object


CXTPControlPopupColor::CXTPControlPopupColor Constructor

CXTPControlPopupColor Constructors, CXTPControlPopupColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlPopupColor::CXTPControlPopupColor Constructor

Constructs a CXTPControlPopupColor object

CXTPControlPopupColor();
Group

CXTPControlPopupColor Constructors


CXTPControlPopupColor Destructors

CXTPControlPopupColor Class, Legend, Public Methods
CXTPControlPopupColor Destructors
Class

CXTPControlPopupColor Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlPopupColor | Destroys a CXTPControlPopupColor object, handles cleanup and deallocation


CXTPControlPopupColor::~CXTPControlPopupColor Destructor

CXTPControlPopupColor Destructors, CXTPControlPopupColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlPopupColor::~CXTPControlPopupColor Destructor

Destroys a CXTPControlPopupColor object, handles cleanup and deallocation

~CXTPControlPopupColor();
Group

CXTPControlPopupColor Destructors


CXTPControlRadioButton Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlRadioButton Constructors, CXTPControlRadioButton Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlRadioButton Class

CXTPControlRadioButton is a CXTPControlButton derived class. It represents a radio button control.

Class Hierarchy

class CXTPControlRadioButton : public CXTPControlButton;
File

XTPControlExt.h

Group

Classes

Legend
Constructor
CXTPControlRadioButton Constructors
CXTPControlRadioButton Constructors | Description
CXTPControlRadioButton | Constructs a CXTPControlRadioButton Object.


CXTPControlRadioButton Constructors

CXTPControlRadioButton Class, Legend, Public Methods
CXTPControlRadioButton Constructors
Class

CXTPControlRadioButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlRadioButton | Constructs a CXTPControlRadioButton Object.


CXTPControlRadioButton::CXTPControlRadioButton Constructor

CXTPControlRadioButton Constructors, CXTPControlRadioButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlRadioButton::CXTPControlRadioButton Constructor

Constructs a CXTPControlRadioButton Object.

CXTPControlRadioButton();
Group

CXTPControlRadioButton Constructors


CXTPControlRecentFileList Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlRecentFileList Methods, CXTPControlRecentFileList Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlRecentFileList Class

CXTPControlRecentFileList is a CXTPControlButton derived class. It is used internally to create recent items list.

Class Hierarchy

class CXTPControlRecentFileList : public CXTPControlButton;
File

XTPControlExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlRecentFileList Methods
CXTPControlRecentFileList Methods | Description
GetFirstMruID | Returns ID_FILE_MRU_FILE1.
GetRecentFileList | Returns pointer to recent file list collection
IsCustomizeDragOverAvail | Call this member to check if the user can drop the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.


CXTPControlRecentFileList Methods

CXTPControlRecentFileList Class, Legend, Protected Methods
CXTPControlRecentFileList Methods
Class

CXTPControlRecentFileList Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetFirstMruID | Returns ID_FILE_MRU_FILE1.
GetRecentFileList | Returns pointer to recent file list collection
IsCustomizeDragOverAvail | Call this member to check if the user can drop the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.


CXTPControlRecentFileList::GetFirstMruID Method

CXTPControlRecentFileList Methods, CXTPControlRecentFileList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlRecentFileList::GetFirstMruID Method

Returns ID_FILE_MRU_FILE1.

virtual int GetFirstMruID();
Group

CXTPControlRecentFileList Methods


CXTPControlRecentFileList::GetRecentFileList Method

CXTPControlRecentFileList Methods, CXTPControlRecentFileList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlRecentFileList::GetRecentFileList Method

Returns pointer to recent file list collection

virtual CRecentFileList* GetRecentFileList();
Returns

Pointer to recent file list collection

Group

CXTPControlRecentFileList Methods


CXTPControlRecentFileList::IsCustomizeDragOverAvail Method

CXTPControlRecentFileList Methods, CXTPControlRecentFileList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlRecentFileList::IsCustomizeDragOverAvail Method

Call this member to check if the user can drop the control.

virtual BOOL IsCustomizeDragOverAvail(
    CXTPCommandBar* pCommandBar,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pCommandBar
Points to a CXTPCommandBar object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Returns

TRUE if successful, otherwise returns FALSE

Group

CXTPControlRecentFileList Methods


CXTPControlRecentFileList::OnCalcDynamicSize Method

CXTPControlRecentFileList Methods, CXTPControlRecentFileList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlRecentFileList::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControl, CXTPControlSelector, CXTPControlListBox

Group

CXTPControlRecentFileList Methods


CXTPControls Class

XTPControls.h, Classes, Legend, Members, Topics, CXTPControls Data Members, CXTPControls Methods, CXTPControls Constructors, CXTPControls Destructors, CXTPControls Constructors, CXTPControls Data Members, CXTPControls Destructors, CXTPControls Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControls Class

CXTPControls is a CCmdTarget derived class. It represents a collection of the controls.

Class Hierarchy

class CXTPControls;
File

XTPControls.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPControls Constructors
CXTPControls Constructors | Description
CXTPControls | Protected constructor used by dynamic creation
CXTPControls Data Members
CXTPControls Data Members | Description
m_arrControls | Collection of controls
m_pCommandBars | Parent Command Bars
m_pOriginalControls | Original controls collection.
m_pParent | Parent Command Bar
CXTPControls Destructors
CXTPControls Destructors | Description
~CXTPControls | Destroys a CXTPControls object, handles cleanup and deallocation
CXTPControls Methods
CXTPControls Methods | Description
Add |
AddClone | Call this member to add the copy of the control.
AddMenuItem | Call this member to add a new control.
CalcDynamicSize | This method is called internally to reposition controls and determine their size.
CalcPopupSize | This method is called internally to reposition controls and determine their size for popup bar.
ClearOriginalControls | Removes the original controls set.
CommandToIndex | This member function returns the index of the first control, starting at position 0, whose command ID matches nIDFind.
Compare | Call this member to compare the controls.
CreateOriginalControls | Creates original controls set.
DoPropExchange | Reads or writes this object from or to an archive.
Duplicate | Makes a copy of all controls.
FindControl |
GetAt | Call this member to return the control at the specified index.
GetCommandBars | Retrieves the parent command bars object.
GetCount | Call this member to get the count of the controls
GetFirst | Call this member to retrieve the first control.
GetNext |
GetOriginalControls | Retrieves original controls set.
GetParent | Call this member to get the parent command bar.
GetVisibleCount | Call this member to get the number of visible controls.
HitTest | This method determines where a point lies in a specified control.
InsertAt | Call this member to insert a new control.
IsChanged | Returns the changed status flag of the control.
LoadMenu | Call this member to convert menu items to command bar controls.
MoveBefore | Move the control to a specified position.
OnControlAdded | This method is called when control is added to collection
OnControlRemoved | This method is called when control is removed from collection
OnControlRemoving | This method is called when control is about to be removed from collection
Remove |
RemoveAll | Call this member to remove all controls.
SetCommandBars | Call this member to attach the specified command bars object.
SetControlType |
SetOriginalControls | Call this method to assign original controls
SetParent | Attaches the parent command bar.


CXTPControls Data Members

CXTPControls Class, Legend, Protected Data Members
CXTPControls Data Members
Class

CXTPControls Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrControls | Collection of controls
m_pCommandBars | Parent Command Bars
m_pOriginalControls | Original controls collection.
m_pParent | Parent Command Bar


CXTPControls::m_arrControls Data Member

CXTPControls Data Members, CXTPControls Class
CXTPControls::m_arrControls Data Member

Collection of controls

CArray<CXTPControl*, CXTPControl*> m_arrControls;
Group

CXTPControls Data Members


CXTPControls::m_pCommandBars Data Member

CXTPControls Data Members, CXTPControls Class
CXTPControls::m_pCommandBars Data Member

Parent Command Bars

CXTPCommandBars* m_pCommandBars;
Group

CXTPControls Data Members


CXTPControls::m_pOriginalControls Data Member

CXTPControls Data Members, CXTPControls Class
CXTPControls::m_pOriginalControls Data Member

Original controls collection.

CXTPOriginalControls* m_pOriginalControls;
Group

CXTPControls Data Members


CXTPControls::m_pParent Data Member

CXTPControls Data Members, CXTPControls Class
CXTPControls::m_pParent Data Member

Parent Command Bar

CXTPCommandBar* m_pParent;
Group

CXTPControls Data Members


CXTPControls Methods

CXTPControls Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControls Methods
Class

CXTPControls Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnControlAdded | This method is called when control is added to collection
OnControlRemoved | This method is called when control is removed from collection
OnControlRemoving | This method is called when control is about to be removed from collection
Public Methods
Public Methods
Public Method | Description
Add |
AddClone | Call this member to add the copy of the control.
AddMenuItem | Call this member to add a new control.
CalcDynamicSize | This method is called internally to reposition controls and determine their size.
CalcPopupSize | This method is called internally to reposition controls and determine their size for popup bar.
ClearOriginalControls | Removes the original controls set.
CommandToIndex | This member function returns the index of the first control, starting at position 0, whose command ID matches nIDFind.
Compare | Call this member to compare the controls.
CreateOriginalControls | Creates original controls set.
DoPropExchange | Reads or writes this object from or to an archive.
Duplicate | Makes a copy of all controls.
FindControl |
GetAt | Call this member to return the control at the specified index.
GetCommandBars | Retrieves the parent command bars object.
GetCount | Call this member to get the count of the controls
GetFirst | Call this member to retrieve the first control.
GetNext |
GetOriginalControls | Retrieves original controls set.
GetParent | Call this member to get the parent command bar.
GetVisibleCount | Call this member to get the number of visible controls.
HitTest | This method determines where a point lies in a specified control.
InsertAt | Call this member to insert a new control.
IsChanged | Returns the changed status flag of the control.
LoadMenu | Call this member to convert menu items to command bar controls.
MoveBefore | Move the control to a specified position.
Remove |
RemoveAll | Call this member to remove all controls.
SetCommandBars | Call this member to attach the specified command bars object.
SetControlType |
SetOriginalControls | Call this method to assign original controls
SetParent | Attaches the parent command bar.


Add Method

CXTPControls Methods
Add Method
Overload List
Methods
Method | Description
CXTPControls::Add (CXTPControl*) | Call this member to add a new control.
CXTPControls::Add (CXTPControl*, int, LPCTSTR, int, BOOL) | Call this member to add a new control.
CXTPControls::Add (XTPControlType, int, LPCTSTR, int, BOOL) | Call this member to add a new control.
Group

CXTPControls Methods


CXTPControls::Add Method (CXTPControl*, int, LPCTSTR, int, BOOL)

Add Method, CXTPControls Class
CXTPControls::Add Method (CXTPControl*, int, LPCTSTR, int, BOOL)

Call this member to add a new control.

CXTPControl* Add(
    CXTPControl* pControl,
    int nId,
    LPCTSTR lpszParameter = NULL,
    int nBefore = -1,
    BOOL bTemporary = FALSE
);
CXTPControl* Add(
    XTPControlType controlType,
    int nId,
    LPCTSTR lpszParameter = NULL,
    int nBefore = -1,
    BOOL bTemporary = FALSE
);
CXTPControl* Add(
    CXTPControl* pControl
);
Parameters

pControl
A pointer to the control to be added.
nId
Identifier of the control to be added.
lpszParameter
Parameter of the control to be added.
nBefore
Index of the control to be inserted.
bTemporary
TRUE if this control is temporary.
controlType
The type of the control to be added.

Returns

A pointer to the added control.

Group

Add Method


CXTPControls::AddClone Method

CXTPControls Methods, CXTPControls Class
CXTPControls::AddClone Method

Call this member to add the copy of the control.

CXTPControl* AddClone(
    CXTPControl* pClone,
    int nBefore = -1,
    BOOL bRecursive = FALSE
);
Parameters

pClone
Points to a CXTPControl object needed to copy.
nBefore
Index of the control to be inserted.
bRecursive
TRUE to copy recursively.

Returns

A pointer to an added CXTPControl object

Group

CXTPControls Methods


CXTPControls::AddMenuItem Method

CXTPControls Methods, CXTPControls Class
CXTPControls::AddMenuItem Method

Call this member to add a new control.

CXTPControl* AddMenuItem(
    CMenu* pMenu,
    int nIndex
);
Parameters

pMenu
Menu that contains the control.
nIndex
Index of the control to be added.

Returns

Pointer to the added control.

Group

CXTPControls Methods


CXTPControls::CalcDynamicSize Method

CXTPControls Methods, CXTPControls Class
CXTPControls::CalcDynamicSize Method

This method is called internally to reposition controls and determine their size.

CSize CalcDynamicSize(
    CDC* pDC,
    int nLength,
    DWORD dwMode,
    const CRect& rcBorder,
    int nWidth = 0
);
Parameters

pDC
Pointer to a valid device context
nLength
Length of the parent bar.
dwMode
Mode of the parent bar.
rcBorder
Borders of commandbar.
nWidth
Width of the parent bar.

Returns

Total size of the controls.

Group

CXTPControls Methods


CXTPControls::CalcPopupSize Method

CXTPControls Methods, CXTPControls Class, See Also
CXTPControls::CalcPopupSize Method

This method is called internally to reposition controls and determine their size for popup bar.

CSize CalcPopupSize(
    CDC* pDC,
    int nLength,
    int nWidth,
    const CRect& rcBorder
);
Parameters

pDC
Pointer to a valid device context
nLength
Length of the parent bar.
rcBorder
Borders of popup bar.

Returns

Total size of the controls.

See Also

CalcDynamicSize

Group

CXTPControls Methods


CXTPControls::ClearOriginalControls Method

CXTPControls Methods, CXTPControls Class
CXTPControls::ClearOriginalControls Method

Removes the original controls set.

void ClearOriginalControls();
Group

CXTPControls Methods


CXTPControls::CommandToIndex Method

CXTPControls Methods, CXTPControls Class
CXTPControls::CommandToIndex Method

This member function returns the index of the first control, starting at position 0, whose command ID matches nIDFind.

int CommandToIndex(
    int nIDFind
) const;
Parameters

nIDFind
Command ID of the control to find.

Returns

The index of the control, or -1 if no control has the given command ID.

Group

CXTPControls Methods


CXTPControls::Compare Method

CXTPControls Methods, CXTPControls Class
CXTPControls::Compare Method

Call this member to compare the controls.

BOOL Compare(
    const CXTPControls* pControls
);
Parameters

pControls
Points to a CXTPControls object

Returns

TRUE if the controls are identical.

Group

CXTPControls Methods


CXTPControls::CreateOriginalControls Method

CXTPControls Methods, CXTPControls Class
CXTPControls::CreateOriginalControls Method

Creates original controls set.

void CreateOriginalControls();
Group

CXTPControls Methods


CXTPControls::DoPropExchange Method

CXTPControls Methods, CXTPControls Class
CXTPControls::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControls Methods


CXTPControls::Duplicate Method

CXTPControls Methods, CXTPControls Class
CXTPControls::Duplicate Method

Makes a copy of all controls.

CXTPControls* Duplicate(
    BOOL bRecursive = FALSE
);
Parameters

bRecursive
TRUE to copy recursively.

Returns

A pointer to a CXTPControls object.

Group

CXTPControls Methods


FindControl Method

CXTPControls Methods
FindControl Method
Overload List
Methods
Method | Description
CXTPControls::FindControl (XTPControlType, int, BOOL, BOOL) | Call this member to find the specified control.
CXTPControls::FindControl (int) | Call this member to find the specified control.
Group

CXTPControls Methods


CXTPControls::FindControl Method (int)

FindControl Method, CXTPControls Class
CXTPControls::FindControl Method (int)

Call this member to find the specified control.

CXTPControl* FindControl(
    int nId
) const;
CXTPControl* FindControl(
    XTPControlType type,
    int nId,
    BOOL bVisible,
    BOOL bRecursive
) const;
CXTPControl* FindControl(
    XTPControlType type,
    int nId,
    BOOL bVisible,
    BOOL bRecursive
) const;
Parameters

nId
The control's identifier.
type
The type of the control to find.
bVisible
TRUE if the control is visible.
bRecursive
TRUE to find in the nested command bars.

Returns

Pointer to the CXTPControl object if successful; otherwise returns NULL.

Group

FindControl Method


CXTPControls::GetAt Method

CXTPControls Methods, CXTPControls Class, Body Source
CXTPControls::GetAt Method

Call this member to return the control at the specified index.

CXTPControl* GetAt(
    int nIndex
) const;
Parameters

nIndex
An integer index.

Returns

The CXTPControl pointer currently at this index.

Body Source
CXTPControl* CXTPControls::GetAt(int nIndex) const {
    ASSERT(nIndex < m_arrControls.GetSize());
    return (nIndex >= 0 && nIndex < m_arrControls.GetSize()) ? m_arrControls.GetAt(nIndex) : NULL;
}
Group

CXTPControls Methods


CXTPControls::GetCommandBars Method

CXTPControls Methods, CXTPControls Class
CXTPControls::GetCommandBars Method

Retrieves the parent command bars object.

CXTPCommandBars* GetCommandBars() const;
Returns

A pointer to a CXTPCommandBars object

Group

CXTPControls Methods


CXTPControls::GetCount Method

CXTPControls Methods, CXTPControls Class, Body Source
CXTPControls::GetCount Method

Call this member to get the count of the controls

int GetCount() const;
Returns

The count of the controls.

Body Source
int CXTPControls::GetCount() const {
    return (int)m_arrControls.GetSize();
}
Group

CXTPControls Methods


CXTPControls::GetFirst Method

CXTPControls Methods, CXTPControls Class
CXTPControls::GetFirst Method

Call this member to retrieve the first control.

CXTPControl* GetFirst() const;
Returns

A pointer to a CXTPControl object

Group

CXTPControls Methods


GetNext Method

CXTPControls Methods
GetNext Method
Overload List
Methods
Method | Description
CXTPControls::GetNext (CXTPControl*&) | Finds the next control in the given direction.
CXTPControls::GetNext (long, int, BOOL, BOOL, BOOL) | Finds the next control in the given direction.
Group

CXTPControls Methods


CXTPControls::GetNext Method (CXTPControl*&)

GetNext Method, CXTPControls Class
CXTPControls::GetNext Method (CXTPControl*&)

Finds the next control in the given direction.

void GetNext(
    CXTPControl*& pControl
) const;
long GetNext(
    long nIndex,
    int nDirection = +1,
    BOOL bKeyboard = TRUE,
    BOOL bSkipTemporary = FALSE,
    BOOL bSkipCollapsed = TRUE
) const;
Parameters

pControl
Receives a pointer to the next control.
nIndex
Current control index.
nDirection
Direction to find.
bKeyboard
TRUE to skip controls with xtpFlagSkipFocus flag.
bSkipTemporary
TRUE to skip all controls with Temporary flag
bSkipCollapsed
TRUE to skip all controls with xtpHideExpand hide flag.

Returns

Index of the next control.

Group

GetNext Method


CXTPControls::GetOriginalControls Method

CXTPControls Methods, CXTPControls Class, Body Source
CXTPControls::GetOriginalControls Method

Retrieves original controls set.

CXTPOriginalControls* GetOriginalControls() const;
Returns

A pointer to a CXTPControls object

Body Source
CXTPOriginalControls* CXTPControls::GetOriginalControls() const {
    return m_pOriginalControls;
}
Group

CXTPControls Methods


CXTPControls::GetParent Method

CXTPControls Methods, CXTPControls Class, Body Source
CXTPControls::GetParent Method

Call this member to get the parent command bar.

CXTPCommandBar* GetParent() const;
Returns

The parent command bar object.

Body Source
CXTPCommandBar* CXTPControls::GetParent() const {
    return m_pParent;
}
Group

CXTPControls Methods


CXTPControls::GetVisibleCount Method

CXTPControls Methods, CXTPControls Class
CXTPControls::GetVisibleCount Method

Call this member to get the number of visible controls.

int GetVisibleCount(
    BOOL bIgnoreWrap = FALSE
) const;
Parameters

bIgnoreWrap
TRUE to ignore controls that are wrapped.

Returns

Number of visible controls.

Group

CXTPControls Methods


CXTPControls::HitTest Method

CXTPControls Methods, CXTPControls Class
CXTPControls::HitTest Method

This method determines where a point lies in a specified control.

CXTPControl* HitTest(
    CPoint point
) const;
Parameters

point
Specifies the point to be tested.

Returns

A pointer to a CXTPControl control that occupies the specified point or NULL if no control occupies the point.

Group

CXTPControls Methods


CXTPControls::InsertAt Method

CXTPControls Methods, CXTPControls Class, See Also
CXTPControls::InsertAt Method

Call this member to insert a new control.

CXTPControl* InsertAt(
    CXTPControl* pControl,
    int nBefore
);
Parameters

pControl
A pointer to the control to be added.
nBefore
Index of the control to be inserted.

Returns

A pointer to the added control.

See Also

Add

Group

CXTPControls Methods


CXTPControls::IsChanged Method

CXTPControls Methods, CXTPControls Class
CXTPControls::IsChanged Method

Returns the changed status flag of the control.

BOOL IsChanged() const;
Returns

TRUE if the internal control state was changed since last drawing, FALSE otherwise.

Group

CXTPControls Methods


CXTPControls::LoadMenu Method

CXTPControls Methods, CXTPControls Class
CXTPControls::LoadMenu Method

Call this member to convert menu items to command bar controls.

BOOL LoadMenu(
    CMenu* pMenu
);
Parameters

pMenu
Menu to be converted.

Returns

TRUE if the method was successful; otherwise FALSE.

Group

CXTPControls Methods


CXTPControls::MoveBefore Method

CXTPControls Methods, CXTPControls Class
CXTPControls::MoveBefore Method

Move the control to a specified position.

void MoveBefore(
    CXTPControl* pControl,
    int nBefore
);
Parameters

pControl
Points to a CXTPControl object
nBefore
Index to be moved.

Group

CXTPControls Methods


CXTPControls::OnControlAdded Method

CXTPControls Methods, CXTPControls Class
CXTPControls::OnControlAdded Method

This method is called when control is added to collection

virtual void OnControlAdded(
    CXTPControl* pControl
);
Parameters

pControl
control that added to collection

Group

CXTPControls Methods


CXTPControls::OnControlRemoved Method

CXTPControls Methods, CXTPControls Class
CXTPControls::OnControlRemoved Method

This method is called when control is removed from collection

virtual void OnControlRemoved(
    CXTPControl* pControl
);
Parameters

pControl
control that removed from collection

Group

CXTPControls Methods


CXTPControls::OnControlRemoving Method

CXTPControls Methods, CXTPControls Class
CXTPControls::OnControlRemoving Method

This method is called when control is about to be removed from collection

virtual BOOL OnControlRemoving(
    CXTPControl* pControl
);
Parameters

pControl
control that removed from collection

Returns

TRUE to cancel removing controls

Group

CXTPControls Methods


Remove Method

CXTPControls Methods
Remove Method
Overload List
Methods
Method | Description
CXTPControls::Remove (CXTPControl*) | Call this member to remove a control.
CXTPControls::Remove (int) | Call this member to remove a control.
Group

CXTPControls Methods


CXTPControls::Remove Method (CXTPControl*)

Remove Method, CXTPControls Class
CXTPControls::Remove Method (CXTPControl*)

Call this member to remove a control.

virtual void Remove(
    CXTPControl* pControl
);
void Remove(
    int nIndex
);
Parameters

pControl
Control to be removed.
nIndex
Index of the control to be removed.

Group

Remove Method


CXTPControls::RemoveAll Method

CXTPControls Methods, CXTPControls Class
CXTPControls::RemoveAll Method

Call this member to remove all controls.

void RemoveAll();
Group

CXTPControls Methods


CXTPControls::SetCommandBars Method

CXTPControls Methods, CXTPControls Class
CXTPControls::SetCommandBars Method

Call this member to attach the specified command bars object.

void SetCommandBars(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
Command bars object need to attach.

Remarks

You can call this member if you create plain toolbar and want to set CommandBars for it.

Group

CXTPControls Methods


SetControlType Method

CXTPControls Methods
SetControlType Method
Overload List
Methods
Method | Description
CXTPControls::SetControlType (CXTPControl*, XTPControlType) | Call this member to change the type of the control.
CXTPControls::SetControlType (int, XTPControlType) | Call this member to change the type of the control.
Group

CXTPControls Methods


CXTPControls::SetControlType Method (CXTPControl*, XTPControlType)

SetControlType Method, CXTPControls Class
CXTPControls::SetControlType Method (CXTPControl*, XTPControlType)

Call this member to change the type of the control.

CXTPControl* SetControlType(
    CXTPControl* pControl,
    XTPControlType type
);
CXTPControl* SetControlType(
    int nIndex,
    XTPControlType type
);
Parameters

pControl
Points to a CXTPControl object
type
Type needed to be changed.
nIndex
Index of the control

Returns

A pointer to a CXTPControl object

Group

SetControlType Method


CXTPControls::SetOriginalControls Method

CXTPControls Methods, CXTPControls Class
CXTPControls::SetOriginalControls Method

Call this method to assign original controls

void SetOriginalControls(
    CXTPOriginalControls* pControls
);
Parameters

pControls
A pointer to a CXTPControls object to assign

Group

CXTPControls Methods


CXTPControls::SetParent Method

CXTPControls Methods, CXTPControls Class
CXTPControls::SetParent Method

Attaches the parent command bar.

void SetParent(
    CXTPCommandBar* pParent
);
Parameters

pParent
Points to a CXTPCommandBar object

Group

CXTPControls Methods


CXTPControls Constructors

CXTPControls Class, Legend, Public Methods
CXTPControls Constructors
Class

CXTPControls Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControls | Protected constructor used by dynamic creation


CXTPControls::CXTPControls Constructor

CXTPControls Constructors, CXTPControls Class
CXTPControls::CXTPControls Constructor

Protected constructor used by dynamic creation

CXTPControls();
Group

CXTPControls Constructors


CXTPControls Destructors

CXTPControls Class, Legend, Public Methods
CXTPControls Destructors
Class

CXTPControls Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControls | Destroys a CXTPControls object, handles cleanup and deallocation


CXTPControls::~CXTPControls Destructor

CXTPControls Destructors, CXTPControls Class
CXTPControls::~CXTPControls Destructor

Destroys a CXTPControls object, handles cleanup and deallocation

virtual ~CXTPControls();
Group

CXTPControls Destructors


CXTPControlSelector Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlSelector Data Members, CXTPControlSelector Methods, CXTPControlSelector Constructors, CXTPControlSelector Constructors, CXTPControlSelector Data Members, CXTPControlSelector Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSelector Class

CXTPControlSelector is a CXTPControl derived class that represents a control selector.

Class Hierarchy

class CXTPControlSelector : public CXTPControl;
File

XTPControlExt.h

Remarks

A control selector is an x by y grid of controls of which can be selected by the user. This control is like the "Insert Table" and "Insert Column" controls seen in Microsoft Word.

When the control selector is created, m_szItemsCount holds the number items that will initially be shown. By clicking and dragging inside the control selector, up to m_szItemsMax items can be shown. For example, if m_szItemsCount = CSize(5, 4) and m_szItemsMax = CSize(12, 12), then the control selector will always display a 5x4 grid of items unless the mouse is clicked and dragged to expand the grid up to 12x12.

The size of the items is set by m_szItem, all items in the grid will be sized according to m_szItem.

The current number of active items (highlighted items) is stored in m_szItemsActive. OnLButtonUp will store the number of selected items in m_szResult.

When the number of selected (activehighlighted) items changes, XTP_SLN_SELCHANGE is send in a message to the parent commandbar. The message is sent while in the SetItemsActive function.

The Office 2003 GUI sample illustrates how to use this class.

Group

Classes

Legend
Data Member
Method
protected
virtual
CXTPControlSelector Constructors
CXTPControlSelector Constructors | Description
CXTPControlSelector | Constructs a CXTPControlSelector object.
CXTPControlSelector Data Members
CXTPControlSelector Data Members | Description
m_szItem | Size of the items.
m_szItemsActive | Number of items currently "active", this is current number of items that are highlighted as the mouse moves across the control selector.
m_szItemsCount | Number of items to draw in the control selector's view.
m_szItemsMax | Maximum number of items to draw in the control selector.
m_szItemsVisible | Number of items currently visible.
m_szResult | Number of items that were selected from the control selector.
CXTPControlSelector Methods
CXTPControlSelector Methods | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnDrawItem | Them member is called when a control item in the control selector is drawn.
OnLButtonUp | This member is called when the user releases the left mouse button.
OnMouseMove | This member is called when the mouse cursor moves.
OnSetSelected | This method is called when the control becomes selected.
SetItemsActive | This member is called to set the number of active items.


CXTPControlSelector Data Members

CXTPControlSelector Class, Legend, Public Data Members
CXTPControlSelector Data Members
Class

CXTPControlSelector Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_szItem | Size of the items.
m_szItemsActive | Number of items currently "active", this is current number of items that are highlighted as the mouse moves across the control selector.
m_szItemsCount | Number of items to draw in the control selector's view.
m_szItemsMax | Maximum number of items to draw in the control selector.
m_szItemsVisible | Number of items currently visible.
m_szResult | Number of items that were selected from the control selector.


CXTPControlSelector::m_szItem Data Member

CXTPControlSelector Data Members, CXTPControlSelector Class
CXTPControlSelector::m_szItem Data Member

Size of the items.

CSize m_szItem;
Group

CXTPControlSelector Data Members


CXTPControlSelector::m_szItemsActive Data Member

CXTPControlSelector Data Members, CXTPControlSelector Class
CXTPControlSelector::m_szItemsActive Data Member

Number of items currently "active", this is current number of items that are highlighted as the mouse moves across the control selector.

CSize m_szItemsActive;
Group

CXTPControlSelector Data Members


CXTPControlSelector::m_szItemsCount Data Member

CXTPControlSelector Data Members, CXTPControlSelector Class
CXTPControlSelector::m_szItemsCount Data Member

Number of items to draw in the control selector's view.

CSize m_szItemsCount;
Group

CXTPControlSelector Data Members


CXTPControlSelector::m_szItemsMax Data Member

CXTPControlSelector Data Members, CXTPControlSelector Class
CXTPControlSelector::m_szItemsMax Data Member

Maximum number of items to draw in the control selector.

CSize m_szItemsMax;
Group

CXTPControlSelector Data Members


CXTPControlSelector::m_szItemsVisible Data Member

CXTPControlSelector Data Members, CXTPControlSelector Class
CXTPControlSelector::m_szItemsVisible Data Member

Number of items currently visible.

CSize m_szItemsVisible;
Group

CXTPControlSelector Data Members


CXTPControlSelector::m_szResult Data Member

CXTPControlSelector Data Members, CXTPControlSelector Class
CXTPControlSelector::m_szResult Data Member

Number of items that were selected from the control selector.

CSize m_szResult;
Group

CXTPControlSelector Data Members


CXTPControlSelector Methods

CXTPControlSelector Class, Legend, Protected Methods
CXTPControlSelector Methods
Class

CXTPControlSelector Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
OnDrawItem | Them member is called when a control item in the control selector is drawn.
OnLButtonUp | This member is called when the user releases the left mouse button.
OnMouseMove | This member is called when the mouse cursor moves.
OnSetSelected | This method is called when the control becomes selected.
SetItemsActive | This member is called to set the number of active items.


CXTPControlSelector::Copy Method

CXTPControlSelector Methods, CXTPControlSelector Class
CXTPControlSelector::Copy Method

This method is called to copy the control.

void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlSelector Methods


CXTPControlSelector::DoPropExchange Method

CXTPControlSelector Methods, CXTPControlSelector Class
CXTPControlSelector::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlSelector Methods


CXTPControlSelector::Draw Method

CXTPControlSelector Methods, CXTPControlSelector Class
CXTPControlSelector::Draw Method

This method is called to draw the control.

void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlSelector Methods


CXTPControlSelector::GetSize Method

CXTPControlSelector Methods, CXTPControlSelector Class
CXTPControlSelector::GetSize Method

This method is called to determine the size of the control.

CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlSelector Methods


CXTPControlSelector::OnCalcDynamicSize Method

CXTPControlSelector Methods, CXTPControlSelector Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSelector::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControl, CXTPControlListBox

Group

CXTPControlSelector Methods


CXTPControlSelector::OnDrawItem Method

CXTPControlSelector Methods, CXTPControlSelector Class
CXTPControlSelector::OnDrawItem Method

Them member is called when a control item in the control selector is drawn.

virtual void OnDrawItem(
    CDC* pDC,
    CRect rcItem,
    COLORREF clrText
);
Parameters

pDC
Pointer to a valid device context.
rcItem
Bounding rectangle of item being drawn.
clrText
Color to use when drawing.

Remarks

Override this member to draw your own custom control. In the Office 2003 GUI sample, this is used to draw the column lines in the column selector control.

Group

CXTPControlSelector Methods


CXTPControlSelector::OnLButtonUp Method

CXTPControlSelector Methods, CXTPControlSelector Class
CXTPControlSelector::OnLButtonUp Method

This member is called when the user releases the left mouse button.

void OnLButtonUp(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlSelector Methods


CXTPControlSelector::OnMouseMove Method

CXTPControlSelector Methods, CXTPControlSelector Class
CXTPControlSelector::OnMouseMove Method

This member is called when the mouse cursor moves.

void OnMouseMove(
    CPoint point
);
Parameters

point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPControlSelector Methods


CXTPControlSelector::OnSetSelected Method

CXTPControlSelector Methods, CXTPControlSelector Class
CXTPControlSelector::OnSetSelected Method

This method is called when the control becomes selected.

BOOL OnSetSelected(
    int bSelected
);
Parameters

bSelected
TRUE if the control becomes selected.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPControlSelector Methods


CXTPControlSelector::SetItemsActive Method

CXTPControlSelector Methods, CXTPControlSelector Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSelector::SetItemsActive Method

This member is called to set the number of active items.

void SetItemsActive(
    CSize szActive,
    BOOL bNotify = FALSE
);
Parameters

szActive
Number of active items (on screen). If m_szItemsActive is not equal to szActive, then SetItemsActive will set m_szItemsActive = szActive.
bNotify
TRUE to send XTP_SLN_SELCHANGE message to parent commandbar even if m_szItemsActive = szActive. This is necessary when the number of items has changed and m_szItemsActive = szActive, which occurs when the mouse is clicked and dragged to select items more items than are currently visible.

Remarks

Active items are the items that are currently highlighted in the control selector.

See Also

XTP_SLN_SELCHANGE

Group

CXTPControlSelector Methods


CXTPControlSelector Constructors

CXTPControlSelector Class, Legend, Public Methods
CXTPControlSelector Constructors
Class

CXTPControlSelector Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlSelector | Constructs a CXTPControlSelector object.


CXTPControlSelector::CXTPControlSelector Constructor

CXTPControlSelector Constructors, CXTPControlSelector Class
CXTPControlSelector::CXTPControlSelector Constructor

Constructs a CXTPControlSelector object.

CXTPControlSelector();
Group

CXTPControlSelector Constructors


CXTPControlSizeComboBox Class

XTPControlComboBoxExt.h, Classes, Legend, Members, Topics, CXTPControlSizeComboBox Methods, CXTPControlSizeComboBox Constructors, CXTPControlSizeComboBox Destructors, CXTPControlSizeComboBox Constructors, CXTPControlSizeComboBox Destructors, CXTPControlSizeComboBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSizeComboBox Class

CXTPControlSizeComboBox is a CXTPControlComboBox derived class. It represents the size picker.

Class Hierarchy

class CXTPControlSizeComboBox : public CXTPControlComboBox;
File

XTPControlComboBoxExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlSizeComboBox Constructors
CXTPControlSizeComboBox Constructors | Description
CXTPControlSizeComboBox | Constructs a CXTPControlSizeComboBox object
CXTPControlSizeComboBox Destructors
CXTPControlSizeComboBox Destructors | Description
~CXTPControlSizeComboBox | Destroys a CXTPControlSizeComboBox object, handles cleanup and deallocation
CXTPControlSizeComboBox Methods
CXTPControlSizeComboBox Methods | Description
GetTwipSize |
OnExecute | This method is called when the control is executed.
OnSetPopup | This method is called to popup the control.
SetTwipSize | Call this method to set the current size.
TwipsToPointString | This method is called to convert twips to string


CXTPControlSizeComboBox Methods

CXTPControlSizeComboBox Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSizeComboBox Methods
Class

CXTPControlSizeComboBox Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetTwipSize |
OnExecute | This method is called when the control is executed.
OnSetPopup | This method is called to popup the control.
Public Methods
Public Methods
Public Method | Description
SetTwipSize | Call this method to set the current size.
TwipsToPointString | This method is called to convert twips to string


GetTwipSize Method

CXTPControlSizeComboBox Methods
GetTwipSize Method
Overload List
Methods
Method | Description
CXTPControlSizeComboBox::GetTwipSize () | Call this method to retrieve the current user selected size.
CXTPControlSizeComboBox::GetTwipSize (LPCTSTR) | This method is called to convert string to twip size
Group

CXTPControlSizeComboBox Methods


CXTPControlSizeComboBox::GetTwipSize Method ()

GetTwipSize Method, CXTPControlSizeComboBox Class
CXTPControlSizeComboBox::GetTwipSize Method ()

Call this method to retrieve the current user selected size.

int GetTwipSize() const;
Returns

The current size.

Group

GetTwipSize Method


CXTPControlSizeComboBox::GetTwipSize Method (LPCTSTR)

GetTwipSize Method, CXTPControlSizeComboBox Class
CXTPControlSizeComboBox::GetTwipSize Method (LPCTSTR)

This method is called to convert string to twip size

static int GetTwipSize(
    LPCTSTR lpszText
);
Parameters

lpszText
String contains twips number

Group

GetTwipSize Method


CXTPControlSizeComboBox::OnExecute Method

CXTPControlSizeComboBox Methods, CXTPControlSizeComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSizeComboBox::OnExecute Method

This method is called when the control is executed.

virtual void OnExecute();
Group

CXTPControlSizeComboBox Methods


CXTPControlSizeComboBox::OnSetPopup Method

CXTPControlSizeComboBox Methods, CXTPControlSizeComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSizeComboBox::OnSetPopup Method

This method is called to popup the control.

virtual BOOL OnSetPopup(
    BOOL bPopup
);
Parameters

bPopup
TRUE to set popup.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPControlSizeComboBox Methods


CXTPControlSizeComboBox::SetTwipSize Method

CXTPControlSizeComboBox Methods, CXTPControlSizeComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSizeComboBox::SetTwipSize Method

Call this method to set the current size.

void SetTwipSize(
    int nTwips
);
Parameters

nTwips
Size, in twips, to be set

Group

CXTPControlSizeComboBox Methods


CXTPControlSizeComboBox::TwipsToPointString Method

CXTPControlSizeComboBox Methods, CXTPControlSizeComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSizeComboBox::TwipsToPointString Method

This method is called to convert twips to string

static CString TwipsToPointString(
    int nTwips
);
Parameters

nTwips
twips number to convert

Group

CXTPControlSizeComboBox Methods


CXTPControlSizeComboBox Constructors

CXTPControlSizeComboBox Class, Legend, Public Methods
CXTPControlSizeComboBox Constructors
Class

CXTPControlSizeComboBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlSizeComboBox | Constructs a CXTPControlSizeComboBox object


CXTPControlSizeComboBox::CXTPControlSizeComboBox Constructor

CXTPControlSizeComboBox Constructors, CXTPControlSizeComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSizeComboBox::CXTPControlSizeComboBox Constructor

Constructs a CXTPControlSizeComboBox object

CXTPControlSizeComboBox();
Group

CXTPControlSizeComboBox Constructors


CXTPControlSizeComboBox Destructors

CXTPControlSizeComboBox Class, Legend, Public Methods
CXTPControlSizeComboBox Destructors
Class

CXTPControlSizeComboBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPControlSizeComboBox | Destroys a CXTPControlSizeComboBox object, handles cleanup and deallocation


CXTPControlSizeComboBox::~CXTPControlSizeComboBox Destructor

CXTPControlSizeComboBox Destructors, CXTPControlSizeComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlSizeComboBox::~CXTPControlSizeComboBox Destructor

Destroys a CXTPControlSizeComboBox object, handles cleanup and deallocation

virtual ~CXTPControlSizeComboBox();
Group

CXTPControlSizeComboBox Destructors


CXTPControlStatic Class

XTPControlListBox.h, Classes, Legend, Members, Topics, CXTPControlStatic Methods, CXTPControlStatic Constructors, CXTPControlStatic Constructors, CXTPControlStatic Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlStatic Class

CXTPControlStatic is a CXTPControl derived class. It represents a static text control.

Class Hierarchy

class CXTPControlStatic : public CXTPControl;
File

XTPControlListBox.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlStatic Constructors
CXTPControlStatic Constructors | Description
CXTPControlStatic | Constructs a CXTPControlStatic object
CXTPControlStatic Methods
CXTPControlStatic Methods | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
SetWidth | Call this member to set the width of the control


CXTPControlStatic Methods

CXTPControlStatic Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlStatic Methods
Class

CXTPControlStatic Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method is called to copy the control.
DoPropExchange | Reads or writes this object from or to an archive.
Draw | This method is called to draw the control.
GetSize | This method is called to determine the size of the control.
Public Methods
Public Methods
Public Method | Description
SetWidth | Call this member to set the width of the control


CXTPControlStatic::Copy Method

CXTPControlStatic Methods, CXTPControlStatic Class
CXTPControlStatic::Copy Method

This method is called to copy the control.

virtual void Copy(
    CXTPControl* pControl,
    BOOL bRecursive = FALSE
);
Parameters

pControl
Points to a source CXTPControl object
bRecursive
TRUE to copy recursively.

Group

CXTPControlStatic Methods


CXTPControlStatic::DoPropExchange Method

CXTPControlStatic Methods, CXTPControlStatic Class
CXTPControlStatic::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPControlStatic Methods


CXTPControlStatic::Draw Method

CXTPControlStatic Methods, CXTPControlStatic Class
CXTPControlStatic::Draw Method

This method is called to draw the control.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPControlStatic Methods


CXTPControlStatic::GetSize Method

CXTPControlStatic Methods, CXTPControlStatic Class
CXTPControlStatic::GetSize Method

This method is called to determine the size of the control.

virtual CSize GetSize(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Returns

Size of the control.

Group

CXTPControlStatic Methods


CXTPControlStatic::SetWidth Method

CXTPControlStatic Methods, CXTPControlStatic Class
CXTPControlStatic::SetWidth Method

Call this member to set the width of the control

void SetWidth(
    int nWidth
);
Parameters

nWidth
The width of the control

Group

CXTPControlStatic Methods


CXTPControlStatic Constructors

CXTPControlStatic Class, Legend, Public Methods
CXTPControlStatic Constructors
Class

CXTPControlStatic Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlStatic | Constructs a CXTPControlStatic object


CXTPControlStatic::CXTPControlStatic Constructor

CXTPControlStatic Constructors, CXTPControlStatic Class
CXTPControlStatic::CXTPControlStatic Constructor

Constructs a CXTPControlStatic object

CXTPControlStatic();
Group

CXTPControlStatic Constructors


CXTPControlToolbars Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlToolbars Classes, CXTPControlToolbars Methods, CXTPControlToolbars Constructors, CXTPControlToolbars Classes, CXTPControlToolbars Constructors, CXTPControlToolbars Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlToolbars Class

CXTPControlToolbars is a CXTPControlButton derived class. It is used internally to create toolbars list items.

Class Hierarchy

class CXTPControlToolbars : public CXTPControlButton;
File

XTPControlExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlToolbars Classes
CXTPControlToolbars Classes | Description
CXTPControlToolbar | Represents single toolbar item.
CXTPControlToolbars Constructors
CXTPControlToolbars Constructors | Description
CXTPControlToolbars | Constructs a CXTPControlToolbars object
CXTPControlToolbars Methods
CXTPControlToolbars Methods | Description
CreateToolbarMenu | Creates a list of toolbars for the CommandBars Context Menu.
IsCustomizeDragOverAvail | Call this member to check if the user can drop the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.


CXTPControlToolbars Classes

Classes, CXTPControlToolbars Class
CXTPControlToolbars Classes
Classes
Class | Description
CXTPControlToolbar | Represents single toolbar item.
Class

CXTPControlToolbars Class


CXTPControlToolbars::CXTPControlToolbar Class

XTPControlExt.h, CXTPControlToolbars Classes
CXTPControlToolbars::CXTPControlToolbar Class

Represents single toolbar item.

Class Hierarchy

class CXTPControlToolbar : public CXTPControlButton;
File

XTPControlExt.h

Group

CXTPControlToolbars Classes


CXTPControlToolbars Methods

CXTPControlToolbars Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlToolbars Methods
Class

CXTPControlToolbars Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
IsCustomizeDragOverAvail | Call this member to check if the user can drop the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
Public Methods
Public Methods
Public Method | Description
CreateToolbarMenu | Creates a list of toolbars for the CommandBars Context Menu.


CXTPControlToolbars::CreateToolbarMenu Method

CXTPControlToolbars Methods, CXTPControlToolbars Class
CXTPControlToolbars::CreateToolbarMenu Method

Creates a list of toolbars for the CommandBars Context Menu.

static void CreateToolbarMenu(
    CXTPCommandBar* pPopupBar,
    int nInsert,
    int nID,
    BOOL bAddCustomize,
    BOOL bBeginGroup = FALSE
);
Parameters

pPopupBar
Points to a CXTPCommandBar object
nInsert
Position to start inserting items in the context menu.
nID
ID to assign the menu items in the context menu
bAddCustomize
TRUE to add the "Customize..." option at the bottom of the menu that allows the Toolbar Customization dialog to be opened.
bBeginGroup
TRUE to start new group.

Remarks

This is the context menu that appears when a toolbar is right-clicked, it lists all the toolbars and allows them to be hiddendisplayed.

Group

CXTPControlToolbars Methods


CXTPControlToolbars::IsCustomizeDragOverAvail Method

CXTPControlToolbars Methods, CXTPControlToolbars Class
CXTPControlToolbars::IsCustomizeDragOverAvail Method

Call this member to check if the user can drop the control.

virtual BOOL IsCustomizeDragOverAvail(
    CXTPCommandBar* pCommandBar,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pCommandBar
Points to a CXTPCommandBar object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Returns

TRUE if successful, otherwise returns FALSE

Group

CXTPControlToolbars Methods


CXTPControlToolbars::OnCalcDynamicSize Method

CXTPControlToolbars Methods, CXTPControlToolbars Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlToolbars::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControl, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Group

CXTPControlToolbars Methods


CXTPControlToolbars Constructors

CXTPControlToolbars Class, Legend, Public Methods
CXTPControlToolbars Constructors
Class

CXTPControlToolbars Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlToolbars | Constructs a CXTPControlToolbars object


CXTPControlToolbars::CXTPControlToolbars Constructor

CXTPControlToolbars Constructors, CXTPControlToolbars Class
CXTPControlToolbars::CXTPControlToolbars Constructor

Constructs a CXTPControlToolbars object

CXTPControlToolbars();
Group

CXTPControlToolbars Constructors


CXTPControlWindowList Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlWindowList Data Members, CXTPControlWindowList Methods, CXTPControlWindowList Data Members, CXTPControlWindowList Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWindowList Class

CXTPControlWindowList is a CXTPControlButton derived class. It is used internally to create window list items.

Class Hierarchy

class CXTPControlWindowList : public CXTPControlButton;
File

XTPControlExt.h

Group

Classes

Legend
Data Member
Method
protected
virtual
CXTPControlWindowList Data Members
CXTPControlWindowList Data Members | Description
m_bShowRadioButtons | TRUE to show Radio buttons.
m_nFistMDIChild | First MDI child id.
m_nItemCount | Maximum allowed items.
CXTPControlWindowList Methods
CXTPControlWindowList Methods | Description
ConstructCaption | Adds the number and an ampersand "&" before the caption of in item that appears in the Windows List.
IsCustomizeDragOverAvail | Call this member to check if the user can drop the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.


CXTPControlWindowList Data Members

CXTPControlWindowList Class, Legend, Public Data Members
CXTPControlWindowList Data Members
Class

CXTPControlWindowList Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bShowRadioButtons | TRUE to show Radio buttons.
m_nFistMDIChild | First MDI child id.
m_nItemCount | Maximum allowed items.


CXTPControlWindowList::m_bShowRadioButtons Data Member

CXTPControlWindowList Data Members, CXTPControlWindowList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWindowList::m_bShowRadioButtons Data Member

TRUE to show Radio buttons.

BOOL m_bShowRadioButtons;
Group

CXTPControlWindowList Data Members


CXTPControlWindowList::m_nFistMDIChild Data Member

CXTPControlWindowList Data Members, CXTPControlWindowList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWindowList::m_nFistMDIChild Data Member

First MDI child id.

UINT m_nFistMDIChild;
Group

CXTPControlWindowList Data Members


CXTPControlWindowList::m_nItemCount Data Member

CXTPControlWindowList Data Members, CXTPControlWindowList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWindowList::m_nItemCount Data Member

Maximum allowed items.

UINT m_nItemCount;
Group

CXTPControlWindowList Data Members


CXTPControlWindowList Methods

CXTPControlWindowList Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWindowList Methods
Class

CXTPControlWindowList Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
IsCustomizeDragOverAvail | Call this member to check if the user can drop the control.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
Public Methods
Public Methods
Public Method | Description
ConstructCaption | Adds the number and an ampersand "&" before the caption of in item that appears in the Windows List.


CXTPControlWindowList::ConstructCaption Method

CXTPControlWindowList Methods, CXTPControlWindowList Class
CXTPControlWindowList::ConstructCaption Method

Adds the number and an ampersand "&" before the caption of in item that appears in the Windows List.

static CString ConstructCaption(
    const CString& lpszTitle,
    int nIndex
);
Parameters

lpszTitle
Text string to display in Windows List, this test will be appended after the number.
nIndex
Position within the Windows list that the Item should appear.

Returns

Returns the text string containing the entire string that will appear in the Windows List.

Group

CXTPControlWindowList Methods


CXTPControlWindowList::IsCustomizeDragOverAvail Method

CXTPControlWindowList Methods, CXTPControlWindowList Class
CXTPControlWindowList::IsCustomizeDragOverAvail Method

Call this member to check if the user can drop the control.

virtual BOOL IsCustomizeDragOverAvail(
    CXTPCommandBar* pCommandBar,
    CPoint point,
    DROPEFFECT& dropEffect
);
Parameters

pCommandBar
Points to a CXTPCommandBar object
point
Mouse position.
dropEffect
DROPEFFECT enumerator.

Returns

TRUE if successful, otherwise returns FALSE

Group

CXTPControlWindowList Methods


CXTPControlWindowList::OnCalcDynamicSize Method

CXTPControlWindowList Methods, CXTPControlWindowList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWindowList::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControl, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Group

CXTPControlWindowList Methods


CXTPControlWorkspaceActions Class

XTPControlExt.h, Classes, Legend, Members, Topics, CXTPControlWorkspaceActions Methods, CXTPControlWorkspaceActions Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWorkspaceActions Class

CXTPControlWorkspaceActions is a CXTPControlButton derived class. It used internally to add workspace actions to window menu.

Class Hierarchy

class CXTPControlWorkspaceActions : public CXTPControlButton;
File

XTPControlExt.h

Group

Classes

Legend
Method
protected
virtual
CXTPControlWorkspaceActions Methods
CXTPControlWorkspaceActions Methods | Description
AddCommand | Adds action command to parent controls.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.


CXTPControlWorkspaceActions Methods

CXTPControlWorkspaceActions Class, Legend, Protected Methods
CXTPControlWorkspaceActions Methods
Class

CXTPControlWorkspaceActions Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AddCommand | Adds action command to parent controls.
OnCalcDynamicSize | This method is called before recalculating the parent command bar size to calculate the dimensions of the control.


CXTPControlWorkspaceActions::AddCommand Method

CXTPControlWorkspaceActions Methods, CXTPControlWorkspaceActions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWorkspaceActions::AddCommand Method

Adds action command to parent controls.

void AddCommand(
    CXTPTabClientWnd* pClient,
    UINT nID,
    int& nIndex
);
Parameters

pClient
Pointer to MDI tabbed client
nID
Specifies the object's child-window ID.
nIndex
Index to add.

Group

CXTPControlWorkspaceActions Methods


CXTPControlWorkspaceActions::OnCalcDynamicSize Method

CXTPControlWorkspaceActions Methods, CXTPControlWorkspaceActions Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPControlWorkspaceActions::OnCalcDynamicSize Method

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

virtual void OnCalcDynamicSize(
    DWORD dwMode
);
Parameters

dwMode
Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

Remarks

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

  • LM_STRETCH Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_HORZ Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation.
  • LM_MRUWIDTH Most Recently Used Dynamic Width. Uses the remembered most recently used width.
  • LM_HORZDOCK Horizontal Docked Dimensions. Returns the dynamic size with the largest width.
  • LM_VERTDOCK Vertical Docked Dimensions. Returns the dynamic size with the largest height.
  • LM_COMMIT Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See Also

CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControl, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Group

CXTPControlWorkspaceActions Methods


CXTPCustomizeCommandsListBox Class

XTPCustomizeCommandsPage.h, Classes, Legend, Members, Topics, CXTPCustomizeCommandsListBox Data Members, CXTPCustomizeCommandsListBox Constructors, CXTPCustomizeCommandsListBox Constructors, CXTPCustomizeCommandsListBox Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsListBox Class

List of the commands

Class Hierarchy

class CXTPCustomizeCommandsListBox : public CListBox;
File

XTPCustomizeCommandsPage.h

Group

Classes

Legend
Data Member
Constructor
CXTPCustomizeCommandsListBox Constructors
CXTPCustomizeCommandsListBox Constructors | Description
CXTPCustomizeCommandsListBox | Constructs a CXTPCustomizeCommandsListBox object
CXTPCustomizeCommandsListBox Data Members
CXTPCustomizeCommandsListBox Data Members | Description
m_bDragable | TRUE if user can drag controls from list
m_pCommandBars | Parent CommandBars object


CXTPCustomizeCommandsListBox Data Members

CXTPCustomizeCommandsListBox Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsListBox Data Members
Class

CXTPCustomizeCommandsListBox Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bDragable | TRUE if user can drag controls from list
m_pCommandBars | Parent CommandBars object


CXTPCustomizeCommandsListBox::m_bDragable Data Member

CXTPCustomizeCommandsListBox Data Members, CXTPCustomizeCommandsListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsListBox::m_bDragable Data Member

TRUE if user can drag controls from list

BOOL m_bDragable;
Group

CXTPCustomizeCommandsListBox Data Members


CXTPCustomizeCommandsListBox::m_pCommandBars Data Member

CXTPCustomizeCommandsListBox Data Members, CXTPCustomizeCommandsListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsListBox::m_pCommandBars Data Member

Parent CommandBars object

CXTPCommandBars* m_pCommandBars;
Group

CXTPCustomizeCommandsListBox Data Members


CXTPCustomizeCommandsListBox Constructors

CXTPCustomizeCommandsListBox Class, Legend, Public Methods
CXTPCustomizeCommandsListBox Constructors
Class

CXTPCustomizeCommandsListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeCommandsListBox | Constructs a CXTPCustomizeCommandsListBox object


CXTPCustomizeCommandsListBox::CXTPCustomizeCommandsListBox Constructor

CXTPCustomizeCommandsListBox Constructors, CXTPCustomizeCommandsListBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsListBox::CXTPCustomizeCommandsListBox Constructor

Constructs a CXTPCustomizeCommandsListBox object

CXTPCustomizeCommandsListBox();
Body Source
CXTPCustomizeCommandsListBox()
{
    m_bDragable = FALSE;
    m_pCommandBars = NULL;
}
Group

CXTPCustomizeCommandsListBox Constructors


CXTPCustomizeCommandsPage Class

XTPCustomizeCommandsPage.h, Classes, Legend, Members, Topics, CXTPCustomizeCommandsPage Data Members, CXTPCustomizeCommandsPage Methods, CXTPCustomizeCommandsPage Constructors, CXTPCustomizeCommandsPage Destructors, CXTPCustomizeCommandsPage Constructors, CXTPCustomizeCommandsPage Data Members, CXTPCustomizeCommandsPage Destructors, CXTPCustomizeCommandsPage Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage Class

CXTPCustomizeCommandsPage is a CPropertyPage derived class. It represents the Commands page of the Customize dialog.

Class Hierarchy

class CXTPCustomizeCommandsPage : public CPropertyPage;
File

XTPCustomizeCommandsPage.h

Group

Classes

Legend
Data Member
protected
Method
CXTPCustomizeCommandsPage Constructors
CXTPCustomizeCommandsPage Constructors | Description
CXTPCustomizeCommandsPage | Constructs a CXTPCustomizeCommandsPage object
CXTPCustomizeCommandsPage Data Members
CXTPCustomizeCommandsPage Data Members | Description
m_arrCategories | Array of categories.
m_lstCategories | List box of categories
m_lstCommands | List box of commands
m_pSheet | Parent Customize dialog
CXTPCustomizeCommandsPage Destructors
CXTPCustomizeCommandsPage Destructors | Description
~CXTPCustomizeCommandsPage | Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.
CXTPCustomizeCommandsPage Methods
CXTPCustomizeCommandsPage Methods | Description
AddCategories |
AddCategory | Adds a new category from a CMenu object.
AddToolbarCategory | Adds a new category from a toolbar resource.
GetControls | Retrieves the control list of the given category.
InsertAllCommandsCategory | Adds "All Commands" category and adds all controls already created in other categories here.
InsertBuiltInMenus | Adds built-in menus category.
InsertCategory | This method adds a new empty category in the given index.
InsertNewMenuCategory | Adds single "New menu" category.


CXTPCustomizeCommandsPage Data Members

CXTPCustomizeCommandsPage Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage Data Members
Class

CXTPCustomizeCommandsPage Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrCategories | Array of categories.
m_lstCategories | List box of categories
m_lstCommands | List box of commands
m_pSheet | Parent Customize dialog


CXTPCustomizeCommandsPage::m_arrCategories Data Member

CXTPCustomizeCommandsPage Data Members, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::m_arrCategories Data Member

Array of categories.

CXTPCommandBarsCategoryArray m_arrCategories;
Group

CXTPCustomizeCommandsPage Data Members


CXTPCustomizeCommandsPage::m_lstCategories Data Member

CXTPCustomizeCommandsPage Data Members, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::m_lstCategories Data Member

List box of categories

CListBox m_lstCategories;
Group

CXTPCustomizeCommandsPage Data Members


CXTPCustomizeCommandsPage::m_lstCommands Data Member

CXTPCustomizeCommandsPage Data Members, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::m_lstCommands Data Member

List box of commands

CXTPCustomizeCommandsListBox m_lstCommands;
Group

CXTPCustomizeCommandsPage Data Members


CXTPCustomizeCommandsPage::m_pSheet Data Member

CXTPCustomizeCommandsPage Data Members, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::m_pSheet Data Member

Parent Customize dialog

CXTPCustomizeSheet* m_pSheet;
Group

CXTPCustomizeCommandsPage Data Members


CXTPCustomizeCommandsPage Methods

CXTPCustomizeCommandsPage Class, Legend, Public Methods
CXTPCustomizeCommandsPage Methods
Class

CXTPCustomizeCommandsPage Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddCategories |
AddCategory | Adds a new category from a CMenu object.
AddToolbarCategory | Adds a new category from a toolbar resource.
GetControls | Retrieves the control list of the given category.
InsertAllCommandsCategory | Adds "All Commands" category and adds all controls already created in other categories here.
InsertBuiltInMenus | Adds built-in menus category.
InsertCategory | This method adds a new empty category in the given index.
InsertNewMenuCategory | Adds single "New menu" category.


AddCategories Method

CXTPCustomizeCommandsPage Methods
AddCategories Method
Overload List
Methods
Method | Description
CXTPCustomizeCommandsPage::AddCategories (CXTPControls*) | Adds categories branch from Controls.
CXTPCustomizeCommandsPage::AddCategories (UINT, BOOL) | Adds categories branch from menu resource.
Group

CXTPCustomizeCommandsPage Methods


CXTPCustomizeCommandsPage::AddCategories Method (CXTPControls*)

AddCategories Method, CXTPCustomizeCommandsPage Class
CXTPCustomizeCommandsPage::AddCategories Method (CXTPControls*)

Adds categories branch from Controls.

BOOL AddCategories(
    CXTPControls* pControls
);
Parameters

pControls
Points to a CXTPControls object

Returns

TRUE if successful; otherwise returns FALSE

Group

AddCategories Method


CXTPCustomizeCommandsPage::AddCategories Method (UINT, BOOL)

AddCategories Method, CXTPCustomizeCommandsPage Class
CXTPCustomizeCommandsPage::AddCategories Method (UINT, BOOL)

Adds categories branch from menu resource.

BOOL AddCategories(
    UINT nIDResource,
    BOOL bListSubItems = FALSE
);
Parameters

nIDResource
Menu resource from where categories will be built.
bListSubItems
TRUE to add sub menus to categories.

Returns

TRUE if successful; otherwise returns FALSE

Group

AddCategories Method


CXTPCustomizeCommandsPage::AddCategory Method

CXTPCustomizeCommandsPage Methods, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::AddCategory Method

Adds a new category from a CMenu object.

BOOL AddCategory(
    LPCTSTR strCategory,
    CMenu* pMenu,
    BOOL bListSubItems = FALSE
);
Parameters

strCategory
Category to be added.
pMenu
Points to a CMenu object
bListSubItems
TRUE to add sub menus to the category.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPCustomizeCommandsPage Methods


CXTPCustomizeCommandsPage::AddToolbarCategory Method

CXTPCustomizeCommandsPage Methods, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::AddToolbarCategory Method

Adds a new category from a toolbar resource.

BOOL AddToolbarCategory(
    LPCTSTR strCategory,
    UINT nIDResource
);
Parameters

strCategory
Category to be added.
nIDResource
Toolbar resource identifier.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPCustomizeCommandsPage Methods


CXTPCustomizeCommandsPage::GetControls Method

CXTPCustomizeCommandsPage Methods, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::GetControls Method

Retrieves the control list of the given category.

CXTPControls* GetControls(
    LPCTSTR strCategory
);
Parameters

strCategory
Category to retrieve.

Returns

A pointer to a CXTPControls object.

Group

CXTPCustomizeCommandsPage Methods


CXTPCustomizeCommandsPage::InsertAllCommandsCategory Method

CXTPCustomizeCommandsPage Methods, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::InsertAllCommandsCategory Method

Adds "All Commands" category and adds all controls already created in other categories here.

void InsertAllCommandsCategory(
    UINT nIDResource = XTP_IDS_ALLCOMMANDS,
    int nIndex = -1
);
Parameters

nIDResource
"All commands" category string resource.
nIndex
Index to insert

Group

CXTPCustomizeCommandsPage Methods


CXTPCustomizeCommandsPage::InsertBuiltInMenus Method

CXTPCustomizeCommandsPage Methods, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::InsertBuiltInMenus Method

Adds built-in menus category.

BOOL InsertBuiltInMenus(
    UINT nIDResourceMenu,
    UINT nIDResourceCategory = XTP_IDS_BUILTINMENUS,
    int nIndex = -1
);
Parameters

nIDResourceMenu
Menu resource identifier.
nIDResourceCategory
"Built-in" string identifier.
nIndex
Index to insert.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPCustomizeCommandsPage Methods


CXTPCustomizeCommandsPage::InsertCategory Method

CXTPCustomizeCommandsPage Methods, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::InsertCategory Method

This method adds a new empty category in the given index.

CXTPControls* InsertCategory(
    LPCTSTR strCategory,
    int nIndex = -1
);
Parameters

strCategory
Category to be added.
nIndex
Index to insert.

Returns

A pointer to a CXTPControls object

Group

CXTPCustomizeCommandsPage Methods


CXTPCustomizeCommandsPage::InsertNewMenuCategory Method

CXTPCustomizeCommandsPage Methods, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::InsertNewMenuCategory Method

Adds single "New menu" category.

void InsertNewMenuCategory(
    UINT nIDResource = XTP_IDS_NEWMENU,
    int nIndex = -1
);
Parameters

nIDResource
"New Menu" category string resource.
nIndex
Index to insert

Group

CXTPCustomizeCommandsPage Methods


CXTPCustomizeCommandsPage Constructors

CXTPCustomizeCommandsPage Class, Legend, Public Methods
CXTPCustomizeCommandsPage Constructors
Class

CXTPCustomizeCommandsPage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeCommandsPage | Constructs a CXTPCustomizeCommandsPage object


CXTPCustomizeCommandsPage::CXTPCustomizeCommandsPage Constructor

CXTPCustomizeCommandsPage Constructors, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::CXTPCustomizeCommandsPage Constructor

Constructs a CXTPCustomizeCommandsPage object

CXTPCustomizeCommandsPage(
    CXTPCustomizeSheet* pSheet = NULL
);
Parameters

pSheet
Points to a CXTPCustomizeSheet object

Group

CXTPCustomizeCommandsPage Constructors


CXTPCustomizeCommandsPage Destructors

CXTPCustomizeCommandsPage Class, Legend, Public Methods
CXTPCustomizeCommandsPage Destructors
Class

CXTPCustomizeCommandsPage Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCustomizeCommandsPage | Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.


CXTPCustomizeCommandsPage::~CXTPCustomizeCommandsPage Destructor

CXTPCustomizeCommandsPage Destructors, CXTPCustomizeCommandsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeCommandsPage::~CXTPCustomizeCommandsPage Destructor

Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.

~CXTPCustomizeCommandsPage();
Group

CXTPCustomizeCommandsPage Destructors


CXTPCustomizeKeyboardPage Class

XTPCustomizeKeyboardPage.h, Classes, Legend, Members, Topics, CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Methods, CXTPCustomizeKeyboardPage Constructors, CXTPCustomizeKeyboardPage Destructors, CXTPCustomizeKeyboardPage Constructors, CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Destructors, CXTPCustomizeKeyboardPage Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage Class

CXTPCustomizeKeyboardPage is a CPropertyPage derived class. It represents the Keyboard page of the Customize dialog.

Class Hierarchy

class CXTPCustomizeKeyboardPage : public CPropertyPage;
File

XTPCustomizeKeyboardPage.h

Group

Classes

Legend
Data Member
protected
Method
CXTPCustomizeKeyboardPage Constructors
CXTPCustomizeKeyboardPage Constructors | Description
CXTPCustomizeKeyboardPage | Constructs a CXTPCustomizeKeyboardPage object
CXTPCustomizeKeyboardPage Data Members
CXTPCustomizeKeyboardPage Data Members | Description
m_arrCategories | Array of categories
m_comboCategory | Categories combo box
m_editShortcutKey | Shortcut edit control
m_iCategory | Selected category
m_lboxCommands | Commands list box
m_lboxKeys | Keys list box
m_pSheet | Parent Customize dialog
m_strDesc | Description of selected control
CXTPCustomizeKeyboardPage Destructors
CXTPCustomizeKeyboardPage Destructors | Description
~CXTPCustomizeKeyboardPage | Destroys a CXTPCustomizeKeyboardPage object, handles cleanup and deallocation.
CXTPCustomizeKeyboardPage Methods
CXTPCustomizeKeyboardPage Methods | Description
AddCategories |
AddCategory | Adds a new category from a CMenu object.
EnableControls | This member function is called by the page to enable the assignment buttons.
FindCategory | Finds the category.
GetFrameAccelerator | Retrieves frame accelerators.
InsertCategory | This method adds a new empty category in the given index.
ReloadList | This member function is called by the page to reload the list items.
UpdateAcellTable | Updates frame accelerators.


CXTPCustomizeKeyboardPage Data Members

CXTPCustomizeKeyboardPage Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage Data Members
Class

CXTPCustomizeKeyboardPage Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrCategories | Array of categories
m_pSheet | Parent Customize dialog
Public Data Members
Public Data Member | Description
m_comboCategory | Categories combo box
m_editShortcutKey | Shortcut edit control
m_iCategory | Selected category
m_lboxCommands | Commands list box
m_lboxKeys | Keys list box
m_strDesc | Description of selected control


CXTPCustomizeKeyboardPage::m_arrCategories Data Member

CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::m_arrCategories Data Member

Array of categories

CXTPCommandBarsCategoryArray m_arrCategories;
Group

CXTPCustomizeKeyboardPage Data Members


CXTPCustomizeKeyboardPage::m_comboCategory Data Member

CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::m_comboCategory Data Member

Categories combo box

CComboBox m_comboCategory;
Group

CXTPCustomizeKeyboardPage Data Members


CXTPCustomizeKeyboardPage::m_editShortcutKey Data Member

CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::m_editShortcutKey Data Member

Shortcut edit control

CXTPShortcutManager::CKeyAssign m_editShortcutKey;
Group

CXTPCustomizeKeyboardPage Data Members


CXTPCustomizeKeyboardPage::m_iCategory Data Member

CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::m_iCategory Data Member

Selected category

int m_iCategory;
Group

CXTPCustomizeKeyboardPage Data Members


CXTPCustomizeKeyboardPage::m_lboxCommands Data Member

CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::m_lboxCommands Data Member

Commands list box

CListBox m_lboxCommands;
Group

CXTPCustomizeKeyboardPage Data Members


CXTPCustomizeKeyboardPage::m_lboxKeys Data Member

CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::m_lboxKeys Data Member

Keys list box

CListBox m_lboxKeys;
Group

CXTPCustomizeKeyboardPage Data Members


CXTPCustomizeKeyboardPage::m_pSheet Data Member

CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::m_pSheet Data Member

Parent Customize dialog

CXTPCustomizeSheet* m_pSheet;
Group

CXTPCustomizeKeyboardPage Data Members


CXTPCustomizeKeyboardPage::m_strDesc Data Member

CXTPCustomizeKeyboardPage Data Members, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::m_strDesc Data Member

Description of selected control

CString m_strDesc;
Group

CXTPCustomizeKeyboardPage Data Members


CXTPCustomizeKeyboardPage Methods

CXTPCustomizeKeyboardPage Class, Legend, Public Methods
CXTPCustomizeKeyboardPage Methods
Class

CXTPCustomizeKeyboardPage Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddCategories |
AddCategory | Adds a new category from a CMenu object.
EnableControls | This member function is called by the page to enable the assignment buttons.
FindCategory | Finds the category.
GetFrameAccelerator | Retrieves frame accelerators.
InsertCategory | This method adds a new empty category in the given index.
ReloadList | This member function is called by the page to reload the list items.
UpdateAcellTable | Updates frame accelerators.


AddCategories Method

CXTPCustomizeKeyboardPage Methods
AddCategories Method
Overload List
Methods
Method | Description
CXTPCustomizeKeyboardPage::AddCategories (CXTPControls*) | Adds categories branch from Control or resource ID.
CXTPCustomizeKeyboardPage::AddCategories (UINT, BOOL) | Adds categories branch from Control or resource ID.
Group

CXTPCustomizeKeyboardPage Methods


CXTPCustomizeKeyboardPage::AddCategories Method (CXTPControls*)

AddCategories Method, CXTPCustomizeKeyboardPage Class
CXTPCustomizeKeyboardPage::AddCategories Method (CXTPControls*)

Adds categories branch from Control or resource ID.

BOOL AddCategories(
    CXTPControls* pControls
);
BOOL AddCategories(
    UINT nIDResource,
    BOOL bListSubItems = FALSE
);
Parameters

pControls
Points to a CXTPControls object
nIDResource
Menu resource from where categories will be built.
bListSubItems
TRUE to add sub menus to categories.

Returns

TRUE if successful; otherwise returns FALSE

Group

AddCategories Method


CXTPCustomizeKeyboardPage::AddCategory Method

CXTPCustomizeKeyboardPage Methods, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::AddCategory Method

Adds a new category from a CMenu object.

BOOL AddCategory(
    LPCTSTR strCategory,
    CMenu* pMenu,
    BOOL bListSubItems = FALSE
);
Parameters

strCategory
Category to be added.
pMenu
Points to a CMenu object
bListSubItems
TRUE to add sub menus to categories.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPCustomizeKeyboardPage Methods


CXTPCustomizeKeyboardPage::EnableControls Method

CXTPCustomizeKeyboardPage Methods, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::EnableControls Method

This member function is called by the page to enable the assignment buttons.

void EnableControls();
Group

CXTPCustomizeKeyboardPage Methods


CXTPCustomizeKeyboardPage::FindCategory Method

CXTPCustomizeKeyboardPage Methods, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::FindCategory Method

Finds the category.

XTP_COMMANDBARS_CATEGORYINFO* FindCategory(
    LPCTSTR strCategory
) const;
Parameters

strCategory
Category needed to find.

Group

CXTPCustomizeKeyboardPage Methods


CXTPCustomizeKeyboardPage::GetFrameAccelerator Method

CXTPCustomizeKeyboardPage Methods, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::GetFrameAccelerator Method

Retrieves frame accelerators.

CXTPShortcutManagerAccelTable* GetFrameAccelerator() const;
Group

CXTPCustomizeKeyboardPage Methods


CXTPCustomizeKeyboardPage::InsertCategory Method

CXTPCustomizeKeyboardPage Methods, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::InsertCategory Method

This method adds a new empty category in the given index.

CXTPControls* InsertCategory(
    LPCTSTR strCategory,
    int nIndex = -1
);
Parameters

strCategory
Category to be added.
nIndex
Index to insert.

Returns

A pointer to a CXTPControls object

Group

CXTPCustomizeKeyboardPage Methods


CXTPCustomizeKeyboardPage::ReloadList Method

CXTPCustomizeKeyboardPage Methods, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::ReloadList Method

This member function is called by the page to reload the list items.

void ReloadList();
Group

CXTPCustomizeKeyboardPage Methods


CXTPCustomizeKeyboardPage::UpdateAcellTable Method

CXTPCustomizeKeyboardPage Methods, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::UpdateAcellTable Method

Updates frame accelerators.

void UpdateAcellTable(
    LPACCEL lpAccel,
    int nSize
);
Parameters

lpAccel
Accelerator table to set.
nSize
Number of items.

Group

CXTPCustomizeKeyboardPage Methods


CXTPCustomizeKeyboardPage Constructors

CXTPCustomizeKeyboardPage Class, Legend, Public Methods
CXTPCustomizeKeyboardPage Constructors
Class

CXTPCustomizeKeyboardPage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeKeyboardPage | Constructs a CXTPCustomizeKeyboardPage object


CXTPCustomizeKeyboardPage::CXTPCustomizeKeyboardPage Constructor

CXTPCustomizeKeyboardPage Constructors, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::CXTPCustomizeKeyboardPage Constructor

Constructs a CXTPCustomizeKeyboardPage object

CXTPCustomizeKeyboardPage(
    CXTPCustomizeSheet* pSheet
);
Parameters

pSheet
Points to a CXTPCustomizeSheet object that this page belongs to.

Group

CXTPCustomizeKeyboardPage Constructors


CXTPCustomizeKeyboardPage Destructors

CXTPCustomizeKeyboardPage Class, Legend, Public Methods
CXTPCustomizeKeyboardPage Destructors
Class

CXTPCustomizeKeyboardPage Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCustomizeKeyboardPage | Destroys a CXTPCustomizeKeyboardPage object, handles cleanup and deallocation.


CXTPCustomizeKeyboardPage::~CXTPCustomizeKeyboardPage Destructor

CXTPCustomizeKeyboardPage Destructors, CXTPCustomizeKeyboardPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeKeyboardPage::~CXTPCustomizeKeyboardPage Destructor

Destroys a CXTPCustomizeKeyboardPage object, handles cleanup and deallocation.

~CXTPCustomizeKeyboardPage();
Group

CXTPCustomizeKeyboardPage Destructors


CXTPCustomizeOptionsPage Class

XTPCustomizeOptionsPage.h, Classes, Legend, Members, Topics, CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Methods, CXTPCustomizeOptionsPage Constructors, CXTPCustomizeOptionsPage Destructors, CXTPCustomizeOptionsPage Constructors, CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Destructors, CXTPCustomizeOptionsPage Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage Class

CXTPCustomizeOptionsPage is a CPropertyPage derived class. It represents the Options page of the Customize dialog.

Class Hierarchy

class CXTPCustomizeOptionsPage : public CPropertyPage;
File

XTPCustomizeOptionsPage.h

Group

Classes

Legend
Data Member
protected
Method
CXTPCustomizeOptionsPage Constructors
CXTPCustomizeOptionsPage Constructors | Description
CXTPCustomizeOptionsPage | Constructs a CXTPCustomizeOptionsPage object
CXTPCustomizeOptionsPage Data Members
CXTPCustomizeOptionsPage Data Members | Description
m_bAlwaysShowFullMenus | TRUE to show full menus always
m_bLargeIcons | TRUE to show large icons
m_bShowFullAfterDelay | TRUE to show menus after delay
m_bToolBarAccelTips | TRUE to show accelerators with tool tips
m_bToolBarScreenTips | TRUE to show tool tips
m_comboAnimationType | Animation combo box
m_nAnimationType | Selected animation type
m_pSheet | Parent sheet.
m_wndOtherGroup | Other group line
m_wndPersonalizedGroup | Personalized group line
CXTPCustomizeOptionsPage Destructors
CXTPCustomizeOptionsPage Destructors | Description
~CXTPCustomizeOptionsPage | Destroys a CXTPCustomizeOptionsPage object, handles cleanup and deallocation.
CXTPCustomizeOptionsPage Methods
CXTPCustomizeOptionsPage Methods | Description
AddComboString | Adds animation string from resource
GetCommandBars | Retrieves parent command bars.


CXTPCustomizeOptionsPage Data Members

CXTPCustomizeOptionsPage Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage Data Members
Class

CXTPCustomizeOptionsPage Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pSheet | Parent sheet.
Public Data Members
Public Data Member | Description
m_bAlwaysShowFullMenus | TRUE to show full menus always
m_bLargeIcons | TRUE to show large icons
m_bShowFullAfterDelay | TRUE to show menus after delay
m_bToolBarAccelTips | TRUE to show accelerators with tool tips
m_bToolBarScreenTips | TRUE to show tool tips
m_comboAnimationType | Animation combo box
m_nAnimationType | Selected animation type
m_wndOtherGroup | Other group line
m_wndPersonalizedGroup | Personalized group line


CXTPCustomizeOptionsPage::m_bAlwaysShowFullMenus Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_bAlwaysShowFullMenus Data Member

TRUE to show full menus always

BOOL m_bAlwaysShowFullMenus;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_bLargeIcons Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_bLargeIcons Data Member

TRUE to show large icons

BOOL m_bLargeIcons;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_bShowFullAfterDelay Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_bShowFullAfterDelay Data Member

TRUE to show menus after delay

BOOL m_bShowFullAfterDelay;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_bToolBarAccelTips Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_bToolBarAccelTips Data Member

TRUE to show accelerators with tool tips

BOOL m_bToolBarAccelTips;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_bToolBarScreenTips Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_bToolBarScreenTips Data Member

TRUE to show tool tips

BOOL m_bToolBarScreenTips;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_comboAnimationType Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_comboAnimationType Data Member

Animation combo box

CComboBox m_comboAnimationType;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_nAnimationType Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_nAnimationType Data Member

Selected animation type

int m_nAnimationType;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_pSheet Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_pSheet Data Member

Parent sheet.

CXTPCustomizeSheet* m_pSheet;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_wndOtherGroup Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_wndOtherGroup Data Member

Other group line

CXTPGroupLine m_wndOtherGroup;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage::m_wndPersonalizedGroup Data Member

CXTPCustomizeOptionsPage Data Members, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::m_wndPersonalizedGroup Data Member

Personalized group line

CXTPGroupLine m_wndPersonalizedGroup;
Group

CXTPCustomizeOptionsPage Data Members


CXTPCustomizeOptionsPage Methods

CXTPCustomizeOptionsPage Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage Methods
Class

CXTPCustomizeOptionsPage Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
AddComboString | Adds animation string from resource
Public Methods
Public Methods
Public Method | Description
GetCommandBars | Retrieves parent command bars.


CXTPCustomizeOptionsPage::AddComboString Method

CXTPCustomizeOptionsPage Methods, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::AddComboString Method

Adds animation string from resource

void AddComboString(
    UINT nIDResource
);
Parameters

nIDResource
Specifies the string resource ID to add.

Group

CXTPCustomizeOptionsPage Methods


CXTPCustomizeOptionsPage::GetCommandBars Method

CXTPCustomizeOptionsPage Methods, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::GetCommandBars Method

Retrieves parent command bars.

CXTPCommandBars* GetCommandBars() const;
Returns

A pointer to a CXTPCommandBars object

Group

CXTPCustomizeOptionsPage Methods


CXTPCustomizeOptionsPage Constructors

CXTPCustomizeOptionsPage Class, Legend, Public Methods
CXTPCustomizeOptionsPage Constructors
Class

CXTPCustomizeOptionsPage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeOptionsPage | Constructs a CXTPCustomizeOptionsPage object


CXTPCustomizeOptionsPage::CXTPCustomizeOptionsPage Constructor

CXTPCustomizeOptionsPage Constructors, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::CXTPCustomizeOptionsPage Constructor

Constructs a CXTPCustomizeOptionsPage object

CXTPCustomizeOptionsPage(
    CXTPCustomizeSheet* pSheet
);
Parameters

pSheet
Points to a CXTPCustomizeSheet object that this page belongs to.

Group

CXTPCustomizeOptionsPage Constructors


CXTPCustomizeOptionsPage Destructors

CXTPCustomizeOptionsPage Class, Legend, Public Methods
CXTPCustomizeOptionsPage Destructors
Class

CXTPCustomizeOptionsPage Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCustomizeOptionsPage | Destroys a CXTPCustomizeOptionsPage object, handles cleanup and deallocation.


CXTPCustomizeOptionsPage::~CXTPCustomizeOptionsPage Destructor

CXTPCustomizeOptionsPage Destructors, CXTPCustomizeOptionsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeOptionsPage::~CXTPCustomizeOptionsPage Destructor

Destroys a CXTPCustomizeOptionsPage object, handles cleanup and deallocation.

~CXTPCustomizeOptionsPage();
Group

CXTPCustomizeOptionsPage Destructors


CXTPCustomizeSheet Class

XTPCustomizeSheet.h, Classes, Legend, Members, Topics, CXTPCustomizeSheet Data Members, CXTPCustomizeSheet Methods, CXTPCustomizeSheet Constructors, CXTPCustomizeSheet Destructors, CXTPCustomizeSheet Constructors, CXTPCustomizeSheet Data Members, CXTPCustomizeSheet Destructors, CXTPCustomizeSheet Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeSheet Class

CXTPCustomizeSheet is a CPropertySheet derived class. It represents the Customize dialog.

Class Hierarchy

class CXTPCustomizeSheet : public CPropertySheet;
File

XTPCustomizeSheet.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCustomizeSheet Constructors
CXTPCustomizeSheet Constructors | Description
CXTPCustomizeSheet | Constructs a CXTPCustomizeSheet object
CXTPCustomizeSheet Data Members
CXTPCustomizeSheet Data Members | Description
m_pCommandBars | Customized comamndBars.
m_pContextMenu | Context menu that is displayed in customization mode when a user right-clicks on a control.
m_pCustomIcons | Icons displayed in the "Change Button Image" popup of the context menu that is displayed when a user right-clicks on a control.
m_pPageCommands | Commands page.
m_pPageToolBars | Toolbar page.
m_pWndParent | Parent window.
CXTPCustomizeSheet Destructors
CXTPCustomizeSheet Destructors | Description
~CXTPCustomizeSheet | Destroys a CXTPCustomizeSheet object, handles cleanup and deallocation.
CXTPCustomizeSheet Methods
CXTPCustomizeSheet Methods | Description
AddPage | Adds the supplied page with the rightmost tab in the property sheet.
ContextMenu | This method shows the context menu for toolbars
DoModal | Call this method to show customize dialog.
GetCommandBars | Returns the parent Command Bars class
GetCommandsPage | Returns the Commands PropertyPage
GetContextMenu | Call this member to get a pointer to the context menu that is displayed in customization mode when a user right-clicks on a control.
GetCustomIcons | Retrieves collection of custom icons that can be selected for a control during customization mode. Custom icons are displayed in the "Change Button Image" popup of the context menu that is displayed when a user right-clicks on a control.


CXTPCustomizeSheet Data Members

CXTPCustomizeSheet Class, Legend, Protected Data Members
CXTPCustomizeSheet Data Members
Class

CXTPCustomizeSheet Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pCommandBars | Customized comamndBars.
m_pContextMenu | Context menu that is displayed in customization mode when a user right-clicks on a control.
m_pCustomIcons | Icons displayed in the "Change Button Image" popup of the context menu that is displayed when a user right-clicks on a control.
m_pPageCommands | Commands page.
m_pPageToolBars | Toolbar page.
m_pWndParent | Parent window.


CXTPCustomizeSheet::m_pCommandBars Data Member

CXTPCustomizeSheet Data Members, CXTPCustomizeSheet Class
CXTPCustomizeSheet::m_pCommandBars Data Member

Customized comamndBars.

CXTPCommandBars* m_pCommandBars;
Group

CXTPCustomizeSheet Data Members


CXTPCustomizeSheet::m_pContextMenu Data Member

CXTPCustomizeSheet Data Members, CXTPCustomizeSheet Class
CXTPCustomizeSheet::m_pContextMenu Data Member

Context menu that is displayed in customization mode when a user right-clicks on a control.

CXTPPopupBar* m_pContextMenu;
Group

CXTPCustomizeSheet Data Members


CXTPCustomizeSheet::m_pCustomIcons Data Member

CXTPCustomizeSheet Data Members, CXTPCustomizeSheet Class
CXTPCustomizeSheet::m_pCustomIcons Data Member

Icons displayed in the "Change Button Image" popup of the context menu that is displayed when a user right-clicks on a control.

CXTPImageManager* m_pCustomIcons;
Group

CXTPCustomizeSheet Data Members


CXTPCustomizeSheet::m_pPageCommands Data Member

CXTPCustomizeSheet Data Members, CXTPCustomizeSheet Class
CXTPCustomizeSheet::m_pPageCommands Data Member

Commands page.

CXTPCustomizeCommandsPage* m_pPageCommands;
Group

CXTPCustomizeSheet Data Members


CXTPCustomizeSheet::m_pPageToolBars Data Member

CXTPCustomizeSheet Data Members, CXTPCustomizeSheet Class
CXTPCustomizeSheet::m_pPageToolBars Data Member

Toolbar page.

CXTPCustomizeToolbarsPage* m_pPageToolBars;
Group

CXTPCustomizeSheet Data Members


CXTPCustomizeSheet::m_pWndParent Data Member

CXTPCustomizeSheet Data Members, CXTPCustomizeSheet Class
CXTPCustomizeSheet::m_pWndParent Data Member

Parent window.

CWnd* m_pWndParent;
Group

CXTPCustomizeSheet Data Members


CXTPCustomizeSheet Methods

CXTPCustomizeSheet Class, Legend, Public Methods
CXTPCustomizeSheet Methods
Class

CXTPCustomizeSheet Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddPage | Adds the supplied page with the rightmost tab in the property sheet.
ContextMenu | This method shows the context menu for toolbars
DoModal | Call this method to show customize dialog.
GetCommandBars | Returns the parent Command Bars class
GetCommandsPage | Returns the Commands PropertyPage
GetContextMenu | Call this member to get a pointer to the context menu that is displayed in customization mode when a user right-clicks on a control.
GetCustomIcons | Retrieves collection of custom icons that can be selected for a control during customization mode. Custom icons are displayed in the "Change Button Image" popup of the context menu that is displayed when a user right-clicks on a control.


CXTPCustomizeSheet::AddPage Method

CXTPCustomizeSheet Methods, CXTPCustomizeSheet Class
CXTPCustomizeSheet::AddPage Method

Adds the supplied page with the rightmost tab in the property sheet.

void AddPage(
    CPropertyPage* pPage
);
Parameters

pPage
Points to the page to be added to the property sheet. Cannot be NULL.

Group

CXTPCustomizeSheet Methods


CXTPCustomizeSheet::ContextMenu Method

CXTPCustomizeSheet Methods, CXTPCustomizeSheet Class
CXTPCustomizeSheet::ContextMenu Method

This method shows the context menu for toolbars

void ContextMenu(
    CPoint point
);
Parameters

point
Position of the menu to show

Group

CXTPCustomizeSheet Methods


CXTPCustomizeSheet::DoModal Method

CXTPCustomizeSheet Methods, CXTPCustomizeSheet Class
CXTPCustomizeSheet::DoModal Method

Call this method to show customize dialog.

INT_PTR DoModal();
Group

CXTPCustomizeSheet Methods


CXTPCustomizeSheet::GetCommandBars Method

CXTPCustomizeSheet Methods, CXTPCustomizeSheet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeSheet::GetCommandBars Method

Returns the parent Command Bars class

CXTPCommandBars* GetCommandBars() const;
Returns

A pointer to a CXTPCommandBars object

Body Source
CXTPCommandBars* CXTPCustomizeSheet::GetCommandBars() const {
    return m_pCommandBars;
}
Group

CXTPCustomizeSheet Methods


CXTPCustomizeSheet::GetCommandsPage Method

CXTPCustomizeSheet Methods, CXTPCustomizeSheet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeSheet::GetCommandsPage Method

Returns the Commands PropertyPage

CXTPCustomizeCommandsPage* GetCommandsPage() const;
Returns

A pointer to a CXTPCustomizeCommandsPage object

Body Source
CXTPCustomizeCommandsPage* CXTPCustomizeSheet::GetCommandsPage() const {
    return m_pPageCommands;
}
Group

CXTPCustomizeSheet Methods


CXTPCustomizeSheet::GetContextMenu Method

CXTPCustomizeSheet Methods, CXTPCustomizeSheet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeSheet::GetContextMenu Method

Call this member to get a pointer to the context menu that is displayed in customization mode when a user right-clicks on a control.

CXTPPopupBar* GetContextMenu() const;
Returns

Retrieves the context menu.

Body Source
CXTPPopupBar* CXTPCustomizeSheet::GetContextMenu() const {
    return m_pContextMenu;
}
Group

CXTPCustomizeSheet Methods


CXTPCustomizeSheet::GetCustomIcons Method

CXTPCustomizeSheet Methods, CXTPCustomizeSheet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeSheet::GetCustomIcons Method

Retrieves collection of custom icons that can be selected for a control during customization mode. Custom icons are displayed in the "Change Button Image" popup of the context menu that is displayed when a user right-clicks on a control.

CXTPImageManager* GetCustomIcons() const;
Remarks

Icons must be numbered from 1. When adding icons, the numbering must start with 1 and increment by 1 for each icon added. So the numbering would look like this: 1, 2, 3, 4, ...N.

The toolkit provide 42 "built-in" icons that you can choose from and they are automatically displayed in the "Change Button Icon" popup menu if you do not remove them. If you do not remove the "built-in" icons that are provided with the toolkit then you should start your numbering at 43. If you start at 1 and you did not remove the "bulilt-in" icons, then you will overwrite some of the "built-in" icons. So you would number your icons 43, 44, 45, ...N. So you could even keep some of the "built-in" icons and overwrite the ones you don't need with your own custom icons.

Body Source
CXTPImageManager* CXTPCustomizeSheet::GetCustomIcons() const {
    return m_pCustomIcons;
}
Group

CXTPCustomizeSheet Methods


CXTPCustomizeSheet Constructors

CXTPCustomizeSheet Class, Legend, Public Methods
CXTPCustomizeSheet Constructors
Class

CXTPCustomizeSheet Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeSheet | Constructs a CXTPCustomizeSheet object


CXTPCustomizeSheet::CXTPCustomizeSheet Constructor

CXTPCustomizeSheet Constructors, CXTPCustomizeSheet Class
CXTPCustomizeSheet::CXTPCustomizeSheet Constructor

Constructs a CXTPCustomizeSheet object

CXTPCustomizeSheet(
    CXTPCommandBars* pCommandBars,
    UINT iSelectPage = 0
);
Parameters

pCommandBars
Points to a CXTPCommandBars object
iSelectPage
Page initially selected.

Group

CXTPCustomizeSheet Constructors


CXTPCustomizeSheet Destructors

CXTPCustomizeSheet Class, Legend, Public Methods
CXTPCustomizeSheet Destructors
Class

CXTPCustomizeSheet Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCustomizeSheet | Destroys a CXTPCustomizeSheet object, handles cleanup and deallocation.


CXTPCustomizeSheet::~CXTPCustomizeSheet Destructor

CXTPCustomizeSheet Destructors, CXTPCustomizeSheet Class
CXTPCustomizeSheet::~CXTPCustomizeSheet Destructor

Destroys a CXTPCustomizeSheet object, handles cleanup and deallocation.

virtual ~CXTPCustomizeSheet();
Group

CXTPCustomizeSheet Destructors


CXTPCustomizeToolbarsPage Class

XTPCustomizeToolbarsPage.h, Classes, Legend, Members, Topics, CXTPCustomizeToolbarsPage Data Members, CXTPCustomizeToolbarsPage Constructors, CXTPCustomizeToolbarsPage Destructors, CXTPCustomizeToolbarsPage Constructors, CXTPCustomizeToolbarsPage Data Members, CXTPCustomizeToolbarsPage Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage Class

CXTPCustomizeToolbarsPage is a CPropertyPage derived class. It represents the Toolbars page of the Customize dialog.

Class Hierarchy

class CXTPCustomizeToolbarsPage : public CPropertyPage;
File

XTPCustomizeToolbarsPage.h

Group

Classes

Legend
Data Member
Constructor
CXTPCustomizeToolbarsPage Constructors
CXTPCustomizeToolbarsPage Constructors | Description
CXTPCustomizeToolbarsPage | Constructs a CXTPCustomizeToolbarsPage object
CXTPCustomizeToolbarsPage Data Members
CXTPCustomizeToolbarsPage Data Members | Description
m_btnDelete | Delete button
m_btnNew | New button
m_btnRename | Rename button
m_btnReset | Reset button
m_checkList | Toolbars list box
m_pSheet | Parent property sheet
CXTPCustomizeToolbarsPage Destructors
CXTPCustomizeToolbarsPage Destructors | Description
~CXTPCustomizeToolbarsPage | Destroys a CXTPCustomizeToolbarsPage object, handles cleanup and deallocation.


CXTPCustomizeToolbarsPage Data Members

CXTPCustomizeToolbarsPage Class, Legend, Public Data Members
CXTPCustomizeToolbarsPage Data Members
Class

CXTPCustomizeToolbarsPage Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_btnDelete | Delete button
m_btnNew | New button
m_btnRename | Rename button
m_btnReset | Reset button
m_checkList | Toolbars list box
m_pSheet | Parent property sheet


CXTPCustomizeToolbarsPage::m_btnDelete Data Member

CXTPCustomizeToolbarsPage Data Members, CXTPCustomizeToolbarsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage::m_btnDelete Data Member

Delete button

CButton m_btnDelete;
Group

CXTPCustomizeToolbarsPage Data Members


CXTPCustomizeToolbarsPage::m_btnNew Data Member

CXTPCustomizeToolbarsPage Data Members, CXTPCustomizeToolbarsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage::m_btnNew Data Member

New button

CButton m_btnNew;
Group

CXTPCustomizeToolbarsPage Data Members


CXTPCustomizeToolbarsPage::m_btnRename Data Member

CXTPCustomizeToolbarsPage Data Members, CXTPCustomizeToolbarsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage::m_btnRename Data Member

Rename button

CButton m_btnRename;
Group

CXTPCustomizeToolbarsPage Data Members


CXTPCustomizeToolbarsPage::m_btnReset Data Member

CXTPCustomizeToolbarsPage Data Members, CXTPCustomizeToolbarsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage::m_btnReset Data Member

Reset button

CButton m_btnReset;
Group

CXTPCustomizeToolbarsPage Data Members


CXTPCustomizeToolbarsPage::m_checkList Data Member

CXTPCustomizeToolbarsPage Data Members, CXTPCustomizeToolbarsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage::m_checkList Data Member

Toolbars list box

CXTPCustomizeToolbarsPageCheckListBox m_checkList;
Group

CXTPCustomizeToolbarsPage Data Members


CXTPCustomizeToolbarsPage::m_pSheet Data Member

CXTPCustomizeToolbarsPage Data Members, CXTPCustomizeToolbarsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage::m_pSheet Data Member

Parent property sheet

CXTPCustomizeSheet* m_pSheet;
Group

CXTPCustomizeToolbarsPage Data Members


CXTPCustomizeToolbarsPage Constructors

CXTPCustomizeToolbarsPage Class, Legend, Public Methods
CXTPCustomizeToolbarsPage Constructors
Class

CXTPCustomizeToolbarsPage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeToolbarsPage | Constructs a CXTPCustomizeToolbarsPage object


CXTPCustomizeToolbarsPage::CXTPCustomizeToolbarsPage Constructor

CXTPCustomizeToolbarsPage Constructors, CXTPCustomizeToolbarsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage::CXTPCustomizeToolbarsPage Constructor

Constructs a CXTPCustomizeToolbarsPage object

CXTPCustomizeToolbarsPage(
    CXTPCustomizeSheet* pSheet = NULL
);
Parameters

pSheet
Points to a CXTPCustomizeSheet object that this page belongs to.

Group

CXTPCustomizeToolbarsPage Constructors


CXTPCustomizeToolbarsPage Destructors

CXTPCustomizeToolbarsPage Class, Legend, Public Methods
CXTPCustomizeToolbarsPage Destructors
Class

CXTPCustomizeToolbarsPage Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCustomizeToolbarsPage | Destroys a CXTPCustomizeToolbarsPage object, handles cleanup and deallocation.


CXTPCustomizeToolbarsPage::~CXTPCustomizeToolbarsPage Destructor

CXTPCustomizeToolbarsPage Destructors, CXTPCustomizeToolbarsPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCustomizeToolbarsPage::~CXTPCustomizeToolbarsPage Destructor

Destroys a CXTPCustomizeToolbarsPage object, handles cleanup and deallocation.

~CXTPCustomizeToolbarsPage();
Group

CXTPCustomizeToolbarsPage Destructors


CXTPDefaultTheme Class

XTPPaintManager.h, Classes, Legend, Members, Topics, CXTPDefaultTheme Data Members, CXTPDefaultTheme Methods, CXTPDefaultTheme Constructors, CXTPDefaultTheme Constructors, CXTPDefaultTheme Data Members, CXTPDefaultTheme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDefaultTheme Class

The CXTPDefaultTheme class is used to enable an Office 2000 style theme for Command Bars

Class Hierarchy

class CXTPDefaultTheme : public CXTPPaintManager;
File

XTPPaintManager.h

See Also

CXTPPaintManager::SetTheme

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDefaultTheme Constructors
CXTPDefaultTheme Constructors | Description
CXTPDefaultTheme | Constructs a CXTPDefaultTheme object.
CXTPDefaultTheme Data Members
CXTPDefaultTheme Data Members | Description
m_nPopupBarText | Popup bar text index.
CXTPDefaultTheme Methods
CXTPDefaultTheme Methods | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
BaseTheme | Retrieves the base theme of the manager.
DrawCommandBarGripper | This method is called to draw the command bar's gripper.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawControlComboBox | This method is called to draw the control.
DrawControlComboBoxButton | This method is called to draw button od combo box control.
DrawControlEdit | This method is called to draw the control.
DrawControlEditFrame | This method is called to draw frame of edit control.
DrawControlEditSpin | This method draws edit control spin buttons
DrawControlPopupParent | This method is called to draw the control placed on the PopupBar.
DrawDialogBarGripper | Call this member to draw gripper of dialog bar.
DrawImage | This method is called to draw the image of the control.
DrawListBoxControl | This method is called to draw the control placed on the ListBox.
DrawRectangle | This method is called to fill the control's face
DrawSpecialControl | This method is called to draw the specified controls.
DrawSplitButtonFrame | Draws split button frame
DrawTearOffGripper | This method is called to draw a tear-off gripper of Popup Bar.
FillCommandBarEntry | This method is called to fill the command bar's face.
GetCommandBarBorders | This method is called to retrieve the command bar's borders.
GetRectangleTextColor | This method retrieves buttons text color
RefreshMetrics | This method is called to refresh the visual metrics of the manager.


CXTPDefaultTheme Data Members

CXTPDefaultTheme Class, Legend, Protected Data Members
CXTPDefaultTheme Data Members
Class

CXTPDefaultTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nPopupBarText | Popup bar text index.


CXTPDefaultTheme::m_nPopupBarText Data Member

CXTPDefaultTheme Data Members, CXTPDefaultTheme Class
CXTPDefaultTheme::m_nPopupBarText Data Member

Popup bar text index.

int m_nPopupBarText;
Group

CXTPDefaultTheme Data Members


CXTPDefaultTheme Methods

CXTPDefaultTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDefaultTheme Methods
Class

CXTPDefaultTheme Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
BaseTheme | Retrieves the base theme of the manager.
DrawControlComboBox | This method is called to draw the control.
DrawControlComboBoxButton | This method is called to draw button od combo box control.
DrawControlEdit | This method is called to draw the control.
DrawControlEditFrame | This method is called to draw frame of edit control.
DrawControlEditSpin | This method draws edit control spin buttons
DrawControlPopupParent | This method is called to draw the control placed on the PopupBar.
DrawDialogBarGripper | Call this member to draw gripper of dialog bar.
DrawImage | This method is called to draw the image of the control.
DrawRectangle | This method is called to fill the control's face
DrawSplitButtonFrame | Draws split button frame
Public Methods
Public Methods
Public Method | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
DrawCommandBarGripper | This method is called to draw the command bar's gripper.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawListBoxControl | This method is called to draw the control placed on the ListBox.
DrawSpecialControl | This method is called to draw the specified controls.
DrawTearOffGripper | This method is called to draw a tear-off gripper of Popup Bar.
FillCommandBarEntry | This method is called to fill the command bar's face.
GetCommandBarBorders | This method is called to retrieve the command bar's borders.
GetRectangleTextColor | This method retrieves buttons text color
RefreshMetrics | This method is called to refresh the visual metrics of the manager.


CXTPDefaultTheme::AdjustExcludeRect Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::AdjustExcludeRect Method

This method is called to determine offset of popuped bar.

virtual void AdjustExcludeRect(
    CRect& rc,
    CXTPControl* pControl,
    BOOL bVertical
);
Parameters

rc
Control's bounding rectangle.
pControl
Points to a CXTPControl object
bVertical
TRUE if control docked vertically.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::BaseTheme Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDefaultTheme::BaseTheme Method

Retrieves the base theme of the manager.

XTPPaintTheme BaseTheme();
Returns

Returns the base theme.

Body Source
XTPPaintTheme BaseTheme() { return xtpThemeOffice2000; }
Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawCommandBarGripper Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawCommandBarGripper Method

This method is called to draw the command bar's gripper.

virtual CSize DrawCommandBarGripper(
    CDC* pDC,
    CXTPCommandBar* pBar,
    BOOL bDraw = TRUE
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
bDraw
TRUE to draw; FALSE to retrieve the size of the gripper.

Returns

Size of the gripper.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawCommandBarSeparator Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawCommandBarSeparator Method

This method is called to draw a command bar's separator.

virtual CSize DrawCommandBarSeparator(
    CDC* pDC,
    CXTPCommandBar* pBar,
    CXTPControl* pControl,
    BOOL bDraw = TRUE
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
pControl
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the separator.

Returns

This method is called to draw a command bar's separator.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawControlComboBox Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawControlComboBox Method

This method is called to draw the control.

virtual CSize DrawControlComboBox(
    CDC* pDC,
    CXTPControlComboBox* pComboBox,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pComboBox
ComboBox to draw.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawControlComboBoxButton Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawControlComboBoxButton Method

This method is called to draw button od combo box control.

virtual void DrawControlComboBoxButton(
    CDC* pDC,
    CRect rcBtn,
    BOOL bEnabled,
    BOOL bSelected,
    BOOL bDropped
);
Parameters

pDC
Points to a valid device context.
rcBtn
Button bounding rectangle.
bEnabled
TRUE if combo box is enabled
bSelected
TRUE if combo box is selected
bDropped
TRUE TRUE if combo box is dropped.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawControlEdit Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawControlEdit Method

This method is called to draw the control.

virtual CSize DrawControlEdit(
    CDC* pDC,
    CXTPControlEdit* pEdit,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pEdit
Edit control to draw.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawControlEditFrame Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawControlEditFrame Method

This method is called to draw frame of edit control.

virtual void DrawControlEditFrame(
    CDC* pDC,
    CRect rc,
    BOOL bEnabled,
    BOOL bSelected
);
Parameters

pDC
Points to a valid device context.
rc
CRect object specifying size of area.
bEnabled
TRUE if control is enabled.
bSelected
TRUE if control is selected.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawControlEditSpin Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawControlEditSpin Method

This method draws edit control spin buttons

virtual void DrawControlEditSpin(
    CDC* pDC,
    CXTPControlEdit* pControlEdit
);
Parameters

pDC
Pointer to device context
pControlEdit
Edit control

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawControlPopupParent Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawControlPopupParent Method

This method is called to draw the control placed on the PopupBar.

virtual CSize DrawControlPopupParent(
    CDC* pDC,
    CXTPControl* pButton,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawDialogBarGripper Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawDialogBarGripper Method

Call this member to draw gripper of dialog bar.

virtual CSize DrawDialogBarGripper(
    CDC* pDC,
    CXTPDialogBar* pBar,
    BOOL bDraw
);
Parameters

pDC
Points to a valid device context.
pBar
Dialog Bar pointer
bDraw
TRUE to draw gripper, FALSE to calculate size.

Returns

Size of gripper to be drawn.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawImage Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawImage Method

This method is called to draw the image of the control.

virtual void DrawImage(
    CDC* pDC,
    CPoint pt,
    CSize sz,
    CXTPImageManagerIcon* pImage,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled = TRUE,
    BOOL bChecked = FALSE,
    BOOL bPopuped = FALSE,
    BOOL bToolBarImage = TRUE
);
Parameters

pDC
Pointer to a valid device context
pt
Position to draw.
sz
Size of the image.
pImage
Points to a CXTPImageManagerIcon object
bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
bToolBarImage
TRUE if it is a toolbar image.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawListBoxControl Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawListBoxControl Method

This method is called to draw the control placed on the ListBox.

virtual CSize DrawListBoxControl(
    CDC* pDC,
    CXTPControl* pButton,
    CRect rc,
    BOOL bSelected,
    BOOL bDraw,
    CXTPCommandBars* pCommandBars = 0
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
rc
Bounding rectangle to draw.
bSelected
TRUE if the control is selected.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.
pCommandBars
CommandBars object which metrics need to use.

Returns

Size of the control.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawRectangle Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawRectangle Method

This method is called to fill the control's face

virtual void DrawRectangle(
    CDC* pDC,
    CRect rc,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

pDC
Pointer to a valid device context
rc
Rectangle to draw.
bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawSpecialControl Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class, See Also
CXTPDefaultTheme::DrawSpecialControl Method

This method is called to draw the specified controls.

virtual CSize DrawSpecialControl(
    CDC* pDC,
    XTPSpecialControl controlType,
    CXTPControl* pButton,
    CXTPCommandBar* pBar,
    BOOL bDraw,
    LPVOID lpParam
);
Parameters

pDC
Pointer to a valid device context
controlType
Special control enumerator.
pButton
Points to a CXTPControl object to draw.
pBar
Parent CXTPCommandBar object.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.
lpParam
Specified parameter.

Returns

Size of the control.

See Also

XTPSpecialControl

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawSplitButtonFrame Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawSplitButtonFrame Method

Draws split button frame

virtual void DrawSplitButtonFrame(
    CDC* pDC,
    CXTPControl* pButton,
    CRect rcButton
);
Parameters

pDC
Points to a valid device context.
pButton
Pointer to split button to draw.
rcButton
Bounding rectangle to draw

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::DrawTearOffGripper Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::DrawTearOffGripper Method

This method is called to draw a tear-off gripper of Popup Bar.

virtual CSize DrawTearOffGripper(
    CDC* pDC,
    CRect rcGripper,
    BOOL bSelected,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
rcGripper
Bounding rectangle of the gripper.
bSelected
True if the gripper is selected.
bDraw
TRUE to draw; FALSE to retrieve the size of the gripper.

Returns

Size of the gripper.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::FillCommandBarEntry Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::FillCommandBarEntry Method

This method is called to fill the command bar's face.

virtual void FillCommandBarEntry(
    CDC* pDC,
    CXTPCommandBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object to draw.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::GetCommandBarBorders Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::GetCommandBarBorders Method

This method is called to retrieve the command bar's borders.

virtual CRect GetCommandBarBorders(
    CXTPCommandBar* pBar
);
Parameters

pBar
Points to a CXTPCommandBar object that the borders need to get.

Returns

Borders of the command bar.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::GetRectangleTextColor Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::GetRectangleTextColor Method

This method retrieves buttons text color

virtual COLORREF GetRectangleTextColor(
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPDefaultTheme Methods


CXTPDefaultTheme::RefreshMetrics Method

CXTPDefaultTheme Methods, CXTPDefaultTheme Class
CXTPDefaultTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the manager.

virtual void RefreshMetrics();
Group

CXTPDefaultTheme Methods


CXTPDefaultTheme Constructors

CXTPDefaultTheme Class, Legend, Public Methods
CXTPDefaultTheme Constructors
Class

CXTPDefaultTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDefaultTheme | Constructs a CXTPDefaultTheme object.


CXTPDefaultTheme::CXTPDefaultTheme Constructor

CXTPDefaultTheme Constructors, CXTPDefaultTheme Class
CXTPDefaultTheme::CXTPDefaultTheme Constructor

Constructs a CXTPDefaultTheme object.

CXTPDefaultTheme();
Group

CXTPDefaultTheme Constructors


CXTPDialog Class

XTPDialogBase.h, Classes, Legend, Members, Topics, CXTPDialog Constructors, CXTPDialog Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDialog Class

CXTPDialog is a CXTPDialogBase derived class. Use this class in your dialog base application.

Class Hierarchy

class CXTPDialog : public CXTPDialogBase<CDialog>;
File

XTPDialogBase.h

Group

Classes

Legend
Constructor
CXTPDialog Constructors
CXTPDialog Constructors | Description
CXTPDialog |


CXTPDialog Constructors

CXTPDialog Class, Legend, Public Methods
CXTPDialog Constructors
Class

CXTPDialog Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDialog |


CXTPDialog Constructor

CXTPDialog Constructors
CXTPDialog Constructor
Overload List
Constructors
Constructor | Description
CXTPDialog::CXTPDialog () | Constructs a CXTPDialog object
CXTPDialog::CXTPDialog (LPCTSTR, CWnd*) | Constructs a CXTPDialog object
CXTPDialog::CXTPDialog (UINT, CWnd*) | Constructs a CXTPDialog object
Group

CXTPDialog Constructors


CXTPDialog::CXTPDialog Constructor ()

CXTPDialog Constructor, CXTPDialog Class, Body Source
CXTPDialog::CXTPDialog Constructor ()

Constructs a CXTPDialog object

CXTPDialog();
CXTPDialog(
    UINT nIDTemplate,
    CWnd* pParentWnd = NULL
);
CXTPDialog(
    LPCTSTR lpszTemplateName,
    CWnd* pParentWnd = NULL
);
Parameters

nIDTemplate
Contains the ID number of a dialog-template resource
pParentWnd
Points to the parent of the Dialog control
lpszTemplateName
Contains a null-terminated string that is the name of a dialog-template resource

Body Source
CXTPDialog()
{

}

CXTPDialog(UINT nIDTemplate, CWnd* pParentWnd = NULL)
    : CXTPDialogBase<CDialog>(nIDTemplate, pParentWnd)
{

}

CXTPDialog(LPCTSTR lpszTemplateName, CWnd* pParentWnd = NULL)
    : CXTPDialogBase<CDialog>(lpszTemplateName, pParentWnd)
{

}
Group

CXTPDialog Constructor


CXTPDialogBar Class

XTPDialogBar.h, Classes, Legend, Members, Topics, CXTPDialogBar Data Members, CXTPDialogBar Methods, CXTPDialogBar Constructors, CXTPDialogBar Destructors, CXTPDialogBar Constructors, CXTPDialogBar Data Members, CXTPDialogBar Destructors, CXTPDialogBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDialogBar Class

CXTPDialogBar is a CXTPToolBar derived class. It represents dockable container for child window

Class Hierarchy

class CXTPDialogBar : public CXTPToolBar;
File

XTPDialogBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDialogBar Constructors
CXTPDialogBar Constructors | Description
CXTPDialogBar | Constructs a CXTPDialogBar object
CXTPDialogBar Data Members
CXTPDialogBar Data Members | Description
m_bActive | TRUE if dialog bar has active caption
m_bCaptionPopup | TRUE to use caption as popup control.
m_bCaptionVisible | TRUE if the caption popup control is visible.
m_bResizable | TRUE if the child window and dialog bar are re-sizable.
m_hwndChild | Child window handle.
m_nCaptionHeight | Caption height.
m_pPopupBar | Pointer to caption popup bar.
m_rcBorders | Borders size.
m_strCaption | Text that is displayed in the caption popup control.
m_szDockingClient | Docking client rectangle
m_szFloatingClient | Floating client rectangle
m_szMinTrackRect | Minimum tracking rectangle
CXTPDialogBar Destructors
CXTPDialogBar Destructors | Description
~CXTPDialogBar | Destroys a CXTPDialogBar object, handles cleanup and deallocation.
CXTPDialogBar Methods
CXTPDialogBar Methods | Description
CalcDockingLayout | This method calculates the dimensions of a toolbar.
CalcDynamicLayout | This method calculates the dimensions of a toolbar.
CalcSize | This method calculates the dimensions of a dialog bar.
GetCaption | Call this member to retrieve the text displayed in the caption popup.
GetCaptionPopup | Call this member to retrieve a pointer to the CXTPPopupBar that is displayed when the caption popup control is clicked/dropped down.
GetMargins | Retrieves client margins of dialog bar.
IsActive | Call this member function to get child pane state.
IsDialogBar | Call this member function to determine if the CommandBar is a CXTPDialogBar.
MoveChildWindow | This method is called to reposition child window in dialog bar.
OnMouseHitTest | This method is called to determine mouse hit code
OnResize | This method is called when user resize dialog bar.
SetCaption | Call this member to set the text that will be displayed in the dialog bar's caption popup.
SetCaptionPopup | Call this member to tell the caption popup which CMenu popup to display when the the caption popup is dropped down.
SetCaptionVisible | Call this member to hide the caption popup control (and close button).
SetChild | Call this member to specify the child window displayed under the dialog bar.
SetResizable | Call this member to specify whether the dialog bar will be re-sizable.
SetSize | Call this member to set the width and height of the dialog bar child window.


CXTPDialogBar Data Members

CXTPDialogBar Class, Legend, Protected Data Members
CXTPDialogBar Data Members
Class

CXTPDialogBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bActive | TRUE if dialog bar has active caption
m_bCaptionPopup | TRUE to use caption as popup control.
m_bCaptionVisible | TRUE if the caption popup control is visible.
m_bResizable | TRUE if the child window and dialog bar are re-sizable.
m_hwndChild | Child window handle.
m_nCaptionHeight | Caption height.
m_pPopupBar | Pointer to caption popup bar.
m_rcBorders | Borders size.
m_strCaption | Text that is displayed in the caption popup control.
m_szDockingClient | Docking client rectangle
m_szFloatingClient | Floating client rectangle
m_szMinTrackRect | Minimum tracking rectangle


CXTPDialogBar::m_bActive Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_bActive Data Member

TRUE if dialog bar has active caption

BOOL m_bActive;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_bCaptionPopup Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_bCaptionPopup Data Member

TRUE to use caption as popup control.

BOOL m_bCaptionPopup;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_bCaptionVisible Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_bCaptionVisible Data Member

TRUE if the caption popup control is visible.

BOOL m_bCaptionVisible;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_bResizable Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_bResizable Data Member

TRUE if the child window and dialog bar are re-sizable.

BOOL m_bResizable;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_hwndChild Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_hwndChild Data Member

Child window handle.

HWND m_hwndChild;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_nCaptionHeight Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_nCaptionHeight Data Member

Caption height.

int m_nCaptionHeight;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_pPopupBar Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_pPopupBar Data Member

Pointer to caption popup bar.

CXTPPopupBar* m_pPopupBar;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_rcBorders Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_rcBorders Data Member

Borders size.

CRect m_rcBorders;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_strCaption Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_strCaption Data Member

Text that is displayed in the caption popup control.

CString m_strCaption;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_szDockingClient Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_szDockingClient Data Member

Docking client rectangle

CSize m_szDockingClient;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_szFloatingClient Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_szFloatingClient Data Member

Floating client rectangle

CSize m_szFloatingClient;
Group

CXTPDialogBar Data Members


CXTPDialogBar::m_szMinTrackRect Data Member

CXTPDialogBar Data Members, CXTPDialogBar Class
CXTPDialogBar::m_szMinTrackRect Data Member

Minimum tracking rectangle

CSize m_szMinTrackRect;
Group

CXTPDialogBar Data Members


CXTPDialogBar Methods

CXTPDialogBar Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDialogBar Methods
Class

CXTPDialogBar Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
CalcDockingLayout | This method calculates the dimensions of a toolbar.
CalcDynamicLayout | This method calculates the dimensions of a toolbar.
CalcSize | This method calculates the dimensions of a dialog bar.
GetMargins | Retrieves client margins of dialog bar.
IsDialogBar | Call this member function to determine if the CommandBar is a CXTPDialogBar.
MoveChildWindow | This method is called to reposition child window in dialog bar.
OnMouseHitTest | This method is called to determine mouse hit code
OnResize | This method is called when user resize dialog bar.
Public Methods
Public Methods
Public Method | Description
GetCaption | Call this member to retrieve the text displayed in the caption popup.
GetCaptionPopup | Call this member to retrieve a pointer to the CXTPPopupBar that is displayed when the caption popup control is clicked/dropped down.
IsActive | Call this member function to get child pane state.
SetCaption | Call this member to set the text that will be displayed in the dialog bar's caption popup.
SetCaptionPopup | Call this member to tell the caption popup which CMenu popup to display when the the caption popup is dropped down.
SetCaptionVisible | Call this member to hide the caption popup control (and close button).
SetChild | Call this member to specify the child window displayed under the dialog bar.
SetResizable | Call this member to specify whether the dialog bar will be re-sizable.
SetSize | Call this member to set the width and height of the dialog bar child window.


CXTPDialogBar::CalcDockingLayout Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::CalcDockingLayout Method

This method calculates the dimensions of a toolbar.

CSize CalcDockingLayout(
    int nLength,
    DWORD dwMode,
    int nWidth
);
Parameters

nLength
Length of the bar.
dwMode
Mode to dock.
nWidth
Width of the bar.

Returns

Size of the docked toolbar.

Group

CXTPDialogBar Methods


CXTPDialogBar::CalcDynamicLayout Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::CalcDynamicLayout Method

This method calculates the dimensions of a toolbar.

CSize CalcDynamicLayout(
    int nLength,
    DWORD dwMode
);
Parameters

nLength
The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode
see CControlBar::CalcDynamicLayout for list of supported flags.

Returns

Size of the docked toolbar.

Group

CXTPDialogBar Methods


CXTPDialogBar::CalcSize Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::CalcSize Method

This method calculates the dimensions of a dialog bar.

CSize CalcSize(
    int nLength,
    DWORD dwMode,
    CSize szClient
);
Parameters

nLength
Length of the bar.
dwMode
Mode to dock.
szClient
Client size of dialog bar

Returns

Size of the dialog bar.

Group

CXTPDialogBar Methods


CXTPDialogBar::GetCaption Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::GetCaption Method

Call this member to retrieve the text displayed in the caption popup.

CString GetCaption() const;
Returns

The text displayed in the caption popup.

Group

CXTPDialogBar Methods


CXTPDialogBar::GetCaptionPopup Method

CXTPDialogBar Methods, CXTPDialogBar Class, Body Source
CXTPDialogBar::GetCaptionPopup Method

Call this member to retrieve a pointer to the CXTPPopupBar that is displayed when the caption popup control is clicked/dropped down.

CXTPPopupBar* GetCaptionPopup() const;
Returns

Pointer to the CXTPPopupBar that is displayed when the caption popup control is clicked/dropped down.

Body Source
CXTPPopupBar* CXTPDialogBar::GetCaptionPopup() const {
    return m_pPopupBar;
}
Group

CXTPDialogBar Methods


CXTPDialogBar::GetMargins Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::GetMargins Method

Retrieves client margins of dialog bar.

CRect GetMargins();
Returns

Rectangle contained top, left, right, bottom margins of dialog bar.

Group

CXTPDialogBar Methods


CXTPDialogBar::IsActive Method

CXTPDialogBar Methods, CXTPDialogBar Class, Body Source
CXTPDialogBar::IsActive Method

Call this member function to get child pane state.

BOOL IsActive() const;
Returns

TRUE if a child pane is active.

Body Source
BOOL CXTPDialogBar::IsActive() const {
    return m_bActive;
}
Group

CXTPDialogBar Methods


CXTPDialogBar::IsDialogBar Method

CXTPDialogBar Methods, CXTPDialogBar Class, Body Source
CXTPDialogBar::IsDialogBar Method

Call this member function to determine if the CommandBar is a CXTPDialogBar.

BOOL IsDialogBar() const;
Returns

Returns TRUE if the CommandBar is a CXTPDialogBar, otherwise FALSE.

Remarks

This will always return TRUE.

Body Source
BOOL CXTPDialogBar::IsDialogBar() const {
    return TRUE;
}
Group

CXTPDialogBar Methods


CXTPDialogBar::MoveChildWindow Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::MoveChildWindow Method

This method is called to reposition child window in dialog bar.

void MoveChildWindow(
    CRect rc
);
Parameters

rc
CRect object specifying size of area.

Group

CXTPDialogBar Methods


CXTPDialogBar::OnMouseHitTest Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::OnMouseHitTest Method

This method is called to determine mouse hit code

int OnMouseHitTest(
    CPoint pt
);
Parameters

pt
Position to test

Returns

HTCLIENT if pointer belongs client area; HTNOWHERE otherwise.

Group

CXTPDialogBar Methods


CXTPDialogBar::OnResize Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::OnResize Method

This method is called when user resize dialog bar.

void OnResize(
    CRect rcWindow,
    int nHitTest
);
Parameters

rcWindow
CRect object specifying the size of the window.
nHitTest
Specifies the hit-test area code.

Group

CXTPDialogBar Methods


CXTPDialogBar::SetCaption Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::SetCaption Method

Call this member to set the text that will be displayed in the dialog bar's caption popup.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
Text that is displayed in the dialog bar's caption popup.

Remarks

This is the text displayed in the dialog bar's caption popup. The caption popup can be used to indicate what is being displayed in the child window.

Group

CXTPDialogBar Methods


CXTPDialogBar::SetCaptionPopup Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::SetCaptionPopup Method

Call this member to tell the caption popup which CMenu popup to display when the the caption popup is dropped down.

void SetCaptionPopup(
    int nMenuResourceID
);
Parameters

nMenuResourceID
Id of the CMenu resource that contains the popup menu that should be displayed when the caption popup is clicked/displayed.

Remarks

If there is more than one popup on the CMenu resource, then only the first popup on the CMenu will be used.

Group

CXTPDialogBar Methods


CXTPDialogBar::SetCaptionVisible Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::SetCaptionVisible Method

Call this member to hide the caption popup control (and close button).

void SetCaptionVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to hide the caption popup control, FALSE to show it.

Remarks

If bVisible is TRUE, only the commandbar is displayed, the caption popup and close button are hidden.

Group

CXTPDialogBar Methods


CXTPDialogBar::SetChild Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::SetChild Method

Call this member to specify the child window displayed under the dialog bar.

void SetChild(
    CWnd* pChild
);
Parameters

pChild
Pointer to a CWnd object that is displayed under the dialog bar.

Group

CXTPDialogBar Methods


CXTPDialogBar::SetResizable Method

CXTPDialogBar Methods, CXTPDialogBar Class, Body Source
CXTPDialogBar::SetResizable Method

Call this member to specify whether the dialog bar will be re-sizable.

void SetResizable(
    BOOL bResizable
);
Parameters

bResizable
TRUE if the dialog bar can be resized, FALSE to lock the dialog bar.

Remarks

By default, bResizable is TRUE. If FALSE, no splitter is displayed when the mouse pointer is positioned over the dialog bar borders. You can use the SetSize member function to change the size of the dialog bar programmatically.

Body Source
void CXTPDialogBar::SetResizable(BOOL bResizable) {
    m_bResizable = bResizable;
}
Group

CXTPDialogBar Methods


CXTPDialogBar::SetSize Method

CXTPDialogBar Methods, CXTPDialogBar Class
CXTPDialogBar::SetSize Method

Call this member to set the width and height of the dialog bar child window.

void SetSize(
    CSize sz
);
Parameters

sz
The width and height of the dialog bar's child window.

Remarks

The size is only used to size the child window when the dialog bar is floating, then both the specified width and height are used. If the bar is dock on the left or right, only the width is used, the height will depend on how much of the client area the dialog bar can occupy. If the bar is docked on the top or bottom, then only the height is used to size the child window.

Group

CXTPDialogBar Methods


CXTPDialogBar Constructors

CXTPDialogBar Class, Legend, Public Methods
CXTPDialogBar Constructors
Class

CXTPDialogBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDialogBar | Constructs a CXTPDialogBar object


CXTPDialogBar::CXTPDialogBar Constructor

CXTPDialogBar Constructors, CXTPDialogBar Class
CXTPDialogBar::CXTPDialogBar Constructor

Constructs a CXTPDialogBar object

CXTPDialogBar();
Group

CXTPDialogBar Constructors


CXTPDialogBar Destructors

CXTPDialogBar Class, Legend, Public Methods
CXTPDialogBar Destructors
Class

CXTPDialogBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDialogBar | Destroys a CXTPDialogBar object, handles cleanup and deallocation.


CXTPDialogBar::~CXTPDialogBar Destructor

CXTPDialogBar Destructors, CXTPDialogBar Class
CXTPDialogBar::~CXTPDialogBar Destructor

Destroys a CXTPDialogBar object, handles cleanup and deallocation.

virtual ~CXTPDialogBar();
Group

CXTPDialogBar Destructors


CXTPDialogBase Template

XTPDialogBase.h, Classes, Legend, Members, Topics, CXTPDialogBase Methods, CXTPDialogBase Constructors, CXTPDialogBase Destructors, CXTPDialogBase Constructors, CXTPDialogBase Destructors, CXTPDialogBase Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDialogBase Template

CXTPDialogBase is a TBase derived class. It represents the parent class for a CXTPDialog class .

Class Hierarchy

template <class TBase>
class CXTPDialogBase : public TBase;
File

XTPDialogBase.h

Group

Classes

Legend
Method
CXTPDialogBase Constructors
CXTPDialogBase Constructors | Description
CXTPDialogBase |
CXTPDialogBase Destructors
CXTPDialogBase Destructors | Description
~CXTPDialogBase | Destroys a CXTPDialogBase object, handles cleanup and deallocation
CXTPDialogBase Methods
CXTPDialogBase Methods | Description
DockRightOf | This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
GetCommandBars | Call this member to retrieve a pointer to the CommandBars object.
InitCommandBars | Creates command bars.
LoadCommandBars | Call this function to retrieve state information from the registry or .INI file.
SaveCommandBars | Call this function to save the state information to the registry or .INI file.


CXTPDialogBase Methods

CXTPDialogBase Template, Legend, Public Methods
CXTPDialogBase Methods
Template

CXTPDialogBase Template

Legend
Method
Public Methods
Public Methods
Public Method | Description
DockRightOf | This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
GetCommandBars | Call this member to retrieve a pointer to the CommandBars object.
InitCommandBars | Creates command bars.
LoadCommandBars | Call this function to retrieve state information from the registry or .INI file.
SaveCommandBars | Call this function to save the state information to the registry or .INI file.


CXTPDialogBase::DockRightOf Method

CXTPDialogBase Methods, CXTPDialogBase Template, Body Source
CXTPDialogBase::DockRightOf Method

This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.

void DockRightOf(
    CXTPToolBar* pBarToDock,
    CXTPToolBar* pBarOnLeft
);
Parameters

pBarToDock
A CXTPToolBar pointer to the toolbar to be docked.
pBarOnLeft
A CXTPToolBar pointer to the already docked toolbar.

Body Source
void DockRightOf(CXTPToolBar* pBarToDock, CXTPToolBar* pBarOnLeft)
{
    RepositionBars(AFX_IDW_CONTROLBAR_FIRST, AFX_IDW_CONTROLBAR_LAST, AFX_IDW_PANE_FIRST);

    CXTPWindowRect rcBar(pBarOnLeft);

    if (IsVerticalPosition(pBarOnLeft->GetPosition())) rcBar.OffsetRect(0, rcBar.Height());
        else rcBar.OffsetRect(rcBar.Width(), 0);

    GetCommandBars()->DockCommandBar(pBarToDock, rcBar, pBarOnLeft->GetDockBar());
}
Group

CXTPDialogBase Methods


CXTPDialogBase::GetCommandBars Method

CXTPDialogBase Methods, CXTPDialogBase Template, Body Source
CXTPDialogBase::GetCommandBars Method

Call this member to retrieve a pointer to the CommandBars object.

CXTPCommandBars* GetCommandBars() const;
Returns

Retrieves Command Bars object.

Body Source
CXTPCommandBars* GetCommandBars() const { return m_pCommandBars; }
Group

CXTPDialogBase Methods


CXTPDialogBase::InitCommandBars Method

CXTPDialogBase Methods, CXTPDialogBase Template, Body Source
CXTPDialogBase::InitCommandBars Method

Creates command bars.

BOOL InitCommandBars(
    CRuntimeClass* pCommandBarsClass = RUNTIME_CLASS(CXTPCommandBars)
);
Parameters

pCommandBarsClass
Custom runtime class of CommandBars. It can be used if you want to override some methods of CXTPCommandBars class.

Returns

Nonzero if successful; otherwise 0.

Body Source
BOOL InitCommandBars(CRuntimeClass* pCommandBarsClass = RUNTIME_CLASS(CXTPCommandBars))
{
    ASSERT(pCommandBarsClass->IsDerivedFrom(RUNTIME_CLASS(CXTPCommandBars)));
    m_pCommandBars =  (CXTPCommandBars*) pCommandBarsClass->CreateObject();
    ASSERT(m_pCommandBars);
    m_pCommandBars->SetSite(this);
    m_pCommandBars->EnableDocking();
    return TRUE;
}
Group

CXTPDialogBase Methods


CXTPDialogBase::LoadCommandBars Method

CXTPDialogBase Methods, CXTPDialogBase Template, Body Source
CXTPDialogBase::LoadCommandBars Method

Call this function to retrieve state information from the registry or .INI file.

void LoadCommandBars(
    LPCTSTR lpszProfileName,
    BOOL bSilent = FALSE
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
bSilent
TRUE to disable user notifications when command bars are restore to their original state.

Body Source
void LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent = FALSE)
{
    if (m_pCommandBars)
    {
        m_pCommandBars->LoadOptions(lpszProfileName);
        m_pCommandBars->LoadBarState(lpszProfileName, bSilent);
        m_pCommandBars->GetShortcutManager()->LoadShortcuts(lpszProfileName);
    }
}
Group

CXTPDialogBase Methods


CXTPDialogBase::SaveCommandBars Method

CXTPDialogBase Methods, CXTPDialogBase Template, Body Source
CXTPDialogBase::SaveCommandBars Method

Call this function to save the state information to the registry or .INI file.

void SaveCommandBars(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

Body Source
void SaveCommandBars(LPCTSTR lpszProfileName)
{
    if (m_pCommandBars)
    {
        m_pCommandBars->SaveOptions(lpszProfileName);
        m_pCommandBars->SaveBarState(lpszProfileName);
        m_pCommandBars->GetShortcutManager()->SaveShortcuts(lpszProfileName);
    }
}
Group

CXTPDialogBase Methods


CXTPDialogBase Constructors

CXTPDialogBase Template, Legend, Public Methods
CXTPDialogBase Constructors
Template

CXTPDialogBase Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDialogBase |


CXTPDialogBase Constructor

CXTPDialogBase Constructors
CXTPDialogBase Constructor
Overload List
Constructors
Constructor | Description
CXTPDialogBase::CXTPDialogBase () | Constructs a CXTPDialog object
CXTPDialogBase::CXTPDialogBase (LPCTSTR, CWnd*) | Constructs a CXTPDialog object
Group

CXTPDialogBase Constructors


CXTPDialogBase::CXTPDialogBase Constructor ()

CXTPDialogBase Constructor, CXTPDialogBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDialogBase::CXTPDialogBase Constructor ()

Constructs a CXTPDialog object

CXTPDialogBase();
CXTPDialogBase(
    LPCTSTR lpszTemplateName,
    CWnd* pParentWnd = NULL
);
Parameters

lpszTemplateName
Contains a null-terminated string that is the name of a dialog-template resource
pParentWnd
Points to the parent of the DialogBase control
nIDTemplate
Contains the ID number of a dialog-template resource

Body Source
CXTPDialogBase()
{
    m_pCommandBars = 0;
}

CXTPDialogBase(LPCTSTR lpszTemplateName, CWnd* pParentWnd = NULL)
    : TBase(lpszTemplateName, pParentWnd)
{
    m_pCommandBars = 0;
}
Group

CXTPDialogBase Constructor


CXTPDialogBase Destructors

CXTPDialogBase Template, Legend, Public Methods
CXTPDialogBase Destructors
Template

CXTPDialogBase Template

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDialogBase | Destroys a CXTPDialogBase object, handles cleanup and deallocation


CXTPDialogBase::~CXTPDialogBase Destructor

CXTPDialogBase Destructors, CXTPDialogBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDialogBase::~CXTPDialogBase Destructor

Destroys a CXTPDialogBase object, handles cleanup and deallocation

~CXTPDialogBase();
Body Source
~CXTPDialogBase()
{
    if (m_pCommandBars)
    {
        m_pCommandBars->InternalRelease();
    }
}
Group

CXTPDialogBase Destructors


CXTPDockBar Class

XTPDockBar.h, Classes, Legend, Members, Topics, CXTPDockBar Data Members, CXTPDockBar Methods, CXTPDockBar Constructors, CXTPDockBar Destructors, CXTPDockBar Nested Types, CXTPDockBar Constructors, CXTPDockBar Data Members, CXTPDockBar Destructors, CXTPDockBar Methods, CXTPDockBar Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockBar Class

CXTPDockBar is a CWnd derived class. It is used internally by CXTPCommandBars.

Class Hierarchy

class CXTPDockBar : public CWnd;
File

XTPDockBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockBar Constructors
CXTPDockBar Constructors | Description
CXTPDockBar | Constructs a CXTPDockBar object
CXTPDockBar Data Members
CXTPDockBar Data Members | Description
m_arrBars | Toolbar list
m_dwStyle | Style of the control.
m_pCommandBars | Parent CommandBars object
CXTPDockBar Destructors
CXTPDockBar Destructors | Description
~CXTPDockBar | Destroys a CXTPDockBar object, handles cleanup and deallocation.
CXTPDockBar Methods
CXTPDockBar Methods | Description
GetPosition | Retrieves the dockbar position.
IsVerticalPosition | Checks if dockbar is vertical.
CXTPDockBar Nested Types
CXTPDockBar Nested Types | Description
CToolBarArray | Array of CXTPToolBar objects.


CXTPDockBar Data Members

CXTPDockBar Class, Legend, Protected Data Members
CXTPDockBar Data Members
Class

CXTPDockBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrBars | Toolbar list
m_dwStyle | Style of the control.
m_pCommandBars | Parent CommandBars object


CXTPDockBar::m_arrBars Data Member

CXTPDockBar Data Members, CXTPDockBar Class
CXTPDockBar::m_arrBars Data Member

Toolbar list

CToolBarArray m_arrBars;
Group

CXTPDockBar Data Members


CXTPDockBar::m_dwStyle Data Member

CXTPDockBar Data Members, CXTPDockBar Class
CXTPDockBar::m_dwStyle Data Member

Style of the control.

DWORD m_dwStyle;
Group

CXTPDockBar Data Members


CXTPDockBar::m_pCommandBars Data Member

CXTPDockBar Data Members, CXTPDockBar Class
CXTPDockBar::m_pCommandBars Data Member

Parent CommandBars object

CXTPCommandBars* m_pCommandBars;
Group

CXTPDockBar Data Members


CXTPDockBar Methods

CXTPDockBar Class, Legend, Public Methods
CXTPDockBar Methods
Class

CXTPDockBar Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetPosition | Retrieves the dockbar position.
IsVerticalPosition | Checks if dockbar is vertical.


CXTPDockBar::GetPosition Method

CXTPDockBar Methods, CXTPDockBar Class
CXTPDockBar::GetPosition Method

Retrieves the dockbar position.

XTPBarPosition GetPosition() const;
Returns

Position of the dock bar.

Group

CXTPDockBar Methods


CXTPDockBar::IsVerticalPosition Method

CXTPDockBar Methods, CXTPDockBar Class
CXTPDockBar::IsVerticalPosition Method

Checks if dockbar is vertical.

BOOL IsVerticalPosition() const;
Returns

TRUE if docked vertically; otherwise returns FALSE

Group

CXTPDockBar Methods


CXTPDockBar Constructors

CXTPDockBar Class, Legend, Public Methods
CXTPDockBar Constructors
Class

CXTPDockBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockBar | Constructs a CXTPDockBar object


CXTPDockBar::CXTPDockBar Constructor

CXTPDockBar Constructors, CXTPDockBar Class
CXTPDockBar::CXTPDockBar Constructor

Constructs a CXTPDockBar object

CXTPDockBar();
Group

CXTPDockBar Constructors


CXTPDockBar Destructors

CXTPDockBar Class, Legend, Public Methods
CXTPDockBar Destructors
Class

CXTPDockBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockBar | Destroys a CXTPDockBar object, handles cleanup and deallocation.


CXTPDockBar::~CXTPDockBar Destructor

CXTPDockBar Destructors, CXTPDockBar Class
CXTPDockBar::~CXTPDockBar Destructor

Destroys a CXTPDockBar object, handles cleanup and deallocation.

virtual ~CXTPDockBar();
Group

CXTPDockBar Destructors


CXTPDockBar Nested Types

CXTPDockBar Class, Public Nested Types
CXTPDockBar Nested Types
Class

CXTPDockBar Class

Public Nested Types
Public Nested Type | Description
CToolBarArray | Array of CXTPToolBar objects.


CXTPDockBar::CToolBarArray Nested Type

CXTPDockBar Nested Types, CXTPDockBar Class
CXTPDockBar::CToolBarArray Nested Type

Array of CXTPToolBar objects.

typedef CArray<CXTPToolBar*, CXTPToolBar*> CToolBarArray;
Group

CXTPDockBar Nested Types


CXTPDockContext Class

XTPDockContext.h, Classes, Legend, Members, Topics, CXTPDockContext Data Members, CXTPDockContext Methods, CXTPDockContext Constructors, CXTPDockContext Destructors, CXTPDockContext Constructors, CXTPDockContext Data Members, CXTPDockContext Destructors, CXTPDockContext Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockContext Class

CXTPDockContext is a stand alone class. It is used internally by CXTPToolBar.

Class Hierarchy

class CXTPDockContext;
File

XTPDockContext.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockContext Constructors
CXTPDockContext Constructors | Description
CXTPDockContext | Constructs a CXTPDockContext object
CXTPDockContext Data Members
CXTPDockContext Data Members | Description
m_nHitTest | Hit Test code
m_pBar | Child toolbar.
m_ptLast | Last mouse position.
m_ptMRUFloatPos | Last floating rectangle
m_rectDragDock | Current docking rectangle
m_rectDragFrame | Current floating rectangle.
m_rectMRUDockPos | Last docking rectangle.
m_uMRUDockPosition | Last docking position.
CXTPDockContext Destructors
CXTPDockContext Destructors | Description
~CXTPDockContext | Destroys a CXTPDockContext object, handles cleanup and deallocation.
CXTPDockContext Methods
CXTPDockContext Methods | Description
Move | This method is called to move child toolbar to the specified position
Resize | This method is called to move child toolbar to resize child dialog bar.
StartDrag | This method is called when the user starts to move the toolbar.
StartResize | This method is called when the user starts to resize the toolbar.
Stretch | This method is called to stretch child toolbar.
ToggleDocking | This method is called to switch the docking position of the toolbar.
Track | This method is called to start tracking loop


CXTPDockContext Data Members

CXTPDockContext Class, Legend, Protected Data Members
CXTPDockContext Data Members
Class

CXTPDockContext Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nHitTest | Hit Test code
m_pBar | Child toolbar.
m_ptLast | Last mouse position.
m_ptMRUFloatPos | Last floating rectangle
m_rectDragDock | Current docking rectangle
m_rectDragFrame | Current floating rectangle.
m_rectMRUDockPos | Last docking rectangle.
m_uMRUDockPosition | Last docking position.


CXTPDockContext::m_nHitTest Data Member

CXTPDockContext Data Members, CXTPDockContext Class
CXTPDockContext::m_nHitTest Data Member

Hit Test code

int m_nHitTest;
Group

CXTPDockContext Data Members


CXTPDockContext::m_pBar Data Member

CXTPDockContext Data Members, CXTPDockContext Class
CXTPDockContext::m_pBar Data Member

Child toolbar.

CXTPToolBar* m_pBar;
Group

CXTPDockContext Data Members


CXTPDockContext::m_ptLast Data Member

CXTPDockContext Data Members, CXTPDockContext Class
CXTPDockContext::m_ptLast Data Member

Last mouse position.

CPoint m_ptLast;
Group

CXTPDockContext Data Members


CXTPDockContext::m_ptMRUFloatPos Data Member

CXTPDockContext Data Members, CXTPDockContext Class
CXTPDockContext::m_ptMRUFloatPos Data Member

Last floating rectangle

CPoint m_ptMRUFloatPos;
Group

CXTPDockContext Data Members


CXTPDockContext::m_rectDragDock Data Member

CXTPDockContext Data Members, CXTPDockContext Class
CXTPDockContext::m_rectDragDock Data Member

Current docking rectangle

CRect m_rectDragDock;
Group

CXTPDockContext Data Members


CXTPDockContext::m_rectDragFrame Data Member

CXTPDockContext Data Members, CXTPDockContext Class
CXTPDockContext::m_rectDragFrame Data Member

Current floating rectangle.

CRect m_rectDragFrame;
Group

CXTPDockContext Data Members


CXTPDockContext::m_rectMRUDockPos Data Member

CXTPDockContext Data Members, CXTPDockContext Class
CXTPDockContext::m_rectMRUDockPos Data Member

Last docking rectangle.

CRect m_rectMRUDockPos;
Group

CXTPDockContext Data Members


CXTPDockContext::m_uMRUDockPosition Data Member

CXTPDockContext Data Members, CXTPDockContext Class
CXTPDockContext::m_uMRUDockPosition Data Member

Last docking position.

XTPBarPosition m_uMRUDockPosition;
Group

CXTPDockContext Data Members


CXTPDockContext Methods

CXTPDockContext Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockContext Methods
Class

CXTPDockContext Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Move | This method is called to move child toolbar to the specified position
Resize | This method is called to move child toolbar to resize child dialog bar.
Stretch | This method is called to stretch child toolbar.
Track | This method is called to start tracking loop
Public Methods
Public Methods
Public Method | Description
StartDrag | This method is called when the user starts to move the toolbar.
StartResize | This method is called when the user starts to resize the toolbar.
ToggleDocking | This method is called to switch the docking position of the toolbar.


CXTPDockContext::Move Method

CXTPDockContext Methods, CXTPDockContext Class
CXTPDockContext::Move Method

This method is called to move child toolbar to the specified position

void Move(
    CPoint pt
);
Parameters

pt
CPoint object specifies xy coordinates.

Group

CXTPDockContext Methods


CXTPDockContext::Resize Method

CXTPDockContext Methods, CXTPDockContext Class
CXTPDockContext::Resize Method

This method is called to move child toolbar to resize child dialog bar.

void Resize(
    CPoint pt
);
Parameters

pt
CPoint object specifies xy coordinates.

Group

CXTPDockContext Methods


CXTPDockContext::StartDrag Method

CXTPDockContext Methods, CXTPDockContext Class
CXTPDockContext::StartDrag Method

This method is called when the user starts to move the toolbar.

virtual void StartDrag(
    CPoint pt
);
Parameters

pt
Initial cursor position.

Group

CXTPDockContext Methods


CXTPDockContext::StartResize Method

CXTPDockContext Methods, CXTPDockContext Class
CXTPDockContext::StartResize Method

This method is called when the user starts to resize the toolbar.

virtual void StartResize(
    int nHitTest,
    CPoint pt
);
Parameters

nHitTest
Specifies the hit-test area code.
pt
Initial cursor position.

Group

CXTPDockContext Methods


CXTPDockContext::Stretch Method

CXTPDockContext Methods, CXTPDockContext Class
CXTPDockContext::Stretch Method

This method is called to stretch child toolbar.

void Stretch(
    CPoint pt
);
Parameters

pt
CPoint object specifies xy coordinates.

Group

CXTPDockContext Methods


CXTPDockContext::ToggleDocking Method

CXTPDockContext Methods, CXTPDockContext Class
CXTPDockContext::ToggleDocking Method

This method is called to switch the docking position of the toolbar.

virtual BOOL ToggleDocking();
Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPDockContext Methods


CXTPDockContext::Track Method

CXTPDockContext Methods, CXTPDockContext Class
CXTPDockContext::Track Method

This method is called to start tracking loop

virtual void Track();
Group

CXTPDockContext Methods


CXTPDockContext Constructors

CXTPDockContext Class, Legend, Public Methods
CXTPDockContext Constructors
Class

CXTPDockContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockContext | Constructs a CXTPDockContext object


CXTPDockContext::CXTPDockContext Constructor

CXTPDockContext Constructors, CXTPDockContext Class
CXTPDockContext::CXTPDockContext Constructor

Constructs a CXTPDockContext object

CXTPDockContext(
    CXTPToolBar* pBar
);
Parameters

pBar
Points to a CXTPToolBar object

Group

CXTPDockContext Constructors


CXTPDockContext Destructors

CXTPDockContext Class, Legend, Public Methods
CXTPDockContext Destructors
Class

CXTPDockContext Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockContext | Destroys a CXTPDockContext object, handles cleanup and deallocation.


CXTPDockContext::~CXTPDockContext Destructor

CXTPDockContext Destructors, CXTPDockContext Class
CXTPDockContext::~CXTPDockContext Destructor

Destroys a CXTPDockContext object, handles cleanup and deallocation.

virtual ~CXTPDockContext();
Group

CXTPDockContext Destructors


CXTPDockState Class

XTPDockState.h, Classes, Legend, Members, Topics, CXTPDockState Methods, CXTPDockState Constructors, CXTPDockState Destructors, CXTPDockState Nested Types, CXTPDockState Constructors, CXTPDockState Destructors, CXTPDockState Methods, CXTPDockState Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockState Class

CXTPDockState is a stand alone class. It is used internally by CXTPToolBar.

Class Hierarchy

class CXTPDockState;
File

XTPDockState.h

Group

Classes

Legend
Method
CXTPDockState Constructors
CXTPDockState Constructors | Description
CXTPDockState | Constructs a CXTPDockState object.
CXTPDockState Destructors
CXTPDockState Destructors | Description
~CXTPDockState | Destroys a CXTPDockState object, handles cleanup and deallocation.
CXTPDockState Methods
CXTPDockState Methods | Description
DoPropExchange | Reads or writes options from or to an archive.
GetVersion | Call this function to retrieve the version number of the stored bar state
LoadState | Call this function to retrieve state information from the registry or .INI file.
SaveState | Call this function to save the state information to the registry or .INI file
ScalePoint | Maps the point from the stored coordinates to the device.
ScaleRectPos | Maps the point from the stored coordinates to the device.
CXTPDockState Nested Types
CXTPDockState Nested Types | Description
TOOLBARINFO | TOOLBARINFO definition


CXTPDockState Methods

CXTPDockState Class, Legend, Public Methods
CXTPDockState Methods
Class

CXTPDockState Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Reads or writes options from or to an archive.
GetVersion | Call this function to retrieve the version number of the stored bar state
LoadState | Call this function to retrieve state information from the registry or .INI file.
SaveState | Call this function to save the state information to the registry or .INI file
ScalePoint | Maps the point from the stored coordinates to the device.
ScaleRectPos | Maps the point from the stored coordinates to the device.


CXTPDockState::DoPropExchange Method

CXTPDockState Methods, CXTPDockState Class, See Also
CXTPDockState::DoPropExchange Method

Reads or writes options from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

See Also

CXTPCommandBars::DoPropExchange

Group

CXTPDockState Methods


CXTPDockState::GetVersion Method

CXTPDockState Methods, CXTPDockState Class, Body Source
CXTPDockState::GetVersion Method

Call this function to retrieve the version number of the stored bar state

DWORD GetVersion() const;
Body Source
DWORD CXTPDockState::GetVersion() const {
    return m_dwVersion;
}
Group

CXTPDockState Methods


CXTPDockState::LoadState Method

CXTPDockState Methods, CXTPDockState Class
CXTPDockState::LoadState Method

Call this function to retrieve state information from the registry or .INI file.

void LoadState(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-teminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

Group

CXTPDockState Methods


CXTPDockState::SaveState Method

CXTPDockState Methods, CXTPDockState Class
CXTPDockState::SaveState Method

Call this function to save the state information to the registry or .INI file

void SaveState(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-teminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

Group

CXTPDockState Methods


CXTPDockState::ScalePoint Method

CXTPDockState Methods, CXTPDockState Class
CXTPDockState::ScalePoint Method

Maps the point from the stored coordinates to the device.

void ScalePoint(
    CPoint& pt
);
Parameters

pt
Specifies the point to be tested

Group

CXTPDockState Methods


CXTPDockState::ScaleRectPos Method

CXTPDockState Methods, CXTPDockState Class
CXTPDockState::ScaleRectPos Method

Maps the point from the stored coordinates to the device.

void ScaleRectPos(
    CRect& rect
);
Parameters

rect
A reference to a CRect object

Group

CXTPDockState Methods


CXTPDockState Constructors

CXTPDockState Class, Legend, Public Methods
CXTPDockState Constructors
Class

CXTPDockState Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockState | Constructs a CXTPDockState object.


CXTPDockState::CXTPDockState Constructor

CXTPDockState Constructors, CXTPDockState Class
CXTPDockState::CXTPDockState Constructor

Constructs a CXTPDockState object.

CXTPDockState();
Group

CXTPDockState Constructors


CXTPDockState Destructors

CXTPDockState Class, Legend, Public Methods
CXTPDockState Destructors
Class

CXTPDockState Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockState | Destroys a CXTPDockState object, handles cleanup and deallocation.


CXTPDockState::~CXTPDockState Destructor

CXTPDockState Destructors, CXTPDockState Class
CXTPDockState::~CXTPDockState Destructor

Destroys a CXTPDockState object, handles cleanup and deallocation.

~CXTPDockState();
Group

CXTPDockState Destructors


CXTPDockState Nested Types

CXTPDockState Class, Public Nested Types
CXTPDockState Nested Types
Class

CXTPDockState Class

Public Nested Types
Public Nested Type | Description
TOOLBARINFO | TOOLBARINFO definition


CXTPDockState::TOOLBARINFO Nested Type

CXTPDockState Nested Types, CXTPDockState Class
CXTPDockState::TOOLBARINFO Nested Type

TOOLBARINFO definition

typedef CXTPToolBar::CToolBarInfo TOOLBARINFO;
Group

CXTPDockState Nested Types


CXTPEdit Class

XTPControlComboBox.h, Classes, Legend, Members, Topics, CXTPEdit Data Members, CXTPEdit Methods, CXTPEdit Constructors, CXTPEdit Constructors, CXTPEdit Data Members, CXTPEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPEdit Class

CXTPEdit is a CEdit derived class. It is for internal usage only.

Class Hierarchy

class CXTPEdit : public CEdit;
File

XTPControlComboBox.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPEdit Constructors
CXTPEdit Constructors | Description
CXTPEdit | Constructs a CXTPEdit object
CXTPEdit Data Members
CXTPEdit Data Members | Description
m_bComposited | TRUE if control is AERO composited.
m_bImeMode | TRUE if IME editor currently enabled.
CXTPEdit Methods
CXTPEdit Methods | Description
CreateEdit | This member function displays a popup context menu.
GetRichEditContext | Call this method to get rich edit version information.
GetWindowTextEx | Returns window text of edit
IsCommandEnabled | Determines if edit command is enable,
IsDialogCode | This method determines whether the specified character is intended for a edit. If it is, this method processes the message.
OnCmdMsg | Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.
OnCommand | The framework calls this member function when the user selects an item from a menu, when a child control sends a notification message, or when an accelerator keystroke is translated.
ShowContextMenu | This member function displays a popup context menu.


CXTPEdit Data Members

CXTPEdit Class, Legend, Protected Data Members
CXTPEdit Data Members
Class

CXTPEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bComposited | TRUE if control is AERO composited.
m_bImeMode | TRUE if IME editor currently enabled.


CXTPEdit::m_bComposited Data Member

CXTPEdit Data Members, CXTPEdit Class
CXTPEdit::m_bComposited Data Member

TRUE if control is AERO composited.

BOOL m_bComposited;
Group

CXTPEdit Data Members


CXTPEdit::m_bImeMode Data Member

CXTPEdit Data Members, CXTPEdit Class
CXTPEdit::m_bImeMode Data Member

TRUE if IME editor currently enabled.

BOOL m_bImeMode;
Group

CXTPEdit Data Members


CXTPEdit Methods

CXTPEdit Class, Legend, Protected Methods, Public Methods
CXTPEdit Methods
Class

CXTPEdit Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetRichEditContext | Call this method to get rich edit version information.
IsCommandEnabled | Determines if edit command is enable,
Public Methods
Public Methods
Public Method | Description
CreateEdit | This member function displays a popup context menu.
GetWindowTextEx | Returns window text of edit
IsDialogCode | This method determines whether the specified character is intended for a edit. If it is, this method processes the message.
OnCmdMsg | Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.
OnCommand | The framework calls this member function when the user selects an item from a menu, when a child control sends a notification message, or when an accelerator keystroke is translated.
ShowContextMenu | This member function displays a popup context menu.


CXTPEdit::CreateEdit Method

CXTPEdit Methods, CXTPEdit Class
CXTPEdit::CreateEdit Method

This member function displays a popup context menu.

virtual BOOL CreateEdit(
    DWORD dwStyle,
    CWnd* pParentWnd
);
Parameters

dwStyle
Specifies object's style flags.
pParentWnd
Pointer to the parent window.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPEdit Methods


CXTPEdit::GetRichEditContext Method

CXTPEdit Methods, CXTPEdit Class
CXTPEdit::GetRichEditContext Method

Call this method to get rich edit version information.

CRichEditContext& GetRichEditContext();
Group

CXTPEdit Methods


CXTPEdit::GetWindowTextEx Method

CXTPEdit Methods, CXTPEdit Class
CXTPEdit::GetWindowTextEx Method

Returns window text of edit

void GetWindowTextEx(
    CString& rString
);
Parameters

rString
String to return text

Group

CXTPEdit Methods


CXTPEdit::IsCommandEnabled Method

CXTPEdit Methods, CXTPEdit Class
CXTPEdit::IsCommandEnabled Method

Determines if edit command is enable,

BOOL IsCommandEnabled(
    UINT nID
);
Parameters

nID
Edit command

Returns

TRUE if edit command is enabled for control

Group

CXTPEdit Methods


CXTPEdit::IsDialogCode Method

CXTPEdit Methods, CXTPEdit Class
CXTPEdit::IsDialogCode Method

This method determines whether the specified character is intended for a edit. If it is, this method processes the message.

BOOL IsDialogCode(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPEdit Methods


CXTPEdit::OnCmdMsg Method

CXTPEdit Methods, CXTPEdit Class
CXTPEdit::OnCmdMsg Method

Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.

virtual BOOL OnCmdMsg(
    UINT nID,
    int nCode,
    void* pExtra,
    AFX_CMDHANDLERINFO* pHandlerInfo
);
Parameters

nID
Contains the command ID.
nCode
Identifies the command notification code.
pExtra
Used according to the value of nCode.
pHandlerInfo
If not NULL, OnCmdMsg fills in the pTarget and pmf members of the pHandlerInfo structure instead of dispatching the command. Typically, this parameter should be NULL.

Returns

Nonzero if the message is handled; otherwise 0.

Group

CXTPEdit Methods


CXTPEdit::OnCommand Method

CXTPEdit Methods, CXTPEdit Class
CXTPEdit::OnCommand Method

The framework calls this member function when the user selects an item from a menu, when a child control sends a notification message, or when an accelerator keystroke is translated.

virtual BOOL OnCommand(
    WPARAM wParam,
    LPARAM lParam
);
Parameters

wParam
The low-order word of wParam identifies the command ID of the menu item, control, or accelerator. The high-order word of wParam specifies the notification message if the message is from a control. If the message is from an accelerator, the high-order word is 1. If the message is from a menu, the high-order word is 0.
lParam
Specifies additional message-dependent information.

Returns

An application returns nonzero if it processes this message; otherwise 0.

Group

CXTPEdit Methods


CXTPEdit::ShowContextMenu Method

CXTPEdit Methods, CXTPEdit Class
CXTPEdit::ShowContextMenu Method

This member function displays a popup context menu.

virtual BOOL ShowContextMenu(
    CXTPControl* pControl,
    CPoint point
);
Parameters

pControl
Pointer to a CXTPControl control.
point
CPoint object specifies xy coordinates.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPEdit Methods


CXTPEdit Constructors

CXTPEdit Class, Legend, Public Methods
CXTPEdit Constructors
Class

CXTPEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPEdit | Constructs a CXTPEdit object


CXTPEdit::CXTPEdit Constructor

CXTPEdit Constructors, CXTPEdit Class
CXTPEdit::CXTPEdit Constructor

Constructs a CXTPEdit object

CXTPEdit();
Group

CXTPEdit Constructors


CXTPFrameWnd Class

XTPFrameWnd.h, Classes, Legend, Members, Topics, CXTPFrameWnd Constructors, CXTPFrameWnd Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPFrameWnd Class

CXTPFrameWnd is a CXTPFrameWndBase derived class.

Class Hierarchy

class CXTPFrameWnd : public CXTPFrameWndBase<CFrameWnd>;
File

XTPFrameWnd.h

Group

Classes

Legend
Constructor
CXTPFrameWnd Constructors
CXTPFrameWnd Constructors | Description
CXTPFrameWnd | Constructs a CXTPFrameWnd object


CXTPFrameWnd Constructors

CXTPFrameWnd Class, Legend, Public Methods
CXTPFrameWnd Constructors
Class

CXTPFrameWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPFrameWnd | Constructs a CXTPFrameWnd object


CXTPFrameWnd::CXTPFrameWnd Constructor

CXTPFrameWnd Constructors, CXTPFrameWnd Class
CXTPFrameWnd::CXTPFrameWnd Constructor

Constructs a CXTPFrameWnd object

CXTPFrameWnd();
Group

CXTPFrameWnd Constructors


CXTPFrameWndBase Template

XTPFrameWnd.h, Classes, Legend, Members, Topics, CXTPFrameWndBase Constructors, CXTPFrameWndBase Destructors, CXTPFrameWndBase Constructors, CXTPFrameWndBase Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPFrameWndBase Template

CXTPFrameWndBase is a stand alone class. It represents the parent class for a CXTPMDIFrameWnd and CXTPFrameWnd classes .

Class Hierarchy

template <class TBase>
class CXTPFrameWndBase : public CXTPCommandBarsSiteBase<TBase>;
File

XTPFrameWnd.h

Group

Classes

Legend
Constructor
CXTPFrameWndBase Constructors
CXTPFrameWndBase Constructors | Description
CXTPFrameWndBase | Constructs a CXTPFrameWndBase object
CXTPFrameWndBase Destructors
CXTPFrameWndBase Destructors | Description
~CXTPFrameWndBase | Destroys a CXTPFrameWndBase object, handles cleanup and deallocation


CXTPFrameWndBase Constructors

CXTPFrameWndBase Template, Legend, Public Methods
CXTPFrameWndBase Constructors
Template

CXTPFrameWndBase Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPFrameWndBase | Constructs a CXTPFrameWndBase object


CXTPFrameWndBase::CXTPFrameWndBase Constructor

CXTPFrameWndBase Constructors, CXTPFrameWndBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPFrameWndBase::CXTPFrameWndBase Constructor

Constructs a CXTPFrameWndBase object

CXTPFrameWndBase();
Body Source
CXTPFrameWndBase()
{
}
Group

CXTPFrameWndBase Constructors


CXTPFrameWndBase Destructors

CXTPFrameWndBase Template, Legend, Public Methods
CXTPFrameWndBase Destructors
Template

CXTPFrameWndBase Template

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPFrameWndBase | Destroys a CXTPFrameWndBase object, handles cleanup and deallocation


CXTPFrameWndBase::~CXTPFrameWndBase Destructor

CXTPFrameWndBase Destructors, CXTPFrameWndBase Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPFrameWndBase::~CXTPFrameWndBase Destructor

Destroys a CXTPFrameWndBase object, handles cleanup and deallocation

~CXTPFrameWndBase();
Body Source
~CXTPFrameWndBase()
{
}
Group

CXTPFrameWndBase Destructors


CXTPGroupLine Class

XTPCustomizeOptionsPage.h, Classes, Legend, Members, Topics, CXTPGroupLine Constructors, CXTPGroupLine Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPGroupLine Class

CXTPGroupLine is a CStatic derived class. It used in CXTPCustomizeOptionsPage page to draw group line static control.

Class Hierarchy

class CXTPGroupLine : public CStatic;
File

XTPCustomizeOptionsPage.h

Group

Classes

Legend
Constructor
CXTPGroupLine Constructors
CXTPGroupLine Constructors | Description
CXTPGroupLine | Constructs a CXTPGroupLine object


CXTPGroupLine Constructors

CXTPGroupLine Class, Legend, Public Methods
CXTPGroupLine Constructors
Class

CXTPGroupLine Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPGroupLine | Constructs a CXTPGroupLine object


CXTPGroupLine::CXTPGroupLine Constructor

CXTPGroupLine Constructors, CXTPGroupLine Class
CXTPGroupLine::CXTPGroupLine Constructor

Constructs a CXTPGroupLine object

CXTPGroupLine();
Group

CXTPGroupLine Constructors


CXTPImageEditorDlg Class

XTPImageEditor.h, Classes, Legend, Members, Topics, CXTPImageEditorDlg Methods, CXTPImageEditorDlg Constructors, CXTPImageEditorDlg Constructors, CXTPImageEditorDlg Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageEditorDlg Class

CXTPImageEditorDlg is a CDialog derived class. It represents the dialog for icons edition.

Class Hierarchy

class CXTPImageEditorDlg : public CDialog;
File

XTPImageEditor.h

Group

Classes

Legend
Method
CXTPImageEditorDlg Constructors
CXTPImageEditorDlg Constructors | Description
CXTPImageEditorDlg | Constructs a CXTPImageEditorDlg object
CXTPImageEditorDlg Methods
CXTPImageEditorDlg Methods | Description
GetIcon | Retrieves the edited icon
SetIcon | Sets the icon to edit
SetIconSize | Sets the icon size to edit.


CXTPImageEditorDlg Methods

CXTPImageEditorDlg Class, Legend, Public Methods
CXTPImageEditorDlg Methods
Class

CXTPImageEditorDlg Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetIcon | Retrieves the edited icon
SetIcon | Sets the icon to edit
SetIconSize | Sets the icon size to edit.


CXTPImageEditorDlg::GetIcon Method

CXTPImageEditorDlg Methods, CXTPImageEditorDlg Class
CXTPImageEditorDlg::GetIcon Method

Retrieves the edited icon

void GetIcon(
    CXTPImageManagerIconHandle* pHandle
);
Parameters

pHandle
Handle of the icon

Group

CXTPImageEditorDlg Methods


CXTPImageEditorDlg::SetIcon Method

CXTPImageEditorDlg Methods, CXTPImageEditorDlg Class
CXTPImageEditorDlg::SetIcon Method

Sets the icon to edit

void SetIcon(
    CXTPImageManagerIconHandle& pHandle
);
Parameters

pHandle
Reference to a CXTPImageManagerIconHandle object that represents the handle of the icon.

Group

CXTPImageEditorDlg Methods


CXTPImageEditorDlg::SetIconSize Method

CXTPImageEditorDlg Methods, CXTPImageEditorDlg Class
CXTPImageEditorDlg::SetIconSize Method

Sets the icon size to edit.

void SetIconSize(
    CSize szIcon
);
Parameters

szIcon
Icon size.

Group

CXTPImageEditorDlg Methods


CXTPImageEditorDlg Constructors

CXTPImageEditorDlg Class, Legend, Public Methods
CXTPImageEditorDlg Constructors
Class

CXTPImageEditorDlg Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageEditorDlg | Constructs a CXTPImageEditorDlg object


CXTPImageEditorDlg::CXTPImageEditorDlg Constructor

CXTPImageEditorDlg Constructors, CXTPImageEditorDlg Class
CXTPImageEditorDlg::CXTPImageEditorDlg Constructor

Constructs a CXTPImageEditorDlg object

CXTPImageEditorDlg(
    CWnd* pParent = NULL,
    BOOL bCommandBarsEditor = FALSE
);
Parameters

pParent
Points to the objects parent window.
bCommandBarsEditor
TRUE if Dialog used in Customize mode

Group

CXTPImageEditorDlg Constructors


CXTPMDIFrameWnd Class

XTPFrameWnd.h, Classes, Legend, Members, Topics, CXTPMDIFrameWnd Constructors, CXTPMDIFrameWnd Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMDIFrameWnd Class

CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.

Class Hierarchy

class CXTPMDIFrameWnd : public CXTPFrameWndBase<CMDIFrameWnd>;
File

XTPFrameWnd.h

Group

Classes

Legend
Constructor
CXTPMDIFrameWnd Constructors
CXTPMDIFrameWnd Constructors | Description
CXTPMDIFrameWnd | Constructs a CXTPMDIFrameWnd object


CXTPMDIFrameWnd Constructors

CXTPMDIFrameWnd Class, Legend, Public Methods
CXTPMDIFrameWnd Constructors
Class

CXTPMDIFrameWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPMDIFrameWnd | Constructs a CXTPMDIFrameWnd object


CXTPMDIFrameWnd::CXTPMDIFrameWnd Constructor

CXTPMDIFrameWnd Constructors, CXTPMDIFrameWnd Class
CXTPMDIFrameWnd::CXTPMDIFrameWnd Constructor

Constructs a CXTPMDIFrameWnd object

CXTPMDIFrameWnd();
Group

CXTPMDIFrameWnd Constructors


CXTPMenuBar Class

XTPMenuBar.h, Classes, Legend, Members, Topics, CXTPMenuBar Data Members, CXTPMenuBar Methods, CXTPMenuBar Constructors, CXTPMenuBar Destructors, CXTPMenuBar Constructors, CXTPMenuBar Data Members, CXTPMenuBar Destructors, CXTPMenuBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBar Class

CXTPMenuBar is a CXTPToolBar derived class. It represents menu bar of frame window.

Class Hierarchy

class CXTPMenuBar : public CXTPToolBar;
File

XTPMenuBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPMenuBar Constructors
CXTPMenuBar Constructors | Description
CXTPMenuBar | Constructs a CXTPMenuBar object
CXTPMenuBar Data Members
CXTPMenuBar Data Members | Description
m_bMdiApp | TRUE if parent frame is CMDIFrameWnd derived.
m_hMenuDefault | Default menu handle.
m_hWndActiveChild | Active MDI window handle.
m_nIDResource | Resource of default menu.
m_nIDResourceCurrent | Currently active menu.
m_pMDIMenus | MDI menus.
CXTPMenuBar Destructors
CXTPMenuBar Destructors | Description
~CXTPMenuBar | Destroys a CXTPMenuBar object, handles cleanup and deallocation
CXTPMenuBar Methods
CXTPMenuBar Methods | Description
AddMDIMenu | Call this method to manually load MDI menu in application initialization
Copy | This method makes a copy of the command bar.
DoPropExchange | Reads or writes this object from or to an archive.
FreeMDIMenus | Destroy all MDI menus.
GenerateCommandBarList | This method is called to assign self identifiers for serialization process.
GetActiveMdiChildWnd | Retrieves active MDI child window handle
GetCurrentMenuResource | Call this method to retrieve identifier of currently visible menu
GetDefaultMenuResource | Call this method to retrieve identifier of default menu
GetMDIMenus | Retrieves collection of application MDI menus
LoadMenuBar | Loads the menu from resource.
OnHookMessage | This member function is called by WindowProc, or is called during message reflection.
RefreshMenu | This member function will refresh the menus
RefreshSysButtons | This method is called to update system buttons of menu bar.
Reset | Resets the controls to their original state.
RestoreCommandBarList | This method is called in serialization process.to restore popups from list of command bars.
SetupHook | This method is called create hooks for main window .
ShouldSerializeBar | This method is called to check if Toolbar was changed and have to be saved
SwitchActiveMenu | This method is called to switch menu to active document menu.
SwitchMDIMenu |
SyncActiveMdiChild | This method is called to update active mdi window hooks.


CXTPMenuBar Data Members

CXTPMenuBar Class, Legend, Protected Data Members
CXTPMenuBar Data Members
Class

CXTPMenuBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bMdiApp | TRUE if parent frame is CMDIFrameWnd derived.
m_hMenuDefault | Default menu handle.
m_hWndActiveChild | Active MDI window handle.
m_nIDResource | Resource of default menu.
m_nIDResourceCurrent | Currently active menu.
m_pMDIMenus | MDI menus.


CXTPMenuBar::m_bMdiApp Data Member

CXTPMenuBar Data Members, CXTPMenuBar Class
CXTPMenuBar::m_bMdiApp Data Member

TRUE if parent frame is CMDIFrameWnd derived.

BOOL m_bMdiApp;
Group

CXTPMenuBar Data Members


CXTPMenuBar::m_hMenuDefault Data Member

CXTPMenuBar Data Members, CXTPMenuBar Class
CXTPMenuBar::m_hMenuDefault Data Member

Default menu handle.

HMENU m_hMenuDefault;
Group

CXTPMenuBar Data Members


CXTPMenuBar::m_hWndActiveChild Data Member

CXTPMenuBar Data Members, CXTPMenuBar Class
CXTPMenuBar::m_hWndActiveChild Data Member

Active MDI window handle.

HWND m_hWndActiveChild;
Group

CXTPMenuBar Data Members


CXTPMenuBar::m_nIDResource Data Member

CXTPMenuBar Data Members, CXTPMenuBar Class
CXTPMenuBar::m_nIDResource Data Member

Resource of default menu.

UINT m_nIDResource;
Group

CXTPMenuBar Data Members


CXTPMenuBar::m_nIDResourceCurrent Data Member

CXTPMenuBar Data Members, CXTPMenuBar Class
CXTPMenuBar::m_nIDResourceCurrent Data Member

Currently active menu.

UINT m_nIDResourceCurrent;
Group

CXTPMenuBar Data Members


CXTPMenuBar::m_pMDIMenus Data Member

CXTPMenuBar Data Members, CXTPMenuBar Class
CXTPMenuBar::m_pMDIMenus Data Member

MDI menus.

CXTPMenuBarMDIMenus* m_pMDIMenus;
Group

CXTPMenuBar Data Members


CXTPMenuBar Methods

CXTPMenuBar Class, Legend, Protected Methods, Public Methods
CXTPMenuBar Methods
Class

CXTPMenuBar Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method makes a copy of the command bar.
DoPropExchange | Reads or writes this object from or to an archive.
GenerateCommandBarList | This method is called to assign self identifiers for serialization process.
GetActiveMdiChildWnd | Retrieves active MDI child window handle
OnHookMessage | This member function is called by WindowProc, or is called during message reflection.
RefreshSysButtons | This method is called to update system buttons of menu bar.
RestoreCommandBarList | This method is called in serialization process.to restore popups from list of command bars.
SetupHook | This method is called create hooks for main window .
ShouldSerializeBar | This method is called to check if Toolbar was changed and have to be saved
SwitchMDIMenu |
SyncActiveMdiChild | This method is called to update active mdi window hooks.
Public Methods
Public Methods
Public Method | Description
AddMDIMenu | Call this method to manually load MDI menu in application initialization
FreeMDIMenus | Destroy all MDI menus.
GetCurrentMenuResource | Call this method to retrieve identifier of currently visible menu
GetDefaultMenuResource | Call this method to retrieve identifier of default menu
GetMDIMenus | Retrieves collection of application MDI menus
LoadMenuBar | Loads the menu from resource.
RefreshMenu | This member function will refresh the menus
Reset | Resets the controls to their original state.
SwitchActiveMenu | This method is called to switch menu to active document menu.


CXTPMenuBar::AddMDIMenu Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::AddMDIMenu Method

Call this method to manually load MDI menu in application initialization

CXTPMenuBarMDIMenuInfo* AddMDIMenu(
    UINT nIDResource
);
Parameters

nIDResource
Template identifier

Group

CXTPMenuBar Methods


CXTPMenuBar::Copy Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::Copy Method

This method makes a copy of the command bar.

virtual void Copy(
    CXTPCommandBar* pCommandBar,
    BOOL bRecursive = FALSE
);
Parameters

pCommandBar
Command bar needed to be copied.
bRecursive
TRUE to copy recursively.

Group

CXTPMenuBar Methods


CXTPMenuBar::DoPropExchange Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPMenuBar Methods


CXTPMenuBar::FreeMDIMenus Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::FreeMDIMenus Method

Destroy all MDI menus.

void FreeMDIMenus();
Group

CXTPMenuBar Methods


CXTPMenuBar::GenerateCommandBarList Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::GenerateCommandBarList Method

This method is called to assign self identifiers for serialization process.

void GenerateCommandBarList(
    DWORD& nID,
    CXTPCommandBarList* pCommandBarList,
    XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam
);
Parameters

nID
Identifier to assign
pCommandBarList
List of CommandBars.
pParam
Address of a XTP_COMMANDBARS_PROPEXCHANGE_PARAM structure.

Group

CXTPMenuBar Methods


CXTPMenuBar::GetActiveMdiChildWnd Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::GetActiveMdiChildWnd Method

Retrieves active MDI child window handle

HWND GetActiveMdiChildWnd(
    BOOL* bMaximized = NULL
);
Parameters

bMaximized
If this parameter is not NULL, it is a pointer to a value that indicates the maximized state of the MDI child window.

Returns

The return value is the handle to the active MDI child window.

Group

CXTPMenuBar Methods


CXTPMenuBar::GetCurrentMenuResource Method

CXTPMenuBar Methods, CXTPMenuBar Class, Body Source
CXTPMenuBar::GetCurrentMenuResource Method

Call this method to retrieve identifier of currently visible menu

UINT GetCurrentMenuResource() const;
Body Source
UINT CXTPMenuBar::GetCurrentMenuResource() const {
    return m_nIDResourceCurrent;
}
Group

CXTPMenuBar Methods


CXTPMenuBar::GetDefaultMenuResource Method

CXTPMenuBar Methods, CXTPMenuBar Class, Body Source
CXTPMenuBar::GetDefaultMenuResource Method

Call this method to retrieve identifier of default menu

UINT GetDefaultMenuResource() const;
Body Source
UINT CXTPMenuBar::GetDefaultMenuResource() const {
    return m_nIDResource;
}
Group

CXTPMenuBar Methods


CXTPMenuBar::GetMDIMenus Method

CXTPMenuBar Methods, CXTPMenuBar Class, Body Source
CXTPMenuBar::GetMDIMenus Method

Retrieves collection of application MDI menus

CXTPMenuBarMDIMenus* GetMDIMenus() const;
Body Source
CXTPMenuBarMDIMenus* CXTPMenuBar::GetMDIMenus() const {
    return m_pMDIMenus;
}
Group

CXTPMenuBar Methods


CXTPMenuBar::LoadMenuBar Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::LoadMenuBar Method

Loads the menu from resource.

virtual BOOL LoadMenuBar(
    UINT nIDResource
);
Parameters

nIDResource
Menu identifier to load.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPMenuBar Methods


CXTPMenuBar::OnHookMessage Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::OnHookMessage Method

This member function is called by WindowProc, or is called during message reflection.

int OnHookMessage(
    HWND hWnd,
    UINT nMessage,
    WPARAM& wParam,
    LPARAM& lParam,
    LRESULT& lResult
);
Parameters

hWnd
Window handle message belongs to.
nMessage
Specifies the message to be sent.
wParam
Specifies additional message-dependent information.
lParam
Specifies additional message-dependent information.
lResult
The return value of WindowProc. Depends on the message; may be NULL.

Group

CXTPMenuBar Methods


CXTPMenuBar::RefreshMenu Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::RefreshMenu Method

This member function will refresh the menus

void RefreshMenu();
Group

CXTPMenuBar Methods


CXTPMenuBar::RefreshSysButtons Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::RefreshSysButtons Method

This method is called to update system buttons of menu bar.

virtual void RefreshSysButtons();
Group

CXTPMenuBar Methods


CXTPMenuBar::Reset Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::Reset Method

Resets the controls to their original state.

virtual void Reset(
    BOOL bShowWarningMessage
);
Parameters

bShowWarningMessage
TRUE to show warning message

Group

CXTPMenuBar Methods


CXTPMenuBar::RestoreCommandBarList Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::RestoreCommandBarList Method

This method is called in serialization process.to restore popups from list of command bars.

void RestoreCommandBarList(
    CXTPCommandBarList* pCommandBarList
);
Parameters

pCommandBarList
List of CommandBars.

Group

CXTPMenuBar Methods


CXTPMenuBar::SetupHook Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::SetupHook Method

This method is called create hooks for main window .

void SetupHook();
Group

CXTPMenuBar Methods


CXTPMenuBar::ShouldSerializeBar Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::ShouldSerializeBar Method

This method is called to check if Toolbar was changed and have to be saved

BOOL ShouldSerializeBar();
Returns

TRUE if toolbar have to be saved

Group

CXTPMenuBar Methods


CXTPMenuBar::SwitchActiveMenu Method

CXTPMenuBar Methods, CXTPMenuBar Class, See Also
CXTPMenuBar::SwitchActiveMenu Method

This method is called to switch menu to active document menu.

void SwitchActiveMenu();
See Also

GetActiveDocTemplate, SwitchMDIMenu

Group

CXTPMenuBar Methods


SwitchMDIMenu Method

CXTPMenuBar Methods
SwitchMDIMenu Method
Overload List
Methods
Method | Description
CXTPMenuBar::SwitchMDIMenu (HMENU) | This method is called to switch current MDI menu.
CXTPMenuBar::SwitchMDIMenu (UINT, CMenu*) | This method is called to switch to MDI menu from MDI menus collection
Group

CXTPMenuBar Methods


CXTPMenuBar::SwitchMDIMenu Method (HMENU)

SwitchMDIMenu Method, CXTPMenuBar Class
CXTPMenuBar::SwitchMDIMenu Method (HMENU)

This method is called to switch current MDI menu.

void SwitchMDIMenu(
    HMENU hMenu
);
Parameters

hMenu
Active menu need to select.

Group

SwitchMDIMenu Method


CXTPMenuBar::SwitchMDIMenu Method (UINT, CMenu*)

SwitchMDIMenu Method, CXTPMenuBar Class, See Also
CXTPMenuBar::SwitchMDIMenu Method (UINT, CMenu*)

This method is called to switch to MDI menu from MDI menus collection

virtual void SwitchMDIMenu(
    UINT nIDMenu,
    CMenu* pMenu = NULL
);
Parameters

nIDMenu
Menu identifier to switch
pMenu
Menu to switch

See Also

SwitchActiveMenu

Group

SwitchMDIMenu Method


CXTPMenuBar::SyncActiveMdiChild Method

CXTPMenuBar Methods, CXTPMenuBar Class
CXTPMenuBar::SyncActiveMdiChild Method

This method is called to update active mdi window hooks.

void SyncActiveMdiChild();
Group

CXTPMenuBar Methods


CXTPMenuBar Constructors

CXTPMenuBar Class, Legend, Public Methods
CXTPMenuBar Constructors
Class

CXTPMenuBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPMenuBar | Constructs a CXTPMenuBar object


CXTPMenuBar::CXTPMenuBar Constructor

CXTPMenuBar Constructors, CXTPMenuBar Class
CXTPMenuBar::CXTPMenuBar Constructor

Constructs a CXTPMenuBar object

CXTPMenuBar();
Group

CXTPMenuBar Constructors


CXTPMenuBar Destructors

CXTPMenuBar Class, Legend, Public Methods
CXTPMenuBar Destructors
Class

CXTPMenuBar Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPMenuBar | Destroys a CXTPMenuBar object, handles cleanup and deallocation


CXTPMenuBar::~CXTPMenuBar Destructor

CXTPMenuBar Destructors, CXTPMenuBar Class
CXTPMenuBar::~CXTPMenuBar Destructor

Destroys a CXTPMenuBar object, handles cleanup and deallocation

~CXTPMenuBar();
Group

CXTPMenuBar Destructors


CXTPMenuBarMDIMenuInfo Class

XTPMenuBar.h, Classes, Legend, Members, Topics, CXTPMenuBarMDIMenuInfo Data Members, CXTPMenuBarMDIMenuInfo Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBarMDIMenuInfo Class

CXTPMenuBarMDIMenuInfo structure used to describe parameters of application MDI menus.

Class Hierarchy

class CXTPMenuBarMDIMenuInfo;
File

XTPMenuBar.h

Group

Classes

Legend
Data Member
CXTPMenuBarMDIMenuInfo Data Members
CXTPMenuBarMDIMenuInfo Data Members | Description
m_bChanged | TRUE if menu was changed.
m_hIcon | Menu Icon
m_nIDResource | Template identifier
m_pControls | Menu controls
m_strDescription | Description of MDI menu
m_strTitle | Title of MDI menu


CXTPMenuBarMDIMenuInfo Data Members

CXTPMenuBarMDIMenuInfo Class, Legend, Public Data Members
CXTPMenuBarMDIMenuInfo Data Members
Class

CXTPMenuBarMDIMenuInfo Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bChanged | TRUE if menu was changed.
m_hIcon | Menu Icon
m_nIDResource | Template identifier
m_pControls | Menu controls
m_strDescription | Description of MDI menu
m_strTitle | Title of MDI menu


CXTPMenuBarMDIMenuInfo::m_bChanged Data Member

CXTPMenuBarMDIMenuInfo Data Members, CXTPMenuBarMDIMenuInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBarMDIMenuInfo::m_bChanged Data Member

TRUE if menu was changed.

BOOL m_bChanged;
Group

CXTPMenuBarMDIMenuInfo Data Members


CXTPMenuBarMDIMenuInfo::m_hIcon Data Member

CXTPMenuBarMDIMenuInfo Data Members, CXTPMenuBarMDIMenuInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBarMDIMenuInfo::m_hIcon Data Member

Menu Icon

HICON m_hIcon;
Group

CXTPMenuBarMDIMenuInfo Data Members


CXTPMenuBarMDIMenuInfo::m_nIDResource Data Member

CXTPMenuBarMDIMenuInfo Data Members, CXTPMenuBarMDIMenuInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBarMDIMenuInfo::m_nIDResource Data Member

Template identifier

UINT m_nIDResource;
Group

CXTPMenuBarMDIMenuInfo Data Members


CXTPMenuBarMDIMenuInfo::m_pControls Data Member

CXTPMenuBarMDIMenuInfo Data Members, CXTPMenuBarMDIMenuInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBarMDIMenuInfo::m_pControls Data Member

Menu controls

CXTPControls* m_pControls;
Group

CXTPMenuBarMDIMenuInfo Data Members


CXTPMenuBarMDIMenuInfo::m_strDescription Data Member

CXTPMenuBarMDIMenuInfo Data Members, CXTPMenuBarMDIMenuInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBarMDIMenuInfo::m_strDescription Data Member

Description of MDI menu

CString m_strDescription;
Group

CXTPMenuBarMDIMenuInfo Data Members


CXTPMenuBarMDIMenuInfo::m_strTitle Data Member

CXTPMenuBarMDIMenuInfo Data Members, CXTPMenuBarMDIMenuInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBarMDIMenuInfo::m_strTitle Data Member

Title of MDI menu

CString m_strTitle;
Group

CXTPMenuBarMDIMenuInfo Data Members


CXTPMenuBarMDIMenus Class

XTPMenuBar.h, Classes, Legend, Members, Topics, CXTPMenuBarMDIMenus Data Members, CXTPMenuBarMDIMenus Methods, CXTPMenuBarMDIMenus Constructors, CXTPMenuBarMDIMenus Destructors, CXTPMenuBarMDIMenus Constructors, CXTPMenuBarMDIMenus Data Members, CXTPMenuBarMDIMenus Destructors, CXTPMenuBarMDIMenus Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMenuBarMDIMenus Class

CXTPMenuBarMDIMenus represents collection of MDI menus for CXTPMenuBar

Class Hierarchy

class CXTPMenuBarMDIMenus;
File

XTPMenuBar.h

Group

Classes

Legend
Data Member
protected
Method
CXTPMenuBarMDIMenus Constructors
CXTPMenuBarMDIMenus Constructors | Description
CXTPMenuBarMDIMenus | Constructs a CXTPMenuBarMDIMenus object.
CXTPMenuBarMDIMenus Data Members
CXTPMenuBarMDIMenus Data Members | Description
m_mapMenus | Menu map
m_pMenuBar | Parent Menu Bar
CXTPMenuBarMDIMenus Destructors
CXTPMenuBarMDIMenus Destructors | Description
~CXTPMenuBarMDIMenus | Destroys a CXTPMenuBarMDIMenus object, handles clean up and deallocation
CXTPMenuBarMDIMenus Methods
CXTPMenuBarMDIMenus Methods | Description
GetCount | Returns number of MDI menus in collection


CXTPMenuBarMDIMenus Data Members

CXTPMenuBarMDIMenus Class, Legend, Protected Data Members
CXTPMenuBarMDIMenus Data Members
Class

CXTPMenuBarMDIMenus Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_mapMenus | Menu map
m_pMenuBar | Parent Menu Bar


CXTPMenuBarMDIMenus::m_mapMenus Data Member

CXTPMenuBarMDIMenus Data Members, CXTPMenuBarMDIMenus Class
CXTPMenuBarMDIMenus::m_mapMenus Data Member

Menu map

CMap<UINT, UINT, CXTPMenuBarMDIMenuInfo*, CXTPMenuBarMDIMenuInfo*> m_mapMenus;
Group

CXTPMenuBarMDIMenus Data Members


CXTPMenuBarMDIMenus::m_pMenuBar Data Member

CXTPMenuBarMDIMenus Data Members, CXTPMenuBarMDIMenus Class
CXTPMenuBarMDIMenus::m_pMenuBar Data Member

Parent Menu Bar

CXTPMenuBar* m_pMenuBar;
Group

CXTPMenuBarMDIMenus Data Members


CXTPMenuBarMDIMenus Methods

CXTPMenuBarMDIMenus Class, Legend, Public Methods
CXTPMenuBarMDIMenus Methods
Class

CXTPMenuBarMDIMenus Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetCount | Returns number of MDI menus in collection


CXTPMenuBarMDIMenus::GetCount Method

CXTPMenuBarMDIMenus Methods, CXTPMenuBarMDIMenus Class
CXTPMenuBarMDIMenus::GetCount Method

Returns number of MDI menus in collection

int GetCount() const;
Group

CXTPMenuBarMDIMenus Methods


CXTPMenuBarMDIMenus Constructors

CXTPMenuBarMDIMenus Class, Legend, Public Methods
CXTPMenuBarMDIMenus Constructors
Class

CXTPMenuBarMDIMenus Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPMenuBarMDIMenus | Constructs a CXTPMenuBarMDIMenus object.


CXTPMenuBarMDIMenus::CXTPMenuBarMDIMenus Constructor

CXTPMenuBarMDIMenus Constructors, CXTPMenuBarMDIMenus Class
CXTPMenuBarMDIMenus::CXTPMenuBarMDIMenus Constructor

Constructs a CXTPMenuBarMDIMenus object.

CXTPMenuBarMDIMenus(
    CXTPMenuBar* pMenuBar
);
Parameters

pMenuBar
Parent CXTPMenuBar

Group

CXTPMenuBarMDIMenus Constructors


CXTPMenuBarMDIMenus Destructors

CXTPMenuBarMDIMenus Class, Legend, Public Methods
CXTPMenuBarMDIMenus Destructors
Class

CXTPMenuBarMDIMenus Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPMenuBarMDIMenus | Destroys a CXTPMenuBarMDIMenus object, handles clean up and deallocation


CXTPMenuBarMDIMenus::~CXTPMenuBarMDIMenus Destructor

CXTPMenuBarMDIMenus Destructors, CXTPMenuBarMDIMenus Class
CXTPMenuBarMDIMenus::~CXTPMenuBarMDIMenus Destructor

Destroys a CXTPMenuBarMDIMenus object, handles clean up and deallocation

~CXTPMenuBarMDIMenus();
Group

CXTPMenuBarMDIMenus Destructors


CXTPMouseManager Class

XTPMouseManager.h, Classes, Legend, Members, Topics, CXTPMouseManager Classes, CXTPMouseManager Methods, CXTPMouseManager Constructors, CXTPMouseManager Destructors, CXTPMouseManager Classes, CXTPMouseManager Constructors, CXTPMouseManager Destructors, CXTPMouseManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager Class

CXTPMouseManager is standalone class. It used in CommandBars to manage mouse.

Class Hierarchy

class CXTPMouseManager : public CNoTrackObject;
File

XTPMouseManager.h

Group

Classes

Legend
Method
CXTPMouseManager Classes
CXTPMouseManager Classes | Description
CTrackArray | Array of the tracking bars.
CXTPMouseManager Constructors
CXTPMouseManager Constructors | Description
CXTPMouseManager | Constructs a CXTPMouseManager object
CXTPMouseManager Destructors
CXTPMouseManager Destructors | Description
~CXTPMouseManager | Destroys a CXTPMouseManager object, handles cleanup and deallocation.
CXTPMouseManager Methods
CXTPMouseManager Methods | Description
AddTrustedWindow | Adds a window to the trusted window list.
IgnoreLButtonUp | This method is called to disable one WM_RBUTTONUP message.
IsForceExpanded | Check if the command bar needs to be expanded
IsMouseLocked | Checks if the mouse cursor locked.
IsTopParentActive | This method called to determine if top parent window is active.
IsTrackedLock | Checks if the command bar is tracked.
LockMouseMove | Captures the mouse cursor.
RemoveSelected | Removes the selected command bar.
RemoveTrack | Removes the tracking bar.
RemoveTrustedWindow | Removes a window from the trusted window list.
SendTrackLost | Removes all tracking bars.
SetForceExpanded | Sets expanded state.
SetSelected | Sets the selected command bar.
SetTrack | Adds a tracking bar.
TrackMouseLeave | Hooks window for the mouse leave event.
UnlockMouseMove | Unlocks the mouse cursor.


CXTPMouseManager Classes

Classes, CXTPMouseManager Class
CXTPMouseManager Classes
Classes
Class | Description
CTrackArray | Array of the tracking bars.
Class

CXTPMouseManager Class


CXTPMouseManager::CTrackArray Class

XTPMouseManager.h, CXTPMouseManager Classes, Legend, Members, Topics, CTrackArray Methods, CTrackArray Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::CTrackArray Class

Array of the tracking bars.

Class Hierarchy

class CTrackArray : public CArray<CXTPCommandBar*, CXTPCommandBar*>;
File

XTPMouseManager.h

Group

CXTPMouseManager Classes

Legend
Method
CTrackArray Methods
CTrackArray Methods | Description
Find | Find position of specified commandbar.


CTrackArray Methods

CXTPMouseManager::CTrackArray Class, Legend, Public Methods
CTrackArray Methods
Class

CXTPMouseManager::CTrackArray Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Find | Find position of specified commandbar.


CXTPMouseManager::CTrackArray::Find Method

CTrackArray Methods, CXTPMouseManager::CTrackArray Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::CTrackArray::Find Method

Find position of specified commandbar.

int Find(
    const CXTPCommandBar* pCommandBar
) const;
Parameters

pCommandBar
CommandBar to find

Returns

Position of command bar in list; -1 if not found.

Body Source
int Find(const CXTPCommandBar* pCommandBar) const
{
    for (int i = 0; i < GetSize(); i++)
    {
        if (pCommandBar == GetAt(i))
            return  i;
    }
    return -1;
}
Group

CTrackArray Methods


CXTPMouseManager Methods

CXTPMouseManager Class, Legend, Public Methods
CXTPMouseManager Methods
Class

CXTPMouseManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddTrustedWindow | Adds a window to the trusted window list.
IgnoreLButtonUp | This method is called to disable one WM_RBUTTONUP message.
IsForceExpanded | Check if the command bar needs to be expanded
IsMouseLocked | Checks if the mouse cursor locked.
IsTopParentActive | This method called to determine if top parent window is active.
IsTrackedLock | Checks if the command bar is tracked.
LockMouseMove | Captures the mouse cursor.
RemoveSelected | Removes the selected command bar.
RemoveTrack | Removes the tracking bar.
RemoveTrustedWindow | Removes a window from the trusted window list.
SendTrackLost | Removes all tracking bars.
SetForceExpanded | Sets expanded state.
SetSelected | Sets the selected command bar.
SetTrack | Adds a tracking bar.
TrackMouseLeave | Hooks window for the mouse leave event.
UnlockMouseMove | Unlocks the mouse cursor.


CXTPMouseManager::AddTrustedWindow Method

CXTPMouseManager Methods, CXTPMouseManager Class
CXTPMouseManager::AddTrustedWindow Method

Adds a window to the trusted window list.

void AddTrustedWindow(
    HWND hWnd
);
Parameters

hWnd
Window handle.

Group

CXTPMouseManager Methods


CXTPMouseManager::IgnoreLButtonUp Method

CXTPMouseManager Methods, CXTPMouseManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::IgnoreLButtonUp Method

This method is called to disable one WM_RBUTTONUP message.

void IgnoreLButtonUp();
Body Source
void CXTPMouseManager::IgnoreLButtonUp() {
    m_bIgnoreLButtonUp = TRUE;
}
Group

CXTPMouseManager Methods


CXTPMouseManager::IsForceExpanded Method

CXTPMouseManager Methods, CXTPMouseManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::IsForceExpanded Method

Check if the command bar needs to be expanded

BOOL IsForceExpanded() const;
Returns

TRUE if successful; otherwise returns FALSE

Body Source
BOOL CXTPMouseManager::IsForceExpanded() const {
    return m_bForceExpanded;
}
Group

CXTPMouseManager Methods


CXTPMouseManager::IsMouseLocked Method

CXTPMouseManager Methods, CXTPMouseManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::IsMouseLocked Method

Checks if the mouse cursor locked.

BOOL IsMouseLocked() const;
Returns

TRUE if locked; otherwise returns FALSE

Body Source
BOOL CXTPMouseManager::IsMouseLocked() const{
    return m_nLock > 0;
}
Group

CXTPMouseManager Methods


CXTPMouseManager::IsTopParentActive Method

CXTPMouseManager Methods, CXTPMouseManager Class
CXTPMouseManager::IsTopParentActive Method

This method called to determine if top parent window is active.

static BOOL IsTopParentActive(
    HWND hWnd
);
Parameters

hWnd
Window handle.

Returns

TRUE if parent window is active; FALSE otherwise.

Group

CXTPMouseManager Methods


CXTPMouseManager::IsTrackedLock Method

CXTPMouseManager Methods, CXTPMouseManager Class
CXTPMouseManager::IsTrackedLock Method

Checks if the command bar is tracked.

BOOL IsTrackedLock(
    const CXTPCommandBar* pItem = NULL
);
Parameters

pItem
Points to a CXTPCommandBar object

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPMouseManager Methods


CXTPMouseManager::LockMouseMove Method

CXTPMouseManager Methods, CXTPMouseManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::LockMouseMove Method

Captures the mouse cursor.

void LockMouseMove();
Body Source
void CXTPMouseManager::LockMouseMove() {
    m_nLock++;
}
Group

CXTPMouseManager Methods


CXTPMouseManager::RemoveSelected Method

CXTPMouseManager Methods, CXTPMouseManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::RemoveSelected Method

Removes the selected command bar.

void RemoveSelected(
    CXTPCommandBar* pSelected
);
Parameters

pSelected
Points to a CXTPCommandBar object

Body Source
void CXTPMouseManager::RemoveSelected(CXTPCommandBar* pSelected){
    if (m_pSelected == pSelected)
        m_pSelected = NULL;
}
Group

CXTPMouseManager Methods


CXTPMouseManager::RemoveTrack Method

CXTPMouseManager Methods, CXTPMouseManager Class
CXTPMouseManager::RemoveTrack Method

Removes the tracking bar.

void RemoveTrack(
    CXTPCommandBar* pTrack
);
Parameters

pTrack
Points to a CXTPCommandBar object

Group

CXTPMouseManager Methods


CXTPMouseManager::RemoveTrustedWindow Method

CXTPMouseManager Methods, CXTPMouseManager Class
CXTPMouseManager::RemoveTrustedWindow Method

Removes a window from the trusted window list.

void RemoveTrustedWindow(
    HWND hWnd
);
Parameters

hWnd
Window handle.

Group

CXTPMouseManager Methods


CXTPMouseManager::SendTrackLost Method

CXTPMouseManager Methods, CXTPMouseManager Class
CXTPMouseManager::SendTrackLost Method

Removes all tracking bars.

void SendTrackLost();
Group

CXTPMouseManager Methods


CXTPMouseManager::SetForceExpanded Method

CXTPMouseManager Methods, CXTPMouseManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::SetForceExpanded Method

Sets expanded state.

void SetForceExpanded(
    BOOL bForceExpanded
);
Parameters

bForceExpanded
TRUE to expand bars.

Body Source
void CXTPMouseManager::SetForceExpanded(BOOL bForceExpanded) {
    m_bForceExpanded = bForceExpanded;
}
Group

CXTPMouseManager Methods


CXTPMouseManager::SetSelected Method

CXTPMouseManager Methods, CXTPMouseManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::SetSelected Method

Sets the selected command bar.

void SetSelected(
    CXTPCommandBar* pSelected
);
Parameters

pSelected
Points to a CXTPCommandBar object

Body Source
void CXTPMouseManager::SetSelected(CXTPCommandBar* pSelected) {
    m_pSelected = pSelected;
}
Group

CXTPMouseManager Methods


CXTPMouseManager::SetTrack Method

CXTPMouseManager Methods, CXTPMouseManager Class
CXTPMouseManager::SetTrack Method

Adds a tracking bar.

void SetTrack(
    CXTPCommandBar* pTrack,
    BOOL bCaptureMouse = TRUE
);
Parameters

pTrack
Points to a CXTPCommandBar object
bCaptureMouse
TRUE to capture the mouse.

Group

CXTPMouseManager Methods


CXTPMouseManager::TrackMouseLeave Method

CXTPMouseManager Methods, CXTPMouseManager Class
CXTPMouseManager::TrackMouseLeave Method

Hooks window for the mouse leave event.

void TrackMouseLeave(
    HWND hwnd
);
Parameters

hwnd
Window handle.

Group

CXTPMouseManager Methods


CXTPMouseManager::UnlockMouseMove Method

CXTPMouseManager Methods, CXTPMouseManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseManager::UnlockMouseMove Method

Unlocks the mouse cursor.

void UnlockMouseMove();
Body Source
void CXTPMouseManager::UnlockMouseMove() {
    m_nLock--;
}
Group

CXTPMouseManager Methods


CXTPMouseManager Constructors

CXTPMouseManager Class, Legend, Public Methods
CXTPMouseManager Constructors
Class

CXTPMouseManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPMouseManager | Constructs a CXTPMouseManager object


CXTPMouseManager::CXTPMouseManager Constructor

CXTPMouseManager Constructors, CXTPMouseManager Class
CXTPMouseManager::CXTPMouseManager Constructor

Constructs a CXTPMouseManager object

CXTPMouseManager();
Group

CXTPMouseManager Constructors


CXTPMouseManager Destructors

CXTPMouseManager Class, Legend, Public Methods
CXTPMouseManager Destructors
Class

CXTPMouseManager Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPMouseManager | Destroys a CXTPMouseManager object, handles cleanup and deallocation.


CXTPMouseManager::~CXTPMouseManager Destructor

CXTPMouseManager Destructors, CXTPMouseManager Class
CXTPMouseManager::~CXTPMouseManager Destructor

Destroys a CXTPMouseManager object, handles cleanup and deallocation.

~CXTPMouseManager();
Group

CXTPMouseManager Destructors


CXTPNativeXPTheme Class

XTPPaintManager.h, Classes, Legend, Members, Topics, CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Methods, CXTPNativeXPTheme Constructors, CXTPNativeXPTheme Destructors, CXTPNativeXPTheme Constructors, CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Destructors, CXTPNativeXPTheme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPNativeXPTheme Class

The CXTPNativeXPTheme class is used to enable a Windows XP style theme for Command Bars

Class Hierarchy

class CXTPNativeXPTheme : public CXTPDefaultTheme;
File

XTPPaintManager.h

See Also

CXTPPaintManager::SetTheme

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPNativeXPTheme Constructors
CXTPNativeXPTheme Constructors | Description
CXTPNativeXPTheme | Constructs a CXTPNativeXPTheme object.
CXTPNativeXPTheme Data Members
CXTPNativeXPTheme Data Members | Description
m_bFlatMenus | TRUE if OS flat menu option enabled
m_clrEdgeHighLightColor | Color of toolbar top line
m_clrEdgeShadowColor | Color of toolbar bottom line
m_themeCombo | ComboBox theme helper
m_themeMenu | Menu theme helper
m_themeRebar | Rebar theme helper
m_themeSpin | Window theme helper
m_themeToolbar | Toolbar theme helper
m_themeWindow | Window theme helper
CXTPNativeXPTheme Destructors
CXTPNativeXPTheme Destructors | Description
~CXTPNativeXPTheme | Destroys a CXTPNativeXPTheme object, handles cleanup and deallocation
CXTPNativeXPTheme Methods
CXTPNativeXPTheme Methods | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
BaseTheme | Retrieves the base theme of the manager.
DrawCommandBarGripper | This method is called to draw the command bar's gripper.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawControlComboBoxButton | This method is called to draw button od combo box control.
DrawControlEditFrame | This method is called to draw frame of edit control.
DrawControlEditSpin | This method draws edit control spin buttons
DrawControlEntry | This method is called to fill the control's face
DrawDialogBarGripper | Call this member to draw gripper of dialog bar.
DrawPopupBarCheckMark | Call this member function to draw a check mark.
DrawPopupBarRadioMark | Call this member function to draw a radio button.
DrawRectangle | This method is called to fill the control's face
DrawSpecialControl | This method is called to draw the specified controls.
DrawSplitButtonFrame | Draws split button frame
FillCommandBarEntry | This method is called to fill the command bar's face.
FillDockBar | This method is called to fill a dockbar.
FillDockBarRect | This method is called to fill a dockbar.
GetControlTextColor | This method returns control text color to draw
GetRectangleTextColor | This method retrieves buttons text color
IsThemeEnabled | Determines if theme is enabled
RefreshMetrics | This method is called to refresh the visual metrics of the manager.


CXTPNativeXPTheme Data Members

CXTPNativeXPTheme Class, Legend, Protected Data Members
CXTPNativeXPTheme Data Members
Class

CXTPNativeXPTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bFlatMenus | TRUE if OS flat menu option enabled
m_clrEdgeHighLightColor | Color of toolbar top line
m_clrEdgeShadowColor | Color of toolbar bottom line
m_themeCombo | ComboBox theme helper
m_themeMenu | Menu theme helper
m_themeRebar | Rebar theme helper
m_themeSpin | Window theme helper
m_themeToolbar | Toolbar theme helper
m_themeWindow | Window theme helper


CXTPNativeXPTheme::m_bFlatMenus Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_bFlatMenus Data Member

TRUE if OS flat menu option enabled

BOOL m_bFlatMenus;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme::m_clrEdgeHighLightColor Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_clrEdgeHighLightColor Data Member

Color of toolbar top line

COLORREF m_clrEdgeHighLightColor;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme::m_clrEdgeShadowColor Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_clrEdgeShadowColor Data Member

Color of toolbar bottom line

COLORREF m_clrEdgeShadowColor;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme::m_themeCombo Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_themeCombo Data Member

ComboBox theme helper

CXTPWinThemeWrapper m_themeCombo;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme::m_themeMenu Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_themeMenu Data Member

Menu theme helper

CXTPWinThemeWrapper m_themeMenu;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme::m_themeRebar Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_themeRebar Data Member

Rebar theme helper

CXTPWinThemeWrapper m_themeRebar;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme::m_themeSpin Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_themeSpin Data Member

Window theme helper

CXTPWinThemeWrapper m_themeSpin;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme::m_themeToolbar Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_themeToolbar Data Member

Toolbar theme helper

CXTPWinThemeWrapper m_themeToolbar;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme::m_themeWindow Data Member

CXTPNativeXPTheme Data Members, CXTPNativeXPTheme Class
CXTPNativeXPTheme::m_themeWindow Data Member

Window theme helper

CXTPWinThemeWrapper m_themeWindow;
Group

CXTPNativeXPTheme Data Members


CXTPNativeXPTheme Methods

CXTPNativeXPTheme Class, Legend, Protected Methods
CXTPNativeXPTheme Methods
Class

CXTPNativeXPTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
BaseTheme | Retrieves the base theme of the manager.
DrawCommandBarGripper | This method is called to draw the command bar's gripper.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawControlComboBoxButton | This method is called to draw button od combo box control.
DrawControlEditFrame | This method is called to draw frame of edit control.
DrawControlEditSpin | This method draws edit control spin buttons
DrawControlEntry | This method is called to fill the control's face
DrawDialogBarGripper | Call this member to draw gripper of dialog bar.
DrawPopupBarCheckMark | Call this member function to draw a check mark.
DrawPopupBarRadioMark | Call this member function to draw a radio button.
DrawRectangle | This method is called to fill the control's face
DrawSpecialControl | This method is called to draw the specified controls.
DrawSplitButtonFrame | Draws split button frame
FillCommandBarEntry | This method is called to fill the command bar's face.
FillDockBar | This method is called to fill a dockbar.
FillDockBarRect | This method is called to fill a dockbar.
GetControlTextColor | This method returns control text color to draw
GetRectangleTextColor | This method retrieves buttons text color
IsThemeEnabled | Determines if theme is enabled
RefreshMetrics | This method is called to refresh the visual metrics of the manager.


CXTPNativeXPTheme::AdjustExcludeRect Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::AdjustExcludeRect Method

This method is called to determine offset of popuped bar.

void AdjustExcludeRect(
    CRect& rc,
    CXTPControl* pControl,
    BOOL bVertical
);
Parameters

rc
Control's bounding rectangle.
pControl
Points to a CXTPControl object
bVertical
TRUE if control docked vertically.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::BaseTheme Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPNativeXPTheme::BaseTheme Method

Retrieves the base theme of the manager.

XTPPaintTheme BaseTheme();
Returns

Returns the base theme.

Body Source
XTPPaintTheme BaseTheme() { return xtpThemeNativeWinXP; }
Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawCommandBarGripper Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawCommandBarGripper Method

This method is called to draw the command bar's gripper.

virtual CSize DrawCommandBarGripper(
    CDC* pDC,
    CXTPCommandBar* pBar,
    BOOL bDraw = TRUE
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
bDraw
TRUE to draw; FALSE to retrieve the size of the gripper.

Returns

Size of the gripper.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawCommandBarSeparator Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawCommandBarSeparator Method

This method is called to draw a command bar's separator.

virtual CSize DrawCommandBarSeparator(
    CDC* pDC,
    CXTPCommandBar* pBar,
    CXTPControl* pControl,
    BOOL bDraw = TRUE
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
pControl
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the separator.

Returns

This method is called to draw a command bar's separator.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawControlComboBoxButton Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawControlComboBoxButton Method

This method is called to draw button od combo box control.

virtual void DrawControlComboBoxButton(
    CDC* pDC,
    CRect rcBtn,
    BOOL bEnabled,
    BOOL bSelected,
    BOOL bDropped
);
Parameters

pDC
Points to a valid device context.
rcBtn
Button bounding rectangle.
bEnabled
TRUE if combo box is enabled
bSelected
TRUE if combo box is selected
bDropped
TRUE TRUE if combo box is dropped.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawControlEditFrame Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawControlEditFrame Method

This method is called to draw frame of edit control.

virtual void DrawControlEditFrame(
    CDC* pDC,
    CRect rc,
    BOOL bEnabled,
    BOOL bSelected
);
Parameters

pDC
Points to a valid device context.
rc
CRect object specifying size of area.
bEnabled
TRUE if control is enabled.
bSelected
TRUE if control is selected.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawControlEditSpin Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawControlEditSpin Method

This method draws edit control spin buttons

virtual void DrawControlEditSpin(
    CDC* pDC,
    CXTPControlEdit* pControlEdit
);
Parameters

pDC
Pointer to device context
pControlEdit
Edit control

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawControlEntry Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawControlEntry Method

This method is called to fill the control's face

void DrawControlEntry(
    CDC* pDC,
    CXTPControl* pButton
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object to draw.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawDialogBarGripper Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawDialogBarGripper Method

Call this member to draw gripper of dialog bar.

virtual CSize DrawDialogBarGripper(
    CDC* pDC,
    CXTPDialogBar* pBar,
    BOOL bDraw
);
Parameters

pDC
Points to a valid device context.
pBar
Dialog Bar pointer
bDraw
TRUE to draw gripper, FALSE to calculate size.

Returns

Size of gripper to be drawn.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawPopupBarCheckMark Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawPopupBarCheckMark Method

Call this member function to draw a check mark.

virtual void DrawPopupBarCheckMark(
    CDC* pDC,
    CRect rcCheck,
    BOOL bEnabled,
    COLORREF clr
);
Parameters

pDC
Pointer to a valid device context
rcCheck
Specifies the rectangle in logical units.
clr
Color to fill.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawPopupBarRadioMark Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawPopupBarRadioMark Method

Call this member function to draw a radio button.

virtual void DrawPopupBarRadioMark(
    CDC* pDC,
    CRect rcCheck,
    BOOL bEnabled,
    COLORREF clr
);
Parameters

pDC
Pointer to a valid device context
rcCheck
Specifies the rectangle in logical units.
clr
Color to fill.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawRectangle Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawRectangle Method

This method is called to fill the control's face

virtual void DrawRectangle(
    CDC* pDC,
    CRect rc,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

pDC
Pointer to a valid device context
rc
Rectangle to draw.
bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawSpecialControl Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawSpecialControl Method

This method is called to draw the specified controls.

virtual CSize DrawSpecialControl(
    CDC* pDC,
    XTPSpecialControl controlType,
    CXTPControl* pButton,
    CXTPCommandBar* pBar,
    BOOL bDraw,
    LPVOID lpParam
);
Parameters

pDC
Pointer to a valid device context
controlType
Special control enumerator.
pButton
Points to a CXTPControl object to draw.
pBar
Parent CXTPCommandBar object.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.
lpParam
Specified parameter.

Returns

Size of the control.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::DrawSplitButtonFrame Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::DrawSplitButtonFrame Method

Draws split button frame

void DrawSplitButtonFrame(
    CDC* pDC,
    CXTPControl* pButton,
    CRect rcButton
);
Parameters

pDC
Points to a valid device context.
pButton
Pointer to split button to draw.
rcButton
Bounding rectangle to draw

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::FillCommandBarEntry Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::FillCommandBarEntry Method

This method is called to fill the command bar's face.

virtual void FillCommandBarEntry(
    CDC* pDC,
    CXTPCommandBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object to draw.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::FillDockBar Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::FillDockBar Method

This method is called to fill a dockbar.

virtual void FillDockBar(
    CDC* pDC,
    CXTPDockBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPDockBar object

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::FillDockBarRect Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::FillDockBarRect Method

This method is called to fill a dockbar.

void FillDockBarRect(
    CDC* pDC,
    CWnd* pWnd,
    CWnd* pFrame
);
Parameters

pDC
Points to a valid device context.
pWnd
Client area to fill.
pFrame
Parent frame window.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::GetControlTextColor Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::GetControlTextColor Method

This method returns control text color to draw

COLORREF GetControlTextColor(
    CXTPControl* pButton
);
Parameters

pButton
Points to a CXTPControl object to draw.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::GetRectangleTextColor Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::GetRectangleTextColor Method

This method retrieves buttons text color

virtual COLORREF GetRectangleTextColor(
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::IsThemeEnabled Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::IsThemeEnabled Method

Determines if theme is enabled

BOOL IsThemeEnabled() const;
Returns

TRUE if WinXP theme is enabled

Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme::RefreshMetrics Method

CXTPNativeXPTheme Methods, CXTPNativeXPTheme Class
CXTPNativeXPTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the manager.

virtual void RefreshMetrics();
Group

CXTPNativeXPTheme Methods


CXTPNativeXPTheme Constructors

CXTPNativeXPTheme Class, Legend, Public Methods
CXTPNativeXPTheme Constructors
Class

CXTPNativeXPTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPNativeXPTheme | Constructs a CXTPNativeXPTheme object.


CXTPNativeXPTheme::CXTPNativeXPTheme Constructor

CXTPNativeXPTheme Constructors, CXTPNativeXPTheme Class
CXTPNativeXPTheme::CXTPNativeXPTheme Constructor

Constructs a CXTPNativeXPTheme object.

CXTPNativeXPTheme();
Group

CXTPNativeXPTheme Constructors


CXTPNativeXPTheme Destructors

CXTPNativeXPTheme Class, Legend, Public Methods
CXTPNativeXPTheme Destructors
Class

CXTPNativeXPTheme Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPNativeXPTheme | Destroys a CXTPNativeXPTheme object, handles cleanup and deallocation


CXTPNativeXPTheme::~CXTPNativeXPTheme Destructor

CXTPNativeXPTheme Destructors, CXTPNativeXPTheme Class
CXTPNativeXPTheme::~CXTPNativeXPTheme Destructor

Destroys a CXTPNativeXPTheme object, handles cleanup and deallocation

~CXTPNativeXPTheme();
Group

CXTPNativeXPTheme Destructors


CXTPNewToolbarDlg Class

XTPCustomizeTools.h, Classes, Legend, Members, Topics, CXTPNewToolbarDlg Data Members, CXTPNewToolbarDlg Constructors, CXTPNewToolbarDlg Constructors, CXTPNewToolbarDlg Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPNewToolbarDlg Class

CXTPNewToolbarDlg is CDialog derived class. It used internally in customization sheet.

Class Hierarchy

class CXTPNewToolbarDlg : public CDialog;
File

XTPCustomizeTools.h

Group

Classes

Legend
Data Member
Constructor
CXTPNewToolbarDlg Constructors
CXTPNewToolbarDlg Constructors | Description
CXTPNewToolbarDlg | Constructs a CXTPNewToolbarDlg object.
CXTPNewToolbarDlg Data Members
CXTPNewToolbarDlg Data Members | Description
m_nNewID | Toolbar identifier
m_pCommandBar | CommandBar to edit
m_pCommandBars | CommandBars class.
m_strToolbar | Caption of toolbar


CXTPNewToolbarDlg Data Members

CXTPNewToolbarDlg Class, Legend, Public Data Members
CXTPNewToolbarDlg Data Members
Class

CXTPNewToolbarDlg Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_nNewID | Toolbar identifier
m_pCommandBar | CommandBar to edit
m_pCommandBars | CommandBars class.
m_strToolbar | Caption of toolbar


CXTPNewToolbarDlg::m_nNewID Data Member

CXTPNewToolbarDlg Data Members, CXTPNewToolbarDlg Class
CXTPNewToolbarDlg::m_nNewID Data Member

Toolbar identifier

UINT m_nNewID;
Group

CXTPNewToolbarDlg Data Members


CXTPNewToolbarDlg::m_pCommandBar Data Member

CXTPNewToolbarDlg Data Members, CXTPNewToolbarDlg Class
CXTPNewToolbarDlg::m_pCommandBar Data Member

CommandBar to edit

CXTPCommandBar* m_pCommandBar;
Group

CXTPNewToolbarDlg Data Members


CXTPNewToolbarDlg::m_pCommandBars Data Member

CXTPNewToolbarDlg Data Members, CXTPNewToolbarDlg Class
CXTPNewToolbarDlg::m_pCommandBars Data Member

CommandBars class.

CXTPCommandBars* m_pCommandBars;
Group

CXTPNewToolbarDlg Data Members


CXTPNewToolbarDlg::m_strToolbar Data Member

CXTPNewToolbarDlg Data Members, CXTPNewToolbarDlg Class
CXTPNewToolbarDlg::m_strToolbar Data Member

Caption of toolbar

CString m_strToolbar;
Group

CXTPNewToolbarDlg Data Members


CXTPNewToolbarDlg Constructors

CXTPNewToolbarDlg Class, Legend, Public Methods
CXTPNewToolbarDlg Constructors
Class

CXTPNewToolbarDlg Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPNewToolbarDlg | Constructs a CXTPNewToolbarDlg object.


CXTPNewToolbarDlg::CXTPNewToolbarDlg Constructor

CXTPNewToolbarDlg Constructors, CXTPNewToolbarDlg Class
CXTPNewToolbarDlg::CXTPNewToolbarDlg Constructor

Constructs a CXTPNewToolbarDlg object.

CXTPNewToolbarDlg(
    CWnd* pParent,
    CXTPCommandBars* pCommandBars,
    CXTPCommandBar* pCommandBar = NULL
);
Parameters

pParent
Points to the objects parent window.
pCommandBars
Pointer to a CXTPCommandBars object.
pCommandBar
Pointer to a CXTPCommandBar need to edit.

Group

CXTPNewToolbarDlg Constructors


CXTPOffice2007Theme Class

XTPOffice2007Theme.h, Classes, Legend, Members, Topics, CXTPOffice2007Theme Data Members, CXTPOffice2007Theme Methods, CXTPOffice2007Theme Constructors, CXTPOffice2007Theme Destructors, CXTPOffice2007Theme Constructors, CXTPOffice2007Theme Data Members, CXTPOffice2007Theme Destructors, CXTPOffice2007Theme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme Class

The CXTPOffice2007Theme class is used to enable an Office 2007 style theme for Command Bars

Class Hierarchy

class CXTPOffice2007Theme : public CXTPOffice2003Theme;
File

XTPOffice2007Theme.h

See Also

CXTPPaintManager::SetTheme

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPOffice2007Theme Constructors
CXTPOffice2007Theme Constructors | Description
CXTPOffice2007Theme | Constructs a CXTPOffice2007Theme object.
CXTPOffice2007Theme Data Members
CXTPOffice2007Theme Data Members | Description
m_bFrameStatusBar | TRUE if status bar used to draw.
m_fontFrameCaption | Font used to draw text in the frame caption
m_nFrameCaptionHeight | Frame caption
m_nRibbonCaptionHeight | Ribbon caption height
CXTPOffice2007Theme Destructors
CXTPOffice2007Theme Destructors | Description
~CXTPOffice2007Theme | Destroys a CXTPOffice2007Theme object, handles cleanup and deallocation
CXTPOffice2007Theme Methods
CXTPOffice2007Theme Methods | Description
BaseTheme | Retrieves the base theme of the manager.
CalcRibbonFrameRegion | This method is called to create window region
DrawCaptionText | This method is called to draw frame caption text
DrawRibbonFrame | This method is called to draw frame if Ribbon was found
DrawRibbonFrameCaptionButton | This method is called to draw caption button
DrawStatusBarGripper | This method is called to draw the status bar's gripper.
DrawStatusBarPaneBorder | This method is called to draw frame of single cell of status bar.
FillStatusBar | This method is called to fill a status bar.
FillWorkspace | Draws workspace space
GetFrameCaptionHeight | Retrieves height of caption
GetFrameLargeIcon | Retrieves frame large icon
GetFrameSmallIcon | Retrieves frame small icon
GetImages | This method is called to get CXTPOffice2007Images pointer
GetRectangleTextColor | This method retrieves buttons text color
GetRibbonCaptionHeight | Retrieves ribbon caption height
IsImagesAvailable | Determines if images is available
LoadImage | Loads a bitmap image from the specified path.
RefreshMetrics | This method is called to refresh the visual metrics of the manager.
SetImageHandle | Specifies the resource that contains the bitmaps to be loaded for the theme. This allows images to be loaded from something other than bitmap files.
SetImages | Call this method to set images for theme


CXTPOffice2007Theme Data Members

CXTPOffice2007Theme Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme Data Members
Class

CXTPOffice2007Theme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nFrameCaptionHeight | Frame caption
m_nRibbonCaptionHeight | Ribbon caption height
Public Data Members
Public Data Member | Description
m_bFrameStatusBar | TRUE if status bar used to draw.
m_fontFrameCaption | Font used to draw text in the frame caption


CXTPOffice2007Theme::m_bFrameStatusBar Data Member

CXTPOffice2007Theme Data Members, CXTPOffice2007Theme Class
CXTPOffice2007Theme::m_bFrameStatusBar Data Member

TRUE if status bar used to draw.

BOOL m_bFrameStatusBar;
Group

CXTPOffice2007Theme Data Members


CXTPOffice2007Theme::m_fontFrameCaption Data Member

CXTPOffice2007Theme Data Members, CXTPOffice2007Theme Class
CXTPOffice2007Theme::m_fontFrameCaption Data Member

Font used to draw text in the frame caption

CXTPPaintManagerFont m_fontFrameCaption;
Group

CXTPOffice2007Theme Data Members


CXTPOffice2007Theme::m_nFrameCaptionHeight Data Member

CXTPOffice2007Theme Data Members, CXTPOffice2007Theme Class
CXTPOffice2007Theme::m_nFrameCaptionHeight Data Member

Frame caption

int m_nFrameCaptionHeight;
Group

CXTPOffice2007Theme Data Members


CXTPOffice2007Theme::m_nRibbonCaptionHeight Data Member

CXTPOffice2007Theme Data Members, CXTPOffice2007Theme Class
CXTPOffice2007Theme::m_nRibbonCaptionHeight Data Member

Ribbon caption height

int m_nRibbonCaptionHeight;
Group

CXTPOffice2007Theme Data Members


CXTPOffice2007Theme Methods

CXTPOffice2007Theme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme Methods
Class

CXTPOffice2007Theme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
BaseTheme | Retrieves the base theme of the manager.
DrawCaptionText | This method is called to draw frame caption text
DrawStatusBarGripper | This method is called to draw the status bar's gripper.
DrawStatusBarPaneBorder | This method is called to draw frame of single cell of status bar.
FillStatusBar | This method is called to fill a status bar.
GetFrameLargeIcon | Retrieves frame large icon
GetFrameSmallIcon | Retrieves frame small icon
IsImagesAvailable | Determines if images is available
RefreshMetrics | This method is called to refresh the visual metrics of the manager.
Public Methods
Public Methods
Public Method | Description
CalcRibbonFrameRegion | This method is called to create window region
DrawRibbonFrame | This method is called to draw frame if Ribbon was found
DrawRibbonFrameCaptionButton | This method is called to draw caption button
FillWorkspace | Draws workspace space
GetFrameCaptionHeight | Retrieves height of caption
GetImages | This method is called to get CXTPOffice2007Images pointer
GetRectangleTextColor | This method retrieves buttons text color
GetRibbonCaptionHeight | Retrieves ribbon caption height
LoadImage | Loads a bitmap image from the specified path.
SetImageHandle | Specifies the resource that contains the bitmaps to be loaded for the theme. This allows images to be loaded from something other than bitmap files.
SetImages | Call this method to set images for theme


CXTPOffice2007Theme::BaseTheme Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme::BaseTheme Method

Retrieves the base theme of the manager.

XTPPaintTheme BaseTheme();
Returns

Returns the base theme.

Body Source
XTPPaintTheme BaseTheme() { return xtpThemeOffice2007; }
Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::CalcRibbonFrameRegion Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::CalcRibbonFrameRegion Method

This method is called to create window region

virtual HRGN CalcRibbonFrameRegion(
    CXTPOffice2007FrameHook* pFrameHook,
    CSize sz
);
Parameters

pFrameHook
CXTPOffice2007FrameHook hook object
sz
Window size

Returns

Region of window to be set

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::DrawCaptionText Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::DrawCaptionText Method

This method is called to draw frame caption text

virtual void DrawCaptionText(
    CDC* pDC,
    CRect rcCaptionText,
    CWnd* pSite,
    BOOL bActive
);
Parameters

pDC
Pointer to device context
rcCaptionText
Bounding rectangle of window text
pSite
Frame to draw
bActive
TRUE if frame is active

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::DrawRibbonFrame Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::DrawRibbonFrame Method

This method is called to draw frame if Ribbon was found

virtual void DrawRibbonFrame(
    CDC* pDC,
    CXTPOffice2007FrameHook* pFrameHook
);
Parameters

pDC
Pointer to device context
pFrameHook
CXTPOffice2007FrameHook hook object

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::DrawRibbonFrameCaptionButton Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::DrawRibbonFrameCaptionButton Method

This method is called to draw caption button

virtual void DrawRibbonFrameCaptionButton(
    CDC* pDC,
    CRect rc,
    int nId,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bActive
);
Parameters

pDC
Pointer to device context
rc
Bounding rectangle of the button
nId
Identifier of the button
bSelected
TURE if button is highlighted
bPressed
TURE if button is pressed
bActive
TURE if frame is active

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::DrawStatusBarGripper Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::DrawStatusBarGripper Method

This method is called to draw the status bar's gripper.

virtual void DrawStatusBarGripper(
    CDC* pDC,
    CRect rcClient
);
Parameters

pDC
Pointer to a valid device context
rcClient
Client rectangle of the status bar.

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::DrawStatusBarPaneBorder Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::DrawStatusBarPaneBorder Method

This method is called to draw frame of single cell of status bar.

virtual void DrawStatusBarPaneBorder(
    CDC* pDC,
    CRect rc,
    CXTPStatusBarPane* pPane,
    BOOL bGripperPane
);
Parameters

pDC
Points to a valid device context.
rc
CRect object specifying size of area.
pPane
The status bar pane need to draw
bGripperPane
TRUE if pane is last cell of status bar

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::FillStatusBar Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::FillStatusBar Method

This method is called to fill a status bar.

virtual void FillStatusBar(
    CDC* pDC,
    CXTPStatusBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPStatusBar object

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::FillWorkspace Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::FillWorkspace Method

Draws workspace space

void FillWorkspace(
    CDC* pDC,
    CRect rc,
    CRect rcExclude
);
Parameters

pDC
Pointer to device context
rc
Bounding rectangle
rcExclude
Excluded rectangle

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::GetFrameCaptionHeight Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme::GetFrameCaptionHeight Method

Retrieves height of caption

int GetFrameCaptionHeight() const;
Body Source
int CXTPOffice2007Theme::GetFrameCaptionHeight() const {
    return m_nFrameCaptionHeight;
}
Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::GetFrameLargeIcon Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme::GetFrameLargeIcon Method

Retrieves frame large icon

HICON GetFrameLargeIcon(
    CWnd* pFrame
);
Parameters

pFrame
Window to retrieve icon

See Also

GetFrameLargeIcon

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::GetFrameSmallIcon Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme::GetFrameSmallIcon Method

Retrieves frame small icon

HICON GetFrameSmallIcon(
    CWnd* pFrame
);
Parameters

pFrame
Window to retrieve icon

See Also

GetFrameLargeIcon

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::GetImages Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::GetImages Method

This method is called to get CXTPOffice2007Images pointer

CXTPOffice2007Images* GetImages() const;
Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::GetRectangleTextColor Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::GetRectangleTextColor Method

This method retrieves buttons text color

virtual COLORREF GetRectangleTextColor(
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::GetRibbonCaptionHeight Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme::GetRibbonCaptionHeight Method

Retrieves ribbon caption height

int GetRibbonCaptionHeight() const;
Body Source
int CXTPOffice2007Theme::GetRibbonCaptionHeight() const {
    return m_nRibbonCaptionHeight;
}
Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::IsImagesAvailable Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::IsImagesAvailable Method

Determines if images is available

BOOL IsImagesAvailable();
Returns

TRUE if images exist in application

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::LoadImage Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme::LoadImage Method

Loads a bitmap image from the specified path.

CXTPOffice2007Image* LoadImage(
    LPCTSTR lpszFileName
);
Parameters

lpszFileName
The name of the file that contains the bitmaps to load.

Returns

New CXTPOffice2007Image containing the loaded bitmap.

Remarks

The images are the bitmaps that represent all the visual components of the Ribbon Bar. For example tab buttons, group buttons, menu buttons, toolbar buttons, option button, toolbar dropdown, etc. The images are loaded using LoadImage and are stored in the m_pImages image collection. Images for the Office 2007 theme can be found in the SourceRibbonRes folder.

See Also

SetImageHandle, m_pImages

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::RefreshMetrics Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class
CXTPOffice2007Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of the manager.

virtual void RefreshMetrics();
Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::SetImageHandle Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme::SetImageHandle Method

Specifies the resource that contains the bitmaps to be loaded for the theme. This allows images to be loaded from something other than bitmap files.

void SetImageHandle(
    HMODULE hResource,
    LPCTSTR lpszIniFileName
);
Parameters

hResource
Handle to a visual style dll file handle. Or some other resource that contains the images to load for the theme.
lpszIniFileName
String identifier of ini file with color specifications

Remarks

The images are the bitmaps that represent all the visual components of the Ribbon Bar. For example tab buttons, group buttons, menu buttons, toolbar buttons, option button, toolbar dropdown, etc. The images are loaded using LoadImage and are stored in the m_pImages image collection. Images for the Office 2007 theme can be found in the SourceRibbonRes folder.

See Also

LoadImage, m_pImages

Example
((CXTPOffice2007Theme*)XTPPaintManager())->SetImageHandle(XTPSkinManager()->GetResourceFile()->GetModuleHandle());
Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme::SetImages Method

CXTPOffice2007Theme Methods, CXTPOffice2007Theme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOffice2007Theme::SetImages Method

Call this method to set images for theme

void SetImages(
    CXTPOffice2007Images* pImages
);
Parameters

pImages
new CXTPOffice2007Images to bet set

See Also

GetImages

Group

CXTPOffice2007Theme Methods


CXTPOffice2007Theme Constructors

CXTPOffice2007Theme Class, Legend, Public Methods
CXTPOffice2007Theme Constructors
Class

CXTPOffice2007Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPOffice2007Theme | Constructs a CXTPOffice2007Theme object.


CXTPOffice2007Theme::CXTPOffice2007Theme Constructor

CXTPOffice2007Theme Constructors, CXTPOffice2007Theme Class
CXTPOffice2007Theme::CXTPOffice2007Theme Constructor

Constructs a CXTPOffice2007Theme object.

CXTPOffice2007Theme();
Group

CXTPOffice2007Theme Constructors


CXTPOffice2007Theme Destructors

CXTPOffice2007Theme Class, Legend, Public Methods
CXTPOffice2007Theme Destructors
Class

CXTPOffice2007Theme Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPOffice2007Theme | Destroys a CXTPOffice2007Theme object, handles cleanup and deallocation


CXTPOffice2007Theme::~CXTPOffice2007Theme Destructor

CXTPOffice2007Theme Destructors, CXTPOffice2007Theme Class
CXTPOffice2007Theme::~CXTPOffice2007Theme Destructor

Destroys a CXTPOffice2007Theme object, handles cleanup and deallocation

~CXTPOffice2007Theme();
Group

CXTPOffice2007Theme Destructors


CXTPOfficeTheme Class

XTPPaintManager.h, Classes, Legend, Members, Topics, CXTPOfficeTheme Methods, CXTPOfficeTheme Constructors, CXTPOfficeTheme Constructors, CXTPOfficeTheme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOfficeTheme Class

The CXTPOfficeTheme class is used to enable an Office XP style theme for Command Bars

Class Hierarchy

class CXTPOfficeTheme : public CXTPPaintManager;
File

XTPPaintManager.h

See Also

CXTPPaintManager::SetTheme

Group

Classes

Legend
Method
virtual
protected
CXTPOfficeTheme Constructors
CXTPOfficeTheme Constructors | Description
CXTPOfficeTheme | Constructs a CXTPOfficeTheme object.
CXTPOfficeTheme Methods
CXTPOfficeTheme Methods | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
BaseTheme | Retrieves the base theme of the manager.
DrawCommandBarGripper | This method is called to draw the command bar's gripper.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawControlCheckBoxMark | This method is called to draw check box mark area
DrawControlComboBox | This method is called to draw the control.
DrawControlEdit | This method is called to draw the control.
DrawControlPopupParent | This method is called to draw the control placed on the PopupBar.
DrawControlRadioButtonMark | This method is called to draw radio button mark area
DrawDialogBarGripper | Call this member to draw gripper of dialog bar.
DrawImage | This method is called to draw the image of the control.
DrawListBoxControl | This method is called to draw the control placed on the ListBox.
DrawPopupBarGripper | This method is called to draw popup bar right gripper.
DrawRectangle | This method is called to fill the control's face
DrawSplitButtonFrame | This method is called to draw the frame for the SplitButton control
DrawStatusBarPaneBorder | This method is called to draw frame of single cell of status bar.
DrawTearOffGripper | This method is called to draw a tear-off gripper of Popup Bar.
FillCommandBarEntry | This method is called to fill the command bar's face.
FillIntersectRect | Draws intersect rectangle of popup bar and its control.
GetRectangleTextColor | This method retrieves buttons text color


CXTPOfficeTheme Methods

CXTPOfficeTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOfficeTheme Methods
Class

CXTPOfficeTheme Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
BaseTheme | Retrieves the base theme of the manager.
DrawControlCheckBoxMark | This method is called to draw check box mark area
DrawControlComboBox | This method is called to draw the control.
DrawControlEdit | This method is called to draw the control.
DrawControlPopupParent | This method is called to draw the control placed on the PopupBar.
DrawControlRadioButtonMark | This method is called to draw radio button mark area
DrawImage | This method is called to draw the image of the control.
DrawPopupBarGripper | This method is called to draw popup bar right gripper.
DrawRectangle | This method is called to fill the control's face
DrawSplitButtonFrame | This method is called to draw the frame for the SplitButton control
DrawStatusBarPaneBorder | This method is called to draw frame of single cell of status bar.
FillIntersectRect | Draws intersect rectangle of popup bar and its control.
Public Methods
Public Methods
Public Method | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
DrawCommandBarGripper | This method is called to draw the command bar's gripper.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawDialogBarGripper | Call this member to draw gripper of dialog bar.
DrawListBoxControl | This method is called to draw the control placed on the ListBox.
DrawTearOffGripper | This method is called to draw a tear-off gripper of Popup Bar.
FillCommandBarEntry | This method is called to fill the command bar's face.
GetRectangleTextColor | This method retrieves buttons text color


CXTPOfficeTheme::AdjustExcludeRect Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::AdjustExcludeRect Method

This method is called to determine offset of popuped bar.

virtual void AdjustExcludeRect(
    CRect& rc,
    CXTPControl* pControl,
    BOOL bVertical
);
Parameters

rc
Control's bounding rectangle.
pControl
Points to a CXTPControl object
bVertical
TRUE if control docked vertically.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::BaseTheme Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class, Body Source
CXTPOfficeTheme::BaseTheme Method

Retrieves the base theme of the manager.

XTPPaintTheme BaseTheme();
Returns

Returns the base theme.

Body Source
XTPPaintTheme BaseTheme() { return xtpThemeOfficeXP; }
Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawCommandBarGripper Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawCommandBarGripper Method

This method is called to draw the command bar's gripper.

virtual CSize DrawCommandBarGripper(
    CDC* pDC,
    CXTPCommandBar* pBar,
    BOOL bDraw = TRUE
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
bDraw
TRUE to draw; FALSE to retrieve the size of the gripper.

Returns

Size of the gripper.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawCommandBarSeparator Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawCommandBarSeparator Method

This method is called to draw a command bar's separator.

virtual CSize DrawCommandBarSeparator(
    CDC* pDC,
    CXTPCommandBar* pBar,
    CXTPControl* pControl,
    BOOL bDraw = TRUE
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
pControl
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the separator.

Returns

This method is called to draw a command bar's separator.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawControlCheckBoxMark Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawControlCheckBoxMark Method

This method is called to draw check box mark area

virtual CSize DrawControlCheckBoxMark(
    CDC* pDC,
    CRect rc,
    BOOL bDraw,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked,
    BOOL bEnabled
);
Parameters

pDC
Pointer to a valid device context
rc
Bounding rectangle
bDraw
TRUE to draw; FALSE to find size
bSelected
TRUE if control is selected
bPressed
TRUE if control is pressed
bChecked
TRUE if control is checked
bEnabled
TRUE if control is enabled

Returns

Size of check box mark

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawControlComboBox Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawControlComboBox Method

This method is called to draw the control.

virtual CSize DrawControlComboBox(
    CDC* pDC,
    CXTPControlComboBox* pComboBox,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pComboBox
CXTPControlComboBox pointer need to draw.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawControlEdit Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawControlEdit Method

This method is called to draw the control.

virtual CSize DrawControlEdit(
    CDC* pDC,
    CXTPControlEdit* pEdit,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pEdit
Edit control to draw.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawControlPopupParent Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawControlPopupParent Method

This method is called to draw the control placed on the PopupBar.

virtual CSize DrawControlPopupParent(
    CDC* pDC,
    CXTPControl* pButton,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawControlRadioButtonMark Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawControlRadioButtonMark Method

This method is called to draw radio button mark area

virtual CSize DrawControlRadioButtonMark(
    CDC* pDC,
    CRect rc,
    BOOL bDraw,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked,
    BOOL bEnabled
);
Parameters

pDC
Pointer to a valid device context
rc
Bounding rectangle
bDraw
TRUE to draw; FALSE to find size
bSelected
TRUE if control is selected
bPressed
TRUE if control is pressed
bChecked
TRUE if control is checked
bEnabled
TRUE if control is enabled

Returns

Size of radio button mark

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawDialogBarGripper Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawDialogBarGripper Method

Call this member to draw gripper of dialog bar.

virtual CSize DrawDialogBarGripper(
    CDC* pDC,
    CXTPDialogBar* pBar,
    BOOL bDraw
);
Parameters

pDC
Points to a valid device context.
pBar
Dialog Bar pointer
bDraw
TRUE to draw gripper, FALSE to calculate size.

Returns

Size of gripper to be drawn.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawImage Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawImage Method

This method is called to draw the image of the control.

virtual void DrawImage(
    CDC* pDC,
    CPoint pt,
    CSize sz,
    CXTPImageManagerIcon* pImage,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled = TRUE,
    BOOL bChecked = FALSE,
    BOOL bPopuped = FALSE,
    BOOL bToolBarImage = TRUE
);
Parameters

pDC
Pointer to a valid device context
pt
Position to draw.
sz
Size of the image.
pImage
Points to a CXTPImageManagerIcon object
bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
bToolBarImage
TRUE if it is a toolbar image.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawListBoxControl Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawListBoxControl Method

This method is called to draw the control placed on the ListBox.

virtual CSize DrawListBoxControl(
    CDC* pDC,
    CXTPControl* pButton,
    CRect rc,
    BOOL bSelected,
    BOOL bDraw,
    CXTPCommandBars* pCommandBars = 0
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
rc
Bounding rectangle to draw.
bSelected
TRUE if the control is selected.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.
pCommandBars
CommandBars object which metrics need to use.

Returns

Size of the control.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawPopupBarGripper Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawPopupBarGripper Method

This method is called to draw popup bar right gripper.

virtual void DrawPopupBarGripper(
    CDC* pDC,
    int xPos,
    int yPos,
    int cx,
    int cy,
    BOOL bExpanded = FALSE
);
Parameters

pDC
Points to a valid device context.
xPos
Specifies the logical x-coordinate of the upper-left corner of the rectangle.
yPos
Specifies the logical y-coordinate of the upper-left corner of the destination rectangle.
cx
Specifies the width of the rectangle.
cy
Specifies the height of the rectangle.
bExpanded
TRUE if expanded.gripper.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawRectangle Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawRectangle Method

This method is called to fill the control's face

virtual void DrawRectangle(
    CDC* pDC,
    CRect rc,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

pDC
Pointer to a valid device context
rc
Rectangle to draw.
bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawSplitButtonFrame Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawSplitButtonFrame Method

This method is called to draw the frame for the SplitButton control

virtual void DrawSplitButtonFrame(
    CDC* pDC,
    CXTPControl* pButton,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
rc
Bounding rectangle to draw

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawStatusBarPaneBorder Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawStatusBarPaneBorder Method

This method is called to draw frame of single cell of status bar.

virtual void DrawStatusBarPaneBorder(
    CDC* pDC,
    CRect rc,
    CXTPStatusBarPane* pPane,
    BOOL bGripperPane
);
Parameters

pDC
Points to a valid device context.
rc
CRect object specifying size of area.
pPane
The status bar pane need to draw
bGripperPane
TRUE if pane is last cell of status bar

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::DrawTearOffGripper Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::DrawTearOffGripper Method

This method is called to draw a tear-off gripper of Popup Bar.

virtual CSize DrawTearOffGripper(
    CDC* pDC,
    CRect rcGripper,
    BOOL bSelected,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
rcGripper
Bounding rectangle of the gripper.
bSelected
True if the gripper is selected.
bDraw
TRUE to draw; FALSE to retrieve the size of the gripper.

Returns

Size of the gripper.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::FillCommandBarEntry Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::FillCommandBarEntry Method

This method is called to fill the command bar's face.

virtual void FillCommandBarEntry(
    CDC* pDC,
    CXTPCommandBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object to draw.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::FillIntersectRect Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::FillIntersectRect Method

Draws intersect rectangle of popup bar and its control.

void FillIntersectRect(
    CDC* pDC,
    CXTPPopupBar* pPopupBar,
    COLORREF clr
);
Parameters

pDC
Points to a valid device context.
pPopupBar
Popup bar pointer.
clr
COLORREF specifies RGB color value.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme::GetRectangleTextColor Method

CXTPOfficeTheme Methods, CXTPOfficeTheme Class
CXTPOfficeTheme::GetRectangleTextColor Method

This method retrieves buttons text color

virtual COLORREF GetRectangleTextColor(
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPOfficeTheme Methods


CXTPOfficeTheme Constructors

CXTPOfficeTheme Class, Legend, Public Methods
CXTPOfficeTheme Constructors
Class

CXTPOfficeTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPOfficeTheme | Constructs a CXTPOfficeTheme object.


CXTPOfficeTheme::CXTPOfficeTheme Constructor

CXTPOfficeTheme Constructors, CXTPOfficeTheme Class
CXTPOfficeTheme::CXTPOfficeTheme Constructor

Constructs a CXTPOfficeTheme object.

CXTPOfficeTheme();
Group

CXTPOfficeTheme Constructors


CXTPPaintManager Class

XTPPaintManager.h, Classes, Legend, Members, Topics, CXTPPaintManager Structures, CXTPPaintManager Data Members, CXTPPaintManager Methods, CXTPPaintManager Constructors, CXTPPaintManager Destructors, CXTPPaintManager Constructors, CXTPPaintManager Data Members, CXTPPaintManager Destructors, CXTPPaintManager Methods, CXTPPaintManager Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager Class

Paint manager of the command bars.

Class Hierarchy

class CXTPPaintManager;
File

XTPPaintManager.h

Group

Classes

Legend
Structure
Data Member
protected
Method
abstract
virtual
CXTPPaintManager Constructors
CXTPPaintManager Constructors | Description
CXTPPaintManager | Constructs a CXTPPaintManager object
CXTPPaintManager Data Members
CXTPPaintManager Data Members | Description
m_arrColor | Self colors array.
m_bAutoResizeIcons | TRUE to automatically resize icons using current DPI
m_bClearTypeTextQuality | TRUE to enable ClearType text for the font.
m_bEmbossedDisabledText | TRUE to draw disabled text embossed
m_bEnableAnimation | TRUE to enable animation for all toolbars
m_bFlatMenuBar | TRUE to draw menubar flat
m_bFlatToolBar | TRUE to draw toolbars flat
m_bOffice2007Padding | TRUE if Office2007 metrics used
m_bOffsetPopupLabelText | TRUE if labels in popups drawn with offset
m_bResourceCharSet | TRUE to use font CharSet from loaded resources.
m_bSelectImageInPopupBar | TRUE to select image as in explorer theme.
m_bShowKeyboardCues | TRUE to show keyboard cues - deprecated.
m_bShowShadow | TRUE to show shadow
m_bThemedCheckBox | TRUE to draw check box using WinXP theme.
m_bThemedStatusBar | TRUE to draw status bar using WinXP theme.
m_bThickCheckMark | TRUE to draw thick check mark
m_bUseOfficeFont | TRUE to use Tahoma font.
m_bUseStandardFont | TRUE to use system font.
m_bWrapCaptionBelowText | Wrap text for xtpButtonIconAndCaptionBelow buttons
m_clrDisabledIcon | Disabled icons color
m_clrFloatingGripper | Gripper color of floating toolbar.
m_clrFloatingGripperText | Gripper text color of floating toolbar.
m_clrStatusTextColor | Status bar test color
m_fontIcon | Icon font.
m_fontIconBold | Icon bold font.
m_fontRegular | Regular font.
m_fontRegularBold | Regular bold font.
m_fontSmCaption | Small caption font.
m_fontToolTip | Tooltip font
m_fontVert | Vertical font.
m_fontVertBold | Vertical font.
m_iconsInfo | Specific icons options.
m_nAnimationSteps | Steps of the animation.
m_nAnimationTime | Time of the animation.
m_nEditHeight | Edit text height
m_nPopupBarTextPadding | Distance between gripper and control text.
m_nSplitButtonDropDownWidth | Split button drop down width in toolbars
m_nSplitButtonPopupWidth | Split button drop down width in popups
m_nTextHeight | Text height of the regular font.
m_pfnSetLayeredWindowAttributes | point to Transparency proc in USER32.dll module
m_pGalleryPaintManager | Gallery paint manager
m_strOfficeFont | Office font
m_systemTheme | Current system theme.
m_themeButton | Buttons theme helper.
m_themeCurrent | Current theme.
m_themeStatusBar | StatusBar theme helper.
s_pInstance | Instance of the manager.
CXTPPaintManager Destructors
CXTPPaintManager Destructors | Description
~CXTPPaintManager | Destroys a CXTPPaintManager object, handles cleanup and deallocation.
CXTPPaintManager Methods
CXTPPaintManager Methods | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
Animate | This method is called to animate the PopupBar.
AnimateExpanding | This method is called to animate the expanding process.
BaseTheme | Retrieves the base theme of the manager.
CreateTheme | Creates new PaintManager pointer.
Done | Call this method to destroy a paint manager object.
Draw3dRect | Call this member function to draw a three-dimensional rectangle.
DrawComboExpandMark | Call this member function to draw a combo box expand symbol
DrawCommandBarGripper | This method is called to draw the command bar's gripper.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawControl | This method is called to draw the control.
DrawControlCheckBoxMark | This method is called to draw check box mark area
DrawControlComboBox | This method is called to draw the control.
DrawControlEdit | This method is called to draw the control.
DrawControlEntry | This method is called to fill the control's face
DrawControlPopupParent | This method is called to draw the control placed on the PopupBar.
DrawControlRadioButtonMark | This method is called to draw radio button mark area
DrawControlText | This method is called to draw control text
DrawControlToolBarParent | This method is called to draw the control placed on the ToolBar.
DrawDialogBarGripper | Call this member to draw gripper of dialog bar.
DrawDropDownGlyph | This member function is called to draw a split button expand symbol
DrawImage | This method is called to draw the image of the control.
DrawListBoxControl | This method is called to draw the control placed on the ListBox.
DrawPopupBarCheckMark | Call this member function to draw a check mark.
DrawPopupBarGripper | This method is called to draw popup bar right gripper.
DrawPopupBarRadioMark | Call this member function to draw a radio button.
DrawRectangle | This method is called to fill the control's face
DrawSpecialControl | This method is called to draw the specified controls.
DrawSplitButtonFrame | This method is called to draw the frame for the SplitButton control
DrawStatusBarGripper | This method is called to draw the status bar's gripper.
DrawStatusBarPaneBorder | This method is called to draw frame of single cell of status bar.
DrawStatusBarPaneEntry | This method is called to draw a single pane text of the status bar.
DrawTearOffGripper | This method is called to draw a tear-off gripper of Popup Bar.
FillCommandBarEntry | This method is called to fill the command bar's face.
FillDockBar | This method is called to fill a dockbar.
FillStatusBar | This method is called to fill a status bar.
FontExists | Determines if the font exists in the system.
GetCommandBarBorders | This method is called to retrieve the command bar's borders.
GetControlEditBackColor | This method returns the edit control back color to draw.
GetControlFont | Call this member to retrieve the font of the command bar control
GetControlHeight | This method returns the common controls height.
GetControlTextColor | This method returns control text color to draw
GetControlTextOrientation | Call this member to determine how to draw text
GetCurrentSystemTheme | Call this member function to determine the current Windows XP theme in use.
GetCurrentTheme | Call this member to get the current visual theme.
GetGalleryPaintManager | Returns paint manager used to draw galleries
GetIconFont | Returns the icon font.
GetIconsInfo | Retrieves specific icon's options.
GetPopupBarGripperWidth | Calculates gripper of popup bar.
GetRectangleTextColor | This method retrieves buttons text color
GetRegularBoldFont | Returns the general bold font.
GetRegularFont | Returns the general font.
GetShadowOptions | Determines the kind of shadow to use.
GetSmCaptionFont | Call this method to retrieve caption of floating mini frame.
GetSplitButtonCommandRect | Determines split button command rectangle
GetXtremeColor | This function retrieves the current color of the specified XP display element. Display elements are the parts of a window and the display that appear on the system display screen. The function returns the red, green, blue (RGB) color value of the given element. To provide a consistent look to all Windows applications, the operating system provides and maintains global settings that define the colors of various aspects of the display. These settings as a group are sometimes referred to as a "color scheme." To view the current color settings, click Control Panel, double-click the Display icon, and then click... more
GradientFill | Gradient fills the rectangle.
HorizontalLine | Draws a line.
Line |
Pixel | Sets the pixel at the point.
Rectangle | Draws a rectangle.
RefreshMetrics | This method is called to refresh the visual metrics of the manager.
SetAnimationDelay | Call this method to set animation delay.
SetColors | Call this member to set the colors for each element to the color in the specified color array.
SetCommandBarRegion | This method is called to set bounding region for popup bars
SetCommandBarsFontIndirect | Call this member to set command bars font.
SetCustomTheme | Call this member to set a custom theme.
SetLunaTheme | Call this method to force system theme.
SetTheme | Call this member to switch the visual theme of the Command Bars.
StripMnemonics | This member function will search a string, strip off the mnemonic '&', and reformat the string.
Triangle | Draws a triangle.
UpdateColors | Refreshes the standard colors to use.
UpdateFonts | Refreshes the fonts to use.
UpdateRTLCaption | This method is called to prepare caption fro Right-To-Left draw
UseOfficeFont | Call this method to use Tahoma font despite system metrics.
VerticalLine | Draws a line.
CXTPPaintManager Structures
CXTPPaintManager Structures | Description
CLogFont | CLogFont is a self initializing LOGFONT derived class. It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.
CNonClientMetrics | CNonClientMetrics is a self initializing NONCLIENTMETRICS derived class. It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.


CXTPPaintManager Structures

CXTPPaintManager Class, Legend, Structures
CXTPPaintManager Structures
Class

CXTPPaintManager Class

Legend
Structure
Structures
Structure | Description
CLogFont | CLogFont is a self initializing LOGFONT derived class. It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.
CNonClientMetrics | CNonClientMetrics is a self initializing NONCLIENTMETRICS derived class. It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.


CXTPPaintManager::CLogFont Structure

XTPPaintManager.h, CXTPPaintManager Structures, Legend, Members, Topics, CLogFont Constructors, CLogFont Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::CLogFont Structure

CLogFont is a self initializing LOGFONT derived class. It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.

Class Hierarchy

struct CLogFont : public LOGFONT {
};
File

XTPPaintManager.h

Group

CXTPPaintManager Structures

Legend
Constructor
CLogFont Constructors
CLogFont Constructors | Description
CLogFont | Constructs an CLogFont object.


CLogFont Constructors

CXTPPaintManager::CLogFont Structure, Legend, Public Methods
CLogFont Constructors
Structure

CXTPPaintManager::CLogFont Structure

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CLogFont | Constructs an CLogFont object.


CXTPPaintManager::CLogFont::CLogFont Constructor

CLogFont Constructors, CXTPPaintManager::CLogFont Structure
CXTPPaintManager::CLogFont::CLogFont Constructor

Constructs an CLogFont object.

CLogFont();
Group

CLogFont Constructors


CXTPPaintManager::CNonClientMetrics Structure

XTPPaintManager.h, CXTPPaintManager Structures, Legend, Members, Topics, CNonClientMetrics Constructors, CNonClientMetrics Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::CNonClientMetrics Structure

CNonClientMetrics is a self initializing NONCLIENTMETRICS derived class. It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.

Class Hierarchy

struct CNonClientMetrics : public NONCLIENTMETRICS {
};
File

XTPPaintManager.h

Group

CXTPPaintManager Structures

Legend
Constructor
CNonClientMetrics Constructors
CNonClientMetrics Constructors | Description
CNonClientMetrics | Constructs a CNonClientMetrics object


CNonClientMetrics Constructors

CXTPPaintManager::CNonClientMetrics Structure, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CNonClientMetrics Constructors
Structure

CXTPPaintManager::CNonClientMetrics Structure

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CNonClientMetrics | Constructs a CNonClientMetrics object


CXTPPaintManager::CNonClientMetrics::CNonClientMetrics Constructor

CNonClientMetrics Constructors, CXTPPaintManager::CNonClientMetrics Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::CNonClientMetrics::CNonClientMetrics Constructor

Constructs a CNonClientMetrics object

CNonClientMetrics();
Group

CNonClientMetrics Constructors


CXTPPaintManager Data Members

CXTPPaintManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager Data Members
Class

CXTPPaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrColor | Self colors array.
m_bEmbossedDisabledText | TRUE to draw disabled text embossed
m_bShowKeyboardCues | TRUE to show keyboard cues - deprecated.
m_bUseOfficeFont | TRUE to use Tahoma font.
m_bUseStandardFont | TRUE to use system font.
m_fontRegular | Regular font.
m_fontRegularBold | Regular bold font.
m_fontVert | Vertical font.
m_fontVertBold | Vertical font.
m_iconsInfo | Specific icons options.
m_nAnimationSteps | Steps of the animation.
m_nAnimationTime | Time of the animation.
m_nEditHeight | Edit text height
m_nTextHeight | Text height of the regular font.
m_strOfficeFont | Office font
m_systemTheme | Current system theme.
m_themeButton | Buttons theme helper.
m_themeCurrent | Current theme.
m_themeStatusBar | StatusBar theme helper.
s_pInstance | Instance of the manager.
Public Data Members
Public Data Member | Description
m_bAutoResizeIcons | TRUE to automatically resize icons using current DPI
m_bClearTypeTextQuality | TRUE to enable ClearType text for the font.
m_bEnableAnimation | TRUE to enable animation for all toolbars
m_bFlatMenuBar | TRUE to draw menubar flat
m_bFlatToolBar | TRUE to draw toolbars flat
m_bOffice2007Padding | TRUE if Office2007 metrics used
m_bOffsetPopupLabelText | TRUE if labels in popups drawn with offset
m_bResourceCharSet | TRUE to use font CharSet from loaded resources.
m_bSelectImageInPopupBar | TRUE to select image as in explorer theme.
m_bShowShadow | TRUE to show shadow
m_bThemedCheckBox | TRUE to draw check box using WinXP theme.
m_bThemedStatusBar | TRUE to draw status bar using WinXP theme.
m_bThickCheckMark | TRUE to draw thick check mark
m_bWrapCaptionBelowText | Wrap text for xtpButtonIconAndCaptionBelow buttons
m_clrDisabledIcon | Disabled icons color
m_clrFloatingGripper | Gripper color of floating toolbar.
m_clrFloatingGripperText | Gripper text color of floating toolbar.
m_clrStatusTextColor | Status bar test color
m_fontIcon | Icon font.
m_fontIconBold | Icon bold font.
m_fontSmCaption | Small caption font.
m_fontToolTip | Tooltip font
m_nPopupBarTextPadding | Distance between gripper and control text.
m_nSplitButtonDropDownWidth | Split button drop down width in toolbars
m_nSplitButtonPopupWidth | Split button drop down width in popups
m_pfnSetLayeredWindowAttributes | point to Transparency proc in USER32.dll module
m_pGalleryPaintManager | Gallery paint manager


CXTPPaintManager::m_arrColor Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_arrColor Data Member

Self colors array.

CXTPPaintManagerColor m_arrColor[XPCOLOR_LAST + 1];
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bAutoResizeIcons Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bAutoResizeIcons Data Member

TRUE to automatically resize icons using current DPI

BOOL m_bAutoResizeIcons;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bClearTypeTextQuality Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bClearTypeTextQuality Data Member

TRUE to enable ClearType text for the font.

BOOL m_bClearTypeTextQuality;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bEmbossedDisabledText Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bEmbossedDisabledText Data Member

TRUE to draw disabled text embossed

BOOL m_bEmbossedDisabledText;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bEnableAnimation Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bEnableAnimation Data Member

TRUE to enable animation for all toolbars

BOOL m_bEnableAnimation;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bFlatMenuBar Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bFlatMenuBar Data Member

TRUE to draw menubar flat

BOOL m_bFlatMenuBar;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bFlatToolBar Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bFlatToolBar Data Member

TRUE to draw toolbars flat

BOOL m_bFlatToolBar;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bOffice2007Padding Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bOffice2007Padding Data Member

TRUE if Office2007 metrics used

BOOL m_bOffice2007Padding;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bOffsetPopupLabelText Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bOffsetPopupLabelText Data Member

TRUE if labels in popups drawn with offset

BOOL m_bOffsetPopupLabelText;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bResourceCharSet Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bResourceCharSet Data Member

TRUE to use font CharSet from loaded resources.

BOOL m_bResourceCharSet;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bSelectImageInPopupBar Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bSelectImageInPopupBar Data Member

TRUE to select image as in explorer theme.

BOOL m_bSelectImageInPopupBar;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bShowKeyboardCues Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bShowKeyboardCues Data Member

TRUE to show keyboard cues - deprecated.

BOOL m_bShowKeyboardCues;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bShowShadow Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bShowShadow Data Member

TRUE to show shadow

BOOL m_bShowShadow;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bThemedCheckBox Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bThemedCheckBox Data Member

TRUE to draw check box using WinXP theme.

BOOL m_bThemedCheckBox;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bThemedStatusBar Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bThemedStatusBar Data Member

TRUE to draw status bar using WinXP theme.

BOOL m_bThemedStatusBar;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bThickCheckMark Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bThickCheckMark Data Member

TRUE to draw thick check mark

BOOL m_bThickCheckMark;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bUseOfficeFont Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bUseOfficeFont Data Member

TRUE to use Tahoma font.

BOOL m_bUseOfficeFont;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bUseStandardFont Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bUseStandardFont Data Member

TRUE to use system font.

BOOL m_bUseStandardFont;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_bWrapCaptionBelowText Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_bWrapCaptionBelowText Data Member

Wrap text for xtpButtonIconAndCaptionBelow buttons

BOOL m_bWrapCaptionBelowText;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_clrDisabledIcon Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_clrDisabledIcon Data Member

Disabled icons color

CXTPPaintManagerColorGradient m_clrDisabledIcon;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_clrFloatingGripper Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_clrFloatingGripper Data Member

Gripper color of floating toolbar.

CXTPPaintManagerColor m_clrFloatingGripper;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_clrFloatingGripperText Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_clrFloatingGripperText Data Member

Gripper text color of floating toolbar.

CXTPPaintManagerColor m_clrFloatingGripperText;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_clrStatusTextColor Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_clrStatusTextColor Data Member

Status bar test color

COLORREF m_clrStatusTextColor;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_fontIcon Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_fontIcon Data Member

Icon font.

CXTPPaintManagerFont m_fontIcon;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_fontIconBold Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_fontIconBold Data Member

Icon bold font.

CXTPPaintManagerFont m_fontIconBold;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_fontRegular Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_fontRegular Data Member

Regular font.

CFont m_fontRegular;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_fontRegularBold Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_fontRegularBold Data Member

Regular bold font.

CFont m_fontRegularBold;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_fontSmCaption Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_fontSmCaption Data Member

Small caption font.

CXTPPaintManagerFont m_fontSmCaption;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_fontToolTip Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_fontToolTip Data Member

Tooltip font

CXTPPaintManagerFont m_fontToolTip;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_fontVert Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_fontVert Data Member

Vertical font.

CFont m_fontVert;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_fontVertBold Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_fontVertBold Data Member

Vertical font.

CFont m_fontVertBold;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_iconsInfo Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_iconsInfo Data Member

Specific icons options.

XTP_COMMANDBARS_ICONSINFO m_iconsInfo;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_nAnimationSteps Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_nAnimationSteps Data Member

Steps of the animation.

int m_nAnimationSteps;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_nAnimationTime Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_nAnimationTime Data Member

Time of the animation.

int m_nAnimationTime;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_nEditHeight Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_nEditHeight Data Member

Edit text height

int m_nEditHeight;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_nPopupBarTextPadding Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_nPopupBarTextPadding Data Member

Distance between gripper and control text.

int m_nPopupBarTextPadding;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_nSplitButtonDropDownWidth Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_nSplitButtonDropDownWidth Data Member

Split button drop down width in toolbars

int m_nSplitButtonDropDownWidth;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_nSplitButtonPopupWidth Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_nSplitButtonPopupWidth Data Member

Split button drop down width in popups

int m_nSplitButtonPopupWidth;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_nTextHeight Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_nTextHeight Data Member

Text height of the regular font.

int m_nTextHeight;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_pfnSetLayeredWindowAttributes Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_pfnSetLayeredWindowAttributes Data Member

point to Transparency proc in USER32.dll module

PVOID m_pfnSetLayeredWindowAttributes;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_pGalleryPaintManager Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_pGalleryPaintManager Data Member

Gallery paint manager

CXTPControlGalleryPaintManager* m_pGalleryPaintManager;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_strOfficeFont Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_strOfficeFont Data Member

Office font

CString m_strOfficeFont;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_systemTheme Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_systemTheme Data Member

Current system theme.

XTPCurrentSystemTheme m_systemTheme;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_themeButton Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_themeButton Data Member

Buttons theme helper.

CXTPWinThemeWrapper m_themeButton;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_themeCurrent Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_themeCurrent Data Member

Current theme.

XTPPaintTheme m_themeCurrent;
Group

CXTPPaintManager Data Members


CXTPPaintManager::m_themeStatusBar Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::m_themeStatusBar Data Member

StatusBar theme helper.

CXTPWinThemeWrapper m_themeStatusBar;
Group

CXTPPaintManager Data Members


CXTPPaintManager::s_pInstance Data Member

CXTPPaintManager Data Members, CXTPPaintManager Class
CXTPPaintManager::s_pInstance Data Member

Instance of the manager.

CXTPPaintManager* s_pInstance;
Group

CXTPPaintManager Data Members


CXTPPaintManager Methods

CXTPPaintManager Class, Legend, Public Methods
CXTPPaintManager Methods
Class

CXTPPaintManager Class

Legend
Method
abstract
virtual
Public Methods
Public Methods
Public Method | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
Animate | This method is called to animate the PopupBar.
AnimateExpanding | This method is called to animate the expanding process.
BaseTheme | Retrieves the base theme of the manager.
CreateTheme | Creates new PaintManager pointer.
Done | Call this method to destroy a paint manager object.
Draw3dRect | Call this member function to draw a three-dimensional rectangle.
DrawComboExpandMark | Call this member function to draw a combo box expand symbol
DrawCommandBarGripper | This method is called to draw the command bar's gripper.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawControl | This method is called to draw the control.
DrawControlCheckBoxMark | This method is called to draw check box mark area
DrawControlComboBox | This method is called to draw the control.
DrawControlEdit | This method is called to draw the control.
DrawControlEntry | This method is called to fill the control's face
DrawControlPopupParent | This method is called to draw the control placed on the PopupBar.
DrawControlRadioButtonMark | This method is called to draw radio button mark area
DrawControlText | This method is called to draw control text
DrawControlToolBarParent | This method is called to draw the control placed on the ToolBar.
DrawDialogBarGripper | Call this member to draw gripper of dialog bar.
DrawDropDownGlyph | This member function is called to draw a split button expand symbol
DrawImage | This method is called to draw the image of the control.
DrawListBoxControl | This method is called to draw the control placed on the ListBox.
DrawPopupBarCheckMark | Call this member function to draw a check mark.
DrawPopupBarGripper | This method is called to draw popup bar right gripper.
DrawPopupBarRadioMark | Call this member function to draw a radio button.
DrawRectangle | This method is called to fill the control's face
DrawSpecialControl | This method is called to draw the specified controls.
DrawSplitButtonFrame | This method is called to draw the frame for the SplitButton control
DrawStatusBarGripper | This method is called to draw the status bar's gripper.
DrawStatusBarPaneBorder | This method is called to draw frame of single cell of status bar.
DrawStatusBarPaneEntry | This method is called to draw a single pane text of the status bar.
DrawTearOffGripper | This method is called to draw a tear-off gripper of Popup Bar.
FillCommandBarEntry | This method is called to fill the command bar's face.
FillDockBar | This method is called to fill a dockbar.
FillStatusBar | This method is called to fill a status bar.
FontExists | Determines if the font exists in the system.
GetCommandBarBorders | This method is called to retrieve the command bar's borders.
GetControlEditBackColor | This method returns the edit control back color to draw.
GetControlFont | Call this member to retrieve the font of the command bar control
GetControlHeight | This method returns the common controls height.
GetControlTextColor | This method returns control text color to draw
GetControlTextOrientation | Call this member to determine how to draw text
GetCurrentSystemTheme | Call this member function to determine the current Windows XP theme in use.
GetCurrentTheme | Call this member to get the current visual theme.
GetGalleryPaintManager | Returns paint manager used to draw galleries
GetIconFont | Returns the icon font.
GetIconsInfo | Retrieves specific icon's options.
GetPopupBarGripperWidth | Calculates gripper of popup bar.
GetRectangleTextColor | This method retrieves buttons text color
GetRegularBoldFont | Returns the general bold font.
GetRegularFont | Returns the general font.
GetShadowOptions | Determines the kind of shadow to use.
GetSmCaptionFont | Call this method to retrieve caption of floating mini frame.
GetSplitButtonCommandRect | Determines split button command rectangle
GetXtremeColor | This function retrieves the current color of the specified XP display element. Display elements are the parts of a window and the display that appear on the system display screen. The function returns the red, green, blue (RGB) color value of the given element. To provide a consistent look to all Windows applications, the operating system provides and maintains global settings that define the colors of various aspects of the display. These settings as a group are sometimes referred to as a "color scheme." To view the current color settings, click Control Panel, double-click the Display icon, and then click... more
GradientFill | Gradient fills the rectangle.
HorizontalLine | Draws a line.
Line |
Pixel | Sets the pixel at the point.
Rectangle | Draws a rectangle.
RefreshMetrics | This method is called to refresh the visual metrics of the manager.
SetAnimationDelay | Call this method to set animation delay.
SetColors | Call this member to set the colors for each element to the color in the specified color array.
SetCommandBarRegion | This method is called to set bounding region for popup bars
SetCommandBarsFontIndirect | Call this member to set command bars font.
SetCustomTheme | Call this member to set a custom theme.
SetLunaTheme | Call this method to force system theme.
SetTheme | Call this member to switch the visual theme of the Command Bars.
StripMnemonics | This member function will search a string, strip off the mnemonic '&', and reformat the string.
Triangle | Draws a triangle.
UpdateColors | Refreshes the standard colors to use.
UpdateFonts | Refreshes the fonts to use.
UpdateRTLCaption | This method is called to prepare caption fro Right-To-Left draw
UseOfficeFont | Call this method to use Tahoma font despite system metrics.
VerticalLine | Draws a line.


CXTPPaintManager::AdjustExcludeRect Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::AdjustExcludeRect Method

This method is called to determine offset of popuped bar.

virtual void AdjustExcludeRect(
    CRect& rc,
    CXTPControl* pControl,
    BOOL bVertical
) = 0;
Parameters

rc
Control's bounding rectangle.
pControl
Points to a CXTPControl object
bVertical
TRUE if control docked vertically.

Group

CXTPPaintManager Methods


CXTPPaintManager::Animate Method

CXTPPaintManager Methods, CXTPPaintManager Class, See Also
CXTPPaintManager::Animate Method

This method is called to animate the PopupBar.

virtual void Animate(
    CDC* pDestDC,
    CDC* pSrcDC,
    CRect rc,
    XTPAnimationType animationType
);
Parameters

pDestDC
Pointer to device context you must draw to.
pSrcDC
Device context that contains the bitmap you must take.
rc
Bounding rectangle.
animationType
Type of animation to perform.

See Also

SetAnimationDelay

Group

CXTPPaintManager Methods


CXTPPaintManager::AnimateExpanding Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::AnimateExpanding Method

This method is called to animate the expanding process.

virtual void AnimateExpanding(
    CXTPCommandBar* pCommandBar,
    CDC* pDestDC,
    CDC* pSrcDC,
    BOOL bExpandDown
);
Parameters

pCommandBar
Command bar to animate.
pDestDC
Pointer to device context you must draw to.
pSrcDC
Device context that contains the bitmap you must take.
bExpandDown
TRUE to animate expanding top-to-bottom; FALSE to animate bottom-to-top.

Group

CXTPPaintManager Methods


CXTPPaintManager::BaseTheme Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::BaseTheme Method

Retrieves the base theme of the manager.

virtual XTPPaintTheme BaseTheme() = 0;
Returns

Returns the base theme.

Group

CXTPPaintManager Methods


CXTPPaintManager::CreateTheme Method

CXTPPaintManager Methods, CXTPPaintManager Class, Example
CXTPPaintManager::CreateTheme Method

Creates new PaintManager pointer.

static CXTPPaintManager* CreateTheme(
    XTPPaintTheme paintTheme
);
Parameters

paintTheme
Theme to be created.

Returns

Pointer to new CXTPPaintManager object.

Example
pCommandBars->SetPaintManager(CXTPPaintManager::CreateTheme(xtpThemeOfficeXP);
Group

CXTPPaintManager Methods


CXTPPaintManager::Done Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::Done Method

Call this method to destroy a paint manager object.

static void Done();
Group

CXTPPaintManager Methods


CXTPPaintManager::Draw3dRect Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::Draw3dRect Method

Call this member function to draw a three-dimensional rectangle.

void Draw3dRect(
    CDC* pDC,
    CRect rc,
    int nTopLeft,
    int nBottomRight
);
Parameters

pDC
Pointer to a valid device context
rc
Specifies the rectangle in logical units.
nTopLeft
Specifies the color of the top and left sides of the three-dimensional rectangle.
nBottomRight
Specifies the color of the bottom and right sides of the three-dimensional rectangle.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawComboExpandMark Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawComboExpandMark Method

Call this member function to draw a combo box expand symbol

virtual void DrawComboExpandMark(
    CDC* pDC,
    CRect rc,
    COLORREF clr
);
Parameters

pDC
Pointer to a valid device context
rc
Specifies the rectangle in logical units.
clr
Color to fill.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawCommandBarGripper Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawCommandBarGripper Method

This method is called to draw the command bar's gripper.

virtual CSize DrawCommandBarGripper(
    CDC* pDC,
    CXTPCommandBar* pBar,
    BOOL bDraw = TRUE
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
bDraw
TRUE to draw; FALSE to retrieve the size of the gripper.

Returns

Size of the gripper.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawCommandBarSeparator Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawCommandBarSeparator Method

This method is called to draw a command bar's separator.

virtual CSize DrawCommandBarSeparator(
    CDC* pDC,
    CXTPCommandBar* pBar,
    CXTPControl* pControl,
    BOOL bDraw = TRUE
) = 0;
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
pControl
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the separator.

Returns

This method is called to draw a command bar's separator.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControl Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControl Method

This method is called to draw the control.

CSize DrawControl(
    CDC* pDC,
    CXTPControl* pButton,
    BOOL bDraw = TRUE
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControlCheckBoxMark Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControlCheckBoxMark Method

This method is called to draw check box mark area

virtual CSize DrawControlCheckBoxMark(
    CDC* pDC,
    CRect rc,
    BOOL bDraw,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked,
    BOOL bEnabled
);
Parameters

pDC
Pointer to a valid device context
rc
Bounding rectangle
bDraw
TRUE to draw; FALSE to find size
bSelected
TRUE if control is selected
bPressed
TRUE if control is pressed
bChecked
TRUE if control is checked
bEnabled
TRUE if control is enabled

Returns

Size of check box mark

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControlComboBox Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControlComboBox Method

This method is called to draw the control.

virtual CSize DrawControlComboBox(
    CDC* pDC,
    CXTPControlComboBox* pCombo,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pCombo
ComboBox to draw.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControlEdit Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControlEdit Method

This method is called to draw the control.

virtual CSize DrawControlEdit(
    CDC* pDC,
    CXTPControlEdit* pEdit,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pEdit
Edit control to draw.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControlEntry Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControlEntry Method

This method is called to fill the control's face

virtual void DrawControlEntry(
    CDC* pDC,
    CXTPControl* pButton
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object to draw.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControlPopupParent Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControlPopupParent Method

This method is called to draw the control placed on the PopupBar.

virtual CSize DrawControlPopupParent(
    CDC* pDC,
    CXTPControl* pButton,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControlRadioButtonMark Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControlRadioButtonMark Method

This method is called to draw radio button mark area

virtual CSize DrawControlRadioButtonMark(
    CDC* pDC,
    CRect rc,
    BOOL bDraw,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked,
    BOOL bEnabled
);
Parameters

pDC
Pointer to a valid device context
rc
Bounding rectangle
bDraw
TRUE to draw; FALSE to find size
bSelected
TRUE if control is selected
bPressed
TRUE if control is pressed
bChecked
TRUE if control is checked
bEnabled
TRUE if control is enabled

Returns

Size of radio button mark

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControlText Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControlText Method

This method is called to draw control text

CSize DrawControlText(
    CDC* pDC,
    CXTPControl* pControl,
    CRect rcText,
    BOOL bDraw,
    BOOL bVert,
    BOOL bCentered,
    BOOL bTriangled
);
Parameters

pDC
Pointer to valid device context
pControl
Pointer to control to draw
rcText
Bounding rectangle of the text
bDraw
TRUE to draw text; FALSE to calculate size
bVert
TRUE if text is vertical
bCentered
TRUE if text is centered
bTriangled
TRUE if triangle drawn

Returns

Size of the text

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawControlToolBarParent Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawControlToolBarParent Method

This method is called to draw the control placed on the ToolBar.

virtual CSize DrawControlToolBarParent(
    CDC* pDC,
    CXTPControl* pButton,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawDialogBarGripper Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawDialogBarGripper Method

Call this member to draw gripper of dialog bar.

virtual CSize DrawDialogBarGripper(
    CDC* pDC,
    CXTPDialogBar* pBar,
    BOOL bDraw
) = 0;
Parameters

pDC
Points to a valid device context.
pBar
Dialog Bar pointer
bDraw
TRUE to draw gripper, FALSE to calculate size.

Returns

Size of gripper to be drawn.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawDropDownGlyph Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawDropDownGlyph Method

This member function is called to draw a split button expand symbol

virtual void DrawDropDownGlyph(
    CDC* pDC,
    CXTPControl* pControl,
    CPoint pt,
    BOOL bSelected,
    BOOL bPopuped,
    BOOL bEnabled,
    BOOL bVert
);
Parameters

pDC
Pointer to a valid device context
pControl
Points to a CXTPControl object
pt
Position of expand symbol
bSelected
TRUE if the control is selected.
bPopuped
TRUE if the control is popuped.
bEnabled
TRUE if the control is enabled.
bVert
TRUE if control is vertical

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawImage Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawImage Method

This method is called to draw the image of the control.

virtual void DrawImage(
    CDC* pDC,
    CPoint pt,
    CSize sz,
    CXTPImageManagerIcon* pImage,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled = TRUE,
    BOOL bChecked = FALSE,
    BOOL bPopuped = FALSE,
    BOOL bToolBarImage = TRUE
) = 0;
Parameters

pDC
Pointer to a valid device context
pt
Position to draw.
sz
Size of the image.
pImage
Points to a CXTPImageManagerIcon object
bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
bToolBarImage
TRUE if it is a toolbar image.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawListBoxControl Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawListBoxControl Method

This method is called to draw the control placed on the ListBox.

virtual CSize DrawListBoxControl(
    CDC* pDC,
    CXTPControl* pButton,
    CRect rc,
    BOOL bSelected,
    BOOL bDraw,
    CXTPCommandBars* pCommandBars = 0
) = 0;
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
rc
Bounding rectangle to draw.
bSelected
TRUE if the control is selected.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.
pCommandBars
CommandBars object which metrics need to use.

Returns

Size of the control.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawPopupBarCheckMark Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawPopupBarCheckMark Method

Call this member function to draw a check mark.

virtual void DrawPopupBarCheckMark(
    CDC* pDC,
    CRect rcCheck,
    BOOL bEnabled,
    COLORREF clr
);
Parameters

pDC
Pointer to a valid device context
rcCheck
Specifies the rectangle in logical units.
clr
Color to fill.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawPopupBarGripper Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawPopupBarGripper Method

This method is called to draw popup bar right gripper.

virtual void DrawPopupBarGripper(
    CDC* pDC,
    int xPos,
    int yPos,
    int cx,
    int cy,
    BOOL bExpanded = FALSE
);
Parameters

pDC
Points to a valid device context.
xPos
Specifies the logical x-coordinate of the upper-left corner of the rectangle.
yPos
Specifies the logical y-coordinate of the upper-left corner of the destination rectangle.
cx
Specifies the width of the rectangle.
cy
Specifies the height of the rectangle.
bExpanded
TRUE if expanded.gripper.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawPopupBarRadioMark Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawPopupBarRadioMark Method

Call this member function to draw a radio button.

virtual void DrawPopupBarRadioMark(
    CDC* pDC,
    CRect rcCheck,
    BOOL bEnabled,
    COLORREF clr
);
Parameters

pDC
Pointer to a valid device context
rcCheck
Specifies the rectangle in logical units.
clr
Color to fill.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawRectangle Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawRectangle Method

This method is called to fill the control's face

virtual void DrawRectangle(
    CDC* pDC,
    CRect rc,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
) = 0;
Parameters

pDC
Pointer to a valid device context
rc
Rectangle to draw.
bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawSpecialControl Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawSpecialControl Method

This method is called to draw the specified controls.

virtual CSize DrawSpecialControl(
    CDC* pDC,
    XTPSpecialControl controlType,
    CXTPControl* pButton,
    CXTPCommandBar* pBar,
    BOOL bDraw,
    LPVOID lpParam
);
Parameters

pDC
Pointer to a valid device context
controlType
Special control enumerator.
pButton
Points to a CXTPControl object to draw.
pBar
Parent CXTPCommandBar object.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.
lpParam
Specified parameter.

Returns

Size of the control.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawSplitButtonFrame Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawSplitButtonFrame Method

This method is called to draw the frame for the SplitButton control

virtual void DrawSplitButtonFrame(
    CDC* pDC,
    CXTPControl* pButton,
    CRect rc
) = 0;
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
rc
Bounding rectangle to draw

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawStatusBarGripper Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawStatusBarGripper Method

This method is called to draw the status bar's gripper.

virtual void DrawStatusBarGripper(
    CDC* pDC,
    CRect rcClient
);
Parameters

pDC
Pointer to a valid device context
rcClient
Client rectangle of the status bar.

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawStatusBarPaneBorder Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawStatusBarPaneBorder Method

This method is called to draw frame of single cell of status bar.

virtual void DrawStatusBarPaneBorder(
    CDC* pDC,
    CRect rc,
    CXTPStatusBarPane* pPane,
    BOOL bGripperPane
);
Parameters

pDC
Points to a valid device context.
rc
CRect object specifying size of area.
pPane
The status bar pane need to draw
bGripperPane
TRUE if pane is last cell of status bar

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawStatusBarPaneEntry Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawStatusBarPaneEntry Method

This method is called to draw a single pane text of the status bar.

virtual void DrawStatusBarPaneEntry(
    CDC* pDC,
    CRect rcItem,
    CXTPStatusBarPane* pPane
);
Parameters

pDC
Pointer to a valid device context
rcItem
Item rectangle
pPane
The status bar pane need to draw

Group

CXTPPaintManager Methods


CXTPPaintManager::DrawTearOffGripper Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::DrawTearOffGripper Method

This method is called to draw a tear-off gripper of Popup Bar.

virtual CSize DrawTearOffGripper(
    CDC* pDC,
    CRect rcGripper,
    BOOL bSelected,
    BOOL bDraw
) = 0;
Parameters

pDC
Pointer to a valid device context
rcGripper
Bounding rectangle of the gripper.
bSelected
True if the gripper is selected.
bDraw
TRUE to draw; FALSE to retrieve the size of the gripper.

Returns

Size of the gripper.

Group

CXTPPaintManager Methods


CXTPPaintManager::FillCommandBarEntry Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::FillCommandBarEntry Method

This method is called to fill the command bar's face.

virtual void FillCommandBarEntry(
    CDC* pDC,
    CXTPCommandBar* pBar
) = 0;
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object to draw.

Group

CXTPPaintManager Methods


CXTPPaintManager::FillDockBar Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::FillDockBar Method

This method is called to fill a dockbar.

virtual void FillDockBar(
    CDC* pDC,
    CXTPDockBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPDockBar object

Group

CXTPPaintManager Methods


CXTPPaintManager::FillStatusBar Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::FillStatusBar Method

This method is called to fill a status bar.

virtual void FillStatusBar(
    CDC* pDC,
    CXTPStatusBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPStatusBar object

Group

CXTPPaintManager Methods


CXTPPaintManager::FontExists Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::FontExists Method

Determines if the font exists in the system.

static BOOL FontExists(
    LPCTSTR lpszFaceName
);
Parameters

lpszFaceName
Font needed to test.

Returns

TRUE if font exists; otherwise returns FALSE

Group

CXTPPaintManager Methods


CXTPPaintManager::GetCommandBarBorders Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetCommandBarBorders Method

This method is called to retrieve the command bar's borders.

virtual CRect GetCommandBarBorders(
    CXTPCommandBar* pBar
);
Parameters

pBar
Points to a CXTPCommandBar object that the borders need to get.

Returns

Borders of the command bar.

Group

CXTPPaintManager Methods


CXTPPaintManager::GetControlEditBackColor Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetControlEditBackColor Method

This method returns the edit control back color to draw.

virtual COLORREF GetControlEditBackColor(
    CXTPControl* pControl
);
Parameters

pControl
Points to a CXTPControl object to get the back color from.

Returns

Edit control back color.

Group

CXTPPaintManager Methods


CXTPPaintManager::GetControlFont Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetControlFont Method

Call this member to retrieve the font of the command bar control

virtual CFont* GetControlFont(
    CXTPControl* pControl
);
Parameters

pBar
Points to a CXTPCommandBar object

Returns

A pointer to a CFont object

Group

CXTPPaintManager Methods


CXTPPaintManager::GetControlHeight Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetControlHeight Method

This method returns the common controls height.

int GetControlHeight() const;
Returns

Controls height.

Group

CXTPPaintManager Methods


CXTPPaintManager::GetControlTextColor Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetControlTextColor Method

This method returns control text color to draw

virtual COLORREF GetControlTextColor(
    CXTPControl* pButton
);
Parameters

pButton
Points to a CXTPControl object to draw.

Group

CXTPPaintManager Methods


CXTPPaintManager::GetControlTextOrientation Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetControlTextOrientation Method

Call this member to determine how to draw text

virtual XTPBarTextOrientation GetControlTextOrientation(
    CXTPControl* pControl
);
Parameters

pCommandBar
Points to a CXTPCommandBar object

Group

CXTPPaintManager Methods


CXTPPaintManager::GetCurrentSystemTheme Method

CXTPPaintManager Methods, CXTPPaintManager Class, See Also
CXTPPaintManager::GetCurrentSystemTheme Method

Call this member function to determine the current Windows XP theme in use.

XTPCurrentSystemTheme GetCurrentSystemTheme();
Returns

A XTPCurrentSystemTheme enumeration that represents the current Windows theme in use, can be one of the following values:

  • xtpSystemThemeUnknown Indicates no known theme in use
  • xtpSystemThemeBlue Indicates blue theme in use
  • xtpSystemThemeOlive Indicates olive theme in use
  • xtpSystemThemeSilver Indicates silver theme in use
See Also

SetLunaTheme, RefreshLunaColors

Group

CXTPPaintManager Methods


CXTPPaintManager::GetCurrentTheme Method

CXTPPaintManager Methods, CXTPPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::GetCurrentTheme Method

Call this member to get the current visual theme.

XTPPaintTheme GetCurrentTheme();
Returns

The current theme.

Body Source
XTPPaintTheme GetCurrentTheme() { return m_themeCurrent;}
Group

CXTPPaintManager Methods


CXTPPaintManager::GetGalleryPaintManager Method

CXTPPaintManager Methods, CXTPPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::GetGalleryPaintManager Method

Returns paint manager used to draw galleries

CXTPControlGalleryPaintManager* GetGalleryPaintManager() const;
Body Source
CXTPControlGalleryPaintManager* CXTPPaintManager::GetGalleryPaintManager() const {
    return m_pGalleryPaintManager;
}
Group

CXTPPaintManager Methods


CXTPPaintManager::GetIconFont Method

CXTPPaintManager Methods, CXTPPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::GetIconFont Method

Returns the icon font.

CFont* GetIconFont();
Returns

A pointer to a CFont object

Body Source
CFont* CXTPPaintManager::GetIconFont() {
    return &m_fontIcon;
}
Group

CXTPPaintManager Methods


CXTPPaintManager::GetIconsInfo Method

CXTPPaintManager Methods, CXTPPaintManager Class, See Also
CXTPPaintManager::GetIconsInfo Method

Retrieves specific icon's options.

XTP_COMMANDBARS_ICONSINFO* GetIconsInfo();
See Also

XTP_COMMANDBARS_ICONSINFO

Group

CXTPPaintManager Methods


CXTPPaintManager::GetPopupBarGripperWidth Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetPopupBarGripperWidth Method

Calculates gripper of popup bar.

virtual int GetPopupBarGripperWidth(
    CXTPCommandBar* pBar
);
Parameters

pBar
Popup bar.

Returns

Width of gripper to draw.

Group

CXTPPaintManager Methods


CXTPPaintManager::GetRectangleTextColor Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetRectangleTextColor Method

This method retrieves buttons text color

virtual COLORREF GetRectangleTextColor(
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
) = 0;
Parameters

bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPPaintManager Methods


CXTPPaintManager::GetRegularBoldFont Method

CXTPPaintManager Methods, CXTPPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::GetRegularBoldFont Method

Returns the general bold font.

CFont* GetRegularBoldFont();
Returns

A Pointer to a CFont object

Body Source
CFont* CXTPPaintManager::GetRegularBoldFont() {
    return &m_fontRegularBold;
}
Group

CXTPPaintManager Methods


CXTPPaintManager::GetRegularFont Method

CXTPPaintManager Methods, CXTPPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::GetRegularFont Method

Returns the general font.

CFont* GetRegularFont();
Returns

A Pointer to a CFont object

Body Source
CFont* CXTPPaintManager::GetRegularFont() {
    return this == NULL ? CFont ::FromHandle((HFONT)::GetStockObject(DEFAULT_GUI_FONT)): &m_fontRegular;
}
Group

CXTPPaintManager Methods


CXTPPaintManager::GetShadowOptions Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetShadowOptions Method

Determines the kind of shadow to use.

int GetShadowOptions() const;
Returns

TRUE to use alpha and solid shadow; otherwise returns FALSE

Group

CXTPPaintManager Methods


CXTPPaintManager::GetSmCaptionFont Method

CXTPPaintManager Methods, CXTPPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::GetSmCaptionFont Method

Call this method to retrieve caption of floating mini frame.

CFont* GetSmCaptionFont();
Returns

A pointer to a CFont object

Body Source
CFont* CXTPPaintManager::GetSmCaptionFont() {
    return &m_fontSmCaption;
}
Group

CXTPPaintManager Methods


CXTPPaintManager::GetSplitButtonCommandRect Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetSplitButtonCommandRect Method

Determines split button command rectangle

virtual CRect GetSplitButtonCommandRect(
    CXTPControl* pButton
);
Parameters

pButton
Button to test

Returns

Bounding rectangle of command part of split button

Group

CXTPPaintManager Methods


CXTPPaintManager::GetXtremeColor Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GetXtremeColor Method

This function retrieves the current color of the specified XP display element. Display elements are the parts of a window and the display that appear on the system display screen. The function returns the red, green, blue (RGB) color value of the given element. To provide a consistent look to all Windows applications, the operating system provides and maintains global settings that define the colors of various aspects of the display. These settings as a group are sometimes referred to as a "color scheme." To view the current color settings, click Control Panel, double-click the Display icon, and then click the "Appearance" tab.

COLORREF GetXtremeColor(
    UINT nIndex
);
Parameters

nIndex
Specifies the display element whose color is to be retrieved. This parameter can be one of the following values displayed in the table below:

Returns

The red, green, blue (RGB) color value of the given element.

Remarks
Constant | Value | Description
COLOR_SCROLLBAR | 0 | Scroll bar color
COLOR_BACKGROUND | 1 | Desktop color
COLOR_ACTIVECAPTION | 2 | Color of the title bar for the active window, Specifies the left side color in the color gradient of an active window's title bar if the gradient effect is enabled.
COLOR_INACTIVECAPTION | 3 | Color of the title bar for the inactive window, Specifies the left side color in the color gradient of an inactive window's title bar if the gradient effect is enabled.
COLOR_MENU | 4 | Menu background color
COLOR_WINDOW | 5 | Window background color
COLOR_WINDOWFRAME | 6 | Window frame color
COLOR_MENUTEXT | 7 | Color of text on menus
COLOR_WINDOWTEXT | 8 | Color of text in windows
COLOR_CAPTIONTEXT | 9 | Color of text in caption, size box, and scroll arrow
COLOR_ACTIVEBORDER | 10 | Border color of active window
COLOR_INACTIVEBORDER | 11 | Border color of inactive window
COLOR_APPWORKSPACE | 12 | Background color of multiple-document interface (MDI) applications
COLOR_HIGHLIGHT | 13 | Background color of items selected in a control
COLOR_HIGHLIGHTTEXT | 14 | Text color of items selected in a control
COLOR_BTNFACE | 15 | Face color for three-dimensional display elements and for dialog box backgrounds.
COLOR_BTNSHADOW | 16 | Color of shading on the edge of command buttons
COLOR_GRAYTEXT | 17 | Grayed (disabled) text
COLOR_BTNTEXT | 18 | Text color on push buttons
COLOR_INACTIVECAPTIONTEXT | 19 | Color of text in an inactive caption
COLOR_BTNHIGHLIGHT | 20 | Highlight color for 3-D display elements
COLOR_3DDKSHADOW | 21 | Darkest shadow color for 3-D display elements
COLOR_3DLIGHT | 22 | Second lightest 3-D color after 3DHighlight, Light color for three-dimensional display elements (for edges facing the light source.)
COLOR_INFOTEXT | 23 | Color of text in ToolTips
COLOR_INFOBK | 24 | Background color of ToolTips
COLOR_HOTLIGHT | 26 | Color for a hot-tracked item. Single clicking a hot-tracked item executes the item.
COLOR_GRADIENTACTIVECAPTION | 27 | Right side color in the color gradient of an active window's title bar. COLOR_ACTIVECAPTION specifies the left side color.
COLOR_GRADIENTINACTIVECAPTION | 28 | Right side color in the color gradient of an inactive window's title bar. COLOR_INACTIVECAPTION specifies the left side color.
XPCOLOR_TOOLBAR_FACE | 30 | XP toolbar background color.
XPCOLOR_HIGHLIGHT | 31 | XP menu item selected color.
XPCOLOR_HIGHLIGHT_BORDER | 32 | XP menu item selected border color.
XPCOLOR_HIGHLIGHT_PUSHED | 33 | XP menu item pushed color.
XPCOLOR_HIGHLIGHT_CHECKED | 36 | XP menu item checked color.
XPCOLOR_HIGHLIGHT_CHECKED_BORDER | 37 | An RGB value that represents the XP menu item checked border color.
XPCOLOR_ICONSHADDOW | 34 | XP menu item icon shadow.
XPCOLOR_GRAYTEXT | 35 | XP menu item disabled text color.
XPCOLOR_TOOLBAR_GRIPPER | 38 | XP toolbar gripper color.
XPCOLOR_SEPARATOR | 39 | XP toolbar separator color.
XPCOLOR_DISABLED | 40 | XP menu icon disabled color.
XPCOLOR_MENUBAR_FACE | 41 | XP menu item text background color.
XPCOLOR_MENUBAR_EXPANDED | 42 | XP hidden menu commands background color.
XPCOLOR_MENUBAR_BORDER | 43 | XP menu border color.
XPCOLOR_MENUBAR_TEXT | 44 | XP menu item text color.
XPCOLOR_HIGHLIGHT_TEXT | 45 | XP menu item selected text color.
XPCOLOR_TOOLBAR_TEXT | 46 | XP toolbar text color.
XPCOLOR_PUSHED_TEXT | 47 | XP toolbar pushed text color.
XPCOLOR_TAB_INACTIVE_BACK | 48 | XP inactive tab background color.
XPCOLOR_TAB_INACTIVE_TEXT | 49 | XP inactive tab text color.
XPCOLOR_HIGHLIGHT_PUSHED_BORDER | 50 | An RGB value that represents the XP border color for pushed in 3D elements.
XPCOLOR_CHECKED_TEXT | 45 | XP color for text displayed in a checked button.
XPCOLOR_3DFACE | 51 | XP face color for three- dimensional display elements and for dialog box backgrounds.
XPCOLOR_3DSHADOW | 52 | XP shadow color for three-dimensional display elements (for edges facing away from the light source).
XPCOLOR_EDITCTRLBORDER | 53 | XP color for the border color of edit controls.
XPCOLOR_FRAME | 54 | Office 2003 frame color.
XPCOLOR_SPLITTER_FACE | 55 | XP splitter face color.
XPCOLOR_LABEL | 56 | Color for label control (xtpControlLabel)
XPCOLOR_STATICFRAME | 57 | WinXP Static frame color
Group

CXTPPaintManager Methods


CXTPPaintManager::GradientFill Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::GradientFill Method

Gradient fills the rectangle.

void GradientFill(
    CDC* pDC,
    LPRECT lpRect,
    COLORREF crFrom,
    COLORREF crTo,
    BOOL bHorz,
    LPCRECT lpRectClip = NULL
);
Parameters

pDC
Pointer to a valid device context
lpRect
Specifies the rectangle in logical units.
crFrom
Start color.
crTo
Endpoint color.
bHorz
TRUE to fill horizontally.
lpRectClip
Pointer to a RECT structure that contains a clipping rectangle. This parameter is optional and may be set to NULL.

Group

CXTPPaintManager Methods


Line Method

CXTPPaintManager Methods
Line Method
Overload List
Methods
Method | Description
CXTPPaintManager::Line (CDC*, CPoint, CPoint) | Draws a line.
CXTPPaintManager::Line (CDC*, int, int, int, int, int) | Draws a line.
Group

CXTPPaintManager Methods


CXTPPaintManager::Line Method (CDC*, CPoint, CPoint)

Line Method, CXTPPaintManager Class
CXTPPaintManager::Line Method (CDC*, CPoint, CPoint)

Draws a line.

void Line(
    CDC* pDC,
    CPoint p0,
    CPoint p1
);
void Line(
    CDC* pDC,
    int x0,
    int y0,
    int x1,
    int y1,
    int nPen
);
void HorizontalLine(
    CDC* pDC,
    int x0,
    int y0,
    int x1,
    COLORREF clrPen
);
void VerticalLine(
    CDC* pDC,
    int x0,
    int y0,
    int y1,
    COLORREF clrPen
);
Parameters

pDC
Pointer to a valid device context
p0
Specifies the logical coordinates of the start position.
p1
Specifies the logical coordinates of the endpoint for the line.
x0
Specifies the logical x-coordinate of the start position.
y0
Specifies the logical y-coordinate of the start position.
x1
Specifies the logical x-coordinate of the endpoint for the line.
y1
Specifies the logical y-coordinate of the endpoint for the line.
nPen
Specifies the color used to paint the line.
clrPen
Specifies the color used to paint the line.

Group

Line Method


CXTPPaintManager::Pixel Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::Pixel Method

Sets the pixel at the point.

void Pixel(
    CDC* pDC,
    int xPos,
    int yPos,
    int nPen
);
Parameters

pDC
Pointer to a valid device context
xPos
Specifies the logical x-coordinate of the point to be set.
yPos
Specifies the logical y-coordinate of the point to be set.
nPen
Specifies the color used to paint the point

Group

CXTPPaintManager Methods


CXTPPaintManager::Rectangle Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::Rectangle Method

Draws a rectangle.

void Rectangle(
    CDC* pDC,
    CRect rc,
    int nPen,
    int nBrush
);
Parameters

pDC
Pointer to a valid device context
rc
Specifies the rectangle in logical units.
nPen
Specifies the color used to paint the rectangle.
nBrush
Specifies the color used to fill the rectangle.

Group

CXTPPaintManager Methods


CXTPPaintManager::RefreshMetrics Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::RefreshMetrics Method

This method is called to refresh the visual metrics of the manager.

virtual void RefreshMetrics();
Group

CXTPPaintManager Methods


CXTPPaintManager::SetAnimationDelay Method

CXTPPaintManager Methods, CXTPPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManager::SetAnimationDelay Method

Call this method to set animation delay.

void SetAnimationDelay(
    int nAnimationSteps,
    int nAnimationTime
);
Parameters

nAnimationSteps
Number of steps to take during animation.
nAnimationTime
Amount of time to rest, in milliseconds, between each step.

Body Source
void CXTPPaintManager::SetAnimationDelay(int nAnimationSteps, int nAnimationTime) {
    m_nAnimationSteps = nAnimationSteps;
    m_nAnimationTime = nAnimationTime;
}
Group

CXTPPaintManager Methods


CXTPPaintManager::SetColors Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::SetColors Method

Call this member to set the colors for each element to the color in the specified color array.

void SetColors(
    int cElements,
    CONST INT* lpaElements,
    CONST COLORREF* lpaRgbValues
);
Parameters

cElements
Number of elements in array.
lpaElements
Array of elements.
lpaRgbValues
Array of RGB values.

Group

CXTPPaintManager Methods


CXTPPaintManager::SetCommandBarRegion Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::SetCommandBarRegion Method

This method is called to set bounding region for popup bars

virtual void SetCommandBarRegion(
    CXTPCommandBar* pCommandBar
);
Parameters

pCommandBar
Pointer to popup bar which region need to set

Group

CXTPPaintManager Methods


CXTPPaintManager::SetCommandBarsFontIndirect Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::SetCommandBarsFontIndirect Method

Call this member to set command bars font.

void SetCommandBarsFontIndirect(
    LOGFONT* pLogFont,
    BOOL bUseStandardFont = FALSE
);
Parameters

pLogFont
New LOGFONT to use for text.
bUseStandardFont
When calling SetCommandBarsFontIndirect, always use FALSE, this will indicate that pLogFont should be used as the new font.

Group

CXTPPaintManager Methods


CXTPPaintManager::SetCustomTheme Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::SetCustomTheme Method

Call this member to set a custom theme.

static void SetCustomTheme(
    CXTPPaintManager* pTheme
);
Parameters

pTheme
theme to be set.

Group

CXTPPaintManager Methods


CXTPPaintManager::SetLunaTheme Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::SetLunaTheme Method

Call this method to force system theme.

void SetLunaTheme(
    XTPCurrentSystemTheme systemTheme
);
Parameters

systemTheme
theme to use. Can be any of the values listed in the Remarks section.

Remarks

theme can be one of the following:

  • xtpSystemThemeUnknown Disables luna theme support.
  • xtpSystemThemeBlue Enables blue theme
  • xtpSystemThemeOlive Enables olive theme
  • xtpSystemThemeSilver Enables silver theme
Group

CXTPPaintManager Methods


CXTPPaintManager::SetTheme Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::SetTheme Method

Call this member to switch the visual theme of the Command Bars.

static void SetTheme(
    XTPPaintTheme paintTheme
);
Parameters

paintTheme
Theme to be set. Can be any of the values listed in the Remarks section.

Remarks

paintTheme can be one of following:

  • xtpThemeOfficeXP Enables Office XP theme.
  • xtpThemeOffice2000 Enables Office 2000 theme.
  • xtpThemeOffice2003 Enables Office 2003 theme.
  • xtpThemeNativeWinXP Enables Windows XP themes support.
  • xtpThemeWhidbey Enables Visual Studio 2005 theme.
Group

CXTPPaintManager Methods


CXTPPaintManager::StripMnemonics Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::StripMnemonics Method

This member function will search a string, strip off the mnemonic '&', and reformat the string.

static void StripMnemonics(
    CString& strClear
);
Parameters

strClear
Text needed to strip.

Group

CXTPPaintManager Methods


CXTPPaintManager::Triangle Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::Triangle Method

Draws a triangle.

static void Triangle(
    CDC* pDC,
    CPoint pt0,
    CPoint pt1,
    CPoint pt2,
    COLORREF clr
);
Parameters

pDC
Pointer to a valid device context
pt0
Specifies the logical coordinates of the first point.
pt1
Specifies the logical coordinates of the second point.
pt2
Specifies the logical coordinates of the third point.
clr
Color to fill.

Group

CXTPPaintManager Methods


CXTPPaintManager::UpdateColors Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::UpdateColors Method

Refreshes the standard colors to use.

virtual void UpdateColors();
Group

CXTPPaintManager Methods


CXTPPaintManager::UpdateFonts Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::UpdateFonts Method

Refreshes the fonts to use.

virtual void UpdateFonts();
Group

CXTPPaintManager Methods


CXTPPaintManager::UpdateRTLCaption Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::UpdateRTLCaption Method

This method is called to prepare caption fro Right-To-Left draw

virtual void UpdateRTLCaption(
    CString& strCaption
);
Parameters

strCaption
Caption to modify

Group

CXTPPaintManager Methods


CXTPPaintManager::UseOfficeFont Method

CXTPPaintManager Methods, CXTPPaintManager Class
CXTPPaintManager::UseOfficeFont Method

Call this method to use Tahoma font despite system metrics.

void UseOfficeFont(
    bool bUseOfficeFont
);
Parameters

bUseOfficeFont
TRUE to use office font.

Group

CXTPPaintManager Methods


CXTPPaintManager Constructors

CXTPPaintManager Class, Legend, Protected Methods
CXTPPaintManager Constructors
Class

CXTPPaintManager Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPPaintManager | Constructs a CXTPPaintManager object


CXTPPaintManager::CXTPPaintManager Constructor

CXTPPaintManager Constructors, CXTPPaintManager Class
CXTPPaintManager::CXTPPaintManager Constructor

Constructs a CXTPPaintManager object

CXTPPaintManager();
Group

CXTPPaintManager Constructors


CXTPPaintManager Destructors

CXTPPaintManager Class, Legend, Protected Methods
CXTPPaintManager Destructors
Class

CXTPPaintManager Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPPaintManager | Destroys a CXTPPaintManager object, handles cleanup and deallocation.


CXTPPaintManager::~CXTPPaintManager Destructor

CXTPPaintManager Destructors, CXTPPaintManager Class
CXTPPaintManager::~CXTPPaintManager Destructor

Destroys a CXTPPaintManager object, handles cleanup and deallocation.

virtual ~CXTPPaintManager();
Group

CXTPPaintManager Destructors


CXTPPaintManagerFont Class

XTPPaintManager.h, Classes, Legend, Members, Topics, CXTPPaintManagerFont Data Members, CXTPPaintManagerFont Methods, CXTPPaintManagerFont Constructors, CXTPPaintManagerFont Constructors, CXTPPaintManagerFont Data Members, CXTPPaintManagerFont Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerFont Class

PaintManagers used CFont wrapper.

Class Hierarchy

class CXTPPaintManagerFont : public CFont;
File

XTPPaintManager.h

Group

Classes

Legend
Data Member
protected
Method
CXTPPaintManagerFont Constructors
CXTPPaintManagerFont Constructors | Description
CXTPPaintManagerFont | Constructs a CXTPPaintManagerFont object.
CXTPPaintManagerFont Data Members
CXTPPaintManagerFont Data Members | Description
m_bStandardFont | TRUE to use standard font;
CXTPPaintManagerFont Methods
CXTPPaintManagerFont Methods | Description
SetCustomFont |
SetStandardFont | Sets paint manager's font


CXTPPaintManagerFont Data Members

CXTPPaintManagerFont Class, Legend, Protected Data Members
CXTPPaintManagerFont Data Members
Class

CXTPPaintManagerFont Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bStandardFont | TRUE to use standard font;


CXTPPaintManagerFont::m_bStandardFont Data Member

CXTPPaintManagerFont Data Members, CXTPPaintManagerFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerFont::m_bStandardFont Data Member

TRUE to use standard font;

BOOL m_bStandardFont;
Group

CXTPPaintManagerFont Data Members


CXTPPaintManagerFont Methods

CXTPPaintManagerFont Class, Legend, Public Methods
CXTPPaintManagerFont Methods
Class

CXTPPaintManagerFont Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetCustomFont |
SetStandardFont | Sets paint manager's font


SetCustomFont Method

CXTPPaintManagerFont Methods
SetCustomFont Method
Overload List
Methods
Method | Description
CXTPPaintManagerFont::SetCustomFont (BOOL) | Call this method to set custom font
CXTPPaintManagerFont::SetCustomFont (const LOGFONT*) | Sets application defined font
Group

CXTPPaintManagerFont Methods


CXTPPaintManagerFont::SetCustomFont Method (BOOL)

SetCustomFont Method, CXTPPaintManagerFont Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerFont::SetCustomFont Method (BOOL)

Call this method to set custom font

void SetCustomFont(
    BOOL bCustomFont
);
Parameters

bCustomFont
TRUE if custom font used

See Also

SetStandardFont

Body Source
void SetCustomFont(BOOL bCustomFont)
{
    m_bStandardFont = !bCustomFont;
}
Group

SetCustomFont Method


CXTPPaintManagerFont::SetCustomFont Method (const LOGFONT*)

SetCustomFont Method, CXTPPaintManagerFont Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerFont::SetCustomFont Method (const LOGFONT*)

Sets application defined font

BOOL SetCustomFont(
    const LOGFONT* lpLogFont
);
Parameters

lpLogFont
Application defined font

Body Source
BOOL SetCustomFont(const LOGFONT* lpLogFont)
{
    m_bStandardFont = (lpLogFont == NULL);
    if (lpLogFont)
    {
        DeleteObject();
        return CreateFontIndirect(lpLogFont);
    }
    return TRUE;
}
Group

SetCustomFont Method


CXTPPaintManagerFont::SetStandardFont Method

CXTPPaintManagerFont Methods, CXTPPaintManagerFont Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerFont::SetStandardFont Method

Sets paint manager's font

BOOL SetStandardFont(
    const LOGFONT* lpLogFont
);
Parameters

lpLogFont
PaintManager's defined font

Body Source
BOOL SetStandardFont(const LOGFONT* lpLogFont)
{
    if (lpLogFont && (m_bStandardFont || !GetSafeHandle()))
    {
        DeleteObject();
        return CreateFontIndirect(lpLogFont);
    }
    return TRUE;
}
Group

CXTPPaintManagerFont Methods


CXTPPaintManagerFont Constructors

CXTPPaintManagerFont Class, Legend, Public Methods
CXTPPaintManagerFont Constructors
Class

CXTPPaintManagerFont Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPaintManagerFont | Constructs a CXTPPaintManagerFont object.


CXTPPaintManagerFont::CXTPPaintManagerFont Constructor

CXTPPaintManagerFont Constructors, CXTPPaintManagerFont Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerFont::CXTPPaintManagerFont Constructor

Constructs a CXTPPaintManagerFont object.

CXTPPaintManagerFont();
Body Source
CXTPPaintManagerFont()
{
    m_bStandardFont = TRUE;
}
Group

CXTPPaintManagerFont Constructors


CXTPPopupBar Class

XTPPopupBar.h, Classes, Legend, Members, Topics, CXTPPopupBar Data Members, CXTPPopupBar Methods, CXTPPopupBar Constructors, CXTPPopupBar Destructors, CXTPPopupBar Constructors, CXTPPopupBar Data Members, CXTPPopupBar Destructors, CXTPPopupBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupBar Class

CXTPPopupBar is a CXTPCommandBar derived class. It represents submenu of menu bar.

Class Hierarchy

class CXTPPopupBar : public CXTPCommandBar;
File

XTPPopupBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPopupBar Constructors
CXTPPopupBar Constructors | Description
CXTPPopupBar | Constructs a CXTPPopupBar object
CXTPPopupBar Data Members
CXTPPopupBar Data Members | Description
m_bCollapsed | TRUE if popupbar is collapsed.
m_bContextMenu | TRUE if popup bar is context menu
m_bDoubleGripper | TRUE if popup is state popup type
m_bDynamicLayout | TRUE if DynamicLayout routine executed.
m_bExpanded | TRUE if popupbar is expanded.
m_bExpanding | TRUE if popupbar is expanding.
m_bResizable | TRUE to allow resize
m_bShowShadow | TRUE to show the shadow.
m_bTearOffPopup | TRUE if popupbar has tear-off option.
m_bTearOffSelected | TRUE if gripper selected.
m_bTearOffTracking | Tear-off tracking mode.
m_dMaxWidthDivisor | Maximum available width of popup
m_nTearOffID | ID of the Tear-off toolbar.
m_nTearOffTimer | Tear-off timer.
m_nTearOffWidth | Width of the Tear-off toolbar.
m_pControlPopup | Control that popuped the bar.
m_popupFlags | Flags of the bar.
m_pTearOffBar | Tear-off toolbar pointer.
m_ptPopup | Position of the bar.
m_rcBorders | Borders of the bar.
m_rcExclude | Excluded area.
m_rcResizeGripper | Resizable gripper position.
m_rcTearOffGripper | Tear-off gripper position.
m_strTearOffCaption | Caption of the Tear-off toolbar.
m_szTearOffBar | Size of the bar.
CXTPPopupBar Destructors
CXTPPopupBar Destructors | Description
~CXTPPopupBar | Destroys a CXTPPopupBar object, handles cleanup and deallocation
CXTPPopupBar Methods
CXTPPopupBar Methods | Description
AdjustExcludeRect | Updates rectangle to set position where popup bar become visible.
CalcDynamicLayout | This method is called to get the size of the command bar.
CalculatePopupRect | This method is called to calculate destination rectangle of popup bar
Copy | Call this method make a copy of the command bar.
Create | Creates the popup bar.
CreatePopupBar | Creates a popup bar object.
DelayRedraw | Redraw the popup bar.
DestroyWindow | Call this member to destroy the window.
DisableShadow | Disables shadow use.
DoPropExchange | Reads or writes this object from or to an archive.
DrawCommandBar | This method is called to draw the command bar in the given context.
ExpandBar | This method expands the bar.
GetControlPopup | Call this member to retrieve the control's popup.
GetDefaultItem | Determines the default menu item on the specified popup bar.
GetParentCommandBar | Call this member to retrieve the parent command bar
IsContextMenu | Determines if popup bar was added as context menu.
IsDoubleGripper | Call this method to determine if popup bar has double gripper.
IsPopupBar | Call this member function to determine if the CommandBar is a CXTPPopupBar.
IsTearOffPopup | Determines if Popupbar has tear-off state.
IsVisible | Call this member to determine if the popup menu is currently visiblepopped up.
OnControlsChanged | This method is called when the controls array is changed.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnRecalcLayout | This method is called to recalculate the command bar layout.
Popup |
PumpMessage | Translates all messages in message queue.
SetBorders | Sets the toolbars borders.
SetDefaultItem | Sets the default menu item for the specified popup bar.
SetDoubleGripper | Call this member to set double gripper for popup bar
SetPopupToolBar | Call this method to make popup bar looks like popup toolbar.
SetSelected | Call this member to select the specified control.
SetTearOffPopup | This method adds the tear-off state to the popup bar.
SetTrackingMode | Call this member to change the tracking state.
UpdateExpandingState | Update expanding state.
UpdateFlags | Update flags.
UpdateLocation | This method sets the PopupBar position.


CXTPPopupBar Data Members

CXTPPopupBar Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupBar Data Members
Class

CXTPPopupBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bCollapsed | TRUE if popupbar is collapsed.
m_bContextMenu | TRUE if popup bar is context menu
m_bDoubleGripper | TRUE if popup is state popup type
m_bDynamicLayout | TRUE if DynamicLayout routine executed.
m_bExpanded | TRUE if popupbar is expanded.
m_bExpanding | TRUE if popupbar is expanding.
m_bResizable | TRUE to allow resize
m_bShowShadow | TRUE to show the shadow.
m_bTearOffPopup | TRUE if popupbar has tear-off option.
m_bTearOffSelected | TRUE if gripper selected.
m_bTearOffTracking | Tear-off tracking mode.
m_nTearOffID | ID of the Tear-off toolbar.
m_nTearOffTimer | Tear-off timer.
m_nTearOffWidth | Width of the Tear-off toolbar.
m_pControlPopup | Control that popuped the bar.
m_popupFlags | Flags of the bar.
m_pTearOffBar | Tear-off toolbar pointer.
m_ptPopup | Position of the bar.
m_rcBorders | Borders of the bar.
m_rcExclude | Excluded area.
m_rcResizeGripper | Resizable gripper position.
m_rcTearOffGripper | Tear-off gripper position.
m_strTearOffCaption | Caption of the Tear-off toolbar.
m_szTearOffBar | Size of the bar.
Public Data Members
Public Data Member | Description
m_dMaxWidthDivisor | Maximum available width of popup


CXTPPopupBar::m_bCollapsed Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bCollapsed Data Member

TRUE if popupbar is collapsed.

BOOL m_bCollapsed;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bContextMenu Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bContextMenu Data Member

TRUE if popup bar is context menu

BOOL m_bContextMenu;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bDoubleGripper Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bDoubleGripper Data Member

TRUE if popup is state popup type

BOOL m_bDoubleGripper;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bDynamicLayout Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bDynamicLayout Data Member

TRUE if DynamicLayout routine executed.

BOOL m_bDynamicLayout;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bExpanded Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bExpanded Data Member

TRUE if popupbar is expanded.

BOOL m_bExpanded;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bExpanding Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bExpanding Data Member

TRUE if popupbar is expanding.

BOOL m_bExpanding;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bResizable Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bResizable Data Member

TRUE to allow resize

BOOL m_bResizable;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bShowShadow Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bShowShadow Data Member

TRUE to show the shadow.

BOOL m_bShowShadow;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bTearOffPopup Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bTearOffPopup Data Member

TRUE if popupbar has tear-off option.

BOOL m_bTearOffPopup;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bTearOffSelected Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bTearOffSelected Data Member

TRUE if gripper selected.

BOOL m_bTearOffSelected;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_bTearOffTracking Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_bTearOffTracking Data Member

Tear-off tracking mode.

BOOL m_bTearOffTracking;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_dMaxWidthDivisor Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_dMaxWidthDivisor Data Member

Maximum available width of popup

double m_dMaxWidthDivisor;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_nTearOffID Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_nTearOffID Data Member

ID of the Tear-off toolbar.

UINT m_nTearOffID;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_nTearOffTimer Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_nTearOffTimer Data Member

Tear-off timer.

UINT_PTR m_nTearOffTimer;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_nTearOffWidth Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_nTearOffWidth Data Member

Width of the Tear-off toolbar.

int m_nTearOffWidth;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_pControlPopup Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_pControlPopup Data Member

Control that popuped the bar.

CXTPControlPopup* m_pControlPopup;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_popupFlags Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_popupFlags Data Member

Flags of the bar.

DWORD m_popupFlags;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_pTearOffBar Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_pTearOffBar Data Member

Tear-off toolbar pointer.

CXTPToolBar* m_pTearOffBar;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_ptPopup Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_ptPopup Data Member

Position of the bar.

CPoint m_ptPopup;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_rcBorders Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_rcBorders Data Member

Borders of the bar.

CRect m_rcBorders;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_rcExclude Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_rcExclude Data Member

Excluded area.

CRect m_rcExclude;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_rcResizeGripper Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_rcResizeGripper Data Member

Resizable gripper position.

CRect m_rcResizeGripper;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_rcTearOffGripper Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_rcTearOffGripper Data Member

Tear-off gripper position.

CRect m_rcTearOffGripper;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_strTearOffCaption Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_strTearOffCaption Data Member

Caption of the Tear-off toolbar.

CString m_strTearOffCaption;
Group

CXTPPopupBar Data Members


CXTPPopupBar::m_szTearOffBar Data Member

CXTPPopupBar Data Members, CXTPPopupBar Class
CXTPPopupBar::m_szTearOffBar Data Member

Size of the bar.

CSize m_szTearOffBar;
Group

CXTPPopupBar Data Members


CXTPPopupBar Methods

CXTPPopupBar Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupBar Methods
Class

CXTPPopupBar Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AdjustExcludeRect | Updates rectangle to set position where popup bar become visible.
Copy | Call this method make a copy of the command bar.
DelayRedraw | Redraw the popup bar.
DoPropExchange | Reads or writes this object from or to an archive.
DrawCommandBar | This method is called to draw the command bar in the given context.
GetParentCommandBar | Call this member to retrieve the parent command bar
OnControlsChanged | This method is called when the controls array is changed.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnRecalcLayout | This method is called to recalculate the command bar layout.
SetSelected | Call this member to select the specified control.
UpdateExpandingState | Update expanding state.
UpdateFlags | Update flags.
UpdateLocation | This method sets the PopupBar position.
Public Methods
Public Methods
Public Method | Description
CalcDynamicLayout | This method is called to get the size of the command bar.
CalculatePopupRect | This method is called to calculate destination rectangle of popup bar
Create | Creates the popup bar.
CreatePopupBar | Creates a popup bar object.
DestroyWindow | Call this member to destroy the window.
DisableShadow | Disables shadow use.
ExpandBar | This method expands the bar.
GetControlPopup | Call this member to retrieve the control's popup.
GetDefaultItem | Determines the default menu item on the specified popup bar.
IsContextMenu | Determines if popup bar was added as context menu.
IsDoubleGripper | Call this method to determine if popup bar has double gripper.
IsPopupBar | Call this member function to determine if the CommandBar is a CXTPPopupBar.
IsTearOffPopup | Determines if Popupbar has tear-off state.
IsVisible | Call this member to determine if the popup menu is currently visiblepopped up.
Popup |
PumpMessage | Translates all messages in message queue.
SetBorders | Sets the toolbars borders.
SetDefaultItem | Sets the default menu item for the specified popup bar.
SetDoubleGripper | Call this member to set double gripper for popup bar
SetPopupToolBar | Call this method to make popup bar looks like popup toolbar.
SetTearOffPopup | This method adds the tear-off state to the popup bar.
SetTrackingMode | Call this member to change the tracking state.


CXTPPopupBar::AdjustExcludeRect Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::AdjustExcludeRect Method

Updates rectangle to set position where popup bar become visible.

virtual void AdjustExcludeRect(
    CRect& rc,
    BOOL bVertical
);
Parameters

rc
CRect object specifying size of exclude area.
bVertical
TRUE if parent control is located vertically in bar.

Group

CXTPPopupBar Methods


CXTPPopupBar::CalcDynamicLayout Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::CalcDynamicLayout Method

This method is called to get the size of the command bar.

CSize CalcDynamicLayout(
    int nLength,
    DWORD dwMode
);
Parameters

nLength
The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode
see CControlBar::CalcDynamicLayout for list of supported flags.

Returns

Size of the command bar.

Group

CXTPPopupBar Methods


CXTPPopupBar::CalculatePopupRect Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::CalculatePopupRect Method

This method is called to calculate destination rectangle of popup bar

virtual CRect CalculatePopupRect(
    CPoint ptPopup,
    CSize sz
);
Parameters

sz
Size of popup bar

Returns

Rectangle where popup bar will be located.

Group

CXTPPopupBar Methods


CXTPPopupBar::Copy Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::Copy Method

Call this method make a copy of the command bar.

virtual void Copy(
    CXTPCommandBar* pCommandBar,
    BOOL bRecursive = FALSE
);
Parameters

pCommandBar
Command bar needed to be copied.
bRecursive
TRUE to copy recursively.

Group

CXTPPopupBar Methods


CXTPPopupBar::Create Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::Create Method

Creates the popup bar.

virtual BOOL Create();
Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPPopupBar Methods


CXTPPopupBar::CreatePopupBar Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::CreatePopupBar Method

Creates a popup bar object.

static CXTPPopupBar* CreatePopupBar(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
Points to a CXTPCommandBars object

Returns

A pointer to a CXTPPopupBar object

Group

CXTPPopupBar Methods


CXTPPopupBar::DelayRedraw Method

CXTPPopupBar Methods, CXTPPopupBar Class, Body Source
CXTPPopupBar::DelayRedraw Method

Redraw the popup bar.

void DelayRedraw();
Body Source
void DelayRedraw() { Redraw(); }
Group

CXTPPopupBar Methods


CXTPPopupBar::DestroyWindow Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::DestroyWindow Method

Call this member to destroy the window.

BOOL DestroyWindow();
Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPPopupBar Methods


CXTPPopupBar::DisableShadow Method

CXTPPopupBar Methods, CXTPPopupBar Class, Body Source
CXTPPopupBar::DisableShadow Method

Disables shadow use.

void DisableShadow();
Body Source
void CXTPPopupBar::DisableShadow() {
    m_bShowShadow = FALSE;
}
Group

CXTPPopupBar Methods


CXTPPopupBar::DoPropExchange Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPPopupBar Methods


CXTPPopupBar::DrawCommandBar Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::DrawCommandBar Method

This method is called to draw the command bar in the given context.

void DrawCommandBar(
    CDC* pDC,
    CRect rcClipBox
);
Parameters

pDC
Pointer to a valid device context
rcClipBox
The rectangular area of the control that is invalid

Group

CXTPPopupBar Methods


CXTPPopupBar::ExpandBar Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::ExpandBar Method

This method expands the bar.

void ExpandBar();
Group

CXTPPopupBar Methods


CXTPPopupBar::GetControlPopup Method

CXTPPopupBar Methods, CXTPPopupBar Class, Body Source
CXTPPopupBar::GetControlPopup Method

Call this member to retrieve the control's popup.

CXTPControlPopup* GetControlPopup() const;
Returns

A pointer to a CXTPControlPopup object.

Body Source
CXTPControlPopup* CXTPPopupBar::GetControlPopup() const {
    return m_pControlPopup;
}
Group

CXTPPopupBar Methods


CXTPPopupBar::GetDefaultItem Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::GetDefaultItem Method

Determines the default menu item on the specified popup bar.

UINT GetDefaultItem(
    UINT gmdiFlags,
    BOOL fByPos = FALSE
);
Parameters

gmdiFlags
Reserved. Should be NULL.
fByPos
Value specifying whether to retrieve the menu item's identifier or its position. If this parameter is FALSE, the identifier is returned. Otherwise, the position is returned.

Returns

If the function succeeds, the return value is the identifier or position of the menu item. If the function fails, the return value is - 1.

Group

CXTPPopupBar Methods


CXTPPopupBar::GetParentCommandBar Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::GetParentCommandBar Method

Call this member to retrieve the parent command bar

CXTPCommandBar* GetParentCommandBar() const;
Returns

A pointer to a CXTPCommandBar object

Group

CXTPPopupBar Methods


CXTPPopupBar::IsContextMenu Method

CXTPPopupBar Methods, CXTPPopupBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupBar::IsContextMenu Method

Determines if popup bar was added as context menu.

BOOL IsContextMenu() const;
Returns

TRUE if popup bar is context menu

See Also

CXTPCommandBarsContextMenus

Body Source
BOOL CXTPPopupBar::IsContextMenu() const {
    return m_bContextMenu;
}
Group

CXTPPopupBar Methods


CXTPPopupBar::IsDoubleGripper Method

CXTPPopupBar Methods, CXTPPopupBar Class, Body Source
CXTPPopupBar::IsDoubleGripper Method

Call this method to determine if popup bar has double gripper.

BOOL IsDoubleGripper() const;
Returns

TRUE if popup bar has double gripper.

Body Source
BOOL CXTPPopupBar::IsDoubleGripper() const {
    return m_bDoubleGripper;
}
Group

CXTPPopupBar Methods


CXTPPopupBar::IsPopupBar Method

CXTPPopupBar Methods, CXTPPopupBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupBar::IsPopupBar Method

Call this member function to determine if the CommandBar is a CXTPPopupBar.

virtual BOOL IsPopupBar() const;
Returns

Returns TRUE if the CommandBar is a CXTPPopupBar, otherwise FALSE

See Also

CXTPCommandBar, CXTPPopupBar

Body Source
BOOL CXTPPopupBar::IsPopupBar() const {
    return TRUE;
}
Group

CXTPPopupBar Methods


CXTPPopupBar::IsTearOffPopup Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::IsTearOffPopup Method

Determines if Popupbar has tear-off state.

BOOL IsTearOffPopup(
    CString& strCaption,
    UINT& nID,
    int& nWidth
);
Parameters

strCaption
Caption of the tear-off toolbar.
nID
Identifier of the toolbar to be created.
nWidth
Width of the toolbar.

Returns

TRUE if tear-off; otherwise returns FALSE

Group

CXTPPopupBar Methods


CXTPPopupBar::IsVisible Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::IsVisible Method

Call this member to determine if the popup menu is currently visiblepopped up.

BOOL IsVisible() const;
Returns

TRUE is the popup menu is visible/displayed, FALSE if the popup menu is currently hidden.

Group

CXTPPopupBar Methods


CXTPPopupBar::OnControlsChanged Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::OnControlsChanged Method

This method is called when the controls array is changed.

virtual void OnControlsChanged();
Group

CXTPPopupBar Methods


CXTPPopupBar::OnHookKeyDown Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::OnHookKeyDown Method

The framework calls this member function when a non-system key is pressed.

virtual BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE

Group

CXTPPopupBar Methods


CXTPPopupBar::OnRecalcLayout Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::OnRecalcLayout Method

This method is called to recalculate the command bar layout.

void OnRecalcLayout();
Group

CXTPPopupBar Methods


Popup Method

CXTPPopupBar Methods
Popup Method
Overload List
Methods
Method | Description
CXTPPopupBar::Popup (CXTPControlPopup*, BOOL) | This method opens the popup bar.
CXTPPopupBar::Popup (int, int, LPCRECT) | This method opens the popup bar.
Group

CXTPPopupBar Methods


CXTPPopupBar::Popup Method (int, int, LPCRECT)

Popup Method, CXTPPopupBar Class
CXTPPopupBar::Popup Method (int, int, LPCRECT)

This method opens the popup bar.

BOOL Popup(
    int xPos,
    int yPos,
    LPCRECT rcExclude
);
BOOL Popup(
    CXTPControlPopup* pControlPopup,
    BOOL bSelectFirst = FALSE
);
Parameters

xPos
Specifies the logical x-coordinate of the popup bar
yPos
Specifies the logical y-coordinate of the position.
rcExclude
Excluded area.
pControlPopup
Pointer to a CXTPControlPopup object
bSelectFirst
TRUE to select the first item.

Returns

TRUE if successful; otherwise returns FALSE.

Group

Popup Method


CXTPPopupBar::PumpMessage Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::PumpMessage Method

Translates all messages in message queue.

void PumpMessage();
Group

CXTPPopupBar Methods


CXTPPopupBar::SetBorders Method

CXTPPopupBar Methods, CXTPPopupBar Class, Body Source
CXTPPopupBar::SetBorders Method

Sets the toolbars borders.

void SetBorders(
    CRect rcBorders
);
Parameters

rcBorders
Borders of the toolbar.

Body Source
void CXTPPopupBar::SetBorders(CRect rcBorders) {
    m_rcBorders = rcBorders;
}
Group

CXTPPopupBar Methods


CXTPPopupBar::SetDefaultItem Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::SetDefaultItem Method

Sets the default menu item for the specified popup bar.

void SetDefaultItem(
    UINT uItem,
    BOOL fByPos = FALSE
);
Parameters

uItem
Identifier or position of the new default menu item or

  • 1 for no default item. The meaning of this parameter

depends on the value of fByPos.

fByPos
Value specifying the meaning of uItem. If this parameter is FALSE, uItem is a menu item identifier. Otherwise, it is a menu item position.

Group

CXTPPopupBar Methods


CXTPPopupBar::SetDoubleGripper Method

CXTPPopupBar Methods, CXTPPopupBar Class, Body Source
CXTPPopupBar::SetDoubleGripper Method

Call this member to set double gripper for popup bar

void SetDoubleGripper(
    BOOL bDoubleGripper = TRUE
);
Parameters

bDoubleGripper
TRUE to set double gripper for popup bar

Body Source
void CXTPPopupBar::SetDoubleGripper(BOOL bDoubleGripper /*= TRUE*/) {
    m_bDoubleGripper = bDoubleGripper;
}
Group

CXTPPopupBar Methods


CXTPPopupBar::SetPopupToolBar Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::SetPopupToolBar Method

Call this method to make popup bar looks like popup toolbar.

void SetPopupToolBar(
    BOOL bToolBarType
);
Parameters

bToolBarType
TRUE to make bar as popup toolbar

Group

CXTPPopupBar Methods


CXTPPopupBar::SetSelected Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::SetSelected Method

Call this member to select the specified control.

BOOL SetSelected(
    int nSelected,
    BOOL bKeyboard = FALSE
);
Parameters

nSelected
An integer index of the item to be selected.
bKeyboard
TRUE if the item was selected using the keyboard.

Returns

TRUE if the method was successful; otherwise FALSE.

Group

CXTPPopupBar Methods


CXTPPopupBar::SetTearOffPopup Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::SetTearOffPopup Method

This method adds the tear-off state to the popup bar.

void SetTearOffPopup(
    LPCTSTR lpszCaption,
    UINT nID,
    int nWidth = 400
);
Parameters

lpszCaption
Caption of the tear-off toolbar.
nID
Identifier of the toolbar to be created.
nWidth
Width of the toolbar.

Group

CXTPPopupBar Methods


CXTPPopupBar::SetTrackingMode Method

CXTPPopupBar Methods, CXTPPopupBar Class, See Also
CXTPPopupBar::SetTrackingMode Method

Call this member to change the tracking state.

BOOL SetTrackingMode(
    int bMode,
    BOOL bSelectFirst = TRUE,
    BOOL bKeyboard = FALSE
);
Parameters

bMode
TRUE to set the tracking mode; otherwise FALSE.
bSelectFirst
TRUE to select the first item.
bKeyboard
TRUE if the item is popuped by the keyboard.

Returns

TRUE if the method was successful.

See Also

IsTrackingMode.

Group

CXTPPopupBar Methods


CXTPPopupBar::UpdateExpandingState Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::UpdateExpandingState Method

Update expanding state.

void UpdateExpandingState();
Group

CXTPPopupBar Methods


CXTPPopupBar::UpdateFlags Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::UpdateFlags Method

Update flags.

virtual void UpdateFlags();
Group

CXTPPopupBar Methods


CXTPPopupBar::UpdateLocation Method

CXTPPopupBar Methods, CXTPPopupBar Class
CXTPPopupBar::UpdateLocation Method

This method sets the PopupBar position.

void UpdateLocation(
    CSize sz
);
Parameters

sz
Size of the popup bar.

Group

CXTPPopupBar Methods


CXTPPopupBar Constructors

CXTPPopupBar Class, Legend, Protected Methods
CXTPPopupBar Constructors
Class

CXTPPopupBar Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPPopupBar | Constructs a CXTPPopupBar object


CXTPPopupBar::CXTPPopupBar Constructor

CXTPPopupBar Constructors, CXTPPopupBar Class
CXTPPopupBar::CXTPPopupBar Constructor

Constructs a CXTPPopupBar object

CXTPPopupBar();
Group

CXTPPopupBar Constructors


CXTPPopupBar Destructors

CXTPPopupBar Class, Legend, Protected Methods
CXTPPopupBar Destructors
Class

CXTPPopupBar Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPPopupBar | Destroys a CXTPPopupBar object, handles cleanup and deallocation


CXTPPopupBar::~CXTPPopupBar Destructor

CXTPPopupBar Destructors, CXTPPopupBar Class
CXTPPopupBar::~CXTPPopupBar Destructor

Destroys a CXTPPopupBar object, handles cleanup and deallocation

~CXTPPopupBar();
Group

CXTPPopupBar Destructors


CXTPPopupToolBar Class

XTPPopupBar.h, Classes, Legend, Members, Topics, CXTPPopupToolBar Methods, CXTPPopupToolBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupToolBar Class

CXTPPopupToolBar is a CXTPPopupBar derived class.

Class Hierarchy

class CXTPPopupToolBar : public CXTPPopupBar;
File

XTPPopupBar.h

Group

Classes

Legend
Method
protected
CXTPPopupToolBar Methods
CXTPPopupToolBar Methods | Description
CalcDynamicLayout | This method is called to get the size of the command bar.
CreatePopupToolBar | Creates a popup toolbar object.


CXTPPopupToolBar Methods

CXTPPopupToolBar Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupToolBar Methods
Class

CXTPPopupToolBar Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
CalcDynamicLayout | This method is called to get the size of the command bar.
Public Methods
Public Methods
Public Method | Description
CreatePopupToolBar | Creates a popup toolbar object.


CXTPPopupToolBar::CalcDynamicLayout Method

CXTPPopupToolBar Methods, CXTPPopupToolBar Class
CXTPPopupToolBar::CalcDynamicLayout Method

This method is called to get the size of the command bar.

CSize CalcDynamicLayout(
    int nLength,
    DWORD dwMode
);
Parameters

nLength
The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode
see CControlBar::CalcDynamicLayout for list of supported flags.

Returns

Size of the command bar.

Group

CXTPPopupToolBar Methods


CXTPPopupToolBar::CreatePopupToolBar Method

CXTPPopupToolBar Methods, CXTPPopupToolBar Class
CXTPPopupToolBar::CreatePopupToolBar Method

Creates a popup toolbar object.

static CXTPPopupToolBar* CreatePopupToolBar(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
Points to a CXTPCommandBars object

Returns

A pointer to a CXTPPopupToolBar object

Group

CXTPPopupToolBar Methods


CXTPReBar Class

XTPReBar.h, Classes, Legend, Members, Topics, CXTPReBar Methods, CXTPReBar Constructors, CXTPReBar Destructors, CXTPReBar Constructors, CXTPReBar Destructors, CXTPReBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReBar Class

The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring of band layouts.

Class Hierarchy

class CXTPReBar : public CXTPReBarBase;
File

XTPReBar.h

Group

Classes

Legend
Method
virtual
CXTPReBar Constructors
CXTPReBar Constructors | Description
CXTPReBar | Constructs a CXTPReBar object.
CXTPReBar Destructors
CXTPReBar Destructors | Description
~CXTPReBar | Destroys a CXTPReBar object, handles cleanup and deallocation.
CXTPReBar Methods
CXTPReBar Methods | Description
AddToolBar | Call this member to add a band to the rebar. The specified Toolbar will be inserted into the band.
DeleteToolBar | Call this member to remove a toolbar within the rebar. This will also remove the band that contained the toolbar.
FindBand | Call this member to locate the band that contains a toolbar.
GetToolBar | Call this member to retrieve a pointer to a toolbar that is contained in the band with the specified id.
LoadState | Call this function to retrieve state information from the registry.
SaveState | Call this function to save state information from the registry.
SetBandInfo | This member function implements the behavior of the Win32 message RB_SETBANDINFO, as described in the Platform SDK.


CXTPReBar Methods

CXTPReBar Class, Legend, Public Methods
CXTPReBar Methods
Class

CXTPReBar Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddToolBar | Call this member to add a band to the rebar. The specified Toolbar will be inserted into the band.
DeleteToolBar | Call this member to remove a toolbar within the rebar. This will also remove the band that contained the toolbar.
FindBand | Call this member to locate the band that contains a toolbar.
GetToolBar | Call this member to retrieve a pointer to a toolbar that is contained in the band with the specified id.
LoadState | Call this function to retrieve state information from the registry.
SaveState | Call this function to save state information from the registry.
SetBandInfo | This member function implements the behavior of the Win32 message RB_SETBANDINFO, as described in the Platform SDK.


CXTPReBar::AddToolBar Method

CXTPReBar Methods, CXTPReBar Class
CXTPReBar::AddToolBar Method

Call this member to add a band to the rebar. The specified Toolbar will be inserted into the band.

BOOL AddToolBar(
    CXTPToolBar* pToolBar,
    DWORD dwStyle = RBBS_GRIPPERALWAYS
);
Parameters

pToolBar
Pointer to the Toolbar object that will be added to rebar band.
dwStyle
Contains styles that can be applied to the rebar.

RBBS_BREAK - The band is on a new line.

RBBS_CHILDEDGE - The band has an edge at the top and bottom of the child window.

RBBS_FIXEDBMP - The background bitmap does not move when the band is resized.

RBBS_FIXEDSIZE - The band cannot be sized. With this style, the sizing grip is not displayed on the band.

RBBS_GRIPPERALWAYS - The band will always have sizing grip, even if it is the only band in the rebar.

RBBS_HIDDEN - The band will not be visible.

RBBS_NOVERT - The band is not displayed when the rebar control uses the CCS_VERT style.

Returns

TRUE is the bar was added successfully, FALSE if the bar wasn't added.

Remarks

The id of the band that contains the toolbar is assigned the same id as the toolbar.

Group

CXTPReBar Methods


CXTPReBar::DeleteToolBar Method

CXTPReBar Methods, CXTPReBar Class
CXTPReBar::DeleteToolBar Method

Call this member to remove a toolbar within the rebar. This will also remove the band that contained the toolbar.

void DeleteToolBar(
    CXTPToolBar* pToolBar
);
Parameters

pToolBar
Pointer to the toolbar that will be removed.

Group

CXTPReBar Methods


CXTPReBar::FindBand Method

CXTPReBar Methods, CXTPReBar Class
CXTPReBar::FindBand Method

Call this member to locate the band that contains a toolbar.

int FindBand(
    CXTPToolBar* pToolBar
);
Parameters

pToolBar
Pointer to the toolbar you want to find.

Returns

-1 if the toolbar was not found on a band in the rebar. If found the Id of the band that contains the toolbar is returned.

Group

CXTPReBar Methods


CXTPReBar::GetToolBar Method

CXTPReBar Methods, CXTPReBar Class
CXTPReBar::GetToolBar Method

Call this member to retrieve a pointer to a toolbar that is contained in the band with the specified id.

CXTPToolBar* GetToolBar(
    int nBand
);
Parameters

nBand
Id of a band in the rebar.

Returns

A pointer to the toolbar contained in the specified band.

Group

CXTPReBar Methods


CXTPReBar::LoadState Method

CXTPReBar Methods, CXTPReBar Class
CXTPReBar::LoadState Method

Call this function to retrieve state information from the registry.

void LoadState(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-teminated string that specifies the name of a key in the Windows registry where state information is stored.

Group

CXTPReBar Methods


CXTPReBar::SaveState Method

CXTPReBar Methods, CXTPReBar Class
CXTPReBar::SaveState Method

Call this function to save state information from the registry.

void SaveState(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-teminated string that specifies the name of a key in the Windows registry where the state information should be stored.

Group

CXTPReBar Methods


CXTPReBar::SetBandInfo Method

CXTPReBar Methods, CXTPReBar Class, Body Source, Example
CXTPReBar::SetBandInfo Method

This member function implements the behavior of the Win32 message RB_SETBANDINFO, as described in the Platform SDK.

BOOL SetBandInfo(
    UINT uBand,
    REBARBANDINFO* prbbi
);
Parameters

uBand
Zero-based index of the band to receive the new settings.
prbbi
Pointer to a REBARBANDINFO structure that defines the band to be inserted. You must set the 'cbSize' member of this structure to sizeof(REBARBANDINFO) before sending this message.

Returns

Nonzero if successful, otherwise returns zero.

Example
int nCount = m_wndReBar.GetReBarCtrl().GetBandCount();
CString strText = "Band #:";

int i;
for (i = 0; i<nCount; i++)
{
    LPREBARBANDINFO prbbi = (LPREBARBANDINFO)alloca(sizeof(REBARBANDINFO));
    prbbi->cbSize = sizeof(REBARBANDINFO);

    CString strText;
    strText.Format("Band #: %d", i);

    LPTSTR lpszText = strText.GetBuffer(strText.GetLength());
    prbbi->lpText = lpszText;
    prbbi->cch = strlen(lpszText) + 1;
    prbbi->fMask = RBBIM_TEXT;

    m_wndReBar.SetBandInfo(i, prbbi);

    strText.ReleaseBuffer();
}
Body Source
BOOL CXTPReBar::SetBandInfo(UINT uBand, REBARBANDINFO* prbbi) {
    return (BOOL)DefWindowProc(RB_SETBANDINFO, uBand, (LPARAM)prbbi);
}
Group

CXTPReBar Methods


CXTPReBar Constructors

CXTPReBar Class, Legend, Public Methods
CXTPReBar Constructors
Class

CXTPReBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReBar | Constructs a CXTPReBar object.


CXTPReBar::CXTPReBar Constructor

CXTPReBar Constructors, CXTPReBar Class
CXTPReBar::CXTPReBar Constructor

Constructs a CXTPReBar object.

CXTPReBar();
Group

CXTPReBar Constructors


CXTPReBar Destructors

CXTPReBar Class, Legend, Public Methods
CXTPReBar Destructors
Class

CXTPReBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReBar | Destroys a CXTPReBar object, handles cleanup and deallocation.


CXTPReBar::~CXTPReBar Destructor

CXTPReBar Destructors, CXTPReBar Class
CXTPReBar::~CXTPReBar Destructor

Destroys a CXTPReBar object, handles cleanup and deallocation.

virtual ~CXTPReBar();
Group

CXTPReBar Destructors


CXTPReBarPaintManager Template

XTPPaintManager.h, Classes, Legend, Members, Topics, CXTPReBarPaintManager Data Members, CXTPReBarPaintManager Methods, CXTPReBarPaintManager Constructors, CXTPReBarPaintManager Constructors, CXTPReBarPaintManager Data Members, CXTPReBarPaintManager Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReBarPaintManager Template

The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars

Class Hierarchy

template <class TBase>
class CXTPReBarPaintManager : public TBase;
File

XTPPaintManager.h

See Also

CXTPPaintManager::SetTheme

Group

Classes

Legend
Data Member
protected
Method
CXTPReBarPaintManager Constructors
CXTPReBarPaintManager Constructors | Description
CXTPReBarPaintManager | Constructs a CXTPReBarPaintManager object.
CXTPReBarPaintManager Data Members
CXTPReBarPaintManager Data Members | Description
m_themeRebar | ReBar theme helper.
CXTPReBarPaintManager Methods
CXTPReBarPaintManager Methods | Description
FillCommandBarEntry | This method is called to fill the command bar's face.
RefreshMetrics | This method is called to refresh the visual metrics of the manager.


CXTPReBarPaintManager Data Members

CXTPReBarPaintManager Template, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReBarPaintManager Data Members
Template

CXTPReBarPaintManager Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_themeRebar | ReBar theme helper.


CXTPReBarPaintManager::m_themeRebar Data Member

CXTPReBarPaintManager Data Members, CXTPReBarPaintManager Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReBarPaintManager::m_themeRebar Data Member

ReBar theme helper.

CXTPWinThemeWrapper m_themeRebar;
Group

CXTPReBarPaintManager Data Members


CXTPReBarPaintManager Methods

CXTPReBarPaintManager Template, Legend, Public Methods
CXTPReBarPaintManager Methods
Template

CXTPReBarPaintManager Template

Legend
Method
Public Methods
Public Methods
Public Method | Description
FillCommandBarEntry | This method is called to fill the command bar's face.
RefreshMetrics | This method is called to refresh the visual metrics of the manager.


CXTPReBarPaintManager::FillCommandBarEntry Method

CXTPReBarPaintManager Methods, CXTPReBarPaintManager Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReBarPaintManager::FillCommandBarEntry Method

This method is called to fill the command bar's face.

void FillCommandBarEntry(
    CDC* pDC,
    CXTPCommandBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object to draw.

Body Source
void FillCommandBarEntry (CDC* pDC, CXTPCommandBar* pBar)
{
    if (pBar->GetPosition() != xtpBarFloating && pBar->GetPosition() != xtpBarPopup)
    {
        if (m_themeRebar.IsAppThemed())
        {
            CXTPWindowRect rcClient(pBar->GetParent());
            pBar->ScreenToClient(&rcClient);

            m_themeRebar.DrawThemeBackground(pDC->GetSafeHdc(), 0, 0, &rcClient, 0);
        }
        else
            pDC->FillSolidRect(CXTPClientRect(pBar), GetSysColor(COLOR_3DFACE));
    }
    else
    {
        TBase::FillCommandBarEntry(pDC, pBar);
    }
}
Group

CXTPReBarPaintManager Methods


CXTPReBarPaintManager::RefreshMetrics Method

CXTPReBarPaintManager Methods, CXTPReBarPaintManager Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReBarPaintManager::RefreshMetrics Method

This method is called to refresh the visual metrics of the manager.

void RefreshMetrics();
Body Source
void RefreshMetrics()
{
    TBase::RefreshMetrics();

    m_themeRebar.OpenThemeData(0, L"REBAR");
}
Group

CXTPReBarPaintManager Methods


CXTPReBarPaintManager Constructors

CXTPReBarPaintManager Template, Legend, Public Methods
CXTPReBarPaintManager Constructors
Template

CXTPReBarPaintManager Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReBarPaintManager | Constructs a CXTPReBarPaintManager object.


CXTPReBarPaintManager::CXTPReBarPaintManager Constructor

CXTPReBarPaintManager Constructors, CXTPReBarPaintManager Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReBarPaintManager::CXTPReBarPaintManager Constructor

Constructs a CXTPReBarPaintManager object.

CXTPReBarPaintManager();
Body Source
CXTPReBarPaintManager()
{
    RefreshMetrics();
}
Group

CXTPReBarPaintManager Constructors


CXTPRibbonBar Class

XTPRibbonBar.h, Classes, Legend, Members, Topics, CXTPRibbonBar Data Members, CXTPRibbonBar Methods, CXTPRibbonBar Constructors, CXTPRibbonBar Destructors, CXTPRibbonBar Constructors, CXTPRibbonBar Data Members, CXTPRibbonBar Destructors, Example, CXTPRibbonBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar Class

CXTPRibbonBar is a CXTPMenuBar derived class, It represents Ribbon control from Office 2007.

Class Hierarchy

class CXTPRibbonBar : public CXTPMenuBar, public CXTPRibbonScrollableBar;
File

XTPRibbonBar.h

Example

The following code sample demonstrates how to create CXTPRibbonBar:

CXTPRibbonBar* pRibbonBar = (CXTPRibbonBar*)pCommandBars->Add(_T("The Ribbon"), xtpBarTop, RUNTIME_CLASS(CXTPRibbonBar));
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPRibbonBar Constructors
CXTPRibbonBar Constructors | Description
CXTPRibbonBar | Constructs a CXTPRibbonBar object
CXTPRibbonBar Data Members
CXTPRibbonBar Data Members | Description
m_bAllowMinimize | TRUE to allow minimize ribbon
m_bAllowQuickAccessCustomization | TRUE to allow quick access customization
m_bAllowQuickAccessDuplicates | TRUE to allow quick access duplicates
m_bGroupReducedChanged | Some group appear in resize handler
m_bGroupsVisible | TRUE if groups is visible
m_bMinimized | TRUE if Ribbon currently minimized
m_bRibbonBarVisible | TRUE if ribbon bar visible
m_bShowCaptionAlways | TRUE to show caption even if EnableFrameTheme was not called.
m_bShowQuickAccess | TRUE to show quick access
m_bShowQuickAccessBelow | TRUE to show quick access controls below ribbon bar
m_bTabsVisible | TRUE if tabs are visible
m_nGroupsHeight | Custom groups height
m_nMinVisibleWidth | Minimum width before ribbon bar disappears
m_nQuickAccessHeight | Quick Access height
m_pContextHeaders | Context header collection
m_pControlQuickAccess | Quick Access menu control
m_pControlQuickAccessMore | Quick Access more control
m_pControlSystemButton | System button control
m_pControlTab | Control tab pointer
m_pFrameHook | Office 2007 Frame hook
m_pQuickAccessControls | Quick AccessControls (not used now)
m_rcCaption | Caption bounding rectangle
m_rcCaptionText | Caption text bounding rectangle
m_rcGroups | Groups bounding rectangle
m_rcHeader | Header bounding rectangle
m_rcQuickAccess | Quick access bounding rectangle
m_rcTabControl | Bounding rectangle of Tabs
m_strCaptionText | Caption text
CXTPRibbonBar Destructors
CXTPRibbonBar Destructors | Description
~CXTPRibbonBar | Destroys a CXTPRibbonBar object, handles cleanup and deallocation
CXTPRibbonBar Methods
CXTPRibbonBar Methods | Description
AddSystemButton | Call this method to add ribbon top-left system button.
AddTab |
AllowMinimize | Call this method to disable minimize feature of Ribbon Bar
AllowQuickAccessCustomization | Call this method to allow customization for quick access
AllowQuickAccessDuplicates | Call this method to allow same controls for quick access
CalcGroupsHeight | This method calculates groups height using GetLargeIconSize method and height of captions
CalcQuickAccessHeight | Calculates Quick Access area height
DrawCommandBar | This method is called to draw the command bar in the given context.
EnableFrameTheme | Call this method to enable Office 2007 frame.
EnsureVisible | Call this method to be sure control is visible on ribbon bar
FindGroup | Cal this method to find group by its identifier
FindTab | Cal this method to find tab by its identifier
GetButtonSize | Call this function to get the size of the command bar button.
GetCaptionHeight | Call this member to get caption height of ribbon bar
GetCaptionRect | Gets the bounding rectangle for the ribbon caption.
GetCaptionTextRect | Gets the bounding rectangle for the ribbon caption text.
GetContextHeaders | This method retrieves Context Headers collection;
GetControlQuickAccess | Call this method to get pointer to quick access button
GetControlTab | Call this method to get CXTPRibbonControlTab that represents ribbon tabs
GetCurSel | Call this method to get select tab index.
GetFontHeight | Determines font height used for Ribbon Bar
GetFrameHook | Returns CXTPOffice2007FrameHook hook window used to skin frame.
GetGroupsHeight | This method retrieves group area height;
GetGroupsRect | Retrieves Groups bounding rectangle
GetHighlightedGroup | Call this method to get highlighted group
GetIconSize | Call this member function to get the size of a toolbar icon.
GetMinimumVisibleWidth | Call this method to get minimum width before ribbon bar disappear
GetQuickAccessControls | Retrieves collection of Quick Access controls.
GetQuickAccessHeight | This method retrieves Quick Access area height
GetQuickAccessRect | Gets the bounding rectangle for the ribbon Quick Access controls.
GetRibbonPaintManager | Retrieves ribbon paint manager.
GetSelectedTab | Cal this method to get current selected tab
GetSystemButton | Call this method to get ribbon top-left system button.
GetTab | Cal this method to get tab in specified position
GetTabControlRect | Gets the bounding rectangle for the ribbon tabs.
GetTabCount | Retrieves the number of tabs in the ribbon bar.
GetTabPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
GetTabsHeight | This method retrieves tabs area height
HitTestGroup | This member function determines which ribbon group, if any, is at a specified position.
InsertTab |
IsAllowQuickAccessControl | Determines if control can be added to quick access controls.
IsAllowQuickAccessDuplicates | Determines if user can add 2 or more same controls to quick access
IsCaptionVisible | Determines if caption part of ribbon is visible
IsDwmEnabled | Determines if Vista Glass Effect enabled for Ribbon Bar.
IsFrameThemeEnabled | Determines if Office 2007 frame enabled
IsGroupsVisible | Determines if groups part of ribbon bar is visible
IsQuickAccessBelowRibbon | Determine if Quick Access controls located below ribbon bar
IsQuickAccessControl | Determines if control belongs to quick access controls.
IsQuickAccessVisible | Determines if quick access is visible
IsRibbonBar | Call this member function to determine if the CommandBar is a CXTPRibbonBar.
IsRibbonBarVisible | Determines if ribbon bar is visible
IsRibbonMinimized | Determines if ribbon bar is minimized
IsTabsVisible | Determines if tabs part of ribbon bar is visible
OnTabChanged | This virtual method called when current tab is changed.
OnTabChanging | This virtual method called when tab is about to be changed.
RebuildControls | When switching tabs, RebuildControls first deletes all the controls from the old tab groups. Then controls are added to the tab groups of the tab to be selected. Finally, the new tab is selected.
RemoveAllTabs | Call this member to remove all tab
RemoveTab | Call this member to remove single tab
SelectNextTab | Call this method to select next or previous tab
SetCurSel | Call this method to select tab.
SetFontHeight | Call this method to set custom font height for ribbon bar
SetGroupsHeight | Call this method to set height of the ribbon groups
SetGroupsVisible | Call this method to hide/show groups part of ribbon bar
SetMinimumVisibleWidth | Call this method to set minimum width before ribbon bar disappear
SetRibbonMinimized | Call this method to minimize Ribbon Bar
SetTabsVisible | Call this method to hide/show tabs part of ribbon bar
SetVisible | Call this member function to show or hide the ribbon.
ShowCaptionAlways | This method allow show/hide caption if frame theme is not enabled.
ShowQuickAccess | Call this method to show/hide quick access
ShowQuickAccessBelowRibbon | Call this method to show Quick Access controls below ribbon bar


CXTPRibbonBar Data Members

CXTPRibbonBar Class, Legend, Protected Data Members
CXTPRibbonBar Data Members
Class

CXTPRibbonBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAllowMinimize | TRUE to allow minimize ribbon
m_bAllowQuickAccessCustomization | TRUE to allow quick access customization
m_bAllowQuickAccessDuplicates | TRUE to allow quick access duplicates
m_bGroupReducedChanged | Some group appear in resize handler
m_bGroupsVisible | TRUE if groups is visible
m_bMinimized | TRUE if Ribbon currently minimized
m_bRibbonBarVisible | TRUE if ribbon bar visible
m_bShowCaptionAlways | TRUE to show caption even if EnableFrameTheme was not called.
m_bShowQuickAccess | TRUE to show quick access
m_bShowQuickAccessBelow | TRUE to show quick access controls below ribbon bar
m_bTabsVisible | TRUE if tabs are visible
m_nGroupsHeight | Custom groups height
m_nMinVisibleWidth | Minimum width before ribbon bar disappears
m_nQuickAccessHeight | Quick Access height
m_pContextHeaders | Context header collection
m_pControlQuickAccess | Quick Access menu control
m_pControlQuickAccessMore | Quick Access more control
m_pControlSystemButton | System button control
m_pControlTab | Control tab pointer
m_pFrameHook | Office 2007 Frame hook
m_pQuickAccessControls | Quick AccessControls (not used now)
m_rcCaption | Caption bounding rectangle
m_rcCaptionText | Caption text bounding rectangle
m_rcGroups | Groups bounding rectangle
m_rcHeader | Header bounding rectangle
m_rcQuickAccess | Quick access bounding rectangle
m_rcTabControl | Bounding rectangle of Tabs
m_strCaptionText | Caption text


CXTPRibbonBar::m_bAllowMinimize Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bAllowMinimize Data Member

TRUE to allow minimize ribbon

BOOL m_bAllowMinimize;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bAllowQuickAccessCustomization Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bAllowQuickAccessCustomization Data Member

TRUE to allow quick access customization

BOOL m_bAllowQuickAccessCustomization;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bAllowQuickAccessDuplicates Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bAllowQuickAccessDuplicates Data Member

TRUE to allow quick access duplicates

BOOL m_bAllowQuickAccessDuplicates;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bGroupReducedChanged Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bGroupReducedChanged Data Member

Some group appear in resize handler

BOOL m_bGroupReducedChanged;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bGroupsVisible Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bGroupsVisible Data Member

TRUE if groups is visible

BOOL m_bGroupsVisible;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bMinimized Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bMinimized Data Member

TRUE if Ribbon currently minimized

BOOL m_bMinimized;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bRibbonBarVisible Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bRibbonBarVisible Data Member

TRUE if ribbon bar visible

BOOL m_bRibbonBarVisible;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bShowCaptionAlways Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bShowCaptionAlways Data Member

TRUE to show caption even if EnableFrameTheme was not called.

BOOL m_bShowCaptionAlways;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bShowQuickAccess Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bShowQuickAccess Data Member

TRUE to show quick access

BOOL m_bShowQuickAccess;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bShowQuickAccessBelow Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bShowQuickAccessBelow Data Member

TRUE to show quick access controls below ribbon bar

BOOL m_bShowQuickAccessBelow;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_bTabsVisible Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_bTabsVisible Data Member

TRUE if tabs are visible

BOOL m_bTabsVisible;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_nGroupsHeight Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_nGroupsHeight Data Member

Custom groups height

int m_nGroupsHeight;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_nMinVisibleWidth Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_nMinVisibleWidth Data Member

Minimum width before ribbon bar disappears

int m_nMinVisibleWidth;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_nQuickAccessHeight Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_nQuickAccessHeight Data Member

Quick Access height

int m_nQuickAccessHeight;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_pContextHeaders Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_pContextHeaders Data Member

Context header collection

CXTPRibbonTabContextHeaders* m_pContextHeaders;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_pControlQuickAccess Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_pControlQuickAccess Data Member

Quick Access menu control

CXTPControl* m_pControlQuickAccess;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_pControlQuickAccessMore Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_pControlQuickAccessMore Data Member

Quick Access more control

CXTPControl* m_pControlQuickAccessMore;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_pControlSystemButton Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_pControlSystemButton Data Member

System button control

CXTPControlPopup* m_pControlSystemButton;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_pControlTab Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_pControlTab Data Member

Control tab pointer

CXTPRibbonControlTab* m_pControlTab;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_pFrameHook Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_pFrameHook Data Member

Office 2007 Frame hook

CXTPOffice2007FrameHook* m_pFrameHook;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_pQuickAccessControls Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_pQuickAccessControls Data Member

Quick AccessControls (not used now)

CXTPRibbonQuickAccessControls* m_pQuickAccessControls;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_rcCaption Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_rcCaption Data Member

Caption bounding rectangle

CRect m_rcCaption;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_rcCaptionText Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_rcCaptionText Data Member

Caption text bounding rectangle

CRect m_rcCaptionText;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_rcGroups Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_rcGroups Data Member

Groups bounding rectangle

CRect m_rcGroups;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_rcHeader Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_rcHeader Data Member

Header bounding rectangle

CRect m_rcHeader;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_rcQuickAccess Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_rcQuickAccess Data Member

Quick access bounding rectangle

CRect m_rcQuickAccess;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_rcTabControl Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_rcTabControl Data Member

Bounding rectangle of Tabs

CRect m_rcTabControl;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar::m_strCaptionText Data Member

CXTPRibbonBar Data Members, CXTPRibbonBar Class
CXTPRibbonBar::m_strCaptionText Data Member

Caption text

CString m_strCaptionText;
Group

CXTPRibbonBar Data Members


CXTPRibbonBar Methods

CXTPRibbonBar Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar Methods
Class

CXTPRibbonBar Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnTabChanged | This virtual method called when current tab is changed.
OnTabChanging | This virtual method called when tab is about to be changed.
Public Methods
Public Methods
Public Method | Description
AddSystemButton | Call this method to add ribbon top-left system button.
AddTab |
AllowMinimize | Call this method to disable minimize feature of Ribbon Bar
AllowQuickAccessCustomization | Call this method to allow customization for quick access
AllowQuickAccessDuplicates | Call this method to allow same controls for quick access
CalcGroupsHeight | This method calculates groups height using GetLargeIconSize method and height of captions
CalcQuickAccessHeight | Calculates Quick Access area height
DrawCommandBar | This method is called to draw the command bar in the given context.
EnableFrameTheme | Call this method to enable Office 2007 frame.
EnsureVisible | Call this method to be sure control is visible on ribbon bar
FindGroup | Cal this method to find group by its identifier
FindTab | Cal this method to find tab by its identifier
GetButtonSize | Call this function to get the size of the command bar button.
GetCaptionHeight | Call this member to get caption height of ribbon bar
GetCaptionRect | Gets the bounding rectangle for the ribbon caption.
GetCaptionTextRect | Gets the bounding rectangle for the ribbon caption text.
GetContextHeaders | This method retrieves Context Headers collection;
GetControlQuickAccess | Call this method to get pointer to quick access button
GetControlTab | Call this method to get CXTPRibbonControlTab that represents ribbon tabs
GetCurSel | Call this method to get select tab index.
GetFontHeight | Determines font height used for Ribbon Bar
GetFrameHook | Returns CXTPOffice2007FrameHook hook window used to skin frame.
GetGroupsHeight | This method retrieves group area height;
GetGroupsRect | Retrieves Groups bounding rectangle
GetHighlightedGroup | Call this method to get highlighted group
GetIconSize | Call this member function to get the size of a toolbar icon.
GetMinimumVisibleWidth | Call this method to get minimum width before ribbon bar disappear
GetQuickAccessControls | Retrieves collection of Quick Access controls.
GetQuickAccessHeight | This method retrieves Quick Access area height
GetQuickAccessRect | Gets the bounding rectangle for the ribbon Quick Access controls.
GetRibbonPaintManager | Retrieves ribbon paint manager.
GetSelectedTab | Cal this method to get current selected tab
GetSystemButton | Call this method to get ribbon top-left system button.
GetTab | Cal this method to get tab in specified position
GetTabControlRect | Gets the bounding rectangle for the ribbon tabs.
GetTabCount | Retrieves the number of tabs in the ribbon bar.
GetTabPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
GetTabsHeight | This method retrieves tabs area height
HitTestGroup | This member function determines which ribbon group, if any, is at a specified position.
InsertTab |
IsAllowQuickAccessControl | Determines if control can be added to quick access controls.
IsAllowQuickAccessDuplicates | Determines if user can add 2 or more same controls to quick access
IsCaptionVisible | Determines if caption part of ribbon is visible
IsDwmEnabled | Determines if Vista Glass Effect enabled for Ribbon Bar.
IsFrameThemeEnabled | Determines if Office 2007 frame enabled
IsGroupsVisible | Determines if groups part of ribbon bar is visible
IsQuickAccessBelowRibbon | Determine if Quick Access controls located below ribbon bar
IsQuickAccessControl | Determines if control belongs to quick access controls.
IsQuickAccessVisible | Determines if quick access is visible
IsRibbonBar | Call this member function to determine if the CommandBar is a CXTPRibbonBar.
IsRibbonBarVisible | Determines if ribbon bar is visible
IsRibbonMinimized | Determines if ribbon bar is minimized
IsTabsVisible | Determines if tabs part of ribbon bar is visible
RebuildControls | When switching tabs, RebuildControls first deletes all the controls from the old tab groups. Then controls are added to the tab groups of the tab to be selected. Finally, the new tab is selected.
RemoveAllTabs | Call this member to remove all tab
RemoveTab | Call this member to remove single tab
SelectNextTab | Call this method to select next or previous tab
SetCurSel | Call this method to select tab.
SetFontHeight | Call this method to set custom font height for ribbon bar
SetGroupsHeight | Call this method to set height of the ribbon groups
SetGroupsVisible | Call this method to hide/show groups part of ribbon bar
SetMinimumVisibleWidth | Call this method to set minimum width before ribbon bar disappear
SetRibbonMinimized | Call this method to minimize Ribbon Bar
SetTabsVisible | Call this method to hide/show tabs part of ribbon bar
SetVisible | Call this member function to show or hide the ribbon.
ShowCaptionAlways | This method allow show/hide caption if frame theme is not enabled.
ShowQuickAccess | Call this method to show/hide quick access
ShowQuickAccessBelowRibbon | Call this method to show Quick Access controls below ribbon bar


CXTPRibbonBar::AddSystemButton Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::AddSystemButton Method

Call this method to add ribbon top-left system button.

CXTPControlPopup* AddSystemButton(
    int nID = 0
);
Parameters

nID
Identifier of system button

See Also

GetSystemButton

Group

CXTPRibbonBar Methods


AddTab Method

CXTPRibbonBar Methods
AddTab Method
Overload List
Methods
Method | Description
CXTPRibbonBar::AddTab (LPCTSTR) | Cal this method to add new tab for ribbon bar
CXTPRibbonBar::AddTab (int) | Cal this method to add new tab for ribbon bar
Group

CXTPRibbonBar Methods


CXTPRibbonBar::AddTab Method (LPCTSTR)

AddTab Method, CXTPRibbonBar Class, See Also
CXTPRibbonBar::AddTab Method (LPCTSTR)

Cal this method to add new tab for ribbon bar

CXTPRibbonTab* AddTab(
    LPCTSTR lpszCaption
);
CXTPRibbonTab* AddTab(
    int nID
);
Parameters

lpszCaption
Caption of tab to be added
nID
Identifier of tab to be added

Returns

Pointer to new CXTPRibbonTab object

See Also

InsertTab

Group

AddTab Method


CXTPRibbonBar::AllowMinimize Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source
CXTPRibbonBar::AllowMinimize Method

Call this method to disable minimize feature of Ribbon Bar

void AllowMinimize(
    BOOL bAllow
);
Parameters

bAllow
TRUE to allow minimize ribbon bar; FALSE to forbid

Body Source
void CXTPRibbonBar::AllowMinimize(BOOL bAllow) {
    m_bAllowMinimize = bAllow;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::AllowQuickAccessCustomization Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::AllowQuickAccessCustomization Method

Call this method to allow customization for quick access

void AllowQuickAccessCustomization(
    BOOL bAllow
);
Parameters

bAllow
TRUE to allow customization for quick access

See Also

IsAllowQuickAccessDuplicates, ShowQuickAccessBelowRibbon

Body Source
void CXTPRibbonBar::AllowQuickAccessCustomization(BOOL bAllow) {
    m_bAllowQuickAccessCustomization = bAllow;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::AllowQuickAccessDuplicates Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::AllowQuickAccessDuplicates Method

Call this method to allow same controls for quick access

void AllowQuickAccessDuplicates(
    BOOL bAllow
);
Parameters

bAllow
TRUE to allow add same controls for quick access

See Also

IsAllowQuickAccessDuplicates, ShowQuickAccessBelowRibbon

Body Source
void CXTPRibbonBar::AllowQuickAccessDuplicates(BOOL bAllow) {
    m_bAllowQuickAccessDuplicates = bAllow;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::CalcGroupsHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::CalcGroupsHeight Method

This method calculates groups height using GetLargeIconSize method and height of captions

virtual int CalcGroupsHeight();
Returns

Height of ribbon groups

See Also

GetGroupsHeight

Group

CXTPRibbonBar Methods


CXTPRibbonBar::CalcQuickAccessHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::CalcQuickAccessHeight Method

Calculates Quick Access area height

int CalcQuickAccessHeight();
Group

CXTPRibbonBar Methods


CXTPRibbonBar::DrawCommandBar Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::DrawCommandBar Method

This method is called to draw the command bar in the given context.

virtual void DrawCommandBar(
    CDC* pDC,
    CRect rcClipBox
);
Parameters

pDC
Pointer to a valid device context
rcClipBox
The rectangular area of the control that is invalid

Group

CXTPRibbonBar Methods


CXTPRibbonBar::EnableFrameTheme Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::EnableFrameTheme Method

Call this method to enable Office 2007 frame.

void EnableFrameTheme(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable Office 2007 frame; FLASE - to disable

See Also

IsFrameThemeEnabled

Group

CXTPRibbonBar Methods


CXTPRibbonBar::EnsureVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::EnsureVisible Method

Call this method to be sure control is visible on ribbon bar

virtual void EnsureVisible(
    CXTPControl* pControl
);
Parameters

pControl
CXTPControl child that need to check

Group

CXTPRibbonBar Methods


CXTPRibbonBar::FindGroup Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::FindGroup Method

Cal this method to find group by its identifier

CXTPRibbonGroup* FindGroup(
    int nId
) const;
Parameters

nId
Identifier of group to be found

Returns

Pointer to CXTPRibbonGroup object with specified identifier

See Also

FindTab

Group

CXTPRibbonBar Methods


CXTPRibbonBar::FindTab Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::FindTab Method

Cal this method to find tab by its identifier

CXTPRibbonTab* FindTab(
    int nId
) const;
Parameters

nId
Identifier of tab to be found

Returns

Pointer to CXTPRibbonTab object with specified identifier

See Also

FindGroup

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetButtonSize Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::GetButtonSize Method

Call this function to get the size of the command bar button.

CSize GetButtonSize() const;
Returns

The width and height values of the command bar button.

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetCaptionHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetCaptionHeight Method

Call this member to get caption height of ribbon bar

int GetCaptionHeight() const;
Returns

Caption height in pixels

See Also

CalcGroupsHeight

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetCaptionRect Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetCaptionRect Method

Gets the bounding rectangle for the ribbon caption.

CRect GetCaptionRect() const;
Returns

Bounding rectangle for the ribbon caption.

See Also

GetCaptionTextRect, GetQuickAccessRect, GetTabControlRect

Body Source
CRect CXTPRibbonBar::GetCaptionRect() const {
    return m_rcCaption;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetCaptionTextRect Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetCaptionTextRect Method

Gets the bounding rectangle for the ribbon caption text.

CRect GetCaptionTextRect() const;
Returns

Bounding rectangle for the ribbon caption text.

See Also

GetCaptionRect, GetQuickAccessRect, GetTabControlRect

Body Source
CRect CXTPRibbonBar::GetCaptionTextRect() const {
    return m_rcCaptionText;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetContextHeaders Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetContextHeaders Method

This method retrieves Context Headers collection;

CXTPRibbonTabContextHeaders* GetContextHeaders() const;
Returns

Pointer to CXTPRibbonTabContextHeaders class contained CXTPRibbonTabContextHeader collection

See Also

CXTPRibbonTabContextHeader

Body Source
CXTPRibbonTabContextHeaders* CXTPRibbonBar::GetContextHeaders() const {
    return m_pContextHeaders;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetControlQuickAccess Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source
CXTPRibbonBar::GetControlQuickAccess Method

Call this method to get pointer to quick access button

CXTPControl* GetControlQuickAccess() const;
Returns

Pointer to quick access button

Body Source
CXTPControl* CXTPRibbonBar::GetControlQuickAccess() const {
    return m_pControlQuickAccess;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetControlTab Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source
CXTPRibbonBar::GetControlTab Method

Call this method to get CXTPRibbonControlTab that represents ribbon tabs

CXTPRibbonControlTab* GetControlTab() const;
Body Source
CXTPRibbonControlTab* CXTPRibbonBar::GetControlTab() const {
    return m_pControlTab;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetCurSel Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetCurSel Method

Call this method to get select tab index.

int GetCurSel() const;
See Also

SetCurSel

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetFontHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::GetFontHeight Method

Determines font height used for Ribbon Bar

int GetFontHeight() const;
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetFrameHook Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetFrameHook Method

Returns CXTPOffice2007FrameHook hook window used to skin frame.

CXTPOffice2007FrameHook* GetFrameHook() const;
See Also

EnableFrameTheme

Body Source
CXTPOffice2007FrameHook* CXTPRibbonBar::GetFrameHook() const {
    return m_pFrameHook;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetGroupsHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetGroupsHeight Method

This method retrieves group area height;

virtual int GetGroupsHeight();
See Also

GetTabsHeight

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetGroupsRect Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source
CXTPRibbonBar::GetGroupsRect Method

Retrieves Groups bounding rectangle

CRect GetGroupsRect() const;
Body Source
CRect CXTPRibbonBar::GetGroupsRect() const {
    return m_rcGroups;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetHighlightedGroup Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetHighlightedGroup Method

Call this method to get highlighted group

CXTPRibbonGroup* GetHighlightedGroup() const;
Returns

CXTPRibbonGroup object under mouse cursor

See Also

CXTPRibbonGroup

Body Source
CXTPRibbonGroup* CXTPRibbonBar::GetHighlightedGroup() const {
    return m_pHighlightedGroup;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetIconSize Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetIconSize Method

Call this member function to get the size of a toolbar icon.

virtual CSize GetIconSize() const;
See Also

GetLargeIconSize

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetMinimumVisibleWidth Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetMinimumVisibleWidth Method

Call this method to get minimum width before ribbon bar disappear

int GetMinimumVisibleWidth() const;
Returns

Minimum width before ribbon bar disappear.

See Also

SetMinimumVisibleWidth

Body Source
int CXTPRibbonBar::GetMinimumVisibleWidth() const {
    return m_nMinVisibleWidth;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetQuickAccessControls Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source
CXTPRibbonBar::GetQuickAccessControls Method

Retrieves collection of Quick Access controls.

CXTPRibbonQuickAccessControls* GetQuickAccessControls() const;
Returns

Pointer to CXTPRibbonQuickAccessControls contained Quick Access controls.

Body Source
CXTPRibbonQuickAccessControls* CXTPRibbonBar::GetQuickAccessControls() const {
    return m_pQuickAccessControls;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetQuickAccessHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetQuickAccessHeight Method

This method retrieves Quick Access area height

int GetQuickAccessHeight() const;
See Also

GetGroupsHeight, GetTabsHeight

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetQuickAccessRect Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetQuickAccessRect Method

Gets the bounding rectangle for the ribbon Quick Access controls.

CRect GetQuickAccessRect() const;
Returns

Bounding rectangle for the ribbon Quick Access controls.

See Also

GetCaptionRect, GetCaptionTextRect, GetTabControlRect

Body Source
CRect CXTPRibbonBar::GetQuickAccessRect() const {
    return m_rcQuickAccess;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetRibbonPaintManager Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetRibbonPaintManager Method

Retrieves ribbon paint manager.

CXTPRibbonTheme* GetRibbonPaintManager() const;
Returns

Pointer to CXTPRibbonTheme object

See Also

AddTab

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetSelectedTab Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetSelectedTab Method

Cal this method to get current selected tab

CXTPRibbonTab* GetSelectedTab() const;
Returns

Pointer to current selected CXTPRibbonTab object

See Also

SetCurSel

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetSystemButton Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetSystemButton Method

Call this method to get ribbon top-left system button.

CXTPControlPopup* GetSystemButton() const;
See Also

AddSystemButton

Body Source
CXTPControlPopup* CXTPRibbonBar::GetSystemButton() const {
    return m_pControlSystemButton;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetTab Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetTab Method

Cal this method to get tab in specified position

CXTPRibbonTab* GetTab(
    int nIndex
) const;
Parameters

nIndex
Index of tab to retrieve

Returns

Pointer to CXTPRibbonTab object in specified position

See Also

GetTabCount

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetTabControlRect Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::GetTabControlRect Method

Gets the bounding rectangle for the ribbon tabs.

CRect GetTabControlRect() const;
Returns

Bounding rectangle for the ribbon tabs.

See Also

CXTPRibbonThemeOffice2007Theme::FillRibbonBar

Body Source
CRect CXTPRibbonBar::GetTabControlRect() const {
    return m_rcTabControl;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetTabCount Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetTabCount Method

Retrieves the number of tabs in the ribbon bar.

int GetTabCount() const;
Returns

Number of tabs in the ribbon bar.

See Also

GetTab

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetTabPaintManager Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::GetTabPaintManager Method

Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.

CXTPTabPaintManager* GetTabPaintManager() const;
Returns

Pointer to CXTPTabPaintManager that contains the visual elements of the tabs.

Group

CXTPRibbonBar Methods


CXTPRibbonBar::GetTabsHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::GetTabsHeight Method

This method retrieves tabs area height

virtual int GetTabsHeight() const;
See Also

GetGroupsHeight

Group

CXTPRibbonBar Methods


CXTPRibbonBar::HitTestGroup Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::HitTestGroup Method

This member function determines which ribbon group, if any, is at a specified position.

CXTPRibbonGroup* HitTestGroup(
    CPoint point
) const;
Parameters

point
A CPoint that contains the coordinates of the point to test.

Returns

The CXTPRibbonGroup that is at the specified point, if no group is at the point, then NULL is returned.

Group

CXTPRibbonBar Methods


InsertTab Method

CXTPRibbonBar Methods
InsertTab Method
Overload List
Methods
Method | Description
CXTPRibbonBar::InsertTab (int, LPCTSTR, int) | Cal this method to insert new tab for ribbon bar to specified position
CXTPRibbonBar::InsertTab (int, int) | Cal this method to insert new tab for ribbon bar to specified position
Group

CXTPRibbonBar Methods


CXTPRibbonBar::InsertTab Method (int, int)

InsertTab Method, CXTPRibbonBar Class, See Also
CXTPRibbonBar::InsertTab Method (int, int)

Cal this method to insert new tab for ribbon bar to specified position

CXTPRibbonTab* InsertTab(
    int nItem,
    int nID
);
CXTPRibbonTab* InsertTab(
    int nItem,
    LPCTSTR lpszCaption,
    int nID = 0
);
Parameters

nItem
Position to insert new tab
nID
Identifier of tab
lpszCaption
Caption of tab to be added

Returns

Pointer to new CXTPRibbonTab object

See Also

AddTab

Group

InsertTab Method


CXTPRibbonBar::IsAllowQuickAccessControl Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::IsAllowQuickAccessControl Method

Determines if control can be added to quick access controls.

virtual BOOL IsAllowQuickAccessControl(
    CXTPControl* pControl
);
Parameters

pControl
Control to test

Returns

TRUE if control can be added in quick access area.

Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsAllowQuickAccessDuplicates Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::IsAllowQuickAccessDuplicates Method

Determines if user can add 2 or more same controls to quick access

BOOL IsAllowQuickAccessDuplicates() const;
Returns

TRUE if duplicates allowed

See Also

AllowQuickAccessDuplicates

Body Source
BOOL CXTPRibbonBar::IsAllowQuickAccessDuplicates() const {
    return m_bAllowQuickAccessDuplicates;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsCaptionVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::IsCaptionVisible Method

Determines if caption part of ribbon is visible

BOOL IsCaptionVisible() const;
Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsDwmEnabled Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::IsDwmEnabled Method

Determines if Vista Glass Effect enabled for Ribbon Bar.

BOOL IsDwmEnabled() const;
Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsFrameThemeEnabled Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::IsFrameThemeEnabled Method

Determines if Office 2007 frame enabled

BOOL IsFrameThemeEnabled() const;
See Also

IsFrameThemeEnabled

Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsGroupsVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::IsGroupsVisible Method

Determines if groups part of ribbon bar is visible

BOOL IsGroupsVisible() const;
Returns

TRUE if groups are visible

See Also

SetGroupsVisible

Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsQuickAccessBelowRibbon Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::IsQuickAccessBelowRibbon Method

Determine if Quick Access controls located below ribbon bar

BOOL IsQuickAccessBelowRibbon() const;
See Also

ShowQuickAccessBelowRibbon

Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsQuickAccessControl Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::IsQuickAccessControl Method

Determines if control belongs to quick access controls.

BOOL IsQuickAccessControl(
    CXTPControl* pControl
) const;
Parameters

pControl
Control to test

Returns

TRUE if control located in quick access area.

Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsQuickAccessVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::IsQuickAccessVisible Method

Determines if quick access is visible

BOOL IsQuickAccessVisible() const;
Returns

TRUE if quick access is visible

See Also

ShowQuickAccess

Body Source
BOOL CXTPRibbonBar::IsQuickAccessVisible() const {
    return m_bShowQuickAccess;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsRibbonBar Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::IsRibbonBar Method

Call this member function to determine if the CommandBar is a CXTPRibbonBar.

virtual BOOL IsRibbonBar() const;
Returns

Returns TRUE if the CommandBar is a CXTPRibbonBar, otherwise FALSE

See Also

CXTPCommandBar, CXTPRibbonBar

Body Source
BOOL CXTPRibbonBar::IsRibbonBar() const {
    return TRUE;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsRibbonBarVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source
CXTPRibbonBar::IsRibbonBarVisible Method

Determines if ribbon bar is visible

BOOL IsRibbonBarVisible() const;
Body Source
BOOL CXTPRibbonBar::IsRibbonBarVisible() const {
    return m_bVisible && m_bRibbonBarVisible;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsRibbonMinimized Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::IsRibbonMinimized Method

Determines if ribbon bar is minimized

BOOL IsRibbonMinimized() const;
Group

CXTPRibbonBar Methods


CXTPRibbonBar::IsTabsVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::IsTabsVisible Method

Determines if tabs part of ribbon bar is visible

BOOL IsTabsVisible() const;
Returns

TRUE if tabs are visible

See Also

SetTabsVisible

Group

CXTPRibbonBar Methods


CXTPRibbonBar::OnTabChanged Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::OnTabChanged Method

This virtual method called when current tab is changed.

virtual void OnTabChanged(
    CXTPRibbonTab* pTab
);
Parameters

pTab
New selected tab

Group

CXTPRibbonBar Methods


CXTPRibbonBar::OnTabChanging Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::OnTabChanging Method

This virtual method called when tab is about to be changed.

virtual BOOL OnTabChanging(
    CXTPRibbonTab* pTab
);
Parameters

pTab
Tab to be selected

Returns

returns TRUE to cancel tab changing, FALSE to allow.

Group

CXTPRibbonBar Methods


CXTPRibbonBar::RebuildControls Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::RebuildControls Method

When switching tabs, RebuildControls first deletes all the controls from the old tab groups. Then controls are added to the tab groups of the tab to be selected. Finally, the new tab is selected.

void RebuildControls(
    CXTPRibbonTab* pSelected
);
Parameters

pSelected
Tab to be selected.

See Also

CXTPRibbonControlTab::SetSelectedItem, CXTPRibbonTab::GetGroups

Group

CXTPRibbonBar Methods


CXTPRibbonBar::RemoveAllTabs Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::RemoveAllTabs Method

Call this member to remove all tab

void RemoveAllTabs();
See Also

RemoveTab

Group

CXTPRibbonBar Methods


CXTPRibbonBar::RemoveTab Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::RemoveTab Method

Call this member to remove single tab

void RemoveTab(
    int nIndex
);
Parameters

nIndex
Index of tab to remove

See Also

RemoveTab

Group

CXTPRibbonBar Methods


CXTPRibbonBar::SelectNextTab Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::SelectNextTab Method

Call this method to select next or previous tab

void SelectNextTab(
    BOOL bNext
);
Parameters

bNext
TRUE to select next

Group

CXTPRibbonBar Methods


CXTPRibbonBar::SetCurSel Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::SetCurSel Method

Call this method to select tab.

void SetCurSel(
    int nIndex
);
Parameters

nIndex
Index of tab to be selected

See Also

GetSelectedTab

Group

CXTPRibbonBar Methods


CXTPRibbonBar::SetFontHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::SetFontHeight Method

Call this method to set custom font height for ribbon bar

void SetFontHeight(
    int nFontHeight
);
Parameters

nFontHeight
Font height to set

Group

CXTPRibbonBar Methods


CXTPRibbonBar::SetGroupsHeight Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::SetGroupsHeight Method

Call this method to set height of the ribbon groups

void SetGroupsHeight(
    int nHeight
);
Parameters

nHeight
Height of groups to set

See Also

GetTabsHeight

Body Source
void CXTPRibbonBar::SetGroupsHeight(int nHeight) {
    m_nGroupsHeight = nHeight;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::SetGroupsVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::SetGroupsVisible Method

Call this method to hide/show groups part of ribbon bar

void SetGroupsVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show groups

See Also

IsGroupsVisible

Group

CXTPRibbonBar Methods


CXTPRibbonBar::SetMinimumVisibleWidth Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::SetMinimumVisibleWidth Method

Call this method to set minimum width before ribbon bar disappear

void SetMinimumVisibleWidth(
    int nMinVisibleWidth
);
Parameters

nMinVisibleWidth
Minimum width.

Remarks

Default value is 250 pixels

See Also

GetMinimumVisibleWidth

Body Source
void CXTPRibbonBar::SetMinimumVisibleWidth(int nMinVisibleWidth) {
    m_nMinVisibleWidth = nMinVisibleWidth;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::SetRibbonMinimized Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::SetRibbonMinimized Method

Call this method to minimize Ribbon Bar

virtual void SetRibbonMinimized(
    BOOL bMinimized
);
Parameters

bMinimized
TRUE to minimize Ribbon Bar.

Group

CXTPRibbonBar Methods


CXTPRibbonBar::SetTabsVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::SetTabsVisible Method

Call this method to hide/show tabs part of ribbon bar

void SetTabsVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show tabs

See Also

IsTabsVisible

Group

CXTPRibbonBar Methods


CXTPRibbonBar::SetVisible Method

CXTPRibbonBar Methods, CXTPRibbonBar Class
CXTPRibbonBar::SetVisible Method

Call this member function to show or hide the ribbon.

virtual void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show the ribbon; FALSE to hide.

Group

CXTPRibbonBar Methods


CXTPRibbonBar::ShowCaptionAlways Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source
CXTPRibbonBar::ShowCaptionAlways Method

This method allow show/hide caption if frame theme is not enabled.

void ShowCaptionAlways(
    BOOL bShowCaption
);
Parameters

bShowCaption
TRUE to show caption if frame theme is not enabled.

Body Source
void CXTPRibbonBar::ShowCaptionAlways(BOOL bShowCaption) {
    m_bShowCaptionAlways = bShowCaption;
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::ShowQuickAccess Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonBar::ShowQuickAccess Method

Call this method to show/hide quick access

void ShowQuickAccess(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE to show quick access; FALSE to hide

See Also

IsQuickAccessVisible, ShowQuickAccessBelowRibbon

Body Source
void CXTPRibbonBar::ShowQuickAccess(BOOL bShow) {
    m_bShowQuickAccess = bShow;
    OnRecalcLayout();
}
Group

CXTPRibbonBar Methods


CXTPRibbonBar::ShowQuickAccessBelowRibbon Method

CXTPRibbonBar Methods, CXTPRibbonBar Class, See Also
CXTPRibbonBar::ShowQuickAccessBelowRibbon Method

Call this method to show Quick Access controls below ribbon bar

void ShowQuickAccessBelowRibbon(
    BOOL bBelow = TRUE
);
Parameters

bBelow
TRUE to show below ribbon; FALSE - above.

See Also

IsQuickAccessBelowRibbon

Group

CXTPRibbonBar Methods


CXTPRibbonBar Constructors

CXTPRibbonBar Class, Legend, Public Methods
CXTPRibbonBar Constructors
Class

CXTPRibbonBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonBar | Constructs a CXTPRibbonBar object


CXTPRibbonBar::CXTPRibbonBar Constructor

CXTPRibbonBar Constructors, CXTPRibbonBar Class
CXTPRibbonBar::CXTPRibbonBar Constructor

Constructs a CXTPRibbonBar object

CXTPRibbonBar();
Group

CXTPRibbonBar Constructors


CXTPRibbonBar Destructors

CXTPRibbonBar Class, Legend, Public Methods
CXTPRibbonBar Destructors
Class

CXTPRibbonBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPRibbonBar | Destroys a CXTPRibbonBar object, handles cleanup and deallocation


CXTPRibbonBar::~CXTPRibbonBar Destructor

CXTPRibbonBar Destructors, CXTPRibbonBar Class
CXTPRibbonBar::~CXTPRibbonBar Destructor

Destroys a CXTPRibbonBar object, handles cleanup and deallocation

virtual ~CXTPRibbonBar();
Group

CXTPRibbonBar Destructors


CXTPRibbonControls Class

XTPRibbonQuickAccessControls.h, Classes, Legend, Members, Topics, CXTPRibbonControls Methods, CXTPRibbonControls Constructors, CXTPRibbonControls Constructors, CXTPRibbonControls Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControls Class

CXTPRibbonControls is a CXTPControls derived class. It represents a collection of the controls for Ribbon Bar.

Class Hierarchy

class CXTPRibbonControls : public CXTPControls;
File

XTPRibbonQuickAccessControls.h

Group

Classes

Legend
Method
protected
virtual
CXTPRibbonControls Constructors
CXTPRibbonControls Constructors | Description
CXTPRibbonControls | Constructs a CXTPRibbonControls object
CXTPRibbonControls Methods
CXTPRibbonControls Methods | Description
OnControlRemoved | This method is called when control is removed from collection
OnControlRemoving | This method is called when control is about to be removing from collection


CXTPRibbonControls Methods

CXTPRibbonControls Class, Legend, Protected Methods
CXTPRibbonControls Methods
Class

CXTPRibbonControls Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnControlRemoved | This method is called when control is removed from collection
OnControlRemoving | This method is called when control is about to be removing from collection


CXTPRibbonControls::OnControlRemoved Method

CXTPRibbonControls Methods, CXTPRibbonControls Class
CXTPRibbonControls::OnControlRemoved Method

This method is called when control is removed from collection

virtual void OnControlRemoved(
    CXTPControl* pControl
);
Parameters

pControl
control that removed from collection

Group

CXTPRibbonControls Methods


CXTPRibbonControls::OnControlRemoving Method

CXTPRibbonControls Methods, CXTPRibbonControls Class
CXTPRibbonControls::OnControlRemoving Method

This method is called when control is about to be removing from collection

virtual BOOL OnControlRemoving(
    CXTPControl* pControl
);
Parameters

pControl
control that removing from collection

Returns

TRUE to cancel removing.

Group

CXTPRibbonControls Methods


CXTPRibbonControls Constructors

CXTPRibbonControls Class, Legend, Public Methods
CXTPRibbonControls Constructors
Class

CXTPRibbonControls Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonControls | Constructs a CXTPRibbonControls object


CXTPRibbonControls::CXTPRibbonControls Constructor

CXTPRibbonControls Constructors, CXTPRibbonControls Class
CXTPRibbonControls::CXTPRibbonControls Constructor

Constructs a CXTPRibbonControls object

CXTPRibbonControls();
Group

CXTPRibbonControls Constructors


CXTPRibbonControlTab Class

XTPRibbonControlTab.h, Classes, Legend, Members, Topics, CXTPRibbonControlTab Data Members, CXTPRibbonControlTab Methods, CXTPRibbonControlTab Constructors, CXTPRibbonControlTab Destructors, CXTPRibbonControlTab Constructors, CXTPRibbonControlTab Data Members, CXTPRibbonControlTab Destructors, CXTPRibbonControlTab Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControlTab Class

CXTPRibbonControlTab is a CXTPTabManager derived class, It represents tabs of the ribbon bar

Class Hierarchy

class CXTPRibbonControlTab : public CXTPControlPopup, public CXTPTabManager;
File

XTPRibbonControlTab.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPRibbonControlTab Constructors
CXTPRibbonControlTab Constructors | Description
CXTPRibbonControlTab | Constructs a CXTPRibbonControlTab object
CXTPRibbonControlTab Data Members
CXTPRibbonControlTab Data Members | Description
m_bFocused | TRUE if groups focused
CXTPRibbonControlTab Destructors
CXTPRibbonControlTab Destructors | Description
~CXTPRibbonControlTab | Destroys a CXTPRibbonControlTab object, handles cleanup and deallocation
CXTPRibbonControlTab Methods
CXTPRibbonControlTab Methods | Description
Draw | This method is called to draw the control.
DrawIcon | This member is called when the icon of the ribbon tab needs to be drawn.
FindTab | Cal this method to find tab by its identifier
GetPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
GetRibbonBar | Retrieves parent CXTPRibbonBar object
GetTab | Cal this method to get tab in specified position
HeaderHasFocus | This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item
IsFocusable | This method is called to check if control accept focus
IsFocused | Call this member to get the focused state of the control.
IsMouseLocked | Checks to see if the mouse is locked.
OnHookKeyDown | This method is called when a non-system key is pressed.
OnSetSelected | This method is called when the control becomes selected.
OnUnderlineActivate | This method is called when the user activate control using its underline.
RedrawControl | Initiates redrawing of the ribbon bar control.
Reposition | This method is called to update position of TabManager.
SetFocused | Call this member to set focus to the control.
SetSelectedItem | Call this member to select a tab in the ribbon bar.


CXTPRibbonControlTab Data Members

CXTPRibbonControlTab Class, Legend, Protected Data Members
CXTPRibbonControlTab Data Members
Class

CXTPRibbonControlTab Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bFocused | TRUE if groups focused


CXTPRibbonControlTab::m_bFocused Data Member

CXTPRibbonControlTab Data Members, CXTPRibbonControlTab Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControlTab::m_bFocused Data Member

TRUE if groups focused

BOOL m_bFocused;
Group

CXTPRibbonControlTab Data Members


CXTPRibbonControlTab Methods

CXTPRibbonControlTab Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControlTab Methods
Class

CXTPRibbonControlTab Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Draw | This method is called to draw the control.
DrawIcon | This member is called when the icon of the ribbon tab needs to be drawn.
HeaderHasFocus | This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item
IsFocusable | This method is called to check if control accept focus
IsFocused | Call this member to get the focused state of the control.
IsMouseLocked | Checks to see if the mouse is locked.
OnHookKeyDown | This method is called when a non-system key is pressed.
OnSetSelected | This method is called when the control becomes selected.
OnUnderlineActivate | This method is called when the user activate control using its underline.
RedrawControl | Initiates redrawing of the ribbon bar control.
Reposition | This method is called to update position of TabManager.
SetFocused | Call this member to set focus to the control.
Public Methods
Public Methods
Public Method | Description
FindTab | Cal this method to find tab by its identifier
GetPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
GetRibbonBar | Retrieves parent CXTPRibbonBar object
GetTab | Cal this method to get tab in specified position
SetSelectedItem | Call this member to select a tab in the ribbon bar.


CXTPRibbonControlTab::Draw Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::Draw Method

This method is called to draw the control.

void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::DrawIcon Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::DrawIcon Method

This member is called when the icon of the ribbon tab needs to be drawn.

BOOL DrawIcon(
    CDC* pDC,
    CPoint pt,
    CXTPTabManagerItem* pItem,
    BOOL bDraw,
    CSize& szIcon
) const;
Parameters

pDC
Pointer to the destination device context.
pt
Specifies the location of the image.
pItem
CXTPTabManagerItem object to draw icon on.
bDraw
TRUE if the icon needs to be drawn, I.e. the icon size changed. FALSE if the icon does not need to be drawn or redrawn.
szIcon
Size of the tab icon.

Returns

TRUE if the icon was successfully drawn, FALSE if the icon was not drawn.

Remarks

For example, on mouseover. This member is overridden by its descendants. This member must be overridden in derived classes.

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::FindTab Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControlTab::FindTab Method

Cal this method to find tab by its identifier

CXTPRibbonTab* FindTab(
    int nId
) const;
Parameters

nId
Identifier of tab to be found

Returns

Pointer to CXTPRibbonTab object with specified identifier

See Also

GetTab

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::GetPaintManager Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::GetPaintManager Method

Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.

virtual CXTPTabPaintManager* GetPaintManager() const;
Returns

Pointer to CXTPTabPaintManager that contains the visual elements of the tabs.

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::GetRibbonBar Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControlTab::GetRibbonBar Method

Retrieves parent CXTPRibbonBar object

CXTPRibbonBar* GetRibbonBar() const;
Body Source
CXTPRibbonBar* CXTPRibbonControlTab::GetRibbonBar() const {
    return (CXTPRibbonBar*)m_pParent;
}
Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::GetTab Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControlTab::GetTab Method

Cal this method to get tab in specified position

CXTPRibbonTab* GetTab(
    int nIndex
) const;
Parameters

nIndex
Index of tab to retrieve

Returns

Pointer to CXTPRibbonTab object in specified position

See Also

FindTab

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::HeaderHasFocus Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::HeaderHasFocus Method

This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item

virtual BOOL HeaderHasFocus() const;
Returns

TRUE if header has has focus

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::IsFocusable Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControlTab::IsFocusable Method

This method is called to check if control accept focus

virtual BOOL IsFocusable() const;
See Also

SetFocused

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::IsFocused Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::IsFocused Method

Call this member to get the focused state of the control.

virtual BOOL IsFocused() const;
Returns

TRUE if the control has focus; otherwise FALSE.

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::IsMouseLocked Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::IsMouseLocked Method

Checks to see if the mouse is locked.

BOOL IsMouseLocked() const;
Returns

TRUE if locked; otherwise returns FALSE.

Remarks

The mouse is locked when a CXTPCommandBarsPopup is currently visible.

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::OnHookKeyDown Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::OnHookKeyDown Method

This method is called when a non-system key is pressed.

BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::OnSetSelected Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::OnSetSelected Method

This method is called when the control becomes selected.

BOOL OnSetSelected(
    int bSelected
);
Parameters

bSelected
TRUE if the control becomes selected.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::OnUnderlineActivate Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::OnUnderlineActivate Method

This method is called when the user activate control using its underline.

void OnUnderlineActivate();
Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::RedrawControl Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::RedrawControl Method

Initiates redrawing of the ribbon bar control.

void RedrawControl(
    LPCRECT lpRect,
    BOOL bAnimate
);
Parameters

lpRect
The rectangular area of the window that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Remarks

Call this member function if you want to initialize redrawing of the control. The control will be redrawn taking into account its latest state.

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::Reposition Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::Reposition Method

This method is called to update position of TabManager.

void Reposition();
Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::SetFocused Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::SetFocused Method

Call this member to set focus to the control.

virtual void SetFocused(
    BOOL bFocused
);
Parameters

bFocused
TRUE to set focus

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab::SetSelectedItem Method

CXTPRibbonControlTab Methods, CXTPRibbonControlTab Class
CXTPRibbonControlTab::SetSelectedItem Method

Call this member to select a tab in the ribbon bar.

void SetSelectedItem(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Points to a CXTPTabManagerItem object to be selected.

Group

CXTPRibbonControlTab Methods


CXTPRibbonControlTab Constructors

CXTPRibbonControlTab Class, Legend, Public Methods
CXTPRibbonControlTab Constructors
Class

CXTPRibbonControlTab Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonControlTab | Constructs a CXTPRibbonControlTab object


CXTPRibbonControlTab::CXTPRibbonControlTab Constructor

CXTPRibbonControlTab Constructors, CXTPRibbonControlTab Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonControlTab::CXTPRibbonControlTab Constructor

Constructs a CXTPRibbonControlTab object

CXTPRibbonControlTab();
Group

CXTPRibbonControlTab Constructors


CXTPRibbonControlTab Destructors

CXTPRibbonControlTab Class, Legend, Public Methods
CXTPRibbonControlTab Destructors
Class

CXTPRibbonControlTab Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPRibbonControlTab | Destroys a CXTPRibbonControlTab object, handles cleanup and deallocation


CXTPRibbonControlTab::~CXTPRibbonControlTab Destructor

CXTPRibbonControlTab Destructors, CXTPRibbonControlTab Class
CXTPRibbonControlTab::~CXTPRibbonControlTab Destructor

Destroys a CXTPRibbonControlTab object, handles cleanup and deallocation

virtual ~CXTPRibbonControlTab();
Group

CXTPRibbonControlTab Destructors


CXTPRibbonCustomizeQuickAccessPage Class

XTPRibbonCustomizeQuickAccessPage.h, Classes, Legend, Members, Topics, CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Methods, CXTPRibbonCustomizeQuickAccessPage Constructors, CXTPRibbonCustomizeQuickAccessPage Destructors, CXTPRibbonCustomizeQuickAccessPage Constructors, CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Destructors, CXTPRibbonCustomizeQuickAccessPage Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage Class

CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class. It represents the Quick Access page of the Customize dialog.

Class Hierarchy

class CXTPRibbonCustomizeQuickAccessPage : public CPropertyPage;
File

XTPRibbonCustomizeQuickAccessPage.h

Group

Classes

Legend
Data Member
protected
Method
CXTPRibbonCustomizeQuickAccessPage Constructors
CXTPRibbonCustomizeQuickAccessPage Constructors | Description
CXTPRibbonCustomizeQuickAccessPage | Constructs a CXTPRibbonCustomizeQuickAccessPage object
CXTPRibbonCustomizeQuickAccessPage Data Members
CXTPRibbonCustomizeQuickAccessPage Data Members | Description
m_arrCategories | Array of categories.
m_bShowQuickAccessBelow | TRUE to show quick access below ribbon
m_lstCategories | Categories list
m_lstCommands | Commands list
m_lstQuickAccess | Quick access list
m_pCommandBars | Parent CommandBars object
m_pSheet | Parent Sheet window
CXTPRibbonCustomizeQuickAccessPage Destructors
CXTPRibbonCustomizeQuickAccessPage Destructors | Description
~CXTPRibbonCustomizeQuickAccessPage | Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.
CXTPRibbonCustomizeQuickAccessPage Methods
CXTPRibbonCustomizeQuickAccessPage Methods | Description
AddCategories |
AddCategory | Adds a new category from a CMenu object.
GetControls | Retrieves the control list of the given category.
GetRibbonBar | Retrieves Ribbon bar to customize
InsertCategory | This method adds a new empty category in the given index.
OnCheckShowQuickAccessBelow | AFX_MSG(CXTPRibbonCustomizeQuickAccessPage)
RefreshQuickAccessList | Refills list of quick access controls


CXTPRibbonCustomizeQuickAccessPage Data Members

CXTPRibbonCustomizeQuickAccessPage Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage Data Members
Class

CXTPRibbonCustomizeQuickAccessPage Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrCategories | Array of categories.
m_pCommandBars | Parent CommandBars object
m_pSheet | Parent Sheet window
Public Data Members
Public Data Member | Description
m_bShowQuickAccessBelow | TRUE to show quick access below ribbon
m_lstCategories | Categories list
m_lstCommands | Commands list
m_lstQuickAccess | Quick access list


CXTPRibbonCustomizeQuickAccessPage::m_arrCategories Data Member

CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::m_arrCategories Data Member

Array of categories.

CXTPCommandBarsCategoryArray m_arrCategories;
Group

CXTPRibbonCustomizeQuickAccessPage Data Members


CXTPRibbonCustomizeQuickAccessPage::m_bShowQuickAccessBelow Data Member

CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::m_bShowQuickAccessBelow Data Member

TRUE to show quick access below ribbon

BOOL m_bShowQuickAccessBelow;
Group

CXTPRibbonCustomizeQuickAccessPage Data Members


CXTPRibbonCustomizeQuickAccessPage::m_lstCategories Data Member

CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::m_lstCategories Data Member

Categories list

CComboBox m_lstCategories;
Group

CXTPRibbonCustomizeQuickAccessPage Data Members


CXTPRibbonCustomizeQuickAccessPage::m_lstCommands Data Member

CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::m_lstCommands Data Member

Commands list

CXTPCustomizeCommandsListBox m_lstCommands;
Group

CXTPRibbonCustomizeQuickAccessPage Data Members


CXTPRibbonCustomizeQuickAccessPage::m_lstQuickAccess Data Member

CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::m_lstQuickAccess Data Member

Quick access list

CXTPCustomizeCommandsListBox m_lstQuickAccess;
Group

CXTPRibbonCustomizeQuickAccessPage Data Members


CXTPRibbonCustomizeQuickAccessPage::m_pCommandBars Data Member

CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::m_pCommandBars Data Member

Parent CommandBars object

CXTPCommandBars* m_pCommandBars;
Group

CXTPRibbonCustomizeQuickAccessPage Data Members


CXTPRibbonCustomizeQuickAccessPage::m_pSheet Data Member

CXTPRibbonCustomizeQuickAccessPage Data Members, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::m_pSheet Data Member

Parent Sheet window

CXTPCustomizeSheet* m_pSheet;
Group

CXTPRibbonCustomizeQuickAccessPage Data Members


CXTPRibbonCustomizeQuickAccessPage Methods

CXTPRibbonCustomizeQuickAccessPage Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage Methods
Class

CXTPRibbonCustomizeQuickAccessPage Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
OnCheckShowQuickAccessBelow | AFX_MSG(CXTPRibbonCustomizeQuickAccessPage)
RefreshQuickAccessList | Refills list of quick access controls
Public Methods
Public Methods
Public Method | Description
AddCategories |
AddCategory | Adds a new category from a CMenu object.
GetControls | Retrieves the control list of the given category.
GetRibbonBar | Retrieves Ribbon bar to customize
InsertCategory | This method adds a new empty category in the given index.


AddCategories Method

CXTPRibbonCustomizeQuickAccessPage Methods
AddCategories Method
Overload List
Methods
Method | Description
CXTPRibbonCustomizeQuickAccessPage::AddCategories (CXTPControls*) | Adds categories branch from Controls.
CXTPRibbonCustomizeQuickAccessPage::AddCategories (UINT, BOOL) | Adds categories branch from menu resource.
Group

CXTPRibbonCustomizeQuickAccessPage Methods


CXTPRibbonCustomizeQuickAccessPage::AddCategories Method (CXTPControls*)

AddCategories Method, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::AddCategories Method (CXTPControls*)

Adds categories branch from Controls.

BOOL AddCategories(
    CXTPControls* pControls
);
Parameters

pControls
Points to a CXTPControls object

Returns

TRUE if successful; otherwise returns FALSE

Group

AddCategories Method


CXTPRibbonCustomizeQuickAccessPage::AddCategories Method (UINT, BOOL)

AddCategories Method, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::AddCategories Method (UINT, BOOL)

Adds categories branch from menu resource.

BOOL AddCategories(
    UINT nIDResource,
    BOOL bListSubItems = FALSE
);
Parameters

nIDResource
Menu resource from where categories will be built.
bListSubItems
TRUE to add sub menus to categories.

Returns

TRUE if successful; otherwise returns FALSE

Group

AddCategories Method


CXTPRibbonCustomizeQuickAccessPage::AddCategory Method

CXTPRibbonCustomizeQuickAccessPage Methods, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::AddCategory Method

Adds a new category from a CMenu object.

BOOL AddCategory(
    LPCTSTR strCategory,
    CMenu* pMenu,
    BOOL bListSubItems = FALSE
);
Parameters

strCategory
Category to be added.
pMenu
Points to a CMenu object
bListSubItems
TRUE to add sub menus to the category.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPRibbonCustomizeQuickAccessPage Methods


CXTPRibbonCustomizeQuickAccessPage::GetControls Method

CXTPRibbonCustomizeQuickAccessPage Methods, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::GetControls Method

Retrieves the control list of the given category.

CXTPControls* GetControls(
    LPCTSTR strCategory
);
Parameters

strCategory
Category to retrieve.

Returns

A pointer to a CXTPControls object.

Group

CXTPRibbonCustomizeQuickAccessPage Methods


CXTPRibbonCustomizeQuickAccessPage::GetRibbonBar Method

CXTPRibbonCustomizeQuickAccessPage Methods, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::GetRibbonBar Method

Retrieves Ribbon bar to customize

CXTPRibbonBar* GetRibbonBar();
Returns

Pointer to commandbars' ribbon bar

Group

CXTPRibbonCustomizeQuickAccessPage Methods


CXTPRibbonCustomizeQuickAccessPage::InsertCategory Method

CXTPRibbonCustomizeQuickAccessPage Methods, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::InsertCategory Method

This method adds a new empty category in the given index.

CXTPControls* InsertCategory(
    LPCTSTR strCategory,
    int nIndex = -1
);
Parameters

strCategory
Category to be added.
nIndex
Index to insert.

Returns

A pointer to a CXTPControls object

Group

CXTPRibbonCustomizeQuickAccessPage Methods


CXTPRibbonCustomizeQuickAccessPage::OnCheckShowQuickAccessBelow Method

CXTPRibbonCustomizeQuickAccessPage Methods, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::OnCheckShowQuickAccessBelow Method

AFX_MSG(CXTPRibbonCustomizeQuickAccessPage)

afx_msg void OnCheckShowQuickAccessBelow();
Group

CXTPRibbonCustomizeQuickAccessPage Methods


CXTPRibbonCustomizeQuickAccessPage::RefreshQuickAccessList Method

CXTPRibbonCustomizeQuickAccessPage Methods, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::RefreshQuickAccessList Method

Refills list of quick access controls

void RefreshQuickAccessList();
Group

CXTPRibbonCustomizeQuickAccessPage Methods


CXTPRibbonCustomizeQuickAccessPage Constructors

CXTPRibbonCustomizeQuickAccessPage Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage Constructors
Class

CXTPRibbonCustomizeQuickAccessPage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonCustomizeQuickAccessPage | Constructs a CXTPRibbonCustomizeQuickAccessPage object


CXTPRibbonCustomizeQuickAccessPage::CXTPRibbonCustomizeQuickAccessPage Constructor

CXTPRibbonCustomizeQuickAccessPage Constructors, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::CXTPRibbonCustomizeQuickAccessPage Constructor

Constructs a CXTPRibbonCustomizeQuickAccessPage object

CXTPRibbonCustomizeQuickAccessPage(
    CXTPCustomizeSheet* pSheet
);
Parameters

pSheet
Points to a CXTPCustomizeSheet object

Group

CXTPRibbonCustomizeQuickAccessPage Constructors


CXTPRibbonCustomizeQuickAccessPage Destructors

CXTPRibbonCustomizeQuickAccessPage Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage Destructors
Class

CXTPRibbonCustomizeQuickAccessPage Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPRibbonCustomizeQuickAccessPage | Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.


CXTPRibbonCustomizeQuickAccessPage::~CXTPRibbonCustomizeQuickAccessPage Destructor

CXTPRibbonCustomizeQuickAccessPage Destructors, CXTPRibbonCustomizeQuickAccessPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonCustomizeQuickAccessPage::~CXTPRibbonCustomizeQuickAccessPage Destructor

Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.

~CXTPRibbonCustomizeQuickAccessPage();
Group

CXTPRibbonCustomizeQuickAccessPage Destructors


CXTPRibbonGroup Class

XTPRibbonGroup.h, Classes, Legend, Members, Topics, CXTPRibbonGroup Data Members, CXTPRibbonGroup Methods, CXTPRibbonGroup Constructors, CXTPRibbonGroup Destructors, CXTPRibbonGroup Constructors, CXTPRibbonGroup Data Members, CXTPRibbonGroup Destructors, CXTPRibbonGroup Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup Class

Represents a single group that is added to a CXTPRibbonTab.

Class Hierarchy

class CXTPRibbonGroup;
File

XTPRibbonGroup.h

Remarks

Each CXTPRibbonTab can contain one or more CXTPRibbonGroup objects that are used to hold CXTPControl objects. The Caption of a CXTPRibbonGroup is a title bar that visually "groups" the CXTPControl objects that have been added to the RibbonGroup Items Collection (CXTPRibbonGroup::GetAt).

Groups are added to the CXTPRibbonTab Groups Collection using the CXTPRibbonGroups::AddGroup and CXTPRibbonGroups::InsertAt methods. Items are added to a group using the CXTPRibbonGroup::Add method.

See Also

CXTPRibbonGroup::GetAt

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPRibbonGroup Constructors
CXTPRibbonGroup Constructors | Description
CXTPRibbonGroup | Constructs a CXTPRibbonGroup object
CXTPRibbonGroup Data Members
CXTPRibbonGroup Data Members | Description
m_arrControls | Collection of group's controls
m_bControlsCentering | TRUE to center controls inside groups
m_bControlsGrouping | TRUE to group controls
m_bReduced | TRUE if group was reduced
m_bShowOptionButton | TRUE to show option button
m_bVisible | TRUE if group is visible
m_nIconId | Icon index of the group
m_nId | Identifier of the group
m_nIndex | Index of the group
m_nRowCount | Total rows number of items
m_pControlGroupOption | Group option control
m_pControlGroupPopup | Group popup control
m_pGroups | Parent groups collection
m_pParent | Parent ribbon bar
m_pRibbonBar | Parent ribbon bar
m_rcGroup | Bounding rectangle of the group
m_strCaption | Caption of the group
CXTPRibbonGroup Destructors
CXTPRibbonGroup Destructors | Description
~CXTPRibbonGroup | Destroys a CXTPRibbonGroup object, handles cleanup and deallocation.
CXTPRibbonGroup Methods
CXTPRibbonGroup Methods | Description
Add |
AllowReduce | Call this method to prevent group to be reduced to button
Copy | This method is called to copy parameter from one group to another
Draw | Draws the group and all of the controls in the group.
FindControl |
GetAt | Gets a CXTPControl object that has been added to the CXTPRibbonGroup at the specified index.
GetCaption | Gets the text displayed in the group title bar.
GetControlGroupOption | CXTPControl that represents the group's OptionButton (used to set tool tip and status bar text).
GetControlGroupPopup | Gets a pointer to the CXTPControlPopup that is used to display controls that are not currently visible in the group.
GetCount | Total number of CXTPControl objects that have been added to the CXTPRibbonGroup.
GetIconId | Call this member to get the icon's identifier. This is the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group.
GetID | Gets the group's Id.
GetIndex | Returns own index in parent group collection
GetMinimumWidth | Calculates minimum width for the ribbon group
GetParentTab | The CXTPRibbonTab object the CXTPRibbonGroup belongs to.
GetRect | Gets the bounding rectangle for the group.
GetRibbonBar | The CXTPRibbonBar object the CXTPRibbonGroup belongs to.
InsertAt | Adds a CXTPControl to the ribbon group.
IsControlsGrouping | Determines if control grouping is used.
IsHighlighted | Gets whether the group is currently highlighted.
IsOptionButtonVisible | Determines if option button is visible
IsReduced | Determines id the CXTPRibbonGroup is currently displayed as a group button.
IsVisible | Determines if group currently visible
LoadToolBar | Call this member function to load the toolbar specified by nIDResource.
OnAfterCalcSize | This method is called after size of ribbon group was calculated
OnBeforeCalcSize | This method is called before calculate size of ribbon group
OnCalcDynamicSize | This method is called to find width of the ribbon group
OnExtendSize | This method is called to increase size of ribbon group
OnGroupAdded | This method is called when the group was added
OnGroupRemoved | This method is called when the group was removed
OnReduceSize | This method is called to decrease size of ribbon group
Remove | Removes and item at the from collection of items.
RemoveAll | Removes all of the items from the group.
RemoveAt | Removes and item at the specified position in the group's collection of items.
RepositionControls | Called automatically to reposition all controls in the group. For example, when the position/size of Ribbon Bar changes.
SetButtons | Call this member to set the controls from the button array.
SetCaption | Sets the text to display in the group title bar.
SetControlsCentering | Call this method to automatically center controls in group
SetControlsGrouping | Call this method to group buttons in the group.
SetIconId | Call this member to set the group icon's identifier. This is the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group.
SetID | Call this method to set Identifier for group
SetRect | Sets the bounding rectangle for the group.
SetVisible | Call this method to show/hide the group
ShowOptionButton | Specifies whether to display an option button in the group caption.


CXTPRibbonGroup Data Members

CXTPRibbonGroup Class, Legend, Protected Data Members
CXTPRibbonGroup Data Members
Class

CXTPRibbonGroup Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrControls | Collection of group's controls
m_bControlsCentering | TRUE to center controls inside groups
m_bControlsGrouping | TRUE to group controls
m_bReduced | TRUE if group was reduced
m_bShowOptionButton | TRUE to show option button
m_bVisible | TRUE if group is visible
m_nIconId | Icon index of the group
m_nId | Identifier of the group
m_nIndex | Index of the group
m_nRowCount | Total rows number of items
m_pControlGroupOption | Group option control
m_pControlGroupPopup | Group popup control
m_pGroups | Parent groups collection
m_pParent | Parent ribbon bar
m_pRibbonBar | Parent ribbon bar
m_rcGroup | Bounding rectangle of the group
m_strCaption | Caption of the group


CXTPRibbonGroup::m_arrControls Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_arrControls Data Member

Collection of group's controls

CArray<CXTPControl*, CXTPControl*> m_arrControls;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_bControlsCentering Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_bControlsCentering Data Member

TRUE to center controls inside groups

BOOL m_bControlsCentering;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_bControlsGrouping Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_bControlsGrouping Data Member

TRUE to group controls

BOOL m_bControlsGrouping;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_bReduced Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_bReduced Data Member

TRUE if group was reduced

BOOL m_bReduced;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_bShowOptionButton Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_bShowOptionButton Data Member

TRUE to show option button

BOOL m_bShowOptionButton;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_bVisible Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_bVisible Data Member

TRUE if group is visible

BOOL m_bVisible;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_nIconId Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_nIconId Data Member

Icon index of the group

int m_nIconId;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_nId Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_nId Data Member

Identifier of the group

int m_nId;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_nIndex Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_nIndex Data Member

Index of the group

int m_nIndex;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_nRowCount Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_nRowCount Data Member

Total rows number of items

int m_nRowCount;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_pControlGroupOption Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_pControlGroupOption Data Member

Group option control

CXTPControl* m_pControlGroupOption;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_pControlGroupPopup Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_pControlGroupPopup Data Member

Group popup control

CXTPControlPopup* m_pControlGroupPopup;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_pGroups Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_pGroups Data Member

Parent groups collection

CXTPRibbonGroups* m_pGroups;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_pParent Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_pParent Data Member

Parent ribbon bar

CXTPCommandBar* m_pParent;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_pRibbonBar Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_pRibbonBar Data Member

Parent ribbon bar

CXTPRibbonBar* m_pRibbonBar;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_rcGroup Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_rcGroup Data Member

Bounding rectangle of the group

CRect m_rcGroup;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup::m_strCaption Data Member

CXTPRibbonGroup Data Members, CXTPRibbonGroup Class
CXTPRibbonGroup::m_strCaption Data Member

Caption of the group

CString m_strCaption;
Group

CXTPRibbonGroup Data Members


CXTPRibbonGroup Methods

CXTPRibbonGroup Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup Methods
Class

CXTPRibbonGroup Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetMinimumWidth | Calculates minimum width for the ribbon group
OnAfterCalcSize | This method is called after size of ribbon group was calculated
OnBeforeCalcSize | This method is called before calculate size of ribbon group
OnCalcDynamicSize | This method is called to find width of the ribbon group
OnExtendSize | This method is called to increase size of ribbon group
OnGroupAdded | This method is called when the group was added
OnGroupRemoved | This method is called when the group was removed
OnReduceSize | This method is called to decrease size of ribbon group
RepositionControls | Called automatically to reposition all controls in the group. For example, when the position/size of Ribbon Bar changes.
Public Methods
Public Methods
Public Method | Description
Add |
AllowReduce | Call this method to prevent group to be reduced to button
Copy | This method is called to copy parameter from one group to another
Draw | Draws the group and all of the controls in the group.
FindControl |
GetAt | Gets a CXTPControl object that has been added to the CXTPRibbonGroup at the specified index.
GetCaption | Gets the text displayed in the group title bar.
GetControlGroupOption | CXTPControl that represents the group's OptionButton (used to set tool tip and status bar text).
GetControlGroupPopup | Gets a pointer to the CXTPControlPopup that is used to display controls that are not currently visible in the group.
GetCount | Total number of CXTPControl objects that have been added to the CXTPRibbonGroup.
GetIconId | Call this member to get the icon's identifier. This is the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group.
GetID | Gets the group's Id.
GetIndex | Returns own index in parent group collection
GetParentTab | The CXTPRibbonTab object the CXTPRibbonGroup belongs to.
GetRect | Gets the bounding rectangle for the group.
GetRibbonBar | The CXTPRibbonBar object the CXTPRibbonGroup belongs to.
InsertAt | Adds a CXTPControl to the ribbon group.
IsControlsGrouping | Determines if control grouping is used.
IsHighlighted | Gets whether the group is currently highlighted.
IsOptionButtonVisible | Determines if option button is visible
IsReduced | Determines id the CXTPRibbonGroup is currently displayed as a group button.
IsVisible | Determines if group currently visible
LoadToolBar | Call this member function to load the toolbar specified by nIDResource.
Remove | Removes and item at the from collection of items.
RemoveAll | Removes all of the items from the group.
RemoveAt | Removes and item at the specified position in the group's collection of items.
SetButtons | Call this member to set the controls from the button array.
SetCaption | Sets the text to display in the group title bar.
SetControlsCentering | Call this method to automatically center controls in group
SetControlsGrouping | Call this method to group buttons in the group.
SetIconId | Call this member to set the group icon's identifier. This is the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group.
SetID | Call this method to set Identifier for group
SetRect | Sets the bounding rectangle for the group.
SetVisible | Call this method to show/hide the group
ShowOptionButton | Specifies whether to display an option button in the group caption.


Add Method

CXTPRibbonGroup Methods
Add Method
Overload List
Methods
Method | Description
CXTPRibbonGroup::Add (CXTPControl*, int, LPCTSTR, int, BOOL) | Adds a CXTPControl to the ribbon group.
CXTPRibbonGroup::Add (XTPControlType, int, LPCTSTR, int, BOOL) | Adds a CXTPControl to the ribbon group.
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::Add Method (XTPControlType, int, LPCTSTR, int, BOOL)

Add Method, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::Add Method (XTPControlType, int, LPCTSTR, int, BOOL)

Adds a CXTPControl to the ribbon group.

CXTPControl* Add(
    XTPControlType controlType,
    int nId,
    LPCTSTR lpszParameter = NULL,
    int nBefore = -1,
    BOOL bTemporary = FALSE
);
CXTPControl* Add(
    CXTPControl* pControl,
    int nId,
    LPCTSTR lpszParameter = NULL,
    int nBefore = -1,
    BOOL bTemporary = FALSE
);
Parameters

controlType
Type of control to add to the ribbon group.
nId
Identifier of the CXTPControl to be added.
lpszParameter
The caption of the CXTPControl to be added.
nBefore
The index of an existing control that the new control should will be inserted before.
bTemporary
A boolean value indicating whether the control is temporary. Temporary controls will not be saved to the system registry when the application is closed, and they will not be restored when the application is opened.
pControl
Pointer to a CXTPControl to add to the ribbon group.

Returns

Pointer to the CXTPControl object that was added to the ribbon group.

Remarks

The Add method allows CXTPControl objects to be added to the ribbon group.

See Also

CXTPControl, GetAt, GetCount, RemoveAt, RemoveAll

Group

Add Method


CXTPRibbonGroup::AllowReduce Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source
CXTPRibbonGroup::AllowReduce Method

Call this method to prevent group to be reduced to button

void AllowReduce(
    int nAllowReduceLevel = 0
);
Parameters

nAllowReduceLevel
Reduce Level to allow

Body Source
void CXTPRibbonGroup::AllowReduce(int nAllowReduce) {
    m_nAllowReduce = nAllowReduce;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::Copy Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class
CXTPRibbonGroup::Copy Method

This method is called to copy parameter from one group to another

virtual void Copy(
    CXTPRibbonGroup* pGroup
);
Parameters

pGroup
Group which parameter will be copied

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::Draw Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class
CXTPRibbonGroup::Draw Method

Draws the group and all of the controls in the group.

virtual void Draw(
    CDC* pDC,
    CRect rcClipBox
);
Parameters

pDC
Pointer to the device context in which to draw the group.
rcClipBox
The rectangular area of the window that is invalid.

Group

CXTPRibbonGroup Methods


FindControl Method

CXTPRibbonGroup Methods
FindControl Method
Overload List
Methods
Method | Description
CXTPRibbonGroup::FindControl (XTPControlType, int, BOOL, BOOL) | Call this member to find the specified control.
CXTPRibbonGroup::FindControl (int) | Call this member to find the specified control.
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::FindControl Method (int)

FindControl Method, CXTPRibbonGroup Class
CXTPRibbonGroup::FindControl Method (int)

Call this member to find the specified control.

CXTPControl* FindControl(
    int nId
) const;
Parameters

nId
The control's identifier.
type
The type of the control to find.
bVisible
TRUE if the control is visible.
bRecursive
TRUE to find in the nested command bars.

Returns

Pointer to the CXTPControl object if successful; otherwise returns NULL.

Group

FindControl Method


CXTPRibbonGroup::GetAt Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetAt Method

Gets a CXTPControl object that has been added to the CXTPRibbonGroup at the specified index.

CXTPControl* GetAt(
    int nIndex
) const;
Parameters

nIndex
Index of the items to retrieve within the group's collection of controls.

Returns

The CXTPControl at the specified index.

Remarks

GetAt retrieves the CXTPControl from the m_arrControls items collection that contains all of the CXTPControl objects that have been added to the CXTPRibbonGroup.

See Also

m_arrControls, Add, RemoveAt, RemoveAll

Body Source
CXTPControl* CXTPRibbonGroup::GetAt(int nIndex) const {
    return nIndex >= 0 && nIndex < GetCount() ? m_arrControls.GetAt(nIndex) : NULL;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetCaption Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetCaption Method

Gets the text displayed in the group title bar.

CString GetCaption() const;
Returns

Text displayed in the group title bar.

Remarks

The Caption is the text string that is displayed in the group's title bar. The Caption of the group is initially set when it is added or inserted.

See Also

SetCaption, CXTPRibbonGroups::AddGroup, CXTPRibbonGroups::InsertAt

Body Source
CString CXTPRibbonGroup::GetCaption() const {
    return m_strCaption;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetControlGroupOption Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetControlGroupOption Method

CXTPControl that represents the group's OptionButton (used to set tool tip and status bar text).

CXTPControl* GetControlGroupOption() const;
Returns

Pointer to the CXTPControl that represents the group's OptionButton.

Remarks

GetControlGroupOption is only used to set the TooltipText and DescriptionText for the OptionButton. No other propertiesmethods of the CXTPControl are used.

See Also

CXTPRibbonPaintManager::DrawControlGroupOption

Body Source
CXTPControl* CXTPRibbonGroup::GetControlGroupOption() const {
    return m_pControlGroupOption;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetControlGroupPopup Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetControlGroupPopup Method

Gets a pointer to the CXTPControlPopup that is used to display controls that are not currently visible in the group.

CXTPControlPopup* GetControlGroupPopup() const;
Returns

CXTPControlPopup that is used to display controls that are not currently visible in the group.

Remarks

A single group button will be displayed if there is not enough room to display the items in the group. A group popup is displayed when the button is clicked. The popup contains all the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group.

See Also

IsReduced, CXTPRibbonPaintManager::DrawControlGroupPopup

Body Source
CXTPControlPopup* CXTPRibbonGroup::GetControlGroupPopup() const {
    return m_pControlGroupPopup;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetCount Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetCount Method

Total number of CXTPControl objects that have been added to the CXTPRibbonGroup.

int GetCount() const;
Returns

Integer containing the total number of CXTPControl objects that have been added to the CXTPRibbonGroup.

Remarks

A CXTPRibbonGroup is used to hold one ore more CXTPControl objects. The total number of items can be found using GetCount.

See Also

CXTPRibbonGroup

Body Source
int CXTPRibbonGroup::GetCount() const {
    return (int)m_arrControls.GetSize();
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetIconId Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetIconId Method

Call this member to get the icon's identifier. This is the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group.

int GetIconId() const;
Returns

An icon's identifier of the group.

Remarks

The m_nIconId specifies the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group. No image will be displayed for the group button if IconId is not set.

See Also

IsReduced, SetIconId, GetControlGroupPopup

Body Source
int CXTPRibbonGroup::GetIconId() const {
    return m_nIconId <= 0 ? m_nId : m_nIconId;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetID Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetID Method

Gets the group's Id.

int GetID() const;
Returns

Integer containing the group's identifier.

Remarks

The Id is used to identify the group.

See Also

GetControlGroupPopup, GetControlGroupOption

Body Source
int CXTPRibbonGroup::GetID() const {
    return m_nId;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetIndex Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source
CXTPRibbonGroup::GetIndex Method

Returns own index in parent group collection

int GetIndex() const;
Body Source
int CXTPRibbonGroup::GetIndex() const {
    return m_nIndex;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetMinimumWidth Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::GetMinimumWidth Method

Calculates minimum width for the ribbon group

virtual int GetMinimumWidth(
    CDC* pDC
);
Parameters

pDC
Pointer to device context used to draw group

Returns

Minimum width of ribbon group

See Also

Draw

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetParentTab Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::GetParentTab Method

The CXTPRibbonTab object the CXTPRibbonGroup belongs to.

CXTPRibbonTab* GetParentTab() const;
Returns

A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to. This is the tab that the group is displayed in.

See Also

CXTPRibbonTab

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetRect Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetRect Method

Gets the bounding rectangle for the group.

CRect GetRect() const;
Returns

A CRect containing the bounding rectangle for the group.

Remarks

The rectangle is the size of the entire group, including the group caption and group popup if present.

See Also

SetRect

Body Source
CRect CXTPRibbonGroup::GetRect() const {
    return m_rcGroup;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::GetRibbonBar Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::GetRibbonBar Method

The CXTPRibbonBar object the CXTPRibbonGroup belongs to.

CXTPRibbonBar* GetRibbonBar() const;
Returns

A pointer to the CXTPRibbonBar object the CXTPRibbonGroup belongs to. This is the RibbonBar that the group is displayed in.

See Also

CXTPRibbonBar

Body Source
CXTPRibbonBar* CXTPRibbonGroup::GetRibbonBar() const {
    return (CXTPRibbonBar*)m_pRibbonBar;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::InsertAt Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::InsertAt Method

Adds a CXTPControl to the ribbon group.

CXTPControl* InsertAt(
    CXTPControl* pControl,
    int nBefore = -1
);
Parameters

pControl
Control to add
nBefore
The index of an existing control that the new control should will be inserted before.

Returns

Pointer to the CXTPControl object that was added to the ribbon group.

See Also

Add

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::IsControlsGrouping Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::IsControlsGrouping Method

Determines if control grouping is used.

BOOL IsControlsGrouping() const;
See Also

SetControlsGrouping

Body Source
BOOL CXTPRibbonGroup::IsControlsGrouping() const {
    return m_bControlsGrouping;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::IsHighlighted Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::IsHighlighted Method

Gets whether the group is currently highlighted.

BOOL IsHighlighted() const;
Returns

TRUE if the group is currently highlighted, FALSE otherwise.

Remarks

A group becomes highlighted when the mouse cursor is positioned over the group or any items in the group.

See Also

CXTPRibbonBar::GetHighlightedGroup

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::IsOptionButtonVisible Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::IsOptionButtonVisible Method

Determines if option button is visible

BOOL IsOptionButtonVisible() const;
See Also

ShowOptionButton

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::IsReduced Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::IsReduced Method

Determines id the CXTPRibbonGroup is currently displayed as a group button.

BOOL IsReduced() const;
Returns

TRUE if the group is displayed as a single group button, FALSE if the group is displayed normally.

Remarks

A single group button will be displayed if there is not enough room to display the items in the group. A group popup is displayed when the button is clicked. The popup contains all the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group.

The m_nIconId specifies the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group. No image will be displayed for the group button if m_nIconId is not set with SetIconId.

See Also

SetIconId, GetIconId, GetControlGroupPopup

Body Source
BOOL CXTPRibbonGroup::IsReduced() const {
    return m_bReduced;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::IsVisible Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::IsVisible Method

Determines if group currently visible

BOOL IsVisible() const;
See Also

SetVisible

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::LoadToolBar Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class
CXTPRibbonGroup::LoadToolBar Method

Call this member function to load the toolbar specified by nIDResource.

BOOL LoadToolBar(
    UINT nIDResource,
    BOOL bLoadIcons = TRUE
);
Parameters

nIDResource
Resource ID of the toolbar to be loaded.
bLoadIcons
TRUE to load icons from application resources.

Returns

Nonzero if successful; otherwise 0.

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::OnAfterCalcSize Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::OnAfterCalcSize Method

This method is called after size of ribbon group was calculated

virtual void OnAfterCalcSize();
See Also

OnBeforeCalcSize

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::OnBeforeCalcSize Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::OnBeforeCalcSize Method

This method is called before calculate size of ribbon group

virtual void OnBeforeCalcSize(
    CDC* pDC
);
Parameters

pDC
Pointer to device context used to draw group

See Also

OnAfterCalcSize

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::OnCalcDynamicSize Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::OnCalcDynamicSize Method

This method is called to find width of the ribbon group

virtual int OnCalcDynamicSize(
    CDC* pDC
);
Parameters

pDC
Pointer to device context used to draw group

Returns

Width of ribbon group

See Also

OnBeforeCalcSize, OnAfterCalcSize, GetMinimumWidth

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::OnExtendSize Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class
CXTPRibbonGroup::OnExtendSize Method

This method is called to increase size of ribbon group

virtual BOOL OnExtendSize(
    int nWidthAvail
);
Parameters

nWidthAvail
Total pixels need to increase

Returns

TRUE if group was increased

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::OnGroupAdded Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::OnGroupAdded Method

This method is called when the group was added

virtual void OnGroupAdded();
See Also

OnGroupRemoved

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::OnGroupRemoved Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::OnGroupRemoved Method

This method is called when the group was removed

virtual void OnGroupRemoved();
See Also

OnGroupAdded

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::OnReduceSize Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class
CXTPRibbonGroup::OnReduceSize Method

This method is called to decrease size of ribbon group

virtual BOOL OnReduceSize(
    int nLevel,
    int nWidthAvail
);
Parameters

nLevel
Reduce level
nWidthAvail
Total pixels need to reduce

Returns

TRUE if group was reduced

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::Remove Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::Remove Method

Removes and item at the from collection of items.

void Remove(
    CXTPControl* pControl
);
Parameters

pControl
The item to remove from the group's collection of items.

See Also

RemoveAt, Add, GetAt, RemoveAll

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::RemoveAll Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::RemoveAll Method

Removes all of the items from the group.

void RemoveAll();
See Also

m_arrControls, Add, GetAt, RemoveAt

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::RemoveAt Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::RemoveAt Method

Removes and item at the specified position in the group's collection of items.

void RemoveAt(
    int nIndex
);
Parameters

nIndex
Index of the item to remove from the group's collection of items.

Remarks

Removes an item by it's index from the group's collection of items.

See Also

m_arrControls, Add, GetAt, RemoveAll

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::RepositionControls Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class
CXTPRibbonGroup::RepositionControls Method

Called automatically to reposition all controls in the group. For example, when the position/size of Ribbon Bar changes.

virtual void RepositionControls(
    CDC* pDC
);
Parameters

pDC
Pointer to the device context in which to draw the group.

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::SetButtons Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::SetButtons Method

Call this member to set the controls from the button array.

BOOL SetButtons(
    UINT* pButtons,
    int nCount
);
Parameters

pButtons
Pointer to an array of command Ids. It cannot be NULL.
nCount
Number of elements in the array pointed to by pButtons.

Returns

Nonzero if successful; otherwise 0.

See Also

LoadToolBar

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::SetCaption Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::SetCaption Method

Sets the text to display in the group title bar.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
Text to display in the group title bar.

Remarks

The Caption is the text string that is displayed in the group's title bar. The Caption of the group is initially set when it is added or inserted.

See Also

GetCaption, CXTPRibbonGroups::AddGroup, CXTPRibbonGroups::InsertAt

Body Source
void CXTPRibbonGroup::SetCaption(LPCTSTR lpszCaption) {
    m_strCaption = lpszCaption;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::SetControlsCentering Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source
CXTPRibbonGroup::SetControlsCentering Method

Call this method to automatically center controls in group

void SetControlsCentering(
    BOOL bControlsCentering = TRUE
);
Parameters

bControlsCentering
TRUE to center controls in group

Body Source
void CXTPRibbonGroup::SetControlsCentering(BOOL bControlsCentering) {
    m_bControlsCentering = bControlsCentering;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::SetControlsGrouping Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::SetControlsGrouping Method

Call this method to group buttons in the group.

void SetControlsGrouping(
    BOOL bControlsGrouping = TRUE
);
Parameters

bControlsGrouping
TRUE to use grouping for buttons

See Also

IsControlsGrouping

Body Source
void CXTPRibbonGroup::SetControlsGrouping(BOOL bControlsGrouping) {
    m_bControlsGrouping = bControlsGrouping;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::SetIconId Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::SetIconId Method

Call this member to set the group icon's identifier. This is the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group.

void SetIconId(
    int nId
);
Parameters

nId
Icon's identifier to be set.

Remarks

The m_nIconId specifies the Id of the image to use for the group button that is displayed when there is not enough room to display the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group. No image will be displayed for the group button if IconId is not set.

See Also

IsReduced, GetIconId, GetControlGroupPopup

Body Source
void CXTPRibbonGroup::SetIconId(int nId) {
    m_nIconId = nId;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::SetID Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::SetID Method

Call this method to set Identifier for group

void SetID(
    int nId
);
Parameters

nId
The Id is used to identify the group.

See Also

GetID

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::SetRect Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::SetRect Method

Sets the bounding rectangle for the group.

virtual void SetRect(
    CRect rc
);
Parameters

rc
A CRect containing the bounding rectangle for the group.

Remarks

The rectangle is the size of the entire group, including the group caption and group popup if present.

See Also

GetRect

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::SetVisible Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, See Also
CXTPRibbonGroup::SetVisible Method

Call this method to show/hide the group

void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show group; FALSE to hide

See Also

IsVisible

Group

CXTPRibbonGroup Methods


CXTPRibbonGroup::ShowOptionButton Method

CXTPRibbonGroup Methods, CXTPRibbonGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroup::ShowOptionButton Method

Specifies whether to display an option button in the group caption.

void ShowOptionButton(
    BOOL bShowOptionButton = TRUE
);
Parameters

bShowOptionButton
TRUE to show an option button in the group's caption, FALSE to hide the option button if one was visible.

Remarks

The option button is typically used to launch a dialog associated with the group. The Group Id(GetID) is used to identify which group's option button was clicked.

See Also

m_bShowOptionButton, GetID, CXTPRibbonPaintManager::DrawControlGroupOption

Body Source
void CXTPRibbonGroup::ShowOptionButton(BOOL bShowOptionButton) {
    m_bShowOptionButton = bShowOptionButton;
}
Group

CXTPRibbonGroup Methods


CXTPRibbonGroup Constructors

CXTPRibbonGroup Class, Legend, Public Methods
CXTPRibbonGroup Constructors
Class

CXTPRibbonGroup Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonGroup | Constructs a CXTPRibbonGroup object


CXTPRibbonGroup::CXTPRibbonGroup Constructor

CXTPRibbonGroup Constructors, CXTPRibbonGroup Class
CXTPRibbonGroup::CXTPRibbonGroup Constructor

Constructs a CXTPRibbonGroup object

CXTPRibbonGroup();
Group

CXTPRibbonGroup Constructors


CXTPRibbonGroup Destructors

CXTPRibbonGroup Class, Legend, Public Methods
CXTPRibbonGroup Destructors
Class

CXTPRibbonGroup Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPRibbonGroup | Destroys a CXTPRibbonGroup object, handles cleanup and deallocation.


CXTPRibbonGroup::~CXTPRibbonGroup Destructor

CXTPRibbonGroup Destructors, CXTPRibbonGroup Class
CXTPRibbonGroup::~CXTPRibbonGroup Destructor

Destroys a CXTPRibbonGroup object, handles cleanup and deallocation.

virtual ~CXTPRibbonGroup();
Group

CXTPRibbonGroup Destructors


CXTPRibbonGroups Class

XTPRibbonGroups.h, Classes, Legend, Members, Topics, CXTPRibbonGroups Data Members, CXTPRibbonGroups Methods, CXTPRibbonGroups Constructors, CXTPRibbonGroups Destructors, CXTPRibbonGroups Constructors, CXTPRibbonGroups Data Members, CXTPRibbonGroups Destructors, CXTPRibbonGroups Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroups Class

Represents a collection of CXTPRibbonGroup objects.

Class Hierarchy

class CXTPRibbonGroups;
File

XTPRibbonGroups.h

Remarks

A CXTPRibbonTab uses the CXTPRibbonGroups object for its Groups Collection to store all of the RibbonGroup objects that have been added to the RibbonTab. A CXTPRibbonGroup is used to hold items such as buttons, popups, edit controls, etc.

Groups are added to the Groups Collection using the Add and InsertAt methods.

See Also

Add, InsertAt

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPRibbonGroups Constructors
CXTPRibbonGroups Constructors | Description
CXTPRibbonGroups | Constructs a CXTPRibbonGroups object
CXTPRibbonGroups Data Members
CXTPRibbonGroups Data Members | Description
m_arrGroups | Collection of groups.
m_nGroupsScrollPos | Scroll position
m_pParentTab | A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to.
CXTPRibbonGroups Destructors
CXTPRibbonGroups Destructors | Description
~CXTPRibbonGroups | Destroys a CXTPRibbonGroups object, handles cleanup and deallocation.
CXTPRibbonGroups Methods
CXTPRibbonGroups Methods | Description
Add | Adds a CXTPRibbonGroup to a CXTPRibbonTab.
CalcDynamicSize | This method is called internally to reposition groups and controls.
Copy | Copies all groups
GetAt | Gets a CXTPRibbonGroup object that has been added to the CXTPRibbonTab at the specified index.
GetCount | Total number of CXTPRibbonGroup objects that have been added to a CXTPRibbonTab.
GetParentTab | The CXTPRibbonTab object the CXTPRibbonGroup belongs to.
GetRibbonBar | The CXTPRibbonBar object the CXTPRibbonGroup belongs to.
GetScrollPos | Call this method to get group scroll position
HitTest | This member function determines which ribbon group, if any, is at a specified position.
InsertAt |
Remove | Removes the group at the specified index.
RemoveAll | Removes all groups.


CXTPRibbonGroups Data Members

CXTPRibbonGroups Class, Legend, Protected Data Members
CXTPRibbonGroups Data Members
Class

CXTPRibbonGroups Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrGroups | Collection of groups.
m_nGroupsScrollPos | Scroll position
m_pParentTab | A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to.


CXTPRibbonGroups::m_arrGroups Data Member

CXTPRibbonGroups Data Members, CXTPRibbonGroups Class
CXTPRibbonGroups::m_arrGroups Data Member

Collection of groups.

CArray<CXTPRibbonGroup*, CXTPRibbonGroup*> m_arrGroups;
Group

CXTPRibbonGroups Data Members


CXTPRibbonGroups::m_nGroupsScrollPos Data Member

CXTPRibbonGroups Data Members, CXTPRibbonGroups Class
CXTPRibbonGroups::m_nGroupsScrollPos Data Member

Scroll position

int m_nGroupsScrollPos;
Group

CXTPRibbonGroups Data Members


CXTPRibbonGroups::m_pParentTab Data Member

CXTPRibbonGroups Data Members, CXTPRibbonGroups Class
CXTPRibbonGroups::m_pParentTab Data Member

A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to.

CXTPRibbonTab* m_pParentTab;
Group

CXTPRibbonGroups Data Members


CXTPRibbonGroups Methods

CXTPRibbonGroups Class, Legend, Public Methods
CXTPRibbonGroups Methods
Class

CXTPRibbonGroups Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add | Adds a CXTPRibbonGroup to a CXTPRibbonTab.
CalcDynamicSize | This method is called internally to reposition groups and controls.
Copy | Copies all groups
GetAt | Gets a CXTPRibbonGroup object that has been added to the CXTPRibbonTab at the specified index.
GetCount | Total number of CXTPRibbonGroup objects that have been added to a CXTPRibbonTab.
GetParentTab | The CXTPRibbonTab object the CXTPRibbonGroup belongs to.
GetRibbonBar | The CXTPRibbonBar object the CXTPRibbonGroup belongs to.
GetScrollPos | Call this method to get group scroll position
HitTest | This member function determines which ribbon group, if any, is at a specified position.
InsertAt |
Remove | Removes the group at the specified index.
RemoveAll | Removes all groups.


CXTPRibbonGroups::Add Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, See Also
CXTPRibbonGroups::Add Method

Adds a CXTPRibbonGroup to a CXTPRibbonTab.

CXTPRibbonGroup* Add(
    LPCTSTR lpszCaption,
    int nId = -1
);
Parameters

lpszCaption
Text to display in the group title bar. This is the group's caption.
nId
Identifier of new group

Returns

Pointer to the CXTPRibbonGroup object added to the CXTPRibbonTab Groups Collection.

Remarks

Tabs in the Ribbon Bar contain one or more CXTPRibbonGroup objects. Buttons, Popups, etc can then be added to the groups.

See Also

InsertAt, Remove, GetCount, GetAt, RemoveAll

Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::CalcDynamicSize Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, See Also
CXTPRibbonGroups::CalcDynamicSize Method

This method is called internally to reposition groups and controls.

void CalcDynamicSize(
    CDC* pDC,
    int nLength,
    DWORD dwMode,
    const CRect& rcBorder
);
Parameters

pDC
Pointer to a valid device context
nLength
Length of the parent bar.
dwMode
Mode of the parent bar.
rcBorder
Border to be set.

See Also

CXTPRibbonBar::RepositionGroups

Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::Copy Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class
CXTPRibbonGroups::Copy Method

Copies all groups

void Copy(
    CXTPRibbonGroups* pGroups
);
Parameters

pGroups
Groups to copy from

Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::GetAt Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroups::GetAt Method

Gets a CXTPRibbonGroup object that has been added to the CXTPRibbonTab at the specified index.

CXTPRibbonGroup* GetAt(
    int nIndex
) const;
Parameters

nIndex
Index of the group to retrieve within the collection of groups.

Returns

The CXTPRibbonGroup at the specified index.

Remarks

GetAt retrieves the CXTPRibbonGroup from the m_arrGroups groups collection that contains all of the CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.

See Also

InsertAt, Remove, GetCount, Add, RemoveAll

Body Source
CXTPRibbonGroup* CXTPRibbonGroups::GetAt(int nIndex) const {
    ASSERT(nIndex < m_arrGroups.GetSize());
    return (nIndex >= 0 && nIndex < m_arrGroups.GetSize()) ? m_arrGroups.GetAt(nIndex) : NULL;
}
Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::GetCount Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroups::GetCount Method

Total number of CXTPRibbonGroup objects that have been added to a CXTPRibbonTab.

int GetCount() const;
Returns

Integer containing the total number of CXTPRibbonGroup objects that have been added to a CXTPRibbonTab.

See Also

InsertAt, Remove, Add, GetAt, RemoveAll

Body Source
int CXTPRibbonGroups::GetCount() const {
    return (int)m_arrGroups.GetSize();
}
Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::GetParentTab Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroups::GetParentTab Method

The CXTPRibbonTab object the CXTPRibbonGroup belongs to.

CXTPRibbonTab* GetParentTab() const;
Returns

A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to. This is the tab that the group is displayed in.

See Also

CXTPRibbonTab

Body Source
CXTPRibbonTab* CXTPRibbonGroups::GetParentTab() const {
    return  m_pParentTab;
}
Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::GetRibbonBar Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, See Also
CXTPRibbonGroups::GetRibbonBar Method

The CXTPRibbonBar object the CXTPRibbonGroup belongs to.

CXTPRibbonBar* GetRibbonBar() const;
Returns

A pointer to the CXTPRibbonBar object the CXTPRibbonGroup belongs to. This is the RibbonBar that the group is displayed in.

See Also

CXTPRibbonBar

Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::GetScrollPos Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonGroups::GetScrollPos Method

Call this method to get group scroll position

int GetScrollPos() const;
Returns

Position of scroll offset

Body Source
int CXTPRibbonGroups::GetScrollPos() const {
    return m_nGroupsScrollPos;
}
Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::HitTest Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class
CXTPRibbonGroups::HitTest Method

This member function determines which ribbon group, if any, is at a specified position.

CXTPRibbonGroup* HitTest(
    CPoint point
) const;
Parameters

point
A CPoint that contains the coordinates of the point to test.

Returns

The CXTPRibbonGroup that is at the specified point, if no group is at the point, then NULL is returned.

Group

CXTPRibbonGroups Methods


InsertAt Method

CXTPRibbonGroups Methods
InsertAt Method
Overload List
Methods
Method | Description
CXTPRibbonGroups::InsertAt (int, CXTPRibbonGroup*) | Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.
CXTPRibbonGroups::InsertAt (int, LPCTSTR, int) | Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.
Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::InsertAt Method (int, LPCTSTR, int)

InsertAt Method, CXTPRibbonGroups Class, See Also
CXTPRibbonGroups::InsertAt Method (int, LPCTSTR, int)

Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.

CXTPRibbonGroup* InsertAt(
    int nIndex,
    LPCTSTR lpszCaption,
    int nId = -1
);
CXTPRibbonGroup* InsertAt(
    int nIndex,
    CXTPRibbonGroup* pGroup
);
Parameters

nIndex
Position within the tab's Groups Collection to insert the new CXTPRibbonGroup.
lpszCaption
Text to display in the group title bar. This in the group's caption.
nId
Identifier of new group
pGroup
New group to insert

Returns

Pointer to the CXTPRibbonGroup object added to the CXTPRibbonTab Groups Collection.

Remarks

InsertAt adds a group at a specific location within the tab's Groups Collection. Groups will be displayed in the order they are added. This means the group with an Index of zero (0) will be displayed first to the far left, then to the immediate right will be the group with an Index of one (1), etc...

See Also

Add, Remove, GetCount, GetAt, RemoveAll

Group

InsertAt Method


CXTPRibbonGroups::Remove Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, See Also
CXTPRibbonGroups::Remove Method

Removes the group at the specified index.

void Remove(
    int nIndex
);
Parameters

nIndex
Index of the group to be removed.

See Also

InsertAt, Add, GetCount, GetAt, RemoveAll

Group

CXTPRibbonGroups Methods


CXTPRibbonGroups::RemoveAll Method

CXTPRibbonGroups Methods, CXTPRibbonGroups Class, See Also
CXTPRibbonGroups::RemoveAll Method

Removes all groups.

void RemoveAll();
See Also

InsertAt, Remove, GetCount, GetAt, Add

Group

CXTPRibbonGroups Methods


CXTPRibbonGroups Constructors

CXTPRibbonGroups Class, Legend, Public Methods
CXTPRibbonGroups Constructors
Class

CXTPRibbonGroups Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonGroups | Constructs a CXTPRibbonGroups object


CXTPRibbonGroups::CXTPRibbonGroups Constructor

CXTPRibbonGroups Constructors, CXTPRibbonGroups Class
CXTPRibbonGroups::CXTPRibbonGroups Constructor

Constructs a CXTPRibbonGroups object

CXTPRibbonGroups();
Group

CXTPRibbonGroups Constructors


CXTPRibbonGroups Destructors

CXTPRibbonGroups Class, Legend, Public Methods
CXTPRibbonGroups Destructors
Class

CXTPRibbonGroups Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPRibbonGroups | Destroys a CXTPRibbonGroups object, handles cleanup and deallocation.


CXTPRibbonGroups::~CXTPRibbonGroups Destructor

CXTPRibbonGroups Destructors, CXTPRibbonGroups Class
CXTPRibbonGroups::~CXTPRibbonGroups Destructor

Destroys a CXTPRibbonGroups object, handles cleanup and deallocation.

virtual ~CXTPRibbonGroups();
Group

CXTPRibbonGroups Destructors


CXTPRibbonQuickAccessControls Class

XTPRibbonQuickAccessControls.h, Classes, Legend, Members, Topics, CXTPRibbonQuickAccessControls Methods, CXTPRibbonQuickAccessControls Constructors, CXTPRibbonQuickAccessControls Destructors, CXTPRibbonQuickAccessControls Constructors, CXTPRibbonQuickAccessControls Destructors, CXTPRibbonQuickAccessControls Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls Class

CXTPRibbonQuickAccessControls is a CXTPControls derived class. It represents a collection of the controls for quick access controls for Ribbon Bar.

Class Hierarchy

class CXTPRibbonQuickAccessControls : public CXTPControls;
File

XTPRibbonQuickAccessControls.h

Group

Classes

Legend
Method
protected
virtual
CXTPRibbonQuickAccessControls Constructors
CXTPRibbonQuickAccessControls Constructors | Description
CXTPRibbonQuickAccessControls | Constructs a CXTPRibbonQuickAccessControls object
CXTPRibbonQuickAccessControls Destructors
CXTPRibbonQuickAccessControls Destructors | Description
~CXTPRibbonQuickAccessControls | Destroys a CXTPRibbonQuickAccessControls object, handles cleanup and deallocation
CXTPRibbonQuickAccessControls Methods
CXTPRibbonQuickAccessControls Methods | Description
FindDuplicate | Call this method to find Duplicate control
OnControlAdded | This method is called when control is added to collection
OnControlRemoved | This method is called when control is removed from collection
Remove | Call this member to remove a control.
Reset | Call this method to reset quick access controls


CXTPRibbonQuickAccessControls Methods

CXTPRibbonQuickAccessControls Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls Methods
Class

CXTPRibbonQuickAccessControls Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnControlAdded | This method is called when control is added to collection
OnControlRemoved | This method is called when control is removed from collection
Public Methods
Public Methods
Public Method | Description
FindDuplicate | Call this method to find Duplicate control
Remove | Call this member to remove a control.
Reset | Call this method to reset quick access controls


CXTPRibbonQuickAccessControls::FindDuplicate Method

CXTPRibbonQuickAccessControls Methods, CXTPRibbonQuickAccessControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls::FindDuplicate Method

Call this method to find Duplicate control

CXTPControl* FindDuplicate(
    CXTPControl* pControl
);
Parameters

pControl
Control to find

Returns

Pointer to Duplicate control.

Group

CXTPRibbonQuickAccessControls Methods


CXTPRibbonQuickAccessControls::OnControlAdded Method

CXTPRibbonQuickAccessControls Methods, CXTPRibbonQuickAccessControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls::OnControlAdded Method

This method is called when control is added to collection

virtual void OnControlAdded(
    CXTPControl* pControl
);
Parameters

pControl
control that added to collection

Group

CXTPRibbonQuickAccessControls Methods


CXTPRibbonQuickAccessControls::OnControlRemoved Method

CXTPRibbonQuickAccessControls Methods, CXTPRibbonQuickAccessControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls::OnControlRemoved Method

This method is called when control is removed from collection

virtual void OnControlRemoved(
    CXTPControl* pControl
);
Parameters

pControl
control that removed from collection

Group

CXTPRibbonQuickAccessControls Methods


CXTPRibbonQuickAccessControls::Remove Method

CXTPRibbonQuickAccessControls Methods, CXTPRibbonQuickAccessControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls::Remove Method

Call this member to remove a control.

void Remove(
    CXTPControl* pControl
);
Parameters

pControl
Control to be removed.

Group

CXTPRibbonQuickAccessControls Methods


CXTPRibbonQuickAccessControls::Reset Method

CXTPRibbonQuickAccessControls Methods, CXTPRibbonQuickAccessControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls::Reset Method

Call this method to reset quick access controls

void Reset();
Group

CXTPRibbonQuickAccessControls Methods


CXTPRibbonQuickAccessControls Constructors

CXTPRibbonQuickAccessControls Class, Legend, Public Methods
CXTPRibbonQuickAccessControls Constructors
Class

CXTPRibbonQuickAccessControls Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonQuickAccessControls | Constructs a CXTPRibbonQuickAccessControls object


CXTPRibbonQuickAccessControls::CXTPRibbonQuickAccessControls Constructor

CXTPRibbonQuickAccessControls Constructors, CXTPRibbonQuickAccessControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls::CXTPRibbonQuickAccessControls Constructor

Constructs a CXTPRibbonQuickAccessControls object

CXTPRibbonQuickAccessControls();
Group

CXTPRibbonQuickAccessControls Constructors


CXTPRibbonQuickAccessControls Destructors

CXTPRibbonQuickAccessControls Class, Legend, Public Methods
CXTPRibbonQuickAccessControls Destructors
Class

CXTPRibbonQuickAccessControls Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPRibbonQuickAccessControls | Destroys a CXTPRibbonQuickAccessControls object, handles cleanup and deallocation


CXTPRibbonQuickAccessControls::~CXTPRibbonQuickAccessControls Destructor

CXTPRibbonQuickAccessControls Destructors, CXTPRibbonQuickAccessControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonQuickAccessControls::~CXTPRibbonQuickAccessControls Destructor

Destroys a CXTPRibbonQuickAccessControls object, handles cleanup and deallocation

virtual ~CXTPRibbonQuickAccessControls();
Group

CXTPRibbonQuickAccessControls Destructors


CXTPRibbonTab Class

XTPRibbonTab.h, Classes, Legend, Members, Topics, CXTPRibbonTab Data Members, CXTPRibbonTab Methods, CXTPRibbonTab Constructors, CXTPRibbonTab Destructors, CXTPRibbonTab Constructors, CXTPRibbonTab Data Members, CXTPRibbonTab Destructors, CXTPRibbonTab Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab Class

Represents a tab in the Ribbon Bar.

Class Hierarchy

class CXTPRibbonTab : public CXTPTabManagerItem;
File

XTPRibbonTab.h

Remarks

Tabs in the Ribbon Bar are used to display different groups of items. The CXTPRibbonBar.InsertTab method adds a new CXTPRibbonTab object to the tabs collection of the Ribbon Bar.

Tabs in the Ribbon Bar contain one or more CXTPRibbonGroup objects. Buttons, Popups, etc can then be added to the groups.

The CXTPRibbonBar::GetTabCount property can be used to determine the total number of tabs that have been added.

See Also

CXTPRibbonBar.InsertTab, CXTPRibbonBar::GetTabCount, CXTPRibbonBar::GetTab

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPRibbonTab Constructors
CXTPRibbonTab Constructors | Description
CXTPRibbonTab | Constructs a CXTPRibbonTab object
CXTPRibbonTab Data Members
CXTPRibbonTab Data Members | Description
m_nContextColor | Context color
m_nId | Identifier of the tab.
m_pContextHeader | Context header
m_pGroups | Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
m_pRibbonBar | The CXTPRibbonBar object the CXTPRibbonTab belongs to.
m_strContextCaption | Context caption
CXTPRibbonTab Destructors
CXTPRibbonTab Destructors | Description
~CXTPRibbonTab | Destroys a CXTPRibbonTab object, handles cleanup and deallocation.
CXTPRibbonTab Methods
CXTPRibbonTab Methods | Description
AddGroup |
Copy | This method is called to copy the tab.
FindGroup | Call this method to find group by its identifier
GetContextCaption | Call this method to get context tab header text
GetContextColor | Call this method to get tab color
GetContextHeader | Retrieve CXTPRibbonTabContextHeader pointer associated with the tab
GetGroups | Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
GetID | Gets the tab's Id.
GetParent | Call this member to get the parent command bar.
GetRibbonBar | The CXTPRibbonBar object the CXTPRibbonTab belongs to.
OnRemoved | This method is called before removing tab from Ribbon Tabs collection
SetContextCaption | Call this method to set context tab header text
SetContextColor | Call this method to set tab color
SetContextTab |
SetID | Call this method to set Identifier for the tab
SetVisible | Call this member to hide or show the tab.


CXTPRibbonTab Data Members

CXTPRibbonTab Class, Legend, Protected Data Members
CXTPRibbonTab Data Members
Class

CXTPRibbonTab Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nContextColor | Context color
m_nId | Identifier of the tab.
m_pContextHeader | Context header
m_pGroups | Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
m_pRibbonBar | The CXTPRibbonBar object the CXTPRibbonTab belongs to.
m_strContextCaption | Context caption


CXTPRibbonTab::m_nContextColor Data Member

CXTPRibbonTab Data Members, CXTPRibbonTab Class
CXTPRibbonTab::m_nContextColor Data Member

Context color

XTPRibbonTabContextColor m_nContextColor;
Group

CXTPRibbonTab Data Members


CXTPRibbonTab::m_nId Data Member

CXTPRibbonTab Data Members, CXTPRibbonTab Class
CXTPRibbonTab::m_nId Data Member

Identifier of the tab.

int m_nId;
Group

CXTPRibbonTab Data Members


CXTPRibbonTab::m_pContextHeader Data Member

CXTPRibbonTab Data Members, CXTPRibbonTab Class
CXTPRibbonTab::m_pContextHeader Data Member

Context header

CXTPRibbonTabContextHeader* m_pContextHeader;
Group

CXTPRibbonTab Data Members


CXTPRibbonTab::m_pGroups Data Member

CXTPRibbonTab Data Members, CXTPRibbonTab Class
CXTPRibbonTab::m_pGroups Data Member

Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.

CXTPRibbonGroups* m_pGroups;
Group

CXTPRibbonTab Data Members


CXTPRibbonTab::m_pRibbonBar Data Member

CXTPRibbonTab Data Members, CXTPRibbonTab Class
CXTPRibbonTab::m_pRibbonBar Data Member

The CXTPRibbonBar object the CXTPRibbonTab belongs to.

CXTPRibbonBar* m_pRibbonBar;
Group

CXTPRibbonTab Data Members


CXTPRibbonTab::m_strContextCaption Data Member

CXTPRibbonTab Data Members, CXTPRibbonTab Class
CXTPRibbonTab::m_strContextCaption Data Member

Context caption

CString m_strContextCaption;
Group

CXTPRibbonTab Data Members


CXTPRibbonTab Methods

CXTPRibbonTab Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab Methods
Class

CXTPRibbonTab Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnRemoved | This method is called before removing tab from Ribbon Tabs collection
Public Methods
Public Methods
Public Method | Description
AddGroup |
Copy | This method is called to copy the tab.
FindGroup | Call this method to find group by its identifier
GetContextCaption | Call this method to get context tab header text
GetContextColor | Call this method to get tab color
GetContextHeader | Retrieve CXTPRibbonTabContextHeader pointer associated with the tab
GetGroups | Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
GetID | Gets the tab's Id.
GetParent | Call this member to get the parent command bar.
GetRibbonBar | The CXTPRibbonBar object the CXTPRibbonTab belongs to.
SetContextCaption | Call this method to set context tab header text
SetContextColor | Call this method to set tab color
SetContextTab |
SetID | Call this method to set Identifier for the tab
SetVisible | Call this member to hide or show the tab.


AddGroup Method

CXTPRibbonTab Methods
AddGroup Method
Overload List
Methods
Method | Description
CXTPRibbonTab::AddGroup (LPCTSTR) | Adds a CXTPRibbonGroup to a CXTPRibbonTab.
CXTPRibbonTab::AddGroup (int) | Adds a CXTPRibbonGroup to a CXTPRibbonTab.
Group

CXTPRibbonTab Methods


CXTPRibbonTab::AddGroup Method (LPCTSTR)

AddGroup Method, CXTPRibbonTab Class, See Also
CXTPRibbonTab::AddGroup Method (LPCTSTR)

Adds a CXTPRibbonGroup to a CXTPRibbonTab.

CXTPRibbonGroup* AddGroup(
    LPCTSTR lpszCaption
);
CXTPRibbonGroup* AddGroup(
    int nID
);
Parameters

lpszCaption
Text to display in the group's title bar. This in the group's caption.
nID
Identifier of group

Returns

Reference to the CXTPRibbonGroup object added to the CXTPRibbonTab's Groups Collection (CXTPRibbonTab::GetGroups).

See Also

CXTPRibbonGroup::SetCaption, CXTPRibbonGroup::SetCaption, CXTPRibbonTab, CXTPRibbonTab::GetGroups

Group

AddGroup Method


CXTPRibbonTab::Copy Method

CXTPRibbonTab Methods, CXTPRibbonTab Class
CXTPRibbonTab::Copy Method

This method is called to copy the tab.

virtual void Copy(
    CXTPRibbonTab* pRibbonTab
);
Parameters

pRibbonTab
Points to a source CXTPRibbonTab object

Group

CXTPRibbonTab Methods


CXTPRibbonTab::FindGroup Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, See Also
CXTPRibbonTab::FindGroup Method

Call this method to find group by its identifier

CXTPRibbonGroup* FindGroup(
    int nId
) const;
Parameters

nId
Identifier of group to be found

Returns

Pointer to CXTPRibbonGroup object with specified identifier

See Also

FindTab

Group

CXTPRibbonTab Methods


CXTPRibbonTab::GetContextCaption Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::GetContextCaption Method

Call this method to get context tab header text

CString GetContextCaption() const;
Returns

Context header text

See Also

SetContextCaption, SetContextColor

Body Source
CString CXTPRibbonTab::GetContextCaption() const {
    return m_strContextCaption;
}
Group

CXTPRibbonTab Methods


CXTPRibbonTab::GetContextColor Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::GetContextColor Method

Call this method to get tab color

XTPRibbonTabContextColor GetContextColor() const;
Returns

XTPRibbonTabContextColor enumerator.

See Also

XTPRibbonTabContextColor

Body Source
XTPRibbonTabContextColor CXTPRibbonTab::GetContextColor() const {
    return m_nContextColor;
}
Group

CXTPRibbonTab Methods


CXTPRibbonTab::GetContextHeader Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::GetContextHeader Method

Retrieve CXTPRibbonTabContextHeader pointer associated with the tab

CXTPRibbonTabContextHeader* GetContextHeader() const;
Parameters

nId
The Id is used to identify the tab.

See Also

GetID

Body Source
CXTPRibbonTabContextHeader* CXTPRibbonTab::GetContextHeader() const {
    return m_pContextHeader;
}
Group

CXTPRibbonTab Methods


CXTPRibbonTab::GetGroups Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::GetGroups Method

Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.

CXTPRibbonGroups* GetGroups() const;
Returns

Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab

Remarks

A CXTPRibbonGroup is used to hold buttons, popups, edit controls, combo box controls, etc. The group organizes the different types of controls in a CXTPRibbonTab so it is easy to see what functionality the controls should perform. Groups are added to the Group collection using the AddGroup and InsertGroup methods. Groups are displayed in the order they are added. This means the group with an Index of zero (0) will be displayed first to the far left, then to the immediate right will be the group with an Index of one (1), etc...

See Also

CXTPRibbonGroups::GetAt, CXTPRibbonGroups::InsertAt, CXTPRibbonGroups::Add, CXTPRibbonGroups.GetCount

Body Source
CXTPRibbonGroups* CXTPRibbonTab::GetGroups() const {
    return m_pGroups;
}
Group

CXTPRibbonTab Methods


CXTPRibbonTab::GetID Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::GetID Method

Gets the tab's Id.

int GetID() const;
Returns

Integer containing the tab's identifier.

Remarks

The Id is used to identify the tab.

See Also

SetID

Body Source
int CXTPRibbonTab::GetID() const {
    return m_nId;
}
Group

CXTPRibbonTab Methods


CXTPRibbonTab::GetParent Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source
CXTPRibbonTab::GetParent Method

Call this member to get the parent command bar.

CXTPCommandBar* GetParent() const;
Returns

The parent command bar object.

Body Source
CXTPCommandBar* CXTPRibbonTab::GetParent() const {
    return m_pParent;
}
Group

CXTPRibbonTab Methods


CXTPRibbonTab::GetRibbonBar Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, See Also
CXTPRibbonTab::GetRibbonBar Method

The CXTPRibbonBar object the CXTPRibbonTab belongs to.

CXTPRibbonBar* GetRibbonBar() const;
Returns

A pointer to the CXTPRibbonBar object the CXTPRibbonTab belongs to. This is the RibbonBar that the tab is displayed in.

See Also

CXTPRibbonBar

Group

CXTPRibbonTab Methods


CXTPRibbonTab::OnRemoved Method

CXTPRibbonTab Methods, CXTPRibbonTab Class
CXTPRibbonTab::OnRemoved Method

This method is called before removing tab from Ribbon Tabs collection

void OnRemoved();
Group

CXTPRibbonTab Methods


CXTPRibbonTab::SetContextCaption Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::SetContextCaption Method

Call this method to set context tab header text

void SetContextCaption(
    LPCTSTR lpszContextCaption
);
Parameters

lpszContextCaption
new text to be set

See Also

GetContextCaption

Body Source
void CXTPRibbonTab::SetContextCaption(LPCTSTR lpszContextCaption) {
    m_strContextCaption = lpszContextCaption;
}
Group

CXTPRibbonTab Methods


CXTPRibbonTab::SetContextColor Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::SetContextColor Method

Call this method to set tab color

void SetContextColor(
    XTPRibbonTabContextColor color
);
Parameters

color
XTPRibbonTabContextColor enumerator.

See Also

XTPRibbonTabContextColor

Body Source
void CXTPRibbonTab::SetContextColor(XTPRibbonTabContextColor color) {
    m_nContextColor = color;
}
Group

CXTPRibbonTab Methods


SetContextTab Method

CXTPRibbonTab Methods
SetContextTab Method
Overload List
Methods
Method | Description
CXTPRibbonTab::SetContextTab (XTPRibbonTabContextColor, LPCTSTR) | Call this method to set context tab color and text
CXTPRibbonTab::SetContextTab (XTPRibbonTabContextColor, int) | Call this method to set context tab color and text
Group

CXTPRibbonTab Methods


CXTPRibbonTab::SetContextTab Method (XTPRibbonTabContextColor, int)

SetContextTab Method, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::SetContextTab Method (XTPRibbonTabContextColor, int)

Call this method to set context tab color and text

void SetContextTab(
    XTPRibbonTabContextColor color,
    int nContextID
);
void SetContextTab(
    XTPRibbonTabContextColor color,
    LPCTSTR lpszContextCaption = NULL
);
Parameters

color
Color to be set
nContextID
Caption string identifier
lpszContextCaption
Caption string

See Also

GetContextCaption, GetContextColor

Body Source
void CXTPRibbonTab::SetContextTab(XTPRibbonTabContextColor color, int nID) {
    m_nContextColor = color;
    if (nID != 0) VERIFY(m_strContextCaption.LoadString(nID));
}

void CXTPRibbonTab::SetContextTab(XTPRibbonTabContextColor color, LPCTSTR lpszContextCaption) {
    m_nContextColor = color;
    m_strContextCaption = lpszContextCaption;
}
Group

SetContextTab Method


CXTPRibbonTab::SetID Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTab::SetID Method

Call this method to set Identifier for the tab

void SetID(
    int nId
);
Parameters

nId
The Id is used to identify the tab.

See Also

GetID

Body Source
void CXTPRibbonTab::SetID(int nID) {
    m_nId = nID;
}
Group

CXTPRibbonTab Methods


CXTPRibbonTab::SetVisible Method

CXTPRibbonTab Methods, CXTPRibbonTab Class, See Also
CXTPRibbonTab::SetVisible Method

Call this member to hide or show the tab.

virtual void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show the tab, FALSE to hide the tab.

See Also

IsVisible

Group

CXTPRibbonTab Methods


CXTPRibbonTab Constructors

CXTPRibbonTab Class, Legend, Public Methods
CXTPRibbonTab Constructors
Class

CXTPRibbonTab Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonTab | Constructs a CXTPRibbonTab object


CXTPRibbonTab::CXTPRibbonTab Constructor

CXTPRibbonTab Constructors, CXTPRibbonTab Class
CXTPRibbonTab::CXTPRibbonTab Constructor

Constructs a CXTPRibbonTab object

CXTPRibbonTab();
Group

CXTPRibbonTab Constructors


CXTPRibbonTab Destructors

CXTPRibbonTab Class, Legend, Public Methods
CXTPRibbonTab Destructors
Class

CXTPRibbonTab Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPRibbonTab | Destroys a CXTPRibbonTab object, handles cleanup and deallocation.


CXTPRibbonTab::~CXTPRibbonTab Destructor

CXTPRibbonTab Destructors, CXTPRibbonTab Class
CXTPRibbonTab::~CXTPRibbonTab Destructor

Destroys a CXTPRibbonTab object, handles cleanup and deallocation.

virtual ~CXTPRibbonTab();
Group

CXTPRibbonTab Destructors


CXTPRibbonTheme Class

XTPRibbonTheme.h, Classes, Legend, Members, Topics, CXTPRibbonTheme Data Members, CXTPRibbonTheme Methods, CXTPRibbonTheme Constructors, CXTPRibbonTheme Destructors, CXTPRibbonTheme Constructors, CXTPRibbonTheme Data Members, CXTPRibbonTheme Destructors, CXTPRibbonTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTheme Class

Standalone class used by the CXTPRibbonBar as a paint manager.

Class Hierarchy

class CXTPRibbonTheme : public CXTPOffice2007Theme;
File

XTPRibbonTheme.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPRibbonTheme Constructors
CXTPRibbonTheme Constructors | Description
CXTPRibbonTheme | Constructs a CXTPRibbonTheme object
CXTPRibbonTheme Data Members
CXTPRibbonTheme Data Members | Description
m_bHotTrackingGroups | TRUE to highlight group under cursor
m_clrControlEditNormal | Edit control color
m_clrMinimizedFrameEdgeHighLight | Minimzed bottom edge
m_clrMinimizedFrameEdgeShadow | Minimzed bottom edge shadow
m_clrRibbonFace | Ribbon face color
m_clrRibbonGroupCaptionText | Ribbon group captions color
m_clrRibbonText | Ribbon text color
m_fontGroupCaption | Font used to draw text in the group caption
m_nFontHeight | Ribbon font height
m_nGroupCaptionHeight | Group caption bar height
m_nTabsHeight | Tabs heights
m_pTabPaintManager | Tab paint manager
CXTPRibbonTheme Destructors
CXTPRibbonTheme Destructors | Description
~CXTPRibbonTheme | Destroys a CXTPRibbonTheme object, handles cleanup and deallocation
CXTPRibbonTheme Methods
CXTPRibbonTheme Methods | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
BaseTheme | Retrieves the base theme of the manager.
CreateTabPaintManager | Returns a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the Ribbon Bar.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawControlComboBox | This method is called to draw the control.
DrawControlEdit | This method is called to draw the control.
DrawControlEntry | This method is called to fill the control's face
DrawControlGroupOption | Draws the group option button.
DrawControlGroupPopup | Draws the group popup button.
DrawControlPopupGlyph | This method is called to draw menu popup Glyph
DrawDwmCaptionText | This method is called to draw caption text for Aero transparent caption
DrawGroup | Draws the specified CXTPRibbonGroup.
DrawKeyboardTip | This method is called to draw ribbon keyboard tip
DrawPopupBarCheckMark | Call this member function to draw a check mark.
DrawPopupBarGripper | This method is called to draw popup bar right gripper.
DrawPopupBarRadioMark | Call this member function to draw a radio button.
DrawRectangle | This method is called to fill the control's face
DrawRibbonFrameCaption | This method is called to Draw Ribbon caption
DrawRibbonFrameCaptionBar | This method is called to draw ribbon caption if EnableFrameTheme was not called
DrawRibbonFrameContextHeaders | This method is called to draw ribbon context headers
DrawRibbonFrameSystemButton | Draws top-left system button
DrawRibbonQuickAccessButton | This method is called to draw quick access customize button
DrawRibbonQuickAccessMoreButton | This method is called to draw quick access more button
DrawRibbonScrollButton | This method is called to draw scroll groups buttons
DrawRibbonTab | This method is called to draw single tab of ribbon bar
DrawSpecialControl | This method is called to draw the specified controls.
DrawSplitButtonFrame | This method is called to draw the frame for the SplitButton control
DrawSplitButtonPopup | This method is called to draw menu split button dropdown rect
DrawStatusBarGripper | This method is called to draw the status bar's gripper.
DrawStatusBarPaneBorder | This method is called to draw frame of single cell of status bar.
FillCommandBarEntry | This method is called to fill the command bar's face.
FillGroupPopupToolBar | This method is called to draw popup toolbar of reduced group
FillGroupRect | This method is called to fill background of a CXTPRibbonGroup.
FillMorePopupToolBarEntry | This method is called to draw popup bar of more button
FillPopupLabelEntry | This method is called to draw menu label background
FillRibbonBar | This method is called to fill background of Ribbon Bar control.
FillStatusBar | This method is called to fill a status bar.
FillTabPopupToolBar | This method is called to draw background of minimzed popup bar
GetControlEditBackColor | This method returns the edit control back color to draw.
GetControlTextColor | This method returns control text color to draw
GetEditHeight | Retrieves edit control height
GetFontHeight | Call this method to get font height used for Ribbon
GetGroupCaptionHeight | Gets the height of the group caption bar.
GetRectangleTextColor | This method retrieves buttons text color
GetTabPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
IsImagesAvailable | Determines if images is available
RefreshMetrics | This method is called to refresh the visual metrics of manager.
SetCommandBarRegion | This method is called to set bounding region for popup bars
SetFontHeight | Call this method to set font height used for Ribbon
SetRoundRectRegion | This method is called to set rounded rectangle region for window
UpdateFonts | This method is called to refresh fonts


CXTPRibbonTheme Data Members

CXTPRibbonTheme Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTheme Data Members
Class

CXTPRibbonTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrControlEditNormal | Edit control color
m_clrMinimizedFrameEdgeHighLight | Minimzed bottom edge
m_clrMinimizedFrameEdgeShadow | Minimzed bottom edge shadow
m_clrRibbonFace | Ribbon face color
m_clrRibbonGroupCaptionText | Ribbon group captions color
m_clrRibbonText | Ribbon text color
m_nFontHeight | Ribbon font height
m_nGroupCaptionHeight | Group caption bar height
m_pTabPaintManager | Tab paint manager
Public Data Members
Public Data Member | Description
m_bHotTrackingGroups | TRUE to highlight group under cursor
m_fontGroupCaption | Font used to draw text in the group caption
m_nTabsHeight | Tabs heights


CXTPRibbonTheme::m_bHotTrackingGroups Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_bHotTrackingGroups Data Member

TRUE to highlight group under cursor

BOOL m_bHotTrackingGroups;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_clrControlEditNormal Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_clrControlEditNormal Data Member

Edit control color

COLORREF m_clrControlEditNormal;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_clrMinimizedFrameEdgeHighLight Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_clrMinimizedFrameEdgeHighLight Data Member

Minimzed bottom edge

COLORREF m_clrMinimizedFrameEdgeHighLight;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_clrMinimizedFrameEdgeShadow Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_clrMinimizedFrameEdgeShadow Data Member

Minimzed bottom edge shadow

COLORREF m_clrMinimizedFrameEdgeShadow;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_clrRibbonFace Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_clrRibbonFace Data Member

Ribbon face color

COLORREF m_clrRibbonFace;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_clrRibbonGroupCaptionText Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_clrRibbonGroupCaptionText Data Member

Ribbon group captions color

COLORREF m_clrRibbonGroupCaptionText;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_clrRibbonText Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_clrRibbonText Data Member

Ribbon text color

COLORREF m_clrRibbonText;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_fontGroupCaption Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_fontGroupCaption Data Member

Font used to draw text in the group caption

CXTPPaintManagerFont m_fontGroupCaption;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_nFontHeight Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_nFontHeight Data Member

Ribbon font height

int m_nFontHeight;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_nGroupCaptionHeight Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_nGroupCaptionHeight Data Member

Group caption bar height

int m_nGroupCaptionHeight;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_nTabsHeight Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_nTabsHeight Data Member

Tabs heights

int m_nTabsHeight;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme::m_pTabPaintManager Data Member

CXTPRibbonTheme Data Members, CXTPRibbonTheme Class
CXTPRibbonTheme::m_pTabPaintManager Data Member

Tab paint manager

CXTPTabPaintManager* m_pTabPaintManager;
Group

CXTPRibbonTheme Data Members


CXTPRibbonTheme Methods

CXTPRibbonTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTheme Methods
Class

CXTPRibbonTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AdjustExcludeRect | This method is called to determine offset of popuped bar.
BaseTheme | Retrieves the base theme of the manager.
CreateTabPaintManager | Returns a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the Ribbon Bar.
DrawCommandBarSeparator | This method is called to draw a command bar's separator.
DrawControlComboBox | This method is called to draw the control.
DrawControlEdit | This method is called to draw the control.
DrawControlEntry | This method is called to fill the control's face
DrawControlPopupGlyph | This method is called to draw menu popup Glyph
DrawDwmCaptionText | This method is called to draw caption text for Aero transparent caption
DrawKeyboardTip | This method is called to draw ribbon keyboard tip
DrawPopupBarGripper | This method is called to draw popup bar right gripper.
DrawRectangle | This method is called to fill the control's face
DrawSpecialControl | This method is called to draw the specified controls.
DrawSplitButtonFrame | This method is called to draw the frame for the SplitButton control
DrawSplitButtonPopup | This method is called to draw menu split button dropdown rect
DrawStatusBarGripper | This method is called to draw the status bar's gripper.
DrawStatusBarPaneBorder | This method is called to draw frame of single cell of status bar.
FillCommandBarEntry | This method is called to fill the command bar's face.
FillPopupLabelEntry | This method is called to draw menu label background
FillStatusBar | This method is called to fill a status bar.
GetControlEditBackColor | This method returns the edit control back color to draw.
GetControlTextColor | This method returns control text color to draw
GetRectangleTextColor | This method retrieves buttons text color
IsImagesAvailable | Determines if images is available
SetCommandBarRegion | This method is called to set bounding region for popup bars
SetRoundRectRegion | This method is called to set rounded rectangle region for window
UpdateFonts | This method is called to refresh fonts
Public Methods
Public Methods
Public Method | Description
DrawControlGroupOption | Draws the group option button.
DrawControlGroupPopup | Draws the group popup button.
DrawGroup | Draws the specified CXTPRibbonGroup.
DrawPopupBarCheckMark | Call this member function to draw a check mark.
DrawPopupBarRadioMark | Call this member function to draw a radio button.
DrawRibbonFrameCaption | This method is called to Draw Ribbon caption
DrawRibbonFrameCaptionBar | This method is called to draw ribbon caption if EnableFrameTheme was not called
DrawRibbonFrameContextHeaders | This method is called to draw ribbon context headers
DrawRibbonFrameSystemButton | Draws top-left system button
DrawRibbonQuickAccessButton | This method is called to draw quick access customize button
DrawRibbonQuickAccessMoreButton | This method is called to draw quick access more button
DrawRibbonScrollButton | This method is called to draw scroll groups buttons
DrawRibbonTab | This method is called to draw single tab of ribbon bar
FillGroupPopupToolBar | This method is called to draw popup toolbar of reduced group
FillGroupRect | This method is called to fill background of a CXTPRibbonGroup.
FillMorePopupToolBarEntry | This method is called to draw popup bar of more button
FillRibbonBar | This method is called to fill background of Ribbon Bar control.
FillTabPopupToolBar | This method is called to draw background of minimzed popup bar
GetEditHeight | Retrieves edit control height
GetFontHeight | Call this method to get font height used for Ribbon
GetGroupCaptionHeight | Gets the height of the group caption bar.
GetTabPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
RefreshMetrics | This method is called to refresh the visual metrics of manager.
SetFontHeight | Call this method to set font height used for Ribbon


CXTPRibbonTheme::AdjustExcludeRect Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::AdjustExcludeRect Method

This method is called to determine offset of popuped bar.

virtual void AdjustExcludeRect(
    CRect& rc,
    CXTPControl* pControl,
    BOOL bVertical
);
Parameters

rc
Control's bounding rectangle.
pControl
Points to a CXTPControl object
bVertical
TRUE if control docked vertically.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::BaseTheme Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, Body Source
CXTPRibbonTheme::BaseTheme Method

Retrieves the base theme of the manager.

XTPPaintTheme BaseTheme();
Returns

Returns the base theme.

Body Source
XTPPaintTheme BaseTheme() { return xtpThemeRibbon; }
Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::CreateTabPaintManager Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::CreateTabPaintManager Method

Returns a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the Ribbon Bar.

virtual CXTPTabPaintManager* CreateTabPaintManager();
Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawCommandBarSeparator Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawCommandBarSeparator Method

This method is called to draw a command bar's separator.

virtual CSize DrawCommandBarSeparator(
    CDC* pDC,
    CXTPCommandBar* pBar,
    CXTPControl* pControl,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object
pControl
Points to a CXTPControl object
bDraw
TRUE to draw; FALSE to retrieve the size of the separator.

Returns

This method is called to draw a command bar's separator.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawControlComboBox Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawControlComboBox Method

This method is called to draw the control.

CSize DrawControlComboBox(
    CDC* pDC,
    CXTPControlComboBox* pComboBox,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pComboBox
ComboBox to draw.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawControlEdit Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawControlEdit Method

This method is called to draw the control.

CSize DrawControlEdit(
    CDC* pDC,
    CXTPControlEdit* pControlEdit,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pControlEdit
Edit control to draw.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.

Returns

Size of the control.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawControlEntry Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawControlEntry Method

This method is called to fill the control's face

virtual void DrawControlEntry(
    CDC* pDC,
    CXTPControl* pButton
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object to draw.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawControlGroupOption Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, See Also
CXTPRibbonTheme::DrawControlGroupOption Method

Draws the group option button.

virtual CSize DrawControlGroupOption(
    CDC* pDC,
    CXTPControl* pControlGroupOption,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pControlGroupOption
Pointer to a CXTPControl object.
bDraw
TRUE to draw option button; FALSE to retrieve the size of the control.

Returns

If bDraw is TRUE, then the size of the option button control is returned.

Remarks

The option button is typically used to launch a dialog associated with the group. It is drawn on the right side of the group caption.

See Also

CXTPRibbonGroup::ShowOptionButton, CXTPRibbonGroup::GetControlGroupOption

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawControlGroupPopup Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, See Also
CXTPRibbonTheme::DrawControlGroupPopup Method

Draws the group popup button.

virtual CSize DrawControlGroupPopup(
    CDC* pDC,
    CXTPControlPopup* pControlGroupPopup,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pControlGroupPopup
Pointer to a CXTPControlPopup object.
bDraw
TRUE to draw group popup button; FALSE to retrieve the size of the control.

Returns

If bDraw is TRUE, then the size of the group popup button is returned.

Remarks

A single group button will be displayed if there is not enough room to display the items in the group. A group popup is displayed when the button is clicked. The popup contains all the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group.

See Also

CXTPRibbonGroup::GetControlGroupPopup

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawControlPopupGlyph Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawControlPopupGlyph Method

This method is called to draw menu popup Glyph

virtual void DrawControlPopupGlyph(
    CDC* pDC,
    CXTPControl* pButton
);
Parameters

pDC
Pointer to a valid device context
pButton
Popup button to draw Glyph

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawDwmCaptionText Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawDwmCaptionText Method

This method is called to draw caption text for Aero transparent caption

void DrawDwmCaptionText(
    CDC* pDC,
    CRect rcCaptionText,
    CString strText,
    CWnd* pSite,
    BOOL bActive
);
Parameters

pDC
Pointer to a valid device context
rcCaptionText
Caption text rectangle
strText
Caption text
pSite
Frame to draw
bActive
TRUE if frame is active

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawGroup Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, See Also
CXTPRibbonTheme::DrawGroup Method

Draws the specified CXTPRibbonGroup.

virtual void DrawGroup(
    CDC* pDC,
    CXTPRibbonGroup* pGroup
);
Parameters

pDC
Pointer to a valid device context
pGroup
Pointer to the CXTPRibbonGroup to be drawn

Remarks

Draws the entire groups including background, caption and text. This will not draw the option button or group popup.

See Also

GROUP_COLOR, FillRibbonBar, FillGroupRect, RefreshMetrics

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawKeyboardTip Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawKeyboardTip Method

This method is called to draw ribbon keyboard tip

virtual void DrawKeyboardTip(
    CDC* pDC,
    CXTPCommandBarKeyboardTip* pWnd,
    BOOL bSetRegion
);
Parameters

pDC
Pointer to a valid device context
pWnd
Keyboard tip window
bSetRegion
TRUE to set region

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawPopupBarCheckMark Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawPopupBarCheckMark Method

Call this member function to draw a check mark.

virtual void DrawPopupBarCheckMark(
    CDC* pDC,
    CRect rcCheck,
    BOOL bEnabled,
    COLORREF clr
);
Parameters

pDC
Pointer to a valid device context
rcCheck
Specifies the rectangle in logical units.
clr
Color to fill.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawPopupBarGripper Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawPopupBarGripper Method

This method is called to draw popup bar right gripper.

virtual void DrawPopupBarGripper(
    CDC* pDC,
    int xPos,
    int yPos,
    int cx,
    int cy,
    BOOL bExpanded = FALSE
);
Parameters

pDC
Points to a valid device context.
xPos
Specifies the logical x-coordinate of the upper-left corner of the rectangle.
yPos
Specifies the logical y-coordinate of the upper-left corner of the destination rectangle.
cx
Specifies the width of the rectangle.
cy
Specifies the height of the rectangle.
bExpanded
TRUE if expanded.gripper.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawPopupBarRadioMark Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawPopupBarRadioMark Method

Call this member function to draw a radio button.

virtual void DrawPopupBarRadioMark(
    CDC* pDC,
    CRect rcCheck,
    BOOL bEnabled,
    COLORREF clr
);
Parameters

pDC
Pointer to a valid device context
rcCheck
Specifies the rectangle in logical units.
clr
Color to fill.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRectangle Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawRectangle Method

This method is called to fill the control's face

virtual void DrawRectangle(
    CDC* pDC,
    CRect rc,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

pDC
Pointer to a valid device context
rc
Rectangle to draw.
bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRibbonFrameCaption Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawRibbonFrameCaption Method

This method is called to Draw Ribbon caption

virtual void DrawRibbonFrameCaption(
    CDC* pDC,
    CXTPRibbonBar* pRibbonBar,
    BOOL bActive
);
Parameters

pDC
Pointer to a valid device context
pRibbonBar
Ribbon Bar to draw
bActive
TRUE if ribbon frame is active

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRibbonFrameCaptionBar Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawRibbonFrameCaptionBar Method

This method is called to draw ribbon caption if EnableFrameTheme was not called

virtual void DrawRibbonFrameCaptionBar(
    CDC* pDC,
    CXTPRibbonBar* pRibbonBar
);
Parameters

pDC
Pointer to a valid device context
pRibbonBar
Ribbon Bar to draw

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRibbonFrameContextHeaders Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawRibbonFrameContextHeaders Method

This method is called to draw ribbon context headers

virtual void DrawRibbonFrameContextHeaders(
    CDC* pDC,
    CXTPRibbonBar* pRibbonBar,
    CXTPRibbonTabContextHeaders* pContextHeaders
);
Parameters

pDC
Pointer to a valid device context
pRibbonBar
Parent RibbonBar pointer
pContextHeaders
Collection of context header

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRibbonFrameSystemButton Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawRibbonFrameSystemButton Method

Draws top-left system button

virtual void DrawRibbonFrameSystemButton(
    CDC* pDC,
    CXTPControlPopup* pControl,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pControl
System button control
rc
Bounding rectangle of control

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRibbonQuickAccessButton Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, See Also
CXTPRibbonTheme::DrawRibbonQuickAccessButton Method

This method is called to draw quick access customize button

virtual void DrawRibbonQuickAccessButton(
    CDC* pDC,
    CXTPControlPopup* pControl
);
Parameters

pDC
Pointer to a valid device context
pControl
Pointer to Quick Access customize button

See Also

DrawRibbonQuickAccessMoreButton

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRibbonQuickAccessMoreButton Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, See Also
CXTPRibbonTheme::DrawRibbonQuickAccessMoreButton Method

This method is called to draw quick access more button

virtual void DrawRibbonQuickAccessMoreButton(
    CDC* pDC,
    CXTPControlPopup* pControl
);
Parameters

pDC
Pointer to a valid device context
pControl
Pointer to Quick Access more button

See Also

DrawRibbonQuickAccessButton

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRibbonScrollButton Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawRibbonScrollButton Method

This method is called to draw scroll groups buttons

virtual void DrawRibbonScrollButton(
    CDC* pDC,
    CXTPControl* pControl,
    BOOL bScrollLeft
);
Parameters

pDC
Pointer to a valid device context
pControl
Scroll button to draw
bScrollLeft
TRUE to draw left button; FALSE - right

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawRibbonTab Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawRibbonTab Method

This method is called to draw single tab of ribbon bar

virtual void DrawRibbonTab(
    CDC* pDC,
    CXTPRibbonTab* pItem
);
Parameters

pDC
Pointer to a valid device context
pItem
Ribbon tab to draw

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawSpecialControl Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawSpecialControl Method

This method is called to draw the specified controls.

virtual CSize DrawSpecialControl(
    CDC* pDC,
    XTPSpecialControl controlType,
    CXTPControl* pButton,
    CXTPCommandBar* pBar,
    BOOL bDraw,
    LPVOID lpParam
);
Parameters

pDC
Pointer to a valid device context
controlType
Special control enumerator.
pButton
Points to a CXTPControl object to draw.
pBar
Parent CXTPCommandBar object.
bDraw
TRUE to draw; FALSE to retrieve the size of the control.
lpParam
Specified parameter.

Returns

Size of the control.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawSplitButtonFrame Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawSplitButtonFrame Method

This method is called to draw the frame for the SplitButton control

virtual void DrawSplitButtonFrame(
    CDC* pDC,
    CXTPControl* pButton,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPControl object
rc
Bounding rectangle to draw

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawSplitButtonPopup Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawSplitButtonPopup Method

This method is called to draw menu split button dropdown rect

virtual void DrawSplitButtonPopup(
    CDC* pDC,
    CXTPControl* pButton
);
Parameters

pDC
Pointer to a valid device context
pButton
Split button to draw

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawStatusBarGripper Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawStatusBarGripper Method

This method is called to draw the status bar's gripper.

virtual void DrawStatusBarGripper(
    CDC* pDC,
    CRect rcClient
);
Parameters

pDC
Pointer to a valid device context
rcClient
Client rectangle of the status bar.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::DrawStatusBarPaneBorder Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::DrawStatusBarPaneBorder Method

This method is called to draw frame of single cell of status bar.

virtual void DrawStatusBarPaneBorder(
    CDC* pDC,
    CRect rc,
    CXTPStatusBarPane* pPane,
    BOOL bGripperPane
);
Parameters

pDC
Points to a valid device context.
rc
CRect object specifying size of area.
pPane
The status bar pane need to draw
bGripperPane
TRUE if pane is last cell of status bar

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::FillCommandBarEntry Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::FillCommandBarEntry Method

This method is called to fill the command bar's face.

virtual void FillCommandBarEntry(
    CDC* pDC,
    CXTPCommandBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPCommandBar object to draw.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::FillGroupPopupToolBar Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::FillGroupPopupToolBar Method

This method is called to draw popup toolbar of reduced group

virtual void FillGroupPopupToolBar(
    CDC* pDC,
    CXTPRibbonGroup* pGroup,
    CXTPCommandBar* pCommandBar
);
Parameters

pDC
Pointer to a valid device context
pGroup
Parent group of popuped toolbar
pCommandBar
popup toolbar to draw

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::FillGroupRect Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, See Also
CXTPRibbonTheme::FillGroupRect Method

This method is called to fill background of a CXTPRibbonGroup.

virtual void FillGroupRect(
    CDC* pDC,
    CXTPRibbonTab* pActiveTab,
    CRect rcGroups
);
Parameters

pDC
Pointer to a valid device context
pActiveTab
Pointer to the tab that is currently active
rcGroups
Bounding rectangle of the group

Remarks

Performs a gradient fill using the GROUP_COLOR::clrBackground for the main group background and GROUP_COLOR::clrCaption to fill the group caption rectangle.

See Also

CXTPRibbonGroup::GetRect, GROUP_COLOR

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::FillMorePopupToolBarEntry Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::FillMorePopupToolBarEntry Method

This method is called to draw popup bar of more button

virtual void FillMorePopupToolBarEntry(
    CDC* pDC,
    CXTPCommandBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
ToolBar to fill

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::FillPopupLabelEntry Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::FillPopupLabelEntry Method

This method is called to draw menu label background

virtual void FillPopupLabelEntry(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
rc
Bounding rectangle of button

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::FillRibbonBar Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::FillRibbonBar Method

This method is called to fill background of Ribbon Bar control.

virtual void FillRibbonBar(
    CDC* pDC,
    CXTPRibbonBar* pRibbonBar
);
Parameters

pDC
Pointer to a valid device context
pRibbonBar
Points to a CXTPRibbonBar object

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::FillStatusBar Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::FillStatusBar Method

This method is called to fill a status bar.

virtual void FillStatusBar(
    CDC* pDC,
    CXTPStatusBar* pBar
);
Parameters

pDC
Pointer to a valid device context
pBar
Points to a CXTPStatusBar object

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::FillTabPopupToolBar Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::FillTabPopupToolBar Method

This method is called to draw background of minimzed popup bar

void FillTabPopupToolBar(
    CDC* pDC,
    CXTPPopupToolBar* pPopupToolBar
);
Parameters

pDC
Pointer to device context
pPopupToolBar
Pointer to popup toolbar.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::GetControlEditBackColor Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::GetControlEditBackColor Method

This method returns the edit control back color to draw.

virtual COLORREF GetControlEditBackColor(
    CXTPControl* pControl
);
Parameters

pControl
Points to a CXTPControl object to get the back color from.

Returns

Edit control back color.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::GetControlTextColor Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::GetControlTextColor Method

This method returns control text color to draw

virtual COLORREF GetControlTextColor(
    CXTPControl* pButton
);
Parameters

pButton
Points to a CXTPControl object to draw.

Returns

Button text color

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::GetEditHeight Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, Body Source
CXTPRibbonTheme::GetEditHeight Method

Retrieves edit control height

int GetEditHeight() const;
Body Source
int CXTPRibbonTheme::GetEditHeight() const {
    return m_nEditHeight;
}
Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::GetFontHeight Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTheme::GetFontHeight Method

Call this method to get font height used for Ribbon

int GetFontHeight() const;
Returns

Font height used for Ribbon

See Also

SetFontHeight

Body Source
int CXTPRibbonTheme::GetFontHeight() const {
    return m_nFontHeight;
}
Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::GetGroupCaptionHeight Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTheme::GetGroupCaptionHeight Method

Gets the height of the group caption bar.

int GetGroupCaptionHeight() const;
Returns

Integer containing the height of the group caption bar.

See Also

CXTPRibbonGroup::RepositionControls, CXTPRibbonGroup::SetRect

Body Source
int CXTPRibbonTheme::GetGroupCaptionHeight() const {
    return m_nGroupCaptionHeight;
}
Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::GetRectangleTextColor Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::GetRectangleTextColor Method

This method retrieves buttons text color

virtual COLORREF GetRectangleTextColor(
    BOOL bSelected,
    BOOL bPressed,
    BOOL bEnabled,
    BOOL bChecked,
    BOOL bPopuped,
    XTPBarType barType,
    XTPBarPosition barPosition
);
Parameters

bSelected
TRUE if the control is selected.
bPressed
TRUE if the control is pushed.
bEnabled
TRUE if the control is enabled.
bChecked
TRUE if the control is checked.
bPopuped
TRUE if the control is popuped.
barType
Parent's bar type
barPosition
Parent's bar position.

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::GetTabPaintManager Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, Body Source
CXTPRibbonTheme::GetTabPaintManager Method

Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.

CXTPTabPaintManager* GetTabPaintManager() const;
Returns

Pointer to CXTPTabPaintManager that contains the visual elements of the tabs.

Body Source
CXTPTabPaintManager* CXTPRibbonTheme::GetTabPaintManager() const {
    return m_pTabPaintManager;
}
Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::IsImagesAvailable Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::IsImagesAvailable Method

Determines if images is available

BOOL IsImagesAvailable();
Returns

TRUE if images exist in application

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::RefreshMetrics Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, See Also
CXTPRibbonTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of manager.

virtual void RefreshMetrics();
Remarks

Refreshes all of the colors in the Ribbon Bar. Many of the colors used are set with the GROUP_COLOR structure.

See Also

GROUP_COLOR

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::SetCommandBarRegion Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::SetCommandBarRegion Method

This method is called to set bounding region for popup bars

virtual void SetCommandBarRegion(
    CXTPCommandBar* pCommandBar
);
Parameters

pCommandBar
Pointer to popup bar which region need to set

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::SetFontHeight Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPRibbonTheme::SetFontHeight Method

Call this method to set font height used for Ribbon

void SetFontHeight(
    int nFontHeight
);
Parameters

nFontHeight
New font height

See Also

GetFontHeight

Body Source
void CXTPRibbonTheme::SetFontHeight(int nFontHeight) {
    m_nFontHeight = nFontHeight;
    RefreshMetrics();
}
Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::SetRoundRectRegion Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::SetRoundRectRegion Method

This method is called to set rounded rectangle region for window

void SetRoundRectRegion(
    CWnd* pWnd
);
Parameters

pWnd
Window to set region to

Group

CXTPRibbonTheme Methods


CXTPRibbonTheme::UpdateFonts Method

CXTPRibbonTheme Methods, CXTPRibbonTheme Class
CXTPRibbonTheme::UpdateFonts Method

This method is called to refresh fonts

void UpdateFonts();
Group

CXTPRibbonTheme Methods


CXTPRibbonTheme Constructors

CXTPRibbonTheme Class, Legend, Public Methods
CXTPRibbonTheme Constructors
Class

CXTPRibbonTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonTheme | Constructs a CXTPRibbonTheme object


CXTPRibbonTheme::CXTPRibbonTheme Constructor

CXTPRibbonTheme Constructors, CXTPRibbonTheme Class
CXTPRibbonTheme::CXTPRibbonTheme Constructor

Constructs a CXTPRibbonTheme object

CXTPRibbonTheme();
Group

CXTPRibbonTheme Constructors


CXTPRibbonTheme Destructors

CXTPRibbonTheme Class, Legend, Public Methods
CXTPRibbonTheme Destructors
Class

CXTPRibbonTheme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPRibbonTheme | Destroys a CXTPRibbonTheme object, handles cleanup and deallocation


CXTPRibbonTheme::~CXTPRibbonTheme Destructor

CXTPRibbonTheme Destructors, CXTPRibbonTheme Class
CXTPRibbonTheme::~CXTPRibbonTheme Destructor

Destroys a CXTPRibbonTheme object, handles cleanup and deallocation

virtual ~CXTPRibbonTheme();
Group

CXTPRibbonTheme Destructors


CXTPShortcutManager Class

XTPShortcutManager.h, Classes, Legend, Members, Topics, CXTPShortcutManager Data Members, CXTPShortcutManager Methods, CXTPShortcutManager Constructors, CXTPShortcutManager Destructors, CXTPShortcutManager Constructors, CXTPShortcutManager Data Members, CXTPShortcutManager Destructors, CXTPShortcutManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutManager Class

CXTPShortcutManager is standalone class used to manipulate accelerators of frame.

Class Hierarchy

class CXTPShortcutManager;
File

XTPShortcutManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPShortcutManager Constructors
CXTPShortcutManager Constructors | Description
CXTPShortcutManager | Constructs a CXTPShortcutManager object.
CXTPShortcutManager Data Members
CXTPShortcutManager Data Members | Description
m_bAllowEscapeShortcut | TRUE to allow escape to use as shortcut
m_bUseSystemKeyNameText | TRUE to use localized shortcuts
m_nDisableShortcuts | Number of shortcuts that have been disabled.
m_pAccelTable | Accelerator table
m_pKeyNameText | KeyNameText map.
m_pOriginalAccelTable | Original accelerator table.
CXTPShortcutManager Destructors
CXTPShortcutManager Destructors | Description
~CXTPShortcutManager | Destroys a CXTPShortcutManager object, handles cleanup and deallocation.
CXTPShortcutManager Methods
CXTPShortcutManager Methods | Description
DisableShortcuts | This method is called to enable/disable shortcuts usage
DoPropExchange | Reads or writes this object from or to an archive.
FindDefaultAccelerator | Retrieves shortcut text for specified command.
Format | This method is called to retrieve text presentation of ACCEL. You can override this method.
GetDefaultAccelerator | Call this member to get accelerator table
GetKeyNameText | The GetKeyNameText function retrieves a string that represents the name of a key. Override this member function to provide additional functionality.
GetOriginalAccelerator | Call this member to get original accelerators
LoadShortcuts | Call this function to retrieve accelerators from the registry or .INI file.
OnBeforeAdd | This method is called before user add new shortcut
OnBeforeRemove | This method is called before user remove shortcut
OnPreviewEditKey | The OnPreviewEditKey function called to determine if user defined shortcut is allowed.
Reset | Call this member to reset shortcuts
SaveShortcuts | Call this function to save the accelerators to the registry or .INI file.
SetAccelerators | Call this member to create original accelerators
SetDefaultAccelerator | Call this member to set accelerator table
SetKeyNameText | Call this member to localize shortcut key name text.
TranslateAccelerator | The TranslateAccelerator function processes accelerator keys for menu commands.
UseSystemKeyNameText | Call this member to use system localized shortcuts


CXTPShortcutManager Data Members

CXTPShortcutManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutManager Data Members
Class

CXTPShortcutManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pAccelTable | Accelerator table
m_pKeyNameText | KeyNameText map.
m_pOriginalAccelTable | Original accelerator table.
Public Data Members
Public Data Member | Description
m_bAllowEscapeShortcut | TRUE to allow escape to use as shortcut
m_bUseSystemKeyNameText | TRUE to use localized shortcuts
m_nDisableShortcuts | Number of shortcuts that have been disabled.


CXTPShortcutManager::m_bAllowEscapeShortcut Data Member

CXTPShortcutManager Data Members, CXTPShortcutManager Class
CXTPShortcutManager::m_bAllowEscapeShortcut Data Member

TRUE to allow escape to use as shortcut

BOOL m_bAllowEscapeShortcut;
Group

CXTPShortcutManager Data Members


CXTPShortcutManager::m_bUseSystemKeyNameText Data Member

CXTPShortcutManager Data Members, CXTPShortcutManager Class
CXTPShortcutManager::m_bUseSystemKeyNameText Data Member

TRUE to use localized shortcuts

BOOL m_bUseSystemKeyNameText;
Group

CXTPShortcutManager Data Members


CXTPShortcutManager::m_nDisableShortcuts Data Member

CXTPShortcutManager Data Members, CXTPShortcutManager Class
CXTPShortcutManager::m_nDisableShortcuts Data Member

Number of shortcuts that have been disabled.

int m_nDisableShortcuts;
Group

CXTPShortcutManager Data Members


CXTPShortcutManager::m_pAccelTable Data Member

CXTPShortcutManager Data Members, CXTPShortcutManager Class
CXTPShortcutManager::m_pAccelTable Data Member

Accelerator table

CXTPShortcutManagerAccelTable* m_pAccelTable;
Group

CXTPShortcutManager Data Members


CXTPShortcutManager::m_pKeyNameText Data Member

CXTPShortcutManager Data Members, CXTPShortcutManager Class
CXTPShortcutManager::m_pKeyNameText Data Member

KeyNameText map.

CKeyNameText* m_pKeyNameText;
Group

CXTPShortcutManager Data Members


CXTPShortcutManager::m_pOriginalAccelTable Data Member

CXTPShortcutManager Data Members, CXTPShortcutManager Class
CXTPShortcutManager::m_pOriginalAccelTable Data Member

Original accelerator table.

CXTPShortcutManagerAccelTable* m_pOriginalAccelTable;
Group

CXTPShortcutManager Data Members


CXTPShortcutManager Methods

CXTPShortcutManager Class, Legend, Public Methods
CXTPShortcutManager Methods
Class

CXTPShortcutManager Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DisableShortcuts | This method is called to enable/disable shortcuts usage
DoPropExchange | Reads or writes this object from or to an archive.
FindDefaultAccelerator | Retrieves shortcut text for specified command.
Format | This method is called to retrieve text presentation of ACCEL. You can override this method.
GetDefaultAccelerator | Call this member to get accelerator table
GetKeyNameText | The GetKeyNameText function retrieves a string that represents the name of a key. Override this member function to provide additional functionality.
GetOriginalAccelerator | Call this member to get original accelerators
LoadShortcuts | Call this function to retrieve accelerators from the registry or .INI file.
OnBeforeAdd | This method is called before user add new shortcut
OnBeforeRemove | This method is called before user remove shortcut
OnPreviewEditKey | The OnPreviewEditKey function called to determine if user defined shortcut is allowed.
Reset | Call this member to reset shortcuts
SaveShortcuts | Call this function to save the accelerators to the registry or .INI file.
SetAccelerators | Call this member to create original accelerators
SetDefaultAccelerator | Call this member to set accelerator table
SetKeyNameText | Call this member to localize shortcut key name text.
TranslateAccelerator | The TranslateAccelerator function processes accelerator keys for menu commands.
UseSystemKeyNameText | Call this member to use system localized shortcuts


CXTPShortcutManager::DisableShortcuts Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::DisableShortcuts Method

This method is called to enable/disable shortcuts usage

void DisableShortcuts(
    BOOL bDisable
);
Parameters

bDisable
TRUE to disable shortcuts

Group

CXTPShortcutManager Methods


CXTPShortcutManager::DoPropExchange Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPShortcutManager Methods


CXTPShortcutManager::FindDefaultAccelerator Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::FindDefaultAccelerator Method

Retrieves shortcut text for specified command.

virtual BOOL FindDefaultAccelerator(
    int nCmd,
    CString& strShortcut
);
Parameters

nCmd
Command which shortcut text need to retrieve
strShortcut
Shortcut text reference.

Returns

TRUE if shortcut found.

Group

CXTPShortcutManager Methods


CXTPShortcutManager::Format Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::Format Method

This method is called to retrieve text presentation of ACCEL. You can override this method.

virtual CString Format(
    CXTPShortcutManagerAccel* lpAccel,
    int* pPriority
);
Parameters

lpAccel
Accelerator need to format.
pPriority
Returns priority of accelerator to be used to determine what accelerator used as default.

Group

CXTPShortcutManager Methods


CXTPShortcutManager::GetDefaultAccelerator Method

CXTPShortcutManager Methods, CXTPShortcutManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutManager::GetDefaultAccelerator Method

Call this member to get accelerator table

virtual CXTPShortcutManagerAccelTable* GetDefaultAccelerator() const;
Returns

Accelerator table handle

Body Source
CXTPShortcutManagerAccelTable* CXTPShortcutManager::GetDefaultAccelerator() const {
    return m_pAccelTable;
}
Group

CXTPShortcutManager Methods


CXTPShortcutManager::GetKeyNameText Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::GetKeyNameText Method

The GetKeyNameText function retrieves a string that represents the name of a key. Override this member function to provide additional functionality.

virtual CString GetKeyNameText(
    UINT uiVirtKey
);
Parameters

uiVirtKey
virtual-key of accelerator.

Group

CXTPShortcutManager Methods


CXTPShortcutManager::GetOriginalAccelerator Method

CXTPShortcutManager Methods, CXTPShortcutManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutManager::GetOriginalAccelerator Method

Call this member to get original accelerators

CXTPShortcutManagerAccelTable* GetOriginalAccelerator() const;
Body Source
CXTPShortcutManagerAccelTable* CXTPShortcutManager::GetOriginalAccelerator() const {
    return m_pOriginalAccelTable;
}
Group

CXTPShortcutManager Methods


CXTPShortcutManager::LoadShortcuts Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::LoadShortcuts Method

Call this function to retrieve accelerators from the registry or .INI file.

void LoadShortcuts(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

Group

CXTPShortcutManager Methods


CXTPShortcutManager::OnBeforeAdd Method

CXTPShortcutManager Methods, CXTPShortcutManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutManager::OnBeforeAdd Method

This method is called before user add new shortcut

virtual BOOL OnBeforeAdd(
    CXTPShortcutManagerAccel* pAccel
);
Parameters

pAccel
New shortcut to add

See Also

OnBeforeRemove

Group

CXTPShortcutManager Methods


CXTPShortcutManager::OnBeforeRemove Method

CXTPShortcutManager Methods, CXTPShortcutManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutManager::OnBeforeRemove Method

This method is called before user remove shortcut

virtual BOOL OnBeforeRemove(
    CXTPShortcutManagerAccel* pAccel
);
Parameters

pAccel
Shortcut to be removed

See Also

OnBeforeAdd

Group

CXTPShortcutManager Methods


CXTPShortcutManager::OnPreviewEditKey Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::OnPreviewEditKey Method

The OnPreviewEditKey function called to determine if user defined shortcut is allowed.

virtual BOOL OnPreviewEditKey(
    CXTPShortcutManagerAccel* pAccel
);
Parameters

hAccel
User pressed key.

Returns

TRUE if key is allowed

Group

CXTPShortcutManager Methods


CXTPShortcutManager::Reset Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::Reset Method

Call this member to reset shortcuts

virtual void Reset();
Group

CXTPShortcutManager Methods


CXTPShortcutManager::SaveShortcuts Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::SaveShortcuts Method

Call this function to save the accelerators to the registry or .INI file.

void SaveShortcuts(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

Group

CXTPShortcutManager Methods


CXTPShortcutManager::SetAccelerators Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::SetAccelerators Method

Call this member to create original accelerators

void SetAccelerators(
    UINT nIDResource
);
Parameters

nIDResource
Resource identifier of Accelerator table.

Group

CXTPShortcutManager Methods


CXTPShortcutManager::SetDefaultAccelerator Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::SetDefaultAccelerator Method

Call this member to set accelerator table

void SetDefaultAccelerator(
    HACCEL hAccelTable
);
Parameters

hAccelTable
New accelerators to be set.

Group

CXTPShortcutManager Methods


CXTPShortcutManager::SetKeyNameText Method

CXTPShortcutManager Methods, CXTPShortcutManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutManager::SetKeyNameText Method

Call this member to localize shortcut key name text.

void SetKeyNameText(
    UINT uiVirtKey,
    LPCTSTR lpszKeyNameText
);
Parameters

uiVirtKey
virtual-key of accelerator.
lpszKeyNameText
New text that will be associated with virtual-key

Example
pCommandBars->GetShortcutManager()->SetKeyNameText(VK_CONTROL, _T("Strg"));
Group

CXTPShortcutManager Methods


CXTPShortcutManager::TranslateAccelerator Method

CXTPShortcutManager Methods, CXTPShortcutManager Class
CXTPShortcutManager::TranslateAccelerator Method

The TranslateAccelerator function processes accelerator keys for menu commands.

BOOL TranslateAccelerator(
    LPMSG lpMsg
);
Parameters

lpMsg
Pointer to an MSG structure that contains message information

Group

CXTPShortcutManager Methods


CXTPShortcutManager::UseSystemKeyNameText Method

CXTPShortcutManager Methods, CXTPShortcutManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutManager::UseSystemKeyNameText Method

Call this member to use system localized shortcuts

void UseSystemKeyNameText(
    BOOL bSystemKey
);
Parameters

bSystemKey
TRUE to allow system to localize shortcuts instead of predefined shortcuts table.

Example
pCommandBars->GetShortcutManager()->UseSystemKeyNameText(TRUE);
Body Source
void CXTPShortcutManager::UseSystemKeyNameText(BOOL bSystemKey) {
    m_bUseSystemKeyNameText = bSystemKey;
}
Group

CXTPShortcutManager Methods


CXTPShortcutManager Constructors

CXTPShortcutManager Class, Legend, Public Methods
CXTPShortcutManager Constructors
Class

CXTPShortcutManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutManager | Constructs a CXTPShortcutManager object.


CXTPShortcutManager::CXTPShortcutManager Constructor

CXTPShortcutManager Constructors, CXTPShortcutManager Class
CXTPShortcutManager::CXTPShortcutManager Constructor

Constructs a CXTPShortcutManager object.

CXTPShortcutManager(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
Owner CommandBars object

Group

CXTPShortcutManager Constructors


CXTPShortcutManager Destructors

CXTPShortcutManager Class, Legend, Public Methods
CXTPShortcutManager Destructors
Class

CXTPShortcutManager Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPShortcutManager | Destroys a CXTPShortcutManager object, handles cleanup and deallocation.


CXTPShortcutManager::~CXTPShortcutManager Destructor

CXTPShortcutManager Destructors, CXTPShortcutManager Class
CXTPShortcutManager::~CXTPShortcutManager Destructor

Destroys a CXTPShortcutManager object, handles cleanup and deallocation.

~CXTPShortcutManager();
Group

CXTPShortcutManager Destructors


CXTPSoundManager Class

XTPSoundManager.h, Classes, Legend, Members, Topics, CXTPSoundManager Methods, CXTPSoundManager Destructors, CXTPSoundManager Destructors, CXTPSoundManager Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSoundManager Class

CXTPSoundManager is standalone class. It used to play system sound.

Class Hierarchy

class CXTPSoundManager;
File

XTPSoundManager.h

See Also

XTPSoundManagerState, XTPSoundManager

Group

Classes

Legend
Method
CXTPSoundManager Destructors
CXTPSoundManager Destructors | Description
~CXTPSoundManager | Destroys a CXTPSoundManager object, handles cleanup and deallocation
CXTPSoundManager Methods
CXTPSoundManager Methods | Description
EnableSystemSounds | Call this method to disable all system sounds for application
PlaySystemSound | Call this method to play system sound
StopThread | This method is called to stop all sounds and terminate sound thread.


CXTPSoundManager Methods

CXTPSoundManager Class, Legend, Public Methods
CXTPSoundManager Methods
Class

CXTPSoundManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
EnableSystemSounds | Call this method to disable all system sounds for application
PlaySystemSound | Call this method to play system sound
StopThread | This method is called to stop all sounds and terminate sound thread.


CXTPSoundManager::EnableSystemSounds Method

CXTPSoundManager Methods, CXTPSoundManager Class
CXTPSoundManager::EnableSystemSounds Method

Call this method to disable all system sounds for application

void EnableSystemSounds(
    BOOL bEnable
);
Parameters

bEnable
FALSE to disable system sounds.

Remarks

Call this method to force system settings and disable all sounds.

Group

CXTPSoundManager Methods


CXTPSoundManager::PlaySystemSound Method

CXTPSoundManager Methods, CXTPSoundManager Class
CXTPSoundManager::PlaySystemSound Method

Call this method to play system sound

void PlaySystemSound(
    XTPSoundManagerState state
);
Parameters

state
System sound to play. Can be any of the values listed in the remarks section.

Remarks

State parameter can be one of the following:

  • xtpSoundMenuCommand Play menu command system sound
  • xtpSoundMenuPopup Play menu popup system sound
Group

CXTPSoundManager Methods


CXTPSoundManager::StopThread Method

CXTPSoundManager Methods, CXTPSoundManager Class
CXTPSoundManager::StopThread Method

This method is called to stop all sounds and terminate sound thread.

void StopThread();
Group

CXTPSoundManager Methods


CXTPSoundManager Destructors

CXTPSoundManager Class, Legend, Public Methods
CXTPSoundManager Destructors
Class

CXTPSoundManager Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSoundManager | Destroys a CXTPSoundManager object, handles cleanup and deallocation


CXTPSoundManager::~CXTPSoundManager Destructor

CXTPSoundManager Destructors, CXTPSoundManager Class
CXTPSoundManager::~CXTPSoundManager Destructor

Destroys a CXTPSoundManager object, handles cleanup and deallocation

~CXTPSoundManager();
Group

CXTPSoundManager Destructors


CXTPStatusBar Class

XTPStatusBar.h, Classes, Legend, Members, Topics, CXTPStatusBar Data Members, CXTPStatusBar Methods, CXTPStatusBar Constructors, CXTPStatusBar Destructors, CXTPStatusBar Constructors, CXTPStatusBar Data Members, CXTPStatusBar Destructors, CXTPStatusBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBar Class

CXTPStatusBar is a CControlBar derived class.

Class Hierarchy

class CXTPStatusBar : public CControlBar;
File

XTPStatusBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPStatusBar Constructors
CXTPStatusBar Constructors | Description
CXTPStatusBar | Constructs a CXTPStatusBar object
CXTPStatusBar Data Members
CXTPStatusBar Data Members | Description
m_arrPanes | Array of panes
m_bDrawDisabledText | TRUE to draw disabled text
m_bShowSizeGripper | TRUE to show size gripper
m_fontStatus | Font of status bar
m_nMinHeight | Minimum client height
m_nRibbonDividerIndex | Position of dark part for Ribbon Theme
m_pHighlightedPane | Pane currently highlighted
CXTPStatusBar Destructors
CXTPStatusBar Destructors | Description
~CXTPStatusBar | Destroys a CXTPStatusBar object, handles cleanup and deallocation
CXTPStatusBar Methods
CXTPStatusBar Methods | Description
AddControl | Call this member function to add a control to an indicator pane.
AddIndicator |
CommandToIndex | Gets the indicator index for a given ID. The index of the first indicator is 0
Create | Creates a status bar (a child window) and associates it with the CStatusBar object. Also sets the initial font and sets the status bar's height to a default value.
CreateEx | Call this function to create a status bar
DrawPaneEntry | This method is called to draw a single pane of the status bar.
DrawStretch | Draws the stretch gripper of the status bar.
EnableCustomization | Call this method to enable/disable customization of the statusbar
FindPane | Call this member function to find the pane for the given Identifier.
GetDrawDisabledText | Call this member to determine if paint manager draw disabled text.
GetImageManager | Call this member to retrieve the image manager of the image manager.
GetItemID | Returns the ID of the indicator specified by nIndex
GetItemRect | Copies the coordinates of the indicator specified by nIndex into the structure pointed to by lpRect. Coordinates are in pixels relative to the upper-left corner of the status bar.
GetPaintManager | Retrieves the paint manager.
GetPane | Call this member function to get the pane information for the given index.
GetPaneCount | Call this member function to return the number of panes that are created for the status bar.
GetPaneInfo | Sets nID, nStyle, and cxWidth to the ID, style, and width of the indicator pane at the location specified by nIndex.
GetPaneStyle | Call this member function to retrieve the style of a status bar's pane. A pane's style determines how the pane appears.
GetPaneText |
GetStatusBarCtrl | This member function allows direct access to the underlying common control
GetToolTipContext | Call this method to get tooltip context pointer.
GetVisiblePaneCount | Calculates total number of visible panes.
HitTest | Call this function to determine which pane, if any, is at the specified screen position.
PositionControls | This member function is called by the status bar to reposition pane item controls.
RemoveAll | Call this member function to remove all indicators.
RemoveAt | Call this member function to remove an indicator pane from the status bar.
RemoveIndicator | Call this member function to remove an indicator pane from the status bar.
SetCommandBars | Call this member to set the command bar's object.
SetDrawDisabledText | Call this member to draw disabled text.
SetFont | Call this method to set font for status bar
SetIndicators | Sets each indicator's ID to the value specified by the corresponding element of the array lpIDArray, loads the string resource specified by each ID, and sets the indicator's text to the string.
SetPaneInfo | Sets the specified indicator pane to a new ID, style, and width.
SetPaneStyle | Call this member function to set the style of a status bar's pane. A pane's style determines how the pane appears.
SetPaneText | Sets the pane text to the string pointed to by lpszNewText.
SetPaneWidth | Call this member function to set the width for an indicator pane.


CXTPStatusBar Data Members

CXTPStatusBar Class, Legend, Protected Data Members
CXTPStatusBar Data Members
Class

CXTPStatusBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrPanes | Array of panes
m_bDrawDisabledText | TRUE to draw disabled text
m_bShowSizeGripper | TRUE to show size gripper
m_fontStatus | Font of status bar
m_nMinHeight | Minimum client height
m_nRibbonDividerIndex | Position of dark part for Ribbon Theme
m_pHighlightedPane | Pane currently highlighted


CXTPStatusBar::m_arrPanes Data Member

CXTPStatusBar Data Members, CXTPStatusBar Class
CXTPStatusBar::m_arrPanes Data Member

Array of panes

CArray<CXTPStatusBarPane*, CXTPStatusBarPane*> m_arrPanes;
Group

CXTPStatusBar Data Members


CXTPStatusBar::m_bDrawDisabledText Data Member

CXTPStatusBar Data Members, CXTPStatusBar Class
CXTPStatusBar::m_bDrawDisabledText Data Member

TRUE to draw disabled text

BOOL m_bDrawDisabledText;
Group

CXTPStatusBar Data Members


CXTPStatusBar::m_bShowSizeGripper Data Member

CXTPStatusBar Data Members, CXTPStatusBar Class
CXTPStatusBar::m_bShowSizeGripper Data Member

TRUE to show size gripper

BOOL m_bShowSizeGripper;
Group

CXTPStatusBar Data Members


CXTPStatusBar::m_fontStatus Data Member

CXTPStatusBar Data Members, CXTPStatusBar Class
CXTPStatusBar::m_fontStatus Data Member

Font of status bar

CFont m_fontStatus;
Group

CXTPStatusBar Data Members


CXTPStatusBar::m_nMinHeight Data Member

CXTPStatusBar Data Members, CXTPStatusBar Class
CXTPStatusBar::m_nMinHeight Data Member

Minimum client height

int m_nMinHeight;
Group

CXTPStatusBar Data Members


CXTPStatusBar::m_nRibbonDividerIndex Data Member

CXTPStatusBar Data Members, CXTPStatusBar Class
CXTPStatusBar::m_nRibbonDividerIndex Data Member

Position of dark part for Ribbon Theme

int m_nRibbonDividerIndex;
Group

CXTPStatusBar Data Members


CXTPStatusBar::m_pHighlightedPane Data Member

CXTPStatusBar Data Members, CXTPStatusBar Class
CXTPStatusBar::m_pHighlightedPane Data Member

Pane currently highlighted

CXTPStatusBarPane* m_pHighlightedPane;
Group

CXTPStatusBar Data Members


CXTPStatusBar Methods

CXTPStatusBar Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBar Methods
Class

CXTPStatusBar Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawStretch | Draws the stretch gripper of the status bar.
Public Methods
Public Methods
Public Method | Description
AddControl | Call this member function to add a control to an indicator pane.
AddIndicator |
CommandToIndex | Gets the indicator index for a given ID. The index of the first indicator is 0
Create | Creates a status bar (a child window) and associates it with the CStatusBar object. Also sets the initial font and sets the status bar's height to a default value.
CreateEx | Call this function to create a status bar
DrawPaneEntry | This method is called to draw a single pane of the status bar.
EnableCustomization | Call this method to enable/disable customization of the statusbar
FindPane | Call this member function to find the pane for the given Identifier.
GetDrawDisabledText | Call this member to determine if paint manager draw disabled text.
GetImageManager | Call this member to retrieve the image manager of the image manager.
GetItemID | Returns the ID of the indicator specified by nIndex
GetItemRect | Copies the coordinates of the indicator specified by nIndex into the structure pointed to by lpRect. Coordinates are in pixels relative to the upper-left corner of the status bar.
GetPaintManager | Retrieves the paint manager.
GetPane | Call this member function to get the pane information for the given index.
GetPaneCount | Call this member function to return the number of panes that are created for the status bar.
GetPaneInfo | Sets nID, nStyle, and cxWidth to the ID, style, and width of the indicator pane at the location specified by nIndex.
GetPaneStyle | Call this member function to retrieve the style of a status bar's pane. A pane's style determines how the pane appears.
GetPaneText |
GetStatusBarCtrl | This member function allows direct access to the underlying common control
GetToolTipContext | Call this method to get tooltip context pointer.
GetVisiblePaneCount | Calculates total number of visible panes.
HitTest | Call this function to determine which pane, if any, is at the specified screen position.
PositionControls | This member function is called by the status bar to reposition pane item controls.
RemoveAll | Call this member function to remove all indicators.
RemoveAt | Call this member function to remove an indicator pane from the status bar.
RemoveIndicator | Call this member function to remove an indicator pane from the status bar.
SetCommandBars | Call this member to set the command bar's object.
SetDrawDisabledText | Call this member to draw disabled text.
SetFont | Call this method to set font for status bar
SetIndicators | Sets each indicator's ID to the value specified by the corresponding element of the array lpIDArray, loads the string resource specified by each ID, and sets the indicator's text to the string.
SetPaneInfo | Sets the specified indicator pane to a new ID, style, and width.
SetPaneStyle | Call this member function to set the style of a status bar's pane. A pane's style determines how the pane appears.
SetPaneText | Sets the pane text to the string pointed to by lpszNewText.
SetPaneWidth | Call this member function to set the width for an indicator pane.


CXTPStatusBar::AddControl Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::AddControl Method

Call this member function to add a control to an indicator pane.

BOOL AddControl(
    CWnd* pWnd,
    UINT nID,
    BOOL bAutoDelete = TRUE
);
Parameters

pWnd
Points to a control window.
nID
ID of the indicator pane.
bAutoDelete
TRUE if the control is to be deleted when destroyed.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPStatusBar Methods


AddIndicator Method

CXTPStatusBar Methods
AddIndicator Method
Overload List
Methods
Method | Description
CXTPStatusBar::AddIndicator (CXTPStatusBarPane*, UINT, int) | Call this member function to add an indicator pane to the status bar.
CXTPStatusBar::AddIndicator (UINT, int) | Call this member function to add an indicator pane to the status bar.
Group

CXTPStatusBar Methods


CXTPStatusBar::AddIndicator Method (UINT, int)

AddIndicator Method, CXTPStatusBar Class
CXTPStatusBar::AddIndicator Method (UINT, int)

Call this member function to add an indicator pane to the status bar.

CXTPStatusBarPane* AddIndicator(
    UINT nID,
    int nIndex = -1
);
CXTPStatusBarPane* AddIndicator(
    CXTPStatusBarPane* pPane,
    UINT nID,
    int nIndex = -1
);
Parameters

nID
ID of the indicator pane.
nIndex
Index of the indicator pane.
pPane
New CXTPStatusBarPane object

Returns

CXTPStatusBarPane pointer if successful, otherwise returns NULL.

Group

AddIndicator Method


CXTPStatusBar::CommandToIndex Method

CXTPStatusBar Methods, CXTPStatusBar Class, See Also
CXTPStatusBar::CommandToIndex Method

Gets the indicator index for a given ID. The index of the first indicator is 0

int CommandToIndex(
    UINT nIDFind
) const;
Parameters

nIDFind
String ID of the indicator whose index is to be retrieved

Returns

The index of the indicator if successful; -1 if not successful.

See Also

GetItemID

Group

CXTPStatusBar Methods


CXTPStatusBar::Create Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::Create Method

Creates a status bar (a child window) and associates it with the CStatusBar object. Also sets the initial font and sets the status bar's height to a default value.

BOOL Create(
    CWnd* pParentWnd,
    DWORD dwStyle = WS_CHILD | WS_VISIBLE | CBRS_BOTTOM | WS_CLIPCHILDREN | WS_CLIPSIBLINGS,
    UINT nID = AFX_IDW_STATUS_BAR
);
Parameters

pParentWnd
Pointer to the CWnd object whose Windows window is the parent of the status bar.
dwStyle
The status-bar style. In addition to the standard Windows styles, these styles are supported
nID
The toolbar's child-window ID

Returns

Nonzero if successful; otherwise 0.

Group

CXTPStatusBar Methods


CXTPStatusBar::CreateEx Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::CreateEx Method

Call this function to create a status bar

BOOL CreateEx(
    CWnd* pParentWnd,
    DWORD dwCtrlStyle = 0,
    DWORD dwStyle = WS_CHILD | WS_VISIBLE | CBRS_BOTTOM,
    UINT nID = AFX_IDW_STATUS_BAR
);
Parameters

pParentWnd
Pointer to the CWnd object whose Windows window is the parent of the status bar.
dwCtrlStyle
Additional styles for the creation of the embedded CStatusBarCtrl object.
dwStyle
The status-bar style
nID
The status bar's child-window ID.

Returns

Nonzero if successful; otherwise 0.

Group

CXTPStatusBar Methods


CXTPStatusBar::DrawPaneEntry Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::DrawPaneEntry Method

This method is called to draw a single pane of the status bar.

virtual void DrawPaneEntry(
    CDC* pDC,
    int nIndex,
    CRect rcItem
);
Parameters

pDC
Pointer to a valid device context
nIndex
Index of the pane to draw.
rcItem
Bounding rectangle of the pane

Group

CXTPStatusBar Methods


CXTPStatusBar::DrawStretch Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::DrawStretch Method

Draws the stretch gripper of the status bar.

virtual void DrawStretch(
    CDC* pDC,
    CRect& rcClient
);
Parameters

pDC
Pointer to a valid device context.
rcClient
Client rectangle.

Group

CXTPStatusBar Methods


CXTPStatusBar::EnableCustomization Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::EnableCustomization Method

Call this method to enable/disable customization of the statusbar

void EnableCustomization(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable customization.

Group

CXTPStatusBar Methods


CXTPStatusBar::FindPane Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::FindPane Method

Call this member function to find the pane for the given Identifier.

CXTPStatusBarPane* FindPane(
    UINT nID
) const;
Parameters

nID
Identifier of the indicator pane.

Returns

A pointer to an CXTPStatusBarPane class.

Group

CXTPStatusBar Methods


CXTPStatusBar::GetDrawDisabledText Method

CXTPStatusBar Methods, CXTPStatusBar Class, Body Source
CXTPStatusBar::GetDrawDisabledText Method

Call this member to determine if paint manager draw disabled text.

BOOL GetDrawDisabledText() const;
Body Source
BOOL CXTPStatusBar::GetDrawDisabledText() const {
    return m_bDrawDisabledText;
}
Group

CXTPStatusBar Methods


CXTPStatusBar::GetImageManager Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::GetImageManager Method

Call this member to retrieve the image manager of the image manager.

CXTPImageManager* GetImageManager() const;
Returns

A pointer to a CXTPImageManager object

Group

CXTPStatusBar Methods


CXTPStatusBar::GetItemID Method

CXTPStatusBar Methods, CXTPStatusBar Class, See Also
CXTPStatusBar::GetItemID Method

Returns the ID of the indicator specified by nIndex

UINT GetItemID(
    int nIndex
) const;
Parameters

nIndex
Index of the indicator whose ID is to be retrieved.

Returns

The ID of the indicator specified by nIndex.

See Also

CommandToIndex

Group

CXTPStatusBar Methods


CXTPStatusBar::GetItemRect Method

CXTPStatusBar Methods, CXTPStatusBar Class, See Also
CXTPStatusBar::GetItemRect Method

Copies the coordinates of the indicator specified by nIndex into the structure pointed to by lpRect. Coordinates are in pixels relative to the upper-left corner of the status bar.

void GetItemRect(
    int nIndex,
    LPRECT lpRect
) const;
Parameters

nIndex
Index of the indicator whose rectangle coordinates are to be retrieved.
lpRect
Points to aRECT structure or a CRect object that will receive the coordinates of the indicator specified by nIndex.

See Also

GetPaneInfo, CommandToIndex

Group

CXTPStatusBar Methods


CXTPStatusBar::GetPaintManager Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::GetPaintManager Method

Retrieves the paint manager.

CXTPPaintManager* GetPaintManager() const;
Returns

A pointer to a CXTPPaintManager object.

Group

CXTPStatusBar Methods


CXTPStatusBar::GetPane Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::GetPane Method

Call this member function to get the pane information for the given index.

CXTPStatusBarPane* GetPane(
    int nIndex
) const;
Parameters

nIndex
Index of the indicator pane.

Returns

A pointer to an CXTPStatusBarPane class.

Group

CXTPStatusBar Methods


CXTPStatusBar::GetPaneCount Method

CXTPStatusBar Methods, CXTPStatusBar Class, Body Source
CXTPStatusBar::GetPaneCount Method

Call this member function to return the number of panes that are created for the status bar.

int GetPaneCount() const;
Returns

An integer value that represents the number of panes for the status bar.

Body Source
int CXTPStatusBar::GetPaneCount() const {
    return (int)m_arrPanes.GetSize();
}
Group

CXTPStatusBar Methods


CXTPStatusBar::GetPaneInfo Method

CXTPStatusBar Methods, CXTPStatusBar Class, See Also
CXTPStatusBar::GetPaneInfo Method

Sets nID, nStyle, and cxWidth to the ID, style, and width of the indicator pane at the location specified by nIndex.

void GetPaneInfo(
    int nIndex,
    UINT& nID,
    UINT& nStyle,
    int& cxWidth
) const;
Parameters

nIndex
Index of the pane whose information is to be retrieved.
nID
Reference to a UINT that is set to the ID of the pane
nStyle
Reference to a UINT that is set to the style of the pane.
cxWidth
Reference to an integer that is set to the width of the pane

See Also

SetPaneInfo, GetItemRect

Group

CXTPStatusBar Methods


CXTPStatusBar::GetPaneStyle Method

CXTPStatusBar Methods, CXTPStatusBar Class, See Also
CXTPStatusBar::GetPaneStyle Method

Call this member function to retrieve the style of a status bar's pane. A pane's style determines how the pane appears.

UINT GetPaneStyle(
    int nIndex
) const;
Parameters

nIndex
Index of the pane whose style is to be retrieved.

Returns

The style of the status-bar pane specified by nIndex

See Also

SetPaneStyle

Group

CXTPStatusBar Methods


GetPaneText Method

CXTPStatusBar Methods
GetPaneText Method
Overload List
Methods
Method | Description
CXTPStatusBar::GetPaneText (int) | Call this member function to retrieve the text that appears in a status-bar pane. The second form of this member function fills a CString object with the string text.
CXTPStatusBar::GetPaneText (int, CString&) | Call this member function to retrieve the text that appears in a status-bar pane. The second form of this member function fills a CString object with the string text.
Group

CXTPStatusBar Methods


CXTPStatusBar::GetPaneText Method (int)

GetPaneText Method, CXTPStatusBar Class, See Also
CXTPStatusBar::GetPaneText Method (int)

Call this member function to retrieve the text that appears in a status-bar pane. The second form of this member function fills a CString object with the string text.

CString GetPaneText(
    int nIndex
) const;
void GetPaneText(
    int nIndex,
    CString& rString
) const;
Parameters

nIndex
Index of the pane whose text is to be retrieved
rString
A reference to a CString object that contains the text to be retrieved.

See Also

SetPaneText

Group

GetPaneText Method


CXTPStatusBar::GetStatusBarCtrl Method

CXTPStatusBar Methods, CXTPStatusBar Class, Body Source
CXTPStatusBar::GetStatusBarCtrl Method

This member function allows direct access to the underlying common control

CStatusBarCtrl& GetStatusBarCtrl() const;
Returns

Contains a reference to a CStatusBarCtrl object.

Body Source
CStatusBarCtrl& CXTPStatusBar::GetStatusBarCtrl() const{
    return *(CStatusBarCtrl*)this;
}
Group

CXTPStatusBar Methods


CXTPStatusBar::GetToolTipContext Method

CXTPStatusBar Methods, CXTPStatusBar Class, Body Source
CXTPStatusBar::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Body Source
CXTPToolTipContext* CXTPStatusBar::GetToolTipContext() const {
    return m_pToolTipContext;
}
Group

CXTPStatusBar Methods


CXTPStatusBar::GetVisiblePaneCount Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::GetVisiblePaneCount Method

Calculates total number of visible panes.

int GetVisiblePaneCount() const;
Returns

Total number of panes currently visible.

Group

CXTPStatusBar Methods


CXTPStatusBar::HitTest Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::HitTest Method

Call this function to determine which pane, if any, is at the specified screen position.

CXTPStatusBarPane* HitTest(
    CPoint pt,
    CRect* lpRect = NULL
) const;
Parameters

pt
Point to be tested.
lpRect
Returns rectangle of the item under point pt.

Returns

CXTPStatusBarPane pointer, or returns NULL if no pane is at the specified position.

Group

CXTPStatusBar Methods


CXTPStatusBar::PositionControls Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::PositionControls Method

This member function is called by the status bar to reposition pane item controls.

void PositionControls();
Group

CXTPStatusBar Methods


CXTPStatusBar::RemoveAll Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::RemoveAll Method

Call this member function to remove all indicators.

void RemoveAll();
Group

CXTPStatusBar Methods


CXTPStatusBar::RemoveAt Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::RemoveAt Method

Call this member function to remove an indicator pane from the status bar.

BOOL RemoveAt(
    int nIndex
);
Parameters

nIndex
Index of the indicator pane.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPStatusBar Methods


CXTPStatusBar::RemoveIndicator Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::RemoveIndicator Method

Call this member function to remove an indicator pane from the status bar.

BOOL RemoveIndicator(
    UINT nID
);
Parameters

nID
ID of the indicator pane.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPStatusBar Methods


CXTPStatusBar::SetCommandBars Method

CXTPStatusBar Methods, CXTPStatusBar Class, Body Source
CXTPStatusBar::SetCommandBars Method

Call this member to set the command bar's object.

void SetCommandBars(
    CXTPCommandBars* pCommandBars
);
Parameters

pCommandBars
CXTPCommandBars to be set.

Body Source
void CXTPStatusBar::SetCommandBars(CXTPCommandBars* pCommandBars) {
    m_pCommandBars = pCommandBars;
}
Group

CXTPStatusBar Methods


CXTPStatusBar::SetDrawDisabledText Method

CXTPStatusBar Methods, CXTPStatusBar Class, Body Source
CXTPStatusBar::SetDrawDisabledText Method

Call this member to draw disabled text.

void SetDrawDisabledText(
    BOOL bDraw
);
Parameters

bDraw
TRUE to draw disabled text, FALSE otherwise.

Body Source
void CXTPStatusBar::SetDrawDisabledText(BOOL bDraw) {
    m_bDrawDisabledText = bDraw;
}
Group

CXTPStatusBar Methods


CXTPStatusBar::SetFont Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::SetFont Method

Call this method to set font for status bar

void SetFont(
    CFont* pFont,
    BOOL bRedraw = TRUE
);
Parameters

pFont
Font to set
bRedraw
TRUE to redraw status bar

Group

CXTPStatusBar Methods


CXTPStatusBar::SetIndicators Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::SetIndicators Method

Sets each indicator's ID to the value specified by the corresponding element of the array lpIDArray, loads the string resource specified by each ID, and sets the indicator's text to the string.

BOOL SetIndicators(
    const UINT* lpIDArray,
    int nIDCount
);
Parameters

lpIDArray
Pointer to an array of IDs.
nIDCount
Number of elements in the array pointed to by lpIDArray.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPStatusBar Methods


CXTPStatusBar::SetPaneInfo Method

CXTPStatusBar Methods, CXTPStatusBar Class, See Also
CXTPStatusBar::SetPaneInfo Method

Sets the specified indicator pane to a new ID, style, and width.

void SetPaneInfo(
    int nIndex,
    UINT nID,
    UINT nStyle,
    int cxWidth
);
Parameters

nIndex
Index of the indicator pane whose style is to be set.
nID
New ID for the indicator pane
nStyle
New style for the indicator pane
cxWidth
New width for the indicator pane

See Also

GetPaneInfo

Group

CXTPStatusBar Methods


CXTPStatusBar::SetPaneStyle Method

CXTPStatusBar Methods, CXTPStatusBar Class, See Also
CXTPStatusBar::SetPaneStyle Method

Call this member function to set the style of a status bar's pane. A pane's style determines how the pane appears.

void SetPaneStyle(
    int nIndex,
    UINT nStyle
);
Parameters

nIndex
Index of the pane whose style is to be set.
nStyle
Style of the pane whose style is to be set

See Also

GetPaneStyle

Group

CXTPStatusBar Methods


CXTPStatusBar::SetPaneText Method

CXTPStatusBar Methods, CXTPStatusBar Class, See Also
CXTPStatusBar::SetPaneText Method

Sets the pane text to the string pointed to by lpszNewText.

BOOL SetPaneText(
    int nIndex,
    const CString& lpszNewText
);
Parameters

nIndex
Index of the pane whose text is to be set.
lpszNewText
Pointer to the new pane text
bUpdate
If TRUE, the pane is invalidated after the text is set.

Returns

Nonzero if successful; otherwise 0.

See Also

GetPaneText

Group

CXTPStatusBar Methods


CXTPStatusBar::SetPaneWidth Method

CXTPStatusBar Methods, CXTPStatusBar Class
CXTPStatusBar::SetPaneWidth Method

Call this member function to set the width for an indicator pane.

void SetPaneWidth(
    int nIndex,
    int cxText
);
Parameters

nIndex
Index of the indicator pane.
cxText
New width for the indicator pane.

Group

CXTPStatusBar Methods


CXTPStatusBar Constructors

CXTPStatusBar Class, Legend, Public Methods
CXTPStatusBar Constructors
Class

CXTPStatusBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPStatusBar | Constructs a CXTPStatusBar object


CXTPStatusBar::CXTPStatusBar Constructor

CXTPStatusBar Constructors, CXTPStatusBar Class
CXTPStatusBar::CXTPStatusBar Constructor

Constructs a CXTPStatusBar object

CXTPStatusBar();
Group

CXTPStatusBar Constructors


CXTPStatusBar Destructors

CXTPStatusBar Class, Legend, Public Methods
CXTPStatusBar Destructors
Class

CXTPStatusBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPStatusBar | Destroys a CXTPStatusBar object, handles cleanup and deallocation


CXTPStatusBar::~CXTPStatusBar Destructor

CXTPStatusBar Destructors, CXTPStatusBar Class
CXTPStatusBar::~CXTPStatusBar Destructor

Destroys a CXTPStatusBar object, handles cleanup and deallocation

virtual ~CXTPStatusBar();
Group

CXTPStatusBar Destructors


CXTPStatusBarPane Class

XTPStatusBar.h, Classes, Legend, Members, Topics, CXTPStatusBarPane Data Members, CXTPStatusBarPane Methods, CXTPStatusBarPane Constructors, CXTPStatusBarPane Destructors, CXTPStatusBarPane Constructors, CXTPStatusBarPane Data Members, CXTPStatusBarPane Destructors, CXTPStatusBarPane Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarPane Class

CXTPStatusBarPane is a CCmdTarget derived class. It represents single pane of status bar

Class Hierarchy

class CXTPStatusBarPane;
File

XTPStatusBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPStatusBarPane Constructors
CXTPStatusBarPane Constructors | Description
CXTPStatusBarPane | Constructs a CXTPStatusBarPane object
CXTPStatusBarPane Data Members
CXTPStatusBarPane Data Members | Description
m_bAutoDeleteWnd | TRUE to auto delete child.
m_bButton | TRUE if pane is clickable button
m_bPressed | TRUE if button was pressed
m_clrBackground | Background color
m_clrText | Text color
m_cxText | Width of the string area in pixels.
m_dwHideFlags | TRUE if pane is visible
m_fntText | Font of an item text
m_hWndPane | Child handle
m_nAlignment | Alignment of the item.
m_nIconIndex | Icon index of the pane
m_nID | IDC of indicator: 0 => normal text area.
m_nIndex | Index of the item
m_nStyle | Style flags (SBPS_*).
m_pStatusBar | Parent StatusBar object
m_rcMargins | Margins of the pane
m_rcPadding | Margins of the pane
m_strText | Text in the pane.
m_strToolTip | Tooltip text for the item..
CXTPStatusBarPane Destructors
CXTPStatusBarPane Destructors | Description
~CXTPStatusBarPane | Destroys a CXTPStatusBarPane object, handles cleanup and deallocation
CXTPStatusBarPane Methods
CXTPStatusBarPane Methods | Description
BestFit | Fits the width of the pane to the its text width.
GetBackgroundColor | Call this member to get the background color of an item.
GetIconIndex | Retrieves icon index.
GetID | Call this member function to get the ID of a status bar's pane.
GetImage | This method is called to get image of the pane
GetIndex | Call this member function to get the index of a status bar's pane.
GetMargins | Returns margins for pane entry
GetStatusBar | Call this member function to get parent status bar object
GetStyle | Call this member function to get the style of a status bar's pane.
GetText | Call this member to get the text caption to the pane.
GetTextAlignment | Call this member function to get the alignment of an item text.
GetTextColor | Call this member function to get the color of an item text.
GetTextFont | Call this member function to set the font of an item text.
GetTooltip | Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.
GetWidth | Call this member to get the width of the pane.
HasBorders | Call this member function to determine if the pane has borders enabled.
IsChecked | Call this member function to determine if the pane button state is checked.
IsVisible | Call this member to determine if the pane is visible.
OnDraw | This method is called to draw pane item. Override it to draw custom pane.
Remove | Call this member function to remove the pane
SetBackgroundColor | Call this member function to set the color of an item background.
SetIconIndex | Call this method to set icon index of item.
SetMargins | Call this method to set margins for pane
SetStyle | Call this member function to set the style of a status bar's pane. A pane's style determines how the pane appears.
SetText | Call this member to set the text caption that is displayed in this pane.
SetTextAlignment | Call this member function to set the alignment of an item text.
SetTextColor | Call this member function to set the color of an item text.
SetTextFont |
SetTooltip | Call this member to set the tooltip for this pane. This is the text that will be displayed when the mouse pointer is positioned over the pane.
SetVisible | Call this member to hide or show the pane.
SetWidth | Call this member to set the width of this pane.


CXTPStatusBarPane Data Members

CXTPStatusBarPane Class, Legend, Protected Data Members
CXTPStatusBarPane Data Members
Class

CXTPStatusBarPane Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoDeleteWnd | TRUE to auto delete child.
m_bButton | TRUE if pane is clickable button
m_bPressed | TRUE if button was pressed
m_clrBackground | Background color
m_clrText | Text color
m_cxText | Width of the string area in pixels.
m_dwHideFlags | TRUE if pane is visible
m_fntText | Font of an item text
m_hWndPane | Child handle
m_nAlignment | Alignment of the item.
m_nIconIndex | Icon index of the pane
m_nID | IDC of indicator: 0 => normal text area.
m_nIndex | Index of the item
m_nStyle | Style flags (SBPS_*).
m_pStatusBar | Parent StatusBar object
m_rcMargins | Margins of the pane
m_rcPadding | Margins of the pane
m_strText | Text in the pane.
m_strToolTip | Tooltip text for the item..


CXTPStatusBarPane::m_bAutoDeleteWnd Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_bAutoDeleteWnd Data Member

TRUE to auto delete child.

BOOL m_bAutoDeleteWnd;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_bButton Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_bButton Data Member

TRUE if pane is clickable button

BOOL m_bButton;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_bPressed Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_bPressed Data Member

TRUE if button was pressed

BOOL m_bPressed;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_clrBackground Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_clrBackground Data Member

Background color

COLORREF m_clrBackground;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_clrText Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_clrText Data Member

Text color

COLORREF m_clrText;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_cxText Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_cxText Data Member

Width of the string area in pixels.

int m_cxText;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_dwHideFlags Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_dwHideFlags Data Member

TRUE if pane is visible

DWORD m_dwHideFlags;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_fntText Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_fntText Data Member

Font of an item text

CFont m_fntText;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_hWndPane Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_hWndPane Data Member

Child handle

HWND m_hWndPane;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_nAlignment Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_nAlignment Data Member

Alignment of the item.

int m_nAlignment;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_nIconIndex Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_nIconIndex Data Member

Icon index of the pane

int m_nIconIndex;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_nID Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_nID Data Member

IDC of indicator: 0 => normal text area.

UINT m_nID;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_nIndex Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_nIndex Data Member

Index of the item

int m_nIndex;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_nStyle Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_nStyle Data Member

Style flags (SBPS_*).

UINT m_nStyle;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_pStatusBar Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_pStatusBar Data Member

Parent StatusBar object

CXTPStatusBar* m_pStatusBar;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_rcMargins Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_rcMargins Data Member

Margins of the pane

CRect m_rcMargins;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_rcPadding Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_rcPadding Data Member

Margins of the pane

CRect m_rcPadding;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_strText Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_strText Data Member

Text in the pane.

CString m_strText;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane::m_strToolTip Data Member

CXTPStatusBarPane Data Members, CXTPStatusBarPane Class
CXTPStatusBarPane::m_strToolTip Data Member

Tooltip text for the item..

CString m_strToolTip;
Group

CXTPStatusBarPane Data Members


CXTPStatusBarPane Methods

CXTPStatusBarPane Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarPane Methods
Class

CXTPStatusBarPane Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnDraw | This method is called to draw pane item. Override it to draw custom pane.
Public Methods
Public Methods
Public Method | Description
BestFit | Fits the width of the pane to the its text width.
GetBackgroundColor | Call this member to get the background color of an item.
GetIconIndex | Retrieves icon index.
GetID | Call this member function to get the ID of a status bar's pane.
GetImage | This method is called to get image of the pane
GetIndex | Call this member function to get the index of a status bar's pane.
GetMargins | Returns margins for pane entry
GetStatusBar | Call this member function to get parent status bar object
GetStyle | Call this member function to get the style of a status bar's pane.
GetText | Call this member to get the text caption to the pane.
GetTextAlignment | Call this member function to get the alignment of an item text.
GetTextColor | Call this member function to get the color of an item text.
GetTextFont | Call this member function to set the font of an item text.
GetTooltip | Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.
GetWidth | Call this member to get the width of the pane.
HasBorders | Call this member function to determine if the pane has borders enabled.
IsChecked | Call this member function to determine if the pane button state is checked.
IsVisible | Call this member to determine if the pane is visible.
Remove | Call this member function to remove the pane
SetBackgroundColor | Call this member function to set the color of an item background.
SetIconIndex | Call this method to set icon index of item.
SetMargins | Call this method to set margins for pane
SetStyle | Call this member function to set the style of a status bar's pane. A pane's style determines how the pane appears.
SetText | Call this member to set the text caption that is displayed in this pane.
SetTextAlignment | Call this member function to set the alignment of an item text.
SetTextColor | Call this member function to set the color of an item text.
SetTextFont |
SetTooltip | Call this member to set the tooltip for this pane. This is the text that will be displayed when the mouse pointer is positioned over the pane.
SetVisible | Call this member to hide or show the pane.
SetWidth | Call this member to set the width of this pane.


CXTPStatusBarPane::BestFit Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::BestFit Method

Fits the width of the pane to the its text width.

void BestFit();
Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetBackgroundColor Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetBackgroundColor Method

Call this member to get the background color of an item.

COLORREF GetBackgroundColor() const;
Returns

The background color of a item.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetIconIndex Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::GetIconIndex Method

Retrieves icon index.

int GetIconIndex() const;
Returns

Icon index.

See Also

SetIconIndex

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetID Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetID Method

Call this member function to get the ID of a status bar's pane.

UINT GetID() const;
Returns

ID of the indicator pane.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetImage Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetImage Method

This method is called to get image of the pane

virtual CXTPImageManagerIcon* GetImage() const;
Returns

CXTPImageManagerIcon Pointer to be drawn.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetIndex Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetIndex Method

Call this member function to get the index of a status bar's pane.

int GetIndex() const;
Returns

Index of the indicator pane.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetMargins Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::GetMargins Method

Returns margins for pane entry

CRect GetMargins() const;
See Also

SetMargins

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetStatusBar Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetStatusBar Method

Call this member function to get parent status bar object

CXTPStatusBar* GetStatusBar() const;
Returns

Pointer to parent status bar object

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetStyle Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetStyle Method

Call this member function to get the style of a status bar's pane.

UINT GetStyle() const;
Returns

Style of the indicator pane.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetText Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::GetText Method

Call this member to get the text caption to the pane.

CString GetText() const;
Returns

Text caption of pane. This is the text displayed in the pane

See Also

SetText

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetTextAlignment Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetTextAlignment Method

Call this member function to get the alignment of an item text.

int GetTextAlignment() const;
Returns

The alignment style of an item text.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetTextColor Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetTextColor Method

Call this member function to get the color of an item text.

COLORREF GetTextColor() const;
Returns

A COLORREF object that represents the color of an item text.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetTextFont Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::GetTextFont Method

Call this member function to set the font of an item text.

virtual CFont* GetTextFont();
Returns

Pointer to CFont object.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetTooltip Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::GetTooltip Method

Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.

CString GetTooltip() const;
Returns

The tooltip displayed when the mouse if over the pane.

See Also

SetTooltip

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::GetWidth Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::GetWidth Method

Call this member to get the width of the pane.

virtual int GetWidth();
Returns

Current width of the pane

See Also

SetWidth

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::HasBorders Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarPane::HasBorders Method

Call this member function to determine if the pane has borders enabled.

BOOL HasBorders() const;
Returns

TRUE if the pane has borders, otherwise FALSE. If the pane is a button, the return value is always FALSE since buttons will handle drawing their own borders.

See Also

IsButton

Body Source
BOOL CXTPStatusBarPane::HasBorders() const {
    return ((m_nStyle & SBPS_NOBORDERS) == 0);
}
Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::IsChecked Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::IsChecked Method

Call this member function to determine if the pane button state is checked.

BOOL IsChecked() const;
Returns

TRUE if the pane button is checked, otherwise FALSE.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::IsVisible Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::IsVisible Method

Call this member to determine if the pane is visible.

BOOL IsVisible() const;
Returns

TRUE if the tab is visible, FALSE otherwise.

See Also

SetVisible

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::OnDraw Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::OnDraw Method

This method is called to draw pane item. Override it to draw custom pane.

virtual void OnDraw(
    CDC* pDC,
    CRect rcItem
);
Parameters

pDC
Pointer to a valid device context
rcItem
Item rectangle

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::Remove Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::Remove Method

Call this member function to remove the pane

void Remove();
Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetBackgroundColor Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::SetBackgroundColor Method

Call this member function to set the color of an item background.

void SetBackgroundColor(
    COLORREF clrBackground
);
Parameters

clrBackground
COLORREF object that represents the background color of an item text.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetIconIndex Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::SetIconIndex Method

Call this method to set icon index of item.

void SetIconIndex(
    int nIconIndex
);
Parameters

nIconIndex
Icon index to be set.

See Also

GetIconIndex

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetMargins Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::SetMargins Method

Call this method to set margins for pane

void SetMargins(
    int nLeft,
    int nTop,
    int nRight,
    int nBottom
);
Parameters

nLeft
Left margin
nTop
Top margin
nRight
Right margin
nBottom
Bottom margin

See Also

GetMargins

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetStyle Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::SetStyle Method

Call this member function to set the style of a status bar's pane. A pane's style determines how the pane appears.

void SetStyle(
    UINT nStyle
);
Parameters

nStyle
Style of the pane whose style is to be set

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetText Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::SetText Method

Call this member to set the text caption that is displayed in this pane.

void SetText(
    LPCTSTR lpszText
);
Parameters

lpszText
Text caption of the pane.

See Also

GetText

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetTextAlignment Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::SetTextAlignment Method

Call this member function to set the alignment of an item text.

void SetTextAlignment(
    int nAlign
);
Parameters

nAlign
The alignment style of an item text.

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetTextColor Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class
CXTPStatusBarPane::SetTextColor Method

Call this member function to set the color of an item text.

void SetTextColor(
    COLORREF clrText
);
Parameters

clrText
COLORREF object that represents the color of an item text.

Group

CXTPStatusBarPane Methods


SetTextFont Method

CXTPStatusBarPane Methods
SetTextFont Method
Overload List
Methods
Method | Description
CXTPStatusBarPane::SetTextFont (CFont*) | Call this member function to set the font of an item text.
CXTPStatusBarPane::SetTextFont (PLOGFONT) | Call this member function to set the font of an item text.
Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetTextFont Method (CFont*)

SetTextFont Method, CXTPStatusBarPane Class
CXTPStatusBarPane::SetTextFont Method (CFont*)

Call this member function to set the font of an item text.

void SetTextFont(
    CFont* pFntText
);
void SetTextFont(
    PLOGFONT pLogfText
);
Parameters

pFntText
point to CFont object.
pLogfText
point to LOGFONT structure.

Group

SetTextFont Method


CXTPStatusBarPane::SetTooltip Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::SetTooltip Method

Call this member to set the tooltip for this pane. This is the text that will be displayed when the mouse pointer is positioned over the pane.

void SetTooltip(
    LPCTSTR lpszTooltip
);
Parameters

lpszTooltip
Tooltip to set for this tab.

See Also

GetTooltip

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetVisible Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::SetVisible Method

Call this member to hide or show the pane.

void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show the tab, FALSE to hide the tab.

See Also

IsVisible

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane::SetWidth Method

CXTPStatusBarPane Methods, CXTPStatusBarPane Class, See Also
CXTPStatusBarPane::SetWidth Method

Call this member to set the width of this pane.

void SetWidth(
    int nWidth
);
Parameters

nWidth
new width to be set

See Also

GetWidth

Group

CXTPStatusBarPane Methods


CXTPStatusBarPane Constructors

CXTPStatusBarPane Class, Legend, Public Methods
CXTPStatusBarPane Constructors
Class

CXTPStatusBarPane Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPStatusBarPane | Constructs a CXTPStatusBarPane object


CXTPStatusBarPane::CXTPStatusBarPane Constructor

CXTPStatusBarPane Constructors, CXTPStatusBarPane Class
CXTPStatusBarPane::CXTPStatusBarPane Constructor

Constructs a CXTPStatusBarPane object

CXTPStatusBarPane();
Group

CXTPStatusBarPane Constructors


CXTPStatusBarPane Destructors

CXTPStatusBarPane Class, Legend, Public Methods
CXTPStatusBarPane Destructors
Class

CXTPStatusBarPane Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPStatusBarPane | Destroys a CXTPStatusBarPane object, handles cleanup and deallocation


CXTPStatusBarPane::~CXTPStatusBarPane Destructor

CXTPStatusBarPane Destructors, CXTPStatusBarPane Class
CXTPStatusBarPane::~CXTPStatusBarPane Destructor

Destroys a CXTPStatusBarPane object, handles cleanup and deallocation

virtual ~CXTPStatusBarPane();
Group

CXTPStatusBarPane Destructors


CXTPStatusBarProgressPane Class

XTPStatusBar.h, Classes, Legend, Members, Topics, CXTPStatusBarProgressPane Methods, CXTPStatusBarProgressPane Constructors, CXTPStatusBarProgressPane Destructors, CXTPStatusBarProgressPane Constructors, CXTPStatusBarProgressPane Destructors, CXTPStatusBarProgressPane Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarProgressPane Class

CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class. CXTPStatusBarProgressPane works with CXTStatusBar and allows you to create progress bar in your status bar area.

Class Hierarchy

class CXTPStatusBarProgressPane : public CXTPStatusBarPane, public CXTPProgressBase;
File

XTPStatusBar.h

Group

Classes

Legend
Method
protected
virtual
CXTPStatusBarProgressPane Constructors
CXTPStatusBarProgressPane Constructors | Description
CXTPStatusBarProgressPane | Constructs a CXTPStatusBarProgressPane object
CXTPStatusBarProgressPane Destructors
CXTPStatusBarProgressPane Destructors | Description
~CXTPStatusBarProgressPane | Destroys a CXTPStatusBarProgressPane object, handles cleanup and deallocation
CXTPStatusBarProgressPane Methods
CXTPStatusBarProgressPane Methods | Description
GetProgressPaintManager | This method is called to retrieve pointer to CXTPProgressPaintManager
GetProgressRect | This method is called to get bounding rectangle of progressbar
OnDraw | This method is called to draw pane item. Override it to draw custom pane.
RedrawProgress | This method is called to redraw progress bar


CXTPStatusBarProgressPane Methods

CXTPStatusBarProgressPane Class, Legend, Protected Methods
CXTPStatusBarProgressPane Methods
Class

CXTPStatusBarProgressPane Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetProgressPaintManager | This method is called to retrieve pointer to CXTPProgressPaintManager
GetProgressRect | This method is called to get bounding rectangle of progressbar
OnDraw | This method is called to draw pane item. Override it to draw custom pane.
RedrawProgress | This method is called to redraw progress bar


CXTPStatusBarProgressPane::GetProgressPaintManager Method

CXTPStatusBarProgressPane Methods, CXTPStatusBarProgressPane Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarProgressPane::GetProgressPaintManager Method

This method is called to retrieve pointer to CXTPProgressPaintManager

virtual CXTPProgressPaintManager* GetProgressPaintManager() const;
Group

CXTPStatusBarProgressPane Methods


CXTPStatusBarProgressPane::GetProgressRect Method

CXTPStatusBarProgressPane Methods, CXTPStatusBarProgressPane Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarProgressPane::GetProgressRect Method

This method is called to get bounding rectangle of progressbar

virtual CRect GetProgressRect();
Group

CXTPStatusBarProgressPane Methods


CXTPStatusBarProgressPane::OnDraw Method

CXTPStatusBarProgressPane Methods, CXTPStatusBarProgressPane Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarProgressPane::OnDraw Method

This method is called to draw pane item. Override it to draw custom pane.

virtual void OnDraw(
    CDC* pDC,
    CRect rcItem
);
Parameters

pDC
Pointer to a valid device context
rcItem
Item rectangle

Group

CXTPStatusBarProgressPane Methods


CXTPStatusBarProgressPane::RedrawProgress Method

CXTPStatusBarProgressPane Methods, CXTPStatusBarProgressPane Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarProgressPane::RedrawProgress Method

This method is called to redraw progress bar

virtual void RedrawProgress();
Group

CXTPStatusBarProgressPane Methods


CXTPStatusBarProgressPane Constructors

CXTPStatusBarProgressPane Class, Legend, Public Methods
CXTPStatusBarProgressPane Constructors
Class

CXTPStatusBarProgressPane Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPStatusBarProgressPane | Constructs a CXTPStatusBarProgressPane object


CXTPStatusBarProgressPane::CXTPStatusBarProgressPane Constructor

CXTPStatusBarProgressPane Constructors, CXTPStatusBarProgressPane Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarProgressPane::CXTPStatusBarProgressPane Constructor

Constructs a CXTPStatusBarProgressPane object

CXTPStatusBarProgressPane();
Group

CXTPStatusBarProgressPane Constructors


CXTPStatusBarProgressPane Destructors

CXTPStatusBarProgressPane Class, Legend, Public Methods
CXTPStatusBarProgressPane Destructors
Class

CXTPStatusBarProgressPane Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPStatusBarProgressPane | Destroys a CXTPStatusBarProgressPane object, handles cleanup and deallocation


CXTPStatusBarProgressPane::~CXTPStatusBarProgressPane Destructor

CXTPStatusBarProgressPane Destructors, CXTPStatusBarProgressPane Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarProgressPane::~CXTPStatusBarProgressPane Destructor

Destroys a CXTPStatusBarProgressPane object, handles cleanup and deallocation

~CXTPStatusBarProgressPane();
Group

CXTPStatusBarProgressPane Destructors


CXTPStatusBarScrollBarPane Class

XTPStatusBar.h, Classes, Legend, Members, Topics, CXTPStatusBarScrollBarPane Methods, CXTPStatusBarScrollBarPane Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarScrollBarPane Class

CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class. CXTPStatusBarScrollBarPane works with CXTStatusBar and allows you to create themed ScrollBar in your status bar area.

Class Hierarchy

class CXTPStatusBarScrollBarPane : public CXTPStatusBarPane, public CXTPScrollBase;
File

XTPStatusBar.h

Group

Classes

Legend
Method
CXTPStatusBarScrollBarPane Methods
CXTPStatusBarScrollBarPane Methods | Description
SetPos | Call this method to set position of scrollbar
SetTooltipPart | Call this method to set tooltip for scroll part of scrollbar.


CXTPStatusBarScrollBarPane Methods

CXTPStatusBarScrollBarPane Class, Legend, Public Methods
CXTPStatusBarScrollBarPane Methods
Class

CXTPStatusBarScrollBarPane Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetPos | Call this method to set position of scrollbar
SetTooltipPart | Call this method to set tooltip for scroll part of scrollbar.


CXTPStatusBarScrollBarPane::SetPos Method

CXTPStatusBarScrollBarPane Methods, CXTPStatusBarScrollBarPane Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarScrollBarPane::SetPos Method

Call this method to set position of scrollbar

void SetPos(
    int nValue
);
Parameters

nValue
Scrollbar position to be set

Group

CXTPStatusBarScrollBarPane Methods


CXTPStatusBarScrollBarPane::SetTooltipPart Method

CXTPStatusBarScrollBarPane Methods, CXTPStatusBarScrollBarPane Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPStatusBarScrollBarPane::SetTooltipPart Method

Call this method to set tooltip for scroll part of scrollbar.

void SetTooltipPart(
    int nPart,
    LPCTSTR lpszTooltip
);
Parameters

nPart
Part of scrollbar to set tooltip. Can be XTP_HTSCROLLUP, XTP_HTSCROLLDOWN, XTP_HTSCROLLUPPAGE, XTP_HTSCROLLDOWNPAGE, XTP_HTSCROLLTHUMB
lpszTooltip
Text of tooltip to set

Group

CXTPStatusBarScrollBarPane Methods


CXTPStatusBarSliderPane Class

XTPStatusBar.h, Classes
CXTPStatusBarSliderPane Class

CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class. CXTPStatusBarSliderPane works with CXTStatusBar and allows you to create themed Slider in your status bar area.

Class Hierarchy

class CXTPStatusBarSliderPane : public CXTPStatusBarScrollBarPane;
File

XTPStatusBar.h

Group

Classes


CXTPStatusBarSwitchPane Class

XTPStatusBar.h, Classes
CXTPStatusBarSwitchPane Class

CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class. CXTPStatusBarSwitchPane works with CXTStatusBar and allows you to create switches in your status bar area.

Class Hierarchy

class CXTPStatusBarSwitchPane : public CXTPStatusBarPane;
File

XTPStatusBar.h

Group

Classes


CXTPTabClientWnd Class

XTPTabClientWnd.h, Classes, Legend, Members, Topics, CXTPTabClientWnd Classes, CXTPTabClientWnd Data Members, CXTPTabClientWnd Methods, CXTPTabClientWnd Constructors, CXTPTabClientWnd Destructors, CXTPTabClientWnd Classes, CXTPTabClientWnd Constructors, CXTPTabClientWnd Data Members, CXTPTabClientWnd Destructors, CXTPTabClientWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd Class

CXTPTabClientWnd is a CWnd derived class. It represents a tabbed workspace.

Class Hierarchy

class CXTPTabClientWnd : public CWnd, public CXTPTabManagerAtom;
File

XTPTabClientWnd.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTabClientWnd Classes
CXTPTabClientWnd Classes | Description
CSingleWorkspace | CSingleWorkspace is a CWorkspace derived class. internal used.
CWorkspace | CWorkspace is a CXTPTabManager derived class. internal used.
CXTPTabClientWnd Constructors
CXTPTabClientWnd Constructors | Description
CXTPTabClientWnd | Constructs a CXTPTabClientWnd object
CXTPTabClientWnd Data Members
CXTPTabClientWnd Data Members | Description
m_afterCloseTabPosition | Tab to make active after the currently active tab is closed.
m_arrWorkspace | Array of workspaces.
m_bAllowReorder | TRUE to allow the user to reorder tabs.
m_bAutoTheme | TRUE to auto theme the TabWorkspace.
m_bDelayLock | TRUE to lock update with small delay
m_bEnableGroups | TRUE if TabWorkspace groups are enabled.
m_bForceToRecalc | TRUE to recalculate in next idle event.
m_bHorizSplitting | TRUE if groups devided horizontally
m_bLockReposition | TRUE to lock reposition.
m_bLockUpdate | TRUE to lock update tabs.
m_bRefreshed | TRUE if Refresh currently executed.
m_bShowWorkspace | TRUE to show the TabWorkspace, FALSE to hide the TabWorkspace.
m_bThemedBackColor | TRUE if a themed backcolor will be used.
m_bUpdateContents | TRUE if UpdateContents executed.
m_bUserWorkspace | TRUE if custom workspace used
m_bUseSplitterTracker | If TRUE, splitter trackers are used.
m_dwFlags | Specifies which tab navigation buttons are displayed.
m_hCursorDelete | Remove item cursor handle
m_hCursorHoriz | Horizontal split cursor handle.
m_hCursorNew | New item cursor handle
m_hCursorVert | Vertical split cursor handle.
m_newTabPosition | New tab position.
m_nSplitterSize | Splitter size
m_pActiveWorkspace | Active workspace.
m_pPaintManager | Current paint manager.
m_pParentFrame | pointer to the corresponding parent MDIFrame window
m_pTabWorkspace | Custom workspace
m_pToolTipContext | Tooltip Context.
m_themeCommandBars | Theme set for the TabWorkspace (Can be different from CommandBars if m_bAutoTheme is FALSE)
CXTPTabClientWnd Destructors
CXTPTabClientWnd Destructors | Description
~CXTPTabClientWnd | Destroys a CXTPTabClientWnd object, handles cleanup and deallocation.
CXTPTabClientWnd Methods
CXTPTabClientWnd Methods | Description
AddItem | This member function adds a new tab item for the specified window.
AddWorkspace | Call this member function to add a workspace.
Attach | Attaches the tabbed workspace.
CancelLoop | This member function is called when a loop is canceled.
CheckCommandBarsTheme | If m_bAutoTheme is FALSE, then it checks to see if the theme set for the TabWorkspace is different from the theme set for the CommandBars. If the themes are different, then the TabWorkSpace theme is set to the theme specified in m_themeCommandBars.
ContextMenu | This method shows the context menu for toolbars.
CreateWorkspace | This method is called to create new CWorkspace class, you can override it for custom Workskspace.
Detach | Detaches the tabbed workspace.
EnableToolTips | Call this member function to enable or disable tooltips show
FindIndex | Call this member to find the specified index.
FindItem | Call this member to find the item that corresponds to the specified window.
GetAutoTheme | Call this member to determine if auto themes are used to theme the TabWorkspace.
GetCommandBars | Call this member to get the command bar's object.
GetFlags | Call this member to determine which tab navigation buttons are currently displayed in the tab workspace.
GetItem | Returns an item by its index.
GetItemColor | This member function returns the RGB value for the referenced item text or (COLORREF)-1, if the color was not set.
GetItemCount | Returns the number of items.
GetItemIcon | This member function retrieves the icon of a specific tab.
GetItemText | This member function retrieves the text of a specific tab.
GetItemTooltip | Returns the tooltip associated with the specified item.
GetNewTabPositon | This method is call to determine where new tab must appear.
GetPaintManager | Call this method to retrieve the paint manager.
GetParentFrame | Retrieves the parent frame of the control.
GetSelectedItem | Returns the selected item in the control.
GetToolTipContext | Call this method to get tooltip context pointer.
GetWorkspace | Call this member to return the workspace at the specified index.
GetWorkspaceCount | Call this member to retrieve the current number of workspaces.
HitTest | Call this function to determine which tab, if any, is at the specified screen position.
InitLoop | Call this member function to initialize a loop.
IsAllowReorder | Returns the current reordering allowance.
IsAttached | Determines if a tab workspace is attached.
IsLayoutRTL | Determines if right-to-left mode was set.
IsSplitterTrackerUsed | Call this member to determine if the splitter tracker is used.
IsWorkspaceCommandEnabled | Returns the workspace command mode.
LoadState | Loads previous docking state.
MDIActivate | Call this member function to activate an MDI child window independently of the MDI frame window.
MDIGetActive | Retrieves the current active MDI child window.
MDITile | Call this member to tile child windows in workspace (only if EnableGroups enabled)
OnDraw | This member is called when the client is drawn.
OnFillBackground | This member is called when the background is filled.
OnWorkspaceCommand | Call this method to execute special workspace command
Refresh | Call this method to refresh all the items.
Reposition | Call this method to reposition items.
SaveState | Saves Position state.
ScreenToWorkspace | Converts the screen coordinates of a given point or rectangle on the display to client coordinates.
SetActiveWorkspace | This member functions sets a workspace active.
SetAfterCloseActiveTab | Call this member to set where new tab must appear.
SetAllowReorder | Call this member function to allow or disallow reordering.
SetAutoTheme | Call this member to specify whether auto themes are used for the TabWorkspace.
SetFlags | Call this member to set flags of the tab workspace.
SetLayoutRTL | Call this member to set right-to-left mode.
SetNewTabPosition | Call this member to set where new tab must appear.
SetPaintManager | Call this member to set the specified paint manager.
SetTabWorkspace | Call this method to set custom workspace control.
ShowWorkspace | Call this member function to show or hide the workspace.
UpdateContents | Scan through all MDIChild windows and update corresponding tab items if any changes happened (e.g. window text or active MDIChild).
UpdateFlags | This member function is called to update the status of the TabWorkspace navigation buttons.
UseSplitterTracker | Call this member to use trackers.
WorkspaceToScreen | Converts the workspace coordinates of a given point on the display to screen coordinates.


CXTPTabClientWnd Classes

Classes, CXTPTabClientWnd Class
CXTPTabClientWnd Classes
Classes
Class | Description
CSingleWorkspace | CSingleWorkspace is a CWorkspace derived class. internal used.
CWorkspace | CWorkspace is a CXTPTabManager derived class. internal used.
Class

CXTPTabClientWnd Class


CXTPTabClientWnd::CSingleWorkspace Class

XTPTabClientWnd.h, CXTPTabClientWnd Classes, Legend, Members, Topics, CSingleWorkspace Methods, CSingleWorkspace Destructors, CSingleWorkspace Destructors, CSingleWorkspace Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::CSingleWorkspace Class

CSingleWorkspace is a CWorkspace derived class. internal used.

Class Hierarchy

class CSingleWorkspace : public CWnd, public CWorkspace;
File

XTPTabClientWnd.h

Group

CXTPTabClientWnd Classes

Legend
Method
protected
virtual
CSingleWorkspace Destructors
CSingleWorkspace Destructors | Description
~CSingleWorkspace | Destroys a CSingleWorkspace object, handles cleanup and deallocation
CSingleWorkspace Methods
CSingleWorkspace Methods | Description
GetWindow | This method is called to get window handle of workspace
OnToolHitTest | The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
RedrawControl | Initiates redrawing of the control


CSingleWorkspace Methods

CXTPTabClientWnd::CSingleWorkspace Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CSingleWorkspace Methods
Class

CXTPTabClientWnd::CSingleWorkspace Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetWindow | This method is called to get window handle of workspace
OnToolHitTest | The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
Public Methods
Public Methods
Public Method | Description
RedrawControl | Initiates redrawing of the control


CXTPTabClientWnd::CSingleWorkspace::GetWindow Method

CSingleWorkspace Methods, CXTPTabClientWnd::CSingleWorkspace Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::CSingleWorkspace::GetWindow Method

This method is called to get window handle of workspace

virtual CWnd* GetWindow() const;
Group

CSingleWorkspace Methods


CXTPTabClientWnd::CSingleWorkspace::OnToolHitTest Method

CSingleWorkspace Methods, CXTPTabClientWnd::CSingleWorkspace Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::CSingleWorkspace::OnToolHitTest Method

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

INT_PTR OnToolHitTest(
    CPoint point,
    TOOLINFO* pTI
) const;
Parameters

point
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window
pTI
A pointer to a TOOLINFO structure.

Returns

If the tooltip control was found, the window control ID. If the tooltip control was not found, -1.

Group

CSingleWorkspace Methods


CXTPTabClientWnd::CSingleWorkspace::RedrawControl Method

CSingleWorkspace Methods, CXTPTabClientWnd::CSingleWorkspace Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::CSingleWorkspace::RedrawControl Method

Initiates redrawing of the control

virtual void RedrawControl(
    LPCRECT lpRect,
    BOOL bAnimate
);
Parameters

lpRect
The rectangular area of the window that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Remarks

Call this member function if you want to initialize redrawing of the control. The control will be redrawn taking into account its latest state.

Group

CSingleWorkspace Methods


CSingleWorkspace Destructors

CXTPTabClientWnd::CSingleWorkspace Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CSingleWorkspace Destructors
Class

CXTPTabClientWnd::CSingleWorkspace Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CSingleWorkspace | Destroys a CSingleWorkspace object, handles cleanup and deallocation


CXTPTabClientWnd::CSingleWorkspace::~CSingleWorkspace Destructor

CSingleWorkspace Destructors, CXTPTabClientWnd::CSingleWorkspace Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::CSingleWorkspace::~CSingleWorkspace Destructor

Destroys a CSingleWorkspace object, handles cleanup and deallocation

~CSingleWorkspace();
Group

CSingleWorkspace Destructors


CXTPTabClientWnd::CWorkspace Class

XTPTabClientWnd.h, CXTPTabClientWnd Classes, Legend, Members, Topics, CWorkspace Data Members, CWorkspace Methods, CWorkspace Constructors, CWorkspace Destructors, CWorkspace Constructors, CWorkspace Data Members, CWorkspace Destructors, CWorkspace Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::CWorkspace Class

CWorkspace is a CXTPTabManager derived class. internal used.

Class Hierarchy

class CWorkspace : public CXTPTabManager;
File

XTPTabClientWnd.h

Group

CXTPTabClientWnd Classes

Legend
Data Member
protected
Method
virtual
CWorkspace Constructors
CWorkspace Constructors | Description
CWorkspace | Constructs a CWorkspace object
CWorkspace Data Members
CWorkspace Data Members | Description
m_dHeight | Height of the workspace
m_pTabClientWnd | Parent tabbed client.
m_rcSplitter | Splitter position.
CWorkspace Destructors
CWorkspace Destructors | Description
~CWorkspace | Destroys a CWorkspace object, handles cleanup and deallocation.
CWorkspace Methods
CWorkspace Methods | Description
AddItem | Adds new tab item for the specified window
DrawIcon | This member is called when the icon of the tab needs to be drawn.
FindItem | Finds the tab item that corresponds to the specified window
GetItemColor | This member function returns the RGB value for the referenced item text or (COLORREF)-1, if the color was not set.
GetItemIcon | This member function gets the index for the current icon.
GetItemTooltip | Returns the tooltip associated with the specified item.
GetPaintManager | Retrieves the paint manager.
GetWindow | This method is called to get window handle of workspace
IsAllowReorder | Returns whether or not reorder is allowed.
IsDrawStaticFrame | Determines if frame must be drawn.
IsMouseLocked | Checks to see if the mouse is locked.
OnBeforeItemClick | This method is called before item click
OnItemClick | This member is called when a tab button is clicked. This will select the tab that was clicked.
OnNavigateButtonClick | This member is called when a tab navigation button is clicked.
OnRecalcLayout | This method is called to recalculate layout of tab client
RedrawControl | Initiates redrawing of the control
ReOrder | This member is called when a CXTPTabManagerItem is clicked and dragged within the tab header. This will reorder the selected tab to the location it is dragged to.
Reposition | This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.
SetAllowReorder | Allows/disallows reorder.
SetSelectedItem | Call this member to select the specified item.


CWorkspace Data Members

CXTPTabClientWnd::CWorkspace Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CWorkspace Data Members
Class

CXTPTabClientWnd::CWorkspace Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dHeight | Height of the workspace
m_pTabClientWnd | Parent tabbed client.
m_rcSplitter | Splitter position.


CXTPTabClientWnd::CWorkspace::m_dHeight Data Member

CWorkspace Data Members, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::m_dHeight Data Member

Height of the workspace

double m_dHeight;
Group

CWorkspace Data Members


CXTPTabClientWnd::CWorkspace::m_pTabClientWnd Data Member

CWorkspace Data Members, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::m_pTabClientWnd Data Member

Parent tabbed client.

CXTPTabClientWnd* m_pTabClientWnd;
Group

CWorkspace Data Members


CXTPTabClientWnd::CWorkspace::m_rcSplitter Data Member

CWorkspace Data Members, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::m_rcSplitter Data Member

Splitter position.

CRect m_rcSplitter;
Group

CWorkspace Data Members


CWorkspace Methods

CXTPTabClientWnd::CWorkspace Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CWorkspace Methods
Class

CXTPTabClientWnd::CWorkspace Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AddItem | Adds new tab item for the specified window
DrawIcon | This member is called when the icon of the tab needs to be drawn.
FindItem | Finds the tab item that corresponds to the specified window
GetItemColor | This member function returns the RGB value for the referenced item text or (COLORREF)-1, if the color was not set.
GetItemIcon | This member function gets the index for the current icon.
GetItemTooltip | Returns the tooltip associated with the specified item.
GetPaintManager | Retrieves the paint manager.
GetWindow | This method is called to get window handle of workspace
IsAllowReorder | Returns whether or not reorder is allowed.
IsDrawStaticFrame | Determines if frame must be drawn.
IsMouseLocked | Checks to see if the mouse is locked.
OnBeforeItemClick | This method is called before item click
OnItemClick | This member is called when a tab button is clicked. This will select the tab that was clicked.
OnNavigateButtonClick | This member is called when a tab navigation button is clicked.
OnRecalcLayout | This method is called to recalculate layout of tab client
RedrawControl | Initiates redrawing of the control
ReOrder | This member is called when a CXTPTabManagerItem is clicked and dragged within the tab header. This will reorder the selected tab to the location it is dragged to.
Reposition | This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.
SetAllowReorder | Allows/disallows reorder.
SetSelectedItem | Call this member to select the specified item.


CXTPTabClientWnd::CWorkspace::AddItem Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::AddItem Method

Adds new tab item for the specified window

CXTPTabManagerItem* AddItem(
    const CWnd* pChildWnd
);
Parameters

pChildWnd
Pointer to MDI child window to add.

Returns

Returns a pointer to the newly added tab.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::DrawIcon Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::DrawIcon Method

This member is called when the icon of the tab needs to be drawn.

virtual BOOL DrawIcon(
    CDC* pDC,
    CPoint pt,
    CXTPTabManagerItem* pItem,
    BOOL bDraw,
    CSize& szIcon
) const;
Parameters

pDC
Pointer to the destination device context.
pt
Specifies the location of the image.
pItem
CXTPTabManagerItem object to draw icon on.
bDraw
TRUE if the icon needs to be drawn, I.e. the icon size changed. FALSE if the icon does not need to be drawn or redrawn.
szIcon
Size of the tab icon.

Returns

TRUE if the icon was successfully drawn, FALSE if the icon was not drawn.

Remarks

For example, on mouseover. This member is overridden by its descendants. This member must be overridden in derived classes.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::FindItem Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::FindItem Method

Finds the tab item that corresponds to the specified window

CXTPTabManagerItem* FindItem(
    const HWND hWnd
) const;
Parameters

hWnd
Handle of MDI child window to find.

Returns

Returns a pointer to the specified tab if it was found.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::GetItemColor Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::GetItemColor Method

This member function returns the RGB value for the referenced item text or (COLORREF)-1, if the color was not set.

COLORREF GetItemColor(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
Pointer to a CXTPTabManagerItem.

Returns

The RGB value for the referenced item text, or (COLORREF)-1, if the color was not set

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::GetItemIcon Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::GetItemIcon Method

This member function gets the index for the current icon.

HICON GetItemIcon(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
Pointer to a CXTPTabManagerItem.

Returns

An icon index for the current item.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::GetItemTooltip Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::GetItemTooltip Method

Returns the tooltip associated with the specified item.

virtual CString GetItemTooltip(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
Points to a CXTPTabManagerItem object.

Returns

Associated tooltip

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::GetPaintManager Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::GetPaintManager Method

Retrieves the paint manager.

virtual CXTPTabPaintManager* GetPaintManager() const;
Returns

A pointer to a CXTPTabPaintManager object.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::GetWindow Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::GetWindow Method

This method is called to get window handle of workspace

virtual CWnd* GetWindow() const;
Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::IsAllowReorder Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::IsAllowReorder Method

Returns whether or not reorder is allowed.

virtual BOOL IsAllowReorder() const;
Returns

TRUE when reorder is allowed; FALSE otherwise.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::IsDrawStaticFrame Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::IsDrawStaticFrame Method

Determines if frame must be drawn.

virtual BOOL IsDrawStaticFrame() const;
Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::IsMouseLocked Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::IsMouseLocked Method

Checks to see if the mouse is locked.

virtual BOOL IsMouseLocked() const;
Returns

TRUE if locked; otherwise returns FALSE.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::OnBeforeItemClick Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::OnBeforeItemClick Method

This method is called before item click

virtual BOOL OnBeforeItemClick(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Pointer to item is about to be clicked

Returns

TRUE if cancel process

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::OnItemClick Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::OnItemClick Method

This member is called when a tab button is clicked. This will select the tab that was clicked.

virtual void OnItemClick(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Pointer to the CXTPTabManagerItem tab that was clicked.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::OnNavigateButtonClick Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::OnNavigateButtonClick Method

This member is called when a tab navigation button is clicked.

virtual void OnNavigateButtonClick(
    CXTPTabManagerNavigateButton* pButton
);
Parameters

pButton
the tab navigation button that was clicked.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::OnRecalcLayout Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::OnRecalcLayout Method

This method is called to recalculate layout of tab client

virtual void OnRecalcLayout();
Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::RedrawControl Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::RedrawControl Method

Initiates redrawing of the control

virtual void RedrawControl(
    LPCRECT lpRect,
    BOOL bAnimate
);
Parameters

lpRect
The rectangular area of the window that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Remarks

Call this member function if you want to initialize redrawing of the control. The control will be redrawn taking into account its latest state.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::ReOrder Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::ReOrder Method

This member is called when a CXTPTabManagerItem is clicked and dragged within the tab header. This will reorder the selected tab to the location it is dragged to.

virtual void ReOrder(
    HWND hWnd,
    CPoint pt,
    CXTPTabManagerItem* pItem
);
Parameters

hWnd
Handle to the CWnd object beneath the mouse cursor.
pt
CPoint object specifies xy coordinates.
pItem
Points to a CXTPTabManagerItem object

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::Reposition Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::Reposition Method

This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.

virtual void Reposition();
Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::SetAllowReorder Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::SetAllowReorder Method

Allows/disallows reorder.

virtual void SetAllowReorder(
    BOOL bAllowReorder
);
Parameters

bAllowReorder
TRUE for allowing reorder; FALSE for disallowing.

Group

CWorkspace Methods


CXTPTabClientWnd::CWorkspace::SetSelectedItem Method

CWorkspace Methods, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::SetSelectedItem Method

Call this member to select the specified item.

virtual void SetSelectedItem(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Points to a CXTPTabManagerItem object.

Group

CWorkspace Methods


CWorkspace Constructors

CXTPTabClientWnd::CWorkspace Class, Legend, Public Methods
CWorkspace Constructors
Class

CXTPTabClientWnd::CWorkspace Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CWorkspace | Constructs a CWorkspace object


CXTPTabClientWnd::CWorkspace::CWorkspace Constructor

CWorkspace Constructors, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::CWorkspace Constructor

Constructs a CWorkspace object

CWorkspace();
Group

CWorkspace Constructors


CWorkspace Destructors

CXTPTabClientWnd::CWorkspace Class, Legend, Public Methods
CWorkspace Destructors
Class

CXTPTabClientWnd::CWorkspace Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CWorkspace | Destroys a CWorkspace object, handles cleanup and deallocation.


CXTPTabClientWnd::CWorkspace::~CWorkspace Destructor

CWorkspace Destructors, CXTPTabClientWnd::CWorkspace Class
CXTPTabClientWnd::CWorkspace::~CWorkspace Destructor

Destroys a CWorkspace object, handles cleanup and deallocation.

virtual ~CWorkspace();
Group

CWorkspace Destructors


CXTPTabClientWnd Data Members

CXTPTabClientWnd Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd Data Members
Class

CXTPTabClientWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_afterCloseTabPosition | Tab to make active after the currently active tab is closed.
m_arrWorkspace | Array of workspaces.
m_bAllowReorder | TRUE to allow the user to reorder tabs.
m_bAutoTheme | TRUE to auto theme the TabWorkspace.
m_bEnableGroups | TRUE if TabWorkspace groups are enabled.
m_bHorizSplitting | TRUE if groups devided horizontally
m_bRefreshed | TRUE if Refresh currently executed.
m_bShowWorkspace | TRUE to show the TabWorkspace, FALSE to hide the TabWorkspace.
m_bThemedBackColor | TRUE if a themed backcolor will be used.
m_bUpdateContents | TRUE if UpdateContents executed.
m_bUserWorkspace | TRUE if custom workspace used
m_bUseSplitterTracker | If TRUE, splitter trackers are used.
m_dwFlags | Specifies which tab navigation buttons are displayed.
m_hCursorDelete | Remove item cursor handle
m_hCursorHoriz | Horizontal split cursor handle.
m_hCursorNew | New item cursor handle
m_hCursorVert | Vertical split cursor handle.
m_newTabPosition | New tab position.
m_nSplitterSize | Splitter size
m_pActiveWorkspace | Active workspace.
m_pPaintManager | Current paint manager.
m_pParentFrame | pointer to the corresponding parent MDIFrame window
m_pTabWorkspace | Custom workspace
m_pToolTipContext | Tooltip Context.
m_themeCommandBars | Theme set for the TabWorkspace (Can be different from CommandBars if m_bAutoTheme is FALSE)
Public Data Members
Public Data Member | Description
m_bDelayLock | TRUE to lock update with small delay
m_bForceToRecalc | TRUE to recalculate in next idle event.
m_bLockReposition | TRUE to lock reposition.
m_bLockUpdate | TRUE to lock update tabs.


CXTPTabClientWnd::m_afterCloseTabPosition Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_afterCloseTabPosition Data Member

Tab to make active after the currently active tab is closed.

XTPWorkspaceActivateTab m_afterCloseTabPosition;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_arrWorkspace Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_arrWorkspace Data Member

Array of workspaces.

CArray<CWorkspace*, CWorkspace*> m_arrWorkspace;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bAllowReorder Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bAllowReorder Data Member

TRUE to allow the user to reorder tabs.

BOOL m_bAllowReorder;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bAutoTheme Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bAutoTheme Data Member

TRUE to auto theme the TabWorkspace.

BOOL m_bAutoTheme;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bDelayLock Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bDelayLock Data Member

TRUE to lock update with small delay

BOOL m_bDelayLock;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bEnableGroups Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bEnableGroups Data Member

TRUE if TabWorkspace groups are enabled.

BOOL m_bEnableGroups;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bForceToRecalc Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bForceToRecalc Data Member

TRUE to recalculate in next idle event.

BOOL m_bForceToRecalc;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bHorizSplitting Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bHorizSplitting Data Member

TRUE if groups devided horizontally

BOOL m_bHorizSplitting;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bLockReposition Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bLockReposition Data Member

TRUE to lock reposition.

BOOL m_bLockReposition;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bLockUpdate Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bLockUpdate Data Member

TRUE to lock update tabs.

BOOL m_bLockUpdate;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bRefreshed Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bRefreshed Data Member

TRUE if Refresh currently executed.

BOOL m_bRefreshed;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bShowWorkspace Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bShowWorkspace Data Member

TRUE to show the TabWorkspace, FALSE to hide the TabWorkspace.

BOOL m_bShowWorkspace;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bThemedBackColor Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bThemedBackColor Data Member

TRUE if a themed backcolor will be used.

BOOL m_bThemedBackColor;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bUpdateContents Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bUpdateContents Data Member

TRUE if UpdateContents executed.

BOOL m_bUpdateContents;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bUserWorkspace Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bUserWorkspace Data Member

TRUE if custom workspace used

BOOL m_bUserWorkspace;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_bUseSplitterTracker Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_bUseSplitterTracker Data Member

If TRUE, splitter trackers are used.

BOOL m_bUseSplitterTracker;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_dwFlags Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_dwFlags Data Member

Specifies which tab navigation buttons are displayed.

DWORD m_dwFlags;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_hCursorDelete Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_hCursorDelete Data Member

Remove item cursor handle

HCURSOR m_hCursorDelete;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_hCursorHoriz Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_hCursorHoriz Data Member

Horizontal split cursor handle.

HCURSOR m_hCursorHoriz;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_hCursorNew Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_hCursorNew Data Member

New item cursor handle

HCURSOR m_hCursorNew;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_hCursorVert Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_hCursorVert Data Member

Vertical split cursor handle.

HCURSOR m_hCursorVert;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_newTabPosition Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_newTabPosition Data Member

New tab position.

XTPWorkspaceNewTabPosition m_newTabPosition;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_nSplitterSize Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_nSplitterSize Data Member

Splitter size

int m_nSplitterSize;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_pActiveWorkspace Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_pActiveWorkspace Data Member

Active workspace.

CWorkspace* m_pActiveWorkspace;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_pPaintManager Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_pPaintManager Data Member

Current paint manager.

CXTPTabPaintManager* m_pPaintManager;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_pParentFrame Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_pParentFrame Data Member

pointer to the corresponding parent MDIFrame window

CMDIFrameWnd* m_pParentFrame;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_pTabWorkspace Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_pTabWorkspace Data Member

Custom workspace

CWorkspace* m_pTabWorkspace;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_pToolTipContext Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_pToolTipContext Data Member

Tooltip Context.

CXTPToolTipContext* m_pToolTipContext;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd::m_themeCommandBars Data Member

CXTPTabClientWnd Data Members, CXTPTabClientWnd Class
CXTPTabClientWnd::m_themeCommandBars Data Member

Theme set for the TabWorkspace (Can be different from CommandBars if m_bAutoTheme is FALSE)

XTPPaintTheme m_themeCommandBars;
Group

CXTPTabClientWnd Data Members


CXTPTabClientWnd Methods

CXTPTabClientWnd Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd Methods
Class

CXTPTabClientWnd Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AddItem | This member function adds a new tab item for the specified window.
AddWorkspace | Call this member function to add a workspace.
CancelLoop | This member function is called when a loop is canceled.
CheckCommandBarsTheme | If m_bAutoTheme is FALSE, then it checks to see if the theme set for the TabWorkspace is different from the theme set for the CommandBars. If the themes are different, then the TabWorkSpace theme is set to the theme specified in m_themeCommandBars.
ContextMenu | This method shows the context menu for toolbars.
FindIndex | Call this member to find the specified index.
GetItemColor | This member function returns the RGB value for the referenced item text or (COLORREF)-1, if the color was not set.
GetItemIcon | This member function retrieves the icon of a specific tab.
GetItemText | This member function retrieves the text of a specific tab.
GetItemTooltip | Returns the tooltip associated with the specified item.
GetSelectedItem | Returns the selected item in the control.
InitLoop | Call this member function to initialize a loop.
MDIActivate | Call this member function to activate an MDI child window independently of the MDI frame window.
MDIGetActive | Retrieves the current active MDI child window.
SetActiveWorkspace | This member functions sets a workspace active.
UpdateFlags | This member function is called to update the status of the TabWorkspace navigation buttons.
Public Methods
Public Methods
Public Method | Description
Attach | Attaches the tabbed workspace.
CreateWorkspace | This method is called to create new CWorkspace class, you can override it for custom Workskspace.
Detach | Detaches the tabbed workspace.
EnableToolTips | Call this member function to enable or disable tooltips show
FindItem | Call this member to find the item that corresponds to the specified window.
GetAutoTheme | Call this member to determine if auto themes are used to theme the TabWorkspace.
GetCommandBars | Call this member to get the command bar's object.
GetFlags | Call this member to determine which tab navigation buttons are currently displayed in the tab workspace.
GetItem | Returns an item by its index.
GetItemCount | Returns the number of items.
GetNewTabPositon | This method is call to determine where new tab must appear.
GetPaintManager | Call this method to retrieve the paint manager.
GetParentFrame | Retrieves the parent frame of the control.
GetToolTipContext | Call this method to get tooltip context pointer.
GetWorkspace | Call this member to return the workspace at the specified index.
GetWorkspaceCount | Call this member to retrieve the current number of workspaces.
HitTest | Call this function to determine which tab, if any, is at the specified screen position.
IsAllowReorder | Returns the current reordering allowance.
IsAttached | Determines if a tab workspace is attached.
IsLayoutRTL | Determines if right-to-left mode was set.
IsSplitterTrackerUsed | Call this member to determine if the splitter tracker is used.
IsWorkspaceCommandEnabled | Returns the workspace command mode.
LoadState | Loads previous docking state.
MDITile | Call this member to tile child windows in workspace (only if EnableGroups enabled)
OnDraw | This member is called when the client is drawn.
OnFillBackground | This member is called when the background is filled.
OnWorkspaceCommand | Call this method to execute special workspace command
Refresh | Call this method to refresh all the items.
Reposition | Call this method to reposition items.
SaveState | Saves Position state.
ScreenToWorkspace | Converts the screen coordinates of a given point or rectangle on the display to client coordinates.
SetAfterCloseActiveTab | Call this member to set where new tab must appear.
SetAllowReorder | Call this member function to allow or disallow reordering.
SetAutoTheme | Call this member to specify whether auto themes are used for the TabWorkspace.
SetFlags | Call this member to set flags of the tab workspace.
SetLayoutRTL | Call this member to set right-to-left mode.
SetNewTabPosition | Call this member to set where new tab must appear.
SetPaintManager | Call this member to set the specified paint manager.
SetTabWorkspace | Call this method to set custom workspace control.
ShowWorkspace | Call this member function to show or hide the workspace.
UpdateContents | Scan through all MDIChild windows and update corresponding tab items if any changes happened (e.g. window text or active MDIChild).
UseSplitterTracker | Call this member to use trackers.
WorkspaceToScreen | Converts the workspace coordinates of a given point on the display to screen coordinates.


CXTPTabClientWnd::AddItem Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::AddItem Method

This member function adds a new tab item for the specified window.

virtual CXTPTabManagerItem* AddItem(
    CWnd* pChildWnd
);
Parameters

pChildWnd
A CWnd pointer that represents the child to be displayed when the window is activated.

Returns

A pointer to a CXTPTabManagerItem object.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::AddWorkspace Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::AddWorkspace Method

Call this member function to add a workspace.

virtual CWorkspace* AddWorkspace(
    int nIndex = -1
);
Parameters

nIndex
Index of the workspace.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::Attach Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::Attach Method

Attaches the tabbed workspace.

BOOL Attach(
    CXTPMDIFrameWnd* pParentFrame,
    BOOL bEnableGroups = FALSE
);
Parameters

pParentFrame
Points to a CMDIFrameWnd object
bEnableGroups
TRUE to enable groups.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::CancelLoop Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::CancelLoop Method

This member function is called when a loop is canceled.

void CancelLoop();
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::CheckCommandBarsTheme Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::CheckCommandBarsTheme Method

If m_bAutoTheme is FALSE, then it checks to see if the theme set for the TabWorkspace is different from the theme set for the CommandBars. If the themes are different, then the TabWorkSpace theme is set to the theme specified in m_themeCommandBars.

virtual void CheckCommandBarsTheme();
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::ContextMenu Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::ContextMenu Method

This method shows the context menu for toolbars.

void ContextMenu(
    CPoint pt
);
Parameters

pt
Position of the menu to show.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::CreateWorkspace Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::CreateWorkspace Method

This method is called to create new CWorkspace class, you can override it for custom Workskspace.

virtual CWorkspace* CreateWorkspace();
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::Detach Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::Detach Method

Detaches the tabbed workspace.

BOOL Detach();
Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::EnableToolTips Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::EnableToolTips Method

Call this member function to enable or disable tooltips show

void EnableToolTips(
    XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways
);
Parameters

behaviour
Tooltips behaviour will be set. See remarks section for available flags.

Remarks

behaviour parameter can be one of the following:

  • xtpTabToolTipNever Show tooltips for tabs always
  • xtpTabToolTipAlways Doesn't show toltips for tabs
  • xtpTabToolTipShrinkedOnly Show tooltips only if tab was shrinked (see xtpTabLayoutSizeToFit layout)
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::FindIndex Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::FindIndex Method

Call this member to find the specified index.

int FindIndex(
    CXTPTabManager* pWorkspace
) const;
Parameters

pWorkspace
Pointer to a CXTPTabManger object.

Returns

The index of the matching item.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::FindItem Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::FindItem Method

Call this member to find the item that corresponds to the specified window.

CXTPTabManagerItem* FindItem(
    const HWND hWnd
) const;
Parameters

hWnd
Handle of the window.

Returns

A pointer to a CXTPTabManagerItem object.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetAutoTheme Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetAutoTheme Method

Call this member to determine if auto themes are used to theme the TabWorkspace.

BOOL GetAutoTheme() const;
Returns

TRUE if auto themes are used to theme the TabWorkspace, FALSE if auto themes are not used.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetCommandBars Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetCommandBars Method

Call this member to get the command bar's object.

virtual CXTPCommandBars* GetCommandBars() const;
Returns

A CXTPCommandBars pointer (can be NULL).

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetFlags Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::GetFlags Method

Call this member to determine which tab navigation buttons are currently displayed in the tab workspace.

DWORD GetFlags() const;
Returns

Retrieves tab navigation flags of the tab workspace.

See Also

SetFlags, XTPWorkspaceButtons

Body Source
DWORD CXTPTabClientWnd::GetFlags() const {
    return m_dwFlags;
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetItem Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetItem Method

Returns an item by its index.

CXTPTabManagerItem* GetItem(
    int nIndex
) const;
Parameters

nIndex
Zero-based index of the item in the collection.

Returns

Pointer to the found item, if any, or NULL otherwise.

Remarks

You use this member function to get an item from collection by item index. If the given index is less than 0 or greater than the value returned by GetItemCount(), GetItem() returns NULL.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetItemColor Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetItemColor Method

This member function returns the RGB value for the referenced item text or (COLORREF)-1, if the color was not set.

virtual COLORREF GetItemColor(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
A pointer to a CXTPTabManagerItem.

Returns

The RGB value for the referenced item text, or (COLORREF)-1, if the color was not set.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetItemCount Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetItemCount Method

Returns the number of items.

int GetItemCount() const;
Returns

The number of items.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetItemIcon Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetItemIcon Method

This member function retrieves the icon of a specific tab.

virtual HICON GetItemIcon(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
A pointer to a CXTPTabManagerItem.

Returns

The icon of a particular tab, or NULL if an error occurs.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetItemText Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetItemText Method

This member function retrieves the text of a specific tab.

virtual CString GetItemText(
    const CWnd* pChildWnd
) const;
Parameters

pChildWnd
A CWnd pointer that represents the child to be displayed when the window is activated.

Returns

The text of a particular tab, or NULL if an error occurs.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetItemTooltip Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetItemTooltip Method

Returns the tooltip associated with the specified item.

virtual CString GetItemTooltip(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
Points to a CXTPTabManagerItem object.

Returns

Associated tooltip

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetNewTabPositon Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::GetNewTabPositon Method

This method is call to determine where new tab must appear.

XTPWorkspaceNewTabPosition GetNewTabPositon() const;
Returns

XTPWorkspaceNewTabPosition enumerator that show where new tab must appear.

See Also

XTPWorkspaceNewTabPosition, SetNewTabPosition

Body Source
XTPWorkspaceNewTabPosition CXTPTabClientWnd::GetNewTabPositon() const {
    return m_newTabPosition;
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetPaintManager Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetPaintManager Method

Call this method to retrieve the paint manager.

CXTPTabPaintManager* GetPaintManager() const;
Returns

A pointer to a CXTPTabPaintManager object.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetParentFrame Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::GetParentFrame Method

Retrieves the parent frame of the control.

CMDIFrameWnd* GetParentFrame() const;
Body Source
CMDIFrameWnd* CXTPTabClientWnd::GetParentFrame() const {
    return m_pParentFrame;
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetSelectedItem Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::GetSelectedItem Method

Returns the selected item in the control.

CXTPTabManagerItem* GetSelectedItem() const;
Returns

A pointer to a CXTPTabManagerItem object.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetToolTipContext Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Body Source
CXTPToolTipContext* CXTPTabClientWnd::GetToolTipContext() const {
    return m_pToolTipContext;
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetWorkspace Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, See Also
CXTPTabClientWnd::GetWorkspace Method

Call this member to return the workspace at the specified index.

CWorkspace* GetWorkspace(
    int nIndex
) const;
Parameters

nIndex
An integer index starting at 0.

Returns

A pointer to the workspace currently at this index.

Remarks

If tab groups are enabled, then there will be more than one workspace. If tab groups are disabled, then there is only 1 workspace with an index of 0.

See Also

GetWorkspaceCount

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::GetWorkspaceCount Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, See Also
CXTPTabClientWnd::GetWorkspaceCount Method

Call this member to retrieve the current number of workspaces.

int GetWorkspaceCount() const;
Returns

An integer value that represents the number of workspaces.

Remarks

If tab groups are enabled, then there will be more than one workspace. If tab groups are disabled, then there is only 1 workspace with an index of 0.

See Also

GetWorkspace

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::HitTest Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::HitTest Method

Call this function to determine which tab, if any, is at the specified screen position.

CXTPTabManagerItem* HitTest(
    CPoint pt
) const;
Parameters

pt
Point to be tested.

Returns

The zero-based index of the tab, or returns -1 if no tab is at the specified position.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::InitLoop Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::InitLoop Method

Call this member function to initialize a loop.

void InitLoop();
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::IsAllowReorder Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::IsAllowReorder Method

Returns the current reordering allowance.

BOOL IsAllowReorder() const;
Returns

TRUE when reordering is allowed; FALSE when it is disallowed.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::IsAttached Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::IsAttached Method

Determines if a tab workspace is attached.

BOOL IsAttached() const;
Returns

TRUE if attached; otherwise returns FALSE

Body Source
BOOL CXTPTabClientWnd::IsAttached() const {
    return (m_pParentFrame!=NULL ? TRUE : FALSE);
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::IsLayoutRTL Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::IsLayoutRTL Method

Determines if right-to-left mode was set.

BOOL IsLayoutRTL() const;
Returns

TRUE if text is displayed using right-to-left reading-order properties.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::IsSplitterTrackerUsed Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::IsSplitterTrackerUsed Method

Call this member to determine if the splitter tracker is used.

BOOL IsSplitterTrackerUsed() const;
Returns

TRUE if the splitter tracker is used; otherwise returns FALSE.

See Also

UseSplitterTracker

Body Source
BOOL CXTPTabClientWnd::IsSplitterTrackerUsed() const {
    return m_bUseSplitterTracker;
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::IsWorkspaceCommandEnabled Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::IsWorkspaceCommandEnabled Method

Returns the workspace command mode.

BOOL IsWorkspaceCommandEnabled(
    UINT nID,
    CXTPTabManagerItem** ppItem = NULL
);
Parameters

nID
Specifies the identifier of the workspace.
ppItem
MDI active item.

Returns

TRUE when workspace command is enabled; FALSE when it is disabled.

Remarks

Call this member function if you want to determine whether or not workspace command is enabled.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::LoadState Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::LoadState Method

Loads previous docking state.

void LoadState();
Body Source
void LoadState()
{
    int nValue = AfxGetApp()->GetProfileInt(_T("TabDocking"), _T("Position"), xtpTabPositionTop);
    m_pPaintManager->SetPosition(XTPTabPosition(nValue));
    m_bForceToRecalc = TRUE;
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::MDIActivate Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::MDIActivate Method

Call this member function to activate an MDI child window independently of the MDI frame window.

void MDIActivate(
    CWnd* pWnd
);
Parameters

pWnd
Pointer to a valid device context.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::MDIGetActive Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::MDIGetActive Method

Retrieves the current active MDI child window.

CWnd* MDIGetActive();
Returns

A pointer to the active MDI child window.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::MDITile Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::MDITile Method

Call this member to tile child windows in workspace (only if EnableGroups enabled)

void MDITile(
    BOOL bHorizontal
);
Parameters

bHorizontal
TRUE to tile horizontally.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::OnDraw Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::OnDraw Method

This member is called when the client is drawn.

virtual void OnDraw(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
rc
Rectangle area to be drawn.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::OnFillBackground Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::OnFillBackground Method

This member is called when the background is filled.

virtual void OnFillBackground(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
rc
Rectangle area to be filled.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::OnWorkspaceCommand Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::OnWorkspaceCommand Method

Call this method to execute special workspace command

void OnWorkspaceCommand(
    UINT nID
);
Parameters

nID
Specifies the identifier of the workspace. Can be any of the values listed in the Remarks section.

Remarks

nID can be one of the following:

  • XTP_ID_WORKSPACE_NEWVERTICAL Creates new vertical group.
  • XTP_ID_WORKSPACE_NEWHORIZONTAL Creates new horizontal group.
  • XTP_ID_WORKSPACE_MOVEPREVIOUS Moves item to previous group.
  • XTP_ID_WORKSPACE_MOVENEXT Moves item to next group.
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::Refresh Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::Refresh Method

Call this method to refresh all the items.

void Refresh(
    BOOL bRecalcLayout = TRUE
);
Parameters

bRecalcLayout
true to recalculate layout of frame.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::Reposition Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::Reposition Method

Call this method to reposition items.

virtual void Reposition();
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SaveState Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::SaveState Method

Saves Position state.

void SaveState();
Body Source
void SaveState()
{
    AfxGetApp()->WriteProfileInt(_T("TabDocking"), _T("Position"), (int)m_pPaintManager->GetPosition());
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::ScreenToWorkspace Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::ScreenToWorkspace Method

Converts the screen coordinates of a given point or rectangle on the display to client coordinates.

void ScreenToWorkspace(
    LPPOINT lpPoint
) const;
Parameters

lpPoint
Points to a CPoint object or POINT structure that contains the screen coordinates to be converted.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SetActiveWorkspace Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::SetActiveWorkspace Method

This member functions sets a workspace active.

void SetActiveWorkspace(
    CWorkspace* pWorkspace
);
Parameters

pWorkspace
Pointer to a CWorkspace object.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SetAllowReorder Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::SetAllowReorder Method

Call this member function to allow or disallow reordering.

void SetAllowReorder(
    BOOL bAllowReorder
);
Parameters

bAllowReorder
TRUE for allowing reordering; FALSE for disallowing reordering.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SetAutoTheme Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::SetAutoTheme Method

Call this member to specify whether auto themes are used for the TabWorkspace.

void SetAutoTheme(
    BOOL bAutoTheme = FALSE
);
Parameters

bAutoTheme
TRUE to use auto themes.

Remarks

By default, AutoTheme = TRUE. When AutoTheme = TRUE, the theme of the TabWorkspace will change when the theme of the CommandBars control is changed. Set AutoTheme = FALSE to keep the currently set theme even if the CommandBars theme is changed.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SetFlags Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, See Also
CXTPTabClientWnd::SetFlags Method

Call this member to set flags of the tab workspace.

void SetFlags(
    DWORD dwButtons
);
Parameters

dwButtons
Buttons to hide. Can be any of the values listed in the remarks section.

Remarks

dwButtons can be one of the following:

  • xtpWorkspaceHideArrows Hides the arrow buttons.
  • xtpWorkspaceHideClose Hides the close button.
  • xtpWorkspaceHideAll Hides the arrow and close buttons.
See Also

GetFlags, XTPWorkspaceButtons

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SetLayoutRTL Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::SetLayoutRTL Method

Call this member to set right-to-left mode.

void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SetNewTabPosition Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::SetNewTabPosition Method

Call this member to set where new tab must appear.

void SetNewTabPosition(
    XTPWorkspaceNewTabPosition tabPosition
);
void SetAfterCloseActiveTab(
    XTPWorkspaceActivateTab activeTab
);
Parameters

tabPosition
Position of new tab regarding other tabs. It can be one of the following

  • xtpWorkspaceNewTabRightMost New tab will be created after all tabs
  • xtpWorkspaceNewTabLeftMost New tab will be created before all tabs
  • xtpWorkspaceNewTabNextToActive New tab will be created after active tab

activeTab
Enumerator that determine which tab will be activated after closing another one. It can be one of the following

  • xtpWorkspaceActivateNextToClosed Activate tab next to the closed tab.
  • xtpWorkspaceActivateTopmost Activate the top-most tab.

See Also

XTPWorkspaceNewTabPosition, GetNewTabPositon, XTPWorkspaceActivateTab

Body Source
void CXTPTabClientWnd::SetNewTabPosition(XTPWorkspaceNewTabPosition tabPosition) {
    m_newTabPosition = tabPosition;
}

void CXTPTabClientWnd::SetAfterCloseActiveTab(XTPWorkspaceActivateTab activeTab) {
    m_afterCloseTabPosition = activeTab;
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SetPaintManager Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::SetPaintManager Method

Call this member to set the specified paint manager.

void SetPaintManager(
    CXTPTabPaintManager* pPaintManager
);
Parameters

pPaintManager
Points to a CXTPTabPaintManager object.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::SetTabWorkspace Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::SetTabWorkspace Method

Call this method to set custom workspace control.

void SetTabWorkspace(
    CWorkspace* pWorkspace
);
Parameters

pWorkspace
Custom workspace control

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::ShowWorkspace Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::ShowWorkspace Method

Call this member function to show or hide the workspace.

void ShowWorkspace(
    BOOL bShow
);
Parameters

bShow
TRUE to show the workspace, or FALSE to hide it.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::UpdateContents Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::UpdateContents Method

Scan through all MDIChild windows and update corresponding tab items if any changes happened (e.g. window text or active MDIChild).

virtual void UpdateContents();
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::UpdateFlags Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, See Also
CXTPTabClientWnd::UpdateFlags Method

This member function is called to update the status of the TabWorkspace navigation buttons.

virtual void UpdateFlags(
    CWorkspace* pWorkspace
);
Parameters

pWorkspace
Pointer to a CWorkspace object.

See Also

SetFlags, GetFlags

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::UseSplitterTracker Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabClientWnd::UseSplitterTracker Method

Call this member to use trackers.

void UseSplitterTracker(
    BOOL bSplitterTracker
);
Parameters

bSplitterTracker
TRUE to use trackers.

Remarks

This member function will display the contents for child window while the splitter is resized if bSplitterTracker is set to FALSE.

See Also

IsSplitterTrackerUsed

Body Source
void CXTPTabClientWnd::UseSplitterTracker(BOOL bSplitterTracker) {
    m_bUseSplitterTracker = bSplitterTracker;
}
Group

CXTPTabClientWnd Methods


CXTPTabClientWnd::WorkspaceToScreen Method

CXTPTabClientWnd Methods, CXTPTabClientWnd Class
CXTPTabClientWnd::WorkspaceToScreen Method

Converts the workspace coordinates of a given point on the display to screen coordinates.

void WorkspaceToScreen(
    LPPOINT lpPoint
) const;
Parameters

lpPoint
Points to a POINT structure or CPoint object that contains the client coordinates to be converted.

Group

CXTPTabClientWnd Methods


CXTPTabClientWnd Constructors

CXTPTabClientWnd Class, Legend, Public Methods
CXTPTabClientWnd Constructors
Class

CXTPTabClientWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabClientWnd | Constructs a CXTPTabClientWnd object


CXTPTabClientWnd::CXTPTabClientWnd Constructor

CXTPTabClientWnd Constructors, CXTPTabClientWnd Class
CXTPTabClientWnd::CXTPTabClientWnd Constructor

Constructs a CXTPTabClientWnd object

CXTPTabClientWnd();
Group

CXTPTabClientWnd Constructors


CXTPTabClientWnd Destructors

CXTPTabClientWnd Class, Legend, Public Methods
CXTPTabClientWnd Destructors
Class

CXTPTabClientWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTabClientWnd | Destroys a CXTPTabClientWnd object, handles cleanup and deallocation.


CXTPTabClientWnd::~CXTPTabClientWnd Destructor

CXTPTabClientWnd Destructors, CXTPTabClientWnd Class
CXTPTabClientWnd::~CXTPTabClientWnd Destructor

Destroys a CXTPTabClientWnd object, handles cleanup and deallocation.

virtual ~CXTPTabClientWnd();
Group

CXTPTabClientWnd Destructors


CXTPTabToolBar Class

XTPTabToolBar.h, Classes, Legend, Members, Topics, CXTPTabToolBar Methods, CXTPTabToolBar Constructors, CXTPTabToolBar Destructors, CXTPTabToolBar Constructors, CXTPTabToolBar Destructors, CXTPTabToolBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabToolBar Class

CXTPTabToolBar is a CXTPToolBar derived class. It represents tabbable toolbar

Class Hierarchy

class CXTPTabToolBar : public CXTPToolBar, public CXTPTabManager;
File

XTPTabToolBar.h

Group

Classes

Legend
Method
protected
virtual
CXTPTabToolBar Constructors
CXTPTabToolBar Constructors | Description
CXTPTabToolBar | Constructs a CXTPTabToolBar object
CXTPTabToolBar Destructors
CXTPTabToolBar Destructors | Description
~CXTPTabToolBar | Destroys a CXTPTabToolBar object, handles cleanup and deallocation
CXTPTabToolBar Methods
CXTPTabToolBar Methods | Description
CalcDockingLayout | This method calculates the dimensions of a toolbar.
CalcDynamicLayout | This method calculates the dimensions of a toolbar.
DrawCommandBar | This method is called to draw the command bar in the given context.
DrawIcon | This member is called when the icon of the tab needs to be drawn.
GetBorders | This method retrieves borders of toolbar
GetPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
InsertCategory |
OnBeforeItemClick | This method is called before item click
OnCustomizeDrop | This method is called when control is dropped to the command bar.
RedrawControl | This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.
Reposition | This method is called to update position of TabManager.
Reset | Resets the controls to their original state.
SetMinimumWidth | Call this method to set minimum available width of toolbar
SetSelectedItem | Call this member to select a CXTPTabManagerItem tab. A selected tab if the currently active tab.
UpdateTabs | Call this method to refresh controls on selected tab


CXTPTabToolBar Methods

CXTPTabToolBar Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabToolBar Methods
Class

CXTPTabToolBar Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalcDockingLayout | This method calculates the dimensions of a toolbar.
CalcDynamicLayout | This method calculates the dimensions of a toolbar.
DrawCommandBar | This method is called to draw the command bar in the given context.
DrawIcon | This member is called when the icon of the tab needs to be drawn.
GetBorders | This method retrieves borders of toolbar
OnBeforeItemClick | This method is called before item click
OnCustomizeDrop | This method is called when control is dropped to the command bar.
RedrawControl | This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.
Reposition | This method is called to update position of TabManager.
Reset | Resets the controls to their original state.
SetSelectedItem | Call this member to select a CXTPTabManagerItem tab. A selected tab if the currently active tab.
Public Methods
Public Methods
Public Method | Description
GetPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
InsertCategory |
SetMinimumWidth | Call this method to set minimum available width of toolbar
UpdateTabs | Call this method to refresh controls on selected tab


CXTPTabToolBar::CalcDockingLayout Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::CalcDockingLayout Method

This method calculates the dimensions of a toolbar.

CSize CalcDockingLayout(
    int nLength,
    DWORD dwMode,
    int nWidth
);
Parameters

nLength
Length of the bar.
dwMode
Mode to dock.
nWidth
Width of the bar.

Returns

Size of the docked toolbar.

Group

CXTPTabToolBar Methods


CXTPTabToolBar::CalcDynamicLayout Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::CalcDynamicLayout Method

This method calculates the dimensions of a toolbar.

CSize CalcDynamicLayout(
    int nLength,
    DWORD dwMode
);
Parameters

nLength
The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode
Mode to dock.

Returns

Size of the docked toolbar.

Group

CXTPTabToolBar Methods


CXTPTabToolBar::DrawCommandBar Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::DrawCommandBar Method

This method is called to draw the command bar in the given context.

void DrawCommandBar(
    CDC* pDC,
    CRect rcClipBox
);
Parameters

pDC
Pointer to a valid device context
rcClipBox
The rectangular area of the control that is invalid

Group

CXTPTabToolBar Methods


CXTPTabToolBar::DrawIcon Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::DrawIcon Method

This member is called when the icon of the tab needs to be drawn.

BOOL DrawIcon(
    CDC* pDC,
    CPoint pt,
    CXTPTabManagerItem* pItem,
    BOOL bDraw,
    CSize& szIcon
) const;
Parameters

pDC
Pointer to the destination device context.
pt
Specifies the location of the image.
pItem
CXTPTabManagerItem object to draw icon on.
bDraw
TRUE if the icon needs to be drawn, I.e. the icon size changed. FALSE if the icon does not need to be drawn or redrawn.
szIcon
Size of the tab icon.

Returns

TRUE if the icon was successfully drawn, FALSE if the icon was not drawn.

Remarks

For example, on mouse-over. This member is overridden by its descendants. This member must be overridden in derived classes.

Group

CXTPTabToolBar Methods


CXTPTabToolBar::GetBorders Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::GetBorders Method

This method retrieves borders of toolbar

CRect GetBorders();
Returns

Borders of toolbar

Group

CXTPTabToolBar Methods


CXTPTabToolBar::GetPaintManager Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::GetPaintManager Method

Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.

virtual CXTPTabPaintManager* GetPaintManager() const;
Returns

Pointer to CXTPTabPaintManager that contains the visual elements of the tabs.

Group

CXTPTabToolBar Methods


InsertCategory Method

CXTPTabToolBar Methods
InsertCategory Method
Overload List
Methods
Method | Description
CXTPTabToolBar::InsertCategory (int, LPCTSTR, UINT, BOOL) | Call this method to add new tab to CXTPTabToolBar
CXTPTabToolBar::InsertCategory (int, LPCTSTR, UINT*, int, BOOL) | Call this method to add new tab to CXTPTabToolBar
Group

CXTPTabToolBar Methods


CXTPTabToolBar::InsertCategory Method (int, LPCTSTR, UINT*, int, BOOL)

InsertCategory Method, CXTPTabToolBar Class
CXTPTabToolBar::InsertCategory Method (int, LPCTSTR, UINT*, int, BOOL)

Call this method to add new tab to CXTPTabToolBar

CXTPTabManagerItem* InsertCategory(
    int nItem,
    LPCTSTR lpszItem,
    UINT* pItems,
    int nCount,
    BOOL bLoadIcons = TRUE
);
CXTPTabManagerItem* InsertCategory(
    int nItem,
    LPCTSTR lpszItem,
    UINT nIDResource,
    BOOL bLoadIcons = TRUE
);
Parameters

nItem
Index to insert category to
lpszItem
Caption of new tab
pItems
Control items
nCount
Control items count
bLoadIcons
TRUE to load icons
nIDResource
Toolbar resource identifier

Returns

CXTPTabManagerItem class of new tab

Group

InsertCategory Method


CXTPTabToolBar::OnBeforeItemClick Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::OnBeforeItemClick Method

This method is called before item click

BOOL OnBeforeItemClick(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Pointer to item is about to be clicked

Returns

TRUE if cancel process

Group

CXTPTabToolBar Methods


CXTPTabToolBar::OnCustomizeDrop Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::OnCustomizeDrop Method

This method is called when control is dropped to the command bar.

void OnCustomizeDrop(
    CXTPControl* pDataObject,
    DROPEFFECT& dropEffect,
    CPoint ptDrop,
    CPoint ptDrag
);
Parameters

pDataObject
Points to a CXTPControl object
dropEffect
DROPEFFECT enumerator.
ptDrop
Point where user drops the control.
ptDrag
Point where user starts drag the control.

Group

CXTPTabToolBar Methods


CXTPTabToolBar::RedrawControl Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::RedrawControl Method

This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.

void RedrawControl(
    LPCRECT lpRect,
    BOOL bAnimate
);
Parameters

lpRect
The rectangular area of the window that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Group

CXTPTabToolBar Methods


CXTPTabToolBar::Reposition Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::Reposition Method

This method is called to update position of TabManager.

void Reposition();
Group

CXTPTabToolBar Methods


CXTPTabToolBar::Reset Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::Reset Method

Resets the controls to their original state.

void Reset(
    BOOL bShowWarningMessage
);
Parameters

bShowWarningMessage
TRUE to show warning message

Group

CXTPTabToolBar Methods


CXTPTabToolBar::SetMinimumWidth Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::SetMinimumWidth Method

Call this method to set minimum available width of toolbar

void SetMinimumWidth(
    int nMinWidth
);
Parameters

nMinWidth
Minimum width of toolbar

Group

CXTPTabToolBar Methods


CXTPTabToolBar::SetSelectedItem Method

CXTPTabToolBar Methods, CXTPTabToolBar Class, See Also
CXTPTabToolBar::SetSelectedItem Method

Call this member to select a CXTPTabManagerItem tab. A selected tab if the currently active tab.

void SetSelectedItem(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
CXTPTabManagerItem tab to select.

Remarks

This member will will select the specified CXTPTabManagerItem.

SetCurSel will set the current CXTPTabManagerItem by its index within the collection of items.

A tab is selected when it has focus or is clicked.

See Also

CXTPTabManagerItem, GetCurSel, SetCurSel, GetSelectedItem

Group

CXTPTabToolBar Methods


CXTPTabToolBar::UpdateTabs Method

CXTPTabToolBar Methods, CXTPTabToolBar Class
CXTPTabToolBar::UpdateTabs Method

Call this method to refresh controls on selected tab

void UpdateTabs(
    CXTPTabManagerItem* pItem = NULL
);
Parameters

pItem
Selected item

Group

CXTPTabToolBar Methods


CXTPTabToolBar Constructors

CXTPTabToolBar Class, Legend, Public Methods
CXTPTabToolBar Constructors
Class

CXTPTabToolBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabToolBar | Constructs a CXTPTabToolBar object


CXTPTabToolBar::CXTPTabToolBar Constructor

CXTPTabToolBar Constructors, CXTPTabToolBar Class
CXTPTabToolBar::CXTPTabToolBar Constructor

Constructs a CXTPTabToolBar object

CXTPTabToolBar();
Group

CXTPTabToolBar Constructors


CXTPTabToolBar Destructors

CXTPTabToolBar Class, Legend, Public Methods
CXTPTabToolBar Destructors
Class

CXTPTabToolBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTabToolBar | Destroys a CXTPTabToolBar object, handles cleanup and deallocation


CXTPTabToolBar::~CXTPTabToolBar Destructor

CXTPTabToolBar Destructors, CXTPTabToolBar Class
CXTPTabToolBar::~CXTPTabToolBar Destructor

Destroys a CXTPTabToolBar object, handles cleanup and deallocation

virtual ~CXTPTabToolBar();
Group

CXTPTabToolBar Destructors


CXTPToolBar Class

XTPToolBar.h, Classes, Legend, Members, Topics, CXTPToolBar Data Members, CXTPToolBar Methods, CXTPToolBar Constructors, CXTPToolBar Destructors, CXTPToolBar Constructors, CXTPToolBar Data Members, CXTPToolBar Destructors, CXTPToolBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolBar Class

CXTPToolBar is a CXTPCommandBar derived class.

Class Hierarchy

class CXTPToolBar : public CXTPCommandBar;
File

XTPToolBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPToolBar Constructors
CXTPToolBar Constructors | Description
CXTPToolBar | Constructs a CXTPToolBar object
CXTPToolBar Data Members
CXTPToolBar Data Members | Description
m_bBuiltIn | TRUE if toolbar is built-in.
m_bContextMenuPresent | TRUE if the command bar is present in context menu.
m_bInRecalcLayout | TRUE if RecalcLayout method is called
m_bPreviewMode | TRUE if Toolbar was visible in preview mode.
m_bPreviewVisible | TRUE if Toolbar was visible in preview mode.
m_bShowExpandButton | TRUE to show expand button of toolbar.
m_bTearOff | TRUE if toolbar is tear-offed.
m_bTemporary | TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)
m_pDockBar | Parent dock bar.
m_pDockContext | Docking context.
CXTPToolBar Destructors
CXTPToolBar Destructors | Description
~CXTPToolBar | Destroys a CXTPToolBar object, handles cleanup and deallocation
CXTPToolBar Methods
CXTPToolBar Methods | Description
CalcDockingLayout | This method calculates the dimensions of a toolbar.
CalcDynamicLayout | This method calculates the dimensions of a toolbar.
Copy | This method makes a copy of the command bar.
Create | Creates a toolbar.
CreateToolBar | This method creates the ToolBar control.
DoPropExchange | Reads or writes this object from or to an archive.
EnableDocking | Call this method to set docking flags.
GetBarInfo | Retrieves bar information for serialization routines.
GetBorders | This method retrieves borders of toolbar
GetDockBar | Retrieves the parent dock bar.
IsBuiltIn | Determines if the toolbar is built-in.
IsCloseable | Call this method to retrieve the close able property of the command bar.
IsContextMenuPresent | Call this member to determine if this toolbar is included in the right-click context menu.
IsCustomizeDialogPresent | Call this member to determine if this toolbar is included in the customize dialog.
IsTemporary | Call this method to determine if the control is temporary.
IsVisible | Returns a Boolean value that indicates whether the toolbar is visible or hidden.
IsWindowVisible | Determines if window visible in the screen
LoadToolBar | Call this member function to load the toolbar specified by nIDResource.
MergeToolBar | This method is called to restore toolbar from previous state
ModifyBarStyle | Modifies the styles of the toolbar.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnPaintManagerChanged | This method is called when paint manager was changed
OnRecalcLayout | This method recalculates the position of the toolbar.
OnSetPreviewMode | Call this method to hide/show toolbars in preview mode.
Reset | Resets the controls to their original state.
SetBarInfo | Sets bar information.
SetCloseable | Call this method to enable/disable close able property of the command bar.
SetContextMenuPresent | This method allows to hide toolbar in a context menu.
SetCustomizeDialogPresent | This method allows to hide toolbar in a customize dialog
SetPosition | Call this member to set the position of the toolbar.
SetTemporary | Call this method to set this control to temporary.
SetVisible | Call this member function to show or hide the toolbar.
ShouldSerializeBar | This method is called to check if Toolbar was changed and have to be saved
ShowExpandButton | Call this method to show/hide expand button of toolbar


CXTPToolBar Data Members

CXTPToolBar Class, Legend, Protected Data Members
CXTPToolBar Data Members
Class

CXTPToolBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bBuiltIn | TRUE if toolbar is built-in.
m_bContextMenuPresent | TRUE if the command bar is present in context menu.
m_bInRecalcLayout | TRUE if RecalcLayout method is called
m_bPreviewMode | TRUE if Toolbar was visible in preview mode.
m_bPreviewVisible | TRUE if Toolbar was visible in preview mode.
m_bShowExpandButton | TRUE to show expand button of toolbar.
m_bTearOff | TRUE if toolbar is tear-offed.
m_bTemporary | TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)
m_pDockBar | Parent dock bar.
m_pDockContext | Docking context.


CXTPToolBar::m_bBuiltIn Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_bBuiltIn Data Member

TRUE if toolbar is built-in.

BOOL m_bBuiltIn;
Group

CXTPToolBar Data Members


CXTPToolBar::m_bContextMenuPresent Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_bContextMenuPresent Data Member

TRUE if the command bar is present in context menu.

BOOL m_bContextMenuPresent;
Group

CXTPToolBar Data Members


CXTPToolBar::m_bInRecalcLayout Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_bInRecalcLayout Data Member

TRUE if RecalcLayout method is called

BOOL m_bInRecalcLayout;
Group

CXTPToolBar Data Members


CXTPToolBar::m_bPreviewMode Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_bPreviewMode Data Member

TRUE if Toolbar was visible in preview mode.

BOOL m_bPreviewMode;
Group

CXTPToolBar Data Members


CXTPToolBar::m_bPreviewVisible Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_bPreviewVisible Data Member

TRUE if Toolbar was visible in preview mode.

BOOL m_bPreviewVisible;
Group

CXTPToolBar Data Members


CXTPToolBar::m_bShowExpandButton Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_bShowExpandButton Data Member

TRUE to show expand button of toolbar.

BOOL m_bShowExpandButton;
Group

CXTPToolBar Data Members


CXTPToolBar::m_bTearOff Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_bTearOff Data Member

TRUE if toolbar is tear-offed.

BOOL m_bTearOff;
Group

CXTPToolBar Data Members


CXTPToolBar::m_bTemporary Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_bTemporary Data Member

TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)

BOOL m_bTemporary;
Group

CXTPToolBar Data Members


CXTPToolBar::m_pDockBar Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_pDockBar Data Member

Parent dock bar.

CXTPDockBar* m_pDockBar;
Group

CXTPToolBar Data Members


CXTPToolBar::m_pDockContext Data Member

CXTPToolBar Data Members, CXTPToolBar Class
CXTPToolBar::m_pDockContext Data Member

Docking context.

CXTPDockContext* m_pDockContext;
Group

CXTPToolBar Data Members


CXTPToolBar Methods

CXTPToolBar Class, Legend, Protected Methods, Public Methods
CXTPToolBar Methods
Class

CXTPToolBar Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Copy | This method makes a copy of the command bar.
Create | Creates a toolbar.
DoPropExchange | Reads or writes this object from or to an archive.
GetBorders | This method retrieves borders of toolbar
MergeToolBar | This method is called to restore toolbar from previous state
OnPaintManagerChanged | This method is called when paint manager was changed
ShouldSerializeBar | This method is called to check if Toolbar was changed and have to be saved
Public Methods
Public Methods
Public Method | Description
CalcDockingLayout | This method calculates the dimensions of a toolbar.
CalcDynamicLayout | This method calculates the dimensions of a toolbar.
CreateToolBar | This method creates the ToolBar control.
EnableDocking | Call this method to set docking flags.
GetBarInfo | Retrieves bar information for serialization routines.
GetDockBar | Retrieves the parent dock bar.
IsBuiltIn | Determines if the toolbar is built-in.
IsCloseable | Call this method to retrieve the close able property of the command bar.
IsContextMenuPresent | Call this member to determine if this toolbar is included in the right-click context menu.
IsCustomizeDialogPresent | Call this member to determine if this toolbar is included in the customize dialog.
IsTemporary | Call this method to determine if the control is temporary.
IsVisible | Returns a Boolean value that indicates whether the toolbar is visible or hidden.
IsWindowVisible | Determines if window visible in the screen
LoadToolBar | Call this member function to load the toolbar specified by nIDResource.
ModifyBarStyle | Modifies the styles of the toolbar.
OnHookKeyDown | The framework calls this member function when a non-system key is pressed.
OnRecalcLayout | This method recalculates the position of the toolbar.
OnSetPreviewMode | Call this method to hide/show toolbars in preview mode.
Reset | Resets the controls to their original state.
SetBarInfo | Sets bar information.
SetCloseable | Call this method to enable/disable close able property of the command bar.
SetContextMenuPresent | This method allows to hide toolbar in a context menu.
SetCustomizeDialogPresent | This method allows to hide toolbar in a customize dialog
SetPosition | Call this member to set the position of the toolbar.
SetTemporary | Call this method to set this control to temporary.
SetVisible | Call this member function to show or hide the toolbar.
ShowExpandButton | Call this method to show/hide expand button of toolbar


CXTPToolBar::CalcDockingLayout Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::CalcDockingLayout Method

This method calculates the dimensions of a toolbar.

virtual CSize CalcDockingLayout(
    int nLength,
    DWORD dwMode,
    int nWidth = 0
);
Parameters

nLength
Length of the bar.
dwMode
Mode to dock.
nWidth
Width of the bar.

Returns

Size of the docked toolbar.

Group

CXTPToolBar Methods


CXTPToolBar::CalcDynamicLayout Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::CalcDynamicLayout Method

This method calculates the dimensions of a toolbar.

virtual CSize CalcDynamicLayout(
    int nLength,
    DWORD dwMode
);
Parameters

nLength
The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode
Mode to dock.

Returns

Size of the docked toolbar.

Group

CXTPToolBar Methods


CXTPToolBar::Copy Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::Copy Method

This method makes a copy of the command bar.

virtual void Copy(
    CXTPCommandBar* pCommandBar,
    BOOL bRecursive = FALSE
);
Parameters

pCommandBar
Command bar needed to be copied.
bRecursive
TRUE to copy recursively.

Group

CXTPToolBar Methods


CXTPToolBar::Create Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::Create Method

Creates a toolbar.

virtual BOOL Create(
    CWnd* pParentWnd,
    BOOL bFloat
);
Parameters

pParentWnd
Points to a CWnd object.
bFloat
TRUE to create a floating bar.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPToolBar Methods


CXTPToolBar::CreateToolBar Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::CreateToolBar Method

This method creates the ToolBar control.

BOOL CreateToolBar(
    DWORD dwStyle,
    CWnd* pParentWnd,
    UINT nID = AFX_IDW_TOOLBAR
);
Parameters

dwStyle
Styles for the toolbars.
pParentWnd
Specifies the parent window of the TaskPanel control.
nID
Specifies the Toolbar control ID.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPToolBar Methods


CXTPToolBar::DoPropExchange Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPToolBar Methods


CXTPToolBar::EnableDocking Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::EnableDocking Method

Call this method to set docking flags.

void EnableDocking(
    DWORD dwFlags = xtpFlagAlignAny | xtpFlagFloating | xtpFlagHideWrap
);
Parameters

dwFlags
Flags of docking. Can be any of the values listed in the Remarks section.

Remarks

dwFlags parameter can be one or more of the following:

  • xtpFlagAlignTop Allows docking at the top of the client area. .
  • xtpFlagAlignBottom Allows docking at the bottom of the client area.
  • xtpFlagAlignLeft Allows docking on the left side of the client area.
  • xtpFlagAlignRight Allows docking on the left side of the client area.
  • xtpFlagFloating Allows floating.
  • xtpFlagHideWrap Allows to hide wrapped controls..
  • xtpFlagStretched Indicates the bar is stretched..
Group

CXTPToolBar Methods


CXTPToolBar::GetBarInfo Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::GetBarInfo Method

Retrieves bar information for serialization routines.

void GetBarInfo(
    CToolBarInfo* pInfo
);
Parameters

pInfo
Points to a CToolBarInfo object.

Group

CXTPToolBar Methods


CXTPToolBar::GetBorders Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::GetBorders Method

This method retrieves borders of toolbar

virtual CRect GetBorders();
Returns

Borders of toolbar

Group

CXTPToolBar Methods


CXTPToolBar::GetDockBar Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::GetDockBar Method

Retrieves the parent dock bar.

CXTPDockBar* GetDockBar() const;
Returns

A pointer to a CXTPDockBar object.

Body Source
CXTPDockBar* CXTPToolBar::GetDockBar() const {
    return m_pDockBar;
}
Group

CXTPToolBar Methods


CXTPToolBar::IsBuiltIn Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::IsBuiltIn Method

Determines if the toolbar is built-in.

BOOL IsBuiltIn() const;
Returns

TRUE if toolbar is built-in; otherwise returns FALSE.

Body Source
BOOL CXTPToolBar::IsBuiltIn() const{
    return m_bBuiltIn;
}
Group

CXTPToolBar Methods


CXTPToolBar::IsCloseable Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::IsCloseable Method

Call this method to retrieve the close able property of the command bar.

BOOL IsCloseable() const;
Returns

TRUE if the control is close able.

Body Source
BOOL CXTPToolBar::IsCloseable() const {
    return m_bCloseable;
}
Group

CXTPToolBar Methods


CXTPToolBar::IsContextMenuPresent Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::IsContextMenuPresent Method

Call this member to determine if this toolbar is included in the right-click context menu.

BOOL IsContextMenuPresent() const;
Body Source
BOOL CXTPToolBar::IsContextMenuPresent() const{
    return m_bContextMenuPresent;
}
Group

CXTPToolBar Methods


CXTPToolBar::IsCustomizeDialogPresent Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::IsCustomizeDialogPresent Method

Call this member to determine if this toolbar is included in the customize dialog.

BOOL IsCustomizeDialogPresent() const;
Body Source
BOOL CXTPToolBar::IsCustomizeDialogPresent() const {
    return m_bCustomizeDialogPresent;
}
Group

CXTPToolBar Methods


CXTPToolBar::IsTemporary Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::IsTemporary Method

Call this method to determine if the control is temporary.

BOOL IsTemporary() const;
Returns

TRUE if the control is temporary.

Remarks

Temporary toolbars will not be saved to the system registry when the application is closed (If SaveCommandBars is used), and they will not be restored when the application is opened (If LoadCommandBars is used).

Body Source
BOOL CXTPToolBar::IsTemporary() const {
    return m_bTemporary;

}
Group

CXTPToolBar Methods


CXTPToolBar::IsVisible Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::IsVisible Method

Returns a Boolean value that indicates whether the toolbar is visible or hidden.

virtual BOOL IsVisible() const;
Returns

TRUE if the toolbar is visible.

Body Source
virtual BOOL IsVisible() const { return m_bVisible; }
Group

CXTPToolBar Methods


CXTPToolBar::IsWindowVisible Method

CXTPToolBar Methods, CXTPToolBar Class, See Also
CXTPToolBar::IsWindowVisible Method

Determines if window visible in the screen

BOOL IsWindowVisible() const;
Returns

TRUE if toolbar is visible

See Also

IsVisible

Group

CXTPToolBar Methods


CXTPToolBar::LoadToolBar Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::LoadToolBar Method

Call this member function to load the toolbar specified by nIDResource.

BOOL LoadToolBar(
    UINT nIDResource,
    BOOL bLoadIcons = TRUE
);
Parameters

nIDResource
Resource ID of the toolbar to be loaded.
bLoadIcons
TRUE to load icons from application resources.

Returns

Nonzero if successful; otherwise 0.

Group

CXTPToolBar Methods


CXTPToolBar::MergeToolBar Method

CXTPToolBar Methods, CXTPToolBar Class, See Also
CXTPToolBar::MergeToolBar Method

This method is called to restore toolbar from previous state

virtual void MergeToolBar(
    CXTPCommandBar* pCommandBar,
    BOOL bSilent
);
Parameters

pCommandBar
previously saved toolbar
bSilent
TRUE to restore without warnings

See Also

ShouldSerializeBar

Group

CXTPToolBar Methods


CXTPToolBar::ModifyBarStyle Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::ModifyBarStyle Method

Modifies the styles of the toolbar.

void ModifyBarStyle(
    DWORD dwRemove,
    DWORD dwAdd
);
Parameters

dwRemove
Styles to remove.
dwAdd
Styles to add.

Body Source
void CXTPToolBar::ModifyBarStyle(DWORD dwRemove, DWORD dwAdd) {
    m_dwStyle |= dwAdd;
    m_dwStyle &= ~dwRemove;
}
Group

CXTPToolBar Methods


CXTPToolBar::OnHookKeyDown Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::OnHookKeyDown Method

The framework calls this member function when a non-system key is pressed.

BOOL OnHookKeyDown(
    UINT nChar,
    LPARAM lParam
);
Parameters

nChar
Specifies the virtual key code of the given key.
lParam
Specifies additional message-dependent information.

Returns

TRUE if key handled, otherwise returns FALSE.

Group

CXTPToolBar Methods


CXTPToolBar::OnPaintManagerChanged Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::OnPaintManagerChanged Method

This method is called when paint manager was changed

virtual void OnPaintManagerChanged();
Body Source
void CXTPToolBar::OnPaintManagerChanged() {
}
Group

CXTPToolBar Methods


CXTPToolBar::OnRecalcLayout Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::OnRecalcLayout Method

This method recalculates the position of the toolbar.

void OnRecalcLayout();
Group

CXTPToolBar Methods


CXTPToolBar::OnSetPreviewMode Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::OnSetPreviewMode Method

Call this method to hide/show toolbars in preview mode.

void OnSetPreviewMode(
    BOOL bPreview
);
Parameters

bPreview
Preview mode.

Group

CXTPToolBar Methods


CXTPToolBar::Reset Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::Reset Method

Resets the controls to their original state.

virtual void Reset(
    BOOL bShowWarningMessage
);
Parameters

bShowWarningMessage
TRUE to show warning message

Group

CXTPToolBar Methods


CXTPToolBar::SetBarInfo Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::SetBarInfo Method

Sets bar information.

void SetBarInfo(
    CToolBarInfo* pInfo
);
Parameters

pInfo
Points to a CToolBarInfo object.

Group

CXTPToolBar Methods


CXTPToolBar::SetCloseable Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::SetCloseable Method

Call this method to enable/disable close able property of the command bar.

void SetCloseable(
    BOOL bCloseable
);
Parameters

bCloseable
TRUE to allow toolbar to be closed by user.

Body Source
void CXTPToolBar::SetCloseable(BOOL bCloseable) {
    m_bCloseable = bCloseable;
}
Group

CXTPToolBar Methods


CXTPToolBar::SetContextMenuPresent Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::SetContextMenuPresent Method

This method allows to hide toolbar in a context menu.

void SetContextMenuPresent(
    BOOL bPresent
);
Parameters

bPresent
TRUE to show the toolbar in a context menu.

Body Source
void CXTPToolBar::SetContextMenuPresent(BOOL bPresent) {
    m_bContextMenuPresent = bPresent;
}
Group

CXTPToolBar Methods


CXTPToolBar::SetCustomizeDialogPresent Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::SetCustomizeDialogPresent Method

This method allows to hide toolbar in a customize dialog

void SetCustomizeDialogPresent(
    BOOL bPresent
);
Parameters

bPresent
TRUE to show the toolbar in a customize dialog.

Body Source
void CXTPToolBar::SetCustomizeDialogPresent(BOOL bPresent) {
    m_bCustomizeDialogPresent = bPresent;
}
Group

CXTPToolBar Methods


CXTPToolBar::SetPosition Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::SetPosition Method

Call this member to set the position of the toolbar.

BOOL SetPosition(
    XTPBarPosition barPosition
);
Parameters

barPosition
New position of toolbar.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPToolBar Methods


CXTPToolBar::SetTemporary Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::SetTemporary Method

Call this method to set this control to temporary.

void SetTemporary(
    BOOL bTemporary
);
Parameters

bTemporary
TRUE if this control is temporary.

Remarks

Temporary toolbars will not be saved to the system registry when the application is closed (If SaveCommandBars is used), and they will not be restored when the application is opened (If LoadCommandBars is used).

Body Source
void CXTPToolBar::SetTemporary(BOOL bTemporary) {
    m_bTemporary = bTemporary;
}
Group

CXTPToolBar Methods


CXTPToolBar::SetVisible Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::SetVisible Method

Call this member function to show or hide the toolbar.

virtual void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show the toolbar; FALSE to hide.

Group

CXTPToolBar Methods


CXTPToolBar::ShouldSerializeBar Method

CXTPToolBar Methods, CXTPToolBar Class
CXTPToolBar::ShouldSerializeBar Method

This method is called to check if Toolbar was changed and have to be saved

virtual BOOL ShouldSerializeBar();
Returns

TRUE if toolbar have to be saved

Group

CXTPToolBar Methods


CXTPToolBar::ShowExpandButton Method

CXTPToolBar Methods, CXTPToolBar Class, Body Source
CXTPToolBar::ShowExpandButton Method

Call this method to show/hide expand button of toolbar

void ShowExpandButton(
    BOOL bShowExpandButton
);
Parameters

bShowExpandButton
TRUE to show expand button; FALSE to hide

Body Source
void CXTPToolBar::ShowExpandButton(BOOL bShowExpandButton) {
    m_bShowExpandButton = bShowExpandButton;
    DelayLayout();
}
Group

CXTPToolBar Methods


CXTPToolBar Constructors

CXTPToolBar Class, Legend, Public Methods
CXTPToolBar Constructors
Class

CXTPToolBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPToolBar | Constructs a CXTPToolBar object


CXTPToolBar::CXTPToolBar Constructor

CXTPToolBar Constructors, CXTPToolBar Class
CXTPToolBar::CXTPToolBar Constructor

Constructs a CXTPToolBar object

CXTPToolBar();
Group

CXTPToolBar Constructors


CXTPToolBar Destructors

CXTPToolBar Class, Legend, Public Methods
CXTPToolBar Destructors
Class

CXTPToolBar Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPToolBar | Destroys a CXTPToolBar object, handles cleanup and deallocation


CXTPToolBar::~CXTPToolBar Destructor

CXTPToolBar Destructors, CXTPToolBar Class
CXTPToolBar::~CXTPToolBar Destructor

Destroys a CXTPToolBar object, handles cleanup and deallocation

~CXTPToolBar();
Group

CXTPToolBar Destructors


Functions

Functions, Legend, Command Bars
Functions
Functions
Function | Description
XTPPaintManager | Call this function to access CXTPPaintManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPPaintManager.
XTPSoundManager | Call this function to access CXTPSoundManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSoundManager.
Module

Command Bars

Legend
Method


XTPPaintManager Function

XTPPaintManager.h, Functions, Body Source, Example
XTPPaintManager Function

Call this function to access CXTPPaintManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPPaintManager.

CXTPPaintManager* XTPPaintManager();
File

XTPPaintManager.h

Example
XTPPaintManager()->GetIconsInfo()->bIconsWithShadow = FALSE;
Body Source
CXTPPaintManager* XTPPaintManager() {
    if (CXTPPaintManager::s_pInstance == NULL)
    {
        CXTPPaintManager::SetTheme(xtpThemeOffice2000);
    }
    return CXTPPaintManager::s_pInstance;
}
Group

Functions


XTPSoundManager Function

XTPSoundManager.h, Functions, Example
XTPSoundManager Function

Call this function to access CXTPSoundManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSoundManager.

CXTPSoundManager* XTPSoundManager();
File

XTPSoundManager.h

Example
XTPSoundManager()->PlaySystemSound(xtpSoundMenuCommand);
Group

Functions


Structs, Records, Enums

Enumerations, Legend, Command Bars, Structures
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPAnimationType | Enumerated type used to determine the animation effect of popup bars.
XTPBarPosition | Position of the command bar
XTPBarType | Type of the command bar.
XTPButtonStyle | Button's styles
XTPControlCustomVerticalOptions | Vertical options enumerator.
XTPControlFlags | Flags of the control.
XTPControlHideFlags | Control's hide flags, these are flags that specify why a control is hidden.
XTPControlType | Type of the control.
XTPIdleFlags | Flags for idle routine
XTPKeyboardCuesShow | Enumerated type used to determine menu underlines.
XTPKeyboardCuesUse | Enumerated type used to determine if menu underlines execute popups.
XTPMenuBarFlags | Menubar system button flags.
XTPPaintTheme | Paint themes used by command bars.
XTPPopupDirection | Docking direction enumerator.
XTPRibbonTabContextColor | Ribbon Tab context color
XTPSoundManagerState | Enumeration used to play system sound.
XTPSpecialControl | Special control with extended drawing.
XTPSpecialKey | Special keys enumerator.
XTPToolBarFlags | Docking flags.
XTPWorkspaceActivateTab | XTPWorkspaceActivateTab enumerator, used to determine which tab will become active after the currently active tab is closed.
XTPWorkspaceButtons | Workspace buttons enumerator, used to indicate which tab navigation buttons to display in the TabWorkspace.
XTPWorkspaceNewTabPosition | XTPWorkspaceNewTabPosition enumerator, used to determine where new tab will appear
Module

Command Bars

Legend
Structure
Enumeration
Structures
Structure | Description
NMXTPCHARHDR | Structure used as parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages.
NMXTPTABCHANGE | Structure used as parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when Ribbon tab is changed
XTP_COMMANDBARS_CATEGORYINFO | This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages
XTP_COMMANDBARS_ICONSINFO | This structure collect icons options for command bars.
XTP_COMMANDBARS_PROPEXCHANGE_PARAM | XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings. This is a set of State options that will be used to change how and what will be saved and loaded when loading and saving XML files.
LPCREATEBARSTRUCT | Create bar structure
LPCREATECONTROLSTRUCT | Create control structure.
LPNMXTPCONTROL | This structure is passed as parameter in CBN_XTP_EXECUTE message.
NMXTPCONTROL | This structure is passed as parameter in CBN_XTP_EXECUTE message.
XTP_COMMANDBARS_CREATEBAR | Create bar structure
XTP_COMMANDBARS_CREATECONTROL | Create control structure.


NMXTPCHARHDR Structure

XTPControlComboBoxExt.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
NMXTPCHARHDR Structure

Structure used as parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages.

struct NMXTPCHARHDR : public NMXTPCONTROL {
  CHARFORMAT cf;
};
File

XTPControlComboBoxExt.h

Members

cf
Character formatting in a rich edit control.

See Also

XTP_FN_SETFORMAT, XTP_FN_GETFORMAT, CXTPControlFontComboBox

Example

See Example of XTP_FN_SETFORMAT

Group

Structs, Records, Enums


NMXTPTABCHANGE Structure

XTPRibbonControlTab.h, Structs, Records, Enums
NMXTPTABCHANGE Structure

Structure used as parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when Ribbon tab is changed

struct NMXTPTABCHANGE : public NMXTPCONTROL {
  CXTPRibbonTab* pTab;
};
File

XTPRibbonControlTab.h

Members

pTab
Ribbon Tab to be selected

Group

Structs, Records, Enums


XTP_COMMANDBARS_CATEGORYINFO Structure

XTPCustomizeCommandsPage.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_COMMANDBARS_CATEGORYINFO Structure

This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages

struct XTP_COMMANDBARS_CATEGORYINFO {
  CString strCategory;
  CXTPControls* pControls;
};
File

XTPCustomizeCommandsPage.h

Members

strCategory
Category caption
pControls
Controls of this category.

See Also

CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage

Group

Structs, Records, Enums


XTP_COMMANDBARS_ICONSINFO Structure

XTPPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_COMMANDBARS_ICONSINFO Structure

This structure collect icons options for command bars.

struct XTP_COMMANDBARS_ICONSINFO {
  BOOL bUseFadedIcons;
  BOOL bUseDisabledIcons;
  BOOL bIconsWithShadow;
  BOOL bOfficeStyleDisabledIcons;
};
File

XTPPaintManager.h

Members

bUseFadedIcons
If TRUE, Icons will appear faded.
bUseDisabledIcons
If TRUE, disabled icons will be used when the control is disabled.
bIconsWithShadow
If TRUE, when the mouse pointer is moved over a command bar control, the icons will appear to "jump" away from the screen casting a shadow.
bOfficeStyleDisabledIcons
If TRUE, Office 2003 style disabled icons will be drawn when using disabled icons.

See Also

CXTPPaintManager::GetIconsInfo

Example
XTPPaintManager()->GetIconsInfo()->bIconsWithShadow = FALSE;
Group

Structs, Records, Enums


XTP_COMMANDBARS_PROPEXCHANGE_PARAM Structure

XTPCommandBars.h, Structs, Records, Enums, Example, See Also
XTP_COMMANDBARS_PROPEXCHANGE_PARAM Structure

XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings. This is a set of State options that will be used to change how and what will be saved and loaded when loading and saving XML files.

struct XTP_COMMANDBARS_PROPEXCHANGE_PARAM {
  BOOL bSerializeControls;
  BOOL bSaveOnlyCustomized;
  BOOL bLoadSilent;
  BOOL bSaveOriginalControls;
  BOOL bSerializeImages;
  BOOL bSerializeOptions;
  BOOL bSerializeLayout;
  BOOL bSerializeDesignerControls;
  BOOL bSerializeActions;
  CXTPCommandBars* pCommandBars;
};
File

XTPCommandBars.h

Members

bSerializeControls
If True, the controls in the CommandBars will be saved.
bSaveOnlyCustomized
If True, only CommandBars that have been customized will be saved.
bLoadSilent
If True, no message boxes will be displayed when the CommandBar layout is loaded.
bSaveOriginalControls
If True, the original state of the CommandBars is saved along with the customized state For example, if a button on a toolbar is moved, then both the original and modified states will be saved.
bSerializeImages
If True, the images stored in the ImageManager will be saved.
bSerializeOptions
If True, the setting on the Keyboard and Options pages of the Customize dialog will be saved.
bSerializeLayout
If True, the layout of the CommandBars will be saved.
bSerializeDesignerControls
In the CommandBar Designer you can export a XCB file to a XML file and Load it in your project.
bSerializeActions
TRUE to save/restore actions for commandbars
pCommandBars
Pointer to the CommandBars object that the XTP_COMMANDBARS_PROPEXCHANGE_PARAM setting apply to.

Remarks

When saving your XML string to a file, be sure to use the .XML file extension. If you open up your .XML file in your favorite web browser it will automatically format the XML string into the correct format.

See Also

CXTPCommandBars::DoPropExchange, CXTPPropExchangeXMLNode

Example
XTP_COMMANDBARS_PROPEXCHANGE_PARAM param;
param.bSerializeControls = TRUE;
// Serialize to XML
CXTPPropExchangeXMLNode px(FALSE, 0, _T("Settings"));
CXTPPropExchangeSection pxCommandBars(px.GetSection(_T("CommandBars")));
GetCommandBars()->DoPropExchange(&pxCommandBars, &param);
px.SaveToFile(m_strIniFileName);
Group

Structs, Records, Enums


XTPAnimationType Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPAnimationType Enumeration

Enumerated type used to determine the animation effect of popup bars.

enum XTPAnimationType {
  xtpAnimateWindowsDefault,
  xtpAnimateRandom,
  xtpAnimateUnfold,
  xtpAnimateSlide,
  xtpAnimateFade,
  xtpAnimateNone
};
File

XTPCommandBarsDefines.h

Members

xtpAnimateWindowsDefault
As defined in the "Display" settings.
xtpAnimateRandom
Any of the first three in random selection.
xtpAnimateUnfold
Unfold top to bottom.
xtpAnimateSlide
Slide in from left.
xtpAnimateFade
Fade-in.
xtpAnimateNone
No animation.

See Also

CXTPCommandBarsOptions, CXTPCommandBarsOptions::animationType

Example
pCommandBars->GetCommandBarsOptions()->animationType = xtpAnimateSlide;
Group

Structs, Records, Enums


XTPBarPosition Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPBarPosition Enumeration

Position of the command bar

enum XTPBarPosition {
  xtpBarTop = 0,
  xtpBarBottom = 1,
  xtpBarLeft = 2,
  xtpBarRight = 3,
  xtpBarFloating = 4,
  xtpBarPopup = 5,
  xtpBarListBox = 6,
  xtpBarNone = 7
};
File

XTPCommandBarsDefines.h

Members

xtpBarTop
Docked at top.
xtpBarBottom
Docked at bottom.
xtpBarLeft
Docked at left.
xtpBarRight
Docked at right.
xtpBarFloating
Floated.
xtpBarPopup
Popup.
xtpBarListBox
List box.
xtpBarNone
None.

See Also

CXTPCommandBars, CXTPToolBar, CXTPToolBar::SetPosition

Example
CXTPToolBar* pToolBar = pCommandBars->Add("ToolBar", xtpBarTop);
pToolBar->SetPosition(xtpBarBottom);
Group

Structs, Records, Enums


XTPBarType Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPBarType Enumeration

Type of the command bar.

enum XTPBarType {
  xtpBarTypeMenuBar,
  xtpBarTypeNormal,
  xtpBarTypePopup,
  xtpBarTypeRibbon
};
File

XTPCommandBarsDefines.h

Members

xtpBarTypeMenuBar
Command bar is a menu bar.
xtpBarTypeNormal
Command bar is a toolbar.
xtpBarTypePopup
Command bar is a popup.
xtpBarTypeRibbon
Command bar is a ribbonbar.

See Also

CXTPCommandBars, CXTPCommandBar, CXTPCommandBar::GetType

Example
CXTPCommandBar* pMenuBar = pCommandBars->GetMenuBar();
ASSERT(pMenuBar->GetType() == xtpBarTypeMenuBar);
Group

Structs, Records, Enums


XTPButtonStyle Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPButtonStyle Enumeration

Button's styles

enum XTPButtonStyle {
  xtpButtonUndefined = -1,
  xtpButtonAutomatic = 0,
  xtpButtonCaption = 1,
  xtpButtonIcon = 2,
  xtpButtonIconAndCaption = 3,
  xtpButtonIconAndCaptionBelow = 4,
  xtpButtonCaptionAndDescription = 5
};
File

XTPCommandBarsDefines.h

Members

xtpButtonUndefined
Automatic style.
xtpButtonAutomatic
Automatic style.
xtpButtonCaption
Button draw only caption.
xtpButtonIcon
Button draw only icon.
xtpButtonIconAndCaption
Button draw icon and caption.
xtpButtonIconAndCaptionBelow
Button draw icon and draw caption below icon.
xtpButtonCaptionAndDescription
Button draw icon, caption and description for popup bar.

Remarks

This styles can be applied to CXTPControlButton and CXTPControlPopup derived classes.

See Also

CXTPControlButton, CXTPControl::SetStyle, CXTPControl::GetStyle

Example
pControl->SetStyle(xtpButtonIconAndCaption);
Group

Structs, Records, Enums


XTPControlCustomVerticalOptions Enumeration

XTPControlCustom.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPControlCustomVerticalOptions Enumeration

Vertical options enumerator.

enum XTPControlCustomVerticalOptions {
  xtpVerticalHide,
  xtpVerticalShow,
  xtpVerticalButton
};
File

XTPControlCustom.h

Members

xtpVerticalHide
To hide control if parent toolbar vertically docked.
xtpVerticalShow
To show control if parent toolbar vertically docked.
xtpVerticalButton
To show control as button.

See Also

CXTPControlCustom::SetVerticalPositionOption

Example
CXTPControlCustom* pControl = (CXTPControlCustom*)pToolBar->GetControls()->Add(xtpControlCustom, ID_VIEW_LOGO);
pControl->SetVerticalPositionOption(xtpVerticalShow);
Group

Structs, Records, Enums


XTPControlFlags Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPControlFlags Enumeration

Flags of the control.

enum XTPControlFlags {
  xtpFlagRightAlign = 1,
  xtpFlagSkipFocus = 2,
  xtpFlagLeftPopup = 4,
  xtpFlagManualUpdate = 8,
  xtpFlagNoMovable = 16,
  xtpFlagControlStretched = 32,
  xtpFlagShowPopupBarTip = 64,
  xtpFlagWrapRow = 128
};
File

XTPCommandBarsDefines.h

Members

xtpFlagRightAlign
Control is right aligned.
xtpFlagSkipFocus
Control does not have focus.
xtpFlagLeftPopup
To Pop up child bar left.
xtpFlagManualUpdate
Control is manually updated.
xtpFlagNoMovable
To disable customization.
xtpFlagControlStretched
Control is stretched in parent command bar.
xtpFlagShowPopupBarTip
Show tooltip always
xtpFlagWrapRow
Wrap row for toolbar or popup bar.

See Also

CXTPControl, CXTPControl::SetFlags

Example
pControl->SetFlags(xtpFlagRightAlign);
Group

Structs, Records, Enums


XTPControlHideFlags Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPControlHideFlags Enumeration

Control's hide flags, these are flags that specify why a control is hidden.

enum XTPControlHideFlags {
  xtpNoHide = 0,
  xtpHideGeneric = 1,
  xtpHideWrap = 2,
  xtpHideDockingPosition = 4,
  xtpHideScroll = 8,
  xtpHideCustomize = 16,
  xtpHideExpand = 32,
  xtpHideDocTemplate = 64,
  xtpHideRibbonTab = 128
};
File

XTPCommandBarsDefines.h

Members

xtpNoHide
Control is visible.
xtpHideGeneric
Control is hidden by generic reason.
xtpHideWrap
Control is hidden by wrap.
xtpHideDockingPosition
Control is hidden by docking position.
xtpHideScroll
Control is hidden by scrolling.
xtpHideCustomize
Control is hidden by customize settings.
xtpHideExpand
If the control is rarely used and it is not visible because the intelligent menus option on and the command is a hidden command.
xtpHideDocTemplate
Control is hidden because active template excluded from its list.
xtpHideRibbonTab
Control is hidden because inactive ribbon tab.

See Also

CXTPControl, CXTPControl::SetHideFlags

Example
pControl->SetHideFlags(xtpHideGeneric);
Group

Structs, Records, Enums


XTPControlType Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPControlType Enumeration

Type of the control.

enum XTPControlType {
  xtpControlError,
  xtpControlButton,
  xtpControlPopup,
  xtpControlButtonPopup,
  xtpControlSplitButtonPopup,
  xtpControlComboBox,
  xtpControlEdit,
  xtpControlCustom,
  xtpControlLabel,
  xtpControlCheckBox,
  xtpControlGallery,
  xtpControlRadioButton
};
File

XTPCommandBarsDefines.h

Members

xtpControlError
Type is not defined.
xtpControlButton
Button type.
xtpControlPopup
Popup type.
xtpControlButtonPopup
Button popup.
xtpControlSplitButtonPopup
Split button popup.
xtpControlComboBox
Combo box button.
xtpControlEdit
Edit control.
xtpControlCustom
Custom control.
xtpControlLabel
Label control
xtpControlCheckBox
CheckBox control
xtpControlGallery
Gallery control
xtpControlRadioButton
Radio Button control

See Also

CXTPControl, CXTPControl::GetType, CXTPControls

Example
pToolBar->GetControls()->Add(xtpControlButton, ID_FILE_NEW);
Group

Structs, Records, Enums


XTPIdleFlags Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPIdleFlags Enumeration

Flags for idle routine

enum XTPIdleFlags {
  xtpIdleLayout = 1,
  xtpIdleRedraw = 2
};
File

XTPCommandBarsDefines.h

Members

xtpIdleLayout
Delay recalculate layout of command bar
xtpIdleRedraw
Delay redraw.command bar.

See Also

CXTPCommandBar::DelayRedraw, CXTPCommandBar::DelayLayout

Example
pToolBar->DelayRedraw();
Group

Structs, Records, Enums


XTPKeyboardCuesShow Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example
XTPKeyboardCuesShow Enumeration

Enumerated type used to determine menu underlines.

enum XTPKeyboardCuesShow {
  xtpKeyboardCuesShowAlways,
  xtpKeyboardCuesShowNever,
  xtpKeyboardCuesShowWindowsDefault
};
File

XTPCommandBarsDefines.h

Members

xtpKeyboardCuesShowAlways
Show keyboard cues always
xtpKeyboardCuesShowNever
Never show keyboard cues
xtpKeyboardCuesShowWindowsDefault
System defined.

Example
pCommandBars->GetCommandBarsOptions()->ShowKeyboardCues(xtpKeyboardCuesShowWindowsDefault);
Group

Structs, Records, Enums


XTPKeyboardCuesUse Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example
XTPKeyboardCuesUse Enumeration

Enumerated type used to determine if menu underlines execute popups.

enum XTPKeyboardCuesUse {
  xtpKeyboardCuesUseMenuOnly = 0,
  xtpKeyboardCuesUseAll = 1,
  xtpKeyboardCuesUseNone = 2,
  xtpKeyboardCuesUseAmpersandOnly = 4
};
File

XTPCommandBarsDefines.h

Members

xtpKeyboardCuesUseMenuOnly
Activate only menu by using underlines
xtpKeyboardCuesUseAll
Activate menu and tool bars by using underlines
xtpKeyboardCuesUseNone
No using underlines
xtpKeyboardCuesUseAmpersandOnly
Activates menu items with ampersand only (by default first character used if no ampersand found)

Example
pCommandBars->GetCommandBarsOptions()->keyboardCuesUse = xtpKeyboardCuesUseAll;
Group

Structs, Records, Enums


XTPMenuBarFlags Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPMenuBarFlags Enumeration

Menubar system button flags.

enum XTPMenuBarFlags {
  xtpFlagHideMinimizeBox = 0x0100L,
  xtpFlagHideMaximizeBox = 0x0200L,
  xtpFlagIgnoreSetMenuMessage = 0x0400L,
  xtpFlagUseMDIMenus = 0x0800L,
  xtpFlagHideClose = 0x1000L,
  xtpFlagHideMDIButtons = xtpFlagHideMinimizeBox|xtpFlagHideMaximizeBox|xtpFlagHideClose,
  xtpFlagAddMDISysPopup = 0x2000L
};
File

XTPCommandBarsDefines.h

Members

xtpFlagHideMinimizeBox
To hide minimize box.
xtpFlagHideMaximizeBox
To hide maximize box.
xtpFlagIgnoreSetMenuMessage
To ignore MDI menus.
xtpFlagUseMDIMenus
To use MDI menus.
xtpFlagHideClose
To hide close button.
xtpFlagHideMDIButtons
Specifies to hide all MDI buttons displayed on the Command Bar.
xtpFlagAddMDISysPopup
To add system MDI popup bar.

See Also

CXTPMenuBar, CXTPCommandBar, CXTPCommandBar::SetFlags

Example
CXTPMenuBar* pMenuBar = pCommandBars->SetMenu(_T("Menu Bar", IDR_MAINFRAME);
pMenuBar->SetFlags(xtpFlagIgnoreSetMenuMessage);
Group

Structs, Records, Enums


XTPPaintTheme Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPaintTheme Enumeration

Paint themes used by command bars.

enum XTPPaintTheme {
  xtpThemeOffice2000,
  xtpThemeOfficeXP,
  xtpThemeOffice2003,
  xtpThemeNativeWinXP,
  xtpThemeWhidbey,
  xtpThemeOffice2007,
  xtpThemeRibbon,
  xtpThemeVisualStudio2008,
  xtpThemeCustom
};
File

XTPCommandBarsDefines.h

Members

xtpThemeOffice2000
Office 2000 theme.
xtpThemeOfficeXP
Office XP theme.
xtpThemeOffice2003
Office 2003 theme.
xtpThemeNativeWinXP
Windows XP themes support.
xtpThemeWhidbey
Visual Studio 2005 theme.
xtpThemeOffice2007
Office 2007 theme.
xtpThemeRibbon
Office 2007 style ribbon theme
xtpThemeVisualStudio2008
Visual Studio 2008 theme
xtpThemeCustom
Custom theme.

See Also

CXTPCommandBars, CXTPPaintManager

Example
XTPPaintManager()->SetTheme(xtpThemeWhidbey);
Group

Structs, Records, Enums


XTPPopupDirection Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, See Also
XTPPopupDirection Enumeration

Docking direction enumerator.

enum XTPPopupDirection {
  xtpPopupRight = 0,
  xtpPopupLeft = 1,
  xtpPopupDown = 2,
  xtpPopupUp = 4
};
File

XTPCommandBarsDefines.h

Members

xtpPopupRight
Popup Bar will be opened right of control.
xtpPopupLeft
Popup Bar will be opened left of control.
xtpPopupDown
Popup Bar will be opened bottom of control.
xtpPopupUp
Popup Bar will be opened top of control.

See Also

CXTPPopupBar, CXTPPopupBar::m_popupFlags

Group

Structs, Records, Enums


XTPRibbonTabContextColor Enumeration

XTPRibbonTab.h, Structs, Records, Enums, Example, See Also
XTPRibbonTabContextColor Enumeration

Ribbon Tab context color

enum XTPRibbonTabContextColor {
  xtpRibbonTabContextColorNone,
  xtpRibbonTabContextColorBlue,
  xtpRibbonTabContextColorYellow,
  xtpRibbonTabContextColorGreen,
  xtpRibbonTabContextColorRed,
  xtpRibbonTabContextColorPurple,
  xtpRibbonTabContextColorCyan,
  xtpRibbonTabContextColorOrange
};
File

XTPRibbonTab.h

Members

xtpRibbonTabContextColorNone
Default color
xtpRibbonTabContextColorBlue
Blue context color
xtpRibbonTabContextColorYellow
Yellow context color
xtpRibbonTabContextColorGreen
Green context color
xtpRibbonTabContextColorRed
Red context color
xtpRibbonTabContextColorPurple
Purple context color
xtpRibbonTabContextColorCyan
Cyan context color
xtpRibbonTabContextColorOrange
Orange context color

See Also

CXTPRibbonTab, CXTPRibbonTab::SetContextColor

Example
pTab = pRibbonBar->AddTab(ID_TAB_CHARTFORMAT);
pTab->SetContextTab(xtpRibbonTabContextColorGreen, ID_TAB_CONTEXTCHART);
Group

Structs, Records, Enums


XTPSoundManagerState Enumeration

XTPSoundManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPSoundManagerState Enumeration

Enumeration used to play system sound.

enum XTPSoundManagerState {
  xtpSoundNone,
  xtpSoundMenuCommand,
  xtpSoundMenuPopup
};
File

XTPSoundManager.h

Members

xtpSoundNone
No Sound (default)
xtpSoundMenuCommand
Menu command system sound
xtpSoundMenuPopup
Menu popup system sound

See Also

CXTPSoundManager

Example
XTPSoundManager()->PlaySystemSound(xtpSoundMenuCommand);
Group

Structs, Records, Enums


XTPSpecialControl Enumeration

XTPPaintManager.h, Structs, Records, Enums, See Also
XTPSpecialControl Enumeration

Special control with extended drawing.

enum XTPSpecialControl {
  xtpButtonExpandToolbar,
  xtpButtonExpandMenu,
  xtpButtonHideFloating,
  xtpButtonExpandFloating
};
File

XTPPaintManager.h

Members

xtpButtonExpandToolbar
Control is option button of docking toolbar.
xtpButtonExpandMenu
Control is expand button of popup bar.
xtpButtonHideFloating
Control is hide button of floating toolbar.
xtpButtonExpandFloating
Control is option button of floating toolbar.

See Also

CXTPPaintManager::DrawSpecialControl

Group

Structs, Records, Enums


XTPSpecialKey Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, See Also
XTPSpecialKey Enumeration

Special keys enumerator.

enum XTPSpecialKey {
  xtpKeyNext,
  xtpKeyPrev,
  xtpKeyBack,
  xtpKeyPopup,
  xtpKeyEscape,
  xtpKeyReturn,
  xtpKeyHome,
  xtpKeyEnd,
  xtpKeyLeft,
  xtpKeyRight,
  xtpKeySpace
};
File

XTPCommandBarsDefines.h

Members

xtpKeyNext
Select next key
xtpKeyPrev
Select previous key
xtpKeyBack
Close active popup key
xtpKeyPopup
Open selected popup key
xtpKeyEscape
Escape key
xtpKeyReturn
Return key
xtpKeyHome
Select firs key
xtpKeyEnd
Select last key
xtpKeyLeft
Select left
xtpKeyRight
Select right
xtpKeySpace
Space

Remarks

See CXTPCommandBar::ProcessSpecialKey for details.

See Also

CXTPCommandBar, CXTPCommandBar::ProcessSpecialKey

Group

Structs, Records, Enums


XTPToolBarFlags Enumeration

XTPCommandBarsDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPToolBarFlags Enumeration

Docking flags.

enum XTPToolBarFlags {
  xtpFlagAlignTop = 1,
  xtpFlagAlignBottom = 2,
  xtpFlagAlignLeft = 4,
  xtpFlagAlignRight = 8,
  xtpFlagAlignAny = xtpFlagAlignTop|xtpFlagAlignBottom|xtpFlagAlignLeft|xtpFlagAlignRight,
  xtpFlagFloating = 16,
  xtpFlagHideWrap = 32,
  xtpFlagStretched = 64,
  xtpFlagStretchedShared = 0x100000,
  xtpFlagSmartLayout = 0x200000
};
File

XTPCommandBarsDefines.h

Members

xtpFlagAlignTop
Allows docking at the top of the client area.
xtpFlagAlignBottom
Allows docking at the bottom of the client area.
xtpFlagAlignLeft
Allows docking on the left side of the client area.
xtpFlagAlignRight
Allows docking on the right side of the client area.
xtpFlagAlignAny
Allows docking on any side of the client area.
xtpFlagFloating
Allows floating.
xtpFlagHideWrap
Allow to hide wrapped controls.
xtpFlagStretched
Bar is stretched.
xtpFlagStretchedShared
Bar is stretched, but not fill whole row
xtpFlagSmartLayout
Smart layout enabled

See Also

CXTPToolBar, CXTPToolBar::EnableDocking

Example
CXTPMenuBar* pMenuBar = pCommandBars->SetMenu(_T("Menu Bar", IDR_MAINFRAME);
pMenuBar->EnableDocking(xtpFlagAlignTop | xtpFlagStretched);
Group

Structs, Records, Enums


XTPWorkspaceActivateTab Enumeration

XTPTabClientWnd.h, Structs, Records, Enums, See Also
XTPWorkspaceActivateTab Enumeration

XTPWorkspaceActivateTab enumerator, used to determine which tab will become active after the currently active tab is closed.

enum XTPWorkspaceActivateTab {
  xtpWorkspaceActivateNextToClosed,
  xtpWorkspaceActivateTopmost
};
File

XTPTabClientWnd.h

Members

xtpWorkspaceActivateNextToClosed
Activate tab next to the closed tab.
xtpWorkspaceActivateTopmost
Activate the left-most tab.

See Also

CXTPTabClientWnd.SetAfterCloseActiveTab

Group

Structs, Records, Enums


XTPWorkspaceButtons Enumeration

XTPTabClientWnd.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPWorkspaceButtons Enumeration

Workspace buttons enumerator, used to indicate which tab navigation buttons to display in the TabWorkspace.

enum XTPWorkspaceButtons {
  xtpWorkspaceHideArrows = 1,
  xtpWorkspaceHideClose = 2,
  xtpWorkspaceHideAll = 3,
  xtpWorkspaceShowActiveFiles = 4,
  xtpWorkspaceHideArrowsAlways = 1+8,
  xtpWorkspaceShowCloseTab = 16,
  xtpWorkspaceShowCloseSelectedTab = 32
};
File

XTPTabClientWnd.h

Members

xtpWorkspaceHideArrows
To hide arrow buttons.
xtpWorkspaceHideClose
To hide close button.
xtpWorkspaceHideAll
To hide arrow and close buttons.
xtpWorkspaceShowActiveFiles
To show active file button.
xtpWorkspaceHideArrowsAlways
To hide arrow buttons always
xtpWorkspaceShowCloseTab
To show close button for all tabs.
xtpWorkspaceShowCloseSelectedTab
To show close button for selected tabs.

See Also

CXTPTabClientWnd::SetFlags

Example
m_MTIClientWnd.SetFlags(xtpWorkspaceHideClose);
Group

Structs, Records, Enums


XTPWorkspaceNewTabPosition Enumeration

XTPTabClientWnd.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPWorkspaceNewTabPosition Enumeration

XTPWorkspaceNewTabPosition enumerator, used to determine where new tab will appear

enum XTPWorkspaceNewTabPosition {
  xtpWorkspaceNewTabRightMost,
  xtpWorkspaceNewTabLeftMost,
  xtpWorkspaceNewTabNextToActive
};
File

XTPTabClientWnd.h

Members

xtpWorkspaceNewTabRightMost
New tab will be created after all tabs
xtpWorkspaceNewTabLeftMost
New tab will be created before all tabs
xtpWorkspaceNewTabNextToActive
New tab will be created after active tab

See Also

CXTPTabClientWnd::SetNewTabPosition

Example
m_MTIClientWnd.SetNewTabPosition(xtpWorkspaceNewTabLeftMost);
Group

Structs, Records, Enums


LPCREATEBARSTRUCT Structure

XTPCommandBarsDefines.h, Structs, Records, Enums, See Also
LPCREATEBARSTRUCT Structure

Create bar structure

typedef struct {
  CXTPCommandBar* pCommandBar;
  BOOL bPopup;
  BOOL bExpandBar;
  BOOL bCustomBar;
  BOOL bTearOffBar;
  LPCTSTR lpcstrCaption;
  UINT nID;
} XTP_COMMANDBARS_CREATEBAR, FAR* LPCREATEBARSTRUCT;
File

XTPCommandBarsDefines.h

Members

pCommandBar
Created command bar.
bPopup
TRUE if it is a popup command bar,
bExpandBar
TRUE if it is an expanded popup.
bCustomBar
TRUE if it is a user defined toolbar.
bTearOffBar
TRUE if it is a user tear-off popup.
lpcstrCaption
Caption of the command bar.
nID
Identifier of the command bar.

Remarks

This structure contains extended information about bar to be created. CXTPCommandBars sent XTP_COMMANDBARS_CREATEBAR message to owner site when new CXTPCommandBar object is about to become created.

See Also

WM_XTP_CREATECOMMANDBAR

Group

Structs, Records, Enums


LPCREATECONTROLSTRUCT Structure

XTPCommandBarsDefines.h, Structs, Records, Enums, See Also
LPCREATECONTROLSTRUCT Structure

Create control structure.

typedef struct {
  UINT nID;
  CXTPControl* pControl;
  BOOL bToolBar;
  int nIndex;
  CMenu* pMenu;
  CXTPCommandBar* pCommandBar;
  CString strCaption;
  XTPControlType controlType;
  XTPButtonStyle buttonStyle;
} XTP_COMMANDBARS_CREATECONTROL, FAR* LPCREATECONTROLSTRUCT;
File

XTPCommandBarsDefines.h

Members

nID
Identifier of the control to be created.
pControl
Control to be created.
bToolBar
TRUE if control is toolbar located.
nIndex
Index of the control to be created.
pMenu
A Pointer to CMenu object.
pCommandBar
Pointer to the parent command bar class.
strCaption
Caption of the control to be created.
controlType
Type of the control.
buttonStyle
Button Style of the control.

Remarks

This structure contains extended information about CXTPControl object to be created. CXTPCommandBars sent XTP_COMMANDBARS_CREATECONTROL message to owner site when new CXTPControl object is about to become created.

See Also

WM_XTP_CREATECONTROL

Group

Structs, Records, Enums


LPNMXTPCONTROL Structure

XTPCommandBarsDefines.h, Structs, Records, Enums, See Also
LPNMXTPCONTROL Structure

This structure is passed as parameter in CBN_XTP_EXECUTE message.

typedef struct {
  NMHDR hdr;
  CXTPControl* pControl;
} NMXTPCONTROL, FAR* LPNMXTPCONTROL;
File

XTPCommandBarsDefines.h

Members

hdr
NMHDR structure that contains additional information about this notification.
pControl
Pointer to control that caused the event.

Remarks

See description of CBN_XTP_EXECUTE for details.

See Also

CBN_XTP_EXECUTE

Group

Structs, Records, Enums


NMXTPCONTROL Structure

XTPCommandBarsDefines.h, Structs, Records, Enums, See Also
NMXTPCONTROL Structure

This structure is passed as parameter in CBN_XTP_EXECUTE message.

typedef struct {
  NMHDR hdr;
  CXTPControl* pControl;
} NMXTPCONTROL, FAR* LPNMXTPCONTROL;
File

XTPCommandBarsDefines.h

Members

hdr
NMHDR structure that contains additional information about this notification.
pControl
Pointer to control that caused the event.

Remarks

See description of CBN_XTP_EXECUTE for details.

See Also

CBN_XTP_EXECUTE

Group

Structs, Records, Enums


XTP_COMMANDBARS_CREATEBAR Structure

XTPCommandBarsDefines.h, Structs, Records, Enums, See Also
XTP_COMMANDBARS_CREATEBAR Structure

Create bar structure

typedef struct {
  CXTPCommandBar* pCommandBar;
  BOOL bPopup;
  BOOL bExpandBar;
  BOOL bCustomBar;
  BOOL bTearOffBar;
  LPCTSTR lpcstrCaption;
  UINT nID;
} XTP_COMMANDBARS_CREATEBAR, FAR* LPCREATEBARSTRUCT;
File

XTPCommandBarsDefines.h

Members

pCommandBar
Created command bar.
bPopup
TRUE if it is a popup command bar,
bExpandBar
TRUE if it is an expanded popup.
bCustomBar
TRUE if it is a user defined toolbar.
bTearOffBar
TRUE if it is a user tear-off popup.
lpcstrCaption
Caption of the command bar.
nID
Identifier of the command bar.

Remarks

This structure contains extended information about bar to be created. CXTPCommandBars sent XTP_COMMANDBARS_CREATEBAR message to owner site when new CXTPCommandBar object is about to become created.

See Also

WM_XTP_CREATECOMMANDBAR

Group

Structs, Records, Enums


XTP_COMMANDBARS_CREATECONTROL Structure

XTPCommandBarsDefines.h, Structs, Records, Enums, See Also
XTP_COMMANDBARS_CREATECONTROL Structure

Create control structure.

typedef struct {
  UINT nID;
  CXTPControl* pControl;
  BOOL bToolBar;
  int nIndex;
  CMenu* pMenu;
  CXTPCommandBar* pCommandBar;
  CString strCaption;
  XTPControlType controlType;
  XTPButtonStyle buttonStyle;
} XTP_COMMANDBARS_CREATECONTROL, FAR* LPCREATECONTROLSTRUCT;
File

XTPCommandBarsDefines.h

Members

nID
Identifier of the control to be created.
pControl
Control to be created.
bToolBar
TRUE if control is toolbar located.
nIndex
Index of the control to be created.
pMenu
A Pointer to CMenu object.
pCommandBar
Pointer to the parent command bar class.
strCaption
Caption of the control to be created.
controlType
Type of the control.
buttonStyle
Button Style of the control.

Remarks

This structure contains extended information about CXTPControl object to be created. CXTPCommandBars sent XTP_COMMANDBARS_CREATECONTROL message to owner site when new CXTPControl object is about to become created.

See Also

WM_XTP_CREATECONTROL

Group

Structs, Records, Enums


Types

Command Bars, Types
Types
Module

Command Bars

Types
Type | Description
CXTPCommandBarsCategoryArray | This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_CATEGORYINFO structures.


CXTPCommandBarsCategoryArray Type

XTPCustomizeCommandsPage.h, Types, See Also
CXTPCommandBarsCategoryArray Type

This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_CATEGORYINFO structures.

typedef CArray<XTP_COMMANDBARS_CATEGORYINFO*, XTP_COMMANDBARS_CATEGORYINFO*> CXTPCommandBarsCategoryArray;
File

XTPCustomizeCommandsPage.h

See Also

CXTPCustomizeCommandsPage

Group

Types


Variables

Command Bars, Variables
Variables
Module

Command Bars

Variables
Variable | Description
CBN_XTP_EXECUTE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
WM_XTP_AFTERCREATECONTROL | The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after new CXTPControl object is created.
WM_XTP_BEFORECREATECONTROL | The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when new CXTPControl object is created.
WM_XTP_COMMANDBARKEYDOWN | The WM_XTP_COMMANDBARKEYDOWN is sent to the CXTPCommandBars site when user press key
WM_XTP_COMMANDBARS_BASE | Base message for CommandBars
WM_XTP_CONTROLRBUTTONUP | The WM_XTP_CONTROLRBUTTONUP is sent to the CXTPCommandBars site when menu user press right button in command bar control.
WM_XTP_CONTROLSELECTED | The WM_XTP_CONTROLSELECTED is sent to the CXTPCommandBars site when the user selects a CXTPCommandBar item
WM_XTP_CREATECOMMANDBAR | The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when new CXTPCommandBars object is created.
WM_XTP_DRAGCONTROLCHANGED | The WM_XTP_DRAGCONTROLCHANGED is sent to the CXTPCommandBars site when user select button of toolbar in customization mode
WM_XTP_GETTABICON | The WM_XTP_GETTABICON message is sent to MDI child window to retrieve icon will be used for tabbed interface.
WM_XTP_GETWINDOWTEXT | The WM_XTP_GETWINDOWTEXT message is sent to MDI child window to retrieve text will be used for tabbed interface.
WM_XTP_GETWINDOWTOOLTIP | The WM_XTP_GETWINDOWTOOLTIP message is sent to MDI child window to retrieve tooltips for CXTPTabClientWnd's tabs.
WM_XTP_INITCOMMANDSPOPUP | The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active
WM_XTP_INITMENU | The WM_XTP_INITMENU is sent to the CXTPCommandBars site when menu is about to become active. It occurs when the user clicks an item on the menu bar or presses a menu key. This allows the application to modify the menu before it is displayed.
WM_XTP_NEWTABITEM | The WM_XTP_NEWTABITEM message is sent to owner window when new tab was created
WM_XTP_PRETRANSLATEMOUSEMSG | The WM_XTP_PRETRANSLATEMOUSEMSG message is sent to owner window to pre-translate mouse messages.
WM_XTP_TOOLBARCONTEXTMENU | The WM_XTP_TOOLBARCONTEXTMENU is sent to the CXTPCommandBars site when context menu is about to become visible
WM_XTP_TOOLBARVISIBLECHANGED | The WM_XTP_TOOLBARVISIBLECHANGED is sent to the CXTPCommandBars site when the user show/hide a toolbar object
WM_XTP_UNINITCOMMANDSPOPUP | The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.
XTP_FN_GETFORMAT | The XTP_FN_GETFORMAT notification sent by CXTPControlFontComboBox to get current RichEdit selection format
XTP_FN_SETFORMAT | The XTP_FN_SETFORMAT notification sent by CXTPControlFontComboBox to set current RichEdit selection format
XTP_LBN_POPUP | The XTP_LBN_POPUP is sent to active view when the CXTPControlListBox is about to become visible.
XTP_LBN_SELCHANGE | The XTP_LBN_SELCHANGE is sent to active view when the selection of CXTPControlListBox is changed
XTP_SLN_SELCHANGE | XTP_SLN_SELCHANGE is sent to the parent commandbar when the number of selected items has changed in the control selector.


CBN_XTP_EXECUTE Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
CBN_XTP_EXECUTE Variable

The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object

const UINT CBN_XTP_EXECUTE = 100;
File

XTPCommandBarsDefines.h

Parameters

id
ID of control was clicked.
memberFxn
Name of member function to handle the message.

Remarks

Use ON_COMMAND to map a single command to a member function if you don't need exact control that caused the event. Use ON_COMMAND_RANGE or ON_XTP_EXECUTE_RANGE to map a range of command ids to one member function.

If you don't set *pResult = 1 then WM_COMMAND also will be sent for this event.

See Also

CXTPControl, NMXTPCONTROL

Example

Here is an example of how an application would process the CBN_XTP_EXECUTE message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_EXECUTE(ID_TOOLS_TOOLITEM, OnToolsItem)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnToolsItem(NMHDR* pNMHDR, LRESULT* pResult)
{
     CXTPControl* pControl = ((NMXTPCONTROL*)pNMHDR)->pControl;

     CToolRec* pTool = (CToolRec*)pControl->GetTag();

     if (!pTool)
         return;

     CString strArg = pTool->m_strArg;
     CString strDir = pTool->m_strDir;

     // launch the process.
     ::ShellExecute(NULL, _T("open"), pTool->m_strCmd, strArg, strDir, SW_SHOW);

     *pResult = 1;
}
Group

Variables


WM_XTP_AFTERCREATECONTROL Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_AFTERCREATECONTROL Variable

The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after new CXTPControl object is created.

const UINT WM_XTP_AFTERCREATECONTROL = (WM_XTP_COMMANDBARS_BASE + 11);
File

XTPCommandBarsDefines.h

Parameters

lpCreateControl
Pointer to XTP_COMMANDBARS_CREATECONTROL structure with information about control to be created.

Returns

If an application processes this message, it should return TRUE.

See Also

XTP_COMMANDBARS_CREATECONTROL, CXTPControl, WM_XTP_BEFORECREATECONTROL

Example

Here is an example of how an application would process the WM_XTP_AFTERCREATECONTROL message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_AFTERCREATECONTROL()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnAfterCreateControl(LPCREATECONTROLSTRUCT lpCreateControl)
{
     ASSERT(lpCreateControl->pControl);

     if (lpCreateControl->nID == ID_BDR_NONE)
     {
          lpCreateControl->pControl->SetCaption(_T("None"));
          return;
     }
}
Group

Variables


WM_XTP_BEFORECREATECONTROL Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_BEFORECREATECONTROL Variable

The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when new CXTPControl object is created.

const UINT WM_XTP_BEFORECREATECONTROL = (WM_XTP_COMMANDBARS_BASE + 10);
File

XTPCommandBarsDefines.h

Parameters

lpCreateControl
Pointer to XTP_COMMANDBARS_CREATECONTROL structure with information about control to be created.

Returns

If an application processes this message, it should return TRUE.

See Also

XTP_COMMANDBARS_CREATECONTROL, CXTPControl, WM_XTP_AFTERCREATECONTROL

Example

Here is an example of how an application would process the WM_XTP_BEFORECREATECONTROL message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_CREATECONTROL()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

int CMainFrame::OnCreateControl(LPCREATECONTROLSTRUCT lpCreateControl)
{
     if (lpCreateControl->nID == ID_BDR_NONE)
     {
          lpCreateControl->controlType = xtpControlSplitButtonPopup;
          return TRUE;
     }
     return FALSE
}
Group

Variables


WM_XTP_COMMANDBARKEYDOWN Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_COMMANDBARKEYDOWN Variable

The WM_XTP_COMMANDBARKEYDOWN is sent to the CXTPCommandBars site when user press key

const UINT WM_XTP_COMMANDBARKEYDOWN = (WM_XTP_COMMANDBARS_BASE + 6);
File

XTPCommandBarsDefines.h

Parameters

pChar
(UINT*)wParam - pointer to UINT containing pressed key
pCommandBar
(CXTPCommandBar*)lParam - pointer to CXTPCommandBar object

See Also

CXTPCommandBar

Example

Here is an example of how an application would process the WM_XTP_COMMANDBARKEYDOWN message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_COMMANDBARKEYDOWN, OnCommandBarKeyDown)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnCommandBarKeyDown(WPARAM wParam, LPARAM lParam)
{
    UINT* pChar = (UINT*)wParam;

    return 0;
}
Group

Variables


WM_XTP_COMMANDBARS_BASE Variable

XTPCommandBarsDefines.h, Variables
WM_XTP_COMMANDBARS_BASE Variable

Base message for CommandBars

const UINT WM_XTP_COMMANDBARS_BASE = (WM_USER + 9300);
File

XTPCommandBarsDefines.h

Group

Variables


WM_XTP_CONTROLRBUTTONUP Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_CONTROLRBUTTONUP Variable

The WM_XTP_CONTROLRBUTTONUP is sent to the CXTPCommandBars site when menu user press right button in command bar control.

const UINT WM_XTP_CONTROLRBUTTONUP = (WM_XTP_COMMANDBARS_BASE + 5);
File

XTPCommandBarsDefines.h

Parameters

pPoint
(LPPOINT)wParam - Cursor position
pControl
(CXTPControl*)lParam - Selected control.

Returns

If an application processes this message, it should return TRUE.

See Also

CXTPCommandBar, CXTPControl

Example

Here is an example of how an application would process the WM_XTP_CONTROLRBUTTONUP message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_CONTROLRBUTTONUP, OnControlRButtonUp)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnControlRButtonUp(WPARAM wParam, LPARAM lParam)
{
     CXTPControl* pControl = (CXTPControl*)lParam;
     if (pControl->GetID() == ID_FAVORITE_LINK)
     {
         CControlFavoriteLink* pLink = DYNAMIC_DOWNCAST(CControlFavoriteLink, pControl);
         if (!pLink)
              return FALSE;

         CMenu menu;
         menu.LoadMenu(IDR_MENU_FAVORITE_LINK);

         CPoint pt;
         GetCursorPos(&pt);

         UINT nReturn = CXTPCommandBars::TrackPopupMenu(menu.GetSubMenu(0), TPM_NONOTIFY | TPM_RECURSE | TPM_RETURNCMD, pt.x, pt.y, this);

         switch (nReturn)
         {
             ....
         }
         return TRUE;
     }
     return FALSE;
}
Group

Variables


WM_XTP_CONTROLSELECTED Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_CONTROLSELECTED Variable

The WM_XTP_CONTROLSELECTED is sent to the CXTPCommandBars site when the user selects a CXTPCommandBar item

const UINT WM_XTP_CONTROLSELECTED = (WM_XTP_COMMANDBARS_BASE + 2);
File

XTPCommandBarsDefines.h

Parameters

pControl
(CXTPControl*)wParam - pointer to selected item.

Remarks

pControl parameter is NULL when the user remove mouse pointer from selected item.

See Also

CXTPControl, CXTPCommandBar

Example

Here is an example of how an application would process the WM_XTP_CONTROLSELECTED message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_CONTROLSELECTED, OnControlSelected)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnControlSelected(WPARAM wParam, LPARAM lParam)
{
    UNUSED_ALWAYS(lParam);
    CXTPControl* pControl = (CXTPControl*)wParam;

    return 0;
}
Group

Variables


WM_XTP_CREATECOMMANDBAR Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_CREATECOMMANDBAR Variable

The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when new CXTPCommandBars object is created.

const UINT WM_XTP_CREATECOMMANDBAR = (WM_XTP_COMMANDBARS_BASE + 13);
File

XTPCommandBarsDefines.h

Parameters

lpCreateBar
Pointer to XTP_COMMANDBARS_CREATEBAR structure with information about bar to be created.

Returns

If an application processes this message, it should return TRUE.

See Also

XTP_COMMANDBARS_CREATEBAR, CXTPCommandBar

Example

Here is an example of how an application would process the WM_XTP_CREATECOMMANDBAR message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_CREATECOMMANDBAR()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

int CMainFrame::OnCreateCommandBar(LPCREATEBARSTRUCT lpCreateBar)
{
    if (lpCreateBar->bPopup && _tcscmp(lpCreateBar->lpcstrCaption, _T("Find")) == 0)
    {

        CXTPPopupBar* pPopupBar = CXTPPopupBar::CreatePopupBar(GetCommandBars());
        pPopupBar->SetTearOffPopup(_T("Find Bar"), 1000);
        lpCreateBar->pCommandBar = pPopupBar;
        return TRUE;
    }
    return FALSE
}
Group

Variables


WM_XTP_DRAGCONTROLCHANGED Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_DRAGCONTROLCHANGED Variable

The WM_XTP_DRAGCONTROLCHANGED is sent to the CXTPCommandBars site when user select button of toolbar in customization mode

const UINT WM_XTP_DRAGCONTROLCHANGED = (WM_XTP_COMMANDBARS_BASE + 3);
File

XTPCommandBarsDefines.h

See Also

CXTPCommandBars::GetDragControl, CXTPCommandBars::SetCustomizeMode

Example

Here is an example of how an application would process the WM_XTP_DRAGCONTROLCHANGED message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE_VOID(WM_XTP_DRAGCONTROLCHANGED, OnDragControlChanged)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnDragControlChanged()
{
    CXTPControl* pControl = GetCommandBars()->GetDragControl();
}
Group

Variables


WM_XTP_GETTABICON Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_GETTABICON Variable

The WM_XTP_GETTABICON message is sent to MDI child window to retrieve icon will be used for tabbed interface.

const UINT WM_XTP_GETTABICON = (WM_XTP_COMMANDBARS_BASE + 12);
File

XTPCommandBarsDefines.h

Returns

ICON handle to be used.

Remarks

If application returns 0, CDocument::GetTitle will be used.You can override CXTPTabClientWnd::GetItemIcon instead of process the message.

See Also

CXTPTabClientWnd, WM_XTP_GETWINDOWTEXT, WM_XTP_GETWINDOWTOOLTIP

Example

Here is an example of how an application would process the WM_XTP_GETTABICON message.

BEGIN_MESSAGE_MAP(CChildFrame, CMDIChildWnd)
    //{{AFX_MSG_MAP(CChildFrame)
    ON_MESSAGE(WM_XTP_GETTABICON, OnGetTabIcon)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CChildFrame::OnGetTabIcon(WPARAM /*wParam*/, LPARAM /*lParam*/)
{
    HICON hIcon = m_bLoading ? m_hIconLoading : m_hIconNormal;
    return (LRESULT)hIcon;
}
Group

Variables


WM_XTP_GETWINDOWTEXT Variable

XTPTabClientWnd.h, Variables, Example, See Also
WM_XTP_GETWINDOWTEXT Variable

The WM_XTP_GETWINDOWTEXT message is sent to MDI child window to retrieve text will be used for tabbed interface.

const UINT WM_XTP_GETWINDOWTEXT = (WM_XTP_COMMANDBARS_BASE + 21);
File

XTPTabClientWnd.h

Returns

Points to a null-terminated string that specifies the text to be used.

Remarks

If application returns 0, CDocument::GetTitle will be used. You can override CXTPTabClientWnd::GetItemText instead of process the message.

See Also

CXTPTabClientWnd, WM_XTP_GETTABICON, WM_XTP_GETWINDOWTOOLTIP

Example

Here is an example of how an application would process the WM_XTP_GETWINDOWTEXT message.

BEGIN_MESSAGE_MAP(CChildFrame, CMDIChildWnd)
    //{{AFX_MSG_MAP(CChildFrame)
    ON_MESSAGE(WM_XTP_GETWINDOWTEXT, OnGetTabText)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CChildFrame::OnGetTabText(WPARAM /*wParam*/, LPARAM /*lParam*/)
{
    return (LPCTSTR)m_strCaption;
}
Group

Variables


WM_XTP_GETWINDOWTOOLTIP Variable

XTPTabClientWnd.h, Variables, Example, See Also
WM_XTP_GETWINDOWTOOLTIP Variable

The WM_XTP_GETWINDOWTOOLTIP message is sent to MDI child window to retrieve tooltips for CXTPTabClientWnd's tabs.

const UINT WM_XTP_GETWINDOWTOOLTIP = (WM_XTP_COMMANDBARS_BASE + 23);
File

XTPTabClientWnd.h

Returns

Points to a null-terminated string that specifies the tooltip to be used.

If application returns 0, CDocument::GetPathName will be used.

Remarks

You must call CXTPTabClientWnd::EnableToolTips to enable tooltips.

See Also

CXTPTabClientWnd, WM_XTP_GETTABICON, WM_XTP_GETWINDOWTEXT

Example

Here is an example of how an application would process the WM_XTP_GETWINDOWTOOLTIP message.

BEGIN_MESSAGE_MAP(CChildFrame, CMDIChildWnd)
    //{{AFX_MSG_MAP(CChildFrame)
    ON_MESSAGE(WM_XTP_GETWINDOWTOOLTIP, OnGetTabTip)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CChildFrame::OnGetTabTip(WPARAM /*wParam*/, LPARAM /*lParam*/)
{
    return (LPCTSTR)m_strToolTip;
}
Group

Variables


WM_XTP_INITCOMMANDSPOPUP Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_INITCOMMANDSPOPUP Variable

The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active

const UINT WM_XTP_INITCOMMANDSPOPUP = (WM_XTP_COMMANDBARS_BASE + 7);
File

XTPCommandBarsDefines.h

Parameters

pPopupBar
Pointer to drop-down menu.

See Also

WM_XTP_UNINITCOMMANDSPOPUP, CXTPPopupBar

Example

Here is an example of how an application would process the WM_XTP_INITCOMMANDSPOPUP message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_INITCOMMANDSPOPUP()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnInitCommandsPopup(CXTPPopupBar* pPopupBar)
{
    // get the list of commands for the popup.
    CXTPControls* pControls = pPopupBar->GetControls();
}
Group

Variables


WM_XTP_INITMENU Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_INITMENU Variable

The WM_XTP_INITMENU is sent to the CXTPCommandBars site when menu is about to become active. It occurs when the user clicks an item on the menu bar or presses a menu key. This allows the application to modify the menu before it is displayed.

const UINT WM_XTP_INITMENU = (WM_XTP_COMMANDBARS_BASE + 4);
File

XTPCommandBarsDefines.h

Parameters

pMenuBar
(CXTPMenuBar*)wParam - pointer to CXTPMenuBar object to be initialized.

Returns

If an application processes this message, it should return zero.

See Also

CXTPCommandBars, CXTPMenuBar

Example

Here is an example of how an application would process the WM_XTP_INITMENU message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_INITMENU, OnInitMenu)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnInitMenu(WPARAM wParam, LPARAM lParam)
{
    UNUSED_ALWAYS(lParam);
    CXTPMenuBar* pMenuBar = (CXTPMenuBar*)wParam;

    return 0;
}
Group

Variables


WM_XTP_NEWTABITEM Variable

XTPTabClientWnd.h, Variables, Example, See Also
WM_XTP_NEWTABITEM Variable

The WM_XTP_NEWTABITEM message is sent to owner window when new tab was created

const UINT WM_XTP_NEWTABITEM = (WM_XTP_COMMANDBARS_BASE + 24);
File

XTPTabClientWnd.h

Parameters

pNewItem
(CXTPTabManagerItem*)wParam. Pointer to tab was created.

See Also

CXTPTabClientWnd

Example

Here is an example of how an application would process the WM_XTP_NEWTABITEM message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_NEWTABITEM, OnTabbarNewItem)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTabbarNewItem(WPARAM wParam, LPARAM /*lParam*/)
{
    CXTPTabManagerItem* pItem = (CXTPTabManagerItem*)wParam;
    return 0;
}
Group

Variables


WM_XTP_PRETRANSLATEMOUSEMSG Variable

XTPTabClientWnd.h, Variables, Example, See Also
WM_XTP_PRETRANSLATEMOUSEMSG Variable

The WM_XTP_PRETRANSLATEMOUSEMSG message is sent to owner window to pre-translate mouse messages.

const UINT WM_XTP_PRETRANSLATEMOUSEMSG = (WM_XTP_COMMANDBARS_BASE + 20);
File

XTPTabClientWnd.h

Parameters

point
CPoint((DWORD)lParam) - mouse cursor position
wParam
mouse notification.

Returns

If the application is to process this message, the return value should be TRUE.

See Also

CXTPTabClientWnd

Example

Here is an example of how an application would process the WM_XTP_PRETRANSLATEMOUSEMSG message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_PRETRANSLATEMOUSEMSG, OnTabbarMouseMsg)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTabbarMouseMsg(WPARAM wParam, LPARAM lParam)
{
    CPoint point = CPoint((DWORD)lParam);

    CXTPTabManagerItem* pItem =  m_MTIClientWnd.HitTest(point);

    if (pItem)
    {
         if (wParam == WM_RBUTTONDOWN)
         {

             CWnd* pFrame = CWnd::FromHandle(pItem->GetHandle());
             MDIActivate(pFrame);

             m_MTIClientWnd.Refresh();

             CMenu menuPopup;
             VERIFY(menuPopup.LoadMenu(IDR_WORKSPACE_POPUP));

             m_MTIClientWnd.WorkspaceToScreen(&point);
             CXTPCommandBars::TrackPopupMenu(menuPopup.GetSubMenu(0), 0, point.x, point.y, this);

             m_MTIClientWnd.Refresh();

             return TRUE;
         }
     }

     return FALSE;
}
Group

Variables


WM_XTP_TOOLBARCONTEXTMENU Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_TOOLBARCONTEXTMENU Variable

The WM_XTP_TOOLBARCONTEXTMENU is sent to the CXTPCommandBars site when context menu is about to become visible

const UINT WM_XTP_TOOLBARCONTEXTMENU = (WM_XTP_COMMANDBARS_BASE + 8);
File

XTPCommandBarsDefines.h

Parameters

pToolBar
(CXTPToolBar*)wParam - Toolbar under cursor; or NULL if clicked docking bar.
pPopup
(CXTPPopupBar*)lParam - Popup bar with context menu.

See Also

CXTPPopupBar, CXTPControls

Example

Here is an example of how an application would process the WM_XTP_TOOLBARCONTEXTMENU message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_TOOLBARCONTEXTMENU, OnToolbarContextMenu)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnToolbarContextMenu(WPARAM wParam, LPARAM lParam)
{
    CXTPToolBar* pToolBar = (CXTPToolBar*)wParam;
    CXTPPopupBar* pPopup = (CXTPPopupBar*)lParam;

    pPopupBar->GetControls()->RemoveAll();

    return TRUE;
}
Group

Variables


WM_XTP_TOOLBARVISIBLECHANGED Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_TOOLBARVISIBLECHANGED Variable

The WM_XTP_TOOLBARVISIBLECHANGED is sent to the CXTPCommandBars site when the user show/hide a toolbar object

const UINT WM_XTP_TOOLBARVISIBLECHANGED = (WM_XTP_COMMANDBARS_BASE + 1);
File

XTPCommandBarsDefines.h

Parameters

pToolBar
(CXTPToolBar*)wParam - pointer to toolbar.

See Also

CXTPToolBar

Example

Here is an example of how an application would process the WM_XTP_TOOLBARVISIBLECHANGED message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_TOOLBARVISIBLECHANGED, OnToolBarVisibleChanged)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnToolBarVisibleChanged(WPARAM wParam, LPARAM lParam)
{
    UNUSED_ALWAYS(lParam);
    CXTPToolBar* pToolBar = (CXTPToolBar*)wParam;

    return 0;
}
Group

Variables


WM_XTP_UNINITCOMMANDSPOPUP Variable

XTPCommandBarsDefines.h, Variables, Example, See Also
WM_XTP_UNINITCOMMANDSPOPUP Variable

The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.

const UINT WM_XTP_UNINITCOMMANDSPOPUP = (WM_XTP_COMMANDBARS_BASE + 9);
File

XTPCommandBarsDefines.h

Parameters

pPopupBar
Pointer to drop-down menu.

See Also

ON_XTP_INITCOMMANDSPOPUP

Example

Here is an example of how an application would process the WM_XTP_UNINITCOMMANDSPOPUP message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_UNINITCOMMANDSPOPUP()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnUninitCommandsPopup(CXTPPopupBar* pPopupBar)
{
    // get the list of commands for the popup.
    CXTPControls* pControls = pPopupBar->GetControls();
}
Group

Variables


XTP_FN_GETFORMAT Variable

XTPControlComboBoxExt.h, Variables, Example, See Also
XTP_FN_GETFORMAT Variable

The XTP_FN_GETFORMAT notification sent by CXTPControlFontComboBox to get current RichEdit selection format

const UINT XTP_FN_GETFORMAT = 0x1001;
File

XTPControlComboBoxExt.h

See Also

XTP_FN_SETFORMAT, CXTPControlFontComboBox

Example

Here is an example of how an application would process the XTP_FN_GETFORMAT message.

BEGIN_MESSAGE_MAP(CApplicationView, CRichEditView)
    //{{AFX_MSG_MAP(CApplicationView)
    ON_NOTIFY(XTP_FN_GETFORMAT, ID_EDIT_SIZE, OnGetCharFormat)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CApplicationView::OnGetCharFormat(NMHDR* pNMHDR, LRESULT* pResult)
{
    CHARFORMAT& cf = ((NMXTPCHARHDR*)pNMHDR)->cf;
    cf = GetCharFormatSelection();
    *pResult = 1;
}
Group

Variables


XTP_FN_SETFORMAT Variable

XTPControlComboBoxExt.h, Variables, Example, See Also
XTP_FN_SETFORMAT Variable

The XTP_FN_SETFORMAT notification sent by CXTPControlFontComboBox to set current RichEdit selection format

const UINT XTP_FN_SETFORMAT = 0x1000;
File

XTPControlComboBoxExt.h

See Also

XTP_FN_GETFORMAT, CXTPControlFontComboBox

Example

Here is an example of how an application would process the XTP_FN_SETFORMAT message.

BEGIN_MESSAGE_MAP(CApplicationView, CRichEditView)
    //{{AFX_MSG_MAP(CApplicationView)
    ON_NOTIFY(XTP_FN_SETFORMAT, ID_EDIT_SIZE, OnSetCharFormat)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CApplicationView::OnSetCharFormat(NMHDR* pNMHDR, LRESULT* pResult)
{
    CHARFORMAT& cf = ((NMXTPCHARHDR*)pNMHDR)->cf;
    SetCharFormat(cf);
    *pResult = 1;
}
Group

Variables


XTP_LBN_POPUP Variable

XTPControlListBox.h, Variables, Example, See Also
XTP_LBN_POPUP Variable

The XTP_LBN_POPUP is sent to active view when the CXTPControlListBox is about to become visible.

const UINT XTP_LBN_POPUP = 0x1004;
File

XTPControlListBox.h

See Also

CXTPControlListBox, XTP_LBN_SELCHANGE

Example

Here is an example of how an application would process the XTP_LBN_POPUP message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_NOTIFY(XTP_LBN_POPUP, ID_EDIT_UNDO, OnListBoxControlPopup)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnListBoxControlPopup(NMHDR* pNMHDR, LRESULT* pResult)
{
    CXTPControlListBox* pControlListBox = DYNAMIC_DOWNCAST(CXTPControlListBox, ((NMXTPCONTROL*)pNMHDR)->pControl);
    if (pControlListBox)
    {
         *pResult = 1;
    }
}
Group

Variables


XTP_LBN_SELCHANGE Variable

XTPControlListBox.h, Variables, Example, See Also
XTP_LBN_SELCHANGE Variable

The XTP_LBN_SELCHANGE is sent to active view when the selection of CXTPControlListBox is changed

const UINT XTP_LBN_SELCHANGE = 0x1003;
File

XTPControlListBox.h

See Also

CXTPControlListBox, XTP_LBN_POPUP

Example

Here is an example of how an application would process the XTP_LBN_SELCHANGE message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_NOTIFY(XTP_LBN_SELCHANGE, ID_EDIT_UNDO, OnListBoxControlSelChange)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnListBoxControlSelChange(NMHDR* pNMHDR, LRESULT* pResult)
{
    CXTPControlListBox* pControlListBox = DYNAMIC_DOWNCAST(CXTPControlListBox, ((NMXTPCONTROL*)pNMHDR)->pControl);
    if (pControlListBox)
    {
         *pResult = 1;
    }
}
Group

Variables


XTP_SLN_SELCHANGE Variable

XTPControlExt.h, Variables, Example, See Also
XTP_SLN_SELCHANGE Variable

XTP_SLN_SELCHANGE is sent to the parent commandbar when the number of selected items has changed in the control selector.

const UINT XTP_SLN_SELCHANGE = 0x1006;
File

XTPControlExt.h

Remarks

The number of selected items changes as the mouse is moved over the controls in the control selector.

XTP_SLN_SELCHANGE is sent in CXTPControlSelector::SetItemsActive.

See Also

CXTPControlSelector::SetItemsActive

Example

Here is an example of how an application would process the XTP_LBN_SELCHANGE message.

BEGIN_MESSAGE_MAP(CExtendedControlsView, CEditView)
    //{{AFX_MSG_MAP(CExtendedControlsView)
    ON_NOTIFY(XTP_SLN_SELCHANGE, ID_INSERT_COLUMNS, OnColumnsSelChange)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CExtendedControlsView::OnColumnsSelChange(NMHDR* pNMHDR, LRESULT* pRes)
{
    ASSERT(pNMHDR != NULL);
    ASSERT(pRes != NULL);

    CControlColumns* pControlColumns = DYNAMIC_DOWNCAST(CControlColumns,
        ((NMXTPCONTROL*)pNMHDR)->pControl);
    if (pControlColumns)
    {

        CXTPControlStatic* pInfo = FindInfoControl(pControlColumns);
        if (pInfo)
        {
            int nCount = pControlColumns->m_szItemsActive.cx;

            CString str = _T("Cancel");
            if (nCount != 0)
            {
                str.Format(_T("%i Columns"), nCount);
            }

            pInfo->SetWidth(pControlColumns->m_szItem.cx *
                pControlColumns->m_szItemsVisible.cx);

            pInfo->SetCaption(str);
            pInfo->DelayRedrawParent();
        }

        *pRes = 1;
    }
}
Group

Variables


Macros

Macros, Command Bars
Macros
Macros
Macro | Description
DECLARE_XTP_COMMANDBAR | This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be serialized.
DECLARE_XTP_CONTROL | This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serialized.
IMPLEMENT_XTP_COMMANDBAR | This macro generates the C++ code necessary for a CXTPCommandBar-derived class that can be serialized.
IMPLEMENT_XTP_CONTROL | This macro generates the C++ code necessary for a CXTPControl-derived class that can be serialized.
ON_XTP_AFTERCREATECONTROL | The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after new CXTPControl object is created.
ON_XTP_CREATECOMMANDBAR | The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when new CXTPCommandBars object is created.
ON_XTP_CREATECONTROL | The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when new CXTPControl object is created.
ON_XTP_EXECUTE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
ON_XTP_EXECUTE_RANGE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
ON_XTP_INITCOMMANDSPOPUP | The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active
ON_XTP_UNINITCOMMANDSPOPUP | The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.
XTP_IDS_AUTOMATIC | Obsolete define
xtpComboLabel | Deprecated style for Combo control
xtpComboNormal | Deprecated style for Combo control
Module

Command Bars


DECLARE_XTP_COMMANDBAR Macro

XTPCommandBarsDefines.h, Macros, Example, See Also
DECLARE_XTP_COMMANDBAR Macro

This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be serialized.

#define DECLARE_XTP_COMMANDBAR(class_name)
File

XTPCommandBarsDefines.h

Parameters

class_name
The actual name of the class (not enclosed in quotation marks).

Remarks

Use the DECLARE_XTP_COMMANDBAR macro in a .H module, then include that module in all .CPP modules that need access to objects of this class.

If DECLARE_XTP_COMMANDBAR is included in the class declaration, then IMPLEMENT_XTP_COMMANDBAR must be included in the class implementation.

The DECLARE_XTP_COMMANDBAR macro includes all the functionality of DECLARE_SERIAL, DECLARE_DYNAMIC and DECLARE_DYNCREATE.

See Also

IMPLEMENT_XTP_COMMANDBAR, DECLARE_XTP_CONTROL

Example
class CToolPopupBar: public CXTPPopupBar
{
    DECLARE_XTP_COMMANDBAR(CToolPopupBar)

public:
    CToolPopupBar();

};
Group

Macros


DECLARE_XTP_CONTROL Macro

XTPCommandBarsDefines.h, Macros, Example, See Also
DECLARE_XTP_CONTROL Macro

This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serialized.

#define DECLARE_XTP_CONTROL(class_name)
File

XTPCommandBarsDefines.h

Parameters

class_name
The actual name of the class (not enclosed in quotation marks).

Remarks

Use the DECLARE_XTP_CONTROL macro in a .H module, then include that module in all .CPP modules that need access to objects of this class.

If DECLARE_XTP_CONTROL is included in the class declaration, then IMPLEMENT_XTP_CONTROL must be included in the class implementation.

The DECLARE_XTP_CONTROL macro includes all the functionality of DECLARE_SERIAL, DECLARE_DYNAMIC and DECLARE_DYNCREATE.

See Also

IMPLEMENT_XTP_CONTROL, DECLARE_XTP_COMMANDBAR

Example
class CBitmapControl: public CXTPControl
{
    DECLARE_XTP_CONTROL(CBitmapControl)

public:
    CBitmapControl();

};
Group

Macros


IMPLEMENT_XTP_COMMANDBAR Macro

XTPCommandBarsDefines.h, Macros, Example, See Also
IMPLEMENT_XTP_COMMANDBAR Macro

This macro generates the C++ code necessary for a CXTPCommandBar-derived class that can be serialized.

#define IMPLEMENT_XTP_COMMANDBAR(class_name, base_class_name)
File

XTPCommandBarsDefines.h

Parameters

class_name
The actual name of the class (not enclosed in quotation marks).
base_class_name
The name of the base class (not enclosed in quotation marks).

Remarks

Use the IMPLEMENT_XTP_COMMANDBAR macro in a .CPP module; then link the resulting object code only once.

See Also

DECLARE_XTP_COMMANDBAR, DECLARE_XTP_CONTROL

Example
// ToolPopupBar.cpp
#include "stdafx.h"
#include "ToolPopupBar.h"

IMPLEMENT_XTP_COMMANDBAR(CToolPopupBar, CXTPPopupBar)
...
pCommandBars->SetPopupBarClass(RUNTIME_CLASS(CToolPopupBar));
...
Group

Macros


IMPLEMENT_XTP_CONTROL Macro

XTPCommandBarsDefines.h, Macros, Example, See Also
IMPLEMENT_XTP_CONTROL Macro

This macro generates the C++ code necessary for a CXTPControl-derived class that can be serialized.

#define IMPLEMENT_XTP_CONTROL(class_name, base_class_name)
File

XTPCommandBarsDefines.h

Parameters

class_name
The actual name of the class (not enclosed in quotation marks).
base_class_name
The name of the base class (not enclosed in quotation marks).

Remarks

Use the IMPLEMENT_XTP_CONTROL macro in a .CPP module; then link the resulting object code only once.

See Also

DECLARE_XTP_CONTROL, DECLARE_XTP_COMMANDBAR

Example
// BitmapControl.cpp
#include "stdafx.h"
#include "BitmapControl.h"

IMPLEMENT_XTP_CONTROL(CBitmapControl, CXTPControl)
Group

Macros


XTP_IDS_AUTOMATIC Macro

XTPControlPopupColor.h, Macros
XTP_IDS_AUTOMATIC Macro

Obsolete define

#define XTP_IDS_AUTOMATIC XTP_IDS_CLR_AUTOMATIC
File

XTPControlPopupColor.h

Group

Macros


xtpComboLabel Macro

XTPCommandBarsDefines.h, Macros
xtpComboLabel Macro

Deprecated style for Combo control

#define xtpComboLabel xtpButtonCaption
File

XTPCommandBarsDefines.h

Group

Macros


xtpComboNormal Macro

XTPCommandBarsDefines.h, Macros
xtpComboNormal Macro

Deprecated style for Combo control

#define xtpComboNormal xtpButtonAutomatic
File

XTPCommandBarsDefines.h

Group

Macros


Files

Files, Command Bars
Files
Files
File | Description
XTPCommandBar.h | XTPCommandBar.h : interface for the CXTPCommandBar class.
XTPCommandBars.h | XTPCommandBars.h : interface for the CXTPCommandBars class.
XTPCommandBarsDefines.h | XTPCommandBarDefines.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControl.h | XTPControl.h : interface for the CXTPControl class.
XTPControlButton.h | XTPControlButton.h : interface for the CXTPControlButton class.
XTPControlComboBox.h | XTPControlComboBox.h : interface for the CXTPControlComboBox class.
XTPControlComboBoxExt.h | XTPControlComboBoxExt.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlCustom.h | XTPControlCustom.h : interface for the CXTPControlCustom class.
XTPControlEdit.h | XTPControlEdit.h : interface for the CXTPControlEdit class.
XTPControlExt.h | XTPControlExt.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlGallery.h | XTPControlGallery.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlListBox.h | XTPControlListBox.h : interface for the CXTPControlListBox class.
XTPControlPopup.h | XTPControlPopup.h : interface for the CXTPControlPopup class.
XTPControlPopupColor.h | XTPControlPopupColor.h : interface for the CXTPControlPopupColor class.
XTPControls.h | XTPControls.h : interface for the CXTPControls class.
XTPCustomizeCommandsPage.h | XTPCustomizeCommandsPage.h : interface for the CXTPCustomizeCommandsPage class.
XTPCustomizeKeyboardPage.h | XTPCustomizeKeyboardPage.h : interface for the CXTPCustomizeKeyboardPage class.
XTPCustomizeOptionsPage.h | XTPCustomizeOptionsPage.h : interface for the CXTPCustomizeOptionsPage class.
XTPCustomizeSheet.h | XTPCustomizeSheet.h : interface for the CXTPCustomizeSheet class.
XTPCustomizeToolbarsPage.h | XTPCustomizeToolbarsPage.h : interface for the CXTPCustomizeToolbarsPage class.
XTPCustomizeTools.h | XTPCustomizeTools.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPDialogBar.h | XTPToolBar.h : interface for the CXTPToolBar class.
XTPDialogBase.h | XTPFrameWnd.h : interface for the CXTPFrameWnd and CXTPMDIFrameWnd classes.
XTPDockBar.h | XTPDockBar.h : interface for the CXTPDockBar class.
XTPDockContext.h | XTPDockContext.h : interface for the CXTPDockContext class.
XTPDockState.h | XTPDockState.h : interface for the CXTPDockState class.
XTPFrameWnd.h | XTPFrameWnd.h : interface for the CXTPFrameWnd and CXTPMDIFrameWnd classes.
XTPImageEditor.h | XTPImageEditor.h : interface for the CXTPImageEditorDlg class.
XTPMenuBar.h | XTPMenuBar.h : interface for the CXTPMenuBar class.
XTPMouseManager.h | XTPMouseManager.h : interface for the CXTPMouseManager class.
XTPOffice2007Theme.h | XTPOffice2007Theme.h : interface for the CXTPOffice2007Theme class.
XTPPaintManager.h | XTPPaintManager.h : interface for the CXTPPaintManager class.
XTPPopupBar.h | XTPPopupBar.h : interface for the CXTPPopupBar class.
XTPReBar.h | XTPReBar.h : header file This file is a part of the XTREME COMMANDBARS MFC class library.
XTPRibbonBar.h | XTPRibbonBar.h: interface for the CXTPRibbonBar class.
XTPRibbonControlTab.h | XTPRibbonControlTab.h: interface for the CXTPRibbonControlTab class.
XTPRibbonCustomizeQuickAccessPage.h | XTPRibbonCustomizeQuickAccessPage.h: interface for the CXTPRibbonCustomizeQuickAccessPage class.
XTPRibbonGroup.h | XTPRibbonGroup.h: interface for the CXTPRibbonGroup class.
XTPRibbonGroups.h | XTPRibbonGroups.h: interface for the CXTPRibbonGroups class.
XTPRibbonQuickAccessControls.h | XTPRibbonQuickAccessControls.h: interface for the CXTPRibbonQuickAccessControls class.
XTPRibbonTab.h | XTPRibbonTab.h: interface for the CXTPRibbonTab class.
XTPRibbonTheme.h | XTPRibbonTheme.h: interface for the CXTPRibbonTheme class.
XTPShortcutManager.h | XTPShortcutManager.h : interface for the CXTPShortcutManager class.
XTPSoundManager.h | XTPSoundManager.h : interface for the CXTPSoundManager class.
XTPStatusBar.h | XTPStatusBar.h : interface for the CXTPStatusBar class.
XTPTabClientWnd.h | XTPTabClientWnd.h : interface for the CXTPTabClientWnd class.
XTPTabToolBar.h | XTPTabToolBar.h : interface for the CXTPTabToolBar class.
XTPToolBar.h | XTPToolBar.h : interface for the CXTPToolBar class.
Module

Command Bars


XTPCommandBar.h

Classes, Files
XTPCommandBar.h

XTPCommandBar.h : interface for the CXTPCommandBar class.

Classes
Class | Description
CXTPCommandBar | CXTPCommandBar is a CWnd derived class. It represents the parent class for command bars.
CXTPCommandBarList | CXTPCommandBarList is a CList derived class. It is used as a collection of CXTPCommandBar classes.
Group

Files


XTPCommandBars.h

Classes, Files, Legend, Structures
XTPCommandBars.h

XTPCommandBars.h : interface for the CXTPCommandBars class.

Classes
Class | Description
CXTPCommandBarKeyboardTip | CXTPCommandBarKeyboardTip is CWnd derived class, represents Keyboard tip single window
CXTPCommandBars | CXTPCommandBars is standalone class. It allows developer manipulate toolbars and popupbars
CXTPCommandBarsContextMenus | CXTPCommandBarsContextMenus is CXTPCommandBarList derived class, represents collection of context menus
CXTPCommandBarsOptions | Options of the command bars.
Group

Files

Legend
Structure
Structures
Structure | Description
XTP_COMMANDBARS_PROPEXCHANGE_PARAM | XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings. This is a set of State options that will be used to change how and what will be saved and loaded when loading and saving XML files.


XTPCommandBarsDefines.h

Enumerations, Files, Legend, Macros, Variables, Structures
XTPCommandBarsDefines.h

XTPCommandBarDefines.h

This file is a part of the XTREME COMMANDBARS MFC class library.

Enumerations
Enumeration | Description
XTPAnimationType | Enumerated type used to determine the animation effect of popup bars.
XTPBarPosition | Position of the command bar
XTPBarType | Type of the command bar.
XTPButtonStyle | Button's styles
XTPControlFlags | Flags of the control.
XTPControlHideFlags | Control's hide flags, these are flags that specify why a control is hidden.
XTPControlType | Type of the control.
XTPIdleFlags | Flags for idle routine
XTPKeyboardCuesShow | Enumerated type used to determine menu underlines.
XTPKeyboardCuesUse | Enumerated type used to determine if menu underlines execute popups.
XTPMenuBarFlags | Menubar system button flags.
XTPPaintTheme | Paint themes used by command bars.
XTPPopupDirection | Docking direction enumerator.
XTPSpecialKey | Special keys enumerator.
XTPToolBarFlags | Docking flags.
Group

Files

Macros
Macro | Description
DECLARE_XTP_COMMANDBAR | This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be serialized.
DECLARE_XTP_CONTROL | This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serialized.
IMPLEMENT_XTP_COMMANDBAR | This macro generates the C++ code necessary for a CXTPCommandBar-derived class that can be serialized.
IMPLEMENT_XTP_CONTROL | This macro generates the C++ code necessary for a CXTPControl-derived class that can be serialized.
ON_XTP_AFTERCREATECONTROL | The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after new CXTPControl object is created.
ON_XTP_CREATECOMMANDBAR | The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when new CXTPCommandBars object is created.
ON_XTP_CREATECONTROL | The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when new CXTPControl object is created.
ON_XTP_EXECUTE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
ON_XTP_EXECUTE_RANGE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
ON_XTP_INITCOMMANDSPOPUP | The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active
ON_XTP_UNINITCOMMANDSPOPUP | The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.
xtpComboLabel | Deprecated style for Combo control
xtpComboNormal | Deprecated style for Combo control
Variables
Variable | Description
CBN_XTP_EXECUTE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
WM_XTP_AFTERCREATECONTROL | The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after new CXTPControl object is created.
WM_XTP_BEFORECREATECONTROL | The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when new CXTPControl object is created.
WM_XTP_COMMANDBARKEYDOWN | The WM_XTP_COMMANDBARKEYDOWN is sent to the CXTPCommandBars site when user press key
WM_XTP_COMMANDBARS_BASE | Base message for CommandBars
WM_XTP_CONTROLRBUTTONUP | The WM_XTP_CONTROLRBUTTONUP is sent to the CXTPCommandBars site when menu user press right button in command bar control.
WM_XTP_CONTROLSELECTED | The WM_XTP_CONTROLSELECTED is sent to the CXTPCommandBars site when the user selects a CXTPCommandBar item
WM_XTP_CREATECOMMANDBAR | The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when new CXTPCommandBars object is created.
WM_XTP_DRAGCONTROLCHANGED | The WM_XTP_DRAGCONTROLCHANGED is sent to the CXTPCommandBars site when user select button of toolbar in customization mode
WM_XTP_GETTABICON | The WM_XTP_GETTABICON message is sent to MDI child window to retrieve icon will be used for tabbed interface.
WM_XTP_INITCOMMANDSPOPUP | The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active
WM_XTP_INITMENU | The WM_XTP_INITMENU is sent to the CXTPCommandBars site when menu is about to become active. It occurs when the user clicks an item on the menu bar or presses a menu key. This allows the application to modify the menu before it is displayed.
WM_XTP_TOOLBARCONTEXTMENU | The WM_XTP_TOOLBARCONTEXTMENU is sent to the CXTPCommandBars site when context menu is about to become visible
WM_XTP_TOOLBARVISIBLECHANGED | The WM_XTP_TOOLBARVISIBLECHANGED is sent to the CXTPCommandBars site when the user show/hide a toolbar object
WM_XTP_UNINITCOMMANDSPOPUP | The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.
Legend
Enumeration
Structures
Structure | Description
LPCREATEBARSTRUCT | Create bar structure
LPCREATECONTROLSTRUCT | Create control structure.
LPNMXTPCONTROL | This structure is passed as parameter in CBN_XTP_EXECUTE message.
NMXTPCONTROL | This structure is passed as parameter in CBN_XTP_EXECUTE message.
XTP_COMMANDBARS_CREATEBAR | Create bar structure
XTP_COMMANDBARS_CREATECONTROL | Create control structure.


XTPControl.h

Classes, Files
XTPControl.h

XTPControl.h : interface for the CXTPControl class.

Classes
Class | Description
CXTPControl | CXTPControl is a CCmdTarget derived class. It represents the parent class for the command bar's controls.
CXTPControlAction | CXTPControlAction is a CCmdTarget derived class. It represents the single action of controls.
CXTPControlActions | CXTPControlActions is a CCmdTarget derived class. It represents a collection of the actions.
Group

Files


XTPControlButton.h

Classes, Files
XTPControlButton.h

XTPControlButton.h : interface for the CXTPControlButton class.

Classes
Class | Description
CXTPControlButton | CXTPControlButton is a CXTPControl derived class. It represents a button control.
Group

Files


XTPControlComboBox.h

Classes, Files
XTPControlComboBox.h

XTPControlComboBox.h : interface for the CXTPControlComboBox class.

Classes
Class | Description
CXTPControlComboBox | CXTPControlComboBox is a CXTPControl derived class. It represents a combo box control.
CXTPControlComboBoxEditCtrl | Inplace Edit control of the combo.
CXTPControlComboBoxList | CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class. It represents a list box of CXTPControlComboBox control.
CXTPControlComboBoxPopupBar | CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class. It represents base class for combo popups.
CXTPEdit | CXTPEdit is a CEdit derived class. It is for internal usage only.
Group

Files


XTPControlComboBoxExt.h

Classes, Files, Legend, Variables, Structures
XTPControlComboBoxExt.h

XTPControlComboBoxExt.h

This file is a part of the XTREME COMMANDBARS MFC class library.

Classes
Class | Description
CXTPControlFontComboBox | CXTPControlFontComboBox is a CXTPControlComboBox derived class. It represents the font picker control.
CXTPControlFontComboBoxList | CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class. It represents the font picker popup.
CXTPControlSizeComboBox | CXTPControlSizeComboBox is a CXTPControlComboBox derived class. It represents the size picker.
Group

Files

Variables
Variable | Description
XTP_FN_GETFORMAT | The XTP_FN_GETFORMAT notification sent by CXTPControlFontComboBox to get current RichEdit selection format
XTP_FN_SETFORMAT | The XTP_FN_SETFORMAT notification sent by CXTPControlFontComboBox to set current RichEdit selection format
Legend
Structure
Structures
Structure | Description
NMXTPCHARHDR | Structure used as parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages.


XTPControlCustom.h

Classes, Enumerations, Files, Legend
XTPControlCustom.h

XTPControlCustom.h : interface for the CXTPControlCustom class.

Classes
Class | Description
CXTPControlCustom | CXTPControlCustom is a CXTPControlButton derived class. It represents the control with some child window.
Enumerations
Enumeration | Description
XTPControlCustomVerticalOptions | Vertical options enumerator.
Group

Files

Legend
Enumeration


XTPControlEdit.h

Classes, Files
XTPControlEdit.h

XTPControlEdit.h : interface for the CXTPControlEdit class.

Classes
Class | Description
CXTPControlEdit | CXTPControlEdit is a CXTPControl derived class. It represents an edit control.
CXTPControlEditCtrl | Inplace Edit control of CXTPControlEdit.
Group

Files


XTPControlExt.h

Classes, Files, Variables
XTPControlExt.h

XTPControlExt.h

This file is a part of the XTREME COMMANDBARS MFC class library.

Classes
Class | Description
CXTPControlBitmap | CXTPControlBitmap is a CXTPControlLabel derived class. It can be used to add bitmap to toolbar.
CXTPControlCheckBox | CXTPControlCheckBox is a CXTPControlButton derived class. It represents a checkbox control.
CXTPControlHyperlink | CXTPControlHyperlink is a CXTPControl derived class. It can be used to add hyperlink text.
CXTPControlLabel | CXTPControlLabel is a CXTPControl derived class. It represents a label control.
CXTPControlMarkupLabel | CXTPControlMarkupLabel is a CXTPControlLabel derived class. It can be used to draw markup text
CXTPControlOleItems | CXTPControlOleItems is a CXTPControlButton derived class. It is used internally to create ole items.
CXTPControlRadioButton | CXTPControlRadioButton is a CXTPControlButton derived class. It represents a radio button control.
CXTPControlRecentFileList | CXTPControlRecentFileList is a CXTPControlButton derived class. It is used internally to create recent items list.
CXTPControlSelector | CXTPControlSelector is a CXTPControl derived class that represents a control selector.
CXTPControlToolbars | CXTPControlToolbars is a CXTPControlButton derived class. It is used internally to create toolbars list items.
CXTPControlWindowList | CXTPControlWindowList is a CXTPControlButton derived class. It is used internally to create window list items.
CXTPControlWorkspaceActions | CXTPControlWorkspaceActions is a CXTPControlButton derived class. It used internally to add workspace actions to window menu.
Group

Files

Variables
Variable | Description
XTP_SLN_SELCHANGE | XTP_SLN_SELCHANGE is sent to the parent commandbar when the number of selected items has changed in the control selector.


XTPControlGallery.h

Classes, Files
XTPControlGallery.h

XTPControlGallery.h

This file is a part of the XTREME COMMANDBARS MFC class library.

Classes
Class | Description
CXTPControlGallery | CXTPControlGallery is a CXTPControlPopup derived class. It represents gallery control of toolbar.
CXTPControlGalleryItem | CXTPControlGalleryItem is a CCmdTarget derived class. It represents single item of gallery object.
CXTPControlGalleryItems | CXTPControlGalleryItems is a CCmdTarget derived class. It represents a collection of the items for gallery control.
CXTPControlGalleryPaintManager | CXTPControlGalleryPaintManager is standalone class used to draw CXTPControlGallery object
Group

Files


XTPControlListBox.h

Classes, Files, Variables
XTPControlListBox.h

XTPControlListBox.h : interface for the CXTPControlListBox class.

Classes
Class | Description
CXTPControlListBox | CXTPControlComboBox is a CXTPControl derived class. It represents a list box control.
CXTPControlStatic | CXTPControlStatic is a CXTPControl derived class. It represents a static text control.
Group

Files

Variables
Variable | Description
XTP_LBN_POPUP | The XTP_LBN_POPUP is sent to active view when the CXTPControlListBox is about to become visible.
XTP_LBN_SELCHANGE | The XTP_LBN_SELCHANGE is sent to active view when the selection of CXTPControlListBox is changed


XTPControlPopup.h

Classes, Files
XTPControlPopup.h

XTPControlPopup.h : interface for the CXTPControlPopup class.

Classes
Class | Description
CXTPControlPopup | CXTPControlPopup is a CXTPControl derived class. It represents a popup-able control.
Group

Files


XTPControlPopupColor.h

Classes, Files, Macros
XTPControlPopupColor.h

XTPControlPopupColor.h : interface for the CXTPControlPopupColor class.

Classes
Class | Description
CXTPControlButtonColor | CXTPControlButtonColor is a CXTPControlButton derived class. It represents a text button in the color picker popup.
CXTPControlColorSelector | CXTPControlColorSelector is a CXTPControl derived class. It represents a color selector control.
CXTPControlPopupColor | CXTPControlPopupColor is a CXTPControlPopup derived class. It represents a color picker control.
Group

Files

Macros
Macro | Description
XTP_IDS_AUTOMATIC | Obsolete define


XTPControls.h

Classes, Files
XTPControls.h

XTPControls.h : interface for the CXTPControls class.

Classes
Class | Description
CXTPControls | CXTPControls is a CCmdTarget derived class. It represents a collection of the controls.
Group

Files


XTPCustomizeCommandsPage.h

Classes, Files, Legend, Types, Structures
XTPCustomizeCommandsPage.h

XTPCustomizeCommandsPage.h : interface for the CXTPCustomizeCommandsPage class.

Classes
Class | Description
CXTPCustomizeCommandsListBox | List of the commands
CXTPCustomizeCommandsPage | CXTPCustomizeCommandsPage is a CPropertyPage derived class. It represents the Commands page of the Customize dialog.
Group

Files

Types
Type | Description
CXTPCommandBarsCategoryArray | This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_CATEGORYINFO structures.
Legend
Structure
Structures
Structure | Description
XTP_COMMANDBARS_CATEGORYINFO | This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages


XTPCustomizeKeyboardPage.h

Classes, Files
XTPCustomizeKeyboardPage.h

XTPCustomizeKeyboardPage.h : interface for the CXTPCustomizeKeyboardPage class.

Classes
Class | Description
CXTPCustomizeKeyboardPage | CXTPCustomizeKeyboardPage is a CPropertyPage derived class. It represents the Keyboard page of the Customize dialog.
Group

Files


XTPCustomizeOptionsPage.h

Classes, Files
XTPCustomizeOptionsPage.h

XTPCustomizeOptionsPage.h : interface for the CXTPCustomizeOptionsPage class.

Classes
Class | Description
CXTPCustomizeOptionsPage | CXTPCustomizeOptionsPage is a CPropertyPage derived class. It represents the Options page of the Customize dialog.
CXTPGroupLine | CXTPGroupLine is a CStatic derived class. It used in CXTPCustomizeOptionsPage page to draw group line static control.
Group

Files


XTPCustomizeSheet.h

Classes, Files
XTPCustomizeSheet.h

XTPCustomizeSheet.h : interface for the CXTPCustomizeSheet class.

Classes
Class | Description
CXTPCustomizeSheet | CXTPCustomizeSheet is a CPropertySheet derived class. It represents the Customize dialog.
Group

Files


XTPCustomizeToolbarsPage.h

Classes, Files
XTPCustomizeToolbarsPage.h

XTPCustomizeToolbarsPage.h : interface for the CXTPCustomizeToolbarsPage class.

Classes
Class | Description
CXTPCustomizeToolbarsPage | CXTPCustomizeToolbarsPage is a CPropertyPage derived class. It represents the Toolbars page of the Customize dialog.
Group

Files


XTPCustomizeTools.h

Classes, Files
XTPCustomizeTools.h

XTPCustomizeTools.h

This file is a part of the XTREME COMMANDBARS MFC class library.

Classes
Class | Description
CXTPNewToolbarDlg | CXTPNewToolbarDlg is CDialog derived class. It used internally in customization sheet.
Group

Files


XTPDialogBar.h

Classes, Files
XTPDialogBar.h

XTPToolBar.h : interface for the CXTPToolBar class.

Classes
Class | Description
CXTPDialogBar | CXTPDialogBar is a CXTPToolBar derived class. It represents dockable container for child window
Group

Files


XTPDialogBase.h

Classes, Files, Legend, Templates
XTPDialogBase.h

XTPFrameWnd.h : interface for the CXTPFrameWnd and CXTPMDIFrameWnd classes.

Classes
Class | Description
CXTPDialog | CXTPDialog is a CXTPDialogBase derived class. Use this class in your dialog base application.
Group

Files

Templates
Template | Description
CXTPDialogBase | CXTPDialogBase is a TBase derived class. It represents the parent class for a CXTPDialog class .
Legend
Template


XTPDockBar.h

Classes, Files
XTPDockBar.h

XTPDockBar.h : interface for the CXTPDockBar class.

Classes
Class | Description
CXTPDockBar | CXTPDockBar is a CWnd derived class. It is used internally by CXTPCommandBars.
Group

Files


XTPDockContext.h

Classes, Files
XTPDockContext.h

XTPDockContext.h : interface for the CXTPDockContext class.

Classes
Class | Description
CXTPDockContext | CXTPDockContext is a stand alone class. It is used internally by CXTPToolBar.
Group

Files


XTPDockState.h

Classes, Files
XTPDockState.h

XTPDockState.h : interface for the CXTPDockState class.

Classes
Class | Description
CXTPDockState | CXTPDockState is a stand alone class. It is used internally by CXTPToolBar.
Group

Files


XTPFrameWnd.h

Classes, Files, Legend, Templates
XTPFrameWnd.h

XTPFrameWnd.h : interface for the CXTPFrameWnd and CXTPMDIFrameWnd classes.

Classes
Class | Description
CXTPFrameWnd | CXTPFrameWnd is a CXTPFrameWndBase derived class.
CXTPMDIFrameWnd | CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.
Group

Files

Templates
Template | Description
CXTPCommandBarsSiteBase | CXTPCommandBarsSiteBase is a stand alone class. It represents site for Command Bars object
CXTPFrameWndBase | CXTPFrameWndBase is a stand alone class. It represents the parent class for a CXTPMDIFrameWnd and CXTPFrameWnd classes .
Legend
Template


XTPImageEditor.h

Classes, Files
XTPImageEditor.h

XTPImageEditor.h : interface for the CXTPImageEditorDlg class.

Classes
Class | Description
CXTPImageEditorDlg | CXTPImageEditorDlg is a CDialog derived class. It represents the dialog for icons edition.
Group

Files


XTPMenuBar.h

Classes, Files
XTPMenuBar.h

XTPMenuBar.h : interface for the CXTPMenuBar class.

Classes
Class | Description
CXTPMenuBar | CXTPMenuBar is a CXTPToolBar derived class. It represents menu bar of frame window.
CXTPMenuBarMDIMenuInfo | CXTPMenuBarMDIMenuInfo structure used to describe parameters of application MDI menus.
CXTPMenuBarMDIMenus | CXTPMenuBarMDIMenus represents collection of MDI menus for CXTPMenuBar
Group

Files


XTPMouseManager.h

Classes, Files
XTPMouseManager.h

XTPMouseManager.h : interface for the CXTPMouseManager class.

Classes
Class | Description
CXTPMouseManager | CXTPMouseManager is standalone class. It used in CommandBars to manage mouse.
Group

Files


XTPOffice2007Theme.h

Classes, Files
XTPOffice2007Theme.h

XTPOffice2007Theme.h : interface for the CXTPOffice2007Theme class.

Classes
Class | Description
CXTPOffice2007Theme | The CXTPOffice2007Theme class is used to enable an Office 2007 style theme for Command Bars
Group

Files


XTPPaintManager.h

Classes, Enumerations, Functions, Files, Legend, Templates, Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPaintManager.h

XTPPaintManager.h : interface for the CXTPPaintManager class.

Classes
Class | Description
CXTPDefaultTheme | The CXTPDefaultTheme class is used to enable an Office 2000 style theme for Command Bars
CXTPNativeXPTheme | The CXTPNativeXPTheme class is used to enable a Windows XP style theme for Command Bars
CXTPOfficeTheme | The CXTPOfficeTheme class is used to enable an Office XP style theme for Command Bars
CXTPPaintManager | Paint manager of the command bars.
CXTPPaintManagerFont | PaintManagers used CFont wrapper.
Enumerations
Enumeration | Description
XTPSpecialControl | Special control with extended drawing.
Functions
Function | Description
XTPPaintManager | Call this function to access CXTPPaintManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPPaintManager.
Group

Files

Templates
Template | Description
CXTPReBarPaintManager | The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars
Legend
Template
Structure
Enumeration
Method
Structures
Structure | Description
XTP_COMMANDBARS_ICONSINFO | This structure collect icons options for command bars.


XTPPopupBar.h

Classes, Files
XTPPopupBar.h

XTPPopupBar.h : interface for the CXTPPopupBar class.

Classes
Class | Description
CXTPPopupBar | CXTPPopupBar is a CXTPCommandBar derived class. It represents submenu of menu bar.
CXTPPopupToolBar | CXTPPopupToolBar is a CXTPPopupBar derived class.
Group

Files


XTPReBar.h

Classes, Files
XTPReBar.h

XTPReBar.h : header file

This file is a part of the XTREME COMMANDBARS MFC class library.

Classes
Class | Description
CXTPReBar | The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring of band layouts.
Group

Files


XTPRibbonBar.h

Classes, Files
XTPRibbonBar.h

XTPRibbonBar.h: interface for the CXTPRibbonBar class.

Classes
Class | Description
CXTPRibbonBar | CXTPRibbonBar is a CXTPMenuBar derived class, It represents Ribbon control from Office 2007.
Group

Files


XTPRibbonControlTab.h

Classes, Files, Legend, Structures
XTPRibbonControlTab.h

XTPRibbonControlTab.h: interface for the CXTPRibbonControlTab class.

Classes
Class | Description
CXTPRibbonControlTab | CXTPRibbonControlTab is a CXTPTabManager derived class, It represents tabs of the ribbon bar
Group

Files

Legend
Structure
Structures
Structure | Description
NMXTPTABCHANGE | Structure used as parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when Ribbon tab is changed


XTPRibbonCustomizeQuickAccessPage.h

Classes, Files
XTPRibbonCustomizeQuickAccessPage.h

XTPRibbonCustomizeQuickAccessPage.h: interface for the CXTPRibbonCustomizeQuickAccessPage class.

Classes
Class | Description
CXTPRibbonCustomizeQuickAccessPage | CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class. It represents the Quick Access page of the Customize dialog.
Group

Files


XTPRibbonGroup.h

Classes, Files
XTPRibbonGroup.h

XTPRibbonGroup.h: interface for the CXTPRibbonGroup class.

Classes
Class | Description
CXTPRibbonGroup | Represents a single group that is added to a CXTPRibbonTab.
Group

Files


XTPRibbonGroups.h

Classes, Files
XTPRibbonGroups.h

XTPRibbonGroups.h: interface for the CXTPRibbonGroups class.

Classes
Class | Description
CXTPRibbonGroups | Represents a collection of CXTPRibbonGroup objects.
Group

Files


XTPRibbonQuickAccessControls.h

Classes, Files
XTPRibbonQuickAccessControls.h

XTPRibbonQuickAccessControls.h: interface for the CXTPRibbonQuickAccessControls class.

Classes
Class | Description
CXTPRibbonControls | CXTPRibbonControls is a CXTPControls derived class. It represents a collection of the controls for Ribbon Bar.
CXTPRibbonQuickAccessControls | CXTPRibbonQuickAccessControls is a CXTPControls derived class. It represents a collection of the controls for quick access controls for Ribbon Bar.
Group

Files


XTPRibbonTab.h

Classes, Enumerations, Files, Legend
XTPRibbonTab.h

XTPRibbonTab.h: interface for the CXTPRibbonTab class.

Classes
Class | Description
CXTPRibbonTab | Represents a tab in the Ribbon Bar.
Enumerations
Enumeration | Description
XTPRibbonTabContextColor | Ribbon Tab context color
Group

Files

Legend
Enumeration


XTPRibbonTheme.h

Classes, Files
XTPRibbonTheme.h

XTPRibbonTheme.h: interface for the CXTPRibbonTheme class.

Classes
Class | Description
CXTPRibbonTheme | Standalone class used by the CXTPRibbonBar as a paint manager.
Group

Files


XTPShortcutManager.h

Classes, Files
XTPShortcutManager.h

XTPShortcutManager.h : interface for the CXTPShortcutManager class.

Classes
Class | Description
CXTPShortcutManager | CXTPShortcutManager is standalone class used to manipulate accelerators of frame.
Group

Files


XTPSoundManager.h

Classes, Enumerations, Functions, Files, Legend
XTPSoundManager.h

XTPSoundManager.h : interface for the CXTPSoundManager class.

Classes
Class | Description
CXTPSoundManager | CXTPSoundManager is standalone class. It used to play system sound.
Enumerations
Enumeration | Description
XTPSoundManagerState | Enumeration used to play system sound.
Functions
Function | Description
XTPSoundManager | Call this function to access CXTPSoundManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSoundManager.
Group

Files

Legend
Enumeration
Method


XTPStatusBar.h

Classes, Files
XTPStatusBar.h

XTPStatusBar.h : interface for the CXTPStatusBar class.

Classes
Class | Description
CXTPStatusBar | CXTPStatusBar is a CControlBar derived class.
CXTPStatusBarPane | CXTPStatusBarPane is a CCmdTarget derived class. It represents single pane of status bar
CXTPStatusBarProgressPane | CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class. CXTPStatusBarProgressPane works with CXTStatusBar and allows you to create progress bar in your status bar area.
CXTPStatusBarScrollBarPane | CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class. CXTPStatusBarScrollBarPane works with CXTStatusBar and allows you to create themed ScrollBar in your status bar area.
CXTPStatusBarSliderPane | CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class. CXTPStatusBarSliderPane works with CXTStatusBar and allows you to create themed Slider in your status bar area.
CXTPStatusBarSwitchPane | CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class. CXTPStatusBarSwitchPane works with CXTStatusBar and allows you to create switches in your status bar area.
Group

Files


XTPTabClientWnd.h

Classes, Enumerations, Files, Legend, Variables
XTPTabClientWnd.h

XTPTabClientWnd.h : interface for the CXTPTabClientWnd class.

Classes
Class | Description
CXTPTabClientWnd | CXTPTabClientWnd is a CWnd derived class. It represents a tabbed workspace.
Enumerations
Enumeration | Description
XTPWorkspaceActivateTab | XTPWorkspaceActivateTab enumerator, used to determine which tab will become active after the currently active tab is closed.
XTPWorkspaceButtons | Workspace buttons enumerator, used to indicate which tab navigation buttons to display in the TabWorkspace.
XTPWorkspaceNewTabPosition | XTPWorkspaceNewTabPosition enumerator, used to determine where new tab will appear
Group

Files

Variables
Variable | Description
WM_XTP_GETWINDOWTEXT | The WM_XTP_GETWINDOWTEXT message is sent to MDI child window to retrieve text will be used for tabbed interface.
WM_XTP_GETWINDOWTOOLTIP | The WM_XTP_GETWINDOWTOOLTIP message is sent to MDI child window to retrieve tooltips for CXTPTabClientWnd's tabs.
WM_XTP_NEWTABITEM | The WM_XTP_NEWTABITEM message is sent to owner window when new tab was created
WM_XTP_PRETRANSLATEMOUSEMSG | The WM_XTP_PRETRANSLATEMOUSEMSG message is sent to owner window to pre-translate mouse messages.
Legend
Enumeration


XTPTabToolBar.h

Classes, Files
XTPTabToolBar.h

XTPTabToolBar.h : interface for the CXTPTabToolBar class.

Classes
Class | Description
CXTPTabToolBar | CXTPTabToolBar is a CXTPToolBar derived class. It represents tabbable toolbar
Group

Files


XTPToolBar.h

Classes, Files
XTPToolBar.h

XTPToolBar.h : interface for the CXTPToolBar class.

Classes
Class | Description
CXTPToolBar | CXTPToolBar is a CXTPCommandBar derived class.
Group

Files


Docking Panes

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Macros, Structs, Records, Enums, Types, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Docking Panes

Codejock Software's Xtreme Docking Pane provides Windows developers with professional Visual Studio.NET™ style docking tabbed windows.

Group

Xtreme Toolkit Pro v12.0

Legend
Structure
Enumeration
Classes
Class | Description
CXTPDockingPane | CXTPDockingPane is a CXTPDockingPaneBase derived class. It is used as a container for a user window.
CXTPDockingPaneAutoHidePanel | CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It is used internally as an auto-hide container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneAutoHideWnd | CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class. It is used internally by CXTPDockingPaneAutoHidePanel as a sliding auto-hide window for the hidden pane.
CXTPDockingPaneBase | CXTPDockingPaneBase is a stand alone class. It represents the parent class for a Docking Pane and its containers.
CXTPDockingPaneBaseContainer | CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class. It represents the parent class for a all virtual containers.
CXTPDockingPaneCaptionButton | CXTPDockingPaneCaptionButton is a stand alone internal class.
CXTPDockingPaneCaptionButtons | CXTPDockingPaneCaptionButtons is CArray derived class used for manipulate Caption Buttons.
CXTPDockingPaneContext | CXTPDockingPaneContext is a stand alone class. It is used internally for docking and sizing panes.
CXTPDockingPaneContextAlphaWnd | CXTPDockingPaneContextAlphaWnd is CWnd derived class represents alpha context helper window
CXTPDockingPaneContextStickerWnd | CXTPDockingPaneContextStickerWnd is CWnd derived class represents sticker window.
CXTPDockingPaneDefaultTheme | CXTPDockingPaneDefaultTheme is CXTPDockingPanePaintManager derived class, represents classic theme for docking panes.
CXTPDockingPaneExplorerTheme | CXTPDockingPaneExplorerTheme is CXTPDockingPaneDefaultTheme derived class, represents explorer theme for docking panes.
CXTPDockingPaneGripperedTheme | CXTPDockingPaneGripperedTheme is CXTPDockingPaneDefaultTheme derived class, represents gripper theme for docking panes.
CXTPDockingPaneLayout | CXTPDockingPaneLayout is a stand alone class. It is used to manipulate a pane's layouts.
CXTPDockingPaneManager | CXTPDockingPaneManager is a CWnd derived class. It is used to manipulate docking panes.
CXTPDockingPaneMiniWnd | CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase. It is used internally as a MiniWnd container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneNativeXPTheme | CXTPDockingPaneNativeXPTheme is CXTPDockingPaneOfficeTheme derived class, represents Win XP theme for docking panes.
CXTPDockingPaneOffice2003Theme | CXTPDockingPaneOffice2003Theme is CXTPDockingPaneOfficeTheme derived class, represents Office 2003 theme for docking panes.
CXTPDockingPaneOffice2007Theme | CXTPDockingPaneOffice2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2007 theme for docking panes.
CXTPDockingPaneOfficeTheme | CXTPDockingPaneOfficeTheme is CXTPDockingPaneGripperedTheme derived class, represents Office XP theme for docking panes.
CXTPDockingPanePaintManager | CXTPDockingPanePaintManager is a stand alone class. Override some virtual functions to get a new visual theme.
CXTPDockingPaneShortcutBar2003Theme | CXTPDockingPaneShortcutBar2003Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2003 theme for docking panes.
CXTPDockingPaneSplitterContainer | CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class. It is used internally as a splitter container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneSplitterWnd | CXTPDockingPaneSplitterWnd is a CWnd derived class. It is used internally for splitting Panes.
CXTPDockingPaneTabbedContainer | CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It represents a tabbed container for Docking Panes.
CXTPDockingPaneVisioTheme | CXTPDockingPaneVisioTheme is CXTPDockingPaneOfficeTheme derived class, represents Visio theme for docking panes.
CXTPDockingPaneVisualStudio2005SecondTheme | CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneWhidbeyTheme derived class, represents Visual Studio 2005 beta 2 theme for docking panes.
CXTPDockingPaneVisualStudio2005Theme | CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneVisualStudio2005SecondTheme derived class, represents Visual Studio 2005 theme for docking panes.
CXTPDockingPaneWhidbeyTheme | CXTPDockingPaneWhidbeyTheme is CXTPDockingPaneOfficeTheme derived class, represents Visual Studio 2005 theme for docking panes.
CXTPDockingPaneWord2007Theme | CXTPDockingPaneWord2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office Word 2007 theme for docking panes.
Files
File | Description
XTPDockingPane.h | XTPDockingPane.h : interface for the CXTPDockingPane class.
XTPDockingPaneAutoHidePanel.h | XTPDockingPaneAutoHidePanel.h : interface for the CXTPDockingPaneAutoHidePanel class.
XTPDockingPaneBase.h | XTPDockingPaneBase.h : interface for the CXTPDockingPaneBase class.
XTPDockingPaneBaseContainer.h | XTPDockingPaneBaseContainer.h : interface for the CXTPDockingPaneBaseContainer class.
XTPDockingPaneContext.h | XTPDockingPaneContext.h : interface for the CXTPDockingPaneContext class.
XTPDockingPaneDefines.h | XTPDockingPaneDefines.h : public defines, structures and enumerations.
XTPDockingPaneLayout.h | XTPDockingPaneLayout.h : interface for the CXTPDockingPaneLayout class.
XTPDockingPaneManager.h | XTPDockingPaneManager.h : interface for the CXTPDockingPaneManager class.
XTPDockingPaneMiniWnd.h | XTPDockingPaneMiniWnd.h : interface for the CXTPDockingPaneMiniWnd class.
XTPDockingPanePaintManager.h | XTPDockingPanePaintManager.h : interface for the CXTPDockingPanePaintManager class.
XTPDockingPaneSplitterContainer.h | XTPDockingPaneSplitterContainer.h : interface for the CXTPDockingPaneSplitterContainer class.
XTPDockingPaneTabbedContainer.h | XTPDockingPaneTabbedContainer.h : interface for the CXTPDockingPaneTabbedContainer class.
Macros
Macro | Description
XTPWM_DOCKINGPANE_NOTIFY | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
Structs, Records, Enums
Struct, Record, Enum | Description
XTP_DOCKINGPANE_ACTION | XTP_DOCKINGPANE_ACTION structure contains information about action performed by user with docking panes.
XTP_DOCKINGPANE_CLICK | XTP_DOCKINGPANE_CLICK structure contains information about pane was used in XTP_DPN_PANEMENUCLICK message
XTP_DOCKINGPANE_INFO | Internal structure used by Layout manager
XTPDockingContextStickerStyle | Docking Panes sticker style enumeration
XTPDockingPaneAction | Actions a docking pane is currently performing.
XTPDockingPaneCaptionButtonStyle | Enumeration of the caption button styles
XTPDockingPaneCaptionDirection | Docking Pane Caption direction enumeration
XTPDockingPaneDirection | Docking direction enumeration
XTPDockingPaneKeyboardNavigate | Keyboard options indicates which key can be used to navigate panes
XTPDockingPaneOptions | Docking Pane Options enumeration
XTPDockingPanePaintTheme | Visual theme enumeration
XTPDockingPanePinState | Enumeration of the pin button state
XTPDockingPaneSplitterStyle | Enumeration of the splitter styles
XTPDockingPaneStickerType | XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be drawn on the screen when a docking pane is dragged.
XTPDockingPaneType | Docking pane type
XTPXTPDockingPaneEnableOptions | Enable options of the pane
Types
Type | Description
CXTPDockingPaneBaseList | This list is used for maintaining a CXTPDockingPaneBase collection.
CXTPDockingPaneInfoList | This list is used by the CXTPDockingPaneLayout class for maintaining a XTP_DOCKINGPANE_INFO collection.
CXTPDockingPaneList | This list is used by the CXTPDockingPaneTabbedContainer class for maintaining a CXTPDockingPane collection.
CXTPPaneIndexToPaneMap | This map is used for mapping index to CXTPDockingPaneBase objects.
CXTPPaneToPaneMap | This map is used for mapping CXTPDockingPaneBase objects.
Variables
Variable | Description
WM_XTP_DOCKINGPANE_BASE | Base for all docking pane messages
XTP_ACTION_NOCLOSE | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_ACTION | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_CLOSEPANE | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_CONTEXTMENU | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_RCLICK | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_SHOWWINDOW | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.


Docking Panes Hierarchy

Docking Panes
Docking Panes Hierarchy

Module

Docking Panes


Classes

Classes, Docking Panes
Classes
Classes
Class | Description
CXTPDockingPane | CXTPDockingPane is a CXTPDockingPaneBase derived class. It is used as a container for a user window.
CXTPDockingPaneAutoHidePanel | CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It is used internally as an auto-hide container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneAutoHideWnd | CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class. It is used internally by CXTPDockingPaneAutoHidePanel as a sliding auto-hide window for the hidden pane.
CXTPDockingPaneBase | CXTPDockingPaneBase is a stand alone class. It represents the parent class for a Docking Pane and its containers.
CXTPDockingPaneBaseContainer | CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class. It represents the parent class for a all virtual containers.
CXTPDockingPaneCaptionButton | CXTPDockingPaneCaptionButton is a stand alone internal class.
CXTPDockingPaneCaptionButtons | CXTPDockingPaneCaptionButtons is CArray derived class used for manipulate Caption Buttons.
CXTPDockingPaneContext | CXTPDockingPaneContext is a stand alone class. It is used internally for docking and sizing panes.
CXTPDockingPaneContextAlphaWnd | CXTPDockingPaneContextAlphaWnd is CWnd derived class represents alpha context helper window
CXTPDockingPaneContextStickerWnd | CXTPDockingPaneContextStickerWnd is CWnd derived class represents sticker window.
CXTPDockingPaneDefaultTheme | CXTPDockingPaneDefaultTheme is CXTPDockingPanePaintManager derived class, represents classic theme for docking panes.
CXTPDockingPaneExplorerTheme | CXTPDockingPaneExplorerTheme is CXTPDockingPaneDefaultTheme derived class, represents explorer theme for docking panes.
CXTPDockingPaneGripperedTheme | CXTPDockingPaneGripperedTheme is CXTPDockingPaneDefaultTheme derived class, represents gripper theme for docking panes.
CXTPDockingPaneLayout | CXTPDockingPaneLayout is a stand alone class. It is used to manipulate a pane's layouts.
CXTPDockingPaneManager | CXTPDockingPaneManager is a CWnd derived class. It is used to manipulate docking panes.
CXTPDockingPaneMiniWnd | CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase. It is used internally as a MiniWnd container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneNativeXPTheme | CXTPDockingPaneNativeXPTheme is CXTPDockingPaneOfficeTheme derived class, represents Win XP theme for docking panes.
CXTPDockingPaneOffice2003Theme | CXTPDockingPaneOffice2003Theme is CXTPDockingPaneOfficeTheme derived class, represents Office 2003 theme for docking panes.
CXTPDockingPaneOffice2007Theme | CXTPDockingPaneOffice2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2007 theme for docking panes.
CXTPDockingPaneOfficeTheme | CXTPDockingPaneOfficeTheme is CXTPDockingPaneGripperedTheme derived class, represents Office XP theme for docking panes.
CXTPDockingPanePaintManager | CXTPDockingPanePaintManager is a stand alone class. Override some virtual functions to get a new visual theme.
CXTPDockingPaneShortcutBar2003Theme | CXTPDockingPaneShortcutBar2003Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2003 theme for docking panes.
CXTPDockingPaneSplitterContainer | CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class. It is used internally as a splitter container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneSplitterWnd | CXTPDockingPaneSplitterWnd is a CWnd derived class. It is used internally for splitting Panes.
CXTPDockingPaneTabbedContainer | CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It represents a tabbed container for Docking Panes.
CXTPDockingPaneVisioTheme | CXTPDockingPaneVisioTheme is CXTPDockingPaneOfficeTheme derived class, represents Visio theme for docking panes.
CXTPDockingPaneVisualStudio2005SecondTheme | CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneWhidbeyTheme derived class, represents Visual Studio 2005 beta 2 theme for docking panes.
CXTPDockingPaneVisualStudio2005Theme | CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneVisualStudio2005SecondTheme derived class, represents Visual Studio 2005 theme for docking panes.
CXTPDockingPaneWhidbeyTheme | CXTPDockingPaneWhidbeyTheme is CXTPDockingPaneOfficeTheme derived class, represents Visual Studio 2005 theme for docking panes.
CXTPDockingPaneWord2007Theme | CXTPDockingPaneWord2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office Word 2007 theme for docking panes.
Module

Docking Panes


CXTPDockingPane Class

XTPDockingPane.h, Classes, Legend, Members, Topics, CXTPDockingPane Data Members, CXTPDockingPane Methods, CXTPDockingPane Constructors, CXTPDockingPane Destructors, CXTPDockingPane Constructors, CXTPDockingPane Data Members, CXTPDockingPane Destructors, CXTPDockingPane Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPane Class

CXTPDockingPane is a CXTPDockingPaneBase derived class. It is used as a container for a user window.

Class Hierarchy

class CXTPDockingPane : public CXTPDockingPaneBase;
File

XTPDockingPane.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPane Constructors
CXTPDockingPane Constructors | Description
CXTPDockingPane | Constructs a CXTPDockingPane object Protected constructor. Use CXTPDockingPaneManager::CreatePane() to create it.
CXTPDockingPane Data Members
CXTPDockingPane Data Members | Description
m_bEnabled | Pane enabled options
m_clrItemTab | Color used to fill the docking pane tab buttons.
m_dwData | User item data
m_dwOptions | Options of the pane.
m_hwndChild | Child window handle
m_nIconID | Icon identifier
m_nID | Pane identifier
m_nIDHelp | Context-sensitive help ID for a child pane
m_ptMaxTrackSize | Maximum pane size.
m_ptMinTrackSize | Minimum pane size.
m_strTitle | Caption of the pane
CXTPDockingPane Destructors
CXTPDockingPane Destructors | Description
~CXTPDockingPane | Destroys a CXTPDockingPane object, handles cleanup and deallocation.
CXTPDockingPane Methods
CXTPDockingPane Methods | Description
Attach | Call this member to associate the pane with a user window.
AttachView | This member function dynamically creates a view based on a CRuntimeClass object and attaches it to the pane.
Close | Call this member to close the pane.
Copy | Copies self data from another pane
DeletePane | This method is called to destroy pane
Detach | Call this member to disassociate the pane from a user window.
DoPropExchange | Call this member function to save/restore the settings of the pane.
GetChild | Call this member to get the associated user window.
GetDockingSite | Call this member function to retrieve the parent window for the pane
GetEnabled | Determines if pane is enabled
GetIcon | Retrieves icon associated with the pane.
GetIconID | Returns identifier of icon if set, otherwise returns pane's identifier
GetID | Call this member to get pane's identifier.
GetItemColor | This member function returns the RGB value for the referenced item tab color or (COLORREF)-1, if the color was not set.
GetMinMaxInfo | Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.
GetOptions | Call this member to get the options of the pane.
GetPaneData | This method retrieves the application-supplied 32-bit value associated with the tab item.
GetParentFrame | Call this member function to retrieve the parent frame window
GetShortTitle | Call this member to get the short title of the pane.
GetTitle | Call this member to get the title of the pane.
Hide | Call this member to hide the pane.
IsClosed | Call this member to check if the pane is closed.
IsFloating | Call this member to check if the pane is floating.
IsFocus | Retrieves the state of the child window.
IsHidden | Call this member to check if the pane is hidden.
IsSelected | Call this member to check if the pane is selected.
IsValid | Call this member to check if the pane is associated with a user window.
OnSizeParent | This method is called to set the position of the pane
Select | Call this member to select the pane.
SetEnabled | Call this method to disable/enable the pane
SetFocus | Call this member to set the focus of the pane.
SetHelpID | Sets a context-sensitive help ID for the child pane
SetIconID | Call this member to set the identifier of the icon.
SetID | Call this member to set the identifier of the item.
SetItemColor | Call this member to set the RGB value for the ite tab.
SetMaxTrackSize | Call this method to set maximum size of pane.
SetMinTrackSize | Call this method to set minimum size of pane.
SetOptions | Call this member to set options of the pane.
SetPaneData | Call this method to set the 32-bit value associated with the pane
SetParentContainer | Call this method to set the parent container of the pane.
SetTitle | Call this member to set a title for this object.
SetWindowRect | Call this member to set the bounding rectangle
ShowWindow | Sets the visibility state of the window.


CXTPDockingPane Data Members

CXTPDockingPane Class, Legend, Protected Data Members
CXTPDockingPane Data Members
Class

CXTPDockingPane Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bEnabled | Pane enabled options
m_clrItemTab | Color used to fill the docking pane tab buttons.
m_dwData | User item data
m_dwOptions | Options of the pane.
m_hwndChild | Child window handle
m_nIconID | Icon identifier
m_nID | Pane identifier
m_nIDHelp | Context-sensitive help ID for a child pane
m_ptMaxTrackSize | Maximum pane size.
m_ptMinTrackSize | Minimum pane size.
m_strTitle | Caption of the pane


CXTPDockingPane::m_bEnabled Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_bEnabled Data Member

Pane enabled options

XTPXTPDockingPaneEnableOptions m_bEnabled;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_clrItemTab Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_clrItemTab Data Member

Color used to fill the docking pane tab buttons.

COLORREF m_clrItemTab;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_dwData Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_dwData Data Member

User item data

DWORD_PTR m_dwData;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_dwOptions Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_dwOptions Data Member

Options of the pane.

DWORD m_dwOptions;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_hwndChild Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_hwndChild Data Member

Child window handle

HWND m_hwndChild;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_nIconID Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_nIconID Data Member

Icon identifier

int m_nIconID;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_nID Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_nID Data Member

Pane identifier

int m_nID;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_nIDHelp Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_nIDHelp Data Member

Context-sensitive help ID for a child pane

int m_nIDHelp;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_ptMaxTrackSize Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_ptMaxTrackSize Data Member

Maximum pane size.

CPoint m_ptMaxTrackSize;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_ptMinTrackSize Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_ptMinTrackSize Data Member

Minimum pane size.

CPoint m_ptMinTrackSize;
Group

CXTPDockingPane Data Members


CXTPDockingPane::m_strTitle Data Member

CXTPDockingPane Data Members, CXTPDockingPane Class
CXTPDockingPane::m_strTitle Data Member

Caption of the pane

CString m_strTitle;
Group

CXTPDockingPane Data Members


CXTPDockingPane Methods

CXTPDockingPane Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPane Methods
Class

CXTPDockingPane Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Copy | Copies self data from another pane
DeletePane | This method is called to destroy pane
DoPropExchange | Call this member function to save/restore the settings of the pane.
OnSizeParent | This method is called to set the position of the pane
SetID | Call this member to set the identifier of the item.
SetParentContainer | Call this method to set the parent container of the pane.
SetWindowRect | Call this member to set the bounding rectangle
ShowWindow | Sets the visibility state of the window.
Public Methods
Public Methods
Public Method | Description
Attach | Call this member to associate the pane with a user window.
AttachView | This member function dynamically creates a view based on a CRuntimeClass object and attaches it to the pane.
Close | Call this member to close the pane.
Detach | Call this member to disassociate the pane from a user window.
GetChild | Call this member to get the associated user window.
GetDockingSite | Call this member function to retrieve the parent window for the pane
GetEnabled | Determines if pane is enabled
GetIcon | Retrieves icon associated with the pane.
GetIconID | Returns identifier of icon if set, otherwise returns pane's identifier
GetID | Call this member to get pane's identifier.
GetItemColor | This member function returns the RGB value for the referenced item tab color or (COLORREF)-1, if the color was not set.
GetMinMaxInfo | Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.
GetOptions | Call this member to get the options of the pane.
GetPaneData | This method retrieves the application-supplied 32-bit value associated with the tab item.
GetParentFrame | Call this member function to retrieve the parent frame window
GetShortTitle | Call this member to get the short title of the pane.
GetTitle | Call this member to get the title of the pane.
Hide | Call this member to hide the pane.
IsClosed | Call this member to check if the pane is closed.
IsFloating | Call this member to check if the pane is floating.
IsFocus | Retrieves the state of the child window.
IsHidden | Call this member to check if the pane is hidden.
IsSelected | Call this member to check if the pane is selected.
IsValid | Call this member to check if the pane is associated with a user window.
Select | Call this member to select the pane.
SetEnabled | Call this method to disable/enable the pane
SetFocus | Call this member to set the focus of the pane.
SetHelpID | Sets a context-sensitive help ID for the child pane
SetIconID | Call this member to set the identifier of the icon.
SetItemColor | Call this member to set the RGB value for the ite tab.
SetMaxTrackSize | Call this method to set maximum size of pane.
SetMinTrackSize | Call this method to set minimum size of pane.
SetOptions | Call this member to set options of the pane.
SetPaneData | Call this method to set the 32-bit value associated with the pane
SetTitle | Call this member to set a title for this object.


CXTPDockingPane::Attach Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::Attach Method

Call this member to associate the pane with a user window.

void Attach(
    CWnd* pWnd
);
Parameters

pWnd
Pointer to a user window.

Remarks

The best place to create a user window and associate it with a pane is after the pane becomes visible. To catch this event use the XTPWM_DOCKINGPANE_NOTIFY Handler.

Group

CXTPDockingPane Methods


CXTPDockingPane::AttachView Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::AttachView Method

This member function dynamically creates a view based on a CRuntimeClass object and attaches it to the pane.

CWnd* AttachView(
    CWnd* pParentWnd,
    CRuntimeClass * pViewClass,
    CDocument * pDocument = NULL,
    CCreateContext* pContext = NULL
);
Parameters

pParentWnd
Points to the parent of the view to be created. The parent must be valid.
pViewClass
CView runtime class.
pDocument
CDocument associated with the view. It can be NULL.
pContext
Create context for the view. It can be NULL.

Returns

A CWnd* pointer to the newly created view if successful, otherwise returns NULL.

Remarks

The best place to create a user window and associate it with a pane is after the pane becomes visible. To catch this event, use the XTPWM_DOCKINGPANE_NOTIFY Handler.

Group

CXTPDockingPane Methods


CXTPDockingPane::Close Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::Close Method

Call this member to close the pane.

void Close();
Group

CXTPDockingPane Methods


CXTPDockingPane::Copy Method

CXTPDockingPane Methods, CXTPDockingPane Class, See Also
CXTPDockingPane::Copy Method

Copies self data from another pane

virtual void Copy(
    CXTPDockingPane* pPane
);
Parameters

pClone
Pane which members need to copy.

See Also

Clone

Group

CXTPDockingPane Methods


CXTPDockingPane::DeletePane Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::DeletePane Method

This method is called to destroy pane

virtual void DeletePane();
Group

CXTPDockingPane Methods


CXTPDockingPane::Detach Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::Detach Method

Call this member to disassociate the pane from a user window.

void Detach();
Group

CXTPDockingPane Methods


CXTPDockingPane::DoPropExchange Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::DoPropExchange Method

Call this member function to save/restore the settings of the pane.

virtual BOOL DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Points to a CXTPPropExchange object.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPDockingPane Methods


CXTPDockingPane::GetChild Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source
CXTPDockingPane::GetChild Method

Call this member to get the associated user window.

CWnd* GetChild() const;
Returns

Pointer to the associated user child window.

Body Source
CWnd* CXTPDockingPane::GetChild() const {
    return m_hwndChild ? CWnd ::FromHandle(m_hwndChild): NULL;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::GetDockingSite Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::GetDockingSite Method

Call this member function to retrieve the parent window for the pane

CWnd* GetDockingSite() const;
Returns

A pointer to a parent window if successful; otherwise NULL

Group

CXTPDockingPane Methods


CXTPDockingPane::GetEnabled Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::GetEnabled Method

Determines if pane is enabled

XTPXTPDockingPaneEnableOptions GetEnabled() const;
Returns

TRUE if pane is enabled

Group

CXTPDockingPane Methods


CXTPDockingPane::GetIcon Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::GetIcon Method

Retrieves icon associated with the pane.

virtual CXTPImageManagerIcon* GetIcon(
    int nWidth = 16
) const;
Parameters

nWidth
Width of the icon to retrieve.

Returns

Handle of the icon.

Group

CXTPDockingPane Methods


CXTPDockingPane::GetIconID Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source
CXTPDockingPane::GetIconID Method

Returns identifier of icon if set, otherwise returns pane's identifier

int GetIconID() const;
Returns

The identifier of the icon if set, otherwise returns the identifier of the pane

Body Source
int CXTPDockingPane::GetIconID() const {
    return m_nIconID == -1 ? m_nID : m_nIconID;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::GetID Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source
CXTPDockingPane::GetID Method

Call this member to get pane's identifier.

int GetID() const;
Returns

The identifier of the pane.

Body Source
int  CXTPDockingPane::GetID() const {
    return m_nID;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::GetItemColor Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::GetItemColor Method

This member function returns the RGB value for the referenced item tab color or (COLORREF)-1, if the color was not set.

virtual COLORREF GetItemColor() const;
Returns

The RGB value for the referenced item tab color, or (COLORREF)-1, if the color was not set.

Group

CXTPDockingPane Methods


CXTPDockingPane::GetMinMaxInfo Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::GetMinMaxInfo Method

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.

virtual void GetMinMaxInfo(
    LPMINMAXINFO pMinMaxInfo
) const;
Parameters

pMinMaxInfo
Pointer to MINMAXINFO structure

Group

CXTPDockingPane Methods


CXTPDockingPane::GetOptions Method

CXTPDockingPane Methods, CXTPDockingPane Class, See Also
CXTPDockingPane::GetOptions Method

Call this member to get the options of the pane.

DWORD GetOptions() const;
Returns

The pane's data

See Also

XTPDockingPaneOptions

Group

CXTPDockingPane Methods


CXTPDockingPane::GetPaneData Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPane::GetPaneData Method

This method retrieves the application-supplied 32-bit value associated with the tab item.

DWORD_PTR GetPaneData() const;
Returns

The 32-bit value associated with the pane

See Also

SetPaneData

Body Source
DWORD_PTR CXTPDockingPane::GetPaneData() const {
    return m_dwData;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::GetParentFrame Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::GetParentFrame Method

Call this member function to retrieve the parent frame window

CFrameWnd* GetParentFrame() const;
Returns

A pointer to a frame window if successful; otherwise NULL

Remarks

The member function searches up the parent chain until a CFrameWnd (or derived class) object is found.

Group

CXTPDockingPane Methods


CXTPDockingPane::GetShortTitle Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::GetShortTitle Method

Call this member to get the short title of the pane.

virtual CString GetShortTitle() const;
Returns

The short title of the pane.

Group

CXTPDockingPane Methods


CXTPDockingPane::GetTitle Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::GetTitle Method

Call this member to get the title of the pane.

virtual CString GetTitle() const;
Returns

The title of the pane.

Group

CXTPDockingPane Methods


CXTPDockingPane::Hide Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::Hide Method

Call this member to hide the pane.

void Hide();
Group

CXTPDockingPane Methods


CXTPDockingPane::IsClosed Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::IsClosed Method

Call this member to check if the pane is closed.

BOOL IsClosed() const;
Returns

TRUE if the pane is closed.

Group

CXTPDockingPane Methods


CXTPDockingPane::IsFloating Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::IsFloating Method

Call this member to check if the pane is floating.

BOOL IsFloating() const;
Returns

TRUE if the pane is floating.

Group

CXTPDockingPane Methods


CXTPDockingPane::IsFocus Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::IsFocus Method

Retrieves the state of the child window.

BOOL IsFocus() const;
Returns

TRUE if child window is focused.

Group

CXTPDockingPane Methods


CXTPDockingPane::IsHidden Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::IsHidden Method

Call this member to check if the pane is hidden.

BOOL IsHidden() const;
Returns

TRUE if the pane is hidden.

Group

CXTPDockingPane Methods


CXTPDockingPane::IsSelected Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::IsSelected Method

Call this member to check if the pane is selected.

BOOL IsSelected() const;
Returns

TRUE if the pane is selected.

Group

CXTPDockingPane Methods


CXTPDockingPane::IsValid Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::IsValid Method

Call this member to check if the pane is associated with a user window.

BOOL IsValid() const;
Returns

TRUE if the pane is associated with a user window.

Group

CXTPDockingPane Methods


CXTPDockingPane::OnSizeParent Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::OnSizeParent Method

This method is called to set the position of the pane

virtual void OnSizeParent(
    CWnd* pParent,
    CRect rect,
    LPVOID lParam
);
Parameters

pParent
Points to a CWnd object.
rect
Rectangle of the pane to be set.
lParam
Pointer to AFX_SIZEPARENTPARAMS structure.

Group

CXTPDockingPane Methods


CXTPDockingPane::Select Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::Select Method

Call this member to select the pane.

void Select();
Group

CXTPDockingPane Methods


CXTPDockingPane::SetEnabled Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::SetEnabled Method

Call this method to disable/enable the pane

void SetEnabled(
    XTPXTPDockingPaneEnableOptions bEnabled
);
Parameters

bEnabled
TRUE to enable pane; FALSE to disable

Group

CXTPDockingPane Methods


CXTPDockingPane::SetFocus Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::SetFocus Method

Call this member to set the focus of the pane.

virtual void SetFocus();
Group

CXTPDockingPane Methods


CXTPDockingPane::SetHelpID Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source
CXTPDockingPane::SetHelpID Method

Sets a context-sensitive help ID for the child pane

void SetHelpID(
    int nIDR
);
Parameters

nIDR
Specifies the context-sensitive help ID.

Body Source
void CXTPDockingPane::SetHelpID(int nIDR) {
    m_nIDHelp = nIDR;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::SetIconID Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source
CXTPDockingPane::SetIconID Method

Call this member to set the identifier of the icon.

void SetIconID(
    UINT nID
);
Parameters

nID
Identifier of the icon

Body Source
void CXTPDockingPane::SetIconID(UINT nID) {
    m_nIconID = nID;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::SetID Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::SetID Method

Call this member to set the identifier of the item.

void SetID(
    int nID
);
Parameters

nID
Identifier of the item.

Group

CXTPDockingPane Methods


CXTPDockingPane::SetItemColor Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::SetItemColor Method

Call this member to set the RGB value for the ite tab.

void SetItemColor(
    COLORREF clr
);
Parameters

clr
Color of the item tab.

Group

CXTPDockingPane Methods


CXTPDockingPane::SetMaxTrackSize Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source
CXTPDockingPane::SetMaxTrackSize Method

Call this method to set maximum size of pane.

CSize SetMaxTrackSize(
    CSize sz
);
Parameters

sz
Maximum size of pane to set

Body Source
CSize CXTPDockingPane::SetMaxTrackSize(CSize sz) {
    CSize szMaxTrackSize(m_ptMaxTrackSize);
    m_ptMaxTrackSize = CPoint(sz);
    return szMaxTrackSize;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::SetMinTrackSize Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source
CXTPDockingPane::SetMinTrackSize Method

Call this method to set minimum size of pane.

CSize SetMinTrackSize(
    CSize sz
);
Parameters

sz
Minimum size of pane to set

Body Source
CSize CXTPDockingPane::SetMinTrackSize(CSize sz) {
    CSize szMinTrackSize(m_ptMinTrackSize);
    m_ptMinTrackSize = CPoint(sz);
    return szMinTrackSize;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::SetOptions Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source
CXTPDockingPane::SetOptions Method

Call this member to set options of the pane.

void SetOptions(
    DWORD dwOptions
);
Parameters

dwOptions
Options to be set. Can be any of the values listed in the Remarks section.

Remarks

dwOptions parameter can be one or more of the following:

  • xtpPaneNoCloseable Indicates the pane can't be closed.
  • xtpPaneNoHideable Indicates the pane can't be hidden.
  • xtpPaneNoFloatable Indicates the pane can't be floated.
  • xtpPaneNoCaption Indicates the pane has no caption.
  • xtpPaneHasMenuButton Indicates the pane has menu button.
  • xtpPaneNoDockable Indicates the pane can't be docked.

See Also XTPDockingPaneOptions

Body Source
void CXTPDockingPane::SetOptions(DWORD dwOptions) {
    m_dwOptions = dwOptions;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::SetPaneData Method

CXTPDockingPane Methods, CXTPDockingPane Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPane::SetPaneData Method

Call this method to set the 32-bit value associated with the pane

void SetPaneData(
    DWORD_PTR dwData
);
Parameters

dwData
Contains the new value to associate with the pane

See Also

GetPaneData

Body Source
void CXTPDockingPane::SetPaneData(DWORD_PTR dwData) {
    m_dwData = dwData;
}
Group

CXTPDockingPane Methods


CXTPDockingPane::SetParentContainer Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::SetParentContainer Method

Call this method to set the parent container of the pane.

virtual void SetParentContainer(
    CXTPDockingPaneBase* pContainer
);
Parameters

pContainer
Points to a CXTPDockingPaneBase object.

Group

CXTPDockingPane Methods


CXTPDockingPane::SetTitle Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::SetTitle Method

Call this member to set a title for this object.

void SetTitle(
    LPCTSTR lpszTitle
);
Parameters

lpszTitle
Title to be set.

Group

CXTPDockingPane Methods


CXTPDockingPane::SetWindowRect Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::SetWindowRect Method

Call this member to set the bounding rectangle

void SetWindowRect(
    CRect rc
);
Parameters

rc
Bounding rectangle to draw.

Group

CXTPDockingPane Methods


CXTPDockingPane::ShowWindow Method

CXTPDockingPane Methods, CXTPDockingPane Class
CXTPDockingPane::ShowWindow Method

Sets the visibility state of the window.

void ShowWindow(
    BOOL bShow
);
Parameters

bShow
TRUE to show the window, or FALSE to hide it.

Group

CXTPDockingPane Methods


CXTPDockingPane Constructors

CXTPDockingPane Class, Legend, Protected Methods
CXTPDockingPane Constructors
Class

CXTPDockingPane Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPane | Constructs a CXTPDockingPane object Protected constructor. Use CXTPDockingPaneManager::CreatePane() to create it.


CXTPDockingPane::CXTPDockingPane Constructor

CXTPDockingPane Constructors, CXTPDockingPane Class
CXTPDockingPane::CXTPDockingPane Constructor

Constructs a CXTPDockingPane object Protected constructor. Use CXTPDockingPaneManager::CreatePane() to create it.

CXTPDockingPane(
    CXTPDockingPaneLayout* pLayout
);
Parameters

pLayout
Points to a CXTPDockingPaneLayout object

Group

CXTPDockingPane Constructors


CXTPDockingPane Destructors

CXTPDockingPane Class, Legend, Protected Methods
CXTPDockingPane Destructors
Class

CXTPDockingPane Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPane | Destroys a CXTPDockingPane object, handles cleanup and deallocation.


CXTPDockingPane::~CXTPDockingPane Destructor

CXTPDockingPane Destructors, CXTPDockingPane Class
CXTPDockingPane::~CXTPDockingPane Destructor

Destroys a CXTPDockingPane object, handles cleanup and deallocation.

virtual ~CXTPDockingPane();
Group

CXTPDockingPane Destructors


CXTPDockingPaneAutoHidePanel Class

XTPDockingPaneAutoHidePanel.h, Classes, Legend, Members, Topics, CXTPDockingPaneAutoHidePanel Data Members, CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Constructors, CXTPDockingPaneAutoHidePanel Destructors, CXTPDockingPaneAutoHidePanel Constructors, CXTPDockingPaneAutoHidePanel Data Members, CXTPDockingPaneAutoHidePanel Destructors, CXTPDockingPaneAutoHidePanel Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel Class

CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It is used internally as an auto-hide container for CXTPDockingPaneBase derived classes.

Class Hierarchy

class CXTPDockingPaneAutoHidePanel : public CWnd, public CXTPDockingPaneBaseContainer;
File

XTPDockingPaneAutoHidePanel.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneAutoHidePanel Constructors
CXTPDockingPaneAutoHidePanel Constructors | Description
CXTPDockingPaneAutoHidePanel | Constructs a CXTPDockingPaneAutoHidePanel object Protected constructor. Internally constructed only.
CXTPDockingPaneAutoHidePanel Data Members
CXTPDockingPaneAutoHidePanel Data Members | Description
m_bCloseActiveWindow | TRUE to allow the AutoHide window to be closed.
m_direction | Location of hidden panel
m_pActiveWnd | Active window
CXTPDockingPaneAutoHidePanel Destructors
CXTPDockingPaneAutoHidePanel Destructors | Description
~CXTPDockingPaneAutoHidePanel | Destroys a CXTPDockingPaneAutoHidePanel object, handles cleanup and deallocation
CXTPDockingPaneAutoHidePanel Methods
CXTPDockingPaneAutoHidePanel Methods | Description
_InsertPane | Call this member to insert a pane into a collection
CloseActiveWindow | Call this member to close the active window from panel
CloseActiveWindows | Call this member to close active windows from all panels
Create | Creates auto-hide panel.
DoPropExchange | Call this member function to save/restore the settings of the pane.
GetDirection | Call this member function to determine the position of the auto-hide panel.
GetPaneHwnd | Returns the window handle for a window.
GetPanelHeight | Retrieves the height of the panel
GetPaneTab | Call this member to get tab for corresponded pane.
HitTest | This member function determines which header item, if any, is at a specified cursor position
InvalidatePane | This member is called when a need to redraw pane.
OnChildContainerChanged | This member is called when a child pane collection is changed.
OnSizeParentEx | This method is called to set the position of the pane
RefreshManagersArray | Call this member to refresh the manager array
RemovePane | Call this member to remove a pane from collection.
ShowPane | Call this member to show (activate) a pane by its identifier.


CXTPDockingPaneAutoHidePanel Data Members

CXTPDockingPaneAutoHidePanel Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel Data Members
Class

CXTPDockingPaneAutoHidePanel Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_direction | Location of hidden panel
m_pActiveWnd | Active window
Public Data Members
Public Data Member | Description
m_bCloseActiveWindow | TRUE to allow the AutoHide window to be closed.


CXTPDockingPaneAutoHidePanel::m_bCloseActiveWindow Data Member

CXTPDockingPaneAutoHidePanel Data Members, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::m_bCloseActiveWindow Data Member

TRUE to allow the AutoHide window to be closed.

BOOL m_bCloseActiveWindow;
Group

CXTPDockingPaneAutoHidePanel Data Members


CXTPDockingPaneAutoHidePanel::m_direction Data Member

CXTPDockingPaneAutoHidePanel Data Members, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::m_direction Data Member

Location of hidden panel

XTPDockingPaneDirection m_direction;
Group

CXTPDockingPaneAutoHidePanel Data Members


CXTPDockingPaneAutoHidePanel::m_pActiveWnd Data Member

CXTPDockingPaneAutoHidePanel Data Members, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::m_pActiveWnd Data Member

Active window

CXTPDockingPaneAutoHideWnd* m_pActiveWnd;
Group

CXTPDockingPaneAutoHidePanel Data Members


CXTPDockingPaneAutoHidePanel Methods

CXTPDockingPaneAutoHidePanel Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel Methods
Class

CXTPDockingPaneAutoHidePanel Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_InsertPane | Call this member to insert a pane into a collection
CloseActiveWindow | Call this member to close the active window from panel
CloseActiveWindows | Call this member to close active windows from all panels
Create | Creates auto-hide panel.
DoPropExchange | Call this member function to save/restore the settings of the pane.
GetPanelHeight | Retrieves the height of the panel
InvalidatePane | This member is called when a need to redraw pane.
OnChildContainerChanged | This member is called when a child pane collection is changed.
OnSizeParentEx | This method is called to set the position of the pane
RefreshManagersArray | Call this member to refresh the manager array
RemovePane | Call this member to remove a pane from collection.
ShowPane | Call this member to show (activate) a pane by its identifier.
Public Methods
Public Methods
Public Method | Description
GetDirection | Call this member function to determine the position of the auto-hide panel.
GetPaneHwnd | Returns the window handle for a window.
GetPaneTab | Call this member to get tab for corresponded pane.
HitTest | This member function determines which header item, if any, is at a specified cursor position


CXTPDockingPaneAutoHidePanel::_InsertPane Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::_InsertPane Method

Call this member to insert a pane into a collection

virtual void _InsertPane(
    CXTPDockingPaneBase* pPane
);
Parameters

pPane
Points to a CXTPDockingPaneBase object

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::CloseActiveWindow Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::CloseActiveWindow Method

Call this member to close the active window from panel

void CloseActiveWindow(
    BOOL bDelayed = FALSE
);
Parameters

bDelayed
FALSE to delay the closing

See Also

CloseActiveWindows

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::CloseActiveWindows Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::CloseActiveWindows Method

Call this member to close active windows from all panels

void CloseActiveWindows();
See Also

CloseActiveWindow

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::Create Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::Create Method

Creates auto-hide panel.

virtual void Create(
    CWnd* pParent
);
Parameters

pParent
Parent frame site.

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::DoPropExchange Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::DoPropExchange Method

Call this member function to save/restore the settings of the pane.

virtual BOOL DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Points to a CXTPPropExchange object.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::GetDirection Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::GetDirection Method

Call this member function to determine the position of the auto-hide panel.

XTPDockingPaneDirection GetDirection() const;
Returns

The panel's direction.

Body Source
XTPDockingPaneDirection CXTPDockingPaneAutoHidePanel::GetDirection() const {
    return m_direction;
}
Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::GetPaneHwnd Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::GetPaneHwnd Method

Returns the window handle for a window.

virtual HWND GetPaneHwnd() const;
Returns

Returns NULL if the HWND is not attached to a window or if it is used with a NULL HWND pointer.

Body Source
HWND CXTPDockingPaneAutoHidePanel::GetPaneHwnd() const {
    return CWnd::GetSafeHwnd();
}
Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::GetPanelHeight Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::GetPanelHeight Method

Retrieves the height of the panel

int GetPanelHeight() const;
Returns

The height of the panel

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::GetPaneTab Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::GetPaneTab Method

Call this member to get tab for corresponded pane.

CXTPTabManagerItem* GetPaneTab(
    CXTPDockingPane* pPane
) const;
Parameters

pPane
Pane to get tab for

Returns

CXTPTabManagerItem pointer corresponded with pPane

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::HitTest Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::HitTest Method

This member function determines which header item, if any, is at a specified cursor position

CXTPDockingPane* HitTest(
    CPoint point
) const;
Parameters

point
Point to be tested.

Returns

The index of the item at the position specified by 'pt', otherwise returns NULL.

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::InvalidatePane Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::InvalidatePane Method

This member is called when a need to redraw pane.

virtual void InvalidatePane(
    BOOL bSelectionChanged
);
Parameters

bSelectionChanged
TRUE if selected pane was changed

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::OnChildContainerChanged Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::OnChildContainerChanged Method

This member is called when a child pane collection is changed.

virtual void OnChildContainerChanged(
    CXTPDockingPaneBase* pContainer
);
Parameters

pContainer
Points to a CXTPDockingPaneBase object that is changed.

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::OnSizeParentEx Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::OnSizeParentEx Method

This method is called to set the position of the pane

virtual void OnSizeParentEx(
    CWnd* pParent,
    CRect& rect,
    LPVOID lParam
);
Parameters

pParent
Points to a CWnd object.
rect
Rectangle of the pane to be set.
lParam
Pointer to AFX_SIZEPARENTPARAMS structure.

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::RefreshManagersArray Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::RefreshManagersArray Method

Call this member to refresh the manager array

void RefreshManagersArray(
    CDC* pDC,
    CRect rcClient
);
Parameters

pDC
Points to a CDC object
rcClient
Size of the client area

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::RemovePane Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::RemovePane Method

Call this member to remove a pane from collection.

virtual void RemovePane(
    CXTPDockingPaneBase* pPane
);
Parameters

pPane
Points to a CXTPDockingPaneBase object.

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel::ShowPane Method

CXTPDockingPaneAutoHidePanel Methods, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::ShowPane Method

Call this member to show (activate) a pane by its identifier.

void ShowPane(
    CXTPDockingPane* pPane,
    BOOL bSetFocus = TRUE
);
Parameters

pPane
Points to a CXTPDockingPane object.
bSetFocus
TRUE to set focus to child docking pane

Group

CXTPDockingPaneAutoHidePanel Methods


CXTPDockingPaneAutoHidePanel Constructors

CXTPDockingPaneAutoHidePanel Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel Constructors
Class

CXTPDockingPaneAutoHidePanel Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneAutoHidePanel | Constructs a CXTPDockingPaneAutoHidePanel object Protected constructor. Internally constructed only.


CXTPDockingPaneAutoHidePanel::CXTPDockingPaneAutoHidePanel Constructor

CXTPDockingPaneAutoHidePanel Constructors, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::CXTPDockingPaneAutoHidePanel Constructor

Constructs a CXTPDockingPaneAutoHidePanel object Protected constructor. Internally constructed only.

CXTPDockingPaneAutoHidePanel(
    CXTPDockingPaneLayout* pLayout
);
Parameters

pLayout
Points to a CXTPDockingPaneLayout object.

Group

CXTPDockingPaneAutoHidePanel Constructors


CXTPDockingPaneAutoHidePanel Destructors

CXTPDockingPaneAutoHidePanel Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel Destructors
Class

CXTPDockingPaneAutoHidePanel Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPaneAutoHidePanel | Destroys a CXTPDockingPaneAutoHidePanel object, handles cleanup and deallocation


CXTPDockingPaneAutoHidePanel::~CXTPDockingPaneAutoHidePanel Destructor

CXTPDockingPaneAutoHidePanel Destructors, CXTPDockingPaneAutoHidePanel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHidePanel::~CXTPDockingPaneAutoHidePanel Destructor

Destroys a CXTPDockingPaneAutoHidePanel object, handles cleanup and deallocation

~CXTPDockingPaneAutoHidePanel();
Group

CXTPDockingPaneAutoHidePanel Destructors


CXTPDockingPaneAutoHideWnd Class

XTPDockingPaneAutoHidePanel.h, Classes, Legend, Members, Topics, CXTPDockingPaneAutoHideWnd Data Members, CXTPDockingPaneAutoHideWnd Methods, CXTPDockingPaneAutoHideWnd Data Members, CXTPDockingPaneAutoHideWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHideWnd Class

CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class. It is used internally by CXTPDockingPaneAutoHidePanel as a sliding auto-hide window for the hidden pane.

Class Hierarchy

class CXTPDockingPaneAutoHideWnd : public CMiniFrameWnd;
File

XTPDockingPaneAutoHidePanel.h

Group

Classes

Legend
Data Member
Method
CXTPDockingPaneAutoHideWnd Data Members
CXTPDockingPaneAutoHideWnd Data Members | Description
m_dAnimationDelay | Animation delay
m_nAnimationDuration | Duration of sliding animation in ms
m_nAnimationInterval | Delay in ms between animation steps
m_nInactiveCollapseDelay | Delay before collapsing inactive.
m_nMouseHoverDelay | Duration of mouse hover before expanding
CXTPDockingPaneAutoHideWnd Methods
CXTPDockingPaneAutoHideWnd Methods | Description
GetPane | Retrieves child container of sliding auto-hide window.


CXTPDockingPaneAutoHideWnd Data Members

CXTPDockingPaneAutoHideWnd Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHideWnd Data Members
Class

CXTPDockingPaneAutoHideWnd Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_dAnimationDelay | Animation delay
m_nAnimationDuration | Duration of sliding animation in ms
m_nAnimationInterval | Delay in ms between animation steps
m_nInactiveCollapseDelay | Delay before collapsing inactive.
m_nMouseHoverDelay | Duration of mouse hover before expanding


CXTPDockingPaneAutoHideWnd::m_dAnimationDelay Data Member

CXTPDockingPaneAutoHideWnd Data Members, CXTPDockingPaneAutoHideWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHideWnd::m_dAnimationDelay Data Member

Animation delay

double m_dAnimationDelay;
Group

CXTPDockingPaneAutoHideWnd Data Members


CXTPDockingPaneAutoHideWnd::m_nAnimationDuration Data Member

CXTPDockingPaneAutoHideWnd Data Members, CXTPDockingPaneAutoHideWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHideWnd::m_nAnimationDuration Data Member

Duration of sliding animation in ms

int m_nAnimationDuration;
Group

CXTPDockingPaneAutoHideWnd Data Members


CXTPDockingPaneAutoHideWnd::m_nAnimationInterval Data Member

CXTPDockingPaneAutoHideWnd Data Members, CXTPDockingPaneAutoHideWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHideWnd::m_nAnimationInterval Data Member

Delay in ms between animation steps

int m_nAnimationInterval;
Group

CXTPDockingPaneAutoHideWnd Data Members


CXTPDockingPaneAutoHideWnd::m_nInactiveCollapseDelay Data Member

CXTPDockingPaneAutoHideWnd Data Members, CXTPDockingPaneAutoHideWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHideWnd::m_nInactiveCollapseDelay Data Member

Delay before collapsing inactive.

UINT m_nInactiveCollapseDelay;
Group

CXTPDockingPaneAutoHideWnd Data Members


CXTPDockingPaneAutoHideWnd::m_nMouseHoverDelay Data Member

CXTPDockingPaneAutoHideWnd Data Members, CXTPDockingPaneAutoHideWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHideWnd::m_nMouseHoverDelay Data Member

Duration of mouse hover before expanding

DWORD m_nMouseHoverDelay;
Group

CXTPDockingPaneAutoHideWnd Data Members


CXTPDockingPaneAutoHideWnd Methods

CXTPDockingPaneAutoHideWnd Class, Legend, Public Methods
CXTPDockingPaneAutoHideWnd Methods
Class

CXTPDockingPaneAutoHideWnd Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetPane | Retrieves child container of sliding auto-hide window.


CXTPDockingPaneAutoHideWnd::GetPane Method

CXTPDockingPaneAutoHideWnd Methods, CXTPDockingPaneAutoHideWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneAutoHideWnd::GetPane Method

Retrieves child container of sliding auto-hide window.

CXTPDockingPaneTabbedContainer* GetPane() const;
Body Source
CXTPDockingPaneTabbedContainer* CXTPDockingPaneAutoHideWnd::GetPane() const {
    return m_pPane;
}
Group

CXTPDockingPaneAutoHideWnd Methods


CXTPDockingPaneBase Class

XTPDockingPaneBase.h, Classes, Legend, Members, Topics, CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Methods, CXTPDockingPaneBase Constructors, CXTPDockingPaneBase Destructors, CXTPDockingPaneBase Constructors, CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Destructors, CXTPDockingPaneBase Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase Class

CXTPDockingPaneBase is a stand alone class. It represents the parent class for a Docking Pane and its containers.

Class Hierarchy

class CXTPDockingPaneBase;
File

XTPDockingPaneBase.h

Group

Classes

Legend
Data Member
protected
Method
virtual
abstract
CXTPDockingPaneBase Constructors
CXTPDockingPaneBase Constructors | Description
CXTPDockingPaneBase | Protected constructor. You cannot create this class.
CXTPDockingPaneBase Data Members
CXTPDockingPaneBase Data Members | Description
m_pCaptionButtons | Collection of caption buttons.
m_pDockingSite | Parent frame.
m_pLayout | Parent layout.
m_pParentContainer | Parent container.
m_rcWindow | Position of the pane.
m_szDocking | Size of the pane.
m_type | Type of the pane.
CXTPDockingPaneBase Destructors
CXTPDockingPaneBase Destructors | Description
~CXTPDockingPaneBase | Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
CXTPDockingPaneBase Methods
CXTPDockingPaneBase Methods | Description
Clone | This member is called to clone the pane.
ContainPane | Call this member to determine if one pane is contained in the collection of another.
CreateContainer | This member is called to create pane
DeletePane | This method is called to destroy pane
DoPropExchange | Call this member function to save/restore the settings of the pane.
FindCaptionButton | Call this member to find the specified caption button
FindPane | Call this member to retrieve a collection of the panes with specified type.
GetCaptionButtons | Call this member to get a reference to the caption's close/ popup button
GetContainer | Call this member function to return the parent container of the pane.
GetDockingPaneManager | Call this member function to return the pane manager
GetDockingSite | Call this member function to retrieve the parent window for the pane
GetMinMaxInfo | Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.
GetPaintManager | Call this member function to return the paint manager
GetPaneHwnd | Returns the window handle for a window.
GetPaneWindowRect | The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
GetType | Call this member to determine the type of the pane.
InvalidatePane | This member is called when a need to redraw pane.
IsCaptionButtonVisible | Call this member to determine if the caption button is visible.
IsEmpty | Call this member to determine if there are children panes
IsHidden | Call this member to check if the pane is hidden.
OnCaptionButtonRectChanged | This member is called when the dimensions of the caption button are changed.
OnChildContainerChanged | This member is called when a child pane collection is changed.
OnFocusChanged | This method is called to update the state of the pane.
OnParentContainerChanged | This member is called when the parent pane collection is changed.
OnSizeParent | This method is called to set position of the pane.
RedrawPane | Call this member to redraw the pane.
RemovePane | Call this member to remove a pane from collection.
SetDockingSite | Call this member to set the parent frame of the pane.
SetParentContainer | Call this method to set the parent container of the pane.


CXTPDockingPaneBase Data Members

CXTPDockingPaneBase Class, Legend, Protected Data Members
CXTPDockingPaneBase Data Members
Class

CXTPDockingPaneBase Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pCaptionButtons | Collection of caption buttons.
m_pDockingSite | Parent frame.
m_pLayout | Parent layout.
m_pParentContainer | Parent container.
m_rcWindow | Position of the pane.
m_szDocking | Size of the pane.
m_type | Type of the pane.


CXTPDockingPaneBase::m_pCaptionButtons Data Member

CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Class
CXTPDockingPaneBase::m_pCaptionButtons Data Member

Collection of caption buttons.

CXTPDockingPaneCaptionButtons* m_pCaptionButtons;
Group

CXTPDockingPaneBase Data Members


CXTPDockingPaneBase::m_pDockingSite Data Member

CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Class
CXTPDockingPaneBase::m_pDockingSite Data Member

Parent frame.

CWnd* m_pDockingSite;
Group

CXTPDockingPaneBase Data Members


CXTPDockingPaneBase::m_pLayout Data Member

CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Class
CXTPDockingPaneBase::m_pLayout Data Member

Parent layout.

CXTPDockingPaneLayout* m_pLayout;
Group

CXTPDockingPaneBase Data Members


CXTPDockingPaneBase::m_pParentContainer Data Member

CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Class
CXTPDockingPaneBase::m_pParentContainer Data Member

Parent container.

CXTPDockingPaneBase* m_pParentContainer;
Group

CXTPDockingPaneBase Data Members


CXTPDockingPaneBase::m_rcWindow Data Member

CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Class
CXTPDockingPaneBase::m_rcWindow Data Member

Position of the pane.

CRect m_rcWindow;
Group

CXTPDockingPaneBase Data Members


CXTPDockingPaneBase::m_szDocking Data Member

CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Class
CXTPDockingPaneBase::m_szDocking Data Member

Size of the pane.

CSize m_szDocking;
Group

CXTPDockingPaneBase Data Members


CXTPDockingPaneBase::m_type Data Member

CXTPDockingPaneBase Data Members, CXTPDockingPaneBase Class
CXTPDockingPaneBase::m_type Data Member

Type of the pane.

XTPDockingPaneType m_type;
Group

CXTPDockingPaneBase Data Members


CXTPDockingPaneBase Methods

CXTPDockingPaneBase Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase Methods
Class

CXTPDockingPaneBase Class

Legend
Method
protected
virtual
abstract
Protected Methods
Protected Methods
Protected Method | Description
Clone | This member is called to clone the pane.
CreateContainer | This member is called to create pane
DeletePane | This method is called to destroy pane
DoPropExchange | Call this member function to save/restore the settings of the pane.
InvalidatePane | This member is called when a need to redraw pane.
IsCaptionButtonVisible | Call this member to determine if the caption button is visible.
OnCaptionButtonRectChanged | This member is called when the dimensions of the caption button are changed.
OnChildContainerChanged | This member is called when a child pane collection is changed.
OnFocusChanged | This method is called to update the state of the pane.
OnParentContainerChanged | This member is called when the parent pane collection is changed.
OnSizeParent | This method is called to set position of the pane.
RemovePane | Call this member to remove a pane from collection.
SetDockingSite | Call this member to set the parent frame of the pane.
SetParentContainer | Call this method to set the parent container of the pane.
Public Methods
Public Methods
Public Method | Description
ContainPane | Call this member to determine if one pane is contained in the collection of another.
FindCaptionButton | Call this member to find the specified caption button
FindPane | Call this member to retrieve a collection of the panes with specified type.
GetCaptionButtons | Call this member to get a reference to the caption's close/ popup button
GetContainer | Call this member function to return the parent container of the pane.
GetDockingPaneManager | Call this member function to return the pane manager
GetDockingSite | Call this member function to retrieve the parent window for the pane
GetMinMaxInfo | Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.
GetPaintManager | Call this member function to return the paint manager
GetPaneHwnd | Returns the window handle for a window.
GetPaneWindowRect | The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
GetType | Call this member to determine the type of the pane.
IsEmpty | Call this member to determine if there are children panes
IsHidden | Call this member to check if the pane is hidden.
RedrawPane | Call this member to redraw the pane.


CXTPDockingPaneBase::Clone Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::Clone Method

This member is called to clone the pane.

virtual CXTPDockingPaneBase* Clone(
    CXTPDockingPaneLayout* pLayout,
    CXTPPaneToPaneMap* pMap,
    DWORD dwIgnoredOptions = 0
);
Parameters

pLayout
Points to a CXTPDockingPaneLayout object.
pMap
Points to a CXTPPaneToPaneMap object.
dwIgnoredOptions
Options that must be skipped.

Returns

A pointer to a CXTPDockingPaneBase object.

See Also

CXTPPaneToPaneMap

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::ContainPane Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::ContainPane Method

Call this member to determine if one pane is contained in the collection of another.

virtual POSITION ContainPane(
    CXTPDockingPaneBase* pPane
) const;
Parameters

pPane
Points to a CXTPDockingPaneBase object

Returns

POSITION of the pane in the collection if successful; otherwise returns NULL.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::CreateContainer Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::CreateContainer Method

This member is called to create pane

virtual void CreateContainer();
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::DeletePane Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::DeletePane Method

This method is called to destroy pane

virtual void DeletePane() = 0;
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::DoPropExchange Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::DoPropExchange Method

Call this member function to save/restore the settings of the pane.

virtual BOOL DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Points to a CXTPPropExchange object.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::FindCaptionButton Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::FindCaptionButton Method

Call this member to find the specified caption button

CXTPDockingPaneCaptionButton* FindCaptionButton(
    int nID
) const;
Parameters

nID
Identifier of the button

Returns

The CXTPDockingPaneCaptionButton object if successful; otherwise NULL.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::FindPane Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::FindPane Method

Call this member to retrieve a collection of the panes with specified type.

virtual void FindPane(
    XTPDockingPaneType type,
    CXTPDockingPaneBaseList* pList
) const;
Parameters

type
Type of the panes to find.
pList
Points to a CXTPDockingPaneBaseList object that will contain found panes.

See Also

CXTPDockingPaneBaseList

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetCaptionButtons Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::GetCaptionButtons Method

Call this member to get a reference to the caption's close/ popup button

CXTPDockingPaneCaptionButtons* GetCaptionButtons() const;
Returns

A reference to a CXTPDockingPaneCaptionButtons object

Body Source
CXTPDockingPaneCaptionButtons* GetCaptionButtons() const {
    return m_pCaptionButtons;
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetContainer Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::GetContainer Method

Call this member function to return the parent container of the pane.

CXTPDockingPaneBase* GetContainer() const;
Returns

The parent container.

Body Source
CXTPDockingPaneBase* CXTPDockingPaneBase::GetContainer() const {
    return m_pParentContainer;
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetDockingPaneManager Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::GetDockingPaneManager Method

Call this member function to return the pane manager

CXTPDockingPaneManager* GetDockingPaneManager() const;
Returns

A pointer to a CXTPDockingPaneManager object

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetDockingSite Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::GetDockingSite Method

Call this member function to retrieve the parent window for the pane

virtual CWnd* GetDockingSite() const;
Returns

A pointer to a parent window if successful; otherwise NULL

Body Source
CWnd* CXTPDockingPaneBase::GetDockingSite() const {
    return m_pDockingSite;
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetMinMaxInfo Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::GetMinMaxInfo Method

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.

virtual void GetMinMaxInfo(
    LPMINMAXINFO pMinMaxInfo
) const;
Parameters

pMinMaxInfo
Pointer to MINMAXINFO structure

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetPaintManager Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::GetPaintManager Method

Call this member function to return the paint manager

CXTPDockingPanePaintManager* GetPaintManager() const;
Returns

A pointer to a CXTPDockingPanePaintManager object

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetPaneHwnd Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::GetPaneHwnd Method

Returns the window handle for a window.

virtual HWND GetPaneHwnd() const;
Returns

Returns NULL if the HWND is not attached to a window or if it is used with a NULL HWND pointer.

Body Source
virtual HWND GetPaneHwnd() const {
    return 0;
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetPaneWindowRect Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::GetPaneWindowRect Method

The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.

CRect GetPaneWindowRect() const;
Returns

The visible rectangle of the pane.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::GetType Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::GetType Method

Call this member to determine the type of the pane.

XTPDockingPaneType GetType() const;
Returns

The type of the Pane. It can be one of the following:

  • xtpPaneTypeDockingPane Indicates the pane's style is a docking pane.
  • xtpPaneTypeTabbedContainer Indicates the pane's style is a tabbed container for pane.
  • xtpPaneTypeSplitterContainer Indicates the pane's style is a splitter container.
  • xtpPaneTypeMiniWnd Indicates the pane's style is a floating window container.
  • xtpPaneTypeClient Indicates the pane's style is a container for client area.
  • xtpPaneTypeAutoHidePanel Indicates the pane's style is an auto-hide panel container.
Body Source
XTPDockingPaneType CXTPDockingPaneBase::GetType() const {
    return m_type;
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::InvalidatePane Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::InvalidatePane Method

This member is called when a need to redraw pane.

virtual void InvalidatePane(
    BOOL bSelectionChanged
);
Parameters

bSelectionChanged
TRUE if selected pane was changed

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::IsCaptionButtonVisible Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::IsCaptionButtonVisible Method

Call this member to determine if the caption button is visible.

virtual BOOL IsCaptionButtonVisible(
    CXTPDockingPaneCaptionButton* pButton
);
Parameters

pButton
caption button pointer.

Returns

TRUE if the caption button is visible; otherwise returns FALSE.

Body Source
BOOL CXTPDockingPaneBase::IsCaptionButtonVisible(CXTPDockingPaneCaptionButton* /*pButton*/) {
    return TRUE;
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::IsEmpty Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::IsEmpty Method

Call this member to determine if there are children panes

virtual BOOL IsEmpty() const;
Returns

TRUE if no children panes; otherwise returns FALSE.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::IsHidden Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::IsHidden Method

Call this member to check if the pane is hidden.

virtual BOOL IsHidden() const;
Returns

TRUE if the pane is hidden.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::OnCaptionButtonRectChanged Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::OnCaptionButtonRectChanged Method

This member is called when the dimensions of the caption button are changed.

virtual void OnCaptionButtonRectChanged(
    CXTPDockingPaneCaptionButton* pButton
);
Parameters

pButton
caption button pointer.

Body Source
void CXTPDockingPaneBase::OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton*) {
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::OnChildContainerChanged Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::OnChildContainerChanged Method

This member is called when a child pane collection is changed.

virtual void OnChildContainerChanged(
    CXTPDockingPaneBase* pContainer
);
Parameters

pContainer
Points to a CXTPDockingPaneBase object that is changed.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::OnFocusChanged Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::OnFocusChanged Method

This method is called to update the state of the pane.

virtual void OnFocusChanged();
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::OnParentContainerChanged Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::OnParentContainerChanged Method

This member is called when the parent pane collection is changed.

virtual void OnParentContainerChanged(
    CXTPDockingPaneBase* pContainer
);
Parameters

pContainer
Points to a CXTPDockingPaneBase object that is changed.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::OnSizeParent Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::OnSizeParent Method

This method is called to set position of the pane.

virtual void OnSizeParent(
    CWnd* pParent,
    CRect rect,
    LPVOID lParam
);
Parameters

pParent
Points to a CWnd object.
rect
Rectangle of the pane to be set.
lParam
Pointer to AFX_SIZEPARENTPARAMS structure.

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::RedrawPane Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::RedrawPane Method

Call this member to redraw the pane.

virtual void RedrawPane();
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::RemovePane Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class
CXTPDockingPaneBase::RemovePane Method

Call this member to remove a pane from collection.

virtual void RemovePane(
    CXTPDockingPaneBase* pPane
);
Parameters

pPane
Points to a CXTPDockingPaneBase object

Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::SetDockingSite Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::SetDockingSite Method

Call this member to set the parent frame of the pane.

virtual void SetDockingSite(
    CWnd* pFrame
);
Parameters

pFrame
Points to a CWnd object

Body Source
void CXTPDockingPaneBase::SetDockingSite(CWnd* pFrame) {
    m_pDockingSite = pFrame;
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase::SetParentContainer Method

CXTPDockingPaneBase Methods, CXTPDockingPaneBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBase::SetParentContainer Method

Call this method to set the parent container of the pane.

virtual void SetParentContainer(
    CXTPDockingPaneBase* pContainer
);
Parameters

pContainer
Points to a CXTPDockingPaneBase object

Body Source
void CXTPDockingPaneBase::SetParentContainer(CXTPDockingPaneBase* pContainer) {
    m_pParentContainer = pContainer;
}
Group

CXTPDockingPaneBase Methods


CXTPDockingPaneBase Constructors

CXTPDockingPaneBase Class, Legend, Protected Methods
CXTPDockingPaneBase Constructors
Class

CXTPDockingPaneBase Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneBase | Protected constructor. You cannot create this class.


CXTPDockingPaneBase::CXTPDockingPaneBase Constructor

CXTPDockingPaneBase Constructors, CXTPDockingPaneBase Class
CXTPDockingPaneBase::CXTPDockingPaneBase Constructor

Protected constructor. You cannot create this class.

CXTPDockingPaneBase(
    XTPDockingPaneType type,
    CXTPDockingPaneLayout* pLayout
);
Parameters

type
Docking Pane type. Can be any of the values listed in the Remarks section.
pLayout
Points to a CXTPDockingPaneLayout object.

Remarks

Docking Pane type can be one of the following:

  • xtpPaneTypeDockingPane Indicates the pane's style is a docking pane.
  • xtpPaneTypeTabbedContainer Indicates the pane's style is a tabbed container for pane.
  • xtpPaneTypeSplitterContainer Indicates the pane's style is a splitter container.
  • xtpPaneTypeMiniWnd Indicates the pane's style is a floating window container.
  • xtpPaneTypeClient Indicates the pane's style is a container for client area.
  • xtpPaneTypeAutoHidePanel Indicates the pane's style is an auto-hide panel container.
Group

CXTPDockingPaneBase Constructors


CXTPDockingPaneBase Destructors

CXTPDockingPaneBase Class, Legend, Protected Methods
CXTPDockingPaneBase Destructors
Class

CXTPDockingPaneBase Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPaneBase | Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.


CXTPDockingPaneBase::~CXTPDockingPaneBase Destructor

CXTPDockingPaneBase Destructors, CXTPDockingPaneBase Class
CXTPDockingPaneBase::~CXTPDockingPaneBase Destructor

Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.

virtual ~CXTPDockingPaneBase();
Group

CXTPDockingPaneBase Destructors


CXTPDockingPaneBaseContainer Class

XTPDockingPaneBaseContainer.h, Classes, Legend, Members, Topics, CXTPDockingPaneBaseContainer Data Members, CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Constructors, CXTPDockingPaneBaseContainer Destructors, CXTPDockingPaneBaseContainer Constructors, CXTPDockingPaneBaseContainer Data Members, CXTPDockingPaneBaseContainer Destructors, CXTPDockingPaneBaseContainer Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer Class

CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class. It represents the parent class for a all virtual containers.

Class Hierarchy

class CXTPDockingPaneBaseContainer : public CXTPDockingPaneBase;
File

XTPDockingPaneBaseContainer.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneBaseContainer Constructors
CXTPDockingPaneBaseContainer Constructors | Description
CXTPDockingPaneBaseContainer | Protected constructor. You cannot create this class.
CXTPDockingPaneBaseContainer Data Members
CXTPDockingPaneBaseContainer Data Members | Description
m_lstPanes | Child panes collection
CXTPDockingPaneBaseContainer Destructors
CXTPDockingPaneBaseContainer Destructors | Description
~CXTPDockingPaneBaseContainer | Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
CXTPDockingPaneBaseContainer Methods
CXTPDockingPaneBaseContainer Methods | Description
ContainPane | Call this member to determine if one pane is contained in the collection of another.
FindPane | Call this member to find all panes of a specific XTPDockingPaneType within the container.
GetFirstPane | This method retrieves the first pane in the container
GetHeadPosition | This method retrieves the position of the first pane of this container
GetLastPane | This method retrieves the last pane in the container
GetNext | Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container. You can use GetNext in a forward iteration loop if you establish the initial position with a call to GetHeadPosition
GetPanes | Call this member to return collection of the child panes.
IsEmpty | Call this member to determine if there are children panes
OnAction | This method is called if some action occur


CXTPDockingPaneBaseContainer Data Members

CXTPDockingPaneBaseContainer Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer Data Members
Class

CXTPDockingPaneBaseContainer Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_lstPanes | Child panes collection


CXTPDockingPaneBaseContainer::m_lstPanes Data Member

CXTPDockingPaneBaseContainer Data Members, CXTPDockingPaneBaseContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::m_lstPanes Data Member

Child panes collection

CXTPDockingPaneBaseList m_lstPanes;
Group

CXTPDockingPaneBaseContainer Data Members


CXTPDockingPaneBaseContainer Methods

CXTPDockingPaneBaseContainer Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer Methods
Class

CXTPDockingPaneBaseContainer Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
IsEmpty | Call this member to determine if there are children panes
Public Methods
Public Methods
Public Method | Description
ContainPane | Call this member to determine if one pane is contained in the collection of another.
FindPane | Call this member to find all panes of a specific XTPDockingPaneType within the container.
GetFirstPane | This method retrieves the first pane in the container
GetHeadPosition | This method retrieves the position of the first pane of this container
GetLastPane | This method retrieves the last pane in the container
GetNext | Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container. You can use GetNext in a forward iteration loop if you establish the initial position with a call to GetHeadPosition
GetPanes | Call this member to return collection of the child panes.
OnAction | This method is called if some action occur


CXTPDockingPaneBaseContainer::ContainPane Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::ContainPane Method

Call this member to determine if one pane is contained in the collection of another.

virtual POSITION ContainPane(
    CXTPDockingPaneBase* pPane
) const;
Parameters

pPane
Points to a CXTPDockingPaneBase object

Returns

POSITION of the pane in the collection if successful; otherwise returns NULL.

Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer::FindPane Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::FindPane Method

Call this member to find all panes of a specific XTPDockingPaneType within the container.

virtual void FindPane(
    XTPDockingPaneType type,
    CXTPDockingPaneBaseList* pList
) const;
Parameters

type
Type of docking pane to search for within container.
pList
An array of type CXTPDockingPaneBaseList that will contain a list of all panes of the specified type that are in the tabbed container. This points to a CXTPDockingPaneBaseList object that will contain found panes.

Remarks

pList is an external list that you must create and pass in as a parameter. See example below:

Example

This will get the count of panes inside container:

CXTPDockingPaneBaseList lst;

m_pTopContainer->FindPane(xtpPaneTypeTabbedContainer, &lst);
int nCount = (int)lst.GetCount();
Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer::GetFirstPane Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::GetFirstPane Method

This method retrieves the first pane in the container

CXTPDockingPaneBase* GetFirstPane() const;
Returns

First pane in the container

See Also

GetLastPane, GetHeadPosition

Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer::GetHeadPosition Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::GetHeadPosition Method

This method retrieves the position of the first pane of this container

POSITION GetHeadPosition() const;
Returns

A POSITION value that can be used for iteration or object pointer retrieval; it is NULL if the list is empty.

See Also

GetNext

Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer::GetLastPane Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::GetLastPane Method

This method retrieves the last pane in the container

CXTPDockingPaneBase* GetLastPane() const;
Returns

Last pane in the container

See Also

GetFirstPane, GetHeadPosition

Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer::GetNext Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::GetNext Method

Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container. You can use GetNext in a forward iteration loop if you establish the initial position with a call to GetHeadPosition

CXTPDockingPaneBase* GetNext(
    POSITION& pos
) const;
Parameters

pos
Specifies a reference to a POSITION value returned by a previous GetNext, GetHeadPosition, or other method call

Returns

Pane identified by rPosition

See Also

GetHeadPosition

Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer::GetPanes Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::GetPanes Method

Call this member to return collection of the child panes.

CXTPDockingPaneBaseList& GetPanes();
Returns

A reference to the child panes collection.

Body Source
CXTPDockingPaneBaseList& CXTPDockingPaneBaseContainer::GetPanes() {
    return m_lstPanes;
}
Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer::IsEmpty Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::IsEmpty Method

Call this member to determine if there are children panes

virtual BOOL IsEmpty() const;
Returns

TRUE if no children panes; otherwise returns FALSE.

Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer::OnAction Method

CXTPDockingPaneBaseContainer Methods, CXTPDockingPaneBaseContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::OnAction Method

This method is called if some action occur

BOOL OnAction(
    XTPDockingPaneAction action
);
Parameters

action
Docking Pane action.

Returns

TRUE if action was canceled

Group

CXTPDockingPaneBaseContainer Methods


CXTPDockingPaneBaseContainer Constructors

CXTPDockingPaneBaseContainer Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer Constructors
Class

CXTPDockingPaneBaseContainer Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneBaseContainer | Protected constructor. You cannot create this class.


CXTPDockingPaneBaseContainer::CXTPDockingPaneBaseContainer Constructor

CXTPDockingPaneBaseContainer Constructors, CXTPDockingPaneBaseContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::CXTPDockingPaneBaseContainer Constructor

Protected constructor. You cannot create this class.

CXTPDockingPaneBaseContainer(
    XTPDockingPaneType type,
    CXTPDockingPaneLayout* pLayout
);
Parameters

type
Docking Pane type. Can be any of the values listed in the Remarks section.
pLayout
Points to a CXTPDockingPaneLayout object.

Remarks

Docking Pane type can be one of the following:

  • xtpPaneTypeDockingPane Indicates the pane's style is a docking pane.
  • xtpPaneTypeTabbedContainer Indicates the pane's style is a tabbed container for pane.
  • xtpPaneTypeSplitterContainer Indicates the pane's style is a splitter container.
  • xtpPaneTypeMiniWnd Indicates the pane's style is a floating window container.
  • xtpPaneTypeClient Indicates the pane's style is a container for client area.
  • xtpPaneTypeAutoHidePanel Indicates the pane's style is an auto-hide panel container.
Group

CXTPDockingPaneBaseContainer Constructors


CXTPDockingPaneBaseContainer Destructors

CXTPDockingPaneBaseContainer Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer Destructors
Class

CXTPDockingPaneBaseContainer Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPaneBaseContainer | Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.


CXTPDockingPaneBaseContainer::~CXTPDockingPaneBaseContainer Destructor

CXTPDockingPaneBaseContainer Destructors, CXTPDockingPaneBaseContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneBaseContainer::~CXTPDockingPaneBaseContainer Destructor

Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.

virtual ~CXTPDockingPaneBaseContainer();
Group

CXTPDockingPaneBaseContainer Destructors


CXTPDockingPaneCaptionButton Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneCaptionButton Data Members, CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Constructors, CXTPDockingPaneCaptionButton Constructors, CXTPDockingPaneCaptionButton Data Members, CXTPDockingPaneCaptionButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton Class

CXTPDockingPaneCaptionButton is a stand alone internal class.

Class Hierarchy

class CXTPDockingPaneCaptionButton;
File

XTPDockingPanePaintManager.h

Group

Classes

Legend
Data Member
protected
Method
CXTPDockingPaneCaptionButton Constructors
CXTPDockingPaneCaptionButton Constructors | Description
CXTPDockingPaneCaptionButton | Constructs a CXTPDockingPaneCaptionButton object
CXTPDockingPaneCaptionButton Data Members
CXTPDockingPaneCaptionButton Data Members | Description
m_bPressed | TRUE if button is pressed by user.
m_bSelected | TRUE if user move mouse cursor inside button rectangle
m_dwState | XTPDockingPanePinState of caption button.
m_nID | Identifier of the button.
m_pPane | Parent pane
m_rcButton | Bounding rectangle of the button
CXTPDockingPaneCaptionButton Methods
CXTPDockingPaneCaptionButton Methods | Description
CheckForMouseOver | Call this member to refresh styles of the button.
Click | Call this method to click button.
DrawMaximizeRestoreButton | Call this member to draw the maximizerestore button.
DrawPinnButton | Call this member to draw a pin button.
GetID | Retrieves button identifier
GetPane | Call this member to retrieve the pane that the pin button controls.
GetRect | Call this member to get the bounding rectangle
GetState | Call this member to determine the state of the caption button. This will tell you if the pin caption button is visible or if it is pushed.
InvalidateRect | Call this method to redraw button
IsEnabled | Determines if button is enabled
IsPressed | Call this member to determine if the button is pushed.
IsSelected | Call this member to determine if the button mouse hover the button
IsVisible | Call this member to determine if the pin caption button is visible.
PtInRect | Call this member to determine if the point belongs to button.
SetRect | Call this member to set the button's rectangle.
SetState | Call this member to set the state of the pin caption button.


CXTPDockingPaneCaptionButton Data Members

CXTPDockingPaneCaptionButton Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton Data Members
Class

CXTPDockingPaneCaptionButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bPressed | TRUE if button is pressed by user.
m_bSelected | TRUE if user move mouse cursor inside button rectangle
m_dwState | XTPDockingPanePinState of caption button.
m_nID | Identifier of the button.
m_pPane | Parent pane
m_rcButton | Bounding rectangle of the button


CXTPDockingPaneCaptionButton::m_bPressed Data Member

CXTPDockingPaneCaptionButton Data Members, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::m_bPressed Data Member

TRUE if button is pressed by user.

BOOL m_bPressed;
Group

CXTPDockingPaneCaptionButton Data Members


CXTPDockingPaneCaptionButton::m_bSelected Data Member

CXTPDockingPaneCaptionButton Data Members, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::m_bSelected Data Member

TRUE if user move mouse cursor inside button rectangle

BOOL m_bSelected;
Group

CXTPDockingPaneCaptionButton Data Members


CXTPDockingPaneCaptionButton::m_dwState Data Member

CXTPDockingPaneCaptionButton Data Members, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::m_dwState Data Member

XTPDockingPanePinState of caption button.

DWORD m_dwState;
Group

CXTPDockingPaneCaptionButton Data Members


CXTPDockingPaneCaptionButton::m_nID Data Member

CXTPDockingPaneCaptionButton Data Members, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::m_nID Data Member

Identifier of the button.

int m_nID;
Group

CXTPDockingPaneCaptionButton Data Members


CXTPDockingPaneCaptionButton::m_pPane Data Member

CXTPDockingPaneCaptionButton Data Members, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::m_pPane Data Member

Parent pane

CXTPDockingPaneBase* m_pPane;
Group

CXTPDockingPaneCaptionButton Data Members


CXTPDockingPaneCaptionButton::m_rcButton Data Member

CXTPDockingPaneCaptionButton Data Members, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::m_rcButton Data Member

Bounding rectangle of the button

CRect m_rcButton;
Group

CXTPDockingPaneCaptionButton Data Members


CXTPDockingPaneCaptionButton Methods

CXTPDockingPaneCaptionButton Class, Legend, Public Methods
CXTPDockingPaneCaptionButton Methods
Class

CXTPDockingPaneCaptionButton Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
CheckForMouseOver | Call this member to refresh styles of the button.
Click | Call this method to click button.
DrawMaximizeRestoreButton | Call this member to draw the maximizerestore button.
DrawPinnButton | Call this member to draw a pin button.
GetID | Retrieves button identifier
GetPane | Call this member to retrieve the pane that the pin button controls.
GetRect | Call this member to get the bounding rectangle
GetState | Call this member to determine the state of the caption button. This will tell you if the pin caption button is visible or if it is pushed.
InvalidateRect | Call this method to redraw button
IsEnabled | Determines if button is enabled
IsPressed | Call this member to determine if the button is pushed.
IsSelected | Call this member to determine if the button mouse hover the button
IsVisible | Call this member to determine if the pin caption button is visible.
PtInRect | Call this member to determine if the point belongs to button.
SetRect | Call this member to set the button's rectangle.
SetState | Call this member to set the state of the pin caption button.


CXTPDockingPaneCaptionButton::CheckForMouseOver Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::CheckForMouseOver Method

Call this member to refresh styles of the button.

BOOL CheckForMouseOver(
    CPoint pt
);
Parameters

pt
Mouse cursor pointer.

Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::Click Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::Click Method

Call this method to click button.

DWORD Click(
    CWnd* pWnd,
    CPoint pt,
    BOOL bClient = TRUE
);
Parameters

pWnd
Parent window of button.
pt
Initial mouse position.
bClient
TRUE if pt belongs client area of window.

Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::DrawMaximizeRestoreButton Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::DrawMaximizeRestoreButton Method

Call this member to draw the maximizerestore button.

static void DrawMaximizeRestoreButton(
    CDC* pDC,
    CPoint pt,
    BOOL bMaximize,
    COLORREF clr
);
Parameters

pDC
Pointer to the device context in which to draw.
pt
Center point.
bMaximize
TRUE if the button is to be drawn maximized, FALSE to draw restore button.
clr
Color of button.

Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::DrawPinnButton Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::DrawPinnButton Method

Call this member to draw a pin button.

static void DrawPinnButton(
    CDC* pDC,
    CPoint pt,
    BOOL bPinned
);
Parameters

pDC
Pointer to the device context in which to draw.
pt
Center point.
bPinned
TRUE if the button is pinned.

Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::GetID Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::GetID Method

Retrieves button identifier

int GetID() const;
Returns

Button identifier. Standard values are

  • XTP_IDS_DOCKINGPANE_CLOSE Close button
  • XTP_IDS_DOCKINGPANE_AUTOHIDE Auto-hide button
Body Source
int GetID() const {
    return m_nID;
}
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::GetPane Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::GetPane Method

Call this member to retrieve the pane that the pin button controls.

CXTPDockingPaneBase* GetPane() const;
Returns

Pane that the pin button controls.

Body Source
CXTPDockingPaneBase* GetPane() const {
    return m_pPane;
}
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::GetRect Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::GetRect Method

Call this member to get the bounding rectangle

CRect GetRect();
Returns

A CRect object

Body Source
CRect GetRect() { return m_rcButton;}
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::GetState Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::GetState Method

Call this member to determine the state of the caption button. This will tell you if the pin caption button is visible or if it is pushed.

DWORD GetState() const;
Returns

1 if the the button is visible, 2 if it is pushed, 3 if it is both visible and pushed.

See Also

XTPDockingPanePinState

Body Source
DWORD GetState() const {
    return m_dwState;
}
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::InvalidateRect Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::InvalidateRect Method

Call this method to redraw button

void InvalidateRect();
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::IsEnabled Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::IsEnabled Method

Determines if button is enabled

BOOL IsEnabled() const;
Returns

TRUE if button is enabled

Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::IsPressed Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::IsPressed Method

Call this member to determine if the button is pushed.

BOOL IsPressed() const;
Returns

TRUE is the button is pushed, FALSE otherwise.

Body Source
BOOL IsPressed() const {
    return m_bPressed;
}
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::IsSelected Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::IsSelected Method

Call this member to determine if the button mouse hover the button

BOOL IsSelected() const;
Returns

TRUE if mouse hover the button.

Body Source
BOOL IsSelected() const {
    return m_bSelected;
}
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::IsVisible Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::IsVisible Method

Call this member to determine if the pin caption button is visible.

BOOL IsVisible();
Returns

TRUE if the pin button is visible, FALSE otherwise.

Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::PtInRect Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::PtInRect Method

Call this member to determine if the point belongs to button.

BOOL PtInRect(
    POINT pt
) const;
Parameters

pt
Point to test.

Returns

TRUE if point belongs to the button; otherwise returns FALSE

Body Source
BOOL PtInRect (POINT pt) const {return m_rcButton.PtInRect (pt) != 0; }
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::SetRect Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::SetRect Method

Call this member to set the button's rectangle.

void SetRect(
    CRect rc
);
Parameters

rc
Button's rectangle.

Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton::SetState Method

CXTPDockingPaneCaptionButton Methods, CXTPDockingPaneCaptionButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::SetState Method

Call this member to set the state of the pin caption button.

void SetState(
    DWORD dwState
);
Parameters

dwState
XTPDockingPanePinState of pin button.

See Also

XTPDockingPanePinState

Body Source
void SetState(DWORD dwState) {
    m_dwState = dwState;
}
Group

CXTPDockingPaneCaptionButton Methods


CXTPDockingPaneCaptionButton Constructors

CXTPDockingPaneCaptionButton Class, Legend, Public Methods
CXTPDockingPaneCaptionButton Constructors
Class

CXTPDockingPaneCaptionButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneCaptionButton | Constructs a CXTPDockingPaneCaptionButton object


CXTPDockingPaneCaptionButton::CXTPDockingPaneCaptionButton Constructor

CXTPDockingPaneCaptionButton Constructors, CXTPDockingPaneCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButton::CXTPDockingPaneCaptionButton Constructor

Constructs a CXTPDockingPaneCaptionButton object

CXTPDockingPaneCaptionButton(
    int nID,
    CXTPDockingPaneBase* pPane
);
Parameters

nID
If of the caption button.
pPane
Pane that the caption button controls.

Body Source
CXTPDockingPaneCaptionButton (int nID, CXTPDockingPaneBase* pPane)
{
    m_nID = nID; m_pPane = pPane;
    m_bPressed = m_bSelected = FALSE;
    m_dwState = 0;
    m_rcButton.SetRectEmpty();
}
Group

CXTPDockingPaneCaptionButton Constructors


CXTPDockingPaneCaptionButtons Class

XTPDockingPaneBase.h, Classes, Legend, Members, Topics, CXTPDockingPaneCaptionButtons Methods, CXTPDockingPaneCaptionButtons Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButtons Class

CXTPDockingPaneCaptionButtons is CArray derived class used for manipulate Caption Buttons.

Class Hierarchy

class CXTPDockingPaneCaptionButtons : public CArray<CXTPDockingPaneCaptionButton*, CXTPDockingPaneCaptionButton*>;
File

XTPDockingPaneBase.h

Group

Classes

Legend
Method
CXTPDockingPaneCaptionButtons Methods
CXTPDockingPaneCaptionButtons Methods | Description
CheckForMouseOver | Call this member to determine if the mouse pointer is positioned over one of the buttons in the pane caption.


CXTPDockingPaneCaptionButtons Methods

CXTPDockingPaneCaptionButtons Class, Legend, Public Methods
CXTPDockingPaneCaptionButtons Methods
Class

CXTPDockingPaneCaptionButtons Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
CheckForMouseOver | Call this member to determine if the mouse pointer is positioned over one of the buttons in the pane caption.


CXTPDockingPaneCaptionButtons::CheckForMouseOver Method

CXTPDockingPaneCaptionButtons Methods, CXTPDockingPaneCaptionButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneCaptionButtons::CheckForMouseOver Method

Call this member to determine if the mouse pointer is positioned over one of the buttons in the pane caption.

BOOL CheckForMouseOver(
    CPoint pt
);
Parameters

pt
CPoint object containing coordinates of mouse pointer.

Returns

TRUE if the mouse pointer is positioned over a caption button, FALSE otherwise.

Group

CXTPDockingPaneCaptionButtons Methods


CXTPDockingPaneContext Class

XTPDockingPaneContext.h, Classes, Legend, Members, Topics, CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Methods, CXTPDockingPaneContext Constructors, CXTPDockingPaneContext Destructors, CXTPDockingPaneContext Constructors, CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Destructors, CXTPDockingPaneContext Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext Class

CXTPDockingPaneContext is a stand alone class. It is used internally for docking and sizing panes.

Class Hierarchy

class CXTPDockingPaneContext;
File

XTPDockingPaneContext.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneContext Constructors
CXTPDockingPaneContext Constructors | Description
CXTPDockingPaneContext | Constructs a CXTPDockingPaneContext object
CXTPDockingPaneContext Data Members
CXTPDockingPaneContext Data Members | Description
m_bDragKeyboard | TRUE if keyboard used to drag pane
m_bUseAlphaContext | TRUE to use alpha context.
m_bUseDockingStickers | TRUE to use docking stickers.
m_lstStickers | List of the stickers
m_pfnSetLayeredWindowAttributes | Pointer to SetLayeredWindowAttributes method.
m_pLastStickerPane | Last Sticker Pane.
m_pManager | Parent pane manager.
m_pPane | Pointer to the associated pane.
m_pStickerPane | Sticker Pane.
m_ptLast | Holds the last selection point.
m_ptSticky | Position of the sticky control.
m_rectDragFrame | Area occupied by the drag frame.
m_rectDragFrameScreen | Screen drag frame
m_rectStickerPane | Area occupied by the sticker pane.
m_wndAttachedTab | Attached tab control.
m_wndContext | Alpha context control.
CXTPDockingPaneContext Destructors
CXTPDockingPaneContext Destructors | Description
~CXTPDockingPaneContext | Destroys a CXTPDockingPaneContext object, handles cleanup and deallocation.
CXTPDockingPaneContext Methods
CXTPDockingPaneContext Methods | Description
AdjustCursor | Moves cursor to available work area
AdjustRectangle | Call this member to adjust the rectangle.
CancelLoop | This member function is called when a loop is canceled.
CreateContextWindow | Call this member function to create a context menu.
CreateNewSticker | Creates new sticker window
DestroyDockingStickers | Call this member to remove the docking stickers.
Drag | Call this member to drag a pane.
DrawFocusRect | This member function is called to draw the focus rectangle.
InitLoop | Call this member function to initialize a loop.
Move | This method is called then user move mouse cursor in track mode.
OnSizingFloatingFrame | This method is called inside WM_SIZING handler of mini frames to update sticky position of frame
Track | This method is called to track the size of the pane.
UpdateDockingStickers | Call this member function to refresh the docking stickers.


CXTPDockingPaneContext Data Members

CXTPDockingPaneContext Class, Legend, Protected Data Members
CXTPDockingPaneContext Data Members
Class

CXTPDockingPaneContext Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bDragKeyboard | TRUE if keyboard used to drag pane
m_bUseAlphaContext | TRUE to use alpha context.
m_bUseDockingStickers | TRUE to use docking stickers.
m_lstStickers | List of the stickers
m_pfnSetLayeredWindowAttributes | Pointer to SetLayeredWindowAttributes method.
m_pLastStickerPane | Last Sticker Pane.
m_pManager | Parent pane manager.
m_pPane | Pointer to the associated pane.
m_pStickerPane | Sticker Pane.
m_ptLast | Holds the last selection point.
m_ptSticky | Position of the sticky control.
m_rectDragFrame | Area occupied by the drag frame.
m_rectDragFrameScreen | Screen drag frame
m_rectStickerPane | Area occupied by the sticker pane.
m_wndAttachedTab | Attached tab control.
m_wndContext | Alpha context control.


CXTPDockingPaneContext::m_bDragKeyboard Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_bDragKeyboard Data Member

TRUE if keyboard used to drag pane

BOOL m_bDragKeyboard;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_bUseAlphaContext Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_bUseAlphaContext Data Member

TRUE to use alpha context.

BOOL m_bUseAlphaContext;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_bUseDockingStickers Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_bUseDockingStickers Data Member

TRUE to use docking stickers.

BOOL m_bUseDockingStickers;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_lstStickers Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_lstStickers Data Member

List of the stickers

CList<CXTPDockingPaneContextStickerWnd*, CXTPDockingPaneContextStickerWnd*> m_lstStickers;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_pfnSetLayeredWindowAttributes Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_pfnSetLayeredWindowAttributes Data Member

Pointer to SetLayeredWindowAttributes method.

PVOID m_pfnSetLayeredWindowAttributes;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_pLastStickerPane Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_pLastStickerPane Data Member

Last Sticker Pane.

CXTPDockingPaneBase* m_pLastStickerPane;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_pManager Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_pManager Data Member

Parent pane manager.

CXTPDockingPaneManager* m_pManager;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_pPane Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_pPane Data Member

Pointer to the associated pane.

CXTPDockingPaneBase* m_pPane;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_pStickerPane Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_pStickerPane Data Member

Sticker Pane.

CXTPDockingPaneBase* m_pStickerPane;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_ptLast Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_ptLast Data Member

Holds the last selection point.

CPoint m_ptLast;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_ptSticky Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_ptSticky Data Member

Position of the sticky control.

CPoint m_ptSticky;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_rectDragFrame Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_rectDragFrame Data Member

Area occupied by the drag frame.

CRect m_rectDragFrame;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_rectDragFrameScreen Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_rectDragFrameScreen Data Member

Screen drag frame

CRect m_rectDragFrameScreen;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_rectStickerPane Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_rectStickerPane Data Member

Area occupied by the sticker pane.

CRect m_rectStickerPane;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_wndAttachedTab Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_wndAttachedTab Data Member

Attached tab control.

CXTPDockingPaneContextAlphaWnd m_wndAttachedTab;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext::m_wndContext Data Member

CXTPDockingPaneContext Data Members, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::m_wndContext Data Member

Alpha context control.

CXTPDockingPaneContextAlphaWnd m_wndContext;
Group

CXTPDockingPaneContext Data Members


CXTPDockingPaneContext Methods

CXTPDockingPaneContext Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext Methods
Class

CXTPDockingPaneContext Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AdjustCursor | Moves cursor to available work area
AdjustRectangle | Call this member to adjust the rectangle.
CancelLoop | This member function is called when a loop is canceled.
CreateContextWindow | Call this member function to create a context menu.
CreateNewSticker | Creates new sticker window
DestroyDockingStickers | Call this member to remove the docking stickers.
DrawFocusRect | This member function is called to draw the focus rectangle.
InitLoop | Call this member function to initialize a loop.
Move | This method is called then user move mouse cursor in track mode.
Track | This method is called to track the size of the pane.
UpdateDockingStickers | Call this member function to refresh the docking stickers.
Public Methods
Public Methods
Public Method | Description
Drag | Call this member to drag a pane.
OnSizingFloatingFrame | This method is called inside WM_SIZING handler of mini frames to update sticky position of frame


CXTPDockingPaneContext::AdjustCursor Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::AdjustCursor Method

Moves cursor to available work area

static void AdjustCursor(
    CPoint& pt
);
Parameters

pt
Pointer to mouse cursor

Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::AdjustRectangle Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::AdjustRectangle Method

Call this member to adjust the rectangle.

static void AdjustRectangle(
    CRect& rect,
    CPoint pt
);
Parameters

rect
Rectangle to be changed.
pt
Position of the rectangle to be changed.

Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::CancelLoop Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::CancelLoop Method

This member function is called when a loop is canceled.

virtual void CancelLoop();
Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::CreateContextWindow Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::CreateContextWindow Method

Call this member function to create a context menu.

void CreateContextWindow(
    CXTPDockingPaneContextAlphaWnd* pWnd
);
Parameters

pWnd
A pointer to a CXTPDockingPaneContextAlphaWnd object.

Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::CreateNewSticker Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::CreateNewSticker Method

Creates new sticker window

CXTPDockingPaneContextStickerWnd* CreateNewSticker(
    CRect rc,
    XTPDockingPaneStickerType typeSticker
);
Parameters

rc
Boundary rectangle of the sticker
typeSticker
Type of the sticker to create

Returns

New Sticker window

Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::DestroyDockingStickers Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::DestroyDockingStickers Method

Call this member to remove the docking stickers.

void DestroyDockingStickers();
Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::Drag Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::Drag Method

Call this member to drag a pane.

virtual void Drag(
    CXTPDockingPaneBase* pPane,
    CPoint point
);
Parameters

pPane
Points to a CXTPDockingPaneBase object
point
Initial mouse position.

Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::DrawFocusRect Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::DrawFocusRect Method

This member function is called to draw the focus rectangle.

virtual void DrawFocusRect(
    BOOL bRemoveRect = FALSE
);
Parameters

bRemoveRect
TRUE to delete focus rect.

Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::InitLoop Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::InitLoop Method

Call this member function to initialize a loop.

virtual void InitLoop();
Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::Move Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::Move Method

This method is called then user move mouse cursor in track mode.

virtual void Move(
    CPoint pt
);
Parameters

pt
New mouse cursor position

Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::OnSizingFloatingFrame Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::OnSizingFloatingFrame Method

This method is called inside WM_SIZING handler of mini frames to update sticky position of frame

virtual void OnSizingFloatingFrame(
    CXTPDockingPaneMiniWnd* pWnd,
    UINT nSide,
    LPRECT lpRect
);
Parameters

pWnd
Mini frame pointer
nSide
Side was dragged by user
lpRect
Rectangle of frame

Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::Track Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::Track Method

This method is called to track the size of the pane.

virtual void Track();
Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext::UpdateDockingStickers Method

CXTPDockingPaneContext Methods, CXTPDockingPaneContext Class
CXTPDockingPaneContext::UpdateDockingStickers Method

Call this member function to refresh the docking stickers.

void UpdateDockingStickers();
Group

CXTPDockingPaneContext Methods


CXTPDockingPaneContext Constructors

CXTPDockingPaneContext Class, Legend, Public Methods
CXTPDockingPaneContext Constructors
Class

CXTPDockingPaneContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneContext | Constructs a CXTPDockingPaneContext object


CXTPDockingPaneContext::CXTPDockingPaneContext Constructor

CXTPDockingPaneContext Constructors, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::CXTPDockingPaneContext Constructor

Constructs a CXTPDockingPaneContext object

CXTPDockingPaneContext();
Group

CXTPDockingPaneContext Constructors


CXTPDockingPaneContext Destructors

CXTPDockingPaneContext Class, Legend, Public Methods
CXTPDockingPaneContext Destructors
Class

CXTPDockingPaneContext Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockingPaneContext | Destroys a CXTPDockingPaneContext object, handles cleanup and deallocation.


CXTPDockingPaneContext::~CXTPDockingPaneContext Destructor

CXTPDockingPaneContext Destructors, CXTPDockingPaneContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContext::~CXTPDockingPaneContext Destructor

Destroys a CXTPDockingPaneContext object, handles cleanup and deallocation.

virtual ~CXTPDockingPaneContext();
Group

CXTPDockingPaneContext Destructors


CXTPDockingPaneContextAlphaWnd Class

XTPDockingPaneContext.h, Classes, Legend, Members, Topics, CXTPDockingPaneContextAlphaWnd Constructors, CXTPDockingPaneContextAlphaWnd Destructors, CXTPDockingPaneContextAlphaWnd Constructors, CXTPDockingPaneContextAlphaWnd Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextAlphaWnd Class

CXTPDockingPaneContextAlphaWnd is CWnd derived class represents alpha context helper window

Class Hierarchy

class CXTPDockingPaneContextAlphaWnd : public CWnd;
File

XTPDockingPaneContext.h

Group

Classes

Legend
Constructor
virtual
CXTPDockingPaneContextAlphaWnd Constructors
CXTPDockingPaneContextAlphaWnd Constructors | Description
CXTPDockingPaneContextAlphaWnd | Constructs a CXTPDockingPaneContextAlphaWnd object.
CXTPDockingPaneContextAlphaWnd Destructors
CXTPDockingPaneContextAlphaWnd Destructors | Description
~CXTPDockingPaneContextAlphaWnd | Destroys a CXTPDockingPaneContextAlphaWnd object, handles cleanup and deallocation.


CXTPDockingPaneContextAlphaWnd Constructors

CXTPDockingPaneContextAlphaWnd Class, Legend, Public Methods
CXTPDockingPaneContextAlphaWnd Constructors
Class

CXTPDockingPaneContextAlphaWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneContextAlphaWnd | Constructs a CXTPDockingPaneContextAlphaWnd object.


CXTPDockingPaneContextAlphaWnd::CXTPDockingPaneContextAlphaWnd Constructor

CXTPDockingPaneContextAlphaWnd Constructors, CXTPDockingPaneContextAlphaWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextAlphaWnd::CXTPDockingPaneContextAlphaWnd Constructor

Constructs a CXTPDockingPaneContextAlphaWnd object.

CXTPDockingPaneContextAlphaWnd();
Group

CXTPDockingPaneContextAlphaWnd Constructors


CXTPDockingPaneContextAlphaWnd Destructors

CXTPDockingPaneContextAlphaWnd Class, Legend, Public Methods
CXTPDockingPaneContextAlphaWnd Destructors
Class

CXTPDockingPaneContextAlphaWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockingPaneContextAlphaWnd | Destroys a CXTPDockingPaneContextAlphaWnd object, handles cleanup and deallocation.


CXTPDockingPaneContextAlphaWnd::~CXTPDockingPaneContextAlphaWnd Destructor

CXTPDockingPaneContextAlphaWnd Destructors, CXTPDockingPaneContextAlphaWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextAlphaWnd::~CXTPDockingPaneContextAlphaWnd Destructor

Destroys a CXTPDockingPaneContextAlphaWnd object, handles cleanup and deallocation.

virtual ~CXTPDockingPaneContextAlphaWnd();
Group

CXTPDockingPaneContextAlphaWnd Destructors


CXTPDockingPaneContextStickerWnd Class

XTPDockingPaneContext.h, Classes, Legend, Members, Topics, CXTPDockingPaneContextStickerWnd Data Members, CXTPDockingPaneContextStickerWnd Methods, CXTPDockingPaneContextStickerWnd Constructors, CXTPDockingPaneContextStickerWnd Destructors, CXTPDockingPaneContextStickerWnd Constructors, CXTPDockingPaneContextStickerWnd Data Members, CXTPDockingPaneContextStickerWnd Destructors, CXTPDockingPaneContextStickerWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd Class

CXTPDockingPaneContextStickerWnd is CWnd derived class represents sticker window.

Class Hierarchy

class CXTPDockingPaneContextStickerWnd : public CWnd;
File

XTPDockingPaneContext.h

Group

Classes

Legend
Data Member
Method
virtual
CXTPDockingPaneContextStickerWnd Constructors
CXTPDockingPaneContextStickerWnd Constructors | Description
CXTPDockingPaneContextStickerWnd | Constructs a CXTPDockingPaneContextStickerWnd object.
CXTPDockingPaneContextStickerWnd Data Members
CXTPDockingPaneContextStickerWnd Data Members | Description
m_pContext | Pointer to docking pane context.
m_selectedSticker | Selected sticker part.
m_typeSticker | Type of the sticker.
CXTPDockingPaneContextStickerWnd Destructors
CXTPDockingPaneContextStickerWnd Destructors | Description
~CXTPDockingPaneContextStickerWnd | Destroys a CXTPDockingPaneContextStickerWnd object, handles cleanup and deallocation.
CXTPDockingPaneContextStickerWnd Methods
CXTPDockingPaneContextStickerWnd Methods | Description
OnDraw | This method is called to draw sticker


CXTPDockingPaneContextStickerWnd Data Members

CXTPDockingPaneContextStickerWnd Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd Data Members
Class

CXTPDockingPaneContextStickerWnd Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_pContext | Pointer to docking pane context.
m_selectedSticker | Selected sticker part.
m_typeSticker | Type of the sticker.


CXTPDockingPaneContextStickerWnd::m_pContext Data Member

CXTPDockingPaneContextStickerWnd Data Members, CXTPDockingPaneContextStickerWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd::m_pContext Data Member

Pointer to docking pane context.

CXTPDockingPaneContext* m_pContext;
Group

CXTPDockingPaneContextStickerWnd Data Members


CXTPDockingPaneContextStickerWnd::m_selectedSticker Data Member

CXTPDockingPaneContextStickerWnd Data Members, CXTPDockingPaneContextStickerWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd::m_selectedSticker Data Member

Selected sticker part.

XTPDockingPaneStickerType m_selectedSticker;
Group

CXTPDockingPaneContextStickerWnd Data Members


CXTPDockingPaneContextStickerWnd::m_typeSticker Data Member

CXTPDockingPaneContextStickerWnd Data Members, CXTPDockingPaneContextStickerWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd::m_typeSticker Data Member

Type of the sticker.

XTPDockingPaneStickerType m_typeSticker;
Group

CXTPDockingPaneContextStickerWnd Data Members


CXTPDockingPaneContextStickerWnd Methods

CXTPDockingPaneContextStickerWnd Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd Methods
Class

CXTPDockingPaneContextStickerWnd Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
OnDraw | This method is called to draw sticker


CXTPDockingPaneContextStickerWnd::OnDraw Method

CXTPDockingPaneContextStickerWnd Methods, CXTPDockingPaneContextStickerWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd::OnDraw Method

This method is called to draw sticker

void OnDraw(
    CDC* pDC
);
Parameters

pDC
Device context pointer

Group

CXTPDockingPaneContextStickerWnd Methods


CXTPDockingPaneContextStickerWnd Constructors

CXTPDockingPaneContextStickerWnd Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd Constructors
Class

CXTPDockingPaneContextStickerWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneContextStickerWnd | Constructs a CXTPDockingPaneContextStickerWnd object.


CXTPDockingPaneContextStickerWnd::CXTPDockingPaneContextStickerWnd Constructor

CXTPDockingPaneContextStickerWnd Constructors, CXTPDockingPaneContextStickerWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd::CXTPDockingPaneContextStickerWnd Constructor

Constructs a CXTPDockingPaneContextStickerWnd object.

CXTPDockingPaneContextStickerWnd(
    CXTPDockingPaneContext* pContext
);
Parameters

pContext
Parent context object.

Group

CXTPDockingPaneContextStickerWnd Constructors


CXTPDockingPaneContextStickerWnd Destructors

CXTPDockingPaneContextStickerWnd Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd Destructors
Class

CXTPDockingPaneContextStickerWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockingPaneContextStickerWnd | Destroys a CXTPDockingPaneContextStickerWnd object, handles cleanup and deallocation.


CXTPDockingPaneContextStickerWnd::~CXTPDockingPaneContextStickerWnd Destructor

CXTPDockingPaneContextStickerWnd Destructors, CXTPDockingPaneContextStickerWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneContextStickerWnd::~CXTPDockingPaneContextStickerWnd Destructor

Destroys a CXTPDockingPaneContextStickerWnd object, handles cleanup and deallocation.

virtual ~CXTPDockingPaneContextStickerWnd();
Group

CXTPDockingPaneContextStickerWnd Destructors


CXTPDockingPaneDefaultTheme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneDefaultTheme Methods, CXTPDockingPaneDefaultTheme Constructors, CXTPDockingPaneDefaultTheme Constructors, CXTPDockingPaneDefaultTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneDefaultTheme Class

CXTPDockingPaneDefaultTheme is CXTPDockingPanePaintManager derived class, represents classic theme for docking panes.

Class Hierarchy

class CXTPDockingPaneDefaultTheme : public CXTPDockingPanePaintManager;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeDefault); to set this theme.

Group

Classes

Legend
Method
virtual
protected
CXTPDockingPaneDefaultTheme Constructors
CXTPDockingPaneDefaultTheme Constructors | Description
CXTPDockingPaneDefaultTheme | Constructs a CXTPDockingPaneDefaultTheme object.
CXTPDockingPaneDefaultTheme Methods
CXTPDockingPaneDefaultTheme Methods | Description
DrawCaption | Override this member function to draw a caption.
DrawCaptionPart | Draw common part of tabbed and floating caption.
DrawFloatingFrame | Call this method to draw frame of floating window


CXTPDockingPaneDefaultTheme Methods

CXTPDockingPaneDefaultTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneDefaultTheme Methods
Class

CXTPDockingPaneDefaultTheme Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionPart | Draw common part of tabbed and floating caption.
Public Methods
Public Methods
Public Method | Description
DrawCaption | Override this member function to draw a caption.
DrawFloatingFrame | Call this method to draw frame of floating window


CXTPDockingPaneDefaultTheme::DrawCaption Method

CXTPDockingPaneDefaultTheme Methods, CXTPDockingPaneDefaultTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneDefaultTheme::DrawCaption Method

Override this member function to draw a caption.

virtual void DrawCaption(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneDefaultTheme Methods


CXTPDockingPaneDefaultTheme::DrawCaptionPart Method

CXTPDockingPaneDefaultTheme Methods, CXTPDockingPaneDefaultTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneDefaultTheme::DrawCaptionPart Method

Draw common part of tabbed and floating caption.

virtual void DrawCaptionPart(
    CDC* pDC,
    CXTPDockingPaneBase* pPane,
    CRect rcCaption,
    const CString& strTitle,
    BOOL bActive,
    BOOL bVertical
);
Parameters

pPane
Container which caption need to draw.
rcCaption
Caption bounding rectangle
strTitle
Caption text.
bActive
TRUE if caption is active.
bVertical
TRUE to draw caption vertically
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneDefaultTheme Methods


CXTPDockingPaneDefaultTheme::DrawFloatingFrame Method

CXTPDockingPaneDefaultTheme Methods, CXTPDockingPaneDefaultTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneDefaultTheme::DrawFloatingFrame Method

Call this method to draw frame of floating window

void DrawFloatingFrame(
    CDC* pDC,
    CXTPDockingPaneMiniWnd* pPane,
    CRect rc
);
Parameters

pPane
Floating window pointer
rc
CLient rectangle of floating frame
dc
Pointer to a valid device context

Group

CXTPDockingPaneDefaultTheme Methods


CXTPDockingPaneDefaultTheme Constructors

CXTPDockingPaneDefaultTheme Class, Legend, Public Methods
CXTPDockingPaneDefaultTheme Constructors
Class

CXTPDockingPaneDefaultTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneDefaultTheme | Constructs a CXTPDockingPaneDefaultTheme object.


CXTPDockingPaneDefaultTheme::CXTPDockingPaneDefaultTheme Constructor

CXTPDockingPaneDefaultTheme Constructors, CXTPDockingPaneDefaultTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneDefaultTheme::CXTPDockingPaneDefaultTheme Constructor

Constructs a CXTPDockingPaneDefaultTheme object.

CXTPDockingPaneDefaultTheme();
Group

CXTPDockingPaneDefaultTheme Constructors


CXTPDockingPaneExplorerTheme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneExplorerTheme Data Members, CXTPDockingPaneExplorerTheme Methods, CXTPDockingPaneExplorerTheme Constructors, CXTPDockingPaneExplorerTheme Constructors, CXTPDockingPaneExplorerTheme Data Members, CXTPDockingPaneExplorerTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneExplorerTheme Class

CXTPDockingPaneExplorerTheme is CXTPDockingPaneDefaultTheme derived class, represents explorer theme for docking panes.

Class Hierarchy

class CXTPDockingPaneExplorerTheme : public CXTPDockingPaneGripperedTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeExplorer); to set this theme.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneExplorerTheme Constructors
CXTPDockingPaneExplorerTheme Constructors | Description
CXTPDockingPaneExplorerTheme | Constructs a CXTPDockingPaneExplorerTheme object.
CXTPDockingPaneExplorerTheme Data Members
CXTPDockingPaneExplorerTheme Data Members | Description
m_themeRebar | Rebar theme helper
CXTPDockingPaneExplorerTheme Methods
CXTPDockingPaneExplorerTheme Methods | Description
DrawCaptionPart | Draw common part of tabbed and floating caption.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneExplorerTheme Data Members

CXTPDockingPaneExplorerTheme Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneExplorerTheme Data Members
Class

CXTPDockingPaneExplorerTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_themeRebar | Rebar theme helper


CXTPDockingPaneExplorerTheme::m_themeRebar Data Member

CXTPDockingPaneExplorerTheme Data Members, CXTPDockingPaneExplorerTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneExplorerTheme::m_themeRebar Data Member

Rebar theme helper

CXTPWinThemeWrapper m_themeRebar;
Group

CXTPDockingPaneExplorerTheme Data Members


CXTPDockingPaneExplorerTheme Methods

CXTPDockingPaneExplorerTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneExplorerTheme Methods
Class

CXTPDockingPaneExplorerTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionPart | Draw common part of tabbed and floating caption.
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneExplorerTheme::DrawCaptionPart Method

CXTPDockingPaneExplorerTheme Methods, CXTPDockingPaneExplorerTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneExplorerTheme::DrawCaptionPart Method

Draw common part of tabbed and floating caption.

virtual void DrawCaptionPart(
    CDC* pDC,
    CXTPDockingPaneBase* pPane,
    CRect rcCaption,
    const CString& strTitle,
    BOOL bActive,
    BOOL bVertical
);
Parameters

pPane
Container which caption need to draw.
rcCaption
Caption bounding rectangle
strTitle
Caption text.
bActive
TRUE if caption is active.
bVertical
TRUE to draw caption vertically
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneExplorerTheme Methods


CXTPDockingPaneExplorerTheme::RefreshMetrics Method

CXTPDockingPaneExplorerTheme Methods, CXTPDockingPaneExplorerTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneExplorerTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

void RefreshMetrics();
Group

CXTPDockingPaneExplorerTheme Methods


CXTPDockingPaneExplorerTheme Constructors

CXTPDockingPaneExplorerTheme Class, Legend, Public Methods
CXTPDockingPaneExplorerTheme Constructors
Class

CXTPDockingPaneExplorerTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneExplorerTheme | Constructs a CXTPDockingPaneExplorerTheme object.


CXTPDockingPaneExplorerTheme::CXTPDockingPaneExplorerTheme Constructor

CXTPDockingPaneExplorerTheme Constructors, CXTPDockingPaneExplorerTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneExplorerTheme::CXTPDockingPaneExplorerTheme Constructor

Constructs a CXTPDockingPaneExplorerTheme object.

CXTPDockingPaneExplorerTheme();
Group

CXTPDockingPaneExplorerTheme Constructors


CXTPDockingPaneGripperedTheme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneGripperedTheme Methods, CXTPDockingPaneGripperedTheme Constructors, CXTPDockingPaneGripperedTheme Constructors, CXTPDockingPaneGripperedTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneGripperedTheme Class

CXTPDockingPaneGripperedTheme is CXTPDockingPaneDefaultTheme derived class, represents gripper theme for docking panes.

Class Hierarchy

class CXTPDockingPaneGripperedTheme : public CXTPDockingPaneDefaultTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeGrippered); to set this theme.

Group

Classes

Legend
Method
virtual
protected
CXTPDockingPaneGripperedTheme Constructors
CXTPDockingPaneGripperedTheme Constructors | Description
CXTPDockingPaneGripperedTheme | Constructs a CXTPDockingPaneGripperedTheme object.
CXTPDockingPaneGripperedTheme Methods
CXTPDockingPaneGripperedTheme Methods | Description
DrawCaption | Override this member function to draw a caption.
DrawCaptionPart | Draw common part of tabbed and floating caption.
DrawFloatingFrame | Call this method to draw frame of floating window


CXTPDockingPaneGripperedTheme Methods

CXTPDockingPaneGripperedTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneGripperedTheme Methods
Class

CXTPDockingPaneGripperedTheme Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionPart | Draw common part of tabbed and floating caption.
Public Methods
Public Methods
Public Method | Description
DrawCaption | Override this member function to draw a caption.
DrawFloatingFrame | Call this method to draw frame of floating window


CXTPDockingPaneGripperedTheme::DrawCaption Method

CXTPDockingPaneGripperedTheme Methods, CXTPDockingPaneGripperedTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneGripperedTheme::DrawCaption Method

Override this member function to draw a caption.

virtual void DrawCaption(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneGripperedTheme Methods


CXTPDockingPaneGripperedTheme::DrawCaptionPart Method

CXTPDockingPaneGripperedTheme Methods, CXTPDockingPaneGripperedTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneGripperedTheme::DrawCaptionPart Method

Draw common part of tabbed and floating caption.

virtual void DrawCaptionPart(
    CDC* pDC,
    CXTPDockingPaneBase* pPane,
    CRect rcCaption,
    const CString& strTitle,
    BOOL bActive,
    BOOL bVertical
);
Parameters

pPane
Container which caption need to draw.
rcCaption
Caption bounding rectangle
strTitle
Caption text.
bActive
TRUE if caption is active.
bVertical
TRUE to draw caption vertically
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneGripperedTheme Methods


CXTPDockingPaneGripperedTheme::DrawFloatingFrame Method

CXTPDockingPaneGripperedTheme Methods, CXTPDockingPaneGripperedTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneGripperedTheme::DrawFloatingFrame Method

Call this method to draw frame of floating window

void DrawFloatingFrame(
    CDC* pDC,
    CXTPDockingPaneMiniWnd* pPane,
    CRect rc
);
Parameters

pPane
Floating window pointer
rc
CLient rectangle of floating frame
dc
Pointer to a valid device context

Group

CXTPDockingPaneGripperedTheme Methods


CXTPDockingPaneGripperedTheme Constructors

CXTPDockingPaneGripperedTheme Class, Legend, Public Methods
CXTPDockingPaneGripperedTheme Constructors
Class

CXTPDockingPaneGripperedTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneGripperedTheme | Constructs a CXTPDockingPaneGripperedTheme object.


CXTPDockingPaneGripperedTheme::CXTPDockingPaneGripperedTheme Constructor

CXTPDockingPaneGripperedTheme Constructors, CXTPDockingPaneGripperedTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneGripperedTheme::CXTPDockingPaneGripperedTheme Constructor

Constructs a CXTPDockingPaneGripperedTheme object.

CXTPDockingPaneGripperedTheme();
Group

CXTPDockingPaneGripperedTheme Constructors


CXTPDockingPaneLayout Class

XTPDockingPaneLayout.h, Classes, Legend, Members, Topics, CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Constructors, CXTPDockingPaneLayout Destructors, CXTPDockingPaneLayout Constructors, CXTPDockingPaneLayout Destructors, CXTPDockingPaneLayout Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneLayout Class

CXTPDockingPaneLayout is a stand alone class. It is used to manipulate a pane's layouts.

Class Hierarchy

class CXTPDockingPaneLayout;
File

XTPDockingPaneLayout.h

Group

Classes

Legend
Method
virtual
CXTPDockingPaneLayout Constructors
CXTPDockingPaneLayout Constructors | Description
CXTPDockingPaneLayout | Constructs a CXTPDockingPaneLayout object.
CXTPDockingPaneLayout Destructors
CXTPDockingPaneLayout Destructors | Description
~CXTPDockingPaneLayout | Destroys a CXTPDockingPaneLayout object, handles cleanup and deallocation
CXTPDockingPaneLayout Methods
CXTPDockingPaneLayout Methods | Description
Copy | Call this member function to copy one layout to another.
DoPropExchange | Call this member function to save/restore the settings of the pane.
GetPaneList | Retrieves list of layout's panes.
IsUserLayout | Call this member to determine if it is a user created layout.
IsValid | Determines if layout is valid.
Load | Call this member function to load the layout from the registry.
LoadFromFile | Call this member function to load the layout from the file.
LoadFromNode | Call this member function to load the layout from the XML node.
Save | Call this member function to save the layout to the registry.
SaveToFile | Call this member function to save the layout to the file.
SaveToNode | Call this member function to save the layout to the XML node.
Serialize | Reads or writes this object from or to an archive.


CXTPDockingPaneLayout Methods

CXTPDockingPaneLayout Class, Legend, Public Methods
CXTPDockingPaneLayout Methods
Class

CXTPDockingPaneLayout Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Copy | Call this member function to copy one layout to another.
DoPropExchange | Call this member function to save/restore the settings of the pane.
GetPaneList | Retrieves list of layout's panes.
IsUserLayout | Call this member to determine if it is a user created layout.
IsValid | Determines if layout is valid.
Load | Call this member function to load the layout from the registry.
LoadFromFile | Call this member function to load the layout from the file.
LoadFromNode | Call this member function to load the layout from the XML node.
Save | Call this member function to save the layout to the registry.
SaveToFile | Call this member function to save the layout to the file.
SaveToNode | Call this member function to save the layout to the XML node.
Serialize | Reads or writes this object from or to an archive.


CXTPDockingPaneLayout::Copy Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::Copy Method

Call this member function to copy one layout to another.

void Copy(
    const CXTPDockingPaneLayout* pLayout
);
Parameters

pLayout
Source Layout.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::DoPropExchange Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::DoPropExchange Method

Call this member function to save/restore the settings of the pane.

BOOL DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Points to a CXTPPropExchange object.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::GetPaneList Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneLayout::GetPaneList Method

Retrieves list of layout's panes.

CXTPDockingPaneInfoList& GetPaneList() const;
Returns

A list of the layout's panes

See Also

CXTPDockingPaneInfoList

Body Source
CXTPDockingPaneInfoList& CXTPDockingPaneLayout::GetPaneList() const {
    return (CXTPDockingPaneInfoList&)m_lstPanes;
}
Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::IsUserLayout Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneLayout::IsUserLayout Method

Call this member to determine if it is a user created layout.

BOOL IsUserLayout() const;
Returns

TRUE if it is a user created layout.

Body Source
BOOL CXTPDockingPaneLayout::IsUserLayout() const {
    return m_bUserLayout;
}
Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::IsValid Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::IsValid Method

Determines if layout is valid.

BOOL IsValid() const;
Returns

TRUE if Layout is valid

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::Load Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::Load Method

Call this member function to load the layout from the registry.

BOOL Load(
    LPCTSTR lpszSection
);
Parameters

lpszSection
Registry section.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::LoadFromFile Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::LoadFromFile Method

Call this member function to load the layout from the file.

BOOL LoadFromFile(
    LPCTSTR lpszFileName,
    LPCTSTR lpszSection
);
Parameters

lpszFileName
The full path and file name.
lpszSection
Registry section.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::LoadFromNode Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::LoadFromNode Method

Call this member function to load the layout from the XML node.

BOOL LoadFromNode(
    CXTPDOMNodePtr xmlNode,
    LPCTSTR lpszSection
);
Parameters

xmlNode
XML node to load.
lpszSection
Registry section.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::Save Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::Save Method

Call this member function to save the layout to the registry.

void Save(
    LPCTSTR lpszSection
);
Parameters

lpszSection
Registry section.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::SaveToFile Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::SaveToFile Method

Call this member function to save the layout to the file.

void SaveToFile(
    LPCTSTR lpszFileName,
    LPCTSTR lpszSection
);
Parameters

lpszFileName
The full path and file name.
lpszSection
Registry section.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::SaveToNode Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::SaveToNode Method

Call this member function to save the layout to the XML node.

void SaveToNode(
    CXTPDOMNodePtr xmlNode,
    LPCTSTR lpszSection
);
Parameters

xmlNode
XML node to save.
lpszSection
Registry section.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout::Serialize Method

CXTPDockingPaneLayout Methods, CXTPDockingPaneLayout Class
CXTPDockingPaneLayout::Serialize Method

Reads or writes this object from or to an archive.

void Serialize(
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.

Group

CXTPDockingPaneLayout Methods


CXTPDockingPaneLayout Constructors

CXTPDockingPaneLayout Class, Legend, Public Methods
CXTPDockingPaneLayout Constructors
Class

CXTPDockingPaneLayout Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneLayout | Constructs a CXTPDockingPaneLayout object.


CXTPDockingPaneLayout::CXTPDockingPaneLayout Constructor

CXTPDockingPaneLayout Constructors, CXTPDockingPaneLayout Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneLayout::CXTPDockingPaneLayout Constructor

Constructs a CXTPDockingPaneLayout object.

CXTPDockingPaneLayout(
    CXTPDockingPaneManager* pManager
);
Parameters

pManager
Points to a CXTPDockingPaneManager object

Returns

A CXTPDockingPaneLayout object.

Group

CXTPDockingPaneLayout Constructors


CXTPDockingPaneLayout Destructors

CXTPDockingPaneLayout Class, Legend, Public Methods
CXTPDockingPaneLayout Destructors
Class

CXTPDockingPaneLayout Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockingPaneLayout | Destroys a CXTPDockingPaneLayout object, handles cleanup and deallocation


CXTPDockingPaneLayout::~CXTPDockingPaneLayout Destructor

CXTPDockingPaneLayout Destructors, CXTPDockingPaneLayout Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneLayout::~CXTPDockingPaneLayout Destructor

Destroys a CXTPDockingPaneLayout object, handles cleanup and deallocation

virtual ~CXTPDockingPaneLayout();
Group

CXTPDockingPaneLayout Destructors


CXTPDockingPaneManager Class

XTPDockingPaneManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Methods, CXTPDockingPaneManager Constructors, CXTPDockingPaneManager Destructors, CXTPDockingPaneManager Constructors, CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Destructors, CXTPDockingPaneManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager Class

CXTPDockingPaneManager is a CWnd derived class. It is used to manipulate docking panes.

Class Hierarchy

class CXTPDockingPaneManager : public CWnd;
File

XTPDockingPaneManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneManager Constructors
CXTPDockingPaneManager Constructors | Description
CXTPDockingPaneManager | Constructs a CXTPDockingPaneManager object
CXTPDockingPaneManager Data Members
CXTPDockingPaneManager Data Members | Description
m_bAlphaDockingContext | If TRUE, alpha docking context is used when dragging a pane, the shaded area indicates the panes new location of dropped.
m_bCloseGroupOnButtonClick | If TRUE, when the close button on a group of panes is clicked, then the entire group of panes is closed.
m_bHideClient | If TRUE, the client area is hidden so that only the docking panes are visible and occupy the entire area.
m_bHideGroupOnButtonClick | If TRUE, when the hide button on a group of panes is clicked, then the entire group of panes is hidden.
m_bKeyboardEnabled | XTPDockingPaneKeyboardNavigate options
m_bLockSplitters | If TRUE, you can not resize the panes when they are docked.
m_bShowContentsWhileDragging | If TRUE, window contents is visible while dragging.
m_bShowDockingContextStickers | If TRUE, docking context stickers are drawn when the pane is being dragged and dropped.
m_bShowMaximizeButton | Allow panes to be maximized.
m_bShowSizeCursorWhileDragging | TRUE to show size cursor while panes are dragged
m_bStickyFloatingFrames | TRUE to enable sticky option for floating panes
m_bSyncActiveFloatingFrames | Synchronizes the activation of the mini-frame window to the activation of its parent window.
m_bThemedFloatingFrames | If TRUE, floating docking panes will use the currently set theme.
m_bUseSplitterTracker | If TRUE, splitter trackers are used.
m_captionDirection | Caption Direction
m_dwDefaultPaneOptions | Default Panes options.
m_nClientMargin | Client margins
m_nDockingContextStickerStyle | Sticker style.
m_nFloatingFramesOpacity | Opacity of floating frames
m_nSplitterGap | Minimum available width of panes.
m_nStickyGap | Sticky gap
m_pActivePane | Current Active pane;
m_pDockingContext | Docking context helper.
m_pfnSetLayeredWindowAttributes | POinter to SetLayeredWindowAttributes API function
m_pImageManager | Image manager of docking panes.
m_pLayout | Selected layout.
m_pPaintManager | Current paint manager.
m_pPreviewLayout | Preview mode layout.
m_pSite | Parent window of docking manager.
m_ptMinClientSize | Minimum client size
m_pToolTipContext | Tooltip Context.
m_pWindowSelectClass | Runtime class of WindowSelect
m_strFloatingFrameCaption | The caption that is displayed in the title bar of a floating frame that has panes docked.
CXTPDockingPaneManager Destructors
CXTPDockingPaneManager Destructors | Description
~CXTPDockingPaneManager | Destroys a CXTPDockingPaneManager object, handles cleanup and deallocation
CXTPDockingPaneManager Methods
CXTPDockingPaneManager Methods | Description
ActivateNextPane | Call this method to activate pane in cycle order
AttachPane | Call this member to attach a pane to another one.
ClearIconMap | Call this member to remove all icons.
CloseAll | Call this member to close all panes.
ClosePane |
CreateLayout | Call this member to create a new layout.
CreatePane | Call this member function to create a docking pane.
DestroyAll | Call this member to destroy all panes.
DestroyPane |
DockPane | Call this member to dock an existing pane.
DoPropExchange | Call this member function to save/restore the settings of the pane.
EnableKeyboardNavigate | Call this member to allow user switch and move panes using keyboard.
EnsureVisible | Call this method to show and activate pane
FindPane | Call this member to find a pane by its identifier.
FloatPane | Call this member to float an existing pane.
GetActivePane | Call this member function to get pane currently active (focused)
GetAnimationDelay | Call this member to get the animation speed.
GetCaptionDirection | Call this member determine the direction the tab buttons are displayed.
GetClientMargin | Retrieves width of margin around panes
GetClientPane | Call this member to retrieve client pane.
GetCurrentTheme | Call this member to get the current visual theme.
GetDefaultPaneOptions | Retrieves default panes options.
GetDockingContext | Retrieves current docking context pointer.
GetDockingContextStickerStyle | Call this member to get Docking Context Stickers style.
GetFloatingFramesOpacity | Determines opacity for inactive floating frames
GetIcon | Call this member to get an icon of the pane.
GetImageManager | Call this member to retrieve Image Manager of Docking Panes.
GetKeyboardWindowSelectClass | Determines Runtime class for CXTPDockingPaneWindowSelect window, that shows active panes and files.
GetLayout | Call this member to get the current layout.
GetPaintManager | Retrieves paint manager of docking panes.
GetPaneDirection | Call this member to determine the XTPDockingPaneDirection of pPane.
GetPaneList | Call this member to get the list of the created panes.
GetPaneStack | Call this member to get the list of the created panes.including virtual containers
GetRTLDirection | Call this member to return the Right-to-Left (RTL) docking direction equivalent to the direction passed in if IsLayoutRTL returns TRUE.
GetShowContentsWhileDragging | Determines if "Show window contents while dragging" option is enabled
GetSite | Call this member to return the docking site of the manager.
GetToolTipContext | Call this method to get tooltip context pointer.
GetTopPane | Retrieves top level virtual container for site window.
HideClient | Call this member to hide client area.
HidePane |
InstallDockingPanes | Call this member function to install docking panes.
IsAlphaDockingContext | Call this member to determine if Alpha Docking Context is used when panes are being dragged and dropped.
IsCaptionMaximizeButtonsVisible | Determines if Maximize/Restore buttons for docking panes are visible
IsClientHidden | Checks to see if the client is hidden.
IsKeyboardNavigateEnabled | Determines if Keyboard Navigate options enabled.
IsLayoutRTL | Call this member to determine if the current layout is Right-to-Left (RTL).
IsPaneClosed |
IsPaneHidden |
IsPaneSelected |
IsShowDockingContextStickers | Call this member to determine whether Docking Context Stickers are used.
IsSplittersLocked | Call this member to determine if the splitters are locked.
IsSplitterTrackerUsed | Call this member to determine if the splitter tracker is used.
IsStickyFloatingFrames | Determines if sticky floating frames option enabled
IsThemedFloatingFrames | Determines if themes are used for the floating frames.
LockSplitters | Call this method to lock splitters.
NormalizeSplitters | Call this method to save current splitter positions for all splitter containers
NotifyOwner | This member is called to notify the parent window that an event has occurred in the docking pane.
OnActivatePane | This method is called when a pane activated/deactivated
OnCreatePane | This method is called when a pane is created.
OnSetPreviewMode | Call this member function to set the application's panes into and out of print-preview mode.
RecalcFrameLayout | This method is called to recalculate layout of pane's site.
RecalcFramesLayout | Call this method to recalculate layout for all parent frames of panes.
RedrawPanes | Call this member to redraw all panes.
SetAlphaDockingContext | Call this member to specify whether an alpha docking context is used to indicate where a pane can be docked while dragging the pane.
SetAnimationDelay | Call this member to set the speed of animation.
SetCaptionDirection | Call this member to set direction of captions
SetClientMargin | Call this method to add margins around panes
SetCustomTheme | Call this member to set a custom theme. See the DockingPane sample as a sample of creating a new theme.
SetDefaultPaneOptions | Call this method to set default options for each pane
SetDockingContext | Call this method to use custom docking context.
SetDockingContextStickerStyle | Call this member to set Docking Context Stickers style.
SetFloatingFrameCaption | Call this method to set common caption for floating frames.
SetFloatingFramesOpacity | Call this method to set opacity for inactive floating frames
SetIcon | Call this member to set an icon to the pane.
SetIcons | Call this member to set icons to panes.
SetImageManager | Call this member to set the specified image manager.
SetKeyboardWindowSelectClass | Call this method to set custom CXTPDockingPaneWindowSelect window, that will use to show active panes and files.
SetLayout | Call this member to set the layout.
SetShowContentsWhileDragging | Call this member to set "Show window contents while dragging" option
SetShowDockingContextStickers | Call this member to specify whether Visual Studio 2005 style Docking Context Stickers are used while dragging a docking pane.
SetStickyFloatingFrames | Call this method to enable sticky floating frames
SetTheme | Call this member to switch the visual theme of the panes.
SetThemedFloatingFrames | Call this method to use themes for floating frames.
ShowCaptionMaximizeButton | Call this method to show Maximize/Restore buttons for docking panes
ShowPane |
SyncActiveFloatingFrames | Call this member to keep the activation of floating frames windows in sync with the activation of the top level frame window.
SyncPanesState | This method updates XTP_DOCKINGPANE_INFO structure for each panes filling its members.
ToggleAutoHide | Call this member to switch the pane's Auto hide (docking/auto hide).
ToggleDocking | Call this member to switch the pane's position (docking/floating).
UpdatePanes | This method is called to update panes state
UseSplitterTracker | Call this member to use trackers.


CXTPDockingPaneManager Data Members

CXTPDockingPaneManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager Data Members
Class

CXTPDockingPaneManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAlphaDockingContext | If TRUE, alpha docking context is used when dragging a pane, the shaded area indicates the panes new location of dropped.
m_bHideClient | If TRUE, the client area is hidden so that only the docking panes are visible and occupy the entire area.
m_bKeyboardEnabled | XTPDockingPaneKeyboardNavigate options
m_bLockSplitters | If TRUE, you can not resize the panes when they are docked.
m_bShowContentsWhileDragging | If TRUE, window contents is visible while dragging.
m_bShowDockingContextStickers | If TRUE, docking context stickers are drawn when the pane is being dragged and dropped.
m_bShowMaximizeButton | Allow panes to be maximized.
m_bStickyFloatingFrames | TRUE to enable sticky option for floating panes
m_bSyncActiveFloatingFrames | Synchronizes the activation of the mini-frame window to the activation of its parent window.
m_bThemedFloatingFrames | If TRUE, floating docking panes will use the currently set theme.
m_bUseSplitterTracker | If TRUE, splitter trackers are used.
m_captionDirection | Caption Direction
m_dwDefaultPaneOptions | Default Panes options.
m_nClientMargin | Client margins
m_nDockingContextStickerStyle | Sticker style.
m_nFloatingFramesOpacity | Opacity of floating frames
m_pActivePane | Current Active pane;
m_pDockingContext | Docking context helper.
m_pfnSetLayeredWindowAttributes | POinter to SetLayeredWindowAttributes API function
m_pImageManager | Image manager of docking panes.
m_pLayout | Selected layout.
m_pPaintManager | Current paint manager.
m_pPreviewLayout | Preview mode layout.
m_pSite | Parent window of docking manager.
m_pToolTipContext | Tooltip Context.
m_pWindowSelectClass | Runtime class of WindowSelect
m_strFloatingFrameCaption | The caption that is displayed in the title bar of a floating frame that has panes docked.
Public Data Members
Public Data Member | Description
m_bCloseGroupOnButtonClick | If TRUE, when the close button on a group of panes is clicked, then the entire group of panes is closed.
m_bHideGroupOnButtonClick | If TRUE, when the hide button on a group of panes is clicked, then the entire group of panes is hidden.
m_bShowSizeCursorWhileDragging | TRUE to show size cursor while panes are dragged
m_nSplitterGap | Minimum available width of panes.
m_nStickyGap | Sticky gap
m_ptMinClientSize | Minimum client size


CXTPDockingPaneManager::m_bAlphaDockingContext Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bAlphaDockingContext Data Member

If TRUE, alpha docking context is used when dragging a pane, the shaded area indicates the panes new location of dropped.

BOOL m_bAlphaDockingContext;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bCloseGroupOnButtonClick Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bCloseGroupOnButtonClick Data Member

If TRUE, when the close button on a group of panes is clicked, then the entire group of panes is closed.

BOOL m_bCloseGroupOnButtonClick;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bHideClient Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bHideClient Data Member

If TRUE, the client area is hidden so that only the docking panes are visible and occupy the entire area.

BOOL m_bHideClient;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bHideGroupOnButtonClick Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bHideGroupOnButtonClick Data Member

If TRUE, when the hide button on a group of panes is clicked, then the entire group of panes is hidden.

BOOL m_bHideGroupOnButtonClick;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bKeyboardEnabled Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bKeyboardEnabled Data Member

XTPDockingPaneKeyboardNavigate options

DWORD m_bKeyboardEnabled;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bLockSplitters Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bLockSplitters Data Member

If TRUE, you can not resize the panes when they are docked.

BOOL m_bLockSplitters;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bShowContentsWhileDragging Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bShowContentsWhileDragging Data Member

If TRUE, window contents is visible while dragging.

BOOL m_bShowContentsWhileDragging;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bShowDockingContextStickers Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bShowDockingContextStickers Data Member

If TRUE, docking context stickers are drawn when the pane is being dragged and dropped.

BOOL m_bShowDockingContextStickers;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bShowMaximizeButton Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bShowMaximizeButton Data Member

Allow panes to be maximized.

BOOL m_bShowMaximizeButton;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bShowSizeCursorWhileDragging Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bShowSizeCursorWhileDragging Data Member

TRUE to show size cursor while panes are dragged

BOOL m_bShowSizeCursorWhileDragging;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bStickyFloatingFrames Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bStickyFloatingFrames Data Member

TRUE to enable sticky option for floating panes

BOOL m_bStickyFloatingFrames;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bSyncActiveFloatingFrames Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bSyncActiveFloatingFrames Data Member

Synchronizes the activation of the mini-frame window to the activation of its parent window.

BOOL m_bSyncActiveFloatingFrames;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bThemedFloatingFrames Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bThemedFloatingFrames Data Member

If TRUE, floating docking panes will use the currently set theme.

BOOL m_bThemedFloatingFrames;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_bUseSplitterTracker Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_bUseSplitterTracker Data Member

If TRUE, splitter trackers are used.

BOOL m_bUseSplitterTracker;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_captionDirection Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_captionDirection Data Member

Caption Direction

XTPDockingPaneCaptionDirection m_captionDirection;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_dwDefaultPaneOptions Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_dwDefaultPaneOptions Data Member

Default Panes options.

DWORD m_dwDefaultPaneOptions;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_nClientMargin Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_nClientMargin Data Member

Client margins

int m_nClientMargin;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_nDockingContextStickerStyle Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_nDockingContextStickerStyle Data Member

Sticker style.

XTPDockingContextStickerStyle m_nDockingContextStickerStyle;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_nFloatingFramesOpacity Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_nFloatingFramesOpacity Data Member

Opacity of floating frames

BOOL m_nFloatingFramesOpacity;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_nSplitterGap Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_nSplitterGap Data Member

Minimum available width of panes.

int m_nSplitterGap;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_nStickyGap Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_nStickyGap Data Member

Sticky gap

int m_nStickyGap;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pActivePane Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pActivePane Data Member

Current Active pane;

CXTPDockingPane* m_pActivePane;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pDockingContext Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pDockingContext Data Member

Docking context helper.

CXTPDockingPaneContext* m_pDockingContext;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pfnSetLayeredWindowAttributes Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pfnSetLayeredWindowAttributes Data Member

POinter to SetLayeredWindowAttributes API function

PFNSETLAYEREDWINDOWATTRIBUTES m_pfnSetLayeredWindowAttributes;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pImageManager Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pImageManager Data Member

Image manager of docking panes.

CXTPImageManager* m_pImageManager;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pLayout Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pLayout Data Member

Selected layout.

CXTPDockingPaneLayout* m_pLayout;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pPaintManager Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pPaintManager Data Member

Current paint manager.

CXTPDockingPanePaintManager* m_pPaintManager;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pPreviewLayout Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pPreviewLayout Data Member

Preview mode layout.

CXTPDockingPaneLayout* m_pPreviewLayout;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pSite Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pSite Data Member

Parent window of docking manager.

CWnd* m_pSite;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_ptMinClientSize Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_ptMinClientSize Data Member

Minimum client size

CPoint m_ptMinClientSize;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pToolTipContext Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pToolTipContext Data Member

Tooltip Context.

CXTPToolTipContext* m_pToolTipContext;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_pWindowSelectClass Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_pWindowSelectClass Data Member

Runtime class of WindowSelect

CRuntimeClass* m_pWindowSelectClass;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager::m_strFloatingFrameCaption Data Member

CXTPDockingPaneManager Data Members, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::m_strFloatingFrameCaption Data Member

The caption that is displayed in the title bar of a floating frame that has panes docked.

CString m_strFloatingFrameCaption;
Group

CXTPDockingPaneManager Data Members


CXTPDockingPaneManager Methods

CXTPDockingPaneManager Class, Legend, Public Methods
CXTPDockingPaneManager Methods
Class

CXTPDockingPaneManager Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
ActivateNextPane | Call this method to activate pane in cycle order
AttachPane | Call this member to attach a pane to another one.
ClearIconMap | Call this member to remove all icons.
CloseAll | Call this member to close all panes.
ClosePane |
CreateLayout | Call this member to create a new layout.
CreatePane | Call this member function to create a docking pane.
DestroyAll | Call this member to destroy all panes.
DestroyPane |
DockPane | Call this member to dock an existing pane.
DoPropExchange | Call this member function to save/restore the settings of the pane.
EnableKeyboardNavigate | Call this member to allow user switch and move panes using keyboard.
EnsureVisible | Call this method to show and activate pane
FindPane | Call this member to find a pane by its identifier.
FloatPane | Call this member to float an existing pane.
GetActivePane | Call this member function to get pane currently active (focused)
GetAnimationDelay | Call this member to get the animation speed.
GetCaptionDirection | Call this member determine the direction the tab buttons are displayed.
GetClientMargin | Retrieves width of margin around panes
GetClientPane | Call this member to retrieve client pane.
GetCurrentTheme | Call this member to get the current visual theme.
GetDefaultPaneOptions | Retrieves default panes options.
GetDockingContext | Retrieves current docking context pointer.
GetDockingContextStickerStyle | Call this member to get Docking Context Stickers style.
GetFloatingFramesOpacity | Determines opacity for inactive floating frames
GetIcon | Call this member to get an icon of the pane.
GetImageManager | Call this member to retrieve Image Manager of Docking Panes.
GetKeyboardWindowSelectClass | Determines Runtime class for CXTPDockingPaneWindowSelect window, that shows active panes and files.
GetLayout | Call this member to get the current layout.
GetPaintManager | Retrieves paint manager of docking panes.
GetPaneDirection | Call this member to determine the XTPDockingPaneDirection of pPane.
GetPaneList | Call this member to get the list of the created panes.
GetPaneStack | Call this member to get the list of the created panes.including virtual containers
GetRTLDirection | Call this member to return the Right-to-Left (RTL) docking direction equivalent to the direction passed in if IsLayoutRTL returns TRUE.
GetShowContentsWhileDragging | Determines if "Show window contents while dragging" option is enabled
GetSite | Call this member to return the docking site of the manager.
GetToolTipContext | Call this method to get tooltip context pointer.
GetTopPane | Retrieves top level virtual container for site window.
HideClient | Call this member to hide client area.
HidePane |
InstallDockingPanes | Call this member function to install docking panes.
IsAlphaDockingContext | Call this member to determine if Alpha Docking Context is used when panes are being dragged and dropped.
IsCaptionMaximizeButtonsVisible | Determines if Maximize/Restore buttons for docking panes are visible
IsClientHidden | Checks to see if the client is hidden.
IsKeyboardNavigateEnabled | Determines if Keyboard Navigate options enabled.
IsLayoutRTL | Call this member to determine if the current layout is Right-to-Left (RTL).
IsPaneClosed |
IsPaneHidden |
IsPaneSelected |
IsShowDockingContextStickers | Call this member to determine whether Docking Context Stickers are used.
IsSplittersLocked | Call this member to determine if the splitters are locked.
IsSplitterTrackerUsed | Call this member to determine if the splitter tracker is used.
IsStickyFloatingFrames | Determines if sticky floating frames option enabled
IsThemedFloatingFrames | Determines if themes are used for the floating frames.
LockSplitters | Call this method to lock splitters.
NormalizeSplitters | Call this method to save current splitter positions for all splitter containers
NotifyOwner | This member is called to notify the parent window that an event has occurred in the docking pane.
OnActivatePane | This method is called when a pane activated/deactivated
OnCreatePane | This method is called when a pane is created.
OnSetPreviewMode | Call this member function to set the application's panes into and out of print-preview mode.
RecalcFrameLayout | This method is called to recalculate layout of pane's site.
RecalcFramesLayout | Call this method to recalculate layout for all parent frames of panes.
RedrawPanes | Call this member to redraw all panes.
SetAlphaDockingContext | Call this member to specify whether an alpha docking context is used to indicate where a pane can be docked while dragging the pane.
SetAnimationDelay | Call this member to set the speed of animation.
SetCaptionDirection | Call this member to set direction of captions
SetClientMargin | Call this method to add margins around panes
SetCustomTheme | Call this member to set a custom theme. See the DockingPane sample as a sample of creating a new theme.
SetDefaultPaneOptions | Call this method to set default options for each pane
SetDockingContext | Call this method to use custom docking context.
SetDockingContextStickerStyle | Call this member to set Docking Context Stickers style.
SetFloatingFrameCaption | Call this method to set common caption for floating frames.
SetFloatingFramesOpacity | Call this method to set opacity for inactive floating frames
SetIcon | Call this member to set an icon to the pane.
SetIcons | Call this member to set icons to panes.
SetImageManager | Call this member to set the specified image manager.
SetKeyboardWindowSelectClass | Call this method to set custom CXTPDockingPaneWindowSelect window, that will use to show active panes and files.
SetLayout | Call this member to set the layout.
SetShowContentsWhileDragging | Call this member to set "Show window contents while dragging" option
SetShowDockingContextStickers | Call this member to specify whether Visual Studio 2005 style Docking Context Stickers are used while dragging a docking pane.
SetStickyFloatingFrames | Call this method to enable sticky floating frames
SetTheme | Call this member to switch the visual theme of the panes.
SetThemedFloatingFrames | Call this method to use themes for floating frames.
ShowCaptionMaximizeButton | Call this method to show Maximize/Restore buttons for docking panes
ShowPane |
SyncActiveFloatingFrames | Call this member to keep the activation of floating frames windows in sync with the activation of the top level frame window.
SyncPanesState | This method updates XTP_DOCKINGPANE_INFO structure for each panes filling its members.
ToggleAutoHide | Call this member to switch the pane's Auto hide (docking/auto hide).
ToggleDocking | Call this member to switch the pane's position (docking/floating).
UpdatePanes | This method is called to update panes state
UseSplitterTracker | Call this member to use trackers.


CXTPDockingPaneManager::ActivateNextPane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::ActivateNextPane Method

Call this method to activate pane in cycle order

BOOL ActivateNextPane(
    CXTPDockingPane* pPane,
    BOOL bForward
);
Parameters

pPane
Pane to start; NULL to select first pane
bForward
TRUE to select next pane; FALSE to select previous pane

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::AttachPane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::AttachPane Method

Call this member to attach a pane to another one.

void AttachPane(
    CXTPDockingPaneBase* pPane,
    CXTPDockingPaneBase* pNeighbour
);
Parameters

pPane
Pane to be attached.
pNeighbour
Pane's Neighbor.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::ClearIconMap Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::ClearIconMap Method

Call this member to remove all icons.

void ClearIconMap();
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::CloseAll Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::CloseAll Method

Call this member to close all panes.

void CloseAll();
Group

CXTPDockingPaneManager Methods


ClosePane Method

CXTPDockingPaneManager Methods
ClosePane Method
Overload List
Methods
Method | Description
CXTPDockingPaneManager::ClosePane (CXTPDockingPane*) | Call this member to close a pane
CXTPDockingPaneManager::ClosePane (int) | Call this member to close a pane
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::ClosePane Method (int)

ClosePane Method, CXTPDockingPaneManager Class, Body Source
CXTPDockingPaneManager::ClosePane Method (int)

Call this member to close a pane

void ClosePane(
    int nID
);
void ClosePane(
    CXTPDockingPane* pPane
);
Parameters

nID
Pane's identifier.
pPane
Pane need to close

Body Source
void CXTPDockingPaneManager::ClosePane(int nID) {
    ClosePane(FindPane(nID));
}
Group

ClosePane Method


CXTPDockingPaneManager::CreateLayout Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::CreateLayout Method

Call this member to create a new layout.

virtual CXTPDockingPaneLayout* CreateLayout();
Returns

A pointer to a CXTPDockingPaneLayout object.

Remarks

You must delete layout when it no longer used.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::CreatePane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::CreatePane Method

Call this member function to create a docking pane.

CXTPDockingPane* CreatePane(
    UINT nID,
    CRect rc,
    XTPDockingPaneDirection direction,
    CXTPDockingPaneBase* pNeighbour = NULL
);
Parameters

nID
Unique identifier of the pane.
rc
Initial size of the pane.
direction
Docking direction. Can be any of the values listed in the Remarks section.
pNeighbour
Pane's Neighbor. It can be NULL to use the frame as a neighbor.

Returns

The pointer to the created pane.

Remarks

direction parameter can be one of the following:

  • xtpPaneDockTop Docks the pane to the top of the neighbor.
  • xtpPaneDockLeft Docks the pane to the left of the neighbor.
  • xtpPaneDockRight Docks the pane to the right of the neighbor.
  • xtpPaneDockBottom Docks the pane to the bottom of the neighbor.
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::DestroyAll Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::DestroyAll Method

Call this member to destroy all panes.

void DestroyAll();
Group

CXTPDockingPaneManager Methods


DestroyPane Method

CXTPDockingPaneManager Methods
DestroyPane Method
Overload List
Methods
Method | Description
CXTPDockingPaneManager::DestroyPane (CXTPDockingPane*) | Call this member to destroy a pane
CXTPDockingPaneManager::DestroyPane (int) | Call this member to destroy a pane
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::DestroyPane Method (int)

DestroyPane Method, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::DestroyPane Method (int)

Call this member to destroy a pane

void DestroyPane(
    int nID
);
void DestroyPane(
    CXTPDockingPane* pPane
);
Parameters

nID
Pane's identifier.
pPane
Pane need to destroy

See Also

ClosePane

Body Source
void CXTPDockingPaneManager::DestroyPane(int nID) {
    DestroyPane(FindPane(nID));
}
Group

DestroyPane Method


CXTPDockingPaneManager::DockPane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::DockPane Method

Call this member to dock an existing pane.

void DockPane(
    CXTPDockingPaneBase* pPane,
    XTPDockingPaneDirection direction,
    CXTPDockingPaneBase* pNeighbour = NULL
);
Parameters

pPane
Pane to be docked.
direction
Docking direction. Can be any of the values listed in the Remarks section.
pNeighbour
Pane's Neighbor.

Remarks

direction parameter can be one of the following:

  • xtpPaneDockTop Docks the pane to the top of the neighbor.
  • xtpPaneDockLeft Docks the pane to the left of the neighbor.
  • xtpPaneDockRight Docks the pane to the right of the neighbor.
  • xtpPaneDockBottom Docks the pane to the bottom of the neighbor.
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::DoPropExchange Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::DoPropExchange Method

Call this member function to save/restore the settings of the pane.

BOOL DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Points to a CXTPPropExchange object.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::EnableKeyboardNavigate Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::EnableKeyboardNavigate Method

Call this member to allow user switch and move panes using keyboard.

void EnableKeyboardNavigate(
    DWORD options = xtpPaneKeyboardUseAll
);
Parameters

options
available keyboard keys that can be use to navigate items

Remarks

options can be combination of the following:

  • xtpPaneKeyboardUseAltMinus To use Alt+'-' to show context menu
  • xtpPaneKeyboardUseAltF6 To use Alt+F6 to select next pane
  • xtpPaneKeyboardUseAltF7 To use Alt+F7 to show window select dialog
  • xtpPaneKeyboardUseCtrlTab To use Ctrl+Tab to show window select dialog
  • xtpPaneKeyboardUseAll To use all keys

You can call SetKeyboardWindowSelectClass to set custom window for Ctrl-Tab and Alt_F7 operations

See Also

XTPDockingPaneKeyboardNavigate

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::EnsureVisible Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::EnsureVisible Method

Call this method to show and activate pane

void EnsureVisible(
    CXTPDockingPaneBase* pPane
);
Parameters

pPane
pane to show

See Also

ShowPane

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::FindPane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::FindPane Method

Call this member to find a pane by its identifier.

CXTPDockingPane* FindPane(
    int nID
) const;
Parameters

nID
Pane's identifier.

Returns

A pointer to a CXTPDockingPane object.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::FloatPane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::FloatPane Method

Call this member to float an existing pane.

CXTPDockingPaneMiniWnd* FloatPane(
    CXTPDockingPaneBase* pPane,
    CRect rc
);
Parameters

pPane
Pane to be floated.
rc
Floating rectangle.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetActivePane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetActivePane Method

Call this member function to get pane currently active (focused)

CXTPDockingPane* GetActivePane() const;
Body Source
CXTPDockingPane* CXTPDockingPaneManager::GetActivePane() const {
    return m_pActivePane;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetAnimationDelay Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetAnimationDelay Method

Call this member to get the animation speed.

double GetAnimationDelay(
    int* pAnimationDuration = NULL,
    int* pAnimationInterval = NULL
) const;
Parameters

pAnimationDuration
Pointer to receive total time of animation, in milliseconds.
pAnimationInterval
Pointer to receive amount of time to rest, in milliseconds, between each step.

Returns

Animation delay.

See Also

SetAnimationDelay

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetCaptionDirection Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetCaptionDirection Method

Call this member determine the direction the tab buttons are displayed.

XTPDockingPaneCaptionDirection GetCaptionDirection() const;
Returns

A XTPDockingPaneCaptionDirection flag indicating which direction the pane caption is displayed.

Remarks

Can return one of the following direction:

  • xtpPaneCaptionHorizontal
  • xtpPaneCaptionVertical
  • xtpPaneCaptionAutoByPosition
  • xtpPaneCaptionAutoBySize
See Also

SetCaptionDirection

Body Source
XTPDockingPaneCaptionDirection CXTPDockingPaneManager::GetCaptionDirection() const {
    return m_captionDirection;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetClientMargin Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetClientMargin Method

Retrieves width of margin around panes

int GetClientMargin() const;
Body Source
int CXTPDockingPaneManager::GetClientMargin() const {
    return m_nClientMargin;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetClientPane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::GetClientPane Method

Call this member to retrieve client pane.

CXTPDockingPaneBase* GetClientPane() const;
Returns

A pointer to a CXTPDockingPaneBase object.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetCurrentTheme Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::GetCurrentTheme Method

Call this member to get the current visual theme.

XTPDockingPanePaintTheme GetCurrentTheme() const;
Returns

The current theme.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetDefaultPaneOptions Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetDefaultPaneOptions Method

Retrieves default panes options.

DWORD GetDefaultPaneOptions() const;
Returns

Default options used for each pane.

See Also

SetDefaultPaneOptions, XTPDockingPaneOptions

Body Source
DWORD CXTPDockingPaneManager::GetDefaultPaneOptions() const {
    return m_dwDefaultPaneOptions;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetDockingContext Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetDockingContext Method

Retrieves current docking context pointer.

CXTPDockingPaneContext* GetDockingContext() const;
Returns

Pointer to current docking context.

Body Source
CXTPDockingPaneContext* CXTPDockingPaneManager::GetDockingContext() const {
    return m_pDockingContext;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetDockingContextStickerStyle Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetDockingContextStickerStyle Method

Call this member to get Docking Context Stickers style.

XTPDockingContextStickerStyle GetDockingContextStickerStyle() const;
Returns

Style of docking pane stickers.

Remarks

Call SetShowDockingContextStickers to enable Stickers.

See Also

SetShowDockingContextStickers, SetDockingContextStickerStyle

Body Source
XTPDockingContextStickerStyle CXTPDockingPaneManager::GetDockingContextStickerStyle() const {
    return m_nDockingContextStickerStyle;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetFloatingFramesOpacity Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetFloatingFramesOpacity Method

Determines opacity for inactive floating frames

int GetFloatingFramesOpacity() const;
Body Source
int CXTPDockingPaneManager::GetFloatingFramesOpacity() const {
    return m_nFloatingFramesOpacity;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetIcon Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::GetIcon Method

Call this member to get an icon of the pane.

CXTPImageManagerIcon* GetIcon(
    UINT nID,
    int nWidth = 16
) const;
Parameters

nID
Docking pane's identifier.
nWidth
Width of icon to retrieve.

Returns

The docking pane's icon.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetImageManager Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetImageManager Method

Call this member to retrieve Image Manager of Docking Panes.

CXTPImageManager* GetImageManager() const;
Returns

Image Manager of Docking Panes.

Body Source
CXTPImageManager* CXTPDockingPaneManager::GetImageManager() const {
    return m_pImageManager;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetKeyboardWindowSelectClass Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetKeyboardWindowSelectClass Method

Determines Runtime class for CXTPDockingPaneWindowSelect window, that shows active panes and files.

CRuntimeClass* GetKeyboardWindowSelectClass() const;
See Also

SetKeyboardWindowSelectClass, EnableKeyboardNavigate, XTPDockingPaneKeyboardNavigate

Body Source
CRuntimeClass* CXTPDockingPaneManager::GetKeyboardWindowSelectClass() const {
    return m_pWindowSelectClass;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetLayout Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::GetLayout Method

Call this member to get the current layout.

void GetLayout(
    CXTPDockingPaneLayout* pLayout
) const;
Parameters

pLayout
Pointer to the existing layout.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetPaintManager Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetPaintManager Method

Retrieves paint manager of docking panes.

CXTPDockingPanePaintManager* GetPaintManager() const;
Returns

Returns paint manager.

Body Source
CXTPDockingPanePaintManager* CXTPDockingPaneManager::GetPaintManager() const {
    return m_pPaintManager;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetPaneDirection Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::GetPaneDirection Method

Call this member to determine the XTPDockingPaneDirection of pPane.

XTPDockingPaneDirection GetPaneDirection(
    const CXTPDockingPaneBase* pPane
) const;
Parameters

pPane
Points to a CXTPDockingPaneBase object

Returns

The current XTPDockingPaneDirection of pPane.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetPaneList Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetPaneList Method

Call this member to get the list of the created panes.

CXTPDockingPaneInfoList& GetPaneList() const;
Returns

A list of created panes.

See Also

GetPaneStack, CXTPDockingPaneInfoList

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetPaneStack Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetPaneStack Method

Call this member to get the list of the created panes.including virtual containers

CXTPDockingPaneBaseList& GetPaneStack() const;
Returns

A list of created panes with its containers.

See Also

GetPaneList

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetRTLDirection Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::GetRTLDirection Method

Call this member to return the Right-to-Left (RTL) docking direction equivalent to the direction passed in if IsLayoutRTL returns TRUE.

XTPDockingPaneDirection GetRTLDirection(
    XTPDockingPaneDirection direction
) const;
Parameters

direction
Docking direction

Returns

Returns the Righ-to-Left docking direction of the supplied direction if IsLayoutRTL returns TRUE. If IsLayoutRTL returns FALSE, then the direction passed in remains the same.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetShowContentsWhileDragging Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetShowContentsWhileDragging Method

Determines if "Show window contents while dragging" option is enabled

BOOL GetShowContentsWhileDragging() const;
Returns

TRUE if contents is visible while dragging.

Body Source
BOOL CXTPDockingPaneManager::GetShowContentsWhileDragging() const {
    return m_bShowContentsWhileDragging;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetSite Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetSite Method

Call this member to return the docking site of the manager.

CWnd* GetSite() const;
Returns

The docking site.

Body Source
CWnd* CXTPDockingPaneManager::GetSite() const {
    return m_pSite;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetToolTipContext Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Body Source
CXTPToolTipContext* CXTPDockingPaneManager::GetToolTipContext() const {
    return m_pToolTipContext;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::GetTopPane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::GetTopPane Method

Retrieves top level virtual container for site window.

CXTPDockingPaneBase* GetTopPane() const;
Returns

Top level container.

Remarks

Top level container always splitter container (xtpPaneTypeSplitterContainer)

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::HideClient Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::HideClient Method

Call this member to hide client area.

void HideClient(
    BOOL bHide
);
Parameters

bHide
TRUE to hide client.

Group

CXTPDockingPaneManager Methods


HidePane Method

CXTPDockingPaneManager Methods
HidePane Method
Overload List
Methods
Method | Description
CXTPDockingPaneManager::HidePane (CXTPDockingPaneBase*) | Call this member to hide a pane.
CXTPDockingPaneManager::HidePane (int) | Call this member to hide a pane.
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::HidePane Method (int)

HidePane Method, CXTPDockingPaneManager Class, Body Source
CXTPDockingPaneManager::HidePane Method (int)

Call this member to hide a pane.

void HidePane(
    int nID
);
void HidePane(
    CXTPDockingPaneBase* pPane
);
Parameters

nID
Pane's identifier.
pPane
Pane need to hide

Body Source
void CXTPDockingPaneManager::HidePane(int nID) {
    HidePane((CXTPDockingPaneBase*)FindPane(nID));
}
Group

HidePane Method


CXTPDockingPaneManager::InstallDockingPanes Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::InstallDockingPanes Method

Call this member function to install docking panes.

bool InstallDockingPanes(
    CWnd* pParent,
    bool bClipChildren = true
);
Parameters

pParent
Parent frame of the panes.
bClipChildren
'true' to add WS_CLIPCHILDREN and WS_CLIPSIBLING styles to frame windows so panes are displayed correctly displayed from a hidden state.

Returns

'true' if the Docking Pane manager was correctly initialized, otherwise returns 'false'.

Remarks

You must call this member function first to initialize the Docking Pane manager. This must be called first before any other member functions are called.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsAlphaDockingContext Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsAlphaDockingContext Method

Call this member to determine if Alpha Docking Context is used when panes are being dragged and dropped.

BOOL IsAlphaDockingContext() const;
Returns

TRUE if AlphaDockingContext is enabled, FALSE if it is disabled.

Remarks

AlphaDockingContext must be TRUE if Docking Context Stickers will be used.

See Also

SetAlphaDockingContext, IsShowDockingContextStickers, SetShowDockingContextStickers

Body Source
BOOL CXTPDockingPaneManager::IsAlphaDockingContext() const {
    return m_bAlphaDockingContext;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsCaptionMaximizeButtonsVisible Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsCaptionMaximizeButtonsVisible Method

Determines if Maximize/Restore buttons for docking panes are visible

BOOL IsCaptionMaximizeButtonsVisible() const;
See Also

ShowCaptionMaximizeButton

Body Source
BOOL CXTPDockingPaneManager::IsCaptionMaximizeButtonsVisible() const {
    return m_bShowMaximizeButton;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsClientHidden Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsClientHidden Method

Checks to see if the client is hidden.

BOOL IsClientHidden() const;
Returns

TRUE if the client is hidden, FALSE if otherwise

Body Source
BOOL CXTPDockingPaneManager::IsClientHidden() const {
    return m_bHideClient;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsKeyboardNavigateEnabled Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsKeyboardNavigateEnabled Method

Determines if Keyboard Navigate options enabled.

BOOL IsKeyboardNavigateEnabled() const;
Returns

Returns combination of XTPDockingPaneKeyboardNavigate flags indicates which keys can be used to navigate panes

See Also

EnableKeyboardNavigate, XTPDockingPaneKeyboardNavigate

Body Source
BOOL CXTPDockingPaneManager::IsKeyboardNavigateEnabled() const {
    return m_bKeyboardEnabled;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsLayoutRTL Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::IsLayoutRTL Method

Call this member to determine if the current layout is Right-to-Left (RTL).

BOOL IsLayoutRTL() const;
Returns

TRUE if the current layout is Right-to-Left (RTL), FALSE if the layout is Left-to-Right.

Group

CXTPDockingPaneManager Methods


IsPaneClosed Method

CXTPDockingPaneManager Methods
IsPaneClosed Method
Overload List
Methods
Method | Description
CXTPDockingPaneManager::IsPaneClosed (CXTPDockingPane*) | Call this member to check if the pane is closed.
CXTPDockingPaneManager::IsPaneClosed (int) | Call this member to check if the pane is closed.
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsPaneClosed Method (int)

IsPaneClosed Method, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsPaneClosed Method (int)

Call this member to check if the pane is closed.

BOOL IsPaneClosed(
    int nID
) const;
BOOL IsPaneClosed(
    CXTPDockingPane* pPane
) const;
Parameters

nID
Pane's identifier.
pPane
Pane need to close.

Returns

TRUE if the pane is closed.

Body Source
BOOL CXTPDockingPaneManager::IsPaneClosed(int nID) const {
    return IsPaneClosed(FindPane(nID));
}
Group

IsPaneClosed Method


IsPaneHidden Method

CXTPDockingPaneManager Methods
IsPaneHidden Method
Overload List
Methods
Method | Description
CXTPDockingPaneManager::IsPaneHidden (CXTPDockingPane*) | Call this member to check if the pane is hidden.
CXTPDockingPaneManager::IsPaneHidden (int) | Call this member to check if the pane is hidden.
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsPaneHidden Method (int)

IsPaneHidden Method, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsPaneHidden Method (int)

Call this member to check if the pane is hidden.

BOOL IsPaneHidden(
    int nID
) const;
BOOL IsPaneHidden(
    CXTPDockingPane* pPane
) const;
Parameters

nID
Pane's identifier.
pPane
Points to a CXTPDockingPane object.

Returns

TRUE if the pane is hidden.

Body Source
BOOL CXTPDockingPaneManager::IsPaneHidden(int nID) const {
    return IsPaneHidden(FindPane(nID));
}
Group

IsPaneHidden Method


IsPaneSelected Method

CXTPDockingPaneManager Methods
IsPaneSelected Method
Overload List
Methods
Method | Description
CXTPDockingPaneManager::IsPaneSelected (CXTPDockingPane*) | Call this member to check if the pane is selected.
CXTPDockingPaneManager::IsPaneSelected (int) | Call this member to check if the pane is selected.
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsPaneSelected Method (int)

IsPaneSelected Method, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsPaneSelected Method (int)

Call this member to check if the pane is selected.

BOOL IsPaneSelected(
    int nID
) const;
BOOL IsPaneSelected(
    CXTPDockingPane* pPane
) const;
Parameters

nID
Pane's identifier.
pPane
Points to a CXTPDockingPane object.

Returns

TRUE if the pane is selected.

Body Source
BOOL CXTPDockingPaneManager::IsPaneSelected(int nID) const {
    return IsPaneSelected(FindPane(nID));
}
Group

IsPaneSelected Method


CXTPDockingPaneManager::IsShowDockingContextStickers Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsShowDockingContextStickers Method

Call this member to determine whether Docking Context Stickers are used.

BOOL IsShowDockingContextStickers() const;
Returns

TRUE if Docking Context Stickers are used, FALSE if they are not used.

See Also

SetAlphaDockingContext, IsAlphaDockingContext, SetShowDockingContextStickers

Body Source
BOOL CXTPDockingPaneManager::IsShowDockingContextStickers() const {
    return m_bShowDockingContextStickers;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsSplittersLocked Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsSplittersLocked Method

Call this member to determine if the splitters are locked.

BOOL IsSplittersLocked() const;
Returns

TRUE if the splitters are locked; otherwise returns FALSE.

Body Source
BOOL CXTPDockingPaneManager::IsSplittersLocked() const {
    return m_bLockSplitters;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsSplitterTrackerUsed Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsSplitterTrackerUsed Method

Call this member to determine if the splitter tracker is used.

BOOL IsSplitterTrackerUsed() const;
Returns

TRUE if the splitter tracker is used; otherwise returns FALSE.

See Also

UseSplitterTracker

Body Source
BOOL CXTPDockingPaneManager::IsSplitterTrackerUsed() const {
    return m_bUseSplitterTracker;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsStickyFloatingFrames Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsStickyFloatingFrames Method

Determines if sticky floating frames option enabled

BOOL IsStickyFloatingFrames() const;
Body Source
BOOL CXTPDockingPaneManager::IsStickyFloatingFrames() const {
    return m_bStickyFloatingFrames;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::IsThemedFloatingFrames Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::IsThemedFloatingFrames Method

Determines if themes are used for the floating frames.

BOOL IsThemedFloatingFrames() const;
Returns

TRUE if they are used; otherwise returns FALSE.

Body Source
BOOL CXTPDockingPaneManager::IsThemedFloatingFrames() const {
    return m_bThemedFloatingFrames;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::LockSplitters Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::LockSplitters Method

Call this method to lock splitters.

void LockSplitters(
    BOOL bLock = TRUE
);
Parameters

bLock
TRUE to forbid splitter window panes to be resized.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::NormalizeSplitters Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::NormalizeSplitters Method

Call this method to save current splitter positions for all splitter containers

void NormalizeSplitters();
See Also

CXTPDockingPaneSplitterContainer

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::NotifyOwner Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::NotifyOwner Method

This member is called to notify the parent window that an event has occurred in the docking pane.

virtual LRESULT NotifyOwner(
    UINT nCode,
    LPARAM lParam
);
Parameters

nCode
Specifies which event has occurred.
lParam
Additional message-specific information.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::OnActivatePane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::OnActivatePane Method

This method is called when a pane activated/deactivated

virtual void OnActivatePane(
    BOOL bActive,
    CXTPDockingPane* pPane
);
Parameters

bActive
TRUE if pane activated, FALSE otherwise;
pPane
Pane was activated/deactivated.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::OnCreatePane Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::OnCreatePane Method

This method is called when a pane is created.

virtual CXTPDockingPaneBase* OnCreatePane(
    XTPDockingPaneType type,
    CXTPDockingPaneLayout* pLayout
);
Parameters

type
Type of pane that is created.
pLayout
Points to a CXTPDockingPaneLayout object.

Returns

Created pane.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::OnSetPreviewMode Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::OnSetPreviewMode Method

Call this member function to set the application's panes into and out of print-preview mode.

void OnSetPreviewMode(
    BOOL bPreview
);
Parameters

bPreview
Specifies whether or not to place the application in print-preview mode. Set to TRUE to place in print preview, FALSE to cancel preview mode.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::RecalcFrameLayout Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::RecalcFrameLayout Method

This method is called to recalculate layout of pane's site.

void RecalcFrameLayout(
    CXTPDockingPaneBase* pPane,
    BOOL bDelay = FALSE
);
Parameters

pPane
Pane which site need to recalculate
bDelay
TRUE to recalculate after small delay

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::RecalcFramesLayout Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::RecalcFramesLayout Method

Call this method to recalculate layout for all parent frames of panes.

void RecalcFramesLayout();
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::RedrawPanes Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::RedrawPanes Method

Call this member to redraw all panes.

void RedrawPanes();
Body Source
void CXTPDockingPaneManager::RedrawPanes() {
    _Redraw();
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetAlphaDockingContext Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetAlphaDockingContext Method

Call this member to specify whether an alpha docking context is used to indicate where a pane can be docked while dragging the pane.

void SetAlphaDockingContext(
    BOOL bAlphaDockingContext
);
Parameters

bAlphaDockingContext
TRUE to enable Alpha colorization while docking.

Remarks

Specifies whether the area that a docking pane can occupy is shaded in gray as the pane is dragged to its new location. The shaded area indicates the area on the application the docking pane will occupy if docked in that location. AlphaDockingContext must be TRUE if Docking Context Stickers will be used.

See Also

IsAlphaDockingContext, IsShowDockingContextStickers, SetShowDockingContextStickers

Body Source
void CXTPDockingPaneManager::SetAlphaDockingContext(BOOL bAlphaDockingContext) {
    m_bAlphaDockingContext = bAlphaDockingContext;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetAnimationDelay Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetAnimationDelay Method

Call this member to set the speed of animation.

void SetAnimationDelay(
    double dAnimationDelay = -1,
    int nAnimationDuration = 128,
    int nAnimationInterval = 16
);
Parameters

dAnimationDelay
Must be -1 to use nAnimationDuration and nAnimationInterval.
nAnimationDuration
Total time of animation, in milliseconds
nAnimationInterval
Amount of time to rest, in milliseconds, between each step.

Remarks

To disable animation set nAnimationDuration = 0.

See Also

GetAnimationDelay

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetCaptionDirection Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetCaptionDirection Method

Call this member to set direction of captions

void SetCaptionDirection(
    XTPDockingPaneCaptionDirection captionDirection
);
Parameters

captionDirection
New direction to be set

Remarks

captionDirection parameter can be one of the following:

  • xtpPaneCaptionHorizontal
  • xtpPaneCaptionVertical
  • xtpPaneCaptionAutoByPosition
  • xtpPaneCaptionAutoBySize
Example

m_paneManager.GetPaintManager()->SetCaptionDirection(xtpPaneCaptionAutoSize);

Body Source
void CXTPDockingPaneManager::SetCaptionDirection(XTPDockingPaneCaptionDirection captionDirection) {
    m_captionDirection = captionDirection;
    RedrawPanes();
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetClientMargin Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetClientMargin Method

Call this method to add margins around panes

void SetClientMargin(
    int nMargin
);
Parameters

nMargin
Width of margin for panes frame

Body Source
void CXTPDockingPaneManager::SetClientMargin(int nMargin) {
    if (m_nClientMargin != nMargin) {
        m_nClientMargin = nMargin;
        RecalcFrameLayout(NULL, TRUE);
    }
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetCustomTheme Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetCustomTheme Method

Call this member to set a custom theme. See the DockingPane sample as a sample of creating a new theme.

void SetCustomTheme(
    CXTPDockingPanePaintManager* pTheme
);
Parameters

pTheme
New Theme.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetDefaultPaneOptions Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetDefaultPaneOptions Method

Call this method to set default options for each pane

void SetDefaultPaneOptions(
    DWORD dwOptions
);
Parameters

dwOptions
Option applied for each pane. Can be any of the values listed in the Remarks section.

Remarks

dwOptions parameter can be one or more of the following:

  • xtpPaneNoCloseable Indicates the pane cannot be closed.
  • xtpPaneNoHideable Indicates the pane cannot be hidden.
  • xtpPaneNoFloatable Indicates the pane cannot be floated.
  • xtpPaneNoCaption Indicates the pane has no caption..
See Also

GetDefaultPaneOptions, CXTPDockingPane::SetOptions, XTPDockingPaneOptions

Body Source
void CXTPDockingPaneManager::SetDefaultPaneOptions(DWORD dwOptions) {
    m_dwDefaultPaneOptions = dwOptions;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetDockingContext Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetDockingContext Method

Call this method to use custom docking context.

void SetDockingContext(
    CXTPDockingPaneContext* pDockingContext
);
Parameters

pDockingContext
Points to a CXTPDockingPaneContext object

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetDockingContextStickerStyle Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetDockingContextStickerStyle Method

Call this member to set Docking Context Stickers style.

void SetDockingContextStickerStyle(
    XTPDockingContextStickerStyle style
);
Parameters

style
Style of docking pane stickers.

Remarks

Call SetShowDockingContextStickers to enable Stickers. Style parameter can be one of the following:

  • xtpPaneStickerStyleWhidbey Whidbey stickers.
  • xtpPaneStickerStyleVisualStudio2005 Visual Studio 2005 stickers.
See Also

SetShowDockingContextStickers, GetDockingContextStickerStyle

Body Source
void CXTPDockingPaneManager::SetDockingContextStickerStyle(XTPDockingContextStickerStyle style) {
    m_nDockingContextStickerStyle = style;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetFloatingFrameCaption Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetFloatingFrameCaption Method

Call this method to set common caption for floating frames.

void SetFloatingFrameCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
Caption to be set.

Body Source
void CXTPDockingPaneManager::SetFloatingFrameCaption(LPCTSTR lpszCaption) {
    m_strFloatingFrameCaption = lpszCaption;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetFloatingFramesOpacity Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetFloatingFramesOpacity Method

Call this method to set opacity for inactive floating frames

void SetFloatingFramesOpacity(
    int nOpacity
);
Parameters

nOpacity
Alpha value. When nOpacity is 0, the window is completely transparent. When nOpacity is 255, the window is opaque.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetIcon Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetIcon Method

Call this member to set an icon to the pane.

void SetIcon(
    UINT nID,
    CXTPImageManagerIconHandle hIcon
);
Parameters

nID
Docking pane's identifier.
hIcon
Icon handle.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetIcons Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetIcons Method

Call this member to set icons to panes.

BOOL SetIcons(
    UINT nIDResource,
    const int* nIDs,
    int nCount,
    COLORREF clrMask = 0xC0C0C0
);
Parameters

nIDResource
Resource Identifier.
nIDs
Pointer to an array of pane Ids.
nCount
Number of elements in the array pointed to by nIDs.
clrMask
RGB value of transparent color.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetImageManager Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetImageManager Method

Call this member to set the specified image manager.

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Points to a CXTPImageManager object.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetKeyboardWindowSelectClass Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetKeyboardWindowSelectClass Method

Call this method to set custom CXTPDockingPaneWindowSelect window, that will use to show active panes and files.

void SetKeyboardWindowSelectClass(
    CRuntimeClass* pWindowSelectClass
);
Parameters

pWindowSelectClass
CRuntimeClass pointer of custom CXTPDockingPaneWindowSelect window.

See Also

EnableKeyboardNavigate, XTPDockingPaneKeyboardNavigate

Body Source
void CXTPDockingPaneManager::SetKeyboardWindowSelectClass(CRuntimeClass* pWindowSelectClass) {
    m_pWindowSelectClass = pWindowSelectClass;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetLayout Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetLayout Method

Call this member to set the layout.

void SetLayout(
    const CXTPDockingPaneLayout* pLayout
);
Parameters

pLayout
Pointer to the existing layout.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetShowContentsWhileDragging Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetShowContentsWhileDragging Method

Call this member to set "Show window contents while dragging" option

void SetShowContentsWhileDragging(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE to set show contents while dragging

Body Source
void CXTPDockingPaneManager::SetShowContentsWhileDragging(BOOL bShow) {
    m_bShowContentsWhileDragging = bShow;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetShowDockingContextStickers Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetShowDockingContextStickers Method

Call this member to specify whether Visual Studio 2005 style Docking Context Stickers are used while dragging a docking pane.

void SetShowDockingContextStickers(
    BOOL bShowDockingContextStickers
);
Parameters

bShowDockingContextStickers
If TRUE, docking stickers are drawn on the screen indicating all the possible locations that the docking pane can be docked while the pane is dragged over the application. AlphaDockingContext must also be True to display the stickers.

Remarks

AlphaDockingContext must be TRUE if Docking Context Stickers will be used.

See Also

SetAlphaDockingContext, IsAlphaDockingContext, IsShowDockingContextStickers, SetDockingContextStickerStyle

Body Source
void CXTPDockingPaneManager::SetShowDockingContextStickers(BOOL bShowDockingContextStickers) {
    m_bShowDockingContextStickers = bShowDockingContextStickers;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetStickyFloatingFrames Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::SetStickyFloatingFrames Method

Call this method to enable sticky floating frames

void SetStickyFloatingFrames(
    BOOL bSticky
);
Parameters

bSticky
TRUE to use sticky floating frames, FALSE otherwise.

Body Source
void CXTPDockingPaneManager::SetStickyFloatingFrames(BOOL bSticky) {
    m_bStickyFloatingFrames = bSticky;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetTheme Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetTheme Method

Call this member to switch the visual theme of the panes.

void SetTheme(
    XTPDockingPanePaintTheme theme
);
Parameters

theme
New visual theme. Can be any of the values listed in the Remarks section.

Remarks

theme can be one of the following:

  • xtpPaneThemeDefault Enables the default theme.
  • xtpPaneThemeOffice Enables Visual Studio .NET style theme.
  • xtpPaneThemeGrippered Enables Visual Studio 6 style theme.
  • xtpPaneThemeVisio Enables Visio style theme.
  • xtpPaneThemeOffice2003 Enables Office 2003 style theme.
  • xtpPaneThemeNativeWinXP Enables XP Theme.
  • xtpPaneThemeWhidbey Enables Whidbey theme.
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SetThemedFloatingFrames Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SetThemedFloatingFrames Method

Call this method to use themes for floating frames.

void SetThemedFloatingFrames(
    BOOL bThemedFloatingFrames
);
Parameters

bThemedFloatingFrames
TRUE to use themed floating panes, FALSE otherwise.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::ShowCaptionMaximizeButton Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::ShowCaptionMaximizeButton Method

Call this method to show Maximize/Restore buttons for docking panes

void ShowCaptionMaximizeButton(
    BOOL bShowMaximizeButton
);
Parameters

bShowMaximizeButton
TRUE to show maximize buttons for panes

See Also

IsCaptionMaximizeButtonsVisible

Body Source
void CXTPDockingPaneManager::ShowCaptionMaximizeButton(BOOL bShowMaximizeButton) {
    m_bShowMaximizeButton = bShowMaximizeButton;
    RedrawPanes();
}
Group

CXTPDockingPaneManager Methods


ShowPane Method

CXTPDockingPaneManager Methods
ShowPane Method
Overload List
Methods
Method | Description
CXTPDockingPaneManager::ShowPane (CXTPDockingPane*, BOOL) | Call this member to show (activate) a pane
CXTPDockingPaneManager::ShowPane (int, BOOL) | Call this member to show (activate) a pane
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::ShowPane Method (int, BOOL)

ShowPane Method, CXTPDockingPaneManager Class, Body Source
CXTPDockingPaneManager::ShowPane Method (int, BOOL)

Call this member to show (activate) a pane

void ShowPane(
    int nID,
    BOOL bSetFocus = TRUE
);
void ShowPane(
    CXTPDockingPane* pPane,
    BOOL bSetFocus = TRUE
);
Parameters

nID
Pane's identifier.
bSetFocus
TRUE to set focus to selected pane
pPane
Pane need to show

Body Source
void CXTPDockingPaneManager::ShowPane(int nID, BOOL bSetFocus) {
    ShowPane(FindPane(nID), bSetFocus);
}
Group

ShowPane Method


CXTPDockingPaneManager::SyncActiveFloatingFrames Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SyncActiveFloatingFrames Method

Call this member to keep the activation of floating frames windows in sync with the activation of the top level frame window.

void SyncActiveFloatingFrames(
    BOOL bSyncActiveFloatingFrames
);
Parameters

bSyncActiveFloatingFrames
TRUE to synchronizes the activation of the mini-frame window to the activation of its parent window.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::SyncPanesState Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::SyncPanesState Method

This method updates XTP_DOCKINGPANE_INFO structure for each panes filling its members.

void SyncPanesState();
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::ToggleAutoHide Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::ToggleAutoHide Method

Call this member to switch the pane's Auto hide (docking/auto hide).

void ToggleAutoHide(
    CXTPDockingPaneBase* pPane
);
Parameters

pPane
Docking Pane.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::ToggleDocking Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::ToggleDocking Method

Call this member to switch the pane's position (docking/floating).

void ToggleDocking(
    CXTPDockingPaneBase* pPane
);
Parameters

pPane
Docking Pane.

Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::UpdatePanes Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class
CXTPDockingPaneManager::UpdatePanes Method

This method is called to update panes state

void UpdatePanes();
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager::UseSplitterTracker Method

CXTPDockingPaneManager Methods, CXTPDockingPaneManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::UseSplitterTracker Method

Call this member to use trackers.

void UseSplitterTracker(
    BOOL bSplitterTracker
);
Parameters

bSplitterTracker
TRUE to use trackers.

Remarks

This member function will display the contents for child pane while the splitter is resized if bSplitterTracker is set to FALSE.

See Also

IsSplitterTrackerUsed

Body Source
void CXTPDockingPaneManager::UseSplitterTracker(BOOL bSplitterTracker) {
    m_bUseSplitterTracker = bSplitterTracker;
}
Group

CXTPDockingPaneManager Methods


CXTPDockingPaneManager Constructors

CXTPDockingPaneManager Class, Legend, Public Methods
CXTPDockingPaneManager Constructors
Class

CXTPDockingPaneManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneManager | Constructs a CXTPDockingPaneManager object


CXTPDockingPaneManager::CXTPDockingPaneManager Constructor

CXTPDockingPaneManager Constructors, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::CXTPDockingPaneManager Constructor

Constructs a CXTPDockingPaneManager object

CXTPDockingPaneManager();
Group

CXTPDockingPaneManager Constructors


CXTPDockingPaneManager Destructors

CXTPDockingPaneManager Class, Legend, Public Methods
CXTPDockingPaneManager Destructors
Class

CXTPDockingPaneManager Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockingPaneManager | Destroys a CXTPDockingPaneManager object, handles cleanup and deallocation


CXTPDockingPaneManager::~CXTPDockingPaneManager Destructor

CXTPDockingPaneManager Destructors, CXTPDockingPaneManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneManager::~CXTPDockingPaneManager Destructor

Destroys a CXTPDockingPaneManager object, handles cleanup and deallocation

~CXTPDockingPaneManager();
Group

CXTPDockingPaneManager Destructors


CXTPDockingPaneMiniWnd Class

XTPDockingPaneMiniWnd.h, Classes, Legend, Members, Topics, CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Constructors, CXTPDockingPaneMiniWnd Destructors, CXTPDockingPaneMiniWnd Constructors, CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Destructors, CXTPDockingPaneMiniWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd Class

CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase. It is used internally as a MiniWnd container for CXTPDockingPaneBase derived classes.

Class Hierarchy

class CXTPDockingPaneMiniWnd : public CMiniFrameWnd, public CXTPDockingPaneBase;
File

XTPDockingPaneMiniWnd.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneMiniWnd Constructors
CXTPDockingPaneMiniWnd Constructors | Description
CXTPDockingPaneMiniWnd | Constructs a CXTPDockingPaneMiniWnd object.
CXTPDockingPaneMiniWnd Data Members
CXTPDockingPaneMiniWnd Data Members | Description
m_bCloseEnabled | Close button of frame is enabled.
m_bCollapsed | Pane is collapsed
m_bDelayInvalidate | True to redraw frame after small delay
m_bExpanded | Pane is collapsed but expanded now
m_bShowPinButton | TRUE to show pin button of the frame.
m_bSlideOut | Pane is currently expanding.
m_nDeactivationCount | Deactivation counter.
m_nExpandedHeight | Expanded height of the frame.
m_nSlideStep | Current step of animation process
m_nStepsCount | Total steps of animation process
m_pTopContainer | Top level container.
CXTPDockingPaneMiniWnd Destructors
CXTPDockingPaneMiniWnd Destructors | Description
~CXTPDockingPaneMiniWnd | Destroys a CXTPDockingPaneMiniWnd object, handles cleanup and deallocation.
CXTPDockingPaneMiniWnd Methods
CXTPDockingPaneMiniWnd Methods | Description
Collapse | This method is called to collapse frame.
Copy | Copies self data from another pane
Create | Creates frame window
DoPropExchange | Call this member function to save/restore the settings of the pane.
DoSlideStep | This method is called to animate collapsed frame
Expand | Call this method to expand collapsed frame.
FindPane | Call this member to retrieve a collection of the panes with specified type.
GetPaneHwnd | Retrieves safe window handle.
GetSelectedPane | Call this member to determine the currently selected pane
GetTopPane | Retrieves top level container of floating frame
Init | Initialize the frame window
InvalidatePane | This member is called when a need to redraw pane.
IsActive | Determines if the frame is active
IsCaptionButtonVisible | Call this member to determine if a specific caption button is visible.
IsCollapsed | Determines if frame is collapsed
IsThemed | Call this member to determine if themed floating panes are used.
OnAction | This method is called if some action occur
OnCaptionButtonClick | This member is called by the framework when a caption button is clicked.
OnCaptionButtonDown | This member is called by the framework when the mouse button is pressed on a caption button.
OnChildContainerChanged | This member is called when a child pane collection is changed.
OnFocusChanged | This method is called when focus was changed inside application
OnPinButtonClick | This member is called when the "pin" caption button is clicked.
OnThemedChanged | This member is called when the theme is changed.
RedrawPane | Call this method to redraw frame
RemovePane | Call this member to remove a pane from collection.
UpdateWindowOpacity | This member is called to update Opacity of floating frame


CXTPDockingPaneMiniWnd Data Members

CXTPDockingPaneMiniWnd Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd Data Members
Class

CXTPDockingPaneMiniWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bCloseEnabled | Close button of frame is enabled.
m_bCollapsed | Pane is collapsed
m_bDelayInvalidate | True to redraw frame after small delay
m_bExpanded | Pane is collapsed but expanded now
m_bSlideOut | Pane is currently expanding.
m_nDeactivationCount | Deactivation counter.
m_nExpandedHeight | Expanded height of the frame.
m_nSlideStep | Current step of animation process
m_nStepsCount | Total steps of animation process
m_pTopContainer | Top level container.
Public Data Members
Public Data Member | Description
m_bShowPinButton | TRUE to show pin button of the frame.


CXTPDockingPaneMiniWnd::m_bCloseEnabled Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_bCloseEnabled Data Member

Close button of frame is enabled.

BOOL m_bCloseEnabled;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_bCollapsed Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_bCollapsed Data Member

Pane is collapsed

BOOL m_bCollapsed;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_bDelayInvalidate Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_bDelayInvalidate Data Member

True to redraw frame after small delay

BOOL m_bDelayInvalidate;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_bExpanded Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_bExpanded Data Member

Pane is collapsed but expanded now

BOOL m_bExpanded;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_bShowPinButton Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_bShowPinButton Data Member

TRUE to show pin button of the frame.

BOOL m_bShowPinButton;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_bSlideOut Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_bSlideOut Data Member

Pane is currently expanding.

BOOL m_bSlideOut;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_nDeactivationCount Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_nDeactivationCount Data Member

Deactivation counter.

int m_nDeactivationCount;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_nExpandedHeight Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_nExpandedHeight Data Member

Expanded height of the frame.

int m_nExpandedHeight;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_nSlideStep Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_nSlideStep Data Member

Current step of animation process

int m_nSlideStep;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_nStepsCount Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_nStepsCount Data Member

Total steps of animation process

int m_nStepsCount;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd::m_pTopContainer Data Member

CXTPDockingPaneMiniWnd Data Members, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::m_pTopContainer Data Member

Top level container.

CXTPDockingPaneSplitterContainer* m_pTopContainer;
Group

CXTPDockingPaneMiniWnd Data Members


CXTPDockingPaneMiniWnd Methods

CXTPDockingPaneMiniWnd Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd Methods
Class

CXTPDockingPaneMiniWnd Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | Copies self data from another pane
Create | Creates frame window
DoPropExchange | Call this member function to save/restore the settings of the pane.
DoSlideStep | This method is called to animate collapsed frame
FindPane | Call this member to retrieve a collection of the panes with specified type.
GetPaneHwnd | Retrieves safe window handle.
GetSelectedPane | Call this member to determine the currently selected pane
Init | Initialize the frame window
InvalidatePane | This member is called when a need to redraw pane.
IsCaptionButtonVisible | Call this member to determine if a specific caption button is visible.
IsThemed | Call this member to determine if themed floating panes are used.
OnAction | This method is called if some action occur
OnCaptionButtonClick | This member is called by the framework when a caption button is clicked.
OnCaptionButtonDown | This member is called by the framework when the mouse button is pressed on a caption button.
OnChildContainerChanged | This member is called when a child pane collection is changed.
OnFocusChanged | This method is called when focus was changed inside application
OnPinButtonClick | This member is called when the "pin" caption button is clicked.
OnThemedChanged | This member is called when the theme is changed.
RedrawPane | Call this method to redraw frame
RemovePane | Call this member to remove a pane from collection.
UpdateWindowOpacity | This member is called to update Opacity of floating frame
Public Methods
Public Methods
Public Method | Description
Collapse | This method is called to collapse frame.
Expand | Call this method to expand collapsed frame.
GetTopPane | Retrieves top level container of floating frame
IsActive | Determines if the frame is active
IsCollapsed | Determines if frame is collapsed


CXTPDockingPaneMiniWnd::Collapse Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::Collapse Method

This method is called to collapse frame.

void Collapse(
    BOOL bDelay = FALSE
);
Parameters

bDelay
TRUE to collapse after small delay with animation.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::Copy Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::Copy Method

Copies self data from another pane

virtual void Copy(
    CXTPDockingPaneBase* pClone,
    CXTPPaneToPaneMap* pMap,
    DWORD dwIgnoredOptions
);
Parameters

pClone
Pane which members need to copy.
pMap
Internal parameter needs to map pane to copied pane.

See Also

CXTPPaneToPaneMap

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::Create Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::Create Method

Creates frame window

virtual BOOL Create(
    CRect rc
);
Parameters

rc
Specifies the size and position of the window

Returns

Nonzero if initialization is successful; otherwise 0.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::DoPropExchange Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::DoPropExchange Method

Call this member function to save/restore the settings of the pane.

virtual BOOL DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Points to a CXTPPropExchange object.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::DoSlideStep Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::DoSlideStep Method

This method is called to animate collapsed frame

void DoSlideStep(
    BOOL bActivate = FALSE
);
Parameters

bActivate
TRUE to activate frame.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::Expand Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::Expand Method

Call this method to expand collapsed frame.

void Expand();
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::FindPane Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::FindPane Method

Call this member to retrieve a collection of the panes with specified type.

virtual void FindPane(
    XTPDockingPaneType type,
    CXTPDockingPaneBaseList* pList
) const;
Parameters

type
Type of the panes to find.
pList
Points to a CXTPDockingPaneBaseList object that will contain found panes.

See Also

CXTPDockingPaneBaseList

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::GetPaneHwnd Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::GetPaneHwnd Method

Retrieves safe window handle.

virtual HWND GetPaneHwnd() const;
Body Source
HWND CXTPDockingPaneMiniWnd::GetPaneHwnd() const {
    return CWnd::GetSafeHwnd();
}
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::GetSelectedPane Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::GetSelectedPane Method

Call this member to determine the currently selected pane

CXTPDockingPane* GetSelectedPane() const;
Returns

Pointer to a CXTPDockingPane object that is the currently selected pane.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::GetTopPane Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::GetTopPane Method

Retrieves top level container of floating frame

CXTPDockingPaneSplitterContainer* GetTopPane() const;
Returns

Pointer to top container of frame

Body Source
CXTPDockingPaneSplitterContainer* CXTPDockingPaneMiniWnd::GetTopPane() const {
    return m_pTopContainer;
}
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::Init Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::Init Method

Initialize the frame window

virtual void Init(
    CXTPDockingPaneBase* pPane,
    CRect rc
);
Parameters

pPane
Child pane will be placed to frame
rc
Rectangle of floating frame.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::InvalidatePane Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::InvalidatePane Method

This member is called when a need to redraw pane.

virtual void InvalidatePane(
    BOOL bSelectionChanged
);
Parameters

bSelectionChanged
TRUE if selected pane was changed

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::IsActive Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::IsActive Method

Determines if the frame is active

BOOL IsActive() const;
Returns

TRUE if the frame is active

Body Source
BOOL CXTPDockingPaneMiniWnd::IsActive() const {
    return m_bActive;
}
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::IsCaptionButtonVisible Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::IsCaptionButtonVisible Method

Call this member to determine if a specific caption button is visible.

virtual BOOL IsCaptionButtonVisible(
    CXTPDockingPaneCaptionButton* pButton
);
Parameters

pButton
Button to check to see if it is visible.

Returns

TRUE if the caption button specified is visible, FALSE otherwise.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::IsCollapsed Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::IsCollapsed Method

Determines if frame is collapsed

BOOL IsCollapsed() const;
Body Source
BOOL CXTPDockingPaneMiniWnd::IsCollapsed() const {
    return m_bCollapsed;
}
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::IsThemed Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::IsThemed Method

Call this member to determine if themed floating panes are used.

BOOL IsThemed() const;
Returns

TRUE is themed floating panes are used, FALSE otherwise.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::OnAction Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::OnAction Method

This method is called if some action occur

BOOL OnAction(
    XTPDockingPaneAction action
);
Parameters

action
Docking Pane action.

Returns

TRUE if action was canceled

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::OnCaptionButtonClick Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::OnCaptionButtonClick Method

This member is called by the framework when a caption button is clicked.

virtual void OnCaptionButtonClick(
    CXTPDockingPaneCaptionButton* pButton
);
Parameters

pButton
Caption button that was clicked.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::OnCaptionButtonDown Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::OnCaptionButtonDown Method

This member is called by the framework when the mouse button is pressed on a caption button.

virtual BOOL OnCaptionButtonDown(
    CXTPDockingPaneCaptionButton* pButton
);
Parameters

pButton
Caption button that is being clicked.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::OnChildContainerChanged Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::OnChildContainerChanged Method

This member is called when a child pane collection is changed.

virtual void OnChildContainerChanged(
    CXTPDockingPaneBase* pContainer
);
Parameters

pContainer
Points to a CXTPDockingPaneBase object that is changed.

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::OnFocusChanged Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::OnFocusChanged Method

This method is called when focus was changed inside application

void OnFocusChanged();
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::OnPinButtonClick Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::OnPinButtonClick Method

This member is called when the "pin" caption button is clicked.

void OnPinButtonClick();
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::OnThemedChanged Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::OnThemedChanged Method

This member is called when the theme is changed.

void OnThemedChanged();
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::RedrawPane Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::RedrawPane Method

Call this method to redraw frame

void RedrawPane();
Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::RemovePane Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class
CXTPDockingPaneMiniWnd::RemovePane Method

Call this member to remove a pane from collection.

virtual void RemovePane(
    CXTPDockingPaneBase* pPane
);
Parameters

pPane
Points to a CXTPDockingPaneBase need to remove

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd::UpdateWindowOpacity Method

CXTPDockingPaneMiniWnd Methods, CXTPDockingPaneMiniWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::UpdateWindowOpacity Method

This member is called to update Opacity of floating frame

virtual void UpdateWindowOpacity();
See Also

CXTPDockingPaneManager::SetFloatingFramesOpacity

Group

CXTPDockingPaneMiniWnd Methods


CXTPDockingPaneMiniWnd Constructors

CXTPDockingPaneMiniWnd Class, Legend, Protected Methods
CXTPDockingPaneMiniWnd Constructors
Class

CXTPDockingPaneMiniWnd Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneMiniWnd | Constructs a CXTPDockingPaneMiniWnd object.


CXTPDockingPaneMiniWnd::CXTPDockingPaneMiniWnd Constructor

CXTPDockingPaneMiniWnd Constructors, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::CXTPDockingPaneMiniWnd Constructor

Constructs a CXTPDockingPaneMiniWnd object.

CXTPDockingPaneMiniWnd(
    CXTPDockingPaneLayout* pLayout
);
Parameters

pLayout
Parent layout pointer.

Group

CXTPDockingPaneMiniWnd Constructors


CXTPDockingPaneMiniWnd Destructors

CXTPDockingPaneMiniWnd Class, Legend, Protected Methods
CXTPDockingPaneMiniWnd Destructors
Class

CXTPDockingPaneMiniWnd Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPaneMiniWnd | Destroys a CXTPDockingPaneMiniWnd object, handles cleanup and deallocation.


CXTPDockingPaneMiniWnd::~CXTPDockingPaneMiniWnd Destructor

CXTPDockingPaneMiniWnd Destructors, CXTPDockingPaneMiniWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneMiniWnd::~CXTPDockingPaneMiniWnd Destructor

Destroys a CXTPDockingPaneMiniWnd object, handles cleanup and deallocation.

~CXTPDockingPaneMiniWnd();
Group

CXTPDockingPaneMiniWnd Destructors


CXTPDockingPaneNativeXPTheme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneNativeXPTheme Methods, CXTPDockingPaneNativeXPTheme Constructors, CXTPDockingPaneNativeXPTheme Constructors, CXTPDockingPaneNativeXPTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneNativeXPTheme Class

CXTPDockingPaneNativeXPTheme is CXTPDockingPaneOfficeTheme derived class, represents Win XP theme for docking panes.

Class Hierarchy

class CXTPDockingPaneNativeXPTheme : public CXTPDockingPaneOfficeTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeNativeWinXP); to set this theme.

Group

Classes

Legend
Method
virtual
protected
CXTPDockingPaneNativeXPTheme Constructors
CXTPDockingPaneNativeXPTheme Constructors | Description
CXTPDockingPaneNativeXPTheme | Constructs a CXTPDockingPaneNativeXPTheme object.
CXTPDockingPaneNativeXPTheme Methods
CXTPDockingPaneNativeXPTheme Methods | Description
DrawCaption | Override this member function to draw a caption.
DrawCaptionPart | Draw common part of tabbed and floating caption.
DrawFloatingFrame | Call this method to draw frame of floating window
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneNativeXPTheme Methods

CXTPDockingPaneNativeXPTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneNativeXPTheme Methods
Class

CXTPDockingPaneNativeXPTheme Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionPart | Draw common part of tabbed and floating caption.
Public Methods
Public Methods
Public Method | Description
DrawCaption | Override this member function to draw a caption.
DrawFloatingFrame | Call this method to draw frame of floating window
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneNativeXPTheme::DrawCaption Method

CXTPDockingPaneNativeXPTheme Methods, CXTPDockingPaneNativeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneNativeXPTheme::DrawCaption Method

Override this member function to draw a caption.

virtual void DrawCaption(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneNativeXPTheme Methods


CXTPDockingPaneNativeXPTheme::DrawCaptionPart Method

CXTPDockingPaneNativeXPTheme Methods, CXTPDockingPaneNativeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneNativeXPTheme::DrawCaptionPart Method

Draw common part of tabbed and floating caption.

virtual void DrawCaptionPart(
    CDC* pDC,
    CXTPDockingPaneBase* pPane,
    CRect rcCaption,
    const CString& strTitle,
    BOOL bActive,
    BOOL bVertical
);
Parameters

pPane
Container which caption need to draw.
rcCaption
Caption bounding rectangle
strTitle
Caption text.
bActive
TRUE if caption is active.
bVertical
TRUE to draw caption vertically
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneNativeXPTheme Methods


CXTPDockingPaneNativeXPTheme::DrawFloatingFrame Method

CXTPDockingPaneNativeXPTheme Methods, CXTPDockingPaneNativeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneNativeXPTheme::DrawFloatingFrame Method

Call this method to draw frame of floating window

void DrawFloatingFrame(
    CDC* pDC,
    CXTPDockingPaneMiniWnd* pPane,
    CRect rc
);
Parameters

pPane
Floating window pointer
rc
CLient rectangle of floating frame
dc
Pointer to a valid device context

Group

CXTPDockingPaneNativeXPTheme Methods


CXTPDockingPaneNativeXPTheme::RefreshMetrics Method

CXTPDockingPaneNativeXPTheme Methods, CXTPDockingPaneNativeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneNativeXPTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

virtual void RefreshMetrics();
Group

CXTPDockingPaneNativeXPTheme Methods


CXTPDockingPaneNativeXPTheme Constructors

CXTPDockingPaneNativeXPTheme Class, Legend, Public Methods
CXTPDockingPaneNativeXPTheme Constructors
Class

CXTPDockingPaneNativeXPTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneNativeXPTheme | Constructs a CXTPDockingPaneNativeXPTheme object.


CXTPDockingPaneNativeXPTheme::CXTPDockingPaneNativeXPTheme Constructor

CXTPDockingPaneNativeXPTheme Constructors, CXTPDockingPaneNativeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneNativeXPTheme::CXTPDockingPaneNativeXPTheme Constructor

Constructs a CXTPDockingPaneNativeXPTheme object.

CXTPDockingPaneNativeXPTheme();
Group

CXTPDockingPaneNativeXPTheme Constructors


CXTPDockingPaneOffice2003Theme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneOffice2003Theme Data Members, CXTPDockingPaneOffice2003Theme Methods, CXTPDockingPaneOffice2003Theme Constructors, CXTPDockingPaneOffice2003Theme Destructors, CXTPDockingPaneOffice2003Theme Constructors, CXTPDockingPaneOffice2003Theme Data Members, CXTPDockingPaneOffice2003Theme Destructors, CXTPDockingPaneOffice2003Theme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme Class

CXTPDockingPaneOffice2003Theme is CXTPDockingPaneOfficeTheme derived class, represents Office 2003 theme for docking panes.

Class Hierarchy

class CXTPDockingPaneOffice2003Theme : public CXTPDockingPaneOfficeTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2003); to set this theme.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneOffice2003Theme Constructors
CXTPDockingPaneOffice2003Theme Constructors | Description
CXTPDockingPaneOffice2003Theme | Constructs a CXTPDockingPaneOffice2003Theme object.
CXTPDockingPaneOffice2003Theme Data Members
CXTPDockingPaneOffice2003Theme Data Members | Description
m_bDrawGripper | TRUE to draw gripper
m_bRoundedCaption | TRUE to draw rounded caption
CXTPDockingPaneOffice2003Theme Destructors
CXTPDockingPaneOffice2003Theme Destructors | Description
~CXTPDockingPaneOffice2003Theme | Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.
CXTPDockingPaneOffice2003Theme Methods
CXTPDockingPaneOffice2003Theme Methods | Description
DrawCaption | Override this member function to draw a caption.
DrawCaptionPart | Draw common part of tabbed and floating caption.
DrawFloatingFrame | Call this method to draw frame of floating window
GetCaptionGripperRect | Call this method to get caption gripper for tabbed container
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneOffice2003Theme Data Members

CXTPDockingPaneOffice2003Theme Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme Data Members
Class

CXTPDockingPaneOffice2003Theme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bRoundedCaption | TRUE to draw rounded caption
Public Data Members
Public Data Member | Description
m_bDrawGripper | TRUE to draw gripper


CXTPDockingPaneOffice2003Theme::m_bDrawGripper Data Member

CXTPDockingPaneOffice2003Theme Data Members, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::m_bDrawGripper Data Member

TRUE to draw gripper

BOOL m_bDrawGripper;
Group

CXTPDockingPaneOffice2003Theme Data Members


CXTPDockingPaneOffice2003Theme::m_bRoundedCaption Data Member

CXTPDockingPaneOffice2003Theme Data Members, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::m_bRoundedCaption Data Member

TRUE to draw rounded caption

BOOL m_bRoundedCaption;
Group

CXTPDockingPaneOffice2003Theme Data Members


CXTPDockingPaneOffice2003Theme Methods

CXTPDockingPaneOffice2003Theme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme Methods
Class

CXTPDockingPaneOffice2003Theme Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionPart | Draw common part of tabbed and floating caption.
Public Methods
Public Methods
Public Method | Description
DrawCaption | Override this member function to draw a caption.
DrawFloatingFrame | Call this method to draw frame of floating window
GetCaptionGripperRect | Call this method to get caption gripper for tabbed container
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneOffice2003Theme::DrawCaption Method

CXTPDockingPaneOffice2003Theme Methods, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::DrawCaption Method

Override this member function to draw a caption.

virtual void DrawCaption(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneOffice2003Theme Methods


CXTPDockingPaneOffice2003Theme::DrawCaptionPart Method

CXTPDockingPaneOffice2003Theme Methods, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::DrawCaptionPart Method

Draw common part of tabbed and floating caption.

virtual void DrawCaptionPart(
    CDC* pDC,
    CXTPDockingPaneBase* pPane,
    CRect rcCaption,
    const CString& strTitle,
    BOOL bActive,
    BOOL bVertical
);
Parameters

pPane
Container which caption need to draw.
rcCaption
Caption bounding rectangle
strTitle
Caption text.
bActive
TRUE if caption is active.
bVertical
TRUE to draw caption vertically
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneOffice2003Theme Methods


CXTPDockingPaneOffice2003Theme::DrawFloatingFrame Method

CXTPDockingPaneOffice2003Theme Methods, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::DrawFloatingFrame Method

Call this method to draw frame of floating window

virtual void DrawFloatingFrame(
    CDC* pDC,
    CXTPDockingPaneMiniWnd* pPane,
    CRect rc
);
Parameters

pPane
Floating window pointer
rc
Client rectangle of floating frame
dc
Pointer to a valid device context

Group

CXTPDockingPaneOffice2003Theme Methods


CXTPDockingPaneOffice2003Theme::GetCaptionGripperRect Method

CXTPDockingPaneOffice2003Theme Methods, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::GetCaptionGripperRect Method

Call this method to get caption gripper for tabbed container

virtual CRect GetCaptionGripperRect(
    const CXTPDockingPaneTabbedContainer* pPane
);
Parameters

pPane
Tabbed container to test

Returns

Bounding rectangle of gripper to set size cursor

Group

CXTPDockingPaneOffice2003Theme Methods


CXTPDockingPaneOffice2003Theme::RefreshMetrics Method

CXTPDockingPaneOffice2003Theme Methods, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

virtual void RefreshMetrics();
Group

CXTPDockingPaneOffice2003Theme Methods


CXTPDockingPaneOffice2003Theme Constructors

CXTPDockingPaneOffice2003Theme Class, Legend, Public Methods
CXTPDockingPaneOffice2003Theme Constructors
Class

CXTPDockingPaneOffice2003Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneOffice2003Theme | Constructs a CXTPDockingPaneOffice2003Theme object.


CXTPDockingPaneOffice2003Theme::CXTPDockingPaneOffice2003Theme Constructor

CXTPDockingPaneOffice2003Theme Constructors, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::CXTPDockingPaneOffice2003Theme Constructor

Constructs a CXTPDockingPaneOffice2003Theme object.

CXTPDockingPaneOffice2003Theme();
Group

CXTPDockingPaneOffice2003Theme Constructors


CXTPDockingPaneOffice2003Theme Destructors

CXTPDockingPaneOffice2003Theme Class, Legend, Public Methods
CXTPDockingPaneOffice2003Theme Destructors
Class

CXTPDockingPaneOffice2003Theme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockingPaneOffice2003Theme | Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.


CXTPDockingPaneOffice2003Theme::~CXTPDockingPaneOffice2003Theme Destructor

CXTPDockingPaneOffice2003Theme Destructors, CXTPDockingPaneOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2003Theme::~CXTPDockingPaneOffice2003Theme Destructor

Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.

virtual ~CXTPDockingPaneOffice2003Theme();
Group

CXTPDockingPaneOffice2003Theme Destructors


CXTPDockingPaneOffice2007Theme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneOffice2007Theme Methods, CXTPDockingPaneOffice2007Theme Constructors, CXTPDockingPaneOffice2007Theme Constructors, CXTPDockingPaneOffice2007Theme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2007Theme Class

CXTPDockingPaneOffice2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2007 theme for docking panes.

Class Hierarchy

class CXTPDockingPaneOffice2007Theme : public CXTPDockingPaneOffice2003Theme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2007); to set this theme.

Group

Classes

Legend
Method
CXTPDockingPaneOffice2007Theme Constructors
CXTPDockingPaneOffice2007Theme Constructors | Description
CXTPDockingPaneOffice2007Theme | Constructs a CXTPDockingPaneOffice2007Theme object.
CXTPDockingPaneOffice2007Theme Methods
CXTPDockingPaneOffice2007Theme Methods | Description
DrawCaption | Override this member function to draw a caption.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneOffice2007Theme Methods

CXTPDockingPaneOffice2007Theme Class, Legend, Public Methods
CXTPDockingPaneOffice2007Theme Methods
Class

CXTPDockingPaneOffice2007Theme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawCaption | Override this member function to draw a caption.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneOffice2007Theme::DrawCaption Method

CXTPDockingPaneOffice2007Theme Methods, CXTPDockingPaneOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2007Theme::DrawCaption Method

Override this member function to draw a caption.

void DrawCaption(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneOffice2007Theme Methods


CXTPDockingPaneOffice2007Theme::RefreshMetrics Method

CXTPDockingPaneOffice2007Theme Methods, CXTPDockingPaneOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2007Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

void RefreshMetrics();
Group

CXTPDockingPaneOffice2007Theme Methods


CXTPDockingPaneOffice2007Theme Constructors

CXTPDockingPaneOffice2007Theme Class, Legend, Public Methods
CXTPDockingPaneOffice2007Theme Constructors
Class

CXTPDockingPaneOffice2007Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneOffice2007Theme | Constructs a CXTPDockingPaneOffice2007Theme object.


CXTPDockingPaneOffice2007Theme::CXTPDockingPaneOffice2007Theme Constructor

CXTPDockingPaneOffice2007Theme Constructors, CXTPDockingPaneOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOffice2007Theme::CXTPDockingPaneOffice2007Theme Constructor

Constructs a CXTPDockingPaneOffice2007Theme object.

CXTPDockingPaneOffice2007Theme();
Group

CXTPDockingPaneOffice2007Theme Constructors


CXTPDockingPaneOfficeTheme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneOfficeTheme Data Members, CXTPDockingPaneOfficeTheme Methods, CXTPDockingPaneOfficeTheme Constructors, CXTPDockingPaneOfficeTheme Constructors, CXTPDockingPaneOfficeTheme Data Members, CXTPDockingPaneOfficeTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOfficeTheme Class

CXTPDockingPaneOfficeTheme is CXTPDockingPaneGripperedTheme derived class, represents Office XP theme for docking panes.

Class Hierarchy

class CXTPDockingPaneOfficeTheme : public CXTPDockingPaneGripperedTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice); to set this theme.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneOfficeTheme Constructors
CXTPDockingPaneOfficeTheme Constructors | Description
CXTPDockingPaneOfficeTheme | Constructs a CXTPDockingPaneOfficeTheme object.
CXTPDockingPaneOfficeTheme Data Members
CXTPDockingPaneOfficeTheme Data Members | Description
m_bGradientCaption | TRUE to draw gradient caption.
CXTPDockingPaneOfficeTheme Methods
CXTPDockingPaneOfficeTheme Methods | Description
DrawCaptionPart | Draw common part of tabbed and floating caption.
FillCaptionPart | Draws the background of the pane caption.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneOfficeTheme Data Members

CXTPDockingPaneOfficeTheme Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOfficeTheme Data Members
Class

CXTPDockingPaneOfficeTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bGradientCaption | TRUE to draw gradient caption.


CXTPDockingPaneOfficeTheme::m_bGradientCaption Data Member

CXTPDockingPaneOfficeTheme Data Members, CXTPDockingPaneOfficeTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOfficeTheme::m_bGradientCaption Data Member

TRUE to draw gradient caption.

BOOL m_bGradientCaption;
Group

CXTPDockingPaneOfficeTheme Data Members


CXTPDockingPaneOfficeTheme Methods

CXTPDockingPaneOfficeTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOfficeTheme Methods
Class

CXTPDockingPaneOfficeTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionPart | Draw common part of tabbed and floating caption.
FillCaptionPart | Draws the background of the pane caption.
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneOfficeTheme::DrawCaptionPart Method

CXTPDockingPaneOfficeTheme Methods, CXTPDockingPaneOfficeTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOfficeTheme::DrawCaptionPart Method

Draw common part of tabbed and floating caption.

virtual void DrawCaptionPart(
    CDC* pDC,
    CXTPDockingPaneBase* pPane,
    CRect rcCaption,
    const CString& strTitle,
    BOOL bActive,
    BOOL bVertical
);
Parameters

pPane
Container which caption need to draw.
rcCaption
Caption bounding rectangle
strTitle
Caption text.
bActive
TRUE if caption is active.
bVertical
TRUE to draw caption vertically
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneOfficeTheme Methods


CXTPDockingPaneOfficeTheme::FillCaptionPart Method

CXTPDockingPaneOfficeTheme Methods, CXTPDockingPaneOfficeTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOfficeTheme::FillCaptionPart Method

Draws the background of the pane caption.

virtual COLORREF FillCaptionPart(
    CDC* pDC,
    CXTPDockingPaneBase* pPane,
    CRect rcCaption,
    BOOL bActive,
    BOOL bVertical
);
Parameters

pPane
Container of the caption needs to draw the background.
rcCaption
Caption bounding rectangle
bActive
TRUE if caption is active.
bVertical
TRUE to draw caption vertically
dc
Reference to the device context in which to draw.
strTitle
Caption text.

Group

CXTPDockingPaneOfficeTheme Methods


CXTPDockingPaneOfficeTheme::RefreshMetrics Method

CXTPDockingPaneOfficeTheme Methods, CXTPDockingPaneOfficeTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOfficeTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

virtual void RefreshMetrics();
Group

CXTPDockingPaneOfficeTheme Methods


CXTPDockingPaneOfficeTheme Constructors

CXTPDockingPaneOfficeTheme Class, Legend, Public Methods
CXTPDockingPaneOfficeTheme Constructors
Class

CXTPDockingPaneOfficeTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneOfficeTheme | Constructs a CXTPDockingPaneOfficeTheme object.


CXTPDockingPaneOfficeTheme::CXTPDockingPaneOfficeTheme Constructor

CXTPDockingPaneOfficeTheme Constructors, CXTPDockingPaneOfficeTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneOfficeTheme::CXTPDockingPaneOfficeTheme Constructor

Constructs a CXTPDockingPaneOfficeTheme object.

CXTPDockingPaneOfficeTheme();
Group

CXTPDockingPaneOfficeTheme Constructors


CXTPDockingPanePaintManager Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Constructors, CXTPDockingPanePaintManager Destructors, CXTPDockingPanePaintManager Constructors, CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Destructors, CXTPDockingPanePaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager Class

CXTPDockingPanePaintManager is a stand alone class. Override some virtual functions to get a new visual theme.

Class Hierarchy

class CXTPDockingPanePaintManager;
File

XTPDockingPanePaintManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
abstract
CXTPDockingPanePaintManager Constructors
CXTPDockingPanePaintManager Constructors | Description
CXTPDockingPanePaintManager | Constructs a CXTPDockingPanePaintManager object
CXTPDockingPanePaintManager Data Members
CXTPDockingPanePaintManager Data Members | Description
m_arrColor | Self colors array.
m_bDrawCaptionIcon | TRUE to draw caption icon
m_bDrawSingleTab | TRUE to draw single tab.
m_bHighlightActiveCaption | TRUE to highlight active caption.
m_bLunaTheme | TRUE if luna colors user
m_bShowCaption | TRUE to draw captions of tabbed containers
m_bUseBoldCaptionFont | TRUE to use Bold font for caption
m_bUseOfficeFont | TRUE to use Tahoma font.
m_bUseStandardFont | TRUE to use system icon font.
m_clrActiveCaption | Color of pane caption when active.
m_clrActiveCaptionText | Active caption text
m_clrDisabledCaptionText | Disabled caption text
m_clrNormalCaption | Color of pane caption when inactive.
m_clrNormalCaptionText | Color of pane caption text when the caption is inactive
m_clrSplitter | Splitter color
m_clrSplitterGradient | Splitter color
m_clrSplitterGripper | Splitter gripper color
m_dwSplitterStyle | Splitter style
m_fntTitle | Title font.
m_fntTitleVertical | Title vertical font.
m_nCaptionButtonStyle | Caption button style
m_nCaptionFontGap | Additional gap of font.
m_nSplitterSize | Splitter size
m_nTabsHeight | Tab bar's height.
m_nTitleHeight | Title's height.
m_pPanelPaintManager | Paint Manager used to draw tabs for auto-hide panel
m_pTabPaintManager | Paint Manager used to draw tabs for tabbed container
m_rcCaptionMargin | Margins of caption.
m_strOfficeFont | Office font name.
m_systemTheme | Current system theme.
m_themeButton | WinXP Button theme helper
m_themeCurrent | Current theme.
m_themeExplorer | WinXP Explorer theme helper
m_themeToolbar | Toolbar theme helper
m_themeWindow | WinXP Window Theme helper.
CXTPDockingPanePaintManager Destructors
CXTPDockingPanePaintManager Destructors | Description
~CXTPDockingPanePaintManager | Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation
CXTPDockingPanePaintManager Methods
CXTPDockingPanePaintManager Methods | Description
AdjustCaptionRect | Override this member to change the caption rectangle of the child docking pane.
AdjustClientRect | Override this member to change the client rectangle of the child docking pane.
DrawCaption | Override this member function to draw a caption.
DrawCaptionButton | Override this member function to draw button of tabbed caption.
DrawCaptionButtonEntry | Draws only the glyph of a button. For example, the cross of a Close Button.
DrawCaptionButtons | Override this member function to draw buttons of tabbed caption.
DrawCaptionText | Draws the text of a pane caption.
DrawFloatingFrame | Call this method to draw frame of floating window
DrawPane | Override this member function to draw a tabbed container.
DrawSidePanel |
DrawSplitter | Override this method to draw splitter.
GetCaptionButtonStyle | Call this method to get caption button styles
GetCaptionGripperRect | Call this method to get caption gripper for tabbed container
GetCaptionHeight | Call this member to get caption height of tabbed container
GetCurrentSystemTheme | Call this member function to determine the current Windows XP theme in use.
GetPanelPaintManager | Retrieves pointer to CXTPTabPaintManager used to draw tabs of panel.
GetSplitterStyle | Call this method to get splitter styles
GetTabPaintManager | Retrieves pointer to CXTPTabPaintManager used to draw tabs of tabbed container.
GetTabsHeight | Call this member to get tabs height of tabbed container
GetXtremeColor | Retrieves the current color of the specified XP display element.
Line |
Pixel | Sets the pixel at the point.
Rectangle | Draws a rectangle.
RefreshMetrics | This method is called to refresh the visual metrics of manager.
SetCaptionButtonStyle | Call this member to set caption buttons style.
SetCaptionFontIndirect | Call this method to change caption font
SetColors | Call this member to set the colors for each element to the color in the specified color array.
SetLunaTheme | Call this method to force system theme.
SetPanelPaintManager | Call this method to set Paint manager used for tabs of panel.
SetSplitterStyle | Call this member to set splitter style.
SetTabPaintManager | Call this method to set Paint manager used for tabs of tabbed container.
UseOfficeFont | Call this member to use office (Tahoma) font.


CXTPDockingPanePaintManager Data Members

CXTPDockingPanePaintManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager Data Members
Class

CXTPDockingPanePaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrColor | Self colors array.
m_bLunaTheme | TRUE if luna colors user
m_bUseOfficeFont | TRUE to use Tahoma font.
m_bUseStandardFont | TRUE to use system icon font.
m_dwSplitterStyle | Splitter style
m_fntTitle | Title font.
m_fntTitleVertical | Title vertical font.
m_nCaptionButtonStyle | Caption button style
m_nCaptionFontGap | Additional gap of font.
m_nTabsHeight | Tab bar's height.
m_nTitleHeight | Title's height.
m_pPanelPaintManager | Paint Manager used to draw tabs for auto-hide panel
m_pTabPaintManager | Paint Manager used to draw tabs for tabbed container
m_rcCaptionMargin | Margins of caption.
m_strOfficeFont | Office font name.
m_systemTheme | Current system theme.
m_themeButton | WinXP Button theme helper
m_themeCurrent | Current theme.
m_themeExplorer | WinXP Explorer theme helper
m_themeToolbar | Toolbar theme helper
m_themeWindow | WinXP Window Theme helper.
Public Data Members
Public Data Member | Description
m_bDrawCaptionIcon | TRUE to draw caption icon
m_bDrawSingleTab | TRUE to draw single tab.
m_bHighlightActiveCaption | TRUE to highlight active caption.
m_bShowCaption | TRUE to draw captions of tabbed containers
m_bUseBoldCaptionFont | TRUE to use Bold font for caption
m_clrActiveCaption | Color of pane caption when active.
m_clrActiveCaptionText | Active caption text
m_clrDisabledCaptionText | Disabled caption text
m_clrNormalCaption | Color of pane caption when inactive.
m_clrNormalCaptionText | Color of pane caption text when the caption is inactive
m_clrSplitter | Splitter color
m_clrSplitterGradient | Splitter color
m_clrSplitterGripper | Splitter gripper color
m_nSplitterSize | Splitter size


CXTPDockingPanePaintManager::m_arrColor Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_arrColor Data Member

Self colors array.

COLORREF m_arrColor[XPCOLOR_LAST + 1];
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_bDrawCaptionIcon Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_bDrawCaptionIcon Data Member

TRUE to draw caption icon

BOOL m_bDrawCaptionIcon;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_bDrawSingleTab Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_bDrawSingleTab Data Member

TRUE to draw single tab.

BOOL m_bDrawSingleTab;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_bHighlightActiveCaption Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_bHighlightActiveCaption Data Member

TRUE to highlight active caption.

BOOL m_bHighlightActiveCaption;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_bLunaTheme Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_bLunaTheme Data Member

TRUE if luna colors user

BOOL m_bLunaTheme;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_bShowCaption Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_bShowCaption Data Member

TRUE to draw captions of tabbed containers

BOOL m_bShowCaption;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_bUseBoldCaptionFont Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_bUseBoldCaptionFont Data Member

TRUE to use Bold font for caption

BOOL m_bUseBoldCaptionFont;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_bUseOfficeFont Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_bUseOfficeFont Data Member

TRUE to use Tahoma font.

BOOL m_bUseOfficeFont;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_bUseStandardFont Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_bUseStandardFont Data Member

TRUE to use system icon font.

BOOL m_bUseStandardFont;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_clrActiveCaption Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_clrActiveCaption Data Member

Color of pane caption when active.

CXTPPaintManagerColorGradient m_clrActiveCaption;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_clrActiveCaptionText Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_clrActiveCaptionText Data Member

Active caption text

CXTPPaintManagerColor m_clrActiveCaptionText;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_clrDisabledCaptionText Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_clrDisabledCaptionText Data Member

Disabled caption text

CXTPPaintManagerColor m_clrDisabledCaptionText;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_clrNormalCaption Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_clrNormalCaption Data Member

Color of pane caption when inactive.

CXTPPaintManagerColorGradient m_clrNormalCaption;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_clrNormalCaptionText Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_clrNormalCaptionText Data Member

Color of pane caption text when the caption is inactive

CXTPPaintManagerColor m_clrNormalCaptionText;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_clrSplitter Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_clrSplitter Data Member

Splitter color

CXTPPaintManagerColor m_clrSplitter;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_clrSplitterGradient Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_clrSplitterGradient Data Member

Splitter color

CXTPPaintManagerColorGradient m_clrSplitterGradient;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_clrSplitterGripper Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_clrSplitterGripper Data Member

Splitter gripper color

CXTPPaintManagerColor m_clrSplitterGripper;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_dwSplitterStyle Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_dwSplitterStyle Data Member

Splitter style

DWORD m_dwSplitterStyle;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_fntTitle Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_fntTitle Data Member

Title font.

CFont m_fntTitle;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_fntTitleVertical Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_fntTitleVertical Data Member

Title vertical font.

CFont m_fntTitleVertical;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_nCaptionButtonStyle Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_nCaptionButtonStyle Data Member

Caption button style

XTPDockingPaneCaptionButtonStyle m_nCaptionButtonStyle;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_nCaptionFontGap Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_nCaptionFontGap Data Member

Additional gap of font.

int m_nCaptionFontGap;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_nSplitterSize Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_nSplitterSize Data Member

Splitter size

int m_nSplitterSize;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_nTabsHeight Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_nTabsHeight Data Member

Tab bar's height.

int m_nTabsHeight;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_nTitleHeight Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_nTitleHeight Data Member

Title's height.

int m_nTitleHeight;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_pPanelPaintManager Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_pPanelPaintManager Data Member

Paint Manager used to draw tabs for auto-hide panel

CXTPTabPaintManager* m_pPanelPaintManager;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_pTabPaintManager Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_pTabPaintManager Data Member

Paint Manager used to draw tabs for tabbed container

CXTPTabPaintManager* m_pTabPaintManager;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_rcCaptionMargin Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_rcCaptionMargin Data Member

Margins of caption.

CRect m_rcCaptionMargin;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_strOfficeFont Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_strOfficeFont Data Member

Office font name.

CString m_strOfficeFont;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_systemTheme Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_systemTheme Data Member

Current system theme.

XTPCurrentSystemTheme m_systemTheme;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_themeButton Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_themeButton Data Member

WinXP Button theme helper

CXTPWinThemeWrapper m_themeButton;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_themeCurrent Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_themeCurrent Data Member

Current theme.

XTPDockingPanePaintTheme m_themeCurrent;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_themeExplorer Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_themeExplorer Data Member

WinXP Explorer theme helper

CXTPWinThemeWrapper m_themeExplorer;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_themeToolbar Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_themeToolbar Data Member

Toolbar theme helper

CXTPWinThemeWrapper m_themeToolbar;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager::m_themeWindow Data Member

CXTPDockingPanePaintManager Data Members, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::m_themeWindow Data Member

WinXP Window Theme helper.

CXTPWinThemeWrapper m_themeWindow;
Group

CXTPDockingPanePaintManager Data Members


CXTPDockingPanePaintManager Methods

CXTPDockingPanePaintManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager Methods
Class

CXTPDockingPanePaintManager Class

Legend
Method
virtual
abstract
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionButtonEntry | Draws only the glyph of a button. For example, the cross of a Close Button.
Public Methods
Public Methods
Public Method | Description
AdjustCaptionRect | Override this member to change the caption rectangle of the child docking pane.
AdjustClientRect | Override this member to change the client rectangle of the child docking pane.
DrawCaption | Override this member function to draw a caption.
DrawCaptionButton | Override this member function to draw button of tabbed caption.
DrawCaptionButtons | Override this member function to draw buttons of tabbed caption.
DrawCaptionText | Draws the text of a pane caption.
DrawFloatingFrame | Call this method to draw frame of floating window
DrawPane | Override this member function to draw a tabbed container.
DrawSidePanel |
DrawSplitter | Override this method to draw splitter.
GetCaptionButtonStyle | Call this method to get caption button styles
GetCaptionGripperRect | Call this method to get caption gripper for tabbed container
GetCaptionHeight | Call this member to get caption height of tabbed container
GetCurrentSystemTheme | Call this member function to determine the current Windows XP theme in use.
GetPanelPaintManager | Retrieves pointer to CXTPTabPaintManager used to draw tabs of panel.
GetSplitterStyle | Call this method to get splitter styles
GetTabPaintManager | Retrieves pointer to CXTPTabPaintManager used to draw tabs of tabbed container.
GetTabsHeight | Call this member to get tabs height of tabbed container
GetXtremeColor | Retrieves the current color of the specified XP display element.
Line |
Pixel | Sets the pixel at the point.
Rectangle | Draws a rectangle.
RefreshMetrics | This method is called to refresh the visual metrics of manager.
SetCaptionButtonStyle | Call this member to set caption buttons style.
SetCaptionFontIndirect | Call this method to change caption font
SetColors | Call this member to set the colors for each element to the color in the specified color array.
SetLunaTheme | Call this method to force system theme.
SetPanelPaintManager | Call this method to set Paint manager used for tabs of panel.
SetSplitterStyle | Call this member to set splitter style.
SetTabPaintManager | Call this method to set Paint manager used for tabs of tabbed container.
UseOfficeFont | Call this member to use office (Tahoma) font.


CXTPDockingPanePaintManager::AdjustCaptionRect Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::AdjustCaptionRect Method

Override this member to change the caption rectangle of the child docking pane.

virtual void AdjustCaptionRect(
    const CXTPDockingPaneTabbedContainer* pPane,
    CRect& rc
);
Parameters

pPane
Pointer to a CXTPDockingPaneTabbedContainer object.
rc
Caption rectangle to be changed.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::AdjustClientRect Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::AdjustClientRect Method

Override this member to change the client rectangle of the child docking pane.

virtual void AdjustClientRect(
    CXTPDockingPaneTabbedContainer* pPane,
    CRect& rect,
    BOOL bApply
);
Parameters

pPane
Pointer to the tabbed container.
rect
Client rectangle to be changed.
bApply
TRUE to update tabs inside client area.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawCaption Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawCaption Method

Override this member function to draw a caption.

virtual void DrawCaption(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
) = 0;
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawCaptionButton Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawCaptionButton Method

Override this member function to draw button of tabbed caption.

virtual void DrawCaptionButton(
    CDC* pDC,
    CXTPDockingPaneCaptionButton* pButton,
    COLORREF clrButton
);
Parameters

pDC
Pointer to a valid device context
pButton
Button pointer need to draw.
clrButton
Color of button text.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawCaptionButtonEntry Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawCaptionButtonEntry Method

Draws only the glyph of a button. For example, the cross of a Close Button.

virtual void DrawCaptionButtonEntry(
    CDC* pDC,
    CXTPDockingPaneCaptionButton* pButton,
    CPoint pt,
    COLORREF clrButton
);
Parameters

pDC
Pointer to the device context in which to draw.
pButton
Button pointer need to draw.
pt
Center point.
clrButton
Color of glyph.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawCaptionButtons Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawCaptionButtons Method

Override this member function to draw buttons of tabbed caption.

virtual void DrawCaptionButtons(
    CDC* pDC,
    CXTPDockingPaneCaptionButtons* pButtons,
    CRect& rcCaption,
    COLORREF clr,
    int nButtonSize,
    int nButtonGap,
    BOOL bVertical = FALSE
);
Parameters

pDC
Pointer to a valid device context
pButtons
Collection of buttons to draw.
rcCaption
Caption rectangle
clr
Color of button text.
nButtonSize
Size of button
nButtonGap
Distance between buttons.
bVertical
TRUE if caption drawn vertically

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawCaptionText Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawCaptionText Method

Draws the text of a pane caption.

int DrawCaptionText(
    CDC* pDC,
    const CString& strTitle,
    CRect rc,
    BOOL bVertical,
    BOOL bCalcWidth = FALSE
);
Parameters

strTitle
Text to draw in caption.
rc
Client rectangle of the tabbed container
bVertical
TRUE to draw caption vertically
bCalcWidth
TRUE to calculate width
dc
Reference to a valid device context

Returns

The width of the text that was drawn in the pane caption bar.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawFloatingFrame Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawFloatingFrame Method

Call this method to draw frame of floating window

virtual void DrawFloatingFrame(
    CDC* pDC,
    CXTPDockingPaneMiniWnd* pPane,
    CRect rc
);
Parameters

pPane
Floating window pointer
rc
Client rectangle of floating frame
dc
Pointer to a valid device context

Body Source
void CXTPDockingPanePaintManager::DrawFloatingFrame(CDC* /*pDC*/, CXTPDockingPaneMiniWnd* /*pPane*/, CRect /*rc*/) {
}
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawPane Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawPane Method

Override this member function to draw a tabbed container.

virtual void DrawPane(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawSidePanel Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawSidePanel Method
virtual void DrawSidePanel(
    CDC* pDC,
    CXTPDockingPaneSidePanel* pPane,
    CRect rc
);
Body Source
void CXTPDockingPanePaintManager::DrawSidePanel(CDC* /*pDC*/, CXTPDockingPaneSidePanel* /*pPane*/, CRect /*rc*/) {
}
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::DrawSplitter Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::DrawSplitter Method

Override this method to draw splitter.

virtual void DrawSplitter(
    CDC* pDC,
    CXTPDockingPaneSplitterWnd* pSplitter
);
Parameters

pSplitter
Pointer to splitter window
dc
Pointer to a valid device context

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetCaptionButtonStyle Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetCaptionButtonStyle Method

Call this method to get caption button styles

XTPDockingPaneCaptionButtonStyle GetCaptionButtonStyle() const;
See Also

XTPDockingPaneCaptionButtonStyle, SetCaptionButtonStyle

Body Source
XTPDockingPaneCaptionButtonStyle CXTPDockingPanePaintManager::GetCaptionButtonStyle() const {
    return m_nCaptionButtonStyle;
}
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetCaptionGripperRect Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetCaptionGripperRect Method

Call this method to get caption gripper for tabbed container

virtual CRect GetCaptionGripperRect(
    const CXTPDockingPaneTabbedContainer* pPane
);
Parameters

pPane
Tabbed container to test

Returns

Bounding rectangle of gripper to set size cursor

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetCaptionHeight Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetCaptionHeight Method

Call this member to get caption height of tabbed container

int GetCaptionHeight() const;
See Also

GetTabsHeight

Body Source
int CXTPDockingPanePaintManager::GetCaptionHeight() const {
    return m_nTitleHeight;
}
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetCurrentSystemTheme Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetCurrentSystemTheme Method

Call this member function to determine the current Windows XP theme in use.

XTPCurrentSystemTheme GetCurrentSystemTheme() const;
Returns

A XTPCurrentSystemTheme enumeration that represents the current Windows theme in use, can be one of the following values:

  • xtpSystemThemeUnknown Indicates no known theme in use
  • xtpSystemThemeBlue Indicates blue theme in use
  • xtpSystemThemeOlive Indicates olive theme in use
  • xtpSystemThemeSilver Indicates silver theme in use
See Also

SetLunaTheme, RefreshLunaColors

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetPanelPaintManager Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetPanelPaintManager Method

Retrieves pointer to CXTPTabPaintManager used to draw tabs of panel.

CXTPTabPaintManager* GetPanelPaintManager() const;
Returns

Pointer used to draw tabs of auto-hide panel.

See Also

SetPanelPaintManager, GetTabPaintManager

Body Source
CXTPTabPaintManager* CXTPDockingPanePaintManager::GetPanelPaintManager() const {
    return m_pPanelPaintManager;
}
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetSplitterStyle Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetSplitterStyle Method

Call this method to get splitter styles

DWORD GetSplitterStyle() const;
See Also

XTPDockingPaneSplitterStyle, SetSplitterStyle

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetTabPaintManager Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetTabPaintManager Method

Retrieves pointer to CXTPTabPaintManager used to draw tabs of tabbed container.

CXTPTabPaintManager* GetTabPaintManager() const;
Returns

Pointer used to draw tabs of tabbed container.

See Also

SetTabPaintManager, GetPanelPaintManager

Body Source
CXTPTabPaintManager* CXTPDockingPanePaintManager::GetTabPaintManager() const {
    return m_pTabPaintManager;
}
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetTabsHeight Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetTabsHeight Method

Call this member to get tabs height of tabbed container

int GetTabsHeight() const;
See Also

GetCaptionHeight

Body Source
int CXTPDockingPanePaintManager::GetTabsHeight() const{
    return m_nTabsHeight;
}
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::GetXtremeColor Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::GetXtremeColor Method

Retrieves the current color of the specified XP display element.

COLORREF GetXtremeColor(
    UINT nIndex
);
Parameters

nIndex
Specifies the display element whose color is to be retrieved. This parameter can be one of the following values displayed in the table below:

Returns

The red, green, blue (RGB) color value of the given element.

Remarks

Display elements are the parts of a window and the display that appear on the system display screen. The function returns the red, green, blue (RGB) color value of the given element. To provide a consistent look to all Windows applications, the operating system provides and maintains global settings that define the colors of various aspects of the display. These settings as a group are sometimes referred to as a "color scheme." To view the current color settings, click Control Panel, double-click the Display icon, and then click the "Appearance" tab.

Constant | Value | Description
COLOR_SCROLLBAR | 0 | Scroll bar color
COLOR_BACKGROUND | 1 | Desktop color
COLOR_ACTIVECAPTION | 2 | Color of the title bar for the active window, Specifies the left side color in the color gradient of an active window's title bar if the gradient effect is enabled.
COLOR_INACTIVECAPTION | 3 | Color of the title bar for the inactive window, Specifies the left side color in the color gradient of an inactive window's title bar if the gradient effect is enabled.
COLOR_MENU | 4 | Menu background color
COLOR_WINDOW | 5 | Window background color
COLOR_WINDOWFRAME | 6 | Window frame color
COLOR_MENUTEXT | 7 | Color of text on menus
COLOR_WINDOWTEXT | 8 | Color of text in windows
COLOR_CAPTIONTEXT | 9 | Color of text in caption, size box, and scroll arrow
COLOR_ACTIVEBORDER | 10 | Border color of active window
COLOR_INACTIVEBORDER | 11 | Border color of inactive window
COLOR_APPWORKSPACE | 12 | Background color of multiple-document interface (MDI) applications
COLOR_HIGHLIGHT | 13 | Background color of items selected in a control
COLOR_HIGHLIGHTTEXT | 14 | Text color of items selected in a control
COLOR_BTNFACE | 15 | Face color for three-dimensional display elements and for dialog box backgrounds.
COLOR_BTNSHADOW | 16 | Color of shading on the edge of command buttons
COLOR_GRAYTEXT | 17 | Grayed (disabled) text
COLOR_BTNTEXT | 18 | Text color on push buttons
COLOR_INACTIVECAPTIONTEXT | 19 | Color of text in an inactive caption
COLOR_BTNHIGHLIGHT | 20 | Highlight color for 3-D display elements
COLOR_3DDKSHADOW | 21 | Darkest shadow color for 3-D display elements
COLOR_3DLIGHT | 22 | Second lightest 3-D color after 3DHighlight, Light color for three-dimensional display elements (for edges facing the light source.)
COLOR_INFOTEXT | 23 | Color of text in ToolTips
COLOR_INFOBK | 24 | Background color of ToolTips
COLOR_HOTLIGHT | 26 | Color for a hot-tracked item. Single clicking a hot-tracked item executes the item.
COLOR_GRADIENTACTIVECAPTION | 27 | Right side color in the color gradient of an active window's title bar. COLOR_ACTIVECAPTION specifies the left side color.
COLOR_GRADIENTINACTIVECAPTION | 28 | Right side color in the color gradient of an inactive window's title bar. COLOR_INACTIVECAPTION specifies the left side color.
XPCOLOR_TOOLBAR_FACE | 30 | XP toolbar background color.
XPCOLOR_HIGHLIGHT | 31 | XP menu item selected color.
XPCOLOR_HIGHLIGHT_BORDER | 32 | XP menu item selected border color.
XPCOLOR_HIGHLIGHT_PUSHED | 33 | XP menu item pushed color.
XPCOLOR_HIGHLIGHT_CHECKED | 36 | XP menu item checked color.
XPCOLOR_HIGHLIGHT_CHECKED_BORDER | 37 | An RGB value that represents the XP menu item checked border color.
XPCOLOR_ICONSHADDOW | 34 | XP menu item icon shadow.
XPCOLOR_GRAYTEXT | 35 | XP menu item disabled text color.
XPCOLOR_TOOLBAR_GRIPPER | 38 | XP toolbar gripper color.
XPCOLOR_SEPARATOR | 39 | XP toolbar separator color.
XPCOLOR_DISABLED | 40 | XP menu icon disabled color.
XPCOLOR_MENUBAR_FACE | 41 | XP menu item text background color.
XPCOLOR_MENUBAR_EXPANDED | 42 | XP hidden menu commands background color.
XPCOLOR_MENUBAR_BORDER | 43 | XP menu border color.
XPCOLOR_MENUBAR_TEXT | 44 | XP menu item text color.
XPCOLOR_HIGHLIGHT_TEXT | 45 | XP menu item selected text color.
XPCOLOR_TOOLBAR_TEXT | 46 | XP toolbar text color.
XPCOLOR_PUSHED_TEXT | 47 | XP toolbar pushed text color.
XPCOLOR_TAB_INACTIVE_BACK | 48 | XP inactive tab background color.
XPCOLOR_TAB_INACTIVE_TEXT | 49 | XP inactive tab text color.
XPCOLOR_HIGHLIGHT_PUSHED_BORDER | 50 | An RGB value that represents the XP border color for pushed in 3D elements.
XPCOLOR_CHECKED_TEXT | 45 | XP color for text displayed in a checked button.
XPCOLOR_3DFACE | 51 | XP face color for three- dimensional display elements and for dialog box backgrounds.
XPCOLOR_3DSHADOW | 52 | XP shadow color for three-dimensional display elements (for edges facing away from the light source).
XPCOLOR_EDITCTRLBORDER | 53 | XP color for the border color of edit controls.
XPCOLOR_FRAME | 54 | Office 2003 frame color.
XPCOLOR_SPLITTER_FACE | 55 | XP splitter face color.
XPCOLOR_LABEL | 56 | Color for label control (xtpControlLabel)
XPCOLOR_STATICFRAME | 57 | WinXP Static frame color
Group

CXTPDockingPanePaintManager Methods


Line Method

CXTPDockingPanePaintManager Methods
Line Method
Overload List
Methods
Method | Description
CXTPDockingPanePaintManager::Line (CDC*, int, int, int, int) | Draws a line.
CXTPDockingPanePaintManager::Line (CDC*, int, int, int, int, int) | Draws a line.
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::Line Method (CDC*, int, int, int, int, int)

Line Method, CXTPDockingPanePaintManager Class
CXTPDockingPanePaintManager::Line Method (CDC*, int, int, int, int, int)

Draws a line.

void Line(
    CDC* pDC,
    int x0,
    int y0,
    int x1,
    int y1,
    int nPen
);
void Line(
    CDC* pDC,
    int x0,
    int y0,
    int x1,
    int y1
);
Parameters

pDC
Pointer to a valid device context
x0
Specifies the logical x-coordinate of the start position.
y0
Specifies the logical y-coordinate of the start position.
x1
Specifies the logical x-coordinate of the endpoint for the line.
y1
Specifies the logical y-coordinate of the endpoint for the line.
nPen
Specifies the color used to paint the line.

Group

Line Method


CXTPDockingPanePaintManager::Pixel Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::Pixel Method

Sets the pixel at the point.

void Pixel(
    CDC* pDC,
    int xPos,
    int yPos,
    int nPen
);
Parameters

pDC
Pointer to a valid device context
xPos
Specifies the logical x-coordinate of the point to be set.
yPos
Specifies the logical y-coordinate of the point to be set.
nPen
Specifies the color used to paint the point

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::Rectangle Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::Rectangle Method

Draws a rectangle.

void Rectangle(
    CDC* pDC,
    CRect rc,
    int nPenEntry,
    int nPenBorder
);
Parameters

pDC
Pointer to a valid device context
rc
Specifies the rectangle in logical units.
nPenEntry
Specifies the color used to paint the rectangle.
nPenBorder
Specifies the color used to fill the rectangle.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::RefreshMetrics Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::RefreshMetrics Method

This method is called to refresh the visual metrics of manager.

virtual void RefreshMetrics();
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::SetCaptionButtonStyle Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::SetCaptionButtonStyle Method

Call this member to set caption buttons style.

void SetCaptionButtonStyle(
    XTPDockingPaneCaptionButtonStyle nStyle
);
Parameters

nStyle
New style of caption buttons

Remarks

dwStyle parameter can be one or more of the following:

  • xtpPaneCaptionButtonDefault
  • xtpPaneCaptionButtonOffice
  • xtpPaneCaptionButtonOffice2003
  • xtpPaneCaptionButtonThemeExplorerBar
  • xtpPaneCaptionButtonThemeButton
  • xtpPaneCaptionButtonThemeToolBar
See Also

XTPDockingPaneCaptionButtonStyle, GetCaptionButtonStyle

Example

m_paneManager.GetPaintManager()->SetCaptionButtonStyle(xtpPaneCaptionButtonOffice2003);

Body Source
void CXTPDockingPanePaintManager::SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) {
    m_nCaptionButtonStyle = nStyle;
}
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::SetCaptionFontIndirect Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::SetCaptionFontIndirect Method

Call this method to change caption font

void SetCaptionFontIndirect(
    LOGFONT* pLogFont,
    BOOL bUseStandardFont = FALSE
);
Parameters

pLogFont
LOGFONT of caption to use
bUseStandardFont
Must be FALSE

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::SetColors Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::SetColors Method

Call this member to set the colors for each element to the color in the specified color array.

void SetColors(
    int cElements,
    CONST INT * lpaElements,
    CONST COLORREF* lpaRgbValues
);
Parameters

cElements
Number of elements in array.
lpaElements
Array of elements.
lpaRgbValues
Array of RGB values.

See Also

SetColor

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::SetLunaTheme Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::SetLunaTheme Method

Call this method to force system theme.

void SetLunaTheme(
    XTPCurrentSystemTheme systemTheme
);
Parameters

systemTheme
theme to use. Can be any of the values listed in the Remarks section.

Remarks

theme can be one of the following:

  • xtpSystemThemeUnknown Disables luna theme support.
  • xtpSystemThemeBlue Enables blue theme
  • xtpSystemThemeOlive Enables olive theme
  • xtpSystemThemeSilver Enables silver theme
Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::SetPanelPaintManager Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::SetPanelPaintManager Method

Call this method to set Paint manager used for tabs of panel.

CXTPTabPaintManager* SetPanelPaintManager(
    CXTPTabPaintManager* pManager
);
Parameters

pManager
New CXTPTabPaintManager pointer

Returns

CXTPTabPaintManager pointer that will be used.

See Also

GetPanelPaintManager, SetTabPaintManager

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::SetSplitterStyle Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::SetSplitterStyle Method

Call this member to set splitter style.

void SetSplitterStyle(
    DWORD dwStyle
);
Parameters

dwStyle
New style of splitters

Remarks

dwStyle parameter can be one or more of the following:

  • xtpPaneSplitterFlat
  • xtpPaneSplitter3D
  • xtpPaneSplitterSoft3D
  • xtpPaneSplitterGripperOfficeXP
  • xtpPaneSplitterGripperOffice2003
Example

m_paneManager.GetPaintManager()->SetSplitterStyle(xtpPaneSplitterSoft3D + xtpPaneSplitterGripperOffice2003);

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::SetTabPaintManager Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::SetTabPaintManager Method

Call this method to set Paint manager used for tabs of tabbed container.

CXTPTabPaintManager* SetTabPaintManager(
    CXTPTabPaintManager* pManager
);
Parameters

pManager
New CXTPTabPaintManager pointer

Returns

CXTPTabPaintManager pointer that will be used.

See Also

GetTabPaintManager, SetPanelPaintManager

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager::UseOfficeFont Method

CXTPDockingPanePaintManager Methods, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::UseOfficeFont Method

Call this member to use office (Tahoma) font.

void UseOfficeFont(
    BOOL bUseOfficeFont
);
Parameters

bUseOfficeFont
TRUE to use office font.

Group

CXTPDockingPanePaintManager Methods


CXTPDockingPanePaintManager Constructors

CXTPDockingPanePaintManager Class, Legend, Protected Methods
CXTPDockingPanePaintManager Constructors
Class

CXTPDockingPanePaintManager Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPanePaintManager | Constructs a CXTPDockingPanePaintManager object


CXTPDockingPanePaintManager::CXTPDockingPanePaintManager Constructor

CXTPDockingPanePaintManager Constructors, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::CXTPDockingPanePaintManager Constructor

Constructs a CXTPDockingPanePaintManager object

CXTPDockingPanePaintManager();
Group

CXTPDockingPanePaintManager Constructors


CXTPDockingPanePaintManager Destructors

CXTPDockingPanePaintManager Class, Legend, Protected Methods
CXTPDockingPanePaintManager Destructors
Class

CXTPDockingPanePaintManager Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPanePaintManager | Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation


CXTPDockingPanePaintManager::~CXTPDockingPanePaintManager Destructor

CXTPDockingPanePaintManager Destructors, CXTPDockingPanePaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPanePaintManager::~CXTPDockingPanePaintManager Destructor

Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation

virtual ~CXTPDockingPanePaintManager();
Group

CXTPDockingPanePaintManager Destructors


CXTPDockingPaneShortcutBar2003Theme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneShortcutBar2003Theme Methods, CXTPDockingPaneShortcutBar2003Theme Constructors, CXTPDockingPaneShortcutBar2003Theme Destructors, CXTPDockingPaneShortcutBar2003Theme Constructors, CXTPDockingPaneShortcutBar2003Theme Destructors, CXTPDockingPaneShortcutBar2003Theme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneShortcutBar2003Theme Class

CXTPDockingPaneShortcutBar2003Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2003 theme for docking panes.

Class Hierarchy

class CXTPDockingPaneShortcutBar2003Theme : public CXTPDockingPaneOffice2003Theme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeShortcutBar2003); to set this theme.

Group

Classes

Legend
Method
virtual
CXTPDockingPaneShortcutBar2003Theme Constructors
CXTPDockingPaneShortcutBar2003Theme Constructors | Description
CXTPDockingPaneShortcutBar2003Theme | Constructs a CXTPDockingPaneShortcutBar2003Theme object.
CXTPDockingPaneShortcutBar2003Theme Destructors
CXTPDockingPaneShortcutBar2003Theme Destructors | Description
~CXTPDockingPaneShortcutBar2003Theme | Destroys a CXTPDockingPaneShortcutBar2003Theme object, handles cleanup and deallocation.
CXTPDockingPaneShortcutBar2003Theme Methods
CXTPDockingPaneShortcutBar2003Theme Methods | Description
GetCaptionGripperRect | Call this method to get caption gripper for tabbed container
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneShortcutBar2003Theme Methods

CXTPDockingPaneShortcutBar2003Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneShortcutBar2003Theme Methods
Class

CXTPDockingPaneShortcutBar2003Theme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetCaptionGripperRect | Call this method to get caption gripper for tabbed container
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneShortcutBar2003Theme::GetCaptionGripperRect Method

CXTPDockingPaneShortcutBar2003Theme Methods, CXTPDockingPaneShortcutBar2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneShortcutBar2003Theme::GetCaptionGripperRect Method

Call this method to get caption gripper for tabbed container

virtual CRect GetCaptionGripperRect(
    const CXTPDockingPaneTabbedContainer* pPane
);
Parameters

pPane
Tabbed container to test

Returns

Bounding rectangle of gripper to set size cursor

Group

CXTPDockingPaneShortcutBar2003Theme Methods


CXTPDockingPaneShortcutBar2003Theme::RefreshMetrics Method

CXTPDockingPaneShortcutBar2003Theme Methods, CXTPDockingPaneShortcutBar2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneShortcutBar2003Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

virtual void RefreshMetrics();
Group

CXTPDockingPaneShortcutBar2003Theme Methods


CXTPDockingPaneShortcutBar2003Theme Constructors

CXTPDockingPaneShortcutBar2003Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneShortcutBar2003Theme Constructors
Class

CXTPDockingPaneShortcutBar2003Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneShortcutBar2003Theme | Constructs a CXTPDockingPaneShortcutBar2003Theme object.


CXTPDockingPaneShortcutBar2003Theme::CXTPDockingPaneShortcutBar2003Theme Constructor

CXTPDockingPaneShortcutBar2003Theme Constructors, CXTPDockingPaneShortcutBar2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneShortcutBar2003Theme::CXTPDockingPaneShortcutBar2003Theme Constructor

Constructs a CXTPDockingPaneShortcutBar2003Theme object.

CXTPDockingPaneShortcutBar2003Theme();
Group

CXTPDockingPaneShortcutBar2003Theme Constructors


CXTPDockingPaneShortcutBar2003Theme Destructors

CXTPDockingPaneShortcutBar2003Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneShortcutBar2003Theme Destructors
Class

CXTPDockingPaneShortcutBar2003Theme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDockingPaneShortcutBar2003Theme | Destroys a CXTPDockingPaneShortcutBar2003Theme object, handles cleanup and deallocation.


CXTPDockingPaneShortcutBar2003Theme::~CXTPDockingPaneShortcutBar2003Theme Destructor

CXTPDockingPaneShortcutBar2003Theme Destructors, CXTPDockingPaneShortcutBar2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneShortcutBar2003Theme::~CXTPDockingPaneShortcutBar2003Theme Destructor

Destroys a CXTPDockingPaneShortcutBar2003Theme object, handles cleanup and deallocation.

virtual ~CXTPDockingPaneShortcutBar2003Theme();
Group

CXTPDockingPaneShortcutBar2003Theme Destructors


CXTPDockingPaneSplitterContainer Class

XTPDockingPaneSplitterContainer.h, Classes, Legend, Members, Topics, CXTPDockingPaneSplitterContainer Data Members, CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Constructors, CXTPDockingPaneSplitterContainer Destructors, CXTPDockingPaneSplitterContainer Constructors, CXTPDockingPaneSplitterContainer Data Members, CXTPDockingPaneSplitterContainer Destructors, CXTPDockingPaneSplitterContainer Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer Class

CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class. It is used internally as a splitter container for CXTPDockingPaneBase derived classes.

Class Hierarchy

class CXTPDockingPaneSplitterContainer : public CXTPDockingPaneBaseContainer;
File

XTPDockingPaneSplitterContainer.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneSplitterContainer Constructors
CXTPDockingPaneSplitterContainer Constructors | Description
CXTPDockingPaneSplitterContainer | Constructs a CXTPDockingPaneSplitterContainer object.
CXTPDockingPaneSplitterContainer Data Members
CXTPDockingPaneSplitterContainer Data Members | Description
m_bHoriz | TRUE if the splitter orientation is horizontal
m_bRecalcLayout | TRUE if RecalcLayout method currently executed.
m_lstSpliters | List of splitter windows
CXTPDockingPaneSplitterContainer Destructors
CXTPDockingPaneSplitterContainer Destructors | Description
~CXTPDockingPaneSplitterContainer | Destroys a CXTPDockingPaneSplitterContainer object, handles cleanup and deallocation
CXTPDockingPaneSplitterContainer Methods
CXTPDockingPaneSplitterContainer Methods | Description
Copy | Copies a CXTPDockingPaneSplitterContainer object
DeletePane | This method is called to destroy pane
DoPropExchange | This member is called to save/restore the settings of the pane.
FindChildPane | Call this member to retrieve a collection of the panes with the specified type only within the splitter container's child panes.
GetMinMaxInfo | Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the splitter container. This will look at the MinMaxInfo for each pane in the splitter container and set the appropriate minimum and maximum width and height for the splitter container.
Init | Constructs a CXTPDockingPaneSplitterContainer object Protected constructor. Internally constructed only.
IsHoriz | Call this member to determine if the splitter orientation is horizontal.
NormalizeDockingSize | This member is called to normalize the size of docking panes in the splitter container. Normalizing the size of the panes means that the value of the left coordinate is less than the right and the top is less than the bottom.
OnChildContainerChanged | This member is called when a child pane collection is changed.
OnCreateSplitter | This member is called by the framework when a splitter container is created.
OnParentContainerChanged | This member is called when the parent pane collection is changed.
OnSizeParent | This method is called to set the position of the pane.
RemovePane | This member is called to remove a pane from the collection.


CXTPDockingPaneSplitterContainer Data Members

CXTPDockingPaneSplitterContainer Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer Data Members
Class

CXTPDockingPaneSplitterContainer Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bHoriz | TRUE if the splitter orientation is horizontal
m_bRecalcLayout | TRUE if RecalcLayout method currently executed.
m_lstSpliters | List of splitter windows


CXTPDockingPaneSplitterContainer::m_bHoriz Data Member

CXTPDockingPaneSplitterContainer Data Members, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::m_bHoriz Data Member

TRUE if the splitter orientation is horizontal

BOOL m_bHoriz;
Group

CXTPDockingPaneSplitterContainer Data Members


CXTPDockingPaneSplitterContainer::m_bRecalcLayout Data Member

CXTPDockingPaneSplitterContainer Data Members, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::m_bRecalcLayout Data Member

TRUE if RecalcLayout method currently executed.

BOOL m_bRecalcLayout;
Group

CXTPDockingPaneSplitterContainer Data Members


CXTPDockingPaneSplitterContainer::m_lstSpliters Data Member

CXTPDockingPaneSplitterContainer Data Members, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::m_lstSpliters Data Member

List of splitter windows

CList<CXTPDockingPaneSplitterWnd*, CXTPDockingPaneSplitterWnd*> m_lstSpliters;
Group

CXTPDockingPaneSplitterContainer Data Members


CXTPDockingPaneSplitterContainer Methods

CXTPDockingPaneSplitterContainer Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer Methods
Class

CXTPDockingPaneSplitterContainer Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Copy | Copies a CXTPDockingPaneSplitterContainer object
DeletePane | This method is called to destroy pane
DoPropExchange | This member is called to save/restore the settings of the pane.
Init | Constructs a CXTPDockingPaneSplitterContainer object Protected constructor. Internally constructed only.
NormalizeDockingSize | This member is called to normalize the size of docking panes in the splitter container. Normalizing the size of the panes means that the value of the left coordinate is less than the right and the top is less than the bottom.
OnChildContainerChanged | This member is called when a child pane collection is changed.
OnCreateSplitter | This member is called by the framework when a splitter container is created.
OnParentContainerChanged | This member is called when the parent pane collection is changed.
RemovePane | This member is called to remove a pane from the collection.
Public Methods
Public Methods
Public Method | Description
FindChildPane | Call this member to retrieve a collection of the panes with the specified type only within the splitter container's child panes.
GetMinMaxInfo | Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the splitter container. This will look at the MinMaxInfo for each pane in the splitter container and set the appropriate minimum and maximum width and height for the splitter container.
IsHoriz | Call this member to determine if the splitter orientation is horizontal.
OnSizeParent | This method is called to set the position of the pane.


CXTPDockingPaneSplitterContainer::Copy Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::Copy Method

Copies a CXTPDockingPaneSplitterContainer object

void Copy(
    CXTPDockingPaneBase* pClone,
    CXTPPaneToPaneMap* pMap,
    DWORD dwIgnoredOptions
);
Parameters

pClone
Points to a CXTPDockingPaneSplitterContainer object
pMap
Points to a CXTPPaneToPaneMap object

See Also

CXTPPaneToPaneMap

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::DeletePane Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::DeletePane Method

This method is called to destroy pane

void DeletePane();
Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::DoPropExchange Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::DoPropExchange Method

This member is called to save/restore the settings of the pane.

virtual BOOL DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Points to a CXTPPropExchange object.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::FindChildPane Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::FindChildPane Method

Call this member to retrieve a collection of the panes with the specified type only within the splitter container's child panes.

void FindChildPane(
    XTPDockingPaneType type,
    CXTPDockingPaneBaseList* pList
) const;
Parameters

type
Type of the panes to find.
pList
Points to a CXTPDockingPaneBaseList object that will contain found panes.

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::GetMinMaxInfo Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::GetMinMaxInfo Method

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the splitter container. This will look at the MinMaxInfo for each pane in the splitter container and set the appropriate minimum and maximum width and height for the splitter container.

void GetMinMaxInfo(
    LPMINMAXINFO pMinMaxInfo
) const;
Parameters

pMinMaxInfo
Pointer to MINMAXINFO structure

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::Init Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::Init Method

Constructs a CXTPDockingPaneSplitterContainer object Protected constructor. Internally constructed only.

void Init(
    CXTPDockingPaneBase* pPane,
    BOOL bHoriz,
    CWnd* pFrame
);
Parameters

pPane
Child pane.
bHoriz
TRUE if the splitter orientation is horizontal
pFrame
Parent Frame.

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::IsHoriz Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::IsHoriz Method

Call this member to determine if the splitter orientation is horizontal.

BOOL IsHoriz() const;
Returns

TRUE if the splitter orientation is horizontal, FALSE otherwise.

Body Source
BOOL IsHoriz() const { return m_bHoriz; }
Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::NormalizeDockingSize Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::NormalizeDockingSize Method

This member is called to normalize the size of docking panes in the splitter container. Normalizing the size of the panes means that the value of the left coordinate is less than the right and the top is less than the bottom.

void NormalizeDockingSize();
Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::OnChildContainerChanged Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::OnChildContainerChanged Method

This member is called when a child pane collection is changed.

virtual void OnChildContainerChanged(
    CXTPDockingPaneBase* pContainer
);
Parameters

pContainer
Points to a CXTPDockingPaneBase object.

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::OnCreateSplitter Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::OnCreateSplitter Method

This member is called by the framework when a splitter container is created.

virtual CXTPDockingPaneSplitterWnd* OnCreateSplitter();
Returns

Pointer to the newly created CXTPDockingPaneSplitterWnd object.

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::OnParentContainerChanged Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::OnParentContainerChanged Method

This member is called when the parent pane collection is changed.

virtual void OnParentContainerChanged(
    CXTPDockingPaneBase* pContainer
);
Parameters

pContainer
Points to a CXTPDockingPaneBase object.

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::OnSizeParent Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::OnSizeParent Method

This method is called to set the position of the pane.

virtual void OnSizeParent(
    CWnd* pParent,
    CRect rect,
    LPVOID lParam
);
Parameters

pParent
Points to a CWnd object
rect
Rectangle of the pane to be set
lParam
Pointer to AFX_SIZEPARENTPARAMS structure

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer::RemovePane Method

CXTPDockingPaneSplitterContainer Methods, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::RemovePane Method

This member is called to remove a pane from the collection.

virtual void RemovePane(
    CXTPDockingPaneBase* pPane
);
Parameters

pPane
Points to a CXTPDockingPaneBase object.

Group

CXTPDockingPaneSplitterContainer Methods


CXTPDockingPaneSplitterContainer Constructors

CXTPDockingPaneSplitterContainer Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer Constructors
Class

CXTPDockingPaneSplitterContainer Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneSplitterContainer | Constructs a CXTPDockingPaneSplitterContainer object.


CXTPDockingPaneSplitterContainer::CXTPDockingPaneSplitterContainer Constructor

CXTPDockingPaneSplitterContainer Constructors, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::CXTPDockingPaneSplitterContainer Constructor

Constructs a CXTPDockingPaneSplitterContainer object.

CXTPDockingPaneSplitterContainer(
    CXTPDockingPaneLayout* pLayout
);
Parameters

pLayout
Points to a CXTPDockingPaneLayout object.

Group

CXTPDockingPaneSplitterContainer Constructors


CXTPDockingPaneSplitterContainer Destructors

CXTPDockingPaneSplitterContainer Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer Destructors
Class

CXTPDockingPaneSplitterContainer Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPaneSplitterContainer | Destroys a CXTPDockingPaneSplitterContainer object, handles cleanup and deallocation


CXTPDockingPaneSplitterContainer::~CXTPDockingPaneSplitterContainer Destructor

CXTPDockingPaneSplitterContainer Destructors, CXTPDockingPaneSplitterContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterContainer::~CXTPDockingPaneSplitterContainer Destructor

Destroys a CXTPDockingPaneSplitterContainer object, handles cleanup and deallocation

virtual ~CXTPDockingPaneSplitterContainer();
Group

CXTPDockingPaneSplitterContainer Destructors


CXTPDockingPaneSplitterWnd Class

XTPDockingPaneSplitterContainer.h, Classes, Legend, Members, Topics, CXTPDockingPaneSplitterWnd Methods, CXTPDockingPaneSplitterWnd Constructors, CXTPDockingPaneSplitterWnd Destructors, CXTPDockingPaneSplitterWnd Constructors, CXTPDockingPaneSplitterWnd Destructors, CXTPDockingPaneSplitterWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterWnd Class

CXTPDockingPaneSplitterWnd is a CWnd derived class. It is used internally for splitting Panes.

Class Hierarchy

class CXTPDockingPaneSplitterWnd : public CWnd;
File

XTPDockingPaneSplitterContainer.h

Group

Classes

Legend
Method
protected
CXTPDockingPaneSplitterWnd Constructors
CXTPDockingPaneSplitterWnd Constructors | Description
CXTPDockingPaneSplitterWnd | Constructs a CXTPDockingPaneSplitterWnd object
CXTPDockingPaneSplitterWnd Destructors
CXTPDockingPaneSplitterWnd Destructors | Description
~CXTPDockingPaneSplitterWnd | Destroys a CXTPDockingPaneSplitterWnd object, handles cleanup and deallocation
CXTPDockingPaneSplitterWnd Methods
CXTPDockingPaneSplitterWnd Methods | Description
Create |
GetContainer | Retrieves associated splitter container of splitter window
IsHorizontal | Determines if splitter is horizontal


CXTPDockingPaneSplitterWnd Methods

CXTPDockingPaneSplitterWnd Class, Legend, Public Methods
CXTPDockingPaneSplitterWnd Methods
Class

CXTPDockingPaneSplitterWnd Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Create |
GetContainer | Retrieves associated splitter container of splitter window
IsHorizontal | Determines if splitter is horizontal


Create Method

CXTPDockingPaneSplitterWnd Methods
Create Method
Overload List
Methods
Method | Description
CXTPDockingPaneSplitterWnd::Create (CXTPDockingPaneManager*, BOOL) | Creates CXTPDockingPaneSplitterWnd window.
CXTPDockingPaneSplitterWnd::Create (CXTPDockingPaneSplitterContainer*, CXTPDockingPaneBase*, CXTPDockingPaneBase*) | Creates CXTPDockingPaneSplitterWnd window.
Group

CXTPDockingPaneSplitterWnd Methods


CXTPDockingPaneSplitterWnd::Create Method (CXTPDockingPaneManager*, BOOL)

Create Method, CXTPDockingPaneSplitterWnd Class
CXTPDockingPaneSplitterWnd::Create Method (CXTPDockingPaneManager*, BOOL)

Creates CXTPDockingPaneSplitterWnd window.

void Create(
    CXTPDockingPaneManager* pManager,
    BOOL bHoriz
);
Parameters

pManager
Parent manager object
bHoriz
True if horizontal splitter

Group

Create Method


CXTPDockingPaneSplitterWnd::Create Method (CXTPDockingPaneSplitterContainer*, CXTPDockingPaneBase*, CXTPDockingPaneBase*)

Create Method, CXTPDockingPaneSplitterWnd Class
CXTPDockingPaneSplitterWnd::Create Method (CXTPDockingPaneSplitterContainer*, CXTPDockingPaneBase*, CXTPDockingPaneBase*)

Creates CXTPDockingPaneSplitterWnd window.

void Create(
    CXTPDockingPaneSplitterContainer* pContainer,
    CXTPDockingPaneBase* pFirst,
    CXTPDockingPaneBase* pSecond
);
Parameters

pContainer
Points to a parent CXTPDockingPaneSplitterContainer object
pFirst
Points to a first splitting CXTPDockingPaneBase object
pSecond
Points to a second splitting CXTPDockingPaneBase object

Group

Create Method


CXTPDockingPaneSplitterWnd::GetContainer Method

CXTPDockingPaneSplitterWnd Methods, CXTPDockingPaneSplitterWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterWnd::GetContainer Method

Retrieves associated splitter container of splitter window

CXTPDockingPaneSplitterContainer* GetContainer() const;
Returns

Pointer to parent CXTPDockingPaneSplitterContainer window

Body Source
CXTPDockingPaneSplitterContainer* CXTPDockingPaneSplitterWnd::GetContainer() const {
    return m_pContainer;
}
Group

CXTPDockingPaneSplitterWnd Methods


CXTPDockingPaneSplitterWnd::IsHorizontal Method

CXTPDockingPaneSplitterWnd Methods, CXTPDockingPaneSplitterWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterWnd::IsHorizontal Method

Determines if splitter is horizontal

BOOL IsHorizontal() const;
Returns

TRUE if splitter is horizontal located.

Group

CXTPDockingPaneSplitterWnd Methods


CXTPDockingPaneSplitterWnd Constructors

CXTPDockingPaneSplitterWnd Class, Legend, Protected Methods
CXTPDockingPaneSplitterWnd Constructors
Class

CXTPDockingPaneSplitterWnd Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneSplitterWnd | Constructs a CXTPDockingPaneSplitterWnd object


CXTPDockingPaneSplitterWnd::CXTPDockingPaneSplitterWnd Constructor

CXTPDockingPaneSplitterWnd Constructors, CXTPDockingPaneSplitterWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterWnd::CXTPDockingPaneSplitterWnd Constructor

Constructs a CXTPDockingPaneSplitterWnd object

CXTPDockingPaneSplitterWnd();
Group

CXTPDockingPaneSplitterWnd Constructors


CXTPDockingPaneSplitterWnd Destructors

CXTPDockingPaneSplitterWnd Class, Legend, Protected Methods
CXTPDockingPaneSplitterWnd Destructors
Class

CXTPDockingPaneSplitterWnd Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPaneSplitterWnd | Destroys a CXTPDockingPaneSplitterWnd object, handles cleanup and deallocation


CXTPDockingPaneSplitterWnd::~CXTPDockingPaneSplitterWnd Destructor

CXTPDockingPaneSplitterWnd Destructors, CXTPDockingPaneSplitterWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneSplitterWnd::~CXTPDockingPaneSplitterWnd Destructor

Destroys a CXTPDockingPaneSplitterWnd object, handles cleanup and deallocation

~CXTPDockingPaneSplitterWnd();
Group

CXTPDockingPaneSplitterWnd Destructors


CXTPDockingPaneTabbedContainer Class

XTPDockingPaneTabbedContainer.h, Classes, Legend, Members, Topics, CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Constructors, CXTPDockingPaneTabbedContainer Destructors, CXTPDockingPaneTabbedContainer Constructors, CXTPDockingPaneTabbedContainer Destructors, CXTPDockingPaneTabbedContainer Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer Class

CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It represents a tabbed container for Docking Panes.

Class Hierarchy

class CXTPDockingPaneTabbedContainer : public CWnd, public CXTPDockingPaneBaseContainer, public CXTPTabManager;
File

XTPDockingPaneTabbedContainer.h

Group

Classes

Legend
Method
virtual
protected
CXTPDockingPaneTabbedContainer Constructors
CXTPDockingPaneTabbedContainer Constructors | Description
CXTPDockingPaneTabbedContainer | Constructs a CXTPDockingPaneTabbedContainer object Protected constructor. Internally constructed only.
CXTPDockingPaneTabbedContainer Destructors
CXTPDockingPaneTabbedContainer Destructors | Description
~CXTPDockingPaneTabbedContainer | Destroys a CXTPDockingPaneTabbedContainer object, handles cleanup and deallocation
CXTPDockingPaneTabbedContainer Methods
CXTPDockingPaneTabbedContainer Methods | Description
CanAttach | This method called to check if docking pane can be attached to tabbed container.
Copy | Copies a CXTPDockingPaneTabbedContainer object
CreateContainer | This member is called to create pane
DoPropExchange | This member is called to save/restore the settings of the pane.
DrawIcon | This member is called when the icon of the tab in the tabbed container needs to be drawn. I.e. On mouse over.
GetCloseButton | Call this member to access title's close button.
GetItemPane | Call this member to get pane by its index.
GetMinMaxInfo | Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.
GetPaintManager | This member is called to access the visual elements of the docking pane tabs. I.e. Tab colors, styles, etc...
GetPaneHwnd | Retrieves safe window handle.
GetPaneTab | Call this member to get tab for corresponded pane.
GetPinButton | Call this member to access title's pin button.
GetSelected | Call this member function to get selected pane.
Init | Constructs a CXTPDockingPaneTabbedContainer object Protected constructor. Internally constructed only.
IsActive | Call this member function to get child pane state.
IsCaptionButtonVisible | This member is called to determine if a specific caption button is visible.
IsCaptionVertical | Returns TRUE if caption drawn vertically
IsHidden | Call this member to determine if the tabbed container is auto-hidden. If one pane in a group of panes is auto-hidden, then the entire group will be auto-hidden.
IsTabsVisible | Call this member to determine if the tab bar is visible.
IsTitleVisible | Call this member to determine if the title is visible.
OnCaptionButtonClick | This member is called by the framework when a caption button is clicked.
OnCaptionLButtonDown | This member is called by the framework when the left mouse button is clicked while the mouse pointer is positioned over a pane caption. This will give the pane focus and begin the pane dragging process (If the left button is held down).
OnTabsChanged | This member is called to when tabs was changed.
RedrawControl | This member is called to redraw the tabbed control, I.e. When an Icon has changed.
Reposition | This member is called to recalculate the positions of tab groups/Items.
SelectPane | Call this member to activate a child docking pane.
SetPaintManager | This member function is called in a derived class to set a pointer the tab paint manager.


CXTPDockingPaneTabbedContainer Methods

CXTPDockingPaneTabbedContainer Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer Methods
Class

CXTPDockingPaneTabbedContainer Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Copy | Copies a CXTPDockingPaneTabbedContainer object
CreateContainer | This member is called to create pane
DoPropExchange | This member is called to save/restore the settings of the pane.
DrawIcon | This member is called when the icon of the tab in the tabbed container needs to be drawn. I.e. On mouse over.
GetPaintManager | This member is called to access the visual elements of the docking pane tabs. I.e. Tab colors, styles, etc...
Init | Constructs a CXTPDockingPaneTabbedContainer object Protected constructor. Internally constructed only.
IsCaptionButtonVisible | This member is called to determine if a specific caption button is visible.
OnCaptionButtonClick | This member is called by the framework when a caption button is clicked.
OnTabsChanged | This member is called to when tabs was changed.
RedrawControl | This member is called to redraw the tabbed control, I.e. When an Icon has changed.
Reposition | This member is called to recalculate the positions of tab groups/Items.
SetPaintManager | This member function is called in a derived class to set a pointer the tab paint manager.
Public Methods
Public Methods
Public Method | Description
CanAttach | This method called to check if docking pane can be attached to tabbed container.
GetCloseButton | Call this member to access title's close button.
GetItemPane | Call this member to get pane by its index.
GetMinMaxInfo | Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.
GetPaneHwnd | Retrieves safe window handle.
GetPaneTab | Call this member to get tab for corresponded pane.
GetPinButton | Call this member to access title's pin button.
GetSelected | Call this member function to get selected pane.
IsActive | Call this member function to get child pane state.
IsCaptionVertical | Returns TRUE if caption drawn vertically
IsHidden | Call this member to determine if the tabbed container is auto-hidden. If one pane in a group of panes is auto-hidden, then the entire group will be auto-hidden.
IsTabsVisible | Call this member to determine if the tab bar is visible.
IsTitleVisible | Call this member to determine if the title is visible.
OnCaptionLButtonDown | This member is called by the framework when the left mouse button is clicked while the mouse pointer is positioned over a pane caption. This will give the pane focus and begin the pane dragging process (If the left button is held down).
SelectPane | Call this member to activate a child docking pane.


CXTPDockingPaneTabbedContainer::CanAttach Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::CanAttach Method

This method called to check if docking pane can be attached to tabbed container.

virtual BOOL CanAttach(
    CRect& rcClient,
    CPoint pt
) const;
Parameters

rcClient
Client rectangle of container.
pt
Point to attach.

Returns

TRUE if pane can be attached as new tab to tabbed container.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::Copy Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::Copy Method

Copies a CXTPDockingPaneTabbedContainer object

virtual void Copy(
    CXTPDockingPaneBase* pClone,
    CXTPPaneToPaneMap* pMap,
    DWORD dwIgnoredOptions
);
Parameters

pClone
Points to a CXTPDockingPaneTabbedContainer object
pMap
Points to a CXTPPaneToPaneMap object
dwIgnoredOptions
Options that must be skipped.

See Also

CXTPPaneToPaneMap

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::CreateContainer Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::CreateContainer Method

This member is called to create pane

virtual void CreateContainer();
Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::DoPropExchange Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::DoPropExchange Method

This member is called to save/restore the settings of the pane.

virtual BOOL DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Points to a CXTPPropExchange object.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::DrawIcon Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::DrawIcon Method

This member is called when the icon of the tab in the tabbed container needs to be drawn. I.e. On mouse over.

virtual BOOL DrawIcon(
    CDC* pDC,
    CPoint pt,
    CXTPTabManagerItem* pItem,
    BOOL bDraw,
    CSize& szIcon
) const;
Parameters

pDC
Pointer to the destination device context.
pt
Specifies the location of the image.
pItem
CXTPTabManagerItem object to draw icon on.
bDraw
TRUE if the icon needs to be drawn, I.e. the icon size changed. FALSE if the icon does not need to be drawn or redrawn.
szIcon
Size of the tab icon.

Returns

TRUE if the icon was successfully drawn, FALSE if the icon was not drawn.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::GetCloseButton Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::GetCloseButton Method

Call this member to access title's close button.

CXTPDockingPaneCaptionButton* GetCloseButton() const;
Returns

A reference to the title's close button.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::GetItemPane Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::GetItemPane Method

Call this member to get pane by its index.

CXTPDockingPane* GetItemPane(
    int nIndex
) const;
Parameters

nIndex
Index of pane need to retrieve

Returns

CXTPDockingPane pointer corresponded with nIndex

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::GetMinMaxInfo Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::GetMinMaxInfo Method

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container. This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.

void GetMinMaxInfo(
    LPMINMAXINFO pMinMaxInfo
) const;
Parameters

pMinMaxInfo
Pointer to MINMAXINFO structure

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::GetPaintManager Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::GetPaintManager Method

This member is called to access the visual elements of the docking pane tabs. I.e. Tab colors, styles, etc...

virtual CXTPTabPaintManager* GetPaintManager() const;
Returns

Pointer to CXTPTabPaintManager that contains the visual elements of the docking pane tabs.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::GetPaneHwnd Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::GetPaneHwnd Method

Retrieves safe window handle.

virtual HWND GetPaneHwnd() const;
Returns

Safe window handle.

Body Source
HWND CXTPDockingPaneTabbedContainer::GetPaneHwnd() const {
    return CWnd::GetSafeHwnd();
}
Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::GetPaneTab Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::GetPaneTab Method

Call this member to get tab for corresponded pane.

CXTPTabManagerItem* GetPaneTab(
    CXTPDockingPane* pPane
) const;
Parameters

pPane
Pane to get tab for

Returns

CXTPTabManagerItem pointer corresponded with pPane

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::GetPinButton Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::GetPinButton Method

Call this member to access title's pin button.

CXTPDockingPaneCaptionButton* GetPinButton() const;
Returns

A reference to the title's pin button.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::GetSelected Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::GetSelected Method

Call this member function to get selected pane.

CXTPDockingPane* GetSelected() const;
Returns

The selected child pane.

Body Source
CXTPDockingPane* CXTPDockingPaneTabbedContainer::GetSelected() const {
    return m_pSelectedPane;
}
Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::Init Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::Init Method

Constructs a CXTPDockingPaneTabbedContainer object Protected constructor. Internally constructed only.

void Init(
    CXTPDockingPane* pPane,
    CWnd* pFrame
);
Parameters

pPane
Child pane.
pFrame
Parent Frame.
pLayout
Points to a CXTPDockingPaneLayout object.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::IsActive Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::IsActive Method

Call this member function to get child pane state.

BOOL IsActive() const;
Returns

TRUE if a child pane is active.

Body Source
BOOL CXTPDockingPaneTabbedContainer::IsActive() const {
    return m_bActive;
}
Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::IsCaptionButtonVisible Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::IsCaptionButtonVisible Method

This member is called to determine if a specific caption button is visible.

virtual BOOL IsCaptionButtonVisible(
    CXTPDockingPaneCaptionButton* pButton
);
Parameters

pButton
Button to check to see if it is visible.

Returns

TRUE if the caption button specified is visible, FALSE otherwise.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::IsCaptionVertical Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::IsCaptionVertical Method

Returns TRUE if caption drawn vertically

virtual BOOL IsCaptionVertical() const;
Returns

TRUE if the caption drawn vertically

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::IsHidden Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::IsHidden Method

Call this member to determine if the tabbed container is auto-hidden. If one pane in a group of panes is auto-hidden, then the entire group will be auto-hidden.

BOOL IsHidden() const;
Returns

TRUE if the tabbed container is auto-hidden, FALSE if the tab group is visible.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::IsTabsVisible Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::IsTabsVisible Method

Call this member to determine if the tab bar is visible.

virtual BOOL IsTabsVisible() const;
Returns

TRUE if the tab bar is visible.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::IsTitleVisible Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::IsTitleVisible Method

Call this member to determine if the title is visible.

BOOL IsTitleVisible() const;
Returns

TRUE if the title is visible.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::OnCaptionButtonClick Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::OnCaptionButtonClick Method

This member is called by the framework when a caption button is clicked.

virtual void OnCaptionButtonClick(
    CXTPDockingPaneCaptionButton* pButton
);
Parameters

pButton
Caption button that was clicked.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::OnCaptionLButtonDown Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::OnCaptionLButtonDown Method

This member is called by the framework when the left mouse button is clicked while the mouse pointer is positioned over a pane caption. This will give the pane focus and begin the pane dragging process (If the left button is held down).

virtual void OnCaptionLButtonDown(
    CPoint point
);
Parameters

point
Cursor location on the pane's caption that was clicked.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::OnTabsChanged Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::OnTabsChanged Method

This member is called to when tabs was changed.

virtual void OnTabsChanged();
Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::RedrawControl Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::RedrawControl Method

This member is called to redraw the tabbed control, I.e. When an Icon has changed.

virtual void RedrawControl(
    LPCRECT lpRect,
    BOOL bAnimate
);
Parameters

lpRect
The rectangular area of the window that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::Reposition Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::Reposition Method

This member is called to recalculate the positions of tab groups/Items.

virtual void Reposition();
Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::SelectPane Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::SelectPane Method

Call this member to activate a child docking pane.

virtual void SelectPane(
    CXTPDockingPane* pPane,
    BOOL bSetFocus = TRUE,
    BOOL bDelayRedraw = TRUE
);
Parameters

pPane
Pane to be activated.
bSetFocus
TRUE to set focus to child docking pane.
bDelayRedraw
TRUE to redraw caption delayed.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer::SetPaintManager Method

CXTPDockingPaneTabbedContainer Methods, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::SetPaintManager Method

This member function is called in a derived class to set a pointer the tab paint manager.

virtual void SetPaintManager(
    CXTPTabPaintManager* pPaintManager
);
Parameters

pPaintManager
Pointer to a CXTPTabPaintManager object.

Group

CXTPDockingPaneTabbedContainer Methods


CXTPDockingPaneTabbedContainer Constructors

CXTPDockingPaneTabbedContainer Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer Constructors
Class

CXTPDockingPaneTabbedContainer Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneTabbedContainer | Constructs a CXTPDockingPaneTabbedContainer object Protected constructor. Internally constructed only.


CXTPDockingPaneTabbedContainer::CXTPDockingPaneTabbedContainer Constructor

CXTPDockingPaneTabbedContainer Constructors, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::CXTPDockingPaneTabbedContainer Constructor

Constructs a CXTPDockingPaneTabbedContainer object Protected constructor. Internally constructed only.

CXTPDockingPaneTabbedContainer(
    CXTPDockingPaneLayout* pLayout
);
Parameters

pLayout
Points to a CXTPDockingPaneLayout object.

Group

CXTPDockingPaneTabbedContainer Constructors


CXTPDockingPaneTabbedContainer Destructors

CXTPDockingPaneTabbedContainer Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer Destructors
Class

CXTPDockingPaneTabbedContainer Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPDockingPaneTabbedContainer | Destroys a CXTPDockingPaneTabbedContainer object, handles cleanup and deallocation


CXTPDockingPaneTabbedContainer::~CXTPDockingPaneTabbedContainer Destructor

CXTPDockingPaneTabbedContainer Destructors, CXTPDockingPaneTabbedContainer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneTabbedContainer::~CXTPDockingPaneTabbedContainer Destructor

Destroys a CXTPDockingPaneTabbedContainer object, handles cleanup and deallocation

virtual ~CXTPDockingPaneTabbedContainer();
Group

CXTPDockingPaneTabbedContainer Destructors


CXTPDockingPaneVisioTheme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneVisioTheme Methods, CXTPDockingPaneVisioTheme Constructors, CXTPDockingPaneVisioTheme Constructors, CXTPDockingPaneVisioTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisioTheme Class

CXTPDockingPaneVisioTheme is CXTPDockingPaneOfficeTheme derived class, represents Visio theme for docking panes.

Class Hierarchy

class CXTPDockingPaneVisioTheme : public CXTPDockingPaneOfficeTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeVisio); to set this theme.

Group

Classes

Legend
Method
CXTPDockingPaneVisioTheme Constructors
CXTPDockingPaneVisioTheme Constructors | Description
CXTPDockingPaneVisioTheme | Constructs a CXTPDockingPaneVisioTheme object.
CXTPDockingPaneVisioTheme Methods
CXTPDockingPaneVisioTheme Methods | Description
AdjustCaptionRect | Override this member to change the caption rectangle of the child docking pane.
DrawCaption | Override this member function to draw a caption.
DrawFloatingFrame | Call this method to draw frame of floating window
DrawPane | Override this member function to draw a tabbed container.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneVisioTheme Methods

CXTPDockingPaneVisioTheme Class, Legend, Public Methods
CXTPDockingPaneVisioTheme Methods
Class

CXTPDockingPaneVisioTheme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AdjustCaptionRect | Override this member to change the caption rectangle of the child docking pane.
DrawCaption | Override this member function to draw a caption.
DrawFloatingFrame | Call this method to draw frame of floating window
DrawPane | Override this member function to draw a tabbed container.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneVisioTheme::AdjustCaptionRect Method

CXTPDockingPaneVisioTheme Methods, CXTPDockingPaneVisioTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisioTheme::AdjustCaptionRect Method

Override this member to change the caption rectangle of the child docking pane.

void AdjustCaptionRect(
    const CXTPDockingPaneTabbedContainer* pPane,
    CRect& rc
);
Parameters

pPane
Pointer to a CXTPDockingPaneTabbedContainer object.
rc
Caption rectangle to be changed.

Group

CXTPDockingPaneVisioTheme Methods


CXTPDockingPaneVisioTheme::DrawCaption Method

CXTPDockingPaneVisioTheme Methods, CXTPDockingPaneVisioTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisioTheme::DrawCaption Method

Override this member function to draw a caption.

void DrawCaption(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneVisioTheme Methods


CXTPDockingPaneVisioTheme::DrawFloatingFrame Method

CXTPDockingPaneVisioTheme Methods, CXTPDockingPaneVisioTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisioTheme::DrawFloatingFrame Method

Call this method to draw frame of floating window

void DrawFloatingFrame(
    CDC* pDC,
    CXTPDockingPaneMiniWnd* pPane,
    CRect rc
);
Parameters

pPane
Floating window pointer
rc
Client rectangle of floating frame
dc
Pointer to a valid device context

Group

CXTPDockingPaneVisioTheme Methods


CXTPDockingPaneVisioTheme::DrawPane Method

CXTPDockingPaneVisioTheme Methods, CXTPDockingPaneVisioTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisioTheme::DrawPane Method

Override this member function to draw a tabbed container.

void DrawPane(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneVisioTheme Methods


CXTPDockingPaneVisioTheme::RefreshMetrics Method

CXTPDockingPaneVisioTheme Methods, CXTPDockingPaneVisioTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisioTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

void RefreshMetrics();
Group

CXTPDockingPaneVisioTheme Methods


CXTPDockingPaneVisioTheme Constructors

CXTPDockingPaneVisioTheme Class, Legend, Public Methods
CXTPDockingPaneVisioTheme Constructors
Class

CXTPDockingPaneVisioTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneVisioTheme | Constructs a CXTPDockingPaneVisioTheme object.


CXTPDockingPaneVisioTheme::CXTPDockingPaneVisioTheme Constructor

CXTPDockingPaneVisioTheme Constructors, CXTPDockingPaneVisioTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisioTheme::CXTPDockingPaneVisioTheme Constructor

Constructs a CXTPDockingPaneVisioTheme object.

CXTPDockingPaneVisioTheme();
Group

CXTPDockingPaneVisioTheme Constructors


CXTPDockingPaneVisualStudio2005SecondTheme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneVisualStudio2005SecondTheme Data Members, CXTPDockingPaneVisualStudio2005SecondTheme Methods, CXTPDockingPaneVisualStudio2005SecondTheme Constructors, CXTPDockingPaneVisualStudio2005SecondTheme Constructors, CXTPDockingPaneVisualStudio2005SecondTheme Data Members, CXTPDockingPaneVisualStudio2005SecondTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005SecondTheme Class

CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneWhidbeyTheme derived class, represents Visual Studio 2005 beta 2 theme for docking panes.

Class Hierarchy

class CXTPDockingPaneVisualStudio2005SecondTheme : public CXTPDockingPaneWhidbeyTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeWhidbey); to set this theme.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDockingPaneVisualStudio2005SecondTheme Constructors
CXTPDockingPaneVisualStudio2005SecondTheme Constructors | Description
CXTPDockingPaneVisualStudio2005SecondTheme | Constructs a CXTPDockingPaneVisualStudio2005SecondTheme object.
CXTPDockingPaneVisualStudio2005SecondTheme Data Members
CXTPDockingPaneVisualStudio2005SecondTheme Data Members | Description
m_clrCaptionBorder | Color used to draw the border of the pane caption.
CXTPDockingPaneVisualStudio2005SecondTheme Methods
CXTPDockingPaneVisualStudio2005SecondTheme Methods | Description
FillCaptionPart | Draws the background of the pane caption.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneVisualStudio2005SecondTheme Data Members

CXTPDockingPaneVisualStudio2005SecondTheme Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005SecondTheme Data Members
Class

CXTPDockingPaneVisualStudio2005SecondTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrCaptionBorder | Color used to draw the border of the pane caption.


CXTPDockingPaneVisualStudio2005SecondTheme::m_clrCaptionBorder Data Member

CXTPDockingPaneVisualStudio2005SecondTheme Data Members, CXTPDockingPaneVisualStudio2005SecondTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005SecondTheme::m_clrCaptionBorder Data Member

Color used to draw the border of the pane caption.

COLORREF m_clrCaptionBorder;
Group

CXTPDockingPaneVisualStudio2005SecondTheme Data Members


CXTPDockingPaneVisualStudio2005SecondTheme Methods

CXTPDockingPaneVisualStudio2005SecondTheme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005SecondTheme Methods
Class

CXTPDockingPaneVisualStudio2005SecondTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
FillCaptionPart | Draws the background of the pane caption.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneVisualStudio2005SecondTheme::FillCaptionPart Method

CXTPDockingPaneVisualStudio2005SecondTheme Methods, CXTPDockingPaneVisualStudio2005SecondTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005SecondTheme::FillCaptionPart Method

Draws the background of the pane caption.

virtual COLORREF FillCaptionPart(
    CDC* pDC,
    CXTPDockingPaneBase* pPane,
    CRect rcCaption,
    BOOL bActive,
    BOOL bVertical
);
Parameters

pPane
Container of the caption needs to draw the background.
rcCaption
Caption bounding rectangle
bActive
TRUE if caption is active.
bVertical
TRUE to draw caption vertically
dc
Reference to the device context in which to draw.
strTitle
Caption text.

Group

CXTPDockingPaneVisualStudio2005SecondTheme Methods


CXTPDockingPaneVisualStudio2005SecondTheme::RefreshMetrics Method

CXTPDockingPaneVisualStudio2005SecondTheme Methods, CXTPDockingPaneVisualStudio2005SecondTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005SecondTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

void RefreshMetrics();
Group

CXTPDockingPaneVisualStudio2005SecondTheme Methods


CXTPDockingPaneVisualStudio2005SecondTheme Constructors

CXTPDockingPaneVisualStudio2005SecondTheme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005SecondTheme Constructors
Class

CXTPDockingPaneVisualStudio2005SecondTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneVisualStudio2005SecondTheme | Constructs a CXTPDockingPaneVisualStudio2005SecondTheme object.


CXTPDockingPaneVisualStudio2005SecondTheme::CXTPDockingPaneVisualStudio2005SecondTheme Constructor

CXTPDockingPaneVisualStudio2005SecondTheme Constructors, CXTPDockingPaneVisualStudio2005SecondTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005SecondTheme::CXTPDockingPaneVisualStudio2005SecondTheme Constructor

Constructs a CXTPDockingPaneVisualStudio2005SecondTheme object.

CXTPDockingPaneVisualStudio2005SecondTheme();
Group

CXTPDockingPaneVisualStudio2005SecondTheme Constructors


CXTPDockingPaneVisualStudio2005Theme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneVisualStudio2005Theme Constructors, CXTPDockingPaneVisualStudio2005Theme Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005Theme Class

CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneVisualStudio2005SecondTheme derived class, represents Visual Studio 2005 theme for docking panes.

Class Hierarchy

class CXTPDockingPaneVisualStudio2005Theme : public CXTPDockingPaneVisualStudio2005SecondTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeWhidbey); to set this theme.

Group

Classes

Legend
Constructor
CXTPDockingPaneVisualStudio2005Theme Constructors
CXTPDockingPaneVisualStudio2005Theme Constructors | Description
CXTPDockingPaneVisualStudio2005Theme | Constructs a CXTPDockingPaneVisualStudio2005Theme object.


CXTPDockingPaneVisualStudio2005Theme Constructors

CXTPDockingPaneVisualStudio2005Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005Theme Constructors
Class

CXTPDockingPaneVisualStudio2005Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneVisualStudio2005Theme | Constructs a CXTPDockingPaneVisualStudio2005Theme object.


CXTPDockingPaneVisualStudio2005Theme::CXTPDockingPaneVisualStudio2005Theme Constructor

CXTPDockingPaneVisualStudio2005Theme Constructors, CXTPDockingPaneVisualStudio2005Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneVisualStudio2005Theme::CXTPDockingPaneVisualStudio2005Theme Constructor

Constructs a CXTPDockingPaneVisualStudio2005Theme object.

CXTPDockingPaneVisualStudio2005Theme();
Group

CXTPDockingPaneVisualStudio2005Theme Constructors


CXTPDockingPaneWhidbeyTheme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneWhidbeyTheme Methods, CXTPDockingPaneWhidbeyTheme Constructors, CXTPDockingPaneWhidbeyTheme Constructors, CXTPDockingPaneWhidbeyTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneWhidbeyTheme Class

CXTPDockingPaneWhidbeyTheme is CXTPDockingPaneOfficeTheme derived class, represents Visual Studio 2005 theme for docking panes.

Class Hierarchy

class CXTPDockingPaneWhidbeyTheme : public CXTPDockingPaneOfficeTheme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeWhidbey); to set this theme.

Group

Classes

Legend
Method
CXTPDockingPaneWhidbeyTheme Constructors
CXTPDockingPaneWhidbeyTheme Constructors | Description
CXTPDockingPaneWhidbeyTheme | Constructs a CXTPDockingPaneWhidbeyTheme object.
CXTPDockingPaneWhidbeyTheme Methods
CXTPDockingPaneWhidbeyTheme Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneWhidbeyTheme Methods

CXTPDockingPaneWhidbeyTheme Class, Legend, Public Methods
CXTPDockingPaneWhidbeyTheme Methods
Class

CXTPDockingPaneWhidbeyTheme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneWhidbeyTheme::RefreshMetrics Method

CXTPDockingPaneWhidbeyTheme Methods, CXTPDockingPaneWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneWhidbeyTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

void RefreshMetrics();
Group

CXTPDockingPaneWhidbeyTheme Methods


CXTPDockingPaneWhidbeyTheme Constructors

CXTPDockingPaneWhidbeyTheme Class, Legend, Public Methods
CXTPDockingPaneWhidbeyTheme Constructors
Class

CXTPDockingPaneWhidbeyTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneWhidbeyTheme | Constructs a CXTPDockingPaneWhidbeyTheme object.


CXTPDockingPaneWhidbeyTheme::CXTPDockingPaneWhidbeyTheme Constructor

CXTPDockingPaneWhidbeyTheme Constructors, CXTPDockingPaneWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneWhidbeyTheme::CXTPDockingPaneWhidbeyTheme Constructor

Constructs a CXTPDockingPaneWhidbeyTheme object.

CXTPDockingPaneWhidbeyTheme();
Group

CXTPDockingPaneWhidbeyTheme Constructors


CXTPDockingPaneWord2007Theme Class

XTPDockingPanePaintManager.h, Classes, Legend, Members, Topics, CXTPDockingPaneWord2007Theme Methods, CXTPDockingPaneWord2007Theme Constructors, CXTPDockingPaneWord2007Theme Constructors, CXTPDockingPaneWord2007Theme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneWord2007Theme Class

CXTPDockingPaneWord2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office Word 2007 theme for docking panes.

Class Hierarchy

class CXTPDockingPaneWord2007Theme : public CXTPDockingPaneOffice2003Theme;
File

XTPDockingPanePaintManager.h

Remarks

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeWord2007); to set this theme.

Group

Classes

Legend
Method
CXTPDockingPaneWord2007Theme Constructors
CXTPDockingPaneWord2007Theme Constructors | Description
CXTPDockingPaneWord2007Theme | Constructs a CXTPDockingPaneWord2007Theme object.
CXTPDockingPaneWord2007Theme Methods
CXTPDockingPaneWord2007Theme Methods | Description
DrawCaption | Override this member function to draw a caption.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneWord2007Theme Methods

CXTPDockingPaneWord2007Theme Class, Legend, Public Methods
CXTPDockingPaneWord2007Theme Methods
Class

CXTPDockingPaneWord2007Theme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawCaption | Override this member function to draw a caption.
RefreshMetrics | This method is called to refresh the visual metrics of the pane.


CXTPDockingPaneWord2007Theme::DrawCaption Method

CXTPDockingPaneWord2007Theme Methods, CXTPDockingPaneWord2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneWord2007Theme::DrawCaption Method

Override this member function to draw a caption.

void DrawCaption(
    CDC* pDC,
    CXTPDockingPaneTabbedContainer* pPane,
    CRect rc
);
Parameters

pPane
Pointer to the tabbed container.
rc
Client rectangle of the tabbed container.
dc
Reference to the device context in which to draw.

Group

CXTPDockingPaneWord2007Theme Methods


CXTPDockingPaneWord2007Theme::RefreshMetrics Method

CXTPDockingPaneWord2007Theme Methods, CXTPDockingPaneWord2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneWord2007Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of the pane.

void RefreshMetrics();
Group

CXTPDockingPaneWord2007Theme Methods


CXTPDockingPaneWord2007Theme Constructors

CXTPDockingPaneWord2007Theme Class, Legend, Public Methods
CXTPDockingPaneWord2007Theme Constructors
Class

CXTPDockingPaneWord2007Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneWord2007Theme | Constructs a CXTPDockingPaneWord2007Theme object.


CXTPDockingPaneWord2007Theme::CXTPDockingPaneWord2007Theme Constructor

CXTPDockingPaneWord2007Theme Constructors, CXTPDockingPaneWord2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDockingPaneWord2007Theme::CXTPDockingPaneWord2007Theme Constructor

Constructs a CXTPDockingPaneWord2007Theme object.

CXTPDockingPaneWord2007Theme();
Group

CXTPDockingPaneWord2007Theme Constructors


Structs, Records, Enums

Enumerations, Legend, Docking Panes, Structures
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPDockingContextStickerStyle | Docking Panes sticker style enumeration
XTPDockingPaneAction | Actions a docking pane is currently performing.
XTPDockingPaneCaptionButtonStyle | Enumeration of the caption button styles
XTPDockingPaneCaptionDirection | Docking Pane Caption direction enumeration
XTPDockingPaneDirection | Docking direction enumeration
XTPDockingPaneKeyboardNavigate | Keyboard options indicates which key can be used to navigate panes
XTPDockingPaneOptions | Docking Pane Options enumeration
XTPDockingPanePaintTheme | Visual theme enumeration
XTPDockingPanePinState | Enumeration of the pin button state
XTPDockingPaneSplitterStyle | Enumeration of the splitter styles
XTPDockingPaneStickerType | XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be drawn on the screen when a docking pane is dragged.
XTPDockingPaneType | Docking pane type
XTPXTPDockingPaneEnableOptions | Enable options of the pane
Module

Docking Panes

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_DOCKINGPANE_ACTION | XTP_DOCKINGPANE_ACTION structure contains information about action performed by user with docking panes.
XTP_DOCKINGPANE_CLICK | XTP_DOCKINGPANE_CLICK structure contains information about pane was used in XTP_DPN_PANEMENUCLICK message
XTP_DOCKINGPANE_INFO | Internal structure used by Layout manager


XTP_DOCKINGPANE_ACTION Structure

XTPDockingPaneDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_DOCKINGPANE_ACTION Structure

XTP_DOCKINGPANE_ACTION structure contains information about action performed by user with docking panes.

struct XTP_DOCKINGPANE_ACTION {
  XTPDockingPaneAction action;
  BOOL bCancel;
  CXTPDockingPane* pPane;
  CXTPDockingPaneBase* pDockContainer;
  XTPDockingPaneDirection dockDirection;
};
File

XTPDockingPaneDefines.h

Members

action
Current action the pane is performing.
bCancel
If TRUE, the current action will be ignored/canceled
pPane
Pane performing the action.
pDockContainer
Container of xtpPaneActionDocking action.
dockDirection
The direction that the pane is trying to dock, if any.

See Also

XTP_DPN_ACTION, XTPDockingPaneAction

Example
LRESULT CMainFrame::OnDockingPaneNotify(WPARAM wParam, LPARAM lParam)
{
    if (wParam == XTP_DPN_ACTION)
    {
        XTP_DOCKINGPANE_ACTION* pAction = (XTP_DOCKINGPANE_ACTION*)lParam;
        TRACE("Action %in", pAction->action);
        return TRUE;
    }
    return FALSE;
}
Group

Structs, Records, Enums


XTP_DOCKINGPANE_CLICK Structure

XTPDockingPaneDefines.h, Structs, Records, Enums, See Also
XTP_DOCKINGPANE_CLICK Structure

XTP_DOCKINGPANE_CLICK structure contains information about pane was used in XTP_DPN_PANEMENUCLICK message

struct XTP_DOCKINGPANE_CLICK {
  CXTPDockingPane* pPane;
  CXTPDockingPaneBase* pContainer;
  CPoint pt;
  CRect rcExclude;
};
File

XTPDockingPaneDefines.h

Members

pPane
Docking Pane pointer
pContainer
Docking Pane container
pt
Mouse pointer
rcExclude
Exclude rectangle

See Also

XTP_DPN_PANEMENUCLICK

Group

Structs, Records, Enums


XTP_DOCKINGPANE_INFO Structure

XTPDockingPaneDefines.h, Structs, Records, Enums, See Also
XTP_DOCKINGPANE_INFO Structure

Internal structure used by Layout manager

struct XTP_DOCKINGPANE_INFO {
  CXTPDockingPane* pPane;
  CXTPDockingPaneBase* pFloatingHolder;
  CXTPDockingPaneBase* pDockingHolder;
  CXTPDockingPaneBase* pLastHolder;
};
File

XTPDockingPaneDefines.h

Members

pPane
Docking Pane
pFloatingHolder
Last floating holder of the pane
pDockingHolder
Last docking holder of the pane
pLastHolder
Last holder (must be pFloatingHolder or pDockingHolder)

See Also

CXTPDockingPaneLayout

Group

Structs, Records, Enums


XTPDockingContextStickerStyle Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums, Example
XTPDockingContextStickerStyle Enumeration

Docking Panes sticker style enumeration

enum XTPDockingContextStickerStyle {
  xtpPaneStickerStyleWhidbey,
  xtpPaneStickerStyleVisualStudio2005
};
File

XTPDockingPaneDefines.h

Members

xtpPaneStickerStyleWhidbey
Whidbey stickers
xtpPaneStickerStyleVisualStudio2005
Visual Studio 2005 stickers

Example
m_paneManager.SetStickerStyle(xtpPaneStickerStyleVisualStudio2005);

Group

Structs, Records, Enums


XTPDockingPaneAction Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneAction Enumeration

Actions a docking pane is currently performing.

enum XTPDockingPaneAction {
  xtpPaneActionFloating,
  xtpPaneActionFloated,
  xtpPaneActionClosing,
  xtpPaneActionClosed,
  xtpPaneActionDocking,
  xtpPaneActionDocked,
  xtpPaneActionAttaching,
  xtpPaneActionAttached,
  xtpPaneActionPinning,
  xtpPaneActionPinned,
  xtpPaneActionCollapsing,
  xtpPaneActionCollapsed,
  xtpPaneActionExpanding,
  xtpPaneActionExpanded,
  xtpPaneActionActivated,
  xtpPaneActionDeactivated,
  xtpPaneActionDetaching,
  xtpPaneActionDragging,
  xtpPaneActionUnpinning,
  xtpPaneActionUnpinned,
  xtpPaneActionSplitterResizing,
  xtpPaneActionSplitterResized
};
File

XTPDockingPaneDefines.h

Members

xtpPaneActionFloating
Docking pane is currently floating.
xtpPaneActionFloated
Docking pane has been docked, and is currently floating.
xtpPaneActionClosing
Docking pane is currently closing.
xtpPaneActionClosed
Docking pane has been closed.
xtpPaneActionDocking
Docking pane is in the process of docking.
xtpPaneActionDocked
Docking pane has been docked.
xtpPaneActionAttaching
Docking pane is in the process of attaching to another pane.
xtpPaneActionAttached
Docking pane has been attached.
xtpPaneActionPinning
Docking pane is currently pinning (hiding).
xtpPaneActionPinned
Docking pane has been pinned.
xtpPaneActionCollapsing
Docking pane is currently collapsing (hiding).
xtpPaneActionCollapsed
Docking Pane has been collapsed.
xtpPaneActionExpanding
Docking pane is currently expanding.
xtpPaneActionExpanded
Docking pane is expanded, this is when the pane is fully shown from the auto-hide position.
xtpPaneActionActivated
Docking pane become active
xtpPaneActionDeactivated
Docking pane deactivated
xtpPaneActionDetaching
Docking pane deactivated
xtpPaneActionDragging
Docking pane has been dragged
xtpPaneActionUnpinning
Docking pane is currently docked.
xtpPaneActionUnpinned
Docking pane has been unpinned.
xtpPaneActionSplitterResizing
Docking pane splitter resizing
xtpPaneActionSplitterResized
Docking pane splitter resized

See Also

XTP_DOCKINGPANE_ACTION, XTP_DPN_ACTION

Example
BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
    ON_MESSAGE(XTPWM_DOCKINGPANE_NOTIFY, OnDockingPaneNotify)
END_MESSAGE_MAP()

LRESULT CMainFrame::OnDockingPaneNotify(WPARAM wParam, LPARAM lParam)
{
    if (wParam == XTP_DPN_ACTION)
    {
        XTP_DOCKINGPANE_ACTION* pAction = (XTP_DOCKINGPANE_ACTION*)lParam;
        TRACE("Action %in", pAction->action);
        return TRUE;
    }
    return FALSE;
}
Group

Structs, Records, Enums


XTPDockingPaneCaptionButtonStyle Enumeration

XTPDockingPanePaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneCaptionButtonStyle Enumeration

Enumeration of the caption button styles

enum XTPDockingPaneCaptionButtonStyle {
  xtpPaneCaptionButtonDefault,
  xtpPaneCaptionButtonOffice,
  xtpPaneCaptionButtonOffice2003,
  xtpPaneCaptionButtonThemedExplorerBar,
  xtpPaneCaptionButtonThemedButton,
  xtpPaneCaptionButtonThemedToolBar,
  xtpPaneCaptionButtonThemedToolWindow
};
File

XTPDockingPanePaintManager.h

Members

xtpPaneCaptionButtonDefault
Default caption button style
xtpPaneCaptionButtonOffice
Office XP caption button style
xtpPaneCaptionButtonOffice2003
Office 2003 caption button style
xtpPaneCaptionButtonThemedExplorerBar
Explorer button style
xtpPaneCaptionButtonThemedButton
Windows XP Button style
xtpPaneCaptionButtonThemedToolBar
Windows XP Toolbar style
xtpPaneCaptionButtonThemedToolWindow
Window XP Tool Window style

See Also

CXTPDockingPanePaintManager::SetCaptionButtonStyle

Example

m_paneManager.GetPaintManager()->SetCaptionButtonStyle(xtpPaneCaptionButtonThemedExplorerBar);

Group

Structs, Records, Enums


XTPDockingPaneCaptionDirection Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneCaptionDirection Enumeration

Docking Pane Caption direction enumeration

enum XTPDockingPaneCaptionDirection {
  xtpPaneCaptionHorizontal,
  xtpPaneCaptionVertical,
  xtpPaneCaptionAutoByPosition,
  xtpPaneCaptionAutoBySize
};
File

XTPDockingPaneDefines.h

Members

xtpPaneCaptionHorizontal
Show caption on top
xtpPaneCaptionVertical
Show caption on left
xtpPaneCaptionAutoByPosition
Automatically
xtpPaneCaptionAutoBySize
Automatically

See Also

CXTPDockingPaneManager::SetCaptionDirection

Example
m_paneManager.SetCaptionDirection(xtpPaneCaptionAutoBySize);
Group

Structs, Records, Enums


XTPDockingPaneDirection Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneDirection Enumeration

Docking direction enumeration

enum XTPDockingPaneDirection {
  xtpPaneDockLeft,
  xtpPaneDockRight,
  xtpPaneDockTop,
  xtpPaneDockBottom
};
File

XTPDockingPaneDefines.h

Members

xtpPaneDockLeft
To dock the pane to the left of the pane or frame.
xtpPaneDockRight
To dock the pane to the right of the pane or frame.
xtpPaneDockTop
To dock the pane to the top of the pane or frame.
xtpPaneDockBottom
To dock the pane to the bottom of the pane or frame.

See Also

CXTPDockingPaneManager::CreatePane, CXTPDockingPaneManager

Example
CXTPDockingPane* pwndPane1 = GetDockingPaneManager()->CreatePane(
    IDR_PANE1, CRect(0, 0, 200, 120), xtpPaneDockTop);
Group

Structs, Records, Enums


XTPDockingPaneKeyboardNavigate Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneKeyboardNavigate Enumeration

Keyboard options indicates which key can be used to navigate panes

enum XTPDockingPaneKeyboardNavigate {
  xtpPaneKeyboardUnused = 0,
  xtpPaneKeyboardUseAltMinus = 1,
  xtpPaneKeyboardUseAltF6 = 2,
  xtpPaneKeyboardUseAltF7 = 4,
  xtpPaneKeyboardUseCtrlTab = 8,
  xtpPaneKeyboardUseAll = 15
};
File

XTPDockingPaneDefines.h

Members

xtpPaneKeyboardUnused
Don't use keyboard
xtpPaneKeyboardUseAltMinus
To use Alt+'-' to show context menu
xtpPaneKeyboardUseAltF6
To use Alt+F6 to select next pane
xtpPaneKeyboardUseAltF7
To use Alt+F7 to show window select dialog
xtpPaneKeyboardUseCtrlTab
To use Ctrl+Tab to show window select dialog
xtpPaneKeyboardUseAll
To use all keys

See Also

CXTPDockingPaneManager::EnableKeyboardNavigate

Example
m_paneManager.EnableKeyboardNavigate(xtpPaneKeyboardUseAll);
Group

Structs, Records, Enums


XTPDockingPaneOptions Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneOptions Enumeration

Docking Pane Options enumeration

enum XTPDockingPaneOptions {
  xtpPaneNoCloseable = 1,
  xtpPaneNoHideable = 2,
  xtpPaneNoFloatable = 4,
  xtpPaneNoCaption = 8,
  xtpPaneHasMenuButton = 16,
  xtpPaneNoDockable = 32
};
File

XTPDockingPaneDefines.h

Members

xtpPaneNoCloseable
Pane can't be closed.
xtpPaneNoHideable
Pane can't be hidden.
xtpPaneNoFloatable
Pane can't be floated.
xtpPaneNoCaption
Pane has no caption.
xtpPaneHasMenuButton
Pane has menu button.
xtpPaneNoDockable
Pane can't be docked.

See Also

CXTPDockingPaneManager::SetDefaultPaneOptions, CXTPDockingPane::SetOptions

Example
// Remove Hide button for all panes
m_paneManager.SetDefaultPaneOptions(xtpPaneNoHideable);
// Remove close button for pPane
pPane->SetOptions(xtpPaneNoCloseable);
Group

Structs, Records, Enums


XTPDockingPanePaintTheme Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPanePaintTheme Enumeration

Visual theme enumeration

enum XTPDockingPanePaintTheme {
  xtpPaneThemeDefault,
  xtpPaneThemeOffice,
  xtpPaneThemeOffice2003,
  xtpPaneThemeNativeWinXP,
  xtpPaneThemeGrippered,
  xtpPaneThemeVisio,
  xtpPaneThemeWhidbey,
  xtpPaneThemeShortcutBar2003,
  xtpPaneThemeExplorer,
  xtpPaneThemeVisualStudio2005,
  xtpPaneThemeOffice2007,
  xtpPaneThemeWord2007,
  xtpPaneThemeCustom
};
File

XTPDockingPaneDefines.h

Members

xtpPaneThemeDefault
Default theme.
xtpPaneThemeOffice
Visual Studio .NET style theme.
xtpPaneThemeOffice2003
Office 2003 style theme.
xtpPaneThemeNativeWinXP
XP Theme.
xtpPaneThemeGrippered
Visual Studio 6 style theme.
xtpPaneThemeVisio
Visio style theme.
xtpPaneThemeWhidbey
Whidbey theme
xtpPaneThemeShortcutBar2003
Shortcut Bar 2003 theme
xtpPaneThemeExplorer
Explorer theme
xtpPaneThemeVisualStudio2005
Visual Studio 2005 theme
xtpPaneThemeOffice2007
Office 2007 theme
xtpPaneThemeWord2007
Word 2007 theme
xtpPaneThemeCustom
Custom theme.

See Also

CXTPDockingPaneManager, CXTPDockingPaneManager::SetTheme

Example
m_paneManager.SetTheme(xtpPaneThemeWhidbey);
Group

Structs, Records, Enums


XTPDockingPanePinState Enumeration

XTPDockingPanePaintManager.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPanePinState Enumeration

Enumeration of the pin button state

enum XTPDockingPanePinState {
  xtpPanePinVisible = 1,
  xtpPanePinPushed = 2
};
File

XTPDockingPanePaintManager.h

Members

xtpPanePinVisible
Pin button is visible.
xtpPanePinPushed
Pin button is pushed.

See Also

CXTPDockingPaneCaptionButton::GetState, CXTPDockingPaneCaptionButton::SetState

Group

Structs, Records, Enums


XTPDockingPaneSplitterStyle Enumeration

XTPDockingPanePaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneSplitterStyle Enumeration

Enumeration of the splitter styles

enum XTPDockingPaneSplitterStyle {
  xtpPaneSplitterFlat = 0,
  xtpPaneSplitter3D = 1,
  xtpPaneSplitterSoft3D = 2,
  xtpPaneSplitterGradient = 4,
  xtpPaneSplitterGradientVert = 8,
  xtpPaneSplitterGripperOfficeXP = 0x100,
  xtpPaneSplitterGripperOffice2003 = 0x200
};
File

XTPDockingPanePaintManager.h

Members

xtpPaneSplitterFlat
Flat splitter style
xtpPaneSplitter3D
3D splitter style
xtpPaneSplitterSoft3D
Soft splitter style
xtpPaneSplitterGradient
Gradient splitter style
xtpPaneSplitterGradientVert
Gradient splitter style
xtpPaneSplitterGripperOfficeXP
Splitter has OfficeXP gripper
xtpPaneSplitterGripperOffice2003
Splitter has Office2003 gripper

See Also

CXTPDockingPanePaintManager::SetSplitterStyle

Example

m_paneManager.GetPaintManager()->SetSplitterStyle(xtpPaneSplitterSoft3D + xtpPaneSplitterGripperOffice2003);

Group

Structs, Records, Enums


XTPDockingPaneStickerType Enumeration

XTPDockingPaneContext.h, Structs, Records, Enums, See Also
XTPDockingPaneStickerType Enumeration

XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be drawn on the screen when a docking pane is dragged.

enum XTPDockingPaneStickerType {
  xtpPaneStickerNone = 0,
  xtpPaneStickerLeft = 1,
  xtpPaneStickerRight = 2,
  xtpPaneStickerTop = 4,
  xtpPaneStickerBottom = 8,
  xtpPaneStickerCenter = 16,
  xtpPaneStickerClient = 32
};
File

XTPDockingPaneContext.h

Members

xtpPaneStickerNone
No docking stickers are displayed
xtpPaneStickerLeft
Display the docking sticker indicating the pane can be docked to the left.
xtpPaneStickerRight
Display the docking sticker indicating the pane can be docked to the right.
xtpPaneStickerTop
Display the docking sticker indicating the pane can be docked on the top.
xtpPaneStickerBottom
Display the docking sticker indicating the pane can be docked on the bottom.
xtpPaneStickerCenter
Display the docking sticker indicating the pane can be docked in the center.
xtpPaneStickerClient
Display the left, top, bottom, and right docking stickers on the client frame.

Remarks

m_bUseAlphaContext must be TRUE to display docking stickers.

See Also

CXTPDockingPaneContext::CreateNewSticker, CXTPDockingPaneContextStickerWnd::m_typeSticker, CXTPDockingPaneContextStickerWnd::m_selectedSticker

Group

Structs, Records, Enums


XTPDockingPaneType Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneType Enumeration

Docking pane type

enum XTPDockingPaneType {
  xtpPaneTypeDockingPane,
  xtpPaneTypeTabbedContainer,
  xtpPaneTypeSplitterContainer,
  xtpPaneTypeMiniWnd,
  xtpPaneTypeClient,
  xtpPaneTypeAutoHidePanel,
  xtpPaneTypeSidePanel
};
File

XTPDockingPaneDefines.h

Members

xtpPaneTypeDockingPane
Object is the docking pane.
xtpPaneTypeTabbedContainer
Object is the tabbed container.
xtpPaneTypeSplitterContainer
Object is the splitter container.
xtpPaneTypeMiniWnd
Object is the mini window container.
xtpPaneTypeClient
Object is the pane contained client area.
xtpPaneTypeAutoHidePanel
Object is the auto hide panel.
xtpPaneTypeSidePanel
Object is the side panel.

See Also

CXTPDockingPaneBase::GetType, CXTPDockingPaneBase

Example
if (pPane->GetType() == xtpPaneTypeDockingPane)
{
    // This is CXTPDockingPane object
}
Group

Structs, Records, Enums


XTPXTPDockingPaneEnableOptions Enumeration

XTPDockingPaneDefines.h, Structs, Records, Enums
XTPXTPDockingPaneEnableOptions Enumeration

Enable options of the pane

enum XTPXTPDockingPaneEnableOptions {
  xtpPaneDisabled = 0,
  xtpPaneEnableClient = 1,
  xtpPaneEnableActions = 2,
  xtpPaneEnabled = 3
};
File

XTPDockingPaneDefines.h

Members

xtpPaneDisabled
Pane is disabled
xtpPaneEnableClient
Client is enabled
xtpPaneEnableActions
All actions are enabled
xtpPaneEnabled
Pane is enabled

Group

Structs, Records, Enums


Types

Docking Panes, Types
Types
Module

Docking Panes

Types
Type | Description
CXTPDockingPaneBaseList | This list is used for maintaining a CXTPDockingPaneBase collection.
CXTPDockingPaneInfoList | This list is used by the CXTPDockingPaneLayout class for maintaining a XTP_DOCKINGPANE_INFO collection.
CXTPDockingPaneList | This list is used by the CXTPDockingPaneTabbedContainer class for maintaining a CXTPDockingPane collection.
CXTPPaneIndexToPaneMap | This map is used for mapping index to CXTPDockingPaneBase objects.
CXTPPaneToPaneMap | This map is used for mapping CXTPDockingPaneBase objects.


CXTPDockingPaneBaseList Type

XTPDockingPaneDefines.h, Types, See Also
CXTPDockingPaneBaseList Type

This list is used for maintaining a CXTPDockingPaneBase collection.

typedef CList<CXTPDockingPaneBase*, CXTPDockingPaneBase*> CXTPDockingPaneBaseList;
File

XTPDockingPaneDefines.h

See Also

CXTPDockingPaneBase::FindPane, CXTPDockingPaneAutoHidePanel::GetPanes

Group

Types


CXTPDockingPaneInfoList Type

XTPDockingPaneDefines.h, Types, See Also
CXTPDockingPaneInfoList Type

This list is used by the CXTPDockingPaneLayout class for maintaining a XTP_DOCKINGPANE_INFO collection.

typedef CList<XTP_DOCKINGPANE_INFO, XTP_DOCKINGPANE_INFO&> CXTPDockingPaneInfoList;
File

XTPDockingPaneDefines.h

See Also

CXTPDockingPaneLayout::GetPaneList, CXTPDockingPaneManager::GetPaneList

Group

Types


CXTPDockingPaneList Type

XTPDockingPaneDefines.h, Types, See Also
CXTPDockingPaneList Type

This list is used by the CXTPDockingPaneTabbedContainer class for maintaining a CXTPDockingPane collection.

typedef CList<CXTPDockingPane*, CXTPDockingPane*> CXTPDockingPaneList;
File

XTPDockingPaneDefines.h

See Also

CXTPDockingPaneTabbedContainer::GetPanes

Group

Types


CXTPPaneIndexToPaneMap Type

XTPDockingPaneDefines.h, Types
CXTPPaneIndexToPaneMap Type

This map is used for mapping index to CXTPDockingPaneBase objects.

typedef CMap<int, int, CXTPDockingPaneBase*, CXTPDockingPaneBase*> CXTPPaneIndexToPaneMap;
File

XTPDockingPaneDefines.h

Group

Types


CXTPPaneToPaneMap Type

XTPDockingPaneDefines.h, Types, Example, See Also
CXTPPaneToPaneMap Type

This map is used for mapping CXTPDockingPaneBase objects.

typedef CMap<CXTPDockingPaneBase*, CXTPDockingPaneBase*, CXTPDockingPaneBase*, CXTPDockingPaneBase*> CXTPPaneToPaneMap;
File

XTPDockingPaneDefines.h

See Also

CXTPDockingPaneBase::Clone, CXTPDockingPane::Clone

Example
CXTPDockingPaneBase* CXTPDockingPaneBase::Clone(
    CXTPDockingPaneLayout* pLayout,
    CXTPPaneToPaneMap* pMap,
    DWORD /*dwIgnoredOptions*/)
{
    ASSERT(pMap);
    CXTPDockingPaneBase* pClone = new CXTPDockingPaneBase(m_type, pLayout);
    pMap->SetAt(this, pClone);
    return pClone;
}
Group

Types


Macros

Macros, Docking Panes
Macros
Macros
Macro | Description
XTPWM_DOCKINGPANE_NOTIFY | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
Module

Docking Panes


XTPWM_DOCKINGPANE_NOTIFY Macro

XTPDockingPaneDefines.h, Macros, Example
XTPWM_DOCKINGPANE_NOTIFY Macro

The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.

#define XTPWM_DOCKINGPANE_NOTIFY (WM_XTP_DOCKINGPANE_BASE + 1)
File

XTPDockingPaneDefines.h

Parameters

pPane
The value of lParam points to a CXTPDockingPane object that becomes visible.(for XTP_DPN_SHOWWINDOW) This pointer should never be NULL.

Returns

If the application is to process this message, the return value should be TRUE, otherwise the return value is FALSE.

Remarks

The XTPWM_DOCKINGPANE_NOTIFY notification message is sent to inform the owner window that an action occurs within the DockingPanes. The owner window of the color picker receives this notification through the WM_COMMAND message.

XTPWM_DOCKINGPANE_NOTIFY
CXTPDockingPane* pPane = (CXTPDockingPane*)lParam; // pointer to an CXTPDockingPane object

wParam can be one of the following:

  • XTP_DPN_SHOWWINDOW The docking pane is just a virtual container for a user window. The best place to associate them is after the pane becomes visible because, initially, it can be created, closed, hidden, or as a non-active tab. You can create your user window in this handler. Process this message to attach an existing window to the Docking Pane container using the Attach member function.
  • XTP_DPN_RCLICK User presses the right mouse button on the docking pane container.
  • XTP_DPN_CLOSEPANE User close the Pane. You can return XTP_ACTION_NOCLOSE while processing the XTP_DPN_CLOSEPANE notification to disable closing docking pane windows.
  • XTP_DPN_ACTION Extended action occur (see XTPDockingPaneAction)
  • XTP_DPN_CONTEXTMENU User pressed menu button or right click to show context menu
Example

Here is an example of how an application would process the XTPWM_DOCKINGPANE_NOTIFY message.

BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
    ON_MESSAGE(XTPWM_DOCKINGPANE_NOTIFY, OnDockingPaneNotify)
END_MESSAGE_MAP()

LRESULT CMainFrame::OnDockingPaneNotify(WPARAM wParam, LPARAM lParam)
{
    switch ((int)wParam)
    {
    case XTP_DPN_SHOWWINDOW:
        {
            CXTPDockingPane* pPane = (CXTPDockingPane*)lParam;

            // check if the Pane hasn't been attached yet.
            if (!pPane->IsValid())
            {
                // check if the user window hasn't been created.
                if (!m_wndPane.m_hWnd)
                {
                    // create it.
                    m_wndPane.CreateEx(WS_EX_STATICEDGE, _T("EDIT"), _T(""),
                        WS_CHILD | ES_AUTOVSCROLL | ES_MULTILINE,
                        CRect(0, 0, 200, 120), this, 0);
                }
                // attach it to the Pane.
                pPane->Attach(&m_wndPane);
            }
            return TRUE;
        }
    case XTP_DPN_CLOSEPANE:
        {
            // Disable the user from closing docking panes.
            return XTP_ACTION_NOCLOSE;
        }
    }

    return FALSE;
}
Group

Macros


Files

Files, Docking Panes
Files
Files
File | Description
XTPDockingPane.h | XTPDockingPane.h : interface for the CXTPDockingPane class.
XTPDockingPaneAutoHidePanel.h | XTPDockingPaneAutoHidePanel.h : interface for the CXTPDockingPaneAutoHidePanel class.
XTPDockingPaneBase.h | XTPDockingPaneBase.h : interface for the CXTPDockingPaneBase class.
XTPDockingPaneBaseContainer.h | XTPDockingPaneBaseContainer.h : interface for the CXTPDockingPaneBaseContainer class.
XTPDockingPaneContext.h | XTPDockingPaneContext.h : interface for the CXTPDockingPaneContext class.
XTPDockingPaneDefines.h | XTPDockingPaneDefines.h : public defines, structures and enumerations.
XTPDockingPaneLayout.h | XTPDockingPaneLayout.h : interface for the CXTPDockingPaneLayout class.
XTPDockingPaneManager.h | XTPDockingPaneManager.h : interface for the CXTPDockingPaneManager class.
XTPDockingPaneMiniWnd.h | XTPDockingPaneMiniWnd.h : interface for the CXTPDockingPaneMiniWnd class.
XTPDockingPanePaintManager.h | XTPDockingPanePaintManager.h : interface for the CXTPDockingPanePaintManager class.
XTPDockingPaneSplitterContainer.h | XTPDockingPaneSplitterContainer.h : interface for the CXTPDockingPaneSplitterContainer class.
XTPDockingPaneTabbedContainer.h | XTPDockingPaneTabbedContainer.h : interface for the CXTPDockingPaneTabbedContainer class.
Module

Docking Panes


XTPDockingPane.h

Classes, Files
XTPDockingPane.h

XTPDockingPane.h : interface for the CXTPDockingPane class.

Classes
Class | Description
CXTPDockingPane | CXTPDockingPane is a CXTPDockingPaneBase derived class. It is used as a container for a user window.
Group

Files


XTPDockingPaneAutoHidePanel.h

Classes, Files
XTPDockingPaneAutoHidePanel.h

XTPDockingPaneAutoHidePanel.h : interface for the CXTPDockingPaneAutoHidePanel class.

Classes
Class | Description
CXTPDockingPaneAutoHidePanel | CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It is used internally as an auto-hide container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneAutoHideWnd | CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class. It is used internally by CXTPDockingPaneAutoHidePanel as a sliding auto-hide window for the hidden pane.
Group

Files


XTPDockingPaneBase.h

Classes, Files
XTPDockingPaneBase.h

XTPDockingPaneBase.h : interface for the CXTPDockingPaneBase class.

Classes
Class | Description
CXTPDockingPaneBase | CXTPDockingPaneBase is a stand alone class. It represents the parent class for a Docking Pane and its containers.
CXTPDockingPaneCaptionButtons | CXTPDockingPaneCaptionButtons is CArray derived class used for manipulate Caption Buttons.
Group

Files


XTPDockingPaneBaseContainer.h

Classes, Files
XTPDockingPaneBaseContainer.h

XTPDockingPaneBaseContainer.h : interface for the CXTPDockingPaneBaseContainer class.

Classes
Class | Description
CXTPDockingPaneBaseContainer | CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class. It represents the parent class for a all virtual containers.
Group

Files


XTPDockingPaneContext.h

Classes, Enumerations, Files, Legend
XTPDockingPaneContext.h

XTPDockingPaneContext.h : interface for the CXTPDockingPaneContext class.

Classes
Class | Description
CXTPDockingPaneContext | CXTPDockingPaneContext is a stand alone class. It is used internally for docking and sizing panes.
CXTPDockingPaneContextAlphaWnd | CXTPDockingPaneContextAlphaWnd is CWnd derived class represents alpha context helper window
CXTPDockingPaneContextStickerWnd | CXTPDockingPaneContextStickerWnd is CWnd derived class represents sticker window.
Enumerations
Enumeration | Description
XTPDockingPaneStickerType | XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be drawn on the screen when a docking pane is dragged.
Group

Files

Legend
Enumeration


XTPDockingPaneDefines.h

Enumerations, Files, Legend, Macros, Types, Variables, Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPDockingPaneDefines.h

XTPDockingPaneDefines.h : public defines, structures and enumerations.

Enumerations
Enumeration | Description
XTPDockingContextStickerStyle | Docking Panes sticker style enumeration
XTPDockingPaneAction | Actions a docking pane is currently performing.
XTPDockingPaneCaptionDirection | Docking Pane Caption direction enumeration
XTPDockingPaneDirection | Docking direction enumeration
XTPDockingPaneKeyboardNavigate | Keyboard options indicates which key can be used to navigate panes
XTPDockingPaneOptions | Docking Pane Options enumeration
XTPDockingPanePaintTheme | Visual theme enumeration
XTPDockingPaneType | Docking pane type
XTPXTPDockingPaneEnableOptions | Enable options of the pane
Group

Files

Macros
Macro | Description
XTPWM_DOCKINGPANE_NOTIFY | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
Types
Type | Description
CXTPDockingPaneBaseList | This list is used for maintaining a CXTPDockingPaneBase collection.
CXTPDockingPaneInfoList | This list is used by the CXTPDockingPaneLayout class for maintaining a XTP_DOCKINGPANE_INFO collection.
CXTPDockingPaneList | This list is used by the CXTPDockingPaneTabbedContainer class for maintaining a CXTPDockingPane collection.
CXTPPaneIndexToPaneMap | This map is used for mapping index to CXTPDockingPaneBase objects.
CXTPPaneToPaneMap | This map is used for mapping CXTPDockingPaneBase objects.
Variables
Variable | Description
WM_XTP_DOCKINGPANE_BASE | Base for all docking pane messages
XTP_ACTION_NOCLOSE | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_ACTION | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_CLOSEPANE | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_CONTEXTMENU | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_RCLICK | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_SHOWWINDOW | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
Legend
Structure
Enumeration
Structures
Structure | Description
XTP_DOCKINGPANE_ACTION | XTP_DOCKINGPANE_ACTION structure contains information about action performed by user with docking panes.
XTP_DOCKINGPANE_CLICK | XTP_DOCKINGPANE_CLICK structure contains information about pane was used in XTP_DPN_PANEMENUCLICK message
XTP_DOCKINGPANE_INFO | Internal structure used by Layout manager


XTPDockingPaneLayout.h

Classes, Files
XTPDockingPaneLayout.h

XTPDockingPaneLayout.h : interface for the CXTPDockingPaneLayout class.

Classes
Class | Description
CXTPDockingPaneLayout | CXTPDockingPaneLayout is a stand alone class. It is used to manipulate a pane's layouts.
Group

Files


XTPDockingPaneManager.h

Classes, Files
XTPDockingPaneManager.h

XTPDockingPaneManager.h : interface for the CXTPDockingPaneManager class.

Classes
Class | Description
CXTPDockingPaneManager | CXTPDockingPaneManager is a CWnd derived class. It is used to manipulate docking panes.
Group

Files


XTPDockingPaneMiniWnd.h

Classes, Files
XTPDockingPaneMiniWnd.h

XTPDockingPaneMiniWnd.h : interface for the CXTPDockingPaneMiniWnd class.

Classes
Class | Description
CXTPDockingPaneMiniWnd | CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase. It is used internally as a MiniWnd container for CXTPDockingPaneBase derived classes.
Group

Files


XTPDockingPanePaintManager.h

Classes, Enumerations, Files, Legend
XTPDockingPanePaintManager.h

XTPDockingPanePaintManager.h : interface for the CXTPDockingPanePaintManager class.

Classes
Class | Description
CXTPDockingPaneCaptionButton | CXTPDockingPaneCaptionButton is a stand alone internal class.
CXTPDockingPaneDefaultTheme | CXTPDockingPaneDefaultTheme is CXTPDockingPanePaintManager derived class, represents classic theme for docking panes.
CXTPDockingPaneExplorerTheme | CXTPDockingPaneExplorerTheme is CXTPDockingPaneDefaultTheme derived class, represents explorer theme for docking panes.
CXTPDockingPaneGripperedTheme | CXTPDockingPaneGripperedTheme is CXTPDockingPaneDefaultTheme derived class, represents gripper theme for docking panes.
CXTPDockingPaneNativeXPTheme | CXTPDockingPaneNativeXPTheme is CXTPDockingPaneOfficeTheme derived class, represents Win XP theme for docking panes.
CXTPDockingPaneOffice2003Theme | CXTPDockingPaneOffice2003Theme is CXTPDockingPaneOfficeTheme derived class, represents Office 2003 theme for docking panes.
CXTPDockingPaneOffice2007Theme | CXTPDockingPaneOffice2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2007 theme for docking panes.
CXTPDockingPaneOfficeTheme | CXTPDockingPaneOfficeTheme is CXTPDockingPaneGripperedTheme derived class, represents Office XP theme for docking panes.
CXTPDockingPanePaintManager | CXTPDockingPanePaintManager is a stand alone class. Override some virtual functions to get a new visual theme.
CXTPDockingPaneShortcutBar2003Theme | CXTPDockingPaneShortcutBar2003Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2003 theme for docking panes.
CXTPDockingPaneVisioTheme | CXTPDockingPaneVisioTheme is CXTPDockingPaneOfficeTheme derived class, represents Visio theme for docking panes.
CXTPDockingPaneVisualStudio2005SecondTheme | CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneWhidbeyTheme derived class, represents Visual Studio 2005 beta 2 theme for docking panes.
CXTPDockingPaneVisualStudio2005Theme | CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneVisualStudio2005SecondTheme derived class, represents Visual Studio 2005 theme for docking panes.
CXTPDockingPaneWhidbeyTheme | CXTPDockingPaneWhidbeyTheme is CXTPDockingPaneOfficeTheme derived class, represents Visual Studio 2005 theme for docking panes.
CXTPDockingPaneWord2007Theme | CXTPDockingPaneWord2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office Word 2007 theme for docking panes.
Enumerations
Enumeration | Description
XTPDockingPaneCaptionButtonStyle | Enumeration of the caption button styles
XTPDockingPanePinState | Enumeration of the pin button state
XTPDockingPaneSplitterStyle | Enumeration of the splitter styles
Group

Files

Legend
Enumeration


XTPDockingPaneSplitterContainer.h

Classes, Files
XTPDockingPaneSplitterContainer.h

XTPDockingPaneSplitterContainer.h : interface for the CXTPDockingPaneSplitterContainer class.

Classes
Class | Description
CXTPDockingPaneSplitterContainer | CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class. It is used internally as a splitter container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneSplitterWnd | CXTPDockingPaneSplitterWnd is a CWnd derived class. It is used internally for splitting Panes.
Group

Files


XTPDockingPaneTabbedContainer.h

Classes, Files
XTPDockingPaneTabbedContainer.h

XTPDockingPaneTabbedContainer.h : interface for the CXTPDockingPaneTabbedContainer class.

Classes
Class | Description
CXTPDockingPaneTabbedContainer | CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It represents a tabbed container for Docking Panes.
Group

Files


Property Grid

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Structs, Records, Enums, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Property Grid

Codejock Software's Xtreme Property Grid provides Windows developers with a professional Visual Studio.NET™ style property grid.

Group

Xtreme Toolkit Pro v12.0

Legend
Structure
Enumeration
Classes
Class | Description
CXTPPropertyGrid | CXTPPropertyGrid is a CWnd derived class. It is used to create a property grid control similar to the property window in VS.NET. See the "PropertyGrid" demo for an example of its usage.
CXTPPropertyGridCoolTheme | CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class. This represents a Cool style theme.
CXTPPropertyGridDelphiTheme | CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class. This represents a Delphi style theme.
CXTPPropertyGridInplaceButton | CXTPPropertyGridInplaceButton is a CCmdTarget derived class. It represents inplace button in Property Grid control.
CXTPPropertyGridInplaceButtons | CXTPPropertyGridInplaceButtons is a CCmdTarget derived class. It represents collection of inplace buttons for specified grid item
CXTPPropertyGridInplaceControl | CXTPPropertyGridInplaceControl is CWnd derived class, represents base class for all item in place controls.
CXTPPropertyGridInplaceControls | CXTPPropertyGridInplaceControls is standalone class it represents collection of CXTPPropertyGridInplaceControl classes.
CXTPPropertyGridInplaceEdit | CXTPPropertyGridInplaceEdit is a CEdit derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceList | CXTPPropertyGridInplaceList is a CListBox derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceMonthCal | Month calendar popup used for CXTPPropertyGridItemDate item.
CXTPPropertyGridInplaceMultilineEdit | CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceSlider | CXTPPropertyGridInplaceSlider is CXTPPropertyGridInplaceControl derived class. It represents in-place slider of the items. Call CXTPPropertyGridItem::AddSliderControl() to add slider for property grid item
CXTPPropertyGridInplaceSpinButton | CXTPPropertyGridInplaceSpinButton is CXTPPropertyGridInplaceControl derived class. It represents in-place spin button of the items. Call CXTPPropertyGridItem::AddSpinButton() to add spin button for property grid item
CXTPPropertyGridItem | CXTPPropertyGridItem is the base class representing an item of the Property Grid Control.
CXTPPropertyGridItemBool | CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class. It is used to create a Boolean value item in a Property Grid control.
CXTPPropertyGridItemCategory | CXTPPropertyGridItemCategory is the CXTPPropertyGridItem derived class. Use it to add subcategory to property grid control.
CXTPPropertyGridItemColor | CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class. It is used to create an RGB value item in a Property Grid control.
CXTPPropertyGridItemConstraint | CXTPPropertyGridItemConstraint is a CCmdTarget derived class. It represents a single item constraints.
CXTPPropertyGridItemConstraints | CXTPPropertyGridItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.
CXTPPropertyGridItemDate | CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class. It is used to create Date item in a Property Grid control.
CXTPPropertyGridItemDouble | CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class. It is used to create an double value item in a Property Grid control.
CXTPPropertyGridItemEnum | CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class. It is used to create an Enum value item in a Property Grid control.
CXTPPropertyGridItemFlags | CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class. It is used to create a Flags value item in a Property Grid control.
CXTPPropertyGridItemFont | CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class. It is used to create a Font value item in a Property Grid control.
CXTPPropertyGridItemMetrics | Standalone class used by CXTPPropertyGridPaintManager as holder of item metrics
CXTPPropertyGridItemNumber | CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class. It is used to create an integer value item in a Property Grid control.
CXTPPropertyGridItems | CXTPPropertyGridItems is a CList derived class. It represents the items collection with some internal functionality.
CXTPPropertyGridItemSize | CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class. It is used to create a size value item in a Property Grid control.
CXTPPropertyGridNativeXPTheme | CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Native Windows XP style theme.
CXTPPropertyGridOffice2003Theme | CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class. This represents an Office 2003 style theme.
CXTPPropertyGridOfficeXPTheme | CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Office XP style theme.
CXTPPropertyGridPaintManager | Standalone class used by CXTPPropertyGrid as the paint manager.
CXTPPropertyGridSimpleTheme | CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class. This represents a Simple style theme.
CXTPPropertyGridToolBar | CXTPPropertyGridToolBar is a CToolBar derived class. It is an internal class used by Property Grid control
CXTPPropertyGridToolTip | CXTPPropertyGridToolTip is a CWnd derived class. It is an internal class used by Property Grid control
CXTPPropertyGridUpdateContext | CXTPPropertyGridUpdateContext is a CCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid. The property grid state information is stored in the CXTPPropertyGridUpdateContext object when CXTPPropertyGrid::BeginUpdate is called and after CXTPPropertyGrid::EndUpdate the expanding state of each item, selected item, and sort preference will be restored.
CXTPPropertyGridVerb | CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET. For example, when the DataGrid control is selected at design time in VS .NET, an AutoFormat link button appears in the Properties window just below the property grid and above the help panel. Verbs will be displayed in a separate panel just below the property grid. Verbs are links that can be used to perform actions in your application. When a verb is clicked, CXTPPropertyGrid::OnVerbClick is called by the framework. If both the verb panel and help panel are visible at the same... more
CXTPPropertyGridVerbs | A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel. See CXTPPropertyGridVerb for a description of verbs.
CXTPPropertyGridView | CXTPPropertyGridView is a CListBox derived class. It is an internal class used by Property Grid control
CXTPPropertyGridWhidbeyTheme | CXTPPropertyGridWhidbeyTheme is a CXTPPropertyGridPaintManager derived class. This represents a Visual Studio 2005 "Whidbey" style theme.
Files
File | Description
XTPPropertyGrid.h | XTPPropertyGrid.h interface for the CXTPPropertyGrid class.
XTPPropertyGridDefines.h | XTPPropertyGridDefines.h This file is a part of the XTREME PROPERTYGRID MFC class library.
XTPPropertyGridInplaceButton.h | XTPPropertyGridInplaceButton.h interface for the CXTPPropertyGridInplaceButton class.
XTPPropertyGridInplaceEdit.h | XTPPropertyGridInplaceEdit.h interface for the CXTPPropertyGridInplaceEdit class.
XTPPropertyGridInplaceList.h | XTPPropertyGridInplaceList.h interface for the CXTPPropertyGridInplaceList class.
XTPPropertyGridItem.h | XTPPropertyGridItem.h interface for the CXTPPropertyGridItem class.
XTPPropertyGridItemBool.h | XTPPropertyGridItemBool.h interface for the CXTPPropertyGridItemBool class.
XTPPropertyGridItemColor.h | XTPPropertyGridItemColor.h interface for the CXTPPropertyGridItemColor class.
XTPPropertyGridItemExt.h | XTPPropertyGridItemExt.h This file is a part of the XTREME PROPERTYGRID MFC class library.
XTPPropertyGridItemFont.h | XTPPropertyGridItemFont.h interface for the CXTPPropertyGridItemFont class.
XTPPropertyGridItemNumber.h | XTPPropertyGridItemNumber.h interface for the CXTPPropertyGridItemNumber class.
XTPPropertyGridItemSize.h | XTPPropertyGridItemSize.h interface for the CXTPPropertyGridItemSize class.
XTPPropertyGridPaintManager.h | XTPPropertyGridPaintManager.h interface for the CXTPPropertyGridPaintManager class.
XTPPropertyGridView.h | XTPPropertyGridView.h interface for the CXTPPropertyGridView class.
Structs, Records, Enums
Struct, Record, Enum | Description
XTP_PROPERTYGRID_NOTIFYEDIT | This struct passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, XTP_PGN_CANCELEDIT notifications to determine item and its new value
XTPPropertyGridBorderStyle | Border Style enumeration
XTPPropertyGridHitCode | XTPPropertyGridHitCode is an enumeration used by CXTPPropertyGrid to determine which part of the property grid is located at a specific point. CXTPPropertyGrid::HitTest is used to test a point when the user clicks on the property grid.
XTPPropertyGridInplaceButtonsStyle | InplaceButtons style
XTPPropertyGridItemColorEditor | Editor type for CXTPPropertyGridItemColor item
XTPPropertyGridItemFlags | Flags that indicate what styles to set for the grid item.
XTPPropertyGridPaintTheme | Visual theme enumeration
XTPPropertyGridSortOrder | XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style. This will specify how the items in the grid are displayed, I.e. Alphabetical, not sort, and grouped by category.
XTPPropertyGridUI | XTPPropertyGridUI is an enumeration used by CXTPPropertyGrid during navigation of the Property Grid, items, and verbs that specifies which object should receive focus.
Variables
Variable | Description
XTP_ID_PROPERTYGRID_COMBOBUTTON | Constructs a CXTPPropertyGridInplaceButton object
XTP_ID_PROPERTYGRID_EXPANDBUTTON | Constructs a CXTPPropertyGridInplaceButton object
XTP_PGI_EXPAND_BORDER | This constant is used to determine the "gutter" width of the property grid. This is the area on the left of the grid that the expand buttons are drawn in.
XTP_PGN_AFTEREDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_CANCELEDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_DBLCLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_DRAWITEM | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_EDIT_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_INPLACEBUTTONDOWN | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_ITEMEXPANDCHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_ITEMVALUE_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_RCLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_REQUESTEDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_SELECTION_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_SORTORDER_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_USER | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_VERB_CLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGS_OWNERDRAW | Apply this style to the property grid to use the owner draw feature.
XTPPROPERTYGRID_CLASSNAME | NULL terminated string used by CXTPPropertyGrid which specifies the window class name for the property grid.
XTPWM_PROPERTYGRID_NOTIFY | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid


Property Grid Hierarchy

Property Grid
Property Grid Hierarchy

Module

Property Grid


Classes

Classes, Property Grid
Classes
Classes
Class | Description
CXTPPropertyGrid | CXTPPropertyGrid is a CWnd derived class. It is used to create a property grid control similar to the property window in VS.NET. See the "PropertyGrid" demo for an example of its usage.
CXTPPropertyGridCoolTheme | CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class. This represents a Cool style theme.
CXTPPropertyGridDelphiTheme | CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class. This represents a Delphi style theme.
CXTPPropertyGridInplaceButton | CXTPPropertyGridInplaceButton is a CCmdTarget derived class. It represents inplace button in Property Grid control.
CXTPPropertyGridInplaceButtons | CXTPPropertyGridInplaceButtons is a CCmdTarget derived class. It represents collection of inplace buttons for specified grid item
CXTPPropertyGridInplaceControl | CXTPPropertyGridInplaceControl is CWnd derived class, represents base class for all item in place controls.
CXTPPropertyGridInplaceControls | CXTPPropertyGridInplaceControls is standalone class it represents collection of CXTPPropertyGridInplaceControl classes.
CXTPPropertyGridInplaceEdit | CXTPPropertyGridInplaceEdit is a CEdit derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceList | CXTPPropertyGridInplaceList is a CListBox derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceMonthCal | Month calendar popup used for CXTPPropertyGridItemDate item.
CXTPPropertyGridInplaceMultilineEdit | CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceSlider | CXTPPropertyGridInplaceSlider is CXTPPropertyGridInplaceControl derived class. It represents in-place slider of the items. Call CXTPPropertyGridItem::AddSliderControl() to add slider for property grid item
CXTPPropertyGridInplaceSpinButton | CXTPPropertyGridInplaceSpinButton is CXTPPropertyGridInplaceControl derived class. It represents in-place spin button of the items. Call CXTPPropertyGridItem::AddSpinButton() to add spin button for property grid item
CXTPPropertyGridItem | CXTPPropertyGridItem is the base class representing an item of the Property Grid Control.
CXTPPropertyGridItemBool | CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class. It is used to create a Boolean value item in a Property Grid control.
CXTPPropertyGridItemCategory | CXTPPropertyGridItemCategory is the CXTPPropertyGridItem derived class. Use it to add subcategory to property grid control.
CXTPPropertyGridItemColor | CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class. It is used to create an RGB value item in a Property Grid control.
CXTPPropertyGridItemConstraint | CXTPPropertyGridItemConstraint is a CCmdTarget derived class. It represents a single item constraints.
CXTPPropertyGridItemConstraints | CXTPPropertyGridItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.
CXTPPropertyGridItemDate | CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class. It is used to create Date item in a Property Grid control.
CXTPPropertyGridItemDouble | CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class. It is used to create an double value item in a Property Grid control.
CXTPPropertyGridItemEnum | CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class. It is used to create an Enum value item in a Property Grid control.
CXTPPropertyGridItemFlags | CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class. It is used to create a Flags value item in a Property Grid control.
CXTPPropertyGridItemFont | CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class. It is used to create a Font value item in a Property Grid control.
CXTPPropertyGridItemMetrics | Standalone class used by CXTPPropertyGridPaintManager as holder of item metrics
CXTPPropertyGridItemNumber | CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class. It is used to create an integer value item in a Property Grid control.
CXTPPropertyGridItems | CXTPPropertyGridItems is a CList derived class. It represents the items collection with some internal functionality.
CXTPPropertyGridItemSize | CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class. It is used to create a size value item in a Property Grid control.
CXTPPropertyGridNativeXPTheme | CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Native Windows XP style theme.
CXTPPropertyGridOffice2003Theme | CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class. This represents an Office 2003 style theme.
CXTPPropertyGridOfficeXPTheme | CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Office XP style theme.
CXTPPropertyGridPaintManager | Standalone class used by CXTPPropertyGrid as the paint manager.
CXTPPropertyGridSimpleTheme | CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class. This represents a Simple style theme.
CXTPPropertyGridToolBar | CXTPPropertyGridToolBar is a CToolBar derived class. It is an internal class used by Property Grid control
CXTPPropertyGridToolTip | CXTPPropertyGridToolTip is a CWnd derived class. It is an internal class used by Property Grid control
CXTPPropertyGridUpdateContext | CXTPPropertyGridUpdateContext is a CCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid. The property grid state information is stored in the CXTPPropertyGridUpdateContext object when CXTPPropertyGrid::BeginUpdate is called and after CXTPPropertyGrid::EndUpdate the expanding state of each item, selected item, and sort preference will be restored.
CXTPPropertyGridVerb | CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET. For example, when the DataGrid control is selected at design time in VS .NET, an AutoFormat link button appears in the Properties window just below the property grid and above the help panel. Verbs will be displayed in a separate panel just below the property grid. Verbs are links that can be used to perform actions in your application. When a verb is clicked, CXTPPropertyGrid::OnVerbClick is called by the framework. If both the verb panel and help panel are visible at the same... more
CXTPPropertyGridVerbs | A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel. See CXTPPropertyGridVerb for a description of verbs.
CXTPPropertyGridView | CXTPPropertyGridView is a CListBox derived class. It is an internal class used by Property Grid control
CXTPPropertyGridWhidbeyTheme | CXTPPropertyGridWhidbeyTheme is a CXTPPropertyGridPaintManager derived class. This represents a Visual Studio 2005 "Whidbey" style theme.
Module

Property Grid


CXTPPropertyGrid Class

XTPPropertyGrid.h, Classes, Legend, Members, Topics, CXTPPropertyGrid Data Members, CXTPPropertyGrid Methods, CXTPPropertyGrid Constructors, CXTPPropertyGrid Destructors, CXTPPropertyGrid Constructors, CXTPPropertyGrid Data Members, CXTPPropertyGrid Destructors, CXTPPropertyGrid Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid Class

CXTPPropertyGrid is a CWnd derived class. It is used to create a property grid control similar to the property window in VS.NET. See the "PropertyGrid" demo for an example of its usage.

Class Hierarchy

class CXTPPropertyGrid : public CWnd;
File

XTPPropertyGrid.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGrid Constructors
CXTPPropertyGrid Constructors | Description
CXTPPropertyGrid | Constructs a CXTPPropertyGrid object
CXTPPropertyGrid Data Members
CXTPPropertyGrid Data Members | Description
m_bEnableTooltips | TRUE if tooltips enabled
m_bHelpVisible | TRUE if the help panel is visible.
m_bHideSelection | TRUE to hide selection when control doesn't have focus;
m_bHighlightChanged | TRUE to highlight changed values
m_bMultiSelect | TRUE for MultiSelect;
m_bPreSubclassWindow | true' when initialized from PreSubclassWindow.
m_bShowInplaceButtonsAlways | TRUE to show all inplace buttons
m_bTabCaptions | TRUE to navigate items with the tab key.
m_bTabItems | TRUE to navigate items with the tab key.
m_bToolBarVisible | TRUE if the built in toolbar is visible.
m_bVariableItemsHeight | TRUE to allow variable items height
m_bVerbsVisible | TRUE if the verb panel is visible.
m_hCursorHand | Handle of the cursor.
m_hCursorSplit | Handle to the cursor when positioned over a splitter.
m_nFocusedVerb | Index of the currently focused verb within the collection of verbs.
m_nHelpHeight | Height of the description area (help panel).
m_nVerbsHeight | Height of the verbs panel.
m_pImageManager | Image manager of property grid
m_pInplaceEdit | In-place edit control.
m_pInplaceListBox | In-place list control.
m_pPaintManager | Current paint manager.
m_pToolTipContext | Tooltip context
m_pVerbs | Collection of verbs (links) displayed in the verb panel when the panel is visible.
m_pView | View pointer
m_themeCurrent | Currently set theme.
m_wndToolbar | Pointer to the "built-in" PropertyGrid toolbar.
CXTPPropertyGrid Destructors
CXTPPropertyGrid Destructors | Description
~CXTPPropertyGrid | Destroys a CXTPPropertyGrid object, handles cleanup and deallocation
CXTPPropertyGrid Methods
CXTPPropertyGrid Methods | Description
AddCategory |
BeginUpdate | Call this member function to "lock" the property grid. This should be called when adding or deleting a large number of item.
Create | Call this member function to create the Property Grid control.
CreateGridView | This member is called to create grid view window
CreateToolbar | This member is called when the "built-in" toolbar is created.
CreateView | Creates View of Property grid. Override this member to use custom view.
EnableMarkup | Call this method to enable markup for tab captions
EnableMultiSelect | Call this method to enable multi select.
EnableToolTips | Call this member function to enable or disable tooltips under items
EndUpdate | This member should be called after BeginUpdate. You need to call EndUpdate to "unlock" the grid after you have finished adding and deleting a large amount of items.
FindItem |
GetBorderStyle | Call this method to get current border style for Property Grid
GetCategories | Call this member function to return the categories of the property grid.
GetCount | Retrieves the number of items in a property grid.
GetCurrentTheme | Retrieves current theme of the grid.
GetGridView | Call this method to retrieve reference to the view object.
GetHelpBackColor | Call this member function to return the background color for the property grid.
GetHelpForeColor | Call this member function to return the foreground color for the property grid.
GetHelpHeight | Call this member function to return the height of the help pane when it is visible.
GetImageManager | Retrieves Image manager associated with property grid
GetMarkupContext | Returns markup context
GetPaintManager | Returns the currently used control's Paint Manager.
GetPropertySort | Call this member function to get the current grouping style for the Property Grid control.
GetSelectedItem | Call this member function to get selected item.
GetShowInplaceButtonsAlways | Determines if in-place buttons are visible for all items.
GetToolBar | Call this method to retrieve reference to the toolbar for the property grid.
GetToolTipContext | Call this method to get tooltip context pointer.
GetTopIndex | Retrieves the zero-based index of the first visible item in a control. Initially, item 0 is at the top of the property grid, but if the list box is scrolled, another item may be at the top.
GetVariableHelpHeight | Determines whether the user can resize the help box with the mouse.
GetVariableSplitterPos | Determines whether the user can move the property grid splitter.
GetVerbs | Call this member to return a pointer to the collection of verbs that are displayed in the verb panel.
GetViewDivider | Call this member function to return the divider position of the grid view.
HighlightChangedItems | Call this member to highlight all item with changed values
HitTest | This member is called to determine if the help splitter, verb splitter, or a verb was clicked upon.
InsertCategory |
IsBarVisible | Call this member function to determine if the toolbar is visible.
IsHelpVisible | Call this member function to determine if the help pane is visible.
IsHighlightChangedItems | Call this member to determine if changed items highlighter
IsLayoutRTL | Determines if right-to-left mode was set.
IsVerbsVisible | Call this member to determine if the verb panel is currently visible.
NavigateItems | Call this method to enable navigate items using Tab key.
OnInvertTracker | This method is called by the framework during resizing of splitters.
OnNavigate | This member is called when items in the property grid are navigated using key on the keyboard. This includes navigating the built in toolbar, verbs, and items in the property grid.
OnSelectionChanged | This member is called when a new item is selected in the grid. Or focus switched from one item to a different item.
OnSortChanged | This member is called when the sort order has changed.
OnVerbClick | This member is called when a user clicks on a verb or when a verb has focus and the enter key is pressed. Override this member to perform custom actions such as displaying a dialog.
OnVerbsChanged | This member is called when a Verb receives focus, and when focus switches from one verb to a different verb.
RedrawControl | Call this member to redraw control;
Refresh | Call this method to refresh items in the list.
RefreshToolBarButtons | This member is called when the toolbar buttons need to be redrawn.
RegisterWindowClass | Register the window class if it has not already been registered.
Reposition |
ResetContent | Removes all items from the list box of a property grid control.
SendNotifyMessage | Sends the specified message to the owner window.
SetBorderStyle | Call this method to set border style for Property Grid
SetCustomColors | Call this member function to set the custom colors of the Property Grid control.
SetCustomTheme | Call this method to set custom theme of the grid.
SetFont | This method sets the grid's current font to the specified font.
SetHelpHeight | Call this member function to set the height of the help pane when visible.
SetImageManager | Call this method to assign new image manager.
SetInplaceEdit | Call this method to set custom in-place edit control.
SetInplaceList | Call this method to set custom in-place list box control.
SetLayoutRTL | Call this member to set right-to-left mode.
SetPropertySort | Call this member function to modify the way items are grouped.
SetShowInplaceButtonsAlways | Call this member to show all in-place buttons of all items
SetStandardColors | Call this member function to set the default colors of the Property Grid control.
SetTheme | Call this member to set the grid theme.
SetTopIndex | Ensures that a particular list-box item is visible. Scrolls the property grid until either the item specified by nIndex appears at the top of the control or the maximum scroll range has been reached.
SetVariableHelpHeight | Specifies whether the user can resize the help box with the mouse.
SetVariableItemsHeight | Call this method to allow variable height items
SetVariableSplitterPos | Specifies whether the user can move the property grid splitter.
SetVerbsHeight | Call this member to specify the height of the verb box when visible.
SetViewDivider | Call this member function to set the divider position of the grid view.
SetViewDividerPos | Call this member function to set the divider position of the grid view.
ShowHelp | Call this member function to show or hide the description pane in the Property Grid window.
ShowToolBar | Call this member function to show or hide the toolbar control in the Property Grid window.


CXTPPropertyGrid Data Members

CXTPPropertyGrid Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid Data Members
Class

CXTPPropertyGrid Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bEnableTooltips | TRUE if tooltips enabled
m_bHelpVisible | TRUE if the help panel is visible.
m_bHighlightChanged | TRUE to highlight changed values
m_bMultiSelect | TRUE for MultiSelect;
m_bPreSubclassWindow | true' when initialized from PreSubclassWindow.
m_bShowInplaceButtonsAlways | TRUE to show all inplace buttons
m_bTabCaptions | TRUE to navigate items with the tab key.
m_bTabItems | TRUE to navigate items with the tab key.
m_bToolBarVisible | TRUE if the built in toolbar is visible.
m_bVariableItemsHeight | TRUE to allow variable items height
m_bVerbsVisible | TRUE if the verb panel is visible.
m_hCursorHand | Handle of the cursor.
m_hCursorSplit | Handle to the cursor when positioned over a splitter.
m_nFocusedVerb | Index of the currently focused verb within the collection of verbs.
m_pImageManager | Image manager of property grid
m_pInplaceEdit | In-place edit control.
m_pInplaceListBox | In-place list control.
m_pPaintManager | Current paint manager.
m_pToolTipContext | Tooltip context
m_pVerbs | Collection of verbs (links) displayed in the verb panel when the panel is visible.
m_pView | View pointer
m_themeCurrent | Currently set theme.
m_wndToolbar | Pointer to the "built-in" PropertyGrid toolbar.
Public Data Members
Public Data Member | Description
m_bHideSelection | TRUE to hide selection when control doesn't have focus;
m_nHelpHeight | Height of the description area (help panel).
m_nVerbsHeight | Height of the verbs panel.


CXTPPropertyGrid::m_bEnableTooltips Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bEnableTooltips Data Member

TRUE if tooltips enabled

BOOL m_bEnableTooltips;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bHelpVisible Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bHelpVisible Data Member

TRUE if the help panel is visible.

BOOL m_bHelpVisible;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bHideSelection Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bHideSelection Data Member

TRUE to hide selection when control doesn't have focus;

BOOL m_bHideSelection;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bHighlightChanged Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bHighlightChanged Data Member

TRUE to highlight changed values

BOOL m_bHighlightChanged;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bMultiSelect Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bMultiSelect Data Member

TRUE for MultiSelect;

BOOL m_bMultiSelect;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bPreSubclassWindow Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bPreSubclassWindow Data Member

true' when initialized from PreSubclassWindow.

BOOL m_bPreSubclassWindow;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bShowInplaceButtonsAlways Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bShowInplaceButtonsAlways Data Member

TRUE to show all inplace buttons

BOOL m_bShowInplaceButtonsAlways;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bTabCaptions Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bTabCaptions Data Member

TRUE to navigate items with the tab key.

BOOL m_bTabCaptions;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bTabItems Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bTabItems Data Member

TRUE to navigate items with the tab key.

BOOL m_bTabItems;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bToolBarVisible Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bToolBarVisible Data Member

TRUE if the built in toolbar is visible.

BOOL m_bToolBarVisible;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bVariableItemsHeight Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bVariableItemsHeight Data Member

TRUE to allow variable items height

BOOL m_bVariableItemsHeight;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_bVerbsVisible Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_bVerbsVisible Data Member

TRUE if the verb panel is visible.

BOOL m_bVerbsVisible;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_hCursorHand Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_hCursorHand Data Member

Handle of the cursor.

HCURSOR m_hCursorHand;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_hCursorSplit Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_hCursorSplit Data Member

Handle to the cursor when positioned over a splitter.

HCURSOR m_hCursorSplit;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_nFocusedVerb Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_nFocusedVerb Data Member

Index of the currently focused verb within the collection of verbs.

int m_nFocusedVerb;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_nHelpHeight Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_nHelpHeight Data Member

Height of the description area (help panel).

int m_nHelpHeight;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_nVerbsHeight Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_nVerbsHeight Data Member

Height of the verbs panel.

int m_nVerbsHeight;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_pImageManager Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_pImageManager Data Member

Image manager of property grid

CXTPImageManager* m_pImageManager;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_pInplaceEdit Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_pInplaceEdit Data Member

In-place edit control.

CXTPPropertyGridInplaceEdit* m_pInplaceEdit;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_pInplaceListBox Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_pInplaceListBox Data Member

In-place list control.

CXTPPropertyGridInplaceList* m_pInplaceListBox;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_pPaintManager Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_pPaintManager Data Member

Current paint manager.

CXTPPropertyGridPaintManager* m_pPaintManager;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_pToolTipContext Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_pToolTipContext Data Member

Tooltip context

CXTPToolTipContext* m_pToolTipContext;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_pVerbs Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_pVerbs Data Member

Collection of verbs (links) displayed in the verb panel when the panel is visible.

CXTPPropertyGridVerbs* m_pVerbs;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_pView Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_pView Data Member

View pointer

mutable CXTPPropertyGridView* m_pView;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_themeCurrent Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_themeCurrent Data Member

Currently set theme.

XTPPropertyGridPaintTheme m_themeCurrent;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid::m_wndToolbar Data Member

CXTPPropertyGrid Data Members, CXTPPropertyGrid Class
CXTPPropertyGrid::m_wndToolbar Data Member

Pointer to the "built-in" PropertyGrid toolbar.

CXTPPropertyGridToolBar m_wndToolbar;
Group

CXTPPropertyGrid Data Members


CXTPPropertyGrid Methods

CXTPPropertyGrid Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid Methods
Class

CXTPPropertyGrid Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
CreateGridView | This member is called to create grid view window
CreateToolbar | This member is called when the "built-in" toolbar is created.
HitTest | This member is called to determine if the help splitter, verb splitter, or a verb was clicked upon.
OnInvertTracker | This method is called by the framework during resizing of splitters.
OnSelectionChanged | This member is called when a new item is selected in the grid. Or focus switched from one item to a different item.
OnSortChanged | This member is called when the sort order has changed.
OnVerbsChanged | This member is called when a Verb receives focus, and when focus switches from one verb to a different verb.
RefreshToolBarButtons | This member is called when the toolbar buttons need to be redrawn.
Public Methods
Public Methods
Public Method | Description
AddCategory |
BeginUpdate | Call this member function to "lock" the property grid. This should be called when adding or deleting a large number of item.
Create | Call this member function to create the Property Grid control.
CreateView | Creates View of Property grid. Override this member to use custom view.
EnableMarkup | Call this method to enable markup for tab captions
EnableMultiSelect | Call this method to enable multi select.
EnableToolTips | Call this member function to enable or disable tooltips under items
EndUpdate | This member should be called after BeginUpdate. You need to call EndUpdate to "unlock" the grid after you have finished adding and deleting a large amount of items.
FindItem |
GetBorderStyle | Call this method to get current border style for Property Grid
GetCategories | Call this member function to return the categories of the property grid.
GetCount | Retrieves the number of items in a property grid.
GetCurrentTheme | Retrieves current theme of the grid.
GetGridView | Call this method to retrieve reference to the view object.
GetHelpBackColor | Call this member function to return the background color for the property grid.
GetHelpForeColor | Call this member function to return the foreground color for the property grid.
GetHelpHeight | Call this member function to return the height of the help pane when it is visible.
GetImageManager | Retrieves Image manager associated with property grid
GetMarkupContext | Returns markup context
GetPaintManager | Returns the currently used control's Paint Manager.
GetPropertySort | Call this member function to get the current grouping style for the Property Grid control.
GetSelectedItem | Call this member function to get selected item.
GetShowInplaceButtonsAlways | Determines if in-place buttons are visible for all items.
GetToolBar | Call this method to retrieve reference to the toolbar for the property grid.
GetToolTipContext | Call this method to get tooltip context pointer.
GetTopIndex | Retrieves the zero-based index of the first visible item in a control. Initially, item 0 is at the top of the property grid, but if the list box is scrolled, another item may be at the top.
GetVariableHelpHeight | Determines whether the user can resize the help box with the mouse.
GetVariableSplitterPos | Determines whether the user can move the property grid splitter.
GetVerbs | Call this member to return a pointer to the collection of verbs that are displayed in the verb panel.
GetViewDivider | Call this member function to return the divider position of the grid view.
HighlightChangedItems | Call this member to highlight all item with changed values
InsertCategory |
IsBarVisible | Call this member function to determine if the toolbar is visible.
IsHelpVisible | Call this member function to determine if the help pane is visible.
IsHighlightChangedItems | Call this member to determine if changed items highlighter
IsLayoutRTL | Determines if right-to-left mode was set.
IsVerbsVisible | Call this member to determine if the verb panel is currently visible.
NavigateItems | Call this method to enable navigate items using Tab key.
OnNavigate | This member is called when items in the property grid are navigated using key on the keyboard. This includes navigating the built in toolbar, verbs, and items in the property grid.
OnVerbClick | This member is called when a user clicks on a verb or when a verb has focus and the enter key is pressed. Override this member to perform custom actions such as displaying a dialog.
RedrawControl | Call this member to redraw control;
Refresh | Call this method to refresh items in the list.
RegisterWindowClass | Register the window class if it has not already been registered.
Reposition |
ResetContent | Removes all items from the list box of a property grid control.
SendNotifyMessage | Sends the specified message to the owner window.
SetBorderStyle | Call this method to set border style for Property Grid
SetCustomColors | Call this member function to set the custom colors of the Property Grid control.
SetCustomTheme | Call this method to set custom theme of the grid.
SetFont | This method sets the grid's current font to the specified font.
SetHelpHeight | Call this member function to set the height of the help pane when visible.
SetImageManager | Call this method to assign new image manager.
SetInplaceEdit | Call this method to set custom in-place edit control.
SetInplaceList | Call this method to set custom in-place list box control.
SetLayoutRTL | Call this member to set right-to-left mode.
SetPropertySort | Call this member function to modify the way items are grouped.
SetShowInplaceButtonsAlways | Call this member to show all in-place buttons of all items
SetStandardColors | Call this member function to set the default colors of the Property Grid control.
SetTheme | Call this member to set the grid theme.
SetTopIndex | Ensures that a particular list-box item is visible. Scrolls the property grid until either the item specified by nIndex appears at the top of the control or the maximum scroll range has been reached.
SetVariableHelpHeight | Specifies whether the user can resize the help box with the mouse.
SetVariableItemsHeight | Call this method to allow variable height items
SetVariableSplitterPos | Specifies whether the user can move the property grid splitter.
SetVerbsHeight | Call this member to specify the height of the verb box when visible.
SetViewDivider | Call this member function to set the divider position of the grid view.
SetViewDividerPos | Call this member function to set the divider position of the grid view.
ShowHelp | Call this member function to show or hide the description pane in the Property Grid window.
ShowToolBar | Call this member function to show or hide the toolbar control in the Property Grid window.


AddCategory Method

CXTPPropertyGrid Methods
AddCategory Method
Overload List
Methods
Method | Description
CXTPPropertyGrid::AddCategory (LPCTSTR, CXTPPropertyGridItem*) | Call this member function to add a new category to the Property Grid control.
CXTPPropertyGrid::AddCategory (int, CXTPPropertyGridItem*) |
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::AddCategory Method (LPCTSTR, CXTPPropertyGridItem*)

AddCategory Method, CXTPPropertyGrid Class, Body Source
CXTPPropertyGrid::AddCategory Method (LPCTSTR, CXTPPropertyGridItem*)

Call this member function to add a new category to the Property Grid control.

CXTPPropertyGridItem* AddCategory(
    LPCTSTR lpszCaption,
    CXTPPropertyGridItem* pCategory = NULL
);
Parameters

lpszCaption
Name of the category to add.
nID
Identifier of new category.

Returns

The pointer to the item object of the newly inserted category.

Body Source
CXTPPropertyGridItem* CXTPPropertyGrid::AddCategory(LPCTSTR strCaption, CXTPPropertyGridItem* pCategory) {
    return GetGridView().AddCategory(strCaption, pCategory);
}
Group

AddCategory Method


CXTPPropertyGrid::AddCategory Method (int, CXTPPropertyGridItem*)

AddCategory Method, CXTPPropertyGrid Class
CXTPPropertyGrid::AddCategory Method (int, CXTPPropertyGridItem*)
CXTPPropertyGridItem* AddCategory(
    int nID,
    CXTPPropertyGridItem* pCategory = NULL
);
Group

AddCategory Method


CXTPPropertyGrid::BeginUpdate Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::BeginUpdate Method

Call this member function to "lock" the property grid. This should be called when adding or deleting a large number of item.

void BeginUpdate(
    CXTPPropertyGridUpdateContext& context,
    BOOL bResetContent = TRUE
);
Parameters

context
Pointer to a CXTPPropertyGridUpdateContext object.
bResetContent
TRUE to delete all items

Remarks

Each time you add a new item or category to the grid, The state of the grid is updated the grid is redrawn.

If you want to delete all items in the grid and then add allot of new items it will be quite slow. To do this, you would call BeginUpdate, then delete all the items. The property grid will be locked until you call EndUpdate.

It might be useful to call BeginWaitCursor to indicate that the grid is "busy" updating.

See Also

EndUpdate, CXTPPropertyGridUpdateContext

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::Create Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::Create Method

Call this member function to create the Property Grid control.

virtual BOOL Create(
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID,
    DWORD dwListStyle = 0
);
Parameters

rect
Size of the control.
pParentWnd
Parent of the control.
nID
Identifier of the Property Grid control.
dwListStyle
List style of the items in the Property Grid.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

Available styles are listed below:

LBS_OWNERDRAWFIXED - The owner of the grid is responsible for drawing its contents; the items in the list box are the same height, should be used with LBS_NOINTEGRALHEIGHT.

LBS_OWNERDRAWVARIABLE - The owner of the grid is responsible for drawing its contents; the items in the grid are variable in height, should be used with LBS_NOINTEGRALHEIGHT

XTP_PGS_OWNERDRAW - Apply this style to the property grid to use the owner draw feature. Catch XTP_PGN_DRAWITEM to draw item. Recommended to use custom Paint Manager instead. (SetCustomTheme)

See Also

SetCustomTheme, SetTheme

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::CreateGridView Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::CreateGridView Method

This member is called to create grid view window

BOOL CreateGridView(
    DWORD dwListStyle
);
Parameters

dwListStyle
Default List style of the view

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::CreateToolbar Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::CreateToolbar Method

This member is called when the "built-in" toolbar is created.

void CreateToolbar();
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::CreateView Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::CreateView Method

Creates View of Property grid. Override this member to use custom view.

virtual CXTPPropertyGridView* CreateView() const;
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::EnableMarkup Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::EnableMarkup Method

Call this method to enable markup for tab captions

void EnableMarkup(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable markup

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::EnableMultiSelect Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::EnableMultiSelect Method

Call this method to enable multi select.

void EnableMultiSelect(
    BOOL bMultiSelect = TRUE
);
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::EnableToolTips Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::EnableToolTips Method

Call this member function to enable or disable tooltips under items

void EnableToolTips(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable tooltips.

Body Source
void CXTPPropertyGrid::EnableToolTips(BOOL bEnable) {
    m_bEnableTooltips = bEnable;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::EndUpdate Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::EndUpdate Method

This member should be called after BeginUpdate. You need to call EndUpdate to "unlock" the grid after you have finished adding and deleting a large amount of items.

void EndUpdate(
    CXTPPropertyGridUpdateContext& context
);
Parameters

context
Pointer to a CXTPPropertyGridUpdateContext object.

See Also

BeginUpdate, CXTPPropertyGridUpdateContext

Group

CXTPPropertyGrid Methods


FindItem Method

CXTPPropertyGrid Methods
FindItem Method
Overload List
Methods
Method | Description
CXTPPropertyGrid::FindItem (LPCTSTR) | Call this member function to find an item.
CXTPPropertyGrid::FindItem (UINT) | Call this member function to find an item.
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::FindItem Method (LPCTSTR)

FindItem Method, CXTPPropertyGrid Class, Body Source
CXTPPropertyGrid::FindItem Method (LPCTSTR)

Call this member function to find an item.

CXTPPropertyGridItem* FindItem(
    LPCTSTR strCaption
) const;
CXTPPropertyGridItem* FindItem(
    UINT nID
) const;
Parameters

strCaption
Caption for the item to find.
nID
Identifier for the item to find.

Returns

The pointer to the CXTPPropertyGridItem object.

Body Source
CXTPPropertyGridItem* CXTPPropertyGrid::FindItem(LPCTSTR strCaption) const {
    return GetGridView().m_pCategories->FindItem(strCaption);
}

CXTPPropertyGridItem* CXTPPropertyGrid::FindItem(UINT nID) const {
    return GetGridView().m_pCategories->FindItem(nID);
}
Group

FindItem Method


CXTPPropertyGrid::GetBorderStyle Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::GetBorderStyle Method

Call this method to get current border style for Property Grid

XTPPropertyGridBorderStyle GetBorderStyle() const;
See Also

SetBorderStyle, XTPPropertyGridBorderStyle

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetCategories Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::GetCategories Method

Call this member function to return the categories of the property grid.

CXTPPropertyGridItems* GetCategories() const;
Returns

The pointer to the CXTPPropertyGridItems object that represents collection of the categories.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetCount Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetCount Method

Retrieves the number of items in a property grid.

int GetCount() const;
Returns

The number of items in the property grid, or LB_ERR if an error occurs.

Remarks

The returned count is one greater than the index value of the last item (the index is zero-based).

Body Source
int CXTPPropertyGrid::GetCount() const {
    return GetGridView().GetCount();
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetCurrentTheme Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetCurrentTheme Method

Retrieves current theme of the grid.

XTPPropertyGridPaintTheme GetCurrentTheme() const;
Body Source
XTPPropertyGridPaintTheme CXTPPropertyGrid::GetCurrentTheme() const {
    return m_themeCurrent;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetGridView Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::GetGridView Method

Call this method to retrieve reference to the view object.

CXTPPropertyGridView& GetGridView() const;
Returns

A CXTPPropertyGridView object

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetHelpBackColor Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetHelpBackColor Method

Call this member function to return the background color for the property grid.

COLORREF GetHelpBackColor() const;
Returns

An RGB value.

Body Source
COLORREF CXTPPropertyGrid::GetHelpBackColor() const {
    return m_pPaintManager->GetItemMetrics()->m_clrHelpBack;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetHelpForeColor Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetHelpForeColor Method

Call this member function to return the foreground color for the property grid.

COLORREF GetHelpForeColor() const;
Returns

An RGB value.

Body Source
COLORREF CXTPPropertyGrid::GetHelpForeColor() const {
    return m_pPaintManager->GetItemMetrics()->m_clrHelpFore;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetHelpHeight Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetHelpHeight Method

Call this member function to return the height of the help pane when it is visible.

int GetHelpHeight() const;
Returns

An integer value that represents the height in pixels.

Body Source
int CXTPPropertyGrid::GetHelpHeight() const {
    return m_nHelpHeight;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetImageManager Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::GetImageManager Method

Retrieves Image manager associated with property grid

CXTPImageManager* GetImageManager() const;
Returns

Pointer to the image manager object that stores the images in the property grid.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetMarkupContext Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetMarkupContext Method

Returns markup context

CXTPMarkupContext* GetMarkupContext() const;
Body Source
CXTPMarkupContext* CXTPPropertyGrid::GetMarkupContext() const {
    return m_pMarkupContext;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetPaintManager Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetPaintManager Method

Returns the currently used control's Paint Manager.

CXTPPropertyGridPaintManager* GetPaintManager() const;
Returns

Pointer to the paint manager object.

Remarks

Call this member function to get the paint manager object used for drawing a property grid control window.

Body Source
CXTPPropertyGridPaintManager* CXTPPropertyGrid::GetPaintManager() const {
    return m_pPaintManager;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetPropertySort Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetPropertySort Method

Call this member function to get the current grouping style for the Property Grid control.

XTPPropertyGridSortOrder GetPropertySort() const;
Returns

An XTPPropertyGridSortOrder value representing the current grouping style.

See Also

SetPropertySort

Body Source
XTPPropertyGridSortOrder CXTPPropertyGrid::GetPropertySort () const {
    return GetGridView().m_properetySort;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetSelectedItem Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::GetSelectedItem Method

Call this member function to get selected item.

CXTPPropertyGridItem* GetSelectedItem() const;
Returns

The pointer to the CXTPPropertyGridItem object if the specified item is selected; otherwise, it is NULL.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetShowInplaceButtonsAlways Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetShowInplaceButtonsAlways Method

Determines if in-place buttons are visible for all items.

BOOL GetShowInplaceButtonsAlways() const;
Body Source
BOOL CXTPPropertyGrid::GetShowInplaceButtonsAlways() const {
    return m_bShowInplaceButtonsAlways;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetToolBar Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetToolBar Method

Call this method to retrieve reference to the toolbar for the property grid.

CToolBar& GetToolBar();
Returns

A reference to a CToolBar object

Body Source
CToolBar& CXTPPropertyGrid::GetToolBar() {
    return m_wndToolbar;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetToolTipContext Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Body Source
CXTPToolTipContext* CXTPPropertyGrid::GetToolTipContext() const {
    return m_pToolTipContext;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetTopIndex Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::GetTopIndex Method

Retrieves the zero-based index of the first visible item in a control. Initially, item 0 is at the top of the property grid, but if the list box is scrolled, another item may be at the top.

int GetTopIndex() const;
Returns

The zero-based index of the first visible item in a control if successful, -1 otherwise.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetVariableHelpHeight Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetVariableHelpHeight Method

Determines whether the user can resize the help box with the mouse.

BOOL GetVariableHelpHeight() const;
Returns

TRUE if the user is allow to resize the help box with the mouse.

Remarks

SetVariableHelpHeight allows the user to resize the help box by moving the mouse cursor over the help splitter that appears between the bottom of the property grid and the top of the help box. A resize mouse cursor will appear when the mouse if positioned over the splitter.

See Also

SetHelpHeight, SetVariableHelpHeight

Body Source
BOOL CXTPPropertyGrid::GetVariableHelpHeight() const {
    return m_bVariableHelpHeight;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetVariableSplitterPos Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetVariableSplitterPos Method

Determines whether the user can move the property grid splitter.

BOOL GetVariableSplitterPos() const;
Returns

TRUE if the user is allowed to resize the property grid splitter.

Remarks

SetVariableSplitterPos allows the user to resize the splitter by moving the mouse cursor over the splitter and dragging the mouse. A resize mouse cursor will appear when the mouse if positioned over the splitter.

See Also

SetVariableSplitterPos, SetViewDividerPos

Body Source
BOOL CXTPPropertyGrid::GetVariableSplitterPos() const {
    return GetGridView().m_bVariableSplitterPos;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetVerbs Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::GetVerbs Method

Call this member to return a pointer to the collection of verbs that are displayed in the verb panel.

CXTPPropertyGridVerbs* GetVerbs() const;
Returns

The pointer to the CXTPPropertyGridVerbs object that represents the collection of verbs.

Body Source
CXTPPropertyGridVerbs* CXTPPropertyGrid::GetVerbs() const {
    return m_pVerbs;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::GetViewDivider Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::GetViewDivider Method

Call this member function to return the divider position of the grid view.

double GetViewDivider() const;
Returns

A value between 0 and 1 that represents the location of the divider as a percentage from the left side of the view. For example, if you wanted the divider to divide at 25% you would pass in .25.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::HighlightChangedItems Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::HighlightChangedItems Method

Call this member to highlight all item with changed values

void HighlightChangedItems(
    BOOL bHighlightChanged
);
Parameters

bHighlightChanged
TRUE to set bold font for all changed items

See Also

IsHighlightChangedItems, CXTPPropertyGridItem::IsValueChanged

Body Source
void CXTPPropertyGrid::HighlightChangedItems(BOOL bHighlightChanged) {
    m_bHighlightChanged = bHighlightChanged;
    RedrawControl();
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::HitTest Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::HitTest Method

This member is called to determine if the help splitter, verb splitter, or a verb was clicked upon.

virtual int HitTest(
    CPoint pt
);
Parameters

pt
A point to test.

Returns

The HitTest method returns the following values which specify which part of the property grid located under the coordinates specified by pt.

  • xtpGridHitError Indicates something else was clicked.
  • xtpGridHitHelpSplitter Indicates the help splitter was clicked.
  • xtpGridHitVerbsSplitter Indicates the verb splitter was clicked.
  • xtpGridHitFirstVerb If the return value is greater than or equal to xtpGridHitFirstVerb then the item clicked upon is a verb. You can retrieve the verb index by subtracting xtpGridHitFirstVerb from the return value, for example:
int iHit = m_wndPropertyGrid.HitTest(pt);
if (iHit >= xtpGridHitFirstVerb)
{
    // Get the index of the verb.
    m_iVerbIndex = (iHit-xtpGridHitFirstVerb);
}
See Also

XTPPropertyGridHitCode

Group

CXTPPropertyGrid Methods


InsertCategory Method

CXTPPropertyGrid Methods
InsertCategory Method
Overload List
Methods
Method | Description
CXTPPropertyGrid::InsertCategory (int, LPCTSTR, CXTPPropertyGridItem*) | Call this member function to insert a new category to the Property Grid control.
CXTPPropertyGrid::InsertCategory (int, int, CXTPPropertyGridItem*) |
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::InsertCategory Method (int, LPCTSTR, CXTPPropertyGridItem*)

InsertCategory Method, CXTPPropertyGrid Class, Body Source
CXTPPropertyGrid::InsertCategory Method (int, LPCTSTR, CXTPPropertyGridItem*)

Call this member function to insert a new category to the Property Grid control.

CXTPPropertyGridItem* InsertCategory(
    int nIndex,
    LPCTSTR lpszCaption,
    CXTPPropertyGridItem* pCategory = NULL
);
Parameters

nIndex
Index of category to be inserted
lpszCaption
Name of the category to add.
nID
Identifier of new category.

Returns

The pointer to the item object of the newly inserted category.

Body Source
CXTPPropertyGridItem* CXTPPropertyGrid::InsertCategory(int nIndex, LPCTSTR strCaption, CXTPPropertyGridItem* pCategory) {
    return GetGridView().InsertCategory(nIndex, strCaption, pCategory);
}
Group

InsertCategory Method


CXTPPropertyGrid::InsertCategory Method (int, int, CXTPPropertyGridItem*)

InsertCategory Method, CXTPPropertyGrid Class
CXTPPropertyGrid::InsertCategory Method (int, int, CXTPPropertyGridItem*)
CXTPPropertyGridItem* InsertCategory(
    int nIndex,
    int nID,
    CXTPPropertyGridItem* pCategory = NULL
);
Group

InsertCategory Method


CXTPPropertyGrid::IsBarVisible Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::IsBarVisible Method

Call this member function to determine if the toolbar is visible.

BOOL IsBarVisible() const;
Returns

TRUE if the toolbar is visible, otherwise returns FALSE.

Body Source
BOOL CXTPPropertyGrid::IsBarVisible() const {
    return m_bToolBarVisible;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::IsHelpVisible Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::IsHelpVisible Method

Call this member function to determine if the help pane is visible.

BOOL IsHelpVisible() const;
Returns

TRUE if the help pane is visible, otherwise returns FALSE.

Body Source
BOOL CXTPPropertyGrid::IsHelpVisible() const {
    return m_bHelpVisible;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::IsHighlightChangedItems Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::IsHighlightChangedItems Method

Call this member to determine if changed items highlighter

BOOL IsHighlightChangedItems() const;
See Also

HighlightChangedItems, CXTPPropertyGridItem::IsValueChanged

Body Source
BOOL CXTPPropertyGrid::IsHighlightChangedItems() const {
    return m_bHighlightChanged;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::IsLayoutRTL Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::IsLayoutRTL Method

Determines if right-to-left mode was set.

BOOL IsLayoutRTL() const;
Returns

TRUE if text is displayed using right-to-left reading-order properties.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::IsVerbsVisible Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::IsVerbsVisible Method

Call this member to determine if the verb panel is currently visible.

BOOL IsVerbsVisible() const;
Returns

TRUE if the verb panel is visible, FALSE otherwise.

See Also

CXTPPropertyGridVerb, CXTPPropertyGridVerbs

Body Source
BOOL CXTPPropertyGrid::IsVerbsVisible() const {
    return !m_pVerbs->IsEmpty();
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::NavigateItems Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::NavigateItems Method

Call this method to enable navigate items using Tab key.

void NavigateItems(
    BOOL bTabItems,
    BOOL bTabCaptions = TRUE
);
Parameters

bTabItems
TRUE to navigate items in the grid using the tab key. When TRUE, focus will move in this order: Caption, Item Value, Item InPlaceButton (if used), Next item Caption FALSE not to navigate the items in the grid with the tab key.

Body Source
void CXTPPropertyGrid::NavigateItems(BOOL bTabItems, BOOL bTabCaptions) {
    m_bTabItems = bTabItems;
    m_bTabCaptions = bTabCaptions;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::OnInvertTracker Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::OnInvertTracker Method

This method is called by the framework during resizing of splitters.

void OnInvertTracker(
    CRect rc
);
Parameters

rc
Specifies the reference to a CRect object specifying the tracking rectangle.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::OnNavigate Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::OnNavigate Method

This member is called when items in the property grid are navigated using key on the keyboard. This includes navigating the built in toolbar, verbs, and items in the property grid.

virtual void OnNavigate(
    XTPPropertyGridUI nUIElement,
    BOOL bForward,
    CXTPPropertyGridItem* pItem
);
Parameters

nUIElement
Indicates which object should receive focus. Members of XTPPropertyGridUI are used to indicate which object receives focus.
bForward
TRUE if the Tab key is pressed and items are being navigated in the forward direction, FALSE if Shift+Tab is pressed and items are navigated backwards. TRUE if the Right or Down arrow is used to navigate the items. FALSE if the Up or Left arrow is used to navigate the items.
pItem
Pointer to the currently selected item.

See Also

XTPPropertyGridUI

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::OnSelectionChanged Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::OnSelectionChanged Method

This member is called when a new item is selected in the grid. Or focus switched from one item to a different item.

virtual void OnSelectionChanged(
    CXTPPropertyGridItem* pItem
);
Parameters

pItem
Item that the selection has changed too. This is the item that just received focus.

See Also

GetSelectedItem

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::OnSortChanged Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::OnSortChanged Method

This member is called when the sort order has changed.

virtual void OnSortChanged();
See Also

SetPropertySort

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::OnVerbClick Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::OnVerbClick Method

This member is called when a user clicks on a verb or when a verb has focus and the enter key is pressed. Override this member to perform custom actions such as displaying a dialog.

virtual void OnVerbClick(
    int nIndex,
    CPoint pt
);
Parameters

nIndex
Index of the verb within the collection of verbs.
pt
Point on the screen that the user clicked. This will the position of the mouse cursor over a verb. This point is stored in the CXTPPropertyGridVerb::m_ptClick member which is a CPoint object. Coordinates will be relative to the screen and not the client.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::OnVerbsChanged Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::OnVerbsChanged Method

This member is called when a Verb receives focus, and when focus switches from one verb to a different verb.

void OnVerbsChanged();
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::RedrawControl Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::RedrawControl Method

Call this member to redraw control;

void RedrawControl();
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::Refresh Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::Refresh Method

Call this method to refresh items in the list.

void Refresh();
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::RefreshToolBarButtons Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::RefreshToolBarButtons Method

This member is called when the toolbar buttons need to be redrawn.

void RefreshToolBarButtons();
Remarks

This occurs when the sort order has changed, and when the toolbar is shown. Sort order can be changed by code or by clicking on a button in the toolbar.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::RegisterWindowClass Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::RegisterWindowClass Method

Register the window class if it has not already been registered.

BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

TRUE if the window class was successfully registered.

Group

CXTPPropertyGrid Methods


Reposition Method

CXTPPropertyGrid Methods
Reposition Method
Overload List
Methods
Method | Description
CXTPPropertyGrid::Reposition () | This method is called to reposition view and help pane inside grid
CXTPPropertyGrid::Reposition (int, int) | This member is called to recalculate the position and size of the property grid, then it resizes the grid to the specified size. New size is 0, 0, cx, cy. This is the area that hold the toolbar and grid, this does not include the area for the verb and help panel.
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::Reposition Method ()

Reposition Method, CXTPPropertyGrid Class
CXTPPropertyGrid::Reposition Method ()

This method is called to reposition view and help pane inside grid

void Reposition();
Group

Reposition Method


CXTPPropertyGrid::Reposition Method (int, int)

Reposition Method, CXTPPropertyGrid Class
CXTPPropertyGrid::Reposition Method (int, int)

This member is called to recalculate the position and size of the property grid, then it resizes the grid to the specified size. New size is 0, 0, cx, cy. This is the area that hold the toolbar and grid, this does not include the area for the verb and help panel.

virtual void Reposition(
    int cx,
    int cy
);
Parameters

cx
New bottom-right x coordinate of the grid's bounding rectangle.
cy
New bottom-right y coordinate of the grid's bounding rectangle.

Group

Reposition Method


CXTPPropertyGrid::ResetContent Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::ResetContent Method

Removes all items from the list box of a property grid control.

void ResetContent();
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SendNotifyMessage Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SendNotifyMessage Method

Sends the specified message to the owner window.

virtual LRESULT SendNotifyMessage(
    WPARAM wParam = 0,
    LPARAM lParam = 0
);
Parameters

wParam
Specifies additional message-dependent information.
lParam
Specifies additional message-dependent information

Returns

The result of the message processing; its value depends on the message sent.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetBorderStyle Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::SetBorderStyle Method

Call this method to set border style for Property Grid

void SetBorderStyle(
    XTPPropertyGridBorderStyle borderStyle
);
Parameters

borderStyle
borders style to be set

See Also

GetBorderStyle, XTPPropertyGridBorderStyle

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetCustomColors Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetCustomColors Method

Call this member function to set the custom colors of the Property Grid control.

void SetCustomColors(
    COLORREF clrHelpBack,
    COLORREF clrHelpFore,
    COLORREF clrViewLine,
    COLORREF clrViewBack,
    COLORREF clrViewFore,
    COLORREF clrCategoryFore = ::GetSysColor(COLOR_GRAYTEXT)
);
Parameters

clrHelpBack
An RGB value that represents the background color the of description pane.
clrHelpFore
An RGB value that represents the text color of the description pane.
clrViewLine
An RGB value that represents the color of separating lines in control.
clrViewBack
An RGB value that represents the background color of the Property Grid control.
clrViewFore
An RGB value that represents the text color of the Property Grid control.
clrCategoryFore
An RGB value that represents the text color of the Category item text.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetCustomTheme Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetCustomTheme Method

Call this method to set custom theme of the grid.

void SetCustomTheme(
    CXTPPropertyGridPaintManager* pPaintManager
);
Parameters

pPaintManager
Points to a CXTPPropertyGridPaintManager object

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetFont Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetFont Method

This method sets the grid's current font to the specified font.

void SetFont(
    CFont* pFont
);
Parameters

pFont
Pointer to a CFont object.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetHelpHeight Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetHelpHeight Method

Call this member function to set the height of the help pane when visible.

void SetHelpHeight(
    int nHeight
);
Parameters

nHeight
The integer value represents the height in pixels.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetImageManager Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetImageManager Method

Call this method to assign new image manager.

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Pointer to the image manager object that stores the images in the property grid.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetInplaceEdit Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::SetInplaceEdit Method

Call this method to set custom in-place edit control.

void SetInplaceEdit(
    CXTPPropertyGridInplaceEdit* pInplaceEdit
);
Parameters

pInplaceEdit
New custom edit control to be set

See Also

SetInplaceList, CXTPPropertyGridItem::GetInplaceEdit

Example
m_wndPropertyGrid.SetInplaceEdit(new CMyInplaceEdit());
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetInplaceList Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::SetInplaceList Method

Call this method to set custom in-place list box control.

void SetInplaceList(
    CXTPPropertyGridInplaceList* pInplaceList
);
Parameters

pInplaceList
New custom list box control to be set

See Also

SetInplaceEdit, CXTPPropertyGridItem::GetInplaceList

Example
m_wndPropertyGrid.SetInplaceList(new CMyInplaceList());
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetLayoutRTL Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetLayoutRTL Method

Call this member to set right-to-left mode.

void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetPropertySort Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::SetPropertySort Method

Call this member function to modify the way items are grouped.

void SetPropertySort(
    XTPPropertyGridSortOrder sort
);
Parameters

sort
style of grouping. Can be any of the values listed in the Remarks section.

Remarks

sort parameter can be one of the following:

  • xtpGridSortCategorized Group items by category.
  • xtpGridSortAlphabetical Sort items alphabetically.
  • xtpGridSortNoSort Disable sorting.
See Also

GetPropertySort

Body Source
void CXTPPropertyGrid::SetPropertySort (XTPPropertyGridSortOrder sort) {
    GetGridView().SetPropertySort(sort);
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetShowInplaceButtonsAlways Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::SetShowInplaceButtonsAlways Method

Call this member to show all in-place buttons of all items

void SetShowInplaceButtonsAlways(
    BOOL bShow
);
Parameters

bShow
TRUE to always show in-place buttons; FALSE to show buttons only for selected item.

See Also

GetShowInplaceButtonsAlways

Body Source
void CXTPPropertyGrid::SetShowInplaceButtonsAlways(BOOL bShow) {
    m_bShowInplaceButtonsAlways = bShow;
    Reposition();
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetStandardColors Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetStandardColors Method

Call this member function to set the default colors of the Property Grid control.

void SetStandardColors();
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetTheme Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetTheme Method

Call this member to set the grid theme.

void SetTheme(
    XTPPropertyGridPaintTheme paintTheme
);
Parameters

paintTheme
theme of property grid. Can be one of the values listed in the Remarks section.

Remarks

paintTheme can be one of the following values:

  • xtpGridThemeDefault Enables default theme.
  • xtpGridThemeNativeWinXP Enables WinXP style theme.
  • xtpGridThemeOffice2003 Enables Office 2003 style theme.
  • xtpGridThemeCool Enables Cool theme.
  • xtpGridThemeSimple Enables Visual Basic style theme.
  • xtpGridThemeDelphi Enables Delphi style theme.
  • xtpGridThemeWhidbey Enables Visual Studio 2005 "Whidbey" style theme.
  • xtpGridThemeOfficeXP Enables Visual Office XP style theme.
  • xtpGridThemeOffice2007 Enables Visual Office 2007 style theme.
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetTopIndex Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetTopIndex Method

Ensures that a particular list-box item is visible. Scrolls the property grid until either the item specified by nIndex appears at the top of the control or the maximum scroll range has been reached.

void SetTopIndex(
    int nIndex
);
Parameters

nIndex
Specifies the zero-based index of the item.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetVariableHelpHeight Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::SetVariableHelpHeight Method

Specifies whether the user can resize the help box with the mouse.

void SetVariableHelpHeight(
    BOOL bVariable
);
Parameters

bVariable
TRUE to allow the user to resize the help box with the mouse.

Remarks

SetVariableHelpHeight allows the user to resize the help box by moving the mouse cursor over the help splitter that appears between the bottom of the property grid and the top of the help box. A resize mouse cursor will appear when the mouse if positioned over the splitter.

See Also

SetHelpHeight, GetVariableHelpHeight

Body Source
void CXTPPropertyGrid::SetVariableHelpHeight(BOOL bVariable) {
    m_bVariableHelpHeight = bVariable;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetVariableItemsHeight Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::SetVariableItemsHeight Method

Call this method to allow variable height items

void SetVariableItemsHeight(
    BOOL bVariable = TRUE
);
Parameters

bVariable
TRUE to allow variable height items

See Also

CXTPPropertyGridItem::SetHeight, CXTPPropertyGridItem::SetMultiLinesCount

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetVariableSplitterPos Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGrid::SetVariableSplitterPos Method

Specifies whether the user can move the property grid splitter.

void SetVariableSplitterPos(
    BOOL bVariable
);
Parameters

bVariable
TRUE to allow the user to resize the property grid splitter.

Remarks

SetVariableSplitterPos allows the user to resize the splitter by moving the mouse cursor over the splitter and dragging the mouse. A resize mouse cursor will appear when the mouse if positioned over the splitter.

See Also

SetViewDividerPos

Body Source
void CXTPPropertyGrid::SetVariableSplitterPos(BOOL bVariable) {
    GetGridView().m_bVariableSplitterPos = bVariable;
}
Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetVerbsHeight Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class, See Also
CXTPPropertyGrid::SetVerbsHeight Method

Call this member to specify the height of the verb box when visible.

void SetVerbsHeight(
    int nHeight
);
Parameters

nHeight
Height of the verb box.

See Also

CXTPPropertyGridVerb, CXTPPropertyGridVerbs, IsVerbsVisible

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetViewDivider Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetViewDivider Method

Call this member function to set the divider position of the grid view.

void SetViewDivider(
    double dDivider
);
Parameters

dDivider
A value between 0 and 1 that represents the location of the divider as a percentage from the left side of the view. For example, if you wanted the divider to divide at 25% you would pass in .25.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::SetViewDividerPos Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::SetViewDividerPos Method

Call this member function to set the divider position of the grid view.

void SetViewDividerPos(
    int nDivider,
    BOOL bLockDivider = FALSE
);
Parameters

nDivider
A value in pixels that represents the location of the divider.
bLockDivider
TRUE to not scale divider if user resize property grid.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::ShowHelp Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::ShowHelp Method

Call this member function to show or hide the description pane in the Property Grid window.

void ShowHelp(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE to show the description pane, or FALSE to hide it.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid::ShowToolBar Method

CXTPPropertyGrid Methods, CXTPPropertyGrid Class
CXTPPropertyGrid::ShowToolBar Method

Call this member function to show or hide the toolbar control in the Property Grid window.

void ShowToolBar(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE to show the toolbar control, or FALSE to hide it.

Group

CXTPPropertyGrid Methods


CXTPPropertyGrid Constructors

CXTPPropertyGrid Class, Legend, Public Methods
CXTPPropertyGrid Constructors
Class

CXTPPropertyGrid Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGrid | Constructs a CXTPPropertyGrid object


CXTPPropertyGrid::CXTPPropertyGrid Constructor

CXTPPropertyGrid Constructors, CXTPPropertyGrid Class
CXTPPropertyGrid::CXTPPropertyGrid Constructor

Constructs a CXTPPropertyGrid object

CXTPPropertyGrid();
Group

CXTPPropertyGrid Constructors


CXTPPropertyGrid Destructors

CXTPPropertyGrid Class, Legend, Public Methods
CXTPPropertyGrid Destructors
Class

CXTPPropertyGrid Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGrid | Destroys a CXTPPropertyGrid object, handles cleanup and deallocation


CXTPPropertyGrid::~CXTPPropertyGrid Destructor

CXTPPropertyGrid Destructors, CXTPPropertyGrid Class
CXTPPropertyGrid::~CXTPPropertyGrid Destructor

Destroys a CXTPPropertyGrid object, handles cleanup and deallocation

virtual ~CXTPPropertyGrid();
Group

CXTPPropertyGrid Destructors


CXTPPropertyGridCoolTheme Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridCoolTheme Methods, CXTPPropertyGridCoolTheme Constructors, CXTPPropertyGridCoolTheme Constructors, CXTPPropertyGridCoolTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridCoolTheme Class

CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class. This represents a Cool style theme.

Class Hierarchy

class CXTPPropertyGridCoolTheme : public CXTPPropertyGridPaintManager;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Method
virtual
CXTPPropertyGridCoolTheme Constructors
CXTPPropertyGridCoolTheme Constructors | Description
CXTPPropertyGridCoolTheme | Constructs a CXTPPropertyGridCoolTheme object.
CXTPPropertyGridCoolTheme Methods
CXTPPropertyGridCoolTheme Methods | Description
DrawItem | This method is called to draw single item of the grid.
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridCoolTheme Methods

CXTPPropertyGridCoolTheme Class, Legend, Public Methods
CXTPPropertyGridCoolTheme Methods
Class

CXTPPropertyGridCoolTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawItem | This method is called to draw single item of the grid.
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridCoolTheme::DrawItem Method

CXTPPropertyGridCoolTheme Methods, CXTPPropertyGridCoolTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridCoolTheme::DrawItem Method

This method is called to draw single item of the grid.

virtual void DrawItem(
    PDRAWITEMSTRUCT lpDrawItemStruct
);
Parameters

lpDrawItemStruct
A long pointer to a DRAWITEMSTRUCT structure that contains information about the type of drawing required.

Group

CXTPPropertyGridCoolTheme Methods


CXTPPropertyGridCoolTheme::RefreshMetrics Method

CXTPPropertyGridCoolTheme Methods, CXTPPropertyGridCoolTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridCoolTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the property grid.

void RefreshMetrics();
Group

CXTPPropertyGridCoolTheme Methods


CXTPPropertyGridCoolTheme Constructors

CXTPPropertyGridCoolTheme Class, Legend, Public Methods
CXTPPropertyGridCoolTheme Constructors
Class

CXTPPropertyGridCoolTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridCoolTheme | Constructs a CXTPPropertyGridCoolTheme object.


CXTPPropertyGridCoolTheme::CXTPPropertyGridCoolTheme Constructor

CXTPPropertyGridCoolTheme Constructors, CXTPPropertyGridCoolTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridCoolTheme::CXTPPropertyGridCoolTheme Constructor

Constructs a CXTPPropertyGridCoolTheme object.

CXTPPropertyGridCoolTheme(
    CXTPPropertyGrid* pGrid
);
Parameters

pGrid
Points to a CXTPPropertyGrid object

Group

CXTPPropertyGridCoolTheme Constructors


CXTPPropertyGridDelphiTheme Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridDelphiTheme Methods, CXTPPropertyGridDelphiTheme Constructors, CXTPPropertyGridDelphiTheme Constructors, CXTPPropertyGridDelphiTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridDelphiTheme Class

CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class. This represents a Delphi style theme.

Class Hierarchy

class CXTPPropertyGridDelphiTheme : public CXTPPropertyGridPaintManager;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Method
virtual
CXTPPropertyGridDelphiTheme Constructors
CXTPPropertyGridDelphiTheme Constructors | Description
CXTPPropertyGridDelphiTheme | Constructs a CXTPPropertyGridDelphiTheme object.
CXTPPropertyGridDelphiTheme Methods
CXTPPropertyGridDelphiTheme Methods | Description
DrawItem | This method is called to draw single item of the grid.
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridDelphiTheme Methods

CXTPPropertyGridDelphiTheme Class, Legend, Public Methods
CXTPPropertyGridDelphiTheme Methods
Class

CXTPPropertyGridDelphiTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawItem | This method is called to draw single item of the grid.
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridDelphiTheme::DrawItem Method

CXTPPropertyGridDelphiTheme Methods, CXTPPropertyGridDelphiTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridDelphiTheme::DrawItem Method

This method is called to draw single item of the grid.

virtual void DrawItem(
    PDRAWITEMSTRUCT lpDrawItemStruct
);
Parameters

lpDrawItemStruct
A long pointer to a DRAWITEMSTRUCT structure that contains information about the type of drawing required.

Group

CXTPPropertyGridDelphiTheme Methods


CXTPPropertyGridDelphiTheme::RefreshMetrics Method

CXTPPropertyGridDelphiTheme Methods, CXTPPropertyGridDelphiTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridDelphiTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the property grid.

virtual void RefreshMetrics();
Group

CXTPPropertyGridDelphiTheme Methods


CXTPPropertyGridDelphiTheme Constructors

CXTPPropertyGridDelphiTheme Class, Legend, Public Methods
CXTPPropertyGridDelphiTheme Constructors
Class

CXTPPropertyGridDelphiTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridDelphiTheme | Constructs a CXTPPropertyGridDelphiTheme object.


CXTPPropertyGridDelphiTheme::CXTPPropertyGridDelphiTheme Constructor

CXTPPropertyGridDelphiTheme Constructors, CXTPPropertyGridDelphiTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridDelphiTheme::CXTPPropertyGridDelphiTheme Constructor

Constructs a CXTPPropertyGridDelphiTheme object.

CXTPPropertyGridDelphiTheme(
    CXTPPropertyGrid* pGrid
);
Parameters

pGrid
Points to a CXTPPropertyGrid object

Group

CXTPPropertyGridDelphiTheme Constructors


CXTPPropertyGridInplaceButton Class

XTPPropertyGridInplaceButton.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Constructors, CXTPPropertyGridInplaceButton Destructors, CXTPPropertyGridInplaceButton Constructors, CXTPPropertyGridInplaceButton Destructors, CXTPPropertyGridInplaceButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton Class

CXTPPropertyGridInplaceButton is a CCmdTarget derived class. It represents inplace button in Property Grid control.

Class Hierarchy

class CXTPPropertyGridInplaceButton;
File

XTPPropertyGridInplaceButton.h

Group

Classes

Legend
Method
virtual
CXTPPropertyGridInplaceButton Constructors
CXTPPropertyGridInplaceButton Constructors | Description
CXTPPropertyGridInplaceButton | Constructs a CXTPPropertyGridInplaceButton object
CXTPPropertyGridInplaceButton Destructors
CXTPPropertyGridInplaceButton Destructors | Description
~CXTPPropertyGridInplaceButton | Destroys a CXTPPropertyGridInplaceButton object, handles cleanup and deallocation.
CXTPPropertyGridInplaceButton Methods
CXTPPropertyGridInplaceButton Methods | Description
GetCaption | Retrieves caption of the button
GetGrid | Retrieves parent grid object
GetIconIndex | Retrieves image index of the button.
GetID | Retrieves identifier of the button
GetImage | Call this method to retrieve image assigned for the button
GetIndex | Retrieves index of button in array of item's buttons
GetItem | This member function retrieves the parent property grid item
GetRect | Retrieves bounding rectangle of the button.
GetTooltip | Call this member to retrieve the item's tooltip
GetWidth | Retrieves width of the button
IsFocused | Determines if button has focus
IsHot | Determines if cursor under button
IsPressed | Determines if user push the button
OnDraw | This method is called to draw the button Override this method to draw custom button
OnKeyDown | This method is called when user press key while button has focus
OnLButtonDown | This method is called when user press the button
SetCaption | Call this method to set caption text of the button
SetIconIndex | Call this method to assign icon index for the button. Add icons first to Image manager of Property Grid
SetTooltip | Associates ToolTip text with the item.
SetWidth | Call this method to set width of the button


CXTPPropertyGridInplaceButton Methods

CXTPPropertyGridInplaceButton Class, Legend, Public Methods
CXTPPropertyGridInplaceButton Methods
Class

CXTPPropertyGridInplaceButton Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetCaption | Retrieves caption of the button
GetGrid | Retrieves parent grid object
GetIconIndex | Retrieves image index of the button.
GetID | Retrieves identifier of the button
GetImage | Call this method to retrieve image assigned for the button
GetIndex | Retrieves index of button in array of item's buttons
GetItem | This member function retrieves the parent property grid item
GetRect | Retrieves bounding rectangle of the button.
GetTooltip | Call this member to retrieve the item's tooltip
GetWidth | Retrieves width of the button
IsFocused | Determines if button has focus
IsHot | Determines if cursor under button
IsPressed | Determines if user push the button
OnDraw | This method is called to draw the button Override this method to draw custom button
OnKeyDown | This method is called when user press key while button has focus
OnLButtonDown | This method is called when user press the button
SetCaption | Call this method to set caption text of the button
SetIconIndex | Call this method to assign icon index for the button. Add icons first to Image manager of Property Grid
SetTooltip | Associates ToolTip text with the item.
SetWidth | Call this method to set width of the button


CXTPPropertyGridInplaceButton::GetCaption Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetCaption Method

Retrieves caption of the button

CString GetCaption() const;
See Also

SetCaption

Body Source
CString CXTPPropertyGridInplaceButton::GetCaption() const {
    return m_strCaption;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetGrid Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetGrid Method

Retrieves parent grid object

CXTPPropertyGridView* GetGrid() const;
Returns

Pointer to parent CXTPPropertyGridView object

Body Source
CXTPPropertyGridView* CXTPPropertyGridInplaceButton::GetGrid() const {
    return m_pGrid;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetIconIndex Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetIconIndex Method

Retrieves image index of the button.

int GetIconIndex() const;
See Also

SetIconIndex

Body Source
int CXTPPropertyGridInplaceButton::GetIconIndex() const {
    return m_nIconIndex;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetID Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetID Method

Retrieves identifier of the button

UINT GetID() const;
Remarks

Default identifier for expand button is XTP_ID_PROPERTYGRID_EXPANDBUTTON; Default identifier for combo button is XTP_ID_PROPERTYGRID_COMBOBUTTON

Body Source
UINT CXTPPropertyGridInplaceButton::GetID() const {
    return m_nID;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetImage Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetImage Method

Call this method to retrieve image assigned for the button

virtual CXTPImageManagerIcon* GetImage() const;
See Also

SetIconIndex, CXTPPropertyGrid::GetImageManager

Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetIndex Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetIndex Method

Retrieves index of button in array of item's buttons

int GetIndex() const;
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetItem Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetItem Method

This member function retrieves the parent property grid item

CXTPPropertyGridItem* GetItem() const;
Returns

A pointer to a CXTPPropertyGridItem object

Body Source
CXTPPropertyGridItem* CXTPPropertyGridInplaceButton::GetItem() const {
    return m_pItem;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetRect Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetRect Method

Retrieves bounding rectangle of the button.

CRect GetRect() const;
Body Source
CRect CXTPPropertyGridInplaceButton::GetRect() const {
    return m_rcButton;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetTooltip Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetTooltip Method

Call this member to retrieve the item's tooltip

CString GetTooltip() const;
Returns

The ToolTip text for the item.

Body Source
CString CXTPPropertyGridInplaceButton::GetTooltip() const {
    return m_strTooltip;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::GetWidth Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::GetWidth Method

Retrieves width of the button

int GetWidth();
See Also

SetWidth

Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::IsFocused Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::IsFocused Method

Determines if button has focus

BOOL IsFocused() const;
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::IsHot Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::IsHot Method

Determines if cursor under button

BOOL IsHot() const;
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::IsPressed Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::IsPressed Method

Determines if user push the button

BOOL IsPressed() const;
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::OnDraw Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::OnDraw Method

This method is called to draw the button Override this method to draw custom button

virtual void OnDraw(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to valid device context
rc
Bounding rectangle of the button

Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::OnKeyDown Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::OnKeyDown Method

This method is called when user press key while button has focus

virtual void OnKeyDown(
    UINT nChar
);
Parameters

nChar
Specifies the virtual-key code of the given key.

Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::OnLButtonDown Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::OnLButtonDown Method

This method is called when user press the button

virtual void OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down
point
Specifies the x- and y-coordinate of the cursor

Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::SetCaption Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::SetCaption Method

Call this method to set caption text of the button

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
New caption to be set

See Also

GetCaption

Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::SetIconIndex Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::SetIconIndex Method

Call this method to assign icon index for the button. Add icons first to Image manager of Property Grid

void SetIconIndex(
    int nIconIndex
);
Parameters

nIconIndex
Image index to be set.

See Also

GetImage, GetIconIndex, CXTPPropertyGrid::GetImageManager

Body Source
void CXTPPropertyGridInplaceButton::SetIconIndex(int nIconIndex) {
    m_nIconIndex = nIconIndex;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::SetTooltip Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::SetTooltip Method

Associates ToolTip text with the item.

void SetTooltip(
    LPCTSTR lpstrTooltip
);
Parameters

lpstrTooltip
The ToolTip text to display when the mouse cursor is over the item.

Body Source
void CXTPPropertyGridInplaceButton::SetTooltip(LPCTSTR lpstrTooltip) {
    m_strTooltip = lpstrTooltip;
}
Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton::SetWidth Method

CXTPPropertyGridInplaceButton Methods, CXTPPropertyGridInplaceButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::SetWidth Method

Call this method to set width of the button

void SetWidth(
    int nWidth
);
Parameters

nWidth
New width to be set

See Also

GetWidth

Group

CXTPPropertyGridInplaceButton Methods


CXTPPropertyGridInplaceButton Constructors

CXTPPropertyGridInplaceButton Class, Legend, Public Methods
CXTPPropertyGridInplaceButton Constructors
Class

CXTPPropertyGridInplaceButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceButton | Constructs a CXTPPropertyGridInplaceButton object


CXTPPropertyGridInplaceButton::CXTPPropertyGridInplaceButton Constructor

CXTPPropertyGridInplaceButton Constructors, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::CXTPPropertyGridInplaceButton Constructor

Constructs a CXTPPropertyGridInplaceButton object

CXTPPropertyGridInplaceButton(
    UINT nID
);
Parameters

nID
Identifier of button

Group

CXTPPropertyGridInplaceButton Constructors


CXTPPropertyGridInplaceButton Destructors

CXTPPropertyGridInplaceButton Class, Legend, Public Methods
CXTPPropertyGridInplaceButton Destructors
Class

CXTPPropertyGridInplaceButton Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridInplaceButton | Destroys a CXTPPropertyGridInplaceButton object, handles cleanup and deallocation.


CXTPPropertyGridInplaceButton::~CXTPPropertyGridInplaceButton Destructor

CXTPPropertyGridInplaceButton Destructors, CXTPPropertyGridInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButton::~CXTPPropertyGridInplaceButton Destructor

Destroys a CXTPPropertyGridInplaceButton object, handles cleanup and deallocation.

virtual ~CXTPPropertyGridInplaceButton();
Group

CXTPPropertyGridInplaceButton Destructors


CXTPPropertyGridInplaceButtons Class

XTPPropertyGridInplaceButton.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Constructors, CXTPPropertyGridInplaceButtons Destructors, CXTPPropertyGridInplaceButtons Constructors, CXTPPropertyGridInplaceButtons Destructors, CXTPPropertyGridInplaceButtons Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons Class

CXTPPropertyGridInplaceButtons is a CCmdTarget derived class. It represents collection of inplace buttons for specified grid item

Class Hierarchy

class CXTPPropertyGridInplaceButtons;
File

XTPPropertyGridInplaceButton.h

Group

Classes

Legend
Method
CXTPPropertyGridInplaceButtons Constructors
CXTPPropertyGridInplaceButtons Constructors | Description
CXTPPropertyGridInplaceButtons | Constructs a CXTPPropertyGridInplaceButtons object
CXTPPropertyGridInplaceButtons Destructors
CXTPPropertyGridInplaceButtons Destructors | Description
~CXTPPropertyGridInplaceButtons | Destroys a CXTPPropertyGridInplaceButtons object, handles cleanup and deallocation.
CXTPPropertyGridInplaceButtons Methods
CXTPPropertyGridInplaceButtons Methods | Description
AddButton | Call this method to add custom button.
AddComboButton | Call this method to add standard combo button
AddExpandButton | Call this method to add standard expand button
Find | Finds button by its identifier
GetAt | Retrieves button by its index
GetCount | Retrieves count of buttons in collection
HitTest | Determines which button, if any, is at a specified position.
Remove |
RemoveAll | Call this method to remove all buttons


CXTPPropertyGridInplaceButtons Methods

CXTPPropertyGridInplaceButtons Class, Legend, Public Methods
CXTPPropertyGridInplaceButtons Methods
Class

CXTPPropertyGridInplaceButtons Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddButton | Call this method to add custom button.
AddComboButton | Call this method to add standard combo button
AddExpandButton | Call this method to add standard expand button
Find | Finds button by its identifier
GetAt | Retrieves button by its index
GetCount | Retrieves count of buttons in collection
HitTest | Determines which button, if any, is at a specified position.
Remove |
RemoveAll | Call this method to remove all buttons


CXTPPropertyGridInplaceButtons::AddButton Method

CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::AddButton Method

Call this method to add custom button.

CXTPPropertyGridInplaceButton* AddButton(
    CXTPPropertyGridInplaceButton* pButton
);
Parameters

pButton
Pointer to button to add

Example
pItem->GetInplaceButtons()->AddButton(new CXTPPropertyGridInplaceButton(1));
Group

CXTPPropertyGridInplaceButtons Methods


CXTPPropertyGridInplaceButtons::AddComboButton Method

CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::AddComboButton Method

Call this method to add standard combo button

void AddComboButton();
Group

CXTPPropertyGridInplaceButtons Methods


CXTPPropertyGridInplaceButtons::AddExpandButton Method

CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::AddExpandButton Method

Call this method to add standard expand button

void AddExpandButton();
Group

CXTPPropertyGridInplaceButtons Methods


CXTPPropertyGridInplaceButtons::Find Method

CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::Find Method

Finds button by its identifier

CXTPPropertyGridInplaceButton* Find(
    UINT nID
) const;
Parameters

nID
Identifier to find

Returns

The button with specified identifier, if any, or NULL otherwise.

Group

CXTPPropertyGridInplaceButtons Methods


CXTPPropertyGridInplaceButtons::GetAt Method

CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::GetAt Method

Retrieves button by its index

CXTPPropertyGridInplaceButton* GetAt(
    int nIndex
) const;
Parameters

nIndex
Index to retrieve button

Body Source
CXTPPropertyGridInplaceButton* CXTPPropertyGridInplaceButtons::GetAt(int nIndex) const {
    return nIndex >= 0 && nIndex < GetCount() ? m_arrButtons.GetAt(nIndex) : NULL;
}
Group

CXTPPropertyGridInplaceButtons Methods


CXTPPropertyGridInplaceButtons::GetCount Method

CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::GetCount Method

Retrieves count of buttons in collection

int GetCount() const;
Body Source
int CXTPPropertyGridInplaceButtons::GetCount() const {
    return (int)m_arrButtons.GetSize();
}
Group

CXTPPropertyGridInplaceButtons Methods


CXTPPropertyGridInplaceButtons::HitTest Method

CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::HitTest Method

Determines which button, if any, is at a specified position.

CXTPPropertyGridInplaceButton* HitTest(
    CPoint point
) const;
Parameters

point
Point to test.

Returns

The button at the specified position, if any, or NULL otherwise.

Group

CXTPPropertyGridInplaceButtons Methods


Remove Method

CXTPPropertyGridInplaceButtons Methods
Remove Method
Overload List
Methods
Method | Description
CXTPPropertyGridInplaceButtons::Remove (CXTPPropertyGridInplaceButton*) | Call this method to remove specified button
CXTPPropertyGridInplaceButtons::Remove (UINT) | Call this method to remove button by its identifier
Group

CXTPPropertyGridInplaceButtons Methods


CXTPPropertyGridInplaceButtons::Remove Method (CXTPPropertyGridInplaceButton*)

Remove Method, CXTPPropertyGridInplaceButtons Class
CXTPPropertyGridInplaceButtons::Remove Method (CXTPPropertyGridInplaceButton*)

Call this method to remove specified button

void Remove(
    CXTPPropertyGridInplaceButton* pButton
);
Parameters

pButton
Button to remove

Group

Remove Method


CXTPPropertyGridInplaceButtons::Remove Method (UINT)

Remove Method, CXTPPropertyGridInplaceButtons Class
CXTPPropertyGridInplaceButtons::Remove Method (UINT)

Call this method to remove button by its identifier

void Remove(
    UINT nID
);
Parameters

nID
identifier of the button to remove

Group

Remove Method


CXTPPropertyGridInplaceButtons::RemoveAll Method

CXTPPropertyGridInplaceButtons Methods, CXTPPropertyGridInplaceButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::RemoveAll Method

Call this method to remove all buttons

void RemoveAll();
Group

CXTPPropertyGridInplaceButtons Methods


CXTPPropertyGridInplaceButtons Constructors

CXTPPropertyGridInplaceButtons Class, Legend, Public Methods
CXTPPropertyGridInplaceButtons Constructors
Class

CXTPPropertyGridInplaceButtons Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceButtons | Constructs a CXTPPropertyGridInplaceButtons object


CXTPPropertyGridInplaceButtons::CXTPPropertyGridInplaceButtons Constructor

CXTPPropertyGridInplaceButtons Constructors, CXTPPropertyGridInplaceButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::CXTPPropertyGridInplaceButtons Constructor

Constructs a CXTPPropertyGridInplaceButtons object

CXTPPropertyGridInplaceButtons(
    CXTPPropertyGridItem* pItem
);
Parameters

pItem
Parent Item of buttons

Group

CXTPPropertyGridInplaceButtons Constructors


CXTPPropertyGridInplaceButtons Destructors

CXTPPropertyGridInplaceButtons Class, Legend, Public Methods
CXTPPropertyGridInplaceButtons Destructors
Class

CXTPPropertyGridInplaceButtons Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridInplaceButtons | Destroys a CXTPPropertyGridInplaceButtons object, handles cleanup and deallocation.


CXTPPropertyGridInplaceButtons::~CXTPPropertyGridInplaceButtons Destructor

CXTPPropertyGridInplaceButtons Destructors, CXTPPropertyGridInplaceButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceButtons::~CXTPPropertyGridInplaceButtons Destructor

Destroys a CXTPPropertyGridInplaceButtons object, handles cleanup and deallocation.

~CXTPPropertyGridInplaceButtons();
Group

CXTPPropertyGridInplaceButtons Destructors


CXTPPropertyGridInplaceControl Class

XTPPropertyGridInplaceEdit.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceControl Data Members, CXTPPropertyGridInplaceControl Methods, CXTPPropertyGridInplaceControl Constructors, CXTPPropertyGridInplaceControl Constructors, CXTPPropertyGridInplaceControl Data Members, CXTPPropertyGridInplaceControl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl Class

CXTPPropertyGridInplaceControl is CWnd derived class, represents base class for all item in place controls.

Class Hierarchy

class CXTPPropertyGridInplaceControl : public CWnd;
File

XTPPropertyGridInplaceEdit.h

Group

Classes

Legend
Data Member
protected
Method
abstract
virtual
CXTPPropertyGridInplaceControl Constructors
CXTPPropertyGridInplaceControl Constructors | Description
CXTPPropertyGridInplaceControl | Constructs a CXTPPropertyGridInplaceControl object
CXTPPropertyGridInplaceControl Data Members
CXTPPropertyGridInplaceControl Data Members | Description
m_nWidth | Width of in-place item
m_pItem | Parent item pointer
CXTPPropertyGridInplaceControl Methods
CXTPPropertyGridInplaceControl Methods | Description
OnAdjustValueRect | This method is called when item require to calculate its value rectangle
OnCreateWindow | This method is called when item creates its in-place control.
OnDestroyWindow | This method is called when item destroys its in-place control.
OnValueChanged | This method is called when value of parent item was changed.


CXTPPropertyGridInplaceControl Data Members

CXTPPropertyGridInplaceControl Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl Data Members
Class

CXTPPropertyGridInplaceControl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nWidth | Width of in-place item
m_pItem | Parent item pointer


CXTPPropertyGridInplaceControl::m_nWidth Data Member

CXTPPropertyGridInplaceControl Data Members, CXTPPropertyGridInplaceControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl::m_nWidth Data Member

Width of in-place item

int m_nWidth;
Group

CXTPPropertyGridInplaceControl Data Members


CXTPPropertyGridInplaceControl::m_pItem Data Member

CXTPPropertyGridInplaceControl Data Members, CXTPPropertyGridInplaceControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl::m_pItem Data Member

Parent item pointer

CXTPPropertyGridItem* m_pItem;
Group

CXTPPropertyGridInplaceControl Data Members


CXTPPropertyGridInplaceControl Methods

CXTPPropertyGridInplaceControl Class, Legend, Public Methods
CXTPPropertyGridInplaceControl Methods
Class

CXTPPropertyGridInplaceControl Class

Legend
Method
abstract
virtual
Public Methods
Public Methods
Public Method | Description
OnAdjustValueRect | This method is called when item require to calculate its value rectangle
OnCreateWindow | This method is called when item creates its in-place control.
OnDestroyWindow | This method is called when item destroys its in-place control.
OnValueChanged | This method is called when value of parent item was changed.


CXTPPropertyGridInplaceControl::OnAdjustValueRect Method

CXTPPropertyGridInplaceControl Methods, CXTPPropertyGridInplaceControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl::OnAdjustValueRect Method

This method is called when item require to calculate its value rectangle

virtual void OnAdjustValueRect(
    CRect& rcValue
) = 0;
Parameters

rcValue
Bounding rectangle of value.

See Also

OnCreateWindow

Group

CXTPPropertyGridInplaceControl Methods


CXTPPropertyGridInplaceControl::OnCreateWindow Method

CXTPPropertyGridInplaceControl Methods, CXTPPropertyGridInplaceControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl::OnCreateWindow Method

This method is called when item creates its in-place control.

virtual void OnCreateWindow(
    CRect& rcValue
) = 0;
Parameters

rcValue
Boundary rectangle of control.

See Also

OnDestroyWindow

Group

CXTPPropertyGridInplaceControl Methods


CXTPPropertyGridInplaceControl::OnDestroyWindow Method

CXTPPropertyGridInplaceControl Methods, CXTPPropertyGridInplaceControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl::OnDestroyWindow Method

This method is called when item destroys its in-place control.

virtual void OnDestroyWindow();
See Also

OnCreateWindow

Group

CXTPPropertyGridInplaceControl Methods


CXTPPropertyGridInplaceControl::OnValueChanged Method

CXTPPropertyGridInplaceControl Methods, CXTPPropertyGridInplaceControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl::OnValueChanged Method

This method is called when value of parent item was changed.

virtual void OnValueChanged();
Group

CXTPPropertyGridInplaceControl Methods


CXTPPropertyGridInplaceControl Constructors

CXTPPropertyGridInplaceControl Class, Legend, Public Methods
CXTPPropertyGridInplaceControl Constructors
Class

CXTPPropertyGridInplaceControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceControl | Constructs a CXTPPropertyGridInplaceControl object


CXTPPropertyGridInplaceControl::CXTPPropertyGridInplaceControl Constructor

CXTPPropertyGridInplaceControl Constructors, CXTPPropertyGridInplaceControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControl::CXTPPropertyGridInplaceControl Constructor

Constructs a CXTPPropertyGridInplaceControl object

CXTPPropertyGridInplaceControl(
    CXTPPropertyGridItem* pItem
);
Parameters

pItem
Parent property grid item

Group

CXTPPropertyGridInplaceControl Constructors


CXTPPropertyGridInplaceControls Class

XTPPropertyGridInplaceEdit.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceControls Data Members, CXTPPropertyGridInplaceControls Methods, CXTPPropertyGridInplaceControls Constructors, CXTPPropertyGridInplaceControls Destructors, CXTPPropertyGridInplaceControls Constructors, CXTPPropertyGridInplaceControls Data Members, CXTPPropertyGridInplaceControls Destructors, CXTPPropertyGridInplaceControls Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls Class

CXTPPropertyGridInplaceControls is standalone class it represents collection of CXTPPropertyGridInplaceControl classes.

Class Hierarchy

class CXTPPropertyGridInplaceControls;
File

XTPPropertyGridInplaceEdit.h

Group

Classes

Legend
Data Member
protected
Method
CXTPPropertyGridInplaceControls Constructors
CXTPPropertyGridInplaceControls Constructors | Description
CXTPPropertyGridInplaceControls | Constructs a CXTPPropertyGridInplaceControls object
CXTPPropertyGridInplaceControls Data Members
CXTPPropertyGridInplaceControls Data Members | Description
m_arrControls | Arraay of controls
CXTPPropertyGridInplaceControls Destructors
CXTPPropertyGridInplaceControls Destructors | Description
~CXTPPropertyGridInplaceControls | Destroys a CXTPPropertyGridInplaceControls object, handles cleanup and deallocation
CXTPPropertyGridInplaceControls Methods
CXTPPropertyGridInplaceControls Methods | Description
Add | Adds new control to collection
GetAt | Call this method to retrieve control by its index
GetCount | Call this method to retrieve total number of controls in collection
RemoveAll | Call this method to remove all in-place controls from collection


CXTPPropertyGridInplaceControls Data Members

CXTPPropertyGridInplaceControls Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls Data Members
Class

CXTPPropertyGridInplaceControls Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrControls | Arraay of controls


CXTPPropertyGridInplaceControls::m_arrControls Data Member

CXTPPropertyGridInplaceControls Data Members, CXTPPropertyGridInplaceControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls::m_arrControls Data Member

Arraay of controls

CArray<CXTPPropertyGridInplaceControl*, CXTPPropertyGridInplaceControl*> m_arrControls;
Group

CXTPPropertyGridInplaceControls Data Members


CXTPPropertyGridInplaceControls Methods

CXTPPropertyGridInplaceControls Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls Methods
Class

CXTPPropertyGridInplaceControls Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add | Adds new control to collection
GetAt | Call this method to retrieve control by its index
GetCount | Call this method to retrieve total number of controls in collection
RemoveAll | Call this method to remove all in-place controls from collection


CXTPPropertyGridInplaceControls::Add Method

CXTPPropertyGridInplaceControls Methods, CXTPPropertyGridInplaceControls Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls::Add Method

Adds new control to collection

void Add(
    CXTPPropertyGridInplaceControl* pWindow
);
Parameters

pWindow
Pointer to new in-place control

See Also

GetAt

Group

CXTPPropertyGridInplaceControls Methods


CXTPPropertyGridInplaceControls::GetAt Method

CXTPPropertyGridInplaceControls Methods, CXTPPropertyGridInplaceControls Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls::GetAt Method

Call this method to retrieve control by its index

CXTPPropertyGridInplaceControl* GetAt(
    int nIndex
);
Parameters

nIndex
Index of control to retrieve

See Also

GetCount, Add

Group

CXTPPropertyGridInplaceControls Methods


CXTPPropertyGridInplaceControls::GetCount Method

CXTPPropertyGridInplaceControls Methods, CXTPPropertyGridInplaceControls Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls::GetCount Method

Call this method to retrieve total number of controls in collection

int GetCount() const;
See Also

GetAt

Group

CXTPPropertyGridInplaceControls Methods


CXTPPropertyGridInplaceControls::RemoveAll Method

CXTPPropertyGridInplaceControls Methods, CXTPPropertyGridInplaceControls Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls::RemoveAll Method

Call this method to remove all in-place controls from collection

void RemoveAll();
See Also

Add

Group

CXTPPropertyGridInplaceControls Methods


CXTPPropertyGridInplaceControls Constructors

CXTPPropertyGridInplaceControls Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls Constructors
Class

CXTPPropertyGridInplaceControls Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceControls | Constructs a CXTPPropertyGridInplaceControls object


CXTPPropertyGridInplaceControls::CXTPPropertyGridInplaceControls Constructor

CXTPPropertyGridInplaceControls Constructors, CXTPPropertyGridInplaceControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls::CXTPPropertyGridInplaceControls Constructor

Constructs a CXTPPropertyGridInplaceControls object

CXTPPropertyGridInplaceControls();
Group

CXTPPropertyGridInplaceControls Constructors


CXTPPropertyGridInplaceControls Destructors

CXTPPropertyGridInplaceControls Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls Destructors
Class

CXTPPropertyGridInplaceControls Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridInplaceControls | Destroys a CXTPPropertyGridInplaceControls object, handles cleanup and deallocation


CXTPPropertyGridInplaceControls::~CXTPPropertyGridInplaceControls Destructor

CXTPPropertyGridInplaceControls Destructors, CXTPPropertyGridInplaceControls Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceControls::~CXTPPropertyGridInplaceControls Destructor

Destroys a CXTPPropertyGridInplaceControls object, handles cleanup and deallocation

~CXTPPropertyGridInplaceControls();
Group

CXTPPropertyGridInplaceControls Destructors


CXTPPropertyGridInplaceEdit Class

XTPPropertyGridInplaceEdit.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceEdit Methods, CXTPPropertyGridInplaceEdit Constructors, CXTPPropertyGridInplaceEdit Destructors, CXTPPropertyGridInplaceEdit Constructors, CXTPPropertyGridInplaceEdit Destructors, CXTPPropertyGridInplaceEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit Class

CXTPPropertyGridInplaceEdit is a CEdit derived class. It is an internal class used by Property Grid control.

Class Hierarchy

class CXTPPropertyGridInplaceEdit : public CXTMaskEditT<CEdit>;
File

XTPPropertyGridInplaceEdit.h

Group

Classes

Legend
Method
virtual
CXTPPropertyGridInplaceEdit Constructors
CXTPPropertyGridInplaceEdit Constructors | Description
CXTPPropertyGridInplaceEdit | Constructs a CXTPPropertyGridInplaceEdit object
CXTPPropertyGridInplaceEdit Destructors
CXTPPropertyGridInplaceEdit Destructors | Description
~CXTPPropertyGridInplaceEdit | Destroys a CXTPPropertyGridInplaceEdit object, handles cleanup and deallocation.
CXTPPropertyGridInplaceEdit Methods
CXTPPropertyGridInplaceEdit Methods | Description
Create | Call this method to create in-place edit control.
DestroyItem | This method is called when a parent item is destroyed.
GetItem | This member function retrieves a child property grid item
HideWindow | Call this method to hide in-place edit control.
SelectConstraint | Call this method to select a constraint in child item constraint list.
SetValue | Call this method to set edit text value.


CXTPPropertyGridInplaceEdit Methods

CXTPPropertyGridInplaceEdit Class, Legend, Public Methods
CXTPPropertyGridInplaceEdit Methods
Class

CXTPPropertyGridInplaceEdit Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Create | Call this method to create in-place edit control.
DestroyItem | This method is called when a parent item is destroyed.
GetItem | This member function retrieves a child property grid item
HideWindow | Call this method to hide in-place edit control.
SelectConstraint | Call this method to select a constraint in child item constraint list.
SetValue | Call this method to set edit text value.


CXTPPropertyGridInplaceEdit::Create Method

CXTPPropertyGridInplaceEdit Methods, CXTPPropertyGridInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit::Create Method

Call this method to create in-place edit control.

virtual void Create(
    CXTPPropertyGridItem* pItem,
    CRect rect
);
Parameters

pItem
Points to a CXTPPropertyGridItem object
rect
Specifies the size and position of the item.

Group

CXTPPropertyGridInplaceEdit Methods


CXTPPropertyGridInplaceEdit::DestroyItem Method

CXTPPropertyGridInplaceEdit Methods, CXTPPropertyGridInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit::DestroyItem Method

This method is called when a parent item is destroyed.

virtual void DestroyItem();
Group

CXTPPropertyGridInplaceEdit Methods


CXTPPropertyGridInplaceEdit::GetItem Method

CXTPPropertyGridInplaceEdit Methods, CXTPPropertyGridInplaceEdit Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit::GetItem Method

This member function retrieves a child property grid item

CXTPPropertyGridItem* GetItem();
Returns

A pointer to a CXTPPropertyGridItem object

Body Source
CXTPPropertyGridItem* CXTPPropertyGridInplaceEdit::GetItem() {
    return m_pItem;
}
Group

CXTPPropertyGridInplaceEdit Methods


CXTPPropertyGridInplaceEdit::HideWindow Method

CXTPPropertyGridInplaceEdit Methods, CXTPPropertyGridInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit::HideWindow Method

Call this method to hide in-place edit control.

virtual void HideWindow();
Group

CXTPPropertyGridInplaceEdit Methods


CXTPPropertyGridInplaceEdit::SelectConstraint Method

CXTPPropertyGridInplaceEdit Methods, CXTPPropertyGridInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit::SelectConstraint Method

Call this method to select a constraint in child item constraint list.

virtual BOOL SelectConstraint(
    int nDirection,
    BOOL bCircle
);
Parameters

nDirection
Direction of constraint search.
bCircle
TRUE to find by cycle.

Group

CXTPPropertyGridInplaceEdit Methods


CXTPPropertyGridInplaceEdit::SetValue Method

CXTPPropertyGridInplaceEdit Methods, CXTPPropertyGridInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit::SetValue Method

Call this method to set edit text value.

virtual void SetValue(
    LPCTSTR strValue
);
Parameters

strValue
String value.

Group

CXTPPropertyGridInplaceEdit Methods


CXTPPropertyGridInplaceEdit Constructors

CXTPPropertyGridInplaceEdit Class, Legend, Public Methods
CXTPPropertyGridInplaceEdit Constructors
Class

CXTPPropertyGridInplaceEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceEdit | Constructs a CXTPPropertyGridInplaceEdit object


CXTPPropertyGridInplaceEdit::CXTPPropertyGridInplaceEdit Constructor

CXTPPropertyGridInplaceEdit Constructors, CXTPPropertyGridInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit::CXTPPropertyGridInplaceEdit Constructor

Constructs a CXTPPropertyGridInplaceEdit object

CXTPPropertyGridInplaceEdit();
Group

CXTPPropertyGridInplaceEdit Constructors


CXTPPropertyGridInplaceEdit Destructors

CXTPPropertyGridInplaceEdit Class, Legend, Public Methods
CXTPPropertyGridInplaceEdit Destructors
Class

CXTPPropertyGridInplaceEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridInplaceEdit | Destroys a CXTPPropertyGridInplaceEdit object, handles cleanup and deallocation.


CXTPPropertyGridInplaceEdit::~CXTPPropertyGridInplaceEdit Destructor

CXTPPropertyGridInplaceEdit Destructors, CXTPPropertyGridInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceEdit::~CXTPPropertyGridInplaceEdit Destructor

Destroys a CXTPPropertyGridInplaceEdit object, handles cleanup and deallocation.

virtual ~CXTPPropertyGridInplaceEdit();
Group

CXTPPropertyGridInplaceEdit Destructors


CXTPPropertyGridInplaceList Class

XTPPropertyGridInplaceList.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceList Methods, CXTPPropertyGridInplaceList Constructors, CXTPPropertyGridInplaceList Destructors, CXTPPropertyGridInplaceList Constructors, CXTPPropertyGridInplaceList Destructors, CXTPPropertyGridInplaceList Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceList Class

CXTPPropertyGridInplaceList is a CListBox derived class. It is an internal class used by Property Grid control.

Class Hierarchy

class CXTPPropertyGridInplaceList : public CListBox;
File

XTPPropertyGridInplaceList.h

Group

Classes

Legend
Method
protected
virtual
CXTPPropertyGridInplaceList Constructors
CXTPPropertyGridInplaceList Constructors | Description
CXTPPropertyGridInplaceList | Constructs a CXTPPropertyGridInplaceList object
CXTPPropertyGridInplaceList Destructors
CXTPPropertyGridInplaceList Destructors | Description
~CXTPPropertyGridInplaceList | Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.
CXTPPropertyGridInplaceList Methods
CXTPPropertyGridInplaceList Methods | Description
Apply | Call this method to apply user changes.
Cancel | Call this method to cancel user changes.
Create | Call this method to create in-place list control.
DestroyItem | This method is called when the parent item is destroyed.


CXTPPropertyGridInplaceList Methods

CXTPPropertyGridInplaceList Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceList Methods
Class

CXTPPropertyGridInplaceList Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Apply | Call this method to apply user changes.
Cancel | Call this method to cancel user changes.
Public Methods
Public Methods
Public Method | Description
Create | Call this method to create in-place list control.
DestroyItem | This method is called when the parent item is destroyed.


CXTPPropertyGridInplaceList::Apply Method

CXTPPropertyGridInplaceList Methods, CXTPPropertyGridInplaceList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceList::Apply Method

Call this method to apply user changes.

virtual void Apply();
Group

CXTPPropertyGridInplaceList Methods


CXTPPropertyGridInplaceList::Cancel Method

CXTPPropertyGridInplaceList Methods, CXTPPropertyGridInplaceList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceList::Cancel Method

Call this method to cancel user changes.

virtual void Cancel();
Group

CXTPPropertyGridInplaceList Methods


CXTPPropertyGridInplaceList::Create Method

CXTPPropertyGridInplaceList Methods, CXTPPropertyGridInplaceList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceList::Create Method

Call this method to create in-place list control.

virtual void Create(
    CXTPPropertyGridItem* pItem,
    CRect rect
);
Parameters

pItem
Parent item of the list.
rect
Specifies the size and position of the item.

Group

CXTPPropertyGridInplaceList Methods


CXTPPropertyGridInplaceList::DestroyItem Method

CXTPPropertyGridInplaceList Methods, CXTPPropertyGridInplaceList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceList::DestroyItem Method

This method is called when the parent item is destroyed.

virtual void DestroyItem();
Group

CXTPPropertyGridInplaceList Methods


CXTPPropertyGridInplaceList Constructors

CXTPPropertyGridInplaceList Class, Legend, Public Methods
CXTPPropertyGridInplaceList Constructors
Class

CXTPPropertyGridInplaceList Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceList | Constructs a CXTPPropertyGridInplaceList object


CXTPPropertyGridInplaceList::CXTPPropertyGridInplaceList Constructor

CXTPPropertyGridInplaceList Constructors, CXTPPropertyGridInplaceList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceList::CXTPPropertyGridInplaceList Constructor

Constructs a CXTPPropertyGridInplaceList object

CXTPPropertyGridInplaceList();
Group

CXTPPropertyGridInplaceList Constructors


CXTPPropertyGridInplaceList Destructors

CXTPPropertyGridInplaceList Class, Legend, Public Methods
CXTPPropertyGridInplaceList Destructors
Class

CXTPPropertyGridInplaceList Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridInplaceList | Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.


CXTPPropertyGridInplaceList::~CXTPPropertyGridInplaceList Destructor

CXTPPropertyGridInplaceList Destructors, CXTPPropertyGridInplaceList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceList::~CXTPPropertyGridInplaceList Destructor

Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.

virtual ~CXTPPropertyGridInplaceList();
Group

CXTPPropertyGridInplaceList Destructors


CXTPPropertyGridInplaceMonthCal Class

XTPPropertyGridItemExt.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceMonthCal Data Members, CXTPPropertyGridInplaceMonthCal Methods, CXTPPropertyGridInplaceMonthCal Constructors, CXTPPropertyGridInplaceMonthCal Constructors, CXTPPropertyGridInplaceMonthCal Data Members, CXTPPropertyGridInplaceMonthCal Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal Class

Month calendar popup used for CXTPPropertyGridItemDate item.

Class Hierarchy

class CXTPPropertyGridInplaceMonthCal : public CWnd;
File

XTPPropertyGridItemExt.h

Group

Classes

Legend
Data Member
protected
Method
CXTPPropertyGridInplaceMonthCal Constructors
CXTPPropertyGridInplaceMonthCal Constructors | Description
CXTPPropertyGridInplaceMonthCal | Constructs a CXTPPropertyGridInplaceMonthCal object.
CXTPPropertyGridInplaceMonthCal Data Members
CXTPPropertyGridInplaceMonthCal Data Members | Description
m_pItem | Parent item
CXTPPropertyGridInplaceMonthCal Methods
CXTPPropertyGridInplaceMonthCal Methods | Description
GetMinReqRect | Gets the minimal size needed to display one month.
OnAccept | Called if the user hits the Return while an inplace calendar is displayed.
OnCancel | Called if the user hits the Escape key or clicks on another part of the property grid or other application while an inplace calendar is displayed.


CXTPPropertyGridInplaceMonthCal Data Members

CXTPPropertyGridInplaceMonthCal Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal Data Members
Class

CXTPPropertyGridInplaceMonthCal Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pItem | Parent item


CXTPPropertyGridInplaceMonthCal::m_pItem Data Member

CXTPPropertyGridInplaceMonthCal Data Members, CXTPPropertyGridInplaceMonthCal Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal::m_pItem Data Member

Parent item

CXTPPropertyGridItemDate* m_pItem;
Group

CXTPPropertyGridInplaceMonthCal Data Members


CXTPPropertyGridInplaceMonthCal Methods

CXTPPropertyGridInplaceMonthCal Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal Methods
Class

CXTPPropertyGridInplaceMonthCal Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
OnAccept | Called if the user hits the Return while an inplace calendar is displayed.
OnCancel | Called if the user hits the Escape key or clicks on another part of the property grid or other application while an inplace calendar is displayed.
Public Methods
Public Methods
Public Method | Description
GetMinReqRect | Gets the minimal size needed to display one month.


CXTPPropertyGridInplaceMonthCal::GetMinReqRect Method

CXTPPropertyGridInplaceMonthCal Methods, CXTPPropertyGridInplaceMonthCal Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal::GetMinReqRect Method

Gets the minimal size needed to display one month.

BOOL GetMinReqRect(
    RECT* pRect
) const;
Parameters

pRect
Pointer to a RECT that will receive the minimal size needed to display one month. This parameter must be a valid address and cannot be NULL.

Returns

If successful, this member function returns nonzero and pRect receives the applicable bounding rectangle information. If unsuccessful, the member function returns 0.

Remarks

This member function implements the behavior of the CMonthCalCtrl::GetMinReqRect function.

Body Source
BOOL GetMinReqRect(RECT* pRect) const
{
    ASSERT(::IsWindow(m_hWnd)); return (BOOL) ::SendMessage(m_hWnd, MCM_GETMINREQRECT, 0, (LPARAM) pRect);
}
Group

CXTPPropertyGridInplaceMonthCal Methods


CXTPPropertyGridInplaceMonthCal::OnAccept Method

CXTPPropertyGridInplaceMonthCal Methods, CXTPPropertyGridInplaceMonthCal Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal::OnAccept Method

Called if the user hits the Return while an inplace calendar is displayed.

void OnAccept();
Remarks

Also occurs when an item in the implace calendar is selected.

See Also

OnCancel

Group

CXTPPropertyGridInplaceMonthCal Methods


CXTPPropertyGridInplaceMonthCal::OnCancel Method

CXTPPropertyGridInplaceMonthCal Methods, CXTPPropertyGridInplaceMonthCal Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal::OnCancel Method

Called if the user hits the Escape key or clicks on another part of the property grid or other application while an inplace calendar is displayed.

void OnCancel();
See Also

OnAccept

Group

CXTPPropertyGridInplaceMonthCal Methods


CXTPPropertyGridInplaceMonthCal Constructors

CXTPPropertyGridInplaceMonthCal Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal Constructors
Class

CXTPPropertyGridInplaceMonthCal Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceMonthCal | Constructs a CXTPPropertyGridInplaceMonthCal object.


CXTPPropertyGridInplaceMonthCal::CXTPPropertyGridInplaceMonthCal Constructor

CXTPPropertyGridInplaceMonthCal Constructors, CXTPPropertyGridInplaceMonthCal Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMonthCal::CXTPPropertyGridInplaceMonthCal Constructor

Constructs a CXTPPropertyGridInplaceMonthCal object.

CXTPPropertyGridInplaceMonthCal(
    CXTPPropertyGridItemDate* pItem
);
Parameters

pItem
Parent item

Body Source
CXTPPropertyGridInplaceMonthCal(CXTPPropertyGridItemDate* pItem)
{
    m_pItem = pItem;
}
Group

CXTPPropertyGridInplaceMonthCal Constructors


CXTPPropertyGridInplaceMultilineEdit Class

XTPPropertyGridInplaceList.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceMultilineEdit Methods, CXTPPropertyGridInplaceMultilineEdit Constructors, CXTPPropertyGridInplaceMultilineEdit Destructors, CXTPPropertyGridInplaceMultilineEdit Constructors, CXTPPropertyGridInplaceMultilineEdit Destructors, CXTPPropertyGridInplaceMultilineEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit Class

CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class. It is an internal class used by Property Grid control.

Class Hierarchy

class CXTPPropertyGridInplaceMultilineEdit : public CEdit;
File

XTPPropertyGridInplaceList.h

Group

Classes

Legend
Method
protected
virtual
CXTPPropertyGridInplaceMultilineEdit Constructors
CXTPPropertyGridInplaceMultilineEdit Constructors | Description
CXTPPropertyGridInplaceMultilineEdit | Constructs a CXTPPropertyGridInplaceList object
CXTPPropertyGridInplaceMultilineEdit Destructors
CXTPPropertyGridInplaceMultilineEdit Destructors | Description
~CXTPPropertyGridInplaceMultilineEdit | Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.
CXTPPropertyGridInplaceMultilineEdit Methods
CXTPPropertyGridInplaceMultilineEdit Methods | Description
Apply | Call this method to apply user changes.
Cancel | Call this method to cancel user changes.
Create | Call this method to create in-place list control.


CXTPPropertyGridInplaceMultilineEdit Methods

CXTPPropertyGridInplaceMultilineEdit Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit Methods
Class

CXTPPropertyGridInplaceMultilineEdit Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Apply | Call this method to apply user changes.
Cancel | Call this method to cancel user changes.
Public Methods
Public Methods
Public Method | Description
Create | Call this method to create in-place list control.


CXTPPropertyGridInplaceMultilineEdit::Apply Method

CXTPPropertyGridInplaceMultilineEdit Methods, CXTPPropertyGridInplaceMultilineEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit::Apply Method

Call this method to apply user changes.

virtual void Apply();
Group

CXTPPropertyGridInplaceMultilineEdit Methods


CXTPPropertyGridInplaceMultilineEdit::Cancel Method

CXTPPropertyGridInplaceMultilineEdit Methods, CXTPPropertyGridInplaceMultilineEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit::Cancel Method

Call this method to cancel user changes.

virtual void Cancel();
Group

CXTPPropertyGridInplaceMultilineEdit Methods


CXTPPropertyGridInplaceMultilineEdit::Create Method

CXTPPropertyGridInplaceMultilineEdit Methods, CXTPPropertyGridInplaceMultilineEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit::Create Method

Call this method to create in-place list control.

virtual void Create(
    CXTPPropertyGridItem* pItem,
    CRect rect
);
Parameters

pItem
Parent item of the list.
rect
Specifies the size and position of the item.

Group

CXTPPropertyGridInplaceMultilineEdit Methods


CXTPPropertyGridInplaceMultilineEdit Constructors

CXTPPropertyGridInplaceMultilineEdit Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit Constructors
Class

CXTPPropertyGridInplaceMultilineEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceMultilineEdit | Constructs a CXTPPropertyGridInplaceList object


CXTPPropertyGridInplaceMultilineEdit::CXTPPropertyGridInplaceMultilineEdit Constructor

CXTPPropertyGridInplaceMultilineEdit Constructors, CXTPPropertyGridInplaceMultilineEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit::CXTPPropertyGridInplaceMultilineEdit Constructor

Constructs a CXTPPropertyGridInplaceList object

CXTPPropertyGridInplaceMultilineEdit();
Group

CXTPPropertyGridInplaceMultilineEdit Constructors


CXTPPropertyGridInplaceMultilineEdit Destructors

CXTPPropertyGridInplaceMultilineEdit Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit Destructors
Class

CXTPPropertyGridInplaceMultilineEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridInplaceMultilineEdit | Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.


CXTPPropertyGridInplaceMultilineEdit::~CXTPPropertyGridInplaceMultilineEdit Destructor

CXTPPropertyGridInplaceMultilineEdit Destructors, CXTPPropertyGridInplaceMultilineEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceMultilineEdit::~CXTPPropertyGridInplaceMultilineEdit Destructor

Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.

virtual ~CXTPPropertyGridInplaceMultilineEdit();
Group

CXTPPropertyGridInplaceMultilineEdit Destructors


CXTPPropertyGridInplaceSlider Class

XTPPropertyGridInplaceEdit.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceSlider Data Members, CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Constructors, CXTPPropertyGridInplaceSlider Constructors, CXTPPropertyGridInplaceSlider Data Members, CXTPPropertyGridInplaceSlider Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider Class

CXTPPropertyGridInplaceSlider is CXTPPropertyGridInplaceControl derived class. It represents in-place slider of the items. Call CXTPPropertyGridItem::AddSliderControl() to add slider for property grid item

Class Hierarchy

class CXTPPropertyGridInplaceSlider : public CXTPPropertyGridInplaceControl;
File

XTPPropertyGridInplaceEdit.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridInplaceSlider Constructors
CXTPPropertyGridInplaceSlider Constructors | Description
CXTPPropertyGridInplaceSlider | Constructs a CXTPPropertyGridInplaceSlider object
CXTPPropertyGridInplaceSlider Data Members
CXTPPropertyGridInplaceSlider Data Members | Description
m_nMax | Upper range
m_nMin | Lower range
m_nValue | Value of slider
CXTPPropertyGridInplaceSlider Methods
CXTPPropertyGridInplaceSlider Methods | Description
GetMax | Retrieves upper range of slider control
GetMin | Retrieves lower range of slider control
GetSliderCtrl | Retrieves slider control
OnAdjustValueRect | This method is called when item require to calculate its value rectangle
OnCreateWindow | This method is called when item creates its in-place control.
OnValueChanged | This method is called when value of parent item was changed.
SetMax | Call this method to set upper range of slider control
SetMin | Call this method to set lower range of slider control


CXTPPropertyGridInplaceSlider Data Members

CXTPPropertyGridInplaceSlider Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider Data Members
Class

CXTPPropertyGridInplaceSlider Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nMax | Upper range
m_nMin | Lower range
m_nValue | Value of slider


CXTPPropertyGridInplaceSlider::m_nMax Data Member

CXTPPropertyGridInplaceSlider Data Members, CXTPPropertyGridInplaceSlider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::m_nMax Data Member

Upper range

int m_nMax;
Group

CXTPPropertyGridInplaceSlider Data Members


CXTPPropertyGridInplaceSlider::m_nMin Data Member

CXTPPropertyGridInplaceSlider Data Members, CXTPPropertyGridInplaceSlider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::m_nMin Data Member

Lower range

int m_nMin;
Group

CXTPPropertyGridInplaceSlider Data Members


CXTPPropertyGridInplaceSlider::m_nValue Data Member

CXTPPropertyGridInplaceSlider Data Members, CXTPPropertyGridInplaceSlider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::m_nValue Data Member

Value of slider

int m_nValue;
Group

CXTPPropertyGridInplaceSlider Data Members


CXTPPropertyGridInplaceSlider Methods

CXTPPropertyGridInplaceSlider Class, Legend, Public Methods
CXTPPropertyGridInplaceSlider Methods
Class

CXTPPropertyGridInplaceSlider Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetMax | Retrieves upper range of slider control
GetMin | Retrieves lower range of slider control
GetSliderCtrl | Retrieves slider control
OnAdjustValueRect | This method is called when item require to calculate its value rectangle
OnCreateWindow | This method is called when item creates its in-place control.
OnValueChanged | This method is called when value of parent item was changed.
SetMax | Call this method to set upper range of slider control
SetMin | Call this method to set lower range of slider control


CXTPPropertyGridInplaceSlider::GetMax Method

CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::GetMax Method

Retrieves upper range of slider control

int GetMax() const;
Body Source
int CXTPPropertyGridInplaceSlider::GetMax() const {
    return m_nMax;
}
Group

CXTPPropertyGridInplaceSlider Methods


CXTPPropertyGridInplaceSlider::GetMin Method

CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::GetMin Method

Retrieves lower range of slider control

int GetMin() const;
Body Source
int CXTPPropertyGridInplaceSlider::GetMin() const {
    return m_nMin;
}
Group

CXTPPropertyGridInplaceSlider Methods


CXTPPropertyGridInplaceSlider::GetSliderCtrl Method

CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::GetSliderCtrl Method

Retrieves slider control

CSliderCtrl* GetSliderCtrl() const;
Body Source
CSliderCtrl* CXTPPropertyGridInplaceSlider::GetSliderCtrl() const {
    return (CSliderCtrl*)this;
}
Group

CXTPPropertyGridInplaceSlider Methods


CXTPPropertyGridInplaceSlider::OnAdjustValueRect Method

CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::OnAdjustValueRect Method

This method is called when item require to calculate its value rectangle

virtual void OnAdjustValueRect(
    CRect& rcValue
);
Parameters

rcValue
Bounding rectangle of value.

See Also

OnCreateWindow

Group

CXTPPropertyGridInplaceSlider Methods


CXTPPropertyGridInplaceSlider::OnCreateWindow Method

CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::OnCreateWindow Method

This method is called when item creates its in-place control.

virtual void OnCreateWindow(
    CRect& rcValue
);
Parameters

rcValue
Boundary rectangle of control.

See Also

OnDestroyWindow

Group

CXTPPropertyGridInplaceSlider Methods


CXTPPropertyGridInplaceSlider::OnValueChanged Method

CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::OnValueChanged Method

This method is called when value of parent item was changed.

virtual void OnValueChanged();
Group

CXTPPropertyGridInplaceSlider Methods


CXTPPropertyGridInplaceSlider::SetMax Method

CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::SetMax Method

Call this method to set upper range of slider control

void SetMax(
    int nMax
);
Parameters

nMax
upper range

See Also

SetMin

Body Source
void CXTPPropertyGridInplaceSlider::SetMax(int nMax) {
    m_nMax = nMax;
}
Group

CXTPPropertyGridInplaceSlider Methods


CXTPPropertyGridInplaceSlider::SetMin Method

CXTPPropertyGridInplaceSlider Methods, CXTPPropertyGridInplaceSlider Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::SetMin Method

Call this method to set lower range of slider control

void SetMin(
    int nMin
);
Parameters

nMin
lower range

See Also

SetMax

Body Source
void CXTPPropertyGridInplaceSlider::SetMin(int nMin) {
    m_nMin = nMin;
}
Group

CXTPPropertyGridInplaceSlider Methods


CXTPPropertyGridInplaceSlider Constructors

CXTPPropertyGridInplaceSlider Class, Legend, Public Methods
CXTPPropertyGridInplaceSlider Constructors
Class

CXTPPropertyGridInplaceSlider Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceSlider | Constructs a CXTPPropertyGridInplaceSlider object


CXTPPropertyGridInplaceSlider::CXTPPropertyGridInplaceSlider Constructor

CXTPPropertyGridInplaceSlider Constructors, CXTPPropertyGridInplaceSlider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSlider::CXTPPropertyGridInplaceSlider Constructor

Constructs a CXTPPropertyGridInplaceSlider object

CXTPPropertyGridInplaceSlider(
    CXTPPropertyGridItem* pItem
);
Parameters

pItem
Parent property grid item

Group

CXTPPropertyGridInplaceSlider Constructors


CXTPPropertyGridInplaceSpinButton Class

XTPPropertyGridInplaceEdit.h, Classes, Legend, Members, Topics, CXTPPropertyGridInplaceSpinButton Data Members, CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Constructors, CXTPPropertyGridInplaceSpinButton Constructors, CXTPPropertyGridInplaceSpinButton Data Members, CXTPPropertyGridInplaceSpinButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton Class

CXTPPropertyGridInplaceSpinButton is CXTPPropertyGridInplaceControl derived class. It represents in-place spin button of the items. Call CXTPPropertyGridItem::AddSpinButton() to add spin button for property grid item

Class Hierarchy

class CXTPPropertyGridInplaceSpinButton : public CXTPPropertyGridInplaceControl;
File

XTPPropertyGridInplaceEdit.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridInplaceSpinButton Constructors
CXTPPropertyGridInplaceSpinButton Constructors | Description
CXTPPropertyGridInplaceSpinButton | Constructs a CXTPPropertyGridInplaceSpinButton object
CXTPPropertyGridInplaceSpinButton Data Members
CXTPPropertyGridInplaceSpinButton Data Members | Description
m_nMax | Upper range
m_nMin | Lower range
CXTPPropertyGridInplaceSpinButton Methods
CXTPPropertyGridInplaceSpinButton Methods | Description
GetMax | Retrieves upper range of spin control
GetMin | Retrieves lower range of spin control
GetSpinButtonCtrl | Retrieves CSpinButtonCtrl control
OnAdjustValueRect | This method is called when item require to calculate its value rectangle
OnCreateWindow | This method is called when item creates its in-place control.
OnValueChanged | This method is called when value of parent item was changed.
SetMax | Call this method to set upper range of spin control
SetMin | Call this method to set lower range of spin control


CXTPPropertyGridInplaceSpinButton Data Members

CXTPPropertyGridInplaceSpinButton Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton Data Members
Class

CXTPPropertyGridInplaceSpinButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nMax | Upper range
m_nMin | Lower range


CXTPPropertyGridInplaceSpinButton::m_nMax Data Member

CXTPPropertyGridInplaceSpinButton Data Members, CXTPPropertyGridInplaceSpinButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::m_nMax Data Member

Upper range

int m_nMax;
Group

CXTPPropertyGridInplaceSpinButton Data Members


CXTPPropertyGridInplaceSpinButton::m_nMin Data Member

CXTPPropertyGridInplaceSpinButton Data Members, CXTPPropertyGridInplaceSpinButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::m_nMin Data Member

Lower range

int m_nMin;
Group

CXTPPropertyGridInplaceSpinButton Data Members


CXTPPropertyGridInplaceSpinButton Methods

CXTPPropertyGridInplaceSpinButton Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton Methods
Class

CXTPPropertyGridInplaceSpinButton Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetMax | Retrieves upper range of spin control
GetMin | Retrieves lower range of spin control
GetSpinButtonCtrl | Retrieves CSpinButtonCtrl control
OnAdjustValueRect | This method is called when item require to calculate its value rectangle
OnCreateWindow | This method is called when item creates its in-place control.
OnValueChanged | This method is called when value of parent item was changed.
SetMax | Call this method to set upper range of spin control
SetMin | Call this method to set lower range of spin control


CXTPPropertyGridInplaceSpinButton::GetMax Method

CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::GetMax Method

Retrieves upper range of spin control

int GetMax() const;
Body Source
int CXTPPropertyGridInplaceSpinButton::GetMax() const {
    return m_nMax;
}
Group

CXTPPropertyGridInplaceSpinButton Methods


CXTPPropertyGridInplaceSpinButton::GetMin Method

CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::GetMin Method

Retrieves lower range of spin control

int GetMin() const;
Body Source
int CXTPPropertyGridInplaceSpinButton::GetMin() const {
    return m_nMin;
}
Group

CXTPPropertyGridInplaceSpinButton Methods


CXTPPropertyGridInplaceSpinButton::GetSpinButtonCtrl Method

CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::GetSpinButtonCtrl Method

Retrieves CSpinButtonCtrl control

CSpinButtonCtrl* GetSpinButtonCtrl() const;
Body Source
CSpinButtonCtrl* CXTPPropertyGridInplaceSpinButton::GetSpinButtonCtrl() const {
    return (CSpinButtonCtrl*)this;
}
Group

CXTPPropertyGridInplaceSpinButton Methods


CXTPPropertyGridInplaceSpinButton::OnAdjustValueRect Method

CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::OnAdjustValueRect Method

This method is called when item require to calculate its value rectangle

virtual void OnAdjustValueRect(
    CRect& rcValue
);
Parameters

rcValue
Bounding rectangle of value.

See Also

OnCreateWindow

Group

CXTPPropertyGridInplaceSpinButton Methods


CXTPPropertyGridInplaceSpinButton::OnCreateWindow Method

CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::OnCreateWindow Method

This method is called when item creates its in-place control.

virtual void OnCreateWindow(
    CRect& rcValue
);
Parameters

rcValue
Boundary rectangle of control.

See Also

OnDestroyWindow

Group

CXTPPropertyGridInplaceSpinButton Methods


CXTPPropertyGridInplaceSpinButton::OnValueChanged Method

CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::OnValueChanged Method

This method is called when value of parent item was changed.

virtual void OnValueChanged();
Group

CXTPPropertyGridInplaceSpinButton Methods


CXTPPropertyGridInplaceSpinButton::SetMax Method

CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::SetMax Method

Call this method to set upper range of spin control

void SetMax(
    int nMax
);
Parameters

nMax
upper range

See Also

SetMin

Body Source
void CXTPPropertyGridInplaceSpinButton::SetMax(int nMax) {
    m_nMax = nMax;
}
Group

CXTPPropertyGridInplaceSpinButton Methods


CXTPPropertyGridInplaceSpinButton::SetMin Method

CXTPPropertyGridInplaceSpinButton Methods, CXTPPropertyGridInplaceSpinButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::SetMin Method

Call this method to set lower range of spin control

void SetMin(
    int nMin
);
Parameters

nMin
lower range

See Also

SetMax

Body Source
void CXTPPropertyGridInplaceSpinButton::SetMin(int nMin) {
    m_nMin = nMin;
}
Group

CXTPPropertyGridInplaceSpinButton Methods


CXTPPropertyGridInplaceSpinButton Constructors

CXTPPropertyGridInplaceSpinButton Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton Constructors
Class

CXTPPropertyGridInplaceSpinButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceSpinButton | Constructs a CXTPPropertyGridInplaceSpinButton object


CXTPPropertyGridInplaceSpinButton::CXTPPropertyGridInplaceSpinButton Constructor

CXTPPropertyGridInplaceSpinButton Constructors, CXTPPropertyGridInplaceSpinButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridInplaceSpinButton::CXTPPropertyGridInplaceSpinButton Constructor

Constructs a CXTPPropertyGridInplaceSpinButton object

CXTPPropertyGridInplaceSpinButton(
    CXTPPropertyGridItem* pItem
);
Parameters

pItem
Parent property grid item

Group

CXTPPropertyGridInplaceSpinButton Constructors


CXTPPropertyGridItem Class

XTPPropertyGridItem.h, Classes, Legend, Members, Topics, CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Methods, CXTPPropertyGridItem Constructors, CXTPPropertyGridItem Destructors, CXTPPropertyGridItem Constructors, CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Destructors, CXTPPropertyGridItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem Class

CXTPPropertyGridItem is the base class representing an item of the Property Grid Control.

Class Hierarchy

class CXTPPropertyGridItem;
File

XTPPropertyGridItem.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItem Constructors
CXTPPropertyGridItem Constructors | Description
CXTPPropertyGridItem |
CXTPPropertyGridItem Data Members
CXTPPropertyGridItem Data Members | Description
m_bCategory | TRUE if the item is category.
m_bConstraintEdit | TRUE to constraint edit.
m_bExpandable | TRUE if item can be expanded.
m_bExpanded | TRUE if item is expanded.
m_bHidden | TRUE if item is hidden
m_bPassword | TRUE to use a password mask.
m_bReadOnly | TRUE to disable item's edition.
m_bUseMask | TRUE to use and edit mask to display item data.
m_bVisible | Visibility of the item.
m_chPrompt | Character used as a space holder for a character.
m_dwData | The 32-bit value associated with the item
m_dwEditStyle | Edit style.
m_nDropDownItemCount | Maximum drop down items
m_nFlags | Item's flags.
m_nHeight | Item's height.
m_nID | Identifier of the item.
m_nIndent | Indent of the item.
m_nIndex | Index of the item.
m_nLinesCount | Count of lines of Multi line item.
m_pBindString | Binded string.
m_pCaptionMetrics | Caption part metrics
m_pChilds | Child items.
m_pConstraints | Item's constraints.
m_pGrid | Parent grid class.
m_pInplaceButtons | Inplace buttons array
m_pParent | Parent item.
m_pValueMetrics | Value part metrics
m_strCaption | Caption of the item.
m_strDefaultValue | Default value of the item.
m_strDescription | Description of the item.
m_strFormat | Format of the double value.
m_strLiteral | String to use as literal.
m_strMask | String to use as edit mask.
m_strValue | Value of the item.
CXTPPropertyGridItem Destructors
CXTPPropertyGridItem Destructors | Description
~CXTPPropertyGridItem | Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation
CXTPPropertyGridItem Methods
CXTPPropertyGridItem Methods | Description
AddChildItem | Call this method to add a child item.
AddComboButton | Call this method to add standard combo button
AddExpandButton | Call this method to add standard expand button
AddSliderControl | Call this method to add slider control
AddSpinButton | Call this method to add spin control
BindToString | Call this method to bind an item to a CString object.
Collapse | Call this method to collapse the item.
EnsureVisible | Call this function to ensure that the item is visible.
Expand | Call this method to expand the item.
GetCaption | Call this method to get the caption of the item.
GetCaptionMetrics | Call this method to get metrics of caption part
GetChilds | Returns a list of the children
GetConstraintEdit | Retrieves constraint edit state.
GetConstraints | Call this method to get the constraints list.
GetDescription | Call this method to get the description of the item.
GetDropDownItemCount | Retrieves count of items in the dropdown list.
GetEditStyle | This method is called to get edit styles of the item, override it if you need custom style
GetFlags | Call this method to get the XTPPropertyGridItemFlags of the item.
GetGrid | Call this member to return the parent window
GetHeight | Call this member to get variable height of the item.
GetID | Call this method to get the identifier of the item.
GetIndent | Call this member function to retrieve the item's indent.
GetIndex | Call this method to get the index of the item in property grid list
GetInplaceButtons | Retrieves collection of in-place buttons for the item
GetInplaceControls | Retrieves collection of in-place controls for the item
GetInplaceEdit | Call this member function to return in-place edit control of the item
GetInplaceList | Call this member function to return in-place list control of the item
GetItemData | This method retrieves the application-supplied 32-bit value associated with the item
GetItemRect | Retrieves the bounding rectangle of the item
GetMaskedText | Call this member to get the actual text value for the property grid item without the "edit mask" characters added by the SetMask member.
GetMetrics | Call this method to get metrics of caption part or value part
GetMultiLinesCount | Call this member to get total item lines
GetParentItem | Call this member function to retrieve the parent property grid item.
GetReadOnly | Call this method to get the read-only state of the item.
GetTooltip | Call this member to retrieve the item's tooltip
GetValue | Call this method to get the current value of the item.
GetValueMetrics | Call this method to get metrics of value part
GetValueRect | Retrieves the bounding rectangle of the item value's text. Override this member function to change it.
GetViewValue | Call this member to retrieve the value of the item that the user is viewing.
HasChilds | The HasChilds function determines whether or not the item has children.
HasParent | The HasParent function determines whether or not the item has a pParent item as a parent.
HasVisibleChilds | The HasChilds function determines whether or not the item has visible children.
InsertChildItem | Call this method to insert a child item.
IsCategory | The IsCategory function determines whether or not the item is a category.
IsExpandable | Call this method to check if item can be expanded.
IsExpanded | Call this member function to determine if the item is expanded.
IsHidden | Call this member function to determine if the item is hidden.
IsInplaceButtonsVisible | Determines if in-place buttons are visible for item
IsMultiLine | Call this member to determine if item is multi line.
IsSelected | Retrieves if the item is selected.
IsValueChanged | This member called to determine if value was changed by user.
IsVisible | Call this member function to determine if the item is visible.
MeasureItem | Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
OnAddChildItem | This method is called when an item is added to the parent.
OnAfterEdit | This method is called before user apply new value of the item
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnCancelEdit | This method is called if user cancel edit item
OnChar | This method is called when a key is pressed.
OnConstraintsChanged | This member is called when constraints are added to this item.
OnDeselect | This method is called when an item is de-selected.
OnDrawItemConstraint | This method is called when an constraint in inplace list is drawn. Override this function if needed.
OnDrawItemValue | This method is called when an item is drawn. Override this function if needed.
OnIndexChanged | This method is called when index of the item was changed
OnInplaceButtonDown | This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.
OnKeyDown | This method is called when a non-system key is pressed.
OnLButtonDblClk | This method is called when the user double-clicks the left mouse button.
OnLButtonDown | This method is called when the user presses the left mouse button.
OnLButtonUp | This method is called when the user release the left mouse button.
OnMergeItemConstraint | This method is called to get size of constraint in inplace list. Override this function if needed.
OnRButtonDown | This method is called when the user clicks the right mouse button down.
OnRequestEdit | This method is called before user start edit the item
OnSelect | This method is called when an item is selected.
OnValidateEdit | This method is called to check value from in-place edit control.
OnValueChanged | This method is called when an item's value is changed. Override this function if needed.
PtInValueRect | Determines if point belongs value rectangle
Remove | Removes this item.
ResetValue | Call this member to rest value to its default
Select | Call this method to select the item.
SelectNextConstraint | This method is called to switch constraints.
SetAutoComplete | Call this method to use enable auto complete from constraint list.
SetCaption | Call this method to set the caption of the item.
SetConstraintEdit | Call this method to edit only values from constraint list.
SetDefaultValue | Call this member to set default value of the item
SetDescription | Call this method to set the description of the item. This is the text displayed in the help panel.
SetDropDownItemCount | Call this member to set the count of items in the dropdown list.
SetEditStyle | Call this method to set edit styles of the item.
SetEditText | This method is called to set text of thein-placee edit control.
SetExpandable | Call this method to enable/disable expanding by users
SetFlags | This member function is called to set a specific flag for the item.
SetFocusToInplaceControl | This method is called to set focus to item in-place control.
SetHeight | Call this member to set variable height of the item.
SetHidden | Call this method to hide/unhide item
SetID | Call this method to set the identifier of the item.
SetItemData | This method sets the 32-bit value associated with the item.
SetMask | Applies the specified Mask to a CXTPPropertyGridItem data field to to create a restrictive field for text entry.
SetMaskedText | Call this member to set the actual text value for the property grid item without the "edit mask" characters added by the SetMask member.
SetMultiLinesCount | Call this member to set total lines of multi line item
SetPasswordMask | Call this method to set a password mask for this item. By default, all characters will be replaced by an asterisk (*).
SetPrompt | Call this member to load a string from a STRINGTABLE resource to set the caption and description.
SetReadOnly | Call this method to set the read-only state of the item.
SetTooltip | Associates ToolTip text with the item.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
SetVisible | This method is called when visibility state of the item was changed.


CXTPPropertyGridItem Data Members

CXTPPropertyGridItem Class, Legend, Protected Data Members
CXTPPropertyGridItem Data Members
Class

CXTPPropertyGridItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bCategory | TRUE if the item is category.
m_bConstraintEdit | TRUE to constraint edit.
m_bExpandable | TRUE if item can be expanded.
m_bExpanded | TRUE if item is expanded.
m_bHidden | TRUE if item is hidden
m_bPassword | TRUE to use a password mask.
m_bReadOnly | TRUE to disable item's edition.
m_bUseMask | TRUE to use and edit mask to display item data.
m_bVisible | Visibility of the item.
m_chPrompt | Character used as a space holder for a character.
m_dwData | The 32-bit value associated with the item
m_dwEditStyle | Edit style.
m_nDropDownItemCount | Maximum drop down items
m_nFlags | Item's flags.
m_nHeight | Item's height.
m_nID | Identifier of the item.
m_nIndent | Indent of the item.
m_nIndex | Index of the item.
m_nLinesCount | Count of lines of Multi line item.
m_pBindString | Binded string.
m_pCaptionMetrics | Caption part metrics
m_pChilds | Child items.
m_pConstraints | Item's constraints.
m_pGrid | Parent grid class.
m_pInplaceButtons | Inplace buttons array
m_pParent | Parent item.
m_pValueMetrics | Value part metrics
m_strCaption | Caption of the item.
m_strDefaultValue | Default value of the item.
m_strDescription | Description of the item.
m_strFormat | Format of the double value.
m_strLiteral | String to use as literal.
m_strMask | String to use as edit mask.
m_strValue | Value of the item.


CXTPPropertyGridItem::m_bCategory Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bCategory Data Member

TRUE if the item is category.

BOOL m_bCategory;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_bConstraintEdit Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bConstraintEdit Data Member

TRUE to constraint edit.

BOOL m_bConstraintEdit;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_bExpandable Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bExpandable Data Member

TRUE if item can be expanded.

BOOL m_bExpandable;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_bExpanded Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bExpanded Data Member

TRUE if item is expanded.

BOOL m_bExpanded;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_bHidden Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bHidden Data Member

TRUE if item is hidden

BOOL m_bHidden;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_bPassword Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bPassword Data Member

TRUE to use a password mask.

BOOL m_bPassword;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_bReadOnly Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bReadOnly Data Member

TRUE to disable item's edition.

BOOL m_bReadOnly;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_bUseMask Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bUseMask Data Member

TRUE to use and edit mask to display item data.

bool m_bUseMask;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_bVisible Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_bVisible Data Member

Visibility of the item.

BOOL m_bVisible;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_chPrompt Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_chPrompt Data Member

Character used as a space holder for a character.

TCHAR m_chPrompt;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_dwData Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_dwData Data Member

The 32-bit value associated with the item

DWORD_PTR m_dwData;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_dwEditStyle Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_dwEditStyle Data Member

Edit style.

DWORD m_dwEditStyle;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_nDropDownItemCount Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_nDropDownItemCount Data Member

Maximum drop down items

int m_nDropDownItemCount;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_nFlags Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_nFlags Data Member

Item's flags.

UINT m_nFlags;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_nHeight Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_nHeight Data Member

Item's height.

int m_nHeight;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_nID Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_nID Data Member

Identifier of the item.

UINT m_nID;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_nIndent Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_nIndent Data Member

Indent of the item.

int m_nIndent;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_nIndex Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_nIndex Data Member

Index of the item.

int m_nIndex;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_nLinesCount Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_nLinesCount Data Member

Count of lines of Multi line item.

int m_nLinesCount;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_pBindString Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_pBindString Data Member

Binded string.

CString* m_pBindString;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_pCaptionMetrics Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_pCaptionMetrics Data Member

Caption part metrics

mutable CXTPPropertyGridItemMetrics* m_pCaptionMetrics;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_pChilds Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_pChilds Data Member

Child items.

CXTPPropertyGridItems* m_pChilds;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_pConstraints Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_pConstraints Data Member

Item's constraints.

CXTPPropertyGridItemConstraints* m_pConstraints;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_pGrid Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_pGrid Data Member

Parent grid class.

CXTPPropertyGridView* m_pGrid;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_pInplaceButtons Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_pInplaceButtons Data Member

Inplace buttons array

CXTPPropertyGridInplaceButtons* m_pInplaceButtons;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_pParent Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_pParent Data Member

Parent item.

CXTPPropertyGridItem* m_pParent;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_pValueMetrics Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_pValueMetrics Data Member

Value part metrics

mutable CXTPPropertyGridItemMetrics* m_pValueMetrics;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_strCaption Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_strCaption Data Member

Caption of the item.

CString m_strCaption;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_strDefaultValue Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_strDefaultValue Data Member

Default value of the item.

CString m_strDefaultValue;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_strDescription Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_strDescription Data Member

Description of the item.

CString m_strDescription;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_strFormat Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_strFormat Data Member

Format of the double value.

CString m_strFormat;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_strLiteral Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_strLiteral Data Member

String to use as literal.

CString m_strLiteral;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_strMask Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_strMask Data Member

String to use as edit mask.

CString m_strMask;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem::m_strValue Data Member

CXTPPropertyGridItem Data Members, CXTPPropertyGridItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::m_strValue Data Member

Value of the item.

CString m_strValue;
Group

CXTPPropertyGridItem Data Members


CXTPPropertyGridItem Methods

CXTPPropertyGridItem Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem Methods
Class

CXTPPropertyGridItem Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetEditStyle | This method is called to get edit styles of the item, override it if you need custom style
GetInplaceList | Call this member function to return in-place list control of the item
OnAddChildItem | This method is called when an item is added to the parent.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnChar | This method is called when a key is pressed.
OnConstraintsChanged | This member is called when constraints are added to this item.
OnDeselect | This method is called when an item is de-selected.
OnIndexChanged | This method is called when index of the item was changed
OnInplaceButtonDown | This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.
OnKeyDown | This method is called when a non-system key is pressed.
OnLButtonDblClk | This method is called when the user double-clicks the left mouse button.
OnLButtonDown | This method is called when the user presses the left mouse button.
OnLButtonUp | This method is called when the user release the left mouse button.
OnRButtonDown | This method is called when the user clicks the right mouse button down.
OnSelect | This method is called when an item is selected.
PtInValueRect | Determines if point belongs value rectangle
SelectNextConstraint | This method is called to switch constraints.
SetEditText | This method is called to set text of thein-placee edit control.
SetVisible | This method is called when visibility state of the item was changed.
Public Methods
Public Methods
Public Method | Description
AddChildItem | Call this method to add a child item.
AddComboButton | Call this method to add standard combo button
AddExpandButton | Call this method to add standard expand button
AddSliderControl | Call this method to add slider control
AddSpinButton | Call this method to add spin control
BindToString | Call this method to bind an item to a CString object.
Collapse | Call this method to collapse the item.
EnsureVisible | Call this function to ensure that the item is visible.
Expand | Call this method to expand the item.
GetCaption | Call this method to get the caption of the item.
GetCaptionMetrics | Call this method to get metrics of caption part
GetChilds | Returns a list of the children
GetConstraintEdit | Retrieves constraint edit state.
GetConstraints | Call this method to get the constraints list.
GetDescription | Call this method to get the description of the item.
GetDropDownItemCount | Retrieves count of items in the dropdown list.
GetFlags | Call this method to get the XTPPropertyGridItemFlags of the item.
GetGrid | Call this member to return the parent window
GetHeight | Call this member to get variable height of the item.
GetID | Call this method to get the identifier of the item.
GetIndent | Call this member function to retrieve the item's indent.
GetIndex | Call this method to get the index of the item in property grid list
GetInplaceButtons | Retrieves collection of in-place buttons for the item
GetInplaceControls | Retrieves collection of in-place controls for the item
GetInplaceEdit | Call this member function to return in-place edit control of the item
GetItemData | This method retrieves the application-supplied 32-bit value associated with the item
GetItemRect | Retrieves the bounding rectangle of the item
GetMaskedText | Call this member to get the actual text value for the property grid item without the "edit mask" characters added by the SetMask member.
GetMetrics | Call this method to get metrics of caption part or value part
GetMultiLinesCount | Call this member to get total item lines
GetParentItem | Call this member function to retrieve the parent property grid item.
GetReadOnly | Call this method to get the read-only state of the item.
GetTooltip | Call this member to retrieve the item's tooltip
GetValue | Call this method to get the current value of the item.
GetValueMetrics | Call this method to get metrics of value part
GetValueRect | Retrieves the bounding rectangle of the item value's text. Override this member function to change it.
GetViewValue | Call this member to retrieve the value of the item that the user is viewing.
HasChilds | The HasChilds function determines whether or not the item has children.
HasParent | The HasParent function determines whether or not the item has a pParent item as a parent.
HasVisibleChilds | The HasChilds function determines whether or not the item has visible children.
InsertChildItem | Call this method to insert a child item.
IsCategory | The IsCategory function determines whether or not the item is a category.
IsExpandable | Call this method to check if item can be expanded.
IsExpanded | Call this member function to determine if the item is expanded.
IsHidden | Call this member function to determine if the item is hidden.
IsInplaceButtonsVisible | Determines if in-place buttons are visible for item
IsMultiLine | Call this member to determine if item is multi line.
IsSelected | Retrieves if the item is selected.
IsValueChanged | This member called to determine if value was changed by user.
IsVisible | Call this member function to determine if the item is visible.
MeasureItem | Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
OnAfterEdit | This method is called before user apply new value of the item
OnCancelEdit | This method is called if user cancel edit item
OnDrawItemConstraint | This method is called when an constraint in inplace list is drawn. Override this function if needed.
OnDrawItemValue | This method is called when an item is drawn. Override this function if needed.
OnMergeItemConstraint | This method is called to get size of constraint in inplace list. Override this function if needed.
OnRequestEdit | This method is called before user start edit the item
OnValidateEdit | This method is called to check value from in-place edit control.
OnValueChanged | This method is called when an item's value is changed. Override this function if needed.
Remove | Removes this item.
ResetValue | Call this member to rest value to its default
Select | Call this method to select the item.
SetAutoComplete | Call this method to use enable auto complete from constraint list.
SetCaption | Call this method to set the caption of the item.
SetConstraintEdit | Call this method to edit only values from constraint list.
SetDefaultValue | Call this member to set default value of the item
SetDescription | Call this method to set the description of the item. This is the text displayed in the help panel.
SetDropDownItemCount | Call this member to set the count of items in the dropdown list.
SetEditStyle | Call this method to set edit styles of the item.
SetExpandable | Call this method to enable/disable expanding by users
SetFlags | This member function is called to set a specific flag for the item.
SetFocusToInplaceControl | This method is called to set focus to item in-place control.
SetHeight | Call this member to set variable height of the item.
SetHidden | Call this method to hide/unhide item
SetID | Call this method to set the identifier of the item.
SetItemData | This method sets the 32-bit value associated with the item.
SetMask | Applies the specified Mask to a CXTPPropertyGridItem data field to to create a restrictive field for text entry.
SetMaskedText | Call this member to set the actual text value for the property grid item without the "edit mask" characters added by the SetMask member.
SetMultiLinesCount | Call this member to set total lines of multi line item
SetPasswordMask | Call this method to set a password mask for this item. By default, all characters will be replaced by an asterisk (*).
SetPrompt | Call this member to load a string from a STRINGTABLE resource to set the caption and description.
SetReadOnly | Call this method to set the read-only state of the item.
SetTooltip | Associates ToolTip text with the item.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.


CXTPPropertyGridItem::AddChildItem Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::AddChildItem Method

Call this method to add a child item.

CXTPPropertyGridItem* AddChildItem(
    CXTPPropertyGridItem* pItem
);
Parameters

pItem
The item to be added as a child.

Returns

A pointer to a CXTPPropertyGridItem object.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::AddComboButton Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::AddComboButton Method

Call this method to add standard combo button

void AddComboButton();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::AddExpandButton Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::AddExpandButton Method

Call this method to add standard expand button

void AddExpandButton();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::AddSliderControl Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::AddSliderControl Method

Call this method to add slider control

CXTPPropertyGridInplaceSlider* AddSliderControl();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::AddSpinButton Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::AddSpinButton Method

Call this method to add spin control

CXTPPropertyGridInplaceSpinButton* AddSpinButton();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::BindToString Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::BindToString Method

Call this method to bind an item to a CString object.

void BindToString(
    CString* pBindString
);
Parameters

pBindString
CString object to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToString member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::Collapse Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::Collapse Method

Call this method to collapse the item.

void Collapse();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::EnsureVisible Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::EnsureVisible Method

Call this function to ensure that the item is visible.

void EnsureVisible();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::Expand Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::Expand Method

Call this method to expand the item.

void Expand();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetCaption Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetCaption Method

Call this method to get the caption of the item.

CString GetCaption() const;
Returns

A CString object containing the caption of the item.

Body Source
CString CXTPPropertyGridItem::GetCaption() const {
    return m_strCaption;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetCaptionMetrics Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetCaptionMetrics Method

Call this method to get metrics of caption part

CXTPPropertyGridItemMetrics* GetCaptionMetrics() const;
Returns

Pointer to CXTPPropertyGridItemMetrics contained metrics (color, style) of caption part

See Also

CXTPPropertyGridItemMetrics, GetValueMetrics

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetChilds Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetChilds Method

Returns a list of the children

CXTPPropertyGridItems* GetChilds() const;
Returns

A pointer to a CXTPPropertyGridItems object.

Body Source
CXTPPropertyGridItems* CXTPPropertyGridItem::GetChilds() const {
    return m_pChilds;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetConstraintEdit Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetConstraintEdit Method

Retrieves constraint edit state.

BOOL GetConstraintEdit() const;
Returns

TRUE if item is constraint edit.

Body Source
BOOL CXTPPropertyGridItem::GetConstraintEdit() const {
    return m_bConstraintEdit;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetConstraints Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetConstraints Method

Call this method to get the constraints list.

CXTPPropertyGridItemConstraints* GetConstraints() const;
Returns

A pointer to a CXTPPropertyGridItemConstraints object.

See Also

CXTPPropertyGridItemConstraints::AddConstraint, OnConstraintsChanged

Example
CXTPPropertyGridItemConstraints* pList = pItem->GetConstraints();
Body Source
CXTPPropertyGridItemConstraints* CXTPPropertyGridItem::GetConstraints() const {
    return m_pConstraints;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetDescription Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetDescription Method

Call this method to get the description of the item.

CString GetDescription() const;
Returns

A CString object containing the description of the item.

Body Source
CString CXTPPropertyGridItem::GetDescription() const {
    return m_strDescription;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetDropDownItemCount Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetDropDownItemCount Method

Retrieves count of items in the dropdown list.

int GetDropDownItemCount() const;
Returns

Count of items in the dropdown list

See Also

SetDropDownItemCount

Body Source
int CXTPPropertyGridItem::GetDropDownItemCount() const {
    return m_nDropDownItemCount;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetEditStyle Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetEditStyle Method

This method is called to get edit styles of the item, override it if you need custom style

virtual DWORD GetEditStyle() const;
Returns

Styles of the edit control.

Remarks

By default it returns WS_CHILD | ES_AUTOHSCROLL

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetFlags Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetFlags Method

Call this method to get the XTPPropertyGridItemFlags of the item.

UINT GetFlags() const;
Returns

A integer value that represents item's flags. Value will be a member of XTPPropertyGridItemFlags.

See Also

XTPPropertyGridItemFlags

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetGrid Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetGrid Method

Call this member to return the parent window

CXTPPropertyGridView* GetGrid() const;
Returns

The parent window.

Body Source
CXTPPropertyGridView* CXTPPropertyGridItem::GetGrid() const {
    return m_pGrid;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetHeight Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetHeight Method

Call this member to get variable height of the item.

int GetHeight() const;
Returns

Height of the item or -1 if default values used.

Body Source
int CXTPPropertyGridItem::GetHeight() const {
    return m_nHeight;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetID Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetID Method

Call this method to get the identifier of the item.

UINT GetID() const;
Returns

An integer value that represents the identifier of the item.

Body Source
UINT CXTPPropertyGridItem::GetID() const {
    return m_nID;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetIndent Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetIndent Method

Call this member function to retrieve the item's indent.

int GetIndent() const;
Returns

Item's indent.

Body Source
int CXTPPropertyGridItem::GetIndent() const {
    return m_nIndent;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetIndex Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetIndex Method

Call this method to get the index of the item in property grid list

int GetIndex() const;
Returns

An integer value that represents the index of the item.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetInplaceButtons Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetInplaceButtons Method

Retrieves collection of in-place buttons for the item

CXTPPropertyGridInplaceButtons* GetInplaceButtons() const;
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetInplaceControls Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetInplaceControls Method

Retrieves collection of in-place controls for the item

CXTPPropertyGridInplaceControls* GetInplaceControls() const;
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetInplaceEdit Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetInplaceEdit Method

Call this member function to return in-place edit control of the item

virtual CXTPPropertyGridInplaceEdit& GetInplaceEdit();
Returns

A reference to an in-place edit control.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetInplaceList Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetInplaceList Method

Call this member function to return in-place list control of the item

virtual CXTPPropertyGridInplaceList& GetInplaceList();
Returns

A reference to an in-place list control.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetItemData Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetItemData Method

This method retrieves the application-supplied 32-bit value associated with the item

DWORD_PTR GetItemData() const;
Returns

The 32-bit value associated with the item

Body Source
DWORD_PTR CXTPPropertyGridItem::GetItemData() const {
    return m_dwData;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetItemRect Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetItemRect Method

Retrieves the bounding rectangle of the item

CRect GetItemRect() const;
Returns

A CRect object that represents the bounding rectangle of the item.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetMaskedText Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetMaskedText Method

Call this member to get the actual text value for the property grid item without the "edit mask" characters added by the SetMask member.

CString GetMaskedText() const;
Returns

Actual text value of the item without mask characters.

See Also

SetMaskedText, SetMask

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetMetrics Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetMetrics Method

Call this method to get metrics of caption part or value part

CXTPPropertyGridItemMetrics* GetMetrics(
    BOOL bValueMetrics,
    BOOL bCreate = TRUE
) const;
Parameters

bValueMetrics
TRUE to retrieve the value metrics
bCreate
TRUE to call GetCaptionMetrics or GetValueMetrics to get metrics

Returns

Pointer to CXTPPropertyGridItemMetrics contained metrics (color, style) of caption part

See Also

CXTPPropertyGridItemMetrics, GetValueMetrics

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetMultiLinesCount Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetMultiLinesCount Method

Call this member to get total item lines

int GetMultiLinesCount() const;
Returns

Total lines count of multi line item

Body Source
int CXTPPropertyGridItem::GetMultiLinesCount() const {
    return m_nLinesCount;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetParentItem Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetParentItem Method

Call this member function to retrieve the parent property grid item.

CXTPPropertyGridItem* GetParentItem() const;
Returns

A CXTPPropertyGridItem pointer that represents the parent item, can be NULL.

Body Source
CXTPPropertyGridItem* CXTPPropertyGridItem::GetParentItem() const {
    return m_pParent;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetReadOnly Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetReadOnly Method

Call this method to get the read-only state of the item.

virtual BOOL GetReadOnly() const;
Returns

TRUE if the item is read only, otherwise returns FALSE.

Body Source
BOOL CXTPPropertyGridItem::GetReadOnly() const{
    return m_bReadOnly;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetTooltip Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetTooltip Method

Call this member to retrieve the item's tooltip

CString GetTooltip() const;
Returns

The ToolTip text for the item.

Body Source
CString CXTPPropertyGridItem::GetTooltip() const {
    return m_strTooltip;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetValue Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetValue Method

Call this method to get the current value of the item.

CString GetValue() const;
Returns

A CString object containing the value of the item.

Body Source
CString CXTPPropertyGridItem::GetValue() const {
    return m_strValue;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetValueMetrics Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::GetValueMetrics Method

Call this method to get metrics of value part

CXTPPropertyGridItemMetrics* GetValueMetrics() const;
Returns

Pointer to CXTPPropertyGridItemMetrics contained metrics (color, style) of value part

See Also

CXTPPropertyGridItemMetrics, GetCaptionMetrics

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetValueRect Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetValueRect Method

Retrieves the bounding rectangle of the item value's text. Override this member function to change it.

virtual CRect GetValueRect();
Returns

A CRect object that represents the bounding rectangle of the item value's text.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::GetViewValue Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::GetViewValue Method

Call this member to retrieve the value of the item that the user is viewing.

virtual CString GetViewValue();
Returns

CString value of the data the user is currently seeing. I.e. If a password mask it used, then the string returned will be filled with asterisks (*). If no password mask is used, it will return the same thing as GetValue.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::HasChilds Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::HasChilds Method

The HasChilds function determines whether or not the item has children.

BOOL HasChilds() const;
Returns

TRUE if the item has children, otherwise returns FALSE.

Body Source
BOOL CXTPPropertyGridItem::HasChilds() const {
    return !m_pChilds->IsEmpty();
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::HasParent Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::HasParent Method

The HasParent function determines whether or not the item has a pParent item as a parent.

BOOL HasParent(
    CXTPPropertyGridItem* pParent
);
Parameters

pParent
Item to be tested.

Returns

TRUE if pParent is a parent of the item.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::HasVisibleChilds Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::HasVisibleChilds Method

The HasChilds function determines whether or not the item has visible children.

BOOL HasVisibleChilds() const;
Returns

TRUE if the item has visible children, otherwise returns FALSE.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::InsertChildItem Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::InsertChildItem Method

Call this method to insert a child item.

CXTPPropertyGridItem* InsertChildItem(
    int nIndex,
    CXTPPropertyGridItem* pItem
);
Parameters

nIndex
Index of item to be added as a child.
pItem
The item to be added as a child.

Returns

A pointer to a CXTPPropertyGridItem object.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsCategory Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::IsCategory Method

The IsCategory function determines whether or not the item is a category.

BOOL IsCategory() const;
Returns

TRUE if the item is a category, otherwise returns FALSE.

Body Source
BOOL CXTPPropertyGridItem::IsCategory() const {
    return m_bCategory;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsExpandable Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::IsExpandable Method

Call this method to check if item can be expanded.

BOOL IsExpandable() const;
Body Source
BOOL CXTPPropertyGridItem::IsExpandable() const {
    return m_bExpandable;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsExpanded Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::IsExpanded Method

Call this member function to determine if the item is expanded.

BOOL IsExpanded() const;
Returns

TRUE if the item is expanded, otherwise returns FALSE.

Body Source
BOOL CXTPPropertyGridItem::IsExpanded() const {
    return m_bExpanded;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsHidden Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::IsHidden Method

Call this member function to determine if the item is hidden.

BOOL IsHidden() const;
Returns

TRUE if the item is hidden, otherwise returns FALSE.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsInplaceButtonsVisible Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::IsInplaceButtonsVisible Method

Determines if in-place buttons are visible for item

virtual BOOL IsInplaceButtonsVisible() const;
See Also

CXTPPropertyGrid::SetShowInplaceButtonsAlways

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsMultiLine Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::IsMultiLine Method

Call this member to determine if item is multi line.

BOOL IsMultiLine() const;
Returns

TRUE if item has more than one view line.

See Also

SetMultiLinesCount

Body Source
BOOL CXTPPropertyGridItem::IsMultiLine() const {
    return m_nLinesCount > 1;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsSelected Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::IsSelected Method

Retrieves if the item is selected.

BOOL IsSelected() const;
Returns

TRUE if the item is selected, FALSE otherwise.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsValueChanged Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::IsValueChanged Method

This member called to determine if value was changed by user.

virtual BOOL IsValueChanged() const;
Returns

TRUE if value was changed

Remarks

Call CXTPPropertyGrid::HighlightChangedItems to highlight all items with changed values

See Also

CXTPPropertyGrid::HighlightChangedItems, ResetValue, SetDefaultValue

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::IsVisible Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::IsVisible Method

Call this member function to determine if the item is visible.

BOOL IsVisible() const;
Returns

TRUE if the item is visible, otherwise returns FALSE.

Body Source
BOOL CXTPPropertyGridItem::IsVisible() const {
    return m_bVisible;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::MeasureItem Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::MeasureItem Method

Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.

virtual void MeasureItem(
    LPMEASUREITEMSTRUCT lpMeasureItemStruct
);
Parameters

lpMeasureItemStruct
Specifies a long pointer to a MEASUREITEMSTRUCT structure.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnAddChildItem Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnAddChildItem Method

This method is called when an item is added to the parent.

virtual void OnAddChildItem();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnAfterEdit Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnAfterEdit Method

This method is called before user apply new value of the item

virtual BOOL OnAfterEdit(
    CString& strValue
);
Parameters

strValue
Value to be set

Returns

TRUE to allow new item value; FALSE to forbid

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnBeforeInsert Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnCancelEdit Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnCancelEdit Method

This method is called if user cancel edit item

virtual void OnCancelEdit();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnChar Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnChar Method

This method is called when a key is pressed.

virtual BOOL OnChar(
    UINT nChar
);
Parameters

nChar
Contains the character code value of the key.

Returns

TRUE if a key is pressed, otherwise returns FALSE.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnConstraintsChanged Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::OnConstraintsChanged Method

This member is called when constraints are added to this item.

virtual void OnConstraintsChanged();
Remarks

OnConstraintsChanged is called when CXTPPropertyGridItemConstraints::AddConstraint is called.

See Also

CXTPPropertyGridItemConstraints::AddConstraint, GetConstraints

Body Source
void CXTPPropertyGridItem::OnConstraintsChanged() {

}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnDeselect Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnDeselect Method

This method is called when an item is de-selected.

virtual void OnDeselect();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnDrawItemConstraint Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnDrawItemConstraint Method

This method is called when an constraint in inplace list is drawn. Override this function if needed.

virtual void OnDrawItemConstraint(
    CDC* pDC,
    CXTPPropertyGridItemConstraint* pConstraint,
    CRect rc,
    BOOL bSelected
);
Parameters

pDC
Reference to the device context to be used for rendering an image of the item.
pConstraint
Constraint to be drawn
rc
Bounding rectangle of the constraint.
bSelected
TRUE if item is selected.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnDrawItemValue Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::OnDrawItemValue Method

This method is called when an item is drawn. Override this function if needed.

virtual BOOL OnDrawItemValue(
    CDC& dc,
    CRect rcValue
);
Parameters

dc
Reference to the device context to be used for rendering an image of the item.
rcValue
Bounding rectangle of the item.

Returns

TRUE if item is self-drawn.

Body Source
BOOL CXTPPropertyGridItem::OnDrawItemValue(CDC&, CRect) {
    return FALSE;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnIndexChanged Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::OnIndexChanged Method

This method is called when index of the item was changed

virtual void OnIndexChanged();
Body Source
void CXTPPropertyGridItem::OnIndexChanged() {

}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnInplaceButtonDown Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnInplaceButtonDown Method

This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.

virtual void OnInplaceButtonDown(
    CXTPPropertyGridInplaceButton* pButton
);
Parameters

pButton
Button that was pressed

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnKeyDown Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::OnKeyDown Method

This method is called when a non-system key is pressed.

virtual BOOL OnKeyDown(
    UINT nChar
);
Parameters

nChar
Specifies the virtual-key code of the given key.

Body Source
BOOL CXTPPropertyGridItem::OnKeyDown (UINT /*nChar*/) {
    return FALSE;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnLButtonDblClk Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnLButtonDblClk Method

This method is called when the user double-clicks the left mouse button.

virtual void OnLButtonDblClk(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down (see Visual C++ documentation).
point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnLButtonDown Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnLButtonDown Method

This method is called when the user presses the left mouse button.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down (see Visual C++ documentation).
point
Specifies the x- and y-coordinate of the cursor.

Returns

TRUE if the message processed, otherwise returns FALSE.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnLButtonUp Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnLButtonUp Method

This method is called when the user release the left mouse button.

virtual void OnLButtonUp(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down (see Visual C++ documentation).
point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnMergeItemConstraint Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnMergeItemConstraint Method

This method is called to get size of constraint in inplace list. Override this function if needed.

virtual CSize OnMergeItemConstraint(
    CDC* pDC,
    CXTPPropertyGridItemConstraint* pConstraint
);
Parameters

pDC
Reference to the device context to be used for rendering an image of the item.
pConstraint
Constraint to be drawn

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnRButtonDown Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::OnRButtonDown Method

This method is called when the user clicks the right mouse button down.

virtual void OnRButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down (see Visual C++ documentation).
point
Specifies the x- and y-coordinate of the cursor.

Body Source
void CXTPPropertyGridItem::OnRButtonDown(UINT, CPoint) {

}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnRequestEdit Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnRequestEdit Method

This method is called before user start edit the item

virtual BOOL OnRequestEdit();
Returns

TRUE to allow edit item; FALSE to forbid

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnSelect Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnSelect Method

This method is called when an item is selected.

virtual void OnSelect();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnValidateEdit Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnValidateEdit Method

This method is called to check value from in-place edit control.

virtual void OnValidateEdit();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::OnValueChanged Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::OnValueChanged Method

This method is called when an item's value is changed. Override this function if needed.

virtual void OnValueChanged(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::PtInValueRect Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::PtInValueRect Method

Determines if point belongs value rectangle

BOOL PtInValueRect(
    CPoint point
);
Parameters

point
Point need to check.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::Remove Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::Remove Method

Removes this item.

void Remove();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::ResetValue Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::ResetValue Method

Call this member to rest value to its default

virtual void ResetValue();
See Also

SetDefaultValue, IsValueChanged

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::Select Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::Select Method

Call this method to select the item.

void Select();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SelectNextConstraint Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::SelectNextConstraint Method

This method is called to switch constraints.

BOOL SelectNextConstraint();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetAutoComplete Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetAutoComplete Method

Call this method to use enable auto complete from constraint list.

void SetAutoComplete(
    BOOL bAutoComplete = TRUE
);
Parameters

bAutoComplete
TRUE to enable auto complete.

Body Source
void CXTPPropertyGridItem::SetAutoComplete(BOOL bAutoComplete) {
    m_bAutoComplete = bAutoComplete;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetCaption Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetCaption Method

Call this method to set the caption of the item.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
The new caption of the item.

See Also

SetPrompt

Body Source
void CXTPPropertyGridItem::SetCaption(LPCTSTR strCaption) {
    if (m_strCaption != strCaption)
    {
        m_strCaption = strCaption;
        OnCaptionChanged();
    }
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetConstraintEdit Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetConstraintEdit Method

Call this method to edit only values from constraint list.

void SetConstraintEdit(
    BOOL bConstraintEdit = TRUE
);
Parameters

bConstraintEdit
TRUE to constraint edit.

Body Source
void CXTPPropertyGridItem::SetConstraintEdit(BOOL bConstraintEdit) {
    m_bConstraintEdit = bConstraintEdit;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetDefaultValue Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetDefaultValue Method

Call this member to set default value of the item

void SetDefaultValue(
    LPCTSTR lpszDefaultValue
);
Parameters

lpszDefaultValue
Value to be set as default.

See Also

ResetValue, IsValueChanged

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetDescription Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetDescription Method

Call this method to set the description of the item. This is the text displayed in the help panel.

void SetDescription(
    LPCTSTR lpszDescription
);
Parameters

lpszDescription
The new description of the item.

See Also

SetPrompt

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetDropDownItemCount Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetDropDownItemCount Method

Call this member to set the count of items in the dropdown list.

void SetDropDownItemCount(
    int nDropDownItemCount
);
Parameters

nDropDownItemCount
The count of items in the dropdown list.

Body Source
void CXTPPropertyGridItem::SetDropDownItemCount(int nDropDownItemCount) {
    m_nDropDownItemCount = nDropDownItemCount;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetEditStyle Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetEditStyle Method

Call this method to set edit styles of the item.

void SetEditStyle(
    DWORD dwEditStyle
);
Parameters

dwEditStyle
New style to be set

Example
pItem->SetEditStyle(ES_MULTILINE | ES_AUTOVSCROLL);
Body Source
void CXTPPropertyGridItem::SetEditStyle(DWORD dwEditStyle) {
    m_dwEditStyle = dwEditStyle;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetEditText Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::SetEditText Method

This method is called to set text of thein-placee edit control.

virtual void SetEditText(
    const CString& str
);
Parameters

str
String value

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetExpandable Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetExpandable Method

Call this method to enable/disable expanding by users

void SetExpandable(
    BOOL bExpandable
);
Parameters

bExpandable
TRUE to allow expand.

Body Source
void CXTPPropertyGridItem::SetExpandable(BOOL bExpandable) {
    m_bExpandable = bExpandable;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetFlags Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetFlags Method

This member function is called to set a specific flag for the item.

void SetFlags(
    UINT nFlags
);
Parameters

nFlags
Flag to set. Can be any of the values listed in the Remarks section.

Remarks

nFlags value can be one or more of the following:

  • xtpGridItemHasEdit Item has edit control.
  • xtpGridItemHasExpandButton Item has expand button.
  • xtpGridItemHasComboButton Item has combo button.
See Also

XTPPropertyGridItemFlags, OnInplaceButtonDown

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetFocusToInplaceControl Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::SetFocusToInplaceControl Method

This method is called to set focus to item in-place control.

virtual void SetFocusToInplaceControl();
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetHeight Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetHeight Method

Call this member to set variable height of the item.

void SetHeight(
    int nHeight
);
Parameters

nHeight
Height of item or -1 to use default value

Remarks

Call CXTPPropertyGrid::SetVariableItemsHeight to use variable height items

See Also

CXTPPropertyGrid::SetVariableItemsHeight, SetMultiLinesCount

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetHidden Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::SetHidden Method

Call this method to hide/unhide item

void SetHidden(
    BOOL bHidden
);
Parameters

bHidden
TRUE to hide item

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetID Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetID Method

Call this method to set the identifier of the item.

void SetID(
    UINT nID
);
Parameters

nID
The new identifier of the item.

Body Source
void CXTPPropertyGridItem::SetID(UINT nID) {
    m_nID = nID;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetItemData Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetItemData Method

This method sets the 32-bit value associated with the item.

void SetItemData(
    DWORD_PTR dwData
);
Parameters

dwData
Contains the new value to associate with the item.

Body Source
void CXTPPropertyGridItem::SetItemData(DWORD_PTR dwData) {
    m_dwData = dwData;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetMask Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetMask Method

Applies the specified Mask to a CXTPPropertyGridItem data field to to create a restrictive field for text entry.

void SetMask(
    LPCTSTR strMask,
    LPCTSTR strLiteral,
    TCHAR chPrompt = _T('_')
);
Parameters

strMask
Mask of the item
strLiteral
Defines the prompt area of the mask where text entry is allowed. This should match the areas that you have already defined as mask fields. By default the prompt character is '_'.

Phone No: (___) ___-____

chPrompt
This value is optional, this is the prompt character used in strLiteral to indicate a place holder. By default this is the underscore '_' character.

Remarks

You can use any of these characters for defining your edit mask:

Mask Character | Description
0 | Numeric (0-9)
9 | Numeric (0-9) or space (' ')
# | Numeric (0-9) or space (' ') or ('+') or ('-')
L | Alpha (a-Z)
? | Alpha (a-Z) or space (' ')
A | Alpha numeric (0-9 and a-Z)
a | Alpha numeric (0-9 and a-Z) or space (' ')
& | All print character only
H | Hex digit (0-9 and A-F)
X | Hex digit (0-9 and A-F) and space (' ')
> | Forces characters to upper case (A-Z)
< | Forces characters to lower case (a-z)

Any of these characters can be combined with additional characters to create a restrictive field for text entry. For example, if you wanted to display a prompt for a telephone number and wanted to restrict only numeric values, but wanted to display the area code inside of parentheses '(' and ')' then you could define your mask as:

Phone No: (000) 000-0000

See Also

GetMaskedText, SetMaskedText

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetMaskedText Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetMaskedText Method

Call this member to set the actual text value for the property grid item without the "edit mask" characters added by the SetMask member.

void SetMaskedText(
    LPCTSTR lpszMaskedText
);
Parameters

lpszMaskedText
Text string without mask.

Remarks

If a mask is used, then the mask will be applied to the text in lpszMaskedText.

See Also

GetMaskedText, SetMask

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetMultiLinesCount Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::SetMultiLinesCount Method

Call this member to set total lines of multi line item

void SetMultiLinesCount(
    int nLinesCount
);
Parameters

nLinesCount
Total lines of multi line item

Remarks

Call CXTPPropertyGrid::SetVariableItemsHeight to use variable height items

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetPasswordMask Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetPasswordMask Method

Call this method to set a password mask for this item. By default, all characters will be replaced by an asterisk (*).

void SetPasswordMask(
    TCHAR chMask = _T('*')
);
Parameters

chMask
Character to use as the password mask.

Remarks

The Value will not contain any asterisk (*) or mask, you can return the actual text with the GetMaskedText member. You can specify which character will be used as the password mask.

Body Source
void CXTPPropertyGridItem::SetPasswordMask(TCHAR chMask) {
    m_bPassword = TRUE;
    m_chPrompt = chMask;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetPrompt Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetPrompt Method

Call this member to load a string from a STRINGTABLE resource to set the caption and description.

void SetPrompt(
    LPCTSTR lpszPrompt
);
Parameters

lpszPrompt
String from resource file that contains the caption and description of the item. Caption and description must be separated by "n" if both are included. You can omit the description and only the caption will be set.

Remarks

Resource strings are in the format "Caption\nDescription".

See Also

SetCaption, SetDescription

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetReadOnly Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::SetReadOnly Method

Call this method to set the read-only state of the item.

void SetReadOnly(
    BOOL bReadOnly = TRUE
);
Parameters

bReadOnly
Specifies whether to set or remove the read-only state of the item. A value of TRUE sets the state to read-only. A value of FALSE sets the state to read/write.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetTooltip Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetTooltip Method

Associates ToolTip text with the item.

void SetTooltip(
    LPCTSTR lpstrTooltip
);
Parameters

lpstrTooltip
The ToolTip text to display when the mouse cursor is over the item.

Body Source
void CXTPPropertyGridItem::SetTooltip(LPCTSTR lpstrTooltip) {
    m_strTooltip = lpstrTooltip;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetValue Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class
CXTPPropertyGridItem::SetValue Method

Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.

virtual void SetValue(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem::SetVisible Method

CXTPPropertyGridItem Methods, CXTPPropertyGridItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::SetVisible Method

This method is called when visibility state of the item was changed.

virtual void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to set the control visible.

Body Source
void CXTPPropertyGridItem::SetVisible(BOOL bVisible) {
    m_bVisible = bVisible;
}
Group

CXTPPropertyGridItem Methods


CXTPPropertyGridItem Constructors

CXTPPropertyGridItem Class, Legend, Public Methods
CXTPPropertyGridItem Constructors
Class

CXTPPropertyGridItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItem |


CXTPPropertyGridItem Constructor

CXTPPropertyGridItem Constructors
CXTPPropertyGridItem Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItem::CXTPPropertyGridItem (LPCTSTR, LPCTSTR, CString*) | Constructs a CXTPPropertyGridItem object
CXTPPropertyGridItem::CXTPPropertyGridItem (UINT, LPCTSTR, CString*) | Constructs a CXTPPropertyGridItem object
Group

CXTPPropertyGridItem Constructors


CXTPPropertyGridItem::CXTPPropertyGridItem Constructor (LPCTSTR, LPCTSTR, CString*)

CXTPPropertyGridItem Constructor, CXTPPropertyGridItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItem::CXTPPropertyGridItem Constructor (LPCTSTR, LPCTSTR, CString*)

Constructs a CXTPPropertyGridItem object

CXTPPropertyGridItem(
    LPCTSTR lpszCaption,
    LPCTSTR strValue = NULL,
    CString* pBindString = NULL
);
CXTPPropertyGridItem(
    UINT nID,
    LPCTSTR strValue = NULL,
    CString* pBindString = NULL
);
Parameters

lpszCaption
Caption of the item.
strValue
Initial value.
pBindString
If not NULL, then the value of this item is bound the value of this variable.
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItem has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToString member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See Also

BindToString

Group

CXTPPropertyGridItem Constructor


CXTPPropertyGridItem Destructors

CXTPPropertyGridItem Class, Legend, Public Methods
CXTPPropertyGridItem Destructors
Class

CXTPPropertyGridItem Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItem | Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation


CXTPPropertyGridItem::~CXTPPropertyGridItem Destructor

CXTPPropertyGridItem Destructors, CXTPPropertyGridItem Class
CXTPPropertyGridItem::~CXTPPropertyGridItem Destructor

Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation

virtual ~CXTPPropertyGridItem();
Group

CXTPPropertyGridItem Destructors


CXTPPropertyGridItemBool Class

XTPPropertyGridItemBool.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemBool Data Members, CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Constructors, CXTPPropertyGridItemBool Destructors, CXTPPropertyGridItemBool Constructors, CXTPPropertyGridItemBool Data Members, CXTPPropertyGridItemBool Destructors, CXTPPropertyGridItemBool Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool Class

CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class. It is used to create a Boolean value item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemBool : public CXTPPropertyGridItem;
File

XTPPropertyGridItemBool.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemBool Constructors
CXTPPropertyGridItemBool Constructors | Description
CXTPPropertyGridItemBool |
CXTPPropertyGridItemBool Data Members
CXTPPropertyGridItemBool Data Members | Description
m_bCheckBoxStyle | Check box style
m_bValue | Value of the item.
m_pBindBool | Binded value.
m_strFalseText | Text of the FALSE label.
m_strTrueText | Text of the TRUE label.
CXTPPropertyGridItemBool Destructors
CXTPPropertyGridItemBool Destructors | Description
~CXTPPropertyGridItemBool | Destroys a CXTPPropertyGridItemBool object.
CXTPPropertyGridItemBool Methods
CXTPPropertyGridItemBool Methods | Description
BindToBool | Call this method to bind the item to a BOOL object.
GetBool | Call this method to get the Boolean value of the item.
GetViewValue | Call this member to retrieve the value of the item that the user is viewing.
IsCheckBoxStyle | Determines is item has check box style.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnDrawItemValue | This method is called when an item is drawn. Override this function if needed.
OnKeyDown | This method is called to check to see if the SpaceBar was pressed and then "check" the item.
OnLButtonDblClk | This method is called when the user double-clicks the left mouse button on the item.
OnLButtonDown | This method is called when the user presses the left mouse button on the item.
PtInCheckBoxRect | Determines if a CPoint is inside the Check Box displayed in the item when the check box style is used.
SetBool | Call this method to change the item's value.
SetCheckBoxStyle | Call this method to draw bool item as check box frame
SetTrueFalseText | Call this method to set the label for true and false values in the drop list. By default these values are set to True and False.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
SetValueText | Call this method to set the label for true or false values in the drop list. This method will search for the value and update it if it exists. If the value is also the current value for the property grid item, that value is updated as well.


CXTPPropertyGridItemBool Data Members

CXTPPropertyGridItemBool Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool Data Members
Class

CXTPPropertyGridItemBool Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bCheckBoxStyle | Check box style
m_bValue | Value of the item.
m_pBindBool | Binded value.
m_strFalseText | Text of the FALSE label.
m_strTrueText | Text of the TRUE label.


CXTPPropertyGridItemBool::m_bCheckBoxStyle Data Member

CXTPPropertyGridItemBool Data Members, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::m_bCheckBoxStyle Data Member

Check box style

BOOL m_bCheckBoxStyle;
Group

CXTPPropertyGridItemBool Data Members


CXTPPropertyGridItemBool::m_bValue Data Member

CXTPPropertyGridItemBool Data Members, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::m_bValue Data Member

Value of the item.

BOOL m_bValue;
Group

CXTPPropertyGridItemBool Data Members


CXTPPropertyGridItemBool::m_pBindBool Data Member

CXTPPropertyGridItemBool Data Members, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::m_pBindBool Data Member

Binded value.

BOOL* m_pBindBool;
Group

CXTPPropertyGridItemBool Data Members


CXTPPropertyGridItemBool::m_strFalseText Data Member

CXTPPropertyGridItemBool Data Members, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::m_strFalseText Data Member

Text of the FALSE label.

CString m_strFalseText;
Group

CXTPPropertyGridItemBool Data Members


CXTPPropertyGridItemBool::m_strTrueText Data Member

CXTPPropertyGridItemBool Data Members, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::m_strTrueText Data Member

Text of the TRUE label.

CString m_strTrueText;
Group

CXTPPropertyGridItemBool Data Members


CXTPPropertyGridItemBool Methods

CXTPPropertyGridItemBool Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool Methods
Class

CXTPPropertyGridItemBool Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetViewValue | Call this member to retrieve the value of the item that the user is viewing.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnDrawItemValue | This method is called when an item is drawn. Override this function if needed.
OnKeyDown | This method is called to check to see if the SpaceBar was pressed and then "check" the item.
OnLButtonDblClk | This method is called when the user double-clicks the left mouse button on the item.
OnLButtonDown | This method is called when the user presses the left mouse button on the item.
PtInCheckBoxRect | Determines if a CPoint is inside the Check Box displayed in the item when the check box style is used.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
SetValueText | Call this method to set the label for true or false values in the drop list. This method will search for the value and update it if it exists. If the value is also the current value for the property grid item, that value is updated as well.
Public Methods
Public Methods
Public Method | Description
BindToBool | Call this method to bind the item to a BOOL object.
GetBool | Call this method to get the Boolean value of the item.
IsCheckBoxStyle | Determines is item has check box style.
SetBool | Call this method to change the item's value.
SetCheckBoxStyle | Call this method to draw bool item as check box frame
SetTrueFalseText | Call this method to set the label for true and false values in the drop list. By default these values are set to True and False.


CXTPPropertyGridItemBool::BindToBool Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::BindToBool Method

Call this method to bind the item to a BOOL object.

virtual void BindToBool(
    BOOL* pBindBool
);
Parameters

pBindBool
BOOL object to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToBool member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::GetBool Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::GetBool Method

Call this method to get the Boolean value of the item.

virtual BOOL GetBool() const;
Returns

TRUE if the items value is TRUE, FALSE is the items value is FALSE.

Body Source
BOOL CXTPPropertyGridItemBool::GetBool() const {
    return m_bValue;
}
Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::GetViewValue Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::GetViewValue Method

Call this member to retrieve the value of the item that the user is viewing.

virtual CString GetViewValue();
Returns

CString value of the data the user is currently seeing. I.e. If a password mask it used, then the string returned will be filled with asterisks (*). If no password mask is used, it will return the same thing as GetValue.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::IsCheckBoxStyle Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::IsCheckBoxStyle Method

Determines is item has check box style.

BOOL IsCheckBoxStyle() const;
Returns

TRUE if item drawn as check box frame.

See Also

SetCheckBoxStyle

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::OnBeforeInsert Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::OnDrawItemValue Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::OnDrawItemValue Method

This method is called when an item is drawn. Override this function if needed.

virtual BOOL OnDrawItemValue(
    CDC& dc,
    CRect rcValue
);
Parameters

dc
Reference to the device context to be used for rendering an image of the item.
rcValue
Bounding rectangle of the item.

Returns

TRUE if item is self-drawn.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::OnKeyDown Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::OnKeyDown Method

This method is called to check to see if the SpaceBar was pressed and then "check" the item.

virtual BOOL OnKeyDown(
    UINT nChar
);
Parameters

nChar
Specifies the virtual-key code of the given key.

Returns

TRUE if the item has a checkbox style, is not read only, and the user pressed the SpaceBar key. FALSE if any other key is pressed.

Remarks

Checks to see if the item has a checkbox style, is not read only, and the user pressed the SpaceBar key, if all is True, then the checkbox will be checkedun-checked.

See Also

PtInCheckBoxRect

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::OnLButtonDblClk Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::OnLButtonDblClk Method

This method is called when the user double-clicks the left mouse button on the item.

virtual void OnLButtonDblClk(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down (see Visual C++ documentation).
point
Specifies the x- and y-coordinate of the cursor.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::OnLButtonDown Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::OnLButtonDown Method

This method is called when the user presses the left mouse button on the item.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down (see Visual C++ documentation).
point
Specifies the x- and y-coordinate of the cursor.

Returns

TRUE if the message processed, otherwise returns FALSE.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::PtInCheckBoxRect Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::PtInCheckBoxRect Method

Determines if a CPoint is inside the Check Box displayed in the item when the check box style is used.

BOOL PtInCheckBoxRect(
    CPoint point
);
Parameters

point
CPoint to text to see if it is inside the check box.

Returns

TRUE if the CPoint is inside the check box, FALSE if the point is not inside the check box.

See Also

OnKeyDown

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::SetBool Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::SetBool Method

Call this method to change the item's value.

virtual void SetBool(
    BOOL bValue
);
Parameters

bValue
The new BOOL value of the item.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::SetCheckBoxStyle Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::SetCheckBoxStyle Method

Call this method to draw bool item as check box frame

void SetCheckBoxStyle(
    BOOL bCheckBoxStyle = TRUE
);
Parameters

bCheckBoxStyle
TRUE to draw item as check box

See Also

IsCheckBoxStyle

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::SetTrueFalseText Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::SetTrueFalseText Method

Call this method to set the label for true and false values in the drop list. By default these values are set to True and False.

BOOL SetTrueFalseText(
    LPCTSTR strTrueText,
    LPCTSTR strFalseText
);
Parameters

strTrueText
NULL terminated string that represents the True label.
strFalseText
NULL terminated string that represents the False label.

Returns

True if successful, otherwise returns false.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::SetValue Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::SetValue Method

Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.

virtual void SetValue(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool::SetValueText Method

CXTPPropertyGridItemBool Methods, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::SetValueText Method

Call this method to set the label for true or false values in the drop list. This method will search for the value and update it if it exists. If the value is also the current value for the property grid item, that value is updated as well.

BOOL SetValueText(
    CString& strValueText,
    LPCTSTR strNewText
);
Parameters

strValueText
NULL terminated string that represents the value label.
strNewText
NULL terminated string that represents the new value label.

Returns

True if successful, otherwise returns false.

Group

CXTPPropertyGridItemBool Methods


CXTPPropertyGridItemBool Constructors

CXTPPropertyGridItemBool Class, Legend, Public Methods
CXTPPropertyGridItemBool Constructors
Class

CXTPPropertyGridItemBool Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemBool |


CXTPPropertyGridItemBool Constructor

CXTPPropertyGridItemBool Constructors
CXTPPropertyGridItemBool Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemBool::CXTPPropertyGridItemBool (LPCTSTR, BOOL, BOOL*) | Constructs a CXTPPropertyGridItemBool object.
CXTPPropertyGridItemBool::CXTPPropertyGridItemBool (UINT, BOOL, BOOL*) | Constructs a CXTPPropertyGridItemBool object.
Group

CXTPPropertyGridItemBool Constructors


CXTPPropertyGridItemBool::CXTPPropertyGridItemBool Constructor (LPCTSTR, BOOL, BOOL*)

CXTPPropertyGridItemBool Constructor, CXTPPropertyGridItemBool Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::CXTPPropertyGridItemBool Constructor (LPCTSTR, BOOL, BOOL*)

Constructs a CXTPPropertyGridItemBool object.

CXTPPropertyGridItemBool(
    LPCTSTR strCaption,
    BOOL bValue = FALSE,
    BOOL* pBindBool = NULL
);
CXTPPropertyGridItemBool(
    UINT nID,
    BOOL bValue = FALSE,
    BOOL* pBindBool = NULL
);
Parameters

strCaption
Caption of the item.
bValue
Initial value of item.
pBindBool
If not NULL, then the value of this item
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItemBool has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToBool member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See Also

BindToBool

Group

CXTPPropertyGridItemBool Constructor


CXTPPropertyGridItemBool Destructors

CXTPPropertyGridItemBool Class, Legend, Public Methods
CXTPPropertyGridItemBool Destructors
Class

CXTPPropertyGridItemBool Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItemBool | Destroys a CXTPPropertyGridItemBool object.


CXTPPropertyGridItemBool::~CXTPPropertyGridItemBool Destructor

CXTPPropertyGridItemBool Destructors, CXTPPropertyGridItemBool Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemBool::~CXTPPropertyGridItemBool Destructor

Destroys a CXTPPropertyGridItemBool object.

virtual ~CXTPPropertyGridItemBool();
Group

CXTPPropertyGridItemBool Destructors


CXTPPropertyGridItemCategory Class

XTPPropertyGridItem.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemCategory Constructors, CXTPPropertyGridItemCategory Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemCategory Class

CXTPPropertyGridItemCategory is the CXTPPropertyGridItem derived class. Use it to add subcategory to property grid control.

Class Hierarchy

class CXTPPropertyGridItemCategory : public CXTPPropertyGridItem;
File

XTPPropertyGridItem.h

Notes

Parent item for category must be also the category.

Group

Classes

Legend
Constructor
CXTPPropertyGridItemCategory Constructors
CXTPPropertyGridItemCategory Constructors | Description
CXTPPropertyGridItemCategory |


CXTPPropertyGridItemCategory Constructors

CXTPPropertyGridItemCategory Class, Legend, Public Methods
CXTPPropertyGridItemCategory Constructors
Class

CXTPPropertyGridItemCategory Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemCategory |


CXTPPropertyGridItemCategory Constructor

CXTPPropertyGridItemCategory Constructors
CXTPPropertyGridItemCategory Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemCategory::CXTPPropertyGridItemCategory (LPCTSTR) | Constructs a CXTPPropertyGridItemCategory object
CXTPPropertyGridItemCategory::CXTPPropertyGridItemCategory (UINT) | Constructs a CXTPPropertyGridItemCategory object
Group

CXTPPropertyGridItemCategory Constructors


CXTPPropertyGridItemCategory::CXTPPropertyGridItemCategory Constructor (LPCTSTR)

CXTPPropertyGridItemCategory Constructor, CXTPPropertyGridItemCategory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemCategory::CXTPPropertyGridItemCategory Constructor (LPCTSTR)

Constructs a CXTPPropertyGridItemCategory object

CXTPPropertyGridItemCategory(
    LPCTSTR strCaption
);
CXTPPropertyGridItemCategory(
    UINT nID
);
Parameters

strCaption
Caption of the item.
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItemCategory has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

Group

CXTPPropertyGridItemCategory Constructor


CXTPPropertyGridItemColor Class

XTPPropertyGridItemColor.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemColor Data Members, CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Constructors, CXTPPropertyGridItemColor Destructors, CXTPPropertyGridItemColor Constructors, CXTPPropertyGridItemColor Data Members, CXTPPropertyGridItemColor Destructors, CXTPPropertyGridItemColor Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor Class

CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class. It is used to create an RGB value item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemColor : public CXTPPropertyGridItem;
File

XTPPropertyGridItemColor.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemColor Constructors
CXTPPropertyGridItemColor Constructors | Description
CXTPPropertyGridItemColor |
CXTPPropertyGridItemColor Data Members
CXTPPropertyGridItemColor Data Members | Description
m_clrValue | Color value of the item.
m_colorEditor | Editor type of color item
m_pBindColor | Pointer to variable bound to this item, this is the color of the bound item.
CXTPPropertyGridItemColor Destructors
CXTPPropertyGridItemColor Destructors | Description
~CXTPPropertyGridItemColor | Destroys a CXTPPropertyGridItemColor object
CXTPPropertyGridItemColor Methods
CXTPPropertyGridItemColor Methods | Description
BindToColor | Call this method to bind an item to a COLORREF object.
GetColor | Call this method to get the RGB value of the item.
GetEditorStyle | Determines editor type for color item
GetValueRect | Retrieves the bounding rectangle of the item value's text. Override this member function to change it.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnDrawItemValue | This method is called when an item is drawn. Override this function if needed.
OnInplaceButtonDown | This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.
RGBToString | The RGBToString function converts a COLORREF to a string.
SetColor | Call this method to change the item's value.
SetEditorStyle | Call this method to set editor type for color item
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
StringToRGB | The StringToRGB function converts a string to a COLORREF.


CXTPPropertyGridItemColor Data Members

CXTPPropertyGridItemColor Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor Data Members
Class

CXTPPropertyGridItemColor Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrValue | Color value of the item.
m_colorEditor | Editor type of color item
m_pBindColor | Pointer to variable bound to this item, this is the color of the bound item.


CXTPPropertyGridItemColor::m_clrValue Data Member

CXTPPropertyGridItemColor Data Members, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::m_clrValue Data Member

Color value of the item.

COLORREF m_clrValue;
Group

CXTPPropertyGridItemColor Data Members


CXTPPropertyGridItemColor::m_colorEditor Data Member

CXTPPropertyGridItemColor Data Members, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::m_colorEditor Data Member

Editor type of color item

XTPPropertyGridItemColorEditor m_colorEditor;
Group

CXTPPropertyGridItemColor Data Members


CXTPPropertyGridItemColor::m_pBindColor Data Member

CXTPPropertyGridItemColor Data Members, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::m_pBindColor Data Member

Pointer to variable bound to this item, this is the color of the bound item.

COLORREF* m_pBindColor;
Group

CXTPPropertyGridItemColor Data Members


CXTPPropertyGridItemColor Methods

CXTPPropertyGridItemColor Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor Methods
Class

CXTPPropertyGridItemColor Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetValueRect | Retrieves the bounding rectangle of the item value's text. Override this member function to change it.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnDrawItemValue | This method is called when an item is drawn. Override this function if needed.
OnInplaceButtonDown | This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
Public Methods
Public Methods
Public Method | Description
BindToColor | Call this method to bind an item to a COLORREF object.
GetColor | Call this method to get the RGB value of the item.
GetEditorStyle | Determines editor type for color item
RGBToString | The RGBToString function converts a COLORREF to a string.
SetColor | Call this method to change the item's value.
SetEditorStyle | Call this method to set editor type for color item
StringToRGB | The StringToRGB function converts a string to a COLORREF.


CXTPPropertyGridItemColor::BindToColor Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::BindToColor Method

Call this method to bind an item to a COLORREF object.

virtual void BindToColor(
    COLORREF* pBindColor
);
Parameters

pBindColor
COLORREF object to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToColor member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::GetColor Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::GetColor Method

Call this method to get the RGB value of the item.

virtual COLORREF GetColor() const;
Returns

An RGB value.

Body Source
COLORREF CXTPPropertyGridItemColor::GetColor() const {
    return m_clrValue;
}
Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::GetEditorStyle Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::GetEditorStyle Method

Determines editor type for color item

XTPPropertyGridItemColorEditor GetEditorStyle();
Returns

XTPPropertyGridItemColorEditor editor type

See Also

SetEditorStyle, XTPPropertyGridItemColorEditor

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::GetValueRect Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::GetValueRect Method

Retrieves the bounding rectangle of the item value's text. Override this member function to change it.

virtual CRect GetValueRect();
Returns

A CRect object that represents the bounding rectangle of the item value's text.

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::OnBeforeInsert Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::OnDrawItemValue Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::OnDrawItemValue Method

This method is called when an item is drawn. Override this function if needed.

virtual BOOL OnDrawItemValue(
    CDC& dc,
    CRect rcValue
);
Parameters

dc
Reference to the device context to be used for rendering an image of the item.
rcValue
Bounding rectangle of the item.

Returns

TRUE if the item is self-drawn.

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::OnInplaceButtonDown Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::OnInplaceButtonDown Method

This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.

virtual void OnInplaceButtonDown(
    CXTPPropertyGridInplaceButton* pButton
);
Parameters

pButton
Button that was pressed

Remarks

The in-place button is the button that the user presses to display the color picker dialog.

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::RGBToString Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::RGBToString Method

The RGBToString function converts a COLORREF to a string.

static CString RGBToString(
    COLORREF clr
);
Parameters

clr
COLORREF that is converted to a string.

Returns

Returns a string in the format RRR;GGG;BBB

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::SetColor Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::SetColor Method

Call this method to change the item's value.

virtual void SetColor(
    COLORREF clr
);
Parameters

clr
The new RGB value of the item.

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::SetEditorStyle Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::SetEditorStyle Method

Call this method to set editor type for color item

void SetEditorStyle(
    XTPPropertyGridItemColorEditor editor
);
Parameters

editor
Editor type to set. It can be one of the following:

  • xtpGridItemColorPopup - Color popup editor
  • xtpGridItemColorStandardDialog - Standard color dialog editor
  • xtpGridItemColorExtendedDialog - Extended color Editor editor

See Also

GetEditorStyle, XTPPropertyGridItemColorEditor

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::SetValue Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::SetValue Method

Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.

virtual void SetValue(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor::StringToRGB Method

CXTPPropertyGridItemColor Methods, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::StringToRGB Method

The StringToRGB function converts a string to a COLORREF.

static COLORREF StringToRGB(
    LPCTSTR str
);
Parameters

str
String that is converted to a COLORREF. Format of string is RRR;GGG;BBB

Returns

An COLORREF RGB value.

Group

CXTPPropertyGridItemColor Methods


CXTPPropertyGridItemColor Constructors

CXTPPropertyGridItemColor Class, Legend, Public Methods
CXTPPropertyGridItemColor Constructors
Class

CXTPPropertyGridItemColor Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemColor |


CXTPPropertyGridItemColor Constructor

CXTPPropertyGridItemColor Constructors
CXTPPropertyGridItemColor Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemColor::CXTPPropertyGridItemColor (LPCTSTR, COLORREF, COLORREF*) | Constructs a CXTPPropertyGridItemColor object.
CXTPPropertyGridItemColor::CXTPPropertyGridItemColor (UINT, COLORREF, COLORREF*) | Constructs a CXTPPropertyGridItemColor object.
Group

CXTPPropertyGridItemColor Constructors


CXTPPropertyGridItemColor::CXTPPropertyGridItemColor Constructor (LPCTSTR, COLORREF, COLORREF*)

CXTPPropertyGridItemColor Constructor, CXTPPropertyGridItemColor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::CXTPPropertyGridItemColor Constructor (LPCTSTR, COLORREF, COLORREF*)

Constructs a CXTPPropertyGridItemColor object.

CXTPPropertyGridItemColor(
    LPCTSTR strCaption,
    COLORREF clr = 0,
    COLORREF* pBindColor = NULL
);
CXTPPropertyGridItemColor(
    UINT nID,
    COLORREF clr = 0,
    COLORREF* pBindColor = NULL
);
Parameters

strCaption
Caption of the item.
clr
Initial color value for this item.
pBindColor
If not NULL, then the value of this item is bound the value of this variable.
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItemColor has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToColor member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See Also

BindToColor

Group

CXTPPropertyGridItemColor Constructor


CXTPPropertyGridItemColor Destructors

CXTPPropertyGridItemColor Class, Legend, Public Methods
CXTPPropertyGridItemColor Destructors
Class

CXTPPropertyGridItemColor Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItemColor | Destroys a CXTPPropertyGridItemColor object


CXTPPropertyGridItemColor::~CXTPPropertyGridItemColor Destructor

CXTPPropertyGridItemColor Destructors, CXTPPropertyGridItemColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemColor::~CXTPPropertyGridItemColor Destructor

Destroys a CXTPPropertyGridItemColor object

virtual ~CXTPPropertyGridItemColor();
Group

CXTPPropertyGridItemColor Destructors


CXTPPropertyGridItemConstraint Class

XTPPropertyGridItem.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemConstraint Data Members, CXTPPropertyGridItemConstraint Methods, CXTPPropertyGridItemConstraint Constructors, CXTPPropertyGridItemConstraint Constructors, CXTPPropertyGridItemConstraint Data Members, CXTPPropertyGridItemConstraint Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint Class

CXTPPropertyGridItemConstraint is a CCmdTarget derived class. It represents a single item constraints.

Class Hierarchy

class CXTPPropertyGridItemConstraint;
File

XTPPropertyGridItem.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemConstraint Constructors
CXTPPropertyGridItemConstraint Constructors | Description
CXTPPropertyGridItemConstraint | Constructs a CXTPPropertyGridItemConstraint object.
CXTPPropertyGridItemConstraint Data Members
CXTPPropertyGridItemConstraint Data Members | Description
m_dwData | The 32-bit value associated with the item.
m_nImage | Image index
m_nIndex | Index of constraint.
m_pItem | Parent item
m_strConstraint | Caption text of constraint.
CXTPPropertyGridItemConstraint Methods
CXTPPropertyGridItemConstraint Methods | Description
GetImage | Retrieves the image of the constraint so it can be used outside of Codejock components.
GetIndex | Call this member to retrieve the index of this constraint within the collection of constraints.


CXTPPropertyGridItemConstraint Data Members

CXTPPropertyGridItemConstraint Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint Data Members
Class

CXTPPropertyGridItemConstraint Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nIndex | Index of constraint.
m_pItem | Parent item
Public Data Members
Public Data Member | Description
m_dwData | The 32-bit value associated with the item.
m_nImage | Image index
m_strConstraint | Caption text of constraint.


CXTPPropertyGridItemConstraint::m_dwData Data Member

CXTPPropertyGridItemConstraint Data Members, CXTPPropertyGridItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint::m_dwData Data Member

The 32-bit value associated with the item.

DWORD_PTR m_dwData;
Group

CXTPPropertyGridItemConstraint Data Members


CXTPPropertyGridItemConstraint::m_nImage Data Member

CXTPPropertyGridItemConstraint Data Members, CXTPPropertyGridItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint::m_nImage Data Member

Image index

int m_nImage;
Group

CXTPPropertyGridItemConstraint Data Members


CXTPPropertyGridItemConstraint::m_nIndex Data Member

CXTPPropertyGridItemConstraint Data Members, CXTPPropertyGridItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint::m_nIndex Data Member

Index of constraint.

int m_nIndex;
Group

CXTPPropertyGridItemConstraint Data Members


CXTPPropertyGridItemConstraint::m_pItem Data Member

CXTPPropertyGridItemConstraint Data Members, CXTPPropertyGridItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint::m_pItem Data Member

Parent item

CXTPPropertyGridItem* m_pItem;
Group

CXTPPropertyGridItemConstraint Data Members


CXTPPropertyGridItemConstraint::m_strConstraint Data Member

CXTPPropertyGridItemConstraint Data Members, CXTPPropertyGridItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint::m_strConstraint Data Member

Caption text of constraint.

CString m_strConstraint;
Group

CXTPPropertyGridItemConstraint Data Members


CXTPPropertyGridItemConstraint Methods

CXTPPropertyGridItemConstraint Class, Legend, Public Methods
CXTPPropertyGridItemConstraint Methods
Class

CXTPPropertyGridItemConstraint Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetImage | Retrieves the image of the constraint so it can be used outside of Codejock components.
GetIndex | Call this member to retrieve the index of this constraint within the collection of constraints.


CXTPPropertyGridItemConstraint::GetImage Method

CXTPPropertyGridItemConstraint Methods, CXTPPropertyGridItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint::GetImage Method

Retrieves the image of the constraint so it can be used outside of Codejock components.

virtual CXTPImageManagerIcon* GetImage() const;
Returns

CXTPImageManagerIcon object containing the image of the constraint.

Group

CXTPPropertyGridItemConstraint Methods


CXTPPropertyGridItemConstraint::GetIndex Method

CXTPPropertyGridItemConstraint Methods, CXTPPropertyGridItemConstraint Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint::GetIndex Method

Call this member to retrieve the index of this constraint within the collection of constraints.

virtual int GetIndex() const;
Returns

Index of this constraint.

Body Source
int CXTPPropertyGridItemConstraint::GetIndex() const {
    return m_nIndex;
}
Group

CXTPPropertyGridItemConstraint Methods


CXTPPropertyGridItemConstraint Constructors

CXTPPropertyGridItemConstraint Class, Legend, Public Methods
CXTPPropertyGridItemConstraint Constructors
Class

CXTPPropertyGridItemConstraint Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemConstraint | Constructs a CXTPPropertyGridItemConstraint object.


CXTPPropertyGridItemConstraint::CXTPPropertyGridItemConstraint Constructor

CXTPPropertyGridItemConstraint Constructors, CXTPPropertyGridItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraint::CXTPPropertyGridItemConstraint Constructor

Constructs a CXTPPropertyGridItemConstraint object.

CXTPPropertyGridItemConstraint();
Group

CXTPPropertyGridItemConstraint Constructors


CXTPPropertyGridItemConstraints Class

XTPPropertyGridItem.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Constructors, CXTPPropertyGridItemConstraints Destructors, CXTPPropertyGridItemConstraints Constructors, CXTPPropertyGridItemConstraints Destructors, CXTPPropertyGridItemConstraints Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints Class

CXTPPropertyGridItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.

Class Hierarchy

class CXTPPropertyGridItemConstraints;
File

XTPPropertyGridItem.h

Remarks

Each PropertyGridItem has it's own collection of constraints. CXTPPropertyGridItem::GetConstraints allows to access the constraints of a given item. If a combo button is added to the property grid item, all the constraints in the item's constraint collection will be displayed in the drop-down list. The AddConstraint method is used to add constraints to the collection.

See Also

CXTPPropertyGridItem::GetConstraints, CXTPPropertyGridItem::SetConstraintEdit, AddConstraint

Group

Classes

Legend
Method
virtual
protected
CXTPPropertyGridItemConstraints Constructors
CXTPPropertyGridItemConstraints Constructors | Description
CXTPPropertyGridItemConstraints | Constructs a CXTPPropertyGridItemConstraints object.
CXTPPropertyGridItemConstraints Destructors
CXTPPropertyGridItemConstraints Destructors | Description
~CXTPPropertyGridItemConstraints | Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation
CXTPPropertyGridItemConstraints Methods
CXTPPropertyGridItemConstraints Methods | Description
AddConstraint | Call this member function to add a new item constraint.
FindConstraint |
GetAt | Call this member to get a constraint by its index.
GetConstraintAt | Call this member to get a constraint by its index.
GetCount | Call this member to retrieve the total number of constraints in the collection.
GetCurrent | Call this member function to get the current constraint.
IsEmpty | Call this member to determine if the list of constraints is empty.
RemoveAll | Removes all the constraints from the collection.
RemoveAt | Call this member to remove a constraint by its index.
SetCurrent | This method sets the current constraint.
Sort | Call this member to sort constraints alphabetically.


CXTPPropertyGridItemConstraints Methods

CXTPPropertyGridItemConstraints Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints Methods
Class

CXTPPropertyGridItemConstraints Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AddConstraint | Call this member function to add a new item constraint.
FindConstraint |
GetAt | Call this member to get a constraint by its index.
GetConstraintAt | Call this member to get a constraint by its index.
GetCount | Call this member to retrieve the total number of constraints in the collection.
GetCurrent | Call this member function to get the current constraint.
IsEmpty | Call this member to determine if the list of constraints is empty.
RemoveAll | Removes all the constraints from the collection.
RemoveAt | Call this member to remove a constraint by its index.
SetCurrent | This method sets the current constraint.
Sort | Call this member to sort constraints alphabetically.


CXTPPropertyGridItemConstraints::AddConstraint Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::AddConstraint Method

Call this member function to add a new item constraint.

virtual CXTPPropertyGridItemConstraint* AddConstraint(
    LPCTSTR str,
    DWORD_PTR dwData = 0,
    int nImage = -1
);
Parameters

str
New constraint.
dwData
Data associated with the constraint.
nImage
Image of constraint

Returns

A pointer to the newly added constraint.

See Also

CXTPPropertyGridItem::OnConstraintsChanged

Group

CXTPPropertyGridItemConstraints Methods


FindConstraint Method

CXTPPropertyGridItemConstraints Methods
FindConstraint Method
Overload List
Methods
Method | Description
CXTPPropertyGridItemConstraints::FindConstraint (DWORD_PTR) | Call this member function to find a constraint in the list.
CXTPPropertyGridItemConstraints::FindConstraint (LPCTSTR) | Call this member function to find a constraint in the list.
Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::FindConstraint Method (LPCTSTR)

FindConstraint Method, CXTPPropertyGridItemConstraints Class
CXTPPropertyGridItemConstraints::FindConstraint Method (LPCTSTR)

Call this member function to find a constraint in the list.

int FindConstraint(
    LPCTSTR str
) const;
int FindConstraint(
    DWORD_PTR dwData
) const;
Parameters

str
A constraint to search for.
dwData
A constraint to search for.

Returns

The zero-based index of the located constraint or -1 if the constraint is not found.

Group

FindConstraint Method


CXTPPropertyGridItemConstraints::GetAt Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::GetAt Method

Call this member to get a constraint by its index.

CString GetAt(
    int nIndex
) const;
Parameters

nIndex
Index of a constraint.

Returns

Caption of constraint if found, otherwise it will return "".

Remarks

This will only return the caption text of a constraint, to return the entire constraint, use GetConstraintAt.

See Also

GetConstraintAt

Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::GetConstraintAt Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::GetConstraintAt Method

Call this member to get a constraint by its index.

CXTPPropertyGridItemConstraint* GetConstraintAt(
    int nIndex
) const;
Parameters

nIndex
Index of a constraint.

Returns

Pointer to CXTPPropertyGridItemConstraint object.

Remarks

This will only the entire constraint object, to return only the caption text of a constraint, use GetAt.

See Also

GetAt

Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::GetCount Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::GetCount Method

Call this member to retrieve the total number of constraints in the collection.

int GetCount() const;
Body Source
int CXTPPropertyGridItemConstraints::GetCount() const {
    return (int)m_arrConstraints.GetSize();
}
Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::GetCurrent Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::GetCurrent Method

Call this member function to get the current constraint.

int GetCurrent() const;
Returns

The index of the current constraint.

Body Source
int CXTPPropertyGridItemConstraints::GetCurrent() const {
    return m_nCurrent;
}
Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::IsEmpty Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::IsEmpty Method

Call this member to determine if the list of constraints is empty.

BOOL IsEmpty() const;
Returns

TRUE if there are no constraints in the collection, FALSE is at least 1 constraint is in the collection.

Body Source
BOOL CXTPPropertyGridItemConstraints::IsEmpty() const {
    return GetCount() == 0;
}
Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::RemoveAll Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::RemoveAll Method

Removes all the constraints from the collection.

void RemoveAll();
See Also

RemoveAt

Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::RemoveAt Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::RemoveAt Method

Call this member to remove a constraint by its index.

void RemoveAt(
    int nIndex
);
Parameters

nIndex
Index of a constraint.

See Also

RemoveAll

Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::SetCurrent Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::SetCurrent Method

This method sets the current constraint.

void SetCurrent(
    int nIndex
);
Parameters

nIndex
Index of the needed constraint.

Body Source
void CXTPPropertyGridItemConstraints::SetCurrent(int nIndex){
    m_nCurrent = nIndex;
}
Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints::Sort Method

CXTPPropertyGridItemConstraints Methods, CXTPPropertyGridItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::Sort Method

Call this member to sort constraints alphabetically.

virtual void Sort();
Group

CXTPPropertyGridItemConstraints Methods


CXTPPropertyGridItemConstraints Constructors

CXTPPropertyGridItemConstraints Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints Constructors
Class

CXTPPropertyGridItemConstraints Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPPropertyGridItemConstraints | Constructs a CXTPPropertyGridItemConstraints object.


CXTPPropertyGridItemConstraints::CXTPPropertyGridItemConstraints Constructor

CXTPPropertyGridItemConstraints Constructors, CXTPPropertyGridItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::CXTPPropertyGridItemConstraints Constructor

Constructs a CXTPPropertyGridItemConstraints object.

CXTPPropertyGridItemConstraints(
    CXTPPropertyGridItem* pItem
);
Parameters

pItem
Pointer to the CXTPPropertyGridItem that the constraints are added to.

Group

CXTPPropertyGridItemConstraints Constructors


CXTPPropertyGridItemConstraints Destructors

CXTPPropertyGridItemConstraints Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints Destructors
Class

CXTPPropertyGridItemConstraints Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPPropertyGridItemConstraints | Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation


CXTPPropertyGridItemConstraints::~CXTPPropertyGridItemConstraints Destructor

CXTPPropertyGridItemConstraints Destructors, CXTPPropertyGridItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemConstraints::~CXTPPropertyGridItemConstraints Destructor

Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation

~CXTPPropertyGridItemConstraints();
Group

CXTPPropertyGridItemConstraints Destructors


CXTPPropertyGridItemDate Class

XTPPropertyGridItemExt.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemDate Data Members, CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Constructors, CXTPPropertyGridItemDate Constructors, CXTPPropertyGridItemDate Data Members, Example, CXTPPropertyGridItemDate Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate Class

CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class. It is used to create Date item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemDate : public CXTPPropertyGridItem;
File

XTPPropertyGridItemExt.h

Remarks

When the in-place button for a date item is pressed, a CXTPPropertyGridInplaceMonthCal object is created, which is a User Interface that allows the user to easily select a date.

See Also

SetDate, GetMonth, GetDay, GetYear, SetDateFormat

Example

This sample illustrates how to add an item of type Date to your grid.

CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Appointments"));

//Create a Date object with the date 12/26/2004.  Note that no time information is entered
//because this information is ignored.
COleDateTime dates(2004, 12, 26, 0, 0, 0);

//Adds a date item to the property grid and set the date to the value stored in dates
CXTPPropertyGridItemDate* pDate = (CXTPPropertyGridItemDate*)(pStandard->AddChildItem(new CXTPPropertyGridItemDate(_T("Date item"), dates)));

//Set the date format to MM/DD/YYYY
pDate->SetDateFormat("%m/%d/%Y");

//Changes the date to 3/22/2001
COleDateTime newDate(2003, 5, 12, 0, 0, 0);

//Changes the date of the Date item.
pDate->SetDate(newDate);

//Gets the currently set date
TRACE(_T("Current Date= %d/%d/%dn"), pDate->GetMonth(), pDate->GetDay(), pDate->GetYear());
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemDate Constructors
CXTPPropertyGridItemDate Constructors | Description
CXTPPropertyGridItemDate |
CXTPPropertyGridItemDate Data Members
CXTPPropertyGridItemDate Data Members | Description
m_oleDate | Currently selected date.
m_pBindDate | Pointer to variable bound to this item, this is the date of the bound item.
m_strNullValue | String value to be displayed for a Date Item when the current date is NULL.
CXTPPropertyGridItemDate Methods
CXTPPropertyGridItemDate Methods | Description
AllowNullDate | Call this member to allow null date
BindToDate | Call this method to bind an item to a COleDateTime object.
Format | This method creates a formatted representation of the date/time value
GetAsSystemTime | Call this member function to convert the time in the COleDateTime object to be represented as a SYSTEMTIME data structure. GetAsSystemTime stores the resulting time in the referenced sysTime object. The SYSTEMTIME data structure initialized by this function will have its wMilliseconds member set to zero.
GetDate | Call this member to return the currently selected date.
GetDay | Call this member to get the Day of the currently selected date.
GetMonth | Call this member to get the Month of the currently selected date.
GetYear | Call this member to get the Year of the currently selected date.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnInplaceButtonDown | This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.
ParseDateTime | This member is called to parse the month, day, and year from the COleDateTime object.
SetDate | Call this member to set the date of the item.
SetDateFormat | Call this member to change the date format.
SetDay | Call this member to set the Day of the date.
SetMonth | Call this member to set the Month of the date.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
SetYear | Call this member to set the Year of the date.


CXTPPropertyGridItemDate Data Members

CXTPPropertyGridItemDate Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate Data Members
Class

CXTPPropertyGridItemDate Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_oleDate | Currently selected date.
m_pBindDate | Pointer to variable bound to this item, this is the date of the bound item.
m_strNullValue | String value to be displayed for a Date Item when the current date is NULL.


CXTPPropertyGridItemDate::m_oleDate Data Member

CXTPPropertyGridItemDate Data Members, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::m_oleDate Data Member

Currently selected date.

COleDateTime m_oleDate;
Group

CXTPPropertyGridItemDate Data Members


CXTPPropertyGridItemDate::m_pBindDate Data Member

CXTPPropertyGridItemDate Data Members, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::m_pBindDate Data Member

Pointer to variable bound to this item, this is the date of the bound item.

COleDateTime* m_pBindDate;
Group

CXTPPropertyGridItemDate Data Members


CXTPPropertyGridItemDate::m_strNullValue Data Member

CXTPPropertyGridItemDate Data Members, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::m_strNullValue Data Member

String value to be displayed for a Date Item when the current date is NULL.

CString m_strNullValue;
Group

CXTPPropertyGridItemDate Data Members


CXTPPropertyGridItemDate Methods

CXTPPropertyGridItemDate Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate Methods
Class

CXTPPropertyGridItemDate Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Format | This method creates a formatted representation of the date/time value
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnInplaceButtonDown | This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
Public Methods
Public Methods
Public Method | Description
AllowNullDate | Call this member to allow null date
BindToDate | Call this method to bind an item to a COleDateTime object.
GetAsSystemTime | Call this member function to convert the time in the COleDateTime object to be represented as a SYSTEMTIME data structure. GetAsSystemTime stores the resulting time in the referenced sysTime object. The SYSTEMTIME data structure initialized by this function will have its wMilliseconds member set to zero.
GetDate | Call this member to return the currently selected date.
GetDay | Call this member to get the Day of the currently selected date.
GetMonth | Call this member to get the Month of the currently selected date.
GetYear | Call this member to get the Year of the currently selected date.
ParseDateTime | This member is called to parse the month, day, and year from the COleDateTime object.
SetDate | Call this member to set the date of the item.
SetDateFormat | Call this member to change the date format.
SetDay | Call this member to set the Day of the date.
SetMonth | Call this member to set the Month of the date.
SetYear | Call this member to set the Year of the date.


CXTPPropertyGridItemDate::AllowNullDate Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::AllowNullDate Method

Call this member to allow null date

void AllowNullDate(
    LPCTSTR lpszNullValue
);
Parameters

lpszNullValue
text to display for null date

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::BindToDate Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::BindToDate Method

Call this method to bind an item to a COleDateTime object.

void BindToDate(
    COleDateTime* pBindDate
);
Parameters

pBindDate
COleDateTime object to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToDate member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::Format Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::Format Method

This method creates a formatted representation of the date/time value

virtual CString Format(
    const COleDateTime& oleDate
);
Parameters

oleDate
Date to be formatted.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::GetAsSystemTime Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::GetAsSystemTime Method

Call this member function to convert the time in the COleDateTime object to be represented as a SYSTEMTIME data structure. GetAsSystemTime stores the resulting time in the referenced sysTime object. The SYSTEMTIME data structure initialized by this function will have its wMilliseconds member set to zero.

virtual BOOL GetAsSystemTime(
    SYSTEMTIME& sysTime
);
Parameters

sysTime
SYSTEMTIME object to hold date.

Returns

TRUE if the COleDateTime date was successfully stored in the sysTime object.

Example

This sample code illustrates how to use the GetAsSystemTime member.

CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Appointments"));

//Create a Date object with the date 12/26/2004.  Note that no time information is entered
//because this information is ignored.
COleDateTime dates(2004, 12, 26, 0, 0, 0);

//Adds a date item to the property grid and set the date to the value stored in dates
CXTPPropertyGridItemDate* pDate = (CXTPPropertyGridItemDate*)(pStandard->AddChildItem(new CXTPPropertyGridItemDate(_T("Date item"), dates)));

//Creates a SYSTEMTIME object
SYSTEMTIME sysTime;

//Stores the day, month, and year into the SYSTEMTIME structure, all other members will be 0.
if (pDate->GetAsSystemTime(sysTime))
    TRACE(_T("SysTime Current Date= %d/%d/%dn"), sysTime.wMonth, sysTime.wDay, sysTime.wYear);
Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::GetDate Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::GetDate Method

Call this member to return the currently selected date.

virtual const COleDateTime& GetDate() const;
Returns

The currently selected date.

Body Source
const COleDateTime& CXTPPropertyGridItemDate::GetDate() const {
    return m_oleDate;
}
Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::GetDay Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::GetDay Method

Call this member to get the Day of the currently selected date.

virtual long GetDay();
Returns

Day of the currently set date.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::GetMonth Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::GetMonth Method

Call this member to get the Month of the currently selected date.

virtual long GetMonth();
Returns

Month of the currently set date.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::GetYear Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::GetYear Method

Call this member to get the Year of the currently selected date.

virtual long GetYear();
Returns

Year of the currently set date.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::OnBeforeInsert Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::OnInplaceButtonDown Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::OnInplaceButtonDown Method

This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.

virtual void OnInplaceButtonDown(
    CXTPPropertyGridInplaceButton* pButton
);
Parameters

pButton
Button that was pressed

Remarks

The in-place button is the button that the user presses to display date picker.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::ParseDateTime Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::ParseDateTime Method

This member is called to parse the month, day, and year from the COleDateTime object.

virtual BOOL ParseDateTime(
    COleDateTime& dt,
    LPCTSTR strValue
);
Parameters

dt
COleDateTime object containing the month, day, and year
strValue
The date format. Format Code:

%m - Month as decimal number (01 - 12)

%d - Day of month as decimal number (01 - 31)

%Y - Year with century, as decimal number Format string for 05/22/2004 is "%m%d%Y"

Returns

TRUE if a valid date was extracted, FALSE if an invalid date or NULL date was found.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::SetDate Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::SetDate Method

Call this member to set the date of the item.

virtual void SetDate(
    const COleDateTime& oleDate
);
Parameters

oleDate
COleDateTime containing a date. You must include the month, day, and year. All time information should be set to zero.

Example

This sample illustrates how to set the currently selected date in and item of type CXTPPropertyGridItemDate.

CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Appointments"));

//Create a Date object with the date 12/26/2004.  Note that no time information is entered
//because this information is ignored.
COleDateTime dates(2004, 12, 26, 0, 0, 0);

//Adds a date item to the property grid and set the date to the value stored in dates
CXTPPropertyGridItemDate* pDate = (CXTPPropertyGridItemDate*)(pStandard->AddChildItem(new CXTPPropertyGridItemDate(_T("Date item"), dates)));

//Set the date format to MM/DD/YYYY
pDate->SetDateFormat("%m/%d/%Y");

//Changes the date to 3/22/2001
COleDateTime newDate(2003, 5, 12, 0, 0, 0);

//Changes the date of the Date item.
pDate->SetDate(newDate);

//Gets the currently set date
TRACE(_T("Current Date= %d/%d/%dn"), pDate->GetMonth(), pDate->GetDay(), pDate->GetYear());
Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::SetDateFormat Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::SetDateFormat Method

Call this member to change the date format.

virtual void SetDateFormat(
    LPCTSTR strFormat
);
Parameters

strFormat
The date format.

%m - Month as decimal number (01 - 12)

%d - Day of month as decimal number (01 - 31)

%Y - Year with century, as decimal number Format string for 05/22/2004 is "%m%d%Y"

Example

This sample code illustrates how to change the date format of of type CXTPPropertyGridItemDate.

CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Appointments"));

//Create a Date object with the date 12/26/2004.  Note that no time information is entered
//because this information is ignored.
COleDateTime dates(2004, 12, 26, 0, 0, 0);

//Adds a date item to the property grid and set the date to the value stored in dates
CXTPPropertyGridItemDate* pDate = (CXTPPropertyGridItemDate*)(pStandard->AddChildItem(new CXTPPropertyGridItemDate(_T("Date item"), dates)));

//Set the date format to MM/DD/YYYY
pDate->SetDateFormat("%m/%d/%Y");
Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::SetDay Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::SetDay Method

Call this member to set the Day of the date.

virtual void SetDay(
    long nDay
);
Parameters

nDay
New Day of date.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::SetMonth Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::SetMonth Method

Call this member to set the Month of the date.

virtual void SetMonth(
    long nMonth
);
Parameters

nMonth
New Month of date.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::SetValue Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::SetValue Method

Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.

virtual void SetValue(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate::SetYear Method

CXTPPropertyGridItemDate Methods, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::SetYear Method

Call this member to set the Year of the date.

virtual void SetYear(
    long nYear
);
Parameters

nYear
New year of date.

Group

CXTPPropertyGridItemDate Methods


CXTPPropertyGridItemDate Constructors

CXTPPropertyGridItemDate Class, Legend, Public Methods
CXTPPropertyGridItemDate Constructors
Class

CXTPPropertyGridItemDate Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemDate |


CXTPPropertyGridItemDate Constructor

CXTPPropertyGridItemDate Constructors
CXTPPropertyGridItemDate Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemDate::CXTPPropertyGridItemDate (LPCTSTR, const COleDateTime&, COleDateTime*) | Constructs a CXTPPropertyGridItemDate object.
CXTPPropertyGridItemDate::CXTPPropertyGridItemDate (UINT, const COleDateTime&, COleDateTime*) | Constructs a CXTPPropertyGridItemDate object.
Group

CXTPPropertyGridItemDate Constructors


CXTPPropertyGridItemDate::CXTPPropertyGridItemDate Constructor (LPCTSTR, const COleDateTime&, COleDateTime*)

CXTPPropertyGridItemDate Constructor, CXTPPropertyGridItemDate Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDate::CXTPPropertyGridItemDate Constructor (LPCTSTR, const COleDateTime&, COleDateTime*)

Constructs a CXTPPropertyGridItemDate object.

CXTPPropertyGridItemDate(
    LPCTSTR strCaption,
    const COleDateTime& oleDate,
    COleDateTime* pBindDate = NULL
);
CXTPPropertyGridItemDate(
    UINT nID,
    const COleDateTime& oleDate,
    COleDateTime* pBindDate = NULL
);
Parameters

strCaption
Caption of the item.
oleDate
COleDateTime object containing the initial date of the item.
pBindDate
If not NULL, then the value of this item is bound the value of this variable.
nID
Identifier of the item.

Group

CXTPPropertyGridItemDate Constructor


CXTPPropertyGridItemDouble Class

XTPPropertyGridItemNumber.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemDouble Data Members, CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Constructors, CXTPPropertyGridItemDouble Destructors, CXTPPropertyGridItemDouble Constructors, CXTPPropertyGridItemDouble Data Members, CXTPPropertyGridItemDouble Destructors, CXTPPropertyGridItemDouble Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble Class

CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class. It is used to create an double value item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemDouble : public CXTPPropertyGridItem;
File

XTPPropertyGridItemNumber.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemDouble Constructors
CXTPPropertyGridItemDouble Constructors | Description
CXTPPropertyGridItemDouble |
CXTPPropertyGridItemDouble Data Members
CXTPPropertyGridItemDouble Data Members | Description
m_bUseSystemDecimalSymbol | TRUE to use system defined decimal symbol, FALSE to always use a decimal point ".".
m_fValue | Double value of item.
m_pBindDouble | Binded value.
CXTPPropertyGridItemDouble Destructors
CXTPPropertyGridItemDouble Destructors | Description
~CXTPPropertyGridItemDouble | Destroys a CXTPPropertyGridItemDouble object.
CXTPPropertyGridItemDouble Methods
CXTPPropertyGridItemDouble Methods | Description
BindToDouble | Call this method to bind the item to a double value.
DoubleToString | Converts a double vale to a CString value.
GetDouble | Call this method to get the double value of the item.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
SetDouble | Call this method to change the item's value.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
StringToDouble | Converts a String vale to a double value.
UseSystemDecimalSymbol | Specifies which type of symbol is used to divide the whole numbers from the decimal parts.


CXTPPropertyGridItemDouble Data Members

CXTPPropertyGridItemDouble Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble Data Members
Class

CXTPPropertyGridItemDouble Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bUseSystemDecimalSymbol | TRUE to use system defined decimal symbol, FALSE to always use a decimal point ".".
m_fValue | Double value of item.
m_pBindDouble | Binded value.


CXTPPropertyGridItemDouble::m_bUseSystemDecimalSymbol Data Member

CXTPPropertyGridItemDouble Data Members, CXTPPropertyGridItemDouble Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::m_bUseSystemDecimalSymbol Data Member

TRUE to use system defined decimal symbol, FALSE to always use a decimal point ".".

BOOL m_bUseSystemDecimalSymbol;
Group

CXTPPropertyGridItemDouble Data Members


CXTPPropertyGridItemDouble::m_fValue Data Member

CXTPPropertyGridItemDouble Data Members, CXTPPropertyGridItemDouble Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::m_fValue Data Member

Double value of item.

double m_fValue;
Group

CXTPPropertyGridItemDouble Data Members


CXTPPropertyGridItemDouble::m_pBindDouble Data Member

CXTPPropertyGridItemDouble Data Members, CXTPPropertyGridItemDouble Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::m_pBindDouble Data Member

Binded value.

double* m_pBindDouble;
Group

CXTPPropertyGridItemDouble Data Members


CXTPPropertyGridItemDouble Methods

CXTPPropertyGridItemDouble Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble Methods
Class

CXTPPropertyGridItemDouble Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DoubleToString | Converts a double vale to a CString value.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
StringToDouble | Converts a String vale to a double value.
Public Methods
Public Methods
Public Method | Description
BindToDouble | Call this method to bind the item to a double value.
GetDouble | Call this method to get the double value of the item.
SetDouble | Call this method to change the item's value.
UseSystemDecimalSymbol | Specifies which type of symbol is used to divide the whole numbers from the decimal parts.


CXTPPropertyGridItemDouble::BindToDouble Method

CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::BindToDouble Method

Call this method to bind the item to a double value.

virtual void BindToDouble(
    double* pBindDouble
);
Parameters

pBindDouble
Double value to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToDouble member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItemDouble Methods


CXTPPropertyGridItemDouble::DoubleToString Method

CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::DoubleToString Method

Converts a double vale to a CString value.

CString DoubleToString(
    double dValue
);
Parameters

dValue
double value to be converted to a CString.

Returns

CString representation of the double value.

See Also

StringToDouble

Group

CXTPPropertyGridItemDouble Methods


CXTPPropertyGridItemDouble::GetDouble Method

CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::GetDouble Method

Call this method to get the double value of the item.

virtual double GetDouble() const;
Returns

The double value of the item.

Body Source
double CXTPPropertyGridItemDouble::GetDouble() const {
    return m_fValue;
}
Group

CXTPPropertyGridItemDouble Methods


CXTPPropertyGridItemDouble::OnBeforeInsert Method

CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItemDouble Methods


CXTPPropertyGridItemDouble::SetDouble Method

CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::SetDouble Method

Call this method to change the item's value.

virtual void SetDouble(
    double fValue
);
Parameters

fValue
The new double value of the item.

Group

CXTPPropertyGridItemDouble Methods


CXTPPropertyGridItemDouble::SetValue Method

CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::SetValue Method

Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.

virtual void SetValue(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItemDouble Methods


CXTPPropertyGridItemDouble::StringToDouble Method

CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::StringToDouble Method

Converts a String vale to a double value.

double StringToDouble(
    LPCTSTR lpszValue
);
Parameters

lpszValue
String value to be converted to a double.

Returns

Double representation of the String value.

See Also

DoubleToString

Group

CXTPPropertyGridItemDouble Methods


CXTPPropertyGridItemDouble::UseSystemDecimalSymbol Method

CXTPPropertyGridItemDouble Methods, CXTPPropertyGridItemDouble Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::UseSystemDecimalSymbol Method

Specifies which type of symbol is used to divide the whole numbers from the decimal parts.

void UseSystemDecimalSymbol(
    BOOL bUseSystemDecimalSymbol
);
Parameters

bUseSystemDecimalSymbol
TRUE to use system defined decimal symbol. FALSE to always use a decimal point ".".

Remarks

Setting UseSystemDecimalSymbol to False causes the decimal point "." to separate the whole numbers from the decimal parts. Setting UseSystemDecimalSymbol to True will cause the system defined symbol to separate the whole numbers from the decimal parts.

For example, when True, a comma "," will be used in Europe to separate the whole numbers from the decimal parts.

Body Source
void CXTPPropertyGridItemDouble::UseSystemDecimalSymbol(BOOL bUseSystemDecimalSymbol) {
    m_bUseSystemDecimalSymbol = bUseSystemDecimalSymbol;
    m_strValue = DoubleToString(m_fValue);
}
Group

CXTPPropertyGridItemDouble Methods


CXTPPropertyGridItemDouble Constructors

CXTPPropertyGridItemDouble Class, Legend, Public Methods
CXTPPropertyGridItemDouble Constructors
Class

CXTPPropertyGridItemDouble Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemDouble |


CXTPPropertyGridItemDouble Constructor

CXTPPropertyGridItemDouble Constructors
CXTPPropertyGridItemDouble Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemDouble::CXTPPropertyGridItemDouble (LPCTSTR, double, LPCTSTR, double*) | Constructs a CXTPPropertyGridItemDouble object.
CXTPPropertyGridItemDouble::CXTPPropertyGridItemDouble (UINT, double, LPCTSTR, double*) | Constructs a CXTPPropertyGridItemDouble object.
Group

CXTPPropertyGridItemDouble Constructors


CXTPPropertyGridItemDouble::CXTPPropertyGridItemDouble Constructor (LPCTSTR, double, LPCTSTR, double*)

CXTPPropertyGridItemDouble Constructor, CXTPPropertyGridItemDouble Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::CXTPPropertyGridItemDouble Constructor (LPCTSTR, double, LPCTSTR, double*)

Constructs a CXTPPropertyGridItemDouble object.

CXTPPropertyGridItemDouble(
    LPCTSTR strCaption,
    double fValue = 0,
    LPCTSTR strFormat = NULL,
    double* pBindNumber = NULL
);
CXTPPropertyGridItemDouble(
    UINT nID,
    double fValue = 0,
    LPCTSTR strFormat = NULL,
    double* pBindNumber = NULL
);
Parameters

strCaption
Caption of the item.
fValue
Initial value.
strFormat
The number of digits after the decimal point. For example "%0.5f" would display 5 digits past the decimal place.
pBindNumber
If not NULL, then the value of this item is bound the value of this variable.
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItemDouble has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToDouble member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See Also

BindToDouble

Group

CXTPPropertyGridItemDouble Constructor


CXTPPropertyGridItemDouble Destructors

CXTPPropertyGridItemDouble Class, Legend, Public Methods
CXTPPropertyGridItemDouble Destructors
Class

CXTPPropertyGridItemDouble Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItemDouble | Destroys a CXTPPropertyGridItemDouble object.


CXTPPropertyGridItemDouble::~CXTPPropertyGridItemDouble Destructor

CXTPPropertyGridItemDouble Destructors, CXTPPropertyGridItemDouble Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemDouble::~CXTPPropertyGridItemDouble Destructor

Destroys a CXTPPropertyGridItemDouble object.

virtual ~CXTPPropertyGridItemDouble();
Group

CXTPPropertyGridItemDouble Destructors


CXTPPropertyGridItemEnum Class

XTPPropertyGridItemBool.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemEnum Data Members, CXTPPropertyGridItemEnum Methods, CXTPPropertyGridItemEnum Constructors, CXTPPropertyGridItemEnum Destructors, CXTPPropertyGridItemEnum Constructors, CXTPPropertyGridItemEnum Data Members, CXTPPropertyGridItemEnum Destructors, Example, CXTPPropertyGridItemEnum Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum Class

CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class. It is used to create an Enum value item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemEnum : public CXTPPropertyGridItem;
File

XTPPropertyGridItemBool.h

Remarks

A Enum item is used to display a list of constraints. This is very similar to a normal constraint list. The difference is that an Enum constraint list will return the Value of the constraint when selected, where a normal constraint wold return the text of the constraint.

See Also

CXTPPropertyGridItemEnum::SetEnum, CXTPPropertyGridItemEnum::GetEnum, CXTPPropertyGridItem::GetValue

Example

This code illustrates how to add an item of type Enum to your grid.

//Adds a category to the grid called "Software"
CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Software"));

//Adds a CXTPPropertyGridItemFlags item with a caption of "Current OS" and an initial value of 2
//This will cause the constraint with a value of 2 to be selected
CXTPPropertyGridItemEnum* pItem = (CXTPPropertyGridItemEnum*)(pStandard->AddChildItem(new CXTPPropertyGridItemEnum(_T("Current OS"), 2)));

//Adds some constraints along with a value
pItem->GetConstraints()->AddConstraint(_T("Windows 98"), 1);
pItem->GetConstraints()->AddConstraint(_T("Windows 2000"), 2);
pItem->GetConstraints()->AddConstraint(_T("Windows XP"), 3);

//GetEnum will return the Data value of the constraint selected
TRACE(_T("Enum Item Value= %dn"), pItem->GetEnum());

//GetValue will return the String of the constraint selected
TRACE(_T("Enum Item String= %sn"), pItem->GetValue());
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemEnum Constructors
CXTPPropertyGridItemEnum Constructors | Description
CXTPPropertyGridItemEnum |
CXTPPropertyGridItemEnum Data Members
CXTPPropertyGridItemEnum Data Members | Description
m_nValue | Value of the item.
m_pBindEnum | Binded value.
CXTPPropertyGridItemEnum Destructors
CXTPPropertyGridItemEnum Destructors | Description
~CXTPPropertyGridItemEnum | Destroys a CXTPPropertyGridItemEnum object.
CXTPPropertyGridItemEnum Methods
CXTPPropertyGridItemEnum Methods | Description
BindToEnum | Call this method to bind the item to a Enum object.
GetEnum | Call this method to get the selected value of the item.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnConstraintsChanged | This member is called when constraints are added to this item.
SetEnum |
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.


CXTPPropertyGridItemEnum Data Members

CXTPPropertyGridItemEnum Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum Data Members
Class

CXTPPropertyGridItemEnum Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nValue | Value of the item.
m_pBindEnum | Binded value.


CXTPPropertyGridItemEnum::m_nValue Data Member

CXTPPropertyGridItemEnum Data Members, CXTPPropertyGridItemEnum Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::m_nValue Data Member

Value of the item.

int m_nValue;
Group

CXTPPropertyGridItemEnum Data Members


CXTPPropertyGridItemEnum::m_pBindEnum Data Member

CXTPPropertyGridItemEnum Data Members, CXTPPropertyGridItemEnum Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::m_pBindEnum Data Member

Binded value.

int* m_pBindEnum;
Group

CXTPPropertyGridItemEnum Data Members


CXTPPropertyGridItemEnum Methods

CXTPPropertyGridItemEnum Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum Methods
Class

CXTPPropertyGridItemEnum Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnConstraintsChanged | This member is called when constraints are added to this item.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
Public Methods
Public Methods
Public Method | Description
BindToEnum | Call this method to bind the item to a Enum object.
GetEnum | Call this method to get the selected value of the item.
SetEnum |


CXTPPropertyGridItemEnum::BindToEnum Method

CXTPPropertyGridItemEnum Methods, CXTPPropertyGridItemEnum Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::BindToEnum Method

Call this method to bind the item to a Enum object.

virtual void BindToEnum(
    int* pBindEnum
);
Parameters

pBindEnum
Enum object to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToEnum member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItemEnum Methods


CXTPPropertyGridItemEnum::GetEnum Method

CXTPPropertyGridItemEnum Methods, CXTPPropertyGridItemEnum Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::GetEnum Method

Call this method to get the selected value of the item.

virtual int GetEnum() const;
Returns

Value of the currently selected constraint. This returns the value, not the text.

See Also

CXTPPropertyGridItemEnum, SetEnum

Body Source
int CXTPPropertyGridItemEnum::GetEnum() const {
    return m_nValue;
}
Group

CXTPPropertyGridItemEnum Methods


CXTPPropertyGridItemEnum::OnBeforeInsert Method

CXTPPropertyGridItemEnum Methods, CXTPPropertyGridItemEnum Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItemEnum Methods


CXTPPropertyGridItemEnum::OnConstraintsChanged Method

CXTPPropertyGridItemEnum Methods, CXTPPropertyGridItemEnum Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::OnConstraintsChanged Method

This member is called when constraints are added to this item.

virtual void OnConstraintsChanged();
Remarks

OnConstraintsChanged is called when CXTPPropertyGridItemConstraints::AddConstraint is called.

See Also

CXTPPropertyGridItemConstraints::AddConstraint

Group

CXTPPropertyGridItemEnum Methods


SetEnum Method

CXTPPropertyGridItemEnum Methods
SetEnum Method
Overload List
Methods
Method | Description
CXTPPropertyGridItemEnum::SetEnum (CXTPPropertyGridItemConstraint*) | Call this method to change the item's value. The second method is called when user click an item in the constraint list.
CXTPPropertyGridItemEnum::SetEnum (int) | Call this method to change the item's value. The second method is called when user click an item in the constraint list.
Group

CXTPPropertyGridItemEnum Methods


CXTPPropertyGridItemEnum::SetEnum Method (int)

SetEnum Method, CXTPPropertyGridItemEnum Class, See Also
CXTPPropertyGridItemEnum::SetEnum Method (int)

Call this method to change the item's value. The second method is called when user click an item in the constraint list.

virtual void SetEnum(
    int nValue
);
virtual void SetEnum(
    CXTPPropertyGridItemConstraint* pConstraint
);
Parameters

nValue
The new value of the item. This should be the value of a constraint.
pConstraint
The currently selected constraint.

See Also

CXTPPropertyGridItemEnum, GetEnum

Group

SetEnum Method


CXTPPropertyGridItemEnum::SetValue Method

CXTPPropertyGridItemEnum Methods, CXTPPropertyGridItemEnum Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::SetValue Method

Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.

virtual void SetValue(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItemEnum Methods


CXTPPropertyGridItemEnum Constructors

CXTPPropertyGridItemEnum Class, Legend, Public Methods
CXTPPropertyGridItemEnum Constructors
Class

CXTPPropertyGridItemEnum Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemEnum |


CXTPPropertyGridItemEnum Constructor

CXTPPropertyGridItemEnum Constructors
CXTPPropertyGridItemEnum Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemEnum::CXTPPropertyGridItemEnum (LPCTSTR, int, int*) | Constructs a CXTPPropertyGridItemEnum object.
CXTPPropertyGridItemEnum::CXTPPropertyGridItemEnum (UINT, int, int*) | Constructs a CXTPPropertyGridItemEnum object.
Group

CXTPPropertyGridItemEnum Constructors


CXTPPropertyGridItemEnum::CXTPPropertyGridItemEnum Constructor (LPCTSTR, int, int*)

CXTPPropertyGridItemEnum Constructor, CXTPPropertyGridItemEnum Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::CXTPPropertyGridItemEnum Constructor (LPCTSTR, int, int*)

Constructs a CXTPPropertyGridItemEnum object.

CXTPPropertyGridItemEnum(
    LPCTSTR strCaption,
    int nValue = 0,
    int* pBindEnum = NULL
);
CXTPPropertyGridItemEnum(
    UINT nID,
    int nValue = 0,
    int* pBindEnum = NULL
);
Parameters

strCaption
Caption of the item.
nValue
Initial value of item. This should be the value of a constraint.
pBindEnum
If not NULL, then the value of this item is bound the value of this variable.
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItemEnum has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToEnum member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See Also

BindToEnum

Group

CXTPPropertyGridItemEnum Constructor


CXTPPropertyGridItemEnum Destructors

CXTPPropertyGridItemEnum Class, Legend, Public Methods
CXTPPropertyGridItemEnum Destructors
Class

CXTPPropertyGridItemEnum Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItemEnum | Destroys a CXTPPropertyGridItemEnum object.


CXTPPropertyGridItemEnum::~CXTPPropertyGridItemEnum Destructor

CXTPPropertyGridItemEnum Destructors, CXTPPropertyGridItemEnum Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemEnum::~CXTPPropertyGridItemEnum Destructor

Destroys a CXTPPropertyGridItemEnum object.

virtual ~CXTPPropertyGridItemEnum();
Group

CXTPPropertyGridItemEnum Destructors


CXTPPropertyGridItemFlags Class

XTPPropertyGridItemBool.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemFlags Data Members, CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Constructors, CXTPPropertyGridItemFlags Destructors, CXTPPropertyGridItemFlags Constructors, CXTPPropertyGridItemFlags Data Members, CXTPPropertyGridItemFlags Destructors, Example, CXTPPropertyGridItemFlags Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags Class

CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class. It is used to create a Flags value item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemFlags : public CXTPPropertyGridItem;
File

XTPPropertyGridItemBool.h

Remarks

A flag item is used to combine multiple boolean values into a single item. When using a flag item, you must add constraints to the flag item. Each constraint will have a value of TRUE or FALSE. The flag item will have an expand button that when clicked will display all boolean constraints for that item. The value of the flag item will be the sum of all the boolean constraints with a value of TRUE.

Notes

Constraint values must be in powers of 2 if you will have an "All" constraint that indicates that the value of all boolean constraints is TRUE or FALSE.

In the example below, the flag item's initial value will be 9, this value is stored in CXTPPropertyGridItemFlags::m_nValue and can be set with SetFlags and retrieved with GetFlags. The string value will be "[Windows 98; Windows 95]" and this value is stored in CXTPPropertyGridItem::m_strValue, which can be retrieved with CXTPPropertyGridItem::GetValue. You must use the SetFlags method to change the flag items value by code. The string value is what is displayed to the user.

See Also

CXTPPropertyGridItemFlags::SetFlags, CXTPPropertyGridItemFlags::GetFlags, CXTPPropertyGridItem::GetValue

Example

This sample illustrates how to add an item of type Flags to your grid.

//Adds a category to the grid called "Software"
CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Software"));

//Adds a CXTPPropertyGridItemFlags item with a caption of "Supported OS" and an initial value of 9
CXTPPropertyGridItemFlags* pItem = (CXTPPropertyGridItemFlags*)(pStandard->AddChildItem(new CXTPPropertyGridItemFlags(_T("Supported OS"), 1 + 8)));

//Adds a constraint that will set all items TRUE or FALSE, note the value of the constraint is the sum
//of all the other constraints.  This item will also be updated when the values of the other constraints
//have changed.
pItem->GetConstraints()->AddConstraint(_T("All Windows"), 1 + 2 + 4 + 8 + 16 + 32);

//Adds a constraint that can have a value of TRUE or FALSE
pItem->GetConstraints()->AddConstraint(_T("Windows 98"), 1);
pItem->GetConstraints()->AddConstraint(_T("Windows 2000"), 2);
pItem->GetConstraints()->AddConstraint(_T("Windows XP"), 4);
pItem->GetConstraints()->AddConstraint(_T("Windows 95"), 8);
pItem->GetConstraints()->AddConstraint(_T("Windows NT"), 16);
pItem->GetConstraints()->AddConstraint(_T("Windows 2003"), 32);

//This changes the value of the flag item to 21 and the string
//caption to [Windows 98; Windows XP; Windows NT]
pItem->SetFlags(21);

//GetFlags will return the sum of all true constraints
TRACE(_T("Flags Item Value= %dn"), pItem->GetFlags());

//GetValue will return a string containing the text of all true constraints
TRACE(_T("Flags Item String= %sn"), pItem->GetValue());
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemFlags Constructors
CXTPPropertyGridItemFlags Constructors | Description
CXTPPropertyGridItemFlags |
CXTPPropertyGridItemFlags Data Members
CXTPPropertyGridItemFlags Data Members | Description
m_nValue | Value of the item.
m_pBindFlags | Binded value.
CXTPPropertyGridItemFlags Destructors
CXTPPropertyGridItemFlags Destructors | Description
~CXTPPropertyGridItemFlags | Destroys a CXTPPropertyGridItemFlags object.
CXTPPropertyGridItemFlags Methods
CXTPPropertyGridItemFlags Methods | Description
BindToFlags | Call this method to bind the item to a flags object.
GetFlags | Call this method to get the value of the flag item. This will be the sum of the constraint values that have a value of TRUE, not the displayed text. To retrieve the text, use CXTPPropertyGrid::GetValue.
GetFlagsString | Retrieves string notation of selected flags.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnConstraintsChanged | This member is called when constraints are added to this item.
SetFlags | Call this method to change the item's value.
SetReadOnly | Call this method to set the read-only state of the item.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
UpdateChilds | This method is called to refresh child bool items.


CXTPPropertyGridItemFlags Data Members

CXTPPropertyGridItemFlags Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags Data Members
Class

CXTPPropertyGridItemFlags Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nValue | Value of the item.
m_pBindFlags | Binded value.


CXTPPropertyGridItemFlags::m_nValue Data Member

CXTPPropertyGridItemFlags Data Members, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::m_nValue Data Member

Value of the item.

int m_nValue;
Group

CXTPPropertyGridItemFlags Data Members


CXTPPropertyGridItemFlags::m_pBindFlags Data Member

CXTPPropertyGridItemFlags Data Members, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::m_pBindFlags Data Member

Binded value.

int* m_pBindFlags;
Group

CXTPPropertyGridItemFlags Data Members


CXTPPropertyGridItemFlags Methods

CXTPPropertyGridItemFlags Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags Methods
Class

CXTPPropertyGridItemFlags Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetFlagsString | Retrieves string notation of selected flags.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
OnConstraintsChanged | This member is called when constraints are added to this item.
SetReadOnly | Call this method to set the read-only state of the item.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
UpdateChilds | This method is called to refresh child bool items.
Public Methods
Public Methods
Public Method | Description
BindToFlags | Call this method to bind the item to a flags object.
GetFlags | Call this method to get the value of the flag item. This will be the sum of the constraint values that have a value of TRUE, not the displayed text. To retrieve the text, use CXTPPropertyGrid::GetValue.
SetFlags | Call this method to change the item's value.


CXTPPropertyGridItemFlags::BindToFlags Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::BindToFlags Method

Call this method to bind the item to a flags object.

virtual void BindToFlags(
    int* pBindFlags
);
Parameters

pBindFlags
Flags object to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToFlags member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags::GetFlags Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::GetFlags Method

Call this method to get the value of the flag item. This will be the sum of the constraint values that have a value of TRUE, not the displayed text. To retrieve the text, use CXTPPropertyGrid::GetValue.

virtual int GetFlags() const;
Returns

The sum of the constraint values with a value of TRUE.

Remarks

See CXTPPropertyGridItemFlags for more information.

See Also

CXTPPropertyGridItemFlags, SetFlags, CXTPPropertyGrid::GetValue.

Body Source
int CXTPPropertyGridItemFlags::GetFlags() const {
    return m_nValue;
}
Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags::GetFlagsString Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::GetFlagsString Method

Retrieves string notation of selected flags.

virtual CString GetFlagsString();
Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags::OnBeforeInsert Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags::OnConstraintsChanged Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::OnConstraintsChanged Method

This member is called when constraints are added to this item.

virtual void OnConstraintsChanged();
Remarks

OnConstraintsChanged is called when CXTPPropertyGridItemConstraints::AddConstraint is called.

See Also

CXTPPropertyGridItemConstraints::AddConstraint

Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags::SetFlags Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::SetFlags Method

Call this method to change the item's value.

virtual void SetFlags(
    int nValue
);
Parameters

nValue
The new value of the item. This should be the sum of the constraints data. See the description of CXTPPropertyGridItemFlags for a more detailed description of this value.

See Also

CXTPPropertyGridItemFlags, GetFlags

Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags::SetReadOnly Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::SetReadOnly Method

Call this method to set the read-only state of the item.

virtual void SetReadOnly(
    BOOL bReadOnly
);
Parameters

bReadOnly
Specifies whether to set or remove the read-only state of the item. A value of TRUE sets the state to read-only. A value of FALSE sets the state to read/write.

Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags::SetValue Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::SetValue Method

Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.

virtual void SetValue(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags::UpdateChilds Method

CXTPPropertyGridItemFlags Methods, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::UpdateChilds Method

This method is called to refresh child bool items.

virtual void UpdateChilds();
Group

CXTPPropertyGridItemFlags Methods


CXTPPropertyGridItemFlags Constructors

CXTPPropertyGridItemFlags Class, Legend, Public Methods
CXTPPropertyGridItemFlags Constructors
Class

CXTPPropertyGridItemFlags Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemFlags |


CXTPPropertyGridItemFlags Constructor

CXTPPropertyGridItemFlags Constructors
CXTPPropertyGridItemFlags Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemFlags::CXTPPropertyGridItemFlags (LPCTSTR, int, int*) | Constructs a CXTPPropertyGridItemFlag object.
CXTPPropertyGridItemFlags::CXTPPropertyGridItemFlags (UINT, int, int*) | Constructs a CXTPPropertyGridItemFlag object.
Group

CXTPPropertyGridItemFlags Constructors


CXTPPropertyGridItemFlags::CXTPPropertyGridItemFlags Constructor (LPCTSTR, int, int*)

CXTPPropertyGridItemFlags Constructor, CXTPPropertyGridItemFlags Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::CXTPPropertyGridItemFlags Constructor (LPCTSTR, int, int*)

Constructs a CXTPPropertyGridItemFlag object.

CXTPPropertyGridItemFlags(
    LPCTSTR strCaption,
    int nValue = 0,
    int* pBindFlags = NULL
);
CXTPPropertyGridItemFlags(
    UINT nID,
    int nValue = 0,
    int* pBindFlags = NULL
);
Parameters

strCaption
Caption of the item.
nValue
Initial value of item. See the description of CXTPPropertyGridItemFlags for a more detailed description of this value.
pBindFlags
If not NULL, then the value of this item is bound the value of this variable.
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItemFlags has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToFlags member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See Also

BindToFlags

Group

CXTPPropertyGridItemFlags Constructor


CXTPPropertyGridItemFlags Destructors

CXTPPropertyGridItemFlags Class, Legend, Public Methods
CXTPPropertyGridItemFlags Destructors
Class

CXTPPropertyGridItemFlags Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItemFlags | Destroys a CXTPPropertyGridItemFlags object.


CXTPPropertyGridItemFlags::~CXTPPropertyGridItemFlags Destructor

CXTPPropertyGridItemFlags Destructors, CXTPPropertyGridItemFlags Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFlags::~CXTPPropertyGridItemFlags Destructor

Destroys a CXTPPropertyGridItemFlags object.

virtual ~CXTPPropertyGridItemFlags();
Group

CXTPPropertyGridItemFlags Destructors


CXTPPropertyGridItemFont Class

XTPPropertyGridItemFont.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemFont Data Members, CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Constructors, CXTPPropertyGridItemFont Destructors, CXTPPropertyGridItemFont Constructors, CXTPPropertyGridItemFont Data Members, CXTPPropertyGridItemFont Destructors, CXTPPropertyGridItemFont Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont Class

CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class. It is used to create a Font value item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemFont : public CXTPPropertyGridItem;
File

XTPPropertyGridItemFont.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemFont Constructors
CXTPPropertyGridItemFont Constructors | Description
CXTPPropertyGridItemFont |
CXTPPropertyGridItemFont Data Members
CXTPPropertyGridItemFont Data Members | Description
m_clrValue | Font color.
m_lfValue | Value of the item, this holds the current font value.
CXTPPropertyGridItemFont Destructors
CXTPPropertyGridItemFont Destructors | Description
~CXTPPropertyGridItemFont | Destroys a CXTPPropertyGridItemFont object.
CXTPPropertyGridItemFont Methods
CXTPPropertyGridItemFont Methods | Description
FontToString | Converts a LOGFONT object into a string that contains the font's name and pt.
GetColor | Call the member to get the COLORREF value of this item.
GetFont | Call this method to get the LOGFONT value of the item.
GetValueRect | Retrieves the bounding rectangle of the item value's text. Override this member function to change it.
OnDrawItemValue | This method is called when an item is drawn. Override this function if needed.
OnInplaceButtonDown | This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.
SetColor | Call this method to change the item's value.
SetFont | Call this method to change the item's value.


CXTPPropertyGridItemFont Data Members

CXTPPropertyGridItemFont Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont Data Members
Class

CXTPPropertyGridItemFont Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrValue | Font color.
m_lfValue | Value of the item, this holds the current font value.


CXTPPropertyGridItemFont::m_clrValue Data Member

CXTPPropertyGridItemFont Data Members, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::m_clrValue Data Member

Font color.

COLORREF m_clrValue;
Group

CXTPPropertyGridItemFont Data Members


CXTPPropertyGridItemFont::m_lfValue Data Member

CXTPPropertyGridItemFont Data Members, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::m_lfValue Data Member

Value of the item, this holds the current font value.

LOGFONT m_lfValue;
Group

CXTPPropertyGridItemFont Data Members


CXTPPropertyGridItemFont Methods

CXTPPropertyGridItemFont Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont Methods
Class

CXTPPropertyGridItemFont Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
FontToString | Converts a LOGFONT object into a string that contains the font's name and pt.
GetValueRect | Retrieves the bounding rectangle of the item value's text. Override this member function to change it.
OnDrawItemValue | This method is called when an item is drawn. Override this function if needed.
OnInplaceButtonDown | This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.
Public Methods
Public Methods
Public Method | Description
GetColor | Call the member to get the COLORREF value of this item.
GetFont | Call this method to get the LOGFONT value of the item.
SetColor | Call this method to change the item's value.
SetFont | Call this method to change the item's value.


CXTPPropertyGridItemFont::FontToString Method

CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::FontToString Method

Converts a LOGFONT object into a string that contains the font's name and pt.

virtual CString FontToString(
    const LOGFONT& lfValue
);
Parameters

lfValue
LOGFONT object to convert to string.

Returns

A string that contains the name pt of the font.

Group

CXTPPropertyGridItemFont Methods


CXTPPropertyGridItemFont::GetColor Method

CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::GetColor Method

Call the member to get the COLORREF value of this item.

virtual COLORREF GetColor();
Returns

The COLORREF value of the item.

Group

CXTPPropertyGridItemFont Methods


CXTPPropertyGridItemFont::GetFont Method

CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::GetFont Method

Call this method to get the LOGFONT value of the item.

virtual void GetFont(
    LOGFONT* lf
);
Parameters

lf
Pointer to the LOGFONT structure to receive the font information.

Group

CXTPPropertyGridItemFont Methods


CXTPPropertyGridItemFont::GetValueRect Method

CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::GetValueRect Method

Retrieves the bounding rectangle of the item value's text. Override this member function to change it.

virtual CRect GetValueRect();
Returns

A CRect object that represents the bounding rectangle of the item value's text.

Group

CXTPPropertyGridItemFont Methods


CXTPPropertyGridItemFont::OnDrawItemValue Method

CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::OnDrawItemValue Method

This method is called when an item is drawn. Override this function if needed.

virtual BOOL OnDrawItemValue(
    CDC& dc,
    CRect rcValue
);
Parameters

dc
Pointer to a valid device context.
rcValue
Bounding rectangle of the item.

Returns

TRUE if the item is self-drawn.

Group

CXTPPropertyGridItemFont Methods


CXTPPropertyGridItemFont::OnInplaceButtonDown Method

CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::OnInplaceButtonDown Method

This method is called when the user presses the in-place button. Override the method to show an item-specific dialog.

virtual void OnInplaceButtonDown(
    CXTPPropertyGridInplaceButton* pButton
);
Parameters

pButton
Button that was pressed

Remarks

The in-place button is the button that the user presses to display the font picker dialog.

Group

CXTPPropertyGridItemFont Methods


CXTPPropertyGridItemFont::SetColor Method

CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::SetColor Method

Call this method to change the item's value.

virtual void SetColor(
    COLORREF clr
);
Parameters

clr
The new COLORREF value of the item.

Group

CXTPPropertyGridItemFont Methods


CXTPPropertyGridItemFont::SetFont Method

CXTPPropertyGridItemFont Methods, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::SetFont Method

Call this method to change the item's value.

virtual void SetFont(
    LOGFONT& font
);
Parameters

font
The new value of the item.

Group

CXTPPropertyGridItemFont Methods


CXTPPropertyGridItemFont Constructors

CXTPPropertyGridItemFont Class, Legend, Public Methods
CXTPPropertyGridItemFont Constructors
Class

CXTPPropertyGridItemFont Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemFont |


CXTPPropertyGridItemFont Constructor

CXTPPropertyGridItemFont Constructors
CXTPPropertyGridItemFont Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemFont::CXTPPropertyGridItemFont (LPCTSTR, LOGFONT&) | Constructs a CXTPPropertyGridItemFont object.
CXTPPropertyGridItemFont::CXTPPropertyGridItemFont (UINT, LOGFONT&) | Constructs a CXTPPropertyGridItemFont object.
Group

CXTPPropertyGridItemFont Constructors


CXTPPropertyGridItemFont::CXTPPropertyGridItemFont Constructor (LPCTSTR, LOGFONT&)

CXTPPropertyGridItemFont Constructor, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::CXTPPropertyGridItemFont Constructor (LPCTSTR, LOGFONT&)

Constructs a CXTPPropertyGridItemFont object.

CXTPPropertyGridItemFont(
    LPCTSTR strCaption,
    LOGFONT& font
);
CXTPPropertyGridItemFont(
    UINT nID,
    LOGFONT& font
);
Parameters

strCaption
Caption of the item.
font
Initial font value.
nID
Identifier of the item.

Group

CXTPPropertyGridItemFont Constructor


CXTPPropertyGridItemFont Destructors

CXTPPropertyGridItemFont Class, Legend, Public Methods
CXTPPropertyGridItemFont Destructors
Class

CXTPPropertyGridItemFont Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItemFont | Destroys a CXTPPropertyGridItemFont object.


CXTPPropertyGridItemFont::~CXTPPropertyGridItemFont Destructor

CXTPPropertyGridItemFont Destructors, CXTPPropertyGridItemFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemFont::~CXTPPropertyGridItemFont Destructor

Destroys a CXTPPropertyGridItemFont object.

virtual ~CXTPPropertyGridItemFont();
Group

CXTPPropertyGridItemFont Destructors


CXTPPropertyGridItemMetrics Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Methods, CXTPPropertyGridItemMetrics Constructors, CXTPPropertyGridItemMetrics Constructors, CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics Class

Standalone class used by CXTPPropertyGridPaintManager as holder of item metrics

Class Hierarchy

class CXTPPropertyGridItemMetrics;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemMetrics Constructors
CXTPPropertyGridItemMetrics Constructors | Description
CXTPPropertyGridItemMetrics | Constructs a CXTPPropertyGridItemMetrics object.
CXTPPropertyGridItemMetrics Data Members
CXTPPropertyGridItemMetrics Data Members | Description
m_clrBack | Background color.
m_clrCategoryFore | Color of the category text.
m_clrFore | Color of the item's text.
m_clrHelpBack | Color of the description background.
m_clrHelpFore | Color of the description text.
m_clrLine | Line color.
m_clrReadOnlyFore | Color of read-only text.
m_clrVerbFace | Text color of verbs.
m_fontBold | Bold font.
m_fontNormal | Normal font.
m_nImage | Image index.
m_nMaxLength | Maximum number of characters that can be entered into an editable item (Edit limit).
m_pPaintManager | Pointer to the paint manager used to draw the property grid.
m_uDrawTextFormat | Text formatting style for the property item.
CXTPPropertyGridItemMetrics Methods
CXTPPropertyGridItemMetrics Methods | Description
SetDefaultValues | Resets all color values to its defaults.


CXTPPropertyGridItemMetrics Data Members

CXTPPropertyGridItemMetrics Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics Data Members
Class

CXTPPropertyGridItemMetrics Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pPaintManager | Pointer to the paint manager used to draw the property grid.
Public Data Members
Public Data Member | Description
m_clrBack | Background color.
m_clrCategoryFore | Color of the category text.
m_clrFore | Color of the item's text.
m_clrHelpBack | Color of the description background.
m_clrHelpFore | Color of the description text.
m_clrLine | Line color.
m_clrReadOnlyFore | Color of read-only text.
m_clrVerbFace | Text color of verbs.
m_fontBold | Bold font.
m_fontNormal | Normal font.
m_nImage | Image index.
m_nMaxLength | Maximum number of characters that can be entered into an editable item (Edit limit).
m_uDrawTextFormat | Text formatting style for the property item.


CXTPPropertyGridItemMetrics::m_clrBack Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_clrBack Data Member

Background color.

CXTPPaintManagerColor m_clrBack;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_clrCategoryFore Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_clrCategoryFore Data Member

Color of the category text.

CXTPPaintManagerColor m_clrCategoryFore;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_clrFore Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_clrFore Data Member

Color of the item's text.

CXTPPaintManagerColor m_clrFore;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_clrHelpBack Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_clrHelpBack Data Member

Color of the description background.

CXTPPaintManagerColor m_clrHelpBack;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_clrHelpFore Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_clrHelpFore Data Member

Color of the description text.

CXTPPaintManagerColor m_clrHelpFore;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_clrLine Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_clrLine Data Member

Line color.

CXTPPaintManagerColor m_clrLine;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_clrReadOnlyFore Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_clrReadOnlyFore Data Member

Color of read-only text.

CXTPPaintManagerColor m_clrReadOnlyFore;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_clrVerbFace Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_clrVerbFace Data Member

Text color of verbs.

CXTPPaintManagerColor m_clrVerbFace;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_fontBold Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_fontBold Data Member

Bold font.

CFont m_fontBold;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_fontNormal Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_fontNormal Data Member

Normal font.

CFont m_fontNormal;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_nImage Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_nImage Data Member

Image index.

int m_nImage;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_nMaxLength Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_nMaxLength Data Member

Maximum number of characters that can be entered into an editable item (Edit limit).

int m_nMaxLength;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_pPaintManager Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_pPaintManager Data Member

Pointer to the paint manager used to draw the property grid.

CXTPPropertyGridPaintManager* m_pPaintManager;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics::m_uDrawTextFormat Data Member

CXTPPropertyGridItemMetrics Data Members, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::m_uDrawTextFormat Data Member

Text formatting style for the property item.

UINT m_uDrawTextFormat;
Group

CXTPPropertyGridItemMetrics Data Members


CXTPPropertyGridItemMetrics Methods

CXTPPropertyGridItemMetrics Class, Legend, Public Methods
CXTPPropertyGridItemMetrics Methods
Class

CXTPPropertyGridItemMetrics Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
SetDefaultValues | Resets all color values to its defaults.


CXTPPropertyGridItemMetrics::SetDefaultValues Method

CXTPPropertyGridItemMetrics Methods, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::SetDefaultValues Method

Resets all color values to its defaults.

virtual void SetDefaultValues();
Group

CXTPPropertyGridItemMetrics Methods


CXTPPropertyGridItemMetrics Constructors

CXTPPropertyGridItemMetrics Class, Legend, Public Methods
CXTPPropertyGridItemMetrics Constructors
Class

CXTPPropertyGridItemMetrics Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemMetrics | Constructs a CXTPPropertyGridItemMetrics object.


CXTPPropertyGridItemMetrics::CXTPPropertyGridItemMetrics Constructor

CXTPPropertyGridItemMetrics Constructors, CXTPPropertyGridItemMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemMetrics::CXTPPropertyGridItemMetrics Constructor

Constructs a CXTPPropertyGridItemMetrics object.

CXTPPropertyGridItemMetrics(
    CXTPPropertyGridPaintManager* pPaintManager
);
Parameters

pPaintManager
Parent CXTPPropertyGridPaintManager object

Group

CXTPPropertyGridItemMetrics Constructors


CXTPPropertyGridItemNumber Class

XTPPropertyGridItemNumber.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemNumber Data Members, CXTPPropertyGridItemNumber Methods, CXTPPropertyGridItemNumber Constructors, CXTPPropertyGridItemNumber Destructors, CXTPPropertyGridItemNumber Constructors, CXTPPropertyGridItemNumber Data Members, CXTPPropertyGridItemNumber Destructors, CXTPPropertyGridItemNumber Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber Class

CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class. It is used to create an integer value item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemNumber : public CXTPPropertyGridItem;
File

XTPPropertyGridItemNumber.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridItemNumber Constructors
CXTPPropertyGridItemNumber Constructors | Description
CXTPPropertyGridItemNumber |
CXTPPropertyGridItemNumber Data Members
CXTPPropertyGridItemNumber Data Members | Description
m_nValue | Value of the item.
m_pBindNumber | Binded object.
CXTPPropertyGridItemNumber Destructors
CXTPPropertyGridItemNumber Destructors | Description
~CXTPPropertyGridItemNumber | Destroys a CXTPPropertyGridItemNumber object
CXTPPropertyGridItemNumber Methods
CXTPPropertyGridItemNumber Methods | Description
BindToNumber | Call this method to bind an item to a long value.
GetNumber | Call this method to get the integer value of the item.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
SetNumber | Call this method to change the item's value.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.


CXTPPropertyGridItemNumber Data Members

CXTPPropertyGridItemNumber Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber Data Members
Class

CXTPPropertyGridItemNumber Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nValue | Value of the item.
m_pBindNumber | Binded object.


CXTPPropertyGridItemNumber::m_nValue Data Member

CXTPPropertyGridItemNumber Data Members, CXTPPropertyGridItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::m_nValue Data Member

Value of the item.

long m_nValue;
Group

CXTPPropertyGridItemNumber Data Members


CXTPPropertyGridItemNumber::m_pBindNumber Data Member

CXTPPropertyGridItemNumber Data Members, CXTPPropertyGridItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::m_pBindNumber Data Member

Binded object.

long* m_pBindNumber;
Group

CXTPPropertyGridItemNumber Data Members


CXTPPropertyGridItemNumber Methods

CXTPPropertyGridItemNumber Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber Methods
Class

CXTPPropertyGridItemNumber Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
SetValue | Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.
Public Methods
Public Methods
Public Method | Description
BindToNumber | Call this method to bind an item to a long value.
GetNumber | Call this method to get the integer value of the item.
SetNumber | Call this method to change the item's value.


CXTPPropertyGridItemNumber::BindToNumber Method

CXTPPropertyGridItemNumber Methods, CXTPPropertyGridItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::BindToNumber Method

Call this method to bind an item to a long value.

virtual void BindToNumber(
    long* pBindNumber
);
Parameters

pBindNumber
Long value to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToNumber member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItemNumber Methods


CXTPPropertyGridItemNumber::GetNumber Method

CXTPPropertyGridItemNumber Methods, CXTPPropertyGridItemNumber Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::GetNumber Method

Call this method to get the integer value of the item.

virtual long GetNumber() const;
Returns

The integer value of the item.

Body Source
long CXTPPropertyGridItemNumber::GetNumber() const {
    return m_nValue;
}
Group

CXTPPropertyGridItemNumber Methods


CXTPPropertyGridItemNumber::OnBeforeInsert Method

CXTPPropertyGridItemNumber Methods, CXTPPropertyGridItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItemNumber Methods


CXTPPropertyGridItemNumber::SetNumber Method

CXTPPropertyGridItemNumber Methods, CXTPPropertyGridItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::SetNumber Method

Call this method to change the item's value.

virtual void SetNumber(
    long nValue
);
Parameters

nValue
The new integer value of the item.

Group

CXTPPropertyGridItemNumber Methods


CXTPPropertyGridItemNumber::SetValue Method

CXTPPropertyGridItemNumber Methods, CXTPPropertyGridItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::SetValue Method

Call this method to change an item's value. Override this method to add new functionality. You should call the base class version of this function from your override.

virtual void SetValue(
    CString strValue
);
Parameters

strValue
New value of the item.

Group

CXTPPropertyGridItemNumber Methods


CXTPPropertyGridItemNumber Constructors

CXTPPropertyGridItemNumber Class, Legend, Public Methods
CXTPPropertyGridItemNumber Constructors
Class

CXTPPropertyGridItemNumber Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemNumber |


CXTPPropertyGridItemNumber Constructor

CXTPPropertyGridItemNumber Constructors
CXTPPropertyGridItemNumber Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemNumber::CXTPPropertyGridItemNumber (LPCTSTR, long, long*) | Constructs a CXTPPropertyGridItemNumber object
CXTPPropertyGridItemNumber::CXTPPropertyGridItemNumber (UINT, long, long*) | Constructs a CXTPPropertyGridItemNumber object
Group

CXTPPropertyGridItemNumber Constructors


CXTPPropertyGridItemNumber::CXTPPropertyGridItemNumber Constructor (LPCTSTR, long, long*)

CXTPPropertyGridItemNumber Constructor, CXTPPropertyGridItemNumber Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::CXTPPropertyGridItemNumber Constructor (LPCTSTR, long, long*)

Constructs a CXTPPropertyGridItemNumber object

CXTPPropertyGridItemNumber(
    LPCTSTR strCaption,
    long nValue = 0,
    long* pBindNumber = NULL
);
CXTPPropertyGridItemNumber(
    UINT nID,
    long nValue = 0,
    long* pBindNumber = NULL
);
Parameters

strCaption
Caption of the item.
nValue
Initial value of item.
pBindNumber
If not NULL, then the value of this item is bound the value of this variable.
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItemNumber has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToNumber member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See Also

BindToNumber

Group

CXTPPropertyGridItemNumber Constructor


CXTPPropertyGridItemNumber Destructors

CXTPPropertyGridItemNumber Class, Legend, Public Methods
CXTPPropertyGridItemNumber Destructors
Class

CXTPPropertyGridItemNumber Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItemNumber | Destroys a CXTPPropertyGridItemNumber object


CXTPPropertyGridItemNumber::~CXTPPropertyGridItemNumber Destructor

CXTPPropertyGridItemNumber Destructors, CXTPPropertyGridItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemNumber::~CXTPPropertyGridItemNumber Destructor

Destroys a CXTPPropertyGridItemNumber object

virtual ~CXTPPropertyGridItemNumber();
Group

CXTPPropertyGridItemNumber Destructors


CXTPPropertyGridItems Class

XTPPropertyGridItem.h, Classes, Legend, Members, Topics, CXTPPropertyGridItems Methods, CXTPPropertyGridItems Constructors, CXTPPropertyGridItems Constructors, CXTPPropertyGridItems Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItems Class

CXTPPropertyGridItems is a CList derived class. It represents the items collection with some internal functionality.

Class Hierarchy

class CXTPPropertyGridItems;
File

XTPPropertyGridItem.h

Group

Classes

Legend
Method
protected
CXTPPropertyGridItems Constructors
CXTPPropertyGridItems Constructors | Description
CXTPPropertyGridItems | Constructs a CXTPPropertyGridItems object.
CXTPPropertyGridItems Methods
CXTPPropertyGridItems Methods | Description
AddTail |
Clear | Call this member to clear all the items in a list.
Find | Call this member to determine the index of a CXTPPropertyGridItem.
FindItem |
GetAt | Call this member to get an item by its index.
GetCount | Call this member to get count of the items in a list.
InsertAt | This member is called to insert a CXTPPropertyGridItem object into the collections of items at a specific location specified by nIndex.
IsEmpty | Call this member to determine if any items have been added to the property grid.
RemoveAt | Call this member to remove an item by its index.
Sort | This member sorts the collection of items in alphabetical order.


CXTPPropertyGridItems Methods

CXTPPropertyGridItems Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItems Methods
Class

CXTPPropertyGridItems Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
AddTail |
InsertAt | This member is called to insert a CXTPPropertyGridItem object into the collections of items at a specific location specified by nIndex.
Public Methods
Public Methods
Public Method | Description
Clear | Call this member to clear all the items in a list.
Find | Call this member to determine the index of a CXTPPropertyGridItem.
FindItem |
GetAt | Call this member to get an item by its index.
GetCount | Call this member to get count of the items in a list.
IsEmpty | Call this member to determine if any items have been added to the property grid.
RemoveAt | Call this member to remove an item by its index.
Sort | This member sorts the collection of items in alphabetical order.


AddTail Method

CXTPPropertyGridItems Methods
AddTail Method
Overload List
Methods
Method | Description
CXTPPropertyGridItems::AddTail (CXTPPropertyGridItem*) | This member adds a new item to the end (tail) of the Property Grid's collection of items. The collection can be empty before the operation.
CXTPPropertyGridItems::AddTail (CXTPPropertyGridItems*) | This member adds a new item to the end (tail) of the Property Grid's collection of items. The collection can be empty before the operation.
Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems::AddTail Method (CXTPPropertyGridItem*)

AddTail Method, CXTPPropertyGridItems Class, Body Source
CXTPPropertyGridItems::AddTail Method (CXTPPropertyGridItem*)

This member adds a new item to the end (tail) of the Property Grid's collection of items. The collection can be empty before the operation.

void AddTail(
    CXTPPropertyGridItem* pItem
);
void AddTail(
    CXTPPropertyGridItems* pItems
);
Parameters

pItem
Pointer to the CXTPPropertyGridItem to add to the collection.
pItems
Pointer to the collection of CXTPPropertyGridItems to add to the collection.

Remarks

The pItems version adds a collection of items to the end (tail) of the Property Grid's collection of items. The collection can be empty before the operation.

Body Source
void CXTPPropertyGridItems::AddTail(CXTPPropertyGridItem* pItem) {
    m_arrItems.Add(pItem);
}
Group

AddTail Method


CXTPPropertyGridItems::Clear Method

CXTPPropertyGridItems Methods, CXTPPropertyGridItems Class
CXTPPropertyGridItems::Clear Method

Call this member to clear all the items in a list.

void Clear();
Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems::Find Method

CXTPPropertyGridItems Methods, CXTPPropertyGridItems Class
CXTPPropertyGridItems::Find Method

Call this member to determine the index of a CXTPPropertyGridItem.

int Find(
    CXTPPropertyGridItem* pItem
) const;
Parameters

pItem
Pointer to the CXTPPropertyGridItem you want to know the index of.

Returns

The index of the item within the collection of items, -1 if the item is not found.

Group

CXTPPropertyGridItems Methods


FindItem Method

CXTPPropertyGridItems Methods
FindItem Method
Overload List
Methods
Method | Description
CXTPPropertyGridItems::FindItem (LPCTSTR) | Call this member function to find an item.
CXTPPropertyGridItems::FindItem (UINT) | Call this member function to find an item.
Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems::FindItem Method (UINT)

FindItem Method, CXTPPropertyGridItems Class
CXTPPropertyGridItems::FindItem Method (UINT)

Call this member function to find an item.

CXTPPropertyGridItem* FindItem(
    UINT nID
) const;
CXTPPropertyGridItem* FindItem(
    LPCTSTR strCaption
) const;
Parameters

nID
Identifier for the item to find.
strCaption
Caption for the item to find.

Returns

A pointer to a CXTPPropertyGridItem object or NULL if item was not found.

Group

FindItem Method


CXTPPropertyGridItems::GetAt Method

CXTPPropertyGridItems Methods, CXTPPropertyGridItems Class
CXTPPropertyGridItems::GetAt Method

Call this member to get an item by its index.

CXTPPropertyGridItem* GetAt(
    int nIndex
) const;
Parameters

nIndex
Item's index.

Returns

A pointer to a CXTPPropertyGridItem object.

Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems::GetCount Method

CXTPPropertyGridItems Methods, CXTPPropertyGridItems Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItems::GetCount Method

Call this member to get count of the items in a list.

long GetCount() const;
Returns

Count of the items in a list.

Body Source
long CXTPPropertyGridItems::GetCount() const {
    return (long)m_arrItems.GetSize();
}
Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems::InsertAt Method

CXTPPropertyGridItems Methods, CXTPPropertyGridItems Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItems::InsertAt Method

This member is called to insert a CXTPPropertyGridItem object into the collections of items at a specific location specified by nIndex.

void InsertAt(
    int nIndex,
    CXTPPropertyGridItem* pItem
);
Parameters

nIndex
Position in the collection of items to insert pItem.
pItem
Pointer to the CXTPPropertyGridItem to add to the collection.

Body Source
void CXTPPropertyGridItems::InsertAt(int nIndex, CXTPPropertyGridItem* pItem) {
    m_arrItems.InsertAt(nIndex, pItem);
}
Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems::IsEmpty Method

CXTPPropertyGridItems Methods, CXTPPropertyGridItems Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItems::IsEmpty Method

Call this member to determine if any items have been added to the property grid.

BOOL IsEmpty() const;
Returns

TRUE if there are no items in the grid, FALSE if at least one item has been added to the grid.

Body Source
BOOL CXTPPropertyGridItems::IsEmpty() const {
    return GetCount() == 0;
}
Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems::RemoveAt Method

CXTPPropertyGridItems Methods, CXTPPropertyGridItems Class
CXTPPropertyGridItems::RemoveAt Method

Call this member to remove an item by its index.

void RemoveAt(
    int nIndex
);
Parameters

nIndex
Item's index.

Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems::Sort Method

CXTPPropertyGridItems Methods, CXTPPropertyGridItems Class
CXTPPropertyGridItems::Sort Method

This member sorts the collection of items in alphabetical order.

void Sort();
Remarks

This method uses Visual C++ run-time library (MSVCRT) implementation of the quick-sort function, qsort, for sorting stored CXTPPropertyGridItem objects.

Group

CXTPPropertyGridItems Methods


CXTPPropertyGridItems Constructors

CXTPPropertyGridItems Class, Legend, Protected Methods
CXTPPropertyGridItems Constructors
Class

CXTPPropertyGridItems Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPPropertyGridItems | Constructs a CXTPPropertyGridItems object.


CXTPPropertyGridItems::CXTPPropertyGridItems Constructor

CXTPPropertyGridItems Constructors, CXTPPropertyGridItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItems::CXTPPropertyGridItems Constructor

Constructs a CXTPPropertyGridItems object.

CXTPPropertyGridItems();
Group

CXTPPropertyGridItems Constructors


CXTPPropertyGridItemSize Class

XTPPropertyGridItemSize.h, Classes, Legend, Members, Topics, CXTPPropertyGridItemSize Methods, CXTPPropertyGridItemSize Constructors, CXTPPropertyGridItemSize Destructors, CXTPPropertyGridItemSize Constructors, CXTPPropertyGridItemSize Destructors, CXTPPropertyGridItemSize Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemSize Class

CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class. It is used to create a size value item in a Property Grid control.

Class Hierarchy

class CXTPPropertyGridItemSize : public CXTPPropertyGridItem;
File

XTPPropertyGridItemSize.h

Group

Classes

Legend
Method
virtual
protected
CXTPPropertyGridItemSize Constructors
CXTPPropertyGridItemSize Constructors | Description
CXTPPropertyGridItemSize |
CXTPPropertyGridItemSize Destructors
CXTPPropertyGridItemSize Destructors | Description
~CXTPPropertyGridItemSize | Destroys a CXTPPropertyGridItemSize object.
CXTPPropertyGridItemSize Methods
CXTPPropertyGridItemSize Methods | Description
BindToSize | Call this method to bind an item to a CSize object.
GetSize | Call this method to get the size value of the item.
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
SetSize | Call this method to change the item's value.


CXTPPropertyGridItemSize Methods

CXTPPropertyGridItemSize Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemSize Methods
Class

CXTPPropertyGridItemSize Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnBeforeInsert | This member is called before the item becomes visible in the property grid.
Public Methods
Public Methods
Public Method | Description
BindToSize | Call this method to bind an item to a CSize object.
GetSize | Call this method to get the size value of the item.
SetSize | Call this method to change the item's value.


CXTPPropertyGridItemSize::BindToSize Method

CXTPPropertyGridItemSize Methods, CXTPPropertyGridItemSize Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemSize::BindToSize Method

Call this method to bind an item to a CSize object.

virtual void BindToSize(
    CSize* pBindSize
);
Parameters

pBindSize
CSize object to bind to item.

Remarks

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToSize member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

Group

CXTPPropertyGridItemSize Methods


CXTPPropertyGridItemSize::GetSize Method

CXTPPropertyGridItemSize Methods, CXTPPropertyGridItemSize Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemSize::GetSize Method

Call this method to get the size value of the item.

virtual CSize GetSize() const;
Returns

A CSize object representing the size value of the item.

Body Source
CSize CXTPPropertyGridItemSize::GetSize() const {
    return m_szValue;
}
Group

CXTPPropertyGridItemSize Methods


CXTPPropertyGridItemSize::OnBeforeInsert Method

CXTPPropertyGridItemSize Methods, CXTPPropertyGridItemSize Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemSize::OnBeforeInsert Method

This member is called before the item becomes visible in the property grid.

virtual void OnBeforeInsert();
Remarks

Before the item is inserted, it is first check to see if it is bound to a variable, if it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Group

CXTPPropertyGridItemSize Methods


CXTPPropertyGridItemSize::SetSize Method

CXTPPropertyGridItemSize Methods, CXTPPropertyGridItemSize Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemSize::SetSize Method

Call this method to change the item's value.

virtual void SetSize(
    CSize size
);
Parameters

size
The new size value of the item.

Group

CXTPPropertyGridItemSize Methods


CXTPPropertyGridItemSize Constructors

CXTPPropertyGridItemSize Class, Legend, Public Methods
CXTPPropertyGridItemSize Constructors
Class

CXTPPropertyGridItemSize Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemSize |


CXTPPropertyGridItemSize Constructor

CXTPPropertyGridItemSize Constructors
CXTPPropertyGridItemSize Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyGridItemSize::CXTPPropertyGridItemSize (LPCTSTR, CSize, CSize*) | Constructs a CXTPPropertyGridItemSize object.
CXTPPropertyGridItemSize::CXTPPropertyGridItemSize (UINT, CSize, CSize*) | Constructs a CXTPPropertyGridItemSize object.
Group

CXTPPropertyGridItemSize Constructors


CXTPPropertyGridItemSize::CXTPPropertyGridItemSize Constructor (LPCTSTR, CSize, CSize*)

CXTPPropertyGridItemSize Constructor, CXTPPropertyGridItemSize Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemSize::CXTPPropertyGridItemSize Constructor (LPCTSTR, CSize, CSize*)

Constructs a CXTPPropertyGridItemSize object.

CXTPPropertyGridItemSize(
    LPCTSTR strCaption,
    CSize size = 0,
    CSize* pBindSize = NULL
);
CXTPPropertyGridItemSize(
    UINT nID,
    CSize size = 0,
    CSize* pBindSize = NULL
);
Parameters

strCaption
Caption of the item.
size
Initial value of item.
pBindSize
If not NULL, then the value of this item is bound the value of this variable.
nID
Identifier of the item.

Remarks

Class CXTPPropertyGridItemSize has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToSize member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

Notes

If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See Also

BindToSize

Group

CXTPPropertyGridItemSize Constructor


CXTPPropertyGridItemSize Destructors

CXTPPropertyGridItemSize Class, Legend, Public Methods
CXTPPropertyGridItemSize Destructors
Class

CXTPPropertyGridItemSize Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridItemSize | Destroys a CXTPPropertyGridItemSize object.


CXTPPropertyGridItemSize::~CXTPPropertyGridItemSize Destructor

CXTPPropertyGridItemSize Destructors, CXTPPropertyGridItemSize Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridItemSize::~CXTPPropertyGridItemSize Destructor

Destroys a CXTPPropertyGridItemSize object.

virtual ~CXTPPropertyGridItemSize();
Group

CXTPPropertyGridItemSize Destructors


CXTPPropertyGridNativeXPTheme Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridNativeXPTheme Methods, CXTPPropertyGridNativeXPTheme Constructors, CXTPPropertyGridNativeXPTheme Constructors, CXTPPropertyGridNativeXPTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridNativeXPTheme Class

CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Native Windows XP style theme.

Class Hierarchy

class CXTPPropertyGridNativeXPTheme : public CXTPPropertyGridPaintManager;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Method
virtual
CXTPPropertyGridNativeXPTheme Constructors
CXTPPropertyGridNativeXPTheme Constructors | Description
CXTPPropertyGridNativeXPTheme | Constructs a CXTPPropertyGridNativeXPTheme object.
CXTPPropertyGridNativeXPTheme Methods
CXTPPropertyGridNativeXPTheme Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridNativeXPTheme Methods

CXTPPropertyGridNativeXPTheme Class, Legend, Public Methods
CXTPPropertyGridNativeXPTheme Methods
Class

CXTPPropertyGridNativeXPTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridNativeXPTheme::RefreshMetrics Method

CXTPPropertyGridNativeXPTheme Methods, CXTPPropertyGridNativeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridNativeXPTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the property grid.

virtual void RefreshMetrics();
Group

CXTPPropertyGridNativeXPTheme Methods


CXTPPropertyGridNativeXPTheme Constructors

CXTPPropertyGridNativeXPTheme Class, Legend, Public Methods
CXTPPropertyGridNativeXPTheme Constructors
Class

CXTPPropertyGridNativeXPTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridNativeXPTheme | Constructs a CXTPPropertyGridNativeXPTheme object.


CXTPPropertyGridNativeXPTheme::CXTPPropertyGridNativeXPTheme Constructor

CXTPPropertyGridNativeXPTheme Constructors, CXTPPropertyGridNativeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridNativeXPTheme::CXTPPropertyGridNativeXPTheme Constructor

Constructs a CXTPPropertyGridNativeXPTheme object.

CXTPPropertyGridNativeXPTheme(
    CXTPPropertyGrid* pGrid
);
Parameters

pGrid
Points to a CXTPPropertyGrid object

Group

CXTPPropertyGridNativeXPTheme Constructors


CXTPPropertyGridOffice2003Theme Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridOffice2003Theme Data Members, CXTPPropertyGridOffice2003Theme Methods, CXTPPropertyGridOffice2003Theme Constructors, CXTPPropertyGridOffice2003Theme Constructors, CXTPPropertyGridOffice2003Theme Data Members, CXTPPropertyGridOffice2003Theme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOffice2003Theme Class

CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class. This represents an Office 2003 style theme.

Class Hierarchy

class CXTPPropertyGridOffice2003Theme : public CXTPPropertyGridPaintManager;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridOffice2003Theme Constructors
CXTPPropertyGridOffice2003Theme Constructors | Description
CXTPPropertyGridOffice2003Theme | Constructs a CXTPPropertyGridOffice2003Theme object.
CXTPPropertyGridOffice2003Theme Data Members
CXTPPropertyGridOffice2003Theme Data Members | Description
m_bLunaTheme | TRUE to use luna colors, FALSE otherwise
CXTPPropertyGridOffice2003Theme Methods
CXTPPropertyGridOffice2003Theme Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridOffice2003Theme Data Members

CXTPPropertyGridOffice2003Theme Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOffice2003Theme Data Members
Class

CXTPPropertyGridOffice2003Theme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bLunaTheme | TRUE to use luna colors, FALSE otherwise


CXTPPropertyGridOffice2003Theme::m_bLunaTheme Data Member

CXTPPropertyGridOffice2003Theme Data Members, CXTPPropertyGridOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOffice2003Theme::m_bLunaTheme Data Member

TRUE to use luna colors, FALSE otherwise

BOOL m_bLunaTheme;
Group

CXTPPropertyGridOffice2003Theme Data Members


CXTPPropertyGridOffice2003Theme Methods

CXTPPropertyGridOffice2003Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOffice2003Theme Methods
Class

CXTPPropertyGridOffice2003Theme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridOffice2003Theme::RefreshMetrics Method

CXTPPropertyGridOffice2003Theme Methods, CXTPPropertyGridOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOffice2003Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of the property grid.

virtual void RefreshMetrics();
Group

CXTPPropertyGridOffice2003Theme Methods


CXTPPropertyGridOffice2003Theme Constructors

CXTPPropertyGridOffice2003Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOffice2003Theme Constructors
Class

CXTPPropertyGridOffice2003Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridOffice2003Theme | Constructs a CXTPPropertyGridOffice2003Theme object.


CXTPPropertyGridOffice2003Theme::CXTPPropertyGridOffice2003Theme Constructor

CXTPPropertyGridOffice2003Theme Constructors, CXTPPropertyGridOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOffice2003Theme::CXTPPropertyGridOffice2003Theme Constructor

Constructs a CXTPPropertyGridOffice2003Theme object.

CXTPPropertyGridOffice2003Theme(
    CXTPPropertyGrid* pGrid
);
Parameters

pGrid
Points to a CXTPPropertyGrid object

Group

CXTPPropertyGridOffice2003Theme Constructors


CXTPPropertyGridOfficeXPTheme Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridOfficeXPTheme Methods, CXTPPropertyGridOfficeXPTheme Constructors, CXTPPropertyGridOfficeXPTheme Constructors, CXTPPropertyGridOfficeXPTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOfficeXPTheme Class

CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Office XP style theme.

Class Hierarchy

class CXTPPropertyGridOfficeXPTheme : public CXTPPropertyGridPaintManager;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Method
CXTPPropertyGridOfficeXPTheme Constructors
CXTPPropertyGridOfficeXPTheme Constructors | Description
CXTPPropertyGridOfficeXPTheme | Constructs a CXTPPropertyGridOfficeXPTheme object.
CXTPPropertyGridOfficeXPTheme Methods
CXTPPropertyGridOfficeXPTheme Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridOfficeXPTheme Methods

CXTPPropertyGridOfficeXPTheme Class, Legend, Public Methods
CXTPPropertyGridOfficeXPTheme Methods
Class

CXTPPropertyGridOfficeXPTheme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridOfficeXPTheme::RefreshMetrics Method

CXTPPropertyGridOfficeXPTheme Methods, CXTPPropertyGridOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOfficeXPTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the property grid.

void RefreshMetrics();
Group

CXTPPropertyGridOfficeXPTheme Methods


CXTPPropertyGridOfficeXPTheme Constructors

CXTPPropertyGridOfficeXPTheme Class, Legend, Public Methods
CXTPPropertyGridOfficeXPTheme Constructors
Class

CXTPPropertyGridOfficeXPTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridOfficeXPTheme | Constructs a CXTPPropertyGridOfficeXPTheme object.


CXTPPropertyGridOfficeXPTheme::CXTPPropertyGridOfficeXPTheme Constructor

CXTPPropertyGridOfficeXPTheme Constructors, CXTPPropertyGridOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridOfficeXPTheme::CXTPPropertyGridOfficeXPTheme Constructor

Constructs a CXTPPropertyGridOfficeXPTheme object.

CXTPPropertyGridOfficeXPTheme(
    CXTPPropertyGrid* pGrid
);
Parameters

pGrid
Points to a CXTPPropertyGrid object

Group

CXTPPropertyGridOfficeXPTheme Constructors


CXTPPropertyGridPaintManager Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Constructors, CXTPPropertyGridPaintManager Destructors, CXTPPropertyGridPaintManager Constructors, CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Destructors, CXTPPropertyGridPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager Class

Standalone class used by CXTPPropertyGrid as the paint manager.

Class Hierarchy

class CXTPPropertyGridPaintManager;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridPaintManager Constructors
CXTPPropertyGridPaintManager Constructors | Description
CXTPPropertyGridPaintManager | Constructs a CXTPPropertyGridPaintManager object.
CXTPPropertyGridPaintManager Data Members
CXTPPropertyGridPaintManager Data Members | Description
m_bTransparent | TRUE to draw background with parent color
m_buttonsStyle | TRUE to use WinXP themes.
m_clrFace | Face color.
m_clrHighlight | Highlight color.
m_clrHighlightText | Highlight text color.
m_clrShadow | Shadow color.
m_fntVerbNormal | Font used to display the caption of verbs without underline
m_fntVerbUnderline | Font used to display the caption of verbs with underline
m_pGrid | Parent grid class.
m_pMetrics | Default metrics of the item
m_themeButton | Themes for button controls
m_themeCombo | Themes for combo button.
m_themeTree | Themes for Tree controls.
CXTPPropertyGridPaintManager Destructors
CXTPPropertyGridPaintManager Destructors | Description
~CXTPPropertyGridPaintManager | Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
CXTPPropertyGridPaintManager Methods
CXTPPropertyGridPaintManager Methods | Description
AdjustItemCaptionRect | This method is called to get rectangle of caption part of the item.
AdjustItemValueRect | This method is called to get rectangle of value part of the item.
DrawCategoryCaptionBackground | This member is called to draw the bounding rectangle for a category caption.
DrawExpandButton | This method is called to draw expand buttons of the grid.
DrawInplaceButtons | This method is called to draw inplace buttons if the item
DrawInplaceListItem | This method is called to draw specified constraint in in-place list.
DrawItem | This method is called to draw single item of the grid.
DrawItemCaption | This method is called to draw caption part of the property grid item
DrawItemValue | This method is called to draw value part of the property grid item
DrawPropertyGridBorder | This method is called to draw grid borders
FillInplaceButton | This method is called to draw in-place button of the grid.
FillPropertyGrid | This method is called to draw property grid background.
FillPropertyGridView | This method is called to draw view background.
GetItemBackColor | This method is called to get item back color
GetItemFont | This method is called to get item font
GetItemMetrics | Retrieves default item metrics
GetItemTextColor | This method is called to get item text color
HitTestVerbs | Call this member to determine if a verb is at a specific point.
MeasureItem | Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
RefreshMetrics | This method is called to refresh the visual metrics of manager.


CXTPPropertyGridPaintManager Data Members

CXTPPropertyGridPaintManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager Data Members
Class

CXTPPropertyGridPaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_fntVerbNormal | Font used to display the caption of verbs without underline
m_fntVerbUnderline | Font used to display the caption of verbs with underline
m_pGrid | Parent grid class.
m_pMetrics | Default metrics of the item
Public Data Members
Public Data Member | Description
m_bTransparent | TRUE to draw background with parent color
m_buttonsStyle | TRUE to use WinXP themes.
m_clrFace | Face color.
m_clrHighlight | Highlight color.
m_clrHighlightText | Highlight text color.
m_clrShadow | Shadow color.
m_themeButton | Themes for button controls
m_themeCombo | Themes for combo button.
m_themeTree | Themes for Tree controls.


CXTPPropertyGridPaintManager::m_bTransparent Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_bTransparent Data Member

TRUE to draw background with parent color

BOOL m_bTransparent;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_buttonsStyle Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_buttonsStyle Data Member

TRUE to use WinXP themes.

XTPPropertyGridInplaceButtonsStyle m_buttonsStyle;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_clrFace Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_clrFace Data Member

Face color.

CXTPPaintManagerColor m_clrFace;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_clrHighlight Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_clrHighlight Data Member

Highlight color.

CXTPPaintManagerColor m_clrHighlight;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_clrHighlightText Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_clrHighlightText Data Member

Highlight text color.

CXTPPaintManagerColor m_clrHighlightText;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_clrShadow Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_clrShadow Data Member

Shadow color.

CXTPPaintManagerColor m_clrShadow;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_fntVerbNormal Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_fntVerbNormal Data Member

Font used to display the caption of verbs without underline

CFont m_fntVerbNormal;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_fntVerbUnderline Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_fntVerbUnderline Data Member

Font used to display the caption of verbs with underline

CFont m_fntVerbUnderline;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_pGrid Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_pGrid Data Member

Parent grid class.

CXTPPropertyGrid* m_pGrid;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_pMetrics Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_pMetrics Data Member

Default metrics of the item

CXTPPropertyGridItemMetrics* m_pMetrics;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_themeButton Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_themeButton Data Member

Themes for button controls

CXTPWinThemeWrapper m_themeButton;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_themeCombo Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_themeCombo Data Member

Themes for combo button.

CXTPWinThemeWrapper m_themeCombo;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager::m_themeTree Data Member

CXTPPropertyGridPaintManager Data Members, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::m_themeTree Data Member

Themes for Tree controls.

CXTPWinThemeWrapper m_themeTree;
Group

CXTPPropertyGridPaintManager Data Members


CXTPPropertyGridPaintManager Methods

CXTPPropertyGridPaintManager Class, Legend, Public Methods
CXTPPropertyGridPaintManager Methods
Class

CXTPPropertyGridPaintManager Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AdjustItemCaptionRect | This method is called to get rectangle of caption part of the item.
AdjustItemValueRect | This method is called to get rectangle of value part of the item.
DrawCategoryCaptionBackground | This member is called to draw the bounding rectangle for a category caption.
DrawExpandButton | This method is called to draw expand buttons of the grid.
DrawInplaceButtons | This method is called to draw inplace buttons if the item
DrawInplaceListItem | This method is called to draw specified constraint in in-place list.
DrawItem | This method is called to draw single item of the grid.
DrawItemCaption | This method is called to draw caption part of the property grid item
DrawItemValue | This method is called to draw value part of the property grid item
DrawPropertyGridBorder | This method is called to draw grid borders
FillInplaceButton | This method is called to draw in-place button of the grid.
FillPropertyGrid | This method is called to draw property grid background.
FillPropertyGridView | This method is called to draw view background.
GetItemBackColor | This method is called to get item back color
GetItemFont | This method is called to get item font
GetItemMetrics | Retrieves default item metrics
GetItemTextColor | This method is called to get item text color
HitTestVerbs | Call this member to determine if a verb is at a specific point.
MeasureItem | Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
RefreshMetrics | This method is called to refresh the visual metrics of manager.


CXTPPropertyGridPaintManager::AdjustItemCaptionRect Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::AdjustItemCaptionRect Method

This method is called to get rectangle of caption part of the item.

virtual void AdjustItemCaptionRect(
    CXTPPropertyGridItem* pItem,
    CRect& rcCaption
);
Parameters

pItem
Property Grid item
rcCaption
Rectangle of the caption part

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::AdjustItemValueRect Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::AdjustItemValueRect Method

This method is called to get rectangle of value part of the item.

virtual void AdjustItemValueRect(
    CXTPPropertyGridItem* pItem,
    CRect& rcValue
);
Parameters

pItem
Property Grid item
rcValue
Rectangle of the value part

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::DrawCategoryCaptionBackground Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::DrawCategoryCaptionBackground Method

This member is called to draw the bounding rectangle for a category caption.

virtual void DrawCategoryCaptionBackground(
    CDC* pDC,
    CXTPPropertyGridItem* pItem,
    CRect rc
);
Parameters

pDC
Reference to a valid device context
rc
Bounding rectangle of Category's caption.

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::DrawExpandButton Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::DrawExpandButton Method

This method is called to draw expand buttons of the grid.

virtual void DrawExpandButton(
    CDC& dc,
    CXTPPropertyGridItem* pItem,
    CRect rcCaption
);
Parameters

dc
Reference to a valid device context
pItem
Points to a CXTPPropertyGridItem object
rcCaption
Caption button rectangle.

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::DrawInplaceButtons Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::DrawInplaceButtons Method

This method is called to draw inplace buttons if the item

virtual void DrawInplaceButtons(
    CDC* pDC,
    CXTPPropertyGridItem* pItem,
    CRect rcValue
);
Parameters

pDC
Pointer to a valid device context
pItem
Property Grid item to draw
rcValue
Value bounding rectangle

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::DrawInplaceListItem Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::DrawInplaceListItem Method

This method is called to draw specified constraint in in-place list.

virtual void DrawInplaceListItem(
    CDC* pDC,
    CXTPPropertyGridItemConstraint* pConstraint,
    CRect rc,
    BOOL bSelected
);
Parameters

pDC
Pointer to a valid device context
pConstraint
Constraint to draw.
rc
Bounding rectangle of the constraint
bSelected
TRUE if constraint is currently selected.

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::DrawItem Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::DrawItem Method

This method is called to draw single item of the grid.

virtual void DrawItem(
    PDRAWITEMSTRUCT lpDrawItemStruct
);
Parameters

lpDrawItemStruct
A long pointer to a DRAWITEMSTRUCT structure that contains information about the type of drawing required.

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::DrawItemCaption Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::DrawItemCaption Method

This method is called to draw caption part of the property grid item

virtual void DrawItemCaption(
    CDC* pDC,
    CXTPPropertyGridItem* pItem,
    CRect rcCaption
);
Parameters

pDC
Pointer to a valid device context
pItem
Property Grid item to draw
rcCaption
Bounding rectangle of the caption part

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::DrawItemValue Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::DrawItemValue Method

This method is called to draw value part of the property grid item

virtual void DrawItemValue(
    CDC* pDC,
    CXTPPropertyGridItem* pItem,
    CRect rcValue
);
Parameters

pDC
Pointer to a valid device context
pItem
Property Grid item to draw
rcValue
Bounding rectangle of the value part

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::DrawPropertyGridBorder Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::DrawPropertyGridBorder Method

This method is called to draw grid borders

virtual void DrawPropertyGridBorder(
    CDC* pDC,
    RECT& rcBorder,
    BOOL bAdjustRect
);
Parameters

pDC
Pointer to a valid device context
rcBorder
Bounding rectangle
bAdjustRect
TURE to adjust bounding rectangle

See Also

FillPropertyGridView

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::FillInplaceButton Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::FillInplaceButton Method

This method is called to draw in-place button of the grid.

virtual void FillInplaceButton(
    CDC* pDC,
    CXTPPropertyGridInplaceButton* pButton
);
Parameters

pDC
Pointer to a valid device context
pButton
Points to a CXTPPropertyGridInplaceButton object

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::FillPropertyGrid Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::FillPropertyGrid Method

This method is called to draw property grid background.

virtual void FillPropertyGrid(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::FillPropertyGridView Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::FillPropertyGridView Method

This method is called to draw view background.

virtual void FillPropertyGridView(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::GetItemBackColor Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::GetItemBackColor Method

This method is called to get item back color

virtual COLORREF GetItemBackColor(
    CXTPPropertyGridItem* pItem,
    BOOL bValuePart
);
Parameters

pItem
Item which back color need to get
bValuePart
TRUE if value part color needed

Returns

COLORREF of item back.

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::GetItemFont Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::GetItemFont Method

This method is called to get item font

virtual CFont* GetItemFont(
    CXTPPropertyGridItem* pItem,
    BOOL bValuePart
);
Parameters

pItem
Item which font color need to get
bValuePart
TRUE if value part font needed

Returns

Pointer to CFont object containing font of the item

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::GetItemMetrics Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::GetItemMetrics Method

Retrieves default item metrics

CXTPPropertyGridItemMetrics* GetItemMetrics() const;
Returns

Call this method to get default item metrics

Body Source
CXTPPropertyGridItemMetrics* CXTPPropertyGridPaintManager::GetItemMetrics() const {
    return m_pMetrics;
}
Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::GetItemTextColor Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::GetItemTextColor Method

This method is called to get item text color

virtual COLORREF GetItemTextColor(
    CXTPPropertyGridItem* pItem,
    BOOL bValuePart
);
Parameters

pItem
Item which text color need to get
bValuePart
TRUE if value part color needed

Returns

COLORREF of item text.

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::HitTestVerbs Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::HitTestVerbs Method

Call this member to determine if a verb is at a specific point.

int HitTestVerbs(
    CDC* pDC,
    CRect rcVerbs,
    CPoint pt
);
Parameters

pDC
Reference to a valid device context
rcVerbs
Bounding rectangle of all verbs.
pt
Point to test.

Returns

Index of verb within collection if the point was on a verb, otherwise -1.

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::MeasureItem Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::MeasureItem Method

Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.

virtual void MeasureItem(
    LPMEASUREITEMSTRUCT lpMeasureItemStruct
);
Parameters

lpMeasureItemStruct
Specifies a long pointer to a MEASUREITEMSTRUCT structure.

Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager::RefreshMetrics Method

CXTPPropertyGridPaintManager Methods, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::RefreshMetrics Method

This method is called to refresh the visual metrics of manager.

virtual void RefreshMetrics();
Group

CXTPPropertyGridPaintManager Methods


CXTPPropertyGridPaintManager Constructors

CXTPPropertyGridPaintManager Class, Legend, Public Methods
CXTPPropertyGridPaintManager Constructors
Class

CXTPPropertyGridPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridPaintManager | Constructs a CXTPPropertyGridPaintManager object.


CXTPPropertyGridPaintManager::CXTPPropertyGridPaintManager Constructor

CXTPPropertyGridPaintManager Constructors, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::CXTPPropertyGridPaintManager Constructor

Constructs a CXTPPropertyGridPaintManager object.

CXTPPropertyGridPaintManager(
    CXTPPropertyGrid* pGrid
);
Parameters

pGrid
Points to a CXTPPropertyGrid object

Group

CXTPPropertyGridPaintManager Constructors


CXTPPropertyGridPaintManager Destructors

CXTPPropertyGridPaintManager Class, Legend, Public Methods
CXTPPropertyGridPaintManager Destructors
Class

CXTPPropertyGridPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridPaintManager | Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.


CXTPPropertyGridPaintManager::~CXTPPropertyGridPaintManager Destructor

CXTPPropertyGridPaintManager Destructors, CXTPPropertyGridPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridPaintManager::~CXTPPropertyGridPaintManager Destructor

Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.

virtual ~CXTPPropertyGridPaintManager();
Group

CXTPPropertyGridPaintManager Destructors


CXTPPropertyGridSimpleTheme Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridSimpleTheme Methods, CXTPPropertyGridSimpleTheme Constructors, CXTPPropertyGridSimpleTheme Constructors, CXTPPropertyGridSimpleTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridSimpleTheme Class

CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class. This represents a Simple style theme.

Class Hierarchy

class CXTPPropertyGridSimpleTheme : public CXTPPropertyGridPaintManager;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Method
virtual
CXTPPropertyGridSimpleTheme Constructors
CXTPPropertyGridSimpleTheme Constructors | Description
CXTPPropertyGridSimpleTheme | Constructs a CXTPPropertyGridSimpleTheme object.
CXTPPropertyGridSimpleTheme Methods
CXTPPropertyGridSimpleTheme Methods | Description
DrawItem | This method is called to draw single item of the grid.
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridSimpleTheme Methods

CXTPPropertyGridSimpleTheme Class, Legend, Public Methods
CXTPPropertyGridSimpleTheme Methods
Class

CXTPPropertyGridSimpleTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawItem | This method is called to draw single item of the grid.
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridSimpleTheme::DrawItem Method

CXTPPropertyGridSimpleTheme Methods, CXTPPropertyGridSimpleTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridSimpleTheme::DrawItem Method

This method is called to draw single item of the grid.

virtual void DrawItem(
    PDRAWITEMSTRUCT lpDrawItemStruct
);
Parameters

lpDrawItemStruct
A long pointer to a DRAWITEMSTRUCT structure that contains information about the type of drawing required.

Group

CXTPPropertyGridSimpleTheme Methods


CXTPPropertyGridSimpleTheme::RefreshMetrics Method

CXTPPropertyGridSimpleTheme Methods, CXTPPropertyGridSimpleTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridSimpleTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the property grid.

void RefreshMetrics();
Group

CXTPPropertyGridSimpleTheme Methods


CXTPPropertyGridSimpleTheme Constructors

CXTPPropertyGridSimpleTheme Class, Legend, Public Methods
CXTPPropertyGridSimpleTheme Constructors
Class

CXTPPropertyGridSimpleTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridSimpleTheme | Constructs a CXTPPropertyGridSimpleTheme object.


CXTPPropertyGridSimpleTheme::CXTPPropertyGridSimpleTheme Constructor

CXTPPropertyGridSimpleTheme Constructors, CXTPPropertyGridSimpleTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridSimpleTheme::CXTPPropertyGridSimpleTheme Constructor

Constructs a CXTPPropertyGridSimpleTheme object.

CXTPPropertyGridSimpleTheme(
    CXTPPropertyGrid* pGrid
);
Parameters

pGrid
Points to a CXTPPropertyGrid object

Group

CXTPPropertyGridSimpleTheme Constructors


CXTPPropertyGridToolBar Class

XTPPropertyGrid.h, Classes, Legend, Members, Topics, CXTPPropertyGridToolBar Constructors, CXTPPropertyGridToolBar Destructors, CXTPPropertyGridToolBar Constructors, CXTPPropertyGridToolBar Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolBar Class

CXTPPropertyGridToolBar is a CToolBar derived class. It is an internal class used by Property Grid control

Class Hierarchy

class CXTPPropertyGridToolBar : public CToolBar;
File

XTPPropertyGrid.h

Group

Classes

Legend
Constructor
CXTPPropertyGridToolBar Constructors
CXTPPropertyGridToolBar Constructors | Description
CXTPPropertyGridToolBar | Constructs a CXTPPropertyGridToolBar object
CXTPPropertyGridToolBar Destructors
CXTPPropertyGridToolBar Destructors | Description
~CXTPPropertyGridToolBar | Destroys a CXTPPropertyGridToolBar object, handles cleanup and deallocation.


CXTPPropertyGridToolBar Constructors

CXTPPropertyGridToolBar Class, Legend, Public Methods
CXTPPropertyGridToolBar Constructors
Class

CXTPPropertyGridToolBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridToolBar | Constructs a CXTPPropertyGridToolBar object


CXTPPropertyGridToolBar::CXTPPropertyGridToolBar Constructor

CXTPPropertyGridToolBar Constructors, CXTPPropertyGridToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolBar::CXTPPropertyGridToolBar Constructor

Constructs a CXTPPropertyGridToolBar object

CXTPPropertyGridToolBar();
Group

CXTPPropertyGridToolBar Constructors


CXTPPropertyGridToolBar Destructors

CXTPPropertyGridToolBar Class, Legend, Public Methods
CXTPPropertyGridToolBar Destructors
Class

CXTPPropertyGridToolBar Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridToolBar | Destroys a CXTPPropertyGridToolBar object, handles cleanup and deallocation.


CXTPPropertyGridToolBar::~CXTPPropertyGridToolBar Destructor

CXTPPropertyGridToolBar Destructors, CXTPPropertyGridToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolBar::~CXTPPropertyGridToolBar Destructor

Destroys a CXTPPropertyGridToolBar object, handles cleanup and deallocation.

~CXTPPropertyGridToolBar();
Group

CXTPPropertyGridToolBar Destructors


CXTPPropertyGridToolTip Class

XTPPropertyGridView.h, Classes, Legend, Members, Topics, CXTPPropertyGridToolTip Data Members, CXTPPropertyGridToolTip Methods, CXTPPropertyGridToolTip Constructors, CXTPPropertyGridToolTip Constructors, CXTPPropertyGridToolTip Data Members, CXTPPropertyGridToolTip Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolTip Class

CXTPPropertyGridToolTip is a CWnd derived class. It is an internal class used by Property Grid control

Class Hierarchy

class CXTPPropertyGridToolTip : public CWnd;
File

XTPPropertyGridView.h

Group

Classes

Legend
Data Member
protected
Method
CXTPPropertyGridToolTip Constructors
CXTPPropertyGridToolTip Constructors | Description
CXTPPropertyGridToolTip | Constructs a CXTPPropertyGridToolTip object
CXTPPropertyGridToolTip Data Members
CXTPPropertyGridToolTip Data Members | Description
m_fnt | Font used to display the tool tip
m_pGrid | Parent window.
CXTPPropertyGridToolTip Methods
CXTPPropertyGridToolTip Methods | Description
Activate | Activate Tooltip control.
Create | Creates Tooltip control.


CXTPPropertyGridToolTip Data Members

CXTPPropertyGridToolTip Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolTip Data Members
Class

CXTPPropertyGridToolTip Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_fnt | Font used to display the tool tip
m_pGrid | Parent window.


CXTPPropertyGridToolTip::m_fnt Data Member

CXTPPropertyGridToolTip Data Members, CXTPPropertyGridToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolTip::m_fnt Data Member

Font used to display the tool tip

CFont m_fnt;
Group

CXTPPropertyGridToolTip Data Members


CXTPPropertyGridToolTip::m_pGrid Data Member

CXTPPropertyGridToolTip Data Members, CXTPPropertyGridToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolTip::m_pGrid Data Member

Parent window.

CXTPPropertyGridView* m_pGrid;
Group

CXTPPropertyGridToolTip Data Members


CXTPPropertyGridToolTip Methods

CXTPPropertyGridToolTip Class, Legend, Public Methods
CXTPPropertyGridToolTip Methods
Class

CXTPPropertyGridToolTip Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Activate | Activate Tooltip control.
Create | Creates Tooltip control.


CXTPPropertyGridToolTip::Activate Method

CXTPPropertyGridToolTip Methods, CXTPPropertyGridToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolTip::Activate Method

Activate Tooltip control.

void Activate(
    BOOL bActive,
    CXTPPropertyGridItem* pItem,
    BOOL bValuePart
);
Parameters

bActive
TRUE to activate.
pItem
Item which tooltip to show
bValuePart
TRUE if tooltip of value part will be visible

Group

CXTPPropertyGridToolTip Methods


CXTPPropertyGridToolTip::Create Method

CXTPPropertyGridToolTip Methods, CXTPPropertyGridToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolTip::Create Method

Creates Tooltip control.

void Create(
    CXTPPropertyGridView* pParentWnd
);
Parameters

pParentWnd
Points to a CXTPPropertyGridView object.

Group

CXTPPropertyGridToolTip Methods


CXTPPropertyGridToolTip Constructors

CXTPPropertyGridToolTip Class, Legend, Public Methods
CXTPPropertyGridToolTip Constructors
Class

CXTPPropertyGridToolTip Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridToolTip | Constructs a CXTPPropertyGridToolTip object


CXTPPropertyGridToolTip::CXTPPropertyGridToolTip Constructor

CXTPPropertyGridToolTip Constructors, CXTPPropertyGridToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridToolTip::CXTPPropertyGridToolTip Constructor

Constructs a CXTPPropertyGridToolTip object

CXTPPropertyGridToolTip();
Group

CXTPPropertyGridToolTip Constructors


CXTPPropertyGridUpdateContext Class

XTPPropertyGrid.h, Classes, Legend, Members, Topics, CXTPPropertyGridUpdateContext Data Members, CXTPPropertyGridUpdateContext Methods, CXTPPropertyGridUpdateContext Constructors, CXTPPropertyGridUpdateContext Constructors, CXTPPropertyGridUpdateContext Data Members, CXTPPropertyGridUpdateContext Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridUpdateContext Class

CXTPPropertyGridUpdateContext is a CCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid. The property grid state information is stored in the CXTPPropertyGridUpdateContext object when CXTPPropertyGrid::BeginUpdate is called and after CXTPPropertyGrid::EndUpdate the expanding state of each item, selected item, and sort preference will be restored.

Class Hierarchy

class CXTPPropertyGridUpdateContext;
File

XTPPropertyGrid.h

Remarks

Each time you add a new item or category to the grid, The state of the grid is updated the grid is redrawn.

If you want to delete all items in the grid and then add allot of new items it will be quite slow. To do this, you would call BeginUpdate, then delete all the items. The property grid will be locked until you call EndUpdate.

It might be useful to call BeginWaitCursor to indicate that the grid is "busy" updating.

See Also

CXTPPropertyGrid::BeginUpdate, CXTPPropertyGrid::EndUpdate

Group

Classes

Legend
Data Member
protected
Method
CXTPPropertyGridUpdateContext Constructors
CXTPPropertyGridUpdateContext Constructors | Description
CXTPPropertyGridUpdateContext | Constructs a CXTPPropertyGridUpdateContext object.
CXTPPropertyGridUpdateContext Data Members
CXTPPropertyGridUpdateContext Data Members | Description
m_mapState | Stores the expanded state of each item in the grid before CXTPPropertyGrid::BeginUpdate.
m_nSelected | Stores the Id of the currently selected item before CXTPPropertyGrid::BeginUpdate.
m_nTopIndex | Stores the Index of the top-most visible item in the property grid.
m_propertySort | Stores the currently used sort method of the grid before CXTPPropertyGrid::BeginUpdate.
CXTPPropertyGridUpdateContext Methods
CXTPPropertyGridUpdateContext Methods | Description
IsEmpty | Call this member to determine if any items in the grid were expanded before CXTPPropertyGrid::BeginUpdate was called. Only items with children can be expanded.


CXTPPropertyGridUpdateContext Data Members

CXTPPropertyGridUpdateContext Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridUpdateContext Data Members
Class

CXTPPropertyGridUpdateContext Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_mapState | Stores the expanded state of each item in the grid before CXTPPropertyGrid::BeginUpdate.
m_nSelected | Stores the Id of the currently selected item before CXTPPropertyGrid::BeginUpdate.
m_nTopIndex | Stores the Index of the top-most visible item in the property grid.
m_propertySort | Stores the currently used sort method of the grid before CXTPPropertyGrid::BeginUpdate.


CXTPPropertyGridUpdateContext::m_mapState Data Member

CXTPPropertyGridUpdateContext Data Members, CXTPPropertyGridUpdateContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridUpdateContext::m_mapState Data Member

Stores the expanded state of each item in the grid before CXTPPropertyGrid::BeginUpdate.

CMap<UINT, UINT, BOOL, BOOL&> m_mapState;
Group

CXTPPropertyGridUpdateContext Data Members


CXTPPropertyGridUpdateContext::m_nSelected Data Member

CXTPPropertyGridUpdateContext Data Members, CXTPPropertyGridUpdateContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridUpdateContext::m_nSelected Data Member

Stores the Id of the currently selected item before CXTPPropertyGrid::BeginUpdate.

UINT m_nSelected;
Group

CXTPPropertyGridUpdateContext Data Members


CXTPPropertyGridUpdateContext::m_nTopIndex Data Member

CXTPPropertyGridUpdateContext Data Members, CXTPPropertyGridUpdateContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridUpdateContext::m_nTopIndex Data Member

Stores the Index of the top-most visible item in the property grid.

UINT m_nTopIndex;
Group

CXTPPropertyGridUpdateContext Data Members


CXTPPropertyGridUpdateContext::m_propertySort Data Member

CXTPPropertyGridUpdateContext Data Members, CXTPPropertyGridUpdateContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridUpdateContext::m_propertySort Data Member

Stores the currently used sort method of the grid before CXTPPropertyGrid::BeginUpdate.

XTPPropertyGridSortOrder m_propertySort;
Group

CXTPPropertyGridUpdateContext Data Members


CXTPPropertyGridUpdateContext Methods

CXTPPropertyGridUpdateContext Class, Legend, Public Methods
CXTPPropertyGridUpdateContext Methods
Class

CXTPPropertyGridUpdateContext Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
IsEmpty | Call this member to determine if any items in the grid were expanded before CXTPPropertyGrid::BeginUpdate was called. Only items with children can be expanded.


CXTPPropertyGridUpdateContext::IsEmpty Method

CXTPPropertyGridUpdateContext Methods, CXTPPropertyGridUpdateContext Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridUpdateContext::IsEmpty Method

Call this member to determine if any items in the grid were expanded before CXTPPropertyGrid::BeginUpdate was called. Only items with children can be expanded.

BOOL IsEmpty() const;
Returns

TRUE if no items were expanded before BeginUpdate, FALSE if at least one item was expanded.

Body Source
BOOL CXTPPropertyGridUpdateContext::IsEmpty() const {
    return m_mapState.IsEmpty();
}
Group

CXTPPropertyGridUpdateContext Methods


CXTPPropertyGridUpdateContext Constructors

CXTPPropertyGridUpdateContext Class, Legend, Public Methods
CXTPPropertyGridUpdateContext Constructors
Class

CXTPPropertyGridUpdateContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridUpdateContext | Constructs a CXTPPropertyGridUpdateContext object.


CXTPPropertyGridUpdateContext::CXTPPropertyGridUpdateContext Constructor

CXTPPropertyGridUpdateContext Constructors, CXTPPropertyGridUpdateContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridUpdateContext::CXTPPropertyGridUpdateContext Constructor

Constructs a CXTPPropertyGridUpdateContext object.

CXTPPropertyGridUpdateContext();
Group

CXTPPropertyGridUpdateContext Constructors


CXTPPropertyGridVerb Class

XTPPropertyGrid.h, Classes, Legend, Members, Topics, CXTPPropertyGridVerb Data Members, CXTPPropertyGridVerb Methods, CXTPPropertyGridVerb Constructors, CXTPPropertyGridVerb Constructors, CXTPPropertyGridVerb Data Members, CXTPPropertyGridVerb Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb Class

CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET. For example, when the DataGrid control is selected at design time in VS .NET, an AutoFormat link button appears in the Properties window just below the property grid and above the help panel. Verbs will be displayed in a separate panel just below the property grid. Verbs are links that can be used to perform actions in your application. When a verb is clicked, CXTPPropertyGrid::OnVerbClick is called by the framework. If both the verb panel and help panel are visible at the same time, the verb panel is displayed above the help panel.

Class Hierarchy

class CXTPPropertyGridVerb;
File

XTPPropertyGrid.h

See Also

CXTPPropertyGrid::GetVerbs, CXTPPropertyGridVerbs

Group

Classes

Legend
Data Member
protected
Method
CXTPPropertyGridVerb Constructors
CXTPPropertyGridVerb Constructors | Description
CXTPPropertyGridVerb | Constructs a CXTPPropertyGridVerb object.
CXTPPropertyGridVerb Data Members
CXTPPropertyGridVerb Data Members | Description
m_nID | Id assigned this verb link.
m_nIndex | Index of this verb link in the collection of verbs.
m_ptClick | The last position the user clicked.
m_pVerbs | Collection of verb links.
m_rcPart | Bounding rectangle of verb.
m_strCaption | Text caption of this verb link.
CXTPPropertyGridVerb Methods
CXTPPropertyGridVerb Methods | Description
GetCaption | Call this member to retrieve the text caption of this verb link.
GetClickPoint | Call this member to retrieve the last position that the user clicked.
GetID | Call this member to retrieve the Id assigned to this verb link.
GetIndex | Call this member to retrieve the Index of this verb link within the collection of verbs.
GetPart | Used internally by PaintManager and PropertyGrid to get the bounding rectangle for verbs. You do not need to call this member.
IsFocused | Call this member to determine if this verb link is currently focused. If focused, a focus rectangle is placed around the text caption of the verb.
SetPart | Used internally by PaintManager and PropertyGrid to set the bounding rectangle for verbs. You do not need to call this member.


CXTPPropertyGridVerb Data Members

CXTPPropertyGridVerb Class, Legend, Protected Data Members
CXTPPropertyGridVerb Data Members
Class

CXTPPropertyGridVerb Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nID | Id assigned this verb link.
m_nIndex | Index of this verb link in the collection of verbs.
m_ptClick | The last position the user clicked.
m_pVerbs | Collection of verb links.
m_rcPart | Bounding rectangle of verb.
m_strCaption | Text caption of this verb link.


CXTPPropertyGridVerb::m_nID Data Member

CXTPPropertyGridVerb Data Members, CXTPPropertyGridVerb Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::m_nID Data Member

Id assigned this verb link.

int m_nID;
Group

CXTPPropertyGridVerb Data Members


CXTPPropertyGridVerb::m_nIndex Data Member

CXTPPropertyGridVerb Data Members, CXTPPropertyGridVerb Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::m_nIndex Data Member

Index of this verb link in the collection of verbs.

int m_nIndex;
Group

CXTPPropertyGridVerb Data Members


CXTPPropertyGridVerb::m_ptClick Data Member

CXTPPropertyGridVerb Data Members, CXTPPropertyGridVerb Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::m_ptClick Data Member

The last position the user clicked.

CPoint m_ptClick;
Group

CXTPPropertyGridVerb Data Members


CXTPPropertyGridVerb::m_pVerbs Data Member

CXTPPropertyGridVerb Data Members, CXTPPropertyGridVerb Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::m_pVerbs Data Member

Collection of verb links.

CXTPPropertyGridVerbs* m_pVerbs;
Group

CXTPPropertyGridVerb Data Members


CXTPPropertyGridVerb::m_rcPart Data Member

CXTPPropertyGridVerb Data Members, CXTPPropertyGridVerb Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::m_rcPart Data Member

Bounding rectangle of verb.

CRect m_rcPart;
Group

CXTPPropertyGridVerb Data Members


CXTPPropertyGridVerb::m_strCaption Data Member

CXTPPropertyGridVerb Data Members, CXTPPropertyGridVerb Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::m_strCaption Data Member

Text caption of this verb link.

CString m_strCaption;
Group

CXTPPropertyGridVerb Data Members


CXTPPropertyGridVerb Methods

CXTPPropertyGridVerb Class, Legend, Public Methods
CXTPPropertyGridVerb Methods
Class

CXTPPropertyGridVerb Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetCaption | Call this member to retrieve the text caption of this verb link.
GetClickPoint | Call this member to retrieve the last position that the user clicked.
GetID | Call this member to retrieve the Id assigned to this verb link.
GetIndex | Call this member to retrieve the Index of this verb link within the collection of verbs.
GetPart | Used internally by PaintManager and PropertyGrid to get the bounding rectangle for verbs. You do not need to call this member.
IsFocused | Call this member to determine if this verb link is currently focused. If focused, a focus rectangle is placed around the text caption of the verb.
SetPart | Used internally by PaintManager and PropertyGrid to set the bounding rectangle for verbs. You do not need to call this member.


CXTPPropertyGridVerb::GetCaption Method

CXTPPropertyGridVerb Methods, CXTPPropertyGridVerb Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::GetCaption Method

Call this member to retrieve the text caption of this verb link.

CString GetCaption() const;
Returns

Text caption of this verb link.

Body Source
CString CXTPPropertyGridVerb::GetCaption() const {
    return m_strCaption;
}
Group

CXTPPropertyGridVerb Methods


CXTPPropertyGridVerb::GetClickPoint Method

CXTPPropertyGridVerb Methods, CXTPPropertyGridVerb Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::GetClickPoint Method

Call this member to retrieve the last position that the user clicked.

CPoint GetClickPoint() const;
Returns

Retrieves the last position the user clicked. If it was "clicked" by pressing the Enter key while a verb has focus, then the BottomLeft position of the "clicked" Verb is returned.

Body Source
CPoint CXTPPropertyGridVerb::GetClickPoint() const {
    return m_ptClick;
}
Group

CXTPPropertyGridVerb Methods


CXTPPropertyGridVerb::GetID Method

CXTPPropertyGridVerb Methods, CXTPPropertyGridVerb Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::GetID Method

Call this member to retrieve the Id assigned to this verb link.

int GetID() const;
Returns

The Id of this verb link.

Body Source
int CXTPPropertyGridVerb::GetID() const {
    return m_nID;
}
Group

CXTPPropertyGridVerb Methods


CXTPPropertyGridVerb::GetIndex Method

CXTPPropertyGridVerb Methods, CXTPPropertyGridVerb Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::GetIndex Method

Call this member to retrieve the Index of this verb link within the collection of verbs.

int GetIndex() const;
Returns

Index of this verb within the collection of verb links.

Body Source
int CXTPPropertyGridVerb::GetIndex() const {
    return m_nIndex;
}
Group

CXTPPropertyGridVerb Methods


CXTPPropertyGridVerb::GetPart Method

CXTPPropertyGridVerb Methods, CXTPPropertyGridVerb Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::GetPart Method

Used internally by PaintManager and PropertyGrid to get the bounding rectangle for verbs. You do not need to call this member.

CRect GetPart() const;
Returns

Bounding rectangle of verb.

Body Source
CRect CXTPPropertyGridVerb::GetPart() const {
    return m_rcPart;
}
Group

CXTPPropertyGridVerb Methods


CXTPPropertyGridVerb::IsFocused Method

CXTPPropertyGridVerb Methods, CXTPPropertyGridVerb Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::IsFocused Method

Call this member to determine if this verb link is currently focused. If focused, a focus rectangle is placed around the text caption of the verb.

BOOL IsFocused() const;
Returns

TRUE if this verb is currently focused, FALSE if this verb is not focused.

Body Source
BOOL CXTPPropertyGridVerb::IsFocused() const {
    return (m_nIndex == m_pVerbs->m_pGrid->m_nFocusedVerb) && (::GetFocus() == m_pVerbs->m_pGrid->GetSafeHwnd());
}
Group

CXTPPropertyGridVerb Methods


CXTPPropertyGridVerb::SetPart Method

CXTPPropertyGridVerb Methods, CXTPPropertyGridVerb Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::SetPart Method

Used internally by PaintManager and PropertyGrid to set the bounding rectangle for verbs. You do not need to call this member.

void SetPart(
    CRect rc
);
Parameters

rc
Bounding rectangle containing the verb text.

Body Source
void CXTPPropertyGridVerb::SetPart(CRect rc) {
    m_rcPart = rc;
}
Group

CXTPPropertyGridVerb Methods


CXTPPropertyGridVerb Constructors

CXTPPropertyGridVerb Class, Legend, Public Methods
CXTPPropertyGridVerb Constructors
Class

CXTPPropertyGridVerb Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridVerb | Constructs a CXTPPropertyGridVerb object.


CXTPPropertyGridVerb::CXTPPropertyGridVerb Constructor

CXTPPropertyGridVerb Constructors, CXTPPropertyGridVerb Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerb::CXTPPropertyGridVerb Constructor

Constructs a CXTPPropertyGridVerb object.

CXTPPropertyGridVerb();
Group

CXTPPropertyGridVerb Constructors


CXTPPropertyGridVerbs Class

XTPPropertyGrid.h, Classes, Legend, Members, Topics, CXTPPropertyGridVerbs Data Members, CXTPPropertyGridVerbs Methods, CXTPPropertyGridVerbs Constructors, CXTPPropertyGridVerbs Destructors, CXTPPropertyGridVerbs Constructors, CXTPPropertyGridVerbs Data Members, CXTPPropertyGridVerbs Destructors, CXTPPropertyGridVerbs Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerbs Class

A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel. See CXTPPropertyGridVerb for a description of verbs.

Class Hierarchy

class CXTPPropertyGridVerbs;
File

XTPPropertyGrid.h

See Also

CXTPPropertyGridVerb

Group

Classes

Legend
Data Member
protected
Method
CXTPPropertyGridVerbs Constructors
CXTPPropertyGridVerbs Constructors | Description
CXTPPropertyGridVerbs | Constructs a CXTPPropertyGridVerbs object.
CXTPPropertyGridVerbs Data Members
CXTPPropertyGridVerbs Data Members | Description
m_arrVerbs | Collection of verb links.
m_pGrid | Pointer to the property grid that the verbs are drawn on.
CXTPPropertyGridVerbs Destructors
CXTPPropertyGridVerbs Destructors | Description
~CXTPPropertyGridVerbs | Destroys a CXTPPropertyGridVerbs object, handles cleanup and deallocation.
CXTPPropertyGridVerbs Methods
CXTPPropertyGridVerbs Methods | Description
Add | Call this member to add a verb link to the verb panel.
GetAt | Call this member to get a pointer to a specific verb in the collection of verbs.
GetCount | Call this member to retrieve the total number of verb links in the collection of verbs.
IsEmpty | Call this member to determine if any verbs have been added to the collection of verbs.
RemoveAll | Call this member to remove all verbs from the collection of verbs.


CXTPPropertyGridVerbs Data Members

CXTPPropertyGridVerbs Class, Legend, Protected Data Members
CXTPPropertyGridVerbs Data Members
Class

CXTPPropertyGridVerbs Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrVerbs | Collection of verb links.
m_pGrid | Pointer to the property grid that the verbs are drawn on.


CXTPPropertyGridVerbs::m_arrVerbs Data Member

CXTPPropertyGridVerbs Data Members, CXTPPropertyGridVerbs Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerbs::m_arrVerbs Data Member

Collection of verb links.

CArray<CXTPPropertyGridVerb*, CXTPPropertyGridVerb*> m_arrVerbs;
Group

CXTPPropertyGridVerbs Data Members


CXTPPropertyGridVerbs::m_pGrid Data Member

CXTPPropertyGridVerbs Data Members, CXTPPropertyGridVerbs Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerbs::m_pGrid Data Member

Pointer to the property grid that the verbs are drawn on.

CXTPPropertyGrid* m_pGrid;
Group

CXTPPropertyGridVerbs Data Members


CXTPPropertyGridVerbs Methods

CXTPPropertyGridVerbs Class, Legend, Public Methods
CXTPPropertyGridVerbs Methods
Class

CXTPPropertyGridVerbs Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add | Call this member to add a verb link to the verb panel.
GetAt | Call this member to get a pointer to a specific verb in the collection of verbs.
GetCount | Call this member to retrieve the total number of verb links in the collection of verbs.
IsEmpty | Call this member to determine if any verbs have been added to the collection of verbs.
RemoveAll | Call this member to remove all verbs from the collection of verbs.


CXTPPropertyGridVerbs::Add Method

CXTPPropertyGridVerbs Methods, CXTPPropertyGridVerbs Class
CXTPPropertyGridVerbs::Add Method

Call this member to add a verb link to the verb panel.

void Add(
    LPCTSTR lpszCaption,
    UINT nID
);
Parameters

lpszCaption
Text caption of the verb link.
nID
Id to assign to the new verb link.

Remarks

This will add a CXTPPropertyGridVerb object to the collection of verbs. Verbs are displayed in the verb panel that is located just below the property grid and above the help panel.

Group

CXTPPropertyGridVerbs Methods


CXTPPropertyGridVerbs::GetAt Method

CXTPPropertyGridVerbs Methods, CXTPPropertyGridVerbs Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerbs::GetAt Method

Call this member to get a pointer to a specific verb in the collection of verbs.

CXTPPropertyGridVerb* GetAt(
    int nIndex
) const;
Parameters

nIndex
Index of the verb withing the collection of verbs.

Returns

Verb at the specified location in the collection of verbs.

Body Source
CXTPPropertyGridVerb* CXTPPropertyGridVerbs::GetAt(int nIndex) const {
    return m_arrVerbs.GetAt(nIndex);
}
Group

CXTPPropertyGridVerbs Methods


CXTPPropertyGridVerbs::GetCount Method

CXTPPropertyGridVerbs Methods, CXTPPropertyGridVerbs Class
CXTPPropertyGridVerbs::GetCount Method

Call this member to retrieve the total number of verb links in the collection of verbs.

int GetCount() const;
Returns

Total number of verbs in the collection of verbs.

Group

CXTPPropertyGridVerbs Methods


CXTPPropertyGridVerbs::IsEmpty Method

CXTPPropertyGridVerbs Methods, CXTPPropertyGridVerbs Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerbs::IsEmpty Method

Call this member to determine if any verbs have been added to the collection of verbs.

BOOL IsEmpty() const;
Returns

TRUE if there are no verbs in the collection, FALSE if there is at least one verb in the collection.

Body Source
BOOL CXTPPropertyGridVerbs::IsEmpty() const {
    return m_arrVerbs.GetSize() == 0;
}
Group

CXTPPropertyGridVerbs Methods


CXTPPropertyGridVerbs::RemoveAll Method

CXTPPropertyGridVerbs Methods, CXTPPropertyGridVerbs Class
CXTPPropertyGridVerbs::RemoveAll Method

Call this member to remove all verbs from the collection of verbs.

void RemoveAll();
Group

CXTPPropertyGridVerbs Methods


CXTPPropertyGridVerbs Constructors

CXTPPropertyGridVerbs Class, Legend, Public Methods
CXTPPropertyGridVerbs Constructors
Class

CXTPPropertyGridVerbs Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridVerbs | Constructs a CXTPPropertyGridVerbs object.


CXTPPropertyGridVerbs::CXTPPropertyGridVerbs Constructor

CXTPPropertyGridVerbs Constructors, CXTPPropertyGridVerbs Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerbs::CXTPPropertyGridVerbs Constructor

Constructs a CXTPPropertyGridVerbs object.

CXTPPropertyGridVerbs();
Group

CXTPPropertyGridVerbs Constructors


CXTPPropertyGridVerbs Destructors

CXTPPropertyGridVerbs Class, Legend, Public Methods
CXTPPropertyGridVerbs Destructors
Class

CXTPPropertyGridVerbs Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridVerbs | Destroys a CXTPPropertyGridVerbs object, handles cleanup and deallocation.


CXTPPropertyGridVerbs::~CXTPPropertyGridVerbs Destructor

CXTPPropertyGridVerbs Destructors, CXTPPropertyGridVerbs Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridVerbs::~CXTPPropertyGridVerbs Destructor

Destroys a CXTPPropertyGridVerbs object, handles cleanup and deallocation.

~CXTPPropertyGridVerbs();
Group

CXTPPropertyGridVerbs Destructors


CXTPPropertyGridView Class

XTPPropertyGridView.h, Classes, Legend, Members, Topics, CXTPPropertyGridView Data Members, CXTPPropertyGridView Methods, CXTPPropertyGridView Constructors, CXTPPropertyGridView Destructors, CXTPPropertyGridView Constructors, CXTPPropertyGridView Data Members, CXTPPropertyGridView Destructors, CXTPPropertyGridView Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView Class

CXTPPropertyGridView is a CListBox derived class. It is an internal class used by Property Grid control

Class Hierarchy

class CXTPPropertyGridView : public CListBox;
File

XTPPropertyGridView.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertyGridView Constructors
CXTPPropertyGridView Constructors | Description
CXTPPropertyGridView | Constructs a CXTPPropertyGridView object
CXTPPropertyGridView Data Members
CXTPPropertyGridView Data Members | Description
m_bAutoDivider | TRUE to auto calculate divider
m_bTracking | TRUE if grid in tracking mode.
m_bVariableSplitterPos | TRUE to allow the user to resize the splitter with the mouse.
m_dDivider | Divider position.
m_hCursor | Handle of the cursor.
m_nItemHeight | Default height of the item
m_nLockUpdate | TRUE to lock update.
m_pCategories | Collection of the categories.
m_pFocusedButton | Currently focused button
m_pGrid | Parent CXTPPropertyGrid class.
m_pHotButton | Currently highlighted button
m_properetySort | Current sort order.
m_pSelected | Current selected item.
m_rcToolTip | Position of the Tooltip.
m_strTipText | Tooltip text.
m_wndTip | Tooltip control.
CXTPPropertyGridView Destructors
CXTPPropertyGridView Destructors | Description
~CXTPPropertyGridView | Destroys a CXTPPropertyGridView object, handles cleanup and deallocation.
CXTPPropertyGridView Methods
CXTPPropertyGridView Methods | Description
AddCategory | Call this member function to add a new category to a Property Grid Control.
FocusInplaceButton | This method is called to move focus to in-place button
GetDividerPos | Call this method to get the position of the divider.
GetImageManager | Retrieves Image manager associated with property grid
GetItem | This method retrieves an item with the specified index.
GetPaintManager | Returns the currently used control's Paint Manager.
GetPropertyGrid | Call this method to get parent property grid class
InsertCategory | Call this member function to insert a new category to the Property Grid control.
ItemFromPoint | This method determines where a point lies in a specified item.
LockDivider | Call this method to disable auto calculating divider position
Refresh | Call this method to refresh items in the list.
ResetContent | Call this method to remove all items in the list.
SendNotifyMessage | Sends the specified message to the owner window.
SetDividerPos | Call this method to set the position of the divider.
ShowToolTip | This method is called to show tooltip under item


CXTPPropertyGridView Data Members

CXTPPropertyGridView Class, Legend, Protected Data Members
CXTPPropertyGridView Data Members
Class

CXTPPropertyGridView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoDivider | TRUE to auto calculate divider
m_bTracking | TRUE if grid in tracking mode.
m_bVariableSplitterPos | TRUE to allow the user to resize the splitter with the mouse.
m_dDivider | Divider position.
m_hCursor | Handle of the cursor.
m_nItemHeight | Default height of the item
m_nLockUpdate | TRUE to lock update.
m_pCategories | Collection of the categories.
m_pFocusedButton | Currently focused button
m_pGrid | Parent CXTPPropertyGrid class.
m_pHotButton | Currently highlighted button
m_properetySort | Current sort order.
m_pSelected | Current selected item.
m_rcToolTip | Position of the Tooltip.
m_strTipText | Tooltip text.
m_wndTip | Tooltip control.


CXTPPropertyGridView::m_bAutoDivider Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_bAutoDivider Data Member

TRUE to auto calculate divider

BOOL m_bAutoDivider;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_bTracking Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_bTracking Data Member

TRUE if grid in tracking mode.

BOOL m_bTracking;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_bVariableSplitterPos Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_bVariableSplitterPos Data Member

TRUE to allow the user to resize the splitter with the mouse.

BOOL m_bVariableSplitterPos;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_dDivider Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_dDivider Data Member

Divider position.

double m_dDivider;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_hCursor Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_hCursor Data Member

Handle of the cursor.

HCURSOR m_hCursor;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_nItemHeight Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_nItemHeight Data Member

Default height of the item

UINT m_nItemHeight;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_nLockUpdate Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_nLockUpdate Data Member

TRUE to lock update.

int m_nLockUpdate;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_pCategories Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_pCategories Data Member

Collection of the categories.

CXTPPropertyGridItems* m_pCategories;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_pFocusedButton Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_pFocusedButton Data Member

Currently focused button

CXTPPropertyGridInplaceButton* m_pFocusedButton;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_pGrid Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_pGrid Data Member

Parent CXTPPropertyGrid class.

CXTPPropertyGrid* m_pGrid;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_pHotButton Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_pHotButton Data Member

Currently highlighted button

CXTPPropertyGridInplaceButton* m_pHotButton;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_properetySort Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_properetySort Data Member

Current sort order.

XTPPropertyGridSortOrder m_properetySort;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_pSelected Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_pSelected Data Member

Current selected item.

CXTPPropertyGridItem* m_pSelected;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_rcToolTip Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_rcToolTip Data Member

Position of the Tooltip.

CRect m_rcToolTip;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_strTipText Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_strTipText Data Member

Tooltip text.

CString m_strTipText;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView::m_wndTip Data Member

CXTPPropertyGridView Data Members, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::m_wndTip Data Member

Tooltip control.

CXTPPropertyGridToolTip m_wndTip;
Group

CXTPPropertyGridView Data Members


CXTPPropertyGridView Methods

CXTPPropertyGridView Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView Methods
Class

CXTPPropertyGridView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
ShowToolTip | This method is called to show tooltip under item
Public Methods
Public Methods
Public Method | Description
AddCategory | Call this member function to add a new category to a Property Grid Control.
FocusInplaceButton | This method is called to move focus to in-place button
GetDividerPos | Call this method to get the position of the divider.
GetImageManager | Retrieves Image manager associated with property grid
GetItem | This method retrieves an item with the specified index.
GetPaintManager | Returns the currently used control's Paint Manager.
GetPropertyGrid | Call this method to get parent property grid class
InsertCategory | Call this member function to insert a new category to the Property Grid control.
ItemFromPoint | This method determines where a point lies in a specified item.
LockDivider | Call this method to disable auto calculating divider position
Refresh | Call this method to refresh items in the list.
ResetContent | Call this method to remove all items in the list.
SendNotifyMessage | Sends the specified message to the owner window.
SetDividerPos | Call this method to set the position of the divider.


CXTPPropertyGridView::AddCategory Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::AddCategory Method

Call this member function to add a new category to a Property Grid Control.

CXTPPropertyGridItem* AddCategory(
    LPCTSTR strCaption,
    CXTPPropertyGridItem* pCategory = NULL
);
Parameters

strCaption
Name of the category to add.
pCategory
Points to a CXTPPropertyGridItem object.

Returns

A pointer to a CXTPPropertyGridItem object.

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::FocusInplaceButton Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::FocusInplaceButton Method

This method is called to move focus to in-place button

void FocusInplaceButton(
    CXTPPropertyGridInplaceButton* pButton
);
Parameters

pButton
Button to move focus

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::GetDividerPos Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::GetDividerPos Method

Call this method to get the position of the divider.

int GetDividerPos() const;
Returns

Position of the divider

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::GetImageManager Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::GetImageManager Method

Retrieves Image manager associated with property grid

CXTPImageManager* GetImageManager() const;
Returns

Pointer to the image manager object that stores the images in the property grid.

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::GetItem Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::GetItem Method

This method retrieves an item with the specified index.

CXTPPropertyGridItem* GetItem(
    int nIndex
) const;
Parameters

nIndex
Specifies the zero-based index of the item to retrieve.

Returns

A pointer to a CXTPPropertyGridItem object

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::GetPaintManager Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::GetPaintManager Method

Returns the currently used control's Paint Manager.

CXTPPropertyGridPaintManager* GetPaintManager() const;
Returns

Pointer to the paint manager object.

Remarks

Call this member function to get the paint manager object used for drawing a property grid control window.

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::GetPropertyGrid Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::GetPropertyGrid Method

Call this method to get parent property grid class

CXTPPropertyGrid* GetPropertyGrid() const;
Returns

Returns parent CXTPPropertyGrid object.

Body Source
CXTPPropertyGrid* CXTPPropertyGridView::GetPropertyGrid() const {
    return  m_pGrid;
}
Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::InsertCategory Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::InsertCategory Method

Call this member function to insert a new category to the Property Grid control.

CXTPPropertyGridItem* InsertCategory(
    int nIndex,
    LPCTSTR strCaption,
    CXTPPropertyGridItem* pCategory = NULL
);
Parameters

nIndex
Index of category to be inserted
strCaption
Name of the category to add.
pCategory
Points to a CXTPPropertyGridItem object.

Returns

The pointer to the item object of the newly inserted category.

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::ItemFromPoint Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::ItemFromPoint Method

This method determines where a point lies in a specified item.

CXTPPropertyGridItem* ItemFromPoint(
    CPoint point
) const;
Parameters

point
Specifies the point to be tested.

Returns

A pointer to a CXTPPropertyGridItem object

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::LockDivider Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::LockDivider Method

Call this method to disable auto calculating divider position

void LockDivider();
Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::Refresh Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::Refresh Method

Call this method to refresh items in the list.

void Refresh();
Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::ResetContent Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::ResetContent Method

Call this method to remove all items in the list.

void ResetContent();
Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::SendNotifyMessage Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::SendNotifyMessage Method

Sends the specified message to the owner window.

LRESULT SendNotifyMessage(
    WPARAM wParam = 0,
    LPARAM lParam = 0
);
Parameters

wParam
Specifies additional message-dependent information.
lParam
Specifies additional message-dependent information

Returns

The result of the message processing; its value depends on the message sent.

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::SetDividerPos Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::SetDividerPos Method

Call this method to set the position of the divider.

void SetDividerPos(
    int nDivider
);
Parameters

nDivider
Position of the divider

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView::ShowToolTip Method

CXTPPropertyGridView Methods, CXTPPropertyGridView Class
CXTPPropertyGridView::ShowToolTip Method

This method is called to show tooltip under item

virtual void ShowToolTip(
    CPoint pt
);
Parameters

pt
Mouse position

Group

CXTPPropertyGridView Methods


CXTPPropertyGridView Constructors

CXTPPropertyGridView Class, Legend, Public Methods
CXTPPropertyGridView Constructors
Class

CXTPPropertyGridView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridView | Constructs a CXTPPropertyGridView object


CXTPPropertyGridView::CXTPPropertyGridView Constructor

CXTPPropertyGridView Constructors, CXTPPropertyGridView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridView::CXTPPropertyGridView Constructor

Constructs a CXTPPropertyGridView object

CXTPPropertyGridView();
Group

CXTPPropertyGridView Constructors


CXTPPropertyGridView Destructors

CXTPPropertyGridView Class, Legend, Public Methods
CXTPPropertyGridView Destructors
Class

CXTPPropertyGridView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyGridView | Destroys a CXTPPropertyGridView object, handles cleanup and deallocation.


CXTPPropertyGridView::~CXTPPropertyGridView Destructor

CXTPPropertyGridView Destructors, CXTPPropertyGridView Class
CXTPPropertyGridView::~CXTPPropertyGridView Destructor

Destroys a CXTPPropertyGridView object, handles cleanup and deallocation.

virtual ~CXTPPropertyGridView();
Group

CXTPPropertyGridView Destructors


CXTPPropertyGridWhidbeyTheme Class

XTPPropertyGridPaintManager.h, Classes, Legend, Members, Topics, CXTPPropertyGridWhidbeyTheme Methods, CXTPPropertyGridWhidbeyTheme Constructors, CXTPPropertyGridWhidbeyTheme Constructors, CXTPPropertyGridWhidbeyTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridWhidbeyTheme Class

CXTPPropertyGridWhidbeyTheme is a CXTPPropertyGridPaintManager derived class. This represents a Visual Studio 2005 "Whidbey" style theme.

Class Hierarchy

class CXTPPropertyGridWhidbeyTheme : public CXTPPropertyGridPaintManager;
File

XTPPropertyGridPaintManager.h

Group

Classes

Legend
Method
protected
CXTPPropertyGridWhidbeyTheme Constructors
CXTPPropertyGridWhidbeyTheme Constructors | Description
CXTPPropertyGridWhidbeyTheme | Constructs a CXTPPropertyGridWhidbeyTheme object.
CXTPPropertyGridWhidbeyTheme Methods
CXTPPropertyGridWhidbeyTheme Methods | Description
DrawCategoryCaptionBackground | This member is called to draw the bounding rectangle for a category caption.
DrawExpandButton | This method is called to draw expand buttons of the grid.
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridWhidbeyTheme Methods

CXTPPropertyGridWhidbeyTheme Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridWhidbeyTheme Methods
Class

CXTPPropertyGridWhidbeyTheme Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawCategoryCaptionBackground | This member is called to draw the bounding rectangle for a category caption.
DrawExpandButton | This method is called to draw expand buttons of the grid.
RefreshMetrics | This method is called to refresh the visual metrics of the property grid.


CXTPPropertyGridWhidbeyTheme::DrawCategoryCaptionBackground Method

CXTPPropertyGridWhidbeyTheme Methods, CXTPPropertyGridWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridWhidbeyTheme::DrawCategoryCaptionBackground Method

This member is called to draw the bounding rectangle for a category caption.

void DrawCategoryCaptionBackground(
    CDC* pDC,
    CXTPPropertyGridItem* pItem,
    CRect rc
);
Parameters

pDC
Reference to a valid device context
rc
Bounding rectangle of Category's caption.

Group

CXTPPropertyGridWhidbeyTheme Methods


CXTPPropertyGridWhidbeyTheme::DrawExpandButton Method

CXTPPropertyGridWhidbeyTheme Methods, CXTPPropertyGridWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridWhidbeyTheme::DrawExpandButton Method

This method is called to draw expand buttons of the grid.

void DrawExpandButton(
    CDC& dc,
    CXTPPropertyGridItem* pItem,
    CRect rcCaption
);
Parameters

dc
Reference to a valid device context
pItem
Points to a CXTPPropertyGridItem object
rcCaption
Caption button rectangle.

Group

CXTPPropertyGridWhidbeyTheme Methods


CXTPPropertyGridWhidbeyTheme::RefreshMetrics Method

CXTPPropertyGridWhidbeyTheme Methods, CXTPPropertyGridWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridWhidbeyTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of the property grid.

void RefreshMetrics();
Group

CXTPPropertyGridWhidbeyTheme Methods


CXTPPropertyGridWhidbeyTheme Constructors

CXTPPropertyGridWhidbeyTheme Class, Legend, Public Methods
CXTPPropertyGridWhidbeyTheme Constructors
Class

CXTPPropertyGridWhidbeyTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridWhidbeyTheme | Constructs a CXTPPropertyGridWhidbeyTheme object.


CXTPPropertyGridWhidbeyTheme::CXTPPropertyGridWhidbeyTheme Constructor

CXTPPropertyGridWhidbeyTheme Constructors, CXTPPropertyGridWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyGridWhidbeyTheme::CXTPPropertyGridWhidbeyTheme Constructor

Constructs a CXTPPropertyGridWhidbeyTheme object.

CXTPPropertyGridWhidbeyTheme(
    CXTPPropertyGrid* pGrid
);
Parameters

pGrid
Points to a CXTPPropertyGrid object

Group

CXTPPropertyGridWhidbeyTheme Constructors


Structs, Records, Enums

Enumerations, Legend, Property Grid, Structures
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPPropertyGridBorderStyle | Border Style enumeration
XTPPropertyGridHitCode | XTPPropertyGridHitCode is an enumeration used by CXTPPropertyGrid to determine which part of the property grid is located at a specific point. CXTPPropertyGrid::HitTest is used to test a point when the user clicks on the property grid.
XTPPropertyGridInplaceButtonsStyle | InplaceButtons style
XTPPropertyGridItemColorEditor | Editor type for CXTPPropertyGridItemColor item
XTPPropertyGridItemFlags | Flags that indicate what styles to set for the grid item.
XTPPropertyGridPaintTheme | Visual theme enumeration
XTPPropertyGridSortOrder | XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style. This will specify how the items in the grid are displayed, I.e. Alphabetical, not sort, and grouped by category.
XTPPropertyGridUI | XTPPropertyGridUI is an enumeration used by CXTPPropertyGrid during navigation of the Property Grid, items, and verbs that specifies which object should receive focus.
Module

Property Grid

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_PROPERTYGRID_NOTIFYEDIT | This struct passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, XTP_PGN_CANCELEDIT notifications to determine item and its new value


XTP_PROPERTYGRID_NOTIFYEDIT Structure

XTPPropertyGridDefines.h, Structs, Records, Enums, See Also
XTP_PROPERTYGRID_NOTIFYEDIT Structure

This struct passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, XTP_PGN_CANCELEDIT notifications to determine item and its new value

struct XTP_PROPERTYGRID_NOTIFYEDIT {
  BOOL bCancel;
  CString strValue;
  CXTPPropertyGridItem* pItem;
};
File

XTPPropertyGridDefines.h

Members

bCancel
TRUE to cancel user edit
strValue
New caption value to be set
pItem
Item to be edit

See Also

XTP_PGN_REQUESTEDIT

Group

Structs, Records, Enums


XTPPropertyGridBorderStyle Enumeration

XTPPropertyGridPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPropertyGridBorderStyle Enumeration

Border Style enumeration

enum XTPPropertyGridBorderStyle {
  xtpGridBorderNone,
  xtpGridBorderFlat,
  xtpGridBorderStaticEdge,
  xtpGridBorderClientEdge
};
File

XTPPropertyGridPaintManager.h

Members

xtpGridBorderNone
Without borders
xtpGridBorderFlat
Black flat borders
xtpGridBorderStaticEdge
Static edge
xtpGridBorderClientEdge
Client edge

See Also

CXTPPropertyGrid::SetBorderStyle

Example
m_wndPropertyGrid.SetBorderStyle(xtpGridBorderClientEdge);
Group

Structs, Records, Enums


XTPPropertyGridHitCode Enumeration

XTPPropertyGrid.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPropertyGridHitCode Enumeration

XTPPropertyGridHitCode is an enumeration used by CXTPPropertyGrid to determine which part of the property grid is located at a specific point. CXTPPropertyGrid::HitTest is used to test a point when the user clicks on the property grid.

enum XTPPropertyGridHitCode {
  xtpGridHitError = -1,
  xtpGridHitHelpSplitter = 1,
  xtpGridHitVerbsSplitter = 2,
  xtpGridHitFirstVerb = 3
};
File

XTPPropertyGrid.h

Members

xtpGridHitError
Indicates that the help splitter, verb splitter and verbs were not clicked.
xtpGridHitHelpSplitter
Indicates that the help splitter was clicked.
xtpGridHitVerbsSplitter
Indicates that the Verb splitter was clicked.
xtpGridHitFirstVerb
Determines if the item clicked upon is a verb.

See Also

CXTPPropertyGrid::HitTest

Example

See CXTPPropertyGrid::HitTest.

Group

Structs, Records, Enums


XTPPropertyGridInplaceButtonsStyle Enumeration

XTPPropertyGridPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPropertyGridInplaceButtonsStyle Enumeration

InplaceButtons style

enum XTPPropertyGridInplaceButtonsStyle {
  xtpGridButtonsDefault,
  xtpGridButtonsThemed,
  xtpGridButtonsOfficeXP
};
File

XTPPropertyGridPaintManager.h

Members

xtpGridButtonsDefault
Default button style
xtpGridButtonsThemed
Themed button style
xtpGridButtonsOfficeXP
Office XP button style

See Also

CXTPPropertyGrid::SetTheme, CXTPPropertyGrid::GetCurrentTheme

Example

pPaintManager->m_buttonsStyle = xtpGridButtonsOfficeXP;

Group

Structs, Records, Enums


XTPPropertyGridItemColorEditor Enumeration

XTPPropertyGridItemColor.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPropertyGridItemColorEditor Enumeration

Editor type for CXTPPropertyGridItemColor item

enum XTPPropertyGridItemColorEditor {
  xtpGridItemColorPopup,
  xtpGridItemColorStandardDialog,
  xtpGridItemColorExtendedDialog
};
File

XTPPropertyGridItemColor.h

Members

xtpGridItemColorPopup
Color popup editor
xtpGridItemColorStandardDialog
Standard color dialog editor
xtpGridItemColorExtendedDialog
Extended color Editor editor

See Also

CXTPPropertyGridItemColor, CXTPPropertyGridItemColor::SetEditorStyle

Example
pItem->SetEditorStyle(xtpGridItemColorExtendedDialog);
Group

Structs, Records, Enums


XTPPropertyGridItemFlags Enumeration

XTPPropertyGridItem.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPropertyGridItemFlags Enumeration

Flags that indicate what styles to set for the grid item.

enum XTPPropertyGridItemFlags {
  xtpGridItemHasEdit = 1,
  xtpGridItemHasExpandButton = 2,
  xtpGridItemHasComboButton = 4
};
File

XTPPropertyGridItem.h

Members

xtpGridItemHasEdit
Item has an edit control.
xtpGridItemHasExpandButton
Item has an expand button.
xtpGridItemHasComboButton
Item has a combo button.

See Also

CXTPPropertyGridItem::SetFlags, OnInplaceButtonDown

Example
pItem->SetFlags(xtpGridItemHasEdit | xtpGridItemHasComboButton);
Group

Structs, Records, Enums


XTPPropertyGridPaintTheme Enumeration

XTPPropertyGridPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPropertyGridPaintTheme Enumeration

Visual theme enumeration

enum XTPPropertyGridPaintTheme {
  xtpGridThemeDefault,
  xtpGridThemeNativeWinXP,
  xtpGridThemeOffice2003,
  xtpGridThemeCool,
  xtpGridThemeSimple,
  xtpGridThemeDelphi,
  xtpGridThemeWhidbey,
  xtpGridThemeOfficeXP,
  xtpGridThemeOffice2007
};
File

XTPPropertyGridPaintManager.h

Members

xtpGridThemeDefault
Default theme.
xtpGridThemeNativeWinXP
WinXP style theme.
xtpGridThemeOffice2003
Office 2003 style theme.
xtpGridThemeCool
Cool theme.
xtpGridThemeSimple
Visual Basic style theme.
xtpGridThemeDelphi
Delphi style theme.
xtpGridThemeWhidbey
Visual Studio 2005 "Whidbey" style theme.
xtpGridThemeOfficeXP
Office XP style theme.
xtpGridThemeOffice2007
Office 2007 style theme.

See Also

CXTPPropertyGrid::SetTheme, CXTPPropertyGrid::GetCurrentTheme

Example
m_wndPropertyGrid.SetTheme(xtpGridThemeWhidbey);
Group

Structs, Records, Enums


XTPPropertyGridSortOrder Enumeration

XTPPropertyGrid.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPropertyGridSortOrder Enumeration

XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style. This will specify how the items in the grid are displayed, I.e. Alphabetical, not sort, and grouped by category.

enum XTPPropertyGridSortOrder {
  xtpGridSortCategorized,
  xtpGridSortAlphabetical,
  xtpGridSortNoSort
};
File

XTPPropertyGrid.h

Members

xtpGridSortCategorized
Group items by category.
xtpGridSortAlphabetical
Sort items alphabetically.
xtpGridSortNoSort
Disable sorting and grouping, all items are displayed in the order that they are added to the grid.

See Also

CXTPPropertyGrid::SetPropertySort, CXTPPropertyGrid::GetPropertySort

Example
XTPPropertyGridSortOrder sort = m_wndPropertyGrid.GetPropertySort();

Group

Structs, Records, Enums


XTPPropertyGridUI Enumeration

XTPPropertyGrid.h, Structs, Records, Enums, See Also
XTPPropertyGridUI Enumeration

XTPPropertyGridUI is an enumeration used by CXTPPropertyGrid during navigation of the Property Grid, items, and verbs that specifies which object should receive focus.

enum XTPPropertyGridUI {
  xtpGridUIParentPrev = -2,
  xtpGridUIViewPrev = -1,
  xtpGridUIView = 0,
  xtpGridUIInplaceEdit = 1,
  xtpGridUIInplaceControl = 2,
  xtpGridUIInplaceButton = 3,
  xtpGridUIViewNext = 4,
  xtpGridUIVerb = 5,
  xtpGridUIParentNext = 6
};
File

XTPPropertyGrid.h

Members

xtpGridUIParentPrev
Used to indicate that focus should be given to the previous object in the tab order.
xtpGridUIViewPrev
If m_bTabItems is TRUE, Used to indicate that focus should be given to the previous item in the grid.
xtpGridUIView
Used to indicate that focus should be given to the Property Grid.
xtpGridUIInplaceEdit
Used to indicate that the Tab key is pressed while in an in-place edit box has focus.
xtpGridUIInplaceControl
Used to indicate that the Tab key is pressed while in an in-place edit box has focus.
xtpGridUIInplaceButton
Used to indicate that the Tab key is pressed while an in-place button has focus.
xtpGridUIViewNext
If m_bTabItems is TRUE, Used to indicate that focus should be given to the next item in the grid.
xtpGridUIVerb
Used to indicate that the Tab key is pressed while in Verb has focus.
xtpGridUIParentNext
Used to indicate that focus should be given to the next object in the tab order.

Remarks

After the Tab key or Shift+Tab key combinations are pressed, focus will be given to the object specified in the XTPPropertyGridUI enumeration. I.e. If xtpGridUIViewNext is passed into OnNaviagte when an item in the grid has focus, then the next item will receive focus.

See Also

CXTPPropertyGrid::OnNavigate, CXTPPropertyGrid::NavigateItems

Group

Structs, Records, Enums


Variables

Property Grid, Variables
Variables
Module

Property Grid

Variables
Variable | Description
XTP_ID_PROPERTYGRID_COMBOBUTTON | Constructs a CXTPPropertyGridInplaceButton object
XTP_ID_PROPERTYGRID_EXPANDBUTTON | Constructs a CXTPPropertyGridInplaceButton object
XTP_PGI_EXPAND_BORDER | This constant is used to determine the "gutter" width of the property grid. This is the area on the left of the grid that the expand buttons are drawn in.
XTP_PGN_AFTEREDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_CANCELEDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_DBLCLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_DRAWITEM | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_EDIT_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_INPLACEBUTTONDOWN | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_ITEMEXPANDCHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_ITEMVALUE_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_RCLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_REQUESTEDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_SELECTION_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_SORTORDER_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_USER | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_VERB_CLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGS_OWNERDRAW | Apply this style to the property grid to use the owner draw feature.
XTPPROPERTYGRID_CLASSNAME | NULL terminated string used by CXTPPropertyGrid which specifies the window class name for the property grid.
XTPWM_PROPERTYGRID_NOTIFY | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid


XTP_PGI_EXPAND_BORDER Variable

XTPPropertyGridItem.h, Variables, Example
XTP_PGI_EXPAND_BORDER Variable

This constant is used to determine the "gutter" width of the property grid. This is the area on the left of the grid that the expand buttons are drawn in.

const int XTP_PGI_EXPAND_BORDER = 14;
File

XTPPropertyGridItem.h

Remarks

This is useful when drawing owner drawn controls such as buttons and drop-down menus.

Example

The following example illustrates using XTP_PGI_EXPAND_BORDER:

void CDelphiGridPage::DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct)
{
    // code snip ...

    CRect rcText(rc);
    rcText.left = max(1, pItem->GetIndent()) * XTP_PGI_EXPAND_BORDER + 3;
    rcText.right = rcCaption.right - 1;
    rcText.bottom -= 1;
    dc.DrawText(pItem->GetCaption(), rcText, DT_SINGLELINE | DT_VCENTER);
}
Group

Variables


XTP_PGS_OWNERDRAW Variable

XTPPropertyGridDefines.h, Variables, Example, See Also
XTP_PGS_OWNERDRAW Variable

Apply this style to the property grid to use the owner draw feature.

const UINT XTP_PGS_OWNERDRAW = 0x0010L;
File

XTPPropertyGridDefines.h

See Also

CXTPPropertyGrid::Create

Example

The following example illustrates using XTP_PGS_OWNERDRAW:

m_wndPropertyGrid.ModifyStyle(0, XTP_PGS_OWNERDRAW);
Group

Variables


XTPPROPERTYGRID_CLASSNAME Variable

XTPPropertyGridDefines.h, Variables, Example, See Also
XTPPROPERTYGRID_CLASSNAME Variable

NULL terminated string used by CXTPPropertyGrid which specifies the window class name for the property grid.

const TCHAR XTPPROPERTYGRID_CLASSNAME[] = _T("XTPPropertyGrid");
File

XTPPropertyGridDefines.h

See Also

CXTPPropertyGrid::RegisterWindowClass

Example
BOOL CXTPPropertyGrid::RegisterWindowClass()
{
    WNDCLASS wndcls;
    HINSTANCE hInst = AfxGetInstanceHandle();

    if (!(::GetClassInfo(hInst, XTPREPORTCTRL_CLASSNAME, &wndcls)))
    {
        // otherwise we need to register a new class
        wndcls.style            = CS_DBLCLKS | CS_HREDRAW | CS_VREDRAW;
        wndcls.lpfnWndProc      = ::DefWindowProc;
        wndcls.cbClsExtra       = wndcls.cbWndExtra = 0;
        wndcls.hInstance        = hInst;
        wndcls.hIcon            = NULL;
        wndcls.hCursor          = AfxGetApp()->LoadStandardCursor(IDC_ARROW);
        wndcls.hbrBackground    = (HBRUSH) (COLOR_3DFACE + 1);
        wndcls.lpszMenuName     = NULL;
        wndcls.lpszClassName    = XTPREPORTCTRL_CLASSNAME;

        if (!AfxRegisterClass(&wndcls))
        {
            AfxThrowResourceException();
            return FALSE;
        }
    }

    return TRUE;
}
Group

Variables


XTPWM_PROPERTYGRID_NOTIFY Variable

XTPPropertyGridDefines.h, Variables, Example
XTPWM_PROPERTYGRID_NOTIFY Variable

The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid

XTWM_PROPERTYGRID_NOTIFY
nGridAction = (int) wParam;              // Property grid action
pItem = (CXTPPropertyGridItem*) lParam;  // pointer to a CXTPPropertyGridItem object

When the user performs an action in the property grid, the XTWM_PROPERTYGRID_NOTIFY message is sent to the property grid's owner window.

const UINT XTPWM_PROPERTYGRID_NOTIFY = (WM_USER + 9950 + 1);
File

XTPPropertyGridDefines.h

Parameters

nGridAction
Value of wParam specifies an value that indicates the user's request .
pItem
The value of lParam points to a CXTPPropertyGridItem object that contains information for the specified item. This pointer should never be NULL.

Returns

If the application is to process this message, the return value should be TRUE, otherwise the return value is FALSE.

Remarks

nGridAction parameter can be one of the following values:

  • XTP_PGN_SORTORDER_CHANGED The sort order has changed in the property grid.
  • XTP_PGN_SELECTION_CHANGED The selection has changed in the property grid.
  • XTP_PGN_ITEMVALUE_CHANGED The value has changed for pItem in the property grid.
  • XTP_PGN_EDIT_CHANGED The edit value has changed in the property grid.
  • XTP_PGN_INPLACEBUTTONDOWN Item's in-place button (combo or expand) down.
  • XTP_PGN_ITEMEXPANDCHANGED User expand or collapse item.
  • XTP_PGN_DBLCLICK The user double-clicks the left mouse button in the property grid.
  • XTP_PGN_RCLICK The user pressed the right mouse button in the property grid.
  • XTP_PGN_VERB_CLICK The user click verb in the property grid.
  • XTP_PGN_REQUESTEDIT The user changing value of the item.
Example

Here is an example of how an application would process the XTWM_PROPERTYGRID_NOTIFY message.

int nGridAction = (int)wParam;

switch (nGridAction)
{
    case XTP_PGN_SORTORDER_CHANGED:
          {
             m_nSort = m_wndXTPPropertyGrid.GetPropertySort();
             UpdateData(FALSE);
          }
        break;
    case XTP_PGN_ITEMVALUE_CHANGED:
          {
             CXTPPropertyGridItem* pItem = (CXTPPropertyGridItem*)lParam;
             TRACE(_T("Value Changed. Caption = %s, ID = %i, Value = %sn"),
                 pItem->GetCaption(), pItem->GetID(), pItem->GetValue());
          }
        break;
    case XTP_PGN_SELECTION_CHANGED:
          {
             CXTPPropertyGridItem* pItem = (CXTPPropertyGridItem*)lParam;
             TRACE(_T("Selection Changed. Item = %sn"), pItem->GetCaption());
          }
    case XTP_PGN_INPLACEBUTTONDOWN:
          {
             CXTPPropertyGridInplaceButton* pButton = (CXTPPropertyGridInplaceButton*)lParam;
          }
        break;
}
return FALSE;
Group

Variables


Files

Files, Property Grid
Files
Files
File | Description
XTPPropertyGrid.h | XTPPropertyGrid.h interface for the CXTPPropertyGrid class.
XTPPropertyGridDefines.h | XTPPropertyGridDefines.h This file is a part of the XTREME PROPERTYGRID MFC class library.
XTPPropertyGridInplaceButton.h | XTPPropertyGridInplaceButton.h interface for the CXTPPropertyGridInplaceButton class.
XTPPropertyGridInplaceEdit.h | XTPPropertyGridInplaceEdit.h interface for the CXTPPropertyGridInplaceEdit class.
XTPPropertyGridInplaceList.h | XTPPropertyGridInplaceList.h interface for the CXTPPropertyGridInplaceList class.
XTPPropertyGridItem.h | XTPPropertyGridItem.h interface for the CXTPPropertyGridItem class.
XTPPropertyGridItemBool.h | XTPPropertyGridItemBool.h interface for the CXTPPropertyGridItemBool class.
XTPPropertyGridItemColor.h | XTPPropertyGridItemColor.h interface for the CXTPPropertyGridItemColor class.
XTPPropertyGridItemExt.h | XTPPropertyGridItemExt.h This file is a part of the XTREME PROPERTYGRID MFC class library.
XTPPropertyGridItemFont.h | XTPPropertyGridItemFont.h interface for the CXTPPropertyGridItemFont class.
XTPPropertyGridItemNumber.h | XTPPropertyGridItemNumber.h interface for the CXTPPropertyGridItemNumber class.
XTPPropertyGridItemSize.h | XTPPropertyGridItemSize.h interface for the CXTPPropertyGridItemSize class.
XTPPropertyGridPaintManager.h | XTPPropertyGridPaintManager.h interface for the CXTPPropertyGridPaintManager class.
XTPPropertyGridView.h | XTPPropertyGridView.h interface for the CXTPPropertyGridView class.
Module

Property Grid


XTPPropertyGrid.h

Classes, Enumerations, Files, Legend
XTPPropertyGrid.h

XTPPropertyGrid.h interface for the CXTPPropertyGrid class.

Classes
Class | Description
CXTPPropertyGrid | CXTPPropertyGrid is a CWnd derived class. It is used to create a property grid control similar to the property window in VS.NET. See the "PropertyGrid" demo for an example of its usage.
CXTPPropertyGridToolBar | CXTPPropertyGridToolBar is a CToolBar derived class. It is an internal class used by Property Grid control
CXTPPropertyGridUpdateContext | CXTPPropertyGridUpdateContext is a CCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid. The property grid state information is stored in the CXTPPropertyGridUpdateContext object when CXTPPropertyGrid::BeginUpdate is called and after CXTPPropertyGrid::EndUpdate the expanding state of each item, selected item, and sort preference will be restored.
CXTPPropertyGridVerb | CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET. For example, when the DataGrid control is selected at design time in VS .NET, an AutoFormat link button appears in the Properties window just below the property grid and above the help panel. Verbs will be displayed in a separate panel just below the property grid. Verbs are links that can be used to perform actions in your application. When a verb is clicked, CXTPPropertyGrid::OnVerbClick is called by the framework. If both the verb panel and help panel are visible at the same... more
CXTPPropertyGridVerbs | A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel. See CXTPPropertyGridVerb for a description of verbs.
Enumerations
Enumeration | Description
XTPPropertyGridHitCode | XTPPropertyGridHitCode is an enumeration used by CXTPPropertyGrid to determine which part of the property grid is located at a specific point. CXTPPropertyGrid::HitTest is used to test a point when the user clicks on the property grid.
XTPPropertyGridSortOrder | XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style. This will specify how the items in the grid are displayed, I.e. Alphabetical, not sort, and grouped by category.
XTPPropertyGridUI | XTPPropertyGridUI is an enumeration used by CXTPPropertyGrid during navigation of the Property Grid, items, and verbs that specifies which object should receive focus.
Group

Files

Legend
Enumeration


XTPPropertyGridDefines.h

Files, Legend, Variables, Structures
XTPPropertyGridDefines.h

XTPPropertyGridDefines.h

This file is a part of the XTREME PROPERTYGRID MFC class library.

Group

Files

Variables
Variable | Description
XTP_PGN_AFTEREDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_CANCELEDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_DBLCLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_DRAWITEM | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_EDIT_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_INPLACEBUTTONDOWN | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_ITEMEXPANDCHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_ITEMVALUE_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_RCLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_REQUESTEDIT | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_SELECTION_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_SORTORDER_CHANGED | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_USER | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGN_VERB_CLICK | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
XTP_PGS_OWNERDRAW | Apply this style to the property grid to use the owner draw feature.
XTPPROPERTYGRID_CLASSNAME | NULL terminated string used by CXTPPropertyGrid which specifies the window class name for the property grid.
XTPWM_PROPERTYGRID_NOTIFY | The XTWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid owner window whenever an action occurs within the CXTPPropertyGrid
Legend
Structure
Structures
Structure | Description
XTP_PROPERTYGRID_NOTIFYEDIT | This struct passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, XTP_PGN_CANCELEDIT notifications to determine item and its new value


XTPPropertyGridInplaceButton.h

Classes, Files, Variables
XTPPropertyGridInplaceButton.h

XTPPropertyGridInplaceButton.h interface for the CXTPPropertyGridInplaceButton class.

Classes
Class | Description
CXTPPropertyGridInplaceButton | CXTPPropertyGridInplaceButton is a CCmdTarget derived class. It represents inplace button in Property Grid control.
CXTPPropertyGridInplaceButtons | CXTPPropertyGridInplaceButtons is a CCmdTarget derived class. It represents collection of inplace buttons for specified grid item
Group

Files

Variables
Variable | Description
XTP_ID_PROPERTYGRID_COMBOBUTTON | Constructs a CXTPPropertyGridInplaceButton object
XTP_ID_PROPERTYGRID_EXPANDBUTTON | Constructs a CXTPPropertyGridInplaceButton object


XTPPropertyGridInplaceEdit.h

Classes, Files
XTPPropertyGridInplaceEdit.h

XTPPropertyGridInplaceEdit.h interface for the CXTPPropertyGridInplaceEdit class.

Classes
Class | Description
CXTPPropertyGridInplaceControl | CXTPPropertyGridInplaceControl is CWnd derived class, represents base class for all item in place controls.
CXTPPropertyGridInplaceControls | CXTPPropertyGridInplaceControls is standalone class it represents collection of CXTPPropertyGridInplaceControl classes.
CXTPPropertyGridInplaceEdit | CXTPPropertyGridInplaceEdit is a CEdit derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceSlider | CXTPPropertyGridInplaceSlider is CXTPPropertyGridInplaceControl derived class. It represents in-place slider of the items. Call CXTPPropertyGridItem::AddSliderControl() to add slider for property grid item
CXTPPropertyGridInplaceSpinButton | CXTPPropertyGridInplaceSpinButton is CXTPPropertyGridInplaceControl derived class. It represents in-place spin button of the items. Call CXTPPropertyGridItem::AddSpinButton() to add spin button for property grid item
Group

Files


XTPPropertyGridInplaceList.h

Classes, Files
XTPPropertyGridInplaceList.h

XTPPropertyGridInplaceList.h interface for the CXTPPropertyGridInplaceList class.

Classes
Class | Description
CXTPPropertyGridInplaceList | CXTPPropertyGridInplaceList is a CListBox derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceMultilineEdit | CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class. It is an internal class used by Property Grid control.
Group

Files


XTPPropertyGridItem.h

Classes, Enumerations, Files, Legend, Variables
XTPPropertyGridItem.h

XTPPropertyGridItem.h interface for the CXTPPropertyGridItem class.

Classes
Class | Description
CXTPPropertyGridItem | CXTPPropertyGridItem is the base class representing an item of the Property Grid Control.
CXTPPropertyGridItemCategory | CXTPPropertyGridItemCategory is the CXTPPropertyGridItem derived class. Use it to add subcategory to property grid control.
CXTPPropertyGridItemConstraint | CXTPPropertyGridItemConstraint is a CCmdTarget derived class. It represents a single item constraints.
CXTPPropertyGridItemConstraints | CXTPPropertyGridItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.
CXTPPropertyGridItems | CXTPPropertyGridItems is a CList derived class. It represents the items collection with some internal functionality.
Enumerations
Enumeration | Description
XTPPropertyGridItemFlags | Flags that indicate what styles to set for the grid item.
Group

Files

Variables
Variable | Description
XTP_PGI_EXPAND_BORDER | This constant is used to determine the "gutter" width of the property grid. This is the area on the left of the grid that the expand buttons are drawn in.
Legend
Enumeration


XTPPropertyGridItemBool.h

Classes, Files
XTPPropertyGridItemBool.h

XTPPropertyGridItemBool.h interface for the CXTPPropertyGridItemBool class.

Classes
Class | Description
CXTPPropertyGridItemBool | CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class. It is used to create a Boolean value item in a Property Grid control.
CXTPPropertyGridItemEnum | CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class. It is used to create an Enum value item in a Property Grid control.
CXTPPropertyGridItemFlags | CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class. It is used to create a Flags value item in a Property Grid control.
Group

Files


XTPPropertyGridItemColor.h

Classes, Enumerations, Files, Legend
XTPPropertyGridItemColor.h

XTPPropertyGridItemColor.h interface for the CXTPPropertyGridItemColor class.

Classes
Class | Description
CXTPPropertyGridItemColor | CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class. It is used to create an RGB value item in a Property Grid control.
Enumerations
Enumeration | Description
XTPPropertyGridItemColorEditor | Editor type for CXTPPropertyGridItemColor item
Group

Files

Legend
Enumeration


XTPPropertyGridItemExt.h

Classes, Files
XTPPropertyGridItemExt.h

XTPPropertyGridItemExt.h

This file is a part of the XTREME PROPERTYGRID MFC class library.

Classes
Class | Description
CXTPPropertyGridInplaceMonthCal | Month calendar popup used for CXTPPropertyGridItemDate item.
CXTPPropertyGridItemDate | CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class. It is used to create Date item in a Property Grid control.
Group

Files


XTPPropertyGridItemFont.h

Classes, Files
XTPPropertyGridItemFont.h

XTPPropertyGridItemFont.h interface for the CXTPPropertyGridItemFont class.

Classes
Class | Description
CXTPPropertyGridItemFont | CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class. It is used to create a Font value item in a Property Grid control.
Group

Files


XTPPropertyGridItemNumber.h

Classes, Files
XTPPropertyGridItemNumber.h

XTPPropertyGridItemNumber.h interface for the CXTPPropertyGridItemNumber class.

Classes
Class | Description
CXTPPropertyGridItemDouble | CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class. It is used to create an double value item in a Property Grid control.
CXTPPropertyGridItemNumber | CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class. It is used to create an integer value item in a Property Grid control.
Group

Files


XTPPropertyGridItemSize.h

Classes, Files
XTPPropertyGridItemSize.h

XTPPropertyGridItemSize.h interface for the CXTPPropertyGridItemSize class.

Classes
Class | Description
CXTPPropertyGridItemSize | CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class. It is used to create a size value item in a Property Grid control.
Group

Files


XTPPropertyGridPaintManager.h

Classes, Enumerations, Files, Legend
XTPPropertyGridPaintManager.h

XTPPropertyGridPaintManager.h interface for the CXTPPropertyGridPaintManager class.

Classes
Class | Description
CXTPPropertyGridCoolTheme | CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class. This represents a Cool style theme.
CXTPPropertyGridDelphiTheme | CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class. This represents a Delphi style theme.
CXTPPropertyGridItemMetrics | Standalone class used by CXTPPropertyGridPaintManager as holder of item metrics
CXTPPropertyGridNativeXPTheme | CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Native Windows XP style theme.
CXTPPropertyGridOffice2003Theme | CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class. This represents an Office 2003 style theme.
CXTPPropertyGridOfficeXPTheme | CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Office XP style theme.
CXTPPropertyGridPaintManager | Standalone class used by CXTPPropertyGrid as the paint manager.
CXTPPropertyGridSimpleTheme | CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class. This represents a Simple style theme.
CXTPPropertyGridWhidbeyTheme | CXTPPropertyGridWhidbeyTheme is a CXTPPropertyGridPaintManager derived class. This represents a Visual Studio 2005 "Whidbey" style theme.
Enumerations
Enumeration | Description
XTPPropertyGridBorderStyle | Border Style enumeration
XTPPropertyGridInplaceButtonsStyle | InplaceButtons style
XTPPropertyGridPaintTheme | Visual theme enumeration
Group

Files

Legend
Enumeration


XTPPropertyGridView.h

Classes, Files
XTPPropertyGridView.h

XTPPropertyGridView.h interface for the CXTPPropertyGridView class.

Classes
Class | Description
CXTPPropertyGridToolTip | CXTPPropertyGridToolTip is a CWnd derived class. It is an internal class used by Property Grid control
CXTPPropertyGridView | CXTPPropertyGridView is a CListBox derived class. It is an internal class used by Property Grid control
Group

Files


Report Control

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Functions, Macros, Structs, Records, Enums, Types, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Report Control

Codejock Software's Xtreme Report Control allows you to display a hierarchical list of items similar to Outlook 2003 email inbox.

Group

Xtreme Toolkit Pro v12.0

Legend
Structure
Enumeration
Method
Classes
Class
Description
CXTPFormulaMulDivC
This class used to store MulDivC formula parameters and perform calculation. MulDivC formula if the folowing:

  • = y * Mul / Div + C

CXTPReportColumn
Represents report column item with its properties and operations.
CXTPReportColumnOrder
Represents column order, used for sorting and grouping.
CXTPReportColumns
This class is a collection of report columns objects, each of which can be referred to by its zero-based index.
CXTPReportControl
The CXTPReportControl class provides an implementation of the Report control.
CXTPReportControlLocale
Helper class with static member functions to control active locale for Report Control and perform some locale dependent tasks.
CXTPReportFilterEditControl
The CXTPReportFilterEditControl class provides the functionality of the filter string edit control, associated to the main Report control window.
CXTPReportGroupRow
This class represents a 'group row' of the report control view - that means a row which has no associated Record item, but has a special text caption instead.
CXTPReportHeader
A report header is a part of the report window positioned above columns of text or numbers. It contains a title for each column, and it can be divided into parts. The user can drag the dividers that separate the parts to set the width of each column.
CXTPReportHeaderDragWnd
CXTPReportHeaderDragWnd is CWnd derived class, it used internally to represent dragging column window.
CXTPReportHeaderDropWnd
CXTPReportHeaderDropWnd is CWnd derived class, it used internally to represent drop target arrows.
CXTPReportHyperlink
This class represents hyperlinks. It stores first position and length in the text for hyperlink and rectangle for drawing and identify clicks on hyperlink. To create an instance of its class, you simply call constructor with first position and length of the hyperlink's text
CXTPReportHyperlinks
This class represents array of pointers to CXTPReportHyperlink objects. InternalRelease is called for each item in the array destructor. Also serialization for array items is provided (see DoPropExchange method).
CXTPReportInplaceButton
CXTPReportInplaceButton is the CXTPReportInplaceControl derived class, it represents combo button and expand button of report cell.
CXTPReportInplaceButtons
This class represents collection of the in-place buttons of the single item of the report control.
CXTPReportInplaceControl
CXTPReportInplaceControl is the base class for all in-place controls of report control item.
CXTPReportInplaceEdit
CXTPReportInplaceEdit is the CXTPReportInplaceControl derived class, it represents edit control to allow users change cell of report control.
CXTPReportInplaceList
CXTPReportInplaceList is the CXTPReportInplaceControl derived class, it represents list box with constraints of item.
CXTPReportPageSetupDialog
Customized Calendar control page setup dialog.
CXTPReportPaintManager
Utility class, handling most of the drawing activities. It stores all settings, needed by a control to perform drawing operations: fonts, colors, styles for all other classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with device context.
CXTPReportRecord
CXTPReportRecord represents a collection of objects of CXTPReportRecordItem or objects of classes that are children of CXTPReportRecordItem. A collection of such items is one record in ReportControl list. You create an object of CXTPReportRecord by simply calling constructor. After it you can add items to the record.
CXTPReportRecordItem
Class for working with single list cell. Base class for extended list cells. It determines the behavior of all specific record items. You don't use its class directly in the control. If you wish to add your own Record Item to the control, you must inherit it from CXTPReportRecordItem. Most member functions in this class are virtual.
CXTPReportRecordItemConstraint
CXTPReportRecordItemConstraint is a CCmdTarget derived class. It represents a single item constraints.
CXTPReportRecordItemConstraints
CXTPReportRecordItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.
CXTPReportRecordItemDateTime
Represents a time cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemEditOptions
This class represents edit options of the single item or column
CXTPReportRecordItemNumber
This class represents a numeric cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemPreview
This represents a preview cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemText
This Class represents a text-only cell and inherits basic functionality from CXTPReportRecordItem class. You create a text record item simply by calling a constructor with one parameter - text string
CXTPReportRecordItemVariant
Represents a variant item and inherits basic functionality from CXTPReportRecordItem class. You can create a bitmap record item simply by calling a constructor with the only one parameter - value of VARIANT type.
CXTPReportRecords
This class represents a records collection class. It supports an array of CXTPReportRecord pointers.
CXTPReportRow
CXTPReportRow class represents an row of the report control window.
CXTPReportRows
This class represents a rows collection class. It supports an array of CXTPReportRow pointers.
CXTPReportSelectedRows
Encapsulates a collection of CXTPReportRow pointers that represent the selected rows in a Report Control.
CXTPReportSubListControl
Field chooser list box control. This control allows the user to move column names from associated CXTPReportControl object from and to its header.
CXTPReportTip
The CXTPReportTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.
CXTPReportView
The CXTPReportView class provides an implementation of the Report control as view class. Use GetReportCtrl method to access methods of CXTPReportControl
CXTPReportViewPrintOptions
This class used to store printing options.
Files
File | Description
XTPReportColumn.h | XTPReportColumn.h: interface for the CXTPReportColumn class.
XTPReportColumns.h | XTPReportColumns.h: interface for the CXTPReportColumns class.
XTPReportControl.h | XTPReportControl.h: interface for the CXTPReportControl class.
XTPReportDefines.h | XTPReportDefines.h This file is a part of the XTREME REPORTCONTROL MFC class library.
XTPReportDragDrop.h | XTPReportDragDrop.h: interface for the CXTPReportHeaderDragWnd and CXTPReportHeaderDropWnd classes.
XTPReportFilterEditControl.h | XTPReportFilterEditControl.h: interface for the CXTPReportFilterEditControl class.
XTPReportGroupRow.h | XTPReportGroupItem.h: interface for the CXTPReportGroupItem class.
XTPReportHeader.h | XTPReportHeader.h: interface for the CXTPReportHeader class.
XTPReportHyperlink.h | XTPReportHyperlink.h: interface for the CXTPReportHyperlink class.
XTPReportInplaceControls.h | XTPReportInplaceControls.h This file is a part of the XTREME REPORTCONTROL MFC class library.
XTPReportPaintManager.h | XTPReportPaintManager.h: interface for the CXTPReportPaintManager class.
XTPReportRecord.h | XTPReportRecord.h: interface for the CXTPReportRecord class.
XTPReportRecordItem.h | XTPReportRecordItem.h: interface for the CXTPReportRecordItem class.
XTPReportRecordItemText.h | XTPReportRecordItemText.h: interface for the CXTPReportRecordItemText class.
XTPReportRecords.h | XTPReportRecords.h: interface for the CXTPReportRecords class.
XTPReportRow.h | XTPReportRow.h: interface for the CXTPReportRow class.
XTPReportRows.h | XTPReportRows.h: interface for the CXTPReportRows class.
XTPReportSubListControl.h | XTPReportSubListControl.h: interface for the CXTPReportSubListControl class.
XTPReportTip.h | XTPReportTip.h: interface for the CXTPReportTip class.
XTPReportView.h | XTPReportView.h: interface for the CXTPReportView class.
Functions
Function | Description
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_ |
Macros
Macro | Description
XTP_NM_REPORT_BEFORE_COPY_TOTEXT | Defines message for handling CXTPReportControl::OnBeforeCopyToText().
XTP_NM_REPORT_BEFORE_PASTE | Defines message for handling CXTPReportControl::OnBeforePaste().
XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT | Defines message for handling CXTPReportControl::OnBeforePasteFromText().
XTP_NM_REPORT_BEGINDRAG | Indicates the user start dragging records.
XTP_NM_REPORT_BEGINEDIT | Defines message for in-place editing has just started. Send after XTP_NM_REPORT_REQUESTEDIT and when inplace editor has been created.
XTP_NM_REPORT_CHECKED | Defines message for handling row checking event.
XTP_NM_REPORT_COLUMNORDERCHANGED | Defines message for column changed event.
XTP_NM_REPORT_COLUMNWIDTHCHANGED | Defines message for handling CXTPReportHeader::AdjustColumnsWidth().
XTP_NM_REPORT_CONSTRAINT_SELECTING | Indicates the user changed a selected item in the combobox.
XTP_NM_REPORT_DRAGDROP_COMPLETED | Indicates the user completed drag&drop operation.
XTP_NM_REPORT_DRAGOVER | Indicates the user is dragging records over a control.
XTP_NM_REPORT_DROP | Indicates the user dropped records to report control.
XTP_NM_REPORT_EDIT_CANCELED | Defines message for in-place editing is canceled and value is not changed event.
XTP_NM_REPORT_FOCUS_CHANGING | Defines message for handling focus changing event.
XTP_NM_REPORT_GETITEMMETRICS | Defines message for handling CXTPReportControl::GetItemMetrics().
XTP_NM_REPORT_GETTOOLTIPINFO | Indicates the tooltip will be drawn.
XTP_NM_REPORT_GROUPORDERCHANGED | Defines message for column group order changed event.
XTP_NM_REPORT_HEADER_RCLICK | Defines message for header context menu
XTP_NM_REPORT_HYPERLINK | Defines message for handling hyperlink click event.
XTP_NM_REPORT_INPLACEBUTTONDOWN | Defines message for in-place button click event.
XTP_NM_REPORT_ITEMBUTTONCLICK | Defines message for item button click event.
XTP_NM_REPORT_LBUTTONDOWN | Defines message for left mouse button click.
XTP_NM_REPORT_PRESORTORDERCHANGED | Defines message when a column header has been clicked and the sort order has changed, but CXTPReportControl::Populate has NOT yet been called.
XTP_NM_REPORT_PREVIEWKEYDOWN | Defines message for handling CXTPReportControl::OnPreviewKeyDown().
XTP_NM_REPORT_RECORDS_DROPPED | Indicates the records were dropped to report control.
XTP_NM_REPORT_REQUESTEDIT | Defines message for handling CXTPReportControl::OnRequestEdit().
XTP_NM_REPORT_ROWEXPANDED | Defines message for row expand event.
XTP_NM_REPORT_SELCHANGED | Defines message for handling rows selection changed event.
XTP_NM_REPORT_SELCHANGING | Defines message for selected rows collection changing. Send for each row when it added/removed.
XTP_NM_REPORT_SORTORDERCHANGED | Defines message for sort changed event.
XTP_NM_REPORT_VALUECHANGED | Defines message for value changed event.
Structs, Records, Enums
Struct, Record, Enum | Description
XTP_NM_REPORT_BEFORE_COPYPASTE | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window.
XTP_NM_REPORTCOLUMNRESIZE | This structure is sent to Main window in a WM_NOTIFY message after column is resized.
XTP_NM_REPORTCONSTRAINTSELECTING | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTDRAGDROP | This structure is sent to main window in a WM_NOTIFY message from from report control to determine Records was dragged or dropped
XTP_NM_REPORTINPLACEBUTTON | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTITEMMETRICS | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTPREVIEWKEYDOWN | This structure is sent to Main window in a WM_NOTIFY message before processing OnKeyDown event.
XTP_NM_REPORTRECORDITEM | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTREQUESTEDIT | A set of parameters transferred with XTP_NM_REPORT_REQUESTEDIT message
XTP_NM_REPORTTOOLTIPINFO | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_SELECTION_CHANGING | This struct defines data for XTP_NM_REPORT_SELCHANGING notification.
XTP_REPORTRECORDITEM_ARGS | Basic set of parameters transferred to item handlers. This structure groups together essential parameters used in items processing activities. It is parent for all other structures: XTP_REPORTRECORDITEM_DRAWARGS, XTP_REPORTRECORDITEM_CLICKARGS
XTP_REPORTRECORDITEM_CLICKARGS | A set of parameters transferred to mouse click item handlers. It inherits essential parameters from XTP_REPORTRECORDITEM_ARGS.
XTP_REPORTRECORDITEM_DRAWARGS | A set of parameters transferred to Draw item handler. It inherits essential parameters from XTP_REPORTRECORDITEM_ARGS.
XTP_REPORTRECORDITEM_METRICS | Record item drawing metrics. Its helper structures group together parameters to store general drawing metrics
XTPReportColumnBestFitMode | This enum defines the best fit mode.
XTPReportColumnIconAlignment | This enum defines alignment style for the column icon and text.
XTPReportColumnStyle | Represents predefined column styles.
XTPReportDragDrop | Enumeration of drag and drop flags
XTPReportElementRect | Enumeration of GetElementRect flags
XTPReportFixedRowsDividerStyle | Represent the Header/Footer rows devider style.
XTPReportFreezeColsDividerStyle | Represents predefined freeze column line styles:
XTPReportGridStyle | Represents predefined grid line styles:
XTPReportGroupRowIconAlignment | This enum defines alignment style for the group row custom icon.
XTPReportMouseMode | Enumeration of operational mouse modes.
XTPReportRowType | This enum defines body, header, and footer rows.
XTPReportSelectionChangeType | This enum defines selection change action.
XTPReportTreeStructureStyle | Represent the style of lines used to draw a hierarchical tree structure.
XTPReportVirtualRowFlags | This enum defines flags for virtual row metrics.
XTPReportWatermarkAlignment | Enumeration of watermark alignment flags
Types
Type | Description
CXTPReportHyperlinks_base | This typedef used to declare a base class for CXTPReportHyperlinks.
Variables
Variable | Description
XTP_ID_REPORT_COMBOBUTTON | Constructs a CXTPReportInplaceButton object
XTP_ID_REPORT_CONTROL | Identifier of report control child window of CXTPReportView.
XTP_ID_REPORT_EXPANDBUTTON | Constructs a CXTPReportInplaceButton object
XTP_ID_REPORT_SPINBUTTON | Constructs a CXTPReportInplaceButton object
XTP_REPORT_COLOR_DEFAULT | This constant indicates that a COLORREF is not defined.
XTP_REPORT_NOICON | This constant indicates that an icon ID is not defined.
XTPREPORTCTRL_CF_RECORDS | Report control records clipboard format name.
XTPREPORTCTRL_CLASSNAME | NULL terminated string used by CXTPReportControl which specifies the window class name for the report control.


Report Control Hierarchy

Report Control
Report Control Hierarchy

Module

Report Control


Classes

Classes, Report Control
Classes
Classes
Class
Description
CXTPFormulaMulDivC
This class used to store MulDivC formula parameters and perform calculation. MulDivC formula if the folowing:

  • = y * Mul / Div + C

CXTPReportColumn
Represents report column item with its properties and operations.
CXTPReportColumnOrder
Represents column order, used for sorting and grouping.
CXTPReportColumns
This class is a collection of report columns objects, each of which can be referred to by its zero-based index.
CXTPReportControl
The CXTPReportControl class provides an implementation of the Report control.
CXTPReportControlLocale
Helper class with static member functions to control active locale for Report Control and perform some locale dependent tasks.
CXTPReportFilterEditControl
The CXTPReportFilterEditControl class provides the functionality of the filter string edit control, associated to the main Report control window.
CXTPReportGroupRow
This class represents a 'group row' of the report control view - that means a row which has no associated Record item, but has a special text caption instead.
CXTPReportHeader
A report header is a part of the report window positioned above columns of text or numbers. It contains a title for each column, and it can be divided into parts. The user can drag the dividers that separate the parts to set the width of each column.
CXTPReportHeaderDragWnd
CXTPReportHeaderDragWnd is CWnd derived class, it used internally to represent dragging column window.
CXTPReportHeaderDropWnd
CXTPReportHeaderDropWnd is CWnd derived class, it used internally to represent drop target arrows.
CXTPReportHyperlink
This class represents hyperlinks. It stores first position and length in the text for hyperlink and rectangle for drawing and identify clicks on hyperlink. To create an instance of its class, you simply call constructor with first position and length of the hyperlink's text
CXTPReportHyperlinks
This class represents array of pointers to CXTPReportHyperlink objects. InternalRelease is called for each item in the array destructor. Also serialization for array items is provided (see DoPropExchange method).
CXTPReportInplaceButton
CXTPReportInplaceButton is the CXTPReportInplaceControl derived class, it represents combo button and expand button of report cell.
CXTPReportInplaceButtons
This class represents collection of the in-place buttons of the single item of the report control.
CXTPReportInplaceControl
CXTPReportInplaceControl is the base class for all in-place controls of report control item.
CXTPReportInplaceEdit
CXTPReportInplaceEdit is the CXTPReportInplaceControl derived class, it represents edit control to allow users change cell of report control.
CXTPReportInplaceList
CXTPReportInplaceList is the CXTPReportInplaceControl derived class, it represents list box with constraints of item.
CXTPReportPageSetupDialog
Customized Calendar control page setup dialog.
CXTPReportPaintManager
Utility class, handling most of the drawing activities. It stores all settings, needed by a control to perform drawing operations: fonts, colors, styles for all other classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with device context.
CXTPReportRecord
CXTPReportRecord represents a collection of objects of CXTPReportRecordItem or objects of classes that are children of CXTPReportRecordItem. A collection of such items is one record in ReportControl list. You create an object of CXTPReportRecord by simply calling constructor. After it you can add items to the record.
CXTPReportRecordItem
Class for working with single list cell. Base class for extended list cells. It determines the behavior of all specific record items. You don't use its class directly in the control. If you wish to add your own Record Item to the control, you must inherit it from CXTPReportRecordItem. Most member functions in this class are virtual.
CXTPReportRecordItemConstraint
CXTPReportRecordItemConstraint is a CCmdTarget derived class. It represents a single item constraints.
CXTPReportRecordItemConstraints
CXTPReportRecordItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.
CXTPReportRecordItemDateTime
Represents a time cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemEditOptions
This class represents edit options of the single item or column
CXTPReportRecordItemNumber
This class represents a numeric cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemPreview
This represents a preview cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemText
This Class represents a text-only cell and inherits basic functionality from CXTPReportRecordItem class. You create a text record item simply by calling a constructor with one parameter - text string
CXTPReportRecordItemVariant
Represents a variant item and inherits basic functionality from CXTPReportRecordItem class. You can create a bitmap record item simply by calling a constructor with the only one parameter - value of VARIANT type.
CXTPReportRecords
This class represents a records collection class. It supports an array of CXTPReportRecord pointers.
CXTPReportRow
CXTPReportRow class represents an row of the report control window.
CXTPReportRows
This class represents a rows collection class. It supports an array of CXTPReportRow pointers.
CXTPReportSelectedRows
Encapsulates a collection of CXTPReportRow pointers that represent the selected rows in a Report Control.
CXTPReportSubListControl
Field chooser list box control. This control allows the user to move column names from associated CXTPReportControl object from and to its header.
CXTPReportTip
The CXTPReportTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.
CXTPReportView
The CXTPReportView class provides an implementation of the Report control as view class. Use GetReportCtrl method to access methods of CXTPReportControl
CXTPReportViewPrintOptions
This class used to store printing options.
Module

Report Control


CXTPFormulaMulDivC Class

XTPReportPaintManager.h, Classes, Legend, Members, Topics, CXTPFormulaMulDivC Data Members, CXTPFormulaMulDivC Methods, CXTPFormulaMulDivC Constructors, CXTPFormulaMulDivC Destructors, CXTPFormulaMulDivC Constructors, CXTPFormulaMulDivC Data Members, CXTPFormulaMulDivC Destructors, CXTPFormulaMulDivC Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPFormulaMulDivC Class

This class used to store MulDivC formula parameters and perform calculation. MulDivC formula if the folowing:

  • = y * Mul / Div + C
Class Hierarchy

class CXTPFormulaMulDivC;
File

XTPReportPaintManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPFormulaMulDivC Constructors
CXTPFormulaMulDivC Constructors | Description
CXTPFormulaMulDivC | Default object constructor.
CXTPFormulaMulDivC Data Members
CXTPFormulaMulDivC Data Members | Description
m_nConstant | Store a constant value.
m_nDivisor | Store a divisor value.
m_nMultiplier | Store a multiplier value.
CXTPFormulaMulDivC Destructors
CXTPFormulaMulDivC Destructors | Description
~CXTPFormulaMulDivC | Default object destructor.
CXTPFormulaMulDivC Methods
CXTPFormulaMulDivC Methods | Description
Calculate | Perform formula calculation.
GetStandardValue | Get formula parameters.
SetStandardValue | Set formula parameters.


CXTPFormulaMulDivC Data Members

CXTPFormulaMulDivC Class, Legend, Protected Data Members
CXTPFormulaMulDivC Data Members
Class

CXTPFormulaMulDivC Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nConstant | Store a constant value.
m_nDivisor | Store a divisor value.
m_nMultiplier | Store a multiplier value.


CXTPFormulaMulDivC::m_nConstant Data Member

CXTPFormulaMulDivC Data Members, CXTPFormulaMulDivC Class
CXTPFormulaMulDivC::m_nConstant Data Member

Store a constant value.

int m_nConstant;
Group

CXTPFormulaMulDivC Data Members


CXTPFormulaMulDivC::m_nDivisor Data Member

CXTPFormulaMulDivC Data Members, CXTPFormulaMulDivC Class
CXTPFormulaMulDivC::m_nDivisor Data Member

Store a divisor value.

int m_nDivisor;
Group

CXTPFormulaMulDivC Data Members


CXTPFormulaMulDivC::m_nMultiplier Data Member

CXTPFormulaMulDivC Data Members, CXTPFormulaMulDivC Class
CXTPFormulaMulDivC::m_nMultiplier Data Member

Store a multiplier value.

int m_nMultiplier;
Group

CXTPFormulaMulDivC Data Members


CXTPFormulaMulDivC Methods

CXTPFormulaMulDivC Class, Legend, Public Methods
CXTPFormulaMulDivC Methods
Class

CXTPFormulaMulDivC Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Calculate | Perform formula calculation.
GetStandardValue | Get formula parameters.
SetStandardValue | Set formula parameters.


CXTPFormulaMulDivC::Calculate Method

CXTPFormulaMulDivC Methods, CXTPFormulaMulDivC Class
CXTPFormulaMulDivC::Calculate Method

Perform formula calculation.

virtual int Calculate(
    int nY
) const;
Parameters

nY
A 'y' formula parameter value.

Returns

Returns value calculated by formula: y * Mul / Div + C

Group

CXTPFormulaMulDivC Methods


CXTPFormulaMulDivC::GetStandardValue Method

CXTPFormulaMulDivC Methods, CXTPFormulaMulDivC Class
CXTPFormulaMulDivC::GetStandardValue Method

Get formula parameters.

virtual void GetStandardValue(
    int& rnMul,
    int& rnDiv,
    int& rnC
);
Parameters

rnMul
An int reference to receive multiplier value.
rnDiv
An int reference to receive divisor value.
rnC
An int reference to receive constant value.

Group

CXTPFormulaMulDivC Methods


CXTPFormulaMulDivC::SetStandardValue Method

CXTPFormulaMulDivC Methods, CXTPFormulaMulDivC Class
CXTPFormulaMulDivC::SetStandardValue Method

Set formula parameters.

virtual void SetStandardValue(
    int nMul,
    int nDiv,
    int nC
);
Parameters

nMul
A multiplier value.
nDiv
A divisor value.
nC
A constant value.

Group

CXTPFormulaMulDivC Methods


CXTPFormulaMulDivC Constructors

CXTPFormulaMulDivC Class, Legend, Public Methods
CXTPFormulaMulDivC Constructors
Class

CXTPFormulaMulDivC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPFormulaMulDivC | Default object constructor.


CXTPFormulaMulDivC::CXTPFormulaMulDivC Constructor

CXTPFormulaMulDivC Constructors, CXTPFormulaMulDivC Class
CXTPFormulaMulDivC::CXTPFormulaMulDivC Constructor

Default object constructor.

CXTPFormulaMulDivC();
Group

CXTPFormulaMulDivC Constructors


CXTPFormulaMulDivC Destructors

CXTPFormulaMulDivC Class, Legend, Public Methods
CXTPFormulaMulDivC Destructors
Class

CXTPFormulaMulDivC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPFormulaMulDivC | Default object destructor.


CXTPFormulaMulDivC::~CXTPFormulaMulDivC Destructor

CXTPFormulaMulDivC Destructors, CXTPFormulaMulDivC Class
CXTPFormulaMulDivC::~CXTPFormulaMulDivC Destructor

Default object destructor.

virtual ~CXTPFormulaMulDivC();
Group

CXTPFormulaMulDivC Destructors


CXTPReportColumn Class

XTPReportColumn.h, Classes, Legend, Members, Topics, CXTPReportColumn Data Members, CXTPReportColumn Methods, CXTPReportColumn Constructors, CXTPReportColumn Destructors, CXTPReportColumn Constructors, CXTPReportColumn Data Members, CXTPReportColumn Destructors, CXTPReportColumn Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn Class

Represents report column item with its properties and operations.

Class Hierarchy

class CXTPReportColumn;
File

XTPReportColumn.h

Remarks

You create object of CXTPReportColumn by calling a constructor and provide all necessary parameters. Many of the parameters have default values. Column has 3 properties that greatly influence its behavior:

bAutoSize - TRUE allows auto resizing of the width of columns when ReportControl's client area is resized by the user. If bAutoSize is set to FALSE, the column keeps its initial size

bSortable - Allows column to be sortable if it has value TRUE. If you set it to FALSE, you won't be able to sort records by their column

bVisible - Determines if columns will draw by control or not. For example, if the column is dragged into FieldChooser, the column still exists in the columns list, but it becomes invisible.

See Also

CXTPReportControl, CXTPReportColumns

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportColumn Constructors
CXTPReportColumn Constructors | Description
CXTPReportColumn |
CXTPReportColumn Data Members
CXTPReportColumn Data Members | Description
m_bAllowDrag | Allow/disallow dragging of the column
m_bAllowRemove | TRUE to allow column remove
m_bAutoSize | TRUE if column auto sized.
m_bAutoSortWhenGrouped | If TRUE this column will be sortable when grouped by, otherwise it will grouped without sorting by it (sort by other columns wiil be applied).
m_bDrawFooterDivider | If TRUE - draw footer column right divider.
m_bDrawFooterRowsVGrid | Indicates whether to draw vertical grid for footers rows.
m_bDrawHeaderDivider | If TRUE - draw header column right divider.
m_bDrawHeaderRowsVGrid | Indicates whether to draw vertical grid for headers rows.
m_bEditable | Indicates whether an edit box should be added to the items in the column.
m_bFiltrable | Is filtering by this column allowed?.
m_bGroupable | Determines if the column could be grouped by.
m_bIsResizable | Indicates if the column allows width resizing
m_bShowInFieldChooser | Indicates if column is shown in the field chooser when the column is hidden or in the GroupBy Box.
m_bSortable | Determines if the column could be sortable by.
m_bSortIncreasing | Stores column sort direction (used when m_bSortable is TRUE).
m_bVisible | Visible state.
m_fontFooter | Column Footer font.
m_nAlignment | Alignment mode for column: DT_LEFT || DT_RIGHT || DT_CENTER
m_nBestFitMode | Best fit mode.
m_nColumnAutoWidth | The column a automatic width
m_nColumnStaticWidth | The user defined with.
m_nFooterAlignment | Alignment mode for column footer text: DT_LEFT || DT_RIGHT || DT_CENTER
m_nHeaderAlignment | Alignment mode for column text: DT_LEFT || DT_RIGHT || DT_CENTER
m_nIconID | Associated icon ID.
m_nItemIndex | Column index.
m_nMaxItemWidth | Contains maximal width of the corresponding item drawn in the column.
m_nMinWidth | Minimal column width.
m_pColumns | Stores a pointer to the parent columns collection.
m_pEditOptions | Edit options of the column
m_rcColumn | Saves rectangle where column was drawn last time.
m_rcGroupBy | Saves rectangle where column was drawn in group box.
m_strFooterText | Column Footer Text.
m_strInternalName | Internal column name (to serialize colunm options).
m_strName | Column name.
m_strTooltip | Column tooltip.
CXTPReportColumn Destructors
CXTPReportColumn Destructors | Description
~CXTPReportColumn | Destroys a CXTPReportColumn object, handles cleanup and deallocation
CXTPReportColumn Methods
CXTPReportColumn Methods | Description
AllowRemove | Allows/disallows column removing.
DoPropExchange | Reads or writes column data to/from the provided archive stream.
EnableResize | Enable/Disables the column's allow resizing mode.
EnsureVisible | Call this member to force this column to be visible. This will cause the report control to scroll to this column.
GetAlignment | Returns the current alignment value for the column.
GetBestFitMode | Call this member to determine the column best fit mode.
GetCaption | Returns the text caption for the column header.
GetCaptionWidth | Calculates caption length.
GetColumns | Retrieves columns array
GetControl | Retrieved parent report control
GetDrawFooterDivider | Returns is right column footer divider visible.
GetDrawFooterRowsVGrid | Call this member to determine if vertical grid to be shown for footer rows.
GetDrawHeaderDivider | Returns is right column header divider visible.
GetDrawHeaderRowsVGrid | Call this member to determine if vertical grid to be shown for header rows.
GetEditOptions | Retrieves CXTPReportRecordItemEditOptions.
GetFooterAlignment | Returns the current alignment value for the column footer.
GetFooterFont | Returns the footer font for the column.
GetFooterText | Returns the footer text for the column.
GetHeaderAlignment | Returns the current alignment for the column text.
GetIconID | Returns the ID of the associated column header icon.
GetIndent | Returns column indentation.
GetIndex | Returns the index of the column.
GetInternalName | Returns internal column name which used in serialization to unique identify column rather than column index.
GetItemIndex | Returns the index of the associated record item.
GetMinWidth | Returns the current minimal column width.
GetPrintWidth | Returns column print width.
GetRect | Returns the last drawn column rect.
GetTooltip | Returns the text tool tip for the column header.
GetWidth | Returns column width.
HasSortTriangle | Checks if the column header should have the sort triangle drawn.
IsAllowDragging | Returns the column dragging allowance flag.
IsAllowRemove | Call this member to determine if column removing allowed.
IsAutoSize | Call this method to set the column auto sized.
IsAutoSortWhenGrouped | Determine is this column sortable when grouped by.
IsDragging | Returns current column header drag mode.
IsEditable | Call this member to determine if an edit box is added for the items in the column.
IsFiltrable | Returns the current column header filtrability mode.
IsGroupable | Call this member to determine if the column can be grouped.
IsHotTracking | Determines if group is highlighted
IsResizable | Returns column allow resizing state.
IsShowInFieldChooser | Call this member to determine if the column header will appear in the field chooser when hidden or in the GroupBy Box.
IsSortable | Returns the column sortable flag.
IsSorted | Determines if the column is sorted.
IsSortedDecreasing | Determines if the column is sorted in the decreasing order.
IsSortedIncreasing | Determines if the column is sorted in the increasing order.
IsTreeColumn | Returns TRUE if the current column contains tree.
IsVisible | Returns the current column header visibility mode.
SetAlignment | Sets new Alignment value for column.
SetAllowDrag | Call this member to specify whether the column can be dragged.
SetAutoSortWhenGrouped | Call this member to specify whether the column sortable when grouped by.
SetBestFitMode | Call this member to specify the column best fit mode.
SetCaption | Call this member to set/change the column header caption.
SetDrawFooterDivider | Call this member to set/change is the right column footer divider visible.
SetDrawFooterRowsVGrid | Call this member to specify whether to show vertical grid for footer rows.
SetDrawHeaderDivider | Call this member to set/change is the right column header divider visible.
SetDrawHeaderRowsVGrid | Call this member to specify whether to show vertical grid for header rows.
SetEditable | Call this member to specify whether the CXTPReportRecordItem(s) in the column can be edited. This will add an edit box to edit the item when the item is click/double-clicked. This can be overridden for individual items if the CXTPReportRecordItem::SetEditable member is called.
SetFiltrable | Sets column filtrable mode (TRUE - filtrable, FALSE - not filtrable).
SetFooterAlignment | Sets new Alignment for column footer.
SetFooterFont | Call this member to set/change the column footer font.
SetFooterText | Call this member to set/change the column footer text.
SetGroupable | Call this member to specify whether the column can be grouped.
SetHeaderAlignment | Sets new Alignment for column text.
SetIconID | Sets the ID of the associated column header icon.
SetInternalName | Sets internal column name which used in serialization to unique identify column rather than column index.
SetMinWidth | Sets minimal width value for column.
SetShowInFieldChooser | Call this member to specify whether the column will appear in the FieldChooser when the column is hidden or in the "Group By Box."
SetSortable | Call this member to specify whether the column can be sorted when the user clicks on the column header.
SetSortIncreasing | Call this member to specify that the column is sorted in the increasing order.
SetTooltip | Call this member to set/change the column tool tip.
SetTreeColumn | Makes/unmakes the current column as containing a tree inside.
SetVisible | Sets column visible mode (TRUE - visible, FALSE - invisible).
SetWidth | Sets column width.


CXTPReportColumn Data Members

CXTPReportColumn Class, Legend, Protected Data Members
CXTPReportColumn Data Members
Class

CXTPReportColumn Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAllowDrag | Allow/disallow dragging of the column
m_bAllowRemove | TRUE to allow column remove
m_bAutoSize | TRUE if column auto sized.
m_bAutoSortWhenGrouped | If TRUE this column will be sortable when grouped by, otherwise it will grouped without sorting by it (sort by other columns wiil be applied).
m_bDrawFooterDivider | If TRUE - draw footer column right divider.
m_bDrawFooterRowsVGrid | Indicates whether to draw vertical grid for footers rows.
m_bDrawHeaderDivider | If TRUE - draw header column right divider.
m_bDrawHeaderRowsVGrid | Indicates whether to draw vertical grid for headers rows.
m_bEditable | Indicates whether an edit box should be added to the items in the column.
m_bFiltrable | Is filtering by this column allowed?.
m_bGroupable | Determines if the column could be grouped by.
m_bIsResizable | Indicates if the column allows width resizing
m_bShowInFieldChooser | Indicates if column is shown in the field chooser when the column is hidden or in the GroupBy Box.
m_bSortable | Determines if the column could be sortable by.
m_bSortIncreasing | Stores column sort direction (used when m_bSortable is TRUE).
m_bVisible | Visible state.
m_fontFooter | Column Footer font.
m_nAlignment | Alignment mode for column: DT_LEFT || DT_RIGHT || DT_CENTER
m_nBestFitMode | Best fit mode.
m_nColumnAutoWidth | The column a automatic width
m_nColumnStaticWidth | The user defined with.
m_nFooterAlignment | Alignment mode for column footer text: DT_LEFT || DT_RIGHT || DT_CENTER
m_nHeaderAlignment | Alignment mode for column text: DT_LEFT || DT_RIGHT || DT_CENTER
m_nIconID | Associated icon ID.
m_nItemIndex | Column index.
m_nMaxItemWidth | Contains maximal width of the corresponding item drawn in the column.
m_nMinWidth | Minimal column width.
m_pColumns | Stores a pointer to the parent columns collection.
m_pEditOptions | Edit options of the column
m_rcColumn | Saves rectangle where column was drawn last time.
m_rcGroupBy | Saves rectangle where column was drawn in group box.
m_strFooterText | Column Footer Text.
m_strInternalName | Internal column name (to serialize colunm options).
m_strName | Column name.
m_strTooltip | Column tooltip.


CXTPReportColumn::m_bAllowDrag Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bAllowDrag Data Member

Allow/disallow dragging of the column

BOOL m_bAllowDrag;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bAllowRemove Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bAllowRemove Data Member

TRUE to allow column remove

BOOL m_bAllowRemove;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bAutoSize Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bAutoSize Data Member

TRUE if column auto sized.

BOOL m_bAutoSize;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bAutoSortWhenGrouped Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bAutoSortWhenGrouped Data Member

If TRUE this column will be sortable when grouped by, otherwise it will grouped without sorting by it (sort by other columns wiil be applied).

BOOL m_bAutoSortWhenGrouped;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bDrawFooterDivider Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bDrawFooterDivider Data Member

If TRUE - draw footer column right divider.

BOOL m_bDrawFooterDivider;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bDrawFooterRowsVGrid Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bDrawFooterRowsVGrid Data Member

Indicates whether to draw vertical grid for footers rows.

BOOL m_bDrawFooterRowsVGrid;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bDrawHeaderDivider Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bDrawHeaderDivider Data Member

If TRUE - draw header column right divider.

BOOL m_bDrawHeaderDivider;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bDrawHeaderRowsVGrid Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bDrawHeaderRowsVGrid Data Member

Indicates whether to draw vertical grid for headers rows.

BOOL m_bDrawHeaderRowsVGrid;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bEditable Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bEditable Data Member

Indicates whether an edit box should be added to the items in the column.

BOOL m_bEditable;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bFiltrable Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bFiltrable Data Member

Is filtering by this column allowed?.

BOOL m_bFiltrable;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bGroupable Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bGroupable Data Member

Determines if the column could be grouped by.

BOOL m_bGroupable;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bIsResizable Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bIsResizable Data Member

Indicates if the column allows width resizing

BOOL m_bIsResizable;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bShowInFieldChooser Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bShowInFieldChooser Data Member

Indicates if column is shown in the field chooser when the column is hidden or in the GroupBy Box.

BOOL m_bShowInFieldChooser;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bSortable Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bSortable Data Member

Determines if the column could be sortable by.

BOOL m_bSortable;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bSortIncreasing Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bSortIncreasing Data Member

Stores column sort direction (used when m_bSortable is TRUE).

BOOL m_bSortIncreasing;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_bVisible Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_bVisible Data Member

Visible state.

BOOL m_bVisible;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_fontFooter Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_fontFooter Data Member

Column Footer font.

CFont m_fontFooter;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nAlignment Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nAlignment Data Member

Alignment mode for column: DT_LEFT || DT_RIGHT || DT_CENTER

int m_nAlignment;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nBestFitMode Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nBestFitMode Data Member

Best fit mode.

int m_nBestFitMode;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nColumnAutoWidth Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nColumnAutoWidth Data Member

The column a automatic width

int m_nColumnAutoWidth;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nColumnStaticWidth Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nColumnStaticWidth Data Member

The user defined with.

int m_nColumnStaticWidth;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nFooterAlignment Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nFooterAlignment Data Member

Alignment mode for column footer text: DT_LEFT || DT_RIGHT || DT_CENTER

int m_nFooterAlignment;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nHeaderAlignment Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nHeaderAlignment Data Member

Alignment mode for column text: DT_LEFT || DT_RIGHT || DT_CENTER

int m_nHeaderAlignment;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nIconID Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nIconID Data Member

Associated icon ID.

int m_nIconID;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nItemIndex Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nItemIndex Data Member

Column index.

int m_nItemIndex;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nMaxItemWidth Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nMaxItemWidth Data Member

Contains maximal width of the corresponding item drawn in the column.

int m_nMaxItemWidth;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_nMinWidth Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_nMinWidth Data Member

Minimal column width.

int m_nMinWidth;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_pColumns Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_pColumns Data Member

Stores a pointer to the parent columns collection.

CXTPReportColumns* m_pColumns;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_pEditOptions Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_pEditOptions Data Member

Edit options of the column

CXTPReportRecordItemEditOptions* m_pEditOptions;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_rcColumn Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_rcColumn Data Member

Saves rectangle where column was drawn last time.

CRect m_rcColumn;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_rcGroupBy Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_rcGroupBy Data Member

Saves rectangle where column was drawn in group box.

CRect m_rcGroupBy;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_strFooterText Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_strFooterText Data Member

Column Footer Text.

CString m_strFooterText;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_strInternalName Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_strInternalName Data Member

Internal column name (to serialize colunm options).

CString m_strInternalName;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_strName Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_strName Data Member

Column name.

CString m_strName;
Group

CXTPReportColumn Data Members


CXTPReportColumn::m_strTooltip Data Member

CXTPReportColumn Data Members, CXTPReportColumn Class
CXTPReportColumn::m_strTooltip Data Member

Column tooltip.

CString m_strTooltip;
Group

CXTPReportColumn Data Members


CXTPReportColumn Methods

CXTPReportColumn Class, Legend, Public Methods
CXTPReportColumn Methods
Class

CXTPReportColumn Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AllowRemove | Allows/disallows column removing.
DoPropExchange | Reads or writes column data to/from the provided archive stream.
EnableResize | Enable/Disables the column's allow resizing mode.
EnsureVisible | Call this member to force this column to be visible. This will cause the report control to scroll to this column.
GetAlignment | Returns the current alignment value for the column.
GetBestFitMode | Call this member to determine the column best fit mode.
GetCaption | Returns the text caption for the column header.
GetCaptionWidth | Calculates caption length.
GetColumns | Retrieves columns array
GetControl | Retrieved parent report control
GetDrawFooterDivider | Returns is right column footer divider visible.
GetDrawFooterRowsVGrid | Call this member to determine if vertical grid to be shown for footer rows.
GetDrawHeaderDivider | Returns is right column header divider visible.
GetDrawHeaderRowsVGrid | Call this member to determine if vertical grid to be shown for header rows.
GetEditOptions | Retrieves CXTPReportRecordItemEditOptions.
GetFooterAlignment | Returns the current alignment value for the column footer.
GetFooterFont | Returns the footer font for the column.
GetFooterText | Returns the footer text for the column.
GetHeaderAlignment | Returns the current alignment for the column text.
GetIconID | Returns the ID of the associated column header icon.
GetIndent | Returns column indentation.
GetIndex | Returns the index of the column.
GetInternalName | Returns internal column name which used in serialization to unique identify column rather than column index.
GetItemIndex | Returns the index of the associated record item.
GetMinWidth | Returns the current minimal column width.
GetPrintWidth | Returns column print width.
GetRect | Returns the last drawn column rect.
GetTooltip | Returns the text tool tip for the column header.
GetWidth | Returns column width.
HasSortTriangle | Checks if the column header should have the sort triangle drawn.
IsAllowDragging | Returns the column dragging allowance flag.
IsAllowRemove | Call this member to determine if column removing allowed.
IsAutoSize | Call this method to set the column auto sized.
IsAutoSortWhenGrouped | Determine is this column sortable when grouped by.
IsDragging | Returns current column header drag mode.
IsEditable | Call this member to determine if an edit box is added for the items in the column.
IsFiltrable | Returns the current column header filtrability mode.
IsGroupable | Call this member to determine if the column can be grouped.
IsHotTracking | Determines if group is highlighted
IsResizable | Returns column allow resizing state.
IsShowInFieldChooser | Call this member to determine if the column header will appear in the field chooser when hidden or in the GroupBy Box.
IsSortable | Returns the column sortable flag.
IsSorted | Determines if the column is sorted.
IsSortedDecreasing | Determines if the column is sorted in the decreasing order.
IsSortedIncreasing | Determines if the column is sorted in the increasing order.
IsTreeColumn | Returns TRUE if the current column contains tree.
IsVisible | Returns the current column header visibility mode.
SetAlignment | Sets new Alignment value for column.
SetAllowDrag | Call this member to specify whether the column can be dragged.
SetAutoSortWhenGrouped | Call this member to specify whether the column sortable when grouped by.
SetBestFitMode | Call this member to specify the column best fit mode.
SetCaption | Call this member to set/change the column header caption.
SetDrawFooterDivider | Call this member to set/change is the right column footer divider visible.
SetDrawFooterRowsVGrid | Call this member to specify whether to show vertical grid for footer rows.
SetDrawHeaderDivider | Call this member to set/change is the right column header divider visible.
SetDrawHeaderRowsVGrid | Call this member to specify whether to show vertical grid for header rows.
SetEditable | Call this member to specify whether the CXTPReportRecordItem(s) in the column can be edited. This will add an edit box to edit the item when the item is click/double-clicked. This can be overridden for individual items if the CXTPReportRecordItem::SetEditable member is called.
SetFiltrable | Sets column filtrable mode (TRUE - filtrable, FALSE - not filtrable).
SetFooterAlignment | Sets new Alignment for column footer.
SetFooterFont | Call this member to set/change the column footer font.
SetFooterText | Call this member to set/change the column footer text.
SetGroupable | Call this member to specify whether the column can be grouped.
SetHeaderAlignment | Sets new Alignment for column text.
SetIconID | Sets the ID of the associated column header icon.
SetInternalName | Sets internal column name which used in serialization to unique identify column rather than column index.
SetMinWidth | Sets minimal width value for column.
SetShowInFieldChooser | Call this member to specify whether the column will appear in the FieldChooser when the column is hidden or in the "Group By Box."
SetSortable | Call this member to specify whether the column can be sorted when the user clicks on the column header.
SetSortIncreasing | Call this member to specify that the column is sorted in the increasing order.
SetTooltip | Call this member to set/change the column tool tip.
SetTreeColumn | Makes/unmakes the current column as containing a tree inside.
SetVisible | Sets column visible mode (TRUE - visible, FALSE - invisible).
SetWidth | Sets column width.


CXTPReportColumn::AllowRemove Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::AllowRemove Method

Allows/disallows column removing.

void AllowRemove(
    BOOL bAllow
);
Parameters

bAllow
TRUE for allowing column removing, FALSE for disallowing.

Remarks

Usually user is allowed to remove a column using mouse drag and drop. Using this member function, you can change the user's permissions force allowing or disallowing of column removing.

See Also

CXTPReportHeader::AllowColumnRemove

Body Source
void CXTPReportColumn::AllowRemove(BOOL bAllow) {
    m_bAllowRemove = bAllow;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::DoPropExchange Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::DoPropExchange Method

Reads or writes column data to/from the provided archive stream.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPReportColumn Methods


CXTPReportColumn::EnableResize Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::EnableResize Method

Enable/Disables the column's allow resizing mode.

void EnableResize(
    BOOL bIsResizable
);
Parameters

bIsResizable
TRUE if column will be resizable, FALSE otherwise.

See Also

IsResizable

Body Source
void CXTPReportColumn::EnableResize(BOOL bIsResizable) {
    m_bIsResizable = bIsResizable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::EnsureVisible Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::EnsureVisible Method

Call this member to force this column to be visible. This will cause the report control to scroll to this column.

virtual void EnsureVisible();
Group

CXTPReportColumn Methods


CXTPReportColumn::GetAlignment Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetAlignment Method

Returns the current alignment value for the column.

int GetAlignment() const;
Returns

Current column alignment value. The result is one of the following: DT_LEFT, DT_CENTER, DT_RIGHT.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetBestFitMode Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetBestFitMode Method

Call this member to determine the column best fit mode.

int GetBestFitMode() const;
Returns

nBestFitMode - the column best fit mode.

See Also

SetBestFitMode

Body Source
int CXTPReportColumn::GetBestFitMode() const{
    return m_nBestFitMode;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetCaption Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetCaption Method

Returns the text caption for the column header.

CString GetCaption() const;
Returns

The text caption for the column header.

Remarks

You use GetCaption() to get the current column caption.

Body Source
CString CXTPReportColumn::GetCaption() const{
    return m_strName;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetCaptionWidth Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetCaptionWidth Method

Calculates caption length.

int GetCaptionWidth(
    CDC* pDC
) const;
Parameters

pDC
Device context to calculate width at.

Returns

Caption length in pixels.

Remarks

This function calculates caption text length in logical units using the given device context, current caption font, and string of text.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetColumns Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetColumns Method

Retrieves columns array

CXTPReportColumns* GetColumns() const;
Returns

CXTPReportColumns object

Body Source
CXTPReportColumns* CXTPReportColumn::GetColumns() const{
    return m_pColumns;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetControl Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::GetControl Method

Retrieved parent report control

CXTPReportControl* GetControl() const;
Returns

Parent report control

See Also

GetColumns

Group

CXTPReportColumn Methods


CXTPReportColumn::GetDrawFooterDivider Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetDrawFooterDivider Method

Returns is right column footer divider visible.

BOOL GetDrawFooterDivider();
Returns

Is column footer divider visible.

Remarks

By default divider is visible.

See Also

SetDrawFooterDivider

Body Source
BOOL CXTPReportColumn::GetDrawFooterDivider() {
    return m_bDrawFooterDivider;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetDrawFooterRowsVGrid Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetDrawFooterRowsVGrid Method

Call this member to determine if vertical grid to be shown for footer rows.

BOOL GetDrawFooterRowsVGrid() const;
Returns

TRUE is vertical grid will be shown, FALSE otherwise.

See Also

SetDrawFooterRowsVGrid

Body Source
BOOL CXTPReportColumn::GetDrawFooterRowsVGrid() const{
    return m_bDrawFooterRowsVGrid;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetDrawHeaderDivider Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetDrawHeaderDivider Method

Returns is right column header divider visible.

BOOL GetDrawHeaderDivider();
Returns

Is column footer divider visible.

Remarks

By default divider is visible.

See Also

SetDrawHeaderDivider

Body Source
BOOL CXTPReportColumn::GetDrawHeaderDivider() {
    return m_bDrawHeaderDivider;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetDrawHeaderRowsVGrid Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetDrawHeaderRowsVGrid Method

Call this member to determine if vertical grid to be shown for header rows.

BOOL GetDrawHeaderRowsVGrid() const;
Returns

TRUE is vertical grid will be shown, FALSE otherwise.

See Also

SetDrawHeaderRowsVGrid

Body Source
BOOL CXTPReportColumn::GetDrawHeaderRowsVGrid() const{
    return m_bDrawHeaderRowsVGrid;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetEditOptions Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetEditOptions Method

Retrieves CXTPReportRecordItemEditOptions.

CXTPReportRecordItemEditOptions* GetEditOptions() const;
Returns

Edit Options of column

Body Source
CXTPReportRecordItemEditOptions* CXTPReportColumn::GetEditOptions() const{
    return m_pEditOptions;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetFooterAlignment Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetFooterAlignment Method

Returns the current alignment value for the column footer.

int GetFooterAlignment() const;
Returns

Current column alignment value. The result is one of the following: DT_LEFT, DT_CENTER, DT_RIGHT.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetFooterFont Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::GetFooterFont Method

Returns the footer font for the column.

CFont* GetFooterFont();
Returns

The footer font for the column.

Remarks

The CXTPReportPaintManager::m_fontCaption is used as default footer font.

See Also

SetFooterFont

Group

CXTPReportColumn Methods


CXTPReportColumn::GetFooterText Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetFooterText Method

Returns the footer text for the column.

CString GetFooterText() const;
Returns

The text caption for the column footer.

Remarks

Use SetFooterText() to set the current footer text.

Body Source
CString CXTPReportColumn::GetFooterText() const {
    return m_strFooterText;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetHeaderAlignment Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetHeaderAlignment Method

Returns the current alignment for the column text.

int GetHeaderAlignment() const;
Returns

Current column alignment value. The result is one of the following: DT_LEFT, DT_CENTER, DT_RIGHT.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetIconID Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetIconID Method

Returns the ID of the associated column header icon.

int GetIconID() const;
Returns

The ID of the associated column header icon.

Remarks

Column can have an image that will be drawn on it. You use GetIconID() to get the current image id which passes to the column ID of the column. It must match to one of the ids in the imagelist

Body Source
int CXTPReportColumn::GetIconID() const{
    return m_nIconID;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetIndent Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetIndent Method

Returns column indentation.

int GetIndent() const;
Returns

Previous column indentation in pixels.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetIndex Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetIndex Method

Returns the index of the column.

int GetIndex() const;
Returns

The index of the column.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetInternalName Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetInternalName Method

Returns internal column name which used in serialization to unique identify column rather than column index.

const CString& GetInternalName() const;
Returns

Internal column name string.

Body Source
const CString& CXTPReportColumn::GetInternalName() const {
    return m_strInternalName;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetItemIndex Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetItemIndex Method

Returns the index of the associated record item.

int GetItemIndex() const;
Returns

The index of the associated record item.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetMinWidth Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::GetMinWidth Method

Returns the current minimal column width.

int GetMinWidth() const;
Returns

Column minimal width value in pixels.

See Also

SetMinWidth

Group

CXTPReportColumn Methods


CXTPReportColumn::GetPrintWidth Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetPrintWidth Method

Returns column print width.

int GetPrintWidth(
    int nTotalWidth
) const;
Parameters

nTotalWidth
Total width in pixels.

Returns

The current column width in logical units for print mode.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetRect Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetRect Method

Returns the last drawn column rect.

CRect GetRect() const;
Returns

The client rectangle where the column was drawn last time.

Remarks

Each time when the column is drawing, its rectangle is recalculated to fit in size after ReportControl resizing, Column resizing or moving, etc. You use GetRect() to get the latest rectangle sizes.

Group

CXTPReportColumn Methods


CXTPReportColumn::GetTooltip Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::GetTooltip Method

Returns the text tool tip for the column header.

CString GetTooltip() const;
Returns

The text tool tip for the column header.

Body Source
CString CXTPReportColumn::GetTooltip() const {
    return m_strTooltip;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::GetWidth Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::GetWidth Method

Returns column width.

int GetWidth() const;
Returns

The current column width in logical units.

Remarks

Each time when the column is drawing, its rectangle is recalculated to fit in size after ReportControl resizing, Column resizing or moving, etc. You use GetWidth() to get the latest rectangle width.

Group

CXTPReportColumn Methods


CXTPReportColumn::HasSortTriangle Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::HasSortTriangle Method

Checks if the column header should have the sort triangle drawn.

BOOL HasSortTriangle() const;
Returns

TRUE if the sort triangle should be drawn for this column, FALSE otherwise.

Group

CXTPReportColumn Methods


CXTPReportColumn::IsAllowDragging Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsAllowDragging Method

Returns the column dragging allowance flag.

BOOL IsAllowDragging() const;
Returns

TRUE if the column can be dragged, FALSE otherwise.

See Also

IsDragging

Body Source
BOOL CXTPReportColumn::IsAllowDragging() const{
    return m_bAllowDrag;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsAllowRemove Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsAllowRemove Method

Call this member to determine if column removing allowed.

BOOL IsAllowRemove() const;
Returns

TRUE is the items in the column removing allowed, FALSE otherwise.

See Also

AllowRemove

Body Source
BOOL CXTPReportColumn::IsAllowRemove() const {
    return m_bAllowRemove;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsAutoSize Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsAutoSize Method

Call this method to set the column auto sized.

BOOL IsAutoSize() const;
Returns

TRUE if the column is automatically sized.

Body Source
BOOL CXTPReportColumn::IsAutoSize() const{
    return m_bAutoSize;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsAutoSortWhenGrouped Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsAutoSortWhenGrouped Method

Determine is this column sortable when grouped by.

BOOL IsAutoSortWhenGrouped() const;
Returns

TRUE if the column is sortable when grouped by, FALSE otherwise.

Remarks

TRUE by default. If FALSE - records will be grouped without sorting by this column (sort by other columns will be applied).

Body Source
BOOL CXTPReportColumn::IsAutoSortWhenGrouped() const {
    return m_bAutoSortWhenGrouped;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsDragging Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::IsDragging Method

Returns current column header drag mode.

BOOL IsDragging() const;
Returns

TRUE if the column header is in dragging mode, FALSE otherwise.

Remarks

ReportColumn may be moved (change order of columns, delete columns from header, move column to FieldChooser) using drag and drop. When column is moved, it is in Dragged mode. You use IsDragging() to determine if columns are in Dragged mode

See Also

IsAllowDragging

Group

CXTPReportColumn Methods


CXTPReportColumn::IsEditable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsEditable Method

Call this member to determine if an edit box is added for the items in the column.

BOOL IsEditable() const;
Returns

TRUE is the items in the column are editable, FALSE if the items can not be edited.

See Also

SetEditable

Body Source
BOOL CXTPReportColumn::IsEditable() const{
    return m_bEditable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsFiltrable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsFiltrable Method

Returns the current column header filtrability mode.

BOOL IsFiltrable() const;
Returns

TRUE if the column header is filtrable, FALSE otherwise.

See Also

SetFiltrable

Body Source
BOOL CXTPReportColumn::IsFiltrable() const {
    return m_bFiltrable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsGroupable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsGroupable Method

Call this member to determine if the column can be grouped.

BOOL IsGroupable() const;
Returns

TRUE if the column can be grouped, FALSE otherwise.

Remarks

Not all columns allow for grouping. You use IsGroupable to determine if the column can be grouped. I.e. Added to the "Group By" box.

Body Source
BOOL CXTPReportColumn::IsGroupable()const {
    return m_bGroupable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsHotTracking Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::IsHotTracking Method

Determines if group is highlighted

BOOL IsHotTracking() const;
Returns

TRUE if group is highlighted

Group

CXTPReportColumn Methods


CXTPReportColumn::IsResizable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsResizable Method

Returns column allow resizing state.

BOOL IsResizable() const;
Returns

TRUE if the column allows resizing, FALSE otherwise.

See Also

EnableResize

Body Source
BOOL CXTPReportColumn::IsResizable() const{
    return m_bIsResizable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsShowInFieldChooser Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::IsShowInFieldChooser Method

Call this member to determine if the column header will appear in the field chooser when hidden or in the GroupBy Box.

BOOL IsShowInFieldChooser() const;
Returns

TRUE is if the column header will be displayed in the field chooser when the column is hidden or in the GroupBy Box, FALSE if it will not.

See Also

SetShowInFieldChooser

Group

CXTPReportColumn Methods


CXTPReportColumn::IsSortable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::IsSortable Method

Returns the column sortable flag.

BOOL IsSortable() const;
Returns

TRUE if column is sortable, FALSE otherwise.

See Also

IsSorted, IsSortedIncreasing, IsSortedDecreasing

Body Source
BOOL CXTPReportColumn::IsSortable() const{
    return m_bSortable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::IsSorted Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::IsSorted Method

Determines if the column is sorted.

BOOL IsSorted() const;
Returns

TRUE if the column is sorted, FALSE otherwise.

Remarks

If the records list is sorted by given column IsSorted() returns TRUE, otherwise - FALSE

See Also

IsSortable, IsSortedIncreasing, IsSortedDecreasing

Group

CXTPReportColumn Methods


CXTPReportColumn::IsSortedDecreasing Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::IsSortedDecreasing Method

Determines if the column is sorted in the decreasing order.

BOOL IsSortedDecreasing() const;
Returns

TRUE if the column is sorted in decreasing order, FALSE otherwise.

See Also

IsSorted, IsSortable, IsSortedIncreasing

Group

CXTPReportColumn Methods


CXTPReportColumn::IsSortedIncreasing Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::IsSortedIncreasing Method

Determines if the column is sorted in the increasing order.

BOOL IsSortedIncreasing() const;
Returns

TRUE if the column is sorted in increasing order, FALSE otherwise.

See Also

IsSorted, IsSortable, IsSortedDecreasing

Group

CXTPReportColumn Methods


CXTPReportColumn::IsTreeColumn Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::IsTreeColumn Method

Returns TRUE if the current column contains tree.

BOOL IsTreeColumn() const;
Returns

TRUE if the current column contains tree items, FALSE otherwise.

See Also

SetTreeColumn

Group

CXTPReportColumn Methods


CXTPReportColumn::IsVisible Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::IsVisible Method

Returns the current column header visibility mode.

BOOL IsVisible() const;
Returns

TRUE if the column header is visible, FALSE otherwise.

See Also

SetVisible

Group

CXTPReportColumn Methods


CXTPReportColumn::SetAlignment Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetAlignment Method

Sets new Alignment value for column.

int SetAlignment(
    int nAlignment
);
Parameters

nAlignment
New alignment value. Possible alignment values: DT_LEFT, DT_CENTER, DT_RIGHT and DT_WORDBREAK. See also DrawText() Format Flags.

Returns

Previous alignment column value.

Body Source
int CXTPReportColumn::SetAlignment(int nAlignment) {
    int nOld = m_nAlignment; m_nAlignment = nAlignment; return nOld;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetAllowDrag Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetAllowDrag Method

Call this member to specify whether the column can be dragged.

void SetAllowDrag(
    BOOL bAllowDrag
);
Parameters

bAllowDrag
If TRUE, the column can be dragged with the mouse. If FALSE, the dragging for this column is prohibited.

See Also

SetSortable, SetGroupable

Body Source
void CXTPReportColumn::SetAllowDrag(BOOL bAllowDrag) {
    m_bAllowDrag = bAllowDrag;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetAutoSortWhenGrouped Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetAutoSortWhenGrouped Method

Call this member to specify whether the column sortable when grouped by.

void SetAutoSortWhenGrouped(
    BOOL bAutoSortWhenGrouped
);
Parameters

bAutoSortWhenGrouped
Used to enable or disable Auto sorting for grouped column.

Remarks

TRUE by default. If FALSE - records will be grouped without sorting by this column (sort by other columns will be applied).

Body Source
void CXTPReportColumn::SetAutoSortWhenGrouped(BOOL bAutoSortWhenGrouped) {
    m_bAutoSortWhenGrouped = bAutoSortWhenGrouped;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetBestFitMode Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetBestFitMode Method

Call this member to specify the column best fit mode.

void SetBestFitMode(
    int nMode
);
Parameters

nMode
the column best fit mode.

See Also

GetBestFitMode

Body Source
void CXTPReportColumn::SetBestFitMode(int nMode) {
    m_nBestFitMode = nMode;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetCaption Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::SetCaption Method

Call this member to set/change the column header caption.

void SetCaption(
    LPCTSTR strCaption
);
Parameters

strCaption
String caption of the column. Text displayed in the column header.

Group

CXTPReportColumn Methods


CXTPReportColumn::SetDrawFooterDivider Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::SetDrawFooterDivider Method

Call this member to set/change is the right column footer divider visible.

void SetDrawFooterDivider(
    BOOL bSet
);
Parameters

bSet
If TRUE divider is visible, FALSE - invisible.

Remarks

By default divider is visible.

See Also

GetDrawFooterDivider

Group

CXTPReportColumn Methods


CXTPReportColumn::SetDrawFooterRowsVGrid Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetDrawFooterRowsVGrid Method

Call this member to specify whether to show vertical grid for footer rows.

void SetDrawFooterRowsVGrid(
    BOOL bDrawVGrid = TRUE
);
Parameters

bDrawVGrid
TRUE to show vertical grid for footer rows.

See Also

GetDrawFooterRowsVGrid

Body Source
void CXTPReportColumn::SetDrawFooterRowsVGrid(BOOL bDrawVGrid) {
    m_bDrawFooterRowsVGrid = bDrawVGrid;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetDrawHeaderDivider Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::SetDrawHeaderDivider Method

Call this member to set/change is the right column header divider visible.

void SetDrawHeaderDivider(
    BOOL bSet
);
Parameters

bSet
If TRUE divider is visible, FALSE - invisible.

Remarks

By default divider is visible.

See Also

GetDrawHeaderDivider

Group

CXTPReportColumn Methods


CXTPReportColumn::SetDrawHeaderRowsVGrid Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetDrawHeaderRowsVGrid Method

Call this member to specify whether to show vertical grid for header rows.

void SetDrawHeaderRowsVGrid(
    BOOL bDrawVGrid = TRUE
);
Parameters

bDrawVGrid
TRUE to show vertical grid for header rows.

See Also

GetDrawHeaderRowsVGrid

Body Source
void CXTPReportColumn::SetDrawHeaderRowsVGrid(BOOL bDrawVGrid) {
    m_bDrawHeaderRowsVGrid = bDrawVGrid;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetEditable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetEditable Method

Call this member to specify whether the CXTPReportRecordItem(s) in the column can be edited. This will add an edit box to edit the item when the item is click/double-clicked. This can be overridden for individual items if the CXTPReportRecordItem::SetEditable member is called.

void SetEditable(
    BOOL bEditable = TRUE
);
Parameters

bEditable
TRUE is the items in the column are editable (an edit box is added to edit the contents of the item).

See Also

IsEditable

Body Source
void CXTPReportColumn::SetEditable(BOOL bEditable /*= TRUE*/) {
    m_bEditable = bEditable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetFiltrable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetFiltrable Method

Sets column filtrable mode (TRUE - filtrable, FALSE - not filtrable).

BOOL SetFiltrable(
    BOOL bFiltrable = TRUE
);
Parameters

bFiltrable
New column filtrable state.

Returns

Previous column filtrable state.

See Also

IsFiltrable

Body Source
BOOL CXTPReportColumn::SetFiltrable(BOOL bFiltrable) {
    BOOL bOldFiltrable = m_bFiltrable; m_bFiltrable = bFiltrable; return bOldFiltrable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetFooterAlignment Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::SetFooterAlignment Method

Sets new Alignment for column footer.

void SetFooterAlignment(
    int nAlignment
);
Parameters

nAlignment
New alignment value. Possible alignment values: DT_LEFT, DT_CENTER, DT_RIGHT and DT_WORDBREAK. See also DrawText() Format Flags.

Group

CXTPReportColumn Methods


CXTPReportColumn::SetFooterFont Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::SetFooterFont Method

Call this member to set/change the column footer font.

void SetFooterFont(
    CFont* pFont
);
Parameters

pFont
Pointer to font object. May be NULL.

Remarks

The CXTPReportPaintManager::m_fontCaption is used as default footer font. If pFont is NULL the default font will be used.

See Also

GetFooterFont

Group

CXTPReportColumn Methods


CXTPReportColumn::SetFooterText Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::SetFooterText Method

Call this member to set/change the column footer text.

void SetFooterText(
    LPCTSTR strFooter
);
Parameters

strFooter
String footer of the column. Text displayed in the column footer.

Remarks

Call CXTPReportControl::ShowFooter to show footer area.

See Also

GetFooterText, CXTPReportControl::ShowFooter

Group

CXTPReportColumn Methods


CXTPReportColumn::SetGroupable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetGroupable Method

Call this member to specify whether the column can be grouped.

void SetGroupable(
    BOOL bGroupable
);
Parameters

bGroupable
If TRUE, the column can be added to the "Group By" box and the contents of the ReportControl will be grouped by the column. If FALSE, the column can't be added to the "Group By" box.

See Also

SetSortable

Body Source
void CXTPReportColumn::SetGroupable(BOOL bGroupable) {
    m_bGroupable = bGroupable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetHeaderAlignment Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetHeaderAlignment Method

Sets new Alignment for column text.

void SetHeaderAlignment(
    int nAlignment
);
Parameters

nAlignment
New alignment value. Possible alignment values: DT_LEFT, DT_CENTER, DT_RIGHT and DT_WORDBREAK. See also DrawText() Format Flags.

Body Source
void CXTPReportColumn::SetHeaderAlignment(int nAlignment) {
    m_nHeaderAlignment = nAlignment;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetIconID Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetIconID Method

Sets the ID of the associated column header icon.

void SetIconID(
    int nIconId
);
Parameters

nIconId
The ID of the associated column header icon.

Remarks

Column can have an image that will be drawn on it. You use GetIconID() to get the current image id which passes to the column ID of the column. It must match to one of the ids in the imagelist

Body Source
void CXTPReportColumn::SetIconID(int nIconId) {
    m_nIconID = nIconId;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetInternalName Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetInternalName Method

Sets internal column name which used in serialization to unique identify column rather than column index.

void SetInternalName(
    LPCTSTR pcszName
);
Returns

pcszName - Internal column name string.

Body Source
void CXTPReportColumn::SetInternalName(LPCTSTR pcszName) {
    m_strInternalName = pcszName;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetMinWidth Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetMinWidth Method

Sets minimal width value for column.

int SetMinWidth(
    int nMinWidth
);
Parameters

nMinWidth
New column minimal width value.

Returns

Previous column minimal width value.

Remarks

After you set the minimal width for the column, it cannot be resizable to less than minimal width.

See Also

GetMinWidth

Body Source
int CXTPReportColumn::SetMinWidth(int nMinWidth) {
    int OldMinWidth = m_nMinWidth;
    m_nMinWidth = nMinWidth;
    return OldMinWidth;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetShowInFieldChooser Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::SetShowInFieldChooser Method

Call this member to specify whether the column will appear in the FieldChooser when the column is hidden or in the "Group By Box."

void SetShowInFieldChooser(
    BOOL bShow
);
Parameters

bShow
TRUE is the column should be displayed in the field chooser when hidden, FALSE otherwise.

Remarks

When a column is hidden or added to the "Group By Box" it will be automatically added to the FieldChooser unless the ShowInFieldChooser property is set to FALSE. If you would like to have a hidden column that the user can not access and you enable the FieldChooser, then you will need to set the ShowInFieldChooser property to FALSE. By default this property is TRUE.

See Also

IsShowInFieldChooser

Group

CXTPReportColumn Methods


CXTPReportColumn::SetSortable Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetSortable Method

Call this member to specify whether the column can be sorted when the user clicks on the column header.

void SetSortable(
    BOOL bSortable
);
Parameters

bSortable
If TRUE, records can be sorted by this column by clicking on the column header. Each time the column header is clicked the sort order will toggle between ascending and descending. by default, bSortable is TRUE. If FALSE, records can not be sorted by this column by clicking on the column header. The column can still be sorted, but not by clicking on the column header. If you would like to sort the column when bSortable is FALSE, then you can add the column to the ReportControl's SortOrder, this will allow you to keep a column sorted at all times.

See Also

SetGroupable

Body Source
void CXTPReportColumn::SetSortable(BOOL bSortable) {
    m_bSortable = bSortable;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetSortIncreasing Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetSortIncreasing Method

Call this member to specify that the column is sorted in the increasing order.

void SetSortIncreasing(
    BOOL bSortIncreasing
);
Parameters

bSortIncreasing
TRUE if the column should be sorted in increasing order, FALSE otherwise.

See Also

IsSorted, IsSortable, IsSortedIncreasing, IsSortedDecreasing

Body Source
void CXTPReportColumn::SetSortIncreasing(BOOL bSortIncreasing) {
    m_bSortIncreasing = bSortIncreasing;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetTooltip Method

CXTPReportColumn Methods, CXTPReportColumn Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::SetTooltip Method

Call this member to set/change the column tool tip.

void SetTooltip(
    LPCTSTR lpszTooltip
);
Parameters

lpszTooltip
Tool tip of the column

Body Source
void CXTPReportColumn::SetTooltip(LPCTSTR lpszTooltip) {
    m_strTooltip = lpszTooltip;
}
Group

CXTPReportColumn Methods


CXTPReportColumn::SetTreeColumn Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::SetTreeColumn Method

Makes/unmakes the current column as containing a tree inside.

void SetTreeColumn(
    BOOL bIsTreeColumn
);
Parameters

bIsTreeColumn
TRUE if this column contains tree items (collapse/expand buttons) drawn inside, FALSE otherwise.

See Also

IsTreeColumn

Group

CXTPReportColumn Methods


CXTPReportColumn::SetVisible Method

CXTPReportColumn Methods, CXTPReportColumn Class, See Also
CXTPReportColumn::SetVisible Method

Sets column visible mode (TRUE - visible, FALSE - invisible).

void SetVisible(
    BOOL bVisible = TRUE
);
Parameters

bVisible
New column visible state.

Remarks

When you move a column to FieldChooser, it becomes invisible. To change visibility of column you use SetVisible(BOOL)

See Also

IsVisible

Group

CXTPReportColumn Methods


CXTPReportColumn::SetWidth Method

CXTPReportColumn Methods, CXTPReportColumn Class
CXTPReportColumn::SetWidth Method

Sets column width.

int SetWidth(
    int nNewWidth
);
Parameters

nNewWidth
New column width in pixels.

Returns

Previous column width in pixels.

Remarks

This member function gives you possibility to change column width manually. To set initial width or set width for columns which AutoSize = FALSE.

Group

CXTPReportColumn Methods


CXTPReportColumn Constructors

CXTPReportColumn Class, Legend, Public Methods
CXTPReportColumn Constructors
Class

CXTPReportColumn Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportColumn |


CXTPReportColumn Constructor

CXTPReportColumn Constructors
CXTPReportColumn Constructor
Overload List
Constructors
Constructor | Description
CXTPReportColumn::CXTPReportColumn (int, LPCTSTR, LPCTSTR, int, BOOL, int, BOOL, BOOL) | Constructs a CXTPReportColumn object.
CXTPReportColumn::CXTPReportColumn (int, LPCTSTR, int, BOOL, int, BOOL, BOOL) | Constructs a CXTPReportColumn object.
Group

CXTPReportColumn Constructors


CXTPReportColumn::CXTPReportColumn Constructor (int, LPCTSTR, int, BOOL, int, BOOL, BOOL)

CXTPReportColumn Constructor, CXTPReportColumn Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumn::CXTPReportColumn Constructor (int, LPCTSTR, int, BOOL, int, BOOL, BOOL)

Constructs a CXTPReportColumn object.

CXTPReportColumn(
    int nItemIndex,
    LPCTSTR strName,
    int nWidth,
    BOOL bAutoSize = TRUE,
    int nIconID = XTP_REPORT_NOICON,
    BOOL bSortable = TRUE,
    BOOL bVisible = TRUE
);
CXTPReportColumn(
    int nItemIndex,
    LPCTSTR strDisplayName,
    LPCTSTR strInternalName,
    int nWidth,
    BOOL bAutoSize = TRUE,
    int nIconID = XTP_REPORT_NOICON,
    BOOL bSortable = TRUE,
    BOOL bVisible = TRUE
);
Parameters

nItemIndex
An index of the corresponding record item.
strName
Column name.
nWidth
An initial width of the created column.
bAutoSize
Is column resizable flag.
nIconID
Number of the corresponding icon in the image list.
bSortable
Is column sortable flag.
bVisible
Is column visible flag.
strInternalName
Internal column name (to serialize colunm options).
nMinWidth
Minimal width of the column.

Remarks

There are 3 parameters that greatly influence a column's behavior:

  • bAutoSize TRUE allows auto resizing of width of columns when the ReportControl's client area is resized by the user. If bAutoSize is set to FALSE, the column keeps its initial size
  • bSortable Allows the column to be sortable if has value TRUE. If you set it to FALSE, you won't be able to sort records by their column
  • bVisible Determines if columns will draw by control or not. For example if the column is dragged into FieldChooser, the column still exists in the columns list, but it becomes invisible.
Example
#define COLUMN_ICON 1
#define COLUMN_MAIL_ICON 1

CXTPReportControl wndReport;
wndReport.AddColumn(new CXTPReportColumn(COLUMN_ICON, _T("Message Class"), 18, FALSE, COLUMN_MAIL_ICON));
Group

CXTPReportColumn Constructor


CXTPReportColumn Destructors

CXTPReportColumn Class, Legend, Public Methods
CXTPReportColumn Destructors
Class

CXTPReportColumn Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportColumn | Destroys a CXTPReportColumn object, handles cleanup and deallocation


CXTPReportColumn::~CXTPReportColumn Destructor

CXTPReportColumn Destructors, CXTPReportColumn Class
CXTPReportColumn::~CXTPReportColumn Destructor

Destroys a CXTPReportColumn object, handles cleanup and deallocation

virtual ~CXTPReportColumn();
Group

CXTPReportColumn Destructors


CXTPReportColumnOrder Class

XTPReportColumns.h, Classes, Legend, Members, Topics, CXTPReportColumnOrder Data Members, CXTPReportColumnOrder Methods, CXTPReportColumnOrder Constructors, CXTPReportColumnOrder Constructors, CXTPReportColumnOrder Data Members, CXTPReportColumnOrder Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumnOrder Class

Represents column order, used for sorting and grouping.

Class Hierarchy

class CXTPReportColumnOrder;
File

XTPReportColumns.h

Remarks

This class is a collection of sorted columns objects, each of which can be referred to by its zero-based index. It provides main operations to manipulate with list of columns: Adding/removing columns, get at given position, clear collection, get index of object by it pointer You create object simply by calling constructor with one parameter pointer to the columns collection

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportColumnOrder Constructors
CXTPReportColumnOrder Constructors | Description
CXTPReportColumnOrder | Default column order constructor.
CXTPReportColumnOrder Data Members
CXTPReportColumnOrder Data Members | Description
m_arrColumns | Storage for column items with the corresponding order.
m_pColumns | Parent columns array.
CXTPReportColumnOrder Methods
CXTPReportColumnOrder Methods | Description
Add |
Clear | Clears all stored order information.
DoPropExchange | Reads or writes column order settings to/from the provided archive stream.
GetAt | Returns specific column item by its numeric index.
GetCount | Returns the number of stored order items.
IndexOf | Call this method to get index of the column.
InsertAt | Inserts specified column at a specified position.
Remove | Removes specified column from order array.
RemoveAt | Removes specified column at a specified position from the order array.


CXTPReportColumnOrder Data Members

CXTPReportColumnOrder Class, Legend, Protected Data Members
CXTPReportColumnOrder Data Members
Class

CXTPReportColumnOrder Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrColumns | Storage for column items with the corresponding order.
m_pColumns | Parent columns array.


CXTPReportColumnOrder::m_arrColumns Data Member

CXTPReportColumnOrder Data Members, CXTPReportColumnOrder Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumnOrder::m_arrColumns Data Member

Storage for column items with the corresponding order.

CArray<CXTPReportColumn*, CXTPReportColumn*> m_arrColumns;
Group

CXTPReportColumnOrder Data Members


CXTPReportColumnOrder::m_pColumns Data Member

CXTPReportColumnOrder Data Members, CXTPReportColumnOrder Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumnOrder::m_pColumns Data Member

Parent columns array.

CXTPReportColumns* m_pColumns;
Group

CXTPReportColumnOrder Data Members


CXTPReportColumnOrder Methods

CXTPReportColumnOrder Class, Legend, Public Methods
CXTPReportColumnOrder Methods
Class

CXTPReportColumnOrder Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Add |
Clear | Clears all stored order information.
DoPropExchange | Reads or writes column order settings to/from the provided archive stream.
GetAt | Returns specific column item by its numeric index.
GetCount | Returns the number of stored order items.
IndexOf | Call this method to get index of the column.
InsertAt | Inserts specified column at a specified position.
Remove | Removes specified column from order array.
RemoveAt | Removes specified column at a specified position from the order array.


Add Method

CXTPReportColumnOrder Methods
Add Method
Overload List
Methods
Method | Description
CXTPReportColumnOrder::Add (CXTPReportColumn*) | Inserts specified column at the end of the order list.
CXTPReportColumnOrder::Add (CXTPReportColumn*, BOOL) | Inserts specified column at the end of the order list.
Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder::Add Method (CXTPReportColumn*)

Add Method, CXTPReportColumnOrder Class
CXTPReportColumnOrder::Add Method (CXTPReportColumn*)

Inserts specified column at the end of the order list.

int Add(
    CXTPReportColumn* pColumn
);
int Add(
    CXTPReportColumn* pColumn,
    BOOL bSortIncreasing
);
Parameters

pColumn
An added column pointer.
bSortIncreasing
TRUE if this column should be sorted in increasing order, FALSE for decreasing order.

Returns

The index of the added element.

Remarks

Adds a new element to the end of a collection, growing the collection by 1

Group

Add Method


CXTPReportColumnOrder::Clear Method

CXTPReportColumnOrder Methods, CXTPReportColumnOrder Class
CXTPReportColumnOrder::Clear Method

Clears all stored order information.

void Clear();
Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder::DoPropExchange Method

CXTPReportColumnOrder Methods, CXTPReportColumnOrder Class
CXTPReportColumnOrder::DoPropExchange Method

Reads or writes column order settings to/from the provided archive stream.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder::GetAt Method

CXTPReportColumnOrder Methods, CXTPReportColumnOrder Class
CXTPReportColumnOrder::GetAt Method

Returns specific column item by its numeric index.

CXTPReportColumn* GetAt(
    int nIndex
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount().

Returns

The pointer to column array element currently at this index.

Remarks

Returns the columns list element at the specified index. Passing a negative value or a value greater than the value returned by GetCount() will return NULL.

Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder::GetCount Method

CXTPReportColumnOrder Methods, CXTPReportColumnOrder Class
CXTPReportColumnOrder::GetCount Method

Returns the number of stored order items.

int GetCount() const;
Returns

The count of items stored in the order array.

Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder::IndexOf Method

CXTPReportColumnOrder Methods, CXTPReportColumnOrder Class
CXTPReportColumnOrder::IndexOf Method

Call this method to get index of the column.

int IndexOf(
    const CXTPReportColumn* pColumn
);
Parameters

pColumn
The column.

Returns

The index of the column;

Remarks

Searches for the first occurrence of the given Column, beginning the search at index, and first position for equality using pointers If no matching found return -1

Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder::InsertAt Method

CXTPReportColumnOrder Methods, CXTPReportColumnOrder Class
CXTPReportColumnOrder::InsertAt Method

Inserts specified column at a specified position.

int InsertAt(
    int nIndex,
    CXTPReportColumn* pColumn
);
Parameters

nIndex
Order index to insert column to.
pColumn
A pointer to the inserted column.

Returns

The index of the inserted column. -1 in case of an error.

Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder::Remove Method

CXTPReportColumnOrder Methods, CXTPReportColumnOrder Class
CXTPReportColumnOrder::Remove Method

Removes specified column from order array.

void Remove(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
A column to remove from the order array.

Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder::RemoveAt Method

CXTPReportColumnOrder Methods, CXTPReportColumnOrder Class
CXTPReportColumnOrder::RemoveAt Method

Removes specified column at a specified position from the order array.

void RemoveAt(
    int nIndex
);
Parameters

nIndex
Order index of the column to remove.

Group

CXTPReportColumnOrder Methods


CXTPReportColumnOrder Constructors

CXTPReportColumnOrder Class, Legend, Public Methods
CXTPReportColumnOrder Constructors
Class

CXTPReportColumnOrder Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportColumnOrder | Default column order constructor.


CXTPReportColumnOrder::CXTPReportColumnOrder Constructor

CXTPReportColumnOrder Constructors, CXTPReportColumnOrder Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumnOrder::CXTPReportColumnOrder Constructor

Default column order constructor.

CXTPReportColumnOrder(
    CXTPReportColumns* pColumns
);
Parameters

pColumns
Parent columns collection.

Group

CXTPReportColumnOrder Constructors


CXTPReportColumns Class

XTPReportColumns.h, Classes, Legend, Members, Topics, CXTPReportColumns Data Members, CXTPReportColumns Methods, CXTPReportColumns Constructors, CXTPReportColumns Destructors, CXTPReportColumns Constructors, CXTPReportColumns Data Members, CXTPReportColumns Destructors, CXTPReportColumns Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumns Class

This class is a collection of report columns objects, each of which can be referred to by its zero-based index.

Class Hierarchy

class CXTPReportColumns;
File

XTPReportColumns.h

Remarks

It provides main operations to manipulate with list of columns:

  • Adding/removing columns
  • Showing columns header
  • Working with field chooser
  • Working with "group by" field
  • (Re)Storing column settings

To create an object of that class simply call it constructor with one parameter - pointer to the Report Control object

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportColumns Constructors
CXTPReportColumns Constructors | Description
CXTPReportColumns | Constructs a CXTPReportColumns object
CXTPReportColumns Data Members
CXTPReportColumns Data Members | Description
m_arrColumns | Storage for column items.
m_pControl | Pointer to the associated report control object.
m_pGroupsOrder | Container for the columns order in auto grouping mode.
m_pSortOrder | Container for the columns sort order.
m_pTreeColumn | Column containing tree view images.
CXTPReportColumns Destructors
CXTPReportColumns Destructors | Description
~CXTPReportColumns | Destroys a CXTPReportColumns object,
CXTPReportColumns Methods
CXTPReportColumns Methods | Description
Add | Adds one more column item to the collection.
ChangeColumnOrder | Changes column order in the collection.
Clear | Clears columns collection items.
DoPropExchange | Reads or writes configuration to/from the provided archive stream.
Find |
GetAt | Returns specific column item by its numeric index.
GetCount | Returns the total number of column items in the collection.
GetFirstVisibleColumn | Returns first visible column
GetGroupsOrder | Provides a user with a columns groups order array.
GetIndentColumn | Gets specific indentation column.
GetLastVisibleColumn | Returns last visible column
GetReportHeader | Returns pointer to the associated report header object.
GetSortOrder | Provides a user with a columns sort order array.
GetVisibleAt | Returns a column at specified visible position.
GetVisibleColumns | Finds all visible columns and places them in the referenced CXTPReportColumns array.
GetVisibleColumnsCount | Returns the number of visible columns in the collection.
IndexOf | Call this method to get index of the column.
InsertSortColumn | Inserts provided column to the sort columns array according to the columns order in the group columns array.
Remove | Removes column from the collection.
ResetSortOrder | Clear sort order for each column.
SetSortColumn | Sets a sort order for the column.


CXTPReportColumns Data Members

CXTPReportColumns Class, Legend, Protected Data Members
CXTPReportColumns Data Members
Class

CXTPReportColumns Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrColumns | Storage for column items.
m_pControl | Pointer to the associated report control object.
m_pGroupsOrder | Container for the columns order in auto grouping mode.
m_pSortOrder | Container for the columns sort order.
m_pTreeColumn | Column containing tree view images.


CXTPReportColumns::m_arrColumns Data Member

CXTPReportColumns Data Members, CXTPReportColumns Class
CXTPReportColumns::m_arrColumns Data Member

Storage for column items.

CArray<CXTPReportColumn*, CXTPReportColumn*> m_arrColumns;
Group

CXTPReportColumns Data Members


CXTPReportColumns::m_pControl Data Member

CXTPReportColumns Data Members, CXTPReportColumns Class
CXTPReportColumns::m_pControl Data Member

Pointer to the associated report control object.

CXTPReportControl* m_pControl;
Group

CXTPReportColumns Data Members


CXTPReportColumns::m_pGroupsOrder Data Member

CXTPReportColumns Data Members, CXTPReportColumns Class
CXTPReportColumns::m_pGroupsOrder Data Member

Container for the columns order in auto grouping mode.

CXTPReportColumnOrder* m_pGroupsOrder;
Group

CXTPReportColumns Data Members


CXTPReportColumns::m_pSortOrder Data Member

CXTPReportColumns Data Members, CXTPReportColumns Class
CXTPReportColumns::m_pSortOrder Data Member

Container for the columns sort order.

CXTPReportColumnOrder* m_pSortOrder;
Group

CXTPReportColumns Data Members


CXTPReportColumns::m_pTreeColumn Data Member

CXTPReportColumns Data Members, CXTPReportColumns Class
CXTPReportColumns::m_pTreeColumn Data Member

Column containing tree view images.

CXTPReportColumn* m_pTreeColumn;
Group

CXTPReportColumns Data Members


CXTPReportColumns Methods

CXTPReportColumns Class, Legend, Public Methods
CXTPReportColumns Methods
Class

CXTPReportColumns Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Add | Adds one more column item to the collection.
ChangeColumnOrder | Changes column order in the collection.
Clear | Clears columns collection items.
DoPropExchange | Reads or writes configuration to/from the provided archive stream.
Find |
GetAt | Returns specific column item by its numeric index.
GetCount | Returns the total number of column items in the collection.
GetFirstVisibleColumn | Returns first visible column
GetGroupsOrder | Provides a user with a columns groups order array.
GetIndentColumn | Gets specific indentation column.
GetLastVisibleColumn | Returns last visible column
GetReportHeader | Returns pointer to the associated report header object.
GetSortOrder | Provides a user with a columns sort order array.
GetVisibleAt | Returns a column at specified visible position.
GetVisibleColumns | Finds all visible columns and places them in the referenced CXTPReportColumns array.
GetVisibleColumnsCount | Returns the number of visible columns in the collection.
IndexOf | Call this method to get index of the column.
InsertSortColumn | Inserts provided column to the sort columns array according to the columns order in the group columns array.
Remove | Removes column from the collection.
ResetSortOrder | Clear sort order for each column.
SetSortColumn | Sets a sort order for the column.


CXTPReportColumns::Add Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::Add Method

Adds one more column item to the collection.

void Add(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
A column to add to the collection.

Remarks

Adds a new element to the end of a collection, growing the collection by 1

Group

CXTPReportColumns Methods


CXTPReportColumns::ChangeColumnOrder Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::ChangeColumnOrder Method

Changes column order in the collection.

int ChangeColumnOrder(
    int nNewOrder,
    int nOldIndex
);
Parameters

nNewOrder
A new column order index.
nOldIndex
Index of the changing column.

Returns

New column order index.

Remarks

Moves column with index nItemIndex to the new position with nNewOrder. If any parameter's value is negative, no changes will be done and returns -1

Group

CXTPReportColumns Methods


CXTPReportColumns::Clear Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::Clear Method

Clears columns collection items.

void Clear();
Group

CXTPReportColumns Methods


CXTPReportColumns::DoPropExchange Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::DoPropExchange Method

Reads or writes configuration to/from the provided archive stream.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPReportColumns Methods


Find Method

CXTPReportColumns Methods
Find Method
Overload List
Methods
Method | Description
CXTPReportColumns::Find (const CString&) | Finds the column by its item index.
CXTPReportColumns::Find (int) | Finds the column by its item index.
Group

CXTPReportColumns Methods


CXTPReportColumns::Find Method (int)

Find Method, CXTPReportColumns Class
CXTPReportColumns::Find Method (int)

Finds the column by its item index.

CXTPReportColumn* Find(
    int nItemIndex
) const;
CXTPReportColumn* Find(
    const CString& strInternalName
) const;
Parameters

nItemIndex
Column item index.
strInternalName
Column internal name.

Returns

Found column.

Remarks

Searches the list sequentially to find the first element matching the specified item index column's value. If no matching found NULL is returned

Group

Find Method


CXTPReportColumns::GetAt Method

CXTPReportColumns Methods, CXTPReportColumns Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumns::GetAt Method

Returns specific column item by its numeric index.

CXTPReportColumn* GetAt(
    int nIndex
) const;
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount().

Returns

The pointer to column array element currently at this index.

Remarks

Returns the columns list element at the specified index. Passing a negative value or a value greater than the value returned by GetCount() will return NULL.

Body Source
CXTPReportColumn* CXTPReportColumns::GetAt(int nIndex) const{
    return (nIndex >= 0 && nIndex < GetCount()) ? m_arrColumns.GetAt(nIndex) : NULL;
}
Group

CXTPReportColumns Methods


CXTPReportColumns::GetCount Method

CXTPReportColumns Methods, CXTPReportColumns Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumns::GetCount Method

Returns the total number of column items in the collection.

int GetCount() const;
Returns

Total count of column items in the collection.

Body Source
int CXTPReportColumns::GetCount() const {
    return (int)m_arrColumns.GetSize();
}
Group

CXTPReportColumns Methods


CXTPReportColumns::GetFirstVisibleColumn Method

CXTPReportColumns Methods, CXTPReportColumns Class, See Also
CXTPReportColumns::GetFirstVisibleColumn Method

Returns first visible column

CXTPReportColumn* GetFirstVisibleColumn() const;
Returns

Pointer to first visible column

See Also

GetLastVisibleColumn

Group

CXTPReportColumns Methods


CXTPReportColumns::GetGroupsOrder Method

CXTPReportColumns Methods, CXTPReportColumns Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumns::GetGroupsOrder Method

Provides a user with a columns groups order array.

CXTPReportColumnOrder* GetGroupsOrder() const;
Returns

A pointer to the columns groups order array.

Body Source
CXTPReportColumnOrder* CXTPReportColumns::GetGroupsOrder() const {
    return m_pGroupsOrder;
}
Group

CXTPReportColumns Methods


CXTPReportColumns::GetIndentColumn Method

CXTPReportColumns Methods, CXTPReportColumns Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumns::GetIndentColumn Method

Gets specific indentation column.

CXTPReportColumn* GetIndentColumn() const;
Returns

An indentation column.

Remarks

Indentation column used for representing it ends in grouping mode. Indentation column usually it is the first column in list.

Body Source
CXTPReportColumn* CXTPReportColumns::GetIndentColumn() const{
    return (GetCount() > 0) ? m_arrColumns.GetAt(0) : NULL;
}
Group

CXTPReportColumns Methods


CXTPReportColumns::GetLastVisibleColumn Method

CXTPReportColumns Methods, CXTPReportColumns Class, See Also
CXTPReportColumns::GetLastVisibleColumn Method

Returns last visible column

CXTPReportColumn* GetLastVisibleColumn() const;
Returns

Pointer to last visible column

See Also

GetFirstVisibleColumn

Group

CXTPReportColumns Methods


CXTPReportColumns::GetReportHeader Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::GetReportHeader Method

Returns pointer to the associated report header object.

CXTPReportHeader* GetReportHeader() const;
Returns

A pointer to the associated report header.

Group

CXTPReportColumns Methods


CXTPReportColumns::GetSortOrder Method

CXTPReportColumns Methods, CXTPReportColumns Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportColumns::GetSortOrder Method

Provides a user with a columns sort order array.

CXTPReportColumnOrder* GetSortOrder() const;
Returns

A pointer to the columns sort order array.

Body Source
CXTPReportColumnOrder* CXTPReportColumns::GetSortOrder() const{
    return m_pSortOrder;
}
Group

CXTPReportColumns Methods


CXTPReportColumns::GetVisibleAt Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::GetVisibleAt Method

Returns a column at specified visible position.

CXTPReportColumn* GetVisibleAt(
    int nIndex
) const;
Parameters

nIndex
Index of column that is visible on position number nIndex.

Returns

Pointer to column object.

Remarks

Returns first visible column before column with given index or column with given index. Passing a negative value or a value greater than the value returned by GetCount() or if visible element not found will return NULL.

Group

CXTPReportColumns Methods


CXTPReportColumns::GetVisibleColumns Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::GetVisibleColumns Method

Finds all visible columns and places them in the referenced CXTPReportColumns array.

void GetVisibleColumns(
    CXTPReportColumns& arrColumns
) const;
Parameters

arrColumns
A reference to a CXTPReportColumns object

Remarks

The referenced CXTPReportColumns array object will get filled will all the visible CXTPReportColumn objects.

Group

CXTPReportColumns Methods


CXTPReportColumns::GetVisibleColumnsCount Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::GetVisibleColumnsCount Method

Returns the number of visible columns in the collection.

int GetVisibleColumnsCount() const;
Returns

The number of visible columns in the collection.

Remarks

In opposite to GetCount() member function this one return count only those columns that have visibility property set to true

Group

CXTPReportColumns Methods


CXTPReportColumns::IndexOf Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::IndexOf Method

Call this method to get index of the column.

int IndexOf(
    const CXTPReportColumn* pColumn
) const;
Parameters

pColumn
The column.

Returns

The index of the column;

Remarks

Searches for the first occurrence of the given Column, beginning the search at index, and first position for equality using pointers equality. If no matching found return -1

Group

CXTPReportColumns Methods


CXTPReportColumns::InsertSortColumn Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::InsertSortColumn Method

Inserts provided column to the sort columns array according to the columns order in the group columns array.

void InsertSortColumn(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
A column to insert.

Returns

The index of the column inserted into the sort columns array.

Group

CXTPReportColumns Methods


CXTPReportColumns::Remove Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::Remove Method

Removes column from the collection.

void Remove(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
column to be removed.

Group

CXTPReportColumns Methods


CXTPReportColumns::ResetSortOrder Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::ResetSortOrder Method

Clear sort order for each column.

void ResetSortOrder();
Group

CXTPReportColumns Methods


CXTPReportColumns::SetSortColumn Method

CXTPReportColumns Methods, CXTPReportColumns Class
CXTPReportColumns::SetSortColumn Method

Sets a sort order for the column.

void SetSortColumn(
    CXTPReportColumn* pColumn,
    BOOL bIncreasing
);
Parameters

pColumn
Pointer to the specified column object.
bIncreasing
TRUE to sort increasing.

Remarks

Sets given column as the sorted column, reset previous sort order

Group

CXTPReportColumns Methods


CXTPReportColumns Constructors

CXTPReportColumns Class, Legend, Public Methods
CXTPReportColumns Constructors
Class

CXTPReportColumns Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportColumns | Constructs a CXTPReportColumns object


CXTPReportColumns::CXTPReportColumns Constructor

CXTPReportColumns Constructors, CXTPReportColumns Class
CXTPReportColumns::CXTPReportColumns Constructor

Constructs a CXTPReportColumns object

CXTPReportColumns(
    CXTPReportControl* pControl
);
Parameters

pControl
Pointer to the parent Report Control object.

Group

CXTPReportColumns Constructors


CXTPReportColumns Destructors

CXTPReportColumns Class, Legend, Public Methods
CXTPReportColumns Destructors
Class

CXTPReportColumns Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportColumns | Destroys a CXTPReportColumns object,


CXTPReportColumns::~CXTPReportColumns Destructor

CXTPReportColumns Destructors, CXTPReportColumns Class
CXTPReportColumns::~CXTPReportColumns Destructor

Destroys a CXTPReportColumns object,

virtual ~CXTPReportColumns();
Remarks

handles cleanup and deallocation, including all of objects presented in list by calling Clear() member function

Group

CXTPReportColumns Destructors


CXTPReportControl Class

XTPReportControl.h, Classes, Legend, Members, Topics, CXTPReportControl Classes, CXTPReportControl Data Members, CXTPReportControl Methods, CXTPReportControl Constructors, CXTPReportControl Destructors, CXTPReportControl Classes, CXTPReportControl Constructors, CXTPReportControl Data Members, CXTPReportControl Destructors, CXTPReportControl Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl Class

The CXTPReportControl class provides an implementation of the Report control.

Class Hierarchy

class CXTPReportControl : public CWnd;
File

XTPReportControl.h

Remarks

A "report control" is a window that displays a hierarchical list of items, such as emails in the inbox. Each item is called a CXTPReportRow and consists of its properties and corresponding CXTPReportRecord, which contains all the corresponding data (mostly text). Each Row item (as well as Record) can have a list of sub-items associated with it. By clicking a Row item, the user can expand and collapse the associated list of sub-items.

The CXTPReportRecords collection holds all the CXTPReportRecord objects that are assigned to the Report control. It could be accessible via GetRecords() method. The records in this collection are referred to as the root records. Any record that is subsequently added to a root record is referred to as a child record. Because each CXTPReportRecord can contain a collection of other CXTPReportRecord objects, you might find it difficult to determine your location in the tree structure when you iterate through the collection.

Record nodes can be expanded to display the next level of child records. The user can expand the CXTPReportRecord by clicking the plus-sign (+) button, if one is displayed, or you can expand the CXTPReportRecord by calling the CXTPReportRecord::SetExpanded method. To expand all the child records, call the ExpandAll method. You can collapse the child CXTPReportRecord level by calling the CXTPReportRecord::SetExpanded(FALSE) method, or the user can press the minus-sign (-) button, if one is displayed. You can also call CollapseAll method to collapse all child records.

Each record contains an array of record items which are implemented with CXTPReportRecordItem and its descendants. You can create your own types of items simply by inheritance from the base record item class.

Each record item has an association with corresponding CXTPReportColumn item. The item will be shown below the corresponding column header depending on its position in report control columns array. If a column has not an associated item in the record, there will be an empty item shown in the corresponding cell.

Columns array is represented by CXTPReportColumns collection and could be accessed via GetColumns() method.

As a finalization of adding data to the report control, which means adding columns and records, Populate() method should be called. It performs population of control rows with data - creates a rows tree if necessary, rebuilds groups if grouping if enabled, and sorts rows on a specified manner. See Also an example below.

Handling notification messages sent by the control to the parent window is allowed with ON_NOTIFY handler. The control is using SendMessageToParent function to send notifications. See below for the example of how messages could be handled in a parent window:

ON_NOTIFY(NM_CLICK, ID_REPORT_CONTROL, OnReportItemClick)
ON_NOTIFY(NM_RCLICK, ID_REPORT_CONTROL, OnReportItemRClick)
ON_NOTIFY(NM_DBLCLK, ID_REPORT_CONTROL, OnReportItemDblClick)
ON_NOTIFY(XTP_NM_SHOWFIELDCHOOSER, ID_REPORT_CONTROL, OnShowFieldChooser)
ON_NOTIFY(XTP_NM_HEADER_RCLICK, ID_REPORT_CONTROL, OnReportColumnRClick)
ON_NOTIFY(NM_KEYDOWN, ID_REPORT_CONTROL, OnReportKeyDown)

You can also change the appearance of the CXTPReportControl control by setting some of its display and style properties.

Also Report control has an ability to store and restore its settings, which includes all columns with their settings, and some required control's settings. It is implemented via standard MFC and XTP serialization and available with the member functions SerializeState(CArchive& ar), DoPropExchange(CXTPPropExchange* pPX);

Report control supports Copy/Paste clipboard operations. See methods: CanCut(), CanCopy(), CanPaste(), Cut(), Copy(), Paste(). There are 2 clipboard formats are supported: Binary - contains all record(s) data; Text - contains visible columns texts.

To support binary format the XTP serialization is used - DoPropExchange() methods are implemented for CXTPReportRecord, CXTPReportRecordItem and derived CXTPReportRecordItemXXX classes. Also some part of standard MFC serialization is used (see DECLARE_SERIAL macro) to automatically create classes when loading from the data source.

If you are creating custom records and records items classes you have to use DECLARE_SERIAL macro and may need to override DoPropExchange() methods to serialize custom data as well as standard records data.

The storing records way is simple: CXTPReportRecord (or derived class) is stored first, then record items (CXTPReportRecordItemXXX classes) are stored one by one. The class information, which allow to create object instances when loading, is stored for all classes. See CArchive::WriteClass(), CArchive::ReadClass() and other CArchive members for more details about this idea.

When report control loads records from the data source: The record class is created automatically (using stored class information). Then items collection cleared and record items are created automatically and added to items collection. For example see ReportSample project: CMessageRecord class.

We support text format with 't' dividers for record items and "rn" dividers for records (simple tab-separated text). Such format is also supported by Excel and some other applications.

There are few methods and corresponding notifications which allow to customize copy/paste operations: OnBeforeCopyToText(); OnBeforePasteFromText(); OnBeforePaste();

See Also

CXTPReportView, CXTPReportHeader, CXTPReportRow, CXTPReportRecord, CXTPReportColumn, CXTPReportRecords, CXTPReportRows, CXTPReportColumns, CXTPReportSubListControl, CXTPReportFilterEditControl

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportControl Classes
CXTPReportControl Classes | Description
CUpdateContext | Internal report update helper.
CXTPReportControl Constructors
CXTPReportControl Constructors | Description
CXTPReportControl | Constructs a CXTPReportControl object.
CXTPReportControl Data Members
CXTPReportControl Data Members | Description
m_arrScreenRows | Rows currently presented on screen.
m_bAllowEdit | TRUE if sub-items can be edited.
m_bAutoCheckItems | TRUE to enable auto check mode, FALSE to disable auto check mode.
m_bChanged | Internal member for storing changed flag.
m_bDragMode | TRUE if records currently dragging
m_bEditOnClick | TRUE if sub-items become editable on a single-click
m_bFilterHiddenColumns | Search filter text in hidden columns too.
m_bFocusSubItems | TRUE if sub-items can receive focus.
m_bFooterAllowEdit | TRUE if sub-items of footer rows can be edited.
m_bFooterRecordsVisible | TRUE if footer records are visible.
m_bFooterRowsAllowAccess | TRUE if a footer row can be selected by user.
m_bFooterRowsSelectionEnable | TRUE if footer row selection enabled.
m_bFooterVisible | TRUE if column footer are visible.
m_bFullColumnScrolling | Store Full Column Scrolling mode for horizontal scrolling.
m_bGroupByEnabled | TRUE if Group By box is enabled
m_bHeaderAllowEdit | TRUE if sub-items of header rows can be edited.
m_bHeaderRecordsVisible | TRUE if header records are visible.
m_bHeaderRowsAllowAccess | TRUE if a header row can be selected by user.
m_bHeaderRowsSelectionEnable | TRUE if header row selection enabled.
m_bHeaderVisible | TRUE if column headers are visible.
m_bHScrollBarVisible | TRUE if horizontal scroll bar is visible
m_bmpCache | Cached window bitmap.
m_bMultipleSelection | TRUE if multiple selection enabled.
m_bMultiSelectionMode | TRUE if multiselection mode enabled (i.e.
m_bmWatermark | Watermark bitmap info.
m_bOnSizeRunning | TRUE if OnSize handler is entered, FALSE otherwise.
m_bPinFooterRecords | TRUE if footer records are drawn immediately after the body rows.
m_bPrepareDrag | TRUE if user click the report control and doesn't release button.
m_bRefreshIndexes | TRUE when it is required to refresh items indexes.
m_bRowFocusVisible | TRUE if showing focused row rectangle enabled.
m_bSelectionEnable | TRUE if selection enabled.
m_bShowTooltips | TRUE if showing tool tips enabled.
m_bSkipGroupsFocus | TRUE if group rows are skipped when navigating rows with the Up and Down arrow keys
m_bSortRecordChilds | TRUE to apply sort order for Record children.
m_bVScrollBarVisible | TRUE if vertical scroll bar is visible
m_cfReport | Report Clipboard format for drag/drop operations
m_dwDragDropFlags | Drag/drop flags.
m_hbmpWatermark | Watermark bitmap handle.
m_mouseMode | Current mouse operation mode
m_nDisableReorderColumnsCount | Count of columns at the left side where reordering is disabled.
m_nDropPos | Position of records to be dropped
m_nEnsureVisibleColumnIdx | Ensure visible column index.
m_nEnsureVisibleRowIdx | Ensure visible row index.
m_nFocusedFooterRow | Pointer to the currently focused footer row.
m_nFocusedHeaderRow | Pointer to the currently focused header row.
m_nFocusedRow | Pointer to the currently focused row.
m_nFreezeColumnsCount | Count of none-scrolled columns at the left side.
m_nHScrollStep | Horizontal scroll step (in pixels).
m_nLeftOffset | Horizontal scroll position.
m_nLockUpdateCount | A counter of the update locks.
m_nPopulatedRecordsCount | Current number of records in the report after using m_strFilterText.
m_nRowsPerWheel | Amount of rows to scroll by mouse wheel.
m_nTopRow | Current top row in the visible area.
m_pActiveItem | Pointer to the currently focused CXTPReportRecordItem.
m_pColumns | List columns container.
m_pDropRecords | Drop records.
m_pDropTarget | Internal drag/drop helper.
m_pFocusedColumn | Pointer to the currently focused CXTPReportColumn.
m_pFooterRecords | Footer records container.
m_pFooterRows | Virtual list of footer rows container.
m_pHeaderRecords | Header records container.
m_pHeaderRows | Virtual list of header rows container.
m_pHotRow | Hot row
m_pImageManager | Contains image list for report control
m_pInplaceButtons | In-place buttons pointer
m_pInplaceEdit | In-place edit pointer
m_pInplaceList | In-place list pointer
m_pNavigator | Navigator
m_pointDrag | Drag position
m_pPaintManager | Paint manager.
m_pPlainTree | Tree rows container.
m_pRecords | List records container.
m_pReportHeader | List header member.
m_pRows | Virtual list rows container.
m_pRowsCompareFunc | Pointer to rows compare function.
m_pSelectedRows | Container for the currently selected rows.
m_pSelectOnUpRow | Row to select on mouse up.
m_pToolTipContext | Tool tip Context.
m_ptrVirtualEditingRow | Currently editing row in virtual mode.
m_rcFooterArea | The area occupied by the footer.
m_rcFooterRecordsArea | The area occupied by the footer records.
m_rcFooterRecordsDividerArea | The area occupied by the footer records divider.
m_rcGroupByArea | The area occupied by Group By item.
m_rcHeaderArea | The area occupied by the header.
m_rcHeaderRecordsArea | The area occupied by the header records.
m_rcHeaderRecordsDividerArea | The area occupied by the header records divider.
m_rcReportArea | The area occupied by rows.
m_strFilterText | Filter text.
m_uAutoScrollTimerID | Auto scroll timer ID or 0.
m_WatermarkAlignment | Watermark alignment flags.
m_WatermarkTransparency | Watermark bitmap transparency value.
m_wndTip | Tip window.
CXTPReportControl Destructors
CXTPReportControl Destructors | Description
~CXTPReportControl | Destroys a CXTPReportControl object, handles cleanup and deallocation.
CXTPReportControl Methods
CXTPReportControl Methods | Description
_DoCollapse | Collapses all children of the specified row.
_DoExpand |
AddColumn | Adds new column to the end of the columns array.
AddRecord | Adds record to records collection.
AddRecordEx | Adds record to records collection and associates a row with it.
AdjustIndentation | Adjust control indentation properties depending on current tree depth.
AdjustLayout | Adjusts main control areas depending on current control size.
AdjustScrollBars | Adjusts scroll bars depending on currently visible rows.
AllowEdit | Call this member to allow the text in all CXTPReportRecordItem(s) to be edited. This will add an edit box to the item where the text can be edited.
ApplyFilter | Checks a record for filter text.
BeginUpdate | Prevents the control from redrawing until the EndUpdate method is called.
BuildTree | Builds rows tree based on provided data record.
CanCopy | Returns TRUE if one or more records are selected indicating the Copy command can be used.
CanCut | Returns TRUE if one or more records are selected indicating the Cut command can be used.
CanPaste | Returns TRUE if BinaryRecords or Text data exists in the clipboard.
CollapseAll | Collapses all rows.
Copy | Copy selected records data (in the Binary and Text data formats) to the clipboard.
Create | This method is called to create a report control.
CreateGroupRow | This method is called to create new CXTPReportGroupRow object. Overwrite it to use derived CXTPReportGroupRow class.
CreateHeaderFooterRow | This method is called to create new CXTPReportRow object for header/footer rows. Overwrite it to use derived CXTPReportRow class.
CreateRow | This method is called to create new CXTPReportRow object. Overwrite it to use derived CXTPReportRow class.
Cut | Copy selected records data (in the Binary and Text data formats) to the clipboard and delete records.
DoAutoVertScrollIfNeed | This method is used to monitoring mouse position. If mouse will be moved to 20 pixels before top or before bottom report borders the control will be scrolled vertically.
DoPropExchange | Reads or writes configuration to/from the provided data source.
DrawFixedRecordsDivider | Draws fixed rows divider on the provided DC.
DrawFixedRows | Draws fixed rows on the provided DC.
DrawNoItems | Draws 'NoItems' text on the provided DC.
DrawRows | Draws all rows on the provided DC.
EditItem | This method is called to start editing a report cell. It makes a specified cell focused and starts in-place editing control which was specified there.
EditOnClick | Call this member to specify whether a CXTPReportRecordItem can be edited by single-clicking on the item.
EnableDragDrop | Call this method to enable built in drag and drop operations
EnableMarkup | Call this method to enable markup for tab captions
EnablePreviewMode | Enable/disable preview mode for the control.
EnableToolTips | Enables/disables showing tooltips for the control.
EndUpdate | Resumes drawing of the report control after drawing is suspended by the BeginUpdate method.
EnsureStartAutoVertScroll | This method is used to enable monitoring mouse position for automatic vertical scrolling.
EnsureStopAutoVertScroll | This method is used to stop monitoring mouse position for automatic vertical scrolling.
EnsureVisible |
ExpandAll | Expands all rows.
FocusSubItems | Call this member to specify whether each individual CXTPReportRecordItem will show focus when the item in a row is clicked.
FooterRowsAllowAccess | Call this member to allow user moving the selection to footer rows.
FooterRowsAllowEdit | Call this member to allow the text in all CXTPReportRecordItem(s) to be edited (for footer records only). This will add an edit box to the item where the text can be edited.
FooterRowsEnableSelection | Call this member to enable selection in footer rows.
FreeRowBatchExtraData | This member function when rows batch allocation enabled to check all allocated blocks and deallocate which are completely free.
GetActiveItem | Call this member to retrieve the currently active item, which is the item that has focus.
GetColumns | Interface for accessing list columns.
GetDisableReorderColumnsCount | Call this method to retrieve count of the columns at the left side where reordering is disabled.
GetElementRect | Call this method to retrieve report element rectangle.
GetFilterText | Returns the text from the associated filter edit control.
GetFocusedColumn | Call this member to retrieve a pointer to the currently selected column.
GetFocusedRow | Retrieves the index of the row that currently has focus in the report control's view.
GetFooterRecords | Returns the collection of the footer records.
GetFooterRows | Returns the collection of the report footer rows
GetFooterRowsDividerHeight | Returns footer divider height.
GetFooterRowsRect | Call this method to retrieve footer rows bounding rectangle.
GetFreezeColumnsCount | Call this method to retrieve count of none-scrolled columns at the left side.
GetGridStyle | Returns current grid drawing mode.
GetHeaderIndent | Call this method to retrieve indentation of the header
GetHeaderRecords | Returns the collection of the header records.
GetHeaderRows | Returns the collection of the report header rows
GetHeaderRowsDividerHeight | Returns header divider height.
GetHeaderRowsRect | Call this method to retrieve Header records bounding rectangle.
GetHScrollStep | Use this function to get horizontal scrolling step.
GetImageManager | Call this method to get a pointer to the image manager of Report Control.
GetIndent | Returns indentation for the tree view row of the specified depth level.
GetInplaceButtons | Retrieves in-place buttons of report control
GetInplaceEdit | Retrieves in-place edit pointer
GetInplaceList | Retrieves in-place list of report controls
GetItemMetrics | Returns drawing metrics for the row.
GetLockUpdateCount | Returns TRUE if control in Update state.
GetMarkupContext | Returns markup context
GetMouseMode | Returns the current control mouse mode.
GetNavigator | Returns the control's Navigator.
GetPaintManager | Returns the currently used control's Paint Manager.
GetRecords | Returns the collection of the data records.
GetReportAreaRows | Returns rows from the visible report area.
GetReportHeader | Returns a pointer to the associated report header object.
GetReportRectangle | Call this method to retrieve Report bounding rectangle.
GetRows | Returns the collection of the report rows
GetRowsHeight | Returns calculated rows height.
GetSelectedRows | Returns the collection of the selected rows.
GetToolTipContext | Call this method to get tooltip context pointer.
GetTopRowIndex | Call this method to retrieve top row index.
GetWatermarkAlignment | Call this member to determine current watermark alignment flags.
HasFocus | Call this member to determine if the ReportControl has focus.
HeaderRowsAllowAccess | Call this member to allow user moving the selection to header rows.
HeaderRowsAllowEdit | Call this member to allow the text in all CXTPReportRecordItem(s) to be edited (for header records only). This will add an edit box to the item where the text can be edited.
HeaderRowsEnableSelection | Call this member to enable selection in header rows.
HitTest | Determines which report row item, if any, is at a specified position.
InsertRow | Inserts the specified row at the specified position.
IsAllowEdit | Call this member to determine if the CXTPReportRecordItem(s)are editable.
IsAutoCheckItems | Call this member to determine id auto check mode for check box items is enabled.
IsChanged | Returns changed status flag of the control. Used for caching control image drawing.
IsEditMode | Returns TRUE if inplace edit control is active (visible and focused), FALSE otherwise.
IsEditOnClick | Call this member to determine whether items are edited with a single-click.
IsFilterHiddenColumns | Determine if control search filter text in hidden columns too. This option is disabled by default. Returns; TRUE if control search filter text in hidden columns; FALSE otherwise.
IsFocusSubItems | Call this member to determine if individual CXTPReportRecordItem(s) will receive focus when that item in the CXTPReportRow that they belong to is clicked.
IsFooterRowsAllowAccess | Call this member to determine if user can move selection to footer rows.
IsFooterRowsAllowEdit | Call this member to determine if the CXTPReportRecordItem(s) are editable (for footer records only).
IsFooterRowsPinned | Call this member to determine if footer records are pinned to the body rows.
IsFooterRowsSelectionEnabled | Call this member to determine if selection in footer rows is enabled.
IsFooterRowsVisible | Call this member to determine if footer records are currently visible.
IsFooterVisible | Call this member to determine is column footers are currently visible.
IsFullColumnScrolling | Get horizontal scrolling mode.
IsGroupByVisible | Returns current Group By area mode.
IsGroupRowsBold | Returns current group rows text bold style.
IsHeaderRowsAllowAccess | Call this member to determine if user can move selection to header rows.
IsHeaderRowsAllowEdit | Call this member to determine if the CXTPReportRecordItem(s) are editable (for header records only).
IsHeaderRowsSelectionEnabled | Call this member to determine if selection in header rows is enabled.
IsHeaderRowsVisible | Call this member to determine if header records are currently visible.
IsHeaderVisible | Call this member to determine is column headers are currently visible.
IsLayoutRTL | Call this member to get right-to-left mode.
IsMultipleSelection | Determines if the report allows multiple selections.
IsMultiSelectionMode | Determines if the multiple selection mode is enabled.
IsPreviewMode | Returns current preview mode.
IsRowFocusVisible | Call this member to determine if the row focus is visible.
IsSelectionEnabled | Call this member to determine if rows selection is enabled.
IsShadeGroupHeadingsEnabled | Returns current group shade mode.
IsSkipGroupsFocusEnabled | Call this member to determine is groups are skipped when navigating the with the Up and Down arrow keys.
IsSortRecordChilds | Use this function to determine is sort order applied for record children.
IsVirtualMode | Determines if control in virtual mode Returns; TRUE if virtual mode is enabled; FALSE otherwise.
OnBeforeCopyToText | This method is called before add record text data to the clipboard.
OnBeforePaste | This method is called after creating new record using binary data from the clipboard, but before add it to records collection.
OnBeforePasteFromText | This method is called before creating new record using text data from the clipboard.
OnBeginDrag | This method is called when user start drag row
OnConstraintSelecting | This method is used to notify about changing constraint selection.
OnDragOver | This member is called when an item is dragged over the report control.
OnDraw | Performs all drawing logic.
OnDrop | This member is called when an item has been dropped into the report control.
OnFocusChanging | This member function is called before the focus change
OnGetColumnDataBestFitWidth | This method is used by the report control to calculate BestFit column width.
OnGetItemsCaptionMaxWidth | This method is used by the report control to calculate items captions maximum width.
OnGetToolTipInfo | This method is called to get tooltip text for the item
OnPreviewKeyDown | This method is called before processing OnKeyDown event.
OnSelectionChanged | This member function is called after a user selects a row or a column
Paste | Reads records from the clipboard and add them to records collection. The Binary data format is used rather than Text format.
PinFooterRows | Call this member to pin footer records to the last body row. By default, footer records are docked to the footer.
Populate | Performs control population, creating view from the data.
PopulateFooterRows | Performs control's footer rows population, creating view from the data.
PopulateHeaderRows | Performs control's header rows population, creating view from the data.
RedrawControl | Initiates report control redrawing.
RefreshIndexes | Recalculates indexes of all rows.
RegisterWindowClass | Register the window class if it has not already been registered.
ReleaseItem | Call this method to remove all items and column in specified position.
RemoveRecordEx | Removes record with data and associated row. It also remove all children records and their rows.
RemoveRowEx | Removes row and associated record. It also remove all children records and rows.
ResetContent | This method deletes all rows and records from Report Control.
ReSortRows | ReSorts rows tree corresponding to the sort order taken from columns. Works faster than Populate.
SelectionEnable | Call this member to enable rows selection.
SendMessageToParent | Notifies parent control of some event that has happened.
SendNotifyMessage | Sends the specified message to the window.
SerializeState | (Re)Stores control configuration to/from the provided archive stream.
SetAutoCheckItems | Call this member to enable auto check mode for check box items.
SetChanged | Sets new changed status flag for the control. Used for caching control image drawing.
SetDisableReorderColumnsCount | Call this method to set count of the columns at the left side where reordering is disabled.
SetFilterHiddenColumns | Call this method to enable or disable search filter text in hidden columns.
SetFilterText | Call this method to set new filter for control.
SetFocusedColumn | Call this member to set selected column.
SetFocusedRow |
SetFreezeColumnsCount | Call this method to set count of none-scrolled columns at the left side.
SetFullColumnScrolling | Set horizontal scrolling mode.
SetGridColor | Change color of GridLines.
SetGridStyle | Set or clear grid drawing style.
SetGroupRowsBold | Set group rows text style: bold or normal.
SetHScrollStep | Use this function to set horizontal scrolling step.
SetImageList | Initiates ImageList of Paint Manager.
SetImageManager | Call this method to set new image manager.
SetLayoutRTL | Call this member to set right-to-left mode.
SetLeftOffset | Call this method to set horizontal scroll position.
SetMouseMode | Sets new operational control mouse mode.
SetMultipleSelection | Changes allowing multiple selections for the control.
SetMultiSelectionMode | Enables/disables the multiple selection mode for the control.
SetPaintManager | Call this method to set custom paint manager.
SetReportHeader | Call this member to change report header of Report Control
SetRowsCompareFunc | Set compare function to sort.
SetSortRecordChilds | Call this method to apply sort order for record children
SetTopRow | Force provided row to the top.
SetTreeIndent | Call this member to specifies the indentation placed before the text of each child node in a hierarchical tree structure.
SetVirtualMode | Call this method to enable virtual mode of the control
SetWatermarkAlignment | Call this member to set watermark alignment flags.
SetWatermarkBitmap |
ShadeGroupHeadings | Enable/disable group shade.
ShowFooter | Call this member to hide/show report footers.
ShowFooterRows | Call this member to hide/show footer records.
ShowGroupBy | Shows/hides Group By control area.
ShowHeader | Call this member to hide/show column headers.
ShowHeaderRows | Call this member to hide/show header records.
ShowRowFocus | Call this member to enable showing the row focus.
SkipGroupsFocus | Call this member to specify whether groups are skipped when navigating the ReportControl with the Up and Down keys.
SortRows | Sorts rows corresponding to the sort order taken from columns.
SortTree | Sorts rows tree corresponding to the sort order taken from columns.
UpdateRecord | Updates record.
UpdateSubList | Update field chooser control with its content.
UseReportCustomHeap | Call this function to use custom heap feature.
UseRowBatchAllocation | Call this function to enable batch allocation feature for report rows.


CXTPReportControl Classes

Classes, CXTPReportControl Class
CXTPReportControl Classes
Classes
Class | Description
CUpdateContext | Internal report update helper.
Class

CXTPReportControl Class


CXTPReportControl::CUpdateContext Class

XTPReportControl.h, CXTPReportControl Classes, Legend, Members, Topics, CUpdateContext Data Members, CUpdateContext Constructors, CUpdateContext Destructors, CUpdateContext Constructors, CUpdateContext Data Members, CUpdateContext Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::CUpdateContext Class

Internal report update helper.

Class Hierarchy

class CUpdateContext;
File

XTPReportControl.h

Group

CXTPReportControl Classes

Legend
Data Member
protected
Constructor
CUpdateContext Constructors
CUpdateContext Constructors | Description
CUpdateContext | Constructs a CXTPReportControlUpdateContext object.
CUpdateContext Data Members
CUpdateContext Data Members | Description
m_pControl | Updated report control pointer
CUpdateContext Destructors
CUpdateContext Destructors | Description
~CUpdateContext | Destroys a CXTPReportControlUpdateContext object, handles cleanup and deallocation.


CUpdateContext Data Members

CXTPReportControl::CUpdateContext Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CUpdateContext Data Members
Class

CXTPReportControl::CUpdateContext Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pControl | Updated report control pointer


CXTPReportControl::CUpdateContext::m_pControl Data Member

CUpdateContext Data Members, CXTPReportControl::CUpdateContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::CUpdateContext::m_pControl Data Member

Updated report control pointer

CXTPReportControl* m_pControl;
Group

CUpdateContext Data Members


CUpdateContext Constructors

CXTPReportControl::CUpdateContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CUpdateContext Constructors
Class

CXTPReportControl::CUpdateContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CUpdateContext | Constructs a CXTPReportControlUpdateContext object.


CXTPReportControl::CUpdateContext::CUpdateContext Constructor

CUpdateContext Constructors, CXTPReportControl::CUpdateContext Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::CUpdateContext::CUpdateContext Constructor

Constructs a CXTPReportControlUpdateContext object.

CUpdateContext(
    CXTPReportControl* pControl
);
Parameters

pControl
Pointer to a Report Control object.

Body Source
CUpdateContext(CXTPReportControl* pControl)
{
    m_pControl = pControl;
    pControl->BeginUpdate();
}
Group

CUpdateContext Constructors


CUpdateContext Destructors

CXTPReportControl::CUpdateContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CUpdateContext Destructors
Class

CXTPReportControl::CUpdateContext Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CUpdateContext | Destroys a CXTPReportControlUpdateContext object, handles cleanup and deallocation.


CXTPReportControl::CUpdateContext::~CUpdateContext Destructor

CUpdateContext Destructors, CXTPReportControl::CUpdateContext Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::CUpdateContext::~CUpdateContext Destructor

Destroys a CXTPReportControlUpdateContext object, handles cleanup and deallocation.

~CUpdateContext();
Body Source
~CUpdateContext()
{
    m_pControl->EndUpdate();
}
Group

CUpdateContext Destructors


CXTPReportControl Data Members

CXTPReportControl Class, Legend, Protected Data Members
CXTPReportControl Data Members
Class

CXTPReportControl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrScreenRows | Rows currently presented on screen.
m_bAllowEdit | TRUE if sub-items can be edited.
m_bAutoCheckItems | TRUE to enable auto check mode, FALSE to disable auto check mode.
m_bChanged | Internal member for storing changed flag.
m_bDragMode | TRUE if records currently dragging
m_bEditOnClick | TRUE if sub-items become editable on a single-click
m_bFilterHiddenColumns | Search filter text in hidden columns too.
m_bFocusSubItems | TRUE if sub-items can receive focus.
m_bFooterAllowEdit | TRUE if sub-items of footer rows can be edited.
m_bFooterRecordsVisible | TRUE if footer records are visible.
m_bFooterRowsAllowAccess | TRUE if a footer row can be selected by user.
m_bFooterRowsSelectionEnable | TRUE if footer row selection enabled.
m_bFooterVisible | TRUE if column footer are visible.
m_bFullColumnScrolling | Store Full Column Scrolling mode for horizontal scrolling.
m_bGroupByEnabled | TRUE if Group By box is enabled
m_bHeaderAllowEdit | TRUE if sub-items of header rows can be edited.
m_bHeaderRecordsVisible | TRUE if header records are visible.
m_bHeaderRowsAllowAccess | TRUE if a header row can be selected by user.
m_bHeaderRowsSelectionEnable | TRUE if header row selection enabled.
m_bHeaderVisible | TRUE if column headers are visible.
m_bHScrollBarVisible | TRUE if horizontal scroll bar is visible
m_bmpCache | Cached window bitmap.
m_bMultipleSelection | TRUE if multiple selection enabled.
m_bMultiSelectionMode | TRUE if multiselection mode enabled (i.e.
m_bmWatermark | Watermark bitmap info.
m_bOnSizeRunning | TRUE if OnSize handler is entered, FALSE otherwise.
m_bPinFooterRecords | TRUE if footer records are drawn immediately after the body rows.
m_bPrepareDrag | TRUE if user click the report control and doesn't release button.
m_bRefreshIndexes | TRUE when it is required to refresh items indexes.
m_bRowFocusVisible | TRUE if showing focused row rectangle enabled.
m_bSelectionEnable | TRUE if selection enabled.
m_bShowTooltips | TRUE if showing tool tips enabled.
m_bSkipGroupsFocus | TRUE if group rows are skipped when navigating rows with the Up and Down arrow keys
m_bSortRecordChilds | TRUE to apply sort order for Record children.
m_bVScrollBarVisible | TRUE if vertical scroll bar is visible
m_cfReport | Report Clipboard format for drag/drop operations
m_dwDragDropFlags | Drag/drop flags.
m_hbmpWatermark | Watermark bitmap handle.
m_mouseMode | Current mouse operation mode
m_nDisableReorderColumnsCount | Count of columns at the left side where reordering is disabled.
m_nDropPos | Position of records to be dropped
m_nEnsureVisibleColumnIdx | Ensure visible column index.
m_nEnsureVisibleRowIdx | Ensure visible row index.
m_nFocusedFooterRow | Pointer to the currently focused footer row.
m_nFocusedHeaderRow | Pointer to the currently focused header row.
m_nFocusedRow | Pointer to the currently focused row.
m_nFreezeColumnsCount | Count of none-scrolled columns at the left side.
m_nHScrollStep | Horizontal scroll step (in pixels).
m_nLeftOffset | Horizontal scroll position.
m_nLockUpdateCount | A counter of the update locks.
m_nPopulatedRecordsCount | Current number of records in the report after using m_strFilterText.
m_nRowsPerWheel | Amount of rows to scroll by mouse wheel.
m_nTopRow | Current top row in the visible area.
m_pActiveItem | Pointer to the currently focused CXTPReportRecordItem.
m_pColumns | List columns container.
m_pDropRecords | Drop records.
m_pDropTarget | Internal drag/drop helper.
m_pFocusedColumn | Pointer to the currently focused CXTPReportColumn.
m_pFooterRecords | Footer records container.
m_pFooterRows | Virtual list of footer rows container.
m_pHeaderRecords | Header records container.
m_pHeaderRows | Virtual list of header rows container.
m_pHotRow | Hot row
m_pImageManager | Contains image list for report control
m_pInplaceButtons | In-place buttons pointer
m_pInplaceEdit | In-place edit pointer
m_pInplaceList | In-place list pointer
m_pNavigator | Navigator
m_pointDrag | Drag position
m_pPaintManager | Paint manager.
m_pPlainTree | Tree rows container.
m_pRecords | List records container.
m_pReportHeader | List header member.
m_pRows | Virtual list rows container.
m_pRowsCompareFunc | Pointer to rows compare function.
m_pSelectedRows | Container for the currently selected rows.
m_pSelectOnUpRow | Row to select on mouse up.
m_pToolTipContext | Tool tip Context.
m_ptrVirtualEditingRow | Currently editing row in virtual mode.
m_rcFooterArea | The area occupied by the footer.
m_rcFooterRecordsArea | The area occupied by the footer records.
m_rcFooterRecordsDividerArea | The area occupied by the footer records divider.
m_rcGroupByArea | The area occupied by Group By item.
m_rcHeaderArea | The area occupied by the header.
m_rcHeaderRecordsArea | The area occupied by the header records.
m_rcHeaderRecordsDividerArea | The area occupied by the header records divider.
m_rcReportArea | The area occupied by rows.
m_strFilterText | Filter text.
m_uAutoScrollTimerID | Auto scroll timer ID or 0.
m_WatermarkAlignment | Watermark alignment flags.
m_WatermarkTransparency | Watermark bitmap transparency value.
m_wndTip | Tip window.


CXTPReportControl::m_arrScreenRows Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_arrScreenRows Data Member

Rows currently presented on screen.

CXTPReportRows m_arrScreenRows;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bAllowEdit Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bAllowEdit Data Member

TRUE if sub-items can be edited.

BOOL m_bAllowEdit;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bAutoCheckItems Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bAutoCheckItems Data Member

TRUE to enable auto check mode, FALSE to disable auto check mode.

BOOL m_bAutoCheckItems;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bChanged Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bChanged Data Member

Internal member for storing changed flag.

BOOL m_bChanged;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bDragMode Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bDragMode Data Member

TRUE if records currently dragging

BOOL m_bDragMode;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bEditOnClick Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bEditOnClick Data Member

TRUE if sub-items become editable on a single-click

BOOL m_bEditOnClick;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bFilterHiddenColumns Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bFilterHiddenColumns Data Member

Search filter text in hidden columns too.

BOOL m_bFilterHiddenColumns;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bFocusSubItems Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bFocusSubItems Data Member

TRUE if sub-items can receive focus.

BOOL m_bFocusSubItems;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bFooterAllowEdit Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bFooterAllowEdit Data Member

TRUE if sub-items of footer rows can be edited.

BOOL m_bFooterAllowEdit;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bFooterRecordsVisible Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bFooterRecordsVisible Data Member

TRUE if footer records are visible.

BOOL m_bFooterRecordsVisible;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bFooterRowsAllowAccess Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bFooterRowsAllowAccess Data Member

TRUE if a footer row can be selected by user.

BOOL m_bFooterRowsAllowAccess;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bFooterRowsSelectionEnable Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bFooterRowsSelectionEnable Data Member

TRUE if footer row selection enabled.

BOOL m_bFooterRowsSelectionEnable;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bFooterVisible Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bFooterVisible Data Member

TRUE if column footer are visible.

BOOL m_bFooterVisible;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bFullColumnScrolling Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bFullColumnScrolling Data Member

Store Full Column Scrolling mode for horizontal scrolling.

BOOL m_bFullColumnScrolling;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bGroupByEnabled Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bGroupByEnabled Data Member

TRUE if Group By box is enabled

BOOL m_bGroupByEnabled;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bHeaderAllowEdit Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bHeaderAllowEdit Data Member

TRUE if sub-items of header rows can be edited.

BOOL m_bHeaderAllowEdit;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bHeaderRecordsVisible Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bHeaderRecordsVisible Data Member

TRUE if header records are visible.

BOOL m_bHeaderRecordsVisible;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bHeaderRowsAllowAccess Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bHeaderRowsAllowAccess Data Member

TRUE if a header row can be selected by user.

BOOL m_bHeaderRowsAllowAccess;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bHeaderRowsSelectionEnable Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bHeaderRowsSelectionEnable Data Member

TRUE if header row selection enabled.

BOOL m_bHeaderRowsSelectionEnable;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bHeaderVisible Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bHeaderVisible Data Member

TRUE if column headers are visible.

BOOL m_bHeaderVisible;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bHScrollBarVisible Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bHScrollBarVisible Data Member

TRUE if horizontal scroll bar is visible

BOOL m_bHScrollBarVisible;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bmpCache Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bmpCache Data Member

Cached window bitmap.

CBitmap m_bmpCache;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bMultipleSelection Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bMultipleSelection Data Member

TRUE if multiple selection enabled.

BOOL m_bMultipleSelection;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bMultiSelectionMode Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bMultiSelectionMode Data Member

TRUE if multiselection mode enabled (i.e.

BOOL m_bMultiSelectionMode;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bmWatermark Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bmWatermark Data Member

Watermark bitmap info.

BITMAP m_bmWatermark;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bOnSizeRunning Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bOnSizeRunning Data Member

TRUE if OnSize handler is entered, FALSE otherwise.

BOOL m_bOnSizeRunning;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bPinFooterRecords Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bPinFooterRecords Data Member

TRUE if footer records are drawn immediately after the body rows.

BOOL m_bPinFooterRecords;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bPrepareDrag Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bPrepareDrag Data Member

TRUE if user click the report control and doesn't release button.

BOOL m_bPrepareDrag;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bRefreshIndexes Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bRefreshIndexes Data Member

TRUE when it is required to refresh items indexes.

BOOL m_bRefreshIndexes;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bRowFocusVisible Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bRowFocusVisible Data Member

TRUE if showing focused row rectangle enabled.

BOOL m_bRowFocusVisible;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bSelectionEnable Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bSelectionEnable Data Member

TRUE if selection enabled.

BOOL m_bSelectionEnable;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bShowTooltips Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bShowTooltips Data Member

TRUE if showing tool tips enabled.

BOOL m_bShowTooltips;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bSkipGroupsFocus Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bSkipGroupsFocus Data Member

TRUE if group rows are skipped when navigating rows with the Up and Down arrow keys

BOOL m_bSkipGroupsFocus;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bSortRecordChilds Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bSortRecordChilds Data Member

TRUE to apply sort order for Record children.

BOOL m_bSortRecordChilds;
Group

CXTPReportControl Data Members


CXTPReportControl::m_bVScrollBarVisible Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_bVScrollBarVisible Data Member

TRUE if vertical scroll bar is visible

BOOL m_bVScrollBarVisible;
Group

CXTPReportControl Data Members


CXTPReportControl::m_cfReport Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_cfReport Data Member

Report Clipboard format for drag/drop operations

CLIPFORMAT m_cfReport;
Group

CXTPReportControl Data Members


CXTPReportControl::m_dwDragDropFlags Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_dwDragDropFlags Data Member

Drag/drop flags.

DWORD m_dwDragDropFlags;
Group

CXTPReportControl Data Members


CXTPReportControl::m_hbmpWatermark Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_hbmpWatermark Data Member

Watermark bitmap handle.

HBITMAP m_hbmpWatermark;
Group

CXTPReportControl Data Members


CXTPReportControl::m_mouseMode Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_mouseMode Data Member

Current mouse operation mode

XTPReportMouseMode m_mouseMode;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nDisableReorderColumnsCount Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nDisableReorderColumnsCount Data Member

Count of columns at the left side where reordering is disabled.

int m_nDisableReorderColumnsCount;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nDropPos Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nDropPos Data Member

Position of records to be dropped

int m_nDropPos;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nEnsureVisibleColumnIdx Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nEnsureVisibleColumnIdx Data Member

Ensure visible column index.

int m_nEnsureVisibleColumnIdx;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nEnsureVisibleRowIdx Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nEnsureVisibleRowIdx Data Member

Ensure visible row index.

int m_nEnsureVisibleRowIdx;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nFocusedFooterRow Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nFocusedFooterRow Data Member

Pointer to the currently focused footer row.

int m_nFocusedFooterRow;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nFocusedHeaderRow Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nFocusedHeaderRow Data Member

Pointer to the currently focused header row.

int m_nFocusedHeaderRow;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nFocusedRow Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nFocusedRow Data Member

Pointer to the currently focused row.

int m_nFocusedRow;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nFreezeColumnsCount Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nFreezeColumnsCount Data Member

Count of none-scrolled columns at the left side.

int m_nFreezeColumnsCount;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nHScrollStep Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nHScrollStep Data Member

Horizontal scroll step (in pixels).

int m_nHScrollStep;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nLeftOffset Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nLeftOffset Data Member

Horizontal scroll position.

int m_nLeftOffset;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nLockUpdateCount Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nLockUpdateCount Data Member

A counter of the update locks.

int m_nLockUpdateCount;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nPopulatedRecordsCount Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nPopulatedRecordsCount Data Member

Current number of records in the report after using m_strFilterText.

int m_nPopulatedRecordsCount;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nRowsPerWheel Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nRowsPerWheel Data Member

Amount of rows to scroll by mouse wheel.

int m_nRowsPerWheel;
Group

CXTPReportControl Data Members


CXTPReportControl::m_nTopRow Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_nTopRow Data Member

Current top row in the visible area.

int m_nTopRow;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pActiveItem Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pActiveItem Data Member

Pointer to the currently focused CXTPReportRecordItem.

CXTPReportRecordItem* m_pActiveItem;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pColumns Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pColumns Data Member

List columns container.

CXTPReportColumns* m_pColumns;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pDropRecords Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pDropRecords Data Member

Drop records.

CXTPReportRecords* m_pDropRecords;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pDropTarget Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pDropTarget Data Member

Internal drag/drop helper.

CReportDropTarget* m_pDropTarget;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pFocusedColumn Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pFocusedColumn Data Member

Pointer to the currently focused CXTPReportColumn.

CXTPReportColumn* m_pFocusedColumn;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pFooterRecords Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pFooterRecords Data Member

Footer records container.

CXTPReportRecords* m_pFooterRecords;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pFooterRows Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pFooterRows Data Member

Virtual list of footer rows container.

CXTPReportRows* m_pFooterRows;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pHeaderRecords Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pHeaderRecords Data Member

Header records container.

CXTPReportRecords* m_pHeaderRecords;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pHeaderRows Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pHeaderRows Data Member

Virtual list of header rows container.

CXTPReportRows* m_pHeaderRows;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pHotRow Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pHotRow Data Member

Hot row

CXTPReportRow* m_pHotRow;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pImageManager Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pImageManager Data Member

Contains image list for report control

CXTPImageManager* m_pImageManager;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pInplaceButtons Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pInplaceButtons Data Member

In-place buttons pointer

CXTPReportInplaceButtons* m_pInplaceButtons;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pInplaceEdit Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pInplaceEdit Data Member

In-place edit pointer

CXTPReportInplaceEdit* m_pInplaceEdit;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pInplaceList Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pInplaceList Data Member

In-place list pointer

CXTPReportInplaceList* m_pInplaceList;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pNavigator Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pNavigator Data Member

Navigator

CXTPReportNavigator* m_pNavigator;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pointDrag Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pointDrag Data Member

Drag position

CPoint m_pointDrag;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pPaintManager Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pPaintManager Data Member

Paint manager.

CXTPReportPaintManager* m_pPaintManager;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pPlainTree Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pPlainTree Data Member

Tree rows container.

CXTPReportRows* m_pPlainTree;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pRecords Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pRecords Data Member

List records container.

CXTPReportRecords* m_pRecords;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pReportHeader Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pReportHeader Data Member

List header member.

CXTPReportHeader* m_pReportHeader;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pRows Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pRows Data Member

Virtual list rows container.

CXTPReportRows* m_pRows;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pRowsCompareFunc Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pRowsCompareFunc Data Member

Pointer to rows compare function.

CXTPReportRows::T_CompareFunc m_pRowsCompareFunc;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pSelectedRows Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pSelectedRows Data Member

Container for the currently selected rows.

CXTPReportSelectedRows* m_pSelectedRows;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pSelectOnUpRow Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pSelectOnUpRow Data Member

Row to select on mouse up.

CXTPReportRow* m_pSelectOnUpRow;
Group

CXTPReportControl Data Members


CXTPReportControl::m_pToolTipContext Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_pToolTipContext Data Member

Tool tip Context.

CXTPToolTipContext* m_pToolTipContext;
Group

CXTPReportControl Data Members


CXTPReportControl::m_ptrVirtualEditingRow Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_ptrVirtualEditingRow Data Member

Currently editing row in virtual mode.

CXTPReportRow* m_ptrVirtualEditingRow;
Group

CXTPReportControl Data Members


CXTPReportControl::m_rcFooterArea Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_rcFooterArea Data Member

The area occupied by the footer.

CRect m_rcFooterArea;
Group

CXTPReportControl Data Members


CXTPReportControl::m_rcFooterRecordsArea Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_rcFooterRecordsArea Data Member

The area occupied by the footer records.

CRect m_rcFooterRecordsArea;
Group

CXTPReportControl Data Members


CXTPReportControl::m_rcFooterRecordsDividerArea Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_rcFooterRecordsDividerArea Data Member

The area occupied by the footer records divider.

CRect m_rcFooterRecordsDividerArea;
Group

CXTPReportControl Data Members


CXTPReportControl::m_rcGroupByArea Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_rcGroupByArea Data Member

The area occupied by Group By item.

CRect m_rcGroupByArea;
Group

CXTPReportControl Data Members


CXTPReportControl::m_rcHeaderArea Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_rcHeaderArea Data Member

The area occupied by the header.

CRect m_rcHeaderArea;
Group

CXTPReportControl Data Members


CXTPReportControl::m_rcHeaderRecordsArea Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_rcHeaderRecordsArea Data Member

The area occupied by the header records.

CRect m_rcHeaderRecordsArea;
Group

CXTPReportControl Data Members


CXTPReportControl::m_rcHeaderRecordsDividerArea Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_rcHeaderRecordsDividerArea Data Member

The area occupied by the header records divider.

CRect m_rcHeaderRecordsDividerArea;
Group

CXTPReportControl Data Members


CXTPReportControl::m_rcReportArea Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_rcReportArea Data Member

The area occupied by rows.

CRect m_rcReportArea;
Group

CXTPReportControl Data Members


CXTPReportControl::m_strFilterText Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_strFilterText Data Member

Filter text.

CString m_strFilterText;
Group

CXTPReportControl Data Members


CXTPReportControl::m_uAutoScrollTimerID Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_uAutoScrollTimerID Data Member

Auto scroll timer ID or 0.

UINT_PTR m_uAutoScrollTimerID;
Group

CXTPReportControl Data Members


CXTPReportControl::m_WatermarkAlignment Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_WatermarkAlignment Data Member

Watermark alignment flags.

XTPReportWatermarkAlignment m_WatermarkAlignment;
Group

CXTPReportControl Data Members


CXTPReportControl::m_WatermarkTransparency Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_WatermarkTransparency Data Member

Watermark bitmap transparency value.

BYTE m_WatermarkTransparency;
Group

CXTPReportControl Data Members


CXTPReportControl::m_wndTip Data Member

CXTPReportControl Data Members, CXTPReportControl Class
CXTPReportControl::m_wndTip Data Member

Tip window.

CXTPReportTip m_wndTip;
Group

CXTPReportControl Data Members


CXTPReportControl Methods

CXTPReportControl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl Methods
Class

CXTPReportControl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_DoCollapse | Collapses all children of the specified row.
_DoExpand |
AdjustIndentation | Adjust control indentation properties depending on current tree depth.
ApplyFilter | Checks a record for filter text.
BuildTree | Builds rows tree based on provided data record.
CreateGroupRow | This method is called to create new CXTPReportGroupRow object. Overwrite it to use derived CXTPReportGroupRow class.
CreateHeaderFooterRow | This method is called to create new CXTPReportRow object for header/footer rows. Overwrite it to use derived CXTPReportRow class.
CreateRow | This method is called to create new CXTPReportRow object. Overwrite it to use derived CXTPReportRow class.
DoAutoVertScrollIfNeed | This method is used to monitoring mouse position. If mouse will be moved to 20 pixels before top or before bottom report borders the control will be scrolled vertically.
DrawFixedRecordsDivider | Draws fixed rows divider on the provided DC.
DrawFixedRows | Draws fixed rows on the provided DC.
DrawNoItems | Draws 'NoItems' text on the provided DC.
DrawRows | Draws all rows on the provided DC.
EnsureStartAutoVertScroll | This method is used to enable monitoring mouse position for automatic vertical scrolling.
EnsureStopAutoVertScroll | This method is used to stop monitoring mouse position for automatic vertical scrolling.
GetElementRect | Call this method to retrieve report element rectangle.
GetFooterRowsDividerHeight | Returns footer divider height.
GetHeaderRowsDividerHeight | Returns header divider height.
GetItemMetrics | Returns drawing metrics for the row.
GetMouseMode | Returns the current control mouse mode.
GetRowsHeight | Returns calculated rows height.
InsertRow | Inserts the specified row at the specified position.
IsChanged | Returns changed status flag of the control. Used for caching control image drawing.
OnBeforeCopyToText | This method is called before add record text data to the clipboard.
OnBeforePaste | This method is called after creating new record using binary data from the clipboard, but before add it to records collection.
OnBeforePasteFromText | This method is called before creating new record using text data from the clipboard.
OnBeginDrag | This method is called when user start drag row
OnConstraintSelecting | This method is used to notify about changing constraint selection.
OnDragOver | This member is called when an item is dragged over the report control.
OnDraw | Performs all drawing logic.
OnDrop | This member is called when an item has been dropped into the report control.
OnFocusChanging | This member function is called before the focus change
OnGetColumnDataBestFitWidth | This method is used by the report control to calculate BestFit column width.
OnGetItemsCaptionMaxWidth | This method is used by the report control to calculate items captions maximum width.
OnGetToolTipInfo | This method is called to get tooltip text for the item
OnPreviewKeyDown | This method is called before processing OnKeyDown event.
OnSelectionChanged | This member function is called after a user selects a row or a column
RefreshIndexes | Recalculates indexes of all rows.
ReSortRows | ReSorts rows tree corresponding to the sort order taken from columns. Works faster than Populate.
SetChanged | Sets new changed status flag for the control. Used for caching control image drawing.
SetMouseMode | Sets new operational control mouse mode.
SetWatermarkBitmap |
SortRows | Sorts rows corresponding to the sort order taken from columns.
SortTree | Sorts rows tree corresponding to the sort order taken from columns.
UpdateSubList | Update field chooser control with its content.
Public Methods
Public Methods
Public Method | Description
AddColumn | Adds new column to the end of the columns array.
AddRecord | Adds record to records collection.
AddRecordEx | Adds record to records collection and associates a row with it.
AdjustLayout | Adjusts main control areas depending on current control size.
AdjustScrollBars | Adjusts scroll bars depending on currently visible rows.
AllowEdit | Call this member to allow the text in all CXTPReportRecordItem(s) to be edited. This will add an edit box to the item where the text can be edited.
BeginUpdate | Prevents the control from redrawing until the EndUpdate method is called.
CanCopy | Returns TRUE if one or more records are selected indicating the Copy command can be used.
CanCut | Returns TRUE if one or more records are selected indicating the Cut command can be used.
CanPaste | Returns TRUE if BinaryRecords or Text data exists in the clipboard.
CollapseAll | Collapses all rows.
Copy | Copy selected records data (in the Binary and Text data formats) to the clipboard.
Create | This method is called to create a report control.
Cut | Copy selected records data (in the Binary and Text data formats) to the clipboard and delete records.
DoPropExchange | Reads or writes configuration to/from the provided data source.
EditItem | This method is called to start editing a report cell. It makes a specified cell focused and starts in-place editing control which was specified there.
EditOnClick | Call this member to specify whether a CXTPReportRecordItem can be edited by single-clicking on the item.
EnableDragDrop | Call this method to enable built in drag and drop operations
EnableMarkup | Call this method to enable markup for tab captions
EnablePreviewMode | Enable/disable preview mode for the control.
EnableToolTips | Enables/disables showing tooltips for the control.
EndUpdate | Resumes drawing of the report control after drawing is suspended by the BeginUpdate method.
EnsureVisible |
ExpandAll | Expands all rows.
FocusSubItems | Call this member to specify whether each individual CXTPReportRecordItem will show focus when the item in a row is clicked.
FooterRowsAllowAccess | Call this member to allow user moving the selection to footer rows.
FooterRowsAllowEdit | Call this member to allow the text in all CXTPReportRecordItem(s) to be edited (for footer records only). This will add an edit box to the item where the text can be edited.
FooterRowsEnableSelection | Call this member to enable selection in footer rows.
FreeRowBatchExtraData | This member function when rows batch allocation enabled to check all allocated blocks and deallocate which are completely free.
GetActiveItem | Call this member to retrieve the currently active item, which is the item that has focus.
GetColumns | Interface for accessing list columns.
GetDisableReorderColumnsCount | Call this method to retrieve count of the columns at the left side where reordering is disabled.
GetFilterText | Returns the text from the associated filter edit control.
GetFocusedColumn | Call this member to retrieve a pointer to the currently selected column.
GetFocusedRow | Retrieves the index of the row that currently has focus in the report control's view.
GetFooterRecords | Returns the collection of the footer records.
GetFooterRows | Returns the collection of the report footer rows
GetFooterRowsRect | Call this method to retrieve footer rows bounding rectangle.
GetFreezeColumnsCount | Call this method to retrieve count of none-scrolled columns at the left side.
GetGridStyle | Returns current grid drawing mode.
GetHeaderIndent | Call this method to retrieve indentation of the header
GetHeaderRecords | Returns the collection of the header records.
GetHeaderRows | Returns the collection of the report header rows
GetHeaderRowsRect | Call this method to retrieve Header records bounding rectangle.
GetHScrollStep | Use this function to get horizontal scrolling step.
GetImageManager | Call this method to get a pointer to the image manager of Report Control.
GetIndent | Returns indentation for the tree view row of the specified depth level.
GetInplaceButtons | Retrieves in-place buttons of report control
GetInplaceEdit | Retrieves in-place edit pointer
GetInplaceList | Retrieves in-place list of report controls
GetLockUpdateCount | Returns TRUE if control in Update state.
GetMarkupContext | Returns markup context
GetNavigator | Returns the control's Navigator.
GetPaintManager | Returns the currently used control's Paint Manager.
GetRecords | Returns the collection of the data records.
GetReportAreaRows | Returns rows from the visible report area.
GetReportHeader | Returns a pointer to the associated report header object.
GetReportRectangle | Call this method to retrieve Report bounding rectangle.
GetRows | Returns the collection of the report rows
GetSelectedRows | Returns the collection of the selected rows.
GetToolTipContext | Call this method to get tooltip context pointer.
GetTopRowIndex | Call this method to retrieve top row index.
GetWatermarkAlignment | Call this member to determine current watermark alignment flags.
HasFocus | Call this member to determine if the ReportControl has focus.
HeaderRowsAllowAccess | Call this member to allow user moving the selection to header rows.
HeaderRowsAllowEdit | Call this member to allow the text in all CXTPReportRecordItem(s) to be edited (for header records only). This will add an edit box to the item where the text can be edited.
HeaderRowsEnableSelection | Call this member to enable selection in header rows.
HitTest | Determines which report row item, if any, is at a specified position.
IsAllowEdit | Call this member to determine if the CXTPReportRecordItem(s)are editable.
IsAutoCheckItems | Call this member to determine id auto check mode for check box items is enabled.
IsEditMode | Returns TRUE if inplace edit control is active (visible and focused), FALSE otherwise.
IsEditOnClick | Call this member to determine whether items are edited with a single-click.
IsFilterHiddenColumns | Determine if control search filter text in hidden columns too. This option is disabled by default. Returns; TRUE if control search filter text in hidden columns; FALSE otherwise.
IsFocusSubItems | Call this member to determine if individual CXTPReportRecordItem(s) will receive focus when that item in the CXTPReportRow that they belong to is clicked.
IsFooterRowsAllowAccess | Call this member to determine if user can move selection to footer rows.
IsFooterRowsAllowEdit | Call this member to determine if the CXTPReportRecordItem(s) are editable (for footer records only).
IsFooterRowsPinned | Call this member to determine if footer records are pinned to the body rows.
IsFooterRowsSelectionEnabled | Call this member to determine if selection in footer rows is enabled.
IsFooterRowsVisible | Call this member to determine if footer records are currently visible.
IsFooterVisible | Call this member to determine is column footers are currently visible.
IsFullColumnScrolling | Get horizontal scrolling mode.
IsGroupByVisible | Returns current Group By area mode.
IsGroupRowsBold | Returns current group rows text bold style.
IsHeaderRowsAllowAccess | Call this member to determine if user can move selection to header rows.
IsHeaderRowsAllowEdit | Call this member to determine if the CXTPReportRecordItem(s) are editable (for header records only).
IsHeaderRowsSelectionEnabled | Call this member to determine if selection in header rows is enabled.
IsHeaderRowsVisible | Call this member to determine if header records are currently visible.
IsHeaderVisible | Call this member to determine is column headers are currently visible.
IsLayoutRTL | Call this member to get right-to-left mode.
IsMultipleSelection | Determines if the report allows multiple selections.
IsMultiSelectionMode | Determines if the multiple selection mode is enabled.
IsPreviewMode | Returns current preview mode.
IsRowFocusVisible | Call this member to determine if the row focus is visible.
IsSelectionEnabled | Call this member to determine if rows selection is enabled.
IsShadeGroupHeadingsEnabled | Returns current group shade mode.
IsSkipGroupsFocusEnabled | Call this member to determine is groups are skipped when navigating the with the Up and Down arrow keys.
IsSortRecordChilds | Use this function to determine is sort order applied for record children.
IsVirtualMode | Determines if control in virtual mode Returns; TRUE if virtual mode is enabled; FALSE otherwise.
Paste | Reads records from the clipboard and add them to records collection. The Binary data format is used rather than Text format.
PinFooterRows | Call this member to pin footer records to the last body row. By default, footer records are docked to the footer.
Populate | Performs control population, creating view from the data.
PopulateFooterRows | Performs control's footer rows population, creating view from the data.
PopulateHeaderRows | Performs control's header rows population, creating view from the data.
RedrawControl | Initiates report control redrawing.
RegisterWindowClass | Register the window class if it has not already been registered.
ReleaseItem | Call this method to remove all items and column in specified position.
RemoveRecordEx | Removes record with data and associated row. It also remove all children records and their rows.
RemoveRowEx | Removes row and associated record. It also remove all children records and rows.
ResetContent | This method deletes all rows and records from Report Control.
SelectionEnable | Call this member to enable rows selection.
SendMessageToParent | Notifies parent control of some event that has happened.
SendNotifyMessage | Sends the specified message to the window.
SerializeState | (Re)Stores control configuration to/from the provided archive stream.
SetAutoCheckItems | Call this member to enable auto check mode for check box items.
SetDisableReorderColumnsCount | Call this method to set count of the columns at the left side where reordering is disabled.
SetFilterHiddenColumns | Call this method to enable or disable search filter text in hidden columns.
SetFilterText | Call this method to set new filter for control.
SetFocusedColumn | Call this member to set selected column.
SetFocusedRow |
SetFreezeColumnsCount | Call this method to set count of none-scrolled columns at the left side.
SetFullColumnScrolling | Set horizontal scrolling mode.
SetGridColor | Change color of GridLines.
SetGridStyle | Set or clear grid drawing style.
SetGroupRowsBold | Set group rows text style: bold or normal.
SetHScrollStep | Use this function to set horizontal scrolling step.
SetImageList | Initiates ImageList of Paint Manager.
SetImageManager | Call this method to set new image manager.
SetLayoutRTL | Call this member to set right-to-left mode.
SetLeftOffset | Call this method to set horizontal scroll position.
SetMultipleSelection | Changes allowing multiple selections for the control.
SetMultiSelectionMode | Enables/disables the multiple selection mode for the control.
SetPaintManager | Call this method to set custom paint manager.
SetReportHeader | Call this member to change report header of Report Control
SetRowsCompareFunc | Set compare function to sort.
SetSortRecordChilds | Call this method to apply sort order for record children
SetTopRow | Force provided row to the top.
SetTreeIndent | Call this member to specifies the indentation placed before the text of each child node in a hierarchical tree structure.
SetVirtualMode | Call this method to enable virtual mode of the control
SetWatermarkAlignment | Call this member to set watermark alignment flags.
ShadeGroupHeadings | Enable/disable group shade.
ShowFooter | Call this member to hide/show report footers.
ShowFooterRows | Call this member to hide/show footer records.
ShowGroupBy | Shows/hides Group By control area.
ShowHeader | Call this member to hide/show column headers.
ShowHeaderRows | Call this member to hide/show header records.
ShowRowFocus | Call this member to enable showing the row focus.
SkipGroupsFocus | Call this member to specify whether groups are skipped when navigating the ReportControl with the Up and Down keys.
UpdateRecord | Updates record.
UseReportCustomHeap | Call this function to use custom heap feature.
UseRowBatchAllocation | Call this function to enable batch allocation feature for report rows.


CXTPReportControl::_DoCollapse Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::_DoCollapse Method

Collapses all children of the specified row.

virtual void _DoCollapse(
    CXTPReportRow* pRow
);
Parameters

pRow
A row to collapse.

Group

CXTPReportControl Methods


_DoExpand Method

CXTPReportControl Methods
_DoExpand Method
Overload List
Methods
Method | Description
CXTPReportControl::_DoExpand (CXTPReportRow*) | Expands all children of the specified row.
CXTPReportControl::_DoExpand (int, CXTPReportRow*) | Expands all children of the specified row.
Group

CXTPReportControl Methods


CXTPReportControl::_DoExpand Method (int, CXTPReportRow*)

_DoExpand Method, CXTPReportControl Class
CXTPReportControl::_DoExpand Method (int, CXTPReportRow*)

Expands all children of the specified row.

virtual int _DoExpand(
    int nIndex,
    CXTPReportRow* pRow
);
virtual void _DoExpand(
    CXTPReportRow* pRow
);
Parameters

nIndex
An index to insert rows from.
pRow
A row to expand.

Returns

A count of the newly added rows or void.

Group

_DoExpand Method


CXTPReportControl::AddColumn Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::AddColumn Method

Adds new column to the end of the columns array.

CXTPReportColumn* AddColumn(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Pointer to the specified column class object.

Remarks

Call this member function if you want to add a new column to a report control. It will be added to the end of the columns array.

See Also

CXTPReportColumn overview

Example
// this function adds a column with "Subject" caption and 250 pixels initial width
void AddSubjectColumn(CXTPReportControl* pReportCtrl)
{
    pReportCtrl->AddColumn(new CXTPReportColumn(1, _T("Subject"), 250));
}
Group

CXTPReportControl Methods


CXTPReportControl::AddRecord Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::AddRecord Method

Adds record to records collection.

virtual CXTPReportRecord* AddRecord(
    CXTPReportRecord* pRecord
);
Parameters

pRecord
Record data with items.

Returns

Pointer to the recently added record object.

Remarks

Call this member function if you want to add a data record to the report control's internal storage.

See Also

CXTPReportRecord overview, GetRecords

Example
// this function adds 2 empty records to a report control
void Add2Empties(CXTPReportControl* pReportCtrl)
{
    pReportCtrl->AddRecord(new CXTPReportRecord());
    pReportCtrl->AddRecord(new CXTPReportRecord());
}
Group

CXTPReportControl Methods


CXTPReportControl::AddRecordEx Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::AddRecordEx Method

Adds record to records collection and associates a row with it.

virtual void AddRecordEx(
    CXTPReportRecord* pRecord,
    CXTPReportRecord* pParentRecord = NULL,
    int nChildIndex = -1
);
Parameters

pRecord
Record data with items.
pParentRecord
Parent record.
nChildIndex
child index a record to be inserted at.

Remarks

Call this member function if you want to add a data record to the report control's internal storage and associate a row with it.

See Also

CXTPReportRecord overview, GetRecords, RemoveRecordEx, RemoveRowEx UpdateRecord

Example
// this function adds 2 empty records to a report control
void Add2Empties(CXTPReportControl* pReportCtrl)
{
    pReportCtrl->AddRecordEx(new CXTPReportRecord());
    pReportCtrl->AddRecordEx(new CXTPReportRecord());
}
Group

CXTPReportControl Methods


CXTPReportControl::AdjustIndentation Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::AdjustIndentation Method

Adjust control indentation properties depending on current tree depth.

void AdjustIndentation();
See Also

GetIndent

Group

CXTPReportControl Methods


CXTPReportControl::AdjustLayout Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::AdjustLayout Method

Adjusts main control areas depending on current control size.

void AdjustLayout();
Group

CXTPReportControl Methods


CXTPReportControl::AdjustScrollBars Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::AdjustScrollBars Method

Adjusts scroll bars depending on currently visible rows.

virtual void AdjustScrollBars();
Group

CXTPReportControl Methods


CXTPReportControl::AllowEdit Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::AllowEdit Method

Call this member to allow the text in all CXTPReportRecordItem(s) to be edited. This will add an edit box to the item where the text can be edited.

void AllowEdit(
    BOOL bAllowEdit
);
Parameters

bAllowEdit
TRUE to add an edit box to the CXTPReportRecordItem(s) so they are editable. FALSE to remove the edit box and not allow them to be edited.

See Also

IsAllowEdit, EditOnClick, IsEditOnClick

Body Source
void CXTPReportControl::AllowEdit(BOOL bAllowEdit) {
    m_bAllowEdit = bAllowEdit;
}
Group

CXTPReportControl Methods


CXTPReportControl::ApplyFilter Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::ApplyFilter Method

Checks a record for filter text.

virtual BOOL ApplyFilter(
    CXTPReportRecord* pRecord,
    CString strFilterText,
    BOOL bIncludePreview
);
Parameters

pRecord
A record to apply filter to.
strFilterText
Filter string text.
bIncludePreview
Include preview item in filtering or not.

Returns

TRUE if record is filtered with the specified filter, FALSE otherwise.

Remarks

This member function represents filter functionality. First, it parses the input text of a filter string by tokens; second it enumerates all visible columns to find text matching to the filter string. Returns TRUE if matching found, FALSE otherwise

Group

CXTPReportControl Methods


CXTPReportControl::BeginUpdate Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::BeginUpdate Method

Prevents the control from redrawing until the EndUpdate method is called.

void BeginUpdate();
Remarks

If you want to add items one at a time using the AddRecord method, or to make some another operations in a single sequence, you can use the BeginUpdate method to prevent the control from repainting the CXTPReportControl each time an item is added. Once you have completed the task of adding items to the control, call the EndUpdate method to enable the CXTPReportControl to repaint. This way of adding items can prevent flickered drawing of the CXTPReportControl when a large number of items are being added to the control.

See Also

EndUpdate, RedrawControl, AddRecord

Example
// This function collapses all rows for the specified report control
void CollapseAll(CXTPReportControl* pReportCtrl)
{
    pReportCtrl->BeginUpdate();
    for (int i = pReportCtrl->GetRows()->GetCount() - 1; i >= 0; i --)
        pReportCtrl->GetRows()->GetAt(i)->SetExpanded(FALSE);

    pReportCtrl->EndUpdate();
}
Group

CXTPReportControl Methods


CXTPReportControl::BuildTree Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::BuildTree Method

Builds rows tree based on provided data record.

virtual void BuildTree(
    CXTPReportRows* pTree,
    CXTPReportRow* pParentRow,
    CXTPReportRecords* pRecords
);
Parameters

pTree
Rows tree to add items into.
pParentRow
Parent tree row.
pRecords
Records collection for transferring to rows.

Remarks

Builds rows tree based on provided data record. Recursively calls itself when build nested branches of rows

Group

CXTPReportControl Methods


CXTPReportControl::CanCopy Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::CanCopy Method

Returns TRUE if one or more records are selected indicating the Copy command can be used.

virtual BOOL CanCopy();
See Also

CanPaste, Cut, Copy, Paste.

Group

CXTPReportControl Methods


CXTPReportControl::CanCut Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::CanCut Method

Returns TRUE if one or more records are selected indicating the Cut command can be used.

virtual BOOL CanCut();
See Also

CanPaste, Cut, Copy, Paste.

Group

CXTPReportControl Methods


CXTPReportControl::CanPaste Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::CanPaste Method

Returns TRUE if BinaryRecords or Text data exists in the clipboard.

virtual BOOL CanPaste();
See Also

CanCut, CanCopy, Cut, Copy, Paste.

Group

CXTPReportControl Methods


CXTPReportControl::CollapseAll Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::CollapseAll Method

Collapses all rows.

void CollapseAll();
Remarks

The CollapseAll method collapses all the CXTPReportRow objects, including all the child rows, that are in the report control.

See Also

ExpandAll, CXTPReportRow::SetExpanded

Group

CXTPReportControl Methods


CXTPReportControl::Copy Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::Copy Method

Copy selected records data (in the Binary and Text data formats) to the clipboard.

virtual void Copy();
See Also

CanCut, CanCopy, CanPaste, Cut, Paste, OnBeforeCopyToText, OnBeforePasteFromText, OnBeforePaste.

Group

CXTPReportControl Methods


CXTPReportControl::Create Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::Create Method

This method is called to create a report control.

BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID,
    CCreateContext* pContext = NULL
);
Parameters

dwStyle
Specifies the window style attributes. It could be a combination of standard window styles.
rect
The size and position of the window, in client coordinates of pParentWnd.
pParentWnd
Specifies the report control parent window.
nID
Specifies the report control identifier.
pContext
The create context of the window.

Returns

Nonzero if successful; otherwise 0.

Remarks

You construct a CXTPReportControl object in two steps. First, call the constructor CXTPReportControl and then call Create method, which initializes the window.

See Also

CXTPReportControl::CXTPReportControl

Example

See the example for CXTPReportControl::CXTPReportControl

Group

CXTPReportControl Methods


CXTPReportControl::CreateGroupRow Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::CreateGroupRow Method

This method is called to create new CXTPReportGroupRow object. Overwrite it to use derived CXTPReportGroupRow class.

virtual CXTPReportGroupRow* CreateGroupRow();
Returns

New CXTPReportGroupRow object.

Group

CXTPReportControl Methods


CXTPReportControl::CreateHeaderFooterRow Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::CreateHeaderFooterRow Method

This method is called to create new CXTPReportRow object for header/footer rows. Overwrite it to use derived CXTPReportRow class.

virtual CXTPReportRow* CreateHeaderFooterRow();
Returns

New CXTPReportRow object.

Group

CXTPReportControl Methods


CXTPReportControl::CreateRow Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::CreateRow Method

This method is called to create new CXTPReportRow object. Overwrite it to use derived CXTPReportRow class.

virtual CXTPReportRow* CreateRow();
Returns

New CXTPReportRow object.

Group

CXTPReportControl Methods


CXTPReportControl::Cut Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::Cut Method

Copy selected records data (in the Binary and Text data formats) to the clipboard and delete records.

virtual void Cut();
See Also

CanCut, CanCopy, CanPaste, Copy, Paste, OnBeforeCopyToText, OnBeforePasteFromText, OnBeforePaste.

Group

CXTPReportControl Methods


CXTPReportControl::DoAutoVertScrollIfNeed Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::DoAutoVertScrollIfNeed Method

This method is used to monitoring mouse position. If mouse will be moved to 20 pixels before top or before bottom report borders the control will be scrolled vertically.

virtual void DoAutoVertScrollIfNeed(
    CPoint ptClick,
    CPoint pt
);
Parameters

ptClick
Coordinates of initial click (or mouse down).
pt
Current mouse position.

Remarks

Used when dragging records.

See Also

EnsureStartAutoVertScroll, EnsureStopAutoVertScroll

Group

CXTPReportControl Methods


CXTPReportControl::DoPropExchange Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::DoPropExchange Method

Reads or writes configuration to/from the provided data source.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPReportControl Methods


CXTPReportControl::DrawFixedRecordsDivider Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::DrawFixedRecordsDivider Method

Draws fixed rows divider on the provided DC.

void DrawFixedRecordsDivider(
    CDC* pDC,
    CRect& rcClient,
    BOOL bHeaderRows
);
Parameters

pDC
Provided DC to draw fixed rows divider image with.
rcClient
A rectangle to draw fixed rows divider into.
bHeaderRows
TRUE if the divider is under header rows; FALSE - if above footer rows.

Group

CXTPReportControl Methods


CXTPReportControl::DrawFixedRows Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::DrawFixedRows Method

Draws fixed rows on the provided DC.

virtual void DrawFixedRows(
    CDC* pDC,
    CRect& rcClient,
    CXTPReportRows* pRows
);
Parameters

pDC
Provided DC to draw header rows image with.
rcClient
A rectangle to draw header rows image into.
pRows
Pointer to header/footer record rows.

Group

CXTPReportControl Methods


CXTPReportControl::DrawNoItems Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::DrawNoItems Method

Draws 'NoItems' text on the provided DC.

virtual void DrawNoItems(
    CDC* pDC,
    const CRect& rcClient
);
Parameters

pDC
Provided DC to draw text.
rcClient
A rectangle to draw text into.

Group

CXTPReportControl Methods


CXTPReportControl::DrawRows Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::DrawRows Method

Draws all rows on the provided DC.

virtual void DrawRows(
    CDC* pDC,
    CRect& rcClient
);
Parameters

pDC
Provided DC to draw rows image with.
rcClient
A rectangle to draw rows image into.

Group

CXTPReportControl Methods


CXTPReportControl::EditItem Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::EditItem Method

This method is called to start editing a report cell. It makes a specified cell focused and starts in-place editing control which was specified there.

void EditItem(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Arguments of item to be edit.

Remarks

Note that all editing options should be enabled for this method to be executed successfully.

Call this method with NULL as parameter to stop item edit.

See Also

AllowEdit, CXTPReportColumn::SetEditable

Group

CXTPReportControl Methods


CXTPReportControl::EditOnClick Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::EditOnClick Method

Call this member to specify whether a CXTPReportRecordItem can be edited by single-clicking on the item.

void EditOnClick(
    BOOL bEditOnClick
);
Parameters

bEditOnClick
If TRUE, when the CXTPReportRecordItem is single-clicked, the item will become editable. The entire ReportControl or the specific CXTPReportRecordItem must have the bAllowEdit property set to TRUE for this to work. If FALSE, the item must be double-clicked to become editable.

See Also

AllowEdit, IsAllowEdit, IsEditOnClick

Body Source
void CXTPReportControl::EditOnClick(BOOL bEditOnClick) {
    m_bEditOnClick = bEditOnClick;
}
Group

CXTPReportControl Methods


CXTPReportControl::EnableDragDrop Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::EnableDragDrop Method

Call this method to enable built in drag and drop operations

CLIPFORMAT EnableDragDrop(
    LPCTSTR lpszClipboardFormat,
    DWORD dwFlags
);
Parameters

lpszClipboardFormat
Name of clipboard format to be used for Report Control
dwFlags
Combination of XTPReportDragDrop flags, can be one or more of following: xtpReportAllowDrop - Allow Drop records to report xtpReportAllowDragCopy - Allow copy records from report xtpReportAllowDragMove - Allow move records from report xtpReportAllowDrag - Allow copy and move records from report

Returns

Clipboard format that will be used with Report Control

See Also

XTPReportDragDrop

Group

CXTPReportControl Methods


CXTPReportControl::EnableMarkup Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::EnableMarkup Method

Call this method to enable markup for tab captions

void EnableMarkup(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable markup

Group

CXTPReportControl Methods


CXTPReportControl::EnablePreviewMode Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::EnablePreviewMode Method

Enable/disable preview mode for the control.

void EnablePreviewMode(
    BOOL bIsPreviewMode
);
Parameters

bIsPreviewMode
TRUE for enabling preview mode, FALSE for disabling.

Remarks

Call this member function if you want to hide or show the row preview item.

See Also

IsPreviewMode

Body Source
void CXTPReportControl::EnablePreviewMode(BOOL bIsPreviewMode) {
    m_pPaintManager->EnablePreviewMode(bIsPreviewMode);
}
Group

CXTPReportControl Methods


CXTPReportControl::EnableToolTips Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::EnableToolTips Method

Enables/disables showing tooltips for the control.

void EnableToolTips(
    BOOL bEnable
);
Parameters

bEnable
TRUE for enabling, FALSE for disabling.

Remarks

Call this member function to enable or disable tooltips show for the report control window.

Body Source
void CXTPReportControl::EnableToolTips(BOOL bEnable) {
    m_bShowTooltips = bEnable;
}
Group

CXTPReportControl Methods


CXTPReportControl::EndUpdate Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::EndUpdate Method

Resumes drawing of the report control after drawing is suspended by the BeginUpdate method.

void EndUpdate();
Remarks

If you want to add items one at a time using the AddRecord method, or to make some other operations in a single sequence, you can use the BeginUpdate method to prevent the control from repainting the CXTPReportControl each time an item is added. Once you have completed the task of adding items to the control, call the EndUpdate method to enable the CXTPReportControl to repaint. This way of adding items can prevent flickered drawing of the CXTPReportControl when a large number of items are being added to the control.

See Also

BeginUpdate, RedrawControl

Example

See example for CXTPReportControl::BeginUpdate method.

Group

CXTPReportControl Methods


CXTPReportControl::EnsureStartAutoVertScroll Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::EnsureStartAutoVertScroll Method

This method is used to enable monitoring mouse position for automatic vertical scrolling.

virtual void EnsureStartAutoVertScroll();
Remarks

Used when dragging records.

See Also

EnsureStopAutoVertScroll, DoAutoVertScrollIfNeed

Group

CXTPReportControl Methods


CXTPReportControl::EnsureStopAutoVertScroll Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::EnsureStopAutoVertScroll Method

This method is used to stop monitoring mouse position for automatic vertical scrolling.

virtual void EnsureStopAutoVertScroll();
Remarks

Used when dragging records.

See Also

EnsureStartAutoVertScroll, DoAutoVertScrollIfNeed

Group

CXTPReportControl Methods


EnsureVisible Method

CXTPReportControl Methods
EnsureVisible Method
Overload List
Methods
Method | Description
CXTPReportControl::EnsureVisible (CXTPReportColumn*) | Ensures that a report control column is at least partially visible.
CXTPReportControl::EnsureVisible (CXTPReportRow*) | Ensures that a report control row is at least partially visible.
Group

CXTPReportControl Methods


CXTPReportControl::EnsureVisible Method (CXTPReportColumn*)

EnsureVisible Method, CXTPReportControl Class, See Also
CXTPReportControl::EnsureVisible Method (CXTPReportColumn*)

Ensures that a report control column is at least partially visible.

void EnsureVisible(
    CXTPReportColumn* pCheckColumn
);
Parameters

pCheckColumn
A pointer to the column that is to be visible.

Remarks

Ensures that a report column item is at least partially visible. The list view control is scrolled if necessary.

See Also

MoveRight, MoveLeft, MoveToColumn, MoveFirstColumn, MoveLastColumn

Group

EnsureVisible Method


CXTPReportControl::EnsureVisible Method (CXTPReportRow*)

EnsureVisible Method, CXTPReportControl Class, See Also
CXTPReportControl::EnsureVisible Method (CXTPReportRow*)

Ensures that a report control row is at least partially visible.

void EnsureVisible(
    CXTPReportRow* pCheckRow
);
Parameters

pCheckRow
A pointer to the row that is to be visible.

Remarks

Ensures that a report row item is at least partially visible. The list view control is scrolled if necessary.

See Also

MoveDown, MoveUp, MovePageDown, MovePageUp, MoveFirst, MoveLast

Group

EnsureVisible Method


CXTPReportControl::ExpandAll Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::ExpandAll Method

Expands all rows.

void ExpandAll();
Remarks

The ExpandAll method expands all the CXTPReportRow objects, including all the child rows, that are in the report control.

See Also

CollapseAll, CXTPReportRow::SetExpanded

Group

CXTPReportControl Methods


CXTPReportControl::FocusSubItems Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::FocusSubItems Method

Call this member to specify whether each individual CXTPReportRecordItem will show focus when the item in a row is clicked.

void FocusSubItems(
    BOOL bFocusSubItems
);
Parameters

bFocusSubItems
If TRUE, when a ReportRecordItem is clicked, the entire row will become highlighted except the individual item that was clicked. If FALSE, the entire row will become highlighted when an item is clicked, including the item that was clicked.

See Also

IsFocusSubItems

Body Source
void CXTPReportControl::FocusSubItems(BOOL bFocusSubItems) {
    m_bFocusSubItems = bFocusSubItems;
    m_pFocusedColumn = NULL;
}
Group

CXTPReportControl Methods


CXTPReportControl::FooterRowsAllowAccess Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::FooterRowsAllowAccess Method

Call this member to allow user moving the selection to footer rows.

void FooterRowsAllowAccess(
    BOOL bAllowAccess
);
Parameters

bAllowAccess
TRUE - selection of footer rows is allowed, FALSE otherwise.

See Also

IsFooterRowsAllowAccess

Body Source
void CXTPReportControl::FooterRowsAllowAccess(BOOL bAllowAccess) {
    m_bFooterRowsAllowAccess = bAllowAccess;
}
Group

CXTPReportControl Methods


CXTPReportControl::FooterRowsAllowEdit Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::FooterRowsAllowEdit Method

Call this member to allow the text in all CXTPReportRecordItem(s) to be edited (for footer records only). This will add an edit box to the item where the text can be edited.

void FooterRowsAllowEdit(
    BOOL bAllowEdit
);
Parameters

bAllowEdit
TRUE to add an edit box to the CXTPReportRecordItem(s) so they are editable. FALSE to remove the edit box and not allow them to be edited.

See Also

IsFooterRowsAllowEdit, EditOnClick, IsEditOnClick

Body Source
void CXTPReportControl::FooterRowsAllowEdit(BOOL bAllowEdit) {
    m_bFooterAllowEdit = bAllowEdit;
}
Group

CXTPReportControl Methods


CXTPReportControl::FooterRowsEnableSelection Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::FooterRowsEnableSelection Method

Call this member to enable selection in footer rows.

void FooterRowsEnableSelection(
    BOOL bEnable
);
Parameters

bEnable
TRUE - selection of footer rows is enabled, FALSE otherwise.

See Also

IsFooterRowsSelectionEnabled

Body Source
void CXTPReportControl::FooterRowsEnableSelection(BOOL bEnable) {
    m_bFooterRowsSelectionEnable = bEnable;
}
Group

CXTPReportControl Methods


CXTPReportControl::FreeRowBatchExtraData Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::FreeRowBatchExtraData Method

This member function when rows batch allocation enabled to check all allocated blocks and deallocate which are completely free.

static void FreeRowBatchExtraData();
See Also

UseRowBatchAllocation, CXTPBatchAllocObjT

Group

CXTPReportControl Methods


CXTPReportControl::GetActiveItem Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetActiveItem Method

Call this member to retrieve the currently active item, which is the item that has focus.

CXTPReportRecordItem* GetActiveItem() const;
Returns

A pointer to the currently active(focused) CXTPReportRecordItem.

Body Source
CXTPReportRecordItem* CXTPReportControl::GetActiveItem() const{
    return m_pActiveItem;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetColumns Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetColumns Method

Interface for accessing list columns.

CXTPReportColumns* GetColumns() const;
Returns

The report Columns collection.

Remarks

Use this member function to retrieve an access to the collection of report columns.

See Also

CXTPReportColumns overview

Example
// this function adds a column with "Subject" caption and 250 pixels initial width
void AddSubjectColumn(CXTPReportControl* pReportCtrl)
{
    pReportCtrl->GetColumns()->Add(new CXTPReportColumn(1, _T("Subject"), 250));
}
Body Source
CXTPReportColumns* CXTPReportControl::GetColumns() const{
    return m_pColumns;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetDisableReorderColumnsCount Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetDisableReorderColumnsCount Method

Call this method to retrieve count of the columns at the left side where reordering is disabled.

int GetDisableReorderColumnsCount() const;
Returns

Count of drop-disable columns at the left side.

Body Source
int CXTPReportControl::GetDisableReorderColumnsCount() const {
    return m_nDisableReorderColumnsCount;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetElementRect Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::GetElementRect Method

Call this method to retrieve report element rectangle.

CRect GetElementRect(
    int nElement
) const;
Returns

Report element rectangle.

Group

CXTPReportControl Methods


CXTPReportControl::GetFilterText Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetFilterText Method

Returns the text from the associated filter edit control.

virtual CString GetFilterText();
Returns

Text string entered by user inside filter edit control.

See Also

SetFilterText

Body Source
CString CXTPReportControl::GetFilterText() {
    return m_strFilterText;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetFocusedColumn Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetFocusedColumn Method

Call this member to retrieve a pointer to the currently selected column.

CXTPReportColumn* GetFocusedColumn() const;
Returns

A pointer to the currently selected item.

Body Source
CXTPReportColumn* CXTPReportControl::GetFocusedColumn() const{
    return m_pFocusedColumn;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetFocusedRow Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::GetFocusedRow Method

Retrieves the index of the row that currently has focus in the report control's view.

CXTPReportRow* GetFocusedRow() const;
Returns

Returns pointer to the focused row, or NULL otherwise.

See Also

SetFocusedRow

Group

CXTPReportControl Methods


CXTPReportControl::GetFooterRecords Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetFooterRecords Method

Returns the collection of the footer records.

CXTPReportRecords* GetFooterRecords() const;
Returns

The footer records collection.

Remarks

Call this member function if you want to retrieve an access to the collection of report footer records. You may then perform standard operations on the collection like adding, removing, etc.

See Also

CXTPReportRecords overview, AddRecord

Body Source
CXTPReportRecords* CXTPReportControl::GetFooterRecords() const{
    return m_pFooterRecords;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetFooterRows Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetFooterRows Method

Returns the collection of the report footer rows

CXTPReportRows* GetFooterRows() const;
Returns

The report footer rows collection.

Remarks

Use this member function to retrieve an access to the collection of report footer rows.

Note that rows collection could be rebuilt automatically on executing Populate method.

See Also

CXTPReportRows overview, Populate

Body Source
CXTPReportRows* CXTPReportControl::GetFooterRows() const{
    return m_pFooterRows;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetFooterRowsDividerHeight Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::GetFooterRowsDividerHeight Method

Returns footer divider height.

virtual int GetFooterRowsDividerHeight();
Parameters

pDC
Pointer to the used Device Context.

Returns

The height of the header divider, depending on the chosen footer divider style.

See Also

XTPReportFixedRowsDividerStyle in XTPReportPaintManager.h

Group

CXTPReportControl Methods


CXTPReportControl::GetFooterRowsRect Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetFooterRowsRect Method

Call this method to retrieve footer rows bounding rectangle.

CRect GetFooterRowsRect() const;
Returns

Footer rows bounding rectangle.

Body Source
CRect CXTPReportControl::GetFooterRowsRect() const{
    return m_rcFooterRecordsArea;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetFreezeColumnsCount Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetFreezeColumnsCount Method

Call this method to retrieve count of none-scrolled columns at the left side.

int GetFreezeColumnsCount() const;
Returns

Count of none-scrolled columns at the left side.

Body Source
int CXTPReportControl::GetFreezeColumnsCount() const {
    return m_nFreezeColumnsCount;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetGridStyle Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetGridStyle Method

Returns current grid drawing mode.

XTPReportGridStyle GetGridStyle(
    BOOL bVertical
) const;
Parameters

bVertical
TRUE for vertical grid style, FALSE for horizontal grid style.

Returns

Current grid drawing style.

Remarks

Call this member function if you want to retrieve current grid lines drawing style for the report control.

See Also

XTPReportGridStyle overview, SetGridStyle, SetGridColor

Body Source
XTPReportGridStyle CXTPReportControl::GetGridStyle(BOOL bVertical) const{
    return bVertical ? m_pPaintManager->m_verticalGridStyle : m_pPaintManager->m_horizontalGridStyle;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetHeaderIndent Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::GetHeaderIndent Method

Call this method to retrieve indentation of the header

int GetHeaderIndent() const;
Returns

Header indent.

Group

CXTPReportControl Methods


CXTPReportControl::GetHeaderRecords Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetHeaderRecords Method

Returns the collection of the header records.

CXTPReportRecords* GetHeaderRecords() const;
Returns

The header records collection.

Remarks

Call this member function if you want to retrieve an access to the collection of report header records. You may then perform standard operations on the collection like adding, removing, etc.

See Also

CXTPReportRecords overview, AddRecord

Body Source
CXTPReportRecords* CXTPReportControl::GetHeaderRecords() const{
    return m_pHeaderRecords;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetHeaderRows Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetHeaderRows Method

Returns the collection of the report header rows

CXTPReportRows* GetHeaderRows() const;
Returns

The report header rows collection.

Remarks

Use this member function to retrieve an access to the collection of report header rows, representing current control view.

Note that rows collection could be rebuilt automatically on executing Populate method.

See Also

CXTPReportRows overview, Populate

Body Source
CXTPReportRows* CXTPReportControl::GetHeaderRows() const{
    return m_pHeaderRows;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetHeaderRowsDividerHeight Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::GetHeaderRowsDividerHeight Method

Returns header divider height.

virtual int GetHeaderRowsDividerHeight();
Parameters

pDC
Pointer to the used Device Context.

Returns

The height of the header divider, depending on the chosen header divider style.

See Also

XTPReportFixedRowsDividerStyle in XTPReportPaintManager.h

Group

CXTPReportControl Methods


CXTPReportControl::GetHeaderRowsRect Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetHeaderRowsRect Method

Call this method to retrieve Header records bounding rectangle.

CRect GetHeaderRowsRect() const;
Returns

Header records bounding rectangle.

Body Source
CRect CXTPReportControl::GetHeaderRowsRect() const{
    return m_rcHeaderRecordsArea;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetHScrollStep Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetHScrollStep Method

Use this function to get horizontal scrolling step.

virtual int GetHScrollStep();
Returns

Horizontal scrolling step in pixels.

Body Source
int CXTPReportControl::GetHScrollStep() {
    return m_nHScrollStep;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetImageManager Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetImageManager Method

Call this method to get a pointer to the image manager of Report Control.

CXTPImageManager* GetImageManager() const;
Returns

Pointer to the image manager of Report Control.

See Also

SetImageManager

Body Source
CXTPImageManager* CXTPReportControl::GetImageManager() const{
    return m_pImageManager;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetIndent Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::GetIndent Method

Returns indentation for the tree view row of the specified depth level.

int GetIndent(
    int nLevel
) const;
Parameters

nLevel
Tree depth level.

Returns

Row indentation in pixels.

Remarks

Calculates row indentation in pixels based on the provided indentation level.

See Also

Populate

Group

CXTPReportControl Methods


CXTPReportControl::GetInplaceButtons Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetInplaceButtons Method

Retrieves in-place buttons of report control

CXTPReportInplaceButtons* GetInplaceButtons() const;
Returns

Collection of in-place buttons.

Body Source
CXTPReportInplaceButtons* CXTPReportControl::GetInplaceButtons() const{
    return m_pInplaceButtons;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetInplaceEdit Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetInplaceEdit Method

Retrieves in-place edit pointer

CXTPReportInplaceEdit* GetInplaceEdit() const;
Returns

in-place Pointer to in-place edit control

Body Source
CXTPReportInplaceEdit* CXTPReportControl::GetInplaceEdit() const{
    return m_pInplaceEdit;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetInplaceList Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetInplaceList Method

Retrieves in-place list of report controls

CXTPReportInplaceList* GetInplaceList() const;
Returns

Pointer to in-place list.

Body Source
CXTPReportInplaceList* CXTPReportControl::GetInplaceList() const{
    return m_pInplaceList;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetItemMetrics Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::GetItemMetrics Method

Returns drawing metrics for the row.

virtual void GetItemMetrics(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pItemMetrics
);
Parameters

pDrawArgs
Pointer to the provided draw arguments structure for calculating metrics.
pItemMetrics
Pointer to the metrics structure to fill.

Group

CXTPReportControl Methods


CXTPReportControl::GetLockUpdateCount Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetLockUpdateCount Method

Returns TRUE if control in Update state.

int GetLockUpdateCount() const;
Body Source
int CXTPReportControl::GetLockUpdateCount() const {
    return m_nLockUpdateCount;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetMarkupContext Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::GetMarkupContext Method

Returns markup context

CXTPMarkupContext* GetMarkupContext() const;
Group

CXTPReportControl Methods


CXTPReportControl::GetMouseMode Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetMouseMode Method

Returns the current control mouse mode.

XTPReportMouseMode GetMouseMode() const;
Returns

Current control mouse mode. For available values, see XTPReportMouseMode enum.

See Also

XTPReportMouseMode overview, SetMouseMode

Body Source
XTPReportMouseMode CXTPReportControl::GetMouseMode() const {
    return m_mouseMode;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetNavigator Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetNavigator Method

Returns the control's Navigator.

CXTPReportNavigator* GetNavigator() const;
Returns

Pointer to the navigator object.

Remarks

Call this member function to get the navigator object used for cell navigation.

See Also

CXTPReportNavigator overview

Body Source
CXTPReportNavigator* CXTPReportControl::GetNavigator() const {
    return m_pNavigator;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetPaintManager Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetPaintManager Method

Returns the currently used control's Paint Manager.

CXTPReportPaintManager* GetPaintManager() const;
Returns

Pointer to the paint manager object.

Remarks

Call this member function to get the paint manager object used for drawing a report control window.

See Also

CXTPReportPaintManager overview

Body Source
CXTPReportPaintManager* CXTPReportControl::GetPaintManager() const {
    return m_pPaintManager;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetRecords Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetRecords Method

Returns the collection of the data records.

CXTPReportRecords* GetRecords() const;
Returns

The data records collection.

Remarks

Call this member function if you want to retrieve an access to the collection of report records. You may then perform standard operations on the collection like adding, removing, etc.

See Also

CXTPReportRecords overview, AddRecord

Body Source
CXTPReportRecords* CXTPReportControl::GetRecords() const{
    return m_pRecords;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetReportAreaRows Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::GetReportAreaRows Method

Returns rows from the visible report area.

int GetReportAreaRows(
    int nStartRow,
    BOOL bMoveDown
);
Parameters

nStartRow
Row index to start calculating from.
bMoveDown
Rows moving direction.

Returns

Visible row index starting from.

Remarks

Call this member function if you want to calculate the amount of currently visible rows between nStartRow and the top/bottom of the current view.

See Also

MovePageDown, MovePageUp

Group

CXTPReportControl Methods


CXTPReportControl::GetReportHeader Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetReportHeader Method

Returns a pointer to the associated report header object.

CXTPReportHeader* GetReportHeader() const;
Returns

A pointer to the associated report header.

Remarks

Call this member function if you want to retrieve access to the report header object properties and methods.

See Also

CXTPReportHeader overview

Body Source
CXTPReportHeader* CXTPReportControl::GetReportHeader() const {
    return m_pReportHeader;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetReportRectangle Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetReportRectangle Method

Call this method to retrieve Report bounding rectangle.

CRect GetReportRectangle() const;
Returns

Report bounding rectangle.

Body Source
CRect CXTPReportControl::GetReportRectangle() const{
    return m_rcReportArea;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetRows Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetRows Method

Returns the collection of the report rows

CXTPReportRows* GetRows() const;
Returns

The report rows collection.

Remarks

Use this member function to retrieve an access to the collection of report rows, representing current control view.

Note that rows collection could be rebuilt automatically on executing Populate method.

See Also

CXTPReportRows overview, Populate

Example

See example for CXTPReportControl::BeginUpdate method.

Body Source
CXTPReportRows* CXTPReportControl::GetRows() const{
    return m_pRows;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetRowsHeight Method

CXTPReportControl Methods, CXTPReportControl Class, Example
CXTPReportControl::GetRowsHeight Method

Returns calculated rows height.

virtual int GetRowsHeight(
    CXTPReportRows* pRows,
    int nTotalWidth,
    int nMaxHeight = -1
);
Parameters

nTotalWidth
Width of the row
nMaxHeight
The maximum rows height to stop calculation. Set this parameter as -1 to calculate all rows height.
pDC
Pointer to the used Device Context.

Returns

The height of the default rectangle where row's items will draw.

Example
int nHeaderRowsHeight = GetRowHeight(pDC, pRow)
Group

CXTPReportControl Methods


CXTPReportControl::GetSelectedRows Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetSelectedRows Method

Returns the collection of the selected rows.

CXTPReportSelectedRows* GetSelectedRows() const;
Returns

The selected rows collection.

Remarks

Use this member function to retrieve an access to the collection of currently selected report rows.

See Also

CXTPReportSelectedRows overview.

Body Source
CXTPReportSelectedRows* CXTPReportControl::GetSelectedRows() const{
    return m_pSelectedRows;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetToolTipContext Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Group

CXTPReportControl Methods


CXTPReportControl::GetTopRowIndex Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetTopRowIndex Method

Call this method to retrieve top row index.

long GetTopRowIndex() const;
Returns

Top row index.

See Also

SetTopRow

Body Source
long CXTPReportControl::GetTopRowIndex() const{
    return m_nTopRow;
}
Group

CXTPReportControl Methods


CXTPReportControl::GetWatermarkAlignment Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::GetWatermarkAlignment Method

Call this member to determine current watermark alignment flags.

int GetWatermarkAlignment() const;
Returns

Current watermark alignment.

See Also

XTPReportWatermarkAlignment, SetWatermarkAlignment.

Body Source
int CXTPReportControl::GetWatermarkAlignment() const{
    return m_WatermarkAlignment;
}
Group

CXTPReportControl Methods


CXTPReportControl::HasFocus Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::HasFocus Method

Call this member to determine if the ReportControl has focus.

BOOL HasFocus() const;
Returns

TRUE if the ReportControl has focus, FALSE otherwise.

Group

CXTPReportControl Methods


CXTPReportControl::HeaderRowsAllowAccess Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::HeaderRowsAllowAccess Method

Call this member to allow user moving the selection to header rows.

void HeaderRowsAllowAccess(
    BOOL bAllowAccess
);
Parameters

bAllowAccess
TRUE - selection of header rows is allowed, FALSE otherwise.

See Also

IsHeaderRowsAllowAccess

Body Source
void CXTPReportControl::HeaderRowsAllowAccess(BOOL bAllowAccess) {
    m_bHeaderRowsAllowAccess = bAllowAccess;
}
Group

CXTPReportControl Methods


CXTPReportControl::HeaderRowsAllowEdit Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::HeaderRowsAllowEdit Method

Call this member to allow the text in all CXTPReportRecordItem(s) to be edited (for header records only). This will add an edit box to the item where the text can be edited.

void HeaderRowsAllowEdit(
    BOOL bAllowEdit
);
Parameters

bAllowEdit
TRUE to add an edit box to the CXTPReportRecordItem(s) so they are editable. FALSE to remove the edit box and not allow them to be edited.

See Also

IsHeaderRowsAllowEdit, EditOnClick, IsEditOnClick

Body Source
void CXTPReportControl::HeaderRowsAllowEdit(BOOL bAllowEdit) {
    m_bHeaderAllowEdit = bAllowEdit;
}
Group

CXTPReportControl Methods


CXTPReportControl::HeaderRowsEnableSelection Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::HeaderRowsEnableSelection Method

Call this member to enable selection in header rows.

void HeaderRowsEnableSelection(
    BOOL bEnable
);
Parameters

bEnable
TRUE - selection of header rows is enabled, FALSE otherwise.

See Also

IsHeaderRowsSelectionEnabled

Body Source
void CXTPReportControl::HeaderRowsEnableSelection(BOOL bEnable) {
    m_bHeaderRowsSelectionEnable = bEnable;
}
Group

CXTPReportControl Methods


CXTPReportControl::HitTest Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::HitTest Method

Determines which report row item, if any, is at a specified position.

CXTPReportRow* HitTest(
    CPoint pt
) const;
Parameters

pt
A point to test.

Returns

The row item at the position specified by pt, if any, or NULL otherwise.

Group

CXTPReportControl Methods


CXTPReportControl::InsertRow Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::InsertRow Method

Inserts the specified row at the specified position.

virtual int InsertRow(
    int nIndex,
    CXTPReportRow* pRow
);
Parameters

nIndex
A position to insert row at.
pRow
A row to insert.

Returns

A number of the inserted rows.

Remarks

Inserts the specified row to the rows array at the specified position with all its children expanded. Use _DoExpand() to expand all child items

Group

CXTPReportControl Methods


CXTPReportControl::IsAllowEdit Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsAllowEdit Method

Call this member to determine if the CXTPReportRecordItem(s)are editable.

BOOL IsAllowEdit() const;
Returns

TRUE is the CXTPReportRecordItem(s) are editable, FALSE otherwise.

See Also

AllowEdit, EditOnClick, IsEditOnClick

Body Source
BOOL CXTPReportControl::IsAllowEdit() const{
    return m_bAllowEdit;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsAutoCheckItems Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsAutoCheckItems Method

Call this member to determine id auto check mode for check box items is enabled.

BOOL IsAutoCheckItems() const;
Returns

TRUE if auto check mode is enabled, FALSE if auto check mode is disable.

Remarks

If TRUE is returned, the check box will become checked or unchecked automatically when the user clicks on the check box.

See Also

SetAutoCheckItems, CXTPReportRecordItem::OnClick, CXTPReportRecordItem::OnChar

Body Source
BOOL CXTPReportControl::IsAutoCheckItems() const {
    return m_bAutoCheckItems;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsChanged Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsChanged Method

Returns changed status flag of the control. Used for caching control image drawing.

BOOL IsChanged() const;
Returns

TRUE if the internal control state was changed since last drawing, FALSE otherwise.

Body Source
BOOL CXTPReportControl::IsChanged() const{
    return m_bChanged;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsEditMode Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::IsEditMode Method

Returns TRUE if inplace edit control is active (visible and focused), FALSE otherwise.

virtual BOOL IsEditMode();
See Also

GetInplaceEdit.

Group

CXTPReportControl Methods


CXTPReportControl::IsEditOnClick Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsEditOnClick Method

Call this member to determine whether items are edited with a single-click.

BOOL IsEditOnClick() const;
Returns

TRUE it items can be edited with a single-click, FALSE is a double-click is needed to edit items.

See Also

AllowEdit, IsAllowEdit, EditOnClick

Body Source
BOOL CXTPReportControl::IsEditOnClick() const{
    return m_bEditOnClick;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFilterHiddenColumns Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFilterHiddenColumns Method

Determine if control search filter text in hidden columns too. This option is disabled by default. Returns; TRUE if control search filter text in hidden columns; FALSE otherwise.

virtual BOOL IsFilterHiddenColumns() const;
See Also

SetFilterHiddenColumns, GetFilterText, SetFilterText

Body Source
BOOL CXTPReportControl::IsFilterHiddenColumns() const {
    return m_bFilterHiddenColumns;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFocusSubItems Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFocusSubItems Method

Call this member to determine if individual CXTPReportRecordItem(s) will receive focus when that item in the CXTPReportRow that they belong to is clicked.

BOOL IsFocusSubItems() const;
Returns

TRUE if individual items can receive focus, FALSE if only the entire row can receive focus.

See Also

FocusSubItems

Body Source
BOOL CXTPReportControl::IsFocusSubItems() const{
    return m_bFocusSubItems;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFooterRowsAllowAccess Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFooterRowsAllowAccess Method

Call this member to determine if user can move selection to footer rows.

BOOL IsFooterRowsAllowAccess() const;
Returns

TRUE if user can move selection to footer rows, FALSE otherwise.

See Also

FooterRowsAllowAccess.

Body Source
BOOL CXTPReportControl::IsFooterRowsAllowAccess() const{
    return m_bFooterRowsAllowAccess;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFooterRowsAllowEdit Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFooterRowsAllowEdit Method

Call this member to determine if the CXTPReportRecordItem(s) are editable (for footer records only).

BOOL IsFooterRowsAllowEdit() const;
Returns

TRUE is the CXTPReportRecordItem(s) are editable, FALSE otherwise.

See Also

FooterRowsAllowEdit, EditOnClick, IsEditOnClick

Body Source
BOOL CXTPReportControl::IsFooterRowsAllowEdit() const{
    return m_bFooterAllowEdit;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFooterRowsPinned Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFooterRowsPinned Method

Call this member to determine if footer records are pinned to the body rows.

BOOL IsFooterRowsPinned() const;
Returns

TRUE if footer records are pinned to the body rows. FALSE if footer records are docked to the footer.

See Also

PinFooterRows

Body Source
BOOL CXTPReportControl::IsFooterRowsPinned() const {
    return m_bPinFooterRecords;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFooterRowsSelectionEnabled Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFooterRowsSelectionEnabled Method

Call this member to determine if selection in footer rows is enabled.

BOOL IsFooterRowsSelectionEnabled() const;
Returns

TRUE if selection in footer rows is enabled, FALSE otherwise.

See Also

FooterRowsEnableSelection.

Body Source
BOOL CXTPReportControl::IsFooterRowsSelectionEnabled() const{
    return m_bFooterRowsSelectionEnable;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFooterRowsVisible Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFooterRowsVisible Method

Call this member to determine if footer records are currently visible.

BOOL IsFooterRowsVisible() const;
Returns

TRUE if footer records are visible, FALSE if footer records are hidden.

See Also

ShowFooterRows

Body Source
BOOL CXTPReportControl::IsFooterRowsVisible() const {
    return m_bFooterRecordsVisible;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFooterVisible Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFooterVisible Method

Call this member to determine is column footers are currently visible.

BOOL IsFooterVisible() const;
Returns

TRUE is column footers are visible, FALSE is column footers are hidden.

See Also

ShowHeader

Body Source
BOOL CXTPReportControl::IsFooterVisible()const {
    return m_bFooterVisible;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsFullColumnScrolling Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsFullColumnScrolling Method

Get horizontal scrolling mode.

BOOL IsFullColumnScrolling() const;
Returns

Returns TRUE if horizontal scrolling is by full columns, otherwise horizontal scrolling is by pixels.

See Also

SetFullColumnScrolling

Body Source
BOOL CXTPReportControl::IsFullColumnScrolling() const {
    return m_bFullColumnScrolling;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsGroupByVisible Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsGroupByVisible Method

Returns current Group By area mode.

BOOL IsGroupByVisible() const;
Returns

TRUE when Group By area is shown on the control, when Group By area is hidden.

Remarks

Call this member function if you want to determine whether Group By area in the report header is visible or not.

See Also

ShowGroupBy

Body Source
BOOL CXTPReportControl::IsGroupByVisible() const {
    return m_bGroupByEnabled;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsGroupRowsBold Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsGroupRowsBold Method

Returns current group rows text bold style.

BOOL IsGroupRowsBold() const;
Returns

TRUE when group text are bold, FALSE when it is normal.

Remarks

Call this member function if you want to determine whether group rows' text are bold or normal.

See Also

SetGroupRowsBold, ShadeGroupHeadings, IsShadeGroupHeadingsEnabled, GetItemMetrics

Body Source
BOOL CXTPReportControl::IsGroupRowsBold() const {
    return m_pPaintManager ? m_pPaintManager->m_bGroupRowTextBold : FALSE;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsHeaderRowsAllowAccess Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsHeaderRowsAllowAccess Method

Call this member to determine if user can move selection to header rows.

BOOL IsHeaderRowsAllowAccess() const;
Returns

TRUE if user can move selection to header rows, FALSE otherwise.

See Also

HeaderRowsAllowAccess.

Body Source
BOOL CXTPReportControl::IsHeaderRowsAllowAccess() const{
    return m_bHeaderRowsAllowAccess;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsHeaderRowsAllowEdit Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsHeaderRowsAllowEdit Method

Call this member to determine if the CXTPReportRecordItem(s) are editable (for header records only).

BOOL IsHeaderRowsAllowEdit() const;
Returns

TRUE is the CXTPReportRecordItem(s) are editable, FALSE otherwise.

See Also

HeaderRowsAllowEdit, EditOnClick, IsEditOnClick

Body Source
BOOL CXTPReportControl::IsHeaderRowsAllowEdit() const{
    return m_bHeaderAllowEdit;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsHeaderRowsSelectionEnabled Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsHeaderRowsSelectionEnabled Method

Call this member to determine if selection in header rows is enabled.

BOOL IsHeaderRowsSelectionEnabled() const;
Returns

TRUE if selection in header rows is enabled, FALSE otherwise.

See Also

HeaderRowsEnableSelection.

Body Source
BOOL CXTPReportControl::IsHeaderRowsSelectionEnabled() const{
    return m_bHeaderRowsSelectionEnable;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsHeaderRowsVisible Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsHeaderRowsVisible Method

Call this member to determine if header records are currently visible.

BOOL IsHeaderRowsVisible() const;
Returns

TRUE if header records are visible, FALSE if header records are hidden.

See Also

ShowHeaderRows

Body Source
BOOL CXTPReportControl::IsHeaderRowsVisible() const {
    return m_bHeaderRecordsVisible;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsHeaderVisible Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsHeaderVisible Method

Call this member to determine is column headers are currently visible.

BOOL IsHeaderVisible() const;
Returns

TRUE is column headers are visible, FALSE is column headers are hidden.

See Also

ShowHeader

Body Source
BOOL CXTPReportControl::IsHeaderVisible()const {
    return m_bHeaderVisible;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsLayoutRTL Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::IsLayoutRTL Method

Call this member to get right-to-left mode.

BOOL IsLayoutRTL();
Returns

TRUE if layout is RTL, FALSE - otherwise.

Group

CXTPReportControl Methods


CXTPReportControl::IsMultipleSelection Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsMultipleSelection Method

Determines if the report allows multiple selections.

BOOL IsMultipleSelection() const;
Returns

TRUE if the report allows multiple selections.

See Also

SetMultipleSelection, GetSelectedRows

Body Source
BOOL CXTPReportControl::IsMultipleSelection() const {
    return m_bMultipleSelection;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsMultiSelectionMode Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsMultiSelectionMode Method

Determines if the multiple selection mode is enabled.

BOOL IsMultiSelectionMode() const;
Returns

TRUE if the multiple selection mode is enabled.

See Also

SetMultiSelectionMode

Body Source
BOOL CXTPReportControl::IsMultiSelectionMode() const {
    return m_bMultiSelectionMode;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsPreviewMode Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsPreviewMode Method

Returns current preview mode.

BOOL IsPreviewMode() const;
Returns

TRUE when preview mode is enabled, FALSE when preview mode is disabled.

Remarks

Call this member function if you want to determine whether the row preview item is shown or not.

See Also

EnablePreviewMode

Body Source
BOOL CXTPReportControl::IsPreviewMode() const{
    return m_pPaintManager->IsPreviewMode();
}
Group

CXTPReportControl Methods


CXTPReportControl::IsRowFocusVisible Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsRowFocusVisible Method

Call this member to determine if the row focus is visible.

BOOL IsRowFocusVisible() const;
Returns

TRUE if the the row focus is visible, FALSE otherwise.

See Also

ShowRowFocus

Body Source
BOOL CXTPReportControl::IsRowFocusVisible() const{
    return m_bRowFocusVisible;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsSelectionEnabled Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsSelectionEnabled Method

Call this member to determine if rows selection is enabled.

BOOL IsSelectionEnabled() const;
Returns

TRUE if rows selection is enabled, FALSE otherwise.

See Also

SelectionEnable

Body Source
BOOL CXTPReportControl::IsSelectionEnabled() const{
    return m_bSelectionEnable;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsShadeGroupHeadingsEnabled Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsShadeGroupHeadingsEnabled Method

Returns current group shade mode.

BOOL IsShadeGroupHeadingsEnabled() const;
Returns

TRUE when group items shading is enabled, FALSE when it is disabled.

Remarks

Call this member function if you want to determine whether group rows' headings are enabled or not.

See Also

ShadeGroupHeadings, IsGroupRowsBold, SetGroupRowsBold, GetItemMetrics

Body Source
BOOL CXTPReportControl::IsShadeGroupHeadingsEnabled() const{
    return m_pPaintManager ? m_pPaintManager->m_bShadeGroupHeadings : FALSE;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsSkipGroupsFocusEnabled Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsSkipGroupsFocusEnabled Method

Call this member to determine is groups are skipped when navigating the with the Up and Down arrow keys.

BOOL IsSkipGroupsFocusEnabled() const;
Returns

TRUE if groups are skipped, FALSE is groups receive focus when navigating the report control with the Up and Down arrow keys.

Body Source
BOOL CXTPReportControl::IsSkipGroupsFocusEnabled()const {
    return m_bSkipGroupsFocus;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsSortRecordChilds Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::IsSortRecordChilds Method

Use this function to determine is sort order applied for record children.

virtual BOOL IsSortRecordChilds();
Returns

TRUE if sort order applied for record children, FALSE otherwise.

Body Source
BOOL CXTPReportControl::IsSortRecordChilds() {
    return m_bSortRecordChilds;
}
Group

CXTPReportControl Methods


CXTPReportControl::IsVirtualMode Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::IsVirtualMode Method

Determines if control in virtual mode Returns; TRUE if virtual mode is enabled; FALSE otherwise.

BOOL IsVirtualMode() const;
See Also

IsVirtualMode

Group

CXTPReportControl Methods


CXTPReportControl::OnBeforeCopyToText Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::OnBeforeCopyToText Method

This method is called before add record text data to the clipboard.

virtual BOOL OnBeforeCopyToText(
    CXTPReportRecord* pRecord,
    CStringArray& rarStrings
);
Parameters

pRecord
[in] A pointer to source record;
rarStrings
[in/out] Reference to strings array with record items values. By default this array contains visible items captions.

Returns

TRUE to cancel copying this record to the clipboard in text format, FALSE to continue.

Remarks

If you would like to customize text data for the clipboard you can change rarStrings as you need.

Default implementation sends XTP_NM_REPORT_BEFORE_COPY_TOTEXT notification.

See Also

OnBeforePasteFromText, OnBeforePaste, Cut, Copy, Paste.

Group

CXTPReportControl Methods


CXTPReportControl::OnBeforePaste Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::OnBeforePaste Method

This method is called after creating new record using binary data from the clipboard, but before add it to records collection.

virtual BOOL OnBeforePaste(
    CXTPReportRecord** ppRecord
);
Parameters

ppRecord
[in/out] A pointer to new record pointer;

Returns

TRUE to cancel adding this record, FALSE to continue.

Remarks

If you would like to customize new record created from binary data you may to create new or change provided record using ppRecord parameter.

Default implementation sends XTP_NM_REPORT_BEFORE_PASTE notification.

See Also

OnBeforeCopyToText, OnBeforePasteFromText, Cut, Copy, Paste.

Group

CXTPReportControl Methods


CXTPReportControl::OnBeforePasteFromText Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::OnBeforePasteFromText Method

This method is called before creating new record using text data from the clipboard.

virtual BOOL OnBeforePasteFromText(
    CStringArray& arStrings,
    CXTPReportRecord** ppRecord
);
Parameters

arStrings
[in] Strings array with record items values.
ppRecord
[out] A pointer to new record pointer;

Returns

TRUE to cancel adding this record, FALSE to continue.

Remarks

If you would like to customize creating new record from text data you have to create new record object with record items and fill them using default values and strings provided in arStrings parameter.

If new record will not be set to ppRecord parameter, control will create CXTPReportRecord object with CXTPReportRecordItemVariant items and fill visible items using strings provided in arStrings parameter.

Default implementation sends XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT notification.

See Also

OnBeforeCopyToText, OnBeforePaste, Cut, Copy, Paste.

Group

CXTPReportControl Methods


CXTPReportControl::OnBeginDrag Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::OnBeginDrag Method

This method is called when user start drag row

virtual void OnBeginDrag(
    CPoint point
);
Parameters

point
Drag point

Remarks

Use can override this method or catch LVN_BEGINDRAG message to proceed drag operations.

Group

CXTPReportControl Methods


CXTPReportControl::OnConstraintSelecting Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::OnConstraintSelecting Method

This method is used to notify about changing constraint selection.

virtual BOOL OnConstraintSelecting(
    CXTPReportRow* pRow,
    CXTPReportRecordItem* pItem,
    CXTPReportColumn* pColumn,
    CXTPReportRecordItemConstraint* pConstraint
);
Parameters

pRow
A pointer to current row object;
pItem
A pointer to current record item object;
pColumn
A pointer to current column object;
pConstraint
A pointer to hot selected constraint;

Returns

TRUE if notification successfully sent, FALSE otherwise.

Remarks

Send for every selection change before new selection applied or canceled.

Group

CXTPReportControl Methods


CXTPReportControl::OnDragOver Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::OnDragOver Method

This member is called when an item is dragged over the report control.

virtual DROPEFFECT OnDragOver(
    COleDataObject* pDataObject,
    DWORD dwKeyState,
    CPoint point,
    int nState
);
Parameters

pDataObject
Points to the COleDataObject being dragged over the drop target.
dwKeyState
State of keys on keyboard. Contains the state of the modifier keys. This is a combination of any number of the following: MK_CONTROL, MK_SHIFT, MK_ALT, MK_LBUTTON, MK_MBUTTON, and MK_RBUTTON.
point
The current mouse position relative to the report control.
nState
The transition state (0 - enter, 1 - leave, 2 - over).

Returns

A value from the DROPEFFECT enumerated type, which indicates the type of drop that would occur if the user dropped the object at this position. The type of drop often depends on the current key state as indicated by dwKeyState. A standard mapping of keystates to DROPEFFECT values is:

  • DROPEFFECT_NONE The data object cannot be dropped in this window.
  • DROPEFFECT_COPY for MK_CONTROL Creates a copy of the dropped object.
  • DROPEFFECT_MOVE for MK_ALT Creates a copy of the dropped object and delete the original object. This is typically the default drop effect, when the view can accept the data object.
Group

CXTPReportControl Methods


CXTPReportControl::OnDraw Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::OnDraw Method

Performs all drawing logic.

virtual void OnDraw(
    CDC* pDC
);
Parameters

pDC
Provided DC to draw control image with.

Group

CXTPReportControl Methods


CXTPReportControl::OnDrop Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::OnDrop Method

This member is called when an item has been dropped into the report control.

virtual BOOL OnDrop(
    COleDataObject* pDataObject,
    DROPEFFECT dropEffect,
    CPoint point
);
Parameters

pDataObject
Points to the COleDataObject that is dropped into the drop target.
dropEffect
The drop effect that the user has requested. Can be any of the values listed in the Remarks section.
point
The current mouse position relative to the report control.

Returns

TRUE if the drop was successful, otherwise FALSE.

Remarks

The dropEffect parameter can be one of the following values:

  • DROPEFFECT_COPY Creates a copy of the data object being dropped.
  • DROPEFFECT_MOVE Moves the data object to the current mouse location.
Group

CXTPReportControl Methods


CXTPReportControl::OnFocusChanging Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::OnFocusChanging Method

This member function is called before the focus change

virtual BOOL OnFocusChanging(
    CXTPReportRow* pNewRow,
    CXTPReportColumn* pNewCol
);
Parameters

pNewRow
A pointer to row object which been focused;
pNewCol
A pointer to column object which been focused;

Returns

Returns True if selection changing is OK, False if selection is to be canceled.

Remarks

Before user changes focused row or column, ReportControl sends notification to the parent window by calling OnFocusChanging()

See Also

XTP_NM_REPORT_FOCUS_CHANGING, SendNotifyMessage(), OnFocusChanged

Group

CXTPReportControl Methods


CXTPReportControl::OnGetColumnDataBestFitWidth Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::OnGetColumnDataBestFitWidth Method

This method is used by the report control to calculate BestFit column width.

virtual int OnGetColumnDataBestFitWidth(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Pointer to a column for width calculation.

Returns

BestFit column width (or zero).

Group

CXTPReportControl Methods


CXTPReportControl::OnGetItemsCaptionMaxWidth Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::OnGetItemsCaptionMaxWidth Method

This method is used by the report control to calculate items captions maximum width.

virtual int OnGetItemsCaptionMaxWidth(
    CDC* pDC,
    CXTPReportRows* pRows,
    CXTPReportColumn* pColumn,
    int nStartRow = 0,
    int nRowsCount = -1
);
Parameters

pDC
Pointer to a compatible CDC object.
pRows
Pointer to a rows collection.
pColumn
Pointer to a column for width calculation.
nStartRow
Start row index.
nRowsCount
Rows count.

Returns

Items captions maximum width.

Group

CXTPReportControl Methods


CXTPReportControl::OnGetToolTipInfo Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::OnGetToolTipInfo Method

This method is called to get tooltip text for the item

virtual const XTP_NM_REPORTTOOLTIPINFO& OnGetToolTipInfo(
    CXTPReportRow* pRow,
    CXTPReportRecordItem* pItem,
    CString& rstrToolTipText
);
Parameters

pRow
A pointer to current row object;
pItem
A pointer to current record item object;
rstrToolTipText
A reference to CString object to customize tool tip text. It contains default tool tip text;

Returns

A reference to XTP_NM_REPORTTOOLTIPINFO structure.

Remarks

If rstrToolTipText set to empty - the default tool tip will be shown when not enough space to draw item text. If rstrToolTipText set to single space (" ") no tool tip will be shown.

Group

CXTPReportControl Methods


CXTPReportControl::OnPreviewKeyDown Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::OnPreviewKeyDown Method

This method is called before processing OnKeyDown event.

virtual BOOL OnPreviewKeyDown(
    UINT& rnChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

rnChar
[in/out] A reference to variable which specifies the virtual key code of the given key. For a list of of standard virtual key codes, see Winuser.h.
nRepCnt
[in] Repeat count (the number of times the keystroke is repeated as a result of the user holding down the key).
nFlags
[in] Specifies the scan code, key-transition code, previous key state, and context code.

Returns

TRUE to continue processing key, FALSE to cancel.

Remarks

If you would like to customize keyboard behavior you can change rnChar parameter value or perform your logic and return FALSE to disable default processing.

Default implementation sends XTP_NM_REPORT_PREVIEWKEYDOWN notification.

See Also

OnKeyDown, CWnd::OnKeyDown, XTP_NM_REPORT_PREVIEWKEYDOWN.

Group

CXTPReportControl Methods


CXTPReportControl::OnSelectionChanged Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::OnSelectionChanged Method

This member function is called after a user selects a row or a column

virtual void OnSelectionChanged();
Remarks

After user selects row or column, ReportControl sends notification to the parent window by calling OnSelectionChanged()

See Also

XTP_NM_REPORT_SELCHANGED, SendNotifyMessage()

Group

CXTPReportControl Methods


CXTPReportControl::Paste Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::Paste Method

Reads records from the clipboard and add them to records collection. The Binary data format is used rather than Text format.

virtual void Paste();
See Also

CanCut, CanCopy, CanPaste, Cut, Copy, OnBeforeCopyToText, OnBeforePasteFromText, OnBeforePaste.

Group

CXTPReportControl Methods


CXTPReportControl::PinFooterRows Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::PinFooterRows Method

Call this member to pin footer records to the last body row. By default, footer records are docked to the footer.

void PinFooterRows(
    BOOL bPin = FALSE
);
Parameters

bPin
TRUE is footer records will be displayed immediately after the body rows.

See Also

IsFooterRowsVisible, ShowFooterRows

Body Source
void CXTPReportControl::PinFooterRows(BOOL bPin /*= TRUE*/) {
    m_bPinFooterRecords = bPin;
    AdjustLayout();
    AdjustScrollBars();
}
Group

CXTPReportControl Methods


CXTPReportControl::Populate Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::Populate Method

Performs control population, creating view from the data.

virtual void Populate();
Remarks

Call this member function to populate control's Rows collection with the data containing in Records collection. It automatically creates Tree View references if necessary (for example, in Grouping mode). , it is the main function which should be called for (re)populating all data changes that you have made into the Records collection.

See Also

CXTPReportPaintManager overview

Group

CXTPReportControl Methods


CXTPReportControl::PopulateFooterRows Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::PopulateFooterRows Method

Performs control's footer rows population, creating view from the data.

virtual void PopulateFooterRows();
Remarks

Call this member function to populate control's footer rows collection with the data containing in FooterRecords collection. Useful when main rows are controlled through AddRecordEx/RemoveRecordEx/UpdateRecord methods.

See Also

Populate, PopulateHeaderRows, AddRecordEx, RemoveRecordEx, UpdateRecord

Group

CXTPReportControl Methods


CXTPReportControl::PopulateHeaderRows Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::PopulateHeaderRows Method

Performs control's header rows population, creating view from the data.

virtual void PopulateHeaderRows();
Remarks

Call this member function to populate control's header rows collection with the data containing in HeaderRecords collection. Useful when main rows are controlled through AddRecordEx/RemoveRecordEx/UpdateRecord methods.

See Also

Populate, PopulateFooterRows, AddRecordEx, RemoveRecordEx, UpdateRecord

Group

CXTPReportControl Methods


CXTPReportControl::RedrawControl Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::RedrawControl Method

Initiates report control redrawing.

void RedrawControl();
Remarks

Call this member function if you want to initialize the report control redrawing. The control will be redrawn taking into account its latest state.

See Also

BeginUpdate, EndUpdate

Group

CXTPReportControl Methods


CXTPReportControl::RefreshIndexes Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::RefreshIndexes Method

Recalculates indexes of all rows.

virtual void RefreshIndexes(
    BOOL bAdjustLayout = TRUE,
    BOOL bReverseOrder = FALSE
);
Parameters

bAdjustLayout
If TRUE, layout is adjusted.
bReverseOrder
If TRUE, row indices are updated in reverse order, starting from the last row.

Group

CXTPReportControl Methods


CXTPReportControl::RegisterWindowClass Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::RegisterWindowClass Method

Register the window class if it has not already been registered.

BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

TRUE if the window class was successfully registered.

Group

CXTPReportControl Methods


CXTPReportControl::ReleaseItem Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::ReleaseItem Method

Call this method to remove all items and column in specified position.

void ReleaseItem(
    int nIndex
);
Parameters

nIndex
Index of item to remove.

Group

CXTPReportControl Methods


CXTPReportControl::RemoveRecordEx Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::RemoveRecordEx Method

Removes record with data and associated row. It also remove all children records and their rows.

virtual BOOL RemoveRecordEx(
    CXTPReportRecord* pRecord,
    BOOL bAdjustLayout = TRUE,
    BOOL bRemoveFromParent = TRUE
);
Parameters

pRecord
Pointer to a record object.
bAdjustLayout
If TRUE AdjustLayout will be called.
bRemoveFromParent
If TRUE the record is to be removed from the parent.

Returns

TRUE if operation succeeded, FALSE otherwise.

Remarks

Call this member function if you want to remove record on the fly, without Populate call.

See Also

RemoveRowEx, AddRecordEx, CXTPReportRecords::RemoveRecord, UpdateRecord

Group

CXTPReportControl Methods


CXTPReportControl::RemoveRowEx Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::RemoveRowEx Method

Removes row and associated record. It also remove all children records and rows.

virtual BOOL RemoveRowEx(
    CXTPReportRow* pRow,
    BOOL bAdjustLayout = TRUE
);
Parameters

pRow
Pointer to a row object.
bAdjustLayout
If TRUE AdjustLayout will be called.

Returns

TRUE if operation succeeded, FALSE otherwise.

Remarks

Call this member function if you want to remove row and record on the fly, without Populate call.

See Also

RemoveRecordEx, AddRecordEx, CXTPReportRecords::RemoveRecord, UpdateRecord

Group

CXTPReportControl Methods


CXTPReportControl::ResetContent Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::ResetContent Method

This method deletes all rows and records from Report Control.

void ResetContent(
    BOOL bUpdateControl = TRUE
);
Parameters

bUpdateControl
Set TRUE to redraw control, otherwise FALSE.

Group

CXTPReportControl Methods


CXTPReportControl::ReSortRows Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::ReSortRows Method

ReSorts rows tree corresponding to the sort order taken from columns. Works faster than Populate.

virtual void ReSortRows();
Group

CXTPReportControl Methods


CXTPReportControl::SelectionEnable Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SelectionEnable Method

Call this member to enable rows selection.

void SelectionEnable(
    BOOL bEnable
);
Parameters

bEnable
TRUE to enable rows selection. FALSE to disable rows selection.

See Also

IsSelectionEnabled

Body Source
void CXTPReportControl::SelectionEnable(BOOL bEnable) {
    m_bSelectionEnable = bEnable;
    if(!m_bSelectionEnable)
        m_pSelectedRows->Clear();
}
Group

CXTPReportControl Methods


CXTPReportControl::SendMessageToParent Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::SendMessageToParent Method

Notifies parent control of some event that has happened.

LRESULT SendMessageToParent(
    CXTPReportRow* pRow,
    CXTPReportRecordItem* pItem,
    CXTPReportColumn* pColumn,
    UINT nMessage,
    CPoint* pPoint,
    int nHyperlink = -1
) const;
Parameters

pRow
Specified row of event if used.
pItem
Specified item of event if used.
pColumn
Specified column of event if used.
nMessage
A message to sent to parent window.
pPoint
A point where the message was sent from in client coordinates.
nHyperlink
Hyperlink order number, where the message was sent from (-1 if message was not send from the hyperlink).

Returns

The result of the message processing; its value depends on the message sent. (see CWnd::SendMessage)

Remarks

Sends a message to the parent in the form of a WM_NOTIFY message with a specific structure attached.

See Also

CXTPReportControl overview, SendNotifyMessage

Group

CXTPReportControl Methods


CXTPReportControl::SendNotifyMessage Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::SendNotifyMessage Method

Sends the specified message to the window.

LRESULT SendNotifyMessage(
    UINT nMessage,
    NMHDR* pNMHDR = NULL
) const;
Parameters

nMessage
The message to be sent.
pNMHDR
Notify header

Returns

Nonzero if successful; otherwise returns zero.

Group

CXTPReportControl Methods


CXTPReportControl::SerializeState Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::SerializeState Method

(Re)Stores control configuration to/from the provided archive stream.

virtual void SerializeState(
    CArchive& ar
);
Parameters

ar
Archive stream for serializing.

Group

CXTPReportControl Methods


CXTPReportControl::SetAutoCheckItems Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetAutoCheckItems Method

Call this member to enable auto check mode for check box items.

void SetAutoCheckItems(
    BOOL bAutoCheck
);
Parameters

bAutoCheck
TRUE to enable auto check mode, FALSE to disable auto check mode.

Remarks

When TRUE, the check box will become checked or unchecked automatically when the user clicks on the check box.

See Also

IsAutoCheckItems, CXTPReportRecordItem::OnClick, CXTPReportRecordItem::OnChar

Body Source
void CXTPReportControl::SetAutoCheckItems(BOOL bAutoCheck) {
    m_bAutoCheckItems = bAutoCheck;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetChanged Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetChanged Method

Sets new changed status flag for the control. Used for caching control image drawing.

void SetChanged(
    BOOL bChanged = TRUE
);
Parameters

bChanged
TRUE when something was changed in the control contents and control needs to be republished.

Body Source
void CXTPReportControl::SetChanged(BOOL bChanged) {
    m_bChanged = bChanged;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetDisableReorderColumnsCount Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetDisableReorderColumnsCount Method

Call this method to set count of the columns at the left side where reordering is disabled.

void SetDisableReorderColumnsCount(
    int nCount
);
Parameters

nCount
Count of reorder-disabled columns at the left side.

Body Source
void CXTPReportControl::SetDisableReorderColumnsCount(int nCount) {
    ASSERT(nCount >= 0);
    m_nDisableReorderColumnsCount = nCount;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetFilterHiddenColumns Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetFilterHiddenColumns Method

Call this method to enable or disable search filter text in hidden columns.

virtual void SetFilterHiddenColumns(
    BOOL bFilterHidden
);
Parameters

bFilterHidden
TRUE to search filter text in hidden columns; FALSE to search in visible columns only.

Remarks

This option is disabled by default. You must call Populate method to update rows.

See Also

IsFilterHiddenColumns, GetFilterText, SetFilterText, Populate

Body Source
void CXTPReportControl::SetFilterHiddenColumns(BOOL bFilterHidden) {
    m_bFilterHiddenColumns = bFilterHidden;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetFilterText Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetFilterText Method

Call this method to set new filter for control.

virtual void SetFilterText(
    LPCTSTR strFilterText
);
Parameters

strFilterText
Filter text to be applied for control.

Remarks

You must call Populate method to update rows.

See Also

GetFilterText, Populate

Body Source
void CXTPReportControl::SetFilterText(LPCTSTR strFilterText) {
    m_strFilterText = strFilterText;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetFocusedColumn Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::SetFocusedColumn Method

Call this member to set selected column.

BOOL SetFocusedColumn(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
column to be selected.

Returns

TRUE if specified column has been focused, FALSE otherwise.

Group

CXTPReportControl Methods


SetFocusedRow Method

CXTPReportControl Methods
SetFocusedRow Method
Overload List
Methods
Method | Description
CXTPReportControl::SetFocusedRow (CXTPReportRow*, BOOL) | Makes the provided row as currently focused.
CXTPReportControl::SetFocusedRow (CXTPReportRow*, BOOL, BOOL) | Makes the provided row as currently focused.
Group

CXTPReportControl Methods


CXTPReportControl::SetFocusedRow Method (CXTPReportRow*, BOOL)

SetFocusedRow Method, CXTPReportControl Class, See Also
CXTPReportControl::SetFocusedRow Method (CXTPReportRow*, BOOL)

Makes the provided row as currently focused.

BOOL SetFocusedRow(
    CXTPReportRow* pRow,
    BOOL bIgnoreSelection = FALSE
);
BOOL SetFocusedRow(
    CXTPReportRow* pRow,
    BOOL bSelectBlock,
    BOOL bIgnoreSelection
);
Parameters

pRow
The row to set as focused to.
bIgnoreSelection
TRUE if select new focused row.
bSelectBlock
TRUE when selecting rows up to new focused row, FALSE otherwise.

Returns

TRUE if specified row has been focused, FALSE otherwise.

See Also

GetFocusedRow

Group

SetFocusedRow Method


CXTPReportControl::SetFreezeColumnsCount Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetFreezeColumnsCount Method

Call this method to set count of none-scrolled columns at the left side.

void SetFreezeColumnsCount(
    int nCount
);
Parameters

nCount
Count of none-scrolled columns at the left side.

Body Source
void CXTPReportControl::SetFreezeColumnsCount(int nCount) {
    ASSERT(nCount >= 0);
    m_nFreezeColumnsCount = nCount;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetFullColumnScrolling Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::SetFullColumnScrolling Method

Set horizontal scrolling mode.

void SetFullColumnScrolling(
    BOOL bSet
);
Parameters

bSet
If TRUE full columns scrolling mode is set, if FALSE horizontal scrolling by pixels mode is set.

See Also

IsFullColumnScrolling

Group

CXTPReportControl Methods


CXTPReportControl::SetGridColor Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetGridColor Method

Change color of GridLines.

COLORREF SetGridColor(
    COLORREF clrGridLine
);
Parameters

clrGridLine
New Grid Lines color.

Returns

Old Grid Lines color.

Remarks

Call this member function if you want to change a color of report control grid lines.

See Also

SetGridStyle, GetGridStyle

Body Source
COLORREF CXTPReportControl::SetGridColor(COLORREF clrGridLine) {
    return m_pPaintManager->SetGridColor(clrGridLine);
}
Group

CXTPReportControl Methods


CXTPReportControl::SetGridStyle Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetGridStyle Method

Set or clear grid drawing style.

void SetGridStyle(
    BOOL bVertical,
    XTPReportGridStyle gridStyle
);
Parameters

bVertical
TRUE for changing vertical grid style, FALSE for changing horizontal grid style.
gridStyle
New grid style. Can be any of the values listed in the Remarks section.

Remarks

Call this member function if you want to change a style of report grid lines.

Possible grid line styles are the following:

  • xtpReportGridNoLines Empty line
  • xtpReportGridSmallDots Line is drawn with small dots
  • xtpReportGridLargeDots Line is drawn with large dots
  • xtpReportGridDashes Line is drawn with dashes
  • xtpReportGridSolid Draws solid line
See Also

XTPReportGridStyle overview, GetGridStyle, SetGridColor

Body Source
void CXTPReportControl::SetGridStyle(BOOL bVertical, XTPReportGridStyle gridStyle) {
    m_pPaintManager->SetGridStyle(bVertical, gridStyle);
    AdjustScrollBars();
}
Group

CXTPReportControl Methods


CXTPReportControl::SetGroupRowsBold Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetGroupRowsBold Method

Set group rows text style: bold or normal.

void SetGroupRowsBold(
    BOOL bBold = TRUE
);
Parameters

bBold
TRUE for bold text style, FALSE for normal.

Remarks

Call this member function if you want to change group rows bold text style.

See Also

IsGroupRowsBold, ShadeGroupHeadings, IsShadeGroupHeadingsEnabled, GetItemMetrics

Body Source
void CXTPReportControl::SetGroupRowsBold(BOOL bBold) {
    if (m_pPaintManager)
        m_pPaintManager->m_bGroupRowTextBold = bBold;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetHScrollStep Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetHScrollStep Method

Use this function to set horizontal scrolling step.

virtual void SetHScrollStep(
    int nStep
);
Parameters

nStep
Horizontal scrolling step in pixels.

Body Source
void CXTPReportControl::SetHScrollStep(int nStep) {
    ASSERT(nStep > 0);
    m_nHScrollStep = max(1, nStep);
}
Group

CXTPReportControl Methods


CXTPReportControl::SetImageList Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetImageList Method

Initiates ImageList of Paint Manager.

void SetImageList(
    CImageList* pImageList
);
Parameters

pImageList
Image list.

Remarks

You use this function to set up your own ImageList with set bitmaps that represent various states of rows and depict any other information.

Notes

Recommended to use SetImageManager/GetImageManager methods instead.

See Also

GetImageManager

Example
CImageList listIcons;
listIcons.Create(16, 16, ILC_COLOR24 | ILC_MASK, 0, 1));
CBitmap bmp;
// load bitmap by id
bmp.LoadBitmap(IDB_BMREPORT);
ilIcons.Add(&bmp, RGB(255, 0, 255));
m_wndReport.SetImageList(&lIcons);
Group

CXTPReportControl Methods


CXTPReportControl::SetImageManager Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetImageManager Method

Call this method to set new image manager.

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Image manager to be set

See Also

GetImageManager

Example
CXTPImageManager* pImageManager = new CXTPImageManager();
pImageManager->SetIcons(IDR_MAINFRAME);
m_wndReport.SetImageManager(pImageManager);
Group

CXTPReportControl Methods


CXTPReportControl::SetLayoutRTL Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::SetLayoutRTL Method

Call this member to set right-to-left mode.

void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPReportControl Methods


CXTPReportControl::SetLeftOffset Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::SetLeftOffset Method

Call this method to set horizontal scroll position.

void SetLeftOffset(
    int nOffset
);
Parameters

nOffset
Horizontal scroll position.

Remarks

This method takes effect only if auto column sizing is disable

See Also

CXTPReportHeader::SetAutoColumnSizing

Group

CXTPReportControl Methods


CXTPReportControl::SetMouseMode Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::SetMouseMode Method

Sets new operational control mouse mode.

void SetMouseMode(
    XTPReportMouseMode nMode
);
Parameters

nMode
New mouse mode. For available values, see XTPReportMouseMode enum.

See Also

XTPReportMouseMode overview, GetMouseMode

Group

CXTPReportControl Methods


CXTPReportControl::SetMultipleSelection Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetMultipleSelection Method

Changes allowing multiple selections for the control.

void SetMultipleSelection(
    BOOL bMultipleSelection
);
Parameters

bMultipleSelection
TRUE for enabling, FALSE for disabling.

Remarks

Sets the flag that determines whether the report allows multiple selections.

See Also

IsMultipleSelection, GetSelectedRows

Body Source
void CXTPReportControl::SetMultipleSelection(BOOL bMultipleSelection) {
    m_bMultipleSelection = bMultipleSelection;
    SetFocusedRow(GetFocusedRow());
}
Group

CXTPReportControl Methods


CXTPReportControl::SetMultiSelectionMode Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetMultiSelectionMode Method

Enables/disables the multiple selection mode for the control.

void SetMultiSelectionMode(
    BOOL bMultiSelectionMode
);
Parameters

bMultiSelectionMode
TRUE for enabling, FALSE for disabling.

Remarks

Sets the flag that determines whether the report is in multiple selection mode.

See Also

IsMultiSelectionMode

Body Source
void CXTPReportControl::SetMultiSelectionMode(BOOL bMultiSelectionMode) {
    m_bMultiSelectionMode = bMultiSelectionMode;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetPaintManager Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::SetPaintManager Method

Call this method to set custom paint manager.

void SetPaintManager(
    CXTPReportPaintManager* pPaintManager
);
Parameters

pPaintManager
A pointer to the custom paint manager.

Group

CXTPReportControl Methods


CXTPReportControl::SetReportHeader Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetReportHeader Method

Call this member to change report header of Report Control

void SetReportHeader(
    CXTPReportHeader* pReportHeader
);
Parameters

pReportHeader
Report header to be set

See Also

CXTPReportHeader overview

Example
m_wndReport.SetReportHeader(new CMyReportHeader());
Group

CXTPReportControl Methods


CXTPReportControl::SetRowsCompareFunc Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetRowsCompareFunc Method

Set compare function to sort.

virtual void SetRowsCompareFunc(
    CXTPReportRows::T_CompareFunc pCompareFunc
);
Parameters

pCompareFunc
A T_CompareFunc function pointer that is used to compare rows or NULL to use the default one.

Remarks

This method uses Visual C++ run-time library (MSVCRT) implementation of the quick-sort function, qsort, for sorting stored CXTPReportRow objects. If pCompareFunc = NULL the default compare function is used. Call Populate() method to resort items.

See Also

SortRows, CXTPReportRows::SortEx, CXTPReportRows::Sort, CXTPReportRows::T_CompareFunc

Body Source
void CXTPReportControl::SetRowsCompareFunc(CXTPReportRows::T_CompareFunc pCompareFunc) {
    m_pRowsCompareFunc = pCompareFunc;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetSortRecordChilds Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetSortRecordChilds Method

Call this method to apply sort order for record children

virtual void SetSortRecordChilds(
    BOOL bSortRecordChilds
);
Parameters

bSortRecordChilds
TRUE to sort record children.

Body Source
void CXTPReportControl::SetSortRecordChilds(BOOL bSortRecordChilds) {
    m_bSortRecordChilds = bSortRecordChilds;
}
Group

CXTPReportControl Methods


CXTPReportControl::SetTopRow Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::SetTopRow Method

Force provided row to the top.

void SetTopRow(
    int nIndex
);
Parameters

nIndex
An index of the row to force.

Remarks

The system scrolls the report control view until either the item specified by nIndex appears at the top of the view the maximum scroll range has been reached.

See Also

GetReportAreaRows, EnsureVisible

Group

CXTPReportControl Methods


CXTPReportControl::SetTreeIndent Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::SetTreeIndent Method

Call this member to specifies the indentation placed before the text of each child node in a hierarchical tree structure.

void SetTreeIndent(
    int nIndent
);
Parameters

nIndent
Indentation used when displaying child nodes.

Group

CXTPReportControl Methods


CXTPReportControl::SetVirtualMode Method

CXTPReportControl Methods, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetVirtualMode Method

Call this method to enable virtual mode of the control

void SetVirtualMode(
    CXTPReportRecord* pVirtualRecord,
    int nCount
);
Parameters

pVirtualRecord
record to be used as virtual for all rows.
nCount
Count of virtual records.

See Also

IsVirtualMode

Example
class CVirtualRecord : public CXTPReportRecord
{
public:
    CVirtualRecord()
    {
        AddItem(new CXTPReportRecordItem());
        AddItem(new CXTPReportRecordItem());
        AddItem(new CXTPReportRecordItem());
    }

    void GetItemMetrics (XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs, XTP_REPORTRECORDITEM_METRICS* pItemMetrics)
    {
        // Draw virtual record
    }
}
...
m_wndReport.SetVirtualMode(new CVirtualRecord(), 540);
Group

CXTPReportControl Methods


CXTPReportControl::SetWatermarkAlignment Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SetWatermarkAlignment Method

Call this member to set watermark alignment flags.

void SetWatermarkAlignment(
    int nWatermarkAlignment
);
Parameters

nWatermarkAlignment
watermark alignment flags.

See Also

XTPReportWatermarkAlignment, GetWatermarkAlignment.

Body Source
void CXTPReportControl::SetWatermarkAlignment(int nWatermarkAlignment) {
    m_WatermarkAlignment = (XTPReportWatermarkAlignment)nWatermarkAlignment;
}
Group

CXTPReportControl Methods


SetWatermarkBitmap Method

CXTPReportControl Methods
SetWatermarkBitmap Method
Overload List
Methods
Method | Description
CXTPReportControl::SetWatermarkBitmap (HBITMAP, BYTE) | Sets a watermark bitmap to be shown in the report control background.
CXTPReportControl::SetWatermarkBitmap (LPCTSTR, BYTE) |
Group

CXTPReportControl Methods


CXTPReportControl::SetWatermarkBitmap Method (HBITMAP, BYTE)

SetWatermarkBitmap Method, CXTPReportControl Class
CXTPReportControl::SetWatermarkBitmap Method (HBITMAP, BYTE)

Sets a watermark bitmap to be shown in the report control background.

virtual BOOL SetWatermarkBitmap(
    HBITMAP hBitmap,
    BYTE Transparency
);
Parameters

hBitmap
bitmap handle.
Transparency
transparency value.
szPath
path to bitmap file.

Returns

TRUE if watermark bitmap successfully added or removed, FALSE otherwise.

Group

SetWatermarkBitmap Method


CXTPReportControl::SetWatermarkBitmap Method (LPCTSTR, BYTE)

SetWatermarkBitmap Method, CXTPReportControl Class
CXTPReportControl::SetWatermarkBitmap Method (LPCTSTR, BYTE)
virtual BOOL SetWatermarkBitmap(
    LPCTSTR szPath,
    BYTE Transparency
);
Group

SetWatermarkBitmap Method


CXTPReportControl::ShadeGroupHeadings Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::ShadeGroupHeadings Method

Enable/disable group shade.

void ShadeGroupHeadings(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE for enabling group items shade, FALSE for disabling.

Remarks

Call this member function if you want to hide or show group rows' headings.

See Also

IsShadeGroupHeadingsEnabled, IsGroupRowsBold, SetGroupRowsBold, GetItemMetrics

Body Source
void CXTPReportControl::ShadeGroupHeadings(BOOL bEnable) {
    if (m_pPaintManager)
        m_pPaintManager->m_bShadeGroupHeadings = bEnable;
    AdjustScrollBars();
}
Group

CXTPReportControl Methods


CXTPReportControl::ShowFooter Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::ShowFooter Method

Call this member to hide/show report footers.

void ShowFooter(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE is column footers will be displayed, FALSE to hide column footers.

See Also

IsFooterVisible, ShowHeader

Body Source
void CXTPReportControl::ShowFooter(BOOL bShow /*= TRUE*/) {
    m_bFooterVisible = bShow;
    AdjustLayout();
    AdjustScrollBars();
}
Group

CXTPReportControl Methods


CXTPReportControl::ShowFooterRows Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::ShowFooterRows Method

Call this member to hide/show footer records.

void ShowFooterRows(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE is footer records will be displayed, FALSE to hide footer records.

See Also

IsFooterRowsVisible, ShowHeaderRows

Body Source
void CXTPReportControl::ShowFooterRows(BOOL bShow /*= TRUE*/) {
    m_bFooterRecordsVisible = bShow;

    if(!bShow)
        GetNavigator()->SetCurrentFocusInFootersRows(FALSE);

    AdjustLayout();
    AdjustScrollBars();
}
Group

CXTPReportControl Methods


CXTPReportControl::ShowGroupBy Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::ShowGroupBy Method

Shows/hides Group By control area.

void ShowGroupBy(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE for showing GroupBy area, FALSE for hiding GroupBy area.

Remarks

Call this member function if you want to hide or show Group By area in the report header.

See Also

IsGroupByVisible

Body Source
void CXTPReportControl::ShowGroupBy(BOOL bEnable) {
    ASSERT(!IsVirtualMode());
    m_bGroupByEnabled = bEnable;
    AdjustLayout();
    AdjustScrollBars();
}
Group

CXTPReportControl Methods


CXTPReportControl::ShowHeader Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::ShowHeader Method

Call this member to hide/show column headers.

void ShowHeader(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE is column headers will be displayed, FALSE to hide column headers.

See Also

IsHeaderVisible, ShowFooter

Body Source
void CXTPReportControl::ShowHeader(BOOL bShow /*= TRUE*/) {
    m_bHeaderVisible = bShow;
    AdjustLayout();
    AdjustScrollBars();
}
Group

CXTPReportControl Methods


CXTPReportControl::ShowHeaderRows Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::ShowHeaderRows Method

Call this member to hide/show header records.

void ShowHeaderRows(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE is header records will be displayed, FALSE to hide header records.

See Also

IsHeaderRowsVisible, ShowFooterRows

Body Source
void CXTPReportControl::ShowHeaderRows(BOOL bShow /*= TRUE*/) {
    m_bHeaderRecordsVisible = bShow;

    if(!bShow)
        GetNavigator()->SetCurrentFocusInHeadersRows(FALSE);

    AdjustLayout();
    AdjustScrollBars();
}
Group

CXTPReportControl Methods


CXTPReportControl::ShowRowFocus Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::ShowRowFocus Method

Call this member to enable showing the row focus.

void ShowRowFocus(
    BOOL bShow
);
Parameters

bEnable
TRUE to enable showing the row focus. FALSE to disable showing the row focus.

See Also

IsRowFocusVisible

Body Source
void CXTPReportControl::ShowRowFocus(BOOL bShow) {
    m_bRowFocusVisible = bShow;
}
Group

CXTPReportControl Methods


CXTPReportControl::SkipGroupsFocus Method

CXTPReportControl Methods, CXTPReportControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::SkipGroupsFocus Method

Call this member to specify whether groups are skipped when navigating the ReportControl with the Up and Down keys.

void SkipGroupsFocus(
    BOOL bSkipFocus
);
Parameters

bSkipFocus
If TRUE, when navigating the rows with the Up and Down keys in the ReportControl the group headings will be skipped and the next non-group heading row will be selected. If FALSE, when navigating the rows with the Up and Down keys in the ReportControlall rows will be selected, even group headings.

Body Source
void CXTPReportControl::SkipGroupsFocus(BOOL bSkipFocus) {
    m_bSkipGroupsFocus = bSkipFocus;
}
Group

CXTPReportControl Methods


CXTPReportControl::SortRows Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::SortRows Method

Sorts rows corresponding to the sort order taken from columns.

virtual void SortRows(
    CXTPReportRows* pRows
);
Parameters

pRows
A rows collection to sort.

Group

CXTPReportControl Methods


CXTPReportControl::SortTree Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::SortTree Method

Sorts rows tree corresponding to the sort order taken from columns.

virtual void SortTree(
    CXTPReportRows* pTree
);
Parameters

pTree
A rows tree collection to sort.

Group

CXTPReportControl Methods


CXTPReportControl::UpdateRecord Method

CXTPReportControl Methods, CXTPReportControl Class, See Also
CXTPReportControl::UpdateRecord Method

Updates record.

virtual void UpdateRecord(
    CXTPReportRecord* pRecord,
    BOOL bUpdateChildren
);
Parameters

pRecord
Record data with items.
bUpdateChildren
If TRUE the children will be updated as well.

Remarks

Call this member function if you modified a record and want it to be updated accordingly to the current grouping and sorting.

See Also

CXTPReportRecord overview, GetRecords

Group

CXTPReportControl Methods


CXTPReportControl::UpdateSubList Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::UpdateSubList Method

Update field chooser control with its content.

void UpdateSubList();
Group

CXTPReportControl Methods


CXTPReportControl::UseReportCustomHeap Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::UseReportCustomHeap Method

Call this function to use custom heap feature.

static BOOL UseReportCustomHeap();
Returns

TRUE if custom heap feature is enabled for all report allocators, FALSE otherwise.

Remarks

If it is enabled, report data will be allocated in custom (separate) heap instead of standard application heap. This optimize memory using (fragmentation) for big amount of data. For custom heap used for classes derived from CXTPHeapObjectT template, like CXTPReportRecord, CXTPReportRecordItem, CXTPReportRow and so others. This template just overrides operators new and delete.

It must be called on initialization before any allocations of classes which use custom heap. OnInitInstance is a fine place for this.

Group

CXTPReportControl Methods


CXTPReportControl::UseRowBatchAllocation Method

CXTPReportControl Methods, CXTPReportControl Class
CXTPReportControl::UseRowBatchAllocation Method

Call this function to enable batch allocation feature for report rows.

static BOOL UseRowBatchAllocation();
Returns

TRUE if batch allocation feature is enabled for report rows, FALSE otherwise.

Remarks

Batch allocation means that memory allocated not for one object only, but for many objects at one time (for 1024 objects by default). Next allocations take memory from this big block. New blocks allocated when necessary. This increase performance and reduce heap fragmentation. Batch allocation mechanism responsible for allocation/deallocation blocks of memory from heap and internally organize free/busy lists of memory pieces. When object deleted, its memory stored in free list and used for new objects. When all memory pieces from block free, it may be deallocated from heap automatically (this depends on options in _TBatchAllocData) or by FreeExtraData call,

It must be called on initialization before any allocations of classes which use batch allocation. OnInitInstance is a fine place for this.

Group

CXTPReportControl Methods


CXTPReportControl Constructors

CXTPReportControl Class, Legend, Public Methods
CXTPReportControl Constructors
Class

CXTPReportControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportControl | Constructs a CXTPReportControl object.


CXTPReportControl::CXTPReportControl Constructor

CXTPReportControl Constructors, CXTPReportControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControl::CXTPReportControl Constructor

Constructs a CXTPReportControl object.

CXTPReportControl();
Remarks

You construct a CXTPReportControl object in two steps. First, call the constructor CXTPReportControl and then call Create method, which initializes the window.

See Also

Create

Example
// Declare a local CXTPReportControl object.
CXTPReportControl myReport;

// Declare a dynamic CXTPReportControl object.
CXTPReportControl* pMyReport = new CXTPReportControl();

if (!myReport.Create(WS_CHILD | WS_TABSTOP | WS_VISIBLE | WM_VSCROLL, CRect(0, 0, 0, 0), this, ID_REPORT_CONTROL))
{
    TRACE(_T("Failed to create view windown"));
}
Group

CXTPReportControl Constructors


CXTPReportControl Destructors

CXTPReportControl Class, Legend, Public Methods
CXTPReportControl Destructors
Class

CXTPReportControl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportControl | Destroys a CXTPReportControl object, handles cleanup and deallocation.


CXTPReportControl::~CXTPReportControl Destructor

CXTPReportControl Destructors, CXTPReportControl Class
CXTPReportControl::~CXTPReportControl Destructor

Destroys a CXTPReportControl object, handles cleanup and deallocation.

virtual ~CXTPReportControl();
Group

CXTPReportControl Destructors


CXTPReportControlLocale Class

XTPReportControl.h, Classes, Legend, Members, Topics, CXTPReportControlLocale Methods, CXTPReportControlLocale Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControlLocale Class

Helper class with static member functions to control active locale for Report Control and perform some locale dependent tasks.

Class Hierarchy

class CXTPReportControlLocale;
File

XTPReportControl.h

Group

Classes

Legend
Method
CXTPReportControlLocale Methods
CXTPReportControlLocale Methods | Description
FormatDateTime | Format a string using strftime() function format specifiers. The active locale ID is used.
GetActiveLCID | Returns active locale ID (current user locale or resource file locale)
IsUseResourceFileLocale | Determine which locale is used active locale: current user locale or resource file locale.
SetUseResourceFileLocale | Used to set which locale is used active locale: current user locale or resource file locale.
VariantChangeTypeEx | Use to change VARIANT type using active locale ID.


CXTPReportControlLocale Methods

CXTPReportControlLocale Class, Legend, Public Methods
CXTPReportControlLocale Methods
Class

CXTPReportControlLocale Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
FormatDateTime | Format a string using strftime() function format specifiers. The active locale ID is used.
GetActiveLCID | Returns active locale ID (current user locale or resource file locale)
IsUseResourceFileLocale | Determine which locale is used active locale: current user locale or resource file locale.
SetUseResourceFileLocale | Used to set which locale is used active locale: current user locale or resource file locale.
VariantChangeTypeEx | Use to change VARIANT type using active locale ID.


CXTPReportControlLocale::FormatDateTime Method

CXTPReportControlLocale Methods, CXTPReportControlLocale Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControlLocale::FormatDateTime Method

Format a string using strftime() function format specifiers. The active locale ID is used.

static CString FormatDateTime(
    const COleDateTime& dt,
    LPCTSTR lpcszFormatString
);
Parameters

dt
[in] A COleDateTime object with date and time value to format.
lpcszFormatString
[in] Format-control string.

Returns

A string which contains date-time formatted using active locale ID.

See Also

GetActiveLCID, strftime

Group

CXTPReportControlLocale Methods


CXTPReportControlLocale::GetActiveLCID Method

CXTPReportControlLocale Methods, CXTPReportControlLocale Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControlLocale::GetActiveLCID Method

Returns active locale ID (current user locale or resource file locale)

static LCID GetActiveLCID();
Returns

LOCALE_USER_DEFAULT or resource file locale ID.

See Also

IsUseResourceFileLocale, SetUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, LOCALE_USER_DEFAULT

Group

CXTPReportControlLocale Methods


CXTPReportControlLocale::IsUseResourceFileLocale Method

CXTPReportControlLocale Methods, CXTPReportControlLocale Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControlLocale::IsUseResourceFileLocale Method

Determine which locale is used active locale: current user locale or resource file locale.

static BOOL IsUseResourceFileLocale();
Returns

TRUE if resource file locale is used active locale, FALSE otherwise.

See Also

SetUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, GetActiveLCID, LOCALE_USER_DEFAULT

Group

CXTPReportControlLocale Methods


CXTPReportControlLocale::SetUseResourceFileLocale Method

CXTPReportControlLocale Methods, CXTPReportControlLocale Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControlLocale::SetUseResourceFileLocale Method

Used to set which locale is used active locale: current user locale or resource file locale.

static void SetUseResourceFileLocale(
    BOOL bUseResourceFileLocale
);
Parameters

bUseResourceFileLocale
If TRUE resource file locale will be used, if FALSE current user locale will be used.

See Also

IsUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, GetActiveLCID, LOCALE_USER_DEFAULT

Group

CXTPReportControlLocale Methods


CXTPReportControlLocale::VariantChangeTypeEx Method

CXTPReportControlLocale Methods, CXTPReportControlLocale Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportControlLocale::VariantChangeTypeEx Method

Use to change VARIANT type using active locale ID.

static BOOL VariantChangeTypeEx(
    VARIANT& rVarValue,
    VARTYPE vartype,
    BOOL bThrowError = TRUE
);
Parameters

rVarValue
[in, out] Reference to VARIANT value to change type.
vartype
[in] new variant type.
bThrowError
[in] if FALSE function returns TRUE or FALSE, if TRUE function throw exception in case of error.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetActiveLCID, ::VariantChangeTypeEx API function.

Group

CXTPReportControlLocale Methods


CXTPReportFilterEditControl Class

XTPReportFilterEditControl.h, Classes, Legend, Members, Topics, CXTPReportFilterEditControl Data Members, CXTPReportFilterEditControl Methods, CXTPReportFilterEditControl Constructors, CXTPReportFilterEditControl Destructors, CXTPReportFilterEditControl Constructors, CXTPReportFilterEditControl Data Members, CXTPReportFilterEditControl Destructors, CXTPReportFilterEditControl Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl Class

The CXTPReportFilterEditControl class provides the functionality of the filter string edit control, associated to the main Report control window.

Class Hierarchy

class CXTPReportFilterEditControl : public CEdit;
File

XTPReportFilterEditControl.h

Remarks

It has all the functionality of the CEdit control, as well as some specific additions.

This control should be instantiated in the user's application. To use a field chooser in an existing dialog box of your application, add a standard list box to your dialog template using the dialog editor and then initialize your CXTPReportSubListControl object inside dialog OnInitialUpdate handler. See example below:

// CXTPReportFilterEditControl wndFilter;
wndFilter.SubclassDlgItem(IDC_FILTEREDIT, &pFilterDialog);
// CXTPReportControl wndReport;
wndReport.GetColumns()->GetReportHeader()->SetFilterEditCtrl(&wndFilter);
See Also

CEdit, CXTPReportHeader::SetFilterEditCtrl

Group

Classes

Legend
Data Member
protected
Method
CXTPReportFilterEditControl Constructors
CXTPReportFilterEditControl Constructors | Description
CXTPReportFilterEditControl | Constructs a CXTPReportFilterEditControl object.
CXTPReportFilterEditControl Data Members
CXTPReportFilterEditControl Data Members | Description
m_pReportCtrl | Pointer to the main report control.
m_strHint | Grayed-out text displayed in the edit control to show a helpful description like "Enter filter text here".
CXTPReportFilterEditControl Destructors
CXTPReportFilterEditControl Destructors | Description
~CXTPReportFilterEditControl | Destroys CXTPReportFilterEditControl object, handles its cleanup.
CXTPReportFilterEditControl Methods
CXTPReportFilterEditControl Methods | Description
GetHint | Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
GetReportCtrl | Returns a pointer to the associated report control.
GetText | Call this member to get the edit text.
SetHint | Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
SetReportCtrl | Sets the associated report control.
SetText | Call this member to set the edit control text.


CXTPReportFilterEditControl Data Members

CXTPReportFilterEditControl Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl Data Members
Class

CXTPReportFilterEditControl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pReportCtrl | Pointer to the main report control.
m_strHint | Grayed-out text displayed in the edit control to show a helpful description like "Enter filter text here".


CXTPReportFilterEditControl::m_pReportCtrl Data Member

CXTPReportFilterEditControl Data Members, CXTPReportFilterEditControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::m_pReportCtrl Data Member

Pointer to the main report control.

CXTPReportControl* m_pReportCtrl;
Group

CXTPReportFilterEditControl Data Members


CXTPReportFilterEditControl::m_strHint Data Member

CXTPReportFilterEditControl Data Members, CXTPReportFilterEditControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::m_strHint Data Member

Grayed-out text displayed in the edit control to show a helpful description like "Enter filter text here".

CString m_strHint;
Group

CXTPReportFilterEditControl Data Members


CXTPReportFilterEditControl Methods

CXTPReportFilterEditControl Class, Legend, Public Methods
CXTPReportFilterEditControl Methods
Class

CXTPReportFilterEditControl Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetHint | Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
GetReportCtrl | Returns a pointer to the associated report control.
GetText | Call this member to get the edit text.
SetHint | Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.
SetReportCtrl | Sets the associated report control.
SetText | Call this member to set the edit control text.


CXTPReportFilterEditControl::GetHint Method

CXTPReportFilterEditControl Methods, CXTPReportFilterEditControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::GetHint Method

Call this member to get grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.

CString GetHint() const;
Returns

Edit hint of the control

See Also

SetHint

Group

CXTPReportFilterEditControl Methods


CXTPReportFilterEditControl::GetReportCtrl Method

CXTPReportFilterEditControl Methods, CXTPReportFilterEditControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::GetReportCtrl Method

Returns a pointer to the associated report control.

CXTPReportControl* GetReportCtrl();
Returns

An associated report control.

See Also

CXTPReportHeader::SetFilterEditCtrl, SetReportCtrl

Group

CXTPReportFilterEditControl Methods


CXTPReportFilterEditControl::GetText Method

CXTPReportFilterEditControl Methods, CXTPReportFilterEditControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::GetText Method

Call this member to get the edit text.

CString GetText() const;
Returns

The Edit control text.

Group

CXTPReportFilterEditControl Methods


CXTPReportFilterEditControl::SetHint Method

CXTPReportFilterEditControl Methods, CXTPReportFilterEditControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::SetHint Method

Call this member to set grayed-out text displayed in the edit control that displayed a helpful description of what the control is used for.

void SetHint(
    LPCTSTR lpszHint
);
Parameters

lpszHint
Edit hint to be set

See Also

GetHint

Example
pEdit->SetHint(_T("Click to find a contact");
Group

CXTPReportFilterEditControl Methods


CXTPReportFilterEditControl::SetReportCtrl Method

CXTPReportFilterEditControl Methods, CXTPReportFilterEditControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::SetReportCtrl Method

Sets the associated report control.

BOOL SetReportCtrl(
    CXTPReportControl* pReportCtrl
);
Parameters

pReportCtrl
Pointer to the associated report control.

Returns

TRUE if set successfully, FALSE otherwise.

Remarks

Usually this method should not be called by the user, instead should call CXTPReportHeader::SetFilterEditCtrl.

See Also

CXTPReportHeader::SetFilterEditCtrl, GetReportCtrl

Group

CXTPReportFilterEditControl Methods


CXTPReportFilterEditControl::SetText Method

CXTPReportFilterEditControl Methods, CXTPReportFilterEditControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::SetText Method

Call this member to set the edit control text.

void SetText(
    const CString& lpszText
);
Parameters

lpszText
New text of the edit control.

Group

CXTPReportFilterEditControl Methods


CXTPReportFilterEditControl Constructors

CXTPReportFilterEditControl Class, Legend, Public Methods
CXTPReportFilterEditControl Constructors
Class

CXTPReportFilterEditControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportFilterEditControl | Constructs a CXTPReportFilterEditControl object.


CXTPReportFilterEditControl::CXTPReportFilterEditControl Constructor

CXTPReportFilterEditControl Constructors, CXTPReportFilterEditControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::CXTPReportFilterEditControl Constructor

Constructs a CXTPReportFilterEditControl object.

CXTPReportFilterEditControl();
Remarks

You construct a CXTPReportFilterEditControl object in two steps. First, call the constructor CXTPReportFilterEditControl and then call Create, which initializes the Windows edit box and attaches it to the CXTPReportFilterEditControl.

See Also

CEdit, SetReportCtrl, CXTPReportHeader::SetFilterEditCtrl

Example
// Declare a local CXTPReportFilterEditControl object.
CXTPReportFilterEditControl myFilterEdit;

// Declare a dynamic CXTPReportFilterEditControl object.
CXTPReportFilterEditControl* pMyFilterEdit = new CXTPReportFilterEditControl;
Group

CXTPReportFilterEditControl Constructors


CXTPReportFilterEditControl Destructors

CXTPReportFilterEditControl Class, Legend, Public Methods
CXTPReportFilterEditControl Destructors
Class

CXTPReportFilterEditControl Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportFilterEditControl | Destroys CXTPReportFilterEditControl object, handles its cleanup.


CXTPReportFilterEditControl::~CXTPReportFilterEditControl Destructor

CXTPReportFilterEditControl Destructors, CXTPReportFilterEditControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportFilterEditControl::~CXTPReportFilterEditControl Destructor

Destroys CXTPReportFilterEditControl object, handles its cleanup.

~CXTPReportFilterEditControl();
Group

CXTPReportFilterEditControl Destructors


CXTPReportGroupRow Class

XTPReportGroupRow.h, Classes, Legend, Members, Topics, CXTPReportGroupRow Data Members, CXTPReportGroupRow Methods, CXTPReportGroupRow Constructors, CXTPReportGroupRow Constructors, CXTPReportGroupRow Data Members, CXTPReportGroupRow Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportGroupRow Class

This class represents a 'group row' of the report control view - that means a row which has no associated Record item, but has a special text caption instead.

Class Hierarchy

class CXTPReportGroupRow : public CXTPReportRow;
File

XTPReportGroupRow.h

Remarks

CXTPReportGroupRow has a slightly different reaction on mouse events and another draw logic.

All other behavior of the group row is similar to its parent.

See Also

CXTPReportRow overview, CXTPReportControl overview

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportGroupRow Constructors
CXTPReportGroupRow Constructors | Description
CXTPReportGroupRow | A constructor of the CXTPReportGroupRow object.
CXTPReportGroupRow Data Members
CXTPReportGroupRow Data Members | Description
m_strGroupText | group text label
CXTPReportGroupRow Methods
CXTPReportGroupRow Methods | Description
Draw | Draws the row using the specified device context.
GetCaption | Returns the group text caption.
GetTooltip | Returns tool tip text displayed for this group row.
IsGroupRow | Determines if this is a group row or not.
OnClick | Process mouse single clicks.
OnDblClick | Process mouse double clicks.
OnToolHitTest | The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
SetCaption | Call this member to specify the text that is displayed as the group caption when the column that the ReportRecordItem is in has been grouped.


CXTPReportGroupRow Data Members

CXTPReportGroupRow Class, Legend, Protected Data Members
CXTPReportGroupRow Data Members
Class

CXTPReportGroupRow Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_strGroupText | group text label


CXTPReportGroupRow::m_strGroupText Data Member

CXTPReportGroupRow Data Members, CXTPReportGroupRow Class
CXTPReportGroupRow::m_strGroupText Data Member

group text label

CString m_strGroupText;
Group

CXTPReportGroupRow Data Members


CXTPReportGroupRow Methods

CXTPReportGroupRow Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportGroupRow Methods
Class

CXTPReportGroupRow Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnToolHitTest | The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
Public Methods
Public Methods
Public Method | Description
Draw | Draws the row using the specified device context.
GetCaption | Returns the group text caption.
GetTooltip | Returns tool tip text displayed for this group row.
IsGroupRow | Determines if this is a group row or not.
OnClick | Process mouse single clicks.
OnDblClick | Process mouse double clicks.
SetCaption | Call this member to specify the text that is displayed as the group caption when the column that the ReportRecordItem is in has been grouped.


CXTPReportGroupRow::Draw Method

CXTPReportGroupRow Methods, CXTPReportGroupRow Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportGroupRow::Draw Method

Draws the row using the specified device context.

virtual void Draw(
    CDC* pDC,
    CRect rcRow,
    int nLeftOffset
);
Parameters

pDC
A pointer to the device context in which the drawing occurs.
rcRow
Position of the row in client window coordinates.
nLeftOffset
Start drawing left offset in pixels (Horizontal scroll position).

See Also

CXTPReportRow::Draw

Group

CXTPReportGroupRow Methods


CXTPReportGroupRow::GetCaption Method

CXTPReportGroupRow Methods, CXTPReportGroupRow Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportGroupRow::GetCaption Method

Returns the group text caption.

virtual CString GetCaption();
Returns

Group text caption.

Remarks

Call this member function to retrieve a text caption of this group row item.

See Also

CXTPReportGroupRow::CXTPReportGroupRow

Group

CXTPReportGroupRow Methods


CXTPReportGroupRow::GetTooltip Method

CXTPReportGroupRow Methods, CXTPReportGroupRow Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportGroupRow::GetTooltip Method

Returns tool tip text displayed for this group row.

virtual CString GetTooltip();
Returns

Tool tip Text for this row.

Remarks

Call this member function to retrieve the tool tip text displayed the this group row.

Body Source
CString CXTPReportGroupRow::GetTooltip() {
    return GetCaption();
}
Group

CXTPReportGroupRow Methods


CXTPReportGroupRow::IsGroupRow Method

CXTPReportGroupRow Methods, CXTPReportGroupRow Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportGroupRow::IsGroupRow Method

Determines if this is a group row or not.

BOOL IsGroupRow() const;
Returns

TRUE because this is a group row.

See Also

CXTPReportRow::IsGroupRow

Body Source
BOOL CXTPReportGroupRow::IsGroupRow() const {
    return TRUE;
}
Group

CXTPReportGroupRow Methods


CXTPReportGroupRow::OnClick Method

CXTPReportGroupRow Methods, CXTPReportGroupRow Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportGroupRow::OnClick Method

Process mouse single clicks.

void OnClick(
    CPoint ptClicked
);
Parameters

ptClicked
Point coordinates where the message was fired from.

See Also

CXTPReportRow::OnClick

Group

CXTPReportGroupRow Methods


CXTPReportGroupRow::OnDblClick Method

CXTPReportGroupRow Methods, CXTPReportGroupRow Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportGroupRow::OnDblClick Method

Process mouse double clicks.

void OnDblClick(
    CPoint ptClicked
);
Parameters

ptClicked
Point coordinates where the message was fired from.

Remarks

Group row adds a collapse/expand functionality if double- clicked on a row.

See Also

CXTPReportRow::OnDblClick

Group

CXTPReportGroupRow Methods


CXTPReportGroupRow::OnToolHitTest Method

CXTPReportGroupRow Methods, CXTPReportGroupRow Class
CXTPReportGroupRow::OnToolHitTest Method

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

virtual INT_PTR OnToolHitTest(
    CPoint point,
    TOOLINFO* pTI
);
Parameters

point
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window
pTI
A pointer to a TOOLINFO structure.

Returns

If the tooltip control was found, the window control ID. If the tooltip control was not found, -1.

Group

CXTPReportGroupRow Methods


CXTPReportGroupRow::SetCaption Method

CXTPReportGroupRow Methods, CXTPReportGroupRow Class
CXTPReportGroupRow::SetCaption Method

Call this member to specify the text that is displayed as the group caption when the column that the ReportRecordItem is in has been grouped.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
Caption to be set

Remarks

When a column that the ReportRecordItem belong to has been grouped, the caption of the column is displayed as the group caption. If you specify a caption with CXTPReportGroupRow::SetCaption for the ReportRecordItem, the m_strGroupText text will be displayed instead of the caption of the column. You can use CXTPReportGroupRow::SetCaption to "sub group" your ReportRecordItems when the column they belong to has been grouped. The ReportRecordItems will be "sub grouped" by the value in m_strGroupText when the column they belong to is grouped.

Group

CXTPReportGroupRow Methods


CXTPReportGroupRow Constructors

CXTPReportGroupRow Class, Legend, Public Methods
CXTPReportGroupRow Constructors
Class

CXTPReportGroupRow Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportGroupRow | A constructor of the CXTPReportGroupRow object.


CXTPReportGroupRow::CXTPReportGroupRow Constructor

CXTPReportGroupRow Constructors, CXTPReportGroupRow Class
CXTPReportGroupRow::CXTPReportGroupRow Constructor

A constructor of the CXTPReportGroupRow object.

CXTPReportGroupRow();
Group

CXTPReportGroupRow Constructors


CXTPReportHeader Class

XTPReportHeader.h, Classes, Legend, Members, Topics, CXTPReportHeader Enumerations, CXTPReportHeader Data Members, CXTPReportHeader Methods, CXTPReportHeader Constructors, CXTPReportHeader Destructors, CXTPReportHeader Constructors, CXTPReportHeader Data Members, CXTPReportHeader Destructors, CXTPReportHeader Enumerations, CXTPReportHeader Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader Class

A report header is a part of the report window positioned above columns of text or numbers. It contains a title for each column, and it can be divided into parts. The user can drag the dividers that separate the parts to set the width of each column.

Class Hierarchy

class CXTPReportHeader;
File

XTPReportHeader.h

Remarks

This class is responsible for header drawing on a report window, processing user events, and changing header properties.

Functionality of the header includes the following:

  • Header self-drawing.
  • Header item custom ordering.
  • Header item drag and drop, for the reordering of header items.
  • Sorting report rows with mouse click on column header.
  • Filtering of the report row items using associated CXTPReportFilterEditControl.
  • Header items choosing using associated filed chooser control: CXTPReportSubListControl.
  • Group By area support containing the order of grouped columns.
See Also

CXTPReportControl, CXTPReportColumn, CXTPReportSubListControl

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
CXTPReportHeader Constructors
CXTPReportHeader Constructors | Description
CXTPReportHeader | Constructs a CXTPReportHeader object.
CXTPReportHeader Data Members
CXTPReportHeader Data Members | Description
m_bAllowColumnRemove | FALSE if columns removing is not allowed.
m_bAllowColumnReorder | FALSE if columns reordering is not allowed.
m_bAllowColumnResize | FALSE if columns resizing is not allowed.
m_bAllowColumnSort | FALSE if columns sorting is not allowed.
m_bAutoColumnSizing | TRUE if AutoColumnSizing should be used.
m_bDragGroupBox | Determines whether control is in group box dragging mode.
m_bDragHeader | Determines whether control is in header dragging mode or group by dragging mode.
m_bShowItemsInGroups | TRUE when showing items in groups, FALSE when grouping is not used.
m_dragMode | Column dragging mode.
m_hDontDropCursor | Handler of user's Don't Drop cursor.
m_hResizeCursor | Handler of user's Resizing cursor.
m_nDropIndex | Item index of the column to drop to.
m_nHeaderWidth | The combined width of all the visible column headers.
m_nIndentLevel | Width indent at the left of the column.
m_nResizeCaptureRange | Distance around column divider where column re-sizer is shown.
m_pColumns | Contains associated columns list.
m_pControl | Pointer to the parent Report control.
m_pDragColumn | Dragging column.
m_pDragWnd | Column drag window.
m_pDropWnd | Column drop window.
m_pFilterEdit | Filter edit control
m_pHotTrackingColumn | Hot column
m_pSubList | Field chooser list control.
m_ptMouse | Stores mouse coordinates for processing when required (resizing, etc).
m_rcGroupBy | Group By area coordinates.
m_rcHeader | Header coordinates.
s_bSendContextMenuForWholeHeaderArea | If set as TRUE report control send ContextMenu event for clicks on whole header area (not only for columns) rectangles.
s_bShowItemsInGroupsPXDefault | Store default value of m_bShowItemsInGroups member for serialization (PropExchange).
s_nMinAutoScrollStep | Minimal horizontal autoscrolling step in pixels.
CXTPReportHeader Destructors
CXTPReportHeader Destructors | Description
~CXTPReportHeader | Destroys CXTPReportHeader object. Performs cleanup operations.
CXTPReportHeader Enumerations
CXTPReportHeader Enumerations | Description
ReportDraggingMode | private:
CXTPReportHeader Methods
CXTPReportHeader Methods | Description
AdjustColumnsWidth | Checks if the provided point is over column resize area.
AllowColumnRemove | Allows/disallows column removing.
AllowColumnReorder | Allows/disallows column reordering.
AllowColumnResize | Allows/disallows column resizing.
AllowColumnSort | Sets allowing column sorting mode.
BestFit | Fits the provided column width to the longest column item width.
CancelMouseMode | Resets any mouse mode to xtpMouseNothing.
DoPropExchange | Reads or writes configuration to/from the provided archive stream.
Draw | Draws columns header on the provided DC.
DrawFooter | Draws columns footer on the provided DC.
DrawGroupByControl | Draws Group By area on the provided DC.
FindGroupByColumn | Calculates index of where to insert a column nearest to the provided point.
FindHeaderColumn | Calculates index of where to insert a column nearest to the provided point.
GetControl | Retrieves parent Report Control
GetDraggingColumn | Returns a column, which is dragging at the moment.
GetFilterEditCtrl | Returns the associated Filter edit control.
GetFulColScrollInfo | Get current scroll information for full columns scroll mode and the helper information to scroll left or right.
GetGroupByHeight | Returns the Group By area height.
GetIndentLevel | Returns an indent for report rows by 1 tree level.
GetMaxAvailWidth | Returns maximum available width for the column.
GetNextVisibleColumn | Call this member to retrieve the next visible column.
GetPaintManager | Returns the currently used control's Paint Manager.
GetSubListCtrl | Retrieves Pointer to the field chooser
GetWidth | Call this member to retrieve the total width of the header (total combined column widths).
HitTest | Finds a column from point.
HitTestHeaderColumnIndex | Finds header column index by provided point.
IsAllowColumnRemove | Returns the current column removing allowance.
IsAllowColumnReorder | Returns the current column reordering allowance.
IsAllowColumnResize | Returns current column resizing allowance.
IsAllowColumnSort | Returns current allowing column sorting mode.
IsAutoColumnSizing | Call this member to determine if AutoColumnSizing is currently used.
IsDragHeader | Determines if dragging the header now.
IsLastResizebleColumn | Checks a column for its position in report header.
IsLastVisibleColumn | Checks a column for its position in report header.
IsShowItemsInGroups | Returns current show items in groups mode.
MouseOverColumnResizeArea | Checks if the provided point is over column resize area.
OnColumnsChanged | Updates header settings after any changes.
OnContextMenu | Process context menu. Called by the framework when the user has clicked the right mouse button (right clicked) in the window.
OnLButtonDblClk | Processes mouse left button double-clicks .
OnLButtonDown | Processes mouse left button down clicks.
OnLButtonUp | Process mouse left button up clicks.
OnMouseMove | Process mouse moving.
OnToolHitTest | The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
ResizeColumn | Resizes a provided column to a specific new width.
SetAutoColumnSizing | Call this member to specify if AutoColumnSizing should be used.
SetFilterEditCtrl | Sets associated filter edit control.
SetHotDivider | Sets a divider between columns.
SetSubListCtrl | Sets associated Field chooser list control.
ShowItemsInGroups | Sets show items in groups mode.
StartDragging | Starts column header dragging mode.


CXTPReportHeader Enumerations

Enumerations, CXTPReportHeader Class, Legend
CXTPReportHeader Enumerations
Enumerations
Enumeration | Description
ReportDraggingMode | private:
Class

CXTPReportHeader Class

Legend
Enumeration


CXTPReportHeader::ReportDraggingMode Enumeration

XTPReportHeader.h, CXTPReportHeader Enumerations
CXTPReportHeader::ReportDraggingMode Enumeration

private:

enum ReportDraggingMode {
  dragNothing = 0,
  dragOutTarget = 1,
  dragInHeader = 2,
  dragInGroupBox = 4,
  dragInTarget = 6,
  dragFieldChooser = 8
};
File

XTPReportHeader.h

Members

dragNothing
User is dragging nothing.
dragOutTarget
User is dragging an item outside the drop target.
dragInHeader
User is dragging an item inside header
dragInGroupBox
User is dragging an item inside group box
dragInTarget
User is dragging an item inside the drop target.
dragFieldChooser
User is dragging an item inside field chooser.

Group

CXTPReportHeader Enumerations


CXTPReportHeader Data Members

CXTPReportHeader Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader Data Members
Class

CXTPReportHeader Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAllowColumnRemove | FALSE if columns removing is not allowed.
m_bAllowColumnReorder | FALSE if columns reordering is not allowed.
m_bAllowColumnResize | FALSE if columns resizing is not allowed.
m_bAllowColumnSort | FALSE if columns sorting is not allowed.
m_bAutoColumnSizing | TRUE if AutoColumnSizing should be used.
m_bDragGroupBox | Determines whether control is in group box dragging mode.
m_bDragHeader | Determines whether control is in header dragging mode or group by dragging mode.
m_bShowItemsInGroups | TRUE when showing items in groups, FALSE when grouping is not used.
m_dragMode | Column dragging mode.
m_hDontDropCursor | Handler of user's Don't Drop cursor.
m_hResizeCursor | Handler of user's Resizing cursor.
m_nDropIndex | Item index of the column to drop to.
m_nHeaderWidth | The combined width of all the visible column headers.
m_nIndentLevel | Width indent at the left of the column.
m_nResizeCaptureRange | Distance around column divider where column re-sizer is shown.
m_pColumns | Contains associated columns list.
m_pControl | Pointer to the parent Report control.
m_pDragColumn | Dragging column.
m_pDragWnd | Column drag window.
m_pDropWnd | Column drop window.
m_pFilterEdit | Filter edit control
m_pHotTrackingColumn | Hot column
m_pSubList | Field chooser list control.
m_ptMouse | Stores mouse coordinates for processing when required (resizing, etc).
m_rcGroupBy | Group By area coordinates.
m_rcHeader | Header coordinates.
Public Data Members
Public Data Member | Description
s_bSendContextMenuForWholeHeaderArea | If set as TRUE report control send ContextMenu event for clicks on whole header area (not only for columns) rectangles.
s_bShowItemsInGroupsPXDefault | Store default value of m_bShowItemsInGroups member for serialization (PropExchange).
s_nMinAutoScrollStep | Minimal horizontal autoscrolling step in pixels.


CXTPReportHeader::m_bAllowColumnRemove Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_bAllowColumnRemove Data Member

FALSE if columns removing is not allowed.

BOOL m_bAllowColumnRemove;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_bAllowColumnReorder Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_bAllowColumnReorder Data Member

FALSE if columns reordering is not allowed.

BOOL m_bAllowColumnReorder;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_bAllowColumnResize Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_bAllowColumnResize Data Member

FALSE if columns resizing is not allowed.

BOOL m_bAllowColumnResize;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_bAllowColumnSort Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_bAllowColumnSort Data Member

FALSE if columns sorting is not allowed.

BOOL m_bAllowColumnSort;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_bAutoColumnSizing Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_bAutoColumnSizing Data Member

TRUE if AutoColumnSizing should be used.

BOOL m_bAutoColumnSizing;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_bDragGroupBox Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_bDragGroupBox Data Member

Determines whether control is in group box dragging mode.

BOOL m_bDragGroupBox;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_bDragHeader Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_bDragHeader Data Member

Determines whether control is in header dragging mode or group by dragging mode.

BOOL m_bDragHeader;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_bShowItemsInGroups Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_bShowItemsInGroups Data Member

TRUE when showing items in groups, FALSE when grouping is not used.

BOOL m_bShowItemsInGroups;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_dragMode Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_dragMode Data Member

Column dragging mode.

enum ReportDraggingMode {
  dragNothing = 0,
  dragOutTarget = 1,
  dragInHeader = 2,
  dragInGroupBox = 4,
  dragInTarget = 6,
  dragFieldChooser = 8
} m_dragMode;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_hDontDropCursor Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_hDontDropCursor Data Member

Handler of user's Don't Drop cursor.

HCURSOR m_hDontDropCursor;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_hResizeCursor Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_hResizeCursor Data Member

Handler of user's Resizing cursor.

HCURSOR m_hResizeCursor;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_nDropIndex Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_nDropIndex Data Member

Item index of the column to drop to.

int m_nDropIndex;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_nHeaderWidth Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_nHeaderWidth Data Member

The combined width of all the visible column headers.

int m_nHeaderWidth;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_nIndentLevel Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_nIndentLevel Data Member

Width indent at the left of the column.

int m_nIndentLevel;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_nResizeCaptureRange Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_nResizeCaptureRange Data Member

Distance around column divider where column re-sizer is shown.

int m_nResizeCaptureRange;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_pColumns Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_pColumns Data Member

Contains associated columns list.

CXTPReportColumns* m_pColumns;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_pControl Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_pControl Data Member

Pointer to the parent Report control.

CXTPReportControl* m_pControl;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_pDragColumn Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_pDragColumn Data Member

Dragging column.

CXTPReportColumn* m_pDragColumn;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_pDragWnd Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_pDragWnd Data Member

Column drag window.

CXTPReportHeaderDragWnd* m_pDragWnd;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_pDropWnd Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_pDropWnd Data Member

Column drop window.

CXTPReportHeaderDropWnd* m_pDropWnd;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_pFilterEdit Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_pFilterEdit Data Member

Filter edit control

CXTPReportFilterEditControl* m_pFilterEdit;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_pHotTrackingColumn Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_pHotTrackingColumn Data Member

Hot column

CXTPReportColumn* m_pHotTrackingColumn;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_pSubList Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_pSubList Data Member

Field chooser list control.

CXTPReportSubListControl* m_pSubList;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_ptMouse Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_ptMouse Data Member

Stores mouse coordinates for processing when required (resizing, etc).

CPoint m_ptMouse;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_rcGroupBy Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_rcGroupBy Data Member

Group By area coordinates.

CRect m_rcGroupBy;
Group

CXTPReportHeader Data Members


CXTPReportHeader::m_rcHeader Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::m_rcHeader Data Member

Header coordinates.

CRect m_rcHeader;
Group

CXTPReportHeader Data Members


CXTPReportHeader::s_bSendContextMenuForWholeHeaderArea Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::s_bSendContextMenuForWholeHeaderArea Data Member

If set as TRUE report control send ContextMenu event for clicks on whole header area (not only for columns) rectangles.

BOOL s_bSendContextMenuForWholeHeaderArea;
Group

CXTPReportHeader Data Members


CXTPReportHeader::s_bShowItemsInGroupsPXDefault Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::s_bShowItemsInGroupsPXDefault Data Member

Store default value of m_bShowItemsInGroups member for serialization (PropExchange).

BOOL s_bShowItemsInGroupsPXDefault;
Group

CXTPReportHeader Data Members


CXTPReportHeader::s_nMinAutoScrollStep Data Member

CXTPReportHeader Data Members, CXTPReportHeader Class
CXTPReportHeader::s_nMinAutoScrollStep Data Member

Minimal horizontal autoscrolling step in pixels.

int s_nMinAutoScrollStep;
Group

CXTPReportHeader Data Members


CXTPReportHeader Methods

CXTPReportHeader Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader Methods
Class

CXTPReportHeader Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AdjustColumnsWidth | Checks if the provided point is over column resize area.
CancelMouseMode | Resets any mouse mode to xtpMouseNothing.
DoPropExchange | Reads or writes configuration to/from the provided archive stream.
Draw | Draws columns header on the provided DC.
DrawFooter | Draws columns footer on the provided DC.
DrawGroupByControl | Draws Group By area on the provided DC.
GetMaxAvailWidth | Returns maximum available width for the column.
GetPaintManager | Returns the currently used control's Paint Manager.
OnContextMenu | Process context menu. Called by the framework when the user has clicked the right mouse button (right clicked) in the window.
OnLButtonDblClk | Processes mouse left button double-clicks .
OnLButtonDown | Processes mouse left button down clicks.
OnLButtonUp | Process mouse left button up clicks.
OnMouseMove | Process mouse moving.
OnToolHitTest | The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
ResizeColumn | Resizes a provided column to a specific new width.
SetHotDivider | Sets a divider between columns.
StartDragging | Starts column header dragging mode.
Public Methods
Public Methods
Public Method | Description
AllowColumnRemove | Allows/disallows column removing.
AllowColumnReorder | Allows/disallows column reordering.
AllowColumnResize | Allows/disallows column resizing.
AllowColumnSort | Sets allowing column sorting mode.
BestFit | Fits the provided column width to the longest column item width.
FindGroupByColumn | Calculates index of where to insert a column nearest to the provided point.
FindHeaderColumn | Calculates index of where to insert a column nearest to the provided point.
GetControl | Retrieves parent Report Control
GetDraggingColumn | Returns a column, which is dragging at the moment.
GetFilterEditCtrl | Returns the associated Filter edit control.
GetFulColScrollInfo | Get current scroll information for full columns scroll mode and the helper information to scroll left or right.
GetGroupByHeight | Returns the Group By area height.
GetIndentLevel | Returns an indent for report rows by 1 tree level.
GetNextVisibleColumn | Call this member to retrieve the next visible column.
GetSubListCtrl | Retrieves Pointer to the field chooser
GetWidth | Call this member to retrieve the total width of the header (total combined column widths).
HitTest | Finds a column from point.
HitTestHeaderColumnIndex | Finds header column index by provided point.
IsAllowColumnRemove | Returns the current column removing allowance.
IsAllowColumnReorder | Returns the current column reordering allowance.
IsAllowColumnResize | Returns current column resizing allowance.
IsAllowColumnSort | Returns current allowing column sorting mode.
IsAutoColumnSizing | Call this member to determine if AutoColumnSizing is currently used.
IsDragHeader | Determines if dragging the header now.
IsLastResizebleColumn | Checks a column for its position in report header.
IsLastVisibleColumn | Checks a column for its position in report header.
IsShowItemsInGroups | Returns current show items in groups mode.
MouseOverColumnResizeArea | Checks if the provided point is over column resize area.
OnColumnsChanged | Updates header settings after any changes.
SetAutoColumnSizing | Call this member to specify if AutoColumnSizing should be used.
SetFilterEditCtrl | Sets associated filter edit control.
SetSubListCtrl | Sets associated Field chooser list control.
ShowItemsInGroups | Sets show items in groups mode.


CXTPReportHeader::AdjustColumnsWidth Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::AdjustColumnsWidth Method

Checks if the provided point is over column resize area.

void AdjustColumnsWidth(
    int nTotalWidth,
    int nFirstIndex = 0
);
Parameters

nTotalWidth
Total width of the header area in pixels.
nFirstIndex
Index of a column to start adjusting from.

Remarks

Call this member function when you want to adjust the width of columns in reaction to any specific event. For example, this member function is called by the framework when changing the report control size (WM_SIZE), and when changing a size of any column by mouse dragging.

See Also

ResizeColumn, GetMaxAvailWidth

Group

CXTPReportHeader Methods


CXTPReportHeader::AllowColumnRemove Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::AllowColumnRemove Method

Allows/disallows column removing.

void AllowColumnRemove(
    BOOL bAllow
);
Parameters

bAllow
TRUE for allowing column removing, FALSE for disallowing.

Remarks

Usually user is allowed to remove a column using mouse drag and drop. Using this member function, you can change the user's permissions force allowing or disallowing of column removing.

See Also

IsAllowColumnRemove, CXTPReportColumn::AllowColumnRemove

Body Source
void CXTPReportHeader::AllowColumnRemove(BOOL bAllow) {
    m_bAllowColumnRemove = bAllow;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::AllowColumnReorder Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::AllowColumnReorder Method

Allows/disallows column reordering.

void AllowColumnReorder(
    BOOL bAllow
);
Parameters

bAllow
TRUE for allowing column reordering, FALSE for disallowing.

Remarks

Usually user is allowed to reorder a column using mouse drag and drop. Using this member function, you can change the user's permissions and force allowing or disallowing of column reordering.

See Also

IsAllowColumnReorder

Body Source
void CXTPReportHeader::AllowColumnReorder(BOOL bAllow) {
    m_bAllowColumnReorder = bAllow;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::AllowColumnResize Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::AllowColumnResize Method

Allows/disallows column resizing.

void AllowColumnResize(
    BOOL bAllow
);
Parameters

bAllow
TRUE for allowing column resizing, FALSE for disallowing.

Remarks

Usually the user is allowed to resize column using mouse drag and drop. Using this member function you can change user's permissions and force allowing or disallowing of column resizing.

See Also

IsAllowColumnResize

Body Source
void CXTPReportHeader::AllowColumnResize(BOOL bAllow) {
    m_bAllowColumnResize = bAllow;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::AllowColumnSort Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::AllowColumnSort Method

Sets allowing column sorting mode.

void AllowColumnSort(
    BOOL bAllow
);
Parameters

bAllow
TRUE for allowing, FALSE for disallowing.

Remarks

Using this member function you can allow or disallow sorting columns by mouse.

See Also

IsAllowColumnSort

Body Source
void CXTPReportHeader::AllowColumnSort(BOOL bAllow) {
    m_bAllowColumnSort = bAllow;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::BestFit Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::BestFit Method

Fits the provided column width to the longest column item width.

void BestFit(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
A column to fit width.

Remarks

Call this method to adjust column width to the width of the widest column item.

Group

CXTPReportHeader Methods


CXTPReportHeader::CancelMouseMode Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::CancelMouseMode Method

Resets any mouse mode to xtpMouseNothing.

void CancelMouseMode();
Remarks

Usually this member function is called when finishing dragging or resizing columns. It performs all necessary cleanup and resets mouse mode to xtpMouseNothing.

See Also

StartDragging

Group

CXTPReportHeader Methods


CXTPReportHeader::DoPropExchange Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::DoPropExchange Method

Reads or writes configuration to/from the provided archive stream.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPReportHeader Methods


CXTPReportHeader::Draw Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::Draw Method

Draws columns header on the provided DC.

virtual void Draw(
    CDC* pDC,
    CRect rcHeader,
    int nLeftOffset
);
Parameters

pDC
Pointer to the destination device context.
rcHeader
Reference to the rectangle in which the header is drawn.
nLeftOffset
Start drawing left offset in pixels (Horizontal scroll position).

Remarks

Call this function to draw the header on the provided device context. Note that it does not contain Group By area.

See Also

DrawGroupByControl

Group

CXTPReportHeader Methods


CXTPReportHeader::DrawFooter Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::DrawFooter Method

Draws columns footer on the provided DC.

virtual void DrawFooter(
    CDC* pDC,
    CRect& rcFooter,
    int nLeftOffset
);
Parameters

pDC
Pointer to the destination device context.
rcFooter
Reference to the rectangle in which the footer is drawn.
nLeftOffset
Start drawing left offset in pixels (Horizontal scroll position).

Remarks

Call this function to draw the footer on the provided device context.

See Also

Draw

Group

CXTPReportHeader Methods


CXTPReportHeader::DrawGroupByControl Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::DrawGroupByControl Method

Draws Group By area on the provided DC.

virtual void DrawGroupByControl(
    CDC* pDC,
    CRect& rcGroupBy
);
Parameters

pDC
Pointer to the destination device context.
rcGroupBy
Reference to the rectangle of the Group By area.

Remarks

Call this function to draw the header on the provided device context. Note that it does not contain Group By area.

See Also

Draw

Group

CXTPReportHeader Methods


CXTPReportHeader::FindGroupByColumn Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::FindGroupByColumn Method

Calculates index of where to insert a column nearest to the provided point.

virtual int FindGroupByColumn(
    CPoint ptPoint,
    BOOL bExactSearch = FALSE
) const;
Parameters

ptPoint
Point coordinates to test.
bExactSearch
TRUE when search by exact position, FALSE when searching average value.

Returns

GroupBy column position.

Group

CXTPReportHeader Methods


CXTPReportHeader::FindHeaderColumn Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::FindHeaderColumn Method

Calculates index of where to insert a column nearest to the provided point.

virtual int FindHeaderColumn(
    CPoint ptPoint
) const;
Parameters

ptPoint
Point coordinates to test

Returns

Header column index.

Group

CXTPReportHeader Methods


CXTPReportHeader::GetControl Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::GetControl Method

Retrieves parent Report Control

CXTPReportControl* GetControl() const;
Returns

CXTPReportControl pointer

Body Source
CXTPReportControl* CXTPReportHeader::GetControl() const{
    return m_pControl;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::GetDraggingColumn Method

CXTPReportHeader Methods, CXTPReportHeader Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::GetDraggingColumn Method

Returns a column, which is dragging at the moment.

CXTPReportColumn* GetDraggingColumn() const;
Returns

A pointer to the dragging column if the control is in dragging mode, or NULL otherwise.

Remarks

Call this member function if you want to retrieve a pointer to the currently dragging column.

See Also

StartDragging, GetResizingColumn,

Example
CXTPReportColumn* pColumn = GetDraggingColumn();
Group

CXTPReportHeader Methods


CXTPReportHeader::GetFilterEditCtrl Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::GetFilterEditCtrl Method

Returns the associated Filter edit control.

CXTPReportFilterEditControl* GetFilterEditCtrl() const;
Returns

A pointer to the associated filter edit control.

Remarks

Call this member function to retrieve a pointer to the associated filter edit control.

See Also

CXTPReportFilterEditControl overview, SetFilterEditCtrl

Body Source
CXTPReportFilterEditControl* CXTPReportHeader::GetFilterEditCtrl() const {
    return m_pFilterEdit;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::GetFulColScrollInfo Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::GetFulColScrollInfo Method

Get current scroll information for full columns scroll mode and the helper information to scroll left or right.

int GetFulColScrollInfo(
    CXTPReportColumn*& rpPrev,
    CXTPReportColumn*& rpCurr,
    CXTPReportColumn*& rpNext,
    int& rnScrollPos,
    int& rnScrollMax
) const;
Parameters

rpPrev
[out] A reference to store next column to scroll left. NULL is returned if current position is on last left column.
rpCurr
[out] A reference to store current column (first visible column on the left).
rpNext
[out] A reference to store next column to scroll right. NULL is returned if current position is on last right column.
rnScrollPos
[out] A reference to store current scrollBar position.
rnScrollMax
[out] A reference to store scrollBar positions count.

Returns

A freezed columns width in pixels.

Group

CXTPReportHeader Methods


CXTPReportHeader::GetGroupByHeight Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::GetGroupByHeight Method

Returns the Group By area height.

int GetGroupByHeight() const;
Returns

A Group By area height in pixels.

Remarks

Calculates Group By area height depending on the number of items contained inside.

Group

CXTPReportHeader Methods


CXTPReportHeader::GetIndentLevel Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::GetIndentLevel Method

Returns an indent for report rows by 1 tree level.

int GetIndentLevel() const;
Returns

An indent by one level in pixels.

Remarks

Call this member function to retrieve an indent for 1 level of tree depth for the report control in tree mode.

Body Source
int CXTPReportHeader::GetIndentLevel()const {
    return m_nIndentLevel;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::GetMaxAvailWidth Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::GetMaxAvailWidth Method

Returns maximum available width for the column.

int GetMaxAvailWidth(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Pointer to the column to check.

Returns

Maximum available width for the column in pixels.

Remarks

Calculates maximum possible width for the column depending on the width and modes for other columns.

See Also

AdjustColumnsWidth, ResizeColumn

Group

CXTPReportHeader Methods


CXTPReportHeader::GetNextVisibleColumn Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::GetNextVisibleColumn Method

Call this member to retrieve the next visible column.

virtual CXTPReportColumn* GetNextVisibleColumn(
    int nIndex,
    int nDirection
);
Parameters

nIndex
Position of a column in the array of columns to start from.
nDirection
The direction to move (left or right) in the array, starting and nIndex.

Returns

A pointer to the next visible column.

Group

CXTPReportHeader Methods


CXTPReportHeader::GetPaintManager Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::GetPaintManager Method

Returns the currently used control's Paint Manager.

CXTPReportPaintManager* GetPaintManager() const;
Returns

Pointer to the paint manager object.

Remarks

Call this member function to get the paint manager object used for drawing a report control window.

See Also

CXTPReportPaintManager overview

Group

CXTPReportHeader Methods


CXTPReportHeader::GetSubListCtrl Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::GetSubListCtrl Method

Retrieves Pointer to the field chooser

CXTPReportSubListControl* GetSubListCtrl() const;
Returns

Pointer to the field chooser list box control.

See Also

SetSubListCtrl

Body Source
CXTPReportSubListControl* CXTPReportHeader::GetSubListCtrl() const {
    return m_pSubList;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::GetWidth Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::GetWidth Method

Call this member to retrieve the total width of the header (total combined column widths).

int GetWidth() const;
Returns

The total combined column widths, which make up the header width.

Body Source
int CXTPReportHeader::GetWidth() const {
    return m_nHeaderWidth;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::HitTest Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::HitTest Method

Finds a column from point.

virtual CXTPReportColumn* HitTest(
    CPoint ptPoint
) const;
Parameters

ptPoint
A point to test in report control client coordinates.

Returns

A pointer to the column placed at the specified position, if any, or NULL otherwise.

Remarks

Call this member function if you want to retrieve a pointer to a column in the specified position.

See Also

CXTPReportControl::HitTest, CXTPReportRow::HitTest

Group

CXTPReportHeader Methods


CXTPReportHeader::HitTestHeaderColumnIndex Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::HitTestHeaderColumnIndex Method

Finds header column index by provided point.

virtual int HitTestHeaderColumnIndex(
    CPoint ptPoint
) const;
Parameters

ptPoint
A point to test in report control window client coordinates.

Returns

An index of the found column in the header column array, if found, or -1 if column was not found.

Group

CXTPReportHeader Methods


CXTPReportHeader::IsAllowColumnRemove Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::IsAllowColumnRemove Method

Returns the current column removing allowance.

BOOL IsAllowColumnRemove() const;
Returns

TRUE when column removing is allowed, FALSE otherwise.

Remarks

Call this member function to determine whether the user is allowed to remove the column using drag and drop or not.

See Also

AllowColumnRemove

Body Source
BOOL CXTPReportHeader::IsAllowColumnRemove() const{
    return m_bAllowColumnRemove;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::IsAllowColumnReorder Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::IsAllowColumnReorder Method

Returns the current column reordering allowance.

BOOL IsAllowColumnReorder() const;
Returns

TRUE when column reordering is allowed, FALSE otherwise.

Remarks

Call this member function to determine whether the user is allowed to reorder the column using drag and drop or not.

See Also

AllowColumnReorder

Body Source
BOOL CXTPReportHeader::IsAllowColumnReorder() const {
    return m_bAllowColumnReorder;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::IsAllowColumnResize Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::IsAllowColumnResize Method

Returns current column resizing allowance.

BOOL IsAllowColumnResize() const;
Returns

TRUE when column resizing is allowed, FALSE otherwise.

Remarks

Call this member function to determine whether the user is allowed to resize a column using drag and drop or not.

See Also

AllowColumnResize

Body Source
BOOL CXTPReportHeader::IsAllowColumnResize() const{
    return m_bAllowColumnResize;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::IsAllowColumnSort Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::IsAllowColumnSort Method

Returns current allowing column sorting mode.

BOOL IsAllowColumnSort() const;
Returns

TRUE when column sorting is allowed, FALSE otherwise.

Remarks

Using this member function you can retrieve the current allowing column sorting mode.

See Also

AllowColumnSort

Body Source
BOOL CXTPReportHeader::IsAllowColumnSort() const{
    return m_bAllowColumnSort;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::IsAutoColumnSizing Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::IsAutoColumnSizing Method

Call this member to determine if AutoColumnSizing is currently used.

BOOL IsAutoColumnSizing() const;
Returns

TRUE is AutoColumnSizing is used, FALSE otherwise.

Body Source
BOOL CXTPReportHeader::IsAutoColumnSizing() const {
    return m_bAutoColumnSizing;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::IsDragHeader Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::IsDragHeader Method

Determines if dragging the header now.

BOOL IsDragHeader() const;
Returns

TRUE when dragging, FALSE otherwise.

Remarks

When user starts dragging a row, Report Header enters a dragging loop and processes each message in the specific way. Using this function you can determine if we are in such a dragging loop or not.

Body Source
BOOL CXTPReportHeader::IsDragHeader() const{
    return m_bDragHeader;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::IsLastResizebleColumn Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::IsLastResizebleColumn Method

Checks a column for its position in report header.

BOOL IsLastResizebleColumn(
    CXTPReportColumn* pColumn
) const;
Parameters

pColumn
A pointer to the column to check.

Returns

TRUE if a provided column is the last resizable column in a report header, FALSE otherwise.

Group

CXTPReportHeader Methods


CXTPReportHeader::IsLastVisibleColumn Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::IsLastVisibleColumn Method

Checks a column for its position in report header.

BOOL IsLastVisibleColumn(
    CXTPReportColumn* pColumn
) const;
Parameters

pColumn
A pointer to the column to check.

Returns

TRUE if a provided column is the last visible column in a report header, FALSE otherwise.

Group

CXTPReportHeader Methods


CXTPReportHeader::IsShowItemsInGroups Method

CXTPReportHeader Methods, CXTPReportHeader Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::IsShowItemsInGroups Method

Returns current show items in groups mode.

BOOL IsShowItemsInGroups() const;
Returns

TRUE when items are shown in groups, FALSE otherwise.

Remarks

Using this member function you can retrieve current showing items in groups mode.

See Also

ShowItemsInGroups

Body Source
BOOL CXTPReportHeader::IsShowItemsInGroups() const{
    return m_bShowItemsInGroups;
}
Group

CXTPReportHeader Methods


CXTPReportHeader::MouseOverColumnResizeArea Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::MouseOverColumnResizeArea Method

Checks if the provided point is over column resize area.

CXTPReportColumn* MouseOverColumnResizeArea(
    CPoint ptPoint
);
Parameters

ptPoint
Point coordinates to test

Returns

A pointer to column for resize, or NULL if point is not over any column resize area.

Group

CXTPReportHeader Methods


CXTPReportHeader::OnColumnsChanged Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::OnColumnsChanged Method

Updates header settings after any changes.

virtual void OnColumnsChanged(
    BOOL bGroupOrderChanged = FALSE
);
Parameters

bGroupOrderChanged
flag indicating whether the group order has been changed or not.

Remarks

Call this member function if you want to automatically adjust columns widths and redraw report control depending on current columns settings.

Group

CXTPReportHeader Methods


CXTPReportHeader::OnContextMenu Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::OnContextMenu Method

Process context menu. Called by the framework when the user has clicked the right mouse button (right clicked) in the window.

virtual void OnContextMenu(
    CPoint ptClick
);
Parameters

ptClick
Position of the cursor, in screen coordinates, at the time of the mouse click.

Remarks

Call this member function if you want Report Header to process a mouse right button down (context menu call) message. You should provide the method with the coordinates of the mouse message to proceed.

See Also

OnLButtonDown, OnLButtonUp, OnMouseMove

Group

CXTPReportHeader Methods


CXTPReportHeader::OnLButtonDblClk Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::OnLButtonDblClk Method

Processes mouse left button double-clicks .

virtual void OnLButtonDblClk(
    CPoint ptDblClick
);
Parameters

ptDblClick
Point coordinates where the message was fired from.

Group

CXTPReportHeader Methods


CXTPReportHeader::OnLButtonDown Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::OnLButtonDown Method

Processes mouse left button down clicks.

virtual void OnLButtonDown(
    CPoint ptClick
);
Parameters

ptClick
Point coordinates where the message was fired from.

Remarks

Call this member function if you want Report Header to process a mouse left button down message. You should provide the method with the coordinates of the mouse message to proceed.

See Also

OnLButtonUp, OnContextMenu, OnMouseMove

Group

CXTPReportHeader Methods


CXTPReportHeader::OnLButtonUp Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::OnLButtonUp Method

Process mouse left button up clicks.

virtual void OnLButtonUp(
    UINT nFlags,
    CPoint ptClick
);
Parameters

nFlags
Indicates whether various virtual keys are down.
ptClick
Point coordinates where the message was fired from.

Remarks

Call this member function if you want Report Header to process a mouse left button up message. You should provide the method with the coordinates of the mouse message to proceed and a flag showing which of virtual keys were down.

See Also

OnLButtonDown, OnContextMenu, OnMouseMove

Group

CXTPReportHeader Methods


CXTPReportHeader::OnMouseMove Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::OnMouseMove Method

Process mouse moving.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down.
point
Point coordinates where the message was fired from.

Remarks

Call this member function if you want Report Header to process a mouse move message. You should provide the method with the coordinates of the mouse message to proceed and a flag showing which of virtual keys were down.

See Also

OnLButtonDown, OnLButtonUp, OnContextMenu

Group

CXTPReportHeader Methods


CXTPReportHeader::OnToolHitTest Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::OnToolHitTest Method

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

virtual INT_PTR OnToolHitTest(
    CPoint point,
    TOOLINFO* pTI
) const;
Parameters

point
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window
pTI
A pointer to a TOOLINFO structure.

Returns

If the tooltip control was found, the window control ID. If the tooltip control was not found, -1.

Group

CXTPReportHeader Methods


CXTPReportHeader::ResizeColumn Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::ResizeColumn Method

Resizes a provided column to a specific new width.

void ResizeColumn(
    CXTPReportColumn* pColumn,
    int nWidth
);
Parameters

pColumn
Pointer to a column to resize.
nWidth
New column width in pixels.

Remarks

This method resizes a provided column to a specific new width, and adjusts the width of other columns in correspondence with the new one.

See Also

AdjustColumnsWidth, GetMaxAvailWidth

Group

CXTPReportHeader Methods


CXTPReportHeader::SetAutoColumnSizing Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::SetAutoColumnSizing Method

Call this member to specify if AutoColumnSizing should be used.

void SetAutoColumnSizing(
    BOOL bAutoColumnSizing
);
Parameters

bAutoColumnSizing
If TRUE, all columns are sized to fill the entire width of the ReportControl. When the ReportControl is resized, the Columns will automatically be resized to fit the new size of the RepotControl. If FALSE, the columns will use the width they were assigned when they were created, or whatever value is stored in the columns width property. The columns widths my occupy more or less that the total width of the ReportControl. If the total width of the columns exceeds the width of the ReportControl, then those columns will not be visible. When the ReportControl is resized, the size of the columns will not be effected.

Group

CXTPReportHeader Methods


CXTPReportHeader::SetFilterEditCtrl Method

CXTPReportHeader Methods, CXTPReportHeader Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::SetFilterEditCtrl Method

Sets associated filter edit control.

BOOL SetFilterEditCtrl(
    CXTPReportFilterEditControl* pFilterEdit
);
Parameters

pFilterEdit
Pointer to the user's filter edit control.

Returns

TRUE if successful; otherwise FALSE.

Remarks

You should call this member function to assign the user's custom edit box control as report control filter edit control. After assigning, the framework will automatically be processing all windows messages for the control.

See Also

CXTPReportFilterEditControl overview, GetFilterEditCtrl, SetSubListCtrl

Example
CXTPReportControl wndReport;
CXTPReportFilterEditControl wndFilterEdit;
wndReport.GetReportHeader()->SetFilterEditCtrl(&wndFilterEdit);
Group

CXTPReportHeader Methods


CXTPReportHeader::SetHotDivider Method

CXTPReportHeader Methods, CXTPReportHeader Class
CXTPReportHeader::SetHotDivider Method

Sets a divider between columns.

int SetHotDivider(
    int nIndex,
    BOOL bHeader = TRUE
);
Parameters

nIndex
An index of the column to set hot divider before.
bHeader
TRUE if you want to set hot divider in columns header, FALSE to set it between on Group By area items.

Returns

An index of the column before which a hot divider was shown.

Remarks

When dragging columns, call this member function to show a hot divider (red arrows by default) between columns as a target dropping a currently dragging one.

Group

CXTPReportHeader Methods


CXTPReportHeader::SetSubListCtrl Method

CXTPReportHeader Methods, CXTPReportHeader Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::SetSubListCtrl Method

Sets associated Field chooser list control.

BOOL SetSubListCtrl(
    CXTPReportSubListControl* pSubList
);
Parameters

pSubList
Pointer to the field chooser list box control.

Returns

TRUE if successful; otherwise FALSE.

Remarks

You should call this member function to assign the user's custom List control as report control Field chooser control. After assigning, the framework will automatically be processing all windows messages from the control.

See Also

CXTPReportSubListControl overview, SetFilterEditCtrl

Example
// CXTPReportControl wndReport;
// CXTPReportSubListControl wndSubList;
wndReport.GetColumns()->GetReportHeader()->SetSubListCtrl(&wndSubList);
Group

CXTPReportHeader Methods


CXTPReportHeader::ShowItemsInGroups Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::ShowItemsInGroups Method

Sets show items in groups mode.

void ShowItemsInGroups(
    BOOL bShowInGroups
);
Parameters

bShowInGroups
TRUE for show items in groups, FALSE otherwise.

Remarks

Using this member function you can change Report Header showing items in groups mode.

See Also

IsShowItemsInGroups

Group

CXTPReportHeader Methods


CXTPReportHeader::StartDragging Method

CXTPReportHeader Methods, CXTPReportHeader Class, See Also
CXTPReportHeader::StartDragging Method

Starts column header dragging mode.

void StartDragging(
    CXTPReportColumn* pColumn,
    BOOL bHeader = FALSE
);
Parameters

pColumn
Pointer to the column, which is entering in dragging mode.
bHeader
TRUE when starting dragging for column header items, FALSE when starting dragging for Group By column items.

Remarks

Usually this method is called internally in a reaction to any specific user actions. For example when a user starts dragging header by mouse.

See Also

GetDraggingColumn, CancelMouseMode

Group

CXTPReportHeader Methods


CXTPReportHeader Constructors

CXTPReportHeader Class, Legend, Public Methods
CXTPReportHeader Constructors
Class

CXTPReportHeader Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHeader | Constructs a CXTPReportHeader object.


CXTPReportHeader::CXTPReportHeader Constructor

CXTPReportHeader Constructors, CXTPReportHeader Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeader::CXTPReportHeader Constructor

Constructs a CXTPReportHeader object.

CXTPReportHeader(
    CXTPReportControl* pControl,
    CXTPReportColumns* pColumns
);
Parameters

pControl
Pointer to the parent report control.
pColumns
Pointer to associated columns array.

Example
// Declare a local CXTPReportHeader object.
CXTPReportHeader  myHeader;

// Declare a dynamic CXTPReportHeader object.
CXTPReportHeader* pmyHeader = new CXTPReportHeader;
Group

CXTPReportHeader Constructors


CXTPReportHeader Destructors

CXTPReportHeader Class, Legend, Public Methods
CXTPReportHeader Destructors
Class

CXTPReportHeader Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportHeader | Destroys CXTPReportHeader object. Performs cleanup operations.


CXTPReportHeader::~CXTPReportHeader Destructor

CXTPReportHeader Destructors, CXTPReportHeader Class
CXTPReportHeader::~CXTPReportHeader Destructor

Destroys CXTPReportHeader object. Performs cleanup operations.

virtual ~CXTPReportHeader();
Group

CXTPReportHeader Destructors


CXTPReportHeaderDragWnd Class

XTPReportDragDrop.h, Classes, Legend, Members, Topics, CXTPReportHeaderDragWnd Data Members, CXTPReportHeaderDragWnd Methods, CXTPReportHeaderDragWnd Constructors, CXTPReportHeaderDragWnd Destructors, CXTPReportHeaderDragWnd Constructors, CXTPReportHeaderDragWnd Data Members, CXTPReportHeaderDragWnd Destructors, CXTPReportHeaderDragWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd Class

CXTPReportHeaderDragWnd is CWnd derived class, it used internally to represent dragging column window.

Class Hierarchy

class CXTPReportHeaderDragWnd : public CWnd;
File

XTPReportDragDrop.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportHeaderDragWnd Constructors
CXTPReportHeaderDragWnd Constructors | Description
CXTPReportHeaderDragWnd | Creates CXTPReportHeaderDragWnd object.
CXTPReportHeaderDragWnd Data Members
CXTPReportHeaderDragWnd Data Members | Description
m_pColumn | Pointer to the associated report column object.
m_pHeader | Pointer to the associated report header object.
m_pPaintManager | Pointer to the associated paint manager object.
CXTPReportHeaderDragWnd Destructors
CXTPReportHeaderDragWnd Destructors | Description
~CXTPReportHeaderDragWnd | Default CXTPReportHeaderDragWnd destructor.
CXTPReportHeaderDragWnd Methods
CXTPReportHeaderDragWnd Methods | Description
Create | Creates dragging window with the specified parameters.
OnDraw | Called by the framework to draw the contents of the window using the specified device context.


CXTPReportHeaderDragWnd Data Members

CXTPReportHeaderDragWnd Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd Data Members
Class

CXTPReportHeaderDragWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pColumn | Pointer to the associated report column object.
m_pHeader | Pointer to the associated report header object.
m_pPaintManager | Pointer to the associated paint manager object.


CXTPReportHeaderDragWnd::m_pColumn Data Member

CXTPReportHeaderDragWnd Data Members, CXTPReportHeaderDragWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd::m_pColumn Data Member

Pointer to the associated report column object.

CXTPReportColumn* m_pColumn;
Group

CXTPReportHeaderDragWnd Data Members


CXTPReportHeaderDragWnd::m_pHeader Data Member

CXTPReportHeaderDragWnd Data Members, CXTPReportHeaderDragWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd::m_pHeader Data Member

Pointer to the associated report header object.

CXTPReportHeader* m_pHeader;
Group

CXTPReportHeaderDragWnd Data Members


CXTPReportHeaderDragWnd::m_pPaintManager Data Member

CXTPReportHeaderDragWnd Data Members, CXTPReportHeaderDragWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd::m_pPaintManager Data Member

Pointer to the associated paint manager object.

CXTPReportPaintManager* m_pPaintManager;
Group

CXTPReportHeaderDragWnd Data Members


CXTPReportHeaderDragWnd Methods

CXTPReportHeaderDragWnd Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd Methods
Class

CXTPReportHeaderDragWnd Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnDraw | Called by the framework to draw the contents of the window using the specified device context.
Public Methods
Public Methods
Public Method | Description
Create | Creates dragging window with the specified parameters.


CXTPReportHeaderDragWnd::Create Method

CXTPReportHeaderDragWnd Methods, CXTPReportHeaderDragWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd::Create Method

Creates dragging window with the specified parameters.

virtual BOOL Create(
    CRect rect,
    CXTPReportHeader* pHeader,
    CXTPReportPaintManager* pPaintManager,
    CXTPReportColumn* pColumn
);
Parameters

rect
Drawing rectangle position.
pHeader
Pointer to parent report header object.
pPaintManager
Paint manager for performing draw operations.
pColumn
Pointer to the associated column.

Returns

TRUE if created successfully, FALSE otherwise.

Group

CXTPReportHeaderDragWnd Methods


CXTPReportHeaderDragWnd::OnDraw Method

CXTPReportHeaderDragWnd Methods, CXTPReportHeaderDragWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd::OnDraw Method

Called by the framework to draw the contents of the window using the specified device context.

virtual void OnDraw(
    CDC* pDC,
    CRect rcClient
);
Parameters

pDC
A pointer to the device context in which the drawing occurs.
rcClient
Coordinates of the client window position.

Group

CXTPReportHeaderDragWnd Methods


CXTPReportHeaderDragWnd Constructors

CXTPReportHeaderDragWnd Class, Legend, Public Methods
CXTPReportHeaderDragWnd Constructors
Class

CXTPReportHeaderDragWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHeaderDragWnd | Creates CXTPReportHeaderDragWnd object.


CXTPReportHeaderDragWnd::CXTPReportHeaderDragWnd Constructor

CXTPReportHeaderDragWnd Constructors, CXTPReportHeaderDragWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd::CXTPReportHeaderDragWnd Constructor

Creates CXTPReportHeaderDragWnd object.

CXTPReportHeaderDragWnd();
Group

CXTPReportHeaderDragWnd Constructors


CXTPReportHeaderDragWnd Destructors

CXTPReportHeaderDragWnd Class, Legend, Public Methods
CXTPReportHeaderDragWnd Destructors
Class

CXTPReportHeaderDragWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportHeaderDragWnd | Default CXTPReportHeaderDragWnd destructor.


CXTPReportHeaderDragWnd::~CXTPReportHeaderDragWnd Destructor

CXTPReportHeaderDragWnd Destructors, CXTPReportHeaderDragWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDragWnd::~CXTPReportHeaderDragWnd Destructor

Default CXTPReportHeaderDragWnd destructor.

virtual ~CXTPReportHeaderDragWnd();
Group

CXTPReportHeaderDragWnd Destructors


CXTPReportHeaderDropWnd Class

XTPReportDragDrop.h, Classes, Legend, Members, Topics, CXTPReportHeaderDropWnd Data Members, CXTPReportHeaderDropWnd Methods, CXTPReportHeaderDropWnd Constructors, CXTPReportHeaderDropWnd Destructors, CXTPReportHeaderDropWnd Constructors, CXTPReportHeaderDropWnd Data Members, CXTPReportHeaderDropWnd Destructors, CXTPReportHeaderDropWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd Class

CXTPReportHeaderDropWnd is CWnd derived class, it used internally to represent drop target arrows.

Class Hierarchy

class CXTPReportHeaderDropWnd : public CWnd;
File

XTPReportDragDrop.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportHeaderDropWnd Constructors
CXTPReportHeaderDropWnd Constructors | Description
CXTPReportHeaderDropWnd | Creates CXTPReportHeaderDropWnd object.
CXTPReportHeaderDropWnd Data Members
CXTPReportHeaderDropWnd Data Members | Description
m_clr | Drawing brush.
m_nHeight | Height of the gap between 2 arrows.
m_rgn | Arrows region.
CXTPReportHeaderDropWnd Destructors
CXTPReportHeaderDropWnd Destructors | Description
~CXTPReportHeaderDropWnd | Destroys CXTPReportHeaderDropWnd object. Performs cleanup operations.
CXTPReportHeaderDropWnd Methods
CXTPReportHeaderDropWnd Methods | Description
Create | Creates a drop window with the specified gap inside.
SetWindowPos | Changes window position.


CXTPReportHeaderDropWnd Data Members

CXTPReportHeaderDropWnd Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd Data Members
Class

CXTPReportHeaderDropWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clr | Drawing brush.
m_nHeight | Height of the gap between 2 arrows.
m_rgn | Arrows region.


CXTPReportHeaderDropWnd::m_clr Data Member

CXTPReportHeaderDropWnd Data Members, CXTPReportHeaderDropWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd::m_clr Data Member

Drawing brush.

COLORREF m_clr;
Group

CXTPReportHeaderDropWnd Data Members


CXTPReportHeaderDropWnd::m_nHeight Data Member

CXTPReportHeaderDropWnd Data Members, CXTPReportHeaderDropWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd::m_nHeight Data Member

Height of the gap between 2 arrows.

int m_nHeight;
Group

CXTPReportHeaderDropWnd Data Members


CXTPReportHeaderDropWnd::m_rgn Data Member

CXTPReportHeaderDropWnd Data Members, CXTPReportHeaderDropWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd::m_rgn Data Member

Arrows region.

CRgn m_rgn;
Group

CXTPReportHeaderDropWnd Data Members


CXTPReportHeaderDropWnd Methods

CXTPReportHeaderDropWnd Class, Legend, Public Methods
CXTPReportHeaderDropWnd Methods
Class

CXTPReportHeaderDropWnd Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Create | Creates a drop window with the specified gap inside.
SetWindowPos | Changes window position.


CXTPReportHeaderDropWnd::Create Method

CXTPReportHeaderDropWnd Methods, CXTPReportHeaderDropWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd::Create Method

Creates a drop window with the specified gap inside.

virtual BOOL Create(
    int nHeight
);
Parameters

nHeight
Height between 2 arrows in pixels.

Returns

TRUE if created successfully, FALSE otherwise.

Group

CXTPReportHeaderDropWnd Methods


CXTPReportHeaderDropWnd::SetWindowPos Method

CXTPReportHeaderDropWnd Methods, CXTPReportHeaderDropWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd::SetWindowPos Method

Changes window position.

void SetWindowPos(
    int xPos,
    int yPos
);
Parameters

xPos
New horizontal position.
yPos
New vertical position.

Group

CXTPReportHeaderDropWnd Methods


CXTPReportHeaderDropWnd Constructors

CXTPReportHeaderDropWnd Class, Legend, Public Methods
CXTPReportHeaderDropWnd Constructors
Class

CXTPReportHeaderDropWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHeaderDropWnd | Creates CXTPReportHeaderDropWnd object.


CXTPReportHeaderDropWnd::CXTPReportHeaderDropWnd Constructor

CXTPReportHeaderDropWnd Constructors, CXTPReportHeaderDropWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd::CXTPReportHeaderDropWnd Constructor

Creates CXTPReportHeaderDropWnd object.

CXTPReportHeaderDropWnd(
    COLORREF crColor
);
Parameters

crColor
Drop window color.

Group

CXTPReportHeaderDropWnd Constructors


CXTPReportHeaderDropWnd Destructors

CXTPReportHeaderDropWnd Class, Legend, Public Methods
CXTPReportHeaderDropWnd Destructors
Class

CXTPReportHeaderDropWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportHeaderDropWnd | Destroys CXTPReportHeaderDropWnd object. Performs cleanup operations.


CXTPReportHeaderDropWnd::~CXTPReportHeaderDropWnd Destructor

CXTPReportHeaderDropWnd Destructors, CXTPReportHeaderDropWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHeaderDropWnd::~CXTPReportHeaderDropWnd Destructor

Destroys CXTPReportHeaderDropWnd object. Performs cleanup operations.

virtual ~CXTPReportHeaderDropWnd();
Group

CXTPReportHeaderDropWnd Destructors


CXTPReportHyperlink Class

XTPReportHyperlink.h, Classes, Legend, Members, Topics, CXTPReportHyperlink Data Members, CXTPReportHyperlink Methods, CXTPReportHyperlink Constructors, CXTPReportHyperlink Destructors, CXTPReportHyperlink Constructors, CXTPReportHyperlink Data Members, CXTPReportHyperlink Destructors, CXTPReportHyperlink Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHyperlink Class

This class represents hyperlinks. It stores first position and length in the text for hyperlink and rectangle for drawing and identify clicks on hyperlink. To create an instance of its class, you simply call constructor with first position and length of the hyperlink's text

Class Hierarchy

class CXTPReportHyperlink : public CXTPHeapObjectT<CCmdTarget, CXTPReportDataAllocator>;
File

XTPReportHyperlink.h

Group

Classes

Legend
Data Member
Method
virtual
CXTPReportHyperlink Constructors
CXTPReportHyperlink Constructors | Description
CXTPReportHyperlink | Default CXTPReportHyperlink constructor.
CXTPReportHyperlink Data Members
CXTPReportHyperlink Data Members | Description
m_nHyperTextBegin | Start position of the hyperlink in the item text.
m_nHyperTextLen | The length of hyperlink text.
m_rcHyperSpot | Hyperlink draw place.
CXTPReportHyperlink Destructors
CXTPReportHyperlink Destructors | Description
~CXTPReportHyperlink | Destroys CXTPReportHyperlink object. Performs cleanup operations.
CXTPReportHyperlink Methods
CXTPReportHyperlink Methods | Description
DoPropExchange | Call this member function to Store/Load a report Hyperlink using the specified data object.


CXTPReportHyperlink Data Members

CXTPReportHyperlink Class, Legend, Public Data Members
CXTPReportHyperlink Data Members
Class

CXTPReportHyperlink Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_nHyperTextBegin | Start position of the hyperlink in the item text.
m_nHyperTextLen | The length of hyperlink text.
m_rcHyperSpot | Hyperlink draw place.


CXTPReportHyperlink::m_nHyperTextBegin Data Member

CXTPReportHyperlink Data Members, CXTPReportHyperlink Class
CXTPReportHyperlink::m_nHyperTextBegin Data Member

Start position of the hyperlink in the item text.

int m_nHyperTextBegin;
Group

CXTPReportHyperlink Data Members


CXTPReportHyperlink::m_nHyperTextLen Data Member

CXTPReportHyperlink Data Members, CXTPReportHyperlink Class
CXTPReportHyperlink::m_nHyperTextLen Data Member

The length of hyperlink text.

int m_nHyperTextLen;
Group

CXTPReportHyperlink Data Members


CXTPReportHyperlink::m_rcHyperSpot Data Member

CXTPReportHyperlink Data Members, CXTPReportHyperlink Class
CXTPReportHyperlink::m_rcHyperSpot Data Member

Hyperlink draw place.

CRect m_rcHyperSpot;
Group

CXTPReportHyperlink Data Members


CXTPReportHyperlink Methods

CXTPReportHyperlink Class, Legend, Public Methods
CXTPReportHyperlink Methods
Class

CXTPReportHyperlink Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Call this member function to Store/Load a report Hyperlink using the specified data object.


CXTPReportHyperlink::DoPropExchange Method

CXTPReportHyperlink Methods, CXTPReportHyperlink Class
CXTPReportHyperlink::DoPropExchange Method

Call this member function to Store/Load a report Hyperlink using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Group

CXTPReportHyperlink Methods


CXTPReportHyperlink Constructors

CXTPReportHyperlink Class, Legend, Public Methods
CXTPReportHyperlink Constructors
Class

CXTPReportHyperlink Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHyperlink | Default CXTPReportHyperlink constructor.


CXTPReportHyperlink::CXTPReportHyperlink Constructor

CXTPReportHyperlink Constructors, CXTPReportHyperlink Class
CXTPReportHyperlink::CXTPReportHyperlink Constructor

Default CXTPReportHyperlink constructor.

CXTPReportHyperlink(
    int nHyperTextBegin = 0,
    int nHyperTextLen = 0
);
Parameters

nHyperTextBegin
Begin position of the hyperlink item text in the parent item caption.
nHyperTextLen
Hyperlink item text length.

Group

CXTPReportHyperlink Constructors


CXTPReportHyperlink Destructors

CXTPReportHyperlink Class, Legend, Public Methods
CXTPReportHyperlink Destructors
Class

CXTPReportHyperlink Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportHyperlink | Destroys CXTPReportHyperlink object. Performs cleanup operations.


CXTPReportHyperlink::~CXTPReportHyperlink Destructor

CXTPReportHyperlink Destructors, CXTPReportHyperlink Class
CXTPReportHyperlink::~CXTPReportHyperlink Destructor

Destroys CXTPReportHyperlink object. Performs cleanup operations.

virtual ~CXTPReportHyperlink();
Group

CXTPReportHyperlink Destructors


CXTPReportHyperlinks Class

XTPReportHyperlink.h, Classes, Legend, Members, Topics, CXTPReportHyperlinks Methods, CXTPReportHyperlinks Constructors, CXTPReportHyperlinks Destructors, CXTPReportHyperlinks Constructors, CXTPReportHyperlinks Destructors, CXTPReportHyperlinks Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHyperlinks Class

This class represents array of pointers to CXTPReportHyperlink objects. InternalRelease is called for each item in the array destructor. Also serialization for array items is provided (see DoPropExchange method).

Class Hierarchy

class CXTPReportHyperlinks : public CXTPHeapObjectT<CXTPReportHyperlinks_base, CXTPReportDataAllocator>;
File

XTPReportHyperlink.h

Group

Classes

Legend
Method
virtual
CXTPReportHyperlinks Constructors
CXTPReportHyperlinks Constructors | Description
CXTPReportHyperlinks | Default CXTPReportHyperlink constructor.
CXTPReportHyperlinks Destructors
CXTPReportHyperlinks Destructors | Description
~CXTPReportHyperlinks | Default CXTPReportHyperlink destructor.
CXTPReportHyperlinks Methods
CXTPReportHyperlinks Methods | Description
CopyFrom | This method copy all members from specified source object.
DoPropExchange | Call this member function to Store/Load a report Hyperlink items using the specified data object.
RemoveAll | Remove all items from the collection.
RemoveAt | Remove hyperlink at the specified index.


CXTPReportHyperlinks Methods

CXTPReportHyperlinks Class, Legend, Public Methods
CXTPReportHyperlinks Methods
Class

CXTPReportHyperlinks Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
CopyFrom | This method copy all members from specified source object.
DoPropExchange | Call this member function to Store/Load a report Hyperlink items using the specified data object.
RemoveAll | Remove all items from the collection.
RemoveAt | Remove hyperlink at the specified index.


CXTPReportHyperlinks::CopyFrom Method

CXTPReportHyperlinks Methods, CXTPReportHyperlinks Class
CXTPReportHyperlinks::CopyFrom Method

This method copy all members from specified source object.

virtual void CopyFrom(
    CXTPReportHyperlinks* pSrc
);
Parameters

pSrc
pointer to a source object.

Group

CXTPReportHyperlinks Methods


CXTPReportHyperlinks::DoPropExchange Method

CXTPReportHyperlinks Methods, CXTPReportHyperlinks Class
CXTPReportHyperlinks::DoPropExchange Method

Call this member function to Store/Load a report Hyperlink items using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Group

CXTPReportHyperlinks Methods


CXTPReportHyperlinks::RemoveAll Method

CXTPReportHyperlinks Methods, CXTPReportHyperlinks Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHyperlinks::RemoveAll Method

Remove all items from the collection.

virtual void RemoveAll();
See Also

RemoveAt, CXTPReportHyperlink, CXTPArrayT

Group

CXTPReportHyperlinks Methods


CXTPReportHyperlinks::RemoveAt Method

CXTPReportHyperlinks Methods, CXTPReportHyperlinks Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHyperlinks::RemoveAt Method

Remove hyperlink at the specified index.

virtual void RemoveAt(
    int nIndex
);
Parameters

nIndex
A zero based index to remove item.

See Also

CXTPReportHyperlink, CXTPArrayT

Group

CXTPReportHyperlinks Methods


CXTPReportHyperlinks Constructors

CXTPReportHyperlinks Class, Legend, Public Methods
CXTPReportHyperlinks Constructors
Class

CXTPReportHyperlinks Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHyperlinks | Default CXTPReportHyperlink constructor.


CXTPReportHyperlinks::CXTPReportHyperlinks Constructor

CXTPReportHyperlinks Constructors, CXTPReportHyperlinks Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportHyperlinks::CXTPReportHyperlinks Constructor

Default CXTPReportHyperlink constructor.

CXTPReportHyperlinks();
Group

CXTPReportHyperlinks Constructors


CXTPReportHyperlinks Destructors

CXTPReportHyperlinks Class, Legend, Public Methods
CXTPReportHyperlinks Destructors
Class

CXTPReportHyperlinks Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportHyperlinks | Default CXTPReportHyperlink destructor.


CXTPReportHyperlinks::~CXTPReportHyperlinks Destructor

CXTPReportHyperlinks Destructors, CXTPReportHyperlinks Class
CXTPReportHyperlinks::~CXTPReportHyperlinks Destructor

Default CXTPReportHyperlink destructor.

virtual ~CXTPReportHyperlinks();
Group

CXTPReportHyperlinks Destructors


CXTPReportInplaceButton Class

XTPReportInplaceControls.h, Classes, Legend, Members, Topics, CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Methods, CXTPReportInplaceButton Constructors, CXTPReportInplaceButton Constructors, CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton Class

CXTPReportInplaceButton is the CXTPReportInplaceControl derived class, it represents combo button and expand button of report cell.

Class Hierarchy

class CXTPReportInplaceButton : public CStatic, public CXTPReportInplaceControl;
File

XTPReportInplaceControls.h

Group

Classes

Legend
Data Member
protected
Method
CXTPReportInplaceButton Constructors
CXTPReportInplaceButton Constructors | Description
CXTPReportInplaceButton | Constructs a CXTPReportInplaceButton object
CXTPReportInplaceButton Data Members
CXTPReportInplaceButton Data Members | Description
m_bInsideCell | Store button place: inside the cell rect, or outside.
m_bOver | TRUE if the mouse cursor is over the button.
m_bPressed | TRUE if the button is pressed.
m_nFixedHeight | Width of the button.
m_nIconIndex | Icon index.
m_nID | Identifier of the button.
m_nSpinIncrement | Spin button only: increment value.
m_nSpinMax | Spin button only: maximum value.
m_nSpinMin | Spin button only: minimum value.
m_nSpinStep | Spin button only: step value.
m_nState | Button state.
m_nWidth | Width of the button.
m_unSpinTimerCnt | Spin button only: timer counter.
m_unSpinTimerId | Spin button only: timer identifier.
CXTPReportInplaceButton Methods
CXTPReportInplaceButton Methods | Description
Create | Call this method to create in-place button control.
GetIconIndex | Retrieves the icon index for the button.
GetID | Retrieves identifier of the button
GetItem | This member function retrieves a child report control item.
GetSpinButtonMax | Retrieves the spin button properties.
GetSpinButtonMin | Retrieves the spin button properties.
GetSpinButtonStep | Retrieves the spin button properties.
GetState | Call this method to determine the button state.
GetWidth | Retrieves button width.
IsInsideCellButton | Call this method to determine if button placed inside the cell rect, or outside (near right cell side).
IsPressed | Call this method to determine if user pressed the button.
SetIconIndex | Sets the icon index for the button.
SetInsideCellButton | Call this method to set button place inside the cell rect, or outside (near right cell side).
SetSpinButtonMax | Use these member functions to set spin button properties.
SetSpinButtonMin | Use these member functions to set spin button properties.
SetSpinButtonStep | Use these member functions to set spin button properties.


CXTPReportInplaceButton Data Members

CXTPReportInplaceButton Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton Data Members
Class

CXTPReportInplaceButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bInsideCell | Store button place: inside the cell rect, or outside.
m_bOver | TRUE if the mouse cursor is over the button.
m_bPressed | TRUE if the button is pressed.
m_nFixedHeight | Width of the button.
m_nIconIndex | Icon index.
m_nID | Identifier of the button.
m_nSpinIncrement | Spin button only: increment value.
m_nSpinMax | Spin button only: maximum value.
m_nSpinMin | Spin button only: minimum value.
m_nSpinStep | Spin button only: step value.
m_nState | Button state.
m_nWidth | Width of the button.
m_unSpinTimerCnt | Spin button only: timer counter.
m_unSpinTimerId | Spin button only: timer identifier.


CXTPReportInplaceButton::m_bInsideCell Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_bInsideCell Data Member

Store button place: inside the cell rect, or outside.

BOOL m_bInsideCell;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_bOver Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_bOver Data Member

TRUE if the mouse cursor is over the button.

BOOL m_bOver;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_bPressed Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_bPressed Data Member

TRUE if the button is pressed.

BOOL m_bPressed;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nFixedHeight Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nFixedHeight Data Member

Width of the button.

int m_nFixedHeight;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nIconIndex Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nIconIndex Data Member

Icon index.

int m_nIconIndex;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nID Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nID Data Member

Identifier of the button.

int m_nID;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nSpinIncrement Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nSpinIncrement Data Member

Spin button only: increment value.

int m_nSpinIncrement;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nSpinMax Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nSpinMax Data Member

Spin button only: maximum value.

int m_nSpinMax;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nSpinMin Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nSpinMin Data Member

Spin button only: minimum value.

int m_nSpinMin;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nSpinStep Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nSpinStep Data Member

Spin button only: step value.

int m_nSpinStep;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nState Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nState Data Member

Button state.

int m_nState;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_nWidth Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_nWidth Data Member

Width of the button.

int m_nWidth;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_unSpinTimerCnt Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_unSpinTimerCnt Data Member

Spin button only: timer counter.

UINT_PTR m_unSpinTimerCnt;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton::m_unSpinTimerId Data Member

CXTPReportInplaceButton Data Members, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::m_unSpinTimerId Data Member

Spin button only: timer identifier.

UINT_PTR m_unSpinTimerId;
Group

CXTPReportInplaceButton Data Members


CXTPReportInplaceButton Methods

CXTPReportInplaceButton Class, Legend, Public Methods
CXTPReportInplaceButton Methods
Class

CXTPReportInplaceButton Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Create | Call this method to create in-place button control.
GetIconIndex | Retrieves the icon index for the button.
GetID | Retrieves identifier of the button
GetItem | This member function retrieves a child report control item.
GetSpinButtonMax | Retrieves the spin button properties.
GetSpinButtonMin | Retrieves the spin button properties.
GetSpinButtonStep | Retrieves the spin button properties.
GetState | Call this method to determine the button state.
GetWidth | Retrieves button width.
IsInsideCellButton | Call this method to determine if button placed inside the cell rect, or outside (near right cell side).
IsPressed | Call this method to determine if user pressed the button.
SetIconIndex | Sets the icon index for the button.
SetInsideCellButton | Call this method to set button place inside the cell rect, or outside (near right cell side).
SetSpinButtonMax | Use these member functions to set spin button properties.
SetSpinButtonMin | Use these member functions to set spin button properties.
SetSpinButtonStep | Use these member functions to set spin button properties.


CXTPReportInplaceButton::Create Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::Create Method

Call this method to create in-place button control.

void Create(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    CRect& rcButtons
);
Parameters

pItemArgs
Parameters of item cell.
rcButtons
Bounding rectangle of the button

Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::GetIconIndex Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::GetIconIndex Method

Retrieves the icon index for the button.

int GetIconIndex();
Returns

Icon index.

See Also

SetIconIndex

Body Source
int CXTPReportInplaceButton::GetIconIndex() {
    return m_nIconIndex;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::GetID Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::GetID Method

Retrieves identifier of the button

int GetID() const;
Returns

Identifier of the button.

Body Source
int CXTPReportInplaceButton::GetID() const {
    return m_nID;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::GetItem Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::GetItem Method

This member function retrieves a child report control item.

CXTPReportRecordItem* GetItem() const;
Returns

A pointer to a CXTPReportRecordItem

Body Source
CXTPReportRecordItem* CXTPReportInplaceButton::GetItem() const {
    return pItem;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::GetSpinButtonMin Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::GetSpinButtonMin Method

Retrieves the spin button properties.

int GetSpinButtonMin();
int GetSpinButtonMax();
int GetSpinButtonStep();
Returns

The requested value.

See Also

SetSpinButtonMin, SetSpinButtonMax, SetSpinButtonStep

Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::GetState Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::GetState Method

Call this method to determine the button state.

int GetState() const;
Returns

The button state.

Body Source
int CXTPReportInplaceButton::GetState() const {
    return m_bOver ? m_nState : 0;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::GetWidth Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::GetWidth Method

Retrieves button width.

int GetWidth();
Returns

A width of the button.

Body Source
int CXTPReportInplaceButton::GetWidth() {
    return m_nWidth;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::IsInsideCellButton Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::IsInsideCellButton Method

Call this method to determine if button placed inside the cell rect, or outside (near right cell side).

BOOL IsInsideCellButton() const;
Returns

TRUE if button is inside cell, FALSE otherwise.

Body Source
BOOL CXTPReportInplaceButton::IsInsideCellButton() const {
    return m_bInsideCell;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::IsPressed Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::IsPressed Method

Call this method to determine if user pressed the button.

BOOL IsPressed() const;
Returns

TRUE if user pressed the button.

Body Source
BOOL CXTPReportInplaceButton::IsPressed() const {
    return m_bPressed && m_bOver;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::SetIconIndex Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::SetIconIndex Method

Sets the icon index for the button.

void SetIconIndex(
    int nIconIndex
);
Parameters

nIconIndex
icon index.

See Also

GetIconIndex

Body Source
void CXTPReportInplaceButton::SetIconIndex(int nIconIndex) {
    m_nIconIndex  = nIconIndex;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::SetInsideCellButton Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::SetInsideCellButton Method

Call this method to set button place inside the cell rect, or outside (near right cell side).

void SetInsideCellButton(
    BOOL bInsideCell
);
Parameters

bInsideCell
TRUE if button is inside cell, FALSE otherwise.

Body Source
void CXTPReportInplaceButton::SetInsideCellButton(BOOL bInsideCell) {
    m_bInsideCell = bInsideCell;
}
Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton::SetSpinButtonMin Method

CXTPReportInplaceButton Methods, CXTPReportInplaceButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::SetSpinButtonMin Method

Use these member functions to set spin button properties.

void SetSpinButtonMin(
    int nValue
);
void SetSpinButtonMax(
    int nValue
);
void SetSpinButtonStep(
    int nValue
);
Parameters

nValue
New Property value.

See Also

GetSpinButtonMin, GetSpinButtonMax, GetSpinButtonStep

Group

CXTPReportInplaceButton Methods


CXTPReportInplaceButton Constructors

CXTPReportInplaceButton Class, Legend, Public Methods
CXTPReportInplaceButton Constructors
Class

CXTPReportInplaceButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceButton | Constructs a CXTPReportInplaceButton object


CXTPReportInplaceButton::CXTPReportInplaceButton Constructor

CXTPReportInplaceButton Constructors, CXTPReportInplaceButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButton::CXTPReportInplaceButton Constructor

Constructs a CXTPReportInplaceButton object

CXTPReportInplaceButton(
    UINT nID
);
Parameters

nID
Identifier of in-place button. Can be any of the values listed in the Remarks section.

Remarks

Default identifiers are:

  • XTP_ID_REPORT_EXPANDBUTTON Indicates the button acts like an expand button
  • XTP_ID_REPORT_COMBOBUTTON Indicates the button acts like a combo button.
  • XTP_ID_REPORT_SPINBUTTON Indicates the button acts like a spin button.
Group

CXTPReportInplaceButton Constructors


CXTPReportInplaceButtons Class

XTPReportRecordItem.h, Classes, Legend, Members, Topics, CXTPReportInplaceButtons Constructors, CXTPReportInplaceButtons Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButtons Class

This class represents collection of the in-place buttons of the single item of the report control.

Class Hierarchy

class CXTPReportInplaceButtons : public CArray<CXTPReportInplaceButton*, CXTPReportInplaceButton*>;
File

XTPReportRecordItem.h

Group

Classes

Legend
Constructor
CXTPReportInplaceButtons Constructors
CXTPReportInplaceButtons Constructors | Description
CXTPReportInplaceButtons | Constructs a CXTPReportInplaceButtons object


CXTPReportInplaceButtons Constructors

CXTPReportInplaceButtons Class, Legend, Public Methods
CXTPReportInplaceButtons Constructors
Class

CXTPReportInplaceButtons Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceButtons | Constructs a CXTPReportInplaceButtons object


CXTPReportInplaceButtons::CXTPReportInplaceButtons Constructor

CXTPReportInplaceButtons Constructors, CXTPReportInplaceButtons Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceButtons::CXTPReportInplaceButtons Constructor

Constructs a CXTPReportInplaceButtons object

CXTPReportInplaceButtons();
Group

CXTPReportInplaceButtons Constructors


CXTPReportInplaceControl Class

XTPReportInplaceControls.h, Classes, Legend, Members, Topics, CXTPReportInplaceControl Methods, CXTPReportInplaceControl Constructors, CXTPReportInplaceControl Destructors, CXTPReportInplaceControl Constructors, CXTPReportInplaceControl Destructors, CXTPReportInplaceControl Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceControl Class

CXTPReportInplaceControl is the base class for all in-place controls of report control item.

Class Hierarchy

class CXTPReportInplaceControl : public XTP_REPORTRECORDITEM_ARGS;
File

XTPReportInplaceControls.h

Remarks

There are 3 built-in in-place controls for Report control item:

  • CXTPReportInplaceEdit - represents edit control to allow users change cell of report control
  • CXTPReportInplaceButton - represents single button of item.
  • CXTPReportInplaceList - represents in-place list box to allow user select constraints of report item
See Also

CXTPReportInplaceEdit, CXTPReportInplaceButton, CXTPReportInplaceList

Group

Classes

Legend
Method
protected
virtual
CXTPReportInplaceControl Constructors
CXTPReportInplaceControl Constructors | Description
CXTPReportInplaceControl | Constructs a CXTPPropertyGridInplaceList object
CXTPReportInplaceControl Destructors
CXTPReportInplaceControl Destructors | Description
~CXTPReportInplaceControl | Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.
CXTPReportInplaceControl Methods
CXTPReportInplaceControl Methods | Description
SetItemArgs | This method is called internal to fill item arguments of in-place control


CXTPReportInplaceControl Methods

CXTPReportInplaceControl Class, Legend, Protected Methods
CXTPReportInplaceControl Methods
Class

CXTPReportInplaceControl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
SetItemArgs | This method is called internal to fill item arguments of in-place control


CXTPReportInplaceControl::SetItemArgs Method

CXTPReportInplaceControl Methods, CXTPReportInplaceControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceControl::SetItemArgs Method

This method is called internal to fill item arguments of in-place control

virtual void SetItemArgs(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Arguments of item.

Group

CXTPReportInplaceControl Methods


CXTPReportInplaceControl Constructors

CXTPReportInplaceControl Class, Legend, Public Methods
CXTPReportInplaceControl Constructors
Class

CXTPReportInplaceControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceControl | Constructs a CXTPPropertyGridInplaceList object


CXTPReportInplaceControl::CXTPReportInplaceControl Constructor

CXTPReportInplaceControl Constructors, CXTPReportInplaceControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceControl::CXTPReportInplaceControl Constructor

Constructs a CXTPPropertyGridInplaceList object

CXTPReportInplaceControl();
Group

CXTPReportInplaceControl Constructors


CXTPReportInplaceControl Destructors

CXTPReportInplaceControl Class, Legend, Public Methods
CXTPReportInplaceControl Destructors
Class

CXTPReportInplaceControl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportInplaceControl | Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.


CXTPReportInplaceControl::~CXTPReportInplaceControl Destructor

CXTPReportInplaceControl Destructors, CXTPReportInplaceControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceControl::~CXTPReportInplaceControl Destructor

Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.

virtual ~CXTPReportInplaceControl();
Group

CXTPReportInplaceControl Destructors


CXTPReportInplaceEdit Class

XTPReportInplaceControls.h, Classes, Legend, Members, Topics, CXTPReportInplaceEdit Data Members, CXTPReportInplaceEdit Methods, CXTPReportInplaceEdit Constructors, CXTPReportInplaceEdit Destructors, CXTPReportInplaceEdit Constructors, CXTPReportInplaceEdit Data Members, CXTPReportInplaceEdit Destructors, CXTPReportInplaceEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit Class

CXTPReportInplaceEdit is the CXTPReportInplaceControl derived class, it represents edit control to allow users change cell of report control.

Class Hierarchy

class CXTPReportInplaceEdit : public CEdit, public CXTPReportInplaceControl;
File

XTPReportInplaceControls.h

Group

Classes

Legend
Data Member
protected
Method
CXTPReportInplaceEdit Constructors
CXTPReportInplaceEdit Constructors | Description
CXTPReportInplaceEdit | Constructs a CXTPReportInplaceEdit object
CXTPReportInplaceEdit Data Members
CXTPReportInplaceEdit Data Members | Description
m_bSetWindowText | Indicates that text is being set with SetWindowText function.
m_clrText | Text color of in-place edit.
m_fntEdit | Font of in-place edit.
m_pSelectedConstraint | Selected constraint.
m_strText_prev | The text value from previous change.
m_strValue | The value of item before user change it.
CXTPReportInplaceEdit Destructors
CXTPReportInplaceEdit Destructors | Description
~CXTPReportInplaceEdit | Destroys a CXTPReportInplaceEdit object, handles cleanup and deallocation.
CXTPReportInplaceEdit Methods
CXTPReportInplaceEdit Methods | Description
Create | Call this method to create in-place edit control.
GetItem | This member function retrieves a child report control item
HideWindow | This method is called to hide in-place edit control
SetFont | This method is called to change font of in-place edit control
SetWindowText | Call this method to set edit text.


CXTPReportInplaceEdit Data Members

CXTPReportInplaceEdit Class, Legend, Protected Data Members
CXTPReportInplaceEdit Data Members
Class

CXTPReportInplaceEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bSetWindowText | Indicates that text is being set with SetWindowText function.
m_clrText | Text color of in-place edit.
m_fntEdit | Font of in-place edit.
m_pSelectedConstraint | Selected constraint.
m_strText_prev | The text value from previous change.
m_strValue | The value of item before user change it.


CXTPReportInplaceEdit::m_bSetWindowText Data Member

CXTPReportInplaceEdit Data Members, CXTPReportInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::m_bSetWindowText Data Member

Indicates that text is being set with SetWindowText function.

BOOL m_bSetWindowText;
Group

CXTPReportInplaceEdit Data Members


CXTPReportInplaceEdit::m_clrText Data Member

CXTPReportInplaceEdit Data Members, CXTPReportInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::m_clrText Data Member

Text color of in-place edit.

COLORREF m_clrText;
Group

CXTPReportInplaceEdit Data Members


CXTPReportInplaceEdit::m_fntEdit Data Member

CXTPReportInplaceEdit Data Members, CXTPReportInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::m_fntEdit Data Member

Font of in-place edit.

CFont m_fntEdit;
Group

CXTPReportInplaceEdit Data Members


CXTPReportInplaceEdit::m_pSelectedConstraint Data Member

CXTPReportInplaceEdit Data Members, CXTPReportInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::m_pSelectedConstraint Data Member

Selected constraint.

CXTPReportRecordItemConstraint* m_pSelectedConstraint;
Group

CXTPReportInplaceEdit Data Members


CXTPReportInplaceEdit::m_strText_prev Data Member

CXTPReportInplaceEdit Data Members, CXTPReportInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::m_strText_prev Data Member

The text value from previous change.

CString m_strText_prev;
Group

CXTPReportInplaceEdit Data Members


CXTPReportInplaceEdit::m_strValue Data Member

CXTPReportInplaceEdit Data Members, CXTPReportInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::m_strValue Data Member

The value of item before user change it.

CString m_strValue;
Group

CXTPReportInplaceEdit Data Members


CXTPReportInplaceEdit Methods

CXTPReportInplaceEdit Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit Methods
Class

CXTPReportInplaceEdit Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
SetFont | This method is called to change font of in-place edit control
Public Methods
Public Methods
Public Method | Description
Create | Call this method to create in-place edit control.
GetItem | This member function retrieves a child report control item
HideWindow | This method is called to hide in-place edit control
SetWindowText | Call this method to set edit text.


CXTPReportInplaceEdit::Create Method

CXTPReportInplaceEdit Methods, CXTPReportInplaceEdit Class
CXTPReportInplaceEdit::Create Method

Call this method to create in-place edit control.

void Create(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Parameters of item cell.

Group

CXTPReportInplaceEdit Methods


CXTPReportInplaceEdit::GetItem Method

CXTPReportInplaceEdit Methods, CXTPReportInplaceEdit Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::GetItem Method

This member function retrieves a child report control item

CXTPReportRecordItem* GetItem() const;
Returns

A pointer to a CXTPReportRecordItem

Body Source
CXTPReportRecordItem* CXTPReportInplaceEdit::GetItem() const {
    return pItem;
}
Group

CXTPReportInplaceEdit Methods


CXTPReportInplaceEdit::HideWindow Method

CXTPReportInplaceEdit Methods, CXTPReportInplaceEdit Class
CXTPReportInplaceEdit::HideWindow Method

This method is called to hide in-place edit control

void HideWindow();
Group

CXTPReportInplaceEdit Methods


CXTPReportInplaceEdit::SetFont Method

CXTPReportInplaceEdit Methods, CXTPReportInplaceEdit Class
CXTPReportInplaceEdit::SetFont Method

This method is called to change font of in-place edit control

void SetFont(
    CFont* pFont
);
Parameters

pFont
New font to be set.

Group

CXTPReportInplaceEdit Methods


CXTPReportInplaceEdit::SetWindowText Method

CXTPReportInplaceEdit Methods, CXTPReportInplaceEdit Class
CXTPReportInplaceEdit::SetWindowText Method

Call this method to set edit text.

void SetWindowText(
    LPCTSTR lpszString
);
Parameters

lpszString
String to set.

Group

CXTPReportInplaceEdit Methods


CXTPReportInplaceEdit Constructors

CXTPReportInplaceEdit Class, Legend, Public Methods
CXTPReportInplaceEdit Constructors
Class

CXTPReportInplaceEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceEdit | Constructs a CXTPReportInplaceEdit object


CXTPReportInplaceEdit::CXTPReportInplaceEdit Constructor

CXTPReportInplaceEdit Constructors, CXTPReportInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::CXTPReportInplaceEdit Constructor

Constructs a CXTPReportInplaceEdit object

CXTPReportInplaceEdit();
Group

CXTPReportInplaceEdit Constructors


CXTPReportInplaceEdit Destructors

CXTPReportInplaceEdit Class, Legend, Public Methods
CXTPReportInplaceEdit Destructors
Class

CXTPReportInplaceEdit Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportInplaceEdit | Destroys a CXTPReportInplaceEdit object, handles cleanup and deallocation.


CXTPReportInplaceEdit::~CXTPReportInplaceEdit Destructor

CXTPReportInplaceEdit Destructors, CXTPReportInplaceEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceEdit::~CXTPReportInplaceEdit Destructor

Destroys a CXTPReportInplaceEdit object, handles cleanup and deallocation.

~CXTPReportInplaceEdit();
Group

CXTPReportInplaceEdit Destructors


CXTPReportInplaceList Class

XTPReportInplaceControls.h, Classes, Legend, Members, Topics, CXTPReportInplaceList Methods, CXTPReportInplaceList Constructors, CXTPReportInplaceList Constructors, CXTPReportInplaceList Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceList Class

CXTPReportInplaceList is the CXTPReportInplaceControl derived class, it represents list box with constraints of item.

Class Hierarchy

class CXTPReportInplaceList : public CListBox, public CXTPReportInplaceControl;
File

XTPReportInplaceControls.h

See Also

CXTPReportRecordItemConstraints

Group

Classes

Legend
Method
protected
virtual
CXTPReportInplaceList Constructors
CXTPReportInplaceList Constructors | Description
CXTPReportInplaceList | Constructs a CXTPReportInplaceList object
CXTPReportInplaceList Methods
CXTPReportInplaceList Methods | Description
Apply | This method is called to save selected value of list box.
Cancel | This method is called to cancel user selection.
Create | Call this method to create in-place list control.
OnSelectionChanged | This method is called internally to react on selection changing.
SetItemArgs | This method is called internal to fill item arguments of in-place control


CXTPReportInplaceList Methods

CXTPReportInplaceList Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceList Methods
Class

CXTPReportInplaceList Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnSelectionChanged | This method is called internally to react on selection changing.
SetItemArgs | This method is called internal to fill item arguments of in-place control
Public Methods
Public Methods
Public Method | Description
Apply | This method is called to save selected value of list box.
Cancel | This method is called to cancel user selection.
Create | Call this method to create in-place list control.


CXTPReportInplaceList::Apply Method

CXTPReportInplaceList Methods, CXTPReportInplaceList Class
CXTPReportInplaceList::Apply Method

This method is called to save selected value of list box.

void Apply();
Group

CXTPReportInplaceList Methods


CXTPReportInplaceList::Cancel Method

CXTPReportInplaceList Methods, CXTPReportInplaceList Class
CXTPReportInplaceList::Cancel Method

This method is called to cancel user selection.

void Cancel();
Group

CXTPReportInplaceList Methods


CXTPReportInplaceList::Create Method

CXTPReportInplaceList Methods, CXTPReportInplaceList Class
CXTPReportInplaceList::Create Method

Call this method to create in-place list control.

void Create(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    CXTPReportRecordItemConstraints* pConstaints
);
Parameters

pItemArgs
Parameters of item cell.
pConstaints
constraints of item

Group

CXTPReportInplaceList Methods


CXTPReportInplaceList::OnSelectionChanged Method

CXTPReportInplaceList Methods, CXTPReportInplaceList Class
CXTPReportInplaceList::OnSelectionChanged Method

This method is called internally to react on selection changing.

virtual void OnSelectionChanged(
    int nLBIndex
);
Parameters

nLBIndex
An index of the selected item in the list.

Group

CXTPReportInplaceList Methods


CXTPReportInplaceList::SetItemArgs Method

CXTPReportInplaceList Methods, CXTPReportInplaceList Class
CXTPReportInplaceList::SetItemArgs Method

This method is called internal to fill item arguments of in-place control

virtual void SetItemArgs(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Arguments of item.

Group

CXTPReportInplaceList Methods


CXTPReportInplaceList Constructors

CXTPReportInplaceList Class, Legend, Public Methods
CXTPReportInplaceList Constructors
Class

CXTPReportInplaceList Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceList | Constructs a CXTPReportInplaceList object


CXTPReportInplaceList::CXTPReportInplaceList Constructor

CXTPReportInplaceList Constructors, CXTPReportInplaceList Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportInplaceList::CXTPReportInplaceList Constructor

Constructs a CXTPReportInplaceList object

CXTPReportInplaceList();
Group

CXTPReportInplaceList Constructors


CXTPReportPageSetupDialog Class

XTPReportView.h, Classes, Legend, Members, Topics, CXTPReportPageSetupDialog Data Members, CXTPReportPageSetupDialog Methods, CXTPReportPageSetupDialog Constructors, CXTPReportPageSetupDialog Destructors, CXTPReportPageSetupDialog Constructors, CXTPReportPageSetupDialog Data Members, CXTPReportPageSetupDialog Destructors, CXTPReportPageSetupDialog Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPageSetupDialog Class

Customized Calendar control page setup dialog.

Class Hierarchy

class CXTPReportPageSetupDialog : public CPageSetupDialog;
File

XTPReportView.h

Remarks

Use this class when you want to allow user to customize printing options for the Calendar control.

This class enhances standard MFC page setup dialog, which encapsulates the services provided by the Windows common OLE Page Setup dialog box with additional support for setting and modifying print margins. This class is designed to take the place of the Print Setup dialog box.

See Also

CXTPReportViewPrintOptions overview, CPageSetupDialog overview

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportPageSetupDialog Constructors
CXTPReportPageSetupDialog Constructors | Description
CXTPReportPageSetupDialog | Class constructor.
CXTPReportPageSetupDialog Data Members
CXTPReportPageSetupDialog Data Members | Description
m_pOptions | Pointer to associated print options object.
CXTPReportPageSetupDialog Destructors
CXTPReportPageSetupDialog Destructors | Description
~CXTPReportPageSetupDialog | Default class constructor, handles members cleanup.
CXTPReportPageSetupDialog Methods
CXTPReportPageSetupDialog Methods | Description
OnInitDialog | Dialog-box initialization.
OnOK | Called when the user clicks the OK button (the button with an ID of IDOK).


CXTPReportPageSetupDialog Data Members

CXTPReportPageSetupDialog Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPageSetupDialog Data Members
Class

CXTPReportPageSetupDialog Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pOptions | Pointer to associated print options object.


CXTPReportPageSetupDialog::m_pOptions Data Member

CXTPReportPageSetupDialog Data Members, CXTPReportPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPageSetupDialog::m_pOptions Data Member

Pointer to associated print options object.

CXTPReportViewPrintOptions* m_pOptions;
Group

CXTPReportPageSetupDialog Data Members


CXTPReportPageSetupDialog Methods

CXTPReportPageSetupDialog Class, Legend, Protected Methods
CXTPReportPageSetupDialog Methods
Class

CXTPReportPageSetupDialog Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnInitDialog | Dialog-box initialization.
OnOK | Called when the user clicks the OK button (the button with an ID of IDOK).


CXTPReportPageSetupDialog::OnInitDialog Method

CXTPReportPageSetupDialog Methods, CXTPReportPageSetupDialog Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPageSetupDialog::OnInitDialog Method

Dialog-box initialization.

virtual BOOL OnInitDialog();
Returns

FALSE because it has explicitly set the input focus to one of the controls in the dialog box.

See Also

CPageSetupDialog::OnInitDialog().

Group

CXTPReportPageSetupDialog Methods


CXTPReportPageSetupDialog::OnOK Method

CXTPReportPageSetupDialog Methods, CXTPReportPageSetupDialog Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPageSetupDialog::OnOK Method

Called when the user clicks the OK button (the button with an ID of IDOK).

virtual void OnOK();
Remarks

Saves all values into m_pOptions structure.

See Also

CPageSetupDialog::OnOK().

Group

CXTPReportPageSetupDialog Methods


CXTPReportPageSetupDialog Constructors

CXTPReportPageSetupDialog Class, Legend, Public Methods
CXTPReportPageSetupDialog Constructors
Class

CXTPReportPageSetupDialog Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportPageSetupDialog | Class constructor.


CXTPReportPageSetupDialog::CXTPReportPageSetupDialog Constructor

CXTPReportPageSetupDialog Constructors, CXTPReportPageSetupDialog Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPageSetupDialog::CXTPReportPageSetupDialog Constructor

Class constructor.

CXTPReportPageSetupDialog(
    CXTPReportViewPrintOptions* pOptions,
    DWORD dwFlags = PSD_MARGINS | PSD_INWININIINTLMEASURE,
    CWnd* pParentWnd = NULL
);
Parameters

pOptions
A pointer to an associated CXTPReportViewPrintOptions object for storing user's interaction results.
dwFlags
One or more flags you can use to customize the settings of the dialog box. The values can be combined using the bitwise-OR operator. For more details see CPageSetupDialog::CPageSetupDialog
pParentWnd
Pointer to the dialog box's parent or owner.

Remarks

Use the DoModal function to display the dialog box.

See Also

CPageSetupDialog::CPageSetupDialog()

Group

CXTPReportPageSetupDialog Constructors


CXTPReportPageSetupDialog Destructors

CXTPReportPageSetupDialog Class, Legend, Public Methods
CXTPReportPageSetupDialog Destructors
Class

CXTPReportPageSetupDialog Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportPageSetupDialog | Default class constructor, handles members cleanup.


CXTPReportPageSetupDialog::~CXTPReportPageSetupDialog Destructor

CXTPReportPageSetupDialog Destructors, CXTPReportPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPageSetupDialog::~CXTPReportPageSetupDialog Destructor

Default class constructor, handles members cleanup.

virtual ~CXTPReportPageSetupDialog();
Group

CXTPReportPageSetupDialog Destructors


CXTPReportPaintManager Class

XTPReportPaintManager.h, Classes, Legend, Members, Topics, CXTPReportPaintManager Data Members, CXTPReportPaintManager Methods, CXTPReportPaintManager Constructors, CXTPReportPaintManager Destructors, CXTPReportPaintManager Constructors, CXTPReportPaintManager Data Members, CXTPReportPaintManager Destructors, CXTPReportPaintManager Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager Class

Utility class, handling most of the drawing activities. It stores all settings, needed by a control to perform drawing operations: fonts, colors, styles for all other classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with device context.

Class Hierarchy

class CXTPReportPaintManager;
File

XTPReportPaintManager.h

Remarks

Could be overridden to provide another look and feel for the control. Thus you have an easy way to change "skin" of your control; just provide your own implementation of CXTPReportPaintManager and there's no need to touch functionality all others classes of control

You create ReportPaintManager by calling its constructor, further you can call getter and setter functions to change every setting as you wish.

See Also

CXTPReportControl overview, CXTPReportRow, CXTPReportGroupRow, CXTPReportColumn, CXTPReportHeader

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportPaintManager Constructors
CXTPReportPaintManager Constructors | Description
CXTPReportPaintManager | Default paint manager constructor, handles properties initialization.
CXTPReportPaintManager Data Members
CXTPReportPaintManager Data Members | Description
m_bDrawGridForEmptySpace | TRUE if grid fills the empty space (if any) after the body rows.
m_bDrawSortTriangleAlways | If TRUE, the sort triangle displayed in column headers when a column is sorted will always be displayed as long as the column size is large enough to drawn the triangle.
m_bFixedInplaceButtonHeight | TRUE if fixed Inplace Buttons height used.
m_bFixedRowHeight | TRUE if fixed rows used.
m_bGroupRowTextBold | TRUE to draw group rows with bold text.
m_bHideSelection | TRUE when hiding report control's selection by drawing selected items as others, FALSE otherwise.
m_bHotTracking | TRUE to allow column hot tracking
m_bInvertColumnOnClick | TRUE to invert column on click
m_bIsPreviewMode | Show or not show the item preview.
m_bRevertAlignment | TRUE to revert column alignments
m_brushHorizontalGrid | Stores brush to draw horizontal grid lines
m_brushTreeStructure | Stores brush to draw tree nodes
m_brushVeriticalGrid | Stores brush to draw vertical grid lines
m_bShadeGroupHeadings | Show or not show the indentation shade.
m_bShadeSortColumn | Show or not show the items shade in the sorted by column.
m_bThemedInplaceButtons | Draw in-place buttons using current theme settings.
m_bUseColumnTextAlignment | TRUE to draw caption text accordingly to its alignment
m_bUseEditTextAlignment | TRUE to automatically apply edit alignment using column alignment
m_clrBtnFace | Standard button face color.
m_clrBtnText | Standard button text color.
m_clrCaptionText | Column header text color.
m_clrColumnOffice2007CustomTheme | Base color for Office2007 custom theme.
m_clrControlBack | Background color of the control report area.
m_clrControlDark | Dark background color of the report control (used on Group By area).
m_clrControlLightLight | Light background color used for drawing shades (used on column header area).
m_clrFooterRowsDivider | Color of footer divider.
m_clrFreezeColsDivider | Freeze Columns Divider color.
m_clrGradientColumnSeparator | Separator of column used with xtpReportColumnOffice2003 style
m_clrGradientColumnShadow | Bottom shadow of column used with xtpReportColumnOffice2003 style
m_clrGridLine | Grid lines color.
m_clrGroupBoxBack | Color of group box.
m_clrGroupRowText | Row text color.
m_clrGroupShadeBack | Group row background color when indentation shade is enabled.
m_clrGroupShadeBorder | Color for group border's shade.
m_clrGroupShadeText | Group row foreground color when indentation shade is enabled.
m_clrHeaderControl | Background color of the report header.
m_clrHeaderRowsDivider | Color of header divider.
m_clrHighlight | Background color of the highlighted row.
m_clrHighlightText | Text color of the highlighted text.
m_clrHotDivider | Color of the column hot divider window (2 arrows).
m_clrHyper | Hyperlink color.
m_clrIndentControl | Color of the tree indentation area.
m_clrItemShade | Color of the shade on sorted by column items.
m_clrPreviewText | Preview text color.
m_clrSelectedRow | Selected row background color.
m_clrSelectedRowText | Selected row text color.
m_clrWindowText | Report items default text color.
m_columnStyle | Contains column drawing style.
m_crlNoGroupByText | A color for "No items" text in GroupBy area (see m_strNoGroupBy member)
m_fontBoldText | Report items default bold text.
m_fontCaption | Column header caption font.
m_fontPreview | Column header caption font.
m_fontText | Report items default text.
m_FooterRowsDividerStyle | Style of a divider line between the footer and body rows.
m_grcGradientColumn | Color of column used with xtpReportColumnOffice2003 style
m_grcGradientColumnHot | HotTracking Color of column used with xtpReportColumnOffice2003 style
m_grcGradientColumnPushed | Pushed Color of column used with xtpReportColumnOffice2003 style
m_HeaderRowsDividerStyle | Style of a divider line between the header and body rows.
m_horizontalGridStyle | Stores current style for horizontal grid lines
m_ilGlyphs | Contains an additional image list for report control
m_nFooterHeight | Column footer height.
m_nFreezeColsDividerStyle | A set of flags from XTPReportFreezeColsDividerStyle
m_nGroupGridLineHeight | The height of the group grid line.
m_nHeaderHeight | Column header height.
m_nMaxPreviewLines | Restrict maximum lines for preview text
m_nResizingWidth | The width of the column resizing marker area.
m_nRowHeight | Report row default height.
m_nTreeIndent | Tree indentation.
m_nTreeStructureStyle | Tree structure style.
m_pHeaderHeightFormula | MulDivC formula for header height calculation
m_rcPreviewIndent | Preview indentation.
m_strNoFieldsAvailable | A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
m_strNoGroupBy | A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
m_strNoItems | A string which contains customized "No Items" text for displaying in view when there are no visible rows.
m_strSortBy | A string which contains customized "Sort By" text for displaying in tooltip
m_szGlyph | Glyph size
m_themeButton | In-place button theme wrapper.
m_themeCombo | Combobox in-place button theme wrapper.
m_themeSpin | Spin in-place button theme wrapper.
m_themeWrapper | Header theme wrapper.
m_treeStructureStyle | Tree structure style
m_verticalGridStyle | Stores current style for vertical grid lines
CXTPReportPaintManager Destructors
CXTPReportPaintManager Destructors | Description
~CXTPReportPaintManager | Default paint manager destructor, handles member items deallocation.
CXTPReportPaintManager Methods
CXTPReportPaintManager Methods | Description
CalcColumnHeight | Calculate optimal height for specified column.
CalculateRowHeight | Calculates height of the rectangle, bounding the multiline text, when the width is fixed.
DrawBitmap | Draws image of Report Control.
DrawCollapsedBitmap | Draws collapsed bitmap.
DrawColumn | Draws column header with all related attributes (sort order, icon, etc).
DrawColumnBackground | This method is called to draw background of the column using current column style
DrawColumnFooter | Draws column footer with all related attributes (footer text).
DrawColumnIcon | Draws image for a column.
DrawConnector | Draws a column connector for Group By box.
DrawFixedRowsDivider | Draws the Fixed Rows divider (for ex. dividing header record rows and body rows).
DrawFocusedRow | Draws rows that were focused.
DrawFreezeColsDivider | Draws the freeze column divider.
DrawGlyph | This method is called to draw standard glyphs of report control
DrawGrid | Draws control's grid.
DrawGridPat | Generates a custom grid pattern
DrawGroupRow | Draws group row.
DrawHorizontalLine | Draws Horizontal line.
DrawInplaceButton | This method is called to draw in-place button of the report
DrawInplaceButtonFrame | Draws in-place button frame
DrawInplaceButtonIcon | Draws in-place button icon
DrawItemBitmap | Draw Item Bitmap. Override this method to draw custom bitmap.
DrawItemCaption | Draw Item Caption. Override this method to draw custom caption.
DrawItemControl | Draw Item Control. Override this method to draw custom control.
DrawLink | Draw hyperlink string using hyperlinks text settings.
DrawLink2 | Draw hyperlink string using hyperlinks text settings (removing blanks).
DrawMultiLineText | Draws multi-line text (keeping hyperlinks active).
DrawNoGroupByText | This method used to draw "No items" text message in Group By area when there are no items inside it. Override it for custom drawing.
DrawSingleLineText | Draws single-line text (keeping hyperlinks active).
DrawString | Draw simple string into rectangle
DrawTextLine | Draw a line of text with respect to the drawing rect
DrawTreeStructure | This method is called to draw tree elements of report control.
DrawTriangle | Draws triangle that shows the sort order of column.
DrawVerticalLine | Draws vertical line.
EnablePreviewMode | Changes the preview mode state for the control.
FillFooter | Fills column footer control area by its background.
FillGroupByControl | Draws Group By box.
FillGroupRowMetrics | Fill font and colors members of the metrics structure for the specified group row.
FillHeaderControl | Fills column header control area by its background.
FillIndent | Fills indent area by its background.
FillItemShade | Fills item shade by its background if necessary.
FillRow | Fills the provided row with its background color.
GetColumnOffice2007CustomThemeBaseColor | Use this member function to get a header's custom theme base color for Office2007 column style.
GetColumnStyle | Use this member function to get a header style.
GetControlBackColor | Returns control background color.
GetFooterHeight | Calculate optimal footer height.
GetFooterRowsDividerHeight | Get height of footer divider line.
GetFooterRowsDividerStyle | Get style of footer divider line.
GetFreezeColsDividerStyle | Get style of Freeze Columns Divider line.
GetGlyphsImageList | Returns point to additional image list with Glyphs
GetHeaderHeight |
GetHeaderRowsDividerHeight | Get height of header divider line.
GetHeaderRowsDividerStyle | Get style of header divider line.
GetMaxPreviewLines | Get the count of max lines of preview text.
GetPreviewItemHeight | Returns preview item height for print mode.
GetPreviewLinesCount | Calculates the line count for preview text, takes into account max lines.
GetRowHeight |
GetTextFont | Returns the default text font for the control items.
IsColumHotTrackingEnabled | Call this method to determine if hot tracking is enabled for current column style.
IsDrawGridForEmptySpace | This method is called to determine if grid fills empty space after the body rows.
IsFixedInplaceButtonHeight | This method is called to determines if paint manager supports variable height of inplace buttons.
IsFixedRowHeight | This method is called to determines if paint manager supports variable height of row
IsGridVisible | Return visibility of grid line
IsPreviewMode | Returns preview mode state for the control.
OnDrawAction | Override this method to do custom activities for the item before processing it.
RefreshMetrics | Initializes all drawings defaults (fonts, colors, etc.). Most of them are system defaults.
SetCaptionFont | Creates and sets the default caption font
SetColumnOffice2007CustomThemeBaseColor | Use this member function to set a header's custom theme base color for Office2007 column style.
SetColumnStyle | Use this member function to set a header style.
SetDrawGridForEmptySpace | This method is called to determine if grid fills empty space after the body rows.
SetFixedRowHeight | This method is called to set if paint manager supports variable height of row
SetFooterRowsDividerStyle | Set style of footer divider line.
SetFreezeColsDividerStyle | Set style of Freeze Columns Divider line.
SetGridColor | Changes report control grid lines color.
SetGridStyle | Sets one of the predefined grid line styles
SetHeaderRowsDividerStyle | Set style of header divider line.
SetInplaceButtonHeight | This method is called to set if paint manager supports fixed height of inplace buttons.
SetMaxPreviewLines | Set count of max lines of the preview text.
SetPreviewIndent | Call this method to set the preview item indent.
SetTextFont | Creates and sets default text font


CXTPReportPaintManager Data Members

CXTPReportPaintManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager Data Members
Class

CXTPReportPaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bDrawGridForEmptySpace | TRUE if grid fills the empty space (if any) after the body rows.
m_bFixedInplaceButtonHeight | TRUE if fixed Inplace Buttons height used.
m_bFixedRowHeight | TRUE if fixed rows used.
m_bIsPreviewMode | Show or not show the item preview.
m_brushHorizontalGrid | Stores brush to draw horizontal grid lines
m_brushTreeStructure | Stores brush to draw tree nodes
m_brushVeriticalGrid | Stores brush to draw vertical grid lines
m_columnStyle | Contains column drawing style.
m_horizontalGridStyle | Stores current style for horizontal grid lines
m_ilGlyphs | Contains an additional image list for report control
m_nFooterHeight | Column footer height.
m_nFreezeColsDividerStyle | A set of flags from XTPReportFreezeColsDividerStyle
m_nGroupGridLineHeight | The height of the group grid line.
m_nHeaderHeight | Column header height.
m_nMaxPreviewLines | Restrict maximum lines for preview text
m_nResizingWidth | The width of the column resizing marker area.
m_nRowHeight | Report row default height.
m_pHeaderHeightFormula | MulDivC formula for header height calculation
m_szGlyph | Glyph size
m_themeButton | In-place button theme wrapper.
m_themeCombo | Combobox in-place button theme wrapper.
m_themeSpin | Spin in-place button theme wrapper.
m_themeWrapper | Header theme wrapper.
m_verticalGridStyle | Stores current style for vertical grid lines
Public Data Members
Public Data Member | Description
m_bDrawSortTriangleAlways | If TRUE, the sort triangle displayed in column headers when a column is sorted will always be displayed as long as the column size is large enough to drawn the triangle.
m_bGroupRowTextBold | TRUE to draw group rows with bold text.
m_bHideSelection | TRUE when hiding report control's selection by drawing selected items as others, FALSE otherwise.
m_bHotTracking | TRUE to allow column hot tracking
m_bInvertColumnOnClick | TRUE to invert column on click
m_bRevertAlignment | TRUE to revert column alignments
m_bShadeGroupHeadings | Show or not show the indentation shade.
m_bShadeSortColumn | Show or not show the items shade in the sorted by column.
m_bThemedInplaceButtons | Draw in-place buttons using current theme settings.
m_bUseColumnTextAlignment | TRUE to draw caption text accordingly to its alignment
m_bUseEditTextAlignment | TRUE to automatically apply edit alignment using column alignment
m_clrBtnFace | Standard button face color.
m_clrBtnText | Standard button text color.
m_clrCaptionText | Column header text color.
m_clrColumnOffice2007CustomTheme | Base color for Office2007 custom theme.
m_clrControlBack | Background color of the control report area.
m_clrControlDark | Dark background color of the report control (used on Group By area).
m_clrControlLightLight | Light background color used for drawing shades (used on column header area).
m_clrFooterRowsDivider | Color of footer divider.
m_clrFreezeColsDivider | Freeze Columns Divider color.
m_clrGradientColumnSeparator | Separator of column used with xtpReportColumnOffice2003 style
m_clrGradientColumnShadow | Bottom shadow of column used with xtpReportColumnOffice2003 style
m_clrGridLine | Grid lines color.
m_clrGroupBoxBack | Color of group box.
m_clrGroupRowText | Row text color.
m_clrGroupShadeBack | Group row background color when indentation shade is enabled.
m_clrGroupShadeBorder | Color for group border's shade.
m_clrGroupShadeText | Group row foreground color when indentation shade is enabled.
m_clrHeaderControl | Background color of the report header.
m_clrHeaderRowsDivider | Color of header divider.
m_clrHighlight | Background color of the highlighted row.
m_clrHighlightText | Text color of the highlighted text.
m_clrHotDivider | Color of the column hot divider window (2 arrows).
m_clrHyper | Hyperlink color.
m_clrIndentControl | Color of the tree indentation area.
m_clrItemShade | Color of the shade on sorted by column items.
m_clrPreviewText | Preview text color.
m_clrSelectedRow | Selected row background color.
m_clrSelectedRowText | Selected row text color.
m_clrWindowText | Report items default text color.
m_crlNoGroupByText | A color for "No items" text in GroupBy area (see m_strNoGroupBy member)
m_fontBoldText | Report items default bold text.
m_fontCaption | Column header caption font.
m_fontPreview | Column header caption font.
m_fontText | Report items default text.
m_FooterRowsDividerStyle | Style of a divider line between the footer and body rows.
m_grcGradientColumn | Color of column used with xtpReportColumnOffice2003 style
m_grcGradientColumnHot | HotTracking Color of column used with xtpReportColumnOffice2003 style
m_grcGradientColumnPushed | Pushed Color of column used with xtpReportColumnOffice2003 style
m_HeaderRowsDividerStyle | Style of a divider line between the header and body rows.
m_nTreeIndent | Tree indentation.
m_nTreeStructureStyle | Tree structure style.
m_rcPreviewIndent | Preview indentation.
m_strNoFieldsAvailable | A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
m_strNoGroupBy | A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
m_strNoItems | A string which contains customized "No Items" text for displaying in view when there are no visible rows.
m_strSortBy | A string which contains customized "Sort By" text for displaying in tooltip
m_treeStructureStyle | Tree structure style


CXTPReportPaintManager::m_bDrawGridForEmptySpace Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bDrawGridForEmptySpace Data Member

TRUE if grid fills the empty space (if any) after the body rows.

BOOL m_bDrawGridForEmptySpace;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bDrawSortTriangleAlways Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bDrawSortTriangleAlways Data Member

If TRUE, the sort triangle displayed in column headers when a column is sorted will always be displayed as long as the column size is large enough to drawn the triangle.

BOOL m_bDrawSortTriangleAlways;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bFixedInplaceButtonHeight Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bFixedInplaceButtonHeight Data Member

TRUE if fixed Inplace Buttons height used.

BOOL m_bFixedInplaceButtonHeight;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bFixedRowHeight Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bFixedRowHeight Data Member

TRUE if fixed rows used.

BOOL m_bFixedRowHeight;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bGroupRowTextBold Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bGroupRowTextBold Data Member

TRUE to draw group rows with bold text.

BOOL m_bGroupRowTextBold;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bHideSelection Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bHideSelection Data Member

TRUE when hiding report control's selection by drawing selected items as others, FALSE otherwise.

BOOL m_bHideSelection;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bHotTracking Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bHotTracking Data Member

TRUE to allow column hot tracking

BOOL m_bHotTracking;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bInvertColumnOnClick Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bInvertColumnOnClick Data Member

TRUE to invert column on click

BOOL m_bInvertColumnOnClick;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bIsPreviewMode Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bIsPreviewMode Data Member

Show or not show the item preview.

BOOL m_bIsPreviewMode;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bRevertAlignment Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bRevertAlignment Data Member

TRUE to revert column alignments

BOOL m_bRevertAlignment;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_brushHorizontalGrid Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_brushHorizontalGrid Data Member

Stores brush to draw horizontal grid lines

CBrush m_brushHorizontalGrid;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_brushTreeStructure Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_brushTreeStructure Data Member

Stores brush to draw tree nodes

CBrush m_brushTreeStructure;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_brushVeriticalGrid Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_brushVeriticalGrid Data Member

Stores brush to draw vertical grid lines

CBrush m_brushVeriticalGrid;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bShadeGroupHeadings Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bShadeGroupHeadings Data Member

Show or not show the indentation shade.

BOOL m_bShadeGroupHeadings;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bShadeSortColumn Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bShadeSortColumn Data Member

Show or not show the items shade in the sorted by column.

BOOL m_bShadeSortColumn;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bThemedInplaceButtons Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bThemedInplaceButtons Data Member

Draw in-place buttons using current theme settings.

BOOL m_bThemedInplaceButtons;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bUseColumnTextAlignment Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bUseColumnTextAlignment Data Member

TRUE to draw caption text accordingly to its alignment

BOOL m_bUseColumnTextAlignment;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_bUseEditTextAlignment Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_bUseEditTextAlignment Data Member

TRUE to automatically apply edit alignment using column alignment

BOOL m_bUseEditTextAlignment;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrBtnFace Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrBtnFace Data Member

Standard button face color.

CXTPPaintManagerColor m_clrBtnFace;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrBtnText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrBtnText Data Member

Standard button text color.

CXTPPaintManagerColor m_clrBtnText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrCaptionText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrCaptionText Data Member

Column header text color.

CXTPPaintManagerColor m_clrCaptionText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrColumnOffice2007CustomTheme Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrColumnOffice2007CustomTheme Data Member

Base color for Office2007 custom theme.

COLORREF m_clrColumnOffice2007CustomTheme;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrControlBack Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrControlBack Data Member

Background color of the control report area.

CXTPPaintManagerColor m_clrControlBack;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrControlDark Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrControlDark Data Member

Dark background color of the report control (used on Group By area).

CXTPPaintManagerColor m_clrControlDark;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrControlLightLight Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrControlLightLight Data Member

Light background color used for drawing shades (used on column header area).

CXTPPaintManagerColor m_clrControlLightLight;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrFooterRowsDivider Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrFooterRowsDivider Data Member

Color of footer divider.

CXTPPaintManagerColor m_clrFooterRowsDivider;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrFreezeColsDivider Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrFreezeColsDivider Data Member

Freeze Columns Divider color.

CXTPPaintManagerColor m_clrFreezeColsDivider;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrGradientColumnSeparator Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrGradientColumnSeparator Data Member

Separator of column used with xtpReportColumnOffice2003 style

CXTPPaintManagerColor m_clrGradientColumnSeparator;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrGradientColumnShadow Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrGradientColumnShadow Data Member

Bottom shadow of column used with xtpReportColumnOffice2003 style

CXTPPaintManagerColor m_clrGradientColumnShadow;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrGridLine Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrGridLine Data Member

Grid lines color.

CXTPPaintManagerColor m_clrGridLine;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrGroupBoxBack Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrGroupBoxBack Data Member

Color of group box.

CXTPPaintManagerColor m_clrGroupBoxBack;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrGroupRowText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrGroupRowText Data Member

Row text color.

CXTPPaintManagerColor m_clrGroupRowText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrGroupShadeBack Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrGroupShadeBack Data Member

Group row background color when indentation shade is enabled.

CXTPPaintManagerColor m_clrGroupShadeBack;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrGroupShadeBorder Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrGroupShadeBorder Data Member

Color for group border's shade.

CXTPPaintManagerColor m_clrGroupShadeBorder;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrGroupShadeText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrGroupShadeText Data Member

Group row foreground color when indentation shade is enabled.

CXTPPaintManagerColor m_clrGroupShadeText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrHeaderControl Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrHeaderControl Data Member

Background color of the report header.

CXTPPaintManagerColor m_clrHeaderControl;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrHeaderRowsDivider Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrHeaderRowsDivider Data Member

Color of header divider.

CXTPPaintManagerColor m_clrHeaderRowsDivider;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrHighlight Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrHighlight Data Member

Background color of the highlighted row.

CXTPPaintManagerColor m_clrHighlight;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrHighlightText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrHighlightText Data Member

Text color of the highlighted text.

CXTPPaintManagerColor m_clrHighlightText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrHotDivider Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrHotDivider Data Member

Color of the column hot divider window (2 arrows).

CXTPPaintManagerColor m_clrHotDivider;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrHyper Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrHyper Data Member

Hyperlink color.

CXTPPaintManagerColor m_clrHyper;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrIndentControl Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrIndentControl Data Member

Color of the tree indentation area.

CXTPPaintManagerColor m_clrIndentControl;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrItemShade Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrItemShade Data Member

Color of the shade on sorted by column items.

CXTPPaintManagerColor m_clrItemShade;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrPreviewText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrPreviewText Data Member

Preview text color.

CXTPPaintManagerColor m_clrPreviewText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrSelectedRow Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrSelectedRow Data Member

Selected row background color.

CXTPPaintManagerColor m_clrSelectedRow;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrSelectedRowText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrSelectedRowText Data Member

Selected row text color.

CXTPPaintManagerColor m_clrSelectedRowText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_clrWindowText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_clrWindowText Data Member

Report items default text color.

CXTPPaintManagerColor m_clrWindowText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_columnStyle Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_columnStyle Data Member

Contains column drawing style.

XTPReportColumnStyle m_columnStyle;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_crlNoGroupByText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_crlNoGroupByText Data Member

A color for "No items" text in GroupBy area (see m_strNoGroupBy member)

CXTPPaintManagerColor m_crlNoGroupByText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_fontBoldText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_fontBoldText Data Member

Report items default bold text.

CFont m_fontBoldText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_fontCaption Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_fontCaption Data Member

Column header caption font.

CFont m_fontCaption;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_fontPreview Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_fontPreview Data Member

Column header caption font.

CFont m_fontPreview;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_fontText Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_fontText Data Member

Report items default text.

CFont m_fontText;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_FooterRowsDividerStyle Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_FooterRowsDividerStyle Data Member

Style of a divider line between the footer and body rows.

XTPReportFixedRowsDividerStyle m_FooterRowsDividerStyle;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_grcGradientColumn Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_grcGradientColumn Data Member

Color of column used with xtpReportColumnOffice2003 style

CXTPPaintManagerColorGradient m_grcGradientColumn;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_grcGradientColumnHot Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_grcGradientColumnHot Data Member

HotTracking Color of column used with xtpReportColumnOffice2003 style

CXTPPaintManagerColorGradient m_grcGradientColumnHot;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_grcGradientColumnPushed Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_grcGradientColumnPushed Data Member

Pushed Color of column used with xtpReportColumnOffice2003 style

CXTPPaintManagerColorGradient m_grcGradientColumnPushed;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_HeaderRowsDividerStyle Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_HeaderRowsDividerStyle Data Member

Style of a divider line between the header and body rows.

XTPReportFixedRowsDividerStyle m_HeaderRowsDividerStyle;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_horizontalGridStyle Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_horizontalGridStyle Data Member

Stores current style for horizontal grid lines

XTPReportGridStyle m_horizontalGridStyle;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_ilGlyphs Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_ilGlyphs Data Member

Contains an additional image list for report control

CImageList m_ilGlyphs;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nFooterHeight Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nFooterHeight Data Member

Column footer height.

int m_nFooterHeight;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nFreezeColsDividerStyle Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nFreezeColsDividerStyle Data Member

A set of flags from XTPReportFreezeColsDividerStyle

int m_nFreezeColsDividerStyle;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nGroupGridLineHeight Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nGroupGridLineHeight Data Member

The height of the group grid line.

int m_nGroupGridLineHeight;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nHeaderHeight Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nHeaderHeight Data Member

Column header height.

int m_nHeaderHeight;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nMaxPreviewLines Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nMaxPreviewLines Data Member

Restrict maximum lines for preview text

int m_nMaxPreviewLines;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nResizingWidth Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nResizingWidth Data Member

The width of the column resizing marker area.

int m_nResizingWidth;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nRowHeight Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nRowHeight Data Member

Report row default height.

int m_nRowHeight;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nTreeIndent Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nTreeIndent Data Member

Tree indentation.

int m_nTreeIndent;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_nTreeStructureStyle Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_nTreeStructureStyle Data Member

Tree structure style.

int m_nTreeStructureStyle;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_pHeaderHeightFormula Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_pHeaderHeightFormula Data Member

MulDivC formula for header height calculation

CXTPFormulaMulDivC* m_pHeaderHeightFormula;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_rcPreviewIndent Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_rcPreviewIndent Data Member

Preview indentation.

CRect m_rcPreviewIndent;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_strNoFieldsAvailable Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_strNoFieldsAvailable Data Member

A string which contains customized "No Fields Available" text message for displaying in Field Chooser.

CString m_strNoFieldsAvailable;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_strNoGroupBy Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_strNoGroupBy Data Member

A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.

CString m_strNoGroupBy;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_strNoItems Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_strNoItems Data Member

A string which contains customized "No Items" text for displaying in view when there are no visible rows.

CString m_strNoItems;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_strSortBy Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_strSortBy Data Member

A string which contains customized "Sort By" text for displaying in tooltip

CString m_strSortBy;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_szGlyph Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_szGlyph Data Member

Glyph size

CSize m_szGlyph;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_themeButton Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_themeButton Data Member

In-place button theme wrapper.

CXTPWinThemeWrapper m_themeButton;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_themeCombo Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_themeCombo Data Member

Combobox in-place button theme wrapper.

CXTPWinThemeWrapper m_themeCombo;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_themeSpin Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_themeSpin Data Member

Spin in-place button theme wrapper.

CXTPWinThemeWrapper m_themeSpin;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_themeWrapper Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_themeWrapper Data Member

Header theme wrapper.

CXTPWinThemeWrapper m_themeWrapper;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_treeStructureStyle Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_treeStructureStyle Data Member

Tree structure style

XTPReportTreeStructureStyle m_treeStructureStyle;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager::m_verticalGridStyle Data Member

CXTPReportPaintManager Data Members, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::m_verticalGridStyle Data Member

Stores current style for vertical grid lines

XTPReportGridStyle m_verticalGridStyle;
Group

CXTPReportPaintManager Data Members


CXTPReportPaintManager Methods

CXTPReportPaintManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager Methods
Class

CXTPReportPaintManager Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalcColumnHeight | Calculate optimal height for specified column.
CalculateRowHeight | Calculates height of the rectangle, bounding the multiline text, when the width is fixed.
DrawColumnBackground | This method is called to draw background of the column using current column style
DrawGridPat | Generates a custom grid pattern
DrawInplaceButtonFrame | Draws in-place button frame
DrawInplaceButtonIcon | Draws in-place button icon
DrawLink | Draw hyperlink string using hyperlinks text settings.
DrawLink2 | Draw hyperlink string using hyperlinks text settings (removing blanks).
DrawMultiLineText | Draws multi-line text (keeping hyperlinks active).
DrawSingleLineText | Draws single-line text (keeping hyperlinks active).
DrawString | Draw simple string into rectangle
DrawTextLine | Draw a line of text with respect to the drawing rect
Public Methods
Public Methods
Public Method | Description
DrawBitmap | Draws image of Report Control.
DrawCollapsedBitmap | Draws collapsed bitmap.
DrawColumn | Draws column header with all related attributes (sort order, icon, etc).
DrawColumnFooter | Draws column footer with all related attributes (footer text).
DrawColumnIcon | Draws image for a column.
DrawConnector | Draws a column connector for Group By box.
DrawFixedRowsDivider | Draws the Fixed Rows divider (for ex. dividing header record rows and body rows).
DrawFocusedRow | Draws rows that were focused.
DrawFreezeColsDivider | Draws the freeze column divider.
DrawGlyph | This method is called to draw standard glyphs of report control
DrawGrid | Draws control's grid.
DrawGroupRow | Draws group row.
DrawHorizontalLine | Draws Horizontal line.
DrawInplaceButton | This method is called to draw in-place button of the report
DrawItemBitmap | Draw Item Bitmap. Override this method to draw custom bitmap.
DrawItemCaption | Draw Item Caption. Override this method to draw custom caption.
DrawItemControl | Draw Item Control. Override this method to draw custom control.
DrawNoGroupByText | This method used to draw "No items" text message in Group By area when there are no items inside it. Override it for custom drawing.
DrawTreeStructure | This method is called to draw tree elements of report control.
DrawTriangle | Draws triangle that shows the sort order of column.
DrawVerticalLine | Draws vertical line.
EnablePreviewMode | Changes the preview mode state for the control.
FillFooter | Fills column footer control area by its background.
FillGroupByControl | Draws Group By box.
FillGroupRowMetrics | Fill font and colors members of the metrics structure for the specified group row.
FillHeaderControl | Fills column header control area by its background.
FillIndent | Fills indent area by its background.
FillItemShade | Fills item shade by its background if necessary.
FillRow | Fills the provided row with its background color.
GetColumnOffice2007CustomThemeBaseColor | Use this member function to get a header's custom theme base color for Office2007 column style.
GetColumnStyle | Use this member function to get a header style.
GetControlBackColor | Returns control background color.
GetFooterHeight | Calculate optimal footer height.
GetFooterRowsDividerHeight | Get height of footer divider line.
GetFooterRowsDividerStyle | Get style of footer divider line.
GetFreezeColsDividerStyle | Get style of Freeze Columns Divider line.
GetGlyphsImageList | Returns point to additional image list with Glyphs
GetHeaderHeight |
GetHeaderRowsDividerHeight | Get height of header divider line.
GetHeaderRowsDividerStyle | Get style of header divider line.
GetMaxPreviewLines | Get the count of max lines of preview text.
GetPreviewItemHeight | Returns preview item height for print mode.
GetPreviewLinesCount | Calculates the line count for preview text, takes into account max lines.
GetRowHeight |
GetTextFont | Returns the default text font for the control items.
IsColumHotTrackingEnabled | Call this method to determine if hot tracking is enabled for current column style.
IsDrawGridForEmptySpace | This method is called to determine if grid fills empty space after the body rows.
IsFixedInplaceButtonHeight | This method is called to determines if paint manager supports variable height of inplace buttons.
IsFixedRowHeight | This method is called to determines if paint manager supports variable height of row
IsGridVisible | Return visibility of grid line
IsPreviewMode | Returns preview mode state for the control.
OnDrawAction | Override this method to do custom activities for the item before processing it.
RefreshMetrics | Initializes all drawings defaults (fonts, colors, etc.). Most of them are system defaults.
SetCaptionFont | Creates and sets the default caption font
SetColumnOffice2007CustomThemeBaseColor | Use this member function to set a header's custom theme base color for Office2007 column style.
SetColumnStyle | Use this member function to set a header style.
SetDrawGridForEmptySpace | This method is called to determine if grid fills empty space after the body rows.
SetFixedRowHeight | This method is called to set if paint manager supports variable height of row
SetFooterRowsDividerStyle | Set style of footer divider line.
SetFreezeColsDividerStyle | Set style of Freeze Columns Divider line.
SetGridColor | Changes report control grid lines color.
SetGridStyle | Sets one of the predefined grid line styles
SetHeaderRowsDividerStyle | Set style of header divider line.
SetInplaceButtonHeight | This method is called to set if paint manager supports fixed height of inplace buttons.
SetMaxPreviewLines | Set count of max lines of the preview text.
SetPreviewIndent | Call this method to set the preview item indent.
SetTextFont | Creates and sets default text font


CXTPReportPaintManager::CalcColumnHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::CalcColumnHeight Method

Calculate optimal height for specified column.

virtual int CalcColumnHeight(
    CDC* pDC,
    CXTPReportColumn* pColumn,
    int nTotalWidth = 0
);
Parameters

pDC
Pointer to device context.
pColumn
Pointer to a column object.
nTotalWidth
Total header with. Used for printing only.

Returns

Optimal height for specified column.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::CalculateRowHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::CalculateRowHeight Method

Calculates height of the rectangle, bounding the multiline text, when the width is fixed.

virtual int CalculateRowHeight(
    CDC* pDC,
    const CString& strText,
    int nMaxWidth,
    BOOL bWordBreak = TRUE
);
Parameters

pDC
Pointer to device context.
strText
String of text.
nMaxWidth
Max width of the rectangle, bounding the text.
bWordBreak
Whether to break the line by words. If FALSE - only new line characters can increase the row height.

Returns

Necessary height to draw the multiline text.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawBitmap Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::DrawBitmap Method

Draws image of Report Control.

virtual int DrawBitmap(
    CDC* pDC,
    CXTPReportControl* pControl,
    CRect rcColumn,
    int iImage
);
Parameters

pDC
Pointer to the used Device Context.
pControl
Pointer to report control which image will be drawn.
rcColumn
Bitmap area rectangle coordinates.
iImage
Image index.

Returns

Width of drawn bitmap.

Remarks

You use this function to draw a bitmap in the column rectangle. If the provided rectangle is too small, the bitmap will not be drawn. Generally, the column rectangle must be big enough to contain text (if presented) and bitmap

Example
// draws bitmap with id ID_READ
pPaintManager->DrawBitmap(pDC, pControl, rcColumn, ID_READ);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawCollapsedBitmap Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawCollapsedBitmap Method

Draws collapsed bitmap.

CSize DrawCollapsedBitmap(
    CDC* pDC,
    const CXTPReportRow* pRow,
    CRect& rcBitmap
);
Parameters

pDC
Pointer to the used Device Context.
pRow
Pointer to the Row.
rcBitmap
Bitmap area rectangle coordinates.

Returns

Size of drawn bitmap.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawColumn Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::DrawColumn Method

Draws column header with all related attributes (sort order, icon, etc).

virtual void DrawColumn(
    CDC* pDC,
    CXTPReportColumn* pColumn,
    CXTPReportHeader* pHeader,
    CRect rcColumn,
    BOOL bDrawExternal = FALSE
);
Parameters

pDC
Pointer to the used Device Context.
pColumn
Column header area rectangle coordinates.
pHeader
Pointer to report header.
rcColumn
Column area rectangle coordinates.
bDrawExternal
whether draw Column on Header area, default is FALSE.

Example
CXTPReportPaintManager* pPaintManager = m_pControl->GetPaintManager();
CXTPReportColumn* pColumn = CXTPReportColumn* pColumn = m_pColumns->GetAt(1);
CRect rcHeader(rcClient);
int nHeaderHeight = m_pControl->GetHeaderHeight();
rcHeader.bottom = rcHeader.top + nHeaderHeight;
GetPaintManager()->DrawColumn(pDC, pColumn, this, rcHeader);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawColumnBackground Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawColumnBackground Method

This method is called to draw background of the column using current column style

virtual void DrawColumnBackground(
    CDC* pDC,
    CXTPReportColumn* pColumn,
    CRect rcColumn,
    BOOL& bColumnPressed,
    CXTPReportHeader* pHeader = NULL
);
Parameters

pDC
Point to used Device Context
pColumn
Column needs to draw
rcColumn
Bounding rectangle of the column
bColumnPressed
TRUE if column is pressed by user.
pHeader
Pointer to a header the column belongs to.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawColumnFooter Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawColumnFooter Method

Draws column footer with all related attributes (footer text).

virtual void DrawColumnFooter(
    CDC* pDC,
    CXTPReportColumn* pColumn,
    CXTPReportHeader* pHeader,
    CRect rcColumn
);
Parameters

pDC
Pointer to the used Device Context.
pColumn
Column header area rectangle coordinates.
pHeader
Pointer to report header.
rcColumn
Column area rectangle coordinates.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawColumnIcon Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawColumnIcon Method

Draws image for a column.

virtual int DrawColumnIcon(
    CDC* pDC,
    CXTPReportColumn* pColumn,
    CRect rcColumn,
    CRect rcIcon,
    int iIcon
);
Parameters

pDC
Pointer to the used Device Context.
pColumn
Pointer to a column object.
rcColumn
Column rectangle.
rcIcon
Image bounding rectangle.
iIcon
Image index.

Returns

Width of drawn bitmap.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawConnector Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::DrawConnector Method

Draws a column connector for Group By box.

void DrawConnector(
    CDC* pDC,
    CPoint ptFrom,
    CPoint ptTo
);
Parameters

pDC
Pointer to the used Device Context.
ptFrom
Source point of the connector.
ptTo
Target point of the connector.

Remarks

You use this function to draw a line that represents a chain of columns in GroupBy box. It connects columns in GroupBy box altogether

Example
DrawConnector(pDC, CPoint(rcItem.right - 5, rcItem.bottom), CPoint(x, rcItem.bottom + 4));
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawFixedRowsDivider Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawFixedRowsDivider Method

Draws the Fixed Rows divider (for ex. dividing header record rows and body rows).

void DrawFixedRowsDivider(
    CDC* pDC,
    const CRect& rc,
    CXTPReportControl* pControl,
    BOOL bHeaderRows,
    BOOL bVScrollBarVisible = TRUE
);
Parameters

pDC
Pointer to the used Device Context.
rc
Rectangle coordinates.
pControl
Pointer to a report control.
bHeaderRows
whether the divider is under header rows or above footer rows.
bVScrollBarVisible
TRUE, if vertical scrollbar is visible, FALSE otherwise.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawFocusedRow Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::DrawFocusedRow Method

Draws rows that were focused.

virtual void DrawFocusedRow(
    CDC* pDC,
    CRect rcRow
);
Parameters

pDC
Pointer to the used Device Context.
rcRow
Area rectangle coordinates.
pHeader
Pointer to report header.

Example
CRect rcClient(GetParent()->GetClientRect());
CXTPReportHeader* pHeader = m_pColumns->GetReportHeader();
CXTPReportPaintManager* pPaintManager = m_pControl->GetPaintManager();
GetPaintManager()->DrawResizingRect(pDC, pHeader, rcClient);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawFreezeColsDivider Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawFreezeColsDivider Method

Draws the freeze column divider.

virtual void DrawFreezeColsDivider(
    CDC* pDC,
    const CRect& rc,
    CXTPReportControl* pControl,
    CXTPReportRow* pRow = NULL
);
Parameters

pDC
Pointer to the used Device Context.
rc
Rectangle coordinates.
pControl
Pointer to a report control.
pRow
Pointer to the Group Row.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawGlyph Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawGlyph Method

This method is called to draw standard glyphs of report control

virtual CSize DrawGlyph(
    CDC* pDC,
    CRect rcColumn,
    int iImage
);
Parameters

pDC
Pointer to the used Device Context.
rcColumn
Bitmap area rectangle coordinates.
iImage
Image index.

Returns

Size of drawn bitmap.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawGrid Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::DrawGrid Method

Draws control's grid.

virtual void DrawGrid(
    CDC* pDC,
    BOOL bVertical,
    CRect rc
);
Parameters

pDC
Pointer to the used Device Context.
bVertical
boolean value determines orientation of grid
rc
Row area rectangle coordinates.

Example
// draw vertical grid in Row
CRect rcGridItem(rcRowRect);
pPaintManager->DrawGrid(pDC, TRUE, rcGridItem);

// draw horizontal grid in Row
CPaintDC pDC(this);
CRect rcGridItem(rcRowRect);
pPaintManager->DrawGrid(pDC, FALSE, rcGridItem);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawGridPat Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawGridPat Method

Generates a custom grid pattern

virtual void DrawGridPat(
    CDC* pDC,
    CBrush* pBrush,
    CRect rc,
    CONST VOID* pPattern,
    COLORREF clr
);
Parameters

pDC
Pointer to device context.
pBrush
Pointer to brush object.
rc
Rectangle area.
pPattern
Points to a short-integer array that contains the initial bitmap bit values. If it is NULL, the new bitmap is left uninitialized.
clr
COLORREF object representing the pattern color.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawGroupRow Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::DrawGroupRow Method

Draws group row.

virtual void DrawGroupRow(
    CDC* pDC,
    CXTPReportGroupRow* pRow,
    CRect rcRow,
    XTP_REPORTRECORDITEM_METRICS* pMetrics
);
Parameters

pDC
Pointer to the used Device Context.
pRow
Pointer to the Group Row.
rcRow
Group Row area rectangle coordinates.
pMetrics
Pointer to a XTP_REPORTRECORDITEM_METRICS object.

Example
CXTPReportPaintManager* pPaintManager = m_pControl->GetPaintManager();
pDC->SetBkMode(TRANSPARENT);
pPaintManager->DrawGroupRow(pDC, this, rcRow);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawHorizontalLine Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawHorizontalLine Method

Draws Horizontal line.

void DrawHorizontalLine(
    CDC* pDC,
    int xPos,
    int yPos,
    int cx,
    COLORREF clr
);
Parameters

pDC
Pointer to the used Device Context.
xPos
Horizontal coordinate of the beginning of line.
yPos
Vertical coordinate of the beginning of line.
cx
Length of line.
clr
Color of line.

Remarks

This member function is called in the control everywhere we need to draw a simple horizontal line

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawInplaceButton Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawInplaceButton Method

This method is called to draw in-place button of the report

virtual void DrawInplaceButton(
    CDC* pDC,
    CXTPReportInplaceButton* pButton
);
Parameters

pDC
Pointer to the device context
pButton
Pointer to in-place button to draw

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawInplaceButtonFrame Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawInplaceButtonFrame Method

Draws in-place button frame

virtual void DrawInplaceButtonFrame(
    CDC* pDC,
    CXTPReportInplaceButton* pButton
);
Parameters

pDC
Pointer to device context.
pButton
Pointer to in-place button

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawInplaceButtonIcon Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawInplaceButtonIcon Method

Draws in-place button icon

virtual BOOL DrawInplaceButtonIcon(
    CDC* pDC,
    CXTPReportInplaceButton* pButton
);
Parameters

pDC
Pointer to device context.
pButton
Pointer to in-place button

Returns

TRUE if icon has been drawn, FALSE otherwise.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawItemBitmap Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawItemBitmap Method

Draw Item Bitmap. Override this method to draw custom bitmap.

virtual void DrawItemBitmap(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    CRect& rcItem,
    int nImage
);
Parameters

pDrawArgs
pointer to structure with drawing arguments
rcItem
Item rectangle.
nImage
Image index.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawItemCaption Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawItemCaption Method

Draw Item Caption. Override this method to draw custom caption.

virtual void DrawItemCaption(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pMetrics
);
Parameters

pDrawArgs
pointer to structure with drawing arguments
pMetrics
Metrics of the item

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawItemControl Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawItemControl Method

Draw Item Control. Override this method to draw custom control.

virtual void DrawItemControl(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    CXTPReportRecordItemControl* pControl,
    CRect& rcItem
);
Parameters

pDrawArgs
pointer to structure with drawing arguments
pMetrics
Metrics of the item

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawLink Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawLink Method

Draw hyperlink string using hyperlinks text settings.

virtual int DrawLink(
    int* pnCurrDrawPos,
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    CXTPReportHyperlink* pHyperlink,
    CString strText,
    CRect rcLink,
    int nFlag
);
Parameters

pnCurrDrawPos
pointer to current drawing position (is updated after each call of function)
pDrawArgs
pointer to structure with drawing arguments
pHyperlink
pointer to hyperlink object
strText
string of text
rcLink
link hot spot area rectangle coordinates
nFlag
Flag can allow next values:
DT_END_ELLIPSIS
truncate text by ellipses
DT_WORDBREAK

  • truncate text by word end

bSelected
if Row is selected

Returns

Position in CString where drawing of one link text was stopped

Remarks

Its member function is internally used by DrawTextLine and draws hyperlink chunk of text string, updates hyperlink's hot spot.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawLink2 Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawLink2 Method

Draw hyperlink string using hyperlinks text settings (removing blanks).

virtual int DrawLink2(
    int* pnCurrDrawPos,
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    CXTPReportHyperlink* pHyperlink,
    CString strText,
    CRect rcLink,
    int nFlag,
    BOOL bTrim = FALSE
);
Parameters

pnCurrDrawPos
pointer to current drawing position (is updated after each call of function)
pDrawArgs
pointer to structure with drawing arguments
pHyperlink
pointer to hyperlink object
strText
string of text
rcLink
link hot spot area rectangle coordinates
nFlag
Flag can allow next values:
bTrim
whether to trim the hyperlink
DT_END_ELLIPSIS
truncate text by ellipses
DT_WORDBREAK

  • truncate text by word end

Returns

Position in CString where drawing of one link text was stopped

Remarks

Its member function is internally used by DrawTextLine and draws hyperlink chunk of text string, updates hyperlink's hot spot. If the hyperlink beginsends with blanks, they are removed.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawMultiLineText Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawMultiLineText Method

Draws multi-line text (keeping hyperlinks active).

virtual void DrawMultiLineText(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    const CString& strText,
    CRect rcItem,
    BOOL bWordBreak = TRUE
);
Parameters

pDrawArgs
Pointer to structure with drawing arguments.
strText
String of text.
rcItem
Item area rectangle coordinates.
bWordBreak
Whether to break the line by words. If FALSE - only new line characters force new lines.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawNoGroupByText Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::DrawNoGroupByText Method

This method used to draw "No items" text message in Group By area when there are no items inside it. Override it for custom drawing.

virtual void DrawNoGroupByText(
    CDC* pDC,
    CRect rcItem
);
Parameters

pDC
Pointer to the used Device Context.
rcItem
Reference to text area rectangle coordinates.

See Also

CXTPReportPaintManager::m_strNoGroupBy

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawSingleLineText Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawSingleLineText Method

Draws single-line text (keeping hyperlinks active).

virtual void DrawSingleLineText(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    const CString& strText,
    CRect rcItem,
    int nStartPos,
    int nEndPos,
    int nActualWidth
);
Parameters

pDrawArgs
Pointer to structure with drawing arguments.
strText
String of text.
rcItem
Item area rectangle coordinates.
nStartPos
Start position in strText.
nEndPos
End position in strText.
nActualWidth
Width of text to be drawn.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawString Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawString Method

Draw simple string into rectangle

virtual int DrawString(
    int* pnCurrDrawPos,
    CDC* pDC,
    const CString& strDraw,
    CRect rcDraw,
    UINT nFormat
);
Parameters

pnCurrDrawPos
Pointer to current drawing position (is updated after each call of function)
pDC
Point to used Device Context
strDraw
String of text
rcDraw
Text area rectangle coordinates
nFormat
Flag can allow next values:
DT_END_ELLIPSIS
truncate text by ellipses
DT_WORDBREAK
truncate text by word end

Returns

Position in CString where drawing of one string of text line was stopped

Remarks

Its member function is internally used by DrawTextLine and draws a plain chunk of text string.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawTextLine Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawTextLine Method

Draw a line of text with respect to the drawing rect

virtual void DrawTextLine(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    const CString& strText,
    CRect rcItem,
    int nFlag,
    int& nCharCounter,
    int& nHyperlikCounter
);
Parameters

pDrawArgs
Pointer to structure with drawing arguments.
strText
String of text.
rcItem
Item area rectangle coordinates.
nFlag
Flag can allow next values:
nCharCounter
Reference to printed char counted, accepts value before, returns value after drawing
nHyperlikCounter
Reference to printed hyperlinks counted, accepts value before, returns value after drawing
DT_END_ELLIPSIS
truncate text by ellipses
DT_WORDBREAK

  • truncate text by word end

bSelected
If Row is selected

Returns

Position in CString where drawing of one line of text was stopped

Remarks

Its member function is internally used by DrawText() and draws one line of text. It processes plain text/ hyperlink text for one line. For multi-line text process last line - the truncate by ellipses, otherwise truncate by word

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawTreeStructure Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawTreeStructure Method

This method is called to draw tree elements of report control.

virtual void DrawTreeStructure(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pMetrics,
    CRect rcItem,
    CSize sizeGlyph
);
Parameters

pDrawArgs
pointer to structure with drawing arguments
pMetrics
Metrics of the item
rcItem
Item area rectangle coordinates.
sizeGlyph
Item glyph rectangle coordinates.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawTriangle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::DrawTriangle Method

Draws triangle that shows the sort order of column.

void DrawTriangle(
    CDC* pDC,
    CRect rcTriangle,
    BOOL bToDown
);
Parameters

pDC
Pointer to the used Device Context.
rcTriangle
Triangle area rectangle coordinates.
bToDown
If TRUE the top of triangle turn downward, otherwise upward.

Remarks

You use this function to draw a triangle image on the header of the column that is sorted. Triangle represents the direction of sorting: ascending or descending. Sizes of the triangle depend on the rectangle area that is provided to draw

Example
// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::DrawVerticalLine Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::DrawVerticalLine Method

Draws vertical line.

void DrawVerticalLine(
    CDC* pDC,
    int xPos,
    int yPos,
    int cy,
    COLORREF clr
);
Parameters

pDC
Pointer to the used Device Context.
xPos
Horizontal coordinate of the beginning of line.
yPos
Vertical coordinate of the beginning of line.
cy
Length of line.
clr
Color of line.

Remarks

This member function is called in the control everywhere we need to draw a simple vertical line

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::EnablePreviewMode Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::EnablePreviewMode Method

Changes the preview mode state for the control.

void EnablePreviewMode(
    BOOL bIsPreviewMode
);
Parameters

bIsPreviewMode
New preview mode (TRUE or FALSE).

Remarks

Preview mode has two states: enable and disabled. When preview is enabled, the control tries to show additional bands with preview text

Example
// enable preview mode
EnablePreviewMode(TRUE);

// disable preview mode
EnablePreviewMode(FALSE);
Body Source
void CXTPReportPaintManager::EnablePreviewMode(BOOL bIsPreviewMode) {
    m_bIsPreviewMode = bIsPreviewMode;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::FillFooter Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::FillFooter Method

Fills column footer control area by its background.

virtual void FillFooter(
    CDC* pDC,
    CRect rcFooter
);
Parameters

pDC
Pointer to the used Device Context.
rcFooter
Footer area rectangle coordinates.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::FillGroupByControl Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::FillGroupByControl Method

Draws Group By box.

virtual void FillGroupByControl(
    CDC* pDC,
    CRect& rcGroupBy
);
Parameters

pDC
Pointer to the used Device Context.
rcGroupBy
Reference to Group By box area rectangle coordinates.

Example
CXTPReportPaintManager* pPaintManager = m_pControl->GetPaintManager();
pPaintManager->FillGroupByControl(pDC, rcGroupBy);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::FillGroupRowMetrics Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::FillGroupRowMetrics Method

Fill font and colors members of the metrics structure for the specified group row.

virtual void FillGroupRowMetrics(
    CXTPReportGroupRow* pRow,
    XTP_REPORTRECORDITEM_METRICS* pMetrics,
    BOOL bPrinting
);
Parameters

pRow
Pointer to the Group Row.
pMetrics
Pointer to the metrics structure to be filled.
bPrinting
Is printing mode.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::FillHeaderControl Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::FillHeaderControl Method

Fills column header control area by its background.

virtual void FillHeaderControl(
    CDC* pDC,
    CRect rcHeader
);
Parameters

pDC
Pointer to the used Device Context.
rcHeader
Header area rectangle coordinates.

Example
CXTPReportPaintManager* pPaintManager = m_pControl->GetPaintManager();
CRect rcHeader(rcClient);
int nHeaderHeight = m_pControl->GetHeaderHeight();
rcHeader.bottom = rcHeader.top + nHeaderHeight;
pPaintManager->FillHeaderControl(pDC, rcHeader);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::FillIndent Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::FillIndent Method

Fills indent area by its background.

virtual void FillIndent(
    CDC* pDC,
    CRect rcRow
);
Parameters

pDC
Pointer to the used Device Context.
rcRow
Row area rectangle coordinates.

Example
CXTPReportPaintManager* pPaintManager = m_pControl->GetPaintManager();
CRect rcRow(rcClient);
// Get default row height
int nRowHeight = m_pControl->GetRowHeight(FALSE)
rcRow.bottom = rcRow.top + nRowHeight;
pPaintManager->FillIndent(pDC, rcRow);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::FillItemShade Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::FillItemShade Method

Fills item shade by its background if necessary.

virtual void FillItemShade(
    CDC* pDC,
    CRect rcItem
);
Parameters

pDC
Pointer to the used Device Context.
rcItem
Item area rectangle coordinates.

Example
CXTPReportPaintManager* pPaintManager = m_pControl->GetPaintManager();
CRect rcItem(m_rcRow);
pPaintManager->FillItemShade(pDC, rcItem);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::FillRow Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::FillRow Method

Fills the provided row with its background color.

virtual void FillRow(
    CDC* pDC,
    CXTPReportRow* pRow,
    CRect rcRow
);
Parameters

pDC
Pointer to the used Device Context.
pRow
Pointer to the Row.
rcRow
Row area rectangle coordinates.

Example
// paint row background
pPaintManager->FillRow(pDC, this, rcRow);
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetColumnOffice2007CustomThemeBaseColor Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetColumnOffice2007CustomThemeBaseColor Method

Use this member function to get a header's custom theme base color for Office2007 column style.

COLORREF GetColumnOffice2007CustomThemeBaseColor() const;
Returns

A COLORREF value representing the custom theme base color for Office2007 column style. Value -1 means that standard theme is used.

See Also

SetColumnOffice2007CustomThemeBaseColor

Body Source
COLORREF CXTPReportPaintManager::GetColumnOffice2007CustomThemeBaseColor() const {
    return m_clrColumnOffice2007CustomTheme;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetColumnStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetColumnStyle Method

Use this member function to get a header style.

XTPReportColumnStyle GetColumnStyle() const;
Returns

A value from XTPReportColumnStyle enum.

See Also

SetColumnStyle, XTPReportColumnStyle

Body Source
XTPReportColumnStyle CXTPReportPaintManager::GetColumnStyle() const {
    return m_columnStyle;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetControlBackColor Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::GetControlBackColor Method

Returns control background color.

virtual COLORREF GetControlBackColor(
    CXTPReportControl* pControl
);
Parameters

pControl
Pointer to the parent report control object.

Returns

Color that is used for filling client rect.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetFooterHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::GetFooterHeight Method

Calculate optimal footer height.

virtual int GetFooterHeight(
    CXTPReportControl* pControl,
    CDC* pDC,
    int nTotalWidth = 0
);
Parameters

pControl
Pointer to a report control.
pDC
Pointer to device context.
nTotalWidth
Total header with. Used for printing only.

Returns

Optimal footer height.

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetFooterRowsDividerHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetFooterRowsDividerHeight Method

Get height of footer divider line.

int GetFooterRowsDividerHeight();
Returns

Footer divider height.

See Also

XTPReportFixedRowsDividerStyle

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetFooterRowsDividerStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetFooterRowsDividerStyle Method

Get style of footer divider line.

int GetFooterRowsDividerStyle() const;
Returns

A value from enum XTPReportFixedRowsDividerStyle.

See Also

XTPReportFixedRowsDividerStyle

Body Source
int  CXTPReportPaintManager::GetFooterRowsDividerStyle() const {
    return m_FooterRowsDividerStyle;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetFreezeColsDividerStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetFreezeColsDividerStyle Method

Get style of Freeze Columns Divider line.

int GetFreezeColsDividerStyle() const;
Returns

A value from enum XTPReportFreezeColsDividerStyle.

See Also

XTPReportFreezeColsDividerStyle

Body Source
int  CXTPReportPaintManager::GetFreezeColsDividerStyle() const {
    return m_nFreezeColsDividerStyle;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetGlyphsImageList Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetGlyphsImageList Method

Returns point to additional image list with Glyphs

CImageList* GetGlyphsImageList();
Returns

Pointer to the instantiated object of CImageList class

Remarks

Additional image list usually used for bitmaps of collapsed icons, etc You call this member function to get a pointer to list and manipulate its content as you wish

Body Source
CImageList* CXTPReportPaintManager::GetGlyphsImageList() {
    return &m_ilGlyphs;
}
Group

CXTPReportPaintManager Methods


GetHeaderHeight Method

CXTPReportPaintManager Methods
GetHeaderHeight Method
Overload List
Methods
Method | Description
CXTPReportPaintManager::GetHeaderHeight () | Returns the default column header height.
CXTPReportPaintManager::GetHeaderHeight (CXTPReportControl*, CDC*, int) | Calculate optimal header height.
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetHeaderHeight Method ()

GetHeaderHeight Method, CXTPReportPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetHeaderHeight Method ()

Returns the default column header height.

virtual int GetHeaderHeight();
Returns

The current height of the rectangle where column's headers draw.

Body Source
int CXTPReportPaintManager::GetHeaderHeight() {
    return m_nHeaderHeight;
}
Group

GetHeaderHeight Method


CXTPReportPaintManager::GetHeaderHeight Method (CXTPReportControl*, CDC*, int)

GetHeaderHeight Method, CXTPReportPaintManager Class
CXTPReportPaintManager::GetHeaderHeight Method (CXTPReportControl*, CDC*, int)

Calculate optimal header height.

virtual int GetHeaderHeight(
    CXTPReportControl* pControl,
    CDC* pDC,
    int nTotalWidth = 0
);
Parameters

pControl
Pointer to a report control.
pDC
Pointer to device context.
nTotalWidth
Total header with. Used for printing only.

Returns

Optimal header height.

Group

GetHeaderHeight Method


CXTPReportPaintManager::GetHeaderRowsDividerHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetHeaderRowsDividerHeight Method

Get height of header divider line.

int GetHeaderRowsDividerHeight();
Returns

Header divider height.

See Also

XTPReportFixedRowsDividerStyle

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetHeaderRowsDividerStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetHeaderRowsDividerStyle Method

Get style of header divider line.

int GetHeaderRowsDividerStyle() const;
Returns

A value from enum XTPReportFixedRowsDividerStyle.

See Also

XTPReportFixedRowsDividerStyle

Body Source
int  CXTPReportPaintManager::GetHeaderRowsDividerStyle() const {
    return m_HeaderRowsDividerStyle;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetMaxPreviewLines Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetMaxPreviewLines Method

Get the count of max lines of preview text.

int GetMaxPreviewLines();
Returns

Current value of max lines of text for a preview item.

Body Source
int CXTPReportPaintManager::GetMaxPreviewLines() {
    return m_nMaxPreviewLines;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetPreviewItemHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetPreviewItemHeight Method

Returns preview item height for print mode.

virtual int GetPreviewItemHeight(
    CDC* pDC,
    CXTPReportRow* pRow,
    int nWidth,
    int nHeight
);
Parameters

pDC
Pointer to the used Device Context.
pRow
Pointer to CXTPReportRow object.
nWidth
Width of the preview item.
nHeight
Height of the preview item.

Returns

The height of the default rectangle where preview item will draw.

Example
int nPreviewItemHeight = GetPreviewItemHeight(pDC, pRow, nWidth, nHeight)
Body Source
int CXTPReportPaintManager::GetPreviewItemHeight(CDC* /*pDC*/, CXTPReportRow* /*pRow*/, int /*nWidth*/, int nHeight) {
    return nHeight;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetPreviewLinesCount Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::GetPreviewLinesCount Method

Calculates the line count for preview text, takes into account max lines.

int GetPreviewLinesCount(
    CDC* pDC,
    CRect& rcText,
    const CString& strText
);
Parameters

pDC
Pointer to the used Device Context.
rcText
Reference to text area rectangle coordinates.
strText
String of text.

Returns

Returns the count of lines needed to draw preview text.

Remarks

This function calculates the count of preview text lines based on the length of preview text string, preview text font and width of provided rectangle. If default max lines count less than count of calculate lines, returns default max lines

Group

CXTPReportPaintManager Methods


GetRowHeight Method

CXTPReportPaintManager Methods
GetRowHeight Method
Overload List
Methods
Method | Description
CXTPReportPaintManager::GetRowHeight (CDC*, CXTPReportRow*) | Returns default row height for print mode.
CXTPReportPaintManager::GetRowHeight (CDC*, CXTPReportRow*, int) | Returns default row height for print mode.
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::GetRowHeight Method (CDC*, CXTPReportRow*)

GetRowHeight Method, CXTPReportPaintManager Class, Example
CXTPReportPaintManager::GetRowHeight Method (CDC*, CXTPReportRow*)

Returns default row height for print mode.

virtual int GetRowHeight(
    CDC* pDC,
    CXTPReportRow* pRow
);
virtual int GetRowHeight(
    CDC* pDC,
    CXTPReportRow* pRow,
    int nTotalWidth
);
Parameters

pDC
Pointer to the used Device Context.
pRow
Pointer to CXTPReportRow object.
nTotalWidth
Width of the row

Returns

The height of the default rectangle where row's items will draw.

Example
int nRowHeight = GetRowHeight(pDC, pRow)
Group

GetRowHeight Method


CXTPReportPaintManager::GetTextFont Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::GetTextFont Method

Returns the default text font for the control items.

CFont* GetTextFont();
Returns

Pointer to the current font used for drawing test.

Body Source
CFont* CXTPReportPaintManager::GetTextFont() {
    return &m_fontText;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::IsColumHotTrackingEnabled Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::IsColumHotTrackingEnabled Method

Call this method to determine if hot tracking is enabled for current column style.

BOOL IsColumHotTrackingEnabled() const;
Returns

TRUE if enabled; FALSE otherwise

Remarks

Hot Tracking can be used only for xtpReportColumnOffice2003 and xtpReportColumnExplorer styles.

See Also

m_columnStyle, m_bHotTracking

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::IsDrawGridForEmptySpace Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::IsDrawGridForEmptySpace Method

This method is called to determine if grid fills empty space after the body rows.

BOOL IsDrawGridForEmptySpace() const;
Returns

TRUE if grid fills empty space after the body rows, FALSE - otherwise (default).

See Also

SetDrawGridForEmptySpace

Body Source
BOOL CXTPReportPaintManager::IsDrawGridForEmptySpace() const {
    return m_bDrawGridForEmptySpace;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::IsFixedInplaceButtonHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::IsFixedInplaceButtonHeight Method

This method is called to determines if paint manager supports variable height of inplace buttons.

BOOL IsFixedInplaceButtonHeight() const;
Returns

TRUE if height of inplace buttons is fixed, FALSE if it is the same as row height.

See Also

SetInplaceButtonHeight

Body Source
BOOL CXTPReportPaintManager::IsFixedInplaceButtonHeight() const {
    return m_bFixedInplaceButtonHeight;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::IsFixedRowHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::IsFixedRowHeight Method

This method is called to determines if paint manager supports variable height of row

BOOL IsFixedRowHeight() const;
Returns

TRUE if GetRowHeight retrieves same value for each row.

See Also

GetRowHeight

Body Source
BOOL CXTPReportPaintManager::IsFixedRowHeight() const {
    return m_bFixedRowHeight;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::IsGridVisible Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::IsGridVisible Method

Return visibility of grid line

BOOL IsGridVisible(
    BOOL bVertical
) const;
Parameters

bVertical
determines which grid lines will be tested, vertical or horizontal.

Returns

boolean value which identifies the visibility of the line

Body Source
BOOL CXTPReportPaintManager::IsGridVisible(BOOL bVertical) const {
    return bVertical ? (m_verticalGridStyle != xtpReportGridNoLines) : (m_horizontalGridStyle != xtpReportGridNoLines);
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::IsPreviewMode Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::IsPreviewMode Method

Returns preview mode state for the control.

BOOL IsPreviewMode() const;
Returns

Current preview mode state.

Remarks

You use this member function to programmatically identify in which mode the control is

Body Source
BOOL CXTPReportPaintManager::IsPreviewMode() const {
    return m_bIsPreviewMode;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::OnDrawAction Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::OnDrawAction Method

Override this method to do custom activities for the item before processing it.

virtual BOOL OnDrawAction(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs
);
Parameters

pDrawArgs
pointer to structure with drawing arguments

Returns

boolean value - TRUE means that the item needs further processing

Body Source
BOOL CXTPReportPaintManager::OnDrawAction(XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs){
    UNREFERENCED_PARAMETER(pDrawArgs);
    return TRUE;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::RefreshMetrics Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::RefreshMetrics Method

Initializes all drawings defaults (fonts, colors, etc.). Most of them are system defaults.

virtual void RefreshMetrics();
See Also

CXTPReportPaintManager

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetCaptionFont Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetCaptionFont Method

Creates and sets the default caption font

void SetCaptionFont(
    LOGFONT& lf
);
Parameters

lf
Reference to LOGFONT structure

See Also

LOGFONT, SetTextFont

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetColumnOffice2007CustomThemeBaseColor Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetColumnOffice2007CustomThemeBaseColor Method

Use this member function to set a header's custom theme base color for Office2007 column style.

void SetColumnOffice2007CustomThemeBaseColor(
    COLORREF clrBaseColor
);
Parameters

clrTheme
A COLORREF value representing the custom theme base color. Set this value as -1 to use standard theme.

See Also

GetColumnOffice2007CustomThemeBaseColor

Body Source
void CXTPReportPaintManager::SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) {
    m_clrColumnOffice2007CustomTheme = clrBaseColor;
    RefreshMetrics();
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetColumnStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetColumnStyle Method

Use this member function to set a header style.

void SetColumnStyle(
    XTPReportColumnStyle columnStyle
);
Parameters

columnStyle
A value from XTPReportColumnStyle enum.

See Also

GetColumnStyle, XTPReportColumnStyle

Body Source
void CXTPReportPaintManager::SetColumnStyle(XTPReportColumnStyle columnStyle) {
    m_columnStyle = columnStyle;
    RefreshMetrics();
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetDrawGridForEmptySpace Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetDrawGridForEmptySpace Method

This method is called to determine if grid fills empty space after the body rows.

void SetDrawGridForEmptySpace(
    BOOL bDrawGrid
);
Returns

TRUE if grid fills empty space after the body rows, FALSE - otherwise (default).

See Also

IsDrawGridForEmptySpace

Body Source
void CXTPReportPaintManager::SetDrawGridForEmptySpace(BOOL bDrawGrid){
    m_bDrawGridForEmptySpace= bDrawGrid;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetFixedRowHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetFixedRowHeight Method

This method is called to set if paint manager supports variable height of row

void SetFixedRowHeight(
    BOOL bFixedRowHeight
);
Parameters

bFixedRowHeight
TRUE to set Fixed Row height, FALSE to set variable

See Also

GetRowHeight

Body Source
void CXTPReportPaintManager::SetFixedRowHeight(BOOL bFixedRowHeight){
    m_bFixedRowHeight = bFixedRowHeight;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetFooterRowsDividerStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetFooterRowsDividerStyle Method

Set style of footer divider line.

void SetFooterRowsDividerStyle(
    int nStyle
);
Parameters

nStyle
A value from enum XTPReportFixedRowsDividerStyle.

See Also

XTPReportFixedRowsDividerStyle

Body Source
void CXTPReportPaintManager::SetFooterRowsDividerStyle(int nStyle) {
    m_FooterRowsDividerStyle = (XTPReportFixedRowsDividerStyle) nStyle;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetFreezeColsDividerStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetFreezeColsDividerStyle Method

Set style of Freeze Columns Divider line.

void SetFreezeColsDividerStyle(
    int nStyle
);
Parameters

nStyle
A value from enum XTPReportFreezeColsDividerStyle.

See Also

XTPReportFreezeColsDividerStyle

Body Source
void CXTPReportPaintManager::SetFreezeColsDividerStyle(int nStyle) {
    m_nFreezeColsDividerStyle = nStyle;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetGridColor Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetGridColor Method

Changes report control grid lines color.

COLORREF SetGridColor(
    COLORREF clrGridLine
);
Parameters

clrGridLine
New grid color.

Returns

Previous grid color

Example
// Set new color, save old one
COLORREF clrNew;
clrNew = RGB(0, 255, 0);
COLORREF clrOld;
clrOld = SetGridColor(clrNew);
Body Source
COLORREF CXTPReportPaintManager::SetGridColor(COLORREF clrGridLine){
    COLORREF clrOldColor = m_clrGridLine;
    m_clrGridLine.SetCustomValue(clrGridLine);
    return clrOldColor;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetGridStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetGridStyle Method

Sets one of the predefined grid line styles

void SetGridStyle(
    BOOL bVertical,
    XTPReportGridStyle gridStyle
);
Parameters

bVertical
Determines which grid lines settings, vertical or horizontal
gridStyle
Grid style. Can be one of the values listed in the remarks section.

Remarks

Grid style can be one of the following:

  • xtpReportGridNoLines Empty line
  • xtpReportGridSmallDots Line drawn by small dots
  • xtpReportGridLargeDots Line drawn by large dots
  • xtpReportGridDashes Line drawn by dashes
  • xtpReportGridSolid Draws solid line
See Also

XTPReportGridStyle

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetHeaderRowsDividerStyle Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetHeaderRowsDividerStyle Method

Set style of header divider line.

void SetHeaderRowsDividerStyle(
    int nStyle
);
Parameters

nStyle
A value from enum XTPReportFixedRowsDividerStyle.

See Also

XTPReportFixedRowsDividerStyle

Body Source
void CXTPReportPaintManager::SetHeaderRowsDividerStyle(int nStyle) {
    m_HeaderRowsDividerStyle = (XTPReportFixedRowsDividerStyle) nStyle;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetInplaceButtonHeight Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetInplaceButtonHeight Method

This method is called to set if paint manager supports fixed height of inplace buttons.

void SetInplaceButtonHeight(
    BOOL bFixedInplaceButtonHeight
);
Parameters

bFixedInplaceButtonHeight
TRUE to set Fixed button height, FALSE to set variable (the same as row height).

See Also

IsFixedInplaceButtonHeight

Body Source
void CXTPReportPaintManager::SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight){
    m_bFixedInplaceButtonHeight= bFixedInplaceButtonHeight;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetMaxPreviewLines Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetMaxPreviewLines Method

Set count of max lines of the preview text.

int SetMaxPreviewLines(
    int nMaxLines
);
Parameters

nMaxLines
New value of max lines of text for a preview item.

Returns

Previous value of max lines of text for a preview item.

Remarks

You use this member function to bound the height of a textPreview item by setting the maximum rows of text for it

Example
int nOldMaxLines = SetMaxPreviewLines(4);
Body Source
int CXTPReportPaintManager::SetMaxPreviewLines(int nMaxLines) {
    int nOldMaxLines = m_nMaxPreviewLines;
    m_nMaxPreviewLines = nMaxLines;
    return nOldMaxLines;
}
Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetPreviewIndent Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class
CXTPReportPaintManager::SetPreviewIndent Method

Call this method to set the preview item indent.

void SetPreviewIndent(
    int nLeft,
    int nTop,
    int nRight,
    int nBottom
);
Parameters

nLeft
Left indent to be used
nTop
Top indent to be used
nRight
Right indent to be used
nBottom
Bottom indent to be used

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager::SetTextFont Method

CXTPReportPaintManager Methods, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::SetTextFont Method

Creates and sets default text font

void SetTextFont(
    LOGFONT& lf
);
Parameters

lf
Reference to LOGFONT structure

See Also

LOGFONT, SetCaptionFont

Group

CXTPReportPaintManager Methods


CXTPReportPaintManager Constructors

CXTPReportPaintManager Class, Legend, Public Methods
CXTPReportPaintManager Constructors
Class

CXTPReportPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportPaintManager | Default paint manager constructor, handles properties initialization.


CXTPReportPaintManager::CXTPReportPaintManager Constructor

CXTPReportPaintManager Constructors, CXTPReportPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::CXTPReportPaintManager Constructor

Default paint manager constructor, handles properties initialization.

CXTPReportPaintManager();
See Also

RefreshMetrics

Group

CXTPReportPaintManager Constructors


CXTPReportPaintManager Destructors

CXTPReportPaintManager Class, Legend, Public Methods
CXTPReportPaintManager Destructors
Class

CXTPReportPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportPaintManager | Default paint manager destructor, handles member items deallocation.


CXTPReportPaintManager::~CXTPReportPaintManager Destructor

CXTPReportPaintManager Destructors, CXTPReportPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportPaintManager::~CXTPReportPaintManager Destructor

Default paint manager destructor, handles member items deallocation.

virtual ~CXTPReportPaintManager();
Group

CXTPReportPaintManager Destructors


CXTPReportRecord Class

XTPReportRecord.h, Classes, Legend, Members, Topics, CXTPReportRecord Data Members, CXTPReportRecord Methods, CXTPReportRecord Constructors, CXTPReportRecord Destructors, CXTPReportRecord Constructors, CXTPReportRecord Data Members, CXTPReportRecord Destructors, Example, CXTPReportRecord Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord Class

CXTPReportRecord represents a collection of objects of CXTPReportRecordItem or objects of classes that are children of CXTPReportRecordItem. A collection of such items is one record in ReportControl list. You create an object of CXTPReportRecord by simply calling constructor. After it you can add items to the record.

Class Hierarchy

class CXTPReportRecord : public CXTPHeapObjectT<CCmdTarget, CXTPReportDataAllocator>;
File

XTPReportRecord.h

Example
// add new record to the record list
CXTPReportRecords* pList = new CXTPReportRecords();
pList->Add(new CXTPReportRecord());
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRecord Constructors
CXTPReportRecord Constructors | Description
CXTPReportRecord | Constructs a CXTPReportRecord object
CXTPReportRecord Data Members
CXTPReportRecord Data Members | Description
m_arrItems | An internal storage for record items.
m_bEditable | TRUE if the record is editable, FALSE otherwise.
m_bExpanded | Contains record expanded state.
m_bLocked | Stores locked state for the record.
m_bVisible | Is this record visible or not
m_nIndex | Index of the record within the collection records.
m_pChildren | A collection of children records.
m_pPreviewItem | store Preview Item for record
m_pRecords | Parent records collection.
CXTPReportRecord Destructors
CXTPReportRecord Destructors | Description
~CXTPReportRecord | Destroys a CXTPReportRecord object, handles cleanup and deallocation
CXTPReportRecord Methods
CXTPReportRecord Methods | Description
AddItem | Adds a record item to the internal records item collection.
Delete | Call this method to remove record
DoPropExchange | Call this member function to Store/Load a report record with record items using the specified data object.
GetChilds | Returns record children.
GetIndex | Retrieves record index in the array.
GetItem |
GetItemCount | Returns the number of items inside record.
GetItemMetrics | Calculates item metrics based on the provided draw arguments. Could be overridden by descendants.
GetItemPreview | Returns a preview item.
GetRecords | Returns parent records.
HasChildren | Determines if record has children records
IndexOf | Returns an index of the provided record item object.
IsEditable | Returns record editable state.
IsExpanded | Returns the expanded state of the Record
IsFiltered | Returns TRUE if record is filtered.
IsLocked | Returns record locked state.
IsVisible | Returns record visible state.
RemoveAll | Removes all items.
SetEditable | Sets record editable state.
SetExpanded | This member function sets the expanded state of the Record
SetLocked | Sets record locked state.
SetPreviewItem | Sets preview item for the record.
SetVisible | Sets record visibility state.
TreeAddRef | Call this method to increment reference counter of a record and all its children
TreeRelease | Call this method to decrement reference counter of a record and all its children


CXTPReportRecord Data Members

CXTPReportRecord Class, Legend, Protected Data Members
CXTPReportRecord Data Members
Class

CXTPReportRecord Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrItems | An internal storage for record items.
m_bEditable | TRUE if the record is editable, FALSE otherwise.
m_bExpanded | Contains record expanded state.
m_bLocked | Stores locked state for the record.
m_bVisible | Is this record visible or not
m_nIndex | Index of the record within the collection records.
m_pChildren | A collection of children records.
m_pPreviewItem | store Preview Item for record
m_pRecords | Parent records collection.


CXTPReportRecord::m_arrItems Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_arrItems Data Member

An internal storage for record items.

CArray<CXTPReportRecordItem*, CXTPReportRecordItem*> m_arrItems;
Group

CXTPReportRecord Data Members


CXTPReportRecord::m_bEditable Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_bEditable Data Member

TRUE if the record is editable, FALSE otherwise.

BOOL m_bEditable;
Group

CXTPReportRecord Data Members


CXTPReportRecord::m_bExpanded Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_bExpanded Data Member

Contains record expanded state.

BOOL m_bExpanded;
Group

CXTPReportRecord Data Members


CXTPReportRecord::m_bLocked Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_bLocked Data Member

Stores locked state for the record.

BOOL m_bLocked;
Group

CXTPReportRecord Data Members


CXTPReportRecord::m_bVisible Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_bVisible Data Member

Is this record visible or not

BOOL m_bVisible;
Group

CXTPReportRecord Data Members


CXTPReportRecord::m_nIndex Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_nIndex Data Member

Index of the record within the collection records.

int m_nIndex;
Group

CXTPReportRecord Data Members


CXTPReportRecord::m_pChildren Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_pChildren Data Member

A collection of children records.

CXTPReportRecords* m_pChildren;
Group

CXTPReportRecord Data Members


CXTPReportRecord::m_pPreviewItem Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_pPreviewItem Data Member

store Preview Item for record

CXTPReportRecordItemPreview* m_pPreviewItem;
Group

CXTPReportRecord Data Members


CXTPReportRecord::m_pRecords Data Member

CXTPReportRecord Data Members, CXTPReportRecord Class
CXTPReportRecord::m_pRecords Data Member

Parent records collection.

CXTPReportRecords* m_pRecords;
Group

CXTPReportRecord Data Members


CXTPReportRecord Methods

CXTPReportRecord Class, Legend, Public Methods
CXTPReportRecord Methods
Class

CXTPReportRecord Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AddItem | Adds a record item to the internal records item collection.
Delete | Call this method to remove record
DoPropExchange | Call this member function to Store/Load a report record with record items using the specified data object.
GetChilds | Returns record children.
GetIndex | Retrieves record index in the array.
GetItem |
GetItemCount | Returns the number of items inside record.
GetItemMetrics | Calculates item metrics based on the provided draw arguments. Could be overridden by descendants.
GetItemPreview | Returns a preview item.
GetRecords | Returns parent records.
HasChildren | Determines if record has children records
IndexOf | Returns an index of the provided record item object.
IsEditable | Returns record editable state.
IsExpanded | Returns the expanded state of the Record
IsFiltered | Returns TRUE if record is filtered.
IsLocked | Returns record locked state.
IsVisible | Returns record visible state.
RemoveAll | Removes all items.
SetEditable | Sets record editable state.
SetExpanded | This member function sets the expanded state of the Record
SetLocked | Sets record locked state.
SetPreviewItem | Sets preview item for the record.
SetVisible | Sets record visibility state.
TreeAddRef | Call this method to increment reference counter of a record and all its children
TreeRelease | Call this method to decrement reference counter of a record and all its children


CXTPReportRecord::AddItem Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::AddItem Method

Adds a record item to the internal records item collection.

CXTPReportRecordItem* AddItem(
    CXTPReportRecordItem* pItem
);
Parameters

pItem
Pointer to the new record item.

Returns

Pointer to the recently added record item.

Group

CXTPReportRecord Methods


CXTPReportRecord::Delete Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::Delete Method

Call this method to remove record

void Delete();
Group

CXTPReportRecord Methods


CXTPReportRecord::DoPropExchange Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::DoPropExchange Method

Call this member function to Store/Load a report record with record items using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Group

CXTPReportRecord Methods


CXTPReportRecord::GetChilds Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::GetChilds Method

Returns record children.

CXTPReportRecords* GetChilds();
Returns

A collection of record children.

Remarks

ReportRecord can have a list of child items. To get the pointer to that list, use GetChilds()

Group

CXTPReportRecord Methods


CXTPReportRecord::GetIndex Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::GetIndex Method

Retrieves record index in the array.

int GetIndex() const;
Returns

The record index in the array.

Group

CXTPReportRecord Methods


GetItem Method

CXTPReportRecord Methods
GetItem Method
Overload List
Methods
Method | Description
CXTPReportRecord::GetItem (CXTPReportColumn*) | Returns an item by its index or column.
CXTPReportRecord::GetItem (int) | Returns an item by its index or column.
Group

CXTPReportRecord Methods


CXTPReportRecord::GetItem Method (int)

GetItem Method, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::GetItem Method (int)

Returns an item by its index or column.

CXTPReportRecordItem* GetItem(
    int nIndex
) const;
CXTPReportRecordItem* GetItem(
    CXTPReportColumn* pColumn
) const;
Parameters

nIndex
zero-based index of item in the collection.
pColumn
A pointer to a column object to find an item by.

Returns

Pointer to the found record item, if any, or NULL otherwise.

Remarks

You use this member function to get an item from collection by item index. If the given index is less than 0 or greater than the value returned by GetItemCount, GetItem returns NULL.

See Also

GetItemCount

Body Source
CXTPReportRecordItem* CXTPReportRecord::GetItem(int nIndex) const {
    return nIndex >= 0 && nIndex < GetItemCount() ? m_arrItems.GetAt(nIndex) : NULL;
}
Group

GetItem Method


CXTPReportRecord::GetItemCount Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::GetItemCount Method

Returns the number of items inside record.

int GetItemCount() const;
Returns

The number of items inside the record.

See Also

GetItem

Body Source
int CXTPReportRecord::GetItemCount() const{
    return (int)m_arrItems.GetSize();
}
Group

CXTPReportRecord Methods


CXTPReportRecord::GetItemMetrics Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::GetItemMetrics Method

Calculates item metrics based on the provided draw arguments. Could be overridden by descendants.

virtual void GetItemMetrics(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pItemMetrics
);
Parameters

pDrawArgs
Draw arguments for calculating item metrics.
pItemMetrics
Pointer to the metrics item to fill with values.

Body Source
void CXTPReportRecord::GetItemMetrics(XTP_REPORTRECORDITEM_DRAWARGS* /*pDrawArgs*/, XTP_REPORTRECORDITEM_METRICS* /*pItemMetrics*/) {

}
Group

CXTPReportRecord Methods


CXTPReportRecord::GetItemPreview Method

CXTPReportRecord Methods, CXTPReportRecord Class, See Also
CXTPReportRecord::GetItemPreview Method

Returns a preview item.

CXTPReportRecordItemPreview* GetItemPreview() const;
Returns

Associated Preview item.

Remarks

Preview items stores separate from all others items. One Record can have only one Preview Item. If ReportRecord doesn't have a preview item, GetItemPreview() returns NULL

See Also

SetPreviewItem

Group

CXTPReportRecord Methods


CXTPReportRecord::GetRecords Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::GetRecords Method

Returns parent records.

CXTPReportRecords* GetRecords() const;
Returns

A collection of parent records.

Body Source
CXTPReportRecords* CXTPReportRecord::GetRecords() const {
    return m_pRecords;
}
Group

CXTPReportRecord Methods


CXTPReportRecord::HasChildren Method

CXTPReportRecord Methods, CXTPReportRecord Class, See Also
CXTPReportRecord::HasChildren Method

Determines if record has children records

BOOL HasChildren() const;
Returns

TRUE if record has children records

See Also

GetChilds

Group

CXTPReportRecord Methods


CXTPReportRecord::IndexOf Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::IndexOf Method

Returns an index of the provided record item object.

int IndexOf(
    const CXTPReportRecordItem* pItem
) const;
Parameters

pItem
record item which index need to retrieve.

Returns

Zero-based index of provided record item

Remarks

This member function is used to get the zero-based index of items in the record collection. If the item is not found, it returns -1

Group

CXTPReportRecord Methods


CXTPReportRecord::IsEditable Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::IsEditable Method

Returns record editable state.

BOOL IsEditable() const;
Returns

TRUE if the record is editable, FALSE otherwise.

See Also

SetEditable

Body Source
BOOL CXTPReportRecord::IsEditable() const {
    return m_bEditable;
}
Group

CXTPReportRecord Methods


CXTPReportRecord::IsExpanded Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::IsExpanded Method

Returns the expanded state of the Record

BOOL IsExpanded() const;
Returns

BOOLEAN value the represent expanded state of ReportRecord

Remarks

Returns expanded state of the Record. If expanded state is set to TRUE, the control tries to draw the record with all its children

See Also

SetExpanded

Body Source
BOOL CXTPReportRecord::IsExpanded() const {
    return m_bExpanded;
}
Group

CXTPReportRecord Methods


CXTPReportRecord::IsFiltered Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::IsFiltered Method

Returns TRUE if record is filtered.

virtual BOOL IsFiltered() const;
Returns

TRUE if the record is filtered, FALSE otherwise

Group

CXTPReportRecord Methods


CXTPReportRecord::IsLocked Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::IsLocked Method

Returns record locked state.

BOOL IsLocked() const;
Returns

TRUE if the record is locked, FALSE otherwise.

See Also

SetLocked

Body Source
BOOL CXTPReportRecord::IsLocked() const {
    return m_bLocked;
}
Group

CXTPReportRecord Methods


CXTPReportRecord::IsVisible Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::IsVisible Method

Returns record visible state.

BOOL IsVisible() const;
Returns

Boolean value that represents visible state.

Remarks

This member function returns FALSE if the record should be invisible, TRUE if visible.

See Also

SetVisible

Body Source
BOOL CXTPReportRecord::IsVisible() const {
    return m_bVisible;
}
Group

CXTPReportRecord Methods


CXTPReportRecord::RemoveAll Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::RemoveAll Method

Removes all items.

void RemoveAll();
Group

CXTPReportRecord Methods


CXTPReportRecord::SetEditable Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::SetEditable Method

Sets record editable state.

void SetEditable(
    BOOL bEditable = TRUE
);
Parameters

bEditable
TRUE if the record is editable, FALSE otherwise.

Group

CXTPReportRecord Methods


CXTPReportRecord::SetExpanded Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::SetExpanded Method

This member function sets the expanded state of the Record

void SetExpanded(
    BOOL bExpanded
);
Parameters

bExpanded
TRUE to set record expanded.

Remarks

Returns the expanded state of the Record. If the expanded state is set to TRUE, the control tries to draw the record with all its children

See Also

IsExpanded

Body Source
void CXTPReportRecord::SetExpanded(BOOL bExpanded) {
    m_bExpanded = bExpanded;
}
Group

CXTPReportRecord Methods


CXTPReportRecord::SetLocked Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::SetLocked Method

Sets record locked state.

BOOL SetLocked(
    BOOL bLocked
);
Parameters

bLocked
TRUE if record is locked, FALSE otherwise.

Returns

Old record locked state.

Remarks

You set the record locked when it shouldn't be sorted on hide. To set record locked or unlocked, you use SetLocked(BOOL)

See Also

IsLocked

Body Source
BOOL CXTPReportRecord::SetLocked(BOOL bLocked) {
    BOOL bOldLocked = m_bLocked; m_bLocked = bLocked; return bOldLocked;
}
Group

CXTPReportRecord Methods


CXTPReportRecord::SetPreviewItem Method

CXTPReportRecord Methods, CXTPReportRecord Class, See Also
CXTPReportRecord::SetPreviewItem Method

Sets preview item for the record.

void SetPreviewItem(
    CXTPReportRecordItemPreview* pItemPreview
);
Parameters

pItemPreview
Pointer to the associated preview item.

Remarks

Preview items stores separate from all others items. One Record can have only one Preview Item.

See Also

GetItemPreview

Group

CXTPReportRecord Methods


CXTPReportRecord::SetVisible Method

CXTPReportRecord Methods, CXTPReportRecord Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecord::SetVisible Method

Sets record visibility state.

BOOL SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE if the record should be visible, FALSE if the record should be hidden.

Returns

Old record visibility state.

See Also

IsVisible

Body Source
BOOL CXTPReportRecord::SetVisible(BOOL bVisible) {
    BOOL bOldVisible = m_bVisible; m_bVisible = bVisible; return bOldVisible;
}
Group

CXTPReportRecord Methods


CXTPReportRecord::TreeAddRef Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::TreeAddRef Method

Call this method to increment reference counter of a record and all its children

void TreeAddRef();
Group

CXTPReportRecord Methods


CXTPReportRecord::TreeRelease Method

CXTPReportRecord Methods, CXTPReportRecord Class
CXTPReportRecord::TreeRelease Method

Call this method to decrement reference counter of a record and all its children

void TreeRelease();
Group

CXTPReportRecord Methods


CXTPReportRecord Constructors

CXTPReportRecord Class, Legend, Public Methods
CXTPReportRecord Constructors
Class

CXTPReportRecord Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecord | Constructs a CXTPReportRecord object


CXTPReportRecord::CXTPReportRecord Constructor

CXTPReportRecord Constructors, CXTPReportRecord Class
CXTPReportRecord::CXTPReportRecord Constructor

Constructs a CXTPReportRecord object

CXTPReportRecord();
Group

CXTPReportRecord Constructors


CXTPReportRecord Destructors

CXTPReportRecord Class, Legend, Public Methods
CXTPReportRecord Destructors
Class

CXTPReportRecord Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportRecord | Destroys a CXTPReportRecord object, handles cleanup and deallocation


CXTPReportRecord::~CXTPReportRecord Destructor

CXTPReportRecord Destructors, CXTPReportRecord Class
CXTPReportRecord::~CXTPReportRecord Destructor

Destroys a CXTPReportRecord object, handles cleanup and deallocation

virtual ~CXTPReportRecord();
Group

CXTPReportRecord Destructors


CXTPReportRecordItem Class

XTPReportRecordItem.h, Classes, Legend, Members, Topics, CXTPReportRecordItem Data Members, CXTPReportRecordItem Methods, CXTPReportRecordItem Constructors, CXTPReportRecordItem Destructors, CXTPReportRecordItem Constructors, CXTPReportRecordItem Data Members, CXTPReportRecordItem Destructors, CXTPReportRecordItem Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem Class

Class for working with single list cell. Base class for extended list cells. It determines the behavior of all specific record items. You don't use its class directly in the control. If you wish to add your own Record Item to the control, you must inherit it from CXTPReportRecordItem. Most member functions in this class are virtual.

Class Hierarchy

class CXTPReportRecordItem : public CXTPHeapObjectT<CCmdTarget, CXTPReportDataAllocator>;
File

XTPReportRecordItem.h

See Also

CXTPReportRecordItemDateTime, CXTPReportRecordItemNumber, CXTPReportRecordItemPreview, CXTPReportRecordItemText, CXTPReportRecordItemVariant

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRecordItem Constructors
CXTPReportRecordItem Constructors | Description
CXTPReportRecordItem | CXTPReportRecordItem default constructor
CXTPReportRecordItem Data Members
CXTPReportRecordItem Data Members | Description
m_Alignment | Alignment style for item.
m_bBoldText | Is bold text.
m_bChecked | TRUE if item checked.
m_bEditable | Stores editable flag.
m_bFocusable | TRUE if item accept focus.
m_bHasCheckbox | TRUE if item has check box.
m_bItemControlUnderMouse | TRUE if an item control is under the mouse pointer.
m_clrBackground | Storage for item background color.
m_clrText | Storage for item text color.
m_dwData | The 32-bit value associated with the item.
m_nGroupPriority | Group priority
m_nIconIndex | ID of the bitmap from the application resources.
m_nSortPriority | Sort priority
m_pEditOptions | Edit options of the item.
m_pFocusedItemControl | Focused record item control.
m_pFontCaption | Storage for item caption font.
m_pHyperlinks | Array of the Item's hyperlinks
m_pItemControlHookWnd | Item control hook window.
m_pItemControls | Record item control list.
m_pRecord | Pointer to the associated record item, if any, or NULL otherwise.
m_rcGlyph | Coordinates of drawn glyph.
m_strCaption | Caption of the item
m_strFormatString | Stores string for extra formatting of item caption.
m_strGroupCaption | Caption of the group
m_strTooltip | Tooltip of the item.
CXTPReportRecordItem Destructors
CXTPReportRecordItem Destructors | Description
~CXTPReportRecordItem | CXTPReportRecordItem default destructor
CXTPReportRecordItem Methods
CXTPReportRecordItem Methods | Description
AddHyperlink | Adds new Hyperlink.
Compare | Compares this item with the provided one. Provides default behavior for descendants.
CompareGroupCaption | Compares group captions.
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
Draw | Should be overridden by descendants for drawing itself.
DrawCheckBox | Draws check box bitmap
GetAlignment | Returns the current alignment value for the item.
GetCaption | Returns item text caption.
GetCaptionRect | Retrieves caption text bounding rectangle
GetEditOptions | Retrieves edit options of item.
GetFont | Call this member function to get item text font.
GetFormatString | Gets item caption format string.
GetGroupCaption | Returns group caption.
GetGroupCaptionID | Returns resource id of string containing text
GetGroupPriority | Retrieves sort priority of the item.
GetHasCheckbox | Determines if item has check box area
GetHyperlinkAt | Return Hyperlink by it's index.
GetHyperlinks | Use this function to access hyperlinks collection.
GetHyperlinksCount | Returns a count of hyperlinks in record item
GetIconIndex | Returns an ID of the associated resource bitmap.
GetIndex | Returns item index.
GetItemControls | Retrieves item controls list.
GetItemData | This method retrieves the application-supplied 32-bit value associated with the item.
GetItemMetrics | Fills XTP_REPORTRECORDITEM_METRICS structure
GetRecord | Retrieved parent record object.
GetSelectedConstraintData | Retrieves associated value with selected constraint.
GetSortPriority | Retrieves sort priority of the item.
GetTooltip | Returns the text tool tip for the item
HasCheckbox | Adds check box area for item.
HitTest | Determines which report item control, if any, is at a specified position.
HitTestHyperlink | Determine if the click occurred on the hyperlink
IsBold | Returns the Bold state for the item
IsChecked | Determines if the item is checked
IsEditable | Call this member function to programmatically check if item is editable.
IsFocusable | Call this member to determine if a CXTPReportRecordItem can receive focus.
IsPreviewItem | Determines if this item is a preview item.
OnBeginEdit | This method is called when user begin edit item.
OnCancelEdit | This method is called when user cancel edit item.
OnChar | This method is called when user press key.
OnClick | Processes single mouse clicks.
OnConstraintChanged | This method is called when user select specified constraint in in-place list
OnDblClick | Processes single mouse clicks.
OnDrawCaption | Should be overridden by descendants for drawing itself.
OnDrawControls | Should be overridden by descendants for drawing itself.
OnEditCanceled | This method is called when in-place editing is canceled and value is not changed.
OnEditChanged | This method is called when value of in-place edit control changed
OnEditChanging | This method is called when in-place editor value changed by user
OnInplaceButtonDown | This method is called when user press in-place button of the item.
OnLButtonDown | Processes mouse left button down clicks.
OnLButtonUp | Processes mouse left button up clicks.
OnMouseMove | Processes the move mouse event.
OnRequestEdit | This method is called when an editable item enters edit mode.
OnValidateEdit | This method is called to save value from in-place edit
RemoveHyperlinkAt | Call this member function to remove hyperlink at the specified index.
SetAlignment | Sets new alignment value for the item.
SetBackgroundColor | Sets item text background color.
SetBold | Sets/clears bold flag for the item font.
SetCaption | Sets caption of the item.
SetChecked | Call this method to check the item.
SetEditable | Sets editable flag.
SetFocusable | Call this member to specify whether the CXTPReportRecordItem can have focus.
SetFont | Sets item text font.
SetFormatString | Sets item caption format string.
SetGroupCaption | Sets the group caption of the item.
SetGroupPriority | Sets the group priority of the item.
SetIconIndex | Sets new associated bitmap ID.
SetItemData | Call this method to set the 32-bit value associated with the item.
SetSortPriority | Sets the sort priority of the item.
SetTextColor | Sets item text color.
SetTooltip | Call this member to set/change the item tool tip.


CXTPReportRecordItem Data Members

CXTPReportRecordItem Class, Legend, Protected Data Members
CXTPReportRecordItem Data Members
Class

CXTPReportRecordItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_Alignment | Alignment style for item.
m_bBoldText | Is bold text.
m_bChecked | TRUE if item checked.
m_bEditable | Stores editable flag.
m_bFocusable | TRUE if item accept focus.
m_bHasCheckbox | TRUE if item has check box.
m_bItemControlUnderMouse | TRUE if an item control is under the mouse pointer.
m_clrBackground | Storage for item background color.
m_clrText | Storage for item text color.
m_dwData | The 32-bit value associated with the item.
m_nGroupPriority | Group priority
m_nIconIndex | ID of the bitmap from the application resources.
m_nSortPriority | Sort priority
m_pEditOptions | Edit options of the item.
m_pFocusedItemControl | Focused record item control.
m_pFontCaption | Storage for item caption font.
m_pHyperlinks | Array of the Item's hyperlinks
m_pItemControlHookWnd | Item control hook window.
m_pItemControls | Record item control list.
m_pRecord | Pointer to the associated record item, if any, or NULL otherwise.
m_rcGlyph | Coordinates of drawn glyph.
m_strCaption | Caption of the item
m_strFormatString | Stores string for extra formatting of item caption.
m_strGroupCaption | Caption of the group
m_strTooltip | Tooltip of the item.


CXTPReportRecordItem::m_Alignment Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_Alignment Data Member

Alignment style for item.

XTPReportColumnIconAlignment m_Alignment;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_bBoldText Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_bBoldText Data Member

Is bold text.

BOOL m_bBoldText;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_bChecked Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_bChecked Data Member

TRUE if item checked.

BOOL m_bChecked;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_bEditable Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_bEditable Data Member

Stores editable flag.

BOOL m_bEditable;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_bFocusable Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_bFocusable Data Member

TRUE if item accept focus.

BOOL m_bFocusable;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_bHasCheckbox Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_bHasCheckbox Data Member

TRUE if item has check box.

BOOL m_bHasCheckbox;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_bItemControlUnderMouse Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_bItemControlUnderMouse Data Member

TRUE if an item control is under the mouse pointer.

BOOL m_bItemControlUnderMouse;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_clrBackground Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_clrBackground Data Member

Storage for item background color.

COLORREF m_clrBackground;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_clrText Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_clrText Data Member

Storage for item text color.

COLORREF m_clrText;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_dwData Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_dwData Data Member

The 32-bit value associated with the item.

DWORD_PTR m_dwData;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_nGroupPriority Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_nGroupPriority Data Member

Group priority

int m_nGroupPriority;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_nIconIndex Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_nIconIndex Data Member

ID of the bitmap from the application resources.

int m_nIconIndex;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_nSortPriority Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_nSortPriority Data Member

Sort priority

int m_nSortPriority;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_pEditOptions Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_pEditOptions Data Member

Edit options of the item.

CXTPReportRecordItemEditOptions* m_pEditOptions;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_pFocusedItemControl Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_pFocusedItemControl Data Member

Focused record item control.

CXTPReportRecordItemControl* m_pFocusedItemControl;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_pFontCaption Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_pFontCaption Data Member

Storage for item caption font.

CFont* m_pFontCaption;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_pHyperlinks Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_pHyperlinks Data Member

Array of the Item's hyperlinks

CXTPReportHyperlinks* m_pHyperlinks;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_pItemControlHookWnd Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_pItemControlHookWnd Data Member

Item control hook window.

CXTPReportRecordItemControlHookWnd* m_pItemControlHookWnd;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_pItemControls Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_pItemControls Data Member

Record item control list.

CXTPReportRecordItemControls* m_pItemControls;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_pRecord Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_pRecord Data Member

Pointer to the associated record item, if any, or NULL otherwise.

CXTPReportRecord* m_pRecord;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_rcGlyph Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_rcGlyph Data Member

Coordinates of drawn glyph.

CRect m_rcGlyph;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_strCaption Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_strCaption Data Member

Caption of the item

CString m_strCaption;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_strFormatString Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_strFormatString Data Member

Stores string for extra formatting of item caption.

CString m_strFormatString;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_strGroupCaption Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_strGroupCaption Data Member

Caption of the group

CString m_strGroupCaption;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem::m_strTooltip Data Member

CXTPReportRecordItem Data Members, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::m_strTooltip Data Member

Tooltip of the item.

CString m_strTooltip;
Group

CXTPReportRecordItem Data Members


CXTPReportRecordItem Methods

CXTPReportRecordItem Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem Methods
Class

CXTPReportRecordItem Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawCheckBox | Draws check box bitmap
GetHyperlinks | Use this function to access hyperlinks collection.
HitTestHyperlink | Determine if the click occurred on the hyperlink
OnBeginEdit | This method is called when user begin edit item.
OnChar | This method is called when user press key.
OnRequestEdit | This method is called when an editable item enters edit mode.
Public Methods
Public Methods
Public Method | Description
AddHyperlink | Adds new Hyperlink.
Compare | Compares this item with the provided one. Provides default behavior for descendants.
CompareGroupCaption | Compares group captions.
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
Draw | Should be overridden by descendants for drawing itself.
GetAlignment | Returns the current alignment value for the item.
GetCaption | Returns item text caption.
GetCaptionRect | Retrieves caption text bounding rectangle
GetEditOptions | Retrieves edit options of item.
GetFont | Call this member function to get item text font.
GetFormatString | Gets item caption format string.
GetGroupCaption | Returns group caption.
GetGroupCaptionID | Returns resource id of string containing text
GetGroupPriority | Retrieves sort priority of the item.
GetHasCheckbox | Determines if item has check box area
GetHyperlinkAt | Return Hyperlink by it's index.
GetHyperlinksCount | Returns a count of hyperlinks in record item
GetIconIndex | Returns an ID of the associated resource bitmap.
GetIndex | Returns item index.
GetItemControls | Retrieves item controls list.
GetItemData | This method retrieves the application-supplied 32-bit value associated with the item.
GetItemMetrics | Fills XTP_REPORTRECORDITEM_METRICS structure
GetRecord | Retrieved parent record object.
GetSelectedConstraintData | Retrieves associated value with selected constraint.
GetSortPriority | Retrieves sort priority of the item.
GetTooltip | Returns the text tool tip for the item
HasCheckbox | Adds check box area for item.
HitTest | Determines which report item control, if any, is at a specified position.
IsBold | Returns the Bold state for the item
IsChecked | Determines if the item is checked
IsEditable | Call this member function to programmatically check if item is editable.
IsFocusable | Call this member to determine if a CXTPReportRecordItem can receive focus.
IsPreviewItem | Determines if this item is a preview item.
OnCancelEdit | This method is called when user cancel edit item.
OnClick | Processes single mouse clicks.
OnConstraintChanged | This method is called when user select specified constraint in in-place list
OnDblClick | Processes single mouse clicks.
OnDrawCaption | Should be overridden by descendants for drawing itself.
OnDrawControls | Should be overridden by descendants for drawing itself.
OnEditCanceled | This method is called when in-place editing is canceled and value is not changed.
OnEditChanged | This method is called when value of in-place edit control changed
OnEditChanging | This method is called when in-place editor value changed by user
OnInplaceButtonDown | This method is called when user press in-place button of the item.
OnLButtonDown | Processes mouse left button down clicks.
OnLButtonUp | Processes mouse left button up clicks.
OnMouseMove | Processes the move mouse event.
OnValidateEdit | This method is called to save value from in-place edit
RemoveHyperlinkAt | Call this member function to remove hyperlink at the specified index.
SetAlignment | Sets new alignment value for the item.
SetBackgroundColor | Sets item text background color.
SetBold | Sets/clears bold flag for the item font.
SetCaption | Sets caption of the item.
SetChecked | Call this method to check the item.
SetEditable | Sets editable flag.
SetFocusable | Call this member to specify whether the CXTPReportRecordItem can have focus.
SetFont | Sets item text font.
SetFormatString | Sets item caption format string.
SetGroupCaption | Sets the group caption of the item.
SetGroupPriority | Sets the group priority of the item.
SetIconIndex | Sets new associated bitmap ID.
SetItemData | Call this method to set the 32-bit value associated with the item.
SetSortPriority | Sets the sort priority of the item.
SetTextColor | Sets item text color.
SetTooltip | Call this member to set/change the item tool tip.


CXTPReportRecordItem::AddHyperlink Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::AddHyperlink Method

Adds new Hyperlink.

virtual int AddHyperlink(
    CXTPReportHyperlink* pHyperlink
);
Parameters

pHyperlink
pointer to hyperlink.

Returns

zero-based id of new Hyperlink.

Remarks

Each record item can have a number of hyperlinks. To add new hyperlink to record item you firs create create the new instance of hyperlink class.

See Also

CXTPReportHyperlink.

Example
AddHyperlink(new CXTPReportHyperlink(27, 7);
Body Source
int CXTPReportRecordItem::AddHyperlink(CXTPReportHyperlink* pHyperlink){
    return GetHyperlinks() ? (int)GetHyperlinks()->Add(pHyperlink) : -1;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::Compare Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::Compare Method

Compares this item with the provided one. Provides default behavior for descendants.

virtual int Compare(
    CXTPReportColumn* pColumn,
    CXTPReportRecordItem* pItem
);
Parameters

pColumn
Corresponded column of the items.
pItem
points to the compared Item

Returns

Zero if the items' values are identical, < 0 if this item value is less than provided, or > 0 if this item value is greater than provided.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::CompareGroupCaption Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::CompareGroupCaption Method

Compares group captions.

virtual int CompareGroupCaption(
    CXTPReportColumn* pColumn,
    CXTPReportRecordItem* pItem
);
Parameters

pColumn
Point to the column
pItem
Point to the item

Returns

Zero if the items' values are identical, < 0 if this item value is less than provided, or > 0 if this item value is greater than provided.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::DoPropExchange Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::DoPropExchange Method

Call this member function to Store/Load a report record item using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::Draw Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::Draw Method

Should be overridden by descendants for drawing itself.

virtual int Draw(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs
);
Parameters

pDrawArgs
structure which contains drawing arguments:

Remarks

Call this member function to draw an item. Actually this function only prepares and calls needed drawing functions from PaintManager. Thus if you wish to change the look of your report item, you must just provide your own implementation of PaintManager

See Also

XTP_REPORTRECORDITEM_DRAWARGS

Example
// fill structure
XTP_REPORTRECORDITEM_DRAWARGS drawArgs;
drawArgs.pDC = pDC;
drawArgs.pControl = m_pControl;
drawArgs.pRow = this;
// call function
Draw(&drawArgs);
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::DrawCheckBox Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::DrawCheckBox Method

Draws check box bitmap

virtual void DrawCheckBox(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    CRect& rcItem
);
Parameters

pDrawArgs
Pointer to structure with drawing arguments
rcItem
Item area rectangle coordinates.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetAlignment Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetAlignment Method

Returns the current alignment value for the item.

int GetAlignment() const;
Returns

Current item alignment value. The result is a combination of alignment styles defined in XTPReportColumnIconAlignment.

Body Source
int CXTPReportRecordItem::GetAlignment() const {
    return m_Alignment;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetCaption Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetCaption Method

Returns item text caption.

virtual CString GetCaption(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Corresponded column of the item.

Returns

Item text caption (empty string for base record item class).

Remarks

Can be overridden by descendants.

Body Source
virtual CString GetCaption(CXTPReportColumn* pColumn) {
    UNREFERENCED_PARAMETER(pColumn); return m_strCaption;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetCaptionRect Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::GetCaptionRect Method

Retrieves caption text bounding rectangle

virtual void GetCaptionRect(
    XTP_REPORTRECORDITEM_ARGS* pDrawArgs,
    CRect& rcItem
);
Parameters

pDrawArgs
structure which contain drawing arguments.
rcItem
Bounding rectangle of the item

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetEditOptions Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::GetEditOptions Method

Retrieves edit options of item.

CXTPReportRecordItemEditOptions* GetEditOptions(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Column of the item.

Returns

Pointer to CXTPReportRecordItemEditOptions class.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetFont Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::GetFont Method

Call this member function to get item text font.

virtual CFont* GetFont();
Returns

Pointer to the current text font.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetFormatString Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetFormatString Method

Gets item caption format string.

virtual CString GetFormatString();
Returns

String object, containing current format string

Body Source
CString CXTPReportRecordItem::GetFormatString() {
    return m_strFormatString;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetGroupCaption Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::GetGroupCaption Method

Returns group caption.

virtual CString GetGroupCaption(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
point to the column

Returns

Text of Group Caption.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetGroupCaptionID Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::GetGroupCaptionID Method

Returns resource id of string containing text

virtual int GetGroupCaptionID(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Point to the column

Returns

Integer value of resource id

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetGroupPriority Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetGroupPriority Method

Retrieves sort priority of the item.

virtual int GetGroupPriority() const;
See Also

GetSortPriority, SetSortPriority, SetGroupPriority, GetGroupPriority

Body Source
int CXTPReportRecordItem::GetGroupPriority() const {
    return m_nGroupPriority;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetHasCheckbox Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetHasCheckbox Method

Determines if item has check box area

virtual BOOL GetHasCheckbox() const;
Returns

TRUE if item has check box; otherwise FALSE

See Also

SetChecked, IsChecked

Body Source
BOOL CXTPReportRecordItem::GetHasCheckbox() const {
    return m_bHasCheckbox;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetHyperlinkAt Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetHyperlinkAt Method

Return Hyperlink by it's index.

virtual CXTPReportHyperlink* GetHyperlinkAt(
    int nHyperlink
) const;
Parameters

nHyperlink
zero-based index of hyperlink.

Returns

Pointer to Hyperlink.

Remarks

To process a hyperlink, you get a pointer to it by calling GetHyperlinkAt();

See Also

CXTPReportHyperlink.

Example
int nHyperlinks = GetHyperlinksCount();
CXTPReportHyperlink* pHyperlink;
for(int nHyperlink = 0; nHyperlink < nHyperlinks; nHyperlink++)
{
    pHyperlink = GetHyperlinkAt(nHyperlink);
    // YOUR PROCESSING HERE
    // ...
    //
}
Body Source
CXTPReportHyperlink* CXTPReportRecordItem::GetHyperlinkAt(int nHyperlink) const{
    return m_pHyperlinks ? m_pHyperlinks->GetAt(nHyperlink) : NULL;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetHyperlinks Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::GetHyperlinks Method

Use this function to access hyperlinks collection.

CXTPReportHyperlinks* GetHyperlinks();
Returns

A pointer to CXTPReportHyperlinks object.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetHyperlinksCount Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetHyperlinksCount Method

Returns a count of hyperlinks in record item

virtual int GetHyperlinksCount() const;
Returns

Count of hyperlinks in item text

Remarks

Each record item can have a number of hyperlinks. To process all of them, you get the count of hyperlinks that are processed by an item using GetHyperlinksCount() member function

Body Source
int CXTPReportRecordItem::GetHyperlinksCount() const{
    return m_pHyperlinks ? (int)m_pHyperlinks->GetSize() : 0;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetIconIndex Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetIconIndex Method

Returns an ID of the associated resource bitmap.

virtual int GetIconIndex() const;
Returns

An ID of the associated resource bitmap.

Body Source
int CXTPReportRecordItem::GetIconIndex() const {
    return m_nIconIndex;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetIndex Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::GetIndex Method

Returns item index.

int GetIndex() const;
Returns

Item numeric index.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetItemControls Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::GetItemControls Method

Retrieves item controls list.

CXTPReportRecordItemControls* GetItemControls();
Returns

Pointer to CXTPReportRecordItemControls class.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetItemData Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetItemData Method

This method retrieves the application-supplied 32-bit value associated with the item.

virtual DWORD_PTR GetItemData() const;
Returns

The 32-bit value associated with the item.

Body Source
DWORD_PTR CXTPReportRecordItem::GetItemData() const {
    return m_dwData;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetItemMetrics Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetItemMetrics Method

Fills XTP_REPORTRECORDITEM_METRICS structure

virtual void GetItemMetrics(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pItemMetrics
);
Parameters

pDrawArgs
Draw arguments for calculating item metrics.
pItemMetrics
Pointer to the metrics item to fill with values.

Remarks

Calculates preview item metrics based on provided draw arguments. Could be overridden by descendants.

See Also

XTP_REPORTRECORDITEM_DRAWARGS, XTP_REPORTRECORDITEM_METRICS

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetRecord Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetRecord Method

Retrieved parent record object.

CXTPReportRecord* GetRecord() const;
Returns

Pointer to parent record object.

Body Source
CXTPReportRecord* CXTPReportRecordItem::GetRecord () const {
    return m_pRecord;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetSelectedConstraintData Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetSelectedConstraintData Method

Retrieves associated value with selected constraint.

virtual DWORD GetSelectedConstraintData(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Pointer to structure with items arguments

Returns

DWORD value associated with selected constraint.

Body Source
DWORD CXTPReportRecordItem::GetSelectedConstraintData(XTP_REPORTRECORDITEM_ARGS* /*pItemArgs*/) {
    return DWORD(-1);
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetSortPriority Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetSortPriority Method

Retrieves sort priority of the item.

virtual int GetSortPriority() const;
See Also

GetSortPriority, SetSortPriority, SetGroupPriority, GetGroupPriority

Body Source
int CXTPReportRecordItem::GetSortPriority() const {
    return m_nSortPriority;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::GetTooltip Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::GetTooltip Method

Returns the text tool tip for the item

virtual CString GetTooltip() const;
Returns

The text tool tip for the item.

Body Source
CString CXTPReportRecordItem::GetTooltip() const {
    return m_strTooltip;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::HasCheckbox Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::HasCheckbox Method

Adds check box area for item.

virtual void HasCheckbox(
    BOOL bHasCheckbox
);
Parameters

bHasCheckbox
TRUE if item has check box area.

See Also

SetChecked, IsChecked

Body Source
void CXTPReportRecordItem::HasCheckbox(BOOL bHasCheckbox) {
    m_bHasCheckbox = bHasCheckbox;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::HitTest Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::HitTest Method

Determines which report item control, if any, is at a specified position.

CXTPReportRecordItemControl* HitTest(
    CPoint ptPoint
);
Parameters

ptPoint
Point to test.

Returns

The item control at the specified position, if any, or NULL otherwise.

Remarks

Call this member function to test an item contents at the specified position.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::HitTestHyperlink Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::HitTestHyperlink Method

Determine if the click occurred on the hyperlink

virtual int HitTestHyperlink(
    CPoint ptClick
);
Parameters

ptClick
point of the mouse click

Returns

Zero-based index of clicked link, -1 otherwise

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::IsBold Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::IsBold Method

Returns the Bold state for the item

virtual BOOL IsBold() const;
Returns

TRUE if item is bold.

Body Source
BOOL CXTPReportRecordItem::IsBold() const {
    return m_bBoldText;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::IsChecked Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::IsChecked Method

Determines if the item is checked

virtual BOOL IsChecked() const;
See Also

SetChecked, HasCheckbox

Body Source
BOOL CXTPReportRecordItem::IsChecked() const {
    return m_bChecked;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::IsEditable Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::IsEditable Method

Call this member function to programmatically check if item is editable.

virtual BOOL IsEditable() const;
Returns

BOOLEAN value represents current editable flag

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::IsFocusable Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::IsFocusable Method

Call this member to determine if a CXTPReportRecordItem can receive focus.

virtual BOOL IsFocusable() const;
Returns

TRUE is the CXTPReportRecordItem can receive focus, FALSE if it can not receive focus.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::IsPreviewItem Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::IsPreviewItem Method

Determines if this item is a preview item.

virtual BOOL IsPreviewItem() const;
Returns

TRUE for the preview item, FALSE otherwise.

Body Source
BOOL CXTPReportRecordItem::IsPreviewItem() const {
    return FALSE;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnBeginEdit Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnBeginEdit Method

This method is called when user begin edit item.

virtual void OnBeginEdit(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Pointer to structure with items arguments.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnCancelEdit Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnCancelEdit Method

This method is called when user cancel edit item.

virtual void OnCancelEdit(
    CXTPReportControl* pControl,
    BOOL bApply
);
Parameters

pControl
Parent report control.
bApply
TRUE to save value of in-place edit.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnChar Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnChar Method

This method is called when user press key.

virtual BOOL OnChar(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    UINT nChar
);
Parameters

pItemArgs
Pointer to structure with items arguments.
nChar
Pressed character code

Returns

TRUE if item proceeded key.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnClick Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::OnClick Method

Processes single mouse clicks.

virtual void OnClick(
    XTP_REPORTRECORDITEM_CLICKARGS* pClickArgs
);
Parameters

pClickArgs
structure which contains mouse click arguments

Remarks

Usually this function is called by ReportRow's OnClick function

See Also

XTP_REPORTRECORDITEM_CLICKARGS

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnConstraintChanged Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnConstraintChanged Method

This method is called when user select specified constraint in in-place list

virtual void OnConstraintChanged(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    CXTPReportRecordItemConstraint* pConstraint
);
Parameters

pItemArgs
Pointer to structure with items arguments
pConstraint
Selected constraint

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnDblClick Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::OnDblClick Method

Processes single mouse clicks.

virtual void OnDblClick(
    XTP_REPORTRECORDITEM_CLICKARGS* pClickArgs
);
Parameters

pClickArgs
structure which contains mouse click arguments:

Remarks

Usually this function is called by ReportRow's OnDblClick function

See Also

XTP_REPORTRECORDITEM_CLICKARGS

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnDrawCaption Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnDrawCaption Method

Should be overridden by descendants for drawing itself.

virtual void OnDrawCaption(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pMetrics
);
Parameters

pDrawArgs
structure which contain drawing arguments.
pMetrics
structure which contain metrics of the item.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnDrawControls Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnDrawControls Method

Should be overridden by descendants for drawing itself.

virtual void OnDrawControls(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    CRect& rcItem
);
Parameters

pDrawArgs
structure which contain drawing arguments.
rcItem
item rectangle.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnEditCanceled Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::OnEditCanceled Method

This method is called when in-place editing is canceled and value is not changed.

virtual void OnEditCanceled(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Pointer to structure with items arguments.

Body Source
virtual void OnEditCanceled(XTP_REPORTRECORDITEM_ARGS* pItemArgs) { UNREFERENCED_PARAMETER(pItemArgs);}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnEditChanged Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::OnEditChanged Method

This method is called when value of in-place edit control changed

virtual void OnEditChanged(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    LPCTSTR szText
);
Parameters

pItemArgs
Pointer to structure with items arguments.
szText
New in-place edit text.

Body Source
virtual void OnEditChanged(XTP_REPORTRECORDITEM_ARGS* pItemArgs, LPCTSTR szText) { UNREFERENCED_PARAMETER(pItemArgs); UNREFERENCED_PARAMETER(szText); }
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnEditChanging Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::OnEditChanging Method

This method is called when in-place editor value changed by user

virtual BOOL OnEditChanging(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    CString& rstrNewText
);
Parameters

pItemArgs
item arguments
rstrNewText
new string to be set in the editor

Returns

FALSE to cancel edit operation.

Body Source
virtual BOOL OnEditChanging(XTP_REPORTRECORDITEM_ARGS* pItemArgs, CString& rstrNewText) { UNREFERENCED_PARAMETER(pItemArgs); UNREFERENCED_PARAMETER(rstrNewText); return TRUE;}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnInplaceButtonDown Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnInplaceButtonDown Method

This method is called when user press in-place button of the item.

virtual void OnInplaceButtonDown(
    CXTPReportInplaceButton* pButton
);
Parameters

pButton
In-place button of the item.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnLButtonDown Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::OnLButtonDown Method

Processes mouse left button down clicks.

virtual BOOL OnLButtonDown(
    XTP_REPORTRECORDITEM_CLICKARGS* pClickArgs
);
Parameters

pClickArgs
structure which contains mouse click arguments

Remarks

Usually this function is called by ReportRow's OnLButtonDown function

See Also

XTP_REPORTRECORDITEM_CLICKARGS

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnLButtonUp Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::OnLButtonUp Method

Processes mouse left button up clicks.

virtual BOOL OnLButtonUp(
    XTP_REPORTRECORDITEM_CLICKARGS* pClickArgs
);
Parameters

pClickArgs
structure which contains mouse click arguments

Remarks

Usually this function is called by ReportRow's OnLButtonUp function

See Also

XTP_REPORTRECORDITEM_CLICKARGS

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnMouseMove Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnMouseMove Method

Processes the move mouse event.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point,
    CXTPReportControl* pControl = NULL
);
Parameters

nFlags
additional flags.
point
mouse point
pControl
pointer to report control.

Remarks

Usually this function is called by ReportRow's OnMouseMove function

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnRequestEdit Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnRequestEdit Method

This method is called when an editable item enters edit mode.

virtual BOOL OnRequestEdit(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Pointer to a XTP_REPORTRECORDITEM_ARGS struct.

Returns

Returns True if the edit request was successful, False if the edit request was canceled.

Remarks

An item can enter edit mode when the user clicks on it and starts typing, or when a check box item is chekedunchecked.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::OnValidateEdit Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::OnValidateEdit Method

This method is called to save value from in-place edit

virtual void OnValidateEdit(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Pointer to structure with items arguments.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::RemoveHyperlinkAt Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::RemoveHyperlinkAt Method

Call this member function to remove hyperlink at the specified index.

virtual void RemoveHyperlinkAt(
    int nHyperlink
);
Parameters

nHyperlink
zero-based index of hyperlink.

Body Source
void CXTPReportRecordItem::RemoveHyperlinkAt(int nHyperlink) {
    if (m_pHyperlinks)
        m_pHyperlinks->RemoveAt(nHyperlink);
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetAlignment Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetAlignment Method

Sets new alignment value for the item.

int SetAlignment(
    int nAlignment
);
Parameters

nAlignment
New alignment value. See XTPReportColumnIconAlignment for possible alignment styles.

Returns

Previous alignment item value.

Body Source
int CXTPReportRecordItem::SetAlignment(int nAlignment) {
    int nOld = m_Alignment; m_Alignment = (XTPReportColumnIconAlignment)nAlignment; return nOld;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetBackgroundColor Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::SetBackgroundColor Method

Sets item text background color.

virtual void SetBackgroundColor(
    COLORREF clrBackground
);
Parameters

clrBackground
New background color.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetBold Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::SetBold Method

Sets/clears bold flag for the item font.

virtual void SetBold(
    BOOL bBold = TRUE
);
Parameters

bBold
If TRUE set font to bold.

Remarks

By using this function you can easily change font to bold or to normal.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetCaption Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::SetCaption Method

Sets caption of the item.

virtual void SetCaption(
    LPCTSTR strCaption
);
Parameters

strCaption
Caption of item to set.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetChecked Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetChecked Method

Call this method to check the item.

virtual void SetChecked(
    BOOL bChecked
);
Parameters

bChecked
TRUE if item is checked.

See Also

IsChecked, HasCheckbox

Body Source
void CXTPReportRecordItem::SetChecked(BOOL bChecked) {
    m_bChecked = bChecked;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetEditable Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetEditable Method

Sets editable flag.

virtual BOOL SetEditable(
    BOOL bEditable = TRUE
);
Parameters

bEditable
new editable flag (default is TRUE).

Returns

Old item editable state.

Body Source
BOOL CXTPReportRecordItem::SetEditable(BOOL bEditable) {
    BOOL bOldEditable = m_bEditable;
    m_bEditable = bEditable;
    return bOldEditable;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetFocusable Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetFocusable Method

Call this member to specify whether the CXTPReportRecordItem can have focus.

virtual void SetFocusable(
    BOOL bFocusable
);
Parameters

bFocusable
TRUE to allow the item to have focus, FALSE to specify the item can not have focus.

Remarks

This will override the CXTPReportControl::FocusSubItems setting which only allows individual items to receive focus. The SetFocusable member specifies whether the item can receive focus, if FALSE, the item can not be edited and the combo or expand buttons will not be displayed.

Body Source
void CXTPReportRecordItem::SetFocusable(BOOL bFocusable) {
    m_bFocusable = bFocusable;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetFont Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::SetFont Method

Sets item text font.

virtual void SetFont(
    CFont* pFont
);
Parameters

pFont
New font for caption.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetFormatString Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetFormatString Method

Sets item caption format string.

virtual void SetFormatString(
    LPCTSTR strFormat
);
Parameters

strFormat
New format string.

Remarks

If the format string is set, a caption text will be formatted accordingly to this format string before drawing it; convenient in many cases (drawing date for example). Format string is C - like style, see sprintf() C function or CString.Format() member function

Body Source
void CXTPReportRecordItem::SetFormatString(LPCTSTR strFormat) {
    m_strFormatString = strFormat;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetGroupCaption Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetGroupCaption Method

Sets the group caption of the item.

virtual void SetGroupCaption(
    LPCTSTR strCaption
);
Parameters

strCaption
Caption of group to set.

Body Source
void CXTPReportRecordItem::SetGroupCaption(LPCTSTR strCaption) {
    m_strGroupCaption = strCaption;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetGroupPriority Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetGroupPriority Method

Sets the group priority of the item.

virtual void SetGroupPriority(
    int nGroupPriority
);
Parameters

nGroupPriority
Priority will be used for sort routines.

See Also

GetSortPriority, SetSortPriority, SetGroupPriority, GetGroupPriority

Body Source
void CXTPReportRecordItem::SetGroupPriority(int nGroupPriority) {
    m_nGroupPriority = nGroupPriority;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetIconIndex Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetIconIndex Method

Sets new associated bitmap ID.

virtual int SetIconIndex(
    int nIconIndex
);
Parameters

nIconIndex
ID of the bitmap from the application resources.

Returns

Returns an ID of old resource bitmap.

Body Source
int CXTPReportRecordItem::SetIconIndex(int nIconIndex){
    int nOldID = GetIconIndex(); m_nIconIndex = nIconIndex; return nOldID;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetItemData Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetItemData Method

Call this method to set the 32-bit value associated with the item.

virtual void SetItemData(
    DWORD_PTR dwData
);
Parameters

dwData
Contains the new value to associate with the item.

Body Source
void CXTPReportRecordItem::SetItemData(DWORD_PTR dwData) {
    m_dwData = dwData;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetSortPriority Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetSortPriority Method

Sets the sort priority of the item.

virtual void SetSortPriority(
    int nSortPriority
);
Parameters

nSortPriority
Priority will be used for sort routines.

See Also

GetSortPriority, SetSortPriority, SetGroupPriority, GetGroupPriority

Body Source
void CXTPReportRecordItem::SetSortPriority(int nSortPriority) {
    m_nSortPriority = nSortPriority;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetTextColor Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class
CXTPReportRecordItem::SetTextColor Method

Sets item text color.

virtual void SetTextColor(
    COLORREF clrText
);
Parameters

clrText
New color.

Group

CXTPReportRecordItem Methods


CXTPReportRecordItem::SetTooltip Method

CXTPReportRecordItem Methods, CXTPReportRecordItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::SetTooltip Method

Call this member to set/change the item tool tip.

virtual void SetTooltip(
    LPCTSTR lpszTooltip
);
Parameters

lpszTooltip
Tool tip of the item

Body Source
void CXTPReportRecordItem::SetTooltip(LPCTSTR lpszTooltip) {
    m_strTooltip = lpszTooltip;
}
Group

CXTPReportRecordItem Methods


CXTPReportRecordItem Constructors

CXTPReportRecordItem Class, Legend, Public Methods
CXTPReportRecordItem Constructors
Class

CXTPReportRecordItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItem | CXTPReportRecordItem default constructor


CXTPReportRecordItem::CXTPReportRecordItem Constructor

CXTPReportRecordItem Constructors, CXTPReportRecordItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItem::CXTPReportRecordItem Constructor

CXTPReportRecordItem default constructor

CXTPReportRecordItem();
Group

CXTPReportRecordItem Constructors


CXTPReportRecordItem Destructors

CXTPReportRecordItem Class, Legend, Public Methods
CXTPReportRecordItem Destructors
Class

CXTPReportRecordItem Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportRecordItem | CXTPReportRecordItem default destructor


CXTPReportRecordItem::~CXTPReportRecordItem Destructor

CXTPReportRecordItem Destructors, CXTPReportRecordItem Class
CXTPReportRecordItem::~CXTPReportRecordItem Destructor

CXTPReportRecordItem default destructor

virtual ~CXTPReportRecordItem();
Group

CXTPReportRecordItem Destructors


CXTPReportRecordItemConstraint Class

XTPReportRecordItem.h, Classes, Legend, Members, Topics, CXTPReportRecordItemConstraint Data Members, CXTPReportRecordItemConstraint Methods, CXTPReportRecordItemConstraint Constructors, CXTPReportRecordItemConstraint Constructors, CXTPReportRecordItemConstraint Data Members, CXTPReportRecordItemConstraint Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraint Class

CXTPReportRecordItemConstraint is a CCmdTarget derived class. It represents a single item constraints.

Class Hierarchy

class CXTPReportRecordItemConstraint;
File

XTPReportRecordItem.h

Group

Classes

Legend
Data Member
protected
Method
CXTPReportRecordItemConstraint Constructors
CXTPReportRecordItemConstraint Constructors | Description
CXTPReportRecordItemConstraint | Constructs a CXTPPropertyGridItemConstraint object.
CXTPReportRecordItemConstraint Data Members
CXTPReportRecordItemConstraint Data Members | Description
m_dwData | The 32-bit value associated with the item.
m_nIndex | Index of constraint.
m_strConstraint | Caption text of constraint.
CXTPReportRecordItemConstraint Methods
CXTPReportRecordItemConstraint Methods | Description
GetIndex | Call this member to retrieve the index of this constraint within the collection of constraints.


CXTPReportRecordItemConstraint Data Members

CXTPReportRecordItemConstraint Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraint Data Members
Class

CXTPReportRecordItemConstraint Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nIndex | Index of constraint.
Public Data Members
Public Data Member | Description
m_dwData | The 32-bit value associated with the item.
m_strConstraint | Caption text of constraint.


CXTPReportRecordItemConstraint::m_dwData Data Member

CXTPReportRecordItemConstraint Data Members, CXTPReportRecordItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraint::m_dwData Data Member

The 32-bit value associated with the item.

DWORD_PTR m_dwData;
Group

CXTPReportRecordItemConstraint Data Members


CXTPReportRecordItemConstraint::m_nIndex Data Member

CXTPReportRecordItemConstraint Data Members, CXTPReportRecordItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraint::m_nIndex Data Member

Index of constraint.

int m_nIndex;
Group

CXTPReportRecordItemConstraint Data Members


CXTPReportRecordItemConstraint::m_strConstraint Data Member

CXTPReportRecordItemConstraint Data Members, CXTPReportRecordItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraint::m_strConstraint Data Member

Caption text of constraint.

CString m_strConstraint;
Group

CXTPReportRecordItemConstraint Data Members


CXTPReportRecordItemConstraint Methods

CXTPReportRecordItemConstraint Class, Legend, Public Methods
CXTPReportRecordItemConstraint Methods
Class

CXTPReportRecordItemConstraint Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetIndex | Call this member to retrieve the index of this constraint within the collection of constraints.


CXTPReportRecordItemConstraint::GetIndex Method

CXTPReportRecordItemConstraint Methods, CXTPReportRecordItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraint::GetIndex Method

Call this member to retrieve the index of this constraint within the collection of constraints.

int GetIndex() const;
Returns

Index of this constraint.

Group

CXTPReportRecordItemConstraint Methods


CXTPReportRecordItemConstraint Constructors

CXTPReportRecordItemConstraint Class, Legend, Public Methods
CXTPReportRecordItemConstraint Constructors
Class

CXTPReportRecordItemConstraint Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemConstraint | Constructs a CXTPPropertyGridItemConstraint object.


CXTPReportRecordItemConstraint::CXTPReportRecordItemConstraint Constructor

CXTPReportRecordItemConstraint Constructors, CXTPReportRecordItemConstraint Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraint::CXTPReportRecordItemConstraint Constructor

Constructs a CXTPPropertyGridItemConstraint object.

CXTPReportRecordItemConstraint();
Group

CXTPReportRecordItemConstraint Constructors


CXTPReportRecordItemConstraints Class

XTPReportRecordItem.h, Classes, Legend, Members, Topics, CXTPReportRecordItemConstraints Data Members, CXTPReportRecordItemConstraints Methods, CXTPReportRecordItemConstraints Constructors, CXTPReportRecordItemConstraints Destructors, CXTPReportRecordItemConstraints Constructors, CXTPReportRecordItemConstraints Data Members, CXTPReportRecordItemConstraints Destructors, CXTPReportRecordItemConstraints Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints Class

CXTPReportRecordItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.

Class Hierarchy

class CXTPReportRecordItemConstraints;
File

XTPReportRecordItem.h

Group

Classes

Legend
Data Member
protected
Method
CXTPReportRecordItemConstraints Constructors
CXTPReportRecordItemConstraints Constructors | Description
CXTPReportRecordItemConstraints | Constructs a CXTPReportRecordItemConstraints object.
CXTPReportRecordItemConstraints Data Members
CXTPReportRecordItemConstraints Data Members | Description
m_arrConstraints | Collection of constraints
CXTPReportRecordItemConstraints Destructors
CXTPReportRecordItemConstraints Destructors | Description
~CXTPReportRecordItemConstraints | Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation
CXTPReportRecordItemConstraints Methods
CXTPReportRecordItemConstraints Methods | Description
GetAt | Call this member to retrieve a constraint at nIndex.
GetCount | Call this member to determine the total number of constraints in the list.
RemoveAll | Call this member to remove all constraints from the list of constraints.


CXTPReportRecordItemConstraints Data Members

CXTPReportRecordItemConstraints Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints Data Members
Class

CXTPReportRecordItemConstraints Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrConstraints | Collection of constraints


CXTPReportRecordItemConstraints::m_arrConstraints Data Member

CXTPReportRecordItemConstraints Data Members, CXTPReportRecordItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints::m_arrConstraints Data Member

Collection of constraints

CArray<CXTPReportRecordItemConstraint*, CXTPReportRecordItemConstraint*> m_arrConstraints;
Group

CXTPReportRecordItemConstraints Data Members


CXTPReportRecordItemConstraints Methods

CXTPReportRecordItemConstraints Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints Methods
Class

CXTPReportRecordItemConstraints Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetAt | Call this member to retrieve a constraint at nIndex.
GetCount | Call this member to determine the total number of constraints in the list.
RemoveAll | Call this member to remove all constraints from the list of constraints.


CXTPReportRecordItemConstraints::GetAt Method

CXTPReportRecordItemConstraints Methods, CXTPReportRecordItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints::GetAt Method

Call this member to retrieve a constraint at nIndex.

CXTPReportRecordItemConstraint* GetAt(
    int nIndex
) const;
Parameters

nIndex
Position in constraint collection.

Returns

Pointer to the constraint at nIndex in the collection of constraints.

Group

CXTPReportRecordItemConstraints Methods


CXTPReportRecordItemConstraints::GetCount Method

CXTPReportRecordItemConstraints Methods, CXTPReportRecordItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints::GetCount Method

Call this member to determine the total number of constraints in the list.

int GetCount() const;
Returns

Returns the total number of constraints added to the ReportRecordItem andor ReportColumn.

Group

CXTPReportRecordItemConstraints Methods


CXTPReportRecordItemConstraints::RemoveAll Method

CXTPReportRecordItemConstraints Methods, CXTPReportRecordItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints::RemoveAll Method

Call this member to remove all constraints from the list of constraints.

void RemoveAll();
Group

CXTPReportRecordItemConstraints Methods


CXTPReportRecordItemConstraints Constructors

CXTPReportRecordItemConstraints Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints Constructors
Class

CXTPReportRecordItemConstraints Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemConstraints | Constructs a CXTPReportRecordItemConstraints object.


CXTPReportRecordItemConstraints::CXTPReportRecordItemConstraints Constructor

CXTPReportRecordItemConstraints Constructors, CXTPReportRecordItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints::CXTPReportRecordItemConstraints Constructor

Constructs a CXTPReportRecordItemConstraints object.

CXTPReportRecordItemConstraints();
Group

CXTPReportRecordItemConstraints Constructors


CXTPReportRecordItemConstraints Destructors

CXTPReportRecordItemConstraints Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints Destructors
Class

CXTPReportRecordItemConstraints Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportRecordItemConstraints | Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation


CXTPReportRecordItemConstraints::~CXTPReportRecordItemConstraints Destructor

CXTPReportRecordItemConstraints Destructors, CXTPReportRecordItemConstraints Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemConstraints::~CXTPReportRecordItemConstraints Destructor

Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation

~CXTPReportRecordItemConstraints();
Group

CXTPReportRecordItemConstraints Destructors


CXTPReportRecordItemDateTime Class

XTPReportRecordItemText.h, Classes, Legend, Members, Topics, CXTPReportRecordItemDateTime Data Members, CXTPReportRecordItemDateTime Methods, CXTPReportRecordItemDateTime Constructors, CXTPReportRecordItemDateTime Constructors, CXTPReportRecordItemDateTime Data Members, CXTPReportRecordItemDateTime Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime Class

Represents a time cell and inherits basic functionality from CXTPReportRecordItem class.

Class Hierarchy

class CXTPReportRecordItemDateTime : public CXTPReportRecordItem;
File

XTPReportRecordItemText.h

Remarks

You create a CXTPReportRecordItemDateTime record item simply by calling a constructor with one COleDateTime parameter

See Also

CXTPReportRecordItem

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRecordItemDateTime Constructors
CXTPReportRecordItemDateTime Constructors | Description
CXTPReportRecordItemDateTime | Creates record date/time item.
CXTPReportRecordItemDateTime Data Members
CXTPReportRecordItemDateTime Data Members | Description
m_odtValue | Cell value.
CXTPReportRecordItemDateTime Methods
CXTPReportRecordItemDateTime Methods | Description
Compare | Compares this item with the provided one.
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns a text caption of this item.
GetValue | Returns the item value in its original format.
OnEditChanged | This method is called when value of in-place edit control changed
SetValue | Call this method to set value of the item


CXTPReportRecordItemDateTime Data Members

CXTPReportRecordItemDateTime Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime Data Members
Class

CXTPReportRecordItemDateTime Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_odtValue | Cell value.


CXTPReportRecordItemDateTime::m_odtValue Data Member

CXTPReportRecordItemDateTime Data Members, CXTPReportRecordItemDateTime Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime::m_odtValue Data Member

Cell value.

COleDateTime m_odtValue;
Group

CXTPReportRecordItemDateTime Data Members


CXTPReportRecordItemDateTime Methods

CXTPReportRecordItemDateTime Class, Legend, Public Methods
CXTPReportRecordItemDateTime Methods
Class

CXTPReportRecordItemDateTime Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Compare | Compares this item with the provided one.
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns a text caption of this item.
GetValue | Returns the item value in its original format.
OnEditChanged | This method is called when value of in-place edit control changed
SetValue | Call this method to set value of the item


CXTPReportRecordItemDateTime::Compare Method

CXTPReportRecordItemDateTime Methods, CXTPReportRecordItemDateTime Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime::Compare Method

Compares this item with the provided one.

int Compare(
    CXTPReportColumn* pColumn,
    CXTPReportRecordItem* pItem
);
Parameters

pColumn
Pointer to a CXTPReportColumn object.
pItem
The item provided for comparing with current.

Returns

Zero if pItem is equal with current; Less than zero if less than pItem; Greater than zero if greater than pItem.

Remarks

Overwrites parents' member function

Group

CXTPReportRecordItemDateTime Methods


CXTPReportRecordItemDateTime::DoPropExchange Method

CXTPReportRecordItemDateTime Methods, CXTPReportRecordItemDateTime Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime::DoPropExchange Method

Call this member function to Store/Load a report record item using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Group

CXTPReportRecordItemDateTime Methods


CXTPReportRecordItemDateTime::GetCaption Method

CXTPReportRecordItemDateTime Methods, CXTPReportRecordItemDateTime Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime::GetCaption Method

Returns a text caption of this item.

CString GetCaption(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Corresponded column of the item.

Returns

Text caption of the item.

Remarks

Overwrites parents' member function.

Group

CXTPReportRecordItemDateTime Methods


CXTPReportRecordItemDateTime::GetValue Method

CXTPReportRecordItemDateTime Methods, CXTPReportRecordItemDateTime Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime::GetValue Method

Returns the item value in its original format.

COleDateTime GetValue();
Returns

Item date-time value.

Body Source
COleDateTime CXTPReportRecordItemDateTime::GetValue() {
    return m_odtValue;
}
Group

CXTPReportRecordItemDateTime Methods


CXTPReportRecordItemDateTime::OnEditChanged Method

CXTPReportRecordItemDateTime Methods, CXTPReportRecordItemDateTime Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime::OnEditChanged Method

This method is called when value of in-place edit control changed

virtual void OnEditChanged(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    LPCTSTR szText
);
Parameters

pItemArgs
Pointer to structure with items arguments.
szText
New in-place edit text.

Group

CXTPReportRecordItemDateTime Methods


CXTPReportRecordItemDateTime::SetValue Method

CXTPReportRecordItemDateTime Methods, CXTPReportRecordItemDateTime Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime::SetValue Method

Call this method to set value of the item

void SetValue(
    COleDateTime odtValue
);
Parameters

odtValue
New item value

Body Source
void CXTPReportRecordItemDateTime::SetValue(COleDateTime odtValue) {
    m_odtValue = odtValue;
}
Group

CXTPReportRecordItemDateTime Methods


CXTPReportRecordItemDateTime Constructors

CXTPReportRecordItemDateTime Class, Legend, Public Methods
CXTPReportRecordItemDateTime Constructors
Class

CXTPReportRecordItemDateTime Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemDateTime | Creates record date/time item.


CXTPReportRecordItemDateTime::CXTPReportRecordItemDateTime Constructor

CXTPReportRecordItemDateTime Constructors, CXTPReportRecordItemDateTime Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemDateTime::CXTPReportRecordItemDateTime Constructor

Creates record date/time item.

CXTPReportRecordItemDateTime(
    COleDateTime odtValue = (DATE)0
);
Parameters

odtValue
Initial date/time item value.

Group

CXTPReportRecordItemDateTime Constructors


CXTPReportRecordItemEditOptions Class

XTPReportRecordItem.h, Classes, Legend, Members, Topics, CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Methods, CXTPReportRecordItemEditOptions Constructors, CXTPReportRecordItemEditOptions Destructors, CXTPReportRecordItemEditOptions Constructors, CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Destructors, CXTPReportRecordItemEditOptions Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions Class

This class represents edit options of the single item or column

Class Hierarchy

class CXTPReportRecordItemEditOptions;
File

XTPReportRecordItem.h

Group

Classes

Legend
Data Member
Method
CXTPReportRecordItemEditOptions Constructors
CXTPReportRecordItemEditOptions Constructors | Description
CXTPReportRecordItemEditOptions | Constructs a CXTPReportRecordItemEditOptions object.
CXTPReportRecordItemEditOptions Data Members
CXTPReportRecordItemEditOptions Data Members | Description
arrInplaceButtons | Array of in-place buttons.
m_bAllowEdit | TRUE to add an edit box to this item.
m_bConstraintEdit | If TRUE, then you can only choose from the list of constraints added, If FALSE, then you can type a custom response not listed in the list of constraints.
m_bSelectTextOnEdit | Select all text on edit
m_dwEditStyle | Edit Style (ES_MULTILINE, ES_NUMBER....)
m_nMaxLength | Maximum number of characters that can be entered into an editable item (Edit limit).
m_pConstraints | Constraint list.
CXTPReportRecordItemEditOptions Destructors
CXTPReportRecordItemEditOptions Destructors | Description
~CXTPReportRecordItemEditOptions | Destroys a CXTPReportRecordItemEditOptions object, handles cleanup and deallocation
CXTPReportRecordItemEditOptions Methods
CXTPReportRecordItemEditOptions Methods | Description
AddComboButton | Call this member to add a combo button to the CXTPReportRecordItem.
AddConstraint | Adds new constraint to constraint list.
AddExpandButton | Call this member to add a expand button to the CXTPReportRecordItem.
AddSpinButton | Call this member to add a spin button to the CXTPReportRecordItem.
FindConstraint |
GetButton | Call this member to get a buttons with the specified index.
GetConstraints | Retrieves constraints pointer.
RemoveButtons | Call this member to remove all buttons of the CXTPReportRecordItem.


CXTPReportRecordItemEditOptions Data Members

CXTPReportRecordItemEditOptions Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions Data Members
Class

CXTPReportRecordItemEditOptions Class

Legend
Data Member
Public Data Members
Public Data Member | Description
arrInplaceButtons | Array of in-place buttons.
m_bAllowEdit | TRUE to add an edit box to this item.
m_bConstraintEdit | If TRUE, then you can only choose from the list of constraints added, If FALSE, then you can type a custom response not listed in the list of constraints.
m_bSelectTextOnEdit | Select all text on edit
m_dwEditStyle | Edit Style (ES_MULTILINE, ES_NUMBER....)
m_nMaxLength | Maximum number of characters that can be entered into an editable item (Edit limit).
m_pConstraints | Constraint list.


CXTPReportRecordItemEditOptions::arrInplaceButtons Data Member

CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::arrInplaceButtons Data Member

Array of in-place buttons.

CXTPReportInplaceButtons arrInplaceButtons;
Group

CXTPReportRecordItemEditOptions Data Members


CXTPReportRecordItemEditOptions::m_bAllowEdit Data Member

CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::m_bAllowEdit Data Member

TRUE to add an edit box to this item.

BOOL m_bAllowEdit;
Group

CXTPReportRecordItemEditOptions Data Members


CXTPReportRecordItemEditOptions::m_bConstraintEdit Data Member

CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::m_bConstraintEdit Data Member

If TRUE, then you can only choose from the list of constraints added, If FALSE, then you can type a custom response not listed in the list of constraints.

BOOL m_bConstraintEdit;
Group

CXTPReportRecordItemEditOptions Data Members


CXTPReportRecordItemEditOptions::m_bSelectTextOnEdit Data Member

CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::m_bSelectTextOnEdit Data Member

Select all text on edit

BOOL m_bSelectTextOnEdit;
Group

CXTPReportRecordItemEditOptions Data Members


CXTPReportRecordItemEditOptions::m_dwEditStyle Data Member

CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::m_dwEditStyle Data Member

Edit Style (ES_MULTILINE, ES_NUMBER....)

DWORD m_dwEditStyle;
Group

CXTPReportRecordItemEditOptions Data Members


CXTPReportRecordItemEditOptions::m_nMaxLength Data Member

CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::m_nMaxLength Data Member

Maximum number of characters that can be entered into an editable item (Edit limit).

int m_nMaxLength;
Group

CXTPReportRecordItemEditOptions Data Members


CXTPReportRecordItemEditOptions::m_pConstraints Data Member

CXTPReportRecordItemEditOptions Data Members, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::m_pConstraints Data Member

Constraint list.

CXTPReportRecordItemConstraints* m_pConstraints;
Group

CXTPReportRecordItemEditOptions Data Members


CXTPReportRecordItemEditOptions Methods

CXTPReportRecordItemEditOptions Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions Methods
Class

CXTPReportRecordItemEditOptions Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddComboButton | Call this member to add a combo button to the CXTPReportRecordItem.
AddConstraint | Adds new constraint to constraint list.
AddExpandButton | Call this member to add a expand button to the CXTPReportRecordItem.
AddSpinButton | Call this member to add a spin button to the CXTPReportRecordItem.
FindConstraint |
GetButton | Call this member to get a buttons with the specified index.
GetConstraints | Retrieves constraints pointer.
RemoveButtons | Call this member to remove all buttons of the CXTPReportRecordItem.


CXTPReportRecordItemEditOptions::AddComboButton Method

CXTPReportRecordItemEditOptions Methods, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::AddComboButton Method

Call this member to add a combo button to the CXTPReportRecordItem.

void AddComboButton();
Remarks

This adds a drop-down combo button to the ReportRecordItem. When the button is pressed, it will display all of the data items that were added as CXTPReportRecordItemConstraints.

Group

CXTPReportRecordItemEditOptions Methods


CXTPReportRecordItemEditOptions::AddConstraint Method

CXTPReportRecordItemEditOptions Methods, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::AddConstraint Method

Adds new constraint to constraint list.

CXTPReportRecordItemConstraint* AddConstraint(
    LPCTSTR lpszConstraint,
    DWORD_PTR dwData = 0
);
Parameters

lpszConstraint
Caption of the constraint to be added.
dwData
The 32-bit value associated with the constraint.

Group

CXTPReportRecordItemEditOptions Methods


CXTPReportRecordItemEditOptions::AddExpandButton Method

CXTPReportRecordItemEditOptions Methods, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::AddExpandButton Method

Call this member to add a expand button to the CXTPReportRecordItem.

void AddExpandButton();
Remarks

A small button with three ellipses is displayed and you can use this button to display your own custom dialog.

Group

CXTPReportRecordItemEditOptions Methods


CXTPReportRecordItemEditOptions::AddSpinButton Method

CXTPReportRecordItemEditOptions Methods, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::AddSpinButton Method

Call this member to add a spin button to the CXTPReportRecordItem.

void AddSpinButton();
Remarks

A spin control with two buttons is displayed and you can use this button to change the cell numeric value.

Group

CXTPReportRecordItemEditOptions Methods


FindConstraint Method

CXTPReportRecordItemEditOptions Methods
FindConstraint Method
Overload List
Methods
Method | Description
CXTPReportRecordItemEditOptions::FindConstraint (DWORD_PTR) | Finds constraint by its value or caption
CXTPReportRecordItemEditOptions::FindConstraint (LPCTSTR) | Finds constraint by its value or caption
Group

CXTPReportRecordItemEditOptions Methods


CXTPReportRecordItemEditOptions::FindConstraint Method (DWORD_PTR)

FindConstraint Method, CXTPReportRecordItemEditOptions Class
CXTPReportRecordItemEditOptions::FindConstraint Method (DWORD_PTR)

Finds constraint by its value or caption

CXTPReportRecordItemConstraint* FindConstraint(
    DWORD_PTR dwData
);
CXTPReportRecordItemConstraint* FindConstraint(
    LPCTSTR lpszConstraint
);
Parameters

dwData
The 32-bit value associated with the constraint.
lpszConstraint
caption of the constraint

Returns

Constraint pointer if found or NULL if the constraint is not found.

Group

FindConstraint Method


CXTPReportRecordItemEditOptions::GetButton Method

CXTPReportRecordItemEditOptions Methods, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::GetButton Method

Call this member to get a buttons with the specified index.

CXTPReportInplaceButton* GetButton(
    int nIndex
);
Parameters

nIndex
the index of a button to get.

Group

CXTPReportRecordItemEditOptions Methods


CXTPReportRecordItemEditOptions::GetConstraints Method

CXTPReportRecordItemEditOptions Methods, CXTPReportRecordItemEditOptions Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::GetConstraints Method

Retrieves constraints pointer.

CXTPReportRecordItemConstraints* GetConstraints();
Returns

Constraint pointer of the edit options.

Body Source
CXTPReportRecordItemConstraints* GetConstraints() {
    return m_pConstraints;
}
Group

CXTPReportRecordItemEditOptions Methods


CXTPReportRecordItemEditOptions::RemoveButtons Method

CXTPReportRecordItemEditOptions Methods, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::RemoveButtons Method

Call this member to remove all buttons of the CXTPReportRecordItem.

void RemoveButtons();
Group

CXTPReportRecordItemEditOptions Methods


CXTPReportRecordItemEditOptions Constructors

CXTPReportRecordItemEditOptions Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions Constructors
Class

CXTPReportRecordItemEditOptions Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemEditOptions | Constructs a CXTPReportRecordItemEditOptions object.


CXTPReportRecordItemEditOptions::CXTPReportRecordItemEditOptions Constructor

CXTPReportRecordItemEditOptions Constructors, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::CXTPReportRecordItemEditOptions Constructor

Constructs a CXTPReportRecordItemEditOptions object.

CXTPReportRecordItemEditOptions();
Group

CXTPReportRecordItemEditOptions Constructors


CXTPReportRecordItemEditOptions Destructors

CXTPReportRecordItemEditOptions Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions Destructors
Class

CXTPReportRecordItemEditOptions Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportRecordItemEditOptions | Destroys a CXTPReportRecordItemEditOptions object, handles cleanup and deallocation


CXTPReportRecordItemEditOptions::~CXTPReportRecordItemEditOptions Destructor

CXTPReportRecordItemEditOptions Destructors, CXTPReportRecordItemEditOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemEditOptions::~CXTPReportRecordItemEditOptions Destructor

Destroys a CXTPReportRecordItemEditOptions object, handles cleanup and deallocation

~CXTPReportRecordItemEditOptions();
Group

CXTPReportRecordItemEditOptions Destructors


CXTPReportRecordItemNumber Class

XTPReportRecordItemText.h, Classes, Legend, Members, Topics, CXTPReportRecordItemNumber Data Members, CXTPReportRecordItemNumber Methods, CXTPReportRecordItemNumber Constructors, CXTPReportRecordItemNumber Constructors, CXTPReportRecordItemNumber Data Members, CXTPReportRecordItemNumber Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber Class

This class represents a numeric cell and inherits basic functionality from CXTPReportRecordItem class.

Class Hierarchy

class CXTPReportRecordItemNumber : public CXTPReportRecordItem;
File

XTPReportRecordItemText.h

Remarks

You create a number record item simply by calling constructor with the only one parameter - its numeric value. There is an additional constructor with second parameter - format string. Format string allows you to determine exactly in which format the numeric value will be represented on the screen. It could be useful for displaying money values, etc.

See Also

CXTPReportRecordItem

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRecordItemNumber Constructors
CXTPReportRecordItemNumber Constructors | Description
CXTPReportRecordItemNumber |
CXTPReportRecordItemNumber Data Members
CXTPReportRecordItemNumber Data Members | Description
m_dValue | Cell value.
CXTPReportRecordItemNumber Methods
CXTPReportRecordItemNumber Methods | Description
Compare | Compares this item with the provided one.
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns a text caption of this item.
GetValue | Returns item value in its original format.
OnEditChanged | This method is called when value of in-place edit control changed
SetValue | Call this method to set value of the item


CXTPReportRecordItemNumber Data Members

CXTPReportRecordItemNumber Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber Data Members
Class

CXTPReportRecordItemNumber Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dValue | Cell value.


CXTPReportRecordItemNumber::m_dValue Data Member

CXTPReportRecordItemNumber Data Members, CXTPReportRecordItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber::m_dValue Data Member

Cell value.

double m_dValue;
Group

CXTPReportRecordItemNumber Data Members


CXTPReportRecordItemNumber Methods

CXTPReportRecordItemNumber Class, Legend, Public Methods
CXTPReportRecordItemNumber Methods
Class

CXTPReportRecordItemNumber Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Compare | Compares this item with the provided one.
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns a text caption of this item.
GetValue | Returns item value in its original format.
OnEditChanged | This method is called when value of in-place edit control changed
SetValue | Call this method to set value of the item


CXTPReportRecordItemNumber::Compare Method

CXTPReportRecordItemNumber Methods, CXTPReportRecordItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber::Compare Method

Compares this item with the provided one.

int Compare(
    CXTPReportColumn* pColumn,
    CXTPReportRecordItem* pItem
);
Parameters

pColumn
Pointer to a CXTPReportColumn object.
pItem
An item to compare with the current.

Returns

Zero if pItem is equal with current; Less than zero if less than pItem; Greater than zero if greater than pItem.

Remarks

Overwrites parents' member function

Group

CXTPReportRecordItemNumber Methods


CXTPReportRecordItemNumber::DoPropExchange Method

CXTPReportRecordItemNumber Methods, CXTPReportRecordItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber::DoPropExchange Method

Call this member function to Store/Load a report record item using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Group

CXTPReportRecordItemNumber Methods


CXTPReportRecordItemNumber::GetCaption Method

CXTPReportRecordItemNumber Methods, CXTPReportRecordItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber::GetCaption Method

Returns a text caption of this item.

CString GetCaption(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Corresponded column of the item.

Returns

Text caption of the item.

Remarks

Overwrites parents' member function

Group

CXTPReportRecordItemNumber Methods


CXTPReportRecordItemNumber::GetValue Method

CXTPReportRecordItemNumber Methods, CXTPReportRecordItemNumber Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber::GetValue Method

Returns item value in its original format.

double GetValue();
Returns

Item original numeric value.

Body Source
double CXTPReportRecordItemNumber::GetValue() {
    return m_dValue;
}
Group

CXTPReportRecordItemNumber Methods


CXTPReportRecordItemNumber::OnEditChanged Method

CXTPReportRecordItemNumber Methods, CXTPReportRecordItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber::OnEditChanged Method

This method is called when value of in-place edit control changed

virtual void OnEditChanged(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    LPCTSTR szText
);
Parameters

pItemArgs
Pointer to structure with items arguments.
szText
New in-place edit text.

Group

CXTPReportRecordItemNumber Methods


CXTPReportRecordItemNumber::SetValue Method

CXTPReportRecordItemNumber Methods, CXTPReportRecordItemNumber Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber::SetValue Method

Call this method to set value of the item

void SetValue(
    double dValue
);
Parameters

dValue
New item value

Body Source
void CXTPReportRecordItemNumber::SetValue(double dValue) {
    m_dValue = dValue;
}
Group

CXTPReportRecordItemNumber Methods


CXTPReportRecordItemNumber Constructors

CXTPReportRecordItemNumber Class, Legend, Public Methods
CXTPReportRecordItemNumber Constructors
Class

CXTPReportRecordItemNumber Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemNumber |


CXTPReportRecordItemNumber Constructor

CXTPReportRecordItemNumber Constructors
CXTPReportRecordItemNumber Constructor
Overload List
Constructors
Constructor | Description
CXTPReportRecordItemNumber::CXTPReportRecordItemNumber (double) | Creates a record numeric item with the specific formatting.
CXTPReportRecordItemNumber::CXTPReportRecordItemNumber (double, LPCTSTR) | Creates a record numeric item with the specific formatting.
Group

CXTPReportRecordItemNumber Constructors


CXTPReportRecordItemNumber::CXTPReportRecordItemNumber Constructor (double)

CXTPReportRecordItemNumber Constructor, CXTPReportRecordItemNumber Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemNumber::CXTPReportRecordItemNumber Constructor (double)

Creates a record numeric item with the specific formatting.

CXTPReportRecordItemNumber(
    double dValue = 0
);
CXTPReportRecordItemNumber(
    double dValue,
    LPCTSTR strFormat
);
Parameters

dValue
Value of this numeric item.
strFormat
Format string for creating caption value of the item.

Remarks

If the format string is set, the value of the item will be formatted according to this format string before drawing it convenient in many cases (drawing date for example). Format string is C - like style, see sprintf() C function or CString.Format() member function

Group

CXTPReportRecordItemNumber Constructor


CXTPReportRecordItemPreview Class

XTPReportRecordItemText.h, Classes, Legend, Members, Topics, CXTPReportRecordItemPreview Data Members, CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Constructors, CXTPReportRecordItemPreview Constructors, CXTPReportRecordItemPreview Data Members, CXTPReportRecordItemPreview Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview Class

This represents a preview cell and inherits basic functionality from CXTPReportRecordItem class.

Class Hierarchy

class CXTPReportRecordItemPreview : public CXTPReportRecordItem;
File

XTPReportRecordItemText.h

Remarks

You create a CXTPReportRecordItemPreview record item simply by calling constructor with one parameter - text string.

See Also

CXTPReportRecordItem

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRecordItemPreview Constructors
CXTPReportRecordItemPreview Constructors | Description
CXTPReportRecordItemPreview | Creates a new preview record item.
CXTPReportRecordItemPreview Data Members
CXTPReportRecordItemPreview Data Members | Description
m_strPreviewText | Preview content.
CXTPReportRecordItemPreview Methods
CXTPReportRecordItemPreview Methods | Description
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns preview text
GetCaptionRect | Retrieves caption text bounding rectangle
GetItemMetrics | Fills XTP_REPORTRECORDITEM_METRICS structure
GetPreviewHeight | This method is called to determine preview area height.
GetPreviewText | Returns preview text
IsPreviewItem | Determines of this item is a preview item.
OnDrawCaption | Should be overridden by descendants for drawing itself.
OnEditChanged | This method is called when value of in-place edit control changed
SetCaption | Sets caption of the item.
SetPreviewText | Set preview text


CXTPReportRecordItemPreview Data Members

CXTPReportRecordItemPreview Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview Data Members
Class

CXTPReportRecordItemPreview Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_strPreviewText | Preview content.


CXTPReportRecordItemPreview::m_strPreviewText Data Member

CXTPReportRecordItemPreview Data Members, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::m_strPreviewText Data Member

Preview content.

CString m_strPreviewText;
Group

CXTPReportRecordItemPreview Data Members


CXTPReportRecordItemPreview Methods

CXTPReportRecordItemPreview Class, Legend, Public Methods
CXTPReportRecordItemPreview Methods
Class

CXTPReportRecordItemPreview Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns preview text
GetCaptionRect | Retrieves caption text bounding rectangle
GetItemMetrics | Fills XTP_REPORTRECORDITEM_METRICS structure
GetPreviewHeight | This method is called to determine preview area height.
GetPreviewText | Returns preview text
IsPreviewItem | Determines of this item is a preview item.
OnDrawCaption | Should be overridden by descendants for drawing itself.
OnEditChanged | This method is called when value of in-place edit control changed
SetCaption | Sets caption of the item.
SetPreviewText | Set preview text


CXTPReportRecordItemPreview::GetCaption Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::GetCaption Method

Returns preview text

CString GetCaption(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Corresponded column of the item.

Returns

Text of preview item

Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::GetCaptionRect Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::GetCaptionRect Method

Retrieves caption text bounding rectangle

virtual void GetCaptionRect(
    XTP_REPORTRECORDITEM_ARGS* pDrawArgs,
    CRect& rcItem
);
Parameters

pDrawArgs
structure which contain drawing arguments.
rcItem
Bounding rectangle of the item

Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::GetItemMetrics Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::GetItemMetrics Method

Fills XTP_REPORTRECORDITEM_METRICS structure

virtual void GetItemMetrics(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pItemMetrics
);
Parameters

pDrawArgs
Draw arguments for calculating item metrics.
pItemMetrics
Pointer to the metrics item to fill with values.

Remarks

Calculates preview item metrics based on provided draw arguments. Overwrites parents' member function

See Also

XTP_REPORTRECORDITEM_DRAWARGS, XTP_REPORTRECORDITEM_METRICS

Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::GetPreviewHeight Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::GetPreviewHeight Method

This method is called to determine preview area height.

virtual int GetPreviewHeight(
    CDC* pDC,
    CXTPReportRow* pRow,
    int nWidth
);
Parameters

pDC
Pointer to control drawing context.
pRow
Pointer to corresponded row.
nWidth
Width of the row

Returns

Height of the preview area.

Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::GetPreviewText Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::GetPreviewText Method

Returns preview text

virtual CString GetPreviewText();
Returns

Text of preview item

Body Source
CString CXTPReportRecordItemPreview::GetPreviewText() {
    return m_strPreviewText;
}
Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::IsPreviewItem Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::IsPreviewItem Method

Determines of this item is a preview item.

BOOL IsPreviewItem() const;
Returns

TRUE for the preview item, FALSE otherwise.

Body Source
BOOL CXTPReportRecordItemPreview::IsPreviewItem() const {
    return TRUE;
}
Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::OnDrawCaption Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::OnDrawCaption Method

Should be overridden by descendants for drawing itself.

virtual void OnDrawCaption(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pMetrics
);
Parameters

pDrawArgs
structure which contain drawing arguments.
pMetrics
structure which contain metrics of the item.

Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::OnEditChanged Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::OnEditChanged Method

This method is called when value of in-place edit control changed

virtual void OnEditChanged(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    LPCTSTR szText
);
Parameters

pItemArgs
Pointer to structure with items arguments.
szText
New in-place edit text.

Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::SetCaption Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::SetCaption Method

Sets caption of the item.

virtual void SetCaption(
    LPCTSTR strCaption
);
Parameters

strCaption
Caption of item to set.

Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview::SetPreviewText Method

CXTPReportRecordItemPreview Methods, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::SetPreviewText Method

Set preview text

void SetPreviewText(
    LPCTSTR strPreviewText
);
Parameters

strPreviewText
new preview text

Group

CXTPReportRecordItemPreview Methods


CXTPReportRecordItemPreview Constructors

CXTPReportRecordItemPreview Class, Legend, Public Methods
CXTPReportRecordItemPreview Constructors
Class

CXTPReportRecordItemPreview Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemPreview | Creates a new preview record item.


CXTPReportRecordItemPreview::CXTPReportRecordItemPreview Constructor

CXTPReportRecordItemPreview Constructors, CXTPReportRecordItemPreview Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemPreview::CXTPReportRecordItemPreview Constructor

Creates a new preview record item.

CXTPReportRecordItemPreview(
    LPCTSTR szPreviewText = _T("")
);
Parameters

szPreviewText
Pointer to the preview text of item.

Group

CXTPReportRecordItemPreview Constructors


CXTPReportRecordItemText Class

XTPReportRecordItemText.h, Classes, Legend, Members, Topics, CXTPReportRecordItemText Data Members, CXTPReportRecordItemText Methods, CXTPReportRecordItemText Constructors, CXTPReportRecordItemText Constructors, CXTPReportRecordItemText Data Members, CXTPReportRecordItemText Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText Class

This Class represents a text-only cell and inherits basic functionality from CXTPReportRecordItem class. You create a text record item simply by calling a constructor with one parameter - text string

Class Hierarchy

class CXTPReportRecordItemText : public CXTPReportRecordItem;
File

XTPReportRecordItemText.h

See Also

CXTPReportRecordItem

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRecordItemText Constructors
CXTPReportRecordItemText Constructors | Description
CXTPReportRecordItemText | Creates a record text item.
CXTPReportRecordItemText Data Members
CXTPReportRecordItemText Data Members | Description
m_strText | Item text value.
CXTPReportRecordItemText Methods
CXTPReportRecordItemText Methods | Description
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns a text caption of this item.
GetValue | Returns the item value in its original format.
OnEditChanged | This method is called when value of in-place edit control changed
SetValue | Sets the text caption for the item.


CXTPReportRecordItemText Data Members

CXTPReportRecordItemText Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText Data Members
Class

CXTPReportRecordItemText Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_strText | Item text value.


CXTPReportRecordItemText::m_strText Data Member

CXTPReportRecordItemText Data Members, CXTPReportRecordItemText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText::m_strText Data Member

Item text value.

CString m_strText;
Group

CXTPReportRecordItemText Data Members


CXTPReportRecordItemText Methods

CXTPReportRecordItemText Class, Legend, Public Methods
CXTPReportRecordItemText Methods
Class

CXTPReportRecordItemText Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns a text caption of this item.
GetValue | Returns the item value in its original format.
OnEditChanged | This method is called when value of in-place edit control changed
SetValue | Sets the text caption for the item.


CXTPReportRecordItemText::DoPropExchange Method

CXTPReportRecordItemText Methods, CXTPReportRecordItemText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText::DoPropExchange Method

Call this member function to Store/Load a report record item using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Group

CXTPReportRecordItemText Methods


CXTPReportRecordItemText::GetCaption Method

CXTPReportRecordItemText Methods, CXTPReportRecordItemText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText::GetCaption Method

Returns a text caption of this item.

CString GetCaption(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Corresponded column of the item.

Returns

Text caption of the item.

Remarks

Overwrites parents' member function

Group

CXTPReportRecordItemText Methods


CXTPReportRecordItemText::GetValue Method

CXTPReportRecordItemText Methods, CXTPReportRecordItemText Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText::GetValue Method

Returns the item value in its original format.

CString GetValue();
Returns

Initial item text string.

Body Source
CString CXTPReportRecordItemText::GetValue() {
    return m_strText;
}
Group

CXTPReportRecordItemText Methods


CXTPReportRecordItemText::OnEditChanged Method

CXTPReportRecordItemText Methods, CXTPReportRecordItemText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText::OnEditChanged Method

This method is called when value of in-place edit control changed

virtual void OnEditChanged(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    LPCTSTR szText
);
Parameters

pItemArgs
Pointer to structure with items arguments.
szText
New in-place edit text.

Group

CXTPReportRecordItemText Methods


CXTPReportRecordItemText::SetValue Method

CXTPReportRecordItemText Methods, CXTPReportRecordItemText Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText::SetValue Method

Sets the text caption for the item.

void SetValue(
    LPCTSTR szText
);
Parameters

szText
Text caption for the item.

Body Source
void CXTPReportRecordItemText::SetValue(LPCTSTR szText){
    m_strText = szText;
}
Group

CXTPReportRecordItemText Methods


CXTPReportRecordItemText Constructors

CXTPReportRecordItemText Class, Legend, Public Methods
CXTPReportRecordItemText Constructors
Class

CXTPReportRecordItemText Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemText | Creates a record text item.


CXTPReportRecordItemText::CXTPReportRecordItemText Constructor

CXTPReportRecordItemText Constructors, CXTPReportRecordItemText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemText::CXTPReportRecordItemText Constructor

Creates a record text item.

CXTPReportRecordItemText(
    LPCTSTR szText = _T("")
);
Parameters

szText
A text value for the item.

Group

CXTPReportRecordItemText Constructors


CXTPReportRecordItemVariant Class

XTPReportRecordItemText.h, Classes, Legend, Members, Topics, CXTPReportRecordItemVariant Data Members, CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Constructors, CXTPReportRecordItemVariant Constructors, CXTPReportRecordItemVariant Data Members, CXTPReportRecordItemVariant Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant Class

Represents a variant item and inherits basic functionality from CXTPReportRecordItem class. You can create a bitmap record item simply by calling a constructor with the only one parameter - value of VARIANT type.

Class Hierarchy

class CXTPReportRecordItemVariant : public CXTPReportRecordItem;
File

XTPReportRecordItemText.h

See Also

CXTPReportRecordItem

Group

Classes

Legend
Data Member
Method
virtual
protected
CXTPReportRecordItemVariant Constructors
CXTPReportRecordItemVariant Constructors | Description
CXTPReportRecordItemVariant | Creates a new variant record item.
CXTPReportRecordItemVariant Data Members
CXTPReportRecordItemVariant Data Members | Description
m_nSortLocale | Sort locale
m_oleValue | Item value.
CXTPReportRecordItemVariant Methods
CXTPReportRecordItemVariant Methods | Description
Compare | Compares this item with the provided one.
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns a text caption of this item.
GetSelectedConstraintData | Retrieves associated value with selected constraint.
OnConstraintChanged | This method is called when user select specified constraint in in-place list
OnEditChanged | This method is called when value of in-place edit control changed
OnEditChanging | This method is called when in-place editor value changed by user
OnValueChanging | This method is called before value changed by user
SetValue | Sets new value for the item.


CXTPReportRecordItemVariant Data Members

CXTPReportRecordItemVariant Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant Data Members
Class

CXTPReportRecordItemVariant Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_nSortLocale | Sort locale
m_oleValue | Item value.


CXTPReportRecordItemVariant::m_nSortLocale Data Member

CXTPReportRecordItemVariant Data Members, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::m_nSortLocale Data Member

Sort locale

int m_nSortLocale;
Group

CXTPReportRecordItemVariant Data Members


CXTPReportRecordItemVariant::m_oleValue Data Member

CXTPReportRecordItemVariant Data Members, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::m_oleValue Data Member

Item value.

COleVariant m_oleValue;
Group

CXTPReportRecordItemVariant Data Members


CXTPReportRecordItemVariant Methods

CXTPReportRecordItemVariant Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant Methods
Class

CXTPReportRecordItemVariant Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnEditChanging | This method is called when in-place editor value changed by user
OnValueChanging | This method is called before value changed by user
Public Methods
Public Methods
Public Method | Description
Compare | Compares this item with the provided one.
DoPropExchange | Call this member function to Store/Load a report record item using the specified data object.
GetCaption | Returns a text caption of this item.
GetSelectedConstraintData | Retrieves associated value with selected constraint.
OnConstraintChanged | This method is called when user select specified constraint in in-place list
OnEditChanged | This method is called when value of in-place edit control changed
SetValue | Sets new value for the item.


CXTPReportRecordItemVariant::Compare Method

CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::Compare Method

Compares this item with the provided one.

int Compare(
    CXTPReportColumn*,
    CXTPReportRecordItem* pItem
);
Parameters

pItem
The item provided for comparing with current.

Returns

Zero if pItem is equal with current; Less than zero if less than pItem; Greater than zero if greater than pItem.

Remarks

Overwrites parents' member function

Group

CXTPReportRecordItemVariant Methods


CXTPReportRecordItemVariant::GetCaption Method

CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::GetCaption Method

Returns a text caption of this item.

CString GetCaption(
    CXTPReportColumn* pColumn
);
Parameters

pColumn
Corresponded column of the item.

Returns

Text caption of the item.

Remarks

Overwrites parents' member function

Group

CXTPReportRecordItemVariant Methods


CXTPReportRecordItemVariant::GetSelectedConstraintData Method

CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::GetSelectedConstraintData Method

Retrieves associated value with selected constraint.

DWORD GetSelectedConstraintData(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs
);
Parameters

pItemArgs
Pointer to structure with items arguments

Returns

DWORD value associated with selected constraint.

Group

CXTPReportRecordItemVariant Methods


CXTPReportRecordItemVariant::OnConstraintChanged Method

CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::OnConstraintChanged Method

This method is called when user select specified constraint in in-place list

void OnConstraintChanged(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    CXTPReportRecordItemConstraint* pConstraint
);
Parameters

pItemArgs
Pointer to structure with items arguments
pConstraint
Selected constraint

Group

CXTPReportRecordItemVariant Methods


CXTPReportRecordItemVariant::OnEditChanged Method

CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::OnEditChanged Method

This method is called when value of in-place edit control changed

virtual void OnEditChanged(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    LPCTSTR szText
);
Parameters

pItemArgs
Pointer to structure with items arguments.
szText
New in-place edit text.

Group

CXTPReportRecordItemVariant Methods


CXTPReportRecordItemVariant::OnEditChanging Method

CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::OnEditChanging Method

This method is called when in-place editor value changed by user

virtual BOOL OnEditChanging(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    CString& rstrNewText
);
Parameters

pItemArgs
item arguments
rstrNewText
new string to be set in the editor

Returns

FALSE to cancel edit operation.

Group

CXTPReportRecordItemVariant Methods


CXTPReportRecordItemVariant::OnValueChanging Method

CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::OnValueChanging Method

This method is called before value changed by user

virtual BOOL OnValueChanging(
    XTP_REPORTRECORDITEM_ARGS* pItemArgs,
    LPVARIANT lpNewValue
);
Parameters

pItemArgs
item arguments
lpNewValue
new value to be set

Returns

FALSE to cancel edit operation.

Group

CXTPReportRecordItemVariant Methods


CXTPReportRecordItemVariant::SetValue Method

CXTPReportRecordItemVariant Methods, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::SetValue Method

Sets new value for the item.

void SetValue(
    COleVariant& var
);
Parameters

var
New value for the item.

Group

CXTPReportRecordItemVariant Methods


CXTPReportRecordItemVariant Constructors

CXTPReportRecordItemVariant Class, Legend, Public Methods
CXTPReportRecordItemVariant Constructors
Class

CXTPReportRecordItemVariant Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemVariant | Creates a new variant record item.


CXTPReportRecordItemVariant::CXTPReportRecordItemVariant Constructor

CXTPReportRecordItemVariant Constructors, CXTPReportRecordItemVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecordItemVariant::CXTPReportRecordItemVariant Constructor

Creates a new variant record item.

CXTPReportRecordItemVariant(
    const VARIANT& lpValue = COleVariant((long)0)
);
Parameters

lpValue
Pointer to the initial item value.

Group

CXTPReportRecordItemVariant Constructors


CXTPReportRecords Class

XTPReportRecords.h, Classes, Legend, Members, Topics, CXTPReportRecords Data Members, CXTPReportRecords Methods, CXTPReportRecords Constructors, CXTPReportRecords Destructors, CXTPReportRecords Constructors, CXTPReportRecords Data Members, CXTPReportRecords Destructors, Example, CXTPReportRecords Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords Class

This class represents a records collection class. It supports an array of CXTPReportRecord pointers.

Class Hierarchy

class CXTPReportRecords : public CXTPHeapObjectT<CCmdTarget, CXTPReportDataAllocator>;
File

XTPReportRecords.h

See Also

CXTPReportRecord

Example

See example for CXTPReportRecords::Add method.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRecords Constructors
CXTPReportRecords Constructors | Description
CXTPReportRecords |
CXTPReportRecords Data Members
CXTPReportRecords Data Members | Description
m_arrRecords | Internal storage array for Record items.
m_bCaseSensitive | Indicating whether string comparisons are case-sensitive.
m_nVirtualRecordsCount | Virtual records count.
m_pMarkupContext | Markup Context;
m_pOwnerRecord | Store pointer to owner record object (or NULL);
m_pVirtualRecord | Virtual record.
CXTPReportRecords Destructors
CXTPReportRecords Destructors | Description
~CXTPReportRecords | Destroys CXTPReportRecords object. Performs cleanup operations.
CXTPReportRecords Methods
CXTPReportRecords Methods | Description
Add | Adds a new Record element to the end of an array.
Compare | Helper function to compares two strings.
DoPropExchange | Call this member function to Store/Load a report records
EnableMarkup | Call this method to enable markup for tab captions
GetAt | Returns a record at the specified numeric index.
GetCount | Gets the number of CXTPReportRecord elements in this collection.
GetMarkupContext | Returns markup context
GetOwnerRecord | Used to get CXTPReportRecord owner object;
InsertAt | Call this method to add record in the specified position.
IsCaseSensitive | Determines whether string comparisons are case-sensitive.
Move | Call this method to move records to specified position
RemoveAll | Removes all the elements from this array.
RemoveAt | Removes record by its index.
RemoveRecord | Removes specified record from collection.
SetAt | This member function is used to set a new element to the position specified in the nIndex parameter.
SetCaseSensitive | Sets a value indicating whether string comparisons are case-sensitive.
SetSize | This member function is used to change the array size.
UpdateIndexes | This member function is used to record indexes.


CXTPReportRecords Data Members

CXTPReportRecords Class, Legend, Protected Data Members
CXTPReportRecords Data Members
Class

CXTPReportRecords Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrRecords | Internal storage array for Record items.
m_bCaseSensitive | Indicating whether string comparisons are case-sensitive.
m_nVirtualRecordsCount | Virtual records count.
m_pMarkupContext | Markup Context;
m_pOwnerRecord | Store pointer to owner record object (or NULL);
m_pVirtualRecord | Virtual record.


CXTPReportRecords::m_arrRecords Data Member

CXTPReportRecords Data Members, CXTPReportRecords Class
CXTPReportRecords::m_arrRecords Data Member

Internal storage array for Record items.

CArray<CXTPReportRecord*, CXTPReportRecord*> m_arrRecords;
Group

CXTPReportRecords Data Members


CXTPReportRecords::m_bCaseSensitive Data Member

CXTPReportRecords Data Members, CXTPReportRecords Class
CXTPReportRecords::m_bCaseSensitive Data Member

Indicating whether string comparisons are case-sensitive.

BOOL m_bCaseSensitive;
Group

CXTPReportRecords Data Members


CXTPReportRecords::m_nVirtualRecordsCount Data Member

CXTPReportRecords Data Members, CXTPReportRecords Class
CXTPReportRecords::m_nVirtualRecordsCount Data Member

Virtual records count.

int m_nVirtualRecordsCount;
Group

CXTPReportRecords Data Members


CXTPReportRecords::m_pMarkupContext Data Member

CXTPReportRecords Data Members, CXTPReportRecords Class
CXTPReportRecords::m_pMarkupContext Data Member

Markup Context;

CXTPMarkupContext* m_pMarkupContext;
Group

CXTPReportRecords Data Members


CXTPReportRecords::m_pOwnerRecord Data Member

CXTPReportRecords Data Members, CXTPReportRecords Class
CXTPReportRecords::m_pOwnerRecord Data Member

Store pointer to owner record object (or NULL);

CXTPReportRecord* m_pOwnerRecord;
Group

CXTPReportRecords Data Members


CXTPReportRecords::m_pVirtualRecord Data Member

CXTPReportRecords Data Members, CXTPReportRecords Class
CXTPReportRecords::m_pVirtualRecord Data Member

Virtual record.

CXTPReportRecord* m_pVirtualRecord;
Group

CXTPReportRecords Data Members


CXTPReportRecords Methods

CXTPReportRecords Class, Legend, Public Methods
CXTPReportRecords Methods
Class

CXTPReportRecords Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Add | Adds a new Record element to the end of an array.
Compare | Helper function to compares two strings.
DoPropExchange | Call this member function to Store/Load a report records
EnableMarkup | Call this method to enable markup for tab captions
GetAt | Returns a record at the specified numeric index.
GetCount | Gets the number of CXTPReportRecord elements in this collection.
GetMarkupContext | Returns markup context
GetOwnerRecord | Used to get CXTPReportRecord owner object;
InsertAt | Call this method to add record in the specified position.
IsCaseSensitive | Determines whether string comparisons are case-sensitive.
Move | Call this method to move records to specified position
RemoveAll | Removes all the elements from this array.
RemoveAt | Removes record by its index.
RemoveRecord | Removes specified record from collection.
SetAt | This member function is used to set a new element to the position specified in the nIndex parameter.
SetCaseSensitive | Sets a value indicating whether string comparisons are case-sensitive.
SetSize | This member function is used to change the array size.
UpdateIndexes | This member function is used to record indexes.


CXTPReportRecords::Add Method

CXTPReportRecords Methods, CXTPReportRecords Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords::Add Method

Adds a new Record element to the end of an array.

CXTPReportRecord* Add(
    CXTPReportRecord* pRecord
);
Parameters

pRecord
The record element to be added to this array.

Remarks

Use this method to add the specified CXTPReportRecord pointer to the end of the CXTPReportRecords collection.

See Also

CXTPReportRecords overview, GetAt, RemoveAll, GetCount

Example
CXTPReportRecords* pList = new CXTPReportRecords();
pList->Add(new CXTPReportRecord());
pList->Add(new CXTPReportRecord());
CXTPReportRecord* pRecord0 = pList->GetAt(0);
CXTPReportRecord* pRecord1 = pList->GetAt(1);
ASSERT(2 == pList->GetCount());
pList->RemoveAll();
ASSERT(0 == pList->GetCount());
Group

CXTPReportRecords Methods


CXTPReportRecords::Compare Method

CXTPReportRecords Methods, CXTPReportRecords Class, See Also
CXTPReportRecords::Compare Method

Helper function to compares two strings.

virtual int Compare(
    const CString& str1,
    const CString& str2
) const;
Parameters

str1
First string to compare
str2
Second string to compare

Returns

Zero if the strings are identical, < 0 if this str1 object is less than str2, or > 0 if this str1 object is greater than str2.

See Also

SetCaseSensitive

Group

CXTPReportRecords Methods


CXTPReportRecords::DoPropExchange Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::DoPropExchange Method

Call this member function to Store/Load a report records

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Group

CXTPReportRecords Methods


CXTPReportRecords::EnableMarkup Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::EnableMarkup Method

Call this method to enable markup for tab captions

void EnableMarkup(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable markup

Group

CXTPReportRecords Methods


CXTPReportRecords::GetAt Method

CXTPReportRecords Methods, CXTPReportRecords Class, Example
CXTPReportRecords::GetAt Method

Returns a record at the specified numeric index.

CXTPReportRecord* GetAt(
    int nIndex
) const;
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.

Returns

The record element currently at this index.

Remarks

Returns the array element at the specified index.

Example

See example for CXTPReportRecords::Add method.

Group

CXTPReportRecords Methods


CXTPReportRecords::GetCount Method

CXTPReportRecords Methods, CXTPReportRecords Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords::GetCount Method

Gets the number of CXTPReportRecord elements in this collection.

int GetCount() const;
Returns

The number of items in the collection.

Remarks

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

See Also

CXTPReportRecords overview

Example

See example for CXTPReportRecords::Add method.

Group

CXTPReportRecords Methods


CXTPReportRecords::GetMarkupContext Method

CXTPReportRecords Methods, CXTPReportRecords Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords::GetMarkupContext Method

Returns markup context

CXTPMarkupContext* GetMarkupContext() const;
Body Source
CXTPMarkupContext* CXTPReportRecords::GetMarkupContext() const {
    return m_pMarkupContext;
}
Group

CXTPReportRecords Methods


CXTPReportRecords::GetOwnerRecord Method

CXTPReportRecords Methods, CXTPReportRecords Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords::GetOwnerRecord Method

Used to get CXTPReportRecord owner object;

CXTPReportRecord* GetOwnerRecord() const;
Returns

A pointer to owner CXTPReportRecord object or NULL.

Body Source
CXTPReportRecord* CXTPReportRecords::GetOwnerRecord() const {
    return m_pOwnerRecord;
}
Group

CXTPReportRecords Methods


CXTPReportRecords::InsertAt Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::InsertAt Method

Call this method to add record in the specified position.

void InsertAt(
    int nIndex,
    CXTPReportRecord* pRecord
);
Parameters

nIndex
Index of record to insert.
pRecord
Record to be inserted.

Group

CXTPReportRecords Methods


CXTPReportRecords::IsCaseSensitive Method

CXTPReportRecords Methods, CXTPReportRecords Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords::IsCaseSensitive Method

Determines whether string comparisons are case-sensitive.

BOOL IsCaseSensitive() const;
See Also

SetCaseSensitive

Body Source
BOOL CXTPReportRecords::IsCaseSensitive() const {
    return m_bCaseSensitive;
}
Group

CXTPReportRecords Methods


CXTPReportRecords::Move Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::Move Method

Call this method to move records to specified position

void Move(
    int nIndex,
    CXTPReportRecords* pRecords
);
Parameters

nIndex
index to move records
pRecords
Records to move

Group

CXTPReportRecords Methods


CXTPReportRecords::RemoveAll Method

CXTPReportRecords Methods, CXTPReportRecords Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords::RemoveAll Method

Removes all the elements from this array.

void RemoveAll();
Remarks

Removes all the pointers from this array and releases instances of all stored CXTPReportRecord objects.

See Also

CXTPReportRecords overview

Example

See example for CXTPReportRecords::Add method.

Group

CXTPReportRecords Methods


CXTPReportRecords::RemoveAt Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::RemoveAt Method

Removes record by its index.

void RemoveAt(
    int nIndex
);
Parameters

nIndex
index of record to remove.

Group

CXTPReportRecords Methods


CXTPReportRecords::RemoveRecord Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::RemoveRecord Method

Removes specified record from collection.

int RemoveRecord(
    CXTPReportRecord* pRecord
);
Parameters

pRecord
Record to be removed.

Returns

Removed record index or -1 if specified record is not in this collection.

Group

CXTPReportRecords Methods


CXTPReportRecords::SetAt Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::SetAt Method

This member function is used to set a new element to the position specified in the nIndex parameter.

virtual void SetAt(
    INT_PTR nIndex,
    CXTPReportRecord* pRecord
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
pRecord
A pointer to a CXTPReportRecord object. The element to add to the array.

Group

CXTPReportRecords Methods


CXTPReportRecords::SetCaseSensitive Method

CXTPReportRecords Methods, CXTPReportRecords Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords::SetCaseSensitive Method

Sets a value indicating whether string comparisons are case-sensitive.

void SetCaseSensitive(
    BOOL bCaseSensitive
);
Parameters

bCaseSensitive
TRUE if string comparisons are case-sensitive; otherwise, FALSE. The default is FALSE.

See Also

IsCaseSensitive

Body Source
void CXTPReportRecords::SetCaseSensitive(BOOL bCaseSensitive) {
    m_bCaseSensitive = bCaseSensitive;
}
Group

CXTPReportRecords Methods


CXTPReportRecords::SetSize Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::SetSize Method

This member function is used to change the array size.

virtual void SetSize(
    INT_PTR nNewSize,
    INT_PTR nGrowBy = -1
);
Parameters

nNewSize
An int that contains the new array size.
nGrowBy
The minimum number of element slots to allocate if a size increase is necessary.

Group

CXTPReportRecords Methods


CXTPReportRecords::UpdateIndexes Method

CXTPReportRecords Methods, CXTPReportRecords Class
CXTPReportRecords::UpdateIndexes Method

This member function is used to record indexes.

virtual void UpdateIndexes(
    int nStart = 0
);
Parameters

nStart
An integer index to start update from.

Group

CXTPReportRecords Methods


CXTPReportRecords Constructors

CXTPReportRecords Class, Legend, Public Methods
CXTPReportRecords Constructors
Class

CXTPReportRecords Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecords |


CXTPReportRecords Constructor

CXTPReportRecords Constructors
CXTPReportRecords Constructor
Overload List
Constructors
Constructor | Description
CXTPReportRecords::CXTPReportRecords (BOOL) | Constructs an empty CXTPReportRecord pointer array.
CXTPReportRecords::CXTPReportRecords (CXTPReportRecord*) | Constructs an empty CXTPReportRecord pointer array in case if it is used as a member of CXTPReportRecord object to store children.
Group

CXTPReportRecords Constructors


CXTPReportRecords::CXTPReportRecords Constructor (BOOL)

CXTPReportRecords Constructor, CXTPReportRecords Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRecords::CXTPReportRecords Constructor (BOOL)

Constructs an empty CXTPReportRecord pointer array.

CXTPReportRecords(
    BOOL bArray = FALSE
);
Example
// Declare a local CXTPReportRecords object.
CXTPReportRecords myList;

// Declare a dynamic CXTPReportRecords object.
CXTPReportRecords* pTree = new CXTPReportRecords();
Group

CXTPReportRecords Constructor


CXTPReportRecords::CXTPReportRecords Constructor (CXTPReportRecord*)

CXTPReportRecords Constructor, CXTPReportRecords Class
CXTPReportRecords::CXTPReportRecords Constructor (CXTPReportRecord*)

Constructs an empty CXTPReportRecord pointer array in case if it is used as a member of CXTPReportRecord object to store children.

CXTPReportRecords(
    CXTPReportRecord* pOwnerRecord
);
Parameters

pOwnerRecord
A pointer to owner CXTPReportRecord object.

Group

CXTPReportRecords Constructor


CXTPReportRecords Destructors

CXTPReportRecords Class, Legend, Public Methods
CXTPReportRecords Destructors
Class

CXTPReportRecords Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportRecords | Destroys CXTPReportRecords object. Performs cleanup operations.


CXTPReportRecords::~CXTPReportRecords Destructor

CXTPReportRecords Destructors, CXTPReportRecords Class
CXTPReportRecords::~CXTPReportRecords Destructor

Destroys CXTPReportRecords object. Performs cleanup operations.

virtual ~CXTPReportRecords();
Group

CXTPReportRecords Destructors


CXTPReportRow Class

XTPReportRow.h, Classes, Legend, Members, Topics, CXTPReportRow Data Members, CXTPReportRow Methods, CXTPReportRow Constructors, CXTPReportRow Destructors, CXTPReportRow Constructors, CXTPReportRow Data Members, CXTPReportRow Destructors, CXTPReportRow Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRow Class

CXTPReportRow class represents an row of the report control window.

Class Hierarchy

class CXTPReportRow : public CXTPHeapObjectT<CCmdTarget, CXTPReportRowAllocator>;
File

XTPReportRow.h

Remarks

Each item has corresponding a CXTPReportRecord, and could have a list of sub-items associated with it. By clicking a Row item, the user can expand and collapse the associated list of sub-items.

CXTPReportRow handles a behavior of report row. It processes user mouse and keyboard events, it also implements external control member functions. It is also handling drawing logic for the row.

A collection of report row items is combined into CXTPReportRows and could be accessed via CXTPReportControl::GetRows() method.

See Also

CXTPReportControl overview, CXTPReportRows, CXTPReportRecord, CXTPReportRecordItem, CXTPReportGroupRow

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRow Constructors
CXTPReportRow Constructors | Description
CXTPReportRow | A constructor of the CXTPReportRow object.
CXTPReportRow Data Members
CXTPReportRow Data Members | Description
m_bExpanded | TRUE when row is expanded in a tree view, FALSE when row is collapsed.
m_bVisible | TRUE if this row should be visible, FALSE when row is hidden.
m_nChildIndex | Index of row inside parent rows.
m_nGroupLevel | Contains row depth level when row is a group row.
m_nIndex | Item index.
m_nPreviewHeight | Height of the preview item of this row.
m_nRowLevel | Row depth level in a tree.
m_nRowType | Row type from XTPReportRowType
m_pChilds | A collection of row children.
m_pControl | Pointer to the parent report control.
m_pParentRow | Pointer to the parent row in the tree.
m_pParentRows | Pointer to the parent rows in the tree.
m_pRecord | Pointer to the associated CXTPReportRecord object.
m_rcCollapse | A rectangle with coordinates of collapse/expand bitmap.
m_rcRow | A rectangle where a row is to be drawn.
CXTPReportRow Destructors
CXTPReportRow Destructors | Description
~CXTPReportRow | Destroys CXTPReportRow object, handles cleanup and deallocation.
CXTPReportRow Methods
CXTPReportRow Methods | Description
AddChild | Adds a child row to the current row.
Draw | Draws the row on the provided DC.
DrawFixed | Draws the row (of header/footer records) on the provided DC.
EnsureVisible | Call this member to force this row to be visible. This will cause the report control to scroll to this row. This is also called by CXTPReportControl::SetFocusedRow to make visible the newly focused row.
FillMetrics | Fill XTP_REPORTRECORDITEM_METRICS structure with drawing metrics
GetChilds | Returns a collection of this row children.
GetControl | Returns a pointer to the parent report control.
GetGroupLevel | Call this member to determine the row depth level when row is a group row.
GetHeight | Calculates height of the row depending on the provided DC.
GetIndex | Returns current row index in the view.
GetItemMetrics | Returns drawing metrics for the row.
GetItemRect | Determines rectangle of specified item
GetLastChildRow | Get the latest row index from the group specified.
GetNextSiblingRow | Returns the next sibling row of the current row.
GetParentRow | Returns the parent row of the current row.
GetParentRows | Returns the parent rows of the current row.
GetRecord | Get associated record.
GetRect | Returns coordinates of the row rectangle.
GetTreeDepth | Returns a depth of this row in tree view.
GetType | Call this member to determine the row type: body, header, or footer.
HasChildren | Determines if a row has children in tree view.
HasParent | Determines if a row has a parent in tree view.
HitTest | Determines which report item, if any, is at a specified position.
InitRow |
IsExpanded | Returns row expanded state.
IsFocused | Returns row focused state.
IsGroupRow | Determines if this row is a group row.
IsItemsVisible | Determines if items are visible
IsLastTreeRow | Call this member to determine if the row is the last tree row. Or is not part of a tree row.
IsPreviewVisible | Determines if preview item is visible.
IsSelected | Returns row selected state.
OnClick | Process mouse clicks. Called by the framework when the user has clicked the mouse button in the row area.
OnContextMenu | Process context menu. Called by the framework when the user has clicked the right mouse button (right clicked) in the window.
OnDblClick | Process mouse double clicks. Called by the framework when the user has double-clicked the mouse button in the row area.
OnLButtonDown | Processes mouse left button down clicks.
OnLButtonUp | Processes mouse left button up clicks.
OnMouseMove | Process mouse moving.
OnToolHitTest | The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
SelectChilds | Call this member to select all child items of specified row.
SetCollapseRect | Sets coordinates of the collapse/expand button for this row.
SetExpanded | Sets row expanded state.
SetIndex | Sets new row index in the view.
SetSelected | Call this member to select/set focus to the row. If multiple selection is enabled, then this row will be added to the selection.
ShiftTreeIndent | This method is call to update rectangle of item
ShowToolTip | Shows a specified tooltip window at the specified position.


CXTPReportRow Data Members

CXTPReportRow Class, Legend, Protected Data Members
CXTPReportRow Data Members
Class

CXTPReportRow Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bExpanded | TRUE when row is expanded in a tree view, FALSE when row is collapsed.
m_bVisible | TRUE if this row should be visible, FALSE when row is hidden.
m_nChildIndex | Index of row inside parent rows.
m_nGroupLevel | Contains row depth level when row is a group row.
m_nIndex | Item index.
m_nPreviewHeight | Height of the preview item of this row.
m_nRowLevel | Row depth level in a tree.
m_nRowType | Row type from XTPReportRowType
m_pChilds | A collection of row children.
m_pControl | Pointer to the parent report control.
m_pParentRow | Pointer to the parent row in the tree.
m_pParentRows | Pointer to the parent rows in the tree.
m_pRecord | Pointer to the associated CXTPReportRecord object.
m_rcCollapse | A rectangle with coordinates of collapse/expand bitmap.
m_rcRow | A rectangle where a row is to be drawn.


CXTPReportRow::m_bExpanded Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_bExpanded Data Member

TRUE when row is expanded in a tree view, FALSE when row is collapsed.

BOOL m_bExpanded;
Group

CXTPReportRow Data Members


CXTPReportRow::m_bVisible Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_bVisible Data Member

TRUE if this row should be visible, FALSE when row is hidden.

BOOL m_bVisible;
Group

CXTPReportRow Data Members


CXTPReportRow::m_nChildIndex Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_nChildIndex Data Member

Index of row inside parent rows.

int m_nChildIndex;
Group

CXTPReportRow Data Members


CXTPReportRow::m_nGroupLevel Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_nGroupLevel Data Member

Contains row depth level when row is a group row.

int m_nGroupLevel;
Group

CXTPReportRow Data Members


CXTPReportRow::m_nIndex Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_nIndex Data Member

Item index.

int m_nIndex;
Group

CXTPReportRow Data Members


CXTPReportRow::m_nPreviewHeight Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_nPreviewHeight Data Member

Height of the preview item of this row.

int m_nPreviewHeight;
Group

CXTPReportRow Data Members


CXTPReportRow::m_nRowLevel Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_nRowLevel Data Member

Row depth level in a tree.

int m_nRowLevel;
Group

CXTPReportRow Data Members


CXTPReportRow::m_nRowType Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_nRowType Data Member

Row type from XTPReportRowType

XTPReportRowType m_nRowType;
Group

CXTPReportRow Data Members


CXTPReportRow::m_pChilds Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_pChilds Data Member

A collection of row children.

CXTPReportRows* m_pChilds;
Group

CXTPReportRow Data Members


CXTPReportRow::m_pControl Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_pControl Data Member

Pointer to the parent report control.

CXTPReportControl* m_pControl;
Group

CXTPReportRow Data Members


CXTPReportRow::m_pParentRow Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_pParentRow Data Member

Pointer to the parent row in the tree.

CXTPReportRow* m_pParentRow;
Group

CXTPReportRow Data Members


CXTPReportRow::m_pParentRows Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_pParentRows Data Member

Pointer to the parent rows in the tree.

CXTPReportRows* m_pParentRows;
Group

CXTPReportRow Data Members


CXTPReportRow::m_pRecord Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_pRecord Data Member

Pointer to the associated CXTPReportRecord object.

CXTPReportRecord* m_pRecord;
Group

CXTPReportRow Data Members


CXTPReportRow::m_rcCollapse Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_rcCollapse Data Member

A rectangle with coordinates of collapse/expand bitmap.

CRect m_rcCollapse;
Group

CXTPReportRow Data Members


CXTPReportRow::m_rcRow Data Member

CXTPReportRow Data Members, CXTPReportRow Class
CXTPReportRow::m_rcRow Data Member

A rectangle where a row is to be drawn.

CRect m_rcRow;
Group

CXTPReportRow Data Members


CXTPReportRow Methods

CXTPReportRow Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRow Methods
Class

CXTPReportRow Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetLastChildRow | Get the latest row index from the group specified.
SetIndex | Sets new row index in the view.
Public Methods
Public Methods
Public Method | Description
AddChild | Adds a child row to the current row.
Draw | Draws the row on the provided DC.
DrawFixed | Draws the row (of header/footer records) on the provided DC.
EnsureVisible | Call this member to force this row to be visible. This will cause the report control to scroll to this row. This is also called by CXTPReportControl::SetFocusedRow to make visible the newly focused row.
FillMetrics | Fill XTP_REPORTRECORDITEM_METRICS structure with drawing metrics
GetChilds | Returns a collection of this row children.
GetControl | Returns a pointer to the parent report control.
GetGroupLevel | Call this member to determine the row depth level when row is a group row.
GetHeight | Calculates height of the row depending on the provided DC.
GetIndex | Returns current row index in the view.
GetItemMetrics | Returns drawing metrics for the row.
GetItemRect | Determines rectangle of specified item
GetNextSiblingRow | Returns the next sibling row of the current row.
GetParentRow | Returns the parent row of the current row.
GetParentRows | Returns the parent rows of the current row.
GetRecord | Get associated record.
GetRect | Returns coordinates of the row rectangle.
GetTreeDepth | Returns a depth of this row in tree view.
GetType | Call this member to determine the row type: body, header, or footer.
HasChildren | Determines if a row has children in tree view.
HasParent | Determines if a row has a parent in tree view.
HitTest | Determines which report item, if any, is at a specified position.
InitRow |
IsExpanded | Returns row expanded state.
IsFocused | Returns row focused state.
IsGroupRow | Determines if this row is a group row.
IsItemsVisible | Determines if items are visible
IsLastTreeRow | Call this member to determine if the row is the last tree row. Or is not part of a tree row.
IsPreviewVisible | Determines if preview item is visible.
IsSelected | Returns row selected state.
OnClick | Process mouse clicks. Called by the framework when the user has clicked the mouse button in the row area.
OnContextMenu | Process context menu. Called by the framework when the user has clicked the right mouse button (right clicked) in the window.
OnDblClick | Process mouse double clicks. Called by the framework when the user has double-clicked the mouse button in the row area.
OnLButtonDown | Processes mouse left button down clicks.
OnLButtonUp | Processes mouse left button up clicks.
OnMouseMove | Process mouse moving.
OnToolHitTest | The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
SelectChilds | Call this member to select all child items of specified row.
SetCollapseRect | Sets coordinates of the collapse/expand button for this row.
SetExpanded | Sets row expanded state.
SetSelected | Call this member to select/set focus to the row. If multiple selection is enabled, then this row will be added to the selection.
ShiftTreeIndent | This method is call to update rectangle of item
ShowToolTip | Shows a specified tooltip window at the specified position.


CXTPReportRow::AddChild Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::AddChild Method

Adds a child row to the current row.

virtual CXTPReportRow* AddChild(
    CXTPReportRow* pRow
);
Parameters

pRow
Pointer to a child CXTPReportRow object.

Returns

A pointer to the added CXTPReportRow object.

Remarks

Call this member function if you want to add a CXTPReportRow object as a child of current row in tree view mode.

See Also

GetParentRow, HasParent, GetTreeDepth, GetChilds

Group

CXTPReportRow Methods


CXTPReportRow::Draw Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::Draw Method

Draws the row on the provided DC.

virtual void Draw(
    CDC* pDC,
    CRect rcRow,
    int nLeftOffset
);
Parameters

pDC
Pointer to control drawing context.
rcRow
Coordinates of the rectangle for drawing this row.
nLeftOffset
Start drawing left offset in pixels (Horizontal scroll position).

Remarks

Call this member function to draw an item. This function only prepares data for drawing and calls needed drawing functions from PaintManager.

Thus if you wish to change the look of your report item, you must just provide your own implementation of PaintManager

See Also

CXTPPaintManager

Group

CXTPReportRow Methods


CXTPReportRow::DrawFixed Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::DrawFixed Method

Draws the row (of header/footer records) on the provided DC.

void DrawFixed(
    CDC* pDC,
    CRect rcRow,
    int nLeftOffset,
    CRect rcArea
);
Parameters

pDC
Pointer to control drawing context.
rcRow
Coordinates of the rectangle for drawing this row.
nLeftOffset
Start drawing left offset in pixels (Horizontal scroll position).
rcArea
Coordinates of the rectangle for drawing rows of header/footer records.

Remarks

Call this member function to draw an item. This function only prepares data for drawing and calls needed drawing functions from PaintManager.

Thus if you wish to change the look of your report item, you must just provide your own implementation of PaintManager

See Also

CXTPPaintManager

Group

CXTPReportRow Methods


CXTPReportRow::EnsureVisible Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::EnsureVisible Method

Call this member to force this row to be visible. This will cause the report control to scroll to this row. This is also called by CXTPReportControl::SetFocusedRow to make visible the newly focused row.

virtual void EnsureVisible();
Group

CXTPReportRow Methods


CXTPReportRow::FillMetrics Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::FillMetrics Method

Fill XTP_REPORTRECORDITEM_METRICS structure with drawing metrics

virtual void FillMetrics(
    CXTPReportColumn* pColumn,
    CXTPReportRecordItem* pItem,
    XTP_REPORTRECORDITEM_METRICS* pMetrics
);
Parameters

pColumn
Column of the item
pItem
Item to be draen
pMetrics
Output drawing metrics for the item

See Also

GetItemMetrics

Group

CXTPReportRow Methods


CXTPReportRow::GetChilds Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::GetChilds Method

Returns a collection of this row children.

virtual CXTPReportRows* GetChilds();
Returns

CXTPReportRows collection of row children.

Remarks

Call this member function to retrieve access to the collection of row children.

See Also

CXTPReportRows overview, GetParentRow, HasParent, GetTreeDepth, AddChild, HasChildren

Group

CXTPReportRow Methods


CXTPReportRow::GetControl Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRow::GetControl Method

Returns a pointer to the parent report control.

CXTPReportControl* GetControl() const;
Returns

A pointer to an associated report control object.

Remarks

Call this member function to retrieve a pointer to the CXTPReportControl which this item belongs to.

See Also

CXTPReportControl overview

Body Source
CXTPReportControl* CXTPReportRow::GetControl() const {
    return m_pControl;
}
Group

CXTPReportRow Methods


CXTPReportRow::GetGroupLevel Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source
CXTPReportRow::GetGroupLevel Method

Call this member to determine the row depth level when row is a group row.

virtual int GetGroupLevel() const;
Returns

Row depth level when row is a group row.

Body Source
int CXTPReportRow::GetGroupLevel() const {
    return m_nGroupLevel;
}
Group

CXTPReportRow Methods


CXTPReportRow::GetHeight Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::GetHeight Method

Calculates height of the row depending on the provided DC.

virtual int GetHeight(
    CDC* pDC,
    int nWidth
);
Parameters

pDC
Provided DC.
nWidth
Row width.

Returns

Returns height of the row in logical units.

Remarks

Row height depends of many factors: provided device context, font to print text, visibility of rows items. GetHeight() takes into account all of them to get real height of Row.

Group

CXTPReportRow Methods


CXTPReportRow::GetIndex Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::GetIndex Method

Returns current row index in the view.

virtual int GetIndex() const;
Returns

Current row index in the view.

Remarks

ReportControl draws row in some order. It depends of Index value You use GetIndex() to get current index value for particular row

Group

CXTPReportRow Methods


CXTPReportRow::GetItemMetrics Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::GetItemMetrics Method

Returns drawing metrics for the row.

virtual void GetItemMetrics(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pItemMetrics
);
Parameters

pDrawArgs
Pointer to the provided draw arguments structure for calculating metrics.
pItemMetrics
Pointer to the metrics structure to fill.

Remarks

Call this member function when you want to retrieve drawing metrics.

See Also

XTP_REPORTRECORDITEM_DRAWARGS, XTP_REPORTRECORDITEM_METRICS

Group

CXTPReportRow Methods


CXTPReportRow::GetItemRect Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::GetItemRect Method

Determines rectangle of specified item

virtual CRect GetItemRect(
    CXTPReportRecordItem* pItem
);
Parameters

pItem
Record Item

Returns

Rectangle of the item.

Group

CXTPReportRow Methods


CXTPReportRow::GetLastChildRow Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::GetLastChildRow Method

Get the latest row index from the group specified.

int GetLastChildRow(
    CXTPReportRows* pChilds
) const;
Parameters

pChilds
Children collection.

Returns

Last row index in group.

Group

CXTPReportRow Methods


CXTPReportRow::GetNextSiblingRow Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::GetNextSiblingRow Method

Returns the next sibling row of the current row.

virtual CXTPReportRow* GetNextSiblingRow() const;
Returns

Pointer to the next sibling row if any, or NULL otherwise.

Remarks

When report rows are arranged as a tree view, this member function returns a pointer to the next CXTPReportRow item.

See Also

HasParent, GetTreeDepth, GetChilds, AddChild, HasChildren

Group

CXTPReportRow Methods


CXTPReportRow::GetParentRow Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRow::GetParentRow Method

Returns the parent row of the current row.

virtual CXTPReportRow* GetParentRow() const;
Returns

Pointer to the parent row if any, or NULL otherwise.

Remarks

When report rows are arranged as a tree view, this member function returns a pointer to the parent CXTPReportRow item.

See Also

HasParent, GetTreeDepth, GetChilds, AddChild, HasChildren

Body Source
CXTPReportRow* CXTPReportRow::GetParentRow() const {
    return m_pParentRow;
}
Group

CXTPReportRow Methods


CXTPReportRow::GetParentRows Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRow::GetParentRows Method

Returns the parent rows of the current row.

virtual CXTPReportRows* GetParentRows() const;
Returns

Pointer to the parent rows if any, or NULL otherwise.

Remarks

When report rows are arranged as a tree view, this member function returns a pointer to the parent CXTPReportRows item.

See Also

HasParent, GetTreeDepth, GetChilds, AddChild, HasChildren

Body Source
CXTPReportRows* CXTPReportRow::GetParentRows() const {
    return m_pParentRows;
}
Group

CXTPReportRow Methods


CXTPReportRow::GetRecord Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRow::GetRecord Method

Get associated record.

virtual CXTPReportRecord* GetRecord() const;
Returns

Associated list record with data.

See Also

CXTPReportRecord overview

Example
CXTPReportRecord* pRecord = pRow->GetRecord();
Body Source
CXTPReportRecord* CXTPReportRow::GetRecord() const{
    return m_pRecord;
}
Group

CXTPReportRow Methods


CXTPReportRow::GetRect Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRow::GetRect Method

Returns coordinates of the row rectangle.

virtual CRect GetRect() const;
Returns

Coordinates of the row rectangle in report window client coordinates.

Remarks

Call this member function to determine the coordinates of the region where this row is drawn on the parent window.

See Also

SetCollapseRect

Body Source
CRect CXTPReportRow::GetRect() const {
    return m_rcRow;
}
Group

CXTPReportRow Methods


CXTPReportRow::GetTreeDepth Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::GetTreeDepth Method

Returns a depth of this row in tree view.

virtual int GetTreeDepth() const;
Returns

A depth of this row in tree view in levels.

Remarks

When report rows are arranged as a tree view, this member function returns a depth level of the row, which means the number of parent elements for the row..

See Also

GetParentRow, HasParent, GetChilds, AddChild, HasChildren

Group

CXTPReportRow Methods


CXTPReportRow::GetType Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source
CXTPReportRow::GetType Method

Call this member to determine the row type: body, header, or footer.

XTPReportRowType GetType() const;
Returns

A value of enum XTPReportRowType.

Body Source
XTPReportRowType CXTPReportRow::GetType() const {
    return m_nRowType;
}
Group

CXTPReportRow Methods


CXTPReportRow::HasChildren Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::HasChildren Method

Determines if a row has children in tree view.

virtual BOOL HasChildren() const;
Parameters

pRow
A row to check.

Returns

TRUE if the specified row has children rows, FALSE otherwise.

Remarks

When report rows are arranged as a tree view, this member function calculates whether this row has children rows or not.

See Also

HasParent, GetParentRow, GetTreeDepth, GetChilds, AddChild, HasChildren

Group

CXTPReportRow Methods


CXTPReportRow::HasParent Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::HasParent Method

Determines if a row has a parent in tree view.

virtual BOOL HasParent(
    CXTPReportRow* pRow
);
Parameters

pRow
A row to check.

Returns

TRUE if specified row has a parent, FALSE otherwise.

Remarks

When report rows are arranged as a tree view, this member function calculates whether this row has a parent row or not.

See Also

HasParent, GetParentRow, GetTreeDepth, GetChilds, AddChild, HasChildren

Group

CXTPReportRow Methods


CXTPReportRow::HitTest Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::HitTest Method

Determines which report item, if any, is at a specified position.

virtual CXTPReportRecordItem* HitTest(
    CPoint ptPoint,
    CRect* pRectItem = NULL,
    CXTPReportColumn** ppColumn = NULL
) const;
Parameters

ptPoint
Point to test.
pRectItem
Returns item rect.
ppColumn
Returns a pointer to the column at tested position.

Returns

The record item at the specified position, if any, or NULL otherwise.

Remarks

Call this member function to test a row contents at the specified position.

Group

CXTPReportRow Methods


InitRow Method

CXTPReportRow Methods
InitRow Method
Overload List
Methods
Method | Description
CXTPReportRow::InitRow (CXTPReportControl*, CXTPReportRecord*) | This method is called for initial initialization of the row.
CXTPReportRow::InitRow (CXTPReportRow*) | This method is called for initial initialization of the row.
Group

CXTPReportRow Methods


CXTPReportRow::InitRow Method (CXTPReportRow*)

InitRow Method, CXTPReportRow Class
CXTPReportRow::InitRow Method (CXTPReportRow*)

This method is called for initial initialization of the row.

virtual void InitRow(
    CXTPReportRow* pRow
);
virtual void InitRow(
    CXTPReportControl* pControl,
    CXTPReportRecord* pRecord
);
Parameters

pRow
Row which settings will be copied for the row.
pControl
Pointer to the parent report control.
pRecord
Pointer to the record associated with the row.

Group

InitRow Method


CXTPReportRow::IsExpanded Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::IsExpanded Method

Returns row expanded state.

virtual BOOL IsExpanded() const;
Returns

TRUE if row is expanded, FALSE otherwise.

Remarks

Call this member function if you want to determine whether this row is expanded in the report control or not.

See Also

SetExpanded

Group

CXTPReportRow Methods


CXTPReportRow::IsFocused Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::IsFocused Method

Returns row focused state.

virtual BOOL IsFocused() const;
Returns

TRUE if row is focused, FALSE otherwise.

Remarks

Call this member function if you want to determine whether this row is focused in the report control or not.

See Also

IsSelected

Group

CXTPReportRow Methods


CXTPReportRow::IsGroupRow Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::IsGroupRow Method

Determines if this row is a group row.

virtual BOOL IsGroupRow() const;
Returns

TRUE if it is a group row, FALSE otherwise.

Remarks

Call this member function if you want to determine whether this row is a group row or not.

Group

CXTPReportRow Methods


CXTPReportRow::IsItemsVisible Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::IsItemsVisible Method

Determines if items are visible

virtual BOOL IsItemsVisible() const;
Returns

TRUE if items are visible See Also IsPreviewVisible

Group

CXTPReportRow Methods


CXTPReportRow::IsLastTreeRow Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::IsLastTreeRow Method

Call this member to determine if the row is the last tree row. Or is not part of a tree row.

virtual BOOL IsLastTreeRow() const;
Returns

TRUE if the row is the last tree row. FALSE if the row is not part of a tree row or is not the last tree row.

Group

CXTPReportRow Methods


CXTPReportRow::IsPreviewVisible Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::IsPreviewVisible Method

Determines if preview item is visible.

virtual BOOL IsPreviewVisible() const;
Returns

TRUE if preview item is visible, FALSE otherwise.

Remarks

Call this member function to determine whether preview item for this row is visible or not.

See Also

CXTPReportRecordItemPreview overview, CXTPReportRecord::GetItemPreview

Group

CXTPReportRow Methods


CXTPReportRow::IsSelected Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::IsSelected Method

Returns row selected state.

virtual BOOL IsSelected() const;
Returns

TRUE if row is selected, FALSE otherwise.

Remarks

Call this member function if you want to determine whether this row is selected in the report control or not.

See Also

IsFocused

Group

CXTPReportRow Methods


CXTPReportRow::OnClick Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::OnClick Method

Process mouse clicks. Called by the framework when the user has clicked the mouse button in the row area.

virtual void OnClick(
    CPoint ptClicked
);
Parameters

ptClicked
Position of the cursor, in screen coordinates, at the time of the mouse click.

Remarks

Call this member function if you want a row to process a mouse button click message. You should provide the method with the coordinates of the mouse message to proceed.

See Also

OnDblClick, OnMouseMove, OnContextMenu

Group

CXTPReportRow Methods


CXTPReportRow::OnContextMenu Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::OnContextMenu Method

Process context menu. Called by the framework when the user has clicked the right mouse button (right clicked) in the window.

virtual void OnContextMenu(
    CPoint ptClick
);
Parameters

ptClick
Position of the cursor, in screen coordinates, at the time of the mouse click.

Remarks

Call this member function if you want a row to process a mouse right button down (context menu call) message. You should provide the method with the coordinates of the mouse message to proceed.

See Also

OnClick, OnDblClick, OnMouseMove

Group

CXTPReportRow Methods


CXTPReportRow::OnDblClick Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::OnDblClick Method

Process mouse double clicks. Called by the framework when the user has double-clicked the mouse button in the row area.

virtual void OnDblClick(
    CPoint ptClicked
);
Parameters

ptClicked
Position of the cursor, in screen coordinates, at the time of the mouse click.

Remarks

Call this member function if you want a row to process a mouse button double click message. You should provide the method with the coordinates of the mouse message to proceed.

See Also

OnClick, OnMouseMove, OnContextMenu

Group

CXTPReportRow Methods


CXTPReportRow::OnLButtonDown Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::OnLButtonDown Method

Processes mouse left button down clicks.

virtual BOOL OnLButtonDown(
    XTP_REPORTRECORDITEM_CLICKARGS* pClickArgs
);
Parameters

pClickArgs
structure which contains mouse click arguments

See Also

OnLButtonUp, OnClick

Group

CXTPReportRow Methods


CXTPReportRow::OnLButtonUp Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::OnLButtonUp Method

Processes mouse left button up clicks.

virtual BOOL OnLButtonUp(
    XTP_REPORTRECORDITEM_CLICKARGS* pClickArgs
);
Parameters

pClickArgs
structure which contains mouse click arguments

See Also

OnLButtonDown, OnClick

Group

CXTPReportRow Methods


CXTPReportRow::OnMouseMove Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::OnMouseMove Method

Process mouse moving.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down.
point
Point coordinates where the message was fired from.

Remarks

Call this member function if you want a row to process a mouse move message. You should provide the method with the coordinates of the mouse message to proceed and a flag showing which of virtual keys were down.

See Also

OnClick, OnDblClick, OnContextMenu

Group

CXTPReportRow Methods


CXTPReportRow::OnToolHitTest Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::OnToolHitTest Method

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

virtual INT_PTR OnToolHitTest(
    CPoint point,
    TOOLINFO* pTI
);
Parameters

point
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window
pTI
A pointer to a TOOLINFO structure.

Returns

If the tooltip control was found, the window control ID. If the tooltip control was not found, -1.

Group

CXTPReportRow Methods


CXTPReportRow::SelectChilds Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::SelectChilds Method

Call this member to select all child items of specified row.

virtual void SelectChilds();
Group

CXTPReportRow Methods


CXTPReportRow::SetCollapseRect Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRow::SetCollapseRect Method

Sets coordinates of the collapse/expand button for this row.

virtual void SetCollapseRect(
    CRect rcCollapse
);
Parameters

rcCollapse
The rectangle in report window client coordinates.

Remarks

Call this member function to setup the coordinates of the collapse/expand button for the row. Note that it could be different depending on the row tree depth.

See Also

GetTreeDepth, GetRect

Body Source
void CXTPReportRow::SetCollapseRect(CRect rcCollapse) {
    m_rcCollapse = rcCollapse;
}
Group

CXTPReportRow Methods


CXTPReportRow::SetExpanded Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::SetExpanded Method

Sets row expanded state.

virtual void SetExpanded(
    BOOL bExpanded
);
Parameters

bExpanded
New row expanded state.

Remarks

Call this member function if you want to expand or collapse this row.

See Also

IsExpanded

Group

CXTPReportRow Methods


CXTPReportRow::SetIndex Method

CXTPReportRow Methods, CXTPReportRow Class, Body Source
CXTPReportRow::SetIndex Method

Sets new row index in the view.

virtual void SetIndex(
    int nNewIndex
);
Parameters

nNewIndex
New row numeric index.

Remarks

Call this member function when you want to change the row position in the corresponding row collection.

Body Source
void CXTPReportRow::SetIndex(int nNewIndex) {
    m_nIndex = nNewIndex;
}
Group

CXTPReportRow Methods


CXTPReportRow::SetSelected Method

CXTPReportRow Methods, CXTPReportRow Class
CXTPReportRow::SetSelected Method

Call this member to select/set focus to the row. If multiple selection is enabled, then this row will be added to the selection.

virtual void SetSelected(
    BOOL bSelected
);
Parameters

bSelected
TRUE to select the row, FALSE to de-select the row.

Group

CXTPReportRow Methods


CXTPReportRow::ShiftTreeIndent Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::ShiftTreeIndent Method

This method is call to update rectangle of item

virtual void ShiftTreeIndent(
    CRect& rcItem,
    CXTPReportColumn* pColumn
) const;
Parameters

rcItem
Bounding Rectangle of item cell
pColumn
Column to test for tree column

See Also

CXTPReportColumn::IsTreeColumn

Group

CXTPReportRow Methods


CXTPReportRow::ShowToolTip Method

CXTPReportRow Methods, CXTPReportRow Class, See Also
CXTPReportRow::ShowToolTip Method

Shows a specified tooltip window at the specified position.

virtual void ShowToolTip(
    CPoint ptTip,
    CXTPReportTip* pTipWnd
);
Parameters

ptTip
A screen position to show tooltip at.
pTipWnd
Pointer to the specified tooltip window.

Remarks

Call this member function if you want to show a report tip window for this row.

See Also

CXTPReportTip overview

Group

CXTPReportRow Methods


CXTPReportRow Constructors

CXTPReportRow Class, Legend, Public Methods
CXTPReportRow Constructors
Class

CXTPReportRow Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRow | A constructor of the CXTPReportRow object.


CXTPReportRow::CXTPReportRow Constructor

CXTPReportRow Constructors, CXTPReportRow Class
CXTPReportRow::CXTPReportRow Constructor

A constructor of the CXTPReportRow object.

CXTPReportRow();
Group

CXTPReportRow Constructors


CXTPReportRow Destructors

CXTPReportRow Class, Legend, Public Methods
CXTPReportRow Destructors
Class

CXTPReportRow Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportRow | Destroys CXTPReportRow object, handles cleanup and deallocation.


CXTPReportRow::~CXTPReportRow Destructor

CXTPReportRow Destructors, CXTPReportRow Class
CXTPReportRow::~CXTPReportRow Destructor

Destroys CXTPReportRow object, handles cleanup and deallocation.

virtual ~CXTPReportRow();
Group

CXTPReportRow Destructors


CXTPReportRows Class

XTPReportRows.h, Classes, Legend, Members, Topics, CXTPReportRows Data Members, CXTPReportRows Methods, CXTPReportRows Constructors, CXTPReportRows Destructors, CXTPReportRows Nested Types, CXTPReportRows Constructors, CXTPReportRows Data Members, CXTPReportRows Destructors, Example, CXTPReportRows Methods, CXTPReportRows Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRows Class

This class represents a rows collection class. It supports an array of CXTPReportRow pointers.

Class Hierarchy

class CXTPReportRows : public CXTPHeapObjectT<CCmdTarget, CXTPReportDataAllocator>;
File

XTPReportRows.h

See Also

CXTPReportRow, CXTPReportSelectedRows

Example

See CXTPReportRows::Add for an example of how to work with this class.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportRows Constructors
CXTPReportRows Constructors | Description
CXTPReportRows | Constructs an empty CXTPReportRow pointer array.
CXTPReportRows Data Members
CXTPReportRows Data Members | Description
m_nVirtualRowsCount | Count of virtual rows.
m_pVirtualRow | Virtual row.
CXTPReportRows Destructors
CXTPReportRows Destructors | Description
~CXTPReportRows | Destroys CXTPReportRows object. Performs cleanup operations.
CXTPReportRows Methods
CXTPReportRows Methods | Description
Add | Adds a new Row element to the end of an array.
Clear | Removes all the elements from this array.
CompareRows | Compares 2 rows using groups and sort orders of the report control.
CompareRows2 | Compares 2 rows using groups and sort orders of the report control.
Find | Call this method to find row corresponded with specified record
FindInsertionPos | Call this method to find a position to insert a new row at. This function performs search in children too.
FindInTree | Call this method to find row corresponded with specified record. This function performs search in children too.
GetAt | Returns a row at the specified numeric index.
GetCount | Gets the number of CXTPReportRow elements in this collection.
GetNext | Returns next row in the list.
GetPrev | Returns previous row in the list.
InsertAt | Adds one more Row object to the collection at the specified position.
RefreshChildIndices | Recalculates child indices of all rows in the collection.
RemoveAt | Removes an item from the collection on specified position.
RemoveRow | Removes specified row from the collection.
SetVirtualMode | Call this method to set virtual mode with nCount rows.
Sort | Sorts collection elements.
SortEx | Sorts collection elements.
CXTPReportRows Nested Types
CXTPReportRows Nested Types | Description
T_CompareFunc | Define a function pointer for comparing events.


CXTPReportRows Data Members

CXTPReportRows Class, Legend, Protected Data Members
CXTPReportRows Data Members
Class

CXTPReportRows Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nVirtualRowsCount | Count of virtual rows.
m_pVirtualRow | Virtual row.


CXTPReportRows::m_nVirtualRowsCount Data Member

CXTPReportRows Data Members, CXTPReportRows Class
CXTPReportRows::m_nVirtualRowsCount Data Member

Count of virtual rows.

int m_nVirtualRowsCount;
Group

CXTPReportRows Data Members


CXTPReportRows::m_pVirtualRow Data Member

CXTPReportRows Data Members, CXTPReportRows Class
CXTPReportRows::m_pVirtualRow Data Member

Virtual row.

CXTPReportRow* m_pVirtualRow;
Group

CXTPReportRows Data Members


CXTPReportRows Methods

CXTPReportRows Class, Legend, Public Methods
CXTPReportRows Methods
Class

CXTPReportRows Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Add | Adds a new Row element to the end of an array.
Clear | Removes all the elements from this array.
CompareRows | Compares 2 rows using groups and sort orders of the report control.
CompareRows2 | Compares 2 rows using groups and sort orders of the report control.
Find | Call this method to find row corresponded with specified record
FindInsertionPos | Call this method to find a position to insert a new row at. This function performs search in children too.
FindInTree | Call this method to find row corresponded with specified record. This function performs search in children too.
GetAt | Returns a row at the specified numeric index.
GetCount | Gets the number of CXTPReportRow elements in this collection.
GetNext | Returns next row in the list.
GetPrev | Returns previous row in the list.
InsertAt | Adds one more Row object to the collection at the specified position.
RefreshChildIndices | Recalculates child indices of all rows in the collection.
RemoveAt | Removes an item from the collection on specified position.
RemoveRow | Removes specified row from the collection.
SetVirtualMode | Call this method to set virtual mode with nCount rows.
Sort | Sorts collection elements.
SortEx | Sorts collection elements.


CXTPReportRows::Add Method

CXTPReportRows Methods, CXTPReportRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRows::Add Method

Adds a new Row element to the end of an array.

virtual int Add(
    CXTPReportRow* pRow
);
Parameters

pRow
The row element to be added to this array.

Returns

The index of the added row.

Remarks

Use this method to add the specified CXTPReportRow pointer to the end of the CXTPReportRows collection.

See Also

CXTPReportRows overview, GetAt, InsertAt, Clear, GetNext, GetPrev, GetCount

Example
CXTPReportRows* pTree = new CXTPReportRows();
pTree->Add(new CXTPReportRow(pControl, pRecord1));
pTree->Add(new CXTPReportRow(pControl, pRecord2));
CXTPReportRow* pRow0 = pTree->GetAt(0);
CXTPReportRow* pRow1 = pTree->GetAt(1);
ASSERT(pRow0 == pTree->GetPrev(pRow1));
ASSERT(pRow1 == pTree->GetNext(pRow0));
pTree->RemoveAt(0);
ASSERT(1 == pTree->GetCount());
pTree->InsertAt(0, pRow0);
ASSERT(2 == pTree->GetCount());
pTree->Clear();
ASSERT(0 == pTree->GetCount());
Group

CXTPReportRows Methods


CXTPReportRows::Clear Method

CXTPReportRows Methods, CXTPReportRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRows::Clear Method

Removes all the elements from this array.

virtual void Clear(
    BOOL bResetRow = TRUE
);
Parameters

bResetRow
TRUE to remove visible flag of child rows.

Remarks

Removes all the pointers from this array and releases instances of all stored CXTPReportRow objects.

See Also

CXTPReportRows overview

Example

See example for CXTPReportRows::Add method.

Group

CXTPReportRows Methods


CXTPReportRows::CompareRows Method

CXTPReportRows Methods, CXTPReportRows Class, See Also
CXTPReportRows::CompareRows Method

Compares 2 rows using groups and sort orders of the report control.

static int _cdecl CompareRows(
    const CXTPReportRow** pRow1,
    const CXTPReportRow** pRow2
);
static int _cdecl CompareRows2(
    const CXTPReportRow** pRow1,
    const CXTPReportRow** pRow2
);
Parameters

pRow1
First row for comparison.
pRow2
Second row for comparison.

Returns

Zero if pRow1 is equal to pRow2; Less than zero if pRow1 is less than pRow2; Greater than zero if pRow1 is greater than pRow2.

Remarks

This function is called directly by Sort method.

The default implementation returns the result of the comparison of *pRow1 and *pRow2.

This implementation uses CXTPReportRecordItem::Compare for comparing two corresponding items from the row records. First it compares record items in the group order, then by sort order. It returns the first comparison result differ from equality. If no differences was found, it returns 0.

See Also

Sort, CXTPReportRecordItem::Compare

Group

CXTPReportRows Methods


CXTPReportRows::Find Method

CXTPReportRows Methods, CXTPReportRows Class
CXTPReportRows::Find Method

Call this method to find row corresponded with specified record

virtual CXTPReportRow* Find(
    CXTPReportRecord* pRecord
);
Parameters

pRecord
Record need to find.

Returns

A pointer to associated row object or NULL.

Group

CXTPReportRows Methods


CXTPReportRows::FindInsertionPos Method

CXTPReportRows Methods, CXTPReportRows Class
CXTPReportRows::FindInsertionPos Method

Call this method to find a position to insert a new row at. This function performs search in children too.

virtual CXTPReportRow* FindInsertionPos(
    CXTPReportRow* pRow,
    BOOL& bInsertAfter
);
Parameters

pRow
A row to insert.
bInsertAfter
the function sets it to TRUE if a row has to be inserted after the row found.

Returns

A pointer to the found row object or NULL.

Group

CXTPReportRows Methods


CXTPReportRows::FindInTree Method

CXTPReportRows Methods, CXTPReportRows Class
CXTPReportRows::FindInTree Method

Call this method to find row corresponded with specified record. This function performs search in children too.

virtual CXTPReportRow* FindInTree(
    CXTPReportRecord* pRecord
);
Parameters

pRecord
Record need to find.

Returns

A pointer to associated row object or NULL.

Group

CXTPReportRows Methods


CXTPReportRows::GetAt Method

CXTPReportRows Methods, CXTPReportRows Class, Example
CXTPReportRows::GetAt Method

Returns a row at the specified numeric index.

virtual CXTPReportRow* GetAt(
    int nIndex
) const;
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.

Returns

The row element currently at this index.

Remarks

Returns the array element at the specified index.

Example

See example for CXTPReportRows::Add method.

Group

CXTPReportRows Methods


CXTPReportRows::GetCount Method

CXTPReportRows Methods, CXTPReportRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRows::GetCount Method

Gets the number of CXTPReportRow elements in this collection.

int GetCount() const;
Returns

The number of items in the collection.

Remarks

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

See Also

CXTPReportRows overview

Example

See example for CXTPReportRows::Add method.

Group

CXTPReportRows Methods


CXTPReportRows::GetNext Method

CXTPReportRows Methods, CXTPReportRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRows::GetNext Method

Returns next row in the list.

virtual CXTPReportRow* GetNext(
    CXTPReportRow* pRow,
    BOOL bSkipGroupFocus
);
Parameters

pRow
A reference to the current element of the list.
bSkipGroupFocus
TRUE to skip all groups.

Returns

A pointer to a next element of the list.

Remarks

This function finds a pointer to the provided row element in the list, and returns a pointer to the elements following the found one.

See Also

GetPrev, CXTPReportControl::SkipGroupsFocus

Example

See example for CXTPReportRows::Add method.

Group

CXTPReportRows Methods


CXTPReportRows::GetPrev Method

CXTPReportRows Methods, CXTPReportRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportRows::GetPrev Method

Returns previous row in the list.

virtual CXTPReportRow* GetPrev(
    CXTPReportRow* pRow,
    BOOL bSkipGroupFocus
);
Parameters

pRow
A reference to the current element of the list.
bSkipGroupFocus
TRUE to skip all groups.

Returns

A pointer to a previous element of the list.

Remarks

This function finds a pointer to the provided row element in the list, and returns a pointer to the elements before the found one.

See Also

GetNext, CXTPReportControl::SkipGroupsFocus

Example

See example for CXTPReportRows::Add method.

Group

CXTPReportRows Methods


CXTPReportRows::InsertAt Method

CXTPReportRows Methods, CXTPReportRows Class, Example
CXTPReportRows::InsertAt Method

Adds one more Row object to the collection at the specified position.

virtual void InsertAt(
    int nIndex,
    CXTPReportRow* pRow
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
pRow
The row element to be placed in this array.

Remarks

InsertAt inserts one element at a specified index in an array. In the process, it shifts up (by incrementing the index) the existing element at this index, and it shifts up all the elements above it.

Example

See example for CXTPReportRows::Add method.

Group

CXTPReportRows Methods


CXTPReportRows::RefreshChildIndices Method

CXTPReportRows Methods, CXTPReportRows Class
CXTPReportRows::RefreshChildIndices Method

Recalculates child indices of all rows in the collection.

virtual void RefreshChildIndices(
    BOOL bRunInChildren = TRUE
);
Parameters

bRunInChildren
if TRUE, indices are refreshed in children also.

Group

CXTPReportRows Methods


CXTPReportRows::RemoveAt Method

CXTPReportRows Methods, CXTPReportRows Class, Example
CXTPReportRows::RemoveAt Method

Removes an item from the collection on specified position.

virtual void RemoveAt(
    int nIndex
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.

Remarks

In the process, it shifts down all the elements above the removed element. It decrements the upper bound of the array but does not free memory. It also releases an instance of the removed element.

Example

See example for CXTPReportRows::Add method.

Group

CXTPReportRows Methods


CXTPReportRows::RemoveRow Method

CXTPReportRows Methods, CXTPReportRows Class
CXTPReportRows::RemoveRow Method

Removes specified row from the collection.

virtual int RemoveRow(
    CXTPReportRow* pRow
);
Parameters

pRow
The row element to be removed.

Group

CXTPReportRows Methods


CXTPReportRows::SetVirtualMode Method

CXTPReportRows Methods, CXTPReportRows Class
CXTPReportRows::SetVirtualMode Method

Call this method to set virtual mode with nCount rows.

virtual void SetVirtualMode(
    CXTPReportRow* pRow,
    int nCount
);
Parameters

pRow
Virtual row
nCount
Count of virtual rows

Group

CXTPReportRows Methods


CXTPReportRows::SortEx Method

CXTPReportRows Methods, CXTPReportRows Class, See Also
CXTPReportRows::SortEx Method

Sorts collection elements.

virtual void SortEx(
    T_CompareFunc pCompareFunc
);
virtual void Sort();
Parameters

pCompareFunc
A T_CompareFunc function pointer that is used to compare rows.

Remarks

This method uses Visual C++ run-time library (MSVCRT) implementation of the quick-sort function, qsort, for sorting stored CXTPReportRow objects.

Sort() internally uses CompareRows method for comparing 2 rows.

See Also

CompareRows

Group

CXTPReportRows Methods


CXTPReportRows Constructors

CXTPReportRows Class, Legend, Public Methods
CXTPReportRows Constructors
Class

CXTPReportRows Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRows | Constructs an empty CXTPReportRow pointer array.


CXTPReportRows::CXTPReportRows Constructor

CXTPReportRows Constructors, CXTPReportRows Class, Example
CXTPReportRows::CXTPReportRows Constructor

Constructs an empty CXTPReportRow pointer array.

CXTPReportRows();
Example
// Declare a local CXTPReportRows object.
CXTPReportRows myList;

// Declare a dynamic CXTPReportRows object.
CXTPReportRows* pTree = new CXTPReportRows();
Group

CXTPReportRows Constructors


CXTPReportRows Destructors

CXTPReportRows Class, Legend, Public Methods
CXTPReportRows Destructors
Class

CXTPReportRows Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportRows | Destroys CXTPReportRows object. Performs cleanup operations.


CXTPReportRows::~CXTPReportRows Destructor

CXTPReportRows Destructors, CXTPReportRows Class
CXTPReportRows::~CXTPReportRows Destructor

Destroys CXTPReportRows object. Performs cleanup operations.

virtual ~CXTPReportRows();
Group

CXTPReportRows Destructors


CXTPReportRows Nested Types

CXTPReportRows Class, Public Nested Types
CXTPReportRows Nested Types
Class

CXTPReportRows Class

Public Nested Types
Public Nested Type | Description
T_CompareFunc | Define a function pointer for comparing events.


CXTPReportRows::T_CompareFunc Nested Type

CXTPReportRows Nested Types, CXTPReportRows Class, See Also
CXTPReportRows::T_CompareFunc Nested Type

Define a function pointer for comparing events.

typedef int (_cdecl * T_CompareFunc)(const CXTPReportRow** pRow1, const CXTPReportRow** pRow2);
Remarks

This function pointer is used in the SortEx method.

See Also

Sort, SortEx, CXTPReportControl::SetRowsCompareFunc

Group

CXTPReportRows Nested Types


CXTPReportSelectedRows Class

XTPReportRows.h, Classes, Legend, Members, Topics, CXTPReportSelectedRows Methods, CXTPReportSelectedRows Constructors, CXTPReportSelectedRows Constructors, Example, CXTPReportSelectedRows Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows Class

Encapsulates a collection of CXTPReportRow pointers that represent the selected rows in a Report Control.

Class Hierarchy

class CXTPReportSelectedRows;
File

XTPReportRows.h

Remarks

Use this class to programmatically manage a collection of CXTPReportRow pointers that represent the selected rows in a Report Control. This class is commonly used to add or remove rows from the collection.

Typical work flow is using Add and Remove methods for changing contents of the selection and using Contains method for checking a specific row for its presence in the selection.

See Also

CXTPReportRow, CXTPReportSelectedRows, CXTPReportControl::GetSelectedRows

Example

The following example demonstrates how to programmatically use the CXTPReportSelectedRows class to select rows in the Report control.

CXTPReportSelectedRows* pSelRows = pReportControl->GetSelectedRows();
pSelRows->Add(pRow1);
pSelRows->Add(pRow2);
ASSERT(TRUE == pSelRows->Contains(pRow1));
ASSERT(TRUE == pSelRows->Contains(pRow2));
pSelRows->Remove(pRow1);
ASSERT(FALSE == pSelRows->Contains(pRow1));
pSelRows->Select(pRow1);
ASSERT(TRUE == pSelRows->Contains(pRow1));
ASSERT(FALSE == pSelRows->Contains(pRow2));
Group

Classes

Legend
Method
CXTPReportSelectedRows Constructors
CXTPReportSelectedRows Constructors | Description
CXTPReportSelectedRows | Constructs an empty CXTPReportSelectedRows collection.
CXTPReportSelectedRows Methods
CXTPReportSelectedRows Methods | Description
Add | Adds a row to the selection.
AddBlock | Adds a rows to the selection.
Clear | Clears itself, removing selection.
Contains | Returns a value indicating whether the CXTPReportSelectedRows contains the specified CXTPReportRow pointer.
GetAt | Retrieves selected row by index.
GetCount | Gets the number of selected rows in the collection.
GetFirstSelectedRowPosition | Gets the position of the first selected row in the list report control.
GetNextSelectedRow | Gets next selected row in the list report control.
Invert | Inverts selection for the specified row.
IsChanged | Call this method to check if selection was changed.
Remove | Removes a row from the selection.
Select | Selects only the specified row.
SelectBlock | Selects a block of rows.
SetChanged | This method is called to reset changed flag.


CXTPReportSelectedRows Methods

CXTPReportSelectedRows Class, Legend, Public Methods
CXTPReportSelectedRows Methods
Class

CXTPReportSelectedRows Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add | Adds a row to the selection.
AddBlock | Adds a rows to the selection.
Clear | Clears itself, removing selection.
Contains | Returns a value indicating whether the CXTPReportSelectedRows contains the specified CXTPReportRow pointer.
GetAt | Retrieves selected row by index.
GetCount | Gets the number of selected rows in the collection.
GetFirstSelectedRowPosition | Gets the position of the first selected row in the list report control.
GetNextSelectedRow | Gets next selected row in the list report control.
Invert | Inverts selection for the specified row.
IsChanged | Call this method to check if selection was changed.
Remove | Removes a row from the selection.
Select | Selects only the specified row.
SelectBlock | Selects a block of rows.
SetChanged | This method is called to reset changed flag.


CXTPReportSelectedRows::Add Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::Add Method

Adds a row to the selection.

void Add(
    CXTPReportRow* pRow
);
Parameters

pRow
Pointer to the row to be added to the selection.

Remarks

This method adds a pointer to the provided row to the selection. After adding, Contains method will return TRUE for all checking attempts of this row pointer.

See Also

CXTPReportSelectedRows overview, Remove, Select, Clear, Contains

Example

See example at CXTPReportSelectedRows overview

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::AddBlock Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class
CXTPReportSelectedRows::AddBlock Method

Adds a rows to the selection.

void AddBlock(
    int nIndexBegin,
    int nIndexEnd
);
Parameters

nIndexBegin
First row index of block to be selected.
nIndexEnd
Last row index of block to be selected.

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::Clear Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class
CXTPReportSelectedRows::Clear Method

Clears itself, removing selection.

void Clear();
Remarks

Removes all the elements from the selection.

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::Contains Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::Contains Method

Returns a value indicating whether the CXTPReportSelectedRows contains the specified CXTPReportRow pointer.

BOOL Contains(
    const CXTPReportRow* pRow
);
Parameters

pRow
The CXTPReportRow pointer to search for in the CXTPReportSelectedRows.

Returns

TRUE if row is contained in the selection, FALSE otherwise.

Remarks

Use this method to determine whether the CXTPReportSelectedRows contains the specified CXTPReportRow pointer.

See Also

CXTPReportSelectedRows overview, Add, Remove, Select, Clear

Example

See example at CXTPReportSelectedRows overview

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::GetAt Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::GetAt Method

Retrieves selected row by index.

CXTPReportRow* GetAt(
    int nIndex
);
Parameters

nIndex
Index of selected row to retrieve.

Remarks

Recommended to use GetFirstSelectedRowPosition / GetNextSelectedRow methods.

See Also

GetFirstSelectedRowPosition, GetNextSelectedRow

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::GetCount Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::GetCount Method

Gets the number of selected rows in the collection.

int GetCount();
Returns

The number of items in the collection.

Remarks

Call this method to retrieve the number of selected rows in the array.

See Also

CXTPReportRows overview

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::GetFirstSelectedRowPosition Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::GetFirstSelectedRowPosition Method

Gets the position of the first selected row in the list report control.

POSITION GetFirstSelectedRowPosition();
Returns

value that can be used for iteration or object pointer retrieval; NULL if no items are selected.

See Also

GetNextSelectedItem

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::GetNextSelectedRow Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class
CXTPReportSelectedRows::GetNextSelectedRow Method

Gets next selected row in the list report control.

CXTPReportRow* GetNextSelectedRow(
    POSITION& pos
);
Parameters

pos
A reference to a POSITION value returned by a previous call to GetNextSelectedRow or GetFirstSelectedRowPosition. The value is updated to the next position by this call.

Returns

The pointer of the next selected row in the list report control.

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::Invert Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::Invert Method

Inverts selection for the specified row.

void Invert(
    CXTPReportRow* pRow
);
Parameters

pRow
Pointer to the specified row.

Remarks

This methods checks the specified method for its presence in the collection and adds or removes it in the reverse order depending on the result.

See Also

Add, Remove, Contains

Example
CXTPReportSelectedRows* pSelRows = pReportControl->GetSelectedRows();
ASSERT(TRUE == pSelRows->Contains(pRow1));
pSelRows->Invert(pRow1);
ASSERT(FALSE == pSelRows->Contains(pRow1));
pSelRows->Invert(pRow1);
ASSERT(TRUE == pSelRows->Contains(pRow1));
Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::IsChanged Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::IsChanged Method

Call this method to check if selection was changed.

BOOL IsChanged() const;
Body Source
BOOL CXTPReportSelectedRows::IsChanged() const {
    return m_bChanged;

}
Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::Remove Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::Remove Method

Removes a row from the selection.

void Remove(
    CXTPReportRow* pRow
);
Parameters

pRow
Pointer to the row to be removed from the selection.

Remarks

This method removes a provided row pointer from the selection. After removing, Contains method will return FALSE for all checking attempts of this row pointer.

See Also

CXTPReportSelectedRows overview, Add, Select, Clear, Contains

Example

See example at CXTPReportSelectedRows overview

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::Select Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::Select Method

Selects only the specified row.

void Select(
    CXTPReportRow* pRow
);
Parameters

pRow
Pointer to the specified row.

Remarks

This method clears the initial selection and selects only the specified row.

See Also

CXTPReportSelectedRows overview, Add, Remove, Contains, Clear

Example

See example at CXTPReportSelectedRows overview

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::SelectBlock Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class
CXTPReportSelectedRows::SelectBlock Method

Selects a block of rows.

void SelectBlock(
    int nBlockBegin,
    int nBlockEnd
);
Parameters

nBlockBegin
First row index from the block.
nBlockEnd
Final row index from the block.

Remarks

This function uses pRowBegin and pRowEnd as the bound for the required selection. It enumerates parent report control rows collection and adds all rows from pRowBegin to pRowEnd inclusively to the selection.

Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows::SetChanged Method

CXTPReportSelectedRows Methods, CXTPReportSelectedRows Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::SetChanged Method

This method is called to reset changed flag.

void SetChanged(
    BOOL bChanged = TRUE
);
Parameters

bChanged
TRUE to reset.

Body Source
void CXTPReportSelectedRows::SetChanged(BOOL bChanged /*= TRUE*/) {
    m_bChanged = bChanged;
}
Group

CXTPReportSelectedRows Methods


CXTPReportSelectedRows Constructors

CXTPReportSelectedRows Class, Legend, Public Methods
CXTPReportSelectedRows Constructors
Class

CXTPReportSelectedRows Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportSelectedRows | Constructs an empty CXTPReportSelectedRows collection.


CXTPReportSelectedRows::CXTPReportSelectedRows Constructor

CXTPReportSelectedRows Constructors, CXTPReportSelectedRows Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSelectedRows::CXTPReportSelectedRows Constructor

Constructs an empty CXTPReportSelectedRows collection.

CXTPReportSelectedRows(
    CXTPReportControl* pControl
);
Parameters

pControl
Pointer to the parent report control.

Remarks

This collection could be created only in association with the CXTPReportControl object.

See Also

CXTPReportSelectedRows overview

Example
// from CXTPReportControl member function
CXTPReportSelectedRows* pSelectedRows = new CXTPReportSelectedRows(this);
Group

CXTPReportSelectedRows Constructors


CXTPReportSubListControl Class

XTPReportSubListControl.h, Classes, Legend, Members, Topics, CXTPReportSubListControl Data Members, CXTPReportSubListControl Methods, CXTPReportSubListControl Constructors, CXTPReportSubListControl Destructors, CXTPReportSubListControl Constructors, CXTPReportSubListControl Data Members, CXTPReportSubListControl Destructors, Example, CXTPReportSubListControl Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl Class

Field chooser list box control. This control allows the user to move column names from associated CXTPReportControl object from and to its header.

Class Hierarchy

class CXTPReportSubListControl : public CListBox;
File

XTPReportSubListControl.h

Remarks

To use a field chooser in an existing dialog box of your application, add a standard list box to your dialog template using the dialog editor and then initialize your CXTPReportSubListControl object inside dialog OnInitialUpdate handler. See example below:

See Also

CDragListBox, CXTPReportControl, CXTPReportHeader, CXTPReportHeaderDragWnd, ReportControl sample application

Example
 // CXTPReportSubListControl m_wndSubList;
 wndSubList.SubclassDlgItem(IDC_COLUMNLIST, &pFieldChooserDialog);
 // CXTPReportControl wndReport;
 wndReport.GetReportHeader()->SetSubListCtrl(&wndSubList);
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportSubListControl Constructors
CXTPReportSubListControl Constructors | Description
CXTPReportSubListControl | Constructs a CXTPReportSubListControl object.
CXTPReportSubListControl Data Members
CXTPReportSubListControl Data Members | Description
m_bSortAscending | TRUE to sort items in list.
m_nDropIndex | Drop item index.
m_pDragWnd | Pointer to the associated dragging window.
m_pReportCtrl | Pointer to the parent report control.
m_rcDragWnd | Coordinates of the associated dragging window.
m_rcDropTarget1 | Contains first drop target - the list window itself.
m_rcDropTarget2 | Contains second drop target - report header.
CXTPReportSubListControl Destructors
CXTPReportSubListControl Destructors | Description
~CXTPReportSubListControl | Destroys CXTPReportSubListControl object, handles its cleanup.
CXTPReportSubListControl Methods
CXTPReportSubListControl Methods | Description
BeginDrag | Called by the framework when a drag operation starts.
CancelDrag | Called by the framework when a drag operation has been canceled.
Disable | Not used for the moment.
Dragging | Called by the framework when an item is being dragged within the CDragListBox object.
Dropped | Called by the framework when an item is dropped within a CDragListBox object.
FindItemData | Finds item index by its data.
GetItemCaption | Retrieves caption text by its index.
GetItemColumn | Retrieves column object by its index.
GetReportCtrl | Returns a pointer to the associated report control.
Include | Not used for the moment.
SetReportCtrl | Sets associated report control.
SortAscending | Call this member to use sorted list.
UpdateList | Updates columns list data in field chooser.


CXTPReportSubListControl Data Members

CXTPReportSubListControl Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl Data Members
Class

CXTPReportSubListControl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bSortAscending | TRUE to sort items in list.
m_nDropIndex | Drop item index.
m_pDragWnd | Pointer to the associated dragging window.
m_pReportCtrl | Pointer to the parent report control.
m_rcDragWnd | Coordinates of the associated dragging window.
m_rcDropTarget1 | Contains first drop target - the list window itself.
m_rcDropTarget2 | Contains second drop target - report header.


CXTPReportSubListControl::m_bSortAscending Data Member

CXTPReportSubListControl Data Members, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::m_bSortAscending Data Member

TRUE to sort items in list.

BOOL m_bSortAscending;
Group

CXTPReportSubListControl Data Members


CXTPReportSubListControl::m_nDropIndex Data Member

CXTPReportSubListControl Data Members, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::m_nDropIndex Data Member

Drop item index.

int m_nDropIndex;
Group

CXTPReportSubListControl Data Members


CXTPReportSubListControl::m_pDragWnd Data Member

CXTPReportSubListControl Data Members, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::m_pDragWnd Data Member

Pointer to the associated dragging window.

CXTPReportHeaderDragWnd* m_pDragWnd;
Group

CXTPReportSubListControl Data Members


CXTPReportSubListControl::m_pReportCtrl Data Member

CXTPReportSubListControl Data Members, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::m_pReportCtrl Data Member

Pointer to the parent report control.

CXTPReportControl* m_pReportCtrl;
Group

CXTPReportSubListControl Data Members


CXTPReportSubListControl::m_rcDragWnd Data Member

CXTPReportSubListControl Data Members, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::m_rcDragWnd Data Member

Coordinates of the associated dragging window.

CRect m_rcDragWnd;
Group

CXTPReportSubListControl Data Members


CXTPReportSubListControl::m_rcDropTarget1 Data Member

CXTPReportSubListControl Data Members, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::m_rcDropTarget1 Data Member

Contains first drop target - the list window itself.

CRect m_rcDropTarget1;
Group

CXTPReportSubListControl Data Members


CXTPReportSubListControl::m_rcDropTarget2 Data Member

CXTPReportSubListControl Data Members, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::m_rcDropTarget2 Data Member

Contains second drop target - report header.

CRect m_rcDropTarget2;
Group

CXTPReportSubListControl Data Members


CXTPReportSubListControl Methods

CXTPReportSubListControl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl Methods
Class

CXTPReportSubListControl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
BeginDrag | Called by the framework when a drag operation starts.
CancelDrag | Called by the framework when a drag operation has been canceled.
Dragging | Called by the framework when an item is being dragged within the CDragListBox object.
Dropped | Called by the framework when an item is dropped within a CDragListBox object.
FindItemData | Finds item index by its data.
Public Methods
Public Methods
Public Method | Description
Disable | Not used for the moment.
GetItemCaption | Retrieves caption text by its index.
GetItemColumn | Retrieves column object by its index.
GetReportCtrl | Returns a pointer to the associated report control.
Include | Not used for the moment.
SetReportCtrl | Sets associated report control.
SortAscending | Call this member to use sorted list.
UpdateList | Updates columns list data in field chooser.


CXTPReportSubListControl::BeginDrag Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::BeginDrag Method

Called by the framework when a drag operation starts.

BOOL BeginDrag(
    int nItem
);
Parameters

nItem
Item to begin drag

Returns

Nonzero if dragging is allowed, otherwise 0.

Remarks

Override this function if you want to control what happens when a drag operation begins. This implementation captures the mouse, creates CXTPReportHeaderDragWnd and stays in drag mode until the user clicks the left or right mouse button or presses ESC, at which time the drag operation is canceled.

See Also

CDragListBox::BeginDrag

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::CancelDrag Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::CancelDrag Method

Called by the framework when a drag operation has been canceled.

void CancelDrag();
Remarks

Destroys dragging CXTPReportHeaderDragWnd window and resets associated report control mouse mode.

See Also

CDragListBox::CancelDrag

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::Disable Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::Disable Method

Not used for the moment.

virtual BOOL Disable(
    int iSubItem
);
Parameters

iSubItem
Sub-item number for disabling.

Returns

Non-zero when completed successfully, zero otherwise.

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::Dragging Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::Dragging Method

Called by the framework when an item is being dragged within the CDragListBox object.

UINT Dragging(
    CPoint pt
);
Parameters

pt
A CPoint object that contains the x and y screen coordinates of the cursor.

Returns

The resource ID of the cursor to be displayed. The following values are possible:

  • DL_COPYCURSOR Indicates that the item will be copied.
  • DL_MOVECURSOR Indicates that the item will be moved.
  • DL_STOPCURSOR Indicates that the current drop target is not acceptable.
Remarks

This implementation allows dropping items only on the control itself and associated report control header. Override this function if you want to provide additional functionality.

See Also

CDragListBox::Dragging

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::Dropped Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::Dropped Method

Called by the framework when an item is dropped within a CDragListBox object.

void Dropped(
    CPoint pt
);
Parameters

pt
A CPoint object that contains the coordinates of the drop site.

Remarks

Destroys dragging CXTPReportHeaderDragWnd window and returns the control to the caller.

See Also

CDragListBox::Dropped

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::FindItemData Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::FindItemData Method

Finds item index by its data.

int FindItemData(
    int nItemData
);
Parameters

nItemData
Item data for search.

Returns

Found item index, -1 if item was not found.

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::GetItemCaption Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::GetItemCaption Method

Retrieves caption text by its index.

CString GetItemCaption(
    int nIndex
);
Parameters

nIndex
Index of item to retrieve.

Returns

Caption of the item.

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::GetItemColumn Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::GetItemColumn Method

Retrieves column object by its index.

CXTPReportColumn* GetItemColumn(
    int nIndex
);
Parameters

nIndex
Index of item to retrieve.

Returns

CXTPReportColumn* object of the item.

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::GetReportCtrl Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::GetReportCtrl Method

Returns a pointer to the associated report control.

CXTPReportControl* GetReportCtrl();
Returns

An associated report control.

See Also

CXTPReportHeader::SetSubListCtrl, SetReportCtrl

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::Include Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::Include Method

Not used for the moment.

virtual BOOL Include(
    int iSubItem
);
Parameters

iSubItem
Sub-item number for including.

Returns

Non-zero when completed successfully, zero otherwise.

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::SetReportCtrl Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::SetReportCtrl Method

Sets associated report control.

BOOL SetReportCtrl(
    CXTPReportControl* pReportCtrl
);
Parameters

pReportCtrl
Pointer to the associated report control.

Returns

TRUE if set successfully, FALSE otherwise.

Remarks

Usually this method should not be called by user, instead you should call CXTPReportHeader::SetSubListCtrl.

See Also

CXTPReportHeader::SetSubListCtrl, GetReportCtrl

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::SortAscending Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::SortAscending Method

Call this member to use sorted list.

void SortAscending(
    BOOL bSort
);
Parameters

bSort
TRUE to sort columns in list.

Group

CXTPReportSubListControl Methods


CXTPReportSubListControl::UpdateList Method

CXTPReportSubListControl Methods, CXTPReportSubListControl Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::UpdateList Method

Updates columns list data in field chooser.

BOOL UpdateList();
Returns

TRUE when updated successfully, FALSE otherwise.

Remarks

Reloads column list from the associated CXTPReportControl object, deletes all visible column items from the internal list, and adds the rest of invisible items.

Example
wndSubList.UpdateList();
Group

CXTPReportSubListControl Methods


CXTPReportSubListControl Constructors

CXTPReportSubListControl Class, Legend, Public Methods
CXTPReportSubListControl Constructors
Class

CXTPReportSubListControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportSubListControl | Constructs a CXTPReportSubListControl object.


CXTPReportSubListControl::CXTPReportSubListControl Constructor

CXTPReportSubListControl Constructors, CXTPReportSubListControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::CXTPReportSubListControl Constructor

Constructs a CXTPReportSubListControl object.

CXTPReportSubListControl();
Remarks

You construct a CXTPReportSubListControl object in two steps. First, call the constructor CXTPReportSubListControl and then call CListBox::Create, which initializes the Windows list box and attaches it to the CXTPReportSubListControl.

See Also

CListBox, CXTPReportSubListControl::SetReportCtrl, CXTPReportHeader::SetSubListCtrl

Example
// Declare a local CXTPReportSubListControl object.
CXTPReportSubListControl mySubList;

// Declare a dynamic CXTPReportSubListControl object.
CXTPReportSubListControl* pMySubList = new CXTPReportSubListControl;
Group

CXTPReportSubListControl Constructors


CXTPReportSubListControl Destructors

CXTPReportSubListControl Class, Legend, Public Methods
CXTPReportSubListControl Destructors
Class

CXTPReportSubListControl Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportSubListControl | Destroys CXTPReportSubListControl object, handles its cleanup.


CXTPReportSubListControl::~CXTPReportSubListControl Destructor

CXTPReportSubListControl Destructors, CXTPReportSubListControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportSubListControl::~CXTPReportSubListControl Destructor

Destroys CXTPReportSubListControl object, handles its cleanup.

~CXTPReportSubListControl();
Group

CXTPReportSubListControl Destructors


CXTPReportTip Class

XTPReportTip.h, Classes, Legend, Members, Topics, CXTPReportTip Data Members, CXTPReportTip Methods, CXTPReportTip Constructors, CXTPReportTip Destructors, CXTPReportTip Constructors, CXTPReportTip Data Members, CXTPReportTip Destructors, CXTPReportTip Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportTip Class

The CXTPReportTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.

Class Hierarchy

class CXTPReportTip : public CWnd;
File

XTPReportTip.h

Remarks

CXTPReportTip provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip.

This class is used by the report control internally.

See Also

CXTPReportControl, CXTPReportRow::ShowToolTip

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportTip Constructors
CXTPReportTip Constructors | Description
CXTPReportTip | Constructs a CXTPReportTip object.
CXTPReportTip Data Members
CXTPReportTip Data Members | Description
m_bMultiline | Multiline tooltip flag.
m_fntToolTip | Font for displaying tooltip text.
m_nRowIndex | Index of item's row.
m_pItem | Item which tooltip is visible.
m_pParentWnd | Pointer to the parent report window.
m_rcHover | Hover window coordinates.
m_strTooltipText | Tooltip text to display.
CXTPReportTip Destructors
CXTPReportTip Destructors | Description
~CXTPReportTip | Destroys a CXTPReportTip object, handles cleanup and deallocation
CXTPReportTip Methods
CXTPReportTip Methods | Description
Activate | Call this function to activate or deactivate a tool tip control.
Create | Creates report tip window.
GetHoverRect | Returns the coordinates of the tooltip hover rectangle.
GetTooltipText | Returns tooltip text string.
SetFont | Sets tooltip text displaying font.
SetHoverRect | Sets coordinates of the tooltip hover rectangle.
SetTooltipText | Sets new tooltip text to show.


CXTPReportTip Data Members

CXTPReportTip Class, Legend, Protected Data Members
CXTPReportTip Data Members
Class

CXTPReportTip Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bMultiline | Multiline tooltip flag.
m_fntToolTip | Font for displaying tooltip text.
m_nRowIndex | Index of item's row.
m_pItem | Item which tooltip is visible.
m_pParentWnd | Pointer to the parent report window.
m_rcHover | Hover window coordinates.
m_strTooltipText | Tooltip text to display.


CXTPReportTip::m_bMultiline Data Member

CXTPReportTip Data Members, CXTPReportTip Class
CXTPReportTip::m_bMultiline Data Member

Multiline tooltip flag.

BOOL m_bMultiline;
Group

CXTPReportTip Data Members


CXTPReportTip::m_fntToolTip Data Member

CXTPReportTip Data Members, CXTPReportTip Class
CXTPReportTip::m_fntToolTip Data Member

Font for displaying tooltip text.

CFont m_fntToolTip;
Group

CXTPReportTip Data Members


CXTPReportTip::m_nRowIndex Data Member

CXTPReportTip Data Members, CXTPReportTip Class
CXTPReportTip::m_nRowIndex Data Member

Index of item's row.

int m_nRowIndex;
Group

CXTPReportTip Data Members


CXTPReportTip::m_pItem Data Member

CXTPReportTip Data Members, CXTPReportTip Class
CXTPReportTip::m_pItem Data Member

Item which tooltip is visible.

CXTPReportRecordItem* m_pItem;
Group

CXTPReportTip Data Members


CXTPReportTip::m_pParentWnd Data Member

CXTPReportTip Data Members, CXTPReportTip Class
CXTPReportTip::m_pParentWnd Data Member

Pointer to the parent report window.

CWnd * m_pParentWnd;
Group

CXTPReportTip Data Members


CXTPReportTip::m_rcHover Data Member

CXTPReportTip Data Members, CXTPReportTip Class
CXTPReportTip::m_rcHover Data Member

Hover window coordinates.

CRect m_rcHover;
Group

CXTPReportTip Data Members


CXTPReportTip::m_strTooltipText Data Member

CXTPReportTip Data Members, CXTPReportTip Class
CXTPReportTip::m_strTooltipText Data Member

Tooltip text to display.

CString m_strTooltipText;
Group

CXTPReportTip Data Members


CXTPReportTip Methods

CXTPReportTip Class, Legend, Public Methods
CXTPReportTip Methods
Class

CXTPReportTip Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Activate | Call this function to activate or deactivate a tool tip control.
Create | Creates report tip window.
GetHoverRect | Returns the coordinates of the tooltip hover rectangle.
GetTooltipText | Returns tooltip text string.
SetFont | Sets tooltip text displaying font.
SetHoverRect | Sets coordinates of the tooltip hover rectangle.
SetTooltipText | Sets new tooltip text to show.


CXTPReportTip::Activate Method

CXTPReportTip Methods, CXTPReportTip Class, See Also
CXTPReportTip::Activate Method

Call this function to activate or deactivate a tool tip control.

void Activate(
    BOOL bActive,
    BOOL bMultiline
);
Parameters

bActive
Specifies whether the tool tip control is to be activated or deactivated.
bMultiline
Specifies whether the tool tip is to be multiline.

Remarks

If bActivate is TRUE, the control is activated; if FALSE, it is deactivated.

When a tool tip control is active, the tool tip information appears when the cursor is on a tool that is registered with the control; when it is inactive, the tool tip information does not appear, even when the cursor is on a tool.

See Also

Create, CXTPReportTip::CXTPReportTip, SetTooltipText

Group

CXTPReportTip Methods


CXTPReportTip::Create Method

CXTPReportTip Methods, CXTPReportTip Class, See Also
CXTPReportTip::Create Method

Creates report tip window.

virtual BOOL Create(
    CWnd* pParentWnd
);
Parameters

pParentWnd
Parent report control window.

Returns

TRUE if the tip window was created successfully, FALSE otherwise.

Remarks

You construct an object in two steps. First, call the constructor object and then call Create, which initializes the window and attaches it to the parent window.

See Also

CXTPReportTip::CXTPReportTip, Activate

Group

CXTPReportTip Methods


CXTPReportTip::GetHoverRect Method

CXTPReportTip Methods, CXTPReportTip Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportTip::GetHoverRect Method

Returns the coordinates of the tooltip hover rectangle.

CRect GetHoverRect() const;
Returns

Coordinates of the tooltip hover rectangle in parent window coordinates.

See Also

SetHoverRect

Body Source
CRect CXTPReportTip::GetHoverRect() const {
    return m_rcHover;
}
Group

CXTPReportTip Methods


CXTPReportTip::GetTooltipText Method

CXTPReportTip Methods, CXTPReportTip Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportTip::GetTooltipText Method

Returns tooltip text string.

CString GetTooltipText() const;
Returns

Current tooltip text.

See Also

SetTooltipText

Body Source
CString CXTPReportTip::GetTooltipText() const{
    return m_strTooltipText;
}
Group

CXTPReportTip Methods


CXTPReportTip::SetFont Method

CXTPReportTip Methods, CXTPReportTip Class, Body Source
CXTPReportTip::SetFont Method

Sets tooltip text displaying font.

void SetFont(
    CFont* pFont
);
Parameters

pFont
Pointer to the new font object.

Body Source
void CXTPReportTip::SetFont(CFont* pFont) {
    m_fntToolTip.DeleteObject();
    LOGFONT lf;
    pFont->GetLogFont(&lf);
    m_fntToolTip.CreateFontIndirect(&lf);
}
Group

CXTPReportTip Methods


CXTPReportTip::SetHoverRect Method

CXTPReportTip Methods, CXTPReportTip Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportTip::SetHoverRect Method

Sets coordinates of the tooltip hover rectangle.

void SetHoverRect(
    CRect rc
);
Parameters

rc
New tooltip hover rectangle in parent window coordinates.

Remarks

Should be called before activating the tooltip window.

See Also

GetHoverRect

Body Source
void CXTPReportTip::SetHoverRect(CRect rc) {
    m_rcHover = rc;
    MoveWindow(rc);
}
Group

CXTPReportTip Methods


CXTPReportTip::SetTooltipText Method

CXTPReportTip Methods, CXTPReportTip Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportTip::SetTooltipText Method

Sets new tooltip text to show.

void SetTooltipText(
    LPCTSTR str
);
Parameters

str
A string with the new tooltip caption.

Remarks

Should be called before activating the tooltip window.

See Also

GetTooltipText

Body Source
void CXTPReportTip::SetTooltipText(LPCTSTR str) {
    m_strTooltipText = str;
}
Group

CXTPReportTip Methods


CXTPReportTip Constructors

CXTPReportTip Class, Legend, Public Methods
CXTPReportTip Constructors
Class

CXTPReportTip Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportTip | Constructs a CXTPReportTip object.


CXTPReportTip::CXTPReportTip Constructor

CXTPReportTip Constructors, CXTPReportTip Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportTip::CXTPReportTip Constructor

Constructs a CXTPReportTip object.

CXTPReportTip();
Remarks

You construct a object object in two steps. First, call the constructor object and then call Create, which initializes the window and attaches it to the parent window.

See Also

CWnd, Create, Activate, CXTPReportRow::ShowToolTip

Example
// Declare a local CXTPReportTip object.
CXTPReportTip wndTip;

// Declare a dynamic CXTPReportTip object.
CXTPReportTip* pTipWnd = new CXTPReportTip;
Group

CXTPReportTip Constructors


CXTPReportTip Destructors

CXTPReportTip Class, Legend, Public Methods
CXTPReportTip Destructors
Class

CXTPReportTip Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPReportTip | Destroys a CXTPReportTip object, handles cleanup and deallocation


CXTPReportTip::~CXTPReportTip Destructor

CXTPReportTip Destructors, CXTPReportTip Class
CXTPReportTip::~CXTPReportTip Destructor

Destroys a CXTPReportTip object, handles cleanup and deallocation

virtual ~CXTPReportTip();
Group

CXTPReportTip Destructors


CXTPReportView Class

XTPReportView.h, Classes, Legend, Members, Topics, CXTPReportView Data Members, CXTPReportView Methods, CXTPReportView Constructors, CXTPReportView Destructors, CXTPReportView Constructors, CXTPReportView Data Members, CXTPReportView Destructors, CXTPReportView Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportView Class

The CXTPReportView class provides an implementation of the Report control as view class. Use GetReportCtrl method to access methods of CXTPReportControl

Class Hierarchy

class CXTPReportView : public CView;
File

XTPReportView.h

See Also

CXTPReportControl

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPReportView Constructors
CXTPReportView Constructors | Description
CXTPReportView | Protected constructor used by dynamic creation
CXTPReportView Data Members
CXTPReportView Data Members | Description
m_aPageStart | Printed indexes.
m_bAllowCut | If TRUE the cut operation is allowed.
m_bAllowPaste | If TRUE the paste operation is allowed.
m_bmpGrayDC | A temporary bitmap to convert colored report control image to 'gray' colors when printing in black&while mode.
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bPrintSelection | TRUE if only printing the currently selected rows in the report, FALSE if printing the entire report,
m_bResizeControlWithView | if FALSE - attached Report control will not be resized with view.
m_pPrintOptions | Printing options.
m_pReport | Child report control pointer.
m_pScrollBar | Store pointer to external scrollbar control.
m_wndReport | Child report control window.
CXTPReportView Destructors
CXTPReportView Destructors | Description
~CXTPReportView | Destroys a CXTPReportView object, handles cleanup and deallocation.
CXTPReportView Methods
CXTPReportView Methods | Description
GetColumnWidth | This method calculates width of column need to print.
GetPaintManager | Retrieved paint manager of the child report control.
GetPrintOptions | Call this method to access print options for this view.
GetReportCtrl | Call this method to access Report control object.
PrintFixedRows | This method prints either header or footer rows.
PrintFixedRowsDivider | This method prints either header or footer divider.
PrintFooter | This method is called to print footer of each page.
PrintHeader | This method is called to print header of each page.
PrintPage | This method is called to print single page of report control.
PrintReport | This method is called to print report control (columns header and rows) on the page.
PrintRow | This method is called by PrintRows to print single row.
PrintRows | This method is called to draw all rows inside bounding rectangle.
SetReportCtrl | Call this method to set custom Report control object.
SetScrollBarCtrl | Use this member function to set external scroll bar control.


CXTPReportView Data Members

CXTPReportView Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportView Data Members
Class

CXTPReportView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_aPageStart | Printed indexes.
m_bmpGrayDC | A temporary bitmap to convert colored report control image to 'gray' colors when printing in black&while mode.
m_bPrintSelection | TRUE if only printing the currently selected rows in the report, FALSE if printing the entire report,
m_pPrintOptions | Printing options.
m_pReport | Child report control pointer.
m_pScrollBar | Store pointer to external scrollbar control.
m_wndReport | Child report control window.
Public Data Members
Public Data Member | Description
m_bAllowCut | If TRUE the cut operation is allowed.
m_bAllowPaste | If TRUE the paste operation is allowed.
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bResizeControlWithView | if FALSE - attached Report control will not be resized with view.


CXTPReportView::m_aPageStart Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_aPageStart Data Member

Printed indexes.

CUIntArray m_aPageStart;
Group

CXTPReportView Data Members


CXTPReportView::m_bAllowCut Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_bAllowCut Data Member

If TRUE the cut operation is allowed.

BOOL m_bAllowCut;
Group

CXTPReportView Data Members


CXTPReportView::m_bAllowPaste Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_bAllowPaste Data Member

If TRUE the paste operation is allowed.

BOOL m_bAllowPaste;
Group

CXTPReportView Data Members


CXTPReportView::m_bmpGrayDC Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_bmpGrayDC Data Member

A temporary bitmap to convert colored report control image to 'gray' colors when printing in black&while mode.

CBitmap m_bmpGrayDC;
Group

CXTPReportView Data Members


CXTPReportView::m_bPrintDirect Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_bPrintDirect Data Member

if TRUE - the Print Dialog is bypassed.

BOOL m_bPrintDirect;
Group

CXTPReportView Data Members


CXTPReportView::m_bPrintSelection Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_bPrintSelection Data Member

TRUE if only printing the currently selected rows in the report, FALSE if printing the entire report,

BOOL m_bPrintSelection;
Group

CXTPReportView Data Members


CXTPReportView::m_bResizeControlWithView Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_bResizeControlWithView Data Member

if FALSE - attached Report control will not be resized with view.

BOOL m_bResizeControlWithView;
Group

CXTPReportView Data Members


CXTPReportView::m_pPrintOptions Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_pPrintOptions Data Member

Printing options.

CXTPReportViewPrintOptions* m_pPrintOptions;
Group

CXTPReportView Data Members


CXTPReportView::m_pReport Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_pReport Data Member

Child report control pointer.

CXTPReportControl* m_pReport;
Group

CXTPReportView Data Members


CXTPReportView::m_pScrollBar Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_pScrollBar Data Member

Store pointer to external scrollbar control.

CScrollBar* m_pScrollBar;
Group

CXTPReportView Data Members


CXTPReportView::m_wndReport Data Member

CXTPReportView Data Members, CXTPReportView Class
CXTPReportView::m_wndReport Data Member

Child report control window.

CXTPReportControl m_wndReport;
Group

CXTPReportView Data Members


CXTPReportView Methods

CXTPReportView Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportView Methods
Class

CXTPReportView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetColumnWidth | This method calculates width of column need to print.
PrintFixedRows | This method prints either header or footer rows.
PrintFixedRowsDivider | This method prints either header or footer divider.
PrintFooter | This method is called to print footer of each page.
PrintHeader | This method is called to print header of each page.
PrintPage | This method is called to print single page of report control.
PrintReport | This method is called to print report control (columns header and rows) on the page.
PrintRow | This method is called by PrintRows to print single row.
PrintRows | This method is called to draw all rows inside bounding rectangle.
SetScrollBarCtrl | Use this member function to set external scroll bar control.
Public Methods
Public Methods
Public Method | Description
GetPaintManager | Retrieved paint manager of the child report control.
GetPrintOptions | Call this method to access print options for this view.
GetReportCtrl | Call this method to access Report control object.
SetReportCtrl | Call this method to set custom Report control object.


CXTPReportView::GetColumnWidth Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::GetColumnWidth Method

This method calculates width of column need to print.

int GetColumnWidth(
    CXTPReportColumn* pColumn,
    int nTotalWidth
);
Parameters

pColumn
Column need to print
nTotalWidth
Total width of all columns.

Returns

Width of column.

Group

CXTPReportView Methods


CXTPReportView::GetPaintManager Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::GetPaintManager Method

Retrieved paint manager of the child report control.

CXTPReportPaintManager* GetPaintManager() const;
Returns

Pointer to paint manager of report control.

Group

CXTPReportView Methods


CXTPReportView::GetPrintOptions Method

CXTPReportView Methods, CXTPReportView Class, Body Source
CXTPReportView::GetPrintOptions Method

Call this method to access print options for this view.

CXTPReportViewPrintOptions* GetPrintOptions();
Returns

Pointer to an object describing print options of this view.

Body Source
CXTPReportViewPrintOptions* CXTPReportView::GetPrintOptions() {
    return m_pPrintOptions;
}
Group

CXTPReportView Methods


CXTPReportView::GetReportCtrl Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::GetReportCtrl Method

Call this method to access Report control object.

virtual CXTPReportControl& GetReportCtrl() const;
Returns

Reference to child CXTPReportControl window

Group

CXTPReportView Methods


CXTPReportView::PrintFixedRows Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::PrintFixedRows Method

This method prints either header or footer rows.

int PrintFixedRows(
    CDC* pDC,
    CRect rcClient,
    BOOL bHeaderRows
);
Parameters

pDC
Pointer to a device context for page output.
rcClient
Bounding rectangle of fixed rows
bHeaderRows
If TRUE, prints the header rows.

Returns

Height of printed rows.

Group

CXTPReportView Methods


CXTPReportView::PrintFixedRowsDivider Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::PrintFixedRowsDivider Method

This method prints either header or footer divider.

int PrintFixedRowsDivider(
    CDC* pDC,
    const CRect& rc,
    BOOL bHeaderRows
);
Parameters

pDC
Pointer to a device context for page output.
rc
Bounding rectangle of the divider.
bHeaderRows
If TRUE, prints the header divider.

Returns

Height of printed rows.

Group

CXTPReportView Methods


CXTPReportView::PrintFooter Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::PrintFooter Method

This method is called to print footer of each page.

virtual void PrintFooter(
    CDC* pDC,
    CRect rcFooter
);
Parameters

pDC
Pointer to a device context for page output.
rcFooter
Header bounding rectangle

Group

CXTPReportView Methods


CXTPReportView::PrintHeader Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::PrintHeader Method

This method is called to print header of each page.

virtual void PrintHeader(
    CDC* pDC,
    CRect rcHeader
);
Parameters

pDC
Pointer to a device context for page output.
rcHeader
Header bounding rectangle

Group

CXTPReportView Methods


CXTPReportView::PrintPage Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::PrintPage Method

This method is called to print single page of report control.

virtual long PrintPage(
    CDC* pDC,
    CPrintInfo* pInfo,
    CRect rcPage,
    long nIndexStart
);
Parameters

pDC
Pointer to a device context for page output.
pInfo
Points to a CPrintInfo structure that describes the current print job.
rcPage
Page bounding rectangle
nIndexStart
First row to print

Returns

Index of last printed row

Remarks

This method prints page header, page footer and call PrintReport method.

Group

CXTPReportView Methods


CXTPReportView::PrintReport Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::PrintReport Method

This method is called to print report control (columns header and rows) on the page.

virtual long PrintReport(
    CDC* pDC,
    CPrintInfo* pInfo,
    CRect rcPage,
    long nIndexStart
);
Parameters

pDC
Pointer to a device context for page output.
pInfo
Points to a CPrintInfo structure that describes the current print job.
rcPage
Report bounding rectangle on the page
nIndexStart
First row to print

Returns

Index of last printed row

Remarks

This method call PrintHeader, PrintRows methods.

Group

CXTPReportView Methods


CXTPReportView::PrintRow Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::PrintRow Method

This method is called by PrintRows to print single row.

virtual void PrintRow(
    CDC* pDC,
    CXTPReportRow* pRow,
    CRect rcRow,
    int nPreviewHeight
);
Parameters

pDC
Pointer to a device context for page output.
pRow
Row to print.
rcRow
Bounding rectangle of row
nPreviewHeight
Height of preview

Group

CXTPReportView Methods


CXTPReportView::PrintRows Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::PrintRows Method

This method is called to draw all rows inside bounding rectangle.

virtual int PrintRows(
    CDC* pDC,
    CRect rcRows,
    long nIndexStart,
    int* pPrintedRowsHeight = NULL
);
Parameters

pDC
Pointer to a device context for page output.
rcRows
Bounding rectangle of rows
nIndexStart
First row to print
pnPrintedRowsHeight
Height of the printed rows.

Returns

Index of last printed row

Group

CXTPReportView Methods


CXTPReportView::SetReportCtrl Method

CXTPReportView Methods, CXTPReportView Class
CXTPReportView::SetReportCtrl Method

Call this method to set custom Report control object.

void SetReportCtrl(
    CXTPReportControl* pReport
);
Parameters

pReport
Pointer to custom report object

Group

CXTPReportView Methods


CXTPReportView::SetScrollBarCtrl Method

CXTPReportView Methods, CXTPReportView Class, See Also
CXTPReportView::SetScrollBarCtrl Method

Use this member function to set external scroll bar control.

void SetScrollBarCtrl(
    CScrollBar* pScrollBar
);
Parameters

pScrollBar
Pointer to a scrollbar object.

See Also

CScrollBar

Group

CXTPReportView Methods


CXTPReportView Constructors

CXTPReportView Class, Legend, Protected Methods
CXTPReportView Constructors
Class

CXTPReportView Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPReportView | Protected constructor used by dynamic creation


CXTPReportView::CXTPReportView Constructor

CXTPReportView Constructors, CXTPReportView Class
CXTPReportView::CXTPReportView Constructor

Protected constructor used by dynamic creation

CXTPReportView();
Group

CXTPReportView Constructors


CXTPReportView Destructors

CXTPReportView Class, Legend, Protected Methods
CXTPReportView Destructors
Class

CXTPReportView Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPReportView | Destroys a CXTPReportView object, handles cleanup and deallocation.


CXTPReportView::~CXTPReportView Destructor

CXTPReportView Destructors, CXTPReportView Class
CXTPReportView::~CXTPReportView Destructor

Destroys a CXTPReportView object, handles cleanup and deallocation.

virtual ~CXTPReportView();
Group

CXTPReportView Destructors


CXTPReportViewPrintOptions Class

XTPReportView.h, Classes, Legend, Members, Topics, CXTPReportViewPrintOptions Data Members, CXTPReportViewPrintOptions Methods, CXTPReportViewPrintOptions Constructors, CXTPReportViewPrintOptions Constructors, CXTPReportViewPrintOptions Data Members, CXTPReportViewPrintOptions Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportViewPrintOptions Class

This class used to store printing options.

Class Hierarchy

class CXTPReportViewPrintOptions : public CXTPPrintOptions;
File

XTPReportView.h

See Also

CXTPPrintOptions, CXTPPrintPageHeaderFooter

Group

Classes

Legend
Data Member
Method
virtual
CXTPReportViewPrintOptions Constructors
CXTPReportViewPrintOptions Constructors | Description
CXTPReportViewPrintOptions | Default Object constructor.
CXTPReportViewPrintOptions Data Members
CXTPReportViewPrintOptions Data Members | Description
m_bRepeatFooterRows | If TRUE - the footer rows will be printed on every page.
m_bRepeatHeaderRows | If TRUE - the header rows will be printed on every page.
CXTPReportViewPrintOptions Methods
CXTPReportViewPrintOptions Methods | Description
GetActiveLCID | Override this member function in derived class to specify active locale ID.
Set | Call this member function to copy members from specified source object.


CXTPReportViewPrintOptions Data Members

CXTPReportViewPrintOptions Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportViewPrintOptions Data Members
Class

CXTPReportViewPrintOptions Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bRepeatFooterRows | If TRUE - the footer rows will be printed on every page.
m_bRepeatHeaderRows | If TRUE - the header rows will be printed on every page.


CXTPReportViewPrintOptions::m_bRepeatFooterRows Data Member

CXTPReportViewPrintOptions Data Members, CXTPReportViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportViewPrintOptions::m_bRepeatFooterRows Data Member

If TRUE - the footer rows will be printed on every page.

BOOL m_bRepeatFooterRows;
Group

CXTPReportViewPrintOptions Data Members


CXTPReportViewPrintOptions::m_bRepeatHeaderRows Data Member

CXTPReportViewPrintOptions Data Members, CXTPReportViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportViewPrintOptions::m_bRepeatHeaderRows Data Member

If TRUE - the header rows will be printed on every page.

BOOL m_bRepeatHeaderRows;
Group

CXTPReportViewPrintOptions Data Members


CXTPReportViewPrintOptions Methods

CXTPReportViewPrintOptions Class, Legend, Public Methods
CXTPReportViewPrintOptions Methods
Class

CXTPReportViewPrintOptions Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetActiveLCID | Override this member function in derived class to specify active locale ID.
Set | Call this member function to copy members from specified source object.


CXTPReportViewPrintOptions::GetActiveLCID Method

CXTPReportViewPrintOptions Methods, CXTPReportViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportViewPrintOptions::GetActiveLCID Method

Override this member function in derived class to specify active locale ID.

virtual LCID GetActiveLCID();
Returns

Locale ID. Base implementation returns LOCALE_USER_DEFAULT;

Group

CXTPReportViewPrintOptions Methods


CXTPReportViewPrintOptions::Set Method

CXTPReportViewPrintOptions Methods, CXTPReportViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportViewPrintOptions::Set Method

Call this member function to copy members from specified source object.

virtual void Set(
    const CXTPReportViewPrintOptions* pSrc
);
Parameters

pSrc
A pointer to source object to copy data.

Group

CXTPReportViewPrintOptions Methods


CXTPReportViewPrintOptions Constructors

CXTPReportViewPrintOptions Class, Legend, Public Methods
CXTPReportViewPrintOptions Constructors
Class

CXTPReportViewPrintOptions Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportViewPrintOptions | Default Object constructor.


CXTPReportViewPrintOptions::CXTPReportViewPrintOptions Constructor

CXTPReportViewPrintOptions Constructors, CXTPReportViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPReportViewPrintOptions::CXTPReportViewPrintOptions Constructor

Default Object constructor.

CXTPReportViewPrintOptions();
Group

CXTPReportViewPrintOptions Constructors


Structs, Records, Enums

Enumerations, Legend, Report Control, Structures
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPReportColumnBestFitMode | This enum defines the best fit mode.
XTPReportColumnIconAlignment | This enum defines alignment style for the column icon and text.
XTPReportColumnStyle | Represents predefined column styles.
XTPReportDragDrop | Enumeration of drag and drop flags
XTPReportElementRect | Enumeration of GetElementRect flags
XTPReportFixedRowsDividerStyle | Represent the Header/Footer rows devider style.
XTPReportFreezeColsDividerStyle | Represents predefined freeze column line styles:
XTPReportGridStyle | Represents predefined grid line styles:
XTPReportGroupRowIconAlignment | This enum defines alignment style for the group row custom icon.
XTPReportMouseMode | Enumeration of operational mouse modes.
XTPReportRowType | This enum defines body, header, and footer rows.
XTPReportSelectionChangeType | This enum defines selection change action.
XTPReportTreeStructureStyle | Represent the style of lines used to draw a hierarchical tree structure.
XTPReportVirtualRowFlags | This enum defines flags for virtual row metrics.
XTPReportWatermarkAlignment | Enumeration of watermark alignment flags
Module

Report Control

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_NM_REPORT_BEFORE_COPYPASTE | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window.
XTP_NM_REPORTCOLUMNRESIZE | This structure is sent to Main window in a WM_NOTIFY message after column is resized.
XTP_NM_REPORTCONSTRAINTSELECTING | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTDRAGDROP | This structure is sent to main window in a WM_NOTIFY message from from report control to determine Records was dragged or dropped
XTP_NM_REPORTINPLACEBUTTON | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTITEMMETRICS | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTPREVIEWKEYDOWN | This structure is sent to Main window in a WM_NOTIFY message before processing OnKeyDown event.
XTP_NM_REPORTRECORDITEM | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTREQUESTEDIT | A set of parameters transferred with XTP_NM_REPORT_REQUESTEDIT message
XTP_NM_REPORTTOOLTIPINFO | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_SELECTION_CHANGING | This struct defines data for XTP_NM_REPORT_SELCHANGING notification.
XTP_REPORTRECORDITEM_ARGS | Basic set of parameters transferred to item handlers. This structure groups together essential parameters used in items processing activities. It is parent for all other structures: XTP_REPORTRECORDITEM_DRAWARGS, XTP_REPORTRECORDITEM_CLICKARGS
XTP_REPORTRECORDITEM_CLICKARGS | A set of parameters transferred to mouse click item handlers. It inherits essential parameters from XTP_REPORTRECORDITEM_ARGS.
XTP_REPORTRECORDITEM_DRAWARGS | A set of parameters transferred to Draw item handler. It inherits essential parameters from XTP_REPORTRECORDITEM_ARGS.
XTP_REPORTRECORDITEM_METRICS | Record item drawing metrics. Its helper structures group together parameters to store general drawing metrics


XTP_NM_REPORT_BEFORE_COPYPASTE Structure

XTPReportRecordItem.h, Structs, Records, Enums, See Also
XTP_NM_REPORT_BEFORE_COPYPASTE Structure

This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window.

struct XTP_NM_REPORT_BEFORE_COPYPASTE {
  NMHDR hdr;
  CXTPReportRecord** ppRecord;
  CStringArray* parStrings;
};
File

XTPReportRecordItem.h

Members

hdr
Standard structure, containing information about a notification message.
ppRecord
in/out] A pointer to record pointer;
parStrings
in/out] A pointer to strings array with record items values.

Remarks

It is sent before clipboard Copy/Paste operations.

See Also

XTP_NM_REPORT_BEFORE_COPY_TOTEXT, XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT, XTP_NM_REPORT_BEFORE_PASTE, CXTPReportControl::OnBeforeCopyToText(), CXTPReportControl::OnBeforePasteFromText(), CXTPReportControl::OnBeforePaste().

Group

Structs, Records, Enums


XTP_NM_REPORTCOLUMNRESIZE Structure

XTPReportHeader.h, Structs, Records, Enums, See Also
XTP_NM_REPORTCOLUMNRESIZE Structure

This structure is sent to Main window in a WM_NOTIFY message after column is resized.

struct XTP_NM_REPORTCOLUMNRESIZE {
  NMHDR hdr;
  CXTPReportColumn* pColumn;
  int nPrevWidth;
  int nNewWidth;
};
File

XTPReportHeader.h

Members

hdr
Standard structure, containing information about a notification message.
pColumn
Resized column.
nPrevWidth
Previous width.
nNewWidth
New width.

See Also

CXTPReportHeader::ResizeColumn, CXTPReportHeader::AdjustColumnsWidth, XTP_NM_REPORT_COLUMNWIDTHCHANGED.

Group

Structs, Records, Enums


XTP_NM_REPORTCONSTRAINTSELECTING Structure

XTPReportRecordItem.h, Structs, Records, Enums, See Also
XTP_NM_REPORTCONSTRAINTSELECTING Structure

This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window

struct XTP_NM_REPORTCONSTRAINTSELECTING : public XTP_NM_REPORTRECORDITEM {
  CXTPReportRecordItemConstraint* pConstraint;
};
File

XTPReportRecordItem.h

Members

pConstraint
Pointer to the constraint associated with the notification.

Remarks

Use this structure to notify about constraint changing.

See Also

XTP_NM_REPORTCONSTRAINTSELECTING

Group

Structs, Records, Enums


XTP_NM_REPORTDRAGDROP Structure

XTPReportControl.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_NM_REPORTDRAGDROP Structure

This structure is sent to main window in a WM_NOTIFY message from from report control to determine Records was dragged or dropped

struct XTP_NM_REPORTDRAGDROP {
  NMHDR hdr;
  CXTPReportRecords* pRecords;
  CXTPReportRecord* pTargetRecord;
  BOOL bAbove;
  DROPEFFECT dropEffect;
  CPoint pt;
  int nState;
};
File

XTPReportControl.h

Members

hdr
Standard structure, containing information about a notification message.
pRecords
Records will be dragged/dropped
pTargetRecord
Target record (if any)
bAbove
Where to insert (relative to the target record)
dropEffect
The DropEffect flags.
pt
The current location of the cursor in client coordinates.
nState
The transition state (0 - enter, 1 - leave, 2 - over).

See Also

XTP_NM_REPORT_DROP, XTP_NM_REPORT_BEGINDRAG, CXTPReportControl::EnableDragDrop

Example
BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_BEGINDRAG, XTP_ID_REPORT_CONTROL, OnReportBeginDrag)
END_MESSAGE_MAP()

void CReportSampleView::OnReportBeginDrag(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTDRAGDROP* pItemNotify = (XTP_NM_REPORTDRAGDROP*)pNotifyStruct;

    ASSERT(pItemNotify->pRecords);
}
Group

Structs, Records, Enums


XTP_NM_REPORTINPLACEBUTTON Structure

XTPReportRecordItem.h, Structs, Records, Enums, See Also
XTP_NM_REPORTINPLACEBUTTON Structure

This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window

struct XTP_NM_REPORTINPLACEBUTTON : public XTP_NM_REPORTRECORDITEM {
  CXTPReportInplaceButton* pButton;
};
File

XTPReportRecordItem.h

Members

pButton
Pointer to in-place button

Remarks

Use this structure to get in-place button which produce XTP_NM_REPORT_INPLACEBUTTONDOWN message.

See Also

XTP_NM_REPORT_INPLACEBUTTONDOWN

Group

Structs, Records, Enums


XTP_NM_REPORTITEMMETRICS Structure

XTPReportControl.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_NM_REPORTITEMMETRICS Structure

This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window

struct XTP_NM_REPORTITEMMETRICS {
  NMHDR hdr;
  XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs;
  XTP_REPORTRECORDITEM_METRICS* pItemMetrics;
};
File

XTPReportControl.h

Members

hdr
Standard structure, containing information about a notification message.
pDrawArgs
Pointer to XTP_REPORTRECORDITEM_DRAWARGS structure.
pItemMetrics
Pointer to XTP_REPORTRECORDITEM_METRICS structure to be filled.

See Also

CXTPReportControl, CXTPReportControl::GetItemMetrics(), XTP_NM_REPORT_GETITEMMETRICS

Example
BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_GETITEMMETRICS, XTP_ID_REPORT_CONTROL, OnReportGetItemMetrics)
END_MESSAGE_MAP()

void CReportSampleView::OnReportGetItemMetrics(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTITEMMETRICS* pItemNotify = (XTP_NM_REPORTITEMMETRICS*)pNotifyStruct;

    ASSERT(pItemNotify->pDrawArgs);
    ASSERT(pItemNotify->pDrawArgs->pControl);
    ASSERT(pItemNotify->pDrawArgs->pRow);

    //     pItemNotify->pDrawArgs->pColumn   - may be NULL (for a group row)
    //     pItemNotify->pDrawArgs->pItem     - may be NULL (for a group row)

    ASSERT(pItemNotify->pItemMetrics);

    // TODO: customize members of pItemNotify->pItemMetrics.
}
Group

Structs, Records, Enums


XTP_NM_REPORTPREVIEWKEYDOWN Structure

XTPReportControl.h, Structs, Records, Enums, See Also
XTP_NM_REPORTPREVIEWKEYDOWN Structure

This structure is sent to Main window in a WM_NOTIFY message before processing OnKeyDown event.

struct XTP_NM_REPORTPREVIEWKEYDOWN {
  NMHDR hdr;
  UINT nChar;
  UINT nRepCnt;
  UINT nFlags;
  BOOL bCancel;
};
File

XTPReportControl.h

Members

hdr
Standard structure, containing information about a notification message.
nChar
in/out] Specifies the virtual key code of the given key.
nRepCnt
in] Repeat count.
nFlags
in] Specifies the scan code, key-transition code, previous key state, and context code.
bCancel
out] TRUE to cancel processing key, FALSE to continue.

See Also

CXTPReportControl::OnPreviewKeyDown, XTP_NM_REPORT_PREVIEWKEYDOWN, CXTPReportControl::OnKeyDown, CWnd::OnKeyDown.

Group

Structs, Records, Enums


XTP_NM_REPORTRECORDITEM Structure

XTPReportRecordItem.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_NM_REPORTRECORDITEM Structure

This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window

struct XTP_NM_REPORTRECORDITEM {
  NMHDR hdr;
  CXTPReportRow* pRow;
  CXTPReportRecordItem* pItem;
  CXTPReportColumn* pColumn;
  int nHyperlink;
  POINT pt;
};
File

XTPReportRecordItem.h

Members

hdr
Standard structure, containing information about a notification message.
pRow
Pointer to the row associated with the notification.
pItem
Pointer to the record item associated with the notification.
pColumn
Pointer to the column associated with the notification.
nHyperlink
Index of clicked Hyperlink, if any, or -1 otherwise.
pt
Point where the message has happened.

See Also

XTP_NM_REPORTINPLACEBUTTON

Example
BEGIN_MESSAGE_MAP(CPropertiesView, CView)
    ON_NOTIFY(XTP_NM_REPORT_VALUECHANGED, ID_REPORT_CONTROL, OnPropertyChanged)
END_MESSAGE_MAP()

void CPropertiesView::OnPropertyChanged(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;

    switch (pItemNotify->pItem->GetItemData())
    {
        // Some code.
    }
}
Group

Structs, Records, Enums


XTP_NM_REPORTREQUESTEDIT Structure

XTPReportRecordItem.h, Structs, Records, Enums, See Also
XTP_NM_REPORTREQUESTEDIT Structure

A set of parameters transferred with XTP_NM_REPORT_REQUESTEDIT message

struct XTP_NM_REPORTREQUESTEDIT : public XTP_NM_REPORTRECORDITEM {
};
File

XTPReportRecordItem.h

Remarks

XTP_NM_REPORTREQUESTEDIT is used to cancel edit operations

See Also

XTP_NM_REPORT_REQUESTEDIT

Group

Structs, Records, Enums


XTP_NM_REPORTTOOLTIPINFO Structure

XTPReportRecordItem.h, Structs, Records, Enums, See Also
XTP_NM_REPORTTOOLTIPINFO Structure

This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window

struct XTP_NM_REPORTTOOLTIPINFO : public XTP_NM_REPORTRECORDITEM {
  CString* pstrText;
};
File

XTPReportRecordItem.h

Members

pstrText
Pointer to a CString object with Tooltip text.

Remarks

Use this structure to notify about tooltip showing.

See Also

XTP_NM_REPORTTOOLTIPTEXT

Group

Structs, Records, Enums


XTP_NM_SELECTION_CHANGING Structure

XTPReportRows.h, Structs, Records, Enums, See Also
XTP_NM_SELECTION_CHANGING Structure

This struct defines data for XTP_NM_REPORT_SELCHANGING notification.

struct XTP_NM_SELECTION_CHANGING {
  NMHDR hdr;
  CXTPReportRow* pRow;
  XTPReportSelectionChangeType nType;
};
File

XTPReportRows.h

Members

hdr
Standard structure, containing information about a notification message.
pRow
Pointer to the row associated with the notification.
nType
Selection change action.

See Also

XTP_NM_REPORT_SELCHANGING, XTP_NM_SELECTION_CHANGING

Group

Structs, Records, Enums


XTP_REPORTRECORDITEM_ARGS Structure

XTPReportRecordItem.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_REPORTRECORDITEM_ARGS Structure

Basic set of parameters transferred to item handlers. This structure groups together essential parameters used in items processing activities. It is parent for all other structures: XTP_REPORTRECORDITEM_DRAWARGS, XTP_REPORTRECORDITEM_CLICKARGS

struct XTP_REPORTRECORDITEM_ARGS {
  CXTPReportControl* pControl;
  CXTPReportRow* pRow;
  CXTPReportColumn* pColumn;
  CXTPReportRecordItem* pItem;
  CRect rcItem;
};
File

XTPReportRecordItem.h

Members

pControl
Pointer to the main Report control.
pRow
Pointer to the associated row.
pColumn
Report column at click position, if any, NULL otherwise.
pItem
Pointer to the associated item.
rcItem
Item position in control client coordinates.

See Also

CXTPReportRecordItem::OnBeginEdit

Example
XTP_REPORTRECORDITEM_ARGS itemArgs(pControl, pRow, pColumn);
pItem->OnBeginEdit(&itemArgs);
Group

Structs, Records, Enums


XTP_REPORTRECORDITEM_CLICKARGS Structure

XTPReportRecordItem.h, Structs, Records, Enums, See Also
XTP_REPORTRECORDITEM_CLICKARGS Structure

A set of parameters transferred to mouse click item handlers. It inherits essential parameters from XTP_REPORTRECORDITEM_ARGS.

struct XTP_REPORTRECORDITEM_CLICKARGS : public XTP_REPORTRECORDITEM_ARGS {
  CPoint ptClient;
};
File

XTPReportRecordItem.h

Members

ptClient
Coordinates of the mouse click point.

Remarks

XTP_REPORTRECORDITEM_CLICKARGS is used in most functions involved in mouse events processing

See Also

CXTPReportControl, CXTPReportRecordItem::OnClick

Group

Structs, Records, Enums


XTP_REPORTRECORDITEM_DRAWARGS Structure

XTPReportRecordItem.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_REPORTRECORDITEM_DRAWARGS Structure

A set of parameters transferred to Draw item handler. It inherits essential parameters from XTP_REPORTRECORDITEM_ARGS.

struct XTP_REPORTRECORDITEM_DRAWARGS : public XTP_REPORTRECORDITEM_ARGS {
  CDC* pDC;
  int nTextAlign;
};
File

XTPReportRecordItem.h

Members

pDC
Pointer to control drawing context.
nTextAlign
Text alignment mode DT_LEFT || DT_RIGHT || DT_CENTER

Remarks

This structure is used in almost all functions concerning drawing activities

See Also

CXTPReportPaintManager

Example
// fill structure
XTP_REPORTRECORDITEM_DRAWARGS drawArgs;
drawArgs.pDC = pDC;
drawArgs.pControl = m_pControl;
drawArgs.pRow = pRow;
// call function
pItem->Draw(&drawArgs);
Group

Structs, Records, Enums


XTP_REPORTRECORDITEM_METRICS Structure

XTPReportRecordItem.h, Structs, Records, Enums
XTP_REPORTRECORDITEM_METRICS Structure

Record item drawing metrics. Its helper structures group together parameters to store general drawing metrics

struct XTP_REPORTRECORDITEM_METRICS {
  CFont* pFont;
  COLORREF clrForeground;
  COLORREF clrBackground;
  CString strText;
  int nGroupRowIcon;
  int nGroupRowIconAlignment;
  int nColumnAlignment;
  int nItemIcon;
  int nVirtRowLevel;
  int nVirtRowFlags;
};
File

XTPReportRecordItem.h

Members

pFont
Drawing font.
clrForeground
Item foreground color.
clrBackground
Item background color.
strText
Item text.
nGroupRowIcon
Group row icon ID.
nGroupRowIconAlignment
Group row icon alignment.
nColumnAlignment
Column alignment.
nItemIcon
Item icon ID.
nVirtRowLevel
Virtual row level.
nVirtRowFlags
Virtual row flags.

Group

Structs, Records, Enums


XTPReportColumnBestFitMode Enumeration

XTPReportColumn.h, Structs, Records, Enums
XTPReportColumnBestFitMode Enumeration

This enum defines the best fit mode.

enum XTPReportColumnBestFitMode {
  xtpColumnBestFitModeVisibleData = 0,
  xtpColumnBestFitModeAllData = 1
};
File

XTPReportColumn.h

Members

xtpColumnBestFitModeVisibleData
Fit by visible column data.
xtpColumnBestFitModeAllData
Fit by all column data.

Group

Structs, Records, Enums


XTPReportColumnIconAlignment Enumeration

XTPReportRecordItem.h, Structs, Records, Enums
XTPReportColumnIconAlignment Enumeration

This enum defines alignment style for the column icon and text.

enum XTPReportColumnIconAlignment {
  xtpColumnTextLeft = DT_LEFT,
  xtpColumnTextCenter = DT_CENTER,
  xtpColumnTextRight = DT_RIGHT,
  xtpColumnTextVCenter = DT_VCENTER,
  xtpColumnTextWordBreak = DT_WORDBREAK,
  xtpColumnTextMask = 0xFF,
  xtpColumnIconLeft = 0x00100000,
  xtpColumnIconCenter = 0x00200000,
  xtpColumnIconRight = 0x00400000,
  xtpColumnIconTop = 0x01000000,
  xtpColumnIconVCenter = 0x02000000,
  xtpColumnIconBottom = 0x04000000,
  xtpColumnIconMask = 0x0FF00000
};
File

XTPReportRecordItem.h

Members

xtpColumnTextLeft
Aligns text to the left.
xtpColumnTextCenter
Centers text horizontally in the column.
xtpColumnTextRight
Aligns text to the right.
xtpColumnTextVCenter
Centers text vertically.
xtpColumnTextWordBreak
Breaks words.
xtpColumnTextMask
A mask for text alignment styles.
xtpColumnIconLeft
Aligns icon to the left.
xtpColumnIconCenter
Centers icon horizontally in the column.
xtpColumnIconRight
Aligns icon to the right.
xtpColumnIconTop
Aligns icon to the top.
xtpColumnIconVCenter
Aligns icon to the center.
xtpColumnIconBottom
Aligns icon to the bottom.
xtpColumnIconMask
A mask for icon alignment styles.

Group

Structs, Records, Enums


XTPReportColumnStyle Enumeration

XTPReportPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPReportColumnStyle Enumeration

Represents predefined column styles.

enum XTPReportColumnStyle {
  xtpReportColumnShaded,
  xtpReportColumnFlat,
  xtpReportColumnExplorer,
  xtpReportColumnOffice2003,
  xtpReportColumnOffice2007
};
File

XTPReportPaintManager.h

Members

xtpReportColumnShaded
Columns are gray shaded.
xtpReportColumnFlat
Flat style for drawing columns.
xtpReportColumnExplorer
Explorer column style
xtpReportColumnOffice2003
Gradient column style
xtpReportColumnOffice2007
Office 2007 column style

See Also

CXTPReportPaintManager::m_columnStyle, CXTPReportPaintManager

Example
m_wndReport.GetPaintManager()->m_columnStyle = xtpReportColumnFlat;
Group

Structs, Records, Enums


XTPReportDragDrop Enumeration

XTPReportControl.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPReportDragDrop Enumeration

Enumeration of drag and drop flags

enum XTPReportDragDrop {
  xtpReportAllowDrop = 1,
  xtpReportAllowDragCopy = 2,
  xtpReportAllowDragMove = 4,
  xtpReportAllowDrag = 6
};
File

XTPReportControl.h

Members

xtpReportAllowDrop
Allow Drop records to report
xtpReportAllowDragCopy
Allow copy records from report
xtpReportAllowDragMove
Allow move records from report
xtpReportAllowDrag
Allow copy and move records from report

Remarks

Call CXTPReportControl::EnableDragDrop to allow drag/drop operations

See Also

CXTPReportControl::EnableDragDrop

Example
m_wndReport.EnableDragDrop("MyApplication", xtpReportAllowDrop | xtpReportAllowDrag);
Group

Structs, Records, Enums


XTPReportElementRect Enumeration

XTPReportControl.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPReportElementRect Enumeration

Enumeration of GetElementRect flags

enum XTPReportElementRect {
  xtpReportElementRectReportArea = 0,
  xtpReportElementRectGroupByArea,
  xtpReportElementRectHeaderArea,
  xtpReportElementRectFooterArea,
  xtpReportElementRectHeaderRecordsArea,
  xtpReportElementRectFooterRecordsArea,
  xtpReportElementRectHeaderRecordsDividerArea,
  xtpReportElementRectFooterRecordsDividerArea
};
File

XTPReportControl.h

Members

xtpReportElementRectReportArea
report area rectangle
xtpReportElementRectGroupByArea
report area rectangle
xtpReportElementRectHeaderArea
report area rectangle
xtpReportElementRectFooterArea
report area rectangle
xtpReportElementRectHeaderRecordsArea
report area rectangle
xtpReportElementRectFooterRecordsArea
report area rectangle
xtpReportElementRectHeaderRecordsDividerArea
report area rectangle
xtpReportElementRectFooterRecordsDividerArea
report area rectangle

Remarks

Call CXTPReportControl::GetElementRect to get report element rectangle

See Also

CXTPReportControl::GetElementRect

Example
m_wndReport.GetElementRect(xtpReportRectGroupByArea, rc);
Group

Structs, Records, Enums


XTPReportFixedRowsDividerStyle Enumeration

XTPReportPaintManager.h, Structs, Records, Enums
XTPReportFixedRowsDividerStyle Enumeration

Represent the Header/Footer rows devider style.

enum XTPReportFixedRowsDividerStyle {
  xtpReportFixedRowsDividerNone = 0x00,
  xtpReportFixedRowsDividerThin = 0x01,
  xtpReportFixedRowsDividerBold = 0x02,
  xtpReportFixedRowsDividerShade = 0x04,
  xtpReportFixedRowsDividerOutlook = 0x08
};
File

XTPReportPaintManager.h

Members

xtpReportFixedRowsDividerNone
no line
xtpReportFixedRowsDividerThin
thin style
xtpReportFixedRowsDividerBold
bold style
xtpReportFixedRowsDividerShade
shaded line style
xtpReportFixedRowsDividerOutlook
outlook line style

Group

Structs, Records, Enums


XTPReportFreezeColsDividerStyle Enumeration

XTPReportPaintManager.h, Structs, Records, Enums
XTPReportFreezeColsDividerStyle Enumeration

Represents predefined freeze column line styles:

enum XTPReportFreezeColsDividerStyle {
  xtpReportFreezeColsDividerThin = 0x01,
  xtpReportFreezeColsDividerBold = 0x02,
  xtpReportFreezeColsDividerHeader = 0x04,
  xtpReportFreezeColsDividerShade = 0x08,
  xtpReportFreezeColsDividerShowAlways = 0x10
};
File

XTPReportPaintManager.h

Members

xtpReportFreezeColsDividerThin
thin line style
xtpReportFreezeColsDividerBold
bold line style
xtpReportFreezeColsDividerHeader
header line style
xtpReportFreezeColsDividerShade
shade line style
xtpReportFreezeColsDividerShowAlways
show event if AutoColumnSizing is On

Group

Structs, Records, Enums


XTPReportGridStyle Enumeration

XTPReportPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPReportGridStyle Enumeration

Represents predefined grid line styles:

enum XTPReportGridStyle {
  xtpReportGridNoLines,
  xtpReportGridSmallDots,
  xtpReportGridLargeDots,
  xtpReportGridDashes,
  xtpReportGridSolid
};
File

XTPReportPaintManager.h

Members

xtpReportGridNoLines
empty line
xtpReportGridSmallDots
line is drawn with small dots
xtpReportGridLargeDots
line is drawn with large dots
xtpReportGridDashes
line is drawn with dashes
xtpReportGridSolid
draws solid line

See Also

CXTPReportControl::SetGridStyle

Example
m_wndReport.SetGridStyle(FALSE, xtpReportGridLargeDots);
Group

Structs, Records, Enums


XTPReportGroupRowIconAlignment Enumeration

XTPReportRecordItem.h, Structs, Records, Enums, See Also
XTPReportGroupRowIconAlignment Enumeration

This enum defines alignment style for the group row custom icon.

enum XTPReportGroupRowIconAlignment {
  xtpGroupRowIconUnknown = 0,
  xtpGroupRowIconLeft = 0x001,
  xtpGroupRowIconBeforeText = 0x002,
  xtpGroupRowIconAfterText = 0x004,
  xtpGroupRowIconRight = 0x008,
  xtpGroupRowIconHmask = 0x00F,
  xtpGroupRowIconVTop = 0x100,
  xtpGroupRowIconVCenter = 0x200,
  xtpGroupRowIconVCenterToText = 0x400,
  xtpGroupRowIconVBottom = 0x800,
  xtpGroupRowIconVmask = 0xF00
};
File

XTPReportRecordItem.h

Members

xtpGroupRowIconUnknown
Unknown (empty) value.
xtpGroupRowIconLeft
Draw icon at the left side of group row rect.
xtpGroupRowIconBeforeText
Draw icon before caption text (between Expand/Collapse icon and text).
xtpGroupRowIconAfterText
Draw icon after caption text.
xtpGroupRowIconRight
Draw icon at the right side of group row rect.
xtpGroupRowIconHmask
A mask for horizontal alignment flags.
xtpGroupRowIconVTop
Vertical alignment: top of group row rect.
xtpGroupRowIconVCenter
Vertical alignment: center of group row rect.
xtpGroupRowIconVCenterToText
Vertical alignment: center of caption text rect.
xtpGroupRowIconVBottom
Vertical alignment: bottom of group row rect.
xtpGroupRowIconVmask
A mask for vertical alignment flags.

See Also

XTP_REPORTRECORDITEM_METRICS::nGroupRowIconAlignment

Group

Structs, Records, Enums


XTPReportMouseMode Enumeration

XTPReportControl.h, Structs, Records, Enums, See Also
XTPReportMouseMode Enumeration

Enumeration of operational mouse modes.

enum XTPReportMouseMode {
  xtpReportMouseNothing,
  xtpReportMouseOverColumnDivide,
  xtpReportMousePrepareDragColumn,
  xtpReportMouseDraggingColumn
};
File

XTPReportControl.h

Members

xtpReportMouseNothing
User is just watching to the list.
xtpReportMouseOverColumnDivide
User watching, but mouse is under column divider.
xtpReportMousePrepareDragColumn
User holds mouse button pressed on the column header.
xtpReportMouseDraggingColumn
User is dragging column header.

Remarks

ReportControl has several Mouse states that handled by control. This enumeration helps to clearly identify each of these

  • Sends Notifications:
  • Sends Messages:
See Also

CXTPReportControl::SetMouseMode, CXTPReportControl::GetMouseMode

Group

Structs, Records, Enums


XTPReportRowType Enumeration

XTPReportRow.h, Structs, Records, Enums, See Also
XTPReportRowType Enumeration

This enum defines body, header, and footer rows.

enum XTPReportRowType {
  xtpRowTypeBody = 0,
  xtpRowTypeHeader = 1,
  xtpRowTypeFooter = 2
};
File

XTPReportRow.h

Members

xtpRowTypeBody
The row is in body rows collection.
xtpRowTypeHeader
The row is in Headers rows collection.
xtpRowTypeFooter
The row is in Footers rows collection.

See Also

CXTPReportRow::m_nRowType

Group

Structs, Records, Enums


XTPReportSelectionChangeType Enumeration

XTPReportRows.h, Structs, Records, Enums, See Also
XTPReportSelectionChangeType Enumeration

This enum defines selection change action.

enum XTPReportSelectionChangeType {
  xtpReportSelectionAdd,
  xtpReportSelectionRemove,
  xtpReportSelectionClear
};
File

XTPReportRows.h

Members

xtpReportSelectionAdd
Row will be added to selected rows collection.
xtpReportSelectionRemove
Row will be removed from selected rows collection.
xtpReportSelectionClear
The selected rows collection will be cleared.

See Also

XTP_NM_REPORT_SELCHANGING, XTP_NM_SELECTION_CHANGING

Group

Structs, Records, Enums


XTPReportTreeStructureStyle Enumeration

XTPReportPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPReportTreeStructureStyle Enumeration

Represent the style of lines used to draw a hierarchical tree structure.

enum XTPReportTreeStructureStyle {
  xtpReportTreeStructureNone,
  xtpReportTreeStructureSolid,
  xtpReportTreeStructureDots
};
File

XTPReportPaintManager.h

Members

xtpReportTreeStructureNone
No lines will be drawn from the parent node to each child node.
xtpReportTreeStructureSolid
Lines will be drawn from the parent node to each child node at the next level.
xtpReportTreeStructureDots
Dots will be drawn from the parent node to each child node at the next level.

See Also

CXTPReportPaintManager::m_treeStructureStyle, CXTPReportPaintManager

Example
m_wndReport.GetPaintManager()->m_treeStructureStyle = xtpReportTreeStructureSolid;
Group

Structs, Records, Enums


XTPReportVirtualRowFlags Enumeration

XTPReportRecordItem.h, Structs, Records, Enums, See Also
XTPReportVirtualRowFlags Enumeration

This enum defines flags for virtual row metrics.

enum XTPReportVirtualRowFlags {
  xtpVirtRowUnknown = 0,
  xtpVirtRowHasChildren = 0x001,
  xtpVirtRowLastChild = 0x002
};
File

XTPReportRecordItem.h

Members

xtpVirtRowUnknown
Unknown (empty) value.
xtpVirtRowHasChildren
A row has children.
xtpVirtRowLastChild
A row is the last child of its parent.

See Also

XTP_REPORTRECORDITEM_METRICS::nVirtRowFlags

Group

Structs, Records, Enums


XTPReportWatermarkAlignment Enumeration

XTPReportControl.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPReportWatermarkAlignment Enumeration

Enumeration of watermark alignment flags

enum XTPReportWatermarkAlignment {
  xtpReportWatermarkUnknown = 0,
  xtpReportWatermarkLeft = 0x0001,
  xtpReportWatermarkCenter = 0x0002,
  xtpReportWatermarkRight = 0x0004,
  xtpReportWatermarkHmask = 0x000F,
  xtpReportWatermarkTop = 0x0010,
  xtpReportWatermarkVCenter = 0x0020,
  xtpReportWatermarkBottom = 0x0040,
  xtpReportWatermarkVmask = 0x00F0,
  xtpReportWatermarkStretch = 0x0100,
  xtpReportWatermarkEnlargeOnly = 0x0200,
  xtpReportWatermarkShrinkOnly = 0x0400,
  xtpReportWatermarkPreserveRatio = 0x0800
};
File

XTPReportControl.h

Members

xtpReportWatermarkUnknown
Unknown (empty) value.
xtpReportWatermarkLeft
Horizontal alignment: left side of report control client rect.
xtpReportWatermarkCenter
Horizontal alignment: center of report control client rect.
xtpReportWatermarkRight
Horizontal alignment: right side of report control client rect.
xtpReportWatermarkHmask
A mask for horizontal alignment flags.
xtpReportWatermarkTop
Vertical alignment: top side of report control client rect.
xtpReportWatermarkVCenter
Vertical alignment: center of report control client rect.
xtpReportWatermarkBottom
Vertical alignment: bottom side of report control client rect.
xtpReportWatermarkVmask
A mask for vertical alignment flags.
xtpReportWatermarkStretch
Stretch watermark to entire report control client rect.
xtpReportWatermarkEnlargeOnly
Watermark can be enlarged only, shrinking is disabled.
xtpReportWatermarkShrinkOnly
Watermark can be shrinked only, enlarging is disabled.
xtpReportWatermarkPreserveRatio
Watermark aspect ratio is preserved.

Remarks

Call CXTPReportControl::SetWatermarkAlignment to modify watermark alignment

See Also

CXTPReportControl::SetWatermarkAlignment, GetWatermarkAlignment

Example
m_wndReport.SetWatermarkAlignment(xtpWatermarkCenter | xtpWatermarkBottom);
Group

Structs, Records, Enums


Variables

Report Control, Variables
Variables
Module

Report Control

Variables
Variable | Description
XTP_ID_REPORT_COMBOBUTTON | Constructs a CXTPReportInplaceButton object
XTP_ID_REPORT_CONTROL | Identifier of report control child window of CXTPReportView.
XTP_ID_REPORT_EXPANDBUTTON | Constructs a CXTPReportInplaceButton object
XTP_ID_REPORT_SPINBUTTON | Constructs a CXTPReportInplaceButton object
XTP_REPORT_COLOR_DEFAULT | This constant indicates that a COLORREF is not defined.
XTP_REPORT_NOICON | This constant indicates that an icon ID is not defined.
XTPREPORTCTRL_CF_RECORDS | Report control records clipboard format name.
XTPREPORTCTRL_CLASSNAME | NULL terminated string used by CXTPReportControl which specifies the window class name for the report control.


XTP_ID_REPORT_CONTROL Variable

XTPReportView.h, Variables, Example, See Also
XTP_ID_REPORT_CONTROL Variable

Identifier of report control child window of CXTPReportView.

const UINT XTP_ID_REPORT_CONTROL = 100;
File

XTPReportView.h

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED CXTPReportView, CXTPReportControl, CXTPReportHeader

Example
int CXTPReportView::OnCreate(LPCREATESTRUCT lpCreateStruct)
{
    if (CView::OnCreate(lpCreateStruct) == -1)
        return -1;

    if (!m_wndReport.Create(WS_CHILD | WS_TABSTOP | WS_VISIBLE | WM_VSCROLL,
        CRect(0, 0, 0, 0), this, XTP_ID_REPORT_CONTROL))
    {
        TRACE(_T("Failed to create tab control windown"));
        return -1;
    }
    return 0;
}
Group

Variables


XTP_REPORT_COLOR_DEFAULT Variable

XTPReportDefines.h, Variables, Example, See Also
XTP_REPORT_COLOR_DEFAULT Variable

This constant indicates that a COLORREF is not defined.

const COLORREF XTP_REPORT_COLOR_DEFAULT = (COLORREF)-1;
File

XTPReportDefines.h

See Also

CXTPReportRecordItem, CXTPReportRow

Example
void CXTPReportRecordItem::GetItemMetrics(
    XTP_REPORTRECORDITEM_DRAWARGS* pDrawArgs,
    XTP_REPORTRECORDITEM_METRICS* pItemMetrics)
{
    if (m_clrBackground != XTP_REPORT_COLOR_DEFAULT)
        pItemMetrics->clrBackground = m_clrBackground;

    if (m_clrText != XTP_REPORT_COLOR_DEFAULT)
        pItemMetrics->clrForeground = m_clrText;

    if (m_pFontCaption != NULL)
        pItemMetrics->pFont = m_pFontCaption;

    else if (m_bBoldText)
        pItemMetrics->pFont =
            &pDrawArgs->pControl->GetPaintManager()->m_fontBoldText;
}
Group

Variables


XTP_REPORT_NOICON Variable

XTPReportDefines.h, Variables, Example, See Also
XTP_REPORT_NOICON Variable

This constant indicates that an icon ID is not defined.

const int XTP_REPORT_NOICON = (int)-1;
File

XTPReportDefines.h

See Also

CXTPReportColumn

Example
m_wndReport.AddColumn(new CXTPReportColumn(COLUMN_PRICE, _T("Price"),
    80, TRUE, XTP_REPORT_NOICON, TRUE, FALSE));
Group

Variables


XTPREPORTCTRL_CF_RECORDS Variable

XTPReportDefines.h, Variables
XTPREPORTCTRL_CF_RECORDS Variable

Report control records clipboard format name.

const LPCTSTR XTPREPORTCTRL_CF_RECORDS = _T("XTPReport_CF_Records");
File

XTPReportDefines.h

Group

Variables


XTPREPORTCTRL_CLASSNAME Variable

XTPReportDefines.h, Variables, Example, See Also
XTPREPORTCTRL_CLASSNAME Variable

NULL terminated string used by CXTPReportControl which specifies the window class name for the report control.

const TCHAR XTPREPORTCTRL_CLASSNAME[] = _T("XTPReport");
File

XTPReportDefines.h

See Also

CXTPReportControl::RegisterWindowClass

Example
BOOL CXTPReportControl::RegisterWindowClass()
{
    WNDCLASS wndcls;
    HINSTANCE hInst = AfxGetInstanceHandle();

    if (!(::GetClassInfo(hInst, XTPREPORTCTRL_CLASSNAME, &wndcls)))
    {
        // otherwise we need to register a new class
        wndcls.style            = CS_DBLCLKS | CS_HREDRAW | CS_VREDRAW;
        wndcls.lpfnWndProc      = ::DefWindowProc;
        wndcls.cbClsExtra       = wndcls.cbWndExtra = 0;
        wndcls.hInstance        = hInst;
        wndcls.hIcon            = NULL;
        wndcls.hCursor          = AfxGetApp()->LoadStandardCursor(IDC_ARROW);
        wndcls.hbrBackground    = (HBRUSH) (COLOR_3DFACE + 1);
        wndcls.lpszMenuName     = NULL;
        wndcls.lpszClassName    = XTPREPORTCTRL_CLASSNAME;

        if (!AfxRegisterClass(&wndcls))
        {
            AfxThrowResourceException();
            return FALSE;
        }
    }

    return TRUE;
}
Group

Variables


Macros

Macros, Report Control
Macros
Macros
Macro | Description
XTP_NM_REPORT_BEFORE_COPY_TOTEXT | Defines message for handling CXTPReportControl::OnBeforeCopyToText().
XTP_NM_REPORT_BEFORE_PASTE | Defines message for handling CXTPReportControl::OnBeforePaste().
XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT | Defines message for handling CXTPReportControl::OnBeforePasteFromText().
XTP_NM_REPORT_BEGINDRAG | Indicates the user start dragging records.
XTP_NM_REPORT_BEGINEDIT | Defines message for in-place editing has just started. Send after XTP_NM_REPORT_REQUESTEDIT and when inplace editor has been created.
XTP_NM_REPORT_CHECKED | Defines message for handling row checking event.
XTP_NM_REPORT_COLUMNORDERCHANGED | Defines message for column changed event.
XTP_NM_REPORT_COLUMNWIDTHCHANGED | Defines message for handling CXTPReportHeader::AdjustColumnsWidth().
XTP_NM_REPORT_CONSTRAINT_SELECTING | Indicates the user changed a selected item in the combobox.
XTP_NM_REPORT_DRAGDROP_COMPLETED | Indicates the user completed drag&drop operation.
XTP_NM_REPORT_DRAGOVER | Indicates the user is dragging records over a control.
XTP_NM_REPORT_DROP | Indicates the user dropped records to report control.
XTP_NM_REPORT_EDIT_CANCELED | Defines message for in-place editing is canceled and value is not changed event.
XTP_NM_REPORT_FOCUS_CHANGING | Defines message for handling focus changing event.
XTP_NM_REPORT_GETITEMMETRICS | Defines message for handling CXTPReportControl::GetItemMetrics().
XTP_NM_REPORT_GETTOOLTIPINFO | Indicates the tooltip will be drawn.
XTP_NM_REPORT_GROUPORDERCHANGED | Defines message for column group order changed event.
XTP_NM_REPORT_HEADER_RCLICK | Defines message for header context menu
XTP_NM_REPORT_HYPERLINK | Defines message for handling hyperlink click event.
XTP_NM_REPORT_INPLACEBUTTONDOWN | Defines message for in-place button click event.
XTP_NM_REPORT_ITEMBUTTONCLICK | Defines message for item button click event.
XTP_NM_REPORT_LBUTTONDOWN | Defines message for left mouse button click.
XTP_NM_REPORT_PRESORTORDERCHANGED | Defines message when a column header has been clicked and the sort order has changed, but CXTPReportControl::Populate has NOT yet been called.
XTP_NM_REPORT_PREVIEWKEYDOWN | Defines message for handling CXTPReportControl::OnPreviewKeyDown().
XTP_NM_REPORT_RECORDS_DROPPED | Indicates the records were dropped to report control.
XTP_NM_REPORT_REQUESTEDIT | Defines message for handling CXTPReportControl::OnRequestEdit().
XTP_NM_REPORT_ROWEXPANDED | Defines message for row expand event.
XTP_NM_REPORT_SELCHANGED | Defines message for handling rows selection changed event.
XTP_NM_REPORT_SELCHANGING | Defines message for selected rows collection changing. Send for each row when it added/removed.
XTP_NM_REPORT_SORTORDERCHANGED | Defines message for sort changed event.
XTP_NM_REPORT_VALUECHANGED | Defines message for value changed event.
Module

Report Control


XTP_NM_REPORT_BEFORE_COPY_TOTEXT Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_BEFORE_COPY_TOTEXT Macro

Defines message for handling CXTPReportControl::OnBeforeCopyToText().

#define XTP_NM_REPORT_BEFORE_COPY_TOTEXT (NM_FIRST-63)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_BEFORE_COPY_TOTEXT notification message is sent to allow the owner window customize copy/paste operations.

See Also

CXTPReportControl, CXTPReportControl::OnBeforeCopyToText()

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_BEFORE_COPY_TOTEXT, XTP_ID_REPORT_CONTROL, OnBeforeCopyToText)
END_MESSAGE_MAP()

void CReportSampleView::OnBeforeCopyToText(NMHDR*  pNotifyStruct, LRESULT* result)
{
 ASSERT(pNotifyStruct);

 XTP_NM_REPORT_BEFORE_COPYPASTE* pnmCopyPaste = (XTP_NM_REPORT_BEFORE_COPYPASTE*)pNotifyStruct;

 if (!pnmCopyPaste || !pnmCopyPaste->ppRecord || !*pnmCopyPaste->ppRecord ||
     !pnmCopyPaste->parStrings)
 {
     ASSERT(FALSE);
     return;
 }

 // customize data provided by pnmCopyPaste->parStrings
 // you can use source record object: (*pnmCopyPaste->ppRecord)->Member()

 // set result to not zero to cancel operation:
 // *result = (LRESULT)TRUE;
}
Group

Macros


XTP_NM_REPORT_BEFORE_PASTE Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_BEFORE_PASTE Macro

Defines message for handling CXTPReportControl::OnBeforePaste().

#define XTP_NM_REPORT_BEFORE_PASTE (NM_FIRST-65)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_BEFORE_PASTE notification message is sent to allow the owner window customize copy/paste operations.

See Also

CXTPReportControl, CXTPReportControl::OnBeforePaste()

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_BEFORE_PASTE, XTP_ID_REPORT_CONTROL, OnBeforePaste)
END_MESSAGE_MAP()

void CReportSampleView::OnBeforePaste(NMHDR*  pNotifyStruct, LRESULT* result)
{
 ASSERT(pNotifyStruct);

 XTP_NM_REPORT_BEFORE_COPYPASTE* pnmCopyPaste = (XTP_NM_REPORT_BEFORE_COPYPASTE*)pNotifyStruct;
 ASSERT(pnmCopyPaste && pnmCopyPaste->parStrings == NULL);

 if (!pnmCopyPaste || !pnmCopyPaste->ppRecord || !*pnmCopyPaste->ppRecord) {
     ASSERT(FALSE);
     return;
 }

 // you can create new or change provided record using pnmCopyPaste->ppRecord

 // set result to not zero to cancel operation:
 // *result = (LRESULT)TRUE;
}
Group

Macros


XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT Macro

Defines message for handling CXTPReportControl::OnBeforePasteFromText().

#define XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT (NM_FIRST-64)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT notification message is sent to allow the owner window customize copy/paste operations.

See Also

CXTPReportControl, CXTPReportControl::OnBeforePasteFromText()

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT, XTP_ID_REPORT_CONTROL, OnReportBeforePasteFromText)
END_MESSAGE_MAP()

 void CReportSampleView::OnReportBeforePasteFromText(NMHDR*  pNotifyStruct, LRESULT* result)
 {
     ASSERT(pNotifyStruct);

     XTP_NM_REPORT_BEFORE_COPYPASTE* pnmCopyPaste = (XTP_NM_REPORT_BEFORE_COPYPASTE*)pNotifyStruct;

     if (!pnmCopyPaste || !pnmCopyPaste->ppRecord || !pnmCopyPaste->parStrings) {
         ASSERT(FALSE);
         return;
     }

     CMessageRecord* pRecord = new CMessageRecord();
     if (!pRecord) {
         return;
     }

     *pnmCopyPaste->ppRecord = pRecord;

     CXTPReportColumns* pColumns = GetReportCtrl().GetColumns();
     ASSERT(pColumns);
     if (!pColumns) {
         return;
     }

     int nDataCount = pnmCopyPaste->parStrings->GetSize();

     const int nColumnCount = pColumns->GetVisibleColumnsCount();
     for (int nCol = 0; nCol < nColumnCount; nCol++)
     {
         CXTPReportColumn* pColumn = pColumns->GetVisibleAt(nCol);
         CXTPReportRecordItem* pItem = pRecord->GetItem(pColumn);
         ASSERT(pItem);
         if (NULL == pItem)
             continue;

         if (nCol < nDataCount)
         {
             CString strItem = pnmCopyPaste->parStrings->GetAt(nCol);
             pItem->SetCaption(strItem);
         }
     }
     // set result to not zero to cancel operation:
     // *result = (LRESULT)TRUE;
 }
Group

Macros


XTP_NM_REPORT_BEGINDRAG Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_BEGINDRAG Macro

Indicates the user start dragging records.

#define XTP_NM_REPORT_BEGINDRAG (NM_FIRST-70)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

XTP_NM_REPORTDRAGDROP structure passed with this message

See Also

XTP_NM_REPORTDRAGDROP, XTP_NM_REPORT_BEGINDRAG, XTP_NM_REPORT_DROP, XTP_NM_REPORT_RECORDS_DROPPED, XTP_NM_REPORT_DRAGDROP_COMPLETED

Group

Macros


XTP_NM_REPORT_BEGINEDIT Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_BEGINEDIT Macro

Defines message for in-place editing has just started. Send after XTP_NM_REPORT_REQUESTEDIT and when inplace editor has been created.

#define XTP_NM_REPORT_BEGINEDIT (NM_FIRST-78)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

XTP_NM_REPORTRECORDITEM structure passed with this message

See Also

XTP_NM_REPORTRECORDITEM, XTP_NM_REPORT_VALUECHANGED, XTP_NM_REPORT_REQUESTEDIT, CXTPReportRecordItem::OnEditCanceled

Group

Macros


XTP_NM_REPORT_CHECKED Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_CHECKED Macro

Defines message for handling row checking event.

#define XTP_NM_REPORT_CHECKED (NM_FIRST-53)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_CHECKED notification message is sent to inform the owner window that the user click check box of item of report control The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_CHECKED, XTP_ID_REPORT_CONTROL, OnReportCheckItem)
END_MESSAGE_MAP()

void CReportSampleView::OnReportCheckItem(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;
    ASSERT(pItemNotify != NULL);

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_COLUMNORDERCHANGED Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_COLUMNORDERCHANGED Macro

Defines message for column changed event.

#define XTP_NM_REPORT_COLUMNORDERCHANGED (NM_FIRST-55)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_COLUMNORDERCHANGED notification message is sent to inform the owner window that the user change the order of columns of report control. The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_GROUPORDERCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_ID_REPORT_CONTROL, OnReportColumnOrderChanged)
END_MESSAGE_MAP()

void CReportSampleView::OnReportColumnOrderChanged(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;
    ASSERT(pItemNotify != NULL);

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_COLUMNWIDTHCHANGED Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_COLUMNWIDTHCHANGED Macro

Defines message for handling CXTPReportHeader::AdjustColumnsWidth().

#define XTP_NM_REPORT_COLUMNWIDTHCHANGED (NM_FIRST-68)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_COLUMNWIDTHCHANGED notification message is sent when the width of a column has changed. This can happen when the user changes the width or when the Report Control automatically changes the width.

See Also

CXTPReportHeader, CXTPReportHeader::AdjustColumnsWidth

Group

Macros


XTP_NM_REPORT_CONSTRAINT_SELECTING Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_CONSTRAINT_SELECTING Macro

Indicates the user changed a selected item in the combobox.

#define XTP_NM_REPORT_CONSTRAINT_SELECTING (NM_FIRST-73)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

See Also

CXTPReportControl::OnConstraintSelecting()

Group

Macros


XTP_NM_REPORT_DRAGDROP_COMPLETED Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_DRAGDROP_COMPLETED Macro

Indicates the user completed drag&drop operation.

#define XTP_NM_REPORT_DRAGDROP_COMPLETED (NM_FIRST-77)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

XTP_NM_REPORTDRAGDROP structure passed with this message

See Also

XTP_NM_REPORTDRAGDROP, XTP_NM_REPORT_BEGINDRAG, XTP_NM_REPORT_DROP, XTP_NM_REPORT_RECORDS_DROPPED

Group

Macros


XTP_NM_REPORT_DRAGOVER Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_DRAGOVER Macro

Indicates the user is dragging records over a control.

#define XTP_NM_REPORT_DRAGOVER (NM_FIRST-81)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

XTP_NM_REPORTDRAGDROP structure passed with this message

See Also

XTP_NM_REPORTDRAGDROP, XTP_NM_REPORT_BEGINDRAG, XTP_NM_REPORT_DROP, XTP_NM_REPORT_RECORDS_DROPPED, XTP_NM_REPORT_DRAGDROP_COMPLETED

Group

Macros


XTP_NM_REPORT_DROP Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_DROP Macro

Indicates the user dropped records to report control.

#define XTP_NM_REPORT_DROP (NM_FIRST-71)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

XTP_NM_REPORTDRAGDROP structure passed with this message

See Also

XTP_NM_REPORTDRAGDROP, XTP_NM_REPORT_BEGINDRAG, XTP_NM_REPORT_RECORDS_DROPPED, XTP_NM_REPORT_DRAGDROP_COMPLETED

Group

Macros


XTP_NM_REPORT_EDIT_CANCELED Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_EDIT_CANCELED Macro

Defines message for in-place editing is canceled and value is not changed event.

#define XTP_NM_REPORT_EDIT_CANCELED (NM_FIRST-72)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

XTP_NM_REPORTRECORDITEM structure passed with this message

See Also

XTP_NM_REPORTRECORDITEM, XTP_NM_REPORT_VALUECHANGED, CXTPReportRecordItem::OnEditCanceled

Group

Macros


XTP_NM_REPORT_FOCUS_CHANGING Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_FOCUS_CHANGING Macro

Defines message for handling focus changing event.

#define XTP_NM_REPORT_FOCUS_CHANGING (NM_FIRST-76)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_FOCUS_CHANGING notification message is sent to inform the owner window that the focused row or column is about to be changed The owner window of the report control receives this notification through the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_FOCUS_CHANGED CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_FOCUS_CHANGING, XTP_ID_REPORT_CONTROL, OnReportFocusChanging)
END_MESSAGE_MAP()

void CReportSampleView::OnReportFocusChanging(NMHDR* pNMHDR, LRESULT* /*result*/)
{
    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_GETITEMMETRICS Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_GETITEMMETRICS Macro

Defines message for handling CXTPReportControl::GetItemMetrics().

#define XTP_NM_REPORT_GETITEMMETRICS (NM_FIRST-61)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_GETITEMMETRICS notification message is sent to allow the owner window customize item drawing. The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

CXTPReportControl, CXTPReportControl::GetItemMetrics()

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_GETITEMMETRICS, XTP_ID_REPORT_CONTROL, OnReportGetItemMetrics)
END_MESSAGE_MAP()

void CReportSampleView::OnReportGetItemMetrics(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTITEMMETRICS* pItemNotify = (XTP_NM_REPORTITEMMETRICS*)pNotifyStruct;

    ASSERT(pItemNotify->pDrawArgs);
    ASSERT(pItemNotify->pDrawArgs->pControl);
    ASSERT(pItemNotify->pDrawArgs->pRow);

    //     pItemNotify->pDrawArgs->pColumn   - may be NULL (for a group row)
    //     pItemNotify->pDrawArgs->pItem     - may be NULL (for a group row)

    ASSERT(pItemNotify->pItemMetrics);

    // TODO: customize members of pItemNotify->pItemMetrics.
}
Group

Macros


XTP_NM_REPORT_GETTOOLTIPINFO Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_GETTOOLTIPINFO Macro

Indicates the tooltip will be drawn.

#define XTP_NM_REPORT_GETTOOLTIPINFO (NM_FIRST-74)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

See Also

CXTPReportControl::OnGetToolTipInfo()

Group

Macros


XTP_NM_REPORT_GROUPORDERCHANGED Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_GROUPORDERCHANGED Macro

Defines message for column group order changed event.

#define XTP_NM_REPORT_GROUPORDERCHANGED (NM_FIRST-82)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_GROUPORDERCHANGED notification message is sent to inform the owner window that the user change the columns group order of report control. The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_GROUPORDERCHANGED, XTP_ID_REPORT_CONTROL, OnReportGroupOrderChanged)
END_MESSAGE_MAP()

void CReportSampleView::OnReportGroupOrderChanged(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;
    ASSERT(pItemNotify != NULL);

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_HEADER_RCLICK Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_HEADER_RCLICK Macro

Defines message for header context menu

#define XTP_NM_REPORT_HEADER_RCLICK (NM_FIRST-51)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_HEADER_RCLICK notification message is sent to inform the owner window that the user has right clicked column of report control The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_HEADER_RCLICK, XTP_ID_REPORT_CONTROL, OnReportColumnRClick)
END_MESSAGE_MAP()

void CReportSampleView::OnReportColumnRClick(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*)pNotifyStruct;
    ASSERT(pItemNotify->pColumn);
    CPoint ptClick = pItemNotify->pt;

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_HYPERLINK Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_HYPERLINK Macro

Defines message for handling hyperlink click event.

#define XTP_NM_REPORT_HYPERLINK (NM_FIRST-54)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_HYPERLINK notification message is sent to inform the owner window that the user click hyperlink of item. The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_HYPERLINK, XTP_ID_REPORT_CONTROL, OnReportHyperlinkClick)
END_MESSAGE_MAP()

void CReportSampleView::OnReportHyperlinkClick(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;

    if (!pItemNotify->pRow || !pItemNotify->pColumn)
        return;

    // if click on Hyperlink in Item
    if (pItemNotify->nHyperlink >= 0)
    {
        TRACE(_T("Hyperlink Click : n row %d n col %d n Hyperlink %d.n"),
            pItemNotify->pRow->GetIndex(),
            pItemNotify->pColumn->GetItemIndex(),
            pItemNotify->nHyperlink);
    }
}
Group

Macros


XTP_NM_REPORT_INPLACEBUTTONDOWN Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_INPLACEBUTTONDOWN Macro

Defines message for in-place button click event.

#define XTP_NM_REPORT_INPLACEBUTTONDOWN (NM_FIRST-58)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Returns

TRUE if message was processed; FALSE for default process.

Remarks

The XTP_NM_REPORT_INPLACEBUTTONDOWN notification message is sent to inform the owner window that the user click in-place button of report control The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_ID_REPORT_CONTROL, OnReportButtonClick)
END_MESSAGE_MAP()

void CReportSampleView::OnReportButtonClick(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTINPLACEBUTTON* pItemNotify = (XTP_NM_REPORTINPLACEBUTTON*) pNotifyStruct;
    ASSERT(pItemNotify->pButton);

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_ITEMBUTTONCLICK Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_ITEMBUTTONCLICK Macro

Defines message for item button click event.

#define XTP_NM_REPORT_ITEMBUTTONCLICK (NM_FIRST-83)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Returns

TRUE if message was processed; FALSE for default process.

Remarks

The XTP_NM_REPORT_ITEMBUTTONCLICK notification message is sent to inform the owner window that the user click item button of report control The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORTITEMCONTROL CXTPReportRecordItemControl, CXTPReportRecordItemButton

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_ITEMBUTTONCLICK, XTP_ID_REPORT_CONTROL, OnReportItemButtonClick)
END_MESSAGE_MAP()

void CReportSampleView::OnReportItemButtonClick(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTITEMCONTROL* pItemNotify = (XTP_NM_REPORTITEMCONTROL*) pNotifyStruct;
    ASSERT(pItemNotify->pItemControl);

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_LBUTTONDOWN Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_LBUTTONDOWN Macro

Defines message for left mouse button click.

#define XTP_NM_REPORT_LBUTTONDOWN (NM_FIRST-60)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_LBUTTONDOWN notification message is sent to inform the owner window that the user press left button on the row.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_LBUTTONDOWN, XTP_ID_REPORT_CONTROL, OnReportLButtonDown)
END_MESSAGE_MAP()

void CReportSampleView::OnReportLButtonDown(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;
    ASSERT(pItemNotify != NULL);

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_PRESORTORDERCHANGED Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_PRESORTORDERCHANGED Macro

Defines message when a column header has been clicked and the sort order has changed, but CXTPReportControl::Populate has NOT yet been called.

#define XTP_NM_REPORT_PRESORTORDERCHANGED (NM_FIRST-67)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_PRESORTORDERCHANGED notification message is sent to inform the owner window that the user change click header of report control the sort order will change. XTP_NM_REPORT_PRESORTORDERCHANGED is send BEFORE CXTPReportControl::Populate has been called, so the order of the rows has not yet been visibly changed. After CXTPReportControl::Populate is called, the XTP_NM_REPORT_SORTORDERCHANGED notification is send to inform that the order has actually changed. The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_VALUECHANGED, XTP_NM_REPORT_SORTORDERCHANGED CXTPReportControl, CXTPReportHeader

Group

Macros


XTP_NM_REPORT_PREVIEWKEYDOWN Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_PREVIEWKEYDOWN Macro

Defines message for handling CXTPReportControl::OnPreviewKeyDown().

#define XTP_NM_REPORT_PREVIEWKEYDOWN (NM_FIRST-69)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

This notification is sent to Main window in a WM_NOTIFY message before processing OnKeyDown event.

See Also

CXTPReportControl::OnPreviewKeyDown, XTP_NM_REPORTPREVIEWKEYDOWN, CXTPReportControl::OnKeyDown, CWnd::OnKeyDown.

Group

Macros


XTP_NM_REPORT_RECORDS_DROPPED Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_RECORDS_DROPPED Macro

Indicates the records were dropped to report control.

#define XTP_NM_REPORT_RECORDS_DROPPED (NM_FIRST-75)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

XTP_NM_REPORTDRAGDROP structure passed with this message

See Also

XTP_NM_REPORTDRAGDROP, XTP_NM_REPORT_BEGINDRAG, XTP_NM_REPORT_DROP, XTP_NM_REPORT_DRAGDROP_COMPLETED

Group

Macros


XTP_NM_REPORT_REQUESTEDIT Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_REQUESTEDIT Macro

Defines message for handling CXTPReportControl::OnRequestEdit().

#define XTP_NM_REPORT_REQUESTEDIT (NM_FIRST-62)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_REQUESTEDIT notification message is sent to notify that an item has entered edit mode. This is send when an editable item starts to be edited or when a check box item is checkedunchecked.

See Also

CXTPReportControl, CXTPReportControl::OnRequestEdit()

Group

Macros


XTP_NM_REPORT_ROWEXPANDED Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_ROWEXPANDED Macro

Defines message for row expand event.

#define XTP_NM_REPORT_ROWEXPANDED (NM_FIRST-59)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_ROWEXPANDED notification message is sent to inform the owner window that the user expand or collapse the row of report control .

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_ROWEXPANDED, XTP_ID_REPORT_CONTROL, OnReportRowExpandChanged)
END_MESSAGE_MAP()

void CReportSampleView::OnReportRowExpandChanged(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;
    ASSERT(pItemNotify != NULL);

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_SELCHANGED Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_SELCHANGED Macro

Defines message for handling rows selection changed event.

#define XTP_NM_REPORT_SELCHANGED (NM_FIRST-52)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_SELCHANGED notification message is sent to inform the owner window that the user select row of report control The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SORTORDERCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_SELCHANGED, XTP_ID_REPORT_CONTROL, OnReportSelChanged)
END_MESSAGE_MAP()

void CReportSampleView::OnReportSelChanged(NMHDR* pNMHDR, LRESULT* /*result*/)
{
    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_SELCHANGING Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_SELCHANGING Macro

Defines message for selected rows collection changing. Send for each row when it added/removed.

#define XTP_NM_REPORT_SELCHANGING (NM_FIRST-80)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

XTP_NM_SELECTION_CHANGING structure passed with this message

See Also

XTP_NM_SELECTION_CHANGING

Group

Macros


XTP_NM_REPORT_SORTORDERCHANGED Macro

XTPReportDefines.h, Macros, Example, See Also
XTP_NM_REPORT_SORTORDERCHANGED Macro

Defines message for sort changed event.

#define XTP_NM_REPORT_SORTORDERCHANGED (NM_FIRST-56)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_SORTORDERCHANGED notification message is sent to inform the owner window that the user change click header of report control and change sort order. The owner window of the report control receives this notification threw the WM_COMMAND message.

See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_VALUECHANGED, CXTPReportControl, CXTPReportHeader

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CReportSampleView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_SORTORDERCHANGED, XTP_ID_REPORT_CONTROL, OnReportSortOrderChanged)
END_MESSAGE_MAP()

void CReportSampleView::OnReportSortOrderChanged(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;
    ASSERT(pItemNotify != NULL);

    // TODO: Handle command.
}
Group

Macros


XTP_NM_REPORT_VALUECHANGED Macro

XTPReportDefines.h, Macros, See Also
XTP_NM_REPORT_VALUECHANGED Macro

Defines message for value changed event.

#define XTP_NM_REPORT_VALUECHANGED (NM_FIRST-57)
File

XTPReportDefines.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The XTP_NM_REPORT_VALUECHANGED notification message is sent to inform the owner window that the user change value of report cell The owner window of the report control receives this notification threw the WM_COMMAND message.

BEGIN_MESSAGE_MAP(CPropertiesView, CXTPReportView)
    ON_NOTIFY(XTP_NM_REPORT_VALUECHANGED, ID_REPORT_CONTROL, OnReportValueChanged)
END_MESSAGE_MAP()

void CPropertiesView::OnReportValueChanged(NMHDR*  pNotifyStruct, LRESULT* /*result*/)
{
    XTP_NM_REPORTRECORDITEM* pItemNotify = (XTP_NM_REPORTRECORDITEM*) pNotifyStruct;
    ASSERT(pItemNotify != NULL);

    switch (pItemNotify->pItem->GetItemData())
    {
        case ID_PROPERTY_MULTIPLESELECTION:
            GetTargetReport()->SetMultipleSelection(
                CRecordPropertyBool::GetValue(pItemNotify));
            break;
        case ID_PROPERTY_PREVIEWMODE:
            GetTargetReport()->EnablePreviewMode(
                CRecordPropertyBool::GetValue(pItemNotify));
            GetTargetReport()->Populate();
            break;
        case ID_PROPERTY_GROUPBOXVISIBLE:
            GetTargetReport()->ShowGroupBy(
                CRecordPropertyBool::GetValue(pItemNotify));
            break;
        case ID_PROPERTY_FOCUSSUBITEMS:
            GetTargetReport()->FocusSubItems(
                CRecordPropertyBool::GetValue(pItemNotify));
            break;
        case ID_PROPERTY_ALLOWCOLUMNREMOVE:
            GetTargetReport()->GetReportHeader()->AllowColumnRemove(
                CRecordPropertyBool::GetValue(pItemNotify));
            break;
        case ID_PROPERTY_ALLOWCOLUMNREORDER:
            GetTargetReport()->GetReportHeader()->AllowColumnReorder(
                CRecordPropertyBool::GetValue(pItemNotify));
            break;
        case ID_PROPERTY_ALLOWCOLUMNRESIZE:
            GetTargetReport()->GetReportHeader()->AllowColumnResize(
                CRecordPropertyBool::GetValue(pItemNotify));
            break;
        case ID_PROPERTY_FLATHEADER:
            GetTargetReport()->GetPaintManager()->m_columnStyle =
                (CRecordPropertyBool::GetValue(pItemNotify)) ? xtpReportColumnFlat : xtpReportColumnShaded;
            break;
        case ID_PROPERTY_HIDESELECTION:
            GetTargetReport()->GetPaintManager()->m_bHideSelection =
                (CRecordPropertyBool::GetValue(pItemNotify));
            break;
        case ID_PROPERTY_TREEINDENT:
            GetTargetReport()->GetPaintManager()->m_nTreeIndent =
                CRecordPropertyInt::GetValue(pItemNotify);
            GetTargetReport()->RedrawControl();
            break;
    }
}
See Also

XTP_NM_REPORT_CHECKED, XTP_NM_REPORT_COLUMNORDERCHANGED, XTP_NM_REPORT_HEADER_RCLICK, XTP_NM_REPORT_HYPERLINK, XTP_NM_REPORT_INPLACEBUTTONDOWN, XTP_NM_REPORT_SELCHANGED, XTP_NM_REPORT_SORTORDERCHANGED, CXTPReportControl, CXTPReportHeader

Group

Macros


Files

Files, Report Control
Files
Files
File | Description
XTPReportColumn.h | XTPReportColumn.h: interface for the CXTPReportColumn class.
XTPReportColumns.h | XTPReportColumns.h: interface for the CXTPReportColumns class.
XTPReportControl.h | XTPReportControl.h: interface for the CXTPReportControl class.
XTPReportDefines.h | XTPReportDefines.h This file is a part of the XTREME REPORTCONTROL MFC class library.
XTPReportDragDrop.h | XTPReportDragDrop.h: interface for the CXTPReportHeaderDragWnd and CXTPReportHeaderDropWnd classes.
XTPReportFilterEditControl.h | XTPReportFilterEditControl.h: interface for the CXTPReportFilterEditControl class.
XTPReportGroupRow.h | XTPReportGroupItem.h: interface for the CXTPReportGroupItem class.
XTPReportHeader.h | XTPReportHeader.h: interface for the CXTPReportHeader class.
XTPReportHyperlink.h | XTPReportHyperlink.h: interface for the CXTPReportHyperlink class.
XTPReportInplaceControls.h | XTPReportInplaceControls.h This file is a part of the XTREME REPORTCONTROL MFC class library.
XTPReportPaintManager.h | XTPReportPaintManager.h: interface for the CXTPReportPaintManager class.
XTPReportRecord.h | XTPReportRecord.h: interface for the CXTPReportRecord class.
XTPReportRecordItem.h | XTPReportRecordItem.h: interface for the CXTPReportRecordItem class.
XTPReportRecordItemText.h | XTPReportRecordItemText.h: interface for the CXTPReportRecordItemText class.
XTPReportRecords.h | XTPReportRecords.h: interface for the CXTPReportRecords class.
XTPReportRow.h | XTPReportRow.h: interface for the CXTPReportRow class.
XTPReportRows.h | XTPReportRows.h: interface for the CXTPReportRows class.
XTPReportSubListControl.h | XTPReportSubListControl.h: interface for the CXTPReportSubListControl class.
XTPReportTip.h | XTPReportTip.h: interface for the CXTPReportTip class.
XTPReportView.h | XTPReportView.h: interface for the CXTPReportView class.
Module

Report Control


XTPReportColumn.h

Classes, Enumerations, Files, Legend
XTPReportColumn.h

XTPReportColumn.h: interface for the CXTPReportColumn class.

Classes
Class | Description
CXTPReportColumn | Represents report column item with its properties and operations.
Enumerations
Enumeration | Description
XTPReportColumnBestFitMode | This enum defines the best fit mode.
Group

Files

Legend
Enumeration


XTPReportColumns.h

Classes, Files
XTPReportColumns.h

XTPReportColumns.h: interface for the CXTPReportColumns class.

Classes
Class | Description
CXTPReportColumnOrder | Represents column order, used for sorting and grouping.
CXTPReportColumns | This class is a collection of report columns objects, each of which can be referred to by its zero-based index.
Group

Files


XTPReportControl.h

Classes, Enumerations, Files, Legend, Structures
XTPReportControl.h

XTPReportControl.h: interface for the CXTPReportControl class.

Classes
Class | Description
CXTPReportControl | The CXTPReportControl class provides an implementation of the Report control.
CXTPReportControlLocale | Helper class with static member functions to control active locale for Report Control and perform some locale dependent tasks.
Enumerations
Enumeration | Description
XTPReportDragDrop | Enumeration of drag and drop flags
XTPReportElementRect | Enumeration of GetElementRect flags
XTPReportMouseMode | Enumeration of operational mouse modes.
XTPReportWatermarkAlignment | Enumeration of watermark alignment flags
Group

Files

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_NM_REPORTDRAGDROP | This structure is sent to main window in a WM_NOTIFY message from from report control to determine Records was dragged or dropped
XTP_NM_REPORTITEMMETRICS | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTPREVIEWKEYDOWN | This structure is sent to Main window in a WM_NOTIFY message before processing OnKeyDown event.


XTPReportDefines.h

Functions, Files, Legend, Macros, Variables
XTPReportDefines.h

XTPReportDefines.h

This file is a part of the XTREME REPORTCONTROL MFC class library.

Functions
Function | Description
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_ |
Group

Files

Macros
Macro | Description
XTP_NM_REPORT_BEFORE_COPY_TOTEXT | Defines message for handling CXTPReportControl::OnBeforeCopyToText().
XTP_NM_REPORT_BEFORE_PASTE | Defines message for handling CXTPReportControl::OnBeforePaste().
XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT | Defines message for handling CXTPReportControl::OnBeforePasteFromText().
XTP_NM_REPORT_BEGINDRAG | Indicates the user start dragging records.
XTP_NM_REPORT_BEGINEDIT | Defines message for in-place editing has just started. Send after XTP_NM_REPORT_REQUESTEDIT and when inplace editor has been created.
XTP_NM_REPORT_CHECKED | Defines message for handling row checking event.
XTP_NM_REPORT_COLUMNORDERCHANGED | Defines message for column changed event.
XTP_NM_REPORT_COLUMNWIDTHCHANGED | Defines message for handling CXTPReportHeader::AdjustColumnsWidth().
XTP_NM_REPORT_CONSTRAINT_SELECTING | Indicates the user changed a selected item in the combobox.
XTP_NM_REPORT_DRAGDROP_COMPLETED | Indicates the user completed drag&drop operation.
XTP_NM_REPORT_DRAGOVER | Indicates the user is dragging records over a control.
XTP_NM_REPORT_DROP | Indicates the user dropped records to report control.
XTP_NM_REPORT_EDIT_CANCELED | Defines message for in-place editing is canceled and value is not changed event.
XTP_NM_REPORT_FOCUS_CHANGING | Defines message for handling focus changing event.
XTP_NM_REPORT_GETITEMMETRICS | Defines message for handling CXTPReportControl::GetItemMetrics().
XTP_NM_REPORT_GETTOOLTIPINFO | Indicates the tooltip will be drawn.
XTP_NM_REPORT_GROUPORDERCHANGED | Defines message for column group order changed event.
XTP_NM_REPORT_HEADER_RCLICK | Defines message for header context menu
XTP_NM_REPORT_HYPERLINK | Defines message for handling hyperlink click event.
XTP_NM_REPORT_INPLACEBUTTONDOWN | Defines message for in-place button click event.
XTP_NM_REPORT_ITEMBUTTONCLICK | Defines message for item button click event.
XTP_NM_REPORT_LBUTTONDOWN | Defines message for left mouse button click.
XTP_NM_REPORT_PRESORTORDERCHANGED | Defines message when a column header has been clicked and the sort order has changed, but CXTPReportControl::Populate has NOT yet been called.
XTP_NM_REPORT_PREVIEWKEYDOWN | Defines message for handling CXTPReportControl::OnPreviewKeyDown().
XTP_NM_REPORT_RECORDS_DROPPED | Indicates the records were dropped to report control.
XTP_NM_REPORT_REQUESTEDIT | Defines message for handling CXTPReportControl::OnRequestEdit().
XTP_NM_REPORT_ROWEXPANDED | Defines message for row expand event.
XTP_NM_REPORT_SELCHANGED | Defines message for handling rows selection changed event.
XTP_NM_REPORT_SELCHANGING | Defines message for selected rows collection changing. Send for each row when it added/removed.
XTP_NM_REPORT_SORTORDERCHANGED | Defines message for sort changed event.
XTP_NM_REPORT_VALUECHANGED | Defines message for value changed event.
Variables
Variable | Description
XTP_REPORT_COLOR_DEFAULT | This constant indicates that a COLORREF is not defined.
XTP_REPORT_NOICON | This constant indicates that an icon ID is not defined.
XTPREPORTCTRL_CF_RECORDS | Report control records clipboard format name.
XTPREPORTCTRL_CLASSNAME | NULL terminated string used by CXTPReportControl which specifies the window class name for the report control.
Legend
Method


XTPReportDragDrop.h

Classes, Files
XTPReportDragDrop.h

XTPReportDragDrop.h: interface for the CXTPReportHeaderDragWnd and CXTPReportHeaderDropWnd classes.

Classes
Class | Description
CXTPReportHeaderDragWnd | CXTPReportHeaderDragWnd is CWnd derived class, it used internally to represent dragging column window.
CXTPReportHeaderDropWnd | CXTPReportHeaderDropWnd is CWnd derived class, it used internally to represent drop target arrows.
Group

Files


XTPReportFilterEditControl.h

Classes, Files
XTPReportFilterEditControl.h

XTPReportFilterEditControl.h: interface for the CXTPReportFilterEditControl class.

Classes
Class | Description
CXTPReportFilterEditControl | The CXTPReportFilterEditControl class provides the functionality of the filter string edit control, associated to the main Report control window.
Group

Files


XTPReportGroupRow.h

Classes, Files
XTPReportGroupRow.h

XTPReportGroupItem.h: interface for the CXTPReportGroupItem class.

Classes
Class | Description
CXTPReportGroupRow | This class represents a 'group row' of the report control view - that means a row which has no associated Record item, but has a special text caption instead.
Group

Files


XTPReportHeader.h

Classes, Files, Legend, Structures
XTPReportHeader.h

XTPReportHeader.h: interface for the CXTPReportHeader class.

Classes
Class | Description
CXTPReportHeader | A report header is a part of the report window positioned above columns of text or numbers. It contains a title for each column, and it can be divided into parts. The user can drag the dividers that separate the parts to set the width of each column.
Group

Files

Legend
Structure
Structures
Structure | Description
XTP_NM_REPORTCOLUMNRESIZE | This structure is sent to Main window in a WM_NOTIFY message after column is resized.


XTPReportHyperlink.h

Classes, Files, Types
XTPReportHyperlink.h

XTPReportHyperlink.h: interface for the CXTPReportHyperlink class.

Classes
Class | Description
CXTPReportHyperlink | This class represents hyperlinks. It stores first position and length in the text for hyperlink and rectangle for drawing and identify clicks on hyperlink. To create an instance of its class, you simply call constructor with first position and length of the hyperlink's text
CXTPReportHyperlinks | This class represents array of pointers to CXTPReportHyperlink objects. InternalRelease is called for each item in the array destructor. Also serialization for array items is provided (see DoPropExchange method).
Group

Files

Types
Type | Description
CXTPReportHyperlinks_base | This typedef used to declare a base class for CXTPReportHyperlinks.


XTPReportInplaceControls.h

Classes, Files, Variables
XTPReportInplaceControls.h

XTPReportInplaceControls.h

This file is a part of the XTREME REPORTCONTROL MFC class library.

Classes
Class | Description
CXTPReportInplaceButton | CXTPReportInplaceButton is the CXTPReportInplaceControl derived class, it represents combo button and expand button of report cell.
CXTPReportInplaceControl | CXTPReportInplaceControl is the base class for all in-place controls of report control item.
CXTPReportInplaceEdit | CXTPReportInplaceEdit is the CXTPReportInplaceControl derived class, it represents edit control to allow users change cell of report control.
CXTPReportInplaceList | CXTPReportInplaceList is the CXTPReportInplaceControl derived class, it represents list box with constraints of item.
Group

Files

Variables
Variable | Description
XTP_ID_REPORT_COMBOBUTTON | Constructs a CXTPReportInplaceButton object
XTP_ID_REPORT_EXPANDBUTTON | Constructs a CXTPReportInplaceButton object
XTP_ID_REPORT_SPINBUTTON | Constructs a CXTPReportInplaceButton object


XTPReportPaintManager.h

Classes, Enumerations, Files, Legend
XTPReportPaintManager.h

XTPReportPaintManager.h: interface for the CXTPReportPaintManager class.

Classes
Class
Description
CXTPFormulaMulDivC
This class used to store MulDivC formula parameters and perform calculation. MulDivC formula if the folowing:

  • = y * Mul / Div + C

CXTPReportPaintManager
Utility class, handling most of the drawing activities. It stores all settings, needed by a control to perform drawing operations: fonts, colors, styles for all other classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with device context.
Enumerations
Enumeration | Description
XTPReportColumnStyle | Represents predefined column styles.
XTPReportFixedRowsDividerStyle | Represent the Header/Footer rows devider style.
XTPReportFreezeColsDividerStyle | Represents predefined freeze column line styles:
XTPReportGridStyle | Represents predefined grid line styles:
XTPReportTreeStructureStyle | Represent the style of lines used to draw a hierarchical tree structure.
Group

Files

Legend
Enumeration


XTPReportRecord.h

Classes, Files
XTPReportRecord.h

XTPReportRecord.h: interface for the CXTPReportRecord class.

Classes
Class | Description
CXTPReportRecord | CXTPReportRecord represents a collection of objects of CXTPReportRecordItem or objects of classes that are children of CXTPReportRecordItem. A collection of such items is one record in ReportControl list. You create an object of CXTPReportRecord by simply calling constructor. After it you can add items to the record.
Group

Files


XTPReportRecordItem.h

Classes, Enumerations, Files, Legend, Structures
XTPReportRecordItem.h

XTPReportRecordItem.h: interface for the CXTPReportRecordItem class.

Classes
Class | Description
CXTPReportInplaceButtons | This class represents collection of the in-place buttons of the single item of the report control.
CXTPReportRecordItem | Class for working with single list cell. Base class for extended list cells. It determines the behavior of all specific record items. You don't use its class directly in the control. If you wish to add your own Record Item to the control, you must inherit it from CXTPReportRecordItem. Most member functions in this class are virtual.
CXTPReportRecordItemConstraint | CXTPReportRecordItemConstraint is a CCmdTarget derived class. It represents a single item constraints.
CXTPReportRecordItemConstraints | CXTPReportRecordItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.
CXTPReportRecordItemEditOptions | This class represents edit options of the single item or column
Enumerations
Enumeration | Description
XTPReportColumnIconAlignment | This enum defines alignment style for the column icon and text.
XTPReportGroupRowIconAlignment | This enum defines alignment style for the group row custom icon.
XTPReportVirtualRowFlags | This enum defines flags for virtual row metrics.
Group

Files

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_NM_REPORT_BEFORE_COPYPASTE | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window.
XTP_NM_REPORTCONSTRAINTSELECTING | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTINPLACEBUTTON | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTRECORDITEM | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_NM_REPORTREQUESTEDIT | A set of parameters transferred with XTP_NM_REPORT_REQUESTEDIT message
XTP_NM_REPORTTOOLTIPINFO | This structure is sent to Main window in a WM_NOTIFY message from Item and provides all parameters that are needed in processing control specific notifications by the main window
XTP_REPORTRECORDITEM_ARGS | Basic set of parameters transferred to item handlers. This structure groups together essential parameters used in items processing activities. It is parent for all other structures: XTP_REPORTRECORDITEM_DRAWARGS, XTP_REPORTRECORDITEM_CLICKARGS
XTP_REPORTRECORDITEM_CLICKARGS | A set of parameters transferred to mouse click item handlers. It inherits essential parameters from XTP_REPORTRECORDITEM_ARGS.
XTP_REPORTRECORDITEM_DRAWARGS | A set of parameters transferred to Draw item handler. It inherits essential parameters from XTP_REPORTRECORDITEM_ARGS.
XTP_REPORTRECORDITEM_METRICS | Record item drawing metrics. Its helper structures group together parameters to store general drawing metrics


XTPReportRecordItemText.h

Classes, Files
XTPReportRecordItemText.h

XTPReportRecordItemText.h: interface for the CXTPReportRecordItemText class.

Classes
Class | Description
CXTPReportRecordItemDateTime | Represents a time cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemNumber | This class represents a numeric cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemPreview | This represents a preview cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemText | This Class represents a text-only cell and inherits basic functionality from CXTPReportRecordItem class. You create a text record item simply by calling a constructor with one parameter - text string
CXTPReportRecordItemVariant | Represents a variant item and inherits basic functionality from CXTPReportRecordItem class. You can create a bitmap record item simply by calling a constructor with the only one parameter - value of VARIANT type.
Group

Files


XTPReportRecords.h

Classes, Files
XTPReportRecords.h

XTPReportRecords.h: interface for the CXTPReportRecords class.

Classes
Class | Description
CXTPReportRecords | This class represents a records collection class. It supports an array of CXTPReportRecord pointers.
Group

Files


XTPReportRow.h

Classes, Enumerations, Files, Legend
XTPReportRow.h

XTPReportRow.h: interface for the CXTPReportRow class.

Classes
Class | Description
CXTPReportRow | CXTPReportRow class represents an row of the report control window.
Enumerations
Enumeration | Description
XTPReportRowType | This enum defines body, header, and footer rows.
Group

Files

Legend
Enumeration


XTPReportRows.h

Classes, Enumerations, Files, Legend, Structures
XTPReportRows.h

XTPReportRows.h: interface for the CXTPReportRows class.

Classes
Class | Description
CXTPReportRows | This class represents a rows collection class. It supports an array of CXTPReportRow pointers.
CXTPReportSelectedRows | Encapsulates a collection of CXTPReportRow pointers that represent the selected rows in a Report Control.
Enumerations
Enumeration | Description
XTPReportSelectionChangeType | This enum defines selection change action.
Group

Files

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_NM_SELECTION_CHANGING | This struct defines data for XTP_NM_REPORT_SELCHANGING notification.


XTPReportSubListControl.h

Classes, Files
XTPReportSubListControl.h

XTPReportSubListControl.h: interface for the CXTPReportSubListControl class.

Classes
Class | Description
CXTPReportSubListControl | Field chooser list box control. This control allows the user to move column names from associated CXTPReportControl object from and to its header.
Group

Files


XTPReportTip.h

Classes, Files
XTPReportTip.h

XTPReportTip.h: interface for the CXTPReportTip class.

Classes
Class | Description
CXTPReportTip | The CXTPReportTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.
Group

Files


XTPReportView.h

Classes, Files, Variables
XTPReportView.h

XTPReportView.h: interface for the CXTPReportView class.

Classes
Class | Description
CXTPReportPageSetupDialog | Customized Calendar control page setup dialog.
CXTPReportView | The CXTPReportView class provides an implementation of the Report control as view class. Use GetReportCtrl method to access methods of CXTPReportControl
CXTPReportViewPrintOptions | This class used to store printing options.
Group

Files

Variables
Variable | Description
XTP_ID_REPORT_CONTROL | Identifier of report control child window of CXTPReportView.


Functions

Functions, Legend, Report Control
Functions
Functions
Function | Description
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_ |
Module

Report Control

Legend
Method


XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_ Function

XTPReportDefines.h, Functions
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_ Function
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_(
    CXTPReportRow_BatchData
);
File

XTPReportDefines.h

Group

Functions


Types

Report Control, Types
Types
Module

Report Control

Types
Type | Description
CXTPReportHyperlinks_base | This typedef used to declare a base class for CXTPReportHyperlinks.


CXTPReportHyperlinks_base Type

XTPReportHyperlink.h, Types
CXTPReportHyperlinks_base Type

This typedef used to declare a base class for CXTPReportHyperlinks.

typedef CXTPArrayT<CXTPReportHyperlink*, CXTPReportHyperlink*, LPDISPATCH> CXTPReportHyperlinks_base;
File

XTPReportHyperlink.h

Group

Types


Tab Manager

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Structs, Records, Enums, Types, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Tab Manager

Codejock Software's Xtreme Tab Manager is an excellent way to display several windows using a tab style interface.

Group

Xtreme Toolkit Pro v12.0

Legend
Enumeration
Classes
Class | Description
CXTPTabControl | CXTPTabControl is a multiple inheritance class derived from CXTPTabManager and CWnd. It is used to draw enhance tab control with Office 2003, Visual Studio, Win XP tabs.
CXTPTabManager | CXTPTabManager is a CXTPTabManagerAtom derived class. This is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
CXTPTabManagerAtom | CXTPTabManagerAtom is a class that has only one purpose, which is to catch the event when a property of the PaintManager has changed. When a property of the PaintManager has changed, the OnPropertyChanged event if called. When the OnPropertyChanged is caught, Reposition is called to recalculate self layout.
CXTPTabManagerItem | CXTPTabManagerItem is a CCmdTarget derived class that represents a tab item. This is the base class for the tabs that appear in the CommandBars TabWorkSpace, DockingPanes, and TabControl.
CXTPTabManagerNavigateButton | CXTPTabManagerNavigateButton is a class used to represent the tab navigation buttons.
CXTPTabPaintManager | CXTPTabPaintManager is a CCmdTarget derived class that is used to store the color and appearance information of the tabs in the tab manager.
Files
File | Description
XTPTabControl.h | XTPTabControl.h: interface for the CXTPTabControl class.
XTPTabManager.h | XTPTabManager.h: interface for the CXTPTabManager class.
XTPTabPaintManager.h | XTPTabPaintManager.h: interface for the CXTPTabPaintManager class.
Structs, Records, Enums
Struct, Record, Enum | Description
XTPTabAppearanceStyle | XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.
XTPTabClientFrame | XTPTabClientFrame is an enumeration used to set the client frame style drawn around the client of tabs.
XTPTabColorStyle | XTPTabColorStyle is an enumeration used to set the color style of tabs.
XTPTabLayoutStyle | XTPTabLayoutStyle is an enumeration used to set the layout of tabs.
XTPTabNavigateButton | XTPTabNavigateButton is an enumeration used to identify navigation buttons within a tab control.
XTPTabNavigateButtonFlags | XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed. This style is applied to one button. Navigate buttons include the left, right, and close buttons that appear in the tab header area.
XTPTabOneNoteColor | XTPTabOneNoteColor is an enumeration used to indicate which OneNote COLORREF value to retrieve.
XTPTabPosition | XTPTabPosition is an enumeration used to set the position of tabs.
XTPTabToolTipBehaviour | XTPTabToolTipBehaviour is an enumeration used to set tooltip behaviour for tabs
XTPTabWorkspacePart | XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace needs to be redrawn.
Types
Type | Description
CXTPTabManagerNavigateButtons | Navigate buttons array definition
Variables
Variable | Description
WM_XTP_GETTABCOLOR | The WM_XTP_GETTABCOLOR message is sent to MDI child window to retrieve color will be used for tabbed interface with enabled OneNote colors.
XTP_TABMANAGER_COLOR_NONE | Indicates that a transparent color should be used.
XTP_TABMANAGER_COLOR_SHADED | Indicates a special "shaded" fill type.


Tab Manager Hierarchy

Tab Manager
Tab Manager Hierarchy

Module

Tab Manager


Classes

Classes, Tab Manager
Classes
Classes
Class | Description
CXTPTabControl | CXTPTabControl is a multiple inheritance class derived from CXTPTabManager and CWnd. It is used to draw enhance tab control with Office 2003, Visual Studio, Win XP tabs.
CXTPTabManager | CXTPTabManager is a CXTPTabManagerAtom derived class. This is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
CXTPTabManagerAtom | CXTPTabManagerAtom is a class that has only one purpose, which is to catch the event when a property of the PaintManager has changed. When a property of the PaintManager has changed, the OnPropertyChanged event if called. When the OnPropertyChanged is caught, Reposition is called to recalculate self layout.
CXTPTabManagerItem | CXTPTabManagerItem is a CCmdTarget derived class that represents a tab item. This is the base class for the tabs that appear in the CommandBars TabWorkSpace, DockingPanes, and TabControl.
CXTPTabManagerNavigateButton | CXTPTabManagerNavigateButton is a class used to represent the tab navigation buttons.
CXTPTabPaintManager | CXTPTabPaintManager is a CCmdTarget derived class that is used to store the color and appearance information of the tabs in the tab manager.
Module

Tab Manager


CXTPTabControl Class

XTPTabControl.h, Classes, Legend, Members, Topics, CXTPTabControl Methods, CXTPTabControl Constructors, CXTPTabControl Destructors, CXTPTabControl Constructors, CXTPTabControl Destructors, CXTPTabControl Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabControl Class

CXTPTabControl is a multiple inheritance class derived from CXTPTabManager and CWnd. It is used to draw enhance tab control with Office 2003, Visual Studio, Win XP tabs.

Class Hierarchy

class CXTPTabControl : public CWnd, public CXTPTabManager;
File

XTPTabControl.h

See Also

Create, CXTPTabManager::SetColor, CXTPTabManager::SetAppearance

Group

Classes

Legend
Method
virtual
protected
CXTPTabControl Constructors
CXTPTabControl Constructors | Description
CXTPTabControl | Constructs a CXTPTabControl object.
CXTPTabControl Destructors
CXTPTabControl Destructors | Description
~CXTPTabControl | Destroys a CXTPTabControl object, handles cleanup and de-allocation
CXTPTabControl Methods
CXTPTabControl Methods | Description
AdjustRect | Call this function to calculate a tab control's display area given a window rectangle, or calculate the window rectangle that would correspond to a given display area.
Create | Call this member function to create the Tab Control.
DrawIcon | This member is called when the icon of the tab needs to be drawn.
EnableToolTips | Call this member function to enable or disable tooltips show
GetImageManager | Call this member to get a pointer to the image manager collected icons of tab control.
GetPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
GetToolTipContext | Call this method to get tooltip context pointer.
HeaderHasFocus | This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item
InsertItem | Inserts a new tab at the position specified by nItem.
OnItemClick | This member is called when a tab button is clicked. This will select the tab that was clicked.
OnNavigateButtonClick | This member is called when a tab navigation button is clicked.
RedrawControl | This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.
Reposition | This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.
SetFocusedItem | This method is called to set focused item.
SetImageList | Call this member to set icons of the tabs.
SetImageManager | Call this member to set the specified image manager.
SetPaintManager | Call this member to set a CXTPTabPaintManager object to the tab manager.
SetSelectedItem | Call this member to select a tab.


CXTPTabControl Methods

CXTPTabControl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabControl Methods
Class

CXTPTabControl Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
HeaderHasFocus | This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item
OnNavigateButtonClick | This member is called when a tab navigation button is clicked.
SetFocusedItem | This method is called to set focused item.
Public Methods
Public Methods
Public Method | Description
AdjustRect | Call this function to calculate a tab control's display area given a window rectangle, or calculate the window rectangle that would correspond to a given display area.
Create | Call this member function to create the Tab Control.
DrawIcon | This member is called when the icon of the tab needs to be drawn.
EnableToolTips | Call this member function to enable or disable tooltips show
GetImageManager | Call this member to get a pointer to the image manager collected icons of tab control.
GetPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
GetToolTipContext | Call this method to get tooltip context pointer.
InsertItem | Inserts a new tab at the position specified by nItem.
OnItemClick | This member is called when a tab button is clicked. This will select the tab that was clicked.
RedrawControl | This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.
Reposition | This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.
SetImageList | Call this member to set icons of the tabs.
SetImageManager | Call this member to set the specified image manager.
SetPaintManager | Call this member to set a CXTPTabPaintManager object to the tab manager.
SetSelectedItem | Call this member to select a tab.


CXTPTabControl::AdjustRect Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::AdjustRect Method

Call this function to calculate a tab control's display area given a window rectangle, or calculate the window rectangle that would correspond to a given display area.

void AdjustRect(
    BOOL bLarger,
    LPRECT lpRect
);
Parameters

bLarger
Indicates which operation to perform. If this parameter is TRUE, lpRect specifies a display rectangle and receives the corresponding window rectangle. If this parameter is FALSE, lpRect specifies a window rectangle and receives the corresponding display rectangle.
lpRect
Pointer to aRECT structure that specifies the given rectangle and receives the calculated rectangle.

Group

CXTPTabControl Methods


CXTPTabControl::Create Method

CXTPTabControl Methods, CXTPTabControl Class, See Also
CXTPTabControl::Create Method

Call this member function to create the Tab Control.

BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Style of the Tab Control.
rect
Size of the control.
pParentWnd
Parent of the control.
nID
Identifier of the Tab control.

Returns

TRUE if successful, otherwise returns FALSE.

See Also

CXTPTabControl::CXTPTabControl, GetPaintManager, CXTPTabManager::SetPosition, CXTPTabManager::SetLayout, GetImageManager

Group

CXTPTabControl Methods


CXTPTabControl::DrawIcon Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::DrawIcon Method

This member is called when the icon of the tab needs to be drawn.

virtual BOOL DrawIcon(
    CDC* pDC,
    CPoint pt,
    CXTPTabManagerItem* pItem,
    BOOL bDraw,
    CSize& szIcon
) const;
Parameters

pDC
Pointer to the destination device context.
pt
Specifies the location of the image.
pItem
CXTPTabManagerItem object to draw icon on.
bDraw
TRUE if the icon needs to be drawn, I.e. the icon size changed. FALSE if the icon does not need to be drawn or redrawn.
szIcon
Size of the tab icon.

Returns

TRUE if the icon was successfully drawn, FALSE if the icon was not drawn.

Remarks

For example, on mouse-over. This member is overridden by its descendants. This member must be overridden in derived classes.

Group

CXTPTabControl Methods


CXTPTabControl::EnableToolTips Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::EnableToolTips Method

Call this member function to enable or disable tooltips show

void EnableToolTips(
    XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways
);
Parameters

behaviour
Tooltips behaviour will be set. See remarks section for available flags.

Remarks

behaviour parameter can be one of the following:

  • xtpTabToolTipNever Show tooltips for tabs always
  • xtpTabToolTipAlways Doesn't show toltips for tabs
  • xtpTabToolTipShrinkedOnly Show tooltips only if tab was shrinked (see xtpTabLayoutSizeToFit layout)
Group

CXTPTabControl Methods


CXTPTabControl::GetImageManager Method

CXTPTabControl Methods, CXTPTabControl Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabControl::GetImageManager Method

Call this member to get a pointer to the image manager collected icons of tab control.

CXTPImageManager* GetImageManager() const;
Returns

Pointer to CXTPImageManager that contains the icons of the tabs.

Example
m_wmdTabControl.GetImageManager()->SetIcons(IDR_MAINFRAME);
Body Source
CXTPImageManager* CXTPTabControl::GetImageManager() const {
    return m_pImageManager;
}
Group

CXTPTabControl Methods


CXTPTabControl::GetPaintManager Method

CXTPTabControl Methods, CXTPTabControl Class, Body Source
CXTPTabControl::GetPaintManager Method

Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.

virtual CXTPTabPaintManager* GetPaintManager() const;
Returns

Pointer to CXTPTabPaintManager that contains the visual elements of the tabs.

Body Source
CXTPTabPaintManager* CXTPTabControl::GetPaintManager() const {
    return m_pPaintManager;
}
Group

CXTPTabControl Methods


CXTPTabControl::GetToolTipContext Method

CXTPTabControl Methods, CXTPTabControl Class, Body Source
CXTPTabControl::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Body Source
CXTPToolTipContext* CXTPTabControl::GetToolTipContext() const {
    return m_pToolTipContext;
}
Group

CXTPTabControl Methods


CXTPTabControl::HeaderHasFocus Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::HeaderHasFocus Method

This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item

virtual BOOL HeaderHasFocus() const;
Returns

TRUE if header has has focus

Group

CXTPTabControl Methods


CXTPTabControl::InsertItem Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::InsertItem Method

Inserts a new tab at the position specified by nItem.

CXTPTabManagerItem* InsertItem(
    int nItem,
    LPCTSTR lpszItem,
    HWND hwndChild = NULL,
    int nImage = -1,
    CXTPTabManagerItem* pAddItem = NULL
);
Parameters

nItem
Index of the new tab.
lpszItem
Caption of the new tab.
hwndChild
Handle to the object to be displayed in the tab. I.e. A Dialog page
nImage
Id of image resource to display in tab is icons are displayed.
pAddItem
Item to add or NULL to create default CXTPTabManagerItem item

Returns

A pointer to the newly added CXTPTabManagerItem.

Group

CXTPTabControl Methods


CXTPTabControl::OnItemClick Method

CXTPTabControl Methods, CXTPTabControl Class, See Also
CXTPTabControl::OnItemClick Method

This member is called when a tab button is clicked. This will select the tab that was clicked.

void OnItemClick(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Pointer to the CXTPTabManagerItem tab that was clicked.

See Also

PerformClick

Group

CXTPTabControl Methods


CXTPTabControl::OnNavigateButtonClick Method

CXTPTabControl Methods, CXTPTabControl Class, See Also
CXTPTabControl::OnNavigateButtonClick Method

This member is called when a tab navigation button is clicked.

void OnNavigateButtonClick(
    CXTPTabManagerNavigateButton* pButton
);
Parameters

pButton
Button that was clicked. The button Identifier, can be one of the values listed in the Remarks section.

Remarks

Standard ids of buttons are listed below:

  • xtpTabNavigateButtonLeft Left tab navigation button.
  • xtpTabNavigateButtonRight Right tab navigation button.
  • xtpTabNavigateButtonClose Close tab navigation button.

This method is overridden in CXTPTabClientWnd::CWorkspace and CXTPTabControl to capture when the tab navigation close "x" button was pressed and deletes the tab.

This member is called after CXTPTabManagerNavigateButton::PerformClick.

See Also

CXTPTabManagerNavigateButton::PerformClick, XTPTabNavigateButton

Group

CXTPTabControl Methods


CXTPTabControl::RedrawControl Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::RedrawControl Method

This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.

virtual void RedrawControl(
    LPCRECT lpRect,
    BOOL bAnimate
);
Parameters

lpRect
The rectangular area of the window that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Group

CXTPTabControl Methods


CXTPTabControl::Reposition Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::Reposition Method

This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.

virtual void Reposition();
Group

CXTPTabControl Methods


CXTPTabControl::SetFocusedItem Method

CXTPTabControl Methods, CXTPTabControl Class, See Also
CXTPTabControl::SetFocusedItem Method

This method is called to set focused item.

virtual void SetFocusedItem(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Item that become focused.

See Also

SetSelectedItem

Group

CXTPTabControl Methods


CXTPTabControl::SetImageList Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::SetImageList Method

Call this member to set icons of the tabs.

void SetImageList(
    CImageList* pImageList
);
Parameters

pImageList
Image list containing icons of the tabs

Remarks

Recommended to use GetImageManager method and CXTPImageManager::SetIcons to add icons.

Group

CXTPTabControl Methods


CXTPTabControl::SetImageManager Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::SetImageManager Method

Call this member to set the specified image manager.

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Points to a CXTPImageManager object.

Group

CXTPTabControl Methods


CXTPTabControl::SetPaintManager Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::SetPaintManager Method

Call this member to set a CXTPTabPaintManager object to the tab manager.

virtual void SetPaintManager(
    CXTPTabPaintManager* pPaintManager
);
Parameters

pPaintManager
Pointer to a CXTPTabPaintManager object.

Remarks

The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager.

Group

CXTPTabControl Methods


CXTPTabControl::SetSelectedItem Method

CXTPTabControl Methods, CXTPTabControl Class
CXTPTabControl::SetSelectedItem Method

Call this member to select a tab.

virtual void SetSelectedItem(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Pointer to the tab to be selected.

Group

CXTPTabControl Methods


CXTPTabControl Constructors

CXTPTabControl Class, Legend, Public Methods
CXTPTabControl Constructors
Class

CXTPTabControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabControl | Constructs a CXTPTabControl object.


CXTPTabControl::CXTPTabControl Constructor

CXTPTabControl Constructors, CXTPTabControl Class
CXTPTabControl::CXTPTabControl Constructor

Constructs a CXTPTabControl object.

CXTPTabControl();
Group

CXTPTabControl Constructors


CXTPTabControl Destructors

CXTPTabControl Class, Legend, Public Methods
CXTPTabControl Destructors
Class

CXTPTabControl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTabControl | Destroys a CXTPTabControl object, handles cleanup and de-allocation


CXTPTabControl::~CXTPTabControl Destructor

CXTPTabControl Destructors, CXTPTabControl Class
CXTPTabControl::~CXTPTabControl Destructor

Destroys a CXTPTabControl object, handles cleanup and de-allocation

virtual ~CXTPTabControl();
Group

CXTPTabControl Destructors


CXTPTabManager Class

XTPTabManager.h, Classes, Legend, Members, Topics, CXTPTabManager Classes, CXTPTabManager Structures, CXTPTabManager Data Members, CXTPTabManager Methods, CXTPTabManager Constructors, CXTPTabManager Destructors, CXTPTabManager Classes, CXTPTabManager Constructors, CXTPTabManager Data Members, CXTPTabManager Destructors, CXTPTabManager Methods, See Also, CXTPTabManager Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager Class

CXTPTabManager is a CXTPTabManagerAtom derived class. This is the base class for docking pane tabs, tab control tabs, and MDI client tabs.

Class Hierarchy

class CXTPTabManager : public CXTPTabManagerAtom;
File

XTPTabManager.h

See Also

CXTPTabClientWnd, CXTPDockingPaneTabbedContainer, CXTPTabControl

Group

Classes

Legend
Structure
Data Member
protected
Method
abstract
virtual
CXTPTabManager Classes
CXTPTabManager Classes | Description
CRowIndexer | Helper class used to collect indexes of rows for multirow tab manager
CXTPTabManager Constructors
CXTPTabManager Constructors | Description
CXTPTabManager | Constructs a CXTPTabManager object.
CXTPTabManager Data Members
CXTPTabManager Data Members | Description
m_arrItems | Collection of tabs of this tab manager.
m_arrNavigateButtons | Collection of tab navigation buttons for this tab manager
m_bActive | TRUE if the MDITabClient tab group is active.
m_bAllowReorder | TRUE to allow tabs to be reordered.
m_bCloseItemButton | TRUE to show close button for tabs.
m_nHeaderOffset | Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
m_nScrollDelta | Scroll header delta
m_pHighlighted | Tab currently highlighted.
m_pHighlightedNavigateButton | Pointer to highlighted navigate button
m_pPressed | Tab currently pressed.
m_pRowIndexer | Row indexer;
m_pSelected | Tab currently selected.
m_rcClient | Bounding rectangle of the tab client area.
m_rcControl | Bounding rectangle of the tab manager control.
m_rcHeaderRect | Bounding rectangle of the tab header area.
m_themeTabControl | Internal helper for drawing XP interface parts.
CXTPTabManager Destructors
CXTPTabManager Destructors | Description
~CXTPTabManager | Destroys a CXTPTabManager object, handles cleanup and deallocation.
CXTPTabManager Methods
CXTPTabManager Methods | Description
AddItem | This member is called to add a new or existing CXTPTabManagerItem to the collection of tabs for this tab manager.
DeleteAllItems | Removes all items from a tab manager.
DeleteItem | Removes the specified item from a tab manager.
DrawIcon | This member is called when the icon of the tab needs to be drawn.
DrawParentBackground | This method is called to draw parent background under tab control
EnableMarkup | Call this method to enable markup for tab captions
EnableTabThemeTexture | Call this member function to enable Windows XP themed back color.
EnsureVisible | Call this member to ensure that a tab is visible.
FindNavigateButton | Call this member to get a pointer to one of the tab navigation buttons. Buttons include the left arrow, right arrow, and close buttons in the tab header area.
FindNextFocusable | Call this method to get next of previous focusable tab item
GetAppearance | Call this member to determine the currently set appearance style.
GetAppearanceSet | Call this member to get the currently set custom appearance set.
GetClientRect | Call this member to get the bounding rectangle to the tab client area.
GetColor | Call this member to get the currently used tab color style.
GetColorSet | Call this member to get the currently used custom color set.
GetControlRect | Call this member to get the bounding rectangle to the tab manager control area.
GetCurSel | Call this member to get the index of the currently selected tab.
GetHeaderOffset | Call this member to get the scroll offset of the tab buttons in the tab header. This is how much the tabs have been scrolled by pressing the left "<" and right ">" tab navigation buttons.
GetHeaderRect | Call this member to get the bounding rectangle to the tab client header area.
GetItem | Retrieves information about a tab in a tab manager.
GetItemCaption | Call this member to get the caption text of a tab.
GetItemColor | Call this member to retrieve the color of a tab button.
GetItemCount | Retrieves the number of tabs in the tab manager.
GetItemIcon | Call this member to get the HICON of a CXTPTabManagerItem.
GetItemMetrics | Call this member to get the minimum, maximum, and normal lengths of tab buttons. These are the values used when calculating the lengths of tabs for each XTPTabLayoutStyle.
GetItemsLength | Call this member to get the total width of all the tab buttons.
GetItemTooltip | Call this member to get the tooltip that is displayed when the mouse pointer is positioned over the specified tab button.
GetLayout | Call this member to get the currently used tab layout style.
GetMarkupContext | Returns markup context
GetNavigateButton | This member will retrieve a tab navigation button by its index.
GetNavigateButtonCount | This member is called to get the total number of tab navigation buttons added to the tab header.
GetNavigateButtons | Call this method to get collection of navigate buttons.
GetPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
GetPosition | Call this member to get the current position of the tabs.
GetRectLength | This member is called to get the length of the bounding rectangle of the tab client header area. This is the area that has all of the tab buttons.
GetRowCount | Retrieves the current number of rows in a tab control. Only tab controls that have the xtpTabLayoutMultiRow layout can have multiple rows of tabs.
GetSelectedItem | Call this member to get the currently selected tab.
HeaderHasFocus | This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item
HitTest | This member is called to determine is a CXTPTabManagerItem tab is at a specific x and y coordinate. This can be used to determine if the user clicked on a tab.
HitTestNavigateButton | This member is called to determine is a CXTPTabManagerNavigateButton is at a specific x and y coordinate.
IsActive | Call this member to determine if a group of tabs in the MDITabClient is active. This only applies to groups of tabs in the TabWorkspace with grouping enabled. enabled
IsAllowReorder | Call this member to determine if tab can be reordered.
IsDrawStaticFrame | Call this member to determine if a static frame is used.
IsHorizontalPosition | Call this member to determine if the tabs are positioned horizontally.
IsMouseLocked | This member is called to determine if the MouseMove event have been disabled. This member is overridden in CXTPTabClientWnd::CWorkspace.
IsNavigateButtonAutomaticVisible | Determines if navigate button with xtpTabNavigateButtonAutomatic style is visible.
MoveItem | Call this member to reorder items.
OnBeforeItemClick | This method is called before item click
OnItemClick | This member is called when a tab button is clicked. This will select the tab that was clicked.
OnItemHandleChanged | This method is called when handle of item was changed
OnItemsChanged | This member is called when the tab items have changed. Tab items will change after an item is added, deleted, or reordered.
OnNavigateButtonClick |
OnScrollHeader | This member is called then user press left or right navigate button
PerformClick | This member is called when the user presses the left mouse button.
PerformKeyDown | This method is called to process WM_KEYDOWN event of TabManager
PerformMouseMove | This member is called when the mouse cursor moves.
PerformToolHitTest | This member is called to retrieve tooltip information about a tab and stores the information in a TOOLINFO object.
RedrawControl | This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.
ReOrder | This member is called when a CXTPTabManagerItem is clicked and dragged within the tab header. This will reorder the selected tab to the location it is dragged to.
SetActive | Call this member to make a MDITabClient tab group active. SetActive works only for tab groups in the MDITabClient when group is enabled. Only one group can be active.
SetAllowReorder | Call this member to specify whether the user can reorder the tabs.
SetAppearance | Call this member to apply one of the "built-in" appearances to the tabs.
SetAppearanceSet | Call this member to apply a custom appearance set.
SetColor | Call this member to apply one of the "built-in" color sets to the tabs.
SetColorSet | Call this member to apply a custom color set to the tabs.
SetCurSel | Call this member to select a tab by its index. A selected tab if the currently active tab.
SetFocusedItem | This method is called to set focused item.
SetHeaderOffset | Call this member to adjust the scroll offset of the tabs in the tab header.
SetItemMetrics | Call this member to set the minimum, maximum, and normal lengths of tab buttons. Each is used when calculating the lengths of tabs for each XTPTabLayoutStyle.
SetLayoutStyle | Call this member to set the tab layout style.
SetPaintManager | Call this member to set a CXTPTabPaintManager object to the tab manager.
SetPosition | Call this member to set the position of the tabs.
SetSelectedItem | Call this member to select a CXTPTabManagerItem tab. A selected tab if the currently active tab.
ShowCloseItemButton | Call this member to show close button for each tab
ShowIcons | Call this member to hide or show tab icons.
TrackClick | This method is called to activate tab item on mouse click
CXTPTabManager Structures
CXTPTabManager Structures | Description
ROW_ITEMS | Helper structure contains first and last item index for row of tab manager


CXTPTabManager Classes

Classes, CXTPTabManager Class
CXTPTabManager Classes
Classes
Class | Description
CRowIndexer | Helper class used to collect indexes of rows for multirow tab manager
Class

CXTPTabManager Class


CXTPTabManager::CRowIndexer Class

XTPTabManager.h, CXTPTabManager Classes, Legend, Members, Topics, CRowIndexer Methods, CRowIndexer Constructors, CRowIndexer Destructors, CRowIndexer Constructors, CRowIndexer Destructors, CRowIndexer Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::CRowIndexer Class

Helper class used to collect indexes of rows for multirow tab manager

Class Hierarchy

class CRowIndexer;
File

XTPTabManager.h

Group

CXTPTabManager Classes

Legend
Method
CRowIndexer Constructors
CRowIndexer Constructors | Description
CRowIndexer | Constructs a CRowIndexer object.
CRowIndexer Destructors
CRowIndexer Destructors | Description
~CRowIndexer | Destroys a CRowIndexer object, handles cleanup and deallocation.
CRowIndexer Methods
CRowIndexer Methods | Description
CreateIndexer | This method is called to create array of indexes for multirow tab manager
GetRowItems | Call this method to get indexes for multirow tab manager


CRowIndexer Methods

CXTPTabManager::CRowIndexer Class, Legend, Public Methods
CRowIndexer Methods
Class

CXTPTabManager::CRowIndexer Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
CreateIndexer | This method is called to create array of indexes for multirow tab manager
GetRowItems | Call this method to get indexes for multirow tab manager


CXTPTabManager::CRowIndexer::CreateIndexer Method

CRowIndexer Methods, CXTPTabManager::CRowIndexer Class
CXTPTabManager::CRowIndexer::CreateIndexer Method

This method is called to create array of indexes for multirow tab manager

ROW_ITEMS* CreateIndexer(
    int nRowCount
);
Parameters

nRowCount
total rows in TabManager.

Returns

Returns Items indexes for each row.

Group

CRowIndexer Methods


CXTPTabManager::CRowIndexer::GetRowItems Method

CRowIndexer Methods, CXTPTabManager::CRowIndexer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::CRowIndexer::GetRowItems Method

Call this method to get indexes for multirow tab manager

ROW_ITEMS* GetRowItems() const;
Body Source
CXTPTabManager::ROW_ITEMS* CXTPTabManager::CRowIndexer::GetRowItems() const {
    return m_pRowItems;
}
Group

CRowIndexer Methods


CRowIndexer Constructors

CXTPTabManager::CRowIndexer Class, Legend, Public Methods
CRowIndexer Constructors
Class

CXTPTabManager::CRowIndexer Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CRowIndexer | Constructs a CRowIndexer object.


CXTPTabManager::CRowIndexer::CRowIndexer Constructor

CRowIndexer Constructors, CXTPTabManager::CRowIndexer Class
CXTPTabManager::CRowIndexer::CRowIndexer Constructor

Constructs a CRowIndexer object.

CRowIndexer(
    CXTPTabManager* pManager
);
Parameters

pManager
Owner tab manager

Group

CRowIndexer Constructors


CRowIndexer Destructors

CXTPTabManager::CRowIndexer Class, Legend, Public Methods
CRowIndexer Destructors
Class

CXTPTabManager::CRowIndexer Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CRowIndexer | Destroys a CRowIndexer object, handles cleanup and deallocation.


CXTPTabManager::CRowIndexer::~CRowIndexer Destructor

CRowIndexer Destructors, CXTPTabManager::CRowIndexer Class
CXTPTabManager::CRowIndexer::~CRowIndexer Destructor

Destroys a CRowIndexer object, handles cleanup and deallocation.

~CRowIndexer();
Group

CRowIndexer Destructors


CXTPTabManager Structures

CXTPTabManager Class, Legend, Structures
CXTPTabManager Structures
Class

CXTPTabManager Class

Legend
Structure
Structures
Structure | Description
ROW_ITEMS | Helper structure contains first and last item index for row of tab manager


CXTPTabManager::ROW_ITEMS Structure

XTPTabManager.h, CXTPTabManager Structures
CXTPTabManager::ROW_ITEMS Structure

Helper structure contains first and last item index for row of tab manager

struct ROW_ITEMS {
  int nFirstItem;
  int nLastItem;
};
File

XTPTabManager.h

Members

nFirstItem
First item index of row
nLastItem
Last item index of row

Group

CXTPTabManager Structures


CXTPTabManager Data Members

CXTPTabManager Class, Legend, Protected Data Members
CXTPTabManager Data Members
Class

CXTPTabManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrItems | Collection of tabs of this tab manager.
m_arrNavigateButtons | Collection of tab navigation buttons for this tab manager
m_bActive | TRUE if the MDITabClient tab group is active.
m_bAllowReorder | TRUE to allow tabs to be reordered.
m_bCloseItemButton | TRUE to show close button for tabs.
m_nHeaderOffset | Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
m_nScrollDelta | Scroll header delta
m_pHighlighted | Tab currently highlighted.
m_pHighlightedNavigateButton | Pointer to highlighted navigate button
m_pPressed | Tab currently pressed.
m_pRowIndexer | Row indexer;
m_pSelected | Tab currently selected.
m_rcClient | Bounding rectangle of the tab client area.
m_rcControl | Bounding rectangle of the tab manager control.
m_rcHeaderRect | Bounding rectangle of the tab header area.
m_themeTabControl | Internal helper for drawing XP interface parts.


CXTPTabManager::m_arrItems Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_arrItems Data Member

Collection of tabs of this tab manager.

CArray<CXTPTabManagerItem*, CXTPTabManagerItem*> m_arrItems;
Group

CXTPTabManager Data Members


CXTPTabManager::m_arrNavigateButtons Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_arrNavigateButtons Data Member

Collection of tab navigation buttons for this tab manager

CXTPTabManagerNavigateButtons m_arrNavigateButtons;
Group

CXTPTabManager Data Members


CXTPTabManager::m_bActive Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_bActive Data Member

TRUE if the MDITabClient tab group is active.

BOOL m_bActive;
Group

CXTPTabManager Data Members


CXTPTabManager::m_bAllowReorder Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_bAllowReorder Data Member

TRUE to allow tabs to be reordered.

BOOL m_bAllowReorder;
Group

CXTPTabManager Data Members


CXTPTabManager::m_bCloseItemButton Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_bCloseItemButton Data Member

TRUE to show close button for tabs.

XTPTabNavigateButtonFlags m_bCloseItemButton;
Group

CXTPTabManager Data Members


CXTPTabManager::m_nHeaderOffset Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_nHeaderOffset Data Member

Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.

int m_nHeaderOffset;
Group

CXTPTabManager Data Members


CXTPTabManager::m_nScrollDelta Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_nScrollDelta Data Member

Scroll header delta

int m_nScrollDelta;
Group

CXTPTabManager Data Members


CXTPTabManager::m_pHighlighted Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_pHighlighted Data Member

Tab currently highlighted.

CXTPTabManagerItem* m_pHighlighted;
Group

CXTPTabManager Data Members


CXTPTabManager::m_pHighlightedNavigateButton Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_pHighlightedNavigateButton Data Member

Pointer to highlighted navigate button

CXTPTabManagerNavigateButton* m_pHighlightedNavigateButton;
Group

CXTPTabManager Data Members


CXTPTabManager::m_pPressed Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_pPressed Data Member

Tab currently pressed.

CXTPTabManagerItem* m_pPressed;
Group

CXTPTabManager Data Members


CXTPTabManager::m_pRowIndexer Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_pRowIndexer Data Member

Row indexer;

CRowIndexer* m_pRowIndexer;
Group

CXTPTabManager Data Members


CXTPTabManager::m_pSelected Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_pSelected Data Member

Tab currently selected.

CXTPTabManagerItem* m_pSelected;
Group

CXTPTabManager Data Members


CXTPTabManager::m_rcClient Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_rcClient Data Member

Bounding rectangle of the tab client area.

CRect m_rcClient;
Group

CXTPTabManager Data Members


CXTPTabManager::m_rcControl Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_rcControl Data Member

Bounding rectangle of the tab manager control.

CRect m_rcControl;
Group

CXTPTabManager Data Members


CXTPTabManager::m_rcHeaderRect Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_rcHeaderRect Data Member

Bounding rectangle of the tab header area.

CRect m_rcHeaderRect;
Group

CXTPTabManager Data Members


CXTPTabManager::m_themeTabControl Data Member

CXTPTabManager Data Members, CXTPTabManager Class
CXTPTabManager::m_themeTabControl Data Member

Internal helper for drawing XP interface parts.

CXTPWinThemeWrapper m_themeTabControl;
Group

CXTPTabManager Data Members


CXTPTabManager Methods

CXTPTabManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager Methods
Class

CXTPTabManager Class

Legend
Method
protected
virtual
abstract
Protected Methods
Protected Methods
Protected Method | Description
AddItem | This member is called to add a new or existing CXTPTabManagerItem to the collection of tabs for this tab manager.
HeaderHasFocus | This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item
IsMouseLocked | This member is called to determine if the MouseMove event have been disabled. This member is overridden in CXTPTabClientWnd::CWorkspace.
IsNavigateButtonAutomaticVisible | Determines if navigate button with xtpTabNavigateButtonAutomatic style is visible.
OnBeforeItemClick | This method is called before item click
OnItemClick | This member is called when a tab button is clicked. This will select the tab that was clicked.
OnItemHandleChanged | This method is called when handle of item was changed
OnNavigateButtonClick |
ReOrder | This member is called when a CXTPTabManagerItem is clicked and dragged within the tab header. This will reorder the selected tab to the location it is dragged to.
TrackClick | This method is called to activate tab item on mouse click
Public Methods
Public Methods
Public Method | Description
DeleteAllItems | Removes all items from a tab manager.
DeleteItem | Removes the specified item from a tab manager.
DrawIcon | This member is called when the icon of the tab needs to be drawn.
DrawParentBackground | This method is called to draw parent background under tab control
EnableMarkup | Call this method to enable markup for tab captions
EnableTabThemeTexture | Call this member function to enable Windows XP themed back color.
EnsureVisible | Call this member to ensure that a tab is visible.
FindNavigateButton | Call this member to get a pointer to one of the tab navigation buttons. Buttons include the left arrow, right arrow, and close buttons in the tab header area.
FindNextFocusable | Call this method to get next of previous focusable tab item
GetAppearance | Call this member to determine the currently set appearance style.
GetAppearanceSet | Call this member to get the currently set custom appearance set.
GetClientRect | Call this member to get the bounding rectangle to the tab client area.
GetColor | Call this member to get the currently used tab color style.
GetColorSet | Call this member to get the currently used custom color set.
GetControlRect | Call this member to get the bounding rectangle to the tab manager control area.
GetCurSel | Call this member to get the index of the currently selected tab.
GetHeaderOffset | Call this member to get the scroll offset of the tab buttons in the tab header. This is how much the tabs have been scrolled by pressing the left "<" and right ">" tab navigation buttons.
GetHeaderRect | Call this member to get the bounding rectangle to the tab client header area.
GetItem | Retrieves information about a tab in a tab manager.
GetItemCaption | Call this member to get the caption text of a tab.
GetItemColor | Call this member to retrieve the color of a tab button.
GetItemCount | Retrieves the number of tabs in the tab manager.
GetItemIcon | Call this member to get the HICON of a CXTPTabManagerItem.
GetItemMetrics | Call this member to get the minimum, maximum, and normal lengths of tab buttons. These are the values used when calculating the lengths of tabs for each XTPTabLayoutStyle.
GetItemsLength | Call this member to get the total width of all the tab buttons.
GetItemTooltip | Call this member to get the tooltip that is displayed when the mouse pointer is positioned over the specified tab button.
GetLayout | Call this member to get the currently used tab layout style.
GetMarkupContext | Returns markup context
GetNavigateButton | This member will retrieve a tab navigation button by its index.
GetNavigateButtonCount | This member is called to get the total number of tab navigation buttons added to the tab header.
GetNavigateButtons | Call this method to get collection of navigate buttons.
GetPaintManager | Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.
GetPosition | Call this member to get the current position of the tabs.
GetRectLength | This member is called to get the length of the bounding rectangle of the tab client header area. This is the area that has all of the tab buttons.
GetRowCount | Retrieves the current number of rows in a tab control. Only tab controls that have the xtpTabLayoutMultiRow layout can have multiple rows of tabs.
GetSelectedItem | Call this member to get the currently selected tab.
HitTest | This member is called to determine is a CXTPTabManagerItem tab is at a specific x and y coordinate. This can be used to determine if the user clicked on a tab.
HitTestNavigateButton | This member is called to determine is a CXTPTabManagerNavigateButton is at a specific x and y coordinate.
IsActive | Call this member to determine if a group of tabs in the MDITabClient is active. This only applies to groups of tabs in the TabWorkspace with grouping enabled. enabled
IsAllowReorder | Call this member to determine if tab can be reordered.
IsDrawStaticFrame | Call this member to determine if a static frame is used.
IsHorizontalPosition | Call this member to determine if the tabs are positioned horizontally.
MoveItem | Call this member to reorder items.
OnItemsChanged | This member is called when the tab items have changed. Tab items will change after an item is added, deleted, or reordered.
OnScrollHeader | This member is called then user press left or right navigate button
PerformClick | This member is called when the user presses the left mouse button.
PerformKeyDown | This method is called to process WM_KEYDOWN event of TabManager
PerformMouseMove | This member is called when the mouse cursor moves.
PerformToolHitTest | This member is called to retrieve tooltip information about a tab and stores the information in a TOOLINFO object.
RedrawControl | This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.
SetActive | Call this member to make a MDITabClient tab group active. SetActive works only for tab groups in the MDITabClient when group is enabled. Only one group can be active.
SetAllowReorder | Call this member to specify whether the user can reorder the tabs.
SetAppearance | Call this member to apply one of the "built-in" appearances to the tabs.
SetAppearanceSet | Call this member to apply a custom appearance set.
SetColor | Call this member to apply one of the "built-in" color sets to the tabs.
SetColorSet | Call this member to apply a custom color set to the tabs.
SetCurSel | Call this member to select a tab by its index. A selected tab if the currently active tab.
SetFocusedItem | This method is called to set focused item.
SetHeaderOffset | Call this member to adjust the scroll offset of the tabs in the tab header.
SetItemMetrics | Call this member to set the minimum, maximum, and normal lengths of tab buttons. Each is used when calculating the lengths of tabs for each XTPTabLayoutStyle.
SetLayoutStyle | Call this member to set the tab layout style.
SetPaintManager | Call this member to set a CXTPTabPaintManager object to the tab manager.
SetPosition | Call this member to set the position of the tabs.
SetSelectedItem | Call this member to select a CXTPTabManagerItem tab. A selected tab if the currently active tab.
ShowCloseItemButton | Call this member to show close button for each tab
ShowIcons | Call this member to hide or show tab icons.


CXTPTabManager::AddItem Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::AddItem Method

This member is called to add a new or existing CXTPTabManagerItem to the collection of tabs for this tab manager.

CXTPTabManagerItem* AddItem(
    int nItem,
    CXTPTabManagerItem* pItem = NULL
);
Parameters

nItem
Position in the collection of CXTPTabManagerItem tabs to add or insert the CXTPTabManagerItem. If the position specified is less than 0 or greater than the amount of tabs in the collection, then it will be added to the end of the collection.
pItem
CXTPTabManagerItem to insert into the collection of tabs. If NULL, then a new CXTPTabManagerItem will be created and inserted at the specified position.

Returns

Pointer to the newly added CXTPTabManagerItem.

Remarks

This member is overridden in its derives classes to provide additional functionality, then this base class member is called.

Group

CXTPTabManager Methods


CXTPTabManager::DeleteAllItems Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::DeleteAllItems Method

Removes all items from a tab manager.

void DeleteAllItems();
Group

CXTPTabManager Methods


CXTPTabManager::DeleteItem Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::DeleteItem Method

Removes the specified item from a tab manager.

BOOL DeleteItem(
    int nItem
);
Parameters

nItem
Zero-based value of the item to delete.

Returns

Nonzero if successful; otherwise 0.

Group

CXTPTabManager Methods


CXTPTabManager::DrawIcon Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::DrawIcon Method

This member is called when the icon of the tab needs to be drawn.

virtual BOOL DrawIcon(
    CDC* pDC,
    CPoint pt,
    CXTPTabManagerItem* pItem,
    BOOL bDraw,
    CSize& szIcon
) const = 0;
Parameters

pDC
Pointer to the destination device context.
pt
Specifies the location of the image.
pItem
CXTPTabManagerItem object to draw icon on.
bDraw
TRUE if the icon needs to be drawn, I.e. the icon size changed. FALSE if the icon does not need to be drawn or redrawn.
szIcon
Size of the tab icon.

Returns

TRUE if the icon was successfully drawn, FALSE if the icon was not drawn.

Remarks

For example, on mouse-over. This member is overridden by its descendants. This member must be overridden in derived classes.

Group

CXTPTabManager Methods


CXTPTabManager::DrawParentBackground Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source
CXTPTabManager::DrawParentBackground Method

This method is called to draw parent background under tab control

virtual BOOL DrawParentBackground(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to valid device context
rc
Bounding rectangle

Returns

TRUE if rectangle was filled.

Body Source
BOOL CXTPTabManager::DrawParentBackground(CDC* /*pDC*/, CRect /*rc*/) {
    return FALSE;
}
Group

CXTPTabManager Methods


CXTPTabManager::EnableMarkup Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::EnableMarkup Method

Call this method to enable markup for tab captions

void EnableMarkup(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable markup

Group

CXTPTabManager Methods


CXTPTabManager::EnableTabThemeTexture Method

CXTPTabManager Methods, CXTPTabManager Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::EnableTabThemeTexture Method

Call this member function to enable Windows XP themed back color.

void EnableTabThemeTexture(
    HWND hWnd,
    BOOL bEnable = TRUE
);
Parameters

hWnd
The window handle of the target object or dialog.
bEnable
TRUE to enable Windows XP themed back color, FALSE to disable Windows XP themed back color.

Remarks

This should only be used when the tab color is set to xtpTabColorWinXP.

See Also

XTPTabColorStyle, GetColor, SetColor

Example

This sample code illustrates how to apply a Windows XP themed back color to a tab control.

m_wndTabControl.GetPaintManager()->SetColor(xtpTabColorWinXP);
XTPTabColorStyle color = m_wndTabControl.GetPaintManager()->GetColor();
m_wndTabControl.EnableTabThemeTexture(m_wndTabControl.GetSafeHwnd(), color == xtpTabColorWinXP ? TRUE : FALSE);
RedrawWindow();
Group

CXTPTabManager Methods


CXTPTabManager::EnsureVisible Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::EnsureVisible Method

Call this member to ensure that a tab is visible.

void EnsureVisible(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
CXTPTabManagerItem tab to make visible.

See Also

SetHeaderOffset, GetHeaderOffset

Group

CXTPTabManager Methods


CXTPTabManager::FindNavigateButton Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::FindNavigateButton Method

Call this member to get a pointer to one of the tab navigation buttons. Buttons include the left arrow, right arrow, and close buttons in the tab header area.

CXTPTabManagerNavigateButton* FindNavigateButton(
    UINT nID
) const;
Parameters

nID
Id of the button, can be one of the values listed in the Remarks section.

Returns

Pointer to the specified navigation button.

Remarks

Standard ids of buttons are listed below:

  • xtpTabNavigateButtonLeft Left tab navigation button.
  • xtpTabNavigateButtonRight Right tab navigation button.
  • xtpTabNavigateButtonClose Close tab navigation button.
See Also

XTPTabNavigateButton

Group

CXTPTabManager Methods


CXTPTabManager::FindNextFocusable Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::FindNextFocusable Method

Call this method to get next of previous focusable tab item

CXTPTabManagerItem* FindNextFocusable(
    int nIndex,
    int nDirection
) const;
Parameters

nIndex
Index to start find
nDirection
Direction to find (+1 or -1)

Returns

Pointer to next focusable item

Remarks

Tab is focusable if visible and enabled

See Also

CXTPTabManagerItem

Group

CXTPTabManager Methods


CXTPTabManager::GetAppearance Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetAppearance Method

Call this member to determine the currently set appearance style.

XTPTabAppearanceStyle GetAppearance() const;
Returns

The currently set XTPTabAppearanceStyle.

Remarks

The appearance is the physical structure of the tab buttons.

See Also

XTPTabAppearanceStyle, GetAppearanceSet, SetAppearanceSet, SetAppearance

Body Source
XTPTabAppearanceStyle CXTPTabManager::GetAppearance() const {
    return GetPaintManager()->GetAppearance();
}
Group

CXTPTabManager Methods


CXTPTabManager::GetAppearanceSet Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetAppearanceSet Method

Call this member to get the currently set custom appearance set.

CXTPTabPaintManager::CAppearanceSet* GetAppearanceSet() const;
Returns

Pointer to the currently used custom appearance set.

Remarks

An appearance set specifies how the tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance style will have a half hexagon shape. SetColorSet is used to set custom colors.

See the GUI_Eclipse sample for an example of how to create a custom appearance set and apply it to the tabs.

See Also

GetAppearanceSet, SetAppearanceSet, SetAppearance

Body Source
CXTPTabPaintManager::CAppearanceSet* CXTPTabManager::GetAppearanceSet() const {
    return GetPaintManager()->GetAppearanceSet();
}
Group

CXTPTabManager Methods


CXTPTabManager::GetClientRect Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetClientRect Method

Call this member to get the bounding rectangle to the tab client area.

CRect GetClientRect() const;
Returns

Bounding rectangle of tab client area.

See Also

GetHeaderRect, GetControlRect

Body Source
CRect CXTPTabManager::GetClientRect() const {
    return m_rcClient;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetColor Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetColor Method

Call this member to get the currently used tab color style.

XTPTabColorStyle GetColor() const;
Returns

Currently used color style.

Remarks

Color styles are used to colorize the tabs. For example, applying the xtpTabColorWinXP color style will give the tabs Windows XP colorization.

See Also

XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

Body Source
XTPTabColorStyle CXTPTabManager::GetColor() const {
    return GetPaintManager()->GetColor();
}
Group

CXTPTabManager Methods


CXTPTabManager::GetColorSet Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetColorSet Method

Call this member to get the currently used custom color set.

CXTPTabPaintManager::CColorSet* GetColorSet() const;
Returns

Currently used custom color set.

See Also

XTPTabColorStyle, GetColor, SetColorSet, SetColor

Body Source
CXTPTabPaintManager::CColorSet* CXTPTabManager::GetColorSet() const {
    return GetPaintManager()->GetColorSet();
}
Group

CXTPTabManager Methods


CXTPTabManager::GetControlRect Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetControlRect Method

Call this member to get the bounding rectangle to the tab manager control area.

CRect GetControlRect() const;
Returns

Bounding rectangle of tab manager control area.

See Also

GetHeaderRect, GetClientRect

Body Source
CRect CXTPTabManager::GetControlRect() const {
    return m_rcControl;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetCurSel Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::GetCurSel Method

Call this member to get the index of the currently selected tab.

int GetCurSel() const;
Returns

Index of the currently selected tab.

Remarks

Gets the index of m_pSelected, which is the currently selected tab. The currently selected tab can be retrieved with the GetSelectedItem member.

See Also

CXTPTabManagerItem, SetSelectedItem, SetCurSel, GetSelectedItem

Group

CXTPTabManager Methods


CXTPTabManager::GetHeaderOffset Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetHeaderOffset Method

Call this member to get the scroll offset of the tab buttons in the tab header. This is how much the tabs have been scrolled by pressing the left "<" and right ">" tab navigation buttons.

int GetHeaderOffset() const;
Returns

The scroll offset of the tab buttons in the tab header.

Remarks

The scroll offset starts at zero. The offset will remain at zero until there are enough tabs to scroll. If the tabs are scrolled, the offset will be a negative number indicating how much the tabs have been scrolled to the right.

Notes

GetHeaderOffset and SetHeaderOffset are used when the left and right tab navigate buttons are pressed to scroll the tabs by 20 pixels to the left or right.

EnsureVisible uses GetHeaderOffset and SetHeaderOffset to ensure that a tab button is visible.

See Also

SetHeaderOffset, CXTPTabManagerNavigateButton, EnsureVisible

Example

This sample illustrate how to programmatically set the scroll offset of the tabs in the tab header of the CXTPTabClientWnd.

//Scroll the tabs in the tab header to the right by 100 pixels.
m_MTIClientWnd.GetWorkspace(0)->SetHeaderOffset((m_MTIClientWnd.GetWorkspace(0)->GetHeaderOffset()) - 100);

//Scroll the tabs in the tab header to the left by 100 pixels.//
m_MTIClientWnd.GetWorkspace(0)->SetHeaderOffset((m_MTIClientWnd.GetWorkspace(0)->GetHeaderOffset()) + 100);
Body Source
int CXTPTabManager::GetHeaderOffset() const {
    return m_nHeaderOffset;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetHeaderRect Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetHeaderRect Method

Call this member to get the bounding rectangle to the tab client header area.

CRect GetHeaderRect() const;
Returns

Bounding rectangle of tab header area.

See Also

GetClientRect, GetControlRect

Body Source
CRect CXTPTabManager::GetHeaderRect() const {
    return m_rcHeaderRect;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetItem Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source
CXTPTabManager::GetItem Method

Retrieves information about a tab in a tab manager.

CXTPTabManagerItem* GetItem(
    int nIndex
) const;
Parameters

nIndex
Zero-based index of the tab.

Returns

Pointer to CXTPTabManagerItem if successful; NULL otherwise.

Body Source
CXTPTabManagerItem* CXTPTabManager::GetItem(int nIndex) const {
    return nIndex >= 0 && nIndex < GetItemCount() ? m_arrItems[nIndex] : NULL;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetItemCaption Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::GetItemCaption Method

Call this member to get the caption text of a tab.

virtual CString GetItemCaption(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
CXTPTabManagerItem tab item.

Returns

Caption text of the specified tab.

Group

CXTPTabManager Methods


CXTPTabManager::GetItemColor Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::GetItemColor Method

Call this member to retrieve the color of a tab button.

virtual COLORREF GetItemColor(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
Tab to get color from.

Returns

The color of the tab button.

See Also

CXTPTabManagerItem::SetColor, CXTPTabManagerItem::GetColor

Group

CXTPTabManager Methods


CXTPTabManager::GetItemCount Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source
CXTPTabManager::GetItemCount Method

Retrieves the number of tabs in the tab manager.

int GetItemCount() const;
Returns

Number of items in the tab manager.

Body Source
int CXTPTabManager::GetItemCount() const {
    return (int)m_arrItems.GetSize();
}
Group

CXTPTabManager Methods


CXTPTabManager::GetItemIcon Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::GetItemIcon Method

Call this member to get the HICON of a CXTPTabManagerItem.

virtual HICON GetItemIcon(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
CXTPTabManagerItem to get HICON from.

Returns

HICON of specified CXTPTabManagerItem.

Group

CXTPTabManager Methods


CXTPTabManager::GetItemMetrics Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::GetItemMetrics Method

Call this member to get the minimum, maximum, and normal lengths of tab buttons. These are the values used when calculating the lengths of tabs for each XTPTabLayoutStyle.

virtual void GetItemMetrics(
    CSize* szNormal,
    CSize* szMin = NULL,
    CSize* szMax = NULL
) const;
Parameters

szNormal
Used only when XTPTabLayoutStyle = xtpTabLayoutFixed. All tabs will have a length of szNormal with this layout. For all other layouts, szMin and szMax are used as bounds for the available length of a single tab.
szMin
Minimum length of a single tab when layout is not xtpTabLayoutFixed.
szMax
Maximum length of a single tab when layout is not xtpTabLayoutFixed.

Remarks

szNormal is only used to size tabs when the layout is xtpTabLayoutFixed. szMin and szMax are used to calculate the length of tabs for all other layouts. For example, SetItemMetrics might be called to set the maximum available length for a tab when using the xtpTabLayoutSizeToFit layout.

See Also

XTPTabLayoutStyle, SetItemMetrics, SetLayoutStyle

Group

CXTPTabManager Methods


CXTPTabManager::GetItemsLength Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::GetItemsLength Method

Call this member to get the total width of all the tab buttons.

int GetItemsLength() const;
Returns

Total width of all the tab buttons.

Remarks

The width might change depending on the tab layout and position of the tabs.

See Also

XTPTabLayoutStyle, XTPTabPosition

Group

CXTPTabManager Methods


CXTPTabManager::GetItemTooltip Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::GetItemTooltip Method

Call this member to get the tooltip that is displayed when the mouse pointer is positioned over the specified tab button.

virtual CString GetItemTooltip(
    const CXTPTabManagerItem* pItem
) const;
Parameters

pItem
Get tooltip of this CXTPTabManagerItem tab.

Returns

The tooltip that is displayed when the mouse if over the specified tab button.

See Also

CXTPTabManagerItem::SetTooltip, CXTPTabManagerItem::GetTooltip

Group

CXTPTabManager Methods


CXTPTabManager::GetLayout Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::GetLayout Method

Call this member to get the currently used tab layout style.

XTPTabLayoutStyle GetLayout() const;
Returns

Currently set tab layout style.

Remarks

The layout refers to how the tabs are sized within the tab header. Tabs can be in a compressed, fixed, auto size, or sized-to-fit layout.

See Also

XTPTabLayoutStyle, SetLayoutStyle

Group

CXTPTabManager Methods


CXTPTabManager::GetMarkupContext Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source
CXTPTabManager::GetMarkupContext Method

Returns markup context

CXTPMarkupContext* GetMarkupContext() const;
Body Source
CXTPMarkupContext* CXTPTabManager::GetMarkupContext() const {
    return m_pMarkupContext;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetNavigateButton Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetNavigateButton Method

This member will retrieve a tab navigation button by its index.

CXTPTabManagerNavigateButton* GetNavigateButton(
    int nIndex
) const;
Parameters

nIndex
Zero based index into the array of tab navigation buttons.

Returns

A CXTPTabManagerNavigateButton object that represents the tab navigation button at the specified index.

Remarks

Call this member function to retrieve a tab navigation button by its index in button array m_arrNavigateButtons.

See Also

GetNavigateButtonCount, CXTPTabManagerNavigateButton, OnNavigateButtonClick

Body Source
CXTPTabManagerNavigateButton* CXTPTabManager::GetNavigateButton(int nIndex) const {
    return nIndex >= 0 && nIndex < GetNavigateButtonCount() ? m_arrNavigateButtons[nIndex] : NULL;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetNavigateButtonCount Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetNavigateButtonCount Method

This member is called to get the total number of tab navigation buttons added to the tab header.

int GetNavigateButtonCount() const;
Returns

Total number of tab navigation buttons added to this tab manager.

See Also

GetNavigateButton, CXTPTabManagerNavigateButton, OnNavigateButtonClick

Body Source
int CXTPTabManager::GetNavigateButtonCount() const {
    return (int)m_arrNavigateButtons.GetSize();
}
Group

CXTPTabManager Methods


CXTPTabManager::GetNavigateButtons Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetNavigateButtons Method

Call this method to get collection of navigate buttons.

CXTPTabManagerNavigateButtons* GetNavigateButtons();
Returns

Array of CXTPTabManagerNavigateButton classes.

See Also

CXTPTabManagerNavigateButtons, CXTPTabManagerNavigateButton

Body Source
CXTPTabManagerNavigateButtons* CXTPTabManager::GetNavigateButtons() {
    return &m_arrNavigateButtons;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetPaintManager Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::GetPaintManager Method

Call this member to get a pointer to the tab paint manager. The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager. I.e. Tab colors, styles, etc... This member must be overridden in derived classes.

virtual CXTPTabPaintManager* GetPaintManager() const = 0;
Returns

Pointer to CXTPTabPaintManager that contains the visual elements of the tabs.

Group

CXTPTabManager Methods


CXTPTabManager::GetPosition Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::GetPosition Method

Call this member to get the current position of the tabs.

virtual XTPTabPosition GetPosition() const;
Returns

Current XTPTabPosition of the tabs.

Remarks

The position refers to where the tabs are located in relation to the TabClient. The tabs can be positioned on the top, bottom, left, or right side of the TabClient.

See Also

XTPTabPosition, SetPosition

Group

CXTPTabManager Methods


CXTPTabManager::GetRectLength Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetRectLength Method

This member is called to get the length of the bounding rectangle of the tab client header area. This is the area that has all of the tab buttons.

int GetRectLength(
    CRect rc
) const;
Parameters

rc
Bounding rectangle of tab client header area

Returns

If tabs are horizontal, then the width of the tab client header area is returned. If the tabs are vertical, then the height of the tab client header area is returned.

See Also

GetAppearanceSet, CAppearanceSet::GetHeaderRect

Body Source
int CXTPTabManager::GetRectLength(CRect rc) const {
    if (IsHorizontalPosition()) return rc.Width();
    return rc.Height();
}
Group

CXTPTabManager Methods


CXTPTabManager::GetRowCount Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetRowCount Method

Retrieves the current number of rows in a tab control. Only tab controls that have the xtpTabLayoutMultiRow layout can have multiple rows of tabs.

int GetRowCount() const;
Returns

The number of rows of tabs in the tab control.

See Also

SetLayoutStyle, CXTPTabManagerItem::GetItemRow

Body Source
int CXTPTabManager::GetRowCount() const {
    return m_pRowIndexer->m_nRowCount;
}
Group

CXTPTabManager Methods


CXTPTabManager::GetSelectedItem Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::GetSelectedItem Method

Call this member to get the currently selected tab.

CXTPTabManagerItem* GetSelectedItem() const;
Returns

Pointer to the currently selected CXTPTabManagerItem tab.

Remarks

A tab is selected when it has focus or is clicked.

See Also

CXTPTabManagerItem, SetSelectedItem, SetCurSel, GetCurSel

Body Source
CXTPTabManagerItem* CXTPTabManager::GetSelectedItem() const {
    return m_pSelected;
}
Group

CXTPTabManager Methods


CXTPTabManager::HeaderHasFocus Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source
CXTPTabManager::HeaderHasFocus Method

This virtual member is called to determine if control has focus and need to draw focused rectangle around focused item

virtual BOOL HeaderHasFocus() const;
Returns

TRUE if header has has focus

Body Source
BOOL CXTPTabManager::HeaderHasFocus() const {
    return FALSE;
}
Group

CXTPTabManager Methods


CXTPTabManager::HitTest Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::HitTest Method

This member is called to determine is a CXTPTabManagerItem tab is at a specific x and y coordinate. This can be used to determine if the user clicked on a tab.

CXTPTabManagerItem* HitTest(
    CPoint point
) const;
Parameters

point
CPoint to test.

Returns

If a CXTPTabManagerItem is at the specified point, then the tab at the point is returned, otherwise NULL is returned.

Remarks

The tab must both be visible and enabled or NULL will be returned.

See Also

PerformClick, PerformMouseMove

Group

CXTPTabManager Methods


CXTPTabManager::HitTestNavigateButton Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::HitTestNavigateButton Method

This member is called to determine is a CXTPTabManagerNavigateButton is at a specific x and y coordinate.

CXTPTabManagerNavigateButton* HitTestNavigateButton(
    CPoint point,
    BOOL bHeaderOnly,
    int* pnIndex = NULL
) const;
Parameters

point
CPoint to test.
bHeaderOnly
FALSE to not test buttons that located in items
pnIndex
Index of button to retrieve

Returns

If a CXTPTabManagerNavigateButton is at the specified point, then the button at the point is returned, otherwise NULL is returned.

See Also

HitTest

Group

CXTPTabManager Methods


CXTPTabManager::IsActive Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::IsActive Method

Call this member to determine if a group of tabs in the MDITabClient is active. This only applies to groups of tabs in the TabWorkspace with grouping enabled. enabled

BOOL IsActive() const;
Returns

TRUE if this group of tabs is active, FALSE otherwise.

Remarks

When grouping is enabled, each tab group has its own CXTPTabManager. SetActive is used to activateset focus to the tab group.

Notes

This only applies to tab groups in the MDITabClient, this is the tabs that appear in the CommandBars TabWorkspace.

See Also

SetActive, CXTPTabClientWnd::Attach

Body Source
BOOL CXTPTabManager::IsActive() const {
    return m_bActive;
}
Group

CXTPTabManager Methods


CXTPTabManager::IsAllowReorder Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::IsAllowReorder Method

Call this member to determine if tab can be reordered.

virtual BOOL IsAllowReorder() const;
Returns

TRUE id tabs can be reordered, FALSE if tabs cannot be reordered.

See Also

SetAllowReorder

Body Source
BOOL CXTPTabManager::IsAllowReorder() const {
    return m_bAllowReorder;
}
Group

CXTPTabManager Methods


CXTPTabManager::IsDrawStaticFrame Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::IsDrawStaticFrame Method

Call this member to determine if a static frame is used.

virtual BOOL IsDrawStaticFrame() const;
Returns

TRUE if a static frame is used, FALSE otherwise.

Remarks

If TRUE, a static frame will be drawn around the entire tab manager control. The frame will be drawn around both the tab header and tab client.

See Also

CXTPTabPaintManager::m_bStaticFrame

Group

CXTPTabManager Methods


CXTPTabManager::IsHorizontalPosition Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::IsHorizontalPosition Method

Call this member to determine if the tabs are positioned horizontally.

BOOL IsHorizontalPosition() const;
Returns

TRUE if the tabs are located at the top or bottom, FALSE if the tabs are on the left or right.

See Also

GetPosition, XTPTabPosition

Body Source
BOOL CXTPTabManager::IsHorizontalPosition() const {
    return (GetPosition() == xtpTabPositionBottom || GetPosition() == xtpTabPositionTop);
}
Group

CXTPTabManager Methods


CXTPTabManager::IsMouseLocked Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::IsMouseLocked Method

This member is called to determine if the MouseMove event have been disabled. This member is overridden in CXTPTabClientWnd::CWorkspace.

virtual BOOL IsMouseLocked() const;
Returns

Always returns FALSE in the base class.

Remarks

The MouseMove event is disabled when a command bar popup becomes active (visible).

See Also

CXTPTabClientWnd::CWorkspace::IsMouseLocked

Body Source
BOOL CXTPTabManager::IsMouseLocked() const {
    return FALSE;
}
Group

CXTPTabManager Methods


CXTPTabManager::IsNavigateButtonAutomaticVisible Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::IsNavigateButtonAutomaticVisible Method

Determines if navigate button with xtpTabNavigateButtonAutomatic style is visible.

virtual BOOL IsNavigateButtonAutomaticVisible(
    CXTPTabManagerNavigateButton* pButton
);
Parameters

pButton
Button to check

Group

CXTPTabManager Methods


CXTPTabManager::MoveItem Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::MoveItem Method

Call this member to reorder items.

void MoveItem(
    CXTPTabManagerItem* pItem,
    int nIndex
);
Parameters

pItem
Item you want to reorder.
nIndex
New item position to be set.

Group

CXTPTabManager Methods


CXTPTabManager::OnBeforeItemClick Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::OnBeforeItemClick Method

This method is called before item click

virtual BOOL OnBeforeItemClick(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Pointer to item is about to be clicked

Returns

TRUE if cancel process

Group

CXTPTabManager Methods


CXTPTabManager::OnItemClick Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::OnItemClick Method

This member is called when a tab button is clicked. This will select the tab that was clicked.

virtual void OnItemClick(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Pointer to the CXTPTabManagerItem tab that was clicked.

See Also

PerformClick

Group

CXTPTabManager Methods


CXTPTabManager::OnItemHandleChanged Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source
CXTPTabManager::OnItemHandleChanged Method

This method is called when handle of item was changed

virtual void OnItemHandleChanged(
    CXTPTabManagerItem* pItem,
    HWND hwndOld,
    HWND hwndNew
);
Parameters

pItem
Item which handle was changed
hwndOld
Previous handle of item
hwndNew
New handle of item

Body Source
void CXTPTabManager::OnItemHandleChanged(CXTPTabManagerItem*, HWND, HWND) {

}
Group

CXTPTabManager Methods


CXTPTabManager::OnItemsChanged Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::OnItemsChanged Method

This member is called when the tab items have changed. Tab items will change after an item is added, deleted, or reordered.

virtual void OnItemsChanged();
Remarks

This member will recalculate the index for all items, then call Reposition.

See Also

CXTPTabManager::AddItem, CXTPTabManager::ReOrder, CXTPTabManager::DeleteItem, CXTPTabManager::DeleteAllItems

Group

CXTPTabManager Methods


OnNavigateButtonClick Method

CXTPTabManager Methods
OnNavigateButtonClick Method
Overload List
Methods
Method | Description
CXTPTabManager::OnNavigateButtonClick (CXTPTabManagerNavigateButton*) | This member is called when a tab navigation button is clicked.
CXTPTabManager::OnNavigateButtonClick (UINT) | This member is called when a tab navigation button is clicked.
Group

CXTPTabManager Methods


CXTPTabManager::OnNavigateButtonClick Method (CXTPTabManagerNavigateButton*)

OnNavigateButtonClick Method, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::OnNavigateButtonClick Method (CXTPTabManagerNavigateButton*)

This member is called when a tab navigation button is clicked.

virtual void OnNavigateButtonClick(
    CXTPTabManagerNavigateButton* pButton
);
virtual void OnNavigateButtonClick(
    UINT nID
);
Parameters

pButton
Button that was clicked
nID
Button identifier. It can be one of the values listed in the Remarks section.

Remarks

Standard ids of buttons are listed below:

  • xtpTabNavigateButtonLeft Left tab navigation button.
  • xtpTabNavigateButtonRight Right tab navigation button.
  • xtpTabNavigateButtonClose Close tab navigation button.

This method is overridden in CXTPTabClientWnd::CWorkspace and CXTPTabControl to capture when the tab navigation close "x" button was pressed and deletes the tab.

This member is called after CXTPTabManagerNavigateButton::PerformClick.

See Also

CXTPTabManagerNavigateButton::PerformClick, XTPTabNavigateButton

Body Source
void CXTPTabManager::OnNavigateButtonClick(CXTPTabManagerNavigateButton* pButton) {
    OnNavigateButtonClick(pButton->GetID());
}

void CXTPTabManager::OnNavigateButtonClick(UINT) {

}
Group

OnNavigateButtonClick Method


CXTPTabManager::OnScrollHeader Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::OnScrollHeader Method

This member is called then user press left or right navigate button

virtual void OnScrollHeader(
    BOOL bRight
);
Parameters

bRight
TRUE to scroll to right; FALSE to left.

Group

CXTPTabManager Methods


CXTPTabManager::PerformClick Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::PerformClick Method

This member is called when the user presses the left mouse button.

BOOL PerformClick(
    HWND hWnd,
    CPoint pt,
    BOOL bNoItemClick = FALSE
);
Parameters

hWnd
Handle to the CWnd object beneath the mouse cursor.
pt
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.
bNoItemClick
TRUE to only perform a click on tab navigation buttons. If TRUE, only the tab navigation buttons will be tested to see if they were clicked, the tabs will not receive the click.

FALSE to test both the tab navigation buttons and the tabs to see if they were clicked.

Returns

TRUE if a tab navigation button or tab was clicked, FALSE not items were clicked or if bNoItemClick is TRUE and a tab was clicked.

Remarks

When the user clicks on a tab navigation button, this member will call the CXTPTabManagerNavigateButton::PerformClick member of the navigation button that was clicked.

If a tab was clicked, then the OnItemClick member is called, which will select the tab.

If IsAllowReorder is TRUE, then ReOrder is called before OnItemClick. ReOrder will check to see if the tab is being moved, if it is, then the tab remains selected so OnItemClick is not called. If the tab was not being moved, then OnItemClick is called.

See Also

OnItemClick, ReOrder, CXTPTabManager::OnNavigateButtonClick

Group

CXTPTabManager Methods


CXTPTabManager::PerformKeyDown Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::PerformKeyDown Method

This method is called to process WM_KEYDOWN event of TabManager

virtual BOOL PerformKeyDown(
    HWND hWnd,
    UINT nChar
);
Parameters

hWnd
Handle to the window that contains the tab.
nChar
Specifies the virtual-key code of the given key.

Returns

TRUE if key was processes; FALSE otherwise

Group

CXTPTabManager Methods


CXTPTabManager::PerformMouseMove Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::PerformMouseMove Method

This member is called when the mouse cursor moves.

void PerformMouseMove(
    HWND hWnd,
    CPoint pt
);
Parameters

hWnd
Handle to the CWnd object beneath the mouse cursor.
pt
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

When the mouse cursor is moved across a tab and hot tracking is enabled, PerformMouseMove will highlight and un-highlight the tabs. It will then call CXTPTabManagerNavigateButton::PerformMouseMove for each tab navigation button.

When the mouse cursor is moved across a tab navigation button, CXTPTabManagerNavigateButton::PerformMouseMove is called to perform actions related to mouse movement over the navigation buttons. This will highlight and un-highlight the tab navigation buttons.

See Also

CXTPTabManagerNavigateButton::PerformMouseMove

Group

CXTPTabManager Methods


CXTPTabManager::PerformToolHitTest Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::PerformToolHitTest Method

This member is called to retrieve tooltip information about a tab and stores the information in a TOOLINFO object.

virtual INT_PTR PerformToolHitTest(
    HWND hWnd,
    CPoint point,
    TOOLINFO* pTI
) const;
Parameters

hWnd
Handle to the window that contains the tab.
point
Specifies the x- and y-coordinate of the cursor.
pTI
The TOOLINFO structure to copy information about a CXTPTabManagerItem.

Returns

-1 if a tooltip was not found for the CXTPTabManagerItem, If a tooltip was found, then the Id of the CXTPTabManagerItem is returned.

Remarks

This member is called in the CXTPTabControl::OnToolHitTest, CXTPDockingPaneTabbedContainer::OnToolHitTest, and CXTPTabClientWnd::OnToolHitTest members.

Group

CXTPTabManager Methods


CXTPTabManager::RedrawControl Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::RedrawControl Method

This member is called when visual properties of the tabs are changed. For example, color, mouse-over, and on-click. This member must be overridden in derived classes.

virtual void RedrawControl(
    LPCRECT lpRect,
    BOOL bAnimate
) = 0;
Parameters

lpRect
The rectangular area of the window that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Group

CXTPTabManager Methods


CXTPTabManager::ReOrder Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::ReOrder Method

This member is called when a CXTPTabManagerItem is clicked and dragged within the tab header. This will reorder the selected tab to the location it is dragged to.

virtual void ReOrder(
    HWND hWnd,
    CPoint pt,
    CXTPTabManagerItem* pItem
);
Parameters

hWnd
Handle to the CWnd object beneath the mouse cursor.
pt
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.
pItem
Pointer to the CXTPTabManagerItem tab that is being clicked and dragged.

See Also

PerformClick

Group

CXTPTabManager Methods


CXTPTabManager::SetActive Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetActive Method

Call this member to make a MDITabClient tab group active. SetActive works only for tab groups in the MDITabClient when group is enabled. Only one group can be active.

void SetActive(
    BOOL bActive
);
Parameters

bActive
TRUE to make this tab group active, FALSE to make this tab group inactive.

Remarks

When grouping is enabled, each tab group has its own CXTPTabManager. SetActive is used to activateset focus to the tab group.

Notes

This only applies to tab groups in the MDITabClient, this is the tabs that appear in the CommandBars TabWorkspace.

See Also

IsActive, CXTPTabClientWnd::Attach

Group

CXTPTabManager Methods


CXTPTabManager::SetAllowReorder Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::SetAllowReorder Method

Call this member to specify whether the user can reorder the tabs.

virtual void SetAllowReorder(
    BOOL bAllowReorder
);
Parameters

bAllowReorder
TRUE to allow tabs to be reordered, FALSE to disallow tab reordering.

See Also

IsAllowReorder

Body Source
void CXTPTabManager::SetAllowReorder(BOOL bAllowReorder) {
    m_bAllowReorder = bAllowReorder;
}
Group

CXTPTabManager Methods


CXTPTabManager::SetAppearance Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::SetAppearance Method

Call this member to apply one of the "built-in" appearances to the tabs.

CXTPTabPaintManager::CAppearanceSet* SetAppearance(
    XTPTabAppearanceStyle tabAppearance
);
Parameters

tabAppearance
XTPTabAppearanceStyle to apply to the tabs. Can be one of the values listed in the Remarks section.

Returns

Pointer to the CXTPTabPaintManager::CAppearanceSet object applied.

Remarks

Use SetAppearance to apply a "Built-In" theme such as xtpTabAppearanceExcel. To apply a custom them, use the SetAppearanceSet member.

tabAppearance can be one of the following:

  • xtpTabAppearancePropertyPage Gives your tabs an Office 2000 appearance.
  • xtpTabAppearancePropertyPageSelected Gives your tabs an Office 2000 selected appearance.
  • xtpTabAppearancePropertyPageFlat Gives your tabs an Office 2000 Flat appearance.
  • xtpTabAppearancePropertyPage2003 Gives your tabs an Office 2003 appearance.
  • xtpTabAppearanceStateButtons Gives your tabs a State Button appearance.
  • xtpTabAppearanceVisualStudio Gives your tabs a Visual Studio appearance.
  • xtpTabAppearanceFlat Gives your tabs Flat appearance.
  • xtpTabAppearanceExcel Gives your tabs an Excel appearance.
  • xtpTabAppearanceVisio Gives your tabs a Visio appearance. // See Also:

XTPTabAppearanceStyle, SetAppearanceSet, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

Group

CXTPTabManager Methods


CXTPTabManager::SetAppearanceSet Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetAppearanceSet Method

Call this member to apply a custom appearance set.

CXTPTabPaintManager::CAppearanceSet* SetAppearanceSet(
    CXTPTabPaintManager::CAppearanceSet* pAppearanceSet
);
Parameters

pAppearanceSet
Pointer to custom CXTPTabPaintManager::CAppearanceSet appearance set.

Returns

Pointer to newly set custom appearance set.

Remarks

An appearance set specifies how the tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance style will have a half hexagon shape. SetColorSet is used to set custom colors.

See the GUI_Eclipse sample for an example of how to create a custom appearance set and apply it to the tabs.

See Also

XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

Group

CXTPTabManager Methods


CXTPTabManager::SetColor Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetColor Method

Call this member to apply one of the "built-in" color sets to the tabs.

CXTPTabPaintManager::CColorSet* SetColor(
    XTPTabColorStyle tabColor
);
Parameters

tabColor
XTPTabColorStyle to apply to the tabs. Can be one of the values listed in the remarks section.

Returns

Pointer to the CXTPTabPaintManager::CColorSet object applied.

Remarks

tabColor can be one of the following:

  • xtpTabColorDefault Tabs will use the default color for the currently set Appearance.
  • xtpTabColorVisualStudio Tabs will use the Visual Studio color style for the currently set Appearance.
  • xtpTabColorOffice2003 Tabs will use the Office 2003 color style for the currently set Appearance.
  • xtpTabColorWinXP Tabs will use the Windows XP color style for the currently set Appearance.
  • xtpTabColorWhidbey Tabs will use the Visual Studio 2005 "Whidbey" color style for the currently set Appearance.
See Also

XTPTabColorStyle, SetColorSet, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

Group

CXTPTabManager Methods


CXTPTabManager::SetColorSet Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetColorSet Method

Call this member to apply a custom color set to the tabs.

CXTPTabPaintManager::CColorSet* SetColorSet(
    CXTPTabPaintManager::CColorSet* pColorSet
);
Parameters

pColorSet
Pointer to custom CXTPTabPaintManager::CColorSet appearance set.

Returns

Pointer to the newly set custom color set.

See Also

XTPTabColorStyle, SetColor, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

Group

CXTPTabManager Methods


CXTPTabManager::SetCurSel Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetCurSel Method

Call this member to select a tab by its index. A selected tab if the currently active tab.

void SetCurSel(
    int nIndex
);
Parameters

nIndex
Index of the tab to select.

Remarks

This member will set the current CXTPTabManagerItem by its index within the collection of items.

SetSelectedItem will select the specified CXTPTabManagerItem.

Notes

SetCurSel will call SetSelectedItem after it gets a pointer to the specified item.

See Also

CXTPTabManagerItem, GetCurSel, SetSelectedItem, GetSelectedItem

Group

CXTPTabManager Methods


CXTPTabManager::SetFocusedItem Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetFocusedItem Method

This method is called to set focused item.

virtual void SetFocusedItem(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Item that become focused.

See Also

SetSelectedItem

Group

CXTPTabManager Methods


CXTPTabManager::SetHeaderOffset Method

CXTPTabManager Methods, CXTPTabManager Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManager::SetHeaderOffset Method

Call this member to adjust the scroll offset of the tabs in the tab header.

void SetHeaderOffset(
    int nOffset
);
Parameters

nOffset
Scroll offset, number must be <= 0. You should use GetHeaderOffset to get the current offset and add or subtract to move left and right. If 0, then the tabs will be reset to there starting position.

Remarks

The scroll offset starts at zero. The offset will remain at zero until there are enough tabs to scroll. If the tabs are scrolled, the offset will be a negative number indicating how much the tabs have been scrolled to the right.

Notes

GetHeaderOffset and SetHeaderOffset are used when the left and right tab navigate buttons are pressed to scroll the tabs by 20 pixels to the left or right.

EnsureVisible uses GetHeaderOffset and SetHeaderOffset to ensure that a tab button is visible.

See Also

GetHeaderOffset, CXTPTabManagerNavigateButton, EnsureVisible

Example

This sample illustrate how to programmatically set the scroll offset of the tabs in the tab header of the CXTPTabClientWnd.

//Scroll the tabs in the tab header to the right by 100 pixels.
m_MTIClientWnd.GetWorkspace(0)->SetHeaderOffset((m_MTIClientWnd.GetWorkspace(0)->GetHeaderOffset()) - 100);

//Scroll the tabs in the tab header to the left by 100 pixels.//
m_MTIClientWnd.GetWorkspace(0)->SetHeaderOffset((m_MTIClientWnd.GetWorkspace(0)->GetHeaderOffset()) + 100);
Group

CXTPTabManager Methods


CXTPTabManager::SetItemMetrics Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetItemMetrics Method

Call this member to set the minimum, maximum, and normal lengths of tab buttons. Each is used when calculating the lengths of tabs for each XTPTabLayoutStyle.

void SetItemMetrics(
    CSize szNormal,
    CSize szMin = CSize(0, 0),
    CSize szMax = CSize(0, 0)
);
Parameters

szNormal
Used only when XTPTabLayoutStyle = xtpTabLayoutFixed. All tabs will have a length of szNormal with this layout. For all other layouts, szMin and szMax are used as bounds for the available length of a single tab.
szMin
Minimum length of a single tab when layout is not xtpTabLayoutFixed.
szMax
Maximum length of a single tab when layout is not xtpTabLayoutFixed.

Remarks

szNormal is only used to size tabs when the layout is xtpTabLayoutFixed. szMin and szMax are used to calculate the length of tabs for all other layouts. For example, SetItemMetrics might be called to set the maximum available length for a tab when using the xtpTabLayoutSizeToFit layout.

See Also

XTPTabLayoutStyle, GetItemMetrics, SetLayoutStyle

Group

CXTPTabManager Methods


CXTPTabManager::SetLayoutStyle Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetLayoutStyle Method

Call this member to set the tab layout style.

void SetLayoutStyle(
    XTPTabLayoutStyle tabLayout
);
Parameters

tabLayout
New XTPTabLayoutStyle to apply to the tabs. Can be one of the values listed in the Remarks section.

Remarks

The layout refers to how the tabs are sized within the tab header. Tabs can be in a compressed, fixed, auto size, or sized-to-fit layout.

tabLayout can be one of the following:

  • xtpTabLayoutAutoSize Tabs will be automatically sized based on the caption and image size. With this flag set, tabs will appear in their normal size.
  • xtpTabLayoutSizeToFit Tabs are sized to fit within the tab panel. All tabs will be compressed and forced to fit into the tab panel.
  • xtpTabLayoutFixed All tabs will be set to a fixed size within the tab panel.
  • xtpTabLayoutCompressed Tabs will be compressed within the tab panel. This will compress the size of the tabs, but all tabs will not be forced into the tab panel.
  • xtpTabLayoutMultiRow Causes a tab control to display multiple rows of tabs
See Also

XTPTabLayoutStyle, GetLayout

Group

CXTPTabManager Methods


CXTPTabManager::SetPaintManager Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source
CXTPTabManager::SetPaintManager Method

Call this member to set a CXTPTabPaintManager object to the tab manager.

virtual void SetPaintManager(
    CXTPTabPaintManager* pPaintManager
);
Parameters

pPaintManager
Pointer to a CXTPTabPaintManager object.

Remarks

The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager.

Body Source
void CXTPTabManager::SetPaintManager(CXTPTabPaintManager* /*pPaintManager*/) {

}
Group

CXTPTabManager Methods


CXTPTabManager::SetPosition Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetPosition Method

Call this member to set the position of the tabs.

void SetPosition(
    XTPTabPosition tabPosition
);
Parameters

tabPosition
New XTPTabPosition to apply to tab manager. Can be one of the values listed in the remarks section.

Remarks

The position refers to where the tabs are located in relation to the TabClient. The tabs can be positioned on the top, bottom, left, or right side of the TabClient.

tabPosition can be one of the following:

  • xtpTabPositionTop Tabs will be drawn on the Top.
  • xtpTabPositionLeft Tabs will be drawn on the Left.
  • xtpTabPositionBottom Tabs will be drawn on the Bottom.
  • xtpTabPositionRight Tabs will be drawn on the Right.
See Also

XTPTabPosition, GetPosition

Group

CXTPTabManager Methods


CXTPTabManager::SetSelectedItem Method

CXTPTabManager Methods, CXTPTabManager Class, See Also
CXTPTabManager::SetSelectedItem Method

Call this member to select a CXTPTabManagerItem tab. A selected tab if the currently active tab.

virtual void SetSelectedItem(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
CXTPTabManagerItem tab to select.

Remarks

This member will will select the specified CXTPTabManagerItem.

SetCurSel will set the current CXTPTabManagerItem by its index within the collection of items.

A tab is selected when it has focus or is clicked.

See Also

CXTPTabManagerItem, GetCurSel, SetCurSel, GetSelectedItem

Group

CXTPTabManager Methods


CXTPTabManager::ShowCloseItemButton Method

CXTPTabManager Methods, CXTPTabManager Class, Body Source
CXTPTabManager::ShowCloseItemButton Method

Call this member to show close button for each tab

void ShowCloseItemButton(
    XTPTabNavigateButtonFlags bCloseItemButton = xtpTabNavigateButtonAlways
);
Parameters

bCloseItemButton
XTPTabNavigateButtonFlags that specify if close button for each tab is visible

Body Source
void CXTPTabManager::ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton) {
    m_bCloseItemButton = bCloseItemButton;
}
Group

CXTPTabManager Methods


CXTPTabManager::ShowIcons Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::ShowIcons Method

Call this member to hide or show tab icons.

void ShowIcons(
    BOOL bShowIcons
);
Parameters

bShowIcons
TRUE to show icons in the tabs, FALSE to hide tab icons.

Group

CXTPTabManager Methods


CXTPTabManager::TrackClick Method

CXTPTabManager Methods, CXTPTabManager Class
CXTPTabManager::TrackClick Method

This method is called to activate tab item on mouse click

void TrackClick(
    HWND hWnd,
    CPoint pt,
    CXTPTabManagerItem* pItem
);
Parameters

hWnd
Handle to the CWnd object beneath the mouse cursor.
pt
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.
pItem
Tab item to track

Group

CXTPTabManager Methods


CXTPTabManager Constructors

CXTPTabManager Class, Legend, Public Methods
CXTPTabManager Constructors
Class

CXTPTabManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabManager | Constructs a CXTPTabManager object.


CXTPTabManager::CXTPTabManager Constructor

CXTPTabManager Constructors, CXTPTabManager Class
CXTPTabManager::CXTPTabManager Constructor

Constructs a CXTPTabManager object.

CXTPTabManager();
Group

CXTPTabManager Constructors


CXTPTabManager Destructors

CXTPTabManager Class, Legend, Public Methods
CXTPTabManager Destructors
Class

CXTPTabManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTabManager | Destroys a CXTPTabManager object, handles cleanup and deallocation.


CXTPTabManager::~CXTPTabManager Destructor

CXTPTabManager Destructors, CXTPTabManager Class
CXTPTabManager::~CXTPTabManager Destructor

Destroys a CXTPTabManager object, handles cleanup and deallocation.

virtual ~CXTPTabManager();
Group

CXTPTabManager Destructors


CXTPTabManagerAtom Class

XTPTabManager.h, Classes, Legend, Members, Topics, CXTPTabManagerAtom Methods, CXTPTabManagerAtom Destructors, CXTPTabManagerAtom Destructors, CXTPTabManagerAtom Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerAtom Class

CXTPTabManagerAtom is a class that has only one purpose, which is to catch the event when a property of the PaintManager has changed. When a property of the PaintManager has changed, the OnPropertyChanged event if called. When the OnPropertyChanged is caught, Reposition is called to recalculate self layout.

Class Hierarchy

class CXTPTabManagerAtom;
File

XTPTabManager.h

Remarks

This is the base class for CXTPTabManager. When a property of the CXTPTabPaintManager has changed, then OnPropertyChanged is called to recalculate the layout. The paint manager can be accessed with the CXTPTabManager::GetPaintManager member.

See Also

CXTPTabManager::GetPaintManager

Group

Classes

Legend
Method
virtual
abstract
protected
CXTPTabManagerAtom Destructors
CXTPTabManagerAtom Destructors | Description
~CXTPTabManagerAtom | Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.
CXTPTabManagerAtom Methods
CXTPTabManagerAtom Methods | Description
OnPropertyChanged | This member is called when a property of the PaintManager has changed.
Reposition | This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.


CXTPTabManagerAtom Methods

CXTPTabManagerAtom Class, Legend, Public Methods
CXTPTabManagerAtom Methods
Class

CXTPTabManagerAtom Class

Legend
Method
virtual
abstract
Public Methods
Public Methods
Public Method | Description
OnPropertyChanged | This member is called when a property of the PaintManager has changed.
Reposition | This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.


CXTPTabManagerAtom::OnPropertyChanged Method

CXTPTabManagerAtom Methods, CXTPTabManagerAtom Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerAtom::OnPropertyChanged Method

This member is called when a property of the PaintManager has changed.

virtual void OnPropertyChanged();
See Also

CXTPTabManager::GetPaintManager

Body Source
virtual void OnPropertyChanged()
{
    Reposition();
}
Group

CXTPTabManagerAtom Methods


CXTPTabManagerAtom::Reposition Method

CXTPTabManagerAtom Methods, CXTPTabManagerAtom Class
CXTPTabManagerAtom::Reposition Method

This member recalculates the layout of the tab manager and then repositions itself. This member must be overridden in derived classes.

virtual void Reposition() = 0;
Group

CXTPTabManagerAtom Methods


CXTPTabManagerAtom Destructors

CXTPTabManagerAtom Class, Legend, Protected Methods
CXTPTabManagerAtom Destructors
Class

CXTPTabManagerAtom Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPTabManagerAtom | Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.


CXTPTabManagerAtom::~CXTPTabManagerAtom Destructor

CXTPTabManagerAtom Destructors, CXTPTabManagerAtom Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerAtom::~CXTPTabManagerAtom Destructor

Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

virtual ~CXTPTabManagerAtom();
Body Source
virtual ~CXTPTabManagerAtom()
{

}
Group

CXTPTabManagerAtom Destructors


CXTPTabManagerItem Class

XTPTabManager.h, Classes, Legend, Members, Topics, CXTPTabManagerItem Data Members, CXTPTabManagerItem Methods, CXTPTabManagerItem Constructors, CXTPTabManagerItem Destructors, CXTPTabManagerItem Constructors, CXTPTabManagerItem Data Members, CXTPTabManagerItem Destructors, CXTPTabManagerItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem Class

CXTPTabManagerItem is a CCmdTarget derived class that represents a tab item. This is the base class for the tabs that appear in the CommandBars TabWorkSpace, DockingPanes, and TabControl.

Class Hierarchy

class CXTPTabManagerItem;
File

XTPTabManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTabManagerItem Constructors
CXTPTabManagerItem Constructors | Description
CXTPTabManagerItem | Constructs a CXTPTabManagerItem object.
CXTPTabManagerItem Data Members
CXTPTabManagerItem Data Members | Description
m_arrNavigateButtons | Array of navigate buttons
m_bClosable | TRUE if item can be closed.
m_bEnabled | TRUE if the tab is enabled.
m_bVisible | TRUE if the tab is visible.
m_clrItem | Color of tab button.
m_dwData | Developer specific data
m_hIcon | Icon associated with the tab.
m_hWnd | A CWnd pointer to the window associated with a tab.
m_nButtonLength | Width of the tab button.
m_nContentLength | Width of the tab button.
m_nImage | Image index, this is the index of an image within a CXTPImageManger or CImageList object.
m_nIndex | Index of the tab within the collection of tabs.
m_nItemRow | Row of the item
m_pTabManager | Parent item.
m_rcItem | Rectangle of this tab.
m_strCaption | User specified label for the tab.
m_strToolTip | Tooltip text for the tab.
CXTPTabManagerItem Destructors
CXTPTabManagerItem Destructors | Description
~CXTPTabManagerItem | Destroys a CXTPTabManagerItem object, handles cleanup and deallocation.
CXTPTabManagerItem Methods
CXTPTabManagerItem Methods | Description
DrawImage | Call this method to draw icon of single tab
GetButtonLength | Call this member to get the width of the tab button.
GetCaption | Call this member to get the text caption to the tab.
GetColor | Call this member to retrieve the color of the tab button.
GetContentLength | Call this member to get the width of the content.
GetData | This method retrieves the application-supplied 32-bit value associated with the tab item.
GetHandle | Call this member to get the HWND of the object associated with the tab. This is the HWND of the object that is displayed in the tab client area when the tab is selected.
GetImageIndex | Call this member to get the image index of the tab.
GetIndex | Call this member to get the index of the tab within the collection of tabs.
GetItemRow | Call this member to get row of the item.
GetNavigateButtons | Call this method to get collection of navigate buttons.
GetRect | Call this member to get the bounding rectangle of the tab button.
GetTabManager | Call this member to get a pointer to the CXTPTabManager object. The CXTPTabManager object manages all CXTPTabManagerItem objects.
GetTooltip | Call this member to get the tooltip displayed when the mouse pointer is positioned over the tab button.
IsClosable | This method is called to determine if item can be closed
IsEnabled | Call this member to determine if the tab is enabled.
IsFocused | Call this member to determine it the tab has focus
IsHighlighted | Call this method to determine if the tab is highlighted.
IsItemShrinked | This method is called to determine if the item was shrinked.
IsPressed | Call this method to determine if the tab is pressed
IsSelected | Call this member to determine it the tab is currently selected. I.e. when a tab is clicked.
IsVisible | Call this member to determine if the tab is visible.
Move | Call this member to reorder item.
OnRemoved | This method is called when item was removed from TabManager collection
Remove | Call this member to delete this tab.
Reposition | This method is called to update position of TabManager.
Select | Call this member to select this tab.
SetCaption | Call this member to set the text caption that is displayed in this tab's button.
SetClosable | Call this member to forbid this tab to be closed
SetColor | Call this member to set the color of the tab button.
SetData | Call this method to set the 32-bit value associated with the tab item.
SetEnabled | Call this member to set whether the tab is enabled.
SetHandle | Call this member to associate an object with the tab. This will tell the tab what to display in the tab client area when the tab is selected. I.e. The HWND of a dialog.
SetImageIndex | Call this member to set the image index of the tab.
SetRect | Call this member to set the bounding rectangle of the tab.
SetTooltip | Call this member to set the tooltip for this tab. This is the text that will be displayed when the mouse pointer is positioned over the tab button.
SetVisible | Call this member to hide or show the tab.


CXTPTabManagerItem Data Members

CXTPTabManagerItem Class, Legend, Protected Data Members
CXTPTabManagerItem Data Members
Class

CXTPTabManagerItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrNavigateButtons | Array of navigate buttons
m_bClosable | TRUE if item can be closed.
m_bEnabled | TRUE if the tab is enabled.
m_bVisible | TRUE if the tab is visible.
m_clrItem | Color of tab button.
m_dwData | Developer specific data
m_hIcon | Icon associated with the tab.
m_hWnd | A CWnd pointer to the window associated with a tab.
m_nButtonLength | Width of the tab button.
m_nContentLength | Width of the tab button.
m_nImage | Image index, this is the index of an image within a CXTPImageManger or CImageList object.
m_nIndex | Index of the tab within the collection of tabs.
m_nItemRow | Row of the item
m_pTabManager | Parent item.
m_rcItem | Rectangle of this tab.
m_strCaption | User specified label for the tab.
m_strToolTip | Tooltip text for the tab.


CXTPTabManagerItem::m_arrNavigateButtons Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_arrNavigateButtons Data Member

Array of navigate buttons

CXTPTabManagerNavigateButtons m_arrNavigateButtons;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_bClosable Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_bClosable Data Member

TRUE if item can be closed.

BOOL m_bClosable;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_bEnabled Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_bEnabled Data Member

TRUE if the tab is enabled.

BOOL m_bEnabled;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_bVisible Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_bVisible Data Member

TRUE if the tab is visible.

BOOL m_bVisible;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_clrItem Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_clrItem Data Member

Color of tab button.

COLORREF m_clrItem;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_dwData Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_dwData Data Member

Developer specific data

DWORD_PTR m_dwData;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_hIcon Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_hIcon Data Member

Icon associated with the tab.

HICON m_hIcon;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_hWnd Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_hWnd Data Member

A CWnd pointer to the window associated with a tab.

HWND m_hWnd;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_nButtonLength Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_nButtonLength Data Member

Width of the tab button.

int m_nButtonLength;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_nContentLength Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_nContentLength Data Member

Width of the tab button.

int m_nContentLength;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_nImage Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_nImage Data Member

Image index, this is the index of an image within a CXTPImageManger or CImageList object.

int m_nImage;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_nIndex Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_nIndex Data Member

Index of the tab within the collection of tabs.

int m_nIndex;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_nItemRow Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_nItemRow Data Member

Row of the item

int m_nItemRow;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_pTabManager Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_pTabManager Data Member

Parent item.

CXTPTabManager* m_pTabManager;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_rcItem Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_rcItem Data Member

Rectangle of this tab.

CRect m_rcItem;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_strCaption Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_strCaption Data Member

User specified label for the tab.

CString m_strCaption;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem::m_strToolTip Data Member

CXTPTabManagerItem Data Members, CXTPTabManagerItem Class
CXTPTabManagerItem::m_strToolTip Data Member

Tooltip text for the tab.

CString m_strToolTip;
Group

CXTPTabManagerItem Data Members


CXTPTabManagerItem Methods

CXTPTabManagerItem Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem Methods
Class

CXTPTabManagerItem Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnRemoved | This method is called when item was removed from TabManager collection
Reposition | This method is called to update position of TabManager.
Public Methods
Public Methods
Public Method | Description
DrawImage | Call this method to draw icon of single tab
GetButtonLength | Call this member to get the width of the tab button.
GetCaption | Call this member to get the text caption to the tab.
GetColor | Call this member to retrieve the color of the tab button.
GetContentLength | Call this member to get the width of the content.
GetData | This method retrieves the application-supplied 32-bit value associated with the tab item.
GetHandle | Call this member to get the HWND of the object associated with the tab. This is the HWND of the object that is displayed in the tab client area when the tab is selected.
GetImageIndex | Call this member to get the image index of the tab.
GetIndex | Call this member to get the index of the tab within the collection of tabs.
GetItemRow | Call this member to get row of the item.
GetNavigateButtons | Call this method to get collection of navigate buttons.
GetRect | Call this member to get the bounding rectangle of the tab button.
GetTabManager | Call this member to get a pointer to the CXTPTabManager object. The CXTPTabManager object manages all CXTPTabManagerItem objects.
GetTooltip | Call this member to get the tooltip displayed when the mouse pointer is positioned over the tab button.
IsClosable | This method is called to determine if item can be closed
IsEnabled | Call this member to determine if the tab is enabled.
IsFocused | Call this member to determine it the tab has focus
IsHighlighted | Call this method to determine if the tab is highlighted.
IsItemShrinked | This method is called to determine if the item was shrinked.
IsPressed | Call this method to determine if the tab is pressed
IsSelected | Call this member to determine it the tab is currently selected. I.e. when a tab is clicked.
IsVisible | Call this member to determine if the tab is visible.
Move | Call this member to reorder item.
Remove | Call this member to delete this tab.
Select | Call this member to select this tab.
SetCaption | Call this member to set the text caption that is displayed in this tab's button.
SetClosable | Call this member to forbid this tab to be closed
SetColor | Call this member to set the color of the tab button.
SetData | Call this method to set the 32-bit value associated with the tab item.
SetEnabled | Call this member to set whether the tab is enabled.
SetHandle | Call this member to associate an object with the tab. This will tell the tab what to display in the tab client area when the tab is selected. I.e. The HWND of a dialog.
SetImageIndex | Call this member to set the image index of the tab.
SetRect | Call this member to set the bounding rectangle of the tab.
SetTooltip | Call this member to set the tooltip for this tab. This is the text that will be displayed when the mouse pointer is positioned over the tab button.
SetVisible | Call this member to hide or show the tab.


CXTPTabManagerItem::DrawImage Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::DrawImage Method

Call this method to draw icon of single tab

void DrawImage(
    CDC* pDC,
    CRect rcIcon,
    CXTPImageManagerIcon* pImage
);
Parameters

pDC
Pointer to device context to draw
rcIcon
Bounding rectangle of icon
pImage
Pointer to image associated with tab

See Also

CXTPImageManagerIcon

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetButtonLength Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetButtonLength Method

Call this member to get the width of the tab button.

int GetButtonLength() const;
Returns

Width of the tab button.

Remarks

The width might change depending on the tab layout and position of the tabs.

See Also

XTPTabLayoutStyle, XTPTabPosition

Body Source
int CXTPTabManagerItem::GetButtonLength() const {
    return m_nButtonLength;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetCaption Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetCaption Method

Call this member to get the text caption to the tab.

CString GetCaption() const;
Returns

Text caption of tab. This is the text displayed in the tab button.

See Also

SetCaption

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetColor Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetColor Method

Call this member to retrieve the color of the tab button.

COLORREF GetColor();
Returns

The color of the tab button.

See Also

SetColor, CXTPTabManager::GetItemColor

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetContentLength Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetContentLength Method

Call this member to get the width of the content.

int GetContentLength() const;
Returns

Width of the content of the button.

Remarks

The width might change depending on the tab layout and position of the tabs.

See Also

XTPTabLayoutStyle, XTPTabPosition

Body Source
int CXTPTabManagerItem::GetContentLength() const {
    return m_nContentLength;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetData Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetData Method

This method retrieves the application-supplied 32-bit value associated with the tab item.

DWORD_PTR GetData() const;
Returns

The 32-bit value associated with the tab item.

Remarks

This returns the "extra" information such as pointers or integers that was associated with the tab item using the SetData function.

Notes

Do not use GetData when working with docking pane tabs. With DockingPanes, GetData returns a pointer to a CXTPDockingPane. Use CXTPDockingPane::GetPaneData when working with docking panes.

See Also

SetData, CXTPDockingPane::SetPaneData, CXTPDockingPane::GetPaneData

Body Source
DWORD_PTR CXTPTabManagerItem::GetData() const {
    return m_dwData;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetHandle Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetHandle Method

Call this member to get the HWND of the object associated with the tab. This is the HWND of the object that is displayed in the tab client area when the tab is selected.

HWND GetHandle() const;
Returns

HWND of object associated with the tab.

See Also

SetHandle

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetImageIndex Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetImageIndex Method

Call this member to get the image index of the tab.

int GetImageIndex() const;
Returns

Index of the image displayed in the tab button. The index is the index of an image within an CXTPImageManager or CImageList object.

Remarks

This is the index of an image within an CXTPImageManager or CImageList object that will be displayed in the tab button. CXTPTabManager::ShowIcons is used to hideshow icons.

See Also

SetImageIndex, CXTPTabControl::InsertItem, CXTPTabControl::GetImageManager, CXTPTabControl::SetImageList, CXTPTabManager::ShowIcons

Body Source
int CXTPTabManagerItem::GetImageIndex() const {
    return m_nImage;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetIndex Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetIndex Method

Call this member to get the index of the tab within the collection of tabs.

int GetIndex() const;
Returns

Index of tab.

See Also

CXTPTabManager::GetItem, CXTPTabManager

Body Source
int CXTPTabManagerItem::GetIndex() const {
    return m_nIndex;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetItemRow Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetItemRow Method

Call this member to get row of the item.

int GetItemRow() const;
Body Source
int CXTPTabManagerItem::GetItemRow() const {
    return m_nItemRow;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetNavigateButtons Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetNavigateButtons Method

Call this method to get collection of navigate buttons.

CXTPTabManagerNavigateButtons* GetNavigateButtons();
Returns

Array of CXTPTabManagerNavigateButton classes.

See Also

CXTPTabManagerNavigateButtons, CXTPTabManagerNavigateButton

Body Source
CXTPTabManagerNavigateButtons* CXTPTabManagerItem::GetNavigateButtons() {
    return &m_arrNavigateButtons;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetRect Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetRect Method

Call this member to get the bounding rectangle of the tab button.

CRect GetRect() const;
Returns

Bounding rectangle of the tab button.

See Also

SetRect

Body Source
CRect CXTPTabManagerItem::GetRect() const{
    return m_rcItem;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetTabManager Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetTabManager Method

Call this member to get a pointer to the CXTPTabManager object. The CXTPTabManager object manages all CXTPTabManagerItem objects.

CXTPTabManager* GetTabManager() const;
Returns

Pointer to parent CXTPTabManager.

Body Source
CXTPTabManager* CXTPTabManagerItem::GetTabManager() const{
    return m_pTabManager;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::GetTooltip Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::GetTooltip Method

Call this member to get the tooltip displayed when the mouse pointer is positioned over the tab button.

CString GetTooltip() const;
Returns

The tooltip displayed when the mouse if over the tab button.

See Also

SetTooltip, CXTPTabManager::GetItemTooltip

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::IsClosable Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::IsClosable Method

This method is called to determine if item can be closed

BOOL IsClosable() const;
Returns

TRUE if item can be closed.

Body Source
BOOL CXTPTabManagerItem::IsClosable() const {
    return m_bClosable;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::IsEnabled Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::IsEnabled Method

Call this member to determine if the tab is enabled.

BOOL IsEnabled() const;
Returns

TRUE if the tab is enabled, FALSE if the tab is disabled.

See Also

SetEnabled

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::IsFocused Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::IsFocused Method

Call this member to determine it the tab has focus

BOOL IsFocused() const;
Returns

TRUE if the tab has focus, FALSE otherwise.

Body Source
BOOL CXTPTabManagerItem::IsFocused() const {
    return IsSelected() && m_pTabManager->HeaderHasFocus();
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::IsHighlighted Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::IsHighlighted Method

Call this method to determine if the tab is highlighted.

BOOL IsHighlighted() const;
Returns

TRUE if the tab is highlighted (If CXTPTabPaintManager::m_bHotTracking is TRUE), otherwise FALSE.

Remarks

A tab will be highlighted when CXTPTabPaintManager::m_bHotTracking is TRUE and the mouse pointer is positioned over the tab button. and when dragging a tab. I.e. Reordering tabs.

See Also

IsPressed, IsFocused

Body Source
BOOL CXTPTabManagerItem::IsHighlighted() const {
    return m_pTabManager->m_pHighlighted == this;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::IsItemShrinked Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::IsItemShrinked Method

This method is called to determine if the item was shrinked.

BOOL IsItemShrinked() const;
Body Source
BOOL CXTPTabManagerItem::IsItemShrinked() const {
    return m_nButtonLength < m_nContentLength;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::IsPressed Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::IsPressed Method

Call this method to determine if the tab is pressed

BOOL IsPressed() const;
Returns

TRUE if the tab is pressed, otherwise FALSE.

See Also

IsHighlighted

Body Source
BOOL CXTPTabManagerItem::IsPressed() const {
    return m_pTabManager->m_pPressed == this;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::IsSelected Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::IsSelected Method

Call this member to determine it the tab is currently selected. I.e. when a tab is clicked.

BOOL IsSelected() const;
Returns

TRUE if the tab is currently selected, FALSE otherwise.

Body Source
BOOL CXTPTabManagerItem::IsSelected() const {
    return m_pTabManager->m_pSelected == this;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::IsVisible Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::IsVisible Method

Call this member to determine if the tab is visible.

BOOL IsVisible() const;
Returns

TRUE if the tab is visible, FALSE otherwise.

Remarks

A tab might not be visible because of the tab layout. You can also use the SetVisible member to hideshow a tab.

See Also

SetVisible

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::Move Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class
CXTPTabManagerItem::Move Method

Call this member to reorder item.

void Move(
    int nIndex
);
Parameters

nIndex
New item position to be set.

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::OnRemoved Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class
CXTPTabManagerItem::OnRemoved Method

This method is called when item was removed from TabManager collection

virtual void OnRemoved();
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::Remove Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class
CXTPTabManagerItem::Remove Method

Call this member to delete this tab.

void Remove();
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::Reposition Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class
CXTPTabManagerItem::Reposition Method

This method is called to update position of TabManager.

void Reposition();
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::Select Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class
CXTPTabManagerItem::Select Method

Call this member to select this tab.

void Select();
Remarks

This will invoke the OnItemClick method. A tab can also be selected by clicking on the tab.

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetCaption Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetCaption Method

Call this member to set the text caption that is displayed in this tab's button.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
Text caption of the tab.

See Also

GetCaption

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetClosable Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetClosable Method

Call this member to forbid this tab to be closed

void SetClosable(
    BOOL bClosable
);
Parameters

bClosable
TRUE to allow user close this tab; FALSE to forbid

Body Source
void CXTPTabManagerItem::SetClosable(BOOL bClosable) {
    m_bClosable = bClosable;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetColor Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetColor Method

Call this member to set the color of the tab button.

void SetColor(
    COLORREF clr
);
Parameters

clr
New color of the tab button.

Remarks

After the new color is set, CXTPTabManager::RedrawControl is called.

See Also

GetColor, CXTPTabManager::GetItemColor

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetData Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetData Method

Call this method to set the 32-bit value associated with the tab item.

void SetData(
    DWORD_PTR dwData
);
Parameters

dwData
Contains the new value to associate with the tab item.

Remarks

This allows any "extra" information such as pointers or integers to be associated with the tab item.

Notes

Do not use SetData when working with docking pane tabs. For DockingPanes, dwData stores a pointer to a CXTPDockingPane. Use CXTPDockingPane::SetPaneData when working with docking panes.

See Also

SetData, CXTPDockingPane::SetPaneData

Body Source
void CXTPTabManagerItem::SetData(DWORD_PTR dwData) {
    m_dwData = dwData;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetEnabled Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetEnabled Method

Call this member to set whether the tab is enabled.

void SetEnabled(
    BOOL bEnabled
);
Parameters

bEnabled
TRUE to enable the tab, FALSE to disable the tab.

Remarks

If FALSE, the tab will appear "grayed out" and the user can not access the tab.

See Also

IsEnabled

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetHandle Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetHandle Method

Call this member to associate an object with the tab. This will tell the tab what to display in the tab client area when the tab is selected. I.e. The HWND of a dialog.

void SetHandle(
    HWND hWnd
);
Parameters

hWnd
HWND of object that should be displayed in this tab when the tab is selected.

See Also

GetHandle

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetImageIndex Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetImageIndex Method

Call this member to set the image index of the tab.

void SetImageIndex(
    int nImage
);
Parameters

nImage
Index of an image within an CXTPImageManager or CImageList object that will be displayed in the tab button.

Remarks

This is the index of an image within an CXTPImageManager or CImageList object that will be displayed in the tab button. CXTPTabManager::ShowIcons is used to hideshow icons.

See Also

GetImageIndex, CXTPTabControl::InsertItem, CXTPTabControl::GetImageManager, CXTPTabControl::SetImageList, CXTPTabManager::ShowIcons

Body Source
void CXTPTabManagerItem::SetImageIndex(int nImage) {
    if (m_nImage != nImage) { m_nImage = nImage; m_pTabManager->Reposition(); }
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetRect Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetRect Method

Call this member to set the bounding rectangle of the tab.

void SetRect(
    CRect rcItem
);
Parameters

rcItem
Bounding rectangle of tab.

See Also

GetRect

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetTooltip Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetTooltip Method

Call this member to set the tooltip for this tab. This is the text that will be displayed when the mouse pointer is positioned over the tab button.

void SetTooltip(
    LPCTSTR lpszTooltip
);
Parameters

lpszTooltip
Tooltip to set for this tab.

See Also

GetTooltip, CXTPTabManager::GetItemTooltip

Body Source
void CXTPTabManagerItem::SetTooltip(LPCTSTR lpszTooltip) {
    m_strToolTip = lpszTooltip;
}
Group

CXTPTabManagerItem Methods


CXTPTabManagerItem::SetVisible Method

CXTPTabManagerItem Methods, CXTPTabManagerItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerItem::SetVisible Method

Call this member to hide or show the tab.

virtual void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show the tab, FALSE to hide the tab.

See Also

IsVisible

Group

CXTPTabManagerItem Methods


CXTPTabManagerItem Constructors

CXTPTabManagerItem Class, Legend, Protected Methods
CXTPTabManagerItem Constructors
Class

CXTPTabManagerItem Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPTabManagerItem | Constructs a CXTPTabManagerItem object.


CXTPTabManagerItem::CXTPTabManagerItem Constructor

CXTPTabManagerItem Constructors, CXTPTabManagerItem Class
CXTPTabManagerItem::CXTPTabManagerItem Constructor

Constructs a CXTPTabManagerItem object.

CXTPTabManagerItem();
Group

CXTPTabManagerItem Constructors


CXTPTabManagerItem Destructors

CXTPTabManagerItem Class, Legend, Protected Methods
CXTPTabManagerItem Destructors
Class

CXTPTabManagerItem Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPTabManagerItem | Destroys a CXTPTabManagerItem object, handles cleanup and deallocation.


CXTPTabManagerItem::~CXTPTabManagerItem Destructor

CXTPTabManagerItem Destructors, CXTPTabManagerItem Class
CXTPTabManagerItem::~CXTPTabManagerItem Destructor

Destroys a CXTPTabManagerItem object, handles cleanup and deallocation.

~CXTPTabManagerItem();
Group

CXTPTabManagerItem Destructors


CXTPTabManagerNavigateButton Class

XTPTabManager.h, Classes, Legend, Members, Topics, CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Constructors, CXTPTabManagerNavigateButton Destructors, CXTPTabManagerNavigateButton Constructors, CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Destructors, Example, CXTPTabManagerNavigateButton Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton Class

CXTPTabManagerNavigateButton is a class used to represent the tab navigation buttons.

Class Hierarchy

class CXTPTabManagerNavigateButton;
File

XTPTabManager.h

Remarks

Navigation button are the buttons that appear in the tab header area. The buttons include the left arrow, right arrow, and close buttons. Any combination of these buttons can be shown. You can choose to never display then, always display them, or automatically display them. If yo automatically display the buttons, they are only displayed when needed. I.e, When there are too many tabs to display in the tab header, the arrow buttons appear.

By default these all these buttons are displayed in the CommandBars TabWorkSpace. You will need to add them to the TabControl.

If the xtpTabNavigateButtonAutomatic flag is used, then the button will appear only when needed. I.e. When the XTPTabLayoutStyle is set to xtpTabLayoutAutoSize, all tab might not fit in the tab header area. When there are more tabs than can fit in the header, the button will automatically be displayed.

See Also

XTPTabNavigateButtonFlags, CXTPTabManager::FindNavigateButton

Example

This example code illustrates how to specify when the tab navigation buttons are displayed.

//Finds the left navigation button and specifies that it is always displayed
m_wndTabControl.FindNavigateButton(xtpTabNavigateButtonLeft)->SetFlags(xtpTabNavigateButtonAlways);
//Finds the right navigation button and specifies that it is never displayed
m_wndTabControl.FindNavigateButton(xtpTabNavigateButtonRight)->SetFlags(xtpTabNavigateButtonNone);
//Finds the close navigation button and specifies that it is always displayed
m_wndTabControl.FindNavigateButton(xtpTabNavigateButtonClose)->SetFlags(xtpTabNavigateButtonAlways);

//Called to recalculate tab area and reposition components
Reposition();
Group

Classes

Legend
Data Member
protected
Method
virtual
abstract
CXTPTabManagerNavigateButton Constructors
CXTPTabManagerNavigateButton Constructors | Description
CXTPTabManagerNavigateButton | Constructs a CXTPTabManagerNavigateButton object.
CXTPTabManagerNavigateButton Data Members
CXTPTabManagerNavigateButton Data Members | Description
m_bEnabled | TRUE if the navigation button is enables.
m_bPressed | TRUE if the navigation button is pressedclicked.
m_dwFlags | Flag that indicates when the navigation button will be drawn.
m_nID | Id of the navigation button.
m_pItem | Owner item.
m_pManager | Pointer to the TabManager the navigation buttons are drawn on.
m_rcButton | Bounding rectangle of the navigation button.
m_strToolTip | Tooltip for the button.
CXTPTabManagerNavigateButton Destructors
CXTPTabManagerNavigateButton Destructors | Description
~CXTPTabManagerNavigateButton | Destroys a CXTPTabManagerNavigateButton object, handles cleanup and deallocation
CXTPTabManagerNavigateButton Methods
CXTPTabManagerNavigateButton Methods | Description
AdjustWidth | Call this member to adjust the width of the tab header area. This will subtract the width of the navigate button from the width of the tab header area supplied.
Draw | Call this member to draw the navigation button in the tab header area.
DrawEntry | This member is called to draw a symbol in the tab navigation button. I.e. "<", ">" or "x". This member must be overridden in derived classes.
GetFlags | Call this member to determine when the navigation button is displayed.
GetID | Call this method to get identifier of the button
GetItem | Call this member to get parent Item of the button.
GetRect | Call this member to get the bounding rectangle of the navigation button.
GetSize | Call this member to retrieve size of the button.
GetTooltip | Call this member to get the tooltip displayed when the mouse pointer is positioned over the button.
IsEnabled | Call this member to determine if the navigation button is enabled.
IsHighlighted | This member is called to determine if the navigation button is currently highlighted. This occurs when the mouse cursor is positioned over the navigation button.
IsPressed | This member is called to determine if the navigation button is currently pressed.
IsVisible | Call this member to determine if the navigation button is currently visible.
OnExecute | This member is called when a navigation button is clicked.
PerformClick | This member is called when the user presses the left mouse button.
Reposition | This method is called to update self position.
SetFlags | Call this member to specify when the navigation button is displayed.
SetRect | This member is called to set bounding rectangle of the navigation button.
SetTooltip | Call this member to set the tooltip for this button. This is the text that will be displayed when the mouse pointer is positioned over the button.


CXTPTabManagerNavigateButton Data Members

CXTPTabManagerNavigateButton Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton Data Members
Class

CXTPTabManagerNavigateButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bEnabled | TRUE if the navigation button is enables.
m_bPressed | TRUE if the navigation button is pressedclicked.
m_dwFlags | Flag that indicates when the navigation button will be drawn.
m_nID | Id of the navigation button.
m_pItem | Owner item.
m_pManager | Pointer to the TabManager the navigation buttons are drawn on.
m_rcButton | Bounding rectangle of the navigation button.
m_strToolTip | Tooltip for the button.


CXTPTabManagerNavigateButton::m_bEnabled Data Member

CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::m_bEnabled Data Member

TRUE if the navigation button is enables.

BOOL m_bEnabled;
Group

CXTPTabManagerNavigateButton Data Members


CXTPTabManagerNavigateButton::m_bPressed Data Member

CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::m_bPressed Data Member

TRUE if the navigation button is pressedclicked.

BOOL m_bPressed;
Group

CXTPTabManagerNavigateButton Data Members


CXTPTabManagerNavigateButton::m_dwFlags Data Member

CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::m_dwFlags Data Member

Flag that indicates when the navigation button will be drawn.

XTPTabNavigateButtonFlags m_dwFlags;
Group

CXTPTabManagerNavigateButton Data Members


CXTPTabManagerNavigateButton::m_nID Data Member

CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::m_nID Data Member

Id of the navigation button.

UINT m_nID;
Group

CXTPTabManagerNavigateButton Data Members


CXTPTabManagerNavigateButton::m_pItem Data Member

CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::m_pItem Data Member

Owner item.

CXTPTabManagerItem* m_pItem;
Group

CXTPTabManagerNavigateButton Data Members


CXTPTabManagerNavigateButton::m_pManager Data Member

CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::m_pManager Data Member

Pointer to the TabManager the navigation buttons are drawn on.

CXTPTabManager* m_pManager;
Group

CXTPTabManagerNavigateButton Data Members


CXTPTabManagerNavigateButton::m_rcButton Data Member

CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::m_rcButton Data Member

Bounding rectangle of the navigation button.

CRect m_rcButton;
Group

CXTPTabManagerNavigateButton Data Members


CXTPTabManagerNavigateButton::m_strToolTip Data Member

CXTPTabManagerNavigateButton Data Members, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::m_strToolTip Data Member

Tooltip for the button.

CString m_strToolTip;
Group

CXTPTabManagerNavigateButton Data Members


CXTPTabManagerNavigateButton Methods

CXTPTabManagerNavigateButton Class, Legend, Public Methods
CXTPTabManagerNavigateButton Methods
Class

CXTPTabManagerNavigateButton Class

Legend
Method
virtual
abstract
Public Methods
Public Methods
Public Method | Description
AdjustWidth | Call this member to adjust the width of the tab header area. This will subtract the width of the navigate button from the width of the tab header area supplied.
Draw | Call this member to draw the navigation button in the tab header area.
DrawEntry | This member is called to draw a symbol in the tab navigation button. I.e. "<", ">" or "x". This member must be overridden in derived classes.
GetFlags | Call this member to determine when the navigation button is displayed.
GetID | Call this method to get identifier of the button
GetItem | Call this member to get parent Item of the button.
GetRect | Call this member to get the bounding rectangle of the navigation button.
GetSize | Call this member to retrieve size of the button.
GetTooltip | Call this member to get the tooltip displayed when the mouse pointer is positioned over the button.
IsEnabled | Call this member to determine if the navigation button is enabled.
IsHighlighted | This member is called to determine if the navigation button is currently highlighted. This occurs when the mouse cursor is positioned over the navigation button.
IsPressed | This member is called to determine if the navigation button is currently pressed.
IsVisible | Call this member to determine if the navigation button is currently visible.
OnExecute | This member is called when a navigation button is clicked.
PerformClick | This member is called when the user presses the left mouse button.
Reposition | This method is called to update self position.
SetFlags | Call this member to specify when the navigation button is displayed.
SetRect | This member is called to set bounding rectangle of the navigation button.
SetTooltip | Call this member to set the tooltip for this button. This is the text that will be displayed when the mouse pointer is positioned over the button.


CXTPTabManagerNavigateButton::AdjustWidth Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::AdjustWidth Method

Call this member to adjust the width of the tab header area. This will subtract the width of the navigate button from the width of the tab header area supplied.

virtual void AdjustWidth(
    int& nWidth
);
Parameters

nWidth
Width of the tab header area.

Remarks

The width will only be adjusted if the xtpTabNavigateButtonAlways is set. If the tabs are vertical, then the height of the buttons are subtracted from the tab header area.

Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::Draw Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::Draw Method

Call this member to draw the navigation button in the tab header area.

void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::DrawEntry Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::DrawEntry Method

This member is called to draw a symbol in the tab navigation button. I.e. "<", ">" or "x". This member must be overridden in derived classes.

virtual void DrawEntry(
    CDC* pDC,
    CRect rc
) = 0;
Parameters

pDC
Pointer to a valid device context.
rc
Bounding rectangle of tab navigation button.

Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::GetFlags Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::GetFlags Method

Call this member to determine when the navigation button is displayed.

XTPTabNavigateButtonFlags GetFlags() const;
Returns

XTPTabNavigateButtonFlags indicating when the navigation button is displayed.

See Also

XTPTabNavigateButtonFlags, CXTPTabManager::FindNavigateButton, SetFlags

Body Source
XTPTabNavigateButtonFlags CXTPTabManagerNavigateButton::GetFlags() const {
    return m_dwFlags;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::GetID Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::GetID Method

Call this method to get identifier of the button

UINT GetID() const;
Returns

Identifier of the button

Remarks

See XTPTabNavigateButton for list of standard identifiers

See Also

XTPTabNavigateButton

Body Source
UINT CXTPTabManagerNavigateButton::GetID() const {
    return m_nID;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::GetItem Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::GetItem Method

Call this member to get parent Item of the button.

CXTPTabManagerItem* GetItem() const;
Body Source
CXTPTabManagerItem* CXTPTabManagerNavigateButton::GetItem() const {
    return m_pItem;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::GetRect Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::GetRect Method

Call this member to get the bounding rectangle of the navigation button.

CRect GetRect() const;
Returns

Bounding rectangle of navigation button.

Body Source
CRect CXTPTabManagerNavigateButton::GetRect() const {
    return m_rcButton;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::GetSize Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::GetSize Method

Call this member to retrieve size of the button.

virtual CSize GetSize() const;
See Also

GetRect

Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::GetTooltip Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::GetTooltip Method

Call this member to get the tooltip displayed when the mouse pointer is positioned over the button.

CString GetTooltip() const;
Returns

The tooltip displayed when the mouse if over the button.

See Also

SetTooltip

Body Source
CString CXTPTabManagerNavigateButton::GetTooltip() const {
    return m_strToolTip;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::IsEnabled Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::IsEnabled Method

Call this member to determine if the navigation button is enabled.

BOOL IsEnabled() const;
Returns

TRUE if the navigation button is enabled, FALSE if it is disabled.

Body Source
BOOL CXTPTabManagerNavigateButton::IsEnabled() const {
    return m_bEnabled;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::IsHighlighted Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::IsHighlighted Method

This member is called to determine if the navigation button is currently highlighted. This occurs when the mouse cursor is positioned over the navigation button.

BOOL IsHighlighted() const;
Returns

TRUE if the navigation button is currently highlighted.

Remarks

This member is used in the CColorSetDefault::FillNavigateButton function and all other objects derived from CColorSetDefault to determine how to colorize the button.

See Also

CColorSetDefault::FillNavigateButton

Body Source
BOOL CXTPTabManagerNavigateButton::IsHighlighted() const {
    return m_pManager->m_pHighlightedNavigateButton == this;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::IsPressed Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::IsPressed Method

This member is called to determine if the navigation button is currently pressed.

BOOL IsPressed() const;
Returns

TRUE if the navigation button is currently pressed.

Remarks

This member is used in the CColorSetDefault::FillNavigateButton function and all other objects derived from CColorSetDefault to determine how to colorize the button.

See Also

CColorSetDefault::FillNavigateButton

Body Source
BOOL CXTPTabManagerNavigateButton::IsPressed() const {
    return m_bPressed;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::IsVisible Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::IsVisible Method

Call this member to determine if the navigation button is currently visible.

BOOL IsVisible() const;
Returns

TRUE if the navigation button is currently visible, FALSE otherwise.

Body Source
BOOL CXTPTabManagerNavigateButton::IsVisible() const {
    return !m_rcButton.IsRectEmpty();
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::OnExecute Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::OnExecute Method

This member is called when a navigation button is clicked.

virtual void OnExecute(
    BOOL bTick
);
Parameters

bTick
If TRUE, CXTPTabManager::OnNavigateButtonClick will be called passing in the Id of the navigation button that was clicked as a parameter.

Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::PerformClick Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::PerformClick Method

This member is called when the user presses the left mouse button.

virtual void PerformClick(
    HWND hWnd,
    CPoint pt
);
Parameters

hWnd
Handle to the CWnd object beneath the mouse cursor.
pt
Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

When the user clicks on a tab navigation button, CXTPTabManagerNavigateButton::PerformClick will call the OnExecute member, the OnExecute member will then call the CXTPTabManager::OnNavigateButtonClick member passing in the ID of the tab navigation button that was pressed.

This member performs the common operations of when a button is clicked such as drawing the "pressed" button and calling the OnExecute function of the clicked tab navigation button.

See Also

CXTPTabManager::OnNavigateButtonClick

Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::Reposition Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::Reposition Method

This method is called to update self position.

virtual void Reposition(
    CRect& rcNavigateButtons
);
Parameters

rcNavigateButtons
Bounding rectangle of the tab navigation buttons.

Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::SetFlags Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::SetFlags Method

Call this member to specify when the navigation button is displayed.

void SetFlags(
    XTPTabNavigateButtonFlags dwFlags
);
Parameters

dwFlags
Indicates when to display the button.

See Also

XTPTabNavigateButtonFlags, CXTPTabManager::FindNavigateButton, GetFlags

Body Source
void CXTPTabManagerNavigateButton::SetFlags(XTPTabNavigateButtonFlags dwFlags) {
    m_dwFlags = dwFlags;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::SetRect Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::SetRect Method

This member is called to set bounding rectangle of the navigation button.

void SetRect(
    CRect rcButton
);
Parameters

rcButton
Bounding rectangle of navigation button to set.

Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton::SetTooltip Method

CXTPTabManagerNavigateButton Methods, CXTPTabManagerNavigateButton Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::SetTooltip Method

Call this member to set the tooltip for this button. This is the text that will be displayed when the mouse pointer is positioned over the button.

void SetTooltip(
    LPCTSTR lpszTooltip
);
Parameters

lpszTooltip
Tooltip to set for this button.

See Also

GetTooltip

Body Source
void CXTPTabManagerNavigateButton::SetTooltip(LPCTSTR lpszTooltip) {
    m_strToolTip = lpszTooltip;
}
Group

CXTPTabManagerNavigateButton Methods


CXTPTabManagerNavigateButton Constructors

CXTPTabManagerNavigateButton Class, Legend, Public Methods
CXTPTabManagerNavigateButton Constructors
Class

CXTPTabManagerNavigateButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabManagerNavigateButton | Constructs a CXTPTabManagerNavigateButton object.


CXTPTabManagerNavigateButton::CXTPTabManagerNavigateButton Constructor

CXTPTabManagerNavigateButton Constructors, CXTPTabManagerNavigateButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::CXTPTabManagerNavigateButton Constructor

Constructs a CXTPTabManagerNavigateButton object.

CXTPTabManagerNavigateButton(
    CXTPTabManager* pManager,
    UINT nID,
    XTPTabNavigateButtonFlags dwFlags
);
Parameters

pManager
CXTPTabManager object to draw the button on.
nID
Id of the button, can be one of the values listed in the Remarks section.
dwFlags
Indicates when to display the button.

Remarks

Standard ids of buttons are listed below:

  • xtpTabNavigateButtonLeft Left tab navigation button.
  • xtpTabNavigateButtonRight Right tab navigation button.
  • xtpTabNavigateButtonClose Close tab navigation button.
See Also

CXTPTabManager::FindNavigateButton, XTPTabNavigateButtonFlags, XTPTabNavigateButton

Group

CXTPTabManagerNavigateButton Constructors


CXTPTabManagerNavigateButton Destructors

CXTPTabManagerNavigateButton Class, Legend, Public Methods
CXTPTabManagerNavigateButton Destructors
Class

CXTPTabManagerNavigateButton Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTabManagerNavigateButton | Destroys a CXTPTabManagerNavigateButton object, handles cleanup and deallocation


CXTPTabManagerNavigateButton::~CXTPTabManagerNavigateButton Destructor

CXTPTabManagerNavigateButton Destructors, CXTPTabManagerNavigateButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabManagerNavigateButton::~CXTPTabManagerNavigateButton Destructor

Destroys a CXTPTabManagerNavigateButton object, handles cleanup and deallocation

virtual ~CXTPTabManagerNavigateButton();
Group

CXTPTabManagerNavigateButton Destructors


CXTPTabPaintManager Class

XTPTabPaintManager.h, Classes, Legend, Members, Topics, CXTPTabPaintManager Classes, CXTPTabPaintManager Data Members, CXTPTabPaintManager Methods, CXTPTabPaintManager Constructors, CXTPTabPaintManager Destructors, CXTPTabPaintManager Classes, CXTPTabPaintManager Constructors, CXTPTabPaintManager Data Members, CXTPTabPaintManager Destructors, CXTPTabPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager Class

CXTPTabPaintManager is a CCmdTarget derived class that is used to store the color and appearance information of the tabs in the tab manager.

Class Hierarchy

class CXTPTabPaintManager;
File

XTPTabPaintManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTabPaintManager Classes
CXTPTabPaintManager Classes | Description
CAppearanceSet | CAppearanceSet is a class that represents the appearance of all the components (tab button, tab caption font, button size, tab margins, etc) of the tab manager.
CAppearanceSetExcel | CAppearanceSetExcel is a CAppearanceSetFlat derived class that represents the Excel tab appearance.
CAppearanceSetFlat | CAppearanceSetFlat is a CAppearanceSet derived class that represents the "Flat" tab appearance.
CAppearanceSetPropertyPage | CAppearanceSetPropertyPage is a CAppearanceSet derived class that represents the Office 2000 tab appearance.
CAppearanceSetPropertyPage2003 | CAppearanceSetPropertyPage2003 is a CAppearanceSet derived class that represents the Office 2003 tab appearance.
CAppearanceSetPropertyPage2007 | CAppearanceSetPropertyPage2007 is a CAppearanceSet derived class that represents the Office 2007 tab appearance.
CAppearanceSetPropertyPageAccess2007 | CAppearanceSetPropertyPageAccess2007 is a CAppearanceSet derived class that represents the Office 2007 tab appearance.
CAppearanceSetPropertyPageFlat | CAppearanceSetPropertyPageFlat is a CAppearanceSetFlat derived class that represents the Office 2000 Flat tab appearance.
CAppearanceSetPropertyPageSelected | CAppearanceSetPropertyPageSelected is a CAppearanceSetPropertyPage derived class that represents the "Office 2000 Selected" tab appearance.
CAppearanceSetStateButtons | CAppearanceSetStateButtons is a CAppearanceSet derived class that represents the "State Button" tab appearance.
CAppearanceSetVisio | CAppearanceSetVisio is a CAppearanceSet derived class that represents the Visio tab appearance.
CAppearanceSetVisualStudio | CAppearanceSetVisualStudio is a CAppearanceSet derived class that represents the Visual Studio tab appearance.
CAppearanceSetVisualStudio2005 | CAppearanceSetVisualStudio2005 is a CAppearanceSetPropertyPage2003 derived class that represents the Visual Studio 2005 tab appearance.
CColorSet | CColorSet is a class that represents the colors of all the components (tab button, tab button border, etc) of the tab manager.
CColorSetAccess2007 | CColorSetAccess2007 is a CColorSetOffice2007 derived class that represents the Office 2007 tab color set.
CColorSetDefault | CColorSetDefault is a CColorSet derived class that represents the default tab color set.
CColorSetOffice2003 | CColorSetOffice2003 is a CColorSetDefault derived class that represents the Office 2003 tab color set.
CColorSetOffice2007 | CColorSetOffice2007 is a CColorSetOffice2003 derived class that represents the Office 2007 tab color set.
CColorSetVisualStudio | CColorSetVisualStudio is a CColorSetDefault derived class that represents the Visual Studio tab color set.
CColorSetVisualStudio2008 | CColorSetVisualStudio2008 is a CColorSetOffice2003 derived class that represents the Visual Studio 2008 tab color set.
CColorSetWhidbey | CColorSetWhidbey is a CColorSetOffice2003 derived class that represents the Visual Studio 2005 "Whidbey" tab color set.
CColorSetWinXP | CColorSetWinXP is a CColorSetDefault derived class that represents the Windows XP tab color set.
CXTPTabPaintManager Constructors
CXTPTabPaintManager Constructors | Description
CXTPTabPaintManager | Constructs a CXTPTabPaintManager object.
CXTPTabPaintManager Data Members
CXTPTabPaintManager Data Members | Description
m_arrObservers | List of controls that receive notification when a property of paint manager has changed.
m_bBoldNormal | If TRUE, bold font will be used for all tab both selected and non-selected.
m_bBoldSelected | If TRUE, the text of selected tabs will be displayed in bold font
m_bClearTypeTextQuality | TRUE to enable ClearType text for the font.
m_bClipHeader | TRUE to select clip rectangle before draw tabs
m_bDisableLunaColors | If FALSE, Tabs will not use LunaColors, is the current theme uses LunaColors
m_bDrawFocusRect | TRUE to draw focus rect for focused item.
m_bDrawTextEndEllipsis | If TRUE, when the size of a tab button is too small to display the caption the end of the caption will be replaced with an ellipse "...", If FALSE, the the end of the caption will be replaced with the ellipse.
m_bDrawTextHidePrefix | If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
m_bDrawTextNoPrefix | If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
m_bDrawTextPathEllipsis | If TRUE, when the size of a tab button is too small to display the caption the middle of the caption will be replaced with an ellipse "...", If FALSE, the the end of the caption will be replaced with the ellipse.
m_bFillBackground | If TRUE, then the tab client space is filled using CXTPTabPaintManager.CColorSet.m_clrControlFace color.
m_bHotTracking | If TRUE, tab hot tracking will be enabled.
m_bInvertGradient | If TRUE, the colors passed into CXTPTabPaintManager::CColorSet::GradientFill will be swapped before the rectangle is filled with the gradient.
m_bMultiRowFixedSelection | FALSE to move row with selected item close to client pane.
m_bMultiRowJustified | Stretch each row of tabs to fill the entire width of the control.
m_bOneNoteColors | If TRUE, tabs will use OneNote colorization
m_bRotateImageOnVerticalDraw | TRUE to rotate image when tab located left or right
m_bSelectOnButtonDown | if TRUE, when tab selected on mouse button down.
m_bSelectOnDragOver | TRUE to activate tab when user drag files/text under it.
m_bShowIcons | If TRUE, tab icons will be drawn is icons were added
m_bShowTabs | TRUE to show tabs
m_bStaticFrame | If TRUE, a static frame will be drawn around the entire tab area
m_bUseStandardFont | TRUE to use standard system "icon" font which is Tahoma 8pt.
m_clientFrame | Frame style of tab client area.
m_fntBold | Font used to display bold text in the tab buttons.
m_fntNormal | Font used to display text in tab buttons.
m_fntVerticalBold | Font used to display bold text in the tab buttons when the tab position is vertical.
m_fntVerticalNormal | Font used to display tab button caption when the tab position is vertical.
m_nButtonExtraLength | Additional padding of tabs
m_nDrawTextFormat | Text format for tabs (default - DT_LEFT | DT_VCENTER)
m_nFixedTabWidth | Tabs width for fixed layout
m_nMaxTabWidth | Maximum tabs width
m_nMinTabWidth | Minimum tabs width
m_pAppearanceSet | Currently set CAppearanceSet.
m_pColorSet | Currently used CColorSet.
m_rcButtonMargin | Margin around the text in tab button.
m_rcButtonTextPadding | Margin around the text in tab button.
m_rcClientMargin | Margin around tab client area.
m_rcControlMargin | Margin around entire tab control (tab client header and tab client area).
m_szIcon | Size of icon displayed in tab button.
m_tabAppearance | Currently set appearance style.
m_tabColor | Currently used color style.
m_tabLayout | Currently set tab button layout.
m_tabPosition | Currently set tab button position.
m_toolBehaviour | Tootips behaviour
CXTPTabPaintManager Destructors
CXTPTabPaintManager Destructors | Description
~CXTPTabPaintManager | Destroys a CXTPTabPaintManager object, handles cleanup and deallocation.
CXTPTabPaintManager Methods
CXTPTabPaintManager Methods | Description
_GetButtonLength | This member is called to get the total button length including the left and right button margin.
AddObserver | This member adds a control to the list of controls that receive notification when a property of paint manager has changed.
AdjustClientRect | This member is called to adjust the client rectangle. It will return the new client rectangle with margins included.
DisableLunaColors | Call this member to enable/disable luna colors.
DrawNavigateButton | This member is called to draw tab navigation buttons.
DrawSingleButtonIconAndText | This method is called to draw the tab button's text and icon.
DrawTabControl | This member is called to draw the tab control.
DrawTabControlEx | This member is called to draw the tab control.
DrawTextPathEllipsis | This member is called to place an ellipse "..." in the middle of a string.
EnableToolTips | Call this member function to enable or disable tooltips show
EnsureVisible | Call this member to ensure that a tab is visible.
FillNavigateButton | This member is called to fill the tab navigation buttons.
GetAppearance | Call this member to determine the currently set appearance style.
GetAppearanceSet | Call this member to get the currently set custom appearance set.
GetBoldFont | Call this method to get the CFont used for displaying tab caption text when bold.
GetColor | Call this member to get the currently used tab color style.
GetColorSet | Call this member to get the currently used custom color set.
GetFont | Call this member to get the CFont used for displaying tab caption text.
GetLayout | Call this member to get the currently set tab layout.
GetOneNoteColor | Retrieves the COLORREF value for the specified OneNote color.
GetPosition | Call this member to set the position of the tab buttons.
IsLunaColorsDisabled | Call this member to determine is luna colors are disabled.
OnPropertyChanged | This member is called when a property of the tab paint manager has changed.
RefreshMetrics | This member is called to refresh the visual metrics of the tab main manager.
RepositionNavigateButtons | This member is called to reposition the tab navigation buttons.
RepositionTabControl | This method is called to move the tab buttons of the tab control to their correct positions.
RepositionTabControlEx | This method is called to move the tab buttons of the tab control to their correct positions.
RepositionTabControlMultiRow | This method is called to move the tab buttons of the multi row tab control to their correct positions.
SetAppearance | Call this member to apply one of the "built-in" appearances to the tabs.
SetAppearanceSet | Call this member to apply a custom appearance set.
SetColor | Call this member to apply one of the "built-in" color sets to the tabs.
SetColorSet | Call this member to apply a custom color set to the tabs.
SetFontIndirect | Call this member to set the font for the tabs.
SetLayout | Call this member to set the tab layout style.
SetOneNoteColors | Call this member to enabledisable OneNote colorization for the tabs.
SetPosition | Call this member to set the tab position.
SizeToFit | This member is called to change the tab button size when the XTPTabLayoutStyle is xtpTabLayoutSizeToFit.


CXTPTabPaintManager Classes

Classes, CXTPTabPaintManager Class
CXTPTabPaintManager Classes
Classes
Class | Description
CAppearanceSet | CAppearanceSet is a class that represents the appearance of all the components (tab button, tab caption font, button size, tab margins, etc) of the tab manager.
CAppearanceSetExcel | CAppearanceSetExcel is a CAppearanceSetFlat derived class that represents the Excel tab appearance.
CAppearanceSetFlat | CAppearanceSetFlat is a CAppearanceSet derived class that represents the "Flat" tab appearance.
CAppearanceSetPropertyPage | CAppearanceSetPropertyPage is a CAppearanceSet derived class that represents the Office 2000 tab appearance.
CAppearanceSetPropertyPage2003 | CAppearanceSetPropertyPage2003 is a CAppearanceSet derived class that represents the Office 2003 tab appearance.
CAppearanceSetPropertyPage2007 | CAppearanceSetPropertyPage2007 is a CAppearanceSet derived class that represents the Office 2007 tab appearance.
CAppearanceSetPropertyPageAccess2007 | CAppearanceSetPropertyPageAccess2007 is a CAppearanceSet derived class that represents the Office 2007 tab appearance.
CAppearanceSetPropertyPageFlat | CAppearanceSetPropertyPageFlat is a CAppearanceSetFlat derived class that represents the Office 2000 Flat tab appearance.
CAppearanceSetPropertyPageSelected | CAppearanceSetPropertyPageSelected is a CAppearanceSetPropertyPage derived class that represents the "Office 2000 Selected" tab appearance.
CAppearanceSetStateButtons | CAppearanceSetStateButtons is a CAppearanceSet derived class that represents the "State Button" tab appearance.
CAppearanceSetVisio | CAppearanceSetVisio is a CAppearanceSet derived class that represents the Visio tab appearance.
CAppearanceSetVisualStudio | CAppearanceSetVisualStudio is a CAppearanceSet derived class that represents the Visual Studio tab appearance.
CAppearanceSetVisualStudio2005 | CAppearanceSetVisualStudio2005 is a CAppearanceSetPropertyPage2003 derived class that represents the Visual Studio 2005 tab appearance.
CColorSet | CColorSet is a class that represents the colors of all the components (tab button, tab button border, etc) of the tab manager.
CColorSetAccess2007 | CColorSetAccess2007 is a CColorSetOffice2007 derived class that represents the Office 2007 tab color set.
CColorSetDefault | CColorSetDefault is a CColorSet derived class that represents the default tab color set.
CColorSetOffice2003 | CColorSetOffice2003 is a CColorSetDefault derived class that represents the Office 2003 tab color set.
CColorSetOffice2007 | CColorSetOffice2007 is a CColorSetOffice2003 derived class that represents the Office 2007 tab color set.
CColorSetVisualStudio | CColorSetVisualStudio is a CColorSetDefault derived class that represents the Visual Studio tab color set.
CColorSetVisualStudio2008 | CColorSetVisualStudio2008 is a CColorSetOffice2003 derived class that represents the Visual Studio 2008 tab color set.
CColorSetWhidbey | CColorSetWhidbey is a CColorSetOffice2003 derived class that represents the Visual Studio 2005 "Whidbey" tab color set.
CColorSetWinXP | CColorSetWinXP is a CColorSetDefault derived class that represents the Windows XP tab color set.
Class

CXTPTabPaintManager Class


CXTPTabPaintManager::CAppearanceSet Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSet Data Members, CAppearanceSet Methods, CAppearanceSet Constructors, CAppearanceSet Destructors, CAppearanceSet Constructors, CAppearanceSet Data Members, CAppearanceSet Destructors, CAppearanceSet Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet Class

CAppearanceSet is a class that represents the appearance of all the components (tab button, tab caption font, button size, tab margins, etc) of the tab manager.

Class Hierarchy

class CAppearanceSet;
File

XTPTabPaintManager.h

Remarks

CAppearanceSet is the base class for all appearances. To create a custom appearance, and new class can be derived from the base class or any of the appearances.

The appearance should be updated in the RefreshMetrics member's for each CAppearanceSet object.

See Also

XTPTabAppearanceStyle, SetAppearance, SetAppearanceSet, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, CColorSet

Group

CXTPTabPaintManager Classes

Legend
Data Member
protected
Method
virtual
CAppearanceSet Constructors
CAppearanceSet Constructors | Description
CAppearanceSet | Constructs a CAppearanceSet object.
CAppearanceSet Data Members
CAppearanceSet Data Members | Description
m_bButtonsReverseZOrder | Draw buttons in right to left order.
m_nButtonHeight | Current tab button height (without margins).
m_nRowMargin | Margin between rows
m_pPaintManager | Self paint manager pointer.
m_rcHeaderMargin | CRect struct containing the left, top, right, and bottom margins of the tab header.
CAppearanceSet Destructors
CAppearanceSet Destructors | Description
~CAppearanceSet | Destroys a CAppearanceSet object, handles cleanup and deallocation.
CAppearanceSet Methods
CAppearanceSet Methods | Description
AdjustClientRect | This member is called to adjust the tab client rectangle. It will return the new tab client rectangle with margins included.
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
DrawTabControl | This member is called to draw the tab control.
DrawWorkspacePart | This member is called to draw the different parts that make up the TabMDIClient TabWorkSpace.
FillButton | This helper method an be called to draw item inside polygon rectangle
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetButtonHeight | This member is called to determine the total height of the tab buttons including the top and bottom margins and icon size.
GetButtonLength | This member is called to get the total button length including the left and right button margin.
GetClientMargin | This method is called to get the top, left, right, and bottom tab client area margins.
GetClientRect | Call this member to get the bounding rectangle to the tab client area.
GetColorSet | Call this member to get the currently used color set.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetHeaderHeight | Call this member to get the height of the tab header area.
GetHeaderMargin | This method is called to get the top, left, right, and bottom tab header margins.
GetHeaderRect | Call this member to get the bounding rectangle to the tab header area.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.
RepositionTabControl | This method is called to move the tab buttons of the tab control to their correct positions.


CAppearanceSet Data Members

CXTPTabPaintManager::CAppearanceSet Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSet Data Members
Class

CXTPTabPaintManager::CAppearanceSet Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bButtonsReverseZOrder | Draw buttons in right to left order.
m_nButtonHeight | Current tab button height (without margins).
m_pPaintManager | Self paint manager pointer.
Public Data Members
Public Data Member | Description
m_nRowMargin | Margin between rows
m_rcHeaderMargin | CRect struct containing the left, top, right, and bottom margins of the tab header.


CXTPTabPaintManager::CAppearanceSet::m_bButtonsReverseZOrder Data Member

CAppearanceSet Data Members, CXTPTabPaintManager::CAppearanceSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::m_bButtonsReverseZOrder Data Member

Draw buttons in right to left order.

BOOL m_bButtonsReverseZOrder;
Group

CAppearanceSet Data Members


CXTPTabPaintManager::CAppearanceSet::m_nButtonHeight Data Member

CAppearanceSet Data Members, CXTPTabPaintManager::CAppearanceSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::m_nButtonHeight Data Member

Current tab button height (without margins).

int m_nButtonHeight;
Group

CAppearanceSet Data Members


CXTPTabPaintManager::CAppearanceSet::m_nRowMargin Data Member

CAppearanceSet Data Members, CXTPTabPaintManager::CAppearanceSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::m_nRowMargin Data Member

Margin between rows

int m_nRowMargin;
Group

CAppearanceSet Data Members


CXTPTabPaintManager::CAppearanceSet::m_pPaintManager Data Member

CAppearanceSet Data Members, CXTPTabPaintManager::CAppearanceSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::m_pPaintManager Data Member

Self paint manager pointer.

CXTPTabPaintManager* m_pPaintManager;
Group

CAppearanceSet Data Members


CXTPTabPaintManager::CAppearanceSet::m_rcHeaderMargin Data Member

CAppearanceSet Data Members, CXTPTabPaintManager::CAppearanceSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::m_rcHeaderMargin Data Member

CRect struct containing the left, top, right, and bottom margins of the tab header.

CRect m_rcHeaderMargin;
Group

CAppearanceSet Data Members


CAppearanceSet Methods

CXTPTabPaintManager::CAppearanceSet Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSet Methods
Class

CXTPTabPaintManager::CAppearanceSet Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AdjustClientRect | This member is called to adjust the tab client rectangle. It will return the new tab client rectangle with margins included.
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
DrawTabControl | This member is called to draw the tab control.
DrawWorkspacePart | This member is called to draw the different parts that make up the TabMDIClient TabWorkSpace.
FillButton | This helper method an be called to draw item inside polygon rectangle
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetButtonHeight | This member is called to determine the total height of the tab buttons including the top and bottom margins and icon size.
GetButtonLength | This member is called to get the total button length including the left and right button margin.
GetClientMargin | This method is called to get the top, left, right, and bottom tab client area margins.
GetClientRect | Call this member to get the bounding rectangle to the tab client area.
GetColorSet | Call this member to get the currently used color set.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetHeaderHeight | Call this member to get the height of the tab header area.
GetHeaderMargin | This method is called to get the top, left, right, and bottom tab header margins.
GetHeaderRect | Call this member to get the bounding rectangle to the tab header area.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.
RepositionTabControl | This method is called to move the tab buttons of the tab control to their correct positions.


CXTPTabPaintManager::CAppearanceSet::AdjustClientRect Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::AdjustClientRect Method

This member is called to adjust the tab client rectangle. It will return the new tab client rectangle with margins included.

virtual void AdjustClientRect(
    CXTPTabManager* pTabManager,
    CRect& rcClient
);
Parameters

pTabManager
Pointer to the tab manager to adjust the tab client rectangle.
rcClient
[out] CRect to store tab client rectangle.

Remarks

CXTPTabPaintManager::AdjustClientRect and CXTPTabPaintManager::RepositionTabControl are called when the window is resized. When CXTPTabPaintManager::DrawTabControl is called the changes will be used when drawing the tab control.

This member will adjust the tab client rectangle based on the currently set XTPTabClientFrame.

Then CXTPTabPaintManager::AdjustClientRect calls this member if there is one or more tab in the tab manager.

See Also

CXTPTabPaintManager::AdjustClientRect

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::DrawSingleButton Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method is overridden in derived classes and will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Body Source
void CXTPTabPaintManager::CAppearanceSet::DrawSingleButton(CDC* /*pDC*/, CXTPTabManagerItem* /*pItem*/) {

}
Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::DrawTabControl Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::DrawTabControl Method

This member is called to draw the tab control.

virtual void DrawTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to the tab manager to draw.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the client area.

Remarks

This member is called in various Draw and Paint functions.

Unless overridden, this member will just call CXTPTabPaintManager::DrawTabControlEx.

See Also

CXTPTabPaintManager::DrawTabControlEx.

Body Source
void CXTPTabPaintManager::CAppearanceSet::DrawTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl) {
    m_pPaintManager->DrawTabControlEx(pTabManager, pDC, rcControl);
}
Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::DrawWorkspacePart Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::DrawWorkspacePart Method

This member is called to draw the different parts that make up the TabMDIClient TabWorkSpace.

virtual void DrawWorkspacePart(
    CDC* pDC,
    LPRECT lpRect,
    XTPTabWorkspacePart workspacePart
);
Parameters

pDC
Pointer to a valid device context.
lpRect
Size of splitter.
workspacePart
XTPTabWorkspacePart to draw.

Remarks

This is used when drawing the TabWorkspace of MDI tabs when tab grouping is enabled.

lpRect is the size of the splitter that is placed between the vertical or horizontal tab groups if workspacePart is XTPTabWorkspacePartHSplitter or XTPTabWorkspacePartVSplitter. And the splitter will be drawn with lpRect.

If workspacePart is XTPTabWorkspacePartWidth, then this is the size of the splitter.

See Also

XTPTabWorkspacePart

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::FillButton Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::FillButton Method

This helper method an be called to draw item inside polygon rectangle

COLORREF FillButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem,
    LPPOINT pts,
    int nCount,
    XTPTabPosition tabPosition,
    BOOL bAbsoulute = FALSE
);
Parameters

pDC
Pointer to device context to draw
pItem
Tab item to draw
pts
Array of points that specified rectangle
nCount
Total number of point in rectangle
tabPosition
Tab position
bAbsoulute
Flag that specified if points specified absolute coordinates

Returns

Color of tab was filled

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::FillTabControl Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::FillTabControl Method

This member fills in the tab header and tab client area. It will then draw tab client frame.

virtual CRect FillTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to tab manager to fill.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.

Returns

Tab header bounding rectangle. This value is returned from GetHeaderRect.

Remarks

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManager::CColorSet::m_clrControlFace color. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing DockingPanePanel AutoHide tabs because there is no client area to draw.

See Also

GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Body Source
CRect CXTPTabPaintManager::CAppearanceSet::FillTabControl(CXTPTabManager* /*pTabManager*/, CDC* /*pDC*/, CRect /*rcControl*/) {
    return 0;
}
Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetButtonDrawRect Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetButtonDrawRect Method

This method called to get bounding rectangle of item that was drawn

virtual CRect GetButtonDrawRect(
    const CXTPTabManagerItem* pItem
);
Parameters

pItem
Item to test

Returns

Bounding rectangle of drawing item

See Also

CXTPTabManagerItem::GetRect

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetButtonHeight Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetButtonHeight Method

This member is called to determine the total height of the tab buttons including the top and bottom margins and icon size.

virtual int GetButtonHeight(
    const CXTPTabManager* pTabManager
);
Parameters

pTabManager
Pointer to the tab manager to get the button height.

Returns

The height of the tab buttons.

Remarks

This member add the size of the left and right margins and the icon size to the size of CXTPTabPaintManager.CAppearanceSet.m_nButtonHeight, which is the current height of the tabs without margins and icon size.

See Also

CXTPTabPaintManager.CAppearanceSet.m_nButtonHeight, CXTPTabPaintManager::m_rcButtonMargin, GetClientMargin, GetHeaderMargin, CXTPTabPaintManager::DrawSingleButtonIconAndText, CXTPTabManager::GetItemMetrics, GetButtonLength

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetButtonLength Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetButtonLength Method

This member is called to get the total button length including the left and right button margin.

virtual int GetButtonLength(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Pointer to tab button to get the length of.

Returns

Tab button length including the left and right button margin.

Remarks

This members calls CXTPTabPaintManager::DrawSingleButtonIconAndText with bDraw = FALSE to get the total button length including margins.

See Also

CXTPTabPaintManager::m_rcButtonMargin, GetClientMargin, GetHeaderMargin, CXTPTabPaintManager::DrawSingleButtonIconAndText, CXTPTabManager::GetItemMetrics, GetButtonHeight

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetClientMargin Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetClientMargin Method

This method is called to get the top, left, right, and bottom tab client area margins.

virtual CRect GetClientMargin();
Returns

CRect struct containing the left, top, right, and bottom margins of the tab client area. This is the margin (space) placed around the tab client area inside the tab control.

Remarks

The CRect structure will contain the margins of the tab client area. CXTPTabPaintManager::m_rcClientMargin contains these margins.

This is the margin placed around the tab client area in the tab control.

See Also

CXTPTabPaintManager::m_rcClientMargin, GetClientRect

Example
// Set the top, left, right, and bottom tab header margins to 5 pixels.  This will
// place a margin of 5 pixels around the tab buttons in the tab header.
m_wndTabControl.GetPaintManager()->GetAppearanceSet()->m_rcHeaderMargin.SetRect(5, 5, 5, 5);

// Set the top, left, right, and bottom tab control margins to 4 pixels.  This will
// place a margin of 4 pixels around the entire tab control (Includes tab header and tab client area).
m_wndTabControl.GetPaintManager()->m_rcControlMargin.SetRect(4, 4, 4, 4);

// Set the top, left, right, and bottom tab button margins to 2 pixels.  This will
// place a margin of 2 pixels around the text and icon in the tab buttons.
m_wndTabControl.GetPaintManager()->m_rcButtonMargin.SetRect(2, 2, 2, 2);

// Set the top, left, right, and bottom tab client margins to 10 pixels.  This will
// place a margin of 10 pixels around the tab client area.
m_wndTabControl.GetPaintManager()->m_rcClientMargin.SetRect(10, 10, 10, 10);
Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetClientRect Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetClientRect Method

Call this member to get the bounding rectangle to the tab client area.

virtual CRect GetClientRect(
    CRect rcControl,
    CXTPTabManager* pTabManager
);
Parameters

rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
pTabManager
Pointer to tab manager.

Returns

Bounding rectangle of tab client area.

See Also

GetHeaderRect, GetHeaderMargin, GetClientMargin, CXTPTabManager::GetControlRect

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetColorSet Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetColorSet Method

Call this member to get the currently used color set.

CColorSet* GetColorSet();
Returns

Currently used custom color set.

See Also

XTPTabColorStyle, CXTPTabPaintManager::GetColor, CXTPTabPaintManager::SetColorSet, CXTPTabPaintManager::SetColor

Body Source
CColorSet* GetColorSet()
{
    return m_pPaintManager->m_pColorSet;
}
Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetDefaultColorSet Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorDefault

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorDefault; }
Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetHeaderHeight Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetHeaderHeight Method

Call this member to get the height of the tab header area.

int GetHeaderHeight(
    CXTPTabManager* pTabManager
);
Parameters

pTabManager
Pointer to tab manager.

Returns

Height of tab header area.

See Also

GetHeaderRect, GetClientRect, GetHeaderMargin, GetClientMargin, CXTPTabManager::GetControlRect

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin Method

This method is called to get the top, left, right, and bottom tab header margins.

virtual CRect GetHeaderMargin();
Returns

CRect struct containing the left, top, right, and bottom margins of the tab header. This is the margin (space) placed around the tab buttons inside the tab header.

Remarks

The CRect structure will contain the margins of the tab header. m_rcHeaderMargin contains these margins.

This is the margin placed around the tab buttons in the tab header. This is not placed around each tab button, but all the tab buttons.

See Also

m_rcHeaderMargin, GetHeaderRect

Example
// Set the top, left, right, and bottom tab header margins to 5 pixels.  This will
// place a margin of 5 pixels around the tab buttons in the tab header.
m_wndTabControl.GetPaintManager()->GetAppearanceSet()->m_rcHeaderMargin.SetRect(5, 5, 5, 5);

// Set the top, left, right, and bottom tab control margins to 4 pixels.  This will
// place a margin of 4 pixels around the entire tab control (Includes tab header and tab client area).
m_wndTabControl.GetPaintManager()->m_rcControlMargin.SetRect(4, 4, 4, 4);

// Set the top, left, right, and bottom tab button margins to 2 pixels.  This will
// place a margin of 2 pixels around the text and icon in the tab buttons.
m_wndTabControl.GetPaintManager()->m_rcButtonMargin.SetRect(2, 2, 2, 2);

// Set the top, left, right, and bottom tab client margins to 10 pixels.  This will
// place a margin of 10 pixels around the tab client area.
m_wndTabControl.GetPaintManager()->m_rcClientMargin.SetRect(10, 10, 10, 10);
Body Source
CRect CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin() {
    return m_rcHeaderMargin;
}
Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetHeaderRect Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetHeaderRect Method

Call this member to get the bounding rectangle to the tab header area.

virtual CRect GetHeaderRect(
    CRect rcControl,
    CXTPTabManager* pTabManager
);
Parameters

rcControl
Bounding rectangle of the tab header. See CXTPTabManager::GetControlRect.
pTabManager
Pointer to tab manager.

Returns

Bounding rectangle of tab header area.

See Also

GetClientRect, GetHeaderMargin, GetClientMargin, CXTPTabManager::GetControlRect

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::GetSupportedColorSets Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::GetSupportedColorSets Method

Call this member to retrieve all the supported XTPTabColorStyle for this appearance.

virtual int GetSupportedColorSets();
Returns

xtpTabColorDefault | xtpTabColorVisualStudio | xtpTabColorOffice2003 | xtpTabColorWinXP | xtpTabColorWhidbey

See Also

GetDefaultColorSet

Body Source
virtual int GetSupportedColorSets() { return xtpTabColorDefault | xtpTabColorVisualStudio | xtpTabColorOffice2003 | xtpTabColorWinXP | xtpTabColorWhidbey | xtpTabColorVisualStudio2008; }
Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::RefreshMetrics Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::RefreshMetrics Method

This member is called to refresh the appearance metrics.

virtual void RefreshMetrics();
Remarks

This member is used to refresh the appearance metrics such as font, button height, margin size, etc. Override this member in derived classes to change the appearance metrics.

See Also

CXTPTabPaintManager::SetFontIndirect, GetHeaderMargin, GetClientMargin, GetButtonLength, GetButtonHeight

Group

CAppearanceSet Methods


CXTPTabPaintManager::CAppearanceSet::RepositionTabControl Method

CAppearanceSet Methods, CXTPTabPaintManager::CAppearanceSet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::RepositionTabControl Method

This method is called to move the tab buttons of the tab control to their correct positions.

virtual void RepositionTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcClient
);
Parameters

pTabManager
Pointer to the tab manager the tab button are on.
pDC
Pointer to a valid device context.
rcClient
Bounding rectangle of the tab client area.

Remarks

CXTPTabPaintManager::RepositionTabControl and CXTPTabPaintManager::AdjustClientRect are called when the window is resized. When DrawTabControl is called the changes will be used when drawing the tab control.

This member is called by CXTPTabPaintManager::RepositionTabControl. Unless overridden this member will just call CXTPTabPaintManager::RepositionTabControlEx.

Body Source
void CXTPTabPaintManager::CAppearanceSet::RepositionTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcClient) {
    m_pPaintManager->RepositionTabControlEx(pTabManager, pDC, rcClient);
}
Group

CAppearanceSet Methods


CAppearanceSet Constructors

CXTPTabPaintManager::CAppearanceSet Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSet Constructors
Class

CXTPTabPaintManager::CAppearanceSet Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSet | Constructs a CAppearanceSet object.


CXTPTabPaintManager::CAppearanceSet::CAppearanceSet Constructor

CAppearanceSet Constructors, CXTPTabPaintManager::CAppearanceSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::CAppearanceSet Constructor

Constructs a CAppearanceSet object.

CAppearanceSet();
Group

CAppearanceSet Constructors


CAppearanceSet Destructors

CXTPTabPaintManager::CAppearanceSet Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSet Destructors
Class

CXTPTabPaintManager::CAppearanceSet Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CAppearanceSet | Destroys a CAppearanceSet object, handles cleanup and deallocation.


CXTPTabPaintManager::CAppearanceSet::~CAppearanceSet Destructor

CAppearanceSet Destructors, CXTPTabPaintManager::CAppearanceSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSet::~CAppearanceSet Destructor

Destroys a CAppearanceSet object, handles cleanup and deallocation.

virtual ~CAppearanceSet();
Group

CAppearanceSet Destructors


CXTPTabPaintManager::CAppearanceSetExcel Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetExcel Methods, CAppearanceSetExcel Constructors, CAppearanceSetExcel Constructors, CAppearanceSetExcel Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetExcel Class

CAppearanceSetExcel is a CAppearanceSetFlat derived class that represents the Excel tab appearance.

Class Hierarchy

class CAppearanceSetExcel : public CAppearanceSetFlat;
File

XTPTabPaintManager.h

Remarks

To use the Excel appearance, SetAppearance is used to apply the xtpTabAppearanceExcel XTPTabAppearanceStyle.

CAppearanceSetExcel supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorVisualStudio Visual Studio color style.
  • xtpTabColorOffice2003 Office 2003 color style.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CAppearanceSetExcel Constructors
CAppearanceSetExcel Constructors | Description
CAppearanceSetExcel | Constructs a CAppearanceSetExcel object.
CAppearanceSetExcel Methods
CAppearanceSetExcel Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetHeaderMargin | This method is called to get the top, left, right, and bottom tab header margins.


CAppearanceSetExcel Methods

CXTPTabPaintManager::CAppearanceSetExcel Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetExcel Methods
Class

CXTPTabPaintManager::CAppearanceSetExcel Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetHeaderMargin | This method is called to get the top, left, right, and bottom tab header margins.


CXTPTabPaintManager::CAppearanceSetExcel::DrawSingleButton Method

CAppearanceSetExcel Methods, CXTPTabPaintManager::CAppearanceSetExcel Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetExcel::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Group

CAppearanceSetExcel Methods


CXTPTabPaintManager::CAppearanceSetExcel::GetButtonDrawRect Method

CAppearanceSetExcel Methods, CXTPTabPaintManager::CAppearanceSetExcel Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetExcel::GetButtonDrawRect Method

This method called to get bounding rectangle of item that was drawn

virtual CRect GetButtonDrawRect(
    const CXTPTabManagerItem* pItem
);
Parameters

pItem
Item to test

Returns

Bounding rectangle of drawing item

See Also

CXTPTabManagerItem::GetRect

Group

CAppearanceSetExcel Methods


CXTPTabPaintManager::CAppearanceSetExcel::GetHeaderMargin Method

CAppearanceSetExcel Methods, CXTPTabPaintManager::CAppearanceSetExcel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetExcel::GetHeaderMargin Method

This method is called to get the top, left, right, and bottom tab header margins.

virtual CRect GetHeaderMargin();
Returns

CRect struct containing the left, top, right, and bottom margins of the tab header. This is the margin (space) placed around the tab buttons inside the tab header.

Remarks

The CRect structure will contain the margins of the tab header. CXTPTabPaintManager::CAppearanceSet::m_rcHeaderMargin contains these margins.

See Also

CXTPTabPaintManager::CAppearanceSet::m_rcHeaderMargin, CXTPTabPaintManager::GetHeaderRect

Body Source
virtual CRect GetHeaderMargin()
{
    return CRect(m_rcHeaderMargin.left + m_nButtonHeight / 2, m_rcHeaderMargin.top, m_rcHeaderMargin.right + m_nButtonHeight / 2, m_rcHeaderMargin.bottom);
}
Group

CAppearanceSetExcel Methods


CAppearanceSetExcel Constructors

CXTPTabPaintManager::CAppearanceSetExcel Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetExcel Constructors
Class

CXTPTabPaintManager::CAppearanceSetExcel Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetExcel | Constructs a CAppearanceSetExcel object.


CXTPTabPaintManager::CAppearanceSetExcel::CAppearanceSetExcel Constructor

CAppearanceSetExcel Constructors, CXTPTabPaintManager::CAppearanceSetExcel Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetExcel::CAppearanceSetExcel Constructor

Constructs a CAppearanceSetExcel object.

CAppearanceSetExcel();
Body Source
CAppearanceSetExcel()
{
    m_rcHeaderMargin.SetRect(2, 3, 2, 0);
}
Group

CAppearanceSetExcel Constructors


CXTPTabPaintManager::CAppearanceSetFlat Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetFlat Methods, CAppearanceSetFlat Constructors, CAppearanceSetFlat Constructors, CAppearanceSetFlat Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetFlat Class

CAppearanceSetFlat is a CAppearanceSet derived class that represents the "Flat" tab appearance.

Class Hierarchy

class CAppearanceSetFlat : public CAppearanceSet;
File

XTPTabPaintManager.h

Remarks

To use the Flat appearance, SetAppearance is used to apply the xtpTabAppearanceFlat XTPTabAppearanceStyle.

CAppearanceSetFlat supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorVisualStudio Visual Studio color style.
  • xtpTabColorOffice2003 Office 2003 color style.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CAppearanceSetFlat Constructors
CAppearanceSetFlat Constructors | Description
CAppearanceSetFlat | Constructs a CAppearanceSetFlat object.
CAppearanceSetFlat Methods
CAppearanceSetFlat Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.


CAppearanceSetFlat Methods

CXTPTabPaintManager::CAppearanceSetFlat Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetFlat Methods
Class

CXTPTabPaintManager::CAppearanceSetFlat Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.


CXTPTabPaintManager::CAppearanceSetFlat::DrawSingleButton Method

CAppearanceSetFlat Methods, CXTPTabPaintManager::CAppearanceSetFlat Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetFlat::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Group

CAppearanceSetFlat Methods


CXTPTabPaintManager::CAppearanceSetFlat::FillTabControl Method

CAppearanceSetFlat Methods, CXTPTabPaintManager::CAppearanceSetFlat Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetFlat::FillTabControl Method

This member fills in the tab header and tab client area. It will then draw tab client frame.

virtual CRect FillTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to tab manager to fill.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.

Returns

Tab header bounding rectangle. This value is returned from GetHeaderRect.

Remarks

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManager::CColorSet::m_clrControlFace color. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing DockingPanePanel AutoHide tabs because there is no client area to draw.

See Also

CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Group

CAppearanceSetFlat Methods


CXTPTabPaintManager::CAppearanceSetFlat::GetDefaultColorSet Method

CAppearanceSetFlat Methods, CXTPTabPaintManager::CAppearanceSetFlat Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetFlat::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorVisualStudio

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorVisualStudio; }
Group

CAppearanceSetFlat Methods


CXTPTabPaintManager::CAppearanceSetFlat::GetSupportedColorSets Method

CAppearanceSetFlat Methods, CXTPTabPaintManager::CAppearanceSetFlat Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetFlat::GetSupportedColorSets Method

Call this member to retrieve all the supported XTPTabColorStyle for this appearance.

virtual int GetSupportedColorSets();
Returns

xtpTabColorDefault |xtpTabColorVisualStudio | xtpTabColorOffice2003

See Also

GetDefaultColorSet

Body Source
virtual int GetSupportedColorSets() { return xtpTabColorDefault |xtpTabColorVisualStudio | xtpTabColorOffice2003; }
Group

CAppearanceSetFlat Methods


CAppearanceSetFlat Constructors

CXTPTabPaintManager::CAppearanceSetFlat Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetFlat Constructors
Class

CXTPTabPaintManager::CAppearanceSetFlat Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetFlat | Constructs a CAppearanceSetFlat object.


CXTPTabPaintManager::CAppearanceSetFlat::CAppearanceSetFlat Constructor

CAppearanceSetFlat Constructors, CXTPTabPaintManager::CAppearanceSetFlat Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetFlat::CAppearanceSetFlat Constructor

Constructs a CAppearanceSetFlat object.

CAppearanceSetFlat();
Body Source
CAppearanceSetFlat()
{
    m_rcHeaderMargin.SetRect(2, 2, 4, 0);
}
Group

CAppearanceSetFlat Constructors


CXTPTabPaintManager::CAppearanceSetPropertyPage Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetPropertyPage Methods, CAppearanceSetPropertyPage Constructors, CAppearanceSetPropertyPage Constructors, CAppearanceSetPropertyPage Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage Class

CAppearanceSetPropertyPage is a CAppearanceSet derived class that represents the Office 2000 tab appearance.

Class Hierarchy

class CAppearanceSetPropertyPage : public CAppearanceSet;
File

XTPTabPaintManager.h

Remarks

To use the Office 2000 appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPage XTPTabAppearanceStyle.

CAppearanceSetPropertyPage supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorOffice2003 Office 2003 color style.
  • xtpTabColorWinXP Windows XP color style.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CAppearanceSetPropertyPage Constructors
CAppearanceSetPropertyPage Constructors | Description
CAppearanceSetPropertyPage | Constructs a CAppearanceSetPropertyPage object.
CAppearanceSetPropertyPage Methods
CAppearanceSetPropertyPage Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetClientMargin | This method is called to get the top, left, right, and bottom tab client area margins.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.


CAppearanceSetPropertyPage Methods

CXTPTabPaintManager::CAppearanceSetPropertyPage Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPage Methods
Class

CXTPTabPaintManager::CAppearanceSetPropertyPage Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetClientMargin | This method is called to get the top, left, right, and bottom tab client area margins.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.


CXTPTabPaintManager::CAppearanceSetPropertyPage::DrawSingleButton Method

CAppearanceSetPropertyPage Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Group

CAppearanceSetPropertyPage Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage::FillTabControl Method

CAppearanceSetPropertyPage Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage::FillTabControl Method

This member fills in the tab header and tab client area. It will then draw tab client frame.

virtual CRect FillTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to tab manager to fill.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.

Returns

Tab header bounding rectangle. This value is returned from GetHeaderRect.

Remarks

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManager::CColorSet::m_clrControlFace color. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing DockingPanePanel AutoHide tabs because there is no client area to draw.

See Also

CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Group

CAppearanceSetPropertyPage Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage::GetButtonDrawRect Method

CAppearanceSetPropertyPage Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage::GetButtonDrawRect Method

This method called to get bounding rectangle of item that was drawn

virtual CRect GetButtonDrawRect(
    const CXTPTabManagerItem* pItem
);
Parameters

pItem
Item to test

Returns

Bounding rectangle of drawing item

See Also

CXTPTabManagerItem::GetRect

Group

CAppearanceSetPropertyPage Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage::GetClientMargin Method

CAppearanceSetPropertyPage Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage::GetClientMargin Method

This method is called to get the top, left, right, and bottom tab client area margins.

virtual CRect GetClientMargin();
Returns

CRect struct containing the left, top, right, and bottom margins of the tab client area. This is the margin (space) placed around the tab client area inside the tab control.

Remarks

The CRect structure will contain the margins of the tab client area. CXTPTabPaintManager::m_rcClientMargin contains these margins.

This is the margin placed around the tab client area in the tab control.

See Also

CXTPTabPaintManager::m_rcClientMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin,

Example
// Set the top, left, right, and bottom tab header margins to 5 pixels.  This will
// place a margin of 5 pixels around the tab buttons in the tab header.
m_wndTabControl.GetPaintManager()->GetAppearanceSet()->m_rcHeaderMargin.SetRect(5, 5, 5, 5);

// Set the top, left, right, and bottom tab control margins to 4 pixels.  This will
// place a margin of 4 pixels around the entire tab control (Includes tab header and tab client area).
m_wndTabControl.GetPaintManager()->m_rcControlMargin.SetRect(4, 4, 4, 4);

// Set the top, left, right, and bottom tab button margins to 2 pixels.  This will
// place a margin of 2 pixels around the text and icon in the tab buttons.
m_wndTabControl.GetPaintManager()->m_rcButtonMargin.SetRect(2, 2, 2, 2);

// Set the top, left, right, and bottom tab client margins to 10 pixels.  This will
// place a margin of 10 pixels around the tab client area.
m_wndTabControl.GetPaintManager()->m_rcClientMargin.SetRect(10, 10, 10, 10);
Group

CAppearanceSetPropertyPage Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage::GetDefaultColorSet Method

CAppearanceSetPropertyPage Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorDefault

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorDefault; }
Group

CAppearanceSetPropertyPage Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage::GetSupportedColorSets Method

CAppearanceSetPropertyPage Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage::GetSupportedColorSets Method

Call this member to retrieve all the supported XTPTabColorStyle for this appearance.

virtual int GetSupportedColorSets();
Returns

xtpTabColorDefault | xtpTabColorOffice2003 | xtpTabColorWinXP

See Also

GetDefaultColorSet

Body Source
virtual int GetSupportedColorSets() { return xtpTabColorDefault | xtpTabColorOffice2003 | xtpTabColorWinXP; }
Group

CAppearanceSetPropertyPage Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage::RefreshMetrics Method

CAppearanceSetPropertyPage Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage::RefreshMetrics Method

This member is called to refresh the appearance metrics.

virtual void RefreshMetrics();
Remarks

This member is used to refresh the appearance metrics such as font, button height, margin size, etc. Override this member to change the appearance metrics.

See Also

CXTPTabPaintManager::SetFontIndirect, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetClientMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetButtonLength, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetButtonHeight

Group

CAppearanceSetPropertyPage Methods


CAppearanceSetPropertyPage Constructors

CXTPTabPaintManager::CAppearanceSetPropertyPage Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPage Constructors
Class

CXTPTabPaintManager::CAppearanceSetPropertyPage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPage | Constructs a CAppearanceSetPropertyPage object.


CXTPTabPaintManager::CAppearanceSetPropertyPage::CAppearanceSetPropertyPage Constructor

CAppearanceSetPropertyPage Constructors, CXTPTabPaintManager::CAppearanceSetPropertyPage Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage::CAppearanceSetPropertyPage Constructor

Constructs a CAppearanceSetPropertyPage object.

CAppearanceSetPropertyPage();
Body Source
CAppearanceSetPropertyPage()
{
    m_rcHeaderMargin.SetRect(2, 3, 6, 0);
}
Group

CAppearanceSetPropertyPage Constructors


CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetPropertyPage2003 Data Members, CAppearanceSetPropertyPage2003 Methods, CAppearanceSetPropertyPage2003 Constructors, CAppearanceSetPropertyPage2003 Constructors, CAppearanceSetPropertyPage2003 Data Members, CAppearanceSetPropertyPage2003 Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class

CAppearanceSetPropertyPage2003 is a CAppearanceSet derived class that represents the Office 2003 tab appearance.

Class Hierarchy

class CAppearanceSetPropertyPage2003 : public CAppearanceSet;
File

XTPTabPaintManager.h

Remarks

To use the Office 2003 appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPage2003 XTPTabAppearanceStyle.

CAppearanceSetPropertyPage2003 supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorOffice2003 Office 2003 color style.
  • xtpTabColorWhidbey Visual Studio 2005 "Whidbey" color style.

By default m_bDoubleHighlightedBorder is FALSE. If TRUE then a double border is drawn on mouse over when hot tracking is enabled.

See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Data Member
Method
virtual
CAppearanceSetPropertyPage2003 Constructors
CAppearanceSetPropertyPage2003 Constructors | Description
CAppearanceSetPropertyPage2003 | Constructs a CAppearanceSetPropertyPage2003 object.
CAppearanceSetPropertyPage2003 Data Members
CAppearanceSetPropertyPage2003 Data Members | Description
m_bDoubleHighlightedBorder | TRUE to draw a double border on mouse over when hot tracking is enabled.
CAppearanceSetPropertyPage2003 Methods
CAppearanceSetPropertyPage2003 Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetHeaderMargin | This method is called to get the top, left, right, and bottom tab header margins.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.


CAppearanceSetPropertyPage2003 Data Members

CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPage2003 Data Members
Class

CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bDoubleHighlightedBorder | TRUE to draw a double border on mouse over when hot tracking is enabled.


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::m_bDoubleHighlightedBorder Data Member

CAppearanceSetPropertyPage2003 Data Members, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::m_bDoubleHighlightedBorder Data Member

TRUE to draw a double border on mouse over when hot tracking is enabled.

BOOL m_bDoubleHighlightedBorder;
Group

CAppearanceSetPropertyPage2003 Data Members


CAppearanceSetPropertyPage2003 Methods

CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPage2003 Methods
Class

CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetHeaderMargin | This method is called to get the top, left, right, and bottom tab header margins.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::DrawSingleButton Method

CAppearanceSetPropertyPage2003 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

If m_bDoubleHighlightedBorder = TRUE, then a double border is drawn on mouse over when hot tracking is enabled.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bDoubleHighlightedBorder

Group

CAppearanceSetPropertyPage2003 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::FillTabControl Method

CAppearanceSetPropertyPage2003 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::FillTabControl Method

This member fills in the tab header and tab client area. It will then draw tab client frame.

virtual CRect FillTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to tab manager to fill.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.

Returns

Tab header bounding rectangle. This value is returned from GetHeaderRect.

Remarks

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManager::CColorSet::m_clrControlFace color. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing DockingPanePanel AutoHide tabs because there is no client area to draw.

See Also

CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Group

CAppearanceSetPropertyPage2003 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::GetButtonDrawRect Method

CAppearanceSetPropertyPage2003 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::GetButtonDrawRect Method

This method called to get bounding rectangle of item that was drawn

virtual CRect GetButtonDrawRect(
    const CXTPTabManagerItem* pItem
);
Parameters

pItem
Item to test

Returns

Bounding rectangle of drawing item

See Also

CXTPTabManagerItem::GetRect

Group

CAppearanceSetPropertyPage2003 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::GetDefaultColorSet Method

CAppearanceSetPropertyPage2003 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorOffice2003

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorOffice2003; }
Group

CAppearanceSetPropertyPage2003 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::GetHeaderMargin Method

CAppearanceSetPropertyPage2003 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::GetHeaderMargin Method

This method is called to get the top, left, right, and bottom tab header margins.

virtual CRect GetHeaderMargin();
Returns

CRect struct containing the left, top, right, and bottom margins of the tab header. This is the margin (space) placed around the tab buttons inside the tab header.

Remarks

The CRect structure will contain the margins of the tab header. CXTPTabPaintManager::CAppearanceSet::m_rcHeaderMargin contains these margins.

See Also

CXTPTabPaintManager::CAppearanceSet::m_rcHeaderMargin, CXTPTabPaintManager::GetHeaderRect

Body Source
virtual CRect GetHeaderMargin()
{
    return CRect(m_rcHeaderMargin.left + m_nButtonHeight, m_rcHeaderMargin.top, m_rcHeaderMargin.right, m_rcHeaderMargin.bottom);
}
Group

CAppearanceSetPropertyPage2003 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::GetSupportedColorSets Method

CAppearanceSetPropertyPage2003 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::GetSupportedColorSets Method

Call this member to retrieve all the supported XTPTabColorStyle for this appearance.

virtual int GetSupportedColorSets();
Returns

xtpTabColorDefault | xtpTabColorOffice2003 | xtpTabColorWhidbey

See Also

GetDefaultColorSet

Body Source
virtual int GetSupportedColorSets() { return xtpTabColorDefault | xtpTabColorOffice2003 | xtpTabColorWhidbey | xtpTabColorVisualStudio2008; }
Group

CAppearanceSetPropertyPage2003 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::RefreshMetrics Method

CAppearanceSetPropertyPage2003 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::RefreshMetrics Method

This member is called to refresh the appearance metrics.

virtual void RefreshMetrics();
Remarks

This member is used to refresh the appearance metrics such as font, button height, margin size, etc. Override this member to change the appearance metrics.

See Also

CXTPTabPaintManager::SetFontIndirect, GetHeaderMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetClientMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetButtonLength, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetButtonHeight

Group

CAppearanceSetPropertyPage2003 Methods


CAppearanceSetPropertyPage2003 Constructors

CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPage2003 Constructors
Class

CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPage2003 | Constructs a CAppearanceSetPropertyPage2003 object.


CXTPTabPaintManager::CAppearanceSetPropertyPage2003::CAppearanceSetPropertyPage2003 Constructor

CAppearanceSetPropertyPage2003 Constructors, CXTPTabPaintManager::CAppearanceSetPropertyPage2003 Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2003::CAppearanceSetPropertyPage2003 Constructor

Constructs a CAppearanceSetPropertyPage2003 object.

CAppearanceSetPropertyPage2003();
Body Source
CAppearanceSetPropertyPage2003()
{
    m_rcHeaderMargin.SetRect(2, 3, 6, 0);
    m_bDoubleHighlightedBorder = FALSE;
}
Group

CAppearanceSetPropertyPage2003 Constructors


CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetPropertyPage2007 Methods, CAppearanceSetPropertyPage2007 Constructors, CAppearanceSetPropertyPage2007 Constructors, CAppearanceSetPropertyPage2007 Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class

CAppearanceSetPropertyPage2007 is a CAppearanceSet derived class that represents the Office 2007 tab appearance.

Class Hierarchy

class CAppearanceSetPropertyPage2007 : public CAppearanceSet;
File

XTPTabPaintManager.h

Remarks

To use the Office 2007 appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPage2007 XTPTabAppearanceStyle.

See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
protected
virtual
CAppearanceSetPropertyPage2007 Constructors
CAppearanceSetPropertyPage2007 Constructors | Description
CAppearanceSetPropertyPage2007 | Constructs a CAppearanceSetPropertyPage2003 object.
CAppearanceSetPropertyPage2007 Methods
CAppearanceSetPropertyPage2007 Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.


CAppearanceSetPropertyPage2007 Methods

CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPage2007 Methods
Class

CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.


CXTPTabPaintManager::CAppearanceSetPropertyPage2007::DrawSingleButton Method

CAppearanceSetPropertyPage2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2007::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

If m_bDoubleHighlightedBorder = TRUE, then a double border is drawn on mouse over when hot tracking is enabled.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bDoubleHighlightedBorder

Group

CAppearanceSetPropertyPage2007 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2007::FillTabControl Method

CAppearanceSetPropertyPage2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2007::FillTabControl Method

This member fills in the tab header and tab client area. It will then draw tab client frame.

virtual CRect FillTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to tab manager to fill.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.

Returns

Tab header bounding rectangle. This value is returned from GetHeaderRect.

Remarks

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManager::CColorSet::m_clrControlFace color. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing DockingPanePanel AutoHide tabs because there is no client area to draw.

See Also

CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Group

CAppearanceSetPropertyPage2007 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2007::GetDefaultColorSet Method

CAppearanceSetPropertyPage2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2007::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorOffice2003

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorOffice2007; }
Group

CAppearanceSetPropertyPage2007 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2007::GetSupportedColorSets Method

CAppearanceSetPropertyPage2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2007::GetSupportedColorSets Method

Call this member to retrieve all the supported XTPTabColorStyle for this appearance.

virtual int GetSupportedColorSets();
Returns

xtpTabColorDefault | xtpTabColorOffice2003 | xtpTabColorWhidbey

See Also

GetDefaultColorSet

Body Source
virtual int GetSupportedColorSets() { return xtpTabColorOffice2007; }
Group

CAppearanceSetPropertyPage2007 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPage2007::RefreshMetrics Method

CAppearanceSetPropertyPage2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2007::RefreshMetrics Method

This member is called to refresh the appearance metrics.

virtual void RefreshMetrics();
Remarks

This member is used to refresh the appearance metrics such as font, button height, margin size, etc. Override this member to change the appearance metrics.

See Also

CXTPTabPaintManager::SetFontIndirect, GetHeaderMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetClientMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetButtonLength, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetButtonHeight

Group

CAppearanceSetPropertyPage2007 Methods


CAppearanceSetPropertyPage2007 Constructors

CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPage2007 Constructors
Class

CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPage2007 | Constructs a CAppearanceSetPropertyPage2003 object.


CXTPTabPaintManager::CAppearanceSetPropertyPage2007::CAppearanceSetPropertyPage2007 Constructor

CAppearanceSetPropertyPage2007 Constructors, CXTPTabPaintManager::CAppearanceSetPropertyPage2007 Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPage2007::CAppearanceSetPropertyPage2007 Constructor

Constructs a CAppearanceSetPropertyPage2003 object.

CAppearanceSetPropertyPage2007();
Body Source
CAppearanceSetPropertyPage2007()
{
    m_rcHeaderMargin.SetRect(4, 1, 0, 0);
}
Group

CAppearanceSetPropertyPage2007 Constructors


CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetPropertyPageAccess2007 Methods, CAppearanceSetPropertyPageAccess2007 Constructors, CAppearanceSetPropertyPageAccess2007 Constructors, CAppearanceSetPropertyPageAccess2007 Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class

CAppearanceSetPropertyPageAccess2007 is a CAppearanceSet derived class that represents the Office 2007 tab appearance.

Class Hierarchy

class CAppearanceSetPropertyPageAccess2007 : public CAppearanceSetPropertyPage2007;
File

XTPTabPaintManager.h

Remarks

To use the Office 2007 appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPage2007 XTPTabAppearanceStyle.

See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
protected
virtual
CAppearanceSetPropertyPageAccess2007 Constructors
CAppearanceSetPropertyPageAccess2007 Constructors | Description
CAppearanceSetPropertyPageAccess2007 | Constructs a CAppearanceSetPropertyPageAccess2007 object.
CAppearanceSetPropertyPageAccess2007 Methods
CAppearanceSetPropertyPageAccess2007 Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.


CAppearanceSetPropertyPageAccess2007 Methods

CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPageAccess2007 Methods
Class

CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RefreshMetrics | This member is called to refresh the appearance metrics.


CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::DrawSingleButton Method

CAppearanceSetPropertyPageAccess2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

If m_bDoubleHighlightedBorder = TRUE, then a double border is drawn on mouse over when hot tracking is enabled.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bDoubleHighlightedBorder

Group

CAppearanceSetPropertyPageAccess2007 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::FillTabControl Method

CAppearanceSetPropertyPageAccess2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::FillTabControl Method

This member fills in the tab header and tab client area. It will then draw tab client frame.

virtual CRect FillTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to tab manager to fill.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.

Returns

Tab header bounding rectangle. This value is returned from GetHeaderRect.

Remarks

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManager::CColorSet::m_clrControlFace color. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing DockingPanePanel AutoHide tabs because there is no client area to draw.

See Also

CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Group

CAppearanceSetPropertyPageAccess2007 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::GetDefaultColorSet Method

CAppearanceSetPropertyPageAccess2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorOffice2003

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorAccess2007; }
Group

CAppearanceSetPropertyPageAccess2007 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::GetSupportedColorSets Method

CAppearanceSetPropertyPageAccess2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::GetSupportedColorSets Method

Call this member to retrieve all the supported XTPTabColorStyle for this appearance.

virtual int GetSupportedColorSets();
Returns

xtpTabColorDefault | xtpTabColorOffice2003 | xtpTabColorWhidbey

See Also

GetDefaultColorSet

Body Source
virtual int GetSupportedColorSets() { return xtpTabColorAccess2007; }
Group

CAppearanceSetPropertyPageAccess2007 Methods


CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::RefreshMetrics Method

CAppearanceSetPropertyPageAccess2007 Methods, CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::RefreshMetrics Method

This member is called to refresh the appearance metrics.

virtual void RefreshMetrics();
Remarks

This member is used to refresh the appearance metrics such as font, button height, margin size, etc. Override this member to change the appearance metrics.

See Also

CXTPTabPaintManager::SetFontIndirect, GetHeaderMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetClientMargin, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetButtonLength, CXTPTabPaintManager::CAppearanceSet::GetHeaderMargin::GetButtonHeight

Group

CAppearanceSetPropertyPageAccess2007 Methods


CAppearanceSetPropertyPageAccess2007 Constructors

CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPageAccess2007 Constructors
Class

CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPageAccess2007 | Constructs a CAppearanceSetPropertyPageAccess2007 object.


CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::CAppearanceSetPropertyPageAccess2007 Constructor

CAppearanceSetPropertyPageAccess2007 Constructors, CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007 Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageAccess2007::CAppearanceSetPropertyPageAccess2007 Constructor

Constructs a CAppearanceSetPropertyPageAccess2007 object.

CAppearanceSetPropertyPageAccess2007();
Body Source
CAppearanceSetPropertyPageAccess2007()
{
    m_rcHeaderMargin.SetRect(4, 1, 0, 0);
}
Group

CAppearanceSetPropertyPageAccess2007 Constructors


CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetPropertyPageFlat Data Members, CAppearanceSetPropertyPageFlat Methods, CAppearanceSetPropertyPageFlat Constructors, CAppearanceSetPropertyPageFlat Constructors, CAppearanceSetPropertyPageFlat Data Members, CAppearanceSetPropertyPageFlat Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class

CAppearanceSetPropertyPageFlat is a CAppearanceSetFlat derived class that represents the Office 2000 Flat tab appearance.

Class Hierarchy

class CAppearanceSetPropertyPageFlat : public CAppearanceSetFlat;
File

XTPTabPaintManager.h

Remarks

To use the Office 2000 Flat appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPageFlat XTPTabAppearanceStyle.

CAppearanceSetPropertyPageSelected supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorVisualStudio Visual Studio color style.
  • xtpTabColorOffice2003 Office 2003 color style.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Data Member
Method
virtual
CAppearanceSetPropertyPageFlat Constructors
CAppearanceSetPropertyPageFlat Constructors | Description
CAppearanceSetPropertyPageFlat | Constructs a CAppearanceSetPropertyPageFlat object.
CAppearanceSetPropertyPageFlat Data Members
CAppearanceSetPropertyPageFlat Data Members | Description
m_bBlurPoints | TRUE to smooth corners of flat tabs.
m_bVisualStudio2005Style | TRUE to draw with Visual Studio 2005 style
CAppearanceSetPropertyPageFlat Methods
CAppearanceSetPropertyPageFlat Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.


CAppearanceSetPropertyPageFlat Data Members

CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPageFlat Data Members
Class

CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bBlurPoints | TRUE to smooth corners of flat tabs.
m_bVisualStudio2005Style | TRUE to draw with Visual Studio 2005 style


CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::m_bBlurPoints Data Member

CAppearanceSetPropertyPageFlat Data Members, CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::m_bBlurPoints Data Member

TRUE to smooth corners of flat tabs.

BOOL m_bBlurPoints;
Group

CAppearanceSetPropertyPageFlat Data Members


CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::m_bVisualStudio2005Style Data Member

CAppearanceSetPropertyPageFlat Data Members, CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::m_bVisualStudio2005Style Data Member

TRUE to draw with Visual Studio 2005 style

BOOL m_bVisualStudio2005Style;
Group

CAppearanceSetPropertyPageFlat Data Members


CAppearanceSetPropertyPageFlat Methods

CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPageFlat Methods
Class

CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.


CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::DrawSingleButton Method

CAppearanceSetPropertyPageFlat Methods, CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

If m_bBlurPoints is TRUE, then the corners of the tabs will be smoothed.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bBlurPoints

Group

CAppearanceSetPropertyPageFlat Methods


CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::GetDefaultColorSet Method

CAppearanceSetPropertyPageFlat Methods, CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorDefault

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorDefault; }
Group

CAppearanceSetPropertyPageFlat Methods


CAppearanceSetPropertyPageFlat Constructors

CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPageFlat Constructors
Class

CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPageFlat | Constructs a CAppearanceSetPropertyPageFlat object.


CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::CAppearanceSetPropertyPageFlat Constructor

CAppearanceSetPropertyPageFlat Constructors, CXTPTabPaintManager::CAppearanceSetPropertyPageFlat Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageFlat::CAppearanceSetPropertyPageFlat Constructor

Constructs a CAppearanceSetPropertyPageFlat object.

CAppearanceSetPropertyPageFlat();
Remarks

By default, m_bBlurPoints is TRUE. This will smooth the edges of the tabs.

Body Source
CAppearanceSetPropertyPageFlat()
{
    m_bBlurPoints = TRUE;
    m_bVisualStudio2005Style = FALSE;
}
Group

CAppearanceSetPropertyPageFlat Constructors


CXTPTabPaintManager::CAppearanceSetPropertyPageSelected Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetPropertyPageSelected Methods, CAppearanceSetPropertyPageSelected Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageSelected Class

CAppearanceSetPropertyPageSelected is a CAppearanceSetPropertyPage derived class that represents the "Office 2000 Selected" tab appearance.

Class Hierarchy

class CAppearanceSetPropertyPageSelected : public CAppearanceSetPropertyPage;
File

XTPTabPaintManager.h

Remarks

To use the Office 2000 Selected appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPageSelected XTPTabAppearanceStyle.

CAppearanceSetPropertyPageSelected supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorOffice2003 Office 2003 color style.
  • xtpTabColorWinXP Windows XP color style.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CAppearanceSetPropertyPageSelected Methods
CAppearanceSetPropertyPageSelected Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.


CAppearanceSetPropertyPageSelected Methods

CXTPTabPaintManager::CAppearanceSetPropertyPageSelected Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetPropertyPageSelected Methods
Class

CXTPTabPaintManager::CAppearanceSetPropertyPageSelected Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.


CXTPTabPaintManager::CAppearanceSetPropertyPageSelected::DrawSingleButton Method

CAppearanceSetPropertyPageSelected Methods, CXTPTabPaintManager::CAppearanceSetPropertyPageSelected Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetPropertyPageSelected::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

If the tab button is selected or highlighted then CXTPTabPaintManager::CAppearanceSetPropertyPageSelected::DrawSingleButton is called instead of CXTPTabPaintManager::DrawSingleButtonIconAndText.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Group

CAppearanceSetPropertyPageSelected Methods


CXTPTabPaintManager::CAppearanceSetStateButtons Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetStateButtons Methods, CAppearanceSetStateButtons Constructors, CAppearanceSetStateButtons Constructors, CAppearanceSetStateButtons Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetStateButtons Class

CAppearanceSetStateButtons is a CAppearanceSet derived class that represents the "State Button" tab appearance.

Class Hierarchy

class CAppearanceSetStateButtons : public CAppearanceSet;
File

XTPTabPaintManager.h

Remarks

To use the "State Button" appearance, SetAppearance is used to apply the xtpTabAppearanceStateButtons XTPTabAppearanceStyle.

CAppearanceSetStateButtons supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorVisualStudio Visual Studio color style.
  • xtpTabColorOffice2003 Office 2003 color style.
  • xtpTabColorWinXP Windows XP color style.
  • xtpTabColorWhidbey Visual Studio 2005 "Whidbey" color style.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CAppearanceSetStateButtons Constructors
CAppearanceSetStateButtons Constructors | Description
CAppearanceSetStateButtons | Constructs a CAppearanceSetStateButtons object.
CAppearanceSetStateButtons Methods
CAppearanceSetStateButtons Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.


CAppearanceSetStateButtons Methods

CXTPTabPaintManager::CAppearanceSetStateButtons Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetStateButtons Methods
Class

CXTPTabPaintManager::CAppearanceSetStateButtons Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.


CXTPTabPaintManager::CAppearanceSetStateButtons::DrawSingleButton Method

CAppearanceSetStateButtons Methods, CXTPTabPaintManager::CAppearanceSetStateButtons Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetStateButtons::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Group

CAppearanceSetStateButtons Methods


CXTPTabPaintManager::CAppearanceSetStateButtons::FillTabControl Method

CAppearanceSetStateButtons Methods, CXTPTabPaintManager::CAppearanceSetStateButtons Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetStateButtons::FillTabControl Method

This member fills in the tab header and tab client area. It will then draw tab client frame.

virtual CRect FillTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to tab manager to fill.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.

Returns

Tab header bounding rectangle. This value is returned from GetHeaderRect.

Remarks

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManager::CColorSet::m_clrControlFace color. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing DockingPanePanel AutoHide tabs because there is no client area to draw.

See Also

CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Group

CAppearanceSetStateButtons Methods


CXTPTabPaintManager::CAppearanceSetStateButtons::GetDefaultColorSet Method

CAppearanceSetStateButtons Methods, CXTPTabPaintManager::CAppearanceSetStateButtons Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetStateButtons::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorVisualStudio

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorVisualStudio; }
Group

CAppearanceSetStateButtons Methods


CAppearanceSetStateButtons Constructors

CXTPTabPaintManager::CAppearanceSetStateButtons Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetStateButtons Constructors
Class

CXTPTabPaintManager::CAppearanceSetStateButtons Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetStateButtons | Constructs a CAppearanceSetStateButtons object.


CXTPTabPaintManager::CAppearanceSetStateButtons::CAppearanceSetStateButtons Constructor

CAppearanceSetStateButtons Constructors, CXTPTabPaintManager::CAppearanceSetStateButtons Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetStateButtons::CAppearanceSetStateButtons Constructor

Constructs a CAppearanceSetStateButtons object.

CAppearanceSetStateButtons();
Body Source
CAppearanceSetStateButtons()
{
    m_rcHeaderMargin.SetRect(2, 2, 4, 2);
    m_nRowMargin = 0;
}
Group

CAppearanceSetStateButtons Constructors


CXTPTabPaintManager::CAppearanceSetVisio Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetVisio Methods, CAppearanceSetVisio Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisio Class

CAppearanceSetVisio is a CAppearanceSet derived class that represents the Visio tab appearance.

Class Hierarchy

class CAppearanceSetVisio : public CAppearanceSet;
File

XTPTabPaintManager.h

Remarks

To use the Visio appearance, SetAppearance is used to apply the xtpTabAppearanceVisio XTPTabAppearanceStyle.

CAppearanceSetVisio supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorOffice2003 Office 2003 color style.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
CAppearanceSetVisio Methods
CAppearanceSetVisio Methods | Description
AdjustClientRect | This member is called to adjust the tab client rectangle. It will return the new tab client rectangle with margins included.
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
DrawTabControl | This member is called to draw the tab control.
GetClientRect | Call this member to get the bounding rectangle to the tab client area.
GetHeaderRect | Call this member to get the bounding rectangle to the tab header area.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RepositionTabControl | This method is called to move the tab buttons of the tab control to their correct positions.


CAppearanceSetVisio Methods

CXTPTabPaintManager::CAppearanceSetVisio Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetVisio Methods
Class

CXTPTabPaintManager::CAppearanceSetVisio Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AdjustClientRect | This member is called to adjust the tab client rectangle. It will return the new tab client rectangle with margins included.
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
DrawTabControl | This member is called to draw the tab control.
GetClientRect | Call this member to get the bounding rectangle to the tab client area.
GetHeaderRect | Call this member to get the bounding rectangle to the tab header area.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.
RepositionTabControl | This method is called to move the tab buttons of the tab control to their correct positions.


CXTPTabPaintManager::CAppearanceSetVisio::AdjustClientRect Method

CAppearanceSetVisio Methods, CXTPTabPaintManager::CAppearanceSetVisio Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisio::AdjustClientRect Method

This member is called to adjust the tab client rectangle. It will return the new tab client rectangle with margins included.

void AdjustClientRect(
    CXTPTabManager* pTabManager,
    CRect& rcClient
);
Parameters

pTabManager
Pointer to the tab manager to adjust the tab client rectangle.
rcClient
[out] CRect to store tab client rectangle.

Remarks

CXTPTabPaintManager::AdjustClientRect and CXTPTabPaintManager::RepositionTabControl are called when the window is resized. When CXTPTabPaintManager::DrawTabControl is called the changes will be used when drawing the tab control.

This member will adjust the tab client rectangle based on the currently set XTPTabClientFrame.

Then CXTPTabPaintManager::AdjustClientRect calls this member if there is one or more tab in the tab manager.

See Also

CXTPTabPaintManager::AdjustClientRect

Group

CAppearanceSetVisio Methods


CXTPTabPaintManager::CAppearanceSetVisio::DrawSingleButton Method

CAppearanceSetVisio Methods, CXTPTabPaintManager::CAppearanceSetVisio Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisio::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Group

CAppearanceSetVisio Methods


CXTPTabPaintManager::CAppearanceSetVisio::DrawTabControl Method

CAppearanceSetVisio Methods, CXTPTabPaintManager::CAppearanceSetVisio Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisio::DrawTabControl Method

This member is called to draw the tab control.

void DrawTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to the tab manager to draw.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the client area.

Remarks

This member is called in various Draw and Paint functions.

This member will be called by CXTPTabPaintManager::DrawTabControl when the tab control needs to be drawn.

Group

CAppearanceSetVisio Methods


CXTPTabPaintManager::CAppearanceSetVisio::GetClientRect Method

CAppearanceSetVisio Methods, CXTPTabPaintManager::CAppearanceSetVisio Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisio::GetClientRect Method

Call this member to get the bounding rectangle to the tab client area.

CRect GetClientRect(
    CRect rcControl,
    CXTPTabManager* pTabManager
);
Parameters

rcControl
Bounding rectangle of the tab control.
pTabManager
Pointer to a CXTPTabManager.

Returns

Bounding rectangle of tab client area.

See Also

GetClientRect, CXTPTabManager::GetControlRect

Group

CAppearanceSetVisio Methods


CXTPTabPaintManager::CAppearanceSetVisio::GetHeaderRect Method

CAppearanceSetVisio Methods, CXTPTabPaintManager::CAppearanceSetVisio Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisio::GetHeaderRect Method

Call this member to get the bounding rectangle to the tab header area.

CRect GetHeaderRect(
    CRect rcControl,
    CXTPTabManager* pTabManager
);
Parameters

rcControl
Bounding rectangle of the tab header. See CXTPTabManager::GetControlRect.
pTabManager
Pointer to a CXTPTabManager.

Returns

Bounding rectangle of tab header area.

See Also

GetClientRect, CXTPTabManager::GetControlRect, CXTPTabManager::CAppearanceSet::GetHeaderMargin, CXTPTabManager::CAppearanceSet::GetClientMargin

Group

CAppearanceSetVisio Methods


CXTPTabPaintManager::CAppearanceSetVisio::GetSupportedColorSets Method

CAppearanceSetVisio Methods, CXTPTabPaintManager::CAppearanceSetVisio Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisio::GetSupportedColorSets Method

Call this member to retrieve all the supported XTPTabColorStyle for this appearance.

int GetSupportedColorSets();
Returns

xtpTabColorDefault | xtpTabColorOffice2003

See Also

GetDefaultColorSet

Body Source
int GetSupportedColorSets() { return xtpTabColorDefault | xtpTabColorOffice2003; }
Group

CAppearanceSetVisio Methods


CXTPTabPaintManager::CAppearanceSetVisio::RepositionTabControl Method

CAppearanceSetVisio Methods, CXTPTabPaintManager::CAppearanceSetVisio Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisio::RepositionTabControl Method

This method is called to move the tab buttons of the tab control to their correct positions.

void RepositionTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcClient
);
Parameters

pTabManager
Pointer to the tab manager the tab button are on.
pDC
Pointer to a valid device context.
rcClient
Bounding rectangle of the tab client area.

Remarks

CXTPTabPaintManager::RepositionTabControl and CXTPTabPaintManager::AdjustClientRect are called when the window is resized. When DrawTabControl is called the changes will be used when drawing the tab control.

This member is called in CXTPTabPaintManager::RepositionTabControl. This member calls CXTPTabPaintManager::RepositionTabControlEx.

Group

CAppearanceSetVisio Methods


CXTPTabPaintManager::CAppearanceSetVisualStudio Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetVisualStudio Methods, CAppearanceSetVisualStudio Constructors, CAppearanceSetVisualStudio Constructors, CAppearanceSetVisualStudio Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio Class

CAppearanceSetVisualStudio is a CAppearanceSet derived class that represents the Visual Studio tab appearance.

Class Hierarchy

class CAppearanceSetVisualStudio : public CAppearanceSet;
File

XTPTabPaintManager.h

Remarks

To use the Visual Studio appearance, SetAppearance is used to apply the xtpTabAppearanceVisualStudio XTPTabAppearanceStyle.

CAppearanceSetVisualStudio supports the following XTPTabColorStyle:

  • xtpTabColorDefault Default color style.
  • xtpTabColorVisualStudio Visual Studio color style.
  • xtpTabColorOffice2003 Office 2003 color style.
  • xtpTabColorWinXP Windows XP color style.
  • xtpTabColorWhidbey Visual Studio 2005 "Whidbey" color style.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CAppearanceSetVisualStudio Constructors
CAppearanceSetVisualStudio Constructors | Description
CAppearanceSetVisualStudio | Constructs a CAppearanceSetVisualStudio object.
CAppearanceSetVisualStudio Methods
CAppearanceSetVisualStudio Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.


CAppearanceSetVisualStudio Methods

CXTPTabPaintManager::CAppearanceSetVisualStudio Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetVisualStudio Methods
Class

CXTPTabPaintManager::CAppearanceSetVisualStudio Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
FillTabControl | This member fills in the tab header and tab client area. It will then draw tab client frame.
GetDefaultColorSet | Call this member to get the default XTPTabColorStyle for this appearance.
GetSupportedColorSets | Call this member to retrieve all the supported XTPTabColorStyle for this appearance.


CXTPTabPaintManager::CAppearanceSetVisualStudio::DrawSingleButton Method

CAppearanceSetVisualStudio Methods, CXTPTabPaintManager::CAppearanceSetVisualStudio Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Group

CAppearanceSetVisualStudio Methods


CXTPTabPaintManager::CAppearanceSetVisualStudio::FillTabControl Method

CAppearanceSetVisualStudio Methods, CXTPTabPaintManager::CAppearanceSetVisualStudio Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio::FillTabControl Method

This member fills in the tab header and tab client area. It will then draw tab client frame.

virtual CRect FillTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to tab manager to fill.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.

Returns

Tab header bounding rectangle. This value is returned from GetHeaderRect.

Remarks

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManager::CColorSet::m_clrControlFace color. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing DockingPanePanel AutoHide tabs because there is no client area to draw.

See Also

CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Group

CAppearanceSetVisualStudio Methods


CXTPTabPaintManager::CAppearanceSetVisualStudio::GetDefaultColorSet Method

CAppearanceSetVisualStudio Methods, CXTPTabPaintManager::CAppearanceSetVisualStudio Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio::GetDefaultColorSet Method

Call this member to get the default XTPTabColorStyle for this appearance.

virtual XTPTabColorStyle GetDefaultColorSet();
Returns

xtpTabColorVisualStudio

See Also

GetSupportedColorSets

Body Source
virtual XTPTabColorStyle GetDefaultColorSet() { return xtpTabColorVisualStudio; }
Group

CAppearanceSetVisualStudio Methods


CXTPTabPaintManager::CAppearanceSetVisualStudio::GetSupportedColorSets Method

CAppearanceSetVisualStudio Methods, CXTPTabPaintManager::CAppearanceSetVisualStudio Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio::GetSupportedColorSets Method

Call this member to retrieve all the supported XTPTabColorStyle for this appearance.

virtual int GetSupportedColorSets();
Returns

xtpTabColorDefault |xtpTabColorVisualStudio | xtpTabColorOffice2003

See Also

GetDefaultColorSet

Body Source
virtual int GetSupportedColorSets() { return xtpTabColorDefault | xtpTabColorVisualStudio | xtpTabColorOffice2003; }
Group

CAppearanceSetVisualStudio Methods


CAppearanceSetVisualStudio Constructors

CXTPTabPaintManager::CAppearanceSetVisualStudio Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetVisualStudio Constructors
Class

CXTPTabPaintManager::CAppearanceSetVisualStudio Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetVisualStudio | Constructs a CAppearanceSetVisualStudio object.


CXTPTabPaintManager::CAppearanceSetVisualStudio::CAppearanceSetVisualStudio Constructor

CAppearanceSetVisualStudio Constructors, CXTPTabPaintManager::CAppearanceSetVisualStudio Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio::CAppearanceSetVisualStudio Constructor

Constructs a CAppearanceSetVisualStudio object.

CAppearanceSetVisualStudio();
Body Source
CAppearanceSetVisualStudio()
{
    m_rcHeaderMargin.SetRect(4, 2, 4, 0);
}
Group

CAppearanceSetVisualStudio Constructors


CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CAppearanceSetVisualStudio2005 Methods, CAppearanceSetVisualStudio2005 Constructors, CAppearanceSetVisualStudio2005 Constructors, CAppearanceSetVisualStudio2005 Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class

CAppearanceSetVisualStudio2005 is a CAppearanceSetPropertyPage2003 derived class that represents the Visual Studio 2005 tab appearance.

Class Hierarchy

class CAppearanceSetVisualStudio2005 : public CAppearanceSetPropertyPage2003;
File

XTPTabPaintManager.h

Remarks

To use the Visual Studio appearance, SetAppearance is used to apply the xtpTabAppearanceVisualStudio2005 XTPTabAppearanceStyle.

See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CAppearanceSetVisualStudio2005 Constructors
CAppearanceSetVisualStudio2005 Constructors | Description
CAppearanceSetVisualStudio2005 | Constructs a CAppearanceSetVisualStudio2005 object.
CAppearanceSetVisualStudio2005 Methods
CAppearanceSetVisualStudio2005 Methods | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetHeaderMargin | This method is called to get the top, left, right, and bottom tab header margins.


CAppearanceSetVisualStudio2005 Methods

CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetVisualStudio2005 Methods
Class

CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawSingleButton | This method is called to draw a single tab button in the tab client header area.
GetButtonDrawRect | This method called to get bounding rectangle of item that was drawn
GetHeaderMargin | This method is called to get the top, left, right, and bottom tab header margins.


CXTPTabPaintManager::CAppearanceSetVisualStudio2005::DrawSingleButton Method

CAppearanceSetVisualStudio2005 Methods, CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio2005::DrawSingleButton Method

This method is called to draw a single tab button in the tab client header area.

virtual void DrawSingleButton(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw.

Remarks

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

: CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Group

CAppearanceSetVisualStudio2005 Methods


CXTPTabPaintManager::CAppearanceSetVisualStudio2005::GetButtonDrawRect Method

CAppearanceSetVisualStudio2005 Methods, CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio2005::GetButtonDrawRect Method

This method called to get bounding rectangle of item that was drawn

virtual CRect GetButtonDrawRect(
    const CXTPTabManagerItem* pItem
);
Parameters

pItem
Item to test

Returns

Bounding rectangle of drawing item

See Also

CXTPTabManagerItem::GetRect

Group

CAppearanceSetVisualStudio2005 Methods


CXTPTabPaintManager::CAppearanceSetVisualStudio2005::GetHeaderMargin Method

CAppearanceSetVisualStudio2005 Methods, CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio2005::GetHeaderMargin Method

This method is called to get the top, left, right, and bottom tab header margins.

virtual CRect GetHeaderMargin();
Returns

CRect struct containing the left, top, right, and bottom margins of the tab header. This is the margin (space) placed around the tab buttons inside the tab header.

Remarks

The CRect structure will contain the margins of the tab header. CXTPTabPaintManager::CAppearanceSet::m_rcHeaderMargin contains these margins.

See Also

CXTPTabPaintManager::CAppearanceSet::m_rcHeaderMargin, CXTPTabPaintManager::GetHeaderRect

Body Source
virtual CRect GetHeaderMargin()
{
    return CRect(m_rcHeaderMargin.left + m_nButtonHeight / 2, m_rcHeaderMargin.top, m_rcHeaderMargin.right, m_rcHeaderMargin.bottom);
}
Group

CAppearanceSetVisualStudio2005 Methods


CAppearanceSetVisualStudio2005 Constructors

CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CAppearanceSetVisualStudio2005 Constructors
Class

CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetVisualStudio2005 | Constructs a CAppearanceSetVisualStudio2005 object.


CXTPTabPaintManager::CAppearanceSetVisualStudio2005::CAppearanceSetVisualStudio2005 Constructor

CAppearanceSetVisualStudio2005 Constructors, CXTPTabPaintManager::CAppearanceSetVisualStudio2005 Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CAppearanceSetVisualStudio2005::CAppearanceSetVisualStudio2005 Constructor

Constructs a CAppearanceSetVisualStudio2005 object.

CAppearanceSetVisualStudio2005();
Body Source
CAppearanceSetVisualStudio2005()
{
    m_bButtonsReverseZOrder = TRUE;
}
Group

CAppearanceSetVisualStudio2005 Constructors


CXTPTabPaintManager::CColorSet Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSet Structures, CColorSet Data Members, CColorSet Methods, CColorSet Constructors, CColorSet Destructors, CColorSet Constructors, CColorSet Data Members, CColorSet Destructors, CColorSet Methods, CColorSet Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet Class

CColorSet is a class that represents the colors of all the components (tab button, tab button border, etc) of the tab manager.

Class Hierarchy

class CColorSet;
File

XTPTabPaintManager.h

Remarks

CColorSet colorizes the different parts that make up a tab, tab header, tab client, and tab manager control.

Colors should be updated in the RefreshMetrics member's for each CColorSet object.

Group

CXTPTabPaintManager Classes

Legend
Structure
Data Member
protected
Method
virtual
abstract
CColorSet Constructors
CColorSet Constructors | Description
CColorSet | Constructs a CColorSet object.
CColorSet Data Members
CColorSet Data Members | Description
m_clrAutoHideFace | Color set of the auto-hide panel background.
m_clrBorderHighlight | Color of highlight border
m_clrButtonHighlighted | Tab button color on mouse over when hot tracking is enabled.
m_clrButtonNormal | Color of normal tabs.
m_clrButtonPressed | Tab pressed button color
m_clrButtonSelected | Color of the currently selected tab.
m_clrControlFace | Color of the control foreground.
m_clrDisabledText | Color of text when a tab is disabled.
m_clrFrameBorder | Color of border placed around the tab buttons and tab client.
m_clrHeaderFace | Color set of the tab header background.
m_clrHighlightText | Color of text on mouse over when hot tracking is enabled.
m_clrInActiveText | Color of text for tabs in all non-active groups of tabs in MDITabClient.
m_clrNormalText | Color of text in a normal tab.
m_clrPaneFace | Color of the control pane foreground.
m_clrSelectedText | Color of text in a "selected" tab button.
m_csExcelNormal | Color set of Normal Excel style tabs.
m_csExcelSelected | Color set of Selected (focused) Excel style tabs.
m_csPropertyPage | Color set of visual studio style tabs.
m_csPropertyPage2003 | Color set of Office 2003 style tabs.
m_csStateButton | Color set of state button style tabs.
m_pPaintManager | Self Paint Manager pointer.
CColorSet Destructors
CColorSet Destructors | Description
~CColorSet | Destroys a CColorSet object, handles cleanup and deallocation.
CColorSet Methods
CColorSet Methods | Description
FillClient | This member is called to fill the TabClient area of the tab manager.
FillHeader | This member is called to fill the header of the TabClient of the tab manager.
FillNavigateButton | This member is called to fill the tab navigation buttons.
FillPropertyButton | This member is called to fill a tab button.
FillStateButton | This member is called to fill a tab button when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
GetItemColor | Call this member to get the color of a tab.
GradientFill | Call this member to do a gradient fill of a rectangle with color that smoothly fades from top to bottom.
IsAppThemed | The member is called to determine if this ColorSet supports Windows XP Themes and if a Windows XP Theme is enabled.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.
SelectClipRgn | This method is called to protect client area to be drawn.
SetTextColor | Call this member to change the color of text in the tab.
CColorSet Structures
CColorSet Structures | Description
COLORSET_TAB_EXCEL | Colors used for Excel tab button colorization.
COLORSET_TAB_PROPERTYPAGE | Colors used for Office 2000 tab button colorization.
COLORSET_TAB_PROPERTYPAGE2003 | Colors used for Office 2003 tab button colorization.
COLORSET_TAB_STATEBUTTON | Colors used for "State Button" tab button colorization.


CColorSet Structures

CXTPTabPaintManager::CColorSet Class, Legend, Structures
CColorSet Structures
Class

CXTPTabPaintManager::CColorSet Class

Legend
Structure
Structures
Structure | Description
COLORSET_TAB_EXCEL | Colors used for Excel tab button colorization.
COLORSET_TAB_PROPERTYPAGE | Colors used for Office 2000 tab button colorization.
COLORSET_TAB_PROPERTYPAGE2003 | Colors used for Office 2003 tab button colorization.
COLORSET_TAB_STATEBUTTON | Colors used for "State Button" tab button colorization.


CXTPTabPaintManager::CColorSet::COLORSET_TAB_EXCEL Structure

XTPTabPaintManager.h, CColorSet Structures, See Also
CXTPTabPaintManager::CColorSet::COLORSET_TAB_EXCEL Structure

Colors used for Excel tab button colorization.

struct COLORSET_TAB_EXCEL {
  CXTPPaintManagerColor clrLeftInnerBorder;
  CXTPPaintManagerColor clrTopInnerBorder;
  CXTPPaintManagerColor clrRightInnerBorder;
  CXTPPaintManagerColor clrLeftOuterBorder;
  CXTPPaintManagerColor clrRightOuterBorder;
  CXTPPaintManagerColor clrTopOuterBorder;
};
File

XTPTabPaintManager.h

Members

clrLeftInnerBorder
Color of the left inner border of the tab button.
clrTopInnerBorder
Color of the top inner border of the tab button.
clrRightInnerBorder
Color of the right inner border of the tab button.
clrLeftOuterBorder
Color of the left outer border of the tab button.
clrRightOuterBorder
Color of the right outer border of the tab button.
clrTopOuterBorder
Color of the top outer border of the tab button.

Remarks

Members of COLORSET_TAB_EXCEL are only used when the XTPTabAppearanceStyle is set to xtpTabAppearanceExcel.

Both the m_csExcelSelected and m_csExcelNormal color sets are used when the xtpTabAppearanceExcel appearance is applied.

By default, the "selected" excel style tab will display the clrLeftInnerBorder and clrTopInnerBorder in addition to the outer borders to indicate that the tab is selected.

The following color sets customize members of COLORSET_TAB_EXCEL in addition to the color members of CColorSet:

  • CColorSetOffice2003 Office 2003 Color Set.
  • CColorSetDefault Default Color Set.
See Also

m_csExcelSelected, m_csExcelNormal

Group

CColorSet Structures


CXTPTabPaintManager::CColorSet::COLORSET_TAB_PROPERTYPAGE Structure

XTPTabPaintManager.h, CColorSet Structures, See Also
CXTPTabPaintManager::CColorSet::COLORSET_TAB_PROPERTYPAGE Structure

Colors used for Office 2000 tab button colorization.

struct COLORSET_TAB_PROPERTYPAGE {
  CXTPPaintManagerColor clrHighlight;
  CXTPPaintManagerColor clrShadow;
  CXTPPaintManagerColor clrDarkShadow;
};
File

XTPTabPaintManager.h

Members

clrHighlight
Color of tab button on mouse over when hot tracking is enabled.
clrShadow
Color of the tab button's shadow.
clrDarkShadow
Color of the tab button's dark shadow.

Remarks

The tab buttons and the tab client area cast a shadow. The shadow consists of a normal and dark color. One or both of these colors can be used depending on the selected XTPTabAppearanceStyle.

Members of COLORSET_TAB_PROPERTYPAGE are only used when the XTPTabAppearanceStyle is set to xtpTabAppearancePropertyPage, xtpTabAppearancePropertyPageFlat, xtpTabAppearancePropertyPageSelected, and xtpTabAppearancePropertyPage2003.

The following color sets customize members of COLORSET_TAB_PROPERTYPAGE in addition to the color members of CColorSet:

  • CColorSetOffice2003 Office 2003 Color Set.
  • CColorSetWinXP Windows XP Color Set.
  • CColorSetDefault Default Color Set.
See Also

m_csPropertyPage

Group

CColorSet Structures


CXTPTabPaintManager::CColorSet::COLORSET_TAB_PROPERTYPAGE2003 Structure

XTPTabPaintManager.h, CColorSet Structures, See Also
CXTPTabPaintManager::CColorSet::COLORSET_TAB_PROPERTYPAGE2003 Structure

Colors used for Office 2003 tab button colorization.

struct COLORSET_TAB_PROPERTYPAGE2003 {
  CXTPPaintManagerColor clrDarkShadow;
  CXTPPaintManagerColor clrFrameBorder;
  CXTPPaintManagerColor clrBorderLeftHighlight;
  CXTPPaintManagerColor clrBorderTopHighlight;
};
File

XTPTabPaintManager.h

Members

clrDarkShadow
Color of the tab buttons shadow.
clrFrameBorder
Color of the XTPTabClientFrame.
clrBorderLeftHighlight
Color of the left border of a tab button.
clrBorderTopHighlight
Color of the top border of a tab button.

Remarks

Members of COLORSET_TAB_PROPERTYPAGE2003 are only used when the XTPTabAppearanceStyle is set to xtpTabAppearancePropertyPage2003.

The following color sets customize members of COLORSET_TAB_PROPERTYPAGE2003 in addition to the color members of CColorSet:

  • CColorSetOffice2003 Office 2003 Color Set.
  • CColorSetWhidbey Visual Studio 2005 "Whidbey" Color Set.
  • CColorSetDefault Default Color Set.
See Also

m_csPropertyPage2003

Group

CColorSet Structures


CXTPTabPaintManager::CColorSet::COLORSET_TAB_STATEBUTTON Structure

XTPTabPaintManager.h, CColorSet Structures, See Also
CXTPTabPaintManager::CColorSet::COLORSET_TAB_STATEBUTTON Structure

Colors used for "State Button" tab button colorization.

struct COLORSET_TAB_STATEBUTTON {
  CXTPPaintManagerColorGradient clrFace;
  CXTPPaintManagerColorGradient clrBorder;
};
File

XTPTabPaintManager.h

Members

clrFace
Color of the currently selected tab button.
clrBorder
Border color of the currently selected tab button.

Remarks

Members of COLORSET_TAB_STATEBUTTON are only used when the XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons.

The following color sets customize members of COLORSET_TAB_STATEBUTTON in addition to the color members of CColorSet:

  • CColorSetOffice2003 Office 2003 Color Set.
  • CColorSetDefault Default Color Set.
See Also

m_csStateButton

Group

CColorSet Structures


CColorSet Data Members

CXTPTabPaintManager::CColorSet Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSet Data Members
Class

CXTPTabPaintManager::CColorSet Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pPaintManager | Self Paint Manager pointer.
Public Data Members
Public Data Member | Description
m_clrAutoHideFace | Color set of the auto-hide panel background.
m_clrBorderHighlight | Color of highlight border
m_clrButtonHighlighted | Tab button color on mouse over when hot tracking is enabled.
m_clrButtonNormal | Color of normal tabs.
m_clrButtonPressed | Tab pressed button color
m_clrButtonSelected | Color of the currently selected tab.
m_clrControlFace | Color of the control foreground.
m_clrDisabledText | Color of text when a tab is disabled.
m_clrFrameBorder | Color of border placed around the tab buttons and tab client.
m_clrHeaderFace | Color set of the tab header background.
m_clrHighlightText | Color of text on mouse over when hot tracking is enabled.
m_clrInActiveText | Color of text for tabs in all non-active groups of tabs in MDITabClient.
m_clrNormalText | Color of text in a normal tab.
m_clrPaneFace | Color of the control pane foreground.
m_clrSelectedText | Color of text in a "selected" tab button.
m_csExcelNormal | Color set of Normal Excel style tabs.
m_csExcelSelected | Color set of Selected (focused) Excel style tabs.
m_csPropertyPage | Color set of visual studio style tabs.
m_csPropertyPage2003 | Color set of Office 2003 style tabs.
m_csStateButton | Color set of state button style tabs.


CXTPTabPaintManager::CColorSet::m_clrAutoHideFace Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrAutoHideFace Data Member

Color set of the auto-hide panel background.

CXTPPaintManagerColorGradient m_clrAutoHideFace;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrBorderHighlight Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrBorderHighlight Data Member

Color of highlight border

CXTPPaintManagerColor m_clrBorderHighlight;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrButtonHighlighted Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrButtonHighlighted Data Member

Tab button color on mouse over when hot tracking is enabled.

CXTPPaintManagerColor m_clrButtonHighlighted;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrButtonNormal Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrButtonNormal Data Member

Color of normal tabs.

CXTPPaintManagerColor m_clrButtonNormal;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrButtonPressed Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrButtonPressed Data Member

Tab pressed button color

CXTPPaintManagerColor m_clrButtonPressed;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrButtonSelected Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrButtonSelected Data Member

Color of the currently selected tab.

CXTPPaintManagerColor m_clrButtonSelected;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrControlFace Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrControlFace Data Member

Color of the control foreground.

CXTPPaintManagerColor m_clrControlFace;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrDisabledText Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrDisabledText Data Member

Color of text when a tab is disabled.

CXTPPaintManagerColor m_clrDisabledText;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrFrameBorder Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrFrameBorder Data Member

Color of border placed around the tab buttons and tab client.

CXTPPaintManagerColor m_clrFrameBorder;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrHeaderFace Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrHeaderFace Data Member

Color set of the tab header background.

CXTPPaintManagerColorGradient m_clrHeaderFace;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrHighlightText Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrHighlightText Data Member

Color of text on mouse over when hot tracking is enabled.

CXTPPaintManagerColor m_clrHighlightText;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrInActiveText Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrInActiveText Data Member

Color of text for tabs in all non-active groups of tabs in MDITabClient.

CXTPPaintManagerColor m_clrInActiveText;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrNormalText Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrNormalText Data Member

Color of text in a normal tab.

CXTPPaintManagerColor m_clrNormalText;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrPaneFace Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrPaneFace Data Member

Color of the control pane foreground.

CXTPPaintManagerColor m_clrPaneFace;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_clrSelectedText Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_clrSelectedText Data Member

Color of text in a "selected" tab button.

CXTPPaintManagerColor m_clrSelectedText;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_csExcelNormal Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_csExcelNormal Data Member

Color set of Normal Excel style tabs.

COLORSET_TAB_EXCEL m_csExcelNormal;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_csExcelSelected Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_csExcelSelected Data Member

Color set of Selected (focused) Excel style tabs.

COLORSET_TAB_EXCEL m_csExcelSelected;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_csPropertyPage Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_csPropertyPage Data Member

Color set of visual studio style tabs.

COLORSET_TAB_PROPERTYPAGE m_csPropertyPage;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_csPropertyPage2003 Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_csPropertyPage2003 Data Member

Color set of Office 2003 style tabs.

COLORSET_TAB_PROPERTYPAGE2003 m_csPropertyPage2003;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_csStateButton Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_csStateButton Data Member

Color set of state button style tabs.

COLORSET_TAB_STATEBUTTON m_csStateButton;
Group

CColorSet Data Members


CXTPTabPaintManager::CColorSet::m_pPaintManager Data Member

CColorSet Data Members, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::m_pPaintManager Data Member

Self Paint Manager pointer.

CXTPTabPaintManager* m_pPaintManager;
Group

CColorSet Data Members


CColorSet Methods

CXTPTabPaintManager::CColorSet Class, Legend, Public Methods
CColorSet Methods
Class

CXTPTabPaintManager::CColorSet Class

Legend
Method
virtual
abstract
Public Methods
Public Methods
Public Method | Description
FillClient | This member is called to fill the TabClient area of the tab manager.
FillHeader | This member is called to fill the header of the TabClient of the tab manager.
FillNavigateButton | This member is called to fill the tab navigation buttons.
FillPropertyButton | This member is called to fill a tab button.
FillStateButton | This member is called to fill a tab button when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
GetItemColor | Call this member to get the color of a tab.
GradientFill | Call this member to do a gradient fill of a rectangle with color that smoothly fades from top to bottom.
IsAppThemed | The member is called to determine if this ColorSet supports Windows XP Themes and if a Windows XP Theme is enabled.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.
SelectClipRgn | This method is called to protect client area to be drawn.
SetTextColor | Call this member to change the color of text in the tab.


CXTPTabPaintManager::CColorSet::FillClient Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::FillClient Method

This member is called to fill the TabClient area of the tab manager.

virtual COLORREF FillClient(
    CDC* pDC,
    CRect rc,
    CXTPTabManager* pTabManager
);
Parameters

pDC
Pointer to a valid device context.
rc
Bounding rectangle of the tab client area.
pTabManager
Fill the tab client area of this CXTPTabManager object.

Returns

If a tab is selected then the color from CXTPTabManager::GetItemColor for the currently selected tab is returned, otherwise m_clrButtonSelected is returned.

Remarks

The TabClient bounding rectangle can be retrieved with the CXTPTabPaintManager::CAppearanceSet::GetClientRect, and CXTPTabManager::GetClientRect members.

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::FillHeader Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet::FillHeader Method

This member is called to fill the header of the TabClient of the tab manager.

virtual void FillHeader(
    CDC* pDC,
    CRect rc,
    CXTPTabManager* pTabManager
);
Parameters

pDC
Pointer to a valid device context.
rc
Bounding rectangle of the tab header.
pTabManager
Fill the header of this CXTPTabManager object.

Remarks

The TabClient header is the bounding rectangle with tab tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See Also

CXTPTabPaintManager::CAppearanceSet::GetHeaderRect, CXTPTabManager::GetHeaderRect

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::FillNavigateButton Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet::FillNavigateButton Method

This member is called to fill the tab navigation buttons.

virtual void FillNavigateButton(
    CDC* pDC,
    CXTPTabManagerNavigateButton* pButton,
    CRect& rc
) = 0;
Parameters

pDC
Pointer to a valid device context.
pButton
Tab navigation button to fill.
rc
Bounding rectangle of the tab navigation button.

Remarks

This member must be overridden and takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

See Also

CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::FillPropertyButton Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet::FillPropertyButton Method

This member is called to fill a tab button.

virtual COLORREF FillPropertyButton(
    CDC* pDC,
    CRect rcItem,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
rcItem
Bounding rectangle of the tab button to fill.
pItem
Tab button to draw.

Returns

COLORREF returned from CXTPTabManager::GetItemColor(pItem).

Remarks

This member is used to fill all tab buttons except when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons require the FillStateButton member.

See Also

FillStateButton

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::FillStateButton Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet::FillStateButton Method

This member is called to fill a tab button when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.

virtual void FillStateButton(
    CDC* pDC,
    CRect rcItem,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
rcItem
Bounding rectangle of the tab button to fill.
pItem
Tab button to draw.

Remarks

This member is only used to fill buttons when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons, for all other buttons, FillPropertyButton is used.

See Also

FillPropertyButton

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::GetItemColor Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet::GetItemColor Method

Call this member to get the color of a tab.

virtual COLORREF GetItemColor(
    CXTPTabManagerItem* pItem
);
Parameters

pItem
Get color of this Tab.

Returns

COLORREF of pItem.

Remarks

This is used in many of the CColorSet "fill" functions.

See Also

CXTPTabManager::GetItemColor, XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::GradientFill Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet::GradientFill Method

Call this member to do a gradient fill of a rectangle with color that smoothly fades from top to bottom.

void GradientFill(
    CDC* pDC,
    CRect rc,
    COLORREF clrLight,
    COLORREF clrDark,
    XTPTabPosition position
);
Parameters

pDC
Pointer to a valid device context.
rc
Rectangle to fill with gradient.
clrLight
COLORREF to start gradient from.
clrDark
COLORREF to fill to.
position
XTPTabPosition of the tab buttons.

Remarks

The color will smoothly fade from clrLight to clrDark, from top to bottom.

If clrLight is XTP_TABMANAGER_COLOR_SHADED, then the rectangle will be filled with a special "shaded" fill type and clrDark will be ignored. See description of XTP_TABMANAGER_COLOR_SHADED for more information on this fill type.

See Also

XTP_TABMANAGER_COLOR_SHADED

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::IsAppThemed Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet::IsAppThemed Method

The member is called to determine if this ColorSet supports Windows XP Themes and if a Windows XP Theme is enabled.

virtual BOOL IsAppThemed() const;
Returns

Always returns FALSE in the base class implementation.

Remarks

This member is overridden in CXTPTabPaintManager::CColorSetWinXP.

See Also

CXTPTabPaintManager::CColorSetWinXP::IsAppThemed

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::RefreshMetrics Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

virtual void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members.

Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::SelectClipRgn Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSet::SelectClipRgn Method

This method is called to protect client area to be drawn.

virtual void SelectClipRgn(
    CDC* pDC,
    CRect rcClient,
    CXTPTabManager* pTabManager
);
Parameters

pDC
Pointer to a valid device context.
rcClient
Bounding rectangle of the TabClient area. This will be the clipping region for the device context.
pTabManager
Pointer to the CXTPTabManager.

Body Source
void CXTPTabPaintManager::CColorSet::SelectClipRgn(CDC* /*pDC*/, CRect /*rcClient*/, CXTPTabManager* /*pTabManager*/) {
}
Group

CColorSet Methods


CXTPTabPaintManager::CColorSet::SetTextColor Method

CColorSet Methods, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::SetTextColor Method

Call this member to change the color of text in the tab.

virtual void SetTextColor(
    CDC* pDC,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
pItem
Change text color of this tab.

Group

CColorSet Methods


CColorSet Constructors

CXTPTabPaintManager::CColorSet Class, Legend, Public Methods
CColorSet Constructors
Class

CXTPTabPaintManager::CColorSet Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CColorSet | Constructs a CColorSet object.


CXTPTabPaintManager::CColorSet::CColorSet Constructor

CColorSet Constructors, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::CColorSet Constructor

Constructs a CColorSet object.

CColorSet();
Group

CColorSet Constructors


CColorSet Destructors

CXTPTabPaintManager::CColorSet Class, Legend, Public Methods
CColorSet Destructors
Class

CXTPTabPaintManager::CColorSet Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CColorSet | Destroys a CColorSet object, handles cleanup and deallocation.


CXTPTabPaintManager::CColorSet::~CColorSet Destructor

CColorSet Destructors, CXTPTabPaintManager::CColorSet Class
CXTPTabPaintManager::CColorSet::~CColorSet Destructor

Destroys a CColorSet object, handles cleanup and deallocation.

virtual ~CColorSet();
Group

CColorSet Destructors


CXTPTabPaintManager::CColorSetAccess2007 Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSetAccess2007 Methods, CColorSetAccess2007 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetAccess2007 Class

CColorSetAccess2007 is a CColorSetOffice2007 derived class that represents the Office 2007 tab color set.

Class Hierarchy

class CColorSetAccess2007 : public CColorSetOffice2007;
File

XTPTabPaintManager.h

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CColorSetAccess2007 Methods
CColorSetAccess2007 Methods | Description
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CColorSetAccess2007 Methods

CXTPTabPaintManager::CColorSetAccess2007 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetAccess2007 Methods
Class

CXTPTabPaintManager::CColorSetAccess2007 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CXTPTabPaintManager::CColorSetAccess2007::RefreshMetrics Method

CColorSetAccess2007 Methods, CXTPTabPaintManager::CColorSetAccess2007 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetAccess2007::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

virtual void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members.

Group

CColorSetAccess2007 Methods


CXTPTabPaintManager::CColorSetDefault Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSetDefault Methods, CColorSetDefault Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetDefault Class

CColorSetDefault is a CColorSet derived class that represents the default tab color set.

Class Hierarchy

class CColorSetDefault : public CColorSet;
File

XTPTabPaintManager.h

Remarks

To use the default color set, SetColor is used to apply the xtpTabColorDefault XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetDefault:

  • xtpTabAppearancePropertyPage Office 2000 appearance.
  • xtpTabAppearancePropertyPageSelected Office 2000 selected appearance.
  • xtpTabAppearancePropertyPageFlat Office 2000 Flat appearance.
  • xtpTabAppearancePropertyPage2003 Office 2003 appearance.
  • xtpTabAppearanceStateButtons State Button appearance.
  • xtpTabAppearanceVisualStudio Visual Studio appearance.
  • xtpTabAppearanceFlat Flat appearance.
  • xtpTabAppearanceExcel Excel appearance.
  • xtpTabAppearanceVisio Visio appearance.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CColorSetDefault Methods
CColorSetDefault Methods | Description
FillNavigateButton | This member is called to fill the tab navigation buttons.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CColorSetDefault Methods

CXTPTabPaintManager::CColorSetDefault Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetDefault Methods
Class

CXTPTabPaintManager::CColorSetDefault Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
FillNavigateButton | This member is called to fill the tab navigation buttons.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CXTPTabPaintManager::CColorSetDefault::FillNavigateButton Method

CColorSetDefault Methods, CXTPTabPaintManager::CColorSetDefault Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetDefault::FillNavigateButton Method

This member is called to fill the tab navigation buttons.

void FillNavigateButton(
    CDC* pDC,
    CXTPTabManagerNavigateButton* pButton,
    CRect& rc
);
Parameters

pDC
Pointer to a valid device context.
pButton
Tab navigation button to fill.
rc
Bounding rectangle of the tab navigation button.

Remarks

This member takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

See Also

CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Group

CColorSetDefault Methods


CXTPTabPaintManager::CColorSetDefault::RefreshMetrics Method

CColorSetDefault Methods, CXTPTabPaintManager::CColorSetDefault Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetDefault::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

virtual void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members.

Group

CColorSetDefault Methods


CXTPTabPaintManager::CColorSetOffice2003 Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSetOffice2003 Data Members, CColorSetOffice2003 Methods, CColorSetOffice2003 Data Members, CColorSetOffice2003 Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2003 Class

CColorSetOffice2003 is a CColorSetDefault derived class that represents the Office 2003 tab color set.

Class Hierarchy

class CColorSetOffice2003 : public CColorSetDefault;
File

XTPTabPaintManager.h

Remarks

To use the Office 2003 color set, SetColor is used to apply the xtpTabColorOffice2003 XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetOffice2003:

  • xtpTabAppearancePropertyPage Office 2000 appearance.
  • xtpTabAppearancePropertyPageSelected Office 2000 selected appearance.
  • xtpTabAppearancePropertyPageFlat Office 2000 Flat appearance.
  • xtpTabAppearancePropertyPage2003 Office 2003 appearance.
  • xtpTabAppearanceStateButtons State Button appearance.
  • xtpTabAppearanceVisualStudio Visual Studio appearance.
  • xtpTabAppearanceFlat Flat appearance.
  • xtpTabAppearanceExcel Excel appearance.
  • xtpTabAppearanceVisio Visio appearance.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Data Member
protected
Method
virtual
CColorSetOffice2003 Data Members
CColorSetOffice2003 Data Members | Description
m_bLunaTheme | TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive, or xtpSystemThemeOlive, FALSE otherwise.
m_clrNavigateButtonBorder | Border color of tab navigation buttons on mouse over.
CColorSetOffice2003 Methods
CColorSetOffice2003 Methods | Description
FillNavigateButton | This member is called to fill the tab navigation buttons.
FillPropertyButton | This member is called to fill a tab button.
Rectangle | This member draws a rectangle with a border.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CColorSetOffice2003 Data Members

CXTPTabPaintManager::CColorSetOffice2003 Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetOffice2003 Data Members
Class

CXTPTabPaintManager::CColorSetOffice2003 Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bLunaTheme | TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive, or xtpSystemThemeOlive, FALSE otherwise.
m_clrNavigateButtonBorder | Border color of tab navigation buttons on mouse over.


CXTPTabPaintManager::CColorSetOffice2003::m_bLunaTheme Data Member

CColorSetOffice2003 Data Members, CXTPTabPaintManager::CColorSetOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2003::m_bLunaTheme Data Member

TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive, or xtpSystemThemeOlive, FALSE otherwise.

BOOL m_bLunaTheme;
Group

CColorSetOffice2003 Data Members


CXTPTabPaintManager::CColorSetOffice2003::m_clrNavigateButtonBorder Data Member

CColorSetOffice2003 Data Members, CXTPTabPaintManager::CColorSetOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2003::m_clrNavigateButtonBorder Data Member

Border color of tab navigation buttons on mouse over.

CXTPPaintManagerColor m_clrNavigateButtonBorder;
Group

CColorSetOffice2003 Data Members


CColorSetOffice2003 Methods

CXTPTabPaintManager::CColorSetOffice2003 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetOffice2003 Methods
Class

CXTPTabPaintManager::CColorSetOffice2003 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
FillNavigateButton | This member is called to fill the tab navigation buttons.
FillPropertyButton | This member is called to fill a tab button.
Rectangle | This member draws a rectangle with a border.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CXTPTabPaintManager::CColorSetOffice2003::FillNavigateButton Method

CColorSetOffice2003 Methods, CXTPTabPaintManager::CColorSetOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2003::FillNavigateButton Method

This member is called to fill the tab navigation buttons.

virtual void FillNavigateButton(
    CDC* pDC,
    CXTPTabManagerNavigateButton* pButton,
    CRect& rc
);
Parameters

pDC
Pointer to a valid device context.
pButton
Tab navigation button to fill.
rc
Bounding rectangle of the tab navigation button.

Remarks

This member takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

See Also

CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton, Rectangle

Group

CColorSetOffice2003 Methods


CXTPTabPaintManager::CColorSetOffice2003::FillPropertyButton Method

CColorSetOffice2003 Methods, CXTPTabPaintManager::CColorSetOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2003::FillPropertyButton Method

This member is called to fill a tab button.

virtual COLORREF FillPropertyButton(
    CDC* pDC,
    CRect rcItem,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
rcItem
Bounding rectangle of the tab button to fill.
pItem
Tab button to draw.

Returns

COLORREF returned from CXTPTabManager::GetItemColor(pItem).

Remarks

This member is used to fill all tab buttons except when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons require the FillStateButton member.

Tab buttons will use CXTPTabPaintManager::CColorSet::GradientFill to fill the buttons. The gradient will use the color of the tab item blended with RGB(255, 255, 255) to produce a "light color", the gradient will start with the "light color" and fill to the normal color of the tab item.

See Also

FillStateButton

Group

CColorSetOffice2003 Methods


CXTPTabPaintManager::CColorSetOffice2003::Rectangle Method

CColorSetOffice2003 Methods, CXTPTabPaintManager::CColorSetOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2003::Rectangle Method

This member draws a rectangle with a border.

void Rectangle(
    CDC* pDC,
    CRect rc,
    int nPen,
    int nBrush
);
Parameters

pDC
Pointer to a valid device context.
rc
Specifies the rectangle in logical units.
nPen
Specifies the color used to paint the rectangle.
nBrush
Specifies the color used to fill the rectangle.

Remarks

This member draws a rectangle using the current pen. The interior of the rectangle is filled using the current brush.

This member is called by FillNavigateButton to fill the tab navigation buttons when luna colors are disabled.

See Also

FillNavigateButton

Group

CColorSetOffice2003 Methods


CXTPTabPaintManager::CColorSetOffice2003::RefreshMetrics Method

CColorSetOffice2003 Methods, CXTPTabPaintManager::CColorSetOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2003::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

virtual void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members. A different color set will be used for each luna color if used.

Group

CColorSetOffice2003 Methods


CXTPTabPaintManager::CColorSetOffice2007 Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSetOffice2007 Methods, CColorSetOffice2007 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2007 Class

CColorSetOffice2007 is a CColorSetOffice2003 derived class that represents the Office 2007 tab color set.

Class Hierarchy

class CColorSetOffice2007 : public CColorSetOffice2003;
File

XTPTabPaintManager.h

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CColorSetOffice2007 Methods
CColorSetOffice2007 Methods | Description
FillNavigateButton | This member is called to fill the tab navigation buttons.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CColorSetOffice2007 Methods

CXTPTabPaintManager::CColorSetOffice2007 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetOffice2007 Methods
Class

CXTPTabPaintManager::CColorSetOffice2007 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
FillNavigateButton | This member is called to fill the tab navigation buttons.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CXTPTabPaintManager::CColorSetOffice2007::FillNavigateButton Method

CColorSetOffice2007 Methods, CXTPTabPaintManager::CColorSetOffice2007 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2007::FillNavigateButton Method

This member is called to fill the tab navigation buttons.

void FillNavigateButton(
    CDC* pDC,
    CXTPTabManagerNavigateButton* pButton,
    CRect& rc
);
Parameters

pDC
Pointer to a valid device context.
pButton
Tab navigation button to fill.
rc
Bounding rectangle of the tab navigation button.

Remarks

This member takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

If IsAppThemed is FALSE, then CColorSetDefault::FillNavigationButton is used.

See Also

CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Group

CColorSetOffice2007 Methods


CXTPTabPaintManager::CColorSetOffice2007::RefreshMetrics Method

CColorSetOffice2007 Methods, CXTPTabPaintManager::CColorSetOffice2007 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetOffice2007::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

virtual void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members.

Group

CColorSetOffice2007 Methods


CXTPTabPaintManager::CColorSetVisualStudio Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSetVisualStudio Methods, CColorSetVisualStudio Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetVisualStudio Class

CColorSetVisualStudio is a CColorSetDefault derived class that represents the Visual Studio tab color set.

Class Hierarchy

class CColorSetVisualStudio : public CColorSetDefault;
File

XTPTabPaintManager.h

Remarks

To use the Visual Studio color set, SetColor is used to apply the xtpTabColorVisualStudio XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetVisualStudio:

  • xtpTabAppearancePropertyPageFlat Office 2000 Flat appearance.
  • xtpTabAppearanceStateButtons State Button appearance.
  • xtpTabAppearanceVisualStudio Visual Studio appearance.
  • xtpTabAppearanceFlat Flat appearance.
  • xtpTabAppearanceExcel Excel appearance.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Method
virtual
CColorSetVisualStudio Methods
CColorSetVisualStudio Methods | Description
FillNavigateButton | This member is called to fill the tab navigation buttons.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CColorSetVisualStudio Methods

CXTPTabPaintManager::CColorSetVisualStudio Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetVisualStudio Methods
Class

CXTPTabPaintManager::CColorSetVisualStudio Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
FillNavigateButton | This member is called to fill the tab navigation buttons.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CXTPTabPaintManager::CColorSetVisualStudio::FillNavigateButton Method

CColorSetVisualStudio Methods, CXTPTabPaintManager::CColorSetVisualStudio Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetVisualStudio::FillNavigateButton Method

This member is called to fill the tab navigation buttons.

void FillNavigateButton(
    CDC* pDC,
    CXTPTabManagerNavigateButton* pButton,
    CRect& rc
);
Parameters

pDC
Pointer to a valid device context.
pButton
Tab navigation button to fill.
rc
Bounding rectangle of the tab navigation button.

Remarks

This member takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

See Also

CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Group

CColorSetVisualStudio Methods


CXTPTabPaintManager::CColorSetVisualStudio::RefreshMetrics Method

CColorSetVisualStudio Methods, CXTPTabPaintManager::CColorSetVisualStudio Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetVisualStudio::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

virtual void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members.

Group

CColorSetVisualStudio Methods


CXTPTabPaintManager::CColorSetVisualStudio2008 Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSetVisualStudio2008 Data Members, CColorSetVisualStudio2008 Methods, CColorSetVisualStudio2008 Constructors, CColorSetVisualStudio2008 Constructors, CColorSetVisualStudio2008 Data Members, CColorSetVisualStudio2008 Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetVisualStudio2008 Class

CColorSetVisualStudio2008 is a CColorSetOffice2003 derived class that represents the Visual Studio 2008 tab color set.

Class Hierarchy

class CColorSetVisualStudio2008 : public CColorSetOffice2003;
File

XTPTabPaintManager.h

Remarks

To use the Visual Studio 2008 color set, SetColor is used to apply the xtpTabColorWhidbey XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetWhidbey:

  • xtpTabAppearancePropertyPage2003 Office 2003 appearance.
  • xtpTabAppearanceStateButtons State Button appearance.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Data Member
protected
Method
CColorSetVisualStudio2008 Constructors
CColorSetVisualStudio2008 Constructors | Description
CColorSetVisualStudio2008 | Constructs a CColorSetVisualStudio2008 object.
CColorSetVisualStudio2008 Data Members
CColorSetVisualStudio2008 Data Members | Description
m_bGradientButton | TRUE if luna colors are enabled.
CColorSetVisualStudio2008 Methods
CColorSetVisualStudio2008 Methods | Description
FillPropertyButton | This member is called to fill a tab button.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CColorSetVisualStudio2008 Data Members

CXTPTabPaintManager::CColorSetVisualStudio2008 Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetVisualStudio2008 Data Members
Class

CXTPTabPaintManager::CColorSetVisualStudio2008 Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bGradientButton | TRUE if luna colors are enabled.


CXTPTabPaintManager::CColorSetVisualStudio2008::m_bGradientButton Data Member

CColorSetVisualStudio2008 Data Members, CXTPTabPaintManager::CColorSetVisualStudio2008 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetVisualStudio2008::m_bGradientButton Data Member

TRUE if luna colors are enabled.

BOOL m_bGradientButton;
Group

CColorSetVisualStudio2008 Data Members


CColorSetVisualStudio2008 Methods

CXTPTabPaintManager::CColorSetVisualStudio2008 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetVisualStudio2008 Methods
Class

CXTPTabPaintManager::CColorSetVisualStudio2008 Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
FillPropertyButton | This member is called to fill a tab button.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CXTPTabPaintManager::CColorSetVisualStudio2008::FillPropertyButton Method

CColorSetVisualStudio2008 Methods, CXTPTabPaintManager::CColorSetVisualStudio2008 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetVisualStudio2008::FillPropertyButton Method

This member is called to fill a tab button.

COLORREF FillPropertyButton(
    CDC* pDC,
    CRect rcItem,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
rcItem
Bounding rectangle of the tab button to fill.
pItem
Tab button to draw.

Returns

COLORREF returned from CXTPTabManager::GetItemColor(pItem).

Remarks

This member is used to fill all tab buttons except when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons require the FillStateButton member.

If m_bGradientButton is TRUE, then CColorSetOffice2003::FillPropertyButton is used to fill the tab button with a gradient fill. See CColorSetOffice2003::FillPropertyButton for details.

If m_bGradientButton is FALSE then CColorSet::FillPropertyButton is used.

See Also

m_bGradientButton

Group

CColorSetVisualStudio2008 Methods


CXTPTabPaintManager::CColorSetVisualStudio2008::RefreshMetrics Method

CColorSetVisualStudio2008 Methods, CXTPTabPaintManager::CColorSetVisualStudio2008 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetVisualStudio2008::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members.

Group

CColorSetVisualStudio2008 Methods


CColorSetVisualStudio2008 Constructors

CXTPTabPaintManager::CColorSetVisualStudio2008 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetVisualStudio2008 Constructors
Class

CXTPTabPaintManager::CColorSetVisualStudio2008 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CColorSetVisualStudio2008 | Constructs a CColorSetVisualStudio2008 object.


CXTPTabPaintManager::CColorSetVisualStudio2008::CColorSetVisualStudio2008 Constructor

CColorSetVisualStudio2008 Constructors, CXTPTabPaintManager::CColorSetVisualStudio2008 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetVisualStudio2008::CColorSetVisualStudio2008 Constructor

Constructs a CColorSetVisualStudio2008 object.

CColorSetVisualStudio2008();
Group

CColorSetVisualStudio2008 Constructors


CXTPTabPaintManager::CColorSetWhidbey Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSetWhidbey Data Members, CColorSetWhidbey Methods, CColorSetWhidbey Constructors, CColorSetWhidbey Constructors, CColorSetWhidbey Data Members, CColorSetWhidbey Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWhidbey Class

CColorSetWhidbey is a CColorSetOffice2003 derived class that represents the Visual Studio 2005 "Whidbey" tab color set.

Class Hierarchy

class CColorSetWhidbey : public CColorSetOffice2003;
File

XTPTabPaintManager.h

Remarks

To use the Visual Studio 2005 "Whidbey" color set, SetColor is used to apply the xtpTabColorWhidbey XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetWhidbey:

  • xtpTabAppearancePropertyPage2003 Office 2003 appearance.
  • xtpTabAppearanceStateButtons State Button appearance.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Data Member
protected
Method
CColorSetWhidbey Constructors
CColorSetWhidbey Constructors | Description
CColorSetWhidbey | Constructs a CColorSetWhidbey object.
CColorSetWhidbey Data Members
CColorSetWhidbey Data Members | Description
m_bGradientButton | TRUE if luna colors are enabled.
CColorSetWhidbey Methods
CColorSetWhidbey Methods | Description
FillPropertyButton | This member is called to fill a tab button.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CColorSetWhidbey Data Members

CXTPTabPaintManager::CColorSetWhidbey Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetWhidbey Data Members
Class

CXTPTabPaintManager::CColorSetWhidbey Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bGradientButton | TRUE if luna colors are enabled.


CXTPTabPaintManager::CColorSetWhidbey::m_bGradientButton Data Member

CColorSetWhidbey Data Members, CXTPTabPaintManager::CColorSetWhidbey Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWhidbey::m_bGradientButton Data Member

TRUE if luna colors are enabled.

BOOL m_bGradientButton;
Group

CColorSetWhidbey Data Members


CColorSetWhidbey Methods

CXTPTabPaintManager::CColorSetWhidbey Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetWhidbey Methods
Class

CXTPTabPaintManager::CColorSetWhidbey Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
FillPropertyButton | This member is called to fill a tab button.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.


CXTPTabPaintManager::CColorSetWhidbey::FillPropertyButton Method

CColorSetWhidbey Methods, CXTPTabPaintManager::CColorSetWhidbey Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWhidbey::FillPropertyButton Method

This member is called to fill a tab button.

COLORREF FillPropertyButton(
    CDC* pDC,
    CRect rcItem,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
rcItem
Bounding rectangle of the tab button to fill.
pItem
Tab button to draw.

Returns

COLORREF returned from CXTPTabManager::GetItemColor(pItem).

Remarks

This member is used to fill all tab buttons except when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons require the FillStateButton member.

If m_bGradientButton is TRUE, then CColorSetOffice2003::FillPropertyButton is used to fill the tab button with a gradient fill. See CColorSetOffice2003::FillPropertyButton for details.

If m_bGradientButton is FALSE then CColorSet::FillPropertyButton is used.

See Also

m_bGradientButton

Group

CColorSetWhidbey Methods


CXTPTabPaintManager::CColorSetWhidbey::RefreshMetrics Method

CColorSetWhidbey Methods, CXTPTabPaintManager::CColorSetWhidbey Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWhidbey::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members.

Group

CColorSetWhidbey Methods


CColorSetWhidbey Constructors

CXTPTabPaintManager::CColorSetWhidbey Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetWhidbey Constructors
Class

CXTPTabPaintManager::CColorSetWhidbey Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CColorSetWhidbey | Constructs a CColorSetWhidbey object.


CXTPTabPaintManager::CColorSetWhidbey::CColorSetWhidbey Constructor

CColorSetWhidbey Constructors, CXTPTabPaintManager::CColorSetWhidbey Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWhidbey::CColorSetWhidbey Constructor

Constructs a CColorSetWhidbey object.

CColorSetWhidbey();
Group

CColorSetWhidbey Constructors


CXTPTabPaintManager::CColorSetWinXP Class

XTPTabPaintManager.h, CXTPTabPaintManager Classes, Legend, Members, Topics, CColorSetWinXP Data Members, CColorSetWinXP Methods, CColorSetWinXP Data Members, CColorSetWinXP Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP Class

CColorSetWinXP is a CColorSetDefault derived class that represents the Windows XP tab color set.

Class Hierarchy

class CColorSetWinXP : public CColorSetDefault;
File

XTPTabPaintManager.h

Remarks

To use the Windows XP color set, SetColor is used to apply the xtpTabColorWinXP XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetWinXP:

  • xtpTabAppearancePropertyPage Office 2000 appearance.
  • xtpTabAppearancePropertyPageSelected Office 2000 selected appearance.
  • xtpTabAppearanceStateButtons State Button appearance.
See Also

XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Group

CXTPTabPaintManager Classes

Legend
Data Member
protected
Method
virtual
CColorSetWinXP Data Members
CColorSetWinXP Data Members | Description
m_themeTabButton | Internally used helper to draw PropertyPage Buttons using Windows XP color set.
m_themeToolbar | Internally used helper to draw State Button using Windows XP color set.
CColorSetWinXP Methods
CColorSetWinXP Methods | Description
FillClient | This member is called to fill the TabClient area of the tab manager.
FillNavigateButton | This member is called to fill the tab navigation buttons.
FillPropertyButton | This member is called to fill a tab button.
FillStateButton | This member is called to fill a tab button when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
IsAppThemed | The member is called to determine if this ColorSet supports Windows XP Themes and if a Windows XP Theme is enabled.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.
SelectClipRgn | This method is called to protect client area to be drawn.


CColorSetWinXP Data Members

CXTPTabPaintManager::CColorSetWinXP Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetWinXP Data Members
Class

CXTPTabPaintManager::CColorSetWinXP Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_themeTabButton | Internally used helper to draw PropertyPage Buttons using Windows XP color set.
m_themeToolbar | Internally used helper to draw State Button using Windows XP color set.


CXTPTabPaintManager::CColorSetWinXP::m_themeTabButton Data Member

CColorSetWinXP Data Members, CXTPTabPaintManager::CColorSetWinXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::m_themeTabButton Data Member

Internally used helper to draw PropertyPage Buttons using Windows XP color set.

CXTPWinThemeWrapper m_themeTabButton;
Group

CColorSetWinXP Data Members


CXTPTabPaintManager::CColorSetWinXP::m_themeToolbar Data Member

CColorSetWinXP Data Members, CXTPTabPaintManager::CColorSetWinXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::m_themeToolbar Data Member

Internally used helper to draw State Button using Windows XP color set.

CXTPWinThemeWrapper m_themeToolbar;
Group

CColorSetWinXP Data Members


CColorSetWinXP Methods

CXTPTabPaintManager::CColorSetWinXP Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CColorSetWinXP Methods
Class

CXTPTabPaintManager::CColorSetWinXP Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
FillClient | This member is called to fill the TabClient area of the tab manager.
FillNavigateButton | This member is called to fill the tab navigation buttons.
FillPropertyButton | This member is called to fill a tab button.
FillStateButton | This member is called to fill a tab button when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
IsAppThemed | The member is called to determine if this ColorSet supports Windows XP Themes and if a Windows XP Theme is enabled.
RefreshMetrics | This member is called to refresh the visual metrics of the tabs.
SelectClipRgn | This method is called to protect client area to be drawn.


CXTPTabPaintManager::CColorSetWinXP::FillClient Method

CColorSetWinXP Methods, CXTPTabPaintManager::CColorSetWinXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::FillClient Method

This member is called to fill the TabClient area of the tab manager.

virtual COLORREF FillClient(
    CDC* pDC,
    CRect rc,
    CXTPTabManager* pTabManager
);
Parameters

pDC
Pointer to a valid device context.
rc
Bounding rectangle of the tab client area.
pTabManager
Fill the tab client area of this CXTPTabManager object.

Returns

If IsAppThemed is TRUE, then 0 is returned.

If IsAppThemed is FALSE and a tab is selected then the color from CXTPTabManager::GetItemColor for the currently selected tab is returned, otherwise CXTPTabPaintManager::CColorSet::m_clrButtonSelected is returned.

Remarks

The TabClient bounding rectangle can be retrieved with the CXTPTabPaintManager::CAppearanceSet::GetClientRect, and CXTPTabManager::GetClientRect members.

Group

CColorSetWinXP Methods


CXTPTabPaintManager::CColorSetWinXP::FillNavigateButton Method

CColorSetWinXP Methods, CXTPTabPaintManager::CColorSetWinXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::FillNavigateButton Method

This member is called to fill the tab navigation buttons.

virtual void FillNavigateButton(
    CDC* pDC,
    CXTPTabManagerNavigateButton* pButton,
    CRect& rc
);
Parameters

pDC
Pointer to a valid device context.
pButton
Tab navigation button to fill.
rc
Bounding rectangle of the tab navigation button.

Remarks

This member takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

If IsAppThemed is FALSE, then CColorSetDefault::FillNavigationButton is used.

See Also

CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Group

CColorSetWinXP Methods


CXTPTabPaintManager::CColorSetWinXP::FillPropertyButton Method

CColorSetWinXP Methods, CXTPTabPaintManager::CColorSetWinXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::FillPropertyButton Method

This member is called to fill a tab button.

virtual COLORREF FillPropertyButton(
    CDC* pDC,
    CRect rcItem,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
rcItem
Bounding rectangle of the tab button to fill.
pItem
Tab button to draw.

Returns

XTP_TABMANAGER_COLOR_NONE

Remarks

This member is used to fill all tab buttons except when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons require the FillStateButton member.

If IsAppThemed is FALSE, then CColorSetDefault::FillPropertyButton is used.

See Also

FillStateButton

Group

CColorSetWinXP Methods


CXTPTabPaintManager::CColorSetWinXP::FillStateButton Method

CColorSetWinXP Methods, CXTPTabPaintManager::CColorSetWinXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::FillStateButton Method

This member is called to fill a tab button when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.

virtual void FillStateButton(
    CDC* pDC,
    CRect rcItem,
    CXTPTabManagerItem* pItem
);
Parameters

pDC
Pointer to a valid device context.
rcItem
Bounding rectangle of the tab button to fill.
pItem
Tab button to draw.

Remarks

This member is only used to fill buttons when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons, for all other buttons, FillPropertyButton is used.

If IsAppThemed is FALSE and/or the tab button is not selected, then CColorSetDefault::FillStateButton is used.

See Also

FillPropertyButton

Group

CColorSetWinXP Methods


CXTPTabPaintManager::CColorSetWinXP::IsAppThemed Method

CColorSetWinXP Methods, CXTPTabPaintManager::CColorSetWinXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::IsAppThemed Method

The member is called to determine if this ColorSet supports Windows XP Themes and if a Windows XP Theme is enabled.

virtual BOOL IsAppThemed() const;
Returns

TRUE if Windows XP themes are enabled and a Windows XP theme is currently used.

Remarks

IsAppThemed will return FALSE if running an operating system before Windows XP i.e. (98, 2000, NT) or if the Standard/Clasic themes are used with Windows XP.

This member is called internally to determine how to colorize the tab buttons. If FALSE, CXTPTabPaintManager::CColorSetDefault is used to colorize the tab buttons. If TRUE, then Windows XP colorization is used to colorize the tabs.

See Also

CXTPTabPaintManager::IsAppThemed

Group

CColorSetWinXP Methods


CXTPTabPaintManager::CColorSetWinXP::RefreshMetrics Method

CColorSetWinXP Methods, CXTPTabPaintManager::CColorSetWinXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::RefreshMetrics Method

This member is called to refresh the visual metrics of the tabs.

virtual void RefreshMetrics();
Remarks

All of the color members are refreshed when this is called. This member can be override this member to change the colors of the color members.

Group

CColorSetWinXP Methods


CXTPTabPaintManager::CColorSetWinXP::SelectClipRgn Method

CColorSetWinXP Methods, CXTPTabPaintManager::CColorSetWinXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::CColorSetWinXP::SelectClipRgn Method

This method is called to protect client area to be drawn.

virtual void SelectClipRgn(
    CDC* pDC,
    CRect rcClient,
    CXTPTabManager* pTabManager
);
Parameters

pDC
Pointer to a valid device context.
rcClient
Bounding rectangle of the TabClient area. This will be the clipping region for the device context.
pTabManager
Pointer to the CXTPTabManager.

Group

CColorSetWinXP Methods


CXTPTabPaintManager Data Members

CXTPTabPaintManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager Data Members
Class

CXTPTabPaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrObservers | List of controls that receive notification when a property of paint manager has changed.
m_bUseStandardFont | TRUE to use standard system "icon" font which is Tahoma 8pt.
m_fntBold | Font used to display bold text in the tab buttons.
m_fntNormal | Font used to display text in tab buttons.
m_fntVerticalBold | Font used to display bold text in the tab buttons when the tab position is vertical.
m_fntVerticalNormal | Font used to display tab button caption when the tab position is vertical.
m_pAppearanceSet | Currently set CAppearanceSet.
m_pColorSet | Currently used CColorSet.
m_tabAppearance | Currently set appearance style.
m_tabColor | Currently used color style.
m_tabLayout | Currently set tab button layout.
m_tabPosition | Currently set tab button position.
Public Data Members
Public Data Member | Description
m_bBoldNormal | If TRUE, bold font will be used for all tab both selected and non-selected.
m_bBoldSelected | If TRUE, the text of selected tabs will be displayed in bold font
m_bClearTypeTextQuality | TRUE to enable ClearType text for the font.
m_bClipHeader | TRUE to select clip rectangle before draw tabs
m_bDisableLunaColors | If FALSE, Tabs will not use LunaColors, is the current theme uses LunaColors
m_bDrawFocusRect | TRUE to draw focus rect for focused item.
m_bDrawTextEndEllipsis | If TRUE, when the size of a tab button is too small to display the caption the end of the caption will be replaced with an ellipse "...", If FALSE, the the end of the caption will be replaced with the ellipse.
m_bDrawTextHidePrefix | If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
m_bDrawTextNoPrefix | If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
m_bDrawTextPathEllipsis | If TRUE, when the size of a tab button is too small to display the caption the middle of the caption will be replaced with an ellipse "...", If FALSE, the the end of the caption will be replaced with the ellipse.
m_bFillBackground | If TRUE, then the tab client space is filled using CXTPTabPaintManager.CColorSet.m_clrControlFace color.
m_bHotTracking | If TRUE, tab hot tracking will be enabled.
m_bInvertGradient | If TRUE, the colors passed into CXTPTabPaintManager::CColorSet::GradientFill will be swapped before the rectangle is filled with the gradient.
m_bMultiRowFixedSelection | FALSE to move row with selected item close to client pane.
m_bMultiRowJustified | Stretch each row of tabs to fill the entire width of the control.
m_bOneNoteColors | If TRUE, tabs will use OneNote colorization
m_bRotateImageOnVerticalDraw | TRUE to rotate image when tab located left or right
m_bSelectOnButtonDown | if TRUE, when tab selected on mouse button down.
m_bSelectOnDragOver | TRUE to activate tab when user drag files/text under it.
m_bShowIcons | If TRUE, tab icons will be drawn is icons were added
m_bShowTabs | TRUE to show tabs
m_bStaticFrame | If TRUE, a static frame will be drawn around the entire tab area
m_clientFrame | Frame style of tab client area.
m_nButtonExtraLength | Additional padding of tabs
m_nDrawTextFormat | Text format for tabs (default - DT_LEFT | DT_VCENTER)
m_nFixedTabWidth | Tabs width for fixed layout
m_nMaxTabWidth | Maximum tabs width
m_nMinTabWidth | Minimum tabs width
m_rcButtonMargin | Margin around the text in tab button.
m_rcButtonTextPadding | Margin around the text in tab button.
m_rcClientMargin | Margin around tab client area.
m_rcControlMargin | Margin around entire tab control (tab client header and tab client area).
m_szIcon | Size of icon displayed in tab button.
m_toolBehaviour | Tootips behaviour


CXTPTabPaintManager::m_arrObservers Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_arrObservers Data Member

List of controls that receive notification when a property of paint manager has changed.

CArray<CXTPTabManagerAtom*, CXTPTabManagerAtom*> m_arrObservers;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bBoldNormal Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bBoldNormal Data Member

If TRUE, bold font will be used for all tab both selected and non-selected.

BOOL m_bBoldNormal;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bBoldSelected Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bBoldSelected Data Member

If TRUE, the text of selected tabs will be displayed in bold font

BOOL m_bBoldSelected;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bClearTypeTextQuality Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bClearTypeTextQuality Data Member

TRUE to enable ClearType text for the font.

BOOL m_bClearTypeTextQuality;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bClipHeader Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bClipHeader Data Member

TRUE to select clip rectangle before draw tabs

BOOL m_bClipHeader;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bDisableLunaColors Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bDisableLunaColors Data Member

If FALSE, Tabs will not use LunaColors, is the current theme uses LunaColors

BOOL m_bDisableLunaColors;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bDrawFocusRect Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bDrawFocusRect Data Member

TRUE to draw focus rect for focused item.

BOOL m_bDrawFocusRect;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bDrawTextEndEllipsis Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bDrawTextEndEllipsis Data Member

If TRUE, when the size of a tab button is too small to display the caption the end of the caption will be replaced with an ellipse "...", If FALSE, the the end of the caption will be replaced with the ellipse.

BOOL m_bDrawTextEndEllipsis;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bDrawTextHidePrefix Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bDrawTextHidePrefix Data Member

If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.

BOOL m_bDrawTextHidePrefix;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bDrawTextNoPrefix Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bDrawTextNoPrefix Data Member

If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.

BOOL m_bDrawTextNoPrefix;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bDrawTextPathEllipsis Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bDrawTextPathEllipsis Data Member

If TRUE, when the size of a tab button is too small to display the caption the middle of the caption will be replaced with an ellipse "...", If FALSE, the the end of the caption will be replaced with the ellipse.

BOOL m_bDrawTextPathEllipsis;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bFillBackground Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bFillBackground Data Member

If TRUE, then the tab client space is filled using CXTPTabPaintManager.CColorSet.m_clrControlFace color.

BOOL m_bFillBackground;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bHotTracking Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bHotTracking Data Member

If TRUE, tab hot tracking will be enabled.

BOOL m_bHotTracking;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bInvertGradient Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bInvertGradient Data Member

If TRUE, the colors passed into CXTPTabPaintManager::CColorSet::GradientFill will be swapped before the rectangle is filled with the gradient.

BOOL m_bInvertGradient;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bMultiRowFixedSelection Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bMultiRowFixedSelection Data Member

FALSE to move row with selected item close to client pane.

BOOL m_bMultiRowFixedSelection;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bMultiRowJustified Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bMultiRowJustified Data Member

Stretch each row of tabs to fill the entire width of the control.

BOOL m_bMultiRowJustified;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bOneNoteColors Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bOneNoteColors Data Member

If TRUE, tabs will use OneNote colorization

BOOL m_bOneNoteColors;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bRotateImageOnVerticalDraw Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bRotateImageOnVerticalDraw Data Member

TRUE to rotate image when tab located left or right

BOOL m_bRotateImageOnVerticalDraw;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bSelectOnButtonDown Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bSelectOnButtonDown Data Member

if TRUE, when tab selected on mouse button down.

BOOL m_bSelectOnButtonDown;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bSelectOnDragOver Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bSelectOnDragOver Data Member

TRUE to activate tab when user drag files/text under it.

BOOL m_bSelectOnDragOver;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bShowIcons Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bShowIcons Data Member

If TRUE, tab icons will be drawn is icons were added

BOOL m_bShowIcons;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bShowTabs Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bShowTabs Data Member

TRUE to show tabs

BOOL m_bShowTabs;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bStaticFrame Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bStaticFrame Data Member

If TRUE, a static frame will be drawn around the entire tab area

BOOL m_bStaticFrame;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_bUseStandardFont Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_bUseStandardFont Data Member

TRUE to use standard system "icon" font which is Tahoma 8pt.

BOOL m_bUseStandardFont;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_clientFrame Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_clientFrame Data Member

Frame style of tab client area.

XTPTabClientFrame m_clientFrame;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_fntBold Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_fntBold Data Member

Font used to display bold text in the tab buttons.

CFont m_fntBold;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_fntNormal Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_fntNormal Data Member

Font used to display text in tab buttons.

CFont m_fntNormal;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_fntVerticalBold Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_fntVerticalBold Data Member

Font used to display bold text in the tab buttons when the tab position is vertical.

CFont m_fntVerticalBold;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_fntVerticalNormal Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_fntVerticalNormal Data Member

Font used to display tab button caption when the tab position is vertical.

CFont m_fntVerticalNormal;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_nButtonExtraLength Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_nButtonExtraLength Data Member

Additional padding of tabs

int m_nButtonExtraLength;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_nDrawTextFormat Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_nDrawTextFormat Data Member

Text format for tabs (default - DT_LEFT | DT_VCENTER)

UINT m_nDrawTextFormat;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_nFixedTabWidth Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_nFixedTabWidth Data Member

Tabs width for fixed layout

int m_nFixedTabWidth;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_nMaxTabWidth Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_nMaxTabWidth Data Member

Maximum tabs width

int m_nMaxTabWidth;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_nMinTabWidth Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_nMinTabWidth Data Member

Minimum tabs width

int m_nMinTabWidth;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_pAppearanceSet Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_pAppearanceSet Data Member

Currently set CAppearanceSet.

CAppearanceSet* m_pAppearanceSet;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_pColorSet Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_pColorSet Data Member

Currently used CColorSet.

CColorSet* m_pColorSet;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_rcButtonMargin Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_rcButtonMargin Data Member

Margin around the text in tab button.

CRect m_rcButtonMargin;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_rcButtonTextPadding Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_rcButtonTextPadding Data Member

Margin around the text in tab button.

CRect m_rcButtonTextPadding;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_rcClientMargin Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_rcClientMargin Data Member

Margin around tab client area.

CRect m_rcClientMargin;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_rcControlMargin Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_rcControlMargin Data Member

Margin around entire tab control (tab client header and tab client area).

CRect m_rcControlMargin;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_szIcon Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_szIcon Data Member

Size of icon displayed in tab button.

CSize m_szIcon;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_tabAppearance Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_tabAppearance Data Member

Currently set appearance style.

XTPTabAppearanceStyle m_tabAppearance;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_tabColor Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_tabColor Data Member

Currently used color style.

XTPTabColorStyle m_tabColor;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_tabLayout Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_tabLayout Data Member

Currently set tab button layout.

XTPTabLayoutStyle m_tabLayout;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_tabPosition Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_tabPosition Data Member

Currently set tab button position.

XTPTabPosition m_tabPosition;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager::m_toolBehaviour Data Member

CXTPTabPaintManager Data Members, CXTPTabPaintManager Class
CXTPTabPaintManager::m_toolBehaviour Data Member

Tootips behaviour

XTPTabToolTipBehaviour m_toolBehaviour;
Group

CXTPTabPaintManager Data Members


CXTPTabPaintManager Methods

CXTPTabPaintManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager Methods
Class

CXTPTabPaintManager Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_GetButtonLength | This member is called to get the total button length including the left and right button margin.
DrawTabControlEx | This member is called to draw the tab control.
DrawTextPathEllipsis | This member is called to place an ellipse "..." in the middle of a string.
OnPropertyChanged | This member is called when a property of the tab paint manager has changed.
RepositionTabControlEx | This method is called to move the tab buttons of the tab control to their correct positions.
RepositionTabControlMultiRow | This method is called to move the tab buttons of the multi row tab control to their correct positions.
SizeToFit | This member is called to change the tab button size when the XTPTabLayoutStyle is xtpTabLayoutSizeToFit.
Public Methods
Public Methods
Public Method | Description
AddObserver | This member adds a control to the list of controls that receive notification when a property of paint manager has changed.
AdjustClientRect | This member is called to adjust the client rectangle. It will return the new client rectangle with margins included.
DisableLunaColors | Call this member to enable/disable luna colors.
DrawNavigateButton | This member is called to draw tab navigation buttons.
DrawSingleButtonIconAndText | This method is called to draw the tab button's text and icon.
DrawTabControl | This member is called to draw the tab control.
EnableToolTips | Call this member function to enable or disable tooltips show
EnsureVisible | Call this member to ensure that a tab is visible.
FillNavigateButton | This member is called to fill the tab navigation buttons.
GetAppearance | Call this member to determine the currently set appearance style.
GetAppearanceSet | Call this member to get the currently set custom appearance set.
GetBoldFont | Call this method to get the CFont used for displaying tab caption text when bold.
GetColor | Call this member to get the currently used tab color style.
GetColorSet | Call this member to get the currently used custom color set.
GetFont | Call this member to get the CFont used for displaying tab caption text.
GetLayout | Call this member to get the currently set tab layout.
GetOneNoteColor | Retrieves the COLORREF value for the specified OneNote color.
GetPosition | Call this member to set the position of the tab buttons.
IsLunaColorsDisabled | Call this member to determine is luna colors are disabled.
RefreshMetrics | This member is called to refresh the visual metrics of the tab main manager.
RepositionNavigateButtons | This member is called to reposition the tab navigation buttons.
RepositionTabControl | This method is called to move the tab buttons of the tab control to their correct positions.
SetAppearance | Call this member to apply one of the "built-in" appearances to the tabs.
SetAppearanceSet | Call this member to apply a custom appearance set.
SetColor | Call this member to apply one of the "built-in" color sets to the tabs.
SetColorSet | Call this member to apply a custom color set to the tabs.
SetFontIndirect | Call this member to set the font for the tabs.
SetLayout | Call this member to set the tab layout style.
SetOneNoteColors | Call this member to enabledisable OneNote colorization for the tabs.
SetPosition | Call this member to set the tab position.


CXTPTabPaintManager::_GetButtonLength Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::_GetButtonLength Method

This member is called to get the total button length including the left and right button margin.

int _GetButtonLength(
    int nValue,
    int nMin,
    int nMax
);
Parameters

nValue
Width of tab button.
nMin
Minimum width of tab button.
nMax
Maximum width of tab button.

Returns

Tab button length including the left and right button margin.

See Also

CXTPTabManager::GetItemMetrics

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::AddObserver Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::AddObserver Method

This member adds a control to the list of controls that receive notification when a property of paint manager has changed.

void AddObserver(
    CXTPTabManagerAtom* pObserver
);
Parameters

pObserver
List of controls that receive notification when a property of paint manager has changed.

Remarks

This member is not used in the MFC version. This is only used in the ActiveX version and does nothing in MFC.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::AdjustClientRect Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::AdjustClientRect Method

This member is called to adjust the client rectangle. It will return the new client rectangle with margins included.

virtual void AdjustClientRect(
    CXTPTabManager* pTabManager,
    CRect& rcClient
);
Parameters

pTabManager
Pointer to the tab manager to adjust the client rectangle.
rcClient
[out] CRect to store client rectangle.

Remarks

AdjustClientRect and RepositionTabControl are called when the window is resized. When DrawTabControl is called the changes will be used when drawing the tab control.

This member will adjust the client rectangle of the entire tab manager if IsDrawStaticFrame is TRUE to make room to draw the static frame.

Then CXTPTabPaintManager::CAppearanceSet::AdjustClientRect is called if there is one or more tabs in the tab manager.

See Also

CXTPTabPaintManager::CAppearanceSet::AdjustClientRect

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::DisableLunaColors Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::DisableLunaColors Method

Call this member to enable/disable luna colors.

void DisableLunaColors(
    BOOL bDisableLunaColors
);
Parameters

bDisableLunaColors
TRUE to disable luna colors, FALSE to enable luna colors.

Remarks

Luna colors are the Windows XP colors (Silver, Blue, Olive). CXTPDrawHelpers::GetCurrentSystemTheme can be called to get the currently used system theme.

See Also

IsLunaColorsDisabled, XTPCurrentSystemTheme, CXTPDrawHelpers::GetCurrentSystemTheme

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::DrawNavigateButton Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::DrawNavigateButton Method

This member is called to draw tab navigation buttons.

virtual void DrawNavigateButton(
    CDC* pDC,
    CXTPTabManagerNavigateButton* pButton,
    CRect& rc
);
Parameters

pDC
Pointer to a valid device context.
pButton
Tab navigation button to fill.
rc
Bounding rectangle of the tab navigation button.

See Also

CXTPTabPaintManager::CColorSet::FillNavigateButton, CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::DrawSingleButtonIconAndText Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::DrawSingleButtonIconAndText Method

This method is called to draw the tab button's text and icon.

virtual int DrawSingleButtonIconAndText(
    CDC* pDC,
    CXTPTabManagerItem* pItem,
    CRect rcItem,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context.
pItem
Tab button to draw text and icon on.
rcItem
Bounding rectangle of the tab.
bDraw
TRUE to draw the text and icon, FALSE to calculate the button width (no drawing is done).

Returns

Returns 0 if bDraw is TRUE and drawing is successful.

Returns the button width including the left and right button margin if bDraw is FALSE.

Remarks

This method only draws the text and icon on a tab button.

CXTPTabPaintManager::CAppearanceSet::DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See Also

CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::CAppearanceSet::DrawSingleButton

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::DrawTabControl Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::DrawTabControl Method

This member is called to draw the tab control.

virtual void DrawTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to the tab manager to draw.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the client area.

Remarks

This member is called in various Draw and Paint functions.

This member will call CXTPTabPaintManager::CAppearanceSet::DrawTabControl for the currently set appearance. CXTPTabPaintManager::CAppearanceSet::DrawTabControl will then call CXTPTabPaintManager::DrawTabControlEx.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::DrawTabControlEx Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::DrawTabControlEx Method

This member is called to draw the tab control.

void DrawTabControlEx(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to the tab manager to draw.
pDC
Pointer to a valid device context.
rcControl
Bounding rectangle of the client area.

Remarks

DrawTabControl calls CXTPTabPaintManager::CAppearanceSet::DrawTabControl which will then call DrawTabControlEx if it has not been overridden.

See Also

CXTPTabPaintManager::CAppearanceSet::DrawTabControl

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::DrawTextPathEllipsis Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::DrawTextPathEllipsis Method

This member is called to place an ellipse "..." in the middle of a string.

void DrawTextPathEllipsis(
    CDC* pDC,
    const CString& strItem,
    CRect rcItem,
    UINT uFormat
);
Parameters

pDC
Pointer to a valid device context.
strItem
String item to place an ellipse in.
rcItem
Bounding rectangle of tab button. This is the rectangle (in logical coordinates) in which the text is to be formatted.
uFormat
See nFormat parameter of CDC::DrawText.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::EnableToolTips Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::EnableToolTips Method

Call this member function to enable or disable tooltips show

void EnableToolTips(
    XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways
);
Parameters

behaviour
Tooltips behaviour will be set. See remarks section for available flags.

Remarks

behaviour parameter can be one of the following:

  • xtpTabToolTipNever Show tooltips for tabs always
  • xtpTabToolTipAlways Doesn't show tooltips for tabs
  • xtpTabToolTipShrinkedOnly Show tooltips only if tab was shrinked (see xtpTabLayoutSizeToFit layout)
Body Source
void CXTPTabPaintManager::EnableToolTips(XTPTabToolTipBehaviour behaviour) {
    m_toolBehaviour = behaviour;
}
Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::EnsureVisible Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::EnsureVisible Method

Call this member to ensure that a tab is visible.

void EnsureVisible(
    CXTPTabManager* pTabManager,
    CXTPTabManagerItem* pItem
);
Parameters

pTabManager
Pointer to the tab manager the tab in on.
pItem
CXTPTabManagerItem tab to make visible.

See Also

CXTPTabManager::SetHeaderOffset, CXTPTabManager::GetHeaderOffset

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::FillNavigateButton Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::FillNavigateButton Method

This member is called to fill the tab navigation buttons.

void FillNavigateButton(
    CDC* pDC,
    CXTPTabManagerNavigateButton* pButton,
    CRect& rc
);
Parameters

pDC
Pointer to a valid device context.
pButton
Tab navigation button to fill.
rc
Bounding rectangle of the tab navigation button.

Remarks

This member calls m_pColorSet->FillNavigateButton.

The XTPTabColorStyle CColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

See Also

CXTPTabPaintManager::CColorSet::FillNavigateButton, CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetAppearance Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetAppearance Method

Call this member to determine the currently set appearance style.

XTPTabAppearanceStyle GetAppearance() const;
Returns

The currently set XTPTabAppearanceStyle.

Remarks

The appearance is the physical structure of the tab buttons.

See Also

XTPTabAppearanceStyle, GetAppearanceSet, SetAppearanceSet, SetAppearance

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetAppearanceSet Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetAppearanceSet Method

Call this member to get the currently set custom appearance set.

CAppearanceSet* GetAppearanceSet() const;
Returns

Pointer to the currently used custom appearance set.

Remarks

An appearance set specifies how the tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance style will have a half hexagon shape. SetColorSet is used to set custom colors.

See the GUI_Eclipse sample for an example of how to create a custom appearance set and apply it to the tabs.

See Also

GetAppearanceSet, SetAppearanceSet, SetAppearance

Body Source
CXTPTabPaintManager::CAppearanceSet* CXTPTabPaintManager::GetAppearanceSet() const {
    return m_pAppearanceSet;
}
Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetBoldFont Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetBoldFont Method

Call this method to get the CFont used for displaying tab caption text when bold.

CFont* GetBoldFont(
    BOOL bVertical = FALSE
);
Parameters

bVertical
TRUE if the XTPTabPosition is vertical, FALSE if the XTPTabPosition is horizontal.

Returns

CFont used to display bold caption text in the tab buttons.

Remarks

Bold font is used to display caption text when a tab is selected and m_bBoldSelected = TRUE.

If m_bBoldNormal = TRUE, then the tabs will use this font even when not selected.

See Also

m_bBoldNormal, m_bBoldSelected, GetFont

Body Source
CFont* CXTPTabPaintManager::GetBoldFont(BOOL bVertical) {
    return bVertical ? &m_fntVerticalBold : &m_fntBold;
}
Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetColor Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetColor Method

Call this member to get the currently used tab color style.

XTPTabColorStyle GetColor() const;
Returns

Currently used color style.

Remarks

Color styles are used to colorize the tabs. For example, applying the xtpTabColorWinXP color style will give the tabs Windows XP colorization.

See Also

XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetColorSet Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetColorSet Method

Call this member to get the currently used custom color set.

CColorSet* GetColorSet() const;
Returns

Currently used custom color set.

See Also

XTPTabColorStyle, GetColor, SetColorSet, SetColor

Body Source
CXTPTabPaintManager::CColorSet* CXTPTabPaintManager::GetColorSet() const {
    return m_pColorSet;
}
Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetFont Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetFont Method

Call this member to get the CFont used for displaying tab caption text.

CFont* GetFont(
    BOOL bVertical = FALSE
);
Parameters

bVertical
TRUE if the XTPTabPosition is vertical, FALSE if the XTPTabPosition is horizontal.

Returns

CFont used to display caption text in the tab buttons.

See Also

GetBoldFont

Body Source
CFont* CXTPTabPaintManager::GetFont(BOOL bVertical) {
    return bVertical ? &m_fntVerticalNormal : &m_fntNormal;
}
Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetLayout Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetLayout Method

Call this member to get the currently set tab layout.

XTPTabLayoutStyle GetLayout() const;
Returns

Currently used XTPTabLayoutStyle.

Remarks

The layout refers to how the tab buttons are sized within the tab client header. The tab buttons can be in a compressed, fixed, auto size, or size to fit layout.

See Also

SetLayout

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetOneNoteColor Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetOneNoteColor Method

Retrieves the COLORREF value for the specified OneNote color.

static COLORREF GetOneNoteColor(
    XTPTabOneNoteColor tabColor
);
Parameters

tabColor
XTPTabOneNoteColor flag indicating which OneNote color to retrieve. See remarks section for available flags.

Remarks

The tab manager calls this member function to retrieve the RGB color for the value specified by tabColor. tabColor can be one of the following values:

  • xtpTabColorBlue Blue tab color used when OneNote colors enabled.
  • xtpTabColorYellow Yellow tab color used when OneNote colors enabled.
  • xtpTabColorGreen Green tab color used when OneNote colors enabled.
  • xtpTabColorRed Red tab color used when OneNote colors enabled.
  • xtpTabColorPurple Purple tab color used when OneNote colors enabled.
  • xtpTabColorCyan Cyan tab color used when OneNote colors enabled.
  • xtpTabColorOrange Orange tab color used when OneNote colors enabled.
  • xtpTabColorMagenta Magenta tab color used when OneNote colors enabled.
See Also

XTPTabOneNoteColor

Example

See WM_XTP_GETTABCOLOR for an example.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::GetPosition Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::GetPosition Method

Call this member to set the position of the tab buttons.

XTPTabPosition GetPosition() const;
Returns

XTPTabPosition of tab buttons.

Remarks

The position refers to where the tab buttons are located. The tab buttons can be positioned on the top, bottom, left, or right side of the tab client area.

See Also

SetPosition

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::IsLunaColorsDisabled Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::IsLunaColorsDisabled Method

Call this member to determine is luna colors are disabled.

BOOL IsLunaColorsDisabled() const;
Returns

TRUE if luna colors are disabled, FALSE is luna colors are enabled.

See Also

DisableLunaColors

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::OnPropertyChanged Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::OnPropertyChanged Method

This member is called when a property of the tab paint manager has changed.

virtual void OnPropertyChanged();
Remarks

This member is called when the value of a property is changed. For example, when hot tracking in enabled/disabled.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::RefreshMetrics Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::RefreshMetrics Method

This member is called to refresh the visual metrics of the tab main manager.

virtual void RefreshMetrics();
Remarks

This member checks if m_bUseStandardFont is TRUE, if it is, then it updates the font with the standard system "icon" font which is Tahoma 8pt. This member also calls the RefreshMetrics member for the currently used CColorSet and CAppearanceSet.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::RepositionNavigateButtons Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::RepositionNavigateButtons Method

This member is called to reposition the tab navigation buttons.

CRect RepositionNavigateButtons(
    CXTPTabManager* pTabManager,
    CRect rcClient
);
Parameters

pTabManager
Pointer to the tab manager the navigation button are on.
rcClient
Client rectangle of control.

Returns

Tab header rectangle including header margins.

Remarks

This member is called in CXTPTabPaintManager::RepositionTabControlEx to reposition the tab navigation buttons.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::RepositionTabControl Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::RepositionTabControl Method

This method is called to move the tab buttons of the tab control to their correct positions.

virtual void RepositionTabControl(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcControl
);
Parameters

pTabManager
Pointer to the tab manager the tab button are on.
pDC
Pointer to a valid device context.
rcControl
Client rectangle of control.

Remarks

RepositionTabControl and AdjustClientRect are called when the window is resized. When DrawTabControl is called the changes will be used when drawing the tab control.

CXTPTabPaintManager::CAppearanceSet::RepositionTabControl is then called for the currently set appearance.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::RepositionTabControlEx Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::RepositionTabControlEx Method

This method is called to move the tab buttons of the tab control to their correct positions.

void RepositionTabControlEx(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcClient
);
Parameters

pTabManager
Pointer to the tab manager the tab button are on.
pDC
Pointer to a valid device context.
rcClient
Client rectangle of control

Remarks

RepositionTabControl calls CXTPTabPaintManager::CAppearanceSet::RepositionTabControl which will then call RepositionTabControlEx if it has not been overridden.

RepositionTabControl and AdjustClientRect are called when the window is resized. When DrawTabControl is called the changes will be used when drawing the tab control.

See Also

CXTPTabPaintManager::CAppearanceSet::RepositionTabControl

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::RepositionTabControlMultiRow Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::RepositionTabControlMultiRow Method

This method is called to move the tab buttons of the multi row tab control to their correct positions.

void RepositionTabControlMultiRow(
    CXTPTabManager* pTabManager,
    CDC* pDC,
    CRect rcClient
);
Parameters

pTabManager
Pointer to the tab manager the tab button are on.
pDC
Pointer to a valid device context.
rcClient
Client rectangle of control

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SetAppearance Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::SetAppearance Method

Call this member to apply one of the "built-in" appearances to the tabs.

CAppearanceSet* SetAppearance(
    XTPTabAppearanceStyle tabAppearance
);
Parameters

tabAppearance
XTPTabAppearanceStyle to apply to the tabs.

Returns

Pointer to the CXTPTabPaintManager::CAppearanceSet object applied.

Remarks

Use SetAppearance to apply a "Built-In" theme such as xtpTabAppearanceExcel. To apply a custom them, use the SetAppearanceSet member.

See Also

XTPTabAppearanceStyle, SetAppearanceSet, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SetAppearanceSet Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::SetAppearanceSet Method

Call this member to apply a custom appearance set.

CAppearanceSet* SetAppearanceSet(
    CAppearanceSet* pAppearanceSet
);
Parameters

pAppearanceSet
Pointer to custom CXTPTabPaintManager::CAppearanceSet appearance set.

Returns

Pointer to newly set custom appearance set.

Remarks

An appearance set specifies how the tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance style will have a half hexagon shape. SetColorSet is used to set custom colors.

See the GUI_Eclipse sample for an example of how to create a custom appearance set and apply it to the tabs.

See Also

XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SetColor Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::SetColor Method

Call this member to apply one of the "built-in" color sets to the tabs.

CColorSet* SetColor(
    XTPTabColorStyle tabColor
);
Parameters

tabColor
XTPTabColorStyle to apply to the tabs.

Returns

Pointer to the CXTPTabPaintManager::CColorSet object applied.

See Also

XTPTabColorStyle, SetColorSet, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SetColorSet Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::SetColorSet Method

Call this member to apply a custom color set to the tabs.

CColorSet* SetColorSet(
    CColorSet* pColorSet
);
Parameters

pColorSet
Pointer to custom CXTPTabPaintManager::CColorSet appearance set.

Returns

Pointer to the newly set custom color set.

See Also

XTPTabColorStyle, SetColor, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SetFontIndirect Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::SetFontIndirect Method

Call this member to set the font for the tabs.

void SetFontIndirect(
    LOGFONT* pLogFont,
    BOOL bUseStandardFont = FALSE
);
Parameters

pLogFont
New LOGFONT to use for text in the tab buttons.
bUseStandardFont
When calling SetFontIndirect, always use FALSE, this will indicate that pLogFont should be used as the new tab font.

TRUE is used when SetFontIndirect is called internally when the system font is changed.

Remarks

When bUseStandardFont is TRUE, the standard system "icon" font will be used. The standard "icon" font is Tahoma 8pt.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SetLayout Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::SetLayout Method

Call this member to set the tab layout style.

void SetLayout(
    XTPTabLayoutStyle tabLayout
);
Parameters

tabLayout
New XTPTabLayoutStyle to apply to the tabs.

Remarks

The layout refers to how the tab buttons are sized within the tab client header. The tab buttons can be in a compressed, fixed, auto size, or size to fit layout.

See Also

GetLayout

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SetOneNoteColors Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class
CXTPTabPaintManager::SetOneNoteColors Method

Call this member to enabledisable OneNote colorization for the tabs.

void SetOneNoteColors(
    BOOL bOneNoteColors
);
Parameters

bOneNoteColors
TRUE to enable OneNote colors, FALSE to disable OneNote colors.

Remarks

OneNote colors are similar to the tab colorization of tabs in Microsoft OneNote.

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SetPosition Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::SetPosition Method

Call this member to set the tab position.

void SetPosition(
    XTPTabPosition tabPosition
);
Parameters

tabPosition
New XTPTabPosition to apply to tab manager.

Remarks

The position refers to where the tab buttons are located. The tab buttons can be positioned on the top, bottom, left, or right side of the tab client area.

See Also

GetPosition

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager::SizeToFit Method

CXTPTabPaintManager Methods, CXTPTabPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTabPaintManager::SizeToFit Method

This member is called to change the tab button size when the XTPTabLayoutStyle is xtpTabLayoutSizeToFit.

void SizeToFit(
    CXTPTabManager* pTabManager,
    int nWidth
);
Parameters

pTabManager
Pointer to tab manager.
nWidth
Total width that all tab buttons must fit in.

Remarks

When calculating nWidth, the left and right rcHeaderMargin and tab navigation button widths should be subtracted from the TabClient width.

See Also

XTPTabLayoutStyle, SetLayout, GetLayout

Group

CXTPTabPaintManager Methods


CXTPTabPaintManager Constructors

CXTPTabPaintManager Class, Legend, Public Methods
CXTPTabPaintManager Constructors
Class

CXTPTabPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabPaintManager | Constructs a CXTPTabPaintManager object.


CXTPTabPaintManager::CXTPTabPaintManager Constructor

CXTPTabPaintManager Constructors, CXTPTabPaintManager Class
CXTPTabPaintManager::CXTPTabPaintManager Constructor

Constructs a CXTPTabPaintManager object.

CXTPTabPaintManager();
Group

CXTPTabPaintManager Constructors


CXTPTabPaintManager Destructors

CXTPTabPaintManager Class, Legend, Public Methods
CXTPTabPaintManager Destructors
Class

CXTPTabPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTabPaintManager | Destroys a CXTPTabPaintManager object, handles cleanup and deallocation.


CXTPTabPaintManager::~CXTPTabPaintManager Destructor

CXTPTabPaintManager Destructors, CXTPTabPaintManager Class
CXTPTabPaintManager::~CXTPTabPaintManager Destructor

Destroys a CXTPTabPaintManager object, handles cleanup and deallocation.

virtual ~CXTPTabPaintManager();
Group

CXTPTabPaintManager Destructors


Structs, Records, Enums

Enumerations, Legend, Tab Manager
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPTabAppearanceStyle | XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.
XTPTabClientFrame | XTPTabClientFrame is an enumeration used to set the client frame style drawn around the client of tabs.
XTPTabColorStyle | XTPTabColorStyle is an enumeration used to set the color style of tabs.
XTPTabLayoutStyle | XTPTabLayoutStyle is an enumeration used to set the layout of tabs.
XTPTabNavigateButton | XTPTabNavigateButton is an enumeration used to identify navigation buttons within a tab control.
XTPTabNavigateButtonFlags | XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed. This style is applied to one button. Navigate buttons include the left, right, and close buttons that appear in the tab header area.
XTPTabOneNoteColor | XTPTabOneNoteColor is an enumeration used to indicate which OneNote COLORREF value to retrieve.
XTPTabPosition | XTPTabPosition is an enumeration used to set the position of tabs.
XTPTabToolTipBehaviour | XTPTabToolTipBehaviour is an enumeration used to set tooltip behaviour for tabs
XTPTabWorkspacePart | XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace needs to be redrawn.
Module

Tab Manager

Legend
Enumeration


XTPTabAppearanceStyle Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabAppearanceStyle Enumeration

XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.

enum XTPTabAppearanceStyle {
  xtpTabAppearancePropertyPage,
  xtpTabAppearancePropertyPageSelected,
  xtpTabAppearancePropertyPageFlat,
  xtpTabAppearancePropertyPage2003,
  xtpTabAppearanceStateButtons,
  xtpTabAppearanceVisualStudio,
  xtpTabAppearanceFlat,
  xtpTabAppearanceExcel,
  xtpTabAppearanceVisio,
  xtpTabAppearanceVisualStudio2005,
  xtpTabAppearancePropertyPage2007,
  xtpTabAppearancePropertyPageAccess2007
};
File

XTPTabPaintManager.h

Members

xtpTabAppearancePropertyPage
Gives your tabs an Office 2000 appearance.
xtpTabAppearancePropertyPageSelected
Gives your tabs an Office 2000 selected appearance.
xtpTabAppearancePropertyPageFlat
Gives your tabs an Office 2000 Flat appearance.
xtpTabAppearancePropertyPage2003
Gives your tabs an Office 2003 appearance.
xtpTabAppearanceStateButtons
Gives your tabs a State Button appearance.
xtpTabAppearanceVisualStudio
Gives your tabs a Visual Studio appearance.
xtpTabAppearanceFlat
Gives your tabs Flat appearance.
xtpTabAppearanceExcel
Gives your tabs an Excel appearance.
xtpTabAppearanceVisio
Gives your tabs a Visio appearance.
xtpTabAppearanceVisualStudio2005
Gives your tabs a Visual Studio 2005 appearance.
xtpTabAppearancePropertyPage2007
Gives your tabs an Office 2007 appearance.
xtpTabAppearancePropertyPageAccess2007
Gives your tabs an Office 2007 appearance.

See Also

CXTPTabManager::SetAppearance, CXTPTabPaintManager::SetAppearance

Example
m_wndTabControl.SetAppearance(xtpTabAppearancePropertyPage2003);
Group

Structs, Records, Enums


XTPTabClientFrame Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabClientFrame Enumeration

XTPTabClientFrame is an enumeration used to set the client frame style drawn around the client of tabs.

enum XTPTabClientFrame {
  xtpTabFrameBorder,
  xtpTabFrameSingleLine,
  xtpTabFrameNone
};
File

XTPTabPaintManager.h

Members

xtpTabFrameBorder
With this flag set, a border will appear around the client area.
xtpTabFrameSingleLine
With this flag set, only a single line is used as a border around the client area.
xtpTabFrameNone
With this flag set, no border will appear around the client area.

See Also

CXTPTabManager, CXTPTabPaintManager

Example
m_wndTabControl.GetPaintManager()->m_clientFrame = xtpTabFrameBorder;
Group

Structs, Records, Enums


XTPTabColorStyle Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabColorStyle Enumeration

XTPTabColorStyle is an enumeration used to set the color style of tabs.

enum XTPTabColorStyle {
  xtpTabColorDefault = 1,
  xtpTabColorVisualStudio = 2,
  xtpTabColorOffice2003 = 4,
  xtpTabColorWinXP = 8,
  xtpTabColorWhidbey = 16,
  xtpTabColorOffice2007 = 32,
  xtpTabColorVisualStudio2008 = 64
};
File

XTPTabPaintManager.h

Members

xtpTabColorDefault
Tabs will use the default color for the currently set Appearance.
xtpTabColorVisualStudio
Tabs will use the Visual Studio color style for the currently set Appearance.
xtpTabColorOffice2003
Tabs will use the Office 2003 color style for the currently set Appearance.
xtpTabColorWinXP
Tabs will use the Windows XP color style for the currently set Appearance.
xtpTabColorWhidbey
Tabs will use the Visual Studio 2005 "Whidbey" color style for the currently set Appearance.
xtpTabColorOffice2007
Tabs will use the Office 2007 color style for the currently set Appearance.
xtpTabColorVisualStudio2008
Tabs will use the Visual Studio 2008 color style for the currently set Appearance.

See Also

CXTPTabManager::SetColor, CXTPTabPaintManager::SetColor, CXTPTabManager::GetColor, CXTPTabPaintManager::GetColor

Example
m_wndTabControl.SetColor(xtpTabColorWhidbey);
Group

Structs, Records, Enums


XTPTabLayoutStyle Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabLayoutStyle Enumeration

XTPTabLayoutStyle is an enumeration used to set the layout of tabs.

enum XTPTabLayoutStyle {
  xtpTabLayoutAutoSize,
  xtpTabLayoutSizeToFit,
  xtpTabLayoutFixed,
  xtpTabLayoutCompressed,
  xtpTabLayoutMultiRow,
  xtpTabLayoutRotated
};
File

XTPTabPaintManager.h

Members

xtpTabLayoutAutoSize
Tabs will be automatically sized based on the caption and image size.
xtpTabLayoutSizeToFit
Tabs are sized to fit within the tab panel.
xtpTabLayoutFixed
All tabs will be set to a fixed size within the tab panel.
xtpTabLayoutCompressed
Tabs will be compressed within the tab panel.
xtpTabLayoutMultiRow
Causes a tab control to display multiple rows of tabs
xtpTabLayoutRotated
Rotated tab layout - all tabs rotated to 90 degree.

See Also

CXTPTabManager::SetLayoutStyle, CXTPTabManager::GetLayout

Example
m_wndTabControl.SetLayoutStyle(xtpTabLayoutCompressed);
Group

Structs, Records, Enums


XTPTabNavigateButton Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabNavigateButton Enumeration

XTPTabNavigateButton is an enumeration used to identify navigation buttons within a tab control.

enum XTPTabNavigateButton {
  xtpTabNavigateButtonLeft,
  xtpTabNavigateButtonRight,
  xtpTabNavigateButtonClose
};
File

XTPTabPaintManager.h

Members

xtpTabNavigateButtonLeft
Left tab navigation button.
xtpTabNavigateButtonRight
Right tab navigation button.
xtpTabNavigateButtonClose
Close tab navigation button.

Remarks

This enumerator is used by the CXTPTabManagerNavigateButton class to identify navigation buttons.

See Also

XTPTabNavigateButtonFlags, CXTPTabManager, CXTPTabManagerNavigateButton

Example

See XTPTabNavigateButtonFlags for an example.

Group

Structs, Records, Enums


XTPTabNavigateButtonFlags Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabNavigateButtonFlags Enumeration

XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed. This style is applied to one button. Navigate buttons include the left, right, and close buttons that appear in the tab header area.

enum XTPTabNavigateButtonFlags {
  xtpTabNavigateButtonNone,
  xtpTabNavigateButtonAutomatic,
  xtpTabNavigateButtonAlways
};
File

XTPTabPaintManager.h

Members

xtpTabNavigateButtonNone
Never display the navigate button.
xtpTabNavigateButtonAutomatic
Automatically display the navigate button.
xtpTabNavigateButtonAlways
Always display the navigate button.

Remarks

If automatic is selected, then the button will appear only when needed. I.e. When the XTPTabLayoutStyle is set to xtpTabLayoutAutoSize, all tab might not fit in the tab header area. When there are more tabs than can fit in the header, the button will automatically be displayed.

See Also

CXTPTabManagerNavigateButton, CXTPTabManagerNavigateButton::SetFlags, CXTPTabManagerNavigateButton::GetFlags

Example

This example code illustrates how to specify when the tab navigation buttons are displayed.

//Gets a reference to the tab manager
CXTPTabManager* pManager = GetManager();
if (pManager)
{
    //Finds the left navigation button and specifies that it is always displayed
    pManager->FindNavigateButton(xtpTabNavigateButtonLeft)->SetFlags(xtpTabNavigateButtonAlways);
    //Finds the right navigation button and specifies that it is never displayed
    pManager->FindNavigateButton(xtpTabNavigateButtonRight)->SetFlags(xtpTabNavigateButtonNone);
    //Finds the close navigation button and specifies that it is always displayed
    pManager->FindNavigateButton(xtpTabNavigateButtonClose)->SetFlags(xtpTabNavigateButtonAlways);
}
//Called to recalculate tab area and reposition components
pManager->Reposition();
Group

Structs, Records, Enums


XTPTabOneNoteColor Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabOneNoteColor Enumeration

XTPTabOneNoteColor is an enumeration used to indicate which OneNote COLORREF value to retrieve.

enum XTPTabOneNoteColor {
  xtpTabColorBlue = 0x1000000,
  xtpTabColorYellow = 0x1000001,
  xtpTabColorGreen = 0x1000002,
  xtpTabColorRed = 0x1000003,
  xtpTabColorPurple = 0x1000004,
  xtpTabColorCyan = 0x1000005,
  xtpTabColorOrange = 0x1000006,
  xtpTabColorMagenta = 0x1000007
};
File

XTPTabPaintManager.h

Members

xtpTabColorBlue
Blue tab color used when OneNote colors enabled.
xtpTabColorYellow
Yellow tab color used when OneNote colors enabled.
xtpTabColorGreen
Green tab color used when OneNote colors enabled.
xtpTabColorRed
Red tab color used when OneNote colors enabled.
xtpTabColorPurple
Purple tab color used when OneNote colors enabled.
xtpTabColorCyan
Cyan tab color used when OneNote colors enabled.
xtpTabColorOrange
Orange tab color used when OneNote colors enabled.
xtpTabColorMagenta
Magenta tab color used when OneNote colors enabled.

Remarks

This enumerator is used by CXTPTabPaintManager::GetOneNoteColor to retrieve a specified OneNote RGB color value.

See Also

CXTPTabPaintManager::GetOneNoteColor, CXTPTabManager::GetItemColor, CXTPDockingPane::GetItemColor

Example

See WM_XTP_GETTABCOLOR for an example.

Group

Structs, Records, Enums


XTPTabPosition Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabPosition Enumeration

XTPTabPosition is an enumeration used to set the position of tabs.

enum XTPTabPosition {
  xtpTabPositionTop,
  xtpTabPositionLeft,
  xtpTabPositionBottom,
  xtpTabPositionRight
};
File

XTPTabPaintManager.h

Members

xtpTabPositionTop
Tabs will be drawn on the Top.
xtpTabPositionLeft
Tabs will be drawn on the Left.
xtpTabPositionBottom
Tabs will be drawn on the Bottom.
xtpTabPositionRight
Tabs will be drawn on the Right.

See Also

CXTPTabManager::SetPosition, CXTPTabManager::GetPosition

Example
m_wndTabControl.SetPosition(xtpTabPositionBottom);
Group

Structs, Records, Enums


XTPTabToolTipBehaviour Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTabToolTipBehaviour Enumeration

XTPTabToolTipBehaviour is an enumeration used to set tooltip behaviour for tabs

enum XTPTabToolTipBehaviour {
  xtpTabToolTipNever,
  xtpTabToolTipAlways,
  xtpTabToolTipShrinkedOnly
};
File

XTPTabPaintManager.h

Members

xtpTabToolTipNever
Doesn't show tooltips for tabs
xtpTabToolTipAlways
Show tooltips for tabs always
xtpTabToolTipShrinkedOnly
Show tooltips only if tab was shrinked (see xtpTabLayoutSizeToFit layout)

See Also

CXTPTabPaintManager::EnableToolTips, XTPTabLayoutStyle

Example
m_wndTabControl.GetPaintManager()->EnableToolTips(xtpTabToolTipAlways);
Group

Structs, Records, Enums


XTPTabWorkspacePart Enumeration

XTPTabPaintManager.h, Structs, Records, Enums, See Also
XTPTabWorkspacePart Enumeration

XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace needs to be redrawn.

enum XTPTabWorkspacePart {
  xtpTabWorkspacePartBorder,
  xtpTabWorkspacePartWidth,
  xtpTabWorkspacePartVSplitter,
  xtpTabWorkspacePartHSplitter
};
File

XTPTabPaintManager.h

Members

xtpTabWorkspacePartBorder
Indicates that the border of the MDITabClient TabWorkspace should be drawn.
xtpTabWorkspacePartWidth
Indicates that the border width of the MDITabClient TabWorkspace should be recalculated.
xtpTabWorkspacePartVSplitter
Indicates that the vertical splitter of the MDITabClient TabWorkspace should be drawn.
xtpTabWorkspacePartHSplitter
Indicates that the horizontal splitter of the MDITabClient TabWorkspace should be drawn.

Remarks

The enumerators are used by CXTPTabPaintManager::CAppearanceSet::DrawWorkspacePart when redrawing the MDITabClient TabWorkspace when grouping is enabled.

See Also

CXTPTabPaintManager::CAppearanceSet::DrawWorkspacePart

Group

Structs, Records, Enums


Variables

Tab Manager, Variables
Variables
Module

Tab Manager

Variables
Variable | Description
WM_XTP_GETTABCOLOR | The WM_XTP_GETTABCOLOR message is sent to MDI child window to retrieve color will be used for tabbed interface with enabled OneNote colors.
XTP_TABMANAGER_COLOR_NONE | Indicates that a transparent color should be used.
XTP_TABMANAGER_COLOR_SHADED | Indicates a special "shaded" fill type.


WM_XTP_GETTABCOLOR Variable

XTPTabManager.h, Variables, Example, See Also
WM_XTP_GETTABCOLOR Variable

The WM_XTP_GETTABCOLOR message is sent to MDI child window to retrieve color will be used for tabbed interface with enabled OneNote colors.

const UINT WM_XTP_GETTABCOLOR = (WM_USER + 9400 + 1);
File

XTPTabManager.h

Returns

COLORREF of color to be used.

Remarks

You can override CXTPTabClientWnd::GetItemColor instead of process the message.

See Also

CXTPTabPaintManager::GetOneNoteColor, CXTPTabClientWnd, WM_XTP_GETWINDOWTEXT, WM_XTP_GETTABICON, WM_XTP_GETWINDOWTOOLTIP

Example

Here is an example of how an application would process the WM_XTP_GETTABCOLOR message.

BEGIN_MESSAGE_MAP(CChildFrame, CMDIChildWnd)
    //{{AFX_MSG_MAP(CChildFrame)
    ON_MESSAGE(WM_XTP_GETTABCOLOR, OnGetTabColor)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CChildFrame::OnGetTabColor(WPARAM /*wParam*/, LPARAM /*lParam*/)
{
    return CXTPTabPaintManager::GetOneNoteColor(xtpTabColorOrange);
}
Group

Variables


XTP_TABMANAGER_COLOR_NONE Variable

XTPTabPaintManager.h, Variables, See Also
XTP_TABMANAGER_COLOR_NONE Variable

Indicates that a transparent color should be used.

const COLORREF XTP_TABMANAGER_COLOR_NONE = (COLORREF)(-1);
File

XTPTabPaintManager.h

Remarks

If an objects COLORREF value is XTP_TABMANAGER_COLOR_NONE it is used to indicate that the object should not be drawn. This is used in the tab appearance and color functions to indicate when tab borders, highlighting, shadowing, etc should be drawn.

Setting a member of CXTPTabPaintManager::CColorSet to XTP_TABMANAGER_COLOR_NONE will indicate that the member should not be drawn.

See Also

CXTPTabPaintManager::CColorSet

Group

Variables


XTP_TABMANAGER_COLOR_SHADED Variable

XTPTabPaintManager.h, Variables, See Also
XTP_TABMANAGER_COLOR_SHADED Variable

Indicates a special "shaded" fill type.

const COLORREF XTP_TABMANAGER_COLOR_SHADED = (COLORREF)(-2);
File

XTPTabPaintManager.h

Remarks

To get the "shaded" effect, the object will be filled with one pixel COLOR_3DFACE, one pixel COLOR_3DHIGHLIGHT, one pixel COLOR_3DFACE....

Setting the clrLight parameter to XTP_TABMANAGER_COLOR_SHADED in the used in CXTPTabPaintManager::CColorSet::GradientFill member will cause the object to be filled with the special shaded fill.

Notes

This is used in xtpTabAppearanceStateButtons to colorize the button face. The special fill was used to color of the currently selected tab. The special fill can be applied to any color member.

See Also

CXTPTabPaintManager::CColorSet::GradientFill

Group

Variables


Files

Files, Tab Manager
Files
Files
File | Description
XTPTabControl.h | XTPTabControl.h: interface for the CXTPTabControl class.
XTPTabManager.h | XTPTabManager.h: interface for the CXTPTabManager class.
XTPTabPaintManager.h | XTPTabPaintManager.h: interface for the CXTPTabPaintManager class.
Module

Tab Manager


XTPTabControl.h

Classes, Files
XTPTabControl.h

XTPTabControl.h: interface for the CXTPTabControl class.

Classes
Class | Description
CXTPTabControl | CXTPTabControl is a multiple inheritance class derived from CXTPTabManager and CWnd. It is used to draw enhance tab control with Office 2003, Visual Studio, Win XP tabs.
Group

Files


XTPTabManager.h

Classes, Files, Types, Variables
XTPTabManager.h

XTPTabManager.h: interface for the CXTPTabManager class.

Classes
Class | Description
CXTPTabManager | CXTPTabManager is a CXTPTabManagerAtom derived class. This is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
CXTPTabManagerAtom | CXTPTabManagerAtom is a class that has only one purpose, which is to catch the event when a property of the PaintManager has changed. When a property of the PaintManager has changed, the OnPropertyChanged event if called. When the OnPropertyChanged is caught, Reposition is called to recalculate self layout.
CXTPTabManagerItem | CXTPTabManagerItem is a CCmdTarget derived class that represents a tab item. This is the base class for the tabs that appear in the CommandBars TabWorkSpace, DockingPanes, and TabControl.
CXTPTabManagerNavigateButton | CXTPTabManagerNavigateButton is a class used to represent the tab navigation buttons.
Group

Files

Types
Type | Description
CXTPTabManagerNavigateButtons | Navigate buttons array definition
Variables
Variable | Description
WM_XTP_GETTABCOLOR | The WM_XTP_GETTABCOLOR message is sent to MDI child window to retrieve color will be used for tabbed interface with enabled OneNote colors.


XTPTabPaintManager.h

Classes, Enumerations, Files, Legend, Variables
XTPTabPaintManager.h

XTPTabPaintManager.h: interface for the CXTPTabPaintManager class.

Classes
Class | Description
CXTPTabPaintManager | CXTPTabPaintManager is a CCmdTarget derived class that is used to store the color and appearance information of the tabs in the tab manager.
Enumerations
Enumeration | Description
XTPTabAppearanceStyle | XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.
XTPTabClientFrame | XTPTabClientFrame is an enumeration used to set the client frame style drawn around the client of tabs.
XTPTabColorStyle | XTPTabColorStyle is an enumeration used to set the color style of tabs.
XTPTabLayoutStyle | XTPTabLayoutStyle is an enumeration used to set the layout of tabs.
XTPTabNavigateButton | XTPTabNavigateButton is an enumeration used to identify navigation buttons within a tab control.
XTPTabNavigateButtonFlags | XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed. This style is applied to one button. Navigate buttons include the left, right, and close buttons that appear in the tab header area.
XTPTabOneNoteColor | XTPTabOneNoteColor is an enumeration used to indicate which OneNote COLORREF value to retrieve.
XTPTabPosition | XTPTabPosition is an enumeration used to set the position of tabs.
XTPTabToolTipBehaviour | XTPTabToolTipBehaviour is an enumeration used to set tooltip behaviour for tabs
XTPTabWorkspacePart | XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace needs to be redrawn.
Group

Files

Variables
Variable | Description
XTP_TABMANAGER_COLOR_NONE | Indicates that a transparent color should be used.
XTP_TABMANAGER_COLOR_SHADED | Indicates a special "shaded" fill type.
Legend
Enumeration


Types

Tab Manager, Types
Types
Module

Tab Manager

Types
Type | Description
CXTPTabManagerNavigateButtons | Navigate buttons array definition


CXTPTabManagerNavigateButtons Type

XTPTabManager.h, Types
CXTPTabManagerNavigateButtons Type

Navigate buttons array definition

typedef CArray<CXTPTabManagerNavigateButton*, CXTPTabManagerNavigateButton*> CXTPTabManagerNavigateButtons;
File

XTPTabManager.h

Group

Types


Standard Controls

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Functions, Macros, Structs, Records, Enums, Types, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Standard Controls

Codejock Software's Standard Controls provide many enhanced components such as hyperlink and multiple selection tree controls, browse edit and Office style color popups, Windows Explorer shell components and much more.

Group

Xtreme Toolkit Pro v12.0

Legend
Template
Method
Structure
Enumeration
Classes
Class | Description
CXTAnimationMemDC | CXTAnimationMemDC is a CXTMemDC derived class. This class can be used to render animation effects for the current device context.
CXTAuxData | CXTAuxData is a stand alone global item data structure class. It is used by the toolkit to initialize and store resource and item data shared by all objects. Items include system colors, icons, fonts and OS flags.
CXTAuxDataTheme | The CXTAuxDataTheme class is used by the CXTAuxData class to provide backward compatibility with older versions that still use bXPMode to provide Office XP theme support.
CXTBrowseButton | CXTBrowseButton is a CXTButton derived class that is used by CXTBrowseEdit to create the browse button that is used to display file dialogs and popup menus.
CXTBrowseDialog | CXTBrowseDialog is derived from the BROWSEINFO structure. It is used to display a directory chooser dialog using shell extensions.
CXTBrowseEdit | CXTBrowseEdit is a CXTEdit derived class. This class also has a push button associated with it. The control can be used to search for directories and files or activate a popup menu.
CXTButton | CXTButton is a CButton derived class. It is used to create flat style and image buttons. This control has several features including flat, semi-flat, and three dimensional borders.
CXTButtonTheme | CXTButtonTheme is used to draw the CXTButton object. All themes used for CXTButton should inherit from this base class.
CXTButtonThemeOffice2003 | CXTButtonThemeOffice2003 is a CXTButtonThemeOfficeXP derived class that is used to draw an Office 2003 style theme for the button.
CXTButtonThemeOfficeXP | CXTButtonThemeOfficeXP is a CXTButtonTheme derived class that is used to draw an Office XP style theme for the button.
CXTCaption | CXTCaption is a CStatic derived class. It is used to create caption or info bars similar to those in Microsoft(r) Outlook.
CXTCaptionButton | CXTCaptionButton is a CXTButton derived class. It is used by the CXTCaption class to activate a CXTCaptionPopupWnd window.
CXTCaptionButtonTheme | CXTCaptionButtonTheme is derived from CXTButtonTheme. This class is used to set the caption for buttons.
CXTCaptionButtonThemeOffice2003 | Class CXTCaptionButtonThemeOffice2003 is a CXTButtonThemeOffice2003 derived class. This class is used to create a button caption that resembles an Office 2003 button caption.
CXTCaptionButtonThemeOfficeXP | Class CXTCaptionButtonThemeOfficeXP is a CXTButtonThemeOfficeXP derived class. This class is used to create a button caption that resembles an Office XP button caption.
CXTCaptionPopupWnd | CXTCaptionPopupWnd is a CWnd derived class. It is used by the CXTCaption class to display a popup child window similar to Outlook(tm).
CXTCaptionTheme | CXTCaptionTheme is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.
CXTCaptionThemeOffice2003 | CXTCaptionThemeOffice2003 is derived from CXTCaptionTheme. It is used to set the caption to the Office 2003 theme.
CXTCaptionThemeOfficeXP | CXTCaptionThemeOfficeXP is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.
CXTCheckListBox | The CXTCheckListBox class is a CXTListBox derived class. It provides the functionality of Office style checklist box. A "checklist box" displays a list of items such as filenames. Each item in the list has a check box next to it that the user can either check or clear.
CXTColorBase | CXTColorBase is a CStatic derived base class. It is used to create custom color selection windows.
CXTColorDialog | CXTColorDialog is a CPropertySheet derived class. It is an Office(tm) style color dialog and can be used as a drop in replacement for the MFC CColorDialog API.
CXTColorHex | CXTColorHex is a CStatic derived class. It displays a color selection grid used by CXTColorPageStandard.
CXTColorLum | CXTColorLum is a CXTColorBase derived class. It is used to create a color luminance selection bar.
CXTColorPageCustom | CXTColorPageCustom is derived from CXTThemePropertyPage. It is used to create a CXTColorPageCustom dialog.
CXTColorPageStandard | CXTColorPageStandard is derived from CXTThemePropertyPage, it is used to create a CXTColorPageStandard dialog.
CXTColorPicker | CXTColorPicker is a CXTButton derived class. It displays a color picker popup window (CXTColorPopup) for Office(tm) style color selection.
CXTColorPopup | CXTColorPopup is a CXTColorSelectorCtrl derived class. It is used to create a CXTColorPopup window that will allow a user to select colors and add custom colors to a color list.
CXTColorRef | CXTColorRef is a stand alone class. It is used to create a CXTColorRef object. This object is used for manipulation of RGB values.
CXTColorSelectorCtrl | CXTColorSelectorCtrl is a CWnd derived class. It is used to create a CXTColorSelectorCtrl control that will allow a user to select colors.
CXTColorSelectorCtrlTheme | CXTColorSelectorCtrlTheme is derived from CXTThemeManagerStyle to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorSelectorCtrlThemeOffice2003 | CXTColorSelectorCtrlThemeOffice2003 is derived from CXTColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorSelectorCtrlThemeOfficeXP | CXTColorSelectorCtrlThemeOfficeXP is derived from CXTColorSelectorCtrlTheme to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorWnd | CXTColorWnd is a CXTColorBase derived class. It is used to create a color selection window.
CXTComboBoxEx | The CXTComboBoxEx class is a CComboBox derived class. It extends the combo box control by providing support for image lists.
CXTContextBkColorHandler | Background color context handler
CXTContextBkModeHandler | Background mode context handler
CXTContextObjectHandler | Safely selects object into device context
CXTContextTextColorHandler | Text color context handler
CXTContextViewPortOrgHandler | Handles viewport origin
CXTDateEdit | CXTDateEdit is a CXTMaskEdit derived class. It is specifically geared toward editing date fields.
CXTDateTimeCtrl | CXTDateTimeCtrl is a CWnd derived class. A CXTDateTimeCtrl object encapsulates the functionality of a date and time picker control.
CXTDirWatcher | The CXTDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur.
CXTDisabledButtonTheme | CXTDisabledButtonTheme is a CXTButtonTheme derived class that is used to draw 3D disabled icons for the button.
CXTDropSource | CXTDropSource class is derived from IDropSource. It is used by the shell list control to provide drag-and-drop operations in your application.
CXTEdit | CXTEdit is a CEdit derived class. The CXTEdit class provides the functionality of a Windows edit control. An edit control is a rectangular child window in which the user can enter text.
CXTEditListBox | CXTEditListBox is a CXTListBox derived class. It is used to create an editable list box. This list box can be configured to display a toolbar for editing. You can define browse styles to search for files or folders. Each entry is made editable with a double mouse click.
CXTEditListBoxToolBar | CXTEditListBoxToolBar is a CStatic derived class. It used by the CXTEditListBox class to create a toolbar above the edit list box to display icons for editing.
CXTExcelTabCtrl | CXTExcelTabCtrl is a CWnd derived class. It is used to create an Excel style sheet control. This control allows you to define if you want the control to have home, end, back, and next buttons.
CXTExcelTabCtrlButtonState | The CXTExcelTabCtrlButtonState class is used by the CXTExcelTabCtrl class to manage navigation button information. This class contains information about the state and command identifiers for the button.
CXTExcelTabCtrlTheme | CXTExcelTabCtrlTheme is used to draw the CXTExcelTabCtrl object. All themes used for CXTExcelTabCtrl should inherit from this base class.
CXTExcelTabCtrlThemeOffice2003 | CXTExcelTabCtrlThemeOffice2003 is used to draw the CXTExcelTabCtrl object.
CXTExcelTabCtrlThemeOfficeXP | CXTExcelTabCtrlThemeOfficeXP is used to draw the CXTExcelTabCtrl object.
CXTFlatComboBox | CXTFlatComboBox is a CComboBox derived class. The CXTFlatComboBox class can easily give your application's standard CComboBox control the Flat Look that is seen in many of the Microsoft(r) Office(tm) products.
CXTFlatComboBoxTheme | CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.
CXTFlatComboBoxThemeOffice2003 | CXTFlatComboBoxThemeOffice2003 class is derived from CXTFlatComboBoxThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.
CXTFlatComboBoxThemeOfficeXP | CXTFlatComboBoxThemeOfficeXP class is derived from CXTFlatComboBoxTheme. This class is used to create the Office 2000 Theme for flat controls.
CXTFlatEdit | CXTFlatEdit is a CXTEdit derived class. The CXTFlatEdit class can easily give your application's standard CEdit control the flat look that is seen in many of the Microsoft(r) Office(tm) products.
CXTFlatEditTheme | CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.
CXTFlatEditThemeOffice2003 | CXTFlatEditThemeOffice2003 class is derived from CXTFlatEditThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.
CXTFlatEditThemeOfficeXP | CXTFlatEditThemeOfficeXP class is derived from CXTFlatEditTheme. This class is used to create the Office 2000 Theme for flat controls.
CXTFlatHeaderCtrl | CXTFlatHeaderCtrl is a CHeaderCtrl derived class. It is used to create list box flat header controls that are similar to list box flat header controls seen in Visual Studio(tm) and Outlook(tm).
CXTFontCombo | CXTFontCombo is a CXTFlatComboBox derived class. It is used to create a combo box that displays a drop list of available fonts for your system. The fonts are displayed in their various styles.
CXTFontEnum | CXTFontEnum is a stand alone singleton font enumeration class. It is used to enumerate a list of fonts found installed for the operating system.
CXTFontListBox | CXTFontListBox is a CXTListBox derived class. It is used to create a font selection list box.
CXTHeaderCtrl | CXTHeaderCtrl is a CHeaderCtrl derived class. It is used to create a CXTHeaderCtrl window similar to CHeaderCtrl, but with additional functionality.
CXTHeaderCtrlTheme | CXTHeaderCtrlTheme is a theme class used to draw windows classic style theme for the header control.
CXTHeaderCtrlThemeExplorer | CXTHeaderCtrlThemeExplorer is a CXTHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control.
CXTHeaderCtrlThemeOffice2003 | CXTHeaderCtrlThemeOffice2003 is a CXTHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control.
CXTHeaderCtrlThemeOfficeXP | CXTHeaderCtrlThemeOfficeXP is a CXTHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control.
CXTHexEdit | CXTHexEdit is a CEdit derived class. It is used to create an edit control which will allow editing in hex display format.
CXTHtmlView | CXTHtmlView is a CFormView derived class. The CXTHtmlView class provides the functionality of the WebBrowser control within the context of MFC's document/view architecture. The WebBrowser control is a window in which the user can browse sites on the World Wide Web as well as folders in the local file system and on a network. The WebBrowser control supports hyperlinking, Uniform Resource Locator (URL) navigation, and maintains a history list.
CXTHyperLink | CXTHyperLink is a CStatic derived class. It is used to display a text string that is used as a hyperlink control. The link's active, hover, and selected color attributes are configurable.
CXTIconHandle | CXTIconHandle is a stand alone helper class. It is used to automatically destroy dynamically created hIcon handles.
CXTItemEdit | CXTItemEdit is a CXTBrowseEdit derived class. It is used to create a CXTItemEdit window that can be used as an "in-place" edit field that can be dynamically created for controls such as a list box.
CXTListBase | CXTListBase is a non-inherited class. It implements the extended list control services provided by the Xtreme Toolkit list control classes.
CXTListBox | CXTListBox is a CListBox derived class. CXTListBox extends the standard list box control to enable flicker free drawing.
CXTListCtrl | CXTListCtrl is a multiple inheritance class derived from CListCtrl and CXTListBase. This class implements flat header and generic sorting routines. See CXTListBase for additional functionality.
CXTListView | CXTListView is a multiple inheritance class derived from CListView and CXTListBase. This class implements flat header and generic sorting routines.
CXTListViewHelper | The CXTListViewHelper class is a helper class that provides helper functions for finding selected items for the MFC CListView class.
CXTLogFont | CXTLogFont is a self initializing LOGFONT derived class. It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.
CXTMaskEdit | CXTMaskEdit is a CEdit derived class. It allows text masking to be applied to the control to format it for special editing restrictions.
CXTMDIClientWnd | CXTMDIClientWnd is a CWnd derived helper class for the CXTMDIWndTab tab control. This class routes messages sent to the client window back to the tab control.
CXTMDIWndTab | CXTMDIWndTab class is used for creating a tabbed MDI document interface.
CXTMemDC | CXTMemDC is a CDC derived class. CXTMemDC is an extension of CDC that helps eliminate screen flicker when windows are resized, by painting to an off screen bitmap. The class then uses CDC::BitBlt to copy the bitmap back into the current device context after all items have been painted.
CXTMemFile | CXTMemFile is a CMemFile derived class. It is used to create a CXTMemFile object to support memory files.
CXTMenuListBox | CCXTMenuListBox is a CListBox derived class. It is used to implement an Outlook bar style control. It can only be used with the LBS_OWNERDRAWVARIABLE style bit set. This is a simpler version of CXTOutBarCtrl and does not allow for shortcut folders.
CXTMenuListBoxTheme | CXTMenuListBoxTheme is used to draw the CXTMenuListBox object. All themes used for CXTButton should inherit from this base class.
CXTMenuListBoxThemeOffice2003 | Class CXTMenuListBoxThemeOffice2003 is derived from CXTMenuListBoxThemeXP. This class is used to implement the Office 2003 theme for Menu List Boxes.
CXTMenuListBoxThemeOfficeXP | Class CXTMenuListBoxThemeOfficeXP is derived from CXTMenuListBoxTheme. This class is used to implement the Office XP theme for Menu List Boxes.
CXTMonthCalCtrl | CXTMonthCalCtrl is a CWnd derived class. A CXTMonthCalCtrl object encapsulates the functionality of a month calendar control.
CXTNonClientMetrics | CXTNonClientMetrics is a self initializing NONCLIENTMETRICS derived class. It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.
CXTOutBarCtrl | CXTOutBarCtrl is a CWnd derived class. It is used to create a shortcut bar window similar to the shortcut bar seen in Outlook(tm).
CXTOutBarCtrlTheme | CXTOutBarCtrlTheme is used to draw the CXTOutBarCtrl object. All themes used for CXTOutBarCtrl should inherit from this base class.
CXTOutBarCtrlThemeOffice2003 | Class CXTOutBarCtrlThemeOffice2003 is derived form CXTOutBarCtrlThemeXP. This class is used to draw an OutBar with the Office XP theme.
CXTOutBarCtrlThemeOfficeXP | Class CXTOutBarCtrlThemeOfficeXP is derived form CXTOutBarCtrlTheme. This class is used to draw an OutBar with the Office XP theme.
CXTOutBarEditItem | CXTOutBarEditItem is a helper class derived from CXTEdit. It is used by CXTOutBarCtrl, an Outlook like control, to create an in-place edit box that is used to modify a folder or an item within the control.
CXTOutBarFolder | CXTOutBarFolder is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder specified in the Outlook bar control.
CXTOutBarItem | CXTOutBarItem is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder item specified in the Outlook bar control.
CXTPagerCtrl | CXTPagerCtrl is a CWnd derived class. It is used to contain and scroll another window, and wraps the windows pager API.
CXTPPopupControl | CXTPPopupControl is a class for control of popup window
CXTPPopupItem | CXTPPopupItem is a class used to management popup item object
CXTPPopupPaintManager | CXTPPopupPaintManager is a class used to perform specialized drawing tasks.
CXTPPopupThemeMSN | CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks.
CXTPPopupThemeOffice2000 | CXTPPopupThemeOffice2000 is a class used to perform Office2000 drawing tasks.
CXTPPopupThemeOffice2003 | CXTPPopupThemeOffice2003 is a class used to perform Office2003 drawing tasks.
CXTPPopupThemeOffice2007 | CXTPPopupThemeOffice2007 is a class used to perform Office2007 drawing tasks.
CXTPPopupThemeOfficeXP | CXTPPopupThemeOfficeXP is a class used to perform OfficeXP drawing tasks.
CXTPPropertyPage | CXTPPropertyPage is a CPropertyPage derived class Objects of class CPropertyPage represent individual pages of a property sheet
CXTPPropertyPageControlNavigator | CXTPPropertyPageControlNavigator is CXTPPropertyPageNavigator derived class It represents base control property page navigator
CXTPPropertyPageListNavigator | CXTPPropertyPageListNavigator is CXTListBox and CXTPPropertyPageControlNavigator derived class It represents list property page navigator
CXTPPropertyPageNavigator | CXTPPropertyPageNavigator is a standalone class CXTPPropertyPageNavigator represents base navigator object for CXTPPropertySheet
CXTPPropertyPageTabNavigator | CXTPPropertyPageTabNavigator is CXTPTabControl and CXTPPropertyPageNavigator derived class It represents tabbed property page navigator
CXTPPropertyPageTreeNavigator | CXTPPropertyPageTreeNavigator is CTreeCtrl and CXTPPropertyPageControlNavigator derived class It represents tree property page navigator
CXTPPropertySheet | CXTPPropertySheet is a CDialog derived class It represents property sheet, otherwise known as tab dialog box. A property sheet consists of a CXTPPropertySheet object and one or more CXTPPropertyPage objects.
CXTPTaskDialog | The CXTPTaskDialog class creates, displays, and operates a task dialog. A task dialog is similar to, while much more flexible than, a basic message box. The task dialog contains application-defined messages, title, verification check box, command links and push buttons, plus any combination of predefined icons and push buttons.
CXTRegistryManager | CXTRegistryManager is a stand alone registry management class. You can use it to read and write values from your system's registry or an .INI file. Use CXTRegistryManager to read and write string, integer, and binary data to and from the registry. You can also specify an .INI file name, and have these values stored there instead.
CXTResize | CXTResize is a base class. It is used by resizing dialogs, property sheets, and form views. It acts as a manager to maintain size and location of the dialog and dialog items.
CXTResizeDialog | CXTResizeDialog is a multiple inheritance class derived from CDialog and CXTResize. CXTResizeDialog is used to create a resizable CDialog type object that allows its dialog items to be resized or moved dynamically.
CXTResizeFormView | CXTResizeFormView is a multiple inheritance class derived from CFormView and CXTResize. CXTResizeFormView is used to create a resizable CFormView type object that allows its form items to be resized or moved dynamically.
CXTResizeGroupBox | CXTResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing. This class is intended to only be used as a group box and only used on a CXTResize window. You can subclass or create this object the way you would any CButton.
CXTResizeItem | CXTResizeItem is a stand alone helper class. It is used by CXTResize to maintain information about each item to be sized or moved.
CXTResizePoint | CXTResizePoint is an XT_RESIZEPOINT structure derived class. The CXTResizePoint class is similar to the XT_RESIZEPOINT structure. It also includes member functions to manipulate CXTResizePoint and XT_RESIZEPOINT structures. A CXTResizePoint object can be used wherever an XT_RESIZEPOINT structure is used.
CXTResizePropertyPage | CXTResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTResize. CXTResizePropertyPage is used to create a resizable CPropertyPage type object that allows its dialog items to be resized or moved dynamically.
CXTResizePropertySheet | CXTResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTResize. CXTResizePropertySheet is used to create a resizable CPropertySheet type object that allows its dialog items to be resized or moved dynamically.
CXTResizeRect | CXTResizeRect is an XT_RESIZERECT structure derived class. The CXTResizeRect class is similar to an XT_RESIZERECT structure. CXTResizeRect also includes member functions to manipulate CXTResizeRect objects and XT_RESIZERECT structures.
CXTSearchOptionsCtrl | CXTSearchOptionsCtrl is a CStatic derived class. CXTSearchOptionsCtrl is used to create a control similar to the Search Options item found in the search pane of Windows Explorer as it is seen in Windows 2000 and later. This class allows you to associate a group of controls to be hidden or shown when the item is expanded and contracted and a set of controls that need to move depending on the CXTSearchOptionsCtrl state. Use with CXTSearchOptionsView form view class to create a pane similar to the Windows Explorer search pane. To use the control, define a set of controls that... more
CXTSearchOptionsView | CXTSearchOptionsView is a CFormView derived class. It is to be used with a CXTSearchOptionsCtrl object to paint the background and control background color white. It is also used for resizing and moving children of the form automatically.
CXTShellListBase | CXTShellListBase is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListBase class object.
CXTShellListCtrl | CXTShellListCtrl is a multiple inheritance class derived from CXTListCtrl and CXTShellPidl. It is used to create a CXTShellListCtrl window.
CXTShellListCtrlEx | CXTShellListCtrlEx is a CXTShellListCtrl derived class. It is used to create a stand-alone shell list control that is not dependent on a CXTShellTreeCtrl for initialization. It is used to create a CXTShellListCtrlEx window for displaying the contents of file folders.
CXTShellListView | CXTShellListView is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListView class object.
CXTShellPidl | CXTShellPidl is a stand alone base class. This class is used by the shell tree and list controls to handle PIDL creation and management.
CXTShellSettings | CXTShellSettings is a SHELLFLAGSTATE struct derived class. CXTShellSettings extends the SHELLFLAGSTATE struct for easy access to the shell flag state settings.
CXTShellTreeBase | CXTShellTreeBase is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeBase class object.
CXTShellTreeCtrl | CXTShellTreeCtrl is a multiple inheritance class derived from CXTTreeCtrl and CXTShellPidl. CXTShellTreeCtrl is used to create a tree control that displays an explorer style tree, and can be associated with a combo box and list control.
CXTShellTreeView | CXTShellTreeView is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeView class object.
CXTSizeIcon | The CXTSizeIcon class is a CStatic derived helper class. It is used by CXTResize to display the sizing grip in the lower right corner of a sizing window.
CXTSortClass | CXTSortClass is a stand alone class. This class will sort a list control by a column of text, integer, float or date/time type. It could be easily extended for other data types. To use this class, instantiate a CXTSortClass object, passing in a pointer to the list control as the first argument and the column index as the second argument.
CXTSplitPath | CXTSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension.
CXTSplitterWnd | CXTSplitterWnd is a CSplitterWnd derived class. It adds the ability to hide and show splitter panes based upon its index.
CXTSplitterWndEx | CXTSplitterWndEx is a CXTSplitterWnd derived class. It can be used with the CXTOutBarCtrl to display a gap between the top of the splitter and the toolbar area.
CXTSplitterWndTheme | Class CXTSplitterWndTheme is derived from CXTThemeManagerStyle. This class is used to apply a Theme to splitter windows.
CXTSplitterWndThemeOffice2003 | Class CXTSplitterWndThemeOffice2003 is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.
CXTSplitterWndThemeOfficeXP | Class CXTSplitterWndThemeOfficeXP is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.
CXTTabBase | CXTTabBase is a stand alone base class. It is used to draw an XP style tab control.
CXTTabBaseTheme | CXTTabBaseTheme is used to draw the CXTTabBase object. All themes used for CXTTabBase should inherit from this base class.
CXTTabBaseThemeOffice2003 | Class CXTTabBaseThemeOffice2003 is derived from CXTTabBaseThemeOfficeXP.
CXTTabBaseThemeOfficeXP | Class CXTTabBaseThemeOfficeXP is derived from CXTTabBaseTheme. This class is used to implement the office XP theme for the tab controls.
CXTTabCtrl | CXTTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTTabCtrlBase. It is used to create a CXTTabCtrl class object. See CXTTabCtrlBase for additional functionality.
CXTTabCtrlButton | CXTTabCtrlButton is a stand alone structure class. It is internal used in CXTTabCtrlButtons class.
CXTTabCtrlButtons | CXTTabCtrlButtonsis a CWnd derived class. It is internally used in the CXTTabBase class.
CXTTabExBase | CXTTabExBase is a stand alone base class. It is used to draw an XP style tab control.
CXTTabView | CXTTabView is a multiple inheritance class derived from CCtrlView and CXTTabCtrlBaseEx. CXTTabView can be used to create a view that contains nested views displayed in a tab control. See CXTTabCtrlBaseEx for additional functionality.
CXTTcbItem | CXTTcbItem class is used to maintain information for a particular tab item in a CXTExcelTabCtrl, CXTTabCtrl and CXTTabView object.
CXTThemeManager | CXTThemeManager is standalone class used to manage the visual styles for your application.
CXTThemeManagerStyle | CXTThemeManagerStyle is standalone class used as base for any components theme.
CXTThemeManagerStyleFactory | CXTThemeManagerStyleFactory is CObject derived class. It managed themes of corresponded CXTThemeManagerStyleHost class
CXTThemeManagerStyleHost | CXTThemeManagerStyleHost is standalone class. It used as base class for all themed component.
CXTTimeEdit | CXTTimeEdit is a CXTDateEdit derived class. It is specifically geared toward editing time fields.
CXTTipOfTheDay | CXTTipOfTheDay is a CDialog derived class. CXTTipOfTheDay is used to create a Visual Studio(tm) style Tip Of The Day dialog. To use, place a file called "tips.txt" in the same directory as your application exe. Place each tip on its own line.
CXTTipWindow | CXTTipWindow is a CWnd derived class. It is used to create a CXTTipWindow object. CXTTipWindow objects are tooltip style popup windows that can display useful information to the end user. Possible options include shadows, borders, and background color settings.
CXTToolbarButtonTheme | CXTToolbarButtonTheme is a CXTDisabledButtonTheme derived class that is used to draw Windows XP style toolbar theme for the button.
CXTToolBox | CXTToolBox is a CXTOutBarCtrl derived class. It is used to create a toolbox control similar to the toolbox control seen in VisualStudio.NET.
CXTTrayIcon | CXTTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure. It is used to display a system tray icon with animation.
CXTTreeBase | CXTTreeBase is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.
CXTTreeCtrl | CXTTreeCtrl is a CTreeCtrl derived class. It extends the CTreeCtrl class to add additional functionality, including tree traversal, searching, color, and settings.
CXTTreeView | CXTTreeView is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.
CXTWindowList | CXTWindowList dialog
CXTWindowPos | CXTWindowPos is a WINDOWPLACEMENT structure derived class. It extends the WINDOWPLACEMENT structure, and is used to save and restore window position.
Files
File | Description
XTAnimationMemDC.h | XTAnimationMemDC.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTBrowseDialog.h | XTBrowseDialog.h: interface for the CXTBrowseDialog class.
XTBrowseEdit.h | XTBrowseEdit.h : interface for the CXTBrowseEdit class.
XTButton.h | XTButton.h : interface for the CXTButton class.
XTButtonTheme.h | XTButtonTheme.h: interface for the CXTButtonTheme class.
XTCaption.h | XTCaption.h : interface for the CXTCaption class.
XTCaptionPopupWnd.h | XTCaptionPopupWnd.h : interface for the CXTCaptionPopupWnd class.
XTCaptionTheme.h | XTCaptionTheme.h: interface for the CXTCaptionTheme class.
XTCheckListBox.h | XTCheckListBox.h : interface for the CXTCheckListBox class.
XTColorDialog.h | XTColorDialog.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPageCustom.h | XTColorPageCustom.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPageStandard.h | XTColorPageStandard.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPicker.h | XTColorPicker.h : interface for the CXTColorPicker class.
XTColorPopup.h | XTColorPopup.h : interface for the CXTColorPopup class.
XTColorRef.h | XTColorRef.h: interface for the CXTColorRef class.
XTColorSelectorCtrl.h | XTColorSelectorCtrl.h : interface for the CXTColorSelectorCtrl class.
XTComboBoxEx.h | XTComboBoxEx.h : interface for the CXTComboBoxEx class.
XTDateTimeCtrl.h | XTDateTimeCtrl.h interface for the CXTDateTimeCtrl class.
XTDefines.h | XTDefines.h interface for the CXTAuxData struct.
XTDirWatcher.h | XTDirWatcher.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTDropSource.h | XTDropSource.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTEditListBox.h | XTEditListBox.h interface for the CXTEditListBox class.
XTExcelTabCtrl.h | XTExcelTabCtrl.h interface for the CXTExcelTabCtrl class.
XTExcelTabCtrlTheme.h | XTExcelTabCtrlTheme.h: interface for the CXTExcelTabCtrlTheme class.
XTFlatComboBox.h | XTFlatComboBox.h interface for the CXTFlatComboBox class.
XTFlatControlsTheme.h | XTFlatControlsTheme.h: interface for the CXTFlatComboBoxTheme class.
XTFontCombo.h | XTFontCombo.h interface for the CXTFontCombo class.
XTFunctions.h | XTFunctions.h : global functions.
XTGlobal.h | XTGlobal.h interface for the CXTAuxData struct.
XTHeaderCtrl.h | XTHeaderCtrl.h interface for the CXTFlatHeaderCtrl class.
XTHeaderCtrlTheme.h | XTHeaderCtrlTheme.h: interface for the CXTHeaderCtrlTheme class.
XTHelpers.h | XTHelpers.h interface This file is a part of the XTREME CONTROLS MFC class library.
XTHexEdit.h | XTHexEdit.h interface for the CXTHexEdit class.
XTHtmlView.h | XTHtmlView.h interface for the CXTHtmlView class.
XTHyperLink.h | XTHyperLink.h interface for the CXTHyperLink class.
XTListBase.h | XTListBase.h interface for the CXTListCtrl class.
XTListBox.h | XTListBox.h interface for the CXTListBox class.
XTListCtrlView.h | XTListCtrlView.h interface for the CXTListView and CXTListCtrlView class.
XTMaskEdit.h | XTMaskEdit.h interface for the CXTMaskEdit class.
XTMDIWndTab.h | XTMDIWndTab.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTMemDC.h | XTMemDC.h interface for the CXTMemDC class.
XTMemFile.h | XTMemFile.h interface for the CXTMemFile class.
XTMenuListBox.h | XTMenuListBox.h interface for the CXTMenuListBox class.
XTMenuListBoxTheme.h | XTMenuListBoxTheme.h: interface for the CXTMenuListBoxTheme class.
XTNotify.h | XTNotify.h : notification handlers This file is a part of the XTREME CONTROLS MFC class library.
XTOutBarCtrl.h | XTOutBarCtrl.h interface for the CXTOutBarCtrl class.
XTOutBarCtrlTheme.h | XTOutBarCtrlTheme.h: interface for the CXTOutBarCtrlTheme class.
XTPagerCtrl.h | XTPagerCtrl.h interface for the CXTPagerCtrl class.
XTPPopupControl.h | XTPPopupControl.h: interface for the CXTPPopupControl class.
XTPPopupItem.h | XTPPopupItem.h: interface for the CXTPPopupItem class.
XTPPopupPaintManager.h | XTPPopupPaintManager.h: interface for the CXTPPopupPaintManager class.
XTPPropertyPage.h | XTPPropertyPage.h : interface for the CXTPPropertyPage class.
XTPPropertyPageNavigator.h | XTPPropertyPageNavigator.h : interface for the CXTPPropertyPageNavigator class.
XTPPropertySheet.h | XTPPropertySheet.h : interface for the CXTPPropertySheet class.
XTPTaskDialog.h | XTPTaskDialog.h: interface for the CXTPTaskDialog class.
XTRegistryManager.h | XTRegistryManager.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTResize.h | XTResize.h: interface for the CXTResize class.
XTResizeDialog.h | XTResizeDialog.h: interface for the CXTResizeDialog class.
XTResizeFormView.h | XTResizeFormView.h: interface for the CXTResizeFormView class.
XTResizeGroupBox.h | XTResizeGroupBox.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTResizePoint.h | XTResizePoint.h: interface for the CXTResizePoint class.
XTResizePropertyPage.h | XTResizePropertyPage.h: interface for the CXTResizePropertyPage class.
XTResizePropertySheet.h | XTResizePropertySheet.h: interface for the CXTResizePropertySheet class.
XTResizeRect.h | XTResizeRect.h: interface for the CXTResizeRect class.
XTSearchOptionsCtrl.h | XTSearchOptionsCtrl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellListBase.h | XTShellListBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellListCtrlView.h | XTShellListCtrlView.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellPidl.h | XTShellPidl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellSettings.h | XTShellSettings.h: interface for the CXTShellSettings class.
XTShellTreeBase.h | XTShellTreeBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellTreeCtrlView.h | XTShellTreeCtrl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTSortClass.h | XTSortClass.h interface for the CXTSortClass class.
XTSplitterWnd.h | XTSplitterWnd.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTSplitterWndTheme.h | XTSplitterWndTheme.h: interface for the CXTSplitterWndTheme class.
XTTabBase.h | XTTabBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTTabBaseTheme.h | XTTabBaseTheme.h: interface for the CXTTabBaseTheme class.
XTTabCtrl.h | XTTabCtrl.h interface for the CXTTabCtrl class.
XTTabCtrlButtons.h | XTTabCtrlbuttons.h : interface for the CXTTabCtrlbuttons class.
XTTabView.h | XTTabView.h interface for the CXTTabView class.
XTThemeManager.h | XTThemeManager.h: interface for the CXTThemeManager class.
XTTipOfTheDay.h | XTTipOfTheDay.h interface for the CXTTipOfTheDay class.
XTTipWindow.h | XTTipWindow.h interface for the CXTTipWindow class.
XTTrayIcon.h | XTTrayIcon.h: interface for the CXTTrayIcon class.
XTTreeBase.h | XTTreeBase.h interface for the CXTTreeBase class.
XTTreeCtrlView.h | XTTreeView.h interface for the CXTTreeView class.
XTUtil.h | XTUtil.h: interface for utility classes.
XTVC50Helpers.h | XTVC50Helpers.h : Visual C++ 5.0 helpers This file is a part of the XTREME CONTROLS MFC class library.
XTWindowList.h | XTWindowList.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTWindowPos.h | XTWindowPos.h interface for the CXTWindowPos class.
Functions
Function | Description
DDV_XTMinMaxDateTime | Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxDateTime | Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxMonth | Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxMonth | Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDX_XTColorPicker | The DDX_XTColorPicker function manages the transfer of integer data between a color picker control in a dialog box, form view, or control view object and a COLORREF data member of the dialog box, form view, or control view object. When DDX_XTColorPicker is called, 'value' is set to the current state of the color picker control.
DDX_XTDateTimeCtrl | The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object and a COleDateTime data member of the dialog box or form view object. When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.
DDX_XTDateTimeCtrl | The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object, and a CTime data member of the dialog box or form view object. When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.
DDX_XTMonthCalCtrl | The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl) in a dialog box, form view, or control view object, and a COleDateTime data member, of the dialog box, form view, or control view object. The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel. When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.
DDX_XTMonthCalCtrl | The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl), in a dialog box, form view, or control view object, and a CTime data member of the dialog box, form view, or control view object. The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel. When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.
DDX_XTOleDateTime | The DDX_XTOleDateTime function manages the transfer of integer data between a date edit control, in a dialog box, form view, or control view object, and a COleDateTime data member of the dialog box, form view, or control view object. When DDX_XTOleDateTime is called, 'value' is set to the current state of the date edit control.
XTAuxData | The XTAuxData function is used for access to the CXTAuxData class.
XTFuncChangeWindowFont | The XTFuncChangeWindowFont function will set the font for the window specified by pWnd and all of the child windows owned by pWnd.
XTFuncChildWindowFromPoint | The XTFuncChildWindowFromPoint function will retrieve an HWND handle for the child window (if any) located directly under the cursor position specified by point.
XTFuncContextMenu | Call this member function to display a context menu that is compatible with both pro and standard versions.
XTFuncCreateView | Creates a view based on a CRuntimeClass object.
XTFuncDrawEmbossed | The XTFuncDrawEmbossed function will draw an embossed icon onto the specified device context from the image list imageList. It is typically used by toolbars and menus to draw a disabled icon in color.
XTFuncDrawShadedRect | Renders a shadow onto the specified device context.
XTFuncInitDLL | This member function will initialize the resources for the Xtreme Toolkit. If using the Xtreme Toolkit as an extension DLL within a regular DLL, add the following two lines to your stdafx.h file. This will give you access to the exported function InitXtremeExtDll():
XTFuncPathExists | The XTFuncPathExists function searches a directory for a file or subdirectory whose name matches the specified name.
XTThemeManager | The XTThemeManager function is used for access to the CXTThemeManager class.
Macros
Macro | Description
BTNS_WHOLEDROPDOWN | draw dropdown arrow, but without split arrow section
CXTHeaderCtrlHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CHeaderCtrl.
CXTListCtrlHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CListCtrl.
CXTStringHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CString.
DECLARE_THEME_FACTORY | Use this macro to declare the factory class for specified theme
DECLATE_SHELLTREE_BASE | The DELCLATE_SHELLTREE_BASE class is a template class used by the CXTShellTreeView and CXTShellTreeCtrl class to declare a multiple inheritance base class so that both classes could share a common code base.
IMPLEMENT_THEME_FACTORY | Use this macro to implement factory class for specified theme.
ON_BEN_XT_LABELEDITCANCEL | BEN_XT_LABELEDITCANCEL notification message handler.
ON_BEN_XT_LABELEDITEND | BEN_XT_LABELEDITEND notification message handler.
ON_CPN_XT_CLOSEUP | CPN_XT_CLOSEUP notification message handler.
ON_CPN_XT_DROPDOWN | CPN_XT_DROPDOWN notification message handler.
ON_CPN_XT_SELCHANGE | CPN_XT_SELCHANGE notification message handler.
ON_CPN_XT_SELENDCANCEL | CPN_XT_SELENDCANCEL notification message handler.
ON_CPN_XT_SELENDOK | CPN_XT_SELENDOK notification message handler.
ON_CPN_XT_SELNOFILL | CPN_XT_SELNOFILL notification message handler.
ON_LBN_XT_DELETEITEM | LBN_XT_DELETEITEM notification message handler.
ON_LBN_XT_LABELEDITCANCEL | LBN_XT_LABELEDITCANCEL notification message handler.
ON_LBN_XT_LABELEDITEND | LBN_XT_LABELEDITEND notification message handler.
ON_LBN_XT_MOVEITEMDOWN | LBN_XT_MOVEITEMDOWN notification message handler.
ON_LBN_XT_MOVEITEMUP | LBN_XT_MOVEITEMUP notification message handler.
ON_LBN_XT_NEWITEM | LBN_XT_NEWITEM notification message handler.
ON_LBN_XT_ONBROWSE |
ON_LBN_XT_PREDELETEITEM | LBN_XT_PREDELETEITEM notification message handler.
ON_LBN_XT_PRENEWITEM | LBN_XT_PRENEWITEM notification message handler.
ON_SON_XT_ITEMCONTRACT | SON_XT_ITEMCONTRACT notification message handler.
ON_SON_XT_ITEMCONTRACTING | SON_XT_ITEMCONTRACTING notification message handler.
ON_SON_XT_ITEMEXPAND | SON_XT_ITEMEXPAND notification message handler.
ON_SON_XT_ITEMEXPANDING | SON_XT_ITEMEXPANDING notification message handler.
SZ_BOTTOM_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_BOTTOM_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_BOTTOM_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_HORREPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_HORRESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_MIDDLE_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_REPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_RESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_TOP_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_VERREPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_VERRESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
XTP_ID_POPUP_CLOSE | Cpecial Id for close item
Structs, Records, Enums
Struct, Record, Enum | Description
XT_LVITEMDATA | XT_LVITEMDATA structure is used to maintain information for a particular list item in a CXTShellListCtrl or CXTShellListView window.
XT_OUTBAR_INFO | XT_OUTBAR_INFO structure is used by by the CXTOutBarCtrl class to store and information for an Outlook bar folder or item.
XT_RESIZEPOINT | XT_RESIZEPOINT structure is used by the CXTResizePoint class for defining single -precision floating point x- and y-coordinates of a point.
XT_RESIZERECT | XT_RESIZERECT structure is used by the CXTResizeRect class for defining single -precision floating point coordinates of the upper-left and lower-right corners of a rectangle.
XT_SIZING |
XT_TVITEMDATA | XT_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTShellTreeCtrl or CXTShellTreeView window.
XTAnimationType | Enumeration used to determine animation style.
XTArrowIcon | Enumeration used to determine arrow button display.
XTFindType | Enumeration used to determine folder or drive type.
XTFontStyle | Enumeration used to determine font display.
XTMouseState | Enumeration to determine mouse state.
XTNavBtnState | Enumeration used to determine navigation button display for a CXTTabCtrl object.
XTP_PICK_BUTTON | XTP_PICK_BUTTON structure is used by the CXTColorSelectorCtrl class to support custom colors.
XTPPopupAnimation | Enumeration used to determine the popup window animation in use
XTPPopupItemIcon | Enumeration used to determine the icon type of CXTPPopupItem.
XTPPopupPaintTheme | Enumeration used to determine the popup window theme in use
XTPPopupState | Enumeration used to determine a current popup window state
XTPPropertyPageBorder | XTPPropertyPageBorder is an enumeration used to set the client frame style drawn around the client of tabs.
XTResize | Enumeration used to determine attributes for resizing windows.
XTSortType | Enumeration used to determine sort type.
XTThemeStyle | Enumeration used to determine active theme.
Types
Type | Description
CXTFontList | List used for enumerating CXTLogFont structures.
XT_RESIZE | The XT_RESIZE data type is defined as a float and is used for storing single-precision floating point x and y window coordinates.
Variables
Variable | Description
BEN_XT_LABELEDITCANCEL | BEN_XT_LABELEDITCANCEL notification message handler.
BEN_XT_LABELEDITEND | BEN_XT_LABELEDITEND notification message handler.
BES_XT_BROWSE | Display a user defined dialog for browsing
BES_XT_CHOOSEDIR | This member function is called to initialize the browse edit control.
BES_XT_CHOOSEFILE | This member function is called to initialize the browse edit control.
BES_XT_POPUPMENU | This member function is called to initialize the browse edit control.
BS_XT_FLAT | This member function will set the display style for the button.
BS_XT_FLAT_ANY | This member function will set the display style for the button.
BS_XT_HILITEPRESSED | This member function will set the display style for the button.
BS_XT_SEMIFLAT | This member function will set the display style for the button.
BS_XT_SHOWFOCUS | This member function will set the display style for the button.
BS_XT_TWOROWS | This member function will set the display style for the button.
BS_XT_WINXP_COMPAT | This member function will set the display style for the button.
BS_XT_XPFLAT | This member function will set the display style for the button.
CBRN_XT_DROPDOWN | The CBRN_XT_DROPDOWN message is sent to the CXTToolBar window whenever a dropdown event occurs in the CXTToolBar.
CPN_XT_CLOSEUP | CPN_XT_CLOSEUP notification message handler.
CPN_XT_DROPDOWN | CPN_XT_DROPDOWN notification message handler.
CPN_XT_SELCHANGE | CPN_XT_SELCHANGE notification message handler.
CPN_XT_SELENDCANCEL | CPN_XT_SELENDCANCEL notification message handler.
CPN_XT_SELENDOK | CPN_XT_SELENDOK notification message handler.
CPN_XT_SELNOFILL | CPN_XT_SELNOFILL notification message handler.
CPS_XT_EXTENDED | This member function handles the creation of the color popup window.
CPS_XT_MORECOLORS | This member function handles the creation of the color popup window.
CPS_XT_NOAUTOMATIC | This member function handles the creation of the color popup window.
CPS_XT_NOFILL | This member function handles the creation of the color popup window.
CPS_XT_RIGHTALIGN | This member function handles the creation of the color popup window.
CPS_XT_SHOW3DSELECTION | Constructs a CXTColorDialog object
CPS_XT_SHOWHEXVALUE | Constructs a CXTColorDialog object
CPS_XT_USERCOLORS | This member function handles the creation of the color popup window.
CPWN_XT_PUSHPINBUTTON | The CPWN_XT_PUSHPINBUTTON message is sent to the owner of a CXTCaptionPopupWnd whenever the push pin button selection has been made.
CPWN_XT_PUSHPINCANCEL | The CPWN_XT_PUSHPINCANCEL message is sent to the owner of a CXTCaptionPopupWnd whenever the push pin button selection has been canceled.
CPWS_EX_CLOSEBUTTON | Creates and initializes the child window associated with the CXTCaption object.
CPWS_EX_GROOVE_EDGE | Creates and initializes the child window associated with the CXTCaption object.
CPWS_EX_RAISED_EDGE | Creates and initializes the child window associated with the CXTCaption object.
FTS_XT_BOTTOM | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_DEFAULT | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HASARROWS | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HASHOMEEND | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HSCROLL | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_MASK | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_TOOLTIPS | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
LBN_XT_DELETEITEM | LBN_XT_DELETEITEM notification message handler.
LBN_XT_LABELEDITCANCEL | LBN_XT_LABELEDITCANCEL notification message handler.
LBN_XT_LABELEDITEND | LBN_XT_LABELEDITEND notification message handler.
LBN_XT_MOVEITEMDOWN | LBN_XT_MOVEITEMDOWN notification message handler.
LBN_XT_MOVEITEMUP | LBN_XT_MOVEITEMUP notification message handler.
LBN_XT_NEWITEM | LBN_XT_NEWITEM notification message handler.
LBN_XT_PREDELETEITEM | LBN_XT_PREDELETEITEM notification message handler.
LBN_XT_PRENEWITEM | LBN_XT_PRENEWITEM notification message handler.
LBS_XT_BROWSE | Browse button
LBS_XT_BROWSE_ONLY | Browse button
LBS_XT_CHOOSEDIR | Sets the edit style for the edit list box.
LBS_XT_CHOOSEFILE | Sets the edit style for the edit list box.
LBS_XT_DEFAULT | Sets the edit style for the edit list box.
LBS_XT_HIDE_UP_DOWN | Hide Up/Down buttons
LBS_XT_NOTOOLBAR | Sets the edit style for the edit list box.
LBS_XT_ONLY_UP_DOWN | Only Up/Down buttons
OBN_XT_BEGINDRAG | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DELETEFOLDER | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DELETEITEM | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DRAGITEM | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_FOLDERCHANGE | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMCLICK | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMHOVER | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMRCLICK | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ONGROUPENDEDIT | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ONLABELENDEDIT | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBS_XT_ADDGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_ANIMATION | Call this member function to modify an Outlook bar style.
OBS_XT_DEFAULT | Call this member function to modify an Outlook bar style.
OBS_XT_DRAGITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_EDITGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_EDITITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_LARGEICON | Call this member function to modify an Outlook bar style.
OBS_XT_REMOVEGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_REMOVEITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_SELHIGHLIGHT | Call this member function to modify an Outlook bar style.
OBS_XT_SMALLICON | Call this member function to modify an Outlook bar style.
SHN_XT_CONTENTSCHANGED | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_INETFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_NOFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_REFRESHFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_REFRESHTREE | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_SELECTCHILD | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_SHELLMENU | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_TREESELCHANGE | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SON_XT_ITEMCONTRACT | SON_XT_ITEMCONTRACT notification message handler.
SON_XT_ITEMCONTRACTING | SON_XT_ITEMCONTRACTING notification message handler.
SON_XT_ITEMEXPAND | SON_XT_ITEMEXPAND notification message handler.
SON_XT_ITEMEXPANDING | SON_XT_ITEMEXPANDING notification message handler.
TIN_XT_TRAYICON | The TIN_XT_TRAYICON message is sent to the CXTTrayIcon window's owner whenever a mouse event occurs in the CXTTrayIcon.
TVIS_FOCUSED | This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. It sets the state of the item specified by hItem.
TWS_XT_ALPHASHADOW | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
TWS_XT_DROPSHADOW | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
TWS_XT_THICKBORDER | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
XT_SPLIT_DOTTRACKER | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOBORDER | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOFULLDRAG | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOSIZE | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XTP_PCN_ITEMCLICK | XTP_PCN_ITEMCLICK is used to indicate that the user clicked on a popup control item.
XTP_PCN_STATECHANGED | XTP_PCN_STATECHANGED is used to indicate that the state of popup control changed
XTPWM_POPUPCONTROL_NOTIFY | The XTPWM_POPUPCONTROL_NOTIFY message is sent to the CXTPPopupControl owner window whenever an action occurs within the CXTPPopupControl
XTTHEME_HOTTRACKING | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
XTTHEME_SORTARROW | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
XTTHEME_WINXPTHEMES | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
XTWM_ADDREBAR | The XTWM_ADDREBAR message is sent to a window whenever it is added to a CXTReBar control.
XTWM_OUTBAR_NOTIFY | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
XTWM_QUERYHOTSPOT | CXTDockContext sends the XTWM_QUERYHOTSPOT message to a control bar to check if the control bar has a hot spot, a point that must match the position of the cursor.
XTWM_QUERYVISUALIZE | CXTDockContext sends the XTWM_QUERYVISUALIZE message to a control bar to check if the control bar shall be visualized while dragging or just a wire frame shall be rendered.
XTWM_REBAR_SIZECHILD | The XTWM_REBAR_SIZECHILD message is sent when CXTReBar control has resized the band in which the recipient resides.
XTWM_SHELL_NOTIFY | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
XTWM_UPDATECOLOR | The XTWM_UPDATECOLOR message is used to send notification that the color selection has changed.


Standard Controls Hierarchy

Standard Controls
Standard Controls Hierarchy

Module

Standard Controls


Classes

Classes, Legend, Standard Controls, Templates
Classes
Classes
Class | Description
CXTAnimationMemDC | CXTAnimationMemDC is a CXTMemDC derived class. This class can be used to render animation effects for the current device context.
CXTAuxData | CXTAuxData is a stand alone global item data structure class. It is used by the toolkit to initialize and store resource and item data shared by all objects. Items include system colors, icons, fonts and OS flags.
CXTAuxDataTheme | The CXTAuxDataTheme class is used by the CXTAuxData class to provide backward compatibility with older versions that still use bXPMode to provide Office XP theme support.
CXTBrowseButton | CXTBrowseButton is a CXTButton derived class that is used by CXTBrowseEdit to create the browse button that is used to display file dialogs and popup menus.
CXTBrowseDialog | CXTBrowseDialog is derived from the BROWSEINFO structure. It is used to display a directory chooser dialog using shell extensions.
CXTBrowseEdit | CXTBrowseEdit is a CXTEdit derived class. This class also has a push button associated with it. The control can be used to search for directories and files or activate a popup menu.
CXTButton | CXTButton is a CButton derived class. It is used to create flat style and image buttons. This control has several features including flat, semi-flat, and three dimensional borders.
CXTButtonTheme | CXTButtonTheme is used to draw the CXTButton object. All themes used for CXTButton should inherit from this base class.
CXTButtonThemeOffice2003 | CXTButtonThemeOffice2003 is a CXTButtonThemeOfficeXP derived class that is used to draw an Office 2003 style theme for the button.
CXTButtonThemeOfficeXP | CXTButtonThemeOfficeXP is a CXTButtonTheme derived class that is used to draw an Office XP style theme for the button.
CXTCaption | CXTCaption is a CStatic derived class. It is used to create caption or info bars similar to those in Microsoft(r) Outlook.
CXTCaptionButton | CXTCaptionButton is a CXTButton derived class. It is used by the CXTCaption class to activate a CXTCaptionPopupWnd window.
CXTCaptionButtonTheme | CXTCaptionButtonTheme is derived from CXTButtonTheme. This class is used to set the caption for buttons.
CXTCaptionButtonThemeOffice2003 | Class CXTCaptionButtonThemeOffice2003 is a CXTButtonThemeOffice2003 derived class. This class is used to create a button caption that resembles an Office 2003 button caption.
CXTCaptionButtonThemeOfficeXP | Class CXTCaptionButtonThemeOfficeXP is a CXTButtonThemeOfficeXP derived class. This class is used to create a button caption that resembles an Office XP button caption.
CXTCaptionPopupWnd | CXTCaptionPopupWnd is a CWnd derived class. It is used by the CXTCaption class to display a popup child window similar to Outlook(tm).
CXTCaptionTheme | CXTCaptionTheme is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.
CXTCaptionThemeOffice2003 | CXTCaptionThemeOffice2003 is derived from CXTCaptionTheme. It is used to set the caption to the Office 2003 theme.
CXTCaptionThemeOfficeXP | CXTCaptionThemeOfficeXP is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.
CXTCheckListBox | The CXTCheckListBox class is a CXTListBox derived class. It provides the functionality of Office style checklist box. A "checklist box" displays a list of items such as filenames. Each item in the list has a check box next to it that the user can either check or clear.
CXTColorBase | CXTColorBase is a CStatic derived base class. It is used to create custom color selection windows.
CXTColorDialog | CXTColorDialog is a CPropertySheet derived class. It is an Office(tm) style color dialog and can be used as a drop in replacement for the MFC CColorDialog API.
CXTColorHex | CXTColorHex is a CStatic derived class. It displays a color selection grid used by CXTColorPageStandard.
CXTColorLum | CXTColorLum is a CXTColorBase derived class. It is used to create a color luminance selection bar.
CXTColorPageCustom | CXTColorPageCustom is derived from CXTThemePropertyPage. It is used to create a CXTColorPageCustom dialog.
CXTColorPageStandard | CXTColorPageStandard is derived from CXTThemePropertyPage, it is used to create a CXTColorPageStandard dialog.
CXTColorPicker | CXTColorPicker is a CXTButton derived class. It displays a color picker popup window (CXTColorPopup) for Office(tm) style color selection.
CXTColorPopup | CXTColorPopup is a CXTColorSelectorCtrl derived class. It is used to create a CXTColorPopup window that will allow a user to select colors and add custom colors to a color list.
CXTColorRef | CXTColorRef is a stand alone class. It is used to create a CXTColorRef object. This object is used for manipulation of RGB values.
CXTColorSelectorCtrl | CXTColorSelectorCtrl is a CWnd derived class. It is used to create a CXTColorSelectorCtrl control that will allow a user to select colors.
CXTColorSelectorCtrlTheme | CXTColorSelectorCtrlTheme is derived from CXTThemeManagerStyle to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorSelectorCtrlThemeOffice2003 | CXTColorSelectorCtrlThemeOffice2003 is derived from CXTColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorSelectorCtrlThemeOfficeXP | CXTColorSelectorCtrlThemeOfficeXP is derived from CXTColorSelectorCtrlTheme to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorWnd | CXTColorWnd is a CXTColorBase derived class. It is used to create a color selection window.
CXTComboBoxEx | The CXTComboBoxEx class is a CComboBox derived class. It extends the combo box control by providing support for image lists.
CXTContextBkColorHandler | Background color context handler
CXTContextBkModeHandler | Background mode context handler
CXTContextTextColorHandler | Text color context handler
CXTContextViewPortOrgHandler | Handles viewport origin
CXTDateEdit | CXTDateEdit is a CXTMaskEdit derived class. It is specifically geared toward editing date fields.
CXTDateTimeCtrl | CXTDateTimeCtrl is a CWnd derived class. A CXTDateTimeCtrl object encapsulates the functionality of a date and time picker control.
CXTDirWatcher | The CXTDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur.
CXTDisabledButtonTheme | CXTDisabledButtonTheme is a CXTButtonTheme derived class that is used to draw 3D disabled icons for the button.
CXTDropSource | CXTDropSource class is derived from IDropSource. It is used by the shell list control to provide drag-and-drop operations in your application.
CXTEdit | CXTEdit is a CEdit derived class. The CXTEdit class provides the functionality of a Windows edit control. An edit control is a rectangular child window in which the user can enter text.
CXTEditListBox | CXTEditListBox is a CXTListBox derived class. It is used to create an editable list box. This list box can be configured to display a toolbar for editing. You can define browse styles to search for files or folders. Each entry is made editable with a double mouse click.
CXTEditListBoxToolBar | CXTEditListBoxToolBar is a CStatic derived class. It used by the CXTEditListBox class to create a toolbar above the edit list box to display icons for editing.
CXTExcelTabCtrl | CXTExcelTabCtrl is a CWnd derived class. It is used to create an Excel style sheet control. This control allows you to define if you want the control to have home, end, back, and next buttons.
CXTExcelTabCtrlButtonState | The CXTExcelTabCtrlButtonState class is used by the CXTExcelTabCtrl class to manage navigation button information. This class contains information about the state and command identifiers for the button.
CXTExcelTabCtrlTheme | CXTExcelTabCtrlTheme is used to draw the CXTExcelTabCtrl object. All themes used for CXTExcelTabCtrl should inherit from this base class.
CXTExcelTabCtrlThemeOffice2003 | CXTExcelTabCtrlThemeOffice2003 is used to draw the CXTExcelTabCtrl object.
CXTExcelTabCtrlThemeOfficeXP | CXTExcelTabCtrlThemeOfficeXP is used to draw the CXTExcelTabCtrl object.
CXTFlatComboBox | CXTFlatComboBox is a CComboBox derived class. The CXTFlatComboBox class can easily give your application's standard CComboBox control the Flat Look that is seen in many of the Microsoft(r) Office(tm) products.
CXTFlatComboBoxTheme | CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.
CXTFlatComboBoxThemeOffice2003 | CXTFlatComboBoxThemeOffice2003 class is derived from CXTFlatComboBoxThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.
CXTFlatComboBoxThemeOfficeXP | CXTFlatComboBoxThemeOfficeXP class is derived from CXTFlatComboBoxTheme. This class is used to create the Office 2000 Theme for flat controls.
CXTFlatEdit | CXTFlatEdit is a CXTEdit derived class. The CXTFlatEdit class can easily give your application's standard CEdit control the flat look that is seen in many of the Microsoft(r) Office(tm) products.
CXTFlatEditTheme | CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.
CXTFlatEditThemeOffice2003 | CXTFlatEditThemeOffice2003 class is derived from CXTFlatEditThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.
CXTFlatEditThemeOfficeXP | CXTFlatEditThemeOfficeXP class is derived from CXTFlatEditTheme. This class is used to create the Office 2000 Theme for flat controls.
CXTFlatHeaderCtrl | CXTFlatHeaderCtrl is a CHeaderCtrl derived class. It is used to create list box flat header controls that are similar to list box flat header controls seen in Visual Studio(tm) and Outlook(tm).
CXTFontCombo | CXTFontCombo is a CXTFlatComboBox derived class. It is used to create a combo box that displays a drop list of available fonts for your system. The fonts are displayed in their various styles.
CXTFontEnum | CXTFontEnum is a stand alone singleton font enumeration class. It is used to enumerate a list of fonts found installed for the operating system.
CXTFontListBox | CXTFontListBox is a CXTListBox derived class. It is used to create a font selection list box.
CXTHeaderCtrl | CXTHeaderCtrl is a CHeaderCtrl derived class. It is used to create a CXTHeaderCtrl window similar to CHeaderCtrl, but with additional functionality.
CXTHeaderCtrlTheme | CXTHeaderCtrlTheme is a theme class used to draw windows classic style theme for the header control.
CXTHeaderCtrlThemeExplorer | CXTHeaderCtrlThemeExplorer is a CXTHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control.
CXTHeaderCtrlThemeOffice2003 | CXTHeaderCtrlThemeOffice2003 is a CXTHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control.
CXTHeaderCtrlThemeOfficeXP | CXTHeaderCtrlThemeOfficeXP is a CXTHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control.
CXTHexEdit | CXTHexEdit is a CEdit derived class. It is used to create an edit control which will allow editing in hex display format.
CXTHtmlView | CXTHtmlView is a CFormView derived class. The CXTHtmlView class provides the functionality of the WebBrowser control within the context of MFC's document/view architecture. The WebBrowser control is a window in which the user can browse sites on the World Wide Web as well as folders in the local file system and on a network. The WebBrowser control supports hyperlinking, Uniform Resource Locator (URL) navigation, and maintains a history list.
CXTHyperLink | CXTHyperLink is a CStatic derived class. It is used to display a text string that is used as a hyperlink control. The link's active, hover, and selected color attributes are configurable.
CXTIconHandle | CXTIconHandle is a stand alone helper class. It is used to automatically destroy dynamically created hIcon handles.
CXTItemEdit | CXTItemEdit is a CXTBrowseEdit derived class. It is used to create a CXTItemEdit window that can be used as an "in-place" edit field that can be dynamically created for controls such as a list box.
CXTListBase | CXTListBase is a non-inherited class. It implements the extended list control services provided by the Xtreme Toolkit list control classes.
CXTListBox | CXTListBox is a CListBox derived class. CXTListBox extends the standard list box control to enable flicker free drawing.
CXTListCtrl | CXTListCtrl is a multiple inheritance class derived from CListCtrl and CXTListBase. This class implements flat header and generic sorting routines. See CXTListBase for additional functionality.
CXTListView | CXTListView is a multiple inheritance class derived from CListView and CXTListBase. This class implements flat header and generic sorting routines.
CXTListViewHelper | The CXTListViewHelper class is a helper class that provides helper functions for finding selected items for the MFC CListView class.
CXTLogFont | CXTLogFont is a self initializing LOGFONT derived class. It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.
CXTMaskEdit | CXTMaskEdit is a CEdit derived class. It allows text masking to be applied to the control to format it for special editing restrictions.
CXTMDIClientWnd | CXTMDIClientWnd is a CWnd derived helper class for the CXTMDIWndTab tab control. This class routes messages sent to the client window back to the tab control.
CXTMDIWndTab | CXTMDIWndTab class is used for creating a tabbed MDI document interface.
CXTMemDC | CXTMemDC is a CDC derived class. CXTMemDC is an extension of CDC that helps eliminate screen flicker when windows are resized, by painting to an off screen bitmap. The class then uses CDC::BitBlt to copy the bitmap back into the current device context after all items have been painted.
CXTMemFile | CXTMemFile is a CMemFile derived class. It is used to create a CXTMemFile object to support memory files.
CXTMenuListBox | CCXTMenuListBox is a CListBox derived class. It is used to implement an Outlook bar style control. It can only be used with the LBS_OWNERDRAWVARIABLE style bit set. This is a simpler version of CXTOutBarCtrl and does not allow for shortcut folders.
CXTMenuListBoxTheme | CXTMenuListBoxTheme is used to draw the CXTMenuListBox object. All themes used for CXTButton should inherit from this base class.
CXTMenuListBoxThemeOffice2003 | Class CXTMenuListBoxThemeOffice2003 is derived from CXTMenuListBoxThemeXP. This class is used to implement the Office 2003 theme for Menu List Boxes.
CXTMenuListBoxThemeOfficeXP | Class CXTMenuListBoxThemeOfficeXP is derived from CXTMenuListBoxTheme. This class is used to implement the Office XP theme for Menu List Boxes.
CXTMonthCalCtrl | CXTMonthCalCtrl is a CWnd derived class. A CXTMonthCalCtrl object encapsulates the functionality of a month calendar control.
CXTNonClientMetrics | CXTNonClientMetrics is a self initializing NONCLIENTMETRICS derived class. It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.
CXTOutBarCtrl | CXTOutBarCtrl is a CWnd derived class. It is used to create a shortcut bar window similar to the shortcut bar seen in Outlook(tm).
CXTOutBarCtrlTheme | CXTOutBarCtrlTheme is used to draw the CXTOutBarCtrl object. All themes used for CXTOutBarCtrl should inherit from this base class.
CXTOutBarCtrlThemeOffice2003 | Class CXTOutBarCtrlThemeOffice2003 is derived form CXTOutBarCtrlThemeXP. This class is used to draw an OutBar with the Office XP theme.
CXTOutBarCtrlThemeOfficeXP | Class CXTOutBarCtrlThemeOfficeXP is derived form CXTOutBarCtrlTheme. This class is used to draw an OutBar with the Office XP theme.
CXTOutBarEditItem | CXTOutBarEditItem is a helper class derived from CXTEdit. It is used by CXTOutBarCtrl, an Outlook like control, to create an in-place edit box that is used to modify a folder or an item within the control.
CXTOutBarFolder | CXTOutBarFolder is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder specified in the Outlook bar control.
CXTOutBarItem | CXTOutBarItem is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder item specified in the Outlook bar control.
CXTPagerCtrl | CXTPagerCtrl is a CWnd derived class. It is used to contain and scroll another window, and wraps the windows pager API.
CXTPPopupControl | CXTPPopupControl is a class for control of popup window
CXTPPopupItem | CXTPPopupItem is a class used to management popup item object
CXTPPopupPaintManager | CXTPPopupPaintManager is a class used to perform specialized drawing tasks.
CXTPPopupThemeMSN | CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks.
CXTPPopupThemeOffice2000 | CXTPPopupThemeOffice2000 is a class used to perform Office2000 drawing tasks.
CXTPPopupThemeOffice2003 | CXTPPopupThemeOffice2003 is a class used to perform Office2003 drawing tasks.
CXTPPopupThemeOffice2007 | CXTPPopupThemeOffice2007 is a class used to perform Office2007 drawing tasks.
CXTPPopupThemeOfficeXP | CXTPPopupThemeOfficeXP is a class used to perform OfficeXP drawing tasks.
CXTPPropertyPage | CXTPPropertyPage is a CPropertyPage derived class Objects of class CPropertyPage represent individual pages of a property sheet
CXTPPropertyPageControlNavigator | CXTPPropertyPageControlNavigator is CXTPPropertyPageNavigator derived class It represents base control property page navigator
CXTPPropertyPageListNavigator | CXTPPropertyPageListNavigator is CXTListBox and CXTPPropertyPageControlNavigator derived class It represents list property page navigator
CXTPPropertyPageNavigator | CXTPPropertyPageNavigator is a standalone class CXTPPropertyPageNavigator represents base navigator object for CXTPPropertySheet
CXTPPropertyPageTabNavigator | CXTPPropertyPageTabNavigator is CXTPTabControl and CXTPPropertyPageNavigator derived class It represents tabbed property page navigator
CXTPPropertyPageTreeNavigator | CXTPPropertyPageTreeNavigator is CTreeCtrl and CXTPPropertyPageControlNavigator derived class It represents tree property page navigator
CXTPPropertySheet | CXTPPropertySheet is a CDialog derived class It represents property sheet, otherwise known as tab dialog box. A property sheet consists of a CXTPPropertySheet object and one or more CXTPPropertyPage objects.
CXTPTaskDialog | The CXTPTaskDialog class creates, displays, and operates a task dialog. A task dialog is similar to, while much more flexible than, a basic message box. The task dialog contains application-defined messages, title, verification check box, command links and push buttons, plus any combination of predefined icons and push buttons.
CXTRegistryManager | CXTRegistryManager is a stand alone registry management class. You can use it to read and write values from your system's registry or an .INI file. Use CXTRegistryManager to read and write string, integer, and binary data to and from the registry. You can also specify an .INI file name, and have these values stored there instead.
CXTResize | CXTResize is a base class. It is used by resizing dialogs, property sheets, and form views. It acts as a manager to maintain size and location of the dialog and dialog items.
CXTResizeDialog | CXTResizeDialog is a multiple inheritance class derived from CDialog and CXTResize. CXTResizeDialog is used to create a resizable CDialog type object that allows its dialog items to be resized or moved dynamically.
CXTResizeFormView | CXTResizeFormView is a multiple inheritance class derived from CFormView and CXTResize. CXTResizeFormView is used to create a resizable CFormView type object that allows its form items to be resized or moved dynamically.
CXTResizeGroupBox | CXTResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing. This class is intended to only be used as a group box and only used on a CXTResize window. You can subclass or create this object the way you would any CButton.
CXTResizeItem | CXTResizeItem is a stand alone helper class. It is used by CXTResize to maintain information about each item to be sized or moved.
CXTResizePoint | CXTResizePoint is an XT_RESIZEPOINT structure derived class. The CXTResizePoint class is similar to the XT_RESIZEPOINT structure. It also includes member functions to manipulate CXTResizePoint and XT_RESIZEPOINT structures. A CXTResizePoint object can be used wherever an XT_RESIZEPOINT structure is used.
CXTResizePropertyPage | CXTResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTResize. CXTResizePropertyPage is used to create a resizable CPropertyPage type object that allows its dialog items to be resized or moved dynamically.
CXTResizePropertySheet | CXTResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTResize. CXTResizePropertySheet is used to create a resizable CPropertySheet type object that allows its dialog items to be resized or moved dynamically.
CXTResizeRect | CXTResizeRect is an XT_RESIZERECT structure derived class. The CXTResizeRect class is similar to an XT_RESIZERECT structure. CXTResizeRect also includes member functions to manipulate CXTResizeRect objects and XT_RESIZERECT structures.
CXTSearchOptionsCtrl | CXTSearchOptionsCtrl is a CStatic derived class. CXTSearchOptionsCtrl is used to create a control similar to the Search Options item found in the search pane of Windows Explorer as it is seen in Windows 2000 and later. This class allows you to associate a group of controls to be hidden or shown when the item is expanded and contracted and a set of controls that need to move depending on the CXTSearchOptionsCtrl state. Use with CXTSearchOptionsView form view class to create a pane similar to the Windows Explorer search pane. To use the control, define a set of controls that... more
CXTSearchOptionsView | CXTSearchOptionsView is a CFormView derived class. It is to be used with a CXTSearchOptionsCtrl object to paint the background and control background color white. It is also used for resizing and moving children of the form automatically.
CXTShellListBase | CXTShellListBase is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListBase class object.
CXTShellListCtrl | CXTShellListCtrl is a multiple inheritance class derived from CXTListCtrl and CXTShellPidl. It is used to create a CXTShellListCtrl window.
CXTShellListCtrlEx | CXTShellListCtrlEx is a CXTShellListCtrl derived class. It is used to create a stand-alone shell list control that is not dependent on a CXTShellTreeCtrl for initialization. It is used to create a CXTShellListCtrlEx window for displaying the contents of file folders.
CXTShellListView | CXTShellListView is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListView class object.
CXTShellPidl | CXTShellPidl is a stand alone base class. This class is used by the shell tree and list controls to handle PIDL creation and management.
CXTShellSettings | CXTShellSettings is a SHELLFLAGSTATE struct derived class. CXTShellSettings extends the SHELLFLAGSTATE struct for easy access to the shell flag state settings.
CXTShellTreeBase | CXTShellTreeBase is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeBase class object.
CXTShellTreeCtrl | CXTShellTreeCtrl is a multiple inheritance class derived from CXTTreeCtrl and CXTShellPidl. CXTShellTreeCtrl is used to create a tree control that displays an explorer style tree, and can be associated with a combo box and list control.
CXTShellTreeView | CXTShellTreeView is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeView class object.
CXTSizeIcon | The CXTSizeIcon class is a CStatic derived helper class. It is used by CXTResize to display the sizing grip in the lower right corner of a sizing window.
CXTSortClass | CXTSortClass is a stand alone class. This class will sort a list control by a column of text, integer, float or date/time type. It could be easily extended for other data types. To use this class, instantiate a CXTSortClass object, passing in a pointer to the list control as the first argument and the column index as the second argument.
CXTSplitPath | CXTSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension.
CXTSplitterWnd | CXTSplitterWnd is a CSplitterWnd derived class. It adds the ability to hide and show splitter panes based upon its index.
CXTSplitterWndEx | CXTSplitterWndEx is a CXTSplitterWnd derived class. It can be used with the CXTOutBarCtrl to display a gap between the top of the splitter and the toolbar area.
CXTSplitterWndTheme | Class CXTSplitterWndTheme is derived from CXTThemeManagerStyle. This class is used to apply a Theme to splitter windows.
CXTSplitterWndThemeOffice2003 | Class CXTSplitterWndThemeOffice2003 is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.
CXTSplitterWndThemeOfficeXP | Class CXTSplitterWndThemeOfficeXP is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.
CXTTabBase | CXTTabBase is a stand alone base class. It is used to draw an XP style tab control.
CXTTabBaseTheme | CXTTabBaseTheme is used to draw the CXTTabBase object. All themes used for CXTTabBase should inherit from this base class.
CXTTabBaseThemeOffice2003 | Class CXTTabBaseThemeOffice2003 is derived from CXTTabBaseThemeOfficeXP.
CXTTabBaseThemeOfficeXP | Class CXTTabBaseThemeOfficeXP is derived from CXTTabBaseTheme. This class is used to implement the office XP theme for the tab controls.
CXTTabCtrl | CXTTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTTabCtrlBase. It is used to create a CXTTabCtrl class object. See CXTTabCtrlBase for additional functionality.
CXTTabCtrlButton | CXTTabCtrlButton is a stand alone structure class. It is internal used in CXTTabCtrlButtons class.
CXTTabCtrlButtons | CXTTabCtrlButtonsis a CWnd derived class. It is internally used in the CXTTabBase class.
CXTTabExBase | CXTTabExBase is a stand alone base class. It is used to draw an XP style tab control.
CXTTabView | CXTTabView is a multiple inheritance class derived from CCtrlView and CXTTabCtrlBaseEx. CXTTabView can be used to create a view that contains nested views displayed in a tab control. See CXTTabCtrlBaseEx for additional functionality.
CXTTcbItem | CXTTcbItem class is used to maintain information for a particular tab item in a CXTExcelTabCtrl, CXTTabCtrl and CXTTabView object.
CXTThemeManager | CXTThemeManager is standalone class used to manage the visual styles for your application.
CXTThemeManagerStyle | CXTThemeManagerStyle is standalone class used as base for any components theme.
CXTThemeManagerStyleFactory | CXTThemeManagerStyleFactory is CObject derived class. It managed themes of corresponded CXTThemeManagerStyleHost class
CXTThemeManagerStyleHost | CXTThemeManagerStyleHost is standalone class. It used as base class for all themed component.
CXTTimeEdit | CXTTimeEdit is a CXTDateEdit derived class. It is specifically geared toward editing time fields.
CXTTipOfTheDay | CXTTipOfTheDay is a CDialog derived class. CXTTipOfTheDay is used to create a Visual Studio(tm) style Tip Of The Day dialog. To use, place a file called "tips.txt" in the same directory as your application exe. Place each tip on its own line.
CXTTipWindow | CXTTipWindow is a CWnd derived class. It is used to create a CXTTipWindow object. CXTTipWindow objects are tooltip style popup windows that can display useful information to the end user. Possible options include shadows, borders, and background color settings.
CXTToolbarButtonTheme | CXTToolbarButtonTheme is a CXTDisabledButtonTheme derived class that is used to draw Windows XP style toolbar theme for the button.
CXTToolBox | CXTToolBox is a CXTOutBarCtrl derived class. It is used to create a toolbox control similar to the toolbox control seen in VisualStudio.NET.
CXTTrayIcon | CXTTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure. It is used to display a system tray icon with animation.
CXTTreeBase | CXTTreeBase is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.
CXTTreeCtrl | CXTTreeCtrl is a CTreeCtrl derived class. It extends the CTreeCtrl class to add additional functionality, including tree traversal, searching, color, and settings.
CXTTreeView | CXTTreeView is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.
CXTWindowList | CXTWindowList dialog
CXTWindowPos | CXTWindowPos is a WINDOWPLACEMENT structure derived class. It extends the WINDOWPLACEMENT structure, and is used to save and restore window position.
Module

Standard Controls

Templates
Template | Description
CXTContextObjectHandler | Safely selects object into device context
Legend
Template


CXTAnimationMemDC Class

XTAnimationMemDC.h, Classes, Legend, Members, Topics, CXTAnimationMemDC Methods, CXTAnimationMemDC Constructors, CXTAnimationMemDC Destructors, CXTAnimationMemDC Nested Types, CXTAnimationMemDC Constructors, CXTAnimationMemDC Destructors, Example, CXTAnimationMemDC Methods, CXTAnimationMemDC Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTAnimationMemDC Class

CXTAnimationMemDC is a CXTMemDC derived class. This class can be used to render animation effects for the current device context.

Class Hierarchy

class CXTAnimationMemDC : public CXTMemDC;
File

XTAnimationMemDC.h

Remarks

By calling Animate the device context is drawn on the screen with a defined animation type. See XTAnimationType for a list of available animation styles.

Animations are similar to the menu animation effect as seen in Microsoft(r) Windows(r) or Microsoft(r) Office products.

See Also

LPFNANIMATION, XTAnimationType, Animate, SetCustomAnimation

Example

See Animate for an example that demonstrates the use of CXTAnimationMemDC.

Group

Classes

Legend
Method
virtual
CXTAnimationMemDC Constructors
CXTAnimationMemDC Constructors | Description
CXTAnimationMemDC | Constructs a CXTAnimationMemDC object
CXTAnimationMemDC Destructors
CXTAnimationMemDC Destructors | Description
~CXTAnimationMemDC | Destroys a CXTAnimationMemDC object, handles cleanup and deallocation.
CXTAnimationMemDC Methods
CXTAnimationMemDC Methods | Description
Animate | This member function performs the animation
DefaultAnimation | This member implements default animation effects Fade, Slide and Unfold.
SetCustomAnimation | Call this member function to setup new Animation effects.
CXTAnimationMemDC Nested Types
CXTAnimationMemDC Nested Types | Description
LPFNANIMATION | Function pointer used to define a custom animation effect.


CXTAnimationMemDC Methods

CXTAnimationMemDC Class, Legend, Public Methods
CXTAnimationMemDC Methods
Class

CXTAnimationMemDC Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Animate | This member function performs the animation
DefaultAnimation | This member implements default animation effects Fade, Slide and Unfold.
SetCustomAnimation | Call this member function to setup new Animation effects.


CXTAnimationMemDC::Animate Method

CXTAnimationMemDC Methods, CXTAnimationMemDC Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTAnimationMemDC::Animate Method

This member function performs the animation

void Animate(
    int nType = xtWindowsDefault,
    int nSteps = 10,
    int nAnimationTime = 1000
);
Parameters

nType
[in] Type of animation to perform.
nSteps
[in] Number of steps to take during animation.
nAnimationTime
[in] Amount of time to rest, in milliseconds, between each step.

Remarks

Call this member function from your WM_PAINT handler to render the animation background.

See Also

LPFNANIMATION, XTAnimationType, SetCustomAnimation

Example

The following example demonstrates the use of Animate.

void CMainFrame::DoAnimationTest(CDC* pDC, XTAnimationType anim)
{
    CRect r(100, 100, 300, 200);
    CXTMemDC background(pDC, r, (COLORREF)-1);
    background.FromDC();
    {
        CXTAnimationMemDC memDC(pDC, r, NULL);

        r -= r.TopLeft();

        memDC.Rectangle(r);
        memDC.MoveTo(0, 0);
        memDC.LineTo(r.BottomRight());
        memDC.SelectStockObject(GRAY_BRUSH);
        memDC.FloodFill(r.left + 10, r.top + 10, RGB(0, 0, 0));
        memDC.Animate(anim, 10, 1000);
    }

    ::Sleep(2000);
}
Group

CXTAnimationMemDC Methods


CXTAnimationMemDC::DefaultAnimation Method

CXTAnimationMemDC Methods, CXTAnimationMemDC Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTAnimationMemDC::DefaultAnimation Method

This member implements default animation effects Fade, Slide and Unfold.

static void DefaultAnimation(
    CRect rc,
    CDC* pDestDC,
    CDC* pSrcDC,
    int nType,
    int nSteps,
    int nAnimationTime
);
Parameters

rc
[in] Bounding rectangle.
pDestDC
[in] Pointer to device context you must draw to.
pSrcDC
[in] Device context that contains the bitmap you must take.
nType
[in] Type of animation to perform. For custom animation you must use numbers greater than xtNone.
nSteps
[in] Number of steps to take during animation.
nAnimationTime
[in] Amount of time to rest, in milliseconds, between each step.

Remarks

You can add new animation effects to call SetCustomAnimation member.

See Also

LPFNANIMATION, XTAnimationType, Animate, SetCustomAnimation

Example

See SetCustomAnimation for an example that demonstrates the use of DefaultAnimation.

Group

CXTAnimationMemDC Methods


CXTAnimationMemDC::SetCustomAnimation Method

CXTAnimationMemDC Methods, CXTAnimationMemDC Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTAnimationMemDC::SetCustomAnimation Method

Call this member function to setup new Animation effects.

static void SetCustomAnimation(
    LPFNANIMATION pCustom
);
Parameters

pCustom
[in] Function pointer that holds the address of a custom animation function.

Remarks

You can call DefaultAnimation in your custom animation method to handle default animation effects.

See Also

LPFNANIMATION, XTAnimationType, Animate, DefaultAnimation

Example

The following example demonstrates the use of SetCustomAnimation.

int CMainFrame::OnCreate()
{
    // custom animation procedure.
    CXTAnimationMemDC::SetCustomAnimation(CustomAnimation);
    ...
}
...
void CMainFrame::CustomAnimation(CRect rc, CDC* pDestDC,
    CDC* pSrcDC, int nType, int nSteps, int nAnimationTime)
{
    if (nType == xtUnfold)
    {
        // do custom animation
    }
    else
    {
        CXTAnimationMemDC::DefaultAnimation(rc, pDestDC,
            pSrcDC, nType, nSteps, nAnimationTime);
    }
}
Group

CXTAnimationMemDC Methods


CXTAnimationMemDC Constructors

CXTAnimationMemDC Class, Legend, Public Methods
CXTAnimationMemDC Constructors
Class

CXTAnimationMemDC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTAnimationMemDC | Constructs a CXTAnimationMemDC object


CXTAnimationMemDC::CXTAnimationMemDC Constructor

CXTAnimationMemDC Constructors, CXTAnimationMemDC Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTAnimationMemDC::CXTAnimationMemDC Constructor

Constructs a CXTAnimationMemDC object

CXTAnimationMemDC(
    CDC* pDC,
    const CRect& rect,
    COLORREF clrColor = GetSysColor(COLOR_3DFACE)
);
Parameters

pDC
[in] A pointer to a CDC object.
rect
[in] An address of a CRect object.
clrColor
[in] An RGB value that represents the current system face color of three dimensional display elements.

Remarks

Call this member function to construct a CXTAnimationMemDC object using the specified device context.

See Also

LPFNANIMATION, XTAnimationType, Animate, SetCustomAnimation

Example

See Animate for an example that demonstrates the use of CXTAnimationMemDC.

Group

CXTAnimationMemDC Constructors


CXTAnimationMemDC Destructors

CXTAnimationMemDC Class, Legend, Public Methods
CXTAnimationMemDC Destructors
Class

CXTAnimationMemDC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTAnimationMemDC | Destroys a CXTAnimationMemDC object, handles cleanup and deallocation.


CXTAnimationMemDC::~CXTAnimationMemDC Destructor

CXTAnimationMemDC Destructors, CXTAnimationMemDC Class
CXTAnimationMemDC::~CXTAnimationMemDC Destructor

Destroys a CXTAnimationMemDC object, handles cleanup and deallocation.

virtual ~CXTAnimationMemDC();
Group

CXTAnimationMemDC Destructors


CXTAnimationMemDC Nested Types

CXTAnimationMemDC Class, Public Nested Types
CXTAnimationMemDC Nested Types
Class

CXTAnimationMemDC Class

Public Nested Types
Public Nested Type | Description
LPFNANIMATION | Function pointer used to define a custom animation effect.


CXTAnimationMemDC::LPFNANIMATION Nested Type

CXTAnimationMemDC Nested Types, CXTAnimationMemDC Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTAnimationMemDC::LPFNANIMATION Nested Type

Function pointer used to define a custom animation effect.

typedef void (* LPFNANIMATION)(CRect rc, CDC* pDestDC, CDC* pSrcDC, int nType, int nSteps, int nAnimationTime);
Parameters

rc
Area to display.
pDestDC
Destination device context.
pSrcDC
Source device context.
nType
Enumerated XTAnimationType to determine animation effect.
nSteps
Number of steps to complete animation.
nAnimationTime
Amount of time in milliseconds between each step.

See Also

CXTAnimationMemDC::SetCustomAnimation, XTAnimationType

Example

See CXTAnimationMemDC::SetCustomAnimation for an example that demonstrates the use of LPFNANIMATION.

Group

CXTAnimationMemDC Nested Types


CXTAuxData Class

XTGlobal.h, Classes, Legend, Members, Topics, CXTAuxData Methods, CXTAuxData Destructors, CXTAuxData Destructors, CXTAuxData Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTAuxData Class

CXTAuxData is a stand alone global item data structure class. It is used by the toolkit to initialize and store resource and item data shared by all objects. Items include system colors, icons, fonts and OS flags.

Class Hierarchy

class CXTAuxData;
File

XTGlobal.h

Group

Classes

Legend
Method
virtual
CXTAuxData Destructors
CXTAuxData Destructors | Description
~CXTAuxData | Destroys an CXTAuxData object, handles cleanup and deallocation
CXTAuxData Methods
CXTAuxData Methods | Description
CreateSysFont | Initializes fonts used by the library.
FontExists | Determines if a font is installed.
FreeSysFonts | This member function frees font resources.
GetComCtlVersion | This member function is called to retrieve the version information for the common control dll (comctl32.dll).
GetXTVersion | Retrieves the library version.
InitResources | This member function is called by the library to initialize resources.
IsComCtlValid | This member function is called to check the current version of the common control dll (comctl32.dll).
LoadSysCursors | Initializes cursors used by the library.
LoadSysFonts | Initializes fonts used by the library.
SetGlobalFont |
UpdateSysColors | This member function updates system colors used by the library.
UpdateSysMetrics | This member function updates system metrics used by the library.
UseOfficeFont | Enables or Disables Tahoma font usage for the library.


CXTAuxData Methods

CXTAuxData Class, Legend, Public Methods
CXTAuxData Methods
Class

CXTAuxData Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
CreateSysFont | Initializes fonts used by the library.
FontExists | Determines if a font is installed.
FreeSysFonts | This member function frees font resources.
GetComCtlVersion | This member function is called to retrieve the version information for the common control dll (comctl32.dll).
GetXTVersion | Retrieves the library version.
InitResources | This member function is called by the library to initialize resources.
IsComCtlValid | This member function is called to check the current version of the common control dll (comctl32.dll).
LoadSysCursors | Initializes cursors used by the library.
LoadSysFonts | Initializes fonts used by the library.
SetGlobalFont |
UpdateSysColors | This member function updates system colors used by the library.
UpdateSysMetrics | This member function updates system metrics used by the library.
UseOfficeFont | Enables or Disables Tahoma font usage for the library.


CXTAuxData::CreateSysFont Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::CreateSysFont Method

Initializes fonts used by the library.

BOOL CreateSysFont(
    const CXTLogFont& lf,
    CFont& font,
    long lfWeight = -1,
    char lfUnderline = -1,
    long lfOrientation = -1,
    long lfEscapement = -1
);
Parameters

lf
[in] Reference to a CXTLogFont or LOGFONT structure.
font
[in] Reference to a CFont object.
lfWeight
[in] Optional, specifies font weight.
lfUnderline
[in] Optional, specifies font underline.
lfOrientation
[in] Optional, specifies font orientation.
lfEscapement
[in] Optional, specifies font escapement.

Returns

TRUE if the font was successfully created, otherwise FALSE.

Remarks

Call this member function to create a CFont object from an existing CXTLogFont or LOGFONT structure. You can specify additional values to set that will override what is specified in the LOGFONT structure passed in.

Group

CXTAuxData Methods


CXTAuxData::FontExists Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::FontExists Method

Determines if a font is installed.

BOOL FontExists(
    LPCTSTR lpszFaceName
);
Parameters

lpszFaceName
[in] NULL terminated string that represents the font name to search for.

Returns

TRUE if the font is installed, otherwise FALSE.

Remarks

Call this member function to determine if the font specified by strFaceName has been installed on the operating system.

Group

CXTAuxData Methods


CXTAuxData::FreeSysFonts Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::FreeSysFonts Method

This member function frees font resources.

void FreeSysFonts();
Group

CXTAuxData Methods


CXTAuxData::GetComCtlVersion Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::GetComCtlVersion Method

This member function is called to retrieve the version information for the common control dll (comctl32.dll).

DWORD GetComCtlVersion();
Returns

A DWORD value.

Group

CXTAuxData Methods


CXTAuxData::GetXTVersion Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::GetXTVersion Method

Retrieves the library version.

CString GetXTVersion(
    bool bVerNumOnly = false
);
Parameters

bVerNumOnly
[in] true to return the version number only, minus "Xtreme Toolkit v".

Returns

A NULL terminated string that indicates the version of the Xtreme Toolkit.

Remarks

Call this member function to retrieve a CString object that represents the current version of the Xtreme Toolkit. The string returned is formatted like so: "Xtreme Toolkit v1.94".

Group

CXTAuxData Methods


CXTAuxData::InitResources Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::InitResources Method

This member function is called by the library to initialize resources.

void InitResources(
    HINSTANCE hInst
);
Parameters

hInst
Instance handle for resources.

Group

CXTAuxData Methods


CXTAuxData::IsComCtlValid Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::IsComCtlValid Method

This member function is called to check the current version of the common control dll (comctl32.dll).

BOOL IsComCtlValid() const;
Returns

Returns TRUE if the version is 4.72 or higher, otherwise FALSE.

Group

CXTAuxData Methods


CXTAuxData::LoadSysCursors Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::LoadSysCursors Method

Initializes cursors used by the library.

BOOL LoadSysCursors();
Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTAuxData Methods


CXTAuxData::LoadSysFonts Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::LoadSysFonts Method

Initializes fonts used by the library.

BOOL LoadSysFonts(
    LPCTSTR lpszHorzFaceName = NULL,
    LPCTSTR lpszVertFaceName = NULL
);
Parameters

lpszHorzFaceName
[in] Points to a NULL terminated font name that is used to create the horizontal fonts used by the library.
lpszVertFaceName
[in] Points to a NULL terminated font name that is used to create the vertical fonts used by the library.

Returns

TRUE if successful, otherwise returns FALSE if a font fails to load.

Remarks

Call this member function to update all of the fonts used by the library.

Group

CXTAuxData Methods


SetGlobalFont Method

CXTAuxData Methods
SetGlobalFont Method
Overload List
Methods
Method | Description
CXTAuxData::SetGlobalFont (CFont*, CFont*) | Initializes fonts used by the library.
CXTAuxData::SetGlobalFont (LPCTSTR, LPCTSTR) | Initializes fonts used by the library.
Group

CXTAuxData Methods


CXTAuxData::SetGlobalFont Method (CFont*, CFont*)

SetGlobalFont Method, CXTAuxData Class
CXTAuxData::SetGlobalFont Method (CFont*, CFont*)

Initializes fonts used by the library.

BOOL SetGlobalFont(
    CFont* pHorzFont,
    CFont* pVertFont = NULL
);
BOOL SetGlobalFont(
    LPCTSTR lpszFaceName,
    LPCTSTR lpszVertFaceName = NULL
);
Parameters

pHorzFont
[in] Points to a valid CFont object that is used to define the fonts the library will use.
pVertFont
[in] Points to a valid CFont object that is used to define the vertical fonts used by the library. If NULL, 'pFont' will be used.
lpszFaceName
[in] Points to a NULL terminated font name that is used to create the horizontal fonts used by the library.
lpszVertFaceName
[in] Points to a NULL terminated font name that is used to create the vertical fonts used by the library.

Returns

TRUE if successful, otherwise returns FALSE if a font fails to load.

Remarks

Call this member function to update fonts used by the library. This function will not update the fonts used for Icon Title, Marlett Icon or Small Captions. To change these fonts as well use the CreateSysFont method.

Group

SetGlobalFont Method


CXTAuxData::UpdateSysColors Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::UpdateSysColors Method

This member function updates system colors used by the library.

void UpdateSysColors();
Group

CXTAuxData Methods


CXTAuxData::UpdateSysMetrics Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::UpdateSysMetrics Method

This member function updates system metrics used by the library.

void UpdateSysMetrics();
Group

CXTAuxData Methods


CXTAuxData::UseOfficeFont Method

CXTAuxData Methods, CXTAuxData Class
CXTAuxData::UseOfficeFont Method

Enables or Disables Tahoma font usage for the library.

void UseOfficeFont(
    BOOL bOfficeFont
);
Parameters

bOfficeFont
[in] True to use the "Tahoma" font if found on the operating system.

Remarks

Call this member function to use the Office font (Tahoma) if it exists on the operating system.

Group

CXTAuxData Methods


CXTAuxData Destructors

CXTAuxData Class, Legend, Public Methods
CXTAuxData Destructors
Class

CXTAuxData Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTAuxData | Destroys an CXTAuxData object, handles cleanup and deallocation


CXTAuxData::~CXTAuxData Destructor

CXTAuxData Destructors, CXTAuxData Class
CXTAuxData::~CXTAuxData Destructor

Destroys an CXTAuxData object, handles cleanup and deallocation

virtual ~CXTAuxData();
Group

CXTAuxData Destructors


CXTAuxDataTheme Class

XTGlobal.h, Classes, Legend, Members, Topics, CXTAuxDataTheme Operators, CXTAuxDataTheme Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTAuxDataTheme Class

The CXTAuxDataTheme class is used by the CXTAuxData class to provide backward compatibility with older versions that still use bXPMode to provide Office XP theme support.

Class Hierarchy

class CXTAuxDataTheme;
File

XTGlobal.h

Group

Classes

Legend
Operator
CXTAuxDataTheme Operators
CXTAuxDataTheme Operators | Description
= | This operator will toggle the Office XP theme for standard controls.
BOOL | Determines if Office XP themes are enabled for standard common controls.


CXTAuxDataTheme Operators

CXTAuxDataTheme Class, Legend, Public Operators
CXTAuxDataTheme Operators
Class

CXTAuxDataTheme Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This operator will toggle the Office XP theme for standard controls.
BOOL | Determines if Office XP themes are enabled for standard common controls.


CXTAuxDataTheme::= Operator

CXTAuxDataTheme Operators, CXTAuxDataTheme Class
CXTAuxDataTheme::= Operator

This operator will toggle the Office XP theme for standard controls.

BOOL operator =(
    BOOL bXPMode
);
Parameters

bXPMode
[in] TRUE to enable Office XP theme.

Returns

TRUE if Office XP themes are enabled; otherwise FALSE.

Remarks

Use this operator overload to enable or disable Office XP theme support for standard common controls.

Group

CXTAuxDataTheme Operators


CXTAuxDataTheme::BOOL Operator

CXTAuxDataTheme Operators, CXTAuxDataTheme Class
CXTAuxDataTheme::BOOL Operator

Determines if Office XP themes are enabled for standard common controls.

operator BOOL();
Remarks

Returns BOOL (MFC typedef) value. TRUE means that Office XP themes are enabled for standard common controls; FALSE otherwise.

Group

CXTAuxDataTheme Operators


CXTBrowseButton Class

XTBrowseEdit.h, Classes, Legend, Members, Topics, CXTBrowseButton Data Members, CXTBrowseButton Methods, CXTBrowseButton Constructors, CXTBrowseButton Destructors, CXTBrowseButton Constructors, CXTBrowseButton Data Members, CXTBrowseButton Destructors, CXTBrowseButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTBrowseButton Class

CXTBrowseButton is a CXTButton derived class that is used by CXTBrowseEdit to create the browse button that is used to display file dialogs and popup menus.

Class Hierarchy

class CXTBrowseButton : public CXTButton;
File

XTBrowseEdit.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTBrowseButton Constructors
CXTBrowseButton Constructors | Description
CXTBrowseButton | Constructs a CXTBrowseButton object
CXTBrowseButton Data Members
CXTBrowseButton Data Members | Description
m_dwBStyle | Search type
m_hPopupIcon | Popup menu icon.
m_nID | Resource id for push button
m_nMenu | Popup menu id
m_nSubMenuIndx | Index of popup submenu.
m_pEditWnd | Parent edit control.
CXTBrowseButton Destructors
CXTBrowseButton Destructors | Description
~CXTBrowseButton | Destroys a CXTBrowseButton object, handles cleanup and deallocation
CXTBrowseButton Methods
CXTBrowseButton Methods | Description
Create | This member function is called to create the browse button used by the edit control.
SetBrowseStyle | This member function will set the browse style for the button.


CXTBrowseButton Data Members

CXTBrowseButton Class, Legend, Protected Data Members
CXTBrowseButton Data Members
Class

CXTBrowseButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dwBStyle | Search type
m_hPopupIcon | Popup menu icon.
m_nID | Resource id for push button
m_nMenu | Popup menu id
m_nSubMenuIndx | Index of popup submenu.
m_pEditWnd | Parent edit control.


CXTBrowseButton::m_dwBStyle Data Member

CXTBrowseButton Data Members, CXTBrowseButton Class
CXTBrowseButton::m_dwBStyle Data Member

Search type

DWORD m_dwBStyle;
Group

CXTBrowseButton Data Members


CXTBrowseButton::m_hPopupIcon Data Member

CXTBrowseButton Data Members, CXTBrowseButton Class
CXTBrowseButton::m_hPopupIcon Data Member

Popup menu icon.

CXTIconHandle m_hPopupIcon;
Group

CXTBrowseButton Data Members


CXTBrowseButton::m_nID Data Member

CXTBrowseButton Data Members, CXTBrowseButton Class
CXTBrowseButton::m_nID Data Member

Resource id for push button

UINT m_nID;
Group

CXTBrowseButton Data Members


CXTBrowseButton::m_nMenu Data Member

CXTBrowseButton Data Members, CXTBrowseButton Class
CXTBrowseButton::m_nMenu Data Member

Popup menu id

UINT m_nMenu;
Group

CXTBrowseButton Data Members


CXTBrowseButton::m_nSubMenuIndx Data Member

CXTBrowseButton Data Members, CXTBrowseButton Class
CXTBrowseButton::m_nSubMenuIndx Data Member

Index of popup submenu.

UINT m_nSubMenuIndx;
Group

CXTBrowseButton Data Members


CXTBrowseButton::m_pEditWnd Data Member

CXTBrowseButton Data Members, CXTBrowseButton Class
CXTBrowseButton::m_pEditWnd Data Member

Parent edit control.

CXTBrowseEdit* m_pEditWnd;
Group

CXTBrowseButton Data Members


CXTBrowseButton Methods

CXTBrowseButton Class, Legend, Public Methods
CXTBrowseButton Methods
Class

CXTBrowseButton Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Create | This member function is called to create the browse button used by the edit control.
SetBrowseStyle | This member function will set the browse style for the button.


CXTBrowseButton::Create Method

CXTBrowseButton Methods, CXTBrowseButton Class
CXTBrowseButton::Create Method

This member function is called to create the browse button used by the edit control.

virtual BOOL Create(
    CXTBrowseEdit* pEditWnd,
    DWORD dwBStyle,
    UINT nID,
    UINT nMenu = (UINT)-1,
    UINT nSubMenuIndx = (UINT)-1
);
Parameters

pEditWnd
[in] Parent edit control.
dwBStyle
[in] Search type
nID
[in] Resource id for push button
nMenu
[in] Popup menu id
nSubMenuIndx
[in] Index of popup submenu.

Returns

TRUE if successful, otherwise FALSE.

Group

CXTBrowseButton Methods


CXTBrowseButton::SetBrowseStyle Method

CXTBrowseButton Methods, CXTBrowseButton Class, See Also
CXTBrowseButton::SetBrowseStyle Method

This member function will set the browse style for the button.

void SetBrowseStyle(
    DWORD dwxStyle
);
Parameters

dwxStyle
Specifies the browse style. The button style can be defined as one or more of the styles listed in the Remarks section.

Remarks

The CXTBrowseButton can be set to use one or more of the following styles:

  • BES_XT_CHOOSEDIR Display the choose folder dialog.
  • BES_XT_CHOOSEFILE Display the choose file dialog.
  • BES_XT_POPUPMENU Display a user defined context menu.
See Also

SetXButtonStyle

Group

CXTBrowseButton Methods


CXTBrowseButton Constructors

CXTBrowseButton Class, Legend, Public Methods
CXTBrowseButton Constructors
Class

CXTBrowseButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTBrowseButton | Constructs a CXTBrowseButton object


CXTBrowseButton::CXTBrowseButton Constructor

CXTBrowseButton Constructors, CXTBrowseButton Class
CXTBrowseButton::CXTBrowseButton Constructor

Constructs a CXTBrowseButton object

CXTBrowseButton();
Group

CXTBrowseButton Constructors


CXTBrowseButton Destructors

CXTBrowseButton Class, Legend, Public Methods
CXTBrowseButton Destructors
Class

CXTBrowseButton Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTBrowseButton | Destroys a CXTBrowseButton object, handles cleanup and deallocation


CXTBrowseButton::~CXTBrowseButton Destructor

CXTBrowseButton Destructors, CXTBrowseButton Class
CXTBrowseButton::~CXTBrowseButton Destructor

Destroys a CXTBrowseButton object, handles cleanup and deallocation

virtual ~CXTBrowseButton();
Group

CXTBrowseButton Destructors


CXTBrowseDialog Class

XTBrowseDialog.h, Classes, Legend, Members, Topics, CXTBrowseDialog Data Members, CXTBrowseDialog Methods, CXTBrowseDialog Constructors, CXTBrowseDialog Destructors, CXTBrowseDialog Constructors, CXTBrowseDialog Data Members, CXTBrowseDialog Destructors, CXTBrowseDialog Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTBrowseDialog Class

CXTBrowseDialog is derived from the BROWSEINFO structure. It is used to display a directory chooser dialog using shell extensions.

Class Hierarchy

class CXTBrowseDialog : protected BROWSEINFO;
File

XTBrowseDialog.h

Remarks

The CXTBrowseDialog class allows you to configure various options, including setting the dialog's title or assigning a callback function for defining the folder display and file filtering styles.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTBrowseDialog Constructors
CXTBrowseDialog Constructors | Description
CXTBrowseDialog | Constructs a CXTBrowseDialog object
CXTBrowseDialog Data Members
CXTBrowseDialog Data Members | Description
m_szSelPath | NULL terminated string that represents the selected directory
CXTBrowseDialog Destructors
CXTBrowseDialog Destructors | Description
~CXTBrowseDialog | Destroys a CXTBrowseDialog object, handles cleanup and deallocation
CXTBrowseDialog Methods
CXTBrowseDialog Methods | Description
BrowseCtrlCallback | Application defined callback.
DoModal | Call this member function to invoke the browse dialog box and to return the dialog box result when done.
GetCallback | Call this member function to return the address for the BrowseCallbackProc function that is called when an event occurs.
GetData | Returns application data that was set to be passed to the callback function.
GetDisplayName | Call this member function to return the display name that is used by the browse dialog box.
GetImage | Call this member function to get the index to the system image list of the image associated with the selected folder.
GetOptions | Call this member function to return the flags specifying the options that have been set for the dialog box.
GetOwner | Call this member function to get an HWND handle to the owner window for the dialog box.
GetPidlRoot | Call this member function to return the address of the ITEMIDLIST structure that was specified for the location of the root folder.
GetSelPath | Call this member function to get a NULL terminated string that represents the currently selected directory.
GetTitle | Call this member function to return a NULL terminated string that represents the title that was set for the dialog box.
SetCallback | Call this member function to define the address for the BrowseCallbackProc function that is to be called when an event occurs.
SetData | Call this member function to set the application data that is passed to the callback function.
SetDisplayName | Call this member function to set the address for the display name the dialog box will use.
SetOptions | Call this member function to set the flags for specifying the options for the browse dialog box.
SetOwner | Call this member function to set the owner window for the dialog box.
SetPidlRoot | Call this member function to set the address of an ITEMIDLIST structure which specifies the location of the root folder to browse from.
SetSelPath | Call this member function to set the initial path to select when the browse dialog is first opened.
SetTitle | Call this member function to set the title for the browse dialog box.


CXTBrowseDialog Data Members

CXTBrowseDialog Class, Legend, Protected Data Members
CXTBrowseDialog Data Members
Class

CXTBrowseDialog Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_szSelPath | NULL terminated string that represents the selected directory


CXTBrowseDialog::m_szSelPath Data Member

CXTBrowseDialog Data Members, CXTBrowseDialog Class
CXTBrowseDialog::m_szSelPath Data Member

NULL terminated string that represents the selected directory

TCHAR m_szSelPath[MAX_PATH];
Group

CXTBrowseDialog Data Members


CXTBrowseDialog Methods

CXTBrowseDialog Class, Legend, Public Methods
CXTBrowseDialog Methods
Class

CXTBrowseDialog Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
BrowseCtrlCallback | Application defined callback.
DoModal | Call this member function to invoke the browse dialog box and to return the dialog box result when done.
GetCallback | Call this member function to return the address for the BrowseCallbackProc function that is called when an event occurs.
GetData | Returns application data that was set to be passed to the callback function.
GetDisplayName | Call this member function to return the display name that is used by the browse dialog box.
GetImage | Call this member function to get the index to the system image list of the image associated with the selected folder.
GetOptions | Call this member function to return the flags specifying the options that have been set for the dialog box.
GetOwner | Call this member function to get an HWND handle to the owner window for the dialog box.
GetPidlRoot | Call this member function to return the address of the ITEMIDLIST structure that was specified for the location of the root folder.
GetSelPath | Call this member function to get a NULL terminated string that represents the currently selected directory.
GetTitle | Call this member function to return a NULL terminated string that represents the title that was set for the dialog box.
SetCallback | Call this member function to define the address for the BrowseCallbackProc function that is to be called when an event occurs.
SetData | Call this member function to set the application data that is passed to the callback function.
SetDisplayName | Call this member function to set the address for the display name the dialog box will use.
SetOptions | Call this member function to set the flags for specifying the options for the browse dialog box.
SetOwner | Call this member function to set the owner window for the dialog box.
SetPidlRoot | Call this member function to set the address of an ITEMIDLIST structure which specifies the location of the root folder to browse from.
SetSelPath | Call this member function to set the initial path to select when the browse dialog is first opened.
SetTitle | Call this member function to set the title for the browse dialog box.


CXTBrowseDialog::BrowseCtrlCallback Method

CXTBrowseDialog Methods, CXTBrowseDialog Class
CXTBrowseDialog::BrowseCtrlCallback Method

Application defined callback.

static int CALLBACK BrowseCtrlCallback(
    HWND hwnd,
    UINT uMsg,
    LPARAM lParam,
    LPARAM lpData
);
Parameters

hwnd
A handle to a window.
uMsg
The message that is sent to the window.
lParam
Specifies the application-defined data passed by the BrowseCtrlCallback function.
lpData
Data that is passed into the function.

Returns

An integer value.

Remarks

Application defined callback function used with the SHBrowseForFolder function. The browse dialog box calls this function to notify it about events. You can define your own callback function by using the SetCallback method.

Group

CXTBrowseDialog Methods


CXTBrowseDialog::DoModal Method

CXTBrowseDialog Methods, CXTBrowseDialog Class
CXTBrowseDialog::DoModal Method

Call this member function to invoke the browse dialog box and to return the dialog box result when done.

INT_PTR DoModal();
Returns

IDOK if the OK button was pressed, otherwise returns IDCANCEL.

Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetCallback Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetCallback Method

Call this member function to return the address for the BrowseCallbackProc function that is called when an event occurs.

BFFCALLBACK GetCallback();
Returns

The address for the BrowseCallbackProc function that is called when an event occurs.

Body Source
BFFCALLBACK CXTBrowseDialog::GetCallback() {
    return lpfn;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetData Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetData Method

Returns application data that was set to be passed to the callback function.

LPARAM GetData();
Returns

The application data that was set to be passed to the callback function, if one is specified.

Body Source
LPARAM CXTBrowseDialog::GetData() {
    return lParam;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetDisplayName Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetDisplayName Method

Call this member function to return the display name that is used by the browse dialog box.

LPCTSTR GetDisplayName();
Returns

The display name that is used by the browse dialog box.

Body Source
LPCTSTR CXTBrowseDialog::GetDisplayName() {
    return pszDisplayName;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetImage Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetImage Method

Call this member function to get the index to the system image list of the image associated with the selected folder.

int GetImage();
Returns

The index to the system image list.

Body Source
int CXTBrowseDialog::GetImage() {
    return iImage;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetOptions Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetOptions Method

Call this member function to return the flags specifying the options that have been set for the dialog box.

UINT GetOptions();
Returns

The flags specifying the options that have been set for the dialog box.

Body Source
UINT CXTBrowseDialog::GetOptions() {
    return ulFlags;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetOwner Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetOwner Method

Call this member function to get an HWND handle to the owner window for the dialog box.

HWND GetOwner();
Returns

An HWND handle.

Body Source
HWND CXTBrowseDialog::GetOwner() {
    return hwndOwner;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetPidlRoot Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetPidlRoot Method

Call this member function to return the address of the ITEMIDLIST structure that was specified for the location of the root folder.

LPCITEMIDLIST GetPidlRoot();
Returns

The address of the ITEMIDLIST structure that was specified for the location of the root folder.

Body Source
LPCITEMIDLIST CXTBrowseDialog::GetPidlRoot() {
    return pidlRoot;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetSelPath Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetSelPath Method

Call this member function to get a NULL terminated string that represents the currently selected directory.

LPCTSTR GetSelPath();
Returns

A NULL terminated string that represents the selected directory.

Body Source
LPCTSTR CXTBrowseDialog::GetSelPath() {
    return m_szSelPath;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::GetTitle Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::GetTitle Method

Call this member function to return a NULL terminated string that represents the title that was set for the dialog box.

LPCTSTR GetTitle();
Returns

A NULL terminated string that represents the title that was set for the dialog box.

Body Source
LPCTSTR CXTBrowseDialog::GetTitle() {
    return lpszTitle;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::SetCallback Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::SetCallback Method

Call this member function to define the address for the BrowseCallbackProc function that is to be called when an event occurs.

void SetCallback(
    BFFCALLBACK pf
);
Parameters

pf
[in] Address of an application-defined function that the dialog box calls when an event occurs. For more information, see the BrowseCallbackProc function. This member can be NULL.

Body Source
void CXTBrowseDialog::SetCallback(BFFCALLBACK pf) {
    lpfn = pf;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::SetData Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::SetData Method

Call this member function to set the application data that is passed to the callback function.

void SetData(
    LPARAM lp
);
Parameters

lp
[in] Application-defined value that the dialog box passes to the callback function, if one is specified.

Body Source
void CXTBrowseDialog::SetData(LPARAM lp) {
    lParam = lp;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::SetDisplayName Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::SetDisplayName Method

Call this member function to set the address for the display name the dialog box will use.

void SetDisplayName(
    LPCTSTR szDisplayName
);
Parameters

szDisplayName
[in] Address of a buffer to receive the display name of the folder selected by the user. The size of this buffer is assumed to be MAX_PATH bytes.

Body Source
void CXTBrowseDialog::SetDisplayName(LPCTSTR szDisplayName) {
    pszDisplayName = (LPTSTR)szDisplayName;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::SetOptions Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::SetOptions Method

Call this member function to set the flags for specifying the options for the browse dialog box.

void SetOptions(
    UINT uf
);
Parameters

uf
[in] Flags specifying the options for the dialog box. See the Remarks section below for a list of available styles.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • BIF_BROWSEFORCOMPUTER Only return computers. If the user selects anything other than a computer, the OK button is grayed.
  • BIF_BROWSEFORPRINTER Only allow the selection of printers. If the user selects anything other than a printer, the OK button is grayed. In Microsoft Windows XP, the best practice is to use an XP-style dialog, setting the root of the dialog to the Printers and Faxes folder (CSIDL_PRINTERS).
  • BIF_BROWSEINCLUDEFILES Version 4.71. The browse dialog box will display files as well as folders.
  • BIF_BROWSEINCLUDEURLS Version 5.0. The browse dialog box can display URLs. The BIF_USENEWUI and BIF_BROWSEINCLUDEFILES flags must also be set. If these three flags are not set, the browser dialog box will reject URLs. Even when these flags are set, the browse dialog box will only display URLs if the folder that contains the selected item supports them. When the folder's IShellFolder::GetAttributesOf method is called to request the selected item's attributes, the folder must set the SFGAO_FOLDER attribute flag. Otherwise, the browse dialog box will not display the URL.
  • BIF_DONTGOBELOWDOMAIN Do not include network folders below the domain level in the dialog box's tree view control.
  • BIF_EDITBOX Version 4.71. Include an edit control in the browse dialog box that allows the user to type the name of an item.
  • BIF_NEWDIALOGSTYLE Version 5.0. Use the new user interface. Setting this flag provides the user with a larger dialog box that can be resized. The dialog box has several new capabilities including: drag-and-drop capability within the dialog box, reordering, shortcut menus, new folders, delete, and other shortcut menu commands. To use this flag, you must call OleInitialize or CoInitialize before calling SHBrowseForFolder.
  • BIF_NONEWFOLDERBUTTON Version 6.0. Do not include the New Folder button in the browse dialog box.
  • BIF_NOTRANSLATETARGETS Version 6.0. When the selected item is a shortcut, return the PIDL of the shortcut itself rather than its target.
  • BIF_RETURNFSANCESTORS Only return file system ancestors. An ancestor is a subfolder that is beneath the root folder in the namespace hierarchy. If the user selects an ancestor of the root folder that is not part of the file system, the OK button is grayed.
  • BIF_RETURNONLYFSDIRS Only return file system directories. If the user selects folders that are not part of the file system, the OK button is grayed.
  • BIF_SHAREABLE Version 5.0. The browse dialog box can display shareable resources on remote systems. It is intended for applications that want to expose remote shares on a local system. The BIF_NEWDIALOGSTYLE flag must also be set.
  • BIF_STATUSTEXT Include a status area in the dialog box. The callback function can set the status text by sending messages to the dialog box. This flag is not supported when BIF_NEWDIALOGSTYLE is specified.
  • BIF_UAHINT Version 6.0. When combined with BIF_NEWDIALOGSTYLE, adds a usage hint to the dialog box in place of the edit box. BIF_EDITBOX overrides this flag.
  • BIF_USENEWUI Version 5.0. Use the new user interface, including an edit box. This flag is equivalent to BIF_EDITBOX | BIF_NEWDIALOGSTYLE. To use BIF_USENEWUI, you must call OleInitialize or CoInitialize before calling SHBrowseForFolder.
  • BIF_VALIDATE Version 4.71. If the user types an invalid name into the edit box, the browse dialog box will call the application's BrowseCallbackProc with the BFFM_VALIDATEFAILED message. This flag is ignored if BIF_EDITBOX is not specified.
Body Source
void CXTBrowseDialog::SetOptions(UINT uf) {
    ulFlags = uf;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::SetOwner Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::SetOwner Method

Call this member function to set the owner window for the dialog box.

void SetOwner(
    HWND hWnd
);
Parameters

hWnd
[in] Handle to the owner window for the dialog box.

Body Source
void CXTBrowseDialog::SetOwner(HWND hWnd) {
    hwndOwner = hWnd;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::SetPidlRoot Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::SetPidlRoot Method

Call this member function to set the address of an ITEMIDLIST structure which specifies the location of the root folder to browse from.

void SetPidlRoot(
    LPCITEMIDLIST pidl
);
Parameters

pidl
[in] Address of an ITEMIDLIST structure specifying the location of the root folder to browse from. Only the specified folder and its subfolders appear in the dialog box. This member can be NULL, in which case, the namespace root (the desktop folder) is used.

Body Source
void CXTBrowseDialog::SetPidlRoot(LPCITEMIDLIST pidl) {
    pidlRoot = pidl;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog::SetSelPath Method

CXTBrowseDialog Methods, CXTBrowseDialog Class
CXTBrowseDialog::SetSelPath Method

Call this member function to set the initial path to select when the browse dialog is first opened.

void SetSelPath(
    LPCTSTR szSelPath
);
Parameters

szSelPath
[in] A NULL terminated string that represents the directory that is selected when the dialog is initially opened. If not set, GetCurrentDirectory is called to set the directory.

Group

CXTBrowseDialog Methods


CXTBrowseDialog::SetTitle Method

CXTBrowseDialog Methods, CXTBrowseDialog Class, Body Source
CXTBrowseDialog::SetTitle Method

Call this member function to set the title for the browse dialog box.

void SetTitle(
    LPCTSTR szTitle
);
Parameters

szTitle
[in] Address of a null-terminated string that is displayed above the tree view control in the dialog box. This string can be used to specify instructions to the user.

Body Source
void CXTBrowseDialog::SetTitle(LPCTSTR szTitle) {
    lpszTitle = szTitle;
}
Group

CXTBrowseDialog Methods


CXTBrowseDialog Constructors

CXTBrowseDialog Class, Legend, Public Methods
CXTBrowseDialog Constructors
Class

CXTBrowseDialog Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTBrowseDialog | Constructs a CXTBrowseDialog object


CXTBrowseDialog::CXTBrowseDialog Constructor

CXTBrowseDialog Constructors, CXTBrowseDialog Class
CXTBrowseDialog::CXTBrowseDialog Constructor

Constructs a CXTBrowseDialog object

CXTBrowseDialog(
    CWnd* pParent = NULL
);
Parameters

pParent
[in] Points to a CWnd object that represents the parent window for the browse dialog.

Group

CXTBrowseDialog Constructors


CXTBrowseDialog Destructors

CXTBrowseDialog Class, Legend, Public Methods
CXTBrowseDialog Destructors
Class

CXTBrowseDialog Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTBrowseDialog | Destroys a CXTBrowseDialog object, handles cleanup and deallocation


CXTBrowseDialog::~CXTBrowseDialog Destructor

CXTBrowseDialog Destructors, CXTBrowseDialog Class
CXTBrowseDialog::~CXTBrowseDialog Destructor

Destroys a CXTBrowseDialog object, handles cleanup and deallocation

virtual ~CXTBrowseDialog();
Group

CXTBrowseDialog Destructors


CXTBrowseEdit Class

XTBrowseEdit.h, Classes, Legend, Members, Topics, CXTBrowseEdit Data Members, CXTBrowseEdit Methods, CXTBrowseEdit Constructors, CXTBrowseEdit Destructors, CXTBrowseEdit Constructors, CXTBrowseEdit Data Members, CXTBrowseEdit Destructors, CXTBrowseEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTBrowseEdit Class

CXTBrowseEdit is a CXTEdit derived class. This class also has a push button associated with it. The control can be used to search for directories and files or activate a popup menu.

Class Hierarchy

class CXTBrowseEdit : public CXTEdit;
File

XTBrowseEdit.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTBrowseEdit Constructors
CXTBrowseEdit Constructors | Description
CXTBrowseEdit | Constructs a CXTBrowseEdit object
CXTBrowseEdit Data Members
CXTBrowseEdit Data Members | Description
m_bBrowsing | true if in browse operation.
m_bOpenFileDialog | TRUE for Open File dialog, FALSE for Save as.
m_btnBrowse | Pointer to a push button.
m_dwBStyle | Search type.
m_dwFlags | File dialog styles.
m_nGap | Distance between the button and edit control.
m_nMenu | Popup menu ID.
m_nSubMenuIndx | Index of a popup submenu.
m_pFileDialog | Points to a valid CFileDialog object.
m_strDefExt | Default file extension.
m_strFileName | Default file name.
m_strFilter | Default file filter.
m_strTitle | Directory dialog title.
CXTBrowseEdit Destructors
CXTBrowseEdit Destructors | Description
~CXTBrowseEdit | Destroys a CXTBrowseEdit object, handles cleanup and deallocation
CXTBrowseEdit Methods
CXTBrowseEdit Methods | Description
ChooseDirectory | This member function is called by the browse edit control to display a directory chooser dialog.
ChooseFile | This member function is called by the browse edit control to display a File Open dialog.
Initialize |
IsBrowsing | Call this member function to determine if the browse edit control is in the middle of a browse operation.
OnBrowse | This member function is called whenever the browse button is pressed, and can be overridden to perform custom browse functions.
PopupMenu | This member function is called by the browse edit control to create and track a pop-up menu. The menu selection is then copied to the edit control.
PositionBrowseButton | This member function is called by the browse edit control to position the browse button in relation to the edit control.
SetDlgDefExt | This member function sets the default extension for the File Open dialog.
SetDlgFileName | This member function sets the default file name for the File Open dialog.
SetDlgFilter | This member function sets the file filter for the File Open dialog.
SetDlgInitialDir | This member function sets the initial directory for the directory dialog.
SetDlgOpenFile | This member function will set the File Open dialog style.
SetDlgStyle | This member function sets the style flags for the File Open dialog.
SetDlgTitle | This member function sets the title for the directory dialog.
SetFileDialog | This member function will set a CFileDialog derived class object to be the file open dialog.
SetGap | Call this member function to set the gap between the browse button and the edit window.


CXTBrowseEdit Data Members

CXTBrowseEdit Class, Legend, Protected Data Members
CXTBrowseEdit Data Members
Class

CXTBrowseEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bBrowsing | true if in browse operation.
m_bOpenFileDialog | TRUE for Open File dialog, FALSE for Save as.
m_btnBrowse | Pointer to a push button.
m_dwBStyle | Search type.
m_dwFlags | File dialog styles.
m_nGap | Distance between the button and edit control.
m_nMenu | Popup menu ID.
m_nSubMenuIndx | Index of a popup submenu.
m_pFileDialog | Points to a valid CFileDialog object.
m_strDefExt | Default file extension.
m_strFileName | Default file name.
m_strFilter | Default file filter.
m_strTitle | Directory dialog title.


CXTBrowseEdit::m_bBrowsing Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_bBrowsing Data Member

true if in browse operation.

bool m_bBrowsing;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_bOpenFileDialog Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_bOpenFileDialog Data Member

TRUE for Open File dialog, FALSE for Save as.

BOOL m_bOpenFileDialog;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_btnBrowse Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_btnBrowse Data Member

Pointer to a push button.

CXTBrowseButton m_btnBrowse;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_dwBStyle Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_dwBStyle Data Member

Search type.

DWORD m_dwBStyle;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_dwFlags Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_dwFlags Data Member

File dialog styles.

DWORD m_dwFlags;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_nGap Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_nGap Data Member

Distance between the button and edit control.

int m_nGap;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_nMenu Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_nMenu Data Member

Popup menu ID.

UINT m_nMenu;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_nSubMenuIndx Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_nSubMenuIndx Data Member

Index of a popup submenu.

UINT m_nSubMenuIndx;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_pFileDialog Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_pFileDialog Data Member

Points to a valid CFileDialog object.

CFileDialog* m_pFileDialog;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_strDefExt Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_strDefExt Data Member

Default file extension.

CString m_strDefExt;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_strFileName Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_strFileName Data Member

Default file name.

CString m_strFileName;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_strFilter Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_strFilter Data Member

Default file filter.

CString m_strFilter;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit::m_strTitle Data Member

CXTBrowseEdit Data Members, CXTBrowseEdit Class
CXTBrowseEdit::m_strTitle Data Member

Directory dialog title.

CString m_strTitle;
Group

CXTBrowseEdit Data Members


CXTBrowseEdit Methods

CXTBrowseEdit Class, Legend, Public Methods
CXTBrowseEdit Methods
Class

CXTBrowseEdit Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
ChooseDirectory | This member function is called by the browse edit control to display a directory chooser dialog.
ChooseFile | This member function is called by the browse edit control to display a File Open dialog.
Initialize |
IsBrowsing | Call this member function to determine if the browse edit control is in the middle of a browse operation.
OnBrowse | This member function is called whenever the browse button is pressed, and can be overridden to perform custom browse functions.
PopupMenu | This member function is called by the browse edit control to create and track a pop-up menu. The menu selection is then copied to the edit control.
PositionBrowseButton | This member function is called by the browse edit control to position the browse button in relation to the edit control.
SetDlgDefExt | This member function sets the default extension for the File Open dialog.
SetDlgFileName | This member function sets the default file name for the File Open dialog.
SetDlgFilter | This member function sets the file filter for the File Open dialog.
SetDlgInitialDir | This member function sets the initial directory for the directory dialog.
SetDlgOpenFile | This member function will set the File Open dialog style.
SetDlgStyle | This member function sets the style flags for the File Open dialog.
SetDlgTitle | This member function sets the title for the directory dialog.
SetFileDialog | This member function will set a CFileDialog derived class object to be the file open dialog.
SetGap | Call this member function to set the gap between the browse button and the edit window.


CXTBrowseEdit::ChooseDirectory Method

CXTBrowseEdit Methods, CXTBrowseEdit Class
CXTBrowseEdit::ChooseDirectory Method

This member function is called by the browse edit control to display a directory chooser dialog.

virtual void ChooseDirectory();
Group

CXTBrowseEdit Methods


CXTBrowseEdit::ChooseFile Method

CXTBrowseEdit Methods, CXTBrowseEdit Class
CXTBrowseEdit::ChooseFile Method

This member function is called by the browse edit control to display a File Open dialog.

virtual void ChooseFile();
Group

CXTBrowseEdit Methods


Initialize Method

CXTBrowseEdit Methods
Initialize Method
Overload List
Methods
Method | Description
CXTBrowseEdit::Initialize (CWnd*) | This member function is called to initialize the browse edit control.
CXTBrowseEdit::Initialize (CWnd*, DWORD, UINT, int) | This member function is called to initialize the browse edit control.
Group

CXTBrowseEdit Methods


CXTBrowseEdit::Initialize Method (CWnd*, DWORD, UINT, int)

Initialize Method, CXTBrowseEdit Class, Example
CXTBrowseEdit::Initialize Method (CWnd*, DWORD, UINT, int)

This member function is called to initialize the browse edit control.

virtual bool Initialize(
    CWnd* pParentWnd,
    DWORD dwBStyle,
    UINT nMenu = 0,
    int nSubMenuIndx = 0
);
virtual bool Initialize(
    CWnd* pParentWnd
);
Parameters

pParentWnd
[in] Pointer to the parent of the edit control.
dwBStyle
[in] A DWORD value that represents the type of search to perform. It can be any one of the styles listed in the remarks section.
nMenu
[in] If dwBStyle contains the BES_XT_POPUPMENU flag, then nMenu represents the resource ID of a popup menu. Otherwise this value is ignored.
nSubMenuIndx
[in] Index of submenu to display.

Returns

TRUE if initialization was successful, otherwise FALSE.

Remarks

The Initialize function must be called once for each browse edit control to complete initialization. This should be done after you have subclassed or created the browse edit control.

The browse edit control can be defined to use any of the following styles:

  • BES_XT_CHOOSEDIR Display the choose folder dialog.
  • BES_XT_CHOOSEFILE Display the choose file dialog.
  • BES_XT_POPUPMENU Display a user defined context menu.

The single argument version of Initialize will call the CXTEdit base class to initialize the edit portion of the control only, generally you would not want to use this override for standard initialization.

Example

The following example demonstrates the use of Initialize.

BOOL CBrowseEditDlg::OnInitDialog()
{
    CXTResizeDialog::OnInitDialog();
    ...
    // Initialize browse edit controls.
    m_edit1.Initialize(this, BES_XT_POPUPMENU, IDR_POPUP);
    m_edit2.Initialize(this, BES_XT_CHOOSEDIR);
    m_edit3.Initialize(this, BES_XT_CHOOSEFILE);

    return TRUE;  // return TRUE  unless you set the focus to a control
}
Group

Initialize Method


CXTBrowseEdit::IsBrowsing Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::IsBrowsing Method

Call this member function to determine if the browse edit control is in the middle of a browse operation.

bool IsBrowsing();
Returns

true if the control is displaying a File Open dialog or popup menu.

Body Source
bool CXTBrowseEdit::IsBrowsing() {
    return m_bBrowsing;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::OnBrowse Method

CXTBrowseEdit Methods, CXTBrowseEdit Class
CXTBrowseEdit::OnBrowse Method

This member function is called whenever the browse button is pressed, and can be overridden to perform custom browse functions.

virtual void OnBrowse();
Group

CXTBrowseEdit Methods


CXTBrowseEdit::PopupMenu Method

CXTBrowseEdit Methods, CXTBrowseEdit Class
CXTBrowseEdit::PopupMenu Method

This member function is called by the browse edit control to create and track a pop-up menu. The menu selection is then copied to the edit control.

virtual void PopupMenu();
Group

CXTBrowseEdit Methods


CXTBrowseEdit::PositionBrowseButton Method

CXTBrowseEdit Methods, CXTBrowseEdit Class
CXTBrowseEdit::PositionBrowseButton Method

This member function is called by the browse edit control to position the browse button in relation to the edit control.

virtual void PositionBrowseButton();
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetDlgDefExt Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetDlgDefExt Method

This member function sets the default extension for the File Open dialog.

void SetDlgDefExt(
    LPCTSTR lpszDefExt = NULL
);
Parameters

lpszDefExt
[in] Points to a NULL terminated string that represents the default file extension to be used with the File Open dialog.

Body Source
void CXTBrowseEdit::SetDlgDefExt(LPCTSTR strDefExt/*=NULL*/) {
    m_strDefExt = strDefExt;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetDlgFileName Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetDlgFileName Method

This member function sets the default file name for the File Open dialog.

void SetDlgFileName(
    LPCTSTR lpszFileName = NULL
);
Parameters

lpszFileName
[in] Points to a NULL terminated string that represents the default file name to be used with the File Open dialog.

Body Source
void CXTBrowseEdit::SetDlgFileName(LPCTSTR strFileName/*=NULL*/) {
    m_strFileName = strFileName;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetDlgFilter Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetDlgFilter Method

This member function sets the file filter for the File Open dialog.

void SetDlgFilter(
    LPCTSTR lpszFilter = NULL
);
Parameters

lpszFilter
[in] Points to a NULL terminated string that represents the file filter used by the File Open dialog.

Body Source
void CXTBrowseEdit::SetDlgFilter(LPCTSTR strFilter/*=NULL*/) {
    m_strFilter = strFilter;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetDlgInitialDir Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetDlgInitialDir Method

This member function sets the initial directory for the directory dialog.

void SetDlgInitialDir(
    LPCTSTR lpszInitialDir
);
Parameters

lpszInitialDir
[in] Points to a NULL terminated string the represents the initial directory of the dialog.

Body Source
void CXTBrowseEdit::SetDlgInitialDir(LPCTSTR lpszInitialDir) {
    m_strInitialDir = lpszInitialDir;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetDlgOpenFile Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetDlgOpenFile Method

This member function will set the File Open dialog style.

virtual void SetDlgOpenFile(
    BOOL bOpenFileDialog = TRUE
);
Parameters

bOpenFileDialog
[in] Set to TRUE to construct a File Open dialog box, or FALSE to construct a File Save as dialog box.

Body Source
void CXTBrowseEdit::SetDlgOpenFile(BOOL bOpenFileDialog/*=TRUE*/) {
    m_bOpenFileDialog = bOpenFileDialog;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetDlgStyle Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetDlgStyle Method

This member function sets the style flags for the File Open dialog.

virtual void SetDlgStyle(
    DWORD dwFlags = OFN_HIDEREADONLY | OFN_OVERWRITEPROMPT
);
Parameters

dwFlags
[in] The desired OFN_ styles for the File Open dialog.

Body Source
void CXTBrowseEdit::SetDlgStyle(DWORD dwFlags/*=OFN_HIDEREADONLY | OFN_OVERWRITEPROMPT*/) {
    m_dwFlags = dwFlags;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetDlgTitle Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetDlgTitle Method

This member function sets the title for the directory dialog.

void SetDlgTitle(
    LPCTSTR lpszTitle = NULL
);
Parameters

lpszTitle
[in] Points to a NULL terminated string the represents the title of the "browse for directory" dialog.

Body Source
void CXTBrowseEdit::SetDlgTitle(LPCTSTR strTitle/*=NULL*/) {
    m_strTitle = strTitle;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetFileDialog Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetFileDialog Method

This member function will set a CFileDialog derived class object to be the file open dialog.

virtual void SetFileDialog(
    CFileDialog* pFileDialog
);
Parameters

pFileDialog
[in] Points to the CFileDialog object that will replace the standard File Open dialog.

Body Source
void CXTBrowseEdit::SetFileDialog(CFileDialog* pFileDialog/*=NULL*/) {
    m_pFileDialog = pFileDialog;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit::SetGap Method

CXTBrowseEdit Methods, CXTBrowseEdit Class, Body Source
CXTBrowseEdit::SetGap Method

Call this member function to set the gap between the browse button and the edit window.

void SetGap(
    int nGap
);
Parameters

nGap
[in] Gap, in pixels, between the browse button and the edit window.

Body Source
void CXTBrowseEdit::SetGap(int nGap) {
    ASSERT(nGap >= 0); m_nGap = nGap;
}
Group

CXTBrowseEdit Methods


CXTBrowseEdit Constructors

CXTBrowseEdit Class, Legend, Public Methods
CXTBrowseEdit Constructors
Class

CXTBrowseEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTBrowseEdit | Constructs a CXTBrowseEdit object


CXTBrowseEdit::CXTBrowseEdit Constructor

CXTBrowseEdit Constructors, CXTBrowseEdit Class
CXTBrowseEdit::CXTBrowseEdit Constructor

Constructs a CXTBrowseEdit object

CXTBrowseEdit();
Group

CXTBrowseEdit Constructors


CXTBrowseEdit Destructors

CXTBrowseEdit Class, Legend, Public Methods
CXTBrowseEdit Destructors
Class

CXTBrowseEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTBrowseEdit | Destroys a CXTBrowseEdit object, handles cleanup and deallocation


CXTBrowseEdit::~CXTBrowseEdit Destructor

CXTBrowseEdit Destructors, CXTBrowseEdit Class
CXTBrowseEdit::~CXTBrowseEdit Destructor

Destroys a CXTBrowseEdit object, handles cleanup and deallocation

virtual ~CXTBrowseEdit();
Group

CXTBrowseEdit Destructors


CXTButton Class

XTButton.h, Classes, Legend, Members, Topics, CXTButton Data Members, CXTButton Methods, CXTButton Constructors, CXTButton Destructors, CXTButton Constructors, CXTButton Data Members, CXTButton Destructors, CXTButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButton Class

CXTButton is a CButton derived class. It is used to create flat style and image buttons. This control has several features including flat, semi-flat, and three dimensional borders.

Class Hierarchy

class CXTButton : public CButton;
File

XTButton.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTButton Constructors
CXTButton Constructors | Description
CXTButton | Constructs a CXTButton object
CXTButton Data Members
CXTButton Data Members | Description
m_bChecked | TRUE if the button is checked.
m_bHot | TRUE if mouse under button
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bPushed | TRUE if button was pressed
m_bUserPosition | TRUE if the user has defined the XY coordinates for the image and text.
m_dwxStyle | The style of the button, see SetXButtonStyle.
m_nBorderGap | Gap between the button edge and the image.
m_nImageGap | Gap between the button text and the image.
m_pIcon | Multiple state icon manager converts icon to different states.
m_ptImage | XY location of the button image.
m_ptText | XY location of the button text.
m_sizeImage | Initial size of the button.
CXTButton Destructors
CXTButton Destructors | Description
~CXTButton | Destroys a CXTButton object, handles cleanup and deallocation
CXTButton Methods
CXTButton Methods | Description
CleanUpGDI | This member function is called to free all associated GDI resources that have been allocated.
GetBorderGap | Call this member function to determine the gap between the button image and the button's edge.
GetButtonText | Call this member function to return the button's text minus the '&'.
GetChecked | Call this member function to determine if the checked state has been defined for the button control.
GetColorFace | This member function gets the current face color.
GetDisabledBitmap | Call this member function to retrieve the disabled bitmap used by the button control.
GetHilite | Call this member function to determine if the button should display highlights on mouse over.
GetIcon | Call this member function to return a pointer to the image manager for the button control.
GetImageGap | Call this member function to determine the gap between the button text and the image.
GetImagePoint | Call this member function to return the x-y location of the top left corner where the button image is displayed.
GetImageSize | Call this member function to return the size of the image displayed for the button control.
GetNormalIcon | Call this member function to retrieve the normal icon image used by the button control.
GetSelectedIcon | Call this member function to retrieve the selected icon image used by the button control.
GetTextPoint | Call this member function to return the x-y location of the top left corner where text is displayed.
GetUserPosition | Call this member function to determine if the user has defined specific locations for text and image display.
GetXButtonStyle | This function returns only the BS_XT_ style values, not any of the other window styles.
Init | This member function is called by the CXTButton class to perform initialization when the window is created or sub-classed.
IsThemeValid | This member function is called to check if the button control is using a theme.
ResetImage | This function toggles the image display for the button on or off.
SetAlternateColors | This method will allow the user to define the default colors for the background shadow and highlight colors for the button.
SetBitmap | This member function will set the bitmap associated with the button.
SetBorderGap | This member function will set the gap between the button's edge and the image.
SetChecked | Sets the highlight state for the button control.
SetColorFace | This member function sets the default face color for the button.
SetColorHilite | This member function sets the default highlight color for the button.
SetColorShadow | This member function sets the default shadow color for the button.
SetColorText | This member function sets the default text color for the button.
SetFontEx | Call this member function to set the font for the button control.
SetIcon |
SetImageGap | This member function will set the gap between the button's text and the image.
SetStateX | Sets the highlight state for the button control.
SetTextAndImagePos | This member function will set the XY location of the text and image that is displayed on the push button.
SetXButtonStyle | This member function will set the display style for the button.
SetXPFlatColors | This member function sets the colors for the BS_XT_XPFLAT mode.


CXTButton Data Members

CXTButton Class, Legend, Protected Data Members
CXTButton Data Members
Class

CXTButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bChecked | TRUE if the button is checked.
m_bHot | TRUE if mouse under button
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bPushed | TRUE if button was pressed
m_bUserPosition | TRUE if the user has defined the XY coordinates for the image and text.
m_dwxStyle | The style of the button, see SetXButtonStyle.
m_nBorderGap | Gap between the button edge and the image.
m_nImageGap | Gap between the button text and the image.
m_pIcon | Multiple state icon manager converts icon to different states.
m_ptImage | XY location of the button image.
m_ptText | XY location of the button text.
m_sizeImage | Initial size of the button.


CXTButton::m_bChecked Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_bChecked Data Member

TRUE if the button is checked.

BOOL m_bChecked;
Group

CXTButton Data Members


CXTButton::m_bHot Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_bHot Data Member

TRUE if mouse under button

BOOL m_bHot;
Group

CXTButton Data Members


CXTButton::m_bPreSubclassInit Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_bPreSubclassInit Data Member

true when initializing from PreSubclassWindow.

bool m_bPreSubclassInit;
Group

CXTButton Data Members


CXTButton::m_bPushed Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_bPushed Data Member

TRUE if button was pressed

BOOL m_bPushed;
Group

CXTButton Data Members


CXTButton::m_bUserPosition Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_bUserPosition Data Member

TRUE if the user has defined the XY coordinates for the image and text.

BOOL m_bUserPosition;
Group

CXTButton Data Members


CXTButton::m_dwxStyle Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_dwxStyle Data Member

The style of the button, see SetXButtonStyle.

DWORD m_dwxStyle;
Group

CXTButton Data Members


CXTButton::m_nBorderGap Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_nBorderGap Data Member

Gap between the button edge and the image.

int m_nBorderGap;
Group

CXTButton Data Members


CXTButton::m_nImageGap Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_nImageGap Data Member

Gap between the button text and the image.

int m_nImageGap;
Group

CXTButton Data Members


CXTButton::m_pIcon Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_pIcon Data Member

Multiple state icon manager converts icon to different states.

CXTPImageManagerIcon* m_pIcon;
Group

CXTButton Data Members


CXTButton::m_ptImage Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_ptImage Data Member

XY location of the button image.

CPoint m_ptImage;
Group

CXTButton Data Members


CXTButton::m_ptText Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_ptText Data Member

XY location of the button text.

CPoint m_ptText;
Group

CXTButton Data Members


CXTButton::m_sizeImage Data Member

CXTButton Data Members, CXTButton Class
CXTButton::m_sizeImage Data Member

Initial size of the button.

CSize m_sizeImage;
Group

CXTButton Data Members


CXTButton Methods

CXTButton Class, Legend, Protected Methods, Public Methods
CXTButton Methods
Class

CXTButton Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CleanUpGDI | This member function is called to free all associated GDI resources that have been allocated.
GetButtonText | Call this member function to return the button's text minus the '&'.
Init | This member function is called by the CXTButton class to perform initialization when the window is created or sub-classed.
Public Methods
Public Methods
Public Method | Description
GetBorderGap | Call this member function to determine the gap between the button image and the button's edge.
GetChecked | Call this member function to determine if the checked state has been defined for the button control.
GetColorFace | This member function gets the current face color.
GetDisabledBitmap | Call this member function to retrieve the disabled bitmap used by the button control.
GetHilite | Call this member function to determine if the button should display highlights on mouse over.
GetIcon | Call this member function to return a pointer to the image manager for the button control.
GetImageGap | Call this member function to determine the gap between the button text and the image.
GetImagePoint | Call this member function to return the x-y location of the top left corner where the button image is displayed.
GetImageSize | Call this member function to return the size of the image displayed for the button control.
GetNormalIcon | Call this member function to retrieve the normal icon image used by the button control.
GetSelectedIcon | Call this member function to retrieve the selected icon image used by the button control.
GetTextPoint | Call this member function to return the x-y location of the top left corner where text is displayed.
GetUserPosition | Call this member function to determine if the user has defined specific locations for text and image display.
GetXButtonStyle | This function returns only the BS_XT_ style values, not any of the other window styles.
IsThemeValid | This member function is called to check if the button control is using a theme.
ResetImage | This function toggles the image display for the button on or off.
SetAlternateColors | This method will allow the user to define the default colors for the background shadow and highlight colors for the button.
SetBitmap | This member function will set the bitmap associated with the button.
SetBorderGap | This member function will set the gap between the button's edge and the image.
SetChecked | Sets the highlight state for the button control.
SetColorFace | This member function sets the default face color for the button.
SetColorHilite | This member function sets the default highlight color for the button.
SetColorShadow | This member function sets the default shadow color for the button.
SetColorText | This member function sets the default text color for the button.
SetFontEx | Call this member function to set the font for the button control.
SetIcon |
SetImageGap | This member function will set the gap between the button's text and the image.
SetStateX | Sets the highlight state for the button control.
SetTextAndImagePos | This member function will set the XY location of the text and image that is displayed on the push button.
SetXButtonStyle | This member function will set the display style for the button.
SetXPFlatColors | This member function sets the colors for the BS_XT_XPFLAT mode.


CXTButton::CleanUpGDI Method

CXTButton Methods, CXTButton Class
CXTButton::CleanUpGDI Method

This member function is called to free all associated GDI resources that have been allocated.

virtual void CleanUpGDI();
Group

CXTButton Methods


CXTButton::GetBorderGap Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::GetBorderGap Method

Call this member function to determine the gap between the button image and the button's edge.

int GetBorderGap() const;
Returns

The amount in pixels between the button image and border.

Body Source
int CXTButton::GetBorderGap() const {
    return m_nBorderGap;
}
Group

CXTButton Methods


CXTButton::GetButtonText Method

CXTButton Methods, CXTButton Class
CXTButton::GetButtonText Method

Call this member function to return the button's text minus the '&'.

virtual CString GetButtonText(
    BOOL bRemoveAmpersand
);
Parameters

bRemoveAmpersand
TRUE to remove the '&' used for mnemonics.

Returns

A CString object that represents the button's text.

Group

CXTButton Methods


CXTButton::GetChecked Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::GetChecked Method

Call this member function to determine if the checked state has been defined for the button control.

BOOL GetChecked() const;
Returns

TRUE if the checked state is defined for the button control, otherwise returns FALSE.

Body Source
BOOL CXTButton::GetChecked() const {
    return m_bChecked;
}
Group

CXTButton Methods


CXTButton::GetColorFace Method

CXTButton Methods, CXTButton Class
CXTButton::GetColorFace Method

This member function gets the current face color.

virtual COLORREF GetColorFace();
Returns

An RGB value that represents the current face color.

Group

CXTButton Methods


CXTButton::GetDisabledBitmap Method

CXTButton Methods, CXTButton Class
CXTButton::GetDisabledBitmap Method

Call this member function to retrieve the disabled bitmap used by the button control.

HBITMAP GetDisabledBitmap() const;
Returns

A handle to a HBITMAP object.

Group

CXTButton Methods


CXTButton::GetHilite Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::GetHilite Method

Call this member function to determine if the button should display highlights on mouse over.

BOOL GetHilite() const;
Returns

TRUE if the button display highlights on mouse over, otherwise returns FALSE.

Body Source
BOOL CXTButton::GetHilite() const {
    return m_bHot || (::GetCapture() == m_hWnd);
}
Group

CXTButton Methods


CXTButton::GetIcon Method

CXTButton Methods, CXTButton Class
CXTButton::GetIcon Method

Call this member function to return a pointer to the image manager for the button control.

CXTPImageManagerIcon* GetIcon() const;
Returns

A pointer to a CXTPImageManagerIcon object.

Group

CXTButton Methods


CXTButton::GetImageGap Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::GetImageGap Method

Call this member function to determine the gap between the button text and the image.

int GetImageGap() const;
Returns

The amount in pixels between the button text and image displayed.

Body Source
int CXTButton::GetImageGap() const {
    return m_nImageGap;
}
Group

CXTButton Methods


CXTButton::GetImagePoint Method

CXTButton Methods, CXTButton Class
CXTButton::GetImagePoint Method

Call this member function to return the x-y location of the top left corner where the button image is displayed.

CPoint GetImagePoint() const;
Returns

A CPoint object.

Group

CXTButton Methods


CXTButton::GetImageSize Method

CXTButton Methods, CXTButton Class
CXTButton::GetImageSize Method

Call this member function to return the size of the image displayed for the button control.

CSize GetImageSize() const;
Returns

A CSize object.

Group

CXTButton Methods


CXTButton::GetNormalIcon Method

CXTButton Methods, CXTButton Class
CXTButton::GetNormalIcon Method

Call this member function to retrieve the normal icon image used by the button control.

HICON GetNormalIcon();
Returns

A handle to a HICON object.

Group

CXTButton Methods


CXTButton::GetSelectedIcon Method

CXTButton Methods, CXTButton Class
CXTButton::GetSelectedIcon Method

Call this member function to retrieve the selected icon image used by the button control.

HICON GetSelectedIcon();
Returns

A handle to a HICON object.

Group

CXTButton Methods


CXTButton::GetTextPoint Method

CXTButton Methods, CXTButton Class
CXTButton::GetTextPoint Method

Call this member function to return the x-y location of the top left corner where text is displayed.

CPoint GetTextPoint() const;
Returns

A CPoint object.

Group

CXTButton Methods


CXTButton::GetUserPosition Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::GetUserPosition Method

Call this member function to determine if the user has defined specific locations for text and image display.

BOOL GetUserPosition() const;
Returns

TRUE if the user has defined text and image display location.

Body Source
BOOL CXTButton::GetUserPosition() const {
    return m_bUserPosition;
}
Group

CXTButton Methods


CXTButton::GetXButtonStyle Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::GetXButtonStyle Method

This function returns only the BS_XT_ style values, not any of the other window styles.

virtual DWORD GetXButtonStyle();
Returns

The button styles for this CXTButton object.

Body Source
DWORD CXTButton::GetXButtonStyle() {
    ASSERT(::IsWindow(m_hWnd)); return m_dwxStyle;
}
Group

CXTButton Methods


CXTButton::Init Method

CXTButton Methods, CXTButton Class
CXTButton::Init Method

This member function is called by the CXTButton class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTButton Methods


CXTButton::IsThemeValid Method

CXTButton Methods, CXTButton Class
CXTButton::IsThemeValid Method

This member function is called to check if the button control is using a theme.

virtual BOOL IsThemeValid() const;
Returns

TRUE if a theme is used, otherwise FALSE.

Group

CXTButton Methods


CXTButton::ResetImage Method

CXTButton Methods, CXTButton Class
CXTButton::ResetImage Method

This function toggles the image display for the button on or off.

virtual void ResetImage();
Group

CXTButton Methods


CXTButton::SetAlternateColors Method

CXTButton Methods, CXTButton Class
CXTButton::SetAlternateColors Method

This method will allow the user to define the default colors for the background shadow and highlight colors for the button.

virtual void SetAlternateColors(
    COLORREF clr3DFace,
    COLORREF clr3DHilight,
    COLORREF clr3DShadow,
    COLORREF clrBtnText
);
Parameters

clr3DFace
An RGB value that represents the user defined face color for three dimensional display elements.
clr3DHilight
An RGB value that represents the user defined highlight color for three dimensional display elements (edges facing the light source.)
clr3DShadow
An RGB value that represents the user defined shadow color for three dimensional display elements (edges facing away from the light source).
clrBtnText
An RGB value that represents the user defined text color on push buttons.

Group

CXTButton Methods


CXTButton::SetBitmap Method

CXTButton Methods, CXTButton Class
CXTButton::SetBitmap Method

This member function will set the bitmap associated with the button.

virtual BOOL SetBitmap(
    CSize size,
    UINT nID,
    BOOL bRedraw = TRUE
);
Parameters

size
CSize object that represents the size of the bitmap.
nID
Resource ID for the bitmap.
bRedraw
Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTButton Methods


CXTButton::SetBorderGap Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::SetBorderGap Method

This member function will set the gap between the button's edge and the image.

int SetBorderGap(
    int nGap
);
Parameters

nGap
Amount in pixels of the gap between the button edge and the image.

Returns

The previous border gap value.

Body Source
int CXTButton::SetBorderGap(int nGap) {
    int nOldGap = m_nBorderGap; m_nBorderGap = nGap; return nOldGap;
}
Group

CXTButton Methods


CXTButton::SetChecked Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::SetChecked Method

Sets the highlight state for the button control.

void SetChecked(
    BOOL bChecked
);
Parameters

bChecked
Specifies whether the button is to be checked. TRUE will check the button. FALSE will uncheck it.

Remarks

This member function sets the highlighting state of the button control. This is the same as its CButton counterpart, except the m_bChecked flag is set. This is done because MFC does not recognize the button as being checked unless it is a radio or check box.

Body Source
void CXTButton::SetChecked(BOOL bChecked) {
    m_bChecked = bChecked; if (GetSafeHwnd()) Invalidate(FALSE);
}
Group

CXTButton Methods


CXTButton::SetColorFace Method

CXTButton Methods, CXTButton Class
CXTButton::SetColorFace Method

This member function sets the default face color for the button.

virtual void SetColorFace(
    COLORREF clrFace
);
Parameters

clrFace
An RGB value that represents the user defined face color.

Group

CXTButton Methods


CXTButton::SetColorHilite Method

CXTButton Methods, CXTButton Class
CXTButton::SetColorHilite Method

This member function sets the default highlight color for the button.

virtual void SetColorHilite(
    COLORREF clrHilite
);
Parameters

clrHilite
An RGB value that represents the user defined highlight color.

Group

CXTButton Methods


CXTButton::SetColorShadow Method

CXTButton Methods, CXTButton Class
CXTButton::SetColorShadow Method

This member function sets the default shadow color for the button.

virtual void SetColorShadow(
    COLORREF clrShadow
);
Parameters

clrShadow
An RGB value that represents the user defined shadow color.

Group

CXTButton Methods


CXTButton::SetColorText Method

CXTButton Methods, CXTButton Class
CXTButton::SetColorText Method

This member function sets the default text color for the button.

virtual void SetColorText(
    COLORREF clrText
);
Parameters

clrText
An RGB value that represents the user defined text color.

Group

CXTButton Methods


CXTButton::SetFontEx Method

CXTButton Methods, CXTButton Class
CXTButton::SetFontEx Method

Call this member function to set the font for the button control.

virtual CFont* SetFontEx(
    CFont* pFont
);
Parameters

pFont
Points to a valid CFont object.

Returns

A pointer to the previously set font for the button control.

Group

CXTButton Methods


SetIcon Method

CXTButton Methods
SetIcon Method
Overload List
Methods
Method | Description
CXTButton::SetIcon (CSize, CXTPImageManagerIconHandle, CXTPImageManagerIconHandle, BOOL) | This member function will set the normal and hot state icons for the push button.
CXTButton::SetIcon (CSize, HICON, HICON, BOOL) | This member function will set the normal and hot state icons for the push button.
CXTButton::SetIcon (CSize, LPCTSTR, LPCTSTR, BOOL) | This member function will set the normal and hot state icons for the push button.
CXTButton::SetIcon (CSize, UINT, UINT, BOOL) | This member function will set the normal and hot state icons for the push button.
Group

CXTButton Methods


CXTButton::SetIcon Method (CSize, HICON, HICON, BOOL)

SetIcon Method, CXTButton Class
CXTButton::SetIcon Method (CSize, HICON, HICON, BOOL)

This member function will set the normal and hot state icons for the push button.

virtual BOOL SetIcon(
    CSize size,
    HICON hIcon,
    HICON hIconHot = NULL,
    BOOL bRedraw = TRUE
);
virtual BOOL SetIcon(
    CSize size,
    UINT nID,
    UINT nHotID = 0,
    BOOL bRedraw = TRUE
);
virtual BOOL SetIcon(
    CSize size,
    LPCTSTR lpszID,
    LPCTSTR lpszHotID = NULL,
    BOOL bRedraw = TRUE
);
virtual BOOL SetIcon(
    CSize size,
    CXTPImageManagerIconHandle hIconHandle,
    CXTPImageManagerIconHandle hIconHotHandle,
    BOOL bRedraw = TRUE
);
Parameters

size
CSize object that represents the size of the icon.
hIcon
Handle to the normal icon.
hIconHot
Handle to the hot icon.
bRedraw
Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.
nID
Resource ID for the normal icon.
nHotID
Resource ID for the pressed icon.
lpszID
Resource string ID for the normal icon.
lpszHotID
Resource string ID for the hot icon.
hIconHandle
Handle to the normal icon.
hIconHotHandle
Handle to the hot icon.

Returns

TRUE if successful, otherwise returns FALSE.

Group

SetIcon Method


CXTButton::SetImageGap Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::SetImageGap Method

This member function will set the gap between the button's text and the image.

int SetImageGap(
    int nGap
);
Parameters

nGap
Amount in pixels of the gap between the button text and the image.

Returns

The previous border gap value.

Body Source
int CXTButton::SetImageGap(int nGap) {
    int nOldGap = m_nImageGap; m_nImageGap = nGap; return nOldGap;
}
Group

CXTButton Methods


CXTButton::SetStateX Method

CXTButton Methods, CXTButton Class, Body Source
CXTButton::SetStateX Method

Sets the highlight state for the button control.

void SetStateX(
    BOOL bChecked
);
Parameters

bChecked
Specifies whether the button is to be checked. TRUE will check the button. FALSE will uncheck it.

Remarks

This member function sets the highlighting state of a button control. This is the same as its CButton counterpart, except the m_bChecked flag is set. This is done because MFC does not recognize the button as being checked unless it is a radio or check box.

Body Source
void CXTButton::SetStateX(BOOL bChecked) {
    m_bChecked = bChecked; if (GetSafeHwnd()) Invalidate(FALSE);
}
Group

CXTButton Methods


CXTButton::SetTextAndImagePos Method

CXTButton Methods, CXTButton Class
CXTButton::SetTextAndImagePos Method

This member function will set the XY location of the text and image that is displayed on the push button.

virtual BOOL SetTextAndImagePos(
    CPoint ptImage,
    CPoint ptText,
    BOOL bRedraw = TRUE
);
Parameters

ptImage
XY location of the image displayed on the button.
ptText
XY location of the text displayed on the button.
bRedraw
Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTButton Methods


CXTButton::SetXButtonStyle Method

CXTButton Methods, CXTButton Class, See Also
CXTButton::SetXButtonStyle Method

This member function will set the display style for the button.

virtual DWORD SetXButtonStyle(
    DWORD dwxStyle,
    BOOL bRedraw = TRUE
);
Parameters

dwxStyle
Specifies the button style. The button style can be defined as one or more of the styles listed in the Remarks section.
bRedraw
Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.

Returns

The previous style that was set.

Remarks

The CXTButton can be set to use one or more of the following styles:

  • BS_XT_FLAT Draws the button flat without any borders.
  • BS_XT_SEMIFLAT Draws the button with a thin 3D border.
  • BS_XT_TWOROWS Draws images and text that are centered.
  • BS_XT_SHOWFOCUS Draws a focus rect when the button has input focus.
  • BS_XT_HILITEPRESSED Highlights the button when pressed.
  • BS_XT_XPFLAT Draws a flat button using Office XP themes.
  • BS_XT_FLAT_ANY Same as (BS_XT_FLAT | BS_XT_SEMIFLAT)
  • BS_XT_WINXP_COMPAT Uses Windows XP themes if available. This setting overrides BS_XT_FLAT and BS_XT_SEMIFLAT, but does not override BS_XT_XPFLAT.
See Also

GetXButtonStyle

Group

CXTButton Methods


CXTButton::SetXPFlatColors Method

CXTButton Methods, CXTButton Class
CXTButton::SetXPFlatColors Method

This member function sets the colors for the BS_XT_XPFLAT mode.

virtual void SetXPFlatColors(
    COLORREF clrBorder,
    COLORREF clrHighlight,
    COLORREF clrPressed
);
Parameters

clrBorder
An RGB value that represents the user defined border color for the flat button.
clrHighlight
An RGB value that represents the user defined highlight color for the flat button.
clrPressed
An RGB value that represents the user defined color for when the flat button is pressed.

Group

CXTButton Methods


CXTButton Constructors

CXTButton Class, Legend, Public Methods
CXTButton Constructors
Class

CXTButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTButton | Constructs a CXTButton object


CXTButton::CXTButton Constructor

CXTButton Constructors, CXTButton Class
CXTButton::CXTButton Constructor

Constructs a CXTButton object

CXTButton(
    CRuntimeClass* pThemeFactoryClass = NULL
);
Parameters

pThemeFactoryClass
Factory runtime class associated with this class

Group

CXTButton Constructors


CXTButton Destructors

CXTButton Class, Legend, Public Methods
CXTButton Destructors
Class

CXTButton Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTButton | Destroys a CXTButton object, handles cleanup and deallocation


CXTButton::~CXTButton Destructor

CXTButton Destructors, CXTButton Class
CXTButton::~CXTButton Destructor

Destroys a CXTButton object, handles cleanup and deallocation

virtual ~CXTButton();
Group

CXTButton Destructors


CXTButtonTheme Class

XTButtonTheme.h, Classes, Legend, Members, Topics, CXTButtonTheme Data Members, CXTButtonTheme Methods, CXTButtonTheme Constructors, CXTButtonTheme Destructors, CXTButtonTheme Constructors, CXTButtonTheme Data Members, CXTButtonTheme Destructors, CXTButtonTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonTheme Class

CXTButtonTheme is used to draw the CXTButton object. All themes used for CXTButton should inherit from this base class.

Class Hierarchy

class CXTButtonTheme : public CXTThemeManagerStyle;
File

XTButtonTheme.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTButtonTheme Constructors
CXTButtonTheme Constructors | Description
CXTButtonTheme | Constructs a CXTButtonTheme object.
CXTButtonTheme Data Members
CXTButtonTheme Data Members | Description
m_bOffsetHiliteText | TRUE if highlighted text is animated.
m_bShowIcon | TRUE if the buttons displays an icon.
m_crBack | RGB value for background color.
m_crBorder3DHilite | RGB value for 3D border highlight color.
m_crBorder3DShadow | RGB value for 3D border shadow color.
m_crBorderHilite | RGB value for border highlight color.
m_crBorderShadow | RGB value for border shadow color.
m_crText | RGB value for text color.
m_crTextDisabled | RGB value for disabled text color.
m_pFont | Points to a user defined font for the theme.
m_themeWrapper | Wraps the Windows XP theme API that is used to display Windows XP themes.
CXTButtonTheme Destructors
CXTButtonTheme Destructors | Description
~CXTButtonTheme | Destroys a CXTButtonTheme object, handles cleanup and deallocation.
CXTButtonTheme Methods
CXTButtonTheme Methods | Description
CalculateImagePosition | This member function is called to determine the location for the image displayed for the button.
CanHilite | This member function is used to determine if the button should displayed raised borders on mouse over.
DrawButtonIcon | This member function draws the icon for the button, if one has been defined.
DrawButtonText | This member function is called to draw the text for the button.
DrawButtonThemeBackground | This member function is called to draw the background for the button.
DrawFocusRect | This member function is called to draw the focus rectangle for the button.
DrawItem | This member function is called to draw the button.
DrawWinThemeBackground | This member function is called to draw the Windows XP theme background for the button.
GetColorFace | This member function gets the current face color.
GetTextColor | Call this member function to return the color used to draw the button text.
GetTextPosition | This member function is called to determine the location of the text displayed for the button.
GetThemeFont | This member function is used to return a pointer the font used by the button to display text.
GetThemeWrapper | Call this member function to return a pointer to the Windows theme API wrapper for this control.
IsIconVisible | Call this member function to determine if icons are displayed for the button.
OffsetPoint | This member function will set the proper XY coordinates for the button text and image.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.
SetAlternateColors | This method will allow the user to define the default colors for the background shadow and highlight colors for the button.
SetColorFace | This member function sets the default face color for the button.
SetColorHilite | This member function sets the default highlight color for the button.
SetColorShadow | This member function sets the default shadow color for the button.
SetColorText | This member function sets the default text color for the button.
SetThemeFont | This member function is used to set the font used by the button
ShowIcon | Call this member function to enable or disable icon display for the button.
UseWinXPThemes | This member function is called to determine if the button should be drawn using Windows XP themes.


CXTButtonTheme Data Members

CXTButtonTheme Class, Legend, Protected Data Members
CXTButtonTheme Data Members
Class

CXTButtonTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bOffsetHiliteText | TRUE if highlighted text is animated.
m_bShowIcon | TRUE if the buttons displays an icon.
m_crBack | RGB value for background color.
m_crBorder3DHilite | RGB value for 3D border highlight color.
m_crBorder3DShadow | RGB value for 3D border shadow color.
m_crBorderHilite | RGB value for border highlight color.
m_crBorderShadow | RGB value for border shadow color.
m_crText | RGB value for text color.
m_crTextDisabled | RGB value for disabled text color.
m_pFont | Points to a user defined font for the theme.
m_themeWrapper | Wraps the Windows XP theme API that is used to display Windows XP themes.


CXTButtonTheme::m_bOffsetHiliteText Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_bOffsetHiliteText Data Member

TRUE if highlighted text is animated.

BOOL m_bOffsetHiliteText;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_bShowIcon Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_bShowIcon Data Member

TRUE if the buttons displays an icon.

BOOL m_bShowIcon;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_crBack Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_crBack Data Member

RGB value for background color.

CXTPPaintManagerColor m_crBack;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_crBorder3DHilite Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_crBorder3DHilite Data Member

RGB value for 3D border highlight color.

CXTPPaintManagerColor m_crBorder3DHilite;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_crBorder3DShadow Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_crBorder3DShadow Data Member

RGB value for 3D border shadow color.

CXTPPaintManagerColor m_crBorder3DShadow;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_crBorderHilite Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_crBorderHilite Data Member

RGB value for border highlight color.

CXTPPaintManagerColor m_crBorderHilite;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_crBorderShadow Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_crBorderShadow Data Member

RGB value for border shadow color.

CXTPPaintManagerColor m_crBorderShadow;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_crText Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_crText Data Member

RGB value for text color.

CXTPPaintManagerColor m_crText;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_crTextDisabled Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_crTextDisabled Data Member

RGB value for disabled text color.

CXTPPaintManagerColor m_crTextDisabled;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_pFont Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_pFont Data Member

Points to a user defined font for the theme.

CFont* m_pFont;
Group

CXTButtonTheme Data Members


CXTButtonTheme::m_themeWrapper Data Member

CXTButtonTheme Data Members, CXTButtonTheme Class
CXTButtonTheme::m_themeWrapper Data Member

Wraps the Windows XP theme API that is used to display Windows XP themes.

CXTPWinThemeWrapper m_themeWrapper;
Group

CXTButtonTheme Data Members


CXTButtonTheme Methods

CXTButtonTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonTheme Methods
Class

CXTButtonTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalculateImagePosition | This member function is called to determine the location for the image displayed for the button.
DrawButtonIcon | This member function draws the icon for the button, if one has been defined.
DrawButtonText | This member function is called to draw the text for the button.
DrawButtonThemeBackground | This member function is called to draw the background for the button.
DrawFocusRect | This member function is called to draw the focus rectangle for the button.
DrawItem | This member function is called to draw the button.
DrawWinThemeBackground | This member function is called to draw the Windows XP theme background for the button.
GetTextColor | Call this member function to return the color used to draw the button text.
GetTextPosition | This member function is called to determine the location of the text displayed for the button.
OffsetPoint | This member function will set the proper XY coordinates for the button text and image.
Public Methods
Public Methods
Public Method | Description
CanHilite | This member function is used to determine if the button should displayed raised borders on mouse over.
GetColorFace | This member function gets the current face color.
GetThemeFont | This member function is used to return a pointer the font used by the button to display text.
GetThemeWrapper | Call this member function to return a pointer to the Windows theme API wrapper for this control.
IsIconVisible | Call this member function to determine if icons are displayed for the button.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.
SetAlternateColors | This method will allow the user to define the default colors for the background shadow and highlight colors for the button.
SetColorFace | This member function sets the default face color for the button.
SetColorHilite | This member function sets the default highlight color for the button.
SetColorShadow | This member function sets the default shadow color for the button.
SetColorText | This member function sets the default text color for the button.
SetThemeFont | This member function is used to set the font used by the button
ShowIcon | Call this member function to enable or disable icon display for the button.
UseWinXPThemes | This member function is called to determine if the button should be drawn using Windows XP themes.


CXTButtonTheme::CalculateImagePosition Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::CalculateImagePosition Method

This member function is called to determine the location for the image displayed for the button.

virtual CPoint CalculateImagePosition(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    bool bHasPushedImage,
    CXTButton* pButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
nState
A UINT value that represents the current state for the button.
rcItem
A CRect reference that represents the current size for the button.
bHasPushedImage
Indicates if the button has a separate image for the pushed state.
pButton
Points to a CXTButton object.

Returns

A CPoint object that represents the x-y location for the button image.

Group

CXTButtonTheme Methods


CXTButtonTheme::CanHilite Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::CanHilite Method

This member function is used to determine if the button should displayed raised borders on mouse over.

virtual BOOL CanHilite(
    CXTButton* pButton
);
Parameters

pButton
Points to a CXTButton object.

Returns

TRUE if the button can display border highlights, otherwise returns FALSE.

Group

CXTButtonTheme Methods


CXTButtonTheme::DrawButtonIcon Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::DrawButtonIcon Method

This member function draws the icon for the button, if one has been defined.

virtual void DrawButtonIcon(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
nState
A UINT value that represents the current state for the button.
rcItem
A CRect reference that represents the current size for the button.
pButton
Points to a CXTButton object.

Group

CXTButtonTheme Methods


CXTButtonTheme::DrawButtonText Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::DrawButtonText Method

This member function is called to draw the text for the button.

virtual void DrawButtonText(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
nState
A UINT value that represents the current state for the button.
rcItem
A CRect reference that represents the current size for the button.
pButton
Points to a CXTButton object.

Group

CXTButtonTheme Methods


CXTButtonTheme::DrawButtonThemeBackground Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::DrawButtonThemeBackground Method

This member function is called to draw the background for the button.

virtual BOOL DrawButtonThemeBackground(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pButton
Points to a CXTButton object.

Returns

TRUE if the background was drawn successfully, otherwise returns FALSE.

Group

CXTButtonTheme Methods


CXTButtonTheme::DrawFocusRect Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::DrawFocusRect Method

This member function is called to draw the focus rectangle for the button.

virtual void DrawFocusRect(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
nState
A UINT value that represents the current state for the button.
rcItem
A CRect reference that represents the current size for the button.
pButton
Points to a CXTButton object.

Group

CXTButtonTheme Methods


CXTButtonTheme::DrawItem Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::DrawItem Method

This member function is called to draw the button.

virtual void DrawItem(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pButton
Points to a CXTButton object.

Group

CXTButtonTheme Methods


CXTButtonTheme::DrawWinThemeBackground Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::DrawWinThemeBackground Method

This member function is called to draw the Windows XP theme background for the button.

virtual BOOL DrawWinThemeBackground(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pButton
Points to a CXTButton object.

Returns

TRUE if the background was drawn successfully, otherwise returns FALSE.

Group

CXTButtonTheme Methods


CXTButtonTheme::GetColorFace Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::GetColorFace Method

This member function gets the current face color.

virtual COLORREF GetColorFace();
Returns

An RGB value that represents the current face color.

Group

CXTButtonTheme Methods


CXTButtonTheme::GetTextColor Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::GetTextColor Method

Call this member function to return the color used to draw the button text.

virtual COLORREF GetTextColor(
    UINT nState,
    CXTButton* pButton
);
Parameters

nState
A UINT value that represents the current state for the button.
pButton
Points to a CXTButton object.

Returns

An RGB value that represents the button text color.

Group

CXTButtonTheme Methods


CXTButtonTheme::GetTextPosition Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::GetTextPosition Method

This member function is called to determine the location of the text displayed for the button.

virtual CPoint GetTextPosition(
    UINT nState,
    CRect& rcItem,
    CSize& sizeText,
    CXTButton* pButton
);
Parameters

nState
A UINT value that represents the current state for the button.
rcItem
A CRect object that represents the current size for the button.
sizeText
A CSize object that represents the current size for the button text.
pButton
Points to a CXTButton object.

Returns

A CPoint object that represents the x-y location for the button text.

Group

CXTButtonTheme Methods


CXTButtonTheme::GetThemeFont Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::GetThemeFont Method

This member function is used to return a pointer the font used by the button to display text.

virtual CFont* GetThemeFont(
    CXTButton* pButton
) const;
Parameters

pButton
Points to a CXTButton object.

Returns

A CFont object that represents the font used to display text for the button if successful, otherwise NULL.

Group

CXTButtonTheme Methods


CXTButtonTheme::GetThemeWrapper Method

CXTButtonTheme Methods, CXTButtonTheme Class, Body Source
CXTButtonTheme::GetThemeWrapper Method

Call this member function to return a pointer to the Windows theme API wrapper for this control.

CXTPWinThemeWrapper* GetThemeWrapper();
Returns

A CXTPWinThemeWrapper pointer.

Body Source
CXTPWinThemeWrapper* CXTButtonTheme::GetThemeWrapper() {
    return &m_themeWrapper;
}
Group

CXTButtonTheme Methods


CXTButtonTheme::IsIconVisible Method

CXTButtonTheme Methods, CXTButtonTheme Class, Body Source
CXTButtonTheme::IsIconVisible Method

Call this member function to determine if icons are displayed for the button.

virtual BOOL IsIconVisible() const;
Returns

TRUE if icons are displayed, otherwise FALSE.

Body Source
BOOL CXTButtonTheme::IsIconVisible() const {
    return m_bShowIcon;
}
Group

CXTButtonTheme Methods


CXTButtonTheme::OffsetPoint Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::OffsetPoint Method

This member function will set the proper XY coordinates for the button text and image.

virtual void OffsetPoint(
    CPoint& point,
    CSize size,
    CXTButton* pButton
);
Parameters

point
XY location of the text and image that are displayed.
size
Initial size of the image associated with the button.
pButton
Points to a CXTButton object.

Group

CXTButtonTheme Methods


CXTButtonTheme::RefreshMetrics Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::RefreshMetrics Method

This member function is called by the theme manager to refresh the visual styles used by each components theme.

virtual void RefreshMetrics();
Group

CXTButtonTheme Methods


CXTButtonTheme::SetAlternateColors Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::SetAlternateColors Method

This method will allow the user to define the default colors for the background shadow and highlight colors for the button.

virtual void SetAlternateColors(
    COLORREF clr3DFace,
    COLORREF clr3DHilight,
    COLORREF clr3DShadow,
    COLORREF clrBtnText
);
Parameters

clr3DFace
An RGB value that represents the user defined face color for three dimensional display elements.
clr3DHilight
An RGB value that represents the user defined highlight color for three dimensional display elements (edges facing the light source.)
clr3DShadow
An RGB value that represents the user defined shadow color for three dimensional display elements (edges facing away from the light source).
clrBtnText
An RGB value that represents the user defined text color on push buttons.

Group

CXTButtonTheme Methods


CXTButtonTheme::SetColorFace Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::SetColorFace Method

This member function sets the default face color for the button.

virtual void SetColorFace(
    COLORREF clrFace
);
Parameters

clrFace
An RGB value that represents the user defined face color.

Group

CXTButtonTheme Methods


CXTButtonTheme::SetColorHilite Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::SetColorHilite Method

This member function sets the default highlight color for the button.

virtual void SetColorHilite(
    COLORREF clrHilite
);
Parameters

clrHilite
An RGB value that represents the user defined highlight color.

Group

CXTButtonTheme Methods


CXTButtonTheme::SetColorShadow Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::SetColorShadow Method

This member function sets the default shadow color for the button.

virtual void SetColorShadow(
    COLORREF clrShadow
);
Parameters

clrShadow
An RGB value that represents the user defined shadow color.

Group

CXTButtonTheme Methods


CXTButtonTheme::SetColorText Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::SetColorText Method

This member function sets the default text color for the button.

virtual void SetColorText(
    COLORREF clrText
);
Parameters

clrText
An RGB value that represents the user defined text color.

Group

CXTButtonTheme Methods


CXTButtonTheme::SetThemeFont Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::SetThemeFont Method

This member function is used to set the font used by the button

virtual void SetThemeFont(
    CFont* pFont
);
Parameters

pFont
Points to a CFont object.

Group

CXTButtonTheme Methods


CXTButtonTheme::ShowIcon Method

CXTButtonTheme Methods, CXTButtonTheme Class, Body Source
CXTButtonTheme::ShowIcon Method

Call this member function to enable or disable icon display for the button.

virtual void ShowIcon(
    BOOL bShowIcon
);
Parameters

bShowIcon
TRUE to display button icon.

Body Source
void CXTButtonTheme::ShowIcon(BOOL bShowIcon) {
    m_bShowIcon = bShowIcon;
}
Group

CXTButtonTheme Methods


CXTButtonTheme::UseWinXPThemes Method

CXTButtonTheme Methods, CXTButtonTheme Class
CXTButtonTheme::UseWinXPThemes Method

This member function is called to determine if the button should be drawn using Windows XP themes.

virtual BOOL UseWinXPThemes(
    CXTButton* pButton
);
Parameters

pButton
Points to a CXTButton object.

Returns

TRUE if the button is to be drawn using Windows XP themes, otherwise FALSE.

Group

CXTButtonTheme Methods


CXTButtonTheme Constructors

CXTButtonTheme Class, Legend, Public Methods
CXTButtonTheme Constructors
Class

CXTButtonTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTButtonTheme | Constructs a CXTButtonTheme object.


CXTButtonTheme::CXTButtonTheme Constructor

CXTButtonTheme Constructors, CXTButtonTheme Class
CXTButtonTheme::CXTButtonTheme Constructor

Constructs a CXTButtonTheme object.

CXTButtonTheme();
Group

CXTButtonTheme Constructors


CXTButtonTheme Destructors

CXTButtonTheme Class, Legend, Public Methods
CXTButtonTheme Destructors
Class

CXTButtonTheme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTButtonTheme | Destroys a CXTButtonTheme object, handles cleanup and deallocation.


CXTButtonTheme::~CXTButtonTheme Destructor

CXTButtonTheme Destructors, CXTButtonTheme Class
CXTButtonTheme::~CXTButtonTheme Destructor

Destroys a CXTButtonTheme object, handles cleanup and deallocation.

virtual ~CXTButtonTheme();
Group

CXTButtonTheme Destructors


CXTButtonThemeOffice2003 Class

XTButtonTheme.h, Classes, Legend, Members, Topics, CXTButtonThemeOffice2003 Methods, CXTButtonThemeOffice2003 Constructors, CXTButtonThemeOffice2003 Constructors, CXTButtonThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOffice2003 Class

CXTButtonThemeOffice2003 is a CXTButtonThemeOfficeXP derived class that is used to draw an Office 2003 style theme for the button.

Class Hierarchy

class CXTButtonThemeOffice2003 : public CXTButtonThemeOfficeXP;
File

XTButtonTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTButtonThemeOffice2003 Constructors
CXTButtonThemeOffice2003 Constructors | Description
CXTButtonThemeOffice2003 | Constructs a CXTButtonThemeOfficeXP object.
CXTButtonThemeOffice2003 Methods
CXTButtonThemeOffice2003 Methods | Description
DrawButtonIcon | This member function draws the icon for the button, if one has been defined.
DrawButtonThemeBackground | This member function is called to draw the background for the button.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTButtonThemeOffice2003 Methods

CXTButtonThemeOffice2003 Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOffice2003 Methods
Class

CXTButtonThemeOffice2003 Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawButtonIcon | This member function draws the icon for the button, if one has been defined.
DrawButtonThemeBackground | This member function is called to draw the background for the button.
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTButtonThemeOffice2003::DrawButtonIcon Method

CXTButtonThemeOffice2003 Methods, CXTButtonThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOffice2003::DrawButtonIcon Method

This member function draws the icon for the button, if one has been defined.

virtual void DrawButtonIcon(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
nState
A UINT value that represents the current state for the button.
rcItem
A CRect reference that represents the current size for the button.
pButton
Points to a CXTButton object.

Group

CXTButtonThemeOffice2003 Methods


CXTButtonThemeOffice2003::DrawButtonThemeBackground Method

CXTButtonThemeOffice2003 Methods, CXTButtonThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOffice2003::DrawButtonThemeBackground Method

This member function is called to draw the background for the button.

virtual BOOL DrawButtonThemeBackground(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pButton
Points to a CXTButton object.

Returns

TRUE if the background was drawn successfully, otherwise returns FALSE.

Group

CXTButtonThemeOffice2003 Methods


CXTButtonThemeOffice2003::RefreshMetrics Method

CXTButtonThemeOffice2003 Methods, CXTButtonThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOffice2003::RefreshMetrics Method

This member function is called by the theme manager to refresh the visual styles used by each components theme.

virtual void RefreshMetrics();
Group

CXTButtonThemeOffice2003 Methods


CXTButtonThemeOffice2003 Constructors

CXTButtonThemeOffice2003 Class, Legend, Public Methods
CXTButtonThemeOffice2003 Constructors
Class

CXTButtonThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTButtonThemeOffice2003 | Constructs a CXTButtonThemeOfficeXP object.


CXTButtonThemeOffice2003::CXTButtonThemeOffice2003 Constructor

CXTButtonThemeOffice2003 Constructors, CXTButtonThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOffice2003::CXTButtonThemeOffice2003 Constructor

Constructs a CXTButtonThemeOfficeXP object.

CXTButtonThemeOffice2003(
    BOOL bWordTheme = FALSE
);
Parameters

bWordTheme
TRUE to use the MS Word style theme to draw the border and focus rectangle for the button.

Group

CXTButtonThemeOffice2003 Constructors


CXTButtonThemeOfficeXP Class

XTButtonTheme.h, Classes, Legend, Members, Topics, CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Constructors, CXTButtonThemeOfficeXP Destructors, CXTButtonThemeOfficeXP Constructors, CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Destructors, CXTButtonThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP Class

CXTButtonThemeOfficeXP is a CXTButtonTheme derived class that is used to draw an Office XP style theme for the button.

Class Hierarchy

class CXTButtonThemeOfficeXP : public CXTButtonTheme;
File

XTButtonTheme.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTButtonThemeOfficeXP Constructors
CXTButtonThemeOfficeXP Constructors | Description
CXTButtonThemeOfficeXP | Constructs a CXTButtonThemeOfficeXP object.
CXTButtonThemeOfficeXP Data Members
CXTButtonThemeOfficeXP Data Members | Description
m_bAnimateIcon | TRUE if the button animates on mouse over.
m_bFadedIcon | TRUE if the button uses faded icons.
m_bWordTheme | TRUE if MS Word theme is used.
m_crBackChecked | RGB value for when the control is checked.
m_crBackHilite | RGB value for highlighted background color.
m_crBackPushed | RGB value for pushed background color.
m_crTextHilite | RGB value for pushed text color.
m_crTextPushed | RGB value for highlighted text color.
CXTButtonThemeOfficeXP Destructors
CXTButtonThemeOfficeXP Destructors | Description
~CXTButtonThemeOfficeXP | Destroys a CXTButtonThemeOfficeXP object, handles cleanup and deallocation.
CXTButtonThemeOfficeXP Methods
CXTButtonThemeOfficeXP Methods | Description
CanHilite | This member function is used to determine if the button should displayed raised borders on mouse over.
DrawButtonIcon | This member function draws the icon for the button, if one has been defined.
DrawButtonThemeBackground | This member function is called to draw the background for the button.
DrawFocusRect | This member function is called to draw the focus rectangle for the button.
GetTextColor | Call this member function to return the color used to draw the button text.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.
SetBackHiliteColor | Call this member function to set the highlight background color.
SetBackPushedColor | Call this member function to set the pushed background color.
SetTextHiliteColor | Call this member function to set the SetAlternateColors text color.
SetTextPushedColor | Call this member function to set the pushed text color.
UseWordTheme | Call this member function to enable or disable MS Word style theme for the button.


CXTButtonThemeOfficeXP Data Members

CXTButtonThemeOfficeXP Class, Legend, Protected Data Members
CXTButtonThemeOfficeXP Data Members
Class

CXTButtonThemeOfficeXP Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAnimateIcon | TRUE if the button animates on mouse over.
m_bFadedIcon | TRUE if the button uses faded icons.
m_bWordTheme | TRUE if MS Word theme is used.
m_crBackChecked | RGB value for when the control is checked.
m_crBackHilite | RGB value for highlighted background color.
m_crBackPushed | RGB value for pushed background color.
m_crTextHilite | RGB value for pushed text color.
m_crTextPushed | RGB value for highlighted text color.


CXTButtonThemeOfficeXP::m_bAnimateIcon Data Member

CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::m_bAnimateIcon Data Member

TRUE if the button animates on mouse over.

BOOL m_bAnimateIcon;
Group

CXTButtonThemeOfficeXP Data Members


CXTButtonThemeOfficeXP::m_bFadedIcon Data Member

CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::m_bFadedIcon Data Member

TRUE if the button uses faded icons.

BOOL m_bFadedIcon;
Group

CXTButtonThemeOfficeXP Data Members


CXTButtonThemeOfficeXP::m_bWordTheme Data Member

CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::m_bWordTheme Data Member

TRUE if MS Word theme is used.

BOOL m_bWordTheme;
Group

CXTButtonThemeOfficeXP Data Members


CXTButtonThemeOfficeXP::m_crBackChecked Data Member

CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::m_crBackChecked Data Member

RGB value for when the control is checked.

CXTPPaintManagerColor m_crBackChecked;
Group

CXTButtonThemeOfficeXP Data Members


CXTButtonThemeOfficeXP::m_crBackHilite Data Member

CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::m_crBackHilite Data Member

RGB value for highlighted background color.

CXTPPaintManagerColor m_crBackHilite;
Group

CXTButtonThemeOfficeXP Data Members


CXTButtonThemeOfficeXP::m_crBackPushed Data Member

CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::m_crBackPushed Data Member

RGB value for pushed background color.

CXTPPaintManagerColor m_crBackPushed;
Group

CXTButtonThemeOfficeXP Data Members


CXTButtonThemeOfficeXP::m_crTextHilite Data Member

CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::m_crTextHilite Data Member

RGB value for pushed text color.

CXTPPaintManagerColor m_crTextHilite;
Group

CXTButtonThemeOfficeXP Data Members


CXTButtonThemeOfficeXP::m_crTextPushed Data Member

CXTButtonThemeOfficeXP Data Members, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::m_crTextPushed Data Member

RGB value for highlighted text color.

CXTPPaintManagerColor m_crTextPushed;
Group

CXTButtonThemeOfficeXP Data Members


CXTButtonThemeOfficeXP Methods

CXTButtonThemeOfficeXP Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP Methods
Class

CXTButtonThemeOfficeXP Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawButtonIcon | This member function draws the icon for the button, if one has been defined.
DrawButtonThemeBackground | This member function is called to draw the background for the button.
DrawFocusRect | This member function is called to draw the focus rectangle for the button.
GetTextColor | Call this member function to return the color used to draw the button text.
Public Methods
Public Methods
Public Method | Description
CanHilite | This member function is used to determine if the button should displayed raised borders on mouse over.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.
SetBackHiliteColor | Call this member function to set the highlight background color.
SetBackPushedColor | Call this member function to set the pushed background color.
SetTextHiliteColor | Call this member function to set the SetAlternateColors text color.
SetTextPushedColor | Call this member function to set the pushed text color.
UseWordTheme | Call this member function to enable or disable MS Word style theme for the button.


CXTButtonThemeOfficeXP::CanHilite Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::CanHilite Method

This member function is used to determine if the button should displayed raised borders on mouse over.

virtual BOOL CanHilite(
    CXTButton* pButton
);
Parameters

pButton
Points to a CXTButton object.

Returns

TRUE if the button can display border highlights, otherwise returns FALSE.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::DrawButtonIcon Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::DrawButtonIcon Method

This member function draws the icon for the button, if one has been defined.

virtual void DrawButtonIcon(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
nState
A UINT value that represents the current state for the button.
rcItem
A CRect reference that represents the current size for the button.
pButton
Points to a CXTButton object.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::DrawButtonThemeBackground Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::DrawButtonThemeBackground Method

This member function is called to draw the background for the button.

virtual BOOL DrawButtonThemeBackground(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pButton
Points to a CXTButton object.

Returns

TRUE if the background was drawn successfully, otherwise returns FALSE.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::DrawFocusRect Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::DrawFocusRect Method

This member function is called to draw the focus rectangle for the button.

virtual void DrawFocusRect(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
nState
A UINT value that represents the current state for the button.
rcItem
A CRect reference that represents the current size for the button.
pButton
Points to a CXTButton object.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::GetTextColor Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::GetTextColor Method

Call this member function to return the color used to draw the button text.

virtual COLORREF GetTextColor(
    UINT nState,
    CXTButton* pButton
);
Parameters

nState
A UINT value that represents the current state for the button.
pButton
Points to a CXTButton object.

Returns

An RGB value that represents the button text color.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::RefreshMetrics Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::RefreshMetrics Method

This member function is called by the theme manager to refresh the visual styles used by each components theme.

virtual void RefreshMetrics();
Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::SetBackHiliteColor Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::SetBackHiliteColor Method

Call this member function to set the highlight background color.

virtual void SetBackHiliteColor(
    COLORREF color
);
Parameters

color
RGB color value.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::SetBackPushedColor Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::SetBackPushedColor Method

Call this member function to set the pushed background color.

virtual void SetBackPushedColor(
    COLORREF color
);
Parameters

color
RGB color value.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::SetTextHiliteColor Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::SetTextHiliteColor Method

Call this member function to set the SetAlternateColors text color.

virtual void SetTextHiliteColor(
    COLORREF color
);
Parameters

color
RGB color value.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::SetTextPushedColor Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class
CXTButtonThemeOfficeXP::SetTextPushedColor Method

Call this member function to set the pushed text color.

virtual void SetTextPushedColor(
    COLORREF color
);
Parameters

color
RGB color value.

Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP::UseWordTheme Method

CXTButtonThemeOfficeXP Methods, CXTButtonThemeOfficeXP Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::UseWordTheme Method

Call this member function to enable or disable MS Word style theme for the button.

virtual void UseWordTheme(
    BOOL bWordTheme
);
Parameters

bWordTheme
TRUE to use the MS Word style theme to draw the border and focus rectangle for the button.

Body Source
void CXTButtonThemeOfficeXP::UseWordTheme(BOOL bWordTheme) {
    m_bWordTheme = bWordTheme;
    RefreshMetrics();
}
Group

CXTButtonThemeOfficeXP Methods


CXTButtonThemeOfficeXP Constructors

CXTButtonThemeOfficeXP Class, Legend, Public Methods
CXTButtonThemeOfficeXP Constructors
Class

CXTButtonThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTButtonThemeOfficeXP | Constructs a CXTButtonThemeOfficeXP object.


CXTButtonThemeOfficeXP::CXTButtonThemeOfficeXP Constructor

CXTButtonThemeOfficeXP Constructors, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::CXTButtonThemeOfficeXP Constructor

Constructs a CXTButtonThemeOfficeXP object.

CXTButtonThemeOfficeXP(
    BOOL bWordTheme = FALSE
);
Parameters

bWordTheme
TRUE to use the MS Word style theme to draw the border and focus rectangle for the button.

Group

CXTButtonThemeOfficeXP Constructors


CXTButtonThemeOfficeXP Destructors

CXTButtonThemeOfficeXP Class, Legend, Public Methods
CXTButtonThemeOfficeXP Destructors
Class

CXTButtonThemeOfficeXP Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTButtonThemeOfficeXP | Destroys a CXTButtonThemeOfficeXP object, handles cleanup and deallocation.


CXTButtonThemeOfficeXP::~CXTButtonThemeOfficeXP Destructor

CXTButtonThemeOfficeXP Destructors, CXTButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTButtonThemeOfficeXP::~CXTButtonThemeOfficeXP Destructor

Destroys a CXTButtonThemeOfficeXP object, handles cleanup and deallocation.

virtual ~CXTButtonThemeOfficeXP();
Group

CXTButtonThemeOfficeXP Destructors


CXTCaption Class

XTCaption.h, Classes, Legend, Members, Topics, CXTCaption Data Members, CXTCaption Methods, CXTCaption Constructors, CXTCaption Destructors, CXTCaption Constructors, CXTCaption Data Members, CXTCaption Destructors, CXTCaption Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaption Class

CXTCaption is a CStatic derived class. It is used to create caption or info bars similar to those in Microsoft(r) Outlook.

Class Hierarchy

class CXTCaption : public CStatic;
File

XTCaption.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTCaption Constructors
CXTCaption Constructors | Description
CXTCaption | Constructs a CXTCaption object
CXTCaption Data Members
CXTCaption Data Members | Description
m_bAppCaption | true if the caption is used as the application's primary caption.
m_btnCaption | Button used to 'tack' the popup window back in place.
m_bUserColors | true if the user has specified caption colors other than the default.
m_dwExStyle | Border style bits, either CPWS_EX_GROOVE_EDGE | CPWS_EX_RAISED_EDGE.
m_hIcon | User defined icon handle.
m_ilButton | Image list used to create the close button icon.
m_nBorder | Size in pixels for the caption border.
m_nOffset | Size in pixels that the child window should leave for its caption area.
m_pChildWnd | A CWnd pointer that represents the child window displayed in the popup window.
m_pParentView | A CWnd pointer that represents the child window's parent view.
m_pPopupWnd | Points to the popup window.
m_pSplitterWnd | A CWnd pointer that represents the splitter window.
m_rcChild | Size of the child window displayed in the popup.
m_rcParent | Size of the child's parent view.
m_rcSplitter | Size of the splitter window.
m_sizeIcon | Width and height of the caption icon area.
m_strCaption | Text that will be displayed in the caption.
CXTCaption Destructors
CXTCaption Destructors | Description
~CXTCaption | Destroys a CXTCaption object, handles cleanup and deallocation
CXTCaption Methods
CXTCaption Methods | Description
Create | Creates and initializes the child window associated with the CXTCaption object.
DrawCaptionBack | This member function is called to draw the caption background.
DrawCaptionIcon | This member function is called to paint the caption icon.
DrawCaptionText | This member function is called to paint the caption text.
GetButtonRect | This member function is called to determine the size and location of the button associated with the caption.
GetCaptionButton | Call this member function to get a reference to the caption's close / popup button.
GetCaptionStyle | Call this member function to return the current style settings for the caption.
GetCaptionText | This member function retrieves the current caption title.
GetTextRect | This member function is called to determine the size and location of the text associated with the caption.
HasCloseButton | Call this member function to see if the caption has a close button.
IsAppCaption | This member function is called to determine if the caption is configured to be used as the application's primary caption.
KillChildWindow | This member function is called to destroy the popup window and associated children.
ModifyCaptionStyle | Modifies the caption title and appearance.
RefreshButton | This member function is called to refresh the caption button style.
SetAppCaption | This member function is called to set the flag that indicates if the caption is the application's primary caption.
SetCaptionColors | This member function will set the caption bar border, background, and font colors.
SetChildWindow | Call this member function to set the child and notification windows for the caption bar.
SetOffice2003Colors | Call this member function to enable Office 2003 visualizations.
ShowPopupWindow | This member function is called to display the popup window and associated children.
UpdateCaption | This member function is called to update the text and icon for the caption bar.
UpdateCaptionText | This member function is called to update the caption text.


CXTCaption Data Members

CXTCaption Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaption Data Members
Class

CXTCaption Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAppCaption | true if the caption is used as the application's primary caption.
m_btnCaption | Button used to 'tack' the popup window back in place.
m_bUserColors | true if the user has specified caption colors other than the default.
m_dwExStyle | Border style bits, either CPWS_EX_GROOVE_EDGE | CPWS_EX_RAISED_EDGE.
m_hIcon | User defined icon handle.
m_ilButton | Image list used to create the close button icon.
m_nOffset | Size in pixels that the child window should leave for its caption area.
m_pChildWnd | A CWnd pointer that represents the child window displayed in the popup window.
m_pParentView | A CWnd pointer that represents the child window's parent view.
m_pPopupWnd | Points to the popup window.
m_pSplitterWnd | A CWnd pointer that represents the splitter window.
m_rcChild | Size of the child window displayed in the popup.
m_rcParent | Size of the child's parent view.
m_rcSplitter | Size of the splitter window.
m_sizeIcon | Width and height of the caption icon area.
m_strCaption | Text that will be displayed in the caption.
Public Data Members
Public Data Member | Description
m_nBorder | Size in pixels for the caption border.


CXTCaption::m_bAppCaption Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_bAppCaption Data Member

true if the caption is used as the application's primary caption.

bool m_bAppCaption;
Group

CXTCaption Data Members


CXTCaption::m_btnCaption Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_btnCaption Data Member

Button used to 'tack' the popup window back in place.

CXTCaptionButton m_btnCaption;
Group

CXTCaption Data Members


CXTCaption::m_bUserColors Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_bUserColors Data Member

true if the user has specified caption colors other than the default.

bool m_bUserColors;
Group

CXTCaption Data Members


CXTCaption::m_dwExStyle Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_dwExStyle Data Member

Border style bits, either CPWS_EX_GROOVE_EDGE | CPWS_EX_RAISED_EDGE.

DWORD m_dwExStyle;
Group

CXTCaption Data Members


CXTCaption::m_hIcon Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_hIcon Data Member

User defined icon handle.

HICON m_hIcon;
Group

CXTCaption Data Members


CXTCaption::m_ilButton Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_ilButton Data Member

Image list used to create the close button icon.

CImageList m_ilButton;
Group

CXTCaption Data Members


CXTCaption::m_nBorder Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_nBorder Data Member

Size in pixels for the caption border.

int m_nBorder;
Group

CXTCaption Data Members


CXTCaption::m_nOffset Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_nOffset Data Member

Size in pixels that the child window should leave for its caption area.

int m_nOffset;
Group

CXTCaption Data Members


CXTCaption::m_pChildWnd Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_pChildWnd Data Member

A CWnd pointer that represents the child window displayed in the popup window.

CWnd* m_pChildWnd;
Group

CXTCaption Data Members


CXTCaption::m_pParentView Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_pParentView Data Member

A CWnd pointer that represents the child window's parent view.

CWnd* m_pParentView;
Group

CXTCaption Data Members


CXTCaption::m_pPopupWnd Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_pPopupWnd Data Member

Points to the popup window.

CXTCaptionPopupWnd* m_pPopupWnd;
Group

CXTCaption Data Members


CXTCaption::m_pSplitterWnd Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_pSplitterWnd Data Member

A CWnd pointer that represents the splitter window.

CWnd* m_pSplitterWnd;
Group

CXTCaption Data Members


CXTCaption::m_rcChild Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_rcChild Data Member

Size of the child window displayed in the popup.

CRect m_rcChild;
Group

CXTCaption Data Members


CXTCaption::m_rcParent Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_rcParent Data Member

Size of the child's parent view.

CRect m_rcParent;
Group

CXTCaption Data Members


CXTCaption::m_rcSplitter Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_rcSplitter Data Member

Size of the splitter window.

CRect m_rcSplitter;
Group

CXTCaption Data Members


CXTCaption::m_sizeIcon Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_sizeIcon Data Member

Width and height of the caption icon area.

CSize m_sizeIcon;
Group

CXTCaption Data Members


CXTCaption::m_strCaption Data Member

CXTCaption Data Members, CXTCaption Class
CXTCaption::m_strCaption Data Member

Text that will be displayed in the caption.

CString m_strCaption;
Group

CXTCaption Data Members


CXTCaption Methods

CXTCaption Class, Legend, Protected Methods, Public Methods
CXTCaption Methods
Class

CXTCaption Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionBack | This member function is called to draw the caption background.
DrawCaptionIcon | This member function is called to paint the caption icon.
DrawCaptionText | This member function is called to paint the caption text.
GetButtonRect | This member function is called to determine the size and location of the button associated with the caption.
UpdateCaptionText | This member function is called to update the caption text.
Public Methods
Public Methods
Public Method | Description
Create | Creates and initializes the child window associated with the CXTCaption object.
GetCaptionButton | Call this member function to get a reference to the caption's close / popup button.
GetCaptionStyle | Call this member function to return the current style settings for the caption.
GetCaptionText | This member function retrieves the current caption title.
GetTextRect | This member function is called to determine the size and location of the text associated with the caption.
HasCloseButton | Call this member function to see if the caption has a close button.
IsAppCaption | This member function is called to determine if the caption is configured to be used as the application's primary caption.
KillChildWindow | This member function is called to destroy the popup window and associated children.
ModifyCaptionStyle | Modifies the caption title and appearance.
RefreshButton | This member function is called to refresh the caption button style.
SetAppCaption | This member function is called to set the flag that indicates if the caption is the application's primary caption.
SetCaptionColors | This member function will set the caption bar border, background, and font colors.
SetChildWindow | Call this member function to set the child and notification windows for the caption bar.
SetOffice2003Colors | Call this member function to enable Office 2003 visualizations.
ShowPopupWindow | This member function is called to display the popup window and associated children.
UpdateCaption | This member function is called to update the text and icon for the caption bar.


CXTCaption::Create Method

CXTCaption Methods, CXTCaption Class
CXTCaption::Create Method

Creates and initializes the child window associated with the CXTCaption object.

virtual BOOL Create(
    CWnd* pParentWnd,
    LPCTSTR lpszWindowName,
    DWORD dwExStyle = CPWS_EX_RAISED_EDGE,
    DWORD dwStyle = WS_VISIBLE | SS_CENTER | SS_CENTERIMAGE,
    const CRect& rect = CRect(0, 0, 0, 0),
    UINT nID = 0xffff
);
Parameters

pParentWnd
Specifies the parent window.
lpszWindowName
Points to a NULL terminated character string that contains the window name. This will be displayed in the caption area.
dwExStyle
Specifies caption bar style. See the Remarks section below for a complete list of available styles.
dwStyle
Specifies the control window style. Apply any combination of caption bar styles to the control.
rect
Specifies the position and size of the caption bar. It can be either a RECT structure or a CRect object.
nID
Specifies the caption bar control ID.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

This method creates a caption bar window and attaches it to the CXTCaption object. You construct a caption bar in two steps. First, call the constructor, which constructs the CXTCaption object. Then call Create, which creates the Window's child window and attaches it to CXTCaption. Create initializes the window class name and window name and registers values for its style, parent, and ID.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • CPWS_EX_GROOVE_EDGE Show the caption with a sunken border.
  • CPWS_EX_RAISED_EDGE Show the caption with a raised 3D border.
  • CPWS_EX_CLOSEBUTTON Caption has a close button.
Group

CXTCaption Methods


CXTCaption::DrawCaptionBack Method

CXTCaption Methods, CXTCaption Class
CXTCaption::DrawCaptionBack Method

This member function is called to draw the caption background.

virtual void DrawCaptionBack(
    CDC* pDC,
    CRect& rcItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
rcItem
A CRect reference that represents the size of the area to paint.

Group

CXTCaption Methods


CXTCaption::DrawCaptionIcon Method

CXTCaption Methods, CXTCaption Class
CXTCaption::DrawCaptionIcon Method

This member function is called to paint the caption icon.

virtual void DrawCaptionIcon(
    CDC* pDC,
    CRect& rcItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
rcItem
A CRect reference that represents the size of the area to paint.

Group

CXTCaption Methods


CXTCaption::DrawCaptionText Method

CXTCaption Methods, CXTCaption Class
CXTCaption::DrawCaptionText Method

This member function is called to paint the caption text.

virtual void DrawCaptionText(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTCaption Methods


CXTCaption::GetButtonRect Method

CXTCaption Methods, CXTCaption Class
CXTCaption::GetButtonRect Method

This member function is called to determine the size and location of the button associated with the caption.

virtual CRect GetButtonRect() const;
Returns

The size and location of the caption button or an empty rect if no button is defined.

Group

CXTCaption Methods


CXTCaption::GetCaptionButton Method

CXTCaption Methods, CXTCaption Class, Body Source
CXTCaption::GetCaptionButton Method

Call this member function to get a reference to the caption's close / popup button.

CXTCaptionButton& GetCaptionButton();
Returns

A reference to a CXTCaptionButton object.

Body Source
CXTCaptionButton& CXTCaption::GetCaptionButton() {
    ASSERT(::IsWindow(m_btnCaption.m_hWnd)); return m_btnCaption;
}
Group

CXTCaption Methods


CXTCaption::GetCaptionStyle Method

CXTCaption Methods, CXTCaption Class, Body Source
CXTCaption::GetCaptionStyle Method

Call this member function to return the current style settings for the caption.

DWORD GetCaptionStyle() const;
Returns

A DWORD value that represents the current style set for the caption.

Body Source
DWORD CXTCaption::GetCaptionStyle() const {
    return m_dwExStyle;
}
Group

CXTCaption Methods


CXTCaption::GetCaptionText Method

CXTCaption Methods, CXTCaption Class, Body Source
CXTCaption::GetCaptionText Method

This member function retrieves the current caption title.

const CString& GetCaptionText();
Returns

A reference to a CString object that contains the caption title.

Body Source
const CString& CXTCaption::GetCaptionText() {
    return m_strCaption;
}
Group

CXTCaption Methods


CXTCaption::GetTextRect Method

CXTCaption Methods, CXTCaption Class
CXTCaption::GetTextRect Method

This member function is called to determine the size and location of the text associated with the caption.

virtual CRect GetTextRect() const;
Returns

The size and location of the caption text or an empty rect if no text is defined.

Group

CXTCaption Methods


CXTCaption::HasCloseButton Method

CXTCaption Methods, CXTCaption Class, Body Source
CXTCaption::HasCloseButton Method

Call this member function to see if the caption has a close button.

BOOL HasCloseButton() const;
Returns

TRUE if the caption contains a close button, otherwise FALSE.

Body Source
BOOL CXTCaption::HasCloseButton() const {
    return ((m_dwExStyle & CPWS_EX_CLOSEBUTTON) == CPWS_EX_CLOSEBUTTON);
}
Group

CXTCaption Methods


CXTCaption::IsAppCaption Method

CXTCaption Methods, CXTCaption Class, Body Source
CXTCaption::IsAppCaption Method

This member function is called to determine if the caption is configured to be used as the application's primary caption.

bool IsAppCaption() const;
Returns

true if the caption is configured to be used as the application's primary caption, otherwise false.

Body Source
bool IsAppCaption() const {
    return m_bAppCaption;
}
Group

CXTCaption Methods


CXTCaption::KillChildWindow Method

CXTCaption Methods, CXTCaption Class
CXTCaption::KillChildWindow Method

This member function is called to destroy the popup window and associated children.

virtual void KillChildWindow();
Group

CXTCaption Methods


CXTCaption::ModifyCaptionStyle Method

CXTCaption Methods, CXTCaption Class
CXTCaption::ModifyCaptionStyle Method

Modifies the caption title and appearance.

virtual void ModifyCaptionStyle(
    int nBorderSize,
    CFont* pFont = NULL,
    LPCTSTR lpszWindText = NULL,
    HICON hIcon = NULL
);
Parameters

nBorderSize
Specifies size in pixels of the banner border.
pFont
Specifies the new caption font.
lpszWindText
NULL terminated string specifying the new caption text.
hIcon
Handle of the icon to be drawn in the caption.

Remarks

You can use this member function to set the border size that is drawn around the caption banner, the font that the caption will use, and the caption text and icon to be displayed.

Group

CXTCaption Methods


CXTCaption::RefreshButton Method

CXTCaption Methods, CXTCaption Class
CXTCaption::RefreshButton Method

This member function is called to refresh the caption button style.

void RefreshButton();
Group

CXTCaption Methods


CXTCaption::SetAppCaption Method

CXTCaption Methods, CXTCaption Class, Body Source
CXTCaption::SetAppCaption Method

This member function is called to set the flag that indicates if the caption is the application's primary caption.

void SetAppCaption(
    bool bAppCaption
);
Parameters

bAppCaption
true if the caption is configured to be used as the applications primary caption.

Body Source
void SetAppCaption(bool bAppCaption) {
    m_bAppCaption = bAppCaption;
}
Group

CXTCaption Methods


CXTCaption::SetCaptionColors Method

CXTCaption Methods, CXTCaption Class
CXTCaption::SetCaptionColors Method

This member function will set the caption bar border, background, and font colors.

virtual void SetCaptionColors(
    COLORREF clrBorder,
    COLORREF clrFace,
    COLORREF clrText
);
Parameters

clrBorder
An RGB value that represents the new border color.
clrFace
An RGB value that represents the new background color.
clrText
An RGB value that represents the new font color.

Group

CXTCaption Methods


CXTCaption::SetChildWindow Method

CXTCaption Methods, CXTCaption Class
CXTCaption::SetChildWindow Method

Call this member function to set the child and notification windows for the caption bar.

virtual void SetChildWindow(
    CWnd* pChild,
    CWnd* pNotifyWnd
);
Parameters

pChild
A CWnd pointer that represents the child window to be displayed in the popup window.
pNotifyWnd
A CWnd pointer that represents the window to receive notification messages.

Group

CXTCaption Methods


CXTCaption::SetOffice2003Colors Method

CXTCaption Methods, CXTCaption Class
CXTCaption::SetOffice2003Colors Method

Call this member function to enable Office 2003 visualizations.

void SetOffice2003Colors(
    bool b2003Colors = true
);
Parameters

b2003Colors
True to enable Office 2003 visualizations, false to disable.

Group

CXTCaption Methods


CXTCaption::ShowPopupWindow Method

CXTCaption Methods, CXTCaption Class
CXTCaption::ShowPopupWindow Method

This member function is called to display the popup window and associated children.

virtual BOOL ShowPopupWindow();
Returns

TRUE if the popup window is successfully displayed, otherwise FALSE.

Group

CXTCaption Methods


CXTCaption::UpdateCaption Method

CXTCaption Methods, CXTCaption Class
CXTCaption::UpdateCaption Method

This member function is called to update the text and icon for the caption bar.

virtual void UpdateCaption(
    LPCTSTR lpszWindowText,
    HICON hIcon
);
Parameters

lpszWindowText
NULL terminated string to display in the caption bar.
hIcon
Handle of the icon to display in the caption bar. It can be NULL.

Group

CXTCaption Methods


CXTCaption::UpdateCaptionText Method

CXTCaption Methods, CXTCaption Class
CXTCaption::UpdateCaptionText Method

This member function is called to update the caption text.

virtual void UpdateCaptionText(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTCaption Methods


CXTCaption Constructors

CXTCaption Class, Legend, Public Methods
CXTCaption Constructors
Class

CXTCaption Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTCaption | Constructs a CXTCaption object


CXTCaption::CXTCaption Constructor

CXTCaption Constructors, CXTCaption Class
CXTCaption::CXTCaption Constructor

Constructs a CXTCaption object

CXTCaption();
Group

CXTCaption Constructors


CXTCaption Destructors

CXTCaption Class, Legend, Public Methods
CXTCaption Destructors
Class

CXTCaption Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTCaption | Destroys a CXTCaption object, handles cleanup and deallocation


CXTCaption::~CXTCaption Destructor

CXTCaption Destructors, CXTCaption Class
CXTCaption::~CXTCaption Destructor

Destroys a CXTCaption object, handles cleanup and deallocation

virtual ~CXTCaption();
Group

CXTCaption Destructors


CXTCaptionButton Class

XTCaption.h, Classes, Legend, Members, Topics, CXTCaptionButton Data Members, CXTCaptionButton Methods, CXTCaptionButton Constructors, CXTCaptionButton Constructors, CXTCaptionButton Data Members, CXTCaptionButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButton Class

CXTCaptionButton is a CXTButton derived class. It is used by the CXTCaption class to activate a CXTCaptionPopupWnd window.

Class Hierarchy

class CXTCaptionButton : public CXTButton;
File

XTCaption.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTCaptionButton Constructors
CXTCaptionButton Constructors | Description
CXTCaptionButton | Constructs a CXTCaptionButton object
CXTCaptionButton Data Members
CXTCaptionButton Data Members | Description
m_pCaption | A pointer to the parent CXTCaption.
CXTCaptionButton Methods
CXTCaptionButton Methods | Description
GetCaption | This member function is called to return a pointer to the parent caption.
SetCaption | This member fuction is called to set the pointer to the parent caption.
SetXButtonStyle | This member function will set the display style for the button.


CXTCaptionButton Data Members

CXTCaptionButton Class, Legend, Protected Data Members
CXTCaptionButton Data Members
Class

CXTCaptionButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pCaption | A pointer to the parent CXTCaption.


CXTCaptionButton::m_pCaption Data Member

CXTCaptionButton Data Members, CXTCaptionButton Class
CXTCaptionButton::m_pCaption Data Member

A pointer to the parent CXTCaption.

CXTCaption* m_pCaption;
Group

CXTCaptionButton Data Members


CXTCaptionButton Methods

CXTCaptionButton Class, Legend, Public Methods
CXTCaptionButton Methods
Class

CXTCaptionButton Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetCaption | This member function is called to return a pointer to the parent caption.
SetCaption | This member fuction is called to set the pointer to the parent caption.
SetXButtonStyle | This member function will set the display style for the button.


CXTCaptionButton::GetCaption Method

CXTCaptionButton Methods, CXTCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButton::GetCaption Method

This member function is called to return a pointer to the parent caption.

CXTCaption* GetCaption();
Returns

A pointer to a CXTCaption object.

Body Source
CXTCaption* GetCaption() {
    return m_pCaption;
}
Group

CXTCaptionButton Methods


CXTCaptionButton::SetCaption Method

CXTCaptionButton Methods, CXTCaptionButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButton::SetCaption Method

This member fuction is called to set the pointer to the parent caption.

void SetCaption(
    CXTCaption* pCaption
);
Parameters

pCaption
A pointer to a CXTCaption object.

Body Source
void SetCaption(CXTCaption* pCaption) {
    m_pCaption = pCaption;
}
Group

CXTCaptionButton Methods


CXTCaptionButton::SetXButtonStyle Method

CXTCaptionButton Methods, CXTCaptionButton Class
CXTCaptionButton::SetXButtonStyle Method

This member function will set the display style for the button.

virtual DWORD SetXButtonStyle(
    DWORD dwxStyle,
    BOOL bRedraw = TRUE
);
Parameters

dwxStyle
Specifies the button style. See the Remarks section below for a list of available styles.
bRedraw
Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.

Returns

The previous style that was set.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • BS_XT_FLAT Draws a flat button.
  • BS_XT_SEMIFLAT Draws a semi-flat button.
  • BS_XT_TWOROWS Draws images and text that are centered.
  • BS_XT_SHOWFOCUS Draws a focus rect when the button has input focus.
  • BS_XT_HILITEPRESSED Highlights the button when pressed.
  • BS_XT_XPFLAT Draws a flat button ala Office XP.
Group

CXTCaptionButton Methods


CXTCaptionButton Constructors

CXTCaptionButton Class, Legend, Public Methods
CXTCaptionButton Constructors
Class

CXTCaptionButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionButton | Constructs a CXTCaptionButton object


CXTCaptionButton::CXTCaptionButton Constructor

CXTCaptionButton Constructors, CXTCaptionButton Class
CXTCaptionButton::CXTCaptionButton Constructor

Constructs a CXTCaptionButton object

CXTCaptionButton();
Group

CXTCaptionButton Constructors


CXTCaptionButtonTheme Class

XTCaptionTheme.h, Classes, Legend, Members, Topics, CXTCaptionButtonTheme Methods, CXTCaptionButtonTheme Constructors, CXTCaptionButtonTheme Constructors, CXTCaptionButtonTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonTheme Class

CXTCaptionButtonTheme is derived from CXTButtonTheme. This class is used to set the caption for buttons.

Class Hierarchy

class CXTCaptionButtonTheme : public CXTButtonTheme;
File

XTCaptionTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTCaptionButtonTheme Constructors
CXTCaptionButtonTheme Constructors | Description
CXTCaptionButtonTheme | Default class constructor.
CXTCaptionButtonTheme Methods
CXTCaptionButtonTheme Methods | Description
DrawButtonText | Call this member function to draw the button caption text.
DrawButtonThemeBackground | This member function is called to draw the background for the button.
GetTextColor | Call this member function to get the text color of the button caption.


CXTCaptionButtonTheme Methods

CXTCaptionButtonTheme Class, Legend, Protected Methods
CXTCaptionButtonTheme Methods
Class

CXTCaptionButtonTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawButtonText | Call this member function to draw the button caption text.
DrawButtonThemeBackground | This member function is called to draw the background for the button.
GetTextColor | Call this member function to get the text color of the button caption.


CXTCaptionButtonTheme::DrawButtonText Method

CXTCaptionButtonTheme Methods, CXTCaptionButtonTheme Class
CXTCaptionButtonTheme::DrawButtonText Method

Call this member function to draw the button caption text.

virtual void DrawButtonText(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A pointer to a valid device context.
nState
A UINT value that represents the current state of the button.
rcItem
a CRect object containing the dimensions of the button.
pButton
A pointer to a valid CXTButton object.

Group

CXTCaptionButtonTheme Methods


CXTCaptionButtonTheme::DrawButtonThemeBackground Method

CXTCaptionButtonTheme Methods, CXTCaptionButtonTheme Class
CXTCaptionButtonTheme::DrawButtonThemeBackground Method

This member function is called to draw the background for the button.

virtual BOOL DrawButtonThemeBackground(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pButton
Points to a CXTButton object.

Returns

TRUE if the background was drawn successfully, otherwise returns FALSE.

Group

CXTCaptionButtonTheme Methods


CXTCaptionButtonTheme::GetTextColor Method

CXTCaptionButtonTheme Methods, CXTCaptionButtonTheme Class
CXTCaptionButtonTheme::GetTextColor Method

Call this member function to get the text color of the button caption.

virtual COLORREF GetTextColor(
    UINT nState,
    CXTButton* pButton
);
Parameters

nState
A UINT that contains the current button state.
pButton
A pointer to a valid CXTButton object.

Returns

An RGB value specifying the text color.

Group

CXTCaptionButtonTheme Methods


CXTCaptionButtonTheme Constructors

CXTCaptionButtonTheme Class, Legend, Public Methods
CXTCaptionButtonTheme Constructors
Class

CXTCaptionButtonTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionButtonTheme | Default class constructor.


CXTCaptionButtonTheme::CXTCaptionButtonTheme Constructor

CXTCaptionButtonTheme Constructors, CXTCaptionButtonTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonTheme::CXTCaptionButtonTheme Constructor

Default class constructor.

CXTCaptionButtonTheme();
Group

CXTCaptionButtonTheme Constructors


CXTCaptionButtonThemeOffice2003 Class

XTCaptionTheme.h, Classes, Legend, Members, Topics, CXTCaptionButtonThemeOffice2003 Methods, CXTCaptionButtonThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOffice2003 Class

Class CXTCaptionButtonThemeOffice2003 is a CXTButtonThemeOffice2003 derived class. This class is used to create a button caption that resembles an Office 2003 button caption.

Class Hierarchy

class CXTCaptionButtonThemeOffice2003 : public CXTButtonThemeOffice2003;
File

XTCaptionTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTCaptionButtonThemeOffice2003 Methods
CXTCaptionButtonThemeOffice2003 Methods | Description
DrawButtonThemeBackground | Call this member function to draw the background of the caption.
GetGradientValues | This member function is called to determine the correct gradient values for rendering the button's background.
GetTextColor | Call this member function to get the text color of the button caption.


CXTCaptionButtonThemeOffice2003 Methods

CXTCaptionButtonThemeOffice2003 Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOffice2003 Methods
Class

CXTCaptionButtonThemeOffice2003 Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawButtonThemeBackground | Call this member function to draw the background of the caption.
GetGradientValues | This member function is called to determine the correct gradient values for rendering the button's background.
GetTextColor | Call this member function to get the text color of the button caption.


CXTCaptionButtonThemeOffice2003::DrawButtonThemeBackground Method

CXTCaptionButtonThemeOffice2003 Methods, CXTCaptionButtonThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOffice2003::DrawButtonThemeBackground Method

Call this member function to draw the background of the caption.

virtual BOOL DrawButtonThemeBackground(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
An LPDRAWITEMSTRUCT struct that contains the information the owner window must have to determine how to paint an owner-drawn control.
pButton
A pointer to valid CXTButton object.

Returns

A TRUE if the background was successfully drawn. FALSE otherwise.

Group

CXTCaptionButtonThemeOffice2003 Methods


CXTCaptionButtonThemeOffice2003::GetGradientValues Method

CXTCaptionButtonThemeOffice2003 Methods, CXTCaptionButtonThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOffice2003::GetGradientValues Method

This member function is called to determine the correct gradient values for rendering the button's background.

virtual BOOL GetGradientValues(
    CRect& rButton,
    CXTCaption* pCaption,
    CXTPPaintManagerColorGradient& clr
);
Parameters

rButton
Reference to the buttons window size.
pCaption
Pointer to the buttons caption parent.
clr
Reference to receive gradient color values.

Returns

TRUE if the gradient colors were successfully determined, otherwise FALSE.

Group

CXTCaptionButtonThemeOffice2003 Methods


CXTCaptionButtonThemeOffice2003::GetTextColor Method

CXTCaptionButtonThemeOffice2003 Methods, CXTCaptionButtonThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOffice2003::GetTextColor Method

Call this member function to get the text color of the button caption.

virtual COLORREF GetTextColor(
    UINT nState,
    CXTButton* pButton
);
Parameters

nState
A UINT that contains the current button state.
pButton
A pointer to a valid CXTButton object.

Returns

An RGB value specifying the text color.

Group

CXTCaptionButtonThemeOffice2003 Methods


CXTCaptionButtonThemeOfficeXP Class

XTCaptionTheme.h, Classes, Legend, Members, Topics, CXTCaptionButtonThemeOfficeXP Methods, CXTCaptionButtonThemeOfficeXP Constructors, CXTCaptionButtonThemeOfficeXP Constructors, CXTCaptionButtonThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOfficeXP Class

Class CXTCaptionButtonThemeOfficeXP is a CXTButtonThemeOfficeXP derived class. This class is used to create a button caption that resembles an Office XP button caption.

Class Hierarchy

class CXTCaptionButtonThemeOfficeXP : public CXTButtonThemeOfficeXP;
File

XTCaptionTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTCaptionButtonThemeOfficeXP Constructors
CXTCaptionButtonThemeOfficeXP Constructors | Description
CXTCaptionButtonThemeOfficeXP | Default class constructor. Call this member function to construct a CXTCaptionButtonThemeOfficeXP object.
CXTCaptionButtonThemeOfficeXP Methods
CXTCaptionButtonThemeOfficeXP Methods | Description
DrawButtonText | Call this member function to draw the button caption text.
DrawButtonThemeBackground | Call this member function to draw the background of the caption.
GetTextColor | Call this member function to get the text color of the button caption.


CXTCaptionButtonThemeOfficeXP Methods

CXTCaptionButtonThemeOfficeXP Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOfficeXP Methods
Class

CXTCaptionButtonThemeOfficeXP Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawButtonText | Call this member function to draw the button caption text.
DrawButtonThemeBackground | Call this member function to draw the background of the caption.
GetTextColor | Call this member function to get the text color of the button caption.


CXTCaptionButtonThemeOfficeXP::DrawButtonText Method

CXTCaptionButtonThemeOfficeXP Methods, CXTCaptionButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOfficeXP::DrawButtonText Method

Call this member function to draw the button caption text.

virtual void DrawButtonText(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A pointer to a valid device context.
nState
A UINT value that represents the current state of the button.
rcItem
a CRect object containing the dimensions of the button.
pButton
A pointer to a valid CXTButton object.

Group

CXTCaptionButtonThemeOfficeXP Methods


CXTCaptionButtonThemeOfficeXP::DrawButtonThemeBackground Method

CXTCaptionButtonThemeOfficeXP Methods, CXTCaptionButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOfficeXP::DrawButtonThemeBackground Method

Call this member function to draw the background of the caption.

virtual BOOL DrawButtonThemeBackground(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
An LPDRAWITEMSTRUCT struct that contains the information the owner window must have to determine how to paint an owner-drawn control.
pButton
A pointer to valid CXTButton object.

Returns

A TRUE if the background was successfully drawn. FALSE otherwise.

Group

CXTCaptionButtonThemeOfficeXP Methods


CXTCaptionButtonThemeOfficeXP::GetTextColor Method

CXTCaptionButtonThemeOfficeXP Methods, CXTCaptionButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOfficeXP::GetTextColor Method

Call this member function to get the text color of the button caption.

virtual COLORREF GetTextColor(
    UINT nState,
    CXTButton* pButton
);
Parameters

nState
A UINT that contains the current button state.
pButton
A pointer to a valid CXTButton object.

Returns

An RGB value specifying the text color.

Group

CXTCaptionButtonThemeOfficeXP Methods


CXTCaptionButtonThemeOfficeXP Constructors

CXTCaptionButtonThemeOfficeXP Class, Legend, Public Methods
CXTCaptionButtonThemeOfficeXP Constructors
Class

CXTCaptionButtonThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionButtonThemeOfficeXP | Default class constructor. Call this member function to construct a CXTCaptionButtonThemeOfficeXP object.


CXTCaptionButtonThemeOfficeXP::CXTCaptionButtonThemeOfficeXP Constructor

CXTCaptionButtonThemeOfficeXP Constructors, CXTCaptionButtonThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionButtonThemeOfficeXP::CXTCaptionButtonThemeOfficeXP Constructor

Default class constructor. Call this member function to construct a CXTCaptionButtonThemeOfficeXP object.

CXTCaptionButtonThemeOfficeXP();
Group

CXTCaptionButtonThemeOfficeXP Constructors


CXTCaptionPopupWnd Class

XTCaptionPopupWnd.h, Classes, Legend, Members, Topics, CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Methods, CXTCaptionPopupWnd Constructors, CXTCaptionPopupWnd Destructors, CXTCaptionPopupWnd Constructors, CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Destructors, CXTCaptionPopupWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionPopupWnd Class

CXTCaptionPopupWnd is a CWnd derived class. It is used by the CXTCaption class to display a popup child window similar to Outlook(tm).

Class Hierarchy

class CXTCaptionPopupWnd : public CWnd;
File

XTCaptionPopupWnd.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTCaptionPopupWnd Constructors
CXTCaptionPopupWnd Constructors | Description
CXTCaptionPopupWnd | Constructs a CXTCaptionPopupWnd object
CXTCaptionPopupWnd Data Members
CXTCaptionPopupWnd Data Members | Description
m_Caption | Caption that is displayed when the window is active.
m_CaptionButton | Close button associated with the caption.
m_hIconOff | Handle to a pressed button icon.
m_hIconOn | Handle to a normal button icon.
m_pChildParent | A CWnd pointer that represents the parent of the child window.
m_pChildWnd | A CWnd pointer that represents the child displayed in the popup.
m_pParentWnd | A CWnd pointer that represents the parent window.
CXTCaptionPopupWnd Destructors
CXTCaptionPopupWnd Destructors | Description
~CXTCaptionPopupWnd | Destroys a CXTCaptionPopupWnd object, handles cleanup and deallocation
CXTCaptionPopupWnd Methods
CXTCaptionPopupWnd Methods | Description
Create | This member function is called to create and display the popup window.
RecalcLayout | Call this member function to recalculate the layout of the caption and child window.
RegisterWindowClass | Call this member function to register the window class for the popup window.
ResetParent | Call this member function to reset the parent of the child window back to its default.
SendCancelMessage | Call this member function to send a cancel message that will cause the popup to close.


CXTCaptionPopupWnd Data Members

CXTCaptionPopupWnd Class, Legend, Protected Data Members
CXTCaptionPopupWnd Data Members
Class

CXTCaptionPopupWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_Caption | Caption that is displayed when the window is active.
m_CaptionButton | Close button associated with the caption.
m_hIconOff | Handle to a pressed button icon.
m_hIconOn | Handle to a normal button icon.
m_pChildParent | A CWnd pointer that represents the parent of the child window.
m_pChildWnd | A CWnd pointer that represents the child displayed in the popup.
m_pParentWnd | A CWnd pointer that represents the parent window.


CXTCaptionPopupWnd::m_Caption Data Member

CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::m_Caption Data Member

Caption that is displayed when the window is active.

CXTCaption m_Caption;
Group

CXTCaptionPopupWnd Data Members


CXTCaptionPopupWnd::m_CaptionButton Data Member

CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::m_CaptionButton Data Member

Close button associated with the caption.

CXTCaptionButton m_CaptionButton;
Group

CXTCaptionPopupWnd Data Members


CXTCaptionPopupWnd::m_hIconOff Data Member

CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::m_hIconOff Data Member

Handle to a pressed button icon.

CXTIconHandle m_hIconOff;
Group

CXTCaptionPopupWnd Data Members


CXTCaptionPopupWnd::m_hIconOn Data Member

CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::m_hIconOn Data Member

Handle to a normal button icon.

CXTIconHandle m_hIconOn;
Group

CXTCaptionPopupWnd Data Members


CXTCaptionPopupWnd::m_pChildParent Data Member

CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::m_pChildParent Data Member

A CWnd pointer that represents the parent of the child window.

CWnd* m_pChildParent;
Group

CXTCaptionPopupWnd Data Members


CXTCaptionPopupWnd::m_pChildWnd Data Member

CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::m_pChildWnd Data Member

A CWnd pointer that represents the child displayed in the popup.

CWnd* m_pChildWnd;
Group

CXTCaptionPopupWnd Data Members


CXTCaptionPopupWnd::m_pParentWnd Data Member

CXTCaptionPopupWnd Data Members, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::m_pParentWnd Data Member

A CWnd pointer that represents the parent window.

CWnd* m_pParentWnd;
Group

CXTCaptionPopupWnd Data Members


CXTCaptionPopupWnd Methods

CXTCaptionPopupWnd Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionPopupWnd Methods
Class

CXTCaptionPopupWnd Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
RegisterWindowClass | Call this member function to register the window class for the popup window.
Public Methods
Public Methods
Public Method | Description
Create | This member function is called to create and display the popup window.
RecalcLayout | Call this member function to recalculate the layout of the caption and child window.
ResetParent | Call this member function to reset the parent of the child window back to its default.
SendCancelMessage | Call this member function to send a cancel message that will cause the popup to close.


CXTCaptionPopupWnd::Create Method

CXTCaptionPopupWnd Methods, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::Create Method

This member function is called to create and display the popup window.

virtual BOOL Create(
    const CRect& rect,
    CWnd* pParentWnd,
    CWnd* pChildWnd
);
Parameters

rect
A CRect reference that represents the size of the popup window.
pParentWnd
A CWnd pointer that represents the popup window.
pChildWnd
A CWnd pointer that represents the child to be displayed when the window is activated.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTCaptionPopupWnd Methods


CXTCaptionPopupWnd::RecalcLayout Method

CXTCaptionPopupWnd Methods, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::RecalcLayout Method

Call this member function to recalculate the layout of the caption and child window.

virtual void RecalcLayout();
Group

CXTCaptionPopupWnd Methods


CXTCaptionPopupWnd::RegisterWindowClass Method

CXTCaptionPopupWnd Methods, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::RegisterWindowClass Method

Call this member function to register the window class for the popup window.

BOOL RegisterWindowClass();
Returns

Returns TRUE if successful, otherwise FALSE.

Group

CXTCaptionPopupWnd Methods


CXTCaptionPopupWnd::ResetParent Method

CXTCaptionPopupWnd Methods, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::ResetParent Method

Call this member function to reset the parent of the child window back to its default.

virtual BOOL ResetParent();
Returns

Returns TRUE if successful, otherwise FALSE.

Group

CXTCaptionPopupWnd Methods


CXTCaptionPopupWnd::SendCancelMessage Method

CXTCaptionPopupWnd Methods, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::SendCancelMessage Method

Call this member function to send a cancel message that will cause the popup to close.

virtual BOOL SendCancelMessage();
Returns

Returns TRUE if successful, otherwise FALSE.

Group

CXTCaptionPopupWnd Methods


CXTCaptionPopupWnd Constructors

CXTCaptionPopupWnd Class, Legend, Public Methods
CXTCaptionPopupWnd Constructors
Class

CXTCaptionPopupWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionPopupWnd | Constructs a CXTCaptionPopupWnd object


CXTCaptionPopupWnd::CXTCaptionPopupWnd Constructor

CXTCaptionPopupWnd Constructors, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::CXTCaptionPopupWnd Constructor

Constructs a CXTCaptionPopupWnd object

CXTCaptionPopupWnd();
Group

CXTCaptionPopupWnd Constructors


CXTCaptionPopupWnd Destructors

CXTCaptionPopupWnd Class, Legend, Public Methods
CXTCaptionPopupWnd Destructors
Class

CXTCaptionPopupWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTCaptionPopupWnd | Destroys a CXTCaptionPopupWnd object, handles cleanup and deallocation


CXTCaptionPopupWnd::~CXTCaptionPopupWnd Destructor

CXTCaptionPopupWnd Destructors, CXTCaptionPopupWnd Class
CXTCaptionPopupWnd::~CXTCaptionPopupWnd Destructor

Destroys a CXTCaptionPopupWnd object, handles cleanup and deallocation

virtual ~CXTCaptionPopupWnd();
Group

CXTCaptionPopupWnd Destructors


CXTCaptionTheme Class

XTCaptionTheme.h, Classes, Legend, Members, Topics, CXTCaptionTheme Data Members, CXTCaptionTheme Methods, CXTCaptionTheme Constructors, CXTCaptionTheme Constructors, CXTCaptionTheme Data Members, CXTCaptionTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionTheme Class

CXTCaptionTheme is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.

Class Hierarchy

class CXTCaptionTheme : public CXTThemeManagerStyle;
File

XTCaptionTheme.h

Group

Classes

Legend
Data Member
Method
virtual
CXTCaptionTheme Constructors
CXTCaptionTheme Constructors | Description
CXTCaptionTheme | Constructs a CXTCaptionTheme object.
CXTCaptionTheme Data Members
CXTCaptionTheme Data Members | Description
m_clrBorder | The system or user defined color of the border.
m_clrEdgeLight | The color of the edge light for the current theme.
m_clrEdgeShadow | The color of the edge shadow for the current theme.
m_clrFace | The system or user defined color of the background.
m_clrText | The system or user defined color of the font.
CXTCaptionTheme Methods
CXTCaptionTheme Methods | Description
DrawCaptionBack | Call this function to draw the background of the caption at the location specified in the rcItem rect.
DrawCaptionIcon | Called by CXTCaption to draw the caption icon.
DrawCaptionText | Called by CXTCaption to draw the caption text.
RefreshMetrics | This function is called to set the edges of a caption to the system default colors for edge shadow and edge light.


CXTCaptionTheme Data Members

CXTCaptionTheme Class, Legend, Public Data Members
CXTCaptionTheme Data Members
Class

CXTCaptionTheme Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrBorder | The system or user defined color of the border.
m_clrEdgeLight | The color of the edge light for the current theme.
m_clrEdgeShadow | The color of the edge shadow for the current theme.
m_clrFace | The system or user defined color of the background.
m_clrText | The system or user defined color of the font.


CXTCaptionTheme::m_clrBorder Data Member

CXTCaptionTheme Data Members, CXTCaptionTheme Class
CXTCaptionTheme::m_clrBorder Data Member

The system or user defined color of the border.

CXTPPaintManagerColor m_clrBorder;
Group

CXTCaptionTheme Data Members


CXTCaptionTheme::m_clrEdgeLight Data Member

CXTCaptionTheme Data Members, CXTCaptionTheme Class
CXTCaptionTheme::m_clrEdgeLight Data Member

The color of the edge light for the current theme.

CXTPPaintManagerColor m_clrEdgeLight;
Group

CXTCaptionTheme Data Members


CXTCaptionTheme::m_clrEdgeShadow Data Member

CXTCaptionTheme Data Members, CXTCaptionTheme Class
CXTCaptionTheme::m_clrEdgeShadow Data Member

The color of the edge shadow for the current theme.

CXTPPaintManagerColor m_clrEdgeShadow;
Group

CXTCaptionTheme Data Members


CXTCaptionTheme::m_clrFace Data Member

CXTCaptionTheme Data Members, CXTCaptionTheme Class
CXTCaptionTheme::m_clrFace Data Member

The system or user defined color of the background.

CXTPPaintManagerColor m_clrFace;
Group

CXTCaptionTheme Data Members


CXTCaptionTheme::m_clrText Data Member

CXTCaptionTheme Data Members, CXTCaptionTheme Class
CXTCaptionTheme::m_clrText Data Member

The system or user defined color of the font.

CXTPPaintManagerColor m_clrText;
Group

CXTCaptionTheme Data Members


CXTCaptionTheme Methods

CXTCaptionTheme Class, Legend, Public Methods
CXTCaptionTheme Methods
Class

CXTCaptionTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawCaptionBack | Call this function to draw the background of the caption at the location specified in the rcItem rect.
DrawCaptionIcon | Called by CXTCaption to draw the caption icon.
DrawCaptionText | Called by CXTCaption to draw the caption text.
RefreshMetrics | This function is called to set the edges of a caption to the system default colors for edge shadow and edge light.


CXTCaptionTheme::DrawCaptionBack Method

CXTCaptionTheme Methods, CXTCaptionTheme Class
CXTCaptionTheme::DrawCaptionBack Method

Call this function to draw the background of the caption at the location specified in the rcItem rect.

virtual void DrawCaptionBack(
    CDC* pDC,
    CXTCaption* pCaption,
    CRect& rcItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
pCaption
A pointer to a CXTCaption object.
rcItem
Location where the caption is drawn.

Group

CXTCaptionTheme Methods


CXTCaptionTheme::DrawCaptionIcon Method

CXTCaptionTheme Methods, CXTCaptionTheme Class
CXTCaptionTheme::DrawCaptionIcon Method

Called by CXTCaption to draw the caption icon.

virtual void DrawCaptionIcon(
    CDC* pDC,
    CXTCaption* pCaption,
    CRect& rcItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
pCaption
A pointer to a CXTCaption object.
rcItem
Location where the caption is drawn.

Remarks

Call this function to draw the icon on the caption. Only draws the icon if there is enough space between the caption borders.

Group

CXTCaptionTheme Methods


CXTCaptionTheme::DrawCaptionText Method

CXTCaptionTheme Methods, CXTCaptionTheme Class
CXTCaptionTheme::DrawCaptionText Method

Called by CXTCaption to draw the caption text.

virtual void DrawCaptionText(
    CDC* pDC,
    CXTCaption* pCaption
);
Parameters

pDC
A CDC pointer that represents the current device context.
pCaption
A pointer to a CXTCaption object.

Group

CXTCaptionTheme Methods


CXTCaptionTheme::RefreshMetrics Method

CXTCaptionTheme Methods, CXTCaptionTheme Class
CXTCaptionTheme::RefreshMetrics Method

This function is called to set the edges of a caption to the system default colors for edge shadow and edge light.

virtual void RefreshMetrics();
Group

CXTCaptionTheme Methods


CXTCaptionTheme Constructors

CXTCaptionTheme Class, Legend, Public Methods
CXTCaptionTheme Constructors
Class

CXTCaptionTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionTheme | Constructs a CXTCaptionTheme object.


CXTCaptionTheme::CXTCaptionTheme Constructor

CXTCaptionTheme Constructors, CXTCaptionTheme Class
CXTCaptionTheme::CXTCaptionTheme Constructor

Constructs a CXTCaptionTheme object.

CXTCaptionTheme();
Group

CXTCaptionTheme Constructors


CXTCaptionThemeOffice2003 Class

XTCaptionTheme.h, Classes, Legend, Members, Topics, CXTCaptionThemeOffice2003 Methods, CXTCaptionThemeOffice2003 Constructors, CXTCaptionThemeOffice2003 Constructors, CXTCaptionThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionThemeOffice2003 Class

CXTCaptionThemeOffice2003 is derived from CXTCaptionTheme. It is used to set the caption to the Office 2003 theme.

Class Hierarchy

class CXTCaptionThemeOffice2003 : public CXTCaptionTheme;
File

XTCaptionTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTCaptionThemeOffice2003 Constructors
CXTCaptionThemeOffice2003 Constructors | Description
CXTCaptionThemeOffice2003 | Default class constructor. Call this member function to construct a CXTCaptionThemeOffice2003 object.
CXTCaptionThemeOffice2003 Methods
CXTCaptionThemeOffice2003 Methods | Description
DrawCaptionBack | Call this function to draw the background of the caption.


CXTCaptionThemeOffice2003 Methods

CXTCaptionThemeOffice2003 Class, Legend, Protected Methods
CXTCaptionThemeOffice2003 Methods
Class

CXTCaptionThemeOffice2003 Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionBack | Call this function to draw the background of the caption.


CXTCaptionThemeOffice2003::DrawCaptionBack Method

CXTCaptionThemeOffice2003 Methods, CXTCaptionThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionThemeOffice2003::DrawCaptionBack Method

Call this function to draw the background of the caption.

virtual void DrawCaptionBack(
    CDC* pDC,
    CXTCaption* pCaption,
    CRect& rcItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
pCaption
A pointer to a CXTCaption object.
rcItem
CRect object with the size and location where the caption is drawn.

Group

CXTCaptionThemeOffice2003 Methods


CXTCaptionThemeOffice2003 Constructors

CXTCaptionThemeOffice2003 Class, Legend, Public Methods
CXTCaptionThemeOffice2003 Constructors
Class

CXTCaptionThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionThemeOffice2003 | Default class constructor. Call this member function to construct a CXTCaptionThemeOffice2003 object.


CXTCaptionThemeOffice2003::CXTCaptionThemeOffice2003 Constructor

CXTCaptionThemeOffice2003 Constructors, CXTCaptionThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionThemeOffice2003::CXTCaptionThemeOffice2003 Constructor

Default class constructor. Call this member function to construct a CXTCaptionThemeOffice2003 object.

CXTCaptionThemeOffice2003();
Group

CXTCaptionThemeOffice2003 Constructors


CXTCaptionThemeOfficeXP Class

XTCaptionTheme.h, Classes, Legend, Members, Topics, CXTCaptionThemeOfficeXP Methods, CXTCaptionThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionThemeOfficeXP Class

CXTCaptionThemeOfficeXP is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.

Class Hierarchy

class CXTCaptionThemeOfficeXP : public CXTCaptionTheme;
File

XTCaptionTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTCaptionThemeOfficeXP Methods
CXTCaptionThemeOfficeXP Methods | Description
DrawCaptionBack | Call this function to draw the background of the caption.


CXTCaptionThemeOfficeXP Methods

CXTCaptionThemeOfficeXP Class, Legend, Protected Methods
CXTCaptionThemeOfficeXP Methods
Class

CXTCaptionThemeOfficeXP Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawCaptionBack | Call this function to draw the background of the caption.


CXTCaptionThemeOfficeXP::DrawCaptionBack Method

CXTCaptionThemeOfficeXP Methods, CXTCaptionThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCaptionThemeOfficeXP::DrawCaptionBack Method

Call this function to draw the background of the caption.

virtual void DrawCaptionBack(
    CDC* pDC,
    CXTCaption* pCaption,
    CRect& rcItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
pCaption
A pointer to a CXTCaption object.
rcItem
CRect object with the size and location where the caption is drawn.

Group

CXTCaptionThemeOfficeXP Methods


CXTCheckListBox Class

XTCheckListBox.h, Classes, Legend, Members, Topics, CXTCheckListBox Classes, CXTCheckListBox Data Members, CXTCheckListBox Methods, CXTCheckListBox Constructors, CXTCheckListBox Destructors, CXTCheckListBox Classes, CXTCheckListBox Constructors, CXTCheckListBox Data Members, CXTCheckListBox Destructors, CXTCheckListBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCheckListBox Class

The CXTCheckListBox class is a CXTListBox derived class. It provides the functionality of Office style checklist box. A "checklist box" displays a list of items such as filenames. Each item in the list has a check box next to it that the user can either check or clear.

Class Hierarchy

class CXTCheckListBox : public CXTListBox;
File

XTCheckListBox.h

Remarks

CXTCheckListBox is only for owner-drawn controls because the list contains more than text strings. At its simplest, a checklist box contains text strings and check boxes, but you do not need to have text at all. For example, you could have a list of small bitmaps with a check box next to each item.

To create your own checklist box, you must derive your own class from CXTCheckListBox. To derive your own class, write a constructor for the derived class, then call Create.

If your checklist box is a default checklist box (a list of strings with the default-sized check boxes to the left of each), you can use the default CXTCheckListBox::DrawItem to draw the checklist box. Otherwise, you must override the CListBox::CompareItem function and the CXTCheckListBox::DrawItem and CXTCheckListBox::MeasureItem functions.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTCheckListBox Classes
CXTCheckListBox Classes | Description
CCheckListState | CCheckListState is a helper class used by CXTCheckListBox that contains information about the checkbox image that is used by the check list box.
CXTCheckListBox Constructors
CXTCheckListBox Constructors | Description
CXTCheckListBox | Constructs a CXTCheckListBox object
CXTCheckListBox Data Members
CXTCheckListBox Data Members | Description
m_checkListState | Holds the check mark image information.
m_cyText | Represents the text height for the check list box.
m_nStyle | Specifies the style for the check list box.
m_themeHelper | Used for drawing Windows XP themed checkbox.
CXTCheckListBox Destructors
CXTCheckListBox Destructors | Description
~CXTCheckListBox | Destroys a CXTCheckListBox object, handles cleanup and deallocation
CXTCheckListBox Methods
CXTCheckListBox Methods | Description
CalcMinimumItemHeight | Called by the check list box to determine the minimum height for each item in the check list box.
CheckFromPoint | Call this function to determine if a left mouse click occurred in the check box to the left of a list box item.
Create | Creates the Windows checklist box and attaches it to the CXTListBox object
Enable | Call this function to enable or disable a checklist box item.
GetCheck | Call this function to determine the check state of an item.
GetCheckStyle | Retrieves the CXTCheckListBox style.
GetFontHeight | Returns the height for the font used by the check list box.
Init | This member function is called by the CXTListBase class to perform initialization when the window is created or sub-classed.
InvalidateCheck | Called by the CXTCheckListBox to redraw a check box.
InvalidateItem | Called by the CXTCheckListBox to redraw an item.
IsEnabled | Call this function to determine whether or not an item is enabled.
OnGetCheckPosition | The framework calls this function to get the position and size of the check box in an item.
PreCompareItem | Called by the framework to determine the relative position of a new item in the check list box.
PreDeleteItem | This function is called so that an owner drawn list box control can properly handle the delete item message WM_DELETEITEM.
PreDrawItem | Called to paint the control to an off screen device context for a themed application.
PreDrawItemNonThemed | Called to paint the control to an off screen device context for a non-themed application.
PreDrawItemThemed | Called to paint the control to an off screen device context for a themed application.
PreMeasureItem | This function is called to measure the size of the item in the list box for the proper handling of an owner drawn list box.
SetCheck | Call this function to set the check box of the item specified by nIndex.
SetCheckStyle | Call this function to set the style of check boxes in the checklist box.
SetSelectionCheck | Call this function to check all items in the list box that are currently highlighted and not disabled.


CXTCheckListBox Classes

Classes, CXTCheckListBox Class
CXTCheckListBox Classes
Classes
Class | Description
CCheckListState | CCheckListState is a helper class used by CXTCheckListBox that contains information about the checkbox image that is used by the check list box.
Class

CXTCheckListBox Class


CXTCheckListBox::CCheckListState Class

XTCheckListBox.h, CXTCheckListBox Classes, Legend, Members, Topics, CCheckListState Data Members, CCheckListState Constructors, CCheckListState Destructors, CCheckListState Constructors, CCheckListState Data Members, CCheckListState Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCheckListBox::CCheckListState Class

CCheckListState is a helper class used by CXTCheckListBox that contains information about the checkbox image that is used by the check list box.

Class Hierarchy

class CCheckListState;
File

XTCheckListBox.h

Group

CXTCheckListBox Classes

Legend
Data Member
Constructor
virtual
CCheckListState Constructors
CCheckListState Constructors | Description
CCheckListState | Constructs a CCheckListState object
CCheckListState Data Members
CCheckListState Data Members | Description
m_hbitmapCheck | Handle to the check mark image bitmap.
m_sizeCheck | Width and height of the check mark bitmap.
CCheckListState Destructors
CCheckListState Destructors | Description
~CCheckListState | Destroys a CCheckListState object, handles cleanup and deallocation


CCheckListState Data Members

CXTCheckListBox::CCheckListState Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CCheckListState Data Members
Class

CXTCheckListBox::CCheckListState Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_hbitmapCheck | Handle to the check mark image bitmap.
m_sizeCheck | Width and height of the check mark bitmap.


CXTCheckListBox::CCheckListState::m_hbitmapCheck Data Member

CCheckListState Data Members, CXTCheckListBox::CCheckListState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCheckListBox::CCheckListState::m_hbitmapCheck Data Member

Handle to the check mark image bitmap.

HBITMAP m_hbitmapCheck;
Group

CCheckListState Data Members


CXTCheckListBox::CCheckListState::m_sizeCheck Data Member

CCheckListState Data Members, CXTCheckListBox::CCheckListState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCheckListBox::CCheckListState::m_sizeCheck Data Member

Width and height of the check mark bitmap.

CSize m_sizeCheck;
Group

CCheckListState Data Members


CCheckListState Constructors

CXTCheckListBox::CCheckListState Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CCheckListState Constructors
Class

CXTCheckListBox::CCheckListState Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CCheckListState | Constructs a CCheckListState object


CXTCheckListBox::CCheckListState::CCheckListState Constructor

CCheckListState Constructors, CXTCheckListBox::CCheckListState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCheckListBox::CCheckListState::CCheckListState Constructor

Constructs a CCheckListState object

CCheckListState(
    BOOL bListBox3D
);
Parameters

bListBox3D
TRUE to use 3d list box checkmarks

Group

CCheckListState Constructors


CCheckListState Destructors

CXTCheckListBox::CCheckListState Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CCheckListState Destructors
Class

CXTCheckListBox::CCheckListState Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CCheckListState | Destroys a CCheckListState object, handles cleanup and deallocation


CXTCheckListBox::CCheckListState::~CCheckListState Destructor

CCheckListState Destructors, CXTCheckListBox::CCheckListState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCheckListBox::CCheckListState::~CCheckListState Destructor

Destroys a CCheckListState object, handles cleanup and deallocation

virtual ~CCheckListState();
Group

CCheckListState Destructors


CXTCheckListBox Data Members

CXTCheckListBox Class, Legend, Protected Data Members
CXTCheckListBox Data Members
Class

CXTCheckListBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_checkListState | Holds the check mark image information.
m_cyText | Represents the text height for the check list box.
m_nStyle | Specifies the style for the check list box.
m_themeHelper | Used for drawing Windows XP themed checkbox.


CXTCheckListBox::m_checkListState Data Member

CXTCheckListBox Data Members, CXTCheckListBox Class
CXTCheckListBox::m_checkListState Data Member

Holds the check mark image information.

CCheckListState m_checkListState;
Group

CXTCheckListBox Data Members


CXTCheckListBox::m_cyText Data Member

CXTCheckListBox Data Members, CXTCheckListBox Class
CXTCheckListBox::m_cyText Data Member

Represents the text height for the check list box.

int m_cyText;
Group

CXTCheckListBox Data Members


CXTCheckListBox::m_nStyle Data Member

CXTCheckListBox Data Members, CXTCheckListBox Class
CXTCheckListBox::m_nStyle Data Member

Specifies the style for the check list box.

UINT m_nStyle;
Group

CXTCheckListBox Data Members


CXTCheckListBox::m_themeHelper Data Member

CXTCheckListBox Data Members, CXTCheckListBox Class
CXTCheckListBox::m_themeHelper Data Member

Used for drawing Windows XP themed checkbox.

CXTPWinThemeWrapper m_themeHelper;
Group

CXTCheckListBox Data Members


CXTCheckListBox Methods

CXTCheckListBox Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCheckListBox Methods
Class

CXTCheckListBox Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalcMinimumItemHeight | Called by the check list box to determine the minimum height for each item in the check list box.
CheckFromPoint | Call this function to determine if a left mouse click occurred in the check box to the left of a list box item.
GetFontHeight | Returns the height for the font used by the check list box.
Init | This member function is called by the CXTListBase class to perform initialization when the window is created or sub-classed.
InvalidateCheck | Called by the CXTCheckListBox to redraw a check box.
InvalidateItem | Called by the CXTCheckListBox to redraw an item.
PreCompareItem | Called by the framework to determine the relative position of a new item in the check list box.
PreDeleteItem | This function is called so that an owner drawn list box control can properly handle the delete item message WM_DELETEITEM.
PreDrawItem | Called to paint the control to an off screen device context for a themed application.
PreDrawItemNonThemed | Called to paint the control to an off screen device context for a non-themed application.
PreDrawItemThemed | Called to paint the control to an off screen device context for a themed application.
PreMeasureItem | This function is called to measure the size of the item in the list box for the proper handling of an owner drawn list box.
SetSelectionCheck | Call this function to check all items in the list box that are currently highlighted and not disabled.
Public Methods
Public Methods
Public Method | Description
Create | Creates the Windows checklist box and attaches it to the CXTListBox object
Enable | Call this function to enable or disable a checklist box item.
GetCheck | Call this function to determine the check state of an item.
GetCheckStyle | Retrieves the CXTCheckListBox style.
IsEnabled | Call this function to determine whether or not an item is enabled.
OnGetCheckPosition | The framework calls this function to get the position and size of the check box in an item.
SetCheck | Call this function to set the check box of the item specified by nIndex.
SetCheckStyle | Call this function to set the style of check boxes in the checklist box.


CXTCheckListBox::CalcMinimumItemHeight Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::CalcMinimumItemHeight Method

Called by the check list box to determine the minimum height for each item in the check list box.

virtual int CalcMinimumItemHeight();
Returns

An integer that represents the minimum item height.

Group

CXTCheckListBox Methods


CXTCheckListBox::CheckFromPoint Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::CheckFromPoint Method

Call this function to determine if a left mouse click occurred in the check box to the left of a list box item.

virtual int CheckFromPoint(
    CPoint point,
    BOOL& bInCheck
);
Parameters

point
A CPoint object that specifies the XY point where the left mouse button was clicked.
bInCheck
TRUE if the current list box item is checked.

Returns

The index of the list box item that was checked. If no list box item was checked, then return -1.

Group

CXTCheckListBox Methods


CXTCheckListBox::Create Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::Create Method

Creates the Windows checklist box and attaches it to the CXTListBox object

virtual BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Specifies the style of the checklist box. The style must be either LBS_OWNERDRAWFIXED (all items in the list are the same height) or LBS_OWNERDRAWVARIABLE (items in the list are of varying heights). This style can be combined with other list-box styles.
rect
Specifies the checklist-box size and position. Can be either a CRect object or a RECT structure.
pParentWnd
Specifies the checklist box's parent window (usually a CDialog object). It must not be NULL.
nID
Specifies the checklist box's control ID.

Returns

Nonzero if successful; otherwise 0.

Group

CXTCheckListBox Methods


CXTCheckListBox::Enable Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::Enable Method

Call this function to enable or disable a checklist box item.

void Enable(
    int nIndex,
    BOOL bEnabled = TRUE
);
Parameters

nIndex
Index of the checklist box item to be enabled.
bEnabled
Specifies whether the item is enabled or disabled.

Group

CXTCheckListBox Methods


CXTCheckListBox::GetCheck Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::GetCheck Method

Call this function to determine the check state of an item.

int GetCheck(
    int nIndex
);
Parameters

nIndex
Index of the item whose check status is to be retrieved.

Returns

Zero if the item is not checked, 1 if it is checked, and 2 if it is indeterminate.

Group

CXTCheckListBox Methods


CXTCheckListBox::GetCheckStyle Method

CXTCheckListBox Methods, CXTCheckListBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTCheckListBox::GetCheckStyle Method

Retrieves the CXTCheckListBox style.

UINT GetCheckStyle();
Returns

The style of the control's check boxes.

Remarks

Call this function to get the checklist box's style. For information on possible styles, see SetCheckStyle.

See Also

SetCheckStyle

Body Source
UINT CXTCheckListBox::GetCheckStyle() {
    return m_nStyle;
}
Group

CXTCheckListBox Methods


CXTCheckListBox::GetFontHeight Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::GetFontHeight Method

Returns the height for the font used by the check list box.

virtual int GetFontHeight();
Returns

An integer that represents the font height.

Group

CXTCheckListBox Methods


CXTCheckListBox::Init Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::Init Method

This member function is called by the CXTListBase class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTCheckListBox Methods


CXTCheckListBox::InvalidateCheck Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::InvalidateCheck Method

Called by the CXTCheckListBox to redraw a check box.

virtual void InvalidateCheck(
    int nIndex
);
Parameters

nIndex
Integer value that specifies the index of the value to invalidate.

Remarks

This member function determines the size of the bounding rectangle of the selected item's check box. Then calls invalidate rectangle so that the background of the rectangle is redrawn during the next WM_PAINT message.

Group

CXTCheckListBox Methods


CXTCheckListBox::InvalidateItem Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::InvalidateItem Method

Called by the CXTCheckListBox to redraw an item.

virtual void InvalidateItem(
    int nIndex
);
Parameters

nIndex
Integer value that specifies the index of the value to invalidate.

Remarks

This member function determines the size of the bounding rectangle of the selected item. Then calls invalidate rectangle so that the item's background is redrawn during the next WM_PAINT message.

Group

CXTCheckListBox Methods


CXTCheckListBox::IsEnabled Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::IsEnabled Method

Call this function to determine whether or not an item is enabled.

BOOL IsEnabled(
    int nIndex
);
Parameters

nIndex
Index of the item.

Returns

Nonzero if the item is enabled; otherwise 0.

Group

CXTCheckListBox Methods


CXTCheckListBox::OnGetCheckPosition Method

CXTCheckListBox Methods, CXTCheckListBox Class, Example
CXTCheckListBox::OnGetCheckPosition Method

The framework calls this function to get the position and size of the check box in an item.

virtual CRect OnGetCheckPosition(
    CRect rectItem,
    CRect rectCheckBox
);
Parameters

rectItem
The position and size of the list item.
rectCheckBox
The default position and size of an item's check box.

Returns

The position and size of an item's check box.

Remarks

The default implementation only returns the default position and size of the check box (rectCheckBox). By default, a check box is aligned in the upper-left corner of an item and is the standard check box size. There may be cases where you want the check boxes on the right or want a larger or smaller check box. In these cases, override OnGetCheckPosition to change the check box position and size within the item.

Example

The following function overrides the default and puts the check box on the right of the item, makes it the same height as the item (minus a pixel offset at the top and bottom), and makes it the standard check box width:

CRect CMyCheckListBox::OnGetCheckPosition(CRect rectItem, CRect rectCheckBox)
{
    CRect rectMyCheckBox;
    rectMyCheckBox.top = rectItem.top -1;
    rectMyCheckBox.bottom = rectItem.bottom -1;
    rectMyCheckBox.right = rectItem.right -1;
    rectMyCheckBox.left = rectItem.right -1 - rectCheckBox.Width();
    return rectMyCheckBox;
}
Group

CXTCheckListBox Methods


CXTCheckListBox::PreCompareItem Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::PreCompareItem Method

Called by the framework to determine the relative position of a new item in the check list box.

virtual int PreCompareItem(
    LPCOMPAREITEMSTRUCT lpCompareItemStruct
);
Parameters

lpCompareItemStruct
Pointer to a COMPAREITEMSTRUCT struct.

Returns

Indicates the relative position of the two items described in the COMPAREITEMSTRUCT structure. It may be any of the following values:

-1 Item 1 sorts before item 2.
 0 Item 1 and item 2 sort the same.
 1 Item 1 sorts after item 2.

See CWnd::OnCompareItem for a description of the COMPAREITEMSTRUCT structure.

Group

CXTCheckListBox Methods


CXTCheckListBox::PreDeleteItem Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::PreDeleteItem Method

This function is called so that an owner drawn list box control can properly handle the delete item message WM_DELETEITEM.

virtual void PreDeleteItem(
    LPDELETEITEMSTRUCT lpDeleteItemStruct
);
Parameters

lpDeleteItemStruct
A LPDELETEITEMSTRUCT struct that contains information about the items to delete. The DELETEITEMSTRUCT structure has the following form:

Group

CXTCheckListBox Methods


CXTCheckListBox::PreDrawItem Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::PreDrawItem Method

Called to paint the control to an off screen device context for a themed application.

virtual void PreDrawItem(
    LPDRAWITEMSTRUCT lpDrawItemStruct
);
Parameters

lpDrawItemStruct
Contains information about the item to draw. The DRAWITEMSTRUCT structure provides information the owner window must have to determine how to paint an owner-drawn control or menu item.

Remarks

Call this function to pre-draw the item to a memory DC or to the ThemeManager. This prevents flickering of the window during drawing.

Group

CXTCheckListBox Methods


CXTCheckListBox::PreDrawItemNonThemed Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::PreDrawItemNonThemed Method

Called to paint the control to an off screen device context for a non-themed application.

void PreDrawItemNonThemed(
    CDC* pDC,
    DRAWITEMSTRUCT & drawItem,
    int nCheck,
    int cyItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
drawItem
A DRAWITEMSTRUCT that contains information about the item to draw. This is necessary because the list box is an owner drawn control.
nCheck
Integer value that specifies the check state. 1 for checked, 0 for not checked, and 2 for intermediate.
cyItem
The vertical position of the item in the list box.

Remarks

Call this function to pre-draw an item in a non-themed application. This is used to prevent flickering when re-drawing the control.

Group

CXTCheckListBox Methods


CXTCheckListBox::PreDrawItemThemed Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::PreDrawItemThemed Method

Called to paint the control to an off screen device context for a themed application.

bool PreDrawItemThemed(
    CDC* pDC,
    DRAWITEMSTRUCT & drawItem,
    int nCheck,
    int cyItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
drawItem
A DRAWITEMSTRUCT that contains information about the item to draw. This is necessary because the list box is an owner drawn control.
nCheck
Integer value that specifies the check state. 1 for checked, 0 for not checked, and 2 for intermediate.
cyItem
The vertical position of the item in the list box.

Returns

Returns true if the item is successfully drawn, otherwise return false. Also, if the application is not themed, then this function returns false.

Remarks

Call this function to pre-draw an item in a themed application. This is used to prevent flickering when re-drawing the control.

Group

CXTCheckListBox Methods


CXTCheckListBox::PreMeasureItem Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::PreMeasureItem Method

This function is called to measure the size of the item in the list box for the proper handling of an owner drawn list box.

virtual void PreMeasureItem(
    LPMEASUREITEMSTRUCT lpMeasureItemStruct
);
Parameters

lpMeasureItemStruct
A LPMEASUREITEMSTRUCT struct. The MEASUREITEMSTRUCT structure informs Windows of the dimensions of an owner-drawn control or menu item. This allows Windows to process user interaction with the control correctly. Failure to fill out the proper members in the MEASUREITEMSTRUCT structure will cause improper operation of the control.

Group

CXTCheckListBox Methods


CXTCheckListBox::SetCheck Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::SetCheck Method

Call this function to set the check box of the item specified by nIndex.

void SetCheck(
    int nIndex,
    int nCheck
);
Parameters

nIndex
Index of the item whose check box is to be set.
nCheck
State of the check box: 0 for clear, 1 for checked, and 2 for indeterminate.

Group

CXTCheckListBox Methods


CXTCheckListBox::SetCheckStyle Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::SetCheckStyle Method

Call this function to set the style of check boxes in the checklist box.

void SetCheckStyle(
    UINT nStyle
);
Parameters

nStyle
Determines the style of check boxes in the checklist box. See the Remarks section for available styles.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • BS_3STATE Same as a check box, except that the box can be dimmed as well as checked. The dimmed state typically is used to show that a check box has been disabled.
  • BS_AUTO3STATE Same as a three-state check box, except that the box changes its state when the user selects it.
  • BS_AUTOCHECKBOX Same as a check box, except that a check mark appears in the check box when the user selects the box; the check mark disappears the next time the user selects the box.
  • BS_CHECKBOX Creates a small square that has text displayed to its right (unless this style is combined with the BS_LEFTTEXT style).

For information on these styles, see Button Styles.

Group

CXTCheckListBox Methods


CXTCheckListBox::SetSelectionCheck Method

CXTCheckListBox Methods, CXTCheckListBox Class
CXTCheckListBox::SetSelectionCheck Method

Call this function to check all items in the list box that are currently highlighted and not disabled.

virtual void SetSelectionCheck(
    int nCheck
);
Parameters

nCheck
Integer value that specifies the check state. 1 for checked, 0 for not checked, and 2 for intermediate.

Group

CXTCheckListBox Methods


CXTCheckListBox Constructors

CXTCheckListBox Class, Legend, Public Methods
CXTCheckListBox Constructors
Class

CXTCheckListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTCheckListBox | Constructs a CXTCheckListBox object


CXTCheckListBox::CXTCheckListBox Constructor

CXTCheckListBox Constructors, CXTCheckListBox Class
CXTCheckListBox::CXTCheckListBox Constructor

Constructs a CXTCheckListBox object

CXTCheckListBox(
    BOOL bListBox3D = FALSE
);
Parameters

bListBox3D
TRUE to use 3d list box checkmarks

Group

CXTCheckListBox Constructors


CXTCheckListBox Destructors

CXTCheckListBox Class, Legend, Public Methods
CXTCheckListBox Destructors
Class

CXTCheckListBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTCheckListBox | Destroys a CXTCheckListBox object, handles cleanup and deallocation


CXTCheckListBox::~CXTCheckListBox Destructor

CXTCheckListBox Destructors, CXTCheckListBox Class
CXTCheckListBox::~CXTCheckListBox Destructor

Destroys a CXTCheckListBox object, handles cleanup and deallocation

virtual ~CXTCheckListBox();
Group

CXTCheckListBox Destructors


CXTColorBase Class

XTColorPageCustom.h, Classes, Legend, Members, Topics, CXTColorBase Enumerations, CXTColorBase Data Members, CXTColorBase Methods, CXTColorBase Constructors, CXTColorBase Destructors, CXTColorBase Constructors, CXTColorBase Data Members, CXTColorBase Destructors, CXTColorBase Enumerations, CXTColorBase Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorBase Class

CXTColorBase is a CStatic derived base class. It is used to create custom color selection windows.

Class Hierarchy

class CXTColorBase : public CStatic;
File

XTColorPageCustom.h

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
CXTColorBase Constructors
CXTColorBase Constructors | Description
CXTColorBase | Constructs a CXTColorBase object
CXTColorBase Data Members
CXTColorBase Data Members | Description
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_eHasFocus | Determines which property page has input focus.
m_nHue | Current hue value.
m_nLum | Current illumination value.
m_nSat | Current saturation value.
m_ptMousePos | Current mouse position relative to the device context.
CXTColorBase Destructors
CXTColorBase Destructors | Description
~CXTColorBase | Destroys a CXTColorBase object, handles cleanup and deallocation
CXTColorBase Enumerations
CXTColorBase Enumerations | Description
FocusedControl | Enumeration used to determine window focus.
CXTColorBase Methods
CXTColorBase Methods | Description
HLStoRGB | This member function is called to convert an HLS value to an RGB color value.
Init | This member function is called by the CXTColorBase class to perform initialization when the window is created or sub-classed.
RGBtoHSL | This member function is called to convert an RGB color value to an HSL value.
UpdateCursorPos | Call this member function to update the cursor position.


CXTColorBase Enumerations

Enumerations, CXTColorBase Class, Legend
CXTColorBase Enumerations
Enumerations
Enumeration | Description
FocusedControl | Enumeration used to determine window focus.
Class

CXTColorBase Class

Legend
Enumeration


CXTColorBase::FocusedControl Enumeration

XTColorPageCustom.h, CXTColorBase Enumerations, See Also
CXTColorBase::FocusedControl Enumeration

Enumeration used to determine window focus.

enum FocusedControl {
  focusNone,
  focusColorWheel,
  focusLumination
};
File

XTColorPageCustom.h

Members

focusNone
Color window does not have input focus.
focusColorWheel
Color wheel window has focus.
focusLumination
Lumination window has focus.

Remarks

FocusControl type defines the constants used by CXTColorBase for determining which area of the color window control has focus.

See Also

CXTColorBase

Group

CXTColorBase Enumerations


CXTColorBase Data Members

CXTColorBase Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorBase Data Members
Class

CXTColorBase Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_eHasFocus | Determines which property page has input focus.
Public Data Members
Public Data Member | Description
m_nHue | Current hue value.
m_nLum | Current illumination value.
m_nSat | Current saturation value.
m_ptMousePos | Current mouse position relative to the device context.


CXTColorBase::m_bPreSubclassInit Data Member

CXTColorBase Data Members, CXTColorBase Class
CXTColorBase::m_bPreSubclassInit Data Member

true when initializing from PreSubclassWindow.

bool m_bPreSubclassInit;
Group

CXTColorBase Data Members


CXTColorBase::m_eHasFocus Data Member

CXTColorBase Data Members, CXTColorBase Class
CXTColorBase::m_eHasFocus Data Member

Determines which property page has input focus.

FocusedControl m_eHasFocus;
Group

CXTColorBase Data Members


CXTColorBase::m_nHue Data Member

CXTColorBase Data Members, CXTColorBase Class
CXTColorBase::m_nHue Data Member

Current hue value.

double m_nHue;
Group

CXTColorBase Data Members


CXTColorBase::m_nLum Data Member

CXTColorBase Data Members, CXTColorBase Class
CXTColorBase::m_nLum Data Member

Current illumination value.

double m_nLum;
Group

CXTColorBase Data Members


CXTColorBase::m_nSat Data Member

CXTColorBase Data Members, CXTColorBase Class
CXTColorBase::m_nSat Data Member

Current saturation value.

double m_nSat;
Group

CXTColorBase Data Members


CXTColorBase::m_ptMousePos Data Member

CXTColorBase Data Members, CXTColorBase Class
CXTColorBase::m_ptMousePos Data Member

Current mouse position relative to the device context.

CPoint m_ptMousePos;
Group

CXTColorBase Data Members


CXTColorBase Methods

CXTColorBase Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorBase Methods
Class

CXTColorBase Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Init | This member function is called by the CXTColorBase class to perform initialization when the window is created or sub-classed.
Public Methods
Public Methods
Public Method | Description
HLStoRGB | This member function is called to convert an HLS value to an RGB color value.
RGBtoHSL | This member function is called to convert an RGB color value to an HSL value.
UpdateCursorPos | Call this member function to update the cursor position.


CXTColorBase::HLStoRGB Method

CXTColorBase Methods, CXTColorBase Class
CXTColorBase::HLStoRGB Method

This member function is called to convert an HLS value to an RGB color value.

static COLORREF HLStoRGB(
    double h,
    double l,
    double s
);
Parameters

h
Represents the color hue.
l
Represents the color illumination.
s
Represents the color saturation.

Returns

A COLORREF value.

Group

CXTColorBase Methods


CXTColorBase::Init Method

CXTColorBase Methods, CXTColorBase Class
CXTColorBase::Init Method

This member function is called by the CXTColorBase class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTColorBase Methods


CXTColorBase::RGBtoHSL Method

CXTColorBase Methods, CXTColorBase Class
CXTColorBase::RGBtoHSL Method

This member function is called to convert an RGB color value to an HSL value.

static void RGBtoHSL(
    COLORREF color,
    double * h,
    double * s,
    double* l
);
Parameters

color
An RGB value that represents the value to convert to HSL.
h
Represents the color hue.
s
Represents the color saturation.
l
Represents the color illumination.

Group

CXTColorBase Methods


CXTColorBase::UpdateCursorPos Method

CXTColorBase Methods, CXTColorBase Class
CXTColorBase::UpdateCursorPos Method

Call this member function to update the cursor position.

virtual void UpdateCursorPos(
    CPoint point
);
Parameters

point
Current cursor location relative to the device context.

Group

CXTColorBase Methods


CXTColorBase Constructors

CXTColorBase Class, Legend, Public Methods
CXTColorBase Constructors
Class

CXTColorBase Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorBase | Constructs a CXTColorBase object


CXTColorBase::CXTColorBase Constructor

CXTColorBase Constructors, CXTColorBase Class
CXTColorBase::CXTColorBase Constructor

Constructs a CXTColorBase object

CXTColorBase();
Group

CXTColorBase Constructors


CXTColorBase Destructors

CXTColorBase Class, Legend, Public Methods
CXTColorBase Destructors
Class

CXTColorBase Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorBase | Destroys a CXTColorBase object, handles cleanup and deallocation


CXTColorBase::~CXTColorBase Destructor

CXTColorBase Destructors, CXTColorBase Class
CXTColorBase::~CXTColorBase Destructor

Destroys a CXTColorBase object, handles cleanup and deallocation

virtual ~CXTColorBase();
Group

CXTColorBase Destructors


CXTColorDialog Class

XTColorDialog.h, Classes, Legend, Members, Topics, CXTColorDialog Data Members, CXTColorDialog Methods, CXTColorDialog Constructors, CXTColorDialog Destructors, CXTColorDialog Constructors, CXTColorDialog Data Members, CXTColorDialog Destructors, CXTColorDialog Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorDialog Class

CXTColorDialog is a CPropertySheet derived class. It is an Office(tm) style color dialog and can be used as a drop in replacement for the MFC CColorDialog API.

Class Hierarchy

class CXTColorDialog : public CPropertySheet;
File

XTColorDialog.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTColorDialog Constructors
CXTColorDialog Constructors | Description
CXTColorDialog | Constructs a CXTColorDialog object
CXTColorDialog Data Members
CXTColorDialog Data Members | Description
m_clrCurrent | A COLORREF value that contains the RGB information for the current color.
m_clrNew | A COLORREF value that contains the RGB information for the new color.
m_dwStyle | Styles for the dialog.
m_editHex | Edit window to display the color hex value.
m_rcCurrent | Size of the rectangle that represents the current color.
m_rcNew | Size of the rectangle that represents the new color.
CXTColorDialog Destructors
CXTColorDialog Destructors | Description
~CXTColorDialog | Destroys a CXTColorDialog object, handles cleanup and deallocation
CXTColorDialog Methods
CXTColorDialog Methods | Description
CalculateRects | Calculates the size of the dialog's tab control.
CopyToClipboard | Call this member function to copy the string specified by 'strText' to the Windows clipboard.
GetColor | Call this member function to retrieve the information about the color that the user selected.
GetCurrentColor | Call this member function to retrieve the information about the current color.
RGBtoHex | This member function returns a CString object that represents the HEX conversion for the specified RGB color.
SetCurrentColor | Call this function to set the new color selection to the color value specified in 'clr'.
SetNewColor | Sets the active color for the dialog.


CXTColorDialog Data Members

CXTColorDialog Class, Legend, Protected Data Members
CXTColorDialog Data Members
Class

CXTColorDialog Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrCurrent | A COLORREF value that contains the RGB information for the current color.
m_clrNew | A COLORREF value that contains the RGB information for the new color.
m_dwStyle | Styles for the dialog.
m_editHex | Edit window to display the color hex value.
m_rcCurrent | Size of the rectangle that represents the current color.
m_rcNew | Size of the rectangle that represents the new color.


CXTColorDialog::m_clrCurrent Data Member

CXTColorDialog Data Members, CXTColorDialog Class
CXTColorDialog::m_clrCurrent Data Member

A COLORREF value that contains the RGB information for the current color.

COLORREF m_clrCurrent;
Group

CXTColorDialog Data Members


CXTColorDialog::m_clrNew Data Member

CXTColorDialog Data Members, CXTColorDialog Class
CXTColorDialog::m_clrNew Data Member

A COLORREF value that contains the RGB information for the new color.

COLORREF m_clrNew;
Group

CXTColorDialog Data Members


CXTColorDialog::m_dwStyle Data Member

CXTColorDialog Data Members, CXTColorDialog Class
CXTColorDialog::m_dwStyle Data Member

Styles for the dialog.

DWORD m_dwStyle;
Group

CXTColorDialog Data Members


CXTColorDialog::m_editHex Data Member

CXTColorDialog Data Members, CXTColorDialog Class
CXTColorDialog::m_editHex Data Member

Edit window to display the color hex value.

CEdit m_editHex;
Group

CXTColorDialog Data Members


CXTColorDialog::m_rcCurrent Data Member

CXTColorDialog Data Members, CXTColorDialog Class
CXTColorDialog::m_rcCurrent Data Member

Size of the rectangle that represents the current color.

CRect m_rcCurrent;
Group

CXTColorDialog Data Members


CXTColorDialog::m_rcNew Data Member

CXTColorDialog Data Members, CXTColorDialog Class
CXTColorDialog::m_rcNew Data Member

Size of the rectangle that represents the new color.

CRect m_rcNew;
Group

CXTColorDialog Data Members


CXTColorDialog Methods

CXTColorDialog Class, Legend, Public Methods
CXTColorDialog Methods
Class

CXTColorDialog Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
CalculateRects | Calculates the size of the dialog's tab control.
CopyToClipboard | Call this member function to copy the string specified by 'strText' to the Windows clipboard.
GetColor | Call this member function to retrieve the information about the color that the user selected.
GetCurrentColor | Call this member function to retrieve the information about the current color.
RGBtoHex | This member function returns a CString object that represents the HEX conversion for the specified RGB color.
SetCurrentColor | Call this function to set the new color selection to the color value specified in 'clr'.
SetNewColor | Sets the active color for the dialog.


CXTColorDialog::CalculateRects Method

CXTColorDialog Methods, CXTColorDialog Class
CXTColorDialog::CalculateRects Method

Calculates the size of the dialog's tab control.

virtual void CalculateRects();
Remarks

This function is used to calculate the size of the dialog's tab control, the first tab item, the size of the OK button, and the size of the cancel button. Then, resize the tab control to fit on the dialog. Also, reposition the OK and Cancel buttons. Next, reposition the Hex-Display. Finally, resize the property sheet.

Group

CXTColorDialog Methods


CXTColorDialog::CopyToClipboard Method

CXTColorDialog Methods, CXTColorDialog Class
CXTColorDialog::CopyToClipboard Method

Call this member function to copy the string specified by 'strText' to the Windows clipboard.

BOOL CopyToClipboard(
    const CString& strText
);
Parameters

strText
A NULL terminated string.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTColorDialog Methods


CXTColorDialog::GetColor Method

CXTColorDialog Methods, CXTColorDialog Class, Body Source
CXTColorDialog::GetColor Method

Call this member function to retrieve the information about the color that the user selected.

COLORREF GetColor();
Returns

A COLORREF value that contains the RGB information for the new color selected in the color dialog box.

Body Source
COLORREF CXTColorDialog::GetColor() {
    return m_clrNew;
}
Group

CXTColorDialog Methods


CXTColorDialog::GetCurrentColor Method

CXTColorDialog Methods, CXTColorDialog Class, Body Source
CXTColorDialog::GetCurrentColor Method

Call this member function to retrieve the information about the current color.

COLORREF GetCurrentColor();
Returns

A COLORREF value that contains the RGB information for the current color specified when the dialog was instantiated.

Body Source
COLORREF CXTColorDialog::GetCurrentColor() {
    return m_clrCurrent;
}
Group

CXTColorDialog Methods


CXTColorDialog::RGBtoHex Method

CXTColorDialog Methods, CXTColorDialog Class
CXTColorDialog::RGBtoHex Method

This member function returns a CString object that represents the HEX conversion for the specified RGB color.

static CString RGBtoHex(
    COLORREF clr
);
Parameters

clr
An RGB value that represents the color.

Returns

A CString object.

Group

CXTColorDialog Methods


CXTColorDialog::SetCurrentColor Method

CXTColorDialog Methods, CXTColorDialog Class
CXTColorDialog::SetCurrentColor Method

Call this function to set the new color selection to the color value specified in 'clr'.

void SetCurrentColor(
    COLORREF clr
);
Parameters

clr
An RGB value that represents the color.

Group

CXTColorDialog Methods


CXTColorDialog::SetNewColor Method

CXTColorDialog Methods, CXTColorDialog Class
CXTColorDialog::SetNewColor Method

Sets the active color for the dialog.

void SetNewColor(
    COLORREF clr,
    BOOL bNotify = TRUE
);
Parameters

clr
An RGB value that represents the color.
bNotify
TRUE to notify tab pages of a color change.

Remarks

Call this member function to set the current color selection to the color value specified in 'clr'. The dialog box will automatically update the user's selection based on the value of the 'clr' parameter.

Group

CXTColorDialog Methods


CXTColorDialog Constructors

CXTColorDialog Class, Legend, Public Methods
CXTColorDialog Constructors
Class

CXTColorDialog Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorDialog | Constructs a CXTColorDialog object


CXTColorDialog::CXTColorDialog Constructor

CXTColorDialog Constructors, CXTColorDialog Class, See Also
CXTColorDialog::CXTColorDialog Constructor

Constructs a CXTColorDialog object

CXTColorDialog(
    COLORREF clrNew,
    COLORREF clrCurrent,
    DWORD dwFlags = 0L,
    CWnd* pWndParent = NULL
);
Parameters

clrNew
An RGB value that represents the new color selection.
clrCurrent
An RGB value that represents the default color selection.
dwFlags
Style for color dialog. See the Remarks section for available styles.
pWndParent
A pointer to the dialog box's parent or owner window.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • CPS_XT_SHOW3DSELECTION Displays the color selection box with a 3D raised border.
  • CPS_XT_SHOWHEXVALUE Displays the hex equivalent of the selected color.
See Also

CXTColorPopup::Create, CXTColorSelectorCtrl::Create, CXTColorPicker::ModifyCPStyle

Group

CXTColorDialog Constructors


CXTColorDialog Destructors

CXTColorDialog Class, Legend, Public Methods
CXTColorDialog Destructors
Class

CXTColorDialog Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorDialog | Destroys a CXTColorDialog object, handles cleanup and deallocation


CXTColorDialog::~CXTColorDialog Destructor

CXTColorDialog Destructors, CXTColorDialog Class
CXTColorDialog::~CXTColorDialog Destructor

Destroys a CXTColorDialog object, handles cleanup and deallocation

virtual ~CXTColorDialog();
Group

CXTColorDialog Destructors


CXTColorHex Class

XTColorPageStandard.h, Classes, Legend, Members, Topics, CXTColorHex Data Members, CXTColorHex Methods, CXTColorHex Constructors, CXTColorHex Destructors, CXTColorHex Nested Types, CXTColorHex Constructors, CXTColorHex Data Members, CXTColorHex Destructors, CXTColorHex Methods, CXTColorHex Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorHex Class

CXTColorHex is a CStatic derived class. It displays a color selection grid used by CXTColorPageStandard.

Class Hierarchy

class CXTColorHex : public CStatic;
File

XTColorPageStandard.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTColorHex Constructors
CXTColorHex Constructors | Description
CXTColorHex | Constructs a CXTColorHex object
CXTColorHex Data Members
CXTColorHex Data Members | Description
clrSelArray | Hex colors.
m_arCells | Array of HEXCOLOR_CELL structs that represent displayed color cells.
m_bLBtnDown | TRUE when the left mouse button is pressed.
m_bmpPicker | Background device context.
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bSmallCell | TRUE when a small color cell is selected.
m_clrColor | A COLORREF value that contains the RGB information for the current color.
m_ptCurrent | Holds the last known selection point.
CXTColorHex Destructors
CXTColorHex Destructors | Description
~CXTColorHex | Destroys a CXTColorHex object, handles cleanup and deallocation
CXTColorHex Methods
CXTColorHex Methods | Description
ColorFromPoint | Retrieves a COLORREF value from a specified point.
DrawCell | This member function is called by the class to draw a single color cell.
DrawColorSelector | This member function is called to draw the selection window.
DrawLargeCell | This member function is called by the class to draw a single large color cell.
DrawLargeSelectCell | This member function is called to select a large color cell if any are selected.
DrawSelectCell | This member function is called to select a color cell if any are selected.
GetColorCell | Retrieves HEXCOLOR_CELL information for a color cell.
GetSelectedColor | Call this member function to return the currently selected color.
Init | This member function is called by the CXTColorHex class to perform initialization when the window is created or sub-classed.
IsValidColor | This member function is called to determine if the specified color is defined.
SelectColorCell | This member function is called to select a cell when a new selection is made.
SetSelectedColor |
UpdateSelection | This member function updates the color selection based on the XY coordinates specified by 'point'.
CXTColorHex Nested Types
CXTColorHex Nested Types | Description
CHexColorCellList | List for maintaining HEXCOLOR_CELL structures.


CXTColorHex Data Members

CXTColorHex Class, Legend, Protected Data Members
CXTColorHex Data Members
Class

CXTColorHex Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
clrSelArray | Hex colors.
m_arCells | Array of HEXCOLOR_CELL structs that represent displayed color cells.
m_bLBtnDown | TRUE when the left mouse button is pressed.
m_bmpPicker | Background device context.
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bSmallCell | TRUE when a small color cell is selected.
m_clrColor | A COLORREF value that contains the RGB information for the current color.
m_ptCurrent | Holds the last known selection point.


CXTColorHex::clrSelArray Data Member

CXTColorHex Data Members, CXTColorHex Class
CXTColorHex::clrSelArray Data Member

Hex colors.

const COLORREF clrSelArray[];
Group

CXTColorHex Data Members


CXTColorHex::m_arCells Data Member

CXTColorHex Data Members, CXTColorHex Class
CXTColorHex::m_arCells Data Member

Array of HEXCOLOR_CELL structs that represent displayed color cells.

CHexColorCellList m_arCells;
Group

CXTColorHex Data Members


CXTColorHex::m_bLBtnDown Data Member

CXTColorHex Data Members, CXTColorHex Class
CXTColorHex::m_bLBtnDown Data Member

TRUE when the left mouse button is pressed.

BOOL m_bLBtnDown;
Group

CXTColorHex Data Members


CXTColorHex::m_bmpPicker Data Member

CXTColorHex Data Members, CXTColorHex Class
CXTColorHex::m_bmpPicker Data Member

Background device context.

CBitmap m_bmpPicker;
Group

CXTColorHex Data Members


CXTColorHex::m_bPreSubclassInit Data Member

CXTColorHex Data Members, CXTColorHex Class
CXTColorHex::m_bPreSubclassInit Data Member

true when initializing from PreSubclassWindow.

bool m_bPreSubclassInit;
Group

CXTColorHex Data Members


CXTColorHex::m_bSmallCell Data Member

CXTColorHex Data Members, CXTColorHex Class
CXTColorHex::m_bSmallCell Data Member

TRUE when a small color cell is selected.

BOOL m_bSmallCell;
Group

CXTColorHex Data Members


CXTColorHex::m_clrColor Data Member

CXTColorHex Data Members, CXTColorHex Class
CXTColorHex::m_clrColor Data Member

A COLORREF value that contains the RGB information for the current color.

COLORREF m_clrColor;
Group

CXTColorHex Data Members


CXTColorHex::m_ptCurrent Data Member

CXTColorHex Data Members, CXTColorHex Class
CXTColorHex::m_ptCurrent Data Member

Holds the last known selection point.

CPoint m_ptCurrent;
Group

CXTColorHex Data Members


CXTColorHex Methods

CXTColorHex Class, Legend, Protected Methods, Public Methods
CXTColorHex Methods
Class

CXTColorHex Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawCell | This member function is called by the class to draw a single color cell.
DrawColorSelector | This member function is called to draw the selection window.
DrawLargeCell | This member function is called by the class to draw a single large color cell.
DrawLargeSelectCell | This member function is called to select a large color cell if any are selected.
DrawSelectCell | This member function is called to select a color cell if any are selected.
Init | This member function is called by the CXTColorHex class to perform initialization when the window is created or sub-classed.
IsValidColor | This member function is called to determine if the specified color is defined.
SelectColorCell | This member function is called to select a cell when a new selection is made.
UpdateSelection | This member function updates the color selection based on the XY coordinates specified by 'point'.
Public Methods
Public Methods
Public Method | Description
ColorFromPoint | Retrieves a COLORREF value from a specified point.
GetColorCell | Retrieves HEXCOLOR_CELL information for a color cell.
GetSelectedColor | Call this member function to return the currently selected color.
SetSelectedColor |


CXTColorHex::ColorFromPoint Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::ColorFromPoint Method

Retrieves a COLORREF value from a specified point.

COLORREF ColorFromPoint(
    CPoint point
);
Parameters

point
XY location of the color to retrieve RGB information for.

Remarks

Call this member function to retrieve RGB information for the color found at the location specified by point. Returns a COLORREF value.

Group

CXTColorHex Methods


CXTColorHex::DrawCell Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::DrawCell Method

This member function is called by the class to draw a single color cell.

void DrawCell(
    CDC* pDC,
    CPoint point,
    COLORREF clr,
    int l,
    int u,
    int r,
    int d
);
Parameters

pDC
A CDC pointer that represents the current device context.
point
XY position of the starting point for the first pixel drawn.
clr
An RGB value that represents the color of the cell to draw.
l
Index of the cell to be selected when VK_LEFT is pressed.
u
Index of the cell to be selected when VK_UP is pressed.
r
Index of the cell to be selected when VK_RIGHT is pressed.
d
Index of the cell to be selected when VK_DOWN is pressed.

Group

CXTColorHex Methods


CXTColorHex::DrawColorSelector Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::DrawColorSelector Method

This member function is called to draw the selection window.

void DrawColorSelector(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTColorHex Methods


CXTColorHex::DrawLargeCell Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::DrawLargeCell Method

This member function is called by the class to draw a single large color cell.

void DrawLargeCell(
    CDC* pDC,
    CPoint point,
    COLORREF clr,
    int l,
    int u,
    int r,
    int d
);
Parameters

pDC
A CDC pointer that represents the current device context.
point
XY position of the starting point for the first pixel drawn.
clr
An RGB value that represents the color of the cell to draw.
l
Index of the cell to be selected when VK_LEFT is pressed.
u
Index of the cell to be selected when VK_UP is pressed.
r
Index of the cell to be selected when VK_RIGHT is pressed.
d
Index of the cell to be selected when VK_DOWN is pressed.

Group

CXTColorHex Methods


CXTColorHex::DrawLargeSelectCell Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::DrawLargeSelectCell Method

This member function is called to select a large color cell if any are selected.

void DrawLargeSelectCell(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTColorHex Methods


CXTColorHex::DrawSelectCell Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::DrawSelectCell Method

This member function is called to select a color cell if any are selected.

void DrawSelectCell(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTColorHex Methods


CXTColorHex::GetColorCell Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::GetColorCell Method

Retrieves HEXCOLOR_CELL information for a color cell.

HEXCOLOR_CELL* GetColorCell(
    COLORREF clr
);
Parameters

clr
An RGB value that represents the color.

Returns

A pointer to an HEXCOLOR_CELL struct.

Remarks

Call this member function to get a pointer to the HEXCOLOR_CELL structure that is represented by 'clr'.

Group

CXTColorHex Methods


CXTColorHex::GetSelectedColor Method

CXTColorHex Methods, CXTColorHex Class, Body Source
CXTColorHex::GetSelectedColor Method

Call this member function to return the currently selected color.

COLORREF GetSelectedColor() const;
Returns

An RGB color value that represents the selected color.

Body Source
COLORREF CXTColorHex::GetSelectedColor() const {
    return m_clrColor;
}
Group

CXTColorHex Methods


CXTColorHex::Init Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::Init Method

This member function is called by the CXTColorHex class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTColorHex Methods


CXTColorHex::IsValidColor Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::IsValidColor Method

This member function is called to determine if the specified color is defined.

virtual bool IsValidColor(
    COLORREF cr
) const;
Parameters

cr
A COLORREF value to check.

Returns

Returns true if the color specified by cr is defined in the color array otherwise returns false.

Group

CXTColorHex Methods


CXTColorHex::SelectColorCell Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::SelectColorCell Method

This member function is called to select a cell when a new selection is made.

void SelectColorCell(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTColorHex Methods


SetSelectedColor Method

CXTColorHex Methods
SetSelectedColor Method
Overload List
Methods
Method | Description
CXTColorHex::SetSelectedColor (COLORREF) | Call this member function to select the color specified by 'iIndex'.
CXTColorHex::SetSelectedColor (int) | Call this member function to select the color specified by 'iIndex'.
Group

CXTColorHex Methods


CXTColorHex::SetSelectedColor Method (int)

SetSelectedColor Method, CXTColorHex Class
CXTColorHex::SetSelectedColor Method (int)

Call this member function to select the color specified by 'iIndex'.

void SetSelectedColor(
    int iIndex
);
void SetSelectedColor(
    COLORREF clr
);
Parameters

iIndex
Index into m_arCells list.
clr
An RGB value that represents the color.

Group

SetSelectedColor Method


CXTColorHex::UpdateSelection Method

CXTColorHex Methods, CXTColorHex Class
CXTColorHex::UpdateSelection Method

This member function updates the color selection based on the XY coordinates specified by 'point'.

void UpdateSelection(
    CPoint point
);
Parameters

point
Current location of the color to select.

Group

CXTColorHex Methods


CXTColorHex Constructors

CXTColorHex Class, Legend, Public Methods
CXTColorHex Constructors
Class

CXTColorHex Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorHex | Constructs a CXTColorHex object


CXTColorHex::CXTColorHex Constructor

CXTColorHex Constructors, CXTColorHex Class
CXTColorHex::CXTColorHex Constructor

Constructs a CXTColorHex object

CXTColorHex();
Group

CXTColorHex Constructors


CXTColorHex Destructors

CXTColorHex Class, Legend, Public Methods
CXTColorHex Destructors
Class

CXTColorHex Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorHex | Destroys a CXTColorHex object, handles cleanup and deallocation


CXTColorHex::~CXTColorHex Destructor

CXTColorHex Destructors, CXTColorHex Class
CXTColorHex::~CXTColorHex Destructor

Destroys a CXTColorHex object, handles cleanup and deallocation

virtual ~CXTColorHex();
Group

CXTColorHex Destructors


CXTColorHex Nested Types

CXTColorHex Class, Public Nested Types
CXTColorHex Nested Types
Class

CXTColorHex Class

Public Nested Types
Public Nested Type | Description
CHexColorCellList | List for maintaining HEXCOLOR_CELL structures.


CXTColorHex::CHexColorCellList Nested Type

CXTColorHex Nested Types, CXTColorHex Class, See Also
CXTColorHex::CHexColorCellList Nested Type

List for maintaining HEXCOLOR_CELL structures.

typedef CList<HEXCOLOR_CELL*, HEXCOLOR_CELL*> CHexColorCellList;
Remarks

CList definition used by the CXTColorHex control to maintain a list of HEXCOLOR_CELL structures representing each color cell in the hex color control.

See Also

CXTColorHex, HEXCOLOR_CELL

Group

CXTColorHex Nested Types


CXTColorLum Class

XTColorPageCustom.h, Classes, Legend, Members, Topics, CXTColorLum Methods, CXTColorLum Constructors, CXTColorLum Destructors, CXTColorLum Constructors, CXTColorLum Destructors, CXTColorLum Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorLum Class

CXTColorLum is a CXTColorBase derived class. It is used to create a color luminance selection bar.

Class Hierarchy

class CXTColorLum : public CXTColorBase;
File

XTColorPageCustom.h

Group

Classes

Legend
Method
virtual
CXTColorLum Constructors
CXTColorLum Constructors | Description
CXTColorLum | Constructs a CXTColorLum object
CXTColorLum Destructors
CXTColorLum Destructors | Description
~CXTColorLum | Destroys a CXTColorLum object, handles cleanup and deallocation
CXTColorLum Methods
CXTColorLum Methods | Description
DrawLuminanceBar | This member function is called to draw the selection bar.
DrawSliderArrow | This member function is called to draw the indicator arrow.
GetLumBarRect | This member function is called to retrieve the display size of the luminance bar.
SetColor | Call this member function to set the color for the selection window.
SetLuminance | This member function is called to set the luminance for the color window.
UpdateCursorPos | Call this member function to update the cursor position.


CXTColorLum Methods

CXTColorLum Class, Legend, Public Methods
CXTColorLum Methods
Class

CXTColorLum Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawLuminanceBar | This member function is called to draw the selection bar.
DrawSliderArrow | This member function is called to draw the indicator arrow.
GetLumBarRect | This member function is called to retrieve the display size of the luminance bar.
SetColor | Call this member function to set the color for the selection window.
SetLuminance | This member function is called to set the luminance for the color window.
UpdateCursorPos | Call this member function to update the cursor position.


CXTColorLum::DrawLuminanceBar Method

CXTColorLum Methods, CXTColorLum Class
CXTColorLum::DrawLuminanceBar Method

This member function is called to draw the selection bar.

void DrawLuminanceBar(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTColorLum Methods


CXTColorLum::DrawSliderArrow Method

CXTColorLum Methods, CXTColorLum Class
CXTColorLum::DrawSliderArrow Method

This member function is called to draw the indicator arrow.

void DrawSliderArrow(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTColorLum Methods


CXTColorLum::GetLumBarRect Method

CXTColorLum Methods, CXTColorLum Class
CXTColorLum::GetLumBarRect Method

This member function is called to retrieve the display size of the luminance bar.

void GetLumBarRect(
    CRect& rect
);
Parameters

rect
Address to a CRect object.

Group

CXTColorLum Methods


CXTColorLum::SetColor Method

CXTColorLum Methods, CXTColorLum Class
CXTColorLum::SetColor Method

Call this member function to set the color for the selection window.

virtual void SetColor(
    double nHue,
    double nSat
);
Parameters

nHue
Current hue value that represents the color.
nSat
Current saturation value that represents the color.

Group

CXTColorLum Methods


CXTColorLum::SetLuminance Method

CXTColorLum Methods, CXTColorLum Class
CXTColorLum::SetLuminance Method

This member function is called to set the luminance for the color window.

void SetLuminance(
    double l
);
Parameters

l
Represents the new luminance value to set.

Group

CXTColorLum Methods


CXTColorLum::UpdateCursorPos Method

CXTColorLum Methods, CXTColorLum Class
CXTColorLum::UpdateCursorPos Method

Call this member function to update the cursor position.

virtual void UpdateCursorPos(
    CPoint point
);
Parameters

point
Current cursor location relative to the device context.

Group

CXTColorLum Methods


CXTColorLum Constructors

CXTColorLum Class, Legend, Public Methods
CXTColorLum Constructors
Class

CXTColorLum Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorLum | Constructs a CXTColorLum object


CXTColorLum::CXTColorLum Constructor

CXTColorLum Constructors, CXTColorLum Class
CXTColorLum::CXTColorLum Constructor

Constructs a CXTColorLum object

CXTColorLum();
Group

CXTColorLum Constructors


CXTColorLum Destructors

CXTColorLum Class, Legend, Public Methods
CXTColorLum Destructors
Class

CXTColorLum Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorLum | Destroys a CXTColorLum object, handles cleanup and deallocation


CXTColorLum::~CXTColorLum Destructor

CXTColorLum Destructors, CXTColorLum Class
CXTColorLum::~CXTColorLum Destructor

Destroys a CXTColorLum object, handles cleanup and deallocation

virtual ~CXTColorLum();
Group

CXTColorLum Destructors


CXTColorPageCustom Class

XTColorPageCustom.h, Classes, Legend, Members, Topics, CXTColorPageCustom Data Members, CXTColorPageCustom Methods, CXTColorPageCustom Constructors, CXTColorPageCustom Destructors, CXTColorPageCustom Constructors, CXTColorPageCustom Data Members, CXTColorPageCustom Destructors, CXTColorPageCustom Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPageCustom Class

CXTColorPageCustom is derived from CXTThemePropertyPage. It is used to create a CXTColorPageCustom dialog.

Class Hierarchy

class CXTColorPageCustom : public CPropertyPage;
File

XTColorPageCustom.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTColorPageCustom Constructors
CXTColorPageCustom Constructors | Description
CXTColorPageCustom | Constructs a CXTColorPageCustom object
CXTColorPageCustom Data Members
CXTColorPageCustom Data Members | Description
m_pParentSheet | Points to the parent property sheet
CXTColorPageCustom Destructors
CXTColorPageCustom Destructors | Description
~CXTColorPageCustom | Destroys a CXTColorPageCustom object, handles cleanup and deallocation
CXTColorPageCustom Methods
CXTColorPageCustom Methods | Description
RGBtoHSL | This member function is called to retrieve the HSL values of the RGB specified by color.


CXTColorPageCustom Data Members

CXTColorPageCustom Class, Legend, Protected Data Members
CXTColorPageCustom Data Members
Class

CXTColorPageCustom Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pParentSheet | Points to the parent property sheet


CXTColorPageCustom::m_pParentSheet Data Member

CXTColorPageCustom Data Members, CXTColorPageCustom Class
CXTColorPageCustom::m_pParentSheet Data Member

Points to the parent property sheet

CXTColorDialog* m_pParentSheet;
Group

CXTColorPageCustom Data Members


CXTColorPageCustom Methods

CXTColorPageCustom Class, Legend, Public Methods
CXTColorPageCustom Methods
Class

CXTColorPageCustom Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RGBtoHSL | This member function is called to retrieve the HSL values of the RGB specified by color.


CXTColorPageCustom::RGBtoHSL Method

CXTColorPageCustom Methods, CXTColorPageCustom Class
CXTColorPageCustom::RGBtoHSL Method

This member function is called to retrieve the HSL values of the RGB specified by color.

void RGBtoHSL(
    COLORREF color,
    int* xtFocusLumination,
    int* sat,
    int* hue
);
Parameters

color
An RGB value that represents the color.
xtFocusLumination
Address of the integer to receive the illumination value (0-255).
sat
Address of the integer to receive the saturation value (0-255).
hue
Address of the integer to receive the hue value (0-255).

Group

CXTColorPageCustom Methods


CXTColorPageCustom Constructors

CXTColorPageCustom Class, Legend, Public Methods
CXTColorPageCustom Constructors
Class

CXTColorPageCustom Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorPageCustom | Constructs a CXTColorPageCustom object


CXTColorPageCustom::CXTColorPageCustom Constructor

CXTColorPageCustom Constructors, CXTColorPageCustom Class
CXTColorPageCustom::CXTColorPageCustom Constructor

Constructs a CXTColorPageCustom object

CXTColorPageCustom(
    CXTColorDialog* pParentSheet = NULL
);
Parameters

pParentSheet
A pointer to the parent sheet.

Group

CXTColorPageCustom Constructors


CXTColorPageCustom Destructors

CXTColorPageCustom Class, Legend, Public Methods
CXTColorPageCustom Destructors
Class

CXTColorPageCustom Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorPageCustom | Destroys a CXTColorPageCustom object, handles cleanup and deallocation


CXTColorPageCustom::~CXTColorPageCustom Destructor

CXTColorPageCustom Destructors, CXTColorPageCustom Class
CXTColorPageCustom::~CXTColorPageCustom Destructor

Destroys a CXTColorPageCustom object, handles cleanup and deallocation

virtual ~CXTColorPageCustom();
Group

CXTColorPageCustom Destructors


CXTColorPageStandard Class

XTColorPageStandard.h, Classes, Legend, Members, Topics, CXTColorPageStandard Data Members, CXTColorPageStandard Methods, CXTColorPageStandard Constructors, CXTColorPageStandard Destructors, CXTColorPageStandard Constructors, CXTColorPageStandard Data Members, CXTColorPageStandard Destructors, CXTColorPageStandard Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPageStandard Class

CXTColorPageStandard is derived from CXTThemePropertyPage, it is used to create a CXTColorPageStandard dialog.

Class Hierarchy

class CXTColorPageStandard : public CPropertyPage;
File

XTColorPageStandard.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTColorPageStandard Constructors
CXTColorPageStandard Constructors | Description
CXTColorPageStandard | Constructs a CXTColorPageStandard object
CXTColorPageStandard Data Members
CXTColorPageStandard Data Members | Description
m_colorHex | ColorHex control.
m_pParentSheet | Points to the parent property sheet
CXTColorPageStandard Destructors
CXTColorPageStandard Destructors | Description
~CXTColorPageStandard | Destroys a CXTColorPageStandard object, handles cleanup and deallocation
CXTColorPageStandard Methods
CXTColorPageStandard Methods | Description
SetColor | This member function is called to set the selected color for the page.


CXTColorPageStandard Data Members

CXTColorPageStandard Class, Legend, Protected Data Members
CXTColorPageStandard Data Members
Class

CXTColorPageStandard Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_colorHex | ColorHex control.
m_pParentSheet | Points to the parent property sheet


CXTColorPageStandard::m_colorHex Data Member

CXTColorPageStandard Data Members, CXTColorPageStandard Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPageStandard::m_colorHex Data Member

ColorHex control.

CXTColorHex m_colorHex;
Group

CXTColorPageStandard Data Members


CXTColorPageStandard::m_pParentSheet Data Member

CXTColorPageStandard Data Members, CXTColorPageStandard Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPageStandard::m_pParentSheet Data Member

Points to the parent property sheet

CXTColorDialog* m_pParentSheet;
Group

CXTColorPageStandard Data Members


CXTColorPageStandard Methods

CXTColorPageStandard Class, Legend, Public Methods
CXTColorPageStandard Methods
Class

CXTColorPageStandard Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetColor | This member function is called to set the selected color for the page.


CXTColorPageStandard::SetColor Method

CXTColorPageStandard Methods, CXTColorPageStandard Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPageStandard::SetColor Method

This member function is called to set the selected color for the page.

void SetColor(
    COLORREF clr
);
Parameters

clr
An RGB value that represents the color.

Body Source
void CXTColorPageStandard::SetColor(COLORREF clr) {
    m_colorHex.SetSelectedColor(clr);
}
Group

CXTColorPageStandard Methods


CXTColorPageStandard Constructors

CXTColorPageStandard Class, Legend, Public Methods
CXTColorPageStandard Constructors
Class

CXTColorPageStandard Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorPageStandard | Constructs a CXTColorPageStandard object


CXTColorPageStandard::CXTColorPageStandard Constructor

CXTColorPageStandard Constructors, CXTColorPageStandard Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPageStandard::CXTColorPageStandard Constructor

Constructs a CXTColorPageStandard object

CXTColorPageStandard(
    CXTColorDialog* pParentSheet = NULL
);
Parameters

pParentSheet
Points to the parent property sheet.

Group

CXTColorPageStandard Constructors


CXTColorPageStandard Destructors

CXTColorPageStandard Class, Legend, Public Methods
CXTColorPageStandard Destructors
Class

CXTColorPageStandard Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorPageStandard | Destroys a CXTColorPageStandard object, handles cleanup and deallocation


CXTColorPageStandard::~CXTColorPageStandard Destructor

CXTColorPageStandard Destructors, CXTColorPageStandard Class
CXTColorPageStandard::~CXTColorPageStandard Destructor

Destroys a CXTColorPageStandard object, handles cleanup and deallocation

virtual ~CXTColorPageStandard();
Group

CXTColorPageStandard Destructors


CXTColorPicker Class

XTColorPicker.h, Classes, Legend, Members, Topics, CXTColorPicker Data Members, CXTColorPicker Methods, CXTColorPicker Constructors, CXTColorPicker Destructors, CXTColorPicker Constructors, CXTColorPicker Data Members, CXTColorPicker Destructors, CXTColorPicker Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPicker Class

CXTColorPicker is a CXTButton derived class. It displays a color picker popup window (CXTColorPopup) for Office(tm) style color selection.

Class Hierarchy

class CXTColorPicker : public CXTButton;
File

XTColorPicker.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTColorPicker Constructors
CXTColorPicker Constructors | Description
CXTColorPicker | Constructs a CXTColorPicker object
CXTColorPicker Data Members
CXTColorPicker Data Members | Description
m_bColorText | TRUE if the color picker text is colorized; only valid if m_bShowText is TRUE.
m_bPopupActive | TRUE if the popup window is currently active.
m_bShowText | TRUE if the color picker displays text.
m_clrDefault | An RGB value that represents the color for the default color.
m_clrSelected | An RGB value that represents the color for the display color.
m_dwPopup | Represents the style for the color picker.
m_nCols | Number of columns in the color popup window.
m_nExtendedColors | Custom colors count
m_pExtendedColors | Custom colors
CXTColorPicker Destructors
CXTColorPicker Destructors | Description
~CXTColorPicker | Destroys a CXTColorPicker object, handles cleanup and deallocation
CXTColorPicker Methods
CXTColorPicker Methods | Description
GetColor | This member function will return the currently selected color.
GetContrastColor | Retrieves the background contrast color for the CXTColorPicker.
GetDefaultColor | This member function will return the default RGB color value for the color picker.
Init | This member function is called by the CXTColorPicker class to perform initialization when the window is created or sub-classed.
IsTextInColor | This member function will determine if the text for the color picker button control is displayed in color.
IsTextShown | This member function will determine if text is displayed for the color picker button control.
ModifyCPStyle | Call this member function to modify the color picker display style.
SetColor | This member function will set the color value for the color picker.
SetColors | Call this method to set custom colors for color picker
SetDefaultColor | This member function will set the default RGB color value for the color picker.
ShowPopupWindow | This member function will activate the color picker and display the color popup window.
ShowText | This member function will display any text associated with the color picker button control. If the button has text, it will be displayed.
ShowTextInColor | This member function will display any text associated with the color picker button control in color.


CXTColorPicker Data Members

CXTColorPicker Class, Legend, Protected Data Members
CXTColorPicker Data Members
Class

CXTColorPicker Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bColorText | TRUE if the color picker text is colorized; only valid if m_bShowText is TRUE.
m_bPopupActive | TRUE if the popup window is currently active.
m_bShowText | TRUE if the color picker displays text.
m_clrDefault | An RGB value that represents the color for the default color.
m_clrSelected | An RGB value that represents the color for the display color.
m_dwPopup | Represents the style for the color picker.
m_nCols | Number of columns in the color popup window.
m_nExtendedColors | Custom colors count
m_pExtendedColors | Custom colors


CXTColorPicker::m_bColorText Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_bColorText Data Member

TRUE if the color picker text is colorized; only valid if m_bShowText is TRUE.

BOOL m_bColorText;
Group

CXTColorPicker Data Members


CXTColorPicker::m_bPopupActive Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_bPopupActive Data Member

TRUE if the popup window is currently active.

BOOL m_bPopupActive;
Group

CXTColorPicker Data Members


CXTColorPicker::m_bShowText Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_bShowText Data Member

TRUE if the color picker displays text.

BOOL m_bShowText;
Group

CXTColorPicker Data Members


CXTColorPicker::m_clrDefault Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_clrDefault Data Member

An RGB value that represents the color for the default color.

COLORREF m_clrDefault;
Group

CXTColorPicker Data Members


CXTColorPicker::m_clrSelected Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_clrSelected Data Member

An RGB value that represents the color for the display color.

COLORREF m_clrSelected;
Group

CXTColorPicker Data Members


CXTColorPicker::m_dwPopup Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_dwPopup Data Member

Represents the style for the color picker.

DWORD m_dwPopup;
Group

CXTColorPicker Data Members


CXTColorPicker::m_nCols Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_nCols Data Member

Number of columns in the color popup window.

int m_nCols;
Group

CXTColorPicker Data Members


CXTColorPicker::m_nExtendedColors Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_nExtendedColors Data Member

Custom colors count

int m_nExtendedColors;
Group

CXTColorPicker Data Members


CXTColorPicker::m_pExtendedColors Data Member

CXTColorPicker Data Members, CXTColorPicker Class
CXTColorPicker::m_pExtendedColors Data Member

Custom colors

XTP_PICK_BUTTON* m_pExtendedColors;
Group

CXTColorPicker Data Members


CXTColorPicker Methods

CXTColorPicker Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPicker Methods
Class

CXTColorPicker Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetContrastColor | Retrieves the background contrast color for the CXTColorPicker.
Init | This member function is called by the CXTColorPicker class to perform initialization when the window is created or sub-classed.
Public Methods
Public Methods
Public Method | Description
GetColor | This member function will return the currently selected color.
GetDefaultColor | This member function will return the default RGB color value for the color picker.
IsTextInColor | This member function will determine if the text for the color picker button control is displayed in color.
IsTextShown | This member function will determine if text is displayed for the color picker button control.
ModifyCPStyle | Call this member function to modify the color picker display style.
SetColor | This member function will set the color value for the color picker.
SetColors | Call this method to set custom colors for color picker
SetDefaultColor | This member function will set the default RGB color value for the color picker.
ShowPopupWindow | This member function will activate the color picker and display the color popup window.
ShowText | This member function will display any text associated with the color picker button control. If the button has text, it will be displayed.
ShowTextInColor | This member function will display any text associated with the color picker button control in color.


CXTColorPicker::GetColor Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source
CXTColorPicker::GetColor Method

This member function will return the currently selected color.

virtual COLORREF GetColor() const;
Returns

An RGB color value that represents the currently selected color.

Body Source
COLORREF CXTColorPicker::GetColor() const {
    return m_clrSelected;
}
Group

CXTColorPicker Methods


CXTColorPicker::GetContrastColor Method

CXTColorPicker Methods, CXTColorPicker Class
CXTColorPicker::GetContrastColor Method

Retrieves the background contrast color for the CXTColorPicker.

virtual COLORREF GetContrastColor() const;
Returns

An RGB value either BLACK or WHITE.

Remarks

This member function is called to return the contrast color for the color picker button. The contrast color is used when text is displayed to contrast with the currently selected color. For example, if the currently selected color is WHITE, then BLACK would be returned so the text is legible.

Group

CXTColorPicker Methods


CXTColorPicker::GetDefaultColor Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source
CXTColorPicker::GetDefaultColor Method

This member function will return the default RGB color value for the color picker.

virtual COLORREF GetDefaultColor() const;
Returns

An RGB value that represents the default color value for the color picker.

Body Source
COLORREF CXTColorPicker::GetDefaultColor() const {
    return m_clrDefault;
}
Group

CXTColorPicker Methods


CXTColorPicker::Init Method

CXTColorPicker Methods, CXTColorPicker Class
CXTColorPicker::Init Method

This member function is called by the CXTColorPicker class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTColorPicker Methods


CXTColorPicker::IsTextInColor Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source
CXTColorPicker::IsTextInColor Method

This member function will determine if the text for the color picker button control is displayed in color.

virtual BOOL IsTextInColor() const;
Returns

TRUE if the button text is in color, otherwise returns FALSE.

Body Source
BOOL CXTColorPicker::IsTextInColor() const {
    return m_bColorText;
}
Group

CXTColorPicker Methods


CXTColorPicker::IsTextShown Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source
CXTColorPicker::IsTextShown Method

This member function will determine if text is displayed for the color picker button control.

virtual BOOL IsTextShown() const;
Returns

TRUE if the color picker displays text, otherwise returns FALSE.

Body Source
BOOL CXTColorPicker::IsTextShown() const {
    return m_bShowText;
}
Group

CXTColorPicker Methods


CXTColorPicker::ModifyCPStyle Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPicker::ModifyCPStyle Method

Call this member function to modify the color picker display style.

virtual void ModifyCPStyle(
    DWORD dwRemove,
    DWORD dwAdd
);
Parameters

dwRemove
Specifies the window styles to be removed during style modification.
dwAdd
Specifies the window styles to be added during style modification.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • CPS_XT_NOFILL The color picker will display a No Fill button rather than the default Automatic Color button.
  • CPS_XT_EXTENDED The color picker will display 40 extended colors rather than the default 16 colors.
  • CPS_XT_MORECOLORS The color picker will display a More Colors button which will display a CXTColorDialog.
  • CPS_XT_SHOW3DSELECTION Displays the color selection box with a 3D raised border in CXTColorDialog.
  • CPS_XT_SHOWHEXVALUE Displays the hex equivalent of the selected color.
See Also

CXTColorPopup::Create, CXTColorSelectorCtrl::Create

Body Source
void CXTColorPicker::ModifyCPStyle(DWORD dwRemove, DWORD dwAdd) {
    m_dwPopup &= ~dwRemove; m_dwPopup |= dwAdd; RedrawWindow();
}
Group

CXTColorPicker Methods


CXTColorPicker::SetColor Method

CXTColorPicker Methods, CXTColorPicker Class
CXTColorPicker::SetColor Method

This member function will set the color value for the color picker.

virtual void SetColor(
    COLORREF clr
);
Parameters

clr
An RGB value that represents the new RGB color for the control.

Group

CXTColorPicker Methods


CXTColorPicker::SetColors Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source
CXTColorPicker::SetColors Method

Call this method to set custom colors for color picker

void SetColors(
    XTP_PICK_BUTTON* pColors,
    int nCount,
    int nCols = 8
);
Parameters

pColors
Static array of colors and tooltips
nCount
Number of colors
nCols
Number of columns to show

Body Source
void CXTColorPicker::SetColors(XTP_PICK_BUTTON* pColors, int nCount, int nCols) {
    m_pExtendedColors = pColors;
    m_nExtendedColors = nCount;
    m_nCols = nCols;
}
Group

CXTColorPicker Methods


CXTColorPicker::SetDefaultColor Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source
CXTColorPicker::SetDefaultColor Method

This member function will set the default RGB color value for the color picker.

virtual void SetDefaultColor(
    COLORREF clrDefault
);
Parameters

clrDefault
An RGB value that represents the default color for the color picker.

Body Source
void CXTColorPicker::SetDefaultColor(COLORREF clrDefault) {
    m_clrDefault = clrDefault; RedrawWindow();
}
Group

CXTColorPicker Methods


CXTColorPicker::ShowPopupWindow Method

CXTColorPicker Methods, CXTColorPicker Class
CXTColorPicker::ShowPopupWindow Method

This member function will activate the color picker and display the color popup window.

virtual void ShowPopupWindow();
Group

CXTColorPicker Methods


CXTColorPicker::ShowText Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source
CXTColorPicker::ShowText Method

This member function will display any text associated with the color picker button control. If the button has text, it will be displayed.

virtual void ShowText(
    BOOL bShowText
);
Parameters

bShowText
TRUE to display button text.

Body Source
void CXTColorPicker::ShowText(BOOL bShowText) {
    m_bShowText = bShowText; RedrawWindow();
}
Group

CXTColorPicker Methods


CXTColorPicker::ShowTextInColor Method

CXTColorPicker Methods, CXTColorPicker Class, Body Source
CXTColorPicker::ShowTextInColor Method

This member function will display any text associated with the color picker button control in color.

virtual void ShowTextInColor(
    BOOL bColorText
);
Parameters

bColorText
TRUE to display the button text in color.

Body Source
void CXTColorPicker::ShowTextInColor(BOOL bColorText) {
    m_bColorText = bColorText; RedrawWindow();
}
Group

CXTColorPicker Methods


CXTColorPicker Constructors

CXTColorPicker Class, Legend, Public Methods
CXTColorPicker Constructors
Class

CXTColorPicker Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorPicker | Constructs a CXTColorPicker object


CXTColorPicker::CXTColorPicker Constructor

CXTColorPicker Constructors, CXTColorPicker Class
CXTColorPicker::CXTColorPicker Constructor

Constructs a CXTColorPicker object

CXTColorPicker();
Group

CXTColorPicker Constructors


CXTColorPicker Destructors

CXTColorPicker Class, Legend, Public Methods
CXTColorPicker Destructors
Class

CXTColorPicker Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorPicker | Destroys a CXTColorPicker object, handles cleanup and deallocation


CXTColorPicker::~CXTColorPicker Destructor

CXTColorPicker Destructors, CXTColorPicker Class
CXTColorPicker::~CXTColorPicker Destructor

Destroys a CXTColorPicker object, handles cleanup and deallocation

virtual ~CXTColorPicker();
Group

CXTColorPicker Destructors


CXTColorPopup Class

XTColorPopup.h, Classes, Legend, Members, Topics, CXTColorPopup Data Members, CXTColorPopup Methods, CXTColorPopup Constructors, CXTColorPopup Destructors, CXTColorPopup Constructors, CXTColorPopup Data Members, CXTColorPopup Destructors, CXTColorPopup Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPopup Class

CXTColorPopup is a CXTColorSelectorCtrl derived class. It is used to create a CXTColorPopup window that will allow a user to select colors and add custom colors to a color list.

Class Hierarchy

class CXTColorPopup : public CXTColorSelectorCtrl;
File

XTColorPopup.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTColorPopup Constructors
CXTColorPopup Constructors | Description
CXTColorPopup | Constructs a CXTColorPopup object.
CXTColorPopup Data Members
CXTColorPopup Data Members | Description
m_bAutoDelete | TRUE if the popup window is to be self deleting.
m_bDisplayShadow | TRUE if the popup window will render its shadow.
m_callerParam | Caller parameter that will be reported back as an LPARAM of all notification messages.
m_rcExclude | Area to exclude from shadow display.
CXTColorPopup Destructors
CXTColorPopup Destructors | Description
~CXTColorPopup | Destroys a CXTColorPopup object, handles cleanup and deallocation
CXTColorPopup Methods
CXTColorPopup Methods | Description
AddListener | This member function adds a window that picker notifications are sent to.
AddUserColor | This member function will add a color to the user defined color list.
Create | This member function handles the creation of the color popup window.
DisplayShadow | Enables or disables popup window shadow.
EndSelection | This member function will finish the selection process for the color box or button in the color popup window.
ResetUserColors | Resets the recently used color list.


CXTColorPopup Data Members

CXTColorPopup Class, Legend, Protected Data Members
CXTColorPopup Data Members
Class

CXTColorPopup Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoDelete | TRUE if the popup window is to be self deleting.
m_bDisplayShadow | TRUE if the popup window will render its shadow.
m_callerParam | Caller parameter that will be reported back as an LPARAM of all notification messages.
m_rcExclude | Area to exclude from shadow display.


CXTColorPopup::m_bAutoDelete Data Member

CXTColorPopup Data Members, CXTColorPopup Class
CXTColorPopup::m_bAutoDelete Data Member

TRUE if the popup window is to be self deleting.

BOOL m_bAutoDelete;
Group

CXTColorPopup Data Members


CXTColorPopup::m_bDisplayShadow Data Member

CXTColorPopup Data Members, CXTColorPopup Class
CXTColorPopup::m_bDisplayShadow Data Member

TRUE if the popup window will render its shadow.

BOOL m_bDisplayShadow;
Group

CXTColorPopup Data Members


CXTColorPopup::m_callerParam Data Member

CXTColorPopup Data Members, CXTColorPopup Class
CXTColorPopup::m_callerParam Data Member

Caller parameter that will be reported back as an LPARAM of all notification messages.

const LPARAM m_callerParam;
Group

CXTColorPopup Data Members


CXTColorPopup::m_rcExclude Data Member

CXTColorPopup Data Members, CXTColorPopup Class
CXTColorPopup::m_rcExclude Data Member

Area to exclude from shadow display.

CRect m_rcExclude;
Group

CXTColorPopup Data Members


CXTColorPopup Methods

CXTColorPopup Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorPopup Methods
Class

CXTColorPopup Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
EndSelection | This member function will finish the selection process for the color box or button in the color popup window.
Public Methods
Public Methods
Public Method | Description
AddListener | This member function adds a window that picker notifications are sent to.
AddUserColor | This member function will add a color to the user defined color list.
Create | This member function handles the creation of the color popup window.
DisplayShadow | Enables or disables popup window shadow.
ResetUserColors | Resets the recently used color list.


CXTColorPopup::AddListener Method

CXTColorPopup Methods, CXTColorPopup Class
CXTColorPopup::AddListener Method

This member function adds a window that picker notifications are sent to.

void AddListener(
    HWND hwndListener
);
Parameters

hwndListener
A handle to the listener window. Messages will be sent to it.

Group

CXTColorPopup Methods


CXTColorPopup::AddUserColor Method

CXTColorPopup Methods, CXTColorPopup Class, Body Source
CXTColorPopup::AddUserColor Method

This member function will add a color to the user defined color list.

static void AddUserColor(
    COLORREF clrColor
);
Parameters

clrColor
An RGB value that represents the user defined color to be displayed in the recent color list.

Body Source
void CXTColorPopup::AddUserColor(COLORREF clrColor) {
    m_arUserDefColors.Add(clrColor);
}
Group

CXTColorPopup Methods


CXTColorPopup::Create Method

CXTColorPopup Methods, CXTColorPopup Class, See Also
CXTColorPopup::Create Method

This member function handles the creation of the color popup window.

virtual BOOL Create(
    CRect& rect,
    CWnd* pParentWnd,
    DWORD dwPopup,
    COLORREF clrColor,
    COLORREF clrDefault = CLR_DEFAULT
);
Parameters

rect
A reference to a CRect object that represents the size of the color popup window.
pParentWnd
Points to the parent window for the color popup.
dwPopup
Style for the popup window. See the Remarks section for a complete list of available styles.
clrColor
An RGB value that represents the currently selected color for the popup window.
clrDefault
Specifies the default color for the color popup. If the current style includes CPS_NOFILL, this parameter is ignored.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • CPS_XT_NOFILL The color picker will display a No Fill button rather than the default Automatic Color button.
  • CPS_XT_EXTENDED The color picker will display 40 extended colors rather than the default 16 colors.
  • CPS_XT_MORECOLORS The color picker will display a More Colors button which will display a CXTColorDialog.
  • CPS_XT_SHOW3DSELECTION Displays the color selection box with a 3D raised border in CXTColorDialog.
  • CPS_XT_SHOWHEXVALUE Displays the hex equivalent of the selected color.
See Also

CXTColorPicker::ModifyCPStyle, CXTColorSelectorCtrl::Create

Group

CXTColorPopup Methods


CXTColorPopup::DisplayShadow Method

CXTColorPopup Methods, CXTColorPopup Class, Body Source
CXTColorPopup::DisplayShadow Method

Enables or disables popup window shadow.

void DisplayShadow(
    BOOL bDisplayShadow = TRUE
);
Parameters

bDisplayShadow
Flag that tells if the shadow is to be displayed.

Remarks

This member function enables or disables the drawing of popup shadows. Call this function after instantiating the color popup as a part of an object's initialization. Do not call it after popup creation because doing so may cause unpredictable results.

Body Source
void CXTColorPopup::DisplayShadow(BOOL bDisplayShadow/* = TRUE*/) {
    m_bDisplayShadow = bDisplayShadow;
}
Group

CXTColorPopup Methods


CXTColorPopup::EndSelection Method

CXTColorPopup Methods, CXTColorPopup Class
CXTColorPopup::EndSelection Method

This member function will finish the selection process for the color box or button in the color popup window.

virtual void EndSelection(
    int nCurSel
);
Parameters

nCurSel
Current index of the selected color box or button in the color popup window.

Group

CXTColorPopup Methods


CXTColorPopup::ResetUserColors Method

CXTColorPopup Methods, CXTColorPopup Class, Body Source
CXTColorPopup::ResetUserColors Method

Resets the recently used color list.

static void ResetUserColors();
Remarks

Call this member function to reset the user defined color list. Calling this function will remove all user defined colors from the MRU list.

Body Source
void CXTColorPopup::ResetUserColors() {
    m_arUserDefColors.RemoveAll();
}
Group

CXTColorPopup Methods


CXTColorPopup Constructors

CXTColorPopup Class, Legend, Public Methods
CXTColorPopup Constructors
Class

CXTColorPopup Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorPopup | Constructs a CXTColorPopup object.


CXTColorPopup::CXTColorPopup Constructor

CXTColorPopup Constructors, CXTColorPopup Class
CXTColorPopup::CXTColorPopup Constructor

Constructs a CXTColorPopup object.

CXTColorPopup(
    BOOL bAutoDelete = FALSE,
    LPARAM callerParam = 0
);
Parameters

bAutoDelete
TRUE if the color picker window is to be self deleting.
callerParam
Caller parameter; it will be reported back as an LPARAM of color popup notification messages.

Group

CXTColorPopup Constructors


CXTColorPopup Destructors

CXTColorPopup Class, Legend, Public Methods
CXTColorPopup Destructors
Class

CXTColorPopup Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorPopup | Destroys a CXTColorPopup object, handles cleanup and deallocation


CXTColorPopup::~CXTColorPopup Destructor

CXTColorPopup Destructors, CXTColorPopup Class
CXTColorPopup::~CXTColorPopup Destructor

Destroys a CXTColorPopup object, handles cleanup and deallocation

virtual ~CXTColorPopup();
Group

CXTColorPopup Destructors


CXTColorRef Class

XTColorRef.h, Classes, Legend, Members, Topics, CXTColorRef Data Members, CXTColorRef Methods, CXTColorRef Constructors, CXTColorRef Operators, CXTColorRef Constructors, CXTColorRef Data Members, CXTColorRef Methods, CXTColorRef Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorRef Class

CXTColorRef is a stand alone class. It is used to create a CXTColorRef object. This object is used for manipulation of RGB values.

Class Hierarchy

class CXTColorRef;
File

XTColorRef.h

Group

Classes

Legend
Data Member
protected
Method
Operator
CXTColorRef Constructors
CXTColorRef Constructors | Description
CXTColorRef |
CXTColorRef Data Members
CXTColorRef Data Members | Description
BLACK | RGB value that represents the color black.
GRAY_25 | RGB value that represents the 25% gray color.
GRAY_50 | RGB value that represents the 50% gray color.
GRAY_75 | RGB value that represents the 75% gray color.
m_ColorRef | Current RGB value for this object
WHITE | RGB value that represents the color white.
CXTColorRef Methods
CXTColorRef Methods | Description
add | Call this member function to add the CXTColorRef object specified by 'clr'.
addColorValue | Adds two color values.
blend | Blends two CXTColorRef objects into a single color.
BlendColor | Blends two color intensities.
fixColorValue | Adjusts color intensity to a valid range.
fromHSB | Creates a new CXTColorRef based on hue saturation and brightness.
fromHSL | Creates a new CXTColorRef based on hue saturation and luminance.
getBValue | This method gets the blue component of this object.
GetColor | Retrieves the current color of the specified display element.
getGValue | This method gets the green component of this object.
getIntensity | This member function will retrieve the overall intensity of the CXTColorRef object.
getRValue | This method gets the red component of this object.
multiplyColorValue | Modifies a color value based on intensity and multiplication.
RefreshColors | This function will refresh the display element colors defined in the CXTColorRef object.
SafeRGB | Retrieves a save COLORREF value from the specified r, g, b values.
setBValue | Call this member function to set the blue intensity value for the CXTColorRef object.
setGValue | Call this member function to set the green intensity value for the CXTColorRef object.
setHSB | This function sets an RGB value that is the equivalent of a specific HSB (hue, saturation, brightness) color.
setHSL | This function sets an RGB value that is the equivalent of a specific HSL (hue, saturation, luminance) color.
setRValue | Call this member function to set the red intensity value for the CXTColorRef object.
subtract | Call this member function to subtract the CXTColorRef object specified by 'clr'.
toHSB | This function converts the RGB color to an HSB (hue, saturation, brightness) trio.
toHSL | This function converts the RGB color to an HSL (hue, saturation, luminance) trio.
CXTColorRef Operators
CXTColorRef Operators | Description
- |
* |
*= |
/ |
/= |
+ |
+= |
= | This assignment operator is used to initialize a CXTColorRef object.
-= |
COLORREF | This operator retrieves the RGB value for the CXTColorRef object.


CXTColorRef Data Members

CXTColorRef Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorRef Data Members
Class

CXTColorRef Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_ColorRef | Current RGB value for this object
Public Data Members
Public Data Member | Description
BLACK | RGB value that represents the color black.
GRAY_25 | RGB value that represents the 25% gray color.
GRAY_50 | RGB value that represents the 50% gray color.
GRAY_75 | RGB value that represents the 75% gray color.
WHITE | RGB value that represents the color white.


CXTColorRef::BLACK Data Member

CXTColorRef Data Members, CXTColorRef Class
CXTColorRef::BLACK Data Member

RGB value that represents the color black.

const CXTColorRef BLACK;
Group

CXTColorRef Data Members


CXTColorRef::GRAY_25 Data Member

CXTColorRef Data Members, CXTColorRef Class
CXTColorRef::GRAY_25 Data Member

RGB value that represents the 25% gray color.

const CXTColorRef GRAY_25;
Group

CXTColorRef Data Members


CXTColorRef::GRAY_50 Data Member

CXTColorRef Data Members, CXTColorRef Class
CXTColorRef::GRAY_50 Data Member

RGB value that represents the 50% gray color.

const CXTColorRef GRAY_50;
Group

CXTColorRef Data Members


CXTColorRef::GRAY_75 Data Member

CXTColorRef Data Members, CXTColorRef Class
CXTColorRef::GRAY_75 Data Member

RGB value that represents the 75% gray color.

const CXTColorRef GRAY_75;
Group

CXTColorRef Data Members


CXTColorRef::m_ColorRef Data Member

CXTColorRef Data Members, CXTColorRef Class
CXTColorRef::m_ColorRef Data Member

Current RGB value for this object

COLORREF m_ColorRef;
Group

CXTColorRef Data Members


CXTColorRef::WHITE Data Member

CXTColorRef Data Members, CXTColorRef Class
CXTColorRef::WHITE Data Member

RGB value that represents the color white.

const CXTColorRef WHITE;
Group

CXTColorRef Data Members


CXTColorRef Methods

CXTColorRef Class, Legend, Protected Methods, Public Methods
CXTColorRef Methods
Class

CXTColorRef Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
SafeRGB | Retrieves a save COLORREF value from the specified r, g, b values.
Public Methods
Public Methods
Public Method | Description
add | Call this member function to add the CXTColorRef object specified by 'clr'.
addColorValue | Adds two color values.
blend | Blends two CXTColorRef objects into a single color.
BlendColor | Blends two color intensities.
fixColorValue | Adjusts color intensity to a valid range.
fromHSB | Creates a new CXTColorRef based on hue saturation and brightness.
fromHSL | Creates a new CXTColorRef based on hue saturation and luminance.
getBValue | This method gets the blue component of this object.
GetColor | Retrieves the current color of the specified display element.
getGValue | This method gets the green component of this object.
getIntensity | This member function will retrieve the overall intensity of the CXTColorRef object.
getRValue | This method gets the red component of this object.
multiplyColorValue | Modifies a color value based on intensity and multiplication.
RefreshColors | This function will refresh the display element colors defined in the CXTColorRef object.
setBValue | Call this member function to set the blue intensity value for the CXTColorRef object.
setGValue | Call this member function to set the green intensity value for the CXTColorRef object.
setHSB | This function sets an RGB value that is the equivalent of a specific HSB (hue, saturation, brightness) color.
setHSL | This function sets an RGB value that is the equivalent of a specific HSL (hue, saturation, luminance) color.
setRValue | Call this member function to set the red intensity value for the CXTColorRef object.
subtract | Call this member function to subtract the CXTColorRef object specified by 'clr'.
toHSB | This function converts the RGB color to an HSB (hue, saturation, brightness) trio.
toHSL | This function converts the RGB color to an HSL (hue, saturation, luminance) trio.


CXTColorRef::add Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::add Method

Call this member function to add the CXTColorRef object specified by 'clr'.

CXTColorRef& add(
    const CXTColorRef& clr
);
Parameters

clr
A reference to a valid CXTColorRef object.

Returns

A reference to a valid CXTColorRef object.

Group

CXTColorRef Methods


CXTColorRef::addColorValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::addColorValue Method

Adds two color values.

static int addColorValue(
    int iVal,
    int iAdd
);
Parameters

iVal
Specifies the color intensity that is the source of the operation.
iAdd
Specifies the intensity to add to the source. It can be negative.

Remarks

This member function adds two color intensities to ensure that the sum is in the proper color value range (0-255). For example, addColorValue(200, 100) will return 255 and not 300. addColorValue(100, -200) will return 0.

Body Source
int CXTColorRef::addColorValue(int iVal, int iAdd) {
    return fixColorValue(iVal + iAdd);
}
Group

CXTColorRef Methods


CXTColorRef::blend Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::blend Method

Blends two CXTColorRef objects into a single color.

CXTColorRef& blend(
    const CXTColorRef& clr,
    int opacity
);
Parameters

clr
A reference to a valid CXTColorRef object.
opacity
The amount of transparency.

Returns

A reference to a valid CXTColorRef object.

Remarks

Call this member function to blend the CXTColorRef object with the object specified by 'clr'.

Group

CXTColorRef Methods


CXTColorRef::BlendColor Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::BlendColor Method

Blends two color intensities.

static int BlendColor(
    int iClrFront,
    int iClrBack,
    int opacity
);
Parameters

iClrFront
Specifies the intensity of the foreground color component. 'iClrFront' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
iClrBack
Specifies the intensity of the background color component. 'iClrBack' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
opacity
The amount of transparency.

Remarks

This function takes a blended color intensity which is ((100-opacity)% * iClrFront and opacity% * iClrBack).

Body Source
int CXTColorRef::BlendColor(int iClrFront, int iClrBack, int opacity) {
    return fixColorValue(((iClrFront * opacity) + (iClrBack * (100 - opacity))) / 100);
}
Group

CXTColorRef Methods


CXTColorRef::fixColorValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::fixColorValue Method

Adjusts color intensity to a valid range.

static int fixColorValue(
    int iVal
);
Parameters

iVal
Specifies the intensity of the color component. 'iVal' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.

Remarks

This function takes in a color intensity and ensures that it is between 0 and 255. Anything out of range will be adjusted to the closest number in range (i.e. -100 will become 0, 300 will become 255).

Body Source
int CXTColorRef::fixColorValue(int iVal) {
    if (iVal > 255) return 255; if (iVal < 0) return 0; return iVal;
}
Group

CXTColorRef Methods


CXTColorRef::fromHSB Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::fromHSB Method

Creates a new CXTColorRef based on hue saturation and brightness.

static CXTColorRef fromHSB(
    double h,
    double s,
    double b
);
Parameters

h
The hue of the source color.
s
The saturation of the source color.
b
The brightness of the source color.

Remarks

This static function creates a new CXTColorRef object out of an HSB (hue, saturation, brightness) color trio. Returns a CXTColorRef object.

Group

CXTColorRef Methods


CXTColorRef::fromHSL Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::fromHSL Method

Creates a new CXTColorRef based on hue saturation and luminance.

static CXTColorRef fromHSL(
    double h,
    double s,
    double l
);
Parameters

h
The hue of the source color.
s
The saturation of the source color.
l
The luminance of the source color.

Remarks

This static function creates a new CXTColorRef object out of an HSL (hue, saturation, luminance) color trio. Returns a CXTColorRef object.

Group

CXTColorRef Methods


CXTColorRef::getBValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::getBValue Method

This method gets the blue component of this object.

int getBValue() const;
Returns

The blue component of the color.

Body Source
int CXTColorRef::getBValue() const {
    return GetBValue(m_ColorRef);
}
Group

CXTColorRef Methods


CXTColorRef::GetColor Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::GetColor Method

Retrieves the current color of the specified display element.

static COLORREF GetColor(
    int nIndex
);
Parameters

nIndex
Specifies the display element whose color is to be retrieved. This parameter can be one of the values listed in the remarks section.

Returns

The red, green, blue (RGB) color value of the given element.

Remarks

This function retrieves the current color of the specified XP display element. Display elements are the parts of a window and the display that appear on the system display screen.

Color can be defined as one of the following values:

  • XPCOLOR_BASE An RGB value that represents the XP base color.
  • XPCOLOR_BARFACE An RGB value that represents the XP toolbar background color.
  • XPCOLOR_HIGHLIGHT An RGB value that represents the XP menu item selected color.
  • XPCOLOR_HIGHLIGHT_BORDER An RGB value that represents the XP menu item selected border color.
  • XPCOLOR_HIGHLIGHT_PUSHED An RGB value that represents the XP menu item pushed color.
  • XPCOLOR_ICONSHADDOW An RGB value that represents the XP menu item icon shadow.
  • XPCOLOR_GRAYTEXT An RGB value that represents the XP menu item disabled text color.
  • XPCOLOR_HIGHLIGHT_CHECKED An RGB value that represents the XP menu item checked color.
  • XPCOLOR_HIGHLIGHT_CHECKED_BORDER An RGB value that represents the XP menu item checked border color.
  • XPCOLOR_GRIPPER An RGB value that represents the XP toolbar gripper color.
  • XPCOLOR_SEPARATOR An RGB value that represents the XP toolbar separator color.
  • XPCOLOR_DISABLED An RGB value that represents the XP menu icon disabled color.
  • XPCOLOR_MENUTEXT_BACK An RGB value that represents the XP menu item text background color.
  • XPCOLOR_MENU_EXPANDED An RGB value that represents the XP hidden menu commands background color.
  • XPCOLOR_MENU_BORDER An RGB value that represents the XP menu border color.
  • XPCOLOR_MENUTEXT An RGB value that represents the XP menu item text color.
  • XPCOLOR_HIGHLIGHT_TEXT An RGB value that represents the XP menu item selected text color.
  • XPCOLOR_BARTEXT An RGB value that represents the XP toolbar text color.
  • XPCOLOR_BARTEXT_PUSHED An RGB value that represents the XP toolbar pushed text color.
  • XPCOLOR_TAB_INACTIVE_BACK An RGB value that represents the XP inactive tab background color.
  • XPCOLOR_TAB_INACTIVE_TEXT An RGB value that represents the XP inactive tab text color.
Group

CXTColorRef Methods


CXTColorRef::getGValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::getGValue Method

This method gets the green component of this object.

int getGValue() const;
Returns

The green component of the color.

Body Source
int CXTColorRef::getGValue() const {
    return GetGValue(m_ColorRef);
}
Group

CXTColorRef Methods


CXTColorRef::getIntensity Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::getIntensity Method

This member function will retrieve the overall intensity of the CXTColorRef object.

double getIntensity() const;
Returns

A double that represents the current color intensity.

Body Source
double CXTColorRef::getIntensity() const {
    return  ((299 * getRValue()) + (587 * getGValue()) + (114 * getBValue())) / 1000.0;
}
Group

CXTColorRef Methods


CXTColorRef::getRValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::getRValue Method

This method gets the red component of this object.

int getRValue() const;
Returns

The red component of the color.

Body Source
int CXTColorRef::getRValue() const {
    return GetRValue(m_ColorRef);
}
Group

CXTColorRef Methods


CXTColorRef::multiplyColorValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::multiplyColorValue Method

Modifies a color value based on intensity and multiplication.

static int multiplyColorValue(
    int iVal,
    int iMult,
    int iDiv
);
Parameters

iVal
Specifies the color intensity that is the source of the operation.
iMult
Specifies a value to multiply the source by.
iDiv
Specifies a value to divide the source by.

Remarks

This member function manipulates a color value by performing a multiplication and then a division. For instance, multiplyColorValue(10, 2, 3) will return 10 * 2 / 3 which is 6. The function guarantees that the resulting value does not exceeded 255.

Body Source
int CXTColorRef::multiplyColorValue(int iVal, int iMult, int iDiv) {
    return fixColorValue(iVal*  iMult / iDiv);
}
Group

CXTColorRef Methods


CXTColorRef::RefreshColors Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::RefreshColors Method

This function will refresh the display element colors defined in the CXTColorRef object.

static void RefreshColors();
Group

CXTColorRef Methods


CXTColorRef::SafeRGB Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::SafeRGB Method

Retrieves a save COLORREF value from the specified r, g, b values.

static COLORREF SafeRGB(
    int r,
    int g,
    int b
);
Parameters

r
Specifies the intensity of the red color component. 'r' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
g
Specifies the intensity of the green color component. 'g' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
b
Specifies the intensity of the blue color component. 'b' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.

Returns

An RGB value.

Remarks

This function takes in a color intensity and ensures that it is between 0 and 255. Anything out of range will be adjusted to the closest number in range (i.e. -100 will become 0, 300 will become 255).

Group

CXTColorRef Methods


CXTColorRef::setBValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::setBValue Method

Call this member function to set the blue intensity value for the CXTColorRef object.

void setBValue(
    int val
);
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.

Body Source
void CXTColorRef::setBValue(int val) {
    m_ColorRef = RGB(getRValue(), getGValue(), val);
}
Group

CXTColorRef Methods


CXTColorRef::setGValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::setGValue Method

Call this member function to set the green intensity value for the CXTColorRef object.

void setGValue(
    int val
);
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.

Body Source
void CXTColorRef::setGValue(int val) {
    m_ColorRef = RGB(getRValue(), val, getBValue());
}
Group

CXTColorRef Methods


CXTColorRef::setHSB Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::setHSB Method

This function sets an RGB value that is the equivalent of a specific HSB (hue, saturation, brightness) color.

void setHSB(
    double h,
    double s,
    double b
);
Parameters

h
The hue of the source color.
s
The saturation of the source color.
b
The brightness of the source color.

Group

CXTColorRef Methods


CXTColorRef::setHSL Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::setHSL Method

This function sets an RGB value that is the equivalent of a specific HSL (hue, saturation, luminance) color.

void setHSL(
    double h,
    double s,
    double l
);
Parameters

h
The hue of the source color.
s
The saturation of the source color.
l
The luminance of the source color.

Group

CXTColorRef Methods


CXTColorRef::setRValue Method

CXTColorRef Methods, CXTColorRef Class, Body Source
CXTColorRef::setRValue Method

Call this member function to set the red intensity value for the CXTColorRef object.

void setRValue(
    int val
);
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.

Body Source
void CXTColorRef::setRValue(int val) {
    m_ColorRef = RGB(val, getGValue(), getBValue());
}
Group

CXTColorRef Methods


CXTColorRef::subtract Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::subtract Method

Call this member function to subtract the CXTColorRef object specified by 'clr'.

CXTColorRef& subtract(
    const CXTColorRef& clr
);
Parameters

clr
A reference to a valid CXTColorRef object.

Returns

A reference to a valid CXTColorRef object.

Group

CXTColorRef Methods


CXTColorRef::toHSB Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::toHSB Method

This function converts the RGB color to an HSB (hue, saturation, brightness) trio.

void toHSB(
    double& h,
    double& s,
    double& b
) const;
Parameters

h
The variable to receive the hue value.
s
The variable to receive the saturation value.
b
The variable to receive the brightness value.

Group

CXTColorRef Methods


CXTColorRef::toHSL Method

CXTColorRef Methods, CXTColorRef Class
CXTColorRef::toHSL Method

This function converts the RGB color to an HSL (hue, saturation, luminance) trio.

void toHSL(
    double& h,
    double& s,
    double& l
) const;
Parameters

h
The variable to receive the hue value.
s
The variable to receive the saturation value.
l
The variable to receive the luminance value.

Group

CXTColorRef Methods


CXTColorRef Constructors

CXTColorRef Class, Legend, Public Methods
CXTColorRef Constructors
Class

CXTColorRef Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorRef |


CXTColorRef Constructor

CXTColorRef Constructors
CXTColorRef Constructor
Overload List
Constructors
Constructor | Description
CXTColorRef::CXTColorRef () | Constructs a CXTColorRef object
CXTColorRef::CXTColorRef (COLORREF) | Constructs a CXTColorRef object
CXTColorRef::CXTColorRef (int, int, int) | Constructs a CXTColorRef object
Group

CXTColorRef Constructors


CXTColorRef::CXTColorRef Constructor ()

CXTColorRef Constructor, CXTColorRef Class, Body Source
CXTColorRef::CXTColorRef Constructor ()

Constructs a CXTColorRef object

CXTColorRef();
CXTColorRef(
    COLORREF cr
);
CXTColorRef(
    int r,
    int g,
    int b
);
Parameters

cr
An RGB value.
r
Specifies the intensity of the red color component. 'r' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
g
Specifies the intensity of the green color component. 'g' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
b
Specifies the intensity of the blue color component. 'b' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.

Body Source
CXTColorRef::CXTColorRef() {
    m_ColorRef = 0;
}

CXTColorRef::CXTColorRef(COLORREF r) {
    *this = r;
}

CXTColorRef::CXTColorRef(int r, int g, int b) {
    *this = RGB(r, g, b);
}
Group

CXTColorRef Constructor


CXTColorRef Operators

CXTColorRef Class, Legend, Public Operators
CXTColorRef Operators
Class

CXTColorRef Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
- |
* |
*= |
/ |
/= |
+ |
+= |
= | This assignment operator is used to initialize a CXTColorRef object.
-= |
COLORREF | This operator retrieves the RGB value for the CXTColorRef object.


- Operator

CXTColorRef Operators
- Operator
Overload List
Operators
Operator | Description
CXTColorRef::- (COLORREF) | This assignment operator is used to modify a CXTColorRef object.
CXTColorRef::- (int) | This assignment operator is used to modify a CXTColorRef object.
Group

CXTColorRef Operators


CXTColorRef::- Operator (int)

- Operator, CXTColorRef Class
CXTColorRef::- Operator (int)

This assignment operator is used to modify a CXTColorRef object.

CXTColorRef operator -(
    int val
) const;
CXTColorRef operator -(
    COLORREF cr
) const;
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
cr
An RGB value.

Returns

A CXTColorRef object.

Group

- Operator


* Operator

CXTColorRef Operators
* Operator
Overload List
Operators
Operator | Description
CXTColorRef::* (COLORREF) | This assignment operator is used to modify a CXTColorRef object.
CXTColorRef::* (int) | This assignment operator is used to modify a CXTColorRef object.
Group

CXTColorRef Operators


CXTColorRef::* Operator (int)

* Operator, CXTColorRef Class
CXTColorRef::* Operator (int)

This assignment operator is used to modify a CXTColorRef object.

CXTColorRef operator *(
    int val
) const;
CXTColorRef operator *(
    COLORREF cr
) const;
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
cr
An RGB value.

Returns

A CXTColorRef object.

Group

* Operator


*= Operator

CXTColorRef Operators
*= Operator
Overload List
Operators
Operator | Description
CXTColorRef::*= (COLORREF) | This assignment operator is used to modify a CXTColorRef object.
CXTColorRef::*= (int) | This assignment operator is used to modify a CXTColorRef object.
Group

CXTColorRef Operators


CXTColorRef::*= Operator (int)

*= Operator, CXTColorRef Class
CXTColorRef::*= Operator (int)

This assignment operator is used to modify a CXTColorRef object.

CXTColorRef& operator *=(
    int val
);
CXTColorRef& operator *=(
    COLORREF cr
);
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
cr
An RGB value.

Returns

A reference to a valid CXTColorRef object.

Group

*= Operator


/ Operator

CXTColorRef Operators
/ Operator
Overload List
Operators
Operator | Description
CXTColorRef::/ (COLORREF) | This assignment operator is used to modify a CXTColorRef object.
CXTColorRef::/ (int) | This assignment operator is used to modify a CXTColorRef object.
Group

CXTColorRef Operators


CXTColorRef::/ Operator (int)

/ Operator, CXTColorRef Class
CXTColorRef::/ Operator (int)

This assignment operator is used to modify a CXTColorRef object.

CXTColorRef operator /(
    int val
) const;
CXTColorRef operator /(
    COLORREF cr
) const;
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
cr
An RGB value.

Returns

A CXTColorRef object.

Group

/ Operator


/= Operator

CXTColorRef Operators
/= Operator
Overload List
Operators
Operator | Description
CXTColorRef::/= (COLORREF) | This assignment operator is used to modify a CXTColorRef object.
CXTColorRef::/= (int) | This assignment operator is used to modify a CXTColorRef object.
Group

CXTColorRef Operators


CXTColorRef::/= Operator (int)

/= Operator, CXTColorRef Class
CXTColorRef::/= Operator (int)

This assignment operator is used to modify a CXTColorRef object.

CXTColorRef& operator /=(
    int val
);
CXTColorRef& operator /=(
    COLORREF cr
);
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
cr
An RGB value.

Returns

A reference to a valid CXTColorRef object.

Group

/= Operator


+ Operator

CXTColorRef Operators
+ Operator
Overload List
Operators
Operator | Description
CXTColorRef::+ (COLORREF) | This assignment operator is used to modify a CXTColorRef object.
CXTColorRef::+ (int) | This assignment operator is used to modify a CXTColorRef object.
Group

CXTColorRef Operators


CXTColorRef::+ Operator (int)

+ Operator, CXTColorRef Class
CXTColorRef::+ Operator (int)

This assignment operator is used to modify a CXTColorRef object.

CXTColorRef operator +(
    int val
) const;
CXTColorRef operator +(
    COLORREF cr
) const;
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
cr
An RGB value.

Returns

A CXTColorRef object.

Group

+ Operator


+= Operator

CXTColorRef Operators
+= Operator
Overload List
Operators
Operator | Description
CXTColorRef::+= (COLORREF) | This assignment operator is used to modify a CXTColorRef object.
CXTColorRef::+= (int) | This assignment operator is used to modify a CXTColorRef object.
Group

CXTColorRef Operators


CXTColorRef::+= Operator (int)

+= Operator, CXTColorRef Class
CXTColorRef::+= Operator (int)

This assignment operator is used to modify a CXTColorRef object.

CXTColorRef& operator +=(
    int val
);
CXTColorRef& operator +=(
    COLORREF cr
);
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
cr
An RGB value.

Returns

A reference to a valid CXTColorRef object.

Group

+= Operator


CXTColorRef::= Operator

CXTColorRef Operators, CXTColorRef Class, Body Source
CXTColorRef::= Operator

This assignment operator is used to initialize a CXTColorRef object.

CXTColorRef& operator =(
    COLORREF cr
);
Parameters

cr
An RGB value.

Returns

A reference to a valid CXTColorRef object.

Body Source
CXTColorRef& CXTColorRef::operator=(COLORREF cr) {
    m_ColorRef = cr; return *this;
}
Group

CXTColorRef Operators


-= Operator

CXTColorRef Operators
-= Operator
Overload List
Operators
Operator | Description
CXTColorRef::-= (COLORREF) | This assignment operator is used to modify a CXTColorRef object.
CXTColorRef::-= (int) | This assignment operator is used to modify a CXTColorRef object.
Group

CXTColorRef Operators


CXTColorRef::-= Operator (int)

-= Operator, CXTColorRef Class
CXTColorRef::-= Operator (int)

This assignment operator is used to modify a CXTColorRef object.

CXTColorRef& operator -=(
    int val
);
CXTColorRef& operator -=(
    COLORREF cr
);
Parameters

val
Specifies the intensity of the color component. 'val' can range from 0 to 255. Zero is the minimum color intensity; 255 is the maximum color intensity.
cr
An RGB value.

Returns

A reference to a valid CXTColorRef object.

Group

-= Operator


CXTColorRef::COLORREF Operator

CXTColorRef Operators, CXTColorRef Class, Body Source
CXTColorRef::COLORREF Operator

This operator retrieves the RGB value for the CXTColorRef object.

operator COLORREF() const;
Returns

An RGB value.

Body Source
CXTColorRef::operator COLORREF () const {
    return m_ColorRef;
}
Group

CXTColorRef Operators


CXTColorSelectorCtrl Class

XTColorSelectorCtrl.h, Classes, Legend, Members, Topics, CXTColorSelectorCtrl Structures, CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Constructors, CXTColorSelectorCtrl Destructors, CXTColorSelectorCtrl Nested Types, CXTColorSelectorCtrl Constructors, CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Destructors, CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Nested Types, CXTColorSelectorCtrl Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl Class

CXTColorSelectorCtrl is a CWnd derived class. It is used to create a CXTColorSelectorCtrl control that will allow a user to select colors.

Class Hierarchy

class CXTColorSelectorCtrl : public CWnd;
File

XTColorSelectorCtrl.h

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTColorSelectorCtrl Constructors
CXTColorSelectorCtrl Constructors | Description
CXTColorSelectorCtrl | Constructs a CXTColorSelectorCtrl object
CXTColorSelectorCtrl Data Members
CXTColorSelectorCtrl Data Members | Description
m_arCells | Array of color items.
m_arUserDefColors | Array of user defined colors.
m_clrColor | An RGB value that represents the currently selected color.
m_clrDefault | An RGB value that represents the default color for the popup window.
m_dwPopup | Color popup window style.
m_listeners | Array of listener windows to be sent notifications.
m_nCols | Number of columns in the color popup window.
m_nCurSel | Currently selected index.
m_nExtendedColors | Custom colors count
m_nPressed | Pressed button.
m_pColorDlg | Points to the color selection dialog when visible.
m_pExtendedColors | Custom colors
m_point | Last known cursor position.
m_pParentWnd | Points to the parent window for the popup window.
m_rcBorders | Control borders
m_rcWnd | Rect for the popup window.
m_sizeButton | cx and cy size for a color picker button.
m_tooltip | Tooltip control.
CXTColorSelectorCtrl Destructors
CXTColorSelectorCtrl Destructors | Description
~CXTColorSelectorCtrl | Destroys a CXTColorSelectorCtrl object, handles cleanup and deallocation
CXTColorSelectorCtrl Methods
CXTColorSelectorCtrl Methods | Description
AddListener | This member function adds a window to send color picker notifications to.
Create | This member function handles the creation of the color popup window.
DrawColorSelector | This member function is called to draw the color selector.
EndSelection | This member function will finish the selection process for the color box or button in the color popup window.
GetCellFromIndex | This member function is called to return an COLOR_CELL struct from the color cell array.
GetCurSel | This member function will return the index of the currently selected color and will initialize 'pColorCell' struct.
GetUserColors | Call this member function to return a reference to the user defined color array.
IsColorDlgVisible | Call this member function to determine if the color selection dialog is visible.
IsColorStatic | Call this member function to determine if the ColorSelector control is used in a dialog or in a toolbar.
LookUpColor | This member function is called to determine if the specified color is already in the ColorDialog's MRU list or in the standard colors list.
OnEndSelection | This member function is called to finish the selection process for the color box or button in the color popup window.
RemoveListener | This member function removes a window from notification list.
SelectColor | This member function is called to select a color cell.
SelectColorCell | This member function is called to select a color cell.
SetBorders | This member function is called to set the size of the borders for the control.
SetColors | Call this method to set custom colors for color picker
SetCurSel | This member function will select a button based upon its index.
SetUserColors | Call this member function to initialize the user defined color array for the color selector.
CXTColorSelectorCtrl Nested Types
CXTColorSelectorCtrl Nested Types | Description
CColorCellList | List for maintaining COLOR_CELL structures.
CListenerArray | Array of listener windows to send notifications to.
CXTColorSelectorCtrl Structures
CXTColorSelectorCtrl Structures | Description
COLOR_CELL | COLOR_CELL structure is used by the CXTColorSelectorCtrl class to maintain information about a particular color cell.


CXTColorSelectorCtrl Structures

CXTColorSelectorCtrl Class, Legend, Structures
CXTColorSelectorCtrl Structures
Class

CXTColorSelectorCtrl Class

Legend
Structure
Structures
Structure | Description
COLOR_CELL | COLOR_CELL structure is used by the CXTColorSelectorCtrl class to maintain information about a particular color cell.


CXTColorSelectorCtrl::COLOR_CELL Structure

XTColorSelectorCtrl.h, CXTColorSelectorCtrl Structures, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::COLOR_CELL Structure

COLOR_CELL structure is used by the CXTColorSelectorCtrl class to maintain information about a particular color cell.

struct COLOR_CELL {
  UINT nID;
  UINT nIndex;
  bool bChecked;
  CRect rect;
  DWORD dwStyle;
  TCHAR szText[256];
  COLORREF clr;
};
File

XTColorSelectorCtrl.h

Members

nID
Command ID of the color cell.
nIndex
Index of the color cell.
bChecked
true if the cell is checked.
rect
Size of the color cell.
dwStyle
Windows style for the cell.
szText
Tooltip text displayed for the color cell.
clr
An RGB value that represents the color of the cell.

See Also

CXTColorSelectorCtrl

Group

CXTColorSelectorCtrl Structures


CXTColorSelectorCtrl Data Members

CXTColorSelectorCtrl Class, Legend, Protected Data Members
CXTColorSelectorCtrl Data Members
Class

CXTColorSelectorCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arCells | Array of color items.
m_arUserDefColors | Array of user defined colors.
m_clrColor | An RGB value that represents the currently selected color.
m_clrDefault | An RGB value that represents the default color for the popup window.
m_dwPopup | Color popup window style.
m_listeners | Array of listener windows to be sent notifications.
m_nCols | Number of columns in the color popup window.
m_nCurSel | Currently selected index.
m_nExtendedColors | Custom colors count
m_nPressed | Pressed button.
m_pColorDlg | Points to the color selection dialog when visible.
m_pExtendedColors | Custom colors
m_point | Last known cursor position.
m_pParentWnd | Points to the parent window for the popup window.
m_rcBorders | Control borders
m_rcWnd | Rect for the popup window.
m_sizeButton | cx and cy size for a color picker button.
m_tooltip | Tooltip control.


CXTColorSelectorCtrl::m_arCells Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_arCells Data Member

Array of color items.

CColorCellList m_arCells;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_arUserDefColors Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_arUserDefColors Data Member

Array of user defined colors.

CUIntArray m_arUserDefColors;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_clrColor Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_clrColor Data Member

An RGB value that represents the currently selected color.

COLORREF m_clrColor;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_clrDefault Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_clrDefault Data Member

An RGB value that represents the default color for the popup window.

COLORREF m_clrDefault;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_dwPopup Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_dwPopup Data Member

Color popup window style.

DWORD m_dwPopup;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_listeners Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_listeners Data Member

Array of listener windows to be sent notifications.

CListenerArray m_listeners;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_nCols Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_nCols Data Member

Number of columns in the color popup window.

int m_nCols;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_nCurSel Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_nCurSel Data Member

Currently selected index.

int m_nCurSel;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_nExtendedColors Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_nExtendedColors Data Member

Custom colors count

int m_nExtendedColors;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_nPressed Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_nPressed Data Member

Pressed button.

int m_nPressed;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_pColorDlg Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_pColorDlg Data Member

Points to the color selection dialog when visible.

CXTColorDialog* m_pColorDlg;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_pExtendedColors Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_pExtendedColors Data Member

Custom colors

XTP_PICK_BUTTON* m_pExtendedColors;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_point Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_point Data Member

Last known cursor position.

CPoint m_point;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_pParentWnd Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_pParentWnd Data Member

Points to the parent window for the popup window.

CWnd* m_pParentWnd;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_rcBorders Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_rcBorders Data Member

Control borders

CRect m_rcBorders;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_rcWnd Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_rcWnd Data Member

Rect for the popup window.

CRect m_rcWnd;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_sizeButton Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_sizeButton Data Member

cx and cy size for a color picker button.

CSize m_sizeButton;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl::m_tooltip Data Member

CXTColorSelectorCtrl Data Members, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::m_tooltip Data Member

Tooltip control.

CToolTipCtrl m_tooltip;
Group

CXTColorSelectorCtrl Data Members


CXTColorSelectorCtrl Methods

CXTColorSelectorCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl Methods
Class

CXTColorSelectorCtrl Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawColorSelector | This member function is called to draw the color selector.
EndSelection | This member function will finish the selection process for the color box or button in the color popup window.
LookUpColor | This member function is called to determine if the specified color is already in the ColorDialog's MRU list or in the standard colors list.
OnEndSelection | This member function is called to finish the selection process for the color box or button in the color popup window.
Public Methods
Public Methods
Public Method | Description
AddListener | This member function adds a window to send color picker notifications to.
Create | This member function handles the creation of the color popup window.
GetCellFromIndex | This member function is called to return an COLOR_CELL struct from the color cell array.
GetCurSel | This member function will return the index of the currently selected color and will initialize 'pColorCell' struct.
GetUserColors | Call this member function to return a reference to the user defined color array.
IsColorDlgVisible | Call this member function to determine if the color selection dialog is visible.
IsColorStatic | Call this member function to determine if the ColorSelector control is used in a dialog or in a toolbar.
RemoveListener | This member function removes a window from notification list.
SelectColor | This member function is called to select a color cell.
SelectColorCell | This member function is called to select a color cell.
SetBorders | This member function is called to set the size of the borders for the control.
SetColors | Call this method to set custom colors for color picker
SetCurSel | This member function will select a button based upon its index.
SetUserColors | Call this member function to initialize the user defined color array for the color selector.


CXTColorSelectorCtrl::AddListener Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::AddListener Method

This member function adds a window to send color picker notifications to.

void AddListener(
    HWND hwndListener
);
Parameters

hwndListener
A handle to the listener window. Messages will be sent to it.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::Create Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::Create Method

This member function handles the creation of the color popup window.

BOOL Create(
    CRect rect,
    CWnd* pParentWnd,
    DWORD dwPopup,
    COLORREF clrColor,
    COLORREF clrDefault = CLR_DEFAULT
);
Parameters

rect
A reference to a CRect object that represents the size of the color popup window.
pParentWnd
Points to the parent window for the color popup.
dwPopup
Style for the popup window. See the Remarks section for a complete list of available styles.
clrColor
An RGB value that represents the currently selected color for the popup window.
clrDefault
Specifies the default color for the color popup. If the current style includes CPS_NOFILL this parameter is ignored.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • CPS_XT_NOFILL The color picker will display a No Fill button rather than the default Automatic Color button.
  • CPS_XT_EXTENDED The color picker will display 40 extended colors rather than the default 16 colors.
  • CPS_XT_MORECOLORS The color picker will display a More Colors button which will display a CXTColorDialog.
  • CPS_XT_USERCOLORS The color picker will display an MRU (most recently used) color list for the control.
See Also

CXTColorPicker::ModifyCPStyle, CXTColorPopup::Create

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::DrawColorSelector Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::DrawColorSelector Method

This member function is called to draw the color selector.

void DrawColorSelector(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::EndSelection Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::EndSelection Method

This member function will finish the selection process for the color box or button in the color popup window.

virtual void EndSelection(
    int nCurSel
);
Parameters

nCurSel
Current index of the selected color box or button in the color popup window.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::GetCellFromIndex Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::GetCellFromIndex Method

This member function is called to return an COLOR_CELL struct from the color cell array.

COLOR_CELL* GetCellFromIndex(
    int iIndex
);
Parameters

iIndex
Index into the color cell array.

Returns

An COLOR_CELL object.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::GetCurSel Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::GetCurSel Method

This member function will return the index of the currently selected color and will initialize 'pColorCell' struct.

int GetCurSel(
    COLOR_CELL* pColorCell
);
Parameters

pColorCell
Receives a pointer to the currently selected button.

Returns

The zero (0) based index of the currently selected button.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::GetUserColors Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::GetUserColors Method

Call this member function to return a reference to the user defined color array.

static CUIntArray& GetUserColors();
Returns

A reference to a CUIintArray object that represents an array of user defined COLORREF values.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::IsColorDlgVisible Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::IsColorDlgVisible Method

Call this member function to determine if the color selection dialog is visible.

bool IsColorDlgVisible();
Returns

True if the color selection dialog is open, otherwise returns false.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::IsColorStatic Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::IsColorStatic Method

Call this member function to determine if the ColorSelector control is used in a dialog or in a toolbar.

BOOL IsColorStatic(
    CDC* pDC
) const;
Parameters

pDC
Deveice context of the control

Returns

TRUE if the ColorSelector control is in a dialog and FALSE if used in a toolbar.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::LookUpColor Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::LookUpColor Method

This member function is called to determine if the specified color is already in the ColorDialog's MRU list or in the standard colors list.

BOOL LookUpColor(
    const COLORREF crFind
);
Parameters

crFind
A const COLORREF value.
Return
TRUE if the color is found otherwise returns FALSE.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::OnEndSelection Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::OnEndSelection Method

This member function is called to finish the selection process for the color box or button in the color popup window.

virtual void OnEndSelection(
    int nCurSel,
    LPARAM callerParam
);
Parameters

nCurSel
Current index of the selected color box or button in the color popup window.
callerParam
User defined value to be passed to listeners.

Remarks

Override this method to pass user defined data to the listener windows that receive notification messages.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::RemoveListener Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::RemoveListener Method

This member function removes a window from notification list.

void RemoveListener(
    HWND hwndListener
);
Parameters

hwndListener
A handle to the listener window to remove.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::SelectColor Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::SelectColor Method

This member function is called to select a color cell.

void SelectColor(
    COLORREF clr
);
Parameters

clr
Color of selected cell.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::SelectColorCell Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::SelectColorCell Method

This member function is called to select a color cell.

virtual void SelectColorCell(
    COLOR_CELL* pColorCell
);
Parameters

pColorCell
Points to an COLOR_CELL object.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::SetBorders Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::SetBorders Method

This member function is called to set the size of the borders for the control.

void SetBorders(
    int cxLeft = 0,
    int cyTop = 0,
    int cxRight = 0,
    int cyBottom = 0
);
Parameters

cxLeft
Specifies the left position.
cyTop
Specifies the top.
cxRight
Specifies the right.
cyBottom
Specifies the bottom.

Body Source
void CXTColorSelectorCtrl::SetBorders(int cxLeft, int cyTop, int cxRight, int cyBottom) {
    m_rcBorders.left = cxLeft; m_rcBorders.top = cyTop; m_rcBorders.right = cxRight; m_rcBorders.bottom = cyBottom;
}
Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::SetColors Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::SetColors Method

Call this method to set custom colors for color picker

void SetColors(
    XTP_PICK_BUTTON* pColors,
    int nCount,
    int nCols = 8
);
Parameters

pColors
Static array of colors and tooltips
nCount
Number of colors
nCols
Number of columns to show

Body Source
void CXTColorSelectorCtrl::SetColors(XTP_PICK_BUTTON* pColors, int nCount, int nCols) {
    m_pExtendedColors = pColors;
    m_nExtendedColors = nCount;
    m_nCols = nCols;
}
Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::SetCurSel Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::SetCurSel Method

This member function will select a button based upon its index.

void SetCurSel(
    int nIndex
);
Parameters

nIndex
An integer value that represents the zero (0) based index of the button to be selected.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl::SetUserColors Method

CXTColorSelectorCtrl Methods, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::SetUserColors Method

Call this member function to initialize the user defined color array for the color selector.

static void SetUserColors(
    const CUIntArray& arUserDefColors
);
Parameters

arUserDefColors
Reference to a CUIntArray object that represents an array of COLORREF values.

Group

CXTColorSelectorCtrl Methods


CXTColorSelectorCtrl Constructors

CXTColorSelectorCtrl Class, Legend, Public Methods
CXTColorSelectorCtrl Constructors
Class

CXTColorSelectorCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorSelectorCtrl | Constructs a CXTColorSelectorCtrl object


CXTColorSelectorCtrl::CXTColorSelectorCtrl Constructor

CXTColorSelectorCtrl Constructors, CXTColorSelectorCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::CXTColorSelectorCtrl Constructor

Constructs a CXTColorSelectorCtrl object

CXTColorSelectorCtrl();
Group

CXTColorSelectorCtrl Constructors


CXTColorSelectorCtrl Destructors

CXTColorSelectorCtrl Class, Legend, Public Methods
CXTColorSelectorCtrl Destructors
Class

CXTColorSelectorCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorSelectorCtrl | Destroys a CXTColorSelectorCtrl object, handles cleanup and deallocation


CXTColorSelectorCtrl::~CXTColorSelectorCtrl Destructor

CXTColorSelectorCtrl Destructors, CXTColorSelectorCtrl Class
CXTColorSelectorCtrl::~CXTColorSelectorCtrl Destructor

Destroys a CXTColorSelectorCtrl object, handles cleanup and deallocation

virtual ~CXTColorSelectorCtrl();
Group

CXTColorSelectorCtrl Destructors


CXTColorSelectorCtrl Nested Types

CXTColorSelectorCtrl Class, Public Nested Types
CXTColorSelectorCtrl Nested Types
Class

CXTColorSelectorCtrl Class

Public Nested Types
Public Nested Type | Description
CColorCellList | List for maintaining COLOR_CELL structures.
CListenerArray | Array of listener windows to send notifications to.


CXTColorSelectorCtrl::CColorCellList Nested Type

CXTColorSelectorCtrl Nested Types, CXTColorSelectorCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::CColorCellList Nested Type

List for maintaining COLOR_CELL structures.

typedef CList<COLOR_CELL*, COLOR_CELL*> CColorCellList;
Remarks

CList definition used by the CXTColorSelectorCtrl class to maintain a list of COLOR_CELL structures representing each color item in the color selector control.

See Also

CXTColorSelectorCtrl, COLOR_CELL

Group

CXTColorSelectorCtrl Nested Types


CXTColorSelectorCtrl::CListenerArray Nested Type

CXTColorSelectorCtrl Nested Types, CXTColorSelectorCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrl::CListenerArray Nested Type

Array of listener windows to send notifications to.

typedef CArray<HWND, HWND> CListenerArray;
Remarks

CArray definition used by the CXTColorSelectorCtrl class to maintain a list of window handles that receive notification messages that are sent when an event occurs in the control.

See Also

CXTColorSelectorCtrl

Group

CXTColorSelectorCtrl Nested Types


CXTColorSelectorCtrlTheme Class

XTColorSelectorCtrl.h, Classes, Legend, Members, Topics, CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Methods, CXTColorSelectorCtrlTheme Constructors, CXTColorSelectorCtrlTheme Constructors, CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme Class

CXTColorSelectorCtrlTheme is derived from CXTThemeManagerStyle to handle theme specific visualizations for the CXTColorSelectorCtrl class.

Class Hierarchy

class CXTColorSelectorCtrlTheme : public CXTThemeManagerStyle;
File

XTColorSelectorCtrl.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTColorSelectorCtrlTheme Constructors
CXTColorSelectorCtrlTheme Constructors | Description
CXTColorSelectorCtrlTheme | Constructs a CXTColorSelectorCtrlTheme object.
CXTColorSelectorCtrlTheme Data Members
CXTColorSelectorCtrlTheme Data Members | Description
m_crBack | RGB value for background color.
m_crBorderHilight | RGB value for 3D border highlight color.
m_crBorderShadow | RGB value for 3D border shadow color.
m_crChecked | RGB value for checked background color.
m_crHilight | RGB value for hilight background color.
m_crPressed | RGB value for pressed background color.
m_crText | RGB value for text color.
CXTColorSelectorCtrlTheme Methods
CXTColorSelectorCtrlTheme Methods | Description
DrawColorCell | This member function is called to draw the cell specified by 'pColorCell'.
FillBackground | Call this member function to draw the background of the ColorSelector control.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTColorSelectorCtrlTheme Data Members

CXTColorSelectorCtrlTheme Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme Data Members
Class

CXTColorSelectorCtrlTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_crBack | RGB value for background color.
m_crBorderHilight | RGB value for 3D border highlight color.
m_crBorderShadow | RGB value for 3D border shadow color.
m_crChecked | RGB value for checked background color.
m_crHilight | RGB value for hilight background color.
m_crPressed | RGB value for pressed background color.
m_crText | RGB value for text color.


CXTColorSelectorCtrlTheme::m_crBack Data Member

CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::m_crBack Data Member

RGB value for background color.

COLORREF m_crBack;
Group

CXTColorSelectorCtrlTheme Data Members


CXTColorSelectorCtrlTheme::m_crBorderHilight Data Member

CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::m_crBorderHilight Data Member

RGB value for 3D border highlight color.

COLORREF m_crBorderHilight;
Group

CXTColorSelectorCtrlTheme Data Members


CXTColorSelectorCtrlTheme::m_crBorderShadow Data Member

CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::m_crBorderShadow Data Member

RGB value for 3D border shadow color.

COLORREF m_crBorderShadow;
Group

CXTColorSelectorCtrlTheme Data Members


CXTColorSelectorCtrlTheme::m_crChecked Data Member

CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::m_crChecked Data Member

RGB value for checked background color.

COLORREF m_crChecked;
Group

CXTColorSelectorCtrlTheme Data Members


CXTColorSelectorCtrlTheme::m_crHilight Data Member

CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::m_crHilight Data Member

RGB value for hilight background color.

COLORREF m_crHilight;
Group

CXTColorSelectorCtrlTheme Data Members


CXTColorSelectorCtrlTheme::m_crPressed Data Member

CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::m_crPressed Data Member

RGB value for pressed background color.

COLORREF m_crPressed;
Group

CXTColorSelectorCtrlTheme Data Members


CXTColorSelectorCtrlTheme::m_crText Data Member

CXTColorSelectorCtrlTheme Data Members, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::m_crText Data Member

RGB value for text color.

COLORREF m_crText;
Group

CXTColorSelectorCtrlTheme Data Members


CXTColorSelectorCtrlTheme Methods

CXTColorSelectorCtrlTheme Class, Legend, Public Methods
CXTColorSelectorCtrlTheme Methods
Class

CXTColorSelectorCtrlTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawColorCell | This member function is called to draw the cell specified by 'pColorCell'.
FillBackground | Call this member function to draw the background of the ColorSelector control.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTColorSelectorCtrlTheme::DrawColorCell Method

CXTColorSelectorCtrlTheme Methods, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::DrawColorCell Method

This member function is called to draw the cell specified by 'pColorCell'.

virtual void DrawColorCell(
    CXTColorSelectorCtrl::COLOR_CELL* pColorCell,
    CDC* pDC,
    BOOL bHilite,
    BOOL bPressed
);
Parameters

pColorCell
An COLOR_CELL object.
pDC
A CDC pointer that represents the current device context.
bHilite
TRUE if mouse over cell
bPressed
TRUE if cell pressed

Group

CXTColorSelectorCtrlTheme Methods


CXTColorSelectorCtrlTheme::FillBackground Method

CXTColorSelectorCtrlTheme Methods, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::FillBackground Method

Call this member function to draw the background of the ColorSelector control.

virtual void FillBackground(
    CDC* pDC,
    const CRect& rect,
    CXTColorSelectorCtrl* pOwner
);
Parameters

pDC
A pointer to a valid device context.
rect
A CRect object that contains the dimensions of the area to fill.
pOwner
A pointer to a valid CXTColorSelectorCtrl object.

Group

CXTColorSelectorCtrlTheme Methods


CXTColorSelectorCtrlTheme::RefreshMetrics Method

CXTColorSelectorCtrlTheme Methods, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::RefreshMetrics Method

This member function is called by the theme manager to refresh the visual styles used by each components theme.

virtual void RefreshMetrics();
Group

CXTColorSelectorCtrlTheme Methods


CXTColorSelectorCtrlTheme Constructors

CXTColorSelectorCtrlTheme Class, Legend, Public Methods
CXTColorSelectorCtrlTheme Constructors
Class

CXTColorSelectorCtrlTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorSelectorCtrlTheme | Constructs a CXTColorSelectorCtrlTheme object.


CXTColorSelectorCtrlTheme::CXTColorSelectorCtrlTheme Constructor

CXTColorSelectorCtrlTheme Constructors, CXTColorSelectorCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlTheme::CXTColorSelectorCtrlTheme Constructor

Constructs a CXTColorSelectorCtrlTheme object.

CXTColorSelectorCtrlTheme();
Group

CXTColorSelectorCtrlTheme Constructors


CXTColorSelectorCtrlThemeOffice2003 Class

XTColorSelectorCtrl.h, Classes, Legend, Members, Topics, CXTColorSelectorCtrlThemeOffice2003 Methods, CXTColorSelectorCtrlThemeOffice2003 Constructors, CXTColorSelectorCtrlThemeOffice2003 Constructors, CXTColorSelectorCtrlThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOffice2003 Class

CXTColorSelectorCtrlThemeOffice2003 is derived from CXTColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTColorSelectorCtrl class.

Class Hierarchy

class CXTColorSelectorCtrlThemeOffice2003 : public CXTColorSelectorCtrlThemeOfficeXP;
File

XTColorSelectorCtrl.h

Group

Classes

Legend
Method
virtual
CXTColorSelectorCtrlThemeOffice2003 Constructors
CXTColorSelectorCtrlThemeOffice2003 Constructors | Description
CXTColorSelectorCtrlThemeOffice2003 | Constructs a CXTColorSelectorCtrlThemeOffice2003 object.
CXTColorSelectorCtrlThemeOffice2003 Methods
CXTColorSelectorCtrlThemeOffice2003 Methods | Description
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTColorSelectorCtrlThemeOffice2003 Methods

CXTColorSelectorCtrlThemeOffice2003 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOffice2003 Methods
Class

CXTColorSelectorCtrlThemeOffice2003 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTColorSelectorCtrlThemeOffice2003::RefreshMetrics Method

CXTColorSelectorCtrlThemeOffice2003 Methods, CXTColorSelectorCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOffice2003::RefreshMetrics Method

This member function is called by the theme manager to refresh the visual styles used by each components theme.

virtual void RefreshMetrics();
Group

CXTColorSelectorCtrlThemeOffice2003 Methods


CXTColorSelectorCtrlThemeOffice2003 Constructors

CXTColorSelectorCtrlThemeOffice2003 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOffice2003 Constructors
Class

CXTColorSelectorCtrlThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorSelectorCtrlThemeOffice2003 | Constructs a CXTColorSelectorCtrlThemeOffice2003 object.


CXTColorSelectorCtrlThemeOffice2003::CXTColorSelectorCtrlThemeOffice2003 Constructor

CXTColorSelectorCtrlThemeOffice2003 Constructors, CXTColorSelectorCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOffice2003::CXTColorSelectorCtrlThemeOffice2003 Constructor

Constructs a CXTColorSelectorCtrlThemeOffice2003 object.

CXTColorSelectorCtrlThemeOffice2003();
Group

CXTColorSelectorCtrlThemeOffice2003 Constructors


CXTColorSelectorCtrlThemeOfficeXP Class

XTColorSelectorCtrl.h, Classes, Legend, Members, Topics, CXTColorSelectorCtrlThemeOfficeXP Methods, CXTColorSelectorCtrlThemeOfficeXP Constructors, CXTColorSelectorCtrlThemeOfficeXP Constructors, CXTColorSelectorCtrlThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOfficeXP Class

CXTColorSelectorCtrlThemeOfficeXP is derived from CXTColorSelectorCtrlTheme to handle theme specific visualizations for the CXTColorSelectorCtrl class.

Class Hierarchy

class CXTColorSelectorCtrlThemeOfficeXP : public CXTColorSelectorCtrlTheme;
File

XTColorSelectorCtrl.h

Group

Classes

Legend
Method
virtual
CXTColorSelectorCtrlThemeOfficeXP Constructors
CXTColorSelectorCtrlThemeOfficeXP Constructors | Description
CXTColorSelectorCtrlThemeOfficeXP | Constructs a CXTColorSelectorCtrlThemeOfficeXP object.
CXTColorSelectorCtrlThemeOfficeXP Methods
CXTColorSelectorCtrlThemeOfficeXP Methods | Description
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTColorSelectorCtrlThemeOfficeXP Methods

CXTColorSelectorCtrlThemeOfficeXP Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOfficeXP Methods
Class

CXTColorSelectorCtrlThemeOfficeXP Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTColorSelectorCtrlThemeOfficeXP::RefreshMetrics Method

CXTColorSelectorCtrlThemeOfficeXP Methods, CXTColorSelectorCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOfficeXP::RefreshMetrics Method

This member function is called by the theme manager to refresh the visual styles used by each components theme.

virtual void RefreshMetrics();
Group

CXTColorSelectorCtrlThemeOfficeXP Methods


CXTColorSelectorCtrlThemeOfficeXP Constructors

CXTColorSelectorCtrlThemeOfficeXP Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOfficeXP Constructors
Class

CXTColorSelectorCtrlThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorSelectorCtrlThemeOfficeXP | Constructs a CXTColorSelectorCtrlThemeOfficeXP object.


CXTColorSelectorCtrlThemeOfficeXP::CXTColorSelectorCtrlThemeOfficeXP Constructor

CXTColorSelectorCtrlThemeOfficeXP Constructors, CXTColorSelectorCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorSelectorCtrlThemeOfficeXP::CXTColorSelectorCtrlThemeOfficeXP Constructor

Constructs a CXTColorSelectorCtrlThemeOfficeXP object.

CXTColorSelectorCtrlThemeOfficeXP();
Group

CXTColorSelectorCtrlThemeOfficeXP Constructors


CXTColorWnd Class

XTColorPageCustom.h, Classes, Legend, Members, Topics, CXTColorWnd Data Members, CXTColorWnd Methods, CXTColorWnd Constructors, CXTColorWnd Destructors, CXTColorWnd Constructors, CXTColorWnd Data Members, CXTColorWnd Destructors, CXTColorWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTColorWnd Class

CXTColorWnd is a CXTColorBase derived class. It is used to create a color selection window.

Class Hierarchy

class CXTColorWnd : public CXTColorBase;
File

XTColorPageCustom.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTColorWnd Constructors
CXTColorWnd Constructors | Description
CXTColorWnd | Constructs a CXTColorWnd object
CXTColorWnd Data Members
CXTColorWnd Data Members | Description
m_bmpPicker | Background device context.
CXTColorWnd Destructors
CXTColorWnd Destructors | Description
~CXTColorWnd | Destroys a CXTColorWnd object, handles cleanup and deallocation
CXTColorWnd Methods
CXTColorWnd Methods | Description
DrawCrossHair | This member function is called to update the cross hair cursor.
SetColor | Call this member function to set the color for the selection window.
SetHue | This member function is called to set the hue for the color window.
SetSaturation | This member function is called to set the saturation for the color window.
UpdateCursorPos | Call this member function to update the cursor position.


CXTColorWnd Data Members

CXTColorWnd Class, Legend, Protected Data Members
CXTColorWnd Data Members
Class

CXTColorWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bmpPicker | Background device context.


CXTColorWnd::m_bmpPicker Data Member

CXTColorWnd Data Members, CXTColorWnd Class
CXTColorWnd::m_bmpPicker Data Member

Background device context.

CBitmap m_bmpPicker;
Group

CXTColorWnd Data Members


CXTColorWnd Methods

CXTColorWnd Class, Legend, Public Methods
CXTColorWnd Methods
Class

CXTColorWnd Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawCrossHair | This member function is called to update the cross hair cursor.
SetColor | Call this member function to set the color for the selection window.
SetHue | This member function is called to set the hue for the color window.
SetSaturation | This member function is called to set the saturation for the color window.
UpdateCursorPos | Call this member function to update the cursor position.


CXTColorWnd::DrawCrossHair Method

CXTColorWnd Methods, CXTColorWnd Class
CXTColorWnd::DrawCrossHair Method

This member function is called to update the cross hair cursor.

void DrawCrossHair(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTColorWnd Methods


CXTColorWnd::SetColor Method

CXTColorWnd Methods, CXTColorWnd Class
CXTColorWnd::SetColor Method

Call this member function to set the color for the selection window.

virtual void SetColor(
    double nHue,
    double nSat
);
Parameters

nHue
Current hue value that represents the color.
nSat
Current saturation value that represents the color.

Group

CXTColorWnd Methods


CXTColorWnd::SetHue Method

CXTColorWnd Methods, CXTColorWnd Class
CXTColorWnd::SetHue Method

This member function is called to set the hue for the color window.

void SetHue(
    double h
);
Parameters

h
Represents the new hue value to set.

Group

CXTColorWnd Methods


CXTColorWnd::SetSaturation Method

CXTColorWnd Methods, CXTColorWnd Class
CXTColorWnd::SetSaturation Method

This member function is called to set the saturation for the color window.

void SetSaturation(
    double s
);
Parameters

s
Represents the new saturation value to set.

Group

CXTColorWnd Methods


CXTColorWnd::UpdateCursorPos Method

CXTColorWnd Methods, CXTColorWnd Class
CXTColorWnd::UpdateCursorPos Method

Call this member function to update the cursor position.

virtual void UpdateCursorPos(
    CPoint point
);
Parameters

point
Current cursor location relative to the device context.

Group

CXTColorWnd Methods


CXTColorWnd Constructors

CXTColorWnd Class, Legend, Public Methods
CXTColorWnd Constructors
Class

CXTColorWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTColorWnd | Constructs a CXTColorWnd object


CXTColorWnd::CXTColorWnd Constructor

CXTColorWnd Constructors, CXTColorWnd Class
CXTColorWnd::CXTColorWnd Constructor

Constructs a CXTColorWnd object

CXTColorWnd();
Group

CXTColorWnd Constructors


CXTColorWnd Destructors

CXTColorWnd Class, Legend, Public Methods
CXTColorWnd Destructors
Class

CXTColorWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTColorWnd | Destroys a CXTColorWnd object, handles cleanup and deallocation


CXTColorWnd::~CXTColorWnd Destructor

CXTColorWnd Destructors, CXTColorWnd Class
CXTColorWnd::~CXTColorWnd Destructor

Destroys a CXTColorWnd object, handles cleanup and deallocation

virtual ~CXTColorWnd();
Group

CXTColorWnd Destructors


CXTComboBoxEx Class

XTComboBoxEx.h, Classes, Legend, Members, Topics, CXTComboBoxEx Methods, CXTComboBoxEx Constructors, CXTComboBoxEx Destructors, CXTComboBoxEx Constructors, CXTComboBoxEx Destructors, CXTComboBoxEx Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTComboBoxEx Class

The CXTComboBoxEx class is a CComboBox derived class. It extends the combo box control by providing support for image lists.

Class Hierarchy

class CXTComboBoxEx : public CComboBox;
File

XTComboBoxEx.h

Remarks

By using CXTComboBoxEx to create combo box controls, you no longer need to implement your own image drawing code. Instead, use CXTComboBoxEx to access images from an image list.

Group

Classes

Legend
Method
virtual
CXTComboBoxEx Constructors
CXTComboBoxEx Constructors | Description
CXTComboBoxEx | Constructs a CXTComboBoxEx object
CXTComboBoxEx Destructors
CXTComboBoxEx Destructors | Description
~CXTComboBoxEx | Destroys a CXTComboBoxEx object, handles cleanup and deallocation
CXTComboBoxEx Methods
CXTComboBoxEx Methods | Description
Create | This member function creates the combo box and attaches it to the CXTComboBoxEx object.
DeleteItem | This member function removes an item from a ComboBoxEx control.
GetComboBoxCtrl | Call this member function to get a pointer to a combo box control within a CXTComboBoxEx object.
GetEditCtrl | Call this member function to get a pointer to the edit control for a combo box.
GetExtendedStyle | This member function retrieves the extended styles control.
GetImageList | Call this member function to retrieve a pointer to the image list used by a CXTComboBoxEx control.
GetItem | This member function retrieves item information for a given ComboBoxEx item.
HasEditChanged | This member function is used to determine if the text in the combo has changed by typing.
InsertItem |
SetExtendedStyle | This member function sets extended styles within a combo box control.
SetImageList | Sets an image list for a ComboBoxEx control.
SetItem | This member function sets the attributes for an item in a ComboBoxEx control.


CXTComboBoxEx Methods

CXTComboBoxEx Class, Legend, Public Methods
CXTComboBoxEx Methods
Class

CXTComboBoxEx Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Create | This member function creates the combo box and attaches it to the CXTComboBoxEx object.
DeleteItem | This member function removes an item from a ComboBoxEx control.
GetComboBoxCtrl | Call this member function to get a pointer to a combo box control within a CXTComboBoxEx object.
GetEditCtrl | Call this member function to get a pointer to the edit control for a combo box.
GetExtendedStyle | This member function retrieves the extended styles control.
GetImageList | Call this member function to retrieve a pointer to the image list used by a CXTComboBoxEx control.
GetItem | This member function retrieves item information for a given ComboBoxEx item.
HasEditChanged | This member function is used to determine if the text in the combo has changed by typing.
InsertItem |
SetExtendedStyle | This member function sets extended styles within a combo box control.
SetImageList | Sets an image list for a ComboBoxEx control.
SetItem | This member function sets the attributes for an item in a ComboBoxEx control.


CXTComboBoxEx::Create Method

CXTComboBoxEx Methods, CXTComboBoxEx Class
CXTComboBoxEx::Create Method

This member function creates the combo box and attaches it to the CXTComboBoxEx object.

BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Specifies the combination of combo box styles applied to the combo box.
rect
A reference to a CRect object or RECT structure that specifies the position and size of the combo box.
pParentWnd
A pointer to a CWnd object that is the parent window of the combo box (usually a CDialog). It must not be NULL.
nID
Specifies the combo box's control ID.

Returns

Nonzero if the operation was successful, otherwise returns zero.

Group

CXTComboBoxEx Methods


CXTComboBoxEx::DeleteItem Method

CXTComboBoxEx Methods, CXTComboBoxEx Class
CXTComboBoxEx::DeleteItem Method

This member function removes an item from a ComboBoxEx control.

int DeleteItem(
    int iIndex
);
Parameters

iIndex
Zero-based index of the item to be removed.

Returns

The number of items remaining in the control. If 'iIndex' is invalid, the function returns CB_ERR.

Group

CXTComboBoxEx Methods


CXTComboBoxEx::GetComboBoxCtrl Method

CXTComboBoxEx Methods, CXTComboBoxEx Class, Body Source
CXTComboBoxEx::GetComboBoxCtrl Method

Call this member function to get a pointer to a combo box control within a CXTComboBoxEx object.

CComboBox* GetComboBoxCtrl();
Returns

A pointer to a CComboBox object.

Body Source
CComboBox* CXTComboBoxEx::GetComboBoxCtrl() {
    ASSERT(::IsWindow(m_hWnd)); return (CComboBox*) CComboBox::FromHandle((HWND) ::SendMessage(m_hWnd, CBEM_GETCOMBOCONTROL, 0, 0));
}
Group

CXTComboBoxEx Methods


CXTComboBoxEx::GetEditCtrl Method

CXTComboBoxEx Methods, CXTComboBoxEx Class, Body Source
CXTComboBoxEx::GetEditCtrl Method

Call this member function to get a pointer to the edit control for a combo box.

CEdit* GetEditCtrl();
Returns

A pointer to a CEdit object.

Body Source
CEdit* CXTComboBoxEx::GetEditCtrl() {
    ASSERT(::IsWindow(m_hWnd)); return (CEdit*) CEdit::FromHandle((HWND) ::SendMessage(m_hWnd, CBEM_GETEDITCONTROL, 0, 0));
}
Group

CXTComboBoxEx Methods


CXTComboBoxEx::GetExtendedStyle Method

CXTComboBoxEx Methods, CXTComboBoxEx Class, Body Source
CXTComboBoxEx::GetExtendedStyle Method

This member function retrieves the extended styles control.

DWORD GetExtendedStyle() const;
Returns

The DWORD value that contains the extended styles that are used for the combo box control.

Body Source
DWORD CXTComboBoxEx::GetExtendedStyle() const {
    ASSERT(::IsWindow(m_hWnd)); return (BOOL) ::SendMessage(m_hWnd, CBEM_GETEXTENDEDSTYLE, 0, 0);
}
Group

CXTComboBoxEx Methods


CXTComboBoxEx::GetImageList Method

CXTComboBoxEx Methods, CXTComboBoxEx Class, Body Source
CXTComboBoxEx::GetImageList Method

Call this member function to retrieve a pointer to the image list used by a CXTComboBoxEx control.

CImageList* GetImageList() const;
Returns

A pointer to a CImageList object. If it fails, this member function returns NULL.

Body Source
CImageList* CXTComboBoxEx::GetImageList() const {
    ASSERT(::IsWindow(m_hWnd)); return CImageList::FromHandle((HIMAGELIST) ::SendMessage(m_hWnd, CBEM_GETIMAGELIST, 0, 0));
}
Group

CXTComboBoxEx Methods


CXTComboBoxEx::GetItem Method

CXTComboBoxEx Methods, CXTComboBoxEx Class
CXTComboBoxEx::GetItem Method

This member function retrieves item information for a given ComboBoxEx item.

BOOL GetItem(
    COMBOBOXEXITEM* pCBItem
);
Parameters

pCBItem
A pointer to a COMBOBOXEXITEM structure that will receive the item information.

Returns

Nonzero if the operation was successful, otherwise returns zero.

Group

CXTComboBoxEx Methods


CXTComboBoxEx::HasEditChanged Method

CXTComboBoxEx Methods, CXTComboBoxEx Class, Body Source
CXTComboBoxEx::HasEditChanged Method

This member function is used to determine if the text in the combo has changed by typing.

BOOL HasEditChanged();
Returns

Nonzero if the user has typed in the control's edit box, otherwise returns zero.

Body Source
BOOL CXTComboBoxEx::HasEditChanged() {
    ASSERT(::IsWindow(m_hWnd)); return (BOOL) ::SendMessage(m_hWnd, CBEM_HASEDITCHANGED, 0, 0);
}
Group

CXTComboBoxEx Methods


InsertItem Method

CXTComboBoxEx Methods
InsertItem Method
Overload List
Methods
Method | Description
CXTComboBoxEx::InsertItem (const COMBOBOXEXITEM*) | This member function inserts a new item in a ComboBoxEx control.
CXTComboBoxEx::InsertItem (int, LPCTSTR, int, int, int, UINT) | This member function inserts a new item in a ComboBoxEx control.
CXTComboBoxEx::InsertItem (int, UINT, int, int, int, UINT) | This member function inserts a new item in a ComboBoxEx control.
Group

CXTComboBoxEx Methods


CXTComboBoxEx::InsertItem Method (const COMBOBOXEXITEM*)

InsertItem Method, CXTComboBoxEx Class
CXTComboBoxEx::InsertItem Method (const COMBOBOXEXITEM*)

This member function inserts a new item in a ComboBoxEx control.

int InsertItem(
    const COMBOBOXEXITEM* pCBItem
);
int InsertItem(
    int iItem,
    UINT nStringID,
    int iIndent = 0,
    int iImage = 0,
    int iSelectedImage = 0,
    UINT mask = CBEIF_TEXT | CBEIF_IMAGE | CBEIF_SELECTEDIMAGE | CBEIF_INDENT
);
int InsertItem(
    int iItem,
    LPCTSTR lpszItem,
    int iIndent = 0,
    int iImage = 0,
    int iSelectedImage = 0,
    UINT mask = CBEIF_TEXT | CBEIF_IMAGE | CBEIF_SELECTEDIMAGE | CBEIF_INDENT
);
Parameters

pCBItem
A pointer to a COMBOBOXEXITEM structure that will receive the item information. This structure contains callback flag values for the item.
iItem
Item index.
nStringID
String resource.
iIndent
Amount in pixels the image is to be indented.
iImage
Image index.
iSelectedImage
Selected image index.
mask
Style mask.
lpszItem
Item string.

Returns

The index at which the new item was inserted if successful; otherwise returns -1.

Group

InsertItem Method


CXTComboBoxEx::SetExtendedStyle Method

CXTComboBoxEx Methods, CXTComboBoxEx Class, Body Source
CXTComboBoxEx::SetExtendedStyle Method

This member function sets extended styles within a combo box control.

DWORD SetExtendedStyle(
    DWORD dwExMask,
    DWORD dwExStyles
);
Parameters

dwExMask
A DWORD value that indicates which styles in 'dwExStyles' are to be affected. Only the extended styles in 'dwExMask' will be changed. All other styles will be maintained as is. If this parameter is zero, then all of the styles in 'dwExStyles' will be affected.
dwExStyles
A DWORD value that contains the combo box control extended styles to set for the control.

Returns

A DWORD value that contains the extended styles previously used for the control.

Body Source
DWORD CXTComboBoxEx::SetExtendedStyle(DWORD dwExMask, DWORD dwExStyles) {
    ASSERT(::IsWindow(m_hWnd)); return (DWORD) ::SendMessage(m_hWnd, CBEM_SETEXTENDEDSTYLE, (DWORD) dwExMask, (LPARAM) dwExStyles);
}
Group

CXTComboBoxEx Methods


CXTComboBoxEx::SetImageList Method

CXTComboBoxEx Methods, CXTComboBoxEx Class, Body Source
CXTComboBoxEx::SetImageList Method

Sets an image list for a ComboBoxEx control.

CImageList* SetImageList(
    CImageList* pImageList
);
Parameters

pImageList
A pointer to a CImageList object containing the images to use with the CXTComboBoxEx control.

Returns

A pointer to a CImageList object containing the images previously used by the CXTComboBoxEx control. Returns NULL if no image list was previously set.

Body Source
CImageList* CXTComboBoxEx::SetImageList(CImageList* pImageList) {
    ASSERT(::IsWindow(m_hWnd)); return CImageList::FromHandle((HIMAGELIST) ::SendMessage(m_hWnd, CBEM_SETIMAGELIST, 0, (LPARAM)pImageList->GetSafeHandle()));
}
Group

CXTComboBoxEx Methods


CXTComboBoxEx::SetItem Method

CXTComboBoxEx Methods, CXTComboBoxEx Class
CXTComboBoxEx::SetItem Method

This member function sets the attributes for an item in a ComboBoxEx control.

BOOL SetItem(
    const COMBOBOXEXITEM* pCBItem
);
Parameters

pCBItem
A pointer to a COMBOBOXEXITEM structure that will receive the item information.

Returns

Nonzero if the operation was successful, otherwise returns zero.

Group

CXTComboBoxEx Methods


CXTComboBoxEx Constructors

CXTComboBoxEx Class, Legend, Public Methods
CXTComboBoxEx Constructors
Class

CXTComboBoxEx Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTComboBoxEx | Constructs a CXTComboBoxEx object


CXTComboBoxEx::CXTComboBoxEx Constructor

CXTComboBoxEx Constructors, CXTComboBoxEx Class, Body Source
CXTComboBoxEx::CXTComboBoxEx Constructor

Constructs a CXTComboBoxEx object

CXTComboBoxEx();
Body Source
CXTComboBoxEx::CXTComboBoxEx() {

}
Group

CXTComboBoxEx Constructors


CXTComboBoxEx Destructors

CXTComboBoxEx Class, Legend, Public Methods
CXTComboBoxEx Destructors
Class

CXTComboBoxEx Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTComboBoxEx | Destroys a CXTComboBoxEx object, handles cleanup and deallocation


CXTComboBoxEx::~CXTComboBoxEx Destructor

CXTComboBoxEx Destructors, CXTComboBoxEx Class
CXTComboBoxEx::~CXTComboBoxEx Destructor

Destroys a CXTComboBoxEx object, handles cleanup and deallocation

virtual ~CXTComboBoxEx();
Group

CXTComboBoxEx Destructors


CXTContextBkColorHandler Class

XTHelpers.h, Classes
CXTContextBkColorHandler Class

Background color context handler

Class Hierarchy

class CXTContextBkColorHandler;
File

XTHelpers.h

Group

Classes


CXTContextBkModeHandler Class

XTHelpers.h, Classes
CXTContextBkModeHandler Class

Background mode context handler

Class Hierarchy

class CXTContextBkModeHandler;
File

XTHelpers.h

Group

Classes


CXTContextObjectHandler Template

XTHelpers.h, Classes
CXTContextObjectHandler Template

Safely selects object into device context

Class Hierarchy

template <class T>
class CXTContextObjectHandler;
File

XTHelpers.h

Group

Classes


CXTContextTextColorHandler Class

XTHelpers.h, Classes
CXTContextTextColorHandler Class

Text color context handler

Class Hierarchy

class CXTContextTextColorHandler;
File

XTHelpers.h

Group

Classes


CXTContextViewPortOrgHandler Class

XTHelpers.h, Classes
CXTContextViewPortOrgHandler Class

Handles viewport origin

Class Hierarchy

class CXTContextViewPortOrgHandler;
File

XTHelpers.h

Group

Classes


CXTDateEdit Class

XTMaskEdit.h, Classes, Legend, Members, Topics, CXTDateEdit Methods, CXTDateEdit Constructors, CXTDateEdit Constructors, CXTDateEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTDateEdit Class

CXTDateEdit is a CXTMaskEdit derived class. It is specifically geared toward editing date fields.

Class Hierarchy

class CXTDateEdit : public CXTMaskEdit;
File

XTMaskEdit.h

Group

Classes

Legend
Method
virtual
CXTDateEdit Constructors
CXTDateEdit Constructors | Description
CXTDateEdit | Constructs a CXTDateEdit object
CXTDateEdit Methods
CXTDateEdit Methods | Description
FormatOleDateTime | This member function will read the date passed in as 'dt', and format the 'strData' string as DD/MM/YY.
GetDateTime | This member function will retrieve a COleDateTime object that represents the currently displayed date.
GetWindowDateTime | This member function will retrieve a CString object that represents the currently displayed date.
ProcessMask | This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
ReadOleDateTime | This member function will read the date string passed in as 'lpszData' and is converted and returned as a COleDateTime object.
SetDateTime |


CXTDateEdit Methods

CXTDateEdit Class, Legend, Public Methods
CXTDateEdit Methods
Class

CXTDateEdit Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
FormatOleDateTime | This member function will read the date passed in as 'dt', and format the 'strData' string as DD/MM/YY.
GetDateTime | This member function will retrieve a COleDateTime object that represents the currently displayed date.
GetWindowDateTime | This member function will retrieve a CString object that represents the currently displayed date.
ProcessMask | This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
ReadOleDateTime | This member function will read the date string passed in as 'lpszData' and is converted and returned as a COleDateTime object.
SetDateTime |


CXTDateEdit::FormatOleDateTime Method

CXTDateEdit Methods, CXTDateEdit Class
CXTDateEdit::FormatOleDateTime Method

This member function will read the date passed in as 'dt', and format the 'strData' string as DD/MM/YY.

virtual void FormatOleDateTime(
    CString& strData,
    COleDateTime dt
);
Parameters

strData
String reference that is filled with the date.
dt
COleDateTime object that represents the date to format.

Group

CXTDateEdit Methods


CXTDateEdit::GetDateTime Method

CXTDateEdit Methods, CXTDateEdit Class
CXTDateEdit::GetDateTime Method

This member function will retrieve a COleDateTime object that represents the currently displayed date.

virtual COleDateTime GetDateTime();
Returns

A COleDateTime object representing the currently displayed date.

Group

CXTDateEdit Methods


CXTDateEdit::GetWindowDateTime Method

CXTDateEdit Methods, CXTDateEdit Class
CXTDateEdit::GetWindowDateTime Method

This member function will retrieve a CString object that represents the currently displayed date.

virtual CString GetWindowDateTime();
Returns

A CString object representing the currently displayed date.

Group

CXTDateEdit Methods


CXTDateEdit::ProcessMask Method

CXTDateEdit Methods, CXTDateEdit Class
CXTDateEdit::ProcessMask Method

This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.

virtual BOOL ProcessMask(
    TCHAR& nChar,
    int nEndPos
);
Parameters

nChar
Contains the character code value of the key.
nEndPos
Index of character in display string.

Returns

true if successful, otherwise returns false.

Group

CXTDateEdit Methods


CXTDateEdit::ReadOleDateTime Method

CXTDateEdit Methods, CXTDateEdit Class
CXTDateEdit::ReadOleDateTime Method

This member function will read the date string passed in as 'lpszData' and is converted and returned as a COleDateTime object.

virtual COleDateTime ReadOleDateTime(
    LPCTSTR lpszData
);
Parameters

lpszData
A NULL terminated string that represents the date to convert.

Returns

A COleDateTime object that represents the converted date string.

Group

CXTDateEdit Methods


SetDateTime Method

CXTDateEdit Methods
SetDateTime Method
Overload List
Methods
Method | Description
CXTDateEdit::SetDateTime (COleDateTime&) | This member function will set the time based on the text string passed in as 'strDate'.
CXTDateEdit::SetDateTime (LPCTSTR) | This member function will set the time based on the text string passed in as 'strDate'.
Group

CXTDateEdit Methods


CXTDateEdit::SetDateTime Method (COleDateTime&)

SetDateTime Method, CXTDateEdit Class
CXTDateEdit::SetDateTime Method (COleDateTime&)

This member function will set the time based on the text string passed in as 'strDate'.

virtual void SetDateTime(
    COleDateTime& dt
);
virtual void SetDateTime(
    LPCTSTR strDate
);
Parameters

dt
A reference to a COleDateTime object that represents the date to display.
strDate
A NULL terminated string that represents the date to display.

Group

SetDateTime Method


CXTDateEdit Constructors

CXTDateEdit Class, Legend, Public Methods
CXTDateEdit Constructors
Class

CXTDateEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTDateEdit | Constructs a CXTDateEdit object


CXTDateEdit::CXTDateEdit Constructor

CXTDateEdit Constructors, CXTDateEdit Class
CXTDateEdit::CXTDateEdit Constructor

Constructs a CXTDateEdit object

CXTDateEdit();
Group

CXTDateEdit Constructors


CXTDateTimeCtrl Class

XTDateTimeCtrl.h, Classes, Legend, Members, Topics, CXTDateTimeCtrl Methods, CXTDateTimeCtrl Constructors, CXTDateTimeCtrl Destructors, CXTDateTimeCtrl Constructors, CXTDateTimeCtrl Destructors, CXTDateTimeCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTDateTimeCtrl Class

CXTDateTimeCtrl is a CWnd derived class. A CXTDateTimeCtrl object encapsulates the functionality of a date and time picker control.

Class Hierarchy

class CXTDateTimeCtrl : public CWnd;
File

XTDateTimeCtrl.h

Remarks

The date and time picker control (DTP control) provides a simple interface to exchange date and time information with a user. This interface contains fields, and each field displays a part of the date and time information stored in the control. The user can change the information stored in the control by changing the content of the string in a given field. The user can also move from field to field using the mouse or the keyboard.

You can customize the date and time picker control by applying a variety of styles to the object when you create it. See Date and Time Picker Control Styles in the Platform SDK for more information about styles specific to the date and time picker control. You can set the display format of the DTP control using format styles. These format styles are described in Preset DTP Display Formats in the Platform SDK.

The date and time picker control also uses notifications and callbacks, which are described in Using CXTDateTimeCtrl in the Xtreme Toolkit online help.

Group

Classes

Legend
Method
virtual
CXTDateTimeCtrl Constructors
CXTDateTimeCtrl Constructors | Description
CXTDateTimeCtrl | Constructs a CXTDateTimeCtrl object
CXTDateTimeCtrl Destructors
CXTDateTimeCtrl Destructors | Description
~CXTDateTimeCtrl | Destroys a CXTDateTimeCtrl object, handles cleanup and deallocation
CXTDateTimeCtrl Methods
CXTDateTimeCtrl Methods | Description
Create | This member function creates the date and time picker control and attaches it to the CXTDateTimeCtrl object.
GetMonthCalColor | This member function retrieves the color for a given portion of the month calendar within the date and time picker control.
GetMonthCalCtrl | This member function retrieves the date and time picker's child month calendar control.
GetMonthCalFont | This member function retrieves the font currently used by the date and time picker control's child month calendar control.
GetRange |
GetTime |
SetFormat | This member function sets the display of a date and time picker control based on a given format string.
SetMonthCalColor | This member function sets the color for a given portion of the month calendar within a date and time picker control.
SetMonthCalFont | This member function sets the font to be used by the date and time picker control's child month calendar control.
SetRange |
SetTime |


CXTDateTimeCtrl Methods

CXTDateTimeCtrl Class, Legend, Public Methods
CXTDateTimeCtrl Methods
Class

CXTDateTimeCtrl Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Create | This member function creates the date and time picker control and attaches it to the CXTDateTimeCtrl object.
GetMonthCalColor | This member function retrieves the color for a given portion of the month calendar within the date and time picker control.
GetMonthCalCtrl | This member function retrieves the date and time picker's child month calendar control.
GetMonthCalFont | This member function retrieves the font currently used by the date and time picker control's child month calendar control.
GetRange |
GetTime |
SetFormat | This member function sets the display of a date and time picker control based on a given format string.
SetMonthCalColor | This member function sets the color for a given portion of the month calendar within a date and time picker control.
SetMonthCalFont | This member function sets the font to be used by the date and time picker control's child month calendar control.
SetRange |
SetTime |


CXTDateTimeCtrl::Create Method

CXTDateTimeCtrl Methods, CXTDateTimeCtrl Class
CXTDateTimeCtrl::Create Method

This member function creates the date and time picker control and attaches it to the CXTDateTimeCtrl object.

BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Specifies the combination of date time control styles. See Date and Time Picker Control Styles in the Platform SDK for more information about date and time picker styles.
rect
A reference to a RECT structure, which is the position and size of the date and time picker control.
pParentWnd
A pointer to a CWnd object that is the parent window of the date and time picker control. It must not be NULL.
nID
Specifies the control ID of the date and time picker control.

Returns

Nonzero if creation was successful, otherwise returns 0.

Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::GetMonthCalColor Method

CXTDateTimeCtrl Methods, CXTDateTimeCtrl Class, Body Source
CXTDateTimeCtrl::GetMonthCalColor Method

This member function retrieves the color for a given portion of the month calendar within the date and time picker control.

COLORREF GetMonthCalColor(
    int iColor
) const;
Parameters

iColor
An int value specifying which color area of the month calendar to retrieve. For a list of values, see the 'iColor' parameter for SetMonthCalColor.

Returns

A COLORREF value that represents the color setting for the specified portion of the month calendar control if successful. The function

1 if unsuccessful.

Body Source
COLORREF CXTDateTimeCtrl::GetMonthCalColor(int iColor) const {
    ASSERT(::IsWindow(m_hWnd)); return (COLORREF) ::SendMessage(m_hWnd, DTM_GETMCCOLOR, (WPARAM) iColor, 0);
}
Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::GetMonthCalCtrl Method

CXTDateTimeCtrl Methods, CXTDateTimeCtrl Class, Body Source
CXTDateTimeCtrl::GetMonthCalCtrl Method

This member function retrieves the date and time picker's child month calendar control.

CXTMonthCalCtrl* GetMonthCalCtrl() const;
Returns

A pointer to a DDX_XTMonthCalCtrl object; or NULL if unsuccessful or the window is not visible.

Body Source
CXTMonthCalCtrl* CXTDateTimeCtrl::GetMonthCalCtrl() const {
    ASSERT(::IsWindow(m_hWnd)); return (CXTMonthCalCtrl*) CWnd::FromHandle((HWND) ::SendMessage(m_hWnd, DTM_GETMONTHCAL, 0, 0));
}
Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::GetMonthCalFont Method

CXTDateTimeCtrl Methods, CXTDateTimeCtrl Class, Body Source
CXTDateTimeCtrl::GetMonthCalFont Method

This member function retrieves the font currently used by the date and time picker control's child month calendar control.

CFont* GetMonthCalFont() const;
Parameters

hFont
Handle to the font that will be set.
bRedraw
Specifies whether or not the control should be redrawn immediately upon setting the font. Setting this parameter to TRUE causes the control to redraw itself.

Returns

A pointer to a CFont object, or returns NULL if unsuccessful.

Body Source
CFont* CXTDateTimeCtrl::GetMonthCalFont() const {
    ASSERT(::IsWindow(m_hWnd)); return CFont::FromHandle((HFONT) ::SendMessage(m_hWnd, DTM_GETMCFONT, 0, 0));
}
Group

CXTDateTimeCtrl Methods


GetRange Method

CXTDateTimeCtrl Methods
GetRange Method
Overload List
Methods
Method | Description
CXTDateTimeCtrl::GetRange (COleDateTime*, COleDateTime*) | This member function retrieves the current minimum and maximum allowable system times for a date and time picker control.
CXTDateTimeCtrl::GetRange (CTime*, CTime*) | This member function retrieves the current minimum and maximum allowable system times for a date and time picker control.
Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::GetRange Method (COleDateTime*, COleDateTime*)

GetRange Method, CXTDateTimeCtrl Class
CXTDateTimeCtrl::GetRange Method (COleDateTime*, COleDateTime*)

This member function retrieves the current minimum and maximum allowable system times for a date and time picker control.

DWORD GetRange(
    COleDateTime* pMinRange,
    COleDateTime* pMaxRange
) const;
DWORD GetRange(
    CTime* pMinRange,
    CTime* pMaxRange
) const;
Parameters

pMinRange
A pointer to a COleDateTime or CTime object containing the earliest time allowed in the CXTDateTimeCtrl object.
pMaxRange
A pointer to a COleDateTime or CTime object containing the latest time allowed in the CXTDateTimeCtrl object.

Returns

A DWORD value containing flags that indicate which ranges are set.

Group

GetRange Method


GetTime Method

CXTDateTimeCtrl Methods
GetTime Method
Overload List
Methods
Method | Description
CXTDateTimeCtrl::GetTime (COleDateTime&) | This member function retrieves the currently selected time from a date and time picker control and places it in a specified SYSTEMTIME structure.
CXTDateTimeCtrl::GetTime (CTime&) | This member function retrieves the currently selected time from a date and time picker control and places it in a specified SYSTEMTIME structure.
CXTDateTimeCtrl::GetTime (LPSYSTEMTIME) | This member function retrieves the currently selected time from a date and time picker control and places it in a specified SYSTEMTIME structure.
Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::GetTime Method (COleDateTime&)

GetTime Method, CXTDateTimeCtrl Class
CXTDateTimeCtrl::GetTime Method (COleDateTime&)

This member function retrieves the currently selected time from a date and time picker control and places it in a specified SYSTEMTIME structure.

BOOL GetTime(
    COleDateTime& timeDest
) const;
DWORD GetTime(
    CTime& timeDest
) const;
DWORD GetTime(
    LPSYSTEMTIME pTimeDest
) const;
Parameters

timeDest
A reference to a CTime or COleDateTime object that will receive the system time information.
pTimeDest
A pointer to the SYSTEMTIME structure to receive the system time information. Must not be NULL.

Returns

In the first version nonzero if the time is successfully written to the COleDateTime object, otherwise returns zero. In the second and third version a DWORD value equal to the dwFlag member set in the NMDATETIMECHANGE structure.

Group

GetTime Method


CXTDateTimeCtrl::SetFormat Method

CXTDateTimeCtrl Methods, CXTDateTimeCtrl Class, Body Source
CXTDateTimeCtrl::SetFormat Method

This member function sets the display of a date and time picker control based on a given format string.

BOOL SetFormat(
    LPCTSTR pstrFormat
);
Parameters

pstrFormat
A pointer to a zero-terminated format string that defines the desired display. Setting this parameter to NULL will reset the control to the default format string for the current style.

Returns

Nonzero if successful, otherwise returns zero.

Body Source
BOOL CXTDateTimeCtrl::SetFormat(LPCTSTR pstrFormat) {
    ASSERT(::IsWindow(m_hWnd)); return (BOOL) ::SendMessage(m_hWnd, DTM_SETFORMAT, 0, (LPARAM) pstrFormat);
}
Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::SetMonthCalColor Method

CXTDateTimeCtrl Methods, CXTDateTimeCtrl Class, Body Source
CXTDateTimeCtrl::SetMonthCalColor Method

This member function sets the color for a given portion of the month calendar within a date and time picker control.

COLORREF SetMonthCalColor(
    int iColor,
    COLORREF ref
);
Parameters

iColor
An int value specifying which area of the month calendar control to set. This value can be one of the values listed in the remarks section.
ref
A RGB value representing the color that will be set for the specified area of the month calendar.

Returns

A COLORREF value that represents the previous color setting for the specified portion of the month calendar control if successful. Otherwise, the message returns -1.

Remarks

The area of the calendar control that the color is to be set for can be one of the following values:

  • MCSC_BACKGROUND Set the background color displayed between months.
  • MCSC_MONTHBK Set the background color displayed within a month.
  • MCSC_TEXT Set the color used to display text within a month.
  • MCSC_TITLEBK Set the background color displayed in the calendar's title.
  • MCSC_TITLETEXT Set the color used to display text within the calendar's title.
  • MCSC_TRAILINGTEXT Set the color used to display header and trailing-day text. Header and trailing days are the days from the previous and following months that appear on the current calendar.
Body Source
COLORREF CXTDateTimeCtrl::SetMonthCalColor(int iColor, COLORREF ref) {
    ASSERT(::IsWindow(m_hWnd)); return (COLORREF) ::SendMessage(m_hWnd, DTM_SETMCCOLOR, (WPARAM) iColor, (LPARAM) ref);
}
Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::SetMonthCalFont Method

CXTDateTimeCtrl Methods, CXTDateTimeCtrl Class, Body Source
CXTDateTimeCtrl::SetMonthCalFont Method

This member function sets the font to be used by the date and time picker control's child month calendar control.

void SetMonthCalFont(
    HFONT hFont,
    BOOL bRedraw = TRUE
);
Parameters

hFont
Handle to a HFONT object that represents the new font to use.
bRedraw
TRUE to redraw the CXTDateTimeCtrl object.

Body Source
void CXTDateTimeCtrl::SetMonthCalFont(HFONT hFont, BOOL bRedraw) {
    ASSERT(::IsWindow(m_hWnd)); ::SendMessage(m_hWnd, DTM_SETMCFONT, (WPARAM) hFont, MAKELONG(bRedraw, 0));
}
Group

CXTDateTimeCtrl Methods


SetRange Method

CXTDateTimeCtrl Methods
SetRange Method
Overload List
Methods
Method | Description
CXTDateTimeCtrl::SetRange (const COleDateTime*, const COleDateTime*) | This member function sets the minimum and maximum allowable system times for a date and time picker control.
CXTDateTimeCtrl::SetRange (const CTime*, const CTime*) | This member function sets the minimum and maximum allowable system times for a date and time picker control.
Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::SetRange Method (const COleDateTime*, const COleDateTime*)

SetRange Method, CXTDateTimeCtrl Class
CXTDateTimeCtrl::SetRange Method (const COleDateTime*, const COleDateTime*)

This member function sets the minimum and maximum allowable system times for a date and time picker control.

BOOL SetRange(
    const COleDateTime* pMinRange,
    const COleDateTime* pMaxRange
);
BOOL SetRange(
    const CTime* pMinRange,
    const CTime* pMaxRange
);
Parameters

pMinRange
A pointer to a CTime or COleDateTime object containing the earliest time allowed in the CXTDateTimeCtrl object.
pMaxRange
A pointer to a CTime or COleDateTime object containing the latest time allowed in the CXTDateTimeCtrl object.

Returns

Nonzero if successful, otherwise returns zero.

Group

SetRange Method


SetTime Method

CXTDateTimeCtrl Methods
SetTime Method
Overload List
Methods
Method | Description
CXTDateTimeCtrl::SetTime (LPSYSTEMTIME) | This member function sets the time in a date and time picker control.
CXTDateTimeCtrl::SetTime (const COleDateTime&) | This member function sets the time in a date and time picker control.
CXTDateTimeCtrl::SetTime (const CTime*) | This member function sets the time in a date and time picker control.
Group

CXTDateTimeCtrl Methods


CXTDateTimeCtrl::SetTime Method (const CTime*)

SetTime Method, CXTDateTimeCtrl Class
CXTDateTimeCtrl::SetTime Method (const CTime*)

This member function sets the time in a date and time picker control.

BOOL SetTime(
    const CTime* pTimeNew
);
BOOL SetTime(
    const COleDateTime& timeNew
);
BOOL SetTime(
    LPSYSTEMTIME pTimeNew = NULL
);
Parameters

pTimeNew
A pointer to a CTime or SYSTEMTIME object containing the time that the control will be set to.
timeNew
A reference to a COleDateTime object containing the time that the control will be set to.

Returns

Nonzero if successful, otherwise returns zero.

Group

SetTime Method


CXTDateTimeCtrl Constructors

CXTDateTimeCtrl Class, Legend, Public Methods
CXTDateTimeCtrl Constructors
Class

CXTDateTimeCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTDateTimeCtrl | Constructs a CXTDateTimeCtrl object


CXTDateTimeCtrl::CXTDateTimeCtrl Constructor

CXTDateTimeCtrl Constructors, CXTDateTimeCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTDateTimeCtrl::CXTDateTimeCtrl Constructor

Constructs a CXTDateTimeCtrl object

CXTDateTimeCtrl();
Body Source
CXTDateTimeCtrl::CXTDateTimeCtrl() {

}
Group

CXTDateTimeCtrl Constructors


CXTDateTimeCtrl Destructors

CXTDateTimeCtrl Class, Legend, Public Methods
CXTDateTimeCtrl Destructors
Class

CXTDateTimeCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTDateTimeCtrl | Destroys a CXTDateTimeCtrl object, handles cleanup and deallocation


CXTDateTimeCtrl::~CXTDateTimeCtrl Destructor

CXTDateTimeCtrl Destructors, CXTDateTimeCtrl Class
CXTDateTimeCtrl::~CXTDateTimeCtrl Destructor

Destroys a CXTDateTimeCtrl object, handles cleanup and deallocation

virtual ~CXTDateTimeCtrl();
Group

CXTDateTimeCtrl Destructors


CXTDirWatcher Class

XTDirWatcher.h, Classes, Legend, Members, Topics, CXTDirWatcher Data Members, CXTDirWatcher Methods, CXTDirWatcher Constructors, CXTDirWatcher Destructors, CXTDirWatcher Constructors, CXTDirWatcher Data Members, CXTDirWatcher Destructors, Example, CXTDirWatcher Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTDirWatcher Class

The CXTDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur.

Class Hierarchy

class CXTDirWatcher : public CWinThread;
File

XTDirWatcher.h

Remarks

Whenever an item is created, deleted or renamed the thread will send a notification to the its owner in the form of a XTWM_SHELL_NOTIFY message. The WPARAM value for the notification will be set to SHN_XT_TREESELCHANGE if the folder list contents require updating or SHN_XT_CONTENTSCHANGED if the tree contents require updating. The LPARAM value is set to the address of a XT_TVITEMDATA structure that contains information the path monitored.

Example

To use CXTDirWatcher, add a CXTDirWatcher* m_pDirThread member to your class and instantiate a new thread using AfxBeginThread:

// Start the directory monitoring thread.
m_pDirThread = (CXTDirWatcher*)AfxBeginThread(RUNTIME_CLASS(CXTDirWatcher),
    THREAD_PRIORITY_NORMAL, 0, CREATE_SUSPENDED, NULL);

You can then specify what directory you wish to monitor by calling SetFolderData or SetFolderPath:

// Specify the folder to monitor.
m_pDirThread->SetFolderData(this, lpTVID);
m_pDirThread->ResumeThread();

You can add a message handler to the window receiving messages and handle your change event notifications. The thread will send two notifications, the wParam indicates what event has occurred. If wParam equal HN_XT_REFRESHFOLDER this indicates that the folder list has changed and needs to be updated. If wParam equals SHN_XT_REFRESHTREE this indicates the folder tree has changed and needs to be updated. The lParam value represents a pointer to a XT_TVITEMDATA structure for the folder:

BEGIN_MESSAGE_MAP(CNotifyWnd, CWnd)
    //{{AFX_MSG_MAP(CNotifyWnd)
    //}}AFX_MSG_MAP
    ON_MESSAGE(XTWM_SHELL_NOTIFY, OnUpdateShell)
END_MESSAGE_MAP()

LRESULT CNotifyWnd::OnUpdateShell(WPARAM wParam, LPARAM lParam)
{
    switch (wParam)
    {
        case SHN_XT_REFRESHFOLDER:
        case SHN_XT_REFRESHTREE:
        {
            // Directory monitory thread has issued an update notification,
            // refresh the list control.
            XT_TVITEMDATA*  lpTVID = (XT_TVITEMDATA*)lParam;
            ASSERT(lpTVID);

            PopulateListView(lpTVID, lpTVID->lpsfParent);
            break;
        }

        default:
            break;
    }

    return 0;
}

When you are finished using the CXTDirWatcher thread, you will need to free the memory associated with the object. To do so you can use the SAFE_DELETE macro like so:

SAFE_DELETE(m_pDirThread);

The CXTDirWatcher class is used internally by the CXTShellListCtrl and CXTShellListView classes to handle refreshing the list when a file or directory change occurs.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTDirWatcher Constructors
CXTDirWatcher Constructors | Description
CXTDirWatcher | Constructs a CXTDirWatcher object
CXTDirWatcher Data Members
CXTDirWatcher Data Members | Description
m_dwMonitorEvents | Change event handles.
m_strFolderPath | Path that is monitored.
m_tvid | Tree view item data.
CXTDirWatcher Destructors
CXTDirWatcher Destructors | Description
~CXTDirWatcher | Destroys a CXTDirWatcher object, handles cleanup and deallocation
CXTDirWatcher Methods
CXTDirWatcher Methods | Description
GetFolderData |
GetFolderPath | Call this member function to retrieve the full path to the directory that is currently monitored.
IsPathValid | Call this member function to determine if the specified path is a valid directory name.
RefreshFolder | This member function is called by the thread whenever the monitored directory list needs to be refreshed.
RefreshTree | This member function is called by the thread whenever the monitored directory tree needs to be refreshed.
SetFolderData | Call this member function to monitor the directory using a pointer to a XT_TVITEMDATA pointer.
SetFolderPath | Call this member function to monitor the directory specified by strPath.


CXTDirWatcher Data Members

CXTDirWatcher Class, Legend, Protected Data Members
CXTDirWatcher Data Members
Class

CXTDirWatcher Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dwMonitorEvents | Change event handles.
m_strFolderPath | Path that is monitored.
m_tvid | Tree view item data.


CXTDirWatcher::m_dwMonitorEvents Data Member

CXTDirWatcher Data Members, CXTDirWatcher Class
CXTDirWatcher::m_dwMonitorEvents Data Member

Change event handles.

HANDLE m_dwMonitorEvents[4];
Group

CXTDirWatcher Data Members


CXTDirWatcher::m_strFolderPath Data Member

CXTDirWatcher Data Members, CXTDirWatcher Class
CXTDirWatcher::m_strFolderPath Data Member

Path that is monitored.

CString m_strFolderPath;
Group

CXTDirWatcher Data Members


CXTDirWatcher::m_tvid Data Member

CXTDirWatcher Data Members, CXTDirWatcher Class
CXTDirWatcher::m_tvid Data Member

Tree view item data.

XT_TVITEMDATA m_tvid;
Group

CXTDirWatcher Data Members


CXTDirWatcher Methods

CXTDirWatcher Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTDirWatcher Methods
Class

CXTDirWatcher Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
RefreshFolder | This member function is called by the thread whenever the monitored directory list needs to be refreshed.
RefreshTree | This member function is called by the thread whenever the monitored directory tree needs to be refreshed.
Public Methods
Public Methods
Public Method | Description
GetFolderData |
GetFolderPath | Call this member function to retrieve the full path to the directory that is currently monitored.
IsPathValid | Call this member function to determine if the specified path is a valid directory name.
SetFolderData | Call this member function to monitor the directory using a pointer to a XT_TVITEMDATA pointer.
SetFolderPath | Call this member function to monitor the directory specified by strPath.


GetFolderData Method

CXTDirWatcher Methods
GetFolderData Method
Overload List
Methods
Method | Description
CXTDirWatcher::GetFolderData () | Constructs or retrieves XT_TVITEMDATA structure information.
CXTDirWatcher::GetFolderData (LPCTSTR, XT_TVITEMDATA&) | Constructs or retrieves XT_TVITEMDATA structure information.
Group

CXTDirWatcher Methods


CXTDirWatcher::GetFolderData Method ()

GetFolderData Method, CXTDirWatcher Class, Body Source
CXTDirWatcher::GetFolderData Method ()

Constructs or retrieves XT_TVITEMDATA structure information.

XT_TVITEMDATA* GetFolderData();
BOOL GetFolderData(
    LPCTSTR lpszFolderPath,
    XT_TVITEMDATA& lpTVID
);
Parameters

lpszFolderPath
Full path to directory.
lpTVID
Reference to tree view item data.

Returns

In the first version a pointer to a XT_TVITEMDATA structure. In the second version TRUE if successful, otherwise FALSE.

Remarks

In the first version this member function is called to return the a pointer to a XT_TVITEMDATA structure for the directory that is currently monitored. In the second version the function constructs a XT_TVITEMDATA structure from the specified path.

Body Source
XT_TVITEMDATA* CXTDirWatcher::GetFolderData() {
    return &m_tvid;
}
Group

GetFolderData Method


CXTDirWatcher::GetFolderPath Method

CXTDirWatcher Methods, CXTDirWatcher Class, Body Source
CXTDirWatcher::GetFolderPath Method

Call this member function to retrieve the full path to the directory that is currently monitored.

CString GetFolderPath() const;
Returns

A CString object representing the path monitored.

Body Source
CString CXTDirWatcher::GetFolderPath() const {
    return m_strFolderPath;
}
Group

CXTDirWatcher Methods


CXTDirWatcher::IsPathValid Method

CXTDirWatcher Methods, CXTDirWatcher Class
CXTDirWatcher::IsPathValid Method

Call this member function to determine if the specified path is a valid directory name.

BOOL IsPathValid(
    LPCTSTR lpszFolderPath
);
Parameters

lpszFolderPath
Full path to directory.

Returns

TRUE if the path is valid, otherwise returns FALSE.

Group

CXTDirWatcher Methods


CXTDirWatcher::RefreshFolder Method

CXTDirWatcher Methods, CXTDirWatcher Class
CXTDirWatcher::RefreshFolder Method

This member function is called by the thread whenever the monitored directory list needs to be refreshed.

virtual void RefreshFolder();
Group

CXTDirWatcher Methods


CXTDirWatcher::RefreshTree Method

CXTDirWatcher Methods, CXTDirWatcher Class
CXTDirWatcher::RefreshTree Method

This member function is called by the thread whenever the monitored directory tree needs to be refreshed.

virtual void RefreshTree();
Group

CXTDirWatcher Methods


CXTDirWatcher::SetFolderData Method

CXTDirWatcher Methods, CXTDirWatcher Class
CXTDirWatcher::SetFolderData Method

Call this member function to monitor the directory using a pointer to a XT_TVITEMDATA pointer.

BOOL SetFolderData(
    CWnd* pMainWnd,
    XT_TVITEMDATA* lpTVID
);
Parameters

pMainWnd
Pointer to the window to receive update notifications.
lpTVID
Pointer to tree view item data.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTDirWatcher Methods


CXTDirWatcher::SetFolderPath Method

CXTDirWatcher Methods, CXTDirWatcher Class
CXTDirWatcher::SetFolderPath Method

Call this member function to monitor the directory specified by strPath.

BOOL SetFolderPath(
    CWnd* pMainWnd,
    LPCTSTR lpszFolderPath
);
Parameters

pMainWnd
Points to the window to receive change notifications.
lpszFolderPath
Full path of directory to monitor.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTDirWatcher Methods


CXTDirWatcher Constructors

CXTDirWatcher Class, Legend, Public Methods
CXTDirWatcher Constructors
Class

CXTDirWatcher Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTDirWatcher | Constructs a CXTDirWatcher object


CXTDirWatcher::CXTDirWatcher Constructor

CXTDirWatcher Constructors, CXTDirWatcher Class
CXTDirWatcher::CXTDirWatcher Constructor

Constructs a CXTDirWatcher object

CXTDirWatcher();
Group

CXTDirWatcher Constructors


CXTDirWatcher Destructors

CXTDirWatcher Class, Legend, Protected Methods
CXTDirWatcher Destructors
Class

CXTDirWatcher Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTDirWatcher | Destroys a CXTDirWatcher object, handles cleanup and deallocation


CXTDirWatcher::~CXTDirWatcher Destructor

CXTDirWatcher Destructors, CXTDirWatcher Class
CXTDirWatcher::~CXTDirWatcher Destructor

Destroys a CXTDirWatcher object, handles cleanup and deallocation

virtual ~CXTDirWatcher();
Group

CXTDirWatcher Destructors


CXTDisabledButtonTheme Class

XTButtonTheme.h, Classes, Legend, Members, Topics, CXTDisabledButtonTheme Methods, CXTDisabledButtonTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTDisabledButtonTheme Class

CXTDisabledButtonTheme is a CXTButtonTheme derived class that is used to draw 3D disabled icons for the button.

Class Hierarchy

class CXTDisabledButtonTheme : public CXTButtonTheme;
File

XTButtonTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTDisabledButtonTheme Methods
CXTDisabledButtonTheme Methods | Description
DrawButtonIcon | This member function draws the icon for the button, if one has been defined.


CXTDisabledButtonTheme Methods

CXTDisabledButtonTheme Class, Legend, Protected Methods
CXTDisabledButtonTheme Methods
Class

CXTDisabledButtonTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawButtonIcon | This member function draws the icon for the button, if one has been defined.


CXTDisabledButtonTheme::DrawButtonIcon Method

CXTDisabledButtonTheme Methods, CXTDisabledButtonTheme Class
CXTDisabledButtonTheme::DrawButtonIcon Method

This member function draws the icon for the button, if one has been defined.

virtual void DrawButtonIcon(
    CDC* pDC,
    UINT nState,
    CRect& rcItem,
    CXTButton* pButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
nState
A UINT value that represents the current state for the button.
rcItem
A CRect reference that represents the current size for the button.
pButton
Points to a CXTButton object.

Group

CXTDisabledButtonTheme Methods


CXTDropSource Class

XTDropSource.h, Classes, Legend, Members, Topics, CXTDropSource Data Members, CXTDropSource Methods, CXTDropSource Constructors, CXTDropSource Destructors, CXTDropSource Constructors, CXTDropSource Data Members, CXTDropSource Destructors, CXTDropSource Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTDropSource Class

CXTDropSource class is derived from IDropSource. It is used by the shell list control to provide drag-and-drop operations in your application.

Class Hierarchy

class CXTDropSource : public IDropSource;
File

XTDropSource.h

Remarks

CXTDropSource contains methods used in any application used as a data source in a drag-and-drop operation. The data source application in a drag-and-drop operation is responsible for:

  • Determining the data being dragged based on the user's selection.
  • Initiating the drag-and-drop operation based on the user's mouse actions.
  • Generating some of the visual feedback during the drag-and-drop operation, such as setting the cursor and highlighting the data selected for the drag-and-drop operation.
  • Canceling or completing the drag-and-drop operation based on the user's mouse actions.
  • Performing any action on the original data caused by the drop operation, such as deleting the data on a drag move.

CXTDropSource contains the methods for generating visual feedback to the end user and for canceling or completing the drag-and-drop operation. You also need to call the DoDragDrop, RegisterDragDrop, and RevokeDragDrop functions in drag-and-drop operations.

Group

Classes

Legend
Data Member
protected
Method
CXTDropSource Constructors
CXTDropSource Constructors | Description
CXTDropSource | Constructs a CXTDropSource object
CXTDropSource Data Members
CXTDropSource Data Members | Description
m_uiRefCount | Indicates the current reference count.
CXTDropSource Destructors
CXTDropSource Destructors | Description
~CXTDropSource | Destroys a CXTDropSource object, handles clean up and deallocation
CXTDropSource Methods
CXTDropSource Methods | Description
GiveFeedback | Provides visual feedback during drag-and-drop operations.
QueryContinueDrag | Determines if drag-and-drop should continue, stop or signal complete.
QueryInterface | Provides client access to other interfaces.


CXTDropSource Data Members

CXTDropSource Class, Legend, Protected Data Members
CXTDropSource Data Members
Class

CXTDropSource Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_uiRefCount | Indicates the current reference count.


CXTDropSource::m_uiRefCount Data Member

CXTDropSource Data Members, CXTDropSource Class
CXTDropSource::m_uiRefCount Data Member

Indicates the current reference count.

UINT m_uiRefCount;
Group

CXTDropSource Data Members


CXTDropSource Methods

CXTDropSource Class, Legend, Public Methods
CXTDropSource Methods
Class

CXTDropSource Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GiveFeedback | Provides visual feedback during drag-and-drop operations.
QueryContinueDrag | Determines if drag-and-drop should continue, stop or signal complete.
QueryInterface | Provides client access to other interfaces.


CXTDropSource::GiveFeedback Method

CXTDropSource Methods, CXTDropSource Class
CXTDropSource::GiveFeedback Method

Provides visual feedback during drag-and-drop operations.

STDMETHODIMP GiveFeedback(
    DWORD dwEffect
);
Parameters

dwEffect
Effect of a drop operation.

Returns

An HRESULT value.

Remarks

This method enables a source application to give visual feedback to the end user during a drag-and-drop operation by providing the DoDragDrop function with an enumeration value specifying the visual effect. This method supports the standard return values E_INVALIDARG, E_UNEXPECTED, and E_OUTOFMEMORY, as well as the following:

  • S_OK Method completed its task successfully, using the cursor set by the source application.
  • DRAGDROP_S_USEDEFAULTCURSORS Successful completion of the method, and requests OLE to update the cursor using the OLE-provided default cursors.
Group

CXTDropSource Methods


CXTDropSource::QueryContinueDrag Method

CXTDropSource Methods, CXTDropSource Class
CXTDropSource::QueryContinueDrag Method

Determines if drag-and-drop should continue, stop or signal complete.

STDMETHODIMP QueryContinueDrag(
    BOOL bEsc,
    DWORD dwKeyState
);
Parameters

bEsc
Specifies whether the ESC key has been pressed since the previous call to QueryContinueDrag, or to DoDragDrop if this is the first call to QueryContinueDrag. A TRUE value indicates that the end user has pressed the escape key. A FALSE value indicates it has not been pressed.
dwKeyState
Current state of the keyboard modifier keys on the keyboard. Valid values can be a combination of any of the flags MK_CONTROL, MK_SHIFT, MK_ALT, MK_BUTTON, MK_LBUTTON, MK_MBUTTON, and MK_RBUTTON.

Returns

An HRESULT value.

Remarks

This method determines whether a drag-and-drop operation should be continued, canceled, or completed. You do not call this method directly. The OLE DoDragDrop function calls this method during a drag-and-drop operation. This method supports the standard return values E_UNEXPECTED and E_OUTOFMEMORY, as well as the following:

  • S_OK Drag operation should continue. This result occurs if no errors are detected, the mouse button starting the drag-and-drop operation has not been released, and the ESC key has not been detected.
  • DRAGDROP_S_DROP Drop operation should occur completing the drag operation. This result occurs if DWORD indicates that the key that started the drag-and-drop operation has been released.
  • DRAGDROP_S_CANCEL Drag operation should be canceled with no drop operation occurring. This result occurs if BOOL is TRUE, indicating the ESC key has been pressed.
Group

CXTDropSource Methods


CXTDropSource::QueryInterface Method

CXTDropSource Methods, CXTDropSource Class
CXTDropSource::QueryInterface Method

Provides client access to other interfaces.

STDMETHODIMP QueryInterface(
    REFIID riid,
    LPVOID* ppReturn
);
Parameters

riid
Identifier of the interface being requested.
ppReturn
Address of the pointer variable that receives the interface pointer requested in 'riid'. Upon successful return, 'ppReturn' contains the requested interface pointer to the object. If the object does not support the interface specified in 'riid', 'ppReturn' is set to NULL.

Returns

A pointer to an interface if successful, otherwise returns NULL.

Remarks

The QueryInterface method gives a client access to other interfaces on an object. For any one object, a specific query for the IUnknown interface on any of the object's interfaces must always return the same pointer value. This allows a client to determine whether two pointers point to the same component by calling QueryInterface on both and comparing the results. It is specifically not the case that queries for interfaces (even the same interface through the same pointer) must return the same pointer value.

Group

CXTDropSource Methods


CXTDropSource Constructors

CXTDropSource Class, Legend, Public Methods
CXTDropSource Constructors
Class

CXTDropSource Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTDropSource | Constructs a CXTDropSource object


CXTDropSource::CXTDropSource Constructor

CXTDropSource Constructors, CXTDropSource Class
CXTDropSource::CXTDropSource Constructor

Constructs a CXTDropSource object

CXTDropSource();
Group

CXTDropSource Constructors


CXTDropSource Destructors

CXTDropSource Class, Legend, Public Methods
CXTDropSource Destructors
Class

CXTDropSource Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTDropSource | Destroys a CXTDropSource object, handles clean up and deallocation


CXTDropSource::~CXTDropSource Destructor

CXTDropSource Destructors, CXTDropSource Class
CXTDropSource::~CXTDropSource Destructor

Destroys a CXTDropSource object, handles clean up and deallocation

~CXTDropSource();
Group

CXTDropSource Destructors


CXTEdit Class

XTFlatComboBox.h, Classes, Legend, Members, Topics, CXTEdit Data Members, CXTEdit Methods, CXTEdit Constructors, CXTEdit Destructors, CXTEdit Constructors, CXTEdit Data Members, CXTEdit Destructors, CXTEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEdit Class

CXTEdit is a CEdit derived class. The CXTEdit class provides the functionality of a Windows edit control. An edit control is a rectangular child window in which the user can enter text.

Class Hierarchy

class CXTEdit : public CEdit;
File

XTFlatComboBox.h

Remarks

You can create an edit control either from a dialog template or directly in your code. In both cases, first call the constructor CXTEdit to construct the CXTEdit object, then call the Create member function to create the Windows edit control and attach it to the CXTEdit object.

Construction can be a one-step process in a class derived from CXTEdit. Write a constructor for the derived class and call Create from within the constructor.

CXTEdit inherits significant functionality from CWnd. To set and retrieve text from a CXTEdit object, use the CWnd member functions SetWindowText and GetWindowText, which either set or get the entire contents of an edit control even if it is a multiline control. Also, if an edit control is multiline, get and set part of the control's text by calling the CXTEdit member functions GetLine, SetSel, GetSel, and ReplaceSel.

If you want to handle Windows notification messages sent by an edit control to its parent (usually a class derived from CDialog), add a message-map entry and message-handler member function to the parent class for each message.

Each message-map entry takes the following form:

ON_Notification(id, memberFxn)

where 'id' specifies the child window ID of the edit control sending the notification, and 'memberFxn' is the name of the parent member function you have written to handle the notification.

The parent's function prototype is as follows:

afx_msg void memberFxn();

Following is a list of potential message-map entries and a description of the cases in which they would be sent to the parent:

  • ON_EN_CHANGE The user has taken an action that may have altered text in an edit control. Unlike the EN_UPDATE notification message, this notification message is sent after Windows updates the display.
  • ON_EN_ERRSPACE The edit control cannot allocate enough memory to meet a specific request.
  • ON_EN_HSCROLL The user clicks an edit control's horizontal scroll bar. The parent window is notified before the screen is updated.
  • ON_EN_KILLFOCUS The edit control loses the input focus.
  • ON_EN_MAXTEXT The current insertion has exceeded the specified number of characters for the edit control and has been truncated. Also sent when an edit control does not have the ES_AUTOHSCROLL style and the number of characters to be inserted would exceed the width of the edit control. Also sent when an edit control does not have the ES_AUTOVSCROLL style and the total number of lines resulting from a text insertion would exceed the height of the edit control.
  • ON_EN_SETFOCUS Sent when an edit control receives the input focus.
  • ON_EN_UPDATE The edit control is about to display altered text. Sent after the control has formatted the text but before it screens the text so that the window size can be altered, if necessary.
  • ON_EN_VSCROLL The user clicks an edit control's vertical scroll bar. The parent window is notified before the screen is updated.

If you create a CXTEdit object within a dialog box, the CXTEdit object is automatically destroyed when the user closes the dialog box.

If you create a CXTEdit object from a dialog resource using the dialog editor, the CXTEdit object is automatically destroyed when the user closes the dialog box.

If you create a CXTEdit object within a window, you may also need to destroy it. If you create the CXTEdit object on the stack, it is destroyed automatically. If you create the CXTEdit object on the heap by using the new function, you must call delete on the object to destroy it when the user terminates the Windows edit control. If you allocate any memory in the CXTEdit object, override the CXTEdit destructor to dispose of the allocations.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTEdit Constructors
CXTEdit Constructors | Description
CXTEdit | Constructs a CXTEdit object
CXTEdit Data Members
CXTEdit Data Members | Description
m_pParentWnd | Pointer to the parent of the edit control.
CXTEdit Destructors
CXTEdit Destructors | Description
~CXTEdit | Destroys a CXTEdit object, handles clean up and deallocation
CXTEdit Methods
CXTEdit Methods | Description
CanPaste | Determines if the clipboard contains valid information.
Initialize | Initializes the CXTEdit control.
SelectionMade | Call this member function to determine if a selection has been made.


CXTEdit Data Members

CXTEdit Class, Legend, Protected Data Members
CXTEdit Data Members
Class

CXTEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pParentWnd | Pointer to the parent of the edit control.


CXTEdit::m_pParentWnd Data Member

CXTEdit Data Members, CXTEdit Class
CXTEdit::m_pParentWnd Data Member

Pointer to the parent of the edit control.

CWnd* m_pParentWnd;
Group

CXTEdit Data Members


CXTEdit Methods

CXTEdit Class, Legend, Public Methods
CXTEdit Methods
Class

CXTEdit Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
CanPaste | Determines if the clipboard contains valid information.
Initialize | Initializes the CXTEdit control.
SelectionMade | Call this member function to determine if a selection has been made.


CXTEdit::CanPaste Method

CXTEdit Methods, CXTEdit Class
CXTEdit::CanPaste Method

Determines if the clipboard contains valid information.

virtual BOOL CanPaste();
Returns

TRUE if the Clipboard contains data in a format which this edit view can accept, otherwise it returns FALSE.

Remarks

Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.

Group

CXTEdit Methods


CXTEdit::Initialize Method

CXTEdit Methods, CXTEdit Class
CXTEdit::Initialize Method

Initializes the CXTEdit control.

virtual bool Initialize(
    CWnd* pParentWnd
);
Parameters

pParentWnd
Pointer to the parent of the edit control.

Returns

True if the control was successfully initialized, otherwise false.

Remarks

Call this member function to initialize edit control. You should always call this after you have created or subclassed your edit control.

Group

CXTEdit Methods


CXTEdit::SelectionMade Method

CXTEdit Methods, CXTEdit Class
CXTEdit::SelectionMade Method

Call this member function to determine if a selection has been made.

virtual BOOL SelectionMade();
Returns

TRUE if a selection has been made, otherwise returns FALSE.

Group

CXTEdit Methods


CXTEdit Constructors

CXTEdit Class, Legend, Public Methods
CXTEdit Constructors
Class

CXTEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTEdit | Constructs a CXTEdit object


CXTEdit::CXTEdit Constructor

CXTEdit Constructors, CXTEdit Class
CXTEdit::CXTEdit Constructor

Constructs a CXTEdit object

CXTEdit();
Group

CXTEdit Constructors


CXTEdit Destructors

CXTEdit Class, Legend, Public Methods
CXTEdit Destructors
Class

CXTEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTEdit | Destroys a CXTEdit object, handles clean up and deallocation


CXTEdit::~CXTEdit Destructor

CXTEdit Destructors, CXTEdit Class
CXTEdit::~CXTEdit Destructor

Destroys a CXTEdit object, handles clean up and deallocation

virtual ~CXTEdit();
Group

CXTEdit Destructors


CXTEditListBox Class

XTEditListBox.h, Classes, Legend, Members, Topics, CXTEditListBox Data Members, CXTEditListBox Methods, CXTEditListBox Constructors, CXTEditListBox Destructors, CXTEditListBox Constructors, CXTEditListBox Data Members, CXTEditListBox Destructors, CXTEditListBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBox Class

CXTEditListBox is a CXTListBox derived class. It is used to create an editable list box. This list box can be configured to display a toolbar for editing. You can define browse styles to search for files or folders. Each entry is made editable with a double mouse click.

Class Hierarchy

class CXTEditListBox : public CXTListBox;
File

XTEditListBox.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTEditListBox Constructors
CXTEditListBox Constructors | Description
CXTEditListBox | Constructs a CXTEditListBox object
CXTEditListBox Data Members
CXTEditListBox Data Members | Description
m_bEnableEdit | True if editing is enabled.
m_bNewItem | TRUE if a new item is being entered into the list box.
m_dwLStyle | List edit styles.
m_editGroup | The edit group (toolbar) that appears above the list box.
m_nIndex | Current index when edit functions are performed.
m_pItemEdit | Points to the in-place edit item.
m_pParentWnd | Pointer to the parent window.
m_strFilter | Default file filter.
m_strInitialDir | Initial Dir.
m_strItemDefaultText | Default text used when new items are created.
m_strItemText | Current text of a selected item during edit.
m_strTitle | Caption area title.
CXTEditListBox Destructors
CXTEditListBox Destructors | Description
~CXTEditListBox | Destroys a CXTEditListBox object, handles cleanup and deallocation
CXTEditListBox Methods
CXTEditListBox Methods | Description
CreateEditControl | This method is called to create in-place Edit control
CreateEditGroup | This member function will create the edit group control.
DeleteItem | Deletes currently selected item
EditItem | This member function will enable editing for the list box item.
EditListItem | Enables editing for the currently selected item.
EnableEdit | This member function will enable or disable editing.
GetCurrentIndex | Retrieves the current item index.
GetEditGroup | Returns a pointer to the CXTEditListBoxToolBar toolbar.
GetEditItemText | Retrieves the edited item's text label.
HasToolbar | Call this member function to determine if the edit list has a toolbar.
Initialize | Initializes the CXTEditListBox control.
MoveItemDown | Moves item down
MoveItemUp | Moves item up
RecalcLayout | Recalculates the toolbar layout for the CXTEditListBox.
SetDlgFilter | Call this member function to set the default filter for the file dialog.
SetDlgInitialDir | This member function sets the initial directory for the file dialog.
SetEditText | This method is called to set inplace edit text
SetListEditStyle |
SetNewItemDefaultText | Sets the default text for new items.


CXTEditListBox Data Members

CXTEditListBox Class, Legend, Protected Data Members
CXTEditListBox Data Members
Class

CXTEditListBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bEnableEdit | True if editing is enabled.
m_bNewItem | TRUE if a new item is being entered into the list box.
m_dwLStyle | List edit styles.
m_editGroup | The edit group (toolbar) that appears above the list box.
m_nIndex | Current index when edit functions are performed.
m_pItemEdit | Points to the in-place edit item.
m_pParentWnd | Pointer to the parent window.
m_strFilter | Default file filter.
m_strInitialDir | Initial Dir.
m_strItemDefaultText | Default text used when new items are created.
m_strItemText | Current text of a selected item during edit.
m_strTitle | Caption area title.


CXTEditListBox::m_bEnableEdit Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_bEnableEdit Data Member

True if editing is enabled.

bool m_bEnableEdit;
Group

CXTEditListBox Data Members


CXTEditListBox::m_bNewItem Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_bNewItem Data Member

TRUE if a new item is being entered into the list box.

BOOL m_bNewItem;
Group

CXTEditListBox Data Members


CXTEditListBox::m_dwLStyle Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_dwLStyle Data Member

List edit styles.

DWORD m_dwLStyle;
Group

CXTEditListBox Data Members


CXTEditListBox::m_editGroup Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_editGroup Data Member

The edit group (toolbar) that appears above the list box.

CXTEditListBoxToolBar m_editGroup;
Group

CXTEditListBox Data Members


CXTEditListBox::m_nIndex Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_nIndex Data Member

Current index when edit functions are performed.

int m_nIndex;
Group

CXTEditListBox Data Members


CXTEditListBox::m_pItemEdit Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_pItemEdit Data Member

Points to the in-place edit item.

CXTItemEdit* m_pItemEdit;
Group

CXTEditListBox Data Members


CXTEditListBox::m_pParentWnd Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_pParentWnd Data Member

Pointer to the parent window.

CWnd* m_pParentWnd;
Group

CXTEditListBox Data Members


CXTEditListBox::m_strFilter Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_strFilter Data Member

Default file filter.

CString m_strFilter;
Group

CXTEditListBox Data Members


CXTEditListBox::m_strInitialDir Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_strInitialDir Data Member

Initial Dir.

CString m_strInitialDir;
Group

CXTEditListBox Data Members


CXTEditListBox::m_strItemDefaultText Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_strItemDefaultText Data Member

Default text used when new items are created.

CString m_strItemDefaultText;
Group

CXTEditListBox Data Members


CXTEditListBox::m_strItemText Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_strItemText Data Member

Current text of a selected item during edit.

CString m_strItemText;
Group

CXTEditListBox Data Members


CXTEditListBox::m_strTitle Data Member

CXTEditListBox Data Members, CXTEditListBox Class
CXTEditListBox::m_strTitle Data Member

Caption area title.

CString m_strTitle;
Group

CXTEditListBox Data Members


CXTEditListBox Methods

CXTEditListBox Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBox Methods
Class

CXTEditListBox Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CreateEditControl | This method is called to create in-place Edit control
CreateEditGroup | This member function will create the edit group control.
DeleteItem | Deletes currently selected item
EditListItem | Enables editing for the currently selected item.
Public Methods
Public Methods
Public Method | Description
EditItem | This member function will enable editing for the list box item.
EnableEdit | This member function will enable or disable editing.
GetCurrentIndex | Retrieves the current item index.
GetEditGroup | Returns a pointer to the CXTEditListBoxToolBar toolbar.
GetEditItemText | Retrieves the edited item's text label.
HasToolbar | Call this member function to determine if the edit list has a toolbar.
Initialize | Initializes the CXTEditListBox control.
MoveItemDown | Moves item down
MoveItemUp | Moves item up
RecalcLayout | Recalculates the toolbar layout for the CXTEditListBox.
SetDlgFilter | Call this member function to set the default filter for the file dialog.
SetDlgInitialDir | This member function sets the initial directory for the file dialog.
SetEditText | This method is called to set inplace edit text
SetListEditStyle |
SetNewItemDefaultText | Sets the default text for new items.


CXTEditListBox::CreateEditControl Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::CreateEditControl Method

This method is called to create in-place Edit control

virtual CXTItemEdit* CreateEditControl(
    CRect rcItem
);
Parameters

rcItem
Bounding rectangle of edit control.

Group

CXTEditListBox Methods


CXTEditListBox::CreateEditGroup Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::CreateEditGroup Method

This member function will create the edit group control.

virtual BOOL CreateEditGroup(
    bool bAutoFont = true
);
Parameters

bAutoFont
True to enable automatic font initialization.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTEditListBox Methods


CXTEditListBox::DeleteItem Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::DeleteItem Method

Deletes currently selected item

virtual void DeleteItem();
Group

CXTEditListBox Methods


CXTEditListBox::EditItem Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::EditItem Method

This member function will enable editing for the list box item.

void EditItem(
    int iItem
);
Parameters

iItem
Index of the item to edit.

Group

CXTEditListBox Methods


CXTEditListBox::EditListItem Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::EditListItem Method

Enables editing for the currently selected item.

virtual void EditListItem(
    BOOL bNewItem
);
Parameters

bNewItem
TRUE to add a new item.

Remarks

This member function will enable editing for the currently selected list box item. If 'bNewItem' is TRUE, a new item is added to the end of the list box.

Group

CXTEditListBox Methods


CXTEditListBox::EnableEdit Method

CXTEditListBox Methods, CXTEditListBox Class, Body Source
CXTEditListBox::EnableEdit Method

This member function will enable or disable editing.

void EnableEdit(
    bool bEnable
);
Parameters

bEnable
True to enable editing.

Body Source
void CXTEditListBox::EnableEdit(bool bEnable) {
    m_bEnableEdit = bEnable; m_editGroup.EnableEdit(bEnable);
}
Group

CXTEditListBox Methods


CXTEditListBox::GetCurrentIndex Method

CXTEditListBox Methods, CXTEditListBox Class, Body Source
CXTEditListBox::GetCurrentIndex Method

Retrieves the current item index.

int GetCurrentIndex();
Returns

An integer value that represents the edit control index.

Remarks

Call this member function to get the current index for the edit control. Similar to GetCurSel; however, the current index is the index of the last item to be modified or added to the edit list box and not necessarily the selected item.

Body Source
int CXTEditListBox::GetCurrentIndex() {
    return m_nIndex;
}
Group

CXTEditListBox Methods


CXTEditListBox::GetEditGroup Method

CXTEditListBox Methods, CXTEditListBox Class, Body Source
CXTEditListBox::GetEditGroup Method

Returns a pointer to the CXTEditListBoxToolBar toolbar.

CXTEditListBoxToolBar& GetEditGroup();
Returns

A reference to a CXTEditListBoxToolBar object.

Remarks

Call this member function to return a reference to the CXTEditListBoxToolBar control that is associated with the edit list box.

Body Source
CXTEditListBoxToolBar& CXTEditListBox::GetEditGroup() {
    return m_editGroup;
}
Group

CXTEditListBox Methods


CXTEditListBox::GetEditItemText Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::GetEditItemText Method

Retrieves the edited item's text label.

virtual void GetEditItemText();
Remarks

This member function is called to retrieve the text for the item that is being edited in the list box and save the value to m_strItemText.

Group

CXTEditListBox Methods


CXTEditListBox::HasToolbar Method

CXTEditListBox Methods, CXTEditListBox Class, Body Source
CXTEditListBox::HasToolbar Method

Call this member function to determine if the edit list has a toolbar.

bool HasToolbar();
Returns

true if the toolbar is turned on, otherwise returns false.

Body Source
bool CXTEditListBox::HasToolbar() {
    return ((m_dwLStyle & LBS_XT_NOTOOLBAR) == 0);
}
Group

CXTEditListBox Methods


CXTEditListBox::Initialize Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::Initialize Method

Initializes the CXTEditListBox control.

virtual void Initialize(
    bool bAutoFont = true
);
Parameters

bAutoFont
True to enable automatic font initialization.

Remarks

Call this member function to initialize the list box. This method should be called directly after creating or sub-classing the control.

Group

CXTEditListBox Methods


CXTEditListBox::MoveItemDown Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::MoveItemDown Method

Moves item down

virtual void MoveItemDown(
    int nIndex
);
Parameters

nIndex
Item index to move

Group

CXTEditListBox Methods


CXTEditListBox::MoveItemUp Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::MoveItemUp Method

Moves item up

virtual void MoveItemUp(
    int nIndex
);
Parameters

nIndex
Item index to move

Group

CXTEditListBox Methods


CXTEditListBox::RecalcLayout Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::RecalcLayout Method

Recalculates the toolbar layout for the CXTEditListBox.

virtual void RecalcLayout();
Remarks

Call this member function to correctly reposition the edit list box toolbar. This will readjust the layout to correctly and position the toolbar in relation to the list.

Group

CXTEditListBox Methods


CXTEditListBox::SetDlgFilter Method

CXTEditListBox Methods, CXTEditListBox Class, Body Source
CXTEditListBox::SetDlgFilter Method

Call this member function to set the default filter for the file dialog.

void SetDlgFilter(
    LPCTSTR lpszFilter = NULL
);
Parameters

lpszFilter
Points to a NULL terminated string that represents the file filter used by the file open dialog.

Body Source
void CXTEditListBox::SetDlgFilter(LPCTSTR lpszFilter/*=NULL*/) {
    m_strFilter = lpszFilter;
}
Group

CXTEditListBox Methods


CXTEditListBox::SetDlgInitialDir Method

CXTEditListBox Methods, CXTEditListBox Class, Body Source
CXTEditListBox::SetDlgInitialDir Method

This member function sets the initial directory for the file dialog.

void SetDlgInitialDir(
    LPCTSTR lpszInitialDir
);
Parameters

lpszInitialDir
[in] Points to a NULL terminated string the represents the initial directory of the file open dialog..

Body Source
void CXTEditListBox::SetDlgInitialDir(LPCTSTR lpszInitialDir/*=NULL*/) {
    m_strInitialDir = lpszInitialDir;
}
Group

CXTEditListBox Methods


CXTEditListBox::SetEditText Method

CXTEditListBox Methods, CXTEditListBox Class
CXTEditListBox::SetEditText Method

This method is called to set inplace edit text

void SetEditText(
    LPCTSTR pcszText
);
Parameters

pcszText
next text to set

Group

CXTEditListBox Methods


SetListEditStyle Method

CXTEditListBox Methods
SetListEditStyle Method
Overload List
Methods
Method | Description
CXTEditListBox::SetListEditStyle (LPCTSTR, DWORD) | Sets the edit style for the edit list box.
CXTEditListBox::SetListEditStyle (UINT, DWORD) | Sets the edit style for the edit list box.
Group

CXTEditListBox Methods


CXTEditListBox::SetListEditStyle Method (UINT, DWORD)

SetListEditStyle Method, CXTEditListBox Class
CXTEditListBox::SetListEditStyle Method (UINT, DWORD)

Sets the edit style for the edit list box.

void SetListEditStyle(
    UINT nTitle,
    DWORD dwLStyle = LBS_XT_DEFAULT
);
void SetListEditStyle(
    LPCTSTR lpszTitle,
    DWORD dwLStyle = LBS_XT_DEFAULT
);
Parameters

nTitle
Resource ID of the string to load for the caption title.
dwLStyle
Style for the list edit control. Pass in LBS_XT_NOTOOLBAR if you do not wish the caption edit navigation control bar to be displayed.
lpszTitle
NULL terminated string that represents the caption title.

Remarks

Call this member function to set the style and title for the edit list box. The style of the edit list box can be set to one or more of the following values:

  • LBS_XT_DEFAULT Standard edit field.
  • LBS_XT_CHOOSEDIR Choose directory browse edit field.
  • LBS_XT_CHOOSEFILE Choose file browse edit field.
  • LBS_XT_NOTOOLBAR Do not display edit toolbar.
Group

SetListEditStyle Method


CXTEditListBox::SetNewItemDefaultText Method

CXTEditListBox Methods, CXTEditListBox Class, Body Source
CXTEditListBox::SetNewItemDefaultText Method

Sets the default text for new items.

void SetNewItemDefaultText(
    LPCTSTR lpszItemDefaultText
);
Parameters

lpszItemDefaultText
NULL terminated string.

Remarks

Call this member function to set the default text that is displayed when a new item is added to the edit list box.

Body Source
void CXTEditListBox::SetNewItemDefaultText(LPCTSTR lpszItemDefaultText) {
    m_strItemDefaultText = lpszItemDefaultText;
}
Group

CXTEditListBox Methods


CXTEditListBox Constructors

CXTEditListBox Class, Legend, Public Methods
CXTEditListBox Constructors
Class

CXTEditListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTEditListBox | Constructs a CXTEditListBox object


CXTEditListBox::CXTEditListBox Constructor

CXTEditListBox Constructors, CXTEditListBox Class
CXTEditListBox::CXTEditListBox Constructor

Constructs a CXTEditListBox object

CXTEditListBox();
Group

CXTEditListBox Constructors


CXTEditListBox Destructors

CXTEditListBox Class, Legend, Public Methods
CXTEditListBox Destructors
Class

CXTEditListBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTEditListBox | Destroys a CXTEditListBox object, handles cleanup and deallocation


CXTEditListBox::~CXTEditListBox Destructor

CXTEditListBox Destructors, CXTEditListBox Class
CXTEditListBox::~CXTEditListBox Destructor

Destroys a CXTEditListBox object, handles cleanup and deallocation

virtual ~CXTEditListBox();
Group

CXTEditListBox Destructors


CXTEditListBoxToolBar Class

XTEditListBox.h, Classes, Legend, Members, Topics, CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Constructors, CXTEditListBoxToolBar Destructors, CXTEditListBoxToolBar Constructors, CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Destructors, CXTEditListBoxToolBar Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar Class

CXTEditListBoxToolBar is a CStatic derived class. It used by the CXTEditListBox class to create a toolbar above the edit list box to display icons for editing.

Class Hierarchy

class CXTEditListBoxToolBar : public CStatic;
File

XTEditListBox.h

Remarks

CXTEditListBoxToolBar can be used for other classes by setting the notify window in Initialize. This window will receive notification messages whenever the new, delete, up, and down buttons are pressed. You can handle these messages by adding an ON_BN_CLICKED handler for each of the buttons XT_IDC_BTN_NEW, XT_IDC_BTN_DELETE, XT_IDC_BTN_UP and XT_IDC_BTN_DOWN.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTEditListBoxToolBar Constructors
CXTEditListBoxToolBar Constructors | Description
CXTEditListBoxToolBar | Constructs a CXTEditListBoxToolBar object
CXTEditListBoxToolBar Data Members
CXTEditListBoxToolBar Data Members | Description
m_arButton | Array of toolbar buttons.
m_arClipRect | Array of toolbar button sizes.
m_arIcon | Array of toolbar button icons.
m_bEnableEdit | True if editing is enabled.
m_bShowNewDeleteButtons | Controls whether of not the up.down buttons are shown.
m_bShowUpDownButtons | Controls whether of not the up.down buttons are shown.
m_tooltip | Tooltip control for edit buttons.
CXTEditListBoxToolBar Destructors
CXTEditListBoxToolBar Destructors | Description
~CXTEditListBoxToolBar | Destroys a CXTEditListBoxToolBar object, handles cleanup and deallocation
CXTEditListBoxToolBar Methods
CXTEditListBoxToolBar Methods | Description
DrawText | This member function is called by the CXTEditListBoxToolBar object to render text display for the control.
EnableEdit | This member function will enable or disable editing.
GetDeleteButton | This member function returns a reference to the delete button of the edit group.
GetDownButton | This member function returns a reference to the down button of the edit group.
GetNewButton | This member function returns a reference to the new button of the edit group.
GetUpButton | This member function returns a reference to the up button of the edit group.
Initialize | Initializes the CXTEditListBoxToolBar control.
MoveButtons | Recalculates the button layout within the CXTEditListBoxToolBar window.
SendCommand | Sends notification to the owner window.
SetXButtonStyle | This member function will set the display style for the toolbar buttons.


CXTEditListBoxToolBar Data Members

CXTEditListBoxToolBar Class, Legend, Protected Data Members
CXTEditListBoxToolBar Data Members
Class

CXTEditListBoxToolBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arButton | Array of toolbar buttons.
m_arClipRect | Array of toolbar button sizes.
m_arIcon | Array of toolbar button icons.
m_bEnableEdit | True if editing is enabled.
m_bShowNewDeleteButtons | Controls whether of not the up.down buttons are shown.
m_bShowUpDownButtons | Controls whether of not the up.down buttons are shown.
m_tooltip | Tooltip control for edit buttons.


CXTEditListBoxToolBar::m_arButton Data Member

CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::m_arButton Data Member

Array of toolbar buttons.

CXTButton m_arButton[4];
Group

CXTEditListBoxToolBar Data Members


CXTEditListBoxToolBar::m_arClipRect Data Member

CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::m_arClipRect Data Member

Array of toolbar button sizes.

CRect m_arClipRect[4];
Group

CXTEditListBoxToolBar Data Members


CXTEditListBoxToolBar::m_arIcon Data Member

CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::m_arIcon Data Member

Array of toolbar button icons.

CXTIconHandle m_arIcon[4];
Group

CXTEditListBoxToolBar Data Members


CXTEditListBoxToolBar::m_bEnableEdit Data Member

CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::m_bEnableEdit Data Member

True if editing is enabled.

bool m_bEnableEdit;
Group

CXTEditListBoxToolBar Data Members


CXTEditListBoxToolBar::m_bShowNewDeleteButtons Data Member

CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::m_bShowNewDeleteButtons Data Member

Controls whether of not the up.down buttons are shown.

bool m_bShowNewDeleteButtons;
Group

CXTEditListBoxToolBar Data Members


CXTEditListBoxToolBar::m_bShowUpDownButtons Data Member

CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::m_bShowUpDownButtons Data Member

Controls whether of not the up.down buttons are shown.

bool m_bShowUpDownButtons;
Group

CXTEditListBoxToolBar Data Members


CXTEditListBoxToolBar::m_tooltip Data Member

CXTEditListBoxToolBar Data Members, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::m_tooltip Data Member

Tooltip control for edit buttons.

CToolTipCtrl m_tooltip;
Group

CXTEditListBoxToolBar Data Members


CXTEditListBoxToolBar Methods

CXTEditListBoxToolBar Class, Legend, Public Methods
CXTEditListBoxToolBar Methods
Class

CXTEditListBoxToolBar Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawText | This member function is called by the CXTEditListBoxToolBar object to render text display for the control.
EnableEdit | This member function will enable or disable editing.
GetDeleteButton | This member function returns a reference to the delete button of the edit group.
GetDownButton | This member function returns a reference to the down button of the edit group.
GetNewButton | This member function returns a reference to the new button of the edit group.
GetUpButton | This member function returns a reference to the up button of the edit group.
Initialize | Initializes the CXTEditListBoxToolBar control.
MoveButtons | Recalculates the button layout within the CXTEditListBoxToolBar window.
SendCommand | Sends notification to the owner window.
SetXButtonStyle | This member function will set the display style for the toolbar buttons.


CXTEditListBoxToolBar::DrawText Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class
CXTEditListBoxToolBar::DrawText Method

This member function is called by the CXTEditListBoxToolBar object to render text display for the control.

virtual void DrawText(
    CDC* pDC,
    CRect& rcClient
);
Parameters

pDC
Pointer to a valid device context.
rcClient
Area to draw text on.

Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::EnableEdit Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::EnableEdit Method

This member function will enable or disable editing.

void EnableEdit(
    bool bEnable
);
Parameters

bEnable
True to enable editing.

Body Source
void CXTEditListBoxToolBar::EnableEdit(bool bEnable) {
    m_bEnableEdit = bEnable;
}
Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::GetDeleteButton Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::GetDeleteButton Method

This member function returns a reference to the delete button of the edit group.

CXTButton& GetDeleteButton();
Returns

A reference to a CXTButton object.

Body Source
CXTButton& CXTEditListBoxToolBar::GetDeleteButton() {
    return m_arButton[1];
}
Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::GetDownButton Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::GetDownButton Method

This member function returns a reference to the down button of the edit group.

CXTButton& GetDownButton();
Returns

A reference to a CXTButton object.

Body Source
CXTButton& CXTEditListBoxToolBar::GetDownButton() {
    return m_arButton[3];
}
Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::GetNewButton Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::GetNewButton Method

This member function returns a reference to the new button of the edit group.

CXTButton& GetNewButton();
Returns

A reference to a CXTButton object.

Body Source
CXTButton& CXTEditListBoxToolBar::GetNewButton() {
    return m_arButton[0];
}
Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::GetUpButton Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::GetUpButton Method

This member function returns a reference to the up button of the edit group.

CXTButton& GetUpButton();
Returns

A reference to a CXTButton object.

Body Source
CXTButton& CXTEditListBoxToolBar::GetUpButton() {
    return m_arButton[2];
}
Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::Initialize Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class
CXTEditListBoxToolBar::Initialize Method

Initializes the CXTEditListBoxToolBar control.

virtual void Initialize(
    bool bAutoFont = true
);
Parameters

bAutoFont
True to enable automatic font initialization.

Remarks

Call this member function to initialize the edit group control. This method should be called directly after creating or sub-classing the control.

Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::MoveButtons Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class
CXTEditListBoxToolBar::MoveButtons Method

Recalculates the button layout within the CXTEditListBoxToolBar window.

virtual void MoveButtons();
Remarks

This member function is called by the CXTEditListBoxToolBar object to position the group bar buttons when the window is sized.

Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::SendCommand Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class
CXTEditListBoxToolBar::SendCommand Method

Sends notification to the owner window.

virtual void SendCommand(
    UINT nCmdID
);
Parameters

nCmdID
Command ID to send.

Remarks

This member function sends the command specified by nCmdID to the owner of the CXTEditListBoxToolBar object. The command is sent whenever a button is pressed on the group bar.

Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar::SetXButtonStyle Method

CXTEditListBoxToolBar Methods, CXTEditListBoxToolBar Class
CXTEditListBoxToolBar::SetXButtonStyle Method

This member function will set the display style for the toolbar buttons.

virtual void SetXButtonStyle(
    DWORD dwxStyle,
    BOOL bRedraw = TRUE
);
Parameters

dwxStyle
Specifies the button style as defined in the Remarks section.
bRedraw
Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.

Returns

The previous style that was set.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • BS_XT_FLAT Draws a flat button.
  • BS_XT_SEMIFLAT Draws a semi-flat button.
  • BS_XT_TWOROWS Draws images and text that are centered.
  • BS_XT_SHOWFOCUS Draws a focus rect when the button has input focus.
  • BS_XT_HILITEPRESSED Highlights the button when pressed.
  • BS_XT_XPFLAT Draws a flat button ala Office XP.
  • BS_XT_WINXP_COMPAT Enables Windows XP themes if available.
Group

CXTEditListBoxToolBar Methods


CXTEditListBoxToolBar Constructors

CXTEditListBoxToolBar Class, Legend, Public Methods
CXTEditListBoxToolBar Constructors
Class

CXTEditListBoxToolBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTEditListBoxToolBar | Constructs a CXTEditListBoxToolBar object


CXTEditListBoxToolBar::CXTEditListBoxToolBar Constructor

CXTEditListBoxToolBar Constructors, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::CXTEditListBoxToolBar Constructor

Constructs a CXTEditListBoxToolBar object

CXTEditListBoxToolBar();
Group

CXTEditListBoxToolBar Constructors


CXTEditListBoxToolBar Destructors

CXTEditListBoxToolBar Class, Legend, Public Methods
CXTEditListBoxToolBar Destructors
Class

CXTEditListBoxToolBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTEditListBoxToolBar | Destroys a CXTEditListBoxToolBar object, handles cleanup and deallocation


CXTEditListBoxToolBar::~CXTEditListBoxToolBar Destructor

CXTEditListBoxToolBar Destructors, CXTEditListBoxToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTEditListBoxToolBar::~CXTEditListBoxToolBar Destructor

Destroys a CXTEditListBoxToolBar object, handles cleanup and deallocation

virtual ~CXTEditListBoxToolBar();
Group

CXTEditListBoxToolBar Destructors


CXTExcelTabCtrl Class

XTExcelTabCtrl.h, Classes, Legend, Members, Topics, CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Methods, CXTExcelTabCtrl Constructors, CXTExcelTabCtrl Destructors, CXTExcelTabCtrl Constructors, CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Destructors, CXTExcelTabCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrl Class

CXTExcelTabCtrl is a CWnd derived class. It is used to create an Excel style sheet control. This control allows you to define if you want the control to have home, end, back, and next buttons.

Class Hierarchy

class CXTExcelTabCtrl : public CWnd;
File

XTExcelTabCtrl.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTExcelTabCtrl Constructors
CXTExcelTabCtrl Constructors | Description
CXTExcelTabCtrl | Constructs a CXTExcelTabCtrl object
CXTExcelTabCtrl Data Members
CXTExcelTabCtrl Data Members | Description
m_bManagingViews | true if the control is managing views.
m_bPainted | Set to TRUE to indicate that a button has been painted.
m_bTracking | Tracking state.
m_bUserColors | true if user defined colors are used.
m_buttons | Array of button information.
m_cx | Width for each arrow button.
m_cy | Height for each arrow button.
m_dwStyle | Tab control style.
m_iBtnEnd | Index of "end" button in button array.
m_iBtnHilight | Index of the button that has the mouse hovering over it.
m_iBtnHome | Index of "home" button in button array.
m_iBtnLeft | Index of "left" button in button array.
m_iBtnRight | Index of "right" button in button array.
m_iGripperPosPerCent | The current gripper position in percent of the control width.
m_nClientHeight | Height in pixels of the tab control client area.
m_nClientWidth | Width in pixels of the tab control client area.
m_nCurSel | Index of the currently selected tab.
m_nOffset | Amount in pixels of the displayed tab offset.
m_pBoldFont | Font that is used for selected tabs.
m_pNormFont | Font that is used for non-selected tabs.
m_pWndLastFocus | Last focused window.
m_rectGripper | Area occupied by the sizing gripper.
m_rectSB_H | Area occupied by the horizontal scroll bar.
m_rectTabs | Area occupied by tabs.
m_rectViews | Area occupied by managed views.
m_tcbItems | Template list containing tab information.
m_ToolTip | Tooltip for the flat tab control.
m_wndHScrollBar | The horizontal scroll bar (used with FTS_XT_HSCROLL).
m_xGripperPos | The current gripper position in pixels from the left.
m_xTrackingDelta | Tracking delta.
CXTExcelTabCtrl Destructors
CXTExcelTabCtrl Destructors | Description
~CXTExcelTabCtrl | Destroys a CXTExcelTabCtrl object, handles cleanup and deallocation
CXTExcelTabCtrl Methods
CXTExcelTabCtrl Methods | Description
_DeleteItem | This internal function deletes an item from the tab item list.
ButtonHitTest | Call this function to determine which button, if any, is at the specified screen position.
ClearAllItems | This member function frees all memory occupied by the tab items.
Create | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
CreateButtonIcons | This member function will create the icon resources that are used by the arrow buttons.
DeleteAllItems | This member function will remove all of the tabs from the tab control.
DeleteItem | This member function will delete the tab specified by 'nItem' from the tab control.
DrawGripper | This member function will draw the horizontal sizing gripper at a specified location.
EnableButtons | This member function will enable or disable the arrow buttons depending on the current tab display state.
FreeButtonIcons | This member function will free the resources allocated for the icons used by the arrow buttons.
GetCurSel | Call this function to retrieve the currently selected tab in a flat tab control.
GetGripperPosition | This member function gets the location of the sizing gripper in pixels relative to the left hand side of the control.
GetItemCount | Call this function to retrieve the number of tabs in the tab control.
GetItemRect | This member function will retrieve the size of the tab specified by 'nItem'.
GetItemText | This member function gets the text of a specific tab.
GetItemWindow | This member function gets a CWnd pointer to the window that is associated with a specific tab.
GetOverlap | This internal function calculates the overlap between two tabs.
GetScrollBarCtrl | This method obtains a pointer to the specified sibling scroll bar for the flat tab control.
GetSelTabBackColor |
GetSelTabTextColor |
GetTabBackColor |
GetTabFont | Retrieves the tab font.
GetTabHilightColor | This member function gets an RGB value that represents the highlight color of the tab.
GetTabItemArray | Call this member function to retrieve a reference to the tab item array.
GetTabShadowColor | This member function gets an RGB value that represents the shadow color of the tab.
GetTabsRect | Retrieves the area occupied by the tabs.
GetTabStyle | Retrieves the FTS_XT_ styles that are currently in use for the flat tab control.
GetTabTextColor |
GetTabWidth | This member function will get the width in pixels of the tab specified by 'nItem'.
GetTipText | This member function will get the tooltip text associated with the tab specified by 'nItem'.
GetTotalArrowWidth | This member function will return the total width of all the arrow buttons that are visible in the flat tab control.
GetTotalButtonRect | Call this member function to get the dimensions of the rectangle that encompasses all of the buttons.
GetTotalTabAreaWidth | This member function will return the total area width of all the tabs in the flat tab control.
GetTotalTabWidth | This member function will return the total width of all the tabs in the flat tab control.
HitTest | Call this function to determine which tab, if any, is at the specified screen position.
Home | This member function will cause the tab control to reposition the tabs to the home position.
InsertItem |
InvalidateTabs | This member function will force all of the tabs to be repainted.
RecalcLayout | This member function is called when the tab control is resized. It is responsible for updating internal structures that are dependent on the control's size.
ResetMouseOver | Call this member function to remove the highlight from all of the buttons.
SetCurSel | This member function selects a tab in a flat tab control.
SetGripperPosition | This member function changes the location of the sizing gripper. The function has no effect if the FTS_XT_HSCROLL is not used.
SetItemText | This member function will set the text of a particular tab.
SetSelTabBackColor |
SetSelTabTextColor |
SetTabBackColor |
SetTabFonts | This member function will set the fonts to be used by the tab control.
SetTabHilightColor | This member function is called to set the highlight color for all tabs.
SetTabShadowColor | This member function is called to set the shadow color for all tabs.
SetTabStyle | Sets the FTS_XT_ styles for a flat tab control.
SetTabTextColor |
SetTipText | This member function will set the tooltip for the tab specified by 'nItem'.
SetTracking | The member function is used internally to toggle the state of the sizing-grip tracking mode.
SyncScrollBar | Synchronizes the scroll bar with the horizontal scroll position.
UpdateDefaultColors | Call this member function to reset the tab control to use default system colors.


CXTExcelTabCtrl Data Members

CXTExcelTabCtrl Class, Legend, Protected Data Members
CXTExcelTabCtrl Data Members
Class

CXTExcelTabCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bManagingViews | true if the control is managing views.
m_bPainted | Set to TRUE to indicate that a button has been painted.
m_bTracking | Tracking state.
m_bUserColors | true if user defined colors are used.
m_buttons | Array of button information.
m_cx | Width for each arrow button.
m_cy | Height for each arrow button.
m_dwStyle | Tab control style.
m_iBtnEnd | Index of "end" button in button array.
m_iBtnHilight | Index of the button that has the mouse hovering over it.
m_iBtnHome | Index of "home" button in button array.
m_iBtnLeft | Index of "left" button in button array.
m_iBtnRight | Index of "right" button in button array.
m_iGripperPosPerCent | The current gripper position in percent of the control width.
m_nClientHeight | Height in pixels of the tab control client area.
m_nClientWidth | Width in pixels of the tab control client area.
m_nCurSel | Index of the currently selected tab.
m_nOffset | Amount in pixels of the displayed tab offset.
m_pBoldFont | Font that is used for selected tabs.
m_pNormFont | Font that is used for non-selected tabs.
m_pWndLastFocus | Last focused window.
m_rectGripper | Area occupied by the sizing gripper.
m_rectSB_H | Area occupied by the horizontal scroll bar.
m_rectTabs | Area occupied by tabs.
m_rectViews | Area occupied by managed views.
m_tcbItems | Template list containing tab information.
m_ToolTip | Tooltip for the flat tab control.
m_wndHScrollBar | The horizontal scroll bar (used with FTS_XT_HSCROLL).
m_xGripperPos | The current gripper position in pixels from the left.
m_xTrackingDelta | Tracking delta.


CXTExcelTabCtrl::m_bManagingViews Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_bManagingViews Data Member

true if the control is managing views.

bool m_bManagingViews;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_bPainted Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_bPainted Data Member

Set to TRUE to indicate that a button has been painted.

bool m_bPainted;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_bTracking Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_bTracking Data Member

Tracking state.

bool m_bTracking;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_bUserColors Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_bUserColors Data Member

true if user defined colors are used.

bool m_bUserColors;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_buttons Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_buttons Data Member

Array of button information.

CXTExcelTabCtrlButtonState m_buttons[4];
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_cx Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_cx Data Member

Width for each arrow button.

int m_cx;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_cy Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_cy Data Member

Height for each arrow button.

int m_cy;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_dwStyle Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_dwStyle Data Member

Tab control style.

DWORD m_dwStyle;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_iBtnEnd Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_iBtnEnd Data Member

Index of "end" button in button array.

int m_iBtnEnd;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_iBtnHilight Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_iBtnHilight Data Member

Index of the button that has the mouse hovering over it.

int m_iBtnHilight;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_iBtnHome Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_iBtnHome Data Member

Index of "home" button in button array.

int m_iBtnHome;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_iBtnLeft Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_iBtnLeft Data Member

Index of "left" button in button array.

int m_iBtnLeft;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_iBtnRight Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_iBtnRight Data Member

Index of "right" button in button array.

int m_iBtnRight;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_iGripperPosPerCent Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_iGripperPosPerCent Data Member

The current gripper position in percent of the control width.

int m_iGripperPosPerCent;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_nClientHeight Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_nClientHeight Data Member

Height in pixels of the tab control client area.

int m_nClientHeight;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_nClientWidth Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_nClientWidth Data Member

Width in pixels of the tab control client area.

int m_nClientWidth;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_nCurSel Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_nCurSel Data Member

Index of the currently selected tab.

int m_nCurSel;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_nOffset Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_nOffset Data Member

Amount in pixels of the displayed tab offset.

int m_nOffset;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_pBoldFont Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_pBoldFont Data Member

Font that is used for selected tabs.

CFont* m_pBoldFont;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_pNormFont Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_pNormFont Data Member

Font that is used for non-selected tabs.

CFont* m_pNormFont;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_pWndLastFocus Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_pWndLastFocus Data Member

Last focused window.

CWnd* m_pWndLastFocus;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_rectGripper Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_rectGripper Data Member

Area occupied by the sizing gripper.

CRect m_rectGripper;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_rectSB_H Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_rectSB_H Data Member

Area occupied by the horizontal scroll bar.

CRect m_rectSB_H;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_rectTabs Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_rectTabs Data Member

Area occupied by tabs.

CRect m_rectTabs;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_rectViews Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_rectViews Data Member

Area occupied by managed views.

CRect m_rectViews;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_tcbItems Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_tcbItems Data Member

Template list containing tab information.

CTabItemArray m_tcbItems;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_ToolTip Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_ToolTip Data Member

Tooltip for the flat tab control.

CToolTipCtrl m_ToolTip;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_wndHScrollBar Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_wndHScrollBar Data Member

The horizontal scroll bar (used with FTS_XT_HSCROLL).

CScrollBar m_wndHScrollBar;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_xGripperPos Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_xGripperPos Data Member

The current gripper position in pixels from the left.

int m_xGripperPos;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl::m_xTrackingDelta Data Member

CXTExcelTabCtrl Data Members, CXTExcelTabCtrl Class
CXTExcelTabCtrl::m_xTrackingDelta Data Member

Tracking delta.

int m_xTrackingDelta;
Group

CXTExcelTabCtrl Data Members


CXTExcelTabCtrl Methods

CXTExcelTabCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrl Methods
Class

CXTExcelTabCtrl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_DeleteItem | This internal function deletes an item from the tab item list.
ButtonHitTest | Call this function to determine which button, if any, is at the specified screen position.
ClearAllItems | This member function frees all memory occupied by the tab items.
CreateButtonIcons | This member function will create the icon resources that are used by the arrow buttons.
DrawGripper | This member function will draw the horizontal sizing gripper at a specified location.
EnableButtons | This member function will enable or disable the arrow buttons depending on the current tab display state.
FreeButtonIcons | This member function will free the resources allocated for the icons used by the arrow buttons.
GetOverlap | This internal function calculates the overlap between two tabs.
GetTabWidth | This member function will get the width in pixels of the tab specified by 'nItem'.
GetTotalArrowWidth | This member function will return the total width of all the arrow buttons that are visible in the flat tab control.
GetTotalButtonRect | Call this member function to get the dimensions of the rectangle that encompasses all of the buttons.
GetTotalTabAreaWidth | This member function will return the total area width of all the tabs in the flat tab control.
GetTotalTabWidth | This member function will return the total width of all the tabs in the flat tab control.
InvalidateTabs | This member function will force all of the tabs to be repainted.
RecalcLayout | This member function is called when the tab control is resized. It is responsible for updating internal structures that are dependent on the control's size.
ResetMouseOver | Call this member function to remove the highlight from all of the buttons.
SetTracking | The member function is used internally to toggle the state of the sizing-grip tracking mode.
Public Methods
Public Methods
Public Method | Description
Create | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
DeleteAllItems | This member function will remove all of the tabs from the tab control.
DeleteItem | This member function will delete the tab specified by 'nItem' from the tab control.
GetCurSel | Call this function to retrieve the currently selected tab in a flat tab control.
GetGripperPosition | This member function gets the location of the sizing gripper in pixels relative to the left hand side of the control.
GetItemCount | Call this function to retrieve the number of tabs in the tab control.
GetItemRect | This member function will retrieve the size of the tab specified by 'nItem'.
GetItemText | This member function gets the text of a specific tab.
GetItemWindow | This member function gets a CWnd pointer to the window that is associated with a specific tab.
GetScrollBarCtrl | This method obtains a pointer to the specified sibling scroll bar for the flat tab control.
GetSelTabBackColor |
GetSelTabTextColor |
GetTabBackColor |
GetTabFont | Retrieves the tab font.
GetTabHilightColor | This member function gets an RGB value that represents the highlight color of the tab.
GetTabItemArray | Call this member function to retrieve a reference to the tab item array.
GetTabShadowColor | This member function gets an RGB value that represents the shadow color of the tab.
GetTabsRect | Retrieves the area occupied by the tabs.
GetTabStyle | Retrieves the FTS_XT_ styles that are currently in use for the flat tab control.
GetTabTextColor |
GetTipText | This member function will get the tooltip text associated with the tab specified by 'nItem'.
HitTest | Call this function to determine which tab, if any, is at the specified screen position.
Home | This member function will cause the tab control to reposition the tabs to the home position.
InsertItem |
SetCurSel | This member function selects a tab in a flat tab control.
SetGripperPosition | This member function changes the location of the sizing gripper. The function has no effect if the FTS_XT_HSCROLL is not used.
SetItemText | This member function will set the text of a particular tab.
SetSelTabBackColor |
SetSelTabTextColor |
SetTabBackColor |
SetTabFonts | This member function will set the fonts to be used by the tab control.
SetTabHilightColor | This member function is called to set the highlight color for all tabs.
SetTabShadowColor | This member function is called to set the shadow color for all tabs.
SetTabStyle | Sets the FTS_XT_ styles for a flat tab control.
SetTabTextColor |
SetTipText | This member function will set the tooltip for the tab specified by 'nItem'.
SyncScrollBar | Synchronizes the scroll bar with the horizontal scroll position.
UpdateDefaultColors | Call this member function to reset the tab control to use default system colors.


CXTExcelTabCtrl::_DeleteItem Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::_DeleteItem Method

This internal function deletes an item from the tab item list.

virtual BOOL _DeleteItem(
    int nItem
);
Parameters

nItem
Index of the tab to delete.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::ButtonHitTest Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::ButtonHitTest Method

Call this function to determine which button, if any, is at the specified screen position.

virtual int ButtonHitTest(
    CPoint& pt
);
Parameters

pt
A CPoint reference representing the specified screen position.

Returns

The zero-based index of the button within the button's array or -1 if no button is at the specified position.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::ClearAllItems Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::ClearAllItems Method

This member function frees all memory occupied by the tab items.

void ClearAllItems();
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::Create Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrl::Create Method

Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.

virtual BOOL Create(
    DWORD dwStyle,
    const CRect& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Specifies the tab control's style. Apply any combination of tab control styles mentioned below in the Remarks section.
rect
Specifies the tab control's size and position. It can be either a CRect object or a RECT structure.
pParentWnd
Specifies the tab control's parent window, usually a CDialog. It must not be NULL.
nID
Specifies the tab control's ID.

Returns

TRUE if initialization of the object was successful; otherwise FALSE.

Remarks

You construct a CXTExcelTabCtrl object in two steps. First, call the constructor, and then call Create, which creates the tab control and attaches it to the CXTExcelTabCtrl object. You can use the following tab control styles when creating the object:

  • FTS_XT_BOTTOM Show tabs on bottom.
  • FTS_XT_HASARROWS Show back and next arrows.
  • FTS_XT_HASHOMEEND Show home and end arrows. Used with FTS_XT_HASARROWS.
  • FTS_XT_TOOLTIPS Show tab tooltips.
  • FTS_XT_DEFAULT Same as (FTS_XT_BOTTOM | FTS_XT_HASARROWS | FTS_XT_HASHOMEEND | FTS_XT_TOOLTIPS).
  • FTS_XT_HSCROLL Show a horizontal scroll bar.
  • FTS_XT_MASK Combines all FTS_ styles.

In addition to tab control styles, you can apply the following window styles to a tab control:

  • WS_CHILD Creates a child window that represents the tab control. Cannot be used with the WS_POPUP style.
  • WS_VISIBLE Creates a tab control that is initially visible.
  • WS_DISABLED Creates a window that is initially disabled.
  • WS_GROUP Specifies the first control of a group of controls in which the user can move from one control to the next with the arrow keys. All controls defined with the WS_GROUP style after the first control belong to the same group. The next control with the WS_GROUP style ends the style group and starts the next group (that is, one group ends where the next begins).
  • WS_TABSTOP Specifies one of any number of controls through which the user can move by using the TAB key. The TAB key moves the user to the next control specified by the WS_TABSTOP style.
See Also

GetTabStyle, SetTabStyle

Example

The following code sample demonstrates the usage of Create.

// Create  the flat tab control.
if (!m_wndFlatTabCtrl.Create(WS_CHILD | WS_VISIBLE | FTS_XT_DEFAULT,
    m_rcTabs, this, IDC_FLAT_TABCTRL))
{
    TRACE0("Failed to create flattab controln");
    return;
}

CreateViews();

// Insert tabs into the flat tab control.
m_wndFlatTabCtrl.InsertItem(0, _T("Build"),           &m_sheet1);
m_wndFlatTabCtrl.InsertItem(1, _T("Debug"),           &m_sheet2);
m_wndFlatTabCtrl.InsertItem(2, _T("Find in Files 1"), &m_sheet3);
m_wndFlatTabCtrl.InsertItem(3, _T("Find in Files 2"), &m_sheet4);
m_wndFlatTabCtrl.InsertItem(4, _T("Results"),         &m_sheet5);
m_wndFlatTabCtrl.InsertItem(5, _T("SQL Debugging"),   &m_sheet6);
m_wndFlatTabCtrl.InsertItem(6, _T("Form View"),       m_pSheet7);
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::CreateButtonIcons Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::CreateButtonIcons Method

This member function will create the icon resources that are used by the arrow buttons.

void CreateButtonIcons();
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::DeleteAllItems Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::DeleteAllItems Method

This member function will remove all of the tabs from the tab control.

virtual BOOL DeleteAllItems();
Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::DeleteItem Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::DeleteItem Method

This member function will delete the tab specified by 'nItem' from the tab control.

virtual BOOL DeleteItem(
    int nItem
);
Parameters

nItem
Index of the tab to delete.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::DrawGripper Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::DrawGripper Method

This member function will draw the horizontal sizing gripper at a specified location.

void DrawGripper(
    CDC* pDC,
    CRect rect
) const;
Parameters

pDC
Points to the device context to draw the gripper to.
rect
Location of the gripper.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::EnableButtons Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::EnableButtons Method

This member function will enable or disable the arrow buttons depending on the current tab display state.

void EnableButtons();
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::FreeButtonIcons Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::FreeButtonIcons Method

This member function will free the resources allocated for the icons used by the arrow buttons.

void FreeButtonIcons();
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetCurSel Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, Body Source
CXTExcelTabCtrl::GetCurSel Method

Call this function to retrieve the currently selected tab in a flat tab control.

virtual int GetCurSel() const;
Returns

A zero-based index of the selected tab if successful, or returns -1 if no tab is selected.

Body Source
int CXTExcelTabCtrl::GetCurSel() const {
    ASSERT(IsWindow(m_hWnd)); return m_nCurSel;
}
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetGripperPosition Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetGripperPosition Method

This member function gets the location of the sizing gripper in pixels relative to the left hand side of the control.

int GetGripperPosition() const;
Returns

An integer value representing the location of the sizing gripper in pixels relative to the left hand side of the control.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetItemCount Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, Body Source
CXTExcelTabCtrl::GetItemCount Method

Call this function to retrieve the number of tabs in the tab control.

virtual int GetItemCount() const;
Returns

The number of items in the tab control.

Body Source
int CXTExcelTabCtrl::GetItemCount() const {
    ASSERT(IsWindow(m_hWnd)); int iItemCount = (int)m_tcbItems.GetSize(); return iItemCount;
}
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetItemRect Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetItemRect Method

This member function will retrieve the size of the tab specified by 'nItem'.

virtual BOOL GetItemRect(
    int nItem,
    LPRECT lpRect
);
Parameters

nItem
Index of the tab to retrieve the size of.
lpRect
Points to a RECT structure to receive the size of the tab.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetItemText Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetItemText Method

This member function gets the text of a specific tab.

LPCTSTR GetItemText(
    int nIndex
) const;
Parameters

nIndex
The index of the tab whose text is to be retrieved.

Returns

The text of a particular tab, or NULL if an error occurs.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetItemWindow Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetItemWindow Method

This member function gets a CWnd pointer to the window that is associated with a specific tab.

CWnd * GetItemWindow(
    int nIndex
) const;
Parameters

nIndex
The index of the tab whose managed window is to be retrieved.

Returns

A pointer to the window that is associated with a tab, or it returns NULL if no window is associated with (managed by) the tab.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetOverlap Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetOverlap Method

This internal function calculates the overlap between two tabs.

virtual int GetOverlap() const;
Returns

An integer value that represents the overlap between the tabs.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetScrollBarCtrl Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetScrollBarCtrl Method

This method obtains a pointer to the specified sibling scroll bar for the flat tab control.

virtual CScrollBar* GetScrollBarCtrl(
    int nBar
) const;
Parameters

nBar
Specifies the type of scroll bar. The parameter can take one of the values specified in the Remarks section.

Remarks

The scroll bar type can be one of the following values.

SB_HORZ - Retrieves the position of the horizontal scroll bar.
SB_VERT - Retrieves the position of the vertical scroll bar.
Group

CXTExcelTabCtrl Methods


GetSelTabBackColor Method

CXTExcelTabCtrl Methods
GetSelTabBackColor Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::GetSelTabBackColor () | This member function gets an RGB value that represents the background color for selected tabs.
CXTExcelTabCtrl::GetSelTabBackColor (int) | This member function gets an RGB value that represents the background color for selected tabs.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetSelTabBackColor Method ()

GetSelTabBackColor Method, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetSelTabBackColor Method ()

This member function gets an RGB value that represents the background color for selected tabs.

COLORREF GetSelTabBackColor() const;
COLORREF GetSelTabBackColor(
    int nIndex
) const;
Parameters

nIndex
The index of the tab to get selected background color for.

Returns

An RGB value that represents the selected tabs background color if successful, otherwise returns COLORREF_NULL.

Group

GetSelTabBackColor Method


GetSelTabTextColor Method

CXTExcelTabCtrl Methods
GetSelTabTextColor Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::GetSelTabTextColor () | This member function gets an RGB value that represents the text color for selected tabs.
CXTExcelTabCtrl::GetSelTabTextColor (int) | This member function gets an RGB value that represents the text color for selected tabs.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetSelTabTextColor Method ()

GetSelTabTextColor Method, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetSelTabTextColor Method ()

This member function gets an RGB value that represents the text color for selected tabs.

COLORREF GetSelTabTextColor() const;
COLORREF GetSelTabTextColor(
    int nIndex
) const;
Parameters

nIndex
The index of the tab to get selected text color for.

Returns

An RGB value that represents the selected tab text color if successful, otherwise returns COLORREF_NULL.

Group

GetSelTabTextColor Method


GetTabBackColor Method

CXTExcelTabCtrl Methods
GetTabBackColor Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::GetTabBackColor () | This member function gets an RGB value that represents the background color of the tab.
CXTExcelTabCtrl::GetTabBackColor (int) | This member function gets an RGB value that represents the background color of the tab.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTabBackColor Method ()

GetTabBackColor Method, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTabBackColor Method ()

This member function gets an RGB value that represents the background color of the tab.

COLORREF GetTabBackColor() const;
COLORREF GetTabBackColor(
    int nIndex
) const;
Parameters

nIndex
The index of the tab to get background color for.

Returns

An RGB value that represents the tab background color if successful, otherwise returns COLORREF_NULL.

Group

GetTabBackColor Method


CXTExcelTabCtrl::GetTabFont Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, Body Source
CXTExcelTabCtrl::GetTabFont Method

Retrieves the tab font.

CFont* GetTabFont(
    BOOL bBold
);
Parameters

bBold
TRUE to return the bold font.

Returns

A pointer to a CFont object.

Remarks

Call this member function to return a pointer to the font used to display the tab item label for the tab control.

Body Source
CFont* CXTExcelTabCtrl::GetTabFont(BOOL bBold) {
    return bBold ? m_pBoldFont : m_pNormFont;
}
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTabHilightColor Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTabHilightColor Method

This member function gets an RGB value that represents the highlight color of the tab.

COLORREF GetTabHilightColor() const;
Returns

An RGB value that represents the tab highlight color.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTabItemArray Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, Body Source
CXTExcelTabCtrl::GetTabItemArray Method

Call this member function to retrieve a reference to the tab item array.

CTabItemArray& GetTabItemArray();
Returns

A reference to a CTabItemArray object used for maintaining the list of tabs for the tab control.

Body Source
CTabItemArray& GetTabItemArray() {
    return m_tcbItems;
}
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTabShadowColor Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTabShadowColor Method

This member function gets an RGB value that represents the shadow color of the tab.

COLORREF GetTabShadowColor() const;
Returns

An RGB value that represents the tab shadow color.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTabsRect Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, Body Source
CXTExcelTabCtrl::GetTabsRect Method

Retrieves the area occupied by the tabs.

CRect GetTabsRect();
Returns

A CRect object representing the tab item area.

Remarks

This member function is called to retrieve the size and location of the area that is occupied by the tab items.

Body Source
CRect CXTExcelTabCtrl::GetTabsRect() {
    return m_rectTabs;
}
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTabStyle Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrl::GetTabStyle Method

Retrieves the FTS_XT_ styles that are currently in use for the flat tab control.

DWORD GetTabStyle();
Returns

A DWORD value that represents the FTS_XT_ styles currently in use for the flat tab control.

Remarks

This value is a combination of tab control FTS_XT_ styles, see the CXTExcelTabCtrl::Create method for a list of available styles.

See Also

Create, SetTabStyle

Body Source
DWORD CXTExcelTabCtrl::GetTabStyle() {
    return m_dwStyle;
}
Group

CXTExcelTabCtrl Methods


GetTabTextColor Method

CXTExcelTabCtrl Methods
GetTabTextColor Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::GetTabTextColor () | This member function gets an RGB value that represents the text color of the tab.
CXTExcelTabCtrl::GetTabTextColor (int) | This member function gets an RGB value that represents the text color of the tab.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTabTextColor Method ()

GetTabTextColor Method, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTabTextColor Method ()

This member function gets an RGB value that represents the text color of the tab.

COLORREF GetTabTextColor() const;
COLORREF GetTabTextColor(
    int nIndex
) const;
Parameters

nIndex
The index of the tab to get text color for.

Returns

An RGB value that represents the tab text color if successful, otherwise returns COLORREF_NULL.

Group

GetTabTextColor Method


CXTExcelTabCtrl::GetTabWidth Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTabWidth Method

This member function will get the width in pixels of the tab specified by 'nItem'.

int GetTabWidth(
    int nItem
) const;
Parameters

nItem
The zero-based index of the tab to retrieve the width for.

Returns

The width in pixels of the tab.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTipText Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTipText Method

This member function will get the tooltip text associated with the tab specified by 'nItem'.

virtual CString GetTipText(
    int nItem
);
Parameters

nItem
The zero-based index of the tab to retrieve the tooltip text for.

Returns

A CString object containing the text to be used in the tooltip.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTotalArrowWidth Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTotalArrowWidth Method

This member function will return the total width of all the arrow buttons that are visible in the flat tab control.

int GetTotalArrowWidth() const;
Returns

The total width in pixels of all the visible arrow buttons.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTotalButtonRect Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTotalButtonRect Method

Call this member function to get the dimensions of the rectangle that encompasses all of the buttons.

CRect GetTotalButtonRect() const;
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTotalTabAreaWidth Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTotalTabAreaWidth Method

This member function will return the total area width of all the tabs in the flat tab control.

int GetTotalTabAreaWidth() const;
Returns

The total area width in pixels of all the tabs in the flat tab control.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::GetTotalTabWidth Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::GetTotalTabWidth Method

This member function will return the total width of all the tabs in the flat tab control.

int GetTotalTabWidth() const;
Returns

The total combined width in pixels of all the tabs in the control.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::HitTest Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::HitTest Method

Call this function to determine which tab, if any, is at the specified screen position.

virtual int HitTest(
    TCHITTESTINFO* pHitTestInfo
) const;
Parameters

pHitTestInfo
Pointer to a TCHITTESTINFO structure, as described in the Platform SDK, which specifies the screen position to test.

Returns

The zero-based index of the tab, or returns -1 if no tab is at the specified position.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::Home Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::Home Method

This member function will cause the tab control to reposition the tabs to the home position.

virtual void Home();
Group

CXTExcelTabCtrl Methods


InsertItem Method

CXTExcelTabCtrl Methods
InsertItem Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::InsertItem (int, LPCTSTR, CWnd*) | This member function will insert a tab into the flat tab control.
CXTExcelTabCtrl::InsertItem (int, UINT, CWnd*) | This member function will insert a tab into the flat tab control.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::InsertItem Method (int, UINT, CWnd*)

InsertItem Method, CXTExcelTabCtrl Class, Body Source
CXTExcelTabCtrl::InsertItem Method (int, UINT, CWnd*)

This member function will insert a tab into the flat tab control.

virtual int InsertItem(
    int nItem,
    UINT nTextID,
    CWnd* pWndControl = NULL
);
virtual int InsertItem(
    int nItem,
    LPCTSTR lpszItem,
    CWnd* pWndControl = NULL
);
Parameters

nItem
Index of the tab to insert.
nTextID
String resource ID of the tab label.
pWndControl
Optional pointer to the managed control.
lpszItem
NULL terminated string that represents the tab label.

Returns

The index of the tab that has been inserted if successful, otherwise -1.

Body Source
int CXTExcelTabCtrl::InsertItem(int nItem, UINT nTextID, CWnd* pWndControl) {
    ASSERT(IsWindow(m_hWnd)); CString strItem; VERIFY(strItem.LoadString(nTextID)); return InsertItem(nItem, strItem, pWndControl);
}
Group

InsertItem Method


CXTExcelTabCtrl::InvalidateTabs Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::InvalidateTabs Method

This member function will force all of the tabs to be repainted.

void InvalidateTabs();
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::RecalcLayout Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::RecalcLayout Method

This member function is called when the tab control is resized. It is responsible for updating internal structures that are dependent on the control's size.

virtual void RecalcLayout();
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::ResetMouseOver Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::ResetMouseOver Method

Call this member function to remove the highlight from all of the buttons.

void ResetMouseOver();
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetCurSel Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetCurSel Method

This member function selects a tab in a flat tab control.

virtual int SetCurSel(
    int nItem
);
Parameters

nItem
The zero-based index of the item to be selected.

Returns

A zero-based index of the previously selected tab if successful, otherwise returns -1.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetGripperPosition Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetGripperPosition Method

This member function changes the location of the sizing gripper. The function has no effect if the FTS_XT_HSCROLL is not used.

void SetGripperPosition(
    int nPos,
    bool bPercent
);
Parameters

nPos
The position for the gripper, relative to the left-hand-side of the control.
bPercent
Indicates that the position is a percent of the control width, as opposed to an absolute location in pixels.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetItemText Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetItemText Method

This member function will set the text of a particular tab.

bool SetItemText(
    int nIndex,
    LPCTSTR pszText
);
Parameters

nIndex
The index of the tab whose text is to be changed.
pszText
The new title for the tab.

Returns

true when successful.

Group

CXTExcelTabCtrl Methods


SetSelTabBackColor Method

CXTExcelTabCtrl Methods
SetSelTabBackColor Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::SetSelTabBackColor (COLORREF) | This member function is called to set the selected background color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.
CXTExcelTabCtrl::SetSelTabBackColor (int, COLORREF) | This member function is called to set the selected background color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetSelTabBackColor Method (COLORREF)

SetSelTabBackColor Method, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetSelTabBackColor Method (COLORREF)

This member function is called to set the selected background color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.

void SetSelTabBackColor(
    COLORREF crBack
);
void SetSelTabBackColor(
    int nIndex,
    COLORREF crBack
);
Parameters

crBack
RGB value that represents the selected tab background color.
nIndex
The index of the tab to set selected background color for.

Group

SetSelTabBackColor Method


SetSelTabTextColor Method

CXTExcelTabCtrl Methods
SetSelTabTextColor Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::SetSelTabTextColor (COLORREF) | This member function is called to set the selected text color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.
CXTExcelTabCtrl::SetSelTabTextColor (int, COLORREF) | This member function is called to set the selected text color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetSelTabTextColor Method (COLORREF)

SetSelTabTextColor Method, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetSelTabTextColor Method (COLORREF)

This member function is called to set the selected text color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.

void SetSelTabTextColor(
    COLORREF crText
);
void SetSelTabTextColor(
    int nIndex,
    COLORREF crText
);
Parameters

crText
RGB value that represents the selected tab text color.
nIndex
The index of the tab to set selected text color for.

Group

SetSelTabTextColor Method


SetTabBackColor Method

CXTExcelTabCtrl Methods
SetTabBackColor Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::SetTabBackColor (COLORREF) | This member function is called to set the default background color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.
CXTExcelTabCtrl::SetTabBackColor (int, COLORREF) | This member function is called to set the default background color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetTabBackColor Method (COLORREF)

SetTabBackColor Method, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetTabBackColor Method (COLORREF)

This member function is called to set the default background color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.

void SetTabBackColor(
    COLORREF crBack
);
void SetTabBackColor(
    int nIndex,
    COLORREF crBack
);
Parameters

crBack
RGB value that represents the tab background color.
nIndex
The index of the tab to set background color for.

Group

SetTabBackColor Method


CXTExcelTabCtrl::SetTabFonts Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, Body Source
CXTExcelTabCtrl::SetTabFonts Method

This member function will set the fonts to be used by the tab control.

virtual void SetTabFonts(
    CFont* pNormFont,
    CFont* pBoldFont
);
Parameters

pNormFont
Represents the font used by non-selected tabs.
pBoldFont
Represents the font used by selected tabs.

Body Source
void CXTExcelTabCtrl::SetTabFonts(CFont* pNormFont, CFont* pBoldFont) {
    if (pNormFont){ m_pNormFont = pNormFont; } if (pBoldFont){ m_pBoldFont = pBoldFont; }
}
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetTabHilightColor Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetTabHilightColor Method

This member function is called to set the highlight color for all tabs.

void SetTabHilightColor(
    COLORREF crHilight
);
Parameters

crHilight
RGB value that represents the tab highlight color.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetTabShadowColor Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetTabShadowColor Method

This member function is called to set the shadow color for all tabs.

void SetTabShadowColor(
    COLORREF crShadow
);
Parameters

crShadow
RGB value that represents the tab shadow color.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetTabStyle Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class, See Also
CXTExcelTabCtrl::SetTabStyle Method

Sets the FTS_XT_ styles for a flat tab control.

void SetTabStyle(
    DWORD dwStyle
);
Parameters

dwStyle
Value specifying a combination of flat tab control FTS_XT_ styles.

Returns

A DWORD value that contains the previous tab control FTS_XT_ styles.

Remarks

The dwStyle parameter allows you to set one or more FTS_XT_ styles, see the CXTExcelTabCtrl::Create method for a list of available styles.

See Also

Create, GetTabStyle

Group

CXTExcelTabCtrl Methods


SetTabTextColor Method

CXTExcelTabCtrl Methods
SetTabTextColor Method
Overload List
Methods
Method | Description
CXTExcelTabCtrl::SetTabTextColor (COLORREF) | This member function is called to set the default text color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.
CXTExcelTabCtrl::SetTabTextColor (int, COLORREF) | This member function is called to set the default text color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetTabTextColor Method (COLORREF)

SetTabTextColor Method, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetTabTextColor Method (COLORREF)

This member function is called to set the default text color for all tabs. If nIndex is specified, the color is only set for the tab located at 'nIndex'.

void SetTabTextColor(
    COLORREF crText
);
void SetTabTextColor(
    int nIndex,
    COLORREF crText
);
Parameters

crText
RGB value that represents the tab text color.
nIndex
The index of the tab to set text color for.

Group

SetTabTextColor Method


CXTExcelTabCtrl::SetTipText Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetTipText Method

This member function will set the tooltip for the tab specified by 'nItem'.

virtual void SetTipText(
    int nItem,
    LPCTSTR lpszTabTip
);
Parameters

nItem
The zero-based index of tab to receive the tooltip text.
lpszTabTip
A pointer to a string containing the tooltip text.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SetTracking Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SetTracking Method

The member function is used internally to toggle the state of the sizing-grip tracking mode.

void SetTracking(
    bool bTracking
);
Parameters

bTracking
true to enable tracking, or false to disable tracking.

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::SyncScrollBar Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::SyncScrollBar Method

Synchronizes the scroll bar with the horizontal scroll position.

void SyncScrollBar();
Remarks

Call this function to synchronize the tab control's horizontal scroll bar with the horizontal scroll bar of the current view.

You should call this function if anything happens in the view that affects the horizontal scroll bar (e.g., a user typing text into an edit control could make the text wider, thus requiring a call to this function).

Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl::UpdateDefaultColors Method

CXTExcelTabCtrl Methods, CXTExcelTabCtrl Class
CXTExcelTabCtrl::UpdateDefaultColors Method

Call this member function to reset the tab control to use default system colors.

void UpdateDefaultColors();
Group

CXTExcelTabCtrl Methods


CXTExcelTabCtrl Constructors

CXTExcelTabCtrl Class, Legend, Public Methods
CXTExcelTabCtrl Constructors
Class

CXTExcelTabCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTExcelTabCtrl | Constructs a CXTExcelTabCtrl object


CXTExcelTabCtrl::CXTExcelTabCtrl Constructor

CXTExcelTabCtrl Constructors, CXTExcelTabCtrl Class
CXTExcelTabCtrl::CXTExcelTabCtrl Constructor

Constructs a CXTExcelTabCtrl object

CXTExcelTabCtrl();
Group

CXTExcelTabCtrl Constructors


CXTExcelTabCtrl Destructors

CXTExcelTabCtrl Class, Legend, Public Methods
CXTExcelTabCtrl Destructors
Class

CXTExcelTabCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTExcelTabCtrl | Destroys a CXTExcelTabCtrl object, handles cleanup and deallocation


CXTExcelTabCtrl::~CXTExcelTabCtrl Destructor

CXTExcelTabCtrl Destructors, CXTExcelTabCtrl Class
CXTExcelTabCtrl::~CXTExcelTabCtrl Destructor

Destroys a CXTExcelTabCtrl object, handles cleanup and deallocation

virtual ~CXTExcelTabCtrl();
Group

CXTExcelTabCtrl Destructors


CXTExcelTabCtrlButtonState Class

XTExcelTabCtrl.h, Classes, Legend, Members, Topics, CXTExcelTabCtrlButtonState Data Members, CXTExcelTabCtrlButtonState Methods, CXTExcelTabCtrlButtonState Constructors, CXTExcelTabCtrlButtonState Constructors, CXTExcelTabCtrlButtonState Data Members, CXTExcelTabCtrlButtonState Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState Class

The CXTExcelTabCtrlButtonState class is used by the CXTExcelTabCtrl class to manage navigation button information. This class contains information about the state and command identifiers for the button.

Class Hierarchy

class CXTExcelTabCtrlButtonState;
File

XTExcelTabCtrl.h

Group

Classes

Legend
Data Member
Method
CXTExcelTabCtrlButtonState Constructors
CXTExcelTabCtrlButtonState Constructors | Description
CXTExcelTabCtrlButtonState | Constructs a CXTExcelTabCtrlButtonState object.
CXTExcelTabCtrlButtonState Data Members
CXTExcelTabCtrlButtonState Data Members | Description
m_bEnabled | true if the button is enabled.
m_bHilight | true if the mouse if hovering.
m_bPressed | true if the button is pressed.
m_iCommand | Button command ID.
m_IconType | Icon style of the button.
m_rect | Size and location of the button.
CXTExcelTabCtrlButtonState Methods
CXTExcelTabCtrlButtonState Methods | Description
SetInfo | This member function is called to initialize the information about the tab control navigation button.


CXTExcelTabCtrlButtonState Data Members

CXTExcelTabCtrlButtonState Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState Data Members
Class

CXTExcelTabCtrlButtonState Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bEnabled | true if the button is enabled.
m_bHilight | true if the mouse if hovering.
m_bPressed | true if the button is pressed.
m_iCommand | Button command ID.
m_IconType | Icon style of the button.
m_rect | Size and location of the button.


CXTExcelTabCtrlButtonState::m_bEnabled Data Member

CXTExcelTabCtrlButtonState Data Members, CXTExcelTabCtrlButtonState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState::m_bEnabled Data Member

true if the button is enabled.

bool m_bEnabled;
Group

CXTExcelTabCtrlButtonState Data Members


CXTExcelTabCtrlButtonState::m_bHilight Data Member

CXTExcelTabCtrlButtonState Data Members, CXTExcelTabCtrlButtonState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState::m_bHilight Data Member

true if the mouse if hovering.

bool m_bHilight;
Group

CXTExcelTabCtrlButtonState Data Members


CXTExcelTabCtrlButtonState::m_bPressed Data Member

CXTExcelTabCtrlButtonState Data Members, CXTExcelTabCtrlButtonState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState::m_bPressed Data Member

true if the button is pressed.

bool m_bPressed;
Group

CXTExcelTabCtrlButtonState Data Members


CXTExcelTabCtrlButtonState::m_iCommand Data Member

CXTExcelTabCtrlButtonState Data Members, CXTExcelTabCtrlButtonState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState::m_iCommand Data Member

Button command ID.

int m_iCommand;
Group

CXTExcelTabCtrlButtonState Data Members


CXTExcelTabCtrlButtonState::m_IconType Data Member

CXTExcelTabCtrlButtonState Data Members, CXTExcelTabCtrlButtonState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState::m_IconType Data Member

Icon style of the button.

XTArrowIcon m_IconType;
Group

CXTExcelTabCtrlButtonState Data Members


CXTExcelTabCtrlButtonState::m_rect Data Member

CXTExcelTabCtrlButtonState Data Members, CXTExcelTabCtrlButtonState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState::m_rect Data Member

Size and location of the button.

CRect m_rect;
Group

CXTExcelTabCtrlButtonState Data Members


CXTExcelTabCtrlButtonState Methods

CXTExcelTabCtrlButtonState Class, Legend, Public Methods
CXTExcelTabCtrlButtonState Methods
Class

CXTExcelTabCtrlButtonState Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetInfo | This member function is called to initialize the information about the tab control navigation button.


CXTExcelTabCtrlButtonState::SetInfo Method

CXTExcelTabCtrlButtonState Methods, CXTExcelTabCtrlButtonState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState::SetInfo Method

This member function is called to initialize the information about the tab control navigation button.

void SetInfo(
    CRect rect,
    int iCommand,
    XTArrowIcon iconType
);
Parameters

rect
Size and location of the button.
iCommand
Command ID for the button.
iconType
Icon style of the button.

Group

CXTExcelTabCtrlButtonState Methods


CXTExcelTabCtrlButtonState Constructors

CXTExcelTabCtrlButtonState Class, Legend, Public Methods
CXTExcelTabCtrlButtonState Constructors
Class

CXTExcelTabCtrlButtonState Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTExcelTabCtrlButtonState | Constructs a CXTExcelTabCtrlButtonState object.


CXTExcelTabCtrlButtonState::CXTExcelTabCtrlButtonState Constructor

CXTExcelTabCtrlButtonState Constructors, CXTExcelTabCtrlButtonState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlButtonState::CXTExcelTabCtrlButtonState Constructor

Constructs a CXTExcelTabCtrlButtonState object.

CXTExcelTabCtrlButtonState();
Group

CXTExcelTabCtrlButtonState Constructors


CXTExcelTabCtrlTheme Class

XTExcelTabCtrlTheme.h, Classes, Legend, Members, Topics, CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Constructors, CXTExcelTabCtrlTheme Destructors, CXTExcelTabCtrlTheme Constructors, CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Destructors, CXTExcelTabCtrlTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme Class

CXTExcelTabCtrlTheme is used to draw the CXTExcelTabCtrl object. All themes used for CXTExcelTabCtrl should inherit from this base class.

Class Hierarchy

class CXTExcelTabCtrlTheme : public CXTThemeManagerStyle;
File

XTExcelTabCtrlTheme.h

Group

Classes

Legend
Data Member
Method
virtual
CXTExcelTabCtrlTheme Constructors
CXTExcelTabCtrlTheme Constructors | Description
CXTExcelTabCtrlTheme | Constructs a CXTExcelTabCtrlTheme object.
CXTExcelTabCtrlTheme Data Members
CXTExcelTabCtrlTheme Data Members | Description
m_clr3DFace | RGB value that represents the normal tab face color.
m_clr3DFaceHilite | RGB value for highlighted background color.
m_clr3DFacePushed | RGB value for pushed background color.
m_clr3DHilight | RGB value that represents the tab highlight color.
m_clr3DShadow | RGB value that represents the tab shadow color.
m_clrBorder3DHilite | RGB value for 3D border highlight color.
m_clrBorder3DShadow | RGB value for 3D border shadow color.
m_clrBtnText | RGB value that represents the tab outline color.
m_clrBtnTextGray | RGB value for disabled text color.
m_clrBtnTextHilite | RGB value for pushed text color.
m_clrBtnTextPushed | RGB value for highlighted text color.
m_clrWindow | RGB value that represents the selected tab face color.
m_clrWindowText | RGB value that represents the tab text color.
m_cx | Width for each arrow button.
m_cy | Height for each arrow button
CXTExcelTabCtrlTheme Destructors
CXTExcelTabCtrlTheme Destructors | Description
~CXTExcelTabCtrlTheme | Destroys a CXTExcelTabCtrlTheme object, handles cleanup and deallocation.
CXTExcelTabCtrlTheme Methods
CXTExcelTabCtrlTheme Methods | Description
DrawButton | This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
DrawButtonBack | Call this member function to draw the background of the button.
DrawTab | This member function will draw a tab to the device context specified by 'pDC'.
GetSelTabBackColor | This member function gets an RGB value that represents the background color for selected tabs.
GetSelTabTextColor | This member function gets an RGB value that represents the text color for selected tabs.
GetTabBackColor | This member function gets an RGB value that represents the background color of the tab.
GetTabTextColor | This member function gets an RGB value that represents the text color of the tab.
RefreshMetrics | Call this function to refresh the flat tab control colors, position any scroll bars to their default positions, and then reset the control to the system defaults.


CXTExcelTabCtrlTheme Data Members

CXTExcelTabCtrlTheme Class, Legend, Public Data Members
CXTExcelTabCtrlTheme Data Members
Class

CXTExcelTabCtrlTheme Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clr3DFace | RGB value that represents the normal tab face color.
m_clr3DFaceHilite | RGB value for highlighted background color.
m_clr3DFacePushed | RGB value for pushed background color.
m_clr3DHilight | RGB value that represents the tab highlight color.
m_clr3DShadow | RGB value that represents the tab shadow color.
m_clrBorder3DHilite | RGB value for 3D border highlight color.
m_clrBorder3DShadow | RGB value for 3D border shadow color.
m_clrBtnText | RGB value that represents the tab outline color.
m_clrBtnTextGray | RGB value for disabled text color.
m_clrBtnTextHilite | RGB value for pushed text color.
m_clrBtnTextPushed | RGB value for highlighted text color.
m_clrWindow | RGB value that represents the selected tab face color.
m_clrWindowText | RGB value that represents the tab text color.
m_cx | Width for each arrow button.
m_cy | Height for each arrow button


CXTExcelTabCtrlTheme::m_clr3DFace Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clr3DFace Data Member

RGB value that represents the normal tab face color.

CXTPPaintManagerColor m_clr3DFace;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clr3DFaceHilite Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clr3DFaceHilite Data Member

RGB value for highlighted background color.

CXTPPaintManagerColor m_clr3DFaceHilite;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clr3DFacePushed Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clr3DFacePushed Data Member

RGB value for pushed background color.

CXTPPaintManagerColor m_clr3DFacePushed;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clr3DHilight Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clr3DHilight Data Member

RGB value that represents the tab highlight color.

CXTPPaintManagerColor m_clr3DHilight;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clr3DShadow Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clr3DShadow Data Member

RGB value that represents the tab shadow color.

CXTPPaintManagerColor m_clr3DShadow;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clrBorder3DHilite Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clrBorder3DHilite Data Member

RGB value for 3D border highlight color.

CXTPPaintManagerColor m_clrBorder3DHilite;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clrBorder3DShadow Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clrBorder3DShadow Data Member

RGB value for 3D border shadow color.

CXTPPaintManagerColor m_clrBorder3DShadow;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clrBtnText Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clrBtnText Data Member

RGB value that represents the tab outline color.

CXTPPaintManagerColor m_clrBtnText;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clrBtnTextGray Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clrBtnTextGray Data Member

RGB value for disabled text color.

CXTPPaintManagerColor m_clrBtnTextGray;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clrBtnTextHilite Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clrBtnTextHilite Data Member

RGB value for pushed text color.

CXTPPaintManagerColor m_clrBtnTextHilite;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clrBtnTextPushed Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clrBtnTextPushed Data Member

RGB value for highlighted text color.

CXTPPaintManagerColor m_clrBtnTextPushed;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clrWindow Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clrWindow Data Member

RGB value that represents the selected tab face color.

CXTPPaintManagerColor m_clrWindow;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_clrWindowText Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_clrWindowText Data Member

RGB value that represents the tab text color.

CXTPPaintManagerColor m_clrWindowText;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_cx Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_cx Data Member

Width for each arrow button.

int m_cx;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme::m_cy Data Member

CXTExcelTabCtrlTheme Data Members, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::m_cy Data Member

Height for each arrow button

int m_cy;
Group

CXTExcelTabCtrlTheme Data Members


CXTExcelTabCtrlTheme Methods

CXTExcelTabCtrlTheme Class, Legend, Public Methods
CXTExcelTabCtrlTheme Methods
Class

CXTExcelTabCtrlTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawButton | This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
DrawButtonBack | Call this member function to draw the background of the button.
DrawTab | This member function will draw a tab to the device context specified by 'pDC'.
GetSelTabBackColor | This member function gets an RGB value that represents the background color for selected tabs.
GetSelTabTextColor | This member function gets an RGB value that represents the text color for selected tabs.
GetTabBackColor | This member function gets an RGB value that represents the background color of the tab.
GetTabTextColor | This member function gets an RGB value that represents the text color of the tab.
RefreshMetrics | Call this function to refresh the flat tab control colors, position any scroll bars to their default positions, and then reset the control to the system defaults.


CXTExcelTabCtrlTheme::DrawButton Method

CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::DrawButton Method

This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.

virtual void DrawButton(
    CDC* pDC,
    CXTExcelTabCtrl* pTabCtrl,
    CXTExcelTabCtrlButtonState& state
);
Parameters

pDC
A CDC pointer that represents the current device context.
pTabCtrl
A pointer to a CXTExcelTabCtrl object.
state
XY location of the top left corner of the tab to draw.

Group

CXTExcelTabCtrlTheme Methods


CXTExcelTabCtrlTheme::DrawButtonBack Method

CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::DrawButtonBack Method

Call this member function to draw the background of the button.

virtual void DrawButtonBack(
    CDC* pDC,
    CRect& rect,
    CXTExcelTabCtrlButtonState& state
);
Parameters

pDC
A pointer to a valid device context.
rect
A CRect object that contains the location and the dimensions of the button.
state
A CXTExcelTabCtrlButtonState that contains the current state of the button.

Group

CXTExcelTabCtrlTheme Methods


CXTExcelTabCtrlTheme::DrawTab Method

CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::DrawTab Method

This member function will draw a tab to the device context specified by 'pDC'.

virtual int DrawTab(
    CDC* pDC,
    CXTExcelTabCtrl* pTabCtrl,
    const CPoint& pt,
    bool bSelected,
    CXTTcbItem* pTcbItem
);
Parameters

pDC
A CDC pointer that represents the current device context.
pTabCtrl
A pointer to a CXTExcelTabCtrl object.
pt
A CPoint object that specifies the position of the XY location of the top left corner of the tab to draw.
bSelected
True if the tab is currently selected.
pTcbItem
Tab pointer to render.

Returns

The x position of the next tab to be drawn if successful, otherwise

1;.

Group

CXTExcelTabCtrlTheme Methods


CXTExcelTabCtrlTheme::GetSelTabBackColor Method

CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::GetSelTabBackColor Method

This member function gets an RGB value that represents the background color for selected tabs.

virtual COLORREF GetSelTabBackColor(
    CXTTcbItem* pTcbItem
) const;
Parameters

pTcbItem
The tab pointer to get selected background color for.

Returns

An RGB value that represents the selected tabs background color if successful, otherwise returns COLORREF_NULL.

Group

CXTExcelTabCtrlTheme Methods


CXTExcelTabCtrlTheme::GetSelTabTextColor Method

CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::GetSelTabTextColor Method

This member function gets an RGB value that represents the text color for selected tabs.

virtual COLORREF GetSelTabTextColor(
    CXTTcbItem* pTcbItem
) const;
Parameters

pTcbItem
The tab pointer to get selected text color for.

Returns

An RGB value that represents the selected tab text color if successful, otherwise returns COLORREF_NULL.

Group

CXTExcelTabCtrlTheme Methods


CXTExcelTabCtrlTheme::GetTabBackColor Method

CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::GetTabBackColor Method

This member function gets an RGB value that represents the background color of the tab.

virtual COLORREF GetTabBackColor(
    CXTTcbItem* pTcbItem
) const;
Parameters

pTcbItem
The tab pointer to get background color for.

Returns

An RGB value that represents the tab background color if successful, otherwise returns COLORREF_NULL.

Group

CXTExcelTabCtrlTheme Methods


CXTExcelTabCtrlTheme::GetTabTextColor Method

CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::GetTabTextColor Method

This member function gets an RGB value that represents the text color of the tab.

virtual COLORREF GetTabTextColor(
    CXTTcbItem* pTcbItem
) const;
Parameters

pTcbItem
The tab pointer to get text color for.

Returns

An RGB value that represents the tab text color if successful, otherwise returns COLORREF_NULL.

Group

CXTExcelTabCtrlTheme Methods


CXTExcelTabCtrlTheme::RefreshMetrics Method

CXTExcelTabCtrlTheme Methods, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::RefreshMetrics Method

Call this function to refresh the flat tab control colors, position any scroll bars to their default positions, and then reset the control to the system defaults.

virtual void RefreshMetrics();
Group

CXTExcelTabCtrlTheme Methods


CXTExcelTabCtrlTheme Constructors

CXTExcelTabCtrlTheme Class, Legend, Public Methods
CXTExcelTabCtrlTheme Constructors
Class

CXTExcelTabCtrlTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTExcelTabCtrlTheme | Constructs a CXTExcelTabCtrlTheme object.


CXTExcelTabCtrlTheme::CXTExcelTabCtrlTheme Constructor

CXTExcelTabCtrlTheme Constructors, CXTExcelTabCtrlTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlTheme::CXTExcelTabCtrlTheme Constructor

Constructs a CXTExcelTabCtrlTheme object.

CXTExcelTabCtrlTheme();
Group

CXTExcelTabCtrlTheme Constructors


CXTExcelTabCtrlTheme Destructors

CXTExcelTabCtrlTheme Class, Legend, Public Methods
CXTExcelTabCtrlTheme Destructors
Class

CXTExcelTabCtrlTheme Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTExcelTabCtrlTheme | Destroys a CXTExcelTabCtrlTheme object, handles cleanup and deallocation.


CXTExcelTabCtrlTheme::~CXTExcelTabCtrlTheme Destructor

CXTExcelTabCtrlTheme Destructors, CXTExcelTabCtrlTheme Class
CXTExcelTabCtrlTheme::~CXTExcelTabCtrlTheme Destructor

Destroys a CXTExcelTabCtrlTheme object, handles cleanup and deallocation.

~CXTExcelTabCtrlTheme();
Group

CXTExcelTabCtrlTheme Destructors


CXTExcelTabCtrlThemeOffice2003 Class

XTExcelTabCtrlTheme.h, Classes
CXTExcelTabCtrlThemeOffice2003 Class

CXTExcelTabCtrlThemeOffice2003 is used to draw the CXTExcelTabCtrl object.

Class Hierarchy

class CXTExcelTabCtrlThemeOffice2003 : public CXTExcelTabCtrlThemeOfficeXP;
File

XTExcelTabCtrlTheme.h

Group

Classes


CXTExcelTabCtrlThemeOfficeXP Class

XTExcelTabCtrlTheme.h, Classes, Legend, Members, Topics, CXTExcelTabCtrlThemeOfficeXP Methods, CXTExcelTabCtrlThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlThemeOfficeXP Class

CXTExcelTabCtrlThemeOfficeXP is used to draw the CXTExcelTabCtrl object.

Class Hierarchy

class CXTExcelTabCtrlThemeOfficeXP : public CXTExcelTabCtrlTheme;
File

XTExcelTabCtrlTheme.h

Group

Classes

Legend
Method
virtual
CXTExcelTabCtrlThemeOfficeXP Methods
CXTExcelTabCtrlThemeOfficeXP Methods | Description
DrawButtonBack | Call this member function to draw the background of the button.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTExcelTabCtrlThemeOfficeXP Methods

CXTExcelTabCtrlThemeOfficeXP Class, Legend, Public Methods
CXTExcelTabCtrlThemeOfficeXP Methods
Class

CXTExcelTabCtrlThemeOfficeXP Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawButtonBack | Call this member function to draw the background of the button.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.


CXTExcelTabCtrlThemeOfficeXP::DrawButtonBack Method

CXTExcelTabCtrlThemeOfficeXP Methods, CXTExcelTabCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlThemeOfficeXP::DrawButtonBack Method

Call this member function to draw the background of the button.

virtual void DrawButtonBack(
    CDC* pDC,
    CRect& rect,
    CXTExcelTabCtrlButtonState& state
);
Parameters

pDC
A pointer to a valid device context.
rect
A CRect object that contains the location and the dimensions of the button.
state
A CXTExcelTabCtrlButtonState that contains the current state of the button.

Group

CXTExcelTabCtrlThemeOfficeXP Methods


CXTExcelTabCtrlThemeOfficeXP::RefreshMetrics Method

CXTExcelTabCtrlThemeOfficeXP Methods, CXTExcelTabCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTExcelTabCtrlThemeOfficeXP::RefreshMetrics Method

This member function is called by the theme manager to refresh the visual styles used by each components theme.

virtual void RefreshMetrics();
Group

CXTExcelTabCtrlThemeOfficeXP Methods


CXTFlatComboBox Class

XTFlatComboBox.h, Classes, Legend, Members, Topics, CXTFlatComboBox Data Members, CXTFlatComboBox Methods, CXTFlatComboBox Constructors, CXTFlatComboBox Destructors, CXTFlatComboBox Constructors, CXTFlatComboBox Data Members, CXTFlatComboBox Destructors, CXTFlatComboBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBox Class

CXTFlatComboBox is a CComboBox derived class. The CXTFlatComboBox class can easily give your application's standard CComboBox control the Flat Look that is seen in many of the Microsoft(r) Office(tm) products.

Class Hierarchy

class CXTFlatComboBox : public CComboBox;
File

XTFlatComboBox.h

Remarks

To use the control, use Class Wizard to add the CComboBox member variable ( Class Wizard -> Member Variables Tab -> Add Variable) and rename CComboBox to CXTFlatComboBox.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTFlatComboBox Constructors
CXTFlatComboBox Constructors | Description
CXTFlatComboBox | Constructs a CXTFlatComboBox object
CXTFlatComboBox Data Members
CXTFlatComboBox Data Members | Description
m_bAutoComp | Used by Auto completing.
m_bDisableAC | TRUE when auto complete is disabled internally.
m_bFlatLook | TRUE if the control is flat.
m_bHasFocus | TRUE if the control has the focus.
m_bPainted | Used during paint operations.
m_crBack | RGB color value representing background color.
m_crText | RGB color value representing text color.
m_nStyle | Stores the standard window styles for the control.
m_nStyleEx | Stores the extended window styles for the control.
CXTFlatComboBox Destructors
CXTFlatComboBox Destructors | Description
~CXTFlatComboBox | Destroys a CXTFlatComboBox object, handles cleanup and deallocation
CXTFlatComboBox Methods
CXTFlatComboBox Methods | Description
CalcClientRect | This member function is called to determine the actual client area for the CXTFlatComboBox control. The actual client area is the display area excluding borders and drop arrow box.
DisableFlatLook | This member function will disable the flat look for the CXTFlatComboBox.
DoPaint | A helper for rendering the control appearance.
DrawCombo | This member function is called by the CXTFlatComboBox whenever a paint operation should occur.
EnableAutoCompletion | This member function enables or disables auto completion.
GetBackColor | Call this member function to retrieve the background color for the CXTFlatComboBox.
GetTextColor | Call this member function to retrieve the text color for the CXTFlatComboBox.
IsFlat | Call this member function to determine if the appearance of the CXTFlatComboBox control is flat.
IsFocused | Call this member function to determine if the control has the focus.
PointInRect | This member function determines if the mouse is within the control's rect.
SetBackColor | Call this member function to set the background color for the CXTFlatComboBox control.
SetTextColor | Call this member function to set the text color for the CXTFlatComboBox control.


CXTFlatComboBox Data Members

CXTFlatComboBox Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBox Data Members
Class

CXTFlatComboBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bHasFocus | TRUE if the control has the focus.
m_bPainted | Used during paint operations.
m_crBack | RGB color value representing background color.
m_crText | RGB color value representing text color.
m_nStyle | Stores the standard window styles for the control.
m_nStyleEx | Stores the extended window styles for the control.
Public Data Members
Public Data Member | Description
m_bAutoComp | Used by Auto completing.
m_bDisableAC | TRUE when auto complete is disabled internally.
m_bFlatLook | TRUE if the control is flat.


CXTFlatComboBox::m_bAutoComp Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_bAutoComp Data Member

Used by Auto completing.

BOOL m_bAutoComp;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox::m_bDisableAC Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_bDisableAC Data Member

TRUE when auto complete is disabled internally.

BOOL m_bDisableAC;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox::m_bFlatLook Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_bFlatLook Data Member

TRUE if the control is flat.

BOOL m_bFlatLook;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox::m_bHasFocus Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_bHasFocus Data Member

TRUE if the control has the focus.

BOOL m_bHasFocus;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox::m_bPainted Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_bPainted Data Member

Used during paint operations.

BOOL m_bPainted;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox::m_crBack Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_crBack Data Member

RGB color value representing background color.

COLORREF m_crBack;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox::m_crText Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_crText Data Member

RGB color value representing text color.

COLORREF m_crText;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox::m_nStyle Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_nStyle Data Member

Stores the standard window styles for the control.

DWORD m_nStyle;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox::m_nStyleEx Data Member

CXTFlatComboBox Data Members, CXTFlatComboBox Class
CXTFlatComboBox::m_nStyleEx Data Member

Stores the extended window styles for the control.

DWORD m_nStyleEx;
Group

CXTFlatComboBox Data Members


CXTFlatComboBox Methods

CXTFlatComboBox Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBox Methods
Class

CXTFlatComboBox Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalcClientRect | This member function is called to determine the actual client area for the CXTFlatComboBox control. The actual client area is the display area excluding borders and drop arrow box.
DoPaint | A helper for rendering the control appearance.
DrawCombo | This member function is called by the CXTFlatComboBox whenever a paint operation should occur.
Public Methods
Public Methods
Public Method | Description
DisableFlatLook | This member function will disable the flat look for the CXTFlatComboBox.
EnableAutoCompletion | This member function enables or disables auto completion.
GetBackColor | Call this member function to retrieve the background color for the CXTFlatComboBox.
GetTextColor | Call this member function to retrieve the text color for the CXTFlatComboBox.
IsFlat | Call this member function to determine if the appearance of the CXTFlatComboBox control is flat.
IsFocused | Call this member function to determine if the control has the focus.
PointInRect | This member function determines if the mouse is within the control's rect.
SetBackColor | Call this member function to set the background color for the CXTFlatComboBox control.
SetTextColor | Call this member function to set the text color for the CXTFlatComboBox control.


CXTFlatComboBox::CalcClientRect Method

CXTFlatComboBox Methods, CXTFlatComboBox Class
CXTFlatComboBox::CalcClientRect Method

This member function is called to determine the actual client area for the CXTFlatComboBox control. The actual client area is the display area excluding borders and drop arrow box.

virtual void CalcClientRect(
    CRect& rc
);
Parameters

rc
Reference to a CRect object to receive client coordinates.

Group

CXTFlatComboBox Methods


CXTFlatComboBox::DisableFlatLook Method

CXTFlatComboBox Methods, CXTFlatComboBox Class
CXTFlatComboBox::DisableFlatLook Method

This member function will disable the flat look for the CXTFlatComboBox.

void DisableFlatLook(
    BOOL bDisable
);
Parameters

bDisable
TRUE to disable flat appearance.

Group

CXTFlatComboBox Methods


CXTFlatComboBox::DoPaint Method

CXTFlatComboBox Methods, CXTFlatComboBox Class
CXTFlatComboBox::DoPaint Method

A helper for rendering the control appearance.

virtual void DoPaint(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context

Group

CXTFlatComboBox Methods


CXTFlatComboBox::DrawCombo Method

CXTFlatComboBox Methods, CXTFlatComboBox Class, See Also
CXTFlatComboBox::DrawCombo Method

This member function is called by the CXTFlatComboBox whenever a paint operation should occur.

virtual void DrawCombo(
    CDC* pDC,
    XTMouseState eState
);
Parameters

pDC
Points to the current device context.
eState
Current state of the CXTFlatComboBox, either xtMouseNormal, xtMouseHover, or xtMouseSelect.

See Also

XTMouseState

Group

CXTFlatComboBox Methods


CXTFlatComboBox::EnableAutoCompletion Method

CXTFlatComboBox Methods, CXTFlatComboBox Class, Body Source
CXTFlatComboBox::EnableAutoCompletion Method

This member function enables or disables auto completion.

virtual void EnableAutoCompletion(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable auto completion, otherwise FALSE.

Body Source
void CXTFlatComboBox::EnableAutoCompletion(BOOL bEnable/*=TRUE*/) {
    m_bAutoComp = bEnable;
}
Group

CXTFlatComboBox Methods


CXTFlatComboBox::GetBackColor Method

CXTFlatComboBox Methods, CXTFlatComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBox::GetBackColor Method

Call this member function to retrieve the background color for the CXTFlatComboBox.

COLORREF GetBackColor() const;
Returns

An RGB color value representing the background color for the CXTFlatComboBox.

See Also

SetTextColor, SetBackColor, GetTextColor

Body Source
COLORREF GetBackColor() const {
    return (m_crBack == COLORREF_NULL) ? GetXtremeColor(COLOR_WINDOW) : m_crBack;
}
Group

CXTFlatComboBox Methods


CXTFlatComboBox::GetTextColor Method

CXTFlatComboBox Methods, CXTFlatComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBox::GetTextColor Method

Call this member function to retrieve the text color for the CXTFlatComboBox.

COLORREF GetTextColor() const;
Returns

An RGB color value representing the text color for the CXTFlatComboBox.

See Also

SetTextColor, SetBackColor, GetBackColor

Body Source
COLORREF GetTextColor() const {
    return (m_crText == COLORREF_NULL) ? GetXtremeColor(COLOR_WINDOWTEXT) : m_crText;
}
Group

CXTFlatComboBox Methods


CXTFlatComboBox::IsFlat Method

CXTFlatComboBox Methods, CXTFlatComboBox Class, Body Source
CXTFlatComboBox::IsFlat Method

Call this member function to determine if the appearance of the CXTFlatComboBox control is flat.

BOOL IsFlat();
Returns

TRUE if the control is flat, otherwise returns FALSE.

Body Source
BOOL CXTFlatComboBox::IsFlat() {
    return m_bFlatLook;
}
Group

CXTFlatComboBox Methods


CXTFlatComboBox::IsFocused Method

CXTFlatComboBox Methods, CXTFlatComboBox Class, Body Source
CXTFlatComboBox::IsFocused Method

Call this member function to determine if the control has the focus.

virtual BOOL IsFocused() const;
Returns

TRUE if the control has the focus. FALSE otherwise.

Body Source
BOOL CXTFlatComboBox::IsFocused() const {
    return m_bHasFocus;
}
Group

CXTFlatComboBox Methods


CXTFlatComboBox::PointInRect Method

CXTFlatComboBox Methods, CXTFlatComboBox Class
CXTFlatComboBox::PointInRect Method

This member function determines if the mouse is within the control's rect.

virtual BOOL PointInRect();
Returns

TRUE if the mouse is over the CXTFlatComboBox, otherwise returns FALSE.

Group

CXTFlatComboBox Methods


CXTFlatComboBox::SetBackColor Method

CXTFlatComboBox Methods, CXTFlatComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBox::SetBackColor Method

Call this member function to set the background color for the CXTFlatComboBox control.

virtual void SetBackColor(
    COLORREF crBack
);
Parameters

crBack
RGB value representing background color.

See Also

SetTextColor, GetBackColor, GetTextColor

Body Source
virtual void SetBackColor(COLORREF crBack) {
    m_crBack = crBack;
}
Group

CXTFlatComboBox Methods


CXTFlatComboBox::SetTextColor Method

CXTFlatComboBox Methods, CXTFlatComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBox::SetTextColor Method

Call this member function to set the text color for the CXTFlatComboBox control.

virtual void SetTextColor(
    COLORREF crText
);
Parameters

crText
RGB value representing text color.

See Also

SetBackColor, GetBackColor, GetTextColor

Body Source
virtual void SetTextColor(COLORREF crText) {
    m_crText = crText;
}
Group

CXTFlatComboBox Methods


CXTFlatComboBox Constructors

CXTFlatComboBox Class, Legend, Public Methods
CXTFlatComboBox Constructors
Class

CXTFlatComboBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatComboBox | Constructs a CXTFlatComboBox object


CXTFlatComboBox::CXTFlatComboBox Constructor

CXTFlatComboBox Constructors, CXTFlatComboBox Class
CXTFlatComboBox::CXTFlatComboBox Constructor

Constructs a CXTFlatComboBox object

CXTFlatComboBox();
Group

CXTFlatComboBox Constructors


CXTFlatComboBox Destructors

CXTFlatComboBox Class, Legend, Public Methods
CXTFlatComboBox Destructors
Class

CXTFlatComboBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTFlatComboBox | Destroys a CXTFlatComboBox object, handles cleanup and deallocation


CXTFlatComboBox::~CXTFlatComboBox Destructor

CXTFlatComboBox Destructors, CXTFlatComboBox Class
CXTFlatComboBox::~CXTFlatComboBox Destructor

Destroys a CXTFlatComboBox object, handles cleanup and deallocation

virtual ~CXTFlatComboBox();
Group

CXTFlatComboBox Destructors


CXTFlatComboBoxTheme Class

XTFlatControlsTheme.h, Classes, Legend, Members, Topics, CXTFlatComboBoxTheme Data Members, CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Constructors, CXTFlatComboBoxTheme Constructors, CXTFlatComboBoxTheme Data Members, CXTFlatComboBoxTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme Class

CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.

Class Hierarchy

class CXTFlatComboBoxTheme : public CXTThemeManagerStyle;
File

XTFlatControlsTheme.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTFlatComboBoxTheme Constructors
CXTFlatComboBoxTheme Constructors | Description
CXTFlatComboBoxTheme | Constructs a CXTFlatComboBoxTheme object.
CXTFlatComboBoxTheme Data Members
CXTFlatComboBoxTheme Data Members | Description
m_cxArrow | This member variable contains the width of the drop down arrow.
m_sizeBorder | Stores dimensions, in pixels, of a 3-D window border.
m_sizeEdge | Stores dimensions, in pixels, of a 3-D window edge.
m_sizeThumb | Stores dimensions, in pixels, of a 3-D drop down arrow box.
CXTFlatComboBoxTheme Methods
CXTFlatComboBoxTheme Methods | Description
DrawArrowBack | Call this function to draw the background for the arrow button.
DrawDownArrow | This member function is called by the Combo Box for drawing the down arrow.
DrawFlatComboBox | Call this function to draw a Flat ComboBox.
GetBorderSize | Call this member function retrieve the dimensions, in pixels, of a 3-D window border.
GetDropArrowWidth | Call this member function to get the width of the drop down arrow.
GetEdgeSize | Call this member function retrieve the dimensions, in pixels, of a 3-D window edge.
GetThumbSize | Call this member function retrieve the dimensions, in pixels, of a 3-D drop down arrow box.
RefreshMetrics | This function refreshes the colors on the flat control.


CXTFlatComboBoxTheme Data Members

CXTFlatComboBoxTheme Class, Legend, Protected Data Members
CXTFlatComboBoxTheme Data Members
Class

CXTFlatComboBoxTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_cxArrow | This member variable contains the width of the drop down arrow.
m_sizeBorder | Stores dimensions, in pixels, of a 3-D window border.
m_sizeEdge | Stores dimensions, in pixels, of a 3-D window edge.
m_sizeThumb | Stores dimensions, in pixels, of a 3-D drop down arrow box.


CXTFlatComboBoxTheme::m_cxArrow Data Member

CXTFlatComboBoxTheme Data Members, CXTFlatComboBoxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::m_cxArrow Data Member

This member variable contains the width of the drop down arrow.

int m_cxArrow;
Group

CXTFlatComboBoxTheme Data Members


CXTFlatComboBoxTheme::m_sizeBorder Data Member

CXTFlatComboBoxTheme Data Members, CXTFlatComboBoxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::m_sizeBorder Data Member

Stores dimensions, in pixels, of a 3-D window border.

CSize m_sizeBorder;
Group

CXTFlatComboBoxTheme Data Members


CXTFlatComboBoxTheme::m_sizeEdge Data Member

CXTFlatComboBoxTheme Data Members, CXTFlatComboBoxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::m_sizeEdge Data Member

Stores dimensions, in pixels, of a 3-D window edge.

CSize m_sizeEdge;
Group

CXTFlatComboBoxTheme Data Members


CXTFlatComboBoxTheme::m_sizeThumb Data Member

CXTFlatComboBoxTheme Data Members, CXTFlatComboBoxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::m_sizeThumb Data Member

Stores dimensions, in pixels, of a 3-D drop down arrow box.

CSize m_sizeThumb;
Group

CXTFlatComboBoxTheme Data Members


CXTFlatComboBoxTheme Methods

CXTFlatComboBoxTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme Methods
Class

CXTFlatComboBoxTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawArrowBack | Call this function to draw the background for the arrow button.
DrawDownArrow | This member function is called by the Combo Box for drawing the down arrow.
GetDropArrowWidth | Call this member function to get the width of the drop down arrow.
Public Methods
Public Methods
Public Method | Description
DrawFlatComboBox | Call this function to draw a Flat ComboBox.
GetBorderSize | Call this member function retrieve the dimensions, in pixels, of a 3-D window border.
GetEdgeSize | Call this member function retrieve the dimensions, in pixels, of a 3-D window edge.
GetThumbSize | Call this member function retrieve the dimensions, in pixels, of a 3-D drop down arrow box.
RefreshMetrics | This function refreshes the colors on the flat control.


CXTFlatComboBoxTheme::DrawArrowBack Method

CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::DrawArrowBack Method

Call this function to draw the background for the arrow button.

virtual void DrawArrowBack(
    CDC* pDC,
    CRect& rcArrow,
    int eState,
    CXTFlatComboBox* pCombo
);
Parameters

pDC
A pointer to a valid device context.
rcArrow
A CRect object that contains the location and the dimensions of the background.
eState
An int that contains the current state for the arrow button.
pCombo
A pointer to a valid CXTFlatComboBox object.

See Also

CXTFlatComboBoxThemeOfficeXP::DrawArrowBack, CXTFlatComboBoxThemeOffice2003::DrawArrowBack

Group

CXTFlatComboBoxTheme Methods


CXTFlatComboBoxTheme::DrawDownArrow Method

CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Class
CXTFlatComboBoxTheme::DrawDownArrow Method

This member function is called by the Combo Box for drawing the down arrow.

virtual void DrawDownArrow(
    CDC* pDC,
    const CRect& rcArrow,
    int eState,
    CXTFlatComboBox* pCombo
);
Parameters

pDC
Device context for drawing.
rcArrow
A rectangle in which to draw.
eState
State of the Combo box
pCombo
Combo box to draw down arrow for

Group

CXTFlatComboBoxTheme Methods


CXTFlatComboBoxTheme::DrawFlatComboBox Method

CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Class
CXTFlatComboBoxTheme::DrawFlatComboBox Method

Call this function to draw a Flat ComboBox.

virtual void DrawFlatComboBox(
    CDC* pDC,
    CXTFlatComboBox* pCombo,
    int eState
);
Parameters

pDC
A CDC pointer that represents the current device context.
pCombo
A pointer to a CXTFlatComboBox object. Represents a flat combo box.
eState
An int that is used to specify the state of the flat combo box. Possible values are: NORMAL, RAISED, and PRESSED.

Group

CXTFlatComboBoxTheme Methods


CXTFlatComboBoxTheme::GetBorderSize Method

CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::GetBorderSize Method

Call this member function retrieve the dimensions, in pixels, of a 3-D window border.

CSize& GetBorderSize();
Returns

A reference to a CSize object that contains 3-D border dimensions.

Body Source
CSize& GetBorderSize() {
    return m_sizeBorder;
}
Group

CXTFlatComboBoxTheme Methods


CXTFlatComboBoxTheme::GetDropArrowWidth Method

CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::GetDropArrowWidth Method

Call this member function to get the width of the drop down arrow.

int GetDropArrowWidth() const;
Returns

An int that contains the width of the drop down arrow.

See Also

DrawDownArrow, DrawArrowBack

Group

CXTFlatComboBoxTheme Methods


CXTFlatComboBoxTheme::GetEdgeSize Method

CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::GetEdgeSize Method

Call this member function retrieve the dimensions, in pixels, of a 3-D window edge.

CSize& GetEdgeSize();
Returns

A reference to a CSize object that contains 3-D edge dimensions.

Body Source
CSize& GetEdgeSize() {
    return m_sizeEdge;
}
Group

CXTFlatComboBoxTheme Methods


CXTFlatComboBoxTheme::GetThumbSize Method

CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::GetThumbSize Method

Call this member function retrieve the dimensions, in pixels, of a 3-D drop down arrow box.

CSize& GetThumbSize();
Returns

A reference to a CSize object that contains 3-D border dimensions.

Body Source
CSize& GetThumbSize() {
    return m_sizeThumb;
}
Group

CXTFlatComboBoxTheme Methods


CXTFlatComboBoxTheme::RefreshMetrics Method

CXTFlatComboBoxTheme Methods, CXTFlatComboBoxTheme Class
CXTFlatComboBoxTheme::RefreshMetrics Method

This function refreshes the colors on the flat control.

virtual void RefreshMetrics();
Group

CXTFlatComboBoxTheme Methods


CXTFlatComboBoxTheme Constructors

CXTFlatComboBoxTheme Class, Legend, Public Methods
CXTFlatComboBoxTheme Constructors
Class

CXTFlatComboBoxTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatComboBoxTheme | Constructs a CXTFlatComboBoxTheme object.


CXTFlatComboBoxTheme::CXTFlatComboBoxTheme Constructor

CXTFlatComboBoxTheme Constructors, CXTFlatComboBoxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxTheme::CXTFlatComboBoxTheme Constructor

Constructs a CXTFlatComboBoxTheme object.

CXTFlatComboBoxTheme();
Group

CXTFlatComboBoxTheme Constructors


CXTFlatComboBoxThemeOffice2003 Class

XTFlatControlsTheme.h, Classes, Legend, Members, Topics, CXTFlatComboBoxThemeOffice2003 Methods, CXTFlatComboBoxThemeOffice2003 Constructors, CXTFlatComboBoxThemeOffice2003 Constructors, CXTFlatComboBoxThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOffice2003 Class

CXTFlatComboBoxThemeOffice2003 class is derived from CXTFlatComboBoxThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.

Class Hierarchy

class CXTFlatComboBoxThemeOffice2003 : public CXTFlatComboBoxThemeOfficeXP;
File

XTFlatControlsTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTFlatComboBoxThemeOffice2003 Constructors
CXTFlatComboBoxThemeOffice2003 Constructors | Description
CXTFlatComboBoxThemeOffice2003 | Constructs a CXTFlatComboBoxThemeOffice2003 object.
CXTFlatComboBoxThemeOffice2003 Methods
CXTFlatComboBoxThemeOffice2003 Methods | Description
DrawArrowBack | Call this function to draw the background for the arrow button.
DrawFlatComboBox | Call this function to draw a rectangle around a ComboBox.


CXTFlatComboBoxThemeOffice2003 Methods

CXTFlatComboBoxThemeOffice2003 Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOffice2003 Methods
Class

CXTFlatComboBoxThemeOffice2003 Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawArrowBack | Call this function to draw the background for the arrow button.
Public Methods
Public Methods
Public Method | Description
DrawFlatComboBox | Call this function to draw a rectangle around a ComboBox.


CXTFlatComboBoxThemeOffice2003::DrawArrowBack Method

CXTFlatComboBoxThemeOffice2003 Methods, CXTFlatComboBoxThemeOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOffice2003::DrawArrowBack Method

Call this function to draw the background for the arrow button.

virtual void DrawArrowBack(
    CDC* pDC,
    CRect& rcArrow,
    int eState,
    CXTFlatComboBox* pCombo
);
Parameters

pDC
A pointer to a valid device context.
rcArrow
A CRect object that contains the location and the dimensions of the background.
eState
An int that contains the current state for the arrow button.
pCombo
A pointer to a valid CXTFlatComboBox object.

See Also

CXTFlatComboBoxTheme::DrawArrowBack, CXTFlatComboBoxThemeOfficeXP::DrawArrowBack

Group

CXTFlatComboBoxThemeOffice2003 Methods


CXTFlatComboBoxThemeOffice2003::DrawFlatComboBox Method

CXTFlatComboBoxThemeOffice2003 Methods, CXTFlatComboBoxThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOffice2003::DrawFlatComboBox Method

Call this function to draw a rectangle around a ComboBox.

virtual void DrawFlatComboBox(
    CDC* pDC,
    CXTFlatComboBox* pCombo,
    int eState
);
Parameters

pDC
A CDC pointer that represents the current device context.
pCombo
A pointer to a CXTFlatComboBox object. Represents a flat combo box.
eState
An int that is used to specify the state of the flat combo box. Possible values are: NORMAL, RAISED, and PRESSED.

Group

CXTFlatComboBoxThemeOffice2003 Methods


CXTFlatComboBoxThemeOffice2003 Constructors

CXTFlatComboBoxThemeOffice2003 Class, Legend, Public Methods
CXTFlatComboBoxThemeOffice2003 Constructors
Class

CXTFlatComboBoxThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatComboBoxThemeOffice2003 | Constructs a CXTFlatComboBoxThemeOffice2003 object.


CXTFlatComboBoxThemeOffice2003::CXTFlatComboBoxThemeOffice2003 Constructor

CXTFlatComboBoxThemeOffice2003 Constructors, CXTFlatComboBoxThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOffice2003::CXTFlatComboBoxThemeOffice2003 Constructor

Constructs a CXTFlatComboBoxThemeOffice2003 object.

CXTFlatComboBoxThemeOffice2003();
Group

CXTFlatComboBoxThemeOffice2003 Constructors


CXTFlatComboBoxThemeOfficeXP Class

XTFlatControlsTheme.h, Classes, Legend, Members, Topics, CXTFlatComboBoxThemeOfficeXP Methods, CXTFlatComboBoxThemeOfficeXP Constructors, CXTFlatComboBoxThemeOfficeXP Constructors, CXTFlatComboBoxThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOfficeXP Class

CXTFlatComboBoxThemeOfficeXP class is derived from CXTFlatComboBoxTheme. This class is used to create the Office 2000 Theme for flat controls.

Class Hierarchy

class CXTFlatComboBoxThemeOfficeXP : public CXTFlatComboBoxTheme;
File

XTFlatControlsTheme.h

Group

Classes

Legend
Method
protected
virtual
CXTFlatComboBoxThemeOfficeXP Constructors
CXTFlatComboBoxThemeOfficeXP Constructors | Description
CXTFlatComboBoxThemeOfficeXP | Constructs a CXTFlatComboBoxThemeOfficeXP object.
CXTFlatComboBoxThemeOfficeXP Methods
CXTFlatComboBoxThemeOfficeXP Methods | Description
DrawArrowBack | Call this function to draw the background for the arrow button.
DrawDownArrow | This member function is called by the Combo Box for drawing the down arrow.
DrawFlatComboBox | Call this function to draw a rectangle around a ComboBox.


CXTFlatComboBoxThemeOfficeXP Methods

CXTFlatComboBoxThemeOfficeXP Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOfficeXP Methods
Class

CXTFlatComboBoxThemeOfficeXP Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawArrowBack | Call this function to draw the background for the arrow button.
DrawDownArrow | This member function is called by the Combo Box for drawing the down arrow.
Public Methods
Public Methods
Public Method | Description
DrawFlatComboBox | Call this function to draw a rectangle around a ComboBox.


CXTFlatComboBoxThemeOfficeXP::DrawArrowBack Method

CXTFlatComboBoxThemeOfficeXP Methods, CXTFlatComboBoxThemeOfficeXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOfficeXP::DrawArrowBack Method

Call this function to draw the background for the arrow button.

virtual void DrawArrowBack(
    CDC* pDC,
    CRect& rcArrow,
    int eState,
    CXTFlatComboBox* pCombo
);
Parameters

pDC
A pointer to a valid device context.
rcArrow
A CRect object that contains the location and the dimensions of the background.
eState
An int that contains the current state for the arrow button.
pCombo
A pointer to a valid CXTFlatComboBox object.

See Also

CXTFlatComboBoxTheme::DrawArrowBack, CXTFlatComboBoxThemeOffice2003::DrawArrowBack

Group

CXTFlatComboBoxThemeOfficeXP Methods


CXTFlatComboBoxThemeOfficeXP::DrawDownArrow Method

CXTFlatComboBoxThemeOfficeXP Methods, CXTFlatComboBoxThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOfficeXP::DrawDownArrow Method

This member function is called by the Combo Box for drawing the down arrow.

virtual void DrawDownArrow(
    CDC* pDC,
    const CRect& rcArrow,
    int eState,
    CXTFlatComboBox* pCombo
);
Parameters

pDC
Device context for drawing.
rcArrow
A rectangle in which to draw.
eState
State of the Combo box
pCombo
Combo box to draw down arrow for

Group

CXTFlatComboBoxThemeOfficeXP Methods


CXTFlatComboBoxThemeOfficeXP::DrawFlatComboBox Method

CXTFlatComboBoxThemeOfficeXP Methods, CXTFlatComboBoxThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOfficeXP::DrawFlatComboBox Method

Call this function to draw a rectangle around a ComboBox.

virtual void DrawFlatComboBox(
    CDC* pDC,
    CXTFlatComboBox* pCombo,
    int eState
);
Parameters

pDC
A CDC pointer that represents the current device context.
pCombo
A pointer to a CXTFlatComboBox object. Represents a flat combo box.
eState
An int that is used to specify the state of the flat combo box. Possible values are: NORMAL, RAISED, and PRESSED.

Group

CXTFlatComboBoxThemeOfficeXP Methods


CXTFlatComboBoxThemeOfficeXP Constructors

CXTFlatComboBoxThemeOfficeXP Class, Legend, Public Methods
CXTFlatComboBoxThemeOfficeXP Constructors
Class

CXTFlatComboBoxThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatComboBoxThemeOfficeXP | Constructs a CXTFlatComboBoxThemeOfficeXP object.


CXTFlatComboBoxThemeOfficeXP::CXTFlatComboBoxThemeOfficeXP Constructor

CXTFlatComboBoxThemeOfficeXP Constructors, CXTFlatComboBoxThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatComboBoxThemeOfficeXP::CXTFlatComboBoxThemeOfficeXP Constructor

Constructs a CXTFlatComboBoxThemeOfficeXP object.

CXTFlatComboBoxThemeOfficeXP();
Group

CXTFlatComboBoxThemeOfficeXP Constructors


CXTFlatEdit Class

XTFlatComboBox.h, Classes, Legend, Members, Topics, CXTFlatEdit Data Members, CXTFlatEdit Methods, CXTFlatEdit Constructors, CXTFlatEdit Destructors, CXTFlatEdit Constructors, CXTFlatEdit Data Members, CXTFlatEdit Destructors, CXTFlatEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEdit Class

CXTFlatEdit is a CXTEdit derived class. The CXTFlatEdit class can easily give your application's standard CEdit control the flat look that is seen in many of the Microsoft(r) Office(tm) products.

Class Hierarchy

class CXTFlatEdit : public CXTEdit;
File

XTFlatComboBox.h

Remarks

To use the control, use Class Wizard to add the CEdit member variable (Class Wizard -> Member Variables Tab -> Add Variable) and rename CEdit to CXTFlatEdit.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTFlatEdit Constructors
CXTFlatEdit Constructors | Description
CXTFlatEdit | Constructs a CXTFlatEdit object
CXTFlatEdit Data Members
CXTFlatEdit Data Members | Description
m_bFlatLook | TRUE if the control is flat.
m_bHasFocus | TRUE if the control has focus.
m_bPainted | Used during paint operations.
m_nStyle | Stores the standard window styles for the control.
m_nStyleEx | Stores the extended window styles for the control.
CXTFlatEdit Destructors
CXTFlatEdit Destructors | Description
~CXTFlatEdit | Destroys a CXTFlatEdit object, handles cleanup and deallocation
CXTFlatEdit Methods
CXTFlatEdit Methods | Description
DisableFlatLook | This member function will disable the flat look for the edit control.
DrawBorders | This member function is called by the edit control whenever a paint operation should occur.
IsFlat | Call this member function to determine if the appearance of the edit control is flat.
PointInRect | This member function determines if the mouse is within the control's rect.


CXTFlatEdit Data Members

CXTFlatEdit Class, Legend, Protected Data Members
CXTFlatEdit Data Members
Class

CXTFlatEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bFlatLook | TRUE if the control is flat.
m_bHasFocus | TRUE if the control has focus.
m_bPainted | Used during paint operations.
m_nStyle | Stores the standard window styles for the control.
m_nStyleEx | Stores the extended window styles for the control.


CXTFlatEdit::m_bFlatLook Data Member

CXTFlatEdit Data Members, CXTFlatEdit Class
CXTFlatEdit::m_bFlatLook Data Member

TRUE if the control is flat.

BOOL m_bFlatLook;
Group

CXTFlatEdit Data Members


CXTFlatEdit::m_bHasFocus Data Member

CXTFlatEdit Data Members, CXTFlatEdit Class
CXTFlatEdit::m_bHasFocus Data Member

TRUE if the control has focus.

BOOL m_bHasFocus;
Group

CXTFlatEdit Data Members


CXTFlatEdit::m_bPainted Data Member

CXTFlatEdit Data Members, CXTFlatEdit Class
CXTFlatEdit::m_bPainted Data Member

Used during paint operations.

BOOL m_bPainted;
Group

CXTFlatEdit Data Members


CXTFlatEdit::m_nStyle Data Member

CXTFlatEdit Data Members, CXTFlatEdit Class
CXTFlatEdit::m_nStyle Data Member

Stores the standard window styles for the control.

DWORD m_nStyle;
Group

CXTFlatEdit Data Members


CXTFlatEdit::m_nStyleEx Data Member

CXTFlatEdit Data Members, CXTFlatEdit Class
CXTFlatEdit::m_nStyleEx Data Member

Stores the extended window styles for the control.

DWORD m_nStyleEx;
Group

CXTFlatEdit Data Members


CXTFlatEdit Methods

CXTFlatEdit Class, Legend, Protected Methods, Public Methods
CXTFlatEdit Methods
Class

CXTFlatEdit Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawBorders | This member function is called by the edit control whenever a paint operation should occur.
Public Methods
Public Methods
Public Method | Description
DisableFlatLook | This member function will disable the flat look for the edit control.
IsFlat | Call this member function to determine if the appearance of the edit control is flat.
PointInRect | This member function determines if the mouse is within the control's rect.


CXTFlatEdit::DisableFlatLook Method

CXTFlatEdit Methods, CXTFlatEdit Class
CXTFlatEdit::DisableFlatLook Method

This member function will disable the flat look for the edit control.

void DisableFlatLook(
    BOOL bDisable
);
Parameters

bDisable
TRUE to disable the flat appearance.

Group

CXTFlatEdit Methods


CXTFlatEdit::DrawBorders Method

CXTFlatEdit Methods, CXTFlatEdit Class, See Also
CXTFlatEdit::DrawBorders Method

This member function is called by the edit control whenever a paint operation should occur.

virtual void DrawBorders(
    CDC* pDC,
    const CRect& rWindow
);
Parameters

pDC
Points to the current device context.
rWindow
Area to render.

See Also

XTMouseState

Group

CXTFlatEdit Methods


CXTFlatEdit::IsFlat Method

CXTFlatEdit Methods, CXTFlatEdit Class, Body Source
CXTFlatEdit::IsFlat Method

Call this member function to determine if the appearance of the edit control is flat.

BOOL IsFlat();
Returns

TRUE if the control is flat, otherwise returns FALSE.

Body Source
BOOL CXTFlatEdit::IsFlat() {
    return m_bFlatLook;
}
Group

CXTFlatEdit Methods


CXTFlatEdit::PointInRect Method

CXTFlatEdit Methods, CXTFlatEdit Class
CXTFlatEdit::PointInRect Method

This member function determines if the mouse is within the control's rect.

virtual BOOL PointInRect();
Returns

TRUE if the mouse is over the edit box, otherwise returns FALSE.

Group

CXTFlatEdit Methods


CXTFlatEdit Constructors

CXTFlatEdit Class, Legend, Public Methods
CXTFlatEdit Constructors
Class

CXTFlatEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatEdit | Constructs a CXTFlatEdit object


CXTFlatEdit::CXTFlatEdit Constructor

CXTFlatEdit Constructors, CXTFlatEdit Class
CXTFlatEdit::CXTFlatEdit Constructor

Constructs a CXTFlatEdit object

CXTFlatEdit();
Group

CXTFlatEdit Constructors


CXTFlatEdit Destructors

CXTFlatEdit Class, Legend, Public Methods
CXTFlatEdit Destructors
Class

CXTFlatEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTFlatEdit | Destroys a CXTFlatEdit object, handles cleanup and deallocation


CXTFlatEdit::~CXTFlatEdit Destructor

CXTFlatEdit Destructors, CXTFlatEdit Class
CXTFlatEdit::~CXTFlatEdit Destructor

Destroys a CXTFlatEdit object, handles cleanup and deallocation

virtual ~CXTFlatEdit();
Group

CXTFlatEdit Destructors


CXTFlatEditTheme Class

XTFlatControlsTheme.h, Classes, Legend, Members, Topics, CXTFlatEditTheme Methods, CXTFlatEditTheme Constructors, CXTFlatEditTheme Constructors, CXTFlatEditTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditTheme Class

CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.

Class Hierarchy

class CXTFlatEditTheme : public CXTThemeManagerStyle;
File

XTFlatControlsTheme.h

Group

Classes

Legend
Method
virtual
CXTFlatEditTheme Constructors
CXTFlatEditTheme Constructors | Description
CXTFlatEditTheme | Constructs a CXTFlatEditTheme object.
CXTFlatEditTheme Methods
CXTFlatEditTheme Methods | Description
DrawBorders | Call this function to draw a rectangle around an EditBox.
RefreshMetrics | This function refreshes the colors on the flat control.


CXTFlatEditTheme Methods

CXTFlatEditTheme Class, Legend, Public Methods
CXTFlatEditTheme Methods
Class

CXTFlatEditTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBorders | Call this function to draw a rectangle around an EditBox.
RefreshMetrics | This function refreshes the colors on the flat control.


CXTFlatEditTheme::DrawBorders Method

CXTFlatEditTheme Methods, CXTFlatEditTheme Class
CXTFlatEditTheme::DrawBorders Method

Call this function to draw a rectangle around an EditBox.

virtual void DrawBorders(
    CDC* pDC,
    CXTFlatEdit* pEdit,
    const CRect& rWindow,
    int eState
);
Parameters

pDC
A CDC pointer that represents the current device context.
pEdit
A pointer to an edit box control.
rWindow
Area to render.
eState
An int that is used to specify the state of the flat edit box.

Group

CXTFlatEditTheme Methods


CXTFlatEditTheme::RefreshMetrics Method

CXTFlatEditTheme Methods, CXTFlatEditTheme Class
CXTFlatEditTheme::RefreshMetrics Method

This function refreshes the colors on the flat control.

virtual void RefreshMetrics();
Group

CXTFlatEditTheme Methods


CXTFlatEditTheme Constructors

CXTFlatEditTheme Class, Legend, Public Methods
CXTFlatEditTheme Constructors
Class

CXTFlatEditTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatEditTheme | Constructs a CXTFlatEditTheme object.


CXTFlatEditTheme::CXTFlatEditTheme Constructor

CXTFlatEditTheme Constructors, CXTFlatEditTheme Class
CXTFlatEditTheme::CXTFlatEditTheme Constructor

Constructs a CXTFlatEditTheme object.

CXTFlatEditTheme();
Group

CXTFlatEditTheme Constructors


CXTFlatEditThemeOffice2003 Class

XTFlatControlsTheme.h, Classes, Legend, Members, Topics, CXTFlatEditThemeOffice2003 Methods, CXTFlatEditThemeOffice2003 Constructors, CXTFlatEditThemeOffice2003 Constructors, CXTFlatEditThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOffice2003 Class

CXTFlatEditThemeOffice2003 class is derived from CXTFlatEditThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.

Class Hierarchy

class CXTFlatEditThemeOffice2003 : public CXTFlatEditThemeOfficeXP;
File

XTFlatControlsTheme.h

Group

Classes

Legend
Method
virtual
CXTFlatEditThemeOffice2003 Constructors
CXTFlatEditThemeOffice2003 Constructors | Description
CXTFlatEditThemeOffice2003 | Constructs a CXTFlatEditThemeOffice2003 object.
CXTFlatEditThemeOffice2003 Methods
CXTFlatEditThemeOffice2003 Methods | Description
DrawBorders | This member function is called to render the flat edit control using the specified theme.
RefreshMetrics | This function is called to refresh the colors of the flat controls Office 2003 theme.


CXTFlatEditThemeOffice2003 Methods

CXTFlatEditThemeOffice2003 Class, Legend, Public Methods
CXTFlatEditThemeOffice2003 Methods
Class

CXTFlatEditThemeOffice2003 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBorders | This member function is called to render the flat edit control using the specified theme.
RefreshMetrics | This function is called to refresh the colors of the flat controls Office 2003 theme.


CXTFlatEditThemeOffice2003::DrawBorders Method

CXTFlatEditThemeOffice2003 Methods, CXTFlatEditThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOffice2003::DrawBorders Method

This member function is called to render the flat edit control using the specified theme.

virtual void DrawBorders(
    CDC* pDC,
    CXTFlatEdit* pEdit,
    const CRect& rWindow,
    int eState
);
Parameters

pDC
A CDC pointer that represents the current device context.
pEdit
A pointer to an edit box control.
rWindow
Area to render.
eState
An int that is used to specify the state of the flat edit box.

Group

CXTFlatEditThemeOffice2003 Methods


CXTFlatEditThemeOffice2003::RefreshMetrics Method

CXTFlatEditThemeOffice2003 Methods, CXTFlatEditThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOffice2003::RefreshMetrics Method

This function is called to refresh the colors of the flat controls Office 2003 theme.

virtual void RefreshMetrics();
Group

CXTFlatEditThemeOffice2003 Methods


CXTFlatEditThemeOffice2003 Constructors

CXTFlatEditThemeOffice2003 Class, Legend, Public Methods
CXTFlatEditThemeOffice2003 Constructors
Class

CXTFlatEditThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatEditThemeOffice2003 | Constructs a CXTFlatEditThemeOffice2003 object.


CXTFlatEditThemeOffice2003::CXTFlatEditThemeOffice2003 Constructor

CXTFlatEditThemeOffice2003 Constructors, CXTFlatEditThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOffice2003::CXTFlatEditThemeOffice2003 Constructor

Constructs a CXTFlatEditThemeOffice2003 object.

CXTFlatEditThemeOffice2003();
Group

CXTFlatEditThemeOffice2003 Constructors


CXTFlatEditThemeOfficeXP Class

XTFlatControlsTheme.h, Classes, Legend, Members, Topics, CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Methods, CXTFlatEditThemeOfficeXP Constructors, CXTFlatEditThemeOfficeXP Constructors, CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP Class

CXTFlatEditThemeOfficeXP class is derived from CXTFlatEditTheme. This class is used to create the Office 2000 Theme for flat controls.

Class Hierarchy

class CXTFlatEditThemeOfficeXP : public CXTFlatEditTheme;
File

XTFlatControlsTheme.h

Group

Classes

Legend
Data Member
Method
virtual
CXTFlatEditThemeOfficeXP Constructors
CXTFlatEditThemeOfficeXP Constructors | Description
CXTFlatEditThemeOfficeXP | Constructs a CXTFlatEditThemeOfficeXP object.
CXTFlatEditThemeOfficeXP Data Members
CXTFlatEditThemeOfficeXP Data Members | Description
m_clrFrameEdit | Used to specify the color an edit frame.
m_clrFrameHighlight | Used to specify the color a highlighted frame.
m_clrFrameNormal | Used to specify the color a normal frame.
m_clrHighlight | Used to specify the color a highlighted object.
m_clrHighlightText | Used to specify the color of highlighted text.
m_clrNormal | Used to specify the color a normal object.
m_clrPushed | Used to specify the color a pushed object.
m_clrPushedText | Used to specify the color of pushed text.
CXTFlatEditThemeOfficeXP Methods
CXTFlatEditThemeOfficeXP Methods | Description
DrawBorders | This member function is called to render the flat edit control using the specified theme.
RefreshMetrics | This function is called to refresh the colors of the flat controls Office XP theme.


CXTFlatEditThemeOfficeXP Data Members

CXTFlatEditThemeOfficeXP Class, Legend, Public Data Members
CXTFlatEditThemeOfficeXP Data Members
Class

CXTFlatEditThemeOfficeXP Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrFrameEdit | Used to specify the color an edit frame.
m_clrFrameHighlight | Used to specify the color a highlighted frame.
m_clrFrameNormal | Used to specify the color a normal frame.
m_clrHighlight | Used to specify the color a highlighted object.
m_clrHighlightText | Used to specify the color of highlighted text.
m_clrNormal | Used to specify the color a normal object.
m_clrPushed | Used to specify the color a pushed object.
m_clrPushedText | Used to specify the color of pushed text.


CXTFlatEditThemeOfficeXP::m_clrFrameEdit Data Member

CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::m_clrFrameEdit Data Member

Used to specify the color an edit frame.

CXTPPaintManagerColor m_clrFrameEdit;
Group

CXTFlatEditThemeOfficeXP Data Members


CXTFlatEditThemeOfficeXP::m_clrFrameHighlight Data Member

CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::m_clrFrameHighlight Data Member

Used to specify the color a highlighted frame.

CXTPPaintManagerColor m_clrFrameHighlight;
Group

CXTFlatEditThemeOfficeXP Data Members


CXTFlatEditThemeOfficeXP::m_clrFrameNormal Data Member

CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::m_clrFrameNormal Data Member

Used to specify the color a normal frame.

CXTPPaintManagerColor m_clrFrameNormal;
Group

CXTFlatEditThemeOfficeXP Data Members


CXTFlatEditThemeOfficeXP::m_clrHighlight Data Member

CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::m_clrHighlight Data Member

Used to specify the color a highlighted object.

CXTPPaintManagerColor m_clrHighlight;
Group

CXTFlatEditThemeOfficeXP Data Members


CXTFlatEditThemeOfficeXP::m_clrHighlightText Data Member

CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::m_clrHighlightText Data Member

Used to specify the color of highlighted text.

CXTPPaintManagerColor m_clrHighlightText;
Group

CXTFlatEditThemeOfficeXP Data Members


CXTFlatEditThemeOfficeXP::m_clrNormal Data Member

CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::m_clrNormal Data Member

Used to specify the color a normal object.

CXTPPaintManagerColor m_clrNormal;
Group

CXTFlatEditThemeOfficeXP Data Members


CXTFlatEditThemeOfficeXP::m_clrPushed Data Member

CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::m_clrPushed Data Member

Used to specify the color a pushed object.

CXTPPaintManagerColor m_clrPushed;
Group

CXTFlatEditThemeOfficeXP Data Members


CXTFlatEditThemeOfficeXP::m_clrPushedText Data Member

CXTFlatEditThemeOfficeXP Data Members, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::m_clrPushedText Data Member

Used to specify the color of pushed text.

CXTPPaintManagerColor m_clrPushedText;
Group

CXTFlatEditThemeOfficeXP Data Members


CXTFlatEditThemeOfficeXP Methods

CXTFlatEditThemeOfficeXP Class, Legend, Public Methods
CXTFlatEditThemeOfficeXP Methods
Class

CXTFlatEditThemeOfficeXP Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBorders | This member function is called to render the flat edit control using the specified theme.
RefreshMetrics | This function is called to refresh the colors of the flat controls Office XP theme.


CXTFlatEditThemeOfficeXP::DrawBorders Method

CXTFlatEditThemeOfficeXP Methods, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::DrawBorders Method

This member function is called to render the flat edit control using the specified theme.

virtual void DrawBorders(
    CDC* pDC,
    CXTFlatEdit* pEdit,
    const CRect& rWindow,
    int eState
);
Parameters

pDC
A CDC pointer that represents the current device context.
pEdit
A pointer to an edit box control.
rWindow
Area to render.
eState
An int that is used to specify the state of the flat edit box.

Group

CXTFlatEditThemeOfficeXP Methods


CXTFlatEditThemeOfficeXP::RefreshMetrics Method

CXTFlatEditThemeOfficeXP Methods, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::RefreshMetrics Method

This function is called to refresh the colors of the flat controls Office XP theme.

virtual void RefreshMetrics();
Group

CXTFlatEditThemeOfficeXP Methods


CXTFlatEditThemeOfficeXP Constructors

CXTFlatEditThemeOfficeXP Class, Legend, Public Methods
CXTFlatEditThemeOfficeXP Constructors
Class

CXTFlatEditThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatEditThemeOfficeXP | Constructs a CXTFlatEditThemeOfficeXP object.


CXTFlatEditThemeOfficeXP::CXTFlatEditThemeOfficeXP Constructor

CXTFlatEditThemeOfficeXP Constructors, CXTFlatEditThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatEditThemeOfficeXP::CXTFlatEditThemeOfficeXP Constructor

Constructs a CXTFlatEditThemeOfficeXP object.

CXTFlatEditThemeOfficeXP();
Group

CXTFlatEditThemeOfficeXP Constructors


CXTFlatHeaderCtrl Class

XTHeaderCtrl.h, Classes, Legend, Members, Topics, CXTFlatHeaderCtrl Constructors, CXTFlatHeaderCtrl Destructors, CXTFlatHeaderCtrl Constructors, CXTFlatHeaderCtrl Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFlatHeaderCtrl Class

CXTFlatHeaderCtrl is a CHeaderCtrl derived class. It is used to create list box flat header controls that are similar to list box flat header controls seen in Visual Studio(tm) and Outlook(tm).

Class Hierarchy

class CXTFlatHeaderCtrl : public CXTHeaderCtrl;
File

XTHeaderCtrl.h

Group

Classes

Legend
Constructor
virtual
CXTFlatHeaderCtrl Constructors
CXTFlatHeaderCtrl Constructors | Description
CXTFlatHeaderCtrl | Constructs a CXTFlatHeaderCtrl object
CXTFlatHeaderCtrl Destructors
CXTFlatHeaderCtrl Destructors | Description
~CXTFlatHeaderCtrl | Destroys a CXTFlatHeaderCtrl object, handles cleanup and deallocation


CXTFlatHeaderCtrl Constructors

CXTFlatHeaderCtrl Class, Legend, Public Methods
CXTFlatHeaderCtrl Constructors
Class

CXTFlatHeaderCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatHeaderCtrl | Constructs a CXTFlatHeaderCtrl object


CXTFlatHeaderCtrl::CXTFlatHeaderCtrl Constructor

CXTFlatHeaderCtrl Constructors, CXTFlatHeaderCtrl Class
CXTFlatHeaderCtrl::CXTFlatHeaderCtrl Constructor

Constructs a CXTFlatHeaderCtrl object

CXTFlatHeaderCtrl();
Group

CXTFlatHeaderCtrl Constructors


CXTFlatHeaderCtrl Destructors

CXTFlatHeaderCtrl Class, Legend, Public Methods
CXTFlatHeaderCtrl Destructors
Class

CXTFlatHeaderCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTFlatHeaderCtrl | Destroys a CXTFlatHeaderCtrl object, handles cleanup and deallocation


CXTFlatHeaderCtrl::~CXTFlatHeaderCtrl Destructor

CXTFlatHeaderCtrl Destructors, CXTFlatHeaderCtrl Class
CXTFlatHeaderCtrl::~CXTFlatHeaderCtrl Destructor

Destroys a CXTFlatHeaderCtrl object, handles cleanup and deallocation

virtual ~CXTFlatHeaderCtrl();
Group

CXTFlatHeaderCtrl Destructors


CXTFontCombo Class

XTFontCombo.h, Classes, Legend, Members, Topics, CXTFontCombo Data Members, CXTFontCombo Methods, CXTFontCombo Constructors, CXTFontCombo Destructors, CXTFontCombo Constructors, CXTFontCombo Data Members, CXTFontCombo Destructors, CXTFontCombo Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFontCombo Class

CXTFontCombo is a CXTFlatComboBox derived class. It is used to create a combo box that displays a drop list of available fonts for your system. The fonts are displayed in their various styles.

Class Hierarchy

class CXTFontCombo : public CXTFlatComboBox;
File

XTFontCombo.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTFontCombo Constructors
CXTFontCombo Constructors | Description
CXTFontCombo | Constructs a CXTFontCombo object
CXTFontCombo Data Members
CXTFontCombo Data Members | Description
m_csSymbol | String displayed for symbol characters.
m_dwStyle | Enumerated style indicating how to display the font list.
m_ilFontType | true type font image list.
CXTFontCombo Destructors
CXTFontCombo Destructors | Description
~CXTFontCombo | Destroys a CXTFontCombo object, handles cleanup and deallocation
CXTFontCombo Methods
CXTFontCombo Methods | Description
GetSelFont |
InitControl | Initializes the CXTFontCombo control.
NotifyOwner | Called by the font combo box to send CBN notifications to the owner window to support keyboard navigation.
SetListStyle | Sets the font style for the CXTFontCombo control.
SetSelFont |


CXTFontCombo Data Members

CXTFontCombo Class, Legend, Protected Data Members
CXTFontCombo Data Members
Class

CXTFontCombo Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_csSymbol | String displayed for symbol characters.
m_dwStyle | Enumerated style indicating how to display the font list.
m_ilFontType | true type font image list.


CXTFontCombo::m_csSymbol Data Member

CXTFontCombo Data Members, CXTFontCombo Class
CXTFontCombo::m_csSymbol Data Member

String displayed for symbol characters.

CString m_csSymbol;
Group

CXTFontCombo Data Members


CXTFontCombo::m_dwStyle Data Member

CXTFontCombo Data Members, CXTFontCombo Class
CXTFontCombo::m_dwStyle Data Member

Enumerated style indicating how to display the font list.

DWORD m_dwStyle;
Group

CXTFontCombo Data Members


CXTFontCombo::m_ilFontType Data Member

CXTFontCombo Data Members, CXTFontCombo Class
CXTFontCombo::m_ilFontType Data Member

true type font image list.

CImageList m_ilFontType;
Group

CXTFontCombo Data Members


CXTFontCombo Methods

CXTFontCombo Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFontCombo Methods
Class

CXTFontCombo Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
NotifyOwner | Called by the font combo box to send CBN notifications to the owner window to support keyboard navigation.
Public Methods
Public Methods
Public Method | Description
GetSelFont |
InitControl | Initializes the CXTFontCombo control.
SetListStyle | Sets the font style for the CXTFontCombo control.
SetSelFont |


GetSelFont Method

CXTFontCombo Methods
GetSelFont Method
Overload List
Methods
Method | Description
CXTFontCombo::GetSelFont (CString&) | Retrieves the selected font.
CXTFontCombo::GetSelFont (CXTLogFont&) | Retrieves the selected font.
Group

CXTFontCombo Methods


CXTFontCombo::GetSelFont Method (CXTLogFont&)

GetSelFont Method, CXTFontCombo Class
CXTFontCombo::GetSelFont Method (CXTLogFont&)

Retrieves the selected font.

virtual bool GetSelFont(
    CXTLogFont& lf
);
virtual bool GetSelFont(
    CString& strFaceName
);
Parameters

lf
Reference to an CXTLogFont structure.
strFaceName
A reference to a valid CString object to receive the logfont face name.

Returns

true if successful, otherwise returns false.

Remarks

The first version of GetSelFont will retrieve the selected font name. The second version will get the CXTLogFont for the currently selected item.

Group

GetSelFont Method


CXTFontCombo::InitControl Method

CXTFontCombo Methods, CXTFontCombo Class
CXTFontCombo::InitControl Method

Initializes the CXTFontCombo control.

virtual void InitControl(
    LPCTSTR lpszFaceName = NULL,
    UINT nWidth = 0,
    BOOL bEnable = TRUE
);
Parameters

lpszFaceName
A NULL terminated string that represents the logfont face name.
nWidth
The minimum allowable width of the list box portion of the combo box in pixels.
bEnable
TRUE to enable auto completion, otherwise FALSE.

Remarks

Call this member function to initialize the font list box and populate it with a list of available fonts.

Group

CXTFontCombo Methods


CXTFontCombo::NotifyOwner Method

CXTFontCombo Methods, CXTFontCombo Class
CXTFontCombo::NotifyOwner Method

Called by the font combo box to send CBN notifications to the owner window to support keyboard navigation.

virtual void NotifyOwner(
    UINT nCode
);
Parameters

nCode
CBN notification message to send.

Group

CXTFontCombo Methods


CXTFontCombo::SetListStyle Method

CXTFontCombo Methods, CXTFontCombo Class, Body Source
CXTFontCombo::SetListStyle Method

Sets the font style for the CXTFontCombo control.

void SetListStyle(
    DWORD dwStyle
);
Parameters

dwStyle
Specifies the style for the font list box. Styles can be any one of the values in the Remarks section.

Remarks

Call this member function to set the font display style for the font list box. There are three styles to choose from that include displaying the font in the default GUI font, displaying the font in its own font style, or displaying both the font name in the default GUI font and a sample to the right.

The style can be any of the following values:

  • xtFontGUI Display font name with GUI font style.
  • xtFontSample Display font name with its own font style.
  • xtFontBoth Display font name with GUI font style, then a sample display to the right.
Body Source
void CXTFontCombo::SetListStyle(DWORD dwStyle) {
    m_dwStyle = dwStyle;
}
Group

CXTFontCombo Methods


SetSelFont Method

CXTFontCombo Methods
SetSelFont Method
Overload List
Methods
Method | Description
CXTFontCombo::SetSelFont (CXTLogFont&) | Sets the selected font.
CXTFontCombo::SetSelFont (const CString&) | Sets the selected font.
Group

CXTFontCombo Methods


CXTFontCombo::SetSelFont Method (CXTLogFont&)

SetSelFont Method, CXTFontCombo Class
CXTFontCombo::SetSelFont Method (CXTLogFont&)

Sets the selected font.

virtual bool SetSelFont(
    CXTLogFont& lf
);
virtual bool SetSelFont(
    const CString& strFaceName
);
Parameters

lf
Reference to an CXTLogFont object.
strFaceName
A NULL terminated string that represents the logfont face name.

Returns

true if successful, otherwise returns false.

Remarks

The first version of SetSelFont will set the selected font by using its face name. The second version will set the selected font by using a CXTLogFont object.

Group

SetSelFont Method


CXTFontCombo Constructors

CXTFontCombo Class, Legend, Public Methods
CXTFontCombo Constructors
Class

CXTFontCombo Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFontCombo | Constructs a CXTFontCombo object


CXTFontCombo::CXTFontCombo Constructor

CXTFontCombo Constructors, CXTFontCombo Class
CXTFontCombo::CXTFontCombo Constructor

Constructs a CXTFontCombo object

CXTFontCombo();
Group

CXTFontCombo Constructors


CXTFontCombo Destructors

CXTFontCombo Class, Legend, Public Methods
CXTFontCombo Destructors
Class

CXTFontCombo Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTFontCombo | Destroys a CXTFontCombo object, handles cleanup and deallocation


CXTFontCombo::~CXTFontCombo Destructor

CXTFontCombo Destructors, CXTFontCombo Class
CXTFontCombo::~CXTFontCombo Destructor

Destroys a CXTFontCombo object, handles cleanup and deallocation

virtual ~CXTFontCombo();
Group

CXTFontCombo Destructors


CXTFontEnum Class

XTFontCombo.h, Classes, Legend, Members, Topics, CXTFontEnum Data Members, CXTFontEnum Methods, CXTFontEnum Constructors, CXTFontEnum Destructors, CXTFontEnum Constructors, CXTFontEnum Data Members, CXTFontEnum Destructors, Example, CXTFontEnum Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFontEnum Class

CXTFontEnum is a stand alone singleton font enumeration class. It is used to enumerate a list of fonts found installed for the operating system.

Class Hierarchy

class CXTFontEnum;
File

XTFontCombo.h

Remarks

CXTFontEnum is a singleton class, which means it can only be instantiated a single time. The constructor is private, so the only way to access members of this class is to use the objects Get() method. To retrieve a list of available fonts for your operating system, you would make the following call:

Example

The following example demonstrates the use of the CXTFontEnum class.

CXTFontEnum::Get().GetFontList()
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTFontEnum Constructors
CXTFontEnum Constructors | Description
CXTFontEnum | Constructs a CXTFontEnum object. CXTFontEnum is a singleton class, to instantiate an object, use the static method Get().
CXTFontEnum Data Members
CXTFontEnum Data Members | Description
m_listFonts | List of fonts found during enumeration
CXTFontEnum Destructors
CXTFontEnum Destructors | Description
~CXTFontEnum | Destroys a CXTFontEnum object, handles cleanup and deallocation
CXTFontEnum Methods
CXTFontEnum Methods | Description
AddFont | This member function is called by the font enumeration callback to add a font to the font list.
DoesFontExist | This member function is used to determine the existence of the font specified by 'strFaceName'.
EnumFontFamExProc | The EnumFontFamExProc function is an application defined-callback function used with the EnumFontFamiliesEx function. It is used to process the fonts and is called once for each enumerated font. The FONTENUMPROC type defines a pointer to this callback function. EnumFontFamExProc is a placeholder for the application defined-function name.
Get | This static member function will return a reference to the one and only CXTFontEnum object. You can use this function to access data members for the CXTFontEnum class.
GetFontList | This member function is used to get a reference to the font list.
GetLogFont | This member function is used to get a pointer to the font specified by 'strFaceName'.
GetMaxWidth | This member function is used by the callback function to retrieve the current width for the longest font name in the list.
Init | This member function is called by the CXTFontEnum class to initialize the font list. You can also call this member function to reinitialize the font enumeration. For example, if you changed printers and you want to enumerate printer fonts, or you wanted to use a different character set.


CXTFontEnum Data Members

CXTFontEnum Class, Legend, Protected Data Members
CXTFontEnum Data Members
Class

CXTFontEnum Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_listFonts | List of fonts found during enumeration


CXTFontEnum::m_listFonts Data Member

CXTFontEnum Data Members, CXTFontEnum Class
CXTFontEnum::m_listFonts Data Member

List of fonts found during enumeration

CXTFontList m_listFonts;
Group

CXTFontEnum Data Members


CXTFontEnum Methods

CXTFontEnum Class, Legend, Protected Methods, Public Methods
CXTFontEnum Methods
Class

CXTFontEnum Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
AddFont | This member function is called by the font enumeration callback to add a font to the font list.
EnumFontFamExProc | The EnumFontFamExProc function is an application defined-callback function used with the EnumFontFamiliesEx function. It is used to process the fonts and is called once for each enumerated font. The FONTENUMPROC type defines a pointer to this callback function. EnumFontFamExProc is a placeholder for the application defined-function name.
Public Methods
Public Methods
Public Method | Description
DoesFontExist | This member function is used to determine the existence of the font specified by 'strFaceName'.
Get | This static member function will return a reference to the one and only CXTFontEnum object. You can use this function to access data members for the CXTFontEnum class.
GetFontList | This member function is used to get a reference to the font list.
GetLogFont | This member function is used to get a pointer to the font specified by 'strFaceName'.
GetMaxWidth | This member function is used by the callback function to retrieve the current width for the longest font name in the list.
Init | This member function is called by the CXTFontEnum class to initialize the font list. You can also call this member function to reinitialize the font enumeration. For example, if you changed printers and you want to enumerate printer fonts, or you wanted to use a different character set.


CXTFontEnum::AddFont Method

CXTFontEnum Methods, CXTFontEnum Class
CXTFontEnum::AddFont Method

This member function is called by the font enumeration callback to add a font to the font list.

bool AddFont(
    const LOGFONT* pLF,
    DWORD dwType
);
Parameters

pLF
Points to a valid LOGFONT structure.
dwType
Specifies the type of the font. This parameter can be a combination of the values in the Remarks section.

Returns

true if successful, otherwise returns false.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • DEVICE_FONTTYPE The font is a device font.
  • RASTER_FONTTYPE The font is a raster font.
  • TRUETYPE_FONTTYPE The font is a TrueType font.
Group

CXTFontEnum Methods


CXTFontEnum::DoesFontExist Method

CXTFontEnum Methods, CXTFontEnum Class
CXTFontEnum::DoesFontExist Method

This member function is used to determine the existence of the font specified by 'strFaceName'.

bool DoesFontExist(
    CString& strFaceName
);
Parameters

strFaceName
Reference to a NULL terminated string that represents the font name.

Returns

true if the font exists, otherwise returns false.

Group

CXTFontEnum Methods


CXTFontEnum::EnumFontFamExProc Method

CXTFontEnum Methods, CXTFontEnum Class
CXTFontEnum::EnumFontFamExProc Method

The EnumFontFamExProc function is an application defined-callback function used with the EnumFontFamiliesEx function. It is used to process the fonts and is called once for each enumerated font. The FONTENUMPROC type defines a pointer to this callback function. EnumFontFamExProc is a placeholder for the application defined-function name.

static BOOL CALLBACK EnumFontFamExProc(
    ENUMLOGFONTEX* pelf,
    NEWTEXTMETRICEX* lpntm,
    DWORD dwFontType,
    LPARAM lParam
);
Parameters

pelf
Pointer to an ENUMLOGFONTEX structure that contains information about the logical attributes of the font.
lpntm
Pointer to a structure that contains information about the physical attributes of a font. The function uses the NEWTEXTMETRICEX structure for TrueType fonts; and the TEXTMETRIC structure for other fonts.
dwFontType
Specifies the type of the font. This parameter can be a combination of the values in the Remarks section.
lParam
Specifies the application-defined data passed by the EnumFontFamiliesEx function.

Returns

The return value must be a nonzero value to continue enumeration. To stop enumeration, the return value must be zero.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • DEVICE_FONTTYPE The font is a device font.
  • RASTER_FONTTYPE The font is a raster font.
  • TRUETYPE_FONTTYPE The font is a TrueType font.
Group

CXTFontEnum Methods


CXTFontEnum::Get Method

CXTFontEnum Methods, CXTFontEnum Class, Example
CXTFontEnum::Get Method

This static member function will return a reference to the one and only CXTFontEnum object. You can use this function to access data members for the CXTFontEnum class.

static CXTFontEnum& Get();
Returns

A reference to a CXTFontEnum object.

Example

The following example demonstrates the use of Get.

CXTFontEnum::Get().GetFontList()
Group

CXTFontEnum Methods


CXTFontEnum::GetFontList Method

CXTFontEnum Methods, CXTFontEnum Class, Body Source
CXTFontEnum::GetFontList Method

This member function is used to get a reference to the font list.

CXTFontList& GetFontList();
Returns

A reference to the CXTFontList used by this class.

Body Source
CXTFontList& CXTFontEnum::GetFontList() {
    return m_listFonts;
}
Group

CXTFontEnum Methods


CXTFontEnum::GetLogFont Method

CXTFontEnum Methods, CXTFontEnum Class
CXTFontEnum::GetLogFont Method

This member function is used to get a pointer to the font specified by 'strFaceName'.

CXTLogFont* GetLogFont(
    const CString& strFaceName
);
Parameters

strFaceName
A NULL terminated string that represents the font name.

Returns

A pointer to the CXTLogFont structure for the specified item, or NULL if no font was found.

Group

CXTFontEnum Methods


CXTFontEnum::GetMaxWidth Method

CXTFontEnum Methods, CXTFontEnum Class
CXTFontEnum::GetMaxWidth Method

This member function is used by the callback function to retrieve the current width for the longest font name in the list.

int GetMaxWidth();
Returns

An integer value that represents the width for the longest font in the list.

Group

CXTFontEnum Methods


CXTFontEnum::Init Method

CXTFontEnum Methods, CXTFontEnum Class
CXTFontEnum::Init Method

This member function is called by the CXTFontEnum class to initialize the font list. You can also call this member function to reinitialize the font enumeration. For example, if you changed printers and you want to enumerate printer fonts, or you wanted to use a different character set.

void Init(
    CDC* pDC = NULL,
    BYTE nCharSet = DEFAULT_CHARSET
);
Parameters

pDC
Points to a valid device context, if NULL, the screen device context is used.
nCharSet
Represents the character set to enumerate.

Group

CXTFontEnum Methods


CXTFontEnum Constructors

CXTFontEnum Class, Legend, Protected Methods
CXTFontEnum Constructors
Class

CXTFontEnum Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTFontEnum | Constructs a CXTFontEnum object. CXTFontEnum is a singleton class, to instantiate an object, use the static method Get().


CXTFontEnum::CXTFontEnum Constructor

CXTFontEnum Constructors, CXTFontEnum Class
CXTFontEnum::CXTFontEnum Constructor

Constructs a CXTFontEnum object. CXTFontEnum is a singleton class, to instantiate an object, use the static method Get().

CXTFontEnum();
Group

CXTFontEnum Constructors


CXTFontEnum Destructors

CXTFontEnum Class, Legend, Public Methods
CXTFontEnum Destructors
Class

CXTFontEnum Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTFontEnum | Destroys a CXTFontEnum object, handles cleanup and deallocation


CXTFontEnum::~CXTFontEnum Destructor

CXTFontEnum Destructors, CXTFontEnum Class
CXTFontEnum::~CXTFontEnum Destructor

Destroys a CXTFontEnum object, handles cleanup and deallocation

virtual ~CXTFontEnum();
Group

CXTFontEnum Destructors


CXTFontListBox Class

XTFontCombo.h, Classes, Legend, Members, Topics, CXTFontListBox Data Members, CXTFontListBox Methods, CXTFontListBox Constructors, CXTFontListBox Destructors, CXTFontListBox Constructors, CXTFontListBox Data Members, CXTFontListBox Destructors, CXTFontListBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFontListBox Class

CXTFontListBox is a CXTListBox derived class. It is used to create a font selection list box.

Class Hierarchy

class CXTFontListBox : public CXTListBox;
File

XTFontCombo.h

Remarks

You can choose to display the font name with the GUI font style, display the font name with its own font style, or display the font name with the default GUI font style and a sample display to the right.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTFontListBox Constructors
CXTFontListBox Constructors | Description
CXTFontListBox | Constructs a CXTFontListBox object
CXTFontListBox Data Members
CXTFontListBox Data Members | Description
m_csSymbol | String displayed for the symbol characters.
m_dwStyle | Display style indicating how to render the font list.
m_ilFontType | True type font image list.
CXTFontListBox Destructors
CXTFontListBox Destructors | Description
~CXTFontListBox | Destroys a CXTFontListBox object, handles cleanup and deallocation
CXTFontListBox Methods
CXTFontListBox Methods | Description
GetSelFont |
Initialize | Call this member function to initialize the font list box and populate it with a list of available fonts. This method should be called directly after creating or sub-classing the control.
SetListStyle | Call this member function to set the font display style for the font list box. There are three styles to choose from that include displaying the font in the default GUI font, displaying the font in its own font style, or displaying both the font name in the default GUI font and a sample to the right.
SetSelFont |


CXTFontListBox Data Members

CXTFontListBox Class, Legend, Protected Data Members
CXTFontListBox Data Members
Class

CXTFontListBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_csSymbol | String displayed for the symbol characters.
m_dwStyle | Display style indicating how to render the font list.
m_ilFontType | True type font image list.


CXTFontListBox::m_csSymbol Data Member

CXTFontListBox Data Members, CXTFontListBox Class
CXTFontListBox::m_csSymbol Data Member

String displayed for the symbol characters.

CString m_csSymbol;
Group

CXTFontListBox Data Members


CXTFontListBox::m_dwStyle Data Member

CXTFontListBox Data Members, CXTFontListBox Class
CXTFontListBox::m_dwStyle Data Member

Display style indicating how to render the font list.

DWORD m_dwStyle;
Group

CXTFontListBox Data Members


CXTFontListBox::m_ilFontType Data Member

CXTFontListBox Data Members, CXTFontListBox Class
CXTFontListBox::m_ilFontType Data Member

True type font image list.

CImageList m_ilFontType;
Group

CXTFontListBox Data Members


CXTFontListBox Methods

CXTFontListBox Class, Legend, Public Methods
CXTFontListBox Methods
Class

CXTFontListBox Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetSelFont |
Initialize | Call this member function to initialize the font list box and populate it with a list of available fonts. This method should be called directly after creating or sub-classing the control.
SetListStyle | Call this member function to set the font display style for the font list box. There are three styles to choose from that include displaying the font in the default GUI font, displaying the font in its own font style, or displaying both the font name in the default GUI font and a sample to the right.
SetSelFont |


GetSelFont Method

CXTFontListBox Methods
GetSelFont Method
Overload List
Methods
Method | Description
CXTFontListBox::GetSelFont (CString&) | Call this member function to get the font for the currently selected item.
CXTFontListBox::GetSelFont (CXTLogFont&) | Call this member function to get the font for the currently selected item.
Group

CXTFontListBox Methods


CXTFontListBox::GetSelFont Method (CXTLogFont&)

GetSelFont Method, CXTFontListBox Class
CXTFontListBox::GetSelFont Method (CXTLogFont&)

Call this member function to get the font for the currently selected item.

virtual bool GetSelFont(
    CXTLogFont& lf
);
virtual bool GetSelFont(
    CString& strFaceName
);
Parameters

lf
Reference to an CXTLogFont structure.
strFaceName
A reference to a valid CString object to receive the logfont face name.

Returns

true if successful, otherwise returns false.

Group

GetSelFont Method


CXTFontListBox::Initialize Method

CXTFontListBox Methods, CXTFontListBox Class
CXTFontListBox::Initialize Method

Call this member function to initialize the font list box and populate it with a list of available fonts. This method should be called directly after creating or sub-classing the control.

virtual void Initialize(
    bool bAutoFont = true
);
Parameters

bAutoFont
True to enable automatic font initialization.

Group

CXTFontListBox Methods


CXTFontListBox::SetListStyle Method

CXTFontListBox Methods, CXTFontListBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTFontListBox::SetListStyle Method

Call this member function to set the font display style for the font list box. There are three styles to choose from that include displaying the font in the default GUI font, displaying the font in its own font style, or displaying both the font name in the default GUI font and a sample to the right.

void SetListStyle(
    DWORD dwStyle
);
Parameters

dwStyle
Specifies the style for the font list box. See XTFontStyle for a list of available styles.

See Also

XTFontStyle

Body Source
void CXTFontListBox::SetListStyle(DWORD dwStyle) {
    m_dwStyle = dwStyle;
}
Group

CXTFontListBox Methods


SetSelFont Method

CXTFontListBox Methods
SetSelFont Method
Overload List
Methods
Method | Description
CXTFontListBox::SetSelFont (CXTLogFont&) | Call this member function to select the font for the list box.
CXTFontListBox::SetSelFont (const CString&) | Call this member function to select the font for the list box.
Group

CXTFontListBox Methods


CXTFontListBox::SetSelFont Method (CXTLogFont&)

SetSelFont Method, CXTFontListBox Class
CXTFontListBox::SetSelFont Method (CXTLogFont&)

Call this member function to select the font for the list box.

virtual bool SetSelFont(
    CXTLogFont& lf
);
virtual bool SetSelFont(
    const CString& strFaceName
);
Parameters

lf
Reference to an CXTLogFont structure.
strFaceName
A NULL terminated string that represents the logfont face name.

Returns

true if successful, otherwise returns false.

Group

SetSelFont Method


CXTFontListBox Constructors

CXTFontListBox Class, Legend, Public Methods
CXTFontListBox Constructors
Class

CXTFontListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTFontListBox | Constructs a CXTFontListBox object


CXTFontListBox::CXTFontListBox Constructor

CXTFontListBox Constructors, CXTFontListBox Class
CXTFontListBox::CXTFontListBox Constructor

Constructs a CXTFontListBox object

CXTFontListBox();
Group

CXTFontListBox Constructors


CXTFontListBox Destructors

CXTFontListBox Class, Legend, Public Methods
CXTFontListBox Destructors
Class

CXTFontListBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTFontListBox | Destroys a CXTFontListBox object, handles cleanup and deallocation


CXTFontListBox::~CXTFontListBox Destructor

CXTFontListBox Destructors, CXTFontListBox Class
CXTFontListBox::~CXTFontListBox Destructor

Destroys a CXTFontListBox object, handles cleanup and deallocation

virtual ~CXTFontListBox();
Group

CXTFontListBox Destructors


CXTHeaderCtrl Class

XTHeaderCtrl.h, Classes, Legend, Members, Topics, CXTHeaderCtrl Data Members, CXTHeaderCtrl Methods, CXTHeaderCtrl Constructors, CXTHeaderCtrl Destructors, CXTHeaderCtrl Constructors, CXTHeaderCtrl Data Members, CXTHeaderCtrl Destructors, CXTHeaderCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrl Class

CXTHeaderCtrl is a CHeaderCtrl derived class. It is used to create a CXTHeaderCtrl window similar to CHeaderCtrl, but with additional functionality.

Class Hierarchy

class CXTHeaderCtrl : public CXTHeaderCtrlHelper;
File

XTHeaderCtrl.h

Remarks

A "header control" is a window that is usually positioned above columns of text or numbers. It contains a title for each column, and it can be divided into parts. The user can drag the dividers that separate the parts to set the width of each column.

Use a header control, represented by class CXTHeaderCtrl, to display column headers for a columnar list. For example, a header control would be useful for implementing column controls in a spreadsheet.

The header control is usually divided into parts, called "header items", each bearing a title for the associated column of text or numbers. Depending on the styles you set, you can provide a number of direct ways for users to manipulate the header items.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTHeaderCtrl Constructors
CXTHeaderCtrl Constructors | Description
CXTHeaderCtrl | Constructs a CXTHeaderCtrl object
CXTHeaderCtrl Data Members
CXTHeaderCtrl Data Members | Description
m_arFrozenCols | List of columns that are not sizable.
m_bAscending | Used, when column is pressed, to draw a sort arrow.
m_bAutoSize | true if the header control columns are auto-sizing.
m_bEnableMenus | TRUE to disable the popup menu display.
m_bLBtnDown | TRUE if left mouse button is pressed.
m_bPainted | Used during paint operations.
m_bRTL | Used internally to determine if text is right-to-left or left-to-right (depends on system locale).
m_iMinSize | Minimum column size for an auto-size header control.
m_iOverIndex | Column mouse is currently hovering.
m_nPos | Index of the popup menu contained in the menu.
m_nSortedCol | Last column pressed during sort.
m_popupMenuID | Popup menu resource ID.
m_pt | Point where right click took place.
CXTHeaderCtrl Destructors
CXTHeaderCtrl Destructors | Description
~CXTHeaderCtrl | Destroys a CXTHeaderCtrl object, handles cleanup and deallocation
CXTHeaderCtrl Methods
CXTHeaderCtrl Methods | Description
ApplyFieldWidths | This member function is used by the header control to auto-size the columns for the list control.
DetermineRTL | This member function is used by the header control to determine the text alignment for the system locale.
EnableAutoSize | Call this member function to enable auto-sizing for the header control. This will cause the columns in the list control to be sized to fit in the available space when the list control is resized.
EnablePopupMenus | Call this member function to enable or disable the popup menu display whenever a user right clicks on the header control.
FitFieldWidths | This member function is used by the header control to determine the new width for auto-sized columns and resize accordingly.
FreezeColumn | Call this member function to freeze a column in the header control. Freezing a column will disable sizing for the column.
GetAscending | Call this member function to return the current sorting order.
GetFrozenColWidth | This member function is used by the header control to determine the total width of all frozen columns in the header control.
GetSortedCol | Call this member function to return the index to the currently sorted column.
HasSortArrow | Call this member function to determine if the header control displays a sort arrow.
HitTest | Tests a point to determine which header item, if any, is at the specified point.
InitializeHeader | This member function must be called after creation to initialize the font that the header will use.
IsColFrozen | Call this member function to determine if the specified column is frozen.
IsThemeValid | This member function is called to check if the header control is using a theme.
ItemPressed | Call this member function to determine if the specified header item is pressed (selected).
OnThemeChanged | This member function is called whenever the theme has changed.
RecalcLayout | Called by the header control to recalculate the size and layout for the header control and header items.
ResizeColumnsToFit | Call this member function to resize all header columns equally to fit the available client area.
SendNotify | Called to send WM_NOTIFY to tell parent's owner that the column needs to be sorted.
SetAlingment | Call this member function to set the text justification for the header control.
SetBitmap |
SetFontBold | This member function can be used to toggle the font from bold to normal.
SetMenuID | This member function is called to associate a menu and toolbar resource with the context menu.
SetMinSize | Call this member to set the minimum size for auto-sizing columns. The minimum size represents the smallest size that all columns can be sized to.
SetSortImage | This member function will set the sort image for the specified column.
ShowSortArrow | Call this member function to enable or disable the column sort arrow.
ThawAllColumns | Call this member function to thaw all column in the header control. This will will enable sizing for any column that was previously frozen.
ThawColumn | Call this member function to thaw a column in the header control. Thawing a column will enable sizing for the column if it was previously frozen.


CXTHeaderCtrl Data Members

CXTHeaderCtrl Class, Legend, Protected Data Members
CXTHeaderCtrl Data Members
Class

CXTHeaderCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arFrozenCols | List of columns that are not sizable.
m_bAscending | Used, when column is pressed, to draw a sort arrow.
m_bAutoSize | true if the header control columns are auto-sizing.
m_bEnableMenus | TRUE to disable the popup menu display.
m_bLBtnDown | TRUE if left mouse button is pressed.
m_bPainted | Used during paint operations.
m_bRTL | Used internally to determine if text is right-to-left or left-to-right (depends on system locale).
m_iMinSize | Minimum column size for an auto-size header control.
m_iOverIndex | Column mouse is currently hovering.
m_nPos | Index of the popup menu contained in the menu.
m_nSortedCol | Last column pressed during sort.
m_popupMenuID | Popup menu resource ID.
m_pt | Point where right click took place.


CXTHeaderCtrl::m_arFrozenCols Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_arFrozenCols Data Member

List of columns that are not sizable.

CList<int, int&> m_arFrozenCols;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_bAscending Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_bAscending Data Member

Used, when column is pressed, to draw a sort arrow.

BOOL m_bAscending;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_bAutoSize Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_bAutoSize Data Member

true if the header control columns are auto-sizing.

bool m_bAutoSize;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_bEnableMenus Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_bEnableMenus Data Member

TRUE to disable the popup menu display.

BOOL m_bEnableMenus;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_bLBtnDown Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_bLBtnDown Data Member

TRUE if left mouse button is pressed.

BOOL m_bLBtnDown;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_bPainted Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_bPainted Data Member

Used during paint operations.

BOOL m_bPainted;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_bRTL Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_bRTL Data Member

Used internally to determine if text is right-to-left or left-to-right (depends on system locale).

bool m_bRTL;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_iMinSize Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_iMinSize Data Member

Minimum column size for an auto-size header control.

int m_iMinSize;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_iOverIndex Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_iOverIndex Data Member

Column mouse is currently hovering.

int m_iOverIndex;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_nPos Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_nPos Data Member

Index of the popup menu contained in the menu.

int m_nPos;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_nSortedCol Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_nSortedCol Data Member

Last column pressed during sort.

int m_nSortedCol;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_popupMenuID Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_popupMenuID Data Member

Popup menu resource ID.

UINT m_popupMenuID;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl::m_pt Data Member

CXTHeaderCtrl Data Members, CXTHeaderCtrl Class
CXTHeaderCtrl::m_pt Data Member

Point where right click took place.

CPoint m_pt;
Group

CXTHeaderCtrl Data Members


CXTHeaderCtrl Methods

CXTHeaderCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrl Methods
Class

CXTHeaderCtrl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
ApplyFieldWidths | This member function is used by the header control to auto-size the columns for the list control.
DetermineRTL | This member function is used by the header control to determine the text alignment for the system locale.
FitFieldWidths | This member function is used by the header control to determine the new width for auto-sized columns and resize accordingly.
GetFrozenColWidth | This member function is used by the header control to determine the total width of all frozen columns in the header control.
SendNotify | Called to send WM_NOTIFY to tell parent's owner that the column needs to be sorted.
Public Methods
Public Methods
Public Method | Description
EnableAutoSize | Call this member function to enable auto-sizing for the header control. This will cause the columns in the list control to be sized to fit in the available space when the list control is resized.
EnablePopupMenus | Call this member function to enable or disable the popup menu display whenever a user right clicks on the header control.
FreezeColumn | Call this member function to freeze a column in the header control. Freezing a column will disable sizing for the column.
GetAscending | Call this member function to return the current sorting order.
GetSortedCol | Call this member function to return the index to the currently sorted column.
HasSortArrow | Call this member function to determine if the header control displays a sort arrow.
HitTest | Tests a point to determine which header item, if any, is at the specified point.
InitializeHeader | This member function must be called after creation to initialize the font that the header will use.
IsColFrozen | Call this member function to determine if the specified column is frozen.
IsThemeValid | This member function is called to check if the header control is using a theme.
ItemPressed | Call this member function to determine if the specified header item is pressed (selected).
OnThemeChanged | This member function is called whenever the theme has changed.
RecalcLayout | Called by the header control to recalculate the size and layout for the header control and header items.
ResizeColumnsToFit | Call this member function to resize all header columns equally to fit the available client area.
SetAlingment | Call this member function to set the text justification for the header control.
SetBitmap |
SetFontBold | This member function can be used to toggle the font from bold to normal.
SetMenuID | This member function is called to associate a menu and toolbar resource with the context menu.
SetMinSize | Call this member to set the minimum size for auto-sizing columns. The minimum size represents the smallest size that all columns can be sized to.
SetSortImage | This member function will set the sort image for the specified column.
ShowSortArrow | Call this member function to enable or disable the column sort arrow.
ThawAllColumns | Call this member function to thaw all column in the header control. This will will enable sizing for any column that was previously frozen.
ThawColumn | Call this member function to thaw a column in the header control. Thawing a column will enable sizing for the column if it was previously frozen.


CXTHeaderCtrl::ApplyFieldWidths Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::ApplyFieldWidths Method

This member function is used by the header control to auto-size the columns for the list control.

virtual void ApplyFieldWidths(
    int iNewWidth
);
Parameters

iNewWidth
New width to resize all columns to.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::DetermineRTL Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::DetermineRTL Method

This member function is used by the header control to determine the text alignment for the system locale.

virtual bool DetermineRTL();
Returns

true if the text alignment is right-to-left, and false if the text alignment is left-to-right.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::EnableAutoSize Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::EnableAutoSize Method

Call this member function to enable auto-sizing for the header control. This will cause the columns in the list control to be sized to fit in the available space when the list control is resized.

void EnableAutoSize(
    bool bEnable = true
);
Parameters

bEnable
true to enable an auto-sizing header control.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::EnablePopupMenus Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class, Body Source
CXTHeaderCtrl::EnablePopupMenus Method

Call this member function to enable or disable the popup menu display whenever a user right clicks on the header control.

void EnablePopupMenus(
    BOOL bEnableMenus
);
Parameters

bEnableMenus
TRUE to enable popup menus, and FALSE to disable.

Body Source
void CXTHeaderCtrl::EnablePopupMenus(BOOL bEnableMenus) {
    m_bEnableMenus = bEnableMenus;
}
Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::FitFieldWidths Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::FitFieldWidths Method

This member function is used by the header control to determine the new width for auto-sized columns and resize accordingly.

virtual void FitFieldWidths(
    int iNewWidth
);
Parameters

iNewWidth
New width to resize all columns to. If iNewWidth is '0', the columns are equally sized to fit the available client area.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::FreezeColumn Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::FreezeColumn Method

Call this member function to freeze a column in the header control. Freezing a column will disable sizing for the column.

void FreezeColumn(
    int iCol
);
Parameters

iCol
Index of the column to freeze.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::GetAscending Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class, Body Source
CXTHeaderCtrl::GetAscending Method

Call this member function to return the current sorting order.

BOOL GetAscending() const;
Returns

TRUE if the sorting order is ascending, otherwise returns FALSE.

Body Source
BOOL CXTHeaderCtrl::GetAscending() const {
    ASSERT(::IsWindow(m_hWnd)); return m_bAscending;
}
Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::GetFrozenColWidth Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::GetFrozenColWidth Method

This member function is used by the header control to determine the total width of all frozen columns in the header control.

virtual int GetFrozenColWidth();
Returns

The combined size in pixels of all frozen columns.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::GetSortedCol Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::GetSortedCol Method

Call this member function to return the index to the currently sorted column.

int GetSortedCol(
    BOOL* pbSortAsc = NULL
);
Parameters

pbSortAsc
Set to TRUE if ascending, otherwise FALSE.

Returns

The index of the currently sorted column.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::HasSortArrow Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::HasSortArrow Method

Call this member function to determine if the header control displays a sort arrow.

BOOL HasSortArrow();
Returns

TRUE if the header control displays a sort arrow, otherwise returns FALSE.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::HitTest Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::HitTest Method

Tests a point to determine which header item, if any, is at the specified point.

int HitTest(
    CPoint pt,
    UINT* pFlags = NULL
) const;
Parameters

pt
POINT structure that contains the point to be hit test, in client coordinates.
pFlags
Variable that receives information about the results of a hit test. This member can be one or more of the values listed in the Remarks section.

Returns

If the hit test is successful, contains the index of the item at the hit test point, if any, or - 1 otherwise.

Remarks

pFlags can be one or more of the following values:

  • HHT_ABOVE The point is above the header control's bounding rectangle.
  • HHT_BELOW The point is below the header control's bounding rectangle.
  • HHT_NOWHERE The point is inside the header control's bounding rectangle but is not over a header item.
  • HHT_ONDIVIDER The point is on the divider between two header items.
  • HHT_ONDIVOPEN The point is on the divider of an item that has a width of zero. Dragging the divider reveals the item instead of resizing the item to the left of the divider.
  • HHT_ONHEADER The point is inside the header control's bounding rectangle.
  • HHT_ONFILTER Version 5.80 The point is over the filter area.
  • HHT_ONFILTERBUTTON Version 5.80 The point is on the filter button.
  • HHT_TOLEFT The point is to the left of the header control's bounding rectangle.
  • HHT_TORIGHT The point is to the right of the header control's bounding rectangle.
Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::InitializeHeader Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::InitializeHeader Method

This member function must be called after creation to initialize the font that the header will use.

virtual void InitializeHeader(
    BOOL bBoldFont
);
Parameters

bBoldFont
TRUE if the header's font should be bold.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::IsColFrozen Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::IsColFrozen Method

Call this member function to determine if the specified column is frozen.

bool IsColFrozen(
    int iCol
);
Parameters

iCol
Index of the column to check.

Returns

true if the column is frozen, otherwise returns false.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::IsThemeValid Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::IsThemeValid Method

This member function is called to check if the header control is using a theme.

BOOL IsThemeValid() const;
Returns

TRUE if a theme is used, otherwise FALSE.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::ItemPressed Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::ItemPressed Method

Call this member function to determine if the specified header item is pressed (selected).

virtual BOOL ItemPressed(
    int iItem
);
Parameters

iItem
Index of the header item to check.

Returns

TRUE if the specified header item is pressed (selected).

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::OnThemeChanged Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::OnThemeChanged Method

This member function is called whenever the theme has changed.

virtual void OnThemeChanged();
Remarks

Override this member function to add additional functionality whenever the control theme changes.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::RecalcLayout Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::RecalcLayout Method

Called by the header control to recalculate the size and layout for the header control and header items.

BOOL RecalcLayout();
Returns

TRUE if successful, otherwise FALSE.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::ResizeColumnsToFit Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::ResizeColumnsToFit Method

Call this member function to resize all header columns equally to fit the available client area.

void ResizeColumnsToFit();
Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::SendNotify Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::SendNotify Method

Called to send WM_NOTIFY to tell parent's owner that the column needs to be sorted.

void SendNotify(
    int iIndex
);
Parameters

iIndex
Index of the column to be sorted.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::SetAlingment Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::SetAlingment Method

Call this member function to set the text justification for the header control.

virtual BOOL SetAlingment(
    int nFlag
);
Parameters

nFlag
Text alignment, either LVCFMT_CENTER, LVCFMT_LEFT, or LVCFMT_RIGHT.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTHeaderCtrl Methods


SetBitmap Method

CXTHeaderCtrl Methods
SetBitmap Method
Overload List
Methods
Method | Description
CXTHeaderCtrl::SetBitmap (int, UINT, BOOL, COLORREF) | Call this member function to set the bitmap image for the specified header item.
CXTHeaderCtrl::SetBitmap (int, UINT, DWORD) | Call this member function to set the bitmap image for the specified header item.
Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::SetBitmap Method (int, UINT, DWORD)

SetBitmap Method, CXTHeaderCtrl Class, Example
CXTHeaderCtrl::SetBitmap Method (int, UINT, DWORD)

Call this member function to set the bitmap image for the specified header item.

void SetBitmap(
    int iCol,
    UINT uBitmapID,
    DWORD dwRemove = NULL
);
void SetBitmap(
    int iCol,
    UINT uBitmapID,
    BOOL bRemove,
    COLORREF crMask
);
Parameters

iCol
Zero-based index of the column to set the sort image for.
uBitmapID
Resource ID of the bitmap to use.
dwRemove
Indicates the header format style to remove, see HD_ITEM structure.
bRemove
TRUE to remove a bitmap, FALSE if adding a bitmap.
crMask
Color used to generate the mask. Each pixel of this color in the given bitmap is changed to black and the corresponding bit in the mask is set to one.

Example

The following example demonstrates the use of SetBitmap.

// add bitmap images.
m_header.SetBitmap(0, IDB_COLUMN_0, FALSE, RGB(0, 255, 0));
m_header.SetBitmap(1, IDB_COLUMN_1, FALSE, RGB(0, 255, 0));
m_header.SetBitmap(2, IDB_COLUMN_2, FALSE, RGB(0, 255, 0));
Group

SetBitmap Method


CXTHeaderCtrl::SetFontBold Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::SetFontBold Method

This member function can be used to toggle the font from bold to normal.

virtual void SetFontBold(
    BOOL bBoldFont = TRUE
);
Parameters

bBoldFont
TRUE if the header's font should be bold.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::SetMenuID Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::SetMenuID Method

This member function is called to associate a menu and toolbar resource with the context menu.

virtual void SetMenuID(
    UINT popupMenuID,
    int nPos = 0
);
Parameters

popupMenuID
Resource ID for the popup menu used with the header.
nPos
Position of the submenu to be displayed.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::SetMinSize Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::SetMinSize Method

Call this member to set the minimum size for auto-sizing columns. The minimum size represents the smallest size that all columns can be sized to.

void SetMinSize(
    int iMinSize
);
Parameters

iMinSize
Minimum column size.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::SetSortImage Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::SetSortImage Method

This member function will set the sort image for the specified column.

int SetSortImage(
    int iSortCol,
    BOOL bSortAsc
);
Parameters

iSortCol
Zero-based index of the column to set the sort image for.
bSortAsc
TRUE if ascending, otherwise FALSE.

Returns

A zero-based index of the previously sorted column.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::ShowSortArrow Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::ShowSortArrow Method

Call this member function to enable or disable the column sort arrow.

virtual void ShowSortArrow(
    BOOL bSortArrow
);
Parameters

bSortArrow
Set to TRUE to draw the column sort arrow.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::ThawAllColumns Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::ThawAllColumns Method

Call this member function to thaw all column in the header control. This will will enable sizing for any column that was previously frozen.

void ThawAllColumns();
Group

CXTHeaderCtrl Methods


CXTHeaderCtrl::ThawColumn Method

CXTHeaderCtrl Methods, CXTHeaderCtrl Class
CXTHeaderCtrl::ThawColumn Method

Call this member function to thaw a column in the header control. Thawing a column will enable sizing for the column if it was previously frozen.

void ThawColumn(
    int iCol
);
Parameters

iCol
Index of the column to thaw.

Group

CXTHeaderCtrl Methods


CXTHeaderCtrl Constructors

CXTHeaderCtrl Class, Legend, Public Methods
CXTHeaderCtrl Constructors
Class

CXTHeaderCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrl | Constructs a CXTHeaderCtrl object


CXTHeaderCtrl::CXTHeaderCtrl Constructor

CXTHeaderCtrl Constructors, CXTHeaderCtrl Class
CXTHeaderCtrl::CXTHeaderCtrl Constructor

Constructs a CXTHeaderCtrl object

CXTHeaderCtrl();
Group

CXTHeaderCtrl Constructors


CXTHeaderCtrl Destructors

CXTHeaderCtrl Class, Legend, Public Methods
CXTHeaderCtrl Destructors
Class

CXTHeaderCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTHeaderCtrl | Destroys a CXTHeaderCtrl object, handles cleanup and deallocation


CXTHeaderCtrl::~CXTHeaderCtrl Destructor

CXTHeaderCtrl Destructors, CXTHeaderCtrl Class
CXTHeaderCtrl::~CXTHeaderCtrl Destructor

Destroys a CXTHeaderCtrl object, handles cleanup and deallocation

virtual ~CXTHeaderCtrl();
Group

CXTHeaderCtrl Destructors


CXTHeaderCtrlTheme Class

XTHeaderCtrlTheme.h, Classes, Legend, Members, Topics, CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Constructors, CXTHeaderCtrlTheme Destructors, CXTHeaderCtrlTheme Constructors, CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Destructors, CXTHeaderCtrlTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlTheme Class

CXTHeaderCtrlTheme is a theme class used to draw windows classic style theme for the header control.

Class Hierarchy

class CXTHeaderCtrlTheme : public CXTThemeManagerStyle;
File

XTHeaderCtrlTheme.h

Remarks

The CXTHeaderCtrlTheme class provides theme capability to the CXTHeaderCtrl class. You can derive a class from CXTHeaderCtrlTheme to custom user defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTHeaderCtrl base class. Once you have done this you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTHeaderCtrlTheme Constructors
CXTHeaderCtrlTheme Constructors | Description
CXTHeaderCtrlTheme | Constructs a CXTHeaderCtrlTheme object using the specified header control.
CXTHeaderCtrlTheme Data Members
CXTHeaderCtrlTheme Data Members | Description
m_bUseWinThemes | TRUE to use Windows XP themes when available.
m_cr3DDkShadow | RGB value for border dark shadow color.
m_cr3DFace | RGB value for header background color.
m_cr3DHighLight | RGB value for border highlight color.
m_cr3DShadow | RGB value for border shadow color.
m_crText | RGB value for text color.
m_dwDrawStyle | Style flags used by theme, see CXTHeaderCtrlTheme::SetDrawStyle().
m_iArrowPadding | Spacing between text and sort arrow.
m_sizeArrow | Width and height of sort arrow.
m_sizePadding | Leading and trailing padding for text display.
m_themeWrapper | Wraps the Windows XP theme API that is used to display Windows XP themes.
CXTHeaderCtrlTheme Destructors
CXTHeaderCtrlTheme Destructors | Description
~CXTHeaderCtrlTheme | Destroys a CXTHeaderCtrlTheme object, handles cleanup and deallocation.
CXTHeaderCtrlTheme Methods
CXTHeaderCtrlTheme Methods | Description
CleanUp | Cleans up allocated GDI resources used by the theme.
DrawHeader | Call this member function from the header control's WM_PAINT message to perform themed drawing.
DrawSortArrow | This member function is called by CXTHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
GetDrawStyle | Call this member function to return the current drawing style used by the header theme.
GetThemeWrapper | Call this member function to return a pointer to the Windows theme API wrapper for this control.
HasSortArrow | Call this member function to determine if the header control displays a sort arrow.
Layout | Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.
OnDrawBackground | This member function is called by the theme to draw the header control's background.
OnDrawBackgroundWinThemed | This member function is called by the theme to draw the header control's background using Windows themes.
OnDrawItemBackground | This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.
OnDrawItemBackgroundWinThemed | This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.
OnDrawItemBitmap | This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.
OnDrawItemSortArrow | This member function is called by the theme to draw the sort used to display sort order for header item specified by lpDIS->itemID.
OnDrawItemText | This member function is called to draw the text for the header item specified by lpDIS->itemID.
RefreshMetrics | Call this member whenever the system colors need to be updated.
SetBitmap | Call this member function to set the bitmap image for the specified header item.
SetDrawStyle | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
UseWinXPThemes | This member function can be called to determine if Windows XP themes can be displayed for the header control.


CXTHeaderCtrlTheme Data Members

CXTHeaderCtrlTheme Class, Legend, Protected Data Members
CXTHeaderCtrlTheme Data Members
Class

CXTHeaderCtrlTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bUseWinThemes | TRUE to use Windows XP themes when available.
m_cr3DDkShadow | RGB value for border dark shadow color.
m_cr3DFace | RGB value for header background color.
m_cr3DHighLight | RGB value for border highlight color.
m_cr3DShadow | RGB value for border shadow color.
m_crText | RGB value for text color.
m_dwDrawStyle | Style flags used by theme, see CXTHeaderCtrlTheme::SetDrawStyle().
m_iArrowPadding | Spacing between text and sort arrow.
m_sizeArrow | Width and height of sort arrow.
m_sizePadding | Leading and trailing padding for text display.
m_themeWrapper | Wraps the Windows XP theme API that is used to display Windows XP themes.


CXTHeaderCtrlTheme::m_bUseWinThemes Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_bUseWinThemes Data Member

TRUE to use Windows XP themes when available.

BOOL m_bUseWinThemes;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_cr3DDkShadow Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_cr3DDkShadow Data Member

RGB value for border dark shadow color.

COLORREF m_cr3DDkShadow;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_cr3DFace Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_cr3DFace Data Member

RGB value for header background color.

COLORREF m_cr3DFace;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_cr3DHighLight Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_cr3DHighLight Data Member

RGB value for border highlight color.

COLORREF m_cr3DHighLight;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_cr3DShadow Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_cr3DShadow Data Member

RGB value for border shadow color.

COLORREF m_cr3DShadow;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_crText Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_crText Data Member

RGB value for text color.

COLORREF m_crText;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_dwDrawStyle Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_dwDrawStyle Data Member

Style flags used by theme, see CXTHeaderCtrlTheme::SetDrawStyle().

DWORD m_dwDrawStyle;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_iArrowPadding Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_iArrowPadding Data Member

Spacing between text and sort arrow.

int m_iArrowPadding;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_sizeArrow Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_sizeArrow Data Member

Width and height of sort arrow.

CSize m_sizeArrow;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_sizePadding Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_sizePadding Data Member

Leading and trailing padding for text display.

CSize m_sizePadding;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme::m_themeWrapper Data Member

CXTHeaderCtrlTheme Data Members, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::m_themeWrapper Data Member

Wraps the Windows XP theme API that is used to display Windows XP themes.

CXTPWinThemeWrapper m_themeWrapper;
Group

CXTHeaderCtrlTheme Data Members


CXTHeaderCtrlTheme Methods

CXTHeaderCtrlTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlTheme Methods
Class

CXTHeaderCtrlTheme Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawSortArrow | This member function is called by CXTHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
OnDrawBackground | This member function is called by the theme to draw the header control's background.
OnDrawBackgroundWinThemed | This member function is called by the theme to draw the header control's background using Windows themes.
OnDrawItemBackground | This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.
OnDrawItemBackgroundWinThemed | This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.
OnDrawItemBitmap | This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.
OnDrawItemSortArrow | This member function is called by the theme to draw the sort used to display sort order for header item specified by lpDIS->itemID.
OnDrawItemText | This member function is called to draw the text for the header item specified by lpDIS->itemID.
Public Methods
Public Methods
Public Method | Description
CleanUp | Cleans up allocated GDI resources used by the theme.
DrawHeader | Call this member function from the header control's WM_PAINT message to perform themed drawing.
GetDrawStyle | Call this member function to return the current drawing style used by the header theme.
GetThemeWrapper | Call this member function to return a pointer to the Windows theme API wrapper for this control.
HasSortArrow | Call this member function to determine if the header control displays a sort arrow.
Layout | Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.
RefreshMetrics | Call this member whenever the system colors need to be updated.
SetBitmap | Call this member function to set the bitmap image for the specified header item.
SetDrawStyle | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
UseWinXPThemes | This member function can be called to determine if Windows XP themes can be displayed for the header control.


CXTHeaderCtrlTheme::CleanUp Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::CleanUp Method

Cleans up allocated GDI resources used by the theme.

virtual void CleanUp(
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

pHeaderCtrl
Points to a CXTHeaderCtrl object.

Remarks

The CXTHeaderCtrlTheme class calls this member function to free GDI resources that have been allocated during draw routines.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::DrawHeader Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::DrawHeader Method

Call this member function from the header control's WM_PAINT message to perform themed drawing.

virtual void DrawHeader(
    CDC* pDC,
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

pDC
Pointer to a valid device context.
pHeaderCtrl
Points to a CXTHeaderCtrl object.

Remarks

Called by the CXTHeaderCtrlTheme class to render the header for the CXTHeaderCtrl object.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::DrawSortArrow Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::DrawSortArrow Method

This member function is called by CXTHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.

virtual void DrawSortArrow(
    CDC* pDC,
    LPPOINT ptsArrow,
    BOOL bAscending
);
Parameters

pDC
Pointer to a valid device context.
ptsArrow
POINT array used to define the 3 points of the arrow drawn.
bAscending
TRUE if the arrow is to be draw ascending.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::GetDrawStyle Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlTheme::GetDrawStyle Method

Call this member function to return the current drawing style used by the header theme.

virtual DWORD GetDrawStyle() const;
Returns

The current XTTHEME_ (xt theme) settings for the header control. See SetDrawStyle for the complete list of available styles.

See Also

SetDrawStyle

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::GetThemeWrapper Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlTheme::GetThemeWrapper Method

Call this member function to return a pointer to the Windows theme API wrapper for this control.

CXTPWinThemeWrapper* GetThemeWrapper();
Returns

A CXTPWinThemeWrapper pointer.

Body Source
CXTPWinThemeWrapper* CXTHeaderCtrlTheme::GetThemeWrapper() {
    return &m_themeWrapper;
}
Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::HasSortArrow Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlTheme::HasSortArrow Method

Call this member function to determine if the header control displays a sort arrow.

BOOL HasSortArrow();
Returns

TRUE if the header control displays a sort arrow, otherwise returns FALSE.

Body Source
BOOL CXTHeaderCtrlTheme::HasSortArrow() {
    return ((m_dwDrawStyle & XTTHEME_SORTARROW) == XTTHEME_SORTARROW);
}
Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::Layout Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::Layout Method

Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.

virtual BOOL Layout(
    LPHDLAYOUT lpHDL,
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

lpHDL
Pointer to an HDLAYOUT structure, which contains information used to set the size and position of a header control.
pHeaderCtrl
Points to a CXTHeaderCtrl object.

Returns

Nonzero if successful; otherwise 0.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::OnDrawBackground Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::OnDrawBackground Method

This member function is called by the theme to draw the header control's background.

virtual void OnDrawBackground(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::OnDrawBackgroundWinThemed Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::OnDrawBackgroundWinThemed Method

This member function is called by the theme to draw the header control's background using Windows themes.

virtual BOOL OnDrawBackgroundWinThemed(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Returns

TRUE if successful; otherwise FALSE.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::OnDrawItemBackground Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::OnDrawItemBackground Method

This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.

virtual void OnDrawItemBackground(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::OnDrawItemBackgroundWinThemed Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::OnDrawItemBackgroundWinThemed Method

This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.

virtual BOOL OnDrawItemBackgroundWinThemed(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Returns

TRUE if successful; otherwise FALSE.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::OnDrawItemBitmap Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::OnDrawItemBitmap Method

This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.

virtual void OnDrawItemBitmap(
    LPDRAWITEMSTRUCT lpDIS,
    CRect& rcText,
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
rcText
Size of the area where the header item text is displayed.
pHeaderCtrl
Points to a CXTHeaderCtrl object.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::OnDrawItemSortArrow Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::OnDrawItemSortArrow Method

This member function is called by the theme to draw the sort used to display sort order for header item specified by lpDIS->itemID.

virtual void OnDrawItemSortArrow(
    LPDRAWITEMSTRUCT lpDIS,
    BOOL bAscending
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
bAscending
TRUE if the arrow is to be draw ascending.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::OnDrawItemText Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::OnDrawItemText Method

This member function is called to draw the text for the header item specified by lpDIS->itemID.

virtual void OnDrawItemText(
    LPDRAWITEMSTRUCT lpDIS,
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pHeaderCtrl
Points to a CXTHeaderCtrl object.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::RefreshMetrics Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::RefreshMetrics Method

Call this member whenever the system colors need to be updated.

virtual void RefreshMetrics();
Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::SetBitmap Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::SetBitmap Method

Call this member function to set the bitmap image for the specified header item.

virtual BOOL SetBitmap(
    int iCol,
    UINT uBitmapID,
    BOOL bRemove,
    COLORREF crMask,
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

iCol
Zero-based index of the column to set the sort image for.
uBitmapID
Resource ID of the bitmap to use.
bRemove
TRUE to remove a bitmap, FALSE if adding a bitmap.
crMask
Color used to generate the mask. Each pixel of this color in the given bitmap is changed to black and the corresponding bit in the mask is set to one.
pHeaderCtrl
Points to a CXTHeaderCtrl object.

Returns

TRUE if successful; otherwise FALSE.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::SetDrawStyle Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlTheme::SetDrawStyle Method

Call this member function to set the desired XTTHEME_ drawing styles for the header theme.

virtual void SetDrawStyle(
    DWORD dwDrawStyle,
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

dwDrawStyle
The desired styles for the header control theme. Can be one or more of the values listed in the remarks section.
pHeaderCtrl
Pointer to a CXTHeaderCtrl object.

Remarks

Does not affect the WS_ (window style) settings. Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • XTTHEME_WINXPTHEMES Allows the header control to display Windows XP themes when they are available.
  • XTTHEME_HOTTRACKING Allows the header control to display mouse over effects for the header control.
  • XTTHEME_SORTARROW Allows the header control to display a sort arrow to indicate sort order.
See Also

GetDrawStyle

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme::UseWinXPThemes Method

CXTHeaderCtrlTheme Methods, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::UseWinXPThemes Method

This member function can be called to determine if Windows XP themes can be displayed for the header control.

virtual BOOL UseWinXPThemes(
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

pHeaderCtrl
Points to a CXTHeaderCtrl object.

Returns

TRUE if Windows themes can be displayed, otherwise FALSE.

Group

CXTHeaderCtrlTheme Methods


CXTHeaderCtrlTheme Constructors

CXTHeaderCtrlTheme Class, Legend, Public Methods
CXTHeaderCtrlTheme Constructors
Class

CXTHeaderCtrlTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrlTheme | Constructs a CXTHeaderCtrlTheme object using the specified header control.


CXTHeaderCtrlTheme::CXTHeaderCtrlTheme Constructor

CXTHeaderCtrlTheme Constructors, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::CXTHeaderCtrlTheme Constructor

Constructs a CXTHeaderCtrlTheme object using the specified header control.

CXTHeaderCtrlTheme();
Group

CXTHeaderCtrlTheme Constructors


CXTHeaderCtrlTheme Destructors

CXTHeaderCtrlTheme Class, Legend, Public Methods
CXTHeaderCtrlTheme Destructors
Class

CXTHeaderCtrlTheme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTHeaderCtrlTheme | Destroys a CXTHeaderCtrlTheme object, handles cleanup and deallocation.


CXTHeaderCtrlTheme::~CXTHeaderCtrlTheme Destructor

CXTHeaderCtrlTheme Destructors, CXTHeaderCtrlTheme Class
CXTHeaderCtrlTheme::~CXTHeaderCtrlTheme Destructor

Destroys a CXTHeaderCtrlTheme object, handles cleanup and deallocation.

virtual ~CXTHeaderCtrlTheme();
Group

CXTHeaderCtrlTheme Destructors


CXTHeaderCtrlThemeExplorer Class

XTHeaderCtrlTheme.h, Classes, Legend, Members, Topics, CXTHeaderCtrlThemeExplorer Methods, CXTHeaderCtrlThemeExplorer Constructors, CXTHeaderCtrlThemeExplorer Destructors, CXTHeaderCtrlThemeExplorer Constructors, CXTHeaderCtrlThemeExplorer Destructors, CXTHeaderCtrlThemeExplorer Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeExplorer Class

CXTHeaderCtrlThemeExplorer is a CXTHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control.

Class Hierarchy

class CXTHeaderCtrlThemeExplorer : public CXTHeaderCtrlThemeOffice2003;
File

XTHeaderCtrlTheme.h

Remarks

The CXTHeaderCtrlThemeExplorer class provides theme capability to the CXTHeaderCtrl class. You can derive a class from CXTHeaderCtrlThemeExplorer to custom user defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTHeaderCtrl base class. Once you have done this you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Group

Classes

Legend
Method
protected
virtual
CXTHeaderCtrlThemeExplorer Constructors
CXTHeaderCtrlThemeExplorer Constructors | Description
CXTHeaderCtrlThemeExplorer | Constructs a CXTHeaderCtrlThemeExplorer object using the specified header control.
CXTHeaderCtrlThemeExplorer Destructors
CXTHeaderCtrlThemeExplorer Destructors | Description
~CXTHeaderCtrlThemeExplorer | Destroys a CXTHeaderCtrlThemeExplorer object, handles cleanup and deallocation.
CXTHeaderCtrlThemeExplorer Methods
CXTHeaderCtrlThemeExplorer Methods | Description
DrawSortArrow | This member function is called by CXTHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
Layout | Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.
OnDrawBackground | This member function is called by the theme to draw the header control's background.
OnDrawItemBackgroundWinThemed | This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.


CXTHeaderCtrlThemeExplorer Methods

CXTHeaderCtrlThemeExplorer Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeExplorer Methods
Class

CXTHeaderCtrlThemeExplorer Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawSortArrow | This member function is called by CXTHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
OnDrawBackground | This member function is called by the theme to draw the header control's background.
OnDrawItemBackgroundWinThemed | This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.
Public Methods
Public Methods
Public Method | Description
Layout | Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.


CXTHeaderCtrlThemeExplorer::DrawSortArrow Method

CXTHeaderCtrlThemeExplorer Methods, CXTHeaderCtrlThemeExplorer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeExplorer::DrawSortArrow Method

This member function is called by CXTHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.

virtual void DrawSortArrow(
    CDC* pDC,
    LPPOINT ptsArrow,
    BOOL bAscending
);
Parameters

pDC
Pointer to a valid device context.
ptsArrow
POINT array used to define the 3 points of the arrow drawn.
bAscending
TRUE if the arrow is to be draw ascending.

Group

CXTHeaderCtrlThemeExplorer Methods


CXTHeaderCtrlThemeExplorer::Layout Method

CXTHeaderCtrlThemeExplorer Methods, CXTHeaderCtrlThemeExplorer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeExplorer::Layout Method

Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.

virtual BOOL Layout(
    LPHDLAYOUT lpHDL,
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

lpHDL
Pointer to anHDLAYOUT structure, which contains information used to set the size and position of a header control.
pHeaderCtrl
Points to a CXTHeaderCtrl object.

Returns

Nonzero if successful; otherwise 0.

Group

CXTHeaderCtrlThemeExplorer Methods


CXTHeaderCtrlThemeExplorer::OnDrawBackground Method

CXTHeaderCtrlThemeExplorer Methods, CXTHeaderCtrlThemeExplorer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeExplorer::OnDrawBackground Method

This member function is called by the theme to draw the header control's background.

virtual void OnDrawBackground(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Group

CXTHeaderCtrlThemeExplorer Methods


CXTHeaderCtrlThemeExplorer::OnDrawItemBackgroundWinThemed Method

CXTHeaderCtrlThemeExplorer Methods, CXTHeaderCtrlThemeExplorer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeExplorer::OnDrawItemBackgroundWinThemed Method

This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.

virtual BOOL OnDrawItemBackgroundWinThemed(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Returns

TRUE if successful; otherwise FALSE.

Group

CXTHeaderCtrlThemeExplorer Methods


CXTHeaderCtrlThemeExplorer Constructors

CXTHeaderCtrlThemeExplorer Class, Legend, Public Methods
CXTHeaderCtrlThemeExplorer Constructors
Class

CXTHeaderCtrlThemeExplorer Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrlThemeExplorer | Constructs a CXTHeaderCtrlThemeExplorer object using the specified header control.


CXTHeaderCtrlThemeExplorer::CXTHeaderCtrlThemeExplorer Constructor

CXTHeaderCtrlThemeExplorer Constructors, CXTHeaderCtrlThemeExplorer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeExplorer::CXTHeaderCtrlThemeExplorer Constructor

Constructs a CXTHeaderCtrlThemeExplorer object using the specified header control.

CXTHeaderCtrlThemeExplorer();
Parameters

pHeaderCtrl
Pointer to the header control to be themed.

Group

CXTHeaderCtrlThemeExplorer Constructors


CXTHeaderCtrlThemeExplorer Destructors

CXTHeaderCtrlThemeExplorer Class, Legend, Public Methods
CXTHeaderCtrlThemeExplorer Destructors
Class

CXTHeaderCtrlThemeExplorer Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTHeaderCtrlThemeExplorer | Destroys a CXTHeaderCtrlThemeExplorer object, handles cleanup and deallocation.


CXTHeaderCtrlThemeExplorer::~CXTHeaderCtrlThemeExplorer Destructor

CXTHeaderCtrlThemeExplorer Destructors, CXTHeaderCtrlThemeExplorer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeExplorer::~CXTHeaderCtrlThemeExplorer Destructor

Destroys a CXTHeaderCtrlThemeExplorer object, handles cleanup and deallocation.

virtual ~CXTHeaderCtrlThemeExplorer();
Group

CXTHeaderCtrlThemeExplorer Destructors


CXTHeaderCtrlThemeOffice2003 Class

XTHeaderCtrlTheme.h, Classes, Legend, Members, Topics, CXTHeaderCtrlThemeOffice2003 Methods, CXTHeaderCtrlThemeOffice2003 Constructors, CXTHeaderCtrlThemeOffice2003 Destructors, CXTHeaderCtrlThemeOffice2003 Constructors, CXTHeaderCtrlThemeOffice2003 Destructors, CXTHeaderCtrlThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOffice2003 Class

CXTHeaderCtrlThemeOffice2003 is a CXTHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control.

Class Hierarchy

class CXTHeaderCtrlThemeOffice2003 : public CXTHeaderCtrlTheme;
File

XTHeaderCtrlTheme.h

Remarks

The CXTHeaderCtrlThemeOffice2003 class provides theme capability to the CXTHeaderCtrl class. You can derive a class from CXTHeaderCtrlThemeOffice2003 to custom user defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTHeaderCtrl base class. Once you have done this you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Group

Classes

Legend
Method
virtual
protected
CXTHeaderCtrlThemeOffice2003 Constructors
CXTHeaderCtrlThemeOffice2003 Constructors | Description
CXTHeaderCtrlThemeOffice2003 | Constructs a CXTHeaderCtrlThemeOffice2003 object using the specified header control.
CXTHeaderCtrlThemeOffice2003 Destructors
CXTHeaderCtrlThemeOffice2003 Destructors | Description
~CXTHeaderCtrlThemeOffice2003 | Destroys a CXTHeaderCtrlThemeOffice2003 object, handles cleanup and deallocation.
CXTHeaderCtrlThemeOffice2003 Methods
CXTHeaderCtrlThemeOffice2003 Methods | Description
Layout | Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.
OnDrawBackground | This member function is called by the theme to draw the header control's background.
OnDrawItemBackground | This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.


CXTHeaderCtrlThemeOffice2003 Methods

CXTHeaderCtrlThemeOffice2003 Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOffice2003 Methods
Class

CXTHeaderCtrlThemeOffice2003 Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnDrawBackground | This member function is called by the theme to draw the header control's background.
OnDrawItemBackground | This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.
Public Methods
Public Methods
Public Method | Description
Layout | Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.


CXTHeaderCtrlThemeOffice2003::Layout Method

CXTHeaderCtrlThemeOffice2003 Methods, CXTHeaderCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOffice2003::Layout Method

Retrieves the size and position of a header control within a given rectangle. This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.

virtual BOOL Layout(
    LPHDLAYOUT lpHDL,
    CXTHeaderCtrl* pHeaderCtrl
);
Parameters

lpHDL
Pointer to anHDLAYOUT structure, which contains information used to set the size and position of a header control.
pHeaderCtrl
Points to a CXTHeaderCtrl object.

Returns

Nonzero if successful; otherwise 0.

Group

CXTHeaderCtrlThemeOffice2003 Methods


CXTHeaderCtrlThemeOffice2003::OnDrawBackground Method

CXTHeaderCtrlThemeOffice2003 Methods, CXTHeaderCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOffice2003::OnDrawBackground Method

This member function is called by the theme to draw the header control's background.

virtual void OnDrawBackground(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Group

CXTHeaderCtrlThemeOffice2003 Methods


CXTHeaderCtrlThemeOffice2003::OnDrawItemBackground Method

CXTHeaderCtrlThemeOffice2003 Methods, CXTHeaderCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOffice2003::OnDrawItemBackground Method

This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.

virtual void OnDrawItemBackground(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Group

CXTHeaderCtrlThemeOffice2003 Methods


CXTHeaderCtrlThemeOffice2003 Constructors

CXTHeaderCtrlThemeOffice2003 Class, Legend, Public Methods
CXTHeaderCtrlThemeOffice2003 Constructors
Class

CXTHeaderCtrlThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrlThemeOffice2003 | Constructs a CXTHeaderCtrlThemeOffice2003 object using the specified header control.


CXTHeaderCtrlThemeOffice2003::CXTHeaderCtrlThemeOffice2003 Constructor

CXTHeaderCtrlThemeOffice2003 Constructors, CXTHeaderCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOffice2003::CXTHeaderCtrlThemeOffice2003 Constructor

Constructs a CXTHeaderCtrlThemeOffice2003 object using the specified header control.

CXTHeaderCtrlThemeOffice2003();
Parameters

pHeaderCtrl
Pointer to the header control to be themed.

Group

CXTHeaderCtrlThemeOffice2003 Constructors


CXTHeaderCtrlThemeOffice2003 Destructors

CXTHeaderCtrlThemeOffice2003 Class, Legend, Public Methods
CXTHeaderCtrlThemeOffice2003 Destructors
Class

CXTHeaderCtrlThemeOffice2003 Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTHeaderCtrlThemeOffice2003 | Destroys a CXTHeaderCtrlThemeOffice2003 object, handles cleanup and deallocation.


CXTHeaderCtrlThemeOffice2003::~CXTHeaderCtrlThemeOffice2003 Destructor

CXTHeaderCtrlThemeOffice2003 Destructors, CXTHeaderCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOffice2003::~CXTHeaderCtrlThemeOffice2003 Destructor

Destroys a CXTHeaderCtrlThemeOffice2003 object, handles cleanup and deallocation.

virtual ~CXTHeaderCtrlThemeOffice2003();
Group

CXTHeaderCtrlThemeOffice2003 Destructors


CXTHeaderCtrlThemeOfficeXP Class

XTHeaderCtrlTheme.h, Classes, Legend, Members, Topics, CXTHeaderCtrlThemeOfficeXP Methods, CXTHeaderCtrlThemeOfficeXP Constructors, CXTHeaderCtrlThemeOfficeXP Destructors, CXTHeaderCtrlThemeOfficeXP Constructors, CXTHeaderCtrlThemeOfficeXP Destructors, CXTHeaderCtrlThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOfficeXP Class

CXTHeaderCtrlThemeOfficeXP is a CXTHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control.

Class Hierarchy

class CXTHeaderCtrlThemeOfficeXP : public CXTHeaderCtrlTheme;
File

XTHeaderCtrlTheme.h

Remarks

The CXTHeaderCtrlThemeOfficeXP class provides theme capability to the CXTHeaderCtrl class. You can derive a class from CXTHeaderCtrlThemeOfficeXP to custom user defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTHeaderCtrl base class. Once you have done this you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Group

Classes

Legend
Method
protected
virtual
CXTHeaderCtrlThemeOfficeXP Constructors
CXTHeaderCtrlThemeOfficeXP Constructors | Description
CXTHeaderCtrlThemeOfficeXP | Constructs a CXTHeaderCtrlThemeOfficeXP object using the specified header control.
CXTHeaderCtrlThemeOfficeXP Destructors
CXTHeaderCtrlThemeOfficeXP Destructors | Description
~CXTHeaderCtrlThemeOfficeXP | Destroys a CXTHeaderCtrlThemeOfficeXP object, handles cleanup and deallocation.
CXTHeaderCtrlThemeOfficeXP Methods
CXTHeaderCtrlThemeOfficeXP Methods | Description
OnDrawBackground | This member function is called by the theme to draw the header control's background.
OnDrawItemBackground | This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.


CXTHeaderCtrlThemeOfficeXP Methods

CXTHeaderCtrlThemeOfficeXP Class, Legend, Protected Methods
CXTHeaderCtrlThemeOfficeXP Methods
Class

CXTHeaderCtrlThemeOfficeXP Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnDrawBackground | This member function is called by the theme to draw the header control's background.
OnDrawItemBackground | This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.


CXTHeaderCtrlThemeOfficeXP::OnDrawBackground Method

CXTHeaderCtrlThemeOfficeXP Methods, CXTHeaderCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOfficeXP::OnDrawBackground Method

This member function is called by the theme to draw the header control's background.

virtual void OnDrawBackground(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Group

CXTHeaderCtrlThemeOfficeXP Methods


CXTHeaderCtrlThemeOfficeXP::OnDrawItemBackground Method

CXTHeaderCtrlThemeOfficeXP Methods, CXTHeaderCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOfficeXP::OnDrawItemBackground Method

This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.

virtual void OnDrawItemBackground(
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Group

CXTHeaderCtrlThemeOfficeXP Methods


CXTHeaderCtrlThemeOfficeXP Constructors

CXTHeaderCtrlThemeOfficeXP Class, Legend, Public Methods
CXTHeaderCtrlThemeOfficeXP Constructors
Class

CXTHeaderCtrlThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrlThemeOfficeXP | Constructs a CXTHeaderCtrlThemeOfficeXP object using the specified header control.


CXTHeaderCtrlThemeOfficeXP::CXTHeaderCtrlThemeOfficeXP Constructor

CXTHeaderCtrlThemeOfficeXP Constructors, CXTHeaderCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOfficeXP::CXTHeaderCtrlThemeOfficeXP Constructor

Constructs a CXTHeaderCtrlThemeOfficeXP object using the specified header control.

CXTHeaderCtrlThemeOfficeXP();
Parameters

pHeaderCtrl
Pointer to the header control to be themed.

Group

CXTHeaderCtrlThemeOfficeXP Constructors


CXTHeaderCtrlThemeOfficeXP Destructors

CXTHeaderCtrlThemeOfficeXP Class, Legend, Public Methods
CXTHeaderCtrlThemeOfficeXP Destructors
Class

CXTHeaderCtrlThemeOfficeXP Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTHeaderCtrlThemeOfficeXP | Destroys a CXTHeaderCtrlThemeOfficeXP object, handles cleanup and deallocation.


CXTHeaderCtrlThemeOfficeXP::~CXTHeaderCtrlThemeOfficeXP Destructor

CXTHeaderCtrlThemeOfficeXP Destructors, CXTHeaderCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHeaderCtrlThemeOfficeXP::~CXTHeaderCtrlThemeOfficeXP Destructor

Destroys a CXTHeaderCtrlThemeOfficeXP object, handles cleanup and deallocation.

virtual ~CXTHeaderCtrlThemeOfficeXP();
Group

CXTHeaderCtrlThemeOfficeXP Destructors


CXTHexEdit Class

XTHexEdit.h, Classes, Legend, Members, Topics, CXTHexEdit Enumerations, CXTHexEdit Data Members, CXTHexEdit Methods, CXTHexEdit Constructors, CXTHexEdit Destructors, CXTHexEdit Constructors, CXTHexEdit Data Members, CXTHexEdit Destructors, CXTHexEdit Enumerations, CXTHexEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHexEdit Class

CXTHexEdit is a CEdit derived class. It is used to create an edit control which will allow editing in hex display format.

Class Hierarchy

class CXTHexEdit : public CXTHexEditBase;
File

XTHexEdit.h

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
CXTHexEdit Constructors
CXTHexEdit Constructors | Description
CXTHexEdit | Constructs a CXTHexEdit object
CXTHexEdit Data Members
CXTHexEdit Data Members | Description
m_bAddressIsWide | 4/8 byte address.
m_bAllowDeletes | A boolean value indicating whether or not deletions are allowed.
m_bDynamicBPR | Calculate bytes-per-row dynamically.
m_bShowAddress | TRUE when showing the address part.
m_bShowAscii | TRUE when showing the ASCII part.
m_bShowCaret | TRUE to display a flashing caret at the current caret position.
m_bShowHex | TRUE when showing the hex part.
m_bUpdate | Value used internally to indicate that the font and size info need to be updated on the next paint cycle.
m_crBack | RGB value that represents the background color of the hex edit control.
m_crDisabledBack | RGB value that represents the disabled background color for the hex edit control.
m_crDisabledHighlightBack | RGB value that represents the disabled highlighted background color of the hex edit control.
m_crDisabledHighlightText | RGB value that represents the disabled highlighted text color of the hex edit control.
m_crDisabledText | RGB value that represents the disabled text color of the hex edit control.
m_crHighlightBack | RGB value that represents the highlighted background color of the hex edit control.
m_crHighlightText | RGB value that represents the highlighted text color of the hex edit control.
m_crText | RGB value that represents the text color of the hex edit control.
m_dwBaseAddress | Base address for data.
m_eEditMode | Current editing mode: address/hex/ASCII.
m_fontHex | Represents the default font used by the hex edit control.
m_nBytePerRow | Bytes per row.
m_nCurrentAddress | Address under the cursor.
m_nLength | Length of data.
m_nLineHeight | Height in pixels of a single line displayed in the control.
m_nLinesPerPage | Lines per page.
m_nMaxLength | Maximum size of data.
m_nNullWidth | Width in pixels of a single character displayed in the control (uniform width).
m_nOffAddress | Internally used value - X position where address part starts.
m_nOffAscii | Internally used value - X position where ASCII part starts.
m_nOffHex | Internally used value - X position where hex part starts.
m_nSelEnd | End address of the selection.
m_nSelStart | Start address of the selection.
m_nTopIndex | Offset of first visible byte on the screen.
m_pData | Pointer to data.
m_ptEditPos | Current caret position.
m_szCaret | Current size of caret.
CXTHexEdit Destructors
CXTHexEdit Destructors | Description
~CXTHexEdit | Destroys a CXTHexEdit object, handles cleanup and deallocation
CXTHexEdit Enumerations
CXTHexEdit Enumerations | Description
EditMode | Enumeration used to determine current editing mode.
CXTHexEdit Methods
CXTHexEdit Methods | Description
EnableCaret | This member function enables or disables a flashing screen caret.
EnableScrollBars | This member function enables or disables a vertical and horizontal scroll bar display.
GetActualBackColor | Call this member function to return the current background color for the hex edit control. The current background color depends on the enabled, disabled, or read-only state of the control.
GetActualHighlightBackColor | Call this member function to return the current highlight background color for the hex edit control. The current highlight background color depends on the enabled, disabled, or read-only state of the control.
GetActualHighlightTextColor | Call this member function to return the current highlight text color for the hex edit control. The current highlight text color depends on the enabled, disabled, or read-only state of the control.
GetActualTextColor | Call this member function to return the current text color for the hex edit control. The current text color depends on the enabled, disabled, or read-only state of the control.
GetAllowDeletes | This member function retrieves the current value of the Allow Deletes setting.
GetBackColor | Call this member function to retrieve the current background color for the hex edit control.
GetData | Call this method to extract the data in the hex edit control.
GetDisabledBackColor | Call this member function to retrieve the current disabled background color for the hex edit control.
GetDisabledHighlightBackColor | Call this member function to retrieve the current disabled highlight background color for the hex edit control.
GetDisabledHighlightTextColor | Call this member function to retrieve the current disabled highlight text color for the hex edit control.
GetDisabledTextColor | Call this member function to retrieve the current disabled text color for the hex edit control.
GetHighlightBackColor | Call this member function to retrieve the current highlight background color for the hex edit control.
GetHighlightTextColor | Call this member function to retrieve the current highlighted text color for the hex edit control.
GetSel | Call this member function to get the size of the current selection.
GetTextColor | Call this member function to retrieve the current text color for the hex edit control.
IsReadOnly | Call this member function to determine if the control in readonly state
OnChange | This method is called when user change text.
RestoreDefaultFont | This member function sets the font for the hex edit control to the default "Courier New" font.
SetAddressBase | Call this member function to set the base address for the hex edit control.
SetAllowDeletes | Call this method to allow or disallow the deletion of characters within the control. For instance, calling SetAllowDeletes(false) will disable the delete, backspace, and other such keys.
SetBackColor | Call this member function to set the background color for the hex edit control.
SetBPR | Call this member function to set the number of bytes per row.
SetData | Call this member function to initialize the hex edit control with data specified by 'pData'.
SetDisabledBackColor | Call this member function to set the disabled background color for the hex edit control.
SetDisabledHighlightBackColor | Call this member function to set the disabled highlight background color for the hex edit control.
SetDisabledHighlightTextColor | Call this member function to set the disabled highlight text color for the hex edit control.
SetDisabledTextColor | Call this member function to set the disabled text color for the hex edit control.
SetHexFont |
SetHighlightBackColor | Call this member function to set the highlight background color for the hex edit control.
SetHighlightTextColor | Call this member function to set the highlighted text color for the hex edit control.
SetOptions | Call this member function to set the display options for the hex edit control.
SetSel | Call this member function to set the current selection.
SetTextColor | Call this member function to set the text color for the hex edit control.


CXTHexEdit Enumerations

Enumerations, CXTHexEdit Class, Legend
CXTHexEdit Enumerations
Enumerations
Enumeration | Description
EditMode | Enumeration used to determine current editing mode.
Class

CXTHexEdit Class

Legend
Enumeration


CXTHexEdit::EditMode Enumeration

XTHexEdit.h, CXTHexEdit Enumerations, See Also
CXTHexEdit::EditMode Enumeration

Enumeration used to determine current editing mode.

enum EditMode {
  editNone,
  editAscii,
  editHigh,
  editLow
};
File

XTHexEdit.h

Members

editNone
No editing mode specified.
editAscii
ASCII editing mode.
editHigh
High editing mode.
editLow
Low editing mode.

Remarks

EditMode type defines the constants used by the CXTHexEdit class to determine the current editing mode.

See Also

CXTHexEdit

Group

CXTHexEdit Enumerations


CXTHexEdit Data Members

CXTHexEdit Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHexEdit Data Members
Class

CXTHexEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bShowCaret | TRUE to display a flashing caret at the current caret position.
m_crBack | RGB value that represents the background color of the hex edit control.
m_crDisabledBack | RGB value that represents the disabled background color for the hex edit control.
m_crDisabledHighlightBack | RGB value that represents the disabled highlighted background color of the hex edit control.
m_crDisabledHighlightText | RGB value that represents the disabled highlighted text color of the hex edit control.
m_crDisabledText | RGB value that represents the disabled text color of the hex edit control.
m_crHighlightBack | RGB value that represents the highlighted background color of the hex edit control.
m_crHighlightText | RGB value that represents the highlighted text color of the hex edit control.
m_crText | RGB value that represents the text color of the hex edit control.
m_fontHex | Represents the default font used by the hex edit control.
m_szCaret | Current size of caret.
Public Data Members
Public Data Member | Description
m_bAddressIsWide | 4/8 byte address.
m_bAllowDeletes | A boolean value indicating whether or not deletions are allowed.
m_bDynamicBPR | Calculate bytes-per-row dynamically.
m_bShowAddress | TRUE when showing the address part.
m_bShowAscii | TRUE when showing the ASCII part.
m_bShowHex | TRUE when showing the hex part.
m_bUpdate | Value used internally to indicate that the font and size info need to be updated on the next paint cycle.
m_dwBaseAddress | Base address for data.
m_eEditMode | Current editing mode: address/hex/ASCII.
m_nBytePerRow | Bytes per row.
m_nCurrentAddress | Address under the cursor.
m_nLength | Length of data.
m_nLineHeight | Height in pixels of a single line displayed in the control.
m_nLinesPerPage | Lines per page.
m_nMaxLength | Maximum size of data.
m_nNullWidth | Width in pixels of a single character displayed in the control (uniform width).
m_nOffAddress | Internally used value - X position where address part starts.
m_nOffAscii | Internally used value - X position where ASCII part starts.
m_nOffHex | Internally used value - X position where hex part starts.
m_nSelEnd | End address of the selection.
m_nSelStart | Start address of the selection.
m_nTopIndex | Offset of first visible byte on the screen.
m_pData | Pointer to data.
m_ptEditPos | Current caret position.


CXTHexEdit::m_bAddressIsWide Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_bAddressIsWide Data Member

4/8 byte address.

BOOL m_bAddressIsWide;
Group

CXTHexEdit Data Members


CXTHexEdit::m_bAllowDeletes Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_bAllowDeletes Data Member

A boolean value indicating whether or not deletions are allowed.

bool m_bAllowDeletes;
Group

CXTHexEdit Data Members


CXTHexEdit::m_bDynamicBPR Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_bDynamicBPR Data Member

Calculate bytes-per-row dynamically.

BOOL m_bDynamicBPR;
Group

CXTHexEdit Data Members


CXTHexEdit::m_bShowAddress Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_bShowAddress Data Member

TRUE when showing the address part.

BOOL m_bShowAddress;
Group

CXTHexEdit Data Members


CXTHexEdit::m_bShowAscii Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_bShowAscii Data Member

TRUE when showing the ASCII part.

BOOL m_bShowAscii;
Group

CXTHexEdit Data Members


CXTHexEdit::m_bShowCaret Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_bShowCaret Data Member

TRUE to display a flashing caret at the current caret position.

BOOL m_bShowCaret;
Group

CXTHexEdit Data Members


CXTHexEdit::m_bShowHex Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_bShowHex Data Member

TRUE when showing the hex part.

BOOL m_bShowHex;
Group

CXTHexEdit Data Members


CXTHexEdit::m_bUpdate Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_bUpdate Data Member

Value used internally to indicate that the font and size info need to be updated on the next paint cycle.

BOOL m_bUpdate;
Group

CXTHexEdit Data Members


CXTHexEdit::m_crBack Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_crBack Data Member

RGB value that represents the background color of the hex edit control.

COLORREF m_crBack;
Group

CXTHexEdit Data Members


CXTHexEdit::m_crDisabledBack Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_crDisabledBack Data Member

RGB value that represents the disabled background color for the hex edit control.

COLORREF m_crDisabledBack;
Group

CXTHexEdit Data Members


CXTHexEdit::m_crDisabledHighlightBack Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_crDisabledHighlightBack Data Member

RGB value that represents the disabled highlighted background color of the hex edit control.

COLORREF m_crDisabledHighlightBack;
Group

CXTHexEdit Data Members


CXTHexEdit::m_crDisabledHighlightText Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_crDisabledHighlightText Data Member

RGB value that represents the disabled highlighted text color of the hex edit control.

COLORREF m_crDisabledHighlightText;
Group

CXTHexEdit Data Members


CXTHexEdit::m_crDisabledText Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_crDisabledText Data Member

RGB value that represents the disabled text color of the hex edit control.

COLORREF m_crDisabledText;
Group

CXTHexEdit Data Members


CXTHexEdit::m_crHighlightBack Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_crHighlightBack Data Member

RGB value that represents the highlighted background color of the hex edit control.

COLORREF m_crHighlightBack;
Group

CXTHexEdit Data Members


CXTHexEdit::m_crHighlightText Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_crHighlightText Data Member

RGB value that represents the highlighted text color of the hex edit control.

COLORREF m_crHighlightText;
Group

CXTHexEdit Data Members


CXTHexEdit::m_crText Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_crText Data Member

RGB value that represents the text color of the hex edit control.

COLORREF m_crText;
Group

CXTHexEdit Data Members


CXTHexEdit::m_dwBaseAddress Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_dwBaseAddress Data Member

Base address for data.

DWORD m_dwBaseAddress;
Group

CXTHexEdit Data Members


CXTHexEdit::m_eEditMode Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_eEditMode Data Member

Current editing mode: address/hex/ASCII.

EditMode m_eEditMode;
Group

CXTHexEdit Data Members


CXTHexEdit::m_fontHex Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_fontHex Data Member

Represents the default font used by the hex edit control.

CFont m_fontHex;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nBytePerRow Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nBytePerRow Data Member

Bytes per row.

int m_nBytePerRow;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nCurrentAddress Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nCurrentAddress Data Member

Address under the cursor.

int m_nCurrentAddress;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nLength Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nLength Data Member

Length of data.

int m_nLength;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nLineHeight Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nLineHeight Data Member

Height in pixels of a single line displayed in the control.

int m_nLineHeight;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nLinesPerPage Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nLinesPerPage Data Member

Lines per page.

int m_nLinesPerPage;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nMaxLength Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nMaxLength Data Member

Maximum size of data.

UINT m_nMaxLength;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nNullWidth Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nNullWidth Data Member

Width in pixels of a single character displayed in the control (uniform width).

int m_nNullWidth;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nOffAddress Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nOffAddress Data Member

Internally used value - X position where address part starts.

int m_nOffAddress;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nOffAscii Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nOffAscii Data Member

Internally used value - X position where ASCII part starts.

int m_nOffAscii;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nOffHex Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nOffHex Data Member

Internally used value - X position where hex part starts.

int m_nOffHex;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nSelEnd Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nSelEnd Data Member

End address of the selection.

int m_nSelEnd;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nSelStart Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nSelStart Data Member

Start address of the selection.

int m_nSelStart;
Group

CXTHexEdit Data Members


CXTHexEdit::m_nTopIndex Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_nTopIndex Data Member

Offset of first visible byte on the screen.

int m_nTopIndex;
Group

CXTHexEdit Data Members


CXTHexEdit::m_pData Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_pData Data Member

Pointer to data.

LPBYTE m_pData;
Group

CXTHexEdit Data Members


CXTHexEdit::m_ptEditPos Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_ptEditPos Data Member

Current caret position.

CPoint m_ptEditPos;
Group

CXTHexEdit Data Members


CXTHexEdit::m_szCaret Data Member

CXTHexEdit Data Members, CXTHexEdit Class
CXTHexEdit::m_szCaret Data Member

Current size of caret.

CSize m_szCaret;
Group

CXTHexEdit Data Members


CXTHexEdit Methods

CXTHexEdit Class, Legend, Public Methods
CXTHexEdit Methods
Class

CXTHexEdit Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
EnableCaret | This member function enables or disables a flashing screen caret.
EnableScrollBars | This member function enables or disables a vertical and horizontal scroll bar display.
GetActualBackColor | Call this member function to return the current background color for the hex edit control. The current background color depends on the enabled, disabled, or read-only state of the control.
GetActualHighlightBackColor | Call this member function to return the current highlight background color for the hex edit control. The current highlight background color depends on the enabled, disabled, or read-only state of the control.
GetActualHighlightTextColor | Call this member function to return the current highlight text color for the hex edit control. The current highlight text color depends on the enabled, disabled, or read-only state of the control.
GetActualTextColor | Call this member function to return the current text color for the hex edit control. The current text color depends on the enabled, disabled, or read-only state of the control.
GetAllowDeletes | This member function retrieves the current value of the Allow Deletes setting.
GetBackColor | Call this member function to retrieve the current background color for the hex edit control.
GetData | Call this method to extract the data in the hex edit control.
GetDisabledBackColor | Call this member function to retrieve the current disabled background color for the hex edit control.
GetDisabledHighlightBackColor | Call this member function to retrieve the current disabled highlight background color for the hex edit control.
GetDisabledHighlightTextColor | Call this member function to retrieve the current disabled highlight text color for the hex edit control.
GetDisabledTextColor | Call this member function to retrieve the current disabled text color for the hex edit control.
GetHighlightBackColor | Call this member function to retrieve the current highlight background color for the hex edit control.
GetHighlightTextColor | Call this member function to retrieve the current highlighted text color for the hex edit control.
GetSel | Call this member function to get the size of the current selection.
GetTextColor | Call this member function to retrieve the current text color for the hex edit control.
IsReadOnly | Call this member function to determine if the control in readonly state
OnChange | This method is called when user change text.
RestoreDefaultFont | This member function sets the font for the hex edit control to the default "Courier New" font.
SetAddressBase | Call this member function to set the base address for the hex edit control.
SetAllowDeletes | Call this method to allow or disallow the deletion of characters within the control. For instance, calling SetAllowDeletes(false) will disable the delete, backspace, and other such keys.
SetBackColor | Call this member function to set the background color for the hex edit control.
SetBPR | Call this member function to set the number of bytes per row.
SetData | Call this member function to initialize the hex edit control with data specified by 'pData'.
SetDisabledBackColor | Call this member function to set the disabled background color for the hex edit control.
SetDisabledHighlightBackColor | Call this member function to set the disabled highlight background color for the hex edit control.
SetDisabledHighlightTextColor | Call this member function to set the disabled highlight text color for the hex edit control.
SetDisabledTextColor | Call this member function to set the disabled text color for the hex edit control.
SetHexFont |
SetHighlightBackColor | Call this member function to set the highlight background color for the hex edit control.
SetHighlightTextColor | Call this member function to set the highlighted text color for the hex edit control.
SetOptions | Call this member function to set the display options for the hex edit control.
SetSel | Call this member function to set the current selection.
SetTextColor | Call this member function to set the text color for the hex edit control.


CXTHexEdit::EnableCaret Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::EnableCaret Method

This member function enables or disables a flashing screen caret.

void EnableCaret(
    bool bEnable
);
Parameters

bEnable
true to enable caret, false to disable.

Body Source
void CXTHexEdit::EnableCaret(bool bEnable) {
    m_bShowCaret = bEnable;
}
Group

CXTHexEdit Methods


CXTHexEdit::EnableScrollBars Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::EnableScrollBars Method

This member function enables or disables a vertical and horizontal scroll bar display.

void EnableScrollBars(
    bool bVertical,
    bool bHorizontal
);
Parameters

bVertical
true to display vertical scroll bar.
bHorizontal
true to display horizontal scroll bar.

Group

CXTHexEdit Methods


CXTHexEdit::GetActualBackColor Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::GetActualBackColor Method

Call this member function to return the current background color for the hex edit control. The current background color depends on the enabled, disabled, or read-only state of the control.

COLORREF GetActualBackColor();
Returns

An RGB value that represents the current background color for the control.

Group

CXTHexEdit Methods


CXTHexEdit::GetActualHighlightBackColor Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::GetActualHighlightBackColor Method

Call this member function to return the current highlight background color for the hex edit control. The current highlight background color depends on the enabled, disabled, or read-only state of the control.

COLORREF GetActualHighlightBackColor();
Returns

An RGB value that represents the current highlight background color for the control.

Group

CXTHexEdit Methods


CXTHexEdit::GetActualHighlightTextColor Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::GetActualHighlightTextColor Method

Call this member function to return the current highlight text color for the hex edit control. The current highlight text color depends on the enabled, disabled, or read-only state of the control.

COLORREF GetActualHighlightTextColor();
Returns

An RGB value that represents the current highlight text color for the control.

Group

CXTHexEdit Methods


CXTHexEdit::GetActualTextColor Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::GetActualTextColor Method

Call this member function to return the current text color for the hex edit control. The current text color depends on the enabled, disabled, or read-only state of the control.

COLORREF GetActualTextColor();
Returns

An RGB value that represents the current text color for the control.

Group

CXTHexEdit Methods


CXTHexEdit::GetAllowDeletes Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source, See Also
CXTHexEdit::GetAllowDeletes Method

This member function retrieves the current value of the Allow Deletes setting.

bool GetAllowDeletes() const;
Returns

true if the Allow Deletes setting is enabled, or false if it is disabled.

See Also

SetAllowDeletes

Body Source
bool CXTHexEdit::GetAllowDeletes() const {
    return m_bAllowDeletes;
}
Group

CXTHexEdit Methods


CXTHexEdit::GetBackColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetBackColor Method

Call this member function to retrieve the current background color for the hex edit control.

COLORREF GetBackColor();
Returns

An RGB value that represents the current background color for the hex edit control.

Body Source
COLORREF CXTHexEdit::GetBackColor() {
    return m_crBack;
}
Group

CXTHexEdit Methods


CXTHexEdit::GetData Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::GetData Method

Call this method to extract the data in the hex edit control.

int GetData(
    LPBYTE pData,
    int nBufferLength
);
Parameters

pData
Pointer to the buffer that will be receiving the data.
nBufferLength
Length of the target data buffer.

Returns

The length of the data.

Group

CXTHexEdit Methods


CXTHexEdit::GetDisabledBackColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetDisabledBackColor Method

Call this member function to retrieve the current disabled background color for the hex edit control.

COLORREF GetDisabledBackColor();
Returns

An RGB value that represents the current disabled background color for the hex edit control.

Body Source
COLORREF CXTHexEdit::GetDisabledBackColor() {
    return m_crDisabledBack;
}
Group

CXTHexEdit Methods


CXTHexEdit::GetDisabledHighlightBackColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetDisabledHighlightBackColor Method

Call this member function to retrieve the current disabled highlight background color for the hex edit control.

COLORREF GetDisabledHighlightBackColor();
Returns

An RGB value that represents the current disabled highlight background color for the hex edit control.

Body Source
COLORREF CXTHexEdit::GetDisabledHighlightBackColor() {
    return m_crDisabledHighlightBack;
}
Group

CXTHexEdit Methods


CXTHexEdit::GetDisabledHighlightTextColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetDisabledHighlightTextColor Method

Call this member function to retrieve the current disabled highlight text color for the hex edit control.

COLORREF GetDisabledHighlightTextColor();
Returns

An RGB value that represents the current disabled highlight text color for the hex edit control.

Body Source
COLORREF CXTHexEdit::GetDisabledHighlightTextColor() {
    return m_crDisabledHighlightText;
}
Group

CXTHexEdit Methods


CXTHexEdit::GetDisabledTextColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetDisabledTextColor Method

Call this member function to retrieve the current disabled text color for the hex edit control.

COLORREF GetDisabledTextColor();
Returns

An RGB value that represents the current disabled text color for the hex edit control.

Body Source
COLORREF CXTHexEdit::GetDisabledTextColor() {
    return m_crDisabledText;
}
Group

CXTHexEdit Methods


CXTHexEdit::GetHighlightBackColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetHighlightBackColor Method

Call this member function to retrieve the current highlight background color for the hex edit control.

COLORREF GetHighlightBackColor();
Returns

An RGB value that represents the current highlight background color for the hex edit control.

Body Source
COLORREF CXTHexEdit::GetHighlightBackColor() {
    return m_crHighlightBack;
}
Group

CXTHexEdit Methods


CXTHexEdit::GetHighlightTextColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetHighlightTextColor Method

Call this member function to retrieve the current highlighted text color for the hex edit control.

COLORREF GetHighlightTextColor();
Returns

An RGB value that represents the current highlighted text color for the hex edit control.

Body Source
COLORREF CXTHexEdit::GetHighlightTextColor() {
    return m_crHighlightText;
}
Group

CXTHexEdit Methods


CXTHexEdit::GetSel Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetSel Method

Call this member function to get the size of the current selection.

CSize GetSel();
Returns

A CSize object.

Body Source
CSize CXTHexEdit::GetSel() {
    return CSize(m_nSelStart, m_nSelEnd);
}
Group

CXTHexEdit Methods


CXTHexEdit::GetTextColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::GetTextColor Method

Call this member function to retrieve the current text color for the hex edit control.

COLORREF GetTextColor();
Returns

An RGB value that represents the current text color for the hex edit control.

Body Source
COLORREF CXTHexEdit::GetTextColor() {
    return m_crText;
}
Group

CXTHexEdit Methods


CXTHexEdit::IsReadOnly Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::IsReadOnly Method

Call this member function to determine if the control in readonly state

BOOL IsReadOnly() const;
Group

CXTHexEdit Methods


CXTHexEdit::OnChange Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::OnChange Method

This method is called when user change text.

virtual void OnChange();
Group

CXTHexEdit Methods


CXTHexEdit::RestoreDefaultFont Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::RestoreDefaultFont Method

This member function sets the font for the hex edit control to the default "Courier New" font.

void RestoreDefaultFont();
Group

CXTHexEdit Methods


CXTHexEdit::SetAddressBase Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::SetAddressBase Method

Call this member function to set the base address for the hex edit control.

DWORD SetAddressBase(
    DWORD dwBase
);
Parameters

dwBase
DWORD value that represents the base address.

Returns

A DWORD value.

Group

CXTHexEdit Methods


CXTHexEdit::SetAllowDeletes Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetAllowDeletes Method

Call this method to allow or disallow the deletion of characters within the control. For instance, calling SetAllowDeletes(false) will disable the delete, backspace, and other such keys.

bool SetAllowDeletes(
    bool bVal = true
);
Parameters

bVal
The new value for this setting.

Returns

The previous value.

Body Source
bool CXTHexEdit::SetAllowDeletes(bool bVal) {
    const bool bOldVal = m_bAllowDeletes; m_bAllowDeletes = bVal; return bOldVal;
}
Group

CXTHexEdit Methods


CXTHexEdit::SetBackColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetBackColor Method

Call this member function to set the background color for the hex edit control.

void SetBackColor(
    COLORREF crBack
);
Parameters

crBack
An RGB value that represents the background color of the hex edit control.

Body Source
void CXTHexEdit::SetBackColor(COLORREF crBack) {
    m_crBack = crBack;
}
Group

CXTHexEdit Methods


CXTHexEdit::SetBPR Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetBPR Method

Call this member function to set the number of bytes per row.

void SetBPR(
    int nBytePerRow
);
Parameters

nBytePerRow
Represents the number of bytes to display.

Body Source
void CXTHexEdit::SetBPR(int nBytePerRow) {
    m_nBytePerRow = nBytePerRow; m_bUpdate = TRUE; RepositionCaret(m_nCurrentAddress);
}
Group

CXTHexEdit Methods


CXTHexEdit::SetData Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::SetData Method

Call this member function to initialize the hex edit control with data specified by 'pData'.

void SetData(
    LPBYTE pData,
    int nLength,
    int nMaxLength = 0
);
Parameters

pData
Pointer to a buffer that contains the initial data for the control.
nLength
Length of the data buffer.
nMaxLength
Optional maximum length that the buffer can grow, or -1 if you want to allow the buffer to grow indefinitely.

Group

CXTHexEdit Methods


CXTHexEdit::SetDisabledBackColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetDisabledBackColor Method

Call this member function to set the disabled background color for the hex edit control.

void SetDisabledBackColor(
    COLORREF crDisabledBack
);
Parameters

crDisabledBack
An RGB value that represents the disabled background color of the hex edit control.

Body Source
void CXTHexEdit::SetDisabledBackColor(COLORREF crDisabledBack) {
    m_crDisabledBack = crDisabledBack;
}
Group

CXTHexEdit Methods


CXTHexEdit::SetDisabledHighlightBackColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetDisabledHighlightBackColor Method

Call this member function to set the disabled highlight background color for the hex edit control.

void SetDisabledHighlightBackColor(
    COLORREF crDisabledHighlight
);
Parameters

crDisabledHighlight
An RGB value that represents the disabled highlight background color of the hex edit control.

Body Source
void CXTHexEdit::SetDisabledHighlightBackColor(COLORREF crDisabledHighlightBack) {
    m_crDisabledHighlightBack = crDisabledHighlightBack;
}
Group

CXTHexEdit Methods


CXTHexEdit::SetDisabledHighlightTextColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetDisabledHighlightTextColor Method

Call this member function to set the disabled highlight text color for the hex edit control.

void SetDisabledHighlightTextColor(
    COLORREF crDisabledHighlightText
);
Parameters

crDisabledHighlightText
An RGB value that represents the disabled highlight text color of the hex edit control.

Body Source
void CXTHexEdit::SetDisabledHighlightTextColor(COLORREF crDisabledHighlightText) {
    m_crDisabledHighlightText = crDisabledHighlightText;
}
Group

CXTHexEdit Methods


CXTHexEdit::SetDisabledTextColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetDisabledTextColor Method

Call this member function to set the disabled text color for the hex edit control.

void SetDisabledTextColor(
    COLORREF crDisabledText
);
Parameters

crDisabledText
An RGB value that represents the disabled text color of the hex edit control.

Body Source
void CXTHexEdit::SetDisabledTextColor(COLORREF crDisabledText) {
    m_crDisabledText = crDisabledText;
}
Group

CXTHexEdit Methods


SetHexFont Method

CXTHexEdit Methods
SetHexFont Method
Overload List
Methods
Method | Description
CXTHexEdit::SetHexFont (CFont*) | This member function sets the font used by the hex edit control.
CXTHexEdit::SetHexFont (LOGFONT*) | This member function sets the font used by the hex edit control.
Group

CXTHexEdit Methods


CXTHexEdit::SetHexFont Method (CFont*)

SetHexFont Method, CXTHexEdit Class
CXTHexEdit::SetHexFont Method (CFont*)

This member function sets the font used by the hex edit control.

void SetHexFont(
    CFont* pFont
);
void SetHexFont(
    LOGFONT* pLogFont
);
Parameters

pFont
Points to a valid CFont object.
pLogFont
Points to a valid LOGFONT structure.

Group

SetHexFont Method


CXTHexEdit::SetHighlightBackColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetHighlightBackColor Method

Call this member function to set the highlight background color for the hex edit control.

void SetHighlightBackColor(
    COLORREF crHighlight
);
Parameters

crHighlight
An RGB value that represents the highlight background color of the hex edit control.

Body Source
void CXTHexEdit::SetHighlightBackColor(COLORREF crHighlightBack) {
    m_crHighlightBack = crHighlightBack;
}
Group

CXTHexEdit Methods


CXTHexEdit::SetHighlightTextColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetHighlightTextColor Method

Call this member function to set the highlighted text color for the hex edit control.

void SetHighlightTextColor(
    COLORREF crHighlightText
);
Parameters

crHighlightText
An RGB value that represents the highlighted text color of the hex edit control.

Body Source
void CXTHexEdit::SetHighlightTextColor(COLORREF crHighlightText) {
    m_crHighlightText = crHighlightText;
}
Group

CXTHexEdit Methods


CXTHexEdit::SetOptions Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetOptions Method

Call this member function to set the display options for the hex edit control.

void SetOptions(
    BOOL bShowAddress,
    BOOL bShowHex,
    BOOL bShowAscii,
    BOOL bAddressIsWide
);
Parameters

bShowAddress
TRUE to display the address value.
bShowHex
TRUE to display the hex value.
bShowAscii
TRUE to display the ASCII value.
bAddressIsWide
TRUE if the display is 8 byte, FALSE for 4 byte display.

Body Source
void CXTHexEdit::SetOptions(BOOL bShowAddress, BOOL bShowHex, BOOL bShowAscii, BOOL bAddressIsWide) {
    m_bShowHex = bShowHex; m_bShowAscii = bShowAscii; m_bShowAddress = bShowAddress; m_bAddressIsWide = bAddressIsWide; m_bUpdate = TRUE; RepositionCaret(m_nCurrentAddress);
}
Group

CXTHexEdit Methods


CXTHexEdit::SetSel Method

CXTHexEdit Methods, CXTHexEdit Class
CXTHexEdit::SetSel Method

Call this member function to set the current selection.

void SetSel(
    int nSelStart,
    int nSelEnd
);
Parameters

nSelStart
Represents the position of the first character in the selection.
nSelEnd
Represents the position of the last character in the selection.

Group

CXTHexEdit Methods


CXTHexEdit::SetTextColor Method

CXTHexEdit Methods, CXTHexEdit Class, Body Source
CXTHexEdit::SetTextColor Method

Call this member function to set the text color for the hex edit control.

void SetTextColor(
    COLORREF crText
);
Parameters

crText
An RGB value that represents the text color of the hex edit control.

Body Source
void CXTHexEdit::SetTextColor(COLORREF crText) {
    m_crText = crText;
}
Group

CXTHexEdit Methods


CXTHexEdit Constructors

CXTHexEdit Class, Legend, Public Methods
CXTHexEdit Constructors
Class

CXTHexEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTHexEdit | Constructs a CXTHexEdit object


CXTHexEdit::CXTHexEdit Constructor

CXTHexEdit Constructors, CXTHexEdit Class
CXTHexEdit::CXTHexEdit Constructor

Constructs a CXTHexEdit object

CXTHexEdit();
Group

CXTHexEdit Constructors


CXTHexEdit Destructors

CXTHexEdit Class, Legend, Public Methods
CXTHexEdit Destructors
Class

CXTHexEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTHexEdit | Destroys a CXTHexEdit object, handles cleanup and deallocation


CXTHexEdit::~CXTHexEdit Destructor

CXTHexEdit Destructors, CXTHexEdit Class
CXTHexEdit::~CXTHexEdit Destructor

Destroys a CXTHexEdit object, handles cleanup and deallocation

virtual ~CXTHexEdit();
Group

CXTHexEdit Destructors


CXTHtmlView Class

XTHtmlView.h, Classes, Legend, Members, Topics, CXTHtmlView Data Members, CXTHtmlView Methods, CXTHtmlView Constructors, CXTHtmlView Destructors, CXTHtmlView Constructors, CXTHtmlView Data Members, CXTHtmlView Destructors, CXTHtmlView Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHtmlView Class

CXTHtmlView is a CFormView derived class. The CXTHtmlView class provides the functionality of the WebBrowser control within the context of MFC's document/view architecture. The WebBrowser control is a window in which the user can browse sites on the World Wide Web as well as folders in the local file system and on a network. The WebBrowser control supports hyperlinking, Uniform Resource Locator (URL) navigation, and maintains a history list.

Class Hierarchy

class CXTHtmlView : public CFormView;
File

XTHtmlView.h

Remarks

Using the CXTHtmlView Class in an MFC Application

In the standard MFC framework application (either SDI or MDI based), the view object is commonly derived from a specialized set of classes. These classes, all derived from CView, provide specialized functionality beyond that provided by CView.

Basing the application's view class on CXTHtmlView provides the view with the WebBrowser control. This effectively makes the application a web browser. The preferred method of creating a web browser-style application is to use the MFC AppWizard, and specify CXTHtmlView as the view class. For more information on implementing and using the WebBrowser control within MFC applications, see Web Browser-Style Applications.

The functionality of CXTHtmlView is designed for applications that access the Web (and/or HTML documents). The following CXTHtmlView member functions apply to the Internet Explorer application only. These functions will succeed on the WebBrowser control, but they will have no visible effect.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTHtmlView Constructors
CXTHtmlView Constructors | Description
CXTHtmlView | Constructs a CXTHtmlView object
CXTHtmlView Data Members
CXTHtmlView Data Members | Description
m_bLoading | true when loading the browser.
m_bLoadingMessage | true to display a loading message while a page is updating.
m_pBrowserApp | Points to the IWebBrowser2 object associated with this view.
m_strLoading | Loading message string.
m_wndBrowser | CWnd object that represents the internet browser control associated with this view
CXTHtmlView Destructors
CXTHtmlView Destructors | Description
~CXTHtmlView | Destroys a CXTHtmlView object, handles cleanup and deallocation
CXTHtmlView Methods
CXTHtmlView Methods | Description
Create | Call this member function to create a WebBrowser control or container for the Internet Explorer executable.
ExecWB | Call this member function to execute a command in the WebBrowser or Internet Explorer. See IWebBrowser2::ExecWB in the Platform SDK.
GetAddressBar | Call this member function to retrieve Internet Explorer's address bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
GetApplication | Call this member function to retrieve the automation object supported by the application that contains the WebBrowser control. Applies to Internet Explorer and WebBrowser.
GetBusy | Call this member function to determine whether the WebBrowser control is engaged in a navigation or downloading operation. Applies to Internet Explorer and WebBrowser.
GetContainer | Call this member function to retrieve an object that points to the container of the web browser. Applies to Internet Explorer and WebBrowser.
GetFullName | Call this member function to retrieve the full path of the file that Internet Explorer is currently displaying. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
GetFullScreen | Call this member function to determine whether the WebBrowser control is operating in full-screen mode or in normal window mode. In full-screen mode, the Internet Explorer main window is maximized and the status bar, toolbar, menu bar, and title bar are hidden. Applies to Internet Explorer and WebBrowser.
GetHeight | Call this member function to retrieve the height in pixels of the WebBrowser control's frame window.
GetHtmlDocument | Call this member function to retrieve the HTML document for the active document. Applies to Internet Explorer and WebBrowser.
GetLeft | Call this member function to retrieve the distance between the internal left edge of the WebBrowser control and the left edge of its container. Applies to Internet Explorer and WebBrowser.
GetLocationName | Call this member function to get the name of the resource being displayed in the WebBrowser. If the resource is an HTML page on the World Wide Web, the name is the title of that page. If the resource is a folder or file on the network or local computer, the name is the UNC or full path of the folder or file. Applies to Internet Explorer and WebBrowser.
GetLocationURL | Call this member function to retrieve the URL of the resource that the WebBrowser control is currently displaying. If the resource is a folder or file on the network or local computer, the name is the UNC or full path of the folder or file. Applies to Internet Explorer and WebBrowser.
GetMenuBar | Call this member function to determine whether or not the menu bar is visible. Applies to Internet Explorer and WebBrowser.
GetOffline | Call this member function to determine whether the web browser is operating offline. Applies to Internet Explorer and WebBrowser.
GetParentBrowser | Call this member function to retrieve a pointer to the parent object of the WebBrowser control. Applies to Internet Explorer and WebBrowser.
GetProperty |
GetReadyState | Call this member function to retrieve the ready state of the WebBrowser object. Applies to Internet Explorer and WebBrowser.
GetRegisterAsBrowser | Call this member function to determine whether the WebBrowser object is registered as a top-level browser for target name resolution. Applies to Internet Explorer and WebBrowser.
GetRegisterAsDropTarget | Call this member function to determine whether the WebBrowser control is registered as a drop target for navigation. Applies to Internet Explorer and WebBrowser.
GetSilent | Call this member function to determine whether any dialog boxes can be shown in the WebBrowser control. Applies to Internet Explorer and WebBrowser.
GetStatusBar | Call this member function to determine whether the WebBrowser control displays a status bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
GetTheaterMode | Call this member function to determine whether the web browser is in theater mode. When the web browser is in theater mode, the browser main window fills the entire screen, a toolbar with a minimal set of navigational tools appears, and the status bar appears in the upper right-hand corner of the screen. Applies to Internet Explorer and WebBrowser.
GetToolBar | Call this member function to determine whether the toolbar is visible.
GetTop | Call this member function to retrieve the screen coordinate of the top edge of the WebBrowser control's main window. Applies to Internet Explorer and WebBrowser.
GetTopLevelContainer | Call this member function to determine whether Internet Explorer is the top-level container of the WebBrowser control. Applies to Internet Explorer and WebBrowser.
GetType | Call this member function to retrieve the type name of the contained active document. Applies to Internet Explorer and WebBrowser.
GetVisible | Call this member function to determine if the contained object is visible. Applies to Internet Explorer and WebBrowser.
GoBack | This member function navigates backward one item in the history list. Applies to Internet Explorer and WebBrowser.
GoForward | This member function navigates forward one item in the history list. Applies to Internet Explorer and WebBrowser.
GoHome | This member function navigates to the current home or start page specified in the Internet Explorer Internet Options dialog box or the Internet Properties dialog box, accessed from the Control Panel. Applies to Internet Explorer and WebBrowser.
GoSearch | This member function navigates to the current search page, as specified in the Internet Explorer Internet Options dialog box or the Internet Properties dialog box, accessed from the Control Panel. Applies to Internet Explorer and WebBrowser.
LoadFromResource |
Navigate | Call this member function to navigate to the resource identified by a URL. Applies to Internet Explorer and WebBrowser.
Navigate2 |
OnBeforeNavigate2 | This member function is called by the framework to cause an event to fire before a navigation occurs in the web browser.
OnCommandStateChange | This member function is called by the framework to notify an application that the enabled state of a web browser command has changed.
OnDocumentComplete | This member function is called by the framework to notify an application that a document has reached the READYSTATE_COMPLETE state. Not every frame will fire this event, but each frame that fires an OnDownloadBegin event will fire a corresponding OnDocumentComplete event. The URL indicated by 'lpszURL' can be different from the URL that the browser was told to navigate to, because this URL is the canonicalized and qualified URL. For example, if an application specifies a URL of "www.microsoft.com" in a call to Navigate or Navigate2, the URL passed by OnNavigateComplete2 will be "http://www.microsoft.com/". Also, if the server has... more
OnDownloadBegin | This member function is called by the framework to begin downloading a document. This event is fired shortly after the OnBeforeNavigate2 event, unless the navigation is canceled. Any animation or "busy" indication that the container needs to display should be connected to this event.
OnDownloadComplete | This member function is called by the framework to indicate that a navigation operation finished, was halted, or failed.
OnDraw | This member function is called by the framework to draw the view. Applies to Internet Explorer and WebBrowser.
OnFullScreen | This member function is called by the framework when the FullScreen property has changed.
OnMenuBar | This member function is called by the framework when the MenuBar property has changed.
OnNavigateComplete2 | This member function is called by the framework after a navigation to a hyperlink completes (on either a window or frameset element). The URL parameter can be a PIDL in the case of a shell name space entity for which there is no URL representation. Note that the URL contained in 'strURL' can be different from the URL that the browser was told to navigate to, because this URL is the canonicalized and qualified URL. For example, if an application specifies a URL of "www.microsoft.com" in a call to Navigate or Navigate2, the URL passed by OnNavigateComplete2 will be... more
OnNavigateError | Called by the framework if navigation to a hyperlink fails. Override this method to provide custom navigation error handling.
OnNewWindow2 | This member function is called by the framework when a new window is to be created for displaying a resource. This event precedes the creation of a new window from within the WebBrowser.
OnProgressChange | This member function is called by the framework to notify an application that the progress of a download operation has been updated. The container can use the information provided by this event to display the number of bytes downloaded so far or to update a progress indicator.
OnPropertyChange | This member function is called by the framework to notify an application that PutProperty has changed the value of a property.
OnQuit | This member function is called by the framework to notify an application that the Internet Explorer application is ready to quit.
OnStatusBar | This member function is called by the framework when the StatusBar property has changed.
OnStatusTextChange | This member function is called by the framework to notify an application that the text of the status bar associated with the WebBrowser control has changed.
OnTheaterMode | This member function is called by the framework when the TheaterMode property has changed.
OnTitleChange | This member function is called by the framework to notify an application if the title of a document in the WebBrowser control becomes available or changes. For HTML, the title might change. While HTML is still downloading, the URL of the document is set as the title. After the real title (if there is one) is parsed from the HTML, the title is changed to reflect the actual title.
OnToolBar | This member function is called by the framework when the ToolBar property has changed.
OnVisible | This member function is called by the framework when the window for the WebBrowser should be shown or hidden. This allows the object control host window to behave the same way the Internet Explorer window would behave.
PutProperty |
QueryStatusWB | Call this member function to query a command status. QueryStatusWB implements the behavior of the IOleCommandTarget::QueryStatus method. Applies to Internet Explorer and WebBrowser.
Refresh | This member function reloads the URL or file that the web browser is currently displaying. Refresh contains no parameters for setting the refresh level. Applies to Internet Explorer and WebBrowser.
Refresh2 | This member function reloads the file that Internet Explorer is currently displaying. Unlike Refresh, Refresh2 contains a parameter that specifies the refresh level. Applies to Internet Explorer and WebBrowser.
SetAddressBar | Call this member function to show or hide the Internet Explorer object's address bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
SetFullScreen | Call this member function to set Internet Explorer to either full-screen or normal window mode. In full-screen mode, the Internet Explorer main window is maximized and the status bar, toolbar, menu bar, and title bar are hidden. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.
SetHeight | Call this member function to set the height of the Internet Explorer main window. Applies to Internet Explorer and WebBrowser.
SetLeft | Call this member function to set the horizontal position of the Internet Explorer main window.
SetMenuBar | Call this member function to show or hide the Internet Explorer menu bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.
SetOffline | Call this member function to set a value indicating whether the WebBrowser control is currently operating in offline mode. In offline mode, the browser reads HTML pages from the local cache rather than from the source document. Applies to Internet Explorer and WebBrowser.
SetRegisterAsBrowser | Call this member function to set a value indicating whether the WebBrowser control is registered as a top-level browser for target name resolution. A top-level browser is the browser set in the registry as the default browser. Applies to Internet Explorer and WebBrowser.
SetRegisterAsDropTarget | Call this member function to set a value indicating whether the WebBrowser control is registered as a drop target for navigation. Applies to Internet Explorer and WebBrowser.
SetSilent | Call this member function to set a value indicating whether any dialog boxes can be shown. Applies to Internet Explorer and WebBrowser.
SetStatusBar | Call this member function to display the status bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
SetTheaterMode | Call this member function to set a value indicating whether the WebBrowser control is in theater mode. When the web browser is in theater mode, the browser main window fills the entire screen, a toolbar with a minimal set of navigational tools appears, and the status bar appears in the upper right-hand corner of the screen. Applies to Internet Explorer and WebBrowser.
SetToolBar | Call this member function to show or hide the Internet Explorer toolbar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.
SetTop | Call this member function to set the distance between the internal top edge of the WebBrowser control and the top edge of its container. Applies to Internet Explorer and WebBrowser.
SetVisible | Call this member function to set the visibility state of the WebBrowser control. Applies to Internet Explorer and WebBrowser.
Stop | Call this member function to cancel any pending navigation or download operation and stop any dynamic page elements, such as background sounds and animations. Applies to Internet Explorer and WebBrowser.


CXTHtmlView Data Members

CXTHtmlView Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHtmlView Data Members
Class

CXTHtmlView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bLoading | true when loading the browser.
m_bLoadingMessage | true to display a loading message while a page is updating.
m_pBrowserApp | Points to the IWebBrowser2 object associated with this view.
m_strLoading | Loading message string.
Public Data Members
Public Data Member | Description
m_wndBrowser | CWnd object that represents the internet browser control associated with this view


CXTHtmlView::m_bLoading Data Member

CXTHtmlView Data Members, CXTHtmlView Class
CXTHtmlView::m_bLoading Data Member

true when loading the browser.

bool m_bLoading;
Group

CXTHtmlView Data Members


CXTHtmlView::m_bLoadingMessage Data Member

CXTHtmlView Data Members, CXTHtmlView Class
CXTHtmlView::m_bLoadingMessage Data Member

true to display a loading message while a page is updating.

bool m_bLoadingMessage;
Group

CXTHtmlView Data Members


CXTHtmlView::m_pBrowserApp Data Member

CXTHtmlView Data Members, CXTHtmlView Class
CXTHtmlView::m_pBrowserApp Data Member

Points to the IWebBrowser2 object associated with this view.

IWebBrowser2* m_pBrowserApp;
Group

CXTHtmlView Data Members


CXTHtmlView::m_strLoading Data Member

CXTHtmlView Data Members, CXTHtmlView Class
CXTHtmlView::m_strLoading Data Member

Loading message string.

CString m_strLoading;
Group

CXTHtmlView Data Members


CXTHtmlView::m_wndBrowser Data Member

CXTHtmlView Data Members, CXTHtmlView Class
CXTHtmlView::m_wndBrowser Data Member

CWnd object that represents the internet browser control associated with this view

CWnd m_wndBrowser;
Group

CXTHtmlView Data Members


CXTHtmlView Methods

CXTHtmlView Class, Legend, Public Methods
CXTHtmlView Methods
Class

CXTHtmlView Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Create | Call this member function to create a WebBrowser control or container for the Internet Explorer executable.
ExecWB | Call this member function to execute a command in the WebBrowser or Internet Explorer. See IWebBrowser2::ExecWB in the Platform SDK.
GetAddressBar | Call this member function to retrieve Internet Explorer's address bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
GetApplication | Call this member function to retrieve the automation object supported by the application that contains the WebBrowser control. Applies to Internet Explorer and WebBrowser.
GetBusy | Call this member function to determine whether the WebBrowser control is engaged in a navigation or downloading operation. Applies to Internet Explorer and WebBrowser.
GetContainer | Call this member function to retrieve an object that points to the container of the web browser. Applies to Internet Explorer and WebBrowser.
GetFullName | Call this member function to retrieve the full path of the file that Internet Explorer is currently displaying. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
GetFullScreen | Call this member function to determine whether the WebBrowser control is operating in full-screen mode or in normal window mode. In full-screen mode, the Internet Explorer main window is maximized and the status bar, toolbar, menu bar, and title bar are hidden. Applies to Internet Explorer and WebBrowser.
GetHeight | Call this member function to retrieve the height in pixels of the WebBrowser control's frame window.
GetHtmlDocument | Call this member function to retrieve the HTML document for the active document. Applies to Internet Explorer and WebBrowser.
GetLeft | Call this member function to retrieve the distance between the internal left edge of the WebBrowser control and the left edge of its container. Applies to Internet Explorer and WebBrowser.
GetLocationName | Call this member function to get the name of the resource being displayed in the WebBrowser. If the resource is an HTML page on the World Wide Web, the name is the title of that page. If the resource is a folder or file on the network or local computer, the name is the UNC or full path of the folder or file. Applies to Internet Explorer and WebBrowser.
GetLocationURL | Call this member function to retrieve the URL of the resource that the WebBrowser control is currently displaying. If the resource is a folder or file on the network or local computer, the name is the UNC or full path of the folder or file. Applies to Internet Explorer and WebBrowser.
GetMenuBar | Call this member function to determine whether or not the menu bar is visible. Applies to Internet Explorer and WebBrowser.
GetOffline | Call this member function to determine whether the web browser is operating offline. Applies to Internet Explorer and WebBrowser.
GetParentBrowser | Call this member function to retrieve a pointer to the parent object of the WebBrowser control. Applies to Internet Explorer and WebBrowser.
GetProperty |
GetReadyState | Call this member function to retrieve the ready state of the WebBrowser object. Applies to Internet Explorer and WebBrowser.
GetRegisterAsBrowser | Call this member function to determine whether the WebBrowser object is registered as a top-level browser for target name resolution. Applies to Internet Explorer and WebBrowser.
GetRegisterAsDropTarget | Call this member function to determine whether the WebBrowser control is registered as a drop target for navigation. Applies to Internet Explorer and WebBrowser.
GetSilent | Call this member function to determine whether any dialog boxes can be shown in the WebBrowser control. Applies to Internet Explorer and WebBrowser.
GetStatusBar | Call this member function to determine whether the WebBrowser control displays a status bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
GetTheaterMode | Call this member function to determine whether the web browser is in theater mode. When the web browser is in theater mode, the browser main window fills the entire screen, a toolbar with a minimal set of navigational tools appears, and the status bar appears in the upper right-hand corner of the screen. Applies to Internet Explorer and WebBrowser.
GetToolBar | Call this member function to determine whether the toolbar is visible.
GetTop | Call this member function to retrieve the screen coordinate of the top edge of the WebBrowser control's main window. Applies to Internet Explorer and WebBrowser.
GetTopLevelContainer | Call this member function to determine whether Internet Explorer is the top-level container of the WebBrowser control. Applies to Internet Explorer and WebBrowser.
GetType | Call this member function to retrieve the type name of the contained active document. Applies to Internet Explorer and WebBrowser.
GetVisible | Call this member function to determine if the contained object is visible. Applies to Internet Explorer and WebBrowser.
GoBack | This member function navigates backward one item in the history list. Applies to Internet Explorer and WebBrowser.
GoForward | This member function navigates forward one item in the history list. Applies to Internet Explorer and WebBrowser.
GoHome | This member function navigates to the current home or start page specified in the Internet Explorer Internet Options dialog box or the Internet Properties dialog box, accessed from the Control Panel. Applies to Internet Explorer and WebBrowser.
GoSearch | This member function navigates to the current search page, as specified in the Internet Explorer Internet Options dialog box or the Internet Properties dialog box, accessed from the Control Panel. Applies to Internet Explorer and WebBrowser.
LoadFromResource |
Navigate | Call this member function to navigate to the resource identified by a URL. Applies to Internet Explorer and WebBrowser.
Navigate2 |
OnBeforeNavigate2 | This member function is called by the framework to cause an event to fire before a navigation occurs in the web browser.
OnCommandStateChange | This member function is called by the framework to notify an application that the enabled state of a web browser command has changed.
OnDocumentComplete | This member function is called by the framework to notify an application that a document has reached the READYSTATE_COMPLETE state. Not every frame will fire this event, but each frame that fires an OnDownloadBegin event will fire a corresponding OnDocumentComplete event. The URL indicated by 'lpszURL' can be different from the URL that the browser was told to navigate to, because this URL is the canonicalized and qualified URL. For example, if an application specifies a URL of "www.microsoft.com" in a call to Navigate or Navigate2, the URL passed by OnNavigateComplete2 will be "http://www.microsoft.com/". Also, if the server has... more
OnDownloadBegin | This member function is called by the framework to begin downloading a document. This event is fired shortly after the OnBeforeNavigate2 event, unless the navigation is canceled. Any animation or "busy" indication that the container needs to display should be connected to this event.
OnDownloadComplete | This member function is called by the framework to indicate that a navigation operation finished, was halted, or failed.
OnDraw | This member function is called by the framework to draw the view. Applies to Internet Explorer and WebBrowser.
OnFullScreen | This member function is called by the framework when the FullScreen property has changed.
OnMenuBar | This member function is called by the framework when the MenuBar property has changed.
OnNavigateComplete2 | This member function is called by the framework after a navigation to a hyperlink completes (on either a window or frameset element). The URL parameter can be a PIDL in the case of a shell name space entity for which there is no URL representation. Note that the URL contained in 'strURL' can be different from the URL that the browser was told to navigate to, because this URL is the canonicalized and qualified URL. For example, if an application specifies a URL of "www.microsoft.com" in a call to Navigate or Navigate2, the URL passed by OnNavigateComplete2 will be... more
OnNavigateError | Called by the framework if navigation to a hyperlink fails. Override this method to provide custom navigation error handling.
OnNewWindow2 | This member function is called by the framework when a new window is to be created for displaying a resource. This event precedes the creation of a new window from within the WebBrowser.
OnProgressChange | This member function is called by the framework to notify an application that the progress of a download operation has been updated. The container can use the information provided by this event to display the number of bytes downloaded so far or to update a progress indicator.
OnPropertyChange | This member function is called by the framework to notify an application that PutProperty has changed the value of a property.
OnQuit | This member function is called by the framework to notify an application that the Internet Explorer application is ready to quit.
OnStatusBar | This member function is called by the framework when the StatusBar property has changed.
OnStatusTextChange | This member function is called by the framework to notify an application that the text of the status bar associated with the WebBrowser control has changed.
OnTheaterMode | This member function is called by the framework when the TheaterMode property has changed.
OnTitleChange | This member function is called by the framework to notify an application if the title of a document in the WebBrowser control becomes available or changes. For HTML, the title might change. While HTML is still downloading, the URL of the document is set as the title. After the real title (if there is one) is parsed from the HTML, the title is changed to reflect the actual title.
OnToolBar | This member function is called by the framework when the ToolBar property has changed.
OnVisible | This member function is called by the framework when the window for the WebBrowser should be shown or hidden. This allows the object control host window to behave the same way the Internet Explorer window would behave.
PutProperty |
QueryStatusWB | Call this member function to query a command status. QueryStatusWB implements the behavior of the IOleCommandTarget::QueryStatus method. Applies to Internet Explorer and WebBrowser.
Refresh | This member function reloads the URL or file that the web browser is currently displaying. Refresh contains no parameters for setting the refresh level. Applies to Internet Explorer and WebBrowser.
Refresh2 | This member function reloads the file that Internet Explorer is currently displaying. Unlike Refresh, Refresh2 contains a parameter that specifies the refresh level. Applies to Internet Explorer and WebBrowser.
SetAddressBar | Call this member function to show or hide the Internet Explorer object's address bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
SetFullScreen | Call this member function to set Internet Explorer to either full-screen or normal window mode. In full-screen mode, the Internet Explorer main window is maximized and the status bar, toolbar, menu bar, and title bar are hidden. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.
SetHeight | Call this member function to set the height of the Internet Explorer main window. Applies to Internet Explorer and WebBrowser.
SetLeft | Call this member function to set the horizontal position of the Internet Explorer main window.
SetMenuBar | Call this member function to show or hide the Internet Explorer menu bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.
SetOffline | Call this member function to set a value indicating whether the WebBrowser control is currently operating in offline mode. In offline mode, the browser reads HTML pages from the local cache rather than from the source document. Applies to Internet Explorer and WebBrowser.
SetRegisterAsBrowser | Call this member function to set a value indicating whether the WebBrowser control is registered as a top-level browser for target name resolution. A top-level browser is the browser set in the registry as the default browser. Applies to Internet Explorer and WebBrowser.
SetRegisterAsDropTarget | Call this member function to set a value indicating whether the WebBrowser control is registered as a drop target for navigation. Applies to Internet Explorer and WebBrowser.
SetSilent | Call this member function to set a value indicating whether any dialog boxes can be shown. Applies to Internet Explorer and WebBrowser.
SetStatusBar | Call this member function to display the status bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.
SetTheaterMode | Call this member function to set a value indicating whether the WebBrowser control is in theater mode. When the web browser is in theater mode, the browser main window fills the entire screen, a toolbar with a minimal set of navigational tools appears, and the status bar appears in the upper right-hand corner of the screen. Applies to Internet Explorer and WebBrowser.
SetToolBar | Call this member function to show or hide the Internet Explorer toolbar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.
SetTop | Call this member function to set the distance between the internal top edge of the WebBrowser control and the top edge of its container. Applies to Internet Explorer and WebBrowser.
SetVisible | Call this member function to set the visibility state of the WebBrowser control. Applies to Internet Explorer and WebBrowser.
Stop | Call this member function to cancel any pending navigation or download operation and stop any dynamic page elements, such as background sounds and animations. Applies to Internet Explorer and WebBrowser.


CXTHtmlView::Create Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::Create Method

Call this member function to create a WebBrowser control or container for the Internet Explorer executable.

virtual BOOL Create(
    LPCTSTR lpszClassName,
    LPCTSTR lpszWindowName,
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID,
    CCreateContext* pContext = NULL
);
Parameters

lpszClassName
Points to a null-terminated character string that names the Windows class. The class name can be any name registered with the AfxRegisterWndClass global function or the RegisterClass Windows function. If NULL, it uses the predefined default CFrameWnd attributes.
lpszWindowName
Points to a null-terminated character string that represents the window's name.
dwStyle
Specifies the window style attributes. By default, the WS_VISIBLE and WS_CHILD Windows styles are set.
rect
A reference to a RECT structure specifying the size and position of the window. The rectDefault value allows Windows to specify the size and position of the new window.
pParentWnd
A pointer to the parent window of the control.
nID
The ID number of the view. By default, set to AFX_IDW_PANE_FIRST.
pContext
A pointer to a CCreateContext. It is NULL by default.

Returns

Nonzero if successful, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::ExecWB Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::ExecWB Method

Call this member function to execute a command in the WebBrowser or Internet Explorer. See IWebBrowser2::ExecWB in the Platform SDK.

void ExecWB(
    OLECMDID cmdID,
    OLECMDEXECOPT cmdexecopt,
    VARIANT* pvaIn,
    VARIANT* pvaOut
);
Parameters

cmdID
The command to execute.
cmdexecopt
The options set for executing the command.
pvaIn
A variant used for specifying the command input arguments.
pvaOut
A variant used for specifying the command output arguments.

Group

CXTHtmlView Methods


CXTHtmlView::GetAddressBar Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetAddressBar Method

Call this member function to retrieve Internet Explorer's address bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.

BOOL GetAddressBar() const;
Returns

Nonzero if the address bar is visible, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetApplication Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetApplication Method

Call this member function to retrieve the automation object supported by the application that contains the WebBrowser control. Applies to Internet Explorer and WebBrowser.

LPDISPATCH GetApplication() const;
Returns

A pointer to the IDispatch interface of the active document object.

Group

CXTHtmlView Methods


CXTHtmlView::GetBusy Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetBusy Method

Call this member function to determine whether the WebBrowser control is engaged in a navigation or downloading operation. Applies to Internet Explorer and WebBrowser.

BOOL GetBusy() const;
Returns

Nonzero if the web browser is busy, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetContainer Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetContainer Method

Call this member function to retrieve an object that points to the container of the web browser. Applies to Internet Explorer and WebBrowser.

LPDISPATCH GetContainer() const;
Returns

A pointer to the IDispatch interface of the active document object.

Group

CXTHtmlView Methods


CXTHtmlView::GetFullName Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetFullName Method

Call this member function to retrieve the full path of the file that Internet Explorer is currently displaying. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.

CString GetFullName() const;
Returns

A CString object containing the path and name of the currently displayed file. If no path and filename exist, GetFullName returns an empty CString.

Group

CXTHtmlView Methods


CXTHtmlView::GetFullScreen Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetFullScreen Method

Call this member function to determine whether the WebBrowser control is operating in full-screen mode or in normal window mode. In full-screen mode, the Internet Explorer main window is maximized and the status bar, toolbar, menu bar, and title bar are hidden. Applies to Internet Explorer and WebBrowser.

BOOL GetFullScreen() const;
Returns

Nonzero if the WebBrowser is operating in full-screen mode, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetHeight Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetHeight Method

Call this member function to retrieve the height in pixels of the WebBrowser control's frame window.

long GetHeight() const;
Returns

The control's frame window height in pixels.

Group

CXTHtmlView Methods


CXTHtmlView::GetHtmlDocument Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetHtmlDocument Method

Call this member function to retrieve the HTML document for the active document. Applies to Internet Explorer and WebBrowser.

LPDISPATCH GetHtmlDocument() const;
Returns

A pointer to the IDispatch interface of the active document object.

Group

CXTHtmlView Methods


CXTHtmlView::GetLeft Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetLeft Method

Call this member function to retrieve the distance between the internal left edge of the WebBrowser control and the left edge of its container. Applies to Internet Explorer and WebBrowser.

long GetLeft() const;
Returns

The left-edge distance in pixels.

Group

CXTHtmlView Methods


CXTHtmlView::GetLocationName Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetLocationName Method

Call this member function to get the name of the resource being displayed in the WebBrowser. If the resource is an HTML page on the World Wide Web, the name is the title of that page. If the resource is a folder or file on the network or local computer, the name is the UNC or full path of the folder or file. Applies to Internet Explorer and WebBrowser.

CString GetLocationName() const;
Returns

A CString object containing the name of the resource currently displayed in the WebBrowser.

Group

CXTHtmlView Methods


CXTHtmlView::GetLocationURL Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetLocationURL Method

Call this member function to retrieve the URL of the resource that the WebBrowser control is currently displaying. If the resource is a folder or file on the network or local computer, the name is the UNC or full path of the folder or file. Applies to Internet Explorer and WebBrowser.

CString GetLocationURL() const;
Returns

A CString object containing the URL of the resource currently displayed in the WebBrowser.

Group

CXTHtmlView Methods


CXTHtmlView::GetMenuBar Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetMenuBar Method

Call this member function to determine whether or not the menu bar is visible. Applies to Internet Explorer and WebBrowser.

BOOL GetMenuBar() const;
Returns

Nonzero if the menu bar is visible, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetOffline Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetOffline Method

Call this member function to determine whether the web browser is operating offline. Applies to Internet Explorer and WebBrowser.

BOOL GetOffline() const;
Returns

Nonzero if the web browser is currently offline, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetParentBrowser Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetParentBrowser Method

Call this member function to retrieve a pointer to the parent object of the WebBrowser control. Applies to Internet Explorer and WebBrowser.

LPDISPATCH GetParentBrowser() const;
Returns

A pointer to the IDispatch interface of the object that is the parent of the WebBrowser control.

Group

CXTHtmlView Methods


GetProperty Method

CXTHtmlView Methods
GetProperty Method
Overload List
Methods
Method | Description
CXTHtmlView::GetProperty (LPCTSTR) | Call this member function to get the value of the property that is currently associated with the control. Applies to Internet Explorer and WebBrowser.
CXTHtmlView::GetProperty (LPCTSTR, CString&) | Call this member function to get the value of the property that is currently associated with the control. Applies to Internet Explorer and WebBrowser.
Group

CXTHtmlView Methods


CXTHtmlView::GetProperty Method (LPCTSTR)

GetProperty Method, CXTHtmlView Class
CXTHtmlView::GetProperty Method (LPCTSTR)

Call this member function to get the value of the property that is currently associated with the control. Applies to Internet Explorer and WebBrowser.

COleVariant GetProperty(
    LPCTSTR lpszProperty
);
BOOL GetProperty(
    LPCTSTR lpszProperty,
    CString& strValue
);
Parameters

lpszProperty
A pointer to a string containing the property to retrieve. A pointer to a string containing the property to retrieve.
strValue
A reference to a CString object that receives the current value of the property.

Returns

The lpszProperty version returns a COleVariant object, the BOOL version returns nonzero if completed successfully, otherwise returns zero.

Group

GetProperty Method


CXTHtmlView::GetReadyState Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetReadyState Method

Call this member function to retrieve the ready state of the WebBrowser object. Applies to Internet Explorer and WebBrowser.

READYSTATE GetReadyState() const;
Returns

A READYSTATE value as described in the Platform SDK.

Group

CXTHtmlView Methods


CXTHtmlView::GetRegisterAsBrowser Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetRegisterAsBrowser Method

Call this member function to determine whether the WebBrowser object is registered as a top-level browser for target name resolution. Applies to Internet Explorer and WebBrowser.

BOOL GetRegisterAsBrowser() const;
Returns

Nonzero if the browser is registered as a top-level browser, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetRegisterAsDropTarget Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetRegisterAsDropTarget Method

Call this member function to determine whether the WebBrowser control is registered as a drop target for navigation. Applies to Internet Explorer and WebBrowser.

BOOL GetRegisterAsDropTarget() const;
Returns

Nonzero if the browser is registered as a drop target, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetSilent Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetSilent Method

Call this member function to determine whether any dialog boxes can be shown in the WebBrowser control. Applies to Internet Explorer and WebBrowser.

BOOL GetSilent() const;
Returns

Nonzero if dialog boxes cannot be displayed from the WebBrowser control, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetStatusBar Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetStatusBar Method

Call this member function to determine whether the WebBrowser control displays a status bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.

BOOL GetStatusBar() const;
Returns

Nonzero if the status bar can be displayed, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetTheaterMode Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetTheaterMode Method

Call this member function to determine whether the web browser is in theater mode. When the web browser is in theater mode, the browser main window fills the entire screen, a toolbar with a minimal set of navigational tools appears, and the status bar appears in the upper right-hand corner of the screen. Applies to Internet Explorer and WebBrowser.

BOOL GetTheaterMode() const;
Returns

Nonzero if the web browser is in theater mode, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetToolBar Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetToolBar Method

Call this member function to determine whether the toolbar is visible.

int GetToolBar() const;
Returns

A value indicating whether the toolbar is visible. Nonzero if the toolbar is visible, otherwise zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetTop Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetTop Method

Call this member function to retrieve the screen coordinate of the top edge of the WebBrowser control's main window. Applies to Internet Explorer and WebBrowser.

long GetTop() const;
Returns

The address of a variable that receives the screen coordinate of the main window's top edge.

Group

CXTHtmlView Methods


CXTHtmlView::GetTopLevelContainer Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetTopLevelContainer Method

Call this member function to determine whether Internet Explorer is the top-level container of the WebBrowser control. Applies to Internet Explorer and WebBrowser.

BOOL GetTopLevelContainer() const;
Returns

Nonzero if the container is the top-level container, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GetType Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetType Method

Call this member function to retrieve the type name of the contained active document. Applies to Internet Explorer and WebBrowser.

CString GetType() const;
Returns

A CString object containing the type name of the contained active document.

Group

CXTHtmlView Methods


CXTHtmlView::GetVisible Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::GetVisible Method

Call this member function to determine if the contained object is visible. Applies to Internet Explorer and WebBrowser.

BOOL GetVisible() const;
Returns

Nonzero if the object is visible, otherwise returns zero.

Group

CXTHtmlView Methods


CXTHtmlView::GoBack Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::GoBack Method

This member function navigates backward one item in the history list. Applies to Internet Explorer and WebBrowser.

void GoBack();
Body Source
void CXTHtmlView::GoBack() {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->GoBack();
}
Group

CXTHtmlView Methods


CXTHtmlView::GoForward Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::GoForward Method

This member function navigates forward one item in the history list. Applies to Internet Explorer and WebBrowser.

void GoForward();
Body Source
void CXTHtmlView::GoForward() {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->GoForward();
}
Group

CXTHtmlView Methods


CXTHtmlView::GoHome Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::GoHome Method

This member function navigates to the current home or start page specified in the Internet Explorer Internet Options dialog box or the Internet Properties dialog box, accessed from the Control Panel. Applies to Internet Explorer and WebBrowser.

void GoHome();
Body Source
void CXTHtmlView::GoHome() {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->GoHome();
}
Group

CXTHtmlView Methods


CXTHtmlView::GoSearch Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::GoSearch Method

This member function navigates to the current search page, as specified in the Internet Explorer Internet Options dialog box or the Internet Properties dialog box, accessed from the Control Panel. Applies to Internet Explorer and WebBrowser.

void GoSearch();
Body Source
void CXTHtmlView::GoSearch() {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->GoSearch();
}
Group

CXTHtmlView Methods


LoadFromResource Method

CXTHtmlView Methods
LoadFromResource Method
Overload List
Methods
Method | Description
CXTHtmlView::LoadFromResource (LPCTSTR) | Call this member function to load the specified resource into the WebBrowser control. Applies to Internet Explorer and WebBrowser.
CXTHtmlView::LoadFromResource (UINT) | Call this member function to load the specified resource into the WebBrowser control. Applies to Internet Explorer and WebBrowser.
Group

CXTHtmlView Methods


CXTHtmlView::LoadFromResource Method (UINT)

LoadFromResource Method, CXTHtmlView Class
CXTHtmlView::LoadFromResource Method (UINT)

Call this member function to load the specified resource into the WebBrowser control. Applies to Internet Explorer and WebBrowser.

BOOL LoadFromResource(
    UINT nRes
);
BOOL LoadFromResource(
    LPCTSTR lpszResource
);
Parameters

nRes
The ID of the buffer containing the name of the resource to load.
lpszResource
A pointer to a string containing the name of the resource to load.

Returns

Nonzero if successful, otherwise returns zero.

Group

LoadFromResource Method


CXTHtmlView::Navigate Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::Navigate Method

Call this member function to navigate to the resource identified by a URL. Applies to Internet Explorer and WebBrowser.

void Navigate(
    LPCTSTR URL,
    DWORD dwFlags = 0,
    LPCTSTR lpszTargetFrameName = NULL,
    LPCTSTR lpszHeaders = NULL,
    LPVOID lpvPostData = NULL,
    DWORD dwPostDataLen = 0
);
Parameters

URL
A caller-allocated string that contains the URL to navigate to, or the full path of the file to display.
dwFlags
The flags of a variable that specifies whether to add the resource to the history list, whether to read to or write from the cache, and whether to display the resource in a new window. The variable can be a combination of the values defined by the BrowserNavConstants enumeration.
lpszTargetFrameName
A pointer to a string that contains the name of the frame in which to display the resource.
lpszHeaders
A pointer to a value that specifies the HTTP headers to send to the server. These headers are added to the default Internet Explorer headers. The headers can specify such things as the action required of the server, the type of data being passed to the server, or a status code. This parameter is ignored if the URL is not an HTTP URL.
lpvPostData
A pointer to the data to send with the HTTP POST transaction. For example, the POST transaction is used to send data gathered by an HTML form. If this parameter does not specify any post data, Navigate issues an HTTP GET transaction. This parameter is ignored if the URL is not an HTTP URL.
dwPostDataLen
Data to send with the HTTP POST transaction. For example, the POST transaction is used to send data gathered by an HTML form. If this parameter does not specify any post data, Navigate issues an HTTP GET transaction. This parameter is ignored if the URL is not an HTTP URL.

Group

CXTHtmlView Methods


Navigate2 Method

CXTHtmlView Methods
Navigate2 Method
Overload List
Methods
Method | Description
CXTHtmlView::Navigate2 (LPCTSTR, DWORD, CByteArray&, LPCTSTR, LPCTSTR) | Call this member function to navigate to the resource identified by a URL, or to the file identified by a full path. This member function extends the Navigate member function by supporting browsing on special folders, such as Desktop and My Computer, that are represented by the parameter 'pIDL'. Applies to Internet Explorer and WebBrowser.
CXTHtmlView::Navigate2 (LPCTSTR, DWORD, LPCTSTR, LPCTSTR, LPVOID, DWORD) | Call this member function to navigate to the resource identified by a URL, or to the file identified by a full path. This member function extends the Navigate member function by supporting browsing on special folders, such as Desktop and My Computer, that are represented by the parameter 'pIDL'. Applies to Internet Explorer and WebBrowser.
CXTHtmlView::Navigate2 (LPITEMIDLIST, DWORD, LPCTSTR) | Call this member function to navigate to the resource identified by a URL, or to the file identified by a full path. This member function extends the Navigate member function by supporting browsing on special folders, such as Desktop and My Computer, that are represented by the parameter 'pIDL'. Applies to Internet Explorer and WebBrowser.
Group

CXTHtmlView Methods


CXTHtmlView::Navigate2 Method (LPITEMIDLIST, DWORD, LPCTSTR)

Navigate2 Method, CXTHtmlView Class
CXTHtmlView::Navigate2 Method (LPITEMIDLIST, DWORD, LPCTSTR)

Call this member function to navigate to the resource identified by a URL, or to the file identified by a full path. This member function extends the Navigate member function by supporting browsing on special folders, such as Desktop and My Computer, that are represented by the parameter 'pIDL'. Applies to Internet Explorer and WebBrowser.

void Navigate2(
    LPITEMIDLIST pIDL,
    DWORD dwFlags = 0,
    LPCTSTR lpszTargetFrameName = NULL
);
void Navigate2(
    LPCTSTR lpszURL,
    DWORD dwFlags = 0,
    LPCTSTR lpszTargetFrameName = NULL,
    LPCTSTR lpszHeaders = NULL,
    LPVOID lpvPostData = NULL,
    DWORD dwPostDataLen = 0
);
void Navigate2(
    LPCTSTR lpszURL,
    DWORD dwFlags,
    CByteArray& baPostedData,
    LPCTSTR lpszTargetFrameName = NULL,
    LPCTSTR lpszHeader = NULL
);
Parameters

pIDL
A pointer to an ITEMIDLIST structure.
dwFlags
The flags of a variable that specifies whether to add the resource to the history list, whether to read to or write from the cache, and whether to display the resource in a new window. The variable can be a combination of the values defined by the BrowserNavConstants enumeration.
lpszTargetFrameName
A pointer to a string that contains the name of the frame in which to display the resource.
lpszURL
A pointer to a string containing the URL.
lpszHeaders
A pointer to a value that specifies the HTTP headers to send to the server. These headers are added to the default Internet Explorer headers. The headers can specify such things as the action required of the server, the type of data being passed to the server, or a status code. This parameter is ignored if the URL is not an HTTP URL.
lpvPostData
Data to send with the HTTP POST transaction. For example, the POST transaction is used to send data gathered by an HTML form. If this parameter does not specify any post data, Navigate2 issues an HTTP GET transaction. This parameter is ignored if the URL is not an HTTP URL.
dwPostDataLen
Length in bytes of the data pointed to by the 'lpvPostData' parameter.
baPostedData
A reference to a CByteArray object
lpszHeader
A pointer to a value that specifies the HTTP headers to send to the server. These headers are added to the default Internet Explorer headers. The headers can specify such things as the action required of the server, the type of data being passed to the server, or a status code. This parameter is ignored if the URL is not an HTTP URL.

Group

Navigate2 Method


CXTHtmlView::OnBeforeNavigate2 Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnBeforeNavigate2 Method

This member function is called by the framework to cause an event to fire before a navigation occurs in the web browser.

virtual void OnBeforeNavigate2(
    LPCTSTR lpszURL,
    DWORD nFlags,
    LPCTSTR lpszTargetFrameName,
    CByteArray& baPostedData,
    LPCTSTR lpszHeaders,
    BOOL* pbCancel
);
Parameters

lpszURL
Pointer to a string containing the URL to navigate to.
nFlags
Reserved for future use.
lpszTargetFrameName
A string that contains the name of the frame in which to display the resource, or NULL if no named frame is targeted for the resource.
baPostedData
A reference to a CByteArray object containing the data to send to the server if the HTTP POST transaction is being used.
lpszHeaders
A pointer to a string containing additional HTTP headers to send to the server (HTTP URLs only). The headers can specify such things as the action required of the server, the type of data being passed to the server, or a status code.
pbCancel
A pointer to a cancel flag. An application can set this parameter to nonzero to cancel the navigation operation, or to zero to allow it to proceed.

Group

CXTHtmlView Methods


CXTHtmlView::OnCommandStateChange Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnCommandStateChange Method

This member function is called by the framework to notify an application that the enabled state of a web browser command has changed.

virtual void OnCommandStateChange(
    long nCommand,
    BOOL bEnable
);
Parameters

nCommand
Identifier of the command whose enabled state has changed.
bEnable
Enabled state. This parameter is nonzero if the command is enabled, or zero if it is disabled.

Group

CXTHtmlView Methods


CXTHtmlView::OnDocumentComplete Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnDocumentComplete Method

This member function is called by the framework to notify an application that a document has reached the READYSTATE_COMPLETE state. Not every frame will fire this event, but each frame that fires an OnDownloadBegin event will fire a corresponding OnDocumentComplete event. The URL indicated by 'lpszURL' can be different from the URL that the browser was told to navigate to, because this URL is the canonicalized and qualified URL. For example, if an application specifies a URL of "www.microsoft.com" in a call to Navigate or Navigate2, the URL passed by OnNavigateComplete2 will be "http://www.microsoft.com/". Also, if the server has redirected the browser to a different URL, the redirected URL will be reflected here.

virtual void OnDocumentComplete(
    LPCTSTR lpszURL
);
Parameters

lpszURL
A pointer to a string that evaluates to the URL, UNC file name, or a PIDL (a pointer to an item identifier list) that was navigated to.

Group

CXTHtmlView Methods


CXTHtmlView::OnDownloadBegin Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnDownloadBegin Method

This member function is called by the framework to begin downloading a document. This event is fired shortly after the OnBeforeNavigate2 event, unless the navigation is canceled. Any animation or "busy" indication that the container needs to display should be connected to this event.

virtual void OnDownloadBegin();
Group

CXTHtmlView Methods


CXTHtmlView::OnDownloadComplete Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnDownloadComplete Method

This member function is called by the framework to indicate that a navigation operation finished, was halted, or failed.

virtual void OnDownloadComplete();
Group

CXTHtmlView Methods


CXTHtmlView::OnDraw Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnDraw Method

This member function is called by the framework to draw the view. Applies to Internet Explorer and WebBrowser.

virtual void OnDraw(
    CDC* pDC
);
Parameters

pDC
A pointer to the device context to be used for rendering an image.

Group

CXTHtmlView Methods


CXTHtmlView::OnFullScreen Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnFullScreen Method

This member function is called by the framework when the FullScreen property has changed.

virtual void OnFullScreen(
    BOOL bFullScreen
);
Parameters

bFullScreen
Nonzero if Internet Explorer is in full screen mode or zero otherwise.

Group

CXTHtmlView Methods


CXTHtmlView::OnMenuBar Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnMenuBar Method

This member function is called by the framework when the MenuBar property has changed.

virtual void OnMenuBar(
    BOOL bMenuBar
);
Parameters

bMenuBar
Nonzero if the Internet Explorer menu bar is visible or zero otherwise.

Group

CXTHtmlView Methods


CXTHtmlView::OnNavigateComplete2 Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnNavigateComplete2 Method

This member function is called by the framework after a navigation to a hyperlink completes (on either a window or frameset element). The URL parameter can be a PIDL in the case of a shell name space entity for which there is no URL representation. Note that the URL contained in 'strURL' can be different from the URL that the browser was told to navigate to, because this URL is the canonicalized and qualified URL. For example, if an application specifies a URL of "www.microsoft.com" in a call to Navigate or Navigate2, the URL passed by OnNavigateComplete2 will be "http://www.microsoft.com/". Also, if the server has redirected the browser to a different URL, the redirected URL will be reflected here.

virtual void OnNavigateComplete2(
    LPCTSTR strURL
);
Parameters

strURL
A string expression that evaluates to the URL, UNC file name, or PIDL (a pointer to an item identifier list) that was navigated to.

Group

CXTHtmlView Methods


CXTHtmlView::OnNavigateError Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnNavigateError Method

Called by the framework if navigation to a hyperlink fails. Override this method to provide custom navigation error handling.

virtual void OnNavigateError(
    LPCTSTR lpszURL,
    LPCTSTR lpszFrame,
    DWORD dwError,
    BOOL* pbCancel
);
Parameters

lpszURL
The URL for which navigation failed.
lpszFrame
The name of the frame in which the resource is to be displayed, or NULL if no named frame was targeted for the resource.
dwError
An error status code, if available. For a list of the possible HRESULT and HTTP status codes, see NavigateError Event Status Codes.
pbCancel
Specifies whether to cancel the navigation to an error page or any further autosearch. If TRUE (the default), continue with navigation to an error page or autosearch; if FALSE, cancel navigation to an error page or autosearch.

Group

CXTHtmlView Methods


CXTHtmlView::OnNewWindow2 Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnNewWindow2 Method

This member function is called by the framework when a new window is to be created for displaying a resource. This event precedes the creation of a new window from within the WebBrowser.

virtual void OnNewWindow2(
    LPDISPATCH* ppDisp,
    BOOL* Cancel
);
Parameters

ppDisp
A pointer to an interface pointer that, optionally, receives the IDispatch interface pointer of a new WebBrowser or Internet Explorer object.
Cancel
A pointer to a cancel flag. An application can set this parameter to nonzero to cancel the navigation operation, or to zero to allow it to proceed.

Group

CXTHtmlView Methods


CXTHtmlView::OnProgressChange Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnProgressChange Method

This member function is called by the framework to notify an application that the progress of a download operation has been updated. The container can use the information provided by this event to display the number of bytes downloaded so far or to update a progress indicator.

virtual void OnProgressChange(
    long nProgress,
    long nProgressMax
);
Parameters

nProgress
Amount of total progress to show, or -1 when progress is complete.
nProgressMax
Maximum progress value.

Group

CXTHtmlView Methods


CXTHtmlView::OnPropertyChange Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnPropertyChange Method

This member function is called by the framework to notify an application that PutProperty has changed the value of a property.

virtual void OnPropertyChange(
    LPCTSTR lpszProperty
);
Parameters

lpszProperty
A pointer to a string containing the name of the property.

Group

CXTHtmlView Methods


CXTHtmlView::OnQuit Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnQuit Method

This member function is called by the framework to notify an application that the Internet Explorer application is ready to quit.

virtual void OnQuit();
Group

CXTHtmlView Methods


CXTHtmlView::OnStatusBar Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnStatusBar Method

This member function is called by the framework when the StatusBar property has changed.

virtual void OnStatusBar(
    BOOL bStatusBar
);
Parameters

bStatusBar
Nonzero if Internet Explorer's status bar is visible or zero otherwise.

Group

CXTHtmlView Methods


CXTHtmlView::OnStatusTextChange Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnStatusTextChange Method

This member function is called by the framework to notify an application that the text of the status bar associated with the WebBrowser control has changed.

virtual void OnStatusTextChange(
    LPCTSTR lpszText
);
Parameters

lpszText
A string that contains the new status bar text.

Group

CXTHtmlView Methods


CXTHtmlView::OnTheaterMode Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnTheaterMode Method

This member function is called by the framework when the TheaterMode property has changed.

virtual void OnTheaterMode(
    BOOL bTheaterMode
);
Parameters

bTheaterMode
Nonzero if Internet Explorer is in theater mode or zero otherwise.

Group

CXTHtmlView Methods


CXTHtmlView::OnTitleChange Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnTitleChange Method

This member function is called by the framework to notify an application if the title of a document in the WebBrowser control becomes available or changes. For HTML, the title might change. While HTML is still downloading, the URL of the document is set as the title. After the real title (if there is one) is parsed from the HTML, the title is changed to reflect the actual title.

virtual void OnTitleChange(
    LPCTSTR lpszText
);
Parameters

lpszText
The new document title.

Group

CXTHtmlView Methods


CXTHtmlView::OnToolBar Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnToolBar Method

This member function is called by the framework when the ToolBar property has changed.

virtual void OnToolBar(
    BOOL bToolBar
);
Parameters

bToolBar
Nonzero if Internet Explorer's toolbar is visible or zero otherwise.

Group

CXTHtmlView Methods


CXTHtmlView::OnVisible Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::OnVisible Method

This member function is called by the framework when the window for the WebBrowser should be shown or hidden. This allows the object control host window to behave the same way the Internet Explorer window would behave.

virtual void OnVisible(
    BOOL bVisible
);
Parameters

bVisible
Nonzero if the object is visible or zero otherwise.

Group

CXTHtmlView Methods


PutProperty Method

CXTHtmlView Methods
PutProperty Method
Overload List
Methods
Method | Description
CXTHtmlView::PutProperty (LPCTSTR, LPCTSTR) | Call this member function to set the property associated with a given object. Applies to Internet Explorer and WebBrowser.
CXTHtmlView::PutProperty (LPCTSTR, const VARIANT&) | Call this member function to set the property associated with a given object. Applies to Internet Explorer and WebBrowser.
CXTHtmlView::PutProperty (LPCTSTR, double) | Call this member function to set the property associated with a given object. Applies to Internet Explorer and WebBrowser.
CXTHtmlView::PutProperty (LPCTSTR, long) | Call this member function to set the property associated with a given object. Applies to Internet Explorer and WebBrowser.
CXTHtmlView::PutProperty (LPCTSTR, short) | Call this member function to set the property associated with a given object. Applies to Internet Explorer and WebBrowser.
Group

CXTHtmlView Methods


CXTHtmlView::PutProperty Method (LPCTSTR, const VARIANT&)

PutProperty Method, CXTHtmlView Class
CXTHtmlView::PutProperty Method (LPCTSTR, const VARIANT&)

Call this member function to set the property associated with a given object. Applies to Internet Explorer and WebBrowser.

void PutProperty(
    LPCTSTR lpszPropertyName,
    const VARIANT& vtValue
);
void PutProperty(
    LPCTSTR lpszPropertyName,
    double dValue
);
void PutProperty(
    LPCTSTR lpszPropertyName,
    LPCTSTR lpszValue
);
void PutProperty(
    LPCTSTR lpszPropertyName,
    long lValue
);
void PutProperty(
    LPCTSTR lpszPropertyName,
    short nValue
);
Parameters

lpszPropertyName
A pointer to a string containing the name of the property to set.
vtValue
The new value of the property indicated by 'lpszProperty'.
dValue
The new value of the property.
lpszValue
A pointer to a string containing the new value of the property.
lValue
The new value of the property.
nValue
The new value of the property.

Group

PutProperty Method


CXTHtmlView::QueryStatusWB Method

CXTHtmlView Methods, CXTHtmlView Class
CXTHtmlView::QueryStatusWB Method

Call this member function to query a command status. QueryStatusWB implements the behavior of the IOleCommandTarget::QueryStatus method. Applies to Internet Explorer and WebBrowser.

OLECMDF QueryStatusWB(
    OLECMDID cmdID
) const;
Parameters

cmdID
The OLECMDID value of the command for which the caller needs status information.

Returns

The address of the OLECMDF value that receives the status of the command.

Group

CXTHtmlView Methods


CXTHtmlView::Refresh Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::Refresh Method

This member function reloads the URL or file that the web browser is currently displaying. Refresh contains no parameters for setting the refresh level. Applies to Internet Explorer and WebBrowser.

void Refresh();
Body Source
void CXTHtmlView::Refresh() {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->Refresh();
}
Group

CXTHtmlView Methods


CXTHtmlView::Refresh2 Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::Refresh2 Method

This member function reloads the file that Internet Explorer is currently displaying. Unlike Refresh, Refresh2 contains a parameter that specifies the refresh level. Applies to Internet Explorer and WebBrowser.

void Refresh2(
    int nLevel
);
Parameters

nLevel
The address of the variable specifying the refresh level. The possible variables are defined in RefreshConstants, in the Platform SDK.

Body Source
void CXTHtmlView::Refresh2(int nLevel) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->Refresh2(COleVariant((long) nLevel, VT_I4));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetAddressBar Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetAddressBar Method

Call this member function to show or hide the Internet Explorer object's address bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.

void SetAddressBar(
    BOOL bNewValue
);
Parameters

bNewValue
Nonzero to show address bar, otherwise zero.

Body Source
void CXTHtmlView::SetAddressBar(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_AddressBar((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetFullScreen Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetFullScreen Method

Call this member function to set Internet Explorer to either full-screen or normal window mode. In full-screen mode, the Internet Explorer main window is maximized and the status bar, toolbar, menu bar, and title bar are hidden. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.

void SetFullScreen(
    BOOL bNewValue
);
Parameters

bNewValue
Nonzero for full-screen mode, otherwise zero.

Body Source
void CXTHtmlView::SetFullScreen(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_FullScreen((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetHeight Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetHeight Method

Call this member function to set the height of the Internet Explorer main window. Applies to Internet Explorer and WebBrowser.

void SetHeight(
    long nNewValue
);
Parameters

nNewValue
The height in pixels of the main window.

Body Source
void CXTHtmlView::SetHeight(long nNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_Height(nNewValue);
}
Group

CXTHtmlView Methods


CXTHtmlView::SetLeft Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetLeft Method

Call this member function to set the horizontal position of the Internet Explorer main window.

void SetLeft(
    long nNewValue
);
Parameters

nNewValue
The screen coordinate of the left edge of the main window.

Body Source
void CXTHtmlView::SetLeft(long nNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_Left(nNewValue);
}
Group

CXTHtmlView Methods


CXTHtmlView::SetMenuBar Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetMenuBar Method

Call this member function to show or hide the Internet Explorer menu bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.

void SetMenuBar(
    BOOL bNewValue
);
Parameters

bNewValue
Nonzero to show the menu bar, otherwise zero.

Body Source
void CXTHtmlView::SetMenuBar(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_MenuBar((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetOffline Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetOffline Method

Call this member function to set a value indicating whether the WebBrowser control is currently operating in offline mode. In offline mode, the browser reads HTML pages from the local cache rather than from the source document. Applies to Internet Explorer and WebBrowser.

void SetOffline(
    BOOL bNewValue
);
Parameters

bNewValue
Nonzero to read from the local cache, otherwise zero.

Body Source
void CXTHtmlView::SetOffline(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_Offline((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetRegisterAsBrowser Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetRegisterAsBrowser Method

Call this member function to set a value indicating whether the WebBrowser control is registered as a top-level browser for target name resolution. A top-level browser is the browser set in the registry as the default browser. Applies to Internet Explorer and WebBrowser.

void SetRegisterAsBrowser(
    BOOL bNewValue
);
Parameters

bNewValue
Determines whether Internet Explorer is registered as a top-level browser. If nonzero, the web browser is registered as a top-level browser. If zero, it is not a top-level browser. The default value is zero.

Body Source
void CXTHtmlView::SetRegisterAsBrowser(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_RegisterAsBrowser((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetRegisterAsDropTarget Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetRegisterAsDropTarget Method

Call this member function to set a value indicating whether the WebBrowser control is registered as a drop target for navigation. Applies to Internet Explorer and WebBrowser.

void SetRegisterAsDropTarget(
    BOOL bNewValue
);
Parameters

bNewValue
Determines if the WebBrowser control is registered as a drop target for navigation. If nonzero, the object is registered as a drop target. If zero, it is not a drop target.

Body Source
void CXTHtmlView::SetRegisterAsDropTarget(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_RegisterAsDropTarget((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetSilent Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetSilent Method

Call this member function to set a value indicating whether any dialog boxes can be shown. Applies to Internet Explorer and WebBrowser.

void SetSilent(
    BOOL bNewValue
);
Parameters

bNewValue
If nonzero, dialog boxes will not be displayed. If zero, dialog boxes will be displayed. The default value is zero.

Body Source
void CXTHtmlView::SetSilent(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_Silent((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetStatusBar Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetStatusBar Method

Call this member function to display the status bar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will return no error, but it will ignore this call.

void SetStatusBar(
    BOOL bNewValue
);
Parameters

bNewValue
Nonzero if the status bar is visible, otherwise zero.

Body Source
void CXTHtmlView::SetStatusBar(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_StatusBar((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetTheaterMode Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetTheaterMode Method

Call this member function to set a value indicating whether the WebBrowser control is in theater mode. When the web browser is in theater mode, the browser main window fills the entire screen, a toolbar with a minimal set of navigational tools appears, and the status bar appears in the upper right-hand corner of the screen. Applies to Internet Explorer and WebBrowser.

void SetTheaterMode(
    BOOL bNewValue
);
Parameters

bNewValue
Nonzero to set the WebBrowser control to theater mode, otherwise zero. The default value is zero.

Body Source
void CXTHtmlView::SetTheaterMode(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_TheaterMode((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::SetToolBar Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetToolBar Method

Call this member function to show or hide the Internet Explorer toolbar. Applies to Internet Explorer. If you use this call with a WebBrowser control, it will not return an error, but it will ignore this call.

void SetToolBar(
    int nNewValue
);
Parameters

nNewValue
Indicates whether to display the toolbar. Nonzero if the toolbar is to be displayed, otherwise zero.

Body Source
void CXTHtmlView::SetToolBar(int nNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_ToolBar(nNewValue);
}
Group

CXTHtmlView Methods


CXTHtmlView::SetTop Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetTop Method

Call this member function to set the distance between the internal top edge of the WebBrowser control and the top edge of its container. Applies to Internet Explorer and WebBrowser.

void SetTop(
    long nNewValue
);
Parameters

nNewValue
The screen coordinate of the top edge of the main window.

Body Source
void CXTHtmlView::SetTop(long nNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_Top(nNewValue);
}
Group

CXTHtmlView Methods


CXTHtmlView::SetVisible Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::SetVisible Method

Call this member function to set the visibility state of the WebBrowser control. Applies to Internet Explorer and WebBrowser.

void SetVisible(
    BOOL bNewValue
);
Parameters

bNewValue
Nonzero if the control is visible, otherwise zero.

Body Source
void CXTHtmlView::SetVisible(BOOL bNewValue) {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->put_Visible((short) (bNewValue ? AFX_OLE_TRUE : AFX_OLE_FALSE));
}
Group

CXTHtmlView Methods


CXTHtmlView::Stop Method

CXTHtmlView Methods, CXTHtmlView Class, Body Source
CXTHtmlView::Stop Method

Call this member function to cancel any pending navigation or download operation and stop any dynamic page elements, such as background sounds and animations. Applies to Internet Explorer and WebBrowser.

void Stop();
Body Source
void CXTHtmlView::Stop() {
    ASSERT(m_pBrowserApp != NULL); if (m_pBrowserApp) m_pBrowserApp->Stop();
}
Group

CXTHtmlView Methods


CXTHtmlView Constructors

CXTHtmlView Class, Legend, Protected Methods
CXTHtmlView Constructors
Class

CXTHtmlView Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTHtmlView | Constructs a CXTHtmlView object


CXTHtmlView::CXTHtmlView Constructor

CXTHtmlView Constructors, CXTHtmlView Class
CXTHtmlView::CXTHtmlView Constructor

Constructs a CXTHtmlView object

CXTHtmlView();
Group

CXTHtmlView Constructors


CXTHtmlView Destructors

CXTHtmlView Class, Legend, Protected Methods
CXTHtmlView Destructors
Class

CXTHtmlView Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTHtmlView | Destroys a CXTHtmlView object, handles cleanup and deallocation


CXTHtmlView::~CXTHtmlView Destructor

CXTHtmlView Destructors, CXTHtmlView Class
CXTHtmlView::~CXTHtmlView Destructor

Destroys a CXTHtmlView object, handles cleanup and deallocation

virtual ~CXTHtmlView();
Group

CXTHtmlView Destructors


CXTHyperLink Class

XTHyperLink.h, Classes, Legend, Members, Topics, CXTHyperLink Data Members, CXTHyperLink Methods, CXTHyperLink Constructors, CXTHyperLink Destructors, CXTHyperLink Constructors, CXTHyperLink Data Members, CXTHyperLink Destructors, CXTHyperLink Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHyperLink Class

CXTHyperLink is a CStatic derived class. It is used to display a text string that is used as a hyperlink control. The link's active, hover, and selected color attributes are configurable.

Class Hierarchy

class CXTHyperLink : public CStatic;
File

XTHyperLink.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTHyperLink Constructors
CXTHyperLink Constructors | Description
CXTHyperLink | Constructs a CXTHyperLink object.
CXTHyperLink Data Members
CXTHyperLink Data Members | Description
m_bMouseOver | Set to true when the cursor is hovering over the control.
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bShellExec | true to cause the hyperlink to call ShellExecute for the specified URL.
m_bTipEnabled | Set to false to disable tooltips.
m_bUnderline | Set to true for underlined text.
m_bVisited | Set to true when the hyperlink has been activated.
m_clrBack | An RGB value representing the background fill color for the hyperlink control.
m_clrHover | An RGB value representing the color for the hyperlink text color when the mouse is hovering.
m_clrLink | An RGB value representing the color for the hyperlink text color.
m_clrVisited | An RGB value representing the color for the hyperlink text color when the URL has been visited.
m_font | Font used by hyperlink control.
m_hcurHand | Handle to the default cursor for this control.
m_strLink | String object that represents the URL for this control.
m_strTipText | String object that represents the tooltip text for this control.
m_toolTip | Tooltip to be displayed for the control.
CXTHyperLink Destructors
CXTHyperLink Destructors | Description
~CXTHyperLink | Destroys a CXTHyperLink object, handles cleanup and deallocation.
CXTHyperLink Methods
CXTHyperLink Methods | Description
CreateFont | This member function is called by the CXTHyperLink class to initialize a font that are used by the hyperlink control.
EnableShellExecute | Call this member function to enable or disable ShellExecute to be called for the URL that is specified for the hyperlink control. If disabled, you can add a BN_CLICKED message handler to perform your own task when the link is clicked.
EnableToolTips | Call this member function to enable or disable tooltips for the hyperlink control.
GetBackColor | This member function will return the current background fill color for the hyperlink control.
GetHoverColor | This member function retrieves the current hyperlink text color when the mouse hovers over the hyperlink.
GetLinkColor | This member function retrieves the current hyperlink text color.
GetLinkCursor | This member function will get a handle to the current cursor associated with the hyperlink control.
GetUnderline | This member function checks to see if the hyperlink text is underlined.
GetURL | This member function retrieves the URL for the hyperlink.
GetVisited | This member function checks to see if the user has visited the URL associated with the hyperlink.
GetVisitedColor | This member function retrieves the current hyperlink text color when the link has been activated.
GotoURL | This member function is called to execute the shell command associated with the current URL.
Init | This member function is called by the CXTHyperLink class to perform initialization when the window is created or sub-classed.
InitFont | This member function is called by the CXTHyperLink class to initialize the font that are used by the hyperlink control.
IsLinkHot | Call this member to determine if the hyperlink is currently hot.
IsTextControl | This member function checks to see if the hyperlink control is a text control.
ReportError | This member function is called by the CXTHyperLink object to display a message box whenever an error occurs.
SetBackColor | This member function will set the background fill color for the hyperlink control. By default the hyperlink control uses the system color for COLOR_3DFACE.
SetColors | This member function will set the RGB color values for the hyperlink text.
SetLinkCursor | This member function will set the cursor to be displayed when the mouse hovers over the hyperlink control.
SetTipText | Call this member function to set the tooltip text for the tooltip associated with the hyperlink control.
SetUnderline | This member function will cause the hyperlink to display the text as underlined. The default value is 'true.'
SetURL | This member function sets the URL for the hyperlink control.
SetVisited | This member function will cause the control to display the hyperlink text color as visited.


CXTHyperLink Data Members

CXTHyperLink Class, Legend, Protected Data Members
CXTHyperLink Data Members
Class

CXTHyperLink Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bMouseOver | Set to true when the cursor is hovering over the control.
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bShellExec | true to cause the hyperlink to call ShellExecute for the specified URL.
m_bTipEnabled | Set to false to disable tooltips.
m_bUnderline | Set to true for underlined text.
m_bVisited | Set to true when the hyperlink has been activated.
m_clrBack | An RGB value representing the background fill color for the hyperlink control.
m_clrHover | An RGB value representing the color for the hyperlink text color when the mouse is hovering.
m_clrLink | An RGB value representing the color for the hyperlink text color.
m_clrVisited | An RGB value representing the color for the hyperlink text color when the URL has been visited.
m_font | Font used by hyperlink control.
m_hcurHand | Handle to the default cursor for this control.
m_strLink | String object that represents the URL for this control.
m_strTipText | String object that represents the tooltip text for this control.
m_toolTip | Tooltip to be displayed for the control.


CXTHyperLink::m_bMouseOver Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_bMouseOver Data Member

Set to true when the cursor is hovering over the control.

bool m_bMouseOver;
Group

CXTHyperLink Data Members


CXTHyperLink::m_bPreSubclassInit Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_bPreSubclassInit Data Member

true when initializing from PreSubclassWindow.

bool m_bPreSubclassInit;
Group

CXTHyperLink Data Members


CXTHyperLink::m_bShellExec Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_bShellExec Data Member

true to cause the hyperlink to call ShellExecute for the specified URL.

bool m_bShellExec;
Group

CXTHyperLink Data Members


CXTHyperLink::m_bTipEnabled Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_bTipEnabled Data Member

Set to false to disable tooltips.

bool m_bTipEnabled;
Group

CXTHyperLink Data Members


CXTHyperLink::m_bUnderline Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_bUnderline Data Member

Set to true for underlined text.

bool m_bUnderline;
Group

CXTHyperLink Data Members


CXTHyperLink::m_bVisited Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_bVisited Data Member

Set to true when the hyperlink has been activated.

bool m_bVisited;
Group

CXTHyperLink Data Members


CXTHyperLink::m_clrBack Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_clrBack Data Member

An RGB value representing the background fill color for the hyperlink control.

COLORREF m_clrBack;
Group

CXTHyperLink Data Members


CXTHyperLink::m_clrHover Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_clrHover Data Member

An RGB value representing the color for the hyperlink text color when the mouse is hovering.

COLORREF m_clrHover;
Group

CXTHyperLink Data Members


CXTHyperLink::m_clrLink Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_clrLink Data Member

An RGB value representing the color for the hyperlink text color.

COLORREF m_clrLink;
Group

CXTHyperLink Data Members


CXTHyperLink::m_clrVisited Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_clrVisited Data Member

An RGB value representing the color for the hyperlink text color when the URL has been visited.

COLORREF m_clrVisited;
Group

CXTHyperLink Data Members


CXTHyperLink::m_font Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_font Data Member

Font used by hyperlink control.

CFont m_font;
Group

CXTHyperLink Data Members


CXTHyperLink::m_hcurHand Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_hcurHand Data Member

Handle to the default cursor for this control.

HCURSOR m_hcurHand;
Group

CXTHyperLink Data Members


CXTHyperLink::m_strLink Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_strLink Data Member

String object that represents the URL for this control.

CString m_strLink;
Group

CXTHyperLink Data Members


CXTHyperLink::m_strTipText Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_strTipText Data Member

String object that represents the tooltip text for this control.

CString m_strTipText;
Group

CXTHyperLink Data Members


CXTHyperLink::m_toolTip Data Member

CXTHyperLink Data Members, CXTHyperLink Class
CXTHyperLink::m_toolTip Data Member

Tooltip to be displayed for the control.

CToolTipCtrl m_toolTip;
Group

CXTHyperLink Data Members


CXTHyperLink Methods

CXTHyperLink Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTHyperLink Methods
Class

CXTHyperLink Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CreateFont | This member function is called by the CXTHyperLink class to initialize a font that are used by the hyperlink control.
Init | This member function is called by the CXTHyperLink class to perform initialization when the window is created or sub-classed.
InitFont | This member function is called by the CXTHyperLink class to initialize the font that are used by the hyperlink control.
Public Methods
Public Methods
Public Method | Description
EnableShellExecute | Call this member function to enable or disable ShellExecute to be called for the URL that is specified for the hyperlink control. If disabled, you can add a BN_CLICKED message handler to perform your own task when the link is clicked.
EnableToolTips | Call this member function to enable or disable tooltips for the hyperlink control.
GetBackColor | This member function will return the current background fill color for the hyperlink control.
GetHoverColor | This member function retrieves the current hyperlink text color when the mouse hovers over the hyperlink.
GetLinkColor | This member function retrieves the current hyperlink text color.
GetLinkCursor | This member function will get a handle to the current cursor associated with the hyperlink control.
GetUnderline | This member function checks to see if the hyperlink text is underlined.
GetURL | This member function retrieves the URL for the hyperlink.
GetVisited | This member function checks to see if the user has visited the URL associated with the hyperlink.
GetVisitedColor | This member function retrieves the current hyperlink text color when the link has been activated.
GotoURL | This member function is called to execute the shell command associated with the current URL.
IsLinkHot | Call this member to determine if the hyperlink is currently hot.
IsTextControl | This member function checks to see if the hyperlink control is a text control.
ReportError | This member function is called by the CXTHyperLink object to display a message box whenever an error occurs.
SetBackColor | This member function will set the background fill color for the hyperlink control. By default the hyperlink control uses the system color for COLOR_3DFACE.
SetColors | This member function will set the RGB color values for the hyperlink text.
SetLinkCursor | This member function will set the cursor to be displayed when the mouse hovers over the hyperlink control.
SetTipText | Call this member function to set the tooltip text for the tooltip associated with the hyperlink control.
SetUnderline | This member function will cause the hyperlink to display the text as underlined. The default value is 'true.'
SetURL | This member function sets the URL for the hyperlink control.
SetVisited | This member function will cause the control to display the hyperlink text color as visited.


CXTHyperLink::CreateFont Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::CreateFont Method

This member function is called by the CXTHyperLink class to initialize a font that are used by the hyperlink control.

virtual BOOL CreateFont(
    CFont& font,
    BOOL bUnderline
);
Parameters

font
Reference to the font to be created
bUnderline
TRUE to create underline font

Returns

TRUE if the control was successfully initialized, otherwise FALSE.

Group

CXTHyperLink Methods


CXTHyperLink::EnableShellExecute Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::EnableShellExecute Method

Call this member function to enable or disable ShellExecute to be called for the URL that is specified for the hyperlink control. If disabled, you can add a BN_CLICKED message handler to perform your own task when the link is clicked.

void EnableShellExecute(
    bool bEnable
);
Parameters

bEnable
true to enable ShellExecute, false to disable.

Body Source
void CXTHyperLink::EnableShellExecute(bool bEnable) {
    m_bShellExec = bEnable;
}
Group

CXTHyperLink Methods


CXTHyperLink::EnableToolTips Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::EnableToolTips Method

Call this member function to enable or disable tooltips for the hyperlink control.

void EnableToolTips(
    bool bEnable = true
);
Parameters

bEnable
true to enable tooltips.

Group

CXTHyperLink Methods


CXTHyperLink::GetBackColor Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::GetBackColor Method

This member function will return the current background fill color for the hyperlink control.

virtual COLORREF GetBackColor() const;
Returns

A COLOREF value.

Body Source
COLORREF CXTHyperLink::GetBackColor() const {
    return (m_clrBack == (COLORREF)-1) ? GetXtremeColor(COLOR_3DFACE) : m_clrBack;
}
Group

CXTHyperLink Methods


CXTHyperLink::GetHoverColor Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::GetHoverColor Method

This member function retrieves the current hyperlink text color when the mouse hovers over the hyperlink.

virtual COLORREF GetHoverColor() const;
Returns

An RGB color value that represents the current hyperlink text color when the mouse hovers over the hyperlink.

Body Source
COLORREF CXTHyperLink::GetHoverColor() const {
    return m_clrHover;
}
Group

CXTHyperLink Methods


CXTHyperLink::GetLinkColor Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::GetLinkColor Method

This member function retrieves the current hyperlink text color.

virtual COLORREF GetLinkColor() const;
Returns

An RGB color value that represents the current hyperlink text color.

Body Source
COLORREF CXTHyperLink::GetLinkColor() const {
    return m_clrLink;
}
Group

CXTHyperLink Methods


CXTHyperLink::GetLinkCursor Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::GetLinkCursor Method

This member function will get a handle to the current cursor associated with the hyperlink control.

virtual HCURSOR GetLinkCursor() const;
Returns

A handle to the current cursor for the hyperlink control.

Body Source
HCURSOR CXTHyperLink::GetLinkCursor() const {
    return m_hcurHand;
}
Group

CXTHyperLink Methods


CXTHyperLink::GetUnderline Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::GetUnderline Method

This member function checks to see if the hyperlink text is underlined.

virtual bool GetUnderline() const;
Returns

true if the hyperlink text is underlined, otherwise returns false.

Body Source
bool CXTHyperLink::GetUnderline() const {
    return m_bUnderline;
}
Group

CXTHyperLink Methods


CXTHyperLink::GetURL Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::GetURL Method

This member function retrieves the URL for the hyperlink.

virtual CString GetURL() const;
Returns

A CString object that represents the URL for the hyperlink control.

Body Source
CString CXTHyperLink::GetURL() const {
    return m_strLink;
}
Group

CXTHyperLink Methods


CXTHyperLink::GetVisited Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::GetVisited Method

This member function checks to see if the user has visited the URL associated with the hyperlink.

virtual bool GetVisited() const;
Returns

true if the URL has been visited, otherwise returns false.

Body Source
bool CXTHyperLink::GetVisited() const {
    return m_bVisited;
}
Group

CXTHyperLink Methods


CXTHyperLink::GetVisitedColor Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::GetVisitedColor Method

This member function retrieves the current hyperlink text color when the link has been activated.

virtual COLORREF GetVisitedColor() const;
Returns

An RGB color value that represents the current hyperlink text color when the link has been activated.

Body Source
COLORREF CXTHyperLink::GetVisitedColor() const {
    return m_clrVisited;
}
Group

CXTHyperLink Methods


CXTHyperLink::GotoURL Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::GotoURL Method

This member function is called to execute the shell command associated with the current URL.

virtual bool GotoURL(
    LPCTSTR lpszLink = NULL,
    int nShowCmd = SW_SHOW,
    LPCTSTR lpszParams = NULL,
    LPCTSTR lpszDir = NULL
);
Parameters

lpszLink
Points to a null terminated string that represents the URL to jump to. If NULL, the default URL is activated.
nShowCmd
Display state for shell command associated with the URL. The default is SW_SHOW.
lpszParams
Points to a null terminated string that represents additional parameters that are to be passed to the ShellExecute command.
lpszDir
Points to a null terminated string that represents the default directory.

Returns

TRUE if SUCCESSFUL, otherwise FALSE.

Group

CXTHyperLink Methods


CXTHyperLink::Init Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::Init Method

This member function is called by the CXTHyperLink class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTHyperLink Methods


CXTHyperLink::InitFont Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::InitFont Method

This member function is called by the CXTHyperLink class to initialize the font that are used by the hyperlink control.

virtual bool InitFont();
Returns

true if the font was successfully created, otherwise false.

Group

CXTHyperLink Methods


CXTHyperLink::IsLinkHot Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::IsLinkHot Method

Call this member to determine if the hyperlink is currently hot.

virtual bool IsLinkHot();
Returns

TRUE if the hyperlink is currently hot. FALSE otherwise.

Remarks

If the link is hot, the mouse pointer is positioned over the link.

Group

CXTHyperLink Methods


CXTHyperLink::IsTextControl Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::IsTextControl Method

This member function checks to see if the hyperlink control is a text control.

virtual bool IsTextControl();
Returns

true if the hyperlink control is a text control, otherwise returns false.

Body Source
bool CXTHyperLink::IsTextControl() {
    return ((GetStyle() & 0xFF) <= SS_RIGHT) ? true : false;
}
Group

CXTHyperLink Methods


CXTHyperLink::ReportError Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::ReportError Method

This member function is called by the CXTHyperLink object to display a message box whenever an error occurs.

virtual void ReportError(
    int iErrorNo
);
Parameters

iErrorNo
See the ShellExecute API for a list of error codes.

Group

CXTHyperLink Methods


CXTHyperLink::SetBackColor Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::SetBackColor Method

This member function will set the background fill color for the hyperlink control. By default the hyperlink control uses the system color for COLOR_3DFACE.

virtual void SetBackColor(
    COLORREF clrBack
);
Parameters

clrBack
An RGB value representing the background fill color.

Body Source
void CXTHyperLink::SetBackColor(COLORREF clrBack) {
    m_clrBack = clrBack; RedrawWindow();
}
Group

CXTHyperLink Methods


CXTHyperLink::SetColors Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::SetColors Method

This member function will set the RGB color values for the hyperlink text.

virtual void SetColors(
    COLORREF clrLink,
    COLORREF clrVisited,
    COLORREF clrHover
);
Parameters

clrLink
An RGB value representing the color for the hyperlink text color.
clrVisited
An RGB value representing the color for the hyperlink text color when the mouse is hovering.
clrHover
An RGB value representing the color for the hyperlink text color when the URL has been visited.

Body Source
void CXTHyperLink::SetColors(COLORREF clrLink, COLORREF clrVisited, COLORREF clrHover) {
    m_clrLink = clrLink; m_clrVisited = clrVisited; m_clrHover = clrHover; RedrawWindow();
}
Group

CXTHyperLink Methods


CXTHyperLink::SetLinkCursor Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::SetLinkCursor Method

This member function will set the cursor to be displayed when the mouse hovers over the hyperlink control.

virtual void SetLinkCursor(
    HCURSOR hCursor
);
Parameters

hCursor
Handle of the cursor to be associated with the hyperlink control.

Body Source
void CXTHyperLink::SetLinkCursor(HCURSOR hCursor) {
    m_hcurHand = hCursor;
}
Group

CXTHyperLink Methods


CXTHyperLink::SetTipText Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::SetTipText Method

Call this member function to set the tooltip text for the tooltip associated with the hyperlink control.

void SetTipText(
    LPCTSTR lpszTipText
);
Parameters

lpszTipText
NULL terminated string that represents the new tooltip text to display.

Group

CXTHyperLink Methods


CXTHyperLink::SetUnderline Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::SetUnderline Method

This member function will cause the hyperlink to display the text as underlined. The default value is 'true.'

virtual void SetUnderline(
    bool bUnderline = true
);
Parameters

bUnderline
A boolean flag that, when set to true, causes the control to display the text as underlined.

Body Source
void CXTHyperLink::SetUnderline(bool bUnderline) {
    m_bUnderline = bUnderline; InitFont();
}
Group

CXTHyperLink Methods


CXTHyperLink::SetURL Method

CXTHyperLink Methods, CXTHyperLink Class
CXTHyperLink::SetURL Method

This member function sets the URL for the hyperlink control.

virtual void SetURL(
    LPCTSTR lpszLink
);
Parameters

lpszLink
A NULL terminated character string that represents the URL for the hyperlink.

Group

CXTHyperLink Methods


CXTHyperLink::SetVisited Method

CXTHyperLink Methods, CXTHyperLink Class, Body Source
CXTHyperLink::SetVisited Method

This member function will cause the control to display the hyperlink text color as visited.

virtual void SetVisited(
    bool bVisited = true
);
Parameters

bVisited
A boolean flag that, when set to true, causes the control to display the hyperlink text color as visited.

Body Source
void CXTHyperLink::SetVisited(bool bVisited) {
    m_bVisited = bVisited; RedrawWindow();
}
Group

CXTHyperLink Methods


CXTHyperLink Constructors

CXTHyperLink Class, Legend, Public Methods
CXTHyperLink Constructors
Class

CXTHyperLink Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTHyperLink | Constructs a CXTHyperLink object.


CXTHyperLink::CXTHyperLink Constructor

CXTHyperLink Constructors, CXTHyperLink Class
CXTHyperLink::CXTHyperLink Constructor

Constructs a CXTHyperLink object.

CXTHyperLink();
Group

CXTHyperLink Constructors


CXTHyperLink Destructors

CXTHyperLink Class, Legend, Public Methods
CXTHyperLink Destructors
Class

CXTHyperLink Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTHyperLink | Destroys a CXTHyperLink object, handles cleanup and deallocation.


CXTHyperLink::~CXTHyperLink Destructor

CXTHyperLink Destructors, CXTHyperLink Class
CXTHyperLink::~CXTHyperLink Destructor

Destroys a CXTHyperLink object, handles cleanup and deallocation.

virtual ~CXTHyperLink();
Group

CXTHyperLink Destructors


CXTIconHandle Class

XTUtil.h, Classes, Legend, Members, Topics, CXTIconHandle Data Members, CXTIconHandle Methods, CXTIconHandle Constructors, CXTIconHandle Destructors, CXTIconHandle Operators, CXTIconHandle Constructors, CXTIconHandle Data Members, CXTIconHandle Destructors, CXTIconHandle Methods, CXTIconHandle Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTIconHandle Class

CXTIconHandle is a stand alone helper class. It is used to automatically destroy dynamically created hIcon handles.

Class Hierarchy

class CXTIconHandle;
File

XTUtil.h

Group

Classes

Legend
Data Member
protected
Method
virtual
Operator
CXTIconHandle Constructors
CXTIconHandle Constructors | Description
CXTIconHandle |
CXTIconHandle Data Members
CXTIconHandle Data Members | Description
m_hIcon | Handle to a dynamically created icon.
CXTIconHandle Destructors
CXTIconHandle Destructors | Description
~CXTIconHandle | Destroys a CXTIconHandle object, handles cleanup and de- allocation.
CXTIconHandle Methods
CXTIconHandle Methods | Description
GetExtent |
ScaleToFit |
CXTIconHandle Operators
CXTIconHandle Operators | Description
= | This operator is used to initialize the icon associated with the CXTIconHandle object.
HICON | This operator is used to retrieve a handle to the icon associated with the CXTIconHandle object.


CXTIconHandle Data Members

CXTIconHandle Class, Legend, Protected Data Members
CXTIconHandle Data Members
Class

CXTIconHandle Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hIcon | Handle to a dynamically created icon.


CXTIconHandle::m_hIcon Data Member

CXTIconHandle Data Members, CXTIconHandle Class
CXTIconHandle::m_hIcon Data Member

Handle to a dynamically created icon.

HICON m_hIcon;
Group

CXTIconHandle Data Members


CXTIconHandle Methods

CXTIconHandle Class, Legend, Public Methods
CXTIconHandle Methods
Class

CXTIconHandle Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetExtent |
ScaleToFit |


GetExtent Method

CXTIconHandle Methods
GetExtent Method
Overload List
Methods
Method | Description
CXTIconHandle::GetExtent () | This member function gets the extent of an icon.
CXTIconHandle::GetExtent (HICON) | This member function gets the extent of an icon.
Group

CXTIconHandle Methods


CXTIconHandle::GetExtent Method ()

GetExtent Method, CXTIconHandle Class
CXTIconHandle::GetExtent Method ()

This member function gets the extent of an icon.

CSize GetExtent() const;
static CSize GetExtent(
    HICON hIcon
);
Parameters

hIcon
Icon handle whose dimensions are to be retrieved.

Returns

A CSize object.

Group

GetExtent Method


ScaleToFit Method

CXTIconHandle Methods
ScaleToFit Method
Overload List
Methods
Method | Description
CXTIconHandle::ScaleToFit (CSize) | This member function scales an icon to fit into a rectangle. The width and height ration is retained as much as possible. The caller assumes ownership of the returned icon handle.
CXTIconHandle::ScaleToFit (HICON, CSize) | This member function scales an icon to fit into a rectangle. The width and height ration is retained as much as possible. The caller assumes ownership of the returned icon handle.
Group

CXTIconHandle Methods


CXTIconHandle::ScaleToFit Method (CSize)

ScaleToFit Method, CXTIconHandle Class
CXTIconHandle::ScaleToFit Method (CSize)

This member function scales an icon to fit into a rectangle. The width and height ration is retained as much as possible. The caller assumes ownership of the returned icon handle.

HICON ScaleToFit(
    CSize desiredExtent
) const;
static HICON ScaleToFit(
    HICON hIcon,
    CSize desiredExtent
);
Parameters

desiredExtent
Desired icon extent.
hIcon
Icon to be fitted.

Returns

An icon handle.

Group

ScaleToFit Method


CXTIconHandle Constructors

CXTIconHandle Class, Legend, Public Methods
CXTIconHandle Constructors
Class

CXTIconHandle Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTIconHandle |


CXTIconHandle Constructor

CXTIconHandle Constructors
CXTIconHandle Constructor
Overload List
Constructors
Constructor | Description
CXTIconHandle::CXTIconHandle () | Constructs a CXTIconHandle object.
CXTIconHandle::CXTIconHandle (HICON) | Constructs a CXTIconHandle object.
Group

CXTIconHandle Constructors


CXTIconHandle::CXTIconHandle Constructor ()

CXTIconHandle Constructor, CXTIconHandle Class
CXTIconHandle::CXTIconHandle Constructor ()

Constructs a CXTIconHandle object.

CXTIconHandle();
CXTIconHandle(
    HICON hIcon
);
Parameters

hIcon
Handle to a dynamically created icon.

Group

CXTIconHandle Constructor


CXTIconHandle Destructors

CXTIconHandle Class, Legend, Public Methods
CXTIconHandle Destructors
Class

CXTIconHandle Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTIconHandle | Destroys a CXTIconHandle object, handles cleanup and de- allocation.


CXTIconHandle::~CXTIconHandle Destructor

CXTIconHandle Destructors, CXTIconHandle Class
CXTIconHandle::~CXTIconHandle Destructor

Destroys a CXTIconHandle object, handles cleanup and de- allocation.

virtual ~CXTIconHandle();
Group

CXTIconHandle Destructors


CXTIconHandle Operators

CXTIconHandle Class, Legend, Public Operators
CXTIconHandle Operators
Class

CXTIconHandle Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This operator is used to initialize the icon associated with the CXTIconHandle object.
HICON | This operator is used to retrieve a handle to the icon associated with the CXTIconHandle object.


CXTIconHandle::= Operator

CXTIconHandle Operators, CXTIconHandle Class
CXTIconHandle::= Operator

This operator is used to initialize the icon associated with the CXTIconHandle object.

CXTIconHandle& operator =(
    HICON hIcon
);
Parameters

hIcon
Handle to a dynamically created icon.

Returns

A reference to a CXTIconHandle object.

Group

CXTIconHandle Operators


CXTIconHandle::HICON Operator

CXTIconHandle Operators, CXTIconHandle Class, Body Source
CXTIconHandle::HICON Operator

This operator is used to retrieve a handle to the icon associated with the CXTIconHandle object.

operator HICON() const;
Returns

An HICON handle to the icon.

Body Source
CXTIconHandle::operator HICON() const {
    return m_hIcon;
}
Group

CXTIconHandle Operators


CXTItemEdit Class

XTBrowseEdit.h, Classes, Legend, Members, Topics, CXTItemEdit Data Members, CXTItemEdit Methods, CXTItemEdit Constructors, CXTItemEdit Destructors, CXTItemEdit Constructors, CXTItemEdit Data Members, CXTItemEdit Destructors, CXTItemEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTItemEdit Class

CXTItemEdit is a CXTBrowseEdit derived class. It is used to create a CXTItemEdit window that can be used as an "in-place" edit field that can be dynamically created for controls such as a list box.

Class Hierarchy

class CXTItemEdit : public CXTBrowseEdit;
File

XTBrowseEdit.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTItemEdit Constructors
CXTItemEdit Constructors | Description
CXTItemEdit | Constructs a CXTItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box
CXTItemEdit Data Members
CXTItemEdit Data Members | Description
m_bAutoDelete | true if self deleting.
m_bClosePosted | Used internally to determine if a WM_CLOSE message has been sent.
m_bEscapeKey | true if the edit window was closed with the escape key.
m_bModified | true if the item was modified.
m_strWindowText | The edit controls text.
CXTItemEdit Destructors
CXTItemEdit Destructors | Description
~CXTItemEdit | Destroys a CXTItemEdit object, handles cleanup and deallocation
CXTItemEdit Methods
CXTItemEdit Methods | Description
Create | Constructs a CXTItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box
EndLabelEdit | This member function is called whenever the control loses focus. This will destroy the window, and notify the parent via WM_COMMAND that the editing has been completed. The two possible commands are: ON_BEN_XT_LABELEDITEND and ON_BEN_XT_LABELEDITCANCEL


CXTItemEdit Data Members

CXTItemEdit Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTItemEdit Data Members
Class

CXTItemEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bClosePosted | Used internally to determine if a WM_CLOSE message has been sent.
Public Data Members
Public Data Member | Description
m_bAutoDelete | true if self deleting.
m_bEscapeKey | true if the edit window was closed with the escape key.
m_bModified | true if the item was modified.
m_strWindowText | The edit controls text.


CXTItemEdit::m_bAutoDelete Data Member

CXTItemEdit Data Members, CXTItemEdit Class
CXTItemEdit::m_bAutoDelete Data Member

true if self deleting.

bool m_bAutoDelete;
Group

CXTItemEdit Data Members


CXTItemEdit::m_bClosePosted Data Member

CXTItemEdit Data Members, CXTItemEdit Class
CXTItemEdit::m_bClosePosted Data Member

Used internally to determine if a WM_CLOSE message has been sent.

bool m_bClosePosted;
Group

CXTItemEdit Data Members


CXTItemEdit::m_bEscapeKey Data Member

CXTItemEdit Data Members, CXTItemEdit Class
CXTItemEdit::m_bEscapeKey Data Member

true if the edit window was closed with the escape key.

bool m_bEscapeKey;
Group

CXTItemEdit Data Members


CXTItemEdit::m_bModified Data Member

CXTItemEdit Data Members, CXTItemEdit Class
CXTItemEdit::m_bModified Data Member

true if the item was modified.

bool m_bModified;
Group

CXTItemEdit Data Members


CXTItemEdit::m_strWindowText Data Member

CXTItemEdit Data Members, CXTItemEdit Class
CXTItemEdit::m_strWindowText Data Member

The edit controls text.

CString m_strWindowText;
Group

CXTItemEdit Data Members


CXTItemEdit Methods

CXTItemEdit Class, Legend, Public Methods
CXTItemEdit Methods
Class

CXTItemEdit Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Create | Constructs a CXTItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box
EndLabelEdit | This member function is called whenever the control loses focus. This will destroy the window, and notify the parent via WM_COMMAND that the editing has been completed. The two possible commands are: ON_BEN_XT_LABELEDITEND and ON_BEN_XT_LABELEDITCANCEL


CXTItemEdit::Create Method

CXTItemEdit Methods, CXTItemEdit Class
CXTItemEdit::Create Method

Constructs a CXTItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box

BOOL Create(
    CWnd* pParent,
    const CRect& rect,
    CString& strWindowText,
    DWORD dwBStyle = BES_XT_CHOOSEDIR,
    bool bAutoDelete = true
);
Parameters

pParent
Points to the parent window.
rect
Size of the edit item.
strWindowText
Text to be initially displayed in the edit field.
dwBStyle
Specifies the browse edit style for the in-place edit field. See CXTBrowseEdit::SetBrowseStyle for available styles.
bAutoDelete
Set to true if the object is to be self deleting.

Group

CXTItemEdit Methods


CXTItemEdit::EndLabelEdit Method

CXTItemEdit Methods, CXTItemEdit Class
CXTItemEdit::EndLabelEdit Method

This member function is called whenever the control loses focus. This will destroy the window, and notify the parent via WM_COMMAND that the editing has been completed. The two possible commands are: ON_BEN_XT_LABELEDITEND and ON_BEN_XT_LABELEDITCANCEL

virtual void EndLabelEdit();
Group

CXTItemEdit Methods


CXTItemEdit Constructors

CXTItemEdit Class, Legend, Public Methods
CXTItemEdit Constructors
Class

CXTItemEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTItemEdit | Constructs a CXTItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box


CXTItemEdit::CXTItemEdit Constructor

CXTItemEdit Constructors, CXTItemEdit Class
CXTItemEdit::CXTItemEdit Constructor

Constructs a CXTItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box

CXTItemEdit();
Group

CXTItemEdit Constructors


CXTItemEdit Destructors

CXTItemEdit Class, Legend, Public Methods
CXTItemEdit Destructors
Class

CXTItemEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTItemEdit | Destroys a CXTItemEdit object, handles cleanup and deallocation


CXTItemEdit::~CXTItemEdit Destructor

CXTItemEdit Destructors, CXTItemEdit Class
CXTItemEdit::~CXTItemEdit Destructor

Destroys a CXTItemEdit object, handles cleanup and deallocation

virtual ~CXTItemEdit();
Group

CXTItemEdit Destructors


CXTListBase Class

XTListBase.h, Classes, Legend, Members, Topics, CXTListBase Structures, CXTListBase Data Members, CXTListBase Methods, CXTListBase Constructors, CXTListBase Destructors, CXTListBase Nested Types, CXTListBase Constructors, CXTListBase Data Members, CXTListBase Destructors, CXTListBase Methods, CXTListBase Nested Types, CXTListBase Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTListBase Class

CXTListBase is a non-inherited class. It implements the extended list control services provided by the Xtreme Toolkit list control classes.

Class Hierarchy

class CXTListBase;
File

XTListBase.h

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTListBase Constructors
CXTListBase Constructors | Description
CXTListBase | Constructs a CXTListBase object
CXTListBase Data Members
CXTListBase Data Members | Description
m_arRowColor | List of user defined text and background row colors.
m_bAscending | Flag to determine the sorting order.
m_bAutoFont | If true, the font will automatically be set for the control
m_bAutoSave | true if saving the column widths.
m_bListColor | true if user defined colors are used for background and text.
m_bNoColSizing | If true, column sizing is disabled.
m_bRowColor | true if rows are drawn with user defined colors.
m_bSortColor | true if the sorted column is drawn in color.
m_crListBack | RGB value representing the row text background color.
m_crListText | RGB value representing the row text color.
m_crSortBack | RGB value for sort column background color.
m_crSortText | RGB value for sort column text color.
m_flatHeader | Subclassed flat header control.
m_nMaxColWidth | Maximum width for columns.
m_nMinColWidth | Minimum width for columns.
m_nSortedCol | Index of the currently selected column.
m_pListCtrl | List control instance.
m_strDefault | Registry default value.
m_strEntry | Registry entry name.
m_strSection | Registry section name.
CXTListBase Destructors
CXTListBase Destructors | Description
~CXTListBase | Destroys a CXTListBase object, handles cleanup and deallocation
CXTListBase Methods
CXTListBase Methods | Description
_xtGetHeaderCtrl | This member function is a utility function to retrieve the associated header control.
AddColumn | Call this member function to add a column after the right most column.
AutoSaveColumns | Initializes the auto save feature.
AutoSizeColumn | Automatically sizes a specified column.
BuildColumns |
CopyRow | This member function copies a row to a new location.
DisableColumnSizing | Call this member function to enable or disable column sizing.
EnableUserListColor | Call this member function to enable or disable user defined colors.
EnableUserRowColor | Call this member function to enable or disable user defined row colors.
EnableUserSortColor | Call this member function to enable or disable sorted column colors.
GetColumnCount | This member function gets the number of columns in the list.
GetExtendedStyle | This member function is called to return the list control extended style.
GetFlatHeaderCtrl | Call this member function to get a pointer to the flat header control.
GetListBackColor | Call this member function to return the RGB color value used for the column background color.
GetListTextColor | Call this member function to return the RGB color value used for the column text color.
GetMaximumColSize | Call this member function to get the maximum column size for the list control.
GetMinimumColSize | Call this member function to get the minimum column size for the list control.
GetSortBackColor | Call this member function to return the RGB color value used for the sorted column background color.
GetSortTextColor | Call this member function to return the RGB color value used for the sorted column text color.
GetStoredWidth | This member function will return the column width stored in the registry.
HitTestEx | Call this member function to determine the row index and column index for a 'point'.
ImplAttach | Sets the list control pointer.
Init | This member function is called by the CXTListBase class to perform initialization when the window is created or sub-classed.
IsUserListColor | Call this member function to determine if user defined colors are enabled.
IsUserRowColor | Call this member function to determine if user defined row colors are enabled.
IsUserSortColor | Call this member function to determine if sorted column color is enabled.
LoadColumnWidths | This member function loads the column widths from the registry.
Lookup | Call this member function to determine if the specified row contains user defined color attributes.
ModifyExtendedStyle | Call this member function to modify the extended style for the list control.
MoveRow | This member function moves a row to a new location.
OnNotify | Called from the derived class OnNotify method.
RefreshMetrics | Updates colors and size values.
RemoveRowColors | Call this member function to remove all user defined row colors from the list control.
SaveColumnWidths | This member function saves the column widths to the registry.
SetAutoFont | Call this member function to automatically set the font for the list control when the control is initialized to use the toolkit default font. This will also reset the font for the header control as well.
SetExtendedStyle | This member function is called to set extended styles for the list control, ie: LVS_EX_FULLROWSELECT, LVS_EX_GRIDLINES, etc. See MSDN documentation for a complete list of available styles.
SetListBackColor | Call this member function to set the RGB color value used for the list background color.
SetListTextColor | Call this member function to set the RGB color value used for the list text color.
SetMinimumColSize | Call this member function to set a minimum column size.
SetRowColor |
SetRowColors | This member function sets the row, text, and background colors for the list control.
SetSortBackColor | Call this member function to set the RGB color value used for the sorted column background color.
SetSortImage | This member function will set the sort image for the specified column.
SetSortTextColor | Call this member function to set the RGB color value used for the sorted column text color.
SetStoredWidth | This member function will set the column width from the registry settings.
SortList | Override this member function in your derived class to perform custom sort routines.
SubclassHeader | Call this member function to subclass the flat header control.
CXTListBase Nested Types
CXTListBase Nested Types | Description
CRowColorList | List for maintaining ROWCOLOR structures.
CXTListBase Structures
CXTListBase Structures | Description
ROWCOLOR | ROWCOLOR structure is used by the CXTListBase class to store user defined background and text color settings for a particular row in a list control.


CXTListBase Structures

CXTListBase Class, Legend, Structures
CXTListBase Structures
Class

CXTListBase Class

Legend
Structure
Structures
Structure | Description
ROWCOLOR | ROWCOLOR structure is used by the CXTListBase class to store user defined background and text color settings for a particular row in a list control.


CXTListBase::ROWCOLOR Structure

XTListBase.h, CXTListBase Structures, See Also
CXTListBase::ROWCOLOR Structure

ROWCOLOR structure is used by the CXTListBase class to store user defined background and text color settings for a particular row in a list control.

struct ROWCOLOR {
  int iRow;
  COLORREF crBack;
  COLORREF crText;
};
File

XTListBase.h

Members

iRow
List control row index.
crBack
RGB value for text background color.
crText
RGB value for text foreground color.

See Also

CRowColorList, SetRowColor, RemoveRowColors, Lookup

Group

CXTListBase Structures


CXTListBase Data Members

CXTListBase Class, Legend, Protected Data Members
CXTListBase Data Members
Class

CXTListBase Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arRowColor | List of user defined text and background row colors.
m_bAscending | Flag to determine the sorting order.
m_bAutoFont | If true, the font will automatically be set for the control
m_bAutoSave | true if saving the column widths.
m_bListColor | true if user defined colors are used for background and text.
m_bNoColSizing | If true, column sizing is disabled.
m_bRowColor | true if rows are drawn with user defined colors.
m_bSortColor | true if the sorted column is drawn in color.
m_crListBack | RGB value representing the row text background color.
m_crListText | RGB value representing the row text color.
m_crSortBack | RGB value for sort column background color.
m_crSortText | RGB value for sort column text color.
m_flatHeader | Subclassed flat header control.
m_nMaxColWidth | Maximum width for columns.
m_nMinColWidth | Minimum width for columns.
m_nSortedCol | Index of the currently selected column.
m_pListCtrl | List control instance.
m_strDefault | Registry default value.
m_strEntry | Registry entry name.
m_strSection | Registry section name.


CXTListBase::m_arRowColor Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_arRowColor Data Member

List of user defined text and background row colors.

CRowColorList m_arRowColor;
Group

CXTListBase Data Members


CXTListBase::m_bAscending Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_bAscending Data Member

Flag to determine the sorting order.

bool m_bAscending;
Group

CXTListBase Data Members


CXTListBase::m_bAutoFont Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_bAutoFont Data Member

If true, the font will automatically be set for the control

bool m_bAutoFont;
Group

CXTListBase Data Members


CXTListBase::m_bAutoSave Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_bAutoSave Data Member

true if saving the column widths.

bool m_bAutoSave;
Group

CXTListBase Data Members


CXTListBase::m_bListColor Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_bListColor Data Member

true if user defined colors are used for background and text.

bool m_bListColor;
Group

CXTListBase Data Members


CXTListBase::m_bNoColSizing Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_bNoColSizing Data Member

If true, column sizing is disabled.

bool m_bNoColSizing;
Group

CXTListBase Data Members


CXTListBase::m_bRowColor Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_bRowColor Data Member

true if rows are drawn with user defined colors.

bool m_bRowColor;
Group

CXTListBase Data Members


CXTListBase::m_bSortColor Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_bSortColor Data Member

true if the sorted column is drawn in color.

bool m_bSortColor;
Group

CXTListBase Data Members


CXTListBase::m_crListBack Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_crListBack Data Member

RGB value representing the row text background color.

COLORREF m_crListBack;
Group

CXTListBase Data Members


CXTListBase::m_crListText Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_crListText Data Member

RGB value representing the row text color.

COLORREF m_crListText;
Group

CXTListBase Data Members


CXTListBase::m_crSortBack Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_crSortBack Data Member

RGB value for sort column background color.

COLORREF m_crSortBack;
Group

CXTListBase Data Members


CXTListBase::m_crSortText Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_crSortText Data Member

RGB value for sort column text color.

COLORREF m_crSortText;
Group

CXTListBase Data Members


CXTListBase::m_flatHeader Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_flatHeader Data Member

Subclassed flat header control.

CXTFlatHeaderCtrl m_flatHeader;
Group

CXTListBase Data Members


CXTListBase::m_nMaxColWidth Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_nMaxColWidth Data Member

Maximum width for columns.

int m_nMaxColWidth;
Group

CXTListBase Data Members


CXTListBase::m_nMinColWidth Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_nMinColWidth Data Member

Minimum width for columns.

int m_nMinColWidth;
Group

CXTListBase Data Members


CXTListBase::m_nSortedCol Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_nSortedCol Data Member

Index of the currently selected column.

int m_nSortedCol;
Group

CXTListBase Data Members


CXTListBase::m_pListCtrl Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_pListCtrl Data Member

List control instance.

CListCtrl_Friendly* m_pListCtrl;
Group

CXTListBase Data Members


CXTListBase::m_strDefault Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_strDefault Data Member

Registry default value.

CString m_strDefault;
Group

CXTListBase Data Members


CXTListBase::m_strEntry Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_strEntry Data Member

Registry entry name.

CString m_strEntry;
Group

CXTListBase Data Members


CXTListBase::m_strSection Data Member

CXTListBase Data Members, CXTListBase Class
CXTListBase::m_strSection Data Member

Registry section name.

CString m_strSection;
Group

CXTListBase Data Members


CXTListBase Methods

CXTListBase Class, Legend, Protected Methods, Public Methods
CXTListBase Methods
Class

CXTListBase Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
ImplAttach | Sets the list control pointer.
Init | This member function is called by the CXTListBase class to perform initialization when the window is created or sub-classed.
OnNotify | Called from the derived class OnNotify method.
RefreshMetrics | Updates colors and size values.
Public Methods
Public Methods
Public Method | Description
_xtGetHeaderCtrl | This member function is a utility function to retrieve the associated header control.
AddColumn | Call this member function to add a column after the right most column.
AutoSaveColumns | Initializes the auto save feature.
AutoSizeColumn | Automatically sizes a specified column.
BuildColumns |
CopyRow | This member function copies a row to a new location.
DisableColumnSizing | Call this member function to enable or disable column sizing.
EnableUserListColor | Call this member function to enable or disable user defined colors.
EnableUserRowColor | Call this member function to enable or disable user defined row colors.
EnableUserSortColor | Call this member function to enable or disable sorted column colors.
GetColumnCount | This member function gets the number of columns in the list.
GetExtendedStyle | This member function is called to return the list control extended style.
GetFlatHeaderCtrl | Call this member function to get a pointer to the flat header control.
GetListBackColor | Call this member function to return the RGB color value used for the column background color.
GetListTextColor | Call this member function to return the RGB color value used for the column text color.
GetMaximumColSize | Call this member function to get the maximum column size for the list control.
GetMinimumColSize | Call this member function to get the minimum column size for the list control.
GetSortBackColor | Call this member function to return the RGB color value used for the sorted column background color.
GetSortTextColor | Call this member function to return the RGB color value used for the sorted column text color.
GetStoredWidth | This member function will return the column width stored in the registry.
HitTestEx | Call this member function to determine the row index and column index for a 'point'.
IsUserListColor | Call this member function to determine if user defined colors are enabled.
IsUserRowColor | Call this member function to determine if user defined row colors are enabled.
IsUserSortColor | Call this member function to determine if sorted column color is enabled.
LoadColumnWidths | This member function loads the column widths from the registry.
Lookup | Call this member function to determine if the specified row contains user defined color attributes.
ModifyExtendedStyle | Call this member function to modify the extended style for the list control.
MoveRow | This member function moves a row to a new location.
RemoveRowColors | Call this member function to remove all user defined row colors from the list control.
SaveColumnWidths | This member function saves the column widths to the registry.
SetAutoFont | Call this member function to automatically set the font for the list control when the control is initialized to use the toolkit default font. This will also reset the font for the header control as well.
SetExtendedStyle | This member function is called to set extended styles for the list control, ie: LVS_EX_FULLROWSELECT, LVS_EX_GRIDLINES, etc. See MSDN documentation for a complete list of available styles.
SetListBackColor | Call this member function to set the RGB color value used for the list background color.
SetListTextColor | Call this member function to set the RGB color value used for the list text color.
SetMinimumColSize | Call this member function to set a minimum column size.
SetRowColor |
SetRowColors | This member function sets the row, text, and background colors for the list control.
SetSortBackColor | Call this member function to set the RGB color value used for the sorted column background color.
SetSortImage | This member function will set the sort image for the specified column.
SetSortTextColor | Call this member function to set the RGB color value used for the sorted column text color.
SetStoredWidth | This member function will set the column width from the registry settings.
SortList | Override this member function in your derived class to perform custom sort routines.
SubclassHeader | Call this member function to subclass the flat header control.


CXTListBase::_xtGetHeaderCtrl Method

CXTListBase Methods, CXTListBase Class
CXTListBase::_xtGetHeaderCtrl Method

This member function is a utility function to retrieve the associated header control.

CHeaderCtrl * _xtGetHeaderCtrl() const;
Returns

A CHeaderCtrl pointer to the associated header control.

Group

CXTListBase Methods


CXTListBase::AddColumn Method

CXTListBase Methods, CXTListBase Class
CXTListBase::AddColumn Method

Call this member function to add a column after the right most column.

virtual int AddColumn(
    LPCTSTR lpszColHeading,
    int nWidth = -1,
    int nFormat = LVCFMT_LEFT
);
Parameters

lpszColHeading
The column's heading.
nWidth
Width of the column in pixels. If this parameter is -1, the column width is the same as the previous column.
nFormat
The alignment of the column. It can be LVCFMT_LEFT, LVCFMT_RIGHT, or LVCFMT_CENTER.

Returns

The index of the new column if successful, or -1 if unsuccessful.

Group

CXTListBase Methods


CXTListBase::AutoSaveColumns Method

CXTListBase Methods, CXTListBase Class
CXTListBase::AutoSaveColumns Method

Initializes the auto save feature.

virtual void AutoSaveColumns(
    LPCTSTR lpszSection = NULL,
    LPCTSTR lpszEntry = NULL,
    LPCTSTR lpszDefault = NULL
);
Parameters

lpszSection
Registry section name. If NULL, the default is "Settings".
lpszEntry
Registry entry name. If NULL, the default is "Column Info".
lpszDefault
Registry default value. If NULL, the default ID.

Remarks

This member function will initialize the auto save feature. If called, column widths will be saved to the system registry when the list control window is destroyed.

Group

CXTListBase Methods


CXTListBase::AutoSizeColumn Method

CXTListBase Methods, CXTListBase Class
CXTListBase::AutoSizeColumn Method

Automatically sizes a specified column.

virtual void AutoSizeColumn(
    int nCol = -1
);
Parameters

nCol
Zero-based index of the column.

Remarks

This member function will automatically size a given column. Pass in a -1 to auto-fit all columns.

Group

CXTListBase Methods


BuildColumns Method

CXTListBase Methods
BuildColumns Method
Overload List
Methods
Method | Description
CXTListBase::BuildColumns (int, int*, CString*) | This member function will build the columns for the list control.
CXTListBase::BuildColumns (int, int*, int*) | This member function will build the columns for the list control.
Group

CXTListBase Methods


CXTListBase::BuildColumns Method (int, int*, int*)

BuildColumns Method, CXTListBase Class, Example
CXTListBase::BuildColumns Method (int, int*, int*)

This member function will build the columns for the list control.

virtual bool BuildColumns(
    int nCols,
    int* nWidth,
    int* nColString
);
virtual bool BuildColumns(
    int nCols,
    int* nWidth,
    CString* strColString
);
Parameters

nCols
[in] Number of columns contained in the list control.
nWidth
[in] 'int' array containing the column widths.
nColString
[in] 'int' array containing the string resource ID for each column.
strColString
[in] CString array containing the string for each column.

Returns

true if successful, or false if an error occurred.

Remarks

Call this member function to automatically generate the columns for the list control. This is done by passing in an array of column indexes specified by nCols, an array of column widths specified by nWidth and and array of column labels specified by nColString or strColString.

Example

The following example demonstrates the use of BuildColumns.

static int arColWidths[] = {
    24,
    21,
    100,
    180,
    120
};

static CString arColLabels[] = {
    _T(" "),
    _T(" "),
    _T("From"),
    _T("Subject"),
    _T("Received")
};

// Insert the columns.
BuildColumns(_countof(arColWidths), arColWidths, arColLabels);
Group

BuildColumns Method


CXTListBase::CopyRow Method

CXTListBase Methods, CXTListBase Class
CXTListBase::CopyRow Method

This member function copies a row to a new location.

virtual int CopyRow(
    int nFrom,
    int nTo
);
Parameters

nFrom
Index of the source row.
nTo
Index of the destination row.

Returns

The index of the source row specified by 'nFrom'.

Group

CXTListBase Methods


CXTListBase::DisableColumnSizing Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::DisableColumnSizing Method

Call this member function to enable or disable column sizing.

virtual void DisableColumnSizing(
    bool bDisable
);
Parameters

bDisable
true to disable column sizing. false to enable.

Body Source
void CXTListBase::DisableColumnSizing(bool bDisable) {
    m_bNoColSizing = bDisable;
}
Group

CXTListBase Methods


CXTListBase::EnableUserListColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::EnableUserListColor Method

Call this member function to enable or disable user defined colors.

void EnableUserListColor(
    bool bEnable
);
Parameters

bEnable
true to enable user defined colors, false to disable.

Body Source
void CXTListBase::EnableUserListColor(bool bEnable) {
    m_bListColor = bEnable;
}
Group

CXTListBase Methods


CXTListBase::EnableUserRowColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::EnableUserRowColor Method

Call this member function to enable or disable user defined row colors.

void EnableUserRowColor(
    bool bEnable
);
Parameters

bEnable
true to enable user defined row colors, false to disable.

Body Source
void CXTListBase::EnableUserRowColor(bool bEnable) {
    m_bRowColor = bEnable;
}
Group

CXTListBase Methods


CXTListBase::EnableUserSortColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::EnableUserSortColor Method

Call this member function to enable or disable sorted column colors.

void EnableUserSortColor(
    bool bEnable
);
Parameters

bEnable
true to enable sorted column colors, false to disable.

Body Source
void CXTListBase::EnableUserSortColor(bool bEnable) {
    m_bSortColor = bEnable;
}
Group

CXTListBase Methods


CXTListBase::GetColumnCount Method

CXTListBase Methods, CXTListBase Class
CXTListBase::GetColumnCount Method

This member function gets the number of columns in the list.

virtual int GetColumnCount();
Returns

An integer value that represents the number of columns in the list.

Group

CXTListBase Methods


CXTListBase::GetExtendedStyle Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::GetExtendedStyle Method

This member function is called to return the list control extended style.

virtual DWORD GetExtendedStyle();
Returns

A DWORD value that represents the extended style of the list control.

Body Source
DWORD CXTListBase::GetExtendedStyle() {
    ASSERT(::IsWindow(m_pListCtrl->GetSafeHwnd())); return (DWORD)m_pListCtrl->SendMessage(LVM_GETEXTENDEDLISTVIEWSTYLE, 0, 0);
}
Group

CXTListBase Methods


CXTListBase::GetFlatHeaderCtrl Method

CXTListBase Methods, CXTListBase Class
CXTListBase::GetFlatHeaderCtrl Method

Call this member function to get a pointer to the flat header control.

CXTFlatHeaderCtrl* GetFlatHeaderCtrl() const;
Returns

A pointer to a CXTFlatHeaderCtrl if subclassed, otherwise returns NULL.

Group

CXTListBase Methods


CXTListBase::GetListBackColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::GetListBackColor Method

Call this member function to return the RGB color value used for the column background color.

COLORREF GetListBackColor() const;
Returns

Returns an RGB value representing the column background color.

Body Source
COLORREF CXTListBase::GetListBackColor() const {
    return m_bListColor ? ((m_crListBack == (COLORREF)-1) ? ::GetSysColor(COLOR_WINDOW) : m_crListBack) : ::GetSysColor(COLOR_WINDOW);
}
Group

CXTListBase Methods


CXTListBase::GetListTextColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::GetListTextColor Method

Call this member function to return the RGB color value used for the column text color.

COLORREF GetListTextColor() const;
Returns

Returns an RGB value representing the column text color.

Body Source
COLORREF CXTListBase::GetListTextColor() const {
    return m_bListColor ? ((m_crListText == (COLORREF)-1) ? ::GetSysColor(COLOR_WINDOWTEXT) : m_crListText) : ::GetSysColor(COLOR_WINDOWTEXT);
}
Group

CXTListBase Methods


CXTListBase::GetMaximumColSize Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::GetMaximumColSize Method

Call this member function to get the maximum column size for the list control.

int GetMaximumColSize();
Returns

An integer value that represents the maximum column size for the list control.

Body Source
int CXTListBase::GetMaximumColSize() {
    return m_nMaxColWidth;
}
Group

CXTListBase Methods


CXTListBase::GetMinimumColSize Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::GetMinimumColSize Method

Call this member function to get the minimum column size for the list control.

int GetMinimumColSize();
Returns

An integer value that represents the minimum column size for the list control.

Body Source
int CXTListBase::GetMinimumColSize() {
    return m_nMinColWidth;
}
Group

CXTListBase Methods


CXTListBase::GetSortBackColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::GetSortBackColor Method

Call this member function to return the RGB color value used for the sorted column background color.

COLORREF GetSortBackColor() const;
Returns

Returns an RGB value representing the sorted column background color.

Body Source
COLORREF CXTListBase::GetSortBackColor() const {
    return (m_crSortBack == (COLORREF)-1) ? GetListBackColor() : m_crSortBack;
}
Group

CXTListBase Methods


CXTListBase::GetSortTextColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::GetSortTextColor Method

Call this member function to return the RGB color value used for the sorted column text color.

COLORREF GetSortTextColor() const;
Returns

Returns an RGB value representing the sorted column text color.

Body Source
COLORREF CXTListBase::GetSortTextColor() const {
    return (m_crSortText == (COLORREF)-1) ? GetListTextColor():m_crSortText;
}
Group

CXTListBase Methods


CXTListBase::GetStoredWidth Method

CXTListBase Methods, CXTListBase Class
CXTListBase::GetStoredWidth Method

This member function will return the column width stored in the registry.

virtual int GetStoredWidth(
    int nCol
);
Parameters

nCol
Zero-based index of the column.

Returns

The column width stored in the registry.

Group

CXTListBase Methods


CXTListBase::HitTestEx Method

CXTListBase Methods, CXTListBase Class
CXTListBase::HitTestEx Method

Call this member function to determine the row index and column index for a 'point'.

virtual int HitTestEx(
    CPoint & point,
    int* col
) const;
Parameters

point
Point to be tested.
col
Address of the column index

Returns

The row index, or -1 if 'point' is not over a row.

Group

CXTListBase Methods


CXTListBase::ImplAttach Method

CXTListBase Methods, CXTListBase Class
CXTListBase::ImplAttach Method

Sets the list control pointer.

void ImplAttach(
    CListCtrl* pListCtrl
);
Parameters

pListCtrl
Points to the CListCtrl object to attach.

Remarks

This member function is called by the derived class to set the list control pointer for this implementation.

Group

CXTListBase Methods


CXTListBase::Init Method

CXTListBase Methods, CXTListBase Class
CXTListBase::Init Method

This member function is called by the CXTListBase class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTListBase Methods


CXTListBase::IsUserListColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::IsUserListColor Method

Call this member function to determine if user defined colors are enabled.

bool IsUserListColor() const;
Returns

true if user defined colors are enabled, otherwise false.

Body Source
bool CXTListBase::IsUserListColor() const {
    return m_bListColor;
}
Group

CXTListBase Methods


CXTListBase::IsUserRowColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::IsUserRowColor Method

Call this member function to determine if user defined row colors are enabled.

bool IsUserRowColor() const;
Returns

true if user defined row colors are enabled, otherwise false.

Body Source
bool CXTListBase::IsUserRowColor() const {
    return m_bRowColor;
}
Group

CXTListBase Methods


CXTListBase::IsUserSortColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::IsUserSortColor Method

Call this member function to determine if sorted column color is enabled.

bool IsUserSortColor() const;
Returns

true if sorted column colors are enabled, otherwise false.

Body Source
bool CXTListBase::IsUserSortColor() const {
    return m_bSortColor;
}
Group

CXTListBase Methods


CXTListBase::LoadColumnWidths Method

CXTListBase Methods, CXTListBase Class
CXTListBase::LoadColumnWidths Method

This member function loads the column widths from the registry.

virtual void LoadColumnWidths();
Group

CXTListBase Methods


CXTListBase::Lookup Method

CXTListBase Methods, CXTListBase Class
CXTListBase::Lookup Method

Call this member function to determine if the specified row contains user defined color attributes.

virtual ROWCOLOR* Lookup(
    int iRow
);
Parameters

iRow
Index of the row to check.

Returns

A pointer to a ROWCOLOR structure if successful, otherwise NULL.

Group

CXTListBase Methods


CXTListBase::ModifyExtendedStyle Method

CXTListBase Methods, CXTListBase Class
CXTListBase::ModifyExtendedStyle Method

Call this member function to modify the extended style for the list control.

virtual BOOL ModifyExtendedStyle(
    DWORD dwRemove,
    DWORD dwAdd
);
Parameters

dwRemove
Specifies window styles to be removed during style modification.
dwAdd
Specifies window styles to be added during style modification.

Returns

TRUE if successful, otherwise FALSE.

Group

CXTListBase Methods


CXTListBase::MoveRow Method

CXTListBase Methods, CXTListBase Class
CXTListBase::MoveRow Method

This member function moves a row to a new location.

virtual bool MoveRow(
    int nFrom,
    int nTo
);
Parameters

nFrom
Index of the source row
nTo
Index of the destination row

Returns

true if successful, or false if an error occurred.

Group

CXTListBase Methods


CXTListBase::OnNotify Method

CXTListBase Methods, CXTListBase Class
CXTListBase::OnNotify Method

Called from the derived class OnNotify method.

virtual BOOL OnNotify(
    WPARAM wParam,
    LPARAM lParam,
    LRESULT* pResult
);
Parameters

wParam
Identifies the control that sends the message if the message is from a control. Otherwise, wParam is 0.
lParam
Pointer to a notification message (NMHDR) structure that contains the notification code and additional information. For some notification messages, this parameter points to a larger structure that has the NMHDR structure as its first member.
pResult
Pointer to an LRESULT variable in which to store the result code if the message is handled.

Returns

An application returns nonzero if it processes this message; otherwise 0.

Remarks

The derived calls this member function to processes the message map for control notification, the derived class should call this member function from the CWnd::OnNotify override.

Group

CXTListBase Methods


CXTListBase::RefreshMetrics Method

CXTListBase Methods, CXTListBase Class
CXTListBase::RefreshMetrics Method

Updates colors and size values.

void RefreshMetrics();
Remarks

This member function is called whenever there is a need to refresh the colors and size values that are set using system values. Usually called when the operating system color or settings change.

Group

CXTListBase Methods


CXTListBase::RemoveRowColors Method

CXTListBase Methods, CXTListBase Class
CXTListBase::RemoveRowColors Method

Call this member function to remove all user defined row colors from the list control.

void RemoveRowColors();
Group

CXTListBase Methods


CXTListBase::SaveColumnWidths Method

CXTListBase Methods, CXTListBase Class
CXTListBase::SaveColumnWidths Method

This member function saves the column widths to the registry.

virtual void SaveColumnWidths();
Group

CXTListBase Methods


CXTListBase::SetAutoFont Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::SetAutoFont Method

Call this member function to automatically set the font for the list control when the control is initialized to use the toolkit default font. This will also reset the font for the header control as well.

void SetAutoFont(
    bool bAutoFont
);
Parameters

bAutoFont
true to enable auto font, otherwise false.

Body Source
void CXTListBase::SetAutoFont(bool bAutoFont) {
    m_bAutoFont = bAutoFont;
}
Group

CXTListBase Methods


CXTListBase::SetExtendedStyle Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::SetExtendedStyle Method

This member function is called to set extended styles for the list control, ie: LVS_EX_FULLROWSELECT, LVS_EX_GRIDLINES, etc. See MSDN documentation for a complete list of available styles.

virtual void SetExtendedStyle(
    DWORD dwExStyle
);
Parameters

dwExStyle
DWORD value that specifies the extended list-view control style. This parameter can be a combination of Extended List-View Styles.

Body Source
void CXTListBase::SetExtendedStyle(DWORD dwExStyle) {
    ASSERT(::IsWindow(m_pListCtrl->GetSafeHwnd())); m_pListCtrl->SendMessage(LVM_SETEXTENDEDLISTVIEWSTYLE, 0, GetExtendedStyle() | dwExStyle);
}
Group

CXTListBase Methods


CXTListBase::SetListBackColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::SetListBackColor Method

Call this member function to set the RGB color value used for the list background color.

void SetListBackColor(
    COLORREF crListBack
);
Parameters

crListBack
An RGB value representing the list background color.

Body Source
void CXTListBase::SetListBackColor(COLORREF crListBack) {
    m_crListBack = crListBack;
}
Group

CXTListBase Methods


CXTListBase::SetListTextColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::SetListTextColor Method

Call this member function to set the RGB color value used for the list text color.

void SetListTextColor(
    COLORREF crListText
);
Parameters

crListText
An RGB value representing the list text color.

Body Source
void CXTListBase::SetListTextColor(COLORREF crListText) {
    m_crListText = crListText;
}
Group

CXTListBase Methods


CXTListBase::SetMinimumColSize Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::SetMinimumColSize Method

Call this member function to set a minimum column size.

void SetMinimumColSize(
    int nSize
);
Parameters

nSize
Size in pixels of the column's minimum size.

Body Source
void CXTListBase::SetMinimumColSize(int nSize) {
    m_nMinColWidth = nSize; GetFlatHeaderCtrl()->SetMinSize(nSize);
}
Group

CXTListBase Methods


SetRowColor Method

CXTListBase Methods
SetRowColor Method
Overload List
Methods
Method | Description
CXTListBase::SetRowColor (ROWCOLOR*, BOOL) | This member function sets the text, and background colors for the specified row in the list control.
CXTListBase::SetRowColor (int, COLORREF, COLORREF, BOOL) | This member function sets the row, text, and background colors for the list control.
Group

CXTListBase Methods


CXTListBase::SetRowColor Method (ROWCOLOR*, BOOL)

SetRowColor Method, CXTListBase Class
CXTListBase::SetRowColor Method (ROWCOLOR*, BOOL)

This member function sets the text, and background colors for the specified row in the list control.

void SetRowColor(
    ROWCOLOR* lpRowColor,
    BOOL bRedraw = TRUE
);
Parameters

lpRowColor
Points to a ROWCOLOR that contains the RGB row color information.
bRedraw
TRUE to invalidate control.

Group

SetRowColor Method


CXTListBase::SetRowColors Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::SetRowColors Method

This member function sets the row, text, and background colors for the list control.

void SetRowColors(
    COLORREF clrText,
    COLORREF clrTextBk
);
void SetRowColor(
    int iRow,
    COLORREF crText,
    COLORREF crBack,
    BOOL bRedraw = TRUE
);
Parameters

clrText
RGB value representing the row text color.
clrTextBk
RGB value representing the row background color.
iRow
Index of the row to set color for.
bRedraw
TRUE to invalidate control.

Remarks

The iIndex version sets the text, and background colors for the specified row in the list control.

Body Source
void CXTListBase::SetRowColors(COLORREF clrText, COLORREF clrTextBk) {
    SetListTextColor(clrText); SetListBackColor(clrTextBk); EnableUserListColor(true); m_pListCtrl->RedrawWindow();
}
Group

CXTListBase Methods


CXTListBase::SetSortBackColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::SetSortBackColor Method

Call this member function to set the RGB color value used for the sorted column background color.

void SetSortBackColor(
    COLORREF crSortBack
);
Parameters

crSortBack
An RGB value representing the sorted column background color.

Body Source
void CXTListBase::SetSortBackColor(COLORREF crSortBack) {
    m_crSortBack = crSortBack;
}
Group

CXTListBase Methods


CXTListBase::SetSortImage Method

CXTListBase Methods, CXTListBase Class
CXTListBase::SetSortImage Method

This member function will set the sort image for the specified column.

virtual int SetSortImage(
    int nCol,
    BOOL bAsc
);
Parameters

nCol
Zero-based index of the column to set the sort image for.
bAsc
TRUE if ascending, otherwise FALSE.

Returns

The zero-based index of the previously sorted column.

Group

CXTListBase Methods


CXTListBase::SetSortTextColor Method

CXTListBase Methods, CXTListBase Class, Body Source
CXTListBase::SetSortTextColor Method

Call this member function to set the RGB color value used for the sorted column text color.

void SetSortTextColor(
    COLORREF crSortText
);
Parameters

crSortText
An RGB value representing the sorted column text color.

Body Source
void CXTListBase::SetSortTextColor(COLORREF crSortText) {
    m_crSortText = crSortText;
}
Group

CXTListBase Methods


CXTListBase::SetStoredWidth Method

CXTListBase Methods, CXTListBase Class
CXTListBase::SetStoredWidth Method

This member function will set the column width from the registry settings.

virtual void SetStoredWidth(
    int nCol
);
Parameters

nCol
Zero-based index of the column.

Group

CXTListBase Methods


CXTListBase::SortList Method

CXTListBase Methods, CXTListBase Class
CXTListBase::SortList Method

Override this member function in your derived class to perform custom sort routines.

virtual bool SortList(
    int nCol,
    bool bAscending
);
Parameters

nCol
Passed in from the control. Index of the column clicked.
bAscending
Passed in from the control. true if sort order should be ascending.

Group

CXTListBase Methods


CXTListBase::SubclassHeader Method

CXTListBase Methods, CXTListBase Class
CXTListBase::SubclassHeader Method

Call this member function to subclass the flat header control.

virtual bool SubclassHeader(
    bool bBoldFont = false
);
Parameters

bBoldFont
true to use a bold font in the header control.

Group

CXTListBase Methods


CXTListBase Constructors

CXTListBase Class, Legend, Public Methods
CXTListBase Constructors
Class

CXTListBase Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTListBase | Constructs a CXTListBase object


CXTListBase::CXTListBase Constructor

CXTListBase Constructors, CXTListBase Class
CXTListBase::CXTListBase Constructor

Constructs a CXTListBase object

CXTListBase();
Group

CXTListBase Constructors


CXTListBase Destructors

CXTListBase Class, Legend, Public Methods
CXTListBase Destructors
Class

CXTListBase Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTListBase | Destroys a CXTListBase object, handles cleanup and deallocation


CXTListBase::~CXTListBase Destructor

CXTListBase Destructors, CXTListBase Class
CXTListBase::~CXTListBase Destructor

Destroys a CXTListBase object, handles cleanup and deallocation

virtual ~CXTListBase();
Group

CXTListBase Destructors


CXTListBase Nested Types

CXTListBase Class, Public Nested Types
CXTListBase Nested Types
Class

CXTListBase Class

Public Nested Types
Public Nested Type | Description
CRowColorList | List for maintaining ROWCOLOR structures.


CXTListBase::CRowColorList Nested Type

CXTListBase Nested Types, CXTListBase Class, See Also
CXTListBase::CRowColorList Nested Type

List for maintaining ROWCOLOR structures.

typedef CList<ROWCOLOR, ROWCOLOR&> CRowColorList;
Remarks

CList definition used by the CXTListBase class to maintain a list of ROWCOLOR structures representing each row that has a user defined color setting for the list control.

See Also

CXTListBase, CXTListBase::SetRowColor, RemoveRowColors, Lookup, ROWCOLOR

Group

CXTListBase Nested Types


CXTListBox Class

XTListBox.h, Classes, Legend, Members, Topics, CXTListBox Data Members, CXTListBox Methods, CXTListBox Constructors, CXTListBox Destructors, CXTListBox Constructors, CXTListBox Data Members, CXTListBox Destructors, CXTListBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTListBox Class

CXTListBox is a CListBox derived class. CXTListBox extends the standard list box control to enable flicker free drawing.

Class Hierarchy

class CXTListBox : public CListBox;
File

XTListBox.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTListBox Constructors
CXTListBox Constructors | Description
CXTListBox | Constructs a CXTListBox object
CXTListBox Data Members
CXTListBox Data Members | Description
m_nStyle | Listbox style;
CXTListBox Destructors
CXTListBox Destructors | Description
~CXTListBox | Destroys a CXTListBox object, handles cleanup and deallocation
CXTListBox Methods
CXTListBox Methods | Description
GetBackColor | This method is called to get background color of listbox
Initialize | Call this member function to initialize the list box. This method should be called directly after creating or sub-classing the control.


CXTListBox Data Members

CXTListBox Class, Legend, Protected Data Members
CXTListBox Data Members
Class

CXTListBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nStyle | Listbox style;


CXTListBox::m_nStyle Data Member

CXTListBox Data Members, CXTListBox Class
CXTListBox::m_nStyle Data Member

Listbox style;

XTListBoxStyle m_nStyle;
Group

CXTListBox Data Members


CXTListBox Methods

CXTListBox Class, Legend, Public Methods
CXTListBox Methods
Class

CXTListBox Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetBackColor | This method is called to get background color of listbox
Initialize | Call this member function to initialize the list box. This method should be called directly after creating or sub-classing the control.


CXTListBox::GetBackColor Method

CXTListBox Methods, CXTListBox Class
CXTListBox::GetBackColor Method

This method is called to get background color of listbox

virtual COLORREF GetBackColor();
Group

CXTListBox Methods


CXTListBox::Initialize Method

CXTListBox Methods, CXTListBox Class
CXTListBox::Initialize Method

Call this member function to initialize the list box. This method should be called directly after creating or sub-classing the control.

virtual void Initialize(
    bool bAutoFont = true
);
Parameters

bAutoFont
True to enable automatic font initialization.

Group

CXTListBox Methods


CXTListBox Constructors

CXTListBox Class, Legend, Public Methods
CXTListBox Constructors
Class

CXTListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTListBox | Constructs a CXTListBox object


CXTListBox::CXTListBox Constructor

CXTListBox Constructors, CXTListBox Class
CXTListBox::CXTListBox Constructor

Constructs a CXTListBox object

CXTListBox();
Group

CXTListBox Constructors


CXTListBox Destructors

CXTListBox Class, Legend, Public Methods
CXTListBox Destructors
Class

CXTListBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTListBox | Destroys a CXTListBox object, handles cleanup and deallocation


CXTListBox::~CXTListBox Destructor

CXTListBox Destructors, CXTListBox Class
CXTListBox::~CXTListBox Destructor

Destroys a CXTListBox object, handles cleanup and deallocation

virtual ~CXTListBox();
Group

CXTListBox Destructors


CXTListCtrl Class

XTListCtrlView.h, Classes, Legend, Members, Topics, CXTListCtrl Constructors, CXTListCtrl Destructors, CXTListCtrl Constructors, CXTListCtrl Destructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTListCtrl Class

CXTListCtrl is a multiple inheritance class derived from CListCtrl and CXTListBase. This class implements flat header and generic sorting routines. See CXTListBase for additional functionality.

Class Hierarchy

class CXTListCtrl : public CXTListCtrlBase;
File

XTListCtrlView.h

See Also

CXTListBase

Group

Classes

Legend
Constructor
virtual
CXTListCtrl Constructors
CXTListCtrl Constructors | Description
CXTListCtrl | Constructs a CXTListCtrl object
CXTListCtrl Destructors
CXTListCtrl Destructors | Description
~CXTListCtrl | Destroys a CXTListCtrl object, handles cleanup and deallocation


CXTListCtrl Constructors

CXTListCtrl Class, Legend, Public Methods
CXTListCtrl Constructors
Class

CXTListCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTListCtrl | Constructs a CXTListCtrl object


CXTListCtrl::CXTListCtrl Constructor

CXTListCtrl Constructors, CXTListCtrl Class
CXTListCtrl::CXTListCtrl Constructor

Constructs a CXTListCtrl object

CXTListCtrl();
Group

CXTListCtrl Constructors


CXTListCtrl Destructors

CXTListCtrl Class, Legend, Public Methods
CXTListCtrl Destructors
Class

CXTListCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTListCtrl | Destroys a CXTListCtrl object, handles cleanup and deallocation


CXTListCtrl::~CXTListCtrl Destructor

CXTListCtrl Destructors, CXTListCtrl Class
CXTListCtrl::~CXTListCtrl Destructor

Destroys a CXTListCtrl object, handles cleanup and deallocation

virtual ~CXTListCtrl();
Group

CXTListCtrl Destructors


CXTListView Class

XTListCtrlView.h, Classes, Legend, Members, Topics, CXTListView Constructors, CXTListView Destructors, CXTListView Constructors, CXTListView Destructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTListView Class

CXTListView is a multiple inheritance class derived from CListView and CXTListBase. This class implements flat header and generic sorting routines.

Class Hierarchy

class CXTListView : public CXTListViewBase;
File

XTListCtrlView.h

See Also

CXTListBase

Group

Classes

Legend
Constructor
virtual
CXTListView Constructors
CXTListView Constructors | Description
CXTListView | Constructs a CXTListView object
CXTListView Destructors
CXTListView Destructors | Description
~CXTListView | Destroys a CXTListView object, handles cleanup and deallocation


CXTListView Constructors

CXTListView Class, Legend, Public Methods
CXTListView Constructors
Class

CXTListView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTListView | Constructs a CXTListView object


CXTListView::CXTListView Constructor

CXTListView Constructors, CXTListView Class
CXTListView::CXTListView Constructor

Constructs a CXTListView object

CXTListView();
Group

CXTListView Constructors


CXTListView Destructors

CXTListView Class, Legend, Public Methods
CXTListView Destructors
Class

CXTListView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTListView | Destroys a CXTListView object, handles cleanup and deallocation


CXTListView::~CXTListView Destructor

CXTListView Destructors, CXTListView Class
CXTListView::~CXTListView Destructor

Destroys a CXTListView object, handles cleanup and deallocation

virtual ~CXTListView();
Group

CXTListView Destructors


CXTListViewHelper Class

XTVC50Helpers.h, Classes, Legend, Members, Topics, CXTListViewHelper Methods, CXTListViewHelper Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTListViewHelper Class

The CXTListViewHelper class is a helper class that provides helper functions for finding selected items for the MFC CListView class.

Class Hierarchy

class CXTListViewHelper : public CListView;
File

XTVC50Helpers.h

See Also

GetFirstSelectedItemPosition, GetNextSelectedItem

Group

Classes

Legend
Method
CXTListViewHelper Methods
CXTListViewHelper Methods | Description
GetFirstSelectedItemPosition | Gets the position of the first selected item in the list view control.
GetNextSelectedItem | Gets the index of the list item identified by pos, then sets pos to the POSITION value.


CXTListViewHelper Methods

CXTListViewHelper Class, Legend, Public Methods
CXTListViewHelper Methods
Class

CXTListViewHelper Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetFirstSelectedItemPosition | Gets the position of the first selected item in the list view control.
GetNextSelectedItem | Gets the index of the list item identified by pos, then sets pos to the POSITION value.


CXTListViewHelper::GetFirstSelectedItemPosition Method

CXTListViewHelper Methods, CXTListViewHelper Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTListViewHelper::GetFirstSelectedItemPosition Method

Gets the position of the first selected item in the list view control.

POSITION GetFirstSelectedItemPosition() const;
Returns

A POSITION value that can be used for iteration or object pointer retrieval; NULL if no items are selected.

See Also

GetNextSelectedItem

Example

The following example demonstrates how to use GetFirstSelectedItemPosition.

CListCtrl* pListCtrl = (CListCtrl*) GetDlgItem(IDC_YOURLISTCONTROL);
ASSERT(pListCtrl != NULL);

POSITION pos = pList->GetFirstSelectedItemPosition();
if (pos == NULL)
    TRACE0("No items were selected!\n");
else
{
    while (pos)
    {
        int nItem = pList->GetNextSelectedItem(pos);
        TRACE1("Item %d was selected!\n", nItem);
        // you could do your own processing on nItem here
    }
}
Group

CXTListViewHelper Methods


CXTListViewHelper::GetNextSelectedItem Method

CXTListViewHelper Methods, CXTListViewHelper Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTListViewHelper::GetNextSelectedItem Method

Gets the index of the list item identified by pos, then sets pos to the POSITION value.

int GetNextSelectedItem(
    POSITION& pos
) const;
Parameters

pos
A reference to a POSITION value returned by a previous call to GetNextSelectedItem or GetFirstSelectedItemPosition. The value is updated to the next position by this call.

Returns

The index of the list item identified by pos.

Remarks

You can use GetNextSelectedItem in a forward iteration loop if you establish the initial position with a call to GetFirstSelectedItemPosition.

You must ensure that your POSITION value is valid. If it is invalid, then the Debug version of the Microsoft Foundation Class Library asserts.

See Also

GetFirstSelectedItemPosition

Example

The following example demonstrates how to use GetNextSelectedItem.

CListCtrl* pListCtrl = (CListCtrl*) GetDlgItem(IDC_YOURLISTCONTROL);
ASSERT(pListCtrl != NULL);

POSITION pos = pList->GetFirstSelectedItemPosition();
if (pos == NULL)
    TRACE0("No items were selected!\n");
else
{
    while (pos)
    {
        int nItem = pList->GetNextSelectedItem(pos);
        TRACE1("Item %d was selected!\n", nItem);
        // you could do your own processing on nItem here
    }
}
Group

CXTListViewHelper Methods


CXTLogFont Class

XTGlobal.h, Classes, Legend, Members, Topics, CXTLogFont Data Members, CXTLogFont Constructors, CXTLogFont Operators, CXTLogFont Constructors, CXTLogFont Data Members, CXTLogFont Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTLogFont Class

CXTLogFont is a self initializing LOGFONT derived class. It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.

Class Hierarchy

class CXTLogFont : public LOGFONT;
File

XTGlobal.h

Group

Classes

Legend
Data Member
Constructor
Operator
CXTLogFont Constructors
CXTLogFont Constructors | Description
CXTLogFont |
CXTLogFont Data Members
CXTLogFont Data Members | Description
dwType | Used to hold the font type, i.e.
CXTLogFont Operators
CXTLogFont Operators | Description
= | This overloaded operator will copy the data specified by 'logfont' into the structure's data members.


CXTLogFont Data Members

CXTLogFont Class, Legend, Public Data Members
CXTLogFont Data Members
Class

CXTLogFont Class

Legend
Data Member
Public Data Members
Public Data Member | Description
dwType | Used to hold the font type, i.e.


CXTLogFont::dwType Data Member

CXTLogFont Data Members, CXTLogFont Class
CXTLogFont::dwType Data Member

Used to hold the font type, i.e.

DWORD dwType;
Group

CXTLogFont Data Members


CXTLogFont Constructors

CXTLogFont Class, Legend, Public Methods
CXTLogFont Constructors
Class

CXTLogFont Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTLogFont |


CXTLogFont Constructor

CXTLogFont Constructors
CXTLogFont Constructor
Overload List
Constructors
Constructor | Description
CXTLogFont::CXTLogFont () | Constructs an CXTLogFont object. The copy constructor will construct an CXTLogFont object and copy the data specified by 'logfont' into the structure's data members.
CXTLogFont::CXTLogFont (LOGFONT&) | Constructs an CXTLogFont object. The copy constructor will construct an CXTLogFont object and copy the data specified by 'logfont' into the structure's data members.
Group

CXTLogFont Constructors


CXTLogFont::CXTLogFont Constructor ()

CXTLogFont Constructor, CXTLogFont Class
CXTLogFont::CXTLogFont Constructor ()

Constructs an CXTLogFont object. The copy constructor will construct an CXTLogFont object and copy the data specified by 'logfont' into the structure's data members.

CXTLogFont();
CXTLogFont(
    LOGFONT& logfont
);
Parameters

logfont
Valid address of a LOGFONT structure.

Group

CXTLogFont Constructor


CXTLogFont Operators

CXTLogFont Class, Legend, Public Operators
CXTLogFont Operators
Class

CXTLogFont Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This overloaded operator will copy the data specified by 'logfont' into the structure's data members.


CXTLogFont::= Operator

CXTLogFont Operators, CXTLogFont Class
CXTLogFont::= Operator

This overloaded operator will copy the data specified by 'logfont' into the structure's data members.

void operator =(
    LOGFONT& logfont
);
Parameters

logfont
Valid address of a LOGFONT structure.

Group

CXTLogFont Operators


CXTMaskEdit Class

XTMaskEdit.h, Classes, Legend, Members, Topics, CXTMaskEdit Methods, CXTMaskEdit Constructors, CXTMaskEdit Constructors, CXTMaskEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMaskEdit Class

CXTMaskEdit is a CEdit derived class. It allows text masking to be applied to the control to format it for special editing restrictions.

Class Hierarchy

class CXTMaskEdit : public CXTMaskEditT<CEdit>;
File

XTMaskEdit.h

Group

Classes

Legend
Method
virtual
CXTMaskEdit Constructors
CXTMaskEdit Constructors | Description
CXTMaskEdit | Constructs a CXTMaskEdit object
CXTMaskEdit Methods
CXTMaskEdit Methods | Description
Initialize | Initializes the CXTMaskEdit control.
SetEditMask | This member function will set the mask for the edit control.


CXTMaskEdit Methods

CXTMaskEdit Class, Legend, Public Methods
CXTMaskEdit Methods
Class

CXTMaskEdit Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Initialize | Initializes the CXTMaskEdit control.
SetEditMask | This member function will set the mask for the edit control.


CXTMaskEdit::Initialize Method

CXTMaskEdit Methods, CXTMaskEdit Class
CXTMaskEdit::Initialize Method

Initializes the CXTMaskEdit control.

virtual bool Initialize(
    CWnd* pParentWnd
);
Parameters

pParentWnd
Pointer to the parent of the edit control.

Returns

True if the control was successfully initialized, otherwise false.

Remarks

Call this member function to initialize edit control. You can call this after you have created or subclassed your edit control.

Group

CXTMaskEdit Methods


CXTMaskEdit::SetEditMask Method

CXTMaskEdit Methods, CXTMaskEdit Class
CXTMaskEdit::SetEditMask Method

This member function will set the mask for the edit control.

virtual BOOL SetEditMask(
    LPCTSTR lpszMask,
    LPCTSTR lpszLiteral,
    LPCTSTR lpszDefault = NULL
);
Parameters

lpszMask
The format for the mask field. For example, if you wanted to set the mask for a phone number, and you only wanted digits to be entered, your mask might look like this; _T("(000) 000-0000").
lpszLiteral
The literal format is entered here. Wherever you place an underscore ('_') is where the user will be allowed to enter data only. Using the phone number example; _T("(___) ___-____").
lpszDefault
Text that is to be displayed when the control is initialized. For example; _T("(800) 555-1212"). If NULL, 'lpszLiteral' is used to initialize the edit text.

Remarks

The values that can be set are:

Mask Character | Description
0 | Numeric (0-9)
9 | Numeric (0-9) or space (' ')
# | Numeric (0-9) or space (' ') or ('+') or ('-')
L | Alpha (a-Z)
? | Alpha (a-Z) or space (' ')
A | Alpha numeric (0-9 and a-Z)
a | Alpha numeric (0-9 and a-Z) or space (' ')
& | All print character only
H | Hex digit (0-9 and A-F)
X | Hex digit (0-9 and A-F) and space (' ')
> | Forces characters to upper case (A-Z)
< | Forces characters to lower case (a-z)
Group

CXTMaskEdit Methods


CXTMaskEdit Constructors

CXTMaskEdit Class, Legend, Public Methods
CXTMaskEdit Constructors
Class

CXTMaskEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMaskEdit | Constructs a CXTMaskEdit object


CXTMaskEdit::CXTMaskEdit Constructor

CXTMaskEdit Constructors, CXTMaskEdit Class
CXTMaskEdit::CXTMaskEdit Constructor

Constructs a CXTMaskEdit object

CXTMaskEdit();
Group

CXTMaskEdit Constructors


CXTMDIClientWnd Class

XTMDIWndTab.h, Classes, Legend, Members, Topics, CXTMDIClientWnd Data Members, CXTMDIClientWnd Methods, CXTMDIClientWnd Constructors, CXTMDIClientWnd Destructors, CXTMDIClientWnd Constructors, CXTMDIClientWnd Data Members, CXTMDIClientWnd Destructors, CXTMDIClientWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMDIClientWnd Class

CXTMDIClientWnd is a CWnd derived helper class for the CXTMDIWndTab tab control. This class routes messages sent to the client window back to the tab control.

Class Hierarchy

class CXTMDIClientWnd : public CWnd;
File

XTMDIWndTab.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTMDIClientWnd Constructors
CXTMDIClientWnd Constructors | Description
CXTMDIClientWnd | Constructs a CXTMDIClientWnd object
CXTMDIClientWnd Data Members
CXTMDIClientWnd Data Members | Description
m_iBorderGap | Amount in pixels between the client and the tab control.
m_pMDIWndTab | Pointer to the MDI tab control.
CXTMDIClientWnd Destructors
CXTMDIClientWnd Destructors | Description
~CXTMDIClientWnd | Destroys a CXTMDIClientWnd object, handles cleanup and deallocation
CXTMDIClientWnd Methods
CXTMDIClientWnd Methods | Description
SetBorderGap | This member function will set the size of the gap between the client area and the tab control.


CXTMDIClientWnd Data Members

CXTMDIClientWnd Class, Legend, Protected Data Members
CXTMDIClientWnd Data Members
Class

CXTMDIClientWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_iBorderGap | Amount in pixels between the client and the tab control.
m_pMDIWndTab | Pointer to the MDI tab control.


CXTMDIClientWnd::m_iBorderGap Data Member

CXTMDIClientWnd Data Members, CXTMDIClientWnd Class
CXTMDIClientWnd::m_iBorderGap Data Member

Amount in pixels between the client and the tab control.

int m_iBorderGap;
Group

CXTMDIClientWnd Data Members


CXTMDIClientWnd::m_pMDIWndTab Data Member

CXTMDIClientWnd Data Members, CXTMDIClientWnd Class
CXTMDIClientWnd::m_pMDIWndTab Data Member

Pointer to the MDI tab control.

CXTMDIWndTab* m_pMDIWndTab;
Group

CXTMDIClientWnd Data Members


CXTMDIClientWnd Methods

CXTMDIClientWnd Class, Legend, Public Methods
CXTMDIClientWnd Methods
Class

CXTMDIClientWnd Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetBorderGap | This member function will set the size of the gap between the client area and the tab control.


CXTMDIClientWnd::SetBorderGap Method

CXTMDIClientWnd Methods, CXTMDIClientWnd Class, Body Source
CXTMDIClientWnd::SetBorderGap Method

This member function will set the size of the gap between the client area and the tab control.

void SetBorderGap(
    int iSize
);
Parameters

iSize
Amount in pixels of gap between the tab control and the client.

Body Source
void CXTMDIClientWnd::SetBorderGap(int iBorderGap) {
    m_iBorderGap = iBorderGap;
}
Group

CXTMDIClientWnd Methods


CXTMDIClientWnd Constructors

CXTMDIClientWnd Class, Legend, Public Methods
CXTMDIClientWnd Constructors
Class

CXTMDIClientWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMDIClientWnd | Constructs a CXTMDIClientWnd object


CXTMDIClientWnd::CXTMDIClientWnd Constructor

CXTMDIClientWnd Constructors, CXTMDIClientWnd Class
CXTMDIClientWnd::CXTMDIClientWnd Constructor

Constructs a CXTMDIClientWnd object

CXTMDIClientWnd(
    CXTMDIWndTab* pMDIWndTab
);
Parameters

pMDIWndTab
Pointer to a CXTMDITabWnd object.

Group

CXTMDIClientWnd Constructors


CXTMDIClientWnd Destructors

CXTMDIClientWnd Class, Legend, Public Methods
CXTMDIClientWnd Destructors
Class

CXTMDIClientWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTMDIClientWnd | Destroys a CXTMDIClientWnd object, handles cleanup and deallocation


CXTMDIClientWnd::~CXTMDIClientWnd Destructor

CXTMDIClientWnd Destructors, CXTMDIClientWnd Class
CXTMDIClientWnd::~CXTMDIClientWnd Destructor

Destroys a CXTMDIClientWnd object, handles cleanup and deallocation

virtual ~CXTMDIClientWnd();
Group

CXTMDIClientWnd Destructors


CXTMDIWndTab Class

XTMDIWndTab.h, Classes, Legend, Members, Topics, CXTMDIWndTab Data Members, CXTMDIWndTab Methods, CXTMDIWndTab Constructors, CXTMDIWndTab Destructors, CXTMDIWndTab Nested Types, CXTMDIWndTab Constructors, CXTMDIWndTab Data Members, CXTMDIWndTab Destructors, Example, CXTMDIWndTab Methods, CXTMDIWndTab Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMDIWndTab Class

CXTMDIWndTab class is used for creating a tabbed MDI document interface.

Class Hierarchy

class CXTMDIWndTab : public CXTMDIWndTabBase;
File

XTMDIWndTab.h

Remarks

CXTMDIWndTab is derived from CTabCtrl and CXTTabCtrlBase and is used to create a tab control for a multiple document interface (MDI) application.

Example

The following example demonstrates the use of CXTMDIWndTab.

// Install the MDI tab window.
m_wndMDITabWindow.Install(this, NULL, TRUE);
m_wndMDITabWindow.SetBorderGap(1);
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTMDIWndTab Constructors
CXTMDIWndTab Constructors | Description
CXTMDIWndTab | Constructs a CXTMDIWndTab object
CXTMDIWndTab Data Members
CXTMDIWndTab Data Members | Description
m_arMDIChildern | Array of the MDI windows added to the tab control.
m_bNoIcons | TRUE if no icons are used.
m_dwInitSignature | Initialization state signature to synch up posted init requests.
m_hActiveChild | Active MDI child.
m_iBorderGap | Amount in pixels between the client and the tab control.
m_iHitTest | Index of the tab that received a right click.
m_imageList | Tab image list.
m_mapTabIcons | Hash table that maps icons to the MDI child frame windows.
m_mapTabLabels | Hash table that maps labels to the MDI child frame windows.
m_nDefCmd | Command ID of the default menu item for the popup menu.
m_nPos | Index of the popup menu contained in the menu.
m_pMDIClientWnd | Window that receives messages on behalf of the MDI client.
m_pMDIFrameWnd | Points to the owner frame.
m_popupMenuID | Popup menu resource ID.
CXTMDIWndTab Destructors
CXTMDIWndTab Destructors | Description
~CXTMDIWndTab | Destroys a CXTMDIWndTab object, handles cleanup and deallocation
CXTMDIWndTab Methods
CXTMDIWndTab Methods | Description
GetChildWndText | This member function will get the text for the specified MDI child window.
GetFrameWnd |
Init | This member function is called by the CXTMDIWndTab class to perform initialization when the window is created or sub-classed.
InitializeFont | This member function is called to initialize the font for the tab control associated with this view.
InsertTabWnd | This member function is called to insert a child frame into the MDI tab control.
Install | This member function will install the MDI tab views with your application.
OnMDIActivate | Called when an WM_MDIACTIVATE message is sent to a multiple-document interface (MDI) client window to instruct the client window to activate a different MDI child window.
OnMDICreate | Called when an WM_MDICREATE message is sent to a multiple-document interface (MDI) client window to create an MDI child window.
OnMDIDestroy | Called when an WM_MDIDESTROY message is sent to a multiple-document interface (MDI) client window to close an MDI child window.
RecalcLayout | Called to refresh the tab labels and frame window layout.
RefreshActiveSel | This member function is called by the tab control to ensure the current selection matches the active document.
RefreshIndexes | This member function is called by the tab control to ensure the stored indexes match their corresponding tab indexes.
RefreshTabLabels | This member function is called by the tab control to ensure the tab labels match their corresponding views.
SetBorderGap | This member function will set the size of the gap between the client area and the tab control.
SetMenuID | This member function is used to set the resource ID for the popup menu used by the tab control.
SetTabIcon |
SetTabLabel |
TabFromPoint | Call this member function to retrieve the tab index from the current cursor position.
UnInstall | This member function will uninstall the MDI tab views from your application.
CXTMDIWndTab Nested Types
CXTMDIWndTab Nested Types | Description
CIconWndMap | Map for maintaining HWND to HICON handle relationships.
CMDIChildList | List for maintaining MDICHILD structures.
CStringMap | Map for maintaining HWND to CString object relationships.


CXTMDIWndTab Data Members

CXTMDIWndTab Class, Legend, Protected Data Members
CXTMDIWndTab Data Members
Class

CXTMDIWndTab Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arMDIChildern | Array of the MDI windows added to the tab control.
m_bNoIcons | TRUE if no icons are used.
m_dwInitSignature | Initialization state signature to synch up posted init requests.
m_hActiveChild | Active MDI child.
m_iBorderGap | Amount in pixels between the client and the tab control.
m_iHitTest | Index of the tab that received a right click.
m_imageList | Tab image list.
m_mapTabIcons | Hash table that maps icons to the MDI child frame windows.
m_mapTabLabels | Hash table that maps labels to the MDI child frame windows.
m_nDefCmd | Command ID of the default menu item for the popup menu.
m_nPos | Index of the popup menu contained in the menu.
m_pMDIClientWnd | Window that receives messages on behalf of the MDI client.
m_pMDIFrameWnd | Points to the owner frame.
m_popupMenuID | Popup menu resource ID.


CXTMDIWndTab::m_arMDIChildern Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_arMDIChildern Data Member

Array of the MDI windows added to the tab control.

CMDIChildList m_arMDIChildern;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_bNoIcons Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_bNoIcons Data Member

TRUE if no icons are used.

BOOL m_bNoIcons;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_dwInitSignature Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_dwInitSignature Data Member

Initialization state signature to synch up posted init requests.

DWORD m_dwInitSignature;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_hActiveChild Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_hActiveChild Data Member

Active MDI child.

HWND m_hActiveChild;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_iBorderGap Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_iBorderGap Data Member

Amount in pixels between the client and the tab control.

int m_iBorderGap;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_iHitTest Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_iHitTest Data Member

Index of the tab that received a right click.

int m_iHitTest;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_imageList Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_imageList Data Member

Tab image list.

CImageList m_imageList;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_mapTabIcons Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_mapTabIcons Data Member

Hash table that maps icons to the MDI child frame windows.

CIconWndMap m_mapTabIcons;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_mapTabLabels Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_mapTabLabels Data Member

Hash table that maps labels to the MDI child frame windows.

CStringMap m_mapTabLabels;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_nDefCmd Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_nDefCmd Data Member

Command ID of the default menu item for the popup menu.

UINT m_nDefCmd;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_nPos Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_nPos Data Member

Index of the popup menu contained in the menu.

int m_nPos;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_pMDIClientWnd Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_pMDIClientWnd Data Member

Window that receives messages on behalf of the MDI client.

CXTMDIClientWnd* m_pMDIClientWnd;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_pMDIFrameWnd Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_pMDIFrameWnd Data Member

Points to the owner frame.

CMDIFrameWnd* m_pMDIFrameWnd;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab::m_popupMenuID Data Member

CXTMDIWndTab Data Members, CXTMDIWndTab Class
CXTMDIWndTab::m_popupMenuID Data Member

Popup menu resource ID.

UINT m_popupMenuID;
Group

CXTMDIWndTab Data Members


CXTMDIWndTab Methods

CXTMDIWndTab Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMDIWndTab Methods
Class

CXTMDIWndTab Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Init | This member function is called by the CXTMDIWndTab class to perform initialization when the window is created or sub-classed.
InitializeFont | This member function is called to initialize the font for the tab control associated with this view.
InsertTabWnd | This member function is called to insert a child frame into the MDI tab control.
OnMDIActivate | Called when an WM_MDIACTIVATE message is sent to a multiple-document interface (MDI) client window to instruct the client window to activate a different MDI child window.
OnMDICreate | Called when an WM_MDICREATE message is sent to a multiple-document interface (MDI) client window to create an MDI child window.
OnMDIDestroy | Called when an WM_MDIDESTROY message is sent to a multiple-document interface (MDI) client window to close an MDI child window.
RecalcLayout | Called to refresh the tab labels and frame window layout.
RefreshActiveSel | This member function is called by the tab control to ensure the current selection matches the active document.
RefreshIndexes | This member function is called by the tab control to ensure the stored indexes match their corresponding tab indexes.
RefreshTabLabels | This member function is called by the tab control to ensure the tab labels match their corresponding views.
Public Methods
Public Methods
Public Method | Description
GetChildWndText | This member function will get the text for the specified MDI child window.
GetFrameWnd |
Install | This member function will install the MDI tab views with your application.
SetBorderGap | This member function will set the size of the gap between the client area and the tab control.
SetMenuID | This member function is used to set the resource ID for the popup menu used by the tab control.
SetTabIcon |
SetTabLabel |
TabFromPoint | Call this member function to retrieve the tab index from the current cursor position.
UnInstall | This member function will uninstall the MDI tab views from your application.


CXTMDIWndTab::GetChildWndText Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::GetChildWndText Method

This member function will get the text for the specified MDI child window.

CString GetChildWndText(
    HWND hWnd
) const;
Parameters

hWnd
Handle to a valid CMDIChildWnd object.

Returns

A const CString object that represents the document title.

Group

CXTMDIWndTab Methods


GetFrameWnd Method

CXTMDIWndTab Methods
GetFrameWnd Method
Overload List
Methods
Method | Description
CXTMDIWndTab::GetFrameWnd (CPoint) | This member function will return a pointer to the child frame associated with the tab item.
CXTMDIWndTab::GetFrameWnd (int) | This member function will return a pointer to the child frame associated with the tab item.
Group

CXTMDIWndTab Methods


CXTMDIWndTab::GetFrameWnd Method (int)

GetFrameWnd Method, CXTMDIWndTab Class
CXTMDIWndTab::GetFrameWnd Method (int)

This member function will return a pointer to the child frame associated with the tab item.

CMDIChildWnd* GetFrameWnd(
    int iIndex = -1
) const;
CMDIChildWnd* GetFrameWnd(
    CPoint point
) const;
Parameters

iIndex
Index of the tab control. If -1, then the tab under the mouse when the last right click was performed will be used.
point
CPoint object that represents the cursor position.

Returns

A CWnd object if successful, otherwise returns NULL.

Group

GetFrameWnd Method


CXTMDIWndTab::Init Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::Init Method

This member function is called by the CXTMDIWndTab class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTMDIWndTab Methods


CXTMDIWndTab::InitializeFont Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::InitializeFont Method

This member function is called to initialize the font for the tab control associated with this view.

virtual void InitializeFont();
Group

CXTMDIWndTab Methods


CXTMDIWndTab::InsertTabWnd Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::InsertTabWnd Method

This member function is called to insert a child frame into the MDI tab control.

virtual void InsertTabWnd(
    CMDIChildWnd* pChildFrame,
    BOOL bRecalcLayout = TRUE
);
Parameters

pChildFrame
A pointer to a valid child frame window.
bRecalcLayout
TRUE to force the MDI frame window to recalc the layout.

Group

CXTMDIWndTab Methods


CXTMDIWndTab::Install Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::Install Method

This member function will install the MDI tab views with your application.

virtual BOOL Install(
    CMDIFrameWnd* pMDIFrameWnd,
    DWORD dwStyle = TCS_BOTTOM | TCS_HOTTRACK,
    BOOL bNoIcons = XTAuxData().bXPMode
);
Parameters

pMDIFrameWnd
Points to the parent MDI frame window.
dwStyle
Style for the tab control. It can be any of the TCS_ values.
bNoIcons
Set to TRUE for no icon to display

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTMDIWndTab Methods


CXTMDIWndTab::OnMDIActivate Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::OnMDIActivate Method

Called when an WM_MDIACTIVATE message is sent to a multiple-document interface (MDI) client window to instruct the client window to activate a different MDI child window.

virtual void OnMDIActivate(
    HWND hWnd
);
Parameters

hWnd
handle to destination control

Group

CXTMDIWndTab Methods


CXTMDIWndTab::OnMDICreate Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::OnMDICreate Method

Called when an WM_MDICREATE message is sent to a multiple-document interface (MDI) client window to create an MDI child window.

virtual void OnMDICreate(
    HWND hWnd
);
Parameters

hWnd
handle to destination control

Group

CXTMDIWndTab Methods


CXTMDIWndTab::OnMDIDestroy Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::OnMDIDestroy Method

Called when an WM_MDIDESTROY message is sent to a multiple-document interface (MDI) client window to close an MDI child window.

virtual void OnMDIDestroy(
    HWND hWnd
);
Parameters

hWnd
handle to destination control

Group

CXTMDIWndTab Methods


CXTMDIWndTab::RecalcLayout Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::RecalcLayout Method

Called to refresh the tab labels and frame window layout.

virtual void RecalcLayout(
    BOOL bDelayRecalc
);
Parameters

bDelayRecalc
TRUE to call DelayRecalcLayout for the parent frame.

Group

CXTMDIWndTab Methods


CXTMDIWndTab::RefreshActiveSel Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::RefreshActiveSel Method

This member function is called by the tab control to ensure the current selection matches the active document.

BOOL RefreshActiveSel();
Returns

FALSE if there is no active document, otherwise returns TRUE.

Group

CXTMDIWndTab Methods


CXTMDIWndTab::RefreshIndexes Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::RefreshIndexes Method

This member function is called by the tab control to ensure the stored indexes match their corresponding tab indexes.

void RefreshIndexes();
Group

CXTMDIWndTab Methods


CXTMDIWndTab::RefreshTabLabels Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::RefreshTabLabels Method

This member function is called by the tab control to ensure the tab labels match their corresponding views.

void RefreshTabLabels();
Group

CXTMDIWndTab Methods


CXTMDIWndTab::SetBorderGap Method

CXTMDIWndTab Methods, CXTMDIWndTab Class, Body Source
CXTMDIWndTab::SetBorderGap Method

This member function will set the size of the gap between the client area and the tab control.

void SetBorderGap(
    int iSize
);
Parameters

iSize
Amount in pixels of gap between the tab control and the client.

Body Source
void CXTMDIWndTab::SetBorderGap(int iBorderGap) {
    m_iBorderGap = iBorderGap; m_pMDIClientWnd->SetBorderGap(iBorderGap + ::GetSystemMetrics(SM_CXSIZEFRAME));
}
Group

CXTMDIWndTab Methods


CXTMDIWndTab::SetMenuID Method

CXTMDIWndTab Methods, CXTMDIWndTab Class, Body Source
CXTMDIWndTab::SetMenuID Method

This member function is used to set the resource ID for the popup menu used by the tab control.

void SetMenuID(
    UINT popupMenuID,
    int nPos = 0,
    UINT nDefCmd = (UINT)-1
);
Parameters

popupMenuID
ID for the tab control popup menu.
nPos
Index position in the menu resource.
nDefCmd
ID of the default menu command, will display bold.

Body Source
void CXTMDIWndTab::SetMenuID(UINT popupMenuID, int nPos, UINT nDefCmd) {
    m_popupMenuID = popupMenuID; m_nPos = nPos; m_nDefCmd = nDefCmd;
}
Group

CXTMDIWndTab Methods


SetTabIcon Method

CXTMDIWndTab Methods
SetTabIcon Method
Overload List
Methods
Method | Description
CXTMDIWndTab::SetTabIcon (HWND, HICON&) | Call this member function to set the icon for the tab item specified by 'iIndex'.
CXTMDIWndTab::SetTabIcon (int, HICON&) | Call this member function to set the icon for the tab item specified by 'iIndex'.
Group

CXTMDIWndTab Methods


CXTMDIWndTab::SetTabIcon Method (int, HICON&)

SetTabIcon Method, CXTMDIWndTab Class
CXTMDIWndTab::SetTabIcon Method (int, HICON&)

Call this member function to set the icon for the tab item specified by 'iIndex'.

bool SetTabIcon(
    int iIndex,
    HICON& hIcon
);
bool SetTabIcon(
    HWND hChildWnd,
    HICON& hIcon
);
Parameters

iIndex
Zero-based index of the tab to set the tab icon for.
hIcon
Reference to an HICON handle that represents the tab icon.
hChildWnd
Valid HWND of the MDI child window to set the tab icon for.

Returns

true if successful, otherwise returns false.

Group

SetTabIcon Method


SetTabLabel Method

CXTMDIWndTab Methods
SetTabLabel Method
Overload List
Methods
Method | Description
CXTMDIWndTab::SetTabLabel (HWND, CString&) | Call this member function to set the label for the tab item specified by 'iIndex'.
CXTMDIWndTab::SetTabLabel (int, CString&) | Call this member function to set the label for the tab item specified by 'iIndex'.
Group

CXTMDIWndTab Methods


CXTMDIWndTab::SetTabLabel Method (int, CString&)

SetTabLabel Method, CXTMDIWndTab Class
CXTMDIWndTab::SetTabLabel Method (int, CString&)

Call this member function to set the label for the tab item specified by 'iIndex'.

bool SetTabLabel(
    int iIndex,
    CString& strLabel
);
bool SetTabLabel(
    HWND hChildWnd,
    CString& strLabel
);
Parameters

iIndex
Zero-based index of the tab to set the tab text for.
strLabel
Reference to a CString object that represents the tab label.
hChildWnd
Valid HWND of the MDI child window to set the tab text for.

Returns

true if successful, otherwise returns false.

Group

SetTabLabel Method


CXTMDIWndTab::TabFromPoint Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::TabFromPoint Method

Call this member function to retrieve the tab index from the current cursor position.

int TabFromPoint(
    CPoint point
) const;
Parameters

point
Pointer to a CPoint object that contains the cursor screen coordinates. Use default for the current cursor position.

Returns

The zero-based index of the tab, or -1 if no tab is at the specified point.

Group

CXTMDIWndTab Methods


CXTMDIWndTab::UnInstall Method

CXTMDIWndTab Methods, CXTMDIWndTab Class
CXTMDIWndTab::UnInstall Method

This member function will uninstall the MDI tab views from your application.

virtual BOOL UnInstall();
Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTMDIWndTab Methods


CXTMDIWndTab Constructors

CXTMDIWndTab Class, Legend, Public Methods
CXTMDIWndTab Constructors
Class

CXTMDIWndTab Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMDIWndTab | Constructs a CXTMDIWndTab object


CXTMDIWndTab::CXTMDIWndTab Constructor

CXTMDIWndTab Constructors, CXTMDIWndTab Class
CXTMDIWndTab::CXTMDIWndTab Constructor

Constructs a CXTMDIWndTab object

CXTMDIWndTab();
Group

CXTMDIWndTab Constructors


CXTMDIWndTab Destructors

CXTMDIWndTab Class, Legend, Public Methods
CXTMDIWndTab Destructors
Class

CXTMDIWndTab Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTMDIWndTab | Destroys a CXTMDIWndTab object, handles cleanup and deallocation


CXTMDIWndTab::~CXTMDIWndTab Destructor

CXTMDIWndTab Destructors, CXTMDIWndTab Class
CXTMDIWndTab::~CXTMDIWndTab Destructor

Destroys a CXTMDIWndTab object, handles cleanup and deallocation

virtual ~CXTMDIWndTab();
Group

CXTMDIWndTab Destructors


CXTMDIWndTab Nested Types

CXTMDIWndTab Class, Public Nested Types
CXTMDIWndTab Nested Types
Class

CXTMDIWndTab Class

Public Nested Types
Public Nested Type | Description
CIconWndMap | Map for maintaining HWND to HICON handle relationships.
CMDIChildList | List for maintaining MDICHILD structures.
CStringMap | Map for maintaining HWND to CString object relationships.


CXTMDIWndTab::CIconWndMap Nested Type

CXTMDIWndTab Nested Types, CXTMDIWndTab Class, See Also
CXTMDIWndTab::CIconWndMap Nested Type

Map for maintaining HWND to HICON handle relationships.

typedef CMap<HWND, HWND, HICON, HICON&> CIconWndMap;
Remarks

CMap definition used by the CXTMDIWndTab class to maintain a list of HWND to HICON handle relationships to map a MDI child window with the tab icon displayed.

See Also

CXTMDIWndTab

Group

CXTMDIWndTab Nested Types


CXTMDIWndTab::CMDIChildList Nested Type

CXTMDIWndTab Nested Types, CXTMDIWndTab Class, See Also
CXTMDIWndTab::CMDIChildList Nested Type

List for maintaining MDICHILD structures.

typedef CList<MDICHILD*, MDICHILD*> CMDIChildList;
Remarks

CList definition used by the CXTMDIWndTab class to maintain a list of MDICHILD structures representing each MDI child item in the tab control.

See Also

CXTMDIWndTab, MDICHILD

Group

CXTMDIWndTab Nested Types


CXTMDIWndTab::CStringMap Nested Type

CXTMDIWndTab Nested Types, CXTMDIWndTab Class, See Also
CXTMDIWndTab::CStringMap Nested Type

Map for maintaining HWND to CString object relationships.

typedef CMap<HWND, HWND, CString, CString&> CStringMap;
Remarks

CMap definition used by the CXTMDIWndTab class to maintain a list of HWND to CString object relationships to map a MDI child window with the tab label displayed.

See Also

CXTMDIWndTab

Group

CXTMDIWndTab Nested Types


CXTMemDC Class

XTMemDC.h, Classes, Legend, Members, Topics, CXTMemDC Data Members, CXTMemDC Methods, CXTMemDC Constructors, CXTMemDC Destructors, CXTMemDC Constructors, CXTMemDC Data Members, CXTMemDC Destructors, CXTMemDC Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMemDC Class

CXTMemDC is a CDC derived class. CXTMemDC is an extension of CDC that helps eliminate screen flicker when windows are resized, by painting to an off screen bitmap. The class then uses CDC::BitBlt to copy the bitmap back into the current device context after all items have been painted.

Class Hierarchy

class CXTMemDC : public CDC;
File

XTMemDC.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTMemDC Constructors
CXTMemDC Constructors | Description
CXTMemDC | Constructs a CXTMemDC object used for flicker free drawing.
CXTMemDC Data Members
CXTMemDC Data Members | Description
m_bitmap | Off screen bitmap.
m_bValid | Flag used for autodraw in destructor.
m_hOldBitmap | Original GDI object.
m_pDC | Saves the CDC passed in constructor.
m_rc | Rectangle of the drawing area.
CXTMemDC Destructors
CXTMemDC Destructors | Description
~CXTMemDC | Destroys a CXTMemDC object, handles cleanup and deallocation
CXTMemDC Methods
CXTMemDC Methods | Description
Discard | This member function is called to set the valid flag to false so that the off screen device context will not be drawn.
FromDC | This member function gets content from the given DC
GetBitmap | This member function retrieves a reference to the CBitmap object associated with the memory device context.
IsValid | Call this member function to determine if memory was allocated and the device context was successfully created.


CXTMemDC Data Members

CXTMemDC Class, Legend, Protected Data Members
CXTMemDC Data Members
Class

CXTMemDC Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bitmap | Off screen bitmap.
m_bValid | Flag used for autodraw in destructor.
m_hOldBitmap | Original GDI object.
m_pDC | Saves the CDC passed in constructor.
m_rc | Rectangle of the drawing area.


CXTMemDC::m_bitmap Data Member

CXTMemDC Data Members, CXTMemDC Class
CXTMemDC::m_bitmap Data Member

Off screen bitmap.

CBitmap m_bitmap;
Group

CXTMemDC Data Members


CXTMemDC::m_bValid Data Member

CXTMemDC Data Members, CXTMemDC Class
CXTMemDC::m_bValid Data Member

Flag used for autodraw in destructor.

BOOL m_bValid;
Group

CXTMemDC Data Members


CXTMemDC::m_hOldBitmap Data Member

CXTMemDC Data Members, CXTMemDC Class
CXTMemDC::m_hOldBitmap Data Member

Original GDI object.

HBITMAP m_hOldBitmap;
Group

CXTMemDC Data Members


CXTMemDC::m_pDC Data Member

CXTMemDC Data Members, CXTMemDC Class
CXTMemDC::m_pDC Data Member

Saves the CDC passed in constructor.

CDC* m_pDC;
Group

CXTMemDC Data Members


CXTMemDC::m_rc Data Member

CXTMemDC Data Members, CXTMemDC Class
CXTMemDC::m_rc Data Member

Rectangle of the drawing area.

CRect m_rc;
Group

CXTMemDC Data Members


CXTMemDC Methods

CXTMemDC Class, Legend, Public Methods
CXTMemDC Methods
Class

CXTMemDC Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Discard | This member function is called to set the valid flag to false so that the off screen device context will not be drawn.
FromDC | This member function gets content from the given DC
GetBitmap | This member function retrieves a reference to the CBitmap object associated with the memory device context.
IsValid | Call this member function to determine if memory was allocated and the device context was successfully created.


CXTMemDC::Discard Method

CXTMemDC Methods, CXTMemDC Class
CXTMemDC::Discard Method

This member function is called to set the valid flag to false so that the off screen device context will not be drawn.

void Discard();
Group

CXTMemDC Methods


CXTMemDC::FromDC Method

CXTMemDC Methods, CXTMemDC Class
CXTMemDC::FromDC Method

This member function gets content from the given DC

void FromDC();
Group

CXTMemDC Methods


CXTMemDC::GetBitmap Method

CXTMemDC Methods, CXTMemDC Class
CXTMemDC::GetBitmap Method

This member function retrieves a reference to the CBitmap object associated with the memory device context.

CBitmap& GetBitmap();
Returns

A reference to the CBitmap object associated with the memory device context.

Group

CXTMemDC Methods


CXTMemDC::IsValid Method

CXTMemDC Methods, CXTMemDC Class
CXTMemDC::IsValid Method

Call this member function to determine if memory was allocated and the device context was successfully created.

BOOL IsValid() const;
Returns

TRUE if the device context is valid, otherwise FALSE.

Group

CXTMemDC Methods


CXTMemDC Constructors

CXTMemDC Class, Legend, Public Methods
CXTMemDC Constructors
Class

CXTMemDC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMemDC | Constructs a CXTMemDC object used for flicker free drawing.


CXTMemDC::CXTMemDC Constructor

CXTMemDC Constructors, CXTMemDC Class
CXTMemDC::CXTMemDC Constructor

Constructs a CXTMemDC object used for flicker free drawing.

CXTMemDC(
    CDC* pDC,
    const CRect& rect,
    CXTPPaintManagerColorGradient crBack = GetXtremeColor(COLOR_3DFACE),
    BOOL bHorz = FALSE
);
Parameters

pDC
A Pointer to the current device context.
rect
Represents the size of the area to paint.
crBack
An RGB color value that represents the background color. If no value is specified the system face color for three dimensional display elements is used.
bHorz
If crBack contains gradient colors indicates the direction of the gradient fill.

Group

CXTMemDC Constructors


CXTMemDC Destructors

CXTMemDC Class, Legend, Public Methods
CXTMemDC Destructors
Class

CXTMemDC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTMemDC | Destroys a CXTMemDC object, handles cleanup and deallocation


CXTMemDC::~CXTMemDC Destructor

CXTMemDC Destructors, CXTMemDC Class
CXTMemDC::~CXTMemDC Destructor

Destroys a CXTMemDC object, handles cleanup and deallocation

virtual ~CXTMemDC();
Group

CXTMemDC Destructors


CXTMemFile Class

XTMemFile.h, Classes, Legend, Members, Topics, CXTMemFile Methods, CXTMemFile Constructors, CXTMemFile Destructors, CXTMemFile Operators, CXTMemFile Constructors, CXTMemFile Destructors, CXTMemFile Methods, CXTMemFile Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMemFile Class

CXTMemFile is a CMemFile derived class. It is used to create a CXTMemFile object to support memory files.

Class Hierarchy

class CXTMemFile : public CMemFile;
File

XTMemFile.h

Remarks

These memory files behave like disk files except that the file is stored in RAM rather than on disk. A memory file is useful for fast temporary storage or for transferring raw bytes or serialized objects between independent processes.

CXTMemFile objects can automatically allocate their own memory, or you can attach your own memory block to the CXTMemFile object by calling Attach. In either case, memory for growing the memory file automatically is allocated in nGrowBytes-sized increments if 'nGrowBytes' is not zero.

The memory block will automatically be deleted upon destruction of the CXTMemFile object if the memory was originally allocated by the CXTMemFile object. Otherwise, you are responsible for de-allocating the memory you attached to the object.

You can access the memory block through the pointer supplied when you detach it from the CXTMemFile object by calling Detach.

The most common use of CXTMemFile is to create a CXTMemFile object and use it by calling CFile member functions. Note that creating a CXTMemFile automatically opens it: you do not call CFile::Open, which is only used for disk files. Because CXTMemFile doesn't use a disk file, the data member CFile::m_hFile is not used and has no meaning.

The CFile member functions Duplicate, LockRange, and UnlockRange are not implemented for CXTMemFile. If you call these functions on a CXTMemFile object, you will get a CNotSupportedException.

CXTMemFile uses the run-time library functions malloc, realloc, and free to allocate, reallocate, and deallocate memory and the intrinsic memcpy to block copy memory when reading and writing. If you would like to change this behavior or the behavior when CXTMemFile grows a file, derive your own class from CXTMemFile and override the appropriate functions.

Group

Classes

Legend
Method
protected
virtual
Operator
CXTMemFile Constructors
CXTMemFile Constructors | Description
CXTMemFile |
CXTMemFile Destructors
CXTMemFile Destructors | Description
~CXTMemFile | Destroys a CXTMemFile object, handles cleanup and deallocation
CXTMemFile Methods
CXTMemFile Methods | Description
Append | This member function appends a CFile derived object to the file (operator+=).
Close | This member function saves the contents of the memory to the disk and closes it.
Discard | This member function discards all changes to file since Open() or last Flush().
Duplicate |
Extract |
FindData | This member function finds data in the file.
Flush | This member function forces any data remaining in the file buffer to be written to the file. The use of Flush does not guarantee flushing of CArchive buffers. If you are using an archive, call CArchive::Flush first.
Import | This member function imports the data of a CFile derived object (operator=).
Insert |
Load | This member function loads the file into memory.
Open | This member function opens and loads a physical File into memory.
ReadString | This member function reads a string.
Save | This member function saves the file to disk.
WriteString | This method writes data from a buffer to the file associated with the CArchive object. The terminating null character, 0, is not written to the file, nor is a newline character automatically written.
CXTMemFile Operators
CXTMemFile Operators | Description
[] | This member operator will perform indexing operations for the CXTMemFile object. Returns a BYTE data type.
+= |
= |


CXTMemFile Methods

CXTMemFile Class, Legend, Protected Methods, Public Methods
CXTMemFile Methods
Class

CXTMemFile Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Append | This member function appends a CFile derived object to the file (operator+=).
Import | This member function imports the data of a CFile derived object (operator=).
Load | This member function loads the file into memory.
Save | This member function saves the file to disk.
Public Methods
Public Methods
Public Method | Description
Close | This member function saves the contents of the memory to the disk and closes it.
Discard | This member function discards all changes to file since Open() or last Flush().
Duplicate |
Extract |
FindData | This member function finds data in the file.
Flush | This member function forces any data remaining in the file buffer to be written to the file. The use of Flush does not guarantee flushing of CArchive buffers. If you are using an archive, call CArchive::Flush first.
Insert |
Open | This member function opens and loads a physical File into memory.
ReadString | This member function reads a string.
WriteString | This method writes data from a buffer to the file associated with the CArchive object. The terminating null character, 0, is not written to the file, nor is a newline character automatically written.


CXTMemFile::Append Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::Append Method

This member function appends a CFile derived object to the file (operator+=).

virtual bool Append(
    CFile* fApp
);
Parameters

fApp
A pointer to a valid CFile object.

Returns

true if successful, otherwise returns false.

Group

CXTMemFile Methods


CXTMemFile::Close Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::Close Method

This member function saves the contents of the memory to the disk and closes it.

virtual void Close();
Group

CXTMemFile Methods


CXTMemFile::Discard Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::Discard Method

This member function discards all changes to file since Open() or last Flush().

virtual bool Discard();
Returns

true if successful, otherwise returns false.

Group

CXTMemFile Methods


Duplicate Method

CXTMemFile Methods
Duplicate Method
Overload List
Methods
Method | Description
CXTMemFile::Duplicate (CFile*) | This member function will initialize the CXTMemFile object with the information specified in the 'fDuplicate' object.
CXTMemFile::Duplicate (LPCTSTR) | This member function will initialize the CXTMemFile object with the information specified in the 'fDuplicate' object.
Group

CXTMemFile Methods


CXTMemFile::Duplicate Method (CFile*)

Duplicate Method, CXTMemFile Class
CXTMemFile::Duplicate Method (CFile*)

This member function will initialize the CXTMemFile object with the information specified in the 'fDuplicate' object.

virtual bool Duplicate(
    CFile* fDuplicate
);
virtual bool Duplicate(
    LPCTSTR strDup
);
Parameters

fDuplicate
A pointer to a valid CFile object.
strDup
A NULL terminated string.

Returns

true if successful, otherwise returns false.

Group

Duplicate Method


Extract Method

CXTMemFile Methods
Extract Method
Overload List
Methods
Method | Description
CXTMemFile::Extract (CFile*, DWORD, DWORD) | This member function extracts bytes to a file and returns the length of the actual copied bytes.
CXTMemFile::Extract (LPCTSTR, DWORD, DWORD) | This member function extracts bytes to a file and returns the length of the actual copied bytes.
Group

CXTMemFile Methods


CXTMemFile::Extract Method (CFile*, DWORD, DWORD)

Extract Method, CXTMemFile Class
CXTMemFile::Extract Method (CFile*, DWORD, DWORD)

This member function extracts bytes to a file and returns the length of the actual copied bytes.

virtual DWORD Extract(
    CFile* fDest,
    DWORD dwStartPos,
    DWORD dwBytes
);
virtual DWORD Extract(
    LPCTSTR strDest,
    DWORD dwStartPos,
    DWORD dwBytes
);
Parameters

fDest
A pointer to a valid CFile object.
dwStartPos
Represents the starting position.
dwBytes
Number of bytes to extract.
strDest
Specifies a NULL terminated string that is the path to the desired file.

Returns

A DWORD value that represents the length of the copied bytes.

Group

Extract Method


CXTMemFile::FindData Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::FindData Method

This member function finds data in the file.

LONG FindData(
    void* pData,
    DWORD dwDataLen,
    LONG lStartPos
);
Parameters

pData
Pointer to the buffer to receive the data found.
dwDataLen
Size of the data to find.
lStartPos
Starting position.

Returns

A LONG data type.

Group

CXTMemFile Methods


CXTMemFile::Flush Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::Flush Method

This member function forces any data remaining in the file buffer to be written to the file. The use of Flush does not guarantee flushing of CArchive buffers. If you are using an archive, call CArchive::Flush first.

virtual void Flush();
Group

CXTMemFile Methods


CXTMemFile::Import Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::Import Method

This member function imports the data of a CFile derived object (operator=).

virtual bool Import(
    CFile* fImp
);
Parameters

fImp
A pointer to a valid CFile object.

Returns

true if successful, otherwise returns false.

Group

CXTMemFile Methods


Insert Method

CXTMemFile Methods
Insert Method
Overload List
Methods
Method | Description
CXTMemFile::Insert (CFile*, DWORD, DWORD, DWORD) | This member function inserts any File and returns the length of the actual copied bytes.
CXTMemFile::Insert (LPCTSTR, DWORD, DWORD, DWORD) | This member function inserts any File and returns the length of the actual copied bytes.
Group

CXTMemFile Methods


CXTMemFile::Insert Method (CFile*, DWORD, DWORD, DWORD)

Insert Method, CXTMemFile Class
CXTMemFile::Insert Method (CFile*, DWORD, DWORD, DWORD)

This member function inserts any File and returns the length of the actual copied bytes.

virtual DWORD Insert(
    CFile* fSrc,
    DWORD dwSourcePos,
    DWORD dwDestPos,
    DWORD dwBytes
);
virtual DWORD Insert(
    LPCTSTR strSrc,
    DWORD dwSourcePos,
    DWORD dwDestPos,
    DWORD dwBytes
);
Parameters

fSrc
A pointer to a valid CFile object.
dwSourcePos
Represents the source file position.
dwDestPos
Represents the destination file position.
dwBytes
Number of bytes to insert.
strSrc
Specifies a NULL terminated string that is the path to the desired file.

Returns

A DWORD value that represents the length of the copied bytes.

Group

Insert Method


CXTMemFile::Load Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::Load Method

This member function loads the file into memory.

virtual bool Load();
Returns

true if successful, otherwise returns false.

Group

CXTMemFile Methods


CXTMemFile::Open Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::Open Method

This member function opens and loads a physical File into memory.

virtual BOOL Open(
    LPCTSTR lpszFileName,
    UINT nOpenFlags,
    CFileException* pError = NULL
);
Parameters

lpszFileName
Specifies a NULL terminated string that is the path to the desired file.
nOpenFlags
Specifies a UINT that defines the sharing and access mode in the file. It specifies the action to take when opening the file. You can combine options by using the bitwise-OR (|) operator. One access permission and one share option are required. The modeCreate and modeNoInherit modes are optional. See the CFile constructor for a list of mode options.
pError
Specifies a pointer to an existing file-exception object that receives the status of a failed operation.

Returns

true if successful, or false if it fails.

Group

CXTMemFile Methods


CXTMemFile::ReadString Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::ReadString Method

This member function reads a string.

virtual BOOL ReadString(
    CString& rString
);
Parameters

rString
A CString reference to an object to receive the string that is read.

Returns

TRUE if successful, or FALSE if there is an error.

Group

CXTMemFile Methods


CXTMemFile::Save Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::Save Method

This member function saves the file to disk.

virtual bool Save();
Returns

true if successful, otherwise returns false.

Group

CXTMemFile Methods


CXTMemFile::WriteString Method

CXTMemFile Methods, CXTMemFile Class
CXTMemFile::WriteString Method

This method writes data from a buffer to the file associated with the CArchive object. The terminating null character, 0, is not written to the file, nor is a newline character automatically written.

virtual void WriteString(
    LPCTSTR lpsz
);
Parameters

lpsz
Specifies a pointer to a buffer containing a null-terminated text string.

Group

CXTMemFile Methods


CXTMemFile Constructors

CXTMemFile Class, Legend, Public Methods
CXTMemFile Constructors
Class

CXTMemFile Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMemFile |


CXTMemFile Constructor

CXTMemFile Constructors
CXTMemFile Constructor
Overload List
Constructors
Constructor | Description
CXTMemFile::CXTMemFile (BYTE*, UINT, UINT) | Constructs a CXTMemFile object. This overload opens an empty memory file. Note that the file is opened by the constructor and that you should not call CFile::Open.
CXTMemFile::CXTMemFile (LPCTSTR, UINT) | Constructs a CXTMemFile object. This overload opens an empty memory file. Note that the file is opened by the constructor and that you should not call CFile::Open.
CXTMemFile::CXTMemFile (UINT) | Constructs a CXTMemFile object. This overload opens an empty memory file. Note that the file is opened by the constructor and that you should not call CFile::Open.
Group

CXTMemFile Constructors


CXTMemFile::CXTMemFile Constructor (UINT)

CXTMemFile Constructor, CXTMemFile Class
CXTMemFile::CXTMemFile Constructor (UINT)

Constructs a CXTMemFile object. This overload opens an empty memory file. Note that the file is opened by the constructor and that you should not call CFile::Open.

CXTMemFile(
    UINT nGrowBytes = 1024
);
CXTMemFile(
    BYTE* lpBuffer,
    UINT nBufferSize,
    UINT nGrowBytes = 0
);
CXTMemFile(
    LPCTSTR lpszFileName,
    UINT uiOpenFlags
);
Parameters

nGrowBytes
The memory allocation increment in bytes. The memory allocation increment in bytes.
lpBuffer
Pointer to the buffer to be attached to CXTMemFile.
nBufferSize
An integer that specifies the size of the buffer in bytes.
lpszFileName
A string that is the path to the desired file. The path can be relative, absolute, or a network name (UNC).
uiOpenFlags
A UINT that defines the file's sharing and access mode. It specifies the action to take when opening the file. You can combine options by using the bitwise-OR (|) operator. One access permission and one share option are required. The modeCreate and modeNoInherit modes are optional. See the CFile constructor for a list of mode options.

Group

CXTMemFile Constructor


CXTMemFile Destructors

CXTMemFile Class, Legend, Public Methods
CXTMemFile Destructors
Class

CXTMemFile Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTMemFile | Destroys a CXTMemFile object, handles cleanup and deallocation


CXTMemFile::~CXTMemFile Destructor

CXTMemFile Destructors, CXTMemFile Class
CXTMemFile::~CXTMemFile Destructor

Destroys a CXTMemFile object, handles cleanup and deallocation

virtual ~CXTMemFile();
Group

CXTMemFile Destructors


CXTMemFile Operators

CXTMemFile Class, Legend, Public Operators
CXTMemFile Operators
Class

CXTMemFile Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
[] | This member operator will perform indexing operations for the CXTMemFile object. Returns a BYTE data type.
+= |
= |


CXTMemFile::[] Operator

CXTMemFile Operators, CXTMemFile Class
CXTMemFile::[] Operator

This member operator will perform indexing operations for the CXTMemFile object. Returns a BYTE data type.

BYTE operator [](
    DWORD dwFilePos
);
Parameters

dwFilePos
DWORD value that specifies file position.

Group

CXTMemFile Operators


+= Operator

CXTMemFile Operators
+= Operator
Overload List
Operators
Operator | Description
CXTMemFile::+= (CFile*) | This member operator will append the CXTMemFile object with the object specified by 'fApp'.
CXTMemFile::+= (CString) | This member operator will append the CXTMemFile object with the object specified by 'strApp'.
Group

CXTMemFile Operators


CXTMemFile::+= Operator (CFile*)

+= Operator, CXTMemFile Class
CXTMemFile::+= Operator (CFile*)

This member operator will append the CXTMemFile object with the object specified by 'fApp'.

void operator +=(
    CFile* fApp
);
Parameters

fApp
A pointer to a valid CFile object.

Group

+= Operator


CXTMemFile::+= Operator (CString)

+= Operator, CXTMemFile Class
CXTMemFile::+= Operator (CString)

This member operator will append the CXTMemFile object with the object specified by 'strApp'.

void operator +=(
    CString strApp
);
Parameters

strApp
Specifies a NULL terminated string that is the path to the desired file.

Group

+= Operator


= Operator

CXTMemFile Operators
= Operator
Overload List
Operators
Operator | Description
CXTMemFile::= (CFile*) | This member operator will initialize the CXTMemFile object with the object specified by 'fDup'.
CXTMemFile::= (CString) | This member operator will initialize the CXTMemFile object with the object specified by 'strDup'.
CXTMemFile::= (DWORD) | This member operator will adjust the file position.
Group

CXTMemFile Operators


CXTMemFile::= Operator (CFile*)

= Operator, CXTMemFile Class
CXTMemFile::= Operator (CFile*)

This member operator will initialize the CXTMemFile object with the object specified by 'fDup'.

void operator =(
    CFile* fDup
);
Parameters

fDup
A pointer to a valid CFile object.

Group

= Operator


CXTMemFile::= Operator (CString)

= Operator, CXTMemFile Class
CXTMemFile::= Operator (CString)

This member operator will initialize the CXTMemFile object with the object specified by 'strDup'.

void operator =(
    CString strDup
);
Parameters

strDup
Specifies a NULL terminated string that is the path to the desired file.

Group

= Operator


CXTMemFile::= Operator (DWORD)

= Operator, CXTMemFile Class
CXTMemFile::= Operator (DWORD)

This member operator will adjust the file position.

void operator =(
    DWORD dwFilePos
);
Parameters

dwFilePos
DWORD value that specifies file position.

Group

= Operator


CXTMenuListBox Class

XTMenuListBox.h, Classes, Legend, Members, Topics, CXTMenuListBox Structures, CXTMenuListBox Data Members, CXTMenuListBox Methods, CXTMenuListBox Constructors, CXTMenuListBox Destructors, CXTMenuListBox Nested Types, CXTMenuListBox Constructors, CXTMenuListBox Data Members, CXTMenuListBox Destructors, CXTMenuListBox Methods, CXTMenuListBox Nested Types, CXTMenuListBox Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBox Class

CCXTMenuListBox is a CListBox derived class. It is used to implement an Outlook bar style control. It can only be used with the LBS_OWNERDRAWVARIABLE style bit set. This is a simpler version of CXTOutBarCtrl and does not allow for shortcut folders.

Class Hierarchy

class CXTMenuListBox : public CListBox;
File

XTMenuListBox.h

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTMenuListBox Constructors
CXTMenuListBox Constructors | Description
CXTMenuListBox | Constructs a CXTMenuListBox object
CXTMenuListBox Data Members
CXTMenuListBox Data Members | Description
m_arContentItems | Array of CONTENT_ITEM structs that represent each item in the Outlook bar.
m_bHilight | true when the menu item is selected.
m_bHilightItemID | Index of the currently highlighted item, set to -1 if no selection.
m_bNoBorder | true to disable a border drawn around highlighted items.
m_bNoUnderline | true if the text is not drawn with a underline when no highlight border is displayed.
m_bTimerActive | true if the redraw timer is active.
m_hCursor | Cursor display when item is hovered.
m_nPrevIndex | Previously selected menu index.
m_point | Holds the cursor position.
CXTMenuListBox Destructors
CXTMenuListBox Destructors | Description
~CXTMenuListBox | Destroys a CXTMenuListBox object, handles cleanup and deallocation
CXTMenuListBox Methods
CXTMenuListBox Methods | Description
AddMenuItem | Call this member function to add a menu item to an Outlook bar. If the Outlook bar was not created with the LBS_SORT style, the menu item is added to the end of the Outlook bar. Otherwise, the menu item is inserted into the Outlook bar, and the Outlook bar is sorted. If the Outlook bar was created with the LBS_SORT style but not the LBS_HASSTRINGS style, the framework sorts the Outlook bar by one or more calls to the CompareItem member function. Use InsertMenuItem to insert a menu item into a specific location within the Outlook bar.
Create | This member function creates an Outlook Bar control.
EnableMenuItem | Call this member function to enable or disable the menu item specified by iItem.
GetMenuItem | Call this member function to return an CONTENT_ITEM object that represents the menu item specified by 'iItem'.
GetTextHeight | This member function is called by the outlook bar to determine the string height for a multi-line text item.
InsertMenuItem | This member function inserts a menu item into the Outlook bar. Unlike the AddMenuItem member function, InsertMenuItem does not cause an Outlook bar with the LBS_SORT style to be sorted.
SetColors | Call this member function to set the text and background colors for the Outlook bar.
SetHilightCursor | Call this member function to set the cursor, text and border attributes for a highlighted item.
CXTMenuListBox Nested Types
CXTMenuListBox Nested Types | Description
CContentItemList | List for maintaining CONTENT_ITEM structures.
CXTMenuListBox Structures
CXTMenuListBox Structures | Description
CONTENT_ITEM | CONTENT_ITEM structure is used by the CXTMenuListBox class to maintain information about a particular menu item.


CXTMenuListBox Structures

CXTMenuListBox Class, Legend, Structures
CXTMenuListBox Structures
Class

CXTMenuListBox Class

Legend
Structure
Structures
Structure | Description
CONTENT_ITEM | CONTENT_ITEM structure is used by the CXTMenuListBox class to maintain information about a particular menu item.


CXTMenuListBox::CONTENT_ITEM Structure

XTMenuListBox.h, CXTMenuListBox Structures, See Also
CXTMenuListBox::CONTENT_ITEM Structure

CONTENT_ITEM structure is used by the CXTMenuListBox class to maintain information about a particular menu item.

struct CONTENT_ITEM {
  int m_nIndex;
  BOOL m_bEnabled;
  CString m_strText;
  CXTPImageManagerIcon* m_pIcon;
};
File

XTMenuListBox.h

Members

m_nIndex
Zero-based index for the menu item.
m_bEnabled
TRUE if the menu item is enabled.
m_strText
Text label for the menu item.
m_pIcon
Icon handle for the menu item.

See Also

CXTMenuListBox

Group

CXTMenuListBox Structures


CXTMenuListBox Data Members

CXTMenuListBox Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBox Data Members
Class

CXTMenuListBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arContentItems | Array of CONTENT_ITEM structs that represent each item in the Outlook bar.
m_bHilight | true when the menu item is selected.
m_bHilightItemID | Index of the currently highlighted item, set to -1 if no selection.
m_bTimerActive | true if the redraw timer is active.
m_hCursor | Cursor display when item is hovered.
m_nPrevIndex | Previously selected menu index.
m_point | Holds the cursor position.
Public Data Members
Public Data Member | Description
m_bNoBorder | true to disable a border drawn around highlighted items.
m_bNoUnderline | true if the text is not drawn with a underline when no highlight border is displayed.


CXTMenuListBox::m_arContentItems Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_arContentItems Data Member

Array of CONTENT_ITEM structs that represent each item in the Outlook bar.

CContentItemList m_arContentItems;
Group

CXTMenuListBox Data Members


CXTMenuListBox::m_bHilight Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_bHilight Data Member

true when the menu item is selected.

bool m_bHilight;
Group

CXTMenuListBox Data Members


CXTMenuListBox::m_bHilightItemID Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_bHilightItemID Data Member

Index of the currently highlighted item, set to -1 if no selection.

int m_bHilightItemID;
Group

CXTMenuListBox Data Members


CXTMenuListBox::m_bNoBorder Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_bNoBorder Data Member

true to disable a border drawn around highlighted items.

bool m_bNoBorder;
Group

CXTMenuListBox Data Members


CXTMenuListBox::m_bNoUnderline Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_bNoUnderline Data Member

true if the text is not drawn with a underline when no highlight border is displayed.

bool m_bNoUnderline;
Group

CXTMenuListBox Data Members


CXTMenuListBox::m_bTimerActive Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_bTimerActive Data Member

true if the redraw timer is active.

bool m_bTimerActive;
Group

CXTMenuListBox Data Members


CXTMenuListBox::m_hCursor Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_hCursor Data Member

Cursor display when item is hovered.

HCURSOR m_hCursor;
Group

CXTMenuListBox Data Members


CXTMenuListBox::m_nPrevIndex Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_nPrevIndex Data Member

Previously selected menu index.

int m_nPrevIndex;
Group

CXTMenuListBox Data Members


CXTMenuListBox::m_point Data Member

CXTMenuListBox Data Members, CXTMenuListBox Class
CXTMenuListBox::m_point Data Member

Holds the cursor position.

CPoint m_point;
Group

CXTMenuListBox Data Members


CXTMenuListBox Methods

CXTMenuListBox Class, Legend, Public Methods
CXTMenuListBox Methods
Class

CXTMenuListBox Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AddMenuItem | Call this member function to add a menu item to an Outlook bar. If the Outlook bar was not created with the LBS_SORT style, the menu item is added to the end of the Outlook bar. Otherwise, the menu item is inserted into the Outlook bar, and the Outlook bar is sorted. If the Outlook bar was created with the LBS_SORT style but not the LBS_HASSTRINGS style, the framework sorts the Outlook bar by one or more calls to the CompareItem member function. Use InsertMenuItem to insert a menu item into a specific location within the Outlook bar.
Create | This member function creates an Outlook Bar control.
EnableMenuItem | Call this member function to enable or disable the menu item specified by iItem.
GetMenuItem | Call this member function to return an CONTENT_ITEM object that represents the menu item specified by 'iItem'.
GetTextHeight | This member function is called by the outlook bar to determine the string height for a multi-line text item.
InsertMenuItem | This member function inserts a menu item into the Outlook bar. Unlike the AddMenuItem member function, InsertMenuItem does not cause an Outlook bar with the LBS_SORT style to be sorted.
SetColors | Call this member function to set the text and background colors for the Outlook bar.
SetHilightCursor | Call this member function to set the cursor, text and border attributes for a highlighted item.


CXTMenuListBox::AddMenuItem Method

CXTMenuListBox Methods, CXTMenuListBox Class
CXTMenuListBox::AddMenuItem Method

Call this member function to add a menu item to an Outlook bar. If the Outlook bar was not created with the LBS_SORT style, the menu item is added to the end of the Outlook bar. Otherwise, the menu item is inserted into the Outlook bar, and the Outlook bar is sorted. If the Outlook bar was created with the LBS_SORT style but not the LBS_HASSTRINGS style, the framework sorts the Outlook bar by one or more calls to the CompareItem member function. Use InsertMenuItem to insert a menu item into a specific location within the Outlook bar.

int AddMenuItem(
    UINT nIconID,
    LPCTSTR lpszText,
    BOOL bEnabled = TRUE
);
Parameters

nIconID
Resource ID of the icon associated with this menu item.
lpszText
Points to the null-terminated string for the menu item.
bEnabled
TRUE if the menu item is enabled.

Returns

The zero-based index to the menu item in the Outlook bar. The return value is LB_ERR if an error occurs. The return value is LB_ERRSPACE if insufficient space is available to store the new menu item.

Group

CXTMenuListBox Methods


CXTMenuListBox::Create Method

CXTMenuListBox Methods, CXTMenuListBox Class
CXTMenuListBox::Create Method

This member function creates an Outlook Bar control.

virtual BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Window style.
rect
The size and position of the window, in client coordinates of 'pParentWnd'.
pParentWnd
The parent window.
nID
The ID of the child window.

Returns

Nonzero if successful, otherwise returns zero.

Group

CXTMenuListBox Methods


CXTMenuListBox::EnableMenuItem Method

CXTMenuListBox Methods, CXTMenuListBox Class
CXTMenuListBox::EnableMenuItem Method

Call this member function to enable or disable the menu item specified by iItem.

BOOL EnableMenuItem(
    int iItem,
    BOOL bEnabled
);
Parameters

iItem
Index of the menu item to enable or disable.
bEnabled
TRUE to enable the menu item, FALSE to disable.

Returns

Returns TRUE if the menu item's enabled state was successfully updated, otherwise FALSE.

Group

CXTMenuListBox Methods


CXTMenuListBox::GetMenuItem Method

CXTMenuListBox Methods, CXTMenuListBox Class
CXTMenuListBox::GetMenuItem Method

Call this member function to return an CONTENT_ITEM object that represents the menu item specified by 'iItem'.

CONTENT_ITEM* GetMenuItem(
    int iItem
);
Parameters

iItem
Specifies the zero-based index of the menu item to retrieve.

Returns

An CONTENT_ITEM pointer.

Group

CXTMenuListBox Methods


CXTMenuListBox::GetTextHeight Method

CXTMenuListBox Methods, CXTMenuListBox Class
CXTMenuListBox::GetTextHeight Method

This member function is called by the outlook bar to determine the string height for a multi-line text item.

int GetTextHeight(
    LPCTSTR lspzItem
) const;
Parameters

lspzItem
NULL terminated string.

Returns

The height in pixels of the specified string.

Group

CXTMenuListBox Methods


CXTMenuListBox::InsertMenuItem Method

CXTMenuListBox Methods, CXTMenuListBox Class
CXTMenuListBox::InsertMenuItem Method

This member function inserts a menu item into the Outlook bar. Unlike the AddMenuItem member function, InsertMenuItem does not cause an Outlook bar with the LBS_SORT style to be sorted.

int InsertMenuItem(
    int iIndex,
    UINT nIconID,
    LPCTSTR lpszText,
    BOOL bEnabled = TRUE
);
Parameters

iIndex
Specifies the zero-based index of the position to insert the menu item. If this parameter is -1, the menu item is added to the end of the list.
nIconID
Resource ID of the icon associated with this menu item.
lpszText
Points to the null-terminated string for the menu item
bEnabled
TRUE if the menu item is enabled.

Returns

The zero-based index of the position at which the menu item was inserted. The return value is LB_ERR if an error occurs. The return value is LB_ERRSPACE if insufficient space is available to store the new menu item.

Group

CXTMenuListBox Methods


CXTMenuListBox::SetColors Method

CXTMenuListBox Methods, CXTMenuListBox Class
CXTMenuListBox::SetColors Method

Call this member function to set the text and background colors for the Outlook bar.

void SetColors(
    COLORREF clrText,
    COLORREF clrBack,
    COLORREF clrBackDark = COLORREF_NULL
);
Parameters

clrText
RGB value representing the text color.
clrBack
RGB value representing the background color.
clrBackDark
RGB value representing the dark background color. If defined the background will be drawn with a gradient effect from crBack to crBackDark.

Group

CXTMenuListBox Methods


CXTMenuListBox::SetHilightCursor Method

CXTMenuListBox Methods, CXTMenuListBox Class
CXTMenuListBox::SetHilightCursor Method

Call this member function to set the cursor, text and border attributes for a highlighted item.

void SetHilightCursor(
    UINT nIDCursor,
    bool bNoBorder = false,
    bool bNoUnderline = false
);
Parameters

nIDCursor
Resource id of the highlight cursor.
bNoBorder
True if not border is displayed when item is highlighted.
bNoUnderline
True if text is not underlined when item is highlighted.

Group

CXTMenuListBox Methods


CXTMenuListBox Constructors

CXTMenuListBox Class, Legend, Public Methods
CXTMenuListBox Constructors
Class

CXTMenuListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMenuListBox | Constructs a CXTMenuListBox object


CXTMenuListBox::CXTMenuListBox Constructor

CXTMenuListBox Constructors, CXTMenuListBox Class
CXTMenuListBox::CXTMenuListBox Constructor

Constructs a CXTMenuListBox object

CXTMenuListBox();
Group

CXTMenuListBox Constructors


CXTMenuListBox Destructors

CXTMenuListBox Class, Legend, Public Methods
CXTMenuListBox Destructors
Class

CXTMenuListBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTMenuListBox | Destroys a CXTMenuListBox object, handles cleanup and deallocation


CXTMenuListBox::~CXTMenuListBox Destructor

CXTMenuListBox Destructors, CXTMenuListBox Class
CXTMenuListBox::~CXTMenuListBox Destructor

Destroys a CXTMenuListBox object, handles cleanup and deallocation

virtual ~CXTMenuListBox();
Group

CXTMenuListBox Destructors


CXTMenuListBox Nested Types

CXTMenuListBox Class, Public Nested Types
CXTMenuListBox Nested Types
Class

CXTMenuListBox Class

Public Nested Types
Public Nested Type | Description
CContentItemList | List for maintaining CONTENT_ITEM structures.


CXTMenuListBox::CContentItemList Nested Type

CXTMenuListBox Nested Types, CXTMenuListBox Class, See Also
CXTMenuListBox::CContentItemList Nested Type

List for maintaining CONTENT_ITEM structures.

typedef CList<CONTENT_ITEM*, CONTENT_ITEM*> CContentItemList;
Remarks

CList definition used by the CXTMenuListBox class to maintain a list of CONTENT_ITEM structures representing each menu item defined for the menu list box control.

See Also

CXTMenuListBox, CXTMenuListBox::InsertMenuItem, CONTENT_ITEM

Group

CXTMenuListBox Nested Types


CXTMenuListBoxTheme Class

XTMenuListBoxTheme.h, Classes, Legend, Members, Topics, CXTMenuListBoxTheme Data Members, CXTMenuListBoxTheme Methods, CXTMenuListBoxTheme Constructors, CXTMenuListBoxTheme Destructors, CXTMenuListBoxTheme Constructors, CXTMenuListBoxTheme Data Members, CXTMenuListBoxTheme Destructors, CXTMenuListBoxTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBoxTheme Class

CXTMenuListBoxTheme is used to draw the CXTMenuListBox object. All themes used for CXTButton should inherit from this base class.

Class Hierarchy

class CXTMenuListBoxTheme : public CXTThemeManagerStyle;
File

XTMenuListBoxTheme.h

Notes

A Menu List box is similar in appearance to an outlook bar.

Group

Classes

Legend
Data Member
Method
virtual
CXTMenuListBoxTheme Constructors
CXTMenuListBoxTheme Constructors | Description
CXTMenuListBoxTheme | Constructs a CXTMenuListBoxTheme object.
CXTMenuListBoxTheme Data Members
CXTMenuListBoxTheme Data Members | Description
m_cxIcon | Width of the menu icon.
m_cyEdge | Height in pixels of the space between the icon an text.
m_cyIcon | Height of the menu icon.
CXTMenuListBoxTheme Destructors
CXTMenuListBoxTheme Destructors | Description
~CXTMenuListBoxTheme | Destroys a CXTMenuListBoxTheme object, handles cleanup and deallocation.
CXTMenuListBoxTheme Methods
CXTMenuListBoxTheme Methods | Description
DrawItem | Call this function to draw an item in the menu list box.
GetBackColor | Call this function to get the background color of the menu list box.
GetTextColor | Call this function to get the color of the text used in the menu list box.
RefreshMetrics | Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.


CXTMenuListBoxTheme Data Members

CXTMenuListBoxTheme Class, Legend, Public Data Members
CXTMenuListBoxTheme Data Members
Class

CXTMenuListBoxTheme Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_cxIcon | Width of the menu icon.
m_cyEdge | Height in pixels of the space between the icon an text.
m_cyIcon | Height of the menu icon.


CXTMenuListBoxTheme::m_cxIcon Data Member

CXTMenuListBoxTheme Data Members, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::m_cxIcon Data Member

Width of the menu icon.

int m_cxIcon;
Group

CXTMenuListBoxTheme Data Members


CXTMenuListBoxTheme::m_cyEdge Data Member

CXTMenuListBoxTheme Data Members, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::m_cyEdge Data Member

Height in pixels of the space between the icon an text.

int m_cyEdge;
Group

CXTMenuListBoxTheme Data Members


CXTMenuListBoxTheme::m_cyIcon Data Member

CXTMenuListBoxTheme Data Members, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::m_cyIcon Data Member

Height of the menu icon.

int m_cyIcon;
Group

CXTMenuListBoxTheme Data Members


CXTMenuListBoxTheme Methods

CXTMenuListBoxTheme Class, Legend, Public Methods
CXTMenuListBoxTheme Methods
Class

CXTMenuListBoxTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawItem | Call this function to draw an item in the menu list box.
GetBackColor | Call this function to get the background color of the menu list box.
GetTextColor | Call this function to get the color of the text used in the menu list box.
RefreshMetrics | Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.


CXTMenuListBoxTheme::DrawItem Method

CXTMenuListBoxTheme Methods, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::DrawItem Method

Call this function to draw an item in the menu list box.

virtual void DrawItem(
    CXTMenuListBox* pMenuListBox,
    LPDRAWITEMSTRUCT lpDIS
);
Parameters

pMenuListBox
A pointer to a CXTMenuListBox object.
lpDIS
A LPDRAWITEMSTRUCT struct that contains information about how the list box should be drawn.

Group

CXTMenuListBoxTheme Methods


CXTMenuListBoxTheme::GetBackColor Method

CXTMenuListBoxTheme Methods, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::GetBackColor Method

Call this function to get the background color of the menu list box.

COLORREF GetBackColor();
Returns

A COLORREF value corresponding to the background color.

Group

CXTMenuListBoxTheme Methods


CXTMenuListBoxTheme::GetTextColor Method

CXTMenuListBoxTheme Methods, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::GetTextColor Method

Call this function to get the color of the text used in the menu list box.

COLORREF GetTextColor();
Returns

A COLORREF value corresponding to the text color.

Group

CXTMenuListBoxTheme Methods


CXTMenuListBoxTheme::RefreshMetrics Method

CXTMenuListBoxTheme Methods, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::RefreshMetrics Method

Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.

virtual void RefreshMetrics();
Group

CXTMenuListBoxTheme Methods


CXTMenuListBoxTheme Constructors

CXTMenuListBoxTheme Class, Legend, Public Methods
CXTMenuListBoxTheme Constructors
Class

CXTMenuListBoxTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMenuListBoxTheme | Constructs a CXTMenuListBoxTheme object.


CXTMenuListBoxTheme::CXTMenuListBoxTheme Constructor

CXTMenuListBoxTheme Constructors, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::CXTMenuListBoxTheme Constructor

Constructs a CXTMenuListBoxTheme object.

CXTMenuListBoxTheme();
Group

CXTMenuListBoxTheme Constructors


CXTMenuListBoxTheme Destructors

CXTMenuListBoxTheme Class, Legend, Public Methods
CXTMenuListBoxTheme Destructors
Class

CXTMenuListBoxTheme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTMenuListBoxTheme | Destroys a CXTMenuListBoxTheme object, handles cleanup and deallocation.


CXTMenuListBoxTheme::~CXTMenuListBoxTheme Destructor

CXTMenuListBoxTheme Destructors, CXTMenuListBoxTheme Class
CXTMenuListBoxTheme::~CXTMenuListBoxTheme Destructor

Destroys a CXTMenuListBoxTheme object, handles cleanup and deallocation.

virtual ~CXTMenuListBoxTheme();
Group

CXTMenuListBoxTheme Destructors


CXTMenuListBoxThemeOffice2003 Class

XTMenuListBoxTheme.h, Classes, Legend, Members, Topics, CXTMenuListBoxThemeOffice2003 Methods, CXTMenuListBoxThemeOffice2003 Constructors, CXTMenuListBoxThemeOffice2003 Constructors, CXTMenuListBoxThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBoxThemeOffice2003 Class

Class CXTMenuListBoxThemeOffice2003 is derived from CXTMenuListBoxThemeXP. This class is used to implement the Office 2003 theme for Menu List Boxes.

Class Hierarchy

class CXTMenuListBoxThemeOffice2003 : public CXTMenuListBoxThemeOfficeXP;
File

XTMenuListBoxTheme.h

Group

Classes

Legend
Method
CXTMenuListBoxThemeOffice2003 Constructors
CXTMenuListBoxThemeOffice2003 Constructors | Description
CXTMenuListBoxThemeOffice2003 | Constructs a CXTMenuListBoxThemeOffice2003 object.
CXTMenuListBoxThemeOffice2003 Methods
CXTMenuListBoxThemeOffice2003 Methods | Description
RefreshMetrics | Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.


CXTMenuListBoxThemeOffice2003 Methods

CXTMenuListBoxThemeOffice2003 Class, Legend, Public Methods
CXTMenuListBoxThemeOffice2003 Methods
Class

CXTMenuListBoxThemeOffice2003 Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.


CXTMenuListBoxThemeOffice2003::RefreshMetrics Method

CXTMenuListBoxThemeOffice2003 Methods, CXTMenuListBoxThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBoxThemeOffice2003::RefreshMetrics Method

Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.

void RefreshMetrics();
Group

CXTMenuListBoxThemeOffice2003 Methods


CXTMenuListBoxThemeOffice2003 Constructors

CXTMenuListBoxThemeOffice2003 Class, Legend, Public Methods
CXTMenuListBoxThemeOffice2003 Constructors
Class

CXTMenuListBoxThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMenuListBoxThemeOffice2003 | Constructs a CXTMenuListBoxThemeOffice2003 object.


CXTMenuListBoxThemeOffice2003::CXTMenuListBoxThemeOffice2003 Constructor

CXTMenuListBoxThemeOffice2003 Constructors, CXTMenuListBoxThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBoxThemeOffice2003::CXTMenuListBoxThemeOffice2003 Constructor

Constructs a CXTMenuListBoxThemeOffice2003 object.

CXTMenuListBoxThemeOffice2003();
Group

CXTMenuListBoxThemeOffice2003 Constructors


CXTMenuListBoxThemeOfficeXP Class

XTMenuListBoxTheme.h, Classes, Legend, Members, Topics, CXTMenuListBoxThemeOfficeXP Methods, CXTMenuListBoxThemeOfficeXP Constructors, CXTMenuListBoxThemeOfficeXP Constructors, CXTMenuListBoxThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBoxThemeOfficeXP Class

Class CXTMenuListBoxThemeOfficeXP is derived from CXTMenuListBoxTheme. This class is used to implement the Office XP theme for Menu List Boxes.

Class Hierarchy

class CXTMenuListBoxThemeOfficeXP : public CXTMenuListBoxTheme;
File

XTMenuListBoxTheme.h

Group

Classes

Legend
Method
CXTMenuListBoxThemeOfficeXP Constructors
CXTMenuListBoxThemeOfficeXP Constructors | Description
CXTMenuListBoxThemeOfficeXP | Constructs a CXTMenuListBoxThemeOfficeXP object.
CXTMenuListBoxThemeOfficeXP Methods
CXTMenuListBoxThemeOfficeXP Methods | Description
RefreshMetrics | Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.


CXTMenuListBoxThemeOfficeXP Methods

CXTMenuListBoxThemeOfficeXP Class, Legend, Public Methods
CXTMenuListBoxThemeOfficeXP Methods
Class

CXTMenuListBoxThemeOfficeXP Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.


CXTMenuListBoxThemeOfficeXP::RefreshMetrics Method

CXTMenuListBoxThemeOfficeXP Methods, CXTMenuListBoxThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBoxThemeOfficeXP::RefreshMetrics Method

Call this function to refresh the colors for the list box control. Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, the function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.

void RefreshMetrics();
Group

CXTMenuListBoxThemeOfficeXP Methods


CXTMenuListBoxThemeOfficeXP Constructors

CXTMenuListBoxThemeOfficeXP Class, Legend, Public Methods
CXTMenuListBoxThemeOfficeXP Constructors
Class

CXTMenuListBoxThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMenuListBoxThemeOfficeXP | Constructs a CXTMenuListBoxThemeOfficeXP object.


CXTMenuListBoxThemeOfficeXP::CXTMenuListBoxThemeOfficeXP Constructor

CXTMenuListBoxThemeOfficeXP Constructors, CXTMenuListBoxThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMenuListBoxThemeOfficeXP::CXTMenuListBoxThemeOfficeXP Constructor

Constructs a CXTMenuListBoxThemeOfficeXP object.

CXTMenuListBoxThemeOfficeXP();
Group

CXTMenuListBoxThemeOfficeXP Constructors


CXTMonthCalCtrl Class

XTDateTimeCtrl.h, Classes, Legend, Members, Topics, CXTMonthCalCtrl Methods, CXTMonthCalCtrl Constructors, CXTMonthCalCtrl Destructors, CXTMonthCalCtrl Constructors, CXTMonthCalCtrl Destructors, CXTMonthCalCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMonthCalCtrl Class

CXTMonthCalCtrl is a CWnd derived class. A CXTMonthCalCtrl object encapsulates the functionality of a month calendar control.

Class Hierarchy

class CXTMonthCalCtrl : public CWnd;
File

XTDateTimeCtrl.h

Remarks

The month calendar control provides the user with a simple calendar interface that the user can select a date from. The user can change the display by:

  • Scrolling backward and forward, from month to month.
  • Clicking the Today text to display the current day (if the MCS_NOTODAY

style is not used).

  • Picking a month or a year from a popup menu.

You can customize the month calendar control by applying a variety of styles to the object when you create it. These styles are described in Month Calendar Control Styles in the Platform SDK.

The month calendar control can display more than one month, and it can indicate special days, such as holidays, by bolding the date.

For more information on using the month calendar control, see Using CXTMonthCalCtrl in the Xtreme Toolkit online help.

Group

Classes

Legend
Method
virtual
CXTMonthCalCtrl Constructors
CXTMonthCalCtrl Constructors | Description
CXTMonthCalCtrl | Constructs a CXTMonthCalCtrl object
CXTMonthCalCtrl Destructors
CXTMonthCalCtrl Destructors | Description
~CXTMonthCalCtrl | Destroys a CXTMonthCalCtrl object, handles cleanup and deallocation
CXTMonthCalCtrl Methods
CXTMonthCalCtrl Methods | Description
Create |
GetColor | This member function gets the color of a specified area of a month calendar control.
GetCurSel |
GetFirstDayOfWeek | This member function gets the first day of the week to be displayed in the leftmost column of the calendar.
GetMaxSelCount | This member function retrieves the current maximum number of days that can be selected in a month calendar control.
GetMinReqRect | This member function retrieves the minimum size required to show a full month in a month calendar control.
GetMonthDelta | This member function retrieves the scroll rate for a month calendar control. The scroll rate is the number of months that the control moves its display when the user clicks a scroll button once.
GetMonthRange |
GetRange |
GetSelRange |
GetToday |
HitTest | This member function determines which portion of a month calendar control is at a given point on the screen.
SetColor | This member function sets the color of a specified area of a month calendar control.
SetCurSel |
SetDayState | This member function sets the display for days in a month calendar control.
SetFirstDayOfWeek | This member function sets the day of the week to be displayed in the leftmost column of the calendar.
SetMaxSelCount | This member function sets the maximum number of days that can be selected in a month calendar control.
SetMonthDelta | This member function sets the scroll rate for a month calendar control.
SetRange |
SetSelRange |
SetToday |
SizeMinReq | This member function repaints the month calendar control to its minimum, one-month size.


CXTMonthCalCtrl Methods

CXTMonthCalCtrl Class, Legend, Public Methods
CXTMonthCalCtrl Methods
Class

CXTMonthCalCtrl Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Create |
GetColor | This member function gets the color of a specified area of a month calendar control.
GetCurSel |
GetFirstDayOfWeek | This member function gets the first day of the week to be displayed in the leftmost column of the calendar.
GetMaxSelCount | This member function retrieves the current maximum number of days that can be selected in a month calendar control.
GetMinReqRect | This member function retrieves the minimum size required to show a full month in a month calendar control.
GetMonthDelta | This member function retrieves the scroll rate for a month calendar control. The scroll rate is the number of months that the control moves its display when the user clicks a scroll button once.
GetMonthRange |
GetRange |
GetSelRange |
GetToday |
HitTest | This member function determines which portion of a month calendar control is at a given point on the screen.
SetColor | This member function sets the color of a specified area of a month calendar control.
SetCurSel |
SetDayState | This member function sets the display for days in a month calendar control.
SetFirstDayOfWeek | This member function sets the day of the week to be displayed in the leftmost column of the calendar.
SetMaxSelCount | This member function sets the maximum number of days that can be selected in a month calendar control.
SetMonthDelta | This member function sets the scroll rate for a month calendar control.
SetRange |
SetSelRange |
SetToday |
SizeMinReq | This member function repaints the month calendar control to its minimum, one-month size.


Create Method

CXTMonthCalCtrl Methods
Create Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::Create (DWORD, const POINT&, CWnd*, UINT) | This member function creates a month calendar control and attaches it to the DDX_XTMonthCalCtrl object.
CXTMonthCalCtrl::Create (DWORD, const RECT&, CWnd*, UINT) | This member function creates a month calendar control and attaches it to the DDX_XTMonthCalCtrl object.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::Create Method (DWORD, const RECT&, CWnd*, UINT)

Create Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::Create Method (DWORD, const RECT&, CWnd*, UINT)

This member function creates a month calendar control and attaches it to the DDX_XTMonthCalCtrl object.

BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
BOOL Create(
    DWORD dwStyle,
    const POINT& pt,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Specifies the combination of Windows styles applied to the month calendar control. See Month Calendar Control Styles in the Platform SDK for more information about the styles.
rect
A reference to a RECT structure. Contains the position and size of the month calendar control.
pParentWnd
A pointer to a CWnd object that is the parent window of the month calendar control. It must not be NULL.
nID
Specifies the control ID of the month calendar control.
pt
A reference to a POINT structure that identifies the location of the month calendar control.

Returns

Nonzero if initialization was successful, otherwise returns zero.

Group

Create Method


CXTMonthCalCtrl::GetColor Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class, Body Source
CXTMonthCalCtrl::GetColor Method

This member function gets the color of a specified area of a month calendar control.

COLORREF GetColor(
    int nRegion
) const;
Parameters

nRegion
The region of the month calendar control from which the color is retrieved. For a list of values, see the 'nRegion' parameter of SetColor.

Returns

A COLORREF value specifying the color associated with the portion of the month calendar control, if successful. Otherwise, this member function returns -1.

Body Source
COLORREF CXTMonthCalCtrl::GetColor(int nRegion) const {
    ASSERT(::IsWindow(m_hWnd)); return (COLORREF) ::SendMessage(m_hWnd, MCM_GETCOLOR, (WPARAM) nRegion, 0);
}
Group

CXTMonthCalCtrl Methods


GetCurSel Method

CXTMonthCalCtrl Methods
GetCurSel Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::GetCurSel (COleDateTime&) | This member function retrieves the system time as indicated by the currently selected date.
CXTMonthCalCtrl::GetCurSel (CTime&) | This member function retrieves the system time as indicated by the currently selected date.
CXTMonthCalCtrl::GetCurSel (LPSYSTEMTIME) | This member function retrieves the system time as indicated by the currently selected date.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::GetCurSel Method (CTime&)

GetCurSel Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::GetCurSel Method (CTime&)

This member function retrieves the system time as indicated by the currently selected date.

BOOL GetCurSel(
    CTime& refTime
) const;
BOOL GetCurSel(
    COleDateTime& refDateTime
) const;
BOOL GetCurSel(
    LPSYSTEMTIME pDateTime
) const;
Parameters

refTime
A reference to a CTime object. It receives the current time.
refDateTime
A reference to a COleDateTime object. It receives the current time.
pDateTime
A pointer to a SYSTEMTIME structure that will receive the currently selected date information. This parameter must be a valid address and cannot be NULL.

Returns

Nonzero if successful, otherwise returns zero.

Group

GetCurSel Method


CXTMonthCalCtrl::GetFirstDayOfWeek Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class
CXTMonthCalCtrl::GetFirstDayOfWeek Method

This member function gets the first day of the week to be displayed in the leftmost column of the calendar.

int GetFirstDayOfWeek(
    BOOL* pbLocal = NULL
) const;
Parameters

pbLocal
A pointer to a BOOL value. If the value is nonzero, the control's setting does not match the setting in the control panel.

Returns

An integer value that represents the first day of the week. The days of the week are represented by integers, as follows:

Value   Day of the Week
0       Monday
1       Tuesday
2       Wednesday
3       Thursday
4       Friday
5       Saturday
6       Sunday
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::GetMaxSelCount Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class, Body Source
CXTMonthCalCtrl::GetMaxSelCount Method

This member function retrieves the current maximum number of days that can be selected in a month calendar control.

int GetMaxSelCount() const;
Returns

An integer value that represents the total number of days that can be selected for the control.

Body Source
int CXTMonthCalCtrl::GetMaxSelCount() const {
    ASSERT(::IsWindow(m_hWnd)); return (int) ::SendMessage(m_hWnd, MCM_GETMAXSELCOUNT, 0, 0);
}
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::GetMinReqRect Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class, Body Source
CXTMonthCalCtrl::GetMinReqRect Method

This member function retrieves the minimum size required to show a full month in a month calendar control.

BOOL GetMinReqRect(
    RECT* pRect
) const;
Parameters

pRect
A pointer to a RECT structure that will receive bounding rectangle information. This parameter must be a valid address and cannot be NULL.

Returns

Nonzero and 'lpRect' receives the applicable bounding information. If unsuccessful, this member function returns zero.

Body Source
BOOL CXTMonthCalCtrl::GetMinReqRect(RECT* pRect) const {
    ASSERT(::IsWindow(m_hWnd)); return (BOOL) ::SendMessage(m_hWnd, MCM_GETMINREQRECT, 0, (LPARAM) pRect);
}
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::GetMonthDelta Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class, Body Source
CXTMonthCalCtrl::GetMonthDelta Method

This member function retrieves the scroll rate for a month calendar control. The scroll rate is the number of months that the control moves its display when the user clicks a scroll button once.

int GetMonthDelta() const;
Returns

An integer value that represents the scroll rate for the month calendar control.

Body Source
int CXTMonthCalCtrl::GetMonthDelta() const {
    ASSERT(::IsWindow(m_hWnd)); return (int) ::SendMessage(m_hWnd, MCM_GETMONTHDELTA, 0, 0);
}
Group

CXTMonthCalCtrl Methods


GetMonthRange Method

CXTMonthCalCtrl Methods
GetMonthRange Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::GetMonthRange (COleDateTime&, COleDateTime&, DWORD) | This member function retrieves date information representing the high and low limits of a month calendar control's display.
CXTMonthCalCtrl::GetMonthRange (CTime&, CTime&, DWORD) | This member function retrieves date information representing the high and low limits of a month calendar control's display.
CXTMonthCalCtrl::GetMonthRange (LPSYSTEMTIME, LPSYSTEMTIME, DWORD) | This member function retrieves date information representing the high and low limits of a month calendar control's display.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::GetMonthRange Method (CTime&, CTime&, DWORD)

GetMonthRange Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::GetMonthRange Method (CTime&, CTime&, DWORD)

This member function retrieves date information representing the high and low limits of a month calendar control's display.

int GetMonthRange(
    CTime& refMinRange,
    CTime& refMaxRange,
    DWORD dwFlags
) const;
int GetMonthRange(
    COleDateTime& refMinRange,
    COleDateTime& refMaxRange,
    DWORD dwFlags
) const;
int GetMonthRange(
    LPSYSTEMTIME pMinRange,
    LPSYSTEMTIME pMaxRange,
    DWORD dwFlags
) const;
Parameters

refMinRange
A reference to a CTime or COleDateTime object containing the minimum date allowed.
refMaxRange
A reference to a CTime or COleDateTime object containing the maximum date allowed.
dwFlags
Value specifying the scope of the range limits to be retrieved. This value must be one of the following:

  • GMR_DAYSTATE Include preceding and trailing months of visible range that are only partially displayed.
  • GMR_VISIBLE Include only those months that are entirely displayed.

pMinRange
A pointer to a SYSTEMTIME structure containing the date at the lowest end of the range.
pMaxRange
A pointer to a SYSTEMTIME structure containing the date at the highest end of the range.

Returns

An integer that represents the range, in months, spanned by the two limits indicated by 'refMinRange' and 'refMaxRange'.

Group

GetMonthRange Method


GetRange Method

CXTMonthCalCtrl Methods
GetRange Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::GetRange (COleDateTime*, COleDateTime*) | This member function retrieves the current minimum and maximum dates set in a month calendar control.
CXTMonthCalCtrl::GetRange (CTime*, CTime*) | This member function retrieves the current minimum and maximum dates set in a month calendar control.
CXTMonthCalCtrl::GetRange (LPSYSTEMTIME, LPSYSTEMTIME) | This member function retrieves the current minimum and maximum dates set in a month calendar control.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::GetRange Method (CTime*, CTime*)

GetRange Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::GetRange Method (CTime*, CTime*)

This member function retrieves the current minimum and maximum dates set in a month calendar control.

DWORD GetRange(
    CTime* pMinRange,
    CTime* pMaxRange
) const;
DWORD GetRange(
    COleDateTime* pMinRange,
    COleDateTime* pMaxRange
) const;
DWORD GetRange(
    LPSYSTEMTIME pMinRange,
    LPSYSTEMTIME pMaxRange
) const;
Parameters

pMinRange
A pointer to a CTime, COleDateTime or SYSTEMTIME object containing the date at the lowest end of the range.
pMaxRange
A pointer to a CTime, COleDateTime or SYSTEMTIME object containing the date at the highest end of the range.

Returns

A DWORD that can be zero (no limits are set) or a combination of the following values that specify limit information:

  • GDTR_MAX A maximum limit is set for the control; pMaxRange is valid and contains the applicable date information.
  • GDTR_MIN A minimum limit is set for the control; pMinRange is valid and contains the applicable date information.
Group

GetRange Method


GetSelRange Method

CXTMonthCalCtrl Methods
GetSelRange Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::GetSelRange (COleDateTime&, COleDateTime&) | This member function retrieves date information that represents the upper and lower limits of the date range currently selected by the user.
CXTMonthCalCtrl::GetSelRange (CTime&, CTime&) | This member function retrieves date information that represents the upper and lower limits of the date range currently selected by the user.
CXTMonthCalCtrl::GetSelRange (LPSYSTEMTIME, LPSYSTEMTIME) | This member function retrieves date information that represents the upper and lower limits of the date range currently selected by the user.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::GetSelRange Method (CTime&, CTime&)

GetSelRange Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::GetSelRange Method (CTime&, CTime&)

This member function retrieves date information that represents the upper and lower limits of the date range currently selected by the user.

BOOL GetSelRange(
    CTime& refMinRange,
    CTime& refMaxRange
) const;
BOOL GetSelRange(
    COleDateTime& refMinRange,
    COleDateTime& refMaxRange
) const;
BOOL GetSelRange(
    LPSYSTEMTIME pMinRange,
    LPSYSTEMTIME pMaxRange
) const;
Parameters

refMinRange
A reference to a CTime or COleDateTime object containing the minimum date allowed.
refMaxRange
A reference to a CTime or COleDateTime object containing the maximum date allowed.
pMinRange
A pointer to a SYSTEMTIME structure containing the date at the lowest end of the range.
pMaxRange
A pointer to a SYSTEMTIME structure containing the date at the highest end of the range.

Returns

Nonzero if successful, otherwise returns zero.

Group

GetSelRange Method


GetToday Method

CXTMonthCalCtrl Methods
GetToday Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::GetToday (COleDateTime&) | This member function retrieves the date information for the date specified as "today" for a month calendar control.
CXTMonthCalCtrl::GetToday (CTime&) | This member function retrieves the date information for the date specified as "today" for a month calendar control.
CXTMonthCalCtrl::GetToday (LPSYSTEMTIME) | This member function retrieves the date information for the date specified as "today" for a month calendar control.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::GetToday Method (CTime&)

GetToday Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::GetToday Method (CTime&)

This member function retrieves the date information for the date specified as "today" for a month calendar control.

BOOL GetToday(
    CTime& refTime
) const;
BOOL GetToday(
    COleDateTime& refDateTime
) const;
BOOL GetToday(
    LPSYSTEMTIME pDateTime
) const;
Parameters

refTime
A reference to a CTime or COleDateTime object indicating the current day.
pDateTime
A pointer to a SYSTEMTIME structure that will receive the date information. This parameter must be a valid address and cannot be NULL.

Returns

Nonzero if successful, otherwise returns zero.

Group

GetToday Method


CXTMonthCalCtrl::HitTest Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class, Body Source
CXTMonthCalCtrl::HitTest Method

This member function determines which portion of a month calendar control is at a given point on the screen.

DWORD HitTest(
    PMCHITTESTINFO pMCHitTest
);
Parameters

pMCHitTest
A pointer to a MCHITTESTINFO structure containing hit testing points for the month calendar control.

Returns

A DWORD value equal to the 'uHit' member of the MCHITTESTINFO structure.

Body Source
DWORD CXTMonthCalCtrl::HitTest(PMCHITTESTINFO pMCHitTest) {
    ASSERT(::IsWindow(m_hWnd)); return (DWORD) ::SendMessage(m_hWnd, MCM_HITTEST, 0, (LPARAM) pMCHitTest);
}
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::SetColor Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class, Body Source
CXTMonthCalCtrl::SetColor Method

This member function sets the color of a specified area of a month calendar control.

COLORREF SetColor(
    int nRegion,
    COLORREF ref
);
Parameters

nRegion
An integer value specifying which month calendar color to set. See remarks section for a list of values.
ref
A COLORREF value for the new color setting for the specified portion of the month calendar control.

Returns

A COLORREF value that represents the previous color setting for the specified portion of the month calendar control, if successful. Otherwise this message returns -1.

Remarks

nRegion values can be one of the following:

  • MCSC_BACKGROUND The background color displayed between months.
  • MCSC_MONTHBK The background color displayed within the month.
  • MCSC_TEXT The color used to display text within a month.
  • MCSC_TITLEBK The background color displayed in the calendar's title.
  • MCSC_TITLETEXT The color used to display text within the calendar's title.
  • MCSC_TRAILINGTEXT The color used to display header and trailing-day text. Header and trailing days are the days from the previous and following months that appear on the current calendar.
Body Source
COLORREF CXTMonthCalCtrl::SetColor(int nRegion, COLORREF ref) {
    ASSERT(::IsWindow(m_hWnd)); return (COLORREF) ::SendMessage(m_hWnd, MCM_SETCOLOR, (WPARAM) nRegion, (LPARAM) ref);
}
Group

CXTMonthCalCtrl Methods


SetCurSel Method

CXTMonthCalCtrl Methods
SetCurSel Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::SetCurSel (const COleDateTime&) | This member function sets the currently selected date for a month calendar control.
CXTMonthCalCtrl::SetCurSel (const CTime&) | This member function sets the currently selected date for a month calendar control.
CXTMonthCalCtrl::SetCurSel (const LPSYSTEMTIME) | This member function sets the currently selected date for a month calendar control.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::SetCurSel Method (const CTime&)

SetCurSel Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::SetCurSel Method (const CTime&)

This member function sets the currently selected date for a month calendar control.

BOOL SetCurSel(
    const CTime& refDateTime
);
BOOL SetCurSel(
    const COleDateTime& refDateTime
);
BOOL SetCurSel(
    const LPSYSTEMTIME pDateTime
);
Parameters

refDateTime
A reference to a CTime or COleDateTime object indicating the currently selected month calendar control.
pDateTime
Pointer to a SYSTEMTIME structure that contains the date to be set as the current selection.

Returns

Nonzero if successful, otherwise returns zero.

Group

SetCurSel Method


CXTMonthCalCtrl::SetDayState Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class
CXTMonthCalCtrl::SetDayState Method

This member function sets the display for days in a month calendar control.

BOOL SetDayState(
    int nMonths,
    LPMONTHDAYSTATE pStates
);
Parameters

nMonths
Value indicating how many elements are in the array that 'pStates' points to.
pStates
A pointer to a MONTHDAYSTATE array of values that define how the month calendar control will draw each day in its display. The MONTHDAYSTATE data type is a bit field, where each bit (1 through 31) represents the state of a day in a month. If a bit is on, the corresponding day will be displayed in bold; otherwise it will be displayed with no emphasis.

Returns

Nonzero if successful, otherwise returns zero.

Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::SetFirstDayOfWeek Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class
CXTMonthCalCtrl::SetFirstDayOfWeek Method

This member function sets the day of the week to be displayed in the leftmost column of the calendar.

BOOL SetFirstDayOfWeek(
    int iDay,
    int* lpnOld = NULL
);
Parameters

iDay
An integer value representing which day is to be set as the first day of the week. This value must be one of the day numbers. See GetFirstDayOfWeek for a description of the day numbers.
lpnOld
A pointer to an integer indicating the first day of the week that was previously set.

Returns

Nonzero if the previous first day of the week is set to a value other than that of LOCALE_IFIRSTDAYOFWEEK, which is the day indicated in the control panel setting. Otherwise, this function returns zero.

Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::SetMaxSelCount Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class, Body Source
CXTMonthCalCtrl::SetMaxSelCount Method

This member function sets the maximum number of days that can be selected in a month calendar control.

BOOL SetMaxSelCount(
    int nMax
);
Parameters

nMax
Specifies the value that will be set to represent the maximum number of selectable days.

Returns

Nonzero if successful, otherwise returns zero.

Body Source
BOOL CXTMonthCalCtrl::SetMaxSelCount(int nMax) {
    ASSERT(::IsWindow(m_hWnd)); return (BOOL) ::SendMessage(m_hWnd, MCM_SETMAXSELCOUNT, nMax, 0);
}
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::SetMonthDelta Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class, Body Source
CXTMonthCalCtrl::SetMonthDelta Method

This member function sets the scroll rate for a month calendar control.

int SetMonthDelta(
    int iDelta
);
Parameters

iDelta
The number of months to be set as the control's scroll rate. If this value is zero, the month delta is reset to the default, which is the number of months displayed in the control.

Returns

The previous scroll rate. If the scroll rate has not been previously set, the return value is zero.

Body Source
int CXTMonthCalCtrl::SetMonthDelta(int iDelta) {
    ASSERT(::IsWindow(m_hWnd)); return (int) ::SendMessage(m_hWnd, MCM_SETMONTHDELTA, (WPARAM) iDelta, 0);
}
Group

CXTMonthCalCtrl Methods


SetRange Method

CXTMonthCalCtrl Methods
SetRange Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::SetRange (const COleDateTime*, const COleDateTime*) | This member function sets the minimum and maximum allowable dates for a month calendar control.
CXTMonthCalCtrl::SetRange (const CTime*, const CTime*) | This member function sets the minimum and maximum allowable dates for a month calendar control.
CXTMonthCalCtrl::SetRange (const LPSYSTEMTIME, const LPSYSTEMTIME) | This member function sets the minimum and maximum allowable dates for a month calendar control.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::SetRange Method (const CTime*, const CTime*)

SetRange Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::SetRange Method (const CTime*, const CTime*)

This member function sets the minimum and maximum allowable dates for a month calendar control.

BOOL SetRange(
    const CTime* pMinRange,
    const CTime* pMaxRange
);
BOOL SetRange(
    const COleDateTime* pMinRange,
    const COleDateTime* pMaxRange
);
BOOL SetRange(
    const LPSYSTEMTIME pMinRange,
    const LPSYSTEMTIME pMaxRange
);
Parameters

pMinRange
A pointer to a CTime, COleDateTime or SYSTEMTIME object containing the date at the lowest end of the range.
pMaxRange
A pointer to a CTime, COleDateTime or SYSTEMTIME object containing the date at the highest end of the range.

Returns

Nonzero if successful, otherwise returns zero.

Group

SetRange Method


SetSelRange Method

CXTMonthCalCtrl Methods
SetSelRange Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::SetSelRange (const COleDateTime&, const COleDateTime&) | This member function sets the selection for a month calendar control to a given date range.
CXTMonthCalCtrl::SetSelRange (const CTime&, const CTime&) | This member function sets the selection for a month calendar control to a given date range.
CXTMonthCalCtrl::SetSelRange (const LPSYSTEMTIME, const LPSYSTEMTIME) | This member function sets the selection for a month calendar control to a given date range.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::SetSelRange Method (const CTime&, const CTime&)

SetSelRange Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::SetSelRange Method (const CTime&, const CTime&)

This member function sets the selection for a month calendar control to a given date range.

BOOL SetSelRange(
    const CTime& pMinRange,
    const CTime& pMaxRange
);
BOOL SetSelRange(
    const COleDateTime& pMinRange,
    const COleDateTime& pMaxRange
);
BOOL SetSelRange(
    const LPSYSTEMTIME pMinRange,
    const LPSYSTEMTIME pMaxRange
);
Parameters

pMinRange
A pointer to a CTime, COleDateTime or SYSTEMTIME object containing the date at the lowest end of the range.
pMaxRange
A pointer to a CTime, COleDateTime or SYSTEMTIME object containing the date at the highest end of the range.

Returns

Nonzero if successful, otherwise returns zero.

Group

SetSelRange Method


SetToday Method

CXTMonthCalCtrl Methods
SetToday Method
Overload List
Methods
Method | Description
CXTMonthCalCtrl::SetToday (const COleDateTime&) | This member function sets the calendar control to the current day.
CXTMonthCalCtrl::SetToday (const CTime*) | This member function sets the calendar control to the current day.
CXTMonthCalCtrl::SetToday (const LPSYSTEMTIME) | This member function sets the calendar control to the current day.
Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl::SetToday Method (const CTime*)

SetToday Method, CXTMonthCalCtrl Class
CXTMonthCalCtrl::SetToday Method (const CTime*)

This member function sets the calendar control to the current day.

void SetToday(
    const CTime* pDateTime
);
void SetToday(
    const COleDateTime& refDateTime
);
void SetToday(
    const LPSYSTEMTIME pDateTime
);
Parameters

pDateTime
A pointer to a CTime or SYSTEMTIME object containing the current date information.
refDateTime
A reference to a COleDateTime object that contains the current date.

Group

SetToday Method


CXTMonthCalCtrl::SizeMinReq Method

CXTMonthCalCtrl Methods, CXTMonthCalCtrl Class
CXTMonthCalCtrl::SizeMinReq Method

This member function repaints the month calendar control to its minimum, one-month size.

BOOL SizeMinReq(
    BOOL bRepaint = TRUE
);
Parameters

bRepaint
Specifies whether the control is to be repainted. By default, TRUE. If FALSE, no repainting occurs.

Returns

Nonzero if the month calendar control is sized to its minimum, otherwise returns zero.

Group

CXTMonthCalCtrl Methods


CXTMonthCalCtrl Constructors

CXTMonthCalCtrl Class, Legend, Public Methods
CXTMonthCalCtrl Constructors
Class

CXTMonthCalCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMonthCalCtrl | Constructs a CXTMonthCalCtrl object


CXTMonthCalCtrl::CXTMonthCalCtrl Constructor

CXTMonthCalCtrl Constructors, CXTMonthCalCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMonthCalCtrl::CXTMonthCalCtrl Constructor

Constructs a CXTMonthCalCtrl object

CXTMonthCalCtrl();
Body Source
CXTMonthCalCtrl::CXTMonthCalCtrl() {

}
Group

CXTMonthCalCtrl Constructors


CXTMonthCalCtrl Destructors

CXTMonthCalCtrl Class, Legend, Public Methods
CXTMonthCalCtrl Destructors
Class

CXTMonthCalCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTMonthCalCtrl | Destroys a CXTMonthCalCtrl object, handles cleanup and deallocation


CXTMonthCalCtrl::~CXTMonthCalCtrl Destructor

CXTMonthCalCtrl Destructors, CXTMonthCalCtrl Class
CXTMonthCalCtrl::~CXTMonthCalCtrl Destructor

Destroys a CXTMonthCalCtrl object, handles cleanup and deallocation

virtual ~CXTMonthCalCtrl();
Group

CXTMonthCalCtrl Destructors


CXTNonClientMetrics Class

XTGlobal.h, Classes, Legend, Members, Topics, CXTNonClientMetrics Constructors, CXTNonClientMetrics Constructors, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTNonClientMetrics Class

CXTNonClientMetrics is a self initializing NONCLIENTMETRICS derived class. It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.

Class Hierarchy

class CXTNonClientMetrics : public NONCLIENTMETRICS;
File

XTGlobal.h

Example

The following example demonstrates using CXTNonClientMetrics.

CXTLogFont lfMenuFont;
CXTNonClientMetrics ncm;

lfMenuFont.lfCharSet = (BYTE)::GetTextCharsetInfo (dc, NULL, 0);
lfMenuFont.lfHeight  = ncm.lfMenuFont.lfHeight;
lfMenuFont.lfWeight  = ncm.lfMenuFont.lfWeight;
lfMenuFont.lfItalic  = ncm.lfMenuFont.lfItalic;

STRCPY_S(lfMenuFont.lfFaceName, LF_FACESIZE, ncm.lfMenuFont.lfFaceName);
Group

Classes

Legend
Constructor
CXTNonClientMetrics Constructors
CXTNonClientMetrics Constructors | Description
CXTNonClientMetrics | Constructs an CXTNonClientMetrics object


CXTNonClientMetrics Constructors

CXTNonClientMetrics Class, Legend, Public Methods
CXTNonClientMetrics Constructors
Class

CXTNonClientMetrics Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTNonClientMetrics | Constructs an CXTNonClientMetrics object


CXTNonClientMetrics::CXTNonClientMetrics Constructor

CXTNonClientMetrics Constructors, CXTNonClientMetrics Class
CXTNonClientMetrics::CXTNonClientMetrics Constructor

Constructs an CXTNonClientMetrics object

CXTNonClientMetrics();
Group

CXTNonClientMetrics Constructors


CXTOutBarCtrl Class

XTOutBarCtrl.h, Classes, Legend, Members, Topics, CXTOutBarCtrl Enumerations, CXTOutBarCtrl Data Members, CXTOutBarCtrl Methods, CXTOutBarCtrl Constructors, CXTOutBarCtrl Destructors, CXTOutBarCtrl Constructors, CXTOutBarCtrl Data Members, CXTOutBarCtrl Destructors, CXTOutBarCtrl Enumerations, CXTOutBarCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrl Class

CXTOutBarCtrl is a CWnd derived class. It is used to create a shortcut bar window similar to the shortcut bar seen in Outlook(tm).

Class Hierarchy

class CXTOutBarCtrl : public CWnd;
File

XTOutBarCtrl.h

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
CXTOutBarCtrl Constructors
CXTOutBarCtrl Constructors | Description
CXTOutBarCtrl | Constructs a CXTOutBarCtrl object
CXTOutBarCtrl Data Members
CXTOutBarCtrl Data Members | Description
m_arFolder | Array of folders added to the outlook bar.
m_bDownArrow | TRUE when the down scroll arrow is displayed.
m_bDownPressed | TRUE when the down scroll arrow is selected.
m_bIconPressed | TRUE when the selected item's icon should be rendered selected.
m_bLooping | TRUE when scrolling to continue iteration.
m_bPressedHighlight | TRUE when the selected item should be rendered.
m_bUpArrow | TRUE when the up scroll arrow is displayed.
m_bUpPressed | TRUE when the up scroll arrow is selected.
m_dwFlags | Style for the Outlook bar.
m_font | Font used by the outlook bar.
m_nAnimationTickCount | Specifies the time in milliseconds between animation.
m_nFirstItem | Index of the first visible item.
m_nFolderHeight | Size in pixels of the folder caption bar.
m_nFolderHilighted | Index of the currently highlighted folder.
m_nHitInternal1 | Used internally to test folder and item indexes.
m_nHitInternal2 | Used internally to test folder and item indexes.
m_nIconSpacingLarge | Amount in pixels of the gap between large icons.
m_nIconSpacingSmall | Amount in pixels of the gap between small icons.
m_nItemHilighted | Index of the currently highlighted item.
m_nLastDragItemDraw | Insertion index for drag and drop operations.
m_nLastDragItemDrawType | Style of last drag item that was rendered.
m_nLastFolderSelected | Index of the last folder that was selected.
m_nLastItemSelected | Index of the last item that was selected.
m_nSelAnimCount | Selected item animation sequence count
m_nSelAnimTiming | Specifies the time in milliseconds that the selected item will animate.
m_nSelFolder | Index of the currently selected folder.
m_penBlack | Pen used to render drag arrow.
m_pLargeImageList | Points to the large image list for the outlook bar.
m_pSmallImageList | Points to the small image list for the outlook bar.
m_rcDownArrow | Size and location of the down scroll arrow.
m_rcUpArrow | Size and location of the up scroll arrow.
m_sizeMargin | Amount in pixels of the gap between the border and item text and icon.
m_sizeOffset | Amount in pixels of the gap between an item icon and text.
CXTOutBarCtrl Destructors
CXTOutBarCtrl Destructors | Description
~CXTOutBarCtrl | Destroys a CXTOutBarCtrl object, handles cleanup and deallocation
CXTOutBarCtrl Enumerations
CXTOutBarCtrl Enumerations | Description
HitTestCode | Enumeration to determine an item type.
RectItem | Enumeration to determine an item's size.
CXTOutBarCtrl Methods
CXTOutBarCtrl Methods | Description
AddFolder | Call this member function to add a folder to the Outlook bar control.
AddFolderBar | Call this member function to add a folder with a CWnd child nested inside of it. You can insert a folder with any CWnd object, such as a tree control (see the OutlookBar sample).
AnimateFolderScroll | Called by the CXTOutBarCtrl to render folder animation when a new folder is selected.
Create | Call this member function to create the Outlook bar control.
CreateEx | Call this member function to create the Outlook bar control.
DrawAnimItem | Called by the CXTOutBarCtrl to render an item animated.
DrawDragArrow | Called by the CXTOutBarCtrl to draw the drag arrow
DrawFolder | Called by the CXTOutBarCtrl to render a folder.
DrawIcon | Called by the CXTOutBarCtrl to render an item's icon.
DrawItem | Called by the CXTOutBarCtrl to draw a folder item.
DrawItemIcon | Called by the CXTOutBarCtrl to draw an item icon.
DrawItemText | Called by the CXTOutBarCtrl to draw an items label.
DrawPreviewBitmap | Called by the CXTOutBarCtrl to render a folder that contains a CWnd object when a new folder is selected.
DrawScrollButton | Called by the CXTOutBarCtrl to draw the up or down scroll button.
EnableItem | Call this member function to enable or disable a folder item.
EndLabelEdit | Called by the CXTOutBarCtrl to end an item or folder label edit.
GetAnimationTickCount | Call this member function to get the current animation tick count.
GetBarFolder | Call this member function to return a pointer to the CXTOutBarFolder data that is associated with the specified folder.
GetBarFolderItem | Call this member function to return a pointer to the CXTOutBarItem data that is associated with the specified folder and item.
GetCurSel | This member function will return the index of the currently selected item for the currently selected folder.
GetDragItemRect | Called by the CXTOutBarCtrl to get the size of the item dragged.
GetFlag | Call this member function to get the current style set for the Outlook bar.
GetFolderChild | Call this member function to retrieve the CWnd object that has been set for the folder specified by 'iFolder'.
GetFolderCount | This member function will get the total number of folders found in the Outlook bar.
GetFolderData | Call this member function to retrieve the item data that was set for the specified folder.
GetFolderImageList | Call this member function to get a pointer to the image list for the specified folder.
GetFolderRect | Call this member function to retrieve the size of the specified folder.
GetFontX | Call this member function to retrieve the font used by the Outlook bar control.
GetIconRect | Call this member function to retrieve the size of the icon for the specified item.
GetImageList | Call this member function to return the global image list for the OutlookBar control.
GetInsideRect | Call this member function to retrieve the size of the client area for the Outlook bar. This is the inside area that contains the folders.
GetItemCount | This member function gets the number of items found in the currently selected folder.
GetItemData | Call this member function to get the item data (lParam) for the specified item in the currently selected folder.
GetItemImage | Call this member function to retrieve the index of the image associated with the specified item in the currently selected folder.
GetItemRect | Call this member function to retrieve the size of the specified item. The size includes the area occupied by the item's label and icon.
GetItemSize | Called by the CXTOutBarCtrl to get the size of a folder item.
GetItemText | Call this member function to get the text of the specified item for the currently selected folder.
GetLabelRect | Call this member function to retrieve the size of the label for the specified item.
GetSelFolder | This member function will get the index of the currently selected folder.
GetVisibleRange | Called by the CXTOutBarCtrl to get the area that is visible to the user.
HighlightFolder | Called by the CXTOutBarCtrl to render a folder highlighted.
HighlightItem | Called by the CXTOutBarCtrl to draw an item highlighted.
HitTestEx | Called to determine the item from a given xy coordinate.
InsertItem | Call this member function to insert an item into the specified folder.
IsSmallIconView | Call this member function to return the current state of the icon display for the Outlook bar control.
IsValidItem | Called to determine if the specified item is valid.
ModifyFlag | Call this member function to modify an Outlook bar style.
NotifyOwner | This member is called to notify the parent window that an event has occurred in the task panel.
OnLabelChanged | Called by the CXTOutBarCtrl when an item or folders label changes.
PaintItems | Called by the CXTOutBarCtrl to render all items for a folder.
RemoveAllItems | Call this member function to remove all items from the folder specified by 'iFolder'.
RemoveFolder | Call this member function to remove the specified folder and its items.
RemoveItem | Call this member function to remove the specified item from the currently selected folder.
SetAnimationTickCount | Call this member function to set the tick count, in milliseconds, between each animation frame in folder scrolling. If you set a value of -1, or minor, no animation will be played. Animation requires the OBS_XT_ANIMATION flag be set.
SetAnimSelHighlight | Call this member function to set an animation effect for the currently selected item. It is not to be used with OBS_XT_SELHIGHLIGHT flag.
SetBackColor | Call this member function to set the background color for the Outlook bar control.
SetCurSel | This member function will set the currently selected item for the currently selected folder.
SetFolderImageList | Call this member function to set the image list for the specified folder.
SetFolderText | Call this member function to set the text label for the specified folder.
SetFontX | Call this member function to set the font used by the Outlook bar control.
SetImageList | This member function will set the main image list. You can link different image lists to the folders using the SetFolderImageList function. If a folder has been linked to an image list with the SetFolderImageList function, it will own the linked image list. Otherwise, it will use the image list set with this function.
SetItemData | Call this member function to set the item data (lParam) for the specified item in the currently selected folder.
SetItemImage | Call this member function to set the image index, in the image list, for the 'iIndex' item of the currently selected folder.
SetItemText | Call this member function to set the text for the specified item in the currently selected folder.
SetSelFolder | This member function will set the selected folder for the Outlook bar.
SetSelItem | This member function will set the selected folder and item for the Outlook bar.
SetSmallIconView | Call this member function to set the size of the icons displayed in the Outlook bar control for the specified folder.
SetTextColor | Call this member function to set the text color for items in the Outlook bar control.
StartGroupEdit | Call this member function to begin editing of the specified folder item's label.
StartItemEdit | Call this member function to begin local editing of the specified item in the currently selected folder.


CXTOutBarCtrl Enumerations

Enumerations, CXTOutBarCtrl Class, Legend
CXTOutBarCtrl Enumerations
Enumerations
Enumeration | Description
HitTestCode | Enumeration to determine an item type.
RectItem | Enumeration to determine an item's size.
Class

CXTOutBarCtrl Class

Legend
Enumeration


CXTOutBarCtrl::HitTestCode Enumeration

XTOutBarCtrl.h, CXTOutBarCtrl Enumerations, See Also
CXTOutBarCtrl::HitTestCode Enumeration

Enumeration to determine an item type.

enum HitTestCode {
  hitNone = -1,
  hitFolder = 0,
  hitItem = 1,
  hitUpScroll = 2,
  hitDnScroll = 3
};
File

XTOutBarCtrl.h

Members

hitNone
No item was found.
hitFolder
The item found was a folder.
hitItem
The item found was a shortcut.
hitUpScroll
The item found was a up arrow.
hitDnScroll
The item found was a down arrow.

Remarks

HitTestCode type defines the constants used to determine the type of item that was found during a HitTestEx operation.

See Also

CXTOutBarCtrl, CXTOutBarCtrl::HitTestEx

Group

CXTOutBarCtrl Enumerations


CXTOutBarCtrl::RectItem Enumeration

XTOutBarCtrl.h, CXTOutBarCtrl Enumerations, See Also
CXTOutBarCtrl::RectItem Enumeration

Enumeration to determine an item's size.

enum RectItem {
  rectItemIcon = 1,
  rectItemLabel = 2,
  rectItemBoth = 3
};
File

XTOutBarCtrl.h

Members

rectItemIcon
Area is the size of an item icon.
rectItemLabel
Area is the size of an item label.
rectItemBoth
Area is the size of both the item icon and label combined.

Remarks

RectItem type defines the constants used to determine the size or the item or one of its components (label or icon). This is used to determine how the control should be rendered.

See Also

CXTOutBarCtrl, CXTOutBarCtrl::GetItemSize

Group

CXTOutBarCtrl Enumerations


CXTOutBarCtrl Data Members

CXTOutBarCtrl Class, Legend, Protected Data Members
CXTOutBarCtrl Data Members
Class

CXTOutBarCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arFolder | Array of folders added to the outlook bar.
m_bDownArrow | TRUE when the down scroll arrow is displayed.
m_bDownPressed | TRUE when the down scroll arrow is selected.
m_bIconPressed | TRUE when the selected item's icon should be rendered selected.
m_bLooping | TRUE when scrolling to continue iteration.
m_bPressedHighlight | TRUE when the selected item should be rendered.
m_bUpArrow | TRUE when the up scroll arrow is displayed.
m_bUpPressed | TRUE when the up scroll arrow is selected.
m_dwFlags | Style for the Outlook bar.
m_font | Font used by the outlook bar.
m_nAnimationTickCount | Specifies the time in milliseconds between animation.
m_nFirstItem | Index of the first visible item.
m_nFolderHeight | Size in pixels of the folder caption bar.
m_nFolderHilighted | Index of the currently highlighted folder.
m_nHitInternal1 | Used internally to test folder and item indexes.
m_nHitInternal2 | Used internally to test folder and item indexes.
m_nIconSpacingLarge | Amount in pixels of the gap between large icons.
m_nIconSpacingSmall | Amount in pixels of the gap between small icons.
m_nItemHilighted | Index of the currently highlighted item.
m_nLastDragItemDraw | Insertion index for drag and drop operations.
m_nLastDragItemDrawType | Style of last drag item that was rendered.
m_nLastFolderSelected | Index of the last folder that was selected.
m_nLastItemSelected | Index of the last item that was selected.
m_nSelAnimCount | Selected item animation sequence count
m_nSelAnimTiming | Specifies the time in milliseconds that the selected item will animate.
m_nSelFolder | Index of the currently selected folder.
m_penBlack | Pen used to render drag arrow.
m_pLargeImageList | Points to the large image list for the outlook bar.
m_pSmallImageList | Points to the small image list for the outlook bar.
m_rcDownArrow | Size and location of the down scroll arrow.
m_rcUpArrow | Size and location of the up scroll arrow.
m_sizeMargin | Amount in pixels of the gap between the border and item text and icon.
m_sizeOffset | Amount in pixels of the gap between an item icon and text.


CXTOutBarCtrl::m_arFolder Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_arFolder Data Member

Array of folders added to the outlook bar.

CPtrArray m_arFolder;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_bDownArrow Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_bDownArrow Data Member

TRUE when the down scroll arrow is displayed.

BOOL m_bDownArrow;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_bDownPressed Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_bDownPressed Data Member

TRUE when the down scroll arrow is selected.

BOOL m_bDownPressed;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_bIconPressed Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_bIconPressed Data Member

TRUE when the selected item's icon should be rendered selected.

BOOL m_bIconPressed;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_bLooping Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_bLooping Data Member

TRUE when scrolling to continue iteration.

BOOL m_bLooping;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_bPressedHighlight Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_bPressedHighlight Data Member

TRUE when the selected item should be rendered.

BOOL m_bPressedHighlight;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_bUpArrow Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_bUpArrow Data Member

TRUE when the up scroll arrow is displayed.

BOOL m_bUpArrow;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_bUpPressed Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_bUpPressed Data Member

TRUE when the up scroll arrow is selected.

BOOL m_bUpPressed;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_dwFlags Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_dwFlags Data Member

Style for the Outlook bar.

DWORD m_dwFlags;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_font Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_font Data Member

Font used by the outlook bar.

CFont m_font;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nAnimationTickCount Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nAnimationTickCount Data Member

Specifies the time in milliseconds between animation.

int m_nAnimationTickCount;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nFirstItem Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nFirstItem Data Member

Index of the first visible item.

int m_nFirstItem;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nFolderHeight Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nFolderHeight Data Member

Size in pixels of the folder caption bar.

int m_nFolderHeight;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nFolderHilighted Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nFolderHilighted Data Member

Index of the currently highlighted folder.

int m_nFolderHilighted;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nHitInternal1 Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nHitInternal1 Data Member

Used internally to test folder and item indexes.

int m_nHitInternal1;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nHitInternal2 Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nHitInternal2 Data Member

Used internally to test folder and item indexes.

int m_nHitInternal2;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nIconSpacingLarge Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nIconSpacingLarge Data Member

Amount in pixels of the gap between large icons.

int m_nIconSpacingLarge;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nIconSpacingSmall Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nIconSpacingSmall Data Member

Amount in pixels of the gap between small icons.

int m_nIconSpacingSmall;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nItemHilighted Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nItemHilighted Data Member

Index of the currently highlighted item.

int m_nItemHilighted;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nLastDragItemDraw Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nLastDragItemDraw Data Member

Insertion index for drag and drop operations.

int m_nLastDragItemDraw;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nLastDragItemDrawType Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nLastDragItemDrawType Data Member

Style of last drag item that was rendered.

int m_nLastDragItemDrawType;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nLastFolderSelected Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nLastFolderSelected Data Member

Index of the last folder that was selected.

int m_nLastFolderSelected;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nLastItemSelected Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nLastItemSelected Data Member

Index of the last item that was selected.

int m_nLastItemSelected;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nSelAnimCount Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nSelAnimCount Data Member

Selected item animation sequence count

int m_nSelAnimCount;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nSelAnimTiming Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nSelAnimTiming Data Member

Specifies the time in milliseconds that the selected item will animate.

int m_nSelAnimTiming;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_nSelFolder Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_nSelFolder Data Member

Index of the currently selected folder.

int m_nSelFolder;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_penBlack Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_penBlack Data Member

Pen used to render drag arrow.

CPen m_penBlack;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_pLargeImageList Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_pLargeImageList Data Member

Points to the large image list for the outlook bar.

CImageList* m_pLargeImageList;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_pSmallImageList Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_pSmallImageList Data Member

Points to the small image list for the outlook bar.

CImageList* m_pSmallImageList;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_rcDownArrow Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_rcDownArrow Data Member

Size and location of the down scroll arrow.

CRect m_rcDownArrow;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_rcUpArrow Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_rcUpArrow Data Member

Size and location of the up scroll arrow.

CRect m_rcUpArrow;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_sizeMargin Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_sizeMargin Data Member

Amount in pixels of the gap between the border and item text and icon.

CSize m_sizeMargin;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl::m_sizeOffset Data Member

CXTOutBarCtrl Data Members, CXTOutBarCtrl Class
CXTOutBarCtrl::m_sizeOffset Data Member

Amount in pixels of the gap between an item icon and text.

CSize m_sizeOffset;
Group

CXTOutBarCtrl Data Members


CXTOutBarCtrl Methods

CXTOutBarCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrl Methods
Class

CXTOutBarCtrl Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
AnimateFolderScroll | Called by the CXTOutBarCtrl to render folder animation when a new folder is selected.
DrawAnimItem | Called by the CXTOutBarCtrl to render an item animated.
DrawDragArrow | Called by the CXTOutBarCtrl to draw the drag arrow
DrawFolder | Called by the CXTOutBarCtrl to render a folder.
DrawIcon | Called by the CXTOutBarCtrl to render an item's icon.
DrawItem | Called by the CXTOutBarCtrl to draw a folder item.
DrawItemIcon | Called by the CXTOutBarCtrl to draw an item icon.
DrawItemText | Called by the CXTOutBarCtrl to draw an items label.
DrawPreviewBitmap | Called by the CXTOutBarCtrl to render a folder that contains a CWnd object when a new folder is selected.
DrawScrollButton | Called by the CXTOutBarCtrl to draw the up or down scroll button.
EndLabelEdit | Called by the CXTOutBarCtrl to end an item or folder label edit.
GetDragItemRect | Called by the CXTOutBarCtrl to get the size of the item dragged.
GetItemSize | Called by the CXTOutBarCtrl to get the size of a folder item.
GetVisibleRange | Called by the CXTOutBarCtrl to get the area that is visible to the user.
HighlightFolder | Called by the CXTOutBarCtrl to render a folder highlighted.
HighlightItem | Called by the CXTOutBarCtrl to draw an item highlighted.
HitTestEx | Called to determine the item from a given xy coordinate.
IsValidItem | Called to determine if the specified item is valid.
NotifyOwner | This member is called to notify the parent window that an event has occurred in the task panel.
OnLabelChanged | Called by the CXTOutBarCtrl when an item or folders label changes.
PaintItems | Called by the CXTOutBarCtrl to render all items for a folder.
Public Methods
Public Methods
Public Method | Description
AddFolder | Call this member function to add a folder to the Outlook bar control.
AddFolderBar | Call this member function to add a folder with a CWnd child nested inside of it. You can insert a folder with any CWnd object, such as a tree control (see the OutlookBar sample).
Create | Call this member function to create the Outlook bar control.
CreateEx | Call this member function to create the Outlook bar control.
EnableItem | Call this member function to enable or disable a folder item.
GetAnimationTickCount | Call this member function to get the current animation tick count.
GetBarFolder | Call this member function to return a pointer to the CXTOutBarFolder data that is associated with the specified folder.
GetBarFolderItem | Call this member function to return a pointer to the CXTOutBarItem data that is associated with the specified folder and item.
GetCurSel | This member function will return the index of the currently selected item for the currently selected folder.
GetFlag | Call this member function to get the current style set for the Outlook bar.
GetFolderChild | Call this member function to retrieve the CWnd object that has been set for the folder specified by 'iFolder'.
GetFolderCount | This member function will get the total number of folders found in the Outlook bar.
GetFolderData | Call this member function to retrieve the item data that was set for the specified folder.
GetFolderImageList | Call this member function to get a pointer to the image list for the specified folder.
GetFolderRect | Call this member function to retrieve the size of the specified folder.
GetFontX | Call this member function to retrieve the font used by the Outlook bar control.
GetIconRect | Call this member function to retrieve the size of the icon for the specified item.
GetImageList | Call this member function to return the global image list for the OutlookBar control.
GetInsideRect | Call this member function to retrieve the size of the client area for the Outlook bar. This is the inside area that contains the folders.
GetItemCount | This member function gets the number of items found in the currently selected folder.
GetItemData | Call this member function to get the item data (lParam) for the specified item in the currently selected folder.
GetItemImage | Call this member function to retrieve the index of the image associated with the specified item in the currently selected folder.
GetItemRect | Call this member function to retrieve the size of the specified item. The size includes the area occupied by the item's label and icon.
GetItemText | Call this member function to get the text of the specified item for the currently selected folder.
GetLabelRect | Call this member function to retrieve the size of the label for the specified item.
GetSelFolder | This member function will get the index of the currently selected folder.
InsertItem | Call this member function to insert an item into the specified folder.
IsSmallIconView | Call this member function to return the current state of the icon display for the Outlook bar control.
ModifyFlag | Call this member function to modify an Outlook bar style.
RemoveAllItems | Call this member function to remove all items from the folder specified by 'iFolder'.
RemoveFolder | Call this member function to remove the specified folder and its items.
RemoveItem | Call this member function to remove the specified item from the currently selected folder.
SetAnimationTickCount | Call this member function to set the tick count, in milliseconds, between each animation frame in folder scrolling. If you set a value of -1, or minor, no animation will be played. Animation requires the OBS_XT_ANIMATION flag be set.
SetAnimSelHighlight | Call this member function to set an animation effect for the currently selected item. It is not to be used with OBS_XT_SELHIGHLIGHT flag.
SetBackColor | Call this member function to set the background color for the Outlook bar control.
SetCurSel | This member function will set the currently selected item for the currently selected folder.
SetFolderImageList | Call this member function to set the image list for the specified folder.
SetFolderText | Call this member function to set the text label for the specified folder.
SetFontX | Call this member function to set the font used by the Outlook bar control.
SetImageList | This member function will set the main image list. You can link different image lists to the folders using the SetFolderImageList function. If a folder has been linked to an image list with the SetFolderImageList function, it will own the linked image list. Otherwise, it will use the image list set with this function.
SetItemData | Call this member function to set the item data (lParam) for the specified item in the currently selected folder.
SetItemImage | Call this member function to set the image index, in the image list, for the 'iIndex' item of the currently selected folder.
SetItemText | Call this member function to set the text for the specified item in the currently selected folder.
SetSelFolder | This member function will set the selected folder for the Outlook bar.
SetSelItem | This member function will set the selected folder and item for the Outlook bar.
SetSmallIconView | Call this member function to set the size of the icons displayed in the Outlook bar control for the specified folder.
SetTextColor | Call this member function to set the text color for items in the Outlook bar control.
StartGroupEdit | Call this member function to begin editing of the specified folder item's label.
StartItemEdit | Call this member function to begin local editing of the specified item in the currently selected folder.


CXTOutBarCtrl::AddFolder Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::AddFolder Method

Call this member function to add a folder to the Outlook bar control.

virtual int AddFolder(
    LPCTSTR lpszFolderName,
    const DWORD dwData
);
Parameters

lpszFolderName
A NULL terminated string that represents the folder's label.
dwData
User defined item data for the folder.

Returns

The index of the newly inserted folder.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::AddFolderBar Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::AddFolderBar Method

Call this member function to add a folder with a CWnd child nested inside of it. You can insert a folder with any CWnd object, such as a tree control (see the OutlookBar sample).

virtual int AddFolderBar(
    LPCTSTR lpszFolderName,
    CWnd* pWndChild,
    const DWORD dwData = 0
);
Parameters

lpszFolderName
Name of the folder to add.
pWndChild
Points to a valid CWnd object. The object must be created before inserting.
dwData
Item data (lParam) for the folder.

Returns

The integer value that represents the index of the added folder.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::AnimateFolderScroll Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::AnimateFolderScroll Method

Called by the CXTOutBarCtrl to render folder animation when a new folder is selected.

virtual void AnimateFolderScroll(
    const int iFrom,
    const int iTo
);
Parameters

iFrom
Index of currently selected folder.
iTo
Index of the new folder to select.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::Create Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, See Also
CXTOutBarCtrl::Create Method

Call this member function to create the Outlook bar control.

virtual BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID,
    const DWORD dwFlag = OBS_XT_DEFAULT
);
Parameters

dwStyle
Style for the Outlook bar. It usually includes the WS_CHILD | WS_VISIBLE flags.
rect
Size of the Outlook bar.
pParentWnd
Parent of the control.
nID
Identifier of the Outlook bar control.
dwFlag
Specifies the style flags for the control. See ModifyFlag for a list of available styles.

Returns

TRUE if successful, otherwise returns FALSE.

See Also

CreateEx, ModifyFlag

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::CreateEx Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, See Also
CXTOutBarCtrl::CreateEx Method

Call this member function to create the Outlook bar control.

virtual BOOL CreateEx(
    DWORD dwExStyle,
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID,
    const DWORD dwFlag = OBS_XT_DEFAULT
);
Parameters

dwExStyle
Extended style for the Outlook bar such as WS_EX_STATICEDGE. It can be NULL.
dwStyle
Style for the Outlook bar. It usually includes the WS_CHILD | WS_VISIBLE flags.
rect
Size of the Outlook bar.
pParentWnd
Parent of the control.
nID
Identifier of the Outlook bar control.
dwFlag
Specifies the style flags for the control. See ModifyFlag for a list of available styles.

Returns

TRUE if successful, otherwise returns FALSE.

See Also

Create, ModifyFlag

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawAnimItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::DrawAnimItem Method

Called by the CXTOutBarCtrl to render an item animated.

virtual void DrawAnimItem(
    const int iOffsetX,
    const int iOffsetY,
    const int iIndex
);
Parameters

iOffsetX
X distance to offset icon animation.
iOffsetY
Y distance to offset icon animation.
iIndex
Index of item to animate.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawDragArrow Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::DrawDragArrow Method

Called by the CXTOutBarCtrl to draw the drag arrow

virtual void DrawDragArrow(
    CDC* pDC,
    const int iFrom,
    const int iTo
);
Parameters

pDC
Pointer to a valid device context.
iFrom
Index of the item before the arrow.
iTo
Index of the item after the arrow.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawFolder Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, See Also
CXTOutBarCtrl::DrawFolder Method

Called by the CXTOutBarCtrl to render a folder.

virtual void DrawFolder(
    CDC* pDC,
    const int iIndex,
    CRect rect,
    const XTMouseState eHilight
);
Parameters

pDC
Pointer to a valid device context.
iIndex
Index of the folder to render.
rect
Size of the area to render.
eHilight
Current mouse over state.

See Also

XTMouseState

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawIcon Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::DrawIcon Method

Called by the CXTOutBarCtrl to render an item's icon.

virtual void DrawIcon(
    CDC* pDC,
    int iIcon,
    int iFolder,
    bool bHilight
);
Parameters

pDC
Pointer to a valid device context.
iIcon
Index of the icon to render.
iFolder
Index of the parent folder.
bHilight
true if the icon is highlighted.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::DrawItem Method

Called by the CXTOutBarCtrl to draw a folder item.

virtual void DrawItem(
    CDC* pDC,
    const int iFolder,
    CRect rc,
    const int iIndex,
    const BOOL bOnlyImage = false
);
Parameters

pDC
Pointer to a valid device context.
iFolder
Index of the parent folder.
rc
Size of the area to render.
iIndex
Index of the item to render.
bOnlyImage
TRUE if only the image is to be drawn.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawItemIcon Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::DrawItemIcon Method

Called by the CXTOutBarCtrl to draw an item icon.

virtual void DrawItemIcon(
    CDC* pDC,
    CPoint pt,
    CXTOutBarItem* pBarItem,
    CImageList* pImageList
);
Parameters

pDC
Pointer to a valid device context.
pt

  • location of the icon to render.

pBarItem
Pointer to a CXTOutBarItem object.
pImageList
Pointer to the CXTOutBarCtrl image list.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawItemText Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::DrawItemText Method

Called by the CXTOutBarCtrl to draw an items label.

virtual void DrawItemText(
    CDC* pDC,
    CRect rc,
    CXTOutBarItem* pBarItem,
    UINT nFormat
);
Parameters

pDC
Pointer to a valid device context.
rc
Size of text to render.
pBarItem
Pointer to a CXTOutBarItem object.
nFormat
Draw text flags, see CXTOutBarCtrlTheme::DrawItemText.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawPreviewBitmap Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::DrawPreviewBitmap Method

Called by the CXTOutBarCtrl to render a folder that contains a CWnd object when a new folder is selected.

void DrawPreviewBitmap(
    CWnd* pWnd,
    CDC* pDC,
    int nOffset
);
Parameters

pWnd
Pointer to the child of the folder.
pDC
Pointer to a valid device context.
nOffset
Amount in pixels to offset from the top.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::DrawScrollButton Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::DrawScrollButton Method

Called by the CXTOutBarCtrl to draw the up or down scroll button.

virtual void DrawScrollButton(
    CDC* pDC,
    CRect rect,
    UINT uType,
    UINT uState
);
Parameters

pDC
Pointer to a valid device context.
rect
Size of area to render.
uType
Specifies the type of frame control to draw. See the uType parameter in DrawFrameControl in the Platform SDK for a list of this parameter's possible values.
uState
Specifies the initial state of the frame control. Can be one or more of the values described for the uState parameter in DrawFrameControl in the Platform SDK. Use the nState value DFCS_ADJUSTRECT to adjust the bounding rectangle to exclude the surrounding edge of the push button.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::EnableItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::EnableItem Method

Call this member function to enable or disable a folder item.

void EnableItem(
    int iFolder,
    int iItem,
    bool bEnable
);
Parameters

iFolder
Index of the folder that owns the item.
iItem
Index of the item to enable or disable.
bEnable
true to enable item, false to disable.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::EndLabelEdit Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::EndLabelEdit Method

Called by the CXTOutBarCtrl to end an item or folder label edit.

virtual void EndLabelEdit(
    CXTOutBarEditItem* pEdit,
    bool bIsFolder
);
Parameters

pEdit
Pointer to the edit control.
bIsFolder
true if the item edited is a folder.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetAnimationTickCount Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, Body Source
CXTOutBarCtrl::GetAnimationTickCount Method

Call this member function to get the current animation tick count.

virtual int GetAnimationTickCount();
Returns

An integer value representing the current tick count.

Body Source
int CXTOutBarCtrl::GetAnimationTickCount() {
    return m_nAnimationTickCount;
}
Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetBarFolder Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, Body Source
CXTOutBarCtrl::GetBarFolder Method

Call this member function to return a pointer to the CXTOutBarFolder data that is associated with the specified folder.

virtual CXTOutBarFolder* GetBarFolder(
    const int iFolder
);
Parameters

iFolder
Index of the folder to retrieve.

Returns

A pointer to a CXTOutBarFolder object.

Body Source
CXTOutBarFolder* CXTOutBarCtrl::GetBarFolder(const int iFolder) {
    return (CXTOutBarFolder*)m_arFolder.GetAt(iFolder);
}
Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetBarFolderItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, Body Source
CXTOutBarCtrl::GetBarFolderItem Method

Call this member function to return a pointer to the CXTOutBarItem data that is associated with the specified folder and item.

virtual CXTOutBarItem* GetBarFolderItem(
    const int iFolder,
    const int iIndex
);
Parameters

iFolder
Index of the folder to retrieve.
iIndex
Index of the item to retrieve.

Returns

A pointer to a CXTOutBarItem object.

Body Source
CXTOutBarItem* CXTOutBarCtrl::GetBarFolderItem(const int iFolder, const int iIndex) {
    return GetBarFolder(iFolder)->GetItemAt(iIndex);
}
Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetCurSel Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, Body Source
CXTOutBarCtrl::GetCurSel Method

This member function will return the index of the currently selected item for the currently selected folder.

int GetCurSel();
Returns

An integer value representing the index of the selected item.

Body Source
int CXTOutBarCtrl::GetCurSel() {
    return m_nItemHilighted;
}
Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetDragItemRect Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetDragItemRect Method

Called by the CXTOutBarCtrl to get the size of the item dragged.

virtual int GetDragItemRect(
    const int iIndex,
    CRect& rect
);
Parameters

iIndex
Index of the item
rect
Size of the item dragged.

Returns

Style of last drag item that was rendered.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetFlag Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, See Also
CXTOutBarCtrl::GetFlag Method

Call this member function to get the current style set for the Outlook bar.

virtual DWORD GetFlag() const;
Returns

A DWORD value representing the current style of the Outlook bar.

Remarks

See ModifyFlag for a list of available styles.

See Also

ModifyFlag, Create, CreateEx

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetFolderChild Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetFolderChild Method

Call this member function to retrieve the CWnd object that has been set for the folder specified by 'iFolder'.

virtual CWnd* GetFolderChild(
    int iFolder = -1
);
Parameters

iFolder
Index of the folder to retrieve the CWnd object for, if -1 the currently selected folder CWnd object is used.

Returns

If 'iFolder' is -1, the child of the currently selected folder is returned. If no object has been set for the folder, the return value is NULL.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetFolderCount Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetFolderCount Method

This member function will get the total number of folders found in the Outlook bar.

virtual int GetFolderCount() const;
Returns

An integer value representing the number of folders in the Outlook bar.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetFolderData Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetFolderData Method

Call this member function to retrieve the item data that was set for the specified folder.

virtual DWORD GetFolderData(
    int iFolder = -1
);
Parameters

iFolder
The index of the folder to retrieve item data for. If -1, the currently selected folder item data is returned.

Returns

A DWORD value.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetFolderImageList Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetFolderImageList Method

Call this member function to get a pointer to the image list for the specified folder.

virtual CImageList* GetFolderImageList(
    const int iIndex,
    const BOOL bSmall
) const;
Parameters

iIndex
Index of the folder to retrieve the image list for.
bSmall
TRUE to return the small image list. FALSE to return the large image list.

Returns

A CImageList pointer representing the image list for the folder specified by 'iIndex'.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetFolderRect Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetFolderRect Method

Call this member function to retrieve the size of the specified folder.

virtual BOOL GetFolderRect(
    const int iIndex,
    CRect& rect
) const;
Parameters

iIndex
Index of the folder item.
rect
Address of a CRect object that will receive the folder size.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetFontX Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, Body Source
CXTOutBarCtrl::GetFontX Method

Call this member function to retrieve the font used by the Outlook bar control.

virtual CFont* GetFontX();
Returns

A pointer to a CFont object representing the font used by the Outlook bar control.

Body Source
CFont* CXTOutBarCtrl::GetFontX() {
    return &m_font;
}
Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetIconRect Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetIconRect Method

Call this member function to retrieve the size of the icon for the specified item.

virtual void GetIconRect(
    const int iFolder,
    const int iIndex,
    CRect& rect,
    CRect* pInsideRect = NULL
);
Parameters

iFolder
Index of the folder where the item is located.
iIndex
Index of the item.
rect
Address of a CRect object that will receive the icon size.
pInsideRect
Pointer to a CRect object that represents the size of the client area for the Outlook bar. If NULL GetInsideRect will be used to determine the client area size.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetImageList Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetImageList Method

Call this member function to return the global image list for the OutlookBar control.

virtual CImageList* GetImageList(
    DWORD dwImageList
);
Parameters

dwImageList
If OBS_XT_SMALLICON, the small image list is returned; if OBS_XT_LARGEICON, the large image list is returned.

Returns

A CImageList pointer representing the global image list for the OutlookBar control.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetInsideRect Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetInsideRect Method

Call this member function to retrieve the size of the client area for the Outlook bar. This is the inside area that contains the folders.

virtual void GetInsideRect(
    CRect& rect
) const;
Parameters

rect
Address of a CRect object that will receive the size.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetItemCount Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetItemCount Method

This member function gets the number of items found in the currently selected folder.

virtual int GetItemCount() const;
Returns

An integer value representing the number of items in the current folder.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetItemData Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetItemData Method

Call this member function to get the item data (lParam) for the specified item in the currently selected folder.

virtual DWORD GetItemData(
    const int iIndex
) const;
Parameters

iIndex
Index of the item to retrieve item data for.

Returns

A DWORD value.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetItemImage Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetItemImage Method

Call this member function to retrieve the index of the image associated with the specified item in the currently selected folder.

virtual int GetItemImage(
    const int iIndex
) const;
Parameters

iIndex
Index of the item to retrieve the image index for.

Returns

An integer value that represents the index of the desired image.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetItemRect Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetItemRect Method

Call this member function to retrieve the size of the specified item. The size includes the area occupied by the item's label and icon.

virtual void GetItemRect(
    const int iFolder,
    const int iIndex,
    CRect& rect,
    CRect* pInsideRect = NULL
);
Parameters

iFolder
Index of the folder where the item is located.
iIndex
Index of the item.
rect
Address of a CRect object that will receive the icon size.
pInsideRect
Pointer to a CRect object that represents the size of the client area for the Outlook bar. If NULL GetInsideRect will be used to determine the client area size.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetItemSize Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetItemSize Method

Called by the CXTOutBarCtrl to get the size of a folder item.

virtual CSize GetItemSize(
    const int iFolder,
    const int iIndex,
    const RectItem iType
);
Parameters

iFolder
Index of parent folder.
iIndex
Index of item.
iType
The pare of the item to get the size for.

Returns

A CSize object representing the item size.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetItemText Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetItemText Method

Call this member function to get the text of the specified item for the currently selected folder.

virtual CString GetItemText(
    const int iIndex
);
Parameters

iIndex
Index of the item to retrieve the text for.

Returns

A CString object containing the retrieved text.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetLabelRect Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetLabelRect Method

Call this member function to retrieve the size of the label for the specified item.

virtual void GetLabelRect(
    const int iFolder,
    const int iIndex,
    CRect& rect
);
Parameters

iFolder
Index of the folder where the item is located.
iIndex
Index of the item.
rect
Address of a CRect object that will receive the label size.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetSelFolder Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetSelFolder Method

This member function will get the index of the currently selected folder.

virtual int GetSelFolder() const;
Returns

An integer value representing the index of the currently selected folder.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::GetVisibleRange Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::GetVisibleRange Method

Called by the CXTOutBarCtrl to get the area that is visible to the user.

virtual void GetVisibleRange(
    const int iFolder,
    int& iFirst,
    int& iLast
);
Parameters

iFolder
[in] Index of the folder to get the range for.
iFirst
[out] Index of the first item that is visible.
iLast
[out] Index of the last item that is visible.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::HighlightFolder Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::HighlightFolder Method

Called by the CXTOutBarCtrl to render a folder highlighted.

virtual void HighlightFolder(
    CDC* pDC,
    const int iIndex
);
Parameters

pDC
Pointer to a valid device context.
iIndex
Index of the folder to highlight.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::HighlightItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::HighlightItem Method

Called by the CXTOutBarCtrl to draw an item highlighted.

virtual void HighlightItem(
    CDC* pDC,
    const int iIndex,
    const BOOL bPressed = false
);
Parameters

pDC
Pointer to a valid device context.
iIndex
Index of the item to render.
bPressed
TRUE if the item is selected.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::HitTestEx Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::HitTestEx Method

Called to determine the item from a given xy coordinate.

virtual HitTestCode HitTestEx(
    const CPoint& point,
    int& iIndex
);
Parameters

point
[in] xy coordinate to test.
iIndex
[out] Index of the item at the given xy coordinates.

Returns

Item type see HitTestCode.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::InsertItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::InsertItem Method

Call this member function to insert an item into the specified folder.

virtual int InsertItem(
    const int iFolder,
    const int iIndex,
    LPCTSTR lpszItemName,
    const int iImage = -1,
    const DWORD dwData = 0
);
Parameters

iFolder
Index of the folder to insert the item into.
iIndex
Index or position of the item to insert into the folder.
lpszItemName
A NULL terminated string that represents the item label. This value cannot be set to NULL.
iImage
Index into the folder's image list.
dwData
User defined item data that you can assign to the item. Use GetItemData and SetItemData to access and change this data.

Returns

The index of the newly inserted item.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::IsSmallIconView Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::IsSmallIconView Method

Call this member function to return the current state of the icon display for the Outlook bar control.

virtual BOOL IsSmallIconView(
    const int iFolder = -1
) const;
Parameters

iFolder
Index of the folder to check. If -1, the currently selected folder is checked.

Returns

TRUE if small icons are displayed, and FALSE if large icons are displayed.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::IsValidItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::IsValidItem Method

Called to determine if the specified item is valid.

virtual BOOL IsValidItem(
    const int iIndex
) const;
Parameters

iIndex
Index of the item to test.

Returns

TRUE if the item is valid, otherwise FALSE.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::ModifyFlag Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, See Also
CXTOutBarCtrl::ModifyFlag Method

Call this member function to modify an Outlook bar style.

virtual void ModifyFlag(
    const DWORD& dwRemove,
    const DWORD& dwAdd,
    const bool bRedraw = false
);
Parameters

dwRemove
Specifies OBS_XT_ styles to be removed during style modification.
dwAdd
Specifies OBS_XT_ styles to be added during style modification.
bRedraw
true to redraw the Outlook bar.

Remarks

Call this member function to modify an Outlook bar style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.

The desired styles for the Outlook bar can be one or more of the following:

  • OBS_XT_SMALLICON Sets small icon mode.
  • OBS_XT_LARGEICON Sets large icon mode.
  • OBS_XT_EDITGROUPS Enables folder local editing (renaming).
  • OBS_XT_EDITITEMS Enables item local editing (renaming).
  • OBS_XT_REMOVEGROUPS Enables the "Remove" command for folders in context menu.
  • OBS_XT_REMOVEITEMS Enables the "Remove" command for items in context menu.
  • OBS_XT_ADDGROUPS Enables folder insertion.
  • OBS_XT_DRAGITEMS Enables item dragging to rearrange position.
  • OBS_XT_ANIMATION Enables animation while changing folder selection.
  • OBS_XT_SELHIGHLIGHT Enables dimmed highlight of last pressed item.
  • OBS_XT_DEFAULT Same as (OBS_XT_DRAGITEMS | OBS_XT_EDITGROUPS | OBS_XT_EDITITEMS | OBS_XT_REMOVEGROUPS | OBS_XT_REMOVEITEMS | OBS_XT_ADDGROUPS).
See Also

GetFlag, Create, CreateEx

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::NotifyOwner Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::NotifyOwner Method

This member is called to notify the parent window that an event has occurred in the task panel.

virtual LRESULT NotifyOwner(
    UINT nCode,
    XT_OUTBAR_INFO* pobi
);
Parameters

nCode
Specifies which event has occurred.
pobi
Additional message-specific information.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::OnLabelChanged Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::OnLabelChanged Method

Called by the CXTOutBarCtrl when an item or folders label changes.

virtual void OnLabelChanged(
    const XT_OUTBAR_INFO* pObi
);
Parameters

pObi
Pointer to a XT_OUTBAR_INFO structure.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::PaintItems Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::PaintItems Method

Called by the CXTOutBarCtrl to render all items for a folder.

virtual void PaintItems(
    CDC* pDC,
    const int iFolder,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
iFolder
Index of the parent folder.
rc
Size of area to render.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::RemoveAllItems Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::RemoveAllItems Method

Call this member function to remove all items from the folder specified by 'iFolder'.

virtual void RemoveAllItems(
    int iFolder,
    bool bNofify = false
);
Parameters

iFolder
Index of the folder to insert the item into.
bNofify
true to send an XTWM_OUTBAR_NOTIFY message.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::RemoveFolder Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::RemoveFolder Method

Call this member function to remove the specified folder and its items.

virtual void RemoveFolder(
    const int iIndex
);
Parameters

iIndex
Index of the folder to remove.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::RemoveItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::RemoveItem Method

Call this member function to remove the specified item from the currently selected folder.

virtual void RemoveItem(
    const int iIndex
);
Parameters

iIndex
Index of the item to remove.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetAnimationTickCount Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, Body Source
CXTOutBarCtrl::SetAnimationTickCount Method

Call this member function to set the tick count, in milliseconds, between each animation frame in folder scrolling. If you set a value of -1, or minor, no animation will be played. Animation requires the OBS_XT_ANIMATION flag be set.

virtual void SetAnimationTickCount(
    const long lValue
);
Parameters

lValue
Specifies the time in milliseconds between animation. A value of -1 will disable animation playback.

Body Source
void CXTOutBarCtrl::SetAnimationTickCount(const long lValue) {
    m_nAnimationTickCount = lValue;
}
Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetAnimSelHighlight Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetAnimSelHighlight Method

Call this member function to set an animation effect for the currently selected item. It is not to be used with OBS_XT_SELHIGHLIGHT flag.

virtual void SetAnimSelHighlight(
    const int iTime
);
Parameters

iTime
Specifies the time in milliseconds that the selected item will animate.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetBackColor Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetBackColor Method

Call this member function to set the background color for the Outlook bar control.

virtual void SetBackColor(
    COLORREF clrBack
);
Parameters

clrBack
An RGB value that represents the background color.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetCurSel Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, Body Source
CXTOutBarCtrl::SetCurSel Method

This member function will set the currently selected item for the currently selected folder.

void SetCurSel(
    int iItem,
    const BOOL bPressed = false
);
Parameters

iItem
Index of the item to select.
bPressed
true if the item is to be pressed when selected.

Body Source
void CXTOutBarCtrl::SetCurSel(int iItem, const BOOL bPressed/*=false*/) {
    HighlightItem(NULL, iItem, bPressed);
}
Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetFolderImageList Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetFolderImageList Method

Call this member function to set the image list for the specified folder.

virtual CImageList* SetFolderImageList(
    const int iFolder,
    CImageList* pImageList,
    DWORD dwImageList
);
Parameters

iFolder
Index of the folder to set the image list for.
pImageList
Points to the new image list.
dwImageList
If OBS_XT_SMALLICON, the small image list is set, if OBS_XT_LARGEICON, the large image list is set.

Returns

A pointer to the previously set image list, or NULL if no previous image list exists.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetFolderText Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetFolderText Method

Call this member function to set the text label for the specified folder.

virtual void SetFolderText(
    const int iIndex,
    LPCTSTR lpszFolderName
);
Parameters

iIndex
Index of the folder to set the text label for.
lpszFolderName
Points to a NULL terminated string.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetFontX Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class, Body Source
CXTOutBarCtrl::SetFontX Method

Call this member function to set the font used by the Outlook bar control.

virtual void SetFontX(
    CFont* pFont
);
Parameters

pFont
Points to the font to be used by the Outlook bar.

Body Source
void CXTOutBarCtrl::SetFontX(CFont* pFont) {
    ASSERT_VALID(pFont); LOGFONT lf; pFont->GetLogFont(&lf); m_font.DeleteObject(); m_font.CreateFontIndirect(&lf);
}
Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetImageList Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetImageList Method

This member function will set the main image list. You can link different image lists to the folders using the SetFolderImageList function. If a folder has been linked to an image list with the SetFolderImageList function, it will own the linked image list. Otherwise, it will use the image list set with this function.

virtual CImageList* SetImageList(
    CImageList* pImageList,
    DWORD dwImageList
);
Parameters

pImageList
Points to the new image list.
dwImageList
If OBS_XT_SMALLICON, the small image list is set; if OBS_XT_LARGEICON, the large image list is set.

Returns

A pointer to the previously set image list, or NULL if no previous image list exists.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetItemData Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetItemData Method

Call this member function to set the item data (lParam) for the specified item in the currently selected folder.

virtual void SetItemData(
    const int iIndex,
    const DWORD dwData
);
Parameters

iIndex
Index of the item to set item data for.
dwData
Item data (lParam) to set.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetItemImage Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetItemImage Method

Call this member function to set the image index, in the image list, for the 'iIndex' item of the currently selected folder.

virtual void SetItemImage(
    const int iIndex,
    const int iImage
);
Parameters

iIndex
Index of the item in the currently selected folder.
iImage
Index of the image, in the image list, to use for the specified item.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetItemText Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetItemText Method

Call this member function to set the text for the specified item in the currently selected folder.

virtual void SetItemText(
    const int iIndex,
    LPCTSTR lpszItemName
);
Parameters

iIndex
Index of the item to set the text for.
lpszItemName
Points to a NULL terminated string.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetSelFolder Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetSelFolder Method

This member function will set the selected folder for the Outlook bar.

virtual void SetSelFolder(
    const int iIndex
);
Parameters

iIndex
Index of the new selected folder.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetSelItem Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetSelItem Method

This member function will set the selected folder and item for the Outlook bar.

virtual void SetSelItem(
    int iFolder,
    int iItem,
    BOOL bEnsureVisible = TRUE
);
Parameters

iFolder
Index of the folder that contains the new selection.
iItem
Index of the new item to select.
bEnsureVisible
TRUE to ensure the item is visible when selected.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetSmallIconView Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetSmallIconView Method

Call this member function to set the size of the icons displayed in the Outlook bar control for the specified folder.

virtual void SetSmallIconView(
    const BOOL bSet,
    const int iFolder = -1
);
Parameters

bSet
TRUE to display small icons, or FALSE to display large icons.
iFolder
Index of the folder to set the icon size for. If -1, all folder icons are set.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::SetTextColor Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::SetTextColor Method

Call this member function to set the text color for items in the Outlook bar control.

virtual void SetTextColor(
    COLORREF clrText
);
Parameters

clrText
An RGB value that represents the text item color.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::StartGroupEdit Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::StartGroupEdit Method

Call this member function to begin editing of the specified folder item's label.

virtual void StartGroupEdit(
    const int iIndex
);
Parameters

iIndex
Index of the folder to begin editing.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl::StartItemEdit Method

CXTOutBarCtrl Methods, CXTOutBarCtrl Class
CXTOutBarCtrl::StartItemEdit Method

Call this member function to begin local editing of the specified item in the currently selected folder.

virtual void StartItemEdit(
    const int iIndex
);
Parameters

iIndex
Index of the item to begin editing for.

Group

CXTOutBarCtrl Methods


CXTOutBarCtrl Constructors

CXTOutBarCtrl Class, Legend, Public Methods
CXTOutBarCtrl Constructors
Class

CXTOutBarCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarCtrl | Constructs a CXTOutBarCtrl object


CXTOutBarCtrl::CXTOutBarCtrl Constructor

CXTOutBarCtrl Constructors, CXTOutBarCtrl Class
CXTOutBarCtrl::CXTOutBarCtrl Constructor

Constructs a CXTOutBarCtrl object

CXTOutBarCtrl();
Group

CXTOutBarCtrl Constructors


CXTOutBarCtrl Destructors

CXTOutBarCtrl Class, Legend, Public Methods
CXTOutBarCtrl Destructors
Class

CXTOutBarCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTOutBarCtrl | Destroys a CXTOutBarCtrl object, handles cleanup and deallocation


CXTOutBarCtrl::~CXTOutBarCtrl Destructor

CXTOutBarCtrl Destructors, CXTOutBarCtrl Class
CXTOutBarCtrl::~CXTOutBarCtrl Destructor

Destroys a CXTOutBarCtrl object, handles cleanup and deallocation

virtual ~CXTOutBarCtrl();
Group

CXTOutBarCtrl Destructors


CXTOutBarCtrlTheme Class

XTOutBarCtrlTheme.h, Classes, Legend, Members, Topics, CXTOutBarCtrlTheme Data Members, CXTOutBarCtrlTheme Methods, CXTOutBarCtrlTheme Constructors, CXTOutBarCtrlTheme Destructors, CXTOutBarCtrlTheme Constructors, CXTOutBarCtrlTheme Data Members, CXTOutBarCtrlTheme Destructors, CXTOutBarCtrlTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlTheme Class

CXTOutBarCtrlTheme is used to draw the CXTOutBarCtrl object. All themes used for CXTOutBarCtrl should inherit from this base class.

Class Hierarchy

class CXTOutBarCtrlTheme : public CXTThemeManagerStyle;
File

XTOutBarCtrlTheme.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTOutBarCtrlTheme Constructors
CXTOutBarCtrlTheme Constructors | Description
CXTOutBarCtrlTheme | Constructs a CXTOutBarCtrlTheme object.
CXTOutBarCtrlTheme Data Members
CXTOutBarCtrlTheme Data Members | Description
m_bFlatIcon | Set this to TRUE to draw flat icons.
m_bPlainText | Set to TRUE to draw plain text.
m_clrBack | The color used to draw the background of the OutBar.
m_clrText | The color used to draw the text on the OutBar.
CXTOutBarCtrlTheme Destructors
CXTOutBarCtrlTheme Destructors | Description
~CXTOutBarCtrlTheme | Destroys a CXTOutBarCtrlTheme object, handles cleanup and deallocation.
CXTOutBarCtrlTheme Methods
CXTOutBarCtrlTheme Methods | Description
DrawFolder | Call this function to draw the folder on the OutBar. The folder can be drawn in any one of three states, normal, selected, and highlighted.
DrawIconFrame | Call this function to draw a 3D rectangle around an icon.
DrawItemIcon | Call this function to draw the icon associated with the pBarItem.
DrawItemText | Call this function to draw text associated with the item in the OutBar.
FillInsideRect | Call this function to draw a filled rectangle specified at position rc.
RefreshMetrics | Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.
SetFont | Set the font used by the OutBar.


CXTOutBarCtrlTheme Data Members

CXTOutBarCtrlTheme Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlTheme Data Members
Class

CXTOutBarCtrlTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bFlatIcon | Set this to TRUE to draw flat icons.
m_bPlainText | Set to TRUE to draw plain text.
Public Data Members
Public Data Member | Description
m_clrBack | The color used to draw the background of the OutBar.
m_clrText | The color used to draw the text on the OutBar.


CXTOutBarCtrlTheme::m_bFlatIcon Data Member

CXTOutBarCtrlTheme Data Members, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::m_bFlatIcon Data Member

Set this to TRUE to draw flat icons.

BOOL m_bFlatIcon;
Group

CXTOutBarCtrlTheme Data Members


CXTOutBarCtrlTheme::m_bPlainText Data Member

CXTOutBarCtrlTheme Data Members, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::m_bPlainText Data Member

Set to TRUE to draw plain text.

BOOL m_bPlainText;
Group

CXTOutBarCtrlTheme Data Members


CXTOutBarCtrlTheme::m_clrBack Data Member

CXTOutBarCtrlTheme Data Members, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::m_clrBack Data Member

The color used to draw the background of the OutBar.

CXTPPaintManagerColor m_clrBack;
Group

CXTOutBarCtrlTheme Data Members


CXTOutBarCtrlTheme::m_clrText Data Member

CXTOutBarCtrlTheme Data Members, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::m_clrText Data Member

The color used to draw the text on the OutBar.

CXTPPaintManagerColor m_clrText;
Group

CXTOutBarCtrlTheme Data Members


CXTOutBarCtrlTheme Methods

CXTOutBarCtrlTheme Class, Legend, Public Methods
CXTOutBarCtrlTheme Methods
Class

CXTOutBarCtrlTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawFolder | Call this function to draw the folder on the OutBar. The folder can be drawn in any one of three states, normal, selected, and highlighted.
DrawIconFrame | Call this function to draw a 3D rectangle around an icon.
DrawItemIcon | Call this function to draw the icon associated with the pBarItem.
DrawItemText | Call this function to draw text associated with the item in the OutBar.
FillInsideRect | Call this function to draw a filled rectangle specified at position rc.
RefreshMetrics | Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.
SetFont | Set the font used by the OutBar.


CXTOutBarCtrlTheme::DrawFolder Method

CXTOutBarCtrlTheme Methods, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::DrawFolder Method

Call this function to draw the folder on the OutBar. The folder can be drawn in any one of three states, normal, selected, and highlighted.

virtual void DrawFolder(
    CDC* pDC,
    CRect rect,
    CXTOutBarFolder* pBarFolder,
    const XTMouseState eHilight
);
Parameters

pDC
A CDC pointer that represents the current device context.
rect
A CRect object that specifies the XY location of the folder.
pBarFolder
A CXTOutBarFolder object that maintains information about the folder.
eHilight
An int that specifies the height of the folder. The possible values are: xtMouseNormal, xtMouseSelect, and xtMouseHover.

Group

CXTOutBarCtrlTheme Methods


CXTOutBarCtrlTheme::DrawIconFrame Method

CXTOutBarCtrlTheme Methods, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::DrawIconFrame Method

Call this function to draw a 3D rectangle around an icon.

virtual void DrawIconFrame(
    CDC* pDC,
    CRect rcIcon,
    BOOL bSelected,
    BOOL bPressed
);
Parameters

pDC
A CDC pointer that represents the current device context.
rcIcon
A CRect object that specifies the XY location of the icon.
bSelected
TRUE if the icon is currently selected. FALSE otherwise.
bPressed
TRUE if the icon is pressed. FALSE otherwise.

Group

CXTOutBarCtrlTheme Methods


CXTOutBarCtrlTheme::DrawItemIcon Method

CXTOutBarCtrlTheme Methods, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::DrawItemIcon Method

Call this function to draw the icon associated with the pBarItem.

virtual void DrawItemIcon(
    CDC* pDC,
    CPoint pt,
    CXTOutBarItem* pBarItem,
    CImageList* pImageList
);
Parameters

pDC
A CDC pointer that represents the current device context.
pt
A CPoint object that specifies the XY location of the icon.
pBarItem
A pointer to a CXTOutBarItem object. Used to maintain information about the folder item.
pImageList
A pointer to a CImageList object. Used to store the icons that are displayed in the folder.

Group

CXTOutBarCtrlTheme Methods


CXTOutBarCtrlTheme::DrawItemText Method

CXTOutBarCtrlTheme Methods, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::DrawItemText Method

Call this function to draw text associated with the item in the OutBar.

virtual void DrawItemText(
    CDC* pDC,
    CRect rc,
    CXTOutBarItem* pBarItem,
    UINT nFormat
);
Parameters

pDC
A CDC pointer that represents the current device context.
rc
A CRect object. Used to specify the XY position of where the text is drawn.
pBarItem
A pointer to a CXTOutBarItem object. Used to maintain information about the folder item. Contains the text to draw.
nFormat
The method of formatting the text. Can be any valid formatting used for the MFC CDC::DrawText function.

Group

CXTOutBarCtrlTheme Methods


CXTOutBarCtrlTheme::FillInsideRect Method

CXTOutBarCtrlTheme Methods, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::FillInsideRect Method

Call this function to draw a filled rectangle specified at position rc.

virtual void FillInsideRect(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
A CDC pointer that represents the current device context.
rc
A CRect object. Used to specify the XY position of where the rectangle is drawn.

Group

CXTOutBarCtrlTheme Methods


CXTOutBarCtrlTheme::RefreshMetrics Method

CXTOutBarCtrlTheme Methods, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::RefreshMetrics Method

Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.

virtual void RefreshMetrics();
Group

CXTOutBarCtrlTheme Methods


CXTOutBarCtrlTheme::SetFont Method

CXTOutBarCtrlTheme Methods, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::SetFont Method

Set the font used by the OutBar.

void SetFont(
    CFont* pFont
);
Parameters

pFont
A pointer to a CFont object.

Group

CXTOutBarCtrlTheme Methods


CXTOutBarCtrlTheme Constructors

CXTOutBarCtrlTheme Class, Legend, Public Methods
CXTOutBarCtrlTheme Constructors
Class

CXTOutBarCtrlTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarCtrlTheme | Constructs a CXTOutBarCtrlTheme object.


CXTOutBarCtrlTheme::CXTOutBarCtrlTheme Constructor

CXTOutBarCtrlTheme Constructors, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::CXTOutBarCtrlTheme Constructor

Constructs a CXTOutBarCtrlTheme object.

CXTOutBarCtrlTheme();
Group

CXTOutBarCtrlTheme Constructors


CXTOutBarCtrlTheme Destructors

CXTOutBarCtrlTheme Class, Legend, Public Methods
CXTOutBarCtrlTheme Destructors
Class

CXTOutBarCtrlTheme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTOutBarCtrlTheme | Destroys a CXTOutBarCtrlTheme object, handles cleanup and deallocation.


CXTOutBarCtrlTheme::~CXTOutBarCtrlTheme Destructor

CXTOutBarCtrlTheme Destructors, CXTOutBarCtrlTheme Class
CXTOutBarCtrlTheme::~CXTOutBarCtrlTheme Destructor

Destroys a CXTOutBarCtrlTheme object, handles cleanup and deallocation.

virtual ~CXTOutBarCtrlTheme();
Group

CXTOutBarCtrlTheme Destructors


CXTOutBarCtrlThemeOffice2003 Class

XTOutBarCtrlTheme.h, Classes, Legend, Members, Topics, CXTOutBarCtrlThemeOffice2003 Data Members, CXTOutBarCtrlThemeOffice2003 Methods, CXTOutBarCtrlThemeOffice2003 Constructors, CXTOutBarCtrlThemeOffice2003 Constructors, CXTOutBarCtrlThemeOffice2003 Data Members, CXTOutBarCtrlThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003 Class

Class CXTOutBarCtrlThemeOffice2003 is derived form CXTOutBarCtrlThemeXP. This class is used to draw an OutBar with the Office XP theme.

Class Hierarchy

class CXTOutBarCtrlThemeOffice2003 : public CXTOutBarCtrlThemeOfficeXP;
File

XTOutBarCtrlTheme.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTOutBarCtrlThemeOffice2003 Constructors
CXTOutBarCtrlThemeOffice2003 Constructors | Description
CXTOutBarCtrlThemeOffice2003 | Constructs a CXTOutBarCtrlThemeOffice2003 object.
CXTOutBarCtrlThemeOffice2003 Data Members
CXTOutBarCtrlThemeOffice2003 Data Members | Description
m_bLunaTheme | TRUE if the current theme is a Luna Theme.
m_grcHot | The hot gradient color.
m_grcPushed | The pushed gradient color.
m_grcSelected | The selected gradient color.
CXTOutBarCtrlThemeOffice2003 Methods
CXTOutBarCtrlThemeOffice2003 Methods | Description
DrawFolder | Call this function to draw the folder on the OutBar. The folder can be drawn in any one of three states, normal, selected, or highlighted.
DrawIconFrame | Call this function to draw a 3D rectangle around an icon.
RefreshMetrics | Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.


CXTOutBarCtrlThemeOffice2003 Data Members

CXTOutBarCtrlThemeOffice2003 Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003 Data Members
Class

CXTOutBarCtrlThemeOffice2003 Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bLunaTheme | TRUE if the current theme is a Luna Theme.
m_grcHot | The hot gradient color.
m_grcPushed | The pushed gradient color.
m_grcSelected | The selected gradient color.


CXTOutBarCtrlThemeOffice2003::m_bLunaTheme Data Member

CXTOutBarCtrlThemeOffice2003 Data Members, CXTOutBarCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003::m_bLunaTheme Data Member

TRUE if the current theme is a Luna Theme.

BOOL m_bLunaTheme;
Group

CXTOutBarCtrlThemeOffice2003 Data Members


CXTOutBarCtrlThemeOffice2003::m_grcHot Data Member

CXTOutBarCtrlThemeOffice2003 Data Members, CXTOutBarCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003::m_grcHot Data Member

The hot gradient color.

CXTPPaintManagerColorGradient m_grcHot;
Group

CXTOutBarCtrlThemeOffice2003 Data Members


CXTOutBarCtrlThemeOffice2003::m_grcPushed Data Member

CXTOutBarCtrlThemeOffice2003 Data Members, CXTOutBarCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003::m_grcPushed Data Member

The pushed gradient color.

CXTPPaintManagerColorGradient m_grcPushed;
Group

CXTOutBarCtrlThemeOffice2003 Data Members


CXTOutBarCtrlThemeOffice2003::m_grcSelected Data Member

CXTOutBarCtrlThemeOffice2003 Data Members, CXTOutBarCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003::m_grcSelected Data Member

The selected gradient color.

CXTPPaintManagerColorGradient m_grcSelected;
Group

CXTOutBarCtrlThemeOffice2003 Data Members


CXTOutBarCtrlThemeOffice2003 Methods

CXTOutBarCtrlThemeOffice2003 Class, Legend, Public Methods
CXTOutBarCtrlThemeOffice2003 Methods
Class

CXTOutBarCtrlThemeOffice2003 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawFolder | Call this function to draw the folder on the OutBar. The folder can be drawn in any one of three states, normal, selected, or highlighted.
DrawIconFrame | Call this function to draw a 3D rectangle around an icon.
RefreshMetrics | Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.


CXTOutBarCtrlThemeOffice2003::DrawFolder Method

CXTOutBarCtrlThemeOffice2003 Methods, CXTOutBarCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003::DrawFolder Method

Call this function to draw the folder on the OutBar. The folder can be drawn in any one of three states, normal, selected, or highlighted.

virtual void DrawFolder(
    CDC* pDC,
    CRect rect,
    CXTOutBarFolder* pBarFolder,
    const XTMouseState eHilight
);
Parameters

pDC
A CDC pointer that represents the current device context.
rect
A CRect object that specifies the XY location of the folder.
pBarFolder
A CXTOutBarFolder object that maintains information about the folder.
eHilight
An int that specifies the height of the folder. The possible values are: xtMouseNormal, xtMouseSelect, and xtMouseHover.

Group

CXTOutBarCtrlThemeOffice2003 Methods


CXTOutBarCtrlThemeOffice2003::DrawIconFrame Method

CXTOutBarCtrlThemeOffice2003 Methods, CXTOutBarCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003::DrawIconFrame Method

Call this function to draw a 3D rectangle around an icon.

virtual void DrawIconFrame(
    CDC* pDC,
    CRect rcIcon,
    BOOL bSelected,
    BOOL bPressed
);
Parameters

pDC
A CDC pointer that represents the current device context.
rcIcon
A CRect object that specifies the XY location of the icon.
bSelected
TRUE if the icon is currently selected. FALSE otherwise.
bPressed
TRUE if the icon is pressed. FALSE otherwise.

Group

CXTOutBarCtrlThemeOffice2003 Methods


CXTOutBarCtrlThemeOffice2003::RefreshMetrics Method

CXTOutBarCtrlThemeOffice2003 Methods, CXTOutBarCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003::RefreshMetrics Method

Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.

virtual void RefreshMetrics();
Group

CXTOutBarCtrlThemeOffice2003 Methods


CXTOutBarCtrlThemeOffice2003 Constructors

CXTOutBarCtrlThemeOffice2003 Class, Legend, Public Methods
CXTOutBarCtrlThemeOffice2003 Constructors
Class

CXTOutBarCtrlThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarCtrlThemeOffice2003 | Constructs a CXTOutBarCtrlThemeOffice2003 object.


CXTOutBarCtrlThemeOffice2003::CXTOutBarCtrlThemeOffice2003 Constructor

CXTOutBarCtrlThemeOffice2003 Constructors, CXTOutBarCtrlThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOffice2003::CXTOutBarCtrlThemeOffice2003 Constructor

Constructs a CXTOutBarCtrlThemeOffice2003 object.

CXTOutBarCtrlThemeOffice2003();
Group

CXTOutBarCtrlThemeOffice2003 Constructors


CXTOutBarCtrlThemeOfficeXP Class

XTOutBarCtrlTheme.h, Classes, Legend, Members, Topics, CXTOutBarCtrlThemeOfficeXP Methods, CXTOutBarCtrlThemeOfficeXP Constructors, CXTOutBarCtrlThemeOfficeXP Constructors, CXTOutBarCtrlThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOfficeXP Class

Class CXTOutBarCtrlThemeOfficeXP is derived form CXTOutBarCtrlTheme. This class is used to draw an OutBar with the Office XP theme.

Class Hierarchy

class CXTOutBarCtrlThemeOfficeXP : public CXTOutBarCtrlTheme;
File

XTOutBarCtrlTheme.h

Group

Classes

Legend
Method
virtual
CXTOutBarCtrlThemeOfficeXP Constructors
CXTOutBarCtrlThemeOfficeXP Constructors | Description
CXTOutBarCtrlThemeOfficeXP | Constructs a CXTOutBarCtrlThemeOfficeXP object.
CXTOutBarCtrlThemeOfficeXP Methods
CXTOutBarCtrlThemeOfficeXP Methods | Description
DrawIconFrame | Call this function to draw a 3D rectangle around an icon.
RefreshMetrics | Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.


CXTOutBarCtrlThemeOfficeXP Methods

CXTOutBarCtrlThemeOfficeXP Class, Legend, Public Methods
CXTOutBarCtrlThemeOfficeXP Methods
Class

CXTOutBarCtrlThemeOfficeXP Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawIconFrame | Call this function to draw a 3D rectangle around an icon.
RefreshMetrics | Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.


CXTOutBarCtrlThemeOfficeXP::DrawIconFrame Method

CXTOutBarCtrlThemeOfficeXP Methods, CXTOutBarCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOfficeXP::DrawIconFrame Method

Call this function to draw a 3D rectangle around an icon.

virtual void DrawIconFrame(
    CDC* pDC,
    CRect rcIcon,
    BOOL bSelected,
    BOOL bPressed
);
Parameters

pDC
A CDC pointer that represents the current device context.
rcIcon
A CRect object that specifies the XY location of the icon.
bSelected
TRUE if the icon is currently selected. FALSE otherwise.
bPressed
TRUE if the icon is pressed. FALSE otherwise.

Group

CXTOutBarCtrlThemeOfficeXP Methods


CXTOutBarCtrlThemeOfficeXP::RefreshMetrics Method

CXTOutBarCtrlThemeOfficeXP Methods, CXTOutBarCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOfficeXP::RefreshMetrics Method

Refresh the colors on the OutBar. Also, set the default colors for the background and the text on the OutBar.

void RefreshMetrics();
Group

CXTOutBarCtrlThemeOfficeXP Methods


CXTOutBarCtrlThemeOfficeXP Constructors

CXTOutBarCtrlThemeOfficeXP Class, Legend, Public Methods
CXTOutBarCtrlThemeOfficeXP Constructors
Class

CXTOutBarCtrlThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarCtrlThemeOfficeXP | Constructs a CXTOutBarCtrlThemeOfficeXP object.


CXTOutBarCtrlThemeOfficeXP::CXTOutBarCtrlThemeOfficeXP Constructor

CXTOutBarCtrlThemeOfficeXP Constructors, CXTOutBarCtrlThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarCtrlThemeOfficeXP::CXTOutBarCtrlThemeOfficeXP Constructor

Constructs a CXTOutBarCtrlThemeOfficeXP object.

CXTOutBarCtrlThemeOfficeXP();
Group

CXTOutBarCtrlThemeOfficeXP Constructors


CXTOutBarEditItem Class

XTOutBarCtrl.h, Classes, Legend, Members, Topics, CXTOutBarEditItem Data Members, CXTOutBarEditItem Methods, CXTOutBarEditItem Constructors, CXTOutBarEditItem Destructors, CXTOutBarEditItem Constructors, CXTOutBarEditItem Data Members, CXTOutBarEditItem Destructors, CXTOutBarEditItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarEditItem Class

CXTOutBarEditItem is a helper class derived from CXTEdit. It is used by CXTOutBarCtrl, an Outlook like control, to create an in-place edit box that is used to modify a folder or an item within the control.

Class Hierarchy

class CXTOutBarEditItem : public CXTEdit;
File

XTOutBarCtrl.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTOutBarEditItem Constructors
CXTOutBarEditItem Constructors | Description
CXTOutBarEditItem | Constructs a CXTOutBarEditItem object
CXTOutBarEditItem Data Members
CXTOutBarEditItem Data Members | Description
m_bEscapeKey | true if the escape key was pressed.
m_bIsFolder | true if the edit box is for a folder.
m_bSmallIcons | true if the folder is using small icons.
m_iIndex | Index of the folder or item.
m_pParentWnd | Parent Outlook bar control.
m_rcOriginal | Original size of the edit box when it was first created.
m_strText | Original string of the edit box when it was first created, and the new text on edit completion.
CXTOutBarEditItem Destructors
CXTOutBarEditItem Destructors | Description
~CXTOutBarEditItem | Destroys a CXTOutBarEditItem object, handles cleanup and deallocation
CXTOutBarEditItem Methods
CXTOutBarEditItem Methods | Description
Create | The Outlook bar control calls this member to create an in-place edit control.
GetIndex | Call this member function to return the index of the folder or item currently being edited.
GetText | Call this member function to return the text associated with this edit control.


CXTOutBarEditItem Data Members

CXTOutBarEditItem Class, Legend, Protected Data Members
CXTOutBarEditItem Data Members
Class

CXTOutBarEditItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bEscapeKey | true if the escape key was pressed.
m_bIsFolder | true if the edit box is for a folder.
m_bSmallIcons | true if the folder is using small icons.
m_iIndex | Index of the folder or item.
m_pParentWnd | Parent Outlook bar control.
m_rcOriginal | Original size of the edit box when it was first created.
m_strText | Original string of the edit box when it was first created, and the new text on edit completion.


CXTOutBarEditItem::m_bEscapeKey Data Member

CXTOutBarEditItem Data Members, CXTOutBarEditItem Class
CXTOutBarEditItem::m_bEscapeKey Data Member

true if the escape key was pressed.

bool m_bEscapeKey;
Group

CXTOutBarEditItem Data Members


CXTOutBarEditItem::m_bIsFolder Data Member

CXTOutBarEditItem Data Members, CXTOutBarEditItem Class
CXTOutBarEditItem::m_bIsFolder Data Member

true if the edit box is for a folder.

bool m_bIsFolder;
Group

CXTOutBarEditItem Data Members


CXTOutBarEditItem::m_bSmallIcons Data Member

CXTOutBarEditItem Data Members, CXTOutBarEditItem Class
CXTOutBarEditItem::m_bSmallIcons Data Member

true if the folder is using small icons.

bool m_bSmallIcons;
Group

CXTOutBarEditItem Data Members


CXTOutBarEditItem::m_iIndex Data Member

CXTOutBarEditItem Data Members, CXTOutBarEditItem Class
CXTOutBarEditItem::m_iIndex Data Member

Index of the folder or item.

int m_iIndex;
Group

CXTOutBarEditItem Data Members


CXTOutBarEditItem::m_pParentWnd Data Member

CXTOutBarEditItem Data Members, CXTOutBarEditItem Class
CXTOutBarEditItem::m_pParentWnd Data Member

Parent Outlook bar control.

CXTOutBarCtrl* m_pParentWnd;
Group

CXTOutBarEditItem Data Members


CXTOutBarEditItem::m_rcOriginal Data Member

CXTOutBarEditItem Data Members, CXTOutBarEditItem Class
CXTOutBarEditItem::m_rcOriginal Data Member

Original size of the edit box when it was first created.

CRect m_rcOriginal;
Group

CXTOutBarEditItem Data Members


CXTOutBarEditItem::m_strText Data Member

CXTOutBarEditItem Data Members, CXTOutBarEditItem Class
CXTOutBarEditItem::m_strText Data Member

Original string of the edit box when it was first created, and the new text on edit completion.

CString m_strText;
Group

CXTOutBarEditItem Data Members


CXTOutBarEditItem Methods

CXTOutBarEditItem Class, Legend, Public Methods
CXTOutBarEditItem Methods
Class

CXTOutBarEditItem Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Create | The Outlook bar control calls this member to create an in-place edit control.
GetIndex | Call this member function to return the index of the folder or item currently being edited.
GetText | Call this member function to return the text associated with this edit control.


CXTOutBarEditItem::Create Method

CXTOutBarEditItem Methods, CXTOutBarEditItem Class
CXTOutBarEditItem::Create Method

The Outlook bar control calls this member to create an in-place edit control.

virtual BOOL Create(
    LPCTSTR lpszText,
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID,
    UINT nIndex,
    bool bIsFolder,
    bool bSmallIcons
);
Parameters

lpszText
NULL terminated string to be displayed in the edit control.
dwStyle
Window style for the edit control.
rect
Size of the edit control.
pParentWnd
Owner window.
nID
Control ID.
nIndex
Folder or item index.
bIsFolder
true if the edit is for a folder item.
bSmallIcons
true if the parent folder is displaying small icons.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTOutBarEditItem Methods


CXTOutBarEditItem::GetIndex Method

CXTOutBarEditItem Methods, CXTOutBarEditItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarEditItem::GetIndex Method

Call this member function to return the index of the folder or item currently being edited.

int GetIndex() const;
Returns

An integer value that represents the index of the folder or item.

Body Source
int CXTOutBarEditItem::GetIndex() const {
    return m_iIndex;
}
Group

CXTOutBarEditItem Methods


CXTOutBarEditItem::GetText Method

CXTOutBarEditItem Methods, CXTOutBarEditItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarEditItem::GetText Method

Call this member function to return the text associated with this edit control.

CString GetText() const;
Returns

A CString object that represents the text originally set for the edit control. If called after the edit is destroyed, it returns the modified text value.

Body Source
CString CXTOutBarEditItem::GetText() const {
    return m_strText;
}
Group

CXTOutBarEditItem Methods


CXTOutBarEditItem Constructors

CXTOutBarEditItem Class, Legend, Public Methods
CXTOutBarEditItem Constructors
Class

CXTOutBarEditItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarEditItem | Constructs a CXTOutBarEditItem object


CXTOutBarEditItem::CXTOutBarEditItem Constructor

CXTOutBarEditItem Constructors, CXTOutBarEditItem Class
CXTOutBarEditItem::CXTOutBarEditItem Constructor

Constructs a CXTOutBarEditItem object

CXTOutBarEditItem();
Group

CXTOutBarEditItem Constructors


CXTOutBarEditItem Destructors

CXTOutBarEditItem Class, Legend, Public Methods
CXTOutBarEditItem Destructors
Class

CXTOutBarEditItem Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTOutBarEditItem | Destroys a CXTOutBarEditItem object, handles cleanup and deallocation


CXTOutBarEditItem::~CXTOutBarEditItem Destructor

CXTOutBarEditItem Destructors, CXTOutBarEditItem Class
CXTOutBarEditItem::~CXTOutBarEditItem Destructor

Destroys a CXTOutBarEditItem object, handles cleanup and deallocation

virtual ~CXTOutBarEditItem();
Group

CXTOutBarEditItem Destructors


CXTOutBarFolder Class

XTOutBarCtrl.h, Classes, Legend, Members, Topics, CXTOutBarFolder Data Members, CXTOutBarFolder Methods, CXTOutBarFolder Constructors, CXTOutBarFolder Destructors, CXTOutBarFolder Constructors, CXTOutBarFolder Data Members, CXTOutBarFolder Destructors, CXTOutBarFolder Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarFolder Class

CXTOutBarFolder is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder specified in the Outlook bar control.

Class Hierarchy

class CXTOutBarFolder;
File

XTOutBarCtrl.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTOutBarFolder Constructors
CXTOutBarFolder Constructors | Description
CXTOutBarFolder | Constructs a CXTOutBarFolder object.
CXTOutBarFolder Data Members
CXTOutBarFolder Data Members | Description
m_barItems | Folder items.
m_bSmallIcons | TRUE to use small icons.
m_dwData | Application data.
m_pChild | Child window pointer.
m_pControl | Pointer to the parent CXTOutBarCtrl object.
m_pLargeList | Image list for large icons.
m_pSmallList | Image list for small icons.
m_strName | Folder label.
CXTOutBarFolder Destructors
CXTOutBarFolder Destructors | Description
~CXTOutBarFolder | Destroys a CXTOutBarFolder object, handles cleanup and deallocation
CXTOutBarFolder Methods
CXTOutBarFolder Methods | Description
GetChild | Retrieves a pointer to the child window.
GetControl | Retrieves a pointer to the parent CXTOutBarCtrl window.
GetData | Call this member function to return the user defined item data (lParam) for the folder.
GetItemAt | Retrieves a pointer to a CXTOutBarItem at the given index.
GetItemCount | Call this member function to retrieve the number of folders found in the Outlook bar.
GetLargeImageList | Call this member function to return a pointer to the large image list for the folder.
GetName | Call this member function to return the label of the folder item.
GetSelIndex | Call this member function to return the index for the currently selected item.
GetSelItem | Call this member function to return a pointer to the currently selected item.
GetSmallImageList | Call this member function to return a pointer to the small image list for the folder.
InsertItem | Call this member function to insert an item into the Outlook bar folder.
InsertItemAt | Call this member function to insert a folder item into the location specified by 'iIndex'.
RemoveItemAt | Call this member function to remove the specified item from the folder.
SetChild | Call this member function to set the CWnd child to be associated with this folder item.
SetData | Call this member function to set the user item data (lParam) for the folder.
SetLargeImageList | Call this member function to set the large image list for the folder.
SetName | Call this member function to set the label for the folder item.
SetSelItem | Call this member function to set the currently selected item for the folder.
SetSmallImageList | Call this member function to set the small image list for the folder.


CXTOutBarFolder Data Members

CXTOutBarFolder Class, Legend, Protected Data Members
CXTOutBarFolder Data Members
Class

CXTOutBarFolder Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_barItems | Folder items.
m_bSmallIcons | TRUE to use small icons.
m_dwData | Application data.
m_pChild | Child window pointer.
m_pControl | Pointer to the parent CXTOutBarCtrl object.
m_pLargeList | Image list for large icons.
m_pSmallList | Image list for small icons.
m_strName | Folder label.


CXTOutBarFolder::m_barItems Data Member

CXTOutBarFolder Data Members, CXTOutBarFolder Class
CXTOutBarFolder::m_barItems Data Member

Folder items.

CList<CXTOutBarItem*, CXTOutBarItem*> m_barItems;
Group

CXTOutBarFolder Data Members


CXTOutBarFolder::m_bSmallIcons Data Member

CXTOutBarFolder Data Members, CXTOutBarFolder Class
CXTOutBarFolder::m_bSmallIcons Data Member

TRUE to use small icons.

BOOL m_bSmallIcons;
Group

CXTOutBarFolder Data Members


CXTOutBarFolder::m_dwData Data Member

CXTOutBarFolder Data Members, CXTOutBarFolder Class
CXTOutBarFolder::m_dwData Data Member

Application data.

DWORD m_dwData;
Group

CXTOutBarFolder Data Members


CXTOutBarFolder::m_pChild Data Member

CXTOutBarFolder Data Members, CXTOutBarFolder Class
CXTOutBarFolder::m_pChild Data Member

Child window pointer.

CWnd* m_pChild;
Group

CXTOutBarFolder Data Members


CXTOutBarFolder::m_pControl Data Member

CXTOutBarFolder Data Members, CXTOutBarFolder Class
CXTOutBarFolder::m_pControl Data Member

Pointer to the parent CXTOutBarCtrl object.

CXTOutBarCtrl* m_pControl;
Group

CXTOutBarFolder Data Members


CXTOutBarFolder::m_pLargeList Data Member

CXTOutBarFolder Data Members, CXTOutBarFolder Class
CXTOutBarFolder::m_pLargeList Data Member

Image list for large icons.

CImageList* m_pLargeList;
Group

CXTOutBarFolder Data Members


CXTOutBarFolder::m_pSmallList Data Member

CXTOutBarFolder Data Members, CXTOutBarFolder Class
CXTOutBarFolder::m_pSmallList Data Member

Image list for small icons.

CImageList* m_pSmallList;
Group

CXTOutBarFolder Data Members


CXTOutBarFolder::m_strName Data Member

CXTOutBarFolder Data Members, CXTOutBarFolder Class
CXTOutBarFolder::m_strName Data Member

Folder label.

CString m_strName;
Group

CXTOutBarFolder Data Members


CXTOutBarFolder Methods

CXTOutBarFolder Class, Legend, Public Methods
CXTOutBarFolder Methods
Class

CXTOutBarFolder Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetChild | Retrieves a pointer to the child window.
GetControl | Retrieves a pointer to the parent CXTOutBarCtrl window.
GetData | Call this member function to return the user defined item data (lParam) for the folder.
GetItemAt | Retrieves a pointer to a CXTOutBarItem at the given index.
GetItemCount | Call this member function to retrieve the number of folders found in the Outlook bar.
GetLargeImageList | Call this member function to return a pointer to the large image list for the folder.
GetName | Call this member function to return the label of the folder item.
GetSelIndex | Call this member function to return the index for the currently selected item.
GetSelItem | Call this member function to return a pointer to the currently selected item.
GetSmallImageList | Call this member function to return a pointer to the small image list for the folder.
InsertItem | Call this member function to insert an item into the Outlook bar folder.
InsertItemAt | Call this member function to insert a folder item into the location specified by 'iIndex'.
RemoveItemAt | Call this member function to remove the specified item from the folder.
SetChild | Call this member function to set the CWnd child to be associated with this folder item.
SetData | Call this member function to set the user item data (lParam) for the folder.
SetLargeImageList | Call this member function to set the large image list for the folder.
SetName | Call this member function to set the label for the folder item.
SetSelItem | Call this member function to set the currently selected item for the folder.
SetSmallImageList | Call this member function to set the small image list for the folder.


CXTOutBarFolder::GetChild Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarFolder::GetChild Method

Retrieves a pointer to the child window.

CWnd* GetChild();
Returns

A CWnd pointer to the child associated with the folder, or NULL if no objects were found.

Remarks

Call this member function to retrieve a CWnd pointer to the child object that is associated with this folder item.

See Also

SetChild, CXTOutBarCtrl::AddFolderBar

Body Source
CWnd* CXTOutBarFolder::GetChild() {
    return m_pChild;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetControl Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::GetControl Method

Retrieves a pointer to the parent CXTOutBarCtrl window.

CXTOutBarCtrl* GetControl();
Returns

A pointer to a CXTOutBarCtrl object if successful, otherwise NULL.

Remarks

Call this member to retrieve a pointer to the folder's CXTOutBarCtrl parent window.

Body Source
CXTOutBarCtrl* CXTOutBarFolder::GetControl() {
    return m_pControl;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetData Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::GetData Method

Call this member function to return the user defined item data (lParam) for the folder.

DWORD GetData();
Returns

A DWORD value that represents the item data if defined, otherwise NULL.

Body Source
DWORD CXTOutBarFolder::GetData() {
    return m_dwData;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetItemAt Method

CXTOutBarFolder Methods, CXTOutBarFolder Class
CXTOutBarFolder::GetItemAt Method

Retrieves a pointer to a CXTOutBarItem at the given index.

CXTOutBarItem* GetItemAt(
    int iIndex
);
Parameters

iIndex
[in] Index of the folder item to retrieve.

Returns

A pointer to a CXTOutBarItem object if successful, otherwise NULL.

Remarks

Call this member function to retrieve a pointer to the CXTOutBarItem at the specified index.

Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetItemCount Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::GetItemCount Method

Call this member function to retrieve the number of folders found in the Outlook bar.

int GetItemCount();
Returns

The number of folders in the Outlook bar.

Body Source
int CXTOutBarFolder::GetItemCount() {
    return (int)m_barItems.GetCount();
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetLargeImageList Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::GetLargeImageList Method

Call this member function to return a pointer to the large image list for the folder.

CImageList* GetLargeImageList();
Returns

A pointer to CImageList object if successful, otherwise returns NULL.

Body Source
CImageList* CXTOutBarFolder::GetLargeImageList() {
    return m_pLargeList;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetName Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::GetName Method

Call this member function to return the label of the folder item.

CString GetName();
Returns

A CString object.

Body Source
CString CXTOutBarFolder::GetName() {
    return m_strName;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetSelIndex Method

CXTOutBarFolder Methods, CXTOutBarFolder Class
CXTOutBarFolder::GetSelIndex Method

Call this member function to return the index for the currently selected item.

int GetSelIndex();
Returns

The index of the currently selected item if successful, otherwise returns -1.

Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetSelItem Method

CXTOutBarFolder Methods, CXTOutBarFolder Class
CXTOutBarFolder::GetSelItem Method

Call this member function to return a pointer to the currently selected item.

CXTOutBarItem* GetSelItem();
Returns

A pointer to a CXTOutBarItem object if successful, otherwise returns NULL.

Group

CXTOutBarFolder Methods


CXTOutBarFolder::GetSmallImageList Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::GetSmallImageList Method

Call this member function to return a pointer to the small image list for the folder.

CImageList* GetSmallImageList();
Returns

A CImageList object if successful, otherwise returns NULL.

Body Source
CImageList* CXTOutBarFolder::GetSmallImageList() {
    return m_pSmallList;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::InsertItem Method

CXTOutBarFolder Methods, CXTOutBarFolder Class
CXTOutBarFolder::InsertItem Method

Call this member function to insert an item into the Outlook bar folder.

int InsertItem(
    int iIndex,
    LPCTSTR lpszName,
    const int nImage,
    const DWORD dwData
);
Parameters

iIndex
[in] Index of the item.
lpszName
[in] A NULL terminated string that represents the label of the item.
nImage
[in] Index into the folder's image list.
dwData
[in] User item data (lParam).

Returns

An integer value.

Group

CXTOutBarFolder Methods


CXTOutBarFolder::InsertItemAt Method

CXTOutBarFolder Methods, CXTOutBarFolder Class
CXTOutBarFolder::InsertItemAt Method

Call this member function to insert a folder item into the location specified by 'iIndex'.

void InsertItemAt(
    int iIndex,
    CXTOutBarItem* pBarItem
);
Parameters

iIndex
[in] Zero-based index of where to insert the new item.
pBarItem
[in] Points to a valid CXTOutBarItem object.

Group

CXTOutBarFolder Methods


CXTOutBarFolder::RemoveItemAt Method

CXTOutBarFolder Methods, CXTOutBarFolder Class
CXTOutBarFolder::RemoveItemAt Method

Call this member function to remove the specified item from the folder.

CXTOutBarItem* RemoveItemAt(
    int iIndex
);
Parameters

iIndex
Index of the item to remove.

Returns

A pointer to the removed item.

Group

CXTOutBarFolder Methods


CXTOutBarFolder::SetChild Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::SetChild Method

Call this member function to set the CWnd child to be associated with this folder item.

void SetChild(
    CWnd* pChild
);
Parameters

pChild
[in] Points to a valid CWnd object.

Body Source
void CXTOutBarFolder::SetChild(CWnd* pChild) {
    m_pChild = pChild;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::SetData Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::SetData Method

Call this member function to set the user item data (lParam) for the folder.

void SetData(
    DWORD dwData
);
Parameters

dwData
[in] User item data (lParam).

Body Source
void CXTOutBarFolder::SetData(DWORD dwData) {
    m_dwData = dwData;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::SetLargeImageList Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::SetLargeImageList Method

Call this member function to set the large image list for the folder.

void SetLargeImageList(
    CImageList* pLargeList
);
Parameters

pLargeList
[in] Points to a CImageList object.

Body Source
void CXTOutBarFolder::SetLargeImageList(CImageList* pLargeList) {
    m_pLargeList = pLargeList;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::SetName Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::SetName Method

Call this member function to set the label for the folder item.

void SetName(
    LPCTSTR strName
);
Parameters

strName
[in] A NULL terminated string that represents the folder's new label.

Body Source
void CXTOutBarFolder::SetName(LPCTSTR strName) {
    m_strName = strName;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder::SetSelItem Method

CXTOutBarFolder Methods, CXTOutBarFolder Class
CXTOutBarFolder::SetSelItem Method

Call this member function to set the currently selected item for the folder.

void SetSelItem(
    int iItem
);
Parameters

iItem
[in] Index of the item to select

Group

CXTOutBarFolder Methods


CXTOutBarFolder::SetSmallImageList Method

CXTOutBarFolder Methods, CXTOutBarFolder Class, Body Source
CXTOutBarFolder::SetSmallImageList Method

Call this member function to set the small image list for the folder.

void SetSmallImageList(
    CImageList* pSmallList
);
Parameters

pSmallList
[in] Points to a CImageList object.

Body Source
void CXTOutBarFolder::SetSmallImageList(CImageList* pSmallList) {
    m_pSmallList = pSmallList;
}
Group

CXTOutBarFolder Methods


CXTOutBarFolder Constructors

CXTOutBarFolder Class, Legend, Public Methods
CXTOutBarFolder Constructors
Class

CXTOutBarFolder Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarFolder | Constructs a CXTOutBarFolder object.


CXTOutBarFolder::CXTOutBarFolder Constructor

CXTOutBarFolder Constructors, CXTOutBarFolder Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarFolder::CXTOutBarFolder Constructor

Constructs a CXTOutBarFolder object.

CXTOutBarFolder(
    LPCTSTR lpszName,
    DWORD dwData,
    CXTOutBarCtrl* pControl
);
Parameters

lpszName
[in] A NULL terminated string that represents the item name.
dwData
[in] User defined item data (lParam).
pControl
[in] Pointer to the parent CXTOutBarCtrl object.

Remarks

The CXTOutBarFolder object is constructed by the CXTOutBarCtrl to when a new folder to the control.

See Also

CXTOutBarCtrl::AddFolder, CXTOutBarCtrl::AddFolderBar

Group

CXTOutBarFolder Constructors


CXTOutBarFolder Destructors

CXTOutBarFolder Class, Legend, Public Methods
CXTOutBarFolder Destructors
Class

CXTOutBarFolder Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTOutBarFolder | Destroys a CXTOutBarFolder object, handles cleanup and deallocation


CXTOutBarFolder::~CXTOutBarFolder Destructor

CXTOutBarFolder Destructors, CXTOutBarFolder Class
CXTOutBarFolder::~CXTOutBarFolder Destructor

Destroys a CXTOutBarFolder object, handles cleanup and deallocation

virtual ~CXTOutBarFolder();
Group

CXTOutBarFolder Destructors


CXTOutBarItem Class

XTOutBarCtrl.h, Classes, Legend, Members, Topics, CXTOutBarItem Data Members, CXTOutBarItem Methods, CXTOutBarItem Constructors, CXTOutBarItem Destructors, CXTOutBarItem Constructors, CXTOutBarItem Data Members, CXTOutBarItem Destructors, CXTOutBarItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTOutBarItem Class

CXTOutBarItem is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder item specified in the Outlook bar control.

Class Hierarchy

class CXTOutBarItem;
File

XTOutBarCtrl.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTOutBarItem Constructors
CXTOutBarItem Constructors | Description
CXTOutBarItem | Constructs a CXTOutBarItem object
CXTOutBarItem Data Members
CXTOutBarItem Data Members | Description
m_bEnabled | true if the icon is enabled.
m_bSelected | true if selected.
m_dwData | User data.
m_nIndex | Item index.
m_strName | label of the folder item.
CXTOutBarItem Destructors
CXTOutBarItem Destructors | Description
~CXTOutBarItem | Destroys a CXTOutBarItem object, handles cleanup and deallocation
CXTOutBarItem Methods
CXTOutBarItem Methods | Description
EnableItem | Call this member function to toggle the enabled state for the outlook bar item.
GetData | Call this member function to return the user specified item data (lParam) for the folder item.
GetIndex | Call this member function to retrieve the zero-based index of the folder item.
GetName | Call this member function to retrieve the label of the folder item.
IsEnabled | Call this member function to determine if the item is enabled.
IsSelected | Call this member function to see if the item is selected.
SelectItem | Call this member function to set the items selected state.
SetData | Call this member function to set a user data (lParam) value for the folder item.
SetIndex | Call this member function to set the zero-based index of the folder item.
SetName | Call this member function to set the label of the folder item.


CXTOutBarItem Data Members

CXTOutBarItem Class, Legend, Protected Data Members
CXTOutBarItem Data Members
Class

CXTOutBarItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bEnabled | true if the icon is enabled.
m_bSelected | true if selected.
m_dwData | User data.
m_nIndex | Item index.
m_strName | label of the folder item.


CXTOutBarItem::m_bEnabled Data Member

CXTOutBarItem Data Members, CXTOutBarItem Class
CXTOutBarItem::m_bEnabled Data Member

true if the icon is enabled.

bool m_bEnabled;
Group

CXTOutBarItem Data Members


CXTOutBarItem::m_bSelected Data Member

CXTOutBarItem Data Members, CXTOutBarItem Class
CXTOutBarItem::m_bSelected Data Member

true if selected.

bool m_bSelected;
Group

CXTOutBarItem Data Members


CXTOutBarItem::m_dwData Data Member

CXTOutBarItem Data Members, CXTOutBarItem Class
CXTOutBarItem::m_dwData Data Member

User data.

DWORD m_dwData;
Group

CXTOutBarItem Data Members


CXTOutBarItem::m_nIndex Data Member

CXTOutBarItem Data Members, CXTOutBarItem Class
CXTOutBarItem::m_nIndex Data Member

Item index.

int m_nIndex;
Group

CXTOutBarItem Data Members


CXTOutBarItem::m_strName Data Member

CXTOutBarItem Data Members, CXTOutBarItem Class
CXTOutBarItem::m_strName Data Member

label of the folder item.

CString m_strName;
Group

CXTOutBarItem Data Members


CXTOutBarItem Methods

CXTOutBarItem Class, Legend, Public Methods
CXTOutBarItem Methods
Class

CXTOutBarItem Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
EnableItem | Call this member function to toggle the enabled state for the outlook bar item.
GetData | Call this member function to return the user specified item data (lParam) for the folder item.
GetIndex | Call this member function to retrieve the zero-based index of the folder item.
GetName | Call this member function to retrieve the label of the folder item.
IsEnabled | Call this member function to determine if the item is enabled.
IsSelected | Call this member function to see if the item is selected.
SelectItem | Call this member function to set the items selected state.
SetData | Call this member function to set a user data (lParam) value for the folder item.
SetIndex | Call this member function to set the zero-based index of the folder item.
SetName | Call this member function to set the label of the folder item.


CXTOutBarItem::EnableItem Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::EnableItem Method

Call this member function to toggle the enabled state for the outlook bar item.

void EnableItem(
    bool bEnable
);
Parameters

bEnable
[in] true to enable, false to disable.

Body Source
void CXTOutBarItem::EnableItem(bool bEnable) {
    m_bEnabled = bEnable;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::GetData Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::GetData Method

Call this member function to return the user specified item data (lParam) for the folder item.

DWORD GetData();
Returns

A DWORD value that represents the user data.

Body Source
DWORD CXTOutBarItem::GetData() {
    return m_dwData;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::GetIndex Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::GetIndex Method

Call this member function to retrieve the zero-based index of the folder item.

int GetIndex();
Returns

An integer value that represents the zero-based index of the folder item.

Body Source
int CXTOutBarItem::GetIndex() {
    return m_nIndex;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::GetName Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::GetName Method

Call this member function to retrieve the label of the folder item.

CString GetName();
Returns

A CString object that contains the folder item label.

Body Source
CString CXTOutBarItem::GetName() {
    return m_strName;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::IsEnabled Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::IsEnabled Method

Call this member function to determine if the item is enabled.

bool IsEnabled();
Returns

true if the item is enabled, otherwise returns false.

Body Source
bool CXTOutBarItem::IsEnabled() {
    return m_bEnabled;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::IsSelected Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::IsSelected Method

Call this member function to see if the item is selected.

bool IsSelected();
Returns

true if the item is selected, otherwise returns false.

Body Source
bool CXTOutBarItem::IsSelected() {
    return m_bSelected;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::SelectItem Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::SelectItem Method

Call this member function to set the items selected state.

void SelectItem(
    bool bSelected
);
Parameters

bSelected
[in] true to set the item state to selected.

Body Source
void CXTOutBarItem::SelectItem(bool bSelected) {
    m_bSelected = bSelected;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::SetData Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::SetData Method

Call this member function to set a user data (lParam) value for the folder item.

void SetData(
    DWORD dwData
);
Parameters

dwData
[in] Specifies the user data (lparam) value to be associated with the folder item.

Body Source
void CXTOutBarItem::SetData(DWORD dwData) {
    m_dwData = dwData;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::SetIndex Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::SetIndex Method

Call this member function to set the zero-based index of the folder item.

void SetIndex(
    int iIndex
);
Parameters

iIndex
[in] New index of the folder item.

Body Source
void CXTOutBarItem::SetIndex(int iIndex) {
    m_nIndex = iIndex;
}
Group

CXTOutBarItem Methods


CXTOutBarItem::SetName Method

CXTOutBarItem Methods, CXTOutBarItem Class, Body Source
CXTOutBarItem::SetName Method

Call this member function to set the label of the folder item.

void SetName(
    LPCTSTR strName
);
Parameters

strName
[in] A NULL terminated string that represents the item label.

Body Source
void CXTOutBarItem::SetName(LPCTSTR strName) {
    m_strName = strName;
}
Group

CXTOutBarItem Methods


CXTOutBarItem Constructors

CXTOutBarItem Class, Legend, Public Methods
CXTOutBarItem Constructors
Class

CXTOutBarItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarItem | Constructs a CXTOutBarItem object


CXTOutBarItem::CXTOutBarItem Constructor

CXTOutBarItem Constructors, CXTOutBarItem Class
CXTOutBarItem::CXTOutBarItem Constructor

Constructs a CXTOutBarItem object

CXTOutBarItem(
    LPCTSTR lpszName,
    const int nImageIndex,
    DWORD dwData
);
Parameters

lpszName
[in] A NULL terminated string that represents the item name.
nImageIndex
[in] An index into the folders image list.
dwData
[in] User item data (lParam).

Group

CXTOutBarItem Constructors


CXTOutBarItem Destructors

CXTOutBarItem Class, Legend, Public Methods
CXTOutBarItem Destructors
Class

CXTOutBarItem Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTOutBarItem | Destroys a CXTOutBarItem object, handles cleanup and deallocation


CXTOutBarItem::~CXTOutBarItem Destructor

CXTOutBarItem Destructors, CXTOutBarItem Class
CXTOutBarItem::~CXTOutBarItem Destructor

Destroys a CXTOutBarItem object, handles cleanup and deallocation

virtual ~CXTOutBarItem();
Group

CXTOutBarItem Destructors


CXTPagerCtrl Class

XTPagerCtrl.h, Classes, Legend, Members, Topics, CXTPagerCtrl Methods, CXTPagerCtrl Constructors, CXTPagerCtrl Destructors, CXTPagerCtrl Constructors, CXTPagerCtrl Destructors, CXTPagerCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPagerCtrl Class

CXTPagerCtrl is a CWnd derived class. It is used to contain and scroll another window, and wraps the windows pager API.

Class Hierarchy

class CXTPagerCtrl : public CWnd;
File

XTPagerCtrl.h

Group

Classes

Legend
Method
virtual
CXTPagerCtrl Constructors
CXTPagerCtrl Constructors | Description
CXTPagerCtrl | Constructs a CXTPagerCtrl object
CXTPagerCtrl Destructors
CXTPagerCtrl Destructors | Description
~CXTPagerCtrl | Destroys a CXTPagerCtrl object, handles cleanup and deallocation
CXTPagerCtrl Methods
CXTPagerCtrl Methods | Description
Create | This member function creates a pager child window and attaches it to this CWnd object. Returns nonzero if successful, otherwise returns zero.
ForwardMouse | This member function enables or disables mouse forwarding for the pager control. When mouse forwarding is enabled, the pager control forwards WM_MOUSEMOVE messages to the contained window.
GetBkColor | This member function retrieves the current background color for the pager control.
GetBorder | This member function retrieves the current border size for the pager control.
GetButtonSize | This member function retrieves the current button size for the pager control.
GetButtonState | This member function retrieves the state of the specified button in a pager control.
GetDropTarget | This member function retrieves a pager control's IDropTarget interface pointer.
GetPos | This member function retrieves the current scroll position of the pager control.
RecalcSize | This member function forces the pager control to recalculate the size of the contained window. Using this command will result in a PGN_CALCSIZE notification being sent.
SetBkColor | This member function sets the current background color for the pager control.
SetBorder | This member function sets the current border size for the pager control.
SetButtonSize | This member function sets the current button size for the pager control.
SetChild | This member function sets the contained window for the pager control. This command will not change the parent of the contained window. It only assigns a window handle to the pager control for scrolling. In most cases, the contained window will be a child window. If this is the case, the contained window should be a child of the pager control.
SetPos | This member function sets the scroll position for the pager control.


CXTPagerCtrl Methods

CXTPagerCtrl Class, Legend, Public Methods
CXTPagerCtrl Methods
Class

CXTPagerCtrl Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Create | This member function creates a pager child window and attaches it to this CWnd object. Returns nonzero if successful, otherwise returns zero.
ForwardMouse | This member function enables or disables mouse forwarding for the pager control. When mouse forwarding is enabled, the pager control forwards WM_MOUSEMOVE messages to the contained window.
GetBkColor | This member function retrieves the current background color for the pager control.
GetBorder | This member function retrieves the current border size for the pager control.
GetButtonSize | This member function retrieves the current button size for the pager control.
GetButtonState | This member function retrieves the state of the specified button in a pager control.
GetDropTarget | This member function retrieves a pager control's IDropTarget interface pointer.
GetPos | This member function retrieves the current scroll position of the pager control.
RecalcSize | This member function forces the pager control to recalculate the size of the contained window. Using this command will result in a PGN_CALCSIZE notification being sent.
SetBkColor | This member function sets the current background color for the pager control.
SetBorder | This member function sets the current border size for the pager control.
SetButtonSize | This member function sets the current button size for the pager control.
SetChild | This member function sets the contained window for the pager control. This command will not change the parent of the contained window. It only assigns a window handle to the pager control for scrolling. In most cases, the contained window will be a child window. If this is the case, the contained window should be a child of the pager control.
SetPos | This member function sets the scroll position for the pager control.


CXTPagerCtrl::Create Method

CXTPagerCtrl Methods, CXTPagerCtrl Class
CXTPagerCtrl::Create Method

This member function creates a pager child window and attaches it to this CWnd object. Returns nonzero if successful, otherwise returns zero.

virtual BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Specifies the window style attributes. See the Remarks section for a list of style to use.
rect
The size and position of the window, in client coordinates of 'pParentWnd'.
pParentWnd
The parent window.
nID
The ID of the child window.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • PGS_AUTOSCROLL The pager control will scroll when the user hovers the mouse over one of the scroll buttons.
  • PGS_DRAGNDROP The contained window can be a drag-and-drop target. The pager control will automatically scroll if an item is dragged from outside the pager over one of the scroll buttons.
  • PGS_HORZ Creates a pager control that can be scrolled horizontally. This style and the PGS_VERT style are mutually exclusive and cannot be combined.
  • PGS_VERT Creates a pager control that can be scrolled vertically. This is the default direction; no direction style is specified. This style and the PGS_HORZ style are mutually exclusive and cannot be combined.
Group

CXTPagerCtrl Methods


CXTPagerCtrl::ForwardMouse Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::ForwardMouse Method

This member function enables or disables mouse forwarding for the pager control. When mouse forwarding is enabled, the pager control forwards WM_MOUSEMOVE messages to the contained window.

void ForwardMouse(
    BOOL bForward
);
Parameters

bForward
BOOL value that determines if mouse forwarding is enabled or disabled. If this value is nonzero, mouse forwarding is enabled. If this value is zero, mouse forwarding is disabled.

Body Source
void CXTPagerCtrl::ForwardMouse(BOOL bForward) {
    ASSERT(::IsWindow(m_hWnd)); Pager_ForwardMouse(m_hWnd, bForward);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::GetBkColor Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::GetBkColor Method

This member function retrieves the current background color for the pager control.

COLORREF GetBkColor();
Returns

A COLORREF value that contains the current background color.

Body Source
COLORREF CXTPagerCtrl::GetBkColor() {
    ASSERT(::IsWindow(m_hWnd)); return Pager_GetBkColor(m_hWnd);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::GetBorder Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::GetBorder Method

This member function retrieves the current border size for the pager control.

int GetBorder();
Returns

An integer value that contains the current border size in pixels.

Body Source
int CXTPagerCtrl::GetBorder() {
    ASSERT(::IsWindow(m_hWnd)); return Pager_GetBorder(m_hWnd);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::GetButtonSize Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::GetButtonSize Method

This member function retrieves the current button size for the pager control.

int GetButtonSize();
Returns

An integer value that contains the current button size in pixels.

Body Source
int CXTPagerCtrl::GetButtonSize() {
    ASSERT(::IsWindow(m_hWnd)); return Pager_GetButtonSize(m_hWnd);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::GetButtonState Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::GetButtonState Method

This member function retrieves the state of the specified button in a pager control.

DWORD GetButtonState(
    int iButton
);
Parameters

iButton
Indicates which button to retrieve the state for. See the description for 'iButton' in PGM_GETBUTTONSTATE for a list of possible values.

Returns

The state of the button specified in 'iButton'. See the return value description in PGM_GETBUTTONSTATE for a list of possible values.

Body Source
DWORD CXTPagerCtrl::GetButtonState(int iButton) {
    ASSERT(::IsWindow(m_hWnd)); return Pager_GetButtonState(m_hWnd, iButton);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::GetDropTarget Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::GetDropTarget Method

This member function retrieves a pager control's IDropTarget interface pointer.

void GetDropTarget(
    IDropTarget** ppdt
);
Parameters

ppdt
Address of an IDropTarget pointer that receives the interface pointer. It is the caller's responsibility to call Release on this pointer when it is no longer needed.

Body Source
void CXTPagerCtrl::GetDropTarget(IDropTarget** ppdt) {
    ASSERT(::IsWindow(m_hWnd)); Pager_GetDropTarget(m_hWnd, ppdt);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::GetPos Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::GetPos Method

This member function retrieves the current scroll position of the pager control.

int GetPos();
Returns

An integer value that contains the current scroll position in pixels.

Body Source
int CXTPagerCtrl::GetPos() {
    ASSERT(::IsWindow(m_hWnd)); return Pager_GetPos(m_hWnd);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::RecalcSize Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::RecalcSize Method

This member function forces the pager control to recalculate the size of the contained window. Using this command will result in a PGN_CALCSIZE notification being sent.

void RecalcSize();
Body Source
void CXTPagerCtrl::RecalcSize() {
    ASSERT(::IsWindow(m_hWnd)); Pager_RecalcSize(m_hWnd);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::SetBkColor Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::SetBkColor Method

This member function sets the current background color for the pager control.

COLORREF SetBkColor(
    COLORREF clr
);
Parameters

clr
COLORREF value that contains the new background color of the pager control.

Returns

A COLORREF value that contains the previous background color.

Body Source
COLORREF CXTPagerCtrl::SetBkColor(COLORREF clr) {
    ASSERT(::IsWindow(m_hWnd)); return Pager_SetBkColor(m_hWnd, clr);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::SetBorder Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::SetBorder Method

This member function sets the current border size for the pager control.

int SetBorder(
    int iBorder
);
Parameters

iBorder
New size of the border, in pixels. This value should not be larger than the pager button or less than zero. If 'iBorder' is too large, the border will be drawn the same size as the button. If 'iBorder' is negative, the border size will be set to zero.

Returns

An integer value that contains the previous border size in pixels.

Body Source
int CXTPagerCtrl::SetBorder(int iBorder) {
    ASSERT(::IsWindow(m_hWnd)); return Pager_SetBorder(m_hWnd, iBorder);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::SetButtonSize Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::SetButtonSize Method

This member function sets the current button size for the pager control.

int SetButtonSize(
    int iSize
);
Parameters

iSize
Integer value that contains the new button size in pixels.

Returns

An integer value that contains the previous button size in pixels.

Body Source
int CXTPagerCtrl::SetButtonSize(int iSize) {
    ASSERT(::IsWindow(m_hWnd)); return Pager_SetButtonSize(m_hWnd, iSize);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::SetChild Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::SetChild Method

This member function sets the contained window for the pager control. This command will not change the parent of the contained window. It only assigns a window handle to the pager control for scrolling. In most cases, the contained window will be a child window. If this is the case, the contained window should be a child of the pager control.

void SetChild(
    HWND hwndChild
);
Parameters

hwndChild
Handle to the window to be contained.

Body Source
void CXTPagerCtrl::SetChild(HWND hwndChild) {
    ASSERT(::IsWindow(m_hWnd)); Pager_SetChild(m_hWnd, hwndChild);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl::SetPos Method

CXTPagerCtrl Methods, CXTPagerCtrl Class, Body Source
CXTPagerCtrl::SetPos Method

This member function sets the scroll position for the pager control.

void SetPos(
    int iPos
);
Parameters

iPos
Integer value that contains the new scroll position in pixels.

Body Source
void CXTPagerCtrl::SetPos(int iPos) {
    ASSERT(::IsWindow(m_hWnd)); Pager_SetPos(m_hWnd, iPos);
}
Group

CXTPagerCtrl Methods


CXTPagerCtrl Constructors

CXTPagerCtrl Class, Legend, Public Methods
CXTPagerCtrl Constructors
Class

CXTPagerCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPagerCtrl | Constructs a CXTPagerCtrl object


CXTPagerCtrl::CXTPagerCtrl Constructor

CXTPagerCtrl Constructors, CXTPagerCtrl Class
CXTPagerCtrl::CXTPagerCtrl Constructor

Constructs a CXTPagerCtrl object

CXTPagerCtrl();
Group

CXTPagerCtrl Constructors


CXTPagerCtrl Destructors

CXTPagerCtrl Class, Legend, Public Methods
CXTPagerCtrl Destructors
Class

CXTPagerCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPagerCtrl | Destroys a CXTPagerCtrl object, handles cleanup and deallocation


CXTPagerCtrl::~CXTPagerCtrl Destructor

CXTPagerCtrl Destructors, CXTPagerCtrl Class
CXTPagerCtrl::~CXTPagerCtrl Destructor

Destroys a CXTPagerCtrl object, handles cleanup and deallocation

virtual ~CXTPagerCtrl();
Group

CXTPagerCtrl Destructors


CXTPPopupControl Class

XTPPopupControl.h, Classes, Legend, Members, Topics, CXTPPopupControl Structures, CXTPPopupControl Data Members, CXTPPopupControl Methods, CXTPPopupControl Constructors, CXTPPopupControl Destructors, CXTPPopupControl Constructors, CXTPPopupControl Data Members, CXTPPopupControl Destructors, CXTPPopupControl Methods, CXTPPopupControl Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl Class

CXTPPopupControl is a class for control of popup window

Class Hierarchy

class CXTPPopupControl : public CWnd;
File

XTPPopupControl.h

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTPPopupControl Constructors
CXTPPopupControl Constructors | Description
CXTPPopupControl | Constructs a CXTPPopupControl object.
CXTPPopupControl Data Members
CXTPPopupControl Data Members | Description
m_arrItems | array for controlled items
m_bAllowMove | If TRUE, the user can click and drag the popup window anywhere on the screen.
m_bRightToLeft | Right-To-Left layout
m_nAnimationInterval | value of animation interval of a popup window
m_nStep | value of step animation of a popup window
m_nTransparency | current value transparency of a popup window
m_paintTheme | Currently used theme.
m_pImageManager | Images of popup items.
m_popupAnimation | current animation method
m_popupState | current popup state
m_pPaintManager | point to CXTPPopupPaintManager object
m_pPressed | point to pressed item
m_pSelected | point to selected item
m_ptPopup | current XY size of a popup window
m_stateCurrent | Current descriptor
m_stateTarget | Target descriptor
m_szPopup | current XY location of a popup window
m_uAnimationDelay | value of animation delay of a popup window
m_uShowDelay | value of show delay of a popup window
CXTPPopupControl Destructors
CXTPPopupControl Destructors | Description
~CXTPPopupControl | Destroys a CXTPPopupControl object, all handles cleanup and deallocation.
CXTPPopupControl Methods
CXTPPopupControl Methods | Description
AddItem | Call this member function to install new controlled item in a popup window.
AllowMove | Call this member to specify whether the user can click and drag the popup window when it is displayed.
Animate | This method animates popup control
Close | Call this member to destroy a popup window.
Create | Creates a popup window
GetAnimateDelay | Call this member function to get the value of animate delay a popup window.
GetBackgroundBitmap | Call this member to get bitmap index for background.
GetImageManager | Call this method to get a pointer to the image manager of popup control.
GetItem | Call this member function to get a controlled item on an index
GetItemCount | Call this member function to get count of controlled items a popup window.
GetPaintManager | Call this member function to get the paint manager object used for drawing a popup window.
GetPopupAnimation | Call this member function to get the popup animation method.
GetPopupPos | Call this member function to get the position of a popup window.
GetPopupSize | Call this member function to get the size of a popup window.
GetPopupState | Call this member function to get the current state of a popup window.
GetShowDelay | Call this member function to get the value of show delay a popup window.
GetTheme | Call this member to get the theme that the popup window is currently using.
GetTransparency | Call this member function to get the transparency value a popup window.
Hide | Call this member for starting collapsing state of a popup window with the posterior destroy.
HitTest | Call this member function to testing a point for controlled items of a popup window.
IsLayoutRTL | Determines if right-to-left mode was set.
Notify | This method is called to notify parent about action.
OnClick | This method is called when user click on controlled item
OnCollapsing | This method is called to start collapsing animation
OnExpanding | This method is called to start expanding animation
OnShow | This method is called to show control
RedrawControl | Call this member function to redraw all controlled items of a popup window.
RemoveAllItems | Call this member function to remove all controlled items from a popup window.
RemoveItem |
SetAnimateDelay | Call this member function to set the value of animate delay a popup window.
SetAutoDelete | Call this member to let popup control delete self.
SetBackgroundBitmap | Call this member to set bitmap index for background.
SetImageManager | Call this method to set new image manager.
SetLayeredWindowAttributes | Updates current control transparency
SetLayoutRTL | Call this member to set right-to-left mode.
SetPopupAnimation |
SetPopupPos | Call this member function to set the position of a popup window.
SetPopupSize | Call this member function to set the size of a popup window.
SetPopupState | This method is called when current state of control changed.
SetShowDelay | Call this member function to set the value of show delay a popup window.
SetTheme |
SetTransparency | Call this member function to set the transparency value of a popup window.
Show | Call this member for create and starting expanding state of a popup window
TrackMove | Loop of control moving.
UpdateState | Updates position in animation according current animation step
CXTPPopupControl Structures
CXTPPopupControl Structures | Description
POPUPSTATE | Popup state descriptor


CXTPPopupControl Structures

CXTPPopupControl Class, Legend, Structures
CXTPPopupControl Structures
Class

CXTPPopupControl Class

Legend
Structure
Structures
Structure | Description
POPUPSTATE | Popup state descriptor


CXTPPopupControl::POPUPSTATE Structure

XTPPopupControl.h, CXTPPopupControl Structures, See Also
CXTPPopupControl::POPUPSTATE Structure

Popup state descriptor

struct POPUPSTATE {
  CRect rcPopup;
  int nTransparency;
};
File

XTPPopupControl.h

Members

rcPopup
Popup position
nTransparency
Popup transparency

See Also

CXTPPopupControl::m_stateTarget, CXTPPopupControl::m_stateCurrent

Group

CXTPPopupControl Structures


CXTPPopupControl Data Members

CXTPPopupControl Class, Legend, Protected Data Members
CXTPPopupControl Data Members
Class

CXTPPopupControl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrItems | array for controlled items
m_bAllowMove | If TRUE, the user can click and drag the popup window anywhere on the screen.
m_bRightToLeft | Right-To-Left layout
m_nAnimationInterval | value of animation interval of a popup window
m_nStep | value of step animation of a popup window
m_nTransparency | current value transparency of a popup window
m_paintTheme | Currently used theme.
m_pImageManager | Images of popup items.
m_popupAnimation | current animation method
m_popupState | current popup state
m_pPaintManager | point to CXTPPopupPaintManager object
m_pPressed | point to pressed item
m_pSelected | point to selected item
m_ptPopup | current XY size of a popup window
m_stateCurrent | Current descriptor
m_stateTarget | Target descriptor
m_szPopup | current XY location of a popup window
m_uAnimationDelay | value of animation delay of a popup window
m_uShowDelay | value of show delay of a popup window


CXTPPopupControl::m_arrItems Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_arrItems Data Member

array for controlled items

CArray<CXTPPopupItem*, CXTPPopupItem*> m_arrItems;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_bAllowMove Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_bAllowMove Data Member

If TRUE, the user can click and drag the popup window anywhere on the screen.

BOOL m_bAllowMove;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_bRightToLeft Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_bRightToLeft Data Member

Right-To-Left layout

BOOL m_bRightToLeft;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_nAnimationInterval Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_nAnimationInterval Data Member

value of animation interval of a popup window

UINT m_nAnimationInterval;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_nStep Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_nStep Data Member

value of step animation of a popup window

int m_nStep;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_nTransparency Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_nTransparency Data Member

current value transparency of a popup window

int m_nTransparency;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_paintTheme Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_paintTheme Data Member

Currently used theme.

XTPPopupPaintTheme m_paintTheme;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_pImageManager Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_pImageManager Data Member

Images of popup items.

CXTPImageManager* m_pImageManager;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_popupAnimation Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_popupAnimation Data Member

current animation method

XTPPopupAnimation m_popupAnimation;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_popupState Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_popupState Data Member

current popup state

XTPPopupState m_popupState;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_pPaintManager Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_pPaintManager Data Member

point to CXTPPopupPaintManager object

CXTPPopupPaintManager* m_pPaintManager;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_pPressed Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_pPressed Data Member

point to pressed item

CXTPPopupItem* m_pPressed;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_pSelected Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_pSelected Data Member

point to selected item

CXTPPopupItem* m_pSelected;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_ptPopup Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_ptPopup Data Member

current XY size of a popup window

CPoint m_ptPopup;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_stateCurrent Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_stateCurrent Data Member

Current descriptor

POPUPSTATE m_stateCurrent;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_stateTarget Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_stateTarget Data Member

Target descriptor

POPUPSTATE m_stateTarget;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_szPopup Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_szPopup Data Member

current XY location of a popup window

CSize m_szPopup;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_uAnimationDelay Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_uAnimationDelay Data Member

value of animation delay of a popup window

UINT m_uAnimationDelay;
Group

CXTPPopupControl Data Members


CXTPPopupControl::m_uShowDelay Data Member

CXTPPopupControl Data Members, CXTPPopupControl Class
CXTPPopupControl::m_uShowDelay Data Member

value of show delay of a popup window

UINT m_uShowDelay;
Group

CXTPPopupControl Data Members


CXTPPopupControl Methods

CXTPPopupControl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl Methods
Class

CXTPPopupControl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Animate | This method animates popup control
Create | Creates a popup window
Notify | This method is called to notify parent about action.
OnClick | This method is called when user click on controlled item
OnCollapsing | This method is called to start collapsing animation
OnExpanding | This method is called to start expanding animation
OnShow | This method is called to show control
SetLayeredWindowAttributes | Updates current control transparency
SetPopupState | This method is called when current state of control changed.
TrackMove | Loop of control moving.
UpdateState | Updates position in animation according current animation step
Public Methods
Public Methods
Public Method | Description
AddItem | Call this member function to install new controlled item in a popup window.
AllowMove | Call this member to specify whether the user can click and drag the popup window when it is displayed.
Close | Call this member to destroy a popup window.
GetAnimateDelay | Call this member function to get the value of animate delay a popup window.
GetBackgroundBitmap | Call this member to get bitmap index for background.
GetImageManager | Call this method to get a pointer to the image manager of popup control.
GetItem | Call this member function to get a controlled item on an index
GetItemCount | Call this member function to get count of controlled items a popup window.
GetPaintManager | Call this member function to get the paint manager object used for drawing a popup window.
GetPopupAnimation | Call this member function to get the popup animation method.
GetPopupPos | Call this member function to get the position of a popup window.
GetPopupSize | Call this member function to get the size of a popup window.
GetPopupState | Call this member function to get the current state of a popup window.
GetShowDelay | Call this member function to get the value of show delay a popup window.
GetTheme | Call this member to get the theme that the popup window is currently using.
GetTransparency | Call this member function to get the transparency value a popup window.
Hide | Call this member for starting collapsing state of a popup window with the posterior destroy.
HitTest | Call this member function to testing a point for controlled items of a popup window.
IsLayoutRTL | Determines if right-to-left mode was set.
RedrawControl | Call this member function to redraw all controlled items of a popup window.
RemoveAllItems | Call this member function to remove all controlled items from a popup window.
RemoveItem |
SetAnimateDelay | Call this member function to set the value of animate delay a popup window.
SetAutoDelete | Call this member to let popup control delete self.
SetBackgroundBitmap | Call this member to set bitmap index for background.
SetImageManager | Call this method to set new image manager.
SetLayoutRTL | Call this member to set right-to-left mode.
SetPopupAnimation |
SetPopupPos | Call this member function to set the position of a popup window.
SetPopupSize | Call this member function to set the size of a popup window.
SetShowDelay | Call this member function to set the value of show delay a popup window.
SetTheme |
SetTransparency | Call this member function to set the transparency value of a popup window.
Show | Call this member for create and starting expanding state of a popup window


CXTPPopupControl::AddItem Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::AddItem Method

Call this member function to install new controlled item in a popup window.

CXTPPopupItem* AddItem(
    CXTPPopupItem* pItem
);
Parameters

pItem
Point to CXTPPopupItem object which will be installed in a popup window.

Returns

Point to the installed CXTPPopupItem object.

Group

CXTPPopupControl Methods


CXTPPopupControl::AllowMove Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::AllowMove Method

Call this member to specify whether the user can click and drag the popup window when it is displayed.

void AllowMove(
    BOOL bAllowMove
);
Parameters

bAllowMove
TRUE to allow the user can click and drag the popup window anywhere on the screen. If FALSE, the popup window cannot be moved by the user.

Body Source
void CXTPPopupControl::AllowMove(BOOL bAllowMove) {
    m_bAllowMove = bAllowMove;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::Animate Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::Animate Method

This method animates popup control

void Animate(
    int nStep
);
Parameters

nStep
Current step of animation.

Group

CXTPPopupControl Methods


CXTPPopupControl::Close Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::Close Method

Call this member to destroy a popup window.

BOOL Close();
Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPPopupControl Methods


CXTPPopupControl::Create Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::Create Method

Creates a popup window

virtual BOOL Create(
    CWnd* pParentWnd
);
Parameters

pParentWnd
Pointer to the parent window.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPPopupControl Methods


CXTPPopupControl::GetAnimateDelay Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::GetAnimateDelay Method

Call this member function to get the value of animate delay a popup window.

DWORD GetAnimateDelay() const;
Returns

Transparency value of animate delay in milliseconds.

Body Source
DWORD CXTPPopupControl::GetAnimateDelay() const {
    return m_uAnimationDelay;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::GetBackgroundBitmap Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::GetBackgroundBitmap Method

Call this member to get bitmap index for background.

int GetBackgroundBitmap() const;
See Also

SetBackgroundBitmap

Body Source
int CXTPPopupControl::GetBackgroundBitmap() const {
    return m_nBackgroundBitmap;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::GetImageManager Method

CXTPPopupControl Methods, CXTPPopupControl Class, See Also
CXTPPopupControl::GetImageManager Method

Call this method to get a pointer to the image manager of popup control.

CXTPImageManager* GetImageManager() const;
Returns

Pointer to the image manager of popup control.

Remarks

The image manager is used to hold all of the icons displayed in the popup control.

See Also

SetImageManager

Group

CXTPPopupControl Methods


CXTPPopupControl::GetItem Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::GetItem Method

Call this member function to get a controlled item on an index

CXTPPopupItem* GetItem(
    int nIndex
) const;
Parameters

nIndex
Index of a controlled item.

Returns

Point to CXTPPopupItem object.

Group

CXTPPopupControl Methods


CXTPPopupControl::GetItemCount Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::GetItemCount Method

Call this member function to get count of controlled items a popup window.

int GetItemCount() const;
Returns

Count of controlled items.

Group

CXTPPopupControl Methods


CXTPPopupControl::GetPaintManager Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::GetPaintManager Method

Call this member function to get the paint manager object used for drawing a popup window.

CXTPPopupPaintManager* GetPaintManager() const;
Returns

Point of paint manager object.

Body Source
CXTPPopupPaintManager* CXTPPopupControl::GetPaintManager() const {
    return m_pPaintManager;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::GetPopupAnimation Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::GetPopupAnimation Method

Call this member function to get the popup animation method.

XTPPopupAnimation GetPopupAnimation() const;
Returns

Method in use, see XTPPopupAnimation enum.

Body Source
XTPPopupAnimation CXTPPopupControl::GetPopupAnimation() const {
    return m_popupAnimation;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::GetPopupPos Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::GetPopupPos Method

Call this member function to get the position of a popup window.

CPoint GetPopupPos() const;
Returns

A CPoint object containing XY location.

Group

CXTPPopupControl Methods


CXTPPopupControl::GetPopupSize Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::GetPopupSize Method

Call this member function to get the size of a popup window.

CSize GetPopupSize() const;
Returns

A CSize object containing XY size.

Body Source
CSize CXTPPopupControl::GetPopupSize() const {
    return m_szPopup;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::GetPopupState Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::GetPopupState Method

Call this member function to get the current state of a popup window.

XTPPopupState GetPopupState() const;
Returns

Current state, see XTPPopupState enum.

Group

CXTPPopupControl Methods


CXTPPopupControl::GetShowDelay Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::GetShowDelay Method

Call this member function to get the value of show delay a popup window.

DWORD GetShowDelay() const;
Returns

Transparency value of show delay in milliseconds.

Body Source
DWORD CXTPPopupControl::GetShowDelay() const {
    return m_uShowDelay;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::GetTheme Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::GetTheme Method

Call this member to get the theme that the popup window is currently using.

XTPPopupPaintTheme GetTheme() const;
Returns

The currently used theme of the popup window drawing.

See Also

SetTheme, XTPPopupPaintTheme

Body Source
XTPPopupPaintTheme CXTPPopupControl::GetTheme() const {
    return m_paintTheme;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::GetTransparency Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::GetTransparency Method

Call this member function to get the transparency value a popup window.

BYTE GetTransparency() const;
Returns

Transparency value of a popup window.

Body Source
BYTE CXTPPopupControl::GetTransparency() const {
    return (BYTE)m_nTransparency;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::Hide Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::Hide Method

Call this member for starting collapsing state of a popup window with the posterior destroy.

void Hide();
Group

CXTPPopupControl Methods


CXTPPopupControl::HitTest Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::HitTest Method

Call this member function to testing a point for controlled items of a popup window.

CXTPPopupItem* HitTest(
    CPoint pt
) const;
Parameters

pt
a CPoint object containing XY location for testing.

Returns

Point to CXTPPopupItem object if test is successful, otherwise returns NULL.

Group

CXTPPopupControl Methods


CXTPPopupControl::IsLayoutRTL Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::IsLayoutRTL Method

Determines if right-to-left mode was set.

BOOL IsLayoutRTL() const;
Returns

TRUE if text is displayed using right-to-left reading-order properties.

Body Source
BOOL CXTPPopupControl::IsLayoutRTL() const {
    return m_bRightToLeft;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::Notify Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::Notify Method

This method is called to notify parent about action.

virtual void Notify(
    WPARAM wParam,
    LPARAM lParam
);
Parameters

wParam
Occured action
lParam
Extended parameter.

Group

CXTPPopupControl Methods


CXTPPopupControl::OnClick Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::OnClick Method

This method is called when user click on controlled item

virtual void OnClick(
    CXTPPopupItem* pItem
);
Parameters

pItem
Item has been clicked.

Group

CXTPPopupControl Methods


CXTPPopupControl::OnCollapsing Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::OnCollapsing Method

This method is called to start collapsing animation

virtual void OnCollapsing();
Group

CXTPPopupControl Methods


CXTPPopupControl::OnExpanding Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::OnExpanding Method

This method is called to start expanding animation

virtual void OnExpanding(
    BOOL bUpdateCurrent
);
Parameters

bUpdateCurrent
TRUE to update current state.

Group

CXTPPopupControl Methods


CXTPPopupControl::OnShow Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::OnShow Method

This method is called to show control

virtual void OnShow();
Group

CXTPPopupControl Methods


CXTPPopupControl::RedrawControl Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::RedrawControl Method

Call this member function to redraw all controlled items of a popup window.

void RedrawControl();
Group

CXTPPopupControl Methods


CXTPPopupControl::RemoveAllItems Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::RemoveAllItems Method

Call this member function to remove all controlled items from a popup window.

void RemoveAllItems();
Group

CXTPPopupControl Methods


RemoveItem Method

CXTPPopupControl Methods
RemoveItem Method
Overload List
Methods
Method | Description
CXTPPopupControl::RemoveItem (CXTPPopupItem*) | Call this member function to remove controlled item from a popup window.
CXTPPopupControl::RemoveItem (int) | Call this member function to remove controlled item from a popup window.
Group

CXTPPopupControl Methods


CXTPPopupControl::RemoveItem Method (CXTPPopupItem*)

RemoveItem Method, CXTPPopupControl Class
CXTPPopupControl::RemoveItem Method (CXTPPopupItem*)

Call this member function to remove controlled item from a popup window.

void RemoveItem(
    CXTPPopupItem* pItem
);
void RemoveItem(
    int nIndex
);
Parameters

pItem
Point to CXTPPopupItem object which will be removed
nIndex
Index of item to remove from control

Group

RemoveItem Method


CXTPPopupControl::SetAnimateDelay Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetAnimateDelay Method

Call this member function to set the value of animate delay a popup window.

void SetAnimateDelay(
    DWORD dwAnimateDelay
);
Parameters

dwAnimateDelay
value of animate delay in milliseconds .

Body Source
void CXTPPopupControl::SetAnimateDelay(DWORD dwAnimateDelay) {
    m_uAnimationDelay = dwAnimateDelay;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::SetAutoDelete Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetAutoDelete Method

Call this member to let popup control delete self.

void SetAutoDelete(
    BOOL bAutoDelete
);
Parameters

bAutoDelete
TRUE to delete control automatically after popup control will be closed.

Body Source
void CXTPPopupControl::SetAutoDelete(BOOL bAutoDelete) {
    m_bAutoDelete = bAutoDelete;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::SetBackgroundBitmap Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetBackgroundBitmap Method

Call this member to set bitmap index for background.

void SetBackgroundBitmap(
    int nBackgroundBitmap
);
Parameters

nBackgroundBitmap
Index of bitmap in IamgeMnaager to set as background and region for control

Body Source
void CXTPPopupControl::SetBackgroundBitmap(int nBackgroundBitmap) {
    m_nBackgroundBitmap = nBackgroundBitmap;
    UpdateBitmapRegion();
}
Group

CXTPPopupControl Methods


CXTPPopupControl::SetImageManager Method

CXTPPopupControl Methods, CXTPPopupControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetImageManager Method

Call this method to set new image manager.

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Points to a CXTPImageManager object to be set

See Also

GetImageManager

Example
    CXTPImageManager* pImageManager = new CXTPImageManager();
    pImageManager->SetIcons(IDR_MAINFRAME);
    m_wndPopupControl.SetImageManager(pImageManager);
Group

CXTPPopupControl Methods


CXTPPopupControl::SetLayeredWindowAttributes Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::SetLayeredWindowAttributes Method

Updates current control transparency

BOOL SetLayeredWindowAttributes(
    int bAlpha
);
Parameters

bAlpha
Current alpha level of window

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPPopupControl Methods


CXTPPopupControl::SetLayoutRTL Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::SetLayoutRTL Method

Call this member to set right-to-left mode.

void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPPopupControl Methods


SetPopupAnimation Method

CXTPPopupControl Methods
SetPopupAnimation Method
Overload List
Methods
Method | Description
CXTPPopupControl::SetPopupAnimation () | Call this member function to set the default popup animation method.
CXTPPopupControl::SetPopupAnimation (XTPPopupAnimation) | Call this member function to set the popup animation method.
Group

CXTPPopupControl Methods


CXTPPopupControl::SetPopupAnimation Method ()

SetPopupAnimation Method, CXTPPopupControl Class
CXTPPopupControl::SetPopupAnimation Method ()

Call this member function to set the default popup animation method.

void SetPopupAnimation();
Group

SetPopupAnimation Method


CXTPPopupControl::SetPopupAnimation Method (XTPPopupAnimation)

SetPopupAnimation Method, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetPopupAnimation Method (XTPPopupAnimation)

Call this member function to set the popup animation method.

void SetPopupAnimation(
    XTPPopupAnimation popupAnimation
);
Parameters

popupAnimation
method in use, see XTPPopupAnimation enum.

Body Source
void CXTPPopupControl::SetPopupAnimation(XTPPopupAnimation popupAnimation) {
    m_popupAnimation = popupAnimation;
}
Group

SetPopupAnimation Method


CXTPPopupControl::SetPopupPos Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetPopupPos Method

Call this member function to set the position of a popup window.

void SetPopupPos(
    CPoint ptPopup
);
Parameters

ptPopup
a CPoint object containing XY location.

Body Source
void CXTPPopupControl::SetPopupPos(CPoint ptPopup) {
    m_ptPopup = ptPopup;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::SetPopupSize Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetPopupSize Method

Call this member function to set the size of a popup window.

void SetPopupSize(
    CSize szPopup
);
Parameters

szPopup
A CSize object containing XY size.

Body Source
void CXTPPopupControl::SetPopupSize(CSize szPopup) {
    m_szPopup = szPopup;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::SetPopupState Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::SetPopupState Method

This method is called when current state of control changed.

void SetPopupState(
    XTPPopupState popupState
);
Parameters

popupState
Current state of control.

Group

CXTPPopupControl Methods


CXTPPopupControl::SetShowDelay Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetShowDelay Method

Call this member function to set the value of show delay a popup window.

void SetShowDelay(
    DWORD dwShowDelay
);
Parameters

dwShowDelay
value of show delay in milliseconds.

Body Source
void CXTPPopupControl::SetShowDelay(DWORD dwShowDelay) {
    m_uShowDelay = dwShowDelay;
}
Group

CXTPPopupControl Methods


SetTheme Method

CXTPPopupControl Methods
SetTheme Method
Overload List
Methods
Method | Description
CXTPPopupControl::SetTheme (CXTPPopupPaintManager*) | Call this member function to set the paint manager or paint theme used for drawing a popup window.
CXTPPopupControl::SetTheme (XTPPopupPaintTheme) | Call this member function to set the paint manager or paint theme used for drawing a popup window.
Group

CXTPPopupControl Methods


CXTPPopupControl::SetTheme Method (XTPPopupPaintTheme)

SetTheme Method, CXTPPopupControl Class
CXTPPopupControl::SetTheme Method (XTPPopupPaintTheme)

Call this member function to set the paint manager or paint theme used for drawing a popup window.

void SetTheme(
    XTPPopupPaintTheme theme
);
void SetTheme(
    CXTPPopupPaintManager* pPaintManager
);
Parameters

theme
theme of popup window drawing, see XTPPopupPaintTheme enum.
pPaintManager
point of paint manager object.

Group

SetTheme Method


CXTPPopupControl::SetTransparency Method

CXTPPopupControl Methods, CXTPPopupControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupControl::SetTransparency Method

Call this member function to set the transparency value of a popup window.

void SetTransparency(
    BYTE bTransp
);
Parameters

bTransp
value of transparency (0...255). If bTransp = 0 the popup window is full transparent, otherwise if bTransp = 255 the popup window is full opaque.

Body Source
void CXTPPopupControl::SetTransparency(BYTE nTransparency) {
    m_nTransparency = nTransparency;
}
Group

CXTPPopupControl Methods


CXTPPopupControl::Show Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::Show Method

Call this member for create and starting expanding state of a popup window

BOOL Show(
    CWnd* pParent
);
Parameters

pParent
points to a CWnd object that represents the parent window.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPPopupControl Methods


CXTPPopupControl::TrackMove Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::TrackMove Method

Loop of control moving.

void TrackMove();
Group

CXTPPopupControl Methods


CXTPPopupControl::UpdateState Method

CXTPPopupControl Methods, CXTPPopupControl Class
CXTPPopupControl::UpdateState Method

Updates position in animation according current animation step

void UpdateState(
    BOOL bInit = FALSE
);
Parameters

bInit
Initial step of animation.

Group

CXTPPopupControl Methods


CXTPPopupControl Constructors

CXTPPopupControl Class, Legend, Public Methods
CXTPPopupControl Constructors
Class

CXTPPopupControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupControl | Constructs a CXTPPopupControl object.


CXTPPopupControl::CXTPPopupControl Constructor

CXTPPopupControl Constructors, CXTPPopupControl Class
CXTPPopupControl::CXTPPopupControl Constructor

Constructs a CXTPPopupControl object.

CXTPPopupControl();
Group

CXTPPopupControl Constructors


CXTPPopupControl Destructors

CXTPPopupControl Class, Legend, Public Methods
CXTPPopupControl Destructors
Class

CXTPPopupControl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPopupControl | Destroys a CXTPPopupControl object, all handles cleanup and deallocation.


CXTPPopupControl::~CXTPPopupControl Destructor

CXTPPopupControl Destructors, CXTPPopupControl Class
CXTPPopupControl::~CXTPPopupControl Destructor

Destroys a CXTPPopupControl object, all handles cleanup and deallocation.

virtual ~CXTPPopupControl();
Group

CXTPPopupControl Destructors


CXTPPopupItem Class

XTPPopupItem.h, Classes, Legend, Members, Topics, CXTPPopupItem Data Members, CXTPPopupItem Methods, CXTPPopupItem Constructors, CXTPPopupItem Destructors, CXTPPopupItem Constructors, CXTPPopupItem Data Members, CXTPPopupItem Destructors, CXTPPopupItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupItem Class

CXTPPopupItem is a class used to management popup item object

Class Hierarchy

class CXTPPopupItem;
File

XTPPopupItem.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPopupItem Constructors
CXTPPopupItem Constructors | Description
CXTPPopupItem | Constructs a CXTPPopupItem object.
CXTPPopupItem Data Members
CXTPPopupItem Data Members | Description
m_bBold | Flag of bold state text
m_bButton | Flag of button state
m_bHyperLink | Flag of a hyperlink support
m_clrBackground | Background color
m_clrBorder | Border color
m_clrText | Text color
m_fntText | Font of an item text
m_nAlign | Alignment style of an item text
m_nIconIndex | Icon Index in parent image maanger;
m_nID | ID number of an item
m_nIndex | Index of item in parent list.
m_pControl | Point to CXTPPopupControl object containing this item
m_pRichRender | Richext Render
m_ptOffset | Icon offset
m_rcItem | Rectangular of an item
m_strCaption | Caption string
CXTPPopupItem Destructors
CXTPPopupItem Destructors | Description
~CXTPPopupItem | Destroys a CXTPPopupItem object.
CXTPPopupItem Methods
CXTPPopupItem Methods | Description
CalculateHeight | Call this member function to update rectangular height of a text.
CalculateWidth | Call this member function to update rectangular width of a text.
CenterIcon | Calculates offset to move icon in center.
Draw | This method is called to draw the item.
GetBackgroundColor | Call this member to get the background color of an item.
GetBorderColor | Call this member to get the border color of an item.
GetCaption | Call this member function to get the text of an item.
GetIconIndex | Retrieves icon index.
GetIconOffset | Retrieve icon offset.
GetID | Call this member function to get ID number of an item. window.
GetImage | Call this member function to get a handle the normal, selected ore pressed icon from icon item.
GetPopupControl | Returns parent popup control object.
GetRect | Call this member function to get rectangular of an item.
GetTextAlignment | Call this member function to get the alignment of an item text.
GetTextColor | Call this member function to get the color of an item text.
GetTextFont | Call this member function to set the font of an item text.
IsBold | Call this member function to get bold state of a text item.
IsButton | Call this member function to get button state of an item.
IsHyperLink | Call this member function to get hyperlink support of a text item.
IsPressed | Call this member function to get pressed state of an item.
IsSelected | Call this member function to get selected state of an item.
OnItemInserted | This method is called when item is inserted to control.
RedrawControl | Call this method to redraw parent control.
SetBold | Call this member function to set bold state of a text item.
SetButton | Call this member function to set button state of an item.
SetCaption | Call this member function to set the text of an item.
SetHyperLink | Call this member function to set hyperlink support of a text item.
SetIcon | Call this member function to set the normal, selected ore pressed icon for icon item.
SetIconIndex | Call this method to set icon index of item.
SetIcons |
SetID | Call this member function to set ID number for an item.
SetRTFText | Call this member function to set RichText of an item.
SetTextAlignment | Call this member function to set the alignment of an item text.
SetTextColor | Call this member function to set the color of an item text.
SetTextFont |


CXTPPopupItem Data Members

CXTPPopupItem Class, Legend, Protected Data Members
CXTPPopupItem Data Members
Class

CXTPPopupItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bBold | Flag of bold state text
m_bButton | Flag of button state
m_bHyperLink | Flag of a hyperlink support
m_clrBackground | Background color
m_clrBorder | Border color
m_clrText | Text color
m_fntText | Font of an item text
m_nAlign | Alignment style of an item text
m_nIconIndex | Icon Index in parent image maanger;
m_nID | ID number of an item
m_nIndex | Index of item in parent list.
m_pControl | Point to CXTPPopupControl object containing this item
m_pRichRender | Richext Render
m_ptOffset | Icon offset
m_rcItem | Rectangular of an item
m_strCaption | Caption string


CXTPPopupItem::m_bBold Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_bBold Data Member

Flag of bold state text

BOOL m_bBold;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_bButton Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_bButton Data Member

Flag of button state

BOOL m_bButton;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_bHyperLink Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_bHyperLink Data Member

Flag of a hyperlink support

BOOL m_bHyperLink;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_clrBackground Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_clrBackground Data Member

Background color

COLORREF m_clrBackground;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_clrBorder Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_clrBorder Data Member

Border color

COLORREF m_clrBorder;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_clrText Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_clrText Data Member

Text color

COLORREF m_clrText;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_fntText Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_fntText Data Member

Font of an item text

CFont m_fntText;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_nAlign Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_nAlign Data Member

Alignment style of an item text

int m_nAlign;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_nIconIndex Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_nIconIndex Data Member

Icon Index in parent image maanger;

int m_nIconIndex;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_nID Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_nID Data Member

ID number of an item

int m_nID;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_nIndex Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_nIndex Data Member

Index of item in parent list.

int m_nIndex;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_pControl Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_pControl Data Member

Point to CXTPPopupControl object containing this item

CXTPPopupControl* m_pControl;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_pRichRender Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_pRichRender Data Member

Richext Render

CXTPRichRender* m_pRichRender;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_ptOffset Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_ptOffset Data Member

Icon offset

CPoint m_ptOffset;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_rcItem Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_rcItem Data Member

Rectangular of an item

CRect m_rcItem;
Group

CXTPPopupItem Data Members


CXTPPopupItem::m_strCaption Data Member

CXTPPopupItem Data Members, CXTPPopupItem Class
CXTPPopupItem::m_strCaption Data Member

Caption string

CString m_strCaption;
Group

CXTPPopupItem Data Members


CXTPPopupItem Methods

CXTPPopupItem Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupItem Methods
Class

CXTPPopupItem Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnItemInserted | This method is called when item is inserted to control.
RedrawControl | Call this method to redraw parent control.
Public Methods
Public Methods
Public Method | Description
CalculateHeight | Call this member function to update rectangular height of a text.
CalculateWidth | Call this member function to update rectangular width of a text.
CenterIcon | Calculates offset to move icon in center.
Draw | This method is called to draw the item.
GetBackgroundColor | Call this member to get the background color of an item.
GetBorderColor | Call this member to get the border color of an item.
GetCaption | Call this member function to get the text of an item.
GetIconIndex | Retrieves icon index.
GetIconOffset | Retrieve icon offset.
GetID | Call this member function to get ID number of an item. window.
GetImage | Call this member function to get a handle the normal, selected ore pressed icon from icon item.
GetPopupControl | Returns parent popup control object.
GetRect | Call this member function to get rectangular of an item.
GetTextAlignment | Call this member function to get the alignment of an item text.
GetTextColor | Call this member function to get the color of an item text.
GetTextFont | Call this member function to set the font of an item text.
IsBold | Call this member function to get bold state of a text item.
IsButton | Call this member function to get button state of an item.
IsHyperLink | Call this member function to get hyperlink support of a text item.
IsPressed | Call this member function to get pressed state of an item.
IsSelected | Call this member function to get selected state of an item.
SetBold | Call this member function to set bold state of a text item.
SetButton | Call this member function to set button state of an item.
SetCaption | Call this member function to set the text of an item.
SetHyperLink | Call this member function to set hyperlink support of a text item.
SetIcon | Call this member function to set the normal, selected ore pressed icon for icon item.
SetIconIndex | Call this method to set icon index of item.
SetIcons |
SetID | Call this member function to set ID number for an item.
SetRTFText | Call this member function to set RichText of an item.
SetTextAlignment | Call this member function to set the alignment of an item text.
SetTextColor | Call this member function to set the color of an item text.
SetTextFont |


CXTPPopupItem::CalculateHeight Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::CalculateHeight Method

Call this member function to update rectangular height of a text.

void CalculateHeight();
Group

CXTPPopupItem Methods


CXTPPopupItem::CalculateWidth Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::CalculateWidth Method

Call this member function to update rectangular width of a text.

void CalculateWidth();
Group

CXTPPopupItem Methods


CXTPPopupItem::CenterIcon Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::CenterIcon Method

Calculates offset to move icon in center.

void CenterIcon();
Group

CXTPPopupItem Methods


CXTPPopupItem::Draw Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::Draw Method

This method is called to draw the item.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
A CDC pointer that represents the current device context.

Group

CXTPPopupItem Methods


CXTPPopupItem::GetBackgroundColor Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetBackgroundColor Method

Call this member to get the background color of an item.

COLORREF GetBackgroundColor() const;
Returns

The background color of a popup control item.

Body Source
COLORREF CXTPPopupItem::GetBackgroundColor() const {
    return m_clrBackground;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetBorderColor Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetBorderColor Method

Call this member to get the border color of an item.

COLORREF GetBorderColor() const;
Returns

The border color of a popup control item.

Body Source
COLORREF CXTPPopupItem::GetBorderColor() const {
    return m_clrBorder;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetCaption Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetCaption Method

Call this member function to get the text of an item.

CString GetCaption() const;
Returns

A CString object that represents the item text.

Body Source
CString CXTPPopupItem::GetCaption() const {
    return m_strCaption;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetIconIndex Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupItem::GetIconIndex Method

Retrieves icon index.

int GetIconIndex() const;
Returns

Icon index.

See Also

SetIconIndex, CXTPPopupControl::GetImageManager

Body Source
int CXTPPopupItem::GetIconIndex() const {
    return m_nIconIndex == -1 ? m_nIndex : m_nIconIndex;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetIconOffset Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetIconOffset Method

Retrieve icon offset.

CPoint GetIconOffset() const;
Returns

Poisition of icon inside item bounding rectangle.

Body Source
CPoint CXTPPopupItem::GetIconOffset() const {
    return m_ptOffset;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetID Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetID Method

Call this member function to get ID number of an item. window.

int GetID() const;
Returns

Value of ID number.

Body Source
int CXTPPopupItem::GetID() const {
    return m_nID;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetImage Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::GetImage Method

Call this member function to get a handle the normal, selected ore pressed icon from icon item.

CXTPImageManagerIcon* GetImage() const;
Returns

CXTPImageManagerIcon pointer to icon.

Group

CXTPPopupItem Methods


CXTPPopupItem::GetPopupControl Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetPopupControl Method

Returns parent popup control object.

CXTPPopupControl* GetPopupControl() const;
Returns

Pointer to parent CXTPPopupControl.

Body Source
CXTPPopupControl* CXTPPopupItem::GetPopupControl() const {
    return m_pControl;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetRect Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetRect Method

Call this member function to get rectangular of an item.

CRect GetRect() const;
Returns

CRect object containing rectangular of an item.

Body Source
CRect CXTPPopupItem::GetRect() const {
    return m_rcItem;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetTextAlignment Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetTextAlignment Method

Call this member function to get the alignment of an item text.

int GetTextAlignment() const;
Returns

The alignment style of an item text.

Body Source
int CXTPPopupItem::GetTextAlignment() const {
    return m_nAlign;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetTextColor Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::GetTextColor Method

Call this member function to get the color of an item text.

COLORREF GetTextColor() const;
Returns

A COLORREF object that represents the color of an item text.

Body Source
COLORREF CXTPPopupItem::GetTextColor() const {
    return m_clrText;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::GetTextFont Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::GetTextFont Method

Call this member function to set the font of an item text.

virtual CFont* GetTextFont();
Returns

Pointer to CFont object.

Group

CXTPPopupItem Methods


CXTPPopupItem::IsBold Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::IsBold Method

Call this member function to get bold state of a text item.

BOOL IsBold() const;
Returns

TRUE if item state is bold, otherwise returns FALSE.

Body Source
BOOL CXTPPopupItem::IsBold() const {
    return m_bBold;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::IsButton Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::IsButton Method

Call this member function to get button state of an item.

BOOL IsButton() const;
Returns

TRUE if button state is enabled, otherwise returns FALSE.

Body Source
BOOL CXTPPopupItem::IsButton() const {
    return m_bButton;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::IsHyperLink Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::IsHyperLink Method

Call this member function to get hyperlink support of a text item.

BOOL IsHyperLink() const;
Returns

TRUE if hyperlink support, otherwise returns FALSE.

Body Source
BOOL CXTPPopupItem::IsHyperLink() const {
    return m_bHyperLink;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::IsPressed Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::IsPressed Method

Call this member function to get pressed state of an item.

BOOL IsPressed() const;
Returns

TRUE if item pressed, otherwise returns FALSE.

Group

CXTPPopupItem Methods


CXTPPopupItem::IsSelected Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::IsSelected Method

Call this member function to get selected state of an item.

BOOL IsSelected() const;
Returns

TRUE if item selected, otherwise returns FALSE.

Group

CXTPPopupItem Methods


CXTPPopupItem::OnItemInserted Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::OnItemInserted Method

This method is called when item is inserted to control.

virtual void OnItemInserted();
Group

CXTPPopupItem Methods


CXTPPopupItem::RedrawControl Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::RedrawControl Method

Call this method to redraw parent control.

void RedrawControl();
Group

CXTPPopupItem Methods


CXTPPopupItem::SetBold Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::SetBold Method

Call this member function to set bold state of a text item.

void SetBold(
    BOOL bBold
);
Parameters

bBold
TRUE to set bold state, FALSE otherwise.

Body Source
void CXTPPopupItem::SetBold(BOOL bBold) {
    m_bBold = bBold;
    RedrawControl();
}
Group

CXTPPopupItem Methods


CXTPPopupItem::SetButton Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::SetButton Method

Call this member function to set button state of an item.

void SetButton(
    BOOL bButton
);
Parameters

bButton
TRUE to enable button state, FALSE otherwise.

Body Source
void CXTPPopupItem::SetButton(BOOL bButton) {
    m_bButton = bButton;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::SetCaption Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::SetCaption Method

Call this member function to set the text of an item.

void SetCaption(
    LPCTSTR str
);
Parameters

str
a CString object that represents the item text.

Group

CXTPPopupItem Methods


CXTPPopupItem::SetHyperLink Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::SetHyperLink Method

Call this member function to set hyperlink support of a text item.

void SetHyperLink(
    BOOL bHyperLink
);
Parameters

bHyperLink
TRUE to set hyperlink support, FALSE otherwise.

Body Source
void CXTPPopupItem::SetHyperLink(BOOL bHyperLink) {
    m_bHyperLink = bHyperLink;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::SetIcon Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::SetIcon Method

Call this member function to set the normal, selected ore pressed icon for icon item.

void SetIcon(
    HICON hIcon,
    XTPPopupItemIcon itemIcon = xtpPopupItemIconNormal
);
Parameters

hIcon
Handle to the icon.
itemIcon
type of icon in use, see XTPPopupItemIcon.

Group

CXTPPopupItem Methods


CXTPPopupItem::SetIconIndex Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupItem::SetIconIndex Method

Call this method to set icon index of item.

void SetIconIndex(
    int nIconIndex
);
Parameters

nIconIndex
Icon index to be set.

See Also

GetIconIndex, CXTPPopupControl::GetImageManager

Body Source
void CXTPPopupItem::SetIconIndex(int nIconIndex) {
    m_nIconIndex = nIconIndex;
    RedrawControl();
}
Group

CXTPPopupItem Methods


SetIcons Method

CXTPPopupItem Methods
SetIcons Method
Overload List
Methods
Method | Description
CXTPPopupItem::SetIcons (HBITMAP, COLORREF, int) | Call this member function to set the normal, selected ore pressed icon from resource bitmap picture.
CXTPPopupItem::SetIcons (UINT, COLORREF, int) | Call this member function to set the normal, selected ore pressed icon from resource bitmap picture.
Group

CXTPPopupItem Methods


CXTPPopupItem::SetIcons Method (UINT, COLORREF, int)

SetIcons Method, CXTPPopupItem Class
CXTPPopupItem::SetIcons Method (UINT, COLORREF, int)

Call this member function to set the normal, selected ore pressed icon from resource bitmap picture.

BOOL SetIcons(
    UINT nIDBitmap,
    COLORREF clrTransparent,
    int itemIcon
);
BOOL SetIcons(
    HBITMAP hBitmap,
    COLORREF clrTransparent,
    int itemIcon
);
Parameters

nIDBitmap
Resource ID for the bitmap.
clrTransparent
transparent color.
itemIcon
type of icon in use, see XTPPopupItemIcon.
hBitmap
bitmap handle to set.

Returns

TRUE if successful, otherwise returns FALSE.

Group

SetIcons Method


CXTPPopupItem::SetID Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::SetID Method

Call this member function to set ID number for an item.

void SetID(
    int nID
);
Parameters

nID
value of ID number.

Body Source
void CXTPPopupItem::SetID(int nID) {
    m_nID = nID;
}
Group

CXTPPopupItem Methods


CXTPPopupItem::SetRTFText Method

CXTPPopupItem Methods, CXTPPopupItem Class
CXTPPopupItem::SetRTFText Method

Call this member function to set RichText of an item.

void SetRTFText(
    LPCTSTR str
);
Parameters

str
a CString object that represents the item text.

Group

CXTPPopupItem Methods


CXTPPopupItem::SetTextAlignment Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::SetTextAlignment Method

Call this member function to set the alignment of an item text.

void SetTextAlignment(
    int nAlign
);
Parameters

nAlign
The alignment style of an item text.

Body Source
void CXTPPopupItem::SetTextAlignment(int nAlign) {
    m_nAlign = nAlign;
    RedrawControl();
}
Group

CXTPPopupItem Methods


CXTPPopupItem::SetTextColor Method

CXTPPopupItem Methods, CXTPPopupItem Class, Body Source
CXTPPopupItem::SetTextColor Method

Call this member function to set the color of an item text.

void SetTextColor(
    COLORREF clrText
);
Parameters

clrText
COLORREF object that represents the color of an item text.

Body Source
void CXTPPopupItem::SetTextColor(COLORREF clrText) {
    m_clrText = clrText;
    RedrawControl();
}
Group

CXTPPopupItem Methods


SetTextFont Method

CXTPPopupItem Methods
SetTextFont Method
Overload List
Methods
Method | Description
CXTPPopupItem::SetTextFont (CFont*) | Call this member function to set the font of an item text.
CXTPPopupItem::SetTextFont (PLOGFONT) | Call this member function to set the font of an item text.
Group

CXTPPopupItem Methods


CXTPPopupItem::SetTextFont Method (CFont*)

SetTextFont Method, CXTPPopupItem Class
CXTPPopupItem::SetTextFont Method (CFont*)

Call this member function to set the font of an item text.

void SetTextFont(
    CFont* pFntText
);
void SetTextFont(
    PLOGFONT pLogfText
);
Parameters

pFntText
point to CFont object.
pLogfText
point to LOGFONT structure.

Group

SetTextFont Method


CXTPPopupItem Constructors

CXTPPopupItem Class, Legend, Public Methods
CXTPPopupItem Constructors
Class

CXTPPopupItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupItem | Constructs a CXTPPopupItem object.


CXTPPopupItem::CXTPPopupItem Constructor

CXTPPopupItem Constructors, CXTPPopupItem Class
CXTPPopupItem::CXTPPopupItem Constructor

Constructs a CXTPPopupItem object.

CXTPPopupItem(
    LPRECT rcItem = NULL,
    LPCTSTR lpszCaption = NULL,
    COLORREF clrBackground = (COLORREF)-1,
    COLORREF clrBorder = (COLORREF)-1
);
Parameters

rcItem
Bounding rectangle of the item.
lpszCaption
NULL terminated string specifying the caption text.
clrBackground
Background color of the item.
clrBorder
Border color of the item

Group

CXTPPopupItem Constructors


CXTPPopupItem Destructors

CXTPPopupItem Class, Legend, Public Methods
CXTPPopupItem Destructors
Class

CXTPPopupItem Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPopupItem | Destroys a CXTPPopupItem object.


CXTPPopupItem::~CXTPPopupItem Destructor

CXTPPopupItem Destructors, CXTPPopupItem Class
CXTPPopupItem::~CXTPPopupItem Destructor

Destroys a CXTPPopupItem object.

~CXTPPopupItem();
Group

CXTPPopupItem Destructors


CXTPPopupPaintManager Class

XTPPopupPaintManager.h, Classes, Legend, Members, Topics, CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Methods, CXTPPopupPaintManager Constructors, CXTPPopupPaintManager Destructors, CXTPPopupPaintManager Constructors, CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Destructors, CXTPPopupPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager Class

CXTPPopupPaintManager is a class used to perform specialized drawing tasks.

Class Hierarchy

class CXTPPopupPaintManager;
File

XTPPopupPaintManager.h

Group

Classes

Legend
Data Member
Method
virtual
CXTPPopupPaintManager Constructors
CXTPPopupPaintManager Constructors | Description
CXTPPopupPaintManager | Constructs a CXTPPopupPaintManager object.
CXTPPopupPaintManager Data Members
CXTPPopupPaintManager Data Members | Description
m_clrBackground | gradient background color
m_clrButtonPressed | color of pressed button
m_clrButtonPressedBorder | 3d border color of pressed button
m_clrButtonSelected | color of selected button
m_clrButtonSelectedBorder | 3d border color of selected button
m_clrFrame | 3d frame color
m_clrText | default color of text
m_fntText | default font of text
CXTPPopupPaintManager Destructors
CXTPPopupPaintManager Destructors | Description
~CXTPPopupPaintManager | Destroys a CXTPPopupPaintManager object.
CXTPPopupPaintManager Methods
CXTPPopupPaintManager Methods | Description
DrawBackground | Call this member function will draw the background of popup window.
DrawButton | Call this method to draw the rectangle of a button.
DrawItem | Call this member function will draw the controlled item object of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.
SetFont | Sets font for text used in Popup control.


CXTPPopupPaintManager Data Members

CXTPPopupPaintManager Class, Legend, Public Data Members
CXTPPopupPaintManager Data Members
Class

CXTPPopupPaintManager Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrBackground | gradient background color
m_clrButtonPressed | color of pressed button
m_clrButtonPressedBorder | 3d border color of pressed button
m_clrButtonSelected | color of selected button
m_clrButtonSelectedBorder | 3d border color of selected button
m_clrFrame | 3d frame color
m_clrText | default color of text
m_fntText | default font of text


CXTPPopupPaintManager::m_clrBackground Data Member

CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::m_clrBackground Data Member

gradient background color

CXTPPaintManagerColorGradient m_clrBackground;
Group

CXTPPopupPaintManager Data Members


CXTPPopupPaintManager::m_clrButtonPressed Data Member

CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::m_clrButtonPressed Data Member

color of pressed button

COLORREF m_clrButtonPressed;
Group

CXTPPopupPaintManager Data Members


CXTPPopupPaintManager::m_clrButtonPressedBorder Data Member

CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::m_clrButtonPressedBorder Data Member

3d border color of pressed button

CXTPPaintManagerColorGradient m_clrButtonPressedBorder;
Group

CXTPPopupPaintManager Data Members


CXTPPopupPaintManager::m_clrButtonSelected Data Member

CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::m_clrButtonSelected Data Member

color of selected button

COLORREF m_clrButtonSelected;
Group

CXTPPopupPaintManager Data Members


CXTPPopupPaintManager::m_clrButtonSelectedBorder Data Member

CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::m_clrButtonSelectedBorder Data Member

3d border color of selected button

CXTPPaintManagerColorGradient m_clrButtonSelectedBorder;
Group

CXTPPopupPaintManager Data Members


CXTPPopupPaintManager::m_clrFrame Data Member

CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::m_clrFrame Data Member

3d frame color

CXTPPaintManagerColorGradient m_clrFrame;
Group

CXTPPopupPaintManager Data Members


CXTPPopupPaintManager::m_clrText Data Member

CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::m_clrText Data Member

default color of text

COLORREF m_clrText;
Group

CXTPPopupPaintManager Data Members


CXTPPopupPaintManager::m_fntText Data Member

CXTPPopupPaintManager Data Members, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::m_fntText Data Member

default font of text

CFont m_fntText;
Group

CXTPPopupPaintManager Data Members


CXTPPopupPaintManager Methods

CXTPPopupPaintManager Class, Legend, Public Methods
CXTPPopupPaintManager Methods
Class

CXTPPopupPaintManager Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBackground | Call this member function will draw the background of popup window.
DrawButton | Call this method to draw the rectangle of a button.
DrawItem | Call this member function will draw the controlled item object of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.
SetFont | Sets font for text used in Popup control.


CXTPPopupPaintManager::DrawBackground Method

CXTPPopupPaintManager Methods, CXTPPopupPaintManager Class
CXTPPopupPaintManager::DrawBackground Method

Call this member function will draw the background of popup window.

virtual void DrawBackground(
    CDC* pDC,
    CXTPPopupControl* pControl,
    CRect rcClient
);
Parameters

pDC
Points to the device context.
pControl
Popup control to draw
rcClient
Size of area to fill.

Group

CXTPPopupPaintManager Methods


CXTPPopupPaintManager::DrawButton Method

CXTPPopupPaintManager Methods, CXTPPopupPaintManager Class
CXTPPopupPaintManager::DrawButton Method

Call this method to draw the rectangle of a button.

void DrawButton(
    CDC* pDC,
    CXTPPopupItem* pItem
);
Parameters

pDC
Points to the device context.
pItem
Pointer to a CXTPPopupItem.

Group

CXTPPopupPaintManager Methods


CXTPPopupPaintManager::DrawItem Method

CXTPPopupPaintManager Methods, CXTPPopupPaintManager Class
CXTPPopupPaintManager::DrawItem Method

Call this member function will draw the controlled item object of popup window.

void DrawItem(
    CDC* pDC,
    CXTPPopupItem* pItem
);
Parameters

pDC
Points to the device context.
pItem
point to CXTPPopupItem object.

Group

CXTPPopupPaintManager Methods


CXTPPopupPaintManager::RefreshMetrics Method

CXTPPopupPaintManager Methods, CXTPPopupPaintManager Class
CXTPPopupPaintManager::RefreshMetrics Method

Call this member function to refresh draw metrics.

virtual void RefreshMetrics();
Group

CXTPPopupPaintManager Methods


CXTPPopupPaintManager::SetFont Method

CXTPPopupPaintManager Methods, CXTPPopupPaintManager Class
CXTPPopupPaintManager::SetFont Method

Sets font for text used in Popup control.

void SetFont(
    HFONT hFont
);
Parameters

hFont
Font handle to use.

Group

CXTPPopupPaintManager Methods


CXTPPopupPaintManager Constructors

CXTPPopupPaintManager Class, Legend, Public Methods
CXTPPopupPaintManager Constructors
Class

CXTPPopupPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupPaintManager | Constructs a CXTPPopupPaintManager object.


CXTPPopupPaintManager::CXTPPopupPaintManager Constructor

CXTPPopupPaintManager Constructors, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::CXTPPopupPaintManager Constructor

Constructs a CXTPPopupPaintManager object.

CXTPPopupPaintManager();
Group

CXTPPopupPaintManager Constructors


CXTPPopupPaintManager Destructors

CXTPPopupPaintManager Class, Legend, Public Methods
CXTPPopupPaintManager Destructors
Class

CXTPPopupPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPopupPaintManager | Destroys a CXTPPopupPaintManager object.


CXTPPopupPaintManager::~CXTPPopupPaintManager Destructor

CXTPPopupPaintManager Destructors, CXTPPopupPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupPaintManager::~CXTPPopupPaintManager Destructor

Destroys a CXTPPopupPaintManager object.

virtual ~CXTPPopupPaintManager();
Group

CXTPPopupPaintManager Destructors


CXTPPopupThemeMSN Class

XTPPopupPaintManager.h, Classes, Legend, Members, Topics, CXTPPopupThemeMSN Methods, CXTPPopupThemeMSN Constructors, CXTPPopupThemeMSN Destructors, CXTPPopupThemeMSN Constructors, CXTPPopupThemeMSN Destructors, CXTPPopupThemeMSN Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeMSN Class

CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks.

Class Hierarchy

class CXTPPopupThemeMSN : public CXTPPopupThemeOffice2000;
File

XTPPopupPaintManager.h

Group

Classes

Legend
Method
virtual
CXTPPopupThemeMSN Constructors
CXTPPopupThemeMSN Constructors | Description
CXTPPopupThemeMSN | Constructs a CXTPPopupThemeMSN object.
CXTPPopupThemeMSN Destructors
CXTPPopupThemeMSN Destructors | Description
~CXTPPopupThemeMSN | Destroys a CXTPPopupThemeMSN object.
CXTPPopupThemeMSN Methods
CXTPPopupThemeMSN Methods | Description
DrawBackground | Call this member function will draw the background of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeMSN Methods

CXTPPopupThemeMSN Class, Legend, Public Methods
CXTPPopupThemeMSN Methods
Class

CXTPPopupThemeMSN Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBackground | Call this member function will draw the background of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeMSN::DrawBackground Method

CXTPPopupThemeMSN Methods, CXTPPopupThemeMSN Class
CXTPPopupThemeMSN::DrawBackground Method

Call this member function will draw the background of popup window.

virtual void DrawBackground(
    CDC* pDC,
    CXTPPopupControl* pControl,
    CRect rcClient
);
Parameters

pDC
Points to the device context.
pControl
Popup control to draw
rcClient
Size of area to fill.

Group

CXTPPopupThemeMSN Methods


CXTPPopupThemeMSN::RefreshMetrics Method

CXTPPopupThemeMSN Methods, CXTPPopupThemeMSN Class
CXTPPopupThemeMSN::RefreshMetrics Method

Call this member function to refresh draw metrics.

void RefreshMetrics();
Group

CXTPPopupThemeMSN Methods


CXTPPopupThemeMSN Constructors

CXTPPopupThemeMSN Class, Legend, Public Methods
CXTPPopupThemeMSN Constructors
Class

CXTPPopupThemeMSN Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeMSN | Constructs a CXTPPopupThemeMSN object.


CXTPPopupThemeMSN::CXTPPopupThemeMSN Constructor

CXTPPopupThemeMSN Constructors, CXTPPopupThemeMSN Class
CXTPPopupThemeMSN::CXTPPopupThemeMSN Constructor

Constructs a CXTPPopupThemeMSN object.

CXTPPopupThemeMSN();
Group

CXTPPopupThemeMSN Constructors


CXTPPopupThemeMSN Destructors

CXTPPopupThemeMSN Class, Legend, Public Methods
CXTPPopupThemeMSN Destructors
Class

CXTPPopupThemeMSN Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPopupThemeMSN | Destroys a CXTPPopupThemeMSN object.


CXTPPopupThemeMSN::~CXTPPopupThemeMSN Destructor

CXTPPopupThemeMSN Destructors, CXTPPopupThemeMSN Class
CXTPPopupThemeMSN::~CXTPPopupThemeMSN Destructor

Destroys a CXTPPopupThemeMSN object.

virtual ~CXTPPopupThemeMSN();
Group

CXTPPopupThemeMSN Destructors


CXTPPopupThemeOffice2000 Class

XTPPopupPaintManager.h, Classes, Legend, Members, Topics, CXTPPopupThemeOffice2000 Methods, CXTPPopupThemeOffice2000 Constructors, CXTPPopupThemeOffice2000 Destructors, CXTPPopupThemeOffice2000 Constructors, CXTPPopupThemeOffice2000 Destructors, CXTPPopupThemeOffice2000 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2000 Class

CXTPPopupThemeOffice2000 is a class used to perform Office2000 drawing tasks.

Class Hierarchy

class CXTPPopupThemeOffice2000 : public CXTPPopupPaintManager;
File

XTPPopupPaintManager.h

Group

Classes

Legend
Method
virtual
CXTPPopupThemeOffice2000 Constructors
CXTPPopupThemeOffice2000 Constructors | Description
CXTPPopupThemeOffice2000 | Constructs a CXTPPopupThemeOffice2000 object.
CXTPPopupThemeOffice2000 Destructors
CXTPPopupThemeOffice2000 Destructors | Description
~CXTPPopupThemeOffice2000 | Destroys a CXTPPopupThemeOffice2000 object.
CXTPPopupThemeOffice2000 Methods
CXTPPopupThemeOffice2000 Methods | Description
DrawBackground | Call this member function will draw the background of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeOffice2000 Methods

CXTPPopupThemeOffice2000 Class, Legend, Public Methods
CXTPPopupThemeOffice2000 Methods
Class

CXTPPopupThemeOffice2000 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBackground | Call this member function will draw the background of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeOffice2000::DrawBackground Method

CXTPPopupThemeOffice2000 Methods, CXTPPopupThemeOffice2000 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2000::DrawBackground Method

Call this member function will draw the background of popup window.

virtual void DrawBackground(
    CDC* pDC,
    CXTPPopupControl* pControl,
    CRect rcClient
);
Parameters

pDC
Points to the device context.
pControl
Popup control to draw
rcClient
Size of area to fill.

Group

CXTPPopupThemeOffice2000 Methods


CXTPPopupThemeOffice2000::RefreshMetrics Method

CXTPPopupThemeOffice2000 Methods, CXTPPopupThemeOffice2000 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2000::RefreshMetrics Method

Call this member function to refresh draw metrics.

void RefreshMetrics();
Group

CXTPPopupThemeOffice2000 Methods


CXTPPopupThemeOffice2000 Constructors

CXTPPopupThemeOffice2000 Class, Legend, Public Methods
CXTPPopupThemeOffice2000 Constructors
Class

CXTPPopupThemeOffice2000 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeOffice2000 | Constructs a CXTPPopupThemeOffice2000 object.


CXTPPopupThemeOffice2000::CXTPPopupThemeOffice2000 Constructor

CXTPPopupThemeOffice2000 Constructors, CXTPPopupThemeOffice2000 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2000::CXTPPopupThemeOffice2000 Constructor

Constructs a CXTPPopupThemeOffice2000 object.

CXTPPopupThemeOffice2000();
Group

CXTPPopupThemeOffice2000 Constructors


CXTPPopupThemeOffice2000 Destructors

CXTPPopupThemeOffice2000 Class, Legend, Public Methods
CXTPPopupThemeOffice2000 Destructors
Class

CXTPPopupThemeOffice2000 Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPopupThemeOffice2000 | Destroys a CXTPPopupThemeOffice2000 object.


CXTPPopupThemeOffice2000::~CXTPPopupThemeOffice2000 Destructor

CXTPPopupThemeOffice2000 Destructors, CXTPPopupThemeOffice2000 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2000::~CXTPPopupThemeOffice2000 Destructor

Destroys a CXTPPopupThemeOffice2000 object.

virtual ~CXTPPopupThemeOffice2000();
Group

CXTPPopupThemeOffice2000 Destructors


CXTPPopupThemeOffice2003 Class

XTPPopupPaintManager.h, Classes, Legend, Members, Topics, CXTPPopupThemeOffice2003 Data Members, CXTPPopupThemeOffice2003 Methods, CXTPPopupThemeOffice2003 Constructors, CXTPPopupThemeOffice2003 Destructors, CXTPPopupThemeOffice2003 Constructors, CXTPPopupThemeOffice2003 Data Members, CXTPPopupThemeOffice2003 Destructors, CXTPPopupThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2003 Class

CXTPPopupThemeOffice2003 is a class used to perform Office2003 drawing tasks.

Class Hierarchy

class CXTPPopupThemeOffice2003 : public CXTPPopupThemeOfficeXP;
File

XTPPopupPaintManager.h

Group

Classes

Legend
Data Member
Method
virtual
CXTPPopupThemeOffice2003 Constructors
CXTPPopupThemeOffice2003 Constructors | Description
CXTPPopupThemeOffice2003 | Constructs a CXTPPopupThemeOffice2003 object.
CXTPPopupThemeOffice2003 Data Members
CXTPPopupThemeOffice2003 Data Members | Description
m_clrGripper | Color of the popup gripper for the xtpPopupThemeOffice2003 paint theme.
CXTPPopupThemeOffice2003 Destructors
CXTPPopupThemeOffice2003 Destructors | Description
~CXTPPopupThemeOffice2003 | Destroys a CXTPPopupThemeOffice2003 object.
CXTPPopupThemeOffice2003 Methods
CXTPPopupThemeOffice2003 Methods | Description
DrawBackground | Call this member function will draw the background of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeOffice2003 Data Members

CXTPPopupThemeOffice2003 Class, Legend, Public Data Members
CXTPPopupThemeOffice2003 Data Members
Class

CXTPPopupThemeOffice2003 Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrGripper | Color of the popup gripper for the xtpPopupThemeOffice2003 paint theme.


CXTPPopupThemeOffice2003::m_clrGripper Data Member

CXTPPopupThemeOffice2003 Data Members, CXTPPopupThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2003::m_clrGripper Data Member

Color of the popup gripper for the xtpPopupThemeOffice2003 paint theme.

CXTPPaintManagerColorGradient m_clrGripper;
Group

CXTPPopupThemeOffice2003 Data Members


CXTPPopupThemeOffice2003 Methods

CXTPPopupThemeOffice2003 Class, Legend, Public Methods
CXTPPopupThemeOffice2003 Methods
Class

CXTPPopupThemeOffice2003 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBackground | Call this member function will draw the background of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeOffice2003::DrawBackground Method

CXTPPopupThemeOffice2003 Methods, CXTPPopupThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2003::DrawBackground Method

Call this member function will draw the background of popup window.

virtual void DrawBackground(
    CDC* pDC,
    CXTPPopupControl* pControl,
    CRect rcClient
);
Parameters

pDC
Points to the device context.
pControl
Popup control to draw
rcClient
Size of area to fill.

Group

CXTPPopupThemeOffice2003 Methods


CXTPPopupThemeOffice2003::RefreshMetrics Method

CXTPPopupThemeOffice2003 Methods, CXTPPopupThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2003::RefreshMetrics Method

Call this member function to refresh draw metrics.

void RefreshMetrics();
Group

CXTPPopupThemeOffice2003 Methods


CXTPPopupThemeOffice2003 Constructors

CXTPPopupThemeOffice2003 Class, Legend, Public Methods
CXTPPopupThemeOffice2003 Constructors
Class

CXTPPopupThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeOffice2003 | Constructs a CXTPPopupThemeOffice2003 object.


CXTPPopupThemeOffice2003::CXTPPopupThemeOffice2003 Constructor

CXTPPopupThemeOffice2003 Constructors, CXTPPopupThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2003::CXTPPopupThemeOffice2003 Constructor

Constructs a CXTPPopupThemeOffice2003 object.

CXTPPopupThemeOffice2003();
Group

CXTPPopupThemeOffice2003 Constructors


CXTPPopupThemeOffice2003 Destructors

CXTPPopupThemeOffice2003 Class, Legend, Public Methods
CXTPPopupThemeOffice2003 Destructors
Class

CXTPPopupThemeOffice2003 Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPopupThemeOffice2003 | Destroys a CXTPPopupThemeOffice2003 object.


CXTPPopupThemeOffice2003::~CXTPPopupThemeOffice2003 Destructor

CXTPPopupThemeOffice2003 Destructors, CXTPPopupThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2003::~CXTPPopupThemeOffice2003 Destructor

Destroys a CXTPPopupThemeOffice2003 object.

virtual ~CXTPPopupThemeOffice2003();
Group

CXTPPopupThemeOffice2003 Destructors


CXTPPopupThemeOffice2007 Class

XTPPopupPaintManager.h, Classes, Legend, Members, Topics, CXTPPopupThemeOffice2007 Methods, CXTPPopupThemeOffice2007 Constructors, CXTPPopupThemeOffice2007 Constructors, CXTPPopupThemeOffice2007 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2007 Class

CXTPPopupThemeOffice2007 is a class used to perform Office2007 drawing tasks.

Class Hierarchy

class CXTPPopupThemeOffice2007 : public CXTPPopupThemeOffice2003;
File

XTPPopupPaintManager.h

Group

Classes

Legend
Method
CXTPPopupThemeOffice2007 Constructors
CXTPPopupThemeOffice2007 Constructors | Description
CXTPPopupThemeOffice2007 | Constructs a CXTPPopupThemeOffice2003 object.
CXTPPopupThemeOffice2007 Methods
CXTPPopupThemeOffice2007 Methods | Description
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeOffice2007 Methods

CXTPPopupThemeOffice2007 Class, Legend, Public Methods
CXTPPopupThemeOffice2007 Methods
Class

CXTPPopupThemeOffice2007 Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeOffice2007::RefreshMetrics Method

CXTPPopupThemeOffice2007 Methods, CXTPPopupThemeOffice2007 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2007::RefreshMetrics Method

Call this member function to refresh draw metrics.

void RefreshMetrics();
Group

CXTPPopupThemeOffice2007 Methods


CXTPPopupThemeOffice2007 Constructors

CXTPPopupThemeOffice2007 Class, Legend, Public Methods
CXTPPopupThemeOffice2007 Constructors
Class

CXTPPopupThemeOffice2007 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeOffice2007 | Constructs a CXTPPopupThemeOffice2003 object.


CXTPPopupThemeOffice2007::CXTPPopupThemeOffice2007 Constructor

CXTPPopupThemeOffice2007 Constructors, CXTPPopupThemeOffice2007 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOffice2007::CXTPPopupThemeOffice2007 Constructor

Constructs a CXTPPopupThemeOffice2003 object.

CXTPPopupThemeOffice2007();
Group

CXTPPopupThemeOffice2007 Constructors


CXTPPopupThemeOfficeXP Class

XTPPopupPaintManager.h, Classes, Legend, Members, Topics, CXTPPopupThemeOfficeXP Methods, CXTPPopupThemeOfficeXP Constructors, CXTPPopupThemeOfficeXP Destructors, CXTPPopupThemeOfficeXP Constructors, CXTPPopupThemeOfficeXP Destructors, CXTPPopupThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOfficeXP Class

CXTPPopupThemeOfficeXP is a class used to perform OfficeXP drawing tasks.

Class Hierarchy

class CXTPPopupThemeOfficeXP : public CXTPPopupThemeOffice2000;
File

XTPPopupPaintManager.h

Group

Classes

Legend
Method
virtual
CXTPPopupThemeOfficeXP Constructors
CXTPPopupThemeOfficeXP Constructors | Description
CXTPPopupThemeOfficeXP | Constructs a CXTPPopupThemeOfficeXP object.
CXTPPopupThemeOfficeXP Destructors
CXTPPopupThemeOfficeXP Destructors | Description
~CXTPPopupThemeOfficeXP | Destroys a CXTPPopupThemeOfficeXP object.
CXTPPopupThemeOfficeXP Methods
CXTPPopupThemeOfficeXP Methods | Description
DrawBackground | Call this member function will draw the background of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeOfficeXP Methods

CXTPPopupThemeOfficeXP Class, Legend, Public Methods
CXTPPopupThemeOfficeXP Methods
Class

CXTPPopupThemeOfficeXP Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBackground | Call this member function will draw the background of popup window.
RefreshMetrics | Call this member function to refresh draw metrics.


CXTPPopupThemeOfficeXP::DrawBackground Method

CXTPPopupThemeOfficeXP Methods, CXTPPopupThemeOfficeXP Class
CXTPPopupThemeOfficeXP::DrawBackground Method

Call this member function will draw the background of popup window.

virtual void DrawBackground(
    CDC* pDC,
    CXTPPopupControl* pControl,
    CRect rcClient
);
Parameters

pDC
Points to the device context.
pControl
Popup control to draw
rcClient
Size of area to fill.

Group

CXTPPopupThemeOfficeXP Methods


CXTPPopupThemeOfficeXP::RefreshMetrics Method

CXTPPopupThemeOfficeXP Methods, CXTPPopupThemeOfficeXP Class
CXTPPopupThemeOfficeXP::RefreshMetrics Method

Call this member function to refresh draw metrics.

void RefreshMetrics();
Group

CXTPPopupThemeOfficeXP Methods


CXTPPopupThemeOfficeXP Constructors

CXTPPopupThemeOfficeXP Class, Legend, Public Methods
CXTPPopupThemeOfficeXP Constructors
Class

CXTPPopupThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeOfficeXP | Constructs a CXTPPopupThemeOfficeXP object.


CXTPPopupThemeOfficeXP::CXTPPopupThemeOfficeXP Constructor

CXTPPopupThemeOfficeXP Constructors, CXTPPopupThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOfficeXP::CXTPPopupThemeOfficeXP Constructor

Constructs a CXTPPopupThemeOfficeXP object.

CXTPPopupThemeOfficeXP();
Group

CXTPPopupThemeOfficeXP Constructors


CXTPPopupThemeOfficeXP Destructors

CXTPPopupThemeOfficeXP Class, Legend, Public Methods
CXTPPopupThemeOfficeXP Destructors
Class

CXTPPopupThemeOfficeXP Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPopupThemeOfficeXP | Destroys a CXTPPopupThemeOfficeXP object.


CXTPPopupThemeOfficeXP::~CXTPPopupThemeOfficeXP Destructor

CXTPPopupThemeOfficeXP Destructors, CXTPPopupThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPopupThemeOfficeXP::~CXTPPopupThemeOfficeXP Destructor

Destroys a CXTPPopupThemeOfficeXP object.

virtual ~CXTPPopupThemeOfficeXP();
Group

CXTPPopupThemeOfficeXP Destructors


CXTPPropertyPage Class

XTPPropertyPage.h, Classes, Legend, Members, Topics, CXTPPropertyPage Data Members, CXTPPropertyPage Methods, CXTPPropertyPage Constructors, CXTPPropertyPage Destructors, CXTPPropertyPage Constructors, CXTPPropertyPage Data Members, CXTPPropertyPage Destructors, CXTPPropertyPage Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPage Class

CXTPPropertyPage is a CPropertyPage derived class Objects of class CPropertyPage represent individual pages of a property sheet

Class Hierarchy

class CXTPPropertyPage : public CPropertyPage, public CXTResize;
File

XTPPropertyPage.h

See Also

CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertyPageNavigator

Group

Classes

Legend
Data Member
protected
Method
CXTPPropertyPage Constructors
CXTPPropertyPage Constructors | Description
CXTPPropertyPage |
CXTPPropertyPage Data Members
CXTPPropertyPage Data Members | Description
m_bModified | TRUE to indicate that the property page settings have been modified
m_dwData | Page specific 32-bit value
m_pSheet | Parent CXTPPropertySheet object
CXTPPropertyPage Destructors
CXTPPropertyPage Destructors | Description
~CXTPPropertyPage | Destroys a CXTPPropertyPage object, handles cleanup and deallocation
CXTPPropertyPage Methods
CXTPPropertyPage Methods | Description
GetCaption | Returns caption text used for property sheet tabs
SetCaption | Sets caption text used to draw property sheet tabs


CXTPPropertyPage Data Members

CXTPPropertyPage Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPage Data Members
Class

CXTPPropertyPage Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bModified | TRUE to indicate that the property page settings have been modified
m_pSheet | Parent CXTPPropertySheet object
Public Data Members
Public Data Member | Description
m_dwData | Page specific 32-bit value


CXTPPropertyPage::m_bModified Data Member

CXTPPropertyPage Data Members, CXTPPropertyPage Class
CXTPPropertyPage::m_bModified Data Member

TRUE to indicate that the property page settings have been modified

BOOL m_bModified;
Group

CXTPPropertyPage Data Members


CXTPPropertyPage::m_dwData Data Member

CXTPPropertyPage Data Members, CXTPPropertyPage Class
CXTPPropertyPage::m_dwData Data Member

Page specific 32-bit value

DWORD_PTR m_dwData;
Group

CXTPPropertyPage Data Members


CXTPPropertyPage::m_pSheet Data Member

CXTPPropertyPage Data Members, CXTPPropertyPage Class
CXTPPropertyPage::m_pSheet Data Member

Parent CXTPPropertySheet object

CXTPPropertySheet* m_pSheet;
Group

CXTPPropertyPage Data Members


CXTPPropertyPage Methods

CXTPPropertyPage Class, Legend, Public Methods
CXTPPropertyPage Methods
Class

CXTPPropertyPage Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetCaption | Returns caption text used for property sheet tabs
SetCaption | Sets caption text used to draw property sheet tabs


CXTPPropertyPage::GetCaption Method

CXTPPropertyPage Methods, CXTPPropertyPage Class
CXTPPropertyPage::GetCaption Method

Returns caption text used for property sheet tabs

CString GetCaption() const;
Group

CXTPPropertyPage Methods


CXTPPropertyPage::SetCaption Method

CXTPPropertyPage Methods, CXTPPropertyPage Class
CXTPPropertyPage::SetCaption Method

Sets caption text used to draw property sheet tabs

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
New caption to be set

Group

CXTPPropertyPage Methods


CXTPPropertyPage Constructors

CXTPPropertyPage Class, Legend, Public Methods
CXTPPropertyPage Constructors
Class

CXTPPropertyPage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPage |


CXTPPropertyPage Constructor

CXTPPropertyPage Constructors
CXTPPropertyPage Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertyPage::CXTPPropertyPage () | Constructs a CXTPPropertyPage object.
CXTPPropertyPage::CXTPPropertyPage (LPCTSTR, UINT) | Constructs a CXTPPropertyPage object.
CXTPPropertyPage::CXTPPropertyPage (UINT, UINT) | Constructs a CXTPPropertyPage object.
Group

CXTPPropertyPage Constructors


CXTPPropertyPage::CXTPPropertyPage Constructor ()

CXTPPropertyPage Constructor, CXTPPropertyPage Class
CXTPPropertyPage::CXTPPropertyPage Constructor ()

Constructs a CXTPPropertyPage object.

CXTPPropertyPage();
CXTPPropertyPage(
    UINT nIDTemplate,
    UINT nIDCaption = 0
);
CXTPPropertyPage(
    LPCTSTR lpszTemplateName,
    UINT nIDCaption = 0
);
Parameters

nIDTemplate
ID of the template used for this page.
nIDCaption
ID of the name to be placed in the tab for this page. If 0, the name will be taken from the dialog template for this page
lpszTemplateName
Points to a string containing the name of the template for this page. Cannot be NULL

Remarks

Use this member function to construct a CXTPPropertyPage object. To display the property sheet, call DoModal or Create. The string contained in the first parameter will be placed in the caption bar for the property sheet.

Group

CXTPPropertyPage Constructor


CXTPPropertyPage Destructors

CXTPPropertyPage Class, Legend, Public Methods
CXTPPropertyPage Destructors
Class

CXTPPropertyPage Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyPage | Destroys a CXTPPropertyPage object, handles cleanup and deallocation


CXTPPropertyPage::~CXTPPropertyPage Destructor

CXTPPropertyPage Destructors, CXTPPropertyPage Class
CXTPPropertyPage::~CXTPPropertyPage Destructor

Destroys a CXTPPropertyPage object, handles cleanup and deallocation

~CXTPPropertyPage();
Group

CXTPPropertyPage Destructors


CXTPPropertyPageControlNavigator Class

XTPPropertyPageNavigator.h, Classes, Legend, Members, Topics, CXTPPropertyPageControlNavigator Constructors, CXTPPropertyPageControlNavigator Constructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageControlNavigator Class

CXTPPropertyPageControlNavigator is CXTPPropertyPageNavigator derived class It represents base control property page navigator

Class Hierarchy

class CXTPPropertyPageControlNavigator : public CXTPPropertyPageNavigator;
File

XTPPropertyPageNavigator.h

See Also

CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator

Group

Classes

Legend
Constructor
CXTPPropertyPageControlNavigator Constructors
CXTPPropertyPageControlNavigator Constructors | Description
CXTPPropertyPageControlNavigator | Constructs a CXTPPropertyPageControlNavigator object.


CXTPPropertyPageControlNavigator Constructors

CXTPPropertyPageControlNavigator Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageControlNavigator Constructors
Class

CXTPPropertyPageControlNavigator Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageControlNavigator | Constructs a CXTPPropertyPageControlNavigator object.


CXTPPropertyPageControlNavigator::CXTPPropertyPageControlNavigator Constructor

CXTPPropertyPageControlNavigator Constructors, CXTPPropertyPageControlNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageControlNavigator::CXTPPropertyPageControlNavigator Constructor

Constructs a CXTPPropertyPageControlNavigator object.

CXTPPropertyPageControlNavigator();
Group

CXTPPropertyPageControlNavigator Constructors


CXTPPropertyPageListNavigator Class

XTPPropertyPageNavigator.h, Classes, Legend, Members, Topics, CXTPPropertyPageListNavigator Constructors, CXTPPropertyPageListNavigator Constructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageListNavigator Class

CXTPPropertyPageListNavigator is CXTListBox and CXTPPropertyPageControlNavigator derived class It represents list property page navigator

Class Hierarchy

class CXTPPropertyPageListNavigator : public CXTListBox, public CXTPPropertyPageControlNavigator;
File

XTPPropertyPageNavigator.h

See Also

CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator

Group

Classes

Legend
Constructor
CXTPPropertyPageListNavigator Constructors
CXTPPropertyPageListNavigator Constructors | Description
CXTPPropertyPageListNavigator | Constructs a CXTPPropertyPageListNavigator object.


CXTPPropertyPageListNavigator Constructors

CXTPPropertyPageListNavigator Class, Legend, Public Methods
CXTPPropertyPageListNavigator Constructors
Class

CXTPPropertyPageListNavigator Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageListNavigator | Constructs a CXTPPropertyPageListNavigator object.


CXTPPropertyPageListNavigator::CXTPPropertyPageListNavigator Constructor

CXTPPropertyPageListNavigator Constructors, CXTPPropertyPageListNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageListNavigator::CXTPPropertyPageListNavigator Constructor

Constructs a CXTPPropertyPageListNavigator object.

CXTPPropertyPageListNavigator();
Group

CXTPPropertyPageListNavigator Constructors


CXTPPropertyPageNavigator Class

XTPPropertyPageNavigator.h, Classes, Legend, Members, Topics, CXTPPropertyPageNavigator Data Members, CXTPPropertyPageNavigator Methods, CXTPPropertyPageNavigator Constructors, CXTPPropertyPageNavigator Destructors, CXTPPropertyPageNavigator Constructors, CXTPPropertyPageNavigator Data Members, CXTPPropertyPageNavigator Destructors, CXTPPropertyPageNavigator Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator Class

CXTPPropertyPageNavigator is a standalone class CXTPPropertyPageNavigator represents base navigator object for CXTPPropertySheet

Class Hierarchy

class CXTPPropertyPageNavigator;
File

XTPPropertyPageNavigator.h

See Also

CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator

Group

Classes

Legend
Data Member
protected
Method
abstract
virtual
CXTPPropertyPageNavigator Constructors
CXTPPropertyPageNavigator Constructors | Description
CXTPPropertyPageNavigator | Constructs a CXTPPropertyPageNavigator object.
CXTPPropertyPageNavigator Data Members
CXTPPropertyPageNavigator Data Members | Description
m_pSheet | Parent property sheet object
m_rcButtonMargin | Total buttons margin
m_rcNavigatorMargin | Total navigator margin
m_rcPageMargin | Total page margin
CXTPPropertyPageNavigator Destructors
CXTPPropertyPageNavigator Destructors | Description
~CXTPPropertyPageNavigator | Destroys a CXTPPropertyPageNavigator object, handles cleanup and deallocation
CXTPPropertyPageNavigator Methods
CXTPPropertyPageNavigator Methods | Description
Create | This method is called to create page navigator
GetPageBrush | Retrieves page brush.
GetSafeHwnd | This method is called to get window handler of navigator window
OnPageSelected | This method is called when page become selected
PageToSize | This method is called to reposition property sheet using size of property page
SizeToPage | This method is called to reposition property page using property sheet size


CXTPPropertyPageNavigator Data Members

CXTPPropertyPageNavigator Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator Data Members
Class

CXTPPropertyPageNavigator Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pSheet | Parent property sheet object
Public Data Members
Public Data Member | Description
m_rcButtonMargin | Total buttons margin
m_rcNavigatorMargin | Total navigator margin
m_rcPageMargin | Total page margin


CXTPPropertyPageNavigator::m_pSheet Data Member

CXTPPropertyPageNavigator Data Members, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::m_pSheet Data Member

Parent property sheet object

CXTPPropertySheet* m_pSheet;
Group

CXTPPropertyPageNavigator Data Members


CXTPPropertyPageNavigator::m_rcButtonMargin Data Member

CXTPPropertyPageNavigator Data Members, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::m_rcButtonMargin Data Member

Total buttons margin

CRect m_rcButtonMargin;
Group

CXTPPropertyPageNavigator Data Members


CXTPPropertyPageNavigator::m_rcNavigatorMargin Data Member

CXTPPropertyPageNavigator Data Members, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::m_rcNavigatorMargin Data Member

Total navigator margin

CRect m_rcNavigatorMargin;
Group

CXTPPropertyPageNavigator Data Members


CXTPPropertyPageNavigator::m_rcPageMargin Data Member

CXTPPropertyPageNavigator Data Members, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::m_rcPageMargin Data Member

Total page margin

CRect m_rcPageMargin;
Group

CXTPPropertyPageNavigator Data Members


CXTPPropertyPageNavigator Methods

CXTPPropertyPageNavigator Class, Legend, Public Methods
CXTPPropertyPageNavigator Methods
Class

CXTPPropertyPageNavigator Class

Legend
Method
abstract
Public Methods
Public Methods
Public Method | Description
Create | This method is called to create page navigator
GetPageBrush | Retrieves page brush.
GetSafeHwnd | This method is called to get window handler of navigator window
OnPageSelected | This method is called when page become selected
PageToSize | This method is called to reposition property sheet using size of property page
SizeToPage | This method is called to reposition property page using property sheet size


CXTPPropertyPageNavigator::Create Method

CXTPPropertyPageNavigator Methods, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::Create Method

This method is called to create page navigator

virtual BOOL Create() = 0;
Group

CXTPPropertyPageNavigator Methods


CXTPPropertyPageNavigator::GetPageBrush Method

CXTPPropertyPageNavigator Methods, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::GetPageBrush Method

Retrieves page brush.

virtual HBRUSH GetPageBrush(
    CDC* pDC,
    CXTPPropertyPage* pPage
) = 0;
Parameters

pDC
Pointer to valid device context
pPage
Property page to draw

Group

CXTPPropertyPageNavigator Methods


CXTPPropertyPageNavigator::GetSafeHwnd Method

CXTPPropertyPageNavigator Methods, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::GetSafeHwnd Method

This method is called to get window handler of navigator window

virtual HWND GetSafeHwnd() const = 0;
Group

CXTPPropertyPageNavigator Methods


CXTPPropertyPageNavigator::OnPageSelected Method

CXTPPropertyPageNavigator Methods, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::OnPageSelected Method

This method is called when page become selected

virtual void OnPageSelected(
    CXTPPropertyPage* pPage
) = 0;
Parameters

pPage
Property page that become selected.

Group

CXTPPropertyPageNavigator Methods


CXTPPropertyPageNavigator::PageToSize Method

CXTPPropertyPageNavigator Methods, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::PageToSize Method

This method is called to reposition property sheet using size of property page

virtual void PageToSize(
    AFX_SIZEPARENTPARAMS* pLayout,
    CSize szPage,
    CRect& rcPage,
    CSize& szClient
) = 0;
Parameters

pLayout
Address of an AFX_SIZEPARENTPARAMS structure
szPage
Page size to calculate from
rcPage
Result bounding rectangle of property pages
szClient
Result size of property sheet

Group

CXTPPropertyPageNavigator Methods


CXTPPropertyPageNavigator::SizeToPage Method

CXTPPropertyPageNavigator Methods, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::SizeToPage Method

This method is called to reposition property page using property sheet size

virtual void SizeToPage(
    AFX_SIZEPARENTPARAMS* pLayout,
    CSize szClient,
    CRect& rcPage
) = 0;
Parameters

pLayout
Address of an AFX_SIZEPARENTPARAMS structure
szClient
Size of property sheet
rcPage
Result bounding rectangle of property pages

Group

CXTPPropertyPageNavigator Methods


CXTPPropertyPageNavigator Constructors

CXTPPropertyPageNavigator Class, Legend, Public Methods
CXTPPropertyPageNavigator Constructors
Class

CXTPPropertyPageNavigator Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageNavigator | Constructs a CXTPPropertyPageNavigator object.


CXTPPropertyPageNavigator::CXTPPropertyPageNavigator Constructor

CXTPPropertyPageNavigator Constructors, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::CXTPPropertyPageNavigator Constructor

Constructs a CXTPPropertyPageNavigator object.

CXTPPropertyPageNavigator();
Group

CXTPPropertyPageNavigator Constructors


CXTPPropertyPageNavigator Destructors

CXTPPropertyPageNavigator Class, Legend, Public Methods
CXTPPropertyPageNavigator Destructors
Class

CXTPPropertyPageNavigator Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertyPageNavigator | Destroys a CXTPPropertyPageNavigator object, handles cleanup and deallocation


CXTPPropertyPageNavigator::~CXTPPropertyPageNavigator Destructor

CXTPPropertyPageNavigator Destructors, CXTPPropertyPageNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageNavigator::~CXTPPropertyPageNavigator Destructor

Destroys a CXTPPropertyPageNavigator object, handles cleanup and deallocation

virtual ~CXTPPropertyPageNavigator();
Group

CXTPPropertyPageNavigator Destructors


CXTPPropertyPageTabNavigator Class

XTPPropertyPageNavigator.h, Classes, Legend, Members, Topics, CXTPPropertyPageTabNavigator Constructors, CXTPPropertyPageTabNavigator Constructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageTabNavigator Class

CXTPPropertyPageTabNavigator is CXTPTabControl and CXTPPropertyPageNavigator derived class It represents tabbed property page navigator

Class Hierarchy

class CXTPPropertyPageTabNavigator : public CXTPTabControl, public CXTPPropertyPageNavigator;
File

XTPPropertyPageNavigator.h

See Also

CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator

Group

Classes

Legend
Constructor
CXTPPropertyPageTabNavigator Constructors
CXTPPropertyPageTabNavigator Constructors | Description
CXTPPropertyPageTabNavigator | Constructs a CXTPPropertyPageTabNavigator object.


CXTPPropertyPageTabNavigator Constructors

CXTPPropertyPageTabNavigator Class, Legend, Public Methods
CXTPPropertyPageTabNavigator Constructors
Class

CXTPPropertyPageTabNavigator Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageTabNavigator | Constructs a CXTPPropertyPageTabNavigator object.


CXTPPropertyPageTabNavigator::CXTPPropertyPageTabNavigator Constructor

CXTPPropertyPageTabNavigator Constructors, CXTPPropertyPageTabNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageTabNavigator::CXTPPropertyPageTabNavigator Constructor

Constructs a CXTPPropertyPageTabNavigator object.

CXTPPropertyPageTabNavigator();
Group

CXTPPropertyPageTabNavigator Constructors


CXTPPropertyPageTreeNavigator Class

XTPPropertyPageNavigator.h, Classes, Legend, Members, Topics, CXTPPropertyPageTreeNavigator Constructors, CXTPPropertyPageTreeNavigator Constructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageTreeNavigator Class

CXTPPropertyPageTreeNavigator is CTreeCtrl and CXTPPropertyPageControlNavigator derived class It represents tree property page navigator

Class Hierarchy

class CXTPPropertyPageTreeNavigator : public CTreeCtrl, public CXTPPropertyPageControlNavigator;
File

XTPPropertyPageNavigator.h

See Also

CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator

Group

Classes

Legend
Constructor
CXTPPropertyPageTreeNavigator Constructors
CXTPPropertyPageTreeNavigator Constructors | Description
CXTPPropertyPageTreeNavigator | Constructs a CXTPPropertyPageTreeNavigator object.


CXTPPropertyPageTreeNavigator Constructors

CXTPPropertyPageTreeNavigator Class, Legend, Public Methods
CXTPPropertyPageTreeNavigator Constructors
Class

CXTPPropertyPageTreeNavigator Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageTreeNavigator | Constructs a CXTPPropertyPageTreeNavigator object.


CXTPPropertyPageTreeNavigator::CXTPPropertyPageTreeNavigator Constructor

CXTPPropertyPageTreeNavigator Constructors, CXTPPropertyPageTreeNavigator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertyPageTreeNavigator::CXTPPropertyPageTreeNavigator Constructor

Constructs a CXTPPropertyPageTreeNavigator object.

CXTPPropertyPageTreeNavigator(
    DWORD dwStyle = TVS_SHOWSELALWAYS
);
Parameters

dwStyle
style of tree control to be used

Group

CXTPPropertyPageTreeNavigator Constructors


CXTPPropertySheet Class

XTPPropertySheet.h, Classes, Legend, Members, Topics, CXTPPropertySheet Data Members, CXTPPropertySheet Methods, CXTPPropertySheet Constructors, CXTPPropertySheet Destructors, CXTPPropertySheet Constructors, CXTPPropertySheet Data Members, CXTPPropertySheet Destructors, CXTPPropertySheet Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet Class

CXTPPropertySheet is a CDialog derived class It represents property sheet, otherwise known as tab dialog box. A property sheet consists of a CXTPPropertySheet object and one or more CXTPPropertyPage objects.

Class Hierarchy

class CXTPPropertySheet : public CDialog;
File

XTPPropertySheet.h

See Also

CXTPPropertySheet::DoModal, CXTPPropertyPage, CXTPPropertyPageNavigator

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropertySheet Constructors
CXTPPropertySheet Constructors | Description
CXTPPropertySheet |
CXTPPropertySheet Data Members
CXTPPropertySheet Data Members | Description
m_arrButtons | Array of buttons of property sheet
m_arrPages | Array of propety pages
m_bAllowApply | TRUE to allow enable apply button
m_bModeless | TRUE if property sheet was created as modeless window
m_bResizable | TRUE if dialog can be resized
m_fntNormal | Font used to draw buttons and navigator
m_lpDlgTemplate | Dialog template
m_nPageBorderStyle | Client border style
m_pActivePage | Pointer to active property page
m_pNavigator | Currently used navigator
m_psh | The Windows PROPSHEETHEADER structure.
m_rcPage | Bounding rectangle of active page
m_scSizeIcon | Resize glyph
m_strCaption | Caption of the dialog
m_szButton | Button size
m_szWindow | Last window size of property sheet
CXTPPropertySheet Destructors
CXTPPropertySheet Destructors | Description
~CXTPPropertySheet | Destroys a CXTPPropertySheet object, handles cleanup and deallocation
CXTPPropertySheet Methods
CXTPPropertySheet Methods | Description
AddButton | Adds new button to property sheet window
AddPage | Adds a page to the property sheet.
Create | Displays a modeless property sheet.
CreateButtons | This method is called to create all property sheet buttons
CreatePage | This method is called to create property page window
DoModal | Displays a modal property sheet.
GetActiveIndex | Retrieves the index of the active page of the property sheet.
GetActivePage | Returns the active page object.
GetNavigator | Returns currently used navigator object
GetPage | Retrieves a pointer to the specified page.
GetPageBorderStyle | Retrieves border style around client page rectangle
GetPageCount | Retrieves the number of pages in the property sheet.
GetPageIndex | Retrieves the index of the specified page of the property sheet.
GetPageRect | Returns bounding rectangle for all property pages.
RemoveButtons | Deletes all buttons from property sheet
SetActivePage |
SetNavigator | Sets navigator object that will be used to switch property pages
SetPageBorderStyle | Sets border around client page rectangle
SetPageSize | Call this member to set custom size for property pages
SetResizable | Call this member to allow user resize property sheet
SetTitle | Sets the caption of the property sheet.


CXTPPropertySheet Data Members

CXTPPropertySheet Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet Data Members
Class

CXTPPropertySheet Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrButtons | Array of buttons of property sheet
m_arrPages | Array of propety pages
m_bAllowApply | TRUE to allow enable apply button
m_bModeless | TRUE if property sheet was created as modeless window
m_bResizable | TRUE if dialog can be resized
m_fntNormal | Font used to draw buttons and navigator
m_lpDlgTemplate | Dialog template
m_nPageBorderStyle | Client border style
m_pActivePage | Pointer to active property page
m_pNavigator | Currently used navigator
m_rcPage | Bounding rectangle of active page
m_scSizeIcon | Resize glyph
m_strCaption | Caption of the dialog
m_szButton | Button size
m_szWindow | Last window size of property sheet
Public Data Members
Public Data Member | Description
m_psh | The Windows PROPSHEETHEADER structure.


CXTPPropertySheet::m_arrButtons Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_arrButtons Data Member

Array of buttons of property sheet

CArray<CButton*, CButton*> m_arrButtons;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_arrPages Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_arrPages Data Member

Array of propety pages

CArray<CXTPPropertyPage*, CXTPPropertyPage*> m_arrPages;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_bAllowApply Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_bAllowApply Data Member

TRUE to allow enable apply button

BOOL m_bAllowApply;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_bModeless Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_bModeless Data Member

TRUE if property sheet was created as modeless window

BOOL m_bModeless;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_bResizable Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_bResizable Data Member

TRUE if dialog can be resized

BOOL m_bResizable;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_fntNormal Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_fntNormal Data Member

Font used to draw buttons and navigator

CFont m_fntNormal;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_lpDlgTemplate Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_lpDlgTemplate Data Member

Dialog template

LPDLGTEMPLATE m_lpDlgTemplate;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_nPageBorderStyle Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_nPageBorderStyle Data Member

Client border style

XTPPropertyPageBorder m_nPageBorderStyle;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_pActivePage Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_pActivePage Data Member

Pointer to active property page

CXTPPropertyPage* m_pActivePage;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_pNavigator Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_pNavigator Data Member

Currently used navigator

CXTPPropertyPageNavigator* m_pNavigator;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_psh Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_psh Data Member

The Windows PROPSHEETHEADER structure.

PROPSHEETHEADER m_psh;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_rcPage Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_rcPage Data Member

Bounding rectangle of active page

CRect m_rcPage;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_scSizeIcon Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_scSizeIcon Data Member

Resize glyph

CScrollBar m_scSizeIcon;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_strCaption Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_strCaption Data Member

Caption of the dialog

CString m_strCaption;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_szButton Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_szButton Data Member

Button size

CSize m_szButton;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet::m_szWindow Data Member

CXTPPropertySheet Data Members, CXTPPropertySheet Class
CXTPPropertySheet::m_szWindow Data Member

Last window size of property sheet

CSize m_szWindow;
Group

CXTPPropertySheet Data Members


CXTPPropertySheet Methods

CXTPPropertySheet Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet Methods
Class

CXTPPropertySheet Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CreateButtons | This method is called to create all property sheet buttons
CreatePage | This method is called to create property page window
Public Methods
Public Methods
Public Method | Description
AddButton | Adds new button to property sheet window
AddPage | Adds a page to the property sheet.
Create | Displays a modeless property sheet.
DoModal | Displays a modal property sheet.
GetActiveIndex | Retrieves the index of the active page of the property sheet.
GetActivePage | Returns the active page object.
GetNavigator | Returns currently used navigator object
GetPage | Retrieves a pointer to the specified page.
GetPageBorderStyle | Retrieves border style around client page rectangle
GetPageCount | Retrieves the number of pages in the property sheet.
GetPageIndex | Retrieves the index of the specified page of the property sheet.
GetPageRect | Returns bounding rectangle for all property pages.
RemoveButtons | Deletes all buttons from property sheet
SetActivePage |
SetNavigator | Sets navigator object that will be used to switch property pages
SetPageBorderStyle | Sets border around client page rectangle
SetPageSize | Call this member to set custom size for property pages
SetResizable | Call this member to allow user resize property sheet
SetTitle | Sets the caption of the property sheet.


CXTPPropertySheet::AddButton Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, See Also
CXTPPropertySheet::AddButton Method

Adds new button to property sheet window

BOOL AddButton(
    UINT nIDCaption,
    UINT nID
);
Parameters

nIDCaption
ID of the caption to be used for the property sheet button.
nID
identifier to be used for the property sheet button.

Returns

Nonzero if the property sheet is activated successfully; otherwise 0.

See Also

CXTPPropertySheet::RemoveButtons

Group

CXTPPropertySheet Methods


CXTPPropertySheet::AddPage Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, See Also
CXTPPropertySheet::AddPage Method

Adds a page to the property sheet.

void AddPage(
    CXTPPropertyPage* pPage
);
Parameters

pPage
Points to the page to be added to the property sheet. Cannot be NULL.

Remarks

This member function adds the supplied page with the rightmost tab in the property sheet. Add pages to the property sheet in the left-to-right order you want them to appear.

AddPage adds the CPropertyPage object to the CPropertySheet object's list of pages but does not actually create the window for the page. The framework postpones creation of the window for the page until the user selects that page.

See Also

CXTPPropertySheet::GetPageCount

Group

CXTPPropertySheet Methods


CXTPPropertySheet::Create Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, See Also
CXTPPropertySheet::Create Method

Displays a modeless property sheet.

BOOL Create(
    CWnd* pParentWnd = NULL,
    DWORD dwStyle = (DWORD)-1,
    DWORD dwExStyle = 0
);
Parameters

pParentWnd
Points to parent window. If NULL, parent is the desktop.
dwStyle
Window styles for property sheet
dwExStyle
Extended window styles for property sheet

Remarks

The default style, expressed by passing -1 as dwStyle, is actually WS_SYSMENU | WS_POPUP | WS_CAPTION | DS_MODALFRAME | DS_CONTEXT_HELP | WS_VISIBLE.

To display a modal property sheet, call DoModal instead.

See Also

CXTPPropertySheet::DoModal

Group

CXTPPropertySheet Methods


CXTPPropertySheet::CreateButtons Method

CXTPPropertySheet Methods, CXTPPropertySheet Class
CXTPPropertySheet::CreateButtons Method

This method is called to create all property sheet buttons

virtual BOOL CreateButtons();
Group

CXTPPropertySheet Methods


CXTPPropertySheet::CreatePage Method

CXTPPropertySheet Methods, CXTPPropertySheet Class
CXTPPropertySheet::CreatePage Method

This method is called to create property page window

virtual BOOL CreatePage(
    CXTPPropertyPage* pPage
);
Parameters

pPage
Page to be created

Group

CXTPPropertySheet Methods


CXTPPropertySheet::DoModal Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::DoModal Method

Displays a modal property sheet.

INT_PTR DoModal();
Returns

IDOK or IDCANCEL if the function was successful; otherwise 0 or -1.

Remarks

Call this member function to display a modal property sheet. The return value corresponds to the ID of the control that closed the property sheet. After this function returns, the windows corresponding to the property sheet and all the pages will have been destroyed.

To display a modeless property sheet, call Create instead.

See Also

CXTPPropertySheet::Create

Body Source
INT_PTR CXTPPropertySheet::DoModal() {
    return CDialog::DoModal();
}
Group

CXTPPropertySheet Methods


CXTPPropertySheet::GetActiveIndex Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::GetActiveIndex Method

Retrieves the index of the active page of the property sheet.

int GetActiveIndex() const;
Returns

The index number of the active page.

Remarks

Call this member function to get the index number of the property sheet window's active page, then use the returned index number as the parameter for GetPage.

See Also

CXTPPropertySheet::GetActivePage

Body Source
int CXTPPropertySheet::GetActiveIndex() const {
    return m_hWnd ? GetPageIndex(m_pActivePage) : m_psh.nStartPage;
}
Group

CXTPPropertySheet Methods


CXTPPropertySheet::GetActivePage Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::GetActivePage Method

Returns the active page object.

CXTPPropertyPage* GetActivePage() const;
Returns

The pointer to the active page.

Remarks

Call this member function to retrieve the property sheet window's active page. Use this member function to perform some action on the active page

See Also

CXTPPropertySheet::GetPage

Body Source
CXTPPropertyPage* CXTPPropertySheet::GetActivePage() const {
    return m_hWnd ? m_pActivePage : GetPage(m_psh.nStartPage);
}
Group

CXTPPropertySheet Methods


CXTPPropertySheet::GetNavigator Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::GetNavigator Method

Returns currently used navigator object

CXTPPropertyPageNavigator* GetNavigator() const;
Returns

CXTPPropertyPageNavigator class pointer presented navigator object

See Also

CXTPPropertySheet::SetNavigator

Body Source
CXTPPropertyPageNavigator* CXTPPropertySheet::GetNavigator() const {
    return m_pNavigator;
}
Group

CXTPPropertySheet Methods


CXTPPropertySheet::GetPage Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::GetPage Method

Retrieves a pointer to the specified page.

CXTPPropertyPage* GetPage(
    int nPage
) const;
Parameters

nPage
Index of the desired page, starting at 0. Must be between 0 and one less than the number of pages in the property sheet, inclusive.

Returns

The pointer to the page corresponding to the nPage parameter.

Remarks

Call this member function to determine the number of pages currently in the property sheet.

See Also

CXTPPropertySheet::AddPage, CXTPPropertySheet::GetPageCount

Body Source
CXTPPropertyPage* CXTPPropertySheet::GetPage(int nPage) const {
    return nPage >= 0 && nPage < m_arrPages.GetSize() ? m_arrPages.GetAt(nPage) : NULL;
}
Group

CXTPPropertySheet Methods


CXTPPropertySheet::GetPageBorderStyle Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::GetPageBorderStyle Method

Retrieves border style around client page rectangle

XTPPropertyPageBorder GetPageBorderStyle() const;
Returns

XTPPropertyPageBorder Border style.

See Also

XTPPropertyPageBorder, CXTPPropertySheet::SetPageBorderStyle

Body Source
XTPPropertyPageBorder CXTPPropertySheet::GetPageBorderStyle() const {
    return m_nPageBorderStyle;
}
Group

CXTPPropertySheet Methods


CXTPPropertySheet::GetPageCount Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::GetPageCount Method

Retrieves the number of pages in the property sheet.

int GetPageCount() const;
Returns

The number of pages in the property sheet.

Remarks

Call this member function to determine the number of pages currently in the property sheet.

See Also

CXTPPropertySheet::AddPage, CXTPPropertySheet::GetPage

Body Source
int CXTPPropertySheet::GetPageCount() const {
    return (int)m_arrPages.GetSize();
}
Group

CXTPPropertySheet Methods


CXTPPropertySheet::GetPageIndex Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, See Also
CXTPPropertySheet::GetPageIndex Method

Retrieves the index of the specified page of the property sheet.

int GetPageIndex(
    CXTPPropertyPage* pPage
) const;
Parameters

pPage
Points to the page with the index to be found. Cannot be NULL

Returns

The index number of a page.

Remarks

Use this member function to retrieve the index number of the specified page in the property sheet. For example, you would use GetPageIndex to get the page index in order to use SetActivePage or GetPage..

See Also

CXTPPropertySheet::GetActivePage

Group

CXTPPropertySheet Methods


CXTPPropertySheet::GetPageRect Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::GetPageRect Method

Returns bounding rectangle for all property pages.

CRect GetPageRect() const;
Returns

CRect bounding rectangle for all property pages.

Body Source
CRect CXTPPropertySheet::GetPageRect() const {
    return m_rcPage;
}
Group

CXTPPropertySheet Methods


CXTPPropertySheet::RemoveButtons Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, See Also
CXTPPropertySheet::RemoveButtons Method

Deletes all buttons from property sheet

void RemoveButtons();
See Also

CXTPPropertySheet::AddButton

Group

CXTPPropertySheet Methods


SetActivePage Method

CXTPPropertySheet Methods
SetActivePage Method
Overload List
Methods
Method | Description
CXTPPropertySheet::SetActivePage (CXTPPropertyPage*) | Programmatically sets the active page object.
CXTPPropertySheet::SetActivePage (int) | Programmatically sets the active page object.
Group

CXTPPropertySheet Methods


CXTPPropertySheet::SetActivePage Method (int)

SetActivePage Method, CXTPPropertySheet Class, See Also
CXTPPropertySheet::SetActivePage Method (int)

Programmatically sets the active page object.

BOOL SetActivePage(
    int nPage
);
BOOL SetActivePage(
    CXTPPropertyPage* pPage
);
Parameters

nPage
Index of the page to set. It must be between 0 and one less than the number of pages in the property sheet, inclusive.
pPage
Points to the page to set in the property sheet. It cannot be NULL.

Returns

Nonzero if the property sheet is activated successfully; otherwise 0.

Remarks

Use this member function to change the active page. For example, use SetActivePage if a user's action on one page should cause another page to become the active page.

See Also

CXTPPropertySheet::GetActivePage

Group

SetActivePage Method


CXTPPropertySheet::SetNavigator Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropertySheet::SetNavigator Method

Sets navigator object that will be used to switch property pages

void SetNavigator(
    CXTPPropertyPageNavigator* pNavigator
);
Parameters

pNavigator
CXTPPropertyPageNavigator class pointer that will be set as new navigator

Remarks

CXTPPropertyPageNavigator class used to specify how user will navigate and switch pages. Default navigator classes are:

  • CXTPPropertyPageTabNavigator - represents TabControl navigator
  • CXTPPropertyPageListNavigator - represents List navigator
  • CXTPPropertyPageTreeNavigator - represents Tree navigator
See Also

CXTPPropertySheet::GetNavigator

Example
    CXTPPropertyPageListNavigator* pList = new CXTPPropertyPageListNavigator();
    pList->SetListStyle(xtListBoxOffice2007);
    ps.SetNavigator(pList);
Group

CXTPPropertySheet Methods


CXTPPropertySheet::SetPageBorderStyle Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, See Also
CXTPPropertySheet::SetPageBorderStyle Method

Sets border around client page rectangle

void SetPageBorderStyle(
    XTPPropertyPageBorder nBorder
);
Parameters

nBorder
Border style to be set

See Also

XTPPropertyPageBorder, CXTPPropertySheet::GetPageBorderStyle

Group

CXTPPropertySheet Methods


CXTPPropertySheet::SetPageSize Method

CXTPPropertySheet Methods, CXTPPropertySheet Class
CXTPPropertySheet::SetPageSize Method

Call this member to set custom size for property pages

void SetPageSize(
    CSize szPage
);
Parameters

szPage
New page size to be set

Group

CXTPPropertySheet Methods


CXTPPropertySheet::SetResizable Method

CXTPPropertySheet Methods, CXTPPropertySheet Class
CXTPPropertySheet::SetResizable Method

Call this member to allow user resize property sheet

void SetResizable(
    BOOL bResizable = TRUE
);
Parameters

bResizable
TRUE to allow user resize property sheet

Group

CXTPPropertySheet Methods


CXTPPropertySheet::SetTitle Method

CXTPPropertySheet Methods, CXTPPropertySheet Class, See Also
CXTPPropertySheet::SetTitle Method

Sets the caption of the property sheet.

void SetTitle(
    LPCTSTR lpszText
);
Parameters

lpszText
Points to the text to be used as the caption in the title bar of the property sheet.

Remarks

Call this member function to specify the property sheet's caption (the text displayed in the title bar of a frame window).

See Also

CXTPPropertySheet::GetPage

Group

CXTPPropertySheet Methods


CXTPPropertySheet Constructors

CXTPPropertySheet Class, Legend, Public Methods
CXTPPropertySheet Constructors
Class

CXTPPropertySheet Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertySheet |


CXTPPropertySheet Constructor

CXTPPropertySheet Constructors
CXTPPropertySheet Constructor
Overload List
Constructors
Constructor | Description
CXTPPropertySheet::CXTPPropertySheet () | Constructs a CXTPPropertySheet object.
CXTPPropertySheet::CXTPPropertySheet (LPCTSTR, CWnd*, UINT) | Constructs a CXTPPropertySheet object.
CXTPPropertySheet::CXTPPropertySheet (UINT, CWnd*, UINT) | Constructs a CXTPPropertySheet object.
Group

CXTPPropertySheet Constructors


CXTPPropertySheet::CXTPPropertySheet Constructor ()

CXTPPropertySheet Constructor, CXTPPropertySheet Class
CXTPPropertySheet::CXTPPropertySheet Constructor ()

Constructs a CXTPPropertySheet object.

CXTPPropertySheet();
CXTPPropertySheet(
    UINT nIDCaption,
    CWnd* pParentWnd = NULL,
    UINT iSelectPage = 0
);
CXTPPropertySheet(
    LPCTSTR pszCaption,
    CWnd* pParentWnd = NULL,
    UINT iSelectPage = 0
);
Parameters

nIDCaption
ID of the caption to be used for the property sheet.
pParentWnd
Points to the parent window of the property sheet. If NULL, the parent window will be the main window of the application.
iSelectPage
The index of the page that will initially be on top. Default is the first page added to the sheet
pszCaption
Points to a string containing the caption to be used for the property sheet. Cannot be NULL

Remarks

Use this member function to construct a CPropertySheet object. To display the property sheet, call DoModal or Create. The string contained in the first parameter will be placed in the caption bar for the property sheet.

Group

CXTPPropertySheet Constructor


CXTPPropertySheet Destructors

CXTPPropertySheet Class, Legend, Public Methods
CXTPPropertySheet Destructors
Class

CXTPPropertySheet Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropertySheet | Destroys a CXTPPropertySheet object, handles cleanup and deallocation


CXTPPropertySheet::~CXTPPropertySheet Destructor

CXTPPropertySheet Destructors, CXTPPropertySheet Class
CXTPPropertySheet::~CXTPPropertySheet Destructor

Destroys a CXTPPropertySheet object, handles cleanup and deallocation

~CXTPPropertySheet();
Group

CXTPPropertySheet Destructors


CXTPTaskDialog Class

XTPTaskDialog.h, Classes, Legend, Members, Topics, CXTPTaskDialog Data Members, CXTPTaskDialog Methods, CXTPTaskDialog Constructors, CXTPTaskDialog Destructors, CXTPTaskDialog Constructors, CXTPTaskDialog Data Members, CXTPTaskDialog Destructors, CXTPTaskDialog Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog Class

The CXTPTaskDialog class creates, displays, and operates a task dialog. A task dialog is similar to, while much more flexible than, a basic message box. The task dialog contains application-defined messages, title, verification check box, command links and push buttons, plus any combination of predefined icons and push buttons.

Class Hierarchy

class CXTPTaskDialog : public CXTPTaskDialogFrame;
File

XTPTaskDialog.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTaskDialog Constructors
CXTPTaskDialog Constructors | Description
CXTPTaskDialog | Constructs a CXTPTaskDialog object.
CXTPTaskDialog Data Members
CXTPTaskDialog Data Members | Description
m_arrButtons | Array of TASKDIALOG_BUTTON structures containing the definition of the custom buttons that are to be displayed in the dialog.
m_arrRadioButtons | Array of TASKDIALOG_BUTTON structures containing the definition of the custom radio buttons that are to be displayed in the dialog.
m_config | Structure contains information used to display a task dialog
m_hwndTaskDialog |
m_nSelButtonID | ID of the button that was selected when the task dialog was closed.
CXTPTaskDialog Destructors
CXTPTaskDialog Destructors | Description
~CXTPTaskDialog | Destroys a CXTPTaskDialog object, handles cleanup and deallocation.
CXTPTaskDialog Methods
CXTPTaskDialog Methods | Description
AddButton | Call this member function to add a user defined button to the task dialog's command area.
AddInputBox | Call this member function to add a user input box to the task dialog's command area.
AddRadioButton | Call this member function to add a user defined radio button to the task dialog's command area.
ClickButton | Call this member function to simulate the action of a button click in the task dialog.
ClickRadioButton | Call this member function to simulate the action of a radio button click in the task dialog.
ClickVerification | Call this member function to simulate the action of clicking the verification checkbox in the task dialog.
Create | Call this member function to create modeless task dialog
CreateFromResource |
CreateFromResourceParam |
DoModal | Call this member function to display the task dialog and return the selected button when done.
EnableButton | Call this member function to enable/disable a push button in the task dialog.
EnableCallbackTimer | Call this member function to enable the callback timer.
EnableCancellation | Call this member function to allow dialog cancellation for the task dialog.
EnableCommandLinks | Call this member function to indicate the buttons specified with AddButton should be displayed as command links (using a standard task dialog glyph) instead of push buttons. This function is ignored if AddButton has not been called.
EnableHyperlinks | Enables hyperlink processing for the strings specified for the functions SetContent, SetExpandedInformation and SetFooter.
EnableMarkup | NEEDS COMMENT
EnableMessageBoxStyle | Call this method to show thed dialog even if standard window theme used
EnableMinimize | Call this member function to enable the the task dialog to be minimized.
EnableRadioButton | Call this member function to enable/disable a radio button in the task dialog.
EnableRelativePosition | Call this member function to position the task dialog relative to the parent window.
EnableRtlLayout | Call this member function to enable right to left text display for the task dialog.
ExpandedByDefault | Call this member function to display the text specified by the SetExpandedInformation member function when the dialog is initially displayed. This function is ignored if the SetExpandedInformation member function has not been called.
ExpandFooterArea | Call this member to display expanded information at the bottom of the task dialog's footer. This function is ignored if the SetExpandedInformation member function has not been called.
GetInputBoxText | Call this member function to get text entered by user in input box field.
GetSelectedButtonId | Call this member function to retrieve the ID of the button used to close the task dialog.
GetSelectedRadioButtonId | Call this member function to retrieve the ID of the radio button that was selected when the task dialog was closed.
IsVerificiationChecked | Call this member function to retrieve the checked state of the verification checkbox when the dialog was closed.
ModifyTaskStyle | Call this member function to modify the style for the task dialog.
NavigatePage | This member function is used to simulate a wizard style task dialog. By using multiple CXTPTaskDialog objects that define the aspects of each page, you can incorporate Back and Next buttons that can be used to update the appearance and behavior of the task dialog.
NoDefaultRadioButton | Call this member function to disable default radio button selection.
OnButtonClicked | This notification is sent by the Task Dialog when a user selects a button or command link in the task dialog.
OnDialogConstructed | This notification is sent by the Task Dialog once the task dialog has been created and before it is displayed.
OnDialogDestroyed | This notification is sent by the Task Dialog once the task dialog has been destroyed.
OnExpandoButtonClicked | This notification is sent by the Task Dialog when the user clicks on an expando in the Task Dialog.
OnHelp | This notification is sent by the Task Dialog when the user presses F1 on the keyboard while the dialog has focus.
OnHyperlinkClicked | This notification is sent by the Task Dialog when a user clicks on a hyperlink in the Task Dialog's content
OnNavigated | This notification is sent by the Task Dialog when a navigation has occurred.
OnRadioButtonClicked | This notification is sent by the Task Dialog when a user selects a radio button in the task dialog.
OnTimer | This notification is sent by the Task Dialog approximately every 200 milliseconds when the EnableCallbackTimer member function has been called.
OnVerificationClicked | This notification is sent by the Task Dialog when the user clicks on the task dialog's verification check box.
ResetContent | Call this member function to reset the configuration attributes for the task dialog to the default state.
SetButtonElevationRequired | Call this member function to designate whether a given Task Dialog button or command link should have a User Account Control (UAC) shield icon (whether the action invoked by the button requires elevation).
SetCollapsedControlText | Call this member function to set the collapsed control text for the task dialog. This function is ignored unless SetExpandedInformation has been called.
SetCommonButtons | Specifies the push buttons displayed in the task dialog. If no common buttons are specified and no custom buttons are specified using the AddButton member function, the task dialog will contain the OK button by default.
SetContent | Call this member function to set the content text for the task dialog.
SetDefaultButton | Call this member function to set the default button ID for the task dialog.
SetDefaultRadioButton | Call this member function to set the default radio button ID for the task dialog.
SetExpandedControlText | Call this member function to set the expanded control text for the task dialog. This function is ignored unless SetExpandedInformation has been called.
SetExpandedInformation | Call this member function to set the expanded information text for the task dialog.
SetFooter | Call this member function to set the footer text for the task dialog.
SetFooterIcon |
SetInputBoxText | Call this member function to set default value for input box field
SetMainIcon |
SetMainInstruction | Call this member function to set the main instruction text for the task dialog.
SetMarqueeProgressBar | Call this member function to indicate whether the progress bar should be displayed in marquee mode or not.
SetProgressBarPos | Call this member function to se the current position for the progress bar.
SetProgressBarRange | Call this member function to set the minimum and maximum values for the progress bar.
SetProgressBarState | Call this member function to set the current state of the progress bar.
SetUseSysIcons | Call this member function to use system icons
SetVerificationText | Call this member function to set the label for the verification checkbox to be displayed in the task dialog.
SetVerifyCheckState | Call this member function to set the checked state for the verification checkbox when the dialog is initially displayed. This function is ignored if the SetVerificationText member function has not been called.
SetWidth | Call this member function to set the width of the task dialog's client area.
SetWindowTitle | Call this member function to set the window title for the task dialog.
ShowProgressBar | Call this member function to display a Progress Bar for the task dialog.
StartProgressBarMarquee | Similar to SetMarqueeProgressBar, this member function is used to indicate whether the progress bar should be displayed in marquee mode or not with the ability to determine marquee speed as well.


CXTPTaskDialog Data Members

CXTPTaskDialog Class, Legend, Protected Data Members
CXTPTaskDialog Data Members
Class

CXTPTaskDialog Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrButtons | Array of TASKDIALOG_BUTTON structures containing the definition of the custom buttons that are to be displayed in the dialog.
m_arrRadioButtons | Array of TASKDIALOG_BUTTON structures containing the definition of the custom radio buttons that are to be displayed in the dialog.
m_config | Structure contains information used to display a task dialog
m_hwndTaskDialog |
m_nSelButtonID | ID of the button that was selected when the task dialog was closed.


CXTPTaskDialog::m_arrButtons Data Member

CXTPTaskDialog Data Members, CXTPTaskDialog Class
CXTPTaskDialog::m_arrButtons Data Member

Array of TASKDIALOG_BUTTON structures containing the definition of the custom buttons that are to be displayed in the dialog.

CArray<TASKDIALOG_BUTTON,TASKDIALOG_BUTTON&> m_arrButtons;
Group

CXTPTaskDialog Data Members


CXTPTaskDialog::m_arrRadioButtons Data Member

CXTPTaskDialog Data Members, CXTPTaskDialog Class
CXTPTaskDialog::m_arrRadioButtons Data Member

Array of TASKDIALOG_BUTTON structures containing the definition of the custom radio buttons that are to be displayed in the dialog.

CArray<TASKDIALOG_BUTTON,TASKDIALOG_BUTTON&> m_arrRadioButtons;
Group

CXTPTaskDialog Data Members


CXTPTaskDialog::m_config Data Member

CXTPTaskDialog Data Members, CXTPTaskDialog Class
CXTPTaskDialog::m_config Data Member

Structure contains information used to display a task dialog

TASKDIALOGCONFIG m_config;
Group

CXTPTaskDialog Data Members


CXTPTaskDialog::m_hwndTaskDialog Data Member

CXTPTaskDialog Data Members, CXTPTaskDialog Class
CXTPTaskDialog::m_hwndTaskDialog Data Member
HWND m_hwndTaskDialog;
Group

CXTPTaskDialog Data Members


CXTPTaskDialog::m_nSelButtonID Data Member

CXTPTaskDialog Data Members, CXTPTaskDialog Class
CXTPTaskDialog::m_nSelButtonID Data Member

ID of the button that was selected when the task dialog was closed.

int m_nSelButtonID;
Group

CXTPTaskDialog Data Members


CXTPTaskDialog Methods

CXTPTaskDialog Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog Methods
Class

CXTPTaskDialog Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnButtonClicked | This notification is sent by the Task Dialog when a user selects a button or command link in the task dialog.
OnDialogConstructed | This notification is sent by the Task Dialog once the task dialog has been created and before it is displayed.
OnDialogDestroyed | This notification is sent by the Task Dialog once the task dialog has been destroyed.
OnExpandoButtonClicked | This notification is sent by the Task Dialog when the user clicks on an expando in the Task Dialog.
OnHelp | This notification is sent by the Task Dialog when the user presses F1 on the keyboard while the dialog has focus.
OnHyperlinkClicked | This notification is sent by the Task Dialog when a user clicks on a hyperlink in the Task Dialog's content
OnNavigated | This notification is sent by the Task Dialog when a navigation has occurred.
OnRadioButtonClicked | This notification is sent by the Task Dialog when a user selects a radio button in the task dialog.
OnTimer | This notification is sent by the Task Dialog approximately every 200 milliseconds when the EnableCallbackTimer member function has been called.
OnVerificationClicked | This notification is sent by the Task Dialog when the user clicks on the task dialog's verification check box.
Public Methods
Public Methods
Public Method | Description
AddButton | Call this member function to add a user defined button to the task dialog's command area.
AddInputBox | Call this member function to add a user input box to the task dialog's command area.
AddRadioButton | Call this member function to add a user defined radio button to the task dialog's command area.
ClickButton | Call this member function to simulate the action of a button click in the task dialog.
ClickRadioButton | Call this member function to simulate the action of a radio button click in the task dialog.
ClickVerification | Call this member function to simulate the action of clicking the verification checkbox in the task dialog.
Create | Call this member function to create modeless task dialog
CreateFromResource |
CreateFromResourceParam |
DoModal | Call this member function to display the task dialog and return the selected button when done.
EnableButton | Call this member function to enable/disable a push button in the task dialog.
EnableCallbackTimer | Call this member function to enable the callback timer.
EnableCancellation | Call this member function to allow dialog cancellation for the task dialog.
EnableCommandLinks | Call this member function to indicate the buttons specified with AddButton should be displayed as command links (using a standard task dialog glyph) instead of push buttons. This function is ignored if AddButton has not been called.
EnableHyperlinks | Enables hyperlink processing for the strings specified for the functions SetContent, SetExpandedInformation and SetFooter.
EnableMarkup | NEEDS COMMENT
EnableMessageBoxStyle | Call this method to show thed dialog even if standard window theme used
EnableMinimize | Call this member function to enable the the task dialog to be minimized.
EnableRadioButton | Call this member function to enable/disable a radio button in the task dialog.
EnableRelativePosition | Call this member function to position the task dialog relative to the parent window.
EnableRtlLayout | Call this member function to enable right to left text display for the task dialog.
ExpandedByDefault | Call this member function to display the text specified by the SetExpandedInformation member function when the dialog is initially displayed. This function is ignored if the SetExpandedInformation member function has not been called.
ExpandFooterArea | Call this member to display expanded information at the bottom of the task dialog's footer. This function is ignored if the SetExpandedInformation member function has not been called.
GetInputBoxText | Call this member function to get text entered by user in input box field.
GetSelectedButtonId | Call this member function to retrieve the ID of the button used to close the task dialog.
GetSelectedRadioButtonId | Call this member function to retrieve the ID of the radio button that was selected when the task dialog was closed.
IsVerificiationChecked | Call this member function to retrieve the checked state of the verification checkbox when the dialog was closed.
ModifyTaskStyle | Call this member function to modify the style for the task dialog.
NavigatePage | This member function is used to simulate a wizard style task dialog. By using multiple CXTPTaskDialog objects that define the aspects of each page, you can incorporate Back and Next buttons that can be used to update the appearance and behavior of the task dialog.
NoDefaultRadioButton | Call this member function to disable default radio button selection.
ResetContent | Call this member function to reset the configuration attributes for the task dialog to the default state.
SetButtonElevationRequired | Call this member function to designate whether a given Task Dialog button or command link should have a User Account Control (UAC) shield icon (whether the action invoked by the button requires elevation).
SetCollapsedControlText | Call this member function to set the collapsed control text for the task dialog. This function is ignored unless SetExpandedInformation has been called.
SetCommonButtons | Specifies the push buttons displayed in the task dialog. If no common buttons are specified and no custom buttons are specified using the AddButton member function, the task dialog will contain the OK button by default.
SetContent | Call this member function to set the content text for the task dialog.
SetDefaultButton | Call this member function to set the default button ID for the task dialog.
SetDefaultRadioButton | Call this member function to set the default radio button ID for the task dialog.
SetExpandedControlText | Call this member function to set the expanded control text for the task dialog. This function is ignored unless SetExpandedInformation has been called.
SetExpandedInformation | Call this member function to set the expanded information text for the task dialog.
SetFooter | Call this member function to set the footer text for the task dialog.
SetFooterIcon |
SetInputBoxText | Call this member function to set default value for input box field
SetMainIcon |
SetMainInstruction | Call this member function to set the main instruction text for the task dialog.
SetMarqueeProgressBar | Call this member function to indicate whether the progress bar should be displayed in marquee mode or not.
SetProgressBarPos | Call this member function to se the current position for the progress bar.
SetProgressBarRange | Call this member function to set the minimum and maximum values for the progress bar.
SetProgressBarState | Call this member function to set the current state of the progress bar.
SetUseSysIcons | Call this member function to use system icons
SetVerificationText | Call this member function to set the label for the verification checkbox to be displayed in the task dialog.
SetVerifyCheckState | Call this member function to set the checked state for the verification checkbox when the dialog is initially displayed. This function is ignored if the SetVerificationText member function has not been called.
SetWidth | Call this member function to set the width of the task dialog's client area.
SetWindowTitle | Call this member function to set the window title for the task dialog.
ShowProgressBar | Call this member function to display a Progress Bar for the task dialog.
StartProgressBarMarquee | Similar to SetMarqueeProgressBar, this member function is used to indicate whether the progress bar should be displayed in marquee mode or not with the ability to determine marquee speed as well.


CXTPTaskDialog::AddButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::AddButton Method

Call this member function to add a user defined button to the task dialog's command area.

void AddButton(
    LPCTSTR pszText,
    int nButtonID
);
Parameters

pszText
Pointer that references the string to be used to label the button.
nButtonID
Indicates the value to be returned when this button is selected.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. When using Command Links, you delineate the command from the note by placing a new line character in the string.

See Also

OnButtonClicked, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

Group

CXTPTaskDialog Methods


CXTPTaskDialog::AddInputBox Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::AddInputBox Method

Call this member function to add a user input box to the task dialog's command area.

void AddInputBox();
Remarks

Call SetInputBoxText to set default value for input box

See Also

SetInputBoxText, GetInputBoxText

Group

CXTPTaskDialog Methods


CXTPTaskDialog::AddRadioButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::AddRadioButton Method

Call this member function to add a user defined radio button to the task dialog's command area.

void AddRadioButton(
    LPCTSTR pszText,
    int nButtonID
);
Parameters

pszText
Pointer that references the string to be used to label the radio button.
nButtonID
Indicates the value to be returned when this button is selected.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro.

See Also

OnRadioButtonClicked, SetDefaultRadioButton, NoDefaultRadioButton, GetSelectedRadioButtonId, ClickRadioButton, EnableRadioButton

Group

CXTPTaskDialog Methods


CXTPTaskDialog::ClickButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::ClickButton Method

Call this member function to simulate the action of a button click in the task dialog.

void ClickButton(
    int nButtonID
);
Parameters

nButtonID
Indicates the button ID to be selected.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, OnButtonClicked, EnableButton, SetButtonElevationRequired

Example
class CSimulateClickDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         BOOL bClick = TRUE;
         if (bClick)
         {
             ClickButton(IDCANCEL);
         }
    }
};
Body Source
void CXTPTaskDialog::ClickButton(int nButtonID) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_CLICK_BUTTON, nButtonID, 0);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::ClickRadioButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::ClickRadioButton Method

Call this member function to simulate the action of a radio button click in the task dialog.

void ClickRadioButton(
    int nButtonID
);
Parameters

nButtonID
Indicates the radio button ID to be selected.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

AddRadioButton, SetDefaultRadioButton, NoDefaultRadioButton, GetSelectedRadioButtonId, OnRadioButtonClicked, EnableRadioButton

Example
class CSimulateClickDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         BOOL bClick = TRUE;
         if (bClick)
         {
             ClickRadioButton(100);
         }
    }
};
Body Source
void CXTPTaskDialog::ClickRadioButton(int nButtonID) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_CLICK_RADIO_BUTTON, nButtonID, 0);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::ClickVerification Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::ClickVerification Method

Call this member function to simulate the action of clicking the verification checkbox in the task dialog.

void ClickVerification(
    BOOL bChecked,
    BOOL bSetKeyFocus
);
Parameters

bChecked
TRUE to set the state of the checkbox to be checked, and FALSE to set it to be unchecked.
bSetKeyFocus
TRUE to set the keyboard focus to the checkbox, and FALSE otherwise.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

SetVerificationText, SetVerifyCheckState, IsVerificiationChecked, OnVerificationClicked

Example
class CSimulateClickDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         BOOL bClick = TRUE;
         if (bClick)
         {
             ClickVerification(TRUE, FALSE);
         }
    }
};
Body Source
void CXTPTaskDialog::ClickVerification(BOOL bChecked, BOOL bSetKeyFocus) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_CLICK_VERIFICATION, bChecked, bSetKeyFocus);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::Create Method

CXTPTaskDialog Methods, CXTPTaskDialog Class
CXTPTaskDialog::Create Method

Call this member function to create modeless task dialog

BOOL Create(
    CWnd* pParentWnd = NULL
);
Parameters

pParentWnd
Parent Window

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPTaskDialog Methods


CreateFromResource Method

CXTPTaskDialog Methods
CreateFromResource Method
Overload List
Methods
Method | Description
CXTPTaskDialog::CreateFromResource (HINSTANCE, UINT, LPCTSTR) | Call this method to create dialog from XML resource.
CXTPTaskDialog::CreateFromResource (UINT, LPCTSTR) | Call this method to create dialog from XML resource.
Group

CXTPTaskDialog Methods


CXTPTaskDialog::CreateFromResource Method (UINT, LPCTSTR)

CreateFromResource Method, CXTPTaskDialog Class
CXTPTaskDialog::CreateFromResource Method (UINT, LPCTSTR)

Call this method to create dialog from XML resource.

BOOL CreateFromResource(
    UINT nIDResource,
    LPCTSTR lpszDialog
);
BOOL CreateFromResource(
    HINSTANCE hInstance,
    UINT nIDResource,
    LPCTSTR lpszDialog
);
BOOL CreateFromResourceParam(
    HINSTANCE hInstance,
    UINT nIDResource,
    LPCTSTR lpszDialog,
    LPCTSTR const* rglpsz,
    int nString
);
BOOL CreateFromResourceParam(
    CXTPPropExchangeXMLNode* pPX,
    LPCTSTR const* rglpsz,
    int nString
);
Parameters

nIDResource
Resource identifier
lpszDialog
Dialog xml section
hInstance
Instance of resources
rglpsz
Array of strings that will be replaced in XML strings
nString
Number of parameter strings

Group

CreateFromResource Method


CreateFromResourceParam Method

CXTPTaskDialog Methods
CreateFromResourceParam Method
Overload List
Methods
Method | Description
CXTPTaskDialog::CreateFromResourceParam (CXTPPropExchangeXMLNode*, LPCTSTR const*, int) | Call this method to create dialog from XML resource.
CXTPTaskDialog::CreateFromResourceParam (HINSTANCE, UINT, LPCTSTR, LPCTSTR const*, int) | Call this method to create dialog from XML resource.
Group

CXTPTaskDialog Methods


CXTPTaskDialog::DoModal Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Example
CXTPTaskDialog::DoModal Method

Call this member function to display the task dialog and return the selected button when done.

INT_PTR DoModal(
    BOOL bUseComCtl32 = TRUE
);
Parameters

bUseComCtl32
TRUE to use ComCtl32.dll version of Task Dialog. This parameter is ignored for operating systems older than Windows Vista.

Returns

The return value is one of the button IDs specified in the AddButton member function or one of the following values:

  • 0 Function call failed.
  • IDCANCEL Cancel button was selected, Alt-F4 was pressed, Escape was pressed or the user clicked on the close window button.
  • IDNO No button was selected.
  • IDOK OK button was selected.
  • IDRETRY Retry button was selected.
  • IDYES Yes button was selected.
Example
CXTPTaskDialog taskDlg(this);
taskDlg.AddButton(_T("Change password"), IDOK);
taskDlg.SetCommonButtons(TDCBF_CANCEL_BUTTON);
taskDlg.SetMainIcon(TD_WARNING_ICON);
taskDlg.SetMainInstruction(_T("Change Password"));
taskDlg.SetContent(_T("Remember your changed password."));

int nRet = taskDlg.DoModal();
switch (nRet)
{
case 0:
   AfxMessageBox(_T("Task Dialog could not be created!"));
   break;
case IDOK:
   // the user pressed the OK button, change password.
   break;
case IDCANCEL:
   // user canceled the dialog.
   break;
};
Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::EnableButton Method

Call this member function to enable/disable a push button in the task dialog.

void EnableButton(
    int nButtonID,
    BOOL bEnable = TRUE
);
Parameters

nButtonID
Indicates the ID of the push button to be enabled/disabled.
bEnable
FALSE to disable the button, TRUE to enable the button.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, OnButtonClicked, SetButtonElevationRequired

Example
class CEnableButtonDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         EnableButton(IDOK, FALSE);
    }
};
Body Source
void CXTPTaskDialog::EnableButton(int nButtonID, BOOL bEnable) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_ENABLE_BUTTON, nButtonID, bEnable);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableCallbackTimer Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::EnableCallbackTimer Method

Call this member function to enable the callback timer.

void EnableCallbackTimer(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE indicates that the task dialog's callback should be called approximately every 200 milliseconds.

See Also

OnTimer, ModifyTaskStyle

Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableCancellation Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::EnableCancellation Method

Call this member function to allow dialog cancellation for the task dialog.

void EnableCancellation(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to allow cancellation, otherwise FALSE.

Remarks

When bAllow is TRUE, this indicates that the dialog should be able to be closed using Alt-F4, Escape and the title bar's close button even if no cancel button is specified by the SetCommonButtons or AddButton member functions.

See Also

SetWidth, SetWindowTitle, EnableRelativePosition, EnableRtlLayout, EnableMinimize, OnDialogConstructed

Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableCommandLinks Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::EnableCommandLinks Method

Call this member function to indicate the buttons specified with AddButton should be displayed as command links (using a standard task dialog glyph) instead of push buttons. This function is ignored if AddButton has not been called.

void EnableCommandLinks(
    BOOL bEnable = TRUE,
    BOOL bShowIcon = TRUE
);
Parameters

bEnable
TRUE to enable command links, FALSE to disable.
bShowIcon
TRUE if the command links should display a glyph.

Remarks

When using command links, all characters up to the first new line character in AddButton's pszText argument will be treated as the command link's main text, and the remainder will be treated as the command link's note.

See Also

AddButton, OnButtonClicked, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableHyperlinks Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::EnableHyperlinks Method

Enables hyperlink processing for the strings specified for the functions SetContent, SetExpandedInformation and SetFooter.

void EnableHyperlinks(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable hyperlinks, FALSE to disable.

Remarks

When enabled, Content, Expanded Information and Footer strings can contain hyperlinks in the form:

<A HREF="executablestring">Hyperlink Text</A>.
See Also

SetContent, SetExpandedInformation, SetFooter, OnHyperlinkClicked

Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableMarkup Method

CXTPTaskDialog Methods, CXTPTaskDialog Class
CXTPTaskDialog::EnableMarkup Method

NEEDS COMMENT

void EnableMarkup(
    BOOL bEnable = TRUE
);
Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableMessageBoxStyle Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source
CXTPTaskDialog::EnableMessageBoxStyle Method

Call this method to show thed dialog even if standard window theme used

void EnableMessageBoxStyle(
    BOOL bEnable = TRUE
);
Body Source
void CXTPTaskDialog::EnableMessageBoxStyle(BOOL bEnable) {
    m_bMessageBoxStyle = bEnable;
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableMinimize Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::EnableMinimize Method

Call this member function to enable the the task dialog to be minimized.

void EnableMinimize(
    BOOL bEnable
);
Parameters

bEnable
TRUE indicates that the task dialog's title bar and system menu contain the minimize command.

See Also

SetWidth, EnableCancellation, EnableRelativePosition, EnableRtlLayout, SetWindowTitle, OnDialogConstructed

Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableRadioButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::EnableRadioButton Method

Call this member function to enable/disable a radio button in the task dialog.

void EnableRadioButton(
    int nButtonID,
    BOOL bEnable = TRUE
);
Parameters

nButtonID
Indicates the ID of the radio button to be enabled/disabled.
bEnable
FALSE to disable the radio button, TRUE to enable the radio button.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

AddRadioButton, SetDefaultRadioButton, NoDefaultRadioButton, GetSelectedRadioButtonId, ClickRadioButton, OnRadioButtonClicked

Example
class CEnableRadioButtonDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         EnableRadioButton(100, FALSE);
    }
};
Body Source
void CXTPTaskDialog::EnableRadioButton(int nButtonID, BOOL bEnable) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_ENABLE_RADIO_BUTTON, nButtonID, bEnable);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableRelativePosition Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::EnableRelativePosition Method

Call this member function to position the task dialog relative to the parent window.

void EnableRelativePosition(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to reposition dialog, otherwise FALSE.

Remarks

When bEnable is TRUE, this indicates that the task dialog should be positioned (centered) relative to the window specified by the hWndParent argument in the DoModal member function. If bEnable is FALSE, or hWndParent is NULL, the task dialog is positioned (centered) relative to the monitor.

See Also

SetWidth, EnableCancellation, SetWindowTitle, EnableRtlLayout, EnableMinimize, OnDialogConstructed

Group

CXTPTaskDialog Methods


CXTPTaskDialog::EnableRtlLayout Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::EnableRtlLayout Method

Call this member function to enable right to left text display for the task dialog.

void EnableRtlLayout(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE indicates that text should be displayed reading right to left.

See Also

SetWidth, EnableCancellation, EnableRelativePosition, SetWindowTitle, EnableMinimize, OnDialogConstructed

Group

CXTPTaskDialog Methods


CXTPTaskDialog::ExpandedByDefault Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::ExpandedByDefault Method

Call this member function to display the text specified by the SetExpandedInformation member function when the dialog is initially displayed. This function is ignored if the SetExpandedInformation member function has not been called.

void ExpandedByDefault(
    BOOL bExpanded = TRUE
);
Parameters

bExpanded
TRUE indicates that the string specified by the SetExpandedInformation member function should be displayed when the dialog is initially displayed.

See Also

SetCollapsedControlText, SetExpandedInformation, SetExpandedControlText, ExpandFooterArea, OnExpandoButtonClicked

Group

CXTPTaskDialog Methods


CXTPTaskDialog::ExpandFooterArea Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::ExpandFooterArea Method

Call this member to display expanded information at the bottom of the task dialog's footer. This function is ignored if the SetExpandedInformation member function has not been called.

void ExpandFooterArea(
    BOOL bExpandFooter = TRUE
);
Parameters

bExpandFooter
TRUE indicates that the string specified by the SetExpandedInformation member should be displayed at the bottom of the dialog's footer area instead of immediately after the dialog's content.

See Also

SetCollapsedControlText, SetExpandedInformation, ExpandedByDefault, SetExpandedControlText, OnExpandoButtonClicked

Group

CXTPTaskDialog Methods


CXTPTaskDialog::GetInputBoxText Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::GetInputBoxText Method

Call this member function to get text entered by user in input box field.

CString GetInputBoxText() const;
Remarks

Call AddInputBox to add user input box for task dialog.

See Also

AddInputBox, SetInputBoxText

Body Source
CString CXTPTaskDialog::GetInputBoxText() const {
    return m_strInputBoxText;
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::GetSelectedButtonId Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::GetSelectedButtonId Method

Call this member function to retrieve the ID of the button used to close the task dialog.

int GetSelectedButtonId() const;
Returns

The return value is one of the button IDs specified in the AddButton member function or one of the following values:

  • 0 Function call failed.
  • IDCANCEL Cancel button was selected, Alt-F4 was pressed, Escape was pressed or the user clicked on the close window button.
  • IDNO No button was selected.
  • IDOK OK button was selected.
  • IDRETRY Retry button was selected.
  • IDYES Yes button was selected.
See Also

AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, OnButtonClicked, ClickButton, EnableButton, SetButtonElevationRequired

Body Source
int CXTPTaskDialog::GetSelectedButtonId() const {
    return m_nSelButtonID;
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::GetSelectedRadioButtonId Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::GetSelectedRadioButtonId Method

Call this member function to retrieve the ID of the radio button that was selected when the task dialog was closed.

int GetSelectedRadioButtonId() const;
Returns

The return value is one of the button IDs specified in the AddRadioButton member function.

See Also

AddRadioButton, SetDefaultRadioButton, NoDefaultRadioButton, OnRadioButtonClicked, ClickRadioButton, EnableRadioButton

Body Source
int CXTPTaskDialog::GetSelectedRadioButtonId() const {
    return m_nSelRadioButtonID;
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::IsVerificiationChecked Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::IsVerificiationChecked Method

Call this member function to retrieve the checked state of the verification checkbox when the dialog was closed.

BOOL IsVerificiationChecked() const;
Returns

TRUE if the verification check box was checked when the task dialog was closed, otherwise false.

See Also

SetVerificationText, SetVerifyCheckState, OnVerificationClicked, ClickVerification

Body Source
BOOL CXTPTaskDialog::IsVerificiationChecked() const {
    return m_bVerification;
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::ModifyTaskStyle Method

CXTPTaskDialog Methods, CXTPTaskDialog Class
CXTPTaskDialog::ModifyTaskStyle Method

Call this member function to modify the style for the task dialog.

BOOL ModifyTaskStyle(
    TASKDIALOG_FLAGS dwRemove,
    TASKDIALOG_FLAGS dwAdd
);
Parameters

dwRemove
Specifies the styles to be removed.
dwAdd
Specifies the styles to be added.

Returns

TRUE if style was successfully modified; otherwise, FALSE.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. The style can be any combination of the following values:

  • TDF_ENABLE_HYPERLINKS See EnableHyperlinks.
  • TDF_USE_HICON_MAIN See SetMainIcon.
  • TDF_USE_HICON_FOOTER See SetFooterIcon.
  • TDF_ALLOW_DIALOG_CANCELLATION See EnableCancellation.
  • TDF_USE_COMMAND_LINKS See EnableCommandLinks.
  • TDF_USE_COMMAND_LINKS_NO_ICON See EnableCommandLinks.
  • TDF_EXPAND_FOOTER_AREA See ExpandFooterArea.
  • TDF_EXPANDED_BY_DEFAULT See ExpandedByDefault.
  • TDF_VERIFICATION_FLAG_CHECKED See SetVerifyCheckState.
  • TDF_SHOW_PROGRESS_BAR See ShowProgressBar.
  • TDF_SHOW_MARQUEE_PROGRESS_BAR See ShowProgressBar.
  • TDF_CALLBACK_TIMER See EnableCallbackTimer.
  • TDF_POSITION_RELATIVE_TO_WINDOW See EnableRelativePosition.
  • TDF_RTL_LAYOUT See EnableRtlLayout.
  • TDF_NO_DEFAULT_RADIO_BUTTON See NoDefaultRadioButton.
  • TDF_CAN_BE_MINIMIZED See EnableMinimize.
Group

CXTPTaskDialog Methods


CXTPTaskDialog::NavigatePage Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::NavigatePage Method

This member function is used to simulate a wizard style task dialog. By using multiple CXTPTaskDialog objects that define the aspects of each page, you can incorporate Back and Next buttons that can be used to update the appearance and behavior of the task dialog.

void NavigatePage(
    CXTPTaskDialog& taskDlg
);
Parameters

taskDlg
Reference to a CXTPTaskDialog object that contains attributes for the appearance and behavior of the new task page.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

OnNavigated

Example
class CNavigateDlg : public CXTPTaskDialog
{
    CXTPTaskDialog m_dlgBack;
    CXTPTaskDialog m_dlgNext;
protected:
    void OnButtonClicked(int nButtonID, BOOL& bCloseDialog)
    {
         switch (nButtonID)
         {
         case IDBACK:
             NavigatePage(m_dlgBack);
             bCloseDialog = FALSE;
             break;
         case IDNEXT:
             NavigatePage(m_dlgNext);
             bCloseDialog = FALSE;
             break;
         }
    }
};
Body Source
void CXTPTaskDialog::NavigatePage(CXTPTaskDialog& taskDlg) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_NAVIGATE_PAGE, 0, (LPARAM)&taskDlg.m_config);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::NoDefaultRadioButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::NoDefaultRadioButton Method

Call this member function to disable default radio button selection.

void NoDefaultRadioButton(
    BOOL bNoDefault
);
Parameters

bNoDefault
TRUE indicates that no default item will be selected.

See Also

AddRadioButton, SetDefaultRadioButton, OnRadioButtonClicked, GetSelectedRadioButtonId, ClickRadioButton, EnableRadioButton

Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnButtonClicked Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnButtonClicked Method

This notification is sent by the Task Dialog when a user selects a button or command link in the task dialog.

virtual void OnButtonClicked(
    int nButtonID,
    BOOL& bCloseDialog
);
Parameters

nButtonID
The ID corresponding to the button selected.
bCloseDialog
Set to TRUE if the task dialog should close.

See Also

AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

Body Source
void CXTPTaskDialog::OnButtonClicked(int nButtonID, BOOL& bCloseDialog) {
    UNREFERENCED_PARAMETER(nButtonID); bCloseDialog = TRUE;
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnDialogConstructed Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnDialogConstructed Method

This notification is sent by the Task Dialog once the task dialog has been created and before it is displayed.

virtual void OnDialogConstructed();
See Also

SetWidth, EnableCancellation, EnableRelativePosition, EnableRtlLayout, EnableMinimize, SetWindowTitle

Body Source
void CXTPTaskDialog::OnDialogConstructed() {

}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnDialogDestroyed Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnDialogDestroyed Method

This notification is sent by the Task Dialog once the task dialog has been destroyed.

virtual void OnDialogDestroyed();
See Also

OnDialogConstructed

Body Source
void CXTPTaskDialog::OnDialogDestroyed() {

}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnExpandoButtonClicked Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnExpandoButtonClicked Method

This notification is sent by the Task Dialog when the user clicks on an expando in the Task Dialog.

virtual void OnExpandoButtonClicked(
    BOOL bExpanded
);
Parameters

bExpanded
TRUE if the dialog is expanded, otherwise FALSE.

See Also

SetCollapsedControlText, SetExpandedInformation, ExpandedByDefault, ExpandFooterArea, SetExpandedControlText

Body Source
void CXTPTaskDialog::OnExpandoButtonClicked(BOOL bExpanded) {
    UNREFERENCED_PARAMETER(bExpanded);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnHelp Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source
CXTPTaskDialog::OnHelp Method

This notification is sent by the Task Dialog when the user presses F1 on the keyboard while the dialog has focus.

virtual void OnHelp();
Body Source
void CXTPTaskDialog::OnHelp() {

}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnHyperlinkClicked Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnHyperlinkClicked Method

This notification is sent by the Task Dialog when a user clicks on a hyperlink in the Task Dialog's content

virtual void OnHyperlinkClicked(
    LPCTSTR pszURL
);
Parameters

pszURL
Pointer to a wide-character string containing the URL of the hyperlink.

See Also

SetContent, SetExpandedInformation, SetFooter, EnableHyperlinks

Body Source
void CXTPTaskDialog::OnHyperlinkClicked(LPCTSTR pszURL) {
    UNREFERENCED_PARAMETER(pszURL);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnNavigated Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnNavigated Method

This notification is sent by the Task Dialog when a navigation has occurred.

virtual void OnNavigated();
See Also

NavigatePage

Body Source
void CXTPTaskDialog::OnNavigated() {

}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnRadioButtonClicked Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnRadioButtonClicked Method

This notification is sent by the Task Dialog when a user selects a radio button in the task dialog.

virtual void OnRadioButtonClicked(
    int nButtonID
);
Parameters

nButtonID
The ID corresponding to the radio button that was clicked.

See Also

AddRadioButton, SetDefaultRadioButton, NoDefaultRadioButton, GetSelectedRadioButtonId, ClickRadioButton, EnableRadioButton

Body Source
void CXTPTaskDialog::OnRadioButtonClicked(int nButtonID) {
    UNREFERENCED_PARAMETER(nButtonID);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnTimer Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnTimer Method

This notification is sent by the Task Dialog approximately every 200 milliseconds when the EnableCallbackTimer member function has been called.

virtual void OnTimer(
    DWORD dwMilliSeconds,
    BOOL& bReset
);
Parameters

dwMilliSeconds
Number of milliseconds since the dialog was created or bReset was set to TRUE.
bReset
TRUE to reset the tickcount, otherwise the tickcount will continue to increment.

See Also

EnableCallbackTimer, ModifyTaskStyle

Body Source
void CXTPTaskDialog::OnTimer(DWORD dwMilliSeconds, BOOL& bReset) {
    UNREFERENCED_PARAMETER(dwMilliSeconds); UNREFERENCED_PARAMETER(bReset);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::OnVerificationClicked Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::OnVerificationClicked Method

This notification is sent by the Task Dialog when the user clicks on the task dialog's verification check box.

virtual void OnVerificationClicked(
    BOOL bChecked
);
Parameters

bChecked
TRUE if the verification checkbox is checked, otherwise FALSE.

See Also

SetVerificationText, SetVerifyCheckState, IsVerificiationChecked, ClickVerification

Body Source
void CXTPTaskDialog::OnVerificationClicked(BOOL bChecked) {
    UNREFERENCED_PARAMETER(bChecked);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::ResetContent Method

CXTPTaskDialog Methods, CXTPTaskDialog Class
CXTPTaskDialog::ResetContent Method

Call this member function to reset the configuration attributes for the task dialog to the default state.

void ResetContent();
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetButtonElevationRequired Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::SetButtonElevationRequired Method

Call this member function to designate whether a given Task Dialog button or command link should have a User Account Control (UAC) shield icon (whether the action invoked by the button requires elevation).

void SetButtonElevationRequired(
    int nButtonID,
    BOOL bRequired = TRUE
);
Parameters

nButtonID
Indicates ID of the push button or command link to be updated.
bRequired
FALSE to designate that the action invoked by the button does not require elevation; TRUE to designate that the action does require elevation.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, OnButtonClicked

Example
class CElevationDlg : public CXTPTaskDialog
{
protected:
    void OnButtonClicked(int nButtonID, BOOL& bCloseDialog)
    {
         switch (nButtonID)
         {
         case IDOK:
             SetButtonElevationRequired(nButtonID, TRUE);
             bCloseDialog = FALSE;
             break;
         case IDCANCEL:
             SetButtonElevationRequired(nButtonID, FALSE);
             bCloseDialog = TRUE;
             break;
         }
    }
};
Body Source
void CXTPTaskDialog::SetButtonElevationRequired(int nButtonID, BOOL bRequired) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_SET_BUTTON_ELEVATION_REQUIRED_STATE, nButtonID, bRequired);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetCollapsedControlText Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetCollapsedControlText Method

Call this member function to set the collapsed control text for the task dialog. This function is ignored unless SetExpandedInformation has been called.

void SetCollapsedControlText(
    LPCTSTR pszText
);
Parameters

pszText
Pointer that references the string to be used to label the button for expanding the expandable information.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If this parameter is NULL, then the value set with SetExpandedControlText will be used for the collapsed control text as well.

See Also

SetExpandedControlText, SetExpandedInformation, ExpandedByDefault, ExpandFooterArea, OnExpandoButtonClicked

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetCommonButtons Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetCommonButtons Method

Specifies the push buttons displayed in the task dialog. If no common buttons are specified and no custom buttons are specified using the AddButton member function, the task dialog will contain the OK button by default.

void SetCommonButtons(
    BOOL bOk,
    BOOL bYes,
    BOOL bNo,
    BOOL bCancel,
    BOOL bRetry,
    BOOL bClose
);
Parameters

bOk
TRUE if the task dialog contains the push button: OK.
bYes
TRUE if the task dialog contains the push button: Yes.
bNo
TRUE if the task dialog contains the push button: No.
bCancel
TRUE if the task dialog contains the push button: Cancel.
bRetry
TRUE if the task dialog contains the push button: Retry.
bClose
TRUE if the task dialog contains the push button: Close.
dwButtons
Can be any combination of the flags listed in the remarks section.

Remarks

Any of the following flags can be used with the dwButtons parameter:

  • TDCBF_OK_BUTTON The task dialog contains the push button: OK.
  • TDCBF_YES_BUTTON The task dialog contains the push button: Yes.
  • TDCBF_NO_BUTTON The task dialog contains the push button: No.
  • TDCBF_CANCEL_BUTTON The task dialog contains the push button: Cancel.
  • TDCBF_RETRY_BUTTON The task dialog contains the push button: Retry.
  • TDCBF_CLOSE_BUTTON The task dialog contains the push button: Close.

If the Cancel button is specified, the task dialog will respond to typical cancel actions (Alt-F4 and Escape).

See Also

AddButton, EnableCommandLinks, SetDefaultButton, OnButtonClicked, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetContent Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetContent Method

Call this member function to set the content text for the task dialog.

BOOL SetContent(
    LPCTSTR pszText
);
Parameters

pszText
Pointer that references the string to be used for the dialog's primary content.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If EnableHyperlinks has been called, then this string may contain hyperlinks in the form:

<A HREF="executablestring">Hyperlink Text</A>.
See Also

OnHyperlinkClicked, SetExpandedInformation, SetFooter, EnableHyperlinks

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetDefaultButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetDefaultButton Method

Call this member function to set the default button ID for the task dialog.

void SetDefaultButton(
    int nButtonID
);
Parameters

nButtonID
Indicates the default button for the dialog.

Remarks

nButtonID may be any of the values specified when calling the AddButton member function, or one of the IDs corresponding to the buttons specified in the SetCommonButtons member function:

  • IDCANCEL Make the Cancel button the default.
  • IDNO Make the No button the default.
  • IDOK Make the OK button the default.
  • IDRETRY Make the Retry button the default.
  • IDYES Make the Yes button the default.
  • IDCLOSE Make the Close button the default.

If this member is zero or its value does not correspond to any button ID in the dialog, then the first button in the dialog will be the default.

See Also

AddButton, EnableCommandLinks, OnButtonClicked, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetDefaultRadioButton Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetDefaultRadioButton Method

Call this member function to set the default radio button ID for the task dialog.

void SetDefaultRadioButton(
    int nButtonID
);
Parameters

nButtonID
Indicates the default radio button for the dialog.

Remarks

nButtonID may be any of the values specified when calling the AddRadioButton member function. If this member is zero or its value does not correspond to any radio button ID in the dialog, then the first button in the dialog will be the default.

See Also

AddRadioButton, OnRadioButtonClicked, NoDefaultRadioButton, GetSelectedRadioButtonId, ClickRadioButton, EnableRadioButton

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetExpandedControlText Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetExpandedControlText Method

Call this member function to set the expanded control text for the task dialog. This function is ignored unless SetExpandedInformation has been called.

void SetExpandedControlText(
    LPCTSTR pszText
);
Parameters

pszText
Pointer that references the string to be used to label the button for collapsing the expandable information.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If this parameter is NULL, then the value set with SetCollapsedControlText will be used for the expanded control text as well.

See Also

SetCollapsedControlText, SetExpandedInformation, ExpandedByDefault, ExpandFooterArea, OnExpandoButtonClicked

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetExpandedInformation Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetExpandedInformation Method

Call this member function to set the expanded information text for the task dialog.

BOOL SetExpandedInformation(
    LPCTSTR pszText
);
Parameters

pszText
Pointer that references the string to be used for displaying additional information.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. The additional information is displayed either immediately below the content or below the footer text depending on whether ExpandFooterArea has been called. If EnableHyperlinks has been called, then this string may contain hyperlinks in the form:

<A HREF="executablestring">Hyperlink Text</A>.
See Also

SetCollapsedControlText, SetExpandedControlText, ExpandedByDefault, ExpandFooterArea, OnExpandoButtonClicked, SetContent, OnHyperlinkClicked, SetFooter, EnableHyperlinks

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetFooter Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetFooter Method

Call this member function to set the footer text for the task dialog.

BOOL SetFooter(
    LPCTSTR pszText
);
Parameters

pszText
Pointer that references the string to be used in the footer area of the task dialog.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If EnableHyperlinks has been called, then this string may contain hyperlinks in the form:

<A HREF="executablestring">Hyperlink Text</A>.
See Also

SetContent, SetExpandedInformation, OnHyperlinkClicked, EnableHyperlinks

Group

CXTPTaskDialog Methods


SetFooterIcon Method

CXTPTaskDialog Methods
SetFooterIcon Method
Overload List
Methods
Method | Description
CXTPTaskDialog::SetFooterIcon (HICON) | Call this member function to set the icon for the Footer area of the task dialog.
CXTPTaskDialog::SetFooterIcon (LPCWSTR) | Call this member function to set the icon for the Footer area of the task dialog.
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetFooterIcon Method (HICON)

SetFooterIcon Method, CXTPTaskDialog Class
CXTPTaskDialog::SetFooterIcon Method (HICON)

Call this member function to set the icon for the Footer area of the task dialog.

BOOL SetFooterIcon(
    HICON hIcon
);
BOOL SetFooterIcon(
    LPCWSTR pszResource
);
Parameters

hIcon
A handle to an Icon that is to be displayed in the task dialog footer area. If this member is NULL, no icon will be displayed.
pszResource
Pointer that references the icon to be displayed in the task dialog footer area. If this parameter is NULL no icon will be displayed.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

The parameter pszResource must be an integer resource identifier passed to the MAKEINTRESOURCE macro, or one of the following predefined values:

  • TD_ERROR_ICON A stop-sign icon appears in the task dialog.
  • TD_WARNING_ICON An exclamation-point icon appears in the task dialog.
  • TD_INFORMATION_ICON An icon consisting of a lowercase letter i in a circle appears in the task dialog.
  • TD_SHIELD_ICON A shield icon appears in the task dialog.
Group

SetFooterIcon Method


CXTPTaskDialog::SetInputBoxText Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::SetInputBoxText Method

Call this member function to set default value for input box field

void SetInputBoxText(
    LPCTSTR lpszInputBoxText
);
Remarks

Call AddInputBox to add user input box for task dialg.

See Also

AddInputBox, GetInputBoxText

Body Source
void CXTPTaskDialog::SetInputBoxText(LPCTSTR lpszInputBoxText) {
    m_strInputBoxText = lpszInputBoxText;
}
Group

CXTPTaskDialog Methods


SetMainIcon Method

CXTPTaskDialog Methods
SetMainIcon Method
Overload List
Methods
Method | Description
CXTPTaskDialog::SetMainIcon (HICON) | Call this member function to set the icon for the Main Instruction area of the task dialog.
CXTPTaskDialog::SetMainIcon (LPCWSTR) | Call this member function to set the icon for the Main Instruction area of the task dialog.
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetMainIcon Method (HICON)

SetMainIcon Method, CXTPTaskDialog Class
CXTPTaskDialog::SetMainIcon Method (HICON)

Call this member function to set the icon for the Main Instruction area of the task dialog.

BOOL SetMainIcon(
    HICON hIcon
);
BOOL SetMainIcon(
    LPCWSTR pszResource
);
Parameters

hIcon
A handle to an Icon that is to be displayed in the task dialog Main Instruction area. If this member is NULL, no icon will be displayed.
pszResource
Pointer that references the icon to be displayed in the task dialog footer area. If this parameter is NULL no icon will be displayed.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

The parameter pszResource must be an integer resource identifier passed to the MAKEINTRESOURCE macro, or one of the following predefined values:

  • TD_ERROR_ICON A stop-sign icon appears in the task dialog.
  • TD_WARNING_ICON An exclamation-point icon appears in the task dialog.
  • TD_INFORMATION_ICON An icon consisting of a lowercase letter i in a circle appears in the task dialog.
  • TD_SHIELD_ICON A shield icon appears in the task dialog.
Group

SetMainIcon Method


CXTPTaskDialog::SetMainInstruction Method

CXTPTaskDialog Methods, CXTPTaskDialog Class
CXTPTaskDialog::SetMainInstruction Method

Call this member function to set the main instruction text for the task dialog.

BOOL SetMainInstruction(
    LPCTSTR pszText
);
Parameters

pszText
Pointer that references the string to be used for the main instruction.

Returns

TRUE if successful, otherwise returns FALSE.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro.

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetMarqueeProgressBar Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::SetMarqueeProgressBar Method

Call this member function to indicate whether the progress bar should be displayed in marquee mode or not.

void SetMarqueeProgressBar(
    BOOL bMarquee = TRUE
);
Parameters

bMarquee
Specifies whether the progress bar should be shown in Marquee mode. A value of TRUE turns on Marquee mode.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

ShowProgressBar, SetProgressBarState, SetProgressBarRange, SetProgressBarPos, StartProgressBarMarquee

Example
class CProgressDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         SetMarqueeProgressBar(TRUE);
         SetProgressBarState(PBST_NORMAL);
    }
};
Body Source
void CXTPTaskDialog::SetMarqueeProgressBar(BOOL bMarquee) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_SET_MARQUEE_PROGRESS_BAR, bMarquee, 0);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetProgressBarPos Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::SetProgressBarPos Method

Call this member function to se the current position for the progress bar.

void SetProgressBarPos(
    int nPosition
);
Parameters

nPosition
Signed integer that becomes the new position.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

SetMarqueeProgressBar, SetProgressBarState, SetProgressBarRange, ShowProgressBar, StartProgressBarMarquee

Example
class CProgressDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         SetProgressBarPos(25);
         SetProgressBarRange(0, 100);
         SetProgressBarState(PBST_PAUSE);
    }
};
Body Source
void CXTPTaskDialog::SetProgressBarPos(int nPosition) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_SET_PROGRESS_BAR_POS, nPosition, 0);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetProgressBarRange Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::SetProgressBarRange Method

Call this member function to set the minimum and maximum values for the progress bar.

void SetProgressBarRange(
    WORD wMinRange = 0,
    WORD wMaxRange = 100
);
Parameters

wMinRange
Minimum range value. By default, the minimum value is zero.
wMaxRange
Maximum range value. By default, the maximum value is 100.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

SetMarqueeProgressBar, SetProgressBarState, ShowProgressBar, SetProgressBarPos, StartProgressBarMarquee

Example
class CProgressDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         SetProgressBarPos(25);
         SetProgressBarRange(0, 100);
         SetProgressBarState(PBST_PAUSE);
    }
};
Body Source
void CXTPTaskDialog::SetProgressBarRange(WORD wMinRange, WORD wMaxRange) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_SET_PROGRESS_BAR_RANGE, 0, MAKELPARAM(wMinRange, wMaxRange));
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetProgressBarState Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::SetProgressBarState Method

Call this member function to set the current state of the progress bar.

void SetProgressBarState(
    int nState
);
Parameters

nState
Specifies the bar state. The parameter can be one of the following values:

  • PBST_NORMAL Sets the progress bar to the normal state.
  • PBST_PAUSE Sets the progress bar to the paused state.
  • PBST_ERROR Set the progress bar to the error state.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

SetMarqueeProgressBar, ShowProgressBar, SetProgressBarRange, SetProgressBarPos, StartProgressBarMarquee

Example
class CProgressDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         SetProgressBarPos(25);
         SetProgressBarRange(0, 100);
         SetProgressBarState(PBST_PAUSE);
    }
};
Body Source
void CXTPTaskDialog::SetProgressBarState(int nState) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_SET_PROGRESS_BAR_STATE, nState, 0);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetUseSysIcons Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source
CXTPTaskDialog::SetUseSysIcons Method

Call this member function to use system icons

void SetUseSysIcons(
    BOOL bUseSysIcons = TRUE
);
Parameters

bUseSysIcons
TRUE to use system icons when available for TD_ERROR_ICON, TD_WARNING_ICON, TD_INFORMATION_ICON and TD_SHIELD_ICON instead of Codejock Software icons. This parameter is ignored when bUseComCtl32 is set to TRUE.

Body Source
void CXTPTaskDialog::SetUseSysIcons(BOOL bUseSysIcons) {
    m_bUseSysIcons = bUseSysIcons;
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetVerificationText Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetVerificationText Method

Call this member function to set the label for the verification checkbox to be displayed in the task dialog.

void SetVerificationText(
    LPCTSTR pszText
);
Parameters

pszText
Pointer that references the string to be used to label the verification checkbox.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If this parameter is NULL, the verification checkbox is not displayed in the task dialog.

See Also

OnVerificationClicked, SetVerifyCheckState, IsVerificiationChecked, ClickVerification

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetVerifyCheckState Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetVerifyCheckState Method

Call this member function to set the checked state for the verification checkbox when the dialog is initially displayed. This function is ignored if the SetVerificationText member function has not been called.

void SetVerifyCheckState(
    BOOL bChecked = TRUE
);
Parameters

bChecked
TRUE indicates that the verification checkbox in the dialog should be checked when the dialog is initially displayed.

See Also

OnVerificationClicked, OnVerificationClicked, IsVerificiationChecked, ClickVerification

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetWidth Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetWidth Method

Call this member function to set the width of the task dialog's client area.

void SetWidth(
    int cxWidth,
    BOOL bPixelToDLU = FALSE
);
Parameters

cxWidth
Specifies the width of the task dialog's client area in dialog units. If 0, task dialog will calculate the ideal width.
bPixelToDLU
TRUE indicates the size specified by cxWidth are pixel units and need to be converted into dialog units (DLU).

See Also

SetWindowTitle, EnableCancellation, EnableRelativePosition, EnableRtlLayout, EnableMinimize, OnDialogConstructed

Group

CXTPTaskDialog Methods


CXTPTaskDialog::SetWindowTitle Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::SetWindowTitle Method

Call this member function to set the window title for the task dialog.

void SetWindowTitle(
    LPCTSTR pszText
);
Parameters

pszText
Pointer that references the string to be used for the task dialog title.

Remarks

The parameter pszText can be either a null-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If this parameter is NULL, the filename of the executable program is used.

See Also

SetWidth, EnableCancellation, EnableRelativePosition, EnableRtlLayout, EnableMinimize, OnDialogConstructed

Group

CXTPTaskDialog Methods


CXTPTaskDialog::ShowProgressBar Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, See Also
CXTPTaskDialog::ShowProgressBar Method

Call this member function to display a Progress Bar for the task dialog.

void ShowProgressBar(
    BOOL bShow,
    BOOL bMarquee = FALSE
);
Parameters

bShow
TRUE indicates that a Progress Bar should be displayed.
bMarquee
TRUE indicates the progress bar should be Marquee style.

See Also

SetMarqueeProgressBar, SetProgressBarState, SetProgressBarRange, SetProgressBarPos, StartProgressBarMarquee

Group

CXTPTaskDialog Methods


CXTPTaskDialog::StartProgressBarMarquee Method

CXTPTaskDialog Methods, CXTPTaskDialog Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskDialog::StartProgressBarMarquee Method

Similar to SetMarqueeProgressBar, this member function is used to indicate whether the progress bar should be displayed in marquee mode or not with the ability to determine marquee speed as well.

void StartProgressBarMarquee(
    BOOL bStartMarquee,
    DWORD dwMilliSeconds
);
Parameters

bStartMarquee
Indicates whether to start marquee.
dwMilliSeconds
Indicates the speed of the marquee in milliseconds.

Remarks

This member function should only be called from a derived class, and only after the task dialog has been initialized.

See Also

SetMarqueeProgressBar, SetProgressBarState, SetProgressBarRange, SetProgressBarPos, ShowProgressBar

Example
class CProgressDlg : public CXTPTaskDialog
{
protected:
    virtual void OnDialogConstructed()
    {
         StartProgressBarMarquee(TRUE, 10);
         SetProgressBarState(PBST_NORMAL);
    }
};
Body Source
void CXTPTaskDialog::StartProgressBarMarquee(BOOL bStartMarquee, DWORD dwMilliSeconds) {
    ASSERT(::IsWindow(m_hwndTaskDialog)); ::SendMessage(m_hwndTaskDialog, TDM_SET_PROGRESS_BAR_MARQUEE, bStartMarquee, dwMilliSeconds);
}
Group

CXTPTaskDialog Methods


CXTPTaskDialog Constructors

CXTPTaskDialog Class, Legend, Public Methods
CXTPTaskDialog Constructors
Class

CXTPTaskDialog Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskDialog | Constructs a CXTPTaskDialog object.


CXTPTaskDialog::CXTPTaskDialog Constructor

CXTPTaskDialog Constructors, CXTPTaskDialog Class
CXTPTaskDialog::CXTPTaskDialog Constructor

Constructs a CXTPTaskDialog object.

CXTPTaskDialog(
    CWnd* pWndParent = NULL
);
Parameters

pWndParent
Points to the parent or owner window object

Group

CXTPTaskDialog Constructors


CXTPTaskDialog Destructors

CXTPTaskDialog Class, Legend, Public Methods
CXTPTaskDialog Destructors
Class

CXTPTaskDialog Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTaskDialog | Destroys a CXTPTaskDialog object, handles cleanup and deallocation.


CXTPTaskDialog::~CXTPTaskDialog Destructor

CXTPTaskDialog Destructors, CXTPTaskDialog Class
CXTPTaskDialog::~CXTPTaskDialog Destructor

Destroys a CXTPTaskDialog object, handles cleanup and deallocation.

virtual ~CXTPTaskDialog();
Group

CXTPTaskDialog Destructors


CXTRegistryManager Class

XTRegistryManager.h, Classes, Legend, Members, Topics, CXTRegistryManager Data Members, CXTRegistryManager Methods, CXTRegistryManager Constructors, CXTRegistryManager Destructors, CXTRegistryManager Constructors, CXTRegistryManager Data Members, CXTRegistryManager Destructors, CXTRegistryManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTRegistryManager Class

CXTRegistryManager is a stand alone registry management class. You can use it to read and write values from your system's registry or an .INI file. Use CXTRegistryManager to read and write string, integer, and binary data to and from the registry. You can also specify an .INI file name, and have these values stored there instead.

Class Hierarchy

class CXTRegistryManager;
File

XTRegistryManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTRegistryManager Constructors
CXTRegistryManager Constructors | Description
CXTRegistryManager | Constructs a CXTRegistryManager object
CXTRegistryManager Data Members
CXTRegistryManager Data Members | Description
m_hKeyBase | Handle to the registry key to use.
m_pszProfileName | The application's .INI filename.
m_pszRegistryKey | Used to determine the full registry key for storing application profile settings.
m_strINIFileName | Name of an .INI file for registry settings.
CXTRegistryManager Destructors
CXTRegistryManager Destructors | Description
~CXTRegistryManager | Destroys a CXTRegistryManager object, handles cleanup and deallocation
CXTRegistryManager Methods
CXTRegistryManager Methods | Description
DeleteKey | Call this function to delete a registry key and all of its contents.
DeleteValue | Call this function to delete a registry value.
EnumKeys | Call this function to fill a CStringArray with the names of keys below the key specified. The return value indicates the number of keys found by the function, which can be used to check if any were found. CStringArray::GetSize will give the same result if needed, assuming the array is zeroed when it goes in. The function does not zero it, leaving the possibility of getting a list of subkeys of more than one key for whatever reason.
EnumValues | Call this function to fill a CMap (CString to DWORD) with the names and value types under a specific registry section.
GetAppRegistryKey | Called to get a handle to the CWinApp's registry key.
GetErrorCode | Call this member function to retrieve that last error (if any) that was returned by Windows when accessing the system registry.
GetErrorMessage | Call this member function to retrieve the description text for the last error (if any) that occurred while accessing the system registry.
GetINIFileName | This member function will return the file name of the .INI file used by the registry manager.
GetProfileBinary | Call this member function to retrieve the binary value from an entry within a specified section of the application's registry or .INI file.
GetProfileColor | Call this member function to retrieve the value of a COLORREF from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.
GetProfileDouble | Call this member function to retrieve the value of a double from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.
GetProfileDword | Call this member function to retrieve the value of a DWORD from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.
GetProfileInt | Call this member function to retrieve the value of an integer from an entry within a specified section of the application's registry or .INI file.
GetProfilePoint | Call this member function to retrieve the value of a CPoint from an entry within a specified section of the application's registry or .INI file. Retrieves the CPoint value that follows the specified entry if the function is successful.
GetProfileRect | Call this member function to retrieve the value of a CRect from an entry within a specified section of the application's registry or .INI file. Retrieves the CRect value that follows the specified entry if the function is successful.
GetProfileSize | Call this member function to retrieve the value of a CSize from an entry within a specified section of the application's registry or .INI file. Retrieves the CSize value that follows the specified entry if the function is successful.
GetProfileString | Call this member function to retrieve the string associated with an entry within the specified section in the application's registry or .INI file. The return value is the string from the application's .INI file or 'lpszDefault' if the string cannot be found. The maximum string length supported by the framework is _MAX_PATH. If 'lpszDefault' is NULL, the return value is an empty string.
GetSectionKey | Called to get a handle to the specified section from the applications registry key.
SetINIFileName | This member function will set the .INI file name for the registry manager to use instead of the system registry.
WriteProfileBinary | Call this member function to write the specified binary value into the specified section of the application's registry or .INI file.
WriteProfileColor | Call this member function to write the specified COLORREF value into the specified section of the application's registry or .INI file.
WriteProfileDouble | Call this member function to write the specified double/float value into the specified section of the application's registry or .INI file.
WriteProfileDword | Call this member function to write the specified DWORD value into the specified section of the application's registry or .INI file.
WriteProfileInt | Call this member function to write the specified INT value into the specified section of the application's registry or .INI file.
WriteProfilePoint | Call this member function to write the specified CPoint value into the specified section of the application's registry or .INI file.
WriteProfileRect | Call this member function to write the specified CRect value into the specified section of the application's registry or .INI file.
WriteProfileSize | Call this member function to write the specified CSize value into the specified section of the application's registry or .INI file.
WriteProfileString | Call this member function to write the specified string value into the specified section of the application's registry or .INI file.


CXTRegistryManager Data Members

CXTRegistryManager Class, Legend, Protected Data Members
CXTRegistryManager Data Members
Class

CXTRegistryManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hKeyBase | Handle to the registry key to use.
m_pszProfileName | The application's .INI filename.
m_pszRegistryKey | Used to determine the full registry key for storing application profile settings.
m_strINIFileName | Name of an .INI file for registry settings.


CXTRegistryManager::m_hKeyBase Data Member

CXTRegistryManager Data Members, CXTRegistryManager Class
CXTRegistryManager::m_hKeyBase Data Member

Handle to the registry key to use.

HKEY m_hKeyBase;
Group

CXTRegistryManager Data Members


CXTRegistryManager::m_pszProfileName Data Member

CXTRegistryManager Data Members, CXTRegistryManager Class
CXTRegistryManager::m_pszProfileName Data Member

The application's .INI filename.

LPCTSTR m_pszProfileName;
Group

CXTRegistryManager Data Members


CXTRegistryManager::m_pszRegistryKey Data Member

CXTRegistryManager Data Members, CXTRegistryManager Class
CXTRegistryManager::m_pszRegistryKey Data Member

Used to determine the full registry key for storing application profile settings.

LPCTSTR m_pszRegistryKey;
Group

CXTRegistryManager Data Members


CXTRegistryManager::m_strINIFileName Data Member

CXTRegistryManager Data Members, CXTRegistryManager Class
CXTRegistryManager::m_strINIFileName Data Member

Name of an .INI file for registry settings.

CString m_strINIFileName;
Group

CXTRegistryManager Data Members


CXTRegistryManager Methods

CXTRegistryManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTRegistryManager Methods
Class

CXTRegistryManager Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetAppRegistryKey | Called to get a handle to the CWinApp's registry key.
GetSectionKey | Called to get a handle to the specified section from the applications registry key.
Public Methods
Public Methods
Public Method | Description
DeleteKey | Call this function to delete a registry key and all of its contents.
DeleteValue | Call this function to delete a registry value.
EnumKeys | Call this function to fill a CStringArray with the names of keys below the key specified. The return value indicates the number of keys found by the function, which can be used to check if any were found. CStringArray::GetSize will give the same result if needed, assuming the array is zeroed when it goes in. The function does not zero it, leaving the possibility of getting a list of subkeys of more than one key for whatever reason.
EnumValues | Call this function to fill a CMap (CString to DWORD) with the names and value types under a specific registry section.
GetErrorCode | Call this member function to retrieve that last error (if any) that was returned by Windows when accessing the system registry.
GetErrorMessage | Call this member function to retrieve the description text for the last error (if any) that occurred while accessing the system registry.
GetINIFileName | This member function will return the file name of the .INI file used by the registry manager.
GetProfileBinary | Call this member function to retrieve the binary value from an entry within a specified section of the application's registry or .INI file.
GetProfileColor | Call this member function to retrieve the value of a COLORREF from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.
GetProfileDouble | Call this member function to retrieve the value of a double from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.
GetProfileDword | Call this member function to retrieve the value of a DWORD from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.
GetProfileInt | Call this member function to retrieve the value of an integer from an entry within a specified section of the application's registry or .INI file.
GetProfilePoint | Call this member function to retrieve the value of a CPoint from an entry within a specified section of the application's registry or .INI file. Retrieves the CPoint value that follows the specified entry if the function is successful.
GetProfileRect | Call this member function to retrieve the value of a CRect from an entry within a specified section of the application's registry or .INI file. Retrieves the CRect value that follows the specified entry if the function is successful.
GetProfileSize | Call this member function to retrieve the value of a CSize from an entry within a specified section of the application's registry or .INI file. Retrieves the CSize value that follows the specified entry if the function is successful.
GetProfileString | Call this member function to retrieve the string associated with an entry within the specified section in the application's registry or .INI file. The return value is the string from the application's .INI file or 'lpszDefault' if the string cannot be found. The maximum string length supported by the framework is _MAX_PATH. If 'lpszDefault' is NULL, the return value is an empty string.
SetINIFileName | This member function will set the .INI file name for the registry manager to use instead of the system registry.
WriteProfileBinary | Call this member function to write the specified binary value into the specified section of the application's registry or .INI file.
WriteProfileColor | Call this member function to write the specified COLORREF value into the specified section of the application's registry or .INI file.
WriteProfileDouble | Call this member function to write the specified double/float value into the specified section of the application's registry or .INI file.
WriteProfileDword | Call this member function to write the specified DWORD value into the specified section of the application's registry or .INI file.
WriteProfileInt | Call this member function to write the specified INT value into the specified section of the application's registry or .INI file.
WriteProfilePoint | Call this member function to write the specified CPoint value into the specified section of the application's registry or .INI file.
WriteProfileRect | Call this member function to write the specified CRect value into the specified section of the application's registry or .INI file.
WriteProfileSize | Call this member function to write the specified CSize value into the specified section of the application's registry or .INI file.
WriteProfileString | Call this member function to write the specified string value into the specified section of the application's registry or .INI file.


CXTRegistryManager::DeleteKey Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::DeleteKey Method

Call this function to delete a registry key and all of its contents.

bool DeleteKey(
    LPCTSTR lpszSection,
    LPCTSTR lpszKey
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszKey
Points to a null-terminated string that specifies the subkey to delete.

Returns

true if successful, otherwise returns false.

Group

CXTRegistryManager Methods


CXTRegistryManager::DeleteValue Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::DeleteValue Method

Call this function to delete a registry value.

bool DeleteValue(
    LPCTSTR lpszSection,
    LPCTSTR lpszKey
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszKey
Points to a null-terminated string that specifies the value to delete.

Returns

true if successful, otherwise returns false.

Group

CXTRegistryManager Methods


CXTRegistryManager::EnumKeys Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::EnumKeys Method

Call this function to fill a CStringArray with the names of keys below the key specified. The return value indicates the number of keys found by the function, which can be used to check if any were found. CStringArray::GetSize will give the same result if needed, assuming the array is zeroed when it goes in. The function does not zero it, leaving the possibility of getting a list of subkeys of more than one key for whatever reason.

int EnumKeys(
    LPCTSTR lpszSection,
    CStringArray & arrayKeys
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
arrayKeys
A reference to a CStringArray, which will contain the keys in the registry under the above key.

Group

CXTRegistryManager Methods


CXTRegistryManager::EnumValues Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::EnumValues Method

Call this function to fill a CMap (CString to DWORD) with the names and value types under a specific registry section.

int EnumValues(
    LPCTSTR lpszSection,
    CMap<CString, LPCTSTR, DWORD, DWORD&>* mapItems,
    CStringArray* arrayNames
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
mapItems
A reference to a CMap, which will contain the items in the registry under this section. Can be NULL. Does not include subsection names.
arrayNames
A reference to a CStringArray which, if not NULL, will contain an array of names in the order they were read from the registry.

Returns

Zero if the section is empty; otherwise it returns the number of values present.

Remarks

The function also takes a pointer to a CStringArray because CMap is a sorted container; therefore, it is not possible to get the items in the order they appeared from it.

Pass NULL for the CStringArray* if you don't want to use it, and NULL into the CMap if you only require a list of the item names.

The DWORD values returned are as follows:

  • REG_BINARY Binary data in any form.
  • REG_DWORD A 32-bit number.
  • REG_DWORD_LITTLE_ENDIAN A 32-bit number in little-endian format. This is equivalent to REG_DWORD. In little-endian format, a multi-byte value is stored in memory from the lowest byte (the "little end") to the highest byte. For example, the value 0x12345678 is stored as (0x78 0x56 0x34 0x12) in little-endian format. Windows NT/Windows 2000, Windows 95, and Windows 98 are designed to run on little-endian computer architectures. A user may connect to computers that have big-endian architectures, such as some UNIX systems.
  • REG_DWORD_BIG_ENDIAN A 32-bit number in big-endian format. In big-endian format, a multi-byte value is stored in memory from the highest byte (the "big end") to the lowest byte. For example, the value 0x12345678 is stored as (0x12 0x34 0x56 0x78) in big-endian format.
  • REG_EXPAND_SZ A null-terminated string that contains unexpanded references to environment variables (for example, "%PATH%"). It will be a Unicode or ANSI string depending on whether you use the Unicode or ANSI functions. To expand the environment variable references, use the ExpandEnvironmentStrings function.
  • REG_LINK A Unicode symbolic link. Used internally. Applications should not use this type.
  • REG_MULTI_SZ An array of null-terminated strings, terminated by two null characters.
  • REG_NONE No defined value type.
  • REG_QWORD A 64-bit number.
  • REG_QWORD_LITTLE_ENDIAN A 64-bit number in little-endian format. This is equivalent to REG_QWORD.
  • REG_RESOURCE_LIST A device-driver resource list.
  • REG_SZ A null-terminated string. It will be a Unicode or ANSI string, depending on whether or not you use the Unicode or ANSI functions.
Group

CXTRegistryManager Methods


CXTRegistryManager::GetAppRegistryKey Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetAppRegistryKey Method

Called to get a handle to the CWinApp's registry key.

virtual HKEY GetAppRegistryKey(
    REGSAM samDesired = KEY_WRITE | KEY_READ
);
Parameters

samDesired
An access mask that specifies the desired access rights to the key

Returns

An HKEY handle to the applications registry key.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetErrorCode Method

CXTRegistryManager Methods, CXTRegistryManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTRegistryManager::GetErrorCode Method

Call this member function to retrieve that last error (if any) that was returned by Windows when accessing the system registry.

LONG GetErrorCode() const;
Returns

If the last operation was successful the return value is ERROR_SUCCESS, otherwise a nonzero error code is returned as defined in Winerror.h. You can call GetErrorMessage() to get a generic description of the error.

Body Source
LONG CXTRegistryManager::GetErrorCode() const {
    return m_lResult;
}
Group

CXTRegistryManager Methods


CXTRegistryManager::GetErrorMessage Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetErrorMessage Method

Call this member function to retrieve the description text for the last error (if any) that occurred while accessing the system registry.

CString GetErrorMessage() const;
Returns

Returns a CString object that contains the error message that describes the last error that occurred while accessing the system registry.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetINIFileName Method

CXTRegistryManager Methods, CXTRegistryManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTRegistryManager::GetINIFileName Method

This member function will return the file name of the .INI file used by the registry manager.

static CString& GetINIFileName();
Returns

A reference to the CString object that contains the INI file path.

Body Source
CString& CXTRegistryManager::GetINIFileName() {
    return m_strINIFileName;
}
Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfileBinary Method

CXTRegistryManager Methods, CXTRegistryManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTRegistryManager::GetProfileBinary Method

Call this member function to retrieve the binary value from an entry within a specified section of the application's registry or .INI file.

BOOL GetProfileBinary(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    BYTE** ppData,
    UINT* pBytes
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
ppData
Address of a LPBYTE data member to receive the value. It is the caller's responsibility to free the memory allocated for 'ppData'.
pBytes
Address of a UINT to receive the size of 'ppData'.

Returns

Nonzero if successful, otherwise returns zero.

Example

An example of this would be:

void CXTDockWindow::LoadBarSize(CString strSection)
{
    XT_MANAGE_STATE;  // Switch to toolkit resources/module state

    // restore the previous bar style.
    if (::IsWindow(m_hWnd))
    {
        UINT nSize = 0;
        LPBYTE pbtData = 0;
        CString string;
        string.LoadString(XT_IDS_REG_BARPOS);

        CXTRegistryManager regManager;
        if (regManager.GetProfileBinary(strSection,
            string, &pbtData, &nSize))
        {
            XT_BARPLACEMENT* pBP =
                reinterpret_cast<XT_BARPLACEMENT*>(pbtData);

            SetBarPlacement(pBP);
            delete [] pbtData;
        }
    }
}
Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfileColor Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetProfileColor Method

Call this member function to retrieve the value of a COLORREF from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.

BOOL GetProfileColor(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    COLORREF* rcResult
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
rcResult
Points to the variable to be filled from the registry.

Note that because COLORREF is a typedef for a DWORD, this function only calls GetProfileDword.

Returns

TRUE if the function succeeds, otherwise returns FALSE.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfileDouble Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetProfileDouble Method

Call this member function to retrieve the value of a double from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.

BOOL GetProfileDouble(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    double* rcResult
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
rcResult
Points to the variable to be filled from the registry.

Returns

TRUE if the function succeeds, otherwise returns FALSE.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfileDword Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetProfileDword Method

Call this member function to retrieve the value of a DWORD from an entry within a specified section of the application's registry or .INI file. Retrieves the value that follows the specified entry if the function is successful.

BOOL GetProfileDword(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    DWORD* rcResult
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
rcResult
Points to the variable to be filled from the registry.

Note that because COLORREF is a typedef for a DWORD, GetProfileColor calls this function.

Returns

TRUE if the function succeeds, otherwise returns FALSE.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfileInt Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetProfileInt Method

Call this member function to retrieve the value of an integer from an entry within a specified section of the application's registry or .INI file.

UINT GetProfileInt(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    int nDefault
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
nDefault
Specifies the default value to return if the framework cannot find the entry. This value can be an unsigned value in the range 0 through 65, 535 or a signed value in the range -32, 768 through 32, 767.

This member function supports hexadecimal notation for the value in the .INI file. When you retrieve a signed integer, you should cast the value into an int.

Returns

The integer value of the string that follows the specified entry if the function is successful. The return value is the value of the 'nDefault' parameter if the function does not find the entry. The return value is zero if the value that corresponds to the specified entry is not an integer.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfilePoint Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetProfilePoint Method

Call this member function to retrieve the value of a CPoint from an entry within a specified section of the application's registry or .INI file. Retrieves the CPoint value that follows the specified entry if the function is successful.

BOOL GetProfilePoint(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    CPoint* ptResult
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
ptResult
Points to the variable to be filled from the registry.

Returns

TRUE if the function succeeds, otherwise returns FALSE.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfileRect Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetProfileRect Method

Call this member function to retrieve the value of a CRect from an entry within a specified section of the application's registry or .INI file. Retrieves the CRect value that follows the specified entry if the function is successful.

BOOL GetProfileRect(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    CRect* rcResult
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
rcResult
Points to the variable to be filled from the registry.

Returns

TRUE if the function succeeds, otherwise returns FALSE.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfileSize Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetProfileSize Method

Call this member function to retrieve the value of a CSize from an entry within a specified section of the application's registry or .INI file. Retrieves the CSize value that follows the specified entry if the function is successful.

BOOL GetProfileSize(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    CSize* rcResult
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
rcResult
Points to the variable to be filled from the registry.

Returns

TRUE if the function succeeds, otherwise returns FALSE.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetProfileString Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetProfileString Method

Call this member function to retrieve the string associated with an entry within the specified section in the application's registry or .INI file. The return value is the string from the application's .INI file or 'lpszDefault' if the string cannot be found. The maximum string length supported by the framework is _MAX_PATH. If 'lpszDefault' is NULL, the return value is an empty string.

CString GetProfileString(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    LPCTSTR lpszDefault
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry.
lpszEntry
Points to a null-terminated string that contains the entry whose value is to be retrieved.
lpszDefault
Points to the default string value for the given entry if the entry cannot be found in the initialization file.

Returns

The string associated with an entry within the specified section in the application's registry or .INI file. The return value is the string from the application's .INI file or 'lpszDefault' if the string cannot be found.

Group

CXTRegistryManager Methods


CXTRegistryManager::GetSectionKey Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::GetSectionKey Method

Called to get a handle to the specified section from the applications registry key.

virtual HKEY GetSectionKey(
    LPCTSTR lpszSection,
    REGSAM samDesired = KEY_WRITE | KEY_READ
);
Parameters

lpszSection
Section to get the key for.
samDesired
An access mask that specifies the desired access rights to the key

Returns

An HKEY handle to the specified section from the applications registry key.

Group

CXTRegistryManager Methods


CXTRegistryManager::SetINIFileName Method

CXTRegistryManager Methods, CXTRegistryManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTRegistryManager::SetINIFileName Method

This member function will set the .INI file name for the registry manager to use instead of the system registry.

static void SetINIFileName(
    LPCTSTR strINIFileName
);
Parameters

strINIFileName
Full path to the .INI file.

Body Source
void CXTRegistryManager::SetINIFileName(LPCTSTR strINIFileName) {
    m_strINIFileName = strINIFileName;
}
Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfileBinary Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfileBinary Method

Call this member function to write the specified binary value into the specified section of the application's registry or .INI file.

BOOL WriteProfileBinary(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    LPBYTE pData,
    UINT nBytes
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
pData
Contains the value to be written.
nBytes
Contains the size of the value to be written.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfileColor Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfileColor Method

Call this member function to write the specified COLORREF value into the specified section of the application's registry or .INI file.

BOOL WriteProfileColor(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    COLORREF* pValue
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
pValue
Contains the value to be written.

Note that because COLORREF is a typedef for a DWORD, this function only calls WriteProfileDword.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfileDouble Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfileDouble Method

Call this member function to write the specified double/float value into the specified section of the application's registry or .INI file.

BOOL WriteProfileDouble(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    double* pValue
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
pValue
Contains the value to be written.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfileDword Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfileDword Method

Call this member function to write the specified DWORD value into the specified section of the application's registry or .INI file.

BOOL WriteProfileDword(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    DWORD* pValue
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
pValue
Contains the value to be written.

Note that as COLORREF is a typedef for a DWORD, WriteProfileColor calls this function.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfileInt Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfileInt Method

Call this member function to write the specified INT value into the specified section of the application's registry or .INI file.

BOOL WriteProfileInt(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    int nValue
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
nValue
Contains the value to be written.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfilePoint Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfilePoint Method

Call this member function to write the specified CPoint value into the specified section of the application's registry or .INI file.

BOOL WriteProfilePoint(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    CPoint* pValue
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
pValue
Contains the value to be written.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfileRect Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfileRect Method

Call this member function to write the specified CRect value into the specified section of the application's registry or .INI file.

BOOL WriteProfileRect(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    CRect* pValue
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
pValue
Contains the value to be written.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfileSize Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfileSize Method

Call this member function to write the specified CSize value into the specified section of the application's registry or .INI file.

BOOL WriteProfileSize(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    CSize* pValue
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
pValue
Contains the value to be written.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager::WriteProfileString Method

CXTRegistryManager Methods, CXTRegistryManager Class
CXTRegistryManager::WriteProfileString Method

Call this member function to write the specified string value into the specified section of the application's registry or .INI file.

BOOL WriteProfileString(
    LPCTSTR lpszSection,
    LPCTSTR lpszEntry,
    LPCTSTR lpszValue
);
Parameters

lpszSection
Points to a null-terminated string that specifies the section containing the entry. If the section does not exist, it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, it is created.
lpszValue
Contains the value to be written.

Returns

Nonzero if successful, otherwise returns zero. If the user does not have access rights to modify the system registry will return -1.

Group

CXTRegistryManager Methods


CXTRegistryManager Constructors

CXTRegistryManager Class, Legend, Public Methods
CXTRegistryManager Constructors
Class

CXTRegistryManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTRegistryManager | Constructs a CXTRegistryManager object


CXTRegistryManager::CXTRegistryManager Constructor

CXTRegistryManager Constructors, CXTRegistryManager Class
CXTRegistryManager::CXTRegistryManager Constructor

Constructs a CXTRegistryManager object

CXTRegistryManager(
    HKEY hKeyBase = HKEY_CURRENT_USER
);
Parameters

hKeyBase
Current key to be used in the registry.

Group

CXTRegistryManager Constructors


CXTRegistryManager Destructors

CXTRegistryManager Class, Legend, Public Methods
CXTRegistryManager Destructors
Class

CXTRegistryManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTRegistryManager | Destroys a CXTRegistryManager object, handles cleanup and deallocation


CXTRegistryManager::~CXTRegistryManager Destructor

CXTRegistryManager Destructors, CXTRegistryManager Class
CXTRegistryManager::~CXTRegistryManager Destructor

Destroys a CXTRegistryManager object, handles cleanup and deallocation

virtual ~CXTRegistryManager();
Group

CXTRegistryManager Destructors


CXTResize Class

XTResize.h, Classes, Legend, Members, Topics, CXTResize Data Members, CXTResize Methods, CXTResize Constructors, CXTResize Destructors, CXTResize Nested Types, CXTResize Constructors, CXTResize Data Members, CXTResize Destructors, CXTResize Methods, CXTResize Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResize Class

CXTResize is a base class. It is used by resizing dialogs, property sheets, and form views. It acts as a manager to maintain size and location of the dialog and dialog items.

Class Hierarchy

class CXTResize;
File

XTResize.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTResize Constructors
CXTResize Constructors | Description
CXTResize | Constructs a CXTResize object
CXTResize Data Members
CXTResize Data Members | Description
m_arrItems | array of controls
m_nFlagsXX | flags passed from constructor
m_pWnd | the associative relation to the window to be resized
m_scSizeIcon | size icon window
m_strSection | section in registry where window placement information is saved.
m_szInitWindow | Initial dialog size
m_szMax | largest size allowed
m_szMin | smallest size allowed
m_szWindow | last dialog size
CXTResize Destructors
CXTResize Destructors | Description
~CXTResize | Destroys a CXTResize object, handles cleanup and deallocation
CXTResize Methods
CXTResize Methods | Description
AjustResizeRect | This method called in Size method to adjust window rectangle to fit real client size
AutoLoadPlacement | This member function loads saved window placement information from the registry. This version is the same as LoadPlacement but there is no need for calling SavePlacement when the window is destroyed. This will be called automatically.
Defer | Called by CXTResize to resize a child window.
GetMinMaxInfo | This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size. The maximized size is the size of the window when its borders are fully extended. The maximum tracking size of the window is the largest window size that can be achieved by using the borders to size the window. The minimum tracking size of the window is the smallest window size that can be achieved by using the borders to size the window.
HasFlag | This member function is called to determine if the specified flag has been set for the resize manager.
Init | This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
LoadPlacement | This member function loads saved window placement information from the registry.
Offset | Called to offset dialog items by the amount specified by ptOffset.
RemoveAllControls | This member function is called to purge the list that contains dialog items to be sized.
RemoveResize | This member function is called to remove the specified dialog item from the list of items to be resized.
Reset | This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
SavePlacement | This member function saves the window placement to the registry.
SetFlag | This member function is called to set a specific flag for the resize manager.
SetMaxSize | This member function sets the maximum size. No maximum is the default.
SetMinSize | This member function sets the minimum size explicitly. Initial size is the default.
SetResize |
Size | This member function is called from OnSize to move and resize the dialog items that are managed.
UpdateControlRect | Call this method to reset m_rrcWindow for item.
CXTResize Nested Types
CXTResize Nested Types | Description
CResizeItemArray | Used by CXTResize to maintain a list of children that are sizable.


CXTResize Data Members

CXTResize Class, Legend, Protected Data Members
CXTResize Data Members
Class

CXTResize Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrItems | array of controls
m_nFlagsXX | flags passed from constructor
m_pWnd | the associative relation to the window to be resized
m_scSizeIcon | size icon window
m_strSection | section in registry where window placement information is saved.
m_szInitWindow | Initial dialog size
m_szMax | largest size allowed
m_szMin | smallest size allowed
m_szWindow | last dialog size


CXTResize::m_arrItems Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_arrItems Data Member

array of controls

CResizeItemArray m_arrItems;
Group

CXTResize Data Members


CXTResize::m_nFlagsXX Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_nFlagsXX Data Member

flags passed from constructor

UINT m_nFlagsXX;
Group

CXTResize Data Members


CXTResize::m_pWnd Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_pWnd Data Member

the associative relation to the window to be resized

CWnd* m_pWnd;
Group

CXTResize Data Members


CXTResize::m_scSizeIcon Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_scSizeIcon Data Member

size icon window

CXTSizeIcon m_scSizeIcon;
Group

CXTResize Data Members


CXTResize::m_strSection Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_strSection Data Member

section in registry where window placement information is saved.

CString m_strSection;
Group

CXTResize Data Members


CXTResize::m_szInitWindow Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_szInitWindow Data Member

Initial dialog size

CSize m_szInitWindow;
Group

CXTResize Data Members


CXTResize::m_szMax Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_szMax Data Member

largest size allowed

CSize m_szMax;
Group

CXTResize Data Members


CXTResize::m_szMin Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_szMin Data Member

smallest size allowed

CSize m_szMin;
Group

CXTResize Data Members


CXTResize::m_szWindow Data Member

CXTResize Data Members, CXTResize Class
CXTResize::m_szWindow Data Member

last dialog size

CSize m_szWindow;
Group

CXTResize Data Members


CXTResize Methods

CXTResize Class, Legend, Protected Methods, Public Methods
CXTResize Methods
Class

CXTResize Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AjustResizeRect | This method called in Size method to adjust window rectangle to fit real client size
Defer | Called by CXTResize to resize a child window.
GetMinMaxInfo | This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size. The maximized size is the size of the window when its borders are fully extended. The maximum tracking size of the window is the largest window size that can be achieved by using the borders to size the window. The minimum tracking size of the window is the smallest window size that can be achieved by using the borders to size the window.
HasFlag | This member function is called to determine if the specified flag has been set for the resize manager.
Init | This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
Offset | Called to offset dialog items by the amount specified by ptOffset.
RemoveAllControls | This member function is called to purge the list that contains dialog items to be sized.
RemoveResize | This member function is called to remove the specified dialog item from the list of items to be resized.
Reset | This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
SetFlag | This member function is called to set a specific flag for the resize manager.
SetResize |
Size | This member function is called from OnSize to move and resize the dialog items that are managed.
UpdateControlRect | Call this method to reset m_rrcWindow for item.
Public Methods
Public Methods
Public Method | Description
AutoLoadPlacement | This member function loads saved window placement information from the registry. This version is the same as LoadPlacement but there is no need for calling SavePlacement when the window is destroyed. This will be called automatically.
LoadPlacement | This member function loads saved window placement information from the registry.
SavePlacement | This member function saves the window placement to the registry.
SetMaxSize | This member function sets the maximum size. No maximum is the default.
SetMinSize | This member function sets the minimum size explicitly. Initial size is the default.


CXTResize::AjustResizeRect Method

CXTResize Methods, CXTResize Class
CXTResize::AjustResizeRect Method

This method called in Size method to adjust window rectangle to fit real client size

virtual void AjustResizeRect(
    CSize& rcWindow
);
Parameters

rcWindow
Window rectangle to change

Group

CXTResize Methods


CXTResize::AutoLoadPlacement Method

CXTResize Methods, CXTResize Class
CXTResize::AutoLoadPlacement Method

This member function loads saved window placement information from the registry. This version is the same as LoadPlacement but there is no need for calling SavePlacement when the window is destroyed. This will be called automatically.

BOOL AutoLoadPlacement(
    LPCTSTR pszSection
);
Parameters

pszSection
Name of a section in the initialization file or a key in the Windows registry where placement information is stored.

Returns

TRUE if position was changed

Group

CXTResize Methods


CXTResize::Defer Method

CXTResize Methods, CXTResize Class
CXTResize::Defer Method

Called by CXTResize to resize a child window.

virtual BOOL Defer(
    HDWP& hdwp,
    CXTResizeItem* pItem,
    int dx,
    int dy
);
Parameters

hdwp
[in] Handle to a multiple-window - position structure that contains size and position information for one or more windows. This structure is returned by BeginDeferWindowPos or by the most recent call to DeferWindowPos.
pItem
[in] Pointer to a CXTResizeItem object that contains additional information about the window being sized.
dx
[in] Specifies the window's new width, in pixels.
dy
[in] Specifies the window's new height, in pixels.

Returns

TRUE if successful, otherwise FALSE.

Group

CXTResize Methods


CXTResize::GetMinMaxInfo Method

CXTResize Methods, CXTResize Class
CXTResize::GetMinMaxInfo Method

This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size. The maximized size is the size of the window when its borders are fully extended. The maximum tracking size of the window is the largest window size that can be achieved by using the borders to size the window. The minimum tracking size of the window is the smallest window size that can be achieved by using the borders to size the window.

void GetMinMaxInfo(
    MINMAXINFO* pMMI
);
Parameters

pMMI
Points to a MINMAXINFO structure that contains information about a window's maximized size and position and its minimum and maximum tracking size. For more information about this structure, see the MINMAXINFO structure.

Group

CXTResize Methods


CXTResize::HasFlag Method

CXTResize Methods, CXTResize Class, Body Source
CXTResize::HasFlag Method

This member function is called to determine if the specified flag has been set for the resize manager.

BOOL HasFlag(
    XTResize eFlag
);
Parameters

eFlag
Flag to check, it can be one of the values in the Remarks section.

Returns

TRUE if the specified flag has been set, otherwise returns FALSE.

Remarks

Styles to be added can one of the following:

  • xtResizeNoSizeIcon Do not add size icon.
  • xtResizeNoHorizontal No horizontal resizing.
  • xtResizeNoVertical No vertical resizing.
  • xtResizeNoMinsize Do not require a minimum size.
  • xtResizeNoClipChildren Do not set clip children style.
  • xtResizeNoTransparentGroup Do not set transparent style

for group boxes.

Body Source
BOOL CXTResize::HasFlag(XTResize eFlag) {
    return (m_nFlagsXX & eFlag) != 0;
}
Group

CXTResize Methods


CXTResize::Init Method

CXTResize Methods, CXTResize Class
CXTResize::Init Method

This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.

virtual void Init();
Group

CXTResize Methods


CXTResize::LoadPlacement Method

CXTResize Methods, CXTResize Class
CXTResize::LoadPlacement Method

This member function loads saved window placement information from the registry.

BOOL LoadPlacement(
    LPCTSTR pszSection
);
Parameters

pszSection
Name of a section in the initialization file or a key in the Windows registry where placement information is stored.

Returns

TRUE if position was changed

Group

CXTResize Methods


CXTResize::Offset Method

CXTResize Methods, CXTResize Class
CXTResize::Offset Method

Called to offset dialog items by the amount specified by ptOffset.

void Offset(
    CPoint ptOffset
);
Parameters

ptOffset
CPoint determines the amount in pixesl to offset dialog items.

Group

CXTResize Methods


CXTResize::RemoveAllControls Method

CXTResize Methods, CXTResize Class
CXTResize::RemoveAllControls Method

This member function is called to purge the list that contains dialog items to be sized.

void RemoveAllControls();
Group

CXTResize Methods


CXTResize::RemoveResize Method

CXTResize Methods, CXTResize Class
CXTResize::RemoveResize Method

This member function is called to remove the specified dialog item from the list of items to be resized.

BOOL RemoveResize(
    const UINT nID
);
Parameters

nID
Specifies the control's ID.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTResize Methods


CXTResize::Reset Method

CXTResize Methods, CXTResize Class
CXTResize::Reset Method

This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.

void Reset();
Group

CXTResize Methods


CXTResize::SavePlacement Method

CXTResize Methods, CXTResize Class
CXTResize::SavePlacement Method

This member function saves the window placement to the registry.

BOOL SavePlacement(
    LPCTSTR pszSection
);
Parameters

pszSection
Name of a section in the initialization file or a key in the Windows registry where placement information is stored.

Returns

TRUE if succeeds

Group

CXTResize Methods


CXTResize::SetFlag Method

CXTResize Methods, CXTResize Class
CXTResize::SetFlag Method

This member function is called to set a specific flag for the resize manager.

void SetFlag(
    XTResize eFlag
);
Parameters

eFlag
Flag to check, it can be one of the values in the Remarks section.

Remarks

Styles to be added can one of the following:

  • xtResizeNoSizeIcon Do not add size icon.
  • xtResizeNoHorizontal No horizontal resizing.
  • xtResizeNoVertical No vertical resizing.
  • xtResizeNoMinsize Do not require a minimum size.
  • xtResizeNoClipChildren Do not set clip children style.
  • xtResizeNoTransparentGroup Do not set transparent style for group boxes.
Group

CXTResize Methods


CXTResize::SetMaxSize Method

CXTResize Methods, CXTResize Class, Body Source
CXTResize::SetMaxSize Method

This member function sets the maximum size. No maximum is the default.

void SetMaxSize(
    CSize& sz
);
Parameters

sz
Specifies the maximum width and height the dialog can be sized to.

Body Source
void CXTResize::SetMaxSize(CSize& sz) {
    m_szMax = sz;
}
Group

CXTResize Methods


CXTResize::SetMinSize Method

CXTResize Methods, CXTResize Class, Body Source
CXTResize::SetMinSize Method

This member function sets the minimum size explicitly. Initial size is the default.

void SetMinSize(
    CSize& sz
);
Parameters

sz
Specifies the minimum width and height the dialog can be sized to.

Body Source
void CXTResize::SetMinSize(CSize& sz) {
    m_szMin = sz;
}
Group

CXTResize Methods


SetResize Method

CXTResize Methods
SetResize Method
Overload List
Methods
Method | Description
CXTResize::SetResize (CWnd*, const CXTResizeRect&, CRect) | The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button) then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.
CXTResize::SetResize (const UINT, XT_RESIZE, XT_RESIZE, XT_RESIZE, XT_RESIZE) | The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button) then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.
CXTResize::SetResize (const UINT, const HWND, const XT_RESIZEPOINT&, const XT_RESIZEPOINT&) | The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button) then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.
CXTResize::SetResize (const UINT, const HWND, const XT_RESIZERECT&) | The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button) then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.
CXTResize::SetResize (const UINT, const XT_RESIZEPOINT&, const XT_RESIZEPOINT&) | The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button) then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.
CXTResize::SetResize (const UINT, const XT_RESIZERECT&) | The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button) then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.
Group

CXTResize Methods


CXTResize::SetResize Method (CWnd*, const CXTResizeRect&, CRect)

SetResize Method, CXTResize Class
CXTResize::SetResize Method (CWnd*, const CXTResizeRect&, CRect)

The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button) then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.

void SetResize(
    const UINT nID,
    XT_RESIZE left,
    XT_RESIZE top,
    XT_RESIZE right,
    XT_RESIZE bottom
);
void SetResize(
    const UINT nID,
    const XT_RESIZERECT& rrcSizing
);
void SetResize(
    const UINT nID,
    const HWND hWnd,
    const XT_RESIZERECT& rrcSizing
);
void SetResize(
    const UINT nID,
    const HWND hWnd,
    const XT_RESIZEPOINT& rpTopLeft,
    const XT_RESIZEPOINT& rpBottomRight
);
void SetResize(
    const UINT nID,
    const XT_RESIZEPOINT& rpTopLeft,
    const XT_RESIZEPOINT& rpBottomRight
);
void SetResize(
    CWnd* pWnd,
    const CXTResizeRect& rrcSizing,
    CRect rcWindow
);
Parameters

nID
Specifies the control's ID.
left
How much the left side will move when the dialog is resized.
top
How much the top side will move when the dialog is resized.
right
How much the right side will move when the dialog is resized.
bottom
How much the bottom side will move when the dialog is resized.
rrcSizing
How much the left, top, right, and bottom sides will move when the dialog is resized.
hWnd
HWND of the dialog item to be sized.
rpTopLeft
How much the top and left sides will move when the dialog is resized.
rpBottomRight
How much the bottom and right sides will move when the dialog is resized.
pWnd
Points to the dialog item to be resized.
rcWindow
Initial size of the dialog item.
arr
Array of XT_SIZING structures that specify how much the left, top, right, and bottom sides of the dialog item will move when the dialog is resized.

Group

SetResize Method


CXTResize::Size Method

CXTResize Methods, CXTResize Class
CXTResize::Size Method

This member function is called from OnSize to move and resize the dialog items that are managed.

virtual void Size();
Group

CXTResize Methods


CXTResize::UpdateControlRect Method

CXTResize Methods, CXTResize Class
CXTResize::UpdateControlRect Method

Call this method to reset m_rrcWindow for item.

void UpdateControlRect(
    CWnd* pWnd
);
Parameters

pWnd
Window to reset.

Group

CXTResize Methods


CXTResize Constructors

CXTResize Class, Legend, Public Methods
CXTResize Constructors
Class

CXTResize Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResize | Constructs a CXTResize object


CXTResize::CXTResize Constructor

CXTResize Constructors, CXTResize Class
CXTResize::CXTResize Constructor

Constructs a CXTResize object

CXTResize(
    CWnd* pWnd,
    const UINT nFlags = 0
);
Parameters

pWnd
Points to the parent or owner window object, of type CWnd, to which the resizing object belongs.
nFlags
Flags that are to be passed to CXTResize that specify the attributes of the resizing property page. See Remarks section for a list of flags.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • xtResizeNoSizeIcon Do not add size icon.
  • xtResizeNoHorizontal No horizontal resizing.
  • xtResizeNoVertical No vertical resizing.
  • xtResizeNoMinsize Do not require a minimum size.
  • xtResizeNoClipChildren Do not set clip children style.
  • xtResizeNoTransparentGroup Do not set transparent style for group boxes.
Group

CXTResize Constructors


CXTResize Destructors

CXTResize Class, Legend, Public Methods
CXTResize Destructors
Class

CXTResize Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTResize | Destroys a CXTResize object, handles cleanup and deallocation


CXTResize::~CXTResize Destructor

CXTResize Destructors, CXTResize Class
CXTResize::~CXTResize Destructor

Destroys a CXTResize object, handles cleanup and deallocation

virtual ~CXTResize();
Group

CXTResize Destructors


CXTResize Nested Types

CXTResize Class, Public Nested Types
CXTResize Nested Types
Class

CXTResize Class

Public Nested Types
Public Nested Type | Description
CResizeItemArray | Used by CXTResize to maintain a list of children that are sizable.


CXTResize::CResizeItemArray Nested Type

CXTResize Nested Types, CXTResize Class
CXTResize::CResizeItemArray Nested Type

Used by CXTResize to maintain a list of children that are sizable.

typedef CArray<CXTResizeItem*, CXTResizeItem*&> CResizeItemArray;
Group

CXTResize Nested Types


CXTResizeDialog Class

XTResizeDialog.h, Classes, Legend, Members, Topics, CXTResizeDialog Data Members, CXTResizeDialog Constructors, CXTResizeDialog Constructors, CXTResizeDialog Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizeDialog Class

CXTResizeDialog is a multiple inheritance class derived from CDialog and CXTResize. CXTResizeDialog is used to create a resizable CDialog type object that allows its dialog items to be resized or moved dynamically.

Class Hierarchy

class CXTResizeDialog : public CDialog, public CXTResize;
File

XTResizeDialog.h

Group

Classes

Legend
Data Member
protected
Constructor
CXTResizeDialog Constructors
CXTResizeDialog Constructors | Description
CXTResizeDialog |
CXTResizeDialog Data Members
CXTResizeDialog Data Members | Description
m_nDialogID | Contains the ID number of a dialog box template resource


CXTResizeDialog Data Members

CXTResizeDialog Class, Legend, Protected Data Members
CXTResizeDialog Data Members
Class

CXTResizeDialog Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nDialogID | Contains the ID number of a dialog box template resource


CXTResizeDialog::m_nDialogID Data Member

CXTResizeDialog Data Members, CXTResizeDialog Class
CXTResizeDialog::m_nDialogID Data Member

Contains the ID number of a dialog box template resource

UINT m_nDialogID;
Group

CXTResizeDialog Data Members


CXTResizeDialog Constructors

CXTResizeDialog Class, Legend, Public Methods
CXTResizeDialog Constructors
Class

CXTResizeDialog Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeDialog |


CXTResizeDialog Constructor

CXTResizeDialog Constructors
CXTResizeDialog Constructor
Overload List
Constructors
Constructor | Description
CXTResizeDialog::CXTResizeDialog () | Constructs a CXTResizeDialog object
CXTResizeDialog::CXTResizeDialog (LPCTSTR, CWnd*, const UINT) | Constructs a CXTResizeDialog object
CXTResizeDialog::CXTResizeDialog (const UINT, CWnd*, const UINT) | Constructs a CXTResizeDialog object
Group

CXTResizeDialog Constructors


CXTResizeDialog::CXTResizeDialog Constructor ()

CXTResizeDialog Constructor, CXTResizeDialog Class
CXTResizeDialog::CXTResizeDialog Constructor ()

Constructs a CXTResizeDialog object

CXTResizeDialog();
CXTResizeDialog(
    const UINT nID,
    CWnd* pParent = 0,
    const UINT nFlags = 0
);
CXTResizeDialog(
    LPCTSTR lpszTemplateName,
    CWnd* pParent = 0,
    const UINT nFlags = 0
);
Parameters

nID
Contains the ID number of a dialog box template resource.
pParent
Points to the parent or owner window object of type CWnd, which the dialog object belongs to. If it is NULL, the dialog object's parent window is set to the main application window.
nFlags
Flags that are to be passed to CXTResize that specify the attributes of the resizing property page. They can be one or more of the values listed in the Remarks section.
lpszTemplateName
Contains a null-terminated string that is the name of a dialog-box template resource.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • xtResizeNoSizeIcon Do not add size icon.
  • xtResizeNoHorizontal No horizontal resizing.
  • xtResizeNoVertical No vertical resizing.
  • xtResizeNoMinsize Do not require a minimum size.
  • xtResizeNoClipChildren Do not set clip children style.
  • xtResizeNoTransparentGroup Do not set transparent style for group boxes.
Group

CXTResizeDialog Constructor


CXTResizeFormView Class

XTResizeFormView.h, Classes, Legend, Members, Topics, CXTResizeFormView Methods, CXTResizeFormView Constructors, CXTResizeFormView Constructors, CXTResizeFormView Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizeFormView Class

CXTResizeFormView is a multiple inheritance class derived from CFormView and CXTResize. CXTResizeFormView is used to create a resizable CFormView type object that allows its form items to be resized or moved dynamically.

Class Hierarchy

class CXTResizeFormView : public CFormView, public CXTResize;
File

XTResizeFormView.h

Group

Classes

Legend
Method
protected
virtual
CXTResizeFormView Constructors
CXTResizeFormView Constructors | Description
CXTResizeFormView | Constructs a CXTResizeFormView object
CXTResizeFormView Methods
CXTResizeFormView Methods | Description
AjustResizeRect | This method called in Size method to adjust window rectangle to fit real client size


CXTResizeFormView Methods

CXTResizeFormView Class, Legend, Protected Methods
CXTResizeFormView Methods
Class

CXTResizeFormView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AjustResizeRect | This method called in Size method to adjust window rectangle to fit real client size


CXTResizeFormView::AjustResizeRect Method

CXTResizeFormView Methods, CXTResizeFormView Class
CXTResizeFormView::AjustResizeRect Method

This method called in Size method to adjust window rectangle to fit real client size

virtual void AjustResizeRect(
    CSize& rcWindow
);
Parameters

rcWindow
Window rectangle to change

Group

CXTResizeFormView Methods


CXTResizeFormView Constructors

CXTResizeFormView Class, Legend, Public Methods
CXTResizeFormView Constructors
Class

CXTResizeFormView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeFormView | Constructs a CXTResizeFormView object


CXTResizeFormView::CXTResizeFormView Constructor

CXTResizeFormView Constructors, CXTResizeFormView Class
CXTResizeFormView::CXTResizeFormView Constructor

Constructs a CXTResizeFormView object

CXTResizeFormView(
    const UINT nID = 0,
    const UINT nFlags = 0
);
Parameters

nID
Contains the ID number of a dialog template resource.
nFlags
Flags that are to be passed to CXTResize that specify the attributes of the resizing property page. They can be one or more of the values in the Remarks section:

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • xtResizeNoSizeIcon Do not add size icon.
  • xtResizeNoHorizontal No horizontal resizing.
  • xtResizeNoVertical No vertical resizing.
  • xtResizeNoMinsize Do not require a minimum size.
  • xtResizeNoClipChildren Do not set clip children style.
  • xtResizeNoTransparentGroup Do not set transparent style for group boxes.
Group

CXTResizeFormView Constructors


CXTResizeGroupBox Class

XTResizeGroupBox.h, Classes, Legend, Members, Topics, CXTResizeGroupBox Methods, CXTResizeGroupBox Constructors, CXTResizeGroupBox Destructors, CXTResizeGroupBox Constructors, CXTResizeGroupBox Destructors, CXTResizeGroupBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizeGroupBox Class

CXTResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing. This class is intended to only be used as a group box and only used on a CXTResize window. You can subclass or create this object the way you would any CButton.

Class Hierarchy

class CXTResizeGroupBox : public CButton;
File

XTResizeGroupBox.h

Notes

Do not use the transparent flag with this control, and make sure you call SetFlag(xtResizeNoTransparentGroup); to disable the resize manager from setting this for you.

Group

Classes

Legend
Method
protected
virtual
CXTResizeGroupBox Constructors
CXTResizeGroupBox Constructors | Description
CXTResizeGroupBox | Constructs a CXTResizeGroupBox object
CXTResizeGroupBox Destructors
CXTResizeGroupBox Destructors | Description
~CXTResizeGroupBox | Destroys a CXTResizeGroupBox object, handles cleanup and deallocation
CXTResizeGroupBox Methods
CXTResizeGroupBox Methods | Description
Exclude | Called during paint operations to exclude the control windows that are grouped by this control.


CXTResizeGroupBox Methods

CXTResizeGroupBox Class, Legend, Protected Methods
CXTResizeGroupBox Methods
Class

CXTResizeGroupBox Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Exclude | Called during paint operations to exclude the control windows that are grouped by this control.


CXTResizeGroupBox::Exclude Method

CXTResizeGroupBox Methods, CXTResizeGroupBox Class
CXTResizeGroupBox::Exclude Method

Called during paint operations to exclude the control windows that are grouped by this control.

virtual void Exclude(
    CDC* pDC,
    CRect& rcClient
);
Parameters

pDC
Pointer to device context.
rcClient
Client area of group box.

Group

CXTResizeGroupBox Methods


CXTResizeGroupBox Constructors

CXTResizeGroupBox Class, Legend, Public Methods
CXTResizeGroupBox Constructors
Class

CXTResizeGroupBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeGroupBox | Constructs a CXTResizeGroupBox object


CXTResizeGroupBox::CXTResizeGroupBox Constructor

CXTResizeGroupBox Constructors, CXTResizeGroupBox Class
CXTResizeGroupBox::CXTResizeGroupBox Constructor

Constructs a CXTResizeGroupBox object

CXTResizeGroupBox();
Group

CXTResizeGroupBox Constructors


CXTResizeGroupBox Destructors

CXTResizeGroupBox Class, Legend, Public Methods
CXTResizeGroupBox Destructors
Class

CXTResizeGroupBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTResizeGroupBox | Destroys a CXTResizeGroupBox object, handles cleanup and deallocation


CXTResizeGroupBox::~CXTResizeGroupBox Destructor

CXTResizeGroupBox Destructors, CXTResizeGroupBox Class
CXTResizeGroupBox::~CXTResizeGroupBox Destructor

Destroys a CXTResizeGroupBox object, handles cleanup and deallocation

virtual ~CXTResizeGroupBox();
Group

CXTResizeGroupBox Destructors


CXTResizeItem Class

XTResize.h, Classes, Legend, Members, Topics, CXTResizeItem Data Members, CXTResizeItem Methods, CXTResizeItem Constructors, CXTResizeItem Destructors, CXTResizeItem Constructors, CXTResizeItem Data Members, CXTResizeItem Destructors, CXTResizeItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizeItem Class

CXTResizeItem is a stand alone helper class. It is used by CXTResize to maintain information about each item to be sized or moved.

Class Hierarchy

class CXTResizeItem;
File

XTResize.h

Group

Classes

Legend
Data Member
Method
virtual
CXTResizeItem Constructors
CXTResizeItem Constructors | Description
CXTResizeItem | Constructs a CXTResizeItem object
CXTResizeItem Data Members
CXTResizeItem Data Members | Description
m_bAutoDelete | TRUE if the window is to be deleted.
m_bInitialSize | Initial size/move has been completed.
m_bIsGroupBox | TRUE if the window is a group box.
m_pWnd | A pointer to the window to be sized or moved.
m_rrcInitWindow | Initial control size.
m_rrcSizing | Sizing option.
m_rrcWindow | Last control size.
CXTResizeItem Destructors
CXTResizeItem Destructors | Description
~CXTResizeItem | Destroys a CXTResizeItem object, handles cleanup and deallocation
CXTResizeItem Methods
CXTResizeItem Methods | Description
MakeTransparent | Called by CXTResize to make group box controls window style transparent.


CXTResizeItem Data Members

CXTResizeItem Class, Legend, Public Data Members
CXTResizeItem Data Members
Class

CXTResizeItem Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bAutoDelete | TRUE if the window is to be deleted.
m_bInitialSize | Initial size/move has been completed.
m_bIsGroupBox | TRUE if the window is a group box.
m_pWnd | A pointer to the window to be sized or moved.
m_rrcInitWindow | Initial control size.
m_rrcSizing | Sizing option.
m_rrcWindow | Last control size.


CXTResizeItem::m_bAutoDelete Data Member

CXTResizeItem Data Members, CXTResizeItem Class
CXTResizeItem::m_bAutoDelete Data Member

TRUE if the window is to be deleted.

BOOL m_bAutoDelete;
Group

CXTResizeItem Data Members


CXTResizeItem::m_bInitialSize Data Member

CXTResizeItem Data Members, CXTResizeItem Class
CXTResizeItem::m_bInitialSize Data Member

Initial size/move has been completed.

BOOL m_bInitialSize;
Group

CXTResizeItem Data Members


CXTResizeItem::m_bIsGroupBox Data Member

CXTResizeItem Data Members, CXTResizeItem Class
CXTResizeItem::m_bIsGroupBox Data Member

TRUE if the window is a group box.

BOOL m_bIsGroupBox;
Group

CXTResizeItem Data Members


CXTResizeItem::m_pWnd Data Member

CXTResizeItem Data Members, CXTResizeItem Class
CXTResizeItem::m_pWnd Data Member

A pointer to the window to be sized or moved.

CWnd* m_pWnd;
Group

CXTResizeItem Data Members


CXTResizeItem::m_rrcInitWindow Data Member

CXTResizeItem Data Members, CXTResizeItem Class
CXTResizeItem::m_rrcInitWindow Data Member

Initial control size.

CXTResizeRect m_rrcInitWindow;
Group

CXTResizeItem Data Members


CXTResizeItem::m_rrcSizing Data Member

CXTResizeItem Data Members, CXTResizeItem Class
CXTResizeItem::m_rrcSizing Data Member

Sizing option.

CXTResizeRect m_rrcSizing;
Group

CXTResizeItem Data Members


CXTResizeItem::m_rrcWindow Data Member

CXTResizeItem Data Members, CXTResizeItem Class
CXTResizeItem::m_rrcWindow Data Member

Last control size.

CXTResizeRect m_rrcWindow;
Group

CXTResizeItem Data Members


CXTResizeItem Methods

CXTResizeItem Class, Legend, Public Methods
CXTResizeItem Methods
Class

CXTResizeItem Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
MakeTransparent | Called by CXTResize to make group box controls window style transparent.


CXTResizeItem::MakeTransparent Method

CXTResizeItem Methods, CXTResizeItem Class
CXTResizeItem::MakeTransparent Method

Called by CXTResize to make group box controls window style transparent.

virtual bool MakeTransparent(
    CXTResize* pXTResize
);
Parameters

pXTResize
Points the resize manager.

Returns

True if the WS_EX_TRANSPARENT style was set for the window, otherwise false.

Group

CXTResizeItem Methods


CXTResizeItem Constructors

CXTResizeItem Class, Legend, Public Methods
CXTResizeItem Constructors
Class

CXTResizeItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeItem | Constructs a CXTResizeItem object


CXTResizeItem::CXTResizeItem Constructor

CXTResizeItem Constructors, CXTResizeItem Class
CXTResizeItem::CXTResizeItem Constructor

Constructs a CXTResizeItem object

CXTResizeItem(
    CWnd* pWnd,
    const CXTResizeRect& rrcSizing,
    CRect& rcWindow,
    BOOL bAutoDelete
);
Parameters

pWnd
Pointer to the window to be sized or moved.
rrcSizing
Reference to a CXTResizeRect object.
rcWindow
Reference to a CRect object.
bAutoDelete
TRUE if the window is to be deleted.

Group

CXTResizeItem Constructors


CXTResizeItem Destructors

CXTResizeItem Class, Legend, Public Methods
CXTResizeItem Destructors
Class

CXTResizeItem Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTResizeItem | Destroys a CXTResizeItem object, handles cleanup and deallocation


CXTResizeItem::~CXTResizeItem Destructor

CXTResizeItem Destructors, CXTResizeItem Class
CXTResizeItem::~CXTResizeItem Destructor

Destroys a CXTResizeItem object, handles cleanup and deallocation

virtual ~CXTResizeItem();
Group

CXTResizeItem Destructors


CXTResizePoint Class

XTResizePoint.h, Classes, Legend, Members, Topics, CXTResizePoint Constructors, CXTResizePoint Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizePoint Class

CXTResizePoint is an XT_RESIZEPOINT structure derived class. The CXTResizePoint class is similar to the XT_RESIZEPOINT structure. It also includes member functions to manipulate CXTResizePoint and XT_RESIZEPOINT structures. A CXTResizePoint object can be used wherever an XT_RESIZEPOINT structure is used.

Class Hierarchy

class CXTResizePoint : public XT_RESIZEPOINT;
File

XTResizePoint.h

Group

Classes

Legend
Constructor
CXTResizePoint Constructors
CXTResizePoint Constructors | Description
CXTResizePoint |


CXTResizePoint Constructors

CXTResizePoint Class, Legend, Public Methods
CXTResizePoint Constructors
Class

CXTResizePoint Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResizePoint |


CXTResizePoint Constructor

CXTResizePoint Constructors
CXTResizePoint Constructor
Overload List
Constructors
Constructor | Description
CXTResizePoint::CXTResizePoint () | Constructs a CXTResizePoint object
CXTResizePoint::CXTResizePoint (XT_RESIZE, XT_RESIZE) | Constructs a CXTResizePoint object
Group

CXTResizePoint Constructors


CXTResizePoint::CXTResizePoint Constructor ()

CXTResizePoint Constructor, CXTResizePoint Class
CXTResizePoint::CXTResizePoint Constructor ()

Constructs a CXTResizePoint object

CXTResizePoint();
CXTResizePoint(
    XT_RESIZE cx,
    XT_RESIZE cy
);
Parameters

cx
Specifies the x-coordinate of a point.
cy
Specifies the y-coordinate of a point.

Group

CXTResizePoint Constructor


CXTResizePropertyPage Class

XTResizePropertyPage.h, Classes, Legend, Members, Topics, CXTResizePropertyPage Data Members, CXTResizePropertyPage Constructors, CXTResizePropertyPage Constructors, CXTResizePropertyPage Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizePropertyPage Class

CXTResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTResize. CXTResizePropertyPage is used to create a resizable CPropertyPage type object that allows its dialog items to be resized or moved dynamically.

Class Hierarchy

class CXTResizePropertyPage : public CPropertyPage, public CXTResize;
File

XTResizePropertyPage.h

Group

Classes

Legend
Data Member
Constructor
CXTResizePropertyPage Constructors
CXTResizePropertyPage Constructors | Description
CXTResizePropertyPage | Constructs a CXTResizePropertyPage object
CXTResizePropertyPage Data Members
CXTResizePropertyPage Data Members | Description
m_nDialogID | ID of the template used for this page


CXTResizePropertyPage Data Members

CXTResizePropertyPage Class, Legend, Public Data Members
CXTResizePropertyPage Data Members
Class

CXTResizePropertyPage Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_nDialogID | ID of the template used for this page


CXTResizePropertyPage::m_nDialogID Data Member

CXTResizePropertyPage Data Members, CXTResizePropertyPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizePropertyPage::m_nDialogID Data Member

ID of the template used for this page

DWORD m_nDialogID;
Group

CXTResizePropertyPage Data Members


CXTResizePropertyPage Constructors

CXTResizePropertyPage Class, Legend, Public Methods
CXTResizePropertyPage Constructors
Class

CXTResizePropertyPage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResizePropertyPage | Constructs a CXTResizePropertyPage object


CXTResizePropertyPage::CXTResizePropertyPage Constructor

CXTResizePropertyPage Constructors, CXTResizePropertyPage Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizePropertyPage::CXTResizePropertyPage Constructor

Constructs a CXTResizePropertyPage object

CXTResizePropertyPage(
    const UINT nTemplate = 0,
    const UINT nCaption = 0,
    const UINT nFlags = 0
);
Parameters

nTemplate
ID of the template used for this page.
nCaption
ID of the name to be placed in the tab for this page. If 0, the name will be taken from the dialog template for this page.
nFlags
Flags that are to be passed to CXTResize that specify the attributes of the resizing property page. They can be one or more of the values in the Remarks section.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • xtResizeNoSizeIcon Do not add size icon.
  • xtResizeNoHorizontal No horizontal resizing.
  • xtResizeNoVertical No vertical resizing.
  • xtResizeNoMinsize Do not require a minimum size.
  • xtResizeNoClipChildren Do not set clip children style.
  • xtResizeNoTransparentGroup Do not set transparent style for group boxes.
Group

CXTResizePropertyPage Constructors


CXTResizePropertySheet Class

XTResizePropertySheet.h, Classes, Legend, Members, Topics, CXTResizePropertySheet Data Members, CXTResizePropertySheet Methods, CXTResizePropertySheet Constructors, CXTResizePropertySheet Constructors, CXTResizePropertySheet Data Members, CXTResizePropertySheet Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizePropertySheet Class

CXTResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTResize. CXTResizePropertySheet is used to create a resizable CPropertySheet type object that allows its dialog items to be resized or moved dynamically.

Class Hierarchy

class CXTResizePropertySheet : public CPropertySheet, public CXTResize;
File

XTResizePropertySheet.h

Group

Classes

Legend
Data Member
Method
protected
CXTResizePropertySheet Constructors
CXTResizePropertySheet Constructors | Description
CXTResizePropertySheet |
CXTResizePropertySheet Data Members
CXTResizePropertySheet Data Members | Description
m_tabCtrl | Tab control.
CXTResizePropertySheet Methods
CXTResizePropertySheet Methods | Description
IsWizard | This member function determines if the property sheet is in wizard mode.


CXTResizePropertySheet Data Members

CXTResizePropertySheet Class, Legend, Public Data Members
CXTResizePropertySheet Data Members
Class

CXTResizePropertySheet Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_tabCtrl | Tab control.


CXTResizePropertySheet::m_tabCtrl Data Member

CXTResizePropertySheet Data Members, CXTResizePropertySheet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizePropertySheet::m_tabCtrl Data Member

Tab control.

CXTPNoFlickerWnd<CTabCtrl> m_tabCtrl;
Group

CXTResizePropertySheet Data Members


CXTResizePropertySheet Methods

CXTResizePropertySheet Class, Legend, Protected Methods
CXTResizePropertySheet Methods
Class

CXTResizePropertySheet Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
IsWizard | This member function determines if the property sheet is in wizard mode.


CXTResizePropertySheet::IsWizard Method

CXTResizePropertySheet Methods, CXTResizePropertySheet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizePropertySheet::IsWizard Method

This member function determines if the property sheet is in wizard mode.

BOOL IsWizard();
Returns

TRUE if the property sheet is a wizard, otherwise returns FALSE.

Body Source
BOOL CXTResizePropertySheet::IsWizard() {
    return ((m_psh.dwFlags & (PSH_WIZARD | PSH_WIZARD97 | PSH_WIZARD_LITE)) != 0);
}
Group

CXTResizePropertySheet Methods


CXTResizePropertySheet Constructors

CXTResizePropertySheet Class, Legend, Public Methods
CXTResizePropertySheet Constructors
Class

CXTResizePropertySheet Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResizePropertySheet |


CXTResizePropertySheet Constructor

CXTResizePropertySheet Constructors
CXTResizePropertySheet Constructor
Overload List
Constructors
Constructor | Description
CXTResizePropertySheet::CXTResizePropertySheet () | Constructs a CXTResizePropertySheet object
CXTResizePropertySheet::CXTResizePropertySheet (LPCTSTR, CWnd*, const UINT, const UINT) | Constructs a CXTResizePropertySheet object
CXTResizePropertySheet::CXTResizePropertySheet (const UINT, CWnd*, const UINT, const UINT) | Constructs a CXTResizePropertySheet object
Group

CXTResizePropertySheet Constructors


CXTResizePropertySheet::CXTResizePropertySheet Constructor ()

CXTResizePropertySheet Constructor, CXTResizePropertySheet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizePropertySheet::CXTResizePropertySheet Constructor ()

Constructs a CXTResizePropertySheet object

CXTResizePropertySheet();
CXTResizePropertySheet(
    const UINT nCaption,
    CWnd* pParent = 0,
    const UINT nSelectPage = 0,
    const UINT nFlags = 0
);
CXTResizePropertySheet(
    LPCTSTR pszCaption,
    CWnd* pParent = 0,
    const UINT nSelectPage = 0,
    const UINT nFlags = 0
);
Parameters

nCaption
ID of the caption to be used for the property sheet.
pParent
Points to the parent window of the property sheet. If NULL, the parent window will be the main window of the application.
nSelectPage
The index of the page that will initially be on top. Default is the first page added to the sheet.
nFlags
Flags that are to be passed to CXTResize that specify the attributes of the resizing property page. They can be one or more of the values in the Remarks section.
pszCaption
Points to a string containing the caption to be used for the property sheet. It cannot be NULL.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • xtResizeNoSizeIcon Do not add size icon.
  • xtResizeNoHorizontal No horizontal resizing.
  • xtResizeNoVertical No vertical resizing.
  • xtResizeNoMinsize Do not require a minimum size.
  • xtResizeNoClipChildren Do not set clip children style.
  • xtResizeNoTransparentGroup Do not set transparent style for group boxes.
Group

CXTResizePropertySheet Constructor


CXTResizeRect Class

XTResizeRect.h, Classes, Legend, Members, Topics, CXTResizeRect Methods, CXTResizeRect Constructors, CXTResizeRect Operators, CXTResizeRect Constructors, CXTResizeRect Methods, CXTResizeRect Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTResizeRect Class

CXTResizeRect is an XT_RESIZERECT structure derived class. The CXTResizeRect class is similar to an XT_RESIZERECT structure. CXTResizeRect also includes member functions to manipulate CXTResizeRect objects and XT_RESIZERECT structures.

Class Hierarchy

class CXTResizeRect : public XT_RESIZERECT;
File

XTResizeRect.h

See Also

XT_RESIZERECT, CXTResizePoint, XT_RESIZEPOINT, XT_RESIZE

Group

Classes

Legend
Method
Operator
CXTResizeRect Constructors
CXTResizeRect Constructors | Description
CXTResizeRect |
CXTResizeRect Methods
CXTResizeRect Methods | Description
Height | This member function calculates the height of a CXTResizeRect by subtracting the top value from the bottom value. The resulting value can be negative.
IsNormalized | This member function determines if CXTResizeRect is normalized.
Width | This member function calculates the width of a CXTResizeRect by subtracting the left value from the right value. The resulting value can be negative.
CXTResizeRect Operators
CXTResizeRect Operators | Description
!= | This operator determines whether CXTResizeRect is not equal to a rectangle.
& | This operator creates the intersection of CXTResizeRect and a rectangle, and returns the resulting CXTResizeRect.
+ | This operator adds the given offsets to CRect or inflates CRect.
+= | This operator adds the specified offsets to CXTResizeRect or inflates CXTResizeRect.
= |
== | This operator determines whether CXTResizeRect is equal to a rectangle.
CRect | This operator converts a CXTResizeRect to a CRect. When you use this function, you do not need the address-of (&) operator. This operator will be automatically used when you pass a CXTResizeRect object to a function that expects a CRect.


CXTResizeRect Methods

CXTResizeRect Class, Legend, Public Methods
CXTResizeRect Methods
Class

CXTResizeRect Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Height | This member function calculates the height of a CXTResizeRect by subtracting the top value from the bottom value. The resulting value can be negative.
IsNormalized | This member function determines if CXTResizeRect is normalized.
Width | This member function calculates the width of a CXTResizeRect by subtracting the left value from the right value. The resulting value can be negative.


CXTResizeRect::Height Method

CXTResizeRect Methods, CXTResizeRect Class, Body Source
CXTResizeRect::Height Method

This member function calculates the height of a CXTResizeRect by subtracting the top value from the bottom value. The resulting value can be negative.

XT_RESIZE Height();
Returns

The height of a CXTResizeRect.

Body Source
XT_RESIZE CXTResizeRect::Height() {
    return bottom - top;
}
Group

CXTResizeRect Methods


CXTResizeRect::IsNormalized Method

CXTResizeRect Methods, CXTResizeRect Class, Body Source
CXTResizeRect::IsNormalized Method

This member function determines if CXTResizeRect is normalized.

bool IsNormalized();
Returns

true if normalized, otherwise returns false.

Body Source
bool CXTResizeRect::IsNormalized() {
    return ((left <= right) && (top <= bottom));
}
Group

CXTResizeRect Methods


CXTResizeRect::Width Method

CXTResizeRect Methods, CXTResizeRect Class, Body Source
CXTResizeRect::Width Method

This member function calculates the width of a CXTResizeRect by subtracting the left value from the right value. The resulting value can be negative.

XT_RESIZE Width();
Returns

The width of a CXTResizeRect.

Body Source
XT_RESIZE CXTResizeRect::Width() {
    return right - left;
}
Group

CXTResizeRect Methods


CXTResizeRect Constructors

CXTResizeRect Class, Legend, Public Methods
CXTResizeRect Constructors
Class

CXTResizeRect Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeRect |


CXTResizeRect Constructor

CXTResizeRect Constructors
CXTResizeRect Constructor
Overload List
Constructors
Constructor | Description
CXTResizeRect::CXTResizeRect () | Constructs a CXTResizeRect object
CXTResizeRect::CXTResizeRect (XT_RESIZE, XT_RESIZE, XT_RESIZE, XT_RESIZE) | Constructs a CXTResizeRect object
CXTResizeRect::CXTResizeRect (const RECT&) | Constructs a CXTResizeRect object
CXTResizeRect::CXTResizeRect (const XT_RESIZERECT&) | Constructs a CXTResizeRect object
Group

CXTResizeRect Constructors


CXTResizeRect::CXTResizeRect Constructor ()

CXTResizeRect Constructor, CXTResizeRect Class
CXTResizeRect::CXTResizeRect Constructor ()

Constructs a CXTResizeRect object

CXTResizeRect();
CXTResizeRect(
    const RECT& rc
);
CXTResizeRect(
    const XT_RESIZERECT& rrc
);
CXTResizeRect(
    XT_RESIZE l,
    XT_RESIZE t,
    XT_RESIZE r,
    XT_RESIZE b
);
Parameters

rc
Refers to the RECT structure with the coordinates for CXTResizeRect.
rrc
Refers to the XT_RESIZERECT structure with the coordinates for CXTResizeRect.
l
Specifies the left position of CXTResizeRect.
t
Specifies the top of CXTResizeRect.
r
Specifies the right position of CXTResizeRect.
b
Specifies the bottom of CXTResizeRect.

Group

CXTResizeRect Constructor


CXTResizeRect Operators

CXTResizeRect Class, Legend, Public Operators
CXTResizeRect Operators
Class

CXTResizeRect Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
!= | This operator determines whether CXTResizeRect is not equal to a rectangle.
& | This operator creates the intersection of CXTResizeRect and a rectangle, and returns the resulting CXTResizeRect.
+ | This operator adds the given offsets to CRect or inflates CRect.
+= | This operator adds the specified offsets to CXTResizeRect or inflates CXTResizeRect.
= |
== | This operator determines whether CXTResizeRect is equal to a rectangle.
CRect | This operator converts a CXTResizeRect to a CRect. When you use this function, you do not need the address-of (&) operator. This operator will be automatically used when you pass a CXTResizeRect object to a function that expects a CRect.


CXTResizeRect::!= Operator

CXTResizeRect Operators, CXTResizeRect Class, Body Source
CXTResizeRect::!= Operator

This operator determines whether CXTResizeRect is not equal to a rectangle.

bool operator !=(
    const XT_RESIZERECT& rrc
);
Parameters

rrc
Refers to a source rectangle. It can be an XT_RESIZERECT or a CXTResizeRect.

Returns

false if equal, otherwise returns true.

Body Source
bool CXTResizeRect::operator!= (const XT_RESIZERECT& rrc) {
    return !operator==(rrc);
}
Group

CXTResizeRect Operators


CXTResizeRect::& Operator

CXTResizeRect Operators, CXTResizeRect Class
CXTResizeRect::& Operator

This operator creates the intersection of CXTResizeRect and a rectangle, and returns the resulting CXTResizeRect.

CXTResizeRect operator &(
    const XT_RESIZERECT& rrc
);
Parameters

rrc
Contains an XT_RESIZERECT or a CXTResizeRect.

Returns

A CXTResizeRect that is the intersection of CXTResizeRect and 'rrc'. The intersection is the largest rectangle that is contained in both rectangles.

Group

CXTResizeRect Operators


CXTResizeRect::+ Operator

CXTResizeRect Operators, CXTResizeRect Class, Body Source
CXTResizeRect::+ Operator

This operator adds the given offsets to CRect or inflates CRect.

CXTResizeRect operator +(
    const XT_RESIZERECT& rrc
);
Parameters

rrc
Points to an XT_RESIZERECT structure or a CXTResizeRect object that contains the number of units to inflate each side of the return value.

Returns

The resulting CXTResizeRect object.

Body Source
CXTResizeRect CXTResizeRect::operator+(const XT_RESIZERECT& rrc) {
    return CXTResizeRect(left + rrc.left, top + rrc.top, right + rrc.right, bottom + rrc.bottom);
}
Group

CXTResizeRect Operators


CXTResizeRect::+= Operator

CXTResizeRect Operators, CXTResizeRect Class
CXTResizeRect::+= Operator

This operator adds the specified offsets to CXTResizeRect or inflates CXTResizeRect.

CXTResizeRect& operator +=(
    const XT_RESIZERECT& rrc
);
Parameters

rrc
Points to an XT_RESIZERECT structure or a CXTResizeRect object that contains the number of units to inflate each side of CXTResizeRect.

Returns

A reference to a CXTResizeRect object.

Group

CXTResizeRect Operators


= Operator

CXTResizeRect Operators
= Operator
Overload List
Operators
Operator | Description
CXTResizeRect::= (const RECT&) | This operator copies the dimensions of a rectangle to CXTResizeRect.
CXTResizeRect::= (const XT_RESIZERECT&) | This operator copies the dimensions of a rectangle to CXTResizeRect.
Group

CXTResizeRect Operators


CXTResizeRect::= Operator (const RECT&)

= Operator, CXTResizeRect Class
CXTResizeRect::= Operator (const RECT&)

This operator copies the dimensions of a rectangle to CXTResizeRect.

CXTResizeRect& operator =(
    const RECT& rc
);
Parameters

rc
Refers to a source rectangle. It can be a RECT or CRect.

Returns

A reference to a CXTResizeRect object.

Group

= Operator


CXTResizeRect::= Operator (const XT_RESIZERECT&)

= Operator, CXTResizeRect Class
CXTResizeRect::= Operator (const XT_RESIZERECT&)

This operator copies the dimensions of a rectangle to CXTResizeRect.

CXTResizeRect& operator =(
    const XT_RESIZERECT& rrc
);
Parameters

rrc
Refers to a source rectangle. It can be a XT_RESIZERECT or CXTResizeRect.

Returns

A reference to a CXTResizeRect object.

Group

= Operator


CXTResizeRect::== Operator

CXTResizeRect Operators, CXTResizeRect Class, Body Source
CXTResizeRect::== Operator

This operator determines whether CXTResizeRect is equal to a rectangle.

bool operator ==(
    const XT_RESIZERECT& rrc
);
Parameters

rrc
Refers to a source rectangle. It can be an XT_RESIZERECT or a CXTResizeRect.

Returns

true if equal, otherwise returns false.

Body Source
bool CXTResizeRect::operator==(const XT_RESIZERECT& rrc) {
    return left == rrc.left && top == rrc.top && right == rrc.right && bottom == rrc.bottom;
}
Group

CXTResizeRect Operators


CXTResizeRect::CRect Operator

CXTResizeRect Operators, CXTResizeRect Class, Body Source
CXTResizeRect::CRect Operator

This operator converts a CXTResizeRect to a CRect. When you use this function, you do not need the address-of (&) operator. This operator will be automatically used when you pass a CXTResizeRect object to a function that expects a CRect.

operator CRect();
Body Source
CXTResizeRect::operator CRect() {
    return CRect((int)left, (int)top, (int)right, (int)bottom);
}
Group

CXTResizeRect Operators


CXTSearchOptionsCtrl Class

XTSearchOptionsCtrl.h, Classes, Legend, Members, Topics, CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Constructors, CXTSearchOptionsCtrl Destructors, CXTSearchOptionsCtrl Constructors, CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Destructors, Example, CXTSearchOptionsCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl Class

CXTSearchOptionsCtrl is a CStatic derived class. CXTSearchOptionsCtrl is used to create a control similar to the Search Options item found in the search pane of Windows Explorer as it is seen in Windows 2000 and later. This class allows you to associate a group of controls to be hidden or shown when the item is expanded and contracted and a set of controls that need to move depending on the CXTSearchOptionsCtrl state.

Use with CXTSearchOptionsView form view class to create a pane similar to the Windows Explorer search pane. To use the control, define a set of controls that are to be hidden and moved depending on the CXTSearchOptionsCtrl state.

Class Hierarchy

class CXTSearchOptionsCtrl : public CStatic;
File

XTSearchOptionsCtrl.h

Example

The following example demonstrates how to use CXTSearchOptionsCtrl.

void CExpandTestView::OnInitialUpdate()
{
    CXTSearchOptionsView::OnInitialUpdate();

    m_expand.AddControl(&m_check1);
    m_expand.AddControl(&m_check2);
    m_expand.AddControl(&m_edit1);
    m_expand.AddControl(&m_edit2);

    m_expand.MoveControl(&m_button1);
    m_expand.MoveControl(&m_button2);
    m_expand.MoveControl(&m_combo1);

    m_expand.SetLabelText(
        _T("Search Options <<"), _T("Search Options >>"));
}

See the "SearchOptions" demo for a complete example.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTSearchOptionsCtrl Constructors
CXTSearchOptionsCtrl Constructors | Description
CXTSearchOptionsCtrl | Constructs a CXTSearchOptionsCtrl object
CXTSearchOptionsCtrl Data Members
CXTSearchOptionsCtrl Data Members | Description
m_arHideCtrls | List of controls to show or hide.
m_arMoveCtrls | List of controls to move when expanded or contracted.
m_bExpanded | true when the control is expanded.
m_bPreSubclassInit | true for initialization.
m_iMaxSize | Height of the control when expanded.
m_iMinSize | Height of the control when contracted.
m_rcLabel | Size of the label that is displayed.
m_strContractLabel | Label to display when the control is contracted.
m_strExpandLabel | Label to display when the control is expanded.
CXTSearchOptionsCtrl Destructors
CXTSearchOptionsCtrl Destructors | Description
~CXTSearchOptionsCtrl | Destroys a CXTSearchOptionsCtrl object, handles cleanup and deallocation
CXTSearchOptionsCtrl Methods
CXTSearchOptionsCtrl Methods | Description
AddControl | Call this member function to add a control to the list of controls that are displayed when the hide item control is expanded.
Contract | Call this member function to contract the hide item control and hide CWnd objects contained in the hide item list. Called by the control whenever the user clicks on the contract label.
Expand | Call this member function to expand the hide item control and display CWnd objects contained in the hide item list. Called by the control whenever the user clicks on the expand label.
GetMaxSize | Call this member function to return the maximum height of the hide item control.
GetMinSize | Call this member function to return the minimum height of the hide item control.
GetOffsetSize | Call this member function to return the offset size for the CXTSearchOptionsCtrl object. This is the distance the controls will be moved to accommodate for the expansion and contraction of the control. Also used by CXTSearchOptionsView for adjusting scroll sizes.
Init | This member function is called by the CXTSearchOptionsCtrl class to perform initialization when the window is created or sub-classed.
IsExpanded | Call this member function to determine if the search options control has been expanded.
MoveControl | Call this member function to add a control to the list of controls that are moved when the hide item control is either expanded or contracted.
SetLabelText | Call this member function to set the text that is displayed when the hide item control is either expanded or contracted.


CXTSearchOptionsCtrl Data Members

CXTSearchOptionsCtrl Class, Legend, Protected Data Members
CXTSearchOptionsCtrl Data Members
Class

CXTSearchOptionsCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arHideCtrls | List of controls to show or hide.
m_arMoveCtrls | List of controls to move when expanded or contracted.
m_bExpanded | true when the control is expanded.
m_bPreSubclassInit | true for initialization.
m_iMaxSize | Height of the control when expanded.
m_iMinSize | Height of the control when contracted.
m_rcLabel | Size of the label that is displayed.
m_strContractLabel | Label to display when the control is contracted.
m_strExpandLabel | Label to display when the control is expanded.


CXTSearchOptionsCtrl::m_arHideCtrls Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_arHideCtrls Data Member

List of controls to show or hide.

CPtrArray m_arHideCtrls;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl::m_arMoveCtrls Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_arMoveCtrls Data Member

List of controls to move when expanded or contracted.

CPtrArray m_arMoveCtrls;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl::m_bExpanded Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_bExpanded Data Member

true when the control is expanded.

bool m_bExpanded;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl::m_bPreSubclassInit Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_bPreSubclassInit Data Member

true for initialization.

bool m_bPreSubclassInit;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl::m_iMaxSize Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_iMaxSize Data Member

Height of the control when expanded.

int m_iMaxSize;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl::m_iMinSize Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_iMinSize Data Member

Height of the control when contracted.

int m_iMinSize;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl::m_rcLabel Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_rcLabel Data Member

Size of the label that is displayed.

CRect m_rcLabel;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl::m_strContractLabel Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_strContractLabel Data Member

Label to display when the control is contracted.

CString m_strContractLabel;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl::m_strExpandLabel Data Member

CXTSearchOptionsCtrl Data Members, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::m_strExpandLabel Data Member

Label to display when the control is expanded.

CString m_strExpandLabel;
Group

CXTSearchOptionsCtrl Data Members


CXTSearchOptionsCtrl Methods

CXTSearchOptionsCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl Methods
Class

CXTSearchOptionsCtrl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Init | This member function is called by the CXTSearchOptionsCtrl class to perform initialization when the window is created or sub-classed.
Public Methods
Public Methods
Public Method | Description
AddControl | Call this member function to add a control to the list of controls that are displayed when the hide item control is expanded.
Contract | Call this member function to contract the hide item control and hide CWnd objects contained in the hide item list. Called by the control whenever the user clicks on the contract label.
Expand | Call this member function to expand the hide item control and display CWnd objects contained in the hide item list. Called by the control whenever the user clicks on the expand label.
GetMaxSize | Call this member function to return the maximum height of the hide item control.
GetMinSize | Call this member function to return the minimum height of the hide item control.
GetOffsetSize | Call this member function to return the offset size for the CXTSearchOptionsCtrl object. This is the distance the controls will be moved to accommodate for the expansion and contraction of the control. Also used by CXTSearchOptionsView for adjusting scroll sizes.
IsExpanded | Call this member function to determine if the search options control has been expanded.
MoveControl | Call this member function to add a control to the list of controls that are moved when the hide item control is either expanded or contracted.
SetLabelText | Call this member function to set the text that is displayed when the hide item control is either expanded or contracted.


CXTSearchOptionsCtrl::AddControl Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class
CXTSearchOptionsCtrl::AddControl Method

Call this member function to add a control to the list of controls that are displayed when the hide item control is expanded.

void AddControl(
    CWnd* pWndCtrl
);
Parameters

pWndCtrl
Points to a valid CWnd object to hide.

Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::Contract Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class
CXTSearchOptionsCtrl::Contract Method

Call this member function to contract the hide item control and hide CWnd objects contained in the hide item list. Called by the control whenever the user clicks on the contract label.

void Contract();
Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::Expand Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class
CXTSearchOptionsCtrl::Expand Method

Call this member function to expand the hide item control and display CWnd objects contained in the hide item list. Called by the control whenever the user clicks on the expand label.

void Expand();
Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::GetMaxSize Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::GetMaxSize Method

Call this member function to return the maximum height of the hide item control.

int GetMaxSize();
Returns

An integer value that represents the height of the control when it is expanded.

Body Source
int CXTSearchOptionsCtrl::GetMaxSize() {
    return m_iMaxSize;
}
Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::GetMinSize Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::GetMinSize Method

Call this member function to return the minimum height of the hide item control.

int GetMinSize();
Returns

An integer value that represents the height of the control when it is contracted.

Body Source
int CXTSearchOptionsCtrl::GetMinSize() {
    return m_iMinSize;
}
Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::GetOffsetSize Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::GetOffsetSize Method

Call this member function to return the offset size for the CXTSearchOptionsCtrl object. This is the distance the controls will be moved to accommodate for the expansion and contraction of the control. Also used by CXTSearchOptionsView for adjusting scroll sizes.

int GetOffsetSize();
Returns

An integer value that represents the distance the controls will be moved.

Body Source
int CXTSearchOptionsCtrl::GetOffsetSize() {
    return GetMaxSize()-GetMinSize();
}
Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::Init Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class
CXTSearchOptionsCtrl::Init Method

This member function is called by the CXTSearchOptionsCtrl class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::IsExpanded Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::IsExpanded Method

Call this member function to determine if the search options control has been expanded.

bool IsExpanded() const;
Returns

True if expanded, otherwise returns false.

Body Source
bool CXTSearchOptionsCtrl::IsExpanded() const {
    return m_bExpanded;
}
Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::MoveControl Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class
CXTSearchOptionsCtrl::MoveControl Method

Call this member function to add a control to the list of controls that are moved when the hide item control is either expanded or contracted.

void MoveControl(
    CWnd* pWndCtrl
);
Parameters

pWndCtrl
Points to a valid CWnd object to move.

Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl::SetLabelText Method

CXTSearchOptionsCtrl Methods, CXTSearchOptionsCtrl Class
CXTSearchOptionsCtrl::SetLabelText Method

Call this member function to set the text that is displayed when the hide item control is either expanded or contracted.

void SetLabelText(
    LPCTSTR lpszExpand,
    LPCTSTR lpszContract
);
Parameters

lpszExpand
NULL terminated string that represents the text displayed when the control is expanded.
lpszContract
NULL terminated string that represents the text displayed when the control is contracted.

Group

CXTSearchOptionsCtrl Methods


CXTSearchOptionsCtrl Constructors

CXTSearchOptionsCtrl Class, Legend, Public Methods
CXTSearchOptionsCtrl Constructors
Class

CXTSearchOptionsCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTSearchOptionsCtrl | Constructs a CXTSearchOptionsCtrl object


CXTSearchOptionsCtrl::CXTSearchOptionsCtrl Constructor

CXTSearchOptionsCtrl Constructors, CXTSearchOptionsCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsCtrl::CXTSearchOptionsCtrl Constructor

Constructs a CXTSearchOptionsCtrl object

CXTSearchOptionsCtrl();
Group

CXTSearchOptionsCtrl Constructors


CXTSearchOptionsCtrl Destructors

CXTSearchOptionsCtrl Class, Legend, Public Methods
CXTSearchOptionsCtrl Destructors
Class

CXTSearchOptionsCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTSearchOptionsCtrl | Destroys a CXTSearchOptionsCtrl object, handles cleanup and deallocation


CXTSearchOptionsCtrl::~CXTSearchOptionsCtrl Destructor

CXTSearchOptionsCtrl Destructors, CXTSearchOptionsCtrl Class
CXTSearchOptionsCtrl::~CXTSearchOptionsCtrl Destructor

Destroys a CXTSearchOptionsCtrl object, handles cleanup and deallocation

virtual ~CXTSearchOptionsCtrl();
Group

CXTSearchOptionsCtrl Destructors


CXTSearchOptionsView Class

XTSearchOptionsCtrl.h, Classes, Legend, Members, Topics, CXTSearchOptionsView Data Members, CXTSearchOptionsView Methods, CXTSearchOptionsView Constructors, CXTSearchOptionsView Destructors, CXTSearchOptionsView Nested Types, CXTSearchOptionsView Constructors, CXTSearchOptionsView Data Members, CXTSearchOptionsView Destructors, CXTSearchOptionsView Methods, CXTSearchOptionsView Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsView Class

CXTSearchOptionsView is a CFormView derived class. It is to be used with a CXTSearchOptionsCtrl object to paint the background and control background color white. It is also used for resizing and moving children of the form automatically.

Class Hierarchy

class CXTSearchOptionsView : public CFormView;
File

XTSearchOptionsCtrl.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTSearchOptionsView Constructors
CXTSearchOptionsView Constructors | Description
CXTSearchOptionsView |
CXTSearchOptionsView Data Members
CXTSearchOptionsView Data Members | Description
m_arResizeWnd | Array of children to move or resize.
m_hBrush | Handle to the current background brush
m_rcWindow | Original size of the window.
CXTSearchOptionsView Destructors
CXTSearchOptionsView Destructors | Description
~CXTSearchOptionsView | Destroys a CXTSearchOptionsView object, handles cleanup and deallocation
CXTSearchOptionsView Methods
CXTSearchOptionsView Methods | Description
AdjustScrollSizes | Call this member function to adjust the scroll sizes for the form view.
SetResize | The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button), all four sides should move by the same amount of pixels as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), the left and top sides should not move, and the right and bottom sides should move by the same amount of pixels as the dialog.
CXTSearchOptionsView Nested Types
CXTSearchOptionsView Nested Types | Description
CResizeWndArray | CResizeWndArray - private helper class


CXTSearchOptionsView Data Members

CXTSearchOptionsView Class, Legend, Protected Data Members
CXTSearchOptionsView Data Members
Class

CXTSearchOptionsView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arResizeWnd | Array of children to move or resize.
m_hBrush | Handle to the current background brush
m_rcWindow | Original size of the window.


CXTSearchOptionsView::m_arResizeWnd Data Member

CXTSearchOptionsView Data Members, CXTSearchOptionsView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsView::m_arResizeWnd Data Member

Array of children to move or resize.

CResizeWndArray m_arResizeWnd;
Group

CXTSearchOptionsView Data Members


CXTSearchOptionsView::m_hBrush Data Member

CXTSearchOptionsView Data Members, CXTSearchOptionsView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsView::m_hBrush Data Member

Handle to the current background brush

HBRUSH m_hBrush;
Group

CXTSearchOptionsView Data Members


CXTSearchOptionsView::m_rcWindow Data Member

CXTSearchOptionsView Data Members, CXTSearchOptionsView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsView::m_rcWindow Data Member

Original size of the window.

CRect m_rcWindow;
Group

CXTSearchOptionsView Data Members


CXTSearchOptionsView Methods

CXTSearchOptionsView Class, Legend, Protected Methods
CXTSearchOptionsView Methods
Class

CXTSearchOptionsView Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
AdjustScrollSizes | Call this member function to adjust the scroll sizes for the form view.
SetResize | The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button), all four sides should move by the same amount of pixels as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), the left and top sides should not move, and the right and bottom sides should move by the same amount of pixels as the dialog.


CXTSearchOptionsView::AdjustScrollSizes Method

CXTSearchOptionsView Methods, CXTSearchOptionsView Class
CXTSearchOptionsView::AdjustScrollSizes Method

Call this member function to adjust the scroll sizes for the form view.

void AdjustScrollSizes(
    CXTSearchOptionsCtrl* pSOCtrl,
    bool bAdd
);
Parameters

pSOCtrl
Points to the CXTSearchOpetionsCtrl object to adjust the scroll sizes for.
bAdd
True to add the size, false to subtract size.

Group

CXTSearchOptionsView Methods


CXTSearchOptionsView::SetResize Method

CXTSearchOptionsView Methods, CXTSearchOptionsView Class
CXTSearchOptionsView::SetResize Method

The SetResize function specifies how much each side of a control will move when the dialog is resized. If a control should be repositioned (e.g. an OK button), all four sides should move by the same amount of pixels as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), the left and top sides should not move, and the right and bottom sides should move by the same amount of pixels as the dialog.

void SetResize(
    int nID,
    const XT_RESIZEPOINT& ptTopLeft,
    const XT_RESIZEPOINT& ptTopRight
);
Parameters

nID
Specifies the control's ID.
ptTopLeft
How much the top and left sides will move when the dialog is resized.
ptTopRight
How much the bottom and right sides will move when the dialog is resized.

Group

CXTSearchOptionsView Methods


CXTSearchOptionsView Constructors

CXTSearchOptionsView Class, Legend, Protected Methods
CXTSearchOptionsView Constructors
Class

CXTSearchOptionsView Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTSearchOptionsView |


CXTSearchOptionsView Constructor

CXTSearchOptionsView Constructors
CXTSearchOptionsView Constructor
Overload List
Constructors
Constructor | Description
CXTSearchOptionsView::CXTSearchOptionsView (LPCTSTR) | When you create an object of a type derived from CXTSearchOptionsView, invoke one of the constructors to create the view object and identify the dialog resource on which the view is based. You can identify the resource either by name (pass a string as the argument to the constructor) or by its ID (pass an unsigned integer as the argument).
CXTSearchOptionsView::CXTSearchOptionsView (UINT) | When you create an object of a type derived from CXTSearchOptionsView, invoke one of the constructors to create the view object and identify the dialog resource on which the view is based. You can identify the resource either by name (pass a string as the argument to the constructor) or by its ID (pass an unsigned integer as the argument).
Group

CXTSearchOptionsView Constructors


CXTSearchOptionsView::CXTSearchOptionsView Constructor (UINT)

CXTSearchOptionsView Constructor, CXTSearchOptionsView Class
CXTSearchOptionsView::CXTSearchOptionsView Constructor (UINT)

When you create an object of a type derived from CXTSearchOptionsView, invoke one of the constructors to create the view object and identify the dialog resource on which the view is based. You can identify the resource either by name (pass a string as the argument to the constructor) or by its ID (pass an unsigned integer as the argument).

CXTSearchOptionsView(
    UINT nIDTemplate
);
CXTSearchOptionsView(
    LPCTSTR lpszTemplateName
);
Parameters

nIDTemplate
Contains the ID number of a dialog-template resource.
lpszTemplateName
Contains a null-terminated string that is the name of a dialog-template resource.

The form-view window and child controls are not created until CWnd::Create is called. CWnd::Create is called by the framework as part of the document and view creation process, which is driven by the document template.

Group

CXTSearchOptionsView Constructor


CXTSearchOptionsView Destructors

CXTSearchOptionsView Class, Legend, Protected Methods
CXTSearchOptionsView Destructors
Class

CXTSearchOptionsView Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTSearchOptionsView | Destroys a CXTSearchOptionsView object, handles cleanup and deallocation


CXTSearchOptionsView::~CXTSearchOptionsView Destructor

CXTSearchOptionsView Destructors, CXTSearchOptionsView Class
CXTSearchOptionsView::~CXTSearchOptionsView Destructor

Destroys a CXTSearchOptionsView object, handles cleanup and deallocation

virtual ~CXTSearchOptionsView();
Group

CXTSearchOptionsView Destructors


CXTSearchOptionsView Nested Types

CXTSearchOptionsView Class, Public Nested Types
CXTSearchOptionsView Nested Types
Class

CXTSearchOptionsView Class

Public Nested Types
Public Nested Type | Description
CResizeWndArray | CResizeWndArray - private helper class


CXTSearchOptionsView::CResizeWndArray Nested Type

CXTSearchOptionsView Nested Types, CXTSearchOptionsView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSearchOptionsView::CResizeWndArray Nested Type

CResizeWndArray - private helper class

typedef CList<CResizeWnd*, CResizeWnd*> CResizeWndArray;
Group

CXTSearchOptionsView Nested Types


CXTShellListBase Class

XTShellListBase.h, Classes, Legend, Members, Topics, CXTShellListBase Data Members, CXTShellListBase Methods, CXTShellListBase Constructors, CXTShellListBase Destructors, CXTShellListBase Constructors, CXTShellListBase Data Members, CXTShellListBase Destructors, CXTShellListBase Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListBase Class

CXTShellListBase is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListBase class object.

Class Hierarchy

class CXTShellListBase : public CXTListBase, public CXTShellPidl;
File

XTShellListBase.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTShellListBase Constructors
CXTShellListBase Constructors | Description
CXTShellListBase | Constructs a CXTShellListBase object
CXTShellListBase Data Members
CXTShellListBase Data Members | Description
m_bContextMenu | TRUE to display the shell context menu on right item click.
m_csIncludeEXT | Comma delimited string of extensions to include in file display.
m_nNameColumnWidth | Size in pixels for the name column width.
m_pDirThread | Thread used to monitor directory activity.
m_pidlINet | Points to the CSIDL_INTERNET folder location.
m_shSettings | Contains SHELLFLAGSTATE info.
m_uFlags | Flags indicating which items to include in the enumeration.
CXTShellListBase Destructors
CXTShellListBase Destructors | Description
~CXTShellListBase | Destroys a CXTShellListBase object, handles cleanup and deallocation
CXTShellListBase Methods
CXTShellListBase Methods | Description
BuildDefaultColumns | This member function creates default columns for the list view
EnableContextMenu | Call this member function to enable or disable the display of the shell context menu on the right click of the item.
GetDoubleClickedItem | This member function returns the index of the list view item that was double clicked on.
GetItemPath | This member function retrieves the path for the specified list view item.
GetNormalAndSelectedIcons | This member function gets the index for the normal and selected icons of the current item.
Init | This member function is called by the CXTShellListBase class to perform initialization when the window is created or sub-classed.
InitListViewItems | This member function adds items to the list view.
InitSystemImageLists | This member function associates the system image list with the list control.
InsertCommas | Called by the shell list control to insert commas into the specified numeric value. The result is then returned in the szBufferOut item. An example of this would be to format a file size 1, 024 KB.
IsItemFiltered | This member function returns if item is filtered. You can override it in your class
OnDragDrop | Used by the shell list control to handle a drag drop event.
PopulateListView | This member function populates the list view control.
SetAttributes | This member function sets the shell attribute flags for the specified list item.
SetEnumFlags | Call this member function to determine the type of items included in the shell enumeration. The default is SHCONTF_FOLDERS | SHCONTF_NONFOLDERS.
SetIncludeExtensions | Call this member function to define a file filter for the files displayed, only those files specified by pFilters to be displayed in the shell list. File extensions are separated by a semi-colon. Call SetIncludeExtensions(NULL); to restore normal file display.
ShellOpenItem |
ShowShellContextMenu | This member function displays the system popup menu for the selected item or folder.
SortList | Override this member function in your derived class to perform custom sort routines.


CXTShellListBase Data Members

CXTShellListBase Class, Legend, Protected Data Members
CXTShellListBase Data Members
Class

CXTShellListBase Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bContextMenu | TRUE to display the shell context menu on right item click.
m_csIncludeEXT | Comma delimited string of extensions to include in file display.
m_nNameColumnWidth | Size in pixels for the name column width.
m_pDirThread | Thread used to monitor directory activity.
m_pidlINet | Points to the CSIDL_INTERNET folder location.
m_shSettings | Contains SHELLFLAGSTATE info.
m_uFlags | Flags indicating which items to include in the enumeration.


CXTShellListBase::m_bContextMenu Data Member

CXTShellListBase Data Members, CXTShellListBase Class
CXTShellListBase::m_bContextMenu Data Member

TRUE to display the shell context menu on right item click.

BOOL m_bContextMenu;
Group

CXTShellListBase Data Members


CXTShellListBase::m_csIncludeEXT Data Member

CXTShellListBase Data Members, CXTShellListBase Class
CXTShellListBase::m_csIncludeEXT Data Member

Comma delimited string of extensions to include in file display.

CString m_csIncludeEXT;
Group

CXTShellListBase Data Members


CXTShellListBase::m_nNameColumnWidth Data Member

CXTShellListBase Data Members, CXTShellListBase Class
CXTShellListBase::m_nNameColumnWidth Data Member

Size in pixels for the name column width.

int m_nNameColumnWidth;
Group

CXTShellListBase Data Members


CXTShellListBase::m_pDirThread Data Member

CXTShellListBase Data Members, CXTShellListBase Class
CXTShellListBase::m_pDirThread Data Member

Thread used to monitor directory activity.

CXTDirWatcher* m_pDirThread;
Group

CXTShellListBase Data Members


CXTShellListBase::m_pidlINet Data Member

CXTShellListBase Data Members, CXTShellListBase Class
CXTShellListBase::m_pidlINet Data Member

Points to the CSIDL_INTERNET folder location.

LPITEMIDLIST m_pidlINet;
Group

CXTShellListBase Data Members


CXTShellListBase::m_shSettings Data Member

CXTShellListBase Data Members, CXTShellListBase Class
CXTShellListBase::m_shSettings Data Member

Contains SHELLFLAGSTATE info.

CXTShellSettings m_shSettings;
Group

CXTShellListBase Data Members


CXTShellListBase::m_uFlags Data Member

CXTShellListBase Data Members, CXTShellListBase Class
CXTShellListBase::m_uFlags Data Member

Flags indicating which items to include in the enumeration.

UINT m_uFlags;
Group

CXTShellListBase Data Members


CXTShellListBase Methods

CXTShellListBase Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListBase Methods
Class

CXTShellListBase Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetNormalAndSelectedIcons | This member function gets the index for the normal and selected icons of the current item.
Init | This member function is called by the CXTShellListBase class to perform initialization when the window is created or sub-classed.
InitListViewItems | This member function adds items to the list view.
IsItemFiltered | This member function returns if item is filtered. You can override it in your class
SetAttributes | This member function sets the shell attribute flags for the specified list item.
Public Methods
Public Methods
Public Method | Description
BuildDefaultColumns | This member function creates default columns for the list view
EnableContextMenu | Call this member function to enable or disable the display of the shell context menu on the right click of the item.
GetDoubleClickedItem | This member function returns the index of the list view item that was double clicked on.
GetItemPath | This member function retrieves the path for the specified list view item.
InitSystemImageLists | This member function associates the system image list with the list control.
InsertCommas | Called by the shell list control to insert commas into the specified numeric value. The result is then returned in the szBufferOut item. An example of this would be to format a file size 1, 024 KB.
OnDragDrop | Used by the shell list control to handle a drag drop event.
PopulateListView | This member function populates the list view control.
SetEnumFlags | Call this member function to determine the type of items included in the shell enumeration. The default is SHCONTF_FOLDERS | SHCONTF_NONFOLDERS.
SetIncludeExtensions | Call this member function to define a file filter for the files displayed, only those files specified by pFilters to be displayed in the shell list. File extensions are separated by a semi-colon. Call SetIncludeExtensions(NULL); to restore normal file display.
ShellOpenItem |
ShowShellContextMenu | This member function displays the system popup menu for the selected item or folder.
SortList | Override this member function in your derived class to perform custom sort routines.


CXTShellListBase::BuildDefaultColumns Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::BuildDefaultColumns Method

This member function creates default columns for the list view

virtual void BuildDefaultColumns();
Group

CXTShellListBase Methods


CXTShellListBase::EnableContextMenu Method

CXTShellListBase Methods, CXTShellListBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListBase::EnableContextMenu Method

Call this member function to enable or disable the display of the shell context menu on the right click of the item.

virtual void EnableContextMenu(
    BOOL bEnable
);
Parameters

bEnable
TRUE to display a context menu.

Body Source
void CXTShellListBase::EnableContextMenu(BOOL bEnable) {
    m_bContextMenu = bEnable;
}
Group

CXTShellListBase Methods


CXTShellListBase::GetDoubleClickedItem Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::GetDoubleClickedItem Method

This member function returns the index of the list view item that was double clicked on.

virtual int GetDoubleClickedItem();
Returns

The index of the item that was double clicked; or -1, if the item was not found.

Group

CXTShellListBase Methods


CXTShellListBase::GetItemPath Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::GetItemPath Method

This member function retrieves the path for the specified list view item.

virtual BOOL GetItemPath(
    int iItem,
    CString& strItemPath
);
Parameters

iItem
Index of the list view item to get the path of.
strItemPath
Reference to a CString object that receives the path string.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellListBase Methods


CXTShellListBase::GetNormalAndSelectedIcons Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::GetNormalAndSelectedIcons Method

This member function gets the index for the normal and selected icons of the current item.

virtual void GetNormalAndSelectedIcons(
    LPITEMIDLIST lpifq,
    LPTV_ITEM lptvitem
);
Parameters

lpifq
Fully qualified item ID list for the current item.
lptvitem
Pointer to the tree view item that is about to be added to the tree.

Group

CXTShellListBase Methods


CXTShellListBase::Init Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::Init Method

This member function is called by the CXTShellListBase class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTShellListBase Methods


CXTShellListBase::InitListViewItems Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::InitListViewItems Method

This member function adds items to the list view.

virtual BOOL InitListViewItems(
    XT_TVITEMDATA* lptvid,
    LPSHELLFOLDER lpsf
);
Parameters

lptvid
Pointer to tree view item data.
lpsf
Pointer to the parent shell folder.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellListBase Methods


CXTShellListBase::InitSystemImageLists Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::InitSystemImageLists Method

This member function associates the system image list with the list control.

virtual BOOL InitSystemImageLists();
Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellListBase Methods


CXTShellListBase::InsertCommas Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::InsertCommas Method

Called by the shell list control to insert commas into the specified numeric value. The result is then returned in the szBufferOut item. An example of this would be to format a file size 1, 024 KB.

virtual TCHAR* InsertCommas(
    LONGLONG value,
    TCHAR* szBuffer,
    UINT nSize
);
Parameters

value
[in] Numeric value to insert commas.
szBuffer
[out] String buffer to receive the formatted string.
nSize
[in] Size of the string specified by szBuffer.

Returns

A string representing a comma separated numeric value.

Group

CXTShellListBase Methods


CXTShellListBase::IsItemFiltered Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::IsItemFiltered Method

This member function returns if item is filtered. You can override it in your class

virtual BOOL IsItemFiltered(
    LPCTSTR lpszItemName,
    ULONG ulItemAttrs
);
Parameters

lpszItemName
Friendly name for the folder or file.
ulItemAttrs
Attributes of the item.

Group

CXTShellListBase Methods


CXTShellListBase::OnDragDrop Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::OnDragDrop Method

Used by the shell list control to handle a drag drop event.

virtual void OnDragDrop(
    NM_LISTVIEW* pNMListView
);
Parameters

pNMListView
Points to a NM_LISTVIEW structure.

Group

CXTShellListBase Methods


CXTShellListBase::PopulateListView Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::PopulateListView Method

This member function populates the list view control.

virtual BOOL PopulateListView(
    XT_TVITEMDATA* lptvid,
    LPSHELLFOLDER lpsf
);
Parameters

lptvid
Pointer to TreeView item data.
lpsf
Pointer to the parent shell folder.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellListBase Methods


CXTShellListBase::SetAttributes Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::SetAttributes Method

This member function sets the shell attribute flags for the specified list item.

virtual void SetAttributes(
    int iItem,
    DWORD dwAttributes
);
Parameters

iItem
Index of the item to set the attributes for.
dwAttributes
Flags retrieved from SHELLFOLDER::GetAttributesOf.

Group

CXTShellListBase Methods


CXTShellListBase::SetEnumFlags Method

CXTShellListBase Methods, CXTShellListBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListBase::SetEnumFlags Method

Call this member function to determine the type of items included in the shell enumeration. The default is SHCONTF_FOLDERS | SHCONTF_NONFOLDERS.

virtual void SetEnumFlags(
    UINT uFlags
);
Parameters

uFlags
Determines the type of items included in an enumeration and can be one or more of the flags listed in the Remarks section.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • SHCONTF_FOLDERS Include items that are folders in the enumeration.
  • SHCONTF_NONFOLDERS Include items that are not folders in the enumeration.
  • SHCONTF_INCLUDEHIDDEN Include hidden items in the enumeration.
  • SHCONTF_INIT_ON_FIRST_NEXT IShellFolder::EnumObjects can return without validating the enumeration object. Validation can be postponed until the first call to IEnumIDList::Next. This flag is intended to be used when a user interface may be displayed prior to the first IEnumIDList::Next call. For a user interface to be presented, 'hwndOwner' must be set to a valid window handle.
  • SHCONTF_NETPRINTERSRCH The caller is looking for printer objects.
Body Source
void CXTShellListBase::SetEnumFlags(UINT uFlags) {
    m_uFlags = uFlags;
}
Group

CXTShellListBase Methods


CXTShellListBase::SetIncludeExtensions Method

CXTShellListBase Methods, CXTShellListBase Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListBase::SetIncludeExtensions Method

Call this member function to define a file filter for the files displayed, only those files specified by pFilters to be displayed in the shell list. File extensions are separated by a semi-colon. Call SetIncludeExtensions(NULL); to restore normal file display.

virtual void SetIncludeExtensions(
    LPCTSTR lpszFilters = NULL
);
Parameters

lpszFilters
NULL terminated string representing files to be displayed in the shell list control.

Example
SetIncludeExtensions(_T("*.wav;*.mp3;*.aif;*.wmv"));
Body Source
void CXTShellListBase::SetIncludeExtensions(LPCTSTR lpszFilters) {
    m_csIncludeEXT = lpszFilters;
}
Group

CXTShellListBase Methods


ShellOpenItem Method

CXTShellListBase Methods
ShellOpenItem Method
Overload List
Methods
Method | Description
CXTShellListBase::ShellOpenItem (XT_LVITEMDATA*) | This member function executes the item clicked on in the list control via the Shell.
CXTShellListBase::ShellOpenItem (int) | This member function executes the item clicked on in the list control via the Shell.
Group

CXTShellListBase Methods


CXTShellListBase::ShellOpenItem Method (int)

ShellOpenItem Method, CXTShellListBase Class
CXTShellListBase::ShellOpenItem Method (int)

This member function executes the item clicked on in the list control via the Shell.

virtual bool ShellOpenItem(
    int iItem
);
virtual bool ShellOpenItem(
    XT_LVITEMDATA* lplvid
);
Parameters

iItem
Index of the list view item clicked on.
lplvid
Pointer to the list view item data.

Returns

true if successful, otherwise returns false.

Group

ShellOpenItem Method


CXTShellListBase::ShowShellContextMenu Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::ShowShellContextMenu Method

This member function displays the system popup menu for the selected item or folder.

virtual void ShowShellContextMenu(
    CPoint pos
);
Parameters

pos
Position to show

Group

CXTShellListBase Methods


CXTShellListBase::SortList Method

CXTShellListBase Methods, CXTShellListBase Class
CXTShellListBase::SortList Method

Override this member function in your derived class to perform custom sort routines.

virtual bool SortList(
    int nCol,
    bool bAscending
);
Parameters

nCol
Passed in from the control. The index of the column clicked.
bAscending
Passed in from the control. true if the sort order should be ascending.

Returns

true if successful, otherwise returns false.

Group

CXTShellListBase Methods


CXTShellListBase Constructors

CXTShellListBase Class, Legend, Public Methods
CXTShellListBase Constructors
Class

CXTShellListBase Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellListBase | Constructs a CXTShellListBase object


CXTShellListBase::CXTShellListBase Constructor

CXTShellListBase Constructors, CXTShellListBase Class
CXTShellListBase::CXTShellListBase Constructor

Constructs a CXTShellListBase object

CXTShellListBase();
Group

CXTShellListBase Constructors


CXTShellListBase Destructors

CXTShellListBase Class, Legend, Public Methods
CXTShellListBase Destructors
Class

CXTShellListBase Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellListBase | Destroys a CXTShellListBase object, handles cleanup and deallocation


CXTShellListBase::~CXTShellListBase Destructor

CXTShellListBase Destructors, CXTShellListBase Class
CXTShellListBase::~CXTShellListBase Destructor

Destroys a CXTShellListBase object, handles cleanup and deallocation

virtual ~CXTShellListBase();
Group

CXTShellListBase Destructors


CXTShellListCtrl Class

XTShellListCtrlView.h, Classes, Legend, Members, Topics, CXTShellListCtrl Data Members, CXTShellListCtrl Methods, CXTShellListCtrl Constructors, CXTShellListCtrl Destructors, CXTShellListCtrl Constructors, CXTShellListCtrl Data Members, CXTShellListCtrl Destructors, CXTShellListCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListCtrl Class

CXTShellListCtrl is a multiple inheritance class derived from CXTListCtrl and CXTShellPidl. It is used to create a CXTShellListCtrl window.

Class Hierarchy

class CXTShellListCtrl : public CXTShellListCtrlBase;
File

XTShellListCtrlView.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTShellListCtrl Constructors
CXTShellListCtrl Constructors | Description
CXTShellListCtrl | Constructs a CXTShellListCtrl object
CXTShellListCtrl Data Members
CXTShellListCtrl Data Members | Description
m_bInitControl | true if the control has not been initialized.
m_pTreeCtrl | Window that receives update notification, usually a CXTShellTreeCtrl.
CXTShellListCtrl Destructors
CXTShellListCtrl Destructors | Description
~CXTShellListCtrl | Destroys a CXTShellListCtrl object, handles cleanup and deallocation
CXTShellListCtrl Methods
CXTShellListCtrl Methods | Description
AssociateTree | Call this member function to associate the tree control with the list.


CXTShellListCtrl Data Members

CXTShellListCtrl Class, Legend, Protected Data Members
CXTShellListCtrl Data Members
Class

CXTShellListCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bInitControl | true if the control has not been initialized.
m_pTreeCtrl | Window that receives update notification, usually a CXTShellTreeCtrl.


CXTShellListCtrl::m_bInitControl Data Member

CXTShellListCtrl Data Members, CXTShellListCtrl Class
CXTShellListCtrl::m_bInitControl Data Member

true if the control has not been initialized.

bool m_bInitControl;
Group

CXTShellListCtrl Data Members


CXTShellListCtrl::m_pTreeCtrl Data Member

CXTShellListCtrl Data Members, CXTShellListCtrl Class
CXTShellListCtrl::m_pTreeCtrl Data Member

Window that receives update notification, usually a CXTShellTreeCtrl.

CWnd* m_pTreeCtrl;
Group

CXTShellListCtrl Data Members


CXTShellListCtrl Methods

CXTShellListCtrl Class, Legend, Public Methods
CXTShellListCtrl Methods
Class

CXTShellListCtrl Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AssociateTree | Call this member function to associate the tree control with the list.


CXTShellListCtrl::AssociateTree Method

CXTShellListCtrl Methods, CXTShellListCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListCtrl::AssociateTree Method

Call this member function to associate the tree control with the list.

virtual void AssociateTree(
    CWnd* pWnd
);
Parameters

pWnd
Points to the tree control that is associated with the list.

Body Source
void CXTShellListCtrl::AssociateTree(CWnd* pWnd) {
    ASSERT_VALID(pWnd); m_pTreeCtrl = pWnd;
}
Group

CXTShellListCtrl Methods


CXTShellListCtrl Constructors

CXTShellListCtrl Class, Legend, Public Methods
CXTShellListCtrl Constructors
Class

CXTShellListCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellListCtrl | Constructs a CXTShellListCtrl object


CXTShellListCtrl::CXTShellListCtrl Constructor

CXTShellListCtrl Constructors, CXTShellListCtrl Class
CXTShellListCtrl::CXTShellListCtrl Constructor

Constructs a CXTShellListCtrl object

CXTShellListCtrl();
Group

CXTShellListCtrl Constructors


CXTShellListCtrl Destructors

CXTShellListCtrl Class, Legend, Public Methods
CXTShellListCtrl Destructors
Class

CXTShellListCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellListCtrl | Destroys a CXTShellListCtrl object, handles cleanup and deallocation


CXTShellListCtrl::~CXTShellListCtrl Destructor

CXTShellListCtrl Destructors, CXTShellListCtrl Class
CXTShellListCtrl::~CXTShellListCtrl Destructor

Destroys a CXTShellListCtrl object, handles cleanup and deallocation

virtual ~CXTShellListCtrl();
Group

CXTShellListCtrl Destructors


CXTShellListCtrlEx Class

XTShellListCtrlView.h, Classes, Legend, Members, Topics, CXTShellListCtrlEx Data Members, CXTShellListCtrlEx Methods, CXTShellListCtrlEx Constructors, CXTShellListCtrlEx Destructors, CXTShellListCtrlEx Constructors, CXTShellListCtrlEx Data Members, CXTShellListCtrlEx Destructors, CXTShellListCtrlEx Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListCtrlEx Class

CXTShellListCtrlEx is a CXTShellListCtrl derived class. It is used to create a stand-alone shell list control that is not dependent on a CXTShellTreeCtrl for initialization. It is used to create a CXTShellListCtrlEx window for displaying the contents of file folders.

Class Hierarchy

class CXTShellListCtrlEx : public CXTShellListCtrl;
File

XTShellListCtrlView.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTShellListCtrlEx Constructors
CXTShellListCtrlEx Constructors | Description
CXTShellListCtrlEx | Constructs a CXTShellListCtrlEx object
CXTShellListCtrlEx Data Members
CXTShellListCtrlEx Data Members | Description
m_pSyncWnd | Points to the window to synchronize with the shell list control.
m_strItemPath | A NULL terminated string that represents the currently selected folder.
CXTShellListCtrlEx Destructors
CXTShellListCtrlEx Destructors | Description
~CXTShellListCtrlEx | Destroys a CXTShellListCtrlEx object, handles cleanup and deallocation
CXTShellListCtrlEx Methods
CXTShellListCtrlEx Methods | Description
BrowseToFolder | This member function is called to browse to a particular file folder.
SetSyncWnd | This member function will associate a CWnd object with the shell list control. This window is usually a CEdit control, but can be any CWnd object. This window will have its window text updated whenever the selected folder is changed.


CXTShellListCtrlEx Data Members

CXTShellListCtrlEx Class, Legend, Protected Data Members
CXTShellListCtrlEx Data Members
Class

CXTShellListCtrlEx Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pSyncWnd | Points to the window to synchronize with the shell list control.
m_strItemPath | A NULL terminated string that represents the currently selected folder.


CXTShellListCtrlEx::m_pSyncWnd Data Member

CXTShellListCtrlEx Data Members, CXTShellListCtrlEx Class
CXTShellListCtrlEx::m_pSyncWnd Data Member

Points to the window to synchronize with the shell list control.

CWnd* m_pSyncWnd;
Group

CXTShellListCtrlEx Data Members


CXTShellListCtrlEx::m_strItemPath Data Member

CXTShellListCtrlEx Data Members, CXTShellListCtrlEx Class
CXTShellListCtrlEx::m_strItemPath Data Member

A NULL terminated string that represents the currently selected folder.

CString m_strItemPath;
Group

CXTShellListCtrlEx Data Members


CXTShellListCtrlEx Methods

CXTShellListCtrlEx Class, Legend, Public Methods
CXTShellListCtrlEx Methods
Class

CXTShellListCtrlEx Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
BrowseToFolder | This member function is called to browse to a particular file folder.
SetSyncWnd | This member function will associate a CWnd object with the shell list control. This window is usually a CEdit control, but can be any CWnd object. This window will have its window text updated whenever the selected folder is changed.


CXTShellListCtrlEx::BrowseToFolder Method

CXTShellListCtrlEx Methods, CXTShellListCtrlEx Class
CXTShellListCtrlEx::BrowseToFolder Method

This member function is called to browse to a particular file folder.

bool BrowseToFolder(
    LPCTSTR lpszPath
);
Parameters

lpszPath
A NULL terminated string that represents the folder to select.

Returns

true if successful, otherwise returns false.

Group

CXTShellListCtrlEx Methods


CXTShellListCtrlEx::SetSyncWnd Method

CXTShellListCtrlEx Methods, CXTShellListCtrlEx Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListCtrlEx::SetSyncWnd Method

This member function will associate a CWnd object with the shell list control. This window is usually a CEdit control, but can be any CWnd object. This window will have its window text updated whenever the selected folder is changed.

void SetSyncWnd(
    CWnd* pSyncWnd
);
Parameters

pSyncWnd
Points to a valid CWnd object.

Body Source
void CXTShellListCtrlEx::SetSyncWnd(CWnd* pSyncWnd) {
    m_pSyncWnd = pSyncWnd;
}
Group

CXTShellListCtrlEx Methods


CXTShellListCtrlEx Constructors

CXTShellListCtrlEx Class, Legend, Public Methods
CXTShellListCtrlEx Constructors
Class

CXTShellListCtrlEx Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellListCtrlEx | Constructs a CXTShellListCtrlEx object


CXTShellListCtrlEx::CXTShellListCtrlEx Constructor

CXTShellListCtrlEx Constructors, CXTShellListCtrlEx Class
CXTShellListCtrlEx::CXTShellListCtrlEx Constructor

Constructs a CXTShellListCtrlEx object

CXTShellListCtrlEx();
Group

CXTShellListCtrlEx Constructors


CXTShellListCtrlEx Destructors

CXTShellListCtrlEx Class, Legend, Public Methods
CXTShellListCtrlEx Destructors
Class

CXTShellListCtrlEx Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellListCtrlEx | Destroys a CXTShellListCtrlEx object, handles cleanup and deallocation


CXTShellListCtrlEx::~CXTShellListCtrlEx Destructor

CXTShellListCtrlEx Destructors, CXTShellListCtrlEx Class
CXTShellListCtrlEx::~CXTShellListCtrlEx Destructor

Destroys a CXTShellListCtrlEx object, handles cleanup and deallocation

virtual ~CXTShellListCtrlEx();
Group

CXTShellListCtrlEx Destructors


CXTShellListView Class

XTShellListCtrlView.h, Classes, Legend, Members, Topics, CXTShellListView Methods, CXTShellListView Constructors, CXTShellListView Destructors, CXTShellListView Constructors, CXTShellListView Destructors, CXTShellListView Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellListView Class

CXTShellListView is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListView class object.

Class Hierarchy

class CXTShellListView : public CXTShellListViewBase;
File

XTShellListCtrlView.h

Group

Classes

Legend
Method
protected
virtual
CXTShellListView Constructors
CXTShellListView Constructors | Description
CXTShellListView | Constructs a CXTShellListView object
CXTShellListView Destructors
CXTShellListView Destructors | Description
~CXTShellListView | Destroys a CXTShellListView object, handles cleanup and deallocation
CXTShellListView Methods
CXTShellListView Methods | Description
OnDblclk | Occurs when the user double clicks on the list control.


CXTShellListView Methods

CXTShellListView Class, Legend, Protected Methods
CXTShellListView Methods
Class

CXTShellListView Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
OnDblclk | Occurs when the user double clicks on the list control.


CXTShellListView::OnDblclk Method

CXTShellListView Methods, CXTShellListView Class
CXTShellListView::OnDblclk Method

Occurs when the user double clicks on the list control.

void OnDblclk(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
Address of an NMHDR structure that contains the notification code and additional information. For some notification messages, this parameter points to a larger structure that has the NMHDR structure as its first member.
pResult
Pointer to an LRESULT variable in which to store the result code if the message is handled.

Group

CXTShellListView Methods


CXTShellListView Constructors

CXTShellListView Class, Legend, Public Methods
CXTShellListView Constructors
Class

CXTShellListView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellListView | Constructs a CXTShellListView object


CXTShellListView::CXTShellListView Constructor

CXTShellListView Constructors, CXTShellListView Class
CXTShellListView::CXTShellListView Constructor

Constructs a CXTShellListView object

CXTShellListView();
Group

CXTShellListView Constructors


CXTShellListView Destructors

CXTShellListView Class, Legend, Public Methods
CXTShellListView Destructors
Class

CXTShellListView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellListView | Destroys a CXTShellListView object, handles cleanup and deallocation


CXTShellListView::~CXTShellListView Destructor

CXTShellListView Destructors, CXTShellListView Class
CXTShellListView::~CXTShellListView Destructor

Destroys a CXTShellListView object, handles cleanup and deallocation

virtual ~CXTShellListView();
Group

CXTShellListView Destructors


CXTShellPidl Class

XTShellPidl.h, Classes, Legend, Members, Topics, CXTShellPidl Methods, CXTShellPidl Constructors, CXTShellPidl Destructors, CXTShellPidl Constructors, CXTShellPidl Destructors, CXTShellPidl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellPidl Class

CXTShellPidl is a stand alone base class. This class is used by the shell tree and list controls to handle PIDL creation and management.

Class Hierarchy

class CXTShellPidl;
File

XTShellPidl.h

Group

Classes

Legend
Method
protected
virtual
CXTShellPidl Constructors
CXTShellPidl Constructors | Description
CXTShellPidl | Constructs a CXTShellPidl object
CXTShellPidl Destructors
CXTShellPidl Destructors | Description
~CXTShellPidl | Destroys a CXTShellPidl object, handles cleanup and deallocation
CXTShellPidl Methods
CXTShellPidl Methods | Description
ComparePidls | This member function compares two PIDLs to determine if they match.
ConcatPidls |
CopyIDList | This member function copies a whole ITEMIDLIST. Remember to Free() the old one if it is no longer needed.
CopyPidlItem | This member function copies a single PIDL out of a list. Remember to Free() the old one if it is no longer needed.
CreatePidl | This member function allocates a PIDL.
DuplicateItem | This member function copies the ITEMID.
FreePidl | This member function frees memory for allocated for a PIDL.
GetFullyQualPidl | This member function gets the fully qualified PIDLs for the specified folder.
GetItemIcon | This member function gets the index for the current icon. Index is the index into the system image list.
GetLastITEM | This member function walks an ITEMIDLIST and points to the last one.
GetName | This member function gets the friendly name for the folder or file.
GetNextPidlItem | This member function retrieves the next PIDL in the list.
GetPidlCount | Calculates number of item IDs in the list.
GetPidlItemCount | This member function computes the number of item IDs in an item ID list.
GetSHContextMenu | This member function retrieves the IContextMenu, IContextMenu2 or IContextMenu3 interface.
IDLFromPath | This member function gets the fully qualified PIDL for the path string.
ListViewCompareProc | CXTShellListCtrl callback sort function.
MapShellFlagsToItemAttributes |
OneUpPATH | This member function gets the parent folder using PIDLs.
OneUpPIDL | This member function performs the OneUp or back function.
OnShowContextMenu | This method is called when item of context menu was executed
ShowContextMenu |
ShowShellLinkIcons |
TreeViewCompareProc | CXTShellTreeCtrl callback sort function.


CXTShellPidl Methods

CXTShellPidl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellPidl Methods
Class

CXTShellPidl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
MapShellFlagsToItemAttributes |
OnShowContextMenu | This method is called when item of context menu was executed
Public Methods
Public Methods
Public Method | Description
ComparePidls | This member function compares two PIDLs to determine if they match.
ConcatPidls |
CopyIDList | This member function copies a whole ITEMIDLIST. Remember to Free() the old one if it is no longer needed.
CopyPidlItem | This member function copies a single PIDL out of a list. Remember to Free() the old one if it is no longer needed.
CreatePidl | This member function allocates a PIDL.
DuplicateItem | This member function copies the ITEMID.
FreePidl | This member function frees memory for allocated for a PIDL.
GetFullyQualPidl | This member function gets the fully qualified PIDLs for the specified folder.
GetItemIcon | This member function gets the index for the current icon. Index is the index into the system image list.
GetLastITEM | This member function walks an ITEMIDLIST and points to the last one.
GetName | This member function gets the friendly name for the folder or file.
GetNextPidlItem | This member function retrieves the next PIDL in the list.
GetPidlCount | Calculates number of item IDs in the list.
GetPidlItemCount | This member function computes the number of item IDs in an item ID list.
GetSHContextMenu | This member function retrieves the IContextMenu, IContextMenu2 or IContextMenu3 interface.
IDLFromPath | This member function gets the fully qualified PIDL for the path string.
ListViewCompareProc | CXTShellListCtrl callback sort function.
OneUpPATH | This member function gets the parent folder using PIDLs.
OneUpPIDL | This member function performs the OneUp or back function.
ShowContextMenu |
ShowShellLinkIcons |
TreeViewCompareProc | CXTShellTreeCtrl callback sort function.


CXTShellPidl::ComparePidls Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::ComparePidls Method

This member function compares two PIDLs to determine if they match.

BOOL ComparePidls(
    LPCITEMIDLIST pidl1,
    LPCITEMIDLIST pidl2,
    LPSHELLFOLDER pShellFolder = NULL
);
Parameters

pidl1
Pointer to an item ID list.
pidl2
Pointer to an item ID list.
pShellFolder
Pointer to the shell folder to use for the comparison (default Desktop)

Returns

TRUE on success, or FALSE on failure.

Group

CXTShellPidl Methods


ConcatPidls Method

CXTShellPidl Methods
ConcatPidls Method
Overload List
Methods
Method | Description
CXTShellPidl::ConcatPidls (LPCITEMIDLIST, LPCITEMIDLIST) | This member function concatenates two PIDLs.
CXTShellPidl::ConcatPidls (LPMALLOC, LPCITEMIDLIST, LPCITEMIDLIST) | This member function concatenates two PIDLs.
Group

CXTShellPidl Methods


CXTShellPidl::ConcatPidls Method (LPCITEMIDLIST, LPCITEMIDLIST)

ConcatPidls Method, CXTShellPidl Class
CXTShellPidl::ConcatPidls Method (LPCITEMIDLIST, LPCITEMIDLIST)

This member function concatenates two PIDLs.

LPITEMIDLIST ConcatPidls(
    LPCITEMIDLIST pidl1,
    LPCITEMIDLIST pidl2
);
LPITEMIDLIST ConcatPidls(
    LPMALLOC lpMalloc,
    LPCITEMIDLIST pidl1,
    LPCITEMIDLIST pidl2
);
Parameters

pidl1
Pointer to an item ID list.
pidl2
Pointer to an item ID list.
lpMalloc
Points to the shell's IMalloc interface.

Returns

A pointer to an item ID list.

Group

ConcatPidls Method


CXTShellPidl::CopyIDList Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::CopyIDList Method

This member function copies a whole ITEMIDLIST. Remember to Free() the old one if it is no longer needed.

LPITEMIDLIST CopyIDList(
    LPITEMIDLIST pidl
);
Parameters

pidl
Pointer to an ITEMIDLIST.

Returns

A new pointer to a copy of the PIDL.

Group

CXTShellPidl Methods


CXTShellPidl::CopyPidlItem Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::CopyPidlItem Method

This member function copies a single PIDL out of a list. Remember to Free() the old one if it is no longer needed.

LPITEMIDLIST CopyPidlItem(
    LPITEMIDLIST pidl,
    UINT nItem
);
Parameters

pidl
Pointer to an ITEMIDLIST.
nItem
PIDL in the list to copy.

Returns

A new pointer to a copy of the PIDL with the single item.

Group

CXTShellPidl Methods


CXTShellPidl::CreatePidl Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::CreatePidl Method

This member function allocates a PIDL.

LPITEMIDLIST CreatePidl(
    LPMALLOC lpMalloc,
    UINT cbSize
);
Parameters

lpMalloc
Points to the shell's IMalloc interface.
cbSize
Initial size of the PIDL.

Returns

A pointer to an item ID list.

Group

CXTShellPidl Methods


CXTShellPidl::DuplicateItem Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::DuplicateItem Method

This member function copies the ITEMID.

LPITEMIDLIST DuplicateItem(
    LPMALLOC lpMalloc,
    LPITEMIDLIST lpi
);
Parameters

lpMalloc
Points to the shell's IMalloc interface.
lpi
Pointer to item ID that is to be copied.

Returns

A pointer to an item ID list.

Group

CXTShellPidl Methods


CXTShellPidl::FreePidl Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::FreePidl Method

This member function frees memory for allocated for a PIDL.

void FreePidl(
    LPITEMIDLIST pidl
);
Parameters

pidl
Pointer to an item ID list.

Group

CXTShellPidl Methods


CXTShellPidl::GetFullyQualPidl Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::GetFullyQualPidl Method

This member function gets the fully qualified PIDLs for the specified folder.

LPITEMIDLIST GetFullyQualPidl(
    LPSHELLFOLDER lpsf,
    LPITEMIDLIST lpi
);
Parameters

lpsf
Pointer to the parent shell folder.
lpi
Pointer to the item ID that is relative to 'lpsf'.

Returns

A pointer to an item ID list.

Group

CXTShellPidl Methods


CXTShellPidl::GetItemIcon Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::GetItemIcon Method

This member function gets the index for the current icon. Index is the index into the system image list.

int GetItemIcon(
    LPITEMIDLIST lpi,
    UINT uFlags
) const;
Parameters

lpi
Fully qualified item ID list for the current item.
uFlags
Flags for SHGetFileInfo().

Returns

An icon index for the current item.

Group

CXTShellPidl Methods


CXTShellPidl::GetLastITEM Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::GetLastITEM Method

This member function walks an ITEMIDLIST and points to the last one.

LPITEMIDLIST GetLastITEM(
    LPITEMIDLIST pidl
);
Parameters

pidl
PIDL list.

Returns

A pointer to the last IDL in the list.

Group

CXTShellPidl Methods


CXTShellPidl::GetName Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::GetName Method

This member function gets the friendly name for the folder or file.

BOOL GetName(
    LPSHELLFOLDER lpsf,
    LPITEMIDLIST lpi,
    DWORD dwFlags,
    CString& lpFriendlyName
);
Parameters

lpsf
Pointer to the parent shell folder.
lpi
Pointer to the item ID that is relative to 'lpsf'.
dwFlags
Flags to determine which value to return. See SHGNO for more details.
lpFriendlyName
Buffer to receive the friendly name of the folder.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellPidl Methods


CXTShellPidl::GetNextPidlItem Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::GetNextPidlItem Method

This member function retrieves the next PIDL in the list.

LPITEMIDLIST GetNextPidlItem(
    LPCITEMIDLIST pidl
);
Parameters

pidl
Pointer to an item ID list.

Returns

A pointer to the next PIDL item in the list.

Group

CXTShellPidl Methods


CXTShellPidl::GetPidlCount Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::GetPidlCount Method

Calculates number of item IDs in the list.

UINT GetPidlCount(
    LPCITEMIDLIST pidl
);
Parameters

pidl
Pointer to an item ID list.

Returns

The number of item IDs in the list.

Group

CXTShellPidl Methods


CXTShellPidl::GetPidlItemCount Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::GetPidlItemCount Method

This member function computes the number of item IDs in an item ID list.

UINT GetPidlItemCount(
    LPCITEMIDLIST pidl
);
Parameters

pidl
Pointer to an item ID list.

Returns

The number of item IDs in the list.

Group

CXTShellPidl Methods


CXTShellPidl::GetSHContextMenu Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::GetSHContextMenu Method

This member function retrieves the IContextMenu, IContextMenu2 or IContextMenu3 interface.

HRESULT GetSHContextMenu(
    LPSHELLFOLDER psfFolder,
    LPCITEMIDLIST* localPidl,
    int nCount,
    void** ppCM,
    int* pcmType
);
Parameters

psfFolder
A pointer to a valid IShellFolder data type.
localPidl
A pointer to a valid _ITEMIDLIST structure.
nCount
Number of items in the context menu.
ppCM
Long pointer to a CONTEXTMENU struct.
pcmType
A pointer to a valid int data type that represents the version number of the context menu.

Returns

An HRESULT value.

Group

CXTShellPidl Methods


CXTShellPidl::IDLFromPath Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::IDLFromPath Method

This member function gets the fully qualified PIDL for the path string.

LPITEMIDLIST IDLFromPath(
    LPCTSTR path
);
Parameters

path
File system path string.

Returns

A pointer to an item ID list. Returns NULL if it fails.

Group

CXTShellPidl Methods


CXTShellPidl::ListViewCompareProc Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::ListViewCompareProc Method

CXTShellListCtrl callback sort function.

static int CALLBACK ListViewCompareProc(
    LPARAM lparam1,
    LPARAM lparam2,
    LPARAM lparamSort
);
Parameters

lparam1
Corresponds to the lParam member of the LV_ITEM structure for the two items being compared.
lparam2
Corresponds to the lParam member of the LV_ITEM structure for the two items being compared.
lparamSort
The 'lParamSort' member corresponds to the lParam member of LV_SORTCB.

Returns

A negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.

Remarks

This member function is a callback function used by CXTShellListCtrl and CXTShellListView, and is called during a sort operation each time the relative order of two list items needs to be compared.

Group

CXTShellPidl Methods


MapShellFlagsToItemAttributes Method

CXTShellPidl Methods
MapShellFlagsToItemAttributes Method
Overload List
Methods
Method | Description
CXTShellPidl::MapShellFlagsToItemAttributes (CListCtrl*, int, DWORD) | This function translates shell attributes into a tree item state
CXTShellPidl::MapShellFlagsToItemAttributes (CTreeCtrl*, HTREEITEM, DWORD) | This function translates shell attributes into a tree item state
Group

CXTShellPidl Methods


CXTShellPidl::MapShellFlagsToItemAttributes Method (CListCtrl*, int, DWORD)

MapShellFlagsToItemAttributes Method, CXTShellPidl Class
CXTShellPidl::MapShellFlagsToItemAttributes Method (CListCtrl*, int, DWORD)

This function translates shell attributes into a tree item state

virtual void MapShellFlagsToItemAttributes(
    CListCtrl* pListCtrl,
    int iItem,
    DWORD dwAttributes
);
virtual void MapShellFlagsToItemAttributes(
    CTreeCtrl* pTreeCtrl,
    HTREEITEM hItem,
    DWORD dwAttributes
);
Parameters

pListCtrl
List Control that owns an item
iItem
Index to identify the item, passed verbatim to SetItemState()
dwAttributes
Shell attributes to translate
pTreeCtrl
Tree Control that owns an item
hItem
Handle to identify the item, passed verbatim to SetItemState()

Group

MapShellFlagsToItemAttributes Method


CXTShellPidl::OneUpPATH Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::OneUpPATH Method

This member function gets the parent folder using PIDLs.

CString OneUpPATH(
    const CString& path
);
Parameters

path
Path string.

Returns

A path string to the parent.

Group

CXTShellPidl Methods


CXTShellPidl::OneUpPIDL Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::OneUpPIDL Method

This member function performs the OneUp or back function.

LPITEMIDLIST OneUpPIDL(
    LPITEMIDLIST pidlPath
);
Parameters

pidlPath
Fully qualified PIDL.

Returns

A fully qualified parent PIDL.

Group

CXTShellPidl Methods


CXTShellPidl::OnShowContextMenu Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::OnShowContextMenu Method

This method is called when item of context menu was executed

virtual void OnShowContextMenu(
    int idCmd,
    CMINVOKECOMMANDINFO& cmi
);
Parameters

idCmd
Item identifier was executed.
cmi
CMINVOKECOMMANDINFO structure reference contained additional information about item was executed.

Group

CXTShellPidl Methods


ShowContextMenu Method

CXTShellPidl Methods
ShowContextMenu Method
Overload List
Methods
Method | Description
CXTShellPidl::ShowContextMenu (HWND, LPSHELLFOLDER, LPCITEMIDLIST*, int, LPPOINT) | This member function displays a popup context menu if given a parent shell folder, relative item ID, and screen location.
CXTShellPidl::ShowContextMenu (HWND, LPSHELLFOLDER, LPITEMIDLIST, LPPOINT) | This member function displays a popup context menu if given a parent shell folder, relative item ID, and screen location.
Group

CXTShellPidl Methods


CXTShellPidl::ShowContextMenu Method (HWND, LPSHELLFOLDER, LPITEMIDLIST, LPPOINT)

ShowContextMenu Method, CXTShellPidl Class
CXTShellPidl::ShowContextMenu Method (HWND, LPSHELLFOLDER, LPITEMIDLIST, LPPOINT)

This member function displays a popup context menu if given a parent shell folder, relative item ID, and screen location.

BOOL ShowContextMenu(
    HWND hwnd,
    LPSHELLFOLDER lpsfParent,
    LPITEMIDLIST lpi,
    LPPOINT lppt
);
BOOL ShowContextMenu(
    HWND hwnd,
    LPSHELLFOLDER lpsfParent,
    LPCITEMIDLIST* lppi,
    int nCount,
    LPPOINT lppt
);
Parameters

hwnd
Context menu owner.
lpsfParent
Pointer to the parent shell folder.
lpi
Pointer to the item ID that is relative to 'lpsfParent'.
lppt
Screen location of where to popup the menu.
lppi
Pointer to the item ID that is relative to 'lpsfParent'.
nCount
Number of PIDLs.

Returns

TRUE on success, or FALSE on failure.

Group

ShowContextMenu Method


CXTShellPidl::ShowShellLinkIcons Method

CXTShellPidl Methods, CXTShellPidl Class, Body Source
CXTShellPidl::ShowShellLinkIcons Method
void ShowShellLinkIcons(
    BOOL bShowLinkIcons = TRUE
);
Parameters

bShowLinkIcons
= TRUE

Body Source
void CXTShellPidl::ShowShellLinkIcons(BOOL bShowLinkIcons /*= TRUE*/) {
    m_bShowShellLinkIcons = bShowLinkIcons;
}
Group

CXTShellPidl Methods


CXTShellPidl::TreeViewCompareProc Method

CXTShellPidl Methods, CXTShellPidl Class
CXTShellPidl::TreeViewCompareProc Method

CXTShellTreeCtrl callback sort function.

static int CALLBACK TreeViewCompareProc(
    LPARAM lparam1,
    LPARAM lparam2,
    LPARAM lparamSort
);
Parameters

lparam1
Corresponds to the lParam member of the TV_ITEM structure for the two items being compared.
lparam2
Corresponds to the lParam member of the TV_ITEM structure for the two items being compared.
lparamSort
The 'lParamSort' member corresponds to the lParam member of TV_SORTCB.

Returns

A negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.

Remarks

This member function is a callback function used by CXTShellTreeCtrl and CXTShellTreeView, and is called during a sort operation each time the relative order of two list items needs to be compared.

Group

CXTShellPidl Methods


CXTShellPidl Constructors

CXTShellPidl Class, Legend, Public Methods
CXTShellPidl Constructors
Class

CXTShellPidl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellPidl | Constructs a CXTShellPidl object


CXTShellPidl::CXTShellPidl Constructor

CXTShellPidl Constructors, CXTShellPidl Class
CXTShellPidl::CXTShellPidl Constructor

Constructs a CXTShellPidl object

CXTShellPidl();
Group

CXTShellPidl Constructors


CXTShellPidl Destructors

CXTShellPidl Class, Legend, Public Methods
CXTShellPidl Destructors
Class

CXTShellPidl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellPidl | Destroys a CXTShellPidl object, handles cleanup and deallocation


CXTShellPidl::~CXTShellPidl Destructor

CXTShellPidl Destructors, CXTShellPidl Class
CXTShellPidl::~CXTShellPidl Destructor

Destroys a CXTShellPidl object, handles cleanup and deallocation

virtual ~CXTShellPidl();
Group

CXTShellPidl Destructors


CXTShellSettings Class

XTShellSettings.h, Classes, Legend, Members, Topics, CXTShellSettings Methods, CXTShellSettings Constructors, CXTShellSettings Destructors, CXTShellSettings Constructors, CXTShellSettings Destructors, CXTShellSettings Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings Class

CXTShellSettings is a SHELLFLAGSTATE struct derived class. CXTShellSettings extends the SHELLFLAGSTATE struct for easy access to the shell flag state settings.

Class Hierarchy

class CXTShellSettings : public SHELLFLAGSTATE;
File

XTShellSettings.h

Group

Classes

Legend
Method
CXTShellSettings Constructors
CXTShellSettings Constructors | Description
CXTShellSettings | Constructs a CXTShellSettings object
CXTShellSettings Destructors
CXTShellSettings Destructors | Description
~CXTShellSettings | Destroys a CXTShellSettings object, handles cleanup and deallocation
CXTShellSettings Methods
CXTShellSettings Methods | Description
AllowUpperCase | This member function checks whether or not the Allow All Uppercase Names option is enabled.
DoubleClickOpen | This member function checks whether or not the Double-Click to Open an Item option is enabled.
HTMLDesktop | This member function checks whether or not the Active Desktop - View as Web Page option is enabled.
NoConfirmRecycle | This member function checks to see if the Display Delete Confirmation Dialog box in the Recycle Bin is enabled.
ShowAllFiles | This member function checks whether or not the Show All Files option is enabled.
ShowAttributes | This member function checks whether or not the Show File Attributes in Detail View option is enabled.
ShowCompColor | This member function checks whether or not the Display Compressed Files and Folders with Alternate Color option is enabled.
ShowExtensions | This member function checks whether or not the Hide File Extensions for Known File Types option is disabled.
ShowInfoTips | This member function checks whether or not the Show Info Tips for Items in Folders & Desktop option is enabled.
ShowMapNetworkDrive | This member function checks whether or not the Show Map Network Drive Button in Toolbar option is enabled.
ShowSysFiles | This member function checks whether or not the Do Not Show Hidden Files option is selected.
Win95Classic | This member function checks whether or not the Classic Style option is enabled.


CXTShellSettings Methods

CXTShellSettings Class, Legend, Public Methods
CXTShellSettings Methods
Class

CXTShellSettings Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AllowUpperCase | This member function checks whether or not the Allow All Uppercase Names option is enabled.
DoubleClickOpen | This member function checks whether or not the Double-Click to Open an Item option is enabled.
HTMLDesktop | This member function checks whether or not the Active Desktop - View as Web Page option is enabled.
NoConfirmRecycle | This member function checks to see if the Display Delete Confirmation Dialog box in the Recycle Bin is enabled.
ShowAllFiles | This member function checks whether or not the Show All Files option is enabled.
ShowAttributes | This member function checks whether or not the Show File Attributes in Detail View option is enabled.
ShowCompColor | This member function checks whether or not the Display Compressed Files and Folders with Alternate Color option is enabled.
ShowExtensions | This member function checks whether or not the Hide File Extensions for Known File Types option is disabled.
ShowInfoTips | This member function checks whether or not the Show Info Tips for Items in Folders & Desktop option is enabled.
ShowMapNetworkDrive | This member function checks whether or not the Show Map Network Drive Button in Toolbar option is enabled.
ShowSysFiles | This member function checks whether or not the Do Not Show Hidden Files option is selected.
Win95Classic | This member function checks whether or not the Classic Style option is enabled.


CXTShellSettings::AllowUpperCase Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::AllowUpperCase Method

This member function checks whether or not the Allow All Uppercase Names option is enabled.

bool AllowUpperCase();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::AllowUpperCase() {
    return fDontPrettyPath != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::DoubleClickOpen Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::DoubleClickOpen Method

This member function checks whether or not the Double-Click to Open an Item option is enabled.

bool DoubleClickOpen();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::DoubleClickOpen() {
    return fDoubleClickInWebView != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::HTMLDesktop Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::HTMLDesktop Method

This member function checks whether or not the Active Desktop - View as Web Page option is enabled.

bool HTMLDesktop();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::HTMLDesktop() {
    return fDesktopHTML != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::NoConfirmRecycle Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::NoConfirmRecycle Method

This member function checks to see if the Display Delete Confirmation Dialog box in the Recycle Bin is enabled.

bool NoConfirmRecycle();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::NoConfirmRecycle() {
    return fNoConfirmRecycle != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::ShowAllFiles Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::ShowAllFiles Method

This member function checks whether or not the Show All Files option is enabled.

bool ShowAllFiles();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::ShowAllFiles() {
    return fShowAllObjects != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::ShowAttributes Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::ShowAttributes Method

This member function checks whether or not the Show File Attributes in Detail View option is enabled.

bool ShowAttributes();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::ShowAttributes() {
    return fShowAttribCol != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::ShowCompColor Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::ShowCompColor Method

This member function checks whether or not the Display Compressed Files and Folders with Alternate Color option is enabled.

bool ShowCompColor();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::ShowCompColor() {
    return fShowCompColor != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::ShowExtensions Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::ShowExtensions Method

This member function checks whether or not the Hide File Extensions for Known File Types option is disabled.

bool ShowExtensions();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::ShowExtensions() {
    return fShowExtensions != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::ShowInfoTips Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::ShowInfoTips Method

This member function checks whether or not the Show Info Tips for Items in Folders & Desktop option is enabled.

bool ShowInfoTips();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::ShowInfoTips() {
    return fShowInfoTip != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::ShowMapNetworkDrive Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::ShowMapNetworkDrive Method

This member function checks whether or not the Show Map Network Drive Button in Toolbar option is enabled.

bool ShowMapNetworkDrive();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::ShowMapNetworkDrive() {
    return fMapNetDrvBtn != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::ShowSysFiles Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::ShowSysFiles Method

This member function checks whether or not the Do Not Show Hidden Files option is selected.

bool ShowSysFiles();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::ShowSysFiles() {
    return fShowSysFiles != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings::Win95Classic Method

CXTShellSettings Methods, CXTShellSettings Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellSettings::Win95Classic Method

This member function checks whether or not the Classic Style option is enabled.

bool Win95Classic();
Returns

true if enabled, otherwise returns false.

Body Source
bool CXTShellSettings::Win95Classic() {
    return fWin95Classic != 0 ? true : false;
}
Group

CXTShellSettings Methods


CXTShellSettings Constructors

CXTShellSettings Class, Legend, Public Methods
CXTShellSettings Constructors
Class

CXTShellSettings Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellSettings | Constructs a CXTShellSettings object


CXTShellSettings::CXTShellSettings Constructor

CXTShellSettings Constructors, CXTShellSettings Class
CXTShellSettings::CXTShellSettings Constructor

Constructs a CXTShellSettings object

CXTShellSettings();
Group

CXTShellSettings Constructors


CXTShellSettings Destructors

CXTShellSettings Class, Legend, Public Methods
CXTShellSettings Destructors
Class

CXTShellSettings Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellSettings | Destroys a CXTShellSettings object, handles cleanup and deallocation


CXTShellSettings::~CXTShellSettings Destructor

CXTShellSettings Destructors, CXTShellSettings Class
CXTShellSettings::~CXTShellSettings Destructor

Destroys a CXTShellSettings object, handles cleanup and deallocation

~CXTShellSettings();
Group

CXTShellSettings Destructors


CXTShellTreeBase Class

XTShellTreeBase.h, Classes, Legend, Members, Topics, CXTShellTreeBase Data Members, CXTShellTreeBase Methods, CXTShellTreeBase Constructors, CXTShellTreeBase Destructors, CXTShellTreeBase Constructors, CXTShellTreeBase Data Members, CXTShellTreeBase Destructors, CXTShellTreeBase Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeBase Class

CXTShellTreeBase is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeBase class object.

Class Hierarchy

class CXTShellTreeBase : public CXTTreeBase, public CXTShellPidl;
File

XTShellTreeBase.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTShellTreeBase Constructors
CXTShellTreeBase Constructors | Description
CXTShellTreeBase | Constructs a CXTShellTreeBase object
CXTShellTreeBase Data Members
CXTShellTreeBase Data Members | Description
m_bContextMenu | TRUE to display the shell context menu on right item click.
m_bShowFiles | FALSE to show only directories
m_bTunneling | true if tree is currently traversing.
m_nRootFolder | Root Folder CSIDL
m_pComboBox | CComboBox that is associated with this control.
m_shSettings | Contains SHELLFLAGSTATE info.
m_uFlags | Flags indicating which items to include in the enumeration.
CXTShellTreeBase Destructors
CXTShellTreeBase Destructors | Description
~CXTShellTreeBase | Destroys a CXTShellTreeBase object, handles cleanup and deallocation
CXTShellTreeBase Methods
CXTShellTreeBase Methods | Description
AssociateCombo | This member function is used to associate a CComboBox object with the control. Whenever the path changes, the combo is updated.
BeginDrag | Used by the shell list control to handle a drag event.
EnableContextMenu | Call this member function to enable or disable the display of the shell context menu on right item click.
FindTreeItem | This member function recursively searches the tree control beginning at 'hItem' to find the item specified by 'lplvid'. This is typically used when the user double clicks an item in the list view.
GetContextMenu | This member function displays the system popup menu for the selected item or folder.
GetFolderItemPath | This member function retrieves the path of a folder item, which does not have to be selected. Pass a CString object that will hold the folder path.
GetNormalAndSelectedIcons | This member function gets the index for the normal and selected icons for the current item.
GetSelectedFolderPath | This member function retrieves the path of the currently selected tree item.
InitializeTree | Call this member function to initialize the shell tree control prior to calling PopulateTree.
InitSystemImageLists | This member function obtains a handle to the system image list and attaches it to the tree control.
InitTreeNode | This member function is called to initialize a branch of the shell tree.
InitTreeViewItems | This member function fills a branch of the TreeView control. Given the shell folder, it enumerates the subitems of this folder and adds the appropriate items to the tree.
InsertDesktopItem | This member function is called to insert the Desktop as the root item in the shell tree control.
OnFolderExpanding | This member function responds to a TVN_ITEMEXPANDING message in order to fill up subdirectories.
OnFolderSelected | This member function responds to a TVN_SELCHANGED message to retrieve the specified folder path.
PathFindNextComponent | Parses a path for the next path component.
PopulateTree | This member function populates a tree based upon a path. You must call InitializeTree() before populating the tree for the first time.
PopulateTreeView | This member function adds items to the tree view.
SearchTree | This member function searches the tree for a specified folder.
SelectionChanged | Called after a user makes a new tree selection.
SetAttributes | This member function sets the shell attribute flags for the specified tree item.
SetEnumFlags | Call this member function to determine the type of items included in the shell enumeration. The default is SHCONTF_FOLDERS | SHCONTF_NONFOLDERS.
SetRootFolder | Call this member to set root CSIDL folder.
ShowFiles | Call this member to show all files instead of only folders
SortChildren | Sorts items in the control using the provided callback function.
TunnelTree | This member function will "tunnel" the tree to find the specified path. This will work only when the PopulateTreeView() method is used to populate the tree.


CXTShellTreeBase Data Members

CXTShellTreeBase Class, Legend, Protected Data Members
CXTShellTreeBase Data Members
Class

CXTShellTreeBase Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bContextMenu | TRUE to display the shell context menu on right item click.
m_bShowFiles | FALSE to show only directories
m_bTunneling | true if tree is currently traversing.
m_nRootFolder | Root Folder CSIDL
m_pComboBox | CComboBox that is associated with this control.
m_shSettings | Contains SHELLFLAGSTATE info.
m_uFlags | Flags indicating which items to include in the enumeration.


CXTShellTreeBase::m_bContextMenu Data Member

CXTShellTreeBase Data Members, CXTShellTreeBase Class
CXTShellTreeBase::m_bContextMenu Data Member

TRUE to display the shell context menu on right item click.

BOOL m_bContextMenu;
Group

CXTShellTreeBase Data Members


CXTShellTreeBase::m_bShowFiles Data Member

CXTShellTreeBase Data Members, CXTShellTreeBase Class
CXTShellTreeBase::m_bShowFiles Data Member

FALSE to show only directories

BOOL m_bShowFiles;
Group

CXTShellTreeBase Data Members


CXTShellTreeBase::m_bTunneling Data Member

CXTShellTreeBase Data Members, CXTShellTreeBase Class
CXTShellTreeBase::m_bTunneling Data Member

true if tree is currently traversing.

bool m_bTunneling;
Group

CXTShellTreeBase Data Members


CXTShellTreeBase::m_nRootFolder Data Member

CXTShellTreeBase Data Members, CXTShellTreeBase Class
CXTShellTreeBase::m_nRootFolder Data Member

Root Folder CSIDL

int m_nRootFolder;
Group

CXTShellTreeBase Data Members


CXTShellTreeBase::m_pComboBox Data Member

CXTShellTreeBase Data Members, CXTShellTreeBase Class
CXTShellTreeBase::m_pComboBox Data Member

CComboBox that is associated with this control.

CWnd* m_pComboBox;
Group

CXTShellTreeBase Data Members


CXTShellTreeBase::m_shSettings Data Member

CXTShellTreeBase Data Members, CXTShellTreeBase Class
CXTShellTreeBase::m_shSettings Data Member

Contains SHELLFLAGSTATE info.

CXTShellSettings m_shSettings;
Group

CXTShellTreeBase Data Members


CXTShellTreeBase::m_uFlags Data Member

CXTShellTreeBase Data Members, CXTShellTreeBase Class
CXTShellTreeBase::m_uFlags Data Member

Flags indicating which items to include in the enumeration.

UINT m_uFlags;
Group

CXTShellTreeBase Data Members


CXTShellTreeBase Methods

CXTShellTreeBase Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeBase Methods
Class

CXTShellTreeBase Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetNormalAndSelectedIcons | This member function gets the index for the normal and selected icons for the current item.
InitTreeViewItems | This member function fills a branch of the TreeView control. Given the shell folder, it enumerates the subitems of this folder and adds the appropriate items to the tree.
PathFindNextComponent | Parses a path for the next path component.
SetAttributes | This member function sets the shell attribute flags for the specified tree item.
SortChildren | Sorts items in the control using the provided callback function.
Public Methods
Public Methods
Public Method | Description
AssociateCombo | This member function is used to associate a CComboBox object with the control. Whenever the path changes, the combo is updated.
BeginDrag | Used by the shell list control to handle a drag event.
EnableContextMenu | Call this member function to enable or disable the display of the shell context menu on right item click.
FindTreeItem | This member function recursively searches the tree control beginning at 'hItem' to find the item specified by 'lplvid'. This is typically used when the user double clicks an item in the list view.
GetContextMenu | This member function displays the system popup menu for the selected item or folder.
GetFolderItemPath | This member function retrieves the path of a folder item, which does not have to be selected. Pass a CString object that will hold the folder path.
GetSelectedFolderPath | This member function retrieves the path of the currently selected tree item.
InitializeTree | Call this member function to initialize the shell tree control prior to calling PopulateTree.
InitSystemImageLists | This member function obtains a handle to the system image list and attaches it to the tree control.
InitTreeNode | This member function is called to initialize a branch of the shell tree.
InsertDesktopItem | This member function is called to insert the Desktop as the root item in the shell tree control.
OnFolderExpanding | This member function responds to a TVN_ITEMEXPANDING message in order to fill up subdirectories.
OnFolderSelected | This member function responds to a TVN_SELCHANGED message to retrieve the specified folder path.
PopulateTree | This member function populates a tree based upon a path. You must call InitializeTree() before populating the tree for the first time.
PopulateTreeView | This member function adds items to the tree view.
SearchTree | This member function searches the tree for a specified folder.
SelectionChanged | Called after a user makes a new tree selection.
SetEnumFlags | Call this member function to determine the type of items included in the shell enumeration. The default is SHCONTF_FOLDERS | SHCONTF_NONFOLDERS.
SetRootFolder | Call this member to set root CSIDL folder.
ShowFiles | Call this member to show all files instead of only folders
TunnelTree | This member function will "tunnel" the tree to find the specified path. This will work only when the PopulateTreeView() method is used to populate the tree.


CXTShellTreeBase::AssociateCombo Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::AssociateCombo Method

This member function is used to associate a CComboBox object with the control. Whenever the path changes, the combo is updated.

virtual void AssociateCombo(
    CWnd* pWnd
);
Parameters

pWnd
Points to the combo box that is associated with the tree.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::BeginDrag Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::BeginDrag Method

Used by the shell list control to handle a drag event.

virtual void BeginDrag(
    NM_TREEVIEW* pNMTreeView
);
Parameters

pNMTreeView
Points to a NM_TREEVIEW structure.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::EnableContextMenu Method

CXTShellTreeBase Methods, CXTShellTreeBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeBase::EnableContextMenu Method

Call this member function to enable or disable the display of the shell context menu on right item click.

void EnableContextMenu(
    BOOL bEnable
);
Parameters

bEnable
TRUE to display a context menu.

Body Source
void CXTShellTreeBase::EnableContextMenu(BOOL bEnable) {
    m_bContextMenu = bEnable;
}
Group

CXTShellTreeBase Methods


CXTShellTreeBase::FindTreeItem Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::FindTreeItem Method

This member function recursively searches the tree control beginning at 'hItem' to find the item specified by 'lplvid'. This is typically used when the user double clicks an item in the list view.

virtual BOOL FindTreeItem(
    HTREEITEM hItem,
    XT_LVITEMDATA* lplvid,
    BOOL bRecursively = TRUE
);
Parameters

hItem
Handle to the tree item to search from.
lplvid
Pointer to the list view item data.
bRecursively
TURE to recursively search.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::GetContextMenu Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::GetContextMenu Method

This member function displays the system popup menu for the selected item or folder.

virtual HTREEITEM GetContextMenu();
Returns

A handle to the currently selected HTREEITEM.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::GetFolderItemPath Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::GetFolderItemPath Method

This member function retrieves the path of a folder item, which does not have to be selected. Pass a CString object that will hold the folder path.

virtual BOOL GetFolderItemPath(
    HTREEITEM hItem,
    CString & strFolderPath
);
Parameters

hItem
Tree item to get the path for.
strFolderPath
Reference to a CString object to contain the folder path.

Returns

TRUE if the path is not in the file system (e.g. MyComputer); if none is selected, it returns FALSE.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::GetNormalAndSelectedIcons Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::GetNormalAndSelectedIcons Method

This member function gets the index for the normal and selected icons for the current item.

virtual void GetNormalAndSelectedIcons(
    LPITEMIDLIST lpifq,
    LPTV_ITEM lptvitem
);
Parameters

lpifq
Fully qualified item ID list for the current item.
lptvitem
Pointer to the tree view item being added to the tree.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::GetSelectedFolderPath Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::GetSelectedFolderPath Method

This member function retrieves the path of the currently selected tree item.

virtual BOOL GetSelectedFolderPath(
    CString& strFolderPath
);
Parameters

strFolderPath
Address of a CString object to receive the file system path.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::InitializeTree Method

CXTShellTreeBase Methods, CXTShellTreeBase Class, See Also
CXTShellTreeBase::InitializeTree Method

Call this member function to initialize the shell tree control prior to calling PopulateTree.

virtual BOOL InitializeTree(
    DWORD dwStyle = TVS_HASBUTTONS | TVS_HASLINES | TVS_LINESATROOT
);
Parameters

dwStyle
TVS_ style flags for tree control.

Returns

TRUE if successful, otherwise returns FALSE.

See Also

PopulateTree()

Group

CXTShellTreeBase Methods


CXTShellTreeBase::InitSystemImageLists Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::InitSystemImageLists Method

This member function obtains a handle to the system image list and attaches it to the tree control.

virtual BOOL InitSystemImageLists();
Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::InitTreeNode Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::InitTreeNode Method

This member function is called to initialize a branch of the shell tree.

virtual void InitTreeNode(
    HTREEITEM hItem,
    XT_TVITEMDATA* lptvid
);
Parameters

hItem
Handle to a tree node.
lptvid
Pointer to the list view item data.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::InitTreeViewItems Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::InitTreeViewItems Method

This member function fills a branch of the TreeView control. Given the shell folder, it enumerates the subitems of this folder and adds the appropriate items to the tree.

virtual BOOL InitTreeViewItems(
    LPSHELLFOLDER lpsf,
    LPITEMIDLIST lpifq,
    HTREEITEM hParent
);
Parameters

lpsf
Pointer to the parent shell folder.
lpifq
Fully qualified item ID list to the item having items enumerated. This is the PIDL to the item identified by the 'lpsf' parameter.
hParent
Parent tree node.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::InsertDesktopItem Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::InsertDesktopItem Method

This member function is called to insert the Desktop as the root item in the shell tree control.

virtual HTREEITEM InsertDesktopItem(
    int nFolder = CSIDL_DESKTOP
);
Parameters

nFolder
Root folder CSIDL to insert.

Returns

A handle to the desktop tree item if successful, otherwise NULL.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::OnFolderExpanding Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::OnFolderExpanding Method

This member function responds to a TVN_ITEMEXPANDING message in order to fill up subdirectories.

virtual void OnFolderExpanding(
    NM_TREEVIEW* pNMTreeView
);
Parameters

pNMTreeView
Address of an NM_TREEVIEW struct.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::OnFolderSelected Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::OnFolderSelected Method

This member function responds to a TVN_SELCHANGED message to retrieve the specified folder path.

virtual BOOL OnFolderSelected(
    NM_TREEVIEW* pNMTreeView,
    CString& strFolderPath
);
Parameters

pNMTreeView
Address of an NM_TREEVIEW struct.
strFolderPath
Address of a CString object to receive the file system path.

Returns

TRUE if the folder path was found, otherwise returns FALSE.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::PathFindNextComponent Method

CXTShellTreeBase Methods, CXTShellTreeBase Class, Example
CXTShellTreeBase::PathFindNextComponent Method

Parses a path for the next path component.

CString PathFindNextComponent(
    const CString& pszPath
);
Parameters

pszPath
Pointer to a NULL-terminated string with the path. Paths are delimited by backslashes or by the NULL at the end of the path.

Returns

A pointer to a NULL-terminated string with the next path component if successful, or NULL otherwise.

Remarks

This member function parses a path for the next path component, not dependent on shell32.dll, and is a replacement for the windows API PathFindNextComponent.

Example

The following example demonstrates using the XTFuncPathFindNextComponent function.

// Path to find the next part.
char buffer_1[ ] = "c:\\path1\\path2\\test";
char *lpStr1;
lpStr1 = buffer_1;

cout << "Search a path for the next path component "
     << "after the root " << lpStr1 << endl;
cout << "Return the next path component: \""
     <<  XTFuncPathFindNextComponent(lpStr1) << "\"" << endl;

cout << "\nSearch a path for the next path component "
     << "after the root \"c:\\path1\\path2\"" << endl;
cout << "Return the next path component: \""
     <<  XTFuncPathFindNextComponent("c:\\path1\\path2") << "\"" << endl;

cout << "\nSearch a path for the next path component "
     << "after the root \"c:\\path1\"" << endl;
cout << "Return the next path component: \""
     <<  XTFuncPathFindNextComponent("c:\\path1") << "\"" << endl;

OUTPUT:
===========
Search a path for the next path component after the root c:\path1\path2\test
Return the next path component: "path1\path2\test"

Search a path for the next path component after the root "c:\path1\path2"
Return the next path component: "path1\path2"

Search a path for the next path component after the root "c:\path1"
Return the next path component: "path1"
Group

CXTShellTreeBase Methods


CXTShellTreeBase::PopulateTree Method

CXTShellTreeBase Methods, CXTShellTreeBase Class, See Also
CXTShellTreeBase::PopulateTree Method

This member function populates a tree based upon a path. You must call InitializeTree() before populating the tree for the first time.

virtual void PopulateTree(
    LPCTSTR lpszPath
);
Parameters

lpszPath
Path to populate.

See Also

InitializeTree()

Group

CXTShellTreeBase Methods


CXTShellTreeBase::PopulateTreeView Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::PopulateTreeView Method

This member function adds items to the tree view.

virtual void PopulateTreeView();
Group

CXTShellTreeBase Methods


CXTShellTreeBase::SearchTree Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::SearchTree Method

This member function searches the tree for a specified folder.

virtual HTREEITEM SearchTree(
    HTREEITEM hItem,
    LPCITEMIDLIST pABSPidl
);
Parameters

hItem
Tree item to begin the search from.
pABSPidl
pidl we're looking to match

Returns

HTREEITEM of node in tree that resulted in a match.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::SelectionChanged Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::SelectionChanged Method

Called after a user makes a new tree selection.

virtual void SelectionChanged(
    HTREEITEM hItem,
    CString strFolderPath
);
Parameters

hItem
Handle to the newly selected tree item.
strFolderPath
NULL terminated string representing the fully qualified path to the selected tree item.

Remarks

This member function is called whenever a user makes a selection within the tree control to synchronize any shell list or shell combo boxes associated with the tree. You can override this member to provide additional functionality.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::SetAttributes Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::SetAttributes Method

This member function sets the shell attribute flags for the specified tree item.

void SetAttributes(
    HTREEITEM hItem,
    DWORD dwAttributes
);
Parameters

hItem
Handle to HTREEITEM node.
dwAttributes
Flags retrieved from SHELLFOLDER::GetAttributesOf.

Group

CXTShellTreeBase Methods


CXTShellTreeBase::SetEnumFlags Method

CXTShellTreeBase Methods, CXTShellTreeBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeBase::SetEnumFlags Method

Call this member function to determine the type of items included in the shell enumeration. The default is SHCONTF_FOLDERS | SHCONTF_NONFOLDERS.

void SetEnumFlags(
    UINT uFlags
);
Parameters

uFlags
Determines the type of items included in an enumeration. It can be one or more of the values listed in the Remarks section.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • SHCONTF_FOLDERS Include items that are folders in the enumeration.
  • SHCONTF_NONFOLDERS Include items that are not folders in the enumeration.
  • SHCONTF_INCLUDEHIDDEN Include hidden items in the enumeration.
  • SHCONTF_INIT_ON_FIRST_NEXT IShellFolder::EnumObjects can return without validating the enumeration object. Validation can be postponed until the first call to IEnumIDList::Next. This flag is intended to be used when a user interface may be displayed prior to the first IEnumIDList::Next call. For a user interface to be presented, 'hwndOwner' must be set to a valid window handle.
  • SHCONTF_NETPRINTERSRCH The caller is looking for printer objects.
Body Source
void CXTShellTreeBase::SetEnumFlags(UINT uFlags) {
    m_uFlags = uFlags;
}
Group

CXTShellTreeBase Methods


CXTShellTreeBase::SetRootFolder Method

CXTShellTreeBase Methods, CXTShellTreeBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeBase::SetRootFolder Method

Call this member to set root CSIDL folder.

void SetRootFolder(
    int nRootFolder = CSIDL_DESKTOP
);
Parameters

nRootFolder
Root folder of tree view.

Body Source
void CXTShellTreeBase::SetRootFolder(int nRootFolder /*= CSIDL_DESKTOP*/) {
    m_nRootFolder = nRootFolder;
}
Group

CXTShellTreeBase Methods


CXTShellTreeBase::ShowFiles Method

CXTShellTreeBase Methods, CXTShellTreeBase Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeBase::ShowFiles Method

Call this member to show all files instead of only folders

void ShowFiles(
    BOOL bShowFiles = TRUE
);
Parameters

bShowFiles
TRUE to show folder's files

Body Source
void CXTShellTreeBase::ShowFiles(BOOL bShowFiles /*= TRUE*/) {
    m_bShowFiles = bShowFiles;
}
Group

CXTShellTreeBase Methods


CXTShellTreeBase::SortChildren Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::SortChildren Method

Sorts items in the control using the provided callback function.

virtual void SortChildren(
    HTREEITEM hParent
);
Parameters

hParent
Parent item to sort

Group

CXTShellTreeBase Methods


CXTShellTreeBase::TunnelTree Method

CXTShellTreeBase Methods, CXTShellTreeBase Class
CXTShellTreeBase::TunnelTree Method

This member function will "tunnel" the tree to find the specified path. This will work only when the PopulateTreeView() method is used to populate the tree.

virtual BOOL TunnelTree(
    CString strFindPath
);
Parameters

strFindPath
Path to find.

Group

CXTShellTreeBase Methods


CXTShellTreeBase Constructors

CXTShellTreeBase Class, Legend, Public Methods
CXTShellTreeBase Constructors
Class

CXTShellTreeBase Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellTreeBase | Constructs a CXTShellTreeBase object


CXTShellTreeBase::CXTShellTreeBase Constructor

CXTShellTreeBase Constructors, CXTShellTreeBase Class
CXTShellTreeBase::CXTShellTreeBase Constructor

Constructs a CXTShellTreeBase object

CXTShellTreeBase();
Group

CXTShellTreeBase Constructors


CXTShellTreeBase Destructors

CXTShellTreeBase Class, Legend, Public Methods
CXTShellTreeBase Destructors
Class

CXTShellTreeBase Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellTreeBase | Destroys a CXTShellTreeBase object, handles cleanup and deallocation


CXTShellTreeBase::~CXTShellTreeBase Destructor

CXTShellTreeBase Destructors, CXTShellTreeBase Class
CXTShellTreeBase::~CXTShellTreeBase Destructor

Destroys a CXTShellTreeBase object, handles cleanup and deallocation

virtual ~CXTShellTreeBase();
Group

CXTShellTreeBase Destructors


CXTShellTreeCtrl Class

XTShellTreeCtrlView.h, Classes, Legend, Members, Topics, CXTShellTreeCtrl Data Members, CXTShellTreeCtrl Methods, CXTShellTreeCtrl Constructors, CXTShellTreeCtrl Destructors, CXTShellTreeCtrl Constructors, CXTShellTreeCtrl Data Members, CXTShellTreeCtrl Destructors, CXTShellTreeCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeCtrl Class

CXTShellTreeCtrl is a multiple inheritance class derived from CXTTreeCtrl and CXTShellPidl. CXTShellTreeCtrl is used to create a tree control that displays an explorer style tree, and can be associated with a combo box and list control.

Class Hierarchy

class CXTShellTreeCtrl : public CXTShellTreeCtrlBase;
File

XTShellTreeCtrlView.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTShellTreeCtrl Constructors
CXTShellTreeCtrl Constructors | Description
CXTShellTreeCtrl | Constructs a CXTShellTreeCtrl object
CXTShellTreeCtrl Data Members
CXTShellTreeCtrl Data Members | Description
m_bAutoInit | TRUE if the tree control is to initialize when created.
m_pListCtrl | Window that receives the update notification, usually a CXTShellListCtrl.
CXTShellTreeCtrl Destructors
CXTShellTreeCtrl Destructors | Description
~CXTShellTreeCtrl | Destroys a CXTShellTreeCtrl object, handles cleanup and deallocation
CXTShellTreeCtrl Methods
CXTShellTreeCtrl Methods | Description
AssociateCombo | This member function is used to associate a CComboBox object with the control. Whenever the path changes, the combo is updated.
AssociateList | Call this member function to associate the list control with the tree.
EnableAutoInit | Call this member function to enable or disable auto-initialization of the shell tree control.
Init | This member function is called by the CInitialize class to perform initialization when the window is created or sub-classed.
SelectionChanged | Called after a user makes a new tree selection.


CXTShellTreeCtrl Data Members

CXTShellTreeCtrl Class, Legend, Protected Data Members
CXTShellTreeCtrl Data Members
Class

CXTShellTreeCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoInit | TRUE if the tree control is to initialize when created.
m_pListCtrl | Window that receives the update notification, usually a CXTShellListCtrl.


CXTShellTreeCtrl::m_bAutoInit Data Member

CXTShellTreeCtrl Data Members, CXTShellTreeCtrl Class
CXTShellTreeCtrl::m_bAutoInit Data Member

TRUE if the tree control is to initialize when created.

BOOL m_bAutoInit;
Group

CXTShellTreeCtrl Data Members


CXTShellTreeCtrl::m_pListCtrl Data Member

CXTShellTreeCtrl Data Members, CXTShellTreeCtrl Class
CXTShellTreeCtrl::m_pListCtrl Data Member

Window that receives the update notification, usually a CXTShellListCtrl.

CWnd* m_pListCtrl;
Group

CXTShellTreeCtrl Data Members


CXTShellTreeCtrl Methods

CXTShellTreeCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeCtrl Methods
Class

CXTShellTreeCtrl Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
SelectionChanged | Called after a user makes a new tree selection.
Public Methods
Public Methods
Public Method | Description
AssociateCombo | This member function is used to associate a CComboBox object with the control. Whenever the path changes, the combo is updated.
AssociateList | Call this member function to associate the list control with the tree.
EnableAutoInit | Call this member function to enable or disable auto-initialization of the shell tree control.
Init | This member function is called by the CInitialize class to perform initialization when the window is created or sub-classed.


CXTShellTreeCtrl::AssociateCombo Method

CXTShellTreeCtrl Methods, CXTShellTreeCtrl Class
CXTShellTreeCtrl::AssociateCombo Method

This member function is used to associate a CComboBox object with the control. Whenever the path changes, the combo is updated.

virtual void AssociateCombo(
    CWnd* pWnd
);
Parameters

pWnd
Points to the combo box that is associated with the tree.

Group

CXTShellTreeCtrl Methods


CXTShellTreeCtrl::AssociateList Method

CXTShellTreeCtrl Methods, CXTShellTreeCtrl Class
CXTShellTreeCtrl::AssociateList Method

Call this member function to associate the list control with the tree.

virtual void AssociateList(
    CWnd* pWnd
);
Parameters

pWnd
Points to the list control that is associated with the tree.

Group

CXTShellTreeCtrl Methods


CXTShellTreeCtrl::EnableAutoInit Method

CXTShellTreeCtrl Methods, CXTShellTreeCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeCtrl::EnableAutoInit Method

Call this member function to enable or disable auto-initialization of the shell tree control.

void EnableAutoInit(
    BOOL bEnable
);
Parameters

bEnable
TRUE if the tree initializes upon creation.

Body Source
void CXTShellTreeCtrl::EnableAutoInit(BOOL bEnable) {
    m_bAutoInit = bEnable;
}
Group

CXTShellTreeCtrl Methods


CXTShellTreeCtrl::Init Method

CXTShellTreeCtrl Methods, CXTShellTreeCtrl Class
CXTShellTreeCtrl::Init Method

This member function is called by the CInitialize class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTShellTreeCtrl Methods


CXTShellTreeCtrl::SelectionChanged Method

CXTShellTreeCtrl Methods, CXTShellTreeCtrl Class
CXTShellTreeCtrl::SelectionChanged Method

Called after a user makes a new tree selection.

virtual void SelectionChanged(
    HTREEITEM hItem,
    CString strFolderPath
);
Parameters

hItem
Handle to the newly selected tree item.
strFolderPath
NULL terminated string representing the fully qualified path to the selected tree item.

Remarks

This member function is called whenever a user makes a selection within the tree control to synchronize any shell list or shell combo boxes associated with the tree. You can override this member to provide additional functionality.

Group

CXTShellTreeCtrl Methods


CXTShellTreeCtrl Constructors

CXTShellTreeCtrl Class, Legend, Public Methods
CXTShellTreeCtrl Constructors
Class

CXTShellTreeCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellTreeCtrl | Constructs a CXTShellTreeCtrl object


CXTShellTreeCtrl::CXTShellTreeCtrl Constructor

CXTShellTreeCtrl Constructors, CXTShellTreeCtrl Class
CXTShellTreeCtrl::CXTShellTreeCtrl Constructor

Constructs a CXTShellTreeCtrl object

CXTShellTreeCtrl();
Group

CXTShellTreeCtrl Constructors


CXTShellTreeCtrl Destructors

CXTShellTreeCtrl Class, Legend, Public Methods
CXTShellTreeCtrl Destructors
Class

CXTShellTreeCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellTreeCtrl | Destroys a CXTShellTreeCtrl object, handles cleanup and deallocation


CXTShellTreeCtrl::~CXTShellTreeCtrl Destructor

CXTShellTreeCtrl Destructors, CXTShellTreeCtrl Class
CXTShellTreeCtrl::~CXTShellTreeCtrl Destructor

Destroys a CXTShellTreeCtrl object, handles cleanup and deallocation

virtual ~CXTShellTreeCtrl();
Group

CXTShellTreeCtrl Destructors


CXTShellTreeView Class

XTShellTreeCtrlView.h, Classes, Legend, Members, Topics, CXTShellTreeView Methods, CXTShellTreeView Constructors, CXTShellTreeView Destructors, CXTShellTreeView Constructors, CXTShellTreeView Destructors, CXTShellTreeView Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTShellTreeView Class

CXTShellTreeView is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeView class object.

Class Hierarchy

class CXTShellTreeView : public CXTShellTreeViewBase;
File

XTShellTreeCtrlView.h

Group

Classes

Legend
Method
protected
virtual
CXTShellTreeView Constructors
CXTShellTreeView Constructors | Description
CXTShellTreeView | Constructs a CXTShellTreeView object
CXTShellTreeView Destructors
CXTShellTreeView Destructors | Description
~CXTShellTreeView | Destroys a CXTShellTreeView object, handles cleanup and deallocation
CXTShellTreeView Methods
CXTShellTreeView Methods | Description
SelectionChanged | Called after a user makes a new tree selection.


CXTShellTreeView Methods

CXTShellTreeView Class, Legend, Protected Methods
CXTShellTreeView Methods
Class

CXTShellTreeView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
SelectionChanged | Called after a user makes a new tree selection.


CXTShellTreeView::SelectionChanged Method

CXTShellTreeView Methods, CXTShellTreeView Class
CXTShellTreeView::SelectionChanged Method

Called after a user makes a new tree selection.

virtual void SelectionChanged(
    HTREEITEM hItem,
    CString strFolderPath
);
Parameters

hItem
Handle to the newly selected tree item.
strFolderPath
NULL terminated string representing the fully qualified path to the selected tree item.

Remarks

This member function is called whenever a user makes a selection within the tree control to synchronize any shell list or shell combo boxes associated with the tree. You can override this member to provide additional functionality.

Group

CXTShellTreeView Methods


CXTShellTreeView Constructors

CXTShellTreeView Class, Legend, Public Methods
CXTShellTreeView Constructors
Class

CXTShellTreeView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTShellTreeView | Constructs a CXTShellTreeView object


CXTShellTreeView::CXTShellTreeView Constructor

CXTShellTreeView Constructors, CXTShellTreeView Class
CXTShellTreeView::CXTShellTreeView Constructor

Constructs a CXTShellTreeView object

CXTShellTreeView();
Group

CXTShellTreeView Constructors


CXTShellTreeView Destructors

CXTShellTreeView Class, Legend, Public Methods
CXTShellTreeView Destructors
Class

CXTShellTreeView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTShellTreeView | Destroys a CXTShellTreeView object, handles cleanup and deallocation


CXTShellTreeView::~CXTShellTreeView Destructor

CXTShellTreeView Destructors, CXTShellTreeView Class
CXTShellTreeView::~CXTShellTreeView Destructor

Destroys a CXTShellTreeView object, handles cleanup and deallocation

virtual ~CXTShellTreeView();
Group

CXTShellTreeView Destructors


CXTSizeIcon Class

XTResize.h, Classes, Legend, Members, Topics, CXTSizeIcon Data Members, CXTSizeIcon Constructors, CXTSizeIcon Destructors, CXTSizeIcon Constructors, CXTSizeIcon Data Members, CXTSizeIcon Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSizeIcon Class

The CXTSizeIcon class is a CStatic derived helper class. It is used by CXTResize to display the sizing grip in the lower right corner of a sizing window.

Class Hierarchy

class CXTSizeIcon : public CScrollBar;
File

XTResize.h

Group

Classes

Legend
Data Member
protected
Constructor
virtual
CXTSizeIcon Constructors
CXTSizeIcon Constructors | Description
CXTSizeIcon | Constructs a CXTSizeIcon object
CXTSizeIcon Data Members
CXTSizeIcon Data Members | Description
m_hCursor | Handle to the cursor displayed for the size icon
CXTSizeIcon Destructors
CXTSizeIcon Destructors | Description
~CXTSizeIcon | Destroys a CXTSizeIcon object, handles cleanup and deallocation


CXTSizeIcon Data Members

CXTSizeIcon Class, Legend, Protected Data Members
CXTSizeIcon Data Members
Class

CXTSizeIcon Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hCursor | Handle to the cursor displayed for the size icon


CXTSizeIcon::m_hCursor Data Member

CXTSizeIcon Data Members, CXTSizeIcon Class
CXTSizeIcon::m_hCursor Data Member

Handle to the cursor displayed for the size icon

HCURSOR m_hCursor;
Group

CXTSizeIcon Data Members


CXTSizeIcon Constructors

CXTSizeIcon Class, Legend, Public Methods
CXTSizeIcon Constructors
Class

CXTSizeIcon Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTSizeIcon | Constructs a CXTSizeIcon object


CXTSizeIcon::CXTSizeIcon Constructor

CXTSizeIcon Constructors, CXTSizeIcon Class
CXTSizeIcon::CXTSizeIcon Constructor

Constructs a CXTSizeIcon object

CXTSizeIcon();
Group

CXTSizeIcon Constructors


CXTSizeIcon Destructors

CXTSizeIcon Class, Legend, Public Methods
CXTSizeIcon Destructors
Class

CXTSizeIcon Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTSizeIcon | Destroys a CXTSizeIcon object, handles cleanup and deallocation


CXTSizeIcon::~CXTSizeIcon Destructor

CXTSizeIcon Destructors, CXTSizeIcon Class
CXTSizeIcon::~CXTSizeIcon Destructor

Destroys a CXTSizeIcon object, handles cleanup and deallocation

virtual ~CXTSizeIcon();
Group

CXTSizeIcon Destructors


CXTSortClass Class

XTSortClass.h, Classes, Legend, Members, Topics, CXTSortClass Data Members, CXTSortClass Methods, CXTSortClass Constructors, CXTSortClass Destructors, CXTSortClass Constructors, CXTSortClass Data Members, CXTSortClass Destructors, Example, CXTSortClass Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSortClass Class

CXTSortClass is a stand alone class. This class will sort a list control by a column of text, integer, float or date/time type. It could be easily extended for other data types. To use this class, instantiate a CXTSortClass object, passing in a pointer to the list control as the first argument and the column index as the second argument.

Class Hierarchy

class CXTSortClass;
File

XTSortClass.h

Example

The following example demonstrates how to use CXTSortClass.

CXTSortClass sortClass(pListCtrl, 0);

Then call the sort method setting ascending as the first argument either TRUE or FALSE, and the type of sort to perform in the second argument.

The following example demonstrates how to use the sortClass.Sort member functin.

sortClass.Sort(TRUE, xtSortString);
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTSortClass Constructors
CXTSortClass Constructors | Description
CXTSortClass | Constructs a CXTSortClass object
CXTSortClass Data Members
CXTSortClass Data Members | Description
m_pListCtrl | Pointer to the CListCtrl object to perform the sort on
CXTSortClass Destructors
CXTSortClass Destructors | Description
~CXTSortClass | Destroys a CXTSortClass object, handles cleanup and deallocation
CXTSortClass Methods
CXTSortClass Methods | Description
Compare | This callback member function is called to compare two data items during sorting operations.
RemoveNonNumeric | This member function is called by the sort class to remove non-numeric characters from the specified source string.
Sort | This member function is called to perform the actual sort procedure.


CXTSortClass Data Members

CXTSortClass Class, Legend, Protected Data Members
CXTSortClass Data Members
Class

CXTSortClass Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pListCtrl | Pointer to the CListCtrl object to perform the sort on


CXTSortClass::m_pListCtrl Data Member

CXTSortClass Data Members, CXTSortClass Class
CXTSortClass::m_pListCtrl Data Member

Pointer to the CListCtrl object to perform the sort on

CListCtrl* m_pListCtrl;
Group

CXTSortClass Data Members


CXTSortClass Methods

CXTSortClass Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSortClass Methods
Class

CXTSortClass Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Compare | This callback member function is called to compare two data items during sorting operations.
RemoveNonNumeric | This member function is called by the sort class to remove non-numeric characters from the specified source string.
Public Methods
Public Methods
Public Method | Description
Sort | This member function is called to perform the actual sort procedure.


CXTSortClass::Compare Method

CXTSortClass Methods, CXTSortClass Class
CXTSortClass::Compare Method

This callback member function is called to compare two data items during sorting operations.

static int CALLBACK Compare(
    LPARAM lParam1,
    LPARAM lParam2,
    LPARAM lParamSort
);
Parameters

lParam1
Specify the item data for the two items being compared.
lParam2
Specify the item data for the two items being compared.
lParamSort
Specifies the application defined value that is passed to the comparison function.

Returns

The comparison function must return a negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.

Group

CXTSortClass Methods


CXTSortClass::RemoveNonNumeric Method

CXTSortClass Methods, CXTSortClass Class
CXTSortClass::RemoveNonNumeric Method

This member function is called by the sort class to remove non-numeric characters from the specified source string.

static int RemoveNonNumeric(
    CString& csSource
);
Parameters

csSource
String to remove non-numeric characters from.

Returns

The length of the specified string after non-numeric characters have been removed.

Group

CXTSortClass Methods


CXTSortClass::Sort Method

CXTSortClass Methods, CXTSortClass Class
CXTSortClass::Sort Method

This member function is called to perform the actual sort procedure.

virtual void Sort(
    bool bAsc,
    XTSortType eType
);
Parameters

bAsc
true to sort ascending.
eType
The type of sort to perform can be one of the values listed in the Remarks section.

Remarks

Sort type can be one of the following.

  • xtSortInt Sort type int.
  • xtSortString Sort type string.
  • xtSortDateTime Sort type date / time.
  • xtSortDecimal Sort type decimal.
Group

CXTSortClass Methods


CXTSortClass Constructors

CXTSortClass Class, Legend, Public Methods
CXTSortClass Constructors
Class

CXTSortClass Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTSortClass | Constructs a CXTSortClass object


CXTSortClass::CXTSortClass Constructor

CXTSortClass Constructors, CXTSortClass Class
CXTSortClass::CXTSortClass Constructor

Constructs a CXTSortClass object

CXTSortClass(
    CListCtrl* pListCtrl,
    const int nCol
);
Parameters

pListCtrl
Pointer to a CListCtrl object.
nCol
Index of the column to be sorted.

Group

CXTSortClass Constructors


CXTSortClass Destructors

CXTSortClass Class, Legend, Public Methods
CXTSortClass Destructors
Class

CXTSortClass Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTSortClass | Destroys a CXTSortClass object, handles cleanup and deallocation


CXTSortClass::~CXTSortClass Destructor

CXTSortClass Destructors, CXTSortClass Class
CXTSortClass::~CXTSortClass Destructor

Destroys a CXTSortClass object, handles cleanup and deallocation

virtual ~CXTSortClass();
Group

CXTSortClass Destructors


CXTSplitPath Class

XTUtil.h, Classes, Legend, Members, Topics, CXTSplitPath Data Members, CXTSplitPath Methods, CXTSplitPath Constructors, CXTSplitPath Destructors, CXTSplitPath Constructors, CXTSplitPath Data Members, CXTSplitPath Destructors, CXTSplitPath Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitPath Class

CXTSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension.

Class Hierarchy

class CXTSplitPath;
File

XTUtil.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTSplitPath Constructors
CXTSplitPath Constructors | Description
CXTSplitPath | Constructs a CXTSplitPath object and breaks a path into its four components.
CXTSplitPath Data Members
CXTSplitPath Data Members | Description
m_szDir | Optional directory path, including trailing slash.
m_szDrive | Optional drive letter, followed by a colon (:)
m_szExt | Optional filename extension, including leading period (.)
m_szFName | Base filename (no extension)
CXTSplitPath Destructors
CXTSplitPath Destructors | Description
~CXTSplitPath | Destroys a CXTSplitPath object, handles cleanup and de- allocation.
CXTSplitPath Methods
CXTSplitPath Methods | Description
GetDir | Call GetDir() to return the directory path, including trailing slash. Forward slashes (/), backslashes (), or both may be used.
GetDrive | Call GetDrive() to return the drive letter, followed by a colon (:) for the path split.
GetExt | Call GetExt() to return the filename extension, including leading period (.)
GetFName | Call GetFName() to return the base filename without extension
GetFullName | Call GetFullName() to return the file name plus extension only for the path that was split.
GetFullPath | Call GetFullPath() to return the full path that was split.
SplitPath | Call SplitPath to break a path into its four components.


CXTSplitPath Data Members

CXTSplitPath Class, Legend, Protected Data Members
CXTSplitPath Data Members
Class

CXTSplitPath Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_szDir | Optional directory path, including trailing slash.
m_szDrive | Optional drive letter, followed by a colon (:)
m_szExt | Optional filename extension, including leading period (.)
m_szFName | Base filename (no extension)


CXTSplitPath::m_szDir Data Member

CXTSplitPath Data Members, CXTSplitPath Class
CXTSplitPath::m_szDir Data Member

Optional directory path, including trailing slash.

TCHAR m_szDir[_MAX_DIR];
Group

CXTSplitPath Data Members


CXTSplitPath::m_szDrive Data Member

CXTSplitPath Data Members, CXTSplitPath Class
CXTSplitPath::m_szDrive Data Member

Optional drive letter, followed by a colon (:)

TCHAR m_szDrive[_MAX_DRIVE];
Group

CXTSplitPath Data Members


CXTSplitPath::m_szExt Data Member

CXTSplitPath Data Members, CXTSplitPath Class
CXTSplitPath::m_szExt Data Member

Optional filename extension, including leading period (.)

TCHAR m_szExt[_MAX_EXT];
Group

CXTSplitPath Data Members


CXTSplitPath::m_szFName Data Member

CXTSplitPath Data Members, CXTSplitPath Class
CXTSplitPath::m_szFName Data Member

Base filename (no extension)

TCHAR m_szFName[_MAX_FNAME];
Group

CXTSplitPath Data Members


CXTSplitPath Methods

CXTSplitPath Class, Legend, Public Methods
CXTSplitPath Methods
Class

CXTSplitPath Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetDir | Call GetDir() to return the directory path, including trailing slash. Forward slashes (/), backslashes (), or both may be used.
GetDrive | Call GetDrive() to return the drive letter, followed by a colon (:) for the path split.
GetExt | Call GetExt() to return the filename extension, including leading period (.)
GetFName | Call GetFName() to return the base filename without extension
GetFullName | Call GetFullName() to return the file name plus extension only for the path that was split.
GetFullPath | Call GetFullPath() to return the full path that was split.
SplitPath | Call SplitPath to break a path into its four components.


CXTSplitPath::GetDir Method

CXTSplitPath Methods, CXTSplitPath Class
CXTSplitPath::GetDir Method

Call GetDir() to return the directory path, including trailing slash. Forward slashes (/), backslashes (), or both may be used.

CString GetDir() const;
Returns

A NULL terminated string.

Group

CXTSplitPath Methods


CXTSplitPath::GetDrive Method

CXTSplitPath Methods, CXTSplitPath Class
CXTSplitPath::GetDrive Method

Call GetDrive() to return the drive letter, followed by a colon (:) for the path split.

CString GetDrive() const;
Returns

A NULL terminated string.

Group

CXTSplitPath Methods


CXTSplitPath::GetExt Method

CXTSplitPath Methods, CXTSplitPath Class
CXTSplitPath::GetExt Method

Call GetExt() to return the filename extension, including leading period (.)

CString GetExt() const;
Returns

A NULL terminated string.

Group

CXTSplitPath Methods


CXTSplitPath::GetFName Method

CXTSplitPath Methods, CXTSplitPath Class
CXTSplitPath::GetFName Method

Call GetFName() to return the base filename without extension

CString GetFName() const;
Returns

A NULL terminated string.

Group

CXTSplitPath Methods


CXTSplitPath::GetFullName Method

CXTSplitPath Methods, CXTSplitPath Class
CXTSplitPath::GetFullName Method

Call GetFullName() to return the file name plus extension only for the path that was split.

CString GetFullName() const;
Returns

A NULL terminated string.

Group

CXTSplitPath Methods


CXTSplitPath::GetFullPath Method

CXTSplitPath Methods, CXTSplitPath Class
CXTSplitPath::GetFullPath Method

Call GetFullPath() to return the full path that was split.

CString GetFullPath() const;
Returns

A NULL terminated string.

Group

CXTSplitPath Methods


CXTSplitPath::SplitPath Method

CXTSplitPath Methods, CXTSplitPath Class
CXTSplitPath::SplitPath Method

Call SplitPath to break a path into its four components.

void SplitPath(
    LPCTSTR lpszPathBuffer
);
Parameters

lpszPathBuffer
A NULL terminated string that represents the path you

Group

CXTSplitPath Methods


CXTSplitPath Constructors

CXTSplitPath Class, Legend, Public Methods
CXTSplitPath Constructors
Class

CXTSplitPath Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTSplitPath | Constructs a CXTSplitPath object and breaks a path into its four components.


CXTSplitPath::CXTSplitPath Constructor

CXTSplitPath Constructors, CXTSplitPath Class
CXTSplitPath::CXTSplitPath Constructor

Constructs a CXTSplitPath object and breaks a path into its four components.

CXTSplitPath(
    LPCTSTR lpszPathBuffer = NULL
);
Parameters

lpszPathBuffer
A NULL terminated string that represents the path you

Group

CXTSplitPath Constructors


CXTSplitPath Destructors

CXTSplitPath Class, Legend, Public Methods
CXTSplitPath Destructors
Class

CXTSplitPath Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTSplitPath | Destroys a CXTSplitPath object, handles cleanup and de- allocation.


CXTSplitPath::~CXTSplitPath Destructor

CXTSplitPath Destructors, CXTSplitPath Class
CXTSplitPath::~CXTSplitPath Destructor

Destroys a CXTSplitPath object, handles cleanup and de- allocation.

virtual ~CXTSplitPath();
Group

CXTSplitPath Destructors


CXTSplitterWnd Class

XTSplitterWnd.h, Classes, Legend, Members, Topics, CXTSplitterWnd Data Members, CXTSplitterWnd Methods, CXTSplitterWnd Constructors, CXTSplitterWnd Destructors, CXTSplitterWnd Constructors, CXTSplitterWnd Data Members, CXTSplitterWnd Destructors, CXTSplitterWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWnd Class

CXTSplitterWnd is a CSplitterWnd derived class. It adds the ability to hide and show splitter panes based upon its index.

Class Hierarchy

class CXTSplitterWnd : public CSplitterWnd;
File

XTSplitterWnd.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTSplitterWnd Constructors
CXTSplitterWnd Constructors | Description
CXTSplitterWnd | Constructs a CXTSplitterWnd object
CXTSplitterWnd Data Members
CXTSplitterWnd Data Members | Description
m_bClipStyles | Clip styles before dragging.
m_bFlatSplit | TRUE if the flat splitter style is used.
m_bForceFullDrag | TRUE to use full drag always.
m_bFullDrag | TRUE if full window dragging is enabled.
m_dwxStyle | The style of the splitter window.
m_nHiddenCol | Index of the hidden column.
m_nHiddenRow | Index of the hidden row.
m_point | Previous cursor position.
CXTSplitterWnd Destructors
CXTSplitterWnd Destructors | Description
~CXTSplitterWnd | Destroys a CXTSplitterWnd object, handles cleanup and deallocation
CXTSplitterWnd Methods
CXTSplitterWnd Methods | Description
EnableFlatLook | Call this member function to enable or disable flat splitters.
GetHiddenColIndex | Call this member function to return the index of the column that is currently hidden.
GetHiddenRowIndex | Call this member function to return the index of the row that is currently hidden.
GetSplitterStyle | Call this member function to return the current style for the splitter window.
HideColumn | This member function will hide a column based upon its index.
HideRow | This member function will hide a row based upon its index.
ReplaceView |
SetActivePane | Sets a pane to be the active one in the frame.
SetFullDrag | Call this method to set full drag state.
SetSplitterStyle | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
ShowColumn | This member function is called to show the column that was previously hidden.
ShowRow | This member function is called to show the row that was previously hidden.
SwitchView | This member function is called to switch, or swap, a splitter view with another.


CXTSplitterWnd Data Members

CXTSplitterWnd Class, Legend, Protected Data Members
CXTSplitterWnd Data Members
Class

CXTSplitterWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bClipStyles | Clip styles before dragging.
m_bFlatSplit | TRUE if the flat splitter style is used.
m_bForceFullDrag | TRUE to use full drag always.
m_bFullDrag | TRUE if full window dragging is enabled.
m_dwxStyle | The style of the splitter window.
m_nHiddenCol | Index of the hidden column.
m_nHiddenRow | Index of the hidden row.
m_point | Previous cursor position.


CXTSplitterWnd::m_bClipStyles Data Member

CXTSplitterWnd Data Members, CXTSplitterWnd Class
CXTSplitterWnd::m_bClipStyles Data Member

Clip styles before dragging.

BOOL m_bClipStyles;
Group

CXTSplitterWnd Data Members


CXTSplitterWnd::m_bFlatSplit Data Member

CXTSplitterWnd Data Members, CXTSplitterWnd Class
CXTSplitterWnd::m_bFlatSplit Data Member

TRUE if the flat splitter style is used.

BOOL m_bFlatSplit;
Group

CXTSplitterWnd Data Members


CXTSplitterWnd::m_bForceFullDrag Data Member

CXTSplitterWnd Data Members, CXTSplitterWnd Class
CXTSplitterWnd::m_bForceFullDrag Data Member

TRUE to use full drag always.

BOOL m_bForceFullDrag;
Group

CXTSplitterWnd Data Members


CXTSplitterWnd::m_bFullDrag Data Member

CXTSplitterWnd Data Members, CXTSplitterWnd Class
CXTSplitterWnd::m_bFullDrag Data Member

TRUE if full window dragging is enabled.

BOOL m_bFullDrag;
Group

CXTSplitterWnd Data Members


CXTSplitterWnd::m_dwxStyle Data Member

CXTSplitterWnd Data Members, CXTSplitterWnd Class
CXTSplitterWnd::m_dwxStyle Data Member

The style of the splitter window.

DWORD m_dwxStyle;
Group

CXTSplitterWnd Data Members


CXTSplitterWnd::m_nHiddenCol Data Member

CXTSplitterWnd Data Members, CXTSplitterWnd Class
CXTSplitterWnd::m_nHiddenCol Data Member

Index of the hidden column.

int m_nHiddenCol;
Group

CXTSplitterWnd Data Members


CXTSplitterWnd::m_nHiddenRow Data Member

CXTSplitterWnd Data Members, CXTSplitterWnd Class
CXTSplitterWnd::m_nHiddenRow Data Member

Index of the hidden row.

int m_nHiddenRow;
Group

CXTSplitterWnd Data Members


CXTSplitterWnd::m_point Data Member

CXTSplitterWnd Data Members, CXTSplitterWnd Class
CXTSplitterWnd::m_point Data Member

Previous cursor position.

CPoint m_point;
Group

CXTSplitterWnd Data Members


CXTSplitterWnd Methods

CXTSplitterWnd Class, Legend, Public Methods
CXTSplitterWnd Methods
Class

CXTSplitterWnd Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
EnableFlatLook | Call this member function to enable or disable flat splitters.
GetHiddenColIndex | Call this member function to return the index of the column that is currently hidden.
GetHiddenRowIndex | Call this member function to return the index of the row that is currently hidden.
GetSplitterStyle | Call this member function to return the current style for the splitter window.
HideColumn | This member function will hide a column based upon its index.
HideRow | This member function will hide a row based upon its index.
ReplaceView |
SetActivePane | Sets a pane to be the active one in the frame.
SetFullDrag | Call this method to set full drag state.
SetSplitterStyle | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
ShowColumn | This member function is called to show the column that was previously hidden.
ShowRow | This member function is called to show the row that was previously hidden.
SwitchView | This member function is called to switch, or swap, a splitter view with another.


CXTSplitterWnd::EnableFlatLook Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::EnableFlatLook Method

Call this member function to enable or disable flat splitters.

virtual void EnableFlatLook(
    BOOL bFlatSplitter
);
Parameters

bFlatSplitter
TRUE to enable flat splitters.

See Also

SetSplitterStyle

Group

CXTSplitterWnd Methods


CXTSplitterWnd::GetHiddenColIndex Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWnd::GetHiddenColIndex Method

Call this member function to return the index of the column that is currently hidden.

int GetHiddenColIndex();
Returns

The index of the hidden column or -1 if no columns are hidden.

See Also

GetHiddenRowIndex

Body Source
int CXTSplitterWnd::GetHiddenColIndex() {
    return m_nHiddenCol;
}
Group

CXTSplitterWnd Methods


CXTSplitterWnd::GetHiddenRowIndex Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWnd::GetHiddenRowIndex Method

Call this member function to return the index of the row that is currently hidden.

int GetHiddenRowIndex();
Returns

The index of the hidden row; or -1, if no rows are hidden.

See Also

GetHiddenColIndex

Body Source
int CXTSplitterWnd::GetHiddenRowIndex() {
    return m_nHiddenRow;
}
Group

CXTSplitterWnd Methods


CXTSplitterWnd::GetSplitterStyle Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWnd::GetSplitterStyle Method

Call this member function to return the current style for the splitter window.

virtual DWORD GetSplitterStyle();
Returns

The current style of the splitter window.

See Also

SetSplitterStyle

Body Source
DWORD CXTSplitterWnd::GetSplitterStyle() {
    return m_dwxStyle;
}
Group

CXTSplitterWnd Methods


CXTSplitterWnd::HideColumn Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::HideColumn Method

This member function will hide a column based upon its index.

virtual void HideColumn(
    int nColHide
);
Parameters

nColHide
Index of the column to hide.

See Also

ShowColumn

Group

CXTSplitterWnd Methods


CXTSplitterWnd::HideRow Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::HideRow Method

This member function will hide a row based upon its index.

virtual void HideRow(
    int nRowHide
);
Parameters

nRowHide
Index of the row to hide.

See Also

ShowRow

Group

CXTSplitterWnd Methods


ReplaceView Method

CXTSplitterWnd Methods
ReplaceView Method
Overload List
Methods
Method | Description
CXTSplitterWnd::ReplaceView (int, int, CRuntimeClass*) | This member function is called to replace an existing splitter view with another.
CXTSplitterWnd::ReplaceView (int, int, CView*) | This member function is called to replace an existing splitter view with another.
Group

CXTSplitterWnd Methods


CXTSplitterWnd::ReplaceView Method (int, int, CView*)

ReplaceView Method, CXTSplitterWnd Class, See Also
CXTSplitterWnd::ReplaceView Method (int, int, CView*)

This member function is called to replace an existing splitter view with another.

virtual CView* ReplaceView(
    int nRow,
    int nCol,
    CView* pNewView
);
virtual CView* ReplaceView(
    int nRow,
    int nCol,
    CRuntimeClass* pViewClass
);
Parameters

nRow
Specifies a row.
nCol
Specifies a column.
pNewView
Points to an already existing view.
pViewClass
Specifies the runtime class to replace the specified pane with.

Returns

A CView pointer to the view that was replaced, otherwise returns NULL.

See Also

SwitchView

Group

ReplaceView Method


CXTSplitterWnd::SetActivePane Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::SetActivePane Method

Sets a pane to be the active one in the frame.

virtual void SetActivePane(
    int row,
    int col,
    CWnd* pWnd = NULL
);
Parameters

row
If pWnd is NULL, specifies the row in the pane that will be active.
col
If pWnd is NULL, specifies the column in the pane that will be active.
pWnd
A pointer to a CWnd object. If NULL, the pane specified by row and col is set active. If not NULL, specifies the pane that is set active.

Remarks

This member function is called by the framework to set a pane as active when the user changes the focus to a pane within the frame window. You may explicitly call SetActivePane to change the focus to the specified view.

Specify pane by providing either row and column, or by providing pWnd.

See Also

CSplitterWnd::GetActivePane, CSplitterWnd::GetPane, CFrameWnd::SetActiveView

Group

CXTSplitterWnd Methods


CXTSplitterWnd::SetFullDrag Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::SetFullDrag Method

Call this method to set full drag state.

void SetFullDrag(
    BOOL bFullDrag
);
Parameters

bFullDrag
TRUE to enable full drag.

Remarks

This member function will display the contents for child pane while the splitter is resized if bFullDrag is set to TRUE.

See Also

SetSplitterStyle

Group

CXTSplitterWnd Methods


CXTSplitterWnd::SetSplitterStyle Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::SetSplitterStyle Method

Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.

virtual void SetSplitterStyle(
    DWORD dwxStyle
);
Parameters

dwxStyle
Specifies XT_SPLIT_ styles to be added during style modification. See the Remarks section for a list of styles.

Remarks

The splitter window can be modified to use one or more of the following styles:

  • XT_SPLIT_DOTTRACKER The splitter window will use a dotted tracker rather than the splitter default.
  • XT_SPLIT_NOFULLDRAG Disable the "Show window contents while dragging" option even if it is set in Windows.
  • XT_SPLIT_NOBORDER The splitter window will not draw a border around the pane.
  • XT_SPLIT_NOSIZE Do not allow splitter window panes to be resized.
See Also

GetSplitterStyle

Group

CXTSplitterWnd Methods


CXTSplitterWnd::ShowColumn Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::ShowColumn Method

This member function is called to show the column that was previously hidden.

virtual void ShowColumn();
See Also

HideColumn

Group

CXTSplitterWnd Methods


CXTSplitterWnd::ShowRow Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::ShowRow Method

This member function is called to show the row that was previously hidden.

virtual void ShowRow();
See Also

HideRow

Group

CXTSplitterWnd Methods


CXTSplitterWnd::SwitchView Method

CXTSplitterWnd Methods, CXTSplitterWnd Class, See Also
CXTSplitterWnd::SwitchView Method

This member function is called to switch, or swap, a splitter view with another.

virtual BOOL SwitchView(
    int nRow,
    int nCol,
    CView* pNewView
);
Parameters

nRow
Specifies a row.
nCol
Specifies a column.
pNewView
Specifies the view to switch the specified pane with.

Returns

TRUE if successful, otherwise returns FALSE.

See Also

ReplaceView

Group

CXTSplitterWnd Methods


CXTSplitterWnd Constructors

CXTSplitterWnd Class, Legend, Public Methods
CXTSplitterWnd Constructors
Class

CXTSplitterWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTSplitterWnd | Constructs a CXTSplitterWnd object


CXTSplitterWnd::CXTSplitterWnd Constructor

CXTSplitterWnd Constructors, CXTSplitterWnd Class
CXTSplitterWnd::CXTSplitterWnd Constructor

Constructs a CXTSplitterWnd object

CXTSplitterWnd();
Group

CXTSplitterWnd Constructors


CXTSplitterWnd Destructors

CXTSplitterWnd Class, Legend, Public Methods
CXTSplitterWnd Destructors
Class

CXTSplitterWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTSplitterWnd | Destroys a CXTSplitterWnd object, handles cleanup and deallocation


CXTSplitterWnd::~CXTSplitterWnd Destructor

CXTSplitterWnd Destructors, CXTSplitterWnd Class
CXTSplitterWnd::~CXTSplitterWnd Destructor

Destroys a CXTSplitterWnd object, handles cleanup and deallocation

virtual ~CXTSplitterWnd();
Group

CXTSplitterWnd Destructors


CXTSplitterWndEx Class

XTSplitterWnd.h, Classes, Legend, Members, Topics, CXTSplitterWndEx Data Members, CXTSplitterWndEx Methods, CXTSplitterWndEx Constructors, CXTSplitterWndEx Destructors, CXTSplitterWndEx Constructors, CXTSplitterWndEx Data Members, CXTSplitterWndEx Destructors, CXTSplitterWndEx Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWndEx Class

CXTSplitterWndEx is a CXTSplitterWnd derived class. It can be used with the CXTOutBarCtrl to display a gap between the top of the splitter and the toolbar area.

Class Hierarchy

class CXTSplitterWndEx : public CXTSplitterWnd;
File

XTSplitterWnd.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTSplitterWndEx Constructors
CXTSplitterWndEx Constructors | Description
CXTSplitterWndEx | Constructs a CXTSplitterWndEx object
CXTSplitterWndEx Data Members
CXTSplitterWndEx Data Members | Description
m_bShowTopBorder | true to draw a top border line.
m_cyTopBorderGap | Size in pixels of the top border.
CXTSplitterWndEx Destructors
CXTSplitterWndEx Destructors | Description
~CXTSplitterWndEx | Destroys a CXTSplitterWndEx object, handles cleanup and deallocation
CXTSplitterWndEx Methods
CXTSplitterWndEx Methods | Description
GetInsideRect | Called to retrieve the client area minus the inside 3D borders.
OnDrawSplitter | Renders an image of a split window.
RecalcLayout | Call to redisplay the splitter window after adjusting row or column size.
ShowTopBorder | Call this member function to show a top border for the splitter window, similar to Outlook. Enabled by default.


CXTSplitterWndEx Data Members

CXTSplitterWndEx Class, Legend, Protected Data Members
CXTSplitterWndEx Data Members
Class

CXTSplitterWndEx Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bShowTopBorder | true to draw a top border line.
m_cyTopBorderGap | Size in pixels of the top border.


CXTSplitterWndEx::m_bShowTopBorder Data Member

CXTSplitterWndEx Data Members, CXTSplitterWndEx Class
CXTSplitterWndEx::m_bShowTopBorder Data Member

true to draw a top border line.

bool m_bShowTopBorder;
Group

CXTSplitterWndEx Data Members


CXTSplitterWndEx::m_cyTopBorderGap Data Member

CXTSplitterWndEx Data Members, CXTSplitterWndEx Class
CXTSplitterWndEx::m_cyTopBorderGap Data Member

Size in pixels of the top border.

int m_cyTopBorderGap;
Group

CXTSplitterWndEx Data Members


CXTSplitterWndEx Methods

CXTSplitterWndEx Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWndEx Methods
Class

CXTSplitterWndEx Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetInsideRect | Called to retrieve the client area minus the inside 3D borders.
Public Methods
Public Methods
Public Method | Description
OnDrawSplitter | Renders an image of a split window.
RecalcLayout | Call to redisplay the splitter window after adjusting row or column size.
ShowTopBorder | Call this member function to show a top border for the splitter window, similar to Outlook. Enabled by default.


CXTSplitterWndEx::GetInsideRect Method

CXTSplitterWndEx Methods, CXTSplitterWndEx Class
CXTSplitterWndEx::GetInsideRect Method

Called to retrieve the client area minus the inside 3D borders.

virtual void GetInsideRect(
    CRect& rect
) const;
Parameters

rect
Size of the client area minus borders.

Remarks

This member function is called by the splitter window to retrieve the size of the client area minus any 3D borders.

Group

CXTSplitterWndEx Methods


CXTSplitterWndEx::OnDrawSplitter Method

CXTSplitterWndEx Methods, CXTSplitterWndEx Class, See Also
CXTSplitterWndEx::OnDrawSplitter Method

Renders an image of a split window.

virtual void OnDrawSplitter(
    CDC* pDC,
    ESplitType nType,
    const CRect& rectArg
);
Parameters

pDC
A pointer to the device context in which to draw. If pDC is NULL, then CWnd::RedrawWindow is called by the framework and no split window is drawn.
nType
A value of the enum ESplitType. See remarks section for a list of values.
rectArg
A reference to a CRect object specifying the size and shape of the split windows.

Remarks

nType can be one of the following values:

  • splitBox The splitter drag box.
  • splitBar The bar that appears between the two split windows.
  • splitIntersection The intersection of the split windows. This element will not be called when running on Windows 95.
  • splitBorder The split window borders.

This member function is called by the framework to draw and specify the exact characteristics of a splitter window.

Override OnDrawSplitter for advanced customization of the imagery for the various graphical components of a splitter window. The default imagery is similar to the splitter in Microsoft Works for Windows or Microsoft Windows 95, in that the intersections of the splitter bars are blended together.

For more on dynamic splitter windows, see "Splitter Windows" in the articleMultiple Document Types, Views, and Frame Windows in Visual C++ Programmer's Guide, Technical Note 29, and the CSplitterWnd class overview.

See Also

CSplitterWnd::OnInvertTracker

Group

CXTSplitterWndEx Methods


CXTSplitterWndEx::RecalcLayout Method

CXTSplitterWndEx Methods, CXTSplitterWndEx Class, Example
CXTSplitterWndEx::RecalcLayout Method

Call to redisplay the splitter window after adjusting row or column size.

virtual void RecalcLayout();
Remarks

Call this member function to correctly redisplay the splitter window after you have adjusted row and column sizes with the SetRowInfo and SetColumnInfo member functions. If you change row and column sizes as part of the creation process before the splitter window is visible, it is not necessary to call this member function.

The framework calls this member function whenever the user resizes the splitter window or moves a split.

Example

See the example for CSplitterWnd::SetColumnInfo.

Group

CXTSplitterWndEx Methods


CXTSplitterWndEx::ShowTopBorder Method

CXTSplitterWndEx Methods, CXTSplitterWndEx Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWndEx::ShowTopBorder Method

Call this member function to show a top border for the splitter window, similar to Outlook. Enabled by default.

virtual void ShowTopBorder(
    bool bShowTopBorder = true,
    int cyTopBorderGap = 7
);
Parameters

bShowTopBorder
Call this member function to show a top border for the splitter window, similar to Outlook. Enabled by default.
cyTopBorderGap
Call this member function to show a top border for the splitter window, similar to Outlook. Enabled by default.

Body Source
void CXTSplitterWndEx::ShowTopBorder(bool bShowTopBorder, int cyTopBorderGap) {
    m_bShowTopBorder = bShowTopBorder; m_cyTopBorderGap = cyTopBorderGap;
}
Group

CXTSplitterWndEx Methods


CXTSplitterWndEx Constructors

CXTSplitterWndEx Class, Legend, Public Methods
CXTSplitterWndEx Constructors
Class

CXTSplitterWndEx Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTSplitterWndEx | Constructs a CXTSplitterWndEx object


CXTSplitterWndEx::CXTSplitterWndEx Constructor

CXTSplitterWndEx Constructors, CXTSplitterWndEx Class
CXTSplitterWndEx::CXTSplitterWndEx Constructor

Constructs a CXTSplitterWndEx object

CXTSplitterWndEx();
Group

CXTSplitterWndEx Constructors


CXTSplitterWndEx Destructors

CXTSplitterWndEx Class, Legend, Public Methods
CXTSplitterWndEx Destructors
Class

CXTSplitterWndEx Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTSplitterWndEx | Destroys a CXTSplitterWndEx object, handles cleanup and deallocation


CXTSplitterWndEx::~CXTSplitterWndEx Destructor

CXTSplitterWndEx Destructors, CXTSplitterWndEx Class
CXTSplitterWndEx::~CXTSplitterWndEx Destructor

Destroys a CXTSplitterWndEx object, handles cleanup and deallocation

virtual ~CXTSplitterWndEx();
Group

CXTSplitterWndEx Destructors


CXTSplitterWndTheme Class

XTSplitterWndTheme.h, Classes, Legend, Members, Topics, CXTSplitterWndTheme Data Members, CXTSplitterWndTheme Methods, CXTSplitterWndTheme Constructors, CXTSplitterWndTheme Constructors, CXTSplitterWndTheme Data Members, CXTSplitterWndTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWndTheme Class

Class CXTSplitterWndTheme is derived from CXTThemeManagerStyle. This class is used to apply a Theme to splitter windows.

Class Hierarchy

class CXTSplitterWndTheme : public CXTThemeManagerStyle;
File

XTSplitterWndTheme.h

Group

Classes

Legend
Data Member
Method
virtual
CXTSplitterWndTheme Constructors
CXTSplitterWndTheme Constructors | Description
CXTSplitterWndTheme | Construct a CXTSplitterWndTheme object.
CXTSplitterWndTheme Data Members
CXTSplitterWndTheme Data Members | Description
m_clrSplitterBorders | The color of the splitter borders.
m_clrSplitterFace | The color of the splitter.
CXTSplitterWndTheme Methods
CXTSplitterWndTheme Methods | Description
RefreshMetrics | Call this function to set the splitter windows face and the borders to the system default colors.


CXTSplitterWndTheme Data Members

CXTSplitterWndTheme Class, Legend, Public Data Members
CXTSplitterWndTheme Data Members
Class

CXTSplitterWndTheme Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrSplitterBorders | The color of the splitter borders.
m_clrSplitterFace | The color of the splitter.


CXTSplitterWndTheme::m_clrSplitterBorders Data Member

CXTSplitterWndTheme Data Members, CXTSplitterWndTheme Class
CXTSplitterWndTheme::m_clrSplitterBorders Data Member

The color of the splitter borders.

CXTPPaintManagerColor m_clrSplitterBorders;
Group

CXTSplitterWndTheme Data Members


CXTSplitterWndTheme::m_clrSplitterFace Data Member

CXTSplitterWndTheme Data Members, CXTSplitterWndTheme Class
CXTSplitterWndTheme::m_clrSplitterFace Data Member

The color of the splitter.

CXTPPaintManagerColor m_clrSplitterFace;
Group

CXTSplitterWndTheme Data Members


CXTSplitterWndTheme Methods

CXTSplitterWndTheme Class, Legend, Public Methods
CXTSplitterWndTheme Methods
Class

CXTSplitterWndTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | Call this function to set the splitter windows face and the borders to the system default colors.


CXTSplitterWndTheme::RefreshMetrics Method

CXTSplitterWndTheme Methods, CXTSplitterWndTheme Class
CXTSplitterWndTheme::RefreshMetrics Method

Call this function to set the splitter windows face and the borders to the system default colors.

virtual void RefreshMetrics();
Group

CXTSplitterWndTheme Methods


CXTSplitterWndTheme Constructors

CXTSplitterWndTheme Class, Legend, Public Methods
CXTSplitterWndTheme Constructors
Class

CXTSplitterWndTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTSplitterWndTheme | Construct a CXTSplitterWndTheme object.


CXTSplitterWndTheme::CXTSplitterWndTheme Constructor

CXTSplitterWndTheme Constructors, CXTSplitterWndTheme Class
CXTSplitterWndTheme::CXTSplitterWndTheme Constructor

Construct a CXTSplitterWndTheme object.

CXTSplitterWndTheme();
Group

CXTSplitterWndTheme Constructors


CXTSplitterWndThemeOffice2003 Class

XTSplitterWndTheme.h, Classes, Legend, Members, Topics, CXTSplitterWndThemeOffice2003 Methods, CXTSplitterWndThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWndThemeOffice2003 Class

Class CXTSplitterWndThemeOffice2003 is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.

Class Hierarchy

class CXTSplitterWndThemeOffice2003 : public CXTSplitterWndThemeOfficeXP;
File

XTSplitterWndTheme.h

Group

Classes

Legend
Method
virtual
CXTSplitterWndThemeOffice2003 Methods
CXTSplitterWndThemeOffice2003 Methods | Description
RefreshMetrics | Call this function to set the splitter windows face and the borders to the system default colors.


CXTSplitterWndThemeOffice2003 Methods

CXTSplitterWndThemeOffice2003 Class, Legend, Public Methods
CXTSplitterWndThemeOffice2003 Methods
Class

CXTSplitterWndThemeOffice2003 Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | Call this function to set the splitter windows face and the borders to the system default colors.


CXTSplitterWndThemeOffice2003::RefreshMetrics Method

CXTSplitterWndThemeOffice2003 Methods, CXTSplitterWndThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWndThemeOffice2003::RefreshMetrics Method

Call this function to set the splitter windows face and the borders to the system default colors.

virtual void RefreshMetrics();
Group

CXTSplitterWndThemeOffice2003 Methods


CXTSplitterWndThemeOfficeXP Class

XTSplitterWndTheme.h, Classes, Legend, Members, Topics, CXTSplitterWndThemeOfficeXP Methods, CXTSplitterWndThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWndThemeOfficeXP Class

Class CXTSplitterWndThemeOfficeXP is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.

Class Hierarchy

class CXTSplitterWndThemeOfficeXP : public CXTSplitterWndTheme;
File

XTSplitterWndTheme.h

Group

Classes

Legend
Method
virtual
CXTSplitterWndThemeOfficeXP Methods
CXTSplitterWndThemeOfficeXP Methods | Description
RefreshMetrics | Call this function to set the splitter windows face and the borders to the system default colors.


CXTSplitterWndThemeOfficeXP Methods

CXTSplitterWndThemeOfficeXP Class, Legend, Public Methods
CXTSplitterWndThemeOfficeXP Methods
Class

CXTSplitterWndThemeOfficeXP Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | Call this function to set the splitter windows face and the borders to the system default colors.


CXTSplitterWndThemeOfficeXP::RefreshMetrics Method

CXTSplitterWndThemeOfficeXP Methods, CXTSplitterWndThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTSplitterWndThemeOfficeXP::RefreshMetrics Method

Call this function to set the splitter windows face and the borders to the system default colors.

virtual void RefreshMetrics();
Group

CXTSplitterWndThemeOfficeXP Methods


CXTTabBase Class

XTTabBase.h, Classes, Legend, Members, Topics, CXTTabBase Data Members, CXTTabBase Methods, CXTTabBase Constructors, CXTTabBase Destructors, CXTTabBase Constructors, CXTTabBase Data Members, CXTTabBase Destructors, CXTTabBase Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBase Class

CXTTabBase is a stand alone base class. It is used to draw an XP style tab control.

Class Hierarchy

class CXTTabBase : public CXTThemeManagerStyleHost;
File

XTTabBase.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTTabBase Constructors
CXTTabBase Constructors | Description
CXTTabBase | Constructs a CXTTabBase object
CXTTabBase Data Members
CXTTabBase Data Members | Description
m_bAutoCondensing | TRUE for auto-condensing tabs.
m_bBoldFont | true to set the selected tab font to bold.
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bXPBorder | true to draw an XP border around the tab child window.
m_pNavBtns | Arrow buttons.
m_pTabCtrl | Pointer to the tab control associated with this object.
CXTTabBase Destructors
CXTTabBase Destructors | Description
~CXTTabBase | Destroys a CXTTabBase object, handles cleanup and deallocation
CXTTabBase Methods
CXTTabBase Methods | Description
GetButtons | Retrieves a pointer to the tab control navigation button object.
GetChildRect | This member function copies the child coordinates of the CTabCtrl client area into the object referenced by 'rcChild'. The client coordinates specify the upper-left and lower-right corners of the client area.
GetPaintManager | Retrieves a pointer to the tab controls paint manager.
GetTabCtrlImpl | Retrieves a pointer to the associated tab control.
ImplAttach | Call this member function to associate the tab control with this object.
Init | This member function is called by the CXTTabBase class to perform initialization when the window is created or sub-classed.
OnAddPadding | This member function is called by the tab control to add padding to a tab label for use with XP style tabs.
ShowNavButtons | Call this member function to set visibility of the navigation buttons. These buttons are used in place of the default forward and back buttons that are displayed when the tab control is not wide enough to display all tabs. You can also define a close button to be used to close the active tab. This will give the tab control a VS.NET style tabbed interface.


CXTTabBase Data Members

CXTTabBase Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBase Data Members
Class

CXTTabBase Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_pNavBtns | Arrow buttons.
m_pTabCtrl | Pointer to the tab control associated with this object.
Public Data Members
Public Data Member | Description
m_bAutoCondensing | TRUE for auto-condensing tabs.
m_bBoldFont | true to set the selected tab font to bold.
m_bXPBorder | true to draw an XP border around the tab child window.


CXTTabBase::m_bAutoCondensing Data Member

CXTTabBase Data Members, CXTTabBase Class
CXTTabBase::m_bAutoCondensing Data Member

TRUE for auto-condensing tabs.

BOOL m_bAutoCondensing;
Group

CXTTabBase Data Members


CXTTabBase::m_bBoldFont Data Member

CXTTabBase Data Members, CXTTabBase Class
CXTTabBase::m_bBoldFont Data Member

true to set the selected tab font to bold.

bool m_bBoldFont;
Group

CXTTabBase Data Members


CXTTabBase::m_bPreSubclassInit Data Member

CXTTabBase Data Members, CXTTabBase Class
CXTTabBase::m_bPreSubclassInit Data Member

true when initializing from PreSubclassWindow.

bool m_bPreSubclassInit;
Group

CXTTabBase Data Members


CXTTabBase::m_bXPBorder Data Member

CXTTabBase Data Members, CXTTabBase Class
CXTTabBase::m_bXPBorder Data Member

true to draw an XP border around the tab child window.

bool m_bXPBorder;
Group

CXTTabBase Data Members


CXTTabBase::m_pNavBtns Data Member

CXTTabBase Data Members, CXTTabBase Class
CXTTabBase::m_pNavBtns Data Member

Arrow buttons.

CXTTabCtrlButtons* m_pNavBtns;
Group

CXTTabBase Data Members


CXTTabBase::m_pTabCtrl Data Member

CXTTabBase Data Members, CXTTabBase Class
CXTTabBase::m_pTabCtrl Data Member

Pointer to the tab control associated with this object.

CTabCtrl* m_pTabCtrl;
Group

CXTTabBase Data Members


CXTTabBase Methods

CXTTabBase Class, Legend, Protected Methods, Public Methods
CXTTabBase Methods
Class

CXTTabBase Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
ImplAttach | Call this member function to associate the tab control with this object.
OnAddPadding | This member function is called by the tab control to add padding to a tab label for use with XP style tabs.
Public Methods
Public Methods
Public Method | Description
GetButtons | Retrieves a pointer to the tab control navigation button object.
GetChildRect | This member function copies the child coordinates of the CTabCtrl client area into the object referenced by 'rcChild'. The client coordinates specify the upper-left and lower-right corners of the client area.
GetPaintManager | Retrieves a pointer to the tab controls paint manager.
GetTabCtrlImpl | Retrieves a pointer to the associated tab control.
Init | This member function is called by the CXTTabBase class to perform initialization when the window is created or sub-classed.
ShowNavButtons | Call this member function to set visibility of the navigation buttons. These buttons are used in place of the default forward and back buttons that are displayed when the tab control is not wide enough to display all tabs. You can also define a close button to be used to close the active tab. This will give the tab control a VS.NET style tabbed interface.


CXTTabBase::GetButtons Method

CXTTabBase Methods, CXTTabBase Class, Body Source
CXTTabBase::GetButtons Method

Retrieves a pointer to the tab control navigation button object.

CXTTabCtrlButtons* GetButtons();
Returns

A pointer to a CXTTabCtrlButtons object if successful, otherwise NULL.

Remarks

This member function is called to retrieve a to the tab control buttons used for navigating and closing tab windows.

Body Source
CXTTabCtrlButtons* CXTTabBase::GetButtons() {
    return m_pNavBtns;
}
Group

CXTTabBase Methods


CXTTabBase::GetChildRect Method

CXTTabBase Methods, CXTTabBase Class
CXTTabBase::GetChildRect Method

This member function copies the child coordinates of the CTabCtrl client area into the object referenced by 'rcChild'. The client coordinates specify the upper-left and lower-right corners of the client area.

virtual void GetChildRect(
    CRect& rcChild
) const;
Parameters

rcChild
A reference to a CRect object to receive the client coordinates.

Group

CXTTabBase Methods


CXTTabBase::GetPaintManager Method

CXTTabBase Methods, CXTTabBase Class
CXTTabBase::GetPaintManager Method

Retrieves a pointer to the tab controls paint manager.

CXTTabBaseTheme* GetPaintManager();
Returns

A pointer to a CXTTabBaseTheme object if successful, otherwise NULL.

Remarks

This member function is called to return a pointer to the tab control paint manager. The paint manager is responsible for the visual appearance of the tab control.

Group

CXTTabBase Methods


CXTTabBase::GetTabCtrlImpl Method

CXTTabBase Methods, CXTTabBase Class, Body Source
CXTTabBase::GetTabCtrlImpl Method

Retrieves a pointer to the associated tab control.

CTabCtrl* GetTabCtrlImpl();
Returns

A pointer to a CTabCtrl object if successful, otherwise NULL.

Remarks

This member function is called by the base class to manage a pointer for the derived class CTabCtrl object.

Body Source
CTabCtrl* CXTTabBase::GetTabCtrlImpl() {
    return m_pTabCtrl;
}
Group

CXTTabBase Methods


CXTTabBase::ImplAttach Method

CXTTabBase Methods, CXTTabBase Class
CXTTabBase::ImplAttach Method

Call this member function to associate the tab control with this object.

void ImplAttach(
    CTabCtrl* pTabCtrl
);
Parameters

pTabCtrl
Points to a valid tab control object.

Group

CXTTabBase Methods


CXTTabBase::Init Method

CXTTabBase Methods, CXTTabBase Class
CXTTabBase::Init Method

This member function is called by the CXTTabBase class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTTabBase Methods


CXTTabBase::OnAddPadding Method

CXTTabBase Methods, CXTTabBase Class
CXTTabBase::OnAddPadding Method

This member function is called by the tab control to add padding to a tab label for use with XP style tabs.

virtual void OnAddPadding(
    CXTStringHelper& strLabelText
);
Parameters

strLabelText
Tab label to add padding to.

Group

CXTTabBase Methods


CXTTabBase::ShowNavButtons Method

CXTTabBase Methods, CXTTabBase Class
CXTTabBase::ShowNavButtons Method

Call this member function to set visibility of the navigation buttons. These buttons are used in place of the default forward and back buttons that are displayed when the tab control is not wide enough to display all tabs. You can also define a close button to be used to close the active tab. This will give the tab control a VS.NET style tabbed interface.

void ShowNavButtons(
    DWORD dwFlags
);
Parameters

dwFlags
The value can be one or more of the values listed in the Remarks section.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • xtNavBtnArrows To show arrow buttons.
  • xtNavBtnClose To show close button.
  • xtNavBtnShowAll To show arrow and close buttons.
Group

CXTTabBase Methods


CXTTabBase Constructors

CXTTabBase Class, Legend, Public Methods
CXTTabBase Constructors
Class

CXTTabBase Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTabBase | Constructs a CXTTabBase object


CXTTabBase::CXTTabBase Constructor

CXTTabBase Constructors, CXTTabBase Class
CXTTabBase::CXTTabBase Constructor

Constructs a CXTTabBase object

CXTTabBase();
Group

CXTTabBase Constructors


CXTTabBase Destructors

CXTTabBase Class, Legend, Public Methods
CXTTabBase Destructors
Class

CXTTabBase Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTabBase | Destroys a CXTTabBase object, handles cleanup and deallocation


CXTTabBase::~CXTTabBase Destructor

CXTTabBase Destructors, CXTTabBase Class
CXTTabBase::~CXTTabBase Destructor

Destroys a CXTTabBase object, handles cleanup and deallocation

virtual ~CXTTabBase();
Group

CXTTabBase Destructors


CXTTabBaseTheme Class

XTTabBaseTheme.h, Classes, Legend, Members, Topics, CXTTabBaseTheme Data Members, CXTTabBaseTheme Methods, CXTTabBaseTheme Constructors, CXTTabBaseTheme Destructors, CXTTabBaseTheme Constructors, CXTTabBaseTheme Data Members, CXTTabBaseTheme Destructors, CXTTabBaseTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme Class

CXTTabBaseTheme is used to draw the CXTTabBase object. All themes used for CXTTabBase should inherit from this base class.

Class Hierarchy

class CXTTabBaseTheme : public CXTThemeManagerStyle;
File

XTTabBaseTheme.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTTabBaseTheme Constructors
CXTTabBaseTheme Constructors | Description
CXTTabBaseTheme | Construct a CXTTabBaseTheme object.
CXTTabBaseTheme Data Members
CXTTabBaseTheme Data Members | Description
m_bSystemDrawing | TRUE to perform system drawing.
m_bUseWinThemes | TRUE to use Windows XP themes when available.
m_clrNormalText | Color of text in a normal tab.
m_clrSelectedText | Color of text in a "selected" tab button.
m_iEdge | The Y dimension of a 3D border.
m_wrapTheme | Windows Theme wrapper.
CXTTabBaseTheme Destructors
CXTTabBaseTheme Destructors | Description
~CXTTabBaseTheme | Destroys a CXTTabBaseTheme object, handles cleanup and deallocation.
CXTTabBaseTheme Methods
CXTTabBaseTheme Methods | Description
AdjustBorders | Call this member function to redraw the borders for a particular tab.
DrawBorder | This member function is called to draw a border around a Tab child window.
DrawBorders | This member function is called to draw the borders around the tab control.
DrawButton | This member function is called to draw a single button of a tab control.
DrawTab | This member function is called to draw a tab on the TabControl.
DrawTabCtrl | This member function is called to render the tab control using the specified theme.
DrawTabIcon | This member function is called to draw the icon on the tab.
DrawTabText | This member function is called to draw text on the tab.
FillHeader | This member function is called to draw the header for the Tab Control.
FillTabFace | This member function is called draw the tab face.
FillTabFaceNativeWinXP | This member function is called to draw the tab face so that the tab appears with the Native Windows XP theme.
GetBackColor | Call this member function to get the current background color for the theme.
GetHeaderRect | Call this member function to get the bounding rectangle of the tab header area.
GetTabStyle | This member function is called to determine the tab style.
HorizontalLine | This member function is called to draw a horizontal line.
IsBottom | This member function is called to determine if the tabs are drawn on the bottom of the TabControl.
IsHorz | This member function is called to determine if the tabs are drawn horizontally on the TabControl.
IsLeft | This member function is called to determine if the tabs are drawn on the left side of the TabControl.
IsRight | This member function is called to determine if the tabs are drawn on the right side of the TabControl.
IsTop | This member function is called to determine if the tabs are drawn on the top of the TabControl.
IsVert | This member function is called to determine if the tabs are drawn vertically on the TabControl.
Pixel | This member function is called to draw a single pixel.
RefreshMetrics | Call this function to refresh the colors of the Tab control.
ShowButtons | Call this function to paint the Navigation buttons on the tab control.
SwapColors | This member function is called to swap the dark and the light colors.
VerticalLine | This member function is called to draw a vertical line.


CXTTabBaseTheme Data Members

CXTTabBaseTheme Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme Data Members
Class

CXTTabBaseTheme Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrNormalText | Color of text in a normal tab.
m_clrSelectedText | Color of text in a "selected" tab button.
m_iEdge | The Y dimension of a 3D border.
m_wrapTheme | Windows Theme wrapper.
Public Data Members
Public Data Member | Description
m_bSystemDrawing | TRUE to perform system drawing.
m_bUseWinThemes | TRUE to use Windows XP themes when available.


CXTTabBaseTheme::m_bSystemDrawing Data Member

CXTTabBaseTheme Data Members, CXTTabBaseTheme Class
CXTTabBaseTheme::m_bSystemDrawing Data Member

TRUE to perform system drawing.

BOOL m_bSystemDrawing;
Group

CXTTabBaseTheme Data Members


CXTTabBaseTheme::m_bUseWinThemes Data Member

CXTTabBaseTheme Data Members, CXTTabBaseTheme Class
CXTTabBaseTheme::m_bUseWinThemes Data Member

TRUE to use Windows XP themes when available.

BOOL m_bUseWinThemes;
Group

CXTTabBaseTheme Data Members


CXTTabBaseTheme::m_clrNormalText Data Member

CXTTabBaseTheme Data Members, CXTTabBaseTheme Class
CXTTabBaseTheme::m_clrNormalText Data Member

Color of text in a normal tab.

CXTPPaintManagerColor m_clrNormalText;
Group

CXTTabBaseTheme Data Members


CXTTabBaseTheme::m_clrSelectedText Data Member

CXTTabBaseTheme Data Members, CXTTabBaseTheme Class
CXTTabBaseTheme::m_clrSelectedText Data Member

Color of text in a "selected" tab button.

CXTPPaintManagerColor m_clrSelectedText;
Group

CXTTabBaseTheme Data Members


CXTTabBaseTheme::m_iEdge Data Member

CXTTabBaseTheme Data Members, CXTTabBaseTheme Class
CXTTabBaseTheme::m_iEdge Data Member

The Y dimension of a 3D border.

int m_iEdge;
Group

CXTTabBaseTheme Data Members


CXTTabBaseTheme::m_wrapTheme Data Member

CXTTabBaseTheme Data Members, CXTTabBaseTheme Class
CXTTabBaseTheme::m_wrapTheme Data Member

Windows Theme wrapper.

CXTPWinThemeWrapper m_wrapTheme;
Group

CXTTabBaseTheme Data Members


CXTTabBaseTheme Methods

CXTTabBaseTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme Methods
Class

CXTTabBaseTheme Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawBorder | This member function is called to draw a border around a Tab child window.
DrawBorders | This member function is called to draw the borders around the tab control.
DrawTab | This member function is called to draw a tab on the TabControl.
DrawTabIcon | This member function is called to draw the icon on the tab.
DrawTabText | This member function is called to draw text on the tab.
FillHeader | This member function is called to draw the header for the Tab Control.
FillTabFace | This member function is called draw the tab face.
FillTabFaceNativeWinXP | This member function is called to draw the tab face so that the tab appears with the Native Windows XP theme.
GetHeaderRect | Call this member function to get the bounding rectangle of the tab header area.
GetTabStyle | This member function is called to determine the tab style.
HorizontalLine | This member function is called to draw a horizontal line.
IsBottom | This member function is called to determine if the tabs are drawn on the bottom of the TabControl.
IsHorz | This member function is called to determine if the tabs are drawn horizontally on the TabControl.
IsLeft | This member function is called to determine if the tabs are drawn on the left side of the TabControl.
IsRight | This member function is called to determine if the tabs are drawn on the right side of the TabControl.
IsTop | This member function is called to determine if the tabs are drawn on the top of the TabControl.
IsVert | This member function is called to determine if the tabs are drawn vertically on the TabControl.
Pixel | This member function is called to draw a single pixel.
ShowButtons | Call this function to paint the Navigation buttons on the tab control.
SwapColors | This member function is called to swap the dark and the light colors.
VerticalLine | This member function is called to draw a vertical line.
Public Methods
Public Methods
Public Method | Description
AdjustBorders | Call this member function to redraw the borders for a particular tab.
DrawButton | This member function is called to draw a single button of a tab control.
DrawTabCtrl | This member function is called to render the tab control using the specified theme.
GetBackColor | Call this member function to get the current background color for the theme.
RefreshMetrics | Call this function to refresh the colors of the Tab control.


CXTTabBaseTheme::AdjustBorders Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::AdjustBorders Method

Call this member function to redraw the borders for a particular tab.

virtual void AdjustBorders(
    CXTTabBase* pTabCtrl,
    CXTTcbItem* pMember
);
Parameters

pTabCtrl
A pointer to a CXTTabBase
pMember
A pointer to a CXTTcbItem struct that contains information about the tab.

See Also

CXTTabBaseThemeOfficeXP::AdjustBorders

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::DrawBorder Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::DrawBorder Method

This member function is called to draw a border around a Tab child window.

virtual void DrawBorder(
    CDC* pDC,
    const CRect& r
);
Parameters

pDC
A pointer to a valid device context.
r
A CRect object that contains the location and the dimensions of the child window.

See Also

CXTTabBaseThemeOfficeXP::DrawBorder, CXTTabBaseThemeOffice2003::DrawBorder

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::DrawBorders Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::DrawBorders Method

This member function is called to draw the borders around the tab control.

virtual void DrawBorders(
    CDC* pDC,
    const CRect& rcClient
);
Parameters

pDC
A pointer to a valid device context.
rcClient
A CRect object that contains the location and the dimensions of the Tab Control.

See Also

CXTTabBaseThemeOfficeXP::DrawBorders

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::DrawButton Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class
CXTTabBaseTheme::DrawButton Method

This member function is called to draw a single button of a tab control.

virtual void DrawButton(
    CDC* pDC,
    CXTTabCtrlButton* pButton,
    COLORREF clrButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
pButton
A pointer to a CXTTabCtrlButton object.
clrButton
The color of the button.

Notes

This function ASSERTS if called. Must be overridden.

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::DrawTab Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::DrawTab Method

This member function is called to draw a tab on the TabControl.

virtual void DrawTab(
    CDC* pDC,
    CXTTabBase* pTabCtrlBase,
    int iItem
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrlBase
A pointer to a CXTTabBase object. Contains information about the tab control.
iItem
An int that specifies the tab item to draw.

See Also

CXTTabBaseThemeOfficeXP::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, DrawTabIcon, DrawTabText, FillTabFaceNativeWinXP, CXTExcelTabCtrlTheme::DrawTab, FillTabFace

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::DrawTabCtrl Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class
CXTTabBaseTheme::DrawTabCtrl Method

This member function is called to render the tab control using the specified theme.

virtual void DrawTabCtrl(
    CDC* pDC,
    CXTTabBase* pTabCtrl
);
Parameters

pDC
A CDC pointer that represents the current device context.
pTabCtrl
A pointer to a CXTTabBase object. Contains information about the tab control.

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::DrawTabIcon Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::DrawTabIcon Method

This member function is called to draw the icon on the tab.

virtual void DrawTabIcon(
    CDC* pDC,
    CTabCtrl* pTabCtrl,
    CRect& rcItem,
    int iItem
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrl
A pointer to a CTabCtrl object.
rcItem
A CRect object that contains the location and the dimensions of the tab.
iItem
An int that represents the tab item to draw the icon on.

See Also

CXTTabBaseThemeOfficeXP::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, DrawTab, DrawTabText, FillTabFace, FillTabFaceNativeWinXP, CXTExcelTabCtrlTheme::DrawTab

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::DrawTabText Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::DrawTabText Method

This member function is called to draw text on the tab.

virtual void DrawTabText(
    CDC* pDC,
    CTabCtrl* pTabCtrl,
    CRect& rcItem,
    int iItem,
    BOOL bSelected,
    BOOL bBoldFont
);
Parameters

pDC
Pointer to a valid device context.
pTabCtrl
A pointer to a CTabCtrl object.
rcItem
A CRect object that contains the location and the dimensions of the tab.
iItem
Index of the item to draw
bSelected
TRUE if the tab is selected. FALSE otherwise.
bBoldFont
TRUE if the text is to be bold. FALSE otherwise.

See Also

CXTTabBaseThemeOfficeXP::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, DrawTabIcon, FillTabFace, FillTabFaceNativeWinXP, CXTExcelTabCtrlTheme::DrawTab

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::FillHeader Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::FillHeader Method

This member function is called to draw the header for the Tab Control.

virtual void FillHeader(
    CDC* pDC,
    CXTTabBase* pTabCtrlBase,
    CRect rcHeader
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrlBase
A pointer to a CXTTabBase object. Contains information about the tab control.
rcHeader
A CRect object that contains the location and the dimensions of the header.

See Also

CXTTabBaseThemeOfficeXP::FillHeader, FillTabFaceNativeWinXP

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::FillTabFace Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::FillTabFace Method

This member function is called draw the tab face.

virtual void FillTabFace(
    CDC* pDC,
    CTabCtrl* pTabCtrl,
    CRect rcItem,
    BOOL bSelected
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrl
A pointer to a CTabCtrl object.
rcItem
A CRect object that contains the location and the dimensions of the tab.
bSelected
TRUE if the tab is selected. FALSE otherwise.

See Also

CXTTabBaseThemeOfficeXP::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, DrawTab, DrawTabIcon, DrawTabText, FillTabFaceNativeWinXP

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::FillTabFaceNativeWinXP Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::FillTabFaceNativeWinXP Method

This member function is called to draw the tab face so that the tab appears with the Native Windows XP theme.

virtual void FillTabFaceNativeWinXP(
    CDC* pDC,
    CTabCtrl* pTabCtrl,
    CRect rcItem,
    BOOL bSelected
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrl
A pointer to a CTabCtrl object. This is the associated TabControl object.
rcItem
A CRect object that contains the location and the dimensions of the tab.
bSelected
TRUE if the tab is selected. FALSE otherwise.

See Also

CXTTabBaseThemeOfficeXP::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, FillTabFace, DrawTab, DrawTabIcon, DrawTabText

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::GetBackColor Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::GetBackColor Method

Call this member function to get the current background color for the theme.

virtual CXTPPaintManagerColor GetBackColor() const;
Returns

A CXTPPaintManagerColor object that contains the value for the current background color.

See Also

CXTTabBaseThemeOffice2003::GetBackColor

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::GetHeaderRect Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::GetHeaderRect Method

Call this member function to get the bounding rectangle of the tab header area.

virtual CRect GetHeaderRect(
    CXTTabBase* pTabCtrlBase
);
Parameters

pTabCtrlBase
A pointer to a CXTTabBase object. Contains information about the tab control.

Returns

A CRect object that contains the bounding rectangle of the header area.

See Also

FillHeader

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::GetTabStyle Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme::GetTabStyle Method

This member function is called to determine the tab style.

DWORD GetTabStyle(
    CTabCtrl* pTabCtrl
) const;
Parameters

pTabCtrl
A pointer to a CTabCtrl object.

Returns

A DWORD representing the tab style.

See Also

IsLeft, IsRight, IsTop, IsBottom, IsVert, IsHorz

Body Source
DWORD GetTabStyle(CTabCtrl* pTabCtrl) const {
    ASSERT(::IsWindow(pTabCtrl->GetSafeHwnd())); return (pTabCtrl->GetStyle() & (TCS_VERTICAL|TCS_RIGHT|TCS_BOTTOM));
}
Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::HorizontalLine Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::HorizontalLine Method

This member function is called to draw a horizontal line.

void HorizontalLine(
    CDC* pDC,
    int xPos,
    int yPos,
    int nLength,
    COLORREF clr
);
Parameters

pDC
A pointer to a valid device context.
xPos
An int that specifies the logical x-coordinate of the line.
yPos
An int that specifies the logical y-coordinate of the line.
nLength
Specifies the length of the line.
clr
An RGB value that specifies the color of the line.

See Also

VerticalLine, Pixel, SwapColors

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::IsBottom Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme::IsBottom Method

This member function is called to determine if the tabs are drawn on the bottom of the TabControl.

BOOL IsBottom(
    DWORD dwStyle
) const;
Parameters

dwStyle
A DWORD value that represents the current tab style.

Returns

A BOOL. TRUE if the tabs are drawn on the bottom of the TabControl. FALSE otherwise.

See Also

GetTabStyle, IsLeft, IsRight, IsTop, IsVert, IsHorz

Body Source
BOOL IsBottom(DWORD dwStyle) const {
    return ((dwStyle & (TCS_VERTICAL|TCS_RIGHT|TCS_BOTTOM)) == TCS_BOTTOM);
}
Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::IsHorz Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme::IsHorz Method

This member function is called to determine if the tabs are drawn horizontally on the TabControl.

BOOL IsHorz(
    DWORD dwStyle
) const;
Parameters

dwStyle
A DWORD value that represents the current tab style.

Returns

A BOOL. TRUE if the tabs are drawn horizontally on the TabControl. FALSE otherwise.

See Also

GetTabStyle, IsLeft, IsRight, IsTop, IsVert, IsBottom

Body Source
BOOL IsHorz(DWORD dwStyle) const {
    return (IsTop(dwStyle) || IsBottom(dwStyle));
}
Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::IsLeft Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme::IsLeft Method

This member function is called to determine if the tabs are drawn on the left side of the TabControl.

BOOL IsLeft(
    DWORD dwStyle
) const;
Parameters

dwStyle
A DWORD value that represents the current tab style.

Returns

A BOOL. TRUE if the tabs are drawn on the left side of the TabControl. FALSE otherwise.

See Also

GetTabStyle, IsRight, IsTop, IsBottom, IsVert, IsHorz

Body Source
BOOL IsLeft(DWORD dwStyle) const {
    return ((dwStyle & (TCS_VERTICAL|TCS_RIGHT|TCS_BOTTOM)) == TCS_VERTICAL);
}
Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::IsRight Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme::IsRight Method

This member function is called to determine if the tabs are drawn on the right side of the TabControl.

BOOL IsRight(
    DWORD dwStyle
) const;
Parameters

dwStyle
A DWORD value that represents the current tab style.

Returns

A BOOL. TRUE if the tabs are drawn on the right side of the TabControl. FALSE otherwise.

See Also

GetTabStyle, IsLeft, IsTop, IsBottom, IsVert, IsHorz

Body Source
BOOL IsRight(DWORD dwStyle) const {
    return ((dwStyle & (TCS_VERTICAL|TCS_RIGHT|TCS_BOTTOM)) == (TCS_VERTICAL|TCS_RIGHT));
}
Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::IsTop Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme::IsTop Method

This member function is called to determine if the tabs are drawn on the top of the TabControl.

BOOL IsTop(
    DWORD dwStyle
) const;
Parameters

dwStyle
A DWORD value that represents the current tab style.

Returns

A BOOL. TRUE if the tabs are drawn on the top of the TabControl. FALSE otherwise.

See Also

GetTabStyle, IsLeft, IsRight, IsBottom, IsVert, IsHorz

Body Source
BOOL IsTop(DWORD dwStyle) const {
    return ((dwStyle & (TCS_VERTICAL|TCS_RIGHT|TCS_BOTTOM)) == 0);
}
Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::IsVert Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseTheme::IsVert Method

This member function is called to determine if the tabs are drawn vertically on the TabControl.

BOOL IsVert(
    DWORD dwStyle
) const;
Parameters

dwStyle
A DWORD value that represents the current tab style.

Returns

A BOOL. TRUE if the tabs are drawn vertically on the TabControl. FALSE otherwise.

See Also

GetTabStyle, IsLeft, IsRight, IsTop, IsBottom, IsHorz

Body Source
BOOL IsVert(DWORD dwStyle) const {
    return (IsRight(dwStyle) || IsLeft(dwStyle));
}
Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::Pixel Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::Pixel Method

This member function is called to draw a single pixel.

void Pixel(
    CDC* pDC,
    int xPos,
    int yPos,
    COLORREF clr
);
Parameters

pDC
A pointer to a valid device context.
xPos
An int that specifies the logical x-coordinate of the pixel.
yPos
An int that specifies the logical y-coordinate of the pixel.
clr
An RGB value that specifies the color of the pixel.

See Also

VerticalLine, HorizontalLine, SwapColors

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::RefreshMetrics Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class
CXTTabBaseTheme::RefreshMetrics Method

Call this function to refresh the colors of the Tab control.

virtual void RefreshMetrics();
Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::ShowButtons Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::ShowButtons Method

Call this function to paint the Navigation buttons on the tab control.

virtual void ShowButtons(
    CXTTabBase* pTabCtrlBase
);
Parameters

pTabCtrlBase
A pointer to a CXTTabBase object. Contains information about the tab control.

See Also

DrawButton

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::SwapColors Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::SwapColors Method

This member function is called to swap the dark and the light colors.

void SwapColors(
    COLORREF& clrLight,
    COLORREF& clrDark
);
Parameters

clrLight
An RGB value that represents the light color.
clrDark
An RGB value that represents the dark color.

See Also

VerticalLine, HorizontalLine, Pixel

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme::VerticalLine Method

CXTTabBaseTheme Methods, CXTTabBaseTheme Class, See Also
CXTTabBaseTheme::VerticalLine Method

This member function is called to draw a vertical line.

void VerticalLine(
    CDC* pDC,
    int xPos,
    int yPos,
    int nLength,
    COLORREF clr
);
Parameters

pDC
A pointer to a valid device context.
xPos
An int that specifies the logical x-coordinate of the line.
yPos
An int that specifies the logical y-coordinate of the line.
nLength
Specifies the length of the line.
clr
An RGB value that specifies the color of the line.

See Also

HorizontalLine, Pixel, SwapColors

Group

CXTTabBaseTheme Methods


CXTTabBaseTheme Constructors

CXTTabBaseTheme Class, Legend, Public Methods
CXTTabBaseTheme Constructors
Class

CXTTabBaseTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTabBaseTheme | Construct a CXTTabBaseTheme object.


CXTTabBaseTheme::CXTTabBaseTheme Constructor

CXTTabBaseTheme Constructors, CXTTabBaseTheme Class
CXTTabBaseTheme::CXTTabBaseTheme Constructor

Construct a CXTTabBaseTheme object.

CXTTabBaseTheme();
Group

CXTTabBaseTheme Constructors


CXTTabBaseTheme Destructors

CXTTabBaseTheme Class, Legend, Public Methods
CXTTabBaseTheme Destructors
Class

CXTTabBaseTheme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTabBaseTheme | Destroys a CXTTabBaseTheme object, handles cleanup and deallocation.


CXTTabBaseTheme::~CXTTabBaseTheme Destructor

CXTTabBaseTheme Destructors, CXTTabBaseTheme Class
CXTTabBaseTheme::~CXTTabBaseTheme Destructor

Destroys a CXTTabBaseTheme object, handles cleanup and deallocation.

virtual ~CXTTabBaseTheme();
Group

CXTTabBaseTheme Destructors


CXTTabBaseThemeOffice2003 Class

XTTabBaseTheme.h, Classes, Legend, Members, Topics, CXTTabBaseThemeOffice2003 Data Members, CXTTabBaseThemeOffice2003 Methods, CXTTabBaseThemeOffice2003 Constructors, CXTTabBaseThemeOffice2003 Constructors, CXTTabBaseThemeOffice2003 Data Members, CXTTabBaseThemeOffice2003 Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003 Class

Class CXTTabBaseThemeOffice2003 is derived from CXTTabBaseThemeOfficeXP.

Class Hierarchy

class CXTTabBaseThemeOffice2003 : public CXTTabBaseThemeOfficeXP;
File

XTTabBaseTheme.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTTabBaseThemeOffice2003 Constructors
CXTTabBaseThemeOffice2003 Constructors | Description
CXTTabBaseThemeOffice2003 | Construct a CXTTabBaseThemeOffice2003 object.
CXTTabBaseThemeOffice2003 Data Members
CXTTabBaseThemeOffice2003 Data Members | Description
m_clrButtonNormal | Represents the color used for normal buttons.
m_clrButtonSelected | Represents the color used for selected buttons.
m_clrDarkShadow | Represents the color used for dark shadows.
m_clrHeaderFace | Represents the gradient color of the header face.
m_clrHighlight | Represents the highlight color.
m_clrShadow | Represents the color used for shadows.
CXTTabBaseThemeOffice2003 Methods
CXTTabBaseThemeOffice2003 Methods | Description
DrawBorder | This member function is called to draw a border around a Tab child window.
FillHeader | This member function is called to draw the header for the Tab Control.
FillTabFace | This member function is called draw the tab face.
GetBackColor | This member function is called to get the background for the theme.
GradientFillTabFace | This member function is called to draw the tab face with a gradient fill.
RefreshMetrics | This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText. Then the CPen member variables are created with the system default colors for COLOR_BTNTEXT, COLOR_3DHILIGHT, COLOR_3DFACE, and COLOR_3DSHADOW. Finally, the member variable m_iEdge is set to the SM_CYEDGE system value.


CXTTabBaseThemeOffice2003 Data Members

CXTTabBaseThemeOffice2003 Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003 Data Members
Class

CXTTabBaseThemeOffice2003 Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrButtonNormal | Represents the color used for normal buttons.
m_clrButtonSelected | Represents the color used for selected buttons.
m_clrDarkShadow | Represents the color used for dark shadows.
m_clrHeaderFace | Represents the gradient color of the header face.
m_clrHighlight | Represents the highlight color.
m_clrShadow | Represents the color used for shadows.


CXTTabBaseThemeOffice2003::m_clrButtonNormal Data Member

CXTTabBaseThemeOffice2003 Data Members, CXTTabBaseThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::m_clrButtonNormal Data Member

Represents the color used for normal buttons.

CXTPPaintManagerColor m_clrButtonNormal;
Group

CXTTabBaseThemeOffice2003 Data Members


CXTTabBaseThemeOffice2003::m_clrButtonSelected Data Member

CXTTabBaseThemeOffice2003 Data Members, CXTTabBaseThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::m_clrButtonSelected Data Member

Represents the color used for selected buttons.

CXTPPaintManagerColor m_clrButtonSelected;
Group

CXTTabBaseThemeOffice2003 Data Members


CXTTabBaseThemeOffice2003::m_clrDarkShadow Data Member

CXTTabBaseThemeOffice2003 Data Members, CXTTabBaseThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::m_clrDarkShadow Data Member

Represents the color used for dark shadows.

CXTPPaintManagerColor m_clrDarkShadow;
Group

CXTTabBaseThemeOffice2003 Data Members


CXTTabBaseThemeOffice2003::m_clrHeaderFace Data Member

CXTTabBaseThemeOffice2003 Data Members, CXTTabBaseThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::m_clrHeaderFace Data Member

Represents the gradient color of the header face.

CXTPPaintManagerColorGradient m_clrHeaderFace;
Group

CXTTabBaseThemeOffice2003 Data Members


CXTTabBaseThemeOffice2003::m_clrHighlight Data Member

CXTTabBaseThemeOffice2003 Data Members, CXTTabBaseThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::m_clrHighlight Data Member

Represents the highlight color.

CXTPPaintManagerColor m_clrHighlight;
Group

CXTTabBaseThemeOffice2003 Data Members


CXTTabBaseThemeOffice2003::m_clrShadow Data Member

CXTTabBaseThemeOffice2003 Data Members, CXTTabBaseThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::m_clrShadow Data Member

Represents the color used for shadows.

CXTPPaintManagerColor m_clrShadow;
Group

CXTTabBaseThemeOffice2003 Data Members


CXTTabBaseThemeOffice2003 Methods

CXTTabBaseThemeOffice2003 Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003 Methods
Class

CXTTabBaseThemeOffice2003 Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawBorder | This member function is called to draw a border around a Tab child window.
FillHeader | This member function is called to draw the header for the Tab Control.
FillTabFace | This member function is called draw the tab face.
GradientFillTabFace | This member function is called to draw the tab face with a gradient fill.
Public Methods
Public Methods
Public Method | Description
GetBackColor | This member function is called to get the background for the theme.
RefreshMetrics | This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText. Then the CPen member variables are created with the system default colors for COLOR_BTNTEXT, COLOR_3DHILIGHT, COLOR_3DFACE, and COLOR_3DSHADOW. Finally, the member variable m_iEdge is set to the SM_CYEDGE system value.


CXTTabBaseThemeOffice2003::DrawBorder Method

CXTTabBaseThemeOffice2003 Methods, CXTTabBaseThemeOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::DrawBorder Method

This member function is called to draw a border around a Tab child window.

virtual void DrawBorder(
    CDC* pDC,
    const CRect& r
);
Parameters

pDC
A pointer to a valid device context.
r
A CRect object that contains the location and the dimensions of the child window.

See Also

CXTTabBaseTheme::DrawBorder, CXTTabBaseThemeOfficeXP::DrawBorder

Group

CXTTabBaseThemeOffice2003 Methods


CXTTabBaseThemeOffice2003::FillHeader Method

CXTTabBaseThemeOffice2003 Methods, CXTTabBaseThemeOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::FillHeader Method

This member function is called to draw the header for the Tab Control.

virtual void FillHeader(
    CDC* pDC,
    CXTTabBase* pTabCtrlBase,
    CRect rcHeader
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrlBase
A pointer to a CXTTabBase object. Contains information about the tab control.
rcHeader
A CRect object that contains the location and the dimensions of the header.

See Also

CXTTabBaseTheme::FillHeader, CXTTabBaseThemeOfficeXP::FillHeader

Group

CXTTabBaseThemeOffice2003 Methods


CXTTabBaseThemeOffice2003::FillTabFace Method

CXTTabBaseThemeOffice2003 Methods, CXTTabBaseThemeOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::FillTabFace Method

This member function is called draw the tab face.

virtual void FillTabFace(
    CDC* pDC,
    CTabCtrl* pTabCtrl,
    CRect rcItem,
    BOOL bSelected
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrl
A pointer to a CTabCtrl object.
rcItem
A CRect object that contains the location and the dimensions of the tab.
bSelected
TRUE if the tab is selected. FALSE otherwise.

See Also

CXTTabBaseTheme::FillTabFace, CXTTabBaseThemeOfficeXP::FillTabFace, GradientFillTabFace

Group

CXTTabBaseThemeOffice2003 Methods


CXTTabBaseThemeOffice2003::GetBackColor Method

CXTTabBaseThemeOffice2003 Methods, CXTTabBaseThemeOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::GetBackColor Method

This member function is called to get the background for the theme.

virtual CXTPPaintManagerColor GetBackColor() const;
Returns

A CXTPPaintManagerColor object that contains the value for the background color.

See Also

CXTTabBaseTheme::GetBackColor

Group

CXTTabBaseThemeOffice2003 Methods


CXTTabBaseThemeOffice2003::GradientFillTabFace Method

CXTTabBaseThemeOffice2003 Methods, CXTTabBaseThemeOffice2003 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::GradientFillTabFace Method

This member function is called to draw the tab face with a gradient fill.

virtual COLORREF GradientFillTabFace(
    CDC* pDC,
    CTabCtrl* pTabCtrl,
    CRect rcItem,
    BOOL bSelected
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrl
A pointer to a CTabCtrl object.
rcItem
A CRect object that contains the location and the dimensions of the tab.
bSelected
TRUE if the tab is selected. FALSE otherwise.

Returns

An RBG color that represents the dark color of the gradient fill for the tab.

See Also

CXTTabBaseThemeOfficeXP::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, FillTabFace, DrawTab, DrawTabIcon, DrawTabText

Group

CXTTabBaseThemeOffice2003 Methods


CXTTabBaseThemeOffice2003::RefreshMetrics Method

CXTTabBaseThemeOffice2003 Methods, CXTTabBaseThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::RefreshMetrics Method

This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText. Then the CPen member variables are created with the system default colors for COLOR_BTNTEXT, COLOR_3DHILIGHT, COLOR_3DFACE, and COLOR_3DSHADOW. Finally, the member variable m_iEdge is set to the SM_CYEDGE system value.

void RefreshMetrics();
Group

CXTTabBaseThemeOffice2003 Methods


CXTTabBaseThemeOffice2003 Constructors

CXTTabBaseThemeOffice2003 Class, Legend, Public Methods
CXTTabBaseThemeOffice2003 Constructors
Class

CXTTabBaseThemeOffice2003 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTabBaseThemeOffice2003 | Construct a CXTTabBaseThemeOffice2003 object.


CXTTabBaseThemeOffice2003::CXTTabBaseThemeOffice2003 Constructor

CXTTabBaseThemeOffice2003 Constructors, CXTTabBaseThemeOffice2003 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOffice2003::CXTTabBaseThemeOffice2003 Constructor

Construct a CXTTabBaseThemeOffice2003 object.

CXTTabBaseThemeOffice2003();
Group

CXTTabBaseThemeOffice2003 Constructors


CXTTabBaseThemeOfficeXP Class

XTTabBaseTheme.h, Classes, Legend, Members, Topics, CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Constructors, CXTTabBaseThemeOfficeXP Constructors, CXTTabBaseThemeOfficeXP Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP Class

Class CXTTabBaseThemeOfficeXP is derived from CXTTabBaseTheme. This class is used to implement the office XP theme for the tab controls.

Class Hierarchy

class CXTTabBaseThemeOfficeXP : public CXTTabBaseTheme;
File

XTTabBaseTheme.h

Group

Classes

Legend
Method
virtual
protected
CXTTabBaseThemeOfficeXP Constructors
CXTTabBaseThemeOfficeXP Constructors | Description
CXTTabBaseThemeOfficeXP | Construct a CXTTabBaseThemeOfficeXP object.
CXTTabBaseThemeOfficeXP Methods
CXTTabBaseThemeOfficeXP Methods | Description
AdjustBorders | Call this member function to redraw the borders for a particular tab.
DrawBorder | This member function is called to draw a border around a Tab child window.
DrawBorders | This member function is called to draw the borders around the tab control.
DrawButton | This member is called to draw single button of tab control.
DrawTabIcon | This member function is called to draw the icon on the tab.
FillHeader | This member function is called to draw the header for the Tab Control.
FillTabFace | This member function is called draw the tab face.
RefreshMetrics | This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText. Then the CPen member variables are created with the system default colors for COLOR_BTNTEXT, COLOR_3DHILIGHT, COLOR_3DFACE, and COLOR_3DSHADOW. Finally, the member variable m_iEdge is set to the SM_CYEDGE system value.


CXTTabBaseThemeOfficeXP Methods

CXTTabBaseThemeOfficeXP Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP Methods
Class

CXTTabBaseThemeOfficeXP Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawBorder | This member function is called to draw a border around a Tab child window.
DrawBorders | This member function is called to draw the borders around the tab control.
DrawTabIcon | This member function is called to draw the icon on the tab.
FillHeader | This member function is called to draw the header for the Tab Control.
FillTabFace | This member function is called draw the tab face.
Public Methods
Public Methods
Public Method | Description
AdjustBorders | Call this member function to redraw the borders for a particular tab.
DrawButton | This member is called to draw single button of tab control.
RefreshMetrics | This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText. Then the CPen member variables are created with the system default colors for COLOR_BTNTEXT, COLOR_3DHILIGHT, COLOR_3DFACE, and COLOR_3DSHADOW. Finally, the member variable m_iEdge is set to the SM_CYEDGE system value.


CXTTabBaseThemeOfficeXP::AdjustBorders Method

CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::AdjustBorders Method

Call this member function to redraw the borders for a particular tab.

virtual void AdjustBorders(
    CXTTabBase* pTabCtrl,
    CXTTcbItem* pMember
);
Parameters

pTabCtrl
A pointer to a CXTTabBase
pMember
A pointer to a CXTTcbItem struct that contains information about the tab.

See Also

CXTTabBaseTheme::AdjustBorders

Group

CXTTabBaseThemeOfficeXP Methods


CXTTabBaseThemeOfficeXP::DrawBorder Method

CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::DrawBorder Method

This member function is called to draw a border around a Tab child window.

virtual void DrawBorder(
    CDC* pDC,
    const CRect& r
);
Parameters

pDC
A pointer to a valid device context.
r
A CRect object that contains the location and the dimensions of the child window.

See Also

CXTTabBaseTheme::DrawBorder, CXTTabBaseThemeOffice2003::DrawBorder

Group

CXTTabBaseThemeOfficeXP Methods


CXTTabBaseThemeOfficeXP::DrawBorders Method

CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::DrawBorders Method

This member function is called to draw the borders around the tab control.

virtual void DrawBorders(
    CDC* pDC,
    const CRect& rcClient
);
Parameters

pDC
A pointer to a valid device context.
rcClient
A CRect object that contains the location and the dimensions of the Tab Control.

See Also

CXTTabBaseTheme::DrawBorders

Group

CXTTabBaseThemeOfficeXP Methods


CXTTabBaseThemeOfficeXP::DrawButton Method

CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::DrawButton Method

This member is called to draw single button of tab control.

virtual void DrawButton(
    CDC* pDC,
    CXTTabCtrlButton* pButton,
    COLORREF clrButton
);
Parameters

pDC
A CDC pointer that represents the current device context.
pButton
A pointer to a CXTTabCtrlButton object.
clrButton
The color of the button.

Notes

This function ASSERTS if called. Must be overridden.

Group

CXTTabBaseThemeOfficeXP Methods


CXTTabBaseThemeOfficeXP::DrawTabIcon Method

CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::DrawTabIcon Method

This member function is called to draw the icon on the tab.

virtual void DrawTabIcon(
    CDC* pDC,
    CTabCtrl* pTabCtrl,
    CRect& rcItem,
    int iItem
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrl
A pointer to a CTabCtrl object.
rcItem
A CRect object that contains the location and the dimensions of the tab.
iItem
An int that represents the tab item to draw the icon on.

See Also

CXTTabBaseTheme::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, CXTTabBaseTheme::DrawTabIcon, FillTabFace, CXTTabBaseTheme::FillTabFaceNativeWinXP, CXTExcelTabCtrlTheme::DrawTab

Group

CXTTabBaseThemeOfficeXP Methods


CXTTabBaseThemeOfficeXP::FillHeader Method

CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::FillHeader Method

This member function is called to draw the header for the Tab Control.

virtual void FillHeader(
    CDC* pDC,
    CXTTabBase* pTabCtrlBase,
    CRect rcHeader
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrlBase
A pointer to a CXTTabBase object. Contains information about the tab control.
rcHeader
A CRect object that contains the location and the dimensions of the header.

See Also

CXTTabBaseTheme::FillHeader, CXTTabBaseThemeOffice2003::FillHeader

Group

CXTTabBaseThemeOfficeXP Methods


CXTTabBaseThemeOfficeXP::FillTabFace Method

CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::FillTabFace Method

This member function is called draw the tab face.

virtual void FillTabFace(
    CDC* pDC,
    CTabCtrl* pTabCtrl,
    CRect rcItem,
    BOOL bSelected
);
Parameters

pDC
A pointer to a valid device context.
pTabCtrl
A pointer to a CTabCtrl object.
rcItem
A CRect object that contains the location and the dimensions of the tab.
bSelected
TRUE if the tab is selected. FALSE otherwise.

See Also

CXTTabBaseTheme::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, CXTTabBaseThemeOffice2003::FillTabFace, DrawTabIcon, CXTExcelTabCtrlTheme::DrawTab, CXTTabBaseTheme::FillTabFaceNativeWinXP

Group

CXTTabBaseThemeOfficeXP Methods


CXTTabBaseThemeOfficeXP::RefreshMetrics Method

CXTTabBaseThemeOfficeXP Methods, CXTTabBaseThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::RefreshMetrics Method

This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText. Then the CPen member variables are created with the system default colors for COLOR_BTNTEXT, COLOR_3DHILIGHT, COLOR_3DFACE, and COLOR_3DSHADOW. Finally, the member variable m_iEdge is set to the SM_CYEDGE system value.

virtual void RefreshMetrics();
Group

CXTTabBaseThemeOfficeXP Methods


CXTTabBaseThemeOfficeXP Constructors

CXTTabBaseThemeOfficeXP Class, Legend, Public Methods
CXTTabBaseThemeOfficeXP Constructors
Class

CXTTabBaseThemeOfficeXP Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTabBaseThemeOfficeXP | Construct a CXTTabBaseThemeOfficeXP object.


CXTTabBaseThemeOfficeXP::CXTTabBaseThemeOfficeXP Constructor

CXTTabBaseThemeOfficeXP Constructors, CXTTabBaseThemeOfficeXP Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabBaseThemeOfficeXP::CXTTabBaseThemeOfficeXP Constructor

Construct a CXTTabBaseThemeOfficeXP object.

CXTTabBaseThemeOfficeXP();
Group

CXTTabBaseThemeOfficeXP Constructors


CXTTabCtrl Class

XTTabCtrl.h, Classes, Legend, Members, Topics, CXTTabCtrl Methods, CXTTabCtrl Constructors, CXTTabCtrl Destructors, CXTTabCtrl Constructors, CXTTabCtrl Destructors, CXTTabCtrl Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabCtrl Class

CXTTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTTabCtrlBase. It is used to create a CXTTabCtrl class object. See CXTTabCtrlBase for additional functionality.

Class Hierarchy

class CXTTabCtrl : public CXTTabCtrlBase;
File

XTTabCtrl.h

Group

Classes

Legend
Method
virtual
CXTTabCtrl Constructors
CXTTabCtrl Constructors | Description
CXTTabCtrl | Constructs a CXTTabCtrl object
CXTTabCtrl Destructors
CXTTabCtrl Destructors | Description
~CXTTabCtrl | Destroys a CXTTabCtrl object, handles cleanup and deallocation
CXTTabCtrl Methods
CXTTabCtrl Methods | Description
EnableToolTips | Call this member function to enable or disable tooltip usage.


CXTTabCtrl Methods

CXTTabCtrl Class, Legend, Public Methods
CXTTabCtrl Methods
Class

CXTTabCtrl Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
EnableToolTips | Call this member function to enable or disable tooltip usage.


CXTTabCtrl::EnableToolTips Method

CXTTabCtrl Methods, CXTTabCtrl Class
CXTTabCtrl::EnableToolTips Method

Call this member function to enable or disable tooltip usage.

virtual BOOL EnableToolTips(
    BOOL bEnable
);
Parameters

bEnable
TRUE to enable tooltip usage.

Returns

TRUE if the tooltip control was found and updated, otherwise returns FALSE.

Group

CXTTabCtrl Methods


CXTTabCtrl Constructors

CXTTabCtrl Class, Legend, Public Methods
CXTTabCtrl Constructors
Class

CXTTabCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTabCtrl | Constructs a CXTTabCtrl object


CXTTabCtrl::CXTTabCtrl Constructor

CXTTabCtrl Constructors, CXTTabCtrl Class
CXTTabCtrl::CXTTabCtrl Constructor

Constructs a CXTTabCtrl object

CXTTabCtrl();
Group

CXTTabCtrl Constructors


CXTTabCtrl Destructors

CXTTabCtrl Class, Legend, Public Methods
CXTTabCtrl Destructors
Class

CXTTabCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTabCtrl | Destroys a CXTTabCtrl object, handles cleanup and deallocation


CXTTabCtrl::~CXTTabCtrl Destructor

CXTTabCtrl Destructors, CXTTabCtrl Class
CXTTabCtrl::~CXTTabCtrl Destructor

Destroys a CXTTabCtrl object, handles cleanup and deallocation

virtual ~CXTTabCtrl();
Group

CXTTabCtrl Destructors


CXTTabCtrlButton Class

XTTabCtrlButtons.h, Classes
CXTTabCtrlButton Class

CXTTabCtrlButton is a stand alone structure class. It is internal used in CXTTabCtrlButtons class.

Class Hierarchy

class CXTTabCtrlButton;
File

XTTabCtrlButtons.h

Group

Classes


CXTTabCtrlButtons Class

XTTabCtrlButtons.h, Classes
CXTTabCtrlButtons Class

CXTTabCtrlButtonsis a CWnd derived class. It is internally used in the CXTTabBase class.

Class Hierarchy

class CXTTabCtrlButtons : public CWnd;
File

XTTabCtrlButtons.h

Group

Classes


CXTTabExBase Class

XTTabBase.h, Classes, Legend, Members, Topics, CXTTabExBase Data Members, CXTTabExBase Methods, CXTTabExBase Constructors, CXTTabExBase Destructors, CXTTabExBase Constructors, CXTTabExBase Data Members, CXTTabExBase Destructors, CXTTabExBase Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabExBase Class

CXTTabExBase is a stand alone base class. It is used to draw an XP style tab control.

Class Hierarchy

class CXTTabExBase : public CXTTabBase;
File

XTTabBase.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTTabExBase Constructors
CXTTabExBase Constructors | Description
CXTTabExBase | Constructs a CXTTabExBase object
CXTTabExBase Data Members
CXTTabExBase Data Members | Description
m_bInitialUpdate | TRUE to send initial update to views when created.
m_nPos | Index of the popup menu contained in the menu.
m_pLastActiveView | Points to the last active view that belongs to the main frame window.
m_popupMenuID | Popup menu resource ID.
m_pParentFrame | Points to the parent frame.
m_pParentWnd | Points to the parent and will equal 'm_pParentFrame' in non-dialog applications.
m_tcbItems | Template list containing tab information.
CXTTabExBase Destructors
CXTTabExBase Destructors | Description
~CXTTabExBase | Destroys a CXTTabExBase object, handles cleanup and deallocation
CXTTabExBase Methods
CXTTabExBase Methods | Description
ActivateView | This member function is called to activate the specified view and deactivate all remaining views.
AddControl | This member function is called to add a control to the tab control associated with this view.
AddToolTip | Call this function to register a tab with the tooltip control so that the information stored in the tooltip is displayed when the cursor is on the tab.
AddView |
CalculateTabWidth | This member function is used internally by the tab control to calculate the width of a tab based on its label text.
Condense | This member function is used internally by the tab control to shrink, or un-shrink, tabs based on the control's width and the state of the auto-condensation mode. See SetAutoCondense() for more information.
CreateTabView | This member function creates the CWnd object that is associated with a tab control item.
Defer | Helper methods
DeleteView |
EnableRedraw | Call this member function to enable or disable the control from being redrawn or updated.
EnableToolTipsEx | Call this member function to enable or disable tooltip usage.
GetActiveView | This member function returns a pointer to the active view associated with the selected tab.
GetAutoCondense | This member function returns the state of the tab control's auto-condense mode. See SetAutoCondense() for a full explanation of this mode.
GetLastKnownChildView | This member function is used to get the last known view that belongs to the frame.
GetMenuID | This member function returns the menu resource associated with the tab control.
GetTabFromPoint | Call this member function to retrieve the tab index from the current cursor position.
GetTips | This member function retrieves the handle of the tooltip control associated with the tab control. The tab control creates a tooltip control if it has the TCS_TOOLTIPS style. You can also assign a tooltip control to a tab control by using the SetToolTips member function.
GetView |
GetViewName |
Init | This member function is called by the CXTTabExBase class to perform initialization when the window is created or sub-classed.
InitializeFont | This member function is called to initialize the font for the tab control associated with this view.
IsChildView | Call this member function to see if the specified CWnd object is a child of the tab control.
ModifyTabStyle | This member function will modify the style for the tab control associated with this view and set the appropriate font depending on the tab's orientation.
NextView | This member function is called to activate the next view in the tab control.
OnSelChange | Override this member function to handle a TCN_SELCHANGE event in your derived class to provide additional functionality.
OnSelChanging | Override this member function to handle a TCN_SELCHANGING event in your derived class to provide additional functionality.
OnThemeChanged | This member function is called whenever the theme has changed.
PrevView | This member function is called to activate the previous view in the tab control.
RecalcLayout | This member function is called when the tab control is resized. It is responsible for updating internal structures that are dependent on the control's size
RemoveAllTabs | Call this member function to remove all the tabs, including all associated views.
RemoveListItem | This member function is used by the tab control bar to remove an item from the tab view list.
ResetToolTips | This member function is called to reset the values for the tooltip control based upon the information stored for each tab.
ResizeTabView | Call this member function to resize the tab view specified by 'pView'.
SendInitialUpdate | Call this member function to allow WM_INITIALUPATE message to be sent to views after creation.
SetActiveView |
SetAutoCondense | Call this member function to enable or disable the tab auto-condensing mode. Auto-condensing mode affects the tab control's behavior when there is not enough room to fit all tabs. Without auto-condensation, the CXTTabCtrl control behaves like a standard tab control (i.e. it will display a slider control that allows the user to pan between tabs). With the auto-condensing mode enabled, CXTTabCtrl attempts to fit all tabs in the available space by trimming the tab label text. This behavior is similar to the behavior displayed by Visual C++'s Workspace View. For instance, you can see the FileView tab shrink if you... more
SetMenuID | This member function is used to set the resource ID for the popup menu used by the tab control.
SetTabText |
SetTips | Call this function to assign a tooltip control to the tab control. You can associate the tooltip control with a tab control by making a call to GetToolTips.
UpdateTabLabel | This member function is called to set the tooltip and tab text for the specified tab.
UpdateToolTip |


CXTTabExBase Data Members

CXTTabExBase Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabExBase Data Members
Class

CXTTabExBase Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bInitialUpdate | TRUE to send initial update to views when created.
m_nPos | Index of the popup menu contained in the menu.
m_pLastActiveView | Points to the last active view that belongs to the main frame window.
m_popupMenuID | Popup menu resource ID.
m_pParentFrame | Points to the parent frame.
m_pParentWnd | Points to the parent and will equal 'm_pParentFrame' in non-dialog applications.
Public Data Members
Public Data Member | Description
m_tcbItems | Template list containing tab information.


CXTTabExBase::m_bInitialUpdate Data Member

CXTTabExBase Data Members, CXTTabExBase Class
CXTTabExBase::m_bInitialUpdate Data Member

TRUE to send initial update to views when created.

BOOL m_bInitialUpdate;
Group

CXTTabExBase Data Members


CXTTabExBase::m_nPos Data Member

CXTTabExBase Data Members, CXTTabExBase Class
CXTTabExBase::m_nPos Data Member

Index of the popup menu contained in the menu.

int m_nPos;
Group

CXTTabExBase Data Members


CXTTabExBase::m_pLastActiveView Data Member

CXTTabExBase Data Members, CXTTabExBase Class
CXTTabExBase::m_pLastActiveView Data Member

Points to the last active view that belongs to the main frame window.

CView* m_pLastActiveView;
Group

CXTTabExBase Data Members


CXTTabExBase::m_popupMenuID Data Member

CXTTabExBase Data Members, CXTTabExBase Class
CXTTabExBase::m_popupMenuID Data Member

Popup menu resource ID.

UINT m_popupMenuID;
Group

CXTTabExBase Data Members


CXTTabExBase::m_pParentFrame Data Member

CXTTabExBase Data Members, CXTTabExBase Class
CXTTabExBase::m_pParentFrame Data Member

Points to the parent frame.

CFrameWnd* m_pParentFrame;
Group

CXTTabExBase Data Members


CXTTabExBase::m_pParentWnd Data Member

CXTTabExBase Data Members, CXTTabExBase Class
CXTTabExBase::m_pParentWnd Data Member

Points to the parent and will equal 'm_pParentFrame' in non-dialog applications.

CWnd* m_pParentWnd;
Group

CXTTabExBase Data Members


CXTTabExBase::m_tcbItems Data Member

CXTTabExBase Data Members, CXTTabExBase Class
CXTTabExBase::m_tcbItems Data Member

Template list containing tab information.

CList<CXTTcbItem*, CXTTcbItem*> m_tcbItems;
Group

CXTTabExBase Data Members


CXTTabExBase Methods

CXTTabExBase Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabExBase Methods
Class

CXTTabExBase Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
CalculateTabWidth | This member function is used internally by the tab control to calculate the width of a tab based on its label text.
Condense | This member function is used internally by the tab control to shrink, or un-shrink, tabs based on the control's width and the state of the auto-condensation mode. See SetAutoCondense() for more information.
CreateTabView | This member function creates the CWnd object that is associated with a tab control item.
Init | This member function is called by the CXTTabExBase class to perform initialization when the window is created or sub-classed.
OnSelChange | Override this member function to handle a TCN_SELCHANGE event in your derived class to provide additional functionality.
OnSelChanging | Override this member function to handle a TCN_SELCHANGING event in your derived class to provide additional functionality.
OnThemeChanged | This member function is called whenever the theme has changed.
UpdateTabLabel | This member function is called to set the tooltip and tab text for the specified tab.
Public Methods
Public Methods
Public Method | Description
ActivateView | This member function is called to activate the specified view and deactivate all remaining views.
AddControl | This member function is called to add a control to the tab control associated with this view.
AddToolTip | Call this function to register a tab with the tooltip control so that the information stored in the tooltip is displayed when the cursor is on the tab.
AddView |
Defer | Helper methods
DeleteView |
EnableRedraw | Call this member function to enable or disable the control from being redrawn or updated.
EnableToolTipsEx | Call this member function to enable or disable tooltip usage.
GetActiveView | This member function returns a pointer to the active view associated with the selected tab.
GetAutoCondense | This member function returns the state of the tab control's auto-condense mode. See SetAutoCondense() for a full explanation of this mode.
GetLastKnownChildView | This member function is used to get the last known view that belongs to the frame.
GetMenuID | This member function returns the menu resource associated with the tab control.
GetTabFromPoint | Call this member function to retrieve the tab index from the current cursor position.
GetTips | This member function retrieves the handle of the tooltip control associated with the tab control. The tab control creates a tooltip control if it has the TCS_TOOLTIPS style. You can also assign a tooltip control to a tab control by using the SetToolTips member function.
GetView |
GetViewName |
InitializeFont | This member function is called to initialize the font for the tab control associated with this view.
IsChildView | Call this member function to see if the specified CWnd object is a child of the tab control.
ModifyTabStyle | This member function will modify the style for the tab control associated with this view and set the appropriate font depending on the tab's orientation.
NextView | This member function is called to activate the next view in the tab control.
PrevView | This member function is called to activate the previous view in the tab control.
RecalcLayout | This member function is called when the tab control is resized. It is responsible for updating internal structures that are dependent on the control's size
RemoveAllTabs | Call this member function to remove all the tabs, including all associated views.
RemoveListItem | This member function is used by the tab control bar to remove an item from the tab view list.
ResetToolTips | This member function is called to reset the values for the tooltip control based upon the information stored for each tab.
ResizeTabView | Call this member function to resize the tab view specified by 'pView'.
SendInitialUpdate | Call this member function to allow WM_INITIALUPATE message to be sent to views after creation.
SetActiveView |
SetAutoCondense | Call this member function to enable or disable the tab auto-condensing mode. Auto-condensing mode affects the tab control's behavior when there is not enough room to fit all tabs. Without auto-condensation, the CXTTabCtrl control behaves like a standard tab control (i.e. it will display a slider control that allows the user to pan between tabs). With the auto-condensing mode enabled, CXTTabCtrl attempts to fit all tabs in the available space by trimming the tab label text. This behavior is similar to the behavior displayed by Visual C++'s Workspace View. For instance, you can see the FileView tab shrink if you... more
SetMenuID | This member function is used to set the resource ID for the popup menu used by the tab control.
SetTabText |
SetTips | Call this function to assign a tooltip control to the tab control. You can associate the tooltip control with a tab control by making a call to GetToolTips.
UpdateToolTip |


CXTTabExBase::ActivateView Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::ActivateView Method

This member function is called to activate the specified view and deactivate all remaining views.

virtual void ActivateView(
    CWnd* pTabView
);
Parameters

pTabView
CWnd object to make active.

Group

CXTTabExBase Methods


CXTTabExBase::AddControl Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::AddControl Method

This member function is called to add a control to the tab control associated with this view.

virtual BOOL AddControl(
    LPCTSTR lpszLabel,
    CWnd* pWnd,
    int iIndex = -1,
    int iIconIndex = -1
);
Parameters

lpszLabel
Pointer to the text for the tab associated with the view.
pWnd
CWnd object associated with the tab.
iIndex
Tab index of where to insert the new view. Default is -1 to add to the end.
iIconIndex
Icon index for the tab. If -1, 'iIndex' is used to determine the index.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTTabExBase Methods


CXTTabExBase::AddToolTip Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::AddToolTip Method

Call this function to register a tab with the tooltip control so that the information stored in the tooltip is displayed when the cursor is on the tab.

virtual void AddToolTip(
    UINT nIDTab,
    LPCTSTR lpszText
);
Parameters

nIDTab
Index of the tab.
lpszText
Pointer to the text for the tool.

Group

CXTTabExBase Methods


AddView Method

CXTTabExBase Methods
AddView Method
Overload List
Methods
Method | Description
CXTTabExBase::AddView (LPCTSTR, CRuntimeClass*, CDocument*, CCreateContext*, int, int) | Call this member function to add a view to the tab control associated with this view.
CXTTabExBase::AddView (LPCTSTR, CView*, int, int) | Call this member function to add a view to the tab control associated with this view.
Group

CXTTabExBase Methods


CXTTabExBase::AddView Method (LPCTSTR, CView*, int, int)

AddView Method, CXTTabExBase Class
CXTTabExBase::AddView Method (LPCTSTR, CView*, int, int)

Call this member function to add a view to the tab control associated with this view.

virtual BOOL AddView(
    LPCTSTR lpszLabel,
    CView* pView,
    int iIndex = -1,
    int iIconIndex = -1
);
virtual BOOL AddView(
    LPCTSTR lpszLabel,
    CRuntimeClass* pViewClass,
    CDocument* pDoc = NULL,
    CCreateContext* pContext = NULL,
    int iIndex = -1,
    int iIconIndex = -1
);
Parameters

lpszLabel
Pointer to the text for the tab associated with the view.
pView
An existing view to be added to the tab control.
iIndex
-1 to add to the end.
iIconIndex
Icon index for the tab. If -1, 'iIndex' is used to determine the index.
pViewClass
CView runtime class associated with the tab.
pDoc
CDocument associated with the view.
pContext
Create context for the view.

Returns

TRUE if successful, otherwise returns FALSE.

Group

AddView Method


CXTTabExBase::CalculateTabWidth Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::CalculateTabWidth Method

This member function is used internally by the tab control to calculate the width of a tab based on its label text.

int CalculateTabWidth(
    CDC* pDC,
    CString& sLabel,
    bool bHasIcon
);
Parameters

pDC
Points to the current device context.
sLabel
Represents the tab label text.
bHasIcon
Set to true if the tab item has an icon.

Returns

An integer value that represents the width of a tab.

Group

CXTTabExBase Methods


CXTTabExBase::Condense Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::Condense Method

This member function is used internally by the tab control to shrink, or un-shrink, tabs based on the control's width and the state of the auto-condensation mode. See SetAutoCondense() for more information.

void Condense();
Group

CXTTabExBase Methods


CXTTabExBase::CreateTabView Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::CreateTabView Method

This member function creates the CWnd object that is associated with a tab control item.

virtual CWnd* CreateTabView(
    CRuntimeClass * pViewClass,
    CDocument * pDocument,
    CCreateContext* pContext
);
Parameters

pViewClass
CView runtime class to be created.
pDocument
CDocument associated with view.
pContext
Create context for the view.

Returns

A pointer to the newly created CWnd object, otherwise returns NULL.

Group

CXTTabExBase Methods


CXTTabExBase::Defer Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::Defer Method

Helper methods

virtual BOOL Defer(
    HDWP& hDWP,
    CWnd* pView
);
Parameters

hDWP
Handle to a multiple-window - position structure that contains size and position information for one or more windows.
pView
A pointer to a CWnd object to be resized.

Group

CXTTabExBase Methods


DeleteView Method

CXTTabExBase Methods
DeleteView Method
Overload List
Methods
Method | Description
CXTTabExBase::DeleteView (CRuntimeClass*, BOOL) | This member function will remove a view based on the specified tab index.
CXTTabExBase::DeleteView (CWnd*, BOOL) | This member function will remove a view based on the specified tab index.
CXTTabExBase::DeleteView (int, BOOL) | This member function will remove a view based on the specified tab index.
Group

CXTTabExBase Methods


CXTTabExBase::DeleteView Method (int, BOOL)

DeleteView Method, CXTTabExBase Class
CXTTabExBase::DeleteView Method (int, BOOL)

This member function will remove a view based on the specified tab index.

virtual void DeleteView(
    int nView,
    BOOL bDestroyWnd = TRUE
);
virtual void DeleteView(
    CWnd* pView,
    BOOL bDestroyWnd = TRUE
);
virtual void DeleteView(
    CRuntimeClass* pViewClass,
    BOOL bDestroyWnd = TRUE
);
Parameters

nView
Tab index of the view.
bDestroyWnd
TRUE to destroy the list item.
pView
Points to the CWnd object associated with the tab.
pViewClass
CView runtime class associated with the tab.

Group

DeleteView Method


CXTTabExBase::EnableRedraw Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::EnableRedraw Method

Call this member function to enable or disable the control from being redrawn or updated.

void EnableRedraw(
    BOOL bRedraw
);
Parameters

bRedraw
Specifies the state of the redraw flag. If this parameter is TRUE, the redraw flag is set; if FALSE, the flag is cleared.

Group

CXTTabExBase Methods


CXTTabExBase::EnableToolTipsEx Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::EnableToolTipsEx Method

Call this member function to enable or disable tooltip usage.

virtual BOOL EnableToolTipsEx(
    BOOL bEnable
);
Parameters

bEnable
TRUE to enable tooltip usage.

Returns

TRUE if the tooltip control was found and updated, otherwise returns FALSE.

Group

CXTTabExBase Methods


CXTTabExBase::GetActiveView Method

CXTTabExBase Methods, CXTTabExBase Class, Body Source
CXTTabExBase::GetActiveView Method

This member function returns a pointer to the active view associated with the selected tab.

virtual CWnd* GetActiveView();
Returns

A pointer to the active view, otherwise returns NULL.

Body Source
CWnd* CXTTabExBase::GetActiveView() {
    return GetView(m_pTabCtrl->GetCurSel());
}
Group

CXTTabExBase Methods


CXTTabExBase::GetAutoCondense Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::GetAutoCondense Method

This member function returns the state of the tab control's auto-condense mode. See SetAutoCondense() for a full explanation of this mode.

BOOL GetAutoCondense();
Returns

TRUE if auto-condense is enabled, or FALSE if it is disabled.

Group

CXTTabExBase Methods


CXTTabExBase::GetLastKnownChildView Method

CXTTabExBase Methods, CXTTabExBase Class, Body Source
CXTTabExBase::GetLastKnownChildView Method

This member function is used to get the last known view that belongs to the frame.

CView* GetLastKnownChildView();
Returns

A CView pointer to the last known view.

Body Source
CView* CXTTabExBase::GetLastKnownChildView() {
    return m_pLastActiveView;
}
Group

CXTTabExBase Methods


CXTTabExBase::GetMenuID Method

CXTTabExBase Methods, CXTTabExBase Class, Body Source
CXTTabExBase::GetMenuID Method

This member function returns the menu resource associated with the tab control.

virtual UINT GetMenuID();
Returns

The resource ID of the menu associated with the tab control.

Body Source
UINT CXTTabExBase::GetMenuID() {
    ASSERT(::IsWindow(m_pTabCtrl->GetSafeHwnd())); return m_popupMenuID;
}
Group

CXTTabExBase Methods


CXTTabExBase::GetTabFromPoint Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::GetTabFromPoint Method

Call this member function to retrieve the tab index from the current cursor position.

virtual int GetTabFromPoint(
    CPoint point
);
Parameters

point
Pointer to a CPoint object that contains the cursor screen coordinates. Use default for current cursor position.

Returns

An integer based index of the tab; or -1, if no tab is at the specified 'point'.

Group

CXTTabExBase Methods


CXTTabExBase::GetTips Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::GetTips Method

This member function retrieves the handle of the tooltip control associated with the tab control. The tab control creates a tooltip control if it has the TCS_TOOLTIPS style. You can also assign a tooltip control to a tab control by using the SetToolTips member function.

virtual CToolTipCtrl* GetTips();
Returns

The handle of the tooltip control if successful; otherwise returns NULL.

Group

CXTTabExBase Methods


GetView Method

CXTTabExBase Methods
GetView Method
Overload List
Methods
Method | Description
CXTTabExBase::GetView (CRuntimeClass*) | This member function returns a pointer to a view from the specified runtime class.
CXTTabExBase::GetView (int) | This member function returns a pointer to a view from the specified runtime class.
Group

CXTTabExBase Methods


CXTTabExBase::GetView Method (int)

GetView Method, CXTTabExBase Class
CXTTabExBase::GetView Method (int)

This member function returns a pointer to a view from the specified runtime class.

virtual CWnd* GetView(
    int nView
);
virtual CWnd* GetView(
    CRuntimeClass* pViewClass
);
Parameters

nView
Tab index.
pViewClass
CView runtime class associated with the tab.

Returns

A pointer to a CView object, otherwise returns NULL.

Group

GetView Method


GetViewName Method

CXTTabExBase Methods
GetViewName Method
Overload List
Methods
Method | Description
CXTTabExBase::GetViewName (CRuntimeClass*) | This member function will return the name for a view based on the tab index.
CXTTabExBase::GetViewName (int) | This member function will return the name for a view based on the tab index.
Group

CXTTabExBase Methods


CXTTabExBase::GetViewName Method (int)

GetViewName Method, CXTTabExBase Class
CXTTabExBase::GetViewName Method (int)

This member function will return the name for a view based on the tab index.

virtual LPCTSTR GetViewName(
    int nView
);
virtual LPCTSTR GetViewName(
    CRuntimeClass* pViewClass
);
Parameters

nView
Tab index of the view.
pViewClass
CView runtime class associated with the tab.

Returns

A NULL terminated string that represents the tab item text.

Group

GetViewName Method


CXTTabExBase::Init Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::Init Method

This member function is called by the CXTTabExBase class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTTabExBase Methods


CXTTabExBase::InitializeFont Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::InitializeFont Method

This member function is called to initialize the font for the tab control associated with this view.

virtual void InitializeFont();
Group

CXTTabExBase Methods


CXTTabExBase::IsChildView Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::IsChildView Method

Call this member function to see if the specified CWnd object is a child of the tab control.

virtual BOOL IsChildView(
    CWnd* pView
);
Parameters

pView
A pointer to a CWnd object.

Returns

TRUE if the specified CWnd object is a child of the tab control, otherwise returns FALSE.

Group

CXTTabExBase Methods


CXTTabExBase::ModifyTabStyle Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::ModifyTabStyle Method

This member function will modify the style for the tab control associated with this view and set the appropriate font depending on the tab's orientation.

virtual BOOL ModifyTabStyle(
    DWORD dwRemove,
    DWORD dwAdd,
    UINT nFlags = 0
);
Parameters

dwRemove
Specifies window styles to be removed during style modification.
dwAdd
Specifies window styles to be added during style modification.
nFlags
Flags to be passed to SetWindowPos, or zero if SetWindowPos should not be called. The default is zero. See CWnd::ModifyStyle for more details.

Returns

Nonzero if the style was successfully modified, otherwise returns zero.

Group

CXTTabExBase Methods


CXTTabExBase::NextView Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::NextView Method

This member function is called to activate the next view in the tab control.

CWnd* NextView();
Returns

A CWnd pointer to the newly activated view.

Group

CXTTabExBase Methods


CXTTabExBase::OnSelChange Method

CXTTabExBase Methods, CXTTabExBase Class, See Also
CXTTabExBase::OnSelChange Method

Override this member function to handle a TCN_SELCHANGE event in your derived class to provide additional functionality.

virtual void OnSelChange();
See Also

OnSelChanging, TCN_XT_SELCHANGE, TCN_XT_SELCHANGING

Group

CXTTabExBase Methods


CXTTabExBase::OnSelChanging Method

CXTTabExBase Methods, CXTTabExBase Class, See Also
CXTTabExBase::OnSelChanging Method

Override this member function to handle a TCN_SELCHANGING event in your derived class to provide additional functionality.

virtual void OnSelChanging();
See Also

OnSelChange, TCN_XT_SELCHANGE, TCN_XT_SELCHANGING

Group

CXTTabExBase Methods


CXTTabExBase::OnThemeChanged Method

CXTTabExBase Methods, CXTTabExBase Class, See Also
CXTTabExBase::OnThemeChanged Method

This member function is called whenever the theme has changed.

virtual void OnThemeChanged();
See Also

CXTThemeManagerStyleHost::OnThemeChanged(), CXTHeaderCtrl::OnThemeChanged()

Group

CXTTabExBase Methods


CXTTabExBase::PrevView Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::PrevView Method

This member function is called to activate the previous view in the tab control.

CWnd* PrevView();
Returns

A CWnd pointer to the newly activated view.

Group

CXTTabExBase Methods


CXTTabExBase::RecalcLayout Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::RecalcLayout Method

This member function is called when the tab control is resized. It is responsible for updating internal structures that are dependent on the control's size

virtual void RecalcLayout();
Group

CXTTabExBase Methods


CXTTabExBase::RemoveAllTabs Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::RemoveAllTabs Method

Call this member function to remove all the tabs, including all associated views.

virtual BOOL RemoveAllTabs(
    BOOL bDestroyWnd = TRUE
);
Parameters

bDestroyWnd
TRUE to destroy the window associated with the tab item.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTTabExBase Methods


CXTTabExBase::RemoveListItem Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::RemoveListItem Method

This member function is used by the tab control bar to remove an item from the tab view list.

virtual void RemoveListItem(
    POSITION pos,
    BOOL bDestroyWnd = TRUE
);
Parameters

pos
The POSITION value of the item to be removed.
bDestroyWnd
TRUE to destroy the list item.

Group

CXTTabExBase Methods


CXTTabExBase::ResetToolTips Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::ResetToolTips Method

This member function is called to reset the values for the tooltip control based upon the information stored for each tab.

virtual void ResetToolTips();
Group

CXTTabExBase Methods


CXTTabExBase::ResizeTabView Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::ResizeTabView Method

Call this member function to resize the tab view specified by 'pView'.

virtual void ResizeTabView(
    CWnd* pView
);
Parameters

pView
A pointer to a CWnd object to be resized.

Group

CXTTabExBase Methods


CXTTabExBase::SendInitialUpdate Method

CXTTabExBase Methods, CXTTabExBase Class, Body Source
CXTTabExBase::SendInitialUpdate Method

Call this member function to allow WM_INITIALUPATE message to be sent to views after creation.

virtual void SendInitialUpdate(
    BOOL bInitialUpdate
);
Parameters

bInitialUpdate
TRUE to send initial update message.

Body Source
void CXTTabExBase::SendInitialUpdate(BOOL bInitialUpdate) {
    m_bInitialUpdate = bInitialUpdate;
}
Group

CXTTabExBase Methods


SetActiveView Method

CXTTabExBase Methods
SetActiveView Method
Overload List
Methods
Method | Description
CXTTabExBase::SetActiveView (CRuntimeClass*) | This member function will set a view active based on the specified runtime class.
CXTTabExBase::SetActiveView (CWnd*) | This member function will set a view active based on the specified runtime class.
CXTTabExBase::SetActiveView (int) | This member function will set a view active based on the specified runtime class.
Group

CXTTabExBase Methods


CXTTabExBase::SetActiveView Method (int)

SetActiveView Method, CXTTabExBase Class
CXTTabExBase::SetActiveView Method (int)

This member function will set a view active based on the specified runtime class.

virtual void SetActiveView(
    int nActiveTab
);
virtual void SetActiveView(
    CWnd* pTabView
);
virtual void SetActiveView(
    CRuntimeClass* pViewClass
);
Parameters

nActiveTab
Tab index.
pTabView
CWnd object to make active.
pViewClass
CView runtime class associated with the tab.

Group

SetActiveView Method


CXTTabExBase::SetAutoCondense Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::SetAutoCondense Method

Call this member function to enable or disable the tab auto-condensing mode. Auto-condensing mode affects the tab control's behavior when there is not enough room to fit all tabs. Without auto-condensation, the CXTTabCtrl control behaves like a standard tab control (i.e. it will display a slider control that allows the user to pan between tabs). With the auto-condensing mode enabled, CXTTabCtrl attempts to fit all tabs in the available space by trimming the tab label text. This behavior is similar to the behavior displayed by Visual C++'s Workspace View. For instance, you can see the FileView tab shrink if you shrink the Workspace View.

void SetAutoCondense(
    BOOL bEnable
);
Parameters

bEnable
TRUE to enable auto-condense mode.

Group

CXTTabExBase Methods


CXTTabExBase::SetMenuID Method

CXTTabExBase Methods, CXTTabExBase Class, Body Source
CXTTabExBase::SetMenuID Method

This member function is used to set the resource ID for the popup menu used by the tab control.

virtual void SetMenuID(
    UINT popupMenuID,
    int nPos = 0
);
Parameters

popupMenuID
ID for the tab control popup menu.
nPos
Index position in the menu resource.

Body Source
void CXTTabExBase::SetMenuID(UINT popupMenuID, int nPos) {
    m_popupMenuID = popupMenuID; m_nPos = nPos;
}
Group

CXTTabExBase Methods


SetTabText Method

CXTTabExBase Methods
SetTabText Method
Overload List
Methods
Method | Description
CXTTabExBase::SetTabText (CRuntimeClass*, LPCTSTR) | Call this member function to set the text for the specified tab.
CXTTabExBase::SetTabText (CWnd*, LPCTSTR) | Call this member function to set the text for the specified tab.
CXTTabExBase::SetTabText (int, LPCTSTR) | Call this member function to set the text for the specified tab.
Group

CXTTabExBase Methods


CXTTabExBase::SetTabText Method (int, LPCTSTR)

SetTabText Method, CXTTabExBase Class
CXTTabExBase::SetTabText Method (int, LPCTSTR)

Call this member function to set the text for the specified tab.

BOOL SetTabText(
    int nTab,
    LPCTSTR lpszLabel
);
BOOL SetTabText(
    CWnd* pView,
    LPCTSTR lpszLabel
);
BOOL SetTabText(
    CRuntimeClass* pViewClass,
    LPCTSTR lpszLabel
);
Parameters

nTab
Index of the tab.
lpszLabel
New text for the tab label.
pView
CWnd object associated with the tab.
pViewClass
CRuntimeClass of the CWnd associated with the tab.

Returns

TRUE if successful, otherwise returns FALSE.

Group

SetTabText Method


CXTTabExBase::SetTips Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::SetTips Method

Call this function to assign a tooltip control to the tab control. You can associate the tooltip control with a tab control by making a call to GetToolTips.

virtual void SetTips(
    CToolTipCtrl* pWndTip
);
Parameters

pWndTip
Pointer to a tooltip control.

Group

CXTTabExBase Methods


CXTTabExBase::UpdateTabLabel Method

CXTTabExBase Methods, CXTTabExBase Class
CXTTabExBase::UpdateTabLabel Method

This member function is called to set the tooltip and tab text for the specified tab.

BOOL UpdateTabLabel(
    int nTab,
    CXTTcbItem* pMember,
    LPCTSTR lpszLabel
);
Parameters

nTab
Index of the tab.
pMember
Address of an CXTTcbItem struct associated with the tab.
lpszLabel
NULL terminated string that represents the new tab label.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTTabExBase Methods


UpdateToolTip Method

CXTTabExBase Methods
UpdateToolTip Method
Overload List
Methods
Method | Description
CXTTabExBase::UpdateToolTip (CRuntimeClass*, LPCTSTR) | Call this function to update the tooltip text for the specified tab.
CXTTabExBase::UpdateToolTip (int, LPCTSTR) | Call this function to update the tooltip text for the specified tab.
Group

CXTTabExBase Methods


CXTTabExBase::UpdateToolTip Method (int, LPCTSTR)

UpdateToolTip Method, CXTTabExBase Class
CXTTabExBase::UpdateToolTip Method (int, LPCTSTR)

Call this function to update the tooltip text for the specified tab.

virtual void UpdateToolTip(
    int nIDTab,
    LPCTSTR lpszText
);
virtual void UpdateToolTip(
    CRuntimeClass* pViewClass,
    LPCTSTR lpszText
);
Parameters

nIDTab
Index of the tab.
lpszText
Pointer to the text for the tool.
pViewClass
CRuntimeClass associated with the tab.

Group

UpdateToolTip Method


CXTTabExBase Constructors

CXTTabExBase Class, Legend, Public Methods
CXTTabExBase Constructors
Class

CXTTabExBase Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTabExBase | Constructs a CXTTabExBase object


CXTTabExBase::CXTTabExBase Constructor

CXTTabExBase Constructors, CXTTabExBase Class
CXTTabExBase::CXTTabExBase Constructor

Constructs a CXTTabExBase object

CXTTabExBase();
Group

CXTTabExBase Constructors


CXTTabExBase Destructors

CXTTabExBase Class, Legend, Public Methods
CXTTabExBase Destructors
Class

CXTTabExBase Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTabExBase | Destroys a CXTTabExBase object, handles cleanup and deallocation


CXTTabExBase::~CXTTabExBase Destructor

CXTTabExBase Destructors, CXTTabExBase Class
CXTTabExBase::~CXTTabExBase Destructor

Destroys a CXTTabExBase object, handles cleanup and deallocation

virtual ~CXTTabExBase();
Group

CXTTabExBase Destructors


CXTTabView Class

XTTabView.h, Classes, Legend, Members, Topics, CXTTabView Methods, CXTTabView Constructors, CXTTabView Destructors, CXTTabView Constructors, CXTTabView Destructors, CXTTabView Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTabView Class

CXTTabView is a multiple inheritance class derived from CCtrlView and CXTTabCtrlBaseEx. CXTTabView can be used to create a view that contains nested views displayed in a tab control. See CXTTabCtrlBaseEx for additional functionality.

Class Hierarchy

class CXTTabView : public CXTTabViewBase;
File

XTTabView.h

Group

Classes

Legend
Method
virtual
protected
CXTTabView Constructors
CXTTabView Constructors | Description
CXTTabView | Constructs a CXTTabView object
CXTTabView Destructors
CXTTabView Destructors | Description
~CXTTabView | Destroys a CXTTabView object, handles cleanup and deallocation
CXTTabView Methods
CXTTabView Methods | Description
GetTabCtrl | Call this member function to retrieve a reference pointer to the CTabCtrl object associated with this view.
GetToolTips | This member function retrieves the handle of the tooltip control associated with the tab control. The tab control creates a tooltip control if it has the TCS_TOOLTIPS style. You can also assign a tooltip control to a tab control by using the SetToolTips member function.
Init | This member function is called by the CXTTabView class to perform initialization when the window is created or sub-classed.
SetTabImageList | Call this function to assign an image list to the tab control associated with this view.
SetToolTips | Call this function to assign a tooltip control to the tab control. You can associate the tooltip control with a tab control by making a call to GetToolTips.
UpdateDocTitle | Call this member function to update the document name with the tab label.


CXTTabView Methods

CXTTabView Class, Legend, Protected Methods, Public Methods
CXTTabView Methods
Class

CXTTabView Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Init | This member function is called by the CXTTabView class to perform initialization when the window is created or sub-classed.
Public Methods
Public Methods
Public Method | Description
GetTabCtrl | Call this member function to retrieve a reference pointer to the CTabCtrl object associated with this view.
GetToolTips | This member function retrieves the handle of the tooltip control associated with the tab control. The tab control creates a tooltip control if it has the TCS_TOOLTIPS style. You can also assign a tooltip control to a tab control by using the SetToolTips member function.
SetTabImageList | Call this function to assign an image list to the tab control associated with this view.
SetToolTips | Call this function to assign a tooltip control to the tab control. You can associate the tooltip control with a tab control by making a call to GetToolTips.
UpdateDocTitle | Call this member function to update the document name with the tab label.


CXTTabView::GetTabCtrl Method

CXTTabView Methods, CXTTabView Class, Body Source
CXTTabView::GetTabCtrl Method

Call this member function to retrieve a reference pointer to the CTabCtrl object associated with this view.

virtual CTabCtrl& GetTabCtrl() const;
Returns

A CTabCtrl reference to the object associated with this view.

Body Source
CTabCtrl& CXTTabView::GetTabCtrl() const {
    ASSERT_VALID(this); return (CTabCtrl&)*this;
}
Group

CXTTabView Methods


CXTTabView::GetToolTips Method

CXTTabView Methods, CXTTabView Class, Body Source
CXTTabView::GetToolTips Method

This member function retrieves the handle of the tooltip control associated with the tab control. The tab control creates a tooltip control if it has the TCS_TOOLTIPS style. You can also assign a tooltip control to a tab control by using the SetToolTips member function.

virtual CToolTipCtrl* GetToolTips();
Returns

The handle of the tooltip control if successful, otherwise returns NULL.

Body Source
CToolTipCtrl* CXTTabView::GetToolTips() {
    return GetTips();
}
Group

CXTTabView Methods


CXTTabView::Init Method

CXTTabView Methods, CXTTabView Class
CXTTabView::Init Method

This member function is called by the CXTTabView class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTTabView Methods


CXTTabView::SetTabImageList Method

CXTTabView Methods, CXTTabView Class, Body Source
CXTTabView::SetTabImageList Method

Call this function to assign an image list to the tab control associated with this view.

virtual CImageList* SetTabImageList(
    CImageList* pImageList
);
Parameters

pImageList
Pointer to the image list to be assigned to the tab control.

Returns

A pointer to the previous image list or NULL, if there is no previous image list.

Body Source
CImageList* CXTTabView::SetTabImageList(CImageList* pImageList) {
    ASSERT_VALID(this); return GetTabCtrl().SetImageList(pImageList);
}
Group

CXTTabView Methods


CXTTabView::SetToolTips Method

CXTTabView Methods, CXTTabView Class, Body Source
CXTTabView::SetToolTips Method

Call this function to assign a tooltip control to the tab control. You can associate the tooltip control with a tab control by making a call to GetToolTips.

virtual void SetToolTips(
    CToolTipCtrl* pWndTip
);
Parameters

pWndTip
Pointer to a tooltip control.

Body Source
void CXTTabView::SetToolTips(CToolTipCtrl* pWndTip) {
    SetTips(pWndTip);
}
Group

CXTTabView Methods


CXTTabView::UpdateDocTitle Method

CXTTabView Methods, CXTTabView Class
CXTTabView::UpdateDocTitle Method

Call this member function to update the document name with the tab label.

void UpdateDocTitle();
Group

CXTTabView Methods


CXTTabView Constructors

CXTTabView Class, Legend, Public Methods
CXTTabView Constructors
Class

CXTTabView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTabView | Constructs a CXTTabView object


CXTTabView::CXTTabView Constructor

CXTTabView Constructors, CXTTabView Class
CXTTabView::CXTTabView Constructor

Constructs a CXTTabView object

CXTTabView();
Group

CXTTabView Constructors


CXTTabView Destructors

CXTTabView Class, Legend, Public Methods
CXTTabView Destructors
Class

CXTTabView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTabView | Destroys a CXTTabView object, handles cleanup and deallocation


CXTTabView::~CXTTabView Destructor

CXTTabView Destructors, CXTTabView Class
CXTTabView::~CXTTabView Destructor

Destroys a CXTTabView object, handles cleanup and deallocation

virtual ~CXTTabView();
Group

CXTTabView Destructors


CXTTcbItem Class

XTGlobal.h, Classes, Legend, Members, Topics, CXTTcbItem Data Members, CXTTcbItem Constructors, CXTTcbItem Constructors, CXTTcbItem Data Members, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTcbItem Class

CXTTcbItem class is used to maintain information for a particular tab item in a CXTExcelTabCtrl, CXTTabCtrl and CXTTabView object.

Class Hierarchy

class CXTTcbItem;
File

XTGlobal.h

See Also

CXTExcelTabCtrl, CXTTabCtrl and CXTTabView

Group

Classes

Legend
Data Member
Constructor
CXTTcbItem Constructors
CXTTcbItem Constructors | Description
CXTTcbItem | Constructs an CXTTcbItem object
CXTTcbItem Data Members
CXTTcbItem Data Members | Description
crTabBack | Application defined tab background color.
crTabSelBack | Application defined selected tab background color.
crTabSelText | Application defined selected tab text color.
crTabText | Application defined tab text color.
dwExStyle | Stores the extended window style when the tab item was created.
dwStyle | Stores the window style when the tab item was created.
pWnd | A CWnd pointer to the window associated with a tab.
szCondensedLabel | The label actually being displayed for auto-condensing tabs.
szTabLabel | User specified label for the tab.
szToolTipLabel | Tooltip text for the tab.
uiToolTipId | Resource ID for the tooltip.


CXTTcbItem Data Members

CXTTcbItem Class, Legend, Public Data Members
CXTTcbItem Data Members
Class

CXTTcbItem Class

Legend
Data Member
Public Data Members
Public Data Member | Description
crTabBack | Application defined tab background color.
crTabSelBack | Application defined selected tab background color.
crTabSelText | Application defined selected tab text color.
crTabText | Application defined tab text color.
dwExStyle | Stores the extended window style when the tab item was created.
dwStyle | Stores the window style when the tab item was created.
pWnd | A CWnd pointer to the window associated with a tab.
szCondensedLabel | The label actually being displayed for auto-condensing tabs.
szTabLabel | User specified label for the tab.
szToolTipLabel | Tooltip text for the tab.
uiToolTipId | Resource ID for the tooltip.


CXTTcbItem::crTabBack Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::crTabBack Data Member

Application defined tab background color.

COLORREF crTabBack;
Group

CXTTcbItem Data Members


CXTTcbItem::crTabSelBack Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::crTabSelBack Data Member

Application defined selected tab background color.

COLORREF crTabSelBack;
Group

CXTTcbItem Data Members


CXTTcbItem::crTabSelText Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::crTabSelText Data Member

Application defined selected tab text color.

COLORREF crTabSelText;
Group

CXTTcbItem Data Members


CXTTcbItem::crTabText Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::crTabText Data Member

Application defined tab text color.

COLORREF crTabText;
Group

CXTTcbItem Data Members


CXTTcbItem::dwExStyle Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::dwExStyle Data Member

Stores the extended window style when the tab item was created.

DWORD dwExStyle;
Group

CXTTcbItem Data Members


CXTTcbItem::dwStyle Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::dwStyle Data Member

Stores the window style when the tab item was created.

DWORD dwStyle;
Group

CXTTcbItem Data Members


CXTTcbItem::pWnd Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::pWnd Data Member

A CWnd pointer to the window associated with a tab.

CWnd* pWnd;
Group

CXTTcbItem Data Members


CXTTcbItem::szCondensedLabel Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::szCondensedLabel Data Member

The label actually being displayed for auto-condensing tabs.

CString szCondensedLabel;
Group

CXTTcbItem Data Members


CXTTcbItem::szTabLabel Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::szTabLabel Data Member

User specified label for the tab.

CString szTabLabel;
Group

CXTTcbItem Data Members


CXTTcbItem::szToolTipLabel Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::szToolTipLabel Data Member

Tooltip text for the tab.

CString szToolTipLabel;
Group

CXTTcbItem Data Members


CXTTcbItem::uiToolTipId Data Member

CXTTcbItem Data Members, CXTTcbItem Class
CXTTcbItem::uiToolTipId Data Member

Resource ID for the tooltip.

UINT uiToolTipId;
Group

CXTTcbItem Data Members


CXTTcbItem Constructors

CXTTcbItem Class, Legend, Public Methods
CXTTcbItem Constructors
Class

CXTTcbItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTcbItem | Constructs an CXTTcbItem object


CXTTcbItem::CXTTcbItem Constructor

CXTTcbItem Constructors, CXTTcbItem Class
CXTTcbItem::CXTTcbItem Constructor

Constructs an CXTTcbItem object

CXTTcbItem();
Group

CXTTcbItem Constructors


CXTThemeManager Class

XTThemeManager.h, Classes, Legend, Members, Topics, CXTThemeManager Data Members, CXTThemeManager Methods, CXTThemeManager Constructors, CXTThemeManager Destructors, CXTThemeManager Constructors, CXTThemeManager Data Members, CXTThemeManager Destructors, CXTThemeManager Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManager Class

CXTThemeManager is standalone class used to manage the visual styles for your application.

Class Hierarchy

class CXTThemeManager : public CNoTrackObject;
File

XTThemeManager.h

Remarks

CXTThemeManager is used to manage the visual styles for your application. Add a member of this type to your frame or dialog class to manage your application themes. See SetTheme for more information on setting themes.

See Also

XTThemeManager, CXTThemeManagerStyle, CXTThemeManagerStyleHost

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTThemeManager Constructors
CXTThemeManager Constructors | Description
CXTThemeManager | Constructs a CXTThemeManager object.
CXTThemeManager Data Members
CXTThemeManager Data Members | Description
m_enumTheme | Default theme for all components
m_factoryList | Collection of all theme factories.
m_mapDefaultFactories | Default factories collection
CXTThemeManager Destructors
CXTThemeManager Destructors | Description
~CXTThemeManager | Destroys a CXTThemeManager object, handles cleanup and deallocation.
CXTThemeManager Methods
CXTThemeManager Methods | Description
GetDefaultThemeFactory | Retrieved theme factory class for specified runtime class. Creates new if no found.
GetTheme | Retrieved default theme for all components
RefreshMetrics | Call this method to refresh visual metrics of all themes.
SetTheme | Call this method to set theme for all components.


CXTThemeManager Data Members

CXTThemeManager Class, Legend, Protected Data Members
CXTThemeManager Data Members
Class

CXTThemeManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_enumTheme | Default theme for all components
m_factoryList | Collection of all theme factories.
m_mapDefaultFactories | Default factories collection


CXTThemeManager::m_enumTheme Data Member

CXTThemeManager Data Members, CXTThemeManager Class
CXTThemeManager::m_enumTheme Data Member

Default theme for all components

XTThemeStyle m_enumTheme;
Group

CXTThemeManager Data Members


CXTThemeManager::m_factoryList Data Member

CXTThemeManager Data Members, CXTThemeManager Class
CXTThemeManager::m_factoryList Data Member

Collection of all theme factories.

CTypedSimpleList<CXTThemeManagerStyleFactory*> m_factoryList;
Group

CXTThemeManager Data Members


CXTThemeManager::m_mapDefaultFactories Data Member

CXTThemeManager Data Members, CXTThemeManager Class
CXTThemeManager::m_mapDefaultFactories Data Member

Default factories collection

CMapPtrToPtr m_mapDefaultFactories;
Group

CXTThemeManager Data Members


CXTThemeManager Methods

CXTThemeManager Class, Legend, Public Methods
CXTThemeManager Methods
Class

CXTThemeManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetDefaultThemeFactory | Retrieved theme factory class for specified runtime class. Creates new if no found.
GetTheme | Retrieved default theme for all components
RefreshMetrics | Call this method to refresh visual metrics of all themes.
SetTheme | Call this method to set theme for all components.


CXTThemeManager::GetDefaultThemeFactory Method

CXTThemeManager Methods, CXTThemeManager Class, Example
CXTThemeManager::GetDefaultThemeFactory Method

Retrieved theme factory class for specified runtime class. Creates new if no found.

CXTThemeManagerStyleFactory* GetDefaultThemeFactory(
    CRuntimeClass* pThemeFactoryClass
);
Parameters

pThemeFactoryClass
Runtime class need to find

Returns

CXTThemeManagerStyleFactory pointer associated with its runtime class.

Example

The following example demonstrates how to use GetDefaultThemeFactory.

XTThemeManager()->GetDefaultThemeFactory(RUNTIME_CLASS(CXTCaptionThemeFactory));
Group

CXTThemeManager Methods


CXTThemeManager::GetTheme Method

CXTThemeManager Methods, CXTThemeManager Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManager::GetTheme Method

Retrieved default theme for all components

XTThemeStyle GetTheme();
Returns

Default theme for all components.

See Also

SetTheme, XTThemeManager

Example

The following example demonstrates how to use GetTheme.

XTThemeManager()->GetTheme();
Body Source
XTThemeStyle CXTThemeManager::GetTheme() {
    return m_enumTheme;
}
Group

CXTThemeManager Methods


CXTThemeManager::RefreshMetrics Method

CXTThemeManager Methods, CXTThemeManager Class, See Also
CXTThemeManager::RefreshMetrics Method

Call this method to refresh visual metrics of all themes.

void RefreshMetrics();
See Also

CXTThemeManagerStyle::RefreshMetrics

Group

CXTThemeManager Methods


CXTThemeManager::SetTheme Method

CXTThemeManager Methods, CXTThemeManager Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManager::SetTheme Method

Call this method to set theme for all components.

void SetTheme(
    XTThemeStyle theme
);
Parameters

theme
Theme need to set

Remarks

Theme can be one of following values:

  • xtThemeDefault Enables Windows classic theme.
  • xtThemeOfficeXP Enables Microsoft(r) Office XP theme.
  • xtThemeOffice2003 Enables Microsoft(r) Office 2003 theme.
See Also

GetTheme, XTThemeManager

Example

The following example demonstrates how to use SetTheme.

XTThemeManager()->SetTheme(xtThemeOffice2003);
Group

CXTThemeManager Methods


CXTThemeManager Constructors

CXTThemeManager Class, Legend, Public Methods
CXTThemeManager Constructors
Class

CXTThemeManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTThemeManager | Constructs a CXTThemeManager object.


CXTThemeManager::CXTThemeManager Constructor

CXTThemeManager Constructors, CXTThemeManager Class
CXTThemeManager::CXTThemeManager Constructor

Constructs a CXTThemeManager object.

CXTThemeManager();
Group

CXTThemeManager Constructors


CXTThemeManager Destructors

CXTThemeManager Class, Legend, Public Methods
CXTThemeManager Destructors
Class

CXTThemeManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTThemeManager | Destroys a CXTThemeManager object, handles cleanup and deallocation.


CXTThemeManager::~CXTThemeManager Destructor

CXTThemeManager Destructors, CXTThemeManager Class
CXTThemeManager::~CXTThemeManager Destructor

Destroys a CXTThemeManager object, handles cleanup and deallocation.

virtual ~CXTThemeManager();
Group

CXTThemeManager Destructors


CXTThemeManagerStyle Class

XTThemeManager.h, Classes, Legend, Members, Topics, CXTThemeManagerStyle Data Members, CXTThemeManagerStyle Methods, CXTThemeManagerStyle Constructors, CXTThemeManagerStyle Destructors, CXTThemeManagerStyle Constructors, CXTThemeManagerStyle Data Members, CXTThemeManagerStyle Destructors, CXTThemeManagerStyle Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle Class

CXTThemeManagerStyle is standalone class used as base for any components theme.

Class Hierarchy

class CXTThemeManagerStyle;
File

XTThemeManager.h

Remarks

This is base class for any theme class. I collect information about selected theme and factory(CXTThemeManagerStyleFactory) created it.

See Also

CXTThemeManagerStyleFactory, CXTThemeManager, CXTThemeManagerStyleHost

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTThemeManagerStyle Constructors
CXTThemeManagerStyle Constructors | Description
CXTThemeManagerStyle | Construct a CXTThemeManagerStyle object.
CXTThemeManagerStyle Data Members
CXTThemeManagerStyle Data Members | Description
m_bmpSnapShot | Used for drawing transparent background.
m_enumTheme | Self theme enumerator.
m_pFactory | Self factory class.
CXTThemeManagerStyle Destructors
CXTThemeManagerStyle Destructors | Description
~CXTThemeManagerStyle | Destroys a CXTThemeManagerStyle object, handles cleanup and deallocation.
CXTThemeManagerStyle Methods
CXTThemeManagerStyle Methods | Description
DrawTransparentBack | This member function is called to render the window specified by pWndOwner transparent displaying the parent windows background instead.
GetTheme | Retrieves self theme enumerator.
GetThemeFactory | Retrieves factory created this theme
IsOfficeTheme | Retrieves if default or Microsoft(r) Office theme used.
RefreshMetrics | This method is called to refresh the visual metrics of the theme (fonts, colors, etc.).
TakeSnapShot | This member function is called by the Theme Manager to capture the area on the parent window underneath the specified owner window. This is then used for rendering the owner transparent.


CXTThemeManagerStyle Data Members

CXTThemeManagerStyle Class, Legend, Protected Data Members
CXTThemeManagerStyle Data Members
Class

CXTThemeManagerStyle Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bmpSnapShot | Used for drawing transparent background.
m_enumTheme | Self theme enumerator.
m_pFactory | Self factory class.


CXTThemeManagerStyle::m_bmpSnapShot Data Member

CXTThemeManagerStyle Data Members, CXTThemeManagerStyle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle::m_bmpSnapShot Data Member

Used for drawing transparent background.

CBitmap m_bmpSnapShot;
Group

CXTThemeManagerStyle Data Members


CXTThemeManagerStyle::m_enumTheme Data Member

CXTThemeManagerStyle Data Members, CXTThemeManagerStyle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle::m_enumTheme Data Member

Self theme enumerator.

XTThemeStyle m_enumTheme;
Group

CXTThemeManagerStyle Data Members


CXTThemeManagerStyle::m_pFactory Data Member

CXTThemeManagerStyle Data Members, CXTThemeManagerStyle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle::m_pFactory Data Member

Self factory class.

CXTThemeManagerStyleFactory* m_pFactory;
Group

CXTThemeManagerStyle Data Members


CXTThemeManagerStyle Methods

CXTThemeManagerStyle Class, Legend, Public Methods
CXTThemeManagerStyle Methods
Class

CXTThemeManagerStyle Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawTransparentBack | This member function is called to render the window specified by pWndOwner transparent displaying the parent windows background instead.
GetTheme | Retrieves self theme enumerator.
GetThemeFactory | Retrieves factory created this theme
IsOfficeTheme | Retrieves if default or Microsoft(r) Office theme used.
RefreshMetrics | This method is called to refresh the visual metrics of the theme (fonts, colors, etc.).
TakeSnapShot | This member function is called by the Theme Manager to capture the area on the parent window underneath the specified owner window. This is then used for rendering the owner transparent.


CXTThemeManagerStyle::DrawTransparentBack Method

CXTThemeManagerStyle Methods, CXTThemeManagerStyle Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle::DrawTransparentBack Method

This member function is called to render the window specified by pWndOwner transparent displaying the parent windows background instead.

virtual BOOL DrawTransparentBack(
    CDC* pDC,
    CWnd* pWndOwner
);
Parameters

pDC
Pointer to pWndOwner device context.
pWndOwner
Pointer the child of the parent window to draw transparent.

Returns

TRUE if the area was dran transparently, otherwise returns FALSE.

See Also

TakeSnapShot

Group

CXTThemeManagerStyle Methods


CXTThemeManagerStyle::GetTheme Method

CXTThemeManagerStyle Methods, CXTThemeManagerStyle Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle::GetTheme Method

Retrieves self theme enumerator.

XTThemeStyle GetTheme();
Returns

Self theme of CXTThemeManagerStyle class. It can be one of the following:

  • xtThemeDefault Enables Windows classic theme.
  • xtThemeOfficeXP Enables Microsoft(r) Office XP theme.
  • xtThemeOffice2003 Enables Microsoft(r) Office 2003 theme.
  • xtThemeCustom Enables User defined theme.
Body Source
XTThemeStyle CXTThemeManagerStyle::GetTheme() {
    return m_enumTheme;
}
Group

CXTThemeManagerStyle Methods


CXTThemeManagerStyle::GetThemeFactory Method

CXTThemeManagerStyle Methods, CXTThemeManagerStyle Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle::GetThemeFactory Method

Retrieves factory created this theme

CXTThemeManagerStyleFactory* GetThemeFactory();
Returns

Pointer to CXTThemeManagerStyleFactory class created the theme

Body Source
CXTThemeManagerStyleFactory* CXTThemeManagerStyle::GetThemeFactory() {
    return m_pFactory;
}
Group

CXTThemeManagerStyle Methods


CXTThemeManagerStyle::IsOfficeTheme Method

CXTThemeManagerStyle Methods, CXTThemeManagerStyle Class
CXTThemeManagerStyle::IsOfficeTheme Method

Retrieves if default or Microsoft(r) Office theme used.

BOOL IsOfficeTheme();
Returns

TRUE if xtThemeOfficeXP or xtThemeOffice2003 used.

Group

CXTThemeManagerStyle Methods


CXTThemeManagerStyle::RefreshMetrics Method

CXTThemeManagerStyle Methods, CXTThemeManagerStyle Class
CXTThemeManagerStyle::RefreshMetrics Method

This method is called to refresh the visual metrics of the theme (fonts, colors, etc.).

virtual void RefreshMetrics();
Group

CXTThemeManagerStyle Methods


CXTThemeManagerStyle::TakeSnapShot Method

CXTThemeManagerStyle Methods, CXTThemeManagerStyle Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle::TakeSnapShot Method

This member function is called by the Theme Manager to capture the area on the parent window underneath the specified owner window. This is then used for rendering the owner transparent.

virtual BOOL TakeSnapShot(
    CWnd* pWndOwner
);
Parameters

pWndOwner
Pointer the child of the parent window to take a snapshot for.

Returns

TRUE if the parent area was successfully captured, otherwise returns FALSE.

See Also

DrawTransparentBack

Group

CXTThemeManagerStyle Methods


CXTThemeManagerStyle Constructors

CXTThemeManagerStyle Class, Legend, Public Methods
CXTThemeManagerStyle Constructors
Class

CXTThemeManagerStyle Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTThemeManagerStyle | Construct a CXTThemeManagerStyle object.


CXTThemeManagerStyle::CXTThemeManagerStyle Constructor

CXTThemeManagerStyle Constructors, CXTThemeManagerStyle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyle::CXTThemeManagerStyle Constructor

Construct a CXTThemeManagerStyle object.

CXTThemeManagerStyle();
Group

CXTThemeManagerStyle Constructors


CXTThemeManagerStyle Destructors

CXTThemeManagerStyle Class, Legend, Public Methods
CXTThemeManagerStyle Destructors
Class

CXTThemeManagerStyle Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTThemeManagerStyle | Destroys a CXTThemeManagerStyle object, handles cleanup and deallocation.


CXTThemeManagerStyle::~CXTThemeManagerStyle Destructor

CXTThemeManagerStyle Destructors, CXTThemeManagerStyle Class
CXTThemeManagerStyle::~CXTThemeManagerStyle Destructor

Destroys a CXTThemeManagerStyle object, handles cleanup and deallocation.

virtual ~CXTThemeManagerStyle();
Group

CXTThemeManagerStyle Destructors


CXTThemeManagerStyleFactory Class

XTThemeManager.h, Classes, Legend, Members, Topics, CXTThemeManagerStyleFactory Methods, CXTThemeManagerStyleFactory Constructors, CXTThemeManagerStyleFactory Destructors, CXTThemeManagerStyleFactory Constructors, CXTThemeManagerStyleFactory Destructors, CXTThemeManagerStyleFactory Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleFactory Class

CXTThemeManagerStyleFactory is CObject derived class. It managed themes of corresponded CXTThemeManagerStyleHost class

Class Hierarchy

class CXTThemeManagerStyleFactory : public CObject;
File

XTThemeManager.h

Remarks

Each Component supported themes associated with one CXTThemeManagerStyleFactory class which porpoise is to create theme specified for this component. CXTThemeManagerStyleFactory class collect pointer to all CXTThemeManagerStyleHost used it. Use DECLARE_THEME_FACTORY and IMPLEMENT_THEME_FACTORY to create theme factory class.

See Also

CXTThemeManagerStyle, CXTThemeManager, CXTThemeManagerStyleHost

Group

Classes

Legend
Method
virtual
protected
CXTThemeManagerStyleFactory Constructors
CXTThemeManagerStyleFactory Constructors | Description
CXTThemeManagerStyleFactory | Construct a CXTThemeManagerStyleFactory object.
CXTThemeManagerStyleFactory Destructors
CXTThemeManagerStyleFactory Destructors | Description
~CXTThemeManagerStyleFactory | Destroys a CXTThemeManagerStyleFactory object, handles cleanup and deallocation.
CXTThemeManagerStyleFactory Methods
CXTThemeManagerStyleFactory Methods | Description
CreateTheme | This method created specified theme for corresponded CXTThemeManagerStyleHost component
GetSafeTheme | Retrieves safe theme.
OnCreateSafeTheme | This method is called when new theme created.
RefreshMetrics | This method is called to refresh the visual metrics of the safe theme (fonts, colors, etc.).
SetTheme |


CXTThemeManagerStyleFactory Methods

CXTThemeManagerStyleFactory Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleFactory Methods
Class

CXTThemeManagerStyleFactory Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnCreateSafeTheme | This method is called when new theme created.
Public Methods
Public Methods
Public Method | Description
CreateTheme | This method created specified theme for corresponded CXTThemeManagerStyleHost component
GetSafeTheme | Retrieves safe theme.
RefreshMetrics | This method is called to refresh the visual metrics of the safe theme (fonts, colors, etc.).
SetTheme |


CXTThemeManagerStyleFactory::CreateTheme Method

CXTThemeManagerStyleFactory Methods, CXTThemeManagerStyleFactory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleFactory::CreateTheme Method

This method created specified theme for corresponded CXTThemeManagerStyleHost component

virtual CXTThemeManagerStyle* CreateTheme(
    XTThemeStyle theme
);
Parameters

theme
Theme need to create

Remarks

Use IMPLEMENT_THEME_FACTORY macro to create new theme with overridden CreateTheme method

Group

CXTThemeManagerStyleFactory Methods


CXTThemeManagerStyleFactory::GetSafeTheme Method

CXTThemeManagerStyleFactory Methods, CXTThemeManagerStyleFactory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleFactory::GetSafeTheme Method

Retrieves safe theme.

CXTThemeManagerStyle* GetSafeTheme();
Returns

Pointer to safe CXTThemeManagerStyle class.

Group

CXTThemeManagerStyleFactory Methods


CXTThemeManagerStyleFactory::OnCreateSafeTheme Method

CXTThemeManagerStyleFactory Methods, CXTThemeManagerStyleFactory Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleFactory::OnCreateSafeTheme Method

This method is called when new theme created.

void OnCreateSafeTheme(
    CXTThemeManagerStyle* pTheme,
    XTThemeStyle theme
);
Parameters

pTheme
new created theme pointer.
theme
style of theme was created.

Body Source
void CXTThemeManagerStyleFactory::OnCreateSafeTheme(CXTThemeManagerStyle* pTheme, XTThemeStyle theme) {
    pTheme->m_enumTheme = theme;
}
Group

CXTThemeManagerStyleFactory Methods


CXTThemeManagerStyleFactory::RefreshMetrics Method

CXTThemeManagerStyleFactory Methods, CXTThemeManagerStyleFactory Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleFactory::RefreshMetrics Method

This method is called to refresh the visual metrics of the safe theme (fonts, colors, etc.).

virtual void RefreshMetrics();
Remarks

It routes call to self m_pTheme:

Example

The following example demonstrates how to use RefreshMetrics.

if (m_pTheme)
{
    m_pTheme->RefreshMetrics();
}
Group

CXTThemeManagerStyleFactory Methods


SetTheme Method

CXTThemeManagerStyleFactory Methods
SetTheme Method
Overload List
Methods
Method | Description
CXTThemeManagerStyleFactory::SetTheme (CXTThemeManagerStyle*) | Call this method to set safe theme
CXTThemeManagerStyleFactory::SetTheme (XTThemeStyle) | Call this method to set safe theme
Group

CXTThemeManagerStyleFactory Methods


CXTThemeManagerStyleFactory::SetTheme Method (XTThemeStyle)

SetTheme Method, CXTThemeManagerStyleFactory Class
CXTThemeManagerStyleFactory::SetTheme Method (XTThemeStyle)

Call this method to set safe theme

void SetTheme(
    XTThemeStyle theme
);
void SetTheme(
    CXTThemeManagerStyle* pTheme
);
Parameters

theme
Theme enumerator.
pTheme
Pointer to custom theme

Remarks

theme can be one of following values:

  • xtThemeDefault Enables Windows classic theme.
  • xtThemeOfficeXP Enables Microsoft(r) Office XP theme.
  • xtThemeOffice2003 Enables Microsoft(r) Office 2003 theme.
Group

SetTheme Method


CXTThemeManagerStyleFactory Constructors

CXTThemeManagerStyleFactory Class, Legend, Public Methods
CXTThemeManagerStyleFactory Constructors
Class

CXTThemeManagerStyleFactory Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTThemeManagerStyleFactory | Construct a CXTThemeManagerStyleFactory object.


CXTThemeManagerStyleFactory::CXTThemeManagerStyleFactory Constructor

CXTThemeManagerStyleFactory Constructors, CXTThemeManagerStyleFactory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleFactory::CXTThemeManagerStyleFactory Constructor

Construct a CXTThemeManagerStyleFactory object.

CXTThemeManagerStyleFactory();
Group

CXTThemeManagerStyleFactory Constructors


CXTThemeManagerStyleFactory Destructors

CXTThemeManagerStyleFactory Class, Legend, Public Methods
CXTThemeManagerStyleFactory Destructors
Class

CXTThemeManagerStyleFactory Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTThemeManagerStyleFactory | Destroys a CXTThemeManagerStyleFactory object, handles cleanup and deallocation.


CXTThemeManagerStyleFactory::~CXTThemeManagerStyleFactory Destructor

CXTThemeManagerStyleFactory Destructors, CXTThemeManagerStyleFactory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleFactory::~CXTThemeManagerStyleFactory Destructor

Destroys a CXTThemeManagerStyleFactory object, handles cleanup and deallocation.

virtual ~CXTThemeManagerStyleFactory();
Group

CXTThemeManagerStyleFactory Destructors


CXTThemeManagerStyleHost Class

XTThemeManager.h, Classes, Legend, Members, Topics, CXTThemeManagerStyleHost Data Members, CXTThemeManagerStyleHost Methods, CXTThemeManagerStyleHost Constructors, CXTThemeManagerStyleHost Destructors, CXTThemeManagerStyleHost Constructors, CXTThemeManagerStyleHost Data Members, CXTThemeManagerStyleHost Destructors, CXTThemeManagerStyleHost Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost Class

CXTThemeManagerStyleHost is standalone class. It used as base class for all themed component.

Class Hierarchy

class CXTThemeManagerStyleHost;
File

XTThemeManager.h

Remarks

CXTThemeManagerStyleHost is base class for all theme supported components. Use its methods to set specified for individual component theme.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTThemeManagerStyleHost Constructors
CXTThemeManagerStyleHost Constructors | Description
CXTThemeManagerStyleHost | Constructs a CXTThemeManagerStyleHost object.
CXTThemeManagerStyleHost Data Members
CXTThemeManagerStyleHost Data Members | Description
m_bAutoDeleteCustomFactory | TRUE to delete custom theme factory.
m_pCustomFactory | Custom theme factory
m_pDefaultFactory | Default theme factory
m_pThemeFactoryClass | Runtime class of default theme factory.
CXTThemeManagerStyleHost Destructors
CXTThemeManagerStyleHost Destructors | Description
~CXTThemeManagerStyleHost | Destroys a CXTThemeManagerStyleHost object, handles cleanup and deallocation.
CXTThemeManagerStyleHost Methods
CXTThemeManagerStyleHost Methods | Description
AttachThemeFactory | Call this method to attach factory to the component.
CreateThemeFactory | This method called to create self theme factory class
GetSafeTheme | Retrieves safe theme of component
GetSafeThemeFactory | Retrieves self factory class
InitStyleHost | This member function is called to initialize the theme manager style host.
OnThemeChanged | This method is called then self theme is changed. Override this method to redraw or reposition parts of component according of new theme.
SetTheme |


CXTThemeManagerStyleHost Data Members

CXTThemeManagerStyleHost Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost Data Members
Class

CXTThemeManagerStyleHost Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoDeleteCustomFactory | TRUE to delete custom theme factory.
m_pCustomFactory | Custom theme factory
m_pDefaultFactory | Default theme factory
m_pThemeFactoryClass | Runtime class of default theme factory.


CXTThemeManagerStyleHost::m_bAutoDeleteCustomFactory Data Member

CXTThemeManagerStyleHost Data Members, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::m_bAutoDeleteCustomFactory Data Member

TRUE to delete custom theme factory.

BOOL m_bAutoDeleteCustomFactory;
Group

CXTThemeManagerStyleHost Data Members


CXTThemeManagerStyleHost::m_pCustomFactory Data Member

CXTThemeManagerStyleHost Data Members, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::m_pCustomFactory Data Member

Custom theme factory

CXTThemeManagerStyleFactory* m_pCustomFactory;
Group

CXTThemeManagerStyleHost Data Members


CXTThemeManagerStyleHost::m_pDefaultFactory Data Member

CXTThemeManagerStyleHost Data Members, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::m_pDefaultFactory Data Member

Default theme factory

CXTThemeManagerStyleFactory* m_pDefaultFactory;
Group

CXTThemeManagerStyleHost Data Members


CXTThemeManagerStyleHost::m_pThemeFactoryClass Data Member

CXTThemeManagerStyleHost Data Members, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::m_pThemeFactoryClass Data Member

Runtime class of default theme factory.

CRuntimeClass* m_pThemeFactoryClass;
Group

CXTThemeManagerStyleHost Data Members


CXTThemeManagerStyleHost Methods

CXTThemeManagerStyleHost Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost Methods
Class

CXTThemeManagerStyleHost Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CreateThemeFactory | This method called to create self theme factory class
GetSafeTheme | Retrieves safe theme of component
GetSafeThemeFactory | Retrieves self factory class
InitStyleHost | This member function is called to initialize the theme manager style host.
OnThemeChanged | This method is called then self theme is changed. Override this method to redraw or reposition parts of component according of new theme.
Public Methods
Public Methods
Public Method | Description
AttachThemeFactory | Call this method to attach factory to the component.
SetTheme |


CXTThemeManagerStyleHost::AttachThemeFactory Method

CXTThemeManagerStyleHost Methods, CXTThemeManagerStyleHost Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::AttachThemeFactory Method

Call this method to attach factory to the component.

void AttachThemeFactory(
    CXTThemeManagerStyleFactory* pFactory
);
Parameters

pFactory
Factory need to be attached.

Example

The following example demonstrates how to use AttachThemeFactory.

extern CXTCaptionThemeFactory m_buttonFactory;
m_buttonFactory.SetTheme(xtpThemeOffice2003);
m_btnOK.AttachThemeFactory(&m_buttonFactory)
m_btnCancel.AttachThemeFactory(&m_buttonFactory)
Group

CXTThemeManagerStyleHost Methods


CXTThemeManagerStyleHost::CreateThemeFactory Method

CXTThemeManagerStyleHost Methods, CXTThemeManagerStyleHost Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::CreateThemeFactory Method

This method called to create self theme factory class

virtual CXTThemeManagerStyleFactory* CreateThemeFactory();
Returns

Pointer to created CXTThemeManagerStyleFactory class

Remarks

It creates factory class used runtime class specified in constructor.

Example

The following example demonstrates how to use CreateThemeFactory.

return (CXTThemeManagerStyleFactory*)m_pThemeFactoryClass->CreateObject();
Group

CXTThemeManagerStyleHost Methods


CXTThemeManagerStyleHost::GetSafeTheme Method

CXTThemeManagerStyleHost Methods, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::GetSafeTheme Method

Retrieves safe theme of component

CXTThemeManagerStyle* GetSafeTheme() const;
Returns

Pointer to self theme.

Group

CXTThemeManagerStyleHost Methods


CXTThemeManagerStyleHost::GetSafeThemeFactory Method

CXTThemeManagerStyleHost Methods, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::GetSafeThemeFactory Method

Retrieves self factory class

CXTThemeManagerStyleFactory* GetSafeThemeFactory() const;
Returns

Pointer to CXTThemeManagerStyleFactory class.

Group

CXTThemeManagerStyleHost Methods


CXTThemeManagerStyleHost::InitStyleHost Method

CXTThemeManagerStyleHost Methods, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::InitStyleHost Method

This member function is called to initialize the theme manager style host.

void InitStyleHost(
    CRuntimeClass* pThemeFactoryClass
);
Parameters

pThemeFactoryClass
Factory runtime class associated with this class

Group

CXTThemeManagerStyleHost Methods


CXTThemeManagerStyleHost::OnThemeChanged Method

CXTThemeManagerStyleHost Methods, CXTThemeManagerStyleHost Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::OnThemeChanged Method

This method is called then self theme is changed. Override this method to redraw or reposition parts of component according of new theme.

virtual void OnThemeChanged();
See Also

GetSafeTheme

Group

CXTThemeManagerStyleHost Methods


SetTheme Method

CXTThemeManagerStyleHost Methods
SetTheme Method
Overload List
Methods
Method | Description
CXTThemeManagerStyleHost::SetTheme (CXTThemeManagerStyle*) | Call this method to set theme for the component
CXTThemeManagerStyleHost::SetTheme (XTThemeStyle) | Call this method to set theme for the component
Group

CXTThemeManagerStyleHost Methods


CXTThemeManagerStyleHost::SetTheme Method (XTThemeStyle)

SetTheme Method, CXTThemeManagerStyleHost Class, Example
CXTThemeManagerStyleHost::SetTheme Method (XTThemeStyle)

Call this method to set theme for the component

void SetTheme(
    XTThemeStyle theme
);
void SetTheme(
    CXTThemeManagerStyle* pTheme
);
Parameters

theme
Theme need to be set
pTheme
Custom theme need to be set

Remarks

Theme can be one of following values:

  • xtThemeDefault Enables Windows classic theme.
  • xtThemeOfficeXP Enables Microsoft(r) Office XP theme.
  • xtThemeOffice2003 Enables Microsoft(r) Office 2003 theme.
Example

The following example demonstrates how to use SetTheme.

m_btnOK.SetTheme(xtThemeOffice2003)
m_btnCancel.SetTheme(xtThemeOffice2003)
Group

SetTheme Method


CXTThemeManagerStyleHost Constructors

CXTThemeManagerStyleHost Class, Legend, Protected Methods
CXTThemeManagerStyleHost Constructors
Class

CXTThemeManagerStyleHost Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTThemeManagerStyleHost | Constructs a CXTThemeManagerStyleHost object.


CXTThemeManagerStyleHost::CXTThemeManagerStyleHost Constructor

CXTThemeManagerStyleHost Constructors, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::CXTThemeManagerStyleHost Constructor

Constructs a CXTThemeManagerStyleHost object.

CXTThemeManagerStyleHost(
    CRuntimeClass* pThemeFactoryClass
);
Parameters

pThemeFactoryClass
Factory runtime class associated with this class

Group

CXTThemeManagerStyleHost Constructors


CXTThemeManagerStyleHost Destructors

CXTThemeManagerStyleHost Class, Legend, Protected Methods
CXTThemeManagerStyleHost Destructors
Class

CXTThemeManagerStyleHost Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTThemeManagerStyleHost | Destroys a CXTThemeManagerStyleHost object, handles cleanup and deallocation.


CXTThemeManagerStyleHost::~CXTThemeManagerStyleHost Destructor

CXTThemeManagerStyleHost Destructors, CXTThemeManagerStyleHost Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTThemeManagerStyleHost::~CXTThemeManagerStyleHost Destructor

Destroys a CXTThemeManagerStyleHost object, handles cleanup and deallocation.

virtual ~CXTThemeManagerStyleHost();
Group

CXTThemeManagerStyleHost Destructors


CXTTimeEdit Class

XTMaskEdit.h, Classes, Legend, Members, Topics, CXTTimeEdit Data Members, CXTTimeEdit Methods, CXTTimeEdit Constructors, CXTTimeEdit Constructors, CXTTimeEdit Data Members, CXTTimeEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTimeEdit Class

CXTTimeEdit is a CXTDateEdit derived class. It is specifically geared toward editing time fields.

Class Hierarchy

class CXTTimeEdit : public CXTDateEdit;
File

XTMaskEdit.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTTimeEdit Constructors
CXTTimeEdit Constructors | Description
CXTTimeEdit | Constructs a CXTTimeEdit object
CXTTimeEdit Data Members
CXTTimeEdit Data Members | Description
m_bMilitary | true if military time is used.
m_iHours | Represents the hours to display.
m_iMins | Represents the minutes to display.
CXTTimeEdit Methods
CXTTimeEdit Methods | Description
FormatOleDateTime | This member function will read the time passed in as 'dt', and format the 'strData' string as HH:MM.
GetHours | This member function will retrieve the hours displayed for the time edit control.
GetMins | This member function will retrieve the minutes displayed for the time edit control.
ProcessMask | This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
SetHours | This member function will update the hours displayed.
SetMilitary | Sets military time format
SetMins | This member function will update the minutes displayed.
SetTime | This member function will update the hours and minutes that are displayed for the time edit control.


CXTTimeEdit Data Members

CXTTimeEdit Class, Legend, Protected Data Members
CXTTimeEdit Data Members
Class

CXTTimeEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bMilitary | true if military time is used.
m_iHours | Represents the hours to display.
m_iMins | Represents the minutes to display.


CXTTimeEdit::m_bMilitary Data Member

CXTTimeEdit Data Members, CXTTimeEdit Class
CXTTimeEdit::m_bMilitary Data Member

true if military time is used.

BOOL m_bMilitary;
Group

CXTTimeEdit Data Members


CXTTimeEdit::m_iHours Data Member

CXTTimeEdit Data Members, CXTTimeEdit Class
CXTTimeEdit::m_iHours Data Member

Represents the hours to display.

int m_iHours;
Group

CXTTimeEdit Data Members


CXTTimeEdit::m_iMins Data Member

CXTTimeEdit Data Members, CXTTimeEdit Class
CXTTimeEdit::m_iMins Data Member

Represents the minutes to display.

int m_iMins;
Group

CXTTimeEdit Data Members


CXTTimeEdit Methods

CXTTimeEdit Class, Legend, Public Methods
CXTTimeEdit Methods
Class

CXTTimeEdit Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
FormatOleDateTime | This member function will read the time passed in as 'dt', and format the 'strData' string as HH:MM.
GetHours | This member function will retrieve the hours displayed for the time edit control.
GetMins | This member function will retrieve the minutes displayed for the time edit control.
ProcessMask | This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
SetHours | This member function will update the hours displayed.
SetMilitary | Sets military time format
SetMins | This member function will update the minutes displayed.
SetTime | This member function will update the hours and minutes that are displayed for the time edit control.


CXTTimeEdit::FormatOleDateTime Method

CXTTimeEdit Methods, CXTTimeEdit Class
CXTTimeEdit::FormatOleDateTime Method

This member function will read the time passed in as 'dt', and format the 'strData' string as HH:MM.

virtual void FormatOleDateTime(
    CString& strData,
    COleDateTime dt
);
Parameters

strData
String reference that is filled with the time.
dt
COleDateTime object that represents the time to format.

Group

CXTTimeEdit Methods


CXTTimeEdit::GetHours Method

CXTTimeEdit Methods, CXTTimeEdit Class, Body Source
CXTTimeEdit::GetHours Method

This member function will retrieve the hours displayed for the time edit control.

int GetHours() const;
Returns

An integer value that represents the hours displayed.

Body Source
int CXTTimeEdit::GetHours() const {
    return m_iHours;
}
Group

CXTTimeEdit Methods


CXTTimeEdit::GetMins Method

CXTTimeEdit Methods, CXTTimeEdit Class, Body Source
CXTTimeEdit::GetMins Method

This member function will retrieve the minutes displayed for the time edit control.

int GetMins() const;
Returns

An integer value that represents the minutes displayed.

Body Source
int CXTTimeEdit::GetMins() const {
    return m_iMins;
}
Group

CXTTimeEdit Methods


CXTTimeEdit::ProcessMask Method

CXTTimeEdit Methods, CXTTimeEdit Class
CXTTimeEdit::ProcessMask Method

This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.

virtual BOOL ProcessMask(
    TCHAR& nChar,
    int nEndPos
);
Parameters

nChar
Contains the character code value of the key.
nEndPos
Index of the character in the display string.

Returns

true if successful, otherwise returns false.

Group

CXTTimeEdit Methods


CXTTimeEdit::SetHours Method

CXTTimeEdit Methods, CXTTimeEdit Class
CXTTimeEdit::SetHours Method

This member function will update the hours displayed.

virtual void SetHours(
    int nHours
);
Parameters

nHours
The new hour to be displayed.

Group

CXTTimeEdit Methods


CXTTimeEdit::SetMilitary Method

CXTTimeEdit Methods, CXTTimeEdit Class, Body Source
CXTTimeEdit::SetMilitary Method

Sets military time format

void SetMilitary(
    BOOL bMilitary = TRUE
);
Parameters

bMilitary
true if military time is used.

Body Source
void CXTTimeEdit::SetMilitary(BOOL bMilitary /*= TRUE*/) {
    m_bMilitary = bMilitary;

}
Group

CXTTimeEdit Methods


CXTTimeEdit::SetMins Method

CXTTimeEdit Methods, CXTTimeEdit Class
CXTTimeEdit::SetMins Method

This member function will update the minutes displayed.

virtual void SetMins(
    int nMins
);
Parameters

nMins
The new minutes to be displayed.

Group

CXTTimeEdit Methods


CXTTimeEdit::SetTime Method

CXTTimeEdit Methods, CXTTimeEdit Class
CXTTimeEdit::SetTime Method

This member function will update the hours and minutes that are displayed for the time edit control.

virtual void SetTime(
    int nHours,
    int nMins
);
Parameters

nHours
The new hour to be displayed.
nMins
The new minutes to be displayed.

Group

CXTTimeEdit Methods


CXTTimeEdit Constructors

CXTTimeEdit Class, Legend, Public Methods
CXTTimeEdit Constructors
Class

CXTTimeEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTimeEdit | Constructs a CXTTimeEdit object


CXTTimeEdit::CXTTimeEdit Constructor

CXTTimeEdit Constructors, CXTTimeEdit Class
CXTTimeEdit::CXTTimeEdit Constructor

Constructs a CXTTimeEdit object

CXTTimeEdit();
Group

CXTTimeEdit Constructors


CXTTipOfTheDay Class

XTTipOfTheDay.h, Classes, Legend, Members, Topics, CXTTipOfTheDay Data Members, CXTTipOfTheDay Methods, CXTTipOfTheDay Constructors, CXTTipOfTheDay Destructors, CXTTipOfTheDay Constructors, CXTTipOfTheDay Data Members, CXTTipOfTheDay Destructors, CXTTipOfTheDay Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTipOfTheDay Class

CXTTipOfTheDay is a CDialog derived class. CXTTipOfTheDay is used to create a Visual Studio(tm) style Tip Of The Day dialog. To use, place a file called "tips.txt" in the same directory as your application exe. Place each tip on its own line.

Class Hierarchy

class CXTTipOfTheDay : public CDialog;
File

XTTipOfTheDay.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTTipOfTheDay Constructors
CXTTipOfTheDay Constructors | Description
CXTTipOfTheDay | Constructs a CXTTipOfTheDay object
CXTTipOfTheDay Data Members
CXTTipOfTheDay Data Members | Description
m_bClassicStyle | Classic Style
m_fontTip | Default font used for tips.
m_fontTitle | Default font used for "Did you know..." text.
m_ilLightBulb | Bulb bitmap.
m_pFontTip | User defined font for tips.
m_pFontTitle | User defined font for "Did you know..." text.
m_pStream | A pointer to the open file stream.
m_rcBorder | Size of the total display area.
m_rcTipText | Size of the display area for tip text.
m_strTipFile | Represents the file name and path for the tips file.
m_strTipText | Represents the Tip Of The Day text.
m_strTipTitle | Represents the "Did you know" text.
CXTTipOfTheDay Destructors
CXTTipOfTheDay Destructors | Description
~CXTTipOfTheDay | Destroys a CXTTipOfTheDay object, handles cleanup and deallocation
CXTTipOfTheDay Methods
CXTTipOfTheDay Methods | Description
GetNextTipString | This member function will retrieve the next string to be displayed as the Tip Of The Day.
SetDefaultFonts | This member function will set the fonts to be used by the "Did you know..." and the Tip Of The Day text.
SetDefaultTitle | This member function will set the text that is to be displayed in place of the "Did you know..." string.
SetTipsFilePath | This member function will set the path to where the tips file is located.


CXTTipOfTheDay Data Members

CXTTipOfTheDay Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTipOfTheDay Data Members
Class

CXTTipOfTheDay Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_fontTip | Default font used for tips.
m_fontTitle | Default font used for "Did you know..." text.
m_ilLightBulb | Bulb bitmap.
m_pFontTip | User defined font for tips.
m_pFontTitle | User defined font for "Did you know..." text.
m_pStream | A pointer to the open file stream.
m_rcBorder | Size of the total display area.
m_rcTipText | Size of the display area for tip text.
m_strTipFile | Represents the file name and path for the tips file.
m_strTipText | Represents the Tip Of The Day text.
m_strTipTitle | Represents the "Did you know" text.
Public Data Members
Public Data Member | Description
m_bClassicStyle | Classic Style


CXTTipOfTheDay::m_bClassicStyle Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_bClassicStyle Data Member

Classic Style

BOOL m_bClassicStyle;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_fontTip Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_fontTip Data Member

Default font used for tips.

CFont m_fontTip;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_fontTitle Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_fontTitle Data Member

Default font used for "Did you know..." text.

CFont m_fontTitle;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_ilLightBulb Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_ilLightBulb Data Member

Bulb bitmap.

CXTPImageManager m_ilLightBulb;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_pFontTip Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_pFontTip Data Member

User defined font for tips.

CFont* m_pFontTip;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_pFontTitle Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_pFontTitle Data Member

User defined font for "Did you know..." text.

CFont* m_pFontTitle;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_pStream Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_pStream Data Member

A pointer to the open file stream.

FILE* m_pStream;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_rcBorder Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_rcBorder Data Member

Size of the total display area.

CRect m_rcBorder;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_rcTipText Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_rcTipText Data Member

Size of the display area for tip text.

CRect m_rcTipText;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_strTipFile Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_strTipFile Data Member

Represents the file name and path for the tips file.

CString m_strTipFile;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_strTipText Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_strTipText Data Member

Represents the Tip Of The Day text.

CString m_strTipText;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay::m_strTipTitle Data Member

CXTTipOfTheDay Data Members, CXTTipOfTheDay Class
CXTTipOfTheDay::m_strTipTitle Data Member

Represents the "Did you know" text.

CString m_strTipTitle;
Group

CXTTipOfTheDay Data Members


CXTTipOfTheDay Methods

CXTTipOfTheDay Class, Legend, Public Methods
CXTTipOfTheDay Methods
Class

CXTTipOfTheDay Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetNextTipString | This member function will retrieve the next string to be displayed as the Tip Of The Day.
SetDefaultFonts | This member function will set the fonts to be used by the "Did you know..." and the Tip Of The Day text.
SetDefaultTitle | This member function will set the text that is to be displayed in place of the "Did you know..." string.
SetTipsFilePath | This member function will set the path to where the tips file is located.


CXTTipOfTheDay::GetNextTipString Method

CXTTipOfTheDay Methods, CXTTipOfTheDay Class
CXTTipOfTheDay::GetNextTipString Method

This member function will retrieve the next string to be displayed as the Tip Of The Day.

virtual void GetNextTipString(
    CString& strNext
);
Parameters

strNext
A CString reference that represents the next Tip Of The Day text that is to be displayed.

Group

CXTTipOfTheDay Methods


CXTTipOfTheDay::SetDefaultFonts Method

CXTTipOfTheDay Methods, CXTTipOfTheDay Class
CXTTipOfTheDay::SetDefaultFonts Method

This member function will set the fonts to be used by the "Did you know..." and the Tip Of The Day text.

virtual void SetDefaultFonts(
    CFont* pFontTitle,
    CFont* pFontTip
);
Parameters

pFontTitle
Points to a CFont object that represents the new font to be used for the "Did you know..." text.
pFontTip
Points to a CFont object that represents the new font to be used for the Tip Of The Day text.

Group

CXTTipOfTheDay Methods


CXTTipOfTheDay::SetDefaultTitle Method

CXTTipOfTheDay Methods, CXTTipOfTheDay Class, Body Source
CXTTipOfTheDay::SetDefaultTitle Method

This member function will set the text that is to be displayed in place of the "Did you know..." string.

virtual void SetDefaultTitle(
    LPCTSTR lpszTitle
);
Parameters

lpszTitle
Represents a NULL terminated string that is the string to be displayed in place of the "Did you know..." text.

Body Source
void CXTTipOfTheDay::SetDefaultTitle(LPCTSTR lpszTitle) {
    m_strTipTitle = lpszTitle;
}
Group

CXTTipOfTheDay Methods


CXTTipOfTheDay::SetTipsFilePath Method

CXTTipOfTheDay Methods, CXTTipOfTheDay Class
CXTTipOfTheDay::SetTipsFilePath Method

This member function will set the path to where the tips file is located.

virtual void SetTipsFilePath(
    LPCTSTR lpszTipFile
);
Parameters

lpszTipFile
A NULL terminated string that represents the full path to where the tips text file is located.

Group

CXTTipOfTheDay Methods


CXTTipOfTheDay Constructors

CXTTipOfTheDay Class, Legend, Public Methods
CXTTipOfTheDay Constructors
Class

CXTTipOfTheDay Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTipOfTheDay | Constructs a CXTTipOfTheDay object


CXTTipOfTheDay::CXTTipOfTheDay Constructor

CXTTipOfTheDay Constructors, CXTTipOfTheDay Class
CXTTipOfTheDay::CXTTipOfTheDay Constructor

Constructs a CXTTipOfTheDay object

CXTTipOfTheDay(
    LPCTSTR lpszTipFile = NULL,
    CWnd* pParent = NULL
);
Parameters

lpszTipFile
A NULL terminated string that represents the path and file name of where the tips text file is located. By default, the file name is set to "tips.txt".
pParent
Points to the parent window for the Tip Of The Day Dialog.

Group

CXTTipOfTheDay Constructors


CXTTipOfTheDay Destructors

CXTTipOfTheDay Class, Legend, Public Methods
CXTTipOfTheDay Destructors
Class

CXTTipOfTheDay Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTipOfTheDay | Destroys a CXTTipOfTheDay object, handles cleanup and deallocation


CXTTipOfTheDay::~CXTTipOfTheDay Destructor

CXTTipOfTheDay Destructors, CXTTipOfTheDay Class
CXTTipOfTheDay::~CXTTipOfTheDay Destructor

Destroys a CXTTipOfTheDay object, handles cleanup and deallocation

virtual ~CXTTipOfTheDay();
Group

CXTTipOfTheDay Destructors


CXTTipWindow Class

XTTipWindow.h, Classes, Legend, Members, Topics, CXTTipWindow Data Members, CXTTipWindow Methods, CXTTipWindow Constructors, CXTTipWindow Destructors, CXTTipWindow Constructors, CXTTipWindow Data Members, CXTTipWindow Destructors, CXTTipWindow Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTipWindow Class

CXTTipWindow is a CWnd derived class. It is used to create a CXTTipWindow object. CXTTipWindow objects are tooltip style popup windows that can display useful information to the end user. Possible options include shadows, borders, and background color settings.

Class Hierarchy

class CXTTipWindow : public CWnd;
File

XTTipWindow.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTTipWindow Constructors
CXTTipWindow Constructors | Description
CXTTipWindow | Constructs a CXTTipWindow object
CXTTipWindow Data Members
CXTTipWindow Data Members | Description
m_arStrings | Stores strings if the tip is multiline.
m_bCenterHorz | TRUE if the window is to be centered horizontally.
m_bDelayTimerRunning | TRUE if delay timer is running.
m_crBackColor | Background color for the tip window.
m_crTextColor | Text color for the tip window.
m_dwTipStyle | Initial style for the tip window.
m_nDelayTimerEventID | Delay timer event ID.
m_nElapseTimerEventID | Elapse timer event ID.
m_nLineSpace | Amount in pixels to space the title and description text.
m_nTabPositions | Specifies the number of tab-stop positions in the array pointed to by m_pnTabStopPositions.
m_pnTabStopPositions | Points to an array of integers containing the tab-stop positions in logical units.
m_pointTipOffsetPos | Specifies the offset to move the top window in relation to the mouse cursor.
m_pParentWnd | Parent window.
m_ptMousePos | Initial xy coordinates of the cursor when when tip window was created.
m_rcScreenWindow | Initial size of the desktop.
m_rcShadow | Initial size of the tip window shadow.
m_rcWindow | Initial size of the tip window.
m_rectTipArea | Size of the client area for the tip window.
m_sizeMargin | Amount in pixels of the tip and side margins of where the tip text is displayed.
m_sizeTitle | title text size.
m_strDescrip | Description text for the tip window.
m_strTitle | Title text for the tip window.
CXTTipWindow Destructors
CXTTipWindow Destructors | Description
~CXTTipWindow | Destroys a CXTTipWindow object, handles cleanup and deallocation
CXTTipWindow Methods
CXTTipWindow Methods | Description
Create | Call this member function to create the tooltip window.
DrawShadowRect | This member function will draw a shadow rect to the device context specified by 'pDC'.
ForwardMessage | Forwards a message to the window at specified cursor position.
HideTipWindow | Call this member function to hide the tip window
InitializeSize | This member function will set the sizes for the tip window.
SetLineSpace | This member function will set the line spacing for the tip window.
SetMargins | This member function will set the text margins for the tip window.
SetTextTabStopPositions | Call this member function to set the text tab stop positions for the tooltip window.
SetTipColors | This member function will set the text and background colors for the tip window display.
SetTipOffsetPos | Call this member function to offset the tip window by the distance specified by pointOffset.
SetTipText | This member function will set the text for the title and description values that are displayed in the tip window.
ShowTipWindow |


CXTTipWindow Data Members

CXTTipWindow Class, Legend, Protected Data Members
CXTTipWindow Data Members
Class

CXTTipWindow Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arStrings | Stores strings if the tip is multiline.
m_bCenterHorz | TRUE if the window is to be centered horizontally.
m_bDelayTimerRunning | TRUE if delay timer is running.
m_crBackColor | Background color for the tip window.
m_crTextColor | Text color for the tip window.
m_dwTipStyle | Initial style for the tip window.
m_nDelayTimerEventID | Delay timer event ID.
m_nElapseTimerEventID | Elapse timer event ID.
m_nLineSpace | Amount in pixels to space the title and description text.
m_nTabPositions | Specifies the number of tab-stop positions in the array pointed to by m_pnTabStopPositions.
m_pnTabStopPositions | Points to an array of integers containing the tab-stop positions in logical units.
m_pointTipOffsetPos | Specifies the offset to move the top window in relation to the mouse cursor.
m_pParentWnd | Parent window.
m_ptMousePos | Initial xy coordinates of the cursor when when tip window was created.
m_rcScreenWindow | Initial size of the desktop.
m_rcShadow | Initial size of the tip window shadow.
m_rcWindow | Initial size of the tip window.
m_rectTipArea | Size of the client area for the tip window.
m_sizeMargin | Amount in pixels of the tip and side margins of where the tip text is displayed.
m_sizeTitle | title text size.
m_strDescrip | Description text for the tip window.
m_strTitle | Title text for the tip window.


CXTTipWindow::m_arStrings Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_arStrings Data Member

Stores strings if the tip is multiline.

CStringArray m_arStrings;
Group

CXTTipWindow Data Members


CXTTipWindow::m_bCenterHorz Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_bCenterHorz Data Member

TRUE if the window is to be centered horizontally.

BOOL m_bCenterHorz;
Group

CXTTipWindow Data Members


CXTTipWindow::m_bDelayTimerRunning Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_bDelayTimerRunning Data Member

TRUE if delay timer is running.

BOOL m_bDelayTimerRunning;
Group

CXTTipWindow Data Members


CXTTipWindow::m_crBackColor Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_crBackColor Data Member

Background color for the tip window.

COLORREF m_crBackColor;
Group

CXTTipWindow Data Members


CXTTipWindow::m_crTextColor Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_crTextColor Data Member

Text color for the tip window.

COLORREF m_crTextColor;
Group

CXTTipWindow Data Members


CXTTipWindow::m_dwTipStyle Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_dwTipStyle Data Member

Initial style for the tip window.

DWORD m_dwTipStyle;
Group

CXTTipWindow Data Members


CXTTipWindow::m_nDelayTimerEventID Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_nDelayTimerEventID Data Member

Delay timer event ID.

UINT m_nDelayTimerEventID;
Group

CXTTipWindow Data Members


CXTTipWindow::m_nElapseTimerEventID Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_nElapseTimerEventID Data Member

Elapse timer event ID.

UINT m_nElapseTimerEventID;
Group

CXTTipWindow Data Members


CXTTipWindow::m_nLineSpace Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_nLineSpace Data Member

Amount in pixels to space the title and description text.

int m_nLineSpace;
Group

CXTTipWindow Data Members


CXTTipWindow::m_nTabPositions Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_nTabPositions Data Member

Specifies the number of tab-stop positions in the array pointed to by m_pnTabStopPositions.

int m_nTabPositions;
Group

CXTTipWindow Data Members


CXTTipWindow::m_pnTabStopPositions Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_pnTabStopPositions Data Member

Points to an array of integers containing the tab-stop positions in logical units.

LPINT m_pnTabStopPositions;
Group

CXTTipWindow Data Members


CXTTipWindow::m_pointTipOffsetPos Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_pointTipOffsetPos Data Member

Specifies the offset to move the top window in relation to the mouse cursor.

CPoint m_pointTipOffsetPos;
Group

CXTTipWindow Data Members


CXTTipWindow::m_pParentWnd Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_pParentWnd Data Member

Parent window.

CWnd* m_pParentWnd;
Group

CXTTipWindow Data Members


CXTTipWindow::m_ptMousePos Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_ptMousePos Data Member

Initial xy coordinates of the cursor when when tip window was created.

CPoint m_ptMousePos;
Group

CXTTipWindow Data Members


CXTTipWindow::m_rcScreenWindow Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_rcScreenWindow Data Member

Initial size of the desktop.

CRect m_rcScreenWindow;
Group

CXTTipWindow Data Members


CXTTipWindow::m_rcShadow Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_rcShadow Data Member

Initial size of the tip window shadow.

CRect m_rcShadow;
Group

CXTTipWindow Data Members


CXTTipWindow::m_rcWindow Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_rcWindow Data Member

Initial size of the tip window.

CRect m_rcWindow;
Group

CXTTipWindow Data Members


CXTTipWindow::m_rectTipArea Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_rectTipArea Data Member

Size of the client area for the tip window.

CRect m_rectTipArea;
Group

CXTTipWindow Data Members


CXTTipWindow::m_sizeMargin Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_sizeMargin Data Member

Amount in pixels of the tip and side margins of where the tip text is displayed.

CSize m_sizeMargin;
Group

CXTTipWindow Data Members


CXTTipWindow::m_sizeTitle Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_sizeTitle Data Member

title text size.

CSize m_sizeTitle;
Group

CXTTipWindow Data Members


CXTTipWindow::m_strDescrip Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_strDescrip Data Member

Description text for the tip window.

CXTStringHelper m_strDescrip;
Group

CXTTipWindow Data Members


CXTTipWindow::m_strTitle Data Member

CXTTipWindow Data Members, CXTTipWindow Class
CXTTipWindow::m_strTitle Data Member

Title text for the tip window.

CString m_strTitle;
Group

CXTTipWindow Data Members


CXTTipWindow Methods

CXTTipWindow Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTipWindow Methods
Class

CXTTipWindow Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawShadowRect | This member function will draw a shadow rect to the device context specified by 'pDC'.
ForwardMessage | Forwards a message to the window at specified cursor position.
InitializeSize | This member function will set the sizes for the tip window.
Public Methods
Public Methods
Public Method | Description
Create | Call this member function to create the tooltip window.
HideTipWindow | Call this member function to hide the tip window
SetLineSpace | This member function will set the line spacing for the tip window.
SetMargins | This member function will set the text margins for the tip window.
SetTextTabStopPositions | Call this member function to set the text tab stop positions for the tooltip window.
SetTipColors | This member function will set the text and background colors for the tip window display.
SetTipOffsetPos | Call this member function to offset the tip window by the distance specified by pointOffset.
SetTipText | This member function will set the text for the title and description values that are displayed in the tip window.
ShowTipWindow |


CXTTipWindow::Create Method

CXTTipWindow Methods, CXTTipWindow Class
CXTTipWindow::Create Method

Call this member function to create the tooltip window.

virtual BOOL Create(
    CWnd* pParentWnd
);
Parameters

pParentWnd
Points to the parent of the tooltip window.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTTipWindow Methods


CXTTipWindow::DrawShadowRect Method

CXTTipWindow Methods, CXTTipWindow Class
CXTTipWindow::DrawShadowRect Method

This member function will draw a shadow rect to the device context specified by 'pDC'.

void DrawShadowRect(
    CDC* pDC,
    const CRect& rect
);
Parameters

pDC
Device context of the window to cast the shadow on.
rect
Reference to a CRect object that represents the initial size of the shadow.

Group

CXTTipWindow Methods


CXTTipWindow::ForwardMessage Method

CXTTipWindow Methods, CXTTipWindow Class
CXTTipWindow::ForwardMessage Method

Forwards a message to the window at specified cursor position.

void ForwardMessage(
    UINT uiMsg,
    UINT nFlags,
    CPoint point
);
Parameters

uiMsg
Specifies the message to be sent.
nFlags
Indicates whether various virtual keys are down. See Remarks section for a list of values.
point

  • coordinates of the window to send the message to.

Remarks

The nFlags parameter can be any combination of the following values:

  • MK_CONTROL Set if the CTRL key is down.
  • MK_LBUTTON Set if the left mouse button is down.
  • MK_MBUTTON Set if the middle mouse button is down.
  • MK_RBUTTON Set if the right mouse button is down.
  • MK_SHIFT Set if the SHIFT key is down.

This member function is called by the CXTTipWindow object to hide the tip window and forward the message specified by uiMsg to the window at coordinates specified by point.

Group

CXTTipWindow Methods


CXTTipWindow::HideTipWindow Method

CXTTipWindow Methods, CXTTipWindow Class
CXTTipWindow::HideTipWindow Method

Call this member function to hide the tip window

void HideTipWindow();
Group

CXTTipWindow Methods


CXTTipWindow::InitializeSize Method

CXTTipWindow Methods, CXTTipWindow Class
CXTTipWindow::InitializeSize Method

This member function will set the sizes for the tip window.

void InitializeSize(
    const CPoint& point,
    BOOL bCenterHorz = FALSE
);
Parameters

point
The x and y coordinates of where the tip window is to be displayed.
bCenterHorz
Horizontal center the window position.

Group

CXTTipWindow Methods


CXTTipWindow::SetLineSpace Method

CXTTipWindow Methods, CXTTipWindow Class, Body Source
CXTTipWindow::SetLineSpace Method

This member function will set the line spacing for the tip window.

void SetLineSpace(
    int nLineSpace
);
Parameters

nLineSpace
Initial size for text line spacing.

Body Source
void CXTTipWindow::SetLineSpace(int nLineSpace) {
    m_nLineSpace = __max(0, nLineSpace);
}
Group

CXTTipWindow Methods


CXTTipWindow::SetMargins Method

CXTTipWindow Methods, CXTTipWindow Class, Body Source
CXTTipWindow::SetMargins Method

This member function will set the text margins for the tip window.

void SetMargins(
    CSize size
);
Parameters

size
Initial size for the horizontal and vertical text margins.

Body Source
void CXTTipWindow::SetMargins(CSize size) {
    m_sizeMargin.cx = __max(0, size.cx); m_sizeMargin.cy = __max(0, size.cy); //EM_BM
}
Group

CXTTipWindow Methods


CXTTipWindow::SetTextTabStopPositions Method

CXTTipWindow Methods, CXTTipWindow Class
CXTTipWindow::SetTextTabStopPositions Method

Call this member function to set the text tab stop positions for the tooltip window.

void SetTextTabStopPositions(
    LPINT pnTabStopPositions,
    int nTabPositions
);
Parameters

pnTabStopPositions
pointer to integer array containing the tab stop positions (could be a static array)
nTabPositions
number of array elements.

Group

CXTTipWindow Methods


CXTTipWindow::SetTipColors Method

CXTTipWindow Methods, CXTTipWindow Class, Body Source
CXTTipWindow::SetTipColors Method

This member function will set the text and background colors for the tip window display.

void SetTipColors(
    COLORREF crBackColor,
    COLORREF crTextColor,
    BOOL bRedraw = FALSE
);
Parameters

crBackColor
The RGB color value for the background of the tip window.
crTextColor
The RGB color value for the text of the tip window.
bRedraw
If TRUE, the tip window will be redrawn.

Body Source
void CXTTipWindow::SetTipColors(COLORREF crBackColor, COLORREF crTextColor, BOOL bRedraw) {
    m_crBackColor = crBackColor; m_crTextColor = crTextColor; if (bRedraw) { InvalidateRect(NULL); }
}
Group

CXTTipWindow Methods


CXTTipWindow::SetTipOffsetPos Method

CXTTipWindow Methods, CXTTipWindow Class, Body Source
CXTTipWindow::SetTipOffsetPos Method

Call this member function to offset the tip window by the distance specified by pointOffset.

void SetTipOffsetPos(
    CPoint pointOffset
);
Parameters

pointOffset
A CPoint object that represents the x, y offset.

Body Source
void CXTTipWindow::SetTipOffsetPos(CPoint pointOffset) {
    m_pointTipOffsetPos = pointOffset;
}
Group

CXTTipWindow Methods


CXTTipWindow::SetTipText Method

CXTTipWindow Methods, CXTTipWindow Class
CXTTipWindow::SetTipText Method

This member function will set the text for the title and description values that are displayed in the tip window.

void SetTipText(
    LPCTSTR lpszTitle,
    LPCTSTR lpszDescrip,
    BOOL bRedraw = FALSE
);
Parameters

lpszTitle
A NULL terminated string that is to be displayed as the title for the tip window.
lpszDescrip
A NULL terminated string that is to be displayed as the description text for the tip window.
bRedraw
If TRUE, the tip window will be redrawn.

Group

CXTTipWindow Methods


ShowTipWindow Method

CXTTipWindow Methods
ShowTipWindow Method
Overload List
Methods
Method | Description
CXTTipWindow::ShowTipWindow (const CPoint&, DWORD, UINT, UINT, BOOL) | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
CXTTipWindow::ShowTipWindow (const CRect&, const CPoint&, DWORD, UINT, UINT, BOOL, BOOL) | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
Group

CXTTipWindow Methods


CXTTipWindow::ShowTipWindow Method (const CPoint&, DWORD, UINT, UINT, BOOL)

ShowTipWindow Method, CXTTipWindow Class
CXTTipWindow::ShowTipWindow Method (const CPoint&, DWORD, UINT, UINT, BOOL)

This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.

virtual BOOL ShowTipWindow(
    const CPoint& point,
    DWORD dwTipStyle = TWS_XT_DROPSHADOW,
    UINT nDelay = 0,
    UINT nElapse = 5000,
    BOOL bCenterHorz = FALSE
);
virtual BOOL ShowTipWindow(
    const CRect& rectCtrl,
    const CPoint& pointMousePos,
    DWORD dwTipStyle = TWS_XT_DROPSHADOW,
    UINT nDelay = 0,
    UINT nElapse = 5000,
    BOOL bCenterHorz = FALSE,
    BOOL bShowTipAtCursorPos = FALSE
);
Parameters

point
The initial x and y coordinates of where the tip window is to be displayed.
dwTipStyle
Initial style for the tip window. See the Remarks section for the styles that can be used with the tip window.
nDelay
Specifies the delay value in milliseconds of when the tip window should show.
nElapse
Specifies the time-out value in milliseconds of when the tip window should close.
bCenterHorz
Set this parameter to 'true' to center the window horizontally on the point passed in.
rectCtrl
Reference to a CRect object that represents the size of the control window where the tip is displayed.
pointMousePos
Reference to a CPoint object that represents the x, y position of the mouse cursor.
bShowTipAtCursorPos
TRUE to show the tip at the cursor position.

Remarks

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

  • TWS_XT_THICKBORDER This style will cause the tip window to display a thick border around its edges.
  • TWS_XT_DROPSHADOW This style will cause the tip window to cast a shadow on the parent window.
  • TWS_XT_ALPHASHADOW Used with TWS_XT_DROPSHADOW to display an alpha style shadow. By default, mono shadowing is enabled.
Group

ShowTipWindow Method


CXTTipWindow Constructors

CXTTipWindow Class, Legend, Public Methods
CXTTipWindow Constructors
Class

CXTTipWindow Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTipWindow | Constructs a CXTTipWindow object


CXTTipWindow::CXTTipWindow Constructor

CXTTipWindow Constructors, CXTTipWindow Class
CXTTipWindow::CXTTipWindow Constructor

Constructs a CXTTipWindow object

CXTTipWindow();
Group

CXTTipWindow Constructors


CXTTipWindow Destructors

CXTTipWindow Class, Legend, Public Methods
CXTTipWindow Destructors
Class

CXTTipWindow Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTipWindow | Destroys a CXTTipWindow object, handles cleanup and deallocation


CXTTipWindow::~CXTTipWindow Destructor

CXTTipWindow Destructors, CXTTipWindow Class
CXTTipWindow::~CXTTipWindow Destructor

Destroys a CXTTipWindow object, handles cleanup and deallocation

virtual ~CXTTipWindow();
Group

CXTTipWindow Destructors


CXTToolbarButtonTheme Class

XTButtonTheme.h, Classes, Legend, Members, Topics, CXTToolbarButtonTheme Methods, CXTToolbarButtonTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTToolbarButtonTheme Class

CXTToolbarButtonTheme is a CXTDisabledButtonTheme derived class that is used to draw Windows XP style toolbar theme for the button.

Class Hierarchy

class CXTToolbarButtonTheme : public CXTDisabledButtonTheme;
File

XTButtonTheme.h

Group

Classes

Legend
Method
virtual
CXTToolbarButtonTheme Methods
CXTToolbarButtonTheme Methods | Description
DrawWinThemeBackground | This member function is called to draw the Windows XP theme background for the button.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.
UseWinXPThemes | This member function is called to determine if the button should be drawn using Windows XP themes.


CXTToolbarButtonTheme Methods

CXTToolbarButtonTheme Class, Legend, Public Methods
CXTToolbarButtonTheme Methods
Class

CXTToolbarButtonTheme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawWinThemeBackground | This member function is called to draw the Windows XP theme background for the button.
RefreshMetrics | This member function is called by the theme manager to refresh the visual styles used by each components theme.
UseWinXPThemes | This member function is called to determine if the button should be drawn using Windows XP themes.


CXTToolbarButtonTheme::DrawWinThemeBackground Method

CXTToolbarButtonTheme Methods, CXTToolbarButtonTheme Class
CXTToolbarButtonTheme::DrawWinThemeBackground Method

This member function is called to draw the Windows XP theme background for the button.

virtual BOOL DrawWinThemeBackground(
    LPDRAWITEMSTRUCT lpDIS,
    CXTButton* pButton
);
Parameters

lpDIS
A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pButton
Points to a CXTButton object.

Returns

TRUE if the background was drawn successfully, otherwise returns FALSE.

Group

CXTToolbarButtonTheme Methods


CXTToolbarButtonTheme::RefreshMetrics Method

CXTToolbarButtonTheme Methods, CXTToolbarButtonTheme Class
CXTToolbarButtonTheme::RefreshMetrics Method

This member function is called by the theme manager to refresh the visual styles used by each components theme.

virtual void RefreshMetrics();
Group

CXTToolbarButtonTheme Methods


CXTToolbarButtonTheme::UseWinXPThemes Method

CXTToolbarButtonTheme Methods, CXTToolbarButtonTheme Class
CXTToolbarButtonTheme::UseWinXPThemes Method

This member function is called to determine if the button should be drawn using Windows XP themes.

virtual BOOL UseWinXPThemes(
    CXTButton* pButton
);
Parameters

pButton
Points to a CXTButton object.

Returns

TRUE if the button is to be drawn using Windows XP themes, otherwise FALSE.

Group

CXTToolbarButtonTheme Methods


CXTToolBox Class

XTOutBarCtrl.h, Classes, Legend, Members, Topics, CXTToolBox Data Members, CXTToolBox Methods, CXTToolBox Constructors, CXTToolBox Destructors, CXTToolBox Constructors, CXTToolBox Data Members, CXTToolBox Destructors, CXTToolBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTToolBox Class

CXTToolBox is a CXTOutBarCtrl derived class. It is used to create a toolbox control similar to the toolbox control seen in VisualStudio.NET.

Class Hierarchy

class CXTToolBox : public CXTOutBarCtrl;
File

XTOutBarCtrl.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTToolBox Constructors
CXTToolBox Constructors | Description
CXTToolBox | Constructs a CXTToolBox object
CXTToolBox Data Members
CXTToolBox Data Members | Description
m_bAnimating | true if the folder selection is changing.
m_iFirst | Index of the first visible item.
m_iLast | Index of the last visible item.
CXTToolBox Destructors
CXTToolBox Destructors | Description
~CXTToolBox | Destroys a CXTToolBox object, handles cleanup and deallocation
CXTToolBox Methods
CXTToolBox Methods | Description
CreateEx | Call this member function to create the toolbox control.
DrawFolder | Called by the CXTToolBox to render a folder.
DrawIcon | Called by the CXTToolBox to render an item's icon.
DrawItem | Called by the CXTToolBox to draw a folder item.
DrawScrollButton | Called by the CXTToolBox to draw the up or down scroll button.
GetIconRect | Call this member function to retrieve the size of the icon for the specified item.
GetItemRect | Call this member function to retrieve the size of the specified item. The size includes the area occupied by the item's label and icon.
SetSelFolder | This member function will set the selected folder for the toolbox.


CXTToolBox Data Members

CXTToolBox Class, Legend, Protected Data Members
CXTToolBox Data Members
Class

CXTToolBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAnimating | true if the folder selection is changing.
m_iFirst | Index of the first visible item.
m_iLast | Index of the last visible item.


CXTToolBox::m_bAnimating Data Member

CXTToolBox Data Members, CXTToolBox Class
CXTToolBox::m_bAnimating Data Member

true if the folder selection is changing.

bool m_bAnimating;
Group

CXTToolBox Data Members


CXTToolBox::m_iFirst Data Member

CXTToolBox Data Members, CXTToolBox Class
CXTToolBox::m_iFirst Data Member

Index of the first visible item.

int m_iFirst;
Group

CXTToolBox Data Members


CXTToolBox::m_iLast Data Member

CXTToolBox Data Members, CXTToolBox Class
CXTToolBox::m_iLast Data Member

Index of the last visible item.

int m_iLast;
Group

CXTToolBox Data Members


CXTToolBox Methods

CXTToolBox Class, Legend, Protected Methods, Public Methods
CXTToolBox Methods
Class

CXTToolBox Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawFolder | Called by the CXTToolBox to render a folder.
DrawIcon | Called by the CXTToolBox to render an item's icon.
DrawItem | Called by the CXTToolBox to draw a folder item.
DrawScrollButton | Called by the CXTToolBox to draw the up or down scroll button.
Public Methods
Public Methods
Public Method | Description
CreateEx | Call this member function to create the toolbox control.
GetIconRect | Call this member function to retrieve the size of the icon for the specified item.
GetItemRect | Call this member function to retrieve the size of the specified item. The size includes the area occupied by the item's label and icon.
SetSelFolder | This member function will set the selected folder for the toolbox.


CXTToolBox::CreateEx Method

CXTToolBox Methods, CXTToolBox Class
CXTToolBox::CreateEx Method

Call this member function to create the toolbox control.

virtual BOOL CreateEx(
    DWORD dwExStyle,
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID,
    const DWORD dwFlag = OBS_XT_DEFAULT
);
Parameters

dwExStyle
Extended style for the toolbox, such as WS_EX_STATICEDGE. It can be NULL.
dwStyle
Style for the toolbox. It usually includes the WS_CHILD | WS_VISIBLE flags.
rect
Size of the toolbox.
pParentWnd
Parent of the control.
nID
Identifier of the toolbox control.
dwFlag
Specifies the style flags for the control. See CXTOutBarCtrl::ModifyFlag for a list of available styles.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTToolBox Methods


CXTToolBox::DrawFolder Method

CXTToolBox Methods, CXTToolBox Class, See Also
CXTToolBox::DrawFolder Method

Called by the CXTToolBox to render a folder.

virtual void DrawFolder(
    CDC* pDC,
    const int iIndex,
    CRect rect,
    const XTMouseState eHilight
);
Parameters

pDC
Pointer to a valid device context.
iIndex
Index of the folder to render.
rect
Size of the area to render.
eHilight
Current mouse over state.

See Also

XTMouseState

Group

CXTToolBox Methods


CXTToolBox::DrawIcon Method

CXTToolBox Methods, CXTToolBox Class
CXTToolBox::DrawIcon Method

Called by the CXTToolBox to render an item's icon.

virtual void DrawIcon(
    CDC* pDC,
    int iIcon,
    int iFolder,
    bool bHilight
);
Parameters

pDC
Pointer to a valid device context.
iIcon
Index of the icon to render.
iFolder
Index of the parent folder.
bHilight
true if the icon is highlighted.

Group

CXTToolBox Methods


CXTToolBox::DrawItem Method

CXTToolBox Methods, CXTToolBox Class
CXTToolBox::DrawItem Method

Called by the CXTToolBox to draw a folder item.

virtual void DrawItem(
    CDC* pDC,
    const int iFolder,
    CRect rc,
    const int iIndex,
    const BOOL bOnlyImage
);
Parameters

pDC
Pointer to a valid device context.
iFolder
Index of the parent folder.
rc
Size of the area to render.
iIndex
Index of the item to render.
bOnlyImage
TRUE if only the image is to be drawn.

Group

CXTToolBox Methods


CXTToolBox::DrawScrollButton Method

CXTToolBox Methods, CXTToolBox Class
CXTToolBox::DrawScrollButton Method

Called by the CXTToolBox to draw the up or down scroll button.

virtual void DrawScrollButton(
    CDC* pDC,
    CRect rect,
    UINT uType,
    UINT uState
);
Parameters

pDC
Pointer to a valid device context.
rect
Size of area to render.
uType
Specifies the type of frame control to draw. See the uType parameter in DrawFrameControl in the Platform SDK for a list of this parameter's possible values.
uState
Specifies the initial state of the frame control. Can be one or more of the values described for the uState parameter in DrawFrameControl in the Platform SDK. Use the nState value DFCS_ADJUSTRECT to adjust the bounding rectangle to exclude the surrounding edge of the push button.

Group

CXTToolBox Methods


CXTToolBox::GetIconRect Method

CXTToolBox Methods, CXTToolBox Class
CXTToolBox::GetIconRect Method

Call this member function to retrieve the size of the icon for the specified item.

virtual void GetIconRect(
    const int iFolder,
    const int iIndex,
    CRect& rect,
    CRect* pInsideRect = NULL
);
Parameters

iFolder
Index of the folder where the item is located.
iIndex
Index of the item.
rect
Address of a CRect object that will receive the icon size.
pInsideRect
Pointer to a CRect object that represents the size of the client area for the Outlook bar. If NULL GetInsideRect will be used to determine the client area size.

Group

CXTToolBox Methods


CXTToolBox::GetItemRect Method

CXTToolBox Methods, CXTToolBox Class
CXTToolBox::GetItemRect Method

Call this member function to retrieve the size of the specified item. The size includes the area occupied by the item's label and icon.

virtual void GetItemRect(
    const int iFolder,
    const int iIndex,
    CRect& rect,
    CRect* pInsideRect = NULL
);
Parameters

iFolder
Index of the folder where the item is located.
iIndex
Index of the item.
rect
Address of a CRect object that will receive the item size.
pInsideRect
Pointer to a CRect object that represents the size of the client area for the Outlook bar. If NULL GetInsideRect will be used to determine the client area size.

Group

CXTToolBox Methods


CXTToolBox::SetSelFolder Method

CXTToolBox Methods, CXTToolBox Class
CXTToolBox::SetSelFolder Method

This member function will set the selected folder for the toolbox.

virtual void SetSelFolder(
    const int iIndex
);
Parameters

iIndex
Index of the new selected folder.

Group

CXTToolBox Methods


CXTToolBox Constructors

CXTToolBox Class, Legend, Public Methods
CXTToolBox Constructors
Class

CXTToolBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTToolBox | Constructs a CXTToolBox object


CXTToolBox::CXTToolBox Constructor

CXTToolBox Constructors, CXTToolBox Class
CXTToolBox::CXTToolBox Constructor

Constructs a CXTToolBox object

CXTToolBox();
Group

CXTToolBox Constructors


CXTToolBox Destructors

CXTToolBox Class, Legend, Public Methods
CXTToolBox Destructors
Class

CXTToolBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTToolBox | Destroys a CXTToolBox object, handles cleanup and deallocation


CXTToolBox::~CXTToolBox Destructor

CXTToolBox Destructors, CXTToolBox Class
CXTToolBox::~CXTToolBox Destructor

Destroys a CXTToolBox object, handles cleanup and deallocation

virtual ~CXTToolBox();
Group

CXTToolBox Destructors


CXTTrayIcon Class

XTTrayIcon.h, Classes, Legend, Members, Topics, CXTTrayIcon Data Members, CXTTrayIcon Methods, CXTTrayIcon Constructors, CXTTrayIcon Destructors, CXTTrayIcon Nested Types, CXTTrayIcon Constructors, CXTTrayIcon Data Members, CXTTrayIcon Destructors, CXTTrayIcon Methods, CXTTrayIcon Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTrayIcon Class

CXTTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure. It is used to display a system tray icon with animation.

Class Hierarchy

class CXTTrayIcon : public CWnd;
File

XTTrayIcon.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTTrayIcon Constructors
CXTTrayIcon Constructors | Description
CXTTrayIcon | Constructs a CXTTrayIcon object
CXTTrayIcon Data Members
CXTTrayIcon Data Members | Description
m_arTrayIcons | Array of icons and text that are displayed during animation.
m_bDefMenuItemByPos | Determines if the default menu item is a command or index.
m_bHidden | State of the icon.
m_bRemoved | true if the icon has been removed from the system tray.
m_bShowPending | true if the icon display is pending.
m_hIcon | Default icon.
m_hWndNotify | Handle to the window that receives command notification.
m_iMaxTipSize | Maximum size for tooltip string.
m_nCounter | Holds the current position in the timer loop.
m_nIconID | Resource ID for the default icon.
m_niData | Tray icon structure see NOTIFYICONDATA.
m_nIDEvent | Timer event ID.
m_strToolTip | Tooltip for the default icon.
m_uDefMenuItemID | Default popup menu item ID.
m_uFlags | Style settings for icon restore.
m_wndMinimize | Hidden window used during minimize and restore functions.
CXTTrayIcon Destructors
CXTTrayIcon Destructors | Description
~CXTTrayIcon | Destroys a CXTTrayIcon object, handles cleanup and deallocation
CXTTrayIcon Methods
CXTTrayIcon Methods | Description
AddIcon | Call this member function to add the icon to the system tray.
Create | This member function will create the system tray icon.
CreateMinimizeWnd | Creates the tray icons min / max window.
GetCallbackMessage | This member function will retrieve the notification message ID used by the tray icon.
GetDefaultMenuItem | Call this member function to retrieve the item ID and position flag for the tray icon.
GetIcon | Call this member function to return a handle to the icon displayed in the system tray.
GetNotificationWnd | Call this member function to retrieve a pointer to the window that receives notification messages from the tray icon.
GetTooltipText | Call this member function to retrieve the tooltip text that is displayed by the tray icon.
HideIcon | Call this member function to hide the system tray icon in Windows 2000 or greater.
InstallIconPending | Adds an icon to the system tray.
KillTimer | Stops the animation timer.
MaximizeFromTray | Call this member function to maximize the specified window from the system tray. If window animation is supported, the window will glide up from the system tray.
MinimizeToTray | Call this member function to minimize the specified window to the system tray. If window animation is supported, the window will glide down to the system tray.
RemoveAnimationIcons | Clears animated icon array.
RemoveIcon | Call this member function to remove the icon from the system tray.
SetAnimationIcons |
SetCallbackMessage | This member function will set the callback message to be used by the tray icon.
SetDefaultMenuItem | This member function will set the default menu item for the tray icon's popup menu if the tray icon handles notification messages.
SetDefaultValues | This member function is called to reset the tray icon control settings to their default value.
SetIcon |
SetNotificationWnd | Call this member function to set the window that is to receive notification messages from the tray icon.
SetTimer | Sets the animation timer.
SetTooltip | Sets the tooltip for the CXTTrayIcon object.
SetTooltipText |
SetTrayIcon | Sets the icon for the CXTTrayIcon object.
ShellNotify | Sends a message to the taskbar's status area.
ShowBalloonTip | Call this member function to display a balloon tooltip for the system tray icon. Must have Windows 2000 or later.
ShowIcon | Call this member function to show the system tray icon in Windows 2000 or greater.
StartAnimation | This member function will start the tray icon animation timer.
StopAnimation | This member function will stop the tray icon animation timer
CXTTrayIcon Nested Types
CXTTrayIcon Nested Types | Description
CTrayIconList | Animated icon array


CXTTrayIcon Data Members

CXTTrayIcon Class, Legend, Protected Data Members
CXTTrayIcon Data Members
Class

CXTTrayIcon Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arTrayIcons | Array of icons and text that are displayed during animation.
m_bDefMenuItemByPos | Determines if the default menu item is a command or index.
m_bHidden | State of the icon.
m_bRemoved | true if the icon has been removed from the system tray.
m_bShowPending | true if the icon display is pending.
m_hIcon | Default icon.
m_hWndNotify | Handle to the window that receives command notification.
m_iMaxTipSize | Maximum size for tooltip string.
m_nCounter | Holds the current position in the timer loop.
m_nIconID | Resource ID for the default icon.
m_niData | Tray icon structure see NOTIFYICONDATA.
m_nIDEvent | Timer event ID.
m_strToolTip | Tooltip for the default icon.
m_uDefMenuItemID | Default popup menu item ID.
m_uFlags | Style settings for icon restore.
m_wndMinimize | Hidden window used during minimize and restore functions.


CXTTrayIcon::m_arTrayIcons Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_arTrayIcons Data Member

Array of icons and text that are displayed during animation.

CTrayIconList m_arTrayIcons;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_bDefMenuItemByPos Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_bDefMenuItemByPos Data Member

Determines if the default menu item is a command or index.

bool m_bDefMenuItemByPos;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_bHidden Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_bHidden Data Member

State of the icon.

bool m_bHidden;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_bRemoved Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_bRemoved Data Member

true if the icon has been removed from the system tray.

bool m_bRemoved;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_bShowPending Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_bShowPending Data Member

true if the icon display is pending.

bool m_bShowPending;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_hIcon Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_hIcon Data Member

Default icon.

CXTIconHandle m_hIcon;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_hWndNotify Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_hWndNotify Data Member

Handle to the window that receives command notification.

HWND m_hWndNotify;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_iMaxTipSize Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_iMaxTipSize Data Member

Maximum size for tooltip string.

size_t m_iMaxTipSize;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_nCounter Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_nCounter Data Member

Holds the current position in the timer loop.

UINT m_nCounter;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_nIconID Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_nIconID Data Member

Resource ID for the default icon.

UINT m_nIconID;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_niData Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_niData Data Member

Tray icon structure see NOTIFYICONDATA.

NOTIFYICONDATAEX m_niData;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_nIDEvent Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_nIDEvent Data Member

Timer event ID.

UINT m_nIDEvent;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_strToolTip Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_strToolTip Data Member

Tooltip for the default icon.

CString m_strToolTip;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_uDefMenuItemID Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_uDefMenuItemID Data Member

Default popup menu item ID.

UINT m_uDefMenuItemID;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_uFlags Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_uFlags Data Member

Style settings for icon restore.

UINT m_uFlags;
Group

CXTTrayIcon Data Members


CXTTrayIcon::m_wndMinimize Data Member

CXTTrayIcon Data Members, CXTTrayIcon Class
CXTTrayIcon::m_wndMinimize Data Member

Hidden window used during minimize and restore functions.

CWnd m_wndMinimize;
Group

CXTTrayIcon Data Members


CXTTrayIcon Methods

CXTTrayIcon Class, Legend, Public Methods
CXTTrayIcon Methods
Class

CXTTrayIcon Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AddIcon | Call this member function to add the icon to the system tray.
Create | This member function will create the system tray icon.
CreateMinimizeWnd | Creates the tray icons min / max window.
GetCallbackMessage | This member function will retrieve the notification message ID used by the tray icon.
GetDefaultMenuItem | Call this member function to retrieve the item ID and position flag for the tray icon.
GetIcon | Call this member function to return a handle to the icon displayed in the system tray.
GetNotificationWnd | Call this member function to retrieve a pointer to the window that receives notification messages from the tray icon.
GetTooltipText | Call this member function to retrieve the tooltip text that is displayed by the tray icon.
HideIcon | Call this member function to hide the system tray icon in Windows 2000 or greater.
InstallIconPending | Adds an icon to the system tray.
KillTimer | Stops the animation timer.
MaximizeFromTray | Call this member function to maximize the specified window from the system tray. If window animation is supported, the window will glide up from the system tray.
MinimizeToTray | Call this member function to minimize the specified window to the system tray. If window animation is supported, the window will glide down to the system tray.
RemoveAnimationIcons | Clears animated icon array.
RemoveIcon | Call this member function to remove the icon from the system tray.
SetAnimationIcons |
SetCallbackMessage | This member function will set the callback message to be used by the tray icon.
SetDefaultMenuItem | This member function will set the default menu item for the tray icon's popup menu if the tray icon handles notification messages.
SetDefaultValues | This member function is called to reset the tray icon control settings to their default value.
SetIcon |
SetNotificationWnd | Call this member function to set the window that is to receive notification messages from the tray icon.
SetTimer | Sets the animation timer.
SetTooltip | Sets the tooltip for the CXTTrayIcon object.
SetTooltipText |
SetTrayIcon | Sets the icon for the CXTTrayIcon object.
ShellNotify | Sends a message to the taskbar's status area.
ShowBalloonTip | Call this member function to display a balloon tooltip for the system tray icon. Must have Windows 2000 or later.
ShowIcon | Call this member function to show the system tray icon in Windows 2000 or greater.
StartAnimation | This member function will start the tray icon animation timer.
StopAnimation | This member function will stop the tray icon animation timer


CXTTrayIcon::AddIcon Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::AddIcon Method

Call this member function to add the icon to the system tray.

bool AddIcon();
Returns

true if successful, otherwise returns false.

Group

CXTTrayIcon Methods


CXTTrayIcon::Create Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::Create Method

This member function will create the system tray icon.

virtual bool Create(
    LPCTSTR lpszCaption,
    CWnd* pParentWnd,
    UINT nIconID,
    UINT uMenuID = 0,
    UINT uDefMenuItemID = 0,
    bool bDefMenuItemByPos = false
);
Parameters

lpszCaption
NULL terminated string that contains the tooltip text displayed when the cursor is over the tray icon.
pParentWnd
Pointer to the window that will receive notification messages associated with an icon in the taskbar status area.
nIconID
Resource ID for the default tray icon.
uMenuID
Popup menu resource identifier.
uDefMenuItemID
Command ID that represents the default item for the menu.
bDefMenuItemByPos
true if the default is defined by its position. false if it is defined by its command ID.

Returns

true if successful, otherwise returns false.

Group

CXTTrayIcon Methods


CXTTrayIcon::CreateMinimizeWnd Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::CreateMinimizeWnd Method

Creates the tray icons min / max window.

virtual bool CreateMinimizeWnd(
    CWnd* pWndApp
);
Parameters

pWndApp
Points to the calling applications main window.

Returns

true if the minimize window was successfully created, otherwise false.

Remarks

Called to create the minimize window used during minimize / maximize operations.

Group

CXTTrayIcon Methods


CXTTrayIcon::GetCallbackMessage Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::GetCallbackMessage Method

This member function will retrieve the notification message ID used by the tray icon.

UINT GetCallbackMessage();
Returns

An ID to a notification message.

Group

CXTTrayIcon Methods


CXTTrayIcon::GetDefaultMenuItem Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::GetDefaultMenuItem Method

Call this member function to retrieve the item ID and position flag for the tray icon.

void GetDefaultMenuItem(
    UINT& uItem,
    bool& bByPos
);
Parameters

uItem
Reference to a UINT that is to receive the default menu item ID.
bByPos
Reference to a bool that is to receive the default menu item position flag.

Group

CXTTrayIcon Methods


CXTTrayIcon::GetIcon Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::GetIcon Method

Call this member function to return a handle to the icon displayed in the system tray.

HICON GetIcon() const;
Returns

A handle to the icon displayed in the system tray.

Group

CXTTrayIcon Methods


CXTTrayIcon::GetNotificationWnd Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::GetNotificationWnd Method

Call this member function to retrieve a pointer to the window that receives notification messages from the tray icon.

CWnd* GetNotificationWnd();
Returns

A pointer to a valid CWnd object.

Group

CXTTrayIcon Methods


CXTTrayIcon::GetTooltipText Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::GetTooltipText Method

Call this member function to retrieve the tooltip text that is displayed by the tray icon.

CString GetTooltipText() const;
Returns

A CString object that represents the tooltip text.

Group

CXTTrayIcon Methods


CXTTrayIcon::HideIcon Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::HideIcon Method

Call this member function to hide the system tray icon in Windows 2000 or greater.

bool HideIcon();
Returns

true if successful, otherwise returns false.

Group

CXTTrayIcon Methods


CXTTrayIcon::InstallIconPending Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::InstallIconPending Method

Adds an icon to the system tray.

virtual void InstallIconPending();
Remarks

This member is called by the CXTTrayIcon object to initialize the icon display in the system tray. It checks to see if there is a pending request or if the icon is hidden first before attempting to add the icon. You can override this member to provide additional functionality.

Group

CXTTrayIcon Methods


CXTTrayIcon::KillTimer Method

CXTTrayIcon Methods, CXTTrayIcon Class, Body Source
CXTTrayIcon::KillTimer Method

Stops the animation timer.

virtual void KillTimer();
Remarks

Called by the CXTTrayIcon object to stop the animation timer event and sets the default icon and tooltip text. You can override this member to provide additional functionality.

Body Source
void CXTTrayIcon::KillTimer() {
    StopAnimation();
}
Group

CXTTrayIcon Methods


CXTTrayIcon::MaximizeFromTray Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::MaximizeFromTray Method

Call this member function to maximize the specified window from the system tray. If window animation is supported, the window will glide up from the system tray.

void MaximizeFromTray(
    CWnd* pWnd
);
Parameters

pWnd
Window to maximize.

Group

CXTTrayIcon Methods


CXTTrayIcon::MinimizeToTray Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::MinimizeToTray Method

Call this member function to minimize the specified window to the system tray. If window animation is supported, the window will glide down to the system tray.

void MinimizeToTray(
    CWnd* pWnd
);
Parameters

pWnd
Window to minimize.

Group

CXTTrayIcon Methods


CXTTrayIcon::RemoveAnimationIcons Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::RemoveAnimationIcons Method

Clears animated icon array.

virtual void RemoveAnimationIcons();
Remarks

Called to clear the animated icon array and free any associated GDI resources.

Group

CXTTrayIcon Methods


CXTTrayIcon::RemoveIcon Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::RemoveIcon Method

Call this member function to remove the icon from the system tray.

bool RemoveIcon();
Returns

true if successful, otherwise returns false.

Group

CXTTrayIcon Methods


SetAnimationIcons Method

CXTTrayIcon Methods
SetAnimationIcons Method
Overload List
Methods
Method | Description
CXTTrayIcon::SetAnimationIcons (const UINT*, const CString*, int) | This member function will set the icons used for animated system tray icons. To use, call SetAnimationIcons, then SetTimer.
CXTTrayIcon::SetAnimationIcons (const UINT*, int, const CString*) | This member function will set the icons used for animated system tray icons. To use, call SetAnimationIcons, then SetTimer.
Group

CXTTrayIcon Methods


CXTTrayIcon::SetAnimationIcons Method (const UINT*, const CString*, int)

SetAnimationIcons Method, CXTTrayIcon Class, Body Source
CXTTrayIcon::SetAnimationIcons Method (const UINT*, const CString*, int)

This member function will set the icons used for animated system tray icons. To use, call SetAnimationIcons, then SetTimer.

virtual void SetAnimationIcons(
    const UINT* lpIDArray,
    const CString* lpStrTipArray,
    int nIDCount
);
virtual bool SetAnimationIcons(
    const UINT* lpIDArray,
    int nIDCount,
    const CString* lpStrTipArray = NULL
);
Parameters

lpIDArray
[in] An array of resource IDs that represent the icons to display in the caption area.
lpStrTipArray
[in] An array of tooltips that match the icons passed in as 'lpStrTipArray'. If NULL, the default tooltip will be used.
nIDCount
[in] Zero based size of the array passed. lpIDArray and lpStrTipArray must contain the same number of items and must match value specified by nIDCount.

Returns

true if successful, otherwise returns false.

Body Source
void CXTTrayIcon::SetAnimationIcons(const UINT* lpIDArray, const CString* lpStrTipArray, int nIDCount) {
    SetAnimationIcons(lpIDArray, nIDCount, lpStrTipArray);
}
Group

SetAnimationIcons Method


CXTTrayIcon::SetCallbackMessage Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::SetCallbackMessage Method

This member function will set the callback message to be used by the tray icon.

bool SetCallbackMessage(
    UINT uNewCallbackMessage
);
Parameters

uNewCallbackMessage
Notification message ID.

Returns

true if successful, otherwise returns false.

Group

CXTTrayIcon Methods


CXTTrayIcon::SetDefaultMenuItem Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::SetDefaultMenuItem Method

This member function will set the default menu item for the tray icon's popup menu if the tray icon handles notification messages.

bool SetDefaultMenuItem(
    UINT uItem,
    bool bByPos
);
Parameters

uItem
Command identifier or position of the default menu item.
bByPos
true if 'uItem' is the menu item's index; false if it is the menu item's command ID.

Returns

true if successful, otherwise returns false.

Group

CXTTrayIcon Methods


CXTTrayIcon::SetDefaultValues Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::SetDefaultValues Method

This member function is called to reset the tray icon control settings to their default value.

void SetDefaultValues();
Group

CXTTrayIcon Methods


SetIcon Method

CXTTrayIcon Methods
SetIcon Method
Overload List
Methods
Method | Description
CXTTrayIcon::SetIcon (HICON) | Call this member function to set the icon that is displayed in the system tray.
CXTTrayIcon::SetIcon (LPCTSTR) | Call this member function to set the icon that is displayed in the system tray.
CXTTrayIcon::SetIcon (UINT) | Call this member function to set the icon that is displayed in the system tray.
Group

CXTTrayIcon Methods


CXTTrayIcon::SetIcon Method (HICON)

SetIcon Method, CXTTrayIcon Class
CXTTrayIcon::SetIcon Method (HICON)

Call this member function to set the icon that is displayed in the system tray.

bool SetIcon(
    HICON hIcon
);
bool SetIcon(
    LPCTSTR lpszIconName
);
bool SetIcon(
    UINT nIDResource
);
Parameters

hIcon
Handle to the icon to display.
lpszIconName
Resource name of the icon to display.
nIDResource
Resource identifier of the icon to display.

Returns

true if the icon was set, otherwise returns false.

Group

SetIcon Method


CXTTrayIcon::SetNotificationWnd Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::SetNotificationWnd Method

Call this member function to set the window that is to receive notification messages from the tray icon.

bool SetNotificationWnd(
    CWnd* pWndNotify
);
Parameters

pWndNotify
Points to a valid CWnd object.

Returns

true if successful, otherwise returns false.

Group

CXTTrayIcon Methods


CXTTrayIcon::SetTimer Method

CXTTrayIcon Methods, CXTTrayIcon Class, Body Source
CXTTrayIcon::SetTimer Method

Sets the animation timer.

virtual void SetTimer(
    UINT nIDEvent,
    UINT uElapse
);
Parameters

nIDEvent
Specifies a nonzero timer identifier.
uElapse
Specifies the time-out value, in milliseconds.

Remarks

Called by the CXTTrayIcon object to initialize and start the animation timer. you can override this member to provide additional functionality.

Body Source
void CXTTrayIcon::SetTimer(UINT nIDEvent, UINT uElapse) {
    m_nIDEvent = nIDEvent; StartAnimation(uElapse);
}
Group

CXTTrayIcon Methods


CXTTrayIcon::SetTooltip Method

CXTTrayIcon Methods, CXTTrayIcon Class, Body Source
CXTTrayIcon::SetTooltip Method

Sets the tooltip for the CXTTrayIcon object.

virtual void SetTooltip(
    LPCTSTR strToolTip
);
Parameters

strToolTip
NULL terminated string that contains the tooltip text displayed when the cursor is over the tray icon.

Remarks

This member function is called to set the tooltip text for the icon that is displayed in the system tray.

Body Source
void CXTTrayIcon::SetTooltip(LPCTSTR strToolTip) {
    SetTooltipText(strToolTip);
}
Group

CXTTrayIcon Methods


SetTooltipText Method

CXTTrayIcon Methods
SetTooltipText Method
Overload List
Methods
Method | Description
CXTTrayIcon::SetTooltipText (LPCTSTR) | Call this member function to set the tooltip text for the tray icon.
CXTTrayIcon::SetTooltipText (UINT) | Call this member function to set the tooltip text for the tray icon.
Group

CXTTrayIcon Methods


CXTTrayIcon::SetTooltipText Method (UINT)

SetTooltipText Method, CXTTrayIcon Class
CXTTrayIcon::SetTooltipText Method (UINT)

Call this member function to set the tooltip text for the tray icon.

bool SetTooltipText(
    UINT nTipText
);
bool SetTooltipText(
    LPCTSTR lpszTipText
);
Parameters

nTipText
Windows string resource ID that represents the tooltip text to display for the icon.
lpszTipText
Null terminated string that represents the tooltip text to display for the icon.

Returns

true if successful, otherwise returns false.

Group

SetTooltipText Method


CXTTrayIcon::SetTrayIcon Method

CXTTrayIcon Methods, CXTTrayIcon Class, Body Source
CXTTrayIcon::SetTrayIcon Method

Sets the icon for the CXTTrayIcon object.

virtual void SetTrayIcon(
    UINT nIcon,
    DWORD dwMessage = NIM_ADD
);
Parameters

nIcon
Resource id of the new icon to set.
dwMessage
Message to be sent, see ShellNotify for more details.

Remarks

This member function is called to set a new icon to be displayed for the CXTTrayIcon object.

Body Source
void CXTTrayIcon::SetTrayIcon(UINT nIcon, DWORD /*dwMessage*/) {
    SetIcon(nIcon);
}
Group

CXTTrayIcon Methods


CXTTrayIcon::ShellNotify Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::ShellNotify Method

Sends a message to the taskbar's status area.

BOOL ShellNotify(
    DWORD dwMessage
);
Parameters

dwMessage
[in] Variable of type DWORD that specifies the action to be taken. See remarks section for a list of values.

Returns

Returns TRUE if successful or FALSE otherwise. If dwMessage is set to NIM_SETVERSION, the function returns TRUE if the version was successfully changed or FALSE if the requested version is not supported.

Remarks

dwMessage can have one of the following values.

  • NIM_ADD Adds an icon to the status area. The hWnd and uID members of the NOTIFYICONDATA structure pointed to by lpdata will be used to identify the icon in later calls to Shell_NotifyIcon.
  • NIM_DELETE Deletes an icon from the status area. Use the hWnd and uID members of the NOTIFYICONDATA structure pointed to by lpdata to identify the icon to be deleted.
  • NIM_MODIFY Modifies an icon in the status area. Use the hWnd and uID members of the NOTIFYICONDATA structure pointed to by lpdata to identify the icon to be modified.
  • NIM_SETFOCUS Version 5.0. Returns focus to the taskbar notification area. Taskbar icons should use this message when they have completed their user interface operation. For example, if the taskbar icon displays a shortcut menu, but the user presses ESCAPE to cancel it, use NIM_SETFOCUS to return focus to the taskbar notification area.
  • NIM_SETVERSION Version 5.0. Instructs the taskbar to behave according to the version number specified in the uVersion member of the structure pointed to by lpdata. This message allows you to specify whether you want the version 5.0 behavior found on Microsoft(r) Windows(r) 2000 systems, or that found with earlier Shell versions. The default value for uVersion is zero, indicating that the original Windows 95 notify icon behavior should be used. For details, see the Remarks section.

The taskbar notification area is sometimes erroneously called the "tray."

Version 5.0 of the Shell, found on Windows 2000, handles Shell_NotifyIcon mouse and keyboard events differently than earlier Shell versions found on Windows NT(r) 4.0, Windows 95, and Windows 98. The differences are:

If a user selects a notify icon's shortcut menu with the keyboard, the version 5.0 Shell sends the associated application a WM_CONTEXTMENU message. Earlier versions send WM_RBUTTONDOWN and WM_RBUTTONUP messages.

If a user selects a notify icon with the keyboard and activates it with the space bar or ENTER key, the version 5.0 Shell sends the associated application an NIN_KEYSELECT notification. Earlier versions send WM_RBUTTONDOWN and WM_RBUTTONUP messages.

If a user selects a notify icon with the mouse and activates it with the ENTER key, the version 5.0 Shell sends the associated application an NIN_SELECT notification. Earlier versions send WM_RBUTTONDOWN and WM_RBUTTONUP messages.

If a user passes the mouse pointer over an icon with which a balloon ToolTip is associated, the version 5.0 Shell sends the following messages.

  • NIN_BALLOONSHOW Sent when the balloon is shown (balloons are queued).
  • NIN_BALLOONHIDE Sent when the balloon disappears-when the icon is deleted, for example. This message is not sent if the balloon is dismissed because of a timeout or mouse click by the user.
  • NIN_BALLOONTIMEOUT Sent when the balloon is dismissed because of a timeout.
  • NIN_BALLOONUSERCLICK Sent when the balloon is dismissed because the user clicked the mouse.

You can select which way the Shell should behave by calling Shell_NotifyIcon with dwMessage set to NIM_SETVERSION. Set the uVersion member of the NOTIFYICONDATA structure to indicate whether you want pre-version 5.0 behavior or version 5.0 and later behavior.

Group

CXTTrayIcon Methods


CXTTrayIcon::ShowBalloonTip Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::ShowBalloonTip Method

Call this member function to display a balloon tooltip for the system tray icon. Must have Windows 2000 or later.

bool ShowBalloonTip(
    LPCTSTR lpszInfo = NULL,
    LPCTSTR lpszInfoTitle = NULL,
    DWORD dwInfoFlags = NIIF_NONE,
    UINT uTimeout = 10
);
Parameters

lpszInfo
Pointer to a null-terminated string with the text for a balloon ToolTip. It can have a maximum of 255 characters.
lpszInfoTitle
Pointer to a null-terminated string containing a title for a balloon ToolTip. This title appears in boldface above the text. It can have a maximum of 63 characters.
dwInfoFlags
Flags that can be set to add an icon to a balloon ToolTip. It is placed to the left of the title. If the 'lpszInfoTitle' member is zero-length, the icon is not shown, and can be any of the values listed in the Remarks section.
uTimeout
The timeout value in milliseconds for a balloon ToolTip. The system enforces minimum and maximum timeout values. 'uTimeout' values that are too large are set to the maximum value, and values that are too small default to the minimum value. The system minimum and maximum timeout values are currently set at 10 seconds and 30 seconds, respectively.

Returns

true if successful, otherwise returns false.

Remarks

The icon shown can be any of the following values:

  • NIIF_ERROR An error icon.
  • NIIF_INFO An information icon.
  • NIIF_NONE No icon.
  • NIIF_WARNING A warning icon.
Group

CXTTrayIcon Methods


CXTTrayIcon::ShowIcon Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::ShowIcon Method

Call this member function to show the system tray icon in Windows 2000 or greater.

bool ShowIcon();
Returns

true if successful, otherwise returns false.

Group

CXTTrayIcon Methods


CXTTrayIcon::StartAnimation Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::StartAnimation Method

This member function will start the tray icon animation timer.

virtual void StartAnimation(
    UINT uElapse = 500
);
Parameters

uElapse
Specifies the time-out value in milliseconds between frames.

Group

CXTTrayIcon Methods


CXTTrayIcon::StopAnimation Method

CXTTrayIcon Methods, CXTTrayIcon Class
CXTTrayIcon::StopAnimation Method

This member function will stop the tray icon animation timer

virtual void StopAnimation();
Group

CXTTrayIcon Methods


CXTTrayIcon Constructors

CXTTrayIcon Class, Legend, Public Methods
CXTTrayIcon Constructors
Class

CXTTrayIcon Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTrayIcon | Constructs a CXTTrayIcon object


CXTTrayIcon::CXTTrayIcon Constructor

CXTTrayIcon Constructors, CXTTrayIcon Class
CXTTrayIcon::CXTTrayIcon Constructor

Constructs a CXTTrayIcon object

CXTTrayIcon();
Group

CXTTrayIcon Constructors


CXTTrayIcon Destructors

CXTTrayIcon Class, Legend, Public Methods
CXTTrayIcon Destructors
Class

CXTTrayIcon Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTrayIcon | Destroys a CXTTrayIcon object, handles cleanup and deallocation


CXTTrayIcon::~CXTTrayIcon Destructor

CXTTrayIcon Destructors, CXTTrayIcon Class
CXTTrayIcon::~CXTTrayIcon Destructor

Destroys a CXTTrayIcon object, handles cleanup and deallocation

virtual ~CXTTrayIcon();
Group

CXTTrayIcon Destructors


CXTTrayIcon Nested Types

CXTTrayIcon Class, Public Nested Types
CXTTrayIcon Nested Types
Class

CXTTrayIcon Class

Public Nested Types
Public Nested Type | Description
CTrayIconList | Animated icon array


CXTTrayIcon::CTrayIconList Nested Type

CXTTrayIcon Nested Types, CXTTrayIcon Class
CXTTrayIcon::CTrayIconList Nested Type

Animated icon array

typedef CList<TRAYICONDATA, TRAYICONDATA&> CTrayIconList;
Group

CXTTrayIcon Nested Types


CXTTreeBase Class

XTTreeBase.h, Classes, Legend, Members, Topics, CXTTreeBase Structures, CXTTreeBase Data Members, CXTTreeBase Methods, CXTTreeBase Constructors, CXTTreeBase Destructors, CXTTreeBase Nested Types, CXTTreeBase Constructors, CXTTreeBase Data Members, CXTTreeBase Destructors, CXTTreeBase Methods, CXTTreeBase Nested Types, CXTTreeBase Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTreeBase Class

CXTTreeBase is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.

Class Hierarchy

class CXTTreeBase;
File

XTTreeBase.h

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTTreeBase Constructors
CXTTreeBase Constructors | Description
CXTTreeBase | Protected constructor used by dynamic creation. Constructs a CXTTreeBase object
CXTTreeBase Data Members
CXTTreeBase Data Members | Description
m_bBandLabel | TRUE to include the label when selecting tree items.
m_bMultiSelect | TRUE for a multi-selection tree control.
m_hSelect | For shift selection.
m_htiEdit | Tree item that is currently edited.
m_htiLast | Tree item that was last had the mouse over.
m_mapColorFont | Maps HTREEITEM handles with CLRFONT structures that contains the color and logfont information for the tree item.
m_pTreeCtrl | Self tree pointer.
CXTTreeBase Destructors
CXTTreeBase Destructors | Description
~CXTTreeBase | Destroys a CXTTreeBase object, handles cleanup and deallocation
CXTTreeBase Methods
CXTTreeBase Methods | Description
DoAction | Called during item selection in a multiple selection tree control.
DoBanding | Draws a selection rectangle during item selection.
DoPaint | Called to render the tree control.
DoPreSelection | Called during item selection in a multiple selection tree control.
EnableMultiSelect | This member function enables or disables multi-selection for the tree control.
FindItem | This member function searches the entire tree for an item label that contains the search string.
FindItemInBranch | This member function searches the entire branch specified by htiItem for an item label that contains the search string.
FocusItem | This member function will set the focus for the tree item specified by 'hItem'.
GetFirstSelectedItem | This member function returns the first selected item in a multi-selection tree control.
GetFocusedItem | This member function returns the handle to the tree item that currently has focus.
GetItemBackColor |
GetItemBold | This member function checks whether or not the tree item has a bold font.
GetItemColor | This member function returns the RGB value for the specified tree item text color or (COLORREF)-1, if color was not set.
GetItemFont | This member function retrieves the current LOGFONT font used by the tree item.
GetItemState | This member function is a replacement for the base class function of the same name to handle TVIS_FOCUSED in a multi-select tree control.
GetItemTextColor | Retrieves a tree items text color.
GetLastItem | This member function retrieves the last item in the branch.
GetNextItem |
GetNextSelectedItem | This member function returns the next selected item in a multi-selection tree control.
GetPrevItem | This member function gets the previous item as if the outline was completely expanded.
GetPrevSelectedItem | This member function returns the previously selected tree item in a multi-selection tree control.
GetSelectedCount | This member function returns the number of tree items that are selected.
GetSelectedList | This member function will retrieve a reference to the typed pointer array that contains the items selected in the tree control.
GetTreeBackColor | Retrieves the tree control background color.
GetTreeTextColor | Retrieves the tree control text color.
HasEditLabels | Determines if the tree control has edit labels.
Init | This member function is called by the CXTTreeBase class to perform initialization when the window is created or sub-classed.
IsFindValid | Member override to determine if a tree item is valid.
IsMultiSelect | This member function checks to see if the tree control is a multi-select tree.
IsSelected | This member function checks whether or not the specified item is selected.
OnButtonDown | Called when a mouse button click event occurs.
SelectAll | Call this member function to clear, or select, all of the visible items in the tree control. This will not effect the focus of the tree items.
SelectAllIgnore | Toggles selection for all items in a multiple selection tree control.
SelectChildren | This member function will cause all of the children of the specified tree item to be selected or deselected.
SelectItem | This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. Call this function to select the given tree view item. If 'hItem' is NULL, then no items are selected.
SelectItems | This member function selects items from 'hItemFrom' to 'hItemTo' in a multi-selection tree control. It does not select a child item if the parent is collapsed. It will remove the selection from all other items if 'bOnly' is set to TRUE.
SendNotify | Sends a WM_NOTIFY message to the tree control owner window.
SetBandingHit | This member function sets the banding mode for a multi-selection tree control. If 'bLabel' is TRUE, then items are selected only when the banding rect passes over the tree item label. If FALSE, passing over any part of the tree item will cause selection to be made when the banding rect passes over it.
SetItemBackColor | This member function sets the tree item background color.
SetItemBold | This member function sets the reference tree item font to bold.
SetItemColor | This member function sets the tree item text color.
SetItemFont | This member function sets the font for the reference tree item.
SetItemState | This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. It sets the state of the item specified by hItem.
UpdateSelectionForRect | Updates tree item selection.
CXTTreeBase Nested Types
CXTTreeBase Nested Types | Description
CColorFontMap | Map for maintaining HTREEITEM to CLRFONT structure relationships.
CXTTreeBase Structures
CXTTreeBase Structures | Description
CLRFONT | CLRFONT structure is used to by the CXTShellTreeCtrl and CXTShellTreeView class to maintain font information for a particular tree item.


CXTTreeBase Structures

CXTTreeBase Class, Legend, Structures
CXTTreeBase Structures
Class

CXTTreeBase Class

Legend
Structure
Structures
Structure | Description
CLRFONT | CLRFONT structure is used to by the CXTShellTreeCtrl and CXTShellTreeView class to maintain font information for a particular tree item.


CXTTreeBase::CLRFONT Structure

XTTreeBase.h, CXTTreeBase Structures, Legend, Members, Topics, CLRFONT Data Members, CLRFONT Constructors, CLRFONT Constructors, CLRFONT Data Members, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTreeBase::CLRFONT Structure

CLRFONT structure is used to by the CXTShellTreeCtrl and CXTShellTreeView class to maintain font information for a particular tree item.

Class Hierarchy

struct CLRFONT {
  LOGFONT logfont;
  COLORREF color;
  COLORREF colorBack;
};
File

XTTreeBase.h

See Also

CXTShellTreeCtrl, CXTShellTreeView

Group

CXTTreeBase Structures

Legend
Data Member
Constructor
CLRFONT Constructors
CLRFONT Constructors | Description
CLRFONT | Constructs a CLRFONT struct and initializes member data.
CLRFONT Data Members
CLRFONT Data Members | Description
color | An RGB value that represents the text color for a tree item.
colorBack | An RGB value that represents the background color for a tree item.
logfont | A LOGFONT object that represents the tree item font.


CLRFONT Data Members

CXTTreeBase::CLRFONT Structure, Legend, Public Data Members
CLRFONT Data Members
Structure

CXTTreeBase::CLRFONT Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
color | An RGB value that represents the text color for a tree item.
colorBack | An RGB value that represents the background color for a tree item.
logfont | A LOGFONT object that represents the tree item font.


CXTTreeBase::CLRFONT::color Data Member

CLRFONT Data Members, CXTTreeBase::CLRFONT Structure
CXTTreeBase::CLRFONT::color Data Member

An RGB value that represents the text color for a tree item.

COLORREF color;
Group

CLRFONT Data Members


CXTTreeBase::CLRFONT::colorBack Data Member

CLRFONT Data Members, CXTTreeBase::CLRFONT Structure
CXTTreeBase::CLRFONT::colorBack Data Member

An RGB value that represents the background color for a tree item.

COLORREF colorBack;
Group

CLRFONT Data Members


CXTTreeBase::CLRFONT::logfont Data Member

CLRFONT Data Members, CXTTreeBase::CLRFONT Structure
CXTTreeBase::CLRFONT::logfont Data Member

A LOGFONT object that represents the tree item font.

LOGFONT logfont;
Group

CLRFONT Data Members


CLRFONT Constructors

CXTTreeBase::CLRFONT Structure, Legend, Public Methods
CLRFONT Constructors
Structure

CXTTreeBase::CLRFONT Structure

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CLRFONT | Constructs a CLRFONT struct and initializes member data.


CXTTreeBase::CLRFONT::CLRFONT Constructor

CLRFONT Constructors, CXTTreeBase::CLRFONT Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTreeBase::CLRFONT::CLRFONT Constructor

Constructs a CLRFONT struct and initializes member data.

CLRFONT();
Body Source
CXTTreeBase::CLRFONT::CLRFONT() : color((COLORREF)-1), colorBack((COLORREF)-1) {
    ::ZeroMemory(&logfont, sizeof(LOGFONT));
}
Group

CLRFONT Constructors


CXTTreeBase Data Members

CXTTreeBase Class, Legend, Protected Data Members
CXTTreeBase Data Members
Class

CXTTreeBase Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bBandLabel | TRUE to include the label when selecting tree items.
m_bMultiSelect | TRUE for a multi-selection tree control.
m_hSelect | For shift selection.
m_htiEdit | Tree item that is currently edited.
m_htiLast | Tree item that was last had the mouse over.
m_mapColorFont | Maps HTREEITEM handles with CLRFONT structures that contains the color and logfont information for the tree item.
m_pTreeCtrl | Self tree pointer.


CXTTreeBase::m_bBandLabel Data Member

CXTTreeBase Data Members, CXTTreeBase Class
CXTTreeBase::m_bBandLabel Data Member

TRUE to include the label when selecting tree items.

BOOL m_bBandLabel;
Group

CXTTreeBase Data Members


CXTTreeBase::m_bMultiSelect Data Member

CXTTreeBase Data Members, CXTTreeBase Class
CXTTreeBase::m_bMultiSelect Data Member

TRUE for a multi-selection tree control.

BOOL m_bMultiSelect;
Group

CXTTreeBase Data Members


CXTTreeBase::m_hSelect Data Member

CXTTreeBase Data Members, CXTTreeBase Class
CXTTreeBase::m_hSelect Data Member

For shift selection.

HTREEITEM m_hSelect;
Group

CXTTreeBase Data Members


CXTTreeBase::m_htiEdit Data Member

CXTTreeBase Data Members, CXTTreeBase Class
CXTTreeBase::m_htiEdit Data Member

Tree item that is currently edited.

HTREEITEM m_htiEdit;
Group

CXTTreeBase Data Members


CXTTreeBase::m_htiLast Data Member

CXTTreeBase Data Members, CXTTreeBase Class
CXTTreeBase::m_htiLast Data Member

Tree item that was last had the mouse over.

HTREEITEM m_htiLast;
Group

CXTTreeBase Data Members


CXTTreeBase::m_mapColorFont Data Member

CXTTreeBase Data Members, CXTTreeBase Class
CXTTreeBase::m_mapColorFont Data Member

Maps HTREEITEM handles with CLRFONT structures that contains the color and logfont information for the tree item.

CColorFontMap m_mapColorFont;
Group

CXTTreeBase Data Members


CXTTreeBase::m_pTreeCtrl Data Member

CXTTreeBase Data Members, CXTTreeBase Class
CXTTreeBase::m_pTreeCtrl Data Member

Self tree pointer.

CTreeCtrl_Friendly* m_pTreeCtrl;
Group

CXTTreeBase Data Members


CXTTreeBase Methods

CXTTreeBase Class, Legend, Protected Methods, Public Methods
CXTTreeBase Methods
Class

CXTTreeBase Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DoAction | Called during item selection in a multiple selection tree control.
DoBanding | Draws a selection rectangle during item selection.
DoPaint | Called to render the tree control.
DoPreSelection | Called during item selection in a multiple selection tree control.
GetItemTextColor | Retrieves a tree items text color.
GetTreeBackColor | Retrieves the tree control background color.
GetTreeTextColor | Retrieves the tree control text color.
HasEditLabels | Determines if the tree control has edit labels.
Init | This member function is called by the CXTTreeBase class to perform initialization when the window is created or sub-classed.
IsFindValid | Member override to determine if a tree item is valid.
OnButtonDown | Called when a mouse button click event occurs.
SelectAllIgnore | Toggles selection for all items in a multiple selection tree control.
SendNotify | Sends a WM_NOTIFY message to the tree control owner window.
UpdateSelectionForRect | Updates tree item selection.
Public Methods
Public Methods
Public Method | Description
EnableMultiSelect | This member function enables or disables multi-selection for the tree control.
FindItem | This member function searches the entire tree for an item label that contains the search string.
FindItemInBranch | This member function searches the entire branch specified by htiItem for an item label that contains the search string.
FocusItem | This member function will set the focus for the tree item specified by 'hItem'.
GetFirstSelectedItem | This member function returns the first selected item in a multi-selection tree control.
GetFocusedItem | This member function returns the handle to the tree item that currently has focus.
GetItemBackColor |
GetItemBold | This member function checks whether or not the tree item has a bold font.
GetItemColor | This member function returns the RGB value for the specified tree item text color or (COLORREF)-1, if color was not set.
GetItemFont | This member function retrieves the current LOGFONT font used by the tree item.
GetItemState | This member function is a replacement for the base class function of the same name to handle TVIS_FOCUSED in a multi-select tree control.
GetLastItem | This member function retrieves the last item in the branch.
GetNextItem |
GetNextSelectedItem | This member function returns the next selected item in a multi-selection tree control.
GetPrevItem | This member function gets the previous item as if the outline was completely expanded.
GetPrevSelectedItem | This member function returns the previously selected tree item in a multi-selection tree control.
GetSelectedCount | This member function returns the number of tree items that are selected.
GetSelectedList | This member function will retrieve a reference to the typed pointer array that contains the items selected in the tree control.
IsMultiSelect | This member function checks to see if the tree control is a multi-select tree.
IsSelected | This member function checks whether or not the specified item is selected.
SelectAll | Call this member function to clear, or select, all of the visible items in the tree control. This will not effect the focus of the tree items.
SelectChildren | This member function will cause all of the children of the specified tree item to be selected or deselected.
SelectItem | This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. Call this function to select the given tree view item. If 'hItem' is NULL, then no items are selected.
SelectItems | This member function selects items from 'hItemFrom' to 'hItemTo' in a multi-selection tree control. It does not select a child item if the parent is collapsed. It will remove the selection from all other items if 'bOnly' is set to TRUE.
SetBandingHit | This member function sets the banding mode for a multi-selection tree control. If 'bLabel' is TRUE, then items are selected only when the banding rect passes over the tree item label. If FALSE, passing over any part of the tree item will cause selection to be made when the banding rect passes over it.
SetItemBackColor | This member function sets the tree item background color.
SetItemBold | This member function sets the reference tree item font to bold.
SetItemColor | This member function sets the tree item text color.
SetItemFont | This member function sets the font for the reference tree item.
SetItemState | This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. It sets the state of the item specified by hItem.


CXTTreeBase::DoAction Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::DoAction Method

Called during item selection in a multiple selection tree control.

virtual void DoAction(
    HTREEITEM hItem,
    BOOL bLeft,
    UINT nFlags,
    CPoint point
);
Parameters

hItem
Handle to the last item clicked that will receive focus.
bLeft
TRUE if the left mouse button is down.
nFlags
Indicates whether various virtual keys are down. See Remarks section for a list of values.
point
Mouse cursor position.

Remarks

nFlags, /i> can be any combination of the following values:

  • MK_CONTROL Set if the CTRL key is down.
  • MK_LBUTTON Set if the left mouse button is down.
  • MK_MBUTTON Set if the middle mouse button is down.
  • MK_RBUTTON Set if the right mouse button is down.
  • MK_SHIFT Set if the SHIFT key is down.
Group

CXTTreeBase Methods


CXTTreeBase::DoBanding Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::DoBanding Method

Draws a selection rectangle during item selection.

virtual void DoBanding(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down. See Remarks section for a list of values.
point

  • location of the mouse cursor.

Remarks

nFlags, /i> can be any combination of the following values:

  • MK_CONTROL Set if the CTRL key is down.
  • MK_LBUTTON Set if the left mouse button is down.
  • MK_MBUTTON Set if the middle mouse button is down.
  • MK_RBUTTON Set if the right mouse button is down.
  • MK_SHIFT Set if the SHIFT key is down.
Group

CXTTreeBase Methods


CXTTreeBase::DoPaint Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::DoPaint Method

Called to render the tree control.

virtual void DoPaint(
    CDC& dc,
    BOOL bInternal = TRUE
);
Parameters

dc
Reference to the tree control device context.
bInternal
FALSE to skip extended rendering tasks and to the tree control's default rendering.

Remarks

This member is called to render the tree control using user defined fonts and colors. You can override this member to provide additional functionality.

Group

CXTTreeBase Methods


CXTTreeBase::DoPreSelection Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::DoPreSelection Method

Called during item selection in a multiple selection tree control.

virtual void DoPreSelection(
    HTREEITEM hItem,
    BOOL bLeft,
    UINT nFlags
);
Parameters

hItem
Handle to the last item clicked that will receive focus.
bLeft
TRUE if the left mouse button is down.
nFlags
Indicates whether various virtual keys are down. See Remarks section for a list of values.

Remarks

nFlags, /i> can be any combination of the following values:

  • MK_CONTROL Set if the CTRL key is down.
  • MK_LBUTTON Set if the left mouse button is down.
  • MK_MBUTTON Set if the middle mouse button is down.
  • MK_RBUTTON Set if the right mouse button is down.
  • MK_SHIFT Set if the SHIFT key is down.
Group

CXTTreeBase Methods


CXTTreeBase::EnableMultiSelect Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::EnableMultiSelect Method

This member function enables or disables multi-selection for the tree control.

virtual BOOL EnableMultiSelect(
    BOOL bMultiSelect = TRUE
);
Parameters

bMultiSelect
TRUE for a multi-selection tree control.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTTreeBase Methods


CXTTreeBase::FindItem Method

CXTTreeBase Methods, CXTTreeBase Class, See Also
CXTTreeBase::FindItem Method

This member function searches the entire tree for an item label that contains the search string.

virtual HTREEITEM FindItem(
    LPCTSTR lpszSearch,
    BOOL bCaseSensitive = FALSE,
    BOOL bDownDir = TRUE,
    BOOL bWholeWord = FALSE,
    HTREEITEM hItem = NULL
);
Parameters

lpszSearch
String to search for.
bCaseSensitive
TRUE if the search should be case sensitive.
bDownDir
TRUE for down.
bWholeWord
TRUE if search should match whole words.
hItem
Handle of the tree item to start searching from, NULL to use the currently selected tree item.

Returns

The handle to the item, or returns NULL.

See Also

IsFindValid

Group

CXTTreeBase Methods


CXTTreeBase::FindItemInBranch Method

CXTTreeBase Methods, CXTTreeBase Class, See Also
CXTTreeBase::FindItemInBranch Method

This member function searches the entire branch specified by htiItem for an item label that contains the search string.

virtual HTREEITEM FindItemInBranch(
    LPCTSTR lpszSearch,
    BOOL bCaseSensitive,
    BOOL bWholeWord,
    HTREEITEM htiItem
);
Parameters

lpszSearch
String to search for.
bCaseSensitive
TRUE if the search should be case sensitive.
bWholeWord
TRUE if search should match whole words.
htiItem
Handle of the tree item to start searching from, NULL to use the currently selected tree item.

Returns

The handle to the item, or returns NULL.

See Also

IsFindValid

Group

CXTTreeBase Methods


CXTTreeBase::FocusItem Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::FocusItem Method

This member function will set the focus for the tree item specified by 'hItem'.

BOOL FocusItem(
    HTREEITEM hItem
);
Parameters

hItem
Handle of a tree item.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTTreeBase Methods


CXTTreeBase::GetFirstSelectedItem Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetFirstSelectedItem Method

This member function returns the first selected item in a multi-selection tree control.

HTREEITEM GetFirstSelectedItem() const;
Returns

A handle to the first selected tree item.

Group

CXTTreeBase Methods


CXTTreeBase::GetFocusedItem Method

CXTTreeBase Methods, CXTTreeBase Class, Body Source
CXTTreeBase::GetFocusedItem Method

This member function returns the handle to the tree item that currently has focus.

HTREEITEM GetFocusedItem() const;
Returns

The handle of the item that has focus, otherwise returns NULL.

Body Source
HTREEITEM CXTTreeBase::GetFocusedItem() const {
    ASSERT(m_bMultiSelect); return m_pTreeCtrl->GetSelectedItem();
}
Group

CXTTreeBase Methods


GetItemBackColor Method

CXTTreeBase Methods
GetItemBackColor Method
Overload List
Methods
Method | Description
CXTTreeBase::GetItemBackColor (HTREEITEM) | This member function returns the RGB value for the specified tree item background color or (COLORREF)-1, if color was not set.
CXTTreeBase::GetItemBackColor (UINT, bool, DWORD, COLORREF) | Retrieves a tree items background color.
Group

CXTTreeBase Methods


CXTTreeBase::GetItemBackColor Method (HTREEITEM)

GetItemBackColor Method, CXTTreeBase Class
CXTTreeBase::GetItemBackColor Method (HTREEITEM)

This member function returns the RGB value for the specified tree item background color or (COLORREF)-1, if color was not set.

virtual COLORREF GetItemBackColor(
    HTREEITEM hItem
);
Parameters

hItem
Handle of the reference item.

Returns

The RGB value for the specified tree item background color, or (COLORREF)-1, if the color was not set.

Group

GetItemBackColor Method


CXTTreeBase::GetItemBackColor Method (UINT, bool, DWORD, COLORREF)

GetItemBackColor Method, CXTTreeBase Class, See Also
CXTTreeBase::GetItemBackColor Method (UINT, bool, DWORD, COLORREF)

Retrieves a tree items background color.

virtual COLORREF GetItemBackColor(
    UINT uState,
    bool bTreeHasFocus,
    DWORD dwStyle,
    COLORREF crBack
) const;
Parameters

uState
Mask indicating which states are to be retrieved. For more information on possible values for nStateMask, see the discussion of the state and stateMask members of the TVITEM structure in the Platform SDK.
bTreeHasFocus
true if the tree item has input focus.
dwStyle
Set of flags specifying tree item state.
crBack
Default color to be returned, usually the tree control background color.

Returns

An RGB value representing the specified item background color.

Remarks

This member function is called to retrieve a tree items background color. The value retrieved will depend on the tree items state and TVS_ style.

See Also

GetTreeBackColor, GetTreeTextColor, GetItemTextColor

Group

GetItemBackColor Method


CXTTreeBase::GetItemBold Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetItemBold Method

This member function checks whether or not the tree item has a bold font.

virtual BOOL GetItemBold(
    HTREEITEM hItem
);
Parameters

hItem
Handle of the reference item.

Returns

TRUE if the tree item has a bold font, otherwise returns FALSE.

Group

CXTTreeBase Methods


CXTTreeBase::GetItemColor Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetItemColor Method

This member function returns the RGB value for the specified tree item text color or (COLORREF)-1, if color was not set.

virtual COLORREF GetItemColor(
    HTREEITEM hItem
);
Parameters

hItem
Handle of the reference item.

Returns

The RGB value for the specified tree item text color, or (COLORREF)-1, if the color was not set.

Group

CXTTreeBase Methods


CXTTreeBase::GetItemFont Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetItemFont Method

This member function retrieves the current LOGFONT font used by the tree item.

virtual BOOL GetItemFont(
    HTREEITEM hItem,
    LOGFONT* plogfont
);
Parameters

hItem
Handle of the reference item.
plogfont
Pointer to receive LOGFONT information.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTTreeBase Methods


CXTTreeBase::GetItemState Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetItemState Method

This member function is a replacement for the base class function of the same name to handle TVIS_FOCUSED in a multi-select tree control.

UINT GetItemState(
    HTREEITEM hItem,
    UINT nStateMask
) const;
Parameters

hItem
Handle of the item whose state is to be retrieved.
nStateMask
Mask indicating which states are to be retrieved. For more information on possible values for 'nStateMask', see the discussion of the 'state' and 'stateMask' members of the TVITEM structure in the Platform SDK.

Returns

The state of the item specified by 'hItem'.

Group

CXTTreeBase Methods


CXTTreeBase::GetItemTextColor Method

CXTTreeBase Methods, CXTTreeBase Class, See Also
CXTTreeBase::GetItemTextColor Method

Retrieves a tree items text color.

virtual COLORREF GetItemTextColor(
    UINT uState,
    bool bTreeHasFocus,
    DWORD dwStyle,
    COLORREF crText
) const;
Parameters

uState
Mask indicating which states are to be retrieved. For more information on possible values for nStateMask, see the discussion of the state and stateMask members of the TVITEM structure in the Platform SDK.
bTreeHasFocus
true if the tree item has input focus.
dwStyle
Set of flags specifying tree item state.
crText
Default color to be returned, usually the tree control text color.

Returns

An RGB value representing the specified item text color.

Remarks

This member function is called to retrieve a tree items text color. The value retrieved will depend on the tree items state and TVS_ style.

See Also

GetTreeBackColor, GetTreeTextColor, GetItemBackColor

Group

CXTTreeBase Methods


CXTTreeBase::GetLastItem Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetLastItem Method

This member function retrieves the last item in the branch.

virtual HTREEITEM GetLastItem(
    HTREEITEM hItem
) const;
Parameters

hItem
Node identifying the branch. NULL will return the last item in the outline.

Returns

The handle of the last item.

Group

CXTTreeBase Methods


GetNextItem Method

CXTTreeBase Methods
GetNextItem Method
Overload List
Methods
Method | Description
CXTTreeBase::GetNextItem (HTREEITEM) | This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.
CXTTreeBase::GetNextItem (HTREEITEM, UINT) | This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.
Group

CXTTreeBase Methods


CXTTreeBase::GetNextItem Method (HTREEITEM)

GetNextItem Method, CXTTreeBase Class
CXTTreeBase::GetNextItem Method (HTREEITEM)

This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.

virtual HTREEITEM GetNextItem(
    HTREEITEM hItem
) const;
virtual HTREEITEM GetNextItem(
    HTREEITEM hItem,
    UINT nCode
) const;
Parameters

hItem
Handle of a tree item.
nCode
A flag indicating the type of relation to 'hItem'. This flag can be one of the values listed in the Remarks section.

Returns

The handle of the next item if successful, otherwise returns NULL.

Remarks

nCode can be one of the following values:

  • TVGN_CARET Retrieves the currently selected item.
  • TVGN_CHILD Retrieves the first child item. The 'hItem' parameter must be NULL.
  • TVGN_DROPHILITE Retrieves the item that is the target of a drag-and-drop operation.
  • TVGN_FIRSTVISIBLE Retrieves the first visible item.
  • TVGN_NEXT Retrieves the next sibling item.
  • TVGN_NEXTVISIBLE Retrieves the next visible item that follows the specified item.
  • TVGN_PARENT Retrieves the parent of the specified item.
  • TVGN_PREVIOUS Retrieves the previous sibling item.
  • TVGN_PREVIOUSVISIBLE Retrieves the first visible item that precedes the specified item.
  • TVGN_ROOT Retrieves the first child item of the root item of which the specified item is a part.

The Non nCode version gets the next item as if the outline was completely expanded.

Group

GetNextItem Method


CXTTreeBase::GetNextSelectedItem Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetNextSelectedItem Method

This member function returns the next selected item in a multi-selection tree control.

HTREEITEM GetNextSelectedItem(
    HTREEITEM hItem
) const;
Parameters

hItem
Handle of the reference item.

Returns

A handle to the next selected tree item.

Group

CXTTreeBase Methods


CXTTreeBase::GetPrevItem Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetPrevItem Method

This member function gets the previous item as if the outline was completely expanded.

virtual HTREEITEM GetPrevItem(
    HTREEITEM hItem
) const;
Parameters

hItem
Handle of the reference item.

Returns

The handle of the item immediately above the reference item.

Group

CXTTreeBase Methods


CXTTreeBase::GetPrevSelectedItem Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetPrevSelectedItem Method

This member function returns the previously selected tree item in a multi-selection tree control.

virtual HTREEITEM GetPrevSelectedItem(
    HTREEITEM hItem
) const;
Parameters

hItem
Handle of the reference item.

Returns

A handle to the previously selected tree item.

Group

CXTTreeBase Methods


CXTTreeBase::GetSelectedCount Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetSelectedCount Method

This member function returns the number of tree items that are selected.

UINT GetSelectedCount() const;
Returns

A UNIT value that represents the number of tree items selected.

Group

CXTTreeBase Methods


CXTTreeBase::GetSelectedList Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::GetSelectedList Method

This member function will retrieve a reference to the typed pointer array that contains the items selected in the tree control.

void GetSelectedList(
    CTypedPtrList<CPtrList, HTREEITEM>& list
) const;
Parameters

list
Reference to a CTypedPtrList<CPtrList, HTREEITEM> object.

Group

CXTTreeBase Methods


CXTTreeBase::GetTreeBackColor Method

CXTTreeBase Methods, CXTTreeBase Class, See Also
CXTTreeBase::GetTreeBackColor Method

Retrieves the tree control background color.

virtual COLORREF GetTreeBackColor() const;
Returns

An RGB value representing the tree control background color.

See Also

CTreeCtrl::SetBkColor, CTreeCtrl::GetBkColor, GetTreeTextColor, GetItemBackColor, GetItemTextColor

Group

CXTTreeBase Methods


CXTTreeBase::GetTreeTextColor Method

CXTTreeBase Methods, CXTTreeBase Class, See Also
CXTTreeBase::GetTreeTextColor Method

Retrieves the tree control text color.

virtual COLORREF GetTreeTextColor() const;
Returns

An RGB value representing the tree control text color.

See Also

CTreeCtrl::SetTextColor, CTreeCtrl::GetTextColor, GetTreeBackColor, GetItemBackColor, GetItemTextColor

Group

CXTTreeBase Methods


CXTTreeBase::HasEditLabels Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::HasEditLabels Method

Determines if the tree control has edit labels.

bool HasEditLabels() const;
Returns

true if the TVS_EDITLABELS style is set for the tree control, otherwise false.

Group

CXTTreeBase Methods


CXTTreeBase::Init Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::Init Method

This member function is called by the CXTTreeBase class to perform initialization when the window is created or sub-classed.

virtual bool Init();
Returns

TRUE if the window was successfully initialized, otherwise FALSE.

Group

CXTTreeBase Methods


CXTTreeBase::IsFindValid Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::IsFindValid Method

Member override to determine if a tree item is valid.

virtual BOOL IsFindValid(
    HTREEITEM hti
);
Parameters

hti
Handle to the tree item that was found when FindItem or FindItemInBranch has been called.

Returns

TRUE in the base class. Derived classes must return TRUE to indicate success and FALSE to indicate failure.

Remarks

Override this member function to determine if the tree item specified by hti is a valid. If IsFindValid returns FALSE the calling functions FindItem and FindItemInBranch will return NULL.

Group

CXTTreeBase Methods


CXTTreeBase::IsMultiSelect Method

CXTTreeBase Methods, CXTTreeBase Class, Body Source
CXTTreeBase::IsMultiSelect Method

This member function checks to see if the tree control is a multi-select tree.

BOOL IsMultiSelect() const;
Returns

TRUE if the tree control is a multi-select tree, otherwise returns FALSE.

Body Source
BOOL CXTTreeBase::IsMultiSelect() const {
    return m_bMultiSelect;
}
Group

CXTTreeBase Methods


CXTTreeBase::IsSelected Method

CXTTreeBase Methods, CXTTreeBase Class, Body Source
CXTTreeBase::IsSelected Method

This member function checks whether or not the specified item is selected.

BOOL IsSelected(
    HTREEITEM hItem
) const;
Parameters

hItem
Handle of a tree item.

Returns

TRUE if the specified item is selected, otherwise returns FALSE.

Body Source
BOOL CXTTreeBase::IsSelected(HTREEITEM hItem) const {
    return !!(TVIS_SELECTED & m_pTreeCtrl->GetItemState(hItem, TVIS_SELECTED));
}
Group

CXTTreeBase Methods


CXTTreeBase::OnButtonDown Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::OnButtonDown Method

Called when a mouse button click event occurs.

virtual BOOL OnButtonDown(
    BOOL bLeft,
    UINT nFlags,
    CPoint point
);
Parameters

bLeft
TRUE if the left mouse button is down.
nFlags
Indicates whether various virtual keys are down. See Remarks section for a list of values.
point

  • cursor location.

Returns

TRUE if successful, otherwise FALSE.

Remarks

nFlags, /i> can be any combination of the following values:

  • MK_CONTROL Set if the CTRL key is down.
  • MK_LBUTTON Set if the left mouse button is down.
  • MK_MBUTTON Set if the middle mouse button is down.
  • MK_RBUTTON Set if the right mouse button is down.
  • MK_SHIFT Set if the SHIFT key is down.
Group

CXTTreeBase Methods


CXTTreeBase::SelectAll Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SelectAll Method

Call this member function to clear, or select, all of the visible items in the tree control. This will not effect the focus of the tree items.

void SelectAll(
    BOOL bSelect = TRUE,
    HTREEITEM htItem = NULL
);
Parameters

bSelect
TRUE to select all the items, or FALSE to clear the selection.
htItem
Tree item to start selection from. If NULL selection will begin at the root.

Group

CXTTreeBase Methods


CXTTreeBase::SelectAllIgnore Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SelectAllIgnore Method

Toggles selection for all items in a multiple selection tree control.

virtual void SelectAllIgnore(
    BOOL bSelect,
    HTREEITEM hIgnore
);
Parameters

bSelect
TRUE to select, FALSE to remove selection.
hIgnore
Handle to a tree item to skip while performing the operation.

Remarks

Called to toggle selection for all items in a multiple selection tree control. You can override this member to provide additional functionality.

Group

CXTTreeBase Methods


CXTTreeBase::SelectChildren Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SelectChildren Method

This member function will cause all of the children of the specified tree item to be selected or deselected.

BOOL SelectChildren(
    HTREEITEM hParent,
    BOOL bSelect = TRUE,
    BOOL bRecurse = TRUE
);
Parameters

hParent
Handle of tree item to begin selection from.
bSelect
TRUE to select only the child items or FALSE to keep existing selections.
bRecurse
TRUE to recurse all siblings or FALSE to select only children of the parent item.

Returns

TRUE if focus was on a child item, otherwise returns FALSE.

Group

CXTTreeBase Methods


CXTTreeBase::SelectItem Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SelectItem Method

This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. Call this function to select the given tree view item. If 'hItem' is NULL, then no items are selected.

BOOL SelectItem(
    HTREEITEM hItem
);
Parameters

hItem
Handle of a tree item.

Returns

Nonzero if successful, otherwise returns zero.

Group

CXTTreeBase Methods


CXTTreeBase::SelectItems Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SelectItems Method

This member function selects items from 'hItemFrom' to 'hItemTo' in a multi-selection tree control. It does not select a child item if the parent is collapsed. It will remove the selection from all other items if 'bOnly' is set to TRUE.

void SelectItems(
    HTREEITEM hItemFrom,
    HTREEITEM hItemTo,
    BOOL bOnly = TRUE
);
Parameters

hItemFrom
Handle of the item to start selecting from.
hItemTo
Handle of the item to end selection at.
bOnly
TRUE to only select the specified range, or FALSE to keep existing selections.

Group

CXTTreeBase Methods


CXTTreeBase::SendNotify Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SendNotify Method

Sends a WM_NOTIFY message to the tree control owner window.

virtual LRESULT SendNotify(
    LPNMHDR pNMHDR
);
Parameters

pNMHDR
Pointer to an NMHDR structure that contains the notification code and additional information. For some notification messages, this parameter points to a larger structure that has the NMHDR structure as its first member.

Returns

The return value is ignored except for notification messages that specify otherwise.

Remarks

Called by the tree control to package and send a WM_NOTIFY message to the tree control's owner window. You can override this member to provide additional functionality.

Group

CXTTreeBase Methods


CXTTreeBase::SetBandingHit Method

CXTTreeBase Methods, CXTTreeBase Class, Body Source
CXTTreeBase::SetBandingHit Method

This member function sets the banding mode for a multi-selection tree control. If 'bLabel' is TRUE, then items are selected only when the banding rect passes over the tree item label. If FALSE, passing over any part of the tree item will cause selection to be made when the banding rect passes over it.

BOOL SetBandingHit(
    BOOL bLabel
);
Parameters

bLabel
TRUE to select items only when banding rect passes over the text label, or FALSE to select items when banding rect passes over any part of the tree item.

Returns

The previous banding state.

Body Source
BOOL CXTTreeBase::SetBandingHit(BOOL bLabel) {
    BOOL bReturn = m_bBandLabel; m_bBandLabel = bLabel; return bReturn;
}
Group

CXTTreeBase Methods


CXTTreeBase::SetItemBackColor Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SetItemBackColor Method

This member function sets the tree item background color.

virtual void SetItemBackColor(
    HTREEITEM hItem,
    COLORREF color
);
Parameters

hItem
Handle of the reference item.
color
RGB value for the tree item's text.

Group

CXTTreeBase Methods


CXTTreeBase::SetItemBold Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SetItemBold Method

This member function sets the reference tree item font to bold.

virtual void SetItemBold(
    HTREEITEM hItem,
    BOOL bBold = TRUE
);
Parameters

hItem
Handle of the reference item.
bBold
TRUE for bold font.

Group

CXTTreeBase Methods


CXTTreeBase::SetItemColor Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SetItemColor Method

This member function sets the tree item text color.

virtual void SetItemColor(
    HTREEITEM hItem,
    COLORREF color
);
Parameters

hItem
Handle of the reference item.
color
RGB value for the tree item's text.

Group

CXTTreeBase Methods


CXTTreeBase::SetItemFont Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SetItemFont Method

This member function sets the font for the reference tree item.

virtual void SetItemFont(
    HTREEITEM hItem,
    LOGFONT& logfont
);
Parameters

hItem
Handle of the reference item.
logfont
New font for the tree item.

Group

CXTTreeBase Methods


CXTTreeBase::SetItemState Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::SetItemState Method

This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. It sets the state of the item specified by hItem.

BOOL SetItemState(
    HTREEITEM hItem,
    UINT nState,
    UINT nStateMask
);
Parameters

hItem
Handle of the item whose state is to be set.
nState
Specifies the new states for the item.
nStateMask
Specifies which states are to be changed.

Returns

Nonzero if successful, otherwise returns zero.

Remarks

The TVIS_FOCUSED state flag when set will draw a focus rectangle around the tree item that currently has input focus. Only one tree item can have focus at any given time. For a list of possible item state flags, see Tree-View Control Item States in the MSDN documentation.

Group

CXTTreeBase Methods


CXTTreeBase::UpdateSelectionForRect Method

CXTTreeBase Methods, CXTTreeBase Class
CXTTreeBase::UpdateSelectionForRect Method

Updates tree item selection.

virtual void UpdateSelectionForRect(
    LPCRECT pRect,
    UINT nFlags,
    CTypedPtrList<CPtrList, HTREEITEM>& list
);
Parameters

pRect
Cursor drag rectangle representing tree items to select.
nFlags
Indicates whether various virtual keys are down. See Remarks section for a list of values.
list
An array of tree items that are currently selected.

Remarks

Called by the tree control to select tree items based upon the area specified by pRect. nFlags, /i> can be any combination of the following values:

  • MK_CONTROL Set if the CTRL key is down.
  • MK_LBUTTON Set if the left mouse button is down.
  • MK_MBUTTON Set if the middle mouse button is down.
  • MK_RBUTTON Set if the right mouse button is down.
  • MK_SHIFT Set if the SHIFT key is down.
Group

CXTTreeBase Methods


CXTTreeBase Constructors

CXTTreeBase Class, Legend, Protected Methods
CXTTreeBase Constructors
Class

CXTTreeBase Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTTreeBase | Protected constructor used by dynamic creation. Constructs a CXTTreeBase object


CXTTreeBase::CXTTreeBase Constructor

CXTTreeBase Constructors, CXTTreeBase Class
CXTTreeBase::CXTTreeBase Constructor

Protected constructor used by dynamic creation. Constructs a CXTTreeBase object

CXTTreeBase();
Group

CXTTreeBase Constructors


CXTTreeBase Destructors

CXTTreeBase Class, Legend, Protected Methods
CXTTreeBase Destructors
Class

CXTTreeBase Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTTreeBase | Destroys a CXTTreeBase object, handles cleanup and deallocation


CXTTreeBase::~CXTTreeBase Destructor

CXTTreeBase Destructors, CXTTreeBase Class
CXTTreeBase::~CXTTreeBase Destructor

Destroys a CXTTreeBase object, handles cleanup and deallocation

virtual ~CXTTreeBase();
Group

CXTTreeBase Destructors


CXTTreeBase Nested Types

CXTTreeBase Class, Public Nested Types
CXTTreeBase Nested Types
Class

CXTTreeBase Class

Public Nested Types
Public Nested Type | Description
CColorFontMap | Map for maintaining HTREEITEM to CLRFONT structure relationships.


CXTTreeBase::CColorFontMap Nested Type

CXTTreeBase Nested Types, CXTTreeBase Class, See Also
CXTTreeBase::CColorFontMap Nested Type

Map for maintaining HTREEITEM to CLRFONT structure relationships.

typedef CMap<void*, void*, CLRFONT, CLRFONT&> CColorFontMap;
Remarks

CMap definition used by the CXTTreeBase class to maintain a list of HTREEITEM to CLRFONT structure relationships representing tree item that has user defined color information.

See Also

CXTTreeBase, CLRFONT

Group

CXTTreeBase Nested Types


CXTTreeCtrl Class

XTTreeCtrlView.h, Classes, Legend, Members, Topics, CXTTreeCtrl Constructors, CXTTreeCtrl Destructors, CXTTreeCtrl Constructors, CXTTreeCtrl Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTreeCtrl Class

CXTTreeCtrl is a CTreeCtrl derived class. It extends the CTreeCtrl class to add additional functionality, including tree traversal, searching, color, and settings.

Class Hierarchy

class CXTTreeCtrl : public CXTTreeCtrlBase;
File

XTTreeCtrlView.h

Group

Classes

Legend
Constructor
virtual
CXTTreeCtrl Constructors
CXTTreeCtrl Constructors | Description
CXTTreeCtrl | Constructs a CXTTreeCtrl object
CXTTreeCtrl Destructors
CXTTreeCtrl Destructors | Description
~CXTTreeCtrl | Destroys a CXTTreeCtrl object, handles cleanup and deallocation


CXTTreeCtrl Constructors

CXTTreeCtrl Class, Legend, Public Methods
CXTTreeCtrl Constructors
Class

CXTTreeCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTTreeCtrl | Constructs a CXTTreeCtrl object


CXTTreeCtrl::CXTTreeCtrl Constructor

CXTTreeCtrl Constructors, CXTTreeCtrl Class
CXTTreeCtrl::CXTTreeCtrl Constructor

Constructs a CXTTreeCtrl object

CXTTreeCtrl();
Group

CXTTreeCtrl Constructors


CXTTreeCtrl Destructors

CXTTreeCtrl Class, Legend, Public Methods
CXTTreeCtrl Destructors
Class

CXTTreeCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTTreeCtrl | Destroys a CXTTreeCtrl object, handles cleanup and deallocation


CXTTreeCtrl::~CXTTreeCtrl Destructor

CXTTreeCtrl Destructors, CXTTreeCtrl Class
CXTTreeCtrl::~CXTTreeCtrl Destructor

Destroys a CXTTreeCtrl object, handles cleanup and deallocation

virtual ~CXTTreeCtrl();
Group

CXTTreeCtrl Destructors


CXTTreeView Class

XTTreeCtrlView.h, Classes, Legend, Members, Topics, CXTTreeView Constructors, CXTTreeView Destructors, CXTTreeView Constructors, CXTTreeView Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTTreeView Class

CXTTreeView is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.

Class Hierarchy

class CXTTreeView : public CXTTreeViewBase;
File

XTTreeCtrlView.h

Group

Classes

Legend
Constructor
protected
virtual
CXTTreeView Constructors
CXTTreeView Constructors | Description
CXTTreeView | Protected constructor used by dynamic creation. Constructs a CXTTreeView object
CXTTreeView Destructors
CXTTreeView Destructors | Description
~CXTTreeView | Destroys a CXTTreeView object, handles cleanup and deallocation


CXTTreeView Constructors

CXTTreeView Class, Legend, Protected Methods
CXTTreeView Constructors
Class

CXTTreeView Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTTreeView | Protected constructor used by dynamic creation. Constructs a CXTTreeView object


CXTTreeView::CXTTreeView Constructor

CXTTreeView Constructors, CXTTreeView Class
CXTTreeView::CXTTreeView Constructor

Protected constructor used by dynamic creation. Constructs a CXTTreeView object

CXTTreeView();
Group

CXTTreeView Constructors


CXTTreeView Destructors

CXTTreeView Class, Legend, Protected Methods
CXTTreeView Destructors
Class

CXTTreeView Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTTreeView | Destroys a CXTTreeView object, handles cleanup and deallocation


CXTTreeView::~CXTTreeView Destructor

CXTTreeView Destructors, CXTTreeView Class
CXTTreeView::~CXTTreeView Destructor

Destroys a CXTTreeView object, handles cleanup and deallocation

virtual ~CXTTreeView();
Group

CXTTreeView Destructors


CXTWindowList Class

XTWindowList.h, Classes, Legend, Members, Topics, CXTWindowList Data Members, CXTWindowList Methods, CXTWindowList Constructors, CXTWindowList Constructors, CXTWindowList Data Members, CXTWindowList Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTWindowList Class

CXTWindowList dialog

Class Hierarchy

class CXTWindowList : public CXTResizeDialog;
File

XTWindowList.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTWindowList Constructors
CXTWindowList Constructors | Description
CXTWindowList | Constructs a CXTWindowList object.
CXTWindowList Data Members
CXTWindowList Data Members | Description
m_hIcon | Resize dialogs handle
m_hWndMDIClient | Handle to MDI client area.
m_lboxWindows | Flicker free list box to display MDI children.
m_pMDIFrameWnd | Pointer to applications MDI frame.
CXTWindowList Methods
CXTWindowList Methods | Description
FillMDIWindowList | Call this member function to populate the window list with currently open MDI children.
GetChildWndText | Call this member function to return the MDI child windows.
InsertMDIChild | Call this member function to add a MDI child to the window list.
RestoreAndMinimize | Call this member function to toggle restore / minimize state for selected MDI children.
SelectMDIActive | Call this member function to select the active MDI child window.
SetEnableButtons | Call this member function to enable / disable button controls for the window list dialog depending on selection.
SetWindowIcon | Call this member function to set the dialogs icon.


CXTWindowList Data Members

CXTWindowList Class, Legend, Protected Data Members
CXTWindowList Data Members
Class

CXTWindowList Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hIcon | Resize dialogs handle
m_hWndMDIClient | Handle to MDI client area.
m_lboxWindows | Flicker free list box to display MDI children.
m_pMDIFrameWnd | Pointer to applications MDI frame.


CXTWindowList::m_hIcon Data Member

CXTWindowList Data Members, CXTWindowList Class
CXTWindowList::m_hIcon Data Member

Resize dialogs handle

HICON m_hIcon;
Group

CXTWindowList Data Members


CXTWindowList::m_hWndMDIClient Data Member

CXTWindowList Data Members, CXTWindowList Class
CXTWindowList::m_hWndMDIClient Data Member

Handle to MDI client area.

HWND m_hWndMDIClient;
Group

CXTWindowList Data Members


CXTWindowList::m_lboxWindows Data Member

CXTWindowList Data Members, CXTWindowList Class
CXTWindowList::m_lboxWindows Data Member

Flicker free list box to display MDI children.

CXTListBox m_lboxWindows;
Group

CXTWindowList Data Members


CXTWindowList::m_pMDIFrameWnd Data Member

CXTWindowList Data Members, CXTWindowList Class
CXTWindowList::m_pMDIFrameWnd Data Member

Pointer to applications MDI frame.

CMDIFrameWnd* m_pMDIFrameWnd;
Group

CXTWindowList Data Members


CXTWindowList Methods

CXTWindowList Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTWindowList Methods
Class

CXTWindowList Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
FillMDIWindowList | Call this member function to populate the window list with currently open MDI children.
GetChildWndText | Call this member function to return the MDI child windows.
InsertMDIChild | Call this member function to add a MDI child to the window list.
RestoreAndMinimize | Call this member function to toggle restore / minimize state for selected MDI children.
SelectMDIActive | Call this member function to select the active MDI child window.
SetEnableButtons | Call this member function to enable / disable button controls for the window list dialog depending on selection.
Public Methods
Public Methods
Public Method | Description
SetWindowIcon | Call this member function to set the dialogs icon.


CXTWindowList::FillMDIWindowList Method

CXTWindowList Methods, CXTWindowList Class
CXTWindowList::FillMDIWindowList Method

Call this member function to populate the window list with currently open MDI children.

virtual void FillMDIWindowList();
Group

CXTWindowList Methods


CXTWindowList::GetChildWndText Method

CXTWindowList Methods, CXTWindowList Class
CXTWindowList::GetChildWndText Method

Call this member function to return the MDI child windows.

virtual CString GetChildWndText(
    HWND hWnd
) const;
Parameters

hWnd
Handle to a MDI child window.

Returns

A CString object representing the windows text.

Group

CXTWindowList Methods


CXTWindowList::InsertMDIChild Method

CXTWindowList Methods, CXTWindowList Class
CXTWindowList::InsertMDIChild Method

Call this member function to add a MDI child to the window list.

virtual void InsertMDIChild(
    HWND hwndMDIChildWnd
);
Parameters

hwndMDIChildWnd
Pointer to a MDI child window.

Group

CXTWindowList Methods


CXTWindowList::RestoreAndMinimize Method

CXTWindowList Methods, CXTWindowList Class
CXTWindowList::RestoreAndMinimize Method

Call this member function to toggle restore / minimize state for selected MDI children.

void RestoreAndMinimize();
Group

CXTWindowList Methods


CXTWindowList::SelectMDIActive Method

CXTWindowList Methods, CXTWindowList Class
CXTWindowList::SelectMDIActive Method

Call this member function to select the active MDI child window.

virtual void SelectMDIActive();
Group

CXTWindowList Methods


CXTWindowList::SetEnableButtons Method

CXTWindowList Methods, CXTWindowList Class
CXTWindowList::SetEnableButtons Method

Call this member function to enable / disable button controls for the window list dialog depending on selection.

virtual void SetEnableButtons();
Group

CXTWindowList Methods


CXTWindowList::SetWindowIcon Method

CXTWindowList Methods, CXTWindowList Class, Body Source
CXTWindowList::SetWindowIcon Method

Call this member function to set the dialogs icon.

void SetWindowIcon(
    HICON hIcon
);
Parameters

hIcon
Icon handle to set.

Body Source
void SetWindowIcon(HICON hIcon) {
    m_hIcon = hIcon;
}
Group

CXTWindowList Methods


CXTWindowList Constructors

CXTWindowList Class, Legend, Public Methods
CXTWindowList Constructors
Class

CXTWindowList Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTWindowList | Constructs a CXTWindowList object.


CXTWindowList::CXTWindowList Constructor

CXTWindowList Constructors, CXTWindowList Class
CXTWindowList::CXTWindowList Constructor

Constructs a CXTWindowList object.

CXTWindowList(
    CMDIFrameWnd* pMDIFrameWnd
);
Parameters

pMDIFrameWnd
Pointer to applications main window.

Group

CXTWindowList Constructors


CXTWindowPos Class

XTWindowPos.h, Classes, Legend, Members, Topics, CXTWindowPos Methods, CXTWindowPos Constructors, CXTWindowPos Constructors, CXTWindowPos Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTWindowPos Class

CXTWindowPos is a WINDOWPLACEMENT structure derived class. It extends the WINDOWPLACEMENT structure, and is used to save and restore window position.

Class Hierarchy

class CXTWindowPos : public WINDOWPLACEMENT;
File

XTWindowPos.h

Group

Classes

Legend
Method
CXTWindowPos Constructors
CXTWindowPos Constructors | Description
CXTWindowPos | Constructs a CXTWindowPos object
CXTWindowPos Methods
CXTWindowPos Methods | Description
LoadWindowPos |
SaveWindowPos | This member function will save the window specified by 'pWnd' by its current window position.


CXTWindowPos Methods

CXTWindowPos Class, Legend, Public Methods
CXTWindowPos Methods
Class

CXTWindowPos Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
LoadWindowPos |
SaveWindowPos | This member function will save the window specified by 'pWnd' by its current window position.


LoadWindowPos Method

CXTWindowPos Methods
LoadWindowPos Method
Overload List
Methods
Method | Description
CXTWindowPos::LoadWindowPos (CWnd*, LPCTSTR, LPCTSTR) | This member function will load the window specified by 'pWnd' to its previous window position.
CXTWindowPos::LoadWindowPos (LPCTSTR, LPCTSTR) | This member function will load the window specified by 'pWnd' to its previous window position.
Group

CXTWindowPos Methods


CXTWindowPos::LoadWindowPos Method (LPCTSTR, LPCTSTR)

LoadWindowPos Method, CXTWindowPos Class
CXTWindowPos::LoadWindowPos Method (LPCTSTR, LPCTSTR)

This member function will load the window specified by 'pWnd' to its previous window position.

BOOL LoadWindowPos(
    LPCTSTR lpszWndPos = NULL,
    LPCTSTR lpszSection = NULL
);
BOOL LoadWindowPos(
    CWnd* pWnd,
    LPCTSTR lpszWndPos = NULL,
    LPCTSTR lpszSection = NULL
);
Parameters

lpszWndPos
If NULL, the default entry name will be used. If using this for MDI children or other windows, pass in a unique string value here. This must match for both LoadWindowPos and SaveWindowPos.
lpszSection
A NULL terminated string representing the registry section where the window position is to be stored. If NULL the default value is used.
pWnd
Points to the CWnd* derived window to be restored to its previous state.

Returns

TRUE if successful, otherwise returns FALSE.

Group

LoadWindowPos Method


CXTWindowPos::SaveWindowPos Method

CXTWindowPos Methods, CXTWindowPos Class
CXTWindowPos::SaveWindowPos Method

This member function will save the window specified by 'pWnd' by its current window position.

BOOL SaveWindowPos(
    CWnd* pWnd,
    LPCTSTR lpszWndPos = NULL,
    LPCTSTR lpszSection = NULL
);
Parameters

pWnd
Points to the CWnd* derived windows position to be saved.
lpszWndPos
If NULL, the default entry name will be used. If using this for MDI children or other windows, pass in a unique string value here. This must match for both LoadWindowPos and SaveWindowPos.
lpszSection
A NULL terminated string representing the registry section where the window position is to be stored. If NULL the default value is used.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTWindowPos Methods


CXTWindowPos Constructors

CXTWindowPos Class, Legend, Public Methods
CXTWindowPos Constructors
Class

CXTWindowPos Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTWindowPos | Constructs a CXTWindowPos object


CXTWindowPos::CXTWindowPos Constructor

CXTWindowPos Constructors, CXTWindowPos Class
CXTWindowPos::CXTWindowPos Constructor

Constructs a CXTWindowPos object

CXTWindowPos();
Group

CXTWindowPos Constructors


Functions

Functions, Legend, Standard Controls
Functions
Functions
Function | Description
DDV_XTMinMaxDateTime | Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxDateTime | Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxMonth | Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxMonth | Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDX_XTColorPicker | The DDX_XTColorPicker function manages the transfer of integer data between a color picker control in a dialog box, form view, or control view object and a COLORREF data member of the dialog box, form view, or control view object. When DDX_XTColorPicker is called, 'value' is set to the current state of the color picker control.
DDX_XTDateTimeCtrl | The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object and a COleDateTime data member of the dialog box or form view object. When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.
DDX_XTDateTimeCtrl | The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object, and a CTime data member of the dialog box or form view object. When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.
DDX_XTMonthCalCtrl | The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl) in a dialog box, form view, or control view object, and a COleDateTime data member, of the dialog box, form view, or control view object. The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel. When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.
DDX_XTMonthCalCtrl | The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl), in a dialog box, form view, or control view object, and a CTime data member of the dialog box, form view, or control view object. The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel. When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.
DDX_XTOleDateTime | The DDX_XTOleDateTime function manages the transfer of integer data between a date edit control, in a dialog box, form view, or control view object, and a COleDateTime data member of the dialog box, form view, or control view object. When DDX_XTOleDateTime is called, 'value' is set to the current state of the date edit control.
XTAuxData | The XTAuxData function is used for access to the CXTAuxData class.
XTFuncChangeWindowFont | The XTFuncChangeWindowFont function will set the font for the window specified by pWnd and all of the child windows owned by pWnd.
XTFuncChildWindowFromPoint | The XTFuncChildWindowFromPoint function will retrieve an HWND handle for the child window (if any) located directly under the cursor position specified by point.
XTFuncContextMenu | Call this member function to display a context menu that is compatible with both pro and standard versions.
XTFuncCreateView | Creates a view based on a CRuntimeClass object.
XTFuncDrawEmbossed | The XTFuncDrawEmbossed function will draw an embossed icon onto the specified device context from the image list imageList. It is typically used by toolbars and menus to draw a disabled icon in color.
XTFuncDrawShadedRect | Renders a shadow onto the specified device context.
XTFuncInitDLL | This member function will initialize the resources for the Xtreme Toolkit. If using the Xtreme Toolkit as an extension DLL within a regular DLL, add the following two lines to your stdafx.h file. This will give you access to the exported function InitXtremeExtDll():
XTFuncPathExists | The XTFuncPathExists function searches a directory for a file or subdirectory whose name matches the specified name.
XTThemeManager | The XTThemeManager function is used for access to the CXTThemeManager class.
Module

Standard Controls

Legend
Method


DDV_XTMinMaxDateTime Function

XTDateTimeCtrl.h, Functions, See Also
DDV_XTMinMaxDateTime Function

Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.

void DDV_XTMinMaxDateTime(
    CDataExchange* pDX,
    COleDateTime& refValue,
    const COleDateTime* pMinRange,
    const COleDateTime* pMaxRange
);
File

XTDateTimeCtrl.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction. You do not need to delete this object.
refValue
A reference to a COleDateTime object associated with a member variable of the dialog box, form view, or control view object. This object contains the data to be validated.
pMinRange
Minimum date/time value allowed.
pMaxRange
Maximum date/time value allowed.

See Also

CXTDateTimeCtrl

Group

Functions


DDV_XTMinMaxDateTime Function

XTDateTimeCtrl.h, Functions, See Also
DDV_XTMinMaxDateTime Function

Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.

void DDV_XTMinMaxDateTime(
    CDataExchange* pDX,
    CTime& refValue,
    const CTime* pMinRange,
    const CTime* pMaxRange
);
File

XTDateTimeCtrl.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction. You do not need to delete this object.
refValue
A reference to a CTime object associated with a member variable of the dialog box, form view, or control view object. This object contains the data to be validated.
pMinRange
Minimum date/time value allowed.
pMaxRange
Maximum date/time value allowed.

See Also

CXTDateTimeCtrl

Group

Functions


DDV_XTMinMaxMonth Function

XTDateTimeCtrl.h, Functions, See Also
DDV_XTMinMaxMonth Function

Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.

void DDV_XTMinMaxMonth(
    CDataExchange* pDX,
    COleDateTime& refValue,
    const COleDateTime* pMinRange,
    const COleDateTime* pMaxRange
);
File

XTDateTimeCtrl.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction.
refValue
A reference to an object of type CTime associated with a member variable of the dialog box, form view, or control view object. This object contains the data to be validated. MFC passes this reference when DDV_XTMinMaxMonth is called.
pMinRange
Minimum date/time value allowed.
pMaxRange
Maximum date/time value allowed.

See Also

CXTMonthCalCtrl

Group

Functions


DDV_XTMinMaxMonth Function

XTDateTimeCtrl.h, Functions, See Also
DDV_XTMinMaxMonth Function

Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.

void DDV_XTMinMaxMonth(
    CDataExchange* pDX,
    CTime& refValue,
    const CTime* pMinRange,
    const CTime* pMaxRange
);
File

XTDateTimeCtrl.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction.
refValue
A reference to an object of type CTime associated with a member variable of the dialog box, form view, or control view object. This object contains the data to be validated. MFC passes this reference when DDV_XTMinMaxMonth is called.
pMinRange
Minimum date/time value allowed.
pMaxRange
Maximum date/time value allowed.

See Also

CXTMonthCalCtrl

Group

Functions


DDX_XTColorPicker Function

XTColorPicker.h, Functions, See Also
DDX_XTColorPicker Function

The DDX_XTColorPicker function manages the transfer of integer data between a color picker control in a dialog box, form view, or control view object and a COLORREF data member of the dialog box, form view, or control view object.

When DDX_XTColorPicker is called, 'value' is set to the current state of the color picker control.

void DDX_XTColorPicker(
    CDataExchange* pDX,
    int nIDC,
    COLORREF& value
);
File

XTColorPicker.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction.
nIDC
The resource ID of the color picker control associated with the control property.
value
A reference to a member variable of the dialog box, form view, or control view object with which data is exchanged.

See Also

CXTColorPicker

Group

Functions


DDX_XTDateTimeCtrl Function

XTDateTimeCtrl.h, Functions, See Also
DDX_XTDateTimeCtrl Function

The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object and a COleDateTime data member of the dialog box or form view object.

When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.

void DDX_XTDateTimeCtrl(
    CDataExchange* pDX,
    int nIDC,
    COleDateTime& value
);
File

XTDateTimeCtrl.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction. You do not need to delete this object.
nIDC
The resource ID of the date and time picker control associated with the member variable.
value
A reference to a COleDateTime member variable, dialog box, form view, or control view object with which data is exchanged.

See Also

CXTDateTimeCtrl

Group

Functions


DDX_XTDateTimeCtrl Function

XTDateTimeCtrl.h, Functions, See Also
DDX_XTDateTimeCtrl Function

The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object, and a CTime data member of the dialog box or form view object.

When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.

void DDX_XTDateTimeCtrl(
    CDataExchange* pDX,
    int nIDC,
    CTime& value
);
File

XTDateTimeCtrl.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction. You do not need to delete this object.
nIDC
The resource ID of the date and time picker control associated with the member variable.
value
A reference to a CTime member variable, dialog box, form view, or control view object with which data is exchanged.

See Also

CXTDateTimeCtrl

Group

Functions


DDX_XTMonthCalCtrl Function

XTDateTimeCtrl.h, Functions, See Also
DDX_XTMonthCalCtrl Function

The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl) in a dialog box, form view, or control view object, and a COleDateTime data member, of the dialog box, form view, or control view object.

The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel.

When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.

void DDX_XTMonthCalCtrl(
    CDataExchange* pDX,
    int nIDC,
    COleDateTime& value
);
File

XTDateTimeCtrl.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction. You do not need to delete this object.
nIDC
The resource ID of the month calendar control associated with the member variable.
value
A reference to a COleDateTime member variable of the dialog box, form view, or control view object with which data is exchanged.

See Also

CXTMonthCalCtrl

Group

Functions


DDX_XTMonthCalCtrl Function

XTDateTimeCtrl.h, Functions, See Also
DDX_XTMonthCalCtrl Function

The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl), in a dialog box, form view, or control view object, and a CTime data member of the dialog box, form view, or control view object.

The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel.

When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.

void DDX_XTMonthCalCtrl(
    CDataExchange* pDX,
    int nIDC,
    CTime& value
);
File

XTDateTimeCtrl.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction. You do not need to delete this object.
nIDC
The resource ID of the month calendar control associated with the member variable.
value
A reference to a CTime member variable of the dialog box, form view, or control view object with which data is exchanged.

See Also

CXTMonthCalCtrl

Group

Functions


DDX_XTOleDateTime Function

XTMaskEdit.h, Functions, See Also
DDX_XTOleDateTime Function

The DDX_XTOleDateTime function manages the transfer of integer data between a date edit control, in a dialog box, form view, or control view object, and a COleDateTime data member of the dialog box, form view, or control view object.

When DDX_XTOleDateTime is called, 'value' is set to the current state of the date edit control.

void DDX_XTOleDateTime(
    CDataExchange* pDX,
    int nIDC,
    CXTDateEdit& rControl,
    COleDateTime& rDateTime
);
File

XTMaskEdit.h

Parameters

pDX
A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction.
nIDC
The resource ID of the date edit control associated with the control property.
rControl
A reference to a member variable of the dialog box, form view, or control view object with which data is exchanged.
rDateTime
A reference to a member variable of the dialog box, form view, or control view object with which data is exchanged.

See Also

CXTDateEdit

Group

Functions


XTAuxData Function

XTGlobal.h, Functions, Example, See Also
XTAuxData Function

The XTAuxData function is used for access to the CXTAuxData class.

CXTAuxData& XTAuxData();
File

XTGlobal.h

Returns

A pointer to the one and only CXTAuxData instance.

Remarks

Call this function to access CXTAuxData members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTAuxData.

See Also

CXTAuxData

Example

The following example demonstrates the use of XTAuxData.

bool bIsWinNT = XTAuxData().bWinNT;
Group

Functions


XTFuncChangeWindowFont Function

XTFunctions.h, Functions
XTFuncChangeWindowFont Function

The XTFuncChangeWindowFont function will set the font for the window specified by pWnd and all of the child windows owned by pWnd.

void XTFuncChangeWindowFont(
    CWnd* pWnd,
    CFont* pFont
);
File

XTFunctions.h

Parameters

pWnd
Pointer to a valid CWnd object.
pFont
Pointer to the new font to set for the window.

Group

Functions


XTFuncChildWindowFromPoint Function

XTFunctions.h, Functions
XTFuncChildWindowFromPoint Function

The XTFuncChildWindowFromPoint function will retrieve an HWND handle for the child window (if any) located directly under the cursor position specified by point.

HWND XTFuncChildWindowFromPoint(
    HWND hWnd,
    POINT point
);
File

XTFunctions.h

Parameters

hWnd
HWND handle of the parent window to find the child for.
point
Current cursor position.

Returns

An HWND handle for the child window at point.

Group

Functions


XTFuncContextMenu Function

XTFunctions.h, Functions, Example, See Also
XTFuncContextMenu Function

Call this member function to display a context menu that is compatible with both pro and standard versions.

BOOL XTFuncContextMenu(
    CMenu* pPopup,
    UINT nFlags,
    int xPos,
    int yPos,
    CWnd* pWnd,
    int nIDBitmap,
    BOOL bNoNotify = TRUE
);
File

XTFunctions.h

Parameters

pPopup
Pointer to a valid CMenu object.
nFlags
Specifies a screen-position flag and a mouse-button flag. The screen-position flag can be one of the following:

TPM_CENTERALIGN Centers the pop-up menu horizontally relative to the coordinate specified by x.

TPM_LEFTALIGN Positions the pop-up menu so that its left side is aligned with the coordinate specified by x.

TPM_RIGHTALIGN Positions the pop-up menu so that its right side is aligned with the coordinate specified by x.

The mouse-button flag can be either of the following:

TPM_LEFTBUTTON Causes the pop-up menu to track the left mouse button.

TPM_RIGHTBUTTON Causes the pop-up menu to track the right mouse button.

xPos
Specifies the horizontal position in screen coordinates of the pop-up menu. Depending on the value of the nFlags parameter, the menu can be left-aligned, right-aligned, or centered relative to this position.
yPos
Specifies the vertical position in screen coordinates of the top of the menu on the screen.
pWnd
Identifies the window that owns the pop-up menu. This window receives all WM_COMMAND messages from the menu. In Windows versions 3.1 and later, the window does not receive WM_COMMAND messages until TrackPopupMenu returns. In Windows 3.0, the window receives WM_COMMAND messages before TrackPopupMenu returns.
nIDBitmap
Toolbar resource ID that contains images to be displayed with menu commands.

Remarks

A floating pop-up menu can appear anywhere on the screen.

See Also

CXTPCommandBars::TrackPopupMenu

Example

The following example demonstrates using XTFuncContextMenu.

CPoint pt = point;
ClientToScreen(&pt);

CMenu menu;
VERIFY(XTPResourceManager()->LoadMenu(&menu, XT_IDM_POPUP));

CMenu* pPopup = menu.GetSubMenu(0);
ASSERT(pPopup != NULL);
CWnd* pWndPopupOwner = this;

XTFuncContextMenu(pPopup, TPM_LEFTALIGN | TPM_RIGHTBUTTON,
    pt.x, pt.y, pWndPopupOwner, XT_IDR_TBAR_OUT);
Group

Functions


XTFuncCreateView Function

XTFunctions.h, Functions, Example
XTFuncCreateView Function

Creates a view based on a CRuntimeClass object.

CWnd* XTFuncCreateView(
    CWnd* pParentWnd,
    CRuntimeClass * pViewClass,
    CDocument * pDocument = NULL,
    CCreateContext* pContext = NULL,
    DWORD dwStyle = AFX_WS_DEFAULT_VIEW,
    CWnd* pOwnerWnd = NULL,
    UINT nID = AFX_IDW_PANE_FIRST
);
File

XTFunctions.h

Parameters

pParentWnd
Points to the parent of the view to be created. The parent must be valid.
pViewClass
Specifies the CRuntimeClass of the new view.
pDocument
CDocument associated with the view. It can be NULL.
pContext
Create context for the view. It can be NULL.
dwStyle
Default style for the view.
pOwnerWnd
Owner of the view. If NULL, 'pParentWnd' is used.
nID
Control ID of the view.

Returns

A CWnd* pointer to the newly created view if successful, otherwise returns NULL.

Remarks

The XTFuncCreateView function will create a view based on the CRuntimeClass pViewClass.

Example
CView* pView = (CView*)XTFuncCreateView(this, RUNTIME_CLASS(CMyView));
ASSERT_VALID(pView);
Group

Functions


XTFuncDrawEmbossed Function

XTFunctions.h, Functions
XTFuncDrawEmbossed Function

The XTFuncDrawEmbossed function will draw an embossed icon onto the specified device context from the image list imageList. It is typically used by toolbars and menus to draw a disabled icon in color.

void XTFuncDrawEmbossed(
    CDC* pDC,
    CImageList& imageList,
    int nIndex,
    CPoint point,
    BOOL bInColor
);
File

XTFunctions.h

Parameters

pDC
Pointer to the current device context.
imageList
Address of an image list.
nIndex
Index of the image in the image list.
point
XY location of where to draw the icon.
bInColor
TRUE to draw the item in color, otherwise the icon will be drawn with the default disabled look.

Group

Functions


XTFuncDrawShadedRect Function

XTFunctions.h, Functions
XTFuncDrawShadedRect Function

Renders a shadow onto the specified device context.

void XTFuncDrawShadedRect(
    CDC* pDC,
    CRect& rect
);
File

XTFunctions.h

Parameters

pDC
Points to the current device context.
rect
Size of the area to draw.

Remarks

The XTFuncDrawShadedRect function will render a shaded or 'shadow' rectangle onto the the device context specified by pDC.

Group

Functions


XTFuncInitDLL Function

XTFunctions.h, Functions, Example
XTFuncInitDLL Function

This member function will initialize the resources for the Xtreme Toolkit. If using the Xtreme Toolkit as an extension DLL within a regular DLL, add the following two lines to your stdafx.h file. This will give you access to the exported function InitXtremeExtDll():

void XTFuncInitDLL();
File

XTFunctions.h

Example

The following code sample demonstrates the usage of XTFuncInitDLL.

#define XT_INIT_BY_REGULAR_DLL
#include "XTToolkit.h"

You will then need to add XT_INIT_BY_REGULAR_DLL to the Xtreme Toolkit preprocessor definitions and rebuild it. After you have done this, locate your CWinApp::InitInstance() method for your regular DLL and make the following call:

XTFuncInitDLL();

This will initialize the resources for the Xtreme Toolkit.

Group

Functions


XTFuncPathExists Function

XTFunctions.h, Functions
XTFuncPathExists Function

The XTFuncPathExists function searches a directory for a file or subdirectory whose name matches the specified name.

BOOL XTFuncPathExists(
    LPCTSTR lpszFileName
);
File

XTFunctions.h

Parameters

lpszFileName
[in] Pointer to a null-terminated string that specifies a valid directory or path and file name, which can contain wild card characters (* and ?). If the string ends with a wild card, a period, or a directory name, the user must have access to the root and all subdirectories on the path.

Returns

TRUE if the file or subdirectory exists, otherwise FALSE.

Group

Functions


XTThemeManager Function

XTThemeManager.h, Functions, Example, See Also
XTThemeManager Function

The XTThemeManager function is used for access to the CXTThemeManager class.

CXTThemeManager* XTThemeManager();
File

XTThemeManager.h

Returns

A pointer to the one and only CXTThemeManager instance.

Remarks

Call this function to access CXTThemeManager members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTThemeManager.

See Also

CXTThemeManager

Example

The following example demonstrates how to use XTThemeManager.

XTThemeManager()->SetTheme(xtThemeOfficeXP);
Group

Functions


Structs, Records, Enums

Enumerations, Legend, Standard Controls, Structures
Structs, Records, Enums
Enumerations
Enumeration | Description
XTAnimationType | Enumeration used to determine animation style.
XTArrowIcon | Enumeration used to determine arrow button display.
XTFindType | Enumeration used to determine folder or drive type.
XTFontStyle | Enumeration used to determine font display.
XTMouseState | Enumeration to determine mouse state.
XTNavBtnState | Enumeration used to determine navigation button display for a CXTTabCtrl object.
XTPPopupAnimation | Enumeration used to determine the popup window animation in use
XTPPopupItemIcon | Enumeration used to determine the icon type of CXTPPopupItem.
XTPPopupPaintTheme | Enumeration used to determine the popup window theme in use
XTPPopupState | Enumeration used to determine a current popup window state
XTPPropertyPageBorder | XTPPropertyPageBorder is an enumeration used to set the client frame style drawn around the client of tabs.
XTResize | Enumeration used to determine attributes for resizing windows.
XTSortType | Enumeration used to determine sort type.
XTThemeStyle | Enumeration used to determine active theme.
Module

Standard Controls

Legend
Structure
Enumeration
Structures
Structure | Description
XT_LVITEMDATA | XT_LVITEMDATA structure is used to maintain information for a particular list item in a CXTShellListCtrl or CXTShellListView window.
XT_OUTBAR_INFO | XT_OUTBAR_INFO structure is used by by the CXTOutBarCtrl class to store and information for an Outlook bar folder or item.
XT_RESIZEPOINT | XT_RESIZEPOINT structure is used by the CXTResizePoint class for defining single -precision floating point x- and y-coordinates of a point.
XT_RESIZERECT | XT_RESIZERECT structure is used by the CXTResizeRect class for defining single -precision floating point coordinates of the upper-left and lower-right corners of a rectangle.
XT_SIZING |
XT_TVITEMDATA | XT_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTShellTreeCtrl or CXTShellTreeView window.
XTP_PICK_BUTTON | XTP_PICK_BUTTON structure is used by the CXTColorSelectorCtrl class to support custom colors.


XT_LVITEMDATA Structure

XTShellPidl.h, Structs, Records, Enums, See Also
XT_LVITEMDATA Structure

XT_LVITEMDATA structure is used to maintain information for a particular list item in a CXTShellListCtrl or CXTShellListView window.

struct XT_LVITEMDATA {
  ULONG ulAttribs;
  LPITEMIDLIST lpi;
  LPSHELLFOLDER lpsfParent;
};
File

XTShellPidl.h

Members

ulAttribs
Shell item attributes.
lpi
Pointer to an item ID list.
lpsfParent
Points to the parent shell folder item.

See Also

CXTShellListCtrl, CXTShellListView

Group

Structs, Records, Enums


XT_OUTBAR_INFO Structure

XTOutBarCtrl.h, Structs, Records, Enums, See Also
XT_OUTBAR_INFO Structure

XT_OUTBAR_INFO structure is used by by the CXTOutBarCtrl class to store and information for an Outlook bar folder or item.

struct XT_OUTBAR_INFO {
  int nIndex;
  int nDragTo;
  int nDragFrom;
  bool bFolder;
  LPCTSTR lpszText;
  HWND hWnd;
};
File

XTOutBarCtrl.h

Members

nIndex
Index of the item.
nDragTo
Ending drag index.
nDragFrom
Starting drag index.
bFolder
true if the item is a folder
lpszText
Item text.
hWnd
CXTOutBarCtrl window handle

See Also

CXTOutBarCtrl, CXTOutBarCtrl::OnLabelChanged

Group

Structs, Records, Enums


XT_RESIZEPOINT Structure

XTResizePoint.h, Structs, Records, Enums, See Also
XT_RESIZEPOINT Structure

XT_RESIZEPOINT structure is used by the CXTResizePoint class for defining single -precision floating point x- and y-coordinates of a point.

struct XT_RESIZEPOINT {
  XT_RESIZE x;
  XT_RESIZE y;
};
File

XTResizePoint.h

Members

x
Specifies the x-coordinate of a point
y
Specifies the y-coordinate of a point

See Also

CXTResizePoint

Group

Structs, Records, Enums


XT_RESIZERECT Structure

XTResizeRect.h, Structs, Records, Enums, Example, See Also
XT_RESIZERECT Structure

XT_RESIZERECT structure is used by the CXTResizeRect class for defining single -precision floating point coordinates of the upper-left and lower-right corners of a rectangle.

struct XT_RESIZERECT {
  XT_RESIZE left;
  XT_RESIZE top;
  XT_RESIZE right;
  XT_RESIZE bottom;
};
File

XTResizeRect.h

Members

left
Specifies the x-coordinate of the upper-left corner of a rectangle.
top
Specifies the y-coordinate of the upper-left corner of a rectangle.
right
Specifies the x-coordinate of the lower-right corner of a rectangle.
bottom
Specifies the y-coordinate of the lower-right corner of a rectangle.

See Also

CXTResizeRect, XT_RESIZE

Example

The following example demonstrates alternate ways to initialize a XT_RESIZERECT structure:

XT_RESIZERECT rc1;
rc1.left = 20;
rc1.top = 30;
rc1.right = 180;
rc1.bottom = 230;

XT_RESIZERECT rc2 = {20, 30, 180, 230};
Group

Structs, Records, Enums


XT_SIZING Structure

XTResize.h, Structs, Records, Enums, See Also
XT_SIZING Structure
struct XT_SIZING {
  UINT id;
  XT_RESIZERECT rrc;
};
File

XTResize.h

Members

id
Control identifier of the window sized.
rrc
Size of the window sized.

Remarks

XT_SIZING structure is used by the CXTResize class to maintain information for a particular window that is being sized.

See Also

CXTResize

Group

Structs, Records, Enums


XT_TVITEMDATA Structure

XTShellPidl.h, Structs, Records, Enums, See Also
XT_TVITEMDATA Structure

XT_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTShellTreeCtrl or CXTShellTreeView window.

struct XT_TVITEMDATA {
  LPITEMIDLIST lpi;
  LPITEMIDLIST lpifq;
  LPSHELLFOLDER lpsfParent;
};
File

XTShellPidl.h

Members

lpi
Pointer to an item ID list.
lpifq
Pointer to an item ID list.
lpsfParent
Pointer to the parent shell folder item.

See Also

CXTShellTreeCtrl, CXTShellTreeView

Group

Structs, Records, Enums


XTAnimationType Enumeration

XTAnimationMemDC.h, Structs, Records, Enums, See Also
XTAnimationType Enumeration

Enumeration used to determine animation style.

enum XTAnimationType {
  xtWindowsDefault,
  xtRandom,
  xtUnfold,
  xtSlide,
  xtFade,
  xtNone
};
File

XTAnimationMemDC.h

Members

xtWindowsDefault
Uses Windows default animation settings.
xtRandom
Animates a window with a random animation type.
xtUnfold
Animates a window to unfold top to bottom.
xtSlide
Animates a window to slide in from left.
xtFade
Animates a window with a fade-in effect.
xtNone
No animation.

Remarks

XTAnimationType type defines constants used by the CXTAnimationMemDC class to determine the animation effect for the current device context.

See Also

CXTAnimationMemDC, CXTAnimationMemDC::Animate, CXTAnimationMemDC::SetCustomAnimation

Group

Structs, Records, Enums


XTArrowIcon Enumeration

XTExcelTabCtrl.h, Structs, Records, Enums, See Also
XTArrowIcon Enumeration

Enumeration used to determine arrow button display.

enum XTArrowIcon {
  xtArrowIconLeft = 0x0200,
  xtArrowIconLeftHome = 0x0201,
  xtArrowIconRight = 0x0000,
  xtArrowIconRightHome = 0x0001
};
File

XTExcelTabCtrl.h

Members

xtArrowIconLeft
Left arrow display.
xtArrowIconLeftHome
Left home arrow display.
xtArrowIconRight
Right arrow display.
xtArrowIconRightHome
Right home arrow display.

Remarks

XTArrowIcon type defines constants used by the CXTExcelTabCtrlButtonState to determine which arrow is to be displayed for a particular tab button.

See Also

CXTExcelTabCtrlButtonState, CXTExcelTabCtrl

Group

Structs, Records, Enums


XTFindType Enumeration

XTShellTreeBase.h, Structs, Records, Enums, See Also
XTFindType Enumeration

Enumeration used to determine folder or drive type.

enum XTFindType {
  xtFindTypeDrive,
  xtFindTypeFolder,
  xtFindTypeRoot,
  xtFindTypeShare
};
File

XTShellTreeBase.h

Members

xtFindTypeDrive
The object type is a drive.
xtFindTypeFolder
The object type is a folder.
xtFindTypeRoot
The object type is a root folder
xtFindTypeShare
The object is a UNC share

Remarks

XTFindType type defines the constants used by the CXTShellTreeBase class to determine the type of object enumerated either folder or drive.

See Also

CXTFontListBox, CXTFontListBox::SetListStyle

Group

Structs, Records, Enums


XTFontStyle Enumeration

XTFontCombo.h, Structs, Records, Enums, See Also
XTFontStyle Enumeration

Enumeration used to determine font display.

enum XTFontStyle {
  xtFontUnknown = 0x00,
  xtFontGUI = 0x01,
  xtFontSample = 0x02,
  xtFontBoth = 0x03
};
File

XTFontCombo.h

Members

xtFontUnknown
Display type not defined.
xtFontGUI
Display font name with GUI font style.
xtFontSample
Display font name with its own font style.
xtFontBoth
Display font name with GUI font style, then a sample display to the right.

Remarks

XTFontStyle type defines the constants used by the CXTFontListBox class to determine how the fonts will be displayed in the CXTFontListBox control.

See Also

CXTFontListBox, CXTFontListBox::SetListStyle

Group

Structs, Records, Enums


XTMouseState Enumeration

XTDefines.h, Structs, Records, Enums, See Also
XTMouseState Enumeration

Enumeration to determine mouse state.

enum XTMouseState {
  xtMouseNormal = 1,
  xtMouseHover = 2,
  xtMouseSelect = 3
};
File

XTDefines.h

Members

xtMouseNormal
The mouse cursor is not hovering.
xtMouseHover
The mouse cursor is hovering the control.
xtMouseSelect
The mouse cursor is hovering the control and the left button is pressed.

Remarks

XTMouseState type defines the constants used to determine the state and position the mouse cursor is with relation to a control's window. This is used to determine how the control should be rendered.

See Also

CXTFlatEdit::DrawEdit, CXTFlatComboBox::DrawCombo, CXTOutBarCtrl::DrawFolder

Group

Structs, Records, Enums


XTNavBtnState Enumeration

XTTabBase.h, Structs, Records, Enums, See Also
XTNavBtnState Enumeration

Enumeration used to determine navigation button display for a CXTTabCtrl object.

enum XTNavBtnState {
  xtNavBtnArrows = 1,
  xtNavBtnClose = 2,
  xtNavBtnShowAll = 3
};
File

XTTabBase.h

Members

xtNavBtnArrows
Display arrow buttons.
xtNavBtnClose
Display close button.
xtNavBtnShowAll
Display arrow and close buttons.

Remarks

XTNavBtnState type defines the constants used by the CXTTabCtrl class to determine which navigation buttons to display.

See Also

CXTTabCtrl

Group

Structs, Records, Enums


XTP_PICK_BUTTON Structure

XTColorSelectorCtrl.h, Structs, Records, Enums, See Also
XTP_PICK_BUTTON Structure

XTP_PICK_BUTTON structure is used by the CXTColorSelectorCtrl class to support custom colors.

struct XTP_PICK_BUTTON {
};
File

XTColorSelectorCtrl.h

See Also

CXTColorSelectorCtrl

Group

Structs, Records, Enums


XTPPopupAnimation Enumeration

XTPPopupControl.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPopupAnimation Enumeration

Enumeration used to determine the popup window animation in use

enum XTPPopupAnimation {
  xtpPopupAnimationNone,
  xtpPopupAnimationFade,
  xtpPopupAnimationSlide,
  xtpPopupAnimationUnfold
};
File

XTPPopupControl.h

Members

xtpPopupAnimationNone
Animation is not used
xtpPopupAnimationFade
Fade method animation
xtpPopupAnimationSlide
Slide method animation
xtpPopupAnimationUnfold
Unfold method animation

See Also

CXTPPopupControl::SetPopupAnimation, CXTPPopupControl::GetPopupAnimation

Example
m_wndPopupControl.SetPopupAnimation(xtpPopupAnimationFade);
Group

Structs, Records, Enums


XTPPopupItemIcon Enumeration

XTPPopupItem.h, Structs, Records, Enums, Example, See Also
XTPPopupItemIcon Enumeration

Enumeration used to determine the icon type of CXTPPopupItem.

enum XTPPopupItemIcon {
  xtpPopupItemIconNormal = 1,
  xtpPopupItemIconSelected = 2,
  xtpPopupItemIconPressed = 4
};
File

XTPPopupItem.h

Members

xtpPopupItemIconNormal
normal icon handler
xtpPopupItemIconSelected
selected icon handler
xtpPopupItemIconPressed
pressed icon handler

See Also

CXTPPopupItem::SetIcon, CXTPPopupItem::SetIcons

Example
CXTPPopupItem* pItemIcon = m_wndPopupControl.AddItem(
    new CXTPPopupItem(CRect(14, 40, 20, 49)));
pItemIcon->SetIcons(IDB_LOGOOFFICE, 0, xtpPopupItemIconNormal);
Group

Structs, Records, Enums


XTPPopupPaintTheme Enumeration

XTPPopupControl.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPopupPaintTheme Enumeration

Enumeration used to determine the popup window theme in use

enum XTPPopupPaintTheme {
  xtpPopupThemeOffice2000,
  xtpPopupThemeOfficeXP,
  xtpPopupThemeOffice2003,
  xtpPopupThemeMSN,
  xtpPopupThemeOffice2007,
  xtpPopupThemeCustom
};
File

XTPPopupControl.h

Members

xtpPopupThemeOffice2000
The theme like to a Office2000
xtpPopupThemeOfficeXP
The theme like to a OfficeXP
xtpPopupThemeOffice2003
The theme like to a Office2003
xtpPopupThemeMSN
The theme like to a MSN Messenger
xtpPopupThemeOffice2007
The theme like to a Office2007
xtpPopupThemeCustom
The custom theme

See Also

CXTPPopupControl::SetTheme, CXTPPopupControl::GetTheme

Example
m_wndPopupControl.SetTheme(xtpPopupThemeOffice2000);
Group

Structs, Records, Enums


XTPPopupState Enumeration

XTPPopupControl.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPopupState Enumeration

Enumeration used to determine a current popup window state

enum XTPPopupState {
  xtpPopupStateClosed,
  xtpPopupStateExpanding,
  xtpPopupStateShow,
  xtpPopupStateCollapsing
};
File

XTPPopupControl.h

Members

xtpPopupStateClosed
The popup window is closed
xtpPopupStateExpanding
The popup window is expanding
xtpPopupStateShow
The popup window is shown
xtpPopupStateCollapsing
The popup window is collapsing

See Also

CXTPPopupControl::GetPopupState, CXTPPopupControl::SetPopupState

Example
if (pControl->GetPopupState() == xtpPopupStateClosed)
{
    EnableItems(TRUE);
}
Group

Structs, Records, Enums


XTPPropertyPageBorder Enumeration

XTPPropertySheet.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPPropertyPageBorder Enumeration

XTPPropertyPageBorder is an enumeration used to set the client frame style drawn around the client of tabs.

enum XTPPropertyPageBorder {
};
File

XTPPropertySheet.h

See Also

CXTPPropertySheet

Example
wndSheet.SetPageBorderStyle(xtpPageBorderFrame);
Group

Structs, Records, Enums


XTResize Enumeration

XTResize.h, Structs, Records, Enums, See Also
XTResize Enumeration

Enumeration used to determine attributes for resizing windows.

enum XTResize {
  xtResizeNoSizeIcon = 0x01,
  xtResizeNoHorizontal = 0x02,
  xtResizeNoVertical = 0x04,
  xtResizeNoMinsize = 0x08,
  xtResizeNoClipChildren = 0x10,
  xtResizeNoTransparentGroup = 0x20
};
File

XTResize.h

Members

xtResizeNoSizeIcon
Do not add size icon.
xtResizeNoHorizontal
No horizontal resizing.
xtResizeNoVertical
No vertical resizing.
xtResizeNoMinsize
Do not require a minimum size.
xtResizeNoClipChildren
Do not set clip children style.
xtResizeNoTransparentGroup
Do not set transparent style for group boxes.

Remarks

XTResize type defines the constants used by the CXTResize class to determine how a window will appear when it is resized.

See Also

CXTResize

Group

Structs, Records, Enums


XTSortType Enumeration

XTSortClass.h, Structs, Records, Enums, See Also
XTSortType Enumeration

Enumeration used to determine sort type.

enum XTSortType {
  xtSortInt = 1,
  xtSortString,
  xtSortDateTime,
  xtSortDecimal
};
File

XTSortClass.h

Members

xtSortInt
Sort type integer.
xtSortString
Sort type string.
xtSortDateTime
Sort type date / time.
xtSortDecimal
Sort type decimal.

Remarks

XTSortType type defines the constants used by the CXTSortClass to determine for what type of sorting to perform.

See Also

CXTSortClass::Sort

Group

Structs, Records, Enums


XTThemeStyle Enumeration

XTThemeManager.h, Structs, Records, Enums, See Also
XTThemeStyle Enumeration

Enumeration used to determine active theme.

enum XTThemeStyle {
  xtThemeDefault,
  xtThemeOfficeXP,
  xtThemeOffice2003,
  xtThemeCustom
};
File

XTThemeManager.h

Members

xtThemeDefault
Windows classic theme.
xtThemeOfficeXP
Microsoft(r) Office XP theme.
xtThemeOffice2003
Microsoft(r) Office 2003 theme.
xtThemeCustom
User defined theme.

Remarks

XTThemeStyle type defines the constants used by the CXTThemeManger to determine the currently selected theme.

See Also

CXTThemeManagerStyleFactory::CreateTheme

Group

Structs, Records, Enums


Types

Standard Controls, Types
Types
Module

Standard Controls

Types
Type | Description
CXTFontList | List used for enumerating CXTLogFont structures.
XT_RESIZE | The XT_RESIZE data type is defined as a float and is used for storing single-precision floating point x and y window coordinates.


CXTFontList Type

XTFontCombo.h, Types, See Also
CXTFontList Type

List used for enumerating CXTLogFont structures.

typedef CList<CXTLogFont, CXTLogFont&> CXTFontList;
File

XTFontCombo.h

Remarks

CList definition used by the CXTFontEnum class to maintain a list of CXTLogFont objects representing each font displayed for a CXTFontListBox control.

See Also

CXTFontEnum::GetFontList

Group

Types


XT_RESIZE Type

XTResizeRect.h, Types, See Also
XT_RESIZE Type

The XT_RESIZE data type is defined as a float and is used for storing single-precision floating point x and y window coordinates.

typedef float XT_RESIZE;
File

XTResizeRect.h

See Also

CXTResizeRect, XT_RESIZERECT, CXTResizePoint, XT_RESIZEPOINT

Group

Types


Variables

Standard Controls, Variables
Variables
Module

Standard Controls

Variables
Variable | Description
BEN_XT_LABELEDITCANCEL | BEN_XT_LABELEDITCANCEL notification message handler.
BEN_XT_LABELEDITEND | BEN_XT_LABELEDITEND notification message handler.
BES_XT_BROWSE | Display a user defined dialog for browsing
BES_XT_CHOOSEDIR | This member function is called to initialize the browse edit control.
BES_XT_CHOOSEFILE | This member function is called to initialize the browse edit control.
BES_XT_POPUPMENU | This member function is called to initialize the browse edit control.
BS_XT_FLAT | This member function will set the display style for the button.
BS_XT_FLAT_ANY | This member function will set the display style for the button.
BS_XT_HILITEPRESSED | This member function will set the display style for the button.
BS_XT_SEMIFLAT | This member function will set the display style for the button.
BS_XT_SHOWFOCUS | This member function will set the display style for the button.
BS_XT_TWOROWS | This member function will set the display style for the button.
BS_XT_WINXP_COMPAT | This member function will set the display style for the button.
BS_XT_XPFLAT | This member function will set the display style for the button.
CBRN_XT_DROPDOWN | The CBRN_XT_DROPDOWN message is sent to the CXTToolBar window whenever a dropdown event occurs in the CXTToolBar.
CPN_XT_CLOSEUP | CPN_XT_CLOSEUP notification message handler.
CPN_XT_DROPDOWN | CPN_XT_DROPDOWN notification message handler.
CPN_XT_SELCHANGE | CPN_XT_SELCHANGE notification message handler.
CPN_XT_SELENDCANCEL | CPN_XT_SELENDCANCEL notification message handler.
CPN_XT_SELENDOK | CPN_XT_SELENDOK notification message handler.
CPN_XT_SELNOFILL | CPN_XT_SELNOFILL notification message handler.
CPS_XT_EXTENDED | This member function handles the creation of the color popup window.
CPS_XT_MORECOLORS | This member function handles the creation of the color popup window.
CPS_XT_NOAUTOMATIC | This member function handles the creation of the color popup window.
CPS_XT_NOFILL | This member function handles the creation of the color popup window.
CPS_XT_RIGHTALIGN | This member function handles the creation of the color popup window.
CPS_XT_SHOW3DSELECTION | Constructs a CXTColorDialog object
CPS_XT_SHOWHEXVALUE | Constructs a CXTColorDialog object
CPS_XT_USERCOLORS | This member function handles the creation of the color popup window.
CPWN_XT_PUSHPINBUTTON | The CPWN_XT_PUSHPINBUTTON message is sent to the owner of a CXTCaptionPopupWnd whenever the push pin button selection has been made.
CPWN_XT_PUSHPINCANCEL | The CPWN_XT_PUSHPINCANCEL message is sent to the owner of a CXTCaptionPopupWnd whenever the push pin button selection has been canceled.
CPWS_EX_CLOSEBUTTON | Creates and initializes the child window associated with the CXTCaption object.
CPWS_EX_GROOVE_EDGE | Creates and initializes the child window associated with the CXTCaption object.
CPWS_EX_RAISED_EDGE | Creates and initializes the child window associated with the CXTCaption object.
FTS_XT_BOTTOM | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_DEFAULT | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HASARROWS | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HASHOMEEND | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HSCROLL | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_MASK | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_TOOLTIPS | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
LBN_XT_DELETEITEM | LBN_XT_DELETEITEM notification message handler.
LBN_XT_LABELEDITCANCEL | LBN_XT_LABELEDITCANCEL notification message handler.
LBN_XT_LABELEDITEND | LBN_XT_LABELEDITEND notification message handler.
LBN_XT_MOVEITEMDOWN | LBN_XT_MOVEITEMDOWN notification message handler.
LBN_XT_MOVEITEMUP | LBN_XT_MOVEITEMUP notification message handler.
LBN_XT_NEWITEM | LBN_XT_NEWITEM notification message handler.
LBN_XT_PREDELETEITEM | LBN_XT_PREDELETEITEM notification message handler.
LBN_XT_PRENEWITEM | LBN_XT_PRENEWITEM notification message handler.
LBS_XT_BROWSE | Browse button
LBS_XT_BROWSE_ONLY | Browse button
LBS_XT_CHOOSEDIR | Sets the edit style for the edit list box.
LBS_XT_CHOOSEFILE | Sets the edit style for the edit list box.
LBS_XT_DEFAULT | Sets the edit style for the edit list box.
LBS_XT_HIDE_UP_DOWN | Hide Up/Down buttons
LBS_XT_NOTOOLBAR | Sets the edit style for the edit list box.
LBS_XT_ONLY_UP_DOWN | Only Up/Down buttons
OBN_XT_BEGINDRAG | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DELETEFOLDER | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DELETEITEM | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DRAGITEM | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_FOLDERCHANGE | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMCLICK | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMHOVER | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMRCLICK | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ONGROUPENDEDIT | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ONLABELENDEDIT | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBS_XT_ADDGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_ANIMATION | Call this member function to modify an Outlook bar style.
OBS_XT_DEFAULT | Call this member function to modify an Outlook bar style.
OBS_XT_DRAGITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_EDITGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_EDITITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_LARGEICON | Call this member function to modify an Outlook bar style.
OBS_XT_REMOVEGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_REMOVEITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_SELHIGHLIGHT | Call this member function to modify an Outlook bar style.
OBS_XT_SMALLICON | Call this member function to modify an Outlook bar style.
SHN_XT_CONTENTSCHANGED | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_INETFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_NOFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_REFRESHFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_REFRESHTREE | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_SELECTCHILD | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_SHELLMENU | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_TREESELCHANGE | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SON_XT_ITEMCONTRACT | SON_XT_ITEMCONTRACT notification message handler.
SON_XT_ITEMCONTRACTING | SON_XT_ITEMCONTRACTING notification message handler.
SON_XT_ITEMEXPAND | SON_XT_ITEMEXPAND notification message handler.
SON_XT_ITEMEXPANDING | SON_XT_ITEMEXPANDING notification message handler.
TIN_XT_TRAYICON | The TIN_XT_TRAYICON message is sent to the CXTTrayIcon window's owner whenever a mouse event occurs in the CXTTrayIcon.
TVIS_FOCUSED | This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. It sets the state of the item specified by hItem.
TWS_XT_ALPHASHADOW | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
TWS_XT_DROPSHADOW | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
TWS_XT_THICKBORDER | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
XT_SPLIT_DOTTRACKER | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOBORDER | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOFULLDRAG | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOSIZE | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XTP_PCN_ITEMCLICK | XTP_PCN_ITEMCLICK is used to indicate that the user clicked on a popup control item.
XTP_PCN_STATECHANGED | XTP_PCN_STATECHANGED is used to indicate that the state of popup control changed
XTPWM_POPUPCONTROL_NOTIFY | The XTPWM_POPUPCONTROL_NOTIFY message is sent to the CXTPPopupControl owner window whenever an action occurs within the CXTPPopupControl
XTTHEME_HOTTRACKING | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
XTTHEME_SORTARROW | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
XTTHEME_WINXPTHEMES | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
XTWM_ADDREBAR | The XTWM_ADDREBAR message is sent to a window whenever it is added to a CXTReBar control.
XTWM_OUTBAR_NOTIFY | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
XTWM_QUERYHOTSPOT | CXTDockContext sends the XTWM_QUERYHOTSPOT message to a control bar to check if the control bar has a hot spot, a point that must match the position of the cursor.
XTWM_QUERYVISUALIZE | CXTDockContext sends the XTWM_QUERYVISUALIZE message to a control bar to check if the control bar shall be visualized while dragging or just a wire frame shall be rendered.
XTWM_REBAR_SIZECHILD | The XTWM_REBAR_SIZECHILD message is sent when CXTReBar control has resized the band in which the recipient resides.
XTWM_SHELL_NOTIFY | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
XTWM_UPDATECOLOR | The XTWM_UPDATECOLOR message is used to send notification that the color selection has changed.


BEN_XT_LABELEDITCANCEL Variable

XTNotify.h, Variables, Example, See Also
BEN_XT_LABELEDITCANCEL Variable

BEN_XT_LABELEDITCANCEL notification message handler.

const UINT BEN_XT_LABELEDITCANCEL = (WM_XTP_CONTROLS_BASE + 8);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The BEN_XT_LABELEDITCANCEL notification message is sent when the user performs a browse operation, but then selects another control or closes the dialog box. It indicates the user's initial operation was ignored. The owner window of the browse edit receives this notification through the WM_COMMAND message.

See Also

CXTBrowseEdit, BEN_XT_LABELEDITEND

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CBrowseDialog, CDialog
    //{{AFX_MSG_MAP(CBrowseDialog)
    ON_BEN_XT_LABELEDITCANCEL(IDC_CTRL_ID, OnLabelEditCancel)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CBrowseDialog::OnLabelEditCancel()
{
    // TODO: Handle command.
}
Group

Variables


BEN_XT_LABELEDITEND Variable

XTNotify.h, Variables, Example, See Also
BEN_XT_LABELEDITEND Variable

BEN_XT_LABELEDITEND notification message handler.

const UINT BEN_XT_LABELEDITEND = (WM_XTP_CONTROLS_BASE + 7);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The BEN_XT_LABELEDITEND notification message is sent when the user performs a browse operation successfully. It indicates the user's selection is to be processed. The owner window of the browse edit receives this notification through the WM_COMMAND message.

See Also

CXTBrowseEdit, BEN_XT_LABELEDITCANCEL

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CBrowseDialog, CDialog
    //{{AFX_MSG_MAP(CBrowseDialog)
    ON_BEN_XT_LABELEDITEND(IDC_CTRL_ID, OnLabelEditEnd)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CBrowseDialog::OnLabelEditEnd()
{
    // TODO: Handle command.
}
Group

Variables


BES_XT_BROWSE Variable

XTBrowseEdit.h, Variables
BES_XT_BROWSE Variable

Display a user defined dialog for browsing

const DWORD BES_XT_BROWSE = 0x0010;
File

XTBrowseEdit.h

Group

Variables


CBRN_XT_DROPDOWN Variable

XTDefines.h, Variables, Example
CBRN_XT_DROPDOWN Variable

The CBRN_XT_DROPDOWN message is sent to the CXTToolBar window whenever a dropdown event occurs in the CXTToolBar.

CBRN_XT_DROPDOWN
pNMTB = (NMTOOLBAR*)wParam;  // pointer to a NMTOOLBAR struct
pRect = (CRect*)lParam;      // pointer to a CRect object
const UINT CBRN_XT_DROPDOWN = (WM_XTP_CONTROLS_BASE + 31);
File

XTDefines.h

Parameters

pNMTB
Value of wParam specifies a NMTOOLBAR structure that represents the toolbar Button where the dropdown event occurred.

pRect
Value of lParam points to a CRect object that represents the size and location of the toolbar button where the dropdown event occurred.

Returns

Dropdown is displaying a modal window, the return value should be 0, otherwise return 1 for menu style displays.

Remarks

When the user clicks on a dropdown arrow for a toolbar button, the CBRN_XT_DROPDOWN message is sent to the toolbar's owner window.

Example

Here is an example of how an application would process the CBRN_XT_DROPDOWN message.

BEGIN_MESSAGE_MAP(CMainFrame, CXTMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(CBRN_XT_DROPDOWN, OnDropDown)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnDropDown(WPARAM wParam, LPARAM lParam)
{
    NMTOOLBAR* pNMTB = (NMTOOLBAR*)wParam;
    ASSERT(pNMTB != NULL);

    CRect* pRect = (CRect*)lParam;
    ASSERT(pRect != NULL);

    // TODO: Handle toolbar dropdown notification (click on REDO drop arrow).

    return 0;
}
Group

Variables


CPN_XT_CLOSEUP Variable

XTNotify.h, Variables, Example, See Also
CPN_XT_CLOSEUP Variable

CPN_XT_CLOSEUP notification message handler.

const UINT CPN_XT_CLOSEUP = (WM_XTP_CONTROLS_BASE + 3);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The CPN_XT_CLOSEUP notification message is sent to inform the owner window that the color selection window has closed. The owner window of the color picker receives this notification through the WM_COMMAND message.

See Also

CXTColorPicker, CXTColorSelectorCtrl, CPN_XT_SELCHANGE, CPN_XT_DROPDOWN, CPN_XT_SELENDOK, CPN_XT_SELENDCANCEL, CPN_XT_SELNOFILL

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CColorDialog, CDialog
    //{{AFX_MSG_MAP(CColorDialog)
    ON_CPN_XT_CLOSEUP(IDC_CTRL_ID, OnCloseUp)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CColorDialog::OnCloseUp()
{
    // TODO: Handle command.
}
Group

Variables


CPN_XT_DROPDOWN Variable

XTNotify.h, Variables, Example, See Also
CPN_XT_DROPDOWN Variable

CPN_XT_DROPDOWN notification message handler.

const UINT CPN_XT_DROPDOWN = (WM_XTP_CONTROLS_BASE + 2);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The CPN_XT_DROPDOWN notification message is sent to inform the owner window that the color selection window is has been displayed. The owner window of the color picker receives this notification through the WM_COMMAND message.

See Also

CXTColorPicker, CXTColorSelectorCtrl, CPN_XT_SELCHANGE, CPN_XT_CLOSEUP, CPN_XT_SELENDOK, CPN_XT_SELENDCANCEL, CPN_XT_SELNOFILL

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CColorDialog, CDialog
    //{{AFX_MSG_MAP(CColorDialog)
    ON_CPN_XT_DROPDOWN(IDC_CTRL_ID, OnDropDown)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CColorDialog::OnDropDown()
{
    // TODO: Handle command.
}
Group

Variables


CPN_XT_SELCHANGE Variable

XTNotify.h, Variables, Example, See Also
CPN_XT_SELCHANGE Variable

CPN_XT_SELCHANGE notification message handler.

const UINT CPN_XT_SELCHANGE = (WM_XTP_CONTROLS_BASE + 1);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The CPN_XT_SELCHANGE notification message is sent to inform the owner window that the current color selection has changed. The owner window of the color picker receives this notification through the WM_COMMAND message.

See Also

CXTColorPicker, CXTColorSelectorCtrl, CPN_XT_DROPDOWN, CPN_XT_CLOSEUP, CPN_XT_SELENDOK, CPN_XT_SELENDCANCEL, CPN_XT_SELNOFILL

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CColorDialog, CDialog
    //{{AFX_MSG_MAP(CColorDialog)
    ON_CPN_XT_SELCHANGE(IDC_CTRL_ID, OnSelChange)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CColorDialog::OnSelChange()
{
    // TODO: Handle command.
}
Group

Variables


CPN_XT_SELENDCANCEL Variable

XTNotify.h, Variables, Example, See Also
CPN_XT_SELENDCANCEL Variable

CPN_XT_SELENDCANCEL notification message handler.

const UINT CPN_XT_SELENDCANCEL = (WM_XTP_CONTROLS_BASE + 5);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The CPN_XT_SELENDCANCEL notification message is sent to inform the owner window that a color selection has been canceled. The owner window of the color picker receives this notification through the WM_COMMAND message.

See Also

CXTColorPicker, CXTColorSelectorCtrl, CPN_XT_SELCHANGE, CPN_XT_DROPDOWN, CPN_XT_CLOSEUP, ON_CPN_XT_SELENDOK, CPN_XT_SELNOFILL

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CColorDialog, CDialog
    //{{AFX_MSG_MAP(CColorDialog)
    ON_CPN_XT_SELENDCANCEL(IDC_CTRL_ID, OnSelEndCancel)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CColorDialog::OnSelEndCancel()
{
    // TODO: Handle command.
}
Group

Variables


CPN_XT_SELENDOK Variable

XTNotify.h, Variables, Example, See Also
CPN_XT_SELENDOK Variable

CPN_XT_SELENDOK notification message handler.

const UINT CPN_XT_SELENDOK = (WM_XTP_CONTROLS_BASE + 4);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The CPN_XT_SELENDOK notification message is sent to inform the owner window that a color selection has been made. The owner window of the color picker receives this notification through the WM_COMMAND message.

See Also

CXTColorPicker, CXTColorSelectorCtrl, CPN_XT_SELCHANGE, CPN_XT_DROPDOWN, CPN_XT_CLOSEUP, CPN_XT_SELENDCANCEL, CPN_XT_SELNOFILL

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CColorDialog, CDialog
    //{{AFX_MSG_MAP(CColorDialog)
    ON_CPN_XT_SELENDOK(IDC_CTRL_ID, OnSelEndOk)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CColorDialog::OnSelEndOk()
{
    // TODO: Handle command.
}
Group

Variables


CPN_XT_SELNOFILL Variable

XTNotify.h, Variables, Example, See Also
CPN_XT_SELNOFILL Variable

CPN_XT_SELNOFILL notification message handler.

const UINT CPN_XT_SELNOFILL = (WM_XTP_CONTROLS_BASE + 6);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The CPN_XT_SELNOFILL notification message is sent to inform the owner window that a "No Fill" or "Automatic Color" selection has been made. The owner window of the color picker receives this notification through the WM_COMMAND message.

See Also

CXTColorPicker, CXTColorSelectorCtrl, CPN_XT_SELCHANGE, CPN_XT_DROPDOWN, CPN_XT_CLOSEUP, ON_CPN_XT_SELENDOK, CPN_XT_SELENDCANCEL

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CColorDialog, CDialog
    //{{AFX_MSG_MAP(CColorDialog)
    ON_CPN_XT_SELNOFILL(IDC_CTRL_ID, OnSelNoFill)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CColorDialog::OnSelNoFill()
{
    // TODO: Handle command.
}
Group

Variables


CPWN_XT_PUSHPINBUTTON Variable

XTNotify.h, Variables, Example, See Also
CPWN_XT_PUSHPINBUTTON Variable

The CPWN_XT_PUSHPINBUTTON message is sent to the owner of a CXTCaptionPopupWnd whenever the push pin button selection has been made.

const UINT CPWN_XT_PUSHPINBUTTON = (WM_XTP_CONTROLS_BASE + 22);
File

XTNotify.h

Remarks

When the user makes a selection of the push pin button, the CPWN_XT_PUSHPINBUTTON message is sent to the caption popup window's owner window.

See Also

CXTCaption, CXTCaptionPopupWnd

Example

Here is an example of how an application would process the TCN_XT_SELCHANGE message.

BEGIN_MESSAGE_MAP(CMainFrame, CXTMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE_VOID(CPWN_XT_PUSHPINBUTTON, OnPushPinButton)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnPushPinButton()
{
    // TODO: Add your message handler code here and/or call default
    m_wndSplitter2.ShowColumn();
    m_nColumn = 1;
}
Group

Variables


CPWN_XT_PUSHPINCANCEL Variable

XTNotify.h, Variables, Example, See Also
CPWN_XT_PUSHPINCANCEL Variable

The CPWN_XT_PUSHPINCANCEL message is sent to the owner of a CXTCaptionPopupWnd whenever the push pin button selection has been canceled.

const UINT CPWN_XT_PUSHPINCANCEL = (WM_XTP_CONTROLS_BASE + 23);
File

XTNotify.h

Remarks

When the user cancels a selection of the push pin button, the CPWN_XT_PUSHPINCANCEL message is sent to the caption popup window's owner window.

See Also

CXTCaption, CXTCaptionPopupWnd

Example

Here is an example of how an application would process the TCN_XT_SELCHANGE message.

BEGIN_MESSAGE_MAP(CMainFrame, CXTMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE_VOID(CPWN_XT_PUSHPINCANCEL, OnPushPinCancel)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnPushPinCancel()
{
    // TODO: Add your message handler code here and/or call default
}
Group

Variables


LBN_XT_DELETEITEM Variable

XTNotify.h, Variables, Example, See Also
LBN_XT_DELETEITEM Variable

LBN_XT_DELETEITEM notification message handler.

const UINT LBN_XT_DELETEITEM = (WM_XTP_CONTROLS_BASE + 11);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The LBN_XT_DELETEITEM notification message is sent to inform the owner whenever the delete item button has been pressed.

See Also

CXTEditListBox, LBN_XT_LABELEDITEND, LBN_XT_LABELEDITCANCEL, LBN_XT_NEWITEM, LBN_XT_PREDELETEITEM, LBN_XT_MOVEITEMUP, LBN_XT_MOVEITEMDOWN, LBN_XT_PRENEWITEM

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_LBN_XT_DELETEITEM(IDC_CTRL_ID, OnDeleteItem)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnDeleteItem()
{
    // TODO: Handle command.
}
Group

Variables


LBN_XT_LABELEDITCANCEL Variable

XTNotify.h, Variables, Example, See Also
LBN_XT_LABELEDITCANCEL Variable

LBN_XT_LABELEDITCANCEL notification message handler.

const DWORD LBN_XT_LABELEDITCANCEL = BEN_XT_LABELEDITCANCEL;
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The LBN_XT_LABELEDITCANCEL notification message is sent to inform the owner whenever the label edit operation has been canceled.

See Also

CXTEditListBox, LBN_XT_LABELEDITEND, LBN_XT_NEWITEM, LBN_XT_PREDELETEITEM, LBN_XT_DELETEITEM, LBN_XT_MOVEITEMUP, LBN_XT_MOVEITEMDOWN, LBN_XT_PRENEWITEM

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_LBN_XT_LABELEDITCANCEL(IDC_CTRL_ID, OnLabelEditCancel)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnLabelEditCancel()
{
    // TODO: Handle command.
}
Group

Variables


LBN_XT_LABELEDITEND Variable

XTNotify.h, Variables, Example, See Also
LBN_XT_LABELEDITEND Variable

LBN_XT_LABELEDITEND notification message handler.

const DWORD LBN_XT_LABELEDITEND = BEN_XT_LABELEDITEND;
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The LBN_XT_LABELEDITEND notification message is sent to inform the owner whenever the label edit operation has ended.

See Also

CXTEditListBox, LBN_XT_LABELEDITCANCEL, LBN_XT_NEWITEM, LBN_XT_PREDELETEITEM, LBN_XT_DELETEITEM, LBN_XT_MOVEITEMUP, LBN_XT_MOVEITEMDOWN, LBN_XT_PRENEWITEM

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_LBN_XT_LABELEDITEND(IDC_CTRL_ID, OnLabelEditEnd)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnLabelEditEnd()
{
    // TODO: Handle command.
}
Group

Variables


LBN_XT_MOVEITEMDOWN Variable

XTNotify.h, Variables, Example, See Also
LBN_XT_MOVEITEMDOWN Variable

LBN_XT_MOVEITEMDOWN notification message handler.

const UINT LBN_XT_MOVEITEMDOWN = (WM_XTP_CONTROLS_BASE + 13);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The LBN_XT_MOVEITEMDOWN notification message is sent to inform the owner whenever the move item down button has been pressed.

See Also

CXTEditListBox, LBN_XT_LABELEDITEND, LBN_XT_LABELEDITCANCEL, LBN_XT_NEWITEM, LBN_XT_PREDELETEITEM, LBN_XT_DELETEITEM, LBN_XT_MOVEITEMUP, LBN_XT_PRENEWITEM

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_LBN_XT_MOVEITEMDOWN(IDC_CTRL_ID, OnMoveItemDown)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnMoveItemDown()
{
    // TODO: Handle command.
}
Group

Variables


LBN_XT_MOVEITEMUP Variable

XTNotify.h, Variables, Example, See Also
LBN_XT_MOVEITEMUP Variable

LBN_XT_MOVEITEMUP notification message handler.

const UINT LBN_XT_MOVEITEMUP = (WM_XTP_CONTROLS_BASE + 12);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The LBN_XT_MOVEITEMUP notification message is sent to inform the owner whenever the move item up button has been pressed.

See Also

CXTEditListBox, LBN_XT_LABELEDITEND, LBN_XT_LABELEDITCANCEL, LBN_XT_NEWITEM, LBN_XT_PREDELETEITEM, LBN_XT_DELETEITEM, LBN_XT_MOVEITEMDOWN, LBN_XT_PRENEWITEM

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_LBN_XT_MOVEITEMUP(IDC_CTRL_ID, OnMoveItemUp)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnMoveItemUp()
{
    // TODO: Handle command.
}
Group

Variables


LBN_XT_NEWITEM Variable

XTNotify.h, Variables, Example, See Also
LBN_XT_NEWITEM Variable

LBN_XT_NEWITEM notification message handler.

const UINT LBN_XT_NEWITEM = (WM_XTP_CONTROLS_BASE + 9);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The LBN_XT_NEWITEM notification message is sent to inform the owner whenever the new item button has been pressed.

See Also

CXTEditListBox, LBN_XT_LABELEDITEND, LBN_XT_LABELEDITCANCEL, LBN_XT_PREDELETEITEM, LBN_XT_DELETEITEM, LBN_XT_MOVEITEMUP, LBN_XT_MOVEITEMDOWN, LBN_XT_PRENEWITEM

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_LBN_XT_NEWITEM(IDC_CTRL_ID, OnNewItem)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnNewItem()
{
    // TODO: Handle command.
}
Group

Variables


LBN_XT_PREDELETEITEM Variable

XTNotify.h, Variables, Example, See Also
LBN_XT_PREDELETEITEM Variable

LBN_XT_PREDELETEITEM notification message handler.

const UINT LBN_XT_PREDELETEITEM = (WM_XTP_CONTROLS_BASE + 10);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The LBN_XT_PREDELETEITEM notification message is sent to inform the owner just before an item is deleted. This is useful for retrieving information about the selected item, such as item data, before it is removed from the edit list control.

See Also

CXTEditListBox, LBN_XT_LABELEDITEND, LBN_XT_LABELEDITCANCEL, LBN_XT_NEWITEM, LBN_XT_DELETEITEM, LBN_XT_MOVEITEMUP, LBN_XT_MOVEITEMDOWN, LBN_XT_PRENEWITEM

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_LBN_XT_PREDELETEITEM(IDC_CTRL_ID, OnPreDeleteItem)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnPreDeleteItem()
{
    // TODO: Handle command.
}
Group

Variables


LBN_XT_PRENEWITEM Variable

XTNotify.h, Variables, Example, See Also
LBN_XT_PRENEWITEM Variable

LBN_XT_PRENEWITEM notification message handler.

const UINT LBN_XT_PRENEWITEM = (WM_XTP_CONTROLS_BASE + 14);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The LBN_XT_PRENEWITEM notification message is sent to inform the owner whenever that a new item is about to be edited in EditListBox.

See Also

CXTEditListBox, LBN_XT_LABELEDITEND, LBN_XT_LABELEDITCANCEL, LBN_XT_NEWITEM, LBN_XT_PREDELETEITEM, LBN_XT_DELETEITEM, LBN_XT_MOVEITEMUP, LBN_XT_MOVEITEMDOWN

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_LBN_XT_PRENEWITEM(IDC_CTRL_ID, OnPreNewItem)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnPreNewItem()
{
    // TODO: Handle command.
}
Group

Variables


LBS_XT_BROWSE Variable

XTEditListBox.h, Variables
LBS_XT_BROWSE Variable

Browse button

const DWORD LBS_XT_BROWSE = 0x0010;
File

XTEditListBox.h

Group

Variables


LBS_XT_BROWSE_ONLY Variable

XTEditListBox.h, Variables
LBS_XT_BROWSE_ONLY Variable

Browse button

const DWORD LBS_XT_BROWSE_ONLY = 0x0080;
File

XTEditListBox.h

Group

Variables


LBS_XT_HIDE_UP_DOWN Variable

XTEditListBox.h, Variables
LBS_XT_HIDE_UP_DOWN Variable

Hide Up/Down buttons

const DWORD LBS_XT_HIDE_UP_DOWN = 0x0020;
File

XTEditListBox.h

Group

Variables


LBS_XT_ONLY_UP_DOWN Variable

XTEditListBox.h, Variables
LBS_XT_ONLY_UP_DOWN Variable

Only Up/Down buttons

const DWORD LBS_XT_ONLY_UP_DOWN = 0x0040;
File

XTEditListBox.h

Group

Variables


SON_XT_ITEMCONTRACT Variable

XTNotify.h, Variables, Example, See Also
SON_XT_ITEMCONTRACT Variable

SON_XT_ITEMCONTRACT notification message handler.

const UINT SON_XT_ITEMCONTRACT = (WM_XTP_CONTROLS_BASE + 18);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The SON_XT_ITEMCONTRACT notification message is sent to inform the owner whenever the search options control has contracted.

See Also

CXTSearchOptionsCtrl, SON_XT_ITEMEXPANDING, SON_XT_ITEMEXPAND, SON_XT_ITEMCONTRACTING

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_SON_XT_ITEMCONTRACT(IDC_CTRL_ID, OnItemContract)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnItemContract()
{
    // TODO: Handle command.
}
Group

Variables


SON_XT_ITEMCONTRACTING Variable

XTNotify.h, Variables, Example, See Also
SON_XT_ITEMCONTRACTING Variable

SON_XT_ITEMCONTRACTING notification message handler.

const UINT SON_XT_ITEMCONTRACTING = (WM_XTP_CONTROLS_BASE + 17);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The SON_XT_ITEMCONTRACTING notification message is sent to inform the owner whenever the search options control is contracting.

See Also

CXTSearchOptionsCtrl, SON_XT_ITEMEXPANDING, SON_XT_ITEMEXPAND, SON_XT_ITEMCONTRACT

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_SON_XT_ITEMCONTRACTING(IDC_CTRL_ID, OnItemContracting)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnItemContracting()
{
    // TODO: Handle command.
}
Group

Variables


SON_XT_ITEMEXPAND Variable

XTNotify.h, Variables, Example, See Also
SON_XT_ITEMEXPAND Variable

SON_XT_ITEMEXPAND notification message handler.

const UINT SON_XT_ITEMEXPAND = (WM_XTP_CONTROLS_BASE + 16);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The SON_XT_ITEMEXPAND notification message is sent to inform the owner whenever the search options control has expanded.

See Also

CXTSearchOptionsCtrl, SON_XT_ITEMEXPANDING, SON_XT_ITEMCONTRACTING, SON_XT_ITEMCONTRACT

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_SON_XT_ITEMEXPAND(IDC_CTRL_ID, OnItemExpand)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnItemExpand()
{
    // TODO: Handle command.
}
Group

Variables


SON_XT_ITEMEXPANDING Variable

XTNotify.h, Variables, Example, See Also
SON_XT_ITEMEXPANDING Variable

SON_XT_ITEMEXPANDING notification message handler.

const UINT SON_XT_ITEMEXPANDING = (WM_XTP_CONTROLS_BASE + 15);
File

XTNotify.h

Parameters

id
Resource ID for the control.
memberFxn
Name of member function to handle the message.

Remarks

The SON_XT_ITEMEXPANDING notification message is sent to inform the owner whenever the search options control is expanding.

See Also

CXTSearchOptionsCtrl, SON_XT_ITEMEXPAND, SON_XT_ITEMCONTRACTING, SON_XT_ITEMCONTRACT

Example

Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CAppDialog, CDialog
    //{{AFX_MSG_MAP(CAppDialog)
    ON_SON_XT_ITEMEXPANDING(IDC_CTRL_ID, OnItemExpanding)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CAppDialog::OnItemExpanding()
{
    // TODO: Handle command.
}
Group

Variables


TIN_XT_TRAYICON Variable

XTNotify.h, Variables, Example, See Also
TIN_XT_TRAYICON Variable

The TIN_XT_TRAYICON message is sent to the CXTTrayIcon window's owner whenever a mouse event occurs in the CXTTrayIcon.

const UINT TIN_XT_TRAYICON = (WM_XTP_CONTROLS_BASE + 21);
File

XTNotify.h

Parameters

uID
(UINT) wParam; - value of wParam specifies the resource ID of the icon associated with the CXTTrayIcon object.
uMouseMsg
(UINT) lParam; - value of lParam specifies the mouse or keyboard message associated with the event.

Returns

If the application is to process this message, the return value should be 0.

Remarks

When a mouse or keyboard event occurs on a tray icon, the TIN_XT_TRAYICON message is sent to the tray icon's owner window.

See Also

CXTTrayIcon

Example

Here is an example of how an application would process the TIN_XT_TRAYICON message.

BEGIN_MESSAGE_MAP(CMainFrame, CXTMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(TIN_XT_TRAYICON, OnTrayIconNotify)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTrayIconNotify(WPARAM wParam, LPARAM lParam)
{
    UINT uID = (UINT) wParam;        // resource ID of the tray icon.
    UINT uMouseMsg = (UINT) lParam;  // mouse message that was sent.

    switch (uMouseMsg)
    {
        case WM_RBUTTONUP:
        {
            CMenu menu;
            VERIFY(menu.LoadMenu(IDR_MAINFRAME));

            CMenu* pPopup = menu.GetSubMenu(0);
            ASSERT(pPopup != NULL);
            CWnd* pWndPopupOwner = this;

            // Insert the restore menu command into the popup.
            if (m_bIsVisible == false)
            {
                pPopup->InsertMenu(0, MF_BYPOSITION,
                    IDR_RESTORE, _T("&Restore Window..."));

                pPopup->InsertMenu(1, MF_BYPOSITION | MF_SEPARATOR,
                    IDR_RESTORE);

                // Make restore command bold.
                ::SetMenuDefaultItem(pPopup->m_hMenu, IDR_RESTORE, FALSE);
            }
            else
            {
                // Make the exit command bold.
                ::SetMenuDefaultItem(pPopup->m_hMenu, ID_APP_EXIT, FALSE);
            }

            // Display the menu at the current mouse location. There's a "bug"
            // (Microsoft calls it a feature) in Windows 95 that requires calling
            // SetForegroundWindow. To find out more, search for Q135788 in MSDN.
            //
            CPoint point;
            GetCursorPos(&point);
            ::SetForegroundWindow(m_hWnd);

            while (pWndPopupOwner->GetStyle() & WS_CHILD)
                pWndPopupOwner = pWndPopupOwner->GetParent();

            int iCmd = pPopup->TrackPopupMenu(
                TPM_RETURNCMD | TPM_LEFTALIGN | TPM_RIGHTBUTTON,
                point.x, point.y, pWndPopupOwner);

            // at this point we want to make sure that the app is visible
            // after the user makes a menu selection - this is just one way
            // of doing so:

            switch (iCmd)
            {
                case 0:
                    // user canceled menu - do nothing
                    break;

                // these are commands for which we don't need to make the
                // main app window visible
                case ID_APP_EXIT:
                    PostMessage(WM_COMMAND, iCmd, 0);  // just post the command
                    break;

                // for all other menu commands - make sure the window is
                // visible before we continue
                default:
                    // make main window visible
                    OnRestore();
                    PostMessage(WM_COMMAND, iCmd, 0); // post the command
                    break;
            }

            return 1; // let the tray icon know that we handled this message.
        }

        case WM_LBUTTONDBLCLK:
            OnRestore();
            return 1; // let the tray icon know that we handled this message.
    }

    return 0;
}
Group

Variables


XTP_PCN_ITEMCLICK Variable

XTPPopupControl.h, Variables, Example, See Also
XTP_PCN_ITEMCLICK Variable

XTP_PCN_ITEMCLICK is used to indicate that the user clicked on a popup control item.

const UINT XTP_PCN_ITEMCLICK = 1;
File

XTPPopupControl.h

Remarks

XTP_PCN_ITEMCLICK is sent in the XTPWM_POPUPCONTROL_NOTIFY message to the owner window when the user has clicked on a popup control item.

See Also

XTPWM_POPUPCONTROL_NOTIFY, XTP_PCN_STATECHANGED

Example

See example of XTPWM_POPUPCONTROL_NOTIFY

Group

Variables


XTP_PCN_STATECHANGED Variable

XTPPopupControl.h, Variables, Example, See Also
XTP_PCN_STATECHANGED Variable

XTP_PCN_STATECHANGED is used to indicate that the state of popup control changed

const UINT XTP_PCN_STATECHANGED = 2;
File

XTPPopupControl.h

Remarks

XTP_PCN_STATECHANGED is sent in the XTPWM_POPUPCONTROL_NOTIFY message to the owner window when the state of popup control changed. It can be one of the following states:

  • xtpPopupStateClosed Indicates the the popup window is closed
  • xtpPopupStateExpanding Indicates the popup window is expanding
  • xtpPopupStateShow Indicates the popup window is shown
  • xtpPopupStateCollapsing Indicates the popup window is collapsing
See Also

XTPWM_POPUPCONTROL_NOTIFY, XTP_PCN_ITEMCLICK

Example

See example of XTPWM_POPUPCONTROL_NOTIFY

Group

Variables


XTPWM_POPUPCONTROL_NOTIFY Variable

XTPPopupControl.h, Variables, Example, See Also
XTPWM_POPUPCONTROL_NOTIFY Variable

The XTPWM_POPUPCONTROL_NOTIFY message is sent to the CXTPPopupControl owner window whenever an action occurs within the CXTPPopupControl

const UINT XTPWM_POPUPCONTROL_NOTIFY = (WM_XTP_CONTROLS_BASE + 37);
File

XTPPopupControl.h

Parameters

nAction
Value of wParam specifies a Popup Control value that indicates the user's request. Can be any of the values listed in the Remarks section.

Returns

If the application is to process this message, the return value should be TRUE, otherwise the return value is FALSE.

Remarks

nAction parameter can be one of the following:

  • XTP_PCN_ITEMCLICK Indicates the user clicked on the popup control item.
  • XTP_PCN_STATECHANGED Indicates the state of control changed.
See Also

XTP_PCN_ITEMCLICK, XTP_PCN_STATECHANGED, CXTPPopupControl

Example

Here is an example of how an application would process the XTPWM_POPUPCONTROL_NOTIFY message.

BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(XTPWM_POPUPCONTROL_NOTIFY, OnPopUpNotify)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnPopUpNotify(WPARAM wParam, LPARAM lParam)
{
     if (wParam == XTP_PCN_ITEMCLICK)
     {
         CXTPPopupItem* pItem = (CXTPPopupItem*)lParam;
         ASSERT(pItem);

         m_wndPopupControl.Close();

         if (pItem->GetID() == ID_GOTO_SITE)
         {
             ::ShellExecute(NULL, _T("open"), _T("http://www.codejock.com/"), NULL, NULL, SW_SHOW);
         }
     }
     else if (wParam == XTP_PCN_STATECHANGED)
     {
         CXTPPopupControl* pControl = (CXTPPopupControl*)lParam;
         ASSERT(pControl);

         if (pControl->GetPopupState() == xtpPopupStateClosed)
         {
             EnableItems(TRUE);
         }
     }
     return TRUE;
 }
Group

Variables


XTWM_ADDREBAR Variable

XTDefines.h, Variables, Example
XTWM_ADDREBAR Variable

The XTWM_ADDREBAR message is sent to a window whenever it is added to a CXTReBar control.

XTWM_ADDREBAR
bHorz = (BOOL) wParam;            // TRUE if horizontal.
pRBBI = (REBARBANDINFO*) lParam;  // Points to a REBARBANDINFO structure.
const UINT XTWM_ADDREBAR = (WM_XTP_CONTROLS_BASE + 30);
File

XTDefines.h

Parameters

bHorz
TRUE if horizontally oriented, FALSE otherwise.
pRBBI
A pointer to a BARBANDINFO structure, the window can modify its parameters as appropriate.

Returns

If the application is to process this message, the return value should be TRUE.

Remarks

When a window is added to a rebar, the XTWM_ADDREBAR message is sent to the window.

Example

Here is an example of how an application would process the XTWM_ADDREBAR message.

BEGIN_MESSAGE_MAP(CWidget, CWnd)
    //{{AFX_MSG_MAP(CWidget)
    ON_MESSAGE(XTWM_ADDREBAR, OnAddReBar)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CWidget::OnAddReBar(WPARAM wParam, LPARAM lParam)
{
    BOOL bHorz = (BOOL) wParam;

    REBARBANDINFO* pRBBI = (REBARBANDINFO*) lParam;
        // TODO: Handle message.

    return TRUE;
}
Group

Variables


XTWM_OUTBAR_NOTIFY Variable

XTNotify.h, Variables, Example, See Also
XTWM_OUTBAR_NOTIFY Variable

The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.

const UINT XTWM_OUTBAR_NOTIFY = (WM_XTP_CONTROLS_BASE + 19);
File

XTNotify.h

Parameters

nBarAction
(int) wParam; - value of wParam specifies an Outlook bar value that indicates the users request. This parameter can be one of the values listed in the Remarks section.
pOBInfo
pOBInfo (XT_OUTBAR_INFO*) lParam; - value of lParam points to an XT_OUTBAR_INFO structure that contains information for the specified item. The item can either be a folder group or icon item, depending on the value of the nBarAction parameter. This pointer should never be NULL.

Returns

If the application is to process this message, the return value should be TRUE. If the return value is FALSE, the user's action is ignored.

Remarks

When the user performs an action in the Outlook bar, the XTWM_OUTBAR_NOTIFY message is sent to the Outlook bar's owner window. nBarAction can be one of the following values:

  • OBN_XT_ITEMCLICK The user has selected an item in the Outlook bar.
  • OBN_XT_ONLABELENDEDIT The user has completed editing an item's label.
  • OBN_XT_ONGROUPENDEDIT The user has completed editing a folder's label.
  • OBN_XT_DRAGITEM The user has dragged an item to a new location in the Outlook bar.
  • OBN_XT_FOLDERCHANGE The user has selected a new folder item.
  • OBN_XT_ITEMHOVER The user's mouse is hovering over an item in the Outlook bar.
  • OBN_XT_DELETEITEM The user has chosen to delete an item from the Outlook bar.
  • OBN_XT_DELETEFOLDER The user has chosen to delete a folder from the Outlook bar.
  • OBN_XT_ITEMRCLICK The user has right clicked on the Outlook bar folder.
See Also

CXTMenuListBox, CXTOutBarCtrl

Example

Here is an example of how an application would process the XTWM_OUTBAR_NOTIFY message.

int nBarAction = (int)wParam;

// Cast the lParam to an XT_OUTBAR_INFO* struct pointer.
XT_OUTBAR_INFO* pOBInfo = (XT_OUTBAR_INFO*)lParam;
ASSERT(pOBInfo);

switch (nBarAction)
{
    case OBN_XT_ITEMCLICK:
    case OBN_XT_FOLDERCHANGE:
    case OBN_XT_ONLABELENDEDIT:
    case OBN_XT_ONGROUPENDEDIT:
    case OBN_XT_DRAGITEM:
    case OBN_XT_ITEMHOVER:
    case OBN_XT_ITEMRCLICK:
        TRACE2("Index: %d, Name: %s.\n", pOBInfo->nIndex, pOBInfo->lpszText);
        break;

    case OBN_XT_DELETEITEM:
        if (AfxMessageBox(_T("Remove this folder shortcut?"),
            MB_ICONWARNING | MB_YESNO) == IDNO)
        {
            return FALSE; // Return FALSE to abort the action.
        }
        break;

    case OBN_XT_DELETEFOLDER:
        if (AfxMessageBox(_T("Remove the specified folder?"),
            MB_ICONWARNING | MB_YESNO) == IDNO)
        {
            return FALSE; // Return FALSE to abort the action.
        }
        break;
}
return TRUE;
Group

Variables


XTWM_QUERYHOTSPOT Variable

XTDefines.h, Variables, Example
XTWM_QUERYHOTSPOT Variable

CXTDockContext sends the XTWM_QUERYHOTSPOT message to a control bar to check if the control bar has a hot spot, a point that must match the position of the cursor.

XTWM_QUERYHOTSPOT
wParam - not used, must be zero
lpSize = (LPSIZE) lParam;  // IN  - Extent of the rectangle in which
                           //       hot spot is to be defined
                           // OUT - Offset of the hot spot location
                           //       within the rectangle.
const UINT XTWM_QUERYHOTSPOT = (WM_XTP_CONTROLS_BASE + 34);
File

XTDefines.h

Returns

TRUE if control bar has a hot spot, FALSE if it does not.

Remarks

CXTDockContext sends the XTWM_QUERYHOTSPOT message the control bar to check for a hot spot.

Example

Here is an example of how an application would process the XTWM_QUERYHOTSPOT message.

BEGIN_MESSAGE_MAP(CWidget, CXTControlBar)
    //{{AFX_MSG_MAP(CWidget)
    ON_MESSAGE(XTWM_QUERYHOTSPOT, OnQueryHotSpot)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CWidget::OnQueryHotSpot(WPARAM wParam, LPARAM lParam)
{
    UNREFERENCED_PARAMETER(wParam);
    LPSIZE lpSize = (LPSIZE) lParam;  // Points to a LPSIZE structure.
    // TODO: Handle message.
    return TRUE;
}
Group

Variables


XTWM_QUERYVISUALIZE Variable

XTDefines.h, Variables, Example
XTWM_QUERYVISUALIZE Variable

CXTDockContext sends the XTWM_QUERYVISUALIZE message to a control bar to check if the control bar shall be visualized while dragging or just a wire frame shall be rendered.

XTWM_QUERYVISUALIZE
wParam - not used, must be zero
lParam - not used, must be zero
const UINT XTWM_QUERYVISUALIZE = (WM_XTP_CONTROLS_BASE + 33);
File

XTDefines.h

Returns

TRUE if the control bar shall be fully visualized, FALSE if just a wire frame must be rendered.

Remarks

When a control bar is dragged the XTWM_QUERYVISUALIZE message is sent to the control bar.

Example

Here is an example of how an application would process the XTWM_QUERYVISUALIZE message.

BEGIN_MESSAGE_MAP(CWidget, CXTControlBar)
    //{{AFX_MSG_MAP(CWidget)
    ON_MESSAGE(XTWM_QUERYVISUALIZE, OnQueryVisualize)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CWidget::OnQueryVisualize(WPARAM wParam, LPARAM lParam)
{
    UNREFERENCED_PARAMETER(wParam);
    UNREFERENCED_PARAMETER(lParam);
    // Allow full visualizations.
    return TRUE;
}
Group

Variables


XTWM_REBAR_SIZECHILD Variable

XTDefines.h, Variables, Example
XTWM_REBAR_SIZECHILD Variable

The XTWM_REBAR_SIZECHILD message is sent when CXTReBar control has resized the band in which the recipient resides.

XTWM_REBAR_SIZECHILD
bHorz = (BOOL) wParam; // TRUE if horizontal.
pRBSCI = (XT_REBARSIZECHILDINFO*) lParam;  // Points to an XT_REBARSIZECHILDINFO structure.
const UINT XTWM_REBAR_SIZECHILD = (WM_XTP_CONTROLS_BASE + 32);
File

XTDefines.h

Parameters

bHorz
TRUE if horizontally oriented, FALSE otherwise.
pRBSCI
A pointer to an XT_REBARSIZECHILDINFO structure, the window can modify its parameters as appropriate.

Returns

If the application is to process this message, the return value should be TRUE.

Remarks

When a window is added to a rebar, the XTWM_REBAR_SIZECHILD message is sent to the window.

Example

Here is an example of how an application would process the XTWM_REBAR_SIZECHILD message.

BEGIN_MESSAGE_MAP(CWidget, CWnd)
    //{{AFX_MSG_MAP(CWidget)
    ON_MESSAGE(XTWM_REBAR_SIZECHILD, OnReBarSizeChild)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CWidget::OnReBarSizeChild(WPARAM wParam, LPARAM lParam)
{
    BOOL bHorz = (BOOL) wParam;

    XT_REBARSIZECHILDINFO* pRBSCI = (XT_REBARSIZECHILDINFO*) lParam;
        // TODO: Handle message.

    return TRUE;
}
Group

Variables


XTWM_SHELL_NOTIFY Variable

XTNotify.h, Variables, Example, See Also
XTWM_SHELL_NOTIFY Variable

The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.

const UINT XTWM_SHELL_NOTIFY = (WM_XTP_CONTROLS_BASE + 20);
File

XTNotify.h

Parameters

nShellAction
(int) wParam; - value of wParam specifies a shell tree value that indicates the users request. See Remarks section for a list of values.
pItemData
(XT_TVITEMDATA*) lParam; - value of lParam points to an XT_TVITEMDATA structure that contains information for the specified item. Depending on the action, this pointer can be NULL.

Returns

If the application is to process this message, the return value should be 0.

Remarks

When the user performs an action in the shell tree, the XTWM_SHELL_NOTIFY message is sent to the shell tree's owner window.

The nShellAction parameter can be one of the following values:

  • SHN_XT_SHELLMENU Shell context menu selection made.
  • SHN_XT_TREESELCHANGE Tree selection made.
  • SHN_XT_SELECTCHILD Child tree node selected.
  • SHN_XT_NOFOLDER Item selected was not a folder.
  • SHN_XT_INETFOLDER Item selected was the Internet folder.
  • SHN_XT_CONTENTSCHANGED Indicates the folder's contents have changed.
  • SHN_XT_REFRESHFOLDER Indicates the folder needs to be updated.
  • SHN_XT_REFRESHTREE Indicates the tree needs to be updated.
See Also

CXTShellTreeCtrl, CXTShellListCtrl, CXTShellListBase, CXTDirWatcher

Example

Here is an example of how an application would process the XTWM_SHELL_NOTIFY message.

int nShellAction = (int)wParam;

// Cast the lParam to an XT_TVITEMDATA* struct pointer.
XT_TVITEMDATA* pItemData = (XT_TVITEMDATA*)lParam;
ASSERT(pItemData);

switch (nBarAction)
{
    case SHN_XT_SHELLMENU:
    case SHN_XT_TREESELCHANGE:
    case SHN_XT_SELECTCHILD:
    case SHN_XT_NOFOLDER:
    case SHN_XT_INETFOLDER:
    case SHN_XT_CONTENTSCHANGED:
    case SHN_XT_REFRESHFOLDER:
    case SHN_XT_REFRESHTREE:
        // TODO: Handle shell notification message.
        TRACE0("Shell notification was sent.n");
        break;
}
return 0;
Group

Variables


XTWM_UPDATECOLOR Variable

XTNotify.h, Variables, Example, See Also
XTWM_UPDATECOLOR Variable

The XTWM_UPDATECOLOR message is used to send notification that the color selection has changed.

const DWORD XTWM_UPDATECOLOR = (WM_XTP_CONTROLS_BASE + 26);
File

XTNotify.h

Parameters

crNew
(COLORREF) wParam; - newly selected RGB color.

Remarks

This message is sent to notify the owner that a color selection has changed.

See Also

CXTColorDialog, CXTColorBase, CXTColorLum, CXTColorPageCustom, CXTColorHex, CXTColorPageStandard

Example

Here is an example of how an application would process the XTWM_UPDATECOLOR message.

BEGIN_MESSAGE_MAP(CXTColorPageCustom, CXTThemePropertyPage)
    //{{AFX_MSG_MAP(CMainFrame)
     ON_MESSAGE(XTWM_UPDATECOLOR, OnUpdateColor)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CXTColorPageCustom::OnUpdateColor(WPARAM wParam, LPARAM lParam)
{
    UNUSED_ALWAYS(lParam);
    COLORREF crNew = (COLORREF)wParam;
}
Group

Variables


Macros

Macros, Standard Controls
Macros
Macros
Macro | Description
BTNS_WHOLEDROPDOWN | draw dropdown arrow, but without split arrow section
CXTHeaderCtrlHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CHeaderCtrl.
CXTListCtrlHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CListCtrl.
CXTStringHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CString.
DECLARE_THEME_FACTORY | Use this macro to declare the factory class for specified theme
DECLATE_SHELLTREE_BASE | The DELCLATE_SHELLTREE_BASE class is a template class used by the CXTShellTreeView and CXTShellTreeCtrl class to declare a multiple inheritance base class so that both classes could share a common code base.
IMPLEMENT_THEME_FACTORY | Use this macro to implement factory class for specified theme.
ON_BEN_XT_LABELEDITCANCEL | BEN_XT_LABELEDITCANCEL notification message handler.
ON_BEN_XT_LABELEDITEND | BEN_XT_LABELEDITEND notification message handler.
ON_CPN_XT_CLOSEUP | CPN_XT_CLOSEUP notification message handler.
ON_CPN_XT_DROPDOWN | CPN_XT_DROPDOWN notification message handler.
ON_CPN_XT_SELCHANGE | CPN_XT_SELCHANGE notification message handler.
ON_CPN_XT_SELENDCANCEL | CPN_XT_SELENDCANCEL notification message handler.
ON_CPN_XT_SELENDOK | CPN_XT_SELENDOK notification message handler.
ON_CPN_XT_SELNOFILL | CPN_XT_SELNOFILL notification message handler.
ON_LBN_XT_DELETEITEM | LBN_XT_DELETEITEM notification message handler.
ON_LBN_XT_LABELEDITCANCEL | LBN_XT_LABELEDITCANCEL notification message handler.
ON_LBN_XT_LABELEDITEND | LBN_XT_LABELEDITEND notification message handler.
ON_LBN_XT_MOVEITEMDOWN | LBN_XT_MOVEITEMDOWN notification message handler.
ON_LBN_XT_MOVEITEMUP | LBN_XT_MOVEITEMUP notification message handler.
ON_LBN_XT_NEWITEM | LBN_XT_NEWITEM notification message handler.
ON_LBN_XT_ONBROWSE |
ON_LBN_XT_PREDELETEITEM | LBN_XT_PREDELETEITEM notification message handler.
ON_LBN_XT_PRENEWITEM | LBN_XT_PRENEWITEM notification message handler.
ON_SON_XT_ITEMCONTRACT | SON_XT_ITEMCONTRACT notification message handler.
ON_SON_XT_ITEMCONTRACTING | SON_XT_ITEMCONTRACTING notification message handler.
ON_SON_XT_ITEMEXPAND | SON_XT_ITEMEXPAND notification message handler.
ON_SON_XT_ITEMEXPANDING | SON_XT_ITEMEXPANDING notification message handler.
SZ_BOTTOM_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_BOTTOM_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_BOTTOM_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_HORREPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_HORRESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_MIDDLE_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_REPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_RESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_TOP_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_VERREPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_VERRESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
XTP_ID_POPUP_CLOSE | Cpecial Id for close item
Module

Standard Controls


BTNS_WHOLEDROPDOWN Macro

XTDefines.h, Macros
BTNS_WHOLEDROPDOWN Macro

draw dropdown arrow, but without split arrow section

#define BTNS_WHOLEDROPDOWN 0x80 /* draw dropdown arrow, but without split arrow section */
File

XTDefines.h

Group

Macros


CXTHeaderCtrlHelper Macro

XTVC50Helpers.h, Macros
CXTHeaderCtrlHelper Macro

Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CHeaderCtrl.

#define CXTHeaderCtrlHelper CHeaderCtrl
File

XTVC50Helpers.h

Group

Macros


CXTListCtrlHelper Macro

XTVC50Helpers.h, Macros
CXTListCtrlHelper Macro

Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CListCtrl.

#define CXTListCtrlHelper CListCtrl
File

XTVC50Helpers.h

Group

Macros


CXTStringHelper Macro

XTVC50Helpers.h, Macros
CXTStringHelper Macro

Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CString.

#define CXTStringHelper CString
File

XTVC50Helpers.h

Group

Macros


DECLARE_THEME_FACTORY Macro

XTThemeManager.h, Macros, Example, See Also
DECLARE_THEME_FACTORY Macro

Use this macro to declare the factory class for specified theme

#define DECLARE_THEME_FACTORY(theClass)
File

XTThemeManager.h

Parameters

theClass
Base theme class.

See Also

IMPLEMENT_THEME_FACTORY, CXTThemeManagerStyleFactory

Example

The following example demonstrates how to use DECLARE_THEME_FACTORY.

DECLARE_THEME_FACTORY(CXTCaptionTheme)

class _XTP_EXT_CLASS CXTCaptionTheme : public CXTThemeManagerStyle
{
public:
    CXTCaptionTheme();
};
Group

Macros


DECLATE_SHELLTREE_BASE Macro

XTShellTreeBase.h, Macros, Example
DECLATE_SHELLTREE_BASE Macro

The DELCLATE_SHELLTREE_BASE class is a template class used by the CXTShellTreeView and CXTShellTreeCtrl class to declare a multiple inheritance base class so that both classes could share a common code base.

#define DECLATE_SHELLTREE_BASE(ClassName, Tree, Base)
File

XTShellTreeBase.h

Parameters

ClassName
Name of the object to be declared as the base class.
Tree
Existing class that this object will derive from.
Base
Existing shared class that this object will derive from.

Remarks

Tree must be an existing class that is derived from either CTreeCtrl or CTreeView.

Example

The following example demonstrates how to use DECLATE_SHELLTREE_BASE.

DECLATE_SHELLTREE_BASE(CXTShellTreeViewBase, CTreeView, CXTShellTreeBase)

class _XTP_EXT_CLASS CXTShellTreeView : public CXTShellTreeViewBase
{
public:
    CXTShellTreeView();
};
Group

Macros


IMPLEMENT_THEME_FACTORY Macro

XTThemeManager.h, Macros, Example, See Also
IMPLEMENT_THEME_FACTORY Macro

Use this macro to implement factory class for specified theme.

#define IMPLEMENT_THEME_FACTORY(theClass)
File

XTThemeManager.h

Parameters

theClass
Base theme class.
theClassOfficeXP
Theme used for xtThemeOfficeXP style
theClassOffice2003
Theme used for xtThemeOffice2003 style

See Also

DECLARE_THEME_FACTORY, CXTThemeManagerStyleFactory

Example

The following example demonstrates how to use IMPLEMENT_THEME_FACTORY.

// Implement CXTCaptionThemeFactory class
IMPLEMENT_THEME_FACTORY(CXTCaptionTheme, CXTCaptionThemeOfficeXP, CXTCaptionThemeOfficeXP)

CXTCaptionTheme::CXTCaptionTheme()
{
    RefreshMetrics();
}

void CXTCaptionTheme::RefreshMetrics()
{
    m_clrEdgeShadow.SetStandardValue(
        GetXtremeColor(COLOR_3DSHADOW));
    m_clrEdgeLight.SetStandardValue(
        GetXtremeColor(COLOR_3DHILIGHT));
}
Group

Macros


ON_LBN_XT_ONBROWSE Macro

XTNotify.h, Macros
ON_LBN_XT_ONBROWSE Macro
#define ON_LBN_XT_ONBROWSE(id, memberFxn)
File

XTNotify.h

Group

Macros


SZ_BOTTOM_CENTER Macro

XTResizePoint.h, Macros, Example, See Also
SZ_BOTTOM_CENTER Macro

CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.

#define SZ_BOTTOM_CENTER CXTResizePoint(.5, 1)
#define SZ_BOTTOM_LEFT CXTResizePoint(0, 1)
#define SZ_BOTTOM_RIGHT CXTResizePoint(1, 1)
#define SZ_MIDDLE_CENTER CXTResizePoint(.5, .5)
#define SZ_MIDDLE_LEFT CXTResizePoint(0, .5)
#define SZ_MIDDLE_RIGHT CXTResizePoint(1, .5)
#define SZ_TOP_LEFT CXTResizePoint(0, 0)
#define SZ_TOP_RIGHT CXTResizePoint(1, 0)
#define SZ_TOP_CENTER CXTResizePoint(.5, 0)
File

XTResizePoint.h

Parameters

SZ_BOTTOM_LEFT
Specifies a bottom left position.
SZ_MIDDLE_RIGHT
Specifies a middle right position.
SZ_BOTTOM_RIGHT
Specifies a bottom right position.
SZ_BOTTOM_CENTER
Specifies a bottom center position.
SZ_MIDDLE_CENTER
Specifies a middle center position.
SZ_TOP_CENTER
Specifies a top center position.
SZ_TOP_LEFT
Specifies a top left position.
SZ_MIDDLE_LEFT
Specifies a middle left position.
SZ_TOP_RIGHT
Specifies a top right position.

See Also

CXTResize, CXTResizeDialog, CXTResizeFormView, CXTResizeGroupBox, CXTResizePropertyPage, CXTResizePropertySheet, CXTResizePoint, CXTResizeRect

Example

The following example demonstrates the use of CXTResizePoint.

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   SZ_TOP_LEFT,     SZ_TOP_RIGHT);
SetResize(IDC_TXT_MASK,        SZ_TOP_CENTER,   SZ_TOP_RIGHT);
SetResize(IDC_LBOX_MASK,       SZ_TOP_CENTER,   SZ_TOP_RIGHT);
SetResize(IDC_BTN_UPDATE,      SZ_TOP_CENTER,   SZ_TOP_CENTER);
SetResize(IDC_EDIT_MASK,       SZ_TOP_LEFT,     SZ_TOP_CENTER);
SetResize(IDC_EDIT_PROMPT,     SZ_TOP_LEFT,     SZ_TOP_CENTER);
SetResize(IDC_EDIT_LITERAL,    SZ_TOP_LEFT,     SZ_TOP_CENTER);
SetResize(IDC_EDIT_DEFAULT,    SZ_TOP_LEFT,     SZ_TOP_CENTER);
SetResize(IDC_GBOX_PROPERTIES, SZ_TOP_LEFT,     SZ_TOP_CENTER);
SetResize(IDCANCEL,            SZ_BOTTOM_RIGHT, SZ_BOTTOM_RIGHT);
SetResize(IDOK,                SZ_BOTTOM_RIGHT, SZ_BOTTOM_RIGHT);
Group

Macros


SZ_RESIZE Macro

XTResizeRect.h, Macros, Example, See Also
SZ_RESIZE Macro

CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.

#define SZ_RESIZE(x) CXTResizeRect(0, 0, x, x)
#define SZ_REPOS(x) CXTResizeRect(x, x, x, x)
#define SZ_HORRESIZE(x) CXTResizeRect(0, 0, x, 0)
#define SZ_HORREPOS(x) CXTResizeRect(x, 0, x, 0)
#define SZ_VERRESIZE(x) CXTResizeRect(0, 0, 0, x)
#define SZ_VERREPOS(x) CXTResizeRect(0, x, 0, x)
File

XTResizeRect.h

Parameters

SZ_HORREPOS
Horizontal reposition.
SZ_VERRESIZE
Vertical resize.
SZ_VERREPOS
Vertical reposition.
SZ_RESIZE
Resize.
SZ_REPOS
Reposition.
SZ_HORRESIZE
Horizontal resize.

See Also

CXTResize, CXTResizeDialog, CXTResizeFormView, CXTResizeGroupBox, CXTResizePropertyPage, CXTResizePropertySheet, CXTResizePoint, CXTResizeRect

Example

The following example demonstrates how to use CXTResizeRect.

// Set control resizing.
SetResize(ID_WIZBACK, SZ_REPOS(1));
SetResize(ID_WIZNEXT, SZ_REPOS(1));
SetResize(ID_WIZFINISH, SZ_REPOS(1));
SetResize(ID_WIZLINE, SZ_BOTTOM_LEFT, SZ_BOTTOM_RIGHT);
Group

Macros


XTP_ID_POPUP_CLOSE Macro

XTPPopupItem.h, Macros
XTP_ID_POPUP_CLOSE Macro

Cpecial Id for close item

#define XTP_ID_POPUP_CLOSE -1
File

XTPPopupItem.h

Group

Macros


Files

Files, Standard Controls
Files
Files
File | Description
XTAnimationMemDC.h | XTAnimationMemDC.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTBrowseDialog.h | XTBrowseDialog.h: interface for the CXTBrowseDialog class.
XTBrowseEdit.h | XTBrowseEdit.h : interface for the CXTBrowseEdit class.
XTButton.h | XTButton.h : interface for the CXTButton class.
XTButtonTheme.h | XTButtonTheme.h: interface for the CXTButtonTheme class.
XTCaption.h | XTCaption.h : interface for the CXTCaption class.
XTCaptionPopupWnd.h | XTCaptionPopupWnd.h : interface for the CXTCaptionPopupWnd class.
XTCaptionTheme.h | XTCaptionTheme.h: interface for the CXTCaptionTheme class.
XTCheckListBox.h | XTCheckListBox.h : interface for the CXTCheckListBox class.
XTColorDialog.h | XTColorDialog.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPageCustom.h | XTColorPageCustom.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPageStandard.h | XTColorPageStandard.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPicker.h | XTColorPicker.h : interface for the CXTColorPicker class.
XTColorPopup.h | XTColorPopup.h : interface for the CXTColorPopup class.
XTColorRef.h | XTColorRef.h: interface for the CXTColorRef class.
XTColorSelectorCtrl.h | XTColorSelectorCtrl.h : interface for the CXTColorSelectorCtrl class.
XTComboBoxEx.h | XTComboBoxEx.h : interface for the CXTComboBoxEx class.
XTDateTimeCtrl.h | XTDateTimeCtrl.h interface for the CXTDateTimeCtrl class.
XTDefines.h | XTDefines.h interface for the CXTAuxData struct.
XTDirWatcher.h | XTDirWatcher.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTDropSource.h | XTDropSource.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTEditListBox.h | XTEditListBox.h interface for the CXTEditListBox class.
XTExcelTabCtrl.h | XTExcelTabCtrl.h interface for the CXTExcelTabCtrl class.
XTExcelTabCtrlTheme.h | XTExcelTabCtrlTheme.h: interface for the CXTExcelTabCtrlTheme class.
XTFlatComboBox.h | XTFlatComboBox.h interface for the CXTFlatComboBox class.
XTFlatControlsTheme.h | XTFlatControlsTheme.h: interface for the CXTFlatComboBoxTheme class.
XTFontCombo.h | XTFontCombo.h interface for the CXTFontCombo class.
XTFunctions.h | XTFunctions.h : global functions.
XTGlobal.h | XTGlobal.h interface for the CXTAuxData struct.
XTHeaderCtrl.h | XTHeaderCtrl.h interface for the CXTFlatHeaderCtrl class.
XTHeaderCtrlTheme.h | XTHeaderCtrlTheme.h: interface for the CXTHeaderCtrlTheme class.
XTHelpers.h | XTHelpers.h interface This file is a part of the XTREME CONTROLS MFC class library.
XTHexEdit.h | XTHexEdit.h interface for the CXTHexEdit class.
XTHtmlView.h | XTHtmlView.h interface for the CXTHtmlView class.
XTHyperLink.h | XTHyperLink.h interface for the CXTHyperLink class.
XTListBase.h | XTListBase.h interface for the CXTListCtrl class.
XTListBox.h | XTListBox.h interface for the CXTListBox class.
XTListCtrlView.h | XTListCtrlView.h interface for the CXTListView and CXTListCtrlView class.
XTMaskEdit.h | XTMaskEdit.h interface for the CXTMaskEdit class.
XTMDIWndTab.h | XTMDIWndTab.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTMemDC.h | XTMemDC.h interface for the CXTMemDC class.
XTMemFile.h | XTMemFile.h interface for the CXTMemFile class.
XTMenuListBox.h | XTMenuListBox.h interface for the CXTMenuListBox class.
XTMenuListBoxTheme.h | XTMenuListBoxTheme.h: interface for the CXTMenuListBoxTheme class.
XTNotify.h | XTNotify.h : notification handlers This file is a part of the XTREME CONTROLS MFC class library.
XTOutBarCtrl.h | XTOutBarCtrl.h interface for the CXTOutBarCtrl class.
XTOutBarCtrlTheme.h | XTOutBarCtrlTheme.h: interface for the CXTOutBarCtrlTheme class.
XTPagerCtrl.h | XTPagerCtrl.h interface for the CXTPagerCtrl class.
XTPPopupControl.h | XTPPopupControl.h: interface for the CXTPPopupControl class.
XTPPopupItem.h | XTPPopupItem.h: interface for the CXTPPopupItem class.
XTPPopupPaintManager.h | XTPPopupPaintManager.h: interface for the CXTPPopupPaintManager class.
XTPPropertyPage.h | XTPPropertyPage.h : interface for the CXTPPropertyPage class.
XTPPropertyPageNavigator.h | XTPPropertyPageNavigator.h : interface for the CXTPPropertyPageNavigator class.
XTPPropertySheet.h | XTPPropertySheet.h : interface for the CXTPPropertySheet class.
XTPTaskDialog.h | XTPTaskDialog.h: interface for the CXTPTaskDialog class.
XTRegistryManager.h | XTRegistryManager.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTResize.h | XTResize.h: interface for the CXTResize class.
XTResizeDialog.h | XTResizeDialog.h: interface for the CXTResizeDialog class.
XTResizeFormView.h | XTResizeFormView.h: interface for the CXTResizeFormView class.
XTResizeGroupBox.h | XTResizeGroupBox.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTResizePoint.h | XTResizePoint.h: interface for the CXTResizePoint class.
XTResizePropertyPage.h | XTResizePropertyPage.h: interface for the CXTResizePropertyPage class.
XTResizePropertySheet.h | XTResizePropertySheet.h: interface for the CXTResizePropertySheet class.
XTResizeRect.h | XTResizeRect.h: interface for the CXTResizeRect class.
XTSearchOptionsCtrl.h | XTSearchOptionsCtrl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellListBase.h | XTShellListBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellListCtrlView.h | XTShellListCtrlView.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellPidl.h | XTShellPidl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellSettings.h | XTShellSettings.h: interface for the CXTShellSettings class.
XTShellTreeBase.h | XTShellTreeBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellTreeCtrlView.h | XTShellTreeCtrl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTSortClass.h | XTSortClass.h interface for the CXTSortClass class.
XTSplitterWnd.h | XTSplitterWnd.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTSplitterWndTheme.h | XTSplitterWndTheme.h: interface for the CXTSplitterWndTheme class.
XTTabBase.h | XTTabBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTTabBaseTheme.h | XTTabBaseTheme.h: interface for the CXTTabBaseTheme class.
XTTabCtrl.h | XTTabCtrl.h interface for the CXTTabCtrl class.
XTTabCtrlButtons.h | XTTabCtrlbuttons.h : interface for the CXTTabCtrlbuttons class.
XTTabView.h | XTTabView.h interface for the CXTTabView class.
XTThemeManager.h | XTThemeManager.h: interface for the CXTThemeManager class.
XTTipOfTheDay.h | XTTipOfTheDay.h interface for the CXTTipOfTheDay class.
XTTipWindow.h | XTTipWindow.h interface for the CXTTipWindow class.
XTTrayIcon.h | XTTrayIcon.h: interface for the CXTTrayIcon class.
XTTreeBase.h | XTTreeBase.h interface for the CXTTreeBase class.
XTTreeCtrlView.h | XTTreeView.h interface for the CXTTreeView class.
XTUtil.h | XTUtil.h: interface for utility classes.
XTVC50Helpers.h | XTVC50Helpers.h : Visual C++ 5.0 helpers This file is a part of the XTREME CONTROLS MFC class library.
XTWindowList.h | XTWindowList.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTWindowPos.h | XTWindowPos.h interface for the CXTWindowPos class.
Module

Standard Controls


XTAnimationMemDC.h

Classes, Enumerations, Files, Legend
XTAnimationMemDC.h

XTAnimationMemDC.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTAnimationMemDC | CXTAnimationMemDC is a CXTMemDC derived class. This class can be used to render animation effects for the current device context.
Enumerations
Enumeration | Description
XTAnimationType | Enumeration used to determine animation style.
Group

Files

Legend
Enumeration


XTBrowseDialog.h

Classes, Files
XTBrowseDialog.h

XTBrowseDialog.h: interface for the CXTBrowseDialog class.

Classes
Class | Description
CXTBrowseDialog | CXTBrowseDialog is derived from the BROWSEINFO structure. It is used to display a directory chooser dialog using shell extensions.
Group

Files


XTBrowseEdit.h

Classes, Files, Variables
XTBrowseEdit.h

XTBrowseEdit.h : interface for the CXTBrowseEdit class.

Classes
Class | Description
CXTBrowseButton | CXTBrowseButton is a CXTButton derived class that is used by CXTBrowseEdit to create the browse button that is used to display file dialogs and popup menus.
CXTBrowseEdit | CXTBrowseEdit is a CXTEdit derived class. This class also has a push button associated with it. The control can be used to search for directories and files or activate a popup menu.
CXTItemEdit | CXTItemEdit is a CXTBrowseEdit derived class. It is used to create a CXTItemEdit window that can be used as an "in-place" edit field that can be dynamically created for controls such as a list box.
Group

Files

Variables
Variable | Description
BES_XT_BROWSE | Display a user defined dialog for browsing
BES_XT_CHOOSEDIR | This member function is called to initialize the browse edit control.
BES_XT_CHOOSEFILE | This member function is called to initialize the browse edit control.
BES_XT_POPUPMENU | This member function is called to initialize the browse edit control.


XTButton.h

Classes, Files, Variables
XTButton.h

XTButton.h : interface for the CXTButton class.

Classes
Class | Description
CXTButton | CXTButton is a CButton derived class. It is used to create flat style and image buttons. This control has several features including flat, semi-flat, and three dimensional borders.
Group

Files

Variables
Variable | Description
BS_XT_FLAT | This member function will set the display style for the button.
BS_XT_FLAT_ANY | This member function will set the display style for the button.
BS_XT_HILITEPRESSED | This member function will set the display style for the button.
BS_XT_SEMIFLAT | This member function will set the display style for the button.
BS_XT_SHOWFOCUS | This member function will set the display style for the button.
BS_XT_TWOROWS | This member function will set the display style for the button.
BS_XT_WINXP_COMPAT | This member function will set the display style for the button.
BS_XT_XPFLAT | This member function will set the display style for the button.


XTButtonTheme.h

Classes, Files
XTButtonTheme.h

XTButtonTheme.h: interface for the CXTButtonTheme class.

Classes
Class | Description
CXTButtonTheme | CXTButtonTheme is used to draw the CXTButton object. All themes used for CXTButton should inherit from this base class.
CXTButtonThemeOffice2003 | CXTButtonThemeOffice2003 is a CXTButtonThemeOfficeXP derived class that is used to draw an Office 2003 style theme for the button.
CXTButtonThemeOfficeXP | CXTButtonThemeOfficeXP is a CXTButtonTheme derived class that is used to draw an Office XP style theme for the button.
CXTDisabledButtonTheme | CXTDisabledButtonTheme is a CXTButtonTheme derived class that is used to draw 3D disabled icons for the button.
CXTToolbarButtonTheme | CXTToolbarButtonTheme is a CXTDisabledButtonTheme derived class that is used to draw Windows XP style toolbar theme for the button.
Group

Files


XTCaption.h

Classes, Files, Variables
XTCaption.h

XTCaption.h : interface for the CXTCaption class.

Classes
Class | Description
CXTCaption | CXTCaption is a CStatic derived class. It is used to create caption or info bars similar to those in Microsoft(r) Outlook.
CXTCaptionButton | CXTCaptionButton is a CXTButton derived class. It is used by the CXTCaption class to activate a CXTCaptionPopupWnd window.
Group

Files

Variables
Variable | Description
CPWS_EX_CLOSEBUTTON | Creates and initializes the child window associated with the CXTCaption object.
CPWS_EX_GROOVE_EDGE | Creates and initializes the child window associated with the CXTCaption object.
CPWS_EX_RAISED_EDGE | Creates and initializes the child window associated with the CXTCaption object.


XTCaptionPopupWnd.h

Classes, Files
XTCaptionPopupWnd.h

XTCaptionPopupWnd.h : interface for the CXTCaptionPopupWnd class.

Classes
Class | Description
CXTCaptionPopupWnd | CXTCaptionPopupWnd is a CWnd derived class. It is used by the CXTCaption class to display a popup child window similar to Outlook(tm).
Group

Files


XTCaptionTheme.h

Classes, Files
XTCaptionTheme.h

XTCaptionTheme.h: interface for the CXTCaptionTheme class.

Classes
Class | Description
CXTCaptionButtonTheme | CXTCaptionButtonTheme is derived from CXTButtonTheme. This class is used to set the caption for buttons.
CXTCaptionButtonThemeOffice2003 | Class CXTCaptionButtonThemeOffice2003 is a CXTButtonThemeOffice2003 derived class. This class is used to create a button caption that resembles an Office 2003 button caption.
CXTCaptionButtonThemeOfficeXP | Class CXTCaptionButtonThemeOfficeXP is a CXTButtonThemeOfficeXP derived class. This class is used to create a button caption that resembles an Office XP button caption.
CXTCaptionTheme | CXTCaptionTheme is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.
CXTCaptionThemeOffice2003 | CXTCaptionThemeOffice2003 is derived from CXTCaptionTheme. It is used to set the caption to the Office 2003 theme.
CXTCaptionThemeOfficeXP | CXTCaptionThemeOfficeXP is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.
Group

Files


XTCheckListBox.h

Classes, Files
XTCheckListBox.h

XTCheckListBox.h : interface for the CXTCheckListBox class.

Classes
Class | Description
CXTCheckListBox | The CXTCheckListBox class is a CXTListBox derived class. It provides the functionality of Office style checklist box. A "checklist box" displays a list of items such as filenames. Each item in the list has a check box next to it that the user can either check or clear.
Group

Files


XTColorDialog.h

Classes, Files, Variables
XTColorDialog.h

XTColorDialog.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTColorDialog | CXTColorDialog is a CPropertySheet derived class. It is an Office(tm) style color dialog and can be used as a drop in replacement for the MFC CColorDialog API.
Group

Files

Variables
Variable | Description
CPS_XT_SHOW3DSELECTION | Constructs a CXTColorDialog object
CPS_XT_SHOWHEXVALUE | Constructs a CXTColorDialog object


XTColorPageCustom.h

Classes, Files
XTColorPageCustom.h

XTColorPageCustom.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTColorBase | CXTColorBase is a CStatic derived base class. It is used to create custom color selection windows.
CXTColorLum | CXTColorLum is a CXTColorBase derived class. It is used to create a color luminance selection bar.
CXTColorPageCustom | CXTColorPageCustom is derived from CXTThemePropertyPage. It is used to create a CXTColorPageCustom dialog.
CXTColorWnd | CXTColorWnd is a CXTColorBase derived class. It is used to create a color selection window.
Group

Files


XTColorPageStandard.h

Classes, Files
XTColorPageStandard.h

XTColorPageStandard.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTColorHex | CXTColorHex is a CStatic derived class. It displays a color selection grid used by CXTColorPageStandard.
CXTColorPageStandard | CXTColorPageStandard is derived from CXTThemePropertyPage, it is used to create a CXTColorPageStandard dialog.
Group

Files


XTColorPicker.h

Classes, Functions, Files, Legend
XTColorPicker.h

XTColorPicker.h : interface for the CXTColorPicker class.

Classes
Class | Description
CXTColorPicker | CXTColorPicker is a CXTButton derived class. It displays a color picker popup window (CXTColorPopup) for Office(tm) style color selection.
Functions
Function | Description
DDX_XTColorPicker | The DDX_XTColorPicker function manages the transfer of integer data between a color picker control in a dialog box, form view, or control view object and a COLORREF data member of the dialog box, form view, or control view object. When DDX_XTColorPicker is called, 'value' is set to the current state of the color picker control.
Group

Files

Legend
Method


XTColorPopup.h

Classes, Files
XTColorPopup.h

XTColorPopup.h : interface for the CXTColorPopup class.

Classes
Class | Description
CXTColorPopup | CXTColorPopup is a CXTColorSelectorCtrl derived class. It is used to create a CXTColorPopup window that will allow a user to select colors and add custom colors to a color list.
Group

Files


XTColorRef.h

Classes, Files
XTColorRef.h

XTColorRef.h: interface for the CXTColorRef class.

Classes
Class | Description
CXTColorRef | CXTColorRef is a stand alone class. It is used to create a CXTColorRef object. This object is used for manipulation of RGB values.
Group

Files


XTColorSelectorCtrl.h

Classes, Files, Legend, Variables, Structures
XTColorSelectorCtrl.h

XTColorSelectorCtrl.h : interface for the CXTColorSelectorCtrl class.

Classes
Class | Description
CXTColorSelectorCtrl | CXTColorSelectorCtrl is a CWnd derived class. It is used to create a CXTColorSelectorCtrl control that will allow a user to select colors.
CXTColorSelectorCtrlTheme | CXTColorSelectorCtrlTheme is derived from CXTThemeManagerStyle to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorSelectorCtrlThemeOffice2003 | CXTColorSelectorCtrlThemeOffice2003 is derived from CXTColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorSelectorCtrlThemeOfficeXP | CXTColorSelectorCtrlThemeOfficeXP is derived from CXTColorSelectorCtrlTheme to handle theme specific visualizations for the CXTColorSelectorCtrl class.
Group

Files

Variables
Variable | Description
CPS_XT_EXTENDED | This member function handles the creation of the color popup window.
CPS_XT_MORECOLORS | This member function handles the creation of the color popup window.
CPS_XT_NOAUTOMATIC | This member function handles the creation of the color popup window.
CPS_XT_NOFILL | This member function handles the creation of the color popup window.
CPS_XT_RIGHTALIGN | This member function handles the creation of the color popup window.
CPS_XT_USERCOLORS | This member function handles the creation of the color popup window.
Legend
Structure
Structures
Structure | Description
XTP_PICK_BUTTON | XTP_PICK_BUTTON structure is used by the CXTColorSelectorCtrl class to support custom colors.


XTComboBoxEx.h

Classes, Files
XTComboBoxEx.h

XTComboBoxEx.h : interface for the CXTComboBoxEx class.

Classes
Class | Description
CXTComboBoxEx | The CXTComboBoxEx class is a CComboBox derived class. It extends the combo box control by providing support for image lists.
Group

Files


XTDateTimeCtrl.h

Classes, Functions, Files, Legend
XTDateTimeCtrl.h

XTDateTimeCtrl.h interface for the CXTDateTimeCtrl class.

Classes
Class | Description
CXTDateTimeCtrl | CXTDateTimeCtrl is a CWnd derived class. A CXTDateTimeCtrl object encapsulates the functionality of a date and time picker control.
CXTMonthCalCtrl | CXTMonthCalCtrl is a CWnd derived class. A CXTMonthCalCtrl object encapsulates the functionality of a month calendar control.
Functions
Function | Description
DDV_XTMinMaxDateTime | Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxDateTime | Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxMonth | Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxMonth | Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDX_XTDateTimeCtrl | The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object and a COleDateTime data member of the dialog box or form view object. When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.
DDX_XTDateTimeCtrl | The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object, and a CTime data member of the dialog box or form view object. When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.
DDX_XTMonthCalCtrl | The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl) in a dialog box, form view, or control view object, and a COleDateTime data member, of the dialog box, form view, or control view object. The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel. When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.
DDX_XTMonthCalCtrl | The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl), in a dialog box, form view, or control view object, and a CTime data member of the dialog box, form view, or control view object. The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel. When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.
Group

Files

Legend
Method


XTDefines.h

Enumerations, Files, Legend, Macros, Variables
XTDefines.h

XTDefines.h interface for the CXTAuxData struct.

Enumerations
Enumeration | Description
XTMouseState | Enumeration to determine mouse state.
Group

Files

Macros
Macro | Description
BTNS_WHOLEDROPDOWN | draw dropdown arrow, but without split arrow section
Variables
Variable | Description
CBRN_XT_DROPDOWN | The CBRN_XT_DROPDOWN message is sent to the CXTToolBar window whenever a dropdown event occurs in the CXTToolBar.
XTWM_ADDREBAR | The XTWM_ADDREBAR message is sent to a window whenever it is added to a CXTReBar control.
XTWM_QUERYHOTSPOT | CXTDockContext sends the XTWM_QUERYHOTSPOT message to a control bar to check if the control bar has a hot spot, a point that must match the position of the cursor.
XTWM_QUERYVISUALIZE | CXTDockContext sends the XTWM_QUERYVISUALIZE message to a control bar to check if the control bar shall be visualized while dragging or just a wire frame shall be rendered.
XTWM_REBAR_SIZECHILD | The XTWM_REBAR_SIZECHILD message is sent when CXTReBar control has resized the band in which the recipient resides.
Legend
Enumeration


XTDirWatcher.h

Classes, Files
XTDirWatcher.h

XTDirWatcher.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTDirWatcher | The CXTDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur.
Group

Files


XTDropSource.h

Classes, Files
XTDropSource.h

XTDropSource.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTDropSource | CXTDropSource class is derived from IDropSource. It is used by the shell list control to provide drag-and-drop operations in your application.
Group

Files


XTEditListBox.h

Classes, Files, Variables
XTEditListBox.h

XTEditListBox.h interface for the CXTEditListBox class.

Classes
Class | Description
CXTEditListBox | CXTEditListBox is a CXTListBox derived class. It is used to create an editable list box. This list box can be configured to display a toolbar for editing. You can define browse styles to search for files or folders. Each entry is made editable with a double mouse click.
CXTEditListBoxToolBar | CXTEditListBoxToolBar is a CStatic derived class. It used by the CXTEditListBox class to create a toolbar above the edit list box to display icons for editing.
Group

Files

Variables
Variable | Description
LBS_XT_BROWSE | Browse button
LBS_XT_BROWSE_ONLY | Browse button
LBS_XT_CHOOSEDIR | Sets the edit style for the edit list box.
LBS_XT_CHOOSEFILE | Sets the edit style for the edit list box.
LBS_XT_DEFAULT | Sets the edit style for the edit list box.
LBS_XT_HIDE_UP_DOWN | Hide Up/Down buttons
LBS_XT_NOTOOLBAR | Sets the edit style for the edit list box.
LBS_XT_ONLY_UP_DOWN | Only Up/Down buttons


XTExcelTabCtrl.h

Classes, Enumerations, Files, Legend, Variables
XTExcelTabCtrl.h

XTExcelTabCtrl.h interface for the CXTExcelTabCtrl class.

Classes
Class | Description
CXTExcelTabCtrl | CXTExcelTabCtrl is a CWnd derived class. It is used to create an Excel style sheet control. This control allows you to define if you want the control to have home, end, back, and next buttons.
CXTExcelTabCtrlButtonState | The CXTExcelTabCtrlButtonState class is used by the CXTExcelTabCtrl class to manage navigation button information. This class contains information about the state and command identifiers for the button.
Enumerations
Enumeration | Description
XTArrowIcon | Enumeration used to determine arrow button display.
Group

Files

Variables
Variable | Description
FTS_XT_BOTTOM | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_DEFAULT | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HASARROWS | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HASHOMEEND | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_HSCROLL | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_MASK | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
FTS_XT_TOOLTIPS | Creates a flat tab control and attaches it to an instance of a CXTExcelTabCtrl object.
Legend
Enumeration


XTExcelTabCtrlTheme.h

Classes, Files
XTExcelTabCtrlTheme.h

XTExcelTabCtrlTheme.h: interface for the CXTExcelTabCtrlTheme class.

Classes
Class | Description
CXTExcelTabCtrlTheme | CXTExcelTabCtrlTheme is used to draw the CXTExcelTabCtrl object. All themes used for CXTExcelTabCtrl should inherit from this base class.
CXTExcelTabCtrlThemeOffice2003 | CXTExcelTabCtrlThemeOffice2003 is used to draw the CXTExcelTabCtrl object.
CXTExcelTabCtrlThemeOfficeXP | CXTExcelTabCtrlThemeOfficeXP is used to draw the CXTExcelTabCtrl object.
Group

Files


XTFlatComboBox.h

Classes, Files
XTFlatComboBox.h

XTFlatComboBox.h interface for the CXTFlatComboBox class.

Classes
Class | Description
CXTEdit | CXTEdit is a CEdit derived class. The CXTEdit class provides the functionality of a Windows edit control. An edit control is a rectangular child window in which the user can enter text.
CXTFlatComboBox | CXTFlatComboBox is a CComboBox derived class. The CXTFlatComboBox class can easily give your application's standard CComboBox control the Flat Look that is seen in many of the Microsoft(r) Office(tm) products.
CXTFlatEdit | CXTFlatEdit is a CXTEdit derived class. The CXTFlatEdit class can easily give your application's standard CEdit control the flat look that is seen in many of the Microsoft(r) Office(tm) products.
Group

Files


XTFlatControlsTheme.h

Classes, Files
XTFlatControlsTheme.h

XTFlatControlsTheme.h: interface for the CXTFlatComboBoxTheme class.

Classes
Class | Description
CXTFlatComboBoxTheme | CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.
CXTFlatComboBoxThemeOffice2003 | CXTFlatComboBoxThemeOffice2003 class is derived from CXTFlatComboBoxThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.
CXTFlatComboBoxThemeOfficeXP | CXTFlatComboBoxThemeOfficeXP class is derived from CXTFlatComboBoxTheme. This class is used to create the Office 2000 Theme for flat controls.
CXTFlatEditTheme | CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.
CXTFlatEditThemeOffice2003 | CXTFlatEditThemeOffice2003 class is derived from CXTFlatEditThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.
CXTFlatEditThemeOfficeXP | CXTFlatEditThemeOfficeXP class is derived from CXTFlatEditTheme. This class is used to create the Office 2000 Theme for flat controls.
Group

Files


XTFontCombo.h

Classes, Enumerations, Files, Legend, Types
XTFontCombo.h

XTFontCombo.h interface for the CXTFontCombo class.

Classes
Class | Description
CXTFontCombo | CXTFontCombo is a CXTFlatComboBox derived class. It is used to create a combo box that displays a drop list of available fonts for your system. The fonts are displayed in their various styles.
CXTFontEnum | CXTFontEnum is a stand alone singleton font enumeration class. It is used to enumerate a list of fonts found installed for the operating system.
CXTFontListBox | CXTFontListBox is a CXTListBox derived class. It is used to create a font selection list box.
Enumerations
Enumeration | Description
XTFontStyle | Enumeration used to determine font display.
Group

Files

Types
Type | Description
CXTFontList | List used for enumerating CXTLogFont structures.
Legend
Enumeration


XTFunctions.h

Functions, Files, Legend
XTFunctions.h

XTFunctions.h : global functions.

Functions
Function | Description
XTFuncChangeWindowFont | The XTFuncChangeWindowFont function will set the font for the window specified by pWnd and all of the child windows owned by pWnd.
XTFuncChildWindowFromPoint | The XTFuncChildWindowFromPoint function will retrieve an HWND handle for the child window (if any) located directly under the cursor position specified by point.
XTFuncContextMenu | Call this member function to display a context menu that is compatible with both pro and standard versions.
XTFuncCreateView | Creates a view based on a CRuntimeClass object.
XTFuncDrawEmbossed | The XTFuncDrawEmbossed function will draw an embossed icon onto the specified device context from the image list imageList. It is typically used by toolbars and menus to draw a disabled icon in color.
XTFuncDrawShadedRect | Renders a shadow onto the specified device context.
XTFuncInitDLL | This member function will initialize the resources for the Xtreme Toolkit. If using the Xtreme Toolkit as an extension DLL within a regular DLL, add the following two lines to your stdafx.h file. This will give you access to the exported function InitXtremeExtDll():
XTFuncPathExists | The XTFuncPathExists function searches a directory for a file or subdirectory whose name matches the specified name.
Group

Files

Legend
Method


XTGlobal.h

Classes, Functions, Files, Legend
XTGlobal.h

XTGlobal.h interface for the CXTAuxData struct.

Classes
Class | Description
CXTAuxData | CXTAuxData is a stand alone global item data structure class. It is used by the toolkit to initialize and store resource and item data shared by all objects. Items include system colors, icons, fonts and OS flags.
CXTAuxDataTheme | The CXTAuxDataTheme class is used by the CXTAuxData class to provide backward compatibility with older versions that still use bXPMode to provide Office XP theme support.
CXTLogFont | CXTLogFont is a self initializing LOGFONT derived class. It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.
CXTNonClientMetrics | CXTNonClientMetrics is a self initializing NONCLIENTMETRICS derived class. It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.
CXTTcbItem | CXTTcbItem class is used to maintain information for a particular tab item in a CXTExcelTabCtrl, CXTTabCtrl and CXTTabView object.
Functions
Function | Description
XTAuxData | The XTAuxData function is used for access to the CXTAuxData class.
Group

Files

Legend
Method


XTHeaderCtrl.h

Classes, Files
XTHeaderCtrl.h

XTHeaderCtrl.h interface for the CXTFlatHeaderCtrl class.

Classes
Class | Description
CXTFlatHeaderCtrl | CXTFlatHeaderCtrl is a CHeaderCtrl derived class. It is used to create list box flat header controls that are similar to list box flat header controls seen in Visual Studio(tm) and Outlook(tm).
CXTHeaderCtrl | CXTHeaderCtrl is a CHeaderCtrl derived class. It is used to create a CXTHeaderCtrl window similar to CHeaderCtrl, but with additional functionality.
Group

Files


XTHeaderCtrlTheme.h

Classes, Files, Variables
XTHeaderCtrlTheme.h

XTHeaderCtrlTheme.h: interface for the CXTHeaderCtrlTheme class.

Classes
Class | Description
CXTHeaderCtrlTheme | CXTHeaderCtrlTheme is a theme class used to draw windows classic style theme for the header control.
CXTHeaderCtrlThemeExplorer | CXTHeaderCtrlThemeExplorer is a CXTHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control.
CXTHeaderCtrlThemeOffice2003 | CXTHeaderCtrlThemeOffice2003 is a CXTHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control.
CXTHeaderCtrlThemeOfficeXP | CXTHeaderCtrlThemeOfficeXP is a CXTHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control.
Group

Files

Variables
Variable | Description
XTTHEME_HOTTRACKING | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
XTTHEME_SORTARROW | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.
XTTHEME_WINXPTHEMES | Call this member function to set the desired XTTHEME_ drawing styles for the header theme.


XTHelpers.h

Classes, Files, Legend, Templates
XTHelpers.h

XTHelpers.h interface

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTContextBkColorHandler | Background color context handler
CXTContextBkModeHandler | Background mode context handler
CXTContextTextColorHandler | Text color context handler
CXTContextViewPortOrgHandler | Handles viewport origin
Group

Files

Templates
Template | Description
CXTContextObjectHandler | Safely selects object into device context
Legend
Template


XTHexEdit.h

Classes, Files
XTHexEdit.h

XTHexEdit.h interface for the CXTHexEdit class.

Classes
Class | Description
CXTHexEdit | CXTHexEdit is a CEdit derived class. It is used to create an edit control which will allow editing in hex display format.
Group

Files


XTHtmlView.h

Classes, Files
XTHtmlView.h

XTHtmlView.h interface for the CXTHtmlView class.

Classes
Class | Description
CXTHtmlView | CXTHtmlView is a CFormView derived class. The CXTHtmlView class provides the functionality of the WebBrowser control within the context of MFC's document/view architecture. The WebBrowser control is a window in which the user can browse sites on the World Wide Web as well as folders in the local file system and on a network. The WebBrowser control supports hyperlinking, Uniform Resource Locator (URL) navigation, and maintains a history list.
Group

Files


XTHyperLink.h

Classes, Files
XTHyperLink.h

XTHyperLink.h interface for the CXTHyperLink class.

Classes
Class | Description
CXTHyperLink | CXTHyperLink is a CStatic derived class. It is used to display a text string that is used as a hyperlink control. The link's active, hover, and selected color attributes are configurable.
Group

Files


XTListBase.h

Classes, Files
XTListBase.h

XTListBase.h interface for the CXTListCtrl class.

Classes
Class | Description
CXTListBase | CXTListBase is a non-inherited class. It implements the extended list control services provided by the Xtreme Toolkit list control classes.
Group

Files


XTListBox.h

Classes, Files
XTListBox.h

XTListBox.h interface for the CXTListBox class.

Classes
Class | Description
CXTListBox | CXTListBox is a CListBox derived class. CXTListBox extends the standard list box control to enable flicker free drawing.
Group

Files


XTListCtrlView.h

Classes, Files
XTListCtrlView.h

XTListCtrlView.h interface for the CXTListView and CXTListCtrlView class.

Classes
Class | Description
CXTListCtrl | CXTListCtrl is a multiple inheritance class derived from CListCtrl and CXTListBase. This class implements flat header and generic sorting routines. See CXTListBase for additional functionality.
CXTListView | CXTListView is a multiple inheritance class derived from CListView and CXTListBase. This class implements flat header and generic sorting routines.
Group

Files


XTMaskEdit.h

Classes, Functions, Files, Legend
XTMaskEdit.h

XTMaskEdit.h interface for the CXTMaskEdit class.

Classes
Class | Description
CXTDateEdit | CXTDateEdit is a CXTMaskEdit derived class. It is specifically geared toward editing date fields.
CXTMaskEdit | CXTMaskEdit is a CEdit derived class. It allows text masking to be applied to the control to format it for special editing restrictions.
CXTTimeEdit | CXTTimeEdit is a CXTDateEdit derived class. It is specifically geared toward editing time fields.
Functions
Function | Description
DDX_XTOleDateTime | The DDX_XTOleDateTime function manages the transfer of integer data between a date edit control, in a dialog box, form view, or control view object, and a COleDateTime data member of the dialog box, form view, or control view object. When DDX_XTOleDateTime is called, 'value' is set to the current state of the date edit control.
Group

Files

Legend
Method


XTMDIWndTab.h

Classes, Files
XTMDIWndTab.h

XTMDIWndTab.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTMDIClientWnd | CXTMDIClientWnd is a CWnd derived helper class for the CXTMDIWndTab tab control. This class routes messages sent to the client window back to the tab control.
CXTMDIWndTab | CXTMDIWndTab class is used for creating a tabbed MDI document interface.
Group

Files


XTMemDC.h

Classes, Files
XTMemDC.h

XTMemDC.h interface for the CXTMemDC class.

Classes
Class | Description
CXTMemDC | CXTMemDC is a CDC derived class. CXTMemDC is an extension of CDC that helps eliminate screen flicker when windows are resized, by painting to an off screen bitmap. The class then uses CDC::BitBlt to copy the bitmap back into the current device context after all items have been painted.
Group

Files


XTMemFile.h

Classes, Files
XTMemFile.h

XTMemFile.h interface for the CXTMemFile class.

Classes
Class | Description
CXTMemFile | CXTMemFile is a CMemFile derived class. It is used to create a CXTMemFile object to support memory files.
Group

Files


XTMenuListBox.h

Classes, Files
XTMenuListBox.h

XTMenuListBox.h interface for the CXTMenuListBox class.

Classes
Class | Description
CXTMenuListBox | CCXTMenuListBox is a CListBox derived class. It is used to implement an Outlook bar style control. It can only be used with the LBS_OWNERDRAWVARIABLE style bit set. This is a simpler version of CXTOutBarCtrl and does not allow for shortcut folders.
Group

Files


XTMenuListBoxTheme.h

Classes, Files
XTMenuListBoxTheme.h

XTMenuListBoxTheme.h: interface for the CXTMenuListBoxTheme class.

Classes
Class | Description
CXTMenuListBoxTheme | CXTMenuListBoxTheme is used to draw the CXTMenuListBox object. All themes used for CXTButton should inherit from this base class.
CXTMenuListBoxThemeOffice2003 | Class CXTMenuListBoxThemeOffice2003 is derived from CXTMenuListBoxThemeXP. This class is used to implement the Office 2003 theme for Menu List Boxes.
CXTMenuListBoxThemeOfficeXP | Class CXTMenuListBoxThemeOfficeXP is derived from CXTMenuListBoxTheme. This class is used to implement the Office XP theme for Menu List Boxes.
Group

Files


XTNotify.h

Files, Macros, Variables
XTNotify.h

XTNotify.h : notification handlers

This file is a part of the XTREME CONTROLS MFC class library.

Group

Files

Macros
Macro | Description
ON_BEN_XT_LABELEDITCANCEL | BEN_XT_LABELEDITCANCEL notification message handler.
ON_BEN_XT_LABELEDITEND | BEN_XT_LABELEDITEND notification message handler.
ON_CPN_XT_CLOSEUP | CPN_XT_CLOSEUP notification message handler.
ON_CPN_XT_DROPDOWN | CPN_XT_DROPDOWN notification message handler.
ON_CPN_XT_SELCHANGE | CPN_XT_SELCHANGE notification message handler.
ON_CPN_XT_SELENDCANCEL | CPN_XT_SELENDCANCEL notification message handler.
ON_CPN_XT_SELENDOK | CPN_XT_SELENDOK notification message handler.
ON_CPN_XT_SELNOFILL | CPN_XT_SELNOFILL notification message handler.
ON_LBN_XT_DELETEITEM | LBN_XT_DELETEITEM notification message handler.
ON_LBN_XT_LABELEDITCANCEL | LBN_XT_LABELEDITCANCEL notification message handler.
ON_LBN_XT_LABELEDITEND | LBN_XT_LABELEDITEND notification message handler.
ON_LBN_XT_MOVEITEMDOWN | LBN_XT_MOVEITEMDOWN notification message handler.
ON_LBN_XT_MOVEITEMUP | LBN_XT_MOVEITEMUP notification message handler.
ON_LBN_XT_NEWITEM | LBN_XT_NEWITEM notification message handler.
ON_LBN_XT_ONBROWSE |
ON_LBN_XT_PREDELETEITEM | LBN_XT_PREDELETEITEM notification message handler.
ON_LBN_XT_PRENEWITEM | LBN_XT_PRENEWITEM notification message handler.
ON_SON_XT_ITEMCONTRACT | SON_XT_ITEMCONTRACT notification message handler.
ON_SON_XT_ITEMCONTRACTING | SON_XT_ITEMCONTRACTING notification message handler.
ON_SON_XT_ITEMEXPAND | SON_XT_ITEMEXPAND notification message handler.
ON_SON_XT_ITEMEXPANDING | SON_XT_ITEMEXPANDING notification message handler.
Variables
Variable | Description
BEN_XT_LABELEDITCANCEL | BEN_XT_LABELEDITCANCEL notification message handler.
BEN_XT_LABELEDITEND | BEN_XT_LABELEDITEND notification message handler.
CPN_XT_CLOSEUP | CPN_XT_CLOSEUP notification message handler.
CPN_XT_DROPDOWN | CPN_XT_DROPDOWN notification message handler.
CPN_XT_SELCHANGE | CPN_XT_SELCHANGE notification message handler.
CPN_XT_SELENDCANCEL | CPN_XT_SELENDCANCEL notification message handler.
CPN_XT_SELENDOK | CPN_XT_SELENDOK notification message handler.
CPN_XT_SELNOFILL | CPN_XT_SELNOFILL notification message handler.
CPWN_XT_PUSHPINBUTTON | The CPWN_XT_PUSHPINBUTTON message is sent to the owner of a CXTCaptionPopupWnd whenever the push pin button selection has been made.
CPWN_XT_PUSHPINCANCEL | The CPWN_XT_PUSHPINCANCEL message is sent to the owner of a CXTCaptionPopupWnd whenever the push pin button selection has been canceled.
LBN_XT_DELETEITEM | LBN_XT_DELETEITEM notification message handler.
LBN_XT_LABELEDITCANCEL | LBN_XT_LABELEDITCANCEL notification message handler.
LBN_XT_LABELEDITEND | LBN_XT_LABELEDITEND notification message handler.
LBN_XT_MOVEITEMDOWN | LBN_XT_MOVEITEMDOWN notification message handler.
LBN_XT_MOVEITEMUP | LBN_XT_MOVEITEMUP notification message handler.
LBN_XT_NEWITEM | LBN_XT_NEWITEM notification message handler.
LBN_XT_PREDELETEITEM | LBN_XT_PREDELETEITEM notification message handler.
LBN_XT_PRENEWITEM | LBN_XT_PRENEWITEM notification message handler.
OBN_XT_BEGINDRAG | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DELETEFOLDER | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DELETEITEM | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_DRAGITEM | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_FOLDERCHANGE | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMCLICK | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMHOVER | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ITEMRCLICK | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ONGROUPENDEDIT | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
OBN_XT_ONLABELENDEDIT | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
SHN_XT_CONTENTSCHANGED | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_INETFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_NOFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_REFRESHFOLDER | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_REFRESHTREE | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_SELECTCHILD | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_SHELLMENU | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SHN_XT_TREESELCHANGE | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
SON_XT_ITEMCONTRACT | SON_XT_ITEMCONTRACT notification message handler.
SON_XT_ITEMCONTRACTING | SON_XT_ITEMCONTRACTING notification message handler.
SON_XT_ITEMEXPAND | SON_XT_ITEMEXPAND notification message handler.
SON_XT_ITEMEXPANDING | SON_XT_ITEMEXPANDING notification message handler.
TIN_XT_TRAYICON | The TIN_XT_TRAYICON message is sent to the CXTTrayIcon window's owner whenever a mouse event occurs in the CXTTrayIcon.
XTWM_OUTBAR_NOTIFY | The XTWM_OUTBAR_NOTIFY message is sent to the outlook bar owner window whenever an action occurs within the control.
XTWM_SHELL_NOTIFY | The XTWM_SHELL_NOTIFY message is sent to the CXTShellTreeCtrl or CXTShellListCtrl owner whenever an action occurs within the control.
XTWM_UPDATECOLOR | The XTWM_UPDATECOLOR message is used to send notification that the color selection has changed.


XTOutBarCtrl.h

Classes, Files, Legend, Variables, Structures
XTOutBarCtrl.h

XTOutBarCtrl.h interface for the CXTOutBarCtrl class.

Classes
Class | Description
CXTOutBarCtrl | CXTOutBarCtrl is a CWnd derived class. It is used to create a shortcut bar window similar to the shortcut bar seen in Outlook(tm).
CXTOutBarEditItem | CXTOutBarEditItem is a helper class derived from CXTEdit. It is used by CXTOutBarCtrl, an Outlook like control, to create an in-place edit box that is used to modify a folder or an item within the control.
CXTOutBarFolder | CXTOutBarFolder is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder specified in the Outlook bar control.
CXTOutBarItem | CXTOutBarItem is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder item specified in the Outlook bar control.
CXTToolBox | CXTToolBox is a CXTOutBarCtrl derived class. It is used to create a toolbox control similar to the toolbox control seen in VisualStudio.NET.
Group

Files

Variables
Variable | Description
OBS_XT_ADDGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_ANIMATION | Call this member function to modify an Outlook bar style.
OBS_XT_DEFAULT | Call this member function to modify an Outlook bar style.
OBS_XT_DRAGITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_EDITGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_EDITITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_LARGEICON | Call this member function to modify an Outlook bar style.
OBS_XT_REMOVEGROUPS | Call this member function to modify an Outlook bar style.
OBS_XT_REMOVEITEMS | Call this member function to modify an Outlook bar style.
OBS_XT_SELHIGHLIGHT | Call this member function to modify an Outlook bar style.
OBS_XT_SMALLICON | Call this member function to modify an Outlook bar style.
Legend
Structure
Structures
Structure | Description
XT_OUTBAR_INFO | XT_OUTBAR_INFO structure is used by by the CXTOutBarCtrl class to store and information for an Outlook bar folder or item.


XTOutBarCtrlTheme.h

Classes, Files
XTOutBarCtrlTheme.h

XTOutBarCtrlTheme.h: interface for the CXTOutBarCtrlTheme class.

Classes
Class | Description
CXTOutBarCtrlTheme | CXTOutBarCtrlTheme is used to draw the CXTOutBarCtrl object. All themes used for CXTOutBarCtrl should inherit from this base class.
CXTOutBarCtrlThemeOffice2003 | Class CXTOutBarCtrlThemeOffice2003 is derived form CXTOutBarCtrlThemeXP. This class is used to draw an OutBar with the Office XP theme.
CXTOutBarCtrlThemeOfficeXP | Class CXTOutBarCtrlThemeOfficeXP is derived form CXTOutBarCtrlTheme. This class is used to draw an OutBar with the Office XP theme.
Group

Files


XTPagerCtrl.h

Classes, Files
XTPagerCtrl.h

XTPagerCtrl.h interface for the CXTPagerCtrl class.

Classes
Class | Description
CXTPagerCtrl | CXTPagerCtrl is a CWnd derived class. It is used to contain and scroll another window, and wraps the windows pager API.
Group

Files


XTPPopupControl.h

Classes, Enumerations, Files, Legend, Variables
XTPPopupControl.h

XTPPopupControl.h: interface for the CXTPPopupControl class.

Classes
Class | Description
CXTPPopupControl | CXTPPopupControl is a class for control of popup window
Enumerations
Enumeration | Description
XTPPopupAnimation | Enumeration used to determine the popup window animation in use
XTPPopupPaintTheme | Enumeration used to determine the popup window theme in use
XTPPopupState | Enumeration used to determine a current popup window state
Group

Files

Variables
Variable | Description
XTP_PCN_ITEMCLICK | XTP_PCN_ITEMCLICK is used to indicate that the user clicked on a popup control item.
XTP_PCN_STATECHANGED | XTP_PCN_STATECHANGED is used to indicate that the state of popup control changed
XTPWM_POPUPCONTROL_NOTIFY | The XTPWM_POPUPCONTROL_NOTIFY message is sent to the CXTPPopupControl owner window whenever an action occurs within the CXTPPopupControl
Legend
Enumeration


XTPPopupItem.h

Classes, Enumerations, Files, Legend, Macros
XTPPopupItem.h

XTPPopupItem.h: interface for the CXTPPopupItem class.

Classes
Class | Description
CXTPPopupItem | CXTPPopupItem is a class used to management popup item object
Enumerations
Enumeration | Description
XTPPopupItemIcon | Enumeration used to determine the icon type of CXTPPopupItem.
Group

Files

Macros
Macro | Description
XTP_ID_POPUP_CLOSE | Cpecial Id for close item
Legend
Enumeration


XTPPopupPaintManager.h

Classes, Files
XTPPopupPaintManager.h

XTPPopupPaintManager.h: interface for the CXTPPopupPaintManager class.

Classes
Class | Description
CXTPPopupPaintManager | CXTPPopupPaintManager is a class used to perform specialized drawing tasks.
CXTPPopupThemeMSN | CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks.
CXTPPopupThemeOffice2000 | CXTPPopupThemeOffice2000 is a class used to perform Office2000 drawing tasks.
CXTPPopupThemeOffice2003 | CXTPPopupThemeOffice2003 is a class used to perform Office2003 drawing tasks.
CXTPPopupThemeOffice2007 | CXTPPopupThemeOffice2007 is a class used to perform Office2007 drawing tasks.
CXTPPopupThemeOfficeXP | CXTPPopupThemeOfficeXP is a class used to perform OfficeXP drawing tasks.
Group

Files


XTPPropertyPage.h

Classes, Files
XTPPropertyPage.h

XTPPropertyPage.h : interface for the CXTPPropertyPage class.

Classes
Class | Description
CXTPPropertyPage | CXTPPropertyPage is a CPropertyPage derived class Objects of class CPropertyPage represent individual pages of a property sheet
Group

Files


XTPPropertyPageNavigator.h

Classes, Files
XTPPropertyPageNavigator.h

XTPPropertyPageNavigator.h : interface for the CXTPPropertyPageNavigator class.

Classes
Class | Description
CXTPPropertyPageControlNavigator | CXTPPropertyPageControlNavigator is CXTPPropertyPageNavigator derived class It represents base control property page navigator
CXTPPropertyPageListNavigator | CXTPPropertyPageListNavigator is CXTListBox and CXTPPropertyPageControlNavigator derived class It represents list property page navigator
CXTPPropertyPageNavigator | CXTPPropertyPageNavigator is a standalone class CXTPPropertyPageNavigator represents base navigator object for CXTPPropertySheet
CXTPPropertyPageTabNavigator | CXTPPropertyPageTabNavigator is CXTPTabControl and CXTPPropertyPageNavigator derived class It represents tabbed property page navigator
CXTPPropertyPageTreeNavigator | CXTPPropertyPageTreeNavigator is CTreeCtrl and CXTPPropertyPageControlNavigator derived class It represents tree property page navigator
Group

Files


XTPPropertySheet.h

Classes, Enumerations, Files, Legend
XTPPropertySheet.h

XTPPropertySheet.h : interface for the CXTPPropertySheet class.

Classes
Class | Description
CXTPPropertySheet | CXTPPropertySheet is a CDialog derived class It represents property sheet, otherwise known as tab dialog box. A property sheet consists of a CXTPPropertySheet object and one or more CXTPPropertyPage objects.
Enumerations
Enumeration | Description
XTPPropertyPageBorder | XTPPropertyPageBorder is an enumeration used to set the client frame style drawn around the client of tabs.
Group

Files

Legend
Enumeration


XTPTaskDialog.h

Classes, Files
XTPTaskDialog.h

XTPTaskDialog.h: interface for the CXTPTaskDialog class.

Classes
Class | Description
CXTPTaskDialog | The CXTPTaskDialog class creates, displays, and operates a task dialog. A task dialog is similar to, while much more flexible than, a basic message box. The task dialog contains application-defined messages, title, verification check box, command links and push buttons, plus any combination of predefined icons and push buttons.
Group

Files


XTRegistryManager.h

Classes, Files
XTRegistryManager.h

XTRegistryManager.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTRegistryManager | CXTRegistryManager is a stand alone registry management class. You can use it to read and write values from your system's registry or an .INI file. Use CXTRegistryManager to read and write string, integer, and binary data to and from the registry. You can also specify an .INI file name, and have these values stored there instead.
Group

Files


XTResize.h

Classes, Enumerations, Files, Legend, Structures
XTResize.h

XTResize.h: interface for the CXTResize class.

Classes
Class | Description
CXTResize | CXTResize is a base class. It is used by resizing dialogs, property sheets, and form views. It acts as a manager to maintain size and location of the dialog and dialog items.
CXTResizeItem | CXTResizeItem is a stand alone helper class. It is used by CXTResize to maintain information about each item to be sized or moved.
CXTSizeIcon | The CXTSizeIcon class is a CStatic derived helper class. It is used by CXTResize to display the sizing grip in the lower right corner of a sizing window.
Enumerations
Enumeration | Description
XTResize | Enumeration used to determine attributes for resizing windows.
Group

Files

Legend
Structure
Enumeration
Structures
Structure | Description
XT_SIZING |


XTResizeDialog.h

Classes, Files
XTResizeDialog.h

XTResizeDialog.h: interface for the CXTResizeDialog class.

Classes
Class | Description
CXTResizeDialog | CXTResizeDialog is a multiple inheritance class derived from CDialog and CXTResize. CXTResizeDialog is used to create a resizable CDialog type object that allows its dialog items to be resized or moved dynamically.
Group

Files


XTResizeFormView.h

Classes, Files
XTResizeFormView.h

XTResizeFormView.h: interface for the CXTResizeFormView class.

Classes
Class | Description
CXTResizeFormView | CXTResizeFormView is a multiple inheritance class derived from CFormView and CXTResize. CXTResizeFormView is used to create a resizable CFormView type object that allows its form items to be resized or moved dynamically.
Group

Files


XTResizeGroupBox.h

Classes, Files
XTResizeGroupBox.h

XTResizeGroupBox.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTResizeGroupBox | CXTResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing. This class is intended to only be used as a group box and only used on a CXTResize window. You can subclass or create this object the way you would any CButton.
Group

Files


XTResizePoint.h

Classes, Files, Legend, Macros, Structures
XTResizePoint.h

XTResizePoint.h: interface for the CXTResizePoint class.

Classes
Class | Description
CXTResizePoint | CXTResizePoint is an XT_RESIZEPOINT structure derived class. The CXTResizePoint class is similar to the XT_RESIZEPOINT structure. It also includes member functions to manipulate CXTResizePoint and XT_RESIZEPOINT structures. A CXTResizePoint object can be used wherever an XT_RESIZEPOINT structure is used.
Group

Files

Macros
Macro | Description
SZ_BOTTOM_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_BOTTOM_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_BOTTOM_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
Legend
Structure
Structures
Structure | Description
XT_RESIZEPOINT | XT_RESIZEPOINT structure is used by the CXTResizePoint class for defining single -precision floating point x- and y-coordinates of a point.


XTResizePropertyPage.h

Classes, Files
XTResizePropertyPage.h

XTResizePropertyPage.h: interface for the CXTResizePropertyPage class.

Classes
Class | Description
CXTResizePropertyPage | CXTResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTResize. CXTResizePropertyPage is used to create a resizable CPropertyPage type object that allows its dialog items to be resized or moved dynamically.
Group

Files


XTResizePropertySheet.h

Classes, Files
XTResizePropertySheet.h

XTResizePropertySheet.h: interface for the CXTResizePropertySheet class.

Classes
Class | Description
CXTResizePropertySheet | CXTResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTResize. CXTResizePropertySheet is used to create a resizable CPropertySheet type object that allows its dialog items to be resized or moved dynamically.
Group

Files


XTResizeRect.h

Classes, Files, Legend, Macros, Types, Structures
XTResizeRect.h

XTResizeRect.h: interface for the CXTResizeRect class.

Classes
Class | Description
CXTResizeRect | CXTResizeRect is an XT_RESIZERECT structure derived class. The CXTResizeRect class is similar to an XT_RESIZERECT structure. CXTResizeRect also includes member functions to manipulate CXTResizeRect objects and XT_RESIZERECT structures.
Group

Files

Macros
Macro | Description
SZ_HORREPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_HORRESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_REPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_RESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_VERREPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_VERRESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
Types
Type | Description
XT_RESIZE | The XT_RESIZE data type is defined as a float and is used for storing single-precision floating point x and y window coordinates.
Legend
Structure
Structures
Structure | Description
XT_RESIZERECT | XT_RESIZERECT structure is used by the CXTResizeRect class for defining single -precision floating point coordinates of the upper-left and lower-right corners of a rectangle.


XTSearchOptionsCtrl.h

Classes, Files
XTSearchOptionsCtrl.h

XTSearchOptionsCtrl.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTSearchOptionsCtrl | CXTSearchOptionsCtrl is a CStatic derived class. CXTSearchOptionsCtrl is used to create a control similar to the Search Options item found in the search pane of Windows Explorer as it is seen in Windows 2000 and later. This class allows you to associate a group of controls to be hidden or shown when the item is expanded and contracted and a set of controls that need to move depending on the CXTSearchOptionsCtrl state. Use with CXTSearchOptionsView form view class to create a pane similar to the Windows Explorer search pane. To use the control, define a set of controls that... more
CXTSearchOptionsView | CXTSearchOptionsView is a CFormView derived class. It is to be used with a CXTSearchOptionsCtrl object to paint the background and control background color white. It is also used for resizing and moving children of the form automatically.
Group

Files


XTShellListBase.h

Classes, Files
XTShellListBase.h

XTShellListBase.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTShellListBase | CXTShellListBase is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListBase class object.
Group

Files


XTShellListCtrlView.h

Classes, Files
XTShellListCtrlView.h

XTShellListCtrlView.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTShellListCtrl | CXTShellListCtrl is a multiple inheritance class derived from CXTListCtrl and CXTShellPidl. It is used to create a CXTShellListCtrl window.
CXTShellListCtrlEx | CXTShellListCtrlEx is a CXTShellListCtrl derived class. It is used to create a stand-alone shell list control that is not dependent on a CXTShellTreeCtrl for initialization. It is used to create a CXTShellListCtrlEx window for displaying the contents of file folders.
CXTShellListView | CXTShellListView is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListView class object.
Group

Files


XTShellPidl.h

Classes, Files, Legend, Structures
XTShellPidl.h

XTShellPidl.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTShellPidl | CXTShellPidl is a stand alone base class. This class is used by the shell tree and list controls to handle PIDL creation and management.
Group

Files

Legend
Structure
Structures
Structure | Description
XT_LVITEMDATA | XT_LVITEMDATA structure is used to maintain information for a particular list item in a CXTShellListCtrl or CXTShellListView window.
XT_TVITEMDATA | XT_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTShellTreeCtrl or CXTShellTreeView window.


XTShellSettings.h

Classes, Files
XTShellSettings.h

XTShellSettings.h: interface for the CXTShellSettings class.

Classes
Class | Description
CXTShellSettings | CXTShellSettings is a SHELLFLAGSTATE struct derived class. CXTShellSettings extends the SHELLFLAGSTATE struct for easy access to the shell flag state settings.
Group

Files


XTShellTreeBase.h

Classes, Enumerations, Files, Legend, Macros
XTShellTreeBase.h

XTShellTreeBase.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTShellTreeBase | CXTShellTreeBase is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeBase class object.
Enumerations
Enumeration | Description
XTFindType | Enumeration used to determine folder or drive type.
Group

Files

Macros
Macro | Description
DECLATE_SHELLTREE_BASE | The DELCLATE_SHELLTREE_BASE class is a template class used by the CXTShellTreeView and CXTShellTreeCtrl class to declare a multiple inheritance base class so that both classes could share a common code base.
Legend
Enumeration


XTShellTreeCtrlView.h

Classes, Files
XTShellTreeCtrlView.h

XTShellTreeCtrl.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTShellTreeCtrl | CXTShellTreeCtrl is a multiple inheritance class derived from CXTTreeCtrl and CXTShellPidl. CXTShellTreeCtrl is used to create a tree control that displays an explorer style tree, and can be associated with a combo box and list control.
CXTShellTreeView | CXTShellTreeView is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeView class object.
Group

Files


XTSortClass.h

Classes, Enumerations, Files, Legend
XTSortClass.h

XTSortClass.h interface for the CXTSortClass class.

Classes
Class | Description
CXTSortClass | CXTSortClass is a stand alone class. This class will sort a list control by a column of text, integer, float or date/time type. It could be easily extended for other data types. To use this class, instantiate a CXTSortClass object, passing in a pointer to the list control as the first argument and the column index as the second argument.
Enumerations
Enumeration | Description
XTSortType | Enumeration used to determine sort type.
Group

Files

Legend
Enumeration


XTSplitterWnd.h

Classes, Files, Variables
XTSplitterWnd.h

XTSplitterWnd.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTSplitterWnd | CXTSplitterWnd is a CSplitterWnd derived class. It adds the ability to hide and show splitter panes based upon its index.
CXTSplitterWndEx | CXTSplitterWndEx is a CXTSplitterWnd derived class. It can be used with the CXTOutBarCtrl to display a gap between the top of the splitter and the toolbar area.
Group

Files

Variables
Variable | Description
XT_SPLIT_DOTTRACKER | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOBORDER | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOFULLDRAG | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.
XT_SPLIT_NOSIZE | Call this member function to modify a splitter window's style. Styles to be added or removed can be combined by using the bitwise OR (|) operator.


XTSplitterWndTheme.h

Classes, Files
XTSplitterWndTheme.h

XTSplitterWndTheme.h: interface for the CXTSplitterWndTheme class.

Classes
Class | Description
CXTSplitterWndTheme | Class CXTSplitterWndTheme is derived from CXTThemeManagerStyle. This class is used to apply a Theme to splitter windows.
CXTSplitterWndThemeOffice2003 | Class CXTSplitterWndThemeOffice2003 is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.
CXTSplitterWndThemeOfficeXP | Class CXTSplitterWndThemeOfficeXP is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.
Group

Files


XTTabBase.h

Classes, Enumerations, Files, Legend
XTTabBase.h

XTTabBase.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTTabBase | CXTTabBase is a stand alone base class. It is used to draw an XP style tab control.
CXTTabExBase | CXTTabExBase is a stand alone base class. It is used to draw an XP style tab control.
Enumerations
Enumeration | Description
XTNavBtnState | Enumeration used to determine navigation button display for a CXTTabCtrl object.
Group

Files

Legend
Enumeration


XTTabBaseTheme.h

Classes, Files
XTTabBaseTheme.h

XTTabBaseTheme.h: interface for the CXTTabBaseTheme class.

Classes
Class | Description
CXTTabBaseTheme | CXTTabBaseTheme is used to draw the CXTTabBase object. All themes used for CXTTabBase should inherit from this base class.
CXTTabBaseThemeOffice2003 | Class CXTTabBaseThemeOffice2003 is derived from CXTTabBaseThemeOfficeXP.
CXTTabBaseThemeOfficeXP | Class CXTTabBaseThemeOfficeXP is derived from CXTTabBaseTheme. This class is used to implement the office XP theme for the tab controls.
Group

Files


XTTabCtrl.h

Classes, Files
XTTabCtrl.h

XTTabCtrl.h interface for the CXTTabCtrl class.

Classes
Class | Description
CXTTabCtrl | CXTTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTTabCtrlBase. It is used to create a CXTTabCtrl class object. See CXTTabCtrlBase for additional functionality.
Group

Files


XTTabCtrlButtons.h

Classes, Files
XTTabCtrlButtons.h

XTTabCtrlbuttons.h : interface for the CXTTabCtrlbuttons class.

Classes
Class | Description
CXTTabCtrlButton | CXTTabCtrlButton is a stand alone structure class. It is internal used in CXTTabCtrlButtons class.
CXTTabCtrlButtons | CXTTabCtrlButtonsis a CWnd derived class. It is internally used in the CXTTabBase class.
Group

Files


XTTabView.h

Classes, Files
XTTabView.h

XTTabView.h interface for the CXTTabView class.

Classes
Class | Description
CXTTabView | CXTTabView is a multiple inheritance class derived from CCtrlView and CXTTabCtrlBaseEx. CXTTabView can be used to create a view that contains nested views displayed in a tab control. See CXTTabCtrlBaseEx for additional functionality.
Group

Files


XTThemeManager.h

Classes, Enumerations, Functions, Files, Legend, Macros
XTThemeManager.h

XTThemeManager.h: interface for the CXTThemeManager class.

Classes
Class | Description
CXTThemeManager | CXTThemeManager is standalone class used to manage the visual styles for your application.
CXTThemeManagerStyle | CXTThemeManagerStyle is standalone class used as base for any components theme.
CXTThemeManagerStyleFactory | CXTThemeManagerStyleFactory is CObject derived class. It managed themes of corresponded CXTThemeManagerStyleHost class
CXTThemeManagerStyleHost | CXTThemeManagerStyleHost is standalone class. It used as base class for all themed component.
Enumerations
Enumeration | Description
XTThemeStyle | Enumeration used to determine active theme.
Functions
Function | Description
XTThemeManager | The XTThemeManager function is used for access to the CXTThemeManager class.
Group

Files

Macros
Macro | Description
DECLARE_THEME_FACTORY | Use this macro to declare the factory class for specified theme
IMPLEMENT_THEME_FACTORY | Use this macro to implement factory class for specified theme.
Legend
Enumeration
Method


XTTipOfTheDay.h

Classes, Files
XTTipOfTheDay.h

XTTipOfTheDay.h interface for the CXTTipOfTheDay class.

Classes
Class | Description
CXTTipOfTheDay | CXTTipOfTheDay is a CDialog derived class. CXTTipOfTheDay is used to create a Visual Studio(tm) style Tip Of The Day dialog. To use, place a file called "tips.txt" in the same directory as your application exe. Place each tip on its own line.
Group

Files


XTTipWindow.h

Classes, Files, Variables
XTTipWindow.h

XTTipWindow.h interface for the CXTTipWindow class.

Classes
Class | Description
CXTTipWindow | CXTTipWindow is a CWnd derived class. It is used to create a CXTTipWindow object. CXTTipWindow objects are tooltip style popup windows that can display useful information to the end user. Possible options include shadows, borders, and background color settings.
Group

Files

Variables
Variable | Description
TWS_XT_ALPHASHADOW | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
TWS_XT_DROPSHADOW | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.
TWS_XT_THICKBORDER | This member function will display a tip window to display a title and description text. Returns TRUE if the tip window was successfully created, otherwise returns FALSE.


XTTrayIcon.h

Classes, Files
XTTrayIcon.h

XTTrayIcon.h: interface for the CXTTrayIcon class.

Classes
Class | Description
CXTTrayIcon | CXTTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure. It is used to display a system tray icon with animation.
Group

Files


XTTreeBase.h

Classes, Files, Variables
XTTreeBase.h

XTTreeBase.h interface for the CXTTreeBase class.

Classes
Class | Description
CXTTreeBase | CXTTreeBase is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.
Group

Files

Variables
Variable | Description
TVIS_FOCUSED | This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control. It sets the state of the item specified by hItem.


XTTreeCtrlView.h

Classes, Files
XTTreeCtrlView.h

XTTreeView.h interface for the CXTTreeView class.

Classes
Class | Description
CXTTreeCtrl | CXTTreeCtrl is a CTreeCtrl derived class. It extends the CTreeCtrl class to add additional functionality, including tree traversal, searching, color, and settings.
CXTTreeView | CXTTreeView is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.
Group

Files


XTUtil.h

Classes, Files
XTUtil.h

XTUtil.h: interface for utility classes.

Classes
Class | Description
CXTIconHandle | CXTIconHandle is a stand alone helper class. It is used to automatically destroy dynamically created hIcon handles.
CXTSplitPath | CXTSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension.
Group

Files


XTVC50Helpers.h

Classes, Files, Macros
XTVC50Helpers.h

XTVC50Helpers.h : Visual C++ 5.0 helpers

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTListViewHelper | The CXTListViewHelper class is a helper class that provides helper functions for finding selected items for the MFC CListView class.
Group

Files

Macros
Macro | Description
CXTHeaderCtrlHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CHeaderCtrl.
CXTListCtrlHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CListCtrl.
CXTStringHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CString.


XTWindowList.h

Classes, Files
XTWindowList.h

XTWindowList.h : header file

This file is a part of the XTREME CONTROLS MFC class library.

Classes
Class | Description
CXTWindowList | CXTWindowList dialog
Group

Files


XTWindowPos.h

Classes, Files
XTWindowPos.h

XTWindowPos.h interface for the CXTWindowPos class.

Classes
Class | Description
CXTWindowPos | CXTWindowPos is a WINDOWPLACEMENT structure derived class. It extends the WINDOWPLACEMENT structure, and is used to save and restore window position.
Group

Files


Calendar

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Functions, Macros, Structs, Records, Enums, Types, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Calendar

Codejock Software's Xtreme Calendar provides Windows developers with a sophisticated Office style Calendar.

Group

Xtreme Toolkit Pro v12.0

Legend
Template
Structure
Method
Enumeration
Classes
Class
Description
CXTPAutoResetValue
Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy. Can be useful to lock some data or actions via flags and unlock automatically.
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
CXTPCalendarController
Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object.
CXTPCalendarControlView
The CXTPCalendarControlView class provides an implementation of the Calendar control as view class. Use GetCalendarCtrl() method to access methods of CXTPCalendarControl
CXTPCalendarControlViewPrintOptions
Describes printing options for the Calendar Control.
CXTPCalendarCustomDataProvider
Custom implementation of XTPCalendarData based on notifications.
CXTPCalendarCustomProperties
This class is used to store properties collection.
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added,
CXTPCalendarDatabaseDataProvider
This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
CXTPCalendarEventCategories
This class is used as a collection of CXTPCalendarEventCategory objects.
CXTPCalendarEventCategory
This class define Calendar Event Category properties. Visual effects for Event Categories (event and day's cells background colors) implemented in Office 2007 theme only. If one or more categories set for event - the category's colors are used, otherwise label's colors used (is label defined). For Office 2003 theme label's colors used in any case.
CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs.
CXTPCalendarEventLabel
This class define Calendar Event label properties.
CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects.
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
CXTPCalendarIconIDs
This class represents the collection of custom icons IDs.
CXTPCalendarMAPIDataProvider
This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.
CXTPCalendarMAPIWrapper
The CXTPCalendarMAPIWrapper class wraps the mapi32.dll API.
CXTPCalendarMemoryDataProvider
This class implements an abstract representation of the data used in the XTPCalendarData class.
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
CXTPCalendarMonthViewGroup
This class represents a single resource view portion of the Calendar Month View.
CXTPCalendarOccurSeriesChooseDlg
This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern).
CXTPCalendarOptions
Structure contains all calendar options.
CXTPCalendarPageSetupDialog
Customized Calendar control page setup dialog.
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build schedule for recurrence events.
CXTPCalendarReminder
This class describes a reminder for calendar event and implements base properties and operations on reminder.
CXTPCalendarReminderForOccurrence
This structure describes a reminder for an occurrence of a recurrence event.
CXTPCalendarReminderForOccurrenceArray
This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it.
CXTPCalendarReminders
This class represents a simple array collection of CXTPCalendarReminder objects.
CXTPCalendarRemindersManager
This class is used to monitor and manage calendar events reminders. It will send notifications when active reminders list is changed - new reminder(s) come or some reminder(s) goes away.
CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of persons or resources.
CXTPCalendarResourceDescription
This class is a wrapper for CXTPCalendarResource class. It is needed for easier processing in scope of CXTPCalendarResourcesManager
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
CXTPCalendarResourcesManager
This class is used as helper to manage calendar resources (and schedules) data configurations.
CXTPCalendarResourcesNf
This class implements CXTPCalendarResource functionality with addition of notifications mechanism implemented by CXTPNotifySink.
CXTPCalendarSchedule
Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc).
This class implements base properties of the Schedule and operations on it.
CXTPCalendarSchedules
This class represents a simple array collection of CXTPCalendarSchedule objects.
CXTPCalendarThemeBOOLValue
Helper class provides functionality to manage customized BOOL value objects.
CXTPCalendarThemeCustomizableXValueT
Helper class template provides functionality to manage customized value for the specified type.
CXTPCalendarThemeFontValue
Helper class provides functionality to manage font value objects.
CXTPCalendarThemeIntValue
Helper class provides functionality to manage customized int value objects.
CXTPCalendarThemeRectValue
Helper class provides functionality to manage customized CRect value objects.
CXTPCalendarThemeStringValue
Helper class provides functionality to manage customized string value objects.
CXTPCalendarTimeScalePropertiesDlg
CXTPCalendarTimeScalePropertiesDlg dialog
This dialog allows to customize Calendar Time Scale part, set a proper time zone and it's description.
CXTPCalendarTimeZone
This class extend TIME_ZONE_INFORMATION structure.
CXTPCalendarTimeZones
This class represents a simple array collection of CXTPCalendarTimeZone objects.
CXTPCalendarTip
The CXTPCalendarTip class emulates the functionality of a "tool tip" control.
CXTPCalendarTypedPtrAutoDeleteArray
This class represents a simple array collection of objects pointers.
CXTPCalendarTypedPtrAutoDeleteMap
This class represents a simple map of typed keys to typed objects pointers. Overridden methods SetAt, operator[], RemoveKey, RemoveAll, call delete for previously stored elements.
CXTPCalendarUIntArray
This class represents the collection of UINT elements.
CXTPCalendarUtils
Helper class with static member functions to perform common tasks with dates, events and other objects.
CXTPCalendarView
This class represents the view portion of the Calendar control.
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
CXTPCalendarViewDayT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class.
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
CXTPCalendarViewEvents
This class used as collection of Event View object.
CXTPCalendarViewEventSubjectEditor
This class is used to edit event subject.
CXTPCalendarViewEventSubjectEditor2007
This class is used to edit event subject in Office 2007 Theme.
CXTPCalendarViewEventT
This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.
CXTPCalendarViewGroup
Regular schema:

  • CalendarView consists of CalendarView(s)Day
  • CalendarViewDay consists of CalendarView(s)Resource
  • CalendarViewGroup contains CalendarView(s)Event

ViewGroup draws a single resource depending on the type of parent day view.

CXTPCalendarViewGroupT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class.
CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager. objects.
CXTPCalendarViewPartBrushValue
Helper class provides functionality to manage brush value objects.
CXTPCalendarViewPartCustomizableValueT
Helper class template provides functionality to manage customized value for the specified class objects.
CXTPCalendarViewPartFontValue
Helper class provides functionality to manage font settings for various graphical elements of control.
CXTPCalendarViewT
This template class represents a view portion of the Calendar control.
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView.
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
CXTPCalendarWeekViewGroup
This class represents a single resource view portion of the Calendar Week View.
CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
CXTPDatePickerButton
This class represents a DatePicker button.
CXTPDatePickerButtons
Class CXTPDatePickerButtons represents a collection of buttons.
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
CXTPDatePickerDaysCollection
CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
CXTPDatePickerList
This class provides the functionality of a list control which displays month names.
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
CXTPDatePickerTheme
Abstract class CXTPDatePickerTheme is derived from CXTPDatePickerPaintManager and handles most of the drawing activities for the DatePicker control. This class must be used as a base to create different themes implementations (like CXTPDatePickerThemeOffice2007).
CXTPDatePickerThemeOffice2007
Class CXTPDatePickerThemeOffice2007 is derived from CXTPDatePickerTheme is implement Office 2007 style for DatePicker control.
CXTPTopLevelWndMsgNotifier
This class is used to catch windows messages, which system sends to top-level windows and to send them to subscribers windows. The following messages are supported: WM_TIMECHANGE WM_SYSCOLORCHANGE
XTP_CALENDAR_RECURRENCE_OPTIONS
This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data.
XTP_DAYITEM_METRICS
This structure represents a set of parameters which are used to display day items.

  1. There could be customized foreground and background colors.
  2. Also you can text font for the displayed day text.
  3. And as the last thing you can customize a day picture displayed there, using OLE PICTUREDISP interface and OleSetPicture method.

Files
File | Description
XTPCalendarControl.h | XTPCalendarControl.h: interface for the CXTPCalendarControl class.
XTPCalendarController.h | XTPCalendarController.h: interface for the CXTPCalendarController class.
XTPCalendarControlView.h | XTPCalendarControlView.h: interface for the CXTPCalendarControlView class.
XTPCalendarCustomDataProvider.h | XTPCalendarCustomDataProvider.h: interface for the CXTPCalendarCustomProperties class.
XTPCalendarCustomProperties.h | XTPCalendarCustomProperties.h: interface for the CXTPCalendarCustomProperties class.
XTPCalendarData.h | XTPCalendarData.h: interface for the CXTPCalendarData class.
XTPCalendarDatabaseDataProvider.h | XTPCalendarDatabaseDataProvider.h: interface for the CXTPCalendarDatabaseDataProvider class.
XTPCalendarDayView.h | XTPCalendarDayView.h: interface for the CXTPCalendarDayView class.
XTPCalendarDayViewDay.h | XTPCalendarDayViewDay.h: interface for the CXTPCalendarDayViewDay class.
XTPCalendarDayViewEvent.h | XTPCalendarDayViewEvent.h: interface for the CXTPCalendarDayViewEvent class.
XTPCalendarDayViewTimeScale.h | XTPCalendarDayViewTimeScale.h: interface for the CXTPCalendarDayViewTimeScale class.
XTPCalendarDefines.h | XTPCalendarDefines.h: interface for the CXTPCalendarEvent class.
XTPCalendarEvent.h | XTPCalendarEvent.h: interface for the CXTPCalendarEvent class.
XTPCalendarEventLabel.h | XTPCalendarEventLabel.h: interface for the CXTPCalendarEventLabel and CXTPCalendarEventLabels classes.
XTPCalendarEvents.h | XTPCalendarEvents.h: CXTPCalendarEvents template.
XTPCalendarMAPIDataProvider.h | XTPCalendarMAPIDataProvider.h: interface for the CXTPCalendarData class.
XTPCalendarMAPIWrapper.h | XTPCalendarMAPIWrapper.h: interface for the CXTPCalendarMAPIWrapper class.
XTPCalendarMemoryDataProvider.h | XTPCalendarMemoryDataProvider.h: interface for the CXTPCalendarMemoryDataProvider class.
XTPCalendarMonthView.h | XTPCalendarMonthView.h: interface for the CXTPCalendarMonthView class.
XTPCalendarMonthViewDay.h | XTPCalendarMonthViewDay.h: interface for the CXTPCalendarMonthViewDay class.
XTPCalendarMonthViewEvent.h | XTPCalendarMonthViewEvent.h: interface for the CXTPCalendarMonthViewEvent class.
XTPCalendarNotifications.h | XTPCalendarNotifications.h: unique notifications identifiers for CXTPCalendarControl class.
XTPCalendarOccurSeriesChooseDlg.h | XTPCalendarOccurSeriesChooseDlg.h interface for CXTPCalendarOccurSeriesChooseDlg class.
XTPCalendarOptions.h | XTPCalendarOptions.h: interface for the CXTPCalendarOptions class.
XTPCalendarPaintManager.h | XTPCalendarControlPaintManager.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarPtrCollectionT.h | XTPCalendarPtrCollectionT.h: CXTPCalendarPtrCollectionT template.
XTPCalendarPtrs.h | XtpCalendarPtrs.h: This file is a part of the XTREME CALENDAR MFC class library.
XTPCalendarRecurrencePattern.h | XTPCalendarRecurrencePattern.h: interface for the CXTPCalendarRecurrencePattern class.
XTPCalendarRemindersManager.h | XTPCalendarRemindersManager.h: interface for the CXTPCalendarRemindersManager class.
XTPCalendarResource.h | XTPCalendarResource.h: interface for the CXTPCalendarResource class.
XTPCalendarResourcesManager.h | XTPCalendarResourcesManager.h: interface for the CXTPCalendarResourcesManager class.
XTPCalendarTheme.h | XTPCalendarTheme.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarThemeOffice2007.h | XTPCalendarThemeOffice2007.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarTimeZoneHelper.h | XTPCalendarTimeZoneHelper.h: interfaces for Time Zone Helper classes.
XTPCalendarTip.h | XTPCalendarTip.h: interface for the CXTPCalendarTip class.
XTPCalendarUtils.h | XTPCalendarUtils.h: interface for the CXTPCalendarUtils class.
XTPCalendarView.h | XTPCalendarView.h: interface for the CXTPCalendarView class.
XTPCalendarViewDay.h | XTPCalendarViewDay.h: interface for the CXTPCalendarViewDay class.
XTPCalendarViewEvent.h | XTPCalendarViewEvent.h: interface for the CXTPCalendarViewEvent class.
XTPCalendarViewPart.h | XTPCalendarViewPart.h: interface for the CXTPCalendarViewPart class.
XTPCalendarWeekView.h | XTPCalendarWeekView.h: interface for the CXTPCalendarWeekView class.
XTPCalendarWeekViewDay.h | XTPCalendarWeekViewDay.h: interface for the CXTPCalendarWeekViewDay class.
XTPCalendarWeekViewEvent.h | XTPCalendarWeekViewEvent.h: interface for the CXTPCalendarWeekViewEvent class.
XTPDatePickerControl.h | XTPDatePickerControl.h: interface for the CXTPDatePickerControl class.
XTPDatePickerDaysCollection.h | XTPDatePickerDaysCollection.h: interface for the CXTPDatePickerDaysCollection class.
XTPDatePickerItemDay.h | XTPDatePickerItemDay.h: interface for the CXTPDatePickerItemDay class.
XTPDatePickerItemMonth.h | XTPDatePickerItemMonth.h: interface for the CXTPDatePickerItemMonth class.
XTPDatePickerList.h | XTPDatePickerItemList.h: interface for the CXTPDatePickerItemList class.
XTPDatePickerNotifications.h | XTPDatePickerNotifications.h: interface for the CXTPDatePickerData class.
XTPDatePickerPaintManager.h | XTPDatePickerPaintManager.h: interface for the CXTPDatePickerPaintManager class.
XTPTopLevelWndMsgNotifier.h | XTPTopLevelWndMsgNotifier.h: interface for the CXTPTopLevelWndMsgNotifier class.
Functions
Function | Description
PX_Color | Call this function within your class's DoPropExchange member function to serialize or initialize a COLORREF property. The property's value is read from or written to the variable referenced by refColor, as appropriate.
PX_Color | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Color property. The property's value is read from or written to the variable referenced by refColor, as appropriate.
PX_Font | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Font property. The property's value is read from or written to the variable referenced by refFont, as appropriate.
PX_Font | Call this function within your class's DoPropExchange member function to serialize or initialize a LOGFONT property. The property's value is read from or written to the variable referenced by rLogFont, as appropriate.
PX_GrColor | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property. The property's value is read from or written to the variable referenced by refGrColor, as appropriate.
xtpCalendarDateTime_max | Defines an upper bound of the time frame for the Calendar control.
xtpCalendarDateTime_min | Defines a lower bound of the time frame for the Calendar control.
XTPGetTopLevelWndMsgNotifier | This global function is used to get library static common top-level window object to catch windows messages, which system sends to top-level windows (like WM_TIMECHANGE, WM_SYSCOLORCHANGE).
Macros
Macro | Description
BEGIN_VIEW_PART | This helper macro is used to declare paint manager drawing parts. theClass - Part name. parentClass - Parent part name. There are two paint manager methods available to access declared part object: CPartName* GetPartName(); void SetPartName(CPartName* pPart); Where PartName is the name of the declared part.
END_VIEW_PART | This helper macro is used to declare paint manager drawing parts. theClass - Part name.
XTP_CALENDAR_DEFAULT_LABEL_ID | Define event label ID which is used by default for a new event. (Valid for default labels list only)
XTP_CALENDAR_DEFAULT_REMINDER_MINUTES | Define default reminders value minutes which is for a new event.
XTP_CALENDAR_DISABLED_COLOR_DARK | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_CALENDAR_DISABLED_COLOR_LIGHT | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX | Define maximum text length for calendar event subject, location or body which will be drawn on the screen. Used to optimize drawing performance.
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX | Define maximum count of weeks which can be shown in the Month View.
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN | Define minimum count of weeks which can be shown in the Month View.
XTP_CALENDAR_NONE_LABEL_ID | Define event label ID which signifies no label. (Valid for default labels list only)
XTP_CALENDAR_OFFICE2007_FONT_NAME | The font name for Office 2007 theme
XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS | Timeout before appearing event tool tip window.
XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS | Timeout before appearing event tool tip window.
XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS |
XTP_CALENDAR_TIMEZONESKEY_9X | The location in the registry that contains time zone information for Windows 9x family.
XTP_CALENDAR_TIMEZONESKEY_NT | The location in the registry that contains time zone information for Windows NT family (NT/2000/XP).
XTP_CALENDAR_TZIRegValName_DATA | Registry key name for some TIME_ZONE_INFORMATION structure members.
XTP_CALENDAR_TZIRegValName_DaylightName | Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_DaylightNameW | Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_DisplayStr | Registry key name for a time zone display string value. For example: "(GMT+02:00) Athens, Beirut, Istanbul, Minsk"
XTP_CALENDAR_TZIRegValName_Index | Registry key name for a time zone order index value.
XTP_CALENDAR_TZIRegValName_StandardName | Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_StandardNameW | Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_UNKNOWN_EVENT_ID | Define unknown event ID.
XTP_CALENDAR_UNKNOWN_LABEL_ID | Define unknown event label ID.
XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID | Define an unknown recurrence pattern ID.
XTP_CALENDAR_UNKNOWN_SCHEDULE_ID | Define unknown schedule ID.
XTP_EVENTS_STORAGE_HASH_TABLE_SIZE | Define events storage hash table size. Should be a prime number! like: 503, 1021, 1511, 2003, 3001, 4001, 5003, 6007, 8009, 12007, 16001, 32003, 48017, 64007
XTP_HALF_SECOND |
XTP_OBJECT_CACHE_HASH_TABLE_SIZE | Cache table size.
Structs, Records, Enums
Struct, Record, Enum | Description
XTP_CALENDAR_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification.
XTP_CALENDAR_GETITEMTEXT_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_GETITEMTEXT notification.
XTP_CALENDAR_HITTESTINFO | Basic set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_HITTESTINFO_DAY_VIEW | Enhanced set of parameters for hit test operations on calendar day view area.
XTP_CALENDAR_HITTESTINFO_MONTH_VIEW | Set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_HITTESTINFO_WEEK_VIEW | Set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_MONTHVIEW_DAYPOS | Defines a set of data and methods to easily manipulate with day positions in month view. Used to convert Week/Day indexes pair to sequential integer value and vice versa.
XTP_CALENDAR_PATTERN_END | This structure describes parameters of the end of the recurrence pattern type.
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.
XTP_CALENDAR_USERACTION_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_USERACTION notification.
XTP_CALENDAR_VIEWSELECTION | Structure contains the calendar day view selection block.
XTP_CALENDAR_WPARAM2 | Doubled custom parameter for notifications. Used when single WPARAM is not enough.
XTP_EVENT_DRAG_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_DragXXX.
XTP_EVENT_EDIT_OPERATION_PARAMS | This structure is used as a generic and base class for customize edit event notifications.
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent.
XTP_EVENT_PASTE_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_Paste.
XTP_NC_DATEPICKER_BUTTON | Structure used to send button notification messages.
XTPCalendarAdditionalOptions | Enumerates additional calendar options flags.
XTPCalendarBeforeDrawThemeObject | This enum defines a set of calendar theme items for which XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification is sent.
XTPCalendarClipboardCopyFlags | Enumerates additional flags used in clipboard operations.
XTPCalendarClockAlignFlags |
XTPCalendarCurrentTimeMarkFlags | Enumerates flags to CXTPCalendarOptions.nDayView_CurrentTimeMarkVisible member. This set of flags define when Current Time Mark on the timescale is visible.
XTPCalendarDataProvider | Enumeration used to determine the calendar data provider in use.
XTPCalendarDataProviderCacheMode | Enumerates DB Provider cache modes.
XTPCalendarDayViewScrollDirection | Enumeration used to determine the scroll direction.
XTPCalendarDraggingMode | Enumerates allowable dragging mode state codes.
XTPCalendarEditOperation | Enumerates customizable event edit operations.
XTPCalendarEndEditSubjectAction | Enumerates allowable flags for driving subject editors.
XTPCalendarEventBusyStatus | Enumerates busy status values.
XTPCalendarEventCaptionFormat | Enumerates allowable formats for event caption.
XTPCalendarEventCategories | Enumerates standard Event Categories for office 2007 theme.
XTPCalendarEventIconIDs | Icons IDs set to be used with calendar event custom icons to customize standard event glyphs.
XTPCalendarEventImportance | Enumerates importance level values.
XTPCalendarEventRecurrenceState | Enumerates recurrence states.
XTPCalendarEventRecurrenceType | Enumerates Recurrence Pattern Types.
XTPCalendarExpandDayButton | This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action.
XTPCalendarGetItemText | This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.
XTPCalendarGetItemTextEx | This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification. These flags are used for office 2007 theme only.
XTPCalendarHitTestCode | Enumerates allowable hit test codes.
XTPCalendarMouseMode | Enumeration of operational mouse modes.
XTPCalendarMultiDayEventFlags | Enumerates defined flags for multi day event states.
XTPCalendarPatternEnd | Specify the end of the recurrence pattern type.
XTPCalendarRemindersAction | Enumeration of possible Calendar Reminder notification actions.
XTPCalendarScrollDayButton | This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action. (valid for office 2007 theme only)
XTPCalendarSelectionChanged | Enumerates calendar selection types.
XTPCalendarTheme | Paint themes used by calendar.
XTPCalendarUndoMode | Enumerates flags to identify undo mode.
XTPCalendarUpdateOptions | Contains bit-masks for adjusting the calendar control.
XTPCalendarUserAction | This enum defines set of user actions which can be customized.
XTPCalendarViewChangedUpdateOptions | This enumeration contains options for CXTPCalendarControl::CViewChangedContext.
XTPCalendarViewType | Enumeration used to determine the calendar view type in use.
XTPCalendarWeek | Enumerates a sequence numbers for days.
XTPCalendarWeekDay | Enumerates Day of Weeks codes.
XTPDatePickerBorderStyle | Border style of Date picker control
XTPEnumCalendarReminderForOccurrenceParameters | Enumerates parameters used in configuring reminders for recurrence patterns occurrences.
Types
Type | Description
CXTPCalendarDatesArray | Type definition for an array of dates.
Variables
Variable | Description
cszCalendarMarkupPrm_Subject | Markup template params
cszEventCustProp_CategoryIDs | String name of the corresponding property.
cszEventCustProp_IconsIDs | String name of the corresponding property.
cszEventCustProp_MarkupTemplate | String name of the MarkupTemplate property.
cszEventCustProp_NextReminderTime_Snoozed | String name of the corresponding property.
cszProcess_RecurrencePatternID | String name for a corresponding property
cszProcess_RecurrenceState | String name for a corresponding property
WM_XTP_CALENDAR_BASE | The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use by private window classes, usually of the form WM_XTP_CALENDAR_BASE+X, where X is an integer value.
XTP_DATEPICKER_TIMER_INTERVAL | Date picker timer interval.
XTP_DATEPICKER_TIMERID | Date picker timer ID.
XTP_ID_CALENDAR_CONTROL | Identifier of Calendar control child window of CXTPCalendarControlView.
XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL | This notification is sent for each calendar day view cell before draw. You may customize clrBackgroundColor member of provided XTP_CALENDAR_DAYVIEWCELL_PARAMS structure. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT | This notification is sent for calendar theme items before draw. You may customize corresponding theme part for each object in this message. Any object part changes which made in this notification handler will be discarded when object draw finished. This let you dynamically customize each calendar item. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION | This notification is sent to customize or disable specified editing operation. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_DoCreate_Event | This notification is used as analog of overridable method CXTPCalendarData::DoCreate_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoCreate_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoCreate_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoDelete_Event | This notification is used as analog of overridable method CXTPCalendarData::DoDelete_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoDelete_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoDelete_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoGetAllEvents_raw | This notification is used as analog of overridable method CXTPCalendarData::DoGetAllEvents_raw. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoGetUpcomingEvents | This notification is used as analog of overridable method CXTPCalendarData::DoGetUpcomingEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRead_Event | This notification is used as analog of overridable method CXTPCalendarData::DoRead_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRead_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoRead_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRemoveAllEvents | This notification is used as analog of overridable method CXTPCalendarData::DoRemoveAllEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRetrieveDayEvents | This notification is used as analog of overridable method CXTPCalendarData::DoRetrieveDayEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoUpdate_Event | This notification is used as analog of overridable method CXTPCalendarData::DoUpdate_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoUpdate_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoUpdate_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_GETGROPVIEWCAPTION | This notification is sent when selection is changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_GETITEMTEXT | This notification is sent for calendar items which defines in AskItemTextFlags property.
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED | This notification is sent to determine is specified editing operation disabled. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_ON_REMINDERS | On RButtonUp event. Sender - CXTPCalendarRemindersManager
XTP_NC_CALENDAR_PREPOPULATE | This notification is sent when calendar is populating. lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_PREPOPULATE_DAY | This notification is sent when calendar is populating. lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED | Calendar Control data provider (resources) where changed. SetDataProvider() or SetResources() methods where called. Sender - CXTPCalendarControl, CXTPCalendarView.
XTP_NC_CALENDAR_SELECTION_CHANGED | This notification is sent when selection is changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_THEME_CHANGED | This notification is sent when calendar paint theme changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_USERACTION | This notification send for when user action defined in XTPCalendarUserAction enum happened. Parameters wParam - [in] A pointer to XTP_CALENDAR_USERACTION_PARAMS structure. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if specified action is handled (to Cancel default processing) , otherwise FALSE. Initial value is FALSE.
XTP_NC_CALENDARCONTEXTMENU | A Context Menu should be displayed for the Calendar Control. Sender - CXTPCalendarControl
XTP_NC_CALENDARDATAPROVIDERWASCHANGED | Calendar Control data provider (resources) where changed. SetDataProvider() or SetResources() methods where called. Sender - CXTPCalendarControl, CXTPCalendarView.
XTP_NC_CALENDAREVENTWASADDED | New event has just been added to the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDAREVENTWASCHANGED | Event has just been changed in the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDAREVENTWASDELETED | Event has just been deleted from the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDARKEYDOWN | On KeyDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONDBLCLICK | On LButtonDblClick event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONDOWN | On LButtonDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONUP | On LButtonUp event. Sender - CXTPCalendarControl
XTP_NC_CALENDARMOUSEMOVE | On MouseMove event. Sender - CXTPCalendarControl
XTP_NC_CALENDAROPTIONSWASCHANGED | Calendar Control options was changed. Sender - CXTPCalendarControl
XTP_NC_CALENDARRBUTTONDOWN | On RButtonDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARRBUTTONUP | On RButtonUp event. Sender - CXTPCalendarControl
XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED | Calendar Control Day view time scale was changed. Sender - CXTPCalendarControl
XTP_NC_CALENDARVIEWWASCHANGED | Current Calendar Control view type(day, week, ...) or content was changed. Sender - CXTPCalendarControl
XTP_NC_DATEPICKER_BUTTON_CLICK | Notify ID to parent window.
XTP_NC_DATEPICKER_SELECTION_CHANGED | Notify ID to parent window.
XTP_NC_DATEPICKERBEFOREGOMODAL | This is a notification ID that is used to indicate that the Date Picker is before run in modal mode (pop-up window), window has already created.
XTP_NC_DATEPICKERBUTTONCLICKED | This is a notification ID that is used to indicate mouse button clicks on a control.
XTP_NC_DATEPICKERGETDAYMETRICS | This notification is used to get day item metrics. Sender - CXTPDatePickerControl.
XTP_NC_DATEPICKERMONTHCHANGED | This is a notification ID that is used to indicate that the Date Picker is populated.
XTP_NC_DATEPICKERMOUSEMOVE | This is a notification ID that is used to indicate mouse move under a control.
XTP_NC_DATEPICKERSELECTIONCHANGED | This is a notification ID that is used to indicate that the selection has changed.
XTP_SELECTION_INFINITE | Infinite number of selected days.
XTP_WM_TIME_ZONE_CHANGED | Define windows message which send by CXTPTopLevelWndMsgNotifier when current timezone is changed.
XTP_WM_TIME_ZONE_CHANGED_MSG | Define name for XTP_WM_TIME_ZONE_CHANGED windows message.
xtp_wm_UserAction | A message identifier of the Calendar User Action custom message
XTPCALENDARCTRL_CF_EVENT |
XTPCALENDARCTRL_CLASSNAME | Custom class name for the Calendar control window
XTPCALENDARCTRL_USERACTION | String name of the calendar switch view custom message


Calendar Hierarchy

Calendar
Calendar Hierarchy

Module

Calendar


Classes

Classes, Legend, Calendar, Templates, Structures
Classes
Classes
Class
Description
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
CXTPCalendarController
Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object.
CXTPCalendarControlView
The CXTPCalendarControlView class provides an implementation of the Calendar control as view class. Use GetCalendarCtrl() method to access methods of CXTPCalendarControl
CXTPCalendarControlViewPrintOptions
Describes printing options for the Calendar Control.
CXTPCalendarCustomDataProvider
Custom implementation of XTPCalendarData based on notifications.
CXTPCalendarCustomProperties
This class is used to store properties collection.
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added,
CXTPCalendarDatabaseDataProvider
This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
CXTPCalendarEventCategories
This class is used as a collection of CXTPCalendarEventCategory objects.
CXTPCalendarEventCategory
This class define Calendar Event Category properties. Visual effects for Event Categories (event and day's cells background colors) implemented in Office 2007 theme only. If one or more categories set for event - the category's colors are used, otherwise label's colors used (is label defined). For Office 2003 theme label's colors used in any case.
CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs.
CXTPCalendarEventLabel
This class define Calendar Event label properties.
CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects.
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
CXTPCalendarIconIDs
This class represents the collection of custom icons IDs.
CXTPCalendarMAPIDataProvider
This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.
CXTPCalendarMAPIWrapper
The CXTPCalendarMAPIWrapper class wraps the mapi32.dll API.
CXTPCalendarMemoryDataProvider
This class implements an abstract representation of the data used in the XTPCalendarData class.
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
CXTPCalendarMonthViewGroup
This class represents a single resource view portion of the Calendar Month View.
CXTPCalendarOccurSeriesChooseDlg
This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern).
CXTPCalendarOptions
Structure contains all calendar options.
CXTPCalendarPageSetupDialog
Customized Calendar control page setup dialog.
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build schedule for recurrence events.
CXTPCalendarReminder
This class describes a reminder for calendar event and implements base properties and operations on reminder.
CXTPCalendarReminderForOccurrence
This structure describes a reminder for an occurrence of a recurrence event.
CXTPCalendarReminderForOccurrenceArray
This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it.
CXTPCalendarReminders
This class represents a simple array collection of CXTPCalendarReminder objects.
CXTPCalendarRemindersManager
This class is used to monitor and manage calendar events reminders. It will send notifications when active reminders list is changed - new reminder(s) come or some reminder(s) goes away.
CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of persons or resources.
CXTPCalendarResourceDescription
This class is a wrapper for CXTPCalendarResource class. It is needed for easier processing in scope of CXTPCalendarResourcesManager
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
CXTPCalendarResourcesManager
This class is used as helper to manage calendar resources (and schedules) data configurations.
CXTPCalendarResourcesNf
This class implements CXTPCalendarResource functionality with addition of notifications mechanism implemented by CXTPNotifySink.
CXTPCalendarSchedule
Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc).
This class implements base properties of the Schedule and operations on it.
CXTPCalendarSchedules
This class represents a simple array collection of CXTPCalendarSchedule objects.
CXTPCalendarThemeBOOLValue
Helper class provides functionality to manage customized BOOL value objects.
CXTPCalendarThemeFontValue
Helper class provides functionality to manage font value objects.
CXTPCalendarThemeIntValue
Helper class provides functionality to manage customized int value objects.
CXTPCalendarThemeRectValue
Helper class provides functionality to manage customized CRect value objects.
CXTPCalendarThemeStringValue
Helper class provides functionality to manage customized string value objects.
CXTPCalendarTimeScalePropertiesDlg
CXTPCalendarTimeScalePropertiesDlg dialog
This dialog allows to customize Calendar Time Scale part, set a proper time zone and it's description.
CXTPCalendarTimeZone
This class extend TIME_ZONE_INFORMATION structure.
CXTPCalendarTimeZones
This class represents a simple array collection of CXTPCalendarTimeZone objects.
CXTPCalendarTip
The CXTPCalendarTip class emulates the functionality of a "tool tip" control.
CXTPCalendarUIntArray
This class represents the collection of UINT elements.
CXTPCalendarView
This class represents the view portion of the Calendar control.
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
CXTPCalendarViewEvents
This class used as collection of Event View object.
CXTPCalendarViewEventSubjectEditor
This class is used to edit event subject.
CXTPCalendarViewEventSubjectEditor2007
This class is used to edit event subject in Office 2007 Theme.
CXTPCalendarViewGroup
Regular schema:

  • CalendarView consists of CalendarView(s)Day
  • CalendarViewDay consists of CalendarView(s)Resource
  • CalendarViewGroup contains CalendarView(s)Event

ViewGroup draws a single resource depending on the type of parent day view.

CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager. objects.
CXTPCalendarViewPartBrushValue
Helper class provides functionality to manage brush value objects.
CXTPCalendarViewPartFontValue
Helper class provides functionality to manage font settings for various graphical elements of control.
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView.
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
CXTPCalendarWeekViewGroup
This class represents a single resource view portion of the Calendar Week View.
CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
CXTPDatePickerButton
This class represents a DatePicker button.
CXTPDatePickerButtons
Class CXTPDatePickerButtons represents a collection of buttons.
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
CXTPDatePickerDaysCollection
CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
CXTPDatePickerList
This class provides the functionality of a list control which displays month names.
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
CXTPDatePickerTheme
Abstract class CXTPDatePickerTheme is derived from CXTPDatePickerPaintManager and handles most of the drawing activities for the DatePicker control. This class must be used as a base to create different themes implementations (like CXTPDatePickerThemeOffice2007).
CXTPDatePickerThemeOffice2007
Class CXTPDatePickerThemeOffice2007 is derived from CXTPDatePickerTheme is implement Office 2007 style for DatePicker control.
CXTPTopLevelWndMsgNotifier
This class is used to catch windows messages, which system sends to top-level windows and to send them to subscribers windows. The following messages are supported: WM_TIMECHANGE WM_SYSCOLORCHANGE
Module

Calendar

Templates
Template | Description
CXTPAutoResetValue | Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy. Can be useful to lock some data or actions via flags and unlock automatically.
CXTPCalendarPtrCollectionT | This class represents a simple array collection of objects.
CXTPCalendarThemeCustomizableXValueT | Helper class template provides functionality to manage customized value for the specified type.
CXTPCalendarTypedPtrAutoDeleteArray | This class represents a simple array collection of objects pointers.
CXTPCalendarTypedPtrAutoDeleteMap | This class represents a simple map of typed keys to typed objects pointers. Overridden methods SetAt, operator[], RemoveKey, RemoveAll, call delete for previously stored elements.
CXTPCalendarUtils | Helper class with static member functions to perform common tasks with dates, events and other objects.
CXTPCalendarViewDayT | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class.
CXTPCalendarViewEventT | This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.
CXTPCalendarViewGroupT | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class.
CXTPCalendarViewPartCustomizableValueT | Helper class template provides functionality to manage customized value for the specified class objects.
CXTPCalendarViewT | This template class represents a view portion of the Calendar control.
Legend
Template
Structure
Structures
Structure
Description
XTP_CALENDAR_RECURRENCE_OPTIONS
This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data.
XTP_DAYITEM_METRICS
This structure represents a set of parameters which are used to display day items.

  1. There could be customized foreground and background colors.
  2. Also you can text font for the displayed day text.
  3. And as the last thing you can customize a day picture displayed there, using OLE PICTUREDISP interface and OleSetPicture method.


CXTPAutoResetValue Template

XTPCalendarUtils.h, Classes, Legend, Members, Topics, CXTPAutoResetValue Constructors, CXTPAutoResetValue Destructors, CXTPAutoResetValue Operators, CXTPAutoResetValue Constructors, CXTPAutoResetValue Destructors, CXTPAutoResetValue Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPAutoResetValue Template

Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy. Can be useful to lock some data or actions via flags and unlock automatically.

Class Hierarchy

template <class _TValue>
class CXTPAutoResetValue;
File

XTPCalendarUtils.h

Group

Classes

Legend
Constructor
virtual
Operator
CXTPAutoResetValue Constructors
CXTPAutoResetValue Constructors | Description
CXTPAutoResetValue |
CXTPAutoResetValue Destructors
CXTPAutoResetValue Destructors | Description
~CXTPAutoResetValue | Object destructor.
CXTPAutoResetValue Operators
CXTPAutoResetValue Operators | Description
_TValue& | This member operator is use to access managing variable.
= | This member function overloads the assignment operator for the CXTPAutoResetValue class.


CXTPAutoResetValue Constructors

CXTPAutoResetValue Template, Legend, Public Methods
CXTPAutoResetValue Constructors
Template

CXTPAutoResetValue Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPAutoResetValue |


CXTPAutoResetValue Constructor

CXTPAutoResetValue Constructors
CXTPAutoResetValue Constructor
Overload List
Constructors
Constructor | Description
CXTPAutoResetValue::CXTPAutoResetValue (_TValue&) | Object constructor.
CXTPAutoResetValue::CXTPAutoResetValue (_TValue&, const _TValue&) | Object constructor.
Group

CXTPAutoResetValue Constructors


CXTPAutoResetValue::CXTPAutoResetValue Constructor (_TValue&)

CXTPAutoResetValue Constructor, CXTPAutoResetValue Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPAutoResetValue::CXTPAutoResetValue Constructor (_TValue&)

Object constructor.

CXTPAutoResetValue(
    _TValue& rData
);
Parameters

rData
A reference to managing variable.

Remarks

The original value of rData is stored in separate member and it will be restored on destroy.

Body Source
CXTPAutoResetValue(_TValue& rData) :
    m_rData(rData)
{
    m_valReset = rData;
}
Group

CXTPAutoResetValue Constructor


CXTPAutoResetValue::CXTPAutoResetValue Constructor (_TValue&, const _TValue&)

CXTPAutoResetValue Constructor, CXTPAutoResetValue Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPAutoResetValue::CXTPAutoResetValue Constructor (_TValue&, const _TValue&)

Object constructor.

CXTPAutoResetValue(
    _TValue& rData,
    const _TValue& valReset
);
Parameters

rData
A reference to managing variable.
valReset
A value to set when destroy.

Remarks

The original value of rData is ignored. valReset value will be used on destroy.

Body Source
CXTPAutoResetValue(_TValue& rData, const _TValue& valReset): m_rData(rData) {
    m_valReset = valReset;
}
Group

CXTPAutoResetValue Constructor


CXTPAutoResetValue Destructors

CXTPAutoResetValue Template, Legend, Public Methods
CXTPAutoResetValue Destructors
Template

CXTPAutoResetValue Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPAutoResetValue | Object destructor.


CXTPAutoResetValue::~CXTPAutoResetValue Destructor

CXTPAutoResetValue Destructors, CXTPAutoResetValue Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPAutoResetValue::~CXTPAutoResetValue Destructor

Object destructor.

virtual ~CXTPAutoResetValue();
Remarks

Managing variable value will be restored to the original one or to value specified as second constructor parameter.

Body Source
virtual ~CXTPAutoResetValue() {
    m_rData = m_valReset;
}
Group

CXTPAutoResetValue Destructors


CXTPAutoResetValue Operators

CXTPAutoResetValue Template, Legend, Public Operators
CXTPAutoResetValue Operators
Template

CXTPAutoResetValue Template

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
_TValue& | This member operator is use to access managing variable.
= | This member function overloads the assignment operator for the CXTPAutoResetValue class.


CXTPAutoResetValue::_TValue& Operator

CXTPAutoResetValue Operators, CXTPAutoResetValue Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPAutoResetValue::_TValue& Operator

This member operator is use to access managing variable.

operator _TValue&();
Returns

Managing variable reference.

Body Source
operator _TValue&() {
    return m_rData;
}
Group

CXTPAutoResetValue Operators


CXTPAutoResetValue::= Operator

CXTPAutoResetValue Operators, CXTPAutoResetValue Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPAutoResetValue::= Operator

This member function overloads the assignment operator for the CXTPAutoResetValue class.

const _TValue& operator =(
    const _TValue& rSrc
);
Parameters

rSrc
A new value.

Returns

A reference to this object.

Body Source
const _TValue& operator =(const _TValue& rSrc) {
    return m_rData = rSrc;
}
Group

CXTPAutoResetValue Operators


CXTPCalendarControl Class

XTPCalendarControl.h, Classes, Legend, Members, Topics, CXTPCalendarControl Classes, CXTPCalendarControl Data Members, CXTPCalendarControl Methods, CXTPCalendarControl Constructors, CXTPCalendarControl Destructors, CXTPCalendarControl Classes, CXTPCalendarControl Constructors, CXTPCalendarControl Data Members, CXTPCalendarControl Destructors, CXTPCalendarControl Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl Class

Class CXTPCalendarControl implements the calendar's view interface.

Class Hierarchy

class CXTPCalendarControl : public CWnd;
File

XTPCalendarControl.h

Remarks

A CXTPCalendarControl object implements a calendar view interface similar to Outlook 2003 interface.

There are 2 main separated concepts: Calendar data contents and Calendar views representing this contents.

It can show 3 types of following predefined views. Also any type of user view could also be implemented as a descendant of CXTPCalendarView class.

  • Day and work week views - using CXTPCalendarDayView class.
  • Week view - using CXTPCalendarWeekView class.
  • Month view - using CXTPCalendarMonthView class.

One of the other main Control's concepts is Calendar Resources. Resource is the source of Calendar data contents with some additional properties. This concept is designed to represent a schedule of a separate person, or a shared resource (sic!) like a conference room, a projector, and any similar entity. Each Resource has its own Data Provider, therefore the Control can show different data sources on the same screen. For example, you can configure Control to show your own Outlook events in "your" resource (using MAPI Data Provider), then you can use some shared resource data using Database Data Provider, etc.

Note that each event now has standard "Schedule" property, defining which user's schedule it belongs to. And each resource has a collection of Schedule ID's to represent on it. For example, you can have only one common Data Provider which stores events data for all members of your organization. Every member has a corresponding schedule (i.e. Jeff - ID 1, Matt - ID 2, John - ID 3, Room 1 - ID 10, Room 2 - ID 11, etc). You can configure a number of resources to show data for every team member separately, and one resource to show events for both room 1 and room 2 together. Or for example, you want to show a common view of all events for a specified team including only some of employees. You will add their schedule ID's to the corresponding Resource collection, and see all of them. Of course, when you open event details, you'll see who it belongs to.

There are 2 regular models of using your custom data source with Calendar control.

a) Firstly, you can use built-in Memory data provider, which will handle all the data in itself. If you do not specify neither XML nor Binary filename, it will not be automatically loaded or saved. In this case, you'll have 2 entry points in your application: -- Loading all data from your data source (could be done on form load for example). Your data access code would transfer CalendarEvents records from the data storage to objects and add them into corresponding Calendar's collection. -- Saving data to your data storage. You'll have to iterate all CalendarEvents, transfer them into your data records and upload into the database. This could be implemented on pressing Save button for example. This is the most easy way.

b) Second idea is to handle basic data storage operations by yourself. This is called "custom data provider model". It could be needed when you have a very lot of CalendarEvents records and do not want to store them all in memory because of a huge size. Another possible need of using this model is having all the information always updated if your data storage is shared.

For some predefined examples of this functionality look Calendar Samples, and menu items: MultiSchedules configuration and Load sample configurations...

See Also

CXTPCalendarView, CXTPCalendarData, CXTPCalendarResource

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarControl Classes
CXTPCalendarControl Classes | Description
CUpdateContext | Class CUpdateContext updates context and redraws control parts depending on input parameters.
CViewChanged_ContextData | Class CViewChanged_ContextData is used as locker context for CViewChangedContext.
CViewChangedContext | Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action.
CXTPCalendarControl Constructors
CXTPCalendarControl Constructors | Description
CXTPCalendarControl | This member function constructs a CXTPCalendarControl object.
CXTPCalendarControl Data Members
CXTPCalendarControl Data Members | Description
m_bDeleteOnFinalRelease | If TRUE - Delete self OnFinalRelease() call.
m_bDisableRedraw | If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).
m_bUpdateWhenEventChangedNotify | Whether to update control when notification comes about an event change.
m_cntViewChanged | Locker context for CViewChangedContext.
m_mouseMode | Current mouse operation mode.
m_nRowsPerWheel | Amount of rows to scroll when using the mouse wheel.
m_pRemindersManager | Stores reminders manager object.
m_strRedoUIText | Text label for the Redo UI command.
m_strUndoUIText | Text label for the Undo UI command.
CXTPCalendarControl Destructors
CXTPCalendarControl Destructors | Description
~CXTPCalendarControl | This member function destroys a CXTPCalendarControl object and handles cleanup and de-allocation.
CXTPCalendarControl Methods
CXTPCalendarControl Methods | Description
_SetDataProvider | This member function internally sets the custom data provider for the control.
AdjustLayout |
AdjustScrollBar | This member function adjusts the scroll bar to reflect the current control's state.
AdjustScrollBarEx | This member function adjusts the scroll bar to reflect the current control's state.
Create | This member function handles control window creation.
CreateDataProvider |
DataProviderTypeFromConStr | Call this method to retrieve a type of the data provider from its connection string.
DataSourceFromConStr | Call this method to retrieve a data source connection string from a regular Calendar connection string.
DayView_IsAutoResetBusyFlag | Call this method to determine if the AutoResetBusyFlag is set.
DayView_SetAutoResetBusyFlag | Call this method to set the AutoResetBusyFlag.
DoDeleteEvent | This member function deletes specified event from the calendar.
DoDeleteSelectedEvents | This member function deletes selected events from the calendar.
EnableMarkup | This member function is used to enable or disable Markup functionality for the control. Enabling this functionality allows a control to process customized special property xtpMarkupTemplate which could be set for each event. If this property exists and contains text with Markup information, it will be drawn inside the Event rectangle (instead of Subject and Body).
EnableReminders | This member function is used to enable or disable Reminders functionality for the control.
EnableSendNotifications | This member function enables or disables sending a notification to all control's event subscribers.
EnableToolTips | This member function is used to enable or disable ToolTips for the control.
GetActiveView | This member function obtains a pointer to the current calendar view.
GetAskItemTextFlags | This member function returns set of flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification. If Calendar theme is set - return value is got from the theme object, otherwise it is got from the paint manager object.
GetCalendarOptions | Call this member function to get direct access to calendar options data.
GetConnection | Obtain a pointer to the notification connection object.
GetDataProvider | Returns common data provider if it was previously set.
GetDayView | This member function obtains a pointer to the Day calendar view.
GetFirstDayOfWeek | This member function obtains the first day of the week.
GetMarkupContext | Returns markup context
GetMonthView | This member function obtains a pointer to the Month calendar view.
GetPaintManager | This member function obtains a pointer to the associated paint manager.
GetPaintTheme | This member function is used to obtain current paint theme.
GetRemindersManager | Obtain an associated Reminders Manager object.
GetResources | Obtain a pointer to collection of Calendar Resources.
GetTheme | This member function obtains a pointer to the associated theme object.
GetWeekView | This member function obtains a pointer to the Week calendar view.
GetWorkDayEndTime |
GetWorkDayStartTime |
GetWorkWeekMask | This member function obtains the bitwise mask of the work week.
HideToolTip | This member function is used to hide the ToolTip rectangle.
IsMarkupEnabled | This member function returns TRUE if Markup functionality is enabled for this Calendar control and FALSE otherwise. In enabled state is automatically process static Markup text for events, and enables processing of dynamic Markup text customization using XTP_NC_CALENDAR_GETITEMTEXT notification.
IsRemindersEnabled | This member function returns TRUE if the Reminders functionality is enabled for this Calendar control and FALSE otherwise.
IsToolTipsEnabled | This member function returns TRUE if the ToolTips enabled, FALSE otherwise.
IsToolTipVisible | This member function is the ToolTip rectangle visible on the screen.
MonthView_IsCompressWeekendDays | Call this method to determine whether weekend days are drawn compressed in month view or not.
MonthView_IsShowEndDate | Call this method to determine whether the end date is shown for events in the month view.
MonthView_IsShowTimeAsClocks | Call this method to determine if the time is shown as a graphical clock for events in the month view.
MonthView_SetCompressWeekendDays | Call this method to specify whether weekend days are drawn compressed in the month view.
MonthView_SetShowEndDate | Call this method to specify whether the end date is shown in the month view.
MonthView_SetShowTimeAsClocks | Call this method to specify if the events start and end time is shown as a graphical clock in the month view.
OnBeforeDestroy | This member function is called by the framework before the view is destroyed.
OnCopy | This member function is used to process the "Copy" command.
OnCut | This member function is used to process the "Cut" command.
OnDraw | This member function performs all of the drawing logic of the calendar control window.
OnEditCommand | This member function is used to process the command with specified ID.
OnOptionsChanged | This member function is called by the calendar control when calendar option was changed.
OnPaste | This member function is used to process the "Paste" command.
OnUndo | This member function is used to process undo commands.
OnUpdateCmdUI | This member function is used to update the user interface object represented by pCmdUI.
OnUpdateCopy | This member function is used to update the user interface object represented by pCmdUI for the "Copy" command only.
OnUpdateCut | This member function is used to update the user interface object represented by pCmdUI for the "Cut" command only.
OnUpdatePaste | This member function is used to update the user interface object represented by pCmdUI for the "Paste" command only.
OnUpdateUndo | This member function is used to update the user interface object represented by pCmdUI for the "Undo" command only.
OnWndMsg_Children | This member function is used to catch messages before children windows (like Subject editor).
Populate | This member function populates the active control view with events data.
RedrawControl | This member function initiates the Calendar control's redrawing.
RegisterWindowClass | Register the window class if it has not already been registered.
SendNotification | This member function sends a notification to all control's event subscribers.
SendNotificationAlways | This member function sends a notification to all control's event subscribers.
SetActiveView | This member function sets the custom calendar view for the control.
SetDataProvider |
SetFirstDayOfWeek | This member function sets the first day of the week.
SetLayoutRTL | Call this member to set right-to-left mode.
SetPaintManager | This member function sets the new control drawing PaintManager.
SetPaintTheme | This member function is used to set current paint theme.
SetResources | This member function sets the new Resources collection for the control.
SetTheme | This member function sets (or disable) the new control drawing theme.
SetTimer | This member function creates a timer event.
SetWorkDayEndTime |
SetWorkDayStartTime |
SetWorkWeekMask | This member function sets the bitwise mask for the work week.
ShowToolTip | This member function is used to show a ToolTip rectangle.
SwitchActiveView | This member function sets a predefined calendar view for the control.
UpdateMouseCursor | This member function updates the mouse cursor in relation with the control's state.
WeekView_IsShowEndDate | Call this method to determine if the end date is shown for events in the week view.
WeekView_IsShowTimeAsClocks | Call this method to determine if the time is shown as a graphical clock for events in the week view.
WeekView_SetShowEndDate | Call this method to specify if the end date is shown in week view.
WeekView_SetShowTimeAsClocks | Call this method to specify if the events start and end time is shown as a graphical clock in week view.


CXTPCalendarControl Classes

Classes, CXTPCalendarControl Class
CXTPCalendarControl Classes
Classes
Class | Description
CUpdateContext | Class CUpdateContext updates context and redraws control parts depending on input parameters.
CViewChanged_ContextData | Class CViewChanged_ContextData is used as locker context for CViewChangedContext.
CViewChangedContext | Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action.
Class

CXTPCalendarControl Class


CXTPCalendarControl::CUpdateContext Class

XTPCalendarControl.h, CXTPCalendarControl Classes, Legend, Members, Topics, CUpdateContext Constructors, CUpdateContext Destructors, CUpdateContext Constructors, CUpdateContext Destructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CUpdateContext Class

Class CUpdateContext updates context and redraws control parts depending on input parameters.

Class Hierarchy

class CUpdateContext;
File

XTPCalendarControl.h

See Also

XTPCalendarUpdateOptions, AdjustLayout, AdjustScrollBar, RedrawControl

Group

CXTPCalendarControl Classes

Legend
Constructor
CUpdateContext Constructors
CUpdateContext Constructors | Description
CUpdateContext | Constructs a CUpdateContext object.
CUpdateContext Destructors
CUpdateContext Destructors | Description
~CUpdateContext | Destroys a CUpdateContext object and calls all the required Calendar Control adjusting and redrawing functions.


CUpdateContext Constructors

CXTPCalendarControl::CUpdateContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CUpdateContext Constructors
Class

CXTPCalendarControl::CUpdateContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CUpdateContext | Constructs a CUpdateContext object.


CXTPCalendarControl::CUpdateContext::CUpdateContext Constructor

CUpdateContext Constructors, CXTPCalendarControl::CUpdateContext Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CUpdateContext::CUpdateContext Constructor

Constructs a CUpdateContext object.

CUpdateContext(
    CXTPCalendarControl* pControl,
    int nOptions = xtpCalendarUpdateLayout | xtpCalendarUpdateRedraw
);
Parameters

pControl
Pointer to the CXTPCalendarControl to adjust.
nOptions
A bitwise combination of the adjusting parameters.

Remarks

When constructing a CUpdateContext object, specify if the control's layout needs adjustment and/or redrawing.

See Also

XTPCalendarUpdateOptions

Body Source
CUpdateContext(CXTPCalendarControl* pControl, int nOptions = xtpCalendarUpdateLayout | xtpCalendarUpdateRedraw) :
    m_pControl(pControl)
{
    // WARNING. (no error)
    // There is no need to use xtpCalendarUpdateRedraw and xtpCalendarUpdateRedrawIfNeed together
    ASSERT(!((nOptions & xtpCalendarUpdateRedraw) && (nOptions & xtpCalendarUpdateRedrawIfNeed)));

    m_nOptions = nOptions;

    if (!m_pControl) {
        ASSERT(FALSE);
        return;
    }

    if (m_nOptions & (xtpCalendarUpdateLayout | xtpCalendarUpdateScrollBar))
        m_pControl->BeginAdjust(nOptions & xtpCalendarUpdateScrollBar);

    if (m_nOptions & xtpCalendarUpdateRedraw)
        m_pControl->BeginUpdate();

    if (m_nOptions & xtpCalendarUpdateRedrawIfNeed)
        m_pControl->LockUpdate();
}
Group

CUpdateContext Constructors


CUpdateContext Destructors

CXTPCalendarControl::CUpdateContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CUpdateContext Destructors
Class

CXTPCalendarControl::CUpdateContext Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CUpdateContext | Destroys a CUpdateContext object and calls all the required Calendar Control adjusting and redrawing functions.


CXTPCalendarControl::CUpdateContext::~CUpdateContext Destructor

CUpdateContext Destructors, CXTPCalendarControl::CUpdateContext Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CUpdateContext::~CUpdateContext Destructor

Destroys a CUpdateContext object and calls all the required Calendar Control adjusting and redrawing functions.

~CUpdateContext();
See Also

XTPCalendarUpdateOptions

Body Source
~CUpdateContext()
{
    if (!m_pControl) {
        return;
    }

    if (m_nOptions & (xtpCalendarUpdateLayout | xtpCalendarUpdateScrollBar))
        m_pControl->EndAdjust(m_nOptions & xtpCalendarUpdateScrollBar);

    if (m_nOptions & xtpCalendarUpdateRedraw)
        m_pControl->EndUpdate();

    if (m_nOptions & xtpCalendarUpdateRedrawIfNeed)
        m_pControl->UnlockUpdate();
}
Group

CUpdateContext Destructors


CXTPCalendarControl::CViewChanged_ContextData Class

XTPCalendarControl.h, CXTPCalendarControl Classes, Legend, Members, Topics, CViewChanged_ContextData Data Members, CViewChanged_ContextData Constructors, CViewChanged_ContextData Constructors, CViewChanged_ContextData Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CViewChanged_ContextData Class

Class CViewChanged_ContextData is used as locker context for CViewChangedContext.

Class Hierarchy

class CViewChanged_ContextData;
File

XTPCalendarControl.h

Group

CXTPCalendarControl Classes

Legend
Data Member
Constructor
CViewChanged_ContextData Constructors
CViewChanged_ContextData Constructors | Description
CViewChanged_ContextData | Default object constructor.
CViewChanged_ContextData Data Members
CViewChanged_ContextData Data Members | Description
m_bRequest | View change send notification request.
m_nLockCount | View change notification lock counter.


CViewChanged_ContextData Data Members

CXTPCalendarControl::CViewChanged_ContextData Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CViewChanged_ContextData Data Members
Class

CXTPCalendarControl::CViewChanged_ContextData Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bRequest | View change send notification request.
m_nLockCount | View change notification lock counter.


CXTPCalendarControl::CViewChanged_ContextData::m_bRequest Data Member

CViewChanged_ContextData Data Members, CXTPCalendarControl::CViewChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CViewChanged_ContextData::m_bRequest Data Member

View change send notification request.

BOOL m_bRequest;
Group

CViewChanged_ContextData Data Members


CXTPCalendarControl::CViewChanged_ContextData::m_nLockCount Data Member

CViewChanged_ContextData Data Members, CXTPCalendarControl::CViewChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CViewChanged_ContextData::m_nLockCount Data Member

View change notification lock counter.

int m_nLockCount;
Group

CViewChanged_ContextData Data Members


CViewChanged_ContextData Constructors

CXTPCalendarControl::CViewChanged_ContextData Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CViewChanged_ContextData Constructors
Class

CXTPCalendarControl::CViewChanged_ContextData Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CViewChanged_ContextData | Default object constructor.


CXTPCalendarControl::CViewChanged_ContextData::CViewChanged_ContextData Constructor

CViewChanged_ContextData Constructors, CXTPCalendarControl::CViewChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CViewChanged_ContextData::CViewChanged_ContextData Constructor

Default object constructor.

CViewChanged_ContextData();
Group

CViewChanged_ContextData Constructors


CXTPCalendarControl::CViewChangedContext Class

XTPCalendarControl.h, CXTPCalendarControl Classes, Legend, Members, Topics, CViewChangedContext Constructors, CViewChangedContext Destructors, CViewChangedContext Constructors, CViewChangedContext Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CViewChangedContext Class

Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action.

Class Hierarchy

class CViewChangedContext;
File

XTPCalendarControl.h

Group

CXTPCalendarControl Classes

Legend
Constructor
virtual
CViewChangedContext Constructors
CViewChangedContext Constructors | Description
CViewChangedContext |
CViewChangedContext Destructors
CViewChangedContext Destructors | Description
~CViewChangedContext | Destroys a CViewChangedContext object and send notification if this is last locker object.


CViewChangedContext Constructors

CXTPCalendarControl::CViewChangedContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CViewChangedContext Constructors
Class

CXTPCalendarControl::CViewChangedContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CViewChangedContext |


CViewChangedContext Constructor

CViewChangedContext Constructors
CViewChangedContext Constructor
Overload List
Constructors
Constructor | Description
CXTPCalendarControl::CViewChangedContext::CViewChangedContext (CXTPCalendarControl*, int) | Constructs a CViewChangedContext object.
CXTPCalendarControl::CViewChangedContext::CViewChangedContext (CXTPCalendarView*, int) | Constructs a CViewChangedContext object.
Group

CViewChangedContext Constructors


CXTPCalendarControl::CViewChangedContext::CViewChangedContext Constructor (CXTPCalendarView*, int)

CViewChangedContext Constructor, CXTPCalendarControl::CViewChangedContext Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CViewChangedContext::CViewChangedContext Constructor (CXTPCalendarView*, int)

Constructs a CViewChangedContext object.

CViewChangedContext(
    CXTPCalendarView* pView,
    int eType = xtpCalendarViewChangedSend
);
CViewChangedContext(
    CXTPCalendarControl* pControl,
    int eType = xtpCalendarViewChangedSend
);
Parameters

pView
Pointer to parent CXTPCalendarView object.
eType
Value from enum XTPCalendarViewChangedUpdateOptions.
pControl
Pointer to parent CXTPCalendarControl object.

See Also

XTP_NC_CALENDARVIEWWASCHANGED

Group

CViewChangedContext Constructor


CViewChangedContext Destructors

CXTPCalendarControl::CViewChangedContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CViewChangedContext Destructors
Class

CXTPCalendarControl::CViewChangedContext Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CViewChangedContext | Destroys a CViewChangedContext object and send notification if this is last locker object.


CXTPCalendarControl::CViewChangedContext::~CViewChangedContext Destructor

CViewChangedContext Destructors, CXTPCalendarControl::CViewChangedContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CViewChangedContext::~CViewChangedContext Destructor

Destroys a CViewChangedContext object and send notification if this is last locker object.

virtual ~CViewChangedContext();
Group

CViewChangedContext Destructors


CXTPCalendarControl Data Members

CXTPCalendarControl Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl Data Members
Class

CXTPCalendarControl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bUpdateWhenEventChangedNotify | Whether to update control when notification comes about an event change.
m_cntViewChanged | Locker context for CViewChangedContext.
m_nRowsPerWheel | Amount of rows to scroll when using the mouse wheel.
m_pRemindersManager | Stores reminders manager object.
m_strRedoUIText | Text label for the Redo UI command.
m_strUndoUIText | Text label for the Undo UI command.
Public Data Members
Public Data Member | Description
m_bDeleteOnFinalRelease | If TRUE - Delete self OnFinalRelease() call.
m_bDisableRedraw | If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).
m_mouseMode | Current mouse operation mode.


CXTPCalendarControl::m_bDeleteOnFinalRelease Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_bDeleteOnFinalRelease Data Member

If TRUE - Delete self OnFinalRelease() call.

BOOL m_bDeleteOnFinalRelease;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl::m_bDisableRedraw Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_bDisableRedraw Data Member

If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).

BOOL m_bDisableRedraw;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl::m_bUpdateWhenEventChangedNotify Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_bUpdateWhenEventChangedNotify Data Member

Whether to update control when notification comes about an event change.

BOOL m_bUpdateWhenEventChangedNotify;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl::m_cntViewChanged Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_cntViewChanged Data Member

Locker context for CViewChangedContext.

CViewChanged_ContextData m_cntViewChanged;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl::m_mouseMode Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_mouseMode Data Member

Current mouse operation mode.

XTPCalendarMouseMode m_mouseMode;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl::m_nRowsPerWheel Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_nRowsPerWheel Data Member

Amount of rows to scroll when using the mouse wheel.

int m_nRowsPerWheel;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl::m_pRemindersManager Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_pRemindersManager Data Member

Stores reminders manager object.

CXTPCalendarRemindersManager* m_pRemindersManager;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl::m_strRedoUIText Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_strRedoUIText Data Member

Text label for the Redo UI command.

CString m_strRedoUIText;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl::m_strUndoUIText Data Member

CXTPCalendarControl Data Members, CXTPCalendarControl Class
CXTPCalendarControl::m_strUndoUIText Data Member

Text label for the Undo UI command.

CString m_strUndoUIText;
Group

CXTPCalendarControl Data Members


CXTPCalendarControl Methods

CXTPCalendarControl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl Methods
Class

CXTPCalendarControl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_SetDataProvider | This member function internally sets the custom data provider for the control.
AdjustScrollBarEx | This member function adjusts the scroll bar to reflect the current control's state.
OnBeforeDestroy | This member function is called by the framework before the view is destroyed.
OnDraw | This member function performs all of the drawing logic of the calendar control window.
OnOptionsChanged | This member function is called by the calendar control when calendar option was changed.
SetActiveView | This member function sets the custom calendar view for the control.
SetTimer | This member function creates a timer event.
Public Methods
Public Methods
Public Method | Description
AdjustLayout |
AdjustScrollBar | This member function adjusts the scroll bar to reflect the current control's state.
Create | This member function handles control window creation.
CreateDataProvider |
DataProviderTypeFromConStr | Call this method to retrieve a type of the data provider from its connection string.
DataSourceFromConStr | Call this method to retrieve a data source connection string from a regular Calendar connection string.
DayView_IsAutoResetBusyFlag | Call this method to determine if the AutoResetBusyFlag is set.
DayView_SetAutoResetBusyFlag | Call this method to set the AutoResetBusyFlag.
DoDeleteEvent | This member function deletes specified event from the calendar.
DoDeleteSelectedEvents | This member function deletes selected events from the calendar.
EnableMarkup | This member function is used to enable or disable Markup functionality for the control. Enabling this functionality allows a control to process customized special property xtpMarkupTemplate which could be set for each event. If this property exists and contains text with Markup information, it will be drawn inside the Event rectangle (instead of Subject and Body).
EnableReminders | This member function is used to enable or disable Reminders functionality for the control.
EnableSendNotifications | This member function enables or disables sending a notification to all control's event subscribers.
EnableToolTips | This member function is used to enable or disable ToolTips for the control.
GetActiveView | This member function obtains a pointer to the current calendar view.
GetAskItemTextFlags | This member function returns set of flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification. If Calendar theme is set - return value is got from the theme object, otherwise it is got from the paint manager object.
GetCalendarOptions | Call this member function to get direct access to calendar options data.
GetConnection | Obtain a pointer to the notification connection object.
GetDataProvider | Returns common data provider if it was previously set.
GetDayView | This member function obtains a pointer to the Day calendar view.
GetFirstDayOfWeek | This member function obtains the first day of the week.
GetMarkupContext | Returns markup context
GetMonthView | This member function obtains a pointer to the Month calendar view.
GetPaintManager | This member function obtains a pointer to the associated paint manager.
GetPaintTheme | This member function is used to obtain current paint theme.
GetRemindersManager | Obtain an associated Reminders Manager object.
GetResources | Obtain a pointer to collection of Calendar Resources.
GetTheme | This member function obtains a pointer to the associated theme object.
GetWeekView | This member function obtains a pointer to the Week calendar view.
GetWorkDayEndTime |
GetWorkDayStartTime |
GetWorkWeekMask | This member function obtains the bitwise mask of the work week.
HideToolTip | This member function is used to hide the ToolTip rectangle.
IsMarkupEnabled | This member function returns TRUE if Markup functionality is enabled for this Calendar control and FALSE otherwise. In enabled state is automatically process static Markup text for events, and enables processing of dynamic Markup text customization using XTP_NC_CALENDAR_GETITEMTEXT notification.
IsRemindersEnabled | This member function returns TRUE if the Reminders functionality is enabled for this Calendar control and FALSE otherwise.
IsToolTipsEnabled | This member function returns TRUE if the ToolTips enabled, FALSE otherwise.
IsToolTipVisible | This member function is the ToolTip rectangle visible on the screen.
MonthView_IsCompressWeekendDays | Call this method to determine whether weekend days are drawn compressed in month view or not.
MonthView_IsShowEndDate | Call this method to determine whether the end date is shown for events in the month view.
MonthView_IsShowTimeAsClocks | Call this method to determine if the time is shown as a graphical clock for events in the month view.
MonthView_SetCompressWeekendDays | Call this method to specify whether weekend days are drawn compressed in the month view.
MonthView_SetShowEndDate | Call this method to specify whether the end date is shown in the month view.
MonthView_SetShowTimeAsClocks | Call this method to specify if the events start and end time is shown as a graphical clock in the month view.
OnCopy | This member function is used to process the "Copy" command.
OnCut | This member function is used to process the "Cut" command.
OnEditCommand | This member function is used to process the command with specified ID.
OnPaste | This member function is used to process the "Paste" command.
OnUndo | This member function is used to process undo commands.
OnUpdateCmdUI | This member function is used to update the user interface object represented by pCmdUI.
OnUpdateCopy | This member function is used to update the user interface object represented by pCmdUI for the "Copy" command only.
OnUpdateCut | This member function is used to update the user interface object represented by pCmdUI for the "Cut" command only.
OnUpdatePaste | This member function is used to update the user interface object represented by pCmdUI for the "Paste" command only.
OnUpdateUndo | This member function is used to update the user interface object represented by pCmdUI for the "Undo" command only.
OnWndMsg_Children | This member function is used to catch messages before children windows (like Subject editor).
Populate | This member function populates the active control view with events data.
RedrawControl | This member function initiates the Calendar control's redrawing.
RegisterWindowClass | Register the window class if it has not already been registered.
SendNotification | This member function sends a notification to all control's event subscribers.
SendNotificationAlways | This member function sends a notification to all control's event subscribers.
SetDataProvider |
SetFirstDayOfWeek | This member function sets the first day of the week.
SetLayoutRTL | Call this member to set right-to-left mode.
SetPaintManager | This member function sets the new control drawing PaintManager.
SetPaintTheme | This member function is used to set current paint theme.
SetResources | This member function sets the new Resources collection for the control.
SetTheme | This member function sets (or disable) the new control drawing theme.
SetWorkDayEndTime |
SetWorkDayStartTime |
SetWorkWeekMask | This member function sets the bitwise mask for the work week.
ShowToolTip | This member function is used to show a ToolTip rectangle.
SwitchActiveView | This member function sets a predefined calendar view for the control.
UpdateMouseCursor | This member function updates the mouse cursor in relation with the control's state.
WeekView_IsShowEndDate | Call this method to determine if the end date is shown for events in the week view.
WeekView_IsShowTimeAsClocks | Call this method to determine if the time is shown as a graphical clock for events in the week view.
WeekView_SetShowEndDate | Call this method to specify if the end date is shown in week view.
WeekView_SetShowTimeAsClocks | Call this method to specify if the events start and end time is shown as a graphical clock in week view.


CXTPCalendarControl::_SetDataProvider Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::_SetDataProvider Method

This member function internally sets the custom data provider for the control.

virtual void _SetDataProvider(
    CXTPCalendarData* pDataProvider,
    BOOL bCloseDataProviderWhenDestroy = TRUE
);
Parameters

pDataProvider
Pointer to the custom data provider object.
bCloseDataProviderWhenDestroy
BOOL value shows whether data provider should be closed with the control's destruction.

Remarks

This method is used by SetDataProvider().

See Also

SetDataProvider

Group

CXTPCalendarControl Methods


AdjustLayout Method

CXTPCalendarControl Methods
AdjustLayout Method
Overload List
Methods
Method | Description
CXTPCalendarControl::AdjustLayout () | This member function adjusts the main control parts depending on the current control's size.
CXTPCalendarControl::AdjustLayout (CDC*, const CRect&) | This member function adjusts the main control parts depending on the current control's size.
Group

CXTPCalendarControl Methods


CXTPCalendarControl::AdjustLayout Method ()

AdjustLayout Method, CXTPCalendarControl Class, See Also
CXTPCalendarControl::AdjustLayout Method ()

This member function adjusts the main control parts depending on the current control's size.

virtual void AdjustLayout();
virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcView
);
Parameters

pDC
Pointer to a valid device context.
rcView
A rectangle for calendar control.

See Also

CXTPCalendarControl::CUpdateContext, AdjustScrollBar, RedrawControl

Group

AdjustLayout Method


CXTPCalendarControl::AdjustScrollBar Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::AdjustScrollBar Method

This member function adjusts the scroll bar to reflect the current control's state.

virtual void AdjustScrollBar(
    int nSBType = -1
);
Parameters

nSBType
Specifies the scroll bar type to be adjusted. This parameter can be either of the following:

  • SB_HORZ - Horizontal scroll bar.
  • SB_VERT - Vertical scroll bar.

See Also

CXTPCalendarControl::CUpdateContext, AdjustLayout, RedrawControl

Group

CXTPCalendarControl Methods


CXTPCalendarControl::AdjustScrollBarEx Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::AdjustScrollBarEx Method

This member function adjusts the scroll bar to reflect the current control's state.

virtual void AdjustScrollBarEx(
    int nSBType
);
Parameters

nSBType
Specifies the scroll bar type to be adjusted. This parameter can be either of the following:

  • SB_HORZ - Horizontal scroll bar.
  • SB_VERT - Vertical scroll bar.

See Also

CXTPCalendarControl::CUpdateContext, AdjustLayout, RedrawControl

Group

CXTPCalendarControl Methods


CXTPCalendarControl::Create Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::Create Method

This member function handles control window creation.

virtual BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Specifies the window style attributes.
rect
The size and position of the window, in client coordinates of pParentWnd.
pParentWnd
The parent window.
nID
The ID of the child window.

Returns

Nonzero if successful; otherwise 0.

Group

CXTPCalendarControl Methods


CreateDataProvider Method

CXTPCalendarControl Methods
CreateDataProvider Method
Overload List
Methods
Method | Description
CXTPCalendarControl::CreateDataProvider (LPCTSTR) | Call this method to create a data provider from a specified Calendar connection string.
CXTPCalendarControl::CreateDataProvider (XTPCalendarDataProvider) | Call this method to create a data provider of the specified type.
Group

CXTPCalendarControl Methods


CXTPCalendarControl::CreateDataProvider Method (LPCTSTR)

CreateDataProvider Method, CXTPCalendarControl Class
CXTPCalendarControl::CreateDataProvider Method (LPCTSTR)

Call this method to create a data provider from a specified Calendar connection string.

static CXTPCalendarData* CreateDataProvider(
    LPCTSTR lpszConnectionString
);
Parameters

lpszConnectionString
A text Calendar connection string.

Returns

Pointer to the created Calendar Data Provider object.

Remarks

This is a helper method which creates calendar's data provider of the specified type with settings taken from the connection string.

Group

CreateDataProvider Method


CXTPCalendarControl::CreateDataProvider Method (XTPCalendarDataProvider)

CreateDataProvider Method, CXTPCalendarControl Class
CXTPCalendarControl::CreateDataProvider Method (XTPCalendarDataProvider)

Call this method to create a data provider of the specified type.

static CXTPCalendarData* CreateDataProvider(
    XTPCalendarDataProvider eDataProvider
);
Parameters

eDataProvider
A member of XTPCalendarDataProvider enumeration, which specifies a type of the Data Provider to create.

Returns

Pointer to the created Calendar Data Provider object.

Remarks

This is a helper method which creates calendar's data provider of the specified type.

Group

CreateDataProvider Method


CXTPCalendarControl::DataProviderTypeFromConStr Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::DataProviderTypeFromConStr Method

Call this method to retrieve a type of the data provider from its connection string.

static XTPCalendarDataProvider DataProviderTypeFromConStr(
    LPCTSTR lpszConnectionString,
    XTPCalendarDataProvider eDPDefault = xtpCalendarDataProviderUnknown
);
Parameters

lpszConnectionString
A text Calendar connection string.
eDPDefault
Default data provider type to be returned if it can't be determined from the string.

Returns

One of the values from XTPCalendarDataProvider enumeration.

Remarks

This is a helper method which parses a connection string and identifies a type of the data provider which is specified there.

See Also

DataSourceFromConStr(), CreateDataProvider()

Group

CXTPCalendarControl Methods


CXTPCalendarControl::DataSourceFromConStr Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::DataSourceFromConStr Method

Call this method to retrieve a data source connection string from a regular Calendar connection string.

static CString DataSourceFromConStr(
    LPCTSTR lpszConnectionString
);
Parameters

lpszConnectionString
A text Calendar connection string.

Returns

Identified data source connection string.

Remarks

This is a helper method which parses a connection string and identifies a data source connection string there.

See Also

DataProviderTypeFromConStr(), CreateDataProvider()

Group

CXTPCalendarControl Methods


CXTPCalendarControl::DayView_IsAutoResetBusyFlag Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::DayView_IsAutoResetBusyFlag Method

Call this method to determine if the AutoResetBusyFlag is set.

BOOL DayView_IsAutoResetBusyFlag() const;
Returns

Value of AutoResetBusyFlag.

See Also

MonthView_SetCompressWeekendDays

Group

CXTPCalendarControl Methods


CXTPCalendarControl::DayView_SetAutoResetBusyFlag Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::DayView_SetAutoResetBusyFlag Method

Call this method to set the AutoResetBusyFlag.

void DayView_SetAutoResetBusyFlag(
    BOOL bAutoResetBusyFlag = TRUE
);
Parameters

bAutoResetBusyFlag
A BOOL. TRUE to set the AutoResetBusyFlag. FALSE otherwise.

Returns

Value of AutoResetBusyFlag.

See Also

MonthView_SetCompressWeekendDays

Group

CXTPCalendarControl Methods


CXTPCalendarControl::DoDeleteEvent Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::DoDeleteEvent Method

This member function deletes specified event from the calendar.

virtual BOOL DoDeleteEvent(
    CXTPCalendarViewEvent* pViewEvent
);
Parameters

pViewEvent
View of the event to delete.

Returns

TRUE if event was deleted successfully; otherwise FALSE.

Remarks

Call member function if you want to delete an event basing on its View object.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::DoDeleteSelectedEvents Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::DoDeleteSelectedEvents Method

This member function deletes selected events from the calendar.

virtual BOOL DoDeleteSelectedEvents(
    CXTPCalendarViewEvent* pViewEvent
);
Parameters

pViewEvent
View of the last event to delete.

Returns

TRUE if events were deleted successfully; otherwise FALSE.

Remarks

Call member function if you want to delete all selected events.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::EnableMarkup Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::EnableMarkup Method

This member function is used to enable or disable Markup functionality for the control. Enabling this functionality allows a control to process customized special property xtpMarkupTemplate which could be set for each event. If this property exists and contains text with Markup information, it will be drawn inside the Event rectangle (instead of Subject and Body).

void EnableMarkup(
    BOOL bEnableMarkup = TRUE
);
Parameters

bEnable
A BOOL. Specifies whether Markup functionality should be enabled (TRUE) or disabled (FALSE).

See Also

IsMarkupEnabled CXTPCalendarViewEvent::GetMarkupText()

Group

CXTPCalendarControl Methods


CXTPCalendarControl::EnableReminders Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::EnableReminders Method

This member function is used to enable or disable Reminders functionality for the control.

void EnableReminders(
    BOOL bEnable = TRUE
);
Parameters

bEnable
A BOOL. Specifies whether Reminders functionality should be enabled (TRUE) or disabled (FALSE).

See Also

IsRemindersEnabled

Group

CXTPCalendarControl Methods


CXTPCalendarControl::EnableSendNotifications Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::EnableSendNotifications Method

This member function enables or disables sending a notification to all control's event subscribers.

virtual void EnableSendNotifications(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to allow sending notifications, FALSE to disallow.

See Also

SendNotification

Body Source
void CXTPCalendarControl::EnableSendNotifications(BOOL bEnable) {
    m_bEnableSendNotifications = bEnable;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::EnableToolTips Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::EnableToolTips Method

This member function is used to enable or disable ToolTips for the control.

void EnableToolTips(
    BOOL bEnable = TRUE
);
Parameters

bEnable
A BOOL. Specifies whether ToolTips should be enabled (TRUE) or disabled (FALSE).

See Also

IsToolTipsEnabled

Body Source
void CXTPCalendarControl::EnableToolTips(BOOL bEnable) {
    if (!bEnable && IsToolTipVisible()) {
        HideToolTip();
    }
    m_bEnableToolTips = bEnable;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetActiveView Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetActiveView Method

This member function obtains a pointer to the current calendar view.

virtual CXTPCalendarView* GetActiveView();
Returns

A CXTPCalendarView pointer to the associated calendar view object.

Remarks

Call this member function to obtain the calendar view object currently used in this calendar control.

See Also

CXTPCalendarView overview, SetActiveView, GetViewDay, GetWeekView, GetMonthView

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetAskItemTextFlags Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetAskItemTextFlags Method

This member function returns set of flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification. If Calendar theme is set - return value is got from the theme object, otherwise it is got from the paint manager object.

virtual DWORD GetAskItemTextFlags();
Returns

Set of flags from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx.

See Also

XTPCalendarGetItemText, XTPCalendarGetItemTextEx, CXTPCalendarControlPaintManager::GetAskItemTextFlags, CXTPCalendarControlPaintManager::SetAskItemTextFlags, CXTPCalendarTheme::GetAskItemTextFlags, CXTPCalendarTheme::SetAskItemTextFlags, XTP_NC_CALENDAR_GETITEMTEXT

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetCalendarOptions Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetCalendarOptions Method

Call this member function to get direct access to calendar options data.

virtual CXTPCalendarOptions* GetCalendarOptions() const;
Returns

A pointer to calendar options data class CXTPCalendarOptions.

Remarks

This member function wraps CXTPCalendarData::GetCalendarOptions() method. If you read or change returned structure members no additional checks are made and no notifications are sent. The preferred way is to use CXTPCalendarControl options methods like GetWorkWeekMask(), SetWorkWeekMask(), GetFirstDayOfWeek(), SetFirstDayOfWeek(), ... etc.

See Also

CXTPCalendarOptions, CXTPCalendarData::GetCalendarOptions().

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetConnection Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetConnection Method

Obtain a pointer to the notification connection object.

virtual CXTPNotifyConnection* GetConnection();
Returns

Connection object pointer.

Remarks

Used to subscribe (Advice) for notification events from the control.

See Also

CXTPNotifyConnection overview, IXTPNotificationSink overview

Body Source
CXTPNotifyConnection* CXTPCalendarControl::GetConnection() {
    ASSERT(this);
    return this ? m_pConnect : NULL;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetDataProvider Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::GetDataProvider Method

Returns common data provider if it was previously set.

CXTPCalendarData* GetDataProvider();
Returns

A pointer to the common data provider if it was previously set; otherwise, returns NULL.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetDayView Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetDayView Method

This member function obtains a pointer to the Day calendar view.

virtual CXTPCalendarView* GetDayView();
Returns

A CXTPCalendarView pointer to the associated calendar view object.

Remarks

Call this member function to obtain Day calendar view object regardless of its visibility.

See Also

CXTPCalendarView overview, GetActiveView, GetWeekView, GetMonthView

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetFirstDayOfWeek Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetFirstDayOfWeek Method

This member function obtains the first day of the week.

int GetFirstDayOfWeek() const;
Returns

First day of the week represented by an integer from range between 1 and 7, where 1 = Sunday, 2 = Monday, and so on.

See Also

SetFirstDayOfWeek, XTPCalendarWeekDay

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetMarkupContext Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetMarkupContext Method

Returns markup context

CXTPMarkupContext* GetMarkupContext();
Body Source
CXTPMarkupContext* CXTPCalendarControl::GetMarkupContext() {
    return m_pMarkupContext;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetMonthView Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetMonthView Method

This member function obtains a pointer to the Month calendar view.

virtual CXTPCalendarView* GetMonthView();
Returns

A CXTPCalendarView pointer to the associated calendar view object.

Remarks

Call this member function to obtain Month calendar view object regardless of its visibility.

See Also

CXTPCalendarView overview, GetActiveView, GetWeekView, GetDayView

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetPaintManager Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetPaintManager Method

This member function obtains a pointer to the associated paint manager.

CXTPCalendarPaintManager* GetPaintManager();
Returns

A CXTPCalendarPaintManager pointer to the associated paint manager object.

Remarks

Call this member function to obtain the paint manager object used for drawing a calendar control window.

Body Source
CXTPCalendarPaintManager* CXTPCalendarControl::GetPaintManager() {
    ASSERT(this);
    return this ? m_pPaintManager : NULL;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetPaintTheme Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::GetPaintTheme Method

This member function is used to obtain current paint theme.

virtual XTPCalendarTheme GetPaintTheme() const;
Returns

A paint theme ID from enum XTPCalendarTheme.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetRemindersManager Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetRemindersManager Method

Obtain an associated Reminders Manager object.

virtual CXTPCalendarRemindersManager* GetRemindersManager();
Returns

Calendar Reminders Manager.

Remarks

Use this method to retrieve a pointer to the Reminders Manager object associated to this Calendar control..

See Also

CXTPCalendarRemindersManager overview

Body Source
CXTPCalendarRemindersManager* CXTPCalendarControl::GetRemindersManager() {
    ASSERT(this);
    return this ? m_pRemindersManager : NULL;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetResources Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetResources Method

Obtain a pointer to collection of Calendar Resources.

CXTPCalendarResources* GetResources();
Returns

CXTPCalendarResources pointer.

Remarks

Use this method to retrieve a pointer to the Calendar Resources collection of this Calendar control.

See Also

CXTPCalendarResources overview

Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetTheme Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetTheme Method

This member function obtains a pointer to the associated theme object.

CXTPCalendarTheme* GetTheme();
Returns

A CXTPCalendarTheme pointer to the associated theme object or NULL.

Remarks

Themes are used for drawing a calendar control window instead of a Paint manager. This is a new feature of Calendar control which will be further developed. Some new drawing features will be added for themes only (no for Paint manager). But the Paint manager will also be used for compatibility.

Initial version. Themes will be expanded in the feature.

See Also

CXTPCalendarView::GetTheme, GetPaintManager

Body Source
CXTPCalendarTheme* CXTPCalendarControl::GetTheme() {
    ASSERT(this);
    return this ? m_pTheme : NULL;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetWeekView Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetWeekView Method

This member function obtains a pointer to the Week calendar view.

virtual CXTPCalendarView* GetWeekView();
Returns

A CXTPCalendarView pointer to the associated calendar view object.

Remarks

Call this member function to obtain Week calendar view object regardless of its visibility.

See Also

CXTPCalendarView overview, GetActiveView, GetDayView, GetMonthView

Group

CXTPCalendarControl Methods


GetWorkDayEndTime Method

CXTPCalendarControl Methods
GetWorkDayEndTime Method
Overload List
Methods
Method | Description
CXTPCalendarControl::GetWorkDayEndTime (COleDateTime&) | This member function obtains the end time of the working day.
CXTPCalendarControl::GetWorkDayEndTime (int&, int&, int&) | This member function obtains the end time of the working day.
Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetWorkDayEndTime Method (COleDateTime&)

GetWorkDayEndTime Method, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetWorkDayEndTime Method (COleDateTime&)

This member function obtains the end time of the working day.

void GetWorkDayEndTime(
    COleDateTime& dtTime
);
void GetWorkDayEndTime(
    int& nHour,
    int& nMin,
    int& nSec
);
Parameters

dtTime
A reference to the COleDateTime value to store the result.
nHour
An int. A reference to the hour part of the result.
nMin
An int. A reference to the minutes part of the result.
nSec
An int. A reference to the seconds part of the result.

See Also

SetWorkDayEndTime, GetWorkDayStartTime, SetWorkDayStartTime

Group

GetWorkDayEndTime Method


GetWorkDayStartTime Method

CXTPCalendarControl Methods
GetWorkDayStartTime Method
Overload List
Methods
Method | Description
CXTPCalendarControl::GetWorkDayStartTime (COleDateTime&) | This member function obtains the begin time of the working day.
CXTPCalendarControl::GetWorkDayStartTime (int&, int&, int&) | This member function obtains the begin time of the working day.
Group

CXTPCalendarControl Methods


CXTPCalendarControl::GetWorkDayStartTime Method (COleDateTime&)

GetWorkDayStartTime Method, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetWorkDayStartTime Method (COleDateTime&)

This member function obtains the begin time of the working day.

void GetWorkDayStartTime(
    COleDateTime& dtTime
);
void GetWorkDayStartTime(
    int& nHour,
    int& nMin,
    int& nSec
);
Parameters

dtTime
A reference to the COleDateTime value to store the result.
nHour
An int. A reference to the hour part of the result.
nMin
An int. A reference to the minutes part of the result.
nSec
An int. A reference to the seconds part of the result.

See Also

SetWorkDayStartTime, GetWorkDayEndTime, SetWorkDayEndTime

Group

GetWorkDayStartTime Method


CXTPCalendarControl::GetWorkWeekMask Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::GetWorkWeekMask Method

This member function obtains the bitwise mask of the work week.

int GetWorkWeekMask() const;
Returns

An integer containing the bitwise day mask.

See Also

SetWorkWeekMask, XTPCalendarWeekDay

Group

CXTPCalendarControl Methods


CXTPCalendarControl::HideToolTip Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::HideToolTip Method

This member function is used to hide the ToolTip rectangle.

virtual void HideToolTip();
See Also

IsToolTipVisible

Group

CXTPCalendarControl Methods


CXTPCalendarControl::IsMarkupEnabled Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::IsMarkupEnabled Method

This member function returns TRUE if Markup functionality is enabled for this Calendar control and FALSE otherwise. In enabled state is automatically process static Markup text for events, and enables processing of dynamic Markup text customization using XTP_NC_CALENDAR_GETITEMTEXT notification.

BOOL IsMarkupEnabled() const;
Returns

TRUE if Markup feature is enabled, FALSE otherwise.

See Also

EnableMarkup(), CXTPCalendarViewEvent::GetMarkupText()

Body Source
BOOL CXTPCalendarControl::IsMarkupEnabled() const {
    return m_pMarkupContext != NULL;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::IsRemindersEnabled Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::IsRemindersEnabled Method

This member function returns TRUE if the Reminders functionality is enabled for this Calendar control and FALSE otherwise.

BOOL IsRemindersEnabled() const;
Returns

TRUE if reminders are enabled, FALSE otherwise.

See Also

EnableReminders()

Group

CXTPCalendarControl Methods


CXTPCalendarControl::IsToolTipsEnabled Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::IsToolTipsEnabled Method

This member function returns TRUE if the ToolTips enabled, FALSE otherwise.

BOOL IsToolTipsEnabled() const;
Returns

TRUE if the ToolTips enabled, FALSE otherwise.

See Also

EnableToolTips

Body Source
BOOL CXTPCalendarControl::IsToolTipsEnabled() const {
    return m_bEnableToolTips;
}
Group

CXTPCalendarControl Methods


CXTPCalendarControl::IsToolTipVisible Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::IsToolTipVisible Method

This member function is the ToolTip rectangle visible on the screen.

virtual BOOL IsToolTipVisible() const;
Returns

TRUE if ToolTip rectangle visible, FALSE otherwise.

See Also

HideToolTip

Group

CXTPCalendarControl Methods


CXTPCalendarControl::MonthView_IsCompressWeekendDays Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::MonthView_IsCompressWeekendDays Method

Call this method to determine whether weekend days are drawn compressed in month view or not.

BOOL MonthView_IsCompressWeekendDays() const;
Returns

TRUE if weekend days are drawn compressed. FALSE otherwise.

See Also

MonthView_SetCompressWeekendDays

Group

CXTPCalendarControl Methods


CXTPCalendarControl::MonthView_IsShowEndDate Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::MonthView_IsShowEndDate Method

Call this method to determine whether the end date is shown for events in the month view.

BOOL MonthView_IsShowEndDate() const;
Returns

TRUE if the end date is shown. FALSE otherwise.

See Also

MonthView_SetShowEndDate

Group

CXTPCalendarControl Methods


CXTPCalendarControl::MonthView_IsShowTimeAsClocks Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::MonthView_IsShowTimeAsClocks Method

Call this method to determine if the time is shown as a graphical clock for events in the month view.

BOOL MonthView_IsShowTimeAsClocks() const;
Returns

TRUE for time shown as graphical clock. FALSE otherwise.

See Also

MonthView_SetShowTimeAsClocks

Group

CXTPCalendarControl Methods


CXTPCalendarControl::MonthView_SetCompressWeekendDays Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::MonthView_SetCompressWeekendDays Method

Call this method to specify whether weekend days are drawn compressed in the month view.

void MonthView_SetCompressWeekendDays(
    BOOL bCompress = TRUE
);
Parameters

bCompress
A BOOL. TRUE if weekend days are drawn compressed. FALSE otherwise.

See Also

MonthView_IsCompressWeekendDays

Group

CXTPCalendarControl Methods


CXTPCalendarControl::MonthView_SetShowEndDate Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::MonthView_SetShowEndDate Method

Call this method to specify whether the end date is shown in the month view.

void MonthView_SetShowEndDate(
    BOOL bShowEnd = TRUE
);
Parameters

bShowEnd
A BOOL. TRUE if the end date is shown in month view. FALSE otherwise.

See Also

MonthView_IsShowEndDate

Group

CXTPCalendarControl Methods


CXTPCalendarControl::MonthView_SetShowTimeAsClocks Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::MonthView_SetShowTimeAsClocks Method

Call this method to specify if the events start and end time is shown as a graphical clock in the month view.

void MonthView_SetShowTimeAsClocks(
    BOOL bShowClocks = TRUE
);
Parameters

bShowClocks
A BOOL. TRUE if the time is shown as a graphical clock. FALSE otherwise.

See Also

MonthView_IsShowTimeAsClocks

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnBeforeDestroy Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::OnBeforeDestroy Method

This member function is called by the framework before the view is destroyed.

virtual void OnBeforeDestroy();
Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnCopy Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnCopy Method

This member function is used to process the "Copy" command.

virtual afx_msg void OnCopy();
See Also

OnCommand, OnUndo, OnCut, OnPaste

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnCut Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnCut Method

This member function is used to process the "Cut" command.

virtual afx_msg void OnCut();
See Also

OnCommand, OnUndo, OnCopy, OnPaste

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnDraw Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnDraw Method

This member function performs all of the drawing logic of the calendar control window.

virtual void OnDraw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

See Also

OnPaint

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnEditCommand Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnEditCommand Method

This member function is used to process the command with specified ID.

virtual void OnEditCommand(
    UINT uCommandID
);
Parameters

uCommandID
Command ID. Specifies which command to process.

See Also

OnUndo, OnCut, OnCopy, OnPaste

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnOptionsChanged Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnOptionsChanged Method

This member function is called by the calendar control when calendar option was changed.

virtual void OnOptionsChanged(
    int nOptionRelation
);
Parameters

nOptionRelation
Changed option relation (or kind). Value -1 specify global or common option. Value from XTPCalendarViewType enum specify which kind of view changed option is related.

Returns

TRUE if events were deleted successfully; otherwise FALSE.

Remarks

It is called from the set option methods like SetWorkWeekMask(), SetFirstDayOfWeek(), SetWorkDayStartTime(), SetWorkDayEndTime(), DayView_SetAutoResetBusyFlag(), ... etc. See CXTPCalendarOptions for details. Default implementation sends XTP_NC_CALENDAROPTIONSWASCHANGED notification.

See Also

CXTPCalendarOptions, CXTPCalendarData::GetCalendarOptions(), XTP_NC_CALENDAROPTIONSWASCHANGED,

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnPaste Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnPaste Method

This member function is used to process the "Paste" command.

virtual afx_msg void OnPaste();
See Also

OnCommand, OnUndo, OnCut, OnCopy

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnUndo Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnUndo Method

This member function is used to process undo commands.

virtual afx_msg void OnUndo();
See Also

OnCommand, OnCut, OnCopy, OnPaste

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnUpdateCmdUI Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnUpdateCmdUI Method

This member function is used to update the user interface object represented by pCmdUI.

virtual afx_msg void OnUpdateCmdUI(
    CCmdUI* pCmdUI
);
Parameters

pCmdUI
pointer to the CCmdUI object.

See Also

OnUpdateUndo, OnUpdateCut, OnUpdateCopy, OnUpdatePaste

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnUpdateCopy Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnUpdateCopy Method

This member function is used to update the user interface object represented by pCmdUI for the "Copy" command only.

virtual afx_msg void OnUpdateCopy(
    CCmdUI* pCmdUI
);
Parameters

pCmdUI
pointer to the CCmdUI object.

See Also

OnUpdateUndo, OnUpdateUndo, OnUpdateCut, OnUpdatePaste

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnUpdateCut Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnUpdateCut Method

This member function is used to update the user interface object represented by pCmdUI for the "Cut" command only.

virtual afx_msg void OnUpdateCut(
    CCmdUI* pCmdUI
);
Parameters

pCmdUI
pointer to the CCmdUI object.

See Also

OnUpdateUndo, OnUpdateUndo, OnUpdateCopy, OnUpdatePaste

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnUpdatePaste Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnUpdatePaste Method

This member function is used to update the user interface object represented by pCmdUI for the "Paste" command only.

virtual afx_msg void OnUpdatePaste(
    CCmdUI* pCmdUI
);
Parameters

pCmdUI
pointer to the CCmdUI object.

See Also

OnUpdateUndo, OnUpdateUndo, OnUpdateCut, OnUpdateCopy

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnUpdateUndo Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnUpdateUndo Method

This member function is used to update the user interface object represented by pCmdUI for the "Undo" command only.

virtual afx_msg void OnUpdateUndo(
    CCmdUI* pCmdUI
);
Parameters

pCmdUI
pointer to the CCmdUI object.

See Also

OnUpdateUndo, OnUpdateCut, OnUpdateCopy, OnUpdatePaste

Group

CXTPCalendarControl Methods


CXTPCalendarControl::OnWndMsg_Children Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::OnWndMsg_Children Method

This member function is used to catch messages before children windows (like Subject editor).

virtual BOOL OnWndMsg_Children(
    UINT message,
    WPARAM wParam,
    LPARAM lParam,
    LRESULT* pResult
);
Parameters

message
Specifies the message to be sent.
wParam
Specifies additional message-dependent information.
lParam
Specifies additional message-dependent information.
pResult
The return value of WindowProc. Depends on the message; may be NULL.

Returns

TRUE if message was handled; otherwise FALSE.

Remarks

The children windows must call OnWndMsg_Children() for the messages which are interesting for other calendar control parts (main control window, view, day view, event view). The OnWndMsg() method may be overridden for this purposes. This mechanism is used instead of PreTranslateMessage() for ActiveX builds.

See Also

CXTPCalendarViewEventSubjectEditor, OnWndMsg().

Group

CXTPCalendarControl Methods


CXTPCalendarControl::Populate Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::Populate Method

This member function populates the active control view with events data.

virtual void Populate();
Remarks

Creates a new events views collection for the view, populating it with the data objects taken from the associated data provider.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::RedrawControl Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::RedrawControl Method

This member function initiates the Calendar control's redrawing.

virtual void RedrawControl(
    BOOL bForce = FALSE
);
Parameters

bForce
Set this parameter to TRUE if you'd like to force control's redrawing even if update is locked.

Remarks

Call this member function if you want to force the control's redrawing. The control will be redrawn to reflect its latest state.

See Also

CXTPCalendarControl::CUpdateContext, AdjustLayout, AdjustScrollBar, LockUpdate, UnlockUpdate.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::RegisterWindowClass Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::RegisterWindowClass Method

Register the window class if it has not already been registered.

virtual BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

TRUE if the window class was successfully registered. FALSE otherwise.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SendNotification Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SendNotification Method

This member function sends a notification to all control's event subscribers.

virtual void SendNotification(
    XTP_NOTIFY_CODE EventCode,
    WPARAM wParam,
    LPARAM lParam
);
virtual void SendNotificationAlways(
    XTP_NOTIFY_CODE EventCode,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

EventCode
A specific code identifying the event.
wParam
First custom parameter. Depends on the event type. See specific event description for details.
lParam
Second custom parameter. Depends on the event type. See specific event description for details.

Remarks

This member function is called internally from inside the control when a notification is sent to all notification listeners. SendNotification depends on EnableSendNotifications flag. SendNotificationAlways - Performs send in any case.

See Also

XTP_NOTIFY_CODE, GetConnection

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetActiveView Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SetActiveView Method

This member function sets the custom calendar view for the control.

virtual void SetActiveView(
    CXTPCalendarView* pView
);
Parameters

pView
Pointer to the custom calendar view object.

Remarks

Call this member function to set the custom calendar view currently used by the calendar control. Note that custom calendar view must be descendant of CXTPCalendarView.

See Also

CXTPCalendarView overview, GetAvtiveView

Group

CXTPCalendarControl Methods


SetDataProvider Method

CXTPCalendarControl Methods
SetDataProvider Method
Overload List
Methods
Method | Description
CXTPCalendarControl::SetDataProvider (CXTPCalendarData*, BOOL) | This member function sets the custom data provider for the control.
CXTPCalendarControl::SetDataProvider (LPCTSTR) | This member function sets a predefined data provider for the control.
CXTPCalendarControl::SetDataProvider (XTPCalendarDataProvider, LPCTSTR) | This member function sets a predefined data provider for the control.
Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetDataProvider Method (CXTPCalendarData*, BOOL)

SetDataProvider Method, CXTPCalendarControl Class, See Also
CXTPCalendarControl::SetDataProvider Method (CXTPCalendarData*, BOOL)

This member function sets the custom data provider for the control.

void SetDataProvider(
    CXTPCalendarData* pDataProvider,
    BOOL bCloseDataProviderWhenDestroy = TRUE
);
Parameters

pDataProvider
Pointer to the custom data provider object.
bCloseDataProviderWhenDestroy
BOOL value shows whether data provider should be closed with the control's destruction.

Remarks

Call this member function to set the custom data provider that is currently used by this calendar control. Note that custom data provider must be a descendant of CXTPCalendarData.

See Also

CXTPCalendarData overview, GetDataProvider

Group

SetDataProvider Method


CXTPCalendarControl::SetDataProvider Method (LPCTSTR)

SetDataProvider Method, CXTPCalendarControl Class, See Also
CXTPCalendarControl::SetDataProvider Method (LPCTSTR)

This member function sets a predefined data provider for the control.

void SetDataProvider(
    LPCTSTR lpszConnectionString
);
void SetDataProvider(
    XTPCalendarDataProvider eDataProvider,
    LPCTSTR lpszConnectionString = NULL
);
Parameters

lpszConnectionString
A text Calendar connection string.
eDataProvider
Data provider type.

Remarks

Call this member function to set the predefined data provider that is currently used by this calendar control.

See Also

CXTPCalendarData overview, XTPCalendarDataProvider, GetDataProvider

Group

SetDataProvider Method


CXTPCalendarControl::SetFirstDayOfWeek Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SetFirstDayOfWeek Method

This member function sets the first day of the week.

void SetFirstDayOfWeek(
    const int nFirstDayOfWeek
);
Parameters

nFirstDayOfWeek
An int that contains the new first day of the week. An integer from range between 1 and 7, where 1 = Sunday, 2 = Monday, and so on.

See Also

GetFirstDayOfWeek, XTPCalendarWeekDay

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetLayoutRTL Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::SetLayoutRTL Method

Call this member to set right-to-left mode.

void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetPaintManager Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SetPaintManager Method

This member function sets the new control drawing PaintManager.

void SetPaintManager(
    CXTPCalendarPaintManager* pPaintManager
);
Parameters

pPaintManager
A CXTPCalendarPaintManager pointer to the new paint manager object.

Remarks

Call this member function to set the paint manager object used for drawing a calendar control window.

See Also

GetPaintManager

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetPaintTheme Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::SetPaintTheme Method

This member function is used to set current paint theme.

virtual void SetPaintTheme(
    XTPCalendarTheme ePaintTheme
);
Parameters

ePaintTheme
A paint theme ID from enum XTPCalendarTheme.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetResources Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::SetResources Method

This member function sets the new Resources collection for the control.

void SetResources(
    CXTPCalendarResources* pResources,
    CXTPCalendarData* pOptionsDataProvider = NULL
);
Parameters

pResources
A pointer to the CXTPCalendarResources collection object.
pOptionsDataProvider
A pointer to the Data Provider object for using on Calendar Options.

Remarks

Call this member function to programmatically set the new Resources collection for the control.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetTheme Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SetTheme Method

This member function sets (or disable) the new control drawing theme.

void SetTheme(
    CXTPCalendarTheme* pTheme
);
Parameters

pTheme
A CXTPCalendarTheme pointer to the theme object. If pTheme is NULL - themes are disabled and the paint manager is used.

Remarks

Themes are used for drawing a calendar control window instead of a Paint manager. This is a new feature of Calendar control which will be further developed. Some new drawing features will be added for themes only (no for Paint manager). But the Paint manager will also be used for compatibility.

Initial version. Themes will be expanded in the feature.

See Also

GetPaintManager

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetTimer Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::SetTimer Method

This member function creates a timer event.

virtual UINT SetTimer(
    UINT uTimeOut_ms
);
Parameters

uTimeOut_ms
Duration of timer in milliseconds.

Returns

The identifier of the timer.

Group

CXTPCalendarControl Methods


SetWorkDayEndTime Method

CXTPCalendarControl Methods
SetWorkDayEndTime Method
Overload List
Methods
Method | Description
CXTPCalendarControl::SetWorkDayEndTime (const COleDateTime&) | This member function sets an end time for the working day.
CXTPCalendarControl::SetWorkDayEndTime (int, int, int) | This member function sets an end time for the working day.
Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetWorkDayEndTime Method (const COleDateTime&)

SetWorkDayEndTime Method, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SetWorkDayEndTime Method (const COleDateTime&)

This member function sets an end time for the working day.

void SetWorkDayEndTime(
    const COleDateTime& dtTime
);
void SetWorkDayEndTime(
    int nHour,
    int nMin,
    int nSec
);
Parameters

dtTime
A new end time value.
nHour
An int. The hour part of the new time value.
nMin
An int. The minutes part of the new time value.
nSec
An int. The seconds part of the new time value.

See Also

GetWorkDayEndTime, GetWorkDayStartTime, SetWorkDayStartTime

Group

SetWorkDayEndTime Method


SetWorkDayStartTime Method

CXTPCalendarControl Methods
SetWorkDayStartTime Method
Overload List
Methods
Method | Description
CXTPCalendarControl::SetWorkDayStartTime (const COleDateTime&) | This member function sets the begin time for the working day.
CXTPCalendarControl::SetWorkDayStartTime (int, int, int) | This member function sets the begin time for the working day.
Group

CXTPCalendarControl Methods


CXTPCalendarControl::SetWorkDayStartTime Method (const COleDateTime&)

SetWorkDayStartTime Method, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SetWorkDayStartTime Method (const COleDateTime&)

This member function sets the begin time for the working day.

void SetWorkDayStartTime(
    const COleDateTime& dtTime
);
void SetWorkDayStartTime(
    int nHour,
    int nMin,
    int nSec
);
Parameters

dtTime
A new begin time value.
nHour
An int. The hour part of the new time value.
nMin
An int. The minutes part of the new time value.
nSec
An int. The seconds part of the new time value.

See Also

GetWorkDayStartTime, GetWorkDayEndTime, SetWorkDayEndTime

Group

SetWorkDayStartTime Method


CXTPCalendarControl::SetWorkWeekMask Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SetWorkWeekMask Method

This member function sets the bitwise mask for the work week.

void SetWorkWeekMask(
    const int nMask
);
Parameters

nMask
An int that contains the new bitwise mask for the work week.

See Also

GetWorkWeekMask, XTPCalendarWeekDay

Group

CXTPCalendarControl Methods


CXTPCalendarControl::ShowToolTip Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::ShowToolTip Method

This member function is used to show a ToolTip rectangle.

virtual void ShowToolTip(
    const CString& strText,
    const CRect rcToolTip,
    CFont* pFont,
    BOOL bAdvanced = FALSE
);
Parameters

strText
A text to be shown inside a tooltip rectangle.
rcToolTip
A rect for a tooltip window.
pFont
Font for to draw tooltip text.
bAdvanced
TRUE for advanced processing (Office2007 theme "add new appt")

Group

CXTPCalendarControl Methods


CXTPCalendarControl::SwitchActiveView Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::SwitchActiveView Method

This member function sets a predefined calendar view for the control.

virtual void SwitchActiveView(
    XTPCalendarViewType eView
);
Parameters

eView
Calendar view type.

Remarks

Call this member function to set the predefined calendar view that is currently used by this calendar control.

See Also

CXTPCalendarView overview, XTPCalendarViewType, GetAvtiveView

Group

CXTPCalendarControl Methods


CXTPCalendarControl::UpdateMouseCursor Method

CXTPCalendarControl Methods, CXTPCalendarControl Class
CXTPCalendarControl::UpdateMouseCursor Method

This member function updates the mouse cursor in relation with the control's state.

virtual BOOL UpdateMouseCursor();
Returns

A BOOL. TRUE if the mouse cursor was updated to one of the known modes, FALSE if the mode is unknown and the cursor was set to default arrow.

Group

CXTPCalendarControl Methods


CXTPCalendarControl::WeekView_IsShowEndDate Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::WeekView_IsShowEndDate Method

Call this method to determine if the end date is shown for events in the week view.

BOOL WeekView_IsShowEndDate() const;
Returns

TRUE if the end date is shown. FALSE otherwise.

See Also

WeekView_SetShowEndDate

Group

CXTPCalendarControl Methods


CXTPCalendarControl::WeekView_IsShowTimeAsClocks Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::WeekView_IsShowTimeAsClocks Method

Call this method to determine if the time is shown as a graphical clock for events in the week view.

BOOL WeekView_IsShowTimeAsClocks() const;
Returns

TRUE for time shown as graphical clocks, FALSE otherwise.

See Also

WeekView_SetShowTimeAsClocks

Group

CXTPCalendarControl Methods


CXTPCalendarControl::WeekView_SetShowEndDate Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::WeekView_SetShowEndDate Method

Call this method to specify if the end date is shown in week view.

void WeekView_SetShowEndDate(
    BOOL bShowEnd
);
Parameters

bShowEnd
A BOOL. TRUE if the end date is shown in week view. FALSE otherwise.

See Also

WeekView_IsShowEndDate

Group

CXTPCalendarControl Methods


CXTPCalendarControl::WeekView_SetShowTimeAsClocks Method

CXTPCalendarControl Methods, CXTPCalendarControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::WeekView_SetShowTimeAsClocks Method

Call this method to specify if the events start and end time is shown as a graphical clock in week view.

void WeekView_SetShowTimeAsClocks(
    BOOL bShowClocks
);
Parameters

bShowClocks
A BOOL. TRUE for time to be shown as graphical clocks, FALSE otherwise.

See Also

WeekView_IsShowTimeAsClocks

Group

CXTPCalendarControl Methods


CXTPCalendarControl Constructors

CXTPCalendarControl Class, Legend, Public Methods
CXTPCalendarControl Constructors
Class

CXTPCalendarControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarControl | This member function constructs a CXTPCalendarControl object.


CXTPCalendarControl::CXTPCalendarControl Constructor

CXTPCalendarControl Constructors, CXTPCalendarControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControl::CXTPCalendarControl Constructor

This member function constructs a CXTPCalendarControl object.

CXTPCalendarControl();
Remarks

Construct a CXTPCalendarControl object in two steps. First, call the constructor CXTPCalendarControl and then call Create method, which initializes the window.

See Also

Create

Example
Declare a local CXTPCalendarControl object.
CXTPCalendarControl myCalendar;

// Declare a dynamic CXTPCalendarControl object.
CXTPCalendarControl* pMyCalendar = new CXTPCalendarControl();

// Create a window
if (!myCalendar.Create(WS_CHILD | WS_TABSTOP | WS_VISIBLE, rcRect, this, ID_CALENDAR_CONTROL))
{
    TRACE(_T("Failed to create calendar control windown"));
}
Group

CXTPCalendarControl Constructors


CXTPCalendarControl Destructors

CXTPCalendarControl Class, Legend, Public Methods
CXTPCalendarControl Destructors
Class

CXTPCalendarControl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarControl | This member function destroys a CXTPCalendarControl object and handles cleanup and de-allocation.


CXTPCalendarControl::~CXTPCalendarControl Destructor

CXTPCalendarControl Destructors, CXTPCalendarControl Class
CXTPCalendarControl::~CXTPCalendarControl Destructor

This member function destroys a CXTPCalendarControl object and handles cleanup and de-allocation.

virtual ~CXTPCalendarControl();
Group

CXTPCalendarControl Destructors


CXTPCalendarController Class

XTPCalendarController.h, Classes, Legend, Members, Topics, CXTPCalendarController Data Members, CXTPCalendarController Methods, CXTPCalendarController Constructors, CXTPCalendarController Destructors, CXTPCalendarController Constructors, CXTPCalendarController Data Members, CXTPCalendarController Destructors, CXTPCalendarController Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController Class

Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object.

Class Hierarchy

class CXTPCalendarController;
File

XTPCalendarController.h

Remarks

A CXTPCalendarController object provides a synchronization facilities between CXTPCalendarControl and CXTPDatePickerControl controls. It works as a "glue" between both controls and reflects changes on one of them to the corresponded changes on the second one.

See Also

CXTPCalendarControl, CXTPDatePickerControl

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarController Constructors
CXTPCalendarController Constructors | Description
CXTPCalendarController | Constructs a CXTPCalendarController object.
CXTPCalendarController Data Members
CXTPCalendarController Data Members | Description
m_bBoldDaysOnIdle | TRUE to retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
m_bBoldDaysWithEvents | TRUE to use Bold for days with events in the associated DatePicker.
m_bUseActiveViewResoucesForBold | If true - active view resources are used, if FALSE - calendar control Resources are used.
m_nBoldDaysIdleStepTime_ms | Time between idle steps to update days state (bold or regular) for the associated DatePicker.
m_nBoldDaysPerIdleStep | Amount of days for the associated DatePicker to update state in one idle step.
m_pCalendarCtrl | Pointer to the associated Calendar control.
m_pDatePickerCtrl | Pointer to the associated DatePicker control.
CXTPCalendarController Destructors
CXTPCalendarController Destructors | Description
~CXTPCalendarController | Destroys a CXTPCalendarController object, handles cleanup and de-allocation.
CXTPCalendarController Methods
CXTPCalendarController Methods | Description
_HasEvents | This member function used to determine has the specified day events or not.
AdviseToNotifications | This member function subscribes itself for all necessary notifications.
GetBoldDaysIdleStepTime_ms | Returns time between idle steps to update days state (bold or regular) for the associated DatePicker.
GetBoldDaysPerIdleStep | Returns Amount of days for the associated DatePicker to update state in one idle step.
GetCalendar | Get a calendar control object associated with the controller.
GetDatePicker | Get a date picker control object associated with the controller.
IsBoldDaysOnIdle | Is BoldDaysOnIdle option enabled or disabled.
IsBoldDaysWithEvents | This member function used to determine whether Bold font is used for days in DatePicker which have corresponding Calendar events.
IsFirstDayOfWeekShifted_FromSun2Mon | This member function used to determine is Compressed Weekend Day - Sunday, used as first day of week in the active calendar view.
OnEvent_CalendarOptionsChanged | This member function catches all the events when calendar control options were changed.
OnEvent_CalendarResourcesChanged | This member function catches all the events when resource configuration was changed in the CalendarControl.
OnEvent_CalendarThemeChanged | This member function catches the XTP_NC_CALENDAR_THEME_CHANGED event.
OnEvent_CalendarView | This member function catches all the events from the associated calendar control and its view.
OnEvent_DatePicker | This member function catches all the events from the associated date picker control.
OnEvent_DtPickGetItemMetrics | This member function catches all the events from the associated date picker control.
SetBoldDaysIdleStepTime_ms | Set time (in milliseconds) between idle steps to update days state (bold or regular) for the associated DatePicker.
SetBoldDaysOnIdle | Enable or Disable retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
SetBoldDaysPerIdleStep | Set amount of days for the associated DatePicker to update state in one idle step.
SetBoldDaysWithEvents | This member function enables or disables Bold font usage for displaying days in DatePicker which have corresponding Calendar events.
SetCalendar | This member function associates a custom calendar control with the controller.
SetDatePicker | This member function associates a custom date picker control with the controller.
SetFirstDayOfWeekToDatePicker | This member function get first day of week from the calendar control and set the same value to the date picker control.


CXTPCalendarController Data Members

CXTPCalendarController Class, Legend, Protected Data Members
CXTPCalendarController Data Members
Class

CXTPCalendarController Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bBoldDaysOnIdle | TRUE to retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
m_bBoldDaysWithEvents | TRUE to use Bold for days with events in the associated DatePicker.
m_bUseActiveViewResoucesForBold | If true - active view resources are used, if FALSE - calendar control Resources are used.
m_nBoldDaysIdleStepTime_ms | Time between idle steps to update days state (bold or regular) for the associated DatePicker.
m_nBoldDaysPerIdleStep | Amount of days for the associated DatePicker to update state in one idle step.
m_pCalendarCtrl | Pointer to the associated Calendar control.
m_pDatePickerCtrl | Pointer to the associated DatePicker control.


CXTPCalendarController::m_bBoldDaysOnIdle Data Member

CXTPCalendarController Data Members, CXTPCalendarController Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::m_bBoldDaysOnIdle Data Member

TRUE to retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.

BOOL m_bBoldDaysOnIdle;
Group

CXTPCalendarController Data Members


CXTPCalendarController::m_bBoldDaysWithEvents Data Member

CXTPCalendarController Data Members, CXTPCalendarController Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::m_bBoldDaysWithEvents Data Member

TRUE to use Bold for days with events in the associated DatePicker.

BOOL m_bBoldDaysWithEvents;
Group

CXTPCalendarController Data Members


CXTPCalendarController::m_bUseActiveViewResoucesForBold Data Member

CXTPCalendarController Data Members, CXTPCalendarController Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::m_bUseActiveViewResoucesForBold Data Member

If true - active view resources are used, if FALSE - calendar control Resources are used.

BOOL m_bUseActiveViewResoucesForBold;
Group

CXTPCalendarController Data Members


CXTPCalendarController::m_nBoldDaysIdleStepTime_ms Data Member

CXTPCalendarController Data Members, CXTPCalendarController Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::m_nBoldDaysIdleStepTime_ms Data Member

Time between idle steps to update days state (bold or regular) for the associated DatePicker.

long m_nBoldDaysIdleStepTime_ms;
Group

CXTPCalendarController Data Members


CXTPCalendarController::m_nBoldDaysPerIdleStep Data Member

CXTPCalendarController Data Members, CXTPCalendarController Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::m_nBoldDaysPerIdleStep Data Member

Amount of days for the associated DatePicker to update state in one idle step.

long m_nBoldDaysPerIdleStep;
Group

CXTPCalendarController Data Members


CXTPCalendarController::m_pCalendarCtrl Data Member

CXTPCalendarController Data Members, CXTPCalendarController Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::m_pCalendarCtrl Data Member

Pointer to the associated Calendar control.

CXTPCalendarControl* m_pCalendarCtrl;
Group

CXTPCalendarController Data Members


CXTPCalendarController::m_pDatePickerCtrl Data Member

CXTPCalendarController Data Members, CXTPCalendarController Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::m_pDatePickerCtrl Data Member

Pointer to the associated DatePicker control.

CXTPDatePickerControl* m_pDatePickerCtrl;
Group

CXTPCalendarController Data Members


CXTPCalendarController Methods

CXTPCalendarController Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController Methods
Class

CXTPCalendarController Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_HasEvents | This member function used to determine has the specified day events or not.
AdviseToNotifications | This member function subscribes itself for all necessary notifications.
IsFirstDayOfWeekShifted_FromSun2Mon | This member function used to determine is Compressed Weekend Day - Sunday, used as first day of week in the active calendar view.
OnEvent_CalendarOptionsChanged | This member function catches all the events when calendar control options were changed.
OnEvent_CalendarResourcesChanged | This member function catches all the events when resource configuration was changed in the CalendarControl.
OnEvent_CalendarThemeChanged | This member function catches the XTP_NC_CALENDAR_THEME_CHANGED event.
OnEvent_CalendarView | This member function catches all the events from the associated calendar control and its view.
OnEvent_DatePicker | This member function catches all the events from the associated date picker control.
OnEvent_DtPickGetItemMetrics | This member function catches all the events from the associated date picker control.
SetFirstDayOfWeekToDatePicker | This member function get first day of week from the calendar control and set the same value to the date picker control.
Public Methods
Public Methods
Public Method | Description
GetBoldDaysIdleStepTime_ms | Returns time between idle steps to update days state (bold or regular) for the associated DatePicker.
GetBoldDaysPerIdleStep | Returns Amount of days for the associated DatePicker to update state in one idle step.
GetCalendar | Get a calendar control object associated with the controller.
GetDatePicker | Get a date picker control object associated with the controller.
IsBoldDaysOnIdle | Is BoldDaysOnIdle option enabled or disabled.
IsBoldDaysWithEvents | This member function used to determine whether Bold font is used for days in DatePicker which have corresponding Calendar events.
SetBoldDaysIdleStepTime_ms | Set time (in milliseconds) between idle steps to update days state (bold or regular) for the associated DatePicker.
SetBoldDaysOnIdle | Enable or Disable retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
SetBoldDaysPerIdleStep | Set amount of days for the associated DatePicker to update state in one idle step.
SetBoldDaysWithEvents | This member function enables or disables Bold font usage for displaying days in DatePicker which have corresponding Calendar events.
SetCalendar | This member function associates a custom calendar control with the controller.
SetDatePicker | This member function associates a custom date picker control with the controller.


CXTPCalendarController::_HasEvents Method

CXTPCalendarController Methods, CXTPCalendarController Class
CXTPCalendarController::_HasEvents Method

This member function used to determine has the specified day events or not.

BOOL _HasEvents(
    COleDateTime dtDay
);
Parameters

dtDay
A COleDateTime object that contains the day's date.

Returns

TRUE if the specified day has events, FALSE otherwise.

Group

CXTPCalendarController Methods


CXTPCalendarController::AdviseToNotifications Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::AdviseToNotifications Method

This member function subscribes itself for all necessary notifications.

virtual void AdviseToNotifications();
Remarks

This member function is called when controller object wants to reinitialize its event subscriptions from associated controls.

See Also

CXTPCalendarController overview

Group

CXTPCalendarController Methods


CXTPCalendarController::GetBoldDaysIdleStepTime_ms Method

CXTPCalendarController Methods, CXTPCalendarController Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::GetBoldDaysIdleStepTime_ms Method

Returns time between idle steps to update days state (bold or regular) for the associated DatePicker.

virtual long GetBoldDaysIdleStepTime_ms() const;
Returns

Time between idle steps in milliseconds.

See Also

SetBoldDaysOnIdle, IsBoldDaysOnIdle, GetBoldDaysPerIdleStep, SetBoldDaysPerIdleStep, SetBoldDaysIdleStepTime_ms.

Body Source
long CXTPCalendarController::GetBoldDaysIdleStepTime_ms() const {
    return m_nBoldDaysIdleStepTime_ms;
}
Group

CXTPCalendarController Methods


CXTPCalendarController::GetBoldDaysPerIdleStep Method

CXTPCalendarController Methods, CXTPCalendarController Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::GetBoldDaysPerIdleStep Method

Returns Amount of days for the associated DatePicker to update state in one idle step.

virtual long GetBoldDaysPerIdleStep() const;
Returns

Amount of days for the associated DatePicker to update state in one idle step.

See Also

SetBoldDaysOnIdle, IsBoldDaysOnIdle, GetBoldDaysIdleStepTime_ms, SetBoldDaysPerIdleStep, SetBoldDaysIdleStepTime_ms.

Body Source
long CXTPCalendarController::GetBoldDaysPerIdleStep() const {
    return m_nBoldDaysPerIdleStep;
}
Group

CXTPCalendarController Methods


CXTPCalendarController::GetCalendar Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::GetCalendar Method

Get a calendar control object associated with the controller.

virtual CXTPCalendarControl* GetCalendar() const;
Remarks

A pointer to calendar control object associated with the controller or NULL.

See Also

SetCalendar, SetDatePicker, GetDatePicker

Group

CXTPCalendarController Methods


CXTPCalendarController::GetDatePicker Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::GetDatePicker Method

Get a date picker control object associated with the controller.

virtual CXTPDatePickerControl* GetDatePicker() const;
Remarks

A pointer to date picker control object associated with the controller or NULL.

See Also

SetCalendar, SetDatePicker, GetCalendar

Group

CXTPCalendarController Methods


CXTPCalendarController::IsBoldDaysOnIdle Method

CXTPCalendarController Methods, CXTPCalendarController Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::IsBoldDaysOnIdle Method

Is BoldDaysOnIdle option enabled or disabled.

virtual BOOL IsBoldDaysOnIdle() const;
Returns

TRUE if enabled retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.

See Also

SetBoldDaysOnIdle, GetBoldDaysPerIdleStep, GetBoldDaysIdleStepTime_ms, SetBoldDaysPerIdleStep, SetBoldDaysIdleStepTime_ms.

Body Source
BOOL CXTPCalendarController::IsBoldDaysOnIdle() const {
    return m_bBoldDaysOnIdle;
}
Group

CXTPCalendarController Methods


CXTPCalendarController::IsBoldDaysWithEvents Method

CXTPCalendarController Methods, CXTPCalendarController Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::IsBoldDaysWithEvents Method

This member function used to determine whether Bold font is used for days in DatePicker which have corresponding Calendar events.

virtual BOOL IsBoldDaysWithEvents() const;
Returns

TRUE when Bold font is used, FALSE otherwise.

See Also

SetBoldDaysWithEvents

Body Source
BOOL CXTPCalendarController::IsBoldDaysWithEvents() const {
    return m_bBoldDaysWithEvents;
}
Group

CXTPCalendarController Methods


CXTPCalendarController::IsFirstDayOfWeekShifted_FromSun2Mon Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::IsFirstDayOfWeekShifted_FromSun2Mon Method

This member function used to determine is Compressed Weekend Day - Sunday, used as first day of week in the active calendar view.

virtual BOOL IsFirstDayOfWeekShifted_FromSun2Mon();
Remarks

It means that first day of week is automatically shifted from Sunday to Monday because Sunday is compressed with Saturday and it cannot be shown as first day of week in the active calendar view.

See Also

CXTPCalendarWeekView, CXTPCalendarMonthView, CXTPCalendarControl::MonthView_IsCompressWeekendDays(), CXTPCalendarControl::GetFirstDayOfWeek()

Group

CXTPCalendarController Methods


CXTPCalendarController::OnEvent_CalendarOptionsChanged Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::OnEvent_CalendarOptionsChanged Method

This member function catches all the events when calendar control options were changed.

virtual void OnEvent_CalendarOptionsChanged(
    XTP_NOTIFY_CODE Event,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

Event
Events code
wParam
First user's parameter.
lParam
Second user's parameter.

Remarks

This member function is called when an event is fired when calendar control options where changed..

See Also

AdviseToNotifications

Group

CXTPCalendarController Methods


CXTPCalendarController::OnEvent_CalendarResourcesChanged Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::OnEvent_CalendarResourcesChanged Method

This member function catches all the events when resource configuration was changed in the CalendarControl.

virtual void OnEvent_CalendarResourcesChanged(
    XTP_NOTIFY_CODE Event,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

Event
Events code
wParam
First user's parameter.
lParam
Second user's parameter.

See Also

AdviseToNotifications

Group

CXTPCalendarController Methods


CXTPCalendarController::OnEvent_CalendarThemeChanged Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::OnEvent_CalendarThemeChanged Method

This member function catches the XTP_NC_CALENDAR_THEME_CHANGED event.

virtual void OnEvent_CalendarThemeChanged(
    XTP_NOTIFY_CODE Event,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

Event
Events code
wParam
First user's parameter.
lParam
Second user's parameter.

See Also

AdviseToNotifications

Group

CXTPCalendarController Methods


CXTPCalendarController::OnEvent_CalendarView Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::OnEvent_CalendarView Method

This member function catches all the events from the associated calendar control and its view.

virtual void OnEvent_CalendarView(
    XTP_NOTIFY_CODE Event,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

Event
Events code
wParam
First user's parameter.
lParam
Second user's parameter.

Remarks

This member function is called when an event is fired from the associated CXTPCalendarControl object or from its view.

See Also

AdviseToNotifications

Group

CXTPCalendarController Methods


CXTPCalendarController::OnEvent_DatePicker Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::OnEvent_DatePicker Method

This member function catches all the events from the associated date picker control.

virtual void OnEvent_DatePicker(
    XTP_NOTIFY_CODE Event,
    WPARAM wParam,
    LPARAM lParam
);
virtual void OnEvent_DtPickGetItemMetrics(
    XTP_NOTIFY_CODE Event,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

Event
Events code.
wParam
First user's parameter.
lParam
Second user's parameter.

Remarks

This member function is called when an event is fired from the associated CXTPDatePickerControl object.

See Also

AdviseToNotifications

Group

CXTPCalendarController Methods


CXTPCalendarController::SetBoldDaysIdleStepTime_ms Method

CXTPCalendarController Methods, CXTPCalendarController Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::SetBoldDaysIdleStepTime_ms Method

Set time (in milliseconds) between idle steps to update days state (bold or regular) for the associated DatePicker.

virtual void SetBoldDaysIdleStepTime_ms(
    long nStepTime_ms
);
Parameters

nStepTime_ms
An idle step in milliseconds.

See Also

SetBoldDaysOnIdle, IsBoldDaysOnIdle, GetBoldDaysPerIdleStep, SetBoldDaysPerIdleStep, GetBoldDaysIdleStepTime_ms.

Body Source
void CXTPCalendarController::SetBoldDaysIdleStepTime_ms(long nStepTime_ms) {
    m_nBoldDaysIdleStepTime_ms = nStepTime_ms;
}
Group

CXTPCalendarController Methods


CXTPCalendarController::SetBoldDaysOnIdle Method

CXTPCalendarController Methods, CXTPCalendarController Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::SetBoldDaysOnIdle Method

Enable or Disable retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.

virtual void SetBoldDaysOnIdle(
    BOOL bBoldDaysOnIdle
);
Parameters

bBoldDaysOnIdle
Set as TRUE to Enable or FALSE to Disable retrieve days state on idle.

See Also

IsBoldDaysOnIdle, GetBoldDaysPerIdleStep, GetBoldDaysIdleStepTime_ms, SetBoldDaysPerIdleStep, SetBoldDaysIdleStepTime_ms.

Body Source
void CXTPCalendarController::SetBoldDaysOnIdle(BOOL bBoldDaysOnIdle) {
    m_bBoldDaysOnIdle = bBoldDaysOnIdle;
    m_DayInfoCache.Clear();
}
Group

CXTPCalendarController Methods


CXTPCalendarController::SetBoldDaysPerIdleStep Method

CXTPCalendarController Methods, CXTPCalendarController Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::SetBoldDaysPerIdleStep Method

Set amount of days for the associated DatePicker to update state in one idle step.

virtual void SetBoldDaysPerIdleStep(
    long nDaysPerStep
);
Parameters

nDaysPerStep
An amount of days to update in one step.

See Also

SetBoldDaysOnIdle, IsBoldDaysOnIdle, GetBoldDaysIdleStepTime_ms, GetBoldDaysPerIdleStep, SetBoldDaysIdleStepTime_ms.

Body Source
void CXTPCalendarController::SetBoldDaysPerIdleStep(long nDaysPerStep) {
    m_nBoldDaysPerIdleStep = nDaysPerStep;
}
Group

CXTPCalendarController Methods


CXTPCalendarController::SetBoldDaysWithEvents Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::SetBoldDaysWithEvents Method

This member function enables or disables Bold font usage for displaying days in DatePicker which have corresponding Calendar events.

virtual void SetBoldDaysWithEvents(
    BOOL bBold
);
Parameters

bBold
TRUE to enable; FALSE to disable.

Remarks

Disabling this parameter could be useful in cases when determining whether a particular day has events takes a long time.

See Also

IsBoldDaysWithEvents

Group

CXTPCalendarController Methods


CXTPCalendarController::SetCalendar Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::SetCalendar Method

This member function associates a custom calendar control with the controller.

virtual void SetCalendar(
    CXTPCalendarControl* pCalendarCtrl
);
Parameters

pCalendarCtrl
A pointer to the user's CXTPCalendarControl object.

Remarks

Call this member function to associate your CXTPCalendarControl object with this calendar controller.

See Also

CXTPCalendarControl overview, SetDatePicker

Group

CXTPCalendarController Methods


CXTPCalendarController::SetDatePicker Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::SetDatePicker Method

This member function associates a custom date picker control with the controller.

virtual void SetDatePicker(
    CXTPDatePickerControl* pDatePickerCtrl
);
Parameters

pDatePickerCtrl
Pointer to the user's CXTPDatePickerControl object.

Remarks

Call this member function to associate your CXTPDatePickerControl object with this calendar controller.

See Also

CXTPDatePickerControl overview, SetCalendar

Group

CXTPCalendarController Methods


CXTPCalendarController::SetFirstDayOfWeekToDatePicker Method

CXTPCalendarController Methods, CXTPCalendarController Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::SetFirstDayOfWeekToDatePicker Method

This member function get first day of week from the calendar control and set the same value to the date picker control.

virtual void SetFirstDayOfWeekToDatePicker();
See Also

OnEvent_CalendarOptionsChanged(), CXTPCalendarController overview

Group

CXTPCalendarController Methods


CXTPCalendarController Constructors

CXTPCalendarController Class, Legend, Public Methods
CXTPCalendarController Constructors
Class

CXTPCalendarController Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarController | Constructs a CXTPCalendarController object.


CXTPCalendarController::CXTPCalendarController Constructor

CXTPCalendarController Constructors, CXTPCalendarController Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::CXTPCalendarController Constructor

Constructs a CXTPCalendarController object.

CXTPCalendarController();
Remarks

Construction of the CXTPCalendarController object defines a point of synchronization between CXTPCalendarControl and CXTPDatePickerControl controls. It can be constructed both in the same scope with controls which would provide us with full live objects time synchronization, and in the local scope for short time synchronization.

See Also

SetCalendar, SetDatePicker

Example
Declare a local CXTPCalendarController object.
CXTPCalendarController myCalendarController;

// Assigns CXTPCalendarControl instance to the object.
myCalendarController.SetCalendar(&m_wndCalendar);

// Assigns CXTPDatePickerControl instance to the object.
myCalendarController.SetDatePicker(&m_wndDatePicker);
Group

CXTPCalendarController Constructors


CXTPCalendarController Destructors

CXTPCalendarController Class, Legend, Public Methods
CXTPCalendarController Destructors
Class

CXTPCalendarController Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarController | Destroys a CXTPCalendarController object, handles cleanup and de-allocation.


CXTPCalendarController::~CXTPCalendarController Destructor

CXTPCalendarController Destructors, CXTPCalendarController Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarController::~CXTPCalendarController Destructor

Destroys a CXTPCalendarController object, handles cleanup and de-allocation.

virtual ~CXTPCalendarController();
Group

CXTPCalendarController Destructors


CXTPCalendarControlView Class

XTPCalendarControlView.h, Classes, Legend, Members, Topics, CXTPCalendarControlView Data Members, CXTPCalendarControlView Methods, CXTPCalendarControlView Constructors, CXTPCalendarControlView Destructors, CXTPCalendarControlView Constructors, CXTPCalendarControlView Data Members, CXTPCalendarControlView Destructors, CXTPCalendarControlView Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView Class

The CXTPCalendarControlView class provides an implementation of the Calendar control as view class. Use GetCalendarCtrl() method to access methods of CXTPCalendarControl

Class Hierarchy

class CXTPCalendarControlView : public CView;
File

XTPCalendarControlView.h

See Also

CXTPCalendarControl

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarControlView Constructors
CXTPCalendarControlView Constructors | Description
CXTPCalendarControlView | Protected constructor used by dynamic creation
CXTPCalendarControlView Data Members
CXTPCalendarControlView Data Members | Description
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bResizeControlWithView | if FALSE - attached Calendar control will not be resized with view.
m_bShowCaptionBar | Store Office 2007 theme Calendar Caption Bar state.
m_pPrintOptions | Printing options.
CXTPCalendarControlView Destructors
CXTPCalendarControlView Destructors | Description
~CXTPCalendarControlView | Destroys a CXTPCalendarControlView object, handles cleanup and deallocation.
CXTPCalendarControlView Methods
CXTPCalendarControlView Methods | Description
_DrawDateHeaderCalendar | Draws month calendar in the right part of the central date header area.
_GetDateHeaderMonths | Calculates a number of shown months and captions for them to be drawn on the date header.
_HimetricToLP | Converts a rectangle of HIMETRIC units into logical units.
AdjustCalendarForPrint | Adjusts calendar printing rectangle by adding space for a header, footer and similar areas.
DrawDateHeader | Draws main (central) date header area.
GetCalendarCtrl | Call this method to access Calendar control object.
GetPrintOptions | Call this method to access print options for this view.
IsShowCaptionBar | Call this method to retrieve is Caption Bar control visible.
SetCalendarCtrl | Call this method to set custom Calendar control object.
SetScrollBarCtrl | Use this member function to set external scroll bar control.
ShowCaptionBar | Call this method to show or hide Caption Bar control.


CXTPCalendarControlView Data Members

CXTPCalendarControlView Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView Data Members
Class

CXTPCalendarControlView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bShowCaptionBar | Store Office 2007 theme Calendar Caption Bar state.
m_pPrintOptions | Printing options.
Public Data Members
Public Data Member | Description
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bResizeControlWithView | if FALSE - attached Calendar control will not be resized with view.


CXTPCalendarControlView::m_bPrintDirect Data Member

CXTPCalendarControlView Data Members, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::m_bPrintDirect Data Member

if TRUE - the Print Dialog is bypassed.

BOOL m_bPrintDirect;
Group

CXTPCalendarControlView Data Members


CXTPCalendarControlView::m_bResizeControlWithView Data Member

CXTPCalendarControlView Data Members, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::m_bResizeControlWithView Data Member

if FALSE - attached Calendar control will not be resized with view.

BOOL m_bResizeControlWithView;
Group

CXTPCalendarControlView Data Members


CXTPCalendarControlView::m_bShowCaptionBar Data Member

CXTPCalendarControlView Data Members, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::m_bShowCaptionBar Data Member

Store Office 2007 theme Calendar Caption Bar state.

BOOL m_bShowCaptionBar;
Group

CXTPCalendarControlView Data Members


CXTPCalendarControlView::m_pPrintOptions Data Member

CXTPCalendarControlView Data Members, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::m_pPrintOptions Data Member

Printing options.

CXTPCalendarControlViewPrintOptions* m_pPrintOptions;
Group

CXTPCalendarControlView Data Members


CXTPCalendarControlView Methods

CXTPCalendarControlView Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView Methods
Class

CXTPCalendarControlView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_DrawDateHeaderCalendar | Draws month calendar in the right part of the central date header area.
_GetDateHeaderMonths | Calculates a number of shown months and captions for them to be drawn on the date header.
_HimetricToLP | Converts a rectangle of HIMETRIC units into logical units.
AdjustCalendarForPrint | Adjusts calendar printing rectangle by adding space for a header, footer and similar areas.
DrawDateHeader | Draws main (central) date header area.
Public Methods
Public Methods
Public Method | Description
GetCalendarCtrl | Call this method to access Calendar control object.
GetPrintOptions | Call this method to access print options for this view.
IsShowCaptionBar | Call this method to retrieve is Caption Bar control visible.
SetCalendarCtrl | Call this method to set custom Calendar control object.
SetScrollBarCtrl | Use this member function to set external scroll bar control.
ShowCaptionBar | Call this method to show or hide Caption Bar control.


CXTPCalendarControlView::_DrawDateHeaderCalendar Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::_DrawDateHeaderCalendar Method

Draws month calendar in the right part of the central date header area.

virtual void _DrawDateHeaderCalendar(
    BOOL bCalculate,
    CDC* pDC,
    CXTPCalendarControlViewPrintOptions* pOptions,
    COleDateTime dtYearMonth,
    CRect& rrcHeaderCalendar
);
Parameters

bCalculate
If TRUE, then only calculate rectangles and do not performs drawing itself.
pDC
Pointer to a valid device context.
pOptions
Pointer to calendar Print Options object.
dtYearMonth
Which month's calendar to draw.
rrcHeaderCalendar
[out] Drawn rectangle area.

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::_GetDateHeaderMonths Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::_GetDateHeaderMonths Method

Calculates a number of shown months and captions for them to be drawn on the date header.

virtual int _GetDateHeaderMonths(
    COleDateTime& dtYearMonth1,
    COleDateTime& dtYearMonth2,
    CString& strHeader1,
    CString& strHeader2,
    CString& strHeaderWeekDay
);
Parameters

dtYearMonth1
Bottom boundary of the date period.
dtYearMonth2
Top boundary of the date period.
strHeader1
[out] Bottom boundary caption.
strHeader2
[out] Top boundary caption.
strHeaderWeekDay
[out] Week day name (for a single day view only).

Returns

A number of months between bottom and top boundaries, including them.

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::_HimetricToLP Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::_HimetricToLP Method

Converts a rectangle of HIMETRIC units into logical units.

static CRect _HimetricToLP(
    CDC* pDC,
    const CRect rcHimetric
);
Parameters

pDC
Pointer to a valid device context.
rcHimetric
A rectangle to convert in HIMETRIC units.

Returns

Converted rectangle in logical units.

Remarks

Use this function when you get HIMETRIC sizes from OLE and wish to convert them to your application's natural mapping mode. The conversion is accomplished by first converting the HIMETRIC units into pixels and then converting these units into logical units using the device context's current mapping units. Note that the extents of the device's window and viewport will affect the result.

See Also

CDC::HIMETRICtoLP()

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::AdjustCalendarForPrint Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::AdjustCalendarForPrint Method

Adjusts calendar printing rectangle by adding space for a header, footer and similar areas.

virtual CRect AdjustCalendarForPrint(
    CDC* pDC,
    CRect rcCalendar,
    CXTPCalendarControlViewPrintOptions* pOptions
);
Parameters

pDC
Pointer to a valid device context.
rcCalendar
Calendar printing rectangle.
pOptions
Pointer to calendar Print Options object.

Returns

Adjusted calendar printing rectangle.

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::DrawDateHeader Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::DrawDateHeader Method

Draws main (central) date header area.

virtual void DrawDateHeader(
    BOOL bCalculate,
    CDC* pDC,
    CXTPCalendarControlViewPrintOptions* pOptions,
    CRect& rrcHeader
);
Parameters

bCalculate
If TRUE, then only calculate rectangles and do not performs drawing itself.
pDC
Pointer to a valid device context.
pOptions
Pointer to calendar Print Options object.
rrcHeader
[out] Drawn rectangle area.

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::GetCalendarCtrl Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::GetCalendarCtrl Method

Call this method to access Calendar control object.

virtual CXTPCalendarControl& GetCalendarCtrl();
Returns

Reference to child CXTPCalendarControl window

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::GetPrintOptions Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::GetPrintOptions Method

Call this method to access print options for this view.

CXTPCalendarControlViewPrintOptions* GetPrintOptions();
Returns

Pointer to an object describing print options of this view.

Body Source
CXTPCalendarControlViewPrintOptions* CXTPCalendarControlView::GetPrintOptions() {
    return m_pPrintOptions;
}
Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::IsShowCaptionBar Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::IsShowCaptionBar Method

Call this method to retrieve is Caption Bar control visible.

virtual BOOL IsShowCaptionBar();
Returns

TRUE if Caption Bar is visible, FALSE otherwise.

See Also

ShowCaptionBar, CXTPCalendarCaptionBarControl

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::SetCalendarCtrl Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::SetCalendarCtrl Method

Call this method to set custom Calendar control object.

virtual void SetCalendarCtrl(
    CXTPCalendarControl* pCalendar,
    BOOL bReleaseWhenDestroy = TRUE
);
Parameters

pCalendar
Pointer to custom report object.
bReleaseWhenDestroy
Set this parameter as TRUE to call InternalRelease for pCalendar object on destroy of CXTPCalendarControlView.

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::SetScrollBarCtrl Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::SetScrollBarCtrl Method

Use this member function to set external scroll bar control.

void SetScrollBarCtrl(
    CScrollBar* pScrollBar
);
Parameters

pScrollBar
Pointer to a scrollbar object.

See Also

CScrollBar

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView::ShowCaptionBar Method

CXTPCalendarControlView Methods, CXTPCalendarControlView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::ShowCaptionBar Method

Call this method to show or hide Caption Bar control.

virtual void ShowCaptionBar(
    BOOL bShow
);
Parameters

bShow
Set this parameter as TRUE to show Caption Bar and as FALSE to hide it.

See Also

IsShowCaptionBar, CXTPCalendarCaptionBarControl

Group

CXTPCalendarControlView Methods


CXTPCalendarControlView Constructors

CXTPCalendarControlView Class, Legend, Protected Methods
CXTPCalendarControlView Constructors
Class

CXTPCalendarControlView Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPCalendarControlView | Protected constructor used by dynamic creation


CXTPCalendarControlView::CXTPCalendarControlView Constructor

CXTPCalendarControlView Constructors, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::CXTPCalendarControlView Constructor

Protected constructor used by dynamic creation

CXTPCalendarControlView();
Group

CXTPCalendarControlView Constructors


CXTPCalendarControlView Destructors

CXTPCalendarControlView Class, Legend, Protected Methods
CXTPCalendarControlView Destructors
Class

CXTPCalendarControlView Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPCalendarControlView | Destroys a CXTPCalendarControlView object, handles cleanup and deallocation.


CXTPCalendarControlView::~CXTPCalendarControlView Destructor

CXTPCalendarControlView Destructors, CXTPCalendarControlView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlView::~CXTPCalendarControlView Destructor

Destroys a CXTPCalendarControlView object, handles cleanup and deallocation.

virtual ~CXTPCalendarControlView();
Group

CXTPCalendarControlView Destructors


CXTPCalendarControlViewPrintOptions Class

XTPCalendarControlView.h, Classes, Legend, Members, Topics, CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Methods, CXTPCalendarControlViewPrintOptions Constructors, CXTPCalendarControlViewPrintOptions Constructors, CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions Class

Describes printing options for the Calendar Control.

Class Hierarchy

class CXTPCalendarControlViewPrintOptions : public CXTPPrintOptions;
File

XTPCalendarControlView.h

Remarks

Use this class when you want to programmatically customize printing options for the Calendar control.

See each property description to examine which customization options are available.

See Also

CXTPPrintOptions, CXTPCalendarPageSetupDialog overview

Group

Classes

Legend
Data Member
Method
virtual
CXTPCalendarControlViewPrintOptions Constructors
CXTPCalendarControlViewPrintOptions Constructors | Description
CXTPCalendarControlViewPrintOptions | Default constructor.
CXTPCalendarControlViewPrintOptions Data Members
CXTPCalendarControlViewPrintOptions Data Members | Description
m_bPrintDateHeader | Defines whether to print a date header or not.
m_bPrintFromToExactly | Defines whether to cut printing area by showing only area between m_dtPrintFrom and m_dtPrintTo
m_dtPrintFrom | Top bound of the printing area for a day view.
m_dtPrintTo | Bottom bound of the printing area for a day view.
m_lfDateHeaderCalendarFont | Font for day header small calendar.
m_lfDateHeaderFont | Font for day header caption (Day 1 - Day 2)
m_lfDateHeaderWeekDayFont | Font for day header week day(Monday, ...)
CXTPCalendarControlViewPrintOptions Methods
CXTPCalendarControlViewPrintOptions Methods | Description
GetActiveLCID | Override this member function in derived class to specify active locale ID.
Set | Copies all print options from a specified PrintOptions object.


CXTPCalendarControlViewPrintOptions Data Members

CXTPCalendarControlViewPrintOptions Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions Data Members
Class

CXTPCalendarControlViewPrintOptions Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bPrintDateHeader | Defines whether to print a date header or not.
m_bPrintFromToExactly | Defines whether to cut printing area by showing only area between m_dtPrintFrom and m_dtPrintTo
m_dtPrintFrom | Top bound of the printing area for a day view.
m_dtPrintTo | Bottom bound of the printing area for a day view.
m_lfDateHeaderCalendarFont | Font for day header small calendar.
m_lfDateHeaderFont | Font for day header caption (Day 1 - Day 2)
m_lfDateHeaderWeekDayFont | Font for day header week day(Monday, ...)


CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader Data Member

CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader Data Member

Defines whether to print a date header or not.

BOOL m_bPrintDateHeader;
Group

CXTPCalendarControlViewPrintOptions Data Members


CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly Data Member

CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly Data Member

Defines whether to cut printing area by showing only area between m_dtPrintFrom and m_dtPrintTo

BOOL m_bPrintFromToExactly;
Group

CXTPCalendarControlViewPrintOptions Data Members


CXTPCalendarControlViewPrintOptions::m_dtPrintFrom Data Member

CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::m_dtPrintFrom Data Member

Top bound of the printing area for a day view.

COleDateTime m_dtPrintFrom;
Group

CXTPCalendarControlViewPrintOptions Data Members


CXTPCalendarControlViewPrintOptions::m_dtPrintTo Data Member

CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::m_dtPrintTo Data Member

Bottom bound of the printing area for a day view.

COleDateTime m_dtPrintTo;
Group

CXTPCalendarControlViewPrintOptions Data Members


CXTPCalendarControlViewPrintOptions::m_lfDateHeaderCalendarFont Data Member

CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::m_lfDateHeaderCalendarFont Data Member

Font for day header small calendar.

LOGFONT m_lfDateHeaderCalendarFont;
Group

CXTPCalendarControlViewPrintOptions Data Members


CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont Data Member

CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont Data Member

Font for day header caption (Day 1 - Day 2)

LOGFONT m_lfDateHeaderFont;
Group

CXTPCalendarControlViewPrintOptions Data Members


CXTPCalendarControlViewPrintOptions::m_lfDateHeaderWeekDayFont Data Member

CXTPCalendarControlViewPrintOptions Data Members, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::m_lfDateHeaderWeekDayFont Data Member

Font for day header week day(Monday, ...)

LOGFONT m_lfDateHeaderWeekDayFont;
Group

CXTPCalendarControlViewPrintOptions Data Members


CXTPCalendarControlViewPrintOptions Methods

CXTPCalendarControlViewPrintOptions Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions Methods
Class

CXTPCalendarControlViewPrintOptions Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetActiveLCID | Override this member function in derived class to specify active locale ID.
Set | Copies all print options from a specified PrintOptions object.


CXTPCalendarControlViewPrintOptions::GetActiveLCID Method

CXTPCalendarControlViewPrintOptions Methods, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::GetActiveLCID Method

Override this member function in derived class to specify active locale ID.

virtual LCID GetActiveLCID();
Returns

Locale ID. Base implementation returns LOCALE_USER_DEFAULT;

Group

CXTPCalendarControlViewPrintOptions Methods


CXTPCalendarControlViewPrintOptions::Set Method

CXTPCalendarControlViewPrintOptions Methods, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::Set Method

Copies all print options from a specified PrintOptions object.

void Set(
    const CXTPCalendarControlViewPrintOptions* pSrc
);
Parameters

pSrc
A pointer to the object to copy options from.

Group

CXTPCalendarControlViewPrintOptions Methods


CXTPCalendarControlViewPrintOptions Constructors

CXTPCalendarControlViewPrintOptions Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions Constructors
Class

CXTPCalendarControlViewPrintOptions Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarControlViewPrintOptions | Default constructor.


CXTPCalendarControlViewPrintOptions::CXTPCalendarControlViewPrintOptions Constructor

CXTPCalendarControlViewPrintOptions Constructors, CXTPCalendarControlViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarControlViewPrintOptions::CXTPCalendarControlViewPrintOptions Constructor

Default constructor.

CXTPCalendarControlViewPrintOptions();
Group

CXTPCalendarControlViewPrintOptions Constructors


CXTPCalendarCustomDataProvider Class

XTPCalendarCustomDataProvider.h, Classes, Legend, Members, Topics, CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Constructors, CXTPCalendarCustomDataProvider Destructors, CXTPCalendarCustomDataProvider Constructors, CXTPCalendarCustomDataProvider Destructors, CXTPCalendarCustomDataProvider Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider Class

Custom implementation of XTPCalendarData based on notifications.

Class Hierarchy

class CXTPCalendarCustomDataProvider : public CXTPCalendarData;
File

XTPCalendarCustomDataProvider.h

Remarks

This class is the implementation of the XTPCalendarData abstract class which represents a data portion of the Calendar control.

This implementation is based on a notifications mechanism. Each significant method sends a custom notification, which could be handled by a user and where a custom data access code should be implemented.

See Also

CXTPCalendarData overview

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarCustomDataProvider Constructors
CXTPCalendarCustomDataProvider Constructors | Description
CXTPCalendarCustomDataProvider | Default constructor.
CXTPCalendarCustomDataProvider Destructors
CXTPCalendarCustomDataProvider Destructors | Description
~CXTPCalendarCustomDataProvider | Default Destructor.
CXTPCalendarCustomDataProvider Methods
CXTPCalendarCustomDataProvider Methods | Description
Close | Call this member function to close the connection to a data source.
DoCreate_Event | Creates a new event in the data source
DoCreate_RPattern | Creates a new recurrence pattern in the data source
DoDelete_Event | Deletes an event from the data source.
DoDelete_RPattern | Deletes a recurrence pattern from the database
DoGetAllEvents_raw | This method implements Getting all events without generating recurrence occurrences.
DoGetUpcomingEvents | This method implements getting a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the data source.
DoRead_RPattern | Read recurrence pattern from the data source
DoRemoveAllEvents | Removes all events from the data source.
DoRetrieveDayEvents | Retrieves day events for a specified day from the data source.
DoUpdate_Event | Updates event properties in the data source.
DoUpdate_RPattern | Updates a recurrence pattern in the database


CXTPCalendarCustomDataProvider Methods

CXTPCalendarCustomDataProvider Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider Methods
Class

CXTPCalendarCustomDataProvider Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DoCreate_Event | Creates a new event in the data source
DoCreate_RPattern | Creates a new recurrence pattern in the data source
DoDelete_Event | Deletes an event from the data source.
DoDelete_RPattern | Deletes a recurrence pattern from the database
DoGetAllEvents_raw | This method implements Getting all events without generating recurrence occurrences.
DoGetUpcomingEvents | This method implements getting a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the data source.
DoRead_RPattern | Read recurrence pattern from the data source
DoRemoveAllEvents | Removes all events from the data source.
DoRetrieveDayEvents | Retrieves day events for a specified day from the data source.
DoUpdate_Event | Updates event properties in the data source.
DoUpdate_RPattern | Updates a recurrence pattern in the database
Public Methods
Public Methods
Public Method | Description
Close | Call this member function to close the connection to a data source.


CXTPCalendarCustomDataProvider::Close Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::Close Method

Call this member function to close the connection to a data source.

virtual void Close();
Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoCreate_Event Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoCreate_Event Method

Creates a new event in the data source

virtual BOOL DoCreate_Event(
    CXTPCalendarEvent* pEvent,
    DWORD& rdwNewEventID
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.
rdwNewEventID
[out] EventID of a newly created record

Returns

TRUE if event created successfully, FALSE in case of any error during the process.

Remarks

This method creates a data record corresponding with the specified event.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoCreate_Event which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoCreate_Event notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoCreate_RPattern Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoCreate_RPattern Method

Creates a new recurrence pattern in the data source

virtual BOOL DoCreate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern,
    DWORD& rdwNewPatternID
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object which describes all data fields of a newly created record.
rdwNewPatternID
[out] ID of a newly created record

Returns

TRUE if recurrence pattern created successfully, FALSE in case of any error during the process.

Remarks

This method creates a data record corresponding with the specified recurrence pattern.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoCreate_RPattern which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoCreate_RPattern notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoDelete_Event Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoDelete_Event Method

Deletes an event from the data source.

virtual BOOL DoDelete_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event deleted successfully, FALSE in case of any errors during the process.

Remarks

This method deletes a data record corresponding with the specified event.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoDelete_Event which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoDelete_Event notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoDelete_RPattern Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoDelete_RPattern Method

Deletes a recurrence pattern from the database

virtual BOOL DoDelete_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object which should be deleted.

Returns

TRUE if recurrence pattern deleted successfully, FALSE in case of any error during the process.

Remarks

This method deletes a data record corresponding with the specified recurrence pattern.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoDelete_RPattern which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoDelete_RPattern notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoGetAllEvents_raw Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoGetAllEvents_raw Method

This method implements Getting all events without generating recurrence occurrences.

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
Returns

A CXTPCalendarEvents pointer containing a collection of all events.

Remarks

This method actually implements working with the data source. Simple events are included as is.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoGetAllEvents_raw which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoGetAllEvents_raw notification, GetAllEvents_raw()

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoGetUpcomingEvents Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoGetUpcomingEvents Method

This method implements getting a collection of events expiring in the period from dtFrom during next spPeriod.

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(
    COleDateTime dtFrom,
    COleDateTimeSpan spPeriod
);
Parameters

dtFrom
Start date and time of a specified period.
spPeriod
A duration of a specified period.

Returns

A CXTPCalendarEvents pointer containing a collection of upcoming events.

Remarks

This method is used by a reminders manager.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoGetUpcomingEvents which a user can handle and implement a custom method.

See Also

CXTPCalendarRemindersManager overview, XTP_NC_CALENDAR_DoGetUpcomingEvents notification.

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoRead_Event Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoRead_Event Method

Read event from the data source.

virtual CXTPCalendarEventPtr DoRead_Event(
    DWORD dwEventID
);
Parameters

dwEventID
Event ID of the read target.

Returns

A pointer to the new CXTPCalendarEvent object which fields are filled with a data from the data source.

Remarks

This method retrieves all data for a specified event.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoRead_Event which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoRead_Event notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoRead_RPattern Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoRead_RPattern Method

Read recurrence pattern from the data source

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(
    DWORD dwPatternID
);
Parameters

dwPatternID
Pattern ID of the read target.

Returns

A pointer to the new CXTPCalendarRecurrencePatternPtr object which fields are filled with a data from the data source.

Remarks

This method retrieves all data for a specified recurrence pattern.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoRead_RPattern which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoRead_RPattern notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoRemoveAllEvents Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoRemoveAllEvents Method

Removes all events from the data source.

virtual void DoRemoveAllEvents();
Remarks

This method removes all appointments from the data source.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoRemoveAllEvents which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoRemoveAllEvents notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoRetrieveDayEvents Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoRetrieveDayEvents Method

Retrieves day events for a specified day from the data source.

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(
    COleDateTime dtDay
);
Parameters

dtDay
A specified day.

Returns

A collection of events for a specified day.

Remarks

This method retrieves all appointments for a specified day from the data source. It includes recurrence appointments occurrences, regular appointments for this day, multi day appointments which also have a part of this day.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoRetrieveDayEvents which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoRetrieveDayEvents notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoUpdate_Event Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoUpdate_Event Method

Updates event properties in the data source.

virtual BOOL DoUpdate_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event updated successfully, FALSE in case of any errors during the process.

Remarks

This method updates a data record corresponding with the specified event.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoUpdate_Event which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoUpdate_Event notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider::DoUpdate_RPattern Method

CXTPCalendarCustomDataProvider Methods, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::DoUpdate_RPattern Method

Updates a recurrence pattern in the database

virtual BOOL DoUpdate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object.

Returns

TRUE if recurrence pattern updated successfully, FALSE in case of any error during the process.

Remarks

This method updates a data record corresponding with the specified recurrence pattern.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoUpdate_RPattern which a user can handle and implement a custom method.

See Also

XTP_NC_CALENDAR_DoUpdate_RPattern notification

Group

CXTPCalendarCustomDataProvider Methods


CXTPCalendarCustomDataProvider Constructors

CXTPCalendarCustomDataProvider Class, Legend, Public Methods
CXTPCalendarCustomDataProvider Constructors
Class

CXTPCalendarCustomDataProvider Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarCustomDataProvider | Default constructor.


CXTPCalendarCustomDataProvider::CXTPCalendarCustomDataProvider Constructor

CXTPCalendarCustomDataProvider Constructors, CXTPCalendarCustomDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::CXTPCalendarCustomDataProvider Constructor

Default constructor.

CXTPCalendarCustomDataProvider();
Remarks

Constructs a Data object. To establish a connection to a specified data source and initialize the object you must call Open() member function immediately after construction.

See Also

Open()

Group

CXTPCalendarCustomDataProvider Constructors


CXTPCalendarCustomDataProvider Destructors

CXTPCalendarCustomDataProvider Class, Legend, Public Methods
CXTPCalendarCustomDataProvider Destructors
Class

CXTPCalendarCustomDataProvider Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarCustomDataProvider | Default Destructor.


CXTPCalendarCustomDataProvider::~CXTPCalendarCustomDataProvider Destructor

CXTPCalendarCustomDataProvider Destructors, CXTPCalendarCustomDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomDataProvider::~CXTPCalendarCustomDataProvider Destructor

Default Destructor.

virtual ~CXTPCalendarCustomDataProvider();
Remarks

Handles all deallocation.

Group

CXTPCalendarCustomDataProvider Destructors


CXTPCalendarCustomProperties Class

XTPCalendarCustomProperties.h, Classes, Legend, Members, Topics, CXTPCalendarCustomProperties Data Members, CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Constructors, CXTPCalendarCustomProperties Destructors, CXTPCalendarCustomProperties Constructors, CXTPCalendarCustomProperties Data Members, CXTPCalendarCustomProperties Destructors, CXTPCalendarCustomProperties Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties Class

This class is used to store properties collection.

Class Hierarchy

class CXTPCalendarCustomProperties;
File

XTPCalendarCustomProperties.h

Remarks

It contains methods to Get, Set, Remove and Iterate on properties.

See Also

CXTPCalendarEvent::GetCustomProperties().

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarCustomProperties Constructors
CXTPCalendarCustomProperties Constructors | Description
CXTPCalendarCustomProperties | Default object constructor.
CXTPCalendarCustomProperties Data Members
CXTPCalendarCustomProperties Data Members | Description
m_bNameIgnoreCase | if TRUE - properties names are not case sensitive.
m_mapProperties | Properties storage map.
CXTPCalendarCustomProperties Destructors
CXTPCalendarCustomProperties Destructors | Description
~CXTPCalendarCustomProperties | Default object destructor.
CXTPCalendarCustomProperties Methods
CXTPCalendarCustomProperties Methods | Description
_Load | Call this member function to Load a properties collection using the specified data object.
_Save | Call this member function to Store a properties collection using the specified data object.
CopyTo | This helper function is used to copy properties from source collection object to destination collection.
DoPropExchange | Call this member function to Store/Load a properties collection using the specified data object.
GetCount | This member function is to get properties count in the collection.
GetNextProperty | Retrieves the properties collection element at rPos, then updates rPos to refer to the next element in the collection.
GetProperty | This member function is used to get property value using the specified name.
GetStartPosition | Starts a properties collection iteration by returning a POSITION value that can be passed to a GetNextProperty call.
LoadFromXML | This helper function is used to load properties collection from XML string source.
PrepareName | Call this member function to prepare property name before pass it in the map access functions.
RemoveAll | This member function is used to remove all properties.
RemoveProperty | This member function is used to remove property with the specified name.
SaveToXML | This helper function is used to store properties collection to XML string.
SetProperty | This member function is used to set property value with the specified name.


CXTPCalendarCustomProperties Data Members

CXTPCalendarCustomProperties Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties Data Members
Class

CXTPCalendarCustomProperties Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bNameIgnoreCase | if TRUE - properties names are not case sensitive.
m_mapProperties | Properties storage map.


CXTPCalendarCustomProperties::m_bNameIgnoreCase Data Member

CXTPCalendarCustomProperties Data Members, CXTPCalendarCustomProperties Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::m_bNameIgnoreCase Data Member

if TRUE - properties names are not case sensitive.

BOOL m_bNameIgnoreCase;
Group

CXTPCalendarCustomProperties Data Members


CXTPCalendarCustomProperties::m_mapProperties Data Member

CXTPCalendarCustomProperties Data Members, CXTPCalendarCustomProperties Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::m_mapProperties Data Member

Properties storage map.

CXTPOleVariantMap m_mapProperties;
Group

CXTPCalendarCustomProperties Data Members


CXTPCalendarCustomProperties Methods

CXTPCalendarCustomProperties Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties Methods
Class

CXTPCalendarCustomProperties Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_Load | Call this member function to Load a properties collection using the specified data object.
_Save | Call this member function to Store a properties collection using the specified data object.
PrepareName | Call this member function to prepare property name before pass it in the map access functions.
Public Methods
Public Methods
Public Method | Description
CopyTo | This helper function is used to copy properties from source collection object to destination collection.
DoPropExchange | Call this member function to Store/Load a properties collection using the specified data object.
GetCount | This member function is to get properties count in the collection.
GetNextProperty | Retrieves the properties collection element at rPos, then updates rPos to refer to the next element in the collection.
GetProperty | This member function is used to get property value using the specified name.
GetStartPosition | Starts a properties collection iteration by returning a POSITION value that can be passed to a GetNextProperty call.
LoadFromXML | This helper function is used to load properties collection from XML string source.
RemoveAll | This member function is used to remove all properties.
RemoveProperty | This member function is used to remove property with the specified name.
SaveToXML | This helper function is used to store properties collection to XML string.
SetProperty | This member function is used to set property value with the specified name.


CXTPCalendarCustomProperties::_Load Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::_Load Method

Call this member function to Load a properties collection using the specified data object.

void _Load(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source CXTPPropExchange data object reference.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::_Save Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::_Save Method

Call this member function to Store a properties collection using the specified data object.

void _Save(
    CXTPPropExchange* pPX
);
Parameters

pPX
Destination CXTPPropExchange data object reference.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::CopyTo Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::CopyTo Method

This helper function is used to copy properties from source collection object to destination collection.

void CopyTo(
    CXTPCalendarCustomProperties* pDest
);
Parameters

pDest
[out] A pointer to destination properties collection object.

Remarks

RemoveAll method is called for destination collection before copying.

See Also

LoadFromXML, SaveToXML.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::DoPropExchange Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::DoPropExchange Method

Call this member function to Store/Load a properties collection using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Remarks

This member function is used to store or load properties collection data to or form an storage.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::GetCount Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::GetCount Method

This member function is to get properties count in the collection.

virtual int GetCount();
Returns

Properties amount in the collection.

See Also

GetProperty, SetProperty, RemoveProperty, RemoveAll.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::GetNextProperty Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::GetNextProperty Method

Retrieves the properties collection element at rPos, then updates rPos to refer to the next element in the collection.

void GetNextProperty(
    POSITION& rPos,
    CString& rStrName,
    COleVariant& rVarValue
) const;
Parameters

rPos
[in out] Specifies a reference to a POSITION value returned by a previous GetNextProperty or GetStartPosition call.
rStrName
[out] A reference to CString object to receive property name value.
rVarValue
[out] A reference to COleVariant object to receive property value.

See Also

GetStartPosition, CMap.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::GetProperty Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::GetProperty Method

This member function is used to get property value using the specified name.

virtual BOOL GetProperty(
    LPCTSTR pcszName,
    COleVariant& rVarValue
) const;
Parameters

pcszName
[in] A pointer to property name string.
rVarValue
[out] A reference to COleVariant object to receive property value.

Returns

TRUE if successful, FALSE if specified property is not present in the collection.

Remarks

The corresponding method for ActiveX returns VT_EMPTY variant value instead of FALSE.

See Also

SetProperty, RemoveProperty.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::GetStartPosition Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::GetStartPosition Method

Starts a properties collection iteration by returning a POSITION value that can be passed to a GetNextProperty call.

POSITION GetStartPosition() const;
Returns

A POSITION value with start position.

See Also

GetNextProperty, CMap.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::LoadFromXML Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::LoadFromXML Method

This helper function is used to load properties collection from XML string source.

BOOL LoadFromXML(
    LPCTSTR pcszXMLData
);
Parameters

pcszXMLData
[in] A pointer to XML string data source.

Returns

TRUE if successful, FALSE otherwise.

Remarks

RemoveAll method is called for collection before loading.

See Also

SaveToXML.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::PrepareName Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::PrepareName Method

Call this member function to prepare property name before pass it in the map access functions.

CString PrepareName(
    LPCTSTR pcszName
) const;
Parameters

pcszName
[in] A pointer to property name string.

Returns

Prepared property name string to pass it in the map access functions.

Remarks

If m_bNameIgnoreCase is TRUE, properties names are converted to lower case.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::RemoveAll Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::RemoveAll Method

This member function is used to remove all properties.

virtual void RemoveAll();
See Also

RemoveProperty, GetProperty, SetProperty.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::RemoveProperty Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::RemoveProperty Method

This member function is used to remove property with the specified name.

virtual BOOL RemoveProperty(
    LPCTSTR pcszName
);
Parameters

pcszName
[in] A pointer to property name string.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetProperty, SetProperty.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::SaveToXML Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::SaveToXML Method

This helper function is used to store properties collection to XML string.

BOOL SaveToXML(
    CString& rstrXMLData
);
Parameters

rstrXMLData
[out] A XML string object reference.

Returns

TRUE if successful, FALSE otherwise.

See Also

LoadFromXML.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties::SetProperty Method

CXTPCalendarCustomProperties Methods, CXTPCalendarCustomProperties Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::SetProperty Method

This member function is used to set property value with the specified name.

virtual BOOL SetProperty(
    LPCTSTR pcszName,
    const COleVariant& varValue
);
Parameters

pcszName
[in] A pointer to property name string.
varValue
[in] A const reference to COleVariant object with a property value.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetProperty, RemoveProperty.

Group

CXTPCalendarCustomProperties Methods


CXTPCalendarCustomProperties Constructors

CXTPCalendarCustomProperties Class, Legend, Public Methods
CXTPCalendarCustomProperties Constructors
Class

CXTPCalendarCustomProperties Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarCustomProperties | Default object constructor.


CXTPCalendarCustomProperties::CXTPCalendarCustomProperties Constructor

CXTPCalendarCustomProperties Constructors, CXTPCalendarCustomProperties Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::CXTPCalendarCustomProperties Constructor

Default object constructor.

CXTPCalendarCustomProperties(
    BOOL bNameIgnoreCase = TRUE
);
Parameters

bNameIgnoreCase
[in] if TRUE - properties names are not case sensitive.

Group

CXTPCalendarCustomProperties Constructors


CXTPCalendarCustomProperties Destructors

CXTPCalendarCustomProperties Class, Legend, Public Methods
CXTPCalendarCustomProperties Destructors
Class

CXTPCalendarCustomProperties Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarCustomProperties | Default object destructor.


CXTPCalendarCustomProperties::~CXTPCalendarCustomProperties Destructor

CXTPCalendarCustomProperties Destructors, CXTPCalendarCustomProperties Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarCustomProperties::~CXTPCalendarCustomProperties Destructor

Default object destructor.

virtual ~CXTPCalendarCustomProperties();
Group

CXTPCalendarCustomProperties Destructors


CXTPCalendarData Class

XTPCalendarData.h, Classes, Legend, Members, Topics, CXTPCalendarData Classes, CXTPCalendarData Templates, CXTPCalendarData Data Members, CXTPCalendarData Methods, CXTPCalendarData Constructors, CXTPCalendarData Destructors, CXTPCalendarData Classes, CXTPCalendarData Constructors, CXTPCalendarData Data Members, CXTPCalendarData Destructors, CXTPCalendarData Methods, See Also, CXTPCalendarData Templates
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData Class

This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added,

Class Hierarchy

class CXTPCalendarData;
File

XTPCalendarData.h

Remarks

This class is the definition of the XTPCalendarData abstract class which represents a data portion of the Calendar control.

To implement a custom Data Provider solution you should create a class derived from CXTPCalendarData and implement necessary virtual methods. The first main set of methods to be implemented are Open, Close, Save, Create, IsOpen, etc. The second main set of methods to be implemented is starting from Do verb. Those are: DoRetrieveDayEvents, DoRead_Event, DoUpdate_RPattern, etc.

To use a descendant of CXTPCalendarData in a regular way you first construct an instance of CXTPCalendarData object, then use Open() member function to establish connection to the data source and initialize the object. Class provides a number of functions to manipulate events and events related data. After finishing working with data source you should call Close() member function to close connection, de-initialize the object and free unused resources.

This class also contains an implementation of the data provider cache, which is used by default and gets a great performance increase in case when any slow connections are used (for example database connection).

See Also

CXTPCalendarData overview, CXTPCalendarEvents, CXTPCalendarEvent, CXTPCalendarCustomDataProvider

Group

Classes

Legend
Template
Data Member
protected
Method
virtual
CXTPCalendarData Classes
CXTPCalendarData Classes | Description
CXTPDPCache |
CXTPCalendarData Constructors
CXTPCalendarData Constructors | Description
CXTPCalendarData | Default constructor.
CXTPCalendarData Data Members
CXTPCalendarData Data Members | Description
m_bDisableNotificationsSending | Stores a flag whether notifications sending is disabled.
m_bOpened | Stores a flag whether a data source connection is open
m_cache | Common data provider cache.
m_pCalendarOptions | This member stores user's calendar view options.
m_pConnect | Connection object to send notifications.
m_pCustomProperties | Custom properties collection object.
m_pEventCategories | Store a collection of Event categories.
m_pLabelList | Event labels list.
m_pSchedules | Data source Schedules list
m_strConnectionString | default connection string;
m_typeProvider | Data provider type.
ms_dwNextFreeTempID | Next unique event ID.
CXTPCalendarData Destructors
CXTPCalendarData Destructors | Description
~CXTPCalendarData | Default Destructor.
CXTPCalendarData Methods
CXTPCalendarData Methods | Description
AddEvent | Creates a new event in the data source
AddEvents | Creates a set of events in the data source
ChangeEvent | Updates event properties in the data source.
ClearCache | Clears common data provider cache.
Close | Call this member function to close the connection to a data source.
Create | Call this member function to create a file for storing custom data provider data.
CreateNewEvent | Creates a new empty CXTPCalendarEvent object.
CreateNewRecurrencePattern | Creates a new empty CXTPCalendarRecurrencePattern object.
DeleteEvent | Deletes an event from the data source.
DoCreate_Event | Creates a new event in the data source
DoCreate_RPattern | Creates a new recurrence pattern in the data source
DoDelete_Event | Deletes an event from the data source.
DoDelete_RPattern | Deletes a recurrence pattern from the database
DoGetAllEvents_raw | Retrieves all events without generating recurrence occurrences.
DoGetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the data source.
DoRead_RPattern | Read recurrence pattern from the data source
DoRemoveAllEvents | Removes all events from the data source.
DoRetrieveDayEvents | Retrieves day events for a specified day from the data source.
DoUpdate_Event | Updates event properties in the data source.
DoUpdate_RPattern | Updates a recurrence pattern in the database
GetAllEvents_raw | This method Gets all events without generating recurrence occurrences.
GetCacheMode | Determines current cache mode.
GetConnection | Returns a connection pointer for the.data source.
GetConnectionString | Returns a data provider connection string.
GetCustomProperties | Returns a custom properties collection.
GetDataSource | Returns a data provider data source.
GetEvent | Read event from the data source.
GetEventCategories | Returns a collection of Event categories.
GetLabelList | Returns a collection of Labels used in this Data source.
GetNextFreeTempID | Call this member function to get a unique temporary event ID.
GetRecurrencePattern | Read recurrence pattern from the data source
GetSchedules | Returns a collection of schedules used in this data source.
GetType | This method determines a type of the current Data Provider implementation.
GetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
IsOpen | This method determines whether a data source connection is opened..
OnTimeZoneChanged | This method is called by the calendar control framework when Time Zone is Changed.
Open | Call this member function to initialize a newly constructed Data object. Your data object must be created before you can call Open().
RemoveAllEvents | Removes all events from the data source.
RetrieveDayEvents | Retrieves day events for a specified day from the data source.
Save | This method saves data to the file.
SendNotification | Sends a notification to all listeners.
SetCacheMode | Set common data provider cache mode.
SetConnectionString | Sets a data provider connection string.
SetLabelList | Set custom collection of Labels to be used in this Data source.
CXTPCalendarData Templates
CXTPCalendarData Templates | Description
EventsMapByID_T |


CXTPCalendarData Classes

Classes, CXTPCalendarData Class
CXTPCalendarData Classes
Classes
Class | Description
CXTPDPCache |
Class

CXTPCalendarData Class


CXTPCalendarData::CXTPDPCache Class

XTPCalendarData.h, CXTPCalendarData Classes, Legend, Members, Topics, CXTPDPCache Data Members, CXTPDPCache Methods, CXTPDPCache Constructors, CXTPDPCache Destructors, CXTPDPCache Constructors, CXTPDPCache Data Members, CXTPDPCache Destructors, CXTPDPCache Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::CXTPDPCache Class
Class Hierarchy

class CXTPDPCache;
File

XTPCalendarData.h

Remarks

Implementation of the data provider cache.

Group

CXTPCalendarData Classes

Legend
Data Member
protected
Method
virtual
CXTPDPCache Constructors
CXTPDPCache Constructors | Description
CXTPDPCache | Default class constructor.
CXTPDPCache Data Members
CXTPDPCache Data Members | Description
m_eCacheMode | see XTPCalendarDataProviderCacheMode
m_mapIsDayInCache | whether events for this day are already stored in cache
m_pCacheDP | Cache Data Provider.
CXTPDPCache Destructors
CXTPDPCache Destructors | Description
~CXTPDPCache | Default class destructor.
CXTPDPCache Methods
CXTPDPCache Methods | Description
_AddToCacheIfNeed | Checks whether a specified recurrence pattern is already stored in cache and adds it there if not.
AddToCache | Adds a collection if events to the cache for a specified day.
AddToCacheIfNeed | Checks whether a specified event is already stored in cache and adds it there if not.
IsDayInCache | Checks whether events for this day are already stored in cache.
IsEventInCache | Checks whether a specified event is already stored in cache.
SafeClose | Closes a cache.
SafeRemoveAll | Safely removes all elements from cache.
SetDayInCache | Sets a flag that this day is in cache.


CXTPDPCache Data Members

CXTPCalendarData::CXTPDPCache Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDPCache Data Members
Class

CXTPCalendarData::CXTPDPCache Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_mapIsDayInCache | whether events for this day are already stored in cache
Public Data Members
Public Data Member | Description
m_eCacheMode | see XTPCalendarDataProviderCacheMode
m_pCacheDP | Cache Data Provider.


CXTPCalendarData::CXTPDPCache::m_eCacheMode Data Member

CXTPDPCache Data Members, CXTPCalendarData::CXTPDPCache Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::CXTPDPCache::m_eCacheMode Data Member

see XTPCalendarDataProviderCacheMode

int m_eCacheMode;
Group

CXTPDPCache Data Members


CXTPCalendarData::CXTPDPCache::m_mapIsDayInCache Data Member

CXTPDPCache Data Members, CXTPCalendarData::CXTPDPCache Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::CXTPDPCache::m_mapIsDayInCache Data Member

whether events for this day are already stored in cache

CMap<DWORD, DWORD, BOOL, BOOL> m_mapIsDayInCache;
Group

CXTPDPCache Data Members


CXTPCalendarData::CXTPDPCache::m_pCacheDP Data Member

CXTPDPCache Data Members, CXTPCalendarData::CXTPDPCache Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::CXTPDPCache::m_pCacheDP Data Member

Cache Data Provider.

CXTPCalendarData* m_pCacheDP;
Group

CXTPDPCache Data Members


CXTPDPCache Methods

CXTPCalendarData::CXTPDPCache Class, Legend, Public Methods
CXTPDPCache Methods
Class

CXTPCalendarData::CXTPDPCache Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
_AddToCacheIfNeed | Checks whether a specified recurrence pattern is already stored in cache and adds it there if not.
AddToCache | Adds a collection if events to the cache for a specified day.
AddToCacheIfNeed | Checks whether a specified event is already stored in cache and adds it there if not.
IsDayInCache | Checks whether events for this day are already stored in cache.
IsEventInCache | Checks whether a specified event is already stored in cache.
SafeClose | Closes a cache.
SafeRemoveAll | Safely removes all elements from cache.
SetDayInCache | Sets a flag that this day is in cache.


CXTPCalendarData::CXTPDPCache::_AddToCacheIfNeed Method

CXTPDPCache Methods, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::_AddToCacheIfNeed Method

Checks whether a specified recurrence pattern is already stored in cache and adds it there if not.

virtual void _AddToCacheIfNeed(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
An pattern to check / add.

Group

CXTPDPCache Methods


CXTPCalendarData::CXTPDPCache::AddToCache Method

CXTPDPCache Methods, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::AddToCache Method

Adds a collection if events to the cache for a specified day.

virtual void AddToCache(
    CXTPCalendarEvents* pEvents,
    COleDateTime dtDay
);
Parameters

pEvents
An events collection.
dtDay
A specified day.

Group

CXTPDPCache Methods


CXTPCalendarData::CXTPDPCache::AddToCacheIfNeed Method

CXTPDPCache Methods, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::AddToCacheIfNeed Method

Checks whether a specified event is already stored in cache and adds it there if not.

virtual void AddToCacheIfNeed(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
An event to check / add.

Group

CXTPDPCache Methods


CXTPCalendarData::CXTPDPCache::IsDayInCache Method

CXTPDPCache Methods, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::IsDayInCache Method

Checks whether events for this day are already stored in cache.

virtual BOOL IsDayInCache(
    COleDateTime dtDay
);
Parameters

dtDay
A day to check.

Returns

TRUE if day is already stored in cache, FALSE otherwise.

Group

CXTPDPCache Methods


CXTPCalendarData::CXTPDPCache::IsEventInCache Method

CXTPDPCache Methods, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::IsEventInCache Method

Checks whether a specified event is already stored in cache.

virtual BOOL IsEventInCache(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
An event to check.

Returns

TRUE if an event is already stored in cache, FALSE otherwise.

Group

CXTPDPCache Methods


CXTPCalendarData::CXTPDPCache::SafeClose Method

CXTPDPCache Methods, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::SafeClose Method

Closes a cache.

void SafeClose();
Group

CXTPDPCache Methods


CXTPCalendarData::CXTPDPCache::SafeRemoveAll Method

CXTPDPCache Methods, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::SafeRemoveAll Method

Safely removes all elements from cache.

void SafeRemoveAll();
Group

CXTPDPCache Methods


CXTPCalendarData::CXTPDPCache::SetDayInCache Method

CXTPDPCache Methods, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::SetDayInCache Method

Sets a flag that this day is in cache.

virtual void SetDayInCache(
    COleDateTime dtDay,
    BOOL bSet = TRUE
);
Parameters

dtDay
A day to set.
bSet
Whether to set or clear flag.

Group

CXTPDPCache Methods


CXTPDPCache Constructors

CXTPCalendarData::CXTPDPCache Class, Legend, Public Methods
CXTPDPCache Constructors
Class

CXTPCalendarData::CXTPDPCache Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDPCache | Default class constructor.


CXTPCalendarData::CXTPDPCache::CXTPDPCache Constructor

CXTPDPCache Constructors, CXTPCalendarData::CXTPDPCache Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::CXTPDPCache::CXTPDPCache Constructor

Default class constructor.

CXTPDPCache();
Group

CXTPDPCache Constructors


CXTPDPCache Destructors

CXTPCalendarData::CXTPDPCache Class, Legend, Public Methods
CXTPDPCache Destructors
Class

CXTPCalendarData::CXTPDPCache Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDPCache | Default class destructor.


CXTPCalendarData::CXTPDPCache::~CXTPDPCache Destructor

CXTPDPCache Destructors, CXTPCalendarData::CXTPDPCache Class
CXTPCalendarData::CXTPDPCache::~CXTPDPCache Destructor

Default class destructor.

virtual ~CXTPDPCache();
Group

CXTPDPCache Destructors


CXTPCalendarData Templates

CXTPCalendarData Class, Legend, Templates
CXTPCalendarData Templates
Class

CXTPCalendarData Class

Templates
Template | Description
EventsMapByID_T |
Legend
Template


CXTPCalendarData::EventsMapByID_T Template

XTPCalendarData.h, CXTPCalendarData Templates, Legend, Members, Topics, EventsMapByID_T Data Members, EventsMapByID_T Methods, EventsMapByID_T Constructors, EventsMapByID_T Destructors, EventsMapByID_T Nested Types, EventsMapByID_T Constructors, EventsMapByID_T Data Members, EventsMapByID_T Destructors, EventsMapByID_T Methods, EventsMapByID_T Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T Template
Class Hierarchy

template <class _TObject>
class EventsMapByID_T;
File

XTPCalendarData.h

Remarks

This template class is used as a map (see CMap) to store ID and object pairs. Using the map allows for quick access using the ID.

See Also

CMap

Group

CXTPCalendarData Templates

Legend
Data Member
protected
Method
virtual
EventsMapByID_T Constructors
EventsMapByID_T Constructors | Description
EventsMapByID_T | Default class constructor.
EventsMapByID_T Data Members
EventsMapByID_T Data Members | Description
m_mapID2Object | The map of ID to object.
EventsMapByID_T Destructors
EventsMapByID_T Destructors | Description
~EventsMapByID_T | Default class destructor.
EventsMapByID_T Methods
EventsMapByID_T Methods | Description
Add | This member function is used to add new or to replace existing pairs of IDs and Objects.
Get | This member function is used to obtain a pointer to an object using the specified ID.
GetCount | This member function is used to get object count.
GetNextElement | This member function is used to get next object pointer.
GetStartPosition | This member function is used to get start iteration position.
IsExist | This member function is used to determine if an object with the specified ID exists.
Remove | This member function is used to remove an object with the specified ID.
RemoveAll | This member function is used to remove all stored objects from the map.
EventsMapByID_T Nested Types
EventsMapByID_T Nested Types | Description
TObjPtr | Smart pointer object type.


EventsMapByID_T Data Members

CXTPCalendarData::EventsMapByID_T Template, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
EventsMapByID_T Data Members
Template

CXTPCalendarData::EventsMapByID_T Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_mapID2Object | The map of ID to object.


CXTPCalendarData::EventsMapByID_T::m_mapID2Object Data Member

EventsMapByID_T Data Members, CXTPCalendarData::EventsMapByID_T Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::m_mapID2Object Data Member

The map of ID to object.

CMap<DWORD, DWORD, TObjPtr, TObjPtr&> m_mapID2Object;
Group

EventsMapByID_T Data Members


EventsMapByID_T Methods

CXTPCalendarData::EventsMapByID_T Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
EventsMapByID_T Methods
Template

CXTPCalendarData::EventsMapByID_T Template

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add | This member function is used to add new or to replace existing pairs of IDs and Objects.
Get | This member function is used to obtain a pointer to an object using the specified ID.
GetCount | This member function is used to get object count.
GetNextElement | This member function is used to get next object pointer.
GetStartPosition | This member function is used to get start iteration position.
IsExist | This member function is used to determine if an object with the specified ID exists.
Remove | This member function is used to remove an object with the specified ID.
RemoveAll | This member function is used to remove all stored objects from the map.


CXTPCalendarData::EventsMapByID_T::Add Method

EventsMapByID_T Methods, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::Add Method

This member function is used to add new or to replace existing pairs of IDs and Objects.

void Add(
    DWORD dwID,
    _TObject* pObj
);
Parameters

dwID
Object ID.
pObj
Object Pointer.

Remarks

Call this method to add new or to replace existing elements in the map. InternalAddRef is called for the stored object.

See Also

Get, Remove, CMap::SetAt

Body Source
void Add(DWORD dwID, _TObject* pObj)
{
    if (!pObj) {
        ASSERT(FALSE);
        return;
    }
    TObjPtr ptrObj(pObj, TRUE);
    m_mapID2Object.SetAt(dwID, ptrObj);
}
Group

EventsMapByID_T Methods


CXTPCalendarData::EventsMapByID_T::Get Method

EventsMapByID_T Methods, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::Get Method

This member function is used to obtain a pointer to an object using the specified ID.

_TObject* Get(
    DWORD dwID
);
Parameters

dwID
Object ID.

Returns

Object pointer or NULL.

Remarks

Call this method to search for the object using the ID. InternalAddRef is called for the non-NULL returned object.

See Also

Add, CMap::Lookup

Body Source
_TObject* Get(DWORD dwID) {
    TObjPtr ptrObj;
    if (m_mapID2Object.Lookup(dwID, ptrObj) && ptrObj) {
        return (_TObject*)(CCmdTarget*)ptrObj;
    }
    return NULL;
}
Group

EventsMapByID_T Methods


CXTPCalendarData::EventsMapByID_T::GetCount Method

EventsMapByID_T Methods, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::GetCount Method

This member function is used to get object count.

int GetCount();
Returns

Count of the objects in the map.

See Also

CMap::GetCount

Body Source
int GetCount()  {
    return (int)m_mapID2Object.GetCount();

}
Group

EventsMapByID_T Methods


CXTPCalendarData::EventsMapByID_T::GetNextElement Method

EventsMapByID_T Methods, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::GetNextElement Method

This member function is used to get next object pointer.

_TObject* GetNextElement(
    POSITION& rPos,
    DWORD& rID
);
Parameters

rPos
[in/out] Iteration position of the element.
rID
[out] Element ID.

Returns

A pointer to the object which corresponds to the specified position (rPos parameter value).

Remarks

Call this method to iterate on elements stored in the map. InternalAddRef is not called for the returned object. rPos parameter value is set to the element next position or NULL if iterating is finished.

See Also

GetStartPosition, CMap::GetNextAssoc

Body Source
_TObject* GetNextElement(POSITION& rPos, DWORD& rID)
{
    TObjPtr ptrElement;
    m_mapID2Object.GetNextAssoc(rPos, rID, ptrElement);
    return (_TObject*)(CCmdTarget*)ptrElement;
}
Group

EventsMapByID_T Methods


CXTPCalendarData::EventsMapByID_T::GetStartPosition Method

EventsMapByID_T Methods, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::GetStartPosition Method

This member function is used to get start iteration position.

POSITION GetStartPosition();
Returns

A POSITION value that indicates a starting position for iterating the map; or NULL if the map is empty.

See Also

GetNextElement, CMap::GetStartPosition

Body Source
POSITION GetStartPosition() {
    return m_mapID2Object.GetStartPosition();
}
Group

EventsMapByID_T Methods


CXTPCalendarData::EventsMapByID_T::IsExist Method

EventsMapByID_T Methods, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::IsExist Method

This member function is used to determine if an object with the specified ID exists.

BOOL IsExist(
    DWORD dwID
);
Parameters

dwID
Object ID.

Returns

TRUE if object with ID exists. Otherwise FALSE.

Remarks

Similar to Get method, but calls InternalAddRef for the returned object.

See Also

Get, CMap::Lookup

Body Source
BOOL IsExist(DWORD dwID) {
    TObjPtr ptrObj;
    return m_mapID2Object.Lookup(dwID, ptrObj) && ptrObj;
}
Group

EventsMapByID_T Methods


CXTPCalendarData::EventsMapByID_T::Remove Method

EventsMapByID_T Methods, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::Remove Method

This member function is used to remove an object with the specified ID.

BOOL Remove(
    DWORD dwID
);
Parameters

dwID
Object ID.

Returns

Nonzero if the entry was found and successfully removed; otherwise 0.

Remarks

Call this method to remove an element with the supplied ID from the map. InternalAddRef is called for the removed object.

See Also

Add, RemoveAll, CMap::RemoveKey

Body Source
BOOL Remove(DWORD dwID) {
    BOOL bRes = m_mapID2Object.RemoveKey(dwID);
    return bRes;
}
Group

EventsMapByID_T Methods


CXTPCalendarData::EventsMapByID_T::RemoveAll Method

EventsMapByID_T Methods, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::RemoveAll Method

This member function is used to remove all stored objects from the map.

void RemoveAll();
Remarks

Call this method to cleanup the map. InternalAddRef is called for all objects.

See Also

Remove, CMap::RemoveAll

Body Source
void RemoveAll() {
    m_mapID2Object.RemoveAll();
}
Group

EventsMapByID_T Methods


EventsMapByID_T Constructors

CXTPCalendarData::EventsMapByID_T Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
EventsMapByID_T Constructors
Template

CXTPCalendarData::EventsMapByID_T Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
EventsMapByID_T | Default class constructor.


CXTPCalendarData::EventsMapByID_T::EventsMapByID_T Constructor

EventsMapByID_T Constructors, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::EventsMapByID_T Constructor

Default class constructor.

EventsMapByID_T(
    UINT uHashTableSize = XTP_OBJECT_CACHE_HASH_TABLE_SIZE
);
Parameters

uHashTableSize
Size of the map hash table.

See Also

CMap, CMap::InitHashTable

Body Source
EventsMapByID_T(UINT uHashTableSize = XTP_OBJECT_CACHE_HASH_TABLE_SIZE)
{
    m_mapID2Object.InitHashTable(uHashTableSize, FALSE);
}
Group

EventsMapByID_T Constructors


EventsMapByID_T Destructors

CXTPCalendarData::EventsMapByID_T Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
EventsMapByID_T Destructors
Template

CXTPCalendarData::EventsMapByID_T Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~EventsMapByID_T | Default class destructor.


CXTPCalendarData::EventsMapByID_T::~EventsMapByID_T Destructor

EventsMapByID_T Destructors, CXTPCalendarData::EventsMapByID_T Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::~EventsMapByID_T Destructor

Default class destructor.

virtual ~EventsMapByID_T();
Remarks

Handles member items deallocation. Decreases references of stored objects.

See Also

CMap

Body Source
virtual ~EventsMapByID_T() {}
Group

EventsMapByID_T Destructors


EventsMapByID_T Nested Types

CXTPCalendarData::EventsMapByID_T Template, Public Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
EventsMapByID_T Nested Types
Template

CXTPCalendarData::EventsMapByID_T Template

Public Nested Types
Public Nested Type | Description
TObjPtr | Smart pointer object type.


CXTPCalendarData::EventsMapByID_T::TObjPtr Nested Type

EventsMapByID_T Nested Types, CXTPCalendarData::EventsMapByID_T Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::EventsMapByID_T::TObjPtr Nested Type

Smart pointer object type.

typedef CXTPSmartPtrInternalT<CCmdTarget> TObjPtr;
Group

EventsMapByID_T Nested Types


CXTPCalendarData Data Members

CXTPCalendarData Class, Legend, Protected Data Members
CXTPCalendarData Data Members
Class

CXTPCalendarData Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bDisableNotificationsSending | Stores a flag whether notifications sending is disabled.
m_bOpened | Stores a flag whether a data source connection is open
m_cache | Common data provider cache.
m_pCalendarOptions | This member stores user's calendar view options.
m_pConnect | Connection object to send notifications.
m_pCustomProperties | Custom properties collection object.
m_pEventCategories | Store a collection of Event categories.
m_pLabelList | Event labels list.
m_pSchedules | Data source Schedules list
m_strConnectionString | default connection string;
m_typeProvider | Data provider type.
ms_dwNextFreeTempID | Next unique event ID.


CXTPCalendarData::m_bDisableNotificationsSending Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_bDisableNotificationsSending Data Member

Stores a flag whether notifications sending is disabled.

BOOL m_bDisableNotificationsSending;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_bOpened Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_bOpened Data Member

Stores a flag whether a data source connection is open

BOOL m_bOpened;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_cache Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_cache Data Member

Common data provider cache.

CXTPDPCache m_cache;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_pCalendarOptions Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_pCalendarOptions Data Member

This member stores user's calendar view options.

CXTPCalendarOptions* m_pCalendarOptions;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_pConnect Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_pConnect Data Member

Connection object to send notifications.

CXTPNotifyConnection* m_pConnect;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_pCustomProperties Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_pCustomProperties Data Member

Custom properties collection object.

CXTPCalendarCustomProperties* m_pCustomProperties;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_pEventCategories Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_pEventCategories Data Member

Store a collection of Event categories.

CXTPCalendarEventCategories* m_pEventCategories;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_pLabelList Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_pLabelList Data Member

Event labels list.

CXTPCalendarEventLabels* m_pLabelList;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_pSchedules Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_pSchedules Data Member

Data source Schedules list

CXTPCalendarSchedules* m_pSchedules;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_strConnectionString Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_strConnectionString Data Member

default connection string;

CString m_strConnectionString;
Group

CXTPCalendarData Data Members


CXTPCalendarData::m_typeProvider Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::m_typeProvider Data Member

Data provider type.

XTPCalendarDataProvider m_typeProvider;
Group

CXTPCalendarData Data Members


CXTPCalendarData::ms_dwNextFreeTempID Data Member

CXTPCalendarData Data Members, CXTPCalendarData Class
CXTPCalendarData::ms_dwNextFreeTempID Data Member

Next unique event ID.

DWORD ms_dwNextFreeTempID;
Group

CXTPCalendarData Data Members


CXTPCalendarData Methods

CXTPCalendarData Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData Methods
Class

CXTPCalendarData Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DoCreate_Event | Creates a new event in the data source
DoCreate_RPattern | Creates a new recurrence pattern in the data source
DoDelete_Event | Deletes an event from the data source.
DoDelete_RPattern | Deletes a recurrence pattern from the database
DoGetAllEvents_raw | Retrieves all events without generating recurrence occurrences.
DoGetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the data source.
DoRead_RPattern | Read recurrence pattern from the data source
DoRemoveAllEvents | Removes all events from the data source.
DoRetrieveDayEvents | Retrieves day events for a specified day from the data source.
DoUpdate_Event | Updates event properties in the data source.
DoUpdate_RPattern | Updates a recurrence pattern in the database
GetNextFreeTempID | Call this member function to get a unique temporary event ID.
OnTimeZoneChanged | This method is called by the calendar control framework when Time Zone is Changed.
SendNotification | Sends a notification to all listeners.
Public Methods
Public Methods
Public Method | Description
AddEvent | Creates a new event in the data source
AddEvents | Creates a set of events in the data source
ChangeEvent | Updates event properties in the data source.
ClearCache | Clears common data provider cache.
Close | Call this member function to close the connection to a data source.
Create | Call this member function to create a file for storing custom data provider data.
CreateNewEvent | Creates a new empty CXTPCalendarEvent object.
CreateNewRecurrencePattern | Creates a new empty CXTPCalendarRecurrencePattern object.
DeleteEvent | Deletes an event from the data source.
GetAllEvents_raw | This method Gets all events without generating recurrence occurrences.
GetCacheMode | Determines current cache mode.
GetConnection | Returns a connection pointer for the.data source.
GetConnectionString | Returns a data provider connection string.
GetCustomProperties | Returns a custom properties collection.
GetDataSource | Returns a data provider data source.
GetEvent | Read event from the data source.
GetEventCategories | Returns a collection of Event categories.
GetLabelList | Returns a collection of Labels used in this Data source.
GetRecurrencePattern | Read recurrence pattern from the data source
GetSchedules | Returns a collection of schedules used in this data source.
GetType | This method determines a type of the current Data Provider implementation.
GetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
IsOpen | This method determines whether a data source connection is opened..
Open | Call this member function to initialize a newly constructed Data object. Your data object must be created before you can call Open().
RemoveAllEvents | Removes all events from the data source.
RetrieveDayEvents | Retrieves day events for a specified day from the data source.
Save | This method saves data to the file.
SetCacheMode | Set common data provider cache mode.
SetConnectionString | Sets a data provider connection string.
SetLabelList | Set custom collection of Labels to be used in this Data source.


CXTPCalendarData::AddEvent Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::AddEvent Method

Creates a new event in the data source

virtual BOOL AddEvent(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.

Returns

TRUE if event created successfully, FALSE in case of any error during the process.

Remarks

This method creates a data record corresponding with the specified event. This method uses DoCreate_Event realization and implements some additional service processing.

Group

CXTPCalendarData Methods


CXTPCalendarData::AddEvents Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::AddEvents Method

Creates a set of events in the data source

virtual BOOL AddEvents(
    CXTPCalendarEvents* pEvents
);
Parameters

pEvents
Pointer to the CXTPCalendarEvents collection which contains a number of CXTPCalendarEvent objects.

Returns

TRUE if all events were added successfully, FALSE in case of any error during the process.

Remarks

This method adds a collection of events into the data source.

Group

CXTPCalendarData Methods


CXTPCalendarData::ChangeEvent Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::ChangeEvent Method

Updates event properties in the data source.

virtual BOOL ChangeEvent(
    CXTPCalendarEvent* pNewEvent
);
Parameters

pNewEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event updated successfully, FALSE in case of any errors during the process.

Remarks

This method updates a data record corresponding with the specified event. This method uses DoUpdate_Event realization and implements some additional service processing.

Group

CXTPCalendarData Methods


CXTPCalendarData::ClearCache Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::ClearCache Method

Clears common data provider cache.

virtual void ClearCache();
Group

CXTPCalendarData Methods


CXTPCalendarData::Close Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::Close Method

Call this member function to close the connection to a data source.

virtual void Close();
Body Source
void CXTPCalendarData::Close() {
    ASSERT(m_bOpened);

    m_cache.SafeClose();
    m_bOpened = FALSE;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::Create Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::Create Method

Call this member function to create a file for storing custom data provider data.

virtual BOOL Create();
Returns

TRUE is successful. FALSE otherwise.

Remarks

It will be opened by default.

Body Source
BOOL CXTPCalendarData::Create() {
    ASSERT(!m_bOpened);
    return m_bOpened = TRUE;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::CreateNewEvent Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::CreateNewEvent Method

Creates a new empty CXTPCalendarEvent object.

virtual CXTPCalendarEventPtr CreateNewEvent(
    DWORD dwEventID = XTP_CALENDAR_UNKNOWN_EVENT_ID
);
Parameters

dwEventID
ID for a new event

Returns

Created empty event.

Remarks

This method creates a new CXTPCalendarEvent class and initializes it's ID.

It could be reimplemented in a descendant if it has its own ID's source (for example, database key field).

Group

CXTPCalendarData Methods


CXTPCalendarData::CreateNewRecurrencePattern Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::CreateNewRecurrencePattern Method

Creates a new empty CXTPCalendarRecurrencePattern object.

virtual CXTPCalendarRecurrencePatternPtr CreateNewRecurrencePattern(
    DWORD dwPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID
);
Parameters

dwPatternID
ID for a new Recurrence Pattern

Returns

Created empty Recurrence Pattern.

Remarks

This method creates a new CXTPCalendarRecurrencePattern class and initializes it's ID.

It could be reimplemented in a descendant if it has its own ID's source (for example, database key field).

Group

CXTPCalendarData Methods


CXTPCalendarData::DeleteEvent Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DeleteEvent Method

Deletes an event from the data source.

virtual BOOL DeleteEvent(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event deleted successfully, FALSE in case of any errors during the process.

Remarks

This method deletes a data record corresponding with the specified event. This method uses DoDelete_Event realization and implements some additional service processing.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoCreate_Event Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoCreate_Event Method

Creates a new event in the data source

virtual BOOL DoCreate_Event(
    CXTPCalendarEvent* pEvent,
    DWORD& rdwNewEventID
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.
rdwNewEventID
[out] EventID of a newly created record

Returns

TRUE if event created successfully, FALSE in case of any error during the process.

Remarks

This method creates a data record corresponding with the specified event. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoCreate_RPattern Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoCreate_RPattern Method

Creates a new recurrence pattern in the data source

virtual BOOL DoCreate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern,
    DWORD& rdwNewPatternID
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object which describes all data fields of a newly created record.
rdwNewPatternID
[out] ID of a newly created record

Returns

TRUE if recurrence pattern created successfully, FALSE in case of any error during the process.

Remarks

This method creates a data record corresponding with the specified recurrence pattern. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoDelete_Event Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoDelete_Event Method

Deletes an event from the data source.

virtual BOOL DoDelete_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event deleted successfully, FALSE in case of any errors during the process.

Remarks

This method deletes a data record corresponding with the specified event. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoDelete_RPattern Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoDelete_RPattern Method

Deletes a recurrence pattern from the database

virtual BOOL DoDelete_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object which should be deleted.

Returns

TRUE if recurrence pattern deleted successfully, FALSE in case of any error during the process.

Remarks

This method deletes a data record corresponding with the specified recurrence pattern. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoGetAllEvents_raw Method

CXTPCalendarData Methods, CXTPCalendarData Class, See Also
CXTPCalendarData::DoGetAllEvents_raw Method

Retrieves all events without generating recurrence occurrences.

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
Returns

A CXTPCalendarEvents pointer containing a collection of all events.

Remarks

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

See Also

GetAllEvents_raw()

Group

CXTPCalendarData Methods


CXTPCalendarData::DoGetUpcomingEvents Method

CXTPCalendarData Methods, CXTPCalendarData Class, See Also
CXTPCalendarData::DoGetUpcomingEvents Method

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(
    COleDateTime dtFrom,
    COleDateTimeSpan spPeriod
);
Parameters

dtFrom
Start date and time of a specified period.
spPeriod
A duration of a specified period.

Returns

A CXTPCalendarEvents pointer containing a collection of upcoming events.

Remarks

This method is used by a reminders manager. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

See Also

CXTPCalendarRemindersManager overview

Group

CXTPCalendarData Methods


CXTPCalendarData::DoRead_Event Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoRead_Event Method

Read event from the data source.

virtual CXTPCalendarEventPtr DoRead_Event(
    DWORD dwEventID
);
Parameters

dwEventID
Event ID of the read target.

Returns

A pointer to the new CXTPCalendarEvent object which fields are filled with a data from the data source.

Remarks

This method retrieves all data for a specified event. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoRead_RPattern Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoRead_RPattern Method

Read recurrence pattern from the data source

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(
    DWORD dwPatternID
);
Parameters

dwPatternID
Pattern ID of the read target.

Returns

A pointer to the new CXTPCalendarRecurrencePatternPtr object which fields are filled with a data from the data source.

Remarks

This method retrieves all data for a specified recurrence pattern. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoRemoveAllEvents Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoRemoveAllEvents Method

Removes all events from the data source.

virtual void DoRemoveAllEvents();
Remarks

This method removes all appointments from the data source. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoRetrieveDayEvents Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoRetrieveDayEvents Method

Retrieves day events for a specified day from the data source.

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(
    COleDateTime dtDay
);
Parameters

dtDay
A specified day.

Returns

A collection of events for a specified day.

Remarks

This method retrieves all appointments for a specified day from the data source. It includes recurrence appointments occurrences, regular appointments for this day, multi day appointments which also have a part of this day. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoUpdate_Event Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoUpdate_Event Method

Updates event properties in the data source.

virtual BOOL DoUpdate_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event updated successfully, FALSE in case of any errors during the process.

Remarks

This method updates a data record corresponding with the specified event. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::DoUpdate_RPattern Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::DoUpdate_RPattern Method

Updates a recurrence pattern in the database

virtual BOOL DoUpdate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object.

Returns

TRUE if recurrence pattern updated successfully, FALSE in case of any error during the process.

Remarks

This method updates a data record corresponding with the specified recurrence pattern. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Group

CXTPCalendarData Methods


CXTPCalendarData::GetAllEvents_raw Method

CXTPCalendarData Methods, CXTPCalendarData Class, See Also
CXTPCalendarData::GetAllEvents_raw Method

This method Gets all events without generating recurrence occurrences.

virtual CXTPCalendarEventsPtr GetAllEvents_raw();
Returns

A CXTPCalendarEvents pointer containing a collection of all events.

Remarks

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated. This method uses DoGetAllEvents_raw realization and implements some additional service processing.

See Also

_Save(), Serialize(), DoGetAllEvents_raw()

Group

CXTPCalendarData Methods


CXTPCalendarData::GetCacheMode Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetCacheMode Method

Determines current cache mode.

virtual int GetCacheMode() const;
See Also

XTPCalendarDataProviderCacheMode enumeration, SetCacheMode().

Body Source
int CXTPCalendarData::GetCacheMode() const {
    return m_cache.m_eCacheMode;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetConnection Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetConnection Method

Returns a connection pointer for the.data source.

virtual CXTPNotifyConnection* GetConnection();
Returns

A connection pointer. See also; CXTPNotifyConnection overview.

Body Source
CXTPNotifyConnection* CXTPCalendarData::GetConnection() {
    return m_pConnect;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetConnectionString Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetConnectionString Method

Returns a data provider connection string.

virtual CString GetConnectionString();
Returns

Current connection string. See also; SetConnectionString(), GetDataSource()

Body Source
CString CXTPCalendarData::GetConnectionString() {
    return m_strConnectionString;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetCustomProperties Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetCustomProperties Method

Returns a custom properties collection.

virtual CXTPCalendarCustomProperties* GetCustomProperties();
Returns

A custom properties collection associated with the data source.. See also; CXTPCalendarCustomProperties overview.

Body Source
CXTPCalendarCustomProperties* CXTPCalendarData::GetCustomProperties() {
    return m_pCustomProperties;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetDataSource Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::GetDataSource Method

Returns a data provider data source.

virtual CString GetDataSource();
Returns

String with current data source settings.

Remarks

This method parses a connection string and returns a data source as a part of it. See also; GetConnectionString(), SetConnectionString()

Group

CXTPCalendarData Methods


CXTPCalendarData::GetEvent Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::GetEvent Method

Read event from the data source.

virtual CXTPCalendarEventPtr GetEvent(
    DWORD dwEventID
);
Parameters

dwEventID
Event ID of the read target.

Returns

A pointer to the new CXTPCalendarEvent object which fields are filled with a data from the data source.

Remarks

This method retrieves all data for a specified event. This method uses DoRead_Event realization and implements some additional service processing.

Group

CXTPCalendarData Methods


CXTPCalendarData::GetEventCategories Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetEventCategories Method

Returns a collection of Event categories.

virtual CXTPCalendarEventCategories* GetEventCategories() const;
Returns

A collection of Event categories. By default it has some predefined values. See also; CXTPCalendarEventCategories overview, CXTPCalendarEventCategories::InitDefaultValues()

Body Source
CXTPCalendarEventCategories* CXTPCalendarData::GetEventCategories() const {
    return m_pEventCategories;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetLabelList Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetLabelList Method

Returns a collection of Labels used in this Data source.

virtual CXTPCalendarEventLabels* GetLabelList() const;
Returns

A collection of Labels used in this Data source. By default it has some predefined values. See also; CXTPCalendarEventLabels overview, SetLabelList(), CXTPCalendarEventLabels::InitDefaultValues

Body Source
CXTPCalendarEventLabels* CXTPCalendarData::GetLabelList() const {
    return m_pLabelList;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetNextFreeTempID Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetNextFreeTempID Method

Call this member function to get a unique temporary event ID.

static DWORD GetNextFreeTempID();
Returns

New value for event ID.

Body Source
DWORD CXTPCalendarData::GetNextFreeTempID() {
    return ms_dwNextFreeTempID--;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetRecurrencePattern Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::GetRecurrencePattern Method

Read recurrence pattern from the data source

virtual CXTPCalendarRecurrencePatternPtr GetRecurrencePattern(
    DWORD dwPatternID
);
Parameters

dwPatternID
Pattern ID of the read target.

Returns

A pointer to the new CXTPCalendarRecurrencePatternPtr object which fields are filled with a data from the data source.

Remarks

This method retrieves all data for a specified recurrence pattern. This method uses DoRead_RPattern realization and implements some additional service processing.

Group

CXTPCalendarData Methods


CXTPCalendarData::GetSchedules Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetSchedules Method

Returns a collection of schedules used in this data source.

virtual CXTPCalendarSchedules* GetSchedules() const;
Returns

A collection of schedules associated with the data source. See also; CXTPCalendarSchedules overview.

Body Source
CXTPCalendarSchedules* CXTPCalendarData::GetSchedules() const {
    return m_pSchedules;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetType Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::GetType Method

This method determines a type of the current Data Provider implementation.

virtual XTPCalendarDataProvider GetType();
Returns

Current Data Provider implementation type.

See Also

XTPCalendarDataProvider enumeration.

Body Source
XTPCalendarDataProvider CXTPCalendarData::GetType() {
    return m_typeProvider;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::GetUpcomingEvents Method

CXTPCalendarData Methods, CXTPCalendarData Class, See Also
CXTPCalendarData::GetUpcomingEvents Method

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

virtual CXTPCalendarEventsPtr GetUpcomingEvents(
    COleDateTime dtFrom = (DATE)0,
    COleDateTimeSpan spPeriod = (DATE)0
);
Parameters

dtFrom
Start date and time of a specified period.
spPeriod
A duration of a specified period.

Returns

A CXTPCalendarEvents pointer containing a collection of upcoming events.

Remarks

This method is used by a reminders manager. This method uses DoGetUpcomingEvents realization and implements some additional service processing.

See Also

CXTPCalendarRemindersManager overview

Group

CXTPCalendarData Methods


CXTPCalendarData::IsOpen Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::IsOpen Method

This method determines whether a data source connection is opened..

virtual BOOL IsOpen();
Returns

TRUE when a connection is already opened. FALSE otherwise.

Body Source
BOOL CXTPCalendarData::IsOpen() {
    return m_bOpened;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::OnTimeZoneChanged Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::OnTimeZoneChanged Method

This method is called by the calendar control framework when Time Zone is Changed.

virtual BOOL OnTimeZoneChanged();
Returns

TRUE if internal data changed and calendar must be re-populated, FALSE if this event is ignored (no data changed). Base implementation do nothing and returns FALSE.

Remarks

The data provider implementation may use this method to adjust its data for a new timezone.

See Also

CXTPTopLevelWndMsgNotifier, XTP_WM_TIME_ZONE_CHANGED

Body Source
virtual BOOL OnTimeZoneChanged() { return FALSE; }
Group

CXTPCalendarData Methods


CXTPCalendarData::Open Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::Open Method

Call this member function to initialize a newly constructed Data object. Your data object must be created before you can call Open().

virtual BOOL Open();
Returns

Boolean value represents succsess/failure result

Body Source
BOOL CXTPCalendarData::Open() {
    ASSERT(!m_bOpened);
    return m_bOpened = TRUE;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::RemoveAllEvents Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::RemoveAllEvents Method

Removes all events from the data source.

virtual void RemoveAllEvents();
Remarks

This method removes all appointments from the data source. This method uses DoRemoveAllEvents realization and implements some additional service processing.

Group

CXTPCalendarData Methods


CXTPCalendarData::RetrieveDayEvents Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::RetrieveDayEvents Method

Retrieves day events for a specified day from the data source.

virtual CXTPCalendarEventsPtr RetrieveDayEvents(
    COleDateTime dtDay
);
Parameters

dtDay
A specified day.

Returns

A collection of events for a specified day.

Remarks

This method retrieves all appointments for a specified day from the data source. It includes recurrence appointments occurrences, regular appointments for this day, multi day appointments which also have a part of this day. This method uses DoRetrieveDayEvents realization and implements some additional service processing.

Group

CXTPCalendarData Methods


CXTPCalendarData::Save Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::Save Method

This method saves data to the file.

virtual BOOL Save();
Returns

TRUE is successful. FALSE otherwise.

Remarks

The most recent data from the data provider will be saved in the same external file as before. Note that all the data inside the data provider is already up to date, this method just allows it to be saved externally.

Body Source
BOOL CXTPCalendarData::Save() {
    ASSERT(m_bOpened);
    return TRUE;
}
Group

CXTPCalendarData Methods


CXTPCalendarData::SendNotification Method

CXTPCalendarData Methods, CXTPCalendarData Class, See Also
CXTPCalendarData::SendNotification Method

Sends a notification to all listeners.

virtual void SendNotification(
    XTP_NOTIFY_CODE EventCode,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

EventCode
Notification event code.
wParam
First notification parameter.
lParam
Second notification parameter.

See Also

CXTPNotifyConnection overview

Group

CXTPCalendarData Methods


CXTPCalendarData::SetCacheMode Method

CXTPCalendarData Methods, CXTPCalendarData Class, See Also
CXTPCalendarData::SetCacheMode Method

Set common data provider cache mode.

virtual void SetCacheMode(
    int eCacheMode,
    CXTPCalendarData* pCacheDataProvider = NULL
);
Parameters

eCacheMode
Cache mode. See XTPCalendarDataProviderCacheMode
pCacheDataProvider
Data Provider object which you want to use for cache purposes. By default it is CXTPCalendarMemoryDataProvider.

Remarks

This method updates an internal cache mode.

See Also

XTPCalendarDataProviderCacheMode enumeration.

Group

CXTPCalendarData Methods


CXTPCalendarData::SetConnectionString Method

CXTPCalendarData Methods, CXTPCalendarData Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::SetConnectionString Method

Sets a data provider connection string.

virtual void SetConnectionString(
    LPCTSTR lpszConnectionString
);
Parameters

lpszConnectionString
A connection string. See also; GetConnectionString(), GetDataSource()

Body Source
void CXTPCalendarData::SetConnectionString(LPCTSTR lpszConnectionString) {
    ASSERT(lpszConnectionString);
    if (lpszConnectionString) {
        m_strConnectionString = lpszConnectionString;
    }
}
Group

CXTPCalendarData Methods


CXTPCalendarData::SetLabelList Method

CXTPCalendarData Methods, CXTPCalendarData Class
CXTPCalendarData::SetLabelList Method

Set custom collection of Labels to be used in this Data source.

virtual void SetLabelList(
    CXTPCalendarEventLabels* pLabelList
);
Parameters

pLabelList
A custom collection of Labels to be used there. See also; CXTPCalendarEventLabels overview, GetLabelList()

Group

CXTPCalendarData Methods


CXTPCalendarData Constructors

CXTPCalendarData Class, Legend, Public Methods
CXTPCalendarData Constructors
Class

CXTPCalendarData Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarData | Default constructor.


CXTPCalendarData::CXTPCalendarData Constructor

CXTPCalendarData Constructors, CXTPCalendarData Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarData::CXTPCalendarData Constructor

Default constructor.

CXTPCalendarData();
Remarks

Constructs a Data object. To establish a connection to a specified data source and initialize the object you must call Open() member function immediately after construction.

See Also

Open()

Group

CXTPCalendarData Constructors


CXTPCalendarData Destructors

CXTPCalendarData Class, Legend, Public Methods
CXTPCalendarData Destructors
Class

CXTPCalendarData Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarData | Default Destructor.


CXTPCalendarData::~CXTPCalendarData Destructor

CXTPCalendarData Destructors, CXTPCalendarData Class
CXTPCalendarData::~CXTPCalendarData Destructor

Default Destructor.

virtual ~CXTPCalendarData();
Remarks

Handles all deallocation.

Group

CXTPCalendarData Destructors


CXTPCalendarDatabaseDataProvider Class

XTPCalendarDatabaseDataProvider.h, Classes, Legend, Members, Topics, CXTPCalendarDatabaseDataProvider Data Members, CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Constructors, CXTPCalendarDatabaseDataProvider Destructors, CXTPCalendarDatabaseDataProvider Constructors, CXTPCalendarDatabaseDataProvider Data Members, CXTPCalendarDatabaseDataProvider Destructors, CXTPCalendarDatabaseDataProvider Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider Class

This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.

Class Hierarchy

class CXTPCalendarDatabaseDataProvider : public CXTPCalendarData;
File

XTPCalendarDatabaseDataProvider.h

Remarks

This implementation uses MS Access database as the data source. The Data source stores all Events data and provides a way to retrieve and save CXTPCalendarEvent objects.

To use CXTPCalendarDatabaseDataProvider first construct an instance of CXTPCalendarDatabaseDataProvider object then use Open() member function to establish connection to the data source and initialize the object. Class provides a number of functions to manipulate events and events related data. After finished working with the data source must call the Close() member function to close the connection and to de-initialize the object and free any unused resources.

See Also

CXTPCalendarData, CXTPCalendarMemoryDataProvider

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarDatabaseDataProvider Constructors
CXTPCalendarDatabaseDataProvider Constructors | Description
CXTPCalendarDatabaseDataProvider | Default constructor.
CXTPCalendarDatabaseDataProvider Data Members
CXTPCalendarDatabaseDataProvider Data Members | Description
m_bTraceOptions | Indicates whether there should be only one record in the options table, or every save should add the new one.
CXTPCalendarDatabaseDataProvider Destructors
CXTPCalendarDatabaseDataProvider Destructors | Description
~CXTPCalendarDatabaseDataProvider | Default Destructor.
CXTPCalendarDatabaseDataProvider Methods
CXTPCalendarDatabaseDataProvider Methods | Description
Close | Call this member function to close the connection to a data source.
Create | Call this member function to create an empty database.
DoCreate_Event | Creates a new event in the database
DoCreate_RPattern | Creates a new recurrence pattern in the database
DoDelete_Event | Deletes an event from the database.
DoDelete_RPattern | Deletes a recurrence pattern from the database
DoGetAllEvents_raw | This method implements Getting all events from the database without generating recurrence occurrences.
DoGetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the database.
DoRead_RPattern | Read recurrence pattern from the database
DoRemoveAllEvents | Remove all events from the database.
DoRetrieveDayEvents | Retrieve day events for a specified day.
DoUpdate_Event | Updates event properties in the database.
DoUpdate_RPattern | Updates a recurrence pattern in the database
Open | Call this member function to initialize a newly constructed Data object.
OpenEx | Call this member function to initialize data provider using existing ADO Connection object.
Save | This method saves data to the database.


CXTPCalendarDatabaseDataProvider Data Members

CXTPCalendarDatabaseDataProvider Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider Data Members
Class

CXTPCalendarDatabaseDataProvider Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bTraceOptions | Indicates whether there should be only one record in the options table, or every save should add the new one.


CXTPCalendarDatabaseDataProvider::m_bTraceOptions Data Member

CXTPCalendarDatabaseDataProvider Data Members, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::m_bTraceOptions Data Member

Indicates whether there should be only one record in the options table, or every save should add the new one.

BOOL m_bTraceOptions;
Group

CXTPCalendarDatabaseDataProvider Data Members


CXTPCalendarDatabaseDataProvider Methods

CXTPCalendarDatabaseDataProvider Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider Methods
Class

CXTPCalendarDatabaseDataProvider Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DoCreate_Event | Creates a new event in the database
DoCreate_RPattern | Creates a new recurrence pattern in the database
DoDelete_Event | Deletes an event from the database.
DoDelete_RPattern | Deletes a recurrence pattern from the database
DoGetAllEvents_raw | This method implements Getting all events from the database without generating recurrence occurrences.
DoGetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the database.
DoRead_RPattern | Read recurrence pattern from the database
DoRemoveAllEvents | Remove all events from the database.
DoRetrieveDayEvents | Retrieve day events for a specified day.
DoUpdate_Event | Updates event properties in the database.
DoUpdate_RPattern | Updates a recurrence pattern in the database
Public Methods
Public Methods
Public Method | Description
Close | Call this member function to close the connection to a data source.
Create | Call this member function to create an empty database.
Open | Call this member function to initialize a newly constructed Data object.
OpenEx | Call this member function to initialize data provider using existing ADO Connection object.
Save | This method saves data to the database.


CXTPCalendarDatabaseDataProvider::Close Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::Close Method

Call this member function to close the connection to a data source.

virtual void Close();
Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::Create Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::Create Method

Call this member function to create an empty database.

virtual BOOL Create();
Returns

TRUE is successful. FALSE otherwise.

Remarks

A database is created with the necessary tables structure. It is opened by default.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoCreate_Event Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoCreate_Event Method

Creates a new event in the database

virtual BOOL DoCreate_Event(
    CXTPCalendarEvent* pEvent,
    DWORD& rdwNewEventID
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.
rdwNewEventID
[out] EventID of a newly created record, it is an auto-generated numeric events table key.

Returns

TRUE if event created successfully, FALSE in case of any error during the process.

Remarks

This method creates and executes a database query which adds a new record to the events table.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoCreate_RPattern Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoCreate_RPattern Method

Creates a new recurrence pattern in the database

virtual BOOL DoCreate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern,
    DWORD& rdwNewPatternID
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object which describes all data fields of a newly created record.
rdwNewPatternID
[out] ID of a newly created record, it is an auto-generated numeric table key.

Returns

TRUE if recurrence pattern created successfully, FALSE in case of any error during the process.

Remarks

This method creates and executes a database query which adds a new record to the recurrence patterns table.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoDelete_Event Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoDelete_Event Method

Deletes an event from the database.

virtual BOOL DoDelete_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event deleted successfully, FALSE in case of any errors during the process.

Remarks

This method creates and executes a database query which deletes a corresponding database record.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoDelete_RPattern Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoDelete_RPattern Method

Deletes a recurrence pattern from the database

virtual BOOL DoDelete_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object which should be deleted.

Returns

TRUE if recurrence pattern deleted successfully, FALSE in case of any error during the process.

Remarks

This method creates and executes a database query which deletes a corresponding record from the recurrence patterns table.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoGetAllEvents_raw Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoGetAllEvents_raw Method

This method implements Getting all events from the database without generating recurrence occurrences.

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
Returns

A CXTPCalendarEvents pointer containing a collection of all events.

Remarks

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated.

See Also

GetAllEvents_raw()

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoGetUpcomingEvents Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoGetUpcomingEvents Method

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(
    COleDateTime dtFrom,
    COleDateTimeSpan spPeriod
);
Parameters

dtFrom
Start date and time of a specified period.
spPeriod
A duration of a specified period.

Returns

A CXTPCalendarEvents pointer containing a collection of upcoming events.

Remarks

This method creates and executes a database query which returns a collection of upcoming events. It is used by a reminders manager.

See Also

CXTPCalendarRemindersManager overview

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoRead_Event Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoRead_Event Method

Read event from the database.

virtual CXTPCalendarEventPtr DoRead_Event(
    DWORD dwEventID
);
Parameters

dwEventID
Event ID of the read target.

Returns

A pointer to the new CXTPCalendarEvent object which fields contains a data from the database.

Remarks

This method creates and executes a database query which retrieves all data for a specified event.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoRead_RPattern Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoRead_RPattern Method

Read recurrence pattern from the database

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(
    DWORD dwPatternID
);
Parameters

dwPatternID
Pattern ID of the read target.

Returns

A pointer to the created CXTPCalendarRecurrencePattern object.

Remarks

This method creates and executes a database query which retrieves all data for a specified recurrence pattern.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoRemoveAllEvents Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoRemoveAllEvents Method

Remove all events from the database.

virtual void DoRemoveAllEvents();
Remarks

This method creates and executes a database query which removes all appointments from the database.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoRetrieveDayEvents Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoRetrieveDayEvents Method

Retrieve day events for a specified day.

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(
    COleDateTime dtDay
);
Parameters

dtDay
A specified day.

Returns

A collection of events for a specified day.

Remarks

This method creates and executes a database query on order to retrieve all appointments for a specified day.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoUpdate_Event Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoUpdate_Event Method

Updates event properties in the database.

virtual BOOL DoUpdate_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event updated successfully, FALSE in case of any errors during the process.

Remarks

This method creates and executes a database query which updates a corresponding database record with properties from the specified event.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::DoUpdate_RPattern Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::DoUpdate_RPattern Method

Updates a recurrence pattern in the database

virtual BOOL DoUpdate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object.

Returns

TRUE if recurrence pattern updated successfully, FALSE in case of any error during the process.

Remarks

This method creates and executes a database query which updates a corresponding record in the recurrence patterns table.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::Open Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::Open Method

Call this member function to initialize a newly constructed Data object.

virtual BOOL Open();
Returns

TRUE is successful. FALSE otherwise.

Remarks

Data object must be created before you call Open.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::OpenEx Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::OpenEx Method

Call this member function to initialize data provider using existing ADO Connection object.

virtual BOOL OpenEx(
    LPDISPATCH pdispADOConnection
);
Parameters

pdispADOConnection
[in] An IDispatch interface of ADO Connection.

Returns

TRUE is successful. FALSE otherwise.

Remarks

Set Connection String as "Provider=ADO;" (or "Provider=Access;") Connection object must be opened before pass to OpenEx. Also calendar data provider do not close ADO Connection on Close method. You have to close it yourself.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider::Save Method

CXTPCalendarDatabaseDataProvider Methods, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::Save Method

This method saves data to the database.

virtual BOOL Save();
Returns

TRUE is successful. FALSE otherwise.

Remarks

Actually, this method just always returns TRUE for the database data provider. The reason is that database data provider always keep consistency of its data and could be closed without saving. The database file would contain the most recent data.

Group

CXTPCalendarDatabaseDataProvider Methods


CXTPCalendarDatabaseDataProvider Constructors

CXTPCalendarDatabaseDataProvider Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider Constructors
Class

CXTPCalendarDatabaseDataProvider Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDatabaseDataProvider | Default constructor.


CXTPCalendarDatabaseDataProvider::CXTPCalendarDatabaseDataProvider Constructor

CXTPCalendarDatabaseDataProvider Constructors, CXTPCalendarDatabaseDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::CXTPCalendarDatabaseDataProvider Constructor

Default constructor.

CXTPCalendarDatabaseDataProvider();
Remarks

Constructs a Data object. To establish a connection to a specified data source and initialize the object the Open() member function must be called immediately after construction.

See Also

Open()

Group

CXTPCalendarDatabaseDataProvider Constructors


CXTPCalendarDatabaseDataProvider Destructors

CXTPCalendarDatabaseDataProvider Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider Destructors
Class

CXTPCalendarDatabaseDataProvider Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarDatabaseDataProvider | Default Destructor.


CXTPCalendarDatabaseDataProvider::~CXTPCalendarDatabaseDataProvider Destructor

CXTPCalendarDatabaseDataProvider Destructors, CXTPCalendarDatabaseDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDatabaseDataProvider::~CXTPCalendarDatabaseDataProvider Destructor

Default Destructor.

virtual ~CXTPCalendarDatabaseDataProvider();
Remarks

Handles all deallocation.

Group

CXTPCalendarDatabaseDataProvider Destructors


CXTPCalendarDayView Class

XTPCalendarDayView.h, Classes, Legend, Members, Topics, CXTPCalendarDayView Data Members, CXTPCalendarDayView Methods, CXTPCalendarDayView Constructors, CXTPCalendarDayView Destructors, CXTPCalendarDayView Nested Types, CXTPCalendarDayView Constructors, CXTPCalendarDayView Data Members, CXTPCalendarDayView Destructors, CXTPCalendarDayView Methods, CXTPCalendarDayView Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView Class

This class implements a specific view portion of the Calendar control - called Day view.

Class Hierarchy

class CXTPCalendarDayView : public CXTPCalendarViewT<CXTPCalendarDayViewDay, XTP_CALENDAR_HITTESTINFO_DAY_VIEW>;
File

XTPCalendarDayView.h

Remarks

The Day view consists of one or more days, placed in a row. Each day is stretched down by a number of fixed time intervals. Each day is represented by a CXTPCalendarDayViewDay class.

The Day view also contains two time scales defining those intervals at the left of the view, which is represented by the CXTPCalendarDayViewTimeScale class. One time scale is the main and is visible by default, second one is the alternative and can be enabled programmatically. Time scale interval can be changed using the SetScaleInterval member function. The content of the view refreshes automatically.

See Also

CXTPCalendarView, CXTPCalendarWeekView, CXTPCalendarMonthView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarDayView Constructors
CXTPCalendarDayView Constructors | Description
CXTPCalendarDayView | Default object constructor.
CXTPCalendarDayView Data Members
CXTPCalendarDayView Data Members | Description
m_nMinColumnWidth | 0 means disabled; -1 use some default width for multiresources only; -N use for multiresources only (internally converted to +N); +N used always (in single and multi resources mode).
m_nScrollOffsetX | Stores horizontal left offset of visible day view part.
CXTPCalendarDayView Destructors
CXTPCalendarDayView Destructors | Description
~CXTPCalendarDayView | Default class destructor.
CXTPCalendarDayView Methods
CXTPCalendarDayView Methods | Description
_EnsureVisibleH | This member function is used to ensure that an event view item is visible.
_EnsureVisibleSelectionH | This member function is used to ensure that an selection is visible.
_EnsureVisibleV | This member function is used to ensure that an event view item is visible.
_GetScrollRectClient | This member function is used to get horizontal scroll area rect.
_GetTimeScaleWith | This member function is used to get time scales area width.
_ScrollV | This member function is used to scroll the content of a view.
AddDay | This member function is used to add a specified date to the dates set showing in the current calendar day view.
AdjustLayout | This member function is used to adjust the view's layout depending on the window's client dimensions and calls.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the window's client dimensions and calls.
AdjustScale2TimeZone | Converts Time Zones from both timescales to the minutes shift of the second time scale in comparison with the first one.
Draw | This member function is used to draw the view content using the specified device context.
Draw2 | This member function is used to draw the view content using the specified device context.
EnsureVisible | This member function is used to ensure that an event view item is visible.
EnsureVisibleH |
GetCellDuration | This member function is used to obtain the current cell duration.
GetCellNumber |
GetCellTime | This member function is used to obtain the time value for the specified cell.
GetCurrentTimeZoneInfo | Get full information about current time zone.
GetDay | Call this member function to obtain the CXTPCalendarDayViewDay object by the day's date.
GetEventDurationMin | This member function is used to return the minimum event duration so that the event is visible in the current view.
GetMinColumnWidth | This member function returns values which interpreted as a minimum column width, where column is a group view object.
GetNeededScrollDirection | This member function is used to determine the scroll direction.
GetRowCount | This member function is used to obtain the total row count on the view.
GetScale2Text | This member function is used to obtain the text label of the alternative time scale.
GetScale2TimeZone | This member function is used to get the time zone information for the alternative time scale.
GetScale2TimeZoneInfo | scale 2
GetScaleInterval | This member function is used to obtain the time scale item interval.
GetScaleText | This member function is used to obtain the text label of the default time scale.
GetScrollBarInfoH | This member function is used to retrieve information about a scroll bar's state.
GetScrollBarInfoV | This member function is used to retrieve information about a scroll bar's state.
GetSelection | This member function is used to obtain the view selection.
GetTimeScale | This member function is used to get main or additional time scale object.
GetTopRow | This member function is used to obtain the top visible row on the view.
GetViewDayDate | Call this member function to get the date of a day view by the day's index.
GetViewType | Call this member function to obtain the view type flag.
GetVisibleRowCount | This member function is used to obtain the visible row count on the view.
HitTestEx | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
IsExpandDown | This member function is used to obtain the Expand Down glyph flag value.
IsExpandUp | This member function is used to obtain the Expand Up glyph flag value.
IsGroupHeaderVisible | This member function is used to determine whether resource group header should be visible.
IsOutOfClientRect | This member function is used to determine if the point is in the drag able rectangle.
IsScale2Visible | This member function is used to obtain the visibility flag of the alternative time scale.
OnDraw | This member function performs all of the drawing logic of the calendar view.
OnKeyDown | This member function is used to process keyboard events.
OnLButtonDown | This member function is used to process left mouse button events.
OnLButtonUp | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to process mouse move events.
ScrollDaysToNext | This member function is used to scroll the view forward a specified number of days.
ScrollDaysToPrev | This member function is used to scroll the view back a specified number of days.
ScrollH | This member function is used to scroll the content of a view.
ScrollToWorkDayBegin | This member function is used to start view from the work day starting time.
ScrollV | This member function is used to scroll the content of a view.
SelectDay | This member function is used to select or un-select the provided day, including all of the day's events.
SetMinColumnWidth | This member function used to set minimum column width, where column is a group view object.
SetMouseOutOfDragArea | This member function is used to change the mouse cursor.
SetScale2Text | This member function is used to set the text label for the alternative time scale.
SetScale2TimeZone | This member function is used to set the time zone information for the alternative time scale.
SetScaleInterval | This member function is used to set the time scale item interval.
SetScaleText | This member function is used to set the text label for the default time scale.
ShowDay | This member function is used to show the specified day in the calendar day view.
ShowDays | This member function is used to show the specified day interval in the calendar day view.
ShowScale2 | This member function is used to Show or hide the alternative time scale.
ShowWorkingDays | This member function is used to show that working week in the calendar day view, which includes the specified day.
StopVertEventScroll | This member function is used to stop vertical scrolling.
VertEventScroll | This member function is used to vertically scroll an event in the current view.
CXTPCalendarDayView Nested Types
CXTPCalendarDayView Nested Types | Description
TBase |


CXTPCalendarDayView Data Members

CXTPCalendarDayView Class, Legend, Protected Data Members
CXTPCalendarDayView Data Members
Class

CXTPCalendarDayView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nMinColumnWidth | 0 means disabled; -1 use some default width for multiresources only; -N use for multiresources only (internally converted to +N); +N used always (in single and multi resources mode).
m_nScrollOffsetX | Stores horizontal left offset of visible day view part.


CXTPCalendarDayView::m_nMinColumnWidth Data Member

CXTPCalendarDayView Data Members, CXTPCalendarDayView Class
CXTPCalendarDayView::m_nMinColumnWidth Data Member

0 means disabled; -1 use some default width for multiresources only; -N use for multiresources only (internally converted to +N); +N used always (in single and multi resources mode).

int m_nMinColumnWidth;
Group

CXTPCalendarDayView Data Members


CXTPCalendarDayView::m_nScrollOffsetX Data Member

CXTPCalendarDayView Data Members, CXTPCalendarDayView Class
CXTPCalendarDayView::m_nScrollOffsetX Data Member

Stores horizontal left offset of visible day view part.

int m_nScrollOffsetX;
Group

CXTPCalendarDayView Data Members


CXTPCalendarDayView Methods

CXTPCalendarDayView Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView Methods
Class

CXTPCalendarDayView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_EnsureVisibleH | This member function is used to ensure that an event view item is visible.
_EnsureVisibleSelectionH | This member function is used to ensure that an selection is visible.
_EnsureVisibleV | This member function is used to ensure that an event view item is visible.
_GetScrollRectClient | This member function is used to get horizontal scroll area rect.
_GetTimeScaleWith | This member function is used to get time scales area width.
_ScrollV | This member function is used to scroll the content of a view.
AdjustScale2TimeZone | Converts Time Zones from both timescales to the minutes shift of the second time scale in comparison with the first one.
GetEventDurationMin | This member function is used to return the minimum event duration so that the event is visible in the current view.
GetNeededScrollDirection | This member function is used to determine the scroll direction.
IsOutOfClientRect | This member function is used to determine if the point is in the drag able rectangle.
SelectDay | This member function is used to select or un-select the provided day, including all of the day's events.
SetMouseOutOfDragArea | This member function is used to change the mouse cursor.
StopVertEventScroll | This member function is used to stop vertical scrolling.
VertEventScroll | This member function is used to vertically scroll an event in the current view.
Public Methods
Public Methods
Public Method | Description
AddDay | This member function is used to add a specified date to the dates set showing in the current calendar day view.
AdjustLayout | This member function is used to adjust the view's layout depending on the window's client dimensions and calls.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the window's client dimensions and calls.
Draw | This member function is used to draw the view content using the specified device context.
Draw2 | This member function is used to draw the view content using the specified device context.
EnsureVisible | This member function is used to ensure that an event view item is visible.
EnsureVisibleH |
GetCellDuration | This member function is used to obtain the current cell duration.
GetCellNumber |
GetCellTime | This member function is used to obtain the time value for the specified cell.
GetCurrentTimeZoneInfo | Get full information about current time zone.
GetDay | Call this member function to obtain the CXTPCalendarDayViewDay object by the day's date.
GetMinColumnWidth | This member function returns values which interpreted as a minimum column width, where column is a group view object.
GetRowCount | This member function is used to obtain the total row count on the view.
GetScale2Text | This member function is used to obtain the text label of the alternative time scale.
GetScale2TimeZone | This member function is used to get the time zone information for the alternative time scale.
GetScale2TimeZoneInfo | scale 2
GetScaleInterval | This member function is used to obtain the time scale item interval.
GetScaleText | This member function is used to obtain the text label of the default time scale.
GetScrollBarInfoH | This member function is used to retrieve information about a scroll bar's state.
GetScrollBarInfoV | This member function is used to retrieve information about a scroll bar's state.
GetSelection | This member function is used to obtain the view selection.
GetTimeScale | This member function is used to get main or additional time scale object.
GetTopRow | This member function is used to obtain the top visible row on the view.
GetViewDayDate | Call this member function to get the date of a day view by the day's index.
GetViewType | Call this member function to obtain the view type flag.
GetVisibleRowCount | This member function is used to obtain the visible row count on the view.
HitTestEx | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
IsExpandDown | This member function is used to obtain the Expand Down glyph flag value.
IsExpandUp | This member function is used to obtain the Expand Up glyph flag value.
IsGroupHeaderVisible | This member function is used to determine whether resource group header should be visible.
IsScale2Visible | This member function is used to obtain the visibility flag of the alternative time scale.
OnDraw | This member function performs all of the drawing logic of the calendar view.
OnKeyDown | This member function is used to process keyboard events.
OnLButtonDown | This member function is used to process left mouse button events.
OnLButtonUp | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to process mouse move events.
ScrollDaysToNext | This member function is used to scroll the view forward a specified number of days.
ScrollDaysToPrev | This member function is used to scroll the view back a specified number of days.
ScrollH | This member function is used to scroll the content of a view.
ScrollToWorkDayBegin | This member function is used to start view from the work day starting time.
ScrollV | This member function is used to scroll the content of a view.
SetMinColumnWidth | This member function used to set minimum column width, where column is a group view object.
SetScale2Text | This member function is used to set the text label for the alternative time scale.
SetScale2TimeZone | This member function is used to set the time zone information for the alternative time scale.
SetScaleInterval | This member function is used to set the time scale item interval.
SetScaleText | This member function is used to set the text label for the default time scale.
ShowDay | This member function is used to show the specified day in the calendar day view.
ShowDays | This member function is used to show the specified day interval in the calendar day view.
ShowScale2 | This member function is used to Show or hide the alternative time scale.
ShowWorkingDays | This member function is used to show that working week in the calendar day view, which includes the specified day.


CXTPCalendarDayView::_EnsureVisibleSelectionH Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::_EnsureVisibleSelectionH Method

This member function is used to ensure that an selection is visible.

BOOL _EnsureVisibleSelectionH();
Returns

Returns TRUE if the system scrolled the day view, otherwise FALSE.

Remarks

If necessary, the function scrolls the day view horizontally so that the selection is visible.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::_GetScrollRectClient Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::_GetScrollRectClient Method

This member function is used to get horizontal scroll area rect.

CRect _GetScrollRectClient();
Returns

Horizontal scroll area rect.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::_GetTimeScaleWith Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::_GetTimeScaleWith Method

This member function is used to get time scales area width.

int _GetTimeScaleWith();
Returns

Time scales area width in pixels.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::_ScrollV Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::_ScrollV Method

This member function is used to scroll the content of a view.

virtual void _ScrollV(
    int nIndex,
    int nPos_raw
);
Parameters

nIndex
Position value.
nPos_raw
Raw position value. (Not used at this time.)

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::AddDay Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::AddDay Method

This member function is used to add a specified date to the dates set showing in the current calendar day view.

virtual void AddDay(
    const COleDateTime& date
);
Parameters

date
A COleDateTime object that contains the date to display.

Remarks

Call this member function to display a specific day in the calendar day view in addition to the days already visible.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::AdjustLayout Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::AdjustLayout Method

This member function is used to adjust the view's layout depending on the window's client dimensions and calls.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcView,
    BOOL bCallPostAdjustLayout = TRUE
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcView,
    BOOL bCallPostAdjustLayout = TRUE
);
Parameters

pDC
Pointer to a valid device context.
rcView
A CRect that contains the bounding rectangle dimensions of the view.
bCallPostAdjustLayout
TRUE for calling additional post-adjustments

Remarks

Call Populate() prior adjusting layout. Adjust layout of all sub-items. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::AdjustScale2TimeZone Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::AdjustScale2TimeZone Method

Converts Time Zones from both timescales to the minutes shift of the second time scale in comparison with the first one.

virtual void AdjustScale2TimeZone();
See Also

CXTPCalendarViewDay, SelectDay(COleDateTime dtSelDay, BOOL bSelect)

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::Draw Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::Draw Method

This member function is used to draw the view content using the specified device context.

virtual void Draw(
    CDC* pDC
);
virtual void Draw2(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

Call AdjustLayout() before Draw() Draw2 is called by calendar control instead of Draw when theme is set.

See Also

AdjustLayout

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::EnsureVisible Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::EnsureVisible Method

This member function is used to ensure that an event view item is visible.

virtual BOOL EnsureVisible(
    CXTPCalendarViewEvent* pViewEvent
);
virtual BOOL EnsureVisibleH(
    CXTPCalendarViewEvent* pViewEvent
);
virtual BOOL EnsureVisibleH(
    CXTPCalendarViewGroup* pViewGroup
);
BOOL _EnsureVisibleH(
    CXTPCalendarViewEvent* pViewEvent
);
BOOL _EnsureVisibleV(
    CXTPCalendarViewEvent* pViewEvent
);
Parameters

pViewEvent
A CXTPCalendarViewEvent object. A pointer to the event view item being made visible.
pViewGroup
A CXTPCalendarViewGroup object. A pointer to the group view being made visible.

Returns

Returns TRUE if the system scrolled the day view in the Calendar control to ensure that the specified event view item is visible. Otherwise, the return value is FALSE.

Remarks

If necessary, the function scrolls the day view so that the event view item is visible.

Group

CXTPCalendarDayView Methods


EnsureVisibleH Method

CXTPCalendarDayView Methods
EnsureVisibleH Method
Overload List
Methods
Method | Description
CXTPCalendarDayView::EnsureVisibleH (CXTPCalendarViewEvent*) | This member function is used to ensure that an event view item is visible.
CXTPCalendarDayView::EnsureVisibleH (CXTPCalendarViewGroup*) | This member function is used to ensure that an event view item is visible.
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetCellDuration Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetCellDuration Method

This member function is used to obtain the current cell duration.

COleDateTimeSpan GetCellDuration() const;
Returns

A COleDateTimeSpan object that contains the amount of time between a cell's start coordinates and the next cell's starting coordinates.

Group

CXTPCalendarDayView Methods


GetCellNumber Method

CXTPCalendarDayView Methods
GetCellNumber Method
Overload List
Methods
Method | Description
CXTPCalendarDayView::GetCellNumber (COleDateTime, BOOL) | This member function is used to calculate the cell number for the specified time value.
CXTPCalendarDayView::GetCellNumber (int, int, int, BOOL) | This member function is used to calculate the cell number for the specified time value.
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetCellNumber Method (COleDateTime, BOOL)

GetCellNumber Method, CXTPCalendarDayView Class
CXTPCalendarDayView::GetCellNumber Method (COleDateTime, BOOL)

This member function is used to calculate the cell number for the specified time value.

int GetCellNumber(
    COleDateTime dtTime,
    BOOL bForEndTime
) const;
Parameters

dtTime
A COleDateTime object that contains a time value to check for.
bForEndTime
A BOOL that contains the value that indicates if we should consider a split line between cells to belong to the end of the previous cell or to the beginning of the next cell.

Returns

Call this member function when you want to retrieve which cell contains a specified time value.

Group

GetCellNumber Method


CXTPCalendarDayView::GetCellNumber Method (int, int, int, BOOL)

GetCellNumber Method, CXTPCalendarDayView Class
CXTPCalendarDayView::GetCellNumber Method (int, int, int, BOOL)

This member function is used to calculate the cell number for the specified time value.

int GetCellNumber(
    int nHour,
    int nMin,
    int nSec,
    BOOL bForEndTime
) const;
Parameters

nHour
An int that contains the hour part of the time value to check for.
nMin
An int that contains the minute part of the time value to check for.
nSec
An int that contains the second part of the time value to check for.
bForEndTime
A BOOL that contains the value that indicates if we should consider a split line between cells to belong to the end of the previous cell or to the beginning of the next cell.

Returns

Call this member function when you want to retrieve which cell contains a specified time value.

Group

GetCellNumber Method


CXTPCalendarDayView::GetCellTime Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetCellTime Method

This member function is used to obtain the time value for the specified cell.

COleDateTime GetCellTime(
    int nCell
) const;
Parameters

nCell
An int that contains a cell number.

Returns

A COleDateTime object that contains the specific time value for the cell's beginning coordinate.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetCurrentTimeZoneInfo Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetCurrentTimeZoneInfo Method

Get full information about current time zone.

CXTPCalendarTimeZonePtr GetCurrentTimeZoneInfo();
Returns

A smart pointer to CXTPCalendarTimeZone object.

Remarks

Retrieve additional information from the registry.

See Also

GetTimeZoneInformation(), CXTPCalendarTimeZone::GetTimeZoneInfo()

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetDay Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetDay Method

Call this member function to obtain the CXTPCalendarDayViewDay object by the day's date.

virtual CXTPCalendarDayViewDay* GetDay(
    COleDateTime dtDay
);
Parameters

dtDay
A day date to find.

Returns

A pointer to a CXTPCalendarViewDay object.

Remarks

Returns NULL if no day with the specified date in the days collection.

See Also

GetViewDayCount(), GetViewDay_, GetViewDay

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetEventDurationMin Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetEventDurationMin Method

This member function is used to return the minimum event duration so that the event is visible in the current view.

virtual COleDateTimeSpan GetEventDurationMin() const;
Returns

A COleDateTimeSpan object that specifies the minimum duration of the event.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetMinColumnWidth Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetMinColumnWidth Method

This member function returns values which interpreted as a minimum column width, where column is a group view object.

virtual int GetMinColumnWidth() const;
Returns

Minimum column width in pixels (may be negative) or 0 or -1.

Remarks

The returned number may be one of the following values: [ul] [li] 0 means disabled; [li] -1 use some default width for multiresources only; [li] -N use for multiresources only (internally converted to +N); [li] +N used always (in single and multi resources mode). [/ul]

See Also

SetMinColumnWidth

Body Source
int CXTPCalendarDayView::GetMinColumnWidth() const {
    return m_nMinColumnWidth;
}
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetNeededScrollDirection Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetNeededScrollDirection Method

This member function is used to determine the scroll direction.

virtual XTPCalendarDayViewScrollDirection GetNeededScrollDirection(
    CPoint pnt
);
Parameters

pnt
Test mouse point.

Returns

xtpCalendarDayViewScrollUp/xtpCalendarDayViewScrollDown if scrolling up/down is needed. xtpCalendarDayViewScrollNotNeeded if scrolling is not needed.

Remarks

This function returns an XTPCalendarDayViewScrollDirection enumeration which defines the scroll direction.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetRowCount Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetRowCount Method

This member function is used to obtain the total row count on the view.

int GetRowCount() const;
Returns

An int containing the total count of rows on the view.

Body Source
int CXTPCalendarDayView::GetRowCount() const {
    return m_LayoutX.m_nRowCount;
}
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetScale2Text Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetScale2Text Method

This member function is used to obtain the text label of the alternative time scale.

CString GetScale2Text();
Returns

A CString object that contains the alternative time scale text label.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetScale2TimeZone Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetScale2TimeZone Method

This member function is used to get the time zone information for the alternative time scale.

const TIME_ZONE_INFORMATION& GetScale2TimeZone();
Returns

A reference to time zone information structure.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetScale2TimeZoneInfo Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetScale2TimeZoneInfo Method

scale 2

CXTPCalendarTimeZonePtr GetScale2TimeZoneInfo();
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetScaleInterval Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetScaleInterval Method

This member function is used to obtain the time scale item interval.

COleDateTimeSpan GetScaleInterval() const;
Returns

A COleDateTimeSpan object that contains the time interval of the time scale item.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetScaleText Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetScaleText Method

This member function is used to obtain the text label of the default time scale.

CString GetScaleText();
Returns

A CString object that contains the default time scale text label.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetScrollBarInfoV Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetScrollBarInfoV Method

This member function is used to retrieve information about a scroll bar's state.

virtual BOOL GetScrollBarInfoV(
    SCROLLINFO* pSI
);
virtual BOOL GetScrollBarInfoH(
    SCROLLINFO* pSI,
    int* pnScrollStep = NULL
);
Parameters

pSI
A pointer to scrollbar information structure.
pnScrollStep
A pointer to int to receive scroll step. Can be NULL.

Returns

A BOOL. TRUE if the visible row count is not the same as the actual row count. FALSE otherwise.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetSelection Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::GetSelection Method

This member function is used to obtain the view selection.

virtual BOOL GetSelection(
    COleDateTime* pBegin = NULL,
    COleDateTime* pEnd = NULL,
    BOOL* pbAllDayEvent = NULL,
    int* pnGroupIndex = NULL,
    COleDateTimeSpan* pspSelectionResolution = NULL
);
Parameters

pBegin
A pointer to the COleDateTime object that contains the beginning of the selection.
pEnd
A pointer to the COleDateTime object that contains the ending of the selection.
pbAllDayEvent
A pointer to the BOOL variable that contains the AllDayEvent attribute of the selection (used in the day view only).
pnGroupIndex
A pointer to int to receive group index.
pspSelectionResolution
A pointer to the COleDateTimeSpan object that contains the selection unit length. (i.e. 1 day, 1 Hour, ... 5 min)

Returns

TRUE - If the selection is returned successfully. FALSE otherwise.

Remarks

Call this member function to fill provided COleDateTime objects with the values of the selection beginning, ending, and selection unit length.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetTimeScale Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetTimeScale Method

This member function is used to get main or additional time scale object.

virtual CXTPCalendarDayViewTimeScale* GetTimeScale(
    int nNumber = 1
);
Parameters

nNumber
A time scale object number: 1 - main time scale, 2 - additional time scale.

Returns

Pointer to the CXTPCalendarDayViewTimeScale object.

Remarks

By default number 1 (main time scale) is used.

Body Source
CXTPCalendarDayViewTimeScale* CXTPCalendarDayView::GetTimeScale(int nNumber) {
    ASSERT(nNumber == 1 || nNumber == 2);
    return nNumber <= 1 ? m_pTimeScaleHeader : m_pTimeScaleHeader2;
}
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetTopRow Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetTopRow Method

This member function is used to obtain the top visible row on the view.

int GetTopRow() const;
Returns

An int that contains the number of the top visible row on the view.

Body Source
int CXTPCalendarDayView::GetTopRow() const {
    return m_LayoutX.m_nTopRow;
}
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetViewDayDate Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetViewDayDate Method

Call this member function to get the date of a day view by the day's index.

virtual COleDateTime GetViewDayDate(
    int nIndex
);
Parameters

nIndex
Day view index in the view collection.

Returns

COleDateTime object with the day view date and time.

Remarks

Index number starts at 0 and cannot be negative.

See Also

GetViewDayCount()

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetViewType Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetViewType Method

Call this member function to obtain the view type flag.

virtual XTPCalendarViewType GetViewType();
Returns

An XTPCalendarViewType object that contains the view type flag.

See Also

XTPCalendarViewType

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::GetVisibleRowCount Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::GetVisibleRowCount Method

This member function is used to obtain the visible row count on the view.

int GetVisibleRowCount() const;
Returns

An int containing the count of the visible rows on the view.

Body Source
int CXTPCalendarDayView::GetVisibleRowCount() const {
    return m_LayoutX.m_nVisibleRowCount;
}
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::HitTestEx Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::HitTestEx Method

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

virtual BOOL HitTestEx(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO_DAY_VIEW* pHitTest
);
Parameters

pt
Coordinates of point to test.
pHitTest
Pointer to a XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

Returns

TRUE if item found. FALSE otherwise.

See Also

XTP_CALENDAR_HITTESTINFO_DAY_VIEW

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::IsExpandDown Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::IsExpandDown Method

This member function is used to obtain the Expand Down glyph flag value.

BOOL IsExpandDown();
Returns

A BOOL that contains the Expand Down flag value. TRUE - If the Expand Down glyph is visible. FALSE - If the Expand Down glyph is not visible.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::IsExpandUp Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::IsExpandUp Method

This member function is used to obtain the Expand Up glyph flag value.

BOOL IsExpandUp();
Returns

A BOOL that contains the Expand Up glyph flag value. TRUE - If the Expand Up glyph is visible. FALSE - If the Expand Up glyph is not visible.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::IsGroupHeaderVisible Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::IsGroupHeaderVisible Method

This member function is used to determine whether resource group header should be visible.

virtual BOOL IsGroupHeaderVisible();
Returns

TRUE when visible; FALSE otherwise.

Remarks

This method returns FALSE when resource groups count is zero and there is only one schedule used.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::IsOutOfClientRect Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::IsOutOfClientRect Method

This member function is used to determine if the point is in the drag able rectangle.

virtual BOOL IsOutOfClientRect(
    CPoint pnt,
    XTP_CALENDAR_HITTESTINFO_DAY_VIEW * pHitInfo
);
Parameters

pnt
A CPoint object that contains the point to test.
pHitInfo
Pointer to the XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure, which helps to determine the client rectangle.

Returns

TRUE if the point is out of the drag able rectangle, FALSE otherwise.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::IsScale2Visible Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::IsScale2Visible Method

This member function is used to obtain the visibility flag of the alternative time scale.

BOOL IsScale2Visible();
Returns

A BOOL that contains the visibility flag value. TRUE - If the alternative time scale is visible. FALSE - If the alternative time scale is not visible.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::OnDraw Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::OnDraw Method

This member function performs all of the drawing logic of the calendar view.

virtual void OnDraw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::OnKeyDown Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::OnKeyDown Method

This member function is used to process keyboard events.

virtual void OnKeyDown(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
Virtual key code of the given key.
nRepCnt
Number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
Scan code, key-transition code, previous key state, and context code.

Remarks

This method is called by the CalendarControl when the user presses keys on the keyboard.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::OnLButtonDown Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::OnLButtonDown Method

This member function is used to process left mouse button events.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down.
point
Specifies the x- and y- coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user presses the left mouse button.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::OnLButtonUp Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::OnLButtonUp Method

This member function is used to processes left mouse button events.

virtual BOOL OnLButtonUp(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user releases the left mouse button.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::OnMouseMove Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::OnMouseMove Method

This member function is used to process mouse move events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
Indicates whether various virtual keys are down.
point
Specifies the x- and y- coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ScrollDaysToNext Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::ScrollDaysToNext Method

This member function is used to scroll the view forward a specified number of days.

virtual void ScrollDaysToNext(
    int nScrollDaysCount = 1
);
Parameters

nScrollDaysCount
An int that is used to specify the number of days to scroll.

Remarks

Call this member function to switch the number of days forward from the current date.

See Also

ScrollDaysToPrev

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ScrollDaysToPrev Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::ScrollDaysToPrev Method

This member function is used to scroll the view back a specified number of days.

virtual void ScrollDaysToPrev(
    int nScrollDaysCount = 1
);
Parameters

nScrollDaysCount
An int that is used to specify the number of days to scroll.

Remarks

Call this member function when you want to switch the number of days back from the current day.

See Also

ScrollDaysToNext

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ScrollH Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::ScrollH Method

This member function is used to scroll the content of a view.

virtual void ScrollH(
    int nPos,
    int nPos_raw
);
Parameters

nPos
Position value.
nPos_raw
Raw position value. (Not used at this time.)

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ScrollToWorkDayBegin Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::ScrollToWorkDayBegin Method

This member function is used to start view from the work day starting time.

virtual void ScrollToWorkDayBegin();
Remarks

Call this method after set new data provider because new data provider store other time scale resolution value.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ScrollV Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::ScrollV Method

This member function is used to scroll the content of a view.

virtual void ScrollV(
    int nPos,
    int nPos_raw
);
Parameters

nPos
Position value.
nPos_raw
Raw position value. (Not used at this time.)

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::SelectDay Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::SelectDay Method

This member function is used to select or un-select the provided day, including all of the day's events.

virtual void SelectDay(
    CXTPCalendarViewDay* pDay
);
Parameters

pDay
A pointer to a CXTPCalendarViewDay object.

See Also

CXTPCalendarViewDay, SelectDay(COleDateTime dtSelDay, BOOL bSelect)

Body Source
void CXTPCalendarDayView::SelectDay(CXTPCalendarViewDay* /*pDay*/) {
    // Do nothing for day view.
}
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::SetMinColumnWidth Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::SetMinColumnWidth Method

This member function used to set minimum column width, where column is a group view object.

virtual void SetMinColumnWidth(
    int nWidth
);
Parameters

nWidth
[in] Minimum column width in pixels (may be negative) or 0 or -1. See remarks section.

Remarks

nWidth number may be one of the following values: [ul] [li] 0 means disabled; [li] -1 use some default width for multiresources only; [li] -N use for multiresources only (internally converted to +N); [li] +N used always (in single and multi resources mode). [/ul]

See Also

GetMinColumnWidth

Body Source
void CXTPCalendarDayView::SetMinColumnWidth(int nWidth) {
    m_nMinColumnWidth = nWidth;
}
Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::SetMouseOutOfDragArea Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::SetMouseOutOfDragArea Method

This member function is used to change the mouse cursor.

virtual void SetMouseOutOfDragArea(
    BOOL bOutOfArea
);
Parameters

bOutOfArea
TRUE means out (FALSE - inside) of drag area.

Remarks

Call this member function to changes the mouse cursor depending on which drag mode is currently active. Note: The drag mode is contained in the XTPCalendarDraggingMode m_eDraggingMode member variable.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::SetScale2Text Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::SetScale2Text Method

This member function is used to set the text label for the alternative time scale.

void SetScale2Text(
    LPCTSTR strText
);
Parameters

strText
A CString that contains the new text label.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::SetScale2TimeZone Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::SetScale2TimeZone Method

This member function is used to set the time zone information for the alternative time scale.

void SetScale2TimeZone(
    const TIME_ZONE_INFORMATION* pTzInfo
);
Parameters

pTzInfo
A pointer to time zone information structure.

See Also

MSDN Articles: INFO: Retrieving Time-Zone Information KB115231, Q115231

HOWTO: Change Time Zone Information Using Visual Basic KB221542, Q221542

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::SetScaleInterval Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::SetScaleInterval Method

This member function is used to set the time scale item interval.

void SetScaleInterval(
    const COleDateTimeSpan spScaleInterval
);
Parameters

spScaleInterval
A COleDateTimeSpan object that contains the new time scale item interval.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::SetScaleText Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::SetScaleText Method

This member function is used to set the text label for the default time scale.

void SetScaleText(
    LPCTSTR strText
);
Parameters

strText
A CString that contains the new text label for the default time label.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ShowDay Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::ShowDay Method

This member function is used to show the specified day in the calendar day view.

virtual void ShowDay(
    const COleDateTime& date,
    BOOL bSelect = TRUE
);
Parameters

date
A COleDateTime object that contains the date to show.
bSelect
TRUE to select the specified day after showing, FALSE otherwise. TRUE is the default value.

Remarks

Call this member function to show only the specified day in the calendar day view.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ShowDays Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::ShowDays Method

This member function is used to show the specified day interval in the calendar day view.

virtual void ShowDays(
    const COleDateTime& dtBegin,
    const COleDateTime& dtEnd
);
Parameters

dtBegin
A COleDateTime object that contains the beginning interval date to show.
dtEnd
A COleDateTime object that contains the ending interval date to show.

Remarks

Call this member function to show all days from the dtBegin up to dtEnd inclusive.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ShowScale2 Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::ShowScale2 Method

This member function is used to Show or hide the alternative time scale.

void ShowScale2(
    BOOL bShow = TRUE
);
Parameters

bShow
A BOOL that contains the new visibility flag value.
TRUE
Default value, shows the alternative time scale.
FALSE
Do not show the default value.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::ShowWorkingDays Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::ShowWorkingDays Method

This member function is used to show that working week in the calendar day view, which includes the specified day.

virtual void ShowWorkingDays(
    const COleDateTime& dtDay
);
Parameters

dtDay
A COleDateTime object that contains the date to show.

Remarks

Call this member function to show working week which includes dtDay.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::StopVertEventScroll Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::StopVertEventScroll Method

This member function is used to stop vertical scrolling.

virtual void StopVertEventScroll();
Remarks

If there is a vertical scroll event in process, then calling this member function stops the vertical scrolling.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView::VertEventScroll Method

CXTPCalendarDayView Methods, CXTPCalendarDayView Class
CXTPCalendarDayView::VertEventScroll Method

This member function is used to vertically scroll an event in the current view.

virtual BOOL VertEventScroll(
    BOOL bUp
);
Parameters

bUp
A BOOL that contains the direction to scroll: TRUE if up. FALSE if down.

Returns

TRUE, if scrolled successfully. FALSE otherwise.

Group

CXTPCalendarDayView Methods


CXTPCalendarDayView Constructors

CXTPCalendarDayView Class, Legend, Public Methods
CXTPCalendarDayView Constructors
Class

CXTPCalendarDayView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayView | Default object constructor.


CXTPCalendarDayView::CXTPCalendarDayView Constructor

CXTPCalendarDayView Constructors, CXTPCalendarDayView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayView::CXTPCalendarDayView Constructor

Default object constructor.

CXTPCalendarDayView(
    CXTPCalendarControl* pCalendarControl
);
Parameters

pCalendarControl
Pointer to CXTPCalendarControl object.

See Also

~CXTPCalendarEvent()

Group

CXTPCalendarDayView Constructors


CXTPCalendarDayView Destructors

CXTPCalendarDayView Class, Legend, Public Methods
CXTPCalendarDayView Destructors
Class

CXTPCalendarDayView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarDayView | Default class destructor.


CXTPCalendarDayView::~CXTPCalendarDayView Destructor

CXTPCalendarDayView Destructors, CXTPCalendarDayView Class
CXTPCalendarDayView::~CXTPCalendarDayView Destructor

Default class destructor.

virtual ~CXTPCalendarDayView();
Remarks

Handles class members deallocation.

Group

CXTPCalendarDayView Destructors


CXTPCalendarDayView Nested Types

CXTPCalendarDayView Class, Public Nested Types
CXTPCalendarDayView Nested Types
Class

CXTPCalendarDayView Class

Public Nested Types
Public Nested Type | Description
TBase |


CXTPCalendarDayView::TBase Nested Type

CXTPCalendarDayView Nested Types, CXTPCalendarDayView Class
CXTPCalendarDayView::TBase Nested Type
typedef CXTPCalendarViewT< CXTPCalendarDayViewDay, XTP_CALENDAR_HITTESTINFO_DAY_VIEW> TBase;
Remarks

Base class type definition

Group

CXTPCalendarDayView Nested Types


CXTPCalendarDayViewDay Class

XTPCalendarDayViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarDayViewDay Methods, CXTPCalendarDayViewDay Constructors, CXTPCalendarDayViewDay Destructors, CXTPCalendarDayViewDay Nested Types, CXTPCalendarDayViewDay Constructors, CXTPCalendarDayViewDay Destructors, CXTPCalendarDayViewDay Methods, CXTPCalendarDayViewDay Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewDay Class

This class represents a day view portion of the Calendar Day View.

Class Hierarchy

class CXTPCalendarDayViewDay : public CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO_DAY_VIEW, CXTPCalendarDayViewDay >;
File

XTPCalendarDayViewDay.h

Remarks

It represents a specific view of the CalendarView's associated events data grouped by one day and provides basic functionality on this data using user input through keyboard and mouse.

CXTPCalendarDayViewDay is based on CXTPCalendarViewDayT template class. It inherits basic behavior from its and overlaps and add some to get its own behavior and look.

See Also

CXTPCalendarViewDay, CXTPCalendarViewDayT

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarDayViewDay Constructors
CXTPCalendarDayViewDay Constructors | Description
CXTPCalendarDayViewDay | Default object constructor.
CXTPCalendarDayViewDay Destructors
CXTPCalendarDayViewDay Destructors | Description
~CXTPCalendarDayViewDay | Default class destructor.
CXTPCalendarDayViewDay Methods
CXTPCalendarDayViewDay Methods | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.
Draw | This member function is used to draw the view content utilizing the specified device context.
FillHitTestEx | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
GetCaption | This member function is used to obtain a single day's view caption.
OnMouseMove | This member function is used to processes mouse movement events.
Populate | This member function is used to populate the view with data for all items contained in the view.
CXTPCalendarDayViewDay Nested Types
CXTPCalendarDayViewDay Nested Types | Description
TBase | Base class type definition.


CXTPCalendarDayViewDay Methods

CXTPCalendarDayViewDay Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewDay Methods
Class

CXTPCalendarDayViewDay Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnMouseMove | This member function is used to processes mouse movement events.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.
Draw | This member function is used to draw the view content utilizing the specified device context.
FillHitTestEx | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
GetCaption | This member function is used to obtain a single day's view caption.
Populate | This member function is used to populate the view with data for all items contained in the view.


CXTPCalendarDayViewDay::AdjustLayout Method

CXTPCalendarDayViewDay Methods, CXTPCalendarDayViewDay Class
CXTPCalendarDayViewDay::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcDay
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcDay
);
Parameters

pDC
Pointer to a valid device context.
rcDay
A CRect object containing the dimensions of the bounding rectangle for the control.

Remarks

AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarDayViewDay Methods


CXTPCalendarDayViewDay::Draw Method

CXTPCalendarDayViewDay Methods, CXTPCalendarDayViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewDay::Draw Method

This member function is used to draw the view content utilizing the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

Call AdjustLayout() before Draw()

See Also

AdjustLayout(CRect rcDay)

Group

CXTPCalendarDayViewDay Methods


CXTPCalendarDayViewDay::FillHitTestEx Method

CXTPCalendarDayViewDay Methods, CXTPCalendarDayViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewDay::FillHitTestEx Method

This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

virtual void FillHitTestEx(
    XTP_CALENDAR_HITTESTINFO_DAY_VIEW* pInfo
);
Parameters

pInfo
A pointer to an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

Remarks

Call this member function to gather hit test information from the day view.

See Also

XTP_CALENDAR_HITTESTINFO_DAY_VIEW

Group

CXTPCalendarDayViewDay Methods


CXTPCalendarDayViewDay::GetCaption Method

CXTPCalendarDayViewDay Methods, CXTPCalendarDayViewDay Class
CXTPCalendarDayViewDay::GetCaption Method

This member function is used to obtain a single day's view caption.

virtual CString GetCaption();
Returns

A CString object that contains the day's view caption.

Group

CXTPCalendarDayViewDay Methods


CXTPCalendarDayViewDay::OnMouseMove Method

CXTPCalendarDayViewDay Methods, CXTPCalendarDayViewDay Class
CXTPCalendarDayViewDay::OnMouseMove Method

This member function is used to processes mouse movement events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Group

CXTPCalendarDayViewDay Methods


CXTPCalendarDayViewDay::Populate Method

CXTPCalendarDayViewDay Methods, CXTPCalendarDayViewDay Class
CXTPCalendarDayViewDay::Populate Method

This member function is used to populate the view with data for all items contained in the view.

virtual void Populate(
    COleDateTime dtDayDate
);
Parameters

dtDayDate
A COleDateTime object that contains the day's date.

Group

CXTPCalendarDayViewDay Methods


CXTPCalendarDayViewDay Constructors

CXTPCalendarDayViewDay Class, Legend, Public Methods
CXTPCalendarDayViewDay Constructors
Class

CXTPCalendarDayViewDay Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayViewDay | Default object constructor.


CXTPCalendarDayViewDay::CXTPCalendarDayViewDay Constructor

CXTPCalendarDayViewDay Constructors, CXTPCalendarDayViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewDay::CXTPCalendarDayViewDay Constructor

Default object constructor.

CXTPCalendarDayViewDay(
    CXTPCalendarDayView* pDayView,
    COleDateTime dtDate
);
Parameters

pDayView
Pointer to parent CXTPCalendarDayView object.
dtDate
A date for which the day view is created.

Remarks

Construct CXTPCalendarDayViewDay object.

See Also

~CXTPCalendarDayViewDay()

Group

CXTPCalendarDayViewDay Constructors


CXTPCalendarDayViewDay Destructors

CXTPCalendarDayViewDay Class, Legend, Public Methods
CXTPCalendarDayViewDay Destructors
Class

CXTPCalendarDayViewDay Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarDayViewDay | Default class destructor.


CXTPCalendarDayViewDay::~CXTPCalendarDayViewDay Destructor

CXTPCalendarDayViewDay Destructors, CXTPCalendarDayViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewDay::~CXTPCalendarDayViewDay Destructor

Default class destructor.

virtual ~CXTPCalendarDayViewDay();
Remarks

Handles member items deallocation.

Group

CXTPCalendarDayViewDay Destructors


CXTPCalendarDayViewDay Nested Types

CXTPCalendarDayViewDay Class, Public Nested Types
CXTPCalendarDayViewDay Nested Types
Class

CXTPCalendarDayViewDay Class

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition.


CXTPCalendarDayViewDay::TBase Nested Type

CXTPCalendarDayViewDay Nested Types, CXTPCalendarDayViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewDay::TBase Nested Type

Base class type definition.

typedef CXTPCalendarViewDayT<CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO_DAY_VIEW, CXTPCalendarDayViewDay > TBase;
Group

CXTPCalendarDayViewDay Nested Types


CXTPCalendarDayViewEvent Class

XTPCalendarDayViewEvent.h, Classes, Legend, Members, Topics, CXTPCalendarDayViewEvent Data Members, CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Constructors, CXTPCalendarDayViewEvent Destructors, CXTPCalendarDayViewEvent Nested Types, CXTPCalendarDayViewEvent Constructors, CXTPCalendarDayViewEvent Data Members, CXTPCalendarDayViewEvent Destructors, CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent Class

This class represents an event view portion of the CalendarDayViewDay.

Class Hierarchy

class CXTPCalendarDayViewEvent : public CXTPCalendarViewEventT< CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO_DAY_VIEW >;
File

XTPCalendarDayViewEvent.h

Remarks

This class is used to represent a specific view of the event associated data according to various view types and display settings. This class also provides basic functionality on the data by using user input through the keyboard and mouse.

CXTPCalendarDayViewEvent is based on CXTPCalendarDayEventT template class. It inherits basic behavior from CXTPCalendarDayEventT template class. Furthermore, CXTPCalendarDayViewEvent overlaps and adds some new functionality to get its own behavior and appearance.

See Also

CXTPCalendarViewEvent, CXTPCalendarViewEventT

Group

Classes

Legend
Data Member
Method
virtual
protected
CXTPCalendarDayViewEvent Constructors
CXTPCalendarDayViewEvent Constructors | Description
CXTPCalendarDayViewEvent | Default object constructor.
CXTPCalendarDayViewEvent Data Members
CXTPCalendarDayViewEvent Data Members | Description
m_bHideEventTime | Flag determines if event time should not be displayed.
m_rcTimeframe | Rectangle area to display times.
CXTPCalendarDayViewEvent Destructors
CXTPCalendarDayViewEvent Destructors | Description
~CXTPCalendarDayViewEvent | Default class destructor.
CXTPCalendarDayViewEvent Methods
CXTPCalendarDayViewEvent Methods | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
AdjustSubjectEditor | This member function is used to perform adjustments of the subject editor area.
AdjustSubjectEditorEx | This member function is used to perform adjustments of the subject editor area. Inputs bUpdateView - A BOOL. TRUE if event view update is required.
ChangeEventPlace | This function is used to change the event place number.
Draw | This member function is used to draw the view content using the specified device context.
GetEventPlaceCount | This member function is used to obtain the count of the event view positions.
GetEventPlacePos | This member function is used to obtain the event's view position identifier.
GetEventsRect | This member function is used to obtain the event's bounding rectangle.
GetSubjectEditorFont | This member function is used to obtain the editor window font.
GetSubjectEditorStyles | This member function is used to obtain the styles of the editor window.
GetTimeframeRect | This member function is used to obtain timeframe's bounding rectangle.
HideEventTime | This member function is used to determine if the event time should not be displayed.
HitTestEx | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
IsMultidayEvent | Call this member function to determine if an event is "Multi Day".
IsVisible | This member function is used to determine if the event is visible.
IsVisibleEx | This member function is used to obtain the value of the visibility flag.
OnPostAdjustLayout | This member function is used to perform additional adjustments in some kinds of views.
SetEventPlaceCount | This member function is used to set the event view places count.
SetEventPlacePos | This member function is used to set the event view place identifier.
StartEditSubject | This member function is used to create and show the subject editor.
CXTPCalendarDayViewEvent Nested Types
CXTPCalendarDayViewEvent Nested Types | Description
TBase |


CXTPCalendarDayViewEvent Data Members

CXTPCalendarDayViewEvent Class, Legend, Public Data Members
CXTPCalendarDayViewEvent Data Members
Class

CXTPCalendarDayViewEvent Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bHideEventTime | Flag determines if event time should not be displayed.
m_rcTimeframe | Rectangle area to display times.


CXTPCalendarDayViewEvent::m_bHideEventTime Data Member

CXTPCalendarDayViewEvent Data Members, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::m_bHideEventTime Data Member

Flag determines if event time should not be displayed.

BOOL m_bHideEventTime;
Group

CXTPCalendarDayViewEvent Data Members


CXTPCalendarDayViewEvent::m_rcTimeframe Data Member

CXTPCalendarDayViewEvent Data Members, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::m_rcTimeframe Data Member

Rectangle area to display times.

CRect m_rcTimeframe;
Group

CXTPCalendarDayViewEvent Data Members


CXTPCalendarDayViewEvent Methods

CXTPCalendarDayViewEvent Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent Methods
Class

CXTPCalendarDayViewEvent Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
ChangeEventPlace | This function is used to change the event place number.
GetSubjectEditorFont | This member function is used to obtain the editor window font.
GetSubjectEditorStyles | This member function is used to obtain the styles of the editor window.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
AdjustSubjectEditor | This member function is used to perform adjustments of the subject editor area.
AdjustSubjectEditorEx | This member function is used to perform adjustments of the subject editor area. Inputs bUpdateView - A BOOL. TRUE if event view update is required.
Draw | This member function is used to draw the view content using the specified device context.
GetEventPlaceCount | This member function is used to obtain the count of the event view positions.
GetEventPlacePos | This member function is used to obtain the event's view position identifier.
GetEventsRect | This member function is used to obtain the event's bounding rectangle.
GetTimeframeRect | This member function is used to obtain timeframe's bounding rectangle.
HideEventTime | This member function is used to determine if the event time should not be displayed.
HitTestEx | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
IsMultidayEvent | Call this member function to determine if an event is "Multi Day".
IsVisible | This member function is used to determine if the event is visible.
IsVisibleEx | This member function is used to obtain the value of the visibility flag.
OnPostAdjustLayout | This member function is used to perform additional adjustments in some kinds of views.
SetEventPlaceCount | This member function is used to set the event view places count.
SetEventPlacePos | This member function is used to set the event view place identifier.
StartEditSubject | This member function is used to create and show the subject editor.


CXTPCalendarDayViewEvent::AdjustLayout Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcEventMax,
    int nEventPlaceNumber
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcEventMax,
    int nEventPlaceNumber
);
Parameters

pDC
Pointer to a valid device context.
rcEventMax
A CRect object that contains the rectangle dimensions for drawing the view.
nEventPlaceNumber
An int that is used as a sequential place number.

Remarks

Call Populate(COleDateTime dtDayDate) prior to adjust layout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::AdjustSubjectEditor Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::AdjustSubjectEditor Method

This member function is used to perform adjustments of the subject editor area.

virtual void AdjustSubjectEditor();
Remarks

Call this member function to perform adjustment of subject editor rectangle.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::AdjustSubjectEditorEx Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::AdjustSubjectEditorEx Method

This member function is used to perform adjustments of the subject editor area. Inputs bUpdateView - A BOOL. TRUE if event view update is required.

virtual void AdjustSubjectEditorEx(
    BOOL bUpdateView
);
Parameters

bUpdateView
TRUE if event view update is required, otherwise FALSE.

Remarks

Call this member function to perform adjustment of subject editor rectangle.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::ChangeEventPlace Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::ChangeEventPlace Method

This function is used to change the event place number.

virtual void ChangeEventPlace(
    int nNewPlace
);
Parameters

nNewPlace
new event place number.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::Draw Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::Draw Method

This member function is used to draw the view content using the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

Call AdjustLayout() before calling Draw().

See Also

AdjustLayout(CRect rcDay)

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::GetEventPlaceCount Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::GetEventPlaceCount Method

This member function is used to obtain the count of the event view positions.

int GetEventPlaceCount();
Returns

An int that contains the number of view positions.

Remarks

Call this member function to count the number of event view positions.

Body Source
int CXTPCalendarDayViewEvent::GetEventPlaceCount() {
    return (int)HIWORD((DWORD)m_nEventPlaceNumber);
}
Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::GetEventPlacePos Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::GetEventPlacePos Method

This member function is used to obtain the event's view position identifier.

int GetEventPlacePos();
Returns

An int that contains the value of the position identifier.

Remarks

The position identifier is a sequential number used to identify the event views.

Body Source
int CXTPCalendarDayViewEvent::GetEventPlacePos() {
    return (int)LOWORD((DWORD)m_nEventPlaceNumber);
}
Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::GetEventsRect Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::GetEventsRect Method

This member function is used to obtain the event's bounding rectangle.

CRect GetEventsRect();
Returns

A CRect object containing the bounding rectangle coordinates.

Remarks

Call this member function to get the event's bounding rectangle coordinates.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::GetSubjectEditorFont Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::GetSubjectEditorFont Method

This member function is used to obtain the editor window font.

virtual CFont* GetSubjectEditorFont();
Returns

Pointer to a CFont object that contains the editor window font.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::GetSubjectEditorStyles Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::GetSubjectEditorStyles Method

This member function is used to obtain the styles of the editor window.

virtual DWORD GetSubjectEditorStyles();
Returns

A DWORD that contains the value of the window styles.

Body Source
DWORD CXTPCalendarDayViewEvent::GetSubjectEditorStyles() {
    if (IsMultidayEvent()) {
        return  TBase::GetSubjectEditorStyles();
    }
    return (ES_NOHIDESEL | ES_MULTILINE | ES_AUTOVSCROLL);
}
Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::GetTimeframeRect Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::GetTimeframeRect Method

This member function is used to obtain timeframe's bounding rectangle.

CRect GetTimeframeRect() const;
Returns

A CRect object containing the bounding rectangle coordinates.

Remarks

Call this member function to get timeframe's bounding rectangle coordinates.

Body Source
CRect CXTPCalendarDayViewEvent::GetTimeframeRect() const {
    return m_rcTimeframe;
}
Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::HideEventTime Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::HideEventTime Method

This member function is used to determine if the event time should not be displayed.

BOOL HideEventTime() const;
Returns

A BOOL that contains the HideExentTime value. TRUE - if event time should not be displayed. Otherwise FALSE.

Body Source
BOOL CXTPCalendarDayViewEvent::HideEventTime() const {
    return m_bHideEventTime;
}
Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::HitTestEx Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::HitTestEx Method

This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

virtual BOOL HitTestEx(
    CPoint point,
    XTP_CALENDAR_HITTESTINFO_DAY_VIEW* pInfo
);
Parameters

point
A CPoint object that contains the point to test.
pInfo
A pointer to an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

Remarks

Call this member function to gather hit test information from the day view.

See Also

XTP_CALENDAR_HITTESTINFO_DAY_VIEW

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::IsMultidayEvent Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::IsMultidayEvent Method

Call this member function to determine if an event is "Multi Day".

virtual BOOL IsMultidayEvent();
Returns

TRUE if events is "Multi Day". FALSE otherwise.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::IsVisible Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::IsVisible Method

This member function is used to determine if the event is visible.

virtual BOOL IsVisible();
Returns

A BOOL that contains the value of the visibility of the event. TRUE if events is visible. FALSE otherwise.

Remarks

This function calls IsVisibleEx(TRUE, TRUE, FALSE);

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::IsVisibleEx Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::IsVisibleEx Method

This member function is used to obtain the value of the visibility flag.

virtual BOOL IsVisibleEx(
    BOOL bCheckTop,
    BOOL bCheckBottom,
    BOOL bTopAndBottom
);
Parameters

bCheckTop
A BOOL that indicates if the top bound visibility is checked.
bCheckBottom
A BOOL that indicates if the bottom bound visibility is checked.
bTopAndBottom
A BOOL that indicates if the top and bottom bound visibility is checked.

Returns

TRUE if events is visible. FALSE otherwise.

Remarks

Checks visibility of boundaries.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::OnPostAdjustLayout Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::OnPostAdjustLayout Method

This member function is used to perform additional adjustments in some kinds of views.

virtual void OnPostAdjustLayout();
Remarks

Call this member function to perform additional adjustments after all adjustment activities are completed.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::SetEventPlaceCount Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::SetEventPlaceCount Method

This member function is used to set the event view places count.

void SetEventPlaceCount(
    int nPlaceCount
);
Parameters

nPlaceCount
An int that contains the number of view places.

Remarks

Call this member function to set event view places count.

Body Source
void CXTPCalendarDayViewEvent::SetEventPlaceCount(int nPlaceCount) {
    m_nEventPlaceNumber = (int)MAKELONG(LOWORD((DWORD)m_nEventPlaceNumber), (WORD)nPlaceCount);
}
Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::SetEventPlacePos Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::SetEventPlacePos Method

This member function is used to set the event view place identifier.

void SetEventPlacePos(
    int nPlace
);
Parameters

nPlace
An int that contains the place identifier value.

Remarks

Call this member function to set the event view place identifier.

Body Source
void CXTPCalendarDayViewEvent::SetEventPlacePos(int nPlace) {
    m_nEventPlaceNumber = (int)MAKELONG((WORD)nPlace, HIWORD((DWORD)m_nEventPlaceNumber));
}
Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent::StartEditSubject Method

CXTPCalendarDayViewEvent Methods, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::StartEditSubject Method

This member function is used to create and show the subject editor.

virtual CXTPCalendarViewEvent* StartEditSubject();
Returns

A pointer to an CXTPCalendarViewEvent object for which the editor is created.

Remarks

A subject is created only for the master event if the event is multi-day. If this member function is called for a slave event, then the editing process is passed to the master event.

Group

CXTPCalendarDayViewEvent Methods


CXTPCalendarDayViewEvent Constructors

CXTPCalendarDayViewEvent Class, Legend, Public Methods
CXTPCalendarDayViewEvent Constructors
Class

CXTPCalendarDayViewEvent Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayViewEvent | Default object constructor.


CXTPCalendarDayViewEvent::CXTPCalendarDayViewEvent Constructor

CXTPCalendarDayViewEvent Constructors, CXTPCalendarDayViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::CXTPCalendarDayViewEvent Constructor

Default object constructor.

CXTPCalendarDayViewEvent(
    CXTPCalendarEvent* pEvent,
    CXTPCalendarDayViewGroup* pViewGroup
);
Parameters

pEvent
Pointer to CXTPCalendarEvent.
pViewGroup
Pointer to CXTPCalendarDayViewGroup object.

See Also

~CXTPCalendarDayViewDay()

Group

CXTPCalendarDayViewEvent Constructors


CXTPCalendarDayViewEvent Destructors

CXTPCalendarDayViewEvent Class, Legend, Public Methods
CXTPCalendarDayViewEvent Destructors
Class

CXTPCalendarDayViewEvent Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarDayViewEvent | Default class destructor.


CXTPCalendarDayViewEvent::~CXTPCalendarDayViewEvent Destructor

CXTPCalendarDayViewEvent Destructors, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::~CXTPCalendarDayViewEvent Destructor

Default class destructor.

virtual ~CXTPCalendarDayViewEvent();
Group

CXTPCalendarDayViewEvent Destructors


CXTPCalendarDayViewEvent Nested Types

CXTPCalendarDayViewEvent Class, Public Nested Types
CXTPCalendarDayViewEvent Nested Types
Class

CXTPCalendarDayViewEvent Class

Public Nested Types
Public Nested Type | Description
TBase |


CXTPCalendarDayViewEvent::TBase Nested Type

CXTPCalendarDayViewEvent Nested Types, CXTPCalendarDayViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewEvent::TBase Nested Type
typedef CXTPCalendarViewEventT< CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO_DAY_VIEW > TBase;
Remarks

Base class type definition.

Group

CXTPCalendarDayViewEvent Nested Types


CXTPCalendarDayViewGroup Class

XTPCalendarDayViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarDayViewGroup Data Members, CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Constructors, CXTPCalendarDayViewGroup Destructors, CXTPCalendarDayViewGroup Nested Types, CXTPCalendarDayViewGroup Constructors, CXTPCalendarDayViewGroup Data Members, CXTPCalendarDayViewGroup Destructors, CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup Class

This class represents a single resource view portion of the Calendar Day View.

Class Hierarchy

class CXTPCalendarDayViewGroup : public CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, XTP_CALENDAR_HITTESTINFO_DAY_VIEW, CXTPCalendarDayViewGroup>;
File

XTPCalendarDayViewDay.h

Remarks

It represents a specific view of the CalendarView's associated events data grouped by one day and one resource and provides basic functionality on this data using user input through keyboard and mouse.

See Also

CXTPCalendarDayViewDay

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarDayViewGroup Constructors
CXTPCalendarDayViewGroup Constructors | Description
CXTPCalendarDayViewGroup | Default object constructor. Construct CXTPCalendarDayViewGroup object.
CXTPCalendarDayViewGroup Data Members
CXTPCalendarDayViewGroup Data Members | Description
m_bExpandDOWN | Store is ExpandDOWN sign visible.
m_bExpandUP | Store is ExpandUP sign visible.
m_LayoutX | Store group view layout.
CXTPCalendarDayViewGroup Destructors
CXTPCalendarDayViewGroup Destructors | Description
~CXTPCalendarDayViewGroup | Default class destructor.
CXTPCalendarDayViewGroup Methods
CXTPCalendarDayViewGroup Methods | Description
AdjustDayEvents | Adjusts layout of day events items.
AdjustLayout | This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.
Draw | This member function is used to draw the view content utilizing the specified device context.
FillHitTestEx | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
FindMinMaxGroupDayEvents | Call this member function to find top and bottom events in group.
GetAllDayEventsRect | This member function is used to obtain the drawing area of all day events.
GetBusyStatus | This member function is used to obtain the busy status for the specified time.
GetCellDateTime | This member function is used to obtain the beginning time value for the specified cell.
GetCellEvents | This member function is used to obtain the events collection which belongs to the specified cell.
GetCellRect | This member function is used to obtain the rect for the specified cell.
GetCellViewPart | This member function is used to obtain the view part of the specified cell.
GetDateTimeCell | This member function is used to calculate the cell number for the specified time value.
GetRowCount | This member function is used to obtain the total number of rows in the view.
GetRowHeight | This member function is used to obtain the height of a single cell.
GetTooltipRect | Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position
GetTopRow | This member function is used to obtain the number of the top visible row in the view.
GetVisibleRowCount | This member function is used to obtain the number of rows visible in the view.
HitTestDateTime | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
HitTestEx | This member function is used to fill the XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
IsExpandDown | Call this member function to determine is ExpandDown sign visible.
IsExpandUp | Call this member function to determine is ExpandUp sign visible.
IsGroupHeaderVisible | This member function is used to determine is the group header visible or not.
IsWorkDateTime | This member function is used to check is the specified date time work or non-work.
OnLButtonDown | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
SetExpandDown | Call this member function to set ExpandDown sign visible.
SetExpandUp | Call this member function to set ExpandUp sign visible.
UserAction_OnScrollDay | This member function used to process user action xtpCalendarUserAction_OnScrollDay.
CXTPCalendarDayViewGroup Nested Types
CXTPCalendarDayViewGroup Nested Types | Description
TBase | Base class type definition.


CXTPCalendarDayViewGroup Data Members

CXTPCalendarDayViewGroup Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup Data Members
Class

CXTPCalendarDayViewGroup Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bExpandDOWN | Store is ExpandDOWN sign visible.
m_bExpandUP | Store is ExpandUP sign visible.
m_LayoutX | Store group view layout.


CXTPCalendarDayViewGroup::m_bExpandDOWN Data Member

CXTPCalendarDayViewGroup Data Members, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::m_bExpandDOWN Data Member

Store is ExpandDOWN sign visible.

BOOL m_bExpandDOWN;
Group

CXTPCalendarDayViewGroup Data Members


CXTPCalendarDayViewGroup::m_bExpandUP Data Member

CXTPCalendarDayViewGroup Data Members, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::m_bExpandUP Data Member

Store is ExpandUP sign visible.

BOOL m_bExpandUP;
Group

CXTPCalendarDayViewGroup Data Members


CXTPCalendarDayViewGroup::m_LayoutX Data Member

CXTPCalendarDayViewGroup Data Members, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::m_LayoutX Data Member

Store group view layout.

XTP_DAY_VIEW_GROUP_LAYOUT m_LayoutX;
Group

CXTPCalendarDayViewGroup Data Members


CXTPCalendarDayViewGroup Methods

CXTPCalendarDayViewGroup Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup Methods
Class

CXTPCalendarDayViewGroup Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
FillHitTestEx | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
GetCellEvents | This member function is used to obtain the events collection which belongs to the specified cell.
GetCellViewPart | This member function is used to obtain the view part of the specified cell.
HitTestDateTime | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
OnLButtonDown | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
Public Methods
Public Methods
Public Method | Description
AdjustDayEvents | Adjusts layout of day events items.
AdjustLayout | This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.
Draw | This member function is used to draw the view content utilizing the specified device context.
FindMinMaxGroupDayEvents | Call this member function to find top and bottom events in group.
GetAllDayEventsRect | This member function is used to obtain the drawing area of all day events.
GetBusyStatus | This member function is used to obtain the busy status for the specified time.
GetCellDateTime | This member function is used to obtain the beginning time value for the specified cell.
GetCellRect | This member function is used to obtain the rect for the specified cell.
GetDateTimeCell | This member function is used to calculate the cell number for the specified time value.
GetRowCount | This member function is used to obtain the total number of rows in the view.
GetRowHeight | This member function is used to obtain the height of a single cell.
GetTooltipRect | Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position
GetTopRow | This member function is used to obtain the number of the top visible row in the view.
GetVisibleRowCount | This member function is used to obtain the number of rows visible in the view.
HitTestEx | This member function is used to fill the XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
IsExpandDown | Call this member function to determine is ExpandDown sign visible.
IsExpandUp | Call this member function to determine is ExpandUp sign visible.
IsGroupHeaderVisible | This member function is used to determine is the group header visible or not.
IsWorkDateTime | This member function is used to check is the specified date time work or non-work.
SetExpandDown | Call this member function to set ExpandDown sign visible.
SetExpandUp | Call this member function to set ExpandUp sign visible.
UserAction_OnScrollDay | This member function used to process user action xtpCalendarUserAction_OnScrollDay.


CXTPCalendarDayViewGroup::AdjustDayEvents Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::AdjustDayEvents Method

Adjusts layout of day events items.

virtual void AdjustDayEvents(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::AdjustLayout Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided bounding rectangle. and calls AdjustLayout() for all sub items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcGroup
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcGroup
);
Parameters

pDC
Pointer to a valid device context.
rcGroup
A CRect object containing the dimensions of the bounding rectangle for the DayViewGroup area.

Remarks

AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::Draw Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::Draw Method

This member function is used to draw the view content utilizing the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

Call AdjustLayout() before Draw()

See Also

AdjustLayout

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::FillHitTestEx Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::FillHitTestEx Method

This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

virtual void FillHitTestEx(
    XTP_CALENDAR_HITTESTINFO_DAY_VIEW* pHitTest
);
Parameters

pHitTest
A pointer to an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

Remarks

Call this member function to gather hit test information from the day view.

See Also

XTP_CALENDAR_HITTESTINFO_DAY_VIEW

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::FindMinMaxGroupDayEvents Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::FindMinMaxGroupDayEvents Method

Call this member function to find top and bottom events in group.

void FindMinMaxGroupDayEvents(
    CXTPCalendarDayViewEvent*& rpMin,
    CXTPCalendarDayViewEvent*& rpMax
);
Parameters

rpMin
[out] Reference to store pointer to a top event.
rpMax
[out] Reference to store pointer to a bottom event.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetAllDayEventsRect Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetAllDayEventsRect Method

This member function is used to obtain the drawing area of all day events.

virtual CRect GetAllDayEventsRect() const;
Returns

A CRect object containing the coordinates of the all day events drawing area.

Body Source
CRect CXTPCalendarDayViewGroup::GetAllDayEventsRect() const {
    return m_LayoutX.m_rcAllDayEvents;
}
Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetBusyStatus Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetBusyStatus Method

This member function is used to obtain the busy status for the specified time.

virtual int GetBusyStatus(
    COleDateTime dtTime
);
Parameters

dtTime
A COleDateTime object that contains the time value for which to check the busy status.

Returns

XTPCalendarEventBusyStatus value.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetCellDateTime Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetCellDateTime Method

This member function is used to obtain the beginning time value for the specified cell.

COleDateTime GetCellDateTime(
    int nCell
) const;
Parameters

nCell
An int that contains the cell index.

Returns

A COleDateTime object that contains the beginning time value for the specified cell.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetCellEvents Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetCellEvents Method

This member function is used to obtain the events collection which belongs to the specified cell.

virtual void GetCellEvents(
    int nCell,
    CXTPCalendarDayViewGroup::TBase::TViewEventsCollection* pViewEvents,
    COleDateTime& rdtMinEventTime,
    COleDateTime& rdtMaxEventTime
);
Parameters

nCell
An int that contains the cell number for the events collection.
pViewEvents
Pointer to an event views collection. This pointer is used populate the views collection with data.
rdtMinEventTime
A COleDateTime object used to contain the minimum time for events in the returned collection.
rdtMaxEventTime
A COleDateTime object used to contain the maximum time for events in the returned collection.

See Also

TViewEventsCollection

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetCellRect Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetCellRect Method

This member function is used to obtain the rect for the specified cell.

CRect GetCellRect(
    int nCell
) const;
Parameters

nCell
An int that contains the cell index.

Returns

A CRect object that contains the cell rect.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetCellViewPart Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetCellViewPart Method

This member function is used to obtain the view part of the specified cell.

virtual CXTPCalendarViewPart* GetCellViewPart(
    const COleDateTime& dtDateTime
);
Parameters

dtDateTime
A COleDateTime object that contains the cell's date to return the view part for.

Returns

A pointer to a CXTPCalendarViewPart object. The CXTPCalendarViewPart object contains the Day View Working Cell part if dtDateTime is the same as the Work Date Time. Otherwise the CXTPCalendarViewPart object contains the Non Work Cell part.

See Also

CXTPCalendarViewPart overview

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetDateTimeCell Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetDateTimeCell Method

This member function is used to calculate the cell number for the specified time value.

int GetDateTimeCell(
    const COleDateTime& dtTime,
    BOOL bForEndTime
) const;
Parameters

dtTime
A COleDateTime object that contains the time value to search for.
bForEndTime
A BOOL object that determines if a split line between cells is needed. The split line is used to indicate if the date to search for belongs to the end of the previous cell or to the beginning of the next cell.

Returns

Call this member function to retrieve the cell that contains the specified time value.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetRowCount Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetRowCount Method

This member function is used to obtain the total number of rows in the view.

int GetRowCount() const;
Returns

An int that contains the total number of rows in the view.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetRowHeight Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetRowHeight Method

This member function is used to obtain the height of a single cell.

int GetRowHeight() const;
Returns

An int that contains the height, in pixels, of a single cell.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetTooltipRect Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetTooltipRect Method

Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position

virtual CRect GetTooltipRect(
    const CPoint& ptHit,
    const XTP_CALENDAR_HITTESTINFO& hitInfo
);
Returns

A CRect object with relative coordinates of the tooltip.

Remarks

This member function returns a rectangle calculated as a single cell rect which user currently holds a mouse on.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetTopRow Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetTopRow Method

This member function is used to obtain the number of the top visible row in the view.

int GetTopRow() const;
Returns

An int that contains the number of the top visible row in the view.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::GetVisibleRowCount Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::GetVisibleRowCount Method

This member function is used to obtain the number of rows visible in the view.

int GetVisibleRowCount() const;
Returns

An int that contains the number of rows visible in the view.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::HitTestDateTime Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::HitTestDateTime Method

This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

virtual BOOL HitTestDateTime(
    XTP_CALENDAR_HITTESTINFO_DAY_VIEW* pHitTest
);
Parameters

pHitTest
A pointer to an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

Returns

A BOOL. TRUE if pHitTest->pt point is on a valid part of the Day View. FALSE otherwise.

Remarks

Call this member function to gather hit test information from the day view. It uses pHitTest->pt point for gathering information.

See Also

XTP_CALENDAR_HITTESTINFO_DAY_VIEW

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::HitTestEx Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::HitTestEx Method

This member function is used to fill the XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

virtual BOOL HitTestEx(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO_DAY_VIEW* pHitTest
);
Parameters

pt
A CPoint object that contains the point to test.
pHitTest
Pointer to an XTP_CALENDAR_HITTESTINFO_DAY_VIEW struct.

Remarks

Call this member function to gather hit test information from the day view.

See Also

XTP_CALENDAR_HITTESTINFO_DAY_VIEW

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::IsExpandDown Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::IsExpandDown Method

Call this member function to determine is ExpandDown sign visible.

BOOL IsExpandDown();
Returns

TRUE if ExpandDown sign visible, FALSE otherwise.

Remarks

Can be useful to implement visualization themes.

Body Source
BOOL CXTPCalendarDayViewGroup::IsExpandDown() {
    return m_bExpandDOWN;
}
Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::IsExpandUp Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::IsExpandUp Method

Call this member function to determine is ExpandUp sign visible.

BOOL IsExpandUp();
Returns

TRUE if ExpandUp sign visible, FALSE otherwise.

Remarks

Can be useful to implement visualization themes.

Body Source
BOOL CXTPCalendarDayViewGroup::IsExpandUp() {
    return m_bExpandUP;
}
Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::IsGroupHeaderVisible Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::IsGroupHeaderVisible Method

This member function is used to determine is the group header visible or not.

BOOL IsGroupHeaderVisible() const;
Returns

TRUE if the group header is visible, FALSE otherwise.

Body Source
BOOL CXTPCalendarDayViewGroup::IsGroupHeaderVisible() const {
    return m_LayoutX.m_bShowHeader;
}
Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::IsWorkDateTime Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::IsWorkDateTime Method

This member function is used to check is the specified date time work or non-work.

BOOL IsWorkDateTime(
    const COleDateTime& dtDateTime
);
Parameters

dtDateTime
A COleDateTime object that contains the date time value to check.

Returns

TRUE if the specified date time is work, FALSE otherwise.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::OnLButtonDown Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::OnLButtonDown Method

This member function is used to processes left mouse button events.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicates whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user presses the left mouse button.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::OnMouseMove Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::OnMouseMove Method

This member function is used to processes mouse movement events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::SetExpandDown Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::SetExpandDown Method

Call this member function to set ExpandDown sign visible.

void SetExpandDown();
Remarks

Can be useful to implement visualization themes.

Body Source
void CXTPCalendarDayViewGroup::SetExpandDown() {
    m_bExpandDOWN = TRUE;
}
Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::SetExpandUp Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::SetExpandUp Method

Call this member function to set ExpandUp sign visible.

void SetExpandUp();
Remarks

Can be useful to implement visualization themes.

Body Source
void CXTPCalendarDayViewGroup::SetExpandUp() {
    m_bExpandUP = TRUE;
}
Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup::UserAction_OnScrollDay Method

CXTPCalendarDayViewGroup Methods, CXTPCalendarDayViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::UserAction_OnScrollDay Method

This member function used to process user action xtpCalendarUserAction_OnScrollDay.

BOOL UserAction_OnScrollDay(
    XTPCalendarScrollDayButton eButton
);
Parameters

eButton
[in] a button from which this action comes.

Returns

TRUE if action was handled by user and default processing must be skipped, FALSE otherwise.

Remarks

Implementation send a XTP_NC_CALENDAR_USERACTION notification.

See Also

XTP_NC_CALENDAR_USERACTION

Group

CXTPCalendarDayViewGroup Methods


CXTPCalendarDayViewGroup Constructors

CXTPCalendarDayViewGroup Class, Legend, Public Methods
CXTPCalendarDayViewGroup Constructors
Class

CXTPCalendarDayViewGroup Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayViewGroup | Default object constructor. Construct CXTPCalendarDayViewGroup object.


CXTPCalendarDayViewGroup::CXTPCalendarDayViewGroup Constructor

CXTPCalendarDayViewGroup Constructors, CXTPCalendarDayViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::CXTPCalendarDayViewGroup Constructor

Default object constructor. Construct CXTPCalendarDayViewGroup object.

CXTPCalendarDayViewGroup(
    CXTPCalendarDayViewDay* pViewDay
);
Parameters

pViewDay
Pointer to CXTPCalendarDayViewDay object.

See Also

~CXTPCalendarDayViewGroup()

Group

CXTPCalendarDayViewGroup Constructors


CXTPCalendarDayViewGroup Destructors

CXTPCalendarDayViewGroup Class, Legend, Public Methods
CXTPCalendarDayViewGroup Destructors
Class

CXTPCalendarDayViewGroup Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarDayViewGroup | Default class destructor.


CXTPCalendarDayViewGroup::~CXTPCalendarDayViewGroup Destructor

CXTPCalendarDayViewGroup Destructors, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::~CXTPCalendarDayViewGroup Destructor

Default class destructor.

virtual ~CXTPCalendarDayViewGroup();
Remarks

Handles member items deallocation.

Group

CXTPCalendarDayViewGroup Destructors


CXTPCalendarDayViewGroup Nested Types

CXTPCalendarDayViewGroup Class, Public Nested Types
CXTPCalendarDayViewGroup Nested Types
Class

CXTPCalendarDayViewGroup Class

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition.


CXTPCalendarDayViewGroup::TBase Nested Type

CXTPCalendarDayViewGroup Nested Types, CXTPCalendarDayViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewGroup::TBase Nested Type

Base class type definition.

typedef CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, XTP_CALENDAR_HITTESTINFO_DAY_VIEW, CXTPCalendarDayViewGroup > TBase;
Group

CXTPCalendarDayViewGroup Nested Types


CXTPCalendarDayViewTimeScale Class

XTPCalendarDayViewTimeScale.h, Classes, Legend, Members, Topics, CXTPCalendarDayViewTimeScale Data Members, CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Constructors, CXTPCalendarDayViewTimeScale Destructors, CXTPCalendarDayViewTimeScale Constructors, CXTPCalendarDayViewTimeScale Data Members, CXTPCalendarDayViewTimeScale Destructors, CXTPCalendarDayViewTimeScale Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale Class

This class implements a specific view portion of the Calendar Day view - called Time scale.

Class Hierarchy

class CXTPCalendarDayViewTimeScale;
File

XTPCalendarDayViewTimeScale.h

Remarks

The Day view contains two time scales defining those intervals at the left of the view, which is represented by the CXTPCalendarDayViewTimeScale class. One time scale is the main and is visible by default, second one is the alternative and could be enabled programmatically. Time scale interval could be changed using SetScaleInterval member function.

See Also

CXTPCalendarDayViewDay

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarDayViewTimeScale Constructors
CXTPCalendarDayViewTimeScale Constructors | Description
CXTPCalendarDayViewTimeScale | Default object constructor.
CXTPCalendarDayViewTimeScale Data Members
CXTPCalendarDayViewTimeScale Data Members | Description
m_bDrawNowLine | Specifies whether we should draw the "Now" line on the time scale.
m_bVisible | Show this timescale or not.
m_Layout | Store time scale layout.
m_nTimeshift_min | Time zone time shift in minutes.
m_pDayView | Pointer to the parent Calendar Day view object.
m_strCaption | Caption under time scale.
CXTPCalendarDayViewTimeScale Destructors
CXTPCalendarDayViewTimeScale Destructors | Description
~CXTPCalendarDayViewTimeScale | Default class destructor.
CXTPCalendarDayViewTimeScale Methods
CXTPCalendarDayViewTimeScale Methods | Description
AdjustLayout | This function is used to adjust the time scale layout.
CalcWidth | This member function is used to obtain the time scale width in pixels.
Draw | This member function is used to perform all drawing logic of the time scale.
Format | This member function is used to format the time scale text.
GetCaption | This member function is used to obtain the text caption for the time scale.
GetDayView | This member function obtains the time scale owner view.
GetScaleInterval | This member function obtains the time scale cell interval.
GetTimeshift | This member function is used to obtain the time shift in hours for the time scale.
GetVisible | This member function is used to obtain the current time scale visibility mode.
GetWidth | This member function is used to get the time scale width.
HitTestDateTime | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
IsDrawNowLine | This member function is used to determine is Current Time Mark can be drawn for this time scale.
MoveTo | This member function shift the time scale object.
SetCaption | This member function is used to set the text caption for the time scale.
SetTimeshift | This member function is used to set the new time shift in hours for the time scale.
SetVisible | This member function is used to set the time scale visible mode (TRUE - visible, FALSE - invisible).


CXTPCalendarDayViewTimeScale Data Members

CXTPCalendarDayViewTimeScale Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale Data Members
Class

CXTPCalendarDayViewTimeScale Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bDrawNowLine | Specifies whether we should draw the "Now" line on the time scale.
m_bVisible | Show this timescale or not.
m_Layout | Store time scale layout.
m_nTimeshift_min | Time zone time shift in minutes.
m_pDayView | Pointer to the parent Calendar Day view object.
m_strCaption | Caption under time scale.


CXTPCalendarDayViewTimeScale::m_bDrawNowLine Data Member

CXTPCalendarDayViewTimeScale Data Members, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::m_bDrawNowLine Data Member

Specifies whether we should draw the "Now" line on the time scale.

BOOL m_bDrawNowLine;
Group

CXTPCalendarDayViewTimeScale Data Members


CXTPCalendarDayViewTimeScale::m_bVisible Data Member

CXTPCalendarDayViewTimeScale Data Members, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::m_bVisible Data Member

Show this timescale or not.

BOOL m_bVisible;
Group

CXTPCalendarDayViewTimeScale Data Members


CXTPCalendarDayViewTimeScale::m_Layout Data Member

CXTPCalendarDayViewTimeScale Data Members, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::m_Layout Data Member

Store time scale layout.

XTP_TIMESCALE_LAYOUT m_Layout;
Group

CXTPCalendarDayViewTimeScale Data Members


CXTPCalendarDayViewTimeScale::m_nTimeshift_min Data Member

CXTPCalendarDayViewTimeScale Data Members, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::m_nTimeshift_min Data Member

Time zone time shift in minutes.

int m_nTimeshift_min;
Group

CXTPCalendarDayViewTimeScale Data Members


CXTPCalendarDayViewTimeScale::m_pDayView Data Member

CXTPCalendarDayViewTimeScale Data Members, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::m_pDayView Data Member

Pointer to the parent Calendar Day view object.

CXTPCalendarDayView* m_pDayView;
Group

CXTPCalendarDayViewTimeScale Data Members


CXTPCalendarDayViewTimeScale::m_strCaption Data Member

CXTPCalendarDayViewTimeScale Data Members, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::m_strCaption Data Member

Caption under time scale.

CString m_strCaption;
Group

CXTPCalendarDayViewTimeScale Data Members


CXTPCalendarDayViewTimeScale Methods

CXTPCalendarDayViewTimeScale Class, Legend, Public Methods
CXTPCalendarDayViewTimeScale Methods
Class

CXTPCalendarDayViewTimeScale Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This function is used to adjust the time scale layout.
CalcWidth | This member function is used to obtain the time scale width in pixels.
Draw | This member function is used to perform all drawing logic of the time scale.
Format | This member function is used to format the time scale text.
GetCaption | This member function is used to obtain the text caption for the time scale.
GetDayView | This member function obtains the time scale owner view.
GetScaleInterval | This member function obtains the time scale cell interval.
GetTimeshift | This member function is used to obtain the time shift in hours for the time scale.
GetVisible | This member function is used to obtain the current time scale visibility mode.
GetWidth | This member function is used to get the time scale width.
HitTestDateTime | This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.
IsDrawNowLine | This member function is used to determine is Current Time Mark can be drawn for this time scale.
MoveTo | This member function shift the time scale object.
SetCaption | This member function is used to set the text caption for the time scale.
SetTimeshift | This member function is used to set the new time shift in hours for the time scale.
SetVisible | This member function is used to set the time scale visible mode (TRUE - visible, FALSE - invisible).


CXTPCalendarDayViewTimeScale::AdjustLayout Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::AdjustLayout Method

This function is used to adjust the time scale layout.

virtual void AdjustLayout(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::CalcWidth Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::CalcWidth Method

This member function is used to obtain the time scale width in pixels.

int CalcWidth(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Returns

An int that contains the time scale width in pixels.

Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::Draw Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::Draw Method

This member function is used to perform all drawing logic of the time scale.

void Draw(
    CDC* pDC
);
Parameters

pDC
A pointer to a valid device context.

Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::Format Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::Format Method

This member function is used to format the time scale text.

virtual CString Format(
    COleDateTime dtTime,
    BOOL bTopCell,
    CString* pHour = NULL,
    CString* pMin = NULL
);
Parameters

dtTime
A COleDateTime object that contains the time to format to text.
bTopCell
If TRUE and minutes value is 0 the minutes value is replaced on am/pm value. This valid only for AM/PM 12-hour time format. If this parameter FALSE, the minutes value 0 is replace only if hour value is 12.
pHour
A pointer to the CString object to write the hour part of the value.
pMin
A pointer to the CString object to write the minutes part of the value.

Returns

A string containing formatted text.

Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::GetCaption Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::GetCaption Method

This member function is used to obtain the text caption for the time scale.

CString GetCaption();
Returns

A CString object that contains the text caption for the time scale.

Remarks

Use GetCaption() to get the current time scale caption.

See Also

SetCaption

Body Source
CString CXTPCalendarDayViewTimeScale::GetCaption() {
    return m_strCaption;
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::GetDayView Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::GetDayView Method

This member function obtains the time scale owner view.

CXTPCalendarDayView* GetDayView();
Returns

A pointer to CXTPCalendarDayView object.

Remarks

Use this member function to get day view object which owns the time scale.

Body Source
CXTPCalendarDayView* CXTPCalendarDayViewTimeScale::GetDayView() {
    return m_pDayView;
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::GetScaleInterval Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::GetScaleInterval Method

This member function obtains the time scale cell interval.

COleDateTimeSpan GetScaleInterval() const;
Returns

A COleDateTimeSpan object that contains the cell interval for the time scale.

Remarks

Use this member function to retrieve the current time scale cell interval.

Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::GetTimeshift Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::GetTimeshift Method

This member function is used to obtain the time shift in hours for the time scale.

int GetTimeshift();
Returns

An int that contains the time shift for the time scale in minutes.

Remarks

Use this member function to retrieve current time shift for the time scale.

See Also

SetTimeshift

Body Source
int CXTPCalendarDayViewTimeScale::GetTimeshift() {
    return m_nTimeshift_min;
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::GetVisible Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::GetVisible Method

This member function is used to obtain the current time scale visibility mode.

BOOL GetVisible();
Returns

A BOOL that contains the time scale visibility scale value. TRUE if the time scale is visible. FALSE otherwise.

See Also

SetVisible(BOOL)

Body Source
BOOL CXTPCalendarDayViewTimeScale::GetVisible() {
    return m_bVisible;
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::GetWidth Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::GetWidth Method

This member function is used to get the time scale width.

int GetWidth() const;
Returns

An int that contains the time scale width in pixels.

Body Source
int CXTPCalendarDayViewTimeScale::GetWidth() const {
    return m_Layout.m_rcHeader.Width();
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::HitTestDateTime Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::HitTestDateTime Method

This member function is used to fill an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

BOOL HitTestDateTime(
    XTP_CALENDAR_HITTESTINFO_DAY_VIEW* pHitTest
);
Parameters

pHitTest
A pointer to an XTP_CALENDAR_HITTESTINFO_DAY_VIEW structure.

Remarks

Call this member function to gather hit test information from the day view. It uses pHitTest->pt point for gathering hit test information.

See Also

XTP_CALENDAR_HITTESTINFO_DAY_VIEW

Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::IsDrawNowLine Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::IsDrawNowLine Method

This member function is used to determine is Current Time Mark can be drawn for this time scale.

virtual BOOL IsDrawNowLine() const;
Returns

Returns TRUE if Current Time Mark may be drawn for this time scale, FALSE otherwise.

Remarks

By default it returns TRUE for primary time scale and FALSE for secondary.

Body Source
BOOL CXTPCalendarDayViewTimeScale::IsDrawNowLine() const {
    return m_bDrawNowLine;
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::MoveTo Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::MoveTo Method

This member function shift the time scale object.

void MoveTo(
    int nXPos
);
Parameters

nXPos
Offset from base position.

Remarks

Used by horizontal scrolling to place timescale always visible on the left border.

Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::SetCaption Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::SetCaption Method

This member function is used to set the text caption for the time scale.

void SetCaption(
    LPCTSTR strCaption
);
Parameters

strCaption
A CString object that contains the new text caption for the time scale.

Remarks

Use this function to set the current time scale caption.

See Also

GetCaption

Body Source
void CXTPCalendarDayViewTimeScale::SetCaption(LPCTSTR strCaption) {
    m_strCaption = strCaption;
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::SetTimeshift Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::SetTimeshift Method

This member function is used to set the new time shift in hours for the time scale.

void SetTimeshift(
    int nMinutes
);
Parameters

nMinutes
An int that contains the new time shift for the time scale in minutes.

Remarks

Use this member function to set the new time shift for the time scale.

See Also

GetTimeshift

Body Source
void CXTPCalendarDayViewTimeScale::SetTimeshift(int nMinutes) {
    m_nTimeshift_min = nMinutes;
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale::SetVisible Method

CXTPCalendarDayViewTimeScale Methods, CXTPCalendarDayViewTimeScale Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::SetVisible Method

This member function is used to set the time scale visible mode (TRUE - visible, FALSE - invisible).

void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
A BOOL that contains the new time scale visible state.
TRUE
Visible.
FALSE
Invisible.

See Also

GetVisible()

Body Source
void CXTPCalendarDayViewTimeScale::SetVisible(BOOL bVisible) {
    m_bVisible = bVisible;
}
Group

CXTPCalendarDayViewTimeScale Methods


CXTPCalendarDayViewTimeScale Constructors

CXTPCalendarDayViewTimeScale Class, Legend, Public Methods
CXTPCalendarDayViewTimeScale Constructors
Class

CXTPCalendarDayViewTimeScale Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayViewTimeScale | Default object constructor.


CXTPCalendarDayViewTimeScale::CXTPCalendarDayViewTimeScale Constructor

CXTPCalendarDayViewTimeScale Constructors, CXTPCalendarDayViewTimeScale Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::CXTPCalendarDayViewTimeScale Constructor

Default object constructor.

CXTPCalendarDayViewTimeScale(
    CXTPCalendarDayView* pDayView,
    BOOL bVisible = TRUE,
    BOOL bDrawNowLine = TRUE
);
Parameters

pDayView
Pointer to associated CXTPCalendarDayView object.
bVisible
Specifies initial visibility mode for the time scale.
bDrawNowLine
If TRUE current time mark is drawn.

See Also

~CXTPCalendarDayViewTimeScale()

Group

CXTPCalendarDayViewTimeScale Constructors


CXTPCalendarDayViewTimeScale Destructors

CXTPCalendarDayViewTimeScale Class, Legend, Public Methods
CXTPCalendarDayViewTimeScale Destructors
Class

CXTPCalendarDayViewTimeScale Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarDayViewTimeScale | Default class destructor.


CXTPCalendarDayViewTimeScale::~CXTPCalendarDayViewTimeScale Destructor

CXTPCalendarDayViewTimeScale Destructors, CXTPCalendarDayViewTimeScale Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarDayViewTimeScale::~CXTPCalendarDayViewTimeScale Destructor

Default class destructor.

virtual ~CXTPCalendarDayViewTimeScale();
Remarks

Handles member items deallocation.

See Also

CXTPCalendarDayViewTimeScale

Group

CXTPCalendarDayViewTimeScale Destructors


CXTPCalendarEvent Class

XTPCalendarEvent.h, Classes, Legend, Members, Topics, CXTPCalendarEvent Data Members, CXTPCalendarEvent Methods, CXTPCalendarEvent Constructors, CXTPCalendarEvent Destructors, CXTPCalendarEvent Constructors, CXTPCalendarEvent Data Members, CXTPCalendarEvent Destructors, Example, CXTPCalendarEvent Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent Class

This class represents the data of a single Event used in the Calendar control.

Class Hierarchy

class CXTPCalendarEvent;
File

XTPCalendarEvent.h

Remarks

Event can be recurring or non-recurring: see GetRecurrenceState() method and XTPCalendarEventRecurrenceState. If Event is recurring use GetRecurrencePattern() method to retrieve recurrence properties. Recurrence States (XTPCalendarEventRecurrenceState):

  • xtpCalendarRecurrenceMaster - Main event which is used for creating Occurrences.
  • xtpCalendarRecurrenceOccurrence - Event is one Occurrence of the Recurrence series.
  • xtpCalendarRecurrenceException - Event is Occurrence which properties differ than in the Recurrence pattern or this Occurrence is deleted (for

See Also

CXTPCalendarRecurrencePattern overview, CXTPCalendarEventLabels overview, CXTPCalendarEventLabel overview, XTPCalendarEventRecurrenceState

Example

Start/End time or Location are different).

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarEvent Constructors
CXTPCalendarEvent Constructors | Description
CXTPCalendarEvent | Default object constructor.
CXTPCalendarEvent Data Members
CXTPCalendarEvent Data Members | Description
m_bAllDayEvent | Is this an all day event value.
m_bMeeting | Boolean flag that is used to indicate if an event is a meeting.
m_bPrivate | Boolean flag that is used to indicate if an event is a private meeting.
m_bReminder | This flag value indicates is the Reminder enabled or not.
m_bRExceptionDeleted | Is Recurrence Exception deleted.
m_dtCreationTime | Creation event time value.
m_dtEndTime | End event time value.
m_dtLastModificationTime | Last Modification event time value.
m_dtRException_EndTimeOrig | Original end time of Recurrence exception event.
m_dtRException_StartTimeOrig | Original start time of Recurrence exception event.
m_dtStartTime | Start event time value.
m_dwEventID | ID of this event object.
m_dwRecurrencePatternID | Recurrence Pattern ID.
m_dwRecurrencePatternID_ToUse | Previously used pattern ID.
m_nBusyStatus | Event Busy Status value.
m_nImportance | Event Importance value.
m_nLabelID | Label ID.
m_nRecurrenceState | Event Recurrence State.
m_nReminderMinutesBeforeStart | Reminder time value.
m_pCustomIconsIDs | An array to store custom icons id's assigned to event.
m_pCustomProperties | Custom properties collection object.
m_pDataProvider | Pointer to the owner data provider.
m_pEventCategoryIDs | An array to store categories id's assigned to event.
m_ptrRPattern | Recurrence Pattern object for a master event only.
m_strBody | Body value.
m_strLocation | Location value.
m_strReminderSoundFile | Reminder sound file path.
m_strSubject | Subject value.
m_uScheduleID | ID of the corresponding Schedule.
CXTPCalendarEvent Destructors
CXTPCalendarEvent Destructors | Description
~CXTPCalendarEvent | Default class destructor.
CXTPCalendarEvent Methods
CXTPCalendarEvent Methods | Description
CalcStartEndDatesFromPattern | This member function is used to calculate the date-time values of the start and end dates for occurrences of recurrent events.
Clear | Clear current event properties
ClearIntermediateData | Clear intermediate data members which where set when operations with recurrence properties where made.
CloneEvent | Call this member function to obtain a pointer to the read-write interface of the event.
CloneEventTo | Clones current event properties into a provided object instance.
CloneForOccurrence | This member function is used to build an occurrence event by duplicating the master event.
DoPropExchange | Call this member function to Store/Load an event using the specified data object.
GetBody | Call this member function to obtain the body text for the event.
GetBusyStatus | Call this member function to get a busy status value for the event.
GetCategories | This member function is used to obtain collection of Event categories IDs associated with event object.
GetCreationTime | Call this member function to get the creation time for an event.
GetCustomIcons | This member function is used to obtain collection of custom icons IDs associated with event object.
GetCustomProperties | Get custom (named, user defined) properties collection.
GetDataProvider | Returns event data provider.
GetDuration | Call this member function to get an event duration as an COleDateTimeSpan object.
GetDurationMinutes | Call this member function to get an event duration in minutes.
GetEndTime | Call this member function to get the event's end DateTime.
GetEventID | This member function is used to obtain a unique event ID.
GetEventPeriodDays | Call this member function to get an event duration as a number of days.
GetImportance | Call this member function to get an importance level for an event.
GetLabel | Call this member function to obtain the event label.
GetLabelID | Call this member function to get the event label ID.
GetLastModificationTime | Call this member function to get the last modification time for an event.
GetLocation | Call this member function to obtain the event location text.
GetRecurrencePattern | Call this member function to get the event's recurrence pattern object.
GetRecurrencePatternID | Call this member function to get the recurrence pattern ID.
GetRecurrenceState | Call this member function to get a recurrence state for the event.
GetReminderMinutesBeforeStart | Call this member function to determine the number of minutes before the start of an event.
GetReminderSoundFile | Call this member function to determine a full path to the sound file assigned to the event reminder.
GetRException_EndTimeOrig | This member function is used to obtain the original end time of an exception event.
GetRException_StartTimeOrig | This member function is used to obtain the original start time of an exception event.
GetRPatternRef | This member function is used to obtain a pointer to the internally stored Recurrence Pattern object.
GetScheduleID | This member function is used to obtain a schedule ID of the event.
GetStartTime | Call this member function to get the event's start DateTime.
GetSubject | This member function is used to obtain the event subject.
IsAllDayEvent | Call this member function to determine if an event is an "All Day" event.
IsEqualIDs | Call this member function to compare IDs of different events.
IsEqualStartEnd | Call this member function to compare start dates of different events.
IsMeeting | This member function is used to obtain the value of the Meeting state flag.
IsPrivate | This member function is used to obtain the value of the private state flag.
IsReminder | Call this member function to determine if a reminder is set for event.
IsRExceptionDeleted | Call this member function to determine if an exception occurrence is marked as deleted.
IsSound | Call this member function to determine if sound file is configured for the event reminder.
MakeAsRException | Call this member function to set the event's recurrence pattern as an exception occurrence.
MakeEventAsRecurrence | Call this member function to change the recurrence state for the event.
MoveEvent | This member function is used to move the start date event to the provided DateTime, duration of the event does not change.
RemoveRecurrence | This member function removes the recurrence pattern for the event.
SetAllDayEvent | This member function is used to set the "All Day" flag for an event.
SetBody | This member function is used to set the body text for the event.
SetBusyStatus | This member function is used to set the busy status value for the event.
SetCreationTime | This member function is used to set the creation time for an event.
SetDuration | This member function is used to set the new duration for the event.
SetEndTime | This member function is used to set the new end date and time for the event.
SetEventID | This member function is used to set a new ID value for an event.
SetImportance | This member function is used to set the importance level for the event.
SetLabelID | This member function is used to set the new label ID for the event.
SetLastModificationTime | This member function is used to set the modification time for the event.
SetLocation | This member function is used to set the location text for the event.
SetMeeting | This member function is used to set the state for the meeting flag.
SetPrivate | This member function is used to set the state for the private flag.
SetRecurrencePatternID | This member function is used to set the new ID value for the event recurrence pattern.
SetRecurrenceState_ExceptionOccurrence | This member function is used to set the exception recurrence.
SetRecurrenceState_Master | This member function is used to assign a new RecurrencePattern to an event and set the Master flag.
SetRecurrenceState_NotRecurring | This function is used to reset the recurrence state for an event.
SetReminder | Call this member function to setup a reminder for this event.
SetReminderMinutesBeforeStart | This member function is used to set the number of minutes before the start of an event.
SetReminderSoundFile | This member function is used to set the sound file for the event reminder.
SetRException_EndTimeOrig | This member function is used to set the original end time of an exception event.
SetRException_StartTimeOrig | This member function is used to set the original start time of an exception event.
SetRExceptionDeleted | Call this member function to mark an exception occurrence as deleted/undeleted.
SetScheduleID | This member function is used to set a new schedule ID of the event.
SetStartTime | This member function is used to set the new start date and time for the event. The time is accepted as is, and no any conversions is performed.
SetSubject | This member function is used to set the subject text for the event.
Update | Call this member function to update the event's data.
UpdateRecurrence | This member function is used to set the recurrence pattern for the event.
UpdateStartEndDatesFromPatternExceptions | This member function is used to change the date-time values of the start and end dates of the master event using exception occurrences of recurrent events.


CXTPCalendarEvent Data Members

CXTPCalendarEvent Class, Legend, Protected Data Members
CXTPCalendarEvent Data Members
Class

CXTPCalendarEvent Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAllDayEvent | Is this an all day event value.
m_bMeeting | Boolean flag that is used to indicate if an event is a meeting.
m_bPrivate | Boolean flag that is used to indicate if an event is a private meeting.
m_bReminder | This flag value indicates is the Reminder enabled or not.
m_bRExceptionDeleted | Is Recurrence Exception deleted.
m_dtCreationTime | Creation event time value.
m_dtEndTime | End event time value.
m_dtLastModificationTime | Last Modification event time value.
m_dtRException_EndTimeOrig | Original end time of Recurrence exception event.
m_dtRException_StartTimeOrig | Original start time of Recurrence exception event.
m_dtStartTime | Start event time value.
m_dwEventID | ID of this event object.
m_dwRecurrencePatternID | Recurrence Pattern ID.
m_dwRecurrencePatternID_ToUse | Previously used pattern ID.
m_nBusyStatus | Event Busy Status value.
m_nImportance | Event Importance value.
m_nLabelID | Label ID.
m_nRecurrenceState | Event Recurrence State.
m_nReminderMinutesBeforeStart | Reminder time value.
m_pCustomIconsIDs | An array to store custom icons id's assigned to event.
m_pCustomProperties | Custom properties collection object.
m_pDataProvider | Pointer to the owner data provider.
m_pEventCategoryIDs | An array to store categories id's assigned to event.
m_ptrRPattern | Recurrence Pattern object for a master event only.
m_strBody | Body value.
m_strLocation | Location value.
m_strReminderSoundFile | Reminder sound file path.
m_strSubject | Subject value.
m_uScheduleID | ID of the corresponding Schedule.


CXTPCalendarEvent::m_bAllDayEvent Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_bAllDayEvent Data Member

Is this an all day event value.

BOOL m_bAllDayEvent;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_bMeeting Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_bMeeting Data Member

Boolean flag that is used to indicate if an event is a meeting.

BOOL m_bMeeting;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_bPrivate Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_bPrivate Data Member

Boolean flag that is used to indicate if an event is a private meeting.

BOOL m_bPrivate;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_bReminder Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_bReminder Data Member

This flag value indicates is the Reminder enabled or not.

BOOL m_bReminder;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_bRExceptionDeleted Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_bRExceptionDeleted Data Member

Is Recurrence Exception deleted.

BOOL m_bRExceptionDeleted;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dtCreationTime Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dtCreationTime Data Member

Creation event time value.

COleDateTime m_dtCreationTime;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dtEndTime Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dtEndTime Data Member

End event time value.

COleDateTime m_dtEndTime;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dtLastModificationTime Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dtLastModificationTime Data Member

Last Modification event time value.

COleDateTime m_dtLastModificationTime;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dtRException_EndTimeOrig Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dtRException_EndTimeOrig Data Member

Original end time of Recurrence exception event.

COleDateTime m_dtRException_EndTimeOrig;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dtRException_StartTimeOrig Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dtRException_StartTimeOrig Data Member

Original start time of Recurrence exception event.

COleDateTime m_dtRException_StartTimeOrig;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dtStartTime Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dtStartTime Data Member

Start event time value.

COleDateTime m_dtStartTime;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dwEventID Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dwEventID Data Member

ID of this event object.

DWORD m_dwEventID;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dwRecurrencePatternID Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dwRecurrencePatternID Data Member

Recurrence Pattern ID.

DWORD m_dwRecurrencePatternID;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_dwRecurrencePatternID_ToUse Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_dwRecurrencePatternID_ToUse Data Member

Previously used pattern ID.

DWORD m_dwRecurrencePatternID_ToUse;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_nBusyStatus Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_nBusyStatus Data Member

Event Busy Status value.

int m_nBusyStatus;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_nImportance Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_nImportance Data Member

Event Importance value.

int m_nImportance;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_nLabelID Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_nLabelID Data Member

Label ID.

int m_nLabelID;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_nRecurrenceState Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_nRecurrenceState Data Member

Event Recurrence State.

XTPCalendarEventRecurrenceState m_nRecurrenceState;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_nReminderMinutesBeforeStart Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_nReminderMinutesBeforeStart Data Member

Reminder time value.

int m_nReminderMinutesBeforeStart;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_pCustomIconsIDs Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_pCustomIconsIDs Data Member

An array to store custom icons id's assigned to event.

CXTPCalendarCustomIconIDs* m_pCustomIconsIDs;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_pCustomProperties Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_pCustomProperties Data Member

Custom properties collection object.

CXTPCalendarCustomProperties* m_pCustomProperties;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_pDataProvider Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_pDataProvider Data Member

Pointer to the owner data provider.

CXTPCalendarData* m_pDataProvider;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_pEventCategoryIDs Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_pEventCategoryIDs Data Member

An array to store categories id's assigned to event.

CXTPCalendarEventCategoryIDs* m_pEventCategoryIDs;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_ptrRPattern Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_ptrRPattern Data Member

Recurrence Pattern object for a master event only.

CXTPCalendarRecurrencePatternPtr m_ptrRPattern;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_strBody Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_strBody Data Member

Body value.

CString m_strBody;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_strLocation Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_strLocation Data Member

Location value.

CString m_strLocation;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_strReminderSoundFile Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_strReminderSoundFile Data Member

Reminder sound file path.

CString m_strReminderSoundFile;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_strSubject Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_strSubject Data Member

Subject value.

CString m_strSubject;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent::m_uScheduleID Data Member

CXTPCalendarEvent Data Members, CXTPCalendarEvent Class
CXTPCalendarEvent::m_uScheduleID Data Member

ID of the corresponding Schedule.

UINT m_uScheduleID;
Group

CXTPCalendarEvent Data Members


CXTPCalendarEvent Methods

CXTPCalendarEvent Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent Methods
Class

CXTPCalendarEvent Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalcStartEndDatesFromPattern | This member function is used to calculate the date-time values of the start and end dates for occurrences of recurrent events.
Clear | Clear current event properties
ClearIntermediateData | Clear intermediate data members which where set when operations with recurrence properties where made.
GetRPatternRef | This member function is used to obtain a pointer to the internally stored Recurrence Pattern object.
SetRecurrenceState_ExceptionOccurrence | This member function is used to set the exception recurrence.
SetRecurrenceState_Master | This member function is used to assign a new RecurrencePattern to an event and set the Master flag.
SetRecurrenceState_NotRecurring | This function is used to reset the recurrence state for an event.
UpdateStartEndDatesFromPatternExceptions | This member function is used to change the date-time values of the start and end dates of the master event using exception occurrences of recurrent events.
Public Methods
Public Methods
Public Method | Description
CloneEvent | Call this member function to obtain a pointer to the read-write interface of the event.
CloneEventTo | Clones current event properties into a provided object instance.
CloneForOccurrence | This member function is used to build an occurrence event by duplicating the master event.
DoPropExchange | Call this member function to Store/Load an event using the specified data object.
GetBody | Call this member function to obtain the body text for the event.
GetBusyStatus | Call this member function to get a busy status value for the event.
GetCategories | This member function is used to obtain collection of Event categories IDs associated with event object.
GetCreationTime | Call this member function to get the creation time for an event.
GetCustomIcons | This member function is used to obtain collection of custom icons IDs associated with event object.
GetCustomProperties | Get custom (named, user defined) properties collection.
GetDataProvider | Returns event data provider.
GetDuration | Call this member function to get an event duration as an COleDateTimeSpan object.
GetDurationMinutes | Call this member function to get an event duration in minutes.
GetEndTime | Call this member function to get the event's end DateTime.
GetEventID | This member function is used to obtain a unique event ID.
GetEventPeriodDays | Call this member function to get an event duration as a number of days.
GetImportance | Call this member function to get an importance level for an event.
GetLabel | Call this member function to obtain the event label.
GetLabelID | Call this member function to get the event label ID.
GetLastModificationTime | Call this member function to get the last modification time for an event.
GetLocation | Call this member function to obtain the event location text.
GetRecurrencePattern | Call this member function to get the event's recurrence pattern object.
GetRecurrencePatternID | Call this member function to get the recurrence pattern ID.
GetRecurrenceState | Call this member function to get a recurrence state for the event.
GetReminderMinutesBeforeStart | Call this member function to determine the number of minutes before the start of an event.
GetReminderSoundFile | Call this member function to determine a full path to the sound file assigned to the event reminder.
GetRException_EndTimeOrig | This member function is used to obtain the original end time of an exception event.
GetRException_StartTimeOrig | This member function is used to obtain the original start time of an exception event.
GetScheduleID | This member function is used to obtain a schedule ID of the event.
GetStartTime | Call this member function to get the event's start DateTime.
GetSubject | This member function is used to obtain the event subject.
IsAllDayEvent | Call this member function to determine if an event is an "All Day" event.
IsEqualIDs | Call this member function to compare IDs of different events.
IsEqualStartEnd | Call this member function to compare start dates of different events.
IsMeeting | This member function is used to obtain the value of the Meeting state flag.
IsPrivate | This member function is used to obtain the value of the private state flag.
IsReminder | Call this member function to determine if a reminder is set for event.
IsRExceptionDeleted | Call this member function to determine if an exception occurrence is marked as deleted.
IsSound | Call this member function to determine if sound file is configured for the event reminder.
MakeAsRException | Call this member function to set the event's recurrence pattern as an exception occurrence.
MakeEventAsRecurrence | Call this member function to change the recurrence state for the event.
MoveEvent | This member function is used to move the start date event to the provided DateTime, duration of the event does not change.
RemoveRecurrence | This member function removes the recurrence pattern for the event.
SetAllDayEvent | This member function is used to set the "All Day" flag for an event.
SetBody | This member function is used to set the body text for the event.
SetBusyStatus | This member function is used to set the busy status value for the event.
SetCreationTime | This member function is used to set the creation time for an event.
SetDuration | This member function is used to set the new duration for the event.
SetEndTime | This member function is used to set the new end date and time for the event.
SetEventID | This member function is used to set a new ID value for an event.
SetImportance | This member function is used to set the importance level for the event.
SetLabelID | This member function is used to set the new label ID for the event.
SetLastModificationTime | This member function is used to set the modification time for the event.
SetLocation | This member function is used to set the location text for the event.
SetMeeting | This member function is used to set the state for the meeting flag.
SetPrivate | This member function is used to set the state for the private flag.
SetRecurrencePatternID | This member function is used to set the new ID value for the event recurrence pattern.
SetReminder | Call this member function to setup a reminder for this event.
SetReminderMinutesBeforeStart | This member function is used to set the number of minutes before the start of an event.
SetReminderSoundFile | This member function is used to set the sound file for the event reminder.
SetRException_EndTimeOrig | This member function is used to set the original end time of an exception event.
SetRException_StartTimeOrig | This member function is used to set the original start time of an exception event.
SetRExceptionDeleted | Call this member function to mark an exception occurrence as deleted/undeleted.
SetScheduleID | This member function is used to set a new schedule ID of the event.
SetStartTime | This member function is used to set the new start date and time for the event. The time is accepted as is, and no any conversions is performed.
SetSubject | This member function is used to set the subject text for the event.
Update | Call this member function to update the event's data.
UpdateRecurrence | This member function is used to set the recurrence pattern for the event.


CXTPCalendarEvent::CalcStartEndDatesFromPattern Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::CalcStartEndDatesFromPattern Method

This member function is used to calculate the date-time values of the start and end dates for occurrences of recurrent events.

virtual BOOL CalcStartEndDatesFromPattern();
Returns

TRUE if successful. FALSE otherwise.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::Clear Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::Clear Method

Clear current event properties

virtual void Clear();
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::ClearIntermediateData Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::ClearIntermediateData Method

Clear intermediate data members which where set when operations with recurrence properties where made.

virtual void ClearIntermediateData();
Remarks

This method is automatically called by the date provider when event is updated or added.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::CloneEvent Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::CloneEvent Method

Call this member function to obtain a pointer to the read-write interface of the event.

virtual CXTPCalendarEventPtr CloneEvent();
Returns

Pointer to a CXTPCalendarEvent object that contains the read-write interface of the event.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::CloneEventTo Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::CloneEventTo Method

Clones current event properties into a provided object instance.

virtual BOOL CloneEventTo(
    CXTPCalendarEvent* pEventDest
);
Parameters

pEventDest
Pointer to a destination CXTPCalendarEvent object.

Returns

TRUE if cloned successfully; FALSE otherwise.

Remarks

This member function is used by CloneEvent() implementation.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::CloneForOccurrence Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::CloneForOccurrence Method

This member function is used to build an occurrence event by duplicating the master event.

virtual CXTPCalendarEventPtr CloneForOccurrence(
    COleDateTime dtStart,
    COleDateTime dtEnd,
    DWORD dwNewEventID = XTP_CALENDAR_UNKNOWN_EVENT_ID
);
Parameters

dtStart
Start occurrence event date time.
dtEnd
End occurrence event date time.
dwNewEventID
Occurrence event ID. If specified value is
XTP_CALENDAR_UNKNOWN_EVENT_ID
a new occurrence event ID will be generated automatically.

Returns

Pointer to a CXTPCalendarEvent object that contains the cloned occurrence event.

Remarks

Call this member function to get an occurrence event object.

See Also

CXTPCalendarEvent

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::DoPropExchange Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::DoPropExchange Method

Call this member function to Store/Load an event using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Remarks

This member function is used to store or load event data to or from a storage.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetBody Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetBody Method

Call this member function to obtain the body text for the event.

virtual CString GetBody() const;
Returns

A CString object with the body text for the event.

See Also

SetBody

Body Source
CString CXTPCalendarEvent::GetBody() const {
    return m_strBody;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetBusyStatus Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetBusyStatus Method

Call this member function to get a busy status value for the event.

virtual int GetBusyStatus() const;
Returns

Busy status value for the event as an XTPCalendarEventBusyStatus flag.

See Also

SetBusyStatus, XTPCalendarEventBusyStatus enum

Body Source
int CXTPCalendarEvent::GetBusyStatus() const {
    return m_nBusyStatus;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetCategories Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetCategories Method

This member function is used to obtain collection of Event categories IDs associated with event object.

virtual CXTPCalendarEventCategoryIDs* GetCategories();
Returns

Pointer to CXTPCalendarEventCategoryIDs object. See also; CXTPCalendarEventCategories overview, CXTPCalendarData::GetEventCategories

Body Source
CXTPCalendarEventCategoryIDs* CXTPCalendarEvent::GetCategories() {
    return m_pEventCategoryIDs;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetCreationTime Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetCreationTime Method

Call this member function to get the creation time for an event.

virtual COleDateTime GetCreationTime() const;
Returns

Creation time for event as COleDateTime object.

See Also

SetCreationTime

Body Source
COleDateTime CXTPCalendarEvent::GetCreationTime() const {
    return m_dtCreationTime;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetCustomIcons Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetCustomIcons Method

This member function is used to obtain collection of custom icons IDs associated with event object.

virtual CXTPCalendarCustomIconIDs* GetCustomIcons();
Returns

Pointer to CXTPCalendarCustomIconIDs object.

Body Source
CXTPCalendarCustomIconIDs* CXTPCalendarEvent::GetCustomIcons() {
    return m_pCustomIconsIDs;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetCustomProperties Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetCustomProperties Method

Get custom (named, user defined) properties collection.

CXTPCalendarCustomProperties* GetCustomProperties();
Returns

A pointer to CXTPCalendarCustomProperties object.

See Also

CXTPCalendarCustomProperties.

Body Source
CXTPCalendarCustomProperties* CXTPCalendarEvent::GetCustomProperties() {
    return m_pCustomProperties;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetDataProvider Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetDataProvider Method

Returns event data provider.

virtual CXTPCalendarData* GetDataProvider();
Returns

A pointer to the data provider which stores this event object.

Body Source
CXTPCalendarData* CXTPCalendarEvent::GetDataProvider() {
    return m_pDataProvider;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetDuration Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::GetDuration Method

Call this member function to get an event duration as an COleDateTimeSpan object.

virtual COleDateTimeSpan GetDuration() const;
Returns

An COleDateTimeSpan object that contains an event duration interval.

See Also

SetDuration

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetDurationMinutes Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::GetDurationMinutes Method

Call this member function to get an event duration in minutes.

virtual int GetDurationMinutes() const;
Returns

Integer value of an event duration in minutes.

See Also

GetDuration

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetEndTime Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetEndTime Method

Call this member function to get the event's end DateTime.

virtual COleDateTime GetEndTime() const;
Returns

A COleDateTime object that contains the event's end DateTime.

See Also

SetEndTime

Body Source
COleDateTime CXTPCalendarEvent::GetEndTime() const {
    return m_dtEndTime;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetEventID Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetEventID Method

This member function is used to obtain a unique event ID.

virtual DWORD GetEventID() const;
See Also

CXTPCalendarEvent, SetEventID

Body Source
DWORD CXTPCalendarEvent::GetEventID() const {
    return m_dwEventID;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetEventPeriodDays Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::GetEventPeriodDays Method

Call this member function to get an event duration as a number of days.

virtual int GetEventPeriodDays() const;
Returns

Integer value of an event duration in days.

See Also

GetDurationMinutes(), GetDuration()

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetImportance Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetImportance Method

Call this member function to get an importance level for an event.

virtual int GetImportance() const;
Returns

Importance level for event as an XTPCalendarEventImportance enum.

See Also

SetImportance, XTPCalendarEventImportance enum

Body Source
int CXTPCalendarEvent::GetImportance() const {
    return m_nImportance;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetLabel Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::GetLabel Method

Call this member function to obtain the event label.

virtual CXTPCalendarEventLabel* GetLabel() const;
Returns

Pointer to an CXTPCalendarEventLabel object that contains the event label.

See Also

CXTPCalendarEventLabel, SetLocation

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetLabelID Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetLabelID Method

Call this member function to get the event label ID.

virtual int GetLabelID() const;
Returns

An int that contains the event label ID value.

See Also

CXTPCalendarEventLabel, SetLabelID

Body Source
int CXTPCalendarEvent::GetLabelID() const {
    return m_nLabelID;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetLastModificationTime Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetLastModificationTime Method

Call this member function to get the last modification time for an event.

virtual COleDateTime GetLastModificationTime() const;
Returns

A COleDateTime object that contains the last modification time for the event.

See Also

SetLastModificationTime

Body Source
COleDateTime CXTPCalendarEvent::GetLastModificationTime() const {
    return m_dtLastModificationTime;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetLocation Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetLocation Method

Call this member function to obtain the event location text.

virtual CString GetLocation() const;
Returns

A CString object that contains the location text.

See Also

SetLocation

Body Source
CString CXTPCalendarEvent::GetLocation() const {
    return m_strLocation;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetRecurrencePattern Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::GetRecurrencePattern Method

Call this member function to get the event's recurrence pattern object.

virtual CXTPCalendarRecurrencePatternPtr GetRecurrencePattern() const;
Returns

Pointer to a CXTPCalendarRecurrencePattern object that contains the event's recurrence pattern.

See Also

CXTPCalendarRecurrencePattern

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetRecurrencePatternID Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetRecurrencePatternID Method

Call this member function to get the recurrence pattern ID.

virtual DWORD GetRecurrencePatternID() const;
Returns

A DWORD containing the recurrence pattern ID.

Body Source
DWORD CXTPCalendarEvent::GetRecurrencePatternID() const {
    return m_dwRecurrencePatternID;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetRecurrenceState Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetRecurrenceState Method

Call this member function to get a recurrence state for the event.

virtual XTPCalendarEventRecurrenceState GetRecurrenceState() const;
Returns

Recurrence state for the event as an XTPCalendarEventRecurrenceState enum.

See Also

MakeEventAsRecurrence, XTPCalendarEventRecurrenceState enum

Body Source
XTPCalendarEventRecurrenceState CXTPCalendarEvent::GetRecurrenceState() const {
    return m_nRecurrenceState;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetReminderMinutesBeforeStart Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetReminderMinutesBeforeStart Method

Call this member function to determine the number of minutes before the start of an event.

virtual int GetReminderMinutesBeforeStart() const;
Returns

An int that contains the number of Minutes before the start of an event.

See Also

SetReminderMinutesBeforeStart(int nMinutes)

Body Source
int CXTPCalendarEvent::GetReminderMinutesBeforeStart() const {
    return m_nReminderMinutesBeforeStart;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetReminderSoundFile Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetReminderSoundFile Method

Call this member function to determine a full path to the sound file assigned to the event reminder.

virtual CString GetReminderSoundFile() const;
Returns

A CString object with full path to the sound file for the event reminder.

See Also

SetReminderSoundFile(LPCTSTR pcszFile)

Body Source
CString CXTPCalendarEvent::GetReminderSoundFile() const {
    return m_strReminderSoundFile;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetRException_EndTimeOrig Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetRException_EndTimeOrig Method

This member function is used to obtain the original end time of an exception event.

virtual COleDateTime GetRException_EndTimeOrig() const;
Returns

A COleDateTime object that contains the original date.

See Also

GetRException_StartTimeOrig, SetRException_EndTimeOrig

Body Source
COleDateTime CXTPCalendarEvent::GetRException_EndTimeOrig() const {
    return m_dtRException_EndTimeOrig;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetRException_StartTimeOrig Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetRException_StartTimeOrig Method

This member function is used to obtain the original start time of an exception event.

virtual COleDateTime GetRException_StartTimeOrig() const;
Returns

A COleDateTime object with the start original date.

See Also

SetRException_StartTimeOrig, GetRException_EndTimeOrig

Body Source
COleDateTime CXTPCalendarEvent::GetRException_StartTimeOrig() const {
    return m_dtRException_StartTimeOrig;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetRPatternRef Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::GetRPatternRef Method

This member function is used to obtain a pointer to the internally stored Recurrence Pattern object.

virtual CXTPCalendarRecurrencePattern* GetRPatternRef();
Returns

A CXTPCalendarRecurrencePattern pointer that contains the Recurrence Pattern object.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetScheduleID Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetScheduleID Method

This member function is used to obtain a schedule ID of the event.

virtual UINT GetScheduleID() const;
Remarks

String with the schedule ID allows to identify schedules for different resources, for example Schedule ID could contain the name of the employee, who is the owner of this event.

See Also

CXTPCalendarEvent, SetScheduleID

Body Source
UINT CXTPCalendarEvent::GetScheduleID() const {
    return m_uScheduleID;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetStartTime Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetStartTime Method

Call this member function to get the event's start DateTime.

virtual COleDateTime GetStartTime() const;
Returns

A COleDateTime object containing the event's start DateTime.

See Also

SetStartTime

Body Source
COleDateTime CXTPCalendarEvent::GetStartTime() const {
    return m_dtStartTime;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::GetSubject Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::GetSubject Method

This member function is used to obtain the event subject.

virtual CString GetSubject() const;
Returns

A CString object that contains the subject text.

Body Source
CString CXTPCalendarEvent::GetSubject() const {
    return m_strSubject;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::IsAllDayEvent Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::IsAllDayEvent Method

Call this member function to determine if an event is an "All Day" event.

virtual BOOL IsAllDayEvent() const;
Returns

A BOOL. TRUE if events is "All Day". FALSE otherwise.

See Also

SetAllDayEvent

Body Source
BOOL CXTPCalendarEvent::IsAllDayEvent() const {
    return m_bAllDayEvent;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::IsEqualIDs Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::IsEqualIDs Method

Call this member function to compare IDs of different events.

virtual BOOL IsEqualIDs(
    CXTPCalendarEvent* pEvent
) const;
Parameters

pEvent
Pointer to a CXTPCalendarEvent object that contains an event to compare.

Returns

TRUE if the provided event ID is equal the "this" ID. FALSE otherwise.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::IsEqualStartEnd Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::IsEqualStartEnd Method

Call this member function to compare start dates of different events.

virtual BOOL IsEqualStartEnd(
    CXTPCalendarEvent* pEvent
) const;
Parameters

pEvent
Pointer to a CXTPCalendarEvent object that contains an event to compare.

Returns

TRUE if the provided event start date is equal to the "this" date. FALSE otherwise.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::IsMeeting Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::IsMeeting Method

This member function is used to obtain the value of the Meeting state flag.

virtual BOOL IsMeeting();
Returns

TRUE if the event is a meeting. FALSE otherwise.

Body Source
BOOL CXTPCalendarEvent::IsMeeting() {
    return m_bMeeting;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::IsPrivate Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::IsPrivate Method

This member function is used to obtain the value of the private state flag.

virtual BOOL IsPrivate();
Returns

TRUE if the event is private. FALSE otherwise. The private flag is used to indicate that a meeting event is private.

Body Source
BOOL CXTPCalendarEvent::IsPrivate() {
    return m_bPrivate;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::IsReminder Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::IsReminder Method

Call this member function to determine if a reminder is set for event.

virtual BOOL IsReminder() const;
Returns

TRUE if a reminder is set. FALSE otherwise.

See Also

SetReminder()

Body Source
BOOL CXTPCalendarEvent::IsReminder() const {
    return m_bReminder;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::IsRExceptionDeleted Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::IsRExceptionDeleted Method

Call this member function to determine if an exception occurrence is marked as deleted.

virtual BOOL IsRExceptionDeleted() const;
Returns

TRUE if an exception occurrence is marked as deleted. FALSE otherwise.

See Also

SetRExceptionDeleted(BOOL bDeleted = TRUE)

Body Source
BOOL CXTPCalendarEvent::IsRExceptionDeleted() const {
    return m_bRExceptionDeleted;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::IsSound Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::IsSound Method

Call this member function to determine if sound file is configured for the event reminder.

virtual BOOL IsSound() const;
Returns

TRUE if sound file is configured. FALSE otherwise.

Body Source
BOOL CXTPCalendarEvent::IsSound() const {
    return !m_strReminderSoundFile.IsEmpty();
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::MakeAsRException Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::MakeAsRException Method

Call this member function to set the event's recurrence pattern as an exception occurrence.

virtual BOOL MakeAsRException(
    DWORD dwPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID
);
Parameters

dwPatternID
Recurrence pattern ID.

Returns

TRUE if successful. FALSE otherwise.

Body Source
BOOL CXTPCalendarEvent::MakeAsRException(DWORD dwPatternID) {
    ASSERT(m_nRecurrenceState == xtpCalendarRecurrenceNotRecurring ||
        m_nRecurrenceState == xtpCalendarRecurrenceOccurrence ||
        m_nRecurrenceState == xtpCalendarRecurrenceException);
    return SetRecurrenceState_ExceptionOccurrence(xtpCalendarRecurrenceException, dwPatternID);
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::MakeEventAsRecurrence Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::MakeEventAsRecurrence Method

Call this member function to change the recurrence state for the event.

virtual BOOL MakeEventAsRecurrence();
Returns

TRUE if recurrence state successfully changed. FALSE otherwise.

See Also

GetRecurrenceState, XTPCalendarEventRecurrenceState enum

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::MoveEvent Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::MoveEvent Method

This member function is used to move the start date event to the provided DateTime, duration of the event does not change.

virtual void MoveEvent(
    COleDateTime dtNewStartTime
);
Parameters

dtNewStartTime
An COleDateTime object that contains the new start date for the event.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::RemoveRecurrence Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::RemoveRecurrence Method

This member function removes the recurrence pattern for the event.

virtual BOOL RemoveRecurrence();
Returns

TRUE if the operation is successful. FALSE otherwise.

See Also

UpdateRecurrence(CXTPCalendarRecurrencePattern* pRPattern)

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetAllDayEvent Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetAllDayEvent Method

This member function is used to set the "All Day" flag for an event.

virtual void SetAllDayEvent(
    BOOL bSet = TRUE
);
Parameters

bSet
A BOOL. Boolean value used to set the "All Day" flag to TRUE or FALSE.
TRUE
Event is an "All day" event.
FALSE
Event is not an "All day" event.

See Also

IsAllDayEvent

Body Source
void CXTPCalendarEvent::SetAllDayEvent(BOOL bSet) {
    ASSERT(m_nRecurrenceState != xtpCalendarRecurrenceOccurrence);
    m_bAllDayEvent = bSet;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetBody Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetBody Method

This member function is used to set the body text for the event.

virtual void SetBody(
    LPCTSTR pcszDesc
);
Parameters

pcszDesc
An LPCTSTR Pointer to the string with the body text.

See Also

GetBody

Body Source
void CXTPCalendarEvent::SetBody(LPCTSTR pcszDesc) {
    m_strBody = pcszDesc;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetBusyStatus Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetBusyStatus Method

This member function is used to set the busy status value for the event.

virtual void SetBusyStatus(
    int Status
);
Parameters

Status
An int that contains the busy status value.

See Also

GetBusyStatus, XTPCalendarEventBusyStatus enum

Body Source
void CXTPCalendarEvent::SetBusyStatus(int nStatus) {
    m_nBusyStatus = nStatus;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetCreationTime Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetCreationTime Method

This member function is used to set the creation time for an event.

virtual void SetCreationTime(
    COleDateTime dtTime
);
Parameters

dtTime
A COleDateTime object that contains the new creation time.

See Also

GetCreationTime

Body Source
void CXTPCalendarEvent::SetCreationTime(COleDateTime dtTime) {
    m_dtCreationTime = dtTime;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetDuration Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::SetDuration Method

This member function is used to set the new duration for the event.

virtual void SetDuration(
    COleDateTimeSpan spDuration,
    BOOL bKeepStart = TRUE
);
Parameters

spDuration
An COleDateTimeSpan object that contains the new date interval value.
bKeepStart
TRUE - Expanded flag and expand end DateTime.
FALSE
Expand start DateTime.

See Also

GetDuration

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetEndTime Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::SetEndTime Method

This member function is used to set the new end date and time for the event.

virtual void SetEndTime(
    COleDateTime dtEnd
);
Parameters

dtEnd
new date value.

See Also

GetEndTime

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetEventID Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::SetEventID Method

This member function is used to set a new ID value for an event.

virtual void SetEventID(
    DWORD dwEventID
);
Parameters

dwEventID
A DWORD that contains the event id value.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetImportance Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetImportance Method

This member function is used to set the importance level for the event.

virtual void SetImportance(
    int nImportance
);
Parameters

nImportance
An int that contains the importance level value.

See Also

GetImportance, XTPCalendarEventImportance enum

Body Source
void CXTPCalendarEvent::SetImportance(int nImportance) {
    m_nImportance = nImportance;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetLabelID Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetLabelID Method

This member function is used to set the new label ID for the event.

virtual void SetLabelID(
    int nLabelID
);
Parameters

nLabelID
An int that contains the label ID value.

See Also

GetLabelID

Body Source
void CXTPCalendarEvent::SetLabelID(int nLabelID) {
    m_nLabelID = nLabelID;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetLastModificationTime Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetLastModificationTime Method

This member function is used to set the modification time for the event.

virtual void SetLastModificationTime(
    COleDateTime dtTime
);
Parameters

dtTime
A COleDateTime object that contains the new modification time.

See Also

GetLastModificationTime

Body Source
void CXTPCalendarEvent::SetLastModificationTime(COleDateTime dtTime) {
    m_dtLastModificationTime = dtTime;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetLocation Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetLocation Method

This member function is used to set the location text for the event.

virtual void SetLocation(
    LPCTSTR pcszLocation
);
Parameters

pcszLocation
An LPCTSTR object that contains the string of text.

See Also

GetLocation

Body Source
void CXTPCalendarEvent::SetLocation(LPCTSTR pcszLocation) {
    m_strLocation = pcszLocation;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetMeeting Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetMeeting Method

This member function is used to set the state for the meeting flag.

virtual void SetMeeting(
    BOOL bMeeting = TRUE
);
Parameters

bMeeting
A BOOL that contains the new state for the meeting flag.

Remarks

Call this member function to set meeting state flag.

Body Source
void CXTPCalendarEvent::SetMeeting(BOOL bMeeting) {
    m_bMeeting = bMeeting;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetPrivate Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetPrivate Method

This member function is used to set the state for the private flag.

virtual void SetPrivate(
    BOOL bPrivate = TRUE
);
Parameters

bPrivate
A BOOL that contains the new state for the private flag.

Remarks

Call this member function to set the private state flag. The private flag is used to indicate that a meeting event is private.

Body Source
void CXTPCalendarEvent::SetPrivate(BOOL bPrivate) {
    m_bPrivate = bPrivate;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetRecurrencePatternID Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::SetRecurrencePatternID Method

This member function is used to set the new ID value for the event recurrence pattern.

virtual void SetRecurrencePatternID(
    DWORD dwRecurrencePatternID
);
Parameters

dwRecurrencePatternID
An DWORD that contains the event recurrence pattern id value.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetRecurrenceState_ExceptionOccurrence Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::SetRecurrenceState_ExceptionOccurrence Method

This member function is used to set the exception recurrence.

virtual BOOL SetRecurrenceState_ExceptionOccurrence(
    XTPCalendarEventRecurrenceState nState,
    DWORD dwNewPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID
);
Parameters

nState
An int that contains the new state value.
dwNewPatternID
A DWORD that contains the new pattern ID.

Returns

TRUE if the provided event start dates are equal. FALSE otherwise.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetRecurrenceState_Master Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::SetRecurrenceState_Master Method

This member function is used to assign a new RecurrencePattern to an event and set the Master flag.

virtual BOOL SetRecurrenceState_Master(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to a CXTPCalendarRecurrencePattern object that contains the new recurrence pattern for the event.

Returns

TRUE - If the provided event start dates are equal. FALSE otherwise.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetRecurrenceState_NotRecurring Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::SetRecurrenceState_NotRecurring Method

This function is used to reset the recurrence state for an event.

virtual BOOL SetRecurrenceState_NotRecurring();
Returns

Always returns TRUE.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetReminder Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetReminder Method

Call this member function to setup a reminder for this event.

virtual void SetReminder(
    BOOL bReminder
);
Parameters

bReminder
TRUE to enable reminder. FALSE to disable.

Remarks

This function allows to enable/disable firing reminders notifications for this event. This boolean setting corresponds to a checkbox near "Reminder" word in Event details dialog.

See Also

IsReminder()

Body Source
void CXTPCalendarEvent::SetReminder(BOOL bReminder) {
    m_bReminder = bReminder;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetReminderMinutesBeforeStart Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetReminderMinutesBeforeStart Method

This member function is used to set the number of minutes before the start of an event.

virtual void SetReminderMinutesBeforeStart(
    int nMinutes
);
Parameters

nMinutes
An int that contains the number of minutes before the start of an event.

See Also

GetReminderMinutesBeforeStart()

Body Source
void CXTPCalendarEvent::SetReminderMinutesBeforeStart(int nMinutes) {
    m_nReminderMinutesBeforeStart = nMinutes;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetReminderSoundFile Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetReminderSoundFile Method

This member function is used to set the sound file for the event reminder.

virtual void SetReminderSoundFile(
    LPCTSTR pcszFile
);
Parameters

pcszFile
An LPCTSTR object. A pointer to a string with full path to the sound file.

See Also

GetReminderSoundFile()

Body Source
void CXTPCalendarEvent::SetReminderSoundFile(LPCTSTR pcszFile) {
    m_strReminderSoundFile = pcszFile;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetRException_EndTimeOrig Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetRException_EndTimeOrig Method

This member function is used to set the original end time of an exception event.

virtual void SetRException_EndTimeOrig(
    COleDateTime dtEndOrig
);
Parameters

dtEndOrig
A COleDateTime object that contains the original end time of an exception event.

See Also

GetRException_EndTimeOrig, SetRException_StartTimeOrig

Body Source
void CXTPCalendarEvent::SetRException_EndTimeOrig(COleDateTime dtEndOrig) {
    m_dtRException_EndTimeOrig = dtEndOrig;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetRException_StartTimeOrig Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetRException_StartTimeOrig Method

This member function is used to set the original start time of an exception event.

virtual void SetRException_StartTimeOrig(
    COleDateTime dtStartOrig
);
Parameters

dtStartOrig
A COleDateTime object that contains the original start time of the exception event.

See Also

GetRException_StartTimeOrig

Body Source
void CXTPCalendarEvent::SetRException_StartTimeOrig(COleDateTime dtStartOrig) {
    m_dtRException_StartTimeOrig = dtStartOrig;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetRExceptionDeleted Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetRExceptionDeleted Method

Call this member function to mark an exception occurrence as deleted/undeleted.

virtual void SetRExceptionDeleted(
    BOOL bDeleted = TRUE
);
Parameters

bDeleted
A BOOL. Exception deleted flag value.
TRUE
To mark the exception recurrence as deleted.
FALSE
To mark the exception recurrence as un-deleted.

Returns

TRUE if successful. FALSE otherwise.

See Also

IsRExceptionDeleted()

Body Source
void CXTPCalendarEvent::SetRExceptionDeleted(BOOL bDeleted) {
    m_bRExceptionDeleted = bDeleted;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetScheduleID Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetScheduleID Method

This member function is used to set a new schedule ID of the event.

virtual void SetScheduleID(
    UINT uScheduleID
);
Parameters

uScheduleID
An UINT that contains the ScheduleID.

Body Source
void CXTPCalendarEvent::SetScheduleID(UINT uScheduleID) {
    m_uScheduleID = uScheduleID;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetStartTime Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::SetStartTime Method

This member function is used to set the new start date and time for the event. The time is accepted as is, and no any conversions is performed.

virtual void SetStartTime(
    COleDateTime dtStart
);
Parameters

dtStart
A COleDateTime object that contains the new start date value.

See Also

GetStartTime

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::SetSubject Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::SetSubject Method

This member function is used to set the subject text for the event.

virtual void SetSubject(
    LPCTSTR pcszSubject
);
Parameters

pcszSubject
An LPCTSTR object that contains the string of text.

Body Source
void CXTPCalendarEvent::SetSubject(LPCTSTR pcszSubject) {
    m_strSubject = pcszSubject;
}
Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::Update Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::Update Method

Call this member function to update the event's data.

virtual BOOL Update(
    CXTPCalendarEvent* pNewData
);
Parameters

pNewData
Pointer to a CXTPCalendarEvent object that contains the new data.

Returns

TRUE if successful. FALSE otherwise.

See Also

CXTPCalendarEvent

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::UpdateRecurrence Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class, See Also
CXTPCalendarEvent::UpdateRecurrence Method

This member function is used to set the recurrence pattern for the event.

virtual BOOL UpdateRecurrence(
    CXTPCalendarRecurrencePattern* pRPattern
);
Parameters

pRPattern
A pointer to a CXTPCalendarRecurrencePattern object that contains the updated recurrence pattern.

Returns

TRUE if new pattern changed successfully. FALSE otherwise.

See Also

CXTPCalendarRecurrencePattern, RemoveRecurrence

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent::UpdateStartEndDatesFromPatternExceptions Method

CXTPCalendarEvent Methods, CXTPCalendarEvent Class
CXTPCalendarEvent::UpdateStartEndDatesFromPatternExceptions Method

This member function is used to change the date-time values of the start and end dates of the master event using exception occurrences of recurrent events.

virtual BOOL UpdateStartEndDatesFromPatternExceptions();
Returns

TRUE if successful. FALSE otherwise.

Group

CXTPCalendarEvent Methods


CXTPCalendarEvent Constructors

CXTPCalendarEvent Class, Legend, Public Methods
CXTPCalendarEvent Constructors
Class

CXTPCalendarEvent Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEvent | Default object constructor.


CXTPCalendarEvent::CXTPCalendarEvent Constructor

CXTPCalendarEvent Constructors, CXTPCalendarEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvent::CXTPCalendarEvent Constructor

Default object constructor.

CXTPCalendarEvent(
    CXTPCalendarData* pDataProvider
);
Parameters

pDataProvider
Pointer to CXTPCalendarData object.

See Also

~CXTPCalendarEvent()

Group

CXTPCalendarEvent Constructors


CXTPCalendarEvent Destructors

CXTPCalendarEvent Class, Legend, Public Methods
CXTPCalendarEvent Destructors
Class

CXTPCalendarEvent Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarEvent | Default class destructor.


CXTPCalendarEvent::~CXTPCalendarEvent Destructor

CXTPCalendarEvent Destructors, CXTPCalendarEvent Class
CXTPCalendarEvent::~CXTPCalendarEvent Destructor

Default class destructor.

virtual ~CXTPCalendarEvent();
Remarks

Handles member items deallocation. Decreases reference of stored objects: CXTPCalendarEventLabels and CXTPCalendarRecurrencePattern.

Group

CXTPCalendarEvent Destructors


CXTPCalendarEventCategories Class

XTPCalendarEventLabel.h, Classes, Legend, Members, Topics, CXTPCalendarEventCategories Methods, CXTPCalendarEventCategories Constructors, CXTPCalendarEventCategories Destructors, CXTPCalendarEventCategories Constructors, CXTPCalendarEventCategories Destructors, CXTPCalendarEventCategories Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategories Class

This class is used as a collection of CXTPCalendarEventCategory objects.

Class Hierarchy

class CXTPCalendarEventCategories : public CXTPCalendarPtrCollectionT<CXTPCalendarEventCategory>;
File

XTPCalendarEventLabel.h

See Also

CXTPCalendarEventCategory, CXTPCalendarEvent

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarEventCategories Constructors
CXTPCalendarEventCategories Constructors | Description
CXTPCalendarEventCategories | Default class constructor.
CXTPCalendarEventCategories Destructors
CXTPCalendarEventCategories Destructors | Description
~CXTPCalendarEventCategories | Default class destructor.
CXTPCalendarEventCategories Methods
CXTPCalendarEventCategories Methods | Description
Find | This member function is used to search for the event category with a specified ID.
FindIndex | Finds event category index in the collection by its ID.
InitDefaultValues | This member function is used to fill the collection using a default label list.


CXTPCalendarEventCategories Methods

CXTPCalendarEventCategories Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategories Methods
Class

CXTPCalendarEventCategories Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
FindIndex | Finds event category index in the collection by its ID.
Public Methods
Public Methods
Public Method | Description
Find | This member function is used to search for the event category with a specified ID.
InitDefaultValues | This member function is used to fill the collection using a default label list.


CXTPCalendarEventCategories::Find Method

CXTPCalendarEventCategories Methods, CXTPCalendarEventCategories Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategories::Find Method

This member function is used to search for the event category with a specified ID.

virtual CXTPCalendarEventCategory* Find(
    UINT nID
) const;
Parameters

nID
An UINT that contains the category ID.

Returns

A pointer to a CXTPCalendarEventCategory object or NULL.

Group

CXTPCalendarEventCategories Methods


CXTPCalendarEventCategories::FindIndex Method

CXTPCalendarEventCategories Methods, CXTPCalendarEventCategories Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategories::FindIndex Method

Finds event category index in the collection by its ID.

virtual int FindIndex(
    UINT nID
) const;
Parameters

nID
An UINT that contains the category ID.

Returns

Category index in the collection.

See Also

Find

Group

CXTPCalendarEventCategories Methods


CXTPCalendarEventCategories::InitDefaultValues Method

CXTPCalendarEventCategories Methods, CXTPCalendarEventCategories Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategories::InitDefaultValues Method

This member function is used to fill the collection using a default label list.

virtual void InitDefaultValues();
Group

CXTPCalendarEventCategories Methods


CXTPCalendarEventCategories Constructors

CXTPCalendarEventCategories Class, Legend, Public Methods
CXTPCalendarEventCategories Constructors
Class

CXTPCalendarEventCategories Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventCategories | Default class constructor.


CXTPCalendarEventCategories::CXTPCalendarEventCategories Constructor

CXTPCalendarEventCategories Constructors, CXTPCalendarEventCategories Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategories::CXTPCalendarEventCategories Constructor

Default class constructor.

CXTPCalendarEventCategories();
Group

CXTPCalendarEventCategories Constructors


CXTPCalendarEventCategories Destructors

CXTPCalendarEventCategories Class, Legend, Public Methods
CXTPCalendarEventCategories Destructors
Class

CXTPCalendarEventCategories Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarEventCategories | Default class destructor.


CXTPCalendarEventCategories::~CXTPCalendarEventCategories Destructor

CXTPCalendarEventCategories Destructors, CXTPCalendarEventCategories Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategories::~CXTPCalendarEventCategories Destructor

Default class destructor.

virtual ~CXTPCalendarEventCategories();
Remarks

Handles class members deallocation.

Group

CXTPCalendarEventCategories Destructors


CXTPCalendarEventCategory Class

XTPCalendarEventLabel.h, Classes, Legend, Members, Topics, CXTPCalendarEventCategory Data Members, CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Constructors, CXTPCalendarEventCategory Destructors, CXTPCalendarEventCategory Constructors, CXTPCalendarEventCategory Data Members, CXTPCalendarEventCategory Destructors, CXTPCalendarEventCategory Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory Class

This class define Calendar Event Category properties. Visual effects for Event Categories (event and day's cells background colors) implemented in Office 2007 theme only. If one or more categories set for event - the category's colors are used, otherwise label's colors used (is label defined). For Office 2003 theme label's colors used in any case.

Class Hierarchy

class CXTPCalendarEventCategory;
File

XTPCalendarEventLabel.h

See Also

CXTPCalendarEvent, CXTPCalendarEventCategories

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarEventCategory Constructors
CXTPCalendarEventCategory Constructors | Description
CXTPCalendarEventCategory | Default class constructor.
CXTPCalendarEventCategory Data Members
CXTPCalendarEventCategory Data Members | Description
m_clrBkBase | Stores Base color to calculate few background colors for event background and other elements.
m_clrBorder | Stores Event border color.
m_grclrBackground | Stores an event background gradient color.
m_nID | Stores category identifier.
m_strName | Stores category name.
CXTPCalendarEventCategory Destructors
CXTPCalendarEventCategory Destructors | Description
~CXTPCalendarEventCategory | Default class destructor.
CXTPCalendarEventCategory Methods
CXTPCalendarEventCategory Methods | Description
GetBackgroundColor | This member function is used to obtain an event background color.
GetBkBaseColor | This member function is used to obtain a background base color.
GetBkColorAllDayEvents | This member function is used to obtain All Day Events area background color.
GetBkColorNonWorkCell | This member function is used to obtain Day View NonWork Cell background color.
GetBkColorWorkCell | This member function is used to obtain Day View Work Cell background color.
GetBorderColor | This member function is used to obtain an event border color.
GetColorCellBorder | This member function is used to obtain Day View Cell border color.
GetID | This member function is used to obtain a unique category ID.
GetName | This member function is used to obtain a category name.
SetBkBaseColor | This member function is used to set a background base color.
SetBorderColor | This member function is used to set an event border color.
SetID | This member function is used to set a unique category ID.
SetName | This member function is used to set a category name.


CXTPCalendarEventCategory Data Members

CXTPCalendarEventCategory Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory Data Members
Class

CXTPCalendarEventCategory Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrBkBase | Stores Base color to calculate few background colors for event background and other elements.
m_clrBorder | Stores Event border color.
m_grclrBackground | Stores an event background gradient color.
m_nID | Stores category identifier.
m_strName | Stores category name.


CXTPCalendarEventCategory::m_clrBkBase Data Member

CXTPCalendarEventCategory Data Members, CXTPCalendarEventCategory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::m_clrBkBase Data Member

Stores Base color to calculate few background colors for event background and other elements.

COLORREF m_clrBkBase;
Group

CXTPCalendarEventCategory Data Members


CXTPCalendarEventCategory::m_clrBorder Data Member

CXTPCalendarEventCategory Data Members, CXTPCalendarEventCategory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::m_clrBorder Data Member

Stores Event border color.

COLORREF m_clrBorder;
Group

CXTPCalendarEventCategory Data Members


CXTPCalendarEventCategory::m_grclrBackground Data Member

CXTPCalendarEventCategory Data Members, CXTPCalendarEventCategory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::m_grclrBackground Data Member

Stores an event background gradient color.

CXTPPaintManagerColorGradient m_grclrBackground;
Group

CXTPCalendarEventCategory Data Members


CXTPCalendarEventCategory::m_nID Data Member

CXTPCalendarEventCategory Data Members, CXTPCalendarEventCategory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::m_nID Data Member

Stores category identifier.

UINT m_nID;
Group

CXTPCalendarEventCategory Data Members


CXTPCalendarEventCategory::m_strName Data Member

CXTPCalendarEventCategory Data Members, CXTPCalendarEventCategory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::m_strName Data Member

Stores category name.

CString m_strName;
Group

CXTPCalendarEventCategory Data Members


CXTPCalendarEventCategory Methods

CXTPCalendarEventCategory Class, Legend, Public Methods
CXTPCalendarEventCategory Methods
Class

CXTPCalendarEventCategory Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetBackgroundColor | This member function is used to obtain an event background color.
GetBkBaseColor | This member function is used to obtain a background base color.
GetBkColorAllDayEvents | This member function is used to obtain All Day Events area background color.
GetBkColorNonWorkCell | This member function is used to obtain Day View NonWork Cell background color.
GetBkColorWorkCell | This member function is used to obtain Day View Work Cell background color.
GetBorderColor | This member function is used to obtain an event border color.
GetColorCellBorder | This member function is used to obtain Day View Cell border color.
GetID | This member function is used to obtain a unique category ID.
GetName | This member function is used to obtain a category name.
SetBkBaseColor | This member function is used to set a background base color.
SetBorderColor | This member function is used to set an event border color.
SetID | This member function is used to set a unique category ID.
SetName | This member function is used to set a category name.


CXTPCalendarEventCategory::GetBackgroundColor Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetBackgroundColor Method

This member function is used to obtain an event background color.

virtual CXTPPaintManagerColorGradient& GetBackgroundColor();
Returns

An event background gradient color.

See Also

GetBkBaseColor, SetBkBaseColor

Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::GetBkBaseColor Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetBkBaseColor Method

This member function is used to obtain a background base color.

virtual COLORREF GetBkBaseColor() const;
Returns

A background base color.

See Also

SetBkBaseColor

Body Source
COLORREF CXTPCalendarEventCategory::GetBkBaseColor() const {
    return m_clrBkBase;
}
Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::GetBkColorAllDayEvents Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetBkColorAllDayEvents Method

This member function is used to obtain All Day Events area background color.

virtual COLORREF GetBkColorAllDayEvents();
Returns

All Day Events area background color.

See Also

GetBkBaseColor, SetBkBaseColor

Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::GetBkColorNonWorkCell Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetBkColorNonWorkCell Method

This member function is used to obtain Day View NonWork Cell background color.

virtual COLORREF GetBkColorNonWorkCell();
Returns

A Day View NonWork Cell background color.

See Also

GetBkBaseColor, SetBkBaseColor

Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::GetBkColorWorkCell Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetBkColorWorkCell Method

This member function is used to obtain Day View Work Cell background color.

virtual COLORREF GetBkColorWorkCell();
Returns

A Day View Work Cell background color.

See Also

GetBkBaseColor, SetBkBaseColor

Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::GetBorderColor Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetBorderColor Method

This member function is used to obtain an event border color.

virtual COLORREF GetBorderColor() const;
Returns

An event border color.

See Also

SetBorderColor

Body Source
COLORREF CXTPCalendarEventCategory::GetBorderColor() const {
    return m_clrBorder;
}
Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::GetColorCellBorder Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetColorCellBorder Method

This member function is used to obtain Day View Cell border color.

virtual COLORREF GetColorCellBorder();
Returns

A Day View Cell border color.

See Also

GetBkBaseColor, SetBkBaseColor

Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::GetID Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetID Method

This member function is used to obtain a unique category ID.

virtual UINT GetID() const;
Returns

A unique category ID.

See Also

SetID

Body Source
UINT CXTPCalendarEventCategory::GetID() const {
    return m_nID;
}
Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::GetName Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::GetName Method

This member function is used to obtain a category name.

virtual LPCTSTR GetName() const;
Returns

A category name.

See Also

SetName

Body Source
LPCTSTR CXTPCalendarEventCategory::GetName() const {
    return m_strName;
}
Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::SetBkBaseColor Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::SetBkBaseColor Method

This member function is used to set a background base color.

virtual void SetBkBaseColor(
    COLORREF clrColor
);
Parameters

clrColor
A background base color.

See Also

GetBkBaseColor

Body Source
void CXTPCalendarEventCategory::SetBkBaseColor(COLORREF clrColor) {
    m_clrBkBase = clrColor;
}
Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::SetBorderColor Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::SetBorderColor Method

This member function is used to set an event border color.

virtual void SetBorderColor(
    COLORREF clrColor
);
Parameters

clrColor
An event border color.

See Also

GetBorderColor

Body Source
void CXTPCalendarEventCategory::SetBorderColor(COLORREF clrColor) {
    m_clrBorder = clrColor;
}
Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::SetID Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::SetID Method

This member function is used to set a unique category ID.

virtual void SetID(
    UINT nID
);
Parameters

nID
A unique category ID.

See Also

GetID

Body Source
void CXTPCalendarEventCategory::SetID(UINT nID) {
    m_nID = nID;
}
Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory::SetName Method

CXTPCalendarEventCategory Methods, CXTPCalendarEventCategory Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::SetName Method

This member function is used to set a category name.

virtual void SetName(
    LPCTSTR pcszName
);
Parameters

pcszName
A category name.

See Also

GetName

Body Source
void CXTPCalendarEventCategory::SetName(LPCTSTR pcszName) {
    m_strName = pcszName;
}
Group

CXTPCalendarEventCategory Methods


CXTPCalendarEventCategory Constructors

CXTPCalendarEventCategory Class, Legend, Public Methods
CXTPCalendarEventCategory Constructors
Class

CXTPCalendarEventCategory Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventCategory | Default class constructor.


CXTPCalendarEventCategory::CXTPCalendarEventCategory Constructor

CXTPCalendarEventCategory Constructors, CXTPCalendarEventCategory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::CXTPCalendarEventCategory Constructor

Default class constructor.

CXTPCalendarEventCategory(
    UINT nID = 0,
    LPCTSTR pcszName = _T(""),
    COLORREF clrBorder = 0,
    COLORREF clrBkBase = 0
);
Parameters

nID
Category identifier.
pcszName
Category name.
clrBorder
Event border color.
clrBkBase
Base color to calculate few background colors for event background and other elements.

Group

CXTPCalendarEventCategory Constructors


CXTPCalendarEventCategory Destructors

CXTPCalendarEventCategory Class, Legend, Public Methods
CXTPCalendarEventCategory Destructors
Class

CXTPCalendarEventCategory Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarEventCategory | Default class destructor.


CXTPCalendarEventCategory::~CXTPCalendarEventCategory Destructor

CXTPCalendarEventCategory Destructors, CXTPCalendarEventCategory Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategory::~CXTPCalendarEventCategory Destructor

Default class destructor.

virtual ~CXTPCalendarEventCategory();
Group

CXTPCalendarEventCategory Destructors


CXTPCalendarEventCategoryIDs Class

XTPCalendarEventLabel.h, Classes, Legend, Members, Topics, CXTPCalendarEventCategoryIDs Methods, CXTPCalendarEventCategoryIDs Constructors, CXTPCalendarEventCategoryIDs Destructors, CXTPCalendarEventCategoryIDs Constructors, CXTPCalendarEventCategoryIDs Destructors, CXTPCalendarEventCategoryIDs Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategoryIDs Class

This class represents the collection of event categories IDs.

Class Hierarchy

class CXTPCalendarEventCategoryIDs : public CXTPCalendarUIntArray;
File

XTPCalendarEventLabel.h

Remarks

It also implements and some useful operations.

Group

Classes

Legend
Method
virtual
CXTPCalendarEventCategoryIDs Constructors
CXTPCalendarEventCategoryIDs Constructors | Description
CXTPCalendarEventCategoryIDs | Default object constructor.
CXTPCalendarEventCategoryIDs Destructors
CXTPCalendarEventCategoryIDs Destructors | Description
~CXTPCalendarEventCategoryIDs | Default object destructor.
CXTPCalendarEventCategoryIDs Methods
CXTPCalendarEventCategoryIDs Methods | Description
DoPropExchange | Call this member function to Store/Load a collection data using the specified data object.


CXTPCalendarEventCategoryIDs Methods

CXTPCalendarEventCategoryIDs Class, Legend, Public Methods
CXTPCalendarEventCategoryIDs Methods
Class

CXTPCalendarEventCategoryIDs Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Call this member function to Store/Load a collection data using the specified data object.


CXTPCalendarEventCategoryIDs::DoPropExchange Method

CXTPCalendarEventCategoryIDs Methods, CXTPCalendarEventCategoryIDs Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategoryIDs::DoPropExchange Method

Call this member function to Store/Load a collection data using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Remarks

This member function is used to store or load event data to or from a storage.

Body Source
void CXTPCalendarEventCategoryIDs::DoPropExchange(CXTPPropExchange* pPX) {
    TBase::DoPropExchange(pPX, _T("EventCategories"), _T("CategoryID"));
}
Group

CXTPCalendarEventCategoryIDs Methods


CXTPCalendarEventCategoryIDs Constructors

CXTPCalendarEventCategoryIDs Class, Legend, Public Methods
CXTPCalendarEventCategoryIDs Constructors
Class

CXTPCalendarEventCategoryIDs Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventCategoryIDs | Default object constructor.


CXTPCalendarEventCategoryIDs::CXTPCalendarEventCategoryIDs Constructor

CXTPCalendarEventCategoryIDs Constructors, CXTPCalendarEventCategoryIDs Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategoryIDs::CXTPCalendarEventCategoryIDs Constructor

Default object constructor.

CXTPCalendarEventCategoryIDs();
Group

CXTPCalendarEventCategoryIDs Constructors


CXTPCalendarEventCategoryIDs Destructors

CXTPCalendarEventCategoryIDs Class, Legend, Public Methods
CXTPCalendarEventCategoryIDs Destructors
Class

CXTPCalendarEventCategoryIDs Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarEventCategoryIDs | Default object destructor.


CXTPCalendarEventCategoryIDs::~CXTPCalendarEventCategoryIDs Destructor

CXTPCalendarEventCategoryIDs Destructors, CXTPCalendarEventCategoryIDs Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventCategoryIDs::~CXTPCalendarEventCategoryIDs Destructor

Default object destructor.

virtual ~CXTPCalendarEventCategoryIDs();
Group

CXTPCalendarEventCategoryIDs Destructors


CXTPCalendarEventLabel Class

XTPCalendarEventLabel.h, Classes, Legend, Members, Topics, CXTPCalendarEventLabel Data Members, CXTPCalendarEventLabel Constructors, CXTPCalendarEventLabel Destructors, CXTPCalendarEventLabel Operators, CXTPCalendarEventLabel Constructors, CXTPCalendarEventLabel Data Members, CXTPCalendarEventLabel Destructors, CXTPCalendarEventLabel Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabel Class

This class define Calendar Event label properties.

Class Hierarchy

class CXTPCalendarEventLabel;
File

XTPCalendarEventLabel.h

See Also

CXTPCalendarEvent

Group

Classes

Legend
Data Member
Constructor
virtual
Operator
CXTPCalendarEventLabel Constructors
CXTPCalendarEventLabel Constructors | Description
CXTPCalendarEventLabel | Default class constructor.
CXTPCalendarEventLabel Data Members
CXTPCalendarEventLabel Data Members | Description
m_clrColor | Label color used to fill the event background.
m_nLabelID | Label ID.
m_strName | Label name.
CXTPCalendarEventLabel Destructors
CXTPCalendarEventLabel Destructors | Description
~CXTPCalendarEventLabel | Default class destructor.
CXTPCalendarEventLabel Operators
CXTPCalendarEventLabel Operators | Description
= | This member function is used to set new object properties.


CXTPCalendarEventLabel Data Members

CXTPCalendarEventLabel Class, Legend, Public Data Members
CXTPCalendarEventLabel Data Members
Class

CXTPCalendarEventLabel Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrColor | Label color used to fill the event background.
m_nLabelID | Label ID.
m_strName | Label name.


CXTPCalendarEventLabel::m_clrColor Data Member

CXTPCalendarEventLabel Data Members, CXTPCalendarEventLabel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabel::m_clrColor Data Member

Label color used to fill the event background.

COLORREF m_clrColor;
Group

CXTPCalendarEventLabel Data Members


CXTPCalendarEventLabel::m_nLabelID Data Member

CXTPCalendarEventLabel Data Members, CXTPCalendarEventLabel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabel::m_nLabelID Data Member

Label ID.

int m_nLabelID;
Group

CXTPCalendarEventLabel Data Members


CXTPCalendarEventLabel::m_strName Data Member

CXTPCalendarEventLabel Data Members, CXTPCalendarEventLabel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabel::m_strName Data Member

Label name.

CString m_strName;
Group

CXTPCalendarEventLabel Data Members


CXTPCalendarEventLabel Constructors

CXTPCalendarEventLabel Class, Legend, Public Methods
CXTPCalendarEventLabel Constructors
Class

CXTPCalendarEventLabel Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventLabel | Default class constructor.


CXTPCalendarEventLabel::CXTPCalendarEventLabel Constructor

CXTPCalendarEventLabel Constructors, CXTPCalendarEventLabel Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabel::CXTPCalendarEventLabel Constructor

Default class constructor.

CXTPCalendarEventLabel(
    int nID = 0,
    COLORREF clrColor = 0,
    LPCTSTR pcszName = _T("")
);
Parameters

nID
Label ID.
clrColor
Label color.
pcszName
Label name.

Group

CXTPCalendarEventLabel Constructors


CXTPCalendarEventLabel Destructors

CXTPCalendarEventLabel Class, Legend, Public Methods
CXTPCalendarEventLabel Destructors
Class

CXTPCalendarEventLabel Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarEventLabel | Default class destructor.


CXTPCalendarEventLabel::~CXTPCalendarEventLabel Destructor

CXTPCalendarEventLabel Destructors, CXTPCalendarEventLabel Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabel::~CXTPCalendarEventLabel Destructor

Default class destructor.

virtual ~CXTPCalendarEventLabel();
Remarks

Handles class member deallocation.

Body Source
virtual ~CXTPCalendarEventLabel() {}
Group

CXTPCalendarEventLabel Destructors


CXTPCalendarEventLabel Operators

CXTPCalendarEventLabel Class, Legend, Public Operators
CXTPCalendarEventLabel Operators
Class

CXTPCalendarEventLabel Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This member function is used to set new object properties.


CXTPCalendarEventLabel::= Operator

CXTPCalendarEventLabel Operators, CXTPCalendarEventLabel Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabel::= Operator

This member function is used to set new object properties.

const CXTPCalendarEventLabel& operator =(
    const CXTPCalendarEventLabel& rSrc
);
Parameters

rSrc
Reference to the source object.

Returns

Reference to this class instance.

Remarks

This is the overloaded assignment operator.

Body Source
const CXTPCalendarEventLabel& operator=(const CXTPCalendarEventLabel& rSrc)
{
    m_nLabelID = rSrc.m_nLabelID;
    m_clrColor = rSrc.m_clrColor;
    m_strName = rSrc.m_strName;

    return *this;
}
Group

CXTPCalendarEventLabel Operators


CXTPCalendarEventLabels Class

XTPCalendarEventLabel.h, Classes, Legend, Members, Topics, CXTPCalendarEventLabels Methods, CXTPCalendarEventLabels Constructors, CXTPCalendarEventLabels Destructors, CXTPCalendarEventLabels Constructors, CXTPCalendarEventLabels Destructors, CXTPCalendarEventLabels Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabels Class

This class is used as a collection of CXTPCalendarEventLabel objects.

Class Hierarchy

class CXTPCalendarEventLabels : public CXTPCalendarPtrCollectionT<CXTPCalendarEventLabel>;
File

XTPCalendarEventLabel.h

See Also

CXTPCalendarEventLabel, CXTPCalendarEvent

Group

Classes

Legend
Method
protected
virtual
CXTPCalendarEventLabels Constructors
CXTPCalendarEventLabels Constructors | Description
CXTPCalendarEventLabels | Default class constructor.
CXTPCalendarEventLabels Destructors
CXTPCalendarEventLabels Destructors | Description
~CXTPCalendarEventLabels | Default class destructor.
CXTPCalendarEventLabels Methods
CXTPCalendarEventLabels Methods | Description
Find | This member function is used to search for the label with a specified ID.
FindIndex | Finds label index in the internal array by its ID.
InitDefaultValues | This member function is used to fill the collection using a default label list.


CXTPCalendarEventLabels Methods

CXTPCalendarEventLabels Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabels Methods
Class

CXTPCalendarEventLabels Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
FindIndex | Finds label index in the internal array by its ID.
Public Methods
Public Methods
Public Method | Description
Find | This member function is used to search for the label with a specified ID.
InitDefaultValues | This member function is used to fill the collection using a default label list.


CXTPCalendarEventLabels::Find Method

CXTPCalendarEventLabels Methods, CXTPCalendarEventLabels Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabels::Find Method

This member function is used to search for the label with a specified ID.

CXTPCalendarEventLabel* Find(
    int nLabelID
) const;
Parameters

nLabelID
An int that contains the label ID.

Returns

A pointer to a CXTPCalendarEventLabel object or NULL.

Group

CXTPCalendarEventLabels Methods


CXTPCalendarEventLabels::FindIndex Method

CXTPCalendarEventLabels Methods, CXTPCalendarEventLabels Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabels::FindIndex Method

Finds label index in the internal array by its ID.

int FindIndex(
    int nLabelID
) const;
Parameters

nLabelID
Label ID

Returns

Label index in the internal label array.

See Also

Find

Group

CXTPCalendarEventLabels Methods


CXTPCalendarEventLabels::InitDefaultValues Method

CXTPCalendarEventLabels Methods, CXTPCalendarEventLabels Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabels::InitDefaultValues Method

This member function is used to fill the collection using a default label list.

virtual void InitDefaultValues();
Group

CXTPCalendarEventLabels Methods


CXTPCalendarEventLabels Constructors

CXTPCalendarEventLabels Class, Legend, Public Methods
CXTPCalendarEventLabels Constructors
Class

CXTPCalendarEventLabels Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventLabels | Default class constructor.


CXTPCalendarEventLabels::CXTPCalendarEventLabels Constructor

CXTPCalendarEventLabels Constructors, CXTPCalendarEventLabels Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabels::CXTPCalendarEventLabels Constructor

Default class constructor.

CXTPCalendarEventLabels();
Group

CXTPCalendarEventLabels Constructors


CXTPCalendarEventLabels Destructors

CXTPCalendarEventLabels Class, Legend, Public Methods
CXTPCalendarEventLabels Destructors
Class

CXTPCalendarEventLabels Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarEventLabels | Default class destructor.


CXTPCalendarEventLabels::~CXTPCalendarEventLabels Destructor

CXTPCalendarEventLabels Destructors, CXTPCalendarEventLabels Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEventLabels::~CXTPCalendarEventLabels Destructor

Default class destructor.

virtual ~CXTPCalendarEventLabels();
Remarks

Handles class members deallocation.

Group

CXTPCalendarEventLabels Destructors


CXTPCalendarEvents Class

XTPCalendarEvents.h, Classes, Legend, Members, Topics, CXTPCalendarEvents Data Members, CXTPCalendarEvents Methods, CXTPCalendarEvents Constructors, CXTPCalendarEvents Destructors, CXTPCalendarEvents Nested Types, CXTPCalendarEvents Constructors, CXTPCalendarEvents Data Members, CXTPCalendarEvents Destructors, CXTPCalendarEvents Methods, CXTPCalendarEvents Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents Class

This class represents a simple array collection of CXTPCalendarEvent objects.

Class Hierarchy

class CXTPCalendarEvents;
File

XTPCalendarEvents.h

Remarks

Array indexes always start at position 0.

As with a C array, the access time for indexed element of this array is constant and is independent of the array size.

Methods Add(), SetAt(), and Append() call InternalAddRef() for the added event. Methods Get(), and Find() do not call InternalAddRef() for the returned event. Methods RemoveAt(), RemoveBy(), RemoveAll(), and the destructor call InternalRelease() for the removed events.

See Also

CArray overview, CXTPCalendarEvent overview.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarEvents Constructors
CXTPCalendarEvents Constructors | Description
CXTPCalendarEvents | Default collection constructor.
CXTPCalendarEvents Data Members
CXTPCalendarEvents Data Members | Description
m_arEvents | An internal storage for CXTPCalendarEvent pointers.
CXTPCalendarEvents Destructors
CXTPCalendarEvents Destructors | Description
~CXTPCalendarEvents | Default collection destructor.
CXTPCalendarEvents Methods
CXTPCalendarEvents Methods | Description
Add | This member function is used to add a new event element to the end of an array.
Append | Adds a new events element to the end of an array.
CloneEvents | Clone events in the collection.
CompareEvents_ByID | This member function is used to compare specified events by the event's IDs.
CompareEvents_ForView | This member function is used to compare specified events so that the events are displayed properly in the event's views.
Find |
FindEvent |
GetAt | Call this method to get an event at the specified numeric index.
GetCount | This member function is used to obtain the number of CXTPCalendarEvent elements in this collection.
InsertAt | Inserts an element at a specified index.
RemoveAll | This function is used to remove all of the elements from this array.
RemoveAt | Removes an element of the specified index from this array.
RemoveByID | This member function is used to find and remove an event using EventID in this array.
SetAt | This member function is used to set a new event element to the position specified in the nIndex parameter.
SetSize | Set size of the array.
Sort | This member function is used to sort events in this array.
CXTPCalendarEvents Nested Types
CXTPCalendarEvents Nested Types | Description
T_CompareFunc | Define a function pointer for comparing events.


CXTPCalendarEvents Data Members

CXTPCalendarEvents Class, Legend, Protected Data Members
CXTPCalendarEvents Data Members
Class

CXTPCalendarEvents Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arEvents | An internal storage for CXTPCalendarEvent pointers.


CXTPCalendarEvents::m_arEvents Data Member

CXTPCalendarEvents Data Members, CXTPCalendarEvents Class
CXTPCalendarEvents::m_arEvents Data Member

An internal storage for CXTPCalendarEvent pointers.

CArray<CXTPCalendarEvent*, CXTPCalendarEvent*> m_arEvents;
Group

CXTPCalendarEvents Data Members


CXTPCalendarEvents Methods

CXTPCalendarEvents Class, Legend, Public Methods
CXTPCalendarEvents Methods
Class

CXTPCalendarEvents Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add | This member function is used to add a new event element to the end of an array.
Append | Adds a new events element to the end of an array.
CloneEvents | Clone events in the collection.
CompareEvents_ByID | This member function is used to compare specified events by the event's IDs.
CompareEvents_ForView | This member function is used to compare specified events so that the events are displayed properly in the event's views.
Find |
FindEvent |
GetAt | Call this method to get an event at the specified numeric index.
GetCount | This member function is used to obtain the number of CXTPCalendarEvent elements in this collection.
InsertAt | Inserts an element at a specified index.
RemoveAll | This function is used to remove all of the elements from this array.
RemoveAt | Removes an element of the specified index from this array.
RemoveByID | This member function is used to find and remove an event using EventID in this array.
SetAt | This member function is used to set a new event element to the position specified in the nIndex parameter.
SetSize | Set size of the array.
Sort | This member function is used to sort events in this array.


CXTPCalendarEvents::Add Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::Add Method

This member function is used to add a new event element to the end of an array.

void Add(
    CXTPCalendarEvent* pNewEvent,
    BOOL bWithAddRef = TRUE
);
Parameters

pNewEvent
The event element to add to this array.
bWithAddRef
If this parameter is TRUE, then InternalAddRef() is called for the pNewEvent, otherwise InternalAddRef() is not called. The default value is TRUE.

Remarks

Use this method to add the specified event pointer to the end of the events collection. Reference to the new object is increased or decreased depending on the value of the bWithAddRef parameter.

See Also

GetAt, RemoveAll, GetCount, CXTPCalendarEvents overview, CXTPCalendarEvent overview.

Example
// CXTPCalendarEvents - derived class
CXTPCalendarEvents* pList = new CXTPCalendarEvents();
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

// Add() will call InernalAddRef()
pList->Add(ptrEvent1);

// Add() will not call InernalAddRef()
pList->Add(new CXTPCalendarEvent(), FALSE);

// GetAt() will call InernalAddRef()
CXTPCalendarEventPtr ptrEvent0 = pList->GetAt(0, TRUE);

// GetAt() will not call InernalAddRef()
CXTPCalendarEvent* pEvent1 = pList->GetAt(1);

ASSERT(2 == pList->GetCount());

//RemoveAll() will call InernalRelease() for all objects
pList->RemoveAll();

ASSERT(0 == pList->GetCount());
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::Append Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::Append Method

Adds a new events element to the end of an array.

void Append(
    CXTPCalendarEvents* pEventsArray
);
Parameters

pEventsArray
The pointer to the collection of event elements to add to this array.

Remarks

Use this method to add event elements from the specified array to the end of the events collection. Reference to the new object is increased by default. This depends on the array constructor parameter. See array constructor CXTPCalendarEvents(BOOL bWithAddRefRelease = TRUE);

See Also

CXTPCalendarEvents overview, GetAt, RemoveAll, GetCount, constructor CXTPCalendarEvents, CXTPCalendarEvents overview, CXTPCalendarEvents overview, CXTPCalendarEvent overview, CXTPCalendarEvent overview

Example
// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents1;
CXTPCalendarEventsPtr ptrEvents2 = new CXTPCalendarEvents();
...
ptrEvents2->Append(&arEvents1);
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::CloneEvents Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::CloneEvents Method

Clone events in the collection.

void CloneEvents();
Remarks

This function pointer is used to replace events objects to their clones. If there is not enough memory to clone some events they are removed from the collection.

See Also

CXTPCalendarEvent::CloneEvent()

Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::CompareEvents_ByID Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::CompareEvents_ByID Method

This member function is used to compare specified events by the event's IDs.

static int _cdecl CompareEvents_ByID(
    const CXTPCalendarEvent** ppEv1,
    const CXTPCalendarEvent** ppEv2
);
Parameters

ppEv1
Pointer to the first event pointer.
ppEv2
Pointer to the second event pointer.

Remarks

This function is used as a parameter for the Sort method to sort events using EventIDs in ascending order. This is useful for performing a fast search for an event ID.

See Also

method CXTPCalendarEvents::Sort overview, CompareEvents_ForView function

Example

See example for CXTPCalendarEvents::Sort method.

Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::CompareEvents_ForView Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::CompareEvents_ForView Method

This member function is used to compare specified events so that the events are displayed properly in the event's views.

static int _cdecl CompareEvents_ForView(
    const CXTPCalendarEvent** ppEv1,
    const CXTPCalendarEvent** ppEv2
);
Parameters

ppEv1
Pointer to the first event.
ppEv2
Pointer to the second event.

Remarks

This function is used as a parameter for the Sort method to sort events in the order needed to display the events in the event's views.

See Also

method CXTPCalendarEvents::Sort overview, CompareEvents_ByID function

Example

See example for CXTPCalendarEvents::Sort method.

Group

CXTPCalendarEvents Methods


Find Method

CXTPCalendarEvents Methods
Find Method
Overload List
Methods
Method | Description
CXTPCalendarEvents::Find (CXTPCalendarEvent*) | This method is used to find an event using the EventID in this array.
CXTPCalendarEvents::Find (DWORD) | This method is used to find an event using the EventID in this array.
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::Find Method (CXTPCalendarEvent*)

Find Method, CXTPCalendarEvents Class, Example, See Also
CXTPCalendarEvents::Find Method (CXTPCalendarEvent*)

This method is used to find an event using the EventID in this array.

int Find(
    CXTPCalendarEvent* pFEvent
) const;
int Find(
    DWORD dwEventID
) const;
Parameters

pFEvent
A pointer to a CXTPCalendarEvent object that contains the event object.
dwEventID
A DWORD that contains the unique event ID.

Returns

The zero-based index of the first event in the collection that matches the requested dwEventID. -1 if the event is not found.

Remarks

When using dwEventID - This method searches this collection for the first match of an event object with event ID equal to dwEventID. When using pFEvent - This method searches this collection for the first match of a event object with identifiers equal to identifiers of the pFEvent. If there are no recurrence events, then these are Event IDs. For recurrence events, then these are RecurrencePatternID, Start/End times, or RException_StartTimeOrig/RException_EndTimeOrig. For details see implementation CXTPCalendarEvent::IsEqualIDs()

See Also

CXTPCalendarEvents overview, constructor CXTPCalendarEvents, CXTPCalendarEvents overview, CXTPCalendarEvents overview, CXTPCalendarEvent overview, CXTPCalendarEvent overview

Example
// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
CXTPCalendarEvent* pEvent;
...
if (arEvents.Find(pEvent->GetEventID()) < 0) {
    arEvents.Add(pEvent);
}
Group

Find Method


FindEvent Method

CXTPCalendarEvents Methods
FindEvent Method
Overload List
Methods
Method | Description
CXTPCalendarEvents::FindEvent (CXTPCalendarEvent*) | This member function is used to find an event using the EventID in this array.
CXTPCalendarEvents::FindEvent (DWORD) | This member function is used to find an event using the EventID in this array.
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::FindEvent Method (DWORD)

FindEvent Method, CXTPCalendarEvents Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::FindEvent Method (DWORD)

This member function is used to find an event using the EventID in this array.

CXTPCalendarEvent* FindEvent(
    DWORD dwEventID
) const;
CXTPCalendarEvent* FindEvent(
    CXTPCalendarEvent* pFEvent
) const;
Parameters

dwEventID
A DWORD that contains the unique event ID.
pFEvent
A CXTPCalendarEvent pointer that contains the event object to compare.

Returns

The pointer to the first event in the collection that matches the requested dwEventID; NULL if the event is not found.

Remarks

When using dwEventID - This method searches this collection for the first match of a event object with event ID equal to dwEventID. Reference to the returned object is not increased. When using pFEvent - This method searches this collection for the first match of a event object with identifiers equal to identifiers of the pFEvent. In the case of no recurrence events these are EventIDs. In the case of recurrence events these are RecurrencePatternIDs, Start/End times or RException_StartTimeOrig/RException_EndTimeOrig. For details see implementation CXTPCalendarEvent::IsEqualIDs() Reference to the returned object is not increased by default.

See Also

CXTPCalendarEvents overview, CXTPCalendarEvent overview,

Example
// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
CXTPCalendarEvent* pEvent;
...
CXTPCalendarEvent* pEvent2;
pEvent2 = arEvents.Find(pEvent->GetEventID());
if (pEvent2) {
    pEvent2.Update(pEvent);
}
Group

FindEvent Method


CXTPCalendarEvents::GetAt Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::GetAt Method

Call this method to get an event at the specified numeric index.

CXTPCalendarEvent* GetAt(
    int nIndex,
    BOOL bWithAddRef = FALSE
) const;
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
bWithAddRef
If this parameter is TRUE the InternalAdRef() will be called for the returned object, otherwise it will not be called. The default value is FALSE.

Returns

The pointer to the CXTPCalendarEvent element currently at this index.

Remarks

Reference to the returned object is increased or not depending on bWithAddRef parameter. Returns the array element at the specified index.

Example

See example for CXTPCalendarEvents::Add method.

Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::GetCount Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::GetCount Method

This member function is used to obtain the number of CXTPCalendarEvent elements in this collection.

int GetCount() const;
Returns

An int that contains the number of items in the collection.

Remarks

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

See Also

CXTPCalendarEvents overview

Example

See example for CXTPCalendarEvents::Add method.

Body Source
int CXTPCalendarEvents::GetCount() const {
    return (int)m_arEvents.GetSize();
}
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::InsertAt Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::InsertAt Method

Inserts an element at a specified index.

void InsertAt(
    int nIndex,
    CXTPCalendarEvent* pEvent,
    BOOL bWithAddRef = TRUE
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and may be greater than the value returned by GetCount.
pEvent
Pointer to the event to insert.
bWithAddRef
Set this value to TRUE to increment the reference count of the inserted object, FALSE to insert object without incrementing reference count. Default value is TRUE.

Remarks

Inserts one element at a specified index in an array. In the process, it shifts up (by incrementing the index) the existing element at this index, and it shifts up all the elements above it.

See Also

CXTPCalendarEvents overview

Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::RemoveAll Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::RemoveAll Method

This function is used to remove all of the elements from this array.

void RemoveAll();
Remarks

Removes all of the pointers from this array. Reference to removed objects are decreased by default.

See Also

CXTPCalendarEvents overview

Example

See example for CXTPCalendarEvents::Add method.

Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::RemoveAt Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::RemoveAt Method

Removes an element of the specified index from this array.

void RemoveAt(
    int nIndex
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.

Remarks

Removes the pointer from this array. Reference to the removed object is decreased by default.

See Also

CXTPCalendarEvents overview

Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::RemoveByID Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::RemoveByID Method

This member function is used to find and remove an event using EventID in this array.

BOOL RemoveByID(
    DWORD dwEventID
);
Parameters

dwEventID
A DWORD containing a unique event ID.

Returns

TRUE - if the event is found and removed. FALSE - if the event is not found.

Remarks

This method searches this collection for the first match of an event object with the event ID equal to dwEventID and removes the object from the collection..

See Also

CXTPCalendarEvents overview, constructor CXTPCalendarEvents, CXTPCalendarEvents overview, CXTPCalendarEvents overview, CXTPCalendarEvent overview, CXTPCalendarEvent overview

Example
// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
DWORD dwEventIDToRemove;
...
if (arEvents.RemoveByID(dwEventIDToRemove) < 0) {
 ...
}
Body Source
BOOL CXTPCalendarEvents::RemoveByID(DWORD dwEventID) {
    int nFIndex = Find(dwEventID);
    if (nFIndex >= 0) {
        RemoveAt(nFIndex);
    }
    return (nFIndex >= 0);
}
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::SetAt Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::SetAt Method

This member function is used to set a new event element to the position specified in the nIndex parameter.

void SetAt(
    int nIndex,
    CXTPCalendarEvent* pEvent,
    BOOL bWithAddRef = TRUE
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
pEvent
The event element to add to this array.
bWithAddRef
If this parameter is TRUE, then InternalAddRef() is called for the pEvent object, otherwise InternalAddRef() is not called.

Remarks

Use this method to set the specified event pointer to the position specified in the nIndex parameter. Reference to the previous object is decreased by default. This depends on the array constructor parameter. See the array constructor CXTPCalendarEvents(BOOL bWithAddRefRelease = TRUE); Reference to the new object is increased or decreased depending on the bWithAddRef parameter.

See Also

CXTPCalendarEvents overview, constructor CXTPCalendarEvents, CXTPCalendarEvents overview, CXTPCalendarEvents overview, CXTPCalendarEvent overview, CXTPCalendarEvent overview

Example
// CXTPCalendarEvents - derived class
CXTPCalendarEvents* pList = new CXTPCalendarEvents();
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

pList->Add(ptrEvent1);
pList->SetAt(0, new CXTPCalendarEvent(), FALSE);
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::SetSize Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::SetSize Method

Set size of the array.

void SetSize(
    int nNewSize,
    int nGrowBy = -1
);
Parameters

nNewSize
A new array size (elements count).
nGrowBy
Amount of elements to grow array when Add and InsertAt methods used. -1 (by default) means using default parameter value.

See Also

GetCount, RemoveAll

Body Source
void CXTPCalendarEvents::SetSize(int nNewSize, int nGrowBy)
{
    m_arEvents.SetSize(nNewSize, nGrowBy);
}
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents::Sort Method

CXTPCalendarEvents Methods, CXTPCalendarEvents Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::Sort Method

This member function is used to sort events in this array.

void Sort(
    T_CompareFunc pCompareFunc
);
Parameters

pCompareFunc
A T_CompareFunc function pointer that is used to compare events.

Remarks

This method sorts events in this collection using specified compare events function. The QuickSort algorithm is used.

See Also

CXTPCalendarEvents overview, CXTPCalendarEvents overview, CXTPCalendarEvents overview, CXTPCalendarEvent overview, CXTPCalendarEvent overview, CompareEvents_ForView function, CompareEvents_ByID function, qsort() function in the stdlib.h

Example
CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
...
arEvents.Sort(CompareEvents_ForView);
...
Group

CXTPCalendarEvents Methods


CXTPCalendarEvents Constructors

CXTPCalendarEvents Class, Legend, Public Methods
CXTPCalendarEvents Constructors
Class

CXTPCalendarEvents Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEvents | Default collection constructor.


CXTPCalendarEvents::CXTPCalendarEvents Constructor

CXTPCalendarEvents Constructors, CXTPCalendarEvents Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::CXTPCalendarEvents Constructor

Default collection constructor.

CXTPCalendarEvents();
See Also

~CXTPCalendarEvents()

Group

CXTPCalendarEvents Constructors


CXTPCalendarEvents Destructors

CXTPCalendarEvents Class, Legend, Public Methods
CXTPCalendarEvents Destructors
Class

CXTPCalendarEvents Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarEvents | Default collection destructor.


CXTPCalendarEvents::~CXTPCalendarEvents Destructor

CXTPCalendarEvents Destructors, CXTPCalendarEvents Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::~CXTPCalendarEvents Destructor

Default collection destructor.

virtual ~CXTPCalendarEvents();
Remarks

Handles member item deallocation. Decreases reference of all stored CXTPCalendarEvent objects.

See Also

RemoveAll()

Group

CXTPCalendarEvents Destructors


CXTPCalendarEvents Nested Types

CXTPCalendarEvents Class, Public Nested Types
CXTPCalendarEvents Nested Types
Class

CXTPCalendarEvents Class

Public Nested Types
Public Nested Type | Description
T_CompareFunc | Define a function pointer for comparing events.


CXTPCalendarEvents::T_CompareFunc Nested Type

CXTPCalendarEvents Nested Types, CXTPCalendarEvents Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarEvents::T_CompareFunc Nested Type

Define a function pointer for comparing events.

typedef int (_cdecl * T_CompareFunc)(const CXTPCalendarEvent** ppEv1, const CXTPCalendarEvent** ppEv2);
Remarks

This function pointer is used in the Sort method.

See Also

Sort method, CompareEvents_ForView function, CompareEvents_ByID function

Group

CXTPCalendarEvents Nested Types


CXTPCalendarIconIDs Class

XTPCalendarEventLabel.h, Classes, Legend, Members, Topics, CXTPCalendarIconIDs Methods, CXTPCalendarIconIDs Constructors, CXTPCalendarIconIDs Destructors, CXTPCalendarIconIDs Constructors, CXTPCalendarIconIDs Destructors, CXTPCalendarIconIDs Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarIconIDs Class

This class represents the collection of custom icons IDs.

Class Hierarchy

class CXTPCalendarIconIDs : public CXTPCalendarUIntArray;
File

XTPCalendarEventLabel.h

Remarks

It also implements and some useful operations on custom icons IDs collection.

Group

Classes

Legend
Method
virtual
CXTPCalendarIconIDs Constructors
CXTPCalendarIconIDs Constructors | Description
CXTPCalendarIconIDs | Default object constructor.
CXTPCalendarIconIDs Destructors
CXTPCalendarIconIDs Destructors | Description
~CXTPCalendarIconIDs | Default object destructor.
CXTPCalendarIconIDs Methods
CXTPCalendarIconIDs Methods | Description
DoPropExchange | Call this member function to Store/Load a collection data using the specified data object.


CXTPCalendarIconIDs Methods

CXTPCalendarIconIDs Class, Legend, Public Methods
CXTPCalendarIconIDs Methods
Class

CXTPCalendarIconIDs Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Call this member function to Store/Load a collection data using the specified data object.


CXTPCalendarIconIDs::DoPropExchange Method

CXTPCalendarIconIDs Methods, CXTPCalendarIconIDs Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarIconIDs::DoPropExchange Method

Call this member function to Store/Load a collection data using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Remarks

This member function is used to store or load event data to or from a storage.

Body Source
void CXTPCalendarIconIDs::DoPropExchange(CXTPPropExchange* pPX) {
    TBase::DoPropExchange(pPX, _T("CustomIcons"), _T("IconID"));
}
Group

CXTPCalendarIconIDs Methods


CXTPCalendarIconIDs Constructors

CXTPCalendarIconIDs Class, Legend, Public Methods
CXTPCalendarIconIDs Constructors
Class

CXTPCalendarIconIDs Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarIconIDs | Default object constructor.


CXTPCalendarIconIDs::CXTPCalendarIconIDs Constructor

CXTPCalendarIconIDs Constructors, CXTPCalendarIconIDs Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarIconIDs::CXTPCalendarIconIDs Constructor

Default object constructor.

CXTPCalendarIconIDs();
See Also

~CXTPCalendarIconIDs()

Group

CXTPCalendarIconIDs Constructors


CXTPCalendarIconIDs Destructors

CXTPCalendarIconIDs Class, Legend, Public Methods
CXTPCalendarIconIDs Destructors
Class

CXTPCalendarIconIDs Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarIconIDs | Default object destructor.


CXTPCalendarIconIDs::~CXTPCalendarIconIDs Destructor

CXTPCalendarIconIDs Destructors, CXTPCalendarIconIDs Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarIconIDs::~CXTPCalendarIconIDs Destructor

Default object destructor.

virtual ~CXTPCalendarIconIDs();
See Also

CXTPCalendarIconIDs()

Group

CXTPCalendarIconIDs Destructors


CXTPCalendarMAPIDataProvider Class

XTPCalendarMAPIDataProvider.h, Classes, Legend, Members, Topics, CXTPCalendarMAPIDataProvider Classes, CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Constructors, CXTPCalendarMAPIDataProvider Destructors, CXTPCalendarMAPIDataProvider Classes, CXTPCalendarMAPIDataProvider Constructors, CXTPCalendarMAPIDataProvider Destructors, CXTPCalendarMAPIDataProvider Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider Class

This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.

Class Hierarchy

class CXTPCalendarMAPIDataProvider : public CXTPCalendarData, public CXTPCalendarMAPIWrapper;
File

XTPCalendarMAPIDataProvider.h

Remarks

This implementation uses Extended MAPI as the data source. The Data source stores all Events data and provides a way to retrieve and save CXTPCalendarEvent objects.

To use CXTPCalendarMAPIDataProvider first construct an instance of CXTPCalendarMAPIDataProvider object then use Open() member function to establish connection to the data source and initialize the object. Class provides a number of functions to manipulate events and events related data. After finished working with the data source must call the Close() member function to close the connection and to de-initialize the object and free any unused resources.

MAPI data provider automatically opens default message store and default user's calendar folder and reads all appointments there. MAPI data provider uses Memory Data Provider internally as a private cache. Also it uses a MAPI notifications mechanism in order to have MAPI appointments always updated. When event is updated in MAPI storage, it will be automatically reloaded in the data provider and updated on the screen. It also works in the same way reverse: when an event is updated in the Calendar control, it will be automatically updated in the MAPI storage.

See Also

CXTPCalendarData, CXTPCalendarMemoryDataProvider

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarMAPIDataProvider Classes
CXTPCalendarMAPIDataProvider Classes | Description
CXTPCalendarMemDPInternal | Internal extension of the CXTPCalendarMemoryDataProvider used for handling all notifications.
CXTPCalendarMAPIDataProvider Constructors
CXTPCalendarMAPIDataProvider Constructors | Description
CXTPCalendarMAPIDataProvider | Default constructor.
CXTPCalendarMAPIDataProvider Destructors
CXTPCalendarMAPIDataProvider Destructors | Description
~CXTPCalendarMAPIDataProvider | Default Destructor.
CXTPCalendarMAPIDataProvider Methods
CXTPCalendarMAPIDataProvider Methods | Description
Close | Call this member function to close the connection to a data source.
Create | For MAPI Data Provider this methods does the same sequence of actions as Open method.
DoCreate_Event | Creates a new appointment in the MAPI storage.
DoCreate_RPattern | Creates a new recurrence pattern
DoDelete_Event | Deletes an appointment from the MAPI storage.
DoDelete_RPattern | Deletes a recurrence pattern
DoGetAllEvents_raw | This method implements Getting all events from the MAPI storage without generating recurrence occurrences.
DoGetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the MAPI storage
DoRead_RPattern | Read recurrence pattern from the MAPI storage
DoRemoveAllEvents | Remove all events from the MAPI storage.
DoRetrieveDayEvents | Retrieve day events from memory cache.
DoUpdate_Event | Updates appointment properties in the MAPI storage.
DoUpdate_RPattern | Updates a recurrence pattern
GetMAPILogonParams | This member function is used to retrieve parameters for MAPI session login. Default implementation try to read them from the connection string or return values for loging with default credentials.
GetParameterValueFromConStr | This member function is used to retrieve parameters from the connection string.
IsOpen | Checks whether a connection to the MAPI data source is already opened.
OnTimeZoneChanged | This method is called by the calendar control framework when Time Zone is Changed.
Open | Open user's message store, default calendar folder and reads all events there.
Save | For MAPI Data Provider this methods does nothing.


CXTPCalendarMAPIDataProvider Classes

Classes, CXTPCalendarMAPIDataProvider Class
CXTPCalendarMAPIDataProvider Classes
Classes
Class | Description
CXTPCalendarMemDPInternal | Internal extension of the CXTPCalendarMemoryDataProvider used for handling all notifications.
Class

CXTPCalendarMAPIDataProvider Class


CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal Class

XTPCalendarMAPIDataProvider.h, CXTPCalendarMAPIDataProvider Classes, Legend, Members, Topics, CXTPCalendarMemDPInternal Methods, CXTPCalendarMemDPInternal Constructors, CXTPCalendarMemDPInternal Constructors, CXTPCalendarMemDPInternal Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal Class

Internal extension of the CXTPCalendarMemoryDataProvider used for handling all notifications.

Class Hierarchy

class CXTPCalendarMemDPInternal : public CXTPCalendarMemoryDataProvider;
File

XTPCalendarMAPIDataProvider.h

Group

CXTPCalendarMAPIDataProvider Classes

Legend
Method
virtual
CXTPCalendarMemDPInternal Constructors
CXTPCalendarMemDPInternal Constructors | Description
CXTPCalendarMemDPInternal | Default constructor.
CXTPCalendarMemDPInternal Methods
CXTPCalendarMemDPInternal Methods | Description
SendNotification | This member function sends a notification to all subscribers.


CXTPCalendarMemDPInternal Methods

CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemDPInternal Methods
Class

CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
SendNotification | This member function sends a notification to all subscribers.


CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal::SendNotification Method

CXTPCalendarMemDPInternal Methods, CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal::SendNotification Method

This member function sends a notification to all subscribers.

virtual void SendNotification(
    XTP_NOTIFY_CODE EventCode,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

EventCode
A specific code identifying the event.
wParam
First custom parameter. Depends on the event type. See specific event description for details.
lParam
Second custom parameter. Depends on the event type. See specific event description for details.

Group

CXTPCalendarMemDPInternal Methods


CXTPCalendarMemDPInternal Constructors

CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemDPInternal Constructors
Class

CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMemDPInternal | Default constructor.


CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal::CXTPCalendarMemDPInternal Constructor

CXTPCalendarMemDPInternal Constructors, CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::CXTPCalendarMemDPInternal::CXTPCalendarMemDPInternal Constructor

Default constructor.

CXTPCalendarMemDPInternal(
    CXTPCalendarData* pDPExternal
);
Parameters

pDPExternal
Pointer to the external data provider to be initialized with.

Group

CXTPCalendarMemDPInternal Constructors


CXTPCalendarMAPIDataProvider Methods

CXTPCalendarMAPIDataProvider Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider Methods
Class

CXTPCalendarMAPIDataProvider Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DoCreate_Event | Creates a new appointment in the MAPI storage.
DoCreate_RPattern | Creates a new recurrence pattern
DoDelete_Event | Deletes an appointment from the MAPI storage.
DoDelete_RPattern | Deletes a recurrence pattern
DoGetAllEvents_raw | This method implements Getting all events from the MAPI storage without generating recurrence occurrences.
DoGetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the MAPI storage
DoRead_RPattern | Read recurrence pattern from the MAPI storage
DoRemoveAllEvents | Remove all events from the MAPI storage.
DoRetrieveDayEvents | Retrieve day events from memory cache.
DoUpdate_Event | Updates appointment properties in the MAPI storage.
DoUpdate_RPattern | Updates a recurrence pattern
GetMAPILogonParams | This member function is used to retrieve parameters for MAPI session login. Default implementation try to read them from the connection string or return values for loging with default credentials.
GetParameterValueFromConStr | This member function is used to retrieve parameters from the connection string.
OnTimeZoneChanged | This method is called by the calendar control framework when Time Zone is Changed.
Public Methods
Public Methods
Public Method | Description
Close | Call this member function to close the connection to a data source.
Create | For MAPI Data Provider this methods does the same sequence of actions as Open method.
IsOpen | Checks whether a connection to the MAPI data source is already opened.
Open | Open user's message store, default calendar folder and reads all events there.
Save | For MAPI Data Provider this methods does nothing.


CXTPCalendarMAPIDataProvider::Close Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::Close Method

Call this member function to close the connection to a data source.

virtual void Close();
Remarks

This method closes the connection to the MAPI data source and uninitializes MAPI libraries.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::Create Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::Create Method

For MAPI Data Provider this methods does the same sequence of actions as Open method.

virtual BOOL Create();
Returns

TRUE is successful. FALSE otherwise.

See Also

Open

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoCreate_Event Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoCreate_Event Method

Creates a new appointment in the MAPI storage.

virtual BOOL DoCreate_Event(
    CXTPCalendarEvent* pEvent,
    DWORD& rdwNewEventID
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created appointment.
rdwNewEventID
[out] EventID of a newly created record.

Returns

TRUE if an appointment created successfully, FALSE in case of any errors during the process.

Remarks

This method creates a new message of the appointment type in the MAPI data storage and saves all event properties there.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoCreate_RPattern Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoCreate_RPattern Method

Creates a new recurrence pattern

virtual BOOL DoCreate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern,
    DWORD& rdwNewPatternID
);
Parameters

pPattern
[in] Pointer to the CXTPCalendarRecurrencePattern object.
rdwNewPatternID
[out] Pattern ID.

Returns

Always returns TRUE.

Remarks

As far as we are getting cache synchronized with the MAPI storage, this method just assigns rdwNewPatternID to the provided pattern ID..

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoDelete_Event Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoDelete_Event Method

Deletes an appointment from the MAPI storage.

virtual BOOL DoDelete_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an appointment.

Returns

TRUE if an appointment deleted successfully, FALSE in case of any errors during the process.

Remarks

This method deletes a corresponding MAPI appointment from the MAPI storage.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoDelete_RPattern Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoDelete_RPattern Method

Deletes a recurrence pattern

virtual BOOL DoDelete_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object.

Returns

Always returns TRUE.

Remarks

As far as we are getting cache synchronized with the MAPI storage, this method actually does nothing..

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoGetAllEvents_raw Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoGetAllEvents_raw Method

This method implements Getting all events from the MAPI storage without generating recurrence occurrences.

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
Returns

A CXTPCalendarEvents pointer containing a collection of all events.

Remarks

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated. As far as we are getting cache synchronized with the MAPI storage, this method actually works from memory cache.

See Also

GetAllEvents_raw()

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoGetUpcomingEvents Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoGetUpcomingEvents Method

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(
    COleDateTime dtFrom,
    COleDateTimeSpan spPeriod
);
Parameters

dtFrom
Start date and time of a specified period.
spPeriod
A duration of a specified period.

Returns

A CXTPCalendarEvents pointer containing a collection of upcoming events.

Remarks

As far as we are getting cache synchronized with the MAPI storage, this method actually works from memory cache. It is used by a reminders manager.

See Also

CXTPCalendarRemindersManager overview

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoRead_Event Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoRead_Event Method

Read event from the MAPI storage

virtual CXTPCalendarEventPtr DoRead_Event(
    DWORD dwEventID
);
Parameters

dwEventID
Event ID of the read target.

Returns

A pointer to the created CXTPCalendarEvent object.

Remarks

As far as we are getting cache synchronized with the MAPI storage, this method reads an event from the memory cache.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoRead_RPattern Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoRead_RPattern Method

Read recurrence pattern from the MAPI storage

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(
    DWORD dwPatternID
);
Parameters

dwPatternID
Pattern ID of the read target.

Returns

A pointer to the created CXTPCalendarRecurrencePattern object.

Remarks

As far as we are getting cache synchronized with the MAPI storage, this method reads a recurrence pattern from the memory cache.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoRemoveAllEvents Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoRemoveAllEvents Method

Remove all events from the MAPI storage.

virtual void DoRemoveAllEvents();
Remarks

This method works with memory cache only and removes all data there.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoRetrieveDayEvents Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoRetrieveDayEvents Method

Retrieve day events from memory cache.

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(
    COleDateTime dtDay
);
Parameters

dtDay
A specified day.

Returns

A collection of events for a specified day.

Remarks

As far as we are getting cache synchronized with the MAPI storage, this method works from memory cache.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoUpdate_Event Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoUpdate_Event Method

Updates appointment properties in the MAPI storage.

virtual BOOL DoUpdate_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an appointment.

Returns

TRUE if an appointment updated successfully, FALSE in case of any errors during the process.

Remarks

This method updates a corresponding MAPI appointment with properties from the specified event.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::DoUpdate_RPattern Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::DoUpdate_RPattern Method

Updates a recurrence pattern

virtual BOOL DoUpdate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object.

Returns

Always returns TRUE.

Remarks

As far as we are getting cache synchronized with the MAPI storage, this method actually does nothing..

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::GetMAPILogonParams Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::GetMAPILogonParams Method

This member function is used to retrieve parameters for MAPI session login. Default implementation try to read them from the connection string or return values for loging with default credentials.

virtual void GetMAPILogonParams(
    LPTSTR& rpszProfile,
    LPTSTR& rpszPassword,
    FLAGS& ruFlags
);
Parameters

rpszProfile
A reference to LPTSTR pointer to receive pointer with profile name string (or NULL).
rpszPassword
A reference to LPTSTR pointer to receive pointer with password string (or NULL).
ruFlags
A reference to FLAGS variable to receive loging flags.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::GetParameterValueFromConStr Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::GetParameterValueFromConStr Method

This member function is used to retrieve parameters from the connection string.

static BOOL GetParameterValueFromConStr(
    LPCTSTR lpszConnectionString,
    LPCTSTR pcszParameterName,
    CString& rstrValue
);
Parameters

lpszConnectionString
A pointer to the connection string.
pcszParameterName
A pointer to the parameter name string.
rstrValue
A reference to CString variable to receive parameter value.

Returns

TRUE if parameter with specified name find, FALSe otherwise.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::IsOpen Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::IsOpen Method

Checks whether a connection to the MAPI data source is already opened.

virtual BOOL IsOpen();
Returns

TRUE is connection is opened. FALSE otherwise.

See Also

Open

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::OnTimeZoneChanged Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::OnTimeZoneChanged Method

This method is called by the calendar control framework when Time Zone is Changed.

virtual BOOL OnTimeZoneChanged();
Returns

TRUE if internal data changed and calendar must be re-populated, FALSE if this event is ignored (no data changed). Base implementation do nothing and returns FALSE.

Remarks

The data provider implementation may use this method to adjust its data for a new timezone.

See Also

CXTPTopLevelWndMsgNotifier, XTP_WM_TIME_ZONE_CHANGED

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::Open Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::Open Method

Open user's message store, default calendar folder and reads all events there.

virtual BOOL Open();
Returns

TRUE is successful. FALSE otherwise.

Remarks

Call this member function to initialize a newly constructed CXTPCalendarMAPIDataProvider object. Data object must be created before you call Open. This method firstly initializes MAPI, login with specified user's credentials and then reads all appointments.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider::Save Method

CXTPCalendarMAPIDataProvider Methods, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::Save Method

For MAPI Data Provider this methods does nothing.

virtual BOOL Save();
Returns

TRUE.

Group

CXTPCalendarMAPIDataProvider Methods


CXTPCalendarMAPIDataProvider Constructors

CXTPCalendarMAPIDataProvider Class, Legend, Public Methods
CXTPCalendarMAPIDataProvider Constructors
Class

CXTPCalendarMAPIDataProvider Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMAPIDataProvider | Default constructor.


CXTPCalendarMAPIDataProvider::CXTPCalendarMAPIDataProvider Constructor

CXTPCalendarMAPIDataProvider Constructors, CXTPCalendarMAPIDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::CXTPCalendarMAPIDataProvider Constructor

Default constructor.

CXTPCalendarMAPIDataProvider();
Remarks

Constructs a CXTPCalendarMAPIDataProvider object. To establish a connection to a specified data source and initialize the object the Open() member function must be called immediately after construction.

See Also

Open()

Group

CXTPCalendarMAPIDataProvider Constructors


CXTPCalendarMAPIDataProvider Destructors

CXTPCalendarMAPIDataProvider Class, Legend, Public Methods
CXTPCalendarMAPIDataProvider Destructors
Class

CXTPCalendarMAPIDataProvider Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarMAPIDataProvider | Default Destructor.


CXTPCalendarMAPIDataProvider::~CXTPCalendarMAPIDataProvider Destructor

CXTPCalendarMAPIDataProvider Destructors, CXTPCalendarMAPIDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIDataProvider::~CXTPCalendarMAPIDataProvider Destructor

Default Destructor.

virtual ~CXTPCalendarMAPIDataProvider();
Remarks

Handles all deallocation.

Group

CXTPCalendarMAPIDataProvider Destructors


CXTPCalendarMAPIWrapper Class

XTPCalendarMAPIWrapper.h, Classes, Legend, Members, Topics, CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Constructors, CXTPCalendarMAPIWrapper Destructors, CXTPCalendarMAPIWrapper Constructors, CXTPCalendarMAPIWrapper Destructors, CXTPCalendarMAPIWrapper Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper Class

The CXTPCalendarMAPIWrapper class wraps the mapi32.dll API.

Class Hierarchy

class CXTPCalendarMAPIWrapper;
File

XTPCalendarMAPIWrapper.h

Group

Classes

Legend
Method
virtual
CXTPCalendarMAPIWrapper Constructors
CXTPCalendarMAPIWrapper Constructors | Description
CXTPCalendarMAPIWrapper | Constructs a CXTPCalendarMAPIWrapper object.
CXTPCalendarMAPIWrapper Destructors
CXTPCalendarMAPIWrapper Destructors | Description
~CXTPCalendarMAPIWrapper | Destroys a CXTPCalendarMAPIWrapper object, handles cleanup and deallocation.
CXTPCalendarMAPIWrapper Methods
CXTPCalendarMAPIWrapper Methods | Description
FreeProws | Destroys an SRowSet structure and frees associated memory, including memory allocated for all member arrays and structures.
HrAllocAdviseSink | Creates an advise sink object, given a context specified by the calling implementation and a callback function to be triggered by an event notification..
HrGetOneProp | Retrieves the value of a single property from a property interface, that is, an interface derived from IMAPIProp.
HrQueryAllRows | Retrieves all rows of a table.
HrSetOneProp | Sets or changes the value of a single property on a property interface, that is, an interface derived from IMAPIProp.
HrThisThreadAdviseSink | Creates an advise sink that wraps an existing advise sink for thread safety.
MAPIAllocateBuffer | Allocates a memory buffer.
MAPIFreeBuffer | Frees a memory buffer allocated with a call to the MAPIAllocateBuffer function or the MAPIAllocateMore function.
MAPIInitialize | Increments the MAPI subsystem reference count and initializes global data for the MAPI DLL.
MAPILogonEx | Logs a client application on to a session with the messaging system..
MAPIUninitialize | Decrements the reference count, cleans up, and deletes per-instance global data for the MAPI DLL.
UlRelease | Provides an alternative way to invoke the OLE method IUnknown::Release. .


CXTPCalendarMAPIWrapper Methods

CXTPCalendarMAPIWrapper Class, Legend, Public Methods
CXTPCalendarMAPIWrapper Methods
Class

CXTPCalendarMAPIWrapper Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
FreeProws | Destroys an SRowSet structure and frees associated memory, including memory allocated for all member arrays and structures.
HrAllocAdviseSink | Creates an advise sink object, given a context specified by the calling implementation and a callback function to be triggered by an event notification..
HrGetOneProp | Retrieves the value of a single property from a property interface, that is, an interface derived from IMAPIProp.
HrQueryAllRows | Retrieves all rows of a table.
HrSetOneProp | Sets or changes the value of a single property on a property interface, that is, an interface derived from IMAPIProp.
HrThisThreadAdviseSink | Creates an advise sink that wraps an existing advise sink for thread safety.
MAPIAllocateBuffer | Allocates a memory buffer.
MAPIFreeBuffer | Frees a memory buffer allocated with a call to the MAPIAllocateBuffer function or the MAPIAllocateMore function.
MAPIInitialize | Increments the MAPI subsystem reference count and initializes global data for the MAPI DLL.
MAPILogonEx | Logs a client application on to a session with the messaging system..
MAPIUninitialize | Decrements the reference count, cleans up, and deletes per-instance global data for the MAPI DLL.
UlRelease | Provides an alternative way to invoke the OLE method IUnknown::Release. .


CXTPCalendarMAPIWrapper::FreeProws Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::FreeProws Method

Destroys an SRowSet structure and frees associated memory, including memory allocated for all member arrays and structures.

void FreeProws(
    LPSRowSet prows
);
Parameters

prows
[in] Pointer to the SRowSet structure to be destroyed.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::HrAllocAdviseSink Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::HrAllocAdviseSink Method

Creates an advise sink object, given a context specified by the calling implementation and a callback function to be triggered by an event notification..

HRESULT HrAllocAdviseSink(
    LPNOTIFCALLBACK lpfnCallback,
    LPVOID lpvContext,
    LPMAPIADVISESINK FAR * lppAdviseSink
);
Parameters

lpfnCallback
[in] Pointer to a callback function based on the NOTIFCALLBACK prototype that MAPI is to call when a notification event occurs for the newly created advise sink. .
lpvContext
[in] Pointer to caller data passed to the callback function when MAPI calls it. The caller data can represent an address of significance to the client or provider. Typically, for C++ code, the lpvContext parameter represents a pointer to the address of an object.
lppAdviseSink
[out] Pointer to a pointer to an advise sink object.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::HrGetOneProp Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::HrGetOneProp Method

Retrieves the value of a single property from a property interface, that is, an interface derived from IMAPIProp.

HRESULT HrGetOneProp(
    LPMAPIPROP pmp,
    ULONG ulPropTag,
    LPSPropValue FAR * ppprop
);
Parameters

pmp
[in] Pointer to the IMAPIProp interface from which the property value is to be retrieved.
ulPropTag
[in] Property tag of the property to be retrieved.
ppprop
[out] Pointer to a pointer to the returned SPropValue structure defining the retrieved property value.

Returns

MAPI_E_NOT_FOUND - The requested property is not available from the specified interface.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::HrQueryAllRows Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::HrQueryAllRows Method

Retrieves all rows of a table.

HRESULT HrQueryAllRows(
    LPMAPITABLE ptable,
    LPSPropTagArray ptaga,
    LPSRestriction pres,
    LPSSortOrderSet psos,
    LONG crowsMax,
    LPSRowSet FAR * pprows
);
Parameters

ptable
[in] Pointer to the MAPI table from which rows are retrieved.
ptaga
[in] Pointer to an SPropTagArray structure containing an array of property tags indicating table columns. These tags are used to select the specific columns to be retrieved. If the ptaga parameter is NULL, HrQueryAllRows retrieves the entire column set of the current table view passed in the ptable parameter.
pres
[in] Pointer to an SRestriction structure containing retrieval restrictions. If the pres parameter is NULL, HrQueryAllRows makes no restrictions.
psos
[in] Pointer to an SSortOrderSet structure identifying the sort order of the columns to be retrieved. If the psos parameter is NULL, the default sort order for the table is used. crowsMax-[in] Maximum number of rows to be retrieved. If the value of the crowsMax parameter is zero, no limit on the number of rows retrieved is set.
pprows
[out] Pointer to a pointer to the returned SRowSet structure containing an array of pointers to the retrieved table rows.

Returns

Returns S_OK if the call succeeded and retrieved the expected rows of a table. MAPI_E_TABLE_TOO_BIG - The number of rows in the table is larger than the number passed for the crowsMax parameter.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::HrSetOneProp Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::HrSetOneProp Method

Sets or changes the value of a single property on a property interface, that is, an interface derived from IMAPIProp.

HRESULT HrSetOneProp(
    LPMAPIPROP pmp,
    LPSPropValue pprop
);
Parameters

pmp
[in] Pointer to an IMAPIProp interface on which the property value is to be set or changed.
pprop
[in] Pointer to the SPropValue structure defining the property to be set or changed.

Returns

MAPI_E_NOT_FOUND - The requested property is not available from the specified interface.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::HrThisThreadAdviseSink Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::HrThisThreadAdviseSink Method

Creates an advise sink that wraps an existing advise sink for thread safety.

HRESULT HrThisThreadAdviseSink(
    LPMAPIADVISESINK lpAdviseSink,
    LPMAPIADVISESINK FAR * lppAdviseSink
);
Parameters

lpAdviseSink
[in] Pointer to the advise sink to be wrapped.
lppAdviseSink
[out] Pointer to a pointer to a new advise sink that wraps the advise sink pointed to by the lpAdviseSink parameter.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::MAPIAllocateBuffer Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::MAPIAllocateBuffer Method

Allocates a memory buffer.

SCODE MAPIAllocateBuffer(
    ULONG cbSize,
    LPVOID FAR * lppBuffer
);
Parameters

cbSize
[in] Size, in bytes, of the buffer to be allocated.
lppBuffer
[out] Pointer to the returned allocated buffer.

Returns

Returns S_OK if the call succeeded and has returned the expected value or values.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::MAPIFreeBuffer Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::MAPIFreeBuffer Method

Frees a memory buffer allocated with a call to the MAPIAllocateBuffer function or the MAPIAllocateMore function.

ULONG MAPIFreeBuffer(
    LPVOID lpBuffer
);
Parameters

lpBuffer
[in] Pointer to a previously allocated memory buffer. If NULL is passed in the lpBuffer parameter, MAPIFreeBuffer does nothing. .

Returns

Returns S_OK if the call succeeded and freed the memory requested. MAPIFreeBuffer can also return S_OK on already freed locations or if memory block is not allocated with MAPIAllocateBuffer and MAPIAllocateMore.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::MAPIInitialize Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::MAPIInitialize Method

Increments the MAPI subsystem reference count and initializes global data for the MAPI DLL.

HRESULT MAPIInitialize(
    LPVOID lpMapiInit
);
Parameters

lpMapiInit
[in] Pointer to a MAPIINIT_0 structure. The lpMapiInit parameter can be set to NULL.

Returns

Returns S_OK if MAPI subsystem was initialized successfully, or an error value otherwise.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::MAPILogonEx Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::MAPILogonEx Method

Logs a client application on to a session with the messaging system..

HRESULT MAPILogonEx(
    ULONG ulUIParam,
    LPTSTR lpszProfileName,
    LPTSTR lpszPassword,
    FLAGS flFlags,
    LPMAPISESSION FAR * lppSession
);
Parameters

ulUIParam
[in] Handle to the window to which the logon dialog box is modal. If no dialog box is displayed during the call, the ulUIParam parameter is ignored. This parameter can be zero..
lpszProfileName
[in] Pointer to a string containing the name of the profile to use when logging on. This string is limited to 64 characters.
lpszPassword
[in] Pointer to a string containing the password of the profile. The lpszPassword parameter can be NULL whether or not the lpszProfileName parameter is NULL. This string is limited to 64 characters. .
flFlags
[in] Bitmask of flags used to control how logon is performed. See API MAPILogonEx description for more info.
lppSession
[out] Pointer to a pointer to the MAPI session interface.

Returns

S_OK - The logon succeeded. MAPI_E_LOGON_FAILED - The logon did not succeed, either because one or more of the parameters to MAPILogonEx were invalid or because there were too many sessions open already. MAPI_E_TIMEOUT - MAPI serializes all logons through a mutex. This is returned if the MAPI_TIMEOUT_SHORT flag was set and another thread held the mutex. MAPI_E_USER_CANCEL - The user canceled the operation, typically by clicking the Cancel button in a dialog box.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::MAPIUninitialize Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::MAPIUninitialize Method

Decrements the reference count, cleans up, and deletes per-instance global data for the MAPI DLL.

void MAPIUninitialize();
Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper::UlRelease Method

CXTPCalendarMAPIWrapper Methods, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::UlRelease Method

Provides an alternative way to invoke the OLE method IUnknown::Release. .

ULONG UlRelease(
    LPVOID punk
);
Parameters

punk
[in] Pointer to an interface derived from the IUnknown interface, in other words any MAPI interface.

Returns

Returns S_OK if the call succeeded and has returned the expected value or values. MAPI_E_CALL_FAILED - An error of unexpected or unknown origin prevented the operation from completing.

Group

CXTPCalendarMAPIWrapper Methods


CXTPCalendarMAPIWrapper Constructors

CXTPCalendarMAPIWrapper Class, Legend, Public Methods
CXTPCalendarMAPIWrapper Constructors
Class

CXTPCalendarMAPIWrapper Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMAPIWrapper | Constructs a CXTPCalendarMAPIWrapper object.


CXTPCalendarMAPIWrapper::CXTPCalendarMAPIWrapper Constructor

CXTPCalendarMAPIWrapper Constructors, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::CXTPCalendarMAPIWrapper Constructor

Constructs a CXTPCalendarMAPIWrapper object.

CXTPCalendarMAPIWrapper();
Group

CXTPCalendarMAPIWrapper Constructors


CXTPCalendarMAPIWrapper Destructors

CXTPCalendarMAPIWrapper Class, Legend, Public Methods
CXTPCalendarMAPIWrapper Destructors
Class

CXTPCalendarMAPIWrapper Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarMAPIWrapper | Destroys a CXTPCalendarMAPIWrapper object, handles cleanup and deallocation.


CXTPCalendarMAPIWrapper::~CXTPCalendarMAPIWrapper Destructor

CXTPCalendarMAPIWrapper Destructors, CXTPCalendarMAPIWrapper Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMAPIWrapper::~CXTPCalendarMAPIWrapper Destructor

Destroys a CXTPCalendarMAPIWrapper object, handles cleanup and deallocation.

virtual ~CXTPCalendarMAPIWrapper();
Group

CXTPCalendarMAPIWrapper Destructors


CXTPCalendarMemoryDataProvider Class

XTPCalendarMemoryDataProvider.h, Classes, Legend, Members, Topics, CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Constructors, CXTPCalendarMemoryDataProvider Destructors, CXTPCalendarMemoryDataProvider Constructors, CXTPCalendarMemoryDataProvider Destructors, CXTPCalendarMemoryDataProvider Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider Class

This class implements an abstract representation of the data used in the XTPCalendarData class.

Class Hierarchy

class CXTPCalendarMemoryDataProvider : public CXTPCalendarData;
File

XTPCalendarMemoryDataProvider.h

Remarks

This class is the implementation of the XTPCalendarData abstract class which represents a data portion of the Calendar control.

This class provides a memory storage implementation of the CXTPCalendarData class. It stores all elements using standard CXTPCalendarEvents array collection and provides fast search on it using search tree algorithms.

To use CXTPCalendarMemoryDataProvider you first construct an instance of CXTPCalendarDatabaseDataProvider object then use Open() member function to establish connection to the data source and initialize the object. Class provides a number of functions to manipulate events and events related data. After finishing working with data source you should call Close() member function to close connection, de-initialize the object and free unused resources.

See Also

CXTPCalendarData overview, CXTPCalendarEvents, CXTPCalendarEvent

Group

Classes

Legend
Method
protected
virtual
CXTPCalendarMemoryDataProvider Constructors
CXTPCalendarMemoryDataProvider Constructors | Description
CXTPCalendarMemoryDataProvider | Default constructor.
CXTPCalendarMemoryDataProvider Destructors
CXTPCalendarMemoryDataProvider Destructors | Description
~CXTPCalendarMemoryDataProvider | Default Destructor.
CXTPCalendarMemoryDataProvider Methods
CXTPCalendarMemoryDataProvider Methods | Description
_Load | This method reads data from an archive.
_Save | This method writes data to an archive.
Close | Call this member function to close the connection to a data source.
Create | Call this member function to create a file for storing memory data provider data.
DoCreate_Event | Creates a new event in the memory storage
DoCreate_RPattern | Creates a new recurrence pattern in the memory storage
DoDelete_Event | Deletes an event from the memory storage.
DoDelete_RPattern | Deletes a recurrence pattern from the memory storage
DoGetAllEvents_raw | This method implements Getting all events from the memory storage without generating recurrence occurrences.
DoGetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
DoPropExchange | This method reads or writes data from or to an storage.
DoRead_Event | Read event from the memory storage.
DoRead_RPattern | Read recurrence pattern from the memory storage
DoRemoveAllEvents | Removes all events from the memory storage.
DoRetrieveDayEvents | Retrieves day events for a specified day from the memory storage.
DoUpdate_Event | Updates event properties in the memory storage.
DoUpdate_RPattern | Updates a recurrence pattern in the memory storage
OnTimeZoneChanged | This method is called by the calendar control framework when Time Zone is Changed.
Open | Call this member function to initialize a newly constructed Data object. Your data object must be created before you can call Open().
RetrieveEvents | Call this member function to get a collection of events for the specified date range.
Save | This method saves data to the file.
Serialize | This method reads or writes data from or to an archive.


CXTPCalendarMemoryDataProvider Methods

CXTPCalendarMemoryDataProvider Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider Methods
Class

CXTPCalendarMemoryDataProvider Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_Load | This method reads data from an archive.
_Save | This method writes data to an archive.
DoCreate_Event | Creates a new event in the memory storage
DoCreate_RPattern | Creates a new recurrence pattern in the memory storage
DoDelete_Event | Deletes an event from the memory storage.
DoDelete_RPattern | Deletes a recurrence pattern from the memory storage
DoGetAllEvents_raw | This method implements Getting all events from the memory storage without generating recurrence occurrences.
DoGetUpcomingEvents | Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
DoRead_Event | Read event from the memory storage.
DoRead_RPattern | Read recurrence pattern from the memory storage
DoRemoveAllEvents | Removes all events from the memory storage.
DoRetrieveDayEvents | Retrieves day events for a specified day from the memory storage.
DoUpdate_Event | Updates event properties in the memory storage.
DoUpdate_RPattern | Updates a recurrence pattern in the memory storage
OnTimeZoneChanged | This method is called by the calendar control framework when Time Zone is Changed.
Public Methods
Public Methods
Public Method | Description
Close | Call this member function to close the connection to a data source.
Create | Call this member function to create a file for storing memory data provider data.
DoPropExchange | This method reads or writes data from or to an storage.
Open | Call this member function to initialize a newly constructed Data object. Your data object must be created before you can call Open().
RetrieveEvents | Call this member function to get a collection of events for the specified date range.
Save | This method saves data to the file.
Serialize | This method reads or writes data from or to an archive.


CXTPCalendarMemoryDataProvider::_Load Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::_Load Method

This method reads data from an archive.

virtual BOOL _Load(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Returns

TRUE is successful. FALSE otherwise.

Remarks

The existing data is not removed from the data provider and a new data will be loaded from the specified archive and added to the existing data set. Call RemoveAllEvents() manually if you need a cleanup before load. Method can throw CArchiveException.

See Also

_Save(), Serialize()

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::_Save Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::_Save Method

This method writes data to an archive.

virtual BOOL _Save(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Returns

TRUE is successful. FALSE otherwise.

Remarks

The most recent data from the data provider will be saved to archive. Method can throw CArchiveException.

See Also

_Load(), Serialize()

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::Close Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::Close Method

Call this member function to close the connection to a data source.

virtual void Close();
Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::Create Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::Create Method

Call this member function to create a file for storing memory data provider data.

virtual BOOL Create();
Returns

TRUE is successful. FALSE otherwise.

Remarks

It will be opened by default.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoCreate_Event Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoCreate_Event Method

Creates a new event in the memory storage

virtual BOOL DoCreate_Event(
    CXTPCalendarEvent* pEvent,
    DWORD& rdwNewEventID
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.
rdwNewEventID
[out] EventID of a newly created record

Returns

TRUE if event created successfully, FALSE in case of any error during the process.

Remarks

This method creates a memory data record corresponding with the specified event.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoCreate_RPattern Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoCreate_RPattern Method

Creates a new recurrence pattern in the memory storage

virtual BOOL DoCreate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern,
    DWORD& rdwNewPatternID
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object which describes all data fields of a newly created memory record.
rdwNewPatternID
[out] ID of a newly created memory record

Returns

TRUE if recurrence pattern created successfully, FALSE in case of any error during the process.

Remarks

This method creates a memory data record corresponding with the specified recurrence pattern.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoDelete_Event Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoDelete_Event Method

Deletes an event from the memory storage.

virtual BOOL DoDelete_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event deleted successfully, FALSE in case of any errors during the process.

Remarks

This method deletes a memory data record corresponding with the specified event.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoDelete_RPattern Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoDelete_RPattern Method

Deletes a recurrence pattern from the memory storage

virtual BOOL DoDelete_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object which should be deleted.

Returns

TRUE if recurrence pattern deleted successfully, FALSE in case of any error during the process.

Remarks

This method deletes a memory data record corresponding with the specified recurrence pattern.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoGetAllEvents_raw Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoGetAllEvents_raw Method

This method implements Getting all events from the memory storage without generating recurrence occurrences.

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
Returns

A CXTPCalendarEvents pointer containing a collection of all events.

Remarks

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated.

See Also

GetAllEvents_raw()

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoGetUpcomingEvents Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoGetUpcomingEvents Method

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(
    COleDateTime dtFrom,
    COleDateTimeSpan spPeriod
);
Parameters

dtFrom
Start date and time of a specified period.
spPeriod
A duration of a specified period.

Returns

A CXTPCalendarEvents pointer containing a collection of upcoming events.

Remarks

This method returns a collection of upcoming events. It is used by a reminders manager.

See Also

CXTPCalendarRemindersManager overview

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoPropExchange Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoPropExchange Method

This method reads or writes data from or to an storage.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Remarks

For the save case the most recent data from the data provider will be saved to archive. For the load case existing data is not removed from the data provider and a new data will be loaded from the specified archive and added to the existing data set. Call RemoveAllEvents() manually if you need a cleanup before load. For load and save operations _Load() and _Save() protected methods are used. Method can throw CArchiveException.

See Also

_Load(), _Save()

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoRead_Event Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoRead_Event Method

Read event from the memory storage.

virtual CXTPCalendarEventPtr DoRead_Event(
    DWORD dwEventID
);
Parameters

dwEventID
Event ID of the read target.

Returns

A pointer to the new CXTPCalendarEvent object which fields are filled with a data from the corresponding memory storage.

Remarks

This method retrieves all data for a specified event.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoRead_RPattern Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoRead_RPattern Method

Read recurrence pattern from the memory storage

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(
    DWORD dwPatternID
);
Parameters

dwPatternID
Pattern ID of the read target.

Returns

A pointer to the new CXTPCalendarRecurrencePatternPtr object which fields are filled with a data from the corresponding memory storage.

Remarks

This method retrieves all data for a specified recurrence pattern.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoRemoveAllEvents Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoRemoveAllEvents Method

Removes all events from the memory storage.

virtual void DoRemoveAllEvents();
Remarks

This method removes all appointments from the memory storage.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoRetrieveDayEvents Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoRetrieveDayEvents Method

Retrieves day events for a specified day from the memory storage.

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(
    COleDateTime dtDay
);
Parameters

dtDay
A specified day.

Returns

A collection of events for a specified day.

Remarks

This method retrieves all appointments for a specified day from the memory storage. It includes recurrence appointments occurrences, regular appointments for this day, multi day appointments which also have a part of this day.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoUpdate_Event Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoUpdate_Event Method

Updates event properties in the memory storage.

virtual BOOL DoUpdate_Event(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

Returns

TRUE if an event updated successfully, FALSE in case of any errors during the process.

Remarks

This method updates a memory data record corresponding with the specified event.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::DoUpdate_RPattern Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::DoUpdate_RPattern Method

Updates a recurrence pattern in the memory storage

virtual BOOL DoUpdate_RPattern(
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pPattern
Pointer to the CXTPCalendarRecurrencePattern object.

Returns

TRUE if recurrence pattern updated successfully, FALSE in case of any error during the process.

Remarks

This method updates a memory data record corresponding with the specified recurrence pattern.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::OnTimeZoneChanged Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::OnTimeZoneChanged Method

This method is called by the calendar control framework when Time Zone is Changed.

virtual BOOL OnTimeZoneChanged();
Returns

TRUE if internal data changed and calendar must be re-populated, FALSE if this event is ignored (no data changed). Base implementation do nothing and returns FALSE.

Remarks

The data provider implementation may use this method to adjust its data for a new timezone.

See Also

CXTPTopLevelWndMsgNotifier, XTP_WM_TIME_ZONE_CHANGED

Body Source
virtual BOOL OnTimeZoneChanged() { return TRUE; }
Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::Open Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::Open Method

Call this member function to initialize a newly constructed Data object. Your data object must be created before you can call Open().

virtual BOOL Open();
Returns

Boolean value represents succsess/failure result

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::RetrieveEvents Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::RetrieveEvents Method

Call this member function to get a collection of events for the specified date range.

virtual CXTPCalendarEventsPtr RetrieveEvents(
    COleDateTime dtStartDay,
    COleDateTime dtEndDay
);
Parameters

dtStartDay
A COleDateTime object without the time portion.
dtEndDay
A COleDateTime object without the time portion.

Returns

A CXTPCalendarEvents pointer containing a collection of day events.

See Also

CXTPCalendarEvents

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::Save Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::Save Method

This method saves data to the file.

virtual BOOL Save();
Returns

TRUE is successful. FALSE otherwise.

Remarks

The most recent data from the data provider will be saved in the same file as before.

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider::Serialize Method

CXTPCalendarMemoryDataProvider Methods, CXTPCalendarMemoryDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::Serialize Method

This method reads or writes data from or to an archive.

virtual void Serialize(
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.

Remarks

For the save case the most recent data from the data provider will be saved to archive. For the load case existing data is not removed from the data provider and a new data will be loaded from the specified archive and added to the existing data set. Call RemoveAllEvents() manually if you need a cleanup before load. For load and save operations _Load() and _Save() protected methods are used. Method can throw CArchiveException.

See Also

_Load(), _Save()

Group

CXTPCalendarMemoryDataProvider Methods


CXTPCalendarMemoryDataProvider Constructors

CXTPCalendarMemoryDataProvider Class, Legend, Public Methods
CXTPCalendarMemoryDataProvider Constructors
Class

CXTPCalendarMemoryDataProvider Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMemoryDataProvider | Default constructor.


CXTPCalendarMemoryDataProvider::CXTPCalendarMemoryDataProvider Constructor

CXTPCalendarMemoryDataProvider Constructors, CXTPCalendarMemoryDataProvider Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::CXTPCalendarMemoryDataProvider Constructor

Default constructor.

CXTPCalendarMemoryDataProvider();
Remarks

Constructs a Data object. To establish a connection to a specified data source and initialize the object you must call Open() member function immediately after construction.

See Also

Open()

Group

CXTPCalendarMemoryDataProvider Constructors


CXTPCalendarMemoryDataProvider Destructors

CXTPCalendarMemoryDataProvider Class, Legend, Public Methods
CXTPCalendarMemoryDataProvider Destructors
Class

CXTPCalendarMemoryDataProvider Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarMemoryDataProvider | Default Destructor.


CXTPCalendarMemoryDataProvider::~CXTPCalendarMemoryDataProvider Destructor

CXTPCalendarMemoryDataProvider Destructors, CXTPCalendarMemoryDataProvider Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMemoryDataProvider::~CXTPCalendarMemoryDataProvider Destructor

Default Destructor.

virtual ~CXTPCalendarMemoryDataProvider();
Remarks

Handles all deallocation.

Group

CXTPCalendarMemoryDataProvider Destructors


CXTPCalendarMonthView Class

XTPCalendarMonthView.h, Classes, Legend, Members, Topics, CXTPCalendarMonthView Classes, CXTPCalendarMonthView Data Members, CXTPCalendarMonthView Methods, CXTPCalendarMonthView Constructors, CXTPCalendarMonthView Destructors, CXTPCalendarMonthView Nested Types, CXTPCalendarMonthView Classes, CXTPCalendarMonthView Constructors, CXTPCalendarMonthView Data Members, CXTPCalendarMonthView Destructors, CXTPCalendarMonthView Methods, CXTPCalendarMonthView Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView Class

This class implements a specific view portion of the Calendar control - called Month view.

Class Hierarchy

class CXTPCalendarMonthView : public CXTPCalendarViewT< CXTPCalendarMonthViewDay, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW>;
File

XTPCalendarMonthView.h

Remarks

The Month can contain one or more weeks, placed in a column. Each week consist of 7 days, as a normal week. Weekend days of the week can be drawn compressed, which means that 2 weekend days will be drawn in a rectangle of a usual day. Each day is represented by a CXTPCalendarMonthViewDay class.

See Also

CXTPCalendarView, CXTPCalendarDayView, CXTPCalendarWeekView, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarMonthView Classes
CXTPCalendarMonthView Classes | Description
CMonthViewGrid |
CXTPCalendarMonthView Constructors
CXTPCalendarMonthView Constructors | Description
CXTPCalendarMonthView | Default object constructor.
CXTPCalendarMonthView Data Members
CXTPCalendarMonthView Data Members | Description
m_DayPOS_LastSelected | Last selected day positions.
m_nEventCaptionFormat | Event caption format flags are stored in packed form by bitwise operations.
m_nEventTimeWidth | width of the area to display the event times.
m_pGrid | Pointer to the grid object.
m_strLongDateFormat | String of the long date format.
m_strSmallDateFormat | String of the short date format.
CXTPCalendarMonthView Destructors
CXTPCalendarMonthView Destructors | Description
~CXTPCalendarMonthView | Default class destructor.
CXTPCalendarMonthView Methods
CXTPCalendarMonthView Methods | Description
_CalculateDateFormats | This member function is used to calculate the view's date format based on the current locale.
_CalculateEventCaptionFormat | This member function is used to calculate the event view's date format based on the current locale.
_FormatDayDate | This member function is used to obtain the format string of a day date.
_ReadDefaultDateFormats | This member function is used to build day header date format default strings.
_SplitDateFormat | This member function is used to parse the format string into tokens.
AdjustLayout | This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the view content using the specified device context.
Draw2 | This member function is used to draw the view content using the specified device context.
GetEventCaptionFormat | This member function is used to obtain the event caption format flags.
GetEventTimeWidth | This member function is used to obtain the width necessary to display the event's time.
GetGrid | This member function is used to obtain the Month View days grid object.
GetScrollBarInfoV | This member function is used to retrieve information about the current scroll bar state.
GetViewDay | This member function is used to obtain the view's day object by the given index.
GetViewDayDate | Call this member function to obtain the date of a day view by the day's index.
GetWeekDayTextIfNeed | This member function is used to obtain week day header text.
OnKeyDown | This member function is used to process keyboard events.
OnLButtonDown | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
Populate | This member function is used to populate the view with data for all items contained in the view.
ScrollV | This member function is used to scroll the contents of a view.
ShowDay | This member function is used to show the specified day in the calendar view.
CXTPCalendarMonthView Nested Types
CXTPCalendarMonthView Nested Types | Description
TBase |


CXTPCalendarMonthView Classes

Classes, CXTPCalendarMonthView Class
CXTPCalendarMonthView Classes
Classes
Class | Description
CMonthViewGrid |
Class

CXTPCalendarMonthView Class


CXTPCalendarMonthView::CMonthViewGrid Class

XTPCalendarMonthView.h, CXTPCalendarMonthView Classes, Legend, Members, Topics, CMonthViewGrid Data Members, CMonthViewGrid Methods, CMonthViewGrid Constructors, CMonthViewGrid Destructors, CMonthViewGrid Constructors, CMonthViewGrid Data Members, CMonthViewGrid Destructors, CMonthViewGrid Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid Class
Class Hierarchy

class CMonthViewGrid;
File

XTPCalendarMonthView.h

Remarks

This helper class implements a grid for the month view.

See Also

CXTPCalendarMonthView overview

Group

CXTPCalendarMonthView Classes

Legend
Data Member
protected
Method
virtual
CMonthViewGrid Constructors
CMonthViewGrid Constructors | Description
CMonthViewGrid | Default class constructor.
CMonthViewGrid Data Members
CMonthViewGrid Data Members | Description
m_arColHeaderText | Array of columns (week days) headers names.
m_arColsLeftX | Array of columns left borders positions.
m_arRowsTopY | Array of rows top borders positions.
m_dtBeginDate | First Cell (cell [0, 0]) date in the grid.
m_nColHeaderHeight | Column header height in pixels.
m_nFirstDayOfWeekIndex | First Day Of Week index: 1-Sunday, 2-Monday ...
m_nWeeksCount | The number of weeks that are displayed.
m_pView | Pointer to the parent view class.
CMonthViewGrid Destructors
CMonthViewGrid Destructors | Description
~CMonthViewGrid | Default class destructor.
CMonthViewGrid Methods
CMonthViewGrid Methods | Description
AdjustDays | This member function is used to call AdjustLayout for each day in days collection with corresponding day rect.
AdjustEvents | This member function is used to adjust the event views layout.
AdjustFirstDayOfWeek | This member function is used to adjust the grid's columns depending on the FirstDayOfWeek calendar control option value.
AdjustGrid | This member function is used to adjust the grid's columns and rows.
AdjustHeader | This member function is used to adjust the grid's column header layout.
AdjustLayout | This member function is used to adjust the grid's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the grid content using the specified device context.
GetBeginDate | This member function is used to obtain the date of the first cell (cell [0, 0]) in the grid.
GetCelRect | This member function is used to obtain the bounding rectangle of the full grid cell.
GetColHeaderHeight | This member function is used to obtain the number of pixels in the height of the Month View week days columns header.
GetColsCount | This member function is used to obtain the number of columns that are displayed in the Month View.
GetDayDate | This member function is used to retrieve the specified day date.
GetDayRect | This member function is used to obtain the bounding rectangle of the day cell.
GetFirstDayOfWeek | This member function is used to obtain the First Day Of Week index.
GetMaxDayPOS | This member function is used to obtain the maximum number of available day positions.
GetMiddleScrollBeginDate | This member function is used to calculate the date for a middle scrollbar position.
GetScrollPos | This member function is used to obtain the current scrolling position.
GetViewDay | This function is used to obtain the view day object that is associated with the given indexes.
GetWeekDayCol | This member function is used to obtain the column for the specified week day.
GetWeekDayForColIndex | This member function is used to obtain the week day index for the specified column.
GetWeeksCount | This member function is used to obtain the weeks (rows) count in the grid.
ScrollV | This member function is used to scroll the contents of a grid.
SetBeginDate | This member function is used to set the start view date.
SetColHeaderHeight | This member function is used to set the height of the Month View week days columns header.
SetWeeksCount | This member function is used to set the number of weeks that are shown in the grid (Month View).
ShiftDateToCell_00 | This member function is used to shift the specified date to the first cell date in the grid.


CMonthViewGrid Data Members

CXTPCalendarMonthView::CMonthViewGrid Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewGrid Data Members
Class

CXTPCalendarMonthView::CMonthViewGrid Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arColHeaderText | Array of columns (week days) headers names.
m_arColsLeftX | Array of columns left borders positions.
m_arRowsTopY | Array of rows top borders positions.
m_dtBeginDate | First Cell (cell [0, 0]) date in the grid.
m_nColHeaderHeight | Column header height in pixels.
m_nFirstDayOfWeekIndex | First Day Of Week index: 1-Sunday, 2-Monday ...
m_nWeeksCount | The number of weeks that are displayed.
m_pView | Pointer to the parent view class.


CXTPCalendarMonthView::CMonthViewGrid::m_arColHeaderText Data Member

CMonthViewGrid Data Members, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::m_arColHeaderText Data Member

Array of columns (week days) headers names.

CStringArray m_arColHeaderText;
Group

CMonthViewGrid Data Members


CXTPCalendarMonthView::CMonthViewGrid::m_arColsLeftX Data Member

CMonthViewGrid Data Members, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::m_arColsLeftX Data Member

Array of columns left borders positions.

CUIntArray m_arColsLeftX;
Group

CMonthViewGrid Data Members


CXTPCalendarMonthView::CMonthViewGrid::m_arRowsTopY Data Member

CMonthViewGrid Data Members, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::m_arRowsTopY Data Member

Array of rows top borders positions.

CUIntArray m_arRowsTopY;
Group

CMonthViewGrid Data Members


CXTPCalendarMonthView::CMonthViewGrid::m_dtBeginDate Data Member

CMonthViewGrid Data Members, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::m_dtBeginDate Data Member

First Cell (cell [0, 0]) date in the grid.

COleDateTime m_dtBeginDate;
Group

CMonthViewGrid Data Members


CXTPCalendarMonthView::CMonthViewGrid::m_nColHeaderHeight Data Member

CMonthViewGrid Data Members, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::m_nColHeaderHeight Data Member

Column header height in pixels.

int m_nColHeaderHeight;
Group

CMonthViewGrid Data Members


CXTPCalendarMonthView::CMonthViewGrid::m_nFirstDayOfWeekIndex Data Member

CMonthViewGrid Data Members, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::m_nFirstDayOfWeekIndex Data Member

First Day Of Week index: 1-Sunday, 2-Monday ...

int m_nFirstDayOfWeekIndex;
Group

CMonthViewGrid Data Members


CXTPCalendarMonthView::CMonthViewGrid::m_nWeeksCount Data Member

CMonthViewGrid Data Members, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::m_nWeeksCount Data Member

The number of weeks that are displayed.

int m_nWeeksCount;
Group

CMonthViewGrid Data Members


CXTPCalendarMonthView::CMonthViewGrid::m_pView Data Member

CMonthViewGrid Data Members, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::m_pView Data Member

Pointer to the parent view class.

CXTPCalendarMonthView* m_pView;
Group

CMonthViewGrid Data Members


CMonthViewGrid Methods

CXTPCalendarMonthView::CMonthViewGrid Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewGrid Methods
Class

CXTPCalendarMonthView::CMonthViewGrid Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
AdjustHeader | This member function is used to adjust the grid's column header layout.
GetMiddleScrollBeginDate | This member function is used to calculate the date for a middle scrollbar position.
Public Methods
Public Methods
Public Method | Description
AdjustDays | This member function is used to call AdjustLayout for each day in days collection with corresponding day rect.
AdjustEvents | This member function is used to adjust the event views layout.
AdjustFirstDayOfWeek | This member function is used to adjust the grid's columns depending on the FirstDayOfWeek calendar control option value.
AdjustGrid | This member function is used to adjust the grid's columns and rows.
AdjustLayout | This member function is used to adjust the grid's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the grid content using the specified device context.
GetBeginDate | This member function is used to obtain the date of the first cell (cell [0, 0]) in the grid.
GetCelRect | This member function is used to obtain the bounding rectangle of the full grid cell.
GetColHeaderHeight | This member function is used to obtain the number of pixels in the height of the Month View week days columns header.
GetColsCount | This member function is used to obtain the number of columns that are displayed in the Month View.
GetDayDate | This member function is used to retrieve the specified day date.
GetDayRect | This member function is used to obtain the bounding rectangle of the day cell.
GetFirstDayOfWeek | This member function is used to obtain the First Day Of Week index.
GetMaxDayPOS | This member function is used to obtain the maximum number of available day positions.
GetScrollPos | This member function is used to obtain the current scrolling position.
GetViewDay | This function is used to obtain the view day object that is associated with the given indexes.
GetWeekDayCol | This member function is used to obtain the column for the specified week day.
GetWeekDayForColIndex | This member function is used to obtain the week day index for the specified column.
GetWeeksCount | This member function is used to obtain the weeks (rows) count in the grid.
ScrollV | This member function is used to scroll the contents of a grid.
SetBeginDate | This member function is used to set the start view date.
SetColHeaderHeight | This member function is used to set the height of the Month View week days columns header.
SetWeeksCount | This member function is used to set the number of weeks that are shown in the grid (Month View).
ShiftDateToCell_00 | This member function is used to shift the specified date to the first cell date in the grid.


CXTPCalendarMonthView::CMonthViewGrid::AdjustDays Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::AdjustDays Method

This member function is used to call AdjustLayout for each day in days collection with corresponding day rect.

void AdjustDays(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

See Also

AdjustEvents

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::AdjustEvents Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::AdjustEvents Method

This member function is used to adjust the event views layout.

void AdjustEvents(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

See Also

AdjustLayout, CXTPCalendarMonthView::AdjustLayout

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::AdjustFirstDayOfWeek Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::AdjustFirstDayOfWeek Method

This member function is used to adjust the grid's columns depending on the FirstDayOfWeek calendar control option value.

void AdjustFirstDayOfWeek();
See Also

CXTPCalendarControl::GetFirstDayOfWeek

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::AdjustGrid Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::AdjustGrid Method

This member function is used to adjust the grid's columns and rows.

void AdjustGrid(
    const CRect& rcRect
);
Parameters

rcRect
A rectangle for grid.

See Also

AdjustDays

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::AdjustHeader Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::AdjustHeader Method

This member function is used to adjust the grid's column header layout.

void AdjustHeader(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

See Also

AdjustLayout, CXTPCalendarMonthView::AdjustLayout

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::AdjustLayout Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::AdjustLayout Method

This member function is used to adjust the grid's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.

void AdjustLayout(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

See Also

CXTPCalendarMonthView::AdjustLayout

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::Draw Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::Draw Method

This member function is used to draw the grid content using the specified device context.

void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

Call CXTPCalendarMonthView::AdjustLayout before Draw().

See Also

CXTPCalendarMonthView::Draw, CXTPCalendarMonthView::AdjustLayout.

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetBeginDate Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetBeginDate Method

This member function is used to obtain the date of the first cell (cell [0, 0]) in the grid.

COleDateTime GetBeginDate() const;
Returns

A COleDateTime object that contains the date of the first cell (cell [0, 0]) in the grid.

See Also

SetBeginDate, ShiftDateToCell_00

Body Source
COleDateTime CXTPCalendarMonthView::CMonthViewGrid::GetBeginDate() const {
    return m_dtBeginDate;
}
Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetCelRect Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetCelRect Method

This member function is used to obtain the bounding rectangle of the full grid cell.

CRect GetCelRect(
    int nWeekIndex,
    int nColIndex,
    BOOL bIncludeBorders = FALSE
) const;
Parameters

nWeekIndex
An int that contains the index of the week. Valid values are from 0 to GetWeeksCount()-1.
nColIndex
An int that contains the index of the cell in the grid. Valid values are from 0 to GetColsCount()-1.
bIncludeBorders
A BOOL. If TRUE, then borders between cells are included in the bounding rectangle coordinates. If FALSE, then the borders between cells are not included in the bounding rectangle coordinates.

Returns

A CRect object that contains the bounding rectangle coordinates of the full grid cell.

Remarks

Full grid cell means day cell for no compressed days or cell included 2 day cells for compressed Sat/Sun if such option is ON.

See Also

GetDayRect, GetWeeksCount, GetColsCount, CRect

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetColHeaderHeight Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetColHeaderHeight Method

This member function is used to obtain the number of pixels in the height of the Month View week days columns header.

int GetColHeaderHeight() const;
Returns

An int that contains the value of the columns header height in pixels.

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetColsCount Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetColsCount Method

This member function is used to obtain the number of columns that are displayed in the Month View.

int GetColsCount() const;
Returns

An int that contains the number of columns that are displayed in the Month View.

Remarks

If the "compress weekend days" option is ON, then 6 is returned, otherwise 7.

See Also

GetWeekDayCol

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetDayDate Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetDayDate Method

This member function is used to retrieve the specified day date.

COleDateTime GetDayDate(
    int nWeekIndex,
    int nWeekDayIndex
) const;
Parameters

nWeekIndex
An int that contains the index of the week. Valid values are from 0 to GetWeeksCount()-1.
nWeekDayIndex
An int that contains the index of the day cell in the week. Valid values are from 0 to 6.

Returns

A COleDateTime object that contains the specified day date.

See Also

GetWeeksCount, SetWeeksCount

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetDayRect Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetDayRect Method

This member function is used to obtain the bounding rectangle of the day cell.

CRect GetDayRect(
    int nWeekIndex,
    int nWeekDayIndex,
    BOOL bIncludeBorders = FALSE
) const;
Parameters

nWeekIndex
An int that contains the index of the week. Valid values are from 0 to GetWeeksCount()-1.
nWeekDayIndex
An int that contains the index of the day cell in the week. Valid values are from 0 to 6.
bIncludeBorders
A BOOL. If TRUE, then borders between days are included in the bounding rectangle coordinates. If FALSE, then borders are not included in the bounding rectangle coordinates.

Returns

A CRect object that contains the bounding rectangle coordinates of the day cell.

See Also

GetCelRect, GetWeeksCount, CRect

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetFirstDayOfWeek Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetFirstDayOfWeek Method

This member function is used to obtain the First Day Of Week index.

int GetFirstDayOfWeek() const;
Returns

First Day Of Week index. (1-Sunday, 2-Monday ...)

See Also

GetWeekDayCol

Body Source
int CXTPCalendarMonthView::CMonthViewGrid::GetFirstDayOfWeek() const {
    return m_nFirstDayOfWeekIndex;
}
Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetMaxDayPOS Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetMaxDayPOS Method

This member function is used to obtain the maximum number of available day positions.

XTP_CALENDAR_MONTHVIEW_DAYPOS GetMaxDayPOS();
Returns

A XTP_CALENDAR_MONTHVIEW_DAYPOS object that contains the maximum number of available day positions.

See Also

XTP_CALENDAR_MONTHVIEW_DAYPOS, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW, CXTPCalendarMonthView::m_DayPOS_LastSelected

Body Source
XTP_CALENDAR_MONTHVIEW_DAYPOS CXTPCalendarMonthView::CMonthViewGrid::GetMaxDayPOS() {
    XTP_CALENDAR_MONTHVIEW_DAYPOS maxPOS = (int)(GetWeeksCount() * 7 - 1);
    return maxPOS;
}
Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetMiddleScrollBeginDate Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetMiddleScrollBeginDate Method

This member function is used to calculate the date for a middle scrollbar position.

COleDateTime GetMiddleScrollBeginDate();
Returns

A COleDateTime object that contains the date for a middle scrollbar position.

See Also

ScrollV, GetScrollPos, CXTPCalendarMonthView::ScrollV, CXTPCalendarMonthView::GetScrollBarInfoV.

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetScrollPos Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetScrollPos Method

This member function is used to obtain the current scrolling position.

int GetScrollPos();
Returns

An int that contains the current scrolling position.

See Also

ScrollV, CXTPCalendarMonthView::ScrollV, CXTPCalendarMonthView::GetScrollBarInfoV.

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetViewDay Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetViewDay Method

This function is used to obtain the view day object that is associated with the given indexes.

CXTPCalendarMonthViewDay* GetViewDay(
    int nWeekIndex,
    int nWeekDayIndex
);
Parameters

nWeekIndex
An int that contains the index of the week. Valid values are from 0 to GetWeeksCount()-1.
nWeekDayIndex
An int that contains the index of the day cell in the week.

Returns

A pointer to a CXTPCalendarMonthViewDay object that contains the view day that is associated with the given indexes.

See Also

CXTPCalendarMonthView::GetViewDay

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetWeekDayCol Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetWeekDayCol Method

This member function is used to obtain the column for the specified week day.

int GetWeekDayCol(
    int nWeekDayIndex
) const;
Parameters

nWeekDayIndex
An in that contains the index of the week day. 1-Sunday, 2-Monday, ....

Returns

An in that contains the column number for the specified week day.

Remarks

If the "compress weekend days" option is ON then, only one column number is returned for Saturday and Sunday.

See Also

GetColsCount, GetWeekDayForColIndex

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetWeekDayForColIndex Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetWeekDayForColIndex Method

This member function is used to obtain the week day index for the specified column.

int GetWeekDayForColIndex(
    int nColIdx
) const;
Parameters

nColIdx
An in that contains the index of the week day. 1-Sunday, 2-Monday, ....

Returns

Index of the week day as: 1-Sunday, 2-Monday, ....

Remarks

If the "compress weekend days" option is ON then, 7 (Saturday) returned for the compressed column.

See Also

GetColsCount, GetWeekDayCol

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount Method

This member function is used to obtain the weeks (rows) count in the grid.

int GetWeeksCount() const;
Returns

An int that contains the number of weeks (rows) in the grid.

See Also

SetWeeksCount

Body Source
int  CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount() const {
    return m_nWeeksCount;
}
Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::ScrollV Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::ScrollV Method

This member function is used to scroll the contents of a grid.

void ScrollV(
    int nPos
);
Parameters

nPos
An int that contains the position value.

Remarks

This member function calculates the date time that corresponds with the current scroll bar position. Next, the function adjusts the dates in the grid so that the date that is associated with the current scroll bar position is placed in the beginning cell of the grid.

See Also

GetScrollPos, CXTPCalendarMonthView::ScrollV, CXTPCalendarMonthView::GetScrollBarInfoV.

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::SetBeginDate Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::SetBeginDate Method

This member function is used to set the start view date.

void SetBeginDate(
    COleDateTime dtBeginDate
);
Parameters

dtBeginDate
A COleDateTime object that contains the start view date.

Remarks

This date will be adjusted (shifted) to be the first cell (cell [0, 0]) date in the grid.

See Also

GetBeginDate, ShiftDateToCell_00

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::SetColHeaderHeight Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::SetColHeaderHeight Method

This member function is used to set the height of the Month View week days columns header.

void SetColHeaderHeight(
    int nHeight
);
Parameters

nHeight
A new height value in pixels.

Remarks

Should be used in visual themes AdjustLayout processing.

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::SetWeeksCount Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::SetWeeksCount Method

This member function is used to set the number of weeks that are shown in the grid (Month View).

void SetWeeksCount(
    int nWeeks
);
Parameters

nWeeks
An int that contains the number of weeks shown in the grid. Minimum and maximum values are defined as XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN and XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX.

See Also

GetWeeksCount, XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN, XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX

Group

CMonthViewGrid Methods


CXTPCalendarMonthView::CMonthViewGrid::ShiftDateToCell_00 Method

CMonthViewGrid Methods, CXTPCalendarMonthView::CMonthViewGrid Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::ShiftDateToCell_00 Method

This member function is used to shift the specified date to the first cell date in the grid.

COleDateTime ShiftDateToCell_00(
    COleDateTime dtDate
);
Parameters

dtDate
A COleDateTime object that contains the date to shift.

Returns

A COleDateTime object that contains the date that was shifted to the first cell in the grid.

See Also

GetBeginDate, SetBeginDate

Group

CMonthViewGrid Methods


CMonthViewGrid Constructors

CXTPCalendarMonthView::CMonthViewGrid Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewGrid Constructors
Class

CXTPCalendarMonthView::CMonthViewGrid Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CMonthViewGrid | Default class constructor.


CXTPCalendarMonthView::CMonthViewGrid::CMonthViewGrid Constructor

CMonthViewGrid Constructors, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::CMonthViewGrid Constructor

Default class constructor.

CMonthViewGrid(
    CXTPCalendarMonthView* pView
);
Parameters

pView
A CXTPCalendarMonthView pointer to the parent view class.

Group

CMonthViewGrid Constructors


CMonthViewGrid Destructors

CXTPCalendarMonthView::CMonthViewGrid Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewGrid Destructors
Class

CXTPCalendarMonthView::CMonthViewGrid Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CMonthViewGrid | Default class destructor.


CXTPCalendarMonthView::CMonthViewGrid::~CMonthViewGrid Destructor

CMonthViewGrid Destructors, CXTPCalendarMonthView::CMonthViewGrid Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CMonthViewGrid::~CMonthViewGrid Destructor

Default class destructor.

virtual ~CMonthViewGrid();
Remarks

Handles member item deallocation.

Group

CMonthViewGrid Destructors


CXTPCalendarMonthView Data Members

CXTPCalendarMonthView Class, Legend, Protected Data Members
CXTPCalendarMonthView Data Members
Class

CXTPCalendarMonthView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_DayPOS_LastSelected | Last selected day positions.
m_nEventCaptionFormat | Event caption format flags are stored in packed form by bitwise operations.
m_nEventTimeWidth | width of the area to display the event times.
m_pGrid | Pointer to the grid object.
m_strLongDateFormat | String of the long date format.
m_strSmallDateFormat | String of the short date format.


CXTPCalendarMonthView::m_DayPOS_LastSelected Data Member

CXTPCalendarMonthView Data Members, CXTPCalendarMonthView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::m_DayPOS_LastSelected Data Member

Last selected day positions.

XTP_CALENDAR_MONTHVIEW_DAYPOS m_DayPOS_LastSelected;
Group

CXTPCalendarMonthView Data Members


CXTPCalendarMonthView::m_nEventCaptionFormat Data Member

CXTPCalendarMonthView Data Members, CXTPCalendarMonthView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::m_nEventCaptionFormat Data Member

Event caption format flags are stored in packed form by bitwise operations.

int m_nEventCaptionFormat;
Group

CXTPCalendarMonthView Data Members


CXTPCalendarMonthView::m_nEventTimeWidth Data Member

CXTPCalendarMonthView Data Members, CXTPCalendarMonthView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::m_nEventTimeWidth Data Member

width of the area to display the event times.

int m_nEventTimeWidth;
Group

CXTPCalendarMonthView Data Members


CXTPCalendarMonthView::m_pGrid Data Member

CXTPCalendarMonthView Data Members, CXTPCalendarMonthView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::m_pGrid Data Member

Pointer to the grid object.

CMonthViewGrid* m_pGrid;
Group

CXTPCalendarMonthView Data Members


CXTPCalendarMonthView::m_strLongDateFormat Data Member

CXTPCalendarMonthView Data Members, CXTPCalendarMonthView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::m_strLongDateFormat Data Member

String of the long date format.

CString m_strLongDateFormat;
Group

CXTPCalendarMonthView Data Members


CXTPCalendarMonthView::m_strSmallDateFormat Data Member

CXTPCalendarMonthView Data Members, CXTPCalendarMonthView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::m_strSmallDateFormat Data Member

String of the short date format.

CString m_strSmallDateFormat;
Group

CXTPCalendarMonthView Data Members


CXTPCalendarMonthView Methods

CXTPCalendarMonthView Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView Methods
Class

CXTPCalendarMonthView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_CalculateDateFormats | This member function is used to calculate the view's date format based on the current locale.
_CalculateEventCaptionFormat | This member function is used to calculate the event view's date format based on the current locale.
_FormatDayDate | This member function is used to obtain the format string of a day date.
_ReadDefaultDateFormats | This member function is used to build day header date format default strings.
_SplitDateFormat | This member function is used to parse the format string into tokens.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the view content using the specified device context.
Draw2 | This member function is used to draw the view content using the specified device context.
GetEventCaptionFormat | This member function is used to obtain the event caption format flags.
GetEventTimeWidth | This member function is used to obtain the width necessary to display the event's time.
GetGrid | This member function is used to obtain the Month View days grid object.
GetScrollBarInfoV | This member function is used to retrieve information about the current scroll bar state.
GetViewDay | This member function is used to obtain the view's day object by the given index.
GetViewDayDate | Call this member function to obtain the date of a day view by the day's index.
GetWeekDayTextIfNeed | This member function is used to obtain week day header text.
OnKeyDown | This member function is used to process keyboard events.
OnLButtonDown | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
Populate | This member function is used to populate the view with data for all items contained in the view.
ScrollV | This member function is used to scroll the contents of a view.
ShowDay | This member function is used to show the specified day in the calendar view.


CXTPCalendarMonthView::_CalculateDateFormats Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::_CalculateDateFormats Method

This member function is used to calculate the view's date format based on the current locale.

void _CalculateDateFormats(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::_CalculateEventCaptionFormat Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::_CalculateEventCaptionFormat Method

This member function is used to calculate the event view's date format based on the current locale.

void _CalculateEventCaptionFormat(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::_FormatDayDate Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::_FormatDayDate Method

This member function is used to obtain the format string of a day date.

CString _FormatDayDate(
    COleDateTime dtDay,
    BOOL bLong
);
Parameters

dtDay
A COleDateTime object that contains the date to be formatted.
bLong
A BOOL. Determines whether to apply a long date format.

Returns

CString object with the formatted date.

Remarks

Call this member function to obtain the date in a form appropriate to display in the day header text.

See Also

GetViewDayCount()

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::_ReadDefaultDateFormats Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::_ReadDefaultDateFormats Method

This member function is used to build day header date format default strings.

void _ReadDefaultDateFormats();
Remarks

This member function read locale settings and fill m_strDayHeaderFormatDefaultXXX members.

See Also

_CalculateDateFormats(), CXTPCalendarView::_ReadDefaultHeaderFormats(), m_strDayHeaderFormatDefaultLong, m_strDayHeaderFormatDefaultMiddle, m_strDayHeaderFormatDefaultShort, m_strDayHeaderFormatDefaultShortest.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::_SplitDateFormat Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::_SplitDateFormat Method

This member function is used to parse the format string into tokens.

void _SplitDateFormat(
    const CString& strDateFormat,
    CStringArray& rarTokens
);
Parameters

strDateFormat
A CString that contains the string to parse.
rarTokens
A CStringArray that contains the resultant token array.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::AdjustLayout Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::AdjustLayout Method

This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcView,
    BOOL bCallPostAdjustLayout = TRUE
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcView,
    BOOL bCallPostAdjustLayout = TRUE
);
Parameters

pDC
Pointer to a valid device context.
rcView
A CRect object that contains the coordinates used to draw the view.
bCallPostAdjustLayout
A BOOL. Flag used to call for additional adjustments.

Remarks

Call Populate() prior to AdjustLayout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::Draw Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::Draw Method

This member function is used to draw the view content using the specified device context.

virtual void Draw(
    CDC* pDC
);
virtual void Draw2(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

Call AdjustLayout() before Draw(). Draw2 is called by calendar control instead of Draw when theme is set.

See Also

AdjustLayout().

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::GetEventCaptionFormat Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::GetEventCaptionFormat Method

This member function is used to obtain the event caption format flags.

virtual int GetEventCaptionFormat() const;
Returns

Integer value containing flags.

Remarks

Call this member function to obtain event caption format flags. Event caption format flags are stored in a packed form. Use bitwise operations to determine each flag state.

Body Source
int CXTPCalendarMonthView::GetEventCaptionFormat() const {
    return m_nEventCaptionFormat;
}
Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::GetEventTimeWidth Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::GetEventTimeWidth Method

This member function is used to obtain the width necessary to display the event's time.

virtual int GetEventTimeWidth() const;
Returns

An int that contains the width as an integer value.

Body Source
int CXTPCalendarMonthView::GetEventTimeWidth() const {
    return m_nEventTimeWidth;
}
Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::GetGrid Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::GetGrid Method

This member function is used to obtain the Month View days grid object.

CMonthViewGrid* GetGrid();
Returns

A pointer to a CMonthViewGrid object that contains the Month View days grid object.

See Also

CMonthViewGrid

Body Source
CXTPCalendarMonthView::CMonthViewGrid* CXTPCalendarMonthView::GetGrid() {
    return m_pGrid;
}
Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::GetScrollBarInfoV Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::GetScrollBarInfoV Method

This member function is used to retrieve information about the current scroll bar state.

virtual BOOL GetScrollBarInfoV(
    SCROLLINFO* pSI
);
Parameters

pSI
A SCROLLINFO pointer. Pointer to a scrollbar information structure.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::GetViewDay Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::GetViewDay Method

This member function is used to obtain the view's day object by the given index.

virtual CXTPCalendarMonthViewDay* GetViewDay(
    int nIndex
);
Parameters

nIndex
An int. Day view index in the view collection.

Returns

Pointer to a CXTPCalendarMonthViewDay object.

Remarks

Index numbers start with 0 and cannot be negative.

See Also

GetViewDayCount()

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::GetViewDayDate Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::GetViewDayDate Method

Call this member function to obtain the date of a day view by the day's index.

virtual COleDateTime GetViewDayDate(
    int nIndex
);
Parameters

nIndex
An int. Day view index in the view collection.

Returns

A COleDateTime object that contains the day view date and time.

Remarks

Index numbers start with 0 and cannot be negative.

See Also

GetViewDayCount()

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::GetWeekDayTextIfNeed Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::GetWeekDayTextIfNeed Method

This member function is used to obtain week day header text.

virtual void GetWeekDayTextIfNeed(
    CString* pstrText,
    int nWeekDay
);
Parameters

pstrText
[in, out] Pointer to item text;
nWeekDay
Week day number as: 1 - Sunday, 2 - Monday, ... 7 - Satyrday.

Remarks

If AskItemTextFlags has xtpCalendarItemText_MonthViewWeekDayHeader flag set - XTP_NC_CALENDAR_GETITEMTEXT notification is sent to customize standard text.

See Also

XTPCalendarGetItemText,XTPCalendarGetItemTextEx, XTP_NC_CALENDAR_GETITEMTEXT, CXTPCalendarControl::GetAskItemTextFlags, CXTPCalendarControlPaintManager::GetAskItemTextFlags, CXTPCalendarControlPaintManager::SetAskItemTextFlags, CXTPCalendarTheme::GetAskItemTextFlags, CXTPCalendarTheme::SetAskItemTextFlags

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::OnKeyDown Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::OnKeyDown Method

This member function is used to process keyboard events.

virtual void OnKeyDown(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT. Virtual key code of the given key.
nRepCnt
A UINT. Number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT. Scan code, key-transition code, previous key state, and context code.

Remarks

This method is called by the CalendarControl when the user presses keys on the keyboard.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::OnLButtonDown Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::OnLButtonDown Method

This member function is used to processes left mouse button events.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicates whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user presses the left mouse button.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::OnMouseMove Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::OnMouseMove Method

This member function is used to processes mouse movement events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::Populate Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::Populate Method

This member function is used to populate the view with data for all items contained in the view.

virtual void Populate();
Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::ScrollV Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::ScrollV Method

This member function is used to scroll the contents of a view.

virtual void ScrollV(
    int nPos,
    int nPos_raw
);
Parameters

nPos
An int that contains the position value.
nPos_raw
An int that contains the raw position value.

Remarks

ScrollV internally uses Populate() to fill new view data.

Notes

nPos is not used at this time. It is reserved for future use.

See Also

Populate(), GetScrollBarInfoV.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView::ShowDay Method

CXTPCalendarMonthView Methods, CXTPCalendarMonthView Class
CXTPCalendarMonthView::ShowDay Method

This member function is used to show the specified day in the calendar view.

virtual void ShowDay(
    const COleDateTime& date,
    BOOL bSelect = TRUE
);
Parameters

date
A COleDateTime object that contains the date to show.
bSelect
TRUE to select the specified day after showing, FALSE otherwise. TRUE is the default value.

Remarks

Call this member function to show only the specified day in the calendar view.

Group

CXTPCalendarMonthView Methods


CXTPCalendarMonthView Constructors

CXTPCalendarMonthView Class, Legend, Public Methods
CXTPCalendarMonthView Constructors
Class

CXTPCalendarMonthView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMonthView | Default object constructor.


CXTPCalendarMonthView::CXTPCalendarMonthView Constructor

CXTPCalendarMonthView Constructors, CXTPCalendarMonthView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::CXTPCalendarMonthView Constructor

Default object constructor.

CXTPCalendarMonthView(
    CXTPCalendarControl* pCalendarControl
);
Parameters

pCalendarControl
Pointer to a CXTPCalendarControl object.

See Also

~CXTPCalendarMonthView()

Group

CXTPCalendarMonthView Constructors


CXTPCalendarMonthView Destructors

CXTPCalendarMonthView Class, Legend, Public Methods
CXTPCalendarMonthView Destructors
Class

CXTPCalendarMonthView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarMonthView | Default class destructor.


CXTPCalendarMonthView::~CXTPCalendarMonthView Destructor

CXTPCalendarMonthView Destructors, CXTPCalendarMonthView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::~CXTPCalendarMonthView Destructor

Default class destructor.

virtual ~CXTPCalendarMonthView();
Remarks

Handles member item deallocation.

Group

CXTPCalendarMonthView Destructors


CXTPCalendarMonthView Nested Types

CXTPCalendarMonthView Class, Public Nested Types
CXTPCalendarMonthView Nested Types
Class

CXTPCalendarMonthView Class

Public Nested Types
Public Nested Type | Description
TBase |


CXTPCalendarMonthView::TBase Nested Type

CXTPCalendarMonthView Nested Types, CXTPCalendarMonthView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthView::TBase Nested Type
typedef CXTPCalendarViewT< CXTPCalendarMonthViewDay, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW> TBase;
Remarks

Base class type definition

Group

CXTPCalendarMonthView Nested Types


CXTPCalendarMonthViewDay Class

XTPCalendarMonthViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarMonthViewDay Data Members, CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Constructors, CXTPCalendarMonthViewDay Destructors, CXTPCalendarMonthViewDay Nested Types, CXTPCalendarMonthViewDay Constructors, CXTPCalendarMonthViewDay Data Members, CXTPCalendarMonthViewDay Destructors, CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay Class

This class represents a day view portion of the CalendarMonthView.

Class Hierarchy

class CXTPCalendarMonthViewDay : public CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW, CXTPCalendarMonthViewDay >;
File

XTPCalendarMonthViewDay.h

Remarks

It represents a specific view of the CalendarView's associated events data grouped by one day and provides basic functionality on this data using user input through keyboard and mouse.

CXTPCalendarMonthViewDay is based on CXTPCalendarViewDayT template class. It inherits basic behavior from its parent and overlaps/add some methods to get its own behavior and look.

See Also

CXTPCalendarViewDay, CXTPCalendarViewDayT

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarMonthViewDay Constructors
CXTPCalendarMonthViewDay Constructors | Description
CXTPCalendarMonthViewDay | Default object constructor. Construct a CXTPCalendarMonthViewDay object.
CXTPCalendarMonthViewDay Data Members
CXTPCalendarMonthViewDay Data Members | Description
m_nWeekDayIndex | Day identifier.
m_nWeekIndex | Week identifier.
CXTPCalendarMonthViewDay Destructors
CXTPCalendarMonthViewDay Destructors | Description
~CXTPCalendarMonthViewDay | Default class destructor.
CXTPCalendarMonthViewDay Methods
CXTPCalendarMonthViewDay Methods | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
CalcDayDateRect | This member function is used to calculate the day date bounding rectangle.
Draw | This member function is used to draw the view contents using the specified device context.
FillHitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.
GetDayEventsRect | This member function is used to calculate the day view area in which to draw event views.
GetPThis | This member function is used to obtain a pointer to itself.
HitTestEx | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.
OnLButtonDown | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
CXTPCalendarMonthViewDay Nested Types
CXTPCalendarMonthViewDay Nested Types | Description
TBase | Base class type definition.


CXTPCalendarMonthViewDay Data Members

CXTPCalendarMonthViewDay Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay Data Members
Class

CXTPCalendarMonthViewDay Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nWeekDayIndex | Day identifier.
m_nWeekIndex | Week identifier.


CXTPCalendarMonthViewDay::m_nWeekDayIndex Data Member

CXTPCalendarMonthViewDay Data Members, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::m_nWeekDayIndex Data Member

Day identifier.

int m_nWeekDayIndex;
Group

CXTPCalendarMonthViewDay Data Members


CXTPCalendarMonthViewDay::m_nWeekIndex Data Member

CXTPCalendarMonthViewDay Data Members, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::m_nWeekIndex Data Member

Week identifier.

int m_nWeekIndex;
Group

CXTPCalendarMonthViewDay Data Members


CXTPCalendarMonthViewDay Methods

CXTPCalendarMonthViewDay Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay Methods
Class

CXTPCalendarMonthViewDay Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetPThis | This member function is used to obtain a pointer to itself.
OnLButtonDown | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
CalcDayDateRect | This member function is used to calculate the day date bounding rectangle.
Draw | This member function is used to draw the view contents using the specified device context.
FillHitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.
GetDayEventsRect | This member function is used to calculate the day view area in which to draw event views.
HitTestEx | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.


CXTPCalendarMonthViewDay::AdjustLayout Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcDay
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcDay
);
Parameters

pDC
Pointer to a valid device context.
rcDay
A CRect object that contains the coordinates for drawing the view.

Remarks

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay::CalcDayDateRect Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::CalcDayDateRect Method

This member function is used to calculate the day date bounding rectangle.

CRect CalcDayDateRect() const;
Remarks

Call this member function to determine the day view header's bounding rectangle.

Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay::Draw Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::Draw Method

This member function is used to draw the view contents using the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

Call AdjustLayout() before Draw()

See Also

AdjustLayout(CRect rcDay)

Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay::FillHitTestEx Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::FillHitTestEx Method

This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.

virtual void FillHitTestEx(
    XTP_CALENDAR_HITTESTINFO_MONTH_VIEW* pInfo
);
Parameters

pInfo
Pointer to XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.

Remarks

Call this member function to gather hit-test information.

See Also

XTP_CALENDAR_HITTESTINFO_MONTH_VIEW

Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay::GetDayEventsRect Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::GetDayEventsRect Method

This member function is used to calculate the day view area in which to draw event views.

CRect GetDayEventsRect() const;
Returns

CRect object with rectangle coordinates.

Remarks

Call this member function to determine day view area that is used for drawing the event views.

Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay::GetPThis Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::GetPThis Method

This member function is used to obtain a pointer to itself.

virtual CXTPCalendarMonthViewDay* GetPThis();
Returns

Pointer to a CXTPCalendarMonthViewDay.

Remarks

Call this member function to get the "this" pointer.

Body Source
CXTPCalendarMonthViewDay* CXTPCalendarMonthViewDay::GetPThis() {
    return this;
}
Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay::HitTestEx Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::HitTestEx Method

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.

virtual BOOL HitTestEx(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO_MONTH_VIEW* pHitTest
);
Parameters

pt
A CPoint that contains the coordinates of the point test.
pHitTest
A pointer to a _THitTest structure.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

Implements standard functionality for the HitTestEx method.

See Also

XTP_CALENDAR_HITTESTINFO

Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay::OnLButtonDown Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::OnLButtonDown Method

This member function is used to processes left mouse button events.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicates whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user presses the left mouse button.

Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay::OnMouseMove Method

CXTPCalendarMonthViewDay Methods, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::OnMouseMove Method

This member function is used to processes mouse movement events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Group

CXTPCalendarMonthViewDay Methods


CXTPCalendarMonthViewDay Constructors

CXTPCalendarMonthViewDay Class, Legend, Public Methods
CXTPCalendarMonthViewDay Constructors
Class

CXTPCalendarMonthViewDay Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMonthViewDay | Default object constructor. Construct a CXTPCalendarMonthViewDay object.


CXTPCalendarMonthViewDay::CXTPCalendarMonthViewDay Constructor

CXTPCalendarMonthViewDay Constructors, CXTPCalendarMonthViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::CXTPCalendarMonthViewDay Constructor

Default object constructor. Construct a CXTPCalendarMonthViewDay object.

CXTPCalendarMonthViewDay(
    CXTPCalendarMonthView* pMonthView,
    int nWeekIndex,
    int nWeekDayIndex
);
Parameters

pMonthView
Pointer to CXTPCalendarMonthView object.
nWeekIndex
An int that contains a week view identifier.
nWeekDayIndex
An int that contains a day view identifier.

See Also

~CXTPCalendarMonthViewDay()

Group

CXTPCalendarMonthViewDay Constructors


CXTPCalendarMonthViewDay Destructors

CXTPCalendarMonthViewDay Class, Legend, Public Methods
CXTPCalendarMonthViewDay Destructors
Class

CXTPCalendarMonthViewDay Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarMonthViewDay | Default class destructor.


CXTPCalendarMonthViewDay::~CXTPCalendarMonthViewDay Destructor

CXTPCalendarMonthViewDay Destructors, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::~CXTPCalendarMonthViewDay Destructor

Default class destructor.

virtual ~CXTPCalendarMonthViewDay();
Remarks

Handles member items deallocation.

Group

CXTPCalendarMonthViewDay Destructors


CXTPCalendarMonthViewDay Nested Types

CXTPCalendarMonthViewDay Class, Public Nested Types
CXTPCalendarMonthViewDay Nested Types
Class

CXTPCalendarMonthViewDay Class

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition.


CXTPCalendarMonthViewDay::TBase Nested Type

CXTPCalendarMonthViewDay Nested Types, CXTPCalendarMonthViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewDay::TBase Nested Type

Base class type definition.

typedef CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW, CXTPCalendarMonthViewDay > TBase;
Group

CXTPCalendarMonthViewDay Nested Types


CXTPCalendarMonthViewEvent Class

XTPCalendarMonthViewEvent.h, Classes, Legend, Members, Topics, CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Constructors, CXTPCalendarMonthViewEvent Destructors, CXTPCalendarMonthViewEvent Nested Types, CXTPCalendarMonthViewEvent Constructors, CXTPCalendarMonthViewEvent Destructors, CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent Class

This class represents an event view portion of the CalendarMonthViewDay.

Class Hierarchy

class CXTPCalendarMonthViewEvent : public CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW>;
File

XTPCalendarMonthViewEvent.h

Remarks

It represents a specific view of the event associated data according to various view types and display settings and provides basic functionality on this data using user input through keyboard and mouse.

CXTPCalendarMonthViewEvent is based on CXTPCalendarViewEventT template class. It inherits basic behavior from its and overlaps and add some to get its own behavior and look.

See Also

CXTPCalendarViewEvent, CXTPCalendarViewEventT

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarMonthViewEvent Constructors
CXTPCalendarMonthViewEvent Constructors | Description
CXTPCalendarMonthViewEvent | Default object constructor.
CXTPCalendarMonthViewEvent Destructors
CXTPCalendarMonthViewEvent Destructors | Description
~CXTPCalendarMonthViewEvent | Default class destructor.
CXTPCalendarMonthViewEvent Methods
CXTPCalendarMonthViewEvent Methods | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the view content using the specified device context.
GetSubjectEditorFont | This member function is used to obtain the editor window font.
HitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.
IsShowEndTime | This member function is used to obtain the value of the "show end time" flag.
IsTimeAsClock | This member function is used to obtain the value of the "show time as clock" flag.
IsVisible | This member function is used to obtain the value of the view visible flag.
OnPostAdjustLayout | This member function is used to perform additional adjustments.
CXTPCalendarMonthViewEvent Nested Types
CXTPCalendarMonthViewEvent Nested Types | Description
TBase |


CXTPCalendarMonthViewEvent Methods

CXTPCalendarMonthViewEvent Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent Methods
Class

CXTPCalendarMonthViewEvent Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetSubjectEditorFont | This member function is used to obtain the editor window font.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the view content using the specified device context.
HitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.
IsShowEndTime | This member function is used to obtain the value of the "show end time" flag.
IsTimeAsClock | This member function is used to obtain the value of the "show time as clock" flag.
IsVisible | This member function is used to obtain the value of the view visible flag.
OnPostAdjustLayout | This member function is used to perform additional adjustments.


CXTPCalendarMonthViewEvent::AdjustLayout Method

CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcEventMax,
    int nEventPlaceNumber
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcEventMax,
    int nEventPlaceNumber
);
Parameters

pDC
Pointer to a valid device context.
rcEventMax
A CRect object that contains the coordinates for drawing the view.
nEventPlaceNumber
An int that contains the sequential place number.

Remarks

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarMonthViewEvent Methods


CXTPCalendarMonthViewEvent::Draw Method

CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::Draw Method

This member function is used to draw the view content using the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

Call AdjustLayout() before Draw()

See Also

AdjustLayout(CRect rcDay)

Group

CXTPCalendarMonthViewEvent Methods


CXTPCalendarMonthViewEvent::GetSubjectEditorFont Method

CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::GetSubjectEditorFont Method

This member function is used to obtain the editor window font.

virtual CFont* GetSubjectEditorFont();
Returns

A pointer to a CFont object that contains the editor window font.

Group

CXTPCalendarMonthViewEvent Methods


CXTPCalendarMonthViewEvent::HitTestEx Method

CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::HitTestEx Method

This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.

virtual BOOL HitTestEx(
    CPoint point,
    XTP_CALENDAR_HITTESTINFO_MONTH_VIEW* pInfo
);
Parameters

point
A CPoint that contains the point to test.
pInfo
A pointer to a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.

Remarks

Call this member function to gather hit test information from the day view.

See Also

XTP_CALENDAR_HITTESTINFO_MONTH_VIEW

Group

CXTPCalendarMonthViewEvent Methods


CXTPCalendarMonthViewEvent::IsShowEndTime Method

CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::IsShowEndTime Method

This member function is used to obtain the value of the "show end time" flag.

BOOL IsShowEndTime();
Returns

A BOOL. TRUE if the view shows the end time value. FALSE otherwise.

Remarks

Call this member function to determine the value of the "show end time" flag.

Group

CXTPCalendarMonthViewEvent Methods


CXTPCalendarMonthViewEvent::IsTimeAsClock Method

CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::IsTimeAsClock Method

This member function is used to obtain the value of the "show time as clock" flag.

BOOL IsTimeAsClock();
Returns

A BOOL. TRUE if the view shows the time as a clock. FALSE otherwise.

Remarks

Call this member function to determine the value of the "show time as clock" flag.

Group

CXTPCalendarMonthViewEvent Methods


CXTPCalendarMonthViewEvent::IsVisible Method

CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::IsVisible Method

This member function is used to obtain the value of the view visible flag.

virtual BOOL IsVisible();
Returns

A BOOL. TRUE if the view is visible. FALSE otherwise.

Remarks

Call this member function to determine the value of the visible flag.

Group

CXTPCalendarMonthViewEvent Methods


CXTPCalendarMonthViewEvent::OnPostAdjustLayout Method

CXTPCalendarMonthViewEvent Methods, CXTPCalendarMonthViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::OnPostAdjustLayout Method

This member function is used to perform additional adjustments.

virtual void OnPostAdjustLayout();
Remarks

Call this member function to perform additional adjustments after all adjustment activities are completed.

Group

CXTPCalendarMonthViewEvent Methods


CXTPCalendarMonthViewEvent Constructors

CXTPCalendarMonthViewEvent Class, Legend, Public Methods
CXTPCalendarMonthViewEvent Constructors
Class

CXTPCalendarMonthViewEvent Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMonthViewEvent | Default object constructor.


CXTPCalendarMonthViewEvent::CXTPCalendarMonthViewEvent Constructor

CXTPCalendarMonthViewEvent Constructors, CXTPCalendarMonthViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::CXTPCalendarMonthViewEvent Constructor

Default object constructor.

CXTPCalendarMonthViewEvent(
    CXTPCalendarEvent* pEvent,
    CXTPCalendarMonthViewGroup* pViewGroup
);
Parameters

pEvent
Pointer to CXTPCalendarEvent.
pViewGroup
Pointer to CXTPCalendarMonthViewGroup object.

See Also

~CXTPCalendarWeekViewDay()

Group

CXTPCalendarMonthViewEvent Constructors


CXTPCalendarMonthViewEvent Destructors

CXTPCalendarMonthViewEvent Class, Legend, Public Methods
CXTPCalendarMonthViewEvent Destructors
Class

CXTPCalendarMonthViewEvent Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarMonthViewEvent | Default class destructor.


CXTPCalendarMonthViewEvent::~CXTPCalendarMonthViewEvent Destructor

CXTPCalendarMonthViewEvent Destructors, CXTPCalendarMonthViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::~CXTPCalendarMonthViewEvent Destructor

Default class destructor.

virtual ~CXTPCalendarMonthViewEvent();
Group

CXTPCalendarMonthViewEvent Destructors


CXTPCalendarMonthViewEvent Nested Types

CXTPCalendarMonthViewEvent Class, Public Nested Types
CXTPCalendarMonthViewEvent Nested Types
Class

CXTPCalendarMonthViewEvent Class

Public Nested Types
Public Nested Type | Description
TBase |


CXTPCalendarMonthViewEvent::TBase Nested Type

CXTPCalendarMonthViewEvent Nested Types, CXTPCalendarMonthViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewEvent::TBase Nested Type
typedef CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW> TBase;
Remarks

Base class type definition.

Group

CXTPCalendarMonthViewEvent Nested Types


CXTPCalendarMonthViewGroup Class

XTPCalendarMonthViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarMonthViewGroup Methods, CXTPCalendarMonthViewGroup Constructors, CXTPCalendarMonthViewGroup Destructors, CXTPCalendarMonthViewGroup Nested Types, CXTPCalendarMonthViewGroup Constructors, CXTPCalendarMonthViewGroup Destructors, CXTPCalendarMonthViewGroup Methods, CXTPCalendarMonthViewGroup Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewGroup Class

This class represents a single resource view portion of the Calendar Month View.

Class Hierarchy

class CXTPCalendarMonthViewGroup : public CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW, CXTPCalendarMonthViewGroup>;
File

XTPCalendarMonthViewDay.h

Remarks

It represents a specific view of the CalendarView's associated events data grouped by one day and one resource group. And provides basic functionality on this data using user input through keyboard and mouse.

See Also

CXTPCalendarMonthViewDay

Group

Classes

Legend
Method
protected
virtual
CXTPCalendarMonthViewGroup Constructors
CXTPCalendarMonthViewGroup Constructors | Description
CXTPCalendarMonthViewGroup | Default object constructor. Construct CXTPCalendarMonthViewGroup object.
CXTPCalendarMonthViewGroup Destructors
CXTPCalendarMonthViewGroup Destructors | Description
~CXTPCalendarMonthViewGroup | Default class destructor.
CXTPCalendarMonthViewGroup Methods
CXTPCalendarMonthViewGroup Methods | Description
FillHitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.
GetPThis | This member function is used to obtain a pointer to itself.
GetTooltipRect | Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position
CXTPCalendarMonthViewGroup Nested Types
CXTPCalendarMonthViewGroup Nested Types | Description
TBase | Base class type definition.


CXTPCalendarMonthViewGroup Methods

CXTPCalendarMonthViewGroup Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewGroup Methods
Class

CXTPCalendarMonthViewGroup Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
FillHitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.
GetPThis | This member function is used to obtain a pointer to itself.
Public Methods
Public Methods
Public Method | Description
GetTooltipRect | Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position


CXTPCalendarMonthViewGroup::FillHitTestEx Method

CXTPCalendarMonthViewGroup Methods, CXTPCalendarMonthViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewGroup::FillHitTestEx Method

This member function is used to fill a XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.

virtual void FillHitTestEx(
    XTP_CALENDAR_HITTESTINFO_MONTH_VIEW* pHitTest
);
Parameters

pHitTest
Pointer to XTP_CALENDAR_HITTESTINFO_MONTH_VIEW structure.

Remarks

Call this member function to gather hit-test information.

See Also

XTP_CALENDAR_HITTESTINFO_MONTH_VIEW

Group

CXTPCalendarMonthViewGroup Methods


CXTPCalendarMonthViewGroup::GetPThis Method

CXTPCalendarMonthViewGroup Methods, CXTPCalendarMonthViewGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewGroup::GetPThis Method

This member function is used to obtain a pointer to itself.

virtual CXTPCalendarMonthViewGroup* GetPThis();
Returns

Pointer to a CXTPCalendarMonthViewGroup.

Remarks

Call this member function to get the "this" pointer.

Body Source
CXTPCalendarMonthViewGroup* CXTPCalendarMonthViewGroup::GetPThis() {
    return this;
}
Group

CXTPCalendarMonthViewGroup Methods


CXTPCalendarMonthViewGroup::GetTooltipRect Method

CXTPCalendarMonthViewGroup Methods, CXTPCalendarMonthViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewGroup::GetTooltipRect Method

Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position

virtual CRect GetTooltipRect(
    const CPoint& ptHit,
    const XTP_CALENDAR_HITTESTINFO& hitInfo
);
Returns

A CRect object with relative coordinates of the tooltip.

Remarks

This member function returns a rectangle calculated as a bottom cell rect of the day area where user currently holds a mouse on.

Group

CXTPCalendarMonthViewGroup Methods


CXTPCalendarMonthViewGroup Constructors

CXTPCalendarMonthViewGroup Class, Legend, Public Methods
CXTPCalendarMonthViewGroup Constructors
Class

CXTPCalendarMonthViewGroup Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMonthViewGroup | Default object constructor. Construct CXTPCalendarMonthViewGroup object.


CXTPCalendarMonthViewGroup::CXTPCalendarMonthViewGroup Constructor

CXTPCalendarMonthViewGroup Constructors, CXTPCalendarMonthViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewGroup::CXTPCalendarMonthViewGroup Constructor

Default object constructor. Construct CXTPCalendarMonthViewGroup object.

CXTPCalendarMonthViewGroup(
    CXTPCalendarMonthViewDay* pViewDay
);
Parameters

pViewDay
Pointer to CXTPCalendarMonthViewDay object.

Group

CXTPCalendarMonthViewGroup Constructors


CXTPCalendarMonthViewGroup Destructors

CXTPCalendarMonthViewGroup Class, Legend, Public Methods
CXTPCalendarMonthViewGroup Destructors
Class

CXTPCalendarMonthViewGroup Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarMonthViewGroup | Default class destructor.


CXTPCalendarMonthViewGroup::~CXTPCalendarMonthViewGroup Destructor

CXTPCalendarMonthViewGroup Destructors, CXTPCalendarMonthViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewGroup::~CXTPCalendarMonthViewGroup Destructor

Default class destructor.

virtual ~CXTPCalendarMonthViewGroup();
Remarks

Handles member items deallocation.

Group

CXTPCalendarMonthViewGroup Destructors


CXTPCalendarMonthViewGroup Nested Types

CXTPCalendarMonthViewGroup Class, Public Nested Types
CXTPCalendarMonthViewGroup Nested Types
Class

CXTPCalendarMonthViewGroup Class

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition.


CXTPCalendarMonthViewGroup::TBase Nested Type

CXTPCalendarMonthViewGroup Nested Types, CXTPCalendarMonthViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarMonthViewGroup::TBase Nested Type

Base class type definition.

typedef CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW, CXTPCalendarMonthViewGroup > TBase;
Group

CXTPCalendarMonthViewGroup Nested Types


CXTPCalendarOccurSeriesChooseDlg Class

XTPCalendarOccurSeriesChooseDlg.h, Classes, Legend, Members, Topics, CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Methods, CXTPCalendarOccurSeriesChooseDlg Constructors, CXTPCalendarOccurSeriesChooseDlg Destructors, CXTPCalendarOccurSeriesChooseDlg Constructors, CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Destructors, CXTPCalendarOccurSeriesChooseDlg Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg Class

This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern).

Class Hierarchy

class CXTPCalendarOccurSeriesChooseDlg : public CDialog;
File

XTPCalendarOccurSeriesChooseDlg.h

Remarks

This is useful in operations with events like edit or delete event. The dialog items inscriptions are customizable and loaded from resources.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarOccurSeriesChooseDlg Constructors
CXTPCalendarOccurSeriesChooseDlg Constructors | Description
CXTPCalendarOccurSeriesChooseDlg | Default object constructor.
CXTPCalendarOccurSeriesChooseDlg Data Members
CXTPCalendarOccurSeriesChooseDlg Data Members | Description
m_bOccur | in/out] Contain default/selected choice.
m_ctrlIcon | Dialog icon control.
m_ctrlMessage | Dialog message text control.
m_ctrlOccur | Occurrence radio button control.
m_ctrlSeries | Series radio button control.
m_hIcon | Dialog icon resource ID.
m_nIDResourceLabels | Dialog labels string resource ID.
m_strMessage | Dialog message text prepared string.
m_strOccur | Occurrence radio button label text string.
m_strSeries | Series radio button label text string.
m_strTitle | Dialog title string.
CXTPCalendarOccurSeriesChooseDlg Destructors
CXTPCalendarOccurSeriesChooseDlg Destructors | Description
~CXTPCalendarOccurSeriesChooseDlg | Default class destructor.
CXTPCalendarOccurSeriesChooseDlg Methods
CXTPCalendarOccurSeriesChooseDlg Methods | Description
SetEvent | Update dialog information from the specified event.


CXTPCalendarOccurSeriesChooseDlg Data Members

CXTPCalendarOccurSeriesChooseDlg Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg Data Members
Class

CXTPCalendarOccurSeriesChooseDlg Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_ctrlIcon | Dialog icon control.
m_ctrlMessage | Dialog message text control.
m_ctrlOccur | Occurrence radio button control.
m_ctrlSeries | Series radio button control.
m_hIcon | Dialog icon resource ID.
m_nIDResourceLabels | Dialog labels string resource ID.
m_strMessage | Dialog message text prepared string.
m_strOccur | Occurrence radio button label text string.
m_strSeries | Series radio button label text string.
m_strTitle | Dialog title string.
Public Data Members
Public Data Member | Description
m_bOccur | in/out] Contain default/selected choice.


CXTPCalendarOccurSeriesChooseDlg::m_bOccur Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_bOccur Data Member

in/out] Contain default/selected choice.

BOOL m_bOccur;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_ctrlIcon Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_ctrlIcon Data Member

Dialog icon control.

CStatic m_ctrlIcon;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_ctrlMessage Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_ctrlMessage Data Member

Dialog message text control.

CStatic m_ctrlMessage;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_ctrlOccur Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_ctrlOccur Data Member

Occurrence radio button control.

CButton m_ctrlOccur;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_ctrlSeries Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_ctrlSeries Data Member

Series radio button control.

CButton m_ctrlSeries;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_hIcon Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_hIcon Data Member

Dialog icon resource ID.

HICON m_hIcon;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_nIDResourceLabels Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_nIDResourceLabels Data Member

Dialog labels string resource ID.

UINT m_nIDResourceLabels;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_strMessage Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_strMessage Data Member

Dialog message text prepared string.

CString m_strMessage;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_strOccur Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_strOccur Data Member

Occurrence radio button label text string.

CString m_strOccur;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_strSeries Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_strSeries Data Member

Series radio button label text string.

CString m_strSeries;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg::m_strTitle Data Member

CXTPCalendarOccurSeriesChooseDlg Data Members, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::m_strTitle Data Member

Dialog title string.

CString m_strTitle;
Group

CXTPCalendarOccurSeriesChooseDlg Data Members


CXTPCalendarOccurSeriesChooseDlg Methods

CXTPCalendarOccurSeriesChooseDlg Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg Methods
Class

CXTPCalendarOccurSeriesChooseDlg Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
SetEvent | Update dialog information from the specified event.


CXTPCalendarOccurSeriesChooseDlg::SetEvent Method

CXTPCalendarOccurSeriesChooseDlg Methods, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::SetEvent Method

Update dialog information from the specified event.

virtual void SetEvent(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to the calendar event object.

Remarks

If message string has %s format specifier - event subject is inserted instead by default.

Group

CXTPCalendarOccurSeriesChooseDlg Methods


CXTPCalendarOccurSeriesChooseDlg Constructors

CXTPCalendarOccurSeriesChooseDlg Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg Constructors
Class

CXTPCalendarOccurSeriesChooseDlg Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarOccurSeriesChooseDlg | Default object constructor.


CXTPCalendarOccurSeriesChooseDlg::CXTPCalendarOccurSeriesChooseDlg Constructor

CXTPCalendarOccurSeriesChooseDlg Constructors, CXTPCalendarOccurSeriesChooseDlg Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::CXTPCalendarOccurSeriesChooseDlg Constructor

Default object constructor.

CXTPCalendarOccurSeriesChooseDlg(
    CWnd* pParent,
    UINT nIDResourceLabels,
    LPCTSTR lpszResourceIcon = IDI_EXCLAMATION,
    UINT nIDTemplate = CXTPCalendarOccurSeriesChooseDlg::IDD
);
Parameters

pParent
Pointer to the parent window.
nIDResourceLabels
Dialog labels string resource ID.
lpszResourceIcon
Dialog icon resource ID.
nIDTemplate
[in] Contains the ID number of a dialog-box template resource.

Remarks

The string format for nIDResourceLabels is: "Title\nOccurrence\nSeries\nMessage" Where:

  • Title - Dialog window title text.
  • Occurrence - Occurrence radio button label.
  • Series - Series radio button label.
  • Message - Dialog message text. If message string has %s format specifier - event subject is inserted instead. See SetEvent() method.
See Also

~CXTPCalendarEvent()

Group

CXTPCalendarOccurSeriesChooseDlg Constructors


CXTPCalendarOccurSeriesChooseDlg Destructors

CXTPCalendarOccurSeriesChooseDlg Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg Destructors
Class

CXTPCalendarOccurSeriesChooseDlg Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarOccurSeriesChooseDlg | Default class destructor.


CXTPCalendarOccurSeriesChooseDlg::~CXTPCalendarOccurSeriesChooseDlg Destructor

CXTPCalendarOccurSeriesChooseDlg Destructors, CXTPCalendarOccurSeriesChooseDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOccurSeriesChooseDlg::~CXTPCalendarOccurSeriesChooseDlg Destructor

Default class destructor.

virtual ~CXTPCalendarOccurSeriesChooseDlg();
Group

CXTPCalendarOccurSeriesChooseDlg Destructors


CXTPCalendarOptions Class

XTPCalendarOptions.h, Classes, Legend, Members, Topics, CXTPCalendarOptions Data Members, CXTPCalendarOptions Methods, CXTPCalendarOptions Constructors, CXTPCalendarOptions Destructors, CXTPCalendarOptions Constructors, CXTPCalendarOptions Data Members, CXTPCalendarOptions Destructors, CXTPCalendarOptions Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOptions Class

Structure contains all calendar options.

Class Hierarchy

class CXTPCalendarOptions;
File

XTPCalendarOptions.h

Remarks

This structure contains all options which could be changed by the user for CXTPCalendarControl.

See Also

CXTPCalendarControl, XTPCalendarWeekDay, XTPCalendarWeekDay

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarOptions Constructors
CXTPCalendarOptions Constructors | Description
CXTPCalendarOptions | Default object constructor.
CXTPCalendarOptions Data Members
CXTPCalendarOptions Data Members | Description
bDayView_AutoResetBusyFlag | If TRUE - 'Busy' event status will be automatically set to 'Free' when moving event from hours area to all day events area and vice versa.
bDayView_Scale2Visible | TRUE when secondary time scale is visible in day view, FALSE otherwise.
bDayView_TimeScaleShowMinutes | If TRUE - minutes will be shown on time scale.
bEnableAddNewTooltip | TRUE when "add new appointment" tooltips appears, FALSE otherwise
bEnableInPlaceCreateEvent | Set TRUE to enable in-place event creation, FALSE otherwise.
bEnableInPlaceEditEventSubject_AfterEventResize | Set TRUE to enable in-place edit event subject after event resize, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByF2 | Set TRUE to enable in-place edit event subject by F2, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByMouseClick | Set TRUE to enable in-place edit event subject by Mouse Click, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByTab | Set TRUE to enable in-place edit event subject by TAB, FALSE otherwise.
bEnablePrevNextEventButtons | TRUE when "Prev/Next Appointment" buttons are enabled, FALSE otherwise
bMonthView_CompressWeekendDays | TRUE when compressing weekend days in month view, FALSE otherwise.
bMonthView_ShowEndDate | TRUE when showing event end date in month view, FALSE otherwise.
bMonthView_ShowTimeAsClocks | TRUE when showing event time as graphical clocks in month view, FALSE otherwise.
bUseOutlookFontGlyphs | Set TRUE to use 'MS Outlook' font to display Glyps, otherwise bitmaps are used.
bWeekView_ShowEndDate | TRUE when showing event end date in week view, FALSE otherwise.
bWeekView_ShowTimeAsClocks | TRUE when showing event time as graphical clocks in week view, FALSE otherwise.
dtWorkDayEndTime | This member contains work day end time.
dtWorkDayStartTime | This member contains work day start time.
dwAdditionalOptions | Additional calendar options.
m_pDataProvider | A stored pointer to the owner data provider.
nDayView_CurrentTimeMarkVisible | A set of flags which define when Current Time Mark on the timescale is visible.
nDayView_ScaleInterval | DayView scale interval in minutes.
nFirstDayOfTheWeek | This member shows the first day of the week using XTPCalendarWeekDay enum.
nWorkWeekMask | This structure member represents week working days using XTPCalendarWeekDay enumeration.
strDayView_Scale2Label | Stores secondary time scale label (day view)
strDayView_ScaleLabel | Stores main time scale label (day view)
strTooltipAddNewText | Text for "add new appointment" tooltip.
tziDayView_Scale2TimeZone | Stores time zone information for the secondary time scale.
CXTPCalendarOptions Destructors
CXTPCalendarOptions Destructors | Description
~CXTPCalendarOptions | Default Destructor.
CXTPCalendarOptions Methods
CXTPCalendarOptions Methods | Description
DoPropExchange | This method reads or writes data from or to an storage.
GetCurrentTimeZoneInfo | Get full information about current time zone.
OnOptionsChanged | This member function is called when option was changed.
SetDataProvider | This member function sets the custom data provider for the control.


CXTPCalendarOptions Data Members

CXTPCalendarOptions Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOptions Data Members
Class

CXTPCalendarOptions Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pDataProvider | A stored pointer to the owner data provider.
Public Data Members
Public Data Member | Description
bDayView_AutoResetBusyFlag | If TRUE - 'Busy' event status will be automatically set to 'Free' when moving event from hours area to all day events area and vice versa.
bDayView_Scale2Visible | TRUE when secondary time scale is visible in day view, FALSE otherwise.
bDayView_TimeScaleShowMinutes | If TRUE - minutes will be shown on time scale.
bEnableAddNewTooltip | TRUE when "add new appointment" tooltips appears, FALSE otherwise
bEnableInPlaceCreateEvent | Set TRUE to enable in-place event creation, FALSE otherwise.
bEnableInPlaceEditEventSubject_AfterEventResize | Set TRUE to enable in-place edit event subject after event resize, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByF2 | Set TRUE to enable in-place edit event subject by F2, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByMouseClick | Set TRUE to enable in-place edit event subject by Mouse Click, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByTab | Set TRUE to enable in-place edit event subject by TAB, FALSE otherwise.
bEnablePrevNextEventButtons | TRUE when "Prev/Next Appointment" buttons are enabled, FALSE otherwise
bMonthView_CompressWeekendDays | TRUE when compressing weekend days in month view, FALSE otherwise.
bMonthView_ShowEndDate | TRUE when showing event end date in month view, FALSE otherwise.
bMonthView_ShowTimeAsClocks | TRUE when showing event time as graphical clocks in month view, FALSE otherwise.
bUseOutlookFontGlyphs | Set TRUE to use 'MS Outlook' font to display Glyps, otherwise bitmaps are used.
bWeekView_ShowEndDate | TRUE when showing event end date in week view, FALSE otherwise.
bWeekView_ShowTimeAsClocks | TRUE when showing event time as graphical clocks in week view, FALSE otherwise.
dtWorkDayEndTime | This member contains work day end time.
dtWorkDayStartTime | This member contains work day start time.
dwAdditionalOptions | Additional calendar options.
nDayView_CurrentTimeMarkVisible | A set of flags which define when Current Time Mark on the timescale is visible.
nDayView_ScaleInterval | DayView scale interval in minutes.
nFirstDayOfTheWeek | This member shows the first day of the week using XTPCalendarWeekDay enum.
nWorkWeekMask | This structure member represents week working days using XTPCalendarWeekDay enumeration.
strDayView_Scale2Label | Stores secondary time scale label (day view)
strDayView_ScaleLabel | Stores main time scale label (day view)
strTooltipAddNewText | Text for "add new appointment" tooltip.
tziDayView_Scale2TimeZone | Stores time zone information for the secondary time scale.


CXTPCalendarOptions::bDayView_AutoResetBusyFlag Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bDayView_AutoResetBusyFlag Data Member

If TRUE - 'Busy' event status will be automatically set to 'Free' when moving event from hours area to all day events area and vice versa.

BOOL bDayView_AutoResetBusyFlag;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bDayView_Scale2Visible Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bDayView_Scale2Visible Data Member

TRUE when secondary time scale is visible in day view, FALSE otherwise.

BOOL bDayView_Scale2Visible;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bDayView_TimeScaleShowMinutes Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bDayView_TimeScaleShowMinutes Data Member

If TRUE - minutes will be shown on time scale.

BOOL bDayView_TimeScaleShowMinutes;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bEnableAddNewTooltip Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bEnableAddNewTooltip Data Member

TRUE when "add new appointment" tooltips appears, FALSE otherwise

BOOL bEnableAddNewTooltip;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bEnableInPlaceCreateEvent Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bEnableInPlaceCreateEvent Data Member

Set TRUE to enable in-place event creation, FALSE otherwise.

BOOL bEnableInPlaceCreateEvent;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bEnableInPlaceEditEventSubject_AfterEventResize Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bEnableInPlaceEditEventSubject_AfterEventResize Data Member

Set TRUE to enable in-place edit event subject after event resize, FALSE otherwise.

BOOL bEnableInPlaceEditEventSubject_AfterEventResize;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByF2 Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByF2 Data Member

Set TRUE to enable in-place edit event subject by F2, FALSE otherwise.

BOOL bEnableInPlaceEditEventSubject_ByF2;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByMouseClick Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByMouseClick Data Member

Set TRUE to enable in-place edit event subject by Mouse Click, FALSE otherwise.

BOOL bEnableInPlaceEditEventSubject_ByMouseClick;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByTab Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByTab Data Member

Set TRUE to enable in-place edit event subject by TAB, FALSE otherwise.

BOOL bEnableInPlaceEditEventSubject_ByTab;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bEnablePrevNextEventButtons Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bEnablePrevNextEventButtons Data Member

TRUE when "Prev/Next Appointment" buttons are enabled, FALSE otherwise

BOOL bEnablePrevNextEventButtons;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bMonthView_CompressWeekendDays Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bMonthView_CompressWeekendDays Data Member

TRUE when compressing weekend days in month view, FALSE otherwise.

BOOL bMonthView_CompressWeekendDays;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bMonthView_ShowEndDate Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bMonthView_ShowEndDate Data Member

TRUE when showing event end date in month view, FALSE otherwise.

BOOL bMonthView_ShowEndDate;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bMonthView_ShowTimeAsClocks Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bMonthView_ShowTimeAsClocks Data Member

TRUE when showing event time as graphical clocks in month view, FALSE otherwise.

BOOL bMonthView_ShowTimeAsClocks;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bUseOutlookFontGlyphs Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bUseOutlookFontGlyphs Data Member

Set TRUE to use 'MS Outlook' font to display Glyps, otherwise bitmaps are used.

BOOL bUseOutlookFontGlyphs;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bWeekView_ShowEndDate Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bWeekView_ShowEndDate Data Member

TRUE when showing event end date in week view, FALSE otherwise.

BOOL bWeekView_ShowEndDate;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::bWeekView_ShowTimeAsClocks Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::bWeekView_ShowTimeAsClocks Data Member

TRUE when showing event time as graphical clocks in week view, FALSE otherwise.

BOOL bWeekView_ShowTimeAsClocks;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::dtWorkDayEndTime Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::dtWorkDayEndTime Data Member

This member contains work day end time.

COleDateTime dtWorkDayEndTime;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::dtWorkDayStartTime Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::dtWorkDayStartTime Data Member

This member contains work day start time.

COleDateTime dtWorkDayStartTime;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::dwAdditionalOptions Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::dwAdditionalOptions Data Member

Additional calendar options.

DWORD dwAdditionalOptions;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::m_pDataProvider Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::m_pDataProvider Data Member

A stored pointer to the owner data provider.

CXTPCalendarData* m_pDataProvider;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::nDayView_CurrentTimeMarkVisible Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::nDayView_CurrentTimeMarkVisible Data Member

A set of flags which define when Current Time Mark on the timescale is visible.

int nDayView_CurrentTimeMarkVisible;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::nDayView_ScaleInterval Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::nDayView_ScaleInterval Data Member

DayView scale interval in minutes.

int nDayView_ScaleInterval;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::nFirstDayOfTheWeek Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::nFirstDayOfTheWeek Data Member

This member shows the first day of the week using XTPCalendarWeekDay enum.

int nFirstDayOfTheWeek;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::nWorkWeekMask Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::nWorkWeekMask Data Member

This structure member represents week working days using XTPCalendarWeekDay enumeration.

int nWorkWeekMask;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::strDayView_Scale2Label Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::strDayView_Scale2Label Data Member

Stores secondary time scale label (day view)

CString strDayView_Scale2Label;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::strDayView_ScaleLabel Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::strDayView_ScaleLabel Data Member

Stores main time scale label (day view)

CString strDayView_ScaleLabel;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::strTooltipAddNewText Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::strTooltipAddNewText Data Member

Text for "add new appointment" tooltip.

CString strTooltipAddNewText;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions::tziDayView_Scale2TimeZone Data Member

CXTPCalendarOptions Data Members, CXTPCalendarOptions Class
CXTPCalendarOptions::tziDayView_Scale2TimeZone Data Member

Stores time zone information for the secondary time scale.

TIME_ZONE_INFORMATION tziDayView_Scale2TimeZone;
Group

CXTPCalendarOptions Data Members


CXTPCalendarOptions Methods

CXTPCalendarOptions Class, Legend, Public Methods
CXTPCalendarOptions Methods
Class

CXTPCalendarOptions Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DoPropExchange | This method reads or writes data from or to an storage.
GetCurrentTimeZoneInfo | Get full information about current time zone.
OnOptionsChanged | This member function is called when option was changed.
SetDataProvider | This member function sets the custom data provider for the control.


CXTPCalendarOptions::DoPropExchange Method

CXTPCalendarOptions Methods, CXTPCalendarOptions Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOptions::DoPropExchange Method

This method reads or writes data from or to an storage.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Remarks

For the save case the options data from will be saved to archive. For the load a new data will be loaded from the specified archive and set to members.

See Also

CXTPPropExchange

Group

CXTPCalendarOptions Methods


CXTPCalendarOptions::GetCurrentTimeZoneInfo Method

CXTPCalendarOptions Methods, CXTPCalendarOptions Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOptions::GetCurrentTimeZoneInfo Method

Get full information about current time zone.

CXTPCalendarTimeZonePtr GetCurrentTimeZoneInfo();
Returns

A smart pointer to CXTPCalendarTimeZone object.

Remarks

Retrieve additional information from the registry.

See Also

GetTimeZoneInformation(), CXTPCalendarTimeZone::GetTimeZoneInfo()

Group

CXTPCalendarOptions Methods


CXTPCalendarOptions::OnOptionsChanged Method

CXTPCalendarOptions Methods, CXTPCalendarOptions Class
CXTPCalendarOptions::OnOptionsChanged Method

This member function is called when option was changed.

void OnOptionsChanged();
Group

CXTPCalendarOptions Methods


CXTPCalendarOptions::SetDataProvider Method

CXTPCalendarOptions Methods, CXTPCalendarOptions Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarOptions::SetDataProvider Method

This member function sets the custom data provider for the control.

void SetDataProvider(
    CXTPCalendarData* pDataProvider
);
Parameters

pDataProvider
Pointer to the custom data provider object.
lpszConnectionString
String containing the name and type of the data provider.

Remarks

Call this member function to set the custom data provider that is currently used by this calendar control. Note that custom data provider must be a descendant of CXTPCalendarData.

See Also

CXTPCalendarData overview, GetDataProvider

Group

CXTPCalendarOptions Methods


CXTPCalendarOptions Constructors

CXTPCalendarOptions Class, Legend, Public Methods
CXTPCalendarOptions Constructors
Class

CXTPCalendarOptions Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarOptions | Default object constructor.


CXTPCalendarOptions::CXTPCalendarOptions Constructor

CXTPCalendarOptions Constructors, CXTPCalendarOptions Class
CXTPCalendarOptions::CXTPCalendarOptions Constructor

Default object constructor.

CXTPCalendarOptions();
Group

CXTPCalendarOptions Constructors


CXTPCalendarOptions Destructors

CXTPCalendarOptions Class, Legend, Public Methods
CXTPCalendarOptions Destructors
Class

CXTPCalendarOptions Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarOptions | Default Destructor.


CXTPCalendarOptions::~CXTPCalendarOptions Destructor

CXTPCalendarOptions Destructors, CXTPCalendarOptions Class
CXTPCalendarOptions::~CXTPCalendarOptions Destructor

Default Destructor.

virtual ~CXTPCalendarOptions();
Remarks

Handles all deallocation.

Group

CXTPCalendarOptions Destructors


CXTPCalendarPageSetupDialog Class

XTPCalendarControlView.h, Classes, Legend, Members, Topics, CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Methods, CXTPCalendarPageSetupDialog Constructors, CXTPCalendarPageSetupDialog Destructors, CXTPCalendarPageSetupDialog Constructors, CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Destructors, CXTPCalendarPageSetupDialog Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog Class

Customized Calendar control page setup dialog.

Class Hierarchy

class CXTPCalendarPageSetupDialog : public CPageSetupDialog;
File

XTPCalendarControlView.h

Remarks

Use this class when you want to allow user to customize printing options for the Calendar control.

This class enhances standard MFC page setup dialog, which encapsulates the services provided by the Windows common OLE Page Setup dialog box with additional support for setting and modifying print margins. This class is designed to take the place of the Print Setup dialog box.

See Also

CXTPCalendarControlViewPrintOptions overview, CPageSetupDialog overview

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarPageSetupDialog Constructors
CXTPCalendarPageSetupDialog Constructors | Description
CXTPCalendarPageSetupDialog | Class constructor.
CXTPCalendarPageSetupDialog Data Members
CXTPCalendarPageSetupDialog Data Members | Description
m_ctrlBlackWhitePrinting | A check box for editing CXTPCalendarControlViewPrintOptions::m_bBlackWhitePrinting value
m_ctrlDateHeaderFont | A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value
m_ctrlDateHeaderFontButton | A button for choosing CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value
m_ctrlDateHeaderFontLabel | A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont caption
m_ctrlFooterFormat | An edit for footer format string
m_ctrlFooterFormatBtn | A button to show footer specifiers menu
m_ctrlHeaderFormat | An edit for header format string
m_ctrlHeaderFormatBtn | A button to show header specifiers menu
m_ctrlPrintDateHeader | A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader value
m_ctrlPrintFromCmb | A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintFrom value
m_ctrlPrintFromTo | A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly value
m_ctrlPrintToCmb | A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintTo value
m_lfDateHeader | Date header font temporary storage
m_pOptions | Pointer to associated print options object.
CXTPCalendarPageSetupDialog Destructors
CXTPCalendarPageSetupDialog Destructors | Description
~CXTPCalendarPageSetupDialog | Default class constructor, handles members cleanup.
CXTPCalendarPageSetupDialog Methods
CXTPCalendarPageSetupDialog Methods | Description
FormatFontName | Converts font name to a human readable string.
OnBnClickedDateHeaderFont | Called when the user clicks the Date Header font button.
OnBnClickedPrintDateHeader | Called when the user clicks the Print Date Header check box.
OnInitDialog | Dialog-box initialization.
OnOK | Called when the user clicks the OK button (the button with an ID of IDOK).


CXTPCalendarPageSetupDialog Data Members

CXTPCalendarPageSetupDialog Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog Data Members
Class

CXTPCalendarPageSetupDialog Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_ctrlBlackWhitePrinting | A check box for editing CXTPCalendarControlViewPrintOptions::m_bBlackWhitePrinting value
m_ctrlDateHeaderFont | A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value
m_ctrlDateHeaderFontButton | A button for choosing CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value
m_ctrlDateHeaderFontLabel | A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont caption
m_ctrlFooterFormat | An edit for footer format string
m_ctrlFooterFormatBtn | A button to show footer specifiers menu
m_ctrlHeaderFormat | An edit for header format string
m_ctrlHeaderFormatBtn | A button to show header specifiers menu
m_ctrlPrintDateHeader | A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader value
m_ctrlPrintFromCmb | A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintFrom value
m_ctrlPrintFromTo | A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly value
m_ctrlPrintToCmb | A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintTo value
m_lfDateHeader | Date header font temporary storage
m_pOptions | Pointer to associated print options object.


CXTPCalendarPageSetupDialog::m_ctrlBlackWhitePrinting Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlBlackWhitePrinting Data Member

A check box for editing CXTPCalendarControlViewPrintOptions::m_bBlackWhitePrinting value

CButton m_ctrlBlackWhitePrinting;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFont Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFont Data Member

A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value

CEdit m_ctrlDateHeaderFont;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFontButton Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFontButton Data Member

A button for choosing CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value

CButton m_ctrlDateHeaderFontButton;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFontLabel Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFontLabel Data Member

A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont caption

CStatic m_ctrlDateHeaderFontLabel;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlFooterFormat Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlFooterFormat Data Member

An edit for footer format string

CEdit m_ctrlFooterFormat;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlFooterFormatBtn Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlFooterFormatBtn Data Member

A button to show footer specifiers menu

CButton m_ctrlFooterFormatBtn;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlHeaderFormat Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlHeaderFormat Data Member

An edit for header format string

CEdit m_ctrlHeaderFormat;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlHeaderFormatBtn Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlHeaderFormatBtn Data Member

A button to show header specifiers menu

CButton m_ctrlHeaderFormatBtn;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlPrintDateHeader Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlPrintDateHeader Data Member

A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader value

CButton m_ctrlPrintDateHeader;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlPrintFromCmb Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlPrintFromCmb Data Member

A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintFrom value

CComboBox m_ctrlPrintFromCmb;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlPrintFromTo Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlPrintFromTo Data Member

A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly value

CButton m_ctrlPrintFromTo;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_ctrlPrintToCmb Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_ctrlPrintToCmb Data Member

A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintTo value

CComboBox m_ctrlPrintToCmb;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_lfDateHeader Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_lfDateHeader Data Member

Date header font temporary storage

LOGFONT m_lfDateHeader;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog::m_pOptions Data Member

CXTPCalendarPageSetupDialog Data Members, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::m_pOptions Data Member

Pointer to associated print options object.

CXTPCalendarControlViewPrintOptions* m_pOptions;
Group

CXTPCalendarPageSetupDialog Data Members


CXTPCalendarPageSetupDialog Methods

CXTPCalendarPageSetupDialog Class, Legend, Protected Methods
CXTPCalendarPageSetupDialog Methods
Class

CXTPCalendarPageSetupDialog Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
FormatFontName | Converts font name to a human readable string.
OnBnClickedDateHeaderFont | Called when the user clicks the Date Header font button.
OnBnClickedPrintDateHeader | Called when the user clicks the Print Date Header check box.
OnInitDialog | Dialog-box initialization.
OnOK | Called when the user clicks the OK button (the button with an ID of IDOK).


CXTPCalendarPageSetupDialog::FormatFontName Method

CXTPCalendarPageSetupDialog Methods, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::FormatFontName Method

Converts font name to a human readable string.

CString FormatFontName(
    const LOGFONT& lfFont
);
Parameters

lfFont
A reference to a font.

Returns

A string describing a provided font.

Group

CXTPCalendarPageSetupDialog Methods


CXTPCalendarPageSetupDialog::OnBnClickedDateHeaderFont Method

CXTPCalendarPageSetupDialog Methods, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::OnBnClickedDateHeaderFont Method

Called when the user clicks the Date Header font button.

afx_msg void OnBnClickedDateHeaderFont();
Remarks

Shows standard Font dialog in order to customize a Date Header font.

Group

CXTPCalendarPageSetupDialog Methods


CXTPCalendarPageSetupDialog::OnBnClickedPrintDateHeader Method

CXTPCalendarPageSetupDialog Methods, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::OnBnClickedPrintDateHeader Method

Called when the user clicks the Print Date Header check box.

afx_msg void OnBnClickedPrintDateHeader();
Remarks

Enables/disables all controls related to configuring a Date Header.

Group

CXTPCalendarPageSetupDialog Methods


CXTPCalendarPageSetupDialog::OnInitDialog Method

CXTPCalendarPageSetupDialog Methods, CXTPCalendarPageSetupDialog Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::OnInitDialog Method

Dialog-box initialization.

virtual BOOL OnInitDialog();
Returns

FALSE because it has explicitly set the input focus to one of the controls in the dialog box.

See Also

CPageSetupDialog::OnInitDialog().

Group

CXTPCalendarPageSetupDialog Methods


CXTPCalendarPageSetupDialog::OnOK Method

CXTPCalendarPageSetupDialog Methods, CXTPCalendarPageSetupDialog Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::OnOK Method

Called when the user clicks the OK button (the button with an ID of IDOK).

virtual void OnOK();
Remarks

Saves all values into m_pOptions structure.

See Also

CPageSetupDialog::OnOK().

Group

CXTPCalendarPageSetupDialog Methods


CXTPCalendarPageSetupDialog Constructors

CXTPCalendarPageSetupDialog Class, Legend, Public Methods
CXTPCalendarPageSetupDialog Constructors
Class

CXTPCalendarPageSetupDialog Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarPageSetupDialog | Class constructor.


CXTPCalendarPageSetupDialog::CXTPCalendarPageSetupDialog Constructor

CXTPCalendarPageSetupDialog Constructors, CXTPCalendarPageSetupDialog Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::CXTPCalendarPageSetupDialog Constructor

Class constructor.

CXTPCalendarPageSetupDialog(
    CXTPCalendarControlViewPrintOptions* pOptions,
    DWORD dwFlags = PSD_MARGINS | PSD_INWININIINTLMEASURE,
    CWnd* pParentWnd = NULL
);
Parameters

pOptions
A pointer to an associated CXTPCalendarControlViewPrintOptions object for storing user's interaction results.
dwFlags
One or more flags you can use to customize the settings of the dialog box. The values can be combined using the bitwise-OR operator. For more details see CPageSetupDialog::CPageSetupDialog
pParentWnd
Pointer to the dialog box's parent or owner.

Remarks

Use the DoModal function to display the dialog box.

See Also

CPageSetupDialog::CPageSetupDialog()

Group

CXTPCalendarPageSetupDialog Constructors


CXTPCalendarPageSetupDialog Destructors

CXTPCalendarPageSetupDialog Class, Legend, Public Methods
CXTPCalendarPageSetupDialog Destructors
Class

CXTPCalendarPageSetupDialog Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarPageSetupDialog | Default class constructor, handles members cleanup.


CXTPCalendarPageSetupDialog::~CXTPCalendarPageSetupDialog Destructor

CXTPCalendarPageSetupDialog Destructors, CXTPCalendarPageSetupDialog Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPageSetupDialog::~CXTPCalendarPageSetupDialog Destructor

Default class constructor, handles members cleanup.

virtual ~CXTPCalendarPageSetupDialog();
Group

CXTPCalendarPageSetupDialog Destructors


CXTPCalendarPaintManager Class

XTPCalendarPaintManager.h, Classes, Legend, Members, Topics, CXTPCalendarPaintManager Classes, CXTPCalendarPaintManager Enumerations, CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Constructors, CXTPCalendarPaintManager Destructors, CXTPCalendarPaintManager Classes, CXTPCalendarPaintManager Constructors, CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Destructors, CXTPCalendarPaintManager Enumerations, CXTPCalendarPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager Class

Utility class, handles most of the drawing activities.

Class Hierarchy

class CXTPCalendarPaintManager;
File

XTPCalendarPaintManager.h

Remarks

It stores all settings, needed by control to perform drawing operations : fonts, colors, styles for all others classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with device context. Can be overridden to provide another look and feel for the control. Thus, you have an easy way to change the "skin" of your control. Just provide your own implementation of CXTPCalendarControlPaintManager and don't touch the functionality of any of the other control classes.

Create a CXTPCalendarControlPaintManager by calling its constructor. Furthermore, you can call get and set functions to change settings as needed.

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
CXTPCalendarPaintManager Classes
CXTPCalendarPaintManager Classes | Description
CControlPart | Paint manager's ControlPart is used as parent for the other parts of the control.
CDayMonthViewHeaderPart | This paint manager part is used to draw days headers for the Day View.
CDayViewAllDayEventsPart | This paint manager part is used to draw all day events area for the Day View.
CDayViewCellPart | This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
CDayViewEventPart | This paint manager part is used to draw events for the Day View.
CDayViewGroupHeaderPart | This paint manager part is used to draw Groups headers for the Day View.
CDayViewHeaderPart | This paint manager part is used to draw days headers for the Day View.
CDayViewNonworkCellPart | This paint manager part is used to draw "no all day non-work" time cells for the Day View.
CDayViewTimeScaleCellPart | This paint manager part is used to draw time scale time cells for the Day View.
CDayViewTimeScaleHeaderPart | This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
CDayViewWorkCellPart | This paint manager part is used to draw a day view that contains no all day work time cells.
CMonthViewEventPart | This paint manager part is used to draw events and day dates for the Month View.
CMonthViewGridPart | This paint manager part is used to draw days grid and to fill days cells background for the Month View.
CMonthViewHeaderPart | This paint manager part is used to draw week days headers for the Month View.
CWeekViewEventPart | This paint manager part is used to draw events for the Week View.
CWeekViewPart | This paint manager part is used to draw week days grid and headers for the Week View.
CXTPShadowDrawer | This is a helper class which handles shadows drawing (for events, etc)
CXTPCalendarPaintManager Constructors
CXTPCalendarPaintManager Constructors | Description
CXTPCalendarPaintManager | Default paint manager constructor.
CXTPCalendarPaintManager Data Members
CXTPCalendarPaintManager Data Members | Description
m_arBusyStatusBrushes | Stores customizable brush values to draw Event Busy Status in the Day View.
m_bEnableTheme | True to enable Luna theme.
m_bmpTentativePattern | Stores standard bitmap pattern to draw Tentative event busy status.
m_brushTentative | Stores standard brush to draw Tentative event busy status.
m_clr3DShadow | Stores standard color to display shadow items.
m_clrButtonFace | Stores standard Button Face color.
m_clrButtonFaceText | Stores standard color to display text.
m_clrHighlight | Stores standard color to display highlighted items.
m_clrUnderLineHdr | Color of header's underline.
m_clrWindow | Stores standard windows color.
m_clrWindowText | Stores standard color to display window text.
m_CurrSystemTheme | Current theme flag.
m_dwAskItemTextFlags | Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.
m_grclrToday | Gradient color of today's header.
m_ilExpandSigns | Stores standard Expand Signs icons.
m_ilGlyphs | Stores standard glyphs for displaying events.
m_lstViewParts | Collection to store ViewParts objects.
m_nPaintTheme | Store the Paint Theme;
m_pControl | Stores a pointer to a CXTPCalendarControl object.
m_pGlyphsFont | Stores standard glyphs font for displaying events.
m_szClockRect | Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarPaintManager Destructors
CXTPCalendarPaintManager Destructors | Description
~CXTPCalendarPaintManager | Default paint manager destructor.
CXTPCalendarPaintManager Enumerations
CXTPCalendarPaintManager Enumerations | Description
XTPEnumExpandSigns | Enumerates types of expand signs drawn on a day view.
CXTPCalendarPaintManager Methods
CXTPCalendarPaintManager Methods | Description
_GetAtGrow_BusyStatusBrushValue | Returns drawing brush value for a specific busy status.
AddViewPart | Call this member function to add the specified ViewPart object to the parts list.
DrawBitmap |
DrawBusyStatus |
DrawClock | This member function is used to draw the time as clock.
DrawHeader |
DrawHorizontalLine | This member function is used to draw a Horizontal line.
DrawIconChar | This member function is used to draw the Glyph symbol using special font.
DrawIcons | Call this member function to draw icons corresponding to the event state.
DrawLine | This member function is used to draw an arbitrary line.
DrawShadow | Call this member function to draw the shadow regions around the rectangle.
DrawVerticalLine | This member function is used to draw a Vertical line.
EnableTheme | This member function is used to enable a new theme.
GetAskItemTextFlags | This member function returns set of flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.
GetBitmapSize | This member function is used to obtain the horizontal and vertical size of the bitmap.
GetBusyStatusBrush | Call this member function to get a brush to draw event busy status.
GetClockSize | This member function is used to obtain the horizontal and vertical size of the Clock.
GetCurrentSystemTheme | Call this member function to determine the current Windows XP theme that is in use.
GetExpandSignSize | This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
GetPaintTheme | This member function is used to obtain current paint theme.
InitBusyStatusDefaultColors | Set default colors/patterns to fill Busy Status area.
IsThemeEnabled | This member function is used to obtain the status of the theme.
RefreshMetrics | This member function is used to initialize all drawing defaults.
SetAskItemTextFlags | This member function is used to set flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.
SetBusyStatusBrush | Call this member function to set custom brush to draw event busy status.
SetControl | This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
SetPaintTheme | This member function is used to set current paint theme.


CXTPCalendarPaintManager Classes

Classes, CXTPCalendarPaintManager Class
CXTPCalendarPaintManager Classes
Classes
Class | Description
CControlPart | Paint manager's ControlPart is used as parent for the other parts of the control.
CDayMonthViewHeaderPart | This paint manager part is used to draw days headers for the Day View.
CDayViewAllDayEventsPart | This paint manager part is used to draw all day events area for the Day View.
CDayViewCellPart | This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
CDayViewEventPart | This paint manager part is used to draw events for the Day View.
CDayViewGroupHeaderPart | This paint manager part is used to draw Groups headers for the Day View.
CDayViewHeaderPart | This paint manager part is used to draw days headers for the Day View.
CDayViewNonworkCellPart | This paint manager part is used to draw "no all day non-work" time cells for the Day View.
CDayViewTimeScaleCellPart | This paint manager part is used to draw time scale time cells for the Day View.
CDayViewTimeScaleHeaderPart | This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
CDayViewWorkCellPart | This paint manager part is used to draw a day view that contains no all day work time cells.
CMonthViewEventPart | This paint manager part is used to draw events and day dates for the Month View.
CMonthViewGridPart | This paint manager part is used to draw days grid and to fill days cells background for the Month View.
CMonthViewHeaderPart | This paint manager part is used to draw week days headers for the Month View.
CWeekViewEventPart | This paint manager part is used to draw events for the Week View.
CWeekViewPart | This paint manager part is used to draw week days grid and headers for the Week View.
CXTPShadowDrawer | This is a helper class which handles shadows drawing (for events, etc)
Class

CXTPCalendarPaintManager Class


CXTPCalendarPaintManager::CControlPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CControlPart Methods, CControlPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CControlPart Class

Paint manager's ControlPart is used as parent for the other parts of the control.

Class Hierarchy

class CControlPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CControlPart Methods
CControlPart Methods | Description
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CControlPart Methods

CXTPCalendarPaintManager::CControlPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CControlPart Methods
Class

CXTPCalendarPaintManager::CControlPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CControlPart::RefreshMetrics Method

CControlPart Methods, CXTPCalendarPaintManager::CControlPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CControlPart::RefreshMetrics Method

Performs refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Body Source
virtual void RefreshMetrics() {
    m_clrTextColor.SetStandardValue(m_pPaintManager->m_clrButtonFaceText);
    m_clrBackground.SetStandardValue(m_pPaintManager->m_clrButtonFace);

    LOGFONT lfIcon;
    VERIFY(::SystemParametersInfo(SPI_GETICONTITLELOGFONT, sizeof(lfIcon), &lfIcon, 0));
    m_fntText.SetStandardValue(&lfIcon);
}
Group

CControlPart Methods


CXTPCalendarPaintManager::CDayMonthViewHeaderPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayMonthViewHeaderPart Data Members, CDayMonthViewHeaderPart Methods, CDayMonthViewHeaderPart Data Members, CDayMonthViewHeaderPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayMonthViewHeaderPart Class

This paint manager part is used to draw days headers for the Day View.

Class Hierarchy

class CDayMonthViewHeaderPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Data Member
Method
virtual
CDayMonthViewHeaderPart Data Members
CDayMonthViewHeaderPart Data Members | Description
m_clrTopLeftBorder | Top and Left borders color.
CDayMonthViewHeaderPart Methods
CDayMonthViewHeaderPart Methods | Description
RefreshMetrics | This member function is used to perform refreshing of graphical related parameters from system settings.


CDayMonthViewHeaderPart Data Members

CXTPCalendarPaintManager::CDayMonthViewHeaderPart Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayMonthViewHeaderPart Data Members
Class

CXTPCalendarPaintManager::CDayMonthViewHeaderPart Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrTopLeftBorder | Top and Left borders color.


CXTPCalendarPaintManager::CDayMonthViewHeaderPart::m_clrTopLeftBorder Data Member

CDayMonthViewHeaderPart Data Members, CXTPCalendarPaintManager::CDayMonthViewHeaderPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayMonthViewHeaderPart::m_clrTopLeftBorder Data Member

Top and Left borders color.

CXTPPaintManagerColor m_clrTopLeftBorder;
Group

CDayMonthViewHeaderPart Data Members


CDayMonthViewHeaderPart Methods

CXTPCalendarPaintManager::CDayMonthViewHeaderPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayMonthViewHeaderPart Methods
Class

CXTPCalendarPaintManager::CDayMonthViewHeaderPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This member function is used to perform refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CDayMonthViewHeaderPart::RefreshMetrics Method

CDayMonthViewHeaderPart Methods, CXTPCalendarPaintManager::CDayMonthViewHeaderPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayMonthViewHeaderPart::RefreshMetrics Method

This member function is used to perform refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Body Source
virtual void RefreshMetrics() {
    m_clrTopLeftBorder.SetStandardValue(RGB(255, 255, 255));
}
Group

CDayMonthViewHeaderPart Methods


CXTPCalendarPaintManager::CDayViewAllDayEventsPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewAllDayEventsPart Methods, CDayViewAllDayEventsPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewAllDayEventsPart Class

This paint manager part is used to draw all day events area for the Day View.

Class Hierarchy

class CDayViewAllDayEventsPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CDayViewAllDayEventsPart Methods
CDayViewAllDayEventsPart Methods | Description
OnDraw | This member function is used to draw the all-day events area.
RefreshMetrics | This member functions is used to perform refreshing of graphical related parameters from system settings.


CDayViewAllDayEventsPart Methods

CXTPCalendarPaintManager::CDayViewAllDayEventsPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewAllDayEventsPart Methods
Class

CXTPCalendarPaintManager::CDayViewAllDayEventsPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
OnDraw | This member function is used to draw the all-day events area.
RefreshMetrics | This member functions is used to perform refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CDayViewAllDayEventsPart::OnDraw Method

CDayViewAllDayEventsPart Methods, CXTPCalendarPaintManager::CDayViewAllDayEventsPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewAllDayEventsPart::OnDraw Method

This member function is used to draw the all-day events area.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarDayViewGroup* pViewGroup,
    CRect rc,
    BOOL bSelected
);
Parameters

pDC
Pointer to a valid device context.
pViewGroup
A CXTPCalendarDayViewGroup pointer to the Group object.
rc
A CRect object that contains the all-day events area bounding rectangle coordinates.
bSelected
A BOOL. TRUE if the draw area is selected. FALSE otherwise.

Group

CDayViewAllDayEventsPart Methods


CXTPCalendarPaintManager::CDayViewAllDayEventsPart::RefreshMetrics Method

CDayViewAllDayEventsPart Methods, CXTPCalendarPaintManager::CDayViewAllDayEventsPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewAllDayEventsPart::RefreshMetrics Method

This member functions is used to perform refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Body Source
virtual void RefreshMetrics() {
    m_clrBackground.SetStandardValue(m_pPaintManager->m_clr3DShadow);
}
Group

CDayViewAllDayEventsPart Methods


CXTPCalendarPaintManager::CDayViewCellPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewCellPart Data Members, CDayViewCellPart Methods, CDayViewCellPart Data Members, CDayViewCellPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewCellPart Class

This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.

Class Hierarchy

class CDayViewCellPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Data Member
Method
virtual
CDayViewCellPart Data Members
CDayViewCellPart Data Members | Description
m_clrHour | Cell border color.
m_clrShadow | Cell background color.
CDayViewCellPart Methods
CDayViewCellPart Methods | Description
GetParams | This member function is used to fill out cell parameters with default values.
OnDraw | This member function is used to draw the day view with no all-day-cells.


CDayViewCellPart Data Members

CXTPCalendarPaintManager::CDayViewCellPart Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewCellPart Data Members
Class

CXTPCalendarPaintManager::CDayViewCellPart Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrHour | Cell border color.
m_clrShadow | Cell background color.


CXTPCalendarPaintManager::CDayViewCellPart::m_clrHour Data Member

CDayViewCellPart Data Members, CXTPCalendarPaintManager::CDayViewCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewCellPart::m_clrHour Data Member

Cell border color.

CXTPPaintManagerColor m_clrHour;
Group

CDayViewCellPart Data Members


CXTPCalendarPaintManager::CDayViewCellPart::m_clrShadow Data Member

CDayViewCellPart Data Members, CXTPCalendarPaintManager::CDayViewCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewCellPart::m_clrShadow Data Member

Cell background color.

CXTPPaintManagerColor m_clrShadow;
Group

CDayViewCellPart Data Members


CDayViewCellPart Methods

CXTPCalendarPaintManager::CDayViewCellPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewCellPart Methods
Class

CXTPCalendarPaintManager::CDayViewCellPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetParams | This member function is used to fill out cell parameters with default values.
OnDraw | This member function is used to draw the day view with no all-day-cells.


CXTPCalendarPaintManager::CDayViewCellPart::GetParams Method

CDayViewCellPart Methods, CXTPCalendarPaintManager::CDayViewCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewCellPart::GetParams Method

This member function is used to fill out cell parameters with default values.

virtual void GetParams(
    CXTPCalendarDayViewGroup* pViewGroup,
    XTP_CALENDAR_DAYVIEWCELL_PARAMS& rCellParams
);
Parameters

pViewGroup
[in] A CXTPCalendarDayViewGroup pointer to the Day View Group object.
rCellParams
[in, out] A XTP_CALENDAR_DAYVIEWCELL_PARAMS object that contains the cell's parameters.

Group

CDayViewCellPart Methods


CXTPCalendarPaintManager::CDayViewCellPart::OnDraw Method

CDayViewCellPart Methods, CXTPCalendarPaintManager::CDayViewCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewCellPart::OnDraw Method

This member function is used to draw the day view with no all-day-cells.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarDayViewGroup* pViewGroup,
    CRect rc,
    const XTP_CALENDAR_DAYVIEWCELL_PARAMS& cellParams
);
Parameters

pDC
Pointer to a valid device context.
pViewGroup
A CXTPCalendarDayViewGroup pointer to the Day View Group object.
rc
A CRect object that contains the cell's bounding rectangle.
cellParams
A XTP_CALENDAR_DAYVIEWCELL_PARAMS object that contains the cell's parameters.

Group

CDayViewCellPart Methods


CXTPCalendarPaintManager::CDayViewEventPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewEventPart Methods, CDayViewEventPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewEventPart Class

This paint manager part is used to draw events for the Day View.

Class Hierarchy

class CDayViewEventPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CDayViewEventPart Methods
CDayViewEventPart Methods | Description
OnDraw | This member function is used to draw an event.
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CDayViewEventPart Methods

CXTPCalendarPaintManager::CDayViewEventPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewEventPart Methods
Class

CXTPCalendarPaintManager::CDayViewEventPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
OnDraw | This member function is used to draw an event.
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CDayViewEventPart::OnDraw Method

CDayViewEventPart Methods, CXTPCalendarPaintManager::CDayViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewEventPart::OnDraw Method

This member function is used to draw an event.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarDayViewEvent* pViewEvent
);
Parameters

pDC
Pointer to a valid device context.
pViewEvent
A CXTPCalendarDayViewEvent pointer to the Day Event View object.

Group

CDayViewEventPart Methods


CXTPCalendarPaintManager::CDayViewEventPart::RefreshMetrics Method

CDayViewEventPart Methods, CXTPCalendarPaintManager::CDayViewEventPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewEventPart::RefreshMetrics Method

Performs refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Body Source
virtual void RefreshMetrics() {
    m_clrBackground.SetStandardValue(RGB(255, 255, 255));
}
Group

CDayViewEventPart Methods


CXTPCalendarPaintManager::CDayViewGroupHeaderPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewGroupHeaderPart Methods, CDayViewGroupHeaderPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewGroupHeaderPart Class

This paint manager part is used to draw Groups headers for the Day View.

Class Hierarchy

class CDayViewGroupHeaderPart : public CDayMonthViewHeaderPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CDayViewGroupHeaderPart Methods
CDayViewGroupHeaderPart Methods | Description
OnDraw | This member function is used to draw the day header.


CDayViewGroupHeaderPart Methods

CXTPCalendarPaintManager::CDayViewGroupHeaderPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewGroupHeaderPart Methods
Class

CXTPCalendarPaintManager::CDayViewGroupHeaderPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
OnDraw | This member function is used to draw the day header.


CXTPCalendarPaintManager::CDayViewGroupHeaderPart::OnDraw Method

CDayViewGroupHeaderPart Methods, CXTPCalendarPaintManager::CDayViewGroupHeaderPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewGroupHeaderPart::OnDraw Method

This member function is used to draw the day header.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarDayViewGroup* pViewGroup,
    CRect rc,
    CString strText
);
Parameters

pDC
Pointer to a valid device context.
pViewGroup
A CXTPCalendarDayViewGroup pointer to the Group object.
rc
A CRect object that contains the coordinates of the Header's bounding rectangle.
strText
A CString object that contains the Header text.

Group

CDayViewGroupHeaderPart Methods


CXTPCalendarPaintManager::CDayViewHeaderPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewHeaderPart Methods, CDayViewHeaderPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewHeaderPart Class

This paint manager part is used to draw days headers for the Day View.

Class Hierarchy

class CDayViewHeaderPart : public CDayMonthViewHeaderPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CDayViewHeaderPart Methods
CDayViewHeaderPart Methods | Description
OnDraw | This member function is used to draw the day header.


CDayViewHeaderPart Methods

CXTPCalendarPaintManager::CDayViewHeaderPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewHeaderPart Methods
Class

CXTPCalendarPaintManager::CDayViewHeaderPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
OnDraw | This member function is used to draw the day header.


CXTPCalendarPaintManager::CDayViewHeaderPart::OnDraw Method

CDayViewHeaderPart Methods, CXTPCalendarPaintManager::CDayViewHeaderPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewHeaderPart::OnDraw Method

This member function is used to draw the day header.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarDayViewDay* pViewDay,
    CRect rc,
    CString strText
);
Parameters

pDC
Pointer to a valid device context.
pViewDay
A CXTPCalendarDayViewDay pointer to the Day View object.
rc
A CRect object that contains the coordinates of the Header's bounding rectangle.
strText
A CString object that contains the Header text.

Group

CDayViewHeaderPart Methods


CXTPCalendarPaintManager::CDayViewNonworkCellPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewNonworkCellPart Methods, CDayViewNonworkCellPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewNonworkCellPart Class

This paint manager part is used to draw "no all day non-work" time cells for the Day View.

Class Hierarchy

class CDayViewNonworkCellPart : public CDayViewCellPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CDayViewNonworkCellPart Methods
CDayViewNonworkCellPart Methods | Description
RefreshMetrics | This member function is used to perform refreshing of graphical related parameters from system settings.


CDayViewNonworkCellPart Methods

CXTPCalendarPaintManager::CDayViewNonworkCellPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewNonworkCellPart Methods
Class

CXTPCalendarPaintManager::CDayViewNonworkCellPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This member function is used to perform refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CDayViewNonworkCellPart::RefreshMetrics Method

CDayViewNonworkCellPart Methods, CXTPCalendarPaintManager::CDayViewNonworkCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewNonworkCellPart::RefreshMetrics Method

This member function is used to perform refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Group

CDayViewNonworkCellPart Methods


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewTimeScaleCellPart Data Members, CDayViewTimeScaleCellPart Methods, CDayViewTimeScaleCellPart Data Members, CDayViewTimeScaleCellPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class

This paint manager part is used to draw time scale time cells for the Day View.

Class Hierarchy

class CDayViewTimeScaleCellPart : public CDayViewTimeScaleHeaderPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Data Member
Method
virtual
CDayViewTimeScaleCellPart Data Members
CDayViewTimeScaleCellPart Data Members | Description
m_fntTimeText | Time text font.
m_nHourWidth | Width of hour part of the text in pixels.
m_nMinWidth | Width of minutes (am/pm) part of the text in pixels.
CDayViewTimeScaleCellPart Methods
CDayViewTimeScaleCellPart Methods | Description
AdjustTimeFont | This member function is used to adjust the time text font size.
CalcWidth | This member function is used to adjust the time text font size.
DrawBigHourCell | This member function is used to draw the big hour cell.
DrawHourCell | This member function is used to draw the hour cell.
RefreshMetrics | This member function is used to refresh the graphical related parameters using system settings.


CDayViewTimeScaleCellPart Data Members

CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewTimeScaleCellPart Data Members
Class

CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_fntTimeText | Time text font.
m_nHourWidth | Width of hour part of the text in pixels.
m_nMinWidth | Width of minutes (am/pm) part of the text in pixels.


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::m_fntTimeText Data Member

CDayViewTimeScaleCellPart Data Members, CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::m_fntTimeText Data Member

Time text font.

CXTPCalendarViewPartFontValue m_fntTimeText;
Group

CDayViewTimeScaleCellPart Data Members


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::m_nHourWidth Data Member

CDayViewTimeScaleCellPart Data Members, CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::m_nHourWidth Data Member

Width of hour part of the text in pixels.

int m_nHourWidth;
Group

CDayViewTimeScaleCellPart Data Members


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::m_nMinWidth Data Member

CDayViewTimeScaleCellPart Data Members, CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::m_nMinWidth Data Member

Width of minutes (am/pm) part of the text in pixels.

int m_nMinWidth;
Group

CDayViewTimeScaleCellPart Data Members


CDayViewTimeScaleCellPart Methods

CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewTimeScaleCellPart Methods
Class

CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AdjustTimeFont | This member function is used to adjust the time text font size.
CalcWidth | This member function is used to adjust the time text font size.
DrawBigHourCell | This member function is used to draw the big hour cell.
DrawHourCell | This member function is used to draw the hour cell.
RefreshMetrics | This member function is used to refresh the graphical related parameters using system settings.


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::AdjustTimeFont Method

CDayViewTimeScaleCellPart Methods, CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::AdjustTimeFont Method

This member function is used to adjust the time text font size.

void AdjustTimeFont(
    CDC* pDC,
    CRect rcCell
);
Parameters

pDC
Pointer to a valid device context.
rcCell
A CRect object that contains the time scale hour cell bounding rectangle.

Group

CDayViewTimeScaleCellPart Methods


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::CalcWidth Method

CDayViewTimeScaleCellPart Methods, CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::CalcWidth Method

This member function is used to adjust the time text font size.

void CalcWidth(
    CDC* pDC,
    const CString& strHour,
    const CString& strMin,
    int nHourHeight,
    int& nWidth
);
Parameters

pDC
Pointer to a valid device context.
strHour
A CString object that contains the Hour text.
strMin
A CString object that contains the Minutes text.
nHourHeight
A hour big text height.
nWidth
An int that returns the width of time scale with provided hour and minutes texts.

Group

CDayViewTimeScaleCellPart Methods


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::DrawBigHourCell Method

CDayViewTimeScaleCellPart Methods, CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::DrawBigHourCell Method

This member function is used to draw the big hour cell.

virtual void DrawBigHourCell(
    CDC* pDC,
    CRect rc,
    CString strHour,
    CString strMin,
    int nRowPerHour,
    BOOL bFillBackground = TRUE
);
Parameters

pDC
Pointer to a valid device context.
rc
A CRect object that contains the time scale hour cell bounding rectangle.
strHour
A CString object that contains the Hour text.
strMin
A CString object that contains the Minutes text.
nRowPerHour
An int that contains the Rows per hour.
bFillBackground
A BOOL. If TRUE, then fill the background before drawing. If FALSE, then do not fill the background before drawing.

Group

CDayViewTimeScaleCellPart Methods


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::DrawHourCell Method

CDayViewTimeScaleCellPart Methods, CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::DrawHourCell Method

This member function is used to draw the hour cell.

virtual void DrawHourCell(
    CDC* pDC,
    CRect rc,
    CString strText,
    BOOL bFillBackground = TRUE
);
Parameters

pDC
Pointer to a valid device context.
rc
A CRect object that contains the time scale hour cell bounding rectangle.
strText
A CString object that contains the time text.
bFillBackground
A BOOL. If TRUE, then fill the background before drawing. If FALSE, then do not fill the background before drawing.

Group

CDayViewTimeScaleCellPart Methods


CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::RefreshMetrics Method

CDayViewTimeScaleCellPart Methods, CXTPCalendarPaintManager::CDayViewTimeScaleCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleCellPart::RefreshMetrics Method

This member function is used to refresh the graphical related parameters using system settings.

virtual void RefreshMetrics();
Group

CDayViewTimeScaleCellPart Methods


CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewTimeScaleHeaderPart Methods, CDayViewTimeScaleHeaderPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart Class

This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.

Class Hierarchy

class CDayViewTimeScaleHeaderPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CDayViewTimeScaleHeaderPart Methods
CDayViewTimeScaleHeaderPart Methods | Description
DrawExpandSigns | This member function is used to draw expand signs.
DrawNowLine | This member function is used to draw the 'Now' line.
OnDraw | This member function is used to draw the time scale header.


CDayViewTimeScaleHeaderPart Methods

CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewTimeScaleHeaderPart Methods
Class

CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawExpandSigns | This member function is used to draw expand signs.
DrawNowLine | This member function is used to draw the 'Now' line.
OnDraw | This member function is used to draw the time scale header.


CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart::DrawExpandSigns Method

CDayViewTimeScaleHeaderPart Methods, CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart::DrawExpandSigns Method

This member function is used to draw expand signs.

virtual void DrawExpandSigns(
    CDC* pDC,
    CXTPCalendarDayView* pView,
    const CRect& rcTSHours
);
Parameters

pDC
Pointer to a valid device context.
pView
A CXTPCalendarDayView pointer to the Day View object.
rcTSHours
A CRect that contains the Time scale hours rectangle.

Group

CDayViewTimeScaleHeaderPart Methods


CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart::DrawNowLine Method

CDayViewTimeScaleHeaderPart Methods, CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart::DrawNowLine Method

This member function is used to draw the 'Now' line.

virtual void DrawNowLine(
    CDC* pDC,
    CXTPCalendarDayView* pView,
    CRect rc,
    int y,
    BOOL bDrawBk = FALSE
);
Parameters

pDC
Pointer to a valid device context.
pView
A CXTPCalendarDayView pointer to the Day View object.
rc
A CRect that contains the Time scale bounding rectangle.
y
An int that contains the 'Now' line position.
bDrawBk
If FALSE, then draw only the line. If TRUE, then draw the line and the gradient fill.

Group

CDayViewTimeScaleHeaderPart Methods


CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart::OnDraw Method

CDayViewTimeScaleHeaderPart Methods, CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewTimeScaleHeaderPart::OnDraw Method

This member function is used to draw the time scale header.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarDayView* pView,
    CRect rc,
    CString strText
);
Parameters

pDC
Pointer to a valid device context.
pView
A CXTPCalendarDayView pointer that contains the Day View object.
rc
The time scale header's bounding rectangle.
strText
A CString object that contains the header text.

Group

CDayViewTimeScaleHeaderPart Methods


CXTPCalendarPaintManager::CDayViewWorkCellPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CDayViewWorkCellPart Methods, CDayViewWorkCellPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewWorkCellPart Class

This paint manager part is used to draw a day view that contains no all day work time cells.

Class Hierarchy

class CDayViewWorkCellPart : public CDayViewCellPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CDayViewWorkCellPart Methods
CDayViewWorkCellPart Methods | Description
RefreshMetrics | This member function is used to perform the refreshing of graphical related parameters from system settings.


CDayViewWorkCellPart Methods

CXTPCalendarPaintManager::CDayViewWorkCellPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CDayViewWorkCellPart Methods
Class

CXTPCalendarPaintManager::CDayViewWorkCellPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This member function is used to perform the refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CDayViewWorkCellPart::RefreshMetrics Method

CDayViewWorkCellPart Methods, CXTPCalendarPaintManager::CDayViewWorkCellPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CDayViewWorkCellPart::RefreshMetrics Method

This member function is used to perform the refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Group

CDayViewWorkCellPart Methods


CXTPCalendarPaintManager::CMonthViewEventPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CMonthViewEventPart Data Members, CMonthViewEventPart Methods, CMonthViewEventPart Data Members, CMonthViewEventPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewEventPart Class

This paint manager part is used to draw events and day dates for the Month View.

Class Hierarchy

class CMonthViewEventPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Data Member
Method
virtual
CMonthViewEventPart Data Members
CMonthViewEventPart Data Members | Description
m_clrClassicUnderline | Underline color for today day.
m_clrMultiDayEventFrameColor | Multi-day event frame color.
m_clrTextHighLightColor | Text color for the selected event.
m_grclrClassicSelDay | Gradient color for today day.
CMonthViewEventPart Methods
CMonthViewEventPart Methods | Description
OnDrawDayDate | This member function is used to draw the week day header.
OnDrawEvent | This member function is used to draw an event.
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CMonthViewEventPart Data Members

CXTPCalendarPaintManager::CMonthViewEventPart Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewEventPart Data Members
Class

CXTPCalendarPaintManager::CMonthViewEventPart Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrClassicUnderline | Underline color for today day.
m_clrMultiDayEventFrameColor | Multi-day event frame color.
m_clrTextHighLightColor | Text color for the selected event.
m_grclrClassicSelDay | Gradient color for today day.


CXTPCalendarPaintManager::CMonthViewEventPart::m_clrClassicUnderline Data Member

CMonthViewEventPart Data Members, CXTPCalendarPaintManager::CMonthViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewEventPart::m_clrClassicUnderline Data Member

Underline color for today day.

COLORREF m_clrClassicUnderline;
Group

CMonthViewEventPart Data Members


CXTPCalendarPaintManager::CMonthViewEventPart::m_clrMultiDayEventFrameColor Data Member

CMonthViewEventPart Data Members, CXTPCalendarPaintManager::CMonthViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewEventPart::m_clrMultiDayEventFrameColor Data Member

Multi-day event frame color.

COLORREF m_clrMultiDayEventFrameColor;
Group

CMonthViewEventPart Data Members


CXTPCalendarPaintManager::CMonthViewEventPart::m_clrTextHighLightColor Data Member

CMonthViewEventPart Data Members, CXTPCalendarPaintManager::CMonthViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewEventPart::m_clrTextHighLightColor Data Member

Text color for the selected event.

COLORREF m_clrTextHighLightColor;
Group

CMonthViewEventPart Data Members


CXTPCalendarPaintManager::CMonthViewEventPart::m_grclrClassicSelDay Data Member

CMonthViewEventPart Data Members, CXTPCalendarPaintManager::CMonthViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewEventPart::m_grclrClassicSelDay Data Member

Gradient color for today day.

CXTPPaintManagerColorGradient m_grclrClassicSelDay;
Group

CMonthViewEventPart Data Members


CMonthViewEventPart Methods

CXTPCalendarPaintManager::CMonthViewEventPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewEventPart Methods
Class

CXTPCalendarPaintManager::CMonthViewEventPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
OnDrawDayDate | This member function is used to draw the week day header.
OnDrawEvent | This member function is used to draw an event.
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CMonthViewEventPart::OnDrawDayDate Method

CMonthViewEventPart Methods, CXTPCalendarPaintManager::CMonthViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewEventPart::OnDrawDayDate Method

This member function is used to draw the week day header.

virtual void OnDrawDayDate(
    CDC* pDC,
    CRect rc,
    BOOL bToday,
    BOOL bSelected,
    CString strText
);
Parameters

pDC
Pointer to a valid device context.
rc
A CRect object that contains the Day header's bounding rectangle coordinates.
bToday
TRUE for today day, otherwise FALSE.
bSelected
Is day selected.
strText
Formatted day date string.

Group

CMonthViewEventPart Methods


CXTPCalendarPaintManager::CMonthViewEventPart::OnDrawEvent Method

CMonthViewEventPart Methods, CXTPCalendarPaintManager::CMonthViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewEventPart::OnDrawEvent Method

This member function is used to draw an event.

virtual void OnDrawEvent(
    CDC* pDC,
    CXTPCalendarMonthViewEvent* pViewEvent
);
Parameters

pDC
Pointer to a valid device context.
pViewEvent
A CXTPCalendarMonthViewEvent pointer to the Month Event View object.

Group

CMonthViewEventPart Methods


CXTPCalendarPaintManager::CMonthViewEventPart::RefreshMetrics Method

CMonthViewEventPart Methods, CXTPCalendarPaintManager::CMonthViewEventPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewEventPart::RefreshMetrics Method

Performs refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Body Source
virtual void RefreshMetrics() {
    m_clrTextHighLightColor = RGB(255, 255, 255);
    m_clrMultiDayEventFrameColor = RGB(0, 0, 0);
    m_clrBackground.SetStandardValue(RGB(255, 255, 213));
    m_grclrClassicSelDay.SetStandardValue(m_clrBackground, RGB(217, 214, 202));
    m_clrClassicUnderline = RGB(10, 36, 106);
}
Group

CMonthViewEventPart Methods


CXTPCalendarPaintManager::CMonthViewGridPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CMonthViewGridPart Data Members, CMonthViewGridPart Methods, CMonthViewGridPart Data Members, CMonthViewGridPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewGridPart Class

This paint manager part is used to draw days grid and to fill days cells background for the Month View.

Class Hierarchy

class CMonthViewGridPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Data Member
Method
virtual
CMonthViewGridPart Data Members
CMonthViewGridPart Data Members | Description
m_clrBackground2 | Second background color which is used to fill days background.
CMonthViewGridPart Methods
CMonthViewGridPart Methods | Description
OnDrawGrid | This member function is used to draw the days grid and to fill the days cells background.
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CMonthViewGridPart Data Members

CXTPCalendarPaintManager::CMonthViewGridPart Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewGridPart Data Members
Class

CXTPCalendarPaintManager::CMonthViewGridPart Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrBackground2 | Second background color which is used to fill days background.


CXTPCalendarPaintManager::CMonthViewGridPart::m_clrBackground2 Data Member

CMonthViewGridPart Data Members, CXTPCalendarPaintManager::CMonthViewGridPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewGridPart::m_clrBackground2 Data Member

Second background color which is used to fill days background.

CXTPPaintManagerColor m_clrBackground2;
Group

CMonthViewGridPart Data Members


CMonthViewGridPart Methods

CXTPCalendarPaintManager::CMonthViewGridPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewGridPart Methods
Class

CXTPCalendarPaintManager::CMonthViewGridPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
OnDrawGrid | This member function is used to draw the days grid and to fill the days cells background.
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CMonthViewGridPart::OnDrawGrid Method

CMonthViewGridPart Methods, CXTPCalendarPaintManager::CMonthViewGridPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewGridPart::OnDrawGrid Method

This member function is used to draw the days grid and to fill the days cells background.

virtual void OnDrawGrid(
    CDC* pDC,
    CXTPCalendarMonthView* pMonthView
);
Parameters

pDC
Pointer to a valid device context.
pMonthView
A CXTPCalendarMonthView pointer to the Month View object.

Group

CMonthViewGridPart Methods


CXTPCalendarPaintManager::CMonthViewGridPart::RefreshMetrics Method

CMonthViewGridPart Methods, CXTPCalendarPaintManager::CMonthViewGridPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewGridPart::RefreshMetrics Method

Performs refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Group

CMonthViewGridPart Methods


CXTPCalendarPaintManager::CMonthViewHeaderPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CMonthViewHeaderPart Methods, CMonthViewHeaderPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewHeaderPart Class

This paint manager part is used to draw week days headers for the Month View.

Class Hierarchy

class CMonthViewHeaderPart : public CDayMonthViewHeaderPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Method
virtual
CMonthViewHeaderPart Methods
CMonthViewHeaderPart Methods | Description
OnDraw | This member function is used to draw the week day header.


CMonthViewHeaderPart Methods

CXTPCalendarPaintManager::CMonthViewHeaderPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CMonthViewHeaderPart Methods
Class

CXTPCalendarPaintManager::CMonthViewHeaderPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
OnDraw | This member function is used to draw the week day header.


CXTPCalendarPaintManager::CMonthViewHeaderPart::OnDraw Method

CMonthViewHeaderPart Methods, CXTPCalendarPaintManager::CMonthViewHeaderPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CMonthViewHeaderPart::OnDraw Method

This member function is used to draw the week day header.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarMonthView* pMonthView,
    CRect rc,
    int nCollIndex,
    CString strText
);
Parameters

pDC
Pointer to a valid device context.
pMonthView
A CXTPCalendarMonthView pointer to the Month View object.
rc
A CRect object that contains the Week Day header's bounding rectangle coordinates.
nCollIndex
An int that contains the Week Day column index in the grid.
strText
A CString object that contains the formatted Week Day name.

Group

CMonthViewHeaderPart Methods


CXTPCalendarPaintManager::CWeekViewEventPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CWeekViewEventPart Data Members, CWeekViewEventPart Methods, CWeekViewEventPart Data Members, CWeekViewEventPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewEventPart Class

This paint manager part is used to draw events for the Week View.

Class Hierarchy

class CWeekViewEventPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Data Member
Method
virtual
CWeekViewEventPart Data Members
CWeekViewEventPart Data Members | Description
m_clrTextHighLightColor | Text color for the selected event.
m_clrTextNormalColor | Text color for the event.
CWeekViewEventPart Methods
CWeekViewEventPart Methods | Description
DrawBorder | This member functions is used to draw the event border.
DrawSubj | This member function is used to draw the event subject.
DrawTimes | This member function is used to draw the event's times texts or icons.
OnDraw | This member function is used to draw the specified event.
RefreshMetrics | This member function is used to perform refreshing of graphical related parameters from system settings.


CWeekViewEventPart Data Members

CXTPCalendarPaintManager::CWeekViewEventPart Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CWeekViewEventPart Data Members
Class

CXTPCalendarPaintManager::CWeekViewEventPart Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrTextHighLightColor | Text color for the selected event.
m_clrTextNormalColor | Text color for the event.


CXTPCalendarPaintManager::CWeekViewEventPart::m_clrTextHighLightColor Data Member

CWeekViewEventPart Data Members, CXTPCalendarPaintManager::CWeekViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewEventPart::m_clrTextHighLightColor Data Member

Text color for the selected event.

COLORREF m_clrTextHighLightColor;
Group

CWeekViewEventPart Data Members


CXTPCalendarPaintManager::CWeekViewEventPart::m_clrTextNormalColor Data Member

CWeekViewEventPart Data Members, CXTPCalendarPaintManager::CWeekViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewEventPart::m_clrTextNormalColor Data Member

Text color for the event.

COLORREF m_clrTextNormalColor;
Group

CWeekViewEventPart Data Members


CWeekViewEventPart Methods

CXTPCalendarPaintManager::CWeekViewEventPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CWeekViewEventPart Methods
Class

CXTPCalendarPaintManager::CWeekViewEventPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawBorder | This member functions is used to draw the event border.
DrawSubj | This member function is used to draw the event subject.
DrawTimes | This member function is used to draw the event's times texts or icons.
OnDraw | This member function is used to draw the specified event.
RefreshMetrics | This member function is used to perform refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CWeekViewEventPart::DrawBorder Method

CWeekViewEventPart Methods, CXTPCalendarPaintManager::CWeekViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewEventPart::DrawBorder Method

This member functions is used to draw the event border.

virtual void DrawBorder(
    CDC* pDC,
    CRect rcView,
    CXTPCalendarWeekViewEvent* pWeekViewEvent
);
Parameters

pDC
Pointer to a valid device context.
rcView
A CRect that contains the day view's bounding rectangle coordinates.
pWeekViewEvent
A CXTPCalendarWeekViewEvent pointer to the Week Event View object.

Group

CWeekViewEventPart Methods


CXTPCalendarPaintManager::CWeekViewEventPart::DrawSubj Method

CWeekViewEventPart Methods, CXTPCalendarPaintManager::CWeekViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewEventPart::DrawSubj Method

This member function is used to draw the event subject.

virtual void DrawSubj(
    CDC* pDC,
    CXTPCalendarWeekViewEvent* pWeekViewEvent
);
Parameters

pDC
Pointer to a valid device context.
pWeekViewEvent
A CXTPCalendarWeekViewEvent pointer to the Week Event View object.

Group

CWeekViewEventPart Methods


CXTPCalendarPaintManager::CWeekViewEventPart::DrawTimes Method

CWeekViewEventPart Methods, CXTPCalendarPaintManager::CWeekViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewEventPart::DrawTimes Method

This member function is used to draw the event's times texts or icons.

virtual int DrawTimes(
    CDC* pDC,
    CXTPCalendarWeekViewEvent* pWeekViewEvent
);
Parameters

pDC
Pointer to a valid device context.
pWeekViewEvent
A CXTPCalendarWeekViewEvent pointer to the Week Event View object.

Group

CWeekViewEventPart Methods


CXTPCalendarPaintManager::CWeekViewEventPart::OnDraw Method

CWeekViewEventPart Methods, CXTPCalendarPaintManager::CWeekViewEventPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewEventPart::OnDraw Method

This member function is used to draw the specified event.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarWeekViewEvent* pWeekViewEvent
);
Parameters

pDC
Pointer to a valid device context.
pWeekViewEvent
A CXTPCalendarWeekViewEvent pointer to the Week Event View object.

Group

CWeekViewEventPart Methods


CXTPCalendarPaintManager::CWeekViewEventPart::RefreshMetrics Method

CWeekViewEventPart Methods, CXTPCalendarPaintManager::CWeekViewEventPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewEventPart::RefreshMetrics Method

This member function is used to perform refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Body Source
virtual void RefreshMetrics() {
    m_clrBackground.SetStandardValue(m_pPaintManager->GetWeekViewPart()->GetBackgroundColor()); // RGB(255, 255, 213));
    m_clrTextColor.SetStandardValue(m_pPaintManager->m_clrButtonFaceText);
    m_clrTextHighLightColor = RGB(255, 255, 255);
    m_clrTextNormalColor = m_pPaintManager->m_clrButtonFaceText;
    LOGFONT lfIcon;
    VERIFY(::SystemParametersInfo(SPI_GETICONTITLELOGFONT, sizeof(lfIcon), &lfIcon, 0));
    m_fntText.SetStandardValue(&lfIcon);
}
Group

CWeekViewEventPart Methods


CXTPCalendarPaintManager::CWeekViewPart Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CWeekViewPart Data Members, CWeekViewPart Methods, CWeekViewPart Data Members, CWeekViewPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewPart Class

This paint manager part is used to draw week days grid and headers for the Week View.

Class Hierarchy

class CWeekViewPart : public CXTPCalendarViewPart;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Data Member
Method
virtual
CWeekViewPart Data Members
CWeekViewPart Data Members | Description
m_clrHeaderBottomLine | Text color for the day header bottom line.
m_clrTextHighLightColor | Text color for the selected day header.
m_clrTextNormalColor | Text color for the day header and some other elements.
CWeekViewPart Methods
CWeekViewPart Methods | Description
DrawDayHeader | This member function is used to draw the day header.
OnDraw | This member function is used to draw an event.
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CWeekViewPart Data Members

CXTPCalendarPaintManager::CWeekViewPart Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CWeekViewPart Data Members
Class

CXTPCalendarPaintManager::CWeekViewPart Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_clrHeaderBottomLine | Text color for the day header bottom line.
m_clrTextHighLightColor | Text color for the selected day header.
m_clrTextNormalColor | Text color for the day header and some other elements.


CXTPCalendarPaintManager::CWeekViewPart::m_clrHeaderBottomLine Data Member

CWeekViewPart Data Members, CXTPCalendarPaintManager::CWeekViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewPart::m_clrHeaderBottomLine Data Member

Text color for the day header bottom line.

COLORREF m_clrHeaderBottomLine;
Group

CWeekViewPart Data Members


CXTPCalendarPaintManager::CWeekViewPart::m_clrTextHighLightColor Data Member

CWeekViewPart Data Members, CXTPCalendarPaintManager::CWeekViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewPart::m_clrTextHighLightColor Data Member

Text color for the selected day header.

COLORREF m_clrTextHighLightColor;
Group

CWeekViewPart Data Members


CXTPCalendarPaintManager::CWeekViewPart::m_clrTextNormalColor Data Member

CWeekViewPart Data Members, CXTPCalendarPaintManager::CWeekViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewPart::m_clrTextNormalColor Data Member

Text color for the day header and some other elements.

COLORREF m_clrTextNormalColor;
Group

CWeekViewPart Data Members


CWeekViewPart Methods

CXTPCalendarPaintManager::CWeekViewPart Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CWeekViewPart Methods
Class

CXTPCalendarPaintManager::CWeekViewPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawDayHeader | This member function is used to draw the day header.
OnDraw | This member function is used to draw an event.
RefreshMetrics | Performs refreshing of graphical related parameters from system settings.


CXTPCalendarPaintManager::CWeekViewPart::DrawDayHeader Method

CWeekViewPart Methods, CXTPCalendarPaintManager::CWeekViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewPart::DrawDayHeader Method

This member function is used to draw the day header.

virtual void DrawDayHeader(
    CDC* pDC,
    CRect rcDay,
    int nHeaderHeight,
    CString strHeader,
    BOOL bIsCurrent = FALSE,
    BOOL bIsSelected = FALSE
);
Parameters

pDC
Pointer to a valid device context.
rcDay
A CRect object that contains the day's bounding rectangle coordinates.
nHeaderHeight
An int that contains the header height value.
strHeader
A CString object that contains the header text.
bIsCurrent
A BOOL. TRUE if this is the current day for today. FALSE otherwise.
bIsSelected
A BOOL. TRUE if the day is selected. FALSE otherwise.

Group

CWeekViewPart Methods


CXTPCalendarPaintManager::CWeekViewPart::OnDraw Method

CWeekViewPart Methods, CXTPCalendarPaintManager::CWeekViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewPart::OnDraw Method

This member function is used to draw an event.

virtual void OnDraw(
    CDC* pDC,
    CXTPCalendarWeekView* pWeekView
);
Parameters

pDC
Pointer to a valid device context.
pWeekView
A CXTPCalendarWeekView pointer to the Week Event View object.

Group

CWeekViewPart Methods


CXTPCalendarPaintManager::CWeekViewPart::RefreshMetrics Method

CWeekViewPart Methods, CXTPCalendarPaintManager::CWeekViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CWeekViewPart::RefreshMetrics Method

Performs refreshing of graphical related parameters from system settings.

virtual void RefreshMetrics();
Group

CWeekViewPart Methods


CXTPCalendarPaintManager::CXTPShadowDrawer Class

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Classes, Legend, Members, Topics, CXTPShadowDrawer Data Members, CXTPShadowDrawer Methods, CXTPShadowDrawer Data Members, CXTPShadowDrawer Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CXTPShadowDrawer Class

This is a helper class which handles shadows drawing (for events, etc)

Class Hierarchy

class CXTPShadowDrawer;
File

XTPCalendarPaintManager.h

Group

CXTPCalendarPaintManager Classes

Legend
Data Member
protected
Method
CXTPShadowDrawer Data Members
CXTPShadowDrawer Data Members | Description
m_dMaxAlpha | maximal shadow alpha grade
m_pDC | drawing device context
CXTPShadowDrawer Methods
CXTPShadowDrawer Methods | Description
ApplyShadow2007Right | methods for Office 2007 theme
ApplyShadowLR | Methods for Office 2003 theme
DrawShadowRectPart | Generic drawing of the shadow rectangle part


CXTPShadowDrawer Data Members

CXTPCalendarPaintManager::CXTPShadowDrawer Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShadowDrawer Data Members
Class

CXTPCalendarPaintManager::CXTPShadowDrawer Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dMaxAlpha | maximal shadow alpha grade
m_pDC | drawing device context


CXTPCalendarPaintManager::CXTPShadowDrawer::m_dMaxAlpha Data Member

CXTPShadowDrawer Data Members, CXTPCalendarPaintManager::CXTPShadowDrawer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CXTPShadowDrawer::m_dMaxAlpha Data Member

maximal shadow alpha grade

double m_dMaxAlpha;
Group

CXTPShadowDrawer Data Members


CXTPCalendarPaintManager::CXTPShadowDrawer::m_pDC Data Member

CXTPShadowDrawer Data Members, CXTPCalendarPaintManager::CXTPShadowDrawer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CXTPShadowDrawer::m_pDC Data Member

drawing device context

CDC* m_pDC;
Group

CXTPShadowDrawer Data Members


CXTPShadowDrawer Methods

CXTPCalendarPaintManager::CXTPShadowDrawer Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShadowDrawer Methods
Class

CXTPCalendarPaintManager::CXTPShadowDrawer Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
ApplyShadow2007Right | methods for Office 2007 theme
ApplyShadowLR | Methods for Office 2003 theme
DrawShadowRectPart | Generic drawing of the shadow rectangle part


CXTPCalendarPaintManager::CXTPShadowDrawer::ApplyShadow2007Right Method

CXTPShadowDrawer Methods, CXTPCalendarPaintManager::CXTPShadowDrawer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CXTPShadowDrawer::ApplyShadow2007Right Method

methods for Office 2007 theme

void ApplyShadow2007Right(
    UINT* pBitmap,
    const ULONG ulBitmapWidth,
    const ULONG ulBitmapHeight
);
Group

CXTPShadowDrawer Methods


CXTPCalendarPaintManager::CXTPShadowDrawer::ApplyShadowLR Method

CXTPShadowDrawer Methods, CXTPCalendarPaintManager::CXTPShadowDrawer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CXTPShadowDrawer::ApplyShadowLR Method

Methods for Office 2003 theme

void ApplyShadowLR(
    UINT* pBitmap,
    const ULONG ulBitmapWidth,
    const ULONG ulBitmapHeight
);
Group

CXTPShadowDrawer Methods


CXTPCalendarPaintManager::CXTPShadowDrawer::DrawShadowRectPart Method

CXTPShadowDrawer Methods, CXTPCalendarPaintManager::CXTPShadowDrawer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CXTPShadowDrawer::DrawShadowRectPart Method

Generic drawing of the shadow rectangle part

void DrawShadowRectPart(
    const CRect& rcShadow,
    const XTPShadowPart part
);
Group

CXTPShadowDrawer Methods


CXTPCalendarPaintManager Enumerations

Enumerations, CXTPCalendarPaintManager Class, Legend
CXTPCalendarPaintManager Enumerations
Enumerations
Enumeration | Description
XTPEnumExpandSigns | Enumerates types of expand signs drawn on a day view.
Class

CXTPCalendarPaintManager Class

Legend
Enumeration


CXTPCalendarPaintManager::XTPEnumExpandSigns Enumeration

XTPCalendarPaintManager.h, CXTPCalendarPaintManager Enumerations
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::XTPEnumExpandSigns Enumeration

Enumerates types of expand signs drawn on a day view.

enum XTPEnumExpandSigns {
  idxExpandSignUp = 0,
  idxExpandSignDown = 1
};
File

XTPCalendarPaintManager.h

Members

idxExpandSignUp
Expand sign: arrow up
idxExpandSignDown
Expand sign: arrow down

Group

CXTPCalendarPaintManager Enumerations


CXTPCalendarPaintManager Data Members

CXTPCalendarPaintManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager Data Members
Class

CXTPCalendarPaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arBusyStatusBrushes | Stores customizable brush values to draw Event Busy Status in the Day View.
m_bEnableTheme | True to enable Luna theme.
m_bmpTentativePattern | Stores standard bitmap pattern to draw Tentative event busy status.
m_brushTentative | Stores standard brush to draw Tentative event busy status.
m_clrUnderLineHdr | Color of header's underline.
m_CurrSystemTheme | Current theme flag.
m_dwAskItemTextFlags | Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.
m_ilExpandSigns | Stores standard Expand Signs icons.
m_ilGlyphs | Stores standard glyphs for displaying events.
m_lstViewParts | Collection to store ViewParts objects.
m_nPaintTheme | Store the Paint Theme;
m_pControl | Stores a pointer to a CXTPCalendarControl object.
m_pGlyphsFont | Stores standard glyphs font for displaying events.
m_szClockRect | Stores dimensions for a rectangle used to display the time as a clock glyph.
Public Data Members
Public Data Member | Description
m_clr3DShadow | Stores standard color to display shadow items.
m_clrButtonFace | Stores standard Button Face color.
m_clrButtonFaceText | Stores standard color to display text.
m_clrHighlight | Stores standard color to display highlighted items.
m_clrWindow | Stores standard windows color.
m_clrWindowText | Stores standard color to display window text.
m_grclrToday | Gradient color of today's header.


CXTPCalendarPaintManager::m_arBusyStatusBrushes Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_arBusyStatusBrushes Data Member

Stores customizable brush values to draw Event Busy Status in the Day View.

CXTPCalendarTypedPtrAutoDeleteArray<CPtrArray, CXTPCalendarViewPartBrushValue*> m_arBusyStatusBrushes;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_bEnableTheme Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_bEnableTheme Data Member

True to enable Luna theme.

BOOL m_bEnableTheme;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_bmpTentativePattern Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_bmpTentativePattern Data Member

Stores standard bitmap pattern to draw Tentative event busy status.

CBitmap m_bmpTentativePattern;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_brushTentative Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_brushTentative Data Member

Stores standard brush to draw Tentative event busy status.

CBrush m_brushTentative;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_clr3DShadow Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_clr3DShadow Data Member

Stores standard color to display shadow items.

CXTPPaintManagerColor m_clr3DShadow;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_clrButtonFace Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_clrButtonFace Data Member

Stores standard Button Face color.

CXTPPaintManagerColor m_clrButtonFace;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_clrButtonFaceText Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_clrButtonFaceText Data Member

Stores standard color to display text.

CXTPPaintManagerColor m_clrButtonFaceText;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_clrHighlight Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_clrHighlight Data Member

Stores standard color to display highlighted items.

CXTPPaintManagerColor m_clrHighlight;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_clrUnderLineHdr Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_clrUnderLineHdr Data Member

Color of header's underline.

COLORREF m_clrUnderLineHdr;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_clrWindow Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_clrWindow Data Member

Stores standard windows color.

CXTPPaintManagerColor m_clrWindow;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_clrWindowText Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_clrWindowText Data Member

Stores standard color to display window text.

CXTPPaintManagerColor m_clrWindowText;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_CurrSystemTheme Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_CurrSystemTheme Data Member

Current theme flag.

XTPCurrentSystemTheme m_CurrSystemTheme;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_dwAskItemTextFlags Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_dwAskItemTextFlags Data Member

Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

DWORD m_dwAskItemTextFlags;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_grclrToday Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_grclrToday Data Member

Gradient color of today's header.

CXTPPaintManagerColorGradient m_grclrToday;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_ilExpandSigns Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_ilExpandSigns Data Member

Stores standard Expand Signs icons.

CImageList m_ilExpandSigns;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_ilGlyphs Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_ilGlyphs Data Member

Stores standard glyphs for displaying events.

CImageList m_ilGlyphs;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_lstViewParts Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_lstViewParts Data Member

Collection to store ViewParts objects.

CList<CXTPCalendarViewPart*, CXTPCalendarViewPart*> m_lstViewParts;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_nPaintTheme Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_nPaintTheme Data Member

Store the Paint Theme;

XTPCalendarTheme m_nPaintTheme;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_pControl Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_pControl Data Member

Stores a pointer to a CXTPCalendarControl object.

CXTPCalendarControl* m_pControl;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_pGlyphsFont Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_pGlyphsFont Data Member

Stores standard glyphs font for displaying events.

CFont* m_pGlyphsFont;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager::m_szClockRect Data Member

CXTPCalendarPaintManager Data Members, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::m_szClockRect Data Member

Stores dimensions for a rectangle used to display the time as a clock glyph.

CSize m_szClockRect;
Group

CXTPCalendarPaintManager Data Members


CXTPCalendarPaintManager Methods

CXTPCalendarPaintManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager Methods
Class

CXTPCalendarPaintManager Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_GetAtGrow_BusyStatusBrushValue | Returns drawing brush value for a specific busy status.
AddViewPart | Call this member function to add the specified ViewPart object to the parts list.
InitBusyStatusDefaultColors | Set default colors/patterns to fill Busy Status area.
Public Methods
Public Methods
Public Method | Description
DrawBitmap |
DrawBusyStatus |
DrawClock | This member function is used to draw the time as clock.
DrawHeader |
DrawHorizontalLine | This member function is used to draw a Horizontal line.
DrawIconChar | This member function is used to draw the Glyph symbol using special font.
DrawIcons | Call this member function to draw icons corresponding to the event state.
DrawLine | This member function is used to draw an arbitrary line.
DrawShadow | Call this member function to draw the shadow regions around the rectangle.
DrawVerticalLine | This member function is used to draw a Vertical line.
EnableTheme | This member function is used to enable a new theme.
GetAskItemTextFlags | This member function returns set of flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.
GetBitmapSize | This member function is used to obtain the horizontal and vertical size of the bitmap.
GetBusyStatusBrush | Call this member function to get a brush to draw event busy status.
GetClockSize | This member function is used to obtain the horizontal and vertical size of the Clock.
GetCurrentSystemTheme | Call this member function to determine the current Windows XP theme that is in use.
GetExpandSignSize | This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
GetPaintTheme | This member function is used to obtain current paint theme.
IsThemeEnabled | This member function is used to obtain the status of the theme.
RefreshMetrics | This member function is used to initialize all drawing defaults.
SetAskItemTextFlags | This member function is used to set flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.
SetBusyStatusBrush | Call this member function to set custom brush to draw event busy status.
SetControl | This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
SetPaintTheme | This member function is used to set current paint theme.


CXTPCalendarPaintManager::_GetAtGrow_BusyStatusBrushValue Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::_GetAtGrow_BusyStatusBrushValue Method

Returns drawing brush value for a specific busy status.

CXTPCalendarViewPartBrushValue* _GetAtGrow_BusyStatusBrushValue(
    int eBusyStatus,
    BOOL bGrow
);
Parameters

eBusyStatus
Busy status enumeration.
bGrow
Append a new brush value if needed or not.

Returns

Pointer to CXTPCalendarViewPartBrushValue array member.

See Also

XTPCalendarEventBusyStatus

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::AddViewPart Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::AddViewPart Method

Call this member function to add the specified ViewPart object to the parts list.

CXTPCalendarViewPart* AddViewPart(
    CXTPCalendarViewPart* pPart
);
Parameters

pPart
Pointer to a 'View Part' object.

Returns

Pointer to a 'View Part' object.

Group

CXTPCalendarPaintManager Methods


DrawBitmap Method

CXTPCalendarPaintManager Methods
DrawBitmap Method
Overload List
Methods
Method | Description
CXTPCalendarPaintManager::DrawBitmap (CImageList*, CDC*, CRect, int, UINT) | This member function is used to draw a bitmap from the provided ImageList.
CXTPCalendarPaintManager::DrawBitmap (UINT, CDC*, CRect) | This member function is used to draw the bitmap using its resource id.
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::DrawBitmap Method (CImageList*, CDC*, CRect, int, UINT)

DrawBitmap Method, CXTPCalendarPaintManager Class
CXTPCalendarPaintManager::DrawBitmap Method (CImageList*, CDC*, CRect, int, UINT)

This member function is used to draw a bitmap from the provided ImageList.

virtual int DrawBitmap(
    CImageList* pImageList,
    CDC* pDC,
    CRect rcView,
    int iIcon,
    UINT uFlags = 0
);
Parameters

pImageList
A CImageList pointer to the ImageList.
pDC
Pointer to a valid device context.
rcView
A CRect object that contains the bounding rectangle coordinates to draw the bitmap.
iIcon
An int that contains the image index.
uFlags
Additional drawing options. Should be 0 or DT_VCENTER.

Returns

An int that contains the width of the drawn bitmap.

Remarks

Use this function to draw a bitmap in the view's bounding rectangle. If the provided bounding rectangle is too small, then the bitmap is not drawn.

Group

DrawBitmap Method


CXTPCalendarPaintManager::DrawBitmap Method (UINT, CDC*, CRect)

DrawBitmap Method, CXTPCalendarPaintManager Class
CXTPCalendarPaintManager::DrawBitmap Method (UINT, CDC*, CRect)

This member function is used to draw the bitmap using its resource id.

virtual int DrawBitmap(
    UINT nIDResource,
    CDC* pDC,
    CRect rcBitmap
);
Parameters

nIDResource
A UINT that contains the integer resource id of the bitmap.
pDC
Pointer to a valid device context.
rcBitmap
A CRect that contains the bounding rectangle coordinates used to draw the bitmap.

Returns

An int that contains the width of the drawn bitmap.

Remarks

Use this function to draw a bitmap in the view's bounding rectangle. If the provided bounding rectangle is too small, then the bitmap is not drawn.

Group

DrawBitmap Method


DrawBusyStatus Method

CXTPCalendarPaintManager Methods
DrawBusyStatus Method
Overload List
Methods
Method | Description
CXTPCalendarPaintManager::DrawBusyStatus (CDC*, CRect&, int) | This member function is used to fill the area using the corresponding busy color or pattern.
CXTPCalendarPaintManager::DrawBusyStatus (CDC*, CRgn&, int) | This member function is used to fill the area using the corresponding busy color or pattern.
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::DrawBusyStatus Method (CDC*, CRect&, int)

DrawBusyStatus Method, CXTPCalendarPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::DrawBusyStatus Method (CDC*, CRect&, int)

This member function is used to fill the area using the corresponding busy color or pattern.

virtual void DrawBusyStatus(
    CDC* pDC,
    CRect& rcRect,
    int eBusyStatus
);
virtual void DrawBusyStatus(
    CDC* pDC,
    CRgn& rgnBusy,
    int eBusyStatus
);
Parameters

pDC
Pointer to a valid device context.
rcRect
A CRect object that contains the rectangle coordinates used to fill the corresponding busy color or pattern.
eBusyStatus
An int that contains the Event Busy Status value from enum XTPCalendarEventBusyStatus.
rgnBusy
A CRgn that contains the region area used to fill with the corresponding busy color or pattern and draw the region border using m_clrWindowText color.

See Also

enum XTPCalendarEventBusyStatus determines Event Busy Status, CRgn.

Group

DrawBusyStatus Method


CXTPCalendarPaintManager::DrawClock Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::DrawClock Method

This member function is used to draw the time as clock.

virtual int DrawClock(
    CDC* pDC,
    COleDateTime dtClockTime,
    CRect rcView,
    COLORREF clrBackground,
    XTPCalendarClockAlignFlags cafAlign
);
Parameters

pDC
Pointer to a valid device context.
dtClockTime
A COleDateTime object that contains the time to draw.
rcView
A CRect object that contains the bounding rectangle coordinates of where the clock is drawn.
clrBackground
A COLORREF object that contains the background color of the clock.
cafAlign
A XTPCalendarClockAlignFlags alignment flag, appropriate values are determined by enum XTPCalendarClockAlignFlags.

Returns

Returns the size (width) of the square where clock icon was drawn inside. Zero when clock icon wasn't successfully drawn.

Remarks

This member function is used anywhere a time clock is needed.

See Also

enum XTPCalendarClockAlignFlags determines alignment flags.

Group

CXTPCalendarPaintManager Methods


DrawHeader Method

CXTPCalendarPaintManager Methods
DrawHeader Method
Overload List
Methods
Method | Description
CXTPCalendarPaintManager::DrawHeader (CDC*, CRect&, BOOL, BOOL) | This member function is used to draw the Header.
CXTPCalendarPaintManager::DrawHeader (CDC*, CRect&, BOOL, BOOL, const CXTPPaintManagerColorGradient&, COLORREF) | This member function is used to draw the Header.
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::DrawHeader Method (CDC*, CRect&, BOOL, BOOL)

DrawHeader Method, CXTPCalendarPaintManager Class
CXTPCalendarPaintManager::DrawHeader Method (CDC*, CRect&, BOOL, BOOL)

This member function is used to draw the Header.

virtual void DrawHeader(
    CDC* pDC,
    CRect& rcHeader,
    BOOL bIsSelected,
    BOOL bIsCurrent
);
virtual void DrawHeader(
    CDC* pDC,
    CRect& rcHeader,
    BOOL bIsSelected,
    BOOL bIsCurrent,
    const CXTPPaintManagerColorGradient& grclr,
    COLORREF clrUnderLineHdr
);
Parameters

pDC
Pointer to a valid device context.
rcHeader
A CRect that contains the bounding rectangle coordinates used to draw the header.
bIsSelected
A BOOL. TRUE if the header is selected. FALSE otherwise.
bIsCurrent
A BOOL. TRUE if the header represents the current time. FALSE otherwise.
grclr
A CXTPPaintManagerColorGradient object that specifies the Gradient color.
clrUnderLineHdr
A COLORREF object that specifies the color of header's underline.

Group

DrawHeader Method


CXTPCalendarPaintManager::DrawHorizontalLine Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::DrawHorizontalLine Method

This member function is used to draw a Horizontal line.

virtual void DrawHorizontalLine(
    CDC* pDC,
    int xPos,
    int yPos,
    int cx
);
Parameters

pDC
Pointer to a valid device context.
xPos
An int that contains the Horizontal coordinate of the beginning of the line.
yPos
An int that contains the Vertical coordinate of the beginning of the line.
cx
An int that contains the Length of the line.

Remarks

This member function is used anywhere a simple horizontal line is needed.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::DrawIconChar Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::DrawIconChar Method

This member function is used to draw the Glyph symbol using special font.

virtual int DrawIconChar(
    CDC* pDC,
    CRect rc,
    TCHAR ch
);
Parameters

pDC
Pointer to a valid device context.
rc
A CRect that contains the bounding rectangle coordinates used to draw the symbol.
ch
A char symbol (from the font) to draw.

Returns

An int that contains the width of the drawn symbol.

Remarks

Use this function to draw the Glyph symbol in the center of the provided bounding rectangle.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::DrawIcons Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::DrawIcons Method

Call this member function to draw icons corresponding to the event state.

virtual int DrawIcons(
    CDC* pDC,
    CXTPCalendarViewEvent* pViewEvent
);
Parameters

pDC
Pointer to a valid device context.
pViewEvent
A CXTPCalendarViewEvent pointer to the event view object.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::DrawLine Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::DrawLine Method

This member function is used to draw an arbitrary line.

virtual void DrawLine(
    CDC* pDC,
    int xPos,
    int yPos,
    int cx,
    int cy
);
Parameters

pDC
Pointer to a valid device context.
xPos
An int that contains the Horizontal coordinate of the beginning of line.
yPos
An int that contains the Vertical coordinate of the beginning of line.
cx
An int that contains the Horizontal coordinate of the end of line.
cy
An int that contains the Vertical coordinate of the end of line.

Remarks

This member function is used anywhere a simple arbitrary line is needed.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::DrawShadow Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::DrawShadow Method

Call this member function to draw the shadow regions around the rectangle.

virtual void DrawShadow(
    CDC* pDC,
    const CRect& rcRect
);
Parameters

pDC
Pointer to a valid device context.
rcRect
A CRect that contains the rectangle coordinates of where to draw the shadow regions.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::DrawVerticalLine Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::DrawVerticalLine Method

This member function is used to draw a Vertical line.

virtual void DrawVerticalLine(
    CDC* pDC,
    int xPos,
    int yPos,
    int cy
);
Parameters

pDC
Pointer to a valid device context.
xPos
An int that contains the Horizontal coordinates of the beginning of the line.
yPos
An int that contains the Vertical coordinates of the beginning of the line.
cy
An int that contains the Length of the line.
pPen
A CPen pointer to the pen object used to draw the line.

Remarks

This member function is used anywhere a simple vertical line is needed.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::EnableTheme Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::EnableTheme Method

This member function is used to enable a new theme.

void EnableTheme(
    BOOL bEnableTheme
);
Parameters

bEnableTheme
A BOOL. TRUE if the theme enabled. FALSE otherwise.

Body Source
void CXTPCalendarPaintManager::EnableTheme(BOOL bEnableTheme){
    m_bEnableTheme = bEnableTheme;
    RefreshMetrics();
}
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::GetAskItemTextFlags Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::GetAskItemTextFlags Method

This member function returns set of flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.

DWORD GetAskItemTextFlags() const;
Returns

Set of flags from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx.

See Also

XTPCalendarGetItemText, XTPCalendarGetItemTextEx, SetAskItemTextFlags, CXTPCalendarControl::GetAskItemTextFlags, CXTPCalendarTheme::GetAskItemTextFlags, CXTPCalendarTheme::SetAskItemTextFlags, XTP_NC_CALENDAR_GETITEMTEXT

Body Source
DWORD CXTPCalendarPaintManager::GetAskItemTextFlags() const {
    return m_dwAskItemTextFlags;
}
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::GetBitmapSize Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::GetBitmapSize Method

This member function is used to obtain the horizontal and vertical size of the bitmap.

virtual CSize GetBitmapSize(
    UINT nIDResource
);
Parameters

nIDResource
A UINT that contains the integer resource id of the bitmap.

Returns

A CSize object that contains the size of the bitmap.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::GetBusyStatusBrush Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::GetBusyStatusBrush Method

Call this member function to get a brush to draw event busy status.

CBrush* GetBusyStatusBrush(
    int nBusyStatus
);
Parameters

nBusyStatus
Busy status value.

Returns

Pointer to a brush object.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::GetClockSize Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::GetClockSize Method

This member function is used to obtain the horizontal and vertical size of the Clock.

virtual CSize GetClockSize();
Returns

A CSize object that contains the bitmap size.

Body Source
CSize CXTPCalendarPaintManager::GetClockSize(){
    return m_szClockRect;
}
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::GetCurrentSystemTheme Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::GetCurrentSystemTheme Method

Call this member function to determine the current Windows XP theme that is in use.

XTPCurrentSystemTheme GetCurrentSystemTheme();
Returns

A XTPCurrentSystemTheme enumeration that represents the current Windows theme in use, can be one of the following values: xtpSystemThemeUnknown - No known theme in use, or Windows Classic theme. xtpSystemThemeBlue - Blue theme in use. xtpSystemThemeOlive - Olive theme in use. xtpSystemThemeSilver - Silver theme in use.

Body Source
XTPCurrentSystemTheme CXTPCalendarPaintManager::GetCurrentSystemTheme(){
    return m_CurrSystemTheme;
}
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::GetExpandSignSize Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::GetExpandSignSize Method

This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.

virtual const CSize GetExpandSignSize();
Returns

A CSize object that contains the bitmap size.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::GetPaintTheme Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::GetPaintTheme Method

This member function is used to obtain current paint theme.

virtual XTPCalendarTheme GetPaintTheme() const;
Returns

A paint theme ID from enum XTPCalendarTheme.

Body Source
XTPCalendarTheme CXTPCalendarPaintManager::GetPaintTheme() const {
    return m_nPaintTheme;
}
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::InitBusyStatusDefaultColors Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::InitBusyStatusDefaultColors Method

Set default colors/patterns to fill Busy Status area.

virtual void InitBusyStatusDefaultColors();
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::IsThemeEnabled Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::IsThemeEnabled Method

This member function is used to obtain the status of the theme.

BOOL IsThemeEnabled();
Returns

A BOOL. TRUE if theme is enabled. FALSE otherwise.

Body Source
BOOL CXTPCalendarPaintManager::IsThemeEnabled(){
    return m_bEnableTheme;
}
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::RefreshMetrics Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::RefreshMetrics Method

This member function is used to initialize all drawing defaults.

virtual void RefreshMetrics();
Remarks

Initializes all drawings defaults (fonts, colors, etc.). most of defaults are system defaults.

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::SetAskItemTextFlags Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::SetAskItemTextFlags Method

This member function is used to set flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.

void SetAskItemTextFlags(
    DWORD dwFlags
);
Parameters

dwFlags
Set of flags from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx.

See Also

XTPCalendarGetItemText, XTPCalendarGetItemTextEx, GetAskItemTextFlags, CXTPCalendarControl::GetAskItemTextFlags, CXTPCalendarTheme::GetAskItemTextFlags, CXTPCalendarTheme::SetAskItemTextFlags, XTP_NC_CALENDAR_GETITEMTEXT

Body Source
void CXTPCalendarPaintManager::SetAskItemTextFlags(DWORD dwFlags) {
    m_dwAskItemTextFlags = dwFlags;
}
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::SetBusyStatusBrush Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::SetBusyStatusBrush Method

Call this member function to set custom brush to draw event busy status.

void SetBusyStatusBrush(
    int nBusyStatus,
    CBrush* pBrush,
    BOOL bAutodeleteBrush
);
Parameters

nBusyStatus
Busy status value.
pBrush
Pointer to a brush object.
bAutodeleteBrush
This parameter indicates should be a brush object deleted when destroy or other brush is set. If TRUE - brush object will be deleted automatically.

Example
 m_wndCalendar.GetPaintManager()->SetBusyStatusBrush(
     xtpCalendarBusyStatusFree, new CBrush(RGB(240, 255, 250)), TRUE);

 m_wndCalendar.GetPaintManager()->SetBusyStatusBrush(
     xtpCalendarBusyStatusTentative, new CBrush(RGB(240, 120, 250)), TRUE);

 m_wndCalendar.GetPaintManager()->SetBusyStatusBrush(
     100, new CBrush(RGB(240, 120, 250)), TRUE);
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::SetControl Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::SetControl Method

This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.

virtual void SetControl(
    CXTPCalendarControl* pControl
);
Parameters

pControl
A CXTPCalendarControl pointer to the CXTPCalendarControl object

Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager::SetPaintTheme Method

CXTPCalendarPaintManager Methods, CXTPCalendarPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::SetPaintTheme Method

This member function is used to set current paint theme.

virtual void SetPaintTheme(
    XTPCalendarTheme ePaintTheme
);
Parameters

ePaintTheme
A paint theme ID from enum XTPCalendarTheme.

Body Source
void CXTPCalendarPaintManager::SetPaintTheme(XTPCalendarTheme ePaintTheme) {
    m_nPaintTheme = min(xtpCalendarThemeOffice2003, ePaintTheme);
    RefreshMetrics();
}
Group

CXTPCalendarPaintManager Methods


CXTPCalendarPaintManager Constructors

CXTPCalendarPaintManager Class, Legend, Public Methods
CXTPCalendarPaintManager Constructors
Class

CXTPCalendarPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarPaintManager | Default paint manager constructor.


CXTPCalendarPaintManager::CXTPCalendarPaintManager Constructor

CXTPCalendarPaintManager Constructors, CXTPCalendarPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::CXTPCalendarPaintManager Constructor

Default paint manager constructor.

CXTPCalendarPaintManager();
Remarks

Handles initial initialization.

See Also

RefreshMetrics()

Group

CXTPCalendarPaintManager Constructors


CXTPCalendarPaintManager Destructors

CXTPCalendarPaintManager Class, Legend, Public Methods
CXTPCalendarPaintManager Destructors
Class

CXTPCalendarPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarPaintManager | Default paint manager destructor.


CXTPCalendarPaintManager::~CXTPCalendarPaintManager Destructor

CXTPCalendarPaintManager Destructors, CXTPCalendarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPaintManager::~CXTPCalendarPaintManager Destructor

Default paint manager destructor.

virtual ~CXTPCalendarPaintManager();
Remarks

Handles member items deallocation.

Group

CXTPCalendarPaintManager Destructors


CXTPCalendarPtrCollectionT Template

XTPCalendarPtrCollectionT.h, Classes, Legend, Members, Topics, CXTPCalendarPtrCollectionT Data Members, CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Constructors, CXTPCalendarPtrCollectionT Destructors, CXTPCalendarPtrCollectionT Nested Types, CXTPCalendarPtrCollectionT Constructors, CXTPCalendarPtrCollectionT Data Members, CXTPCalendarPtrCollectionT Destructors, CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT Template

This class represents a simple array collection of objects.

Class Hierarchy

template <class _TObject>
class CXTPCalendarPtrCollectionT;
File

XTPCalendarPtrCollectionT.h

Remarks

Array indexes always start at position 0.

As with a C array, the access time for indexed element of this array is constant and is independent of the array size.

See Also

overview, CArray overview

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarPtrCollectionT Constructors
CXTPCalendarPtrCollectionT Constructors | Description
CXTPCalendarPtrCollectionT | Default collection constructor.
CXTPCalendarPtrCollectionT Data Members
CXTPCalendarPtrCollectionT Data Members | Description
m_arElements | Objects storage.
CXTPCalendarPtrCollectionT Destructors
CXTPCalendarPtrCollectionT Destructors | Description
~CXTPCalendarPtrCollectionT | Default collection destructor.
CXTPCalendarPtrCollectionT Methods
CXTPCalendarPtrCollectionT Methods | Description
Add |
Append | This member function is used to add a new elements to the end of the array.
Find | This member function finds element index in the collection using its pointer.
GetAt |
GetCount | This member function is used to obtain the number of elements in the collection.
InsertAt | This member function is used to insert a new element at the position specified in the nIndex parameter.
Remove | This member function finds an element using its pointer and removes it from the array.
RemoveAll | This member function is used to remove all of the elements from the array.
RemoveAt | This member function removes an element at the specified index from the array.
SetAt | This member function is used to set a new element to the position specified in the nIndex parameter.
SetSize | This member function is used to change the array size.
CXTPCalendarPtrCollectionT Nested Types
CXTPCalendarPtrCollectionT Nested Types | Description
TObjectPtr | Smart pointer type for stored objects.


CXTPCalendarPtrCollectionT Data Members

CXTPCalendarPtrCollectionT Template, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT Data Members
Template

CXTPCalendarPtrCollectionT Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arElements | Objects storage.


CXTPCalendarPtrCollectionT::m_arElements Data Member

CXTPCalendarPtrCollectionT Data Members, CXTPCalendarPtrCollectionT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::m_arElements Data Member

Objects storage.

CArray<TObjectPtr, TObjectPtr&> m_arElements;
Group

CXTPCalendarPtrCollectionT Data Members


CXTPCalendarPtrCollectionT Methods

CXTPCalendarPtrCollectionT Template, Legend, Public Methods
CXTPCalendarPtrCollectionT Methods
Template

CXTPCalendarPtrCollectionT Template

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Add |
Append | This member function is used to add a new elements to the end of the array.
Find | This member function finds element index in the collection using its pointer.
GetAt |
GetCount | This member function is used to obtain the number of elements in the collection.
InsertAt | This member function is used to insert a new element at the position specified in the nIndex parameter.
Remove | This member function finds an element using its pointer and removes it from the array.
RemoveAll | This member function is used to remove all of the elements from the array.
RemoveAt | This member function removes an element at the specified index from the array.
SetAt | This member function is used to set a new element to the position specified in the nIndex parameter.
SetSize | This member function is used to change the array size.


Add Method

CXTPCalendarPtrCollectionT Methods
Add Method
Overload List
Methods
Method | Description
CXTPCalendarPtrCollectionT::Add (_TObject*) | This member function adds a new element to the end of the array.
CXTPCalendarPtrCollectionT::Add (_TObject*, BOOL) | This member function adds a new element to the end of the array.
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::Add Method (_TObject*)

Add Method, CXTPCalendarPtrCollectionT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::Add Method (_TObject*)

This member function adds a new element to the end of the array.

virtual void Add(
    _TObject* pNewElement
);
virtual void Add(
    _TObject* pNewElement,
    BOOL bWithAddRef
);
Parameters

pNewElement
A pointer to a _TObjectThe object. Element to add to the array.
bWithAddRef
A BOOL. If this parameter is TRUE then InternalAddRef() is called for pNewElement, otherwise it is not called.

Remarks

Use this method to add the specified pointer to the end of the events collection. Reference to the added object is increased.

See Also

CXTPCalendarPtrCollectionT overview, GetAt, RemoveAll, GetCount

Example
CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

// Add() will call InernalAddRef()
arList.Add(ptrEvent1);

// Add() will not call InernalAddRef()
arList.Add(new CXTPCalendarEvent(), FALSE);

// GetAt() will call InernalAddRef()
CXTPCalendarEventPtr ptrEvent0 = arList.GetAt(0);

// GetAt() will not call InernalAddRef()
CXTPCalendarEvent* pEvent1 = arList.GetAt(1, FALSE);

ASSERT(2 == arList.GetCount());

//RemoveAll() will call InernalRelease() for all objects
arList.RemoveAll();

ASSERT(0 == arList.GetCount());

Version 2

CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

// Add() will call InernalAddRef()
arList.Add(ptrEvent1);

// Add() will not call InernalAddRef()
arList.Add(new CXTPCalendarEvent(), FALSE);

// GetAt() will call InernalAddRef()
CXTPCalendarEventPtr ptrEvent0 = arList.GetAt(0);

// GetAt() will not call InernalAddRef()
CXTPCalendarEvent* pEvent1 = arList.GetAt(1, FALSE);

ASSERT(2 == arList.GetCount());

//RemoveAll() will call InernalRelease() for all objects
arList.RemoveAll();

ASSERT(0 == arList.GetCount());
Body Source
template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::Add(_TObject* pNewElement)
{
    TObjectPtr ptrNewElement(pNewElement);
    m_arElements.Add(ptrNewElement);
}

template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::Add(_TObject* pNewElement, BOOL bWithAddRef)
{
    if (bWithAddRef && pNewElement) {
        pNewElement->InternalAddRef();
    }
    TObjectPtr ptrNewElement(pNewElement);
    m_arElements.Add(ptrNewElement);
}
Group

Add Method


CXTPCalendarPtrCollectionT::Append Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::Append Method

This member function is used to add a new elements to the end of the array.

virtual void Append(
    CXTPCalendarPtrCollectionT<_TObject>* pElementsArray
);
Parameters

pElementsArray
A pointer to an array of _TObject objects. A pointer to the collection to add to the array.

Remarks

Use this method to add the elements from the specified array to the end of the collection. Reference to the new object is increased.

See Also

GetAt, Add, InsertAt, SetAt

Example
CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList1;
CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList2;
...
arList1.Append(&arList2);
Body Source
template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::Append(CXTPCalendarPtrCollectionT<_TObject>* pElementsArray)
{
    if (!pElementsArray) {
        ASSERT(FALSE);
        return;
    }

    int nCount = pElementsArray->GetCount();
    for (int i = 0; i < nCount; i++)
    {
        TObjectPtr ptrElement = pElementsArray->GetAt(i, TRUE);
        m_arElements.Add(ptrElement);
    }
}
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::Find Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::Find Method

This member function finds element index in the collection using its pointer.

virtual int Find(
    const _TObject* pElement
);
Parameters

pElement
A pointer to a _TObject object. The element to find in the array.

Returns

-1 if element is not found, otherwise an integer index that is greater than or equal to 0 and less than the value returned by GetCount. The specified element currently at this index.

Body Source
template<class _TObject>
AFX_INLINE int CXTPCalendarPtrCollectionT<_TObject>::Find(const _TObject* pElement)
{
    int nCount = GetCount();
    for (int i = 0; i < nCount; i++)
    {
        if (GetAt(i) == pElement)
            return i;
    }
    return -1;
}
Group

CXTPCalendarPtrCollectionT Methods


GetAt Method

CXTPCalendarPtrCollectionT Methods
GetAt Method
Overload List
Methods
Method | Description
CXTPCalendarPtrCollectionT::GetAt (int) | This member function returns an element at the specified numeric index. Reference to the returned object is increased.
CXTPCalendarPtrCollectionT::GetAt (int, BOOL) | This member function returns an element at the specified numeric index. Reference to the returned object is increased.
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::GetAt Method (int)

GetAt Method, CXTPCalendarPtrCollectionT Template, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::GetAt Method (int)

This member function returns an element at the specified numeric index. Reference to the returned object is increased.

virtual _TObject* GetAt(
    int nIndex
) const;
virtual _TObject* GetAt(
    int nIndex,
    BOOL bWithAddRef
) const;
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
bWithAddRef
A BOOL. If this parameter is TRUE then InternalAddRef() is called for the returned object, otherwise it is not called.

Returns

A pointer to a _TObject object. The element currently at this index.

Remarks

Returns the array element at the specified index.

Example

See the example for the Add() method.

Body Source
template<class _TObject>
AFX_INLINE _TObject* CXTPCalendarPtrCollectionT<_TObject>::GetAt(int nIndex) const
{
    _TObject* pElement = m_arElements[nIndex];
    return pElement;
}

template<class _TObject>
AFX_INLINE _TObject* CXTPCalendarPtrCollectionT<_TObject>::GetAt(int nIndex, BOOL bWithAddRef) const
{
    _TObject* pElement = m_arElements[nIndex];
    if (bWithAddRef && pElement) {
        pElement->InternalAddRef();
    }
    return pElement;
}
Group

GetAt Method


CXTPCalendarPtrCollectionT::GetCount Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::GetCount Method

This member function is used to obtain the number of elements in the collection.

virtual int GetCount() const;
Returns

The number of items in the collection.

Remarks

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

Example

See example for CXTPCalendarEvents::Add method.

Body Source
template<class _TObject>
AFX_INLINE int CXTPCalendarPtrCollectionT<_TObject>::GetCount() const
{
    return (int)m_arElements.GetSize();
}
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::InsertAt Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::InsertAt Method

This member function is used to insert a new element at the position specified in the nIndex parameter.

virtual void InsertAt(
    int nIndex,
    _TObject* pElement
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount().
pElement
A pointer to a _TObject object. The element to add to the array.

Remarks

Use this method to insert the specified element t the position specified in the nIndex parameter. Reference to the new object is increased.

See Also

GetAt, Add, InsertAt

Example
CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

arList.Add(ptrEvent1);
arList.InsertAt(0, new CXTPCalendarEvent());
Body Source
template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::InsertAt(int nIndex, _TObject* pElement)
{
    TObjectPtr ptrNewElement(pElement);
    m_arElements.InsertAt(nIndex, ptrNewElement);
}
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::Remove Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::Remove Method

This member function finds an element using its pointer and removes it from the array.

virtual void Remove(
    _TObject* pElement
);
Parameters

pElement
A pointer to a _TObject object. The element to find in the array.

Remarks

Removes the pointer from this array and releases instance of the stored object.

See Also

RemoveAt(), RemoveAll()

Body Source
template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::Remove(_TObject* pElement)
{
    int nCount = GetCount();
    for (int i = 0; i < nCount; i++)
    {
        if (GetAt(i) == pElement)
        {
            RemoveAt(i);
            break;
        }
    }
}
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::RemoveAll Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::RemoveAll Method

This member function is used to remove all of the elements from the array.

virtual void RemoveAll();
Remarks

Removes all of the pointers from this array and releases instances of all stored objects.

See Also

CXTPCalendarEvents overview

Example

See example for CXTPCalendarEvents::Add method.

Body Source
template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::RemoveAll(/*BOOL bWithRelease*/)
{
    m_arElements.RemoveAll();
}
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::RemoveAt Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::RemoveAt Method

This member function removes an element at the specified index from the array.

virtual void RemoveAt(
    int nIndex
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount().

Remarks

Removes the pointer from this array and releases instance of the stored object.

Body Source
template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::RemoveAt(int nIndex/*, BOOL bWithRelease*/)
{
    m_arElements.RemoveAt(nIndex);
}
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::SetAt Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::SetAt Method

This member function is used to set a new element to the position specified in the nIndex parameter.

virtual void SetAt(
    int nIndex,
    _TObject* pElement
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
pElement
A pointer to a _TObject object. The element to add to the array.

Remarks

Use this method to set the specified element to the position specified in nIndex parameter. Reference to the previous object is decreased. Reference to the new object is increased.

See Also

GetAt, Add, InsertAt

Example
CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

arList.Add(ptrEvent1);
arList.SetAt(0, new CXTPCalendarEvent());
Body Source
template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::SetAt(int nIndex, _TObject* pElement)
{
    TObjectPtr ptrNewElement(pElement);
    m_arElements.SetAt(nIndex, ptrNewElement);
}
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT::SetSize Method

CXTPCalendarPtrCollectionT Methods, CXTPCalendarPtrCollectionT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::SetSize Method

This member function is used to change the array size.

virtual void SetSize(
    int nNewSize
);
Parameters

nNewSize
An int that contains the new array size.

Remarks

Argument nNewSize contains the new array size (number of elements). Must be greater than or equal to 0.

Body Source
template<class _TObject>
AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::SetSize(int nNewSize)
{
    m_arElements.SetSize(nNewSize);
}
Group

CXTPCalendarPtrCollectionT Methods


CXTPCalendarPtrCollectionT Constructors

CXTPCalendarPtrCollectionT Template, Legend, Public Methods
CXTPCalendarPtrCollectionT Constructors
Template

CXTPCalendarPtrCollectionT Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarPtrCollectionT | Default collection constructor.


CXTPCalendarPtrCollectionT::CXTPCalendarPtrCollectionT Constructor

CXTPCalendarPtrCollectionT Constructors, CXTPCalendarPtrCollectionT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::CXTPCalendarPtrCollectionT Constructor

Default collection constructor.

CXTPCalendarPtrCollectionT();
See Also

~CXTPCalendarPtrCollectionT()

Body Source
template<class _TObject>
AFX_INLINE CXTPCalendarPtrCollectionT<_TObject>::CXTPCalendarPtrCollectionT()
{
}
Group

CXTPCalendarPtrCollectionT Constructors


CXTPCalendarPtrCollectionT Destructors

CXTPCalendarPtrCollectionT Template, Legend, Public Methods
CXTPCalendarPtrCollectionT Destructors
Template

CXTPCalendarPtrCollectionT Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarPtrCollectionT | Default collection destructor.


CXTPCalendarPtrCollectionT::~CXTPCalendarPtrCollectionT Destructor

CXTPCalendarPtrCollectionT Destructors, CXTPCalendarPtrCollectionT Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::~CXTPCalendarPtrCollectionT Destructor

Default collection destructor.

virtual ~CXTPCalendarPtrCollectionT();
Remarks

Handles member items deallocation. Decreases reference of all stored objects.

See Also

RemoveAll()

Group

CXTPCalendarPtrCollectionT Destructors


CXTPCalendarPtrCollectionT Nested Types

CXTPCalendarPtrCollectionT Template, Public Nested Types
CXTPCalendarPtrCollectionT Nested Types
Template

CXTPCalendarPtrCollectionT Template

Public Nested Types
Public Nested Type | Description
TObjectPtr | Smart pointer type for stored objects.


CXTPCalendarPtrCollectionT::TObjectPtr Nested Type

CXTPCalendarPtrCollectionT Nested Types, CXTPCalendarPtrCollectionT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarPtrCollectionT::TObjectPtr Nested Type

Smart pointer type for stored objects.

typedef CXTPSmartPtrInternalT<_TObject> TObjectPtr;
Group

CXTPCalendarPtrCollectionT Nested Types


CXTPCalendarRecurrencePattern Class

XTPCalendarRecurrencePattern.h, Classes, Legend, Members, Topics, CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Constructors, CXTPCalendarRecurrencePattern Destructors, CXTPCalendarRecurrencePattern Constructors, CXTPCalendarRecurrencePattern Destructors, CXTPCalendarRecurrencePattern Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern Class

This class represents a recurrence pattern and stores data to build schedule for recurrence events.

Class Hierarchy

class CXTPCalendarRecurrencePattern;
File

XTPCalendarRecurrencePattern.h

See Also

CXTPCalendarEvent overview.

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarRecurrencePattern Constructors
CXTPCalendarRecurrencePattern Constructors | Description
CXTPCalendarRecurrencePattern | Protected pattern constructor.
CXTPCalendarRecurrencePattern Destructors
CXTPCalendarRecurrencePattern Destructors | Description
~CXTPCalendarRecurrencePattern | Default class destructor.
CXTPCalendarRecurrencePattern Methods
CXTPCalendarRecurrencePattern Methods | Description
ClonePattern | This member function is used to obtain a pointer to the read-write copy of the pattern object.
DoPropExchange | Call this member function to Store/Load a recurrence pattern using the specified data object.
FindException | This member function is used to find the exception event by its original start and end dates.
FindExceptionIndex | This member function is used to find the index of the exception event by its original start and end dates.
FindExceptions | This member function is used to find an exception event by its original start and end dates.
GetCustomProperties | Get custom (named, user defined) properties collection.
GetDuration | Call this member function to get the duration as a COleDateTimeSpan object.
GetDurationMinutes | Call this member function to get a duration in minutes.
GetEndAfterOccurrences | This member function is used to obtain the "End After occurrences" recurrence pattern option.
GetEndOccurrenceTime | Call this member function to get the occurrence end date-time by its start time.
GetExceptions | This member function is used to return the read-only collection with the exception events.
GetMasterEvent | This member function is used to obtain a pointer to the read-only interface of the master event.
GetMasterEventID | This member function is used to obtain the master event ID value.
GetOccReminders | This member function is used to retrieve a collection of reminders settings for occurrences of this recurrence pattern.
GetOccurrences | This member function is used to obtain the occurrence dates from the pattern in the given interval.
GetOccurrencesDates | This member function is used to obtain the occurrence dates from the pattern in the given interval.
GetPatternEnd | Call this method to retrieve the end pattern value.
GetPatternEndDate | Call this member function to obtain the end pattern DateTime.
GetPatternID | Returns a unique pattern ID.
GetPatternStartDate | Call this member function to obtain the start pattern DateTime.
GetRecurrenceOptions | This member function is used to obtain a set of recurrence options.
GetRecurrenceType | This member function is used to obtain the value of the recurrence type flag.
GetStartOccurrenceTime | Call this member function to get the occurrence start date-time.
GetStartTime | Call this member function to get start date-time.
GetUseEndMethod | Call this method to retrieve the value of the "use end" flag.
IsNoEndDate | This member function is used to determines if the pattern has an end date.
RemoveAllExceptions | This member function is used to remove all of the exceptions from the master event.
RemoveException | This member function is used to remove an exception from the master event.
SetDurationMinutes | This member function is used to set the new duration value.
SetEndAfterOccurrences | This member function is used to set the "End After occurrences" recurrence pattern option.
SetException | This member function is used to add an exception to the master event.
SetMasterEventID | This member function is used to set the master event ID value.
SetNoEndDate | This member function is used to reset the pattern end date.
SetOccReminder | This member function is used to setup an occurrence with new Reminder settings.
SetPatternEnd | Call this method to set the end pattern value.
SetPatternEndDate | This member function is used to set the new end pattern date.
SetPatternID | This member function is used to assign an ID to a pattern.
SetPatternStartDate | This member function is used to set the new start pattern date and time.
SetRecurrenceOptions | This member function is used to set the recurrence options.
SetStartTime | This member function is used to set the new start date and time.
Update | This member function is used to update the pattern data from the given pattern.


CXTPCalendarRecurrencePattern Methods

CXTPCalendarRecurrencePattern Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern Methods
Class

CXTPCalendarRecurrencePattern Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
SetPatternID | This member function is used to assign an ID to a pattern.
Public Methods
Public Methods
Public Method | Description
ClonePattern | This member function is used to obtain a pointer to the read-write copy of the pattern object.
DoPropExchange | Call this member function to Store/Load a recurrence pattern using the specified data object.
FindException | This member function is used to find the exception event by its original start and end dates.
FindExceptionIndex | This member function is used to find the index of the exception event by its original start and end dates.
FindExceptions | This member function is used to find an exception event by its original start and end dates.
GetCustomProperties | Get custom (named, user defined) properties collection.
GetDuration | Call this member function to get the duration as a COleDateTimeSpan object.
GetDurationMinutes | Call this member function to get a duration in minutes.
GetEndAfterOccurrences | This member function is used to obtain the "End After occurrences" recurrence pattern option.
GetEndOccurrenceTime | Call this member function to get the occurrence end date-time by its start time.
GetExceptions | This member function is used to return the read-only collection with the exception events.
GetMasterEvent | This member function is used to obtain a pointer to the read-only interface of the master event.
GetMasterEventID | This member function is used to obtain the master event ID value.
GetOccReminders | This member function is used to retrieve a collection of reminders settings for occurrences of this recurrence pattern.
GetOccurrences | This member function is used to obtain the occurrence dates from the pattern in the given interval.
GetOccurrencesDates | This member function is used to obtain the occurrence dates from the pattern in the given interval.
GetPatternEnd | Call this method to retrieve the end pattern value.
GetPatternEndDate | Call this member function to obtain the end pattern DateTime.
GetPatternID | Returns a unique pattern ID.
GetPatternStartDate | Call this member function to obtain the start pattern DateTime.
GetRecurrenceOptions | This member function is used to obtain a set of recurrence options.
GetRecurrenceType | This member function is used to obtain the value of the recurrence type flag.
GetStartOccurrenceTime | Call this member function to get the occurrence start date-time.
GetStartTime | Call this member function to get start date-time.
GetUseEndMethod | Call this method to retrieve the value of the "use end" flag.
IsNoEndDate | This member function is used to determines if the pattern has an end date.
RemoveAllExceptions | This member function is used to remove all of the exceptions from the master event.
RemoveException | This member function is used to remove an exception from the master event.
SetDurationMinutes | This member function is used to set the new duration value.
SetEndAfterOccurrences | This member function is used to set the "End After occurrences" recurrence pattern option.
SetException | This member function is used to add an exception to the master event.
SetMasterEventID | This member function is used to set the master event ID value.
SetNoEndDate | This member function is used to reset the pattern end date.
SetOccReminder | This member function is used to setup an occurrence with new Reminder settings.
SetPatternEnd | Call this method to set the end pattern value.
SetPatternEndDate | This member function is used to set the new end pattern date.
SetPatternStartDate | This member function is used to set the new start pattern date and time.
SetRecurrenceOptions | This member function is used to set the recurrence options.
SetStartTime | This member function is used to set the new start date and time.
Update | This member function is used to update the pattern data from the given pattern.


CXTPCalendarRecurrencePattern::ClonePattern Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::ClonePattern Method

This member function is used to obtain a pointer to the read-write copy of the pattern object.

virtual CXTPCalendarRecurrencePatternPtr ClonePattern();
Returns

Smart pointer to CXTPCalendarRecurrencePattern object.

See Also

CXTPCalendarRecurrencePattern.

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::DoPropExchange Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::DoPropExchange Method

Call this member function to Store/Load a recurrence pattern using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Remarks

This member function is used to store or load pattern data to or form an storage.

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::FindException Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::FindException Method

This member function is used to find the exception event by its original start and end dates.

virtual CXTPCalendarEvent* FindException(
    COleDateTime dtStartOrig,
    COleDateTime dtEndOrig
) const;
Parameters

dtStartOrig
A COleDateTime object that contains the start date.
dtEndOrig
A COleDateTime object that contains the end date.

Returns

If the exception event is found, then the function returns a pointer to a CXTPCalendarEvent object that contains the exception event. If the exception event is not found, then the function returns NULL.

See Also

CXTPCalendarEvent

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::FindExceptionIndex Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::FindExceptionIndex Method

This member function is used to find the index of the exception event by its original start and end dates.

virtual int FindExceptionIndex(
    COleDateTime dtStartOrig,
    COleDateTime dtEndOrig
) const;
Parameters

dtStartOrig
A COleDateTime object that contains the start date.
dtEndOrig
A COleDateTime object that contains the end date.

Returns

An int that contains the value of the index in the collection. -1 if the exception is not found in the collection.

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::FindExceptions Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::FindExceptions Method

This member function is used to find an exception event by its original start and end dates.

virtual BOOL FindExceptions(
    CXTPCalendarEvents* pEvents,
    COleDateTime dtStart,
    COleDateTime dtEnd
) const;
Parameters

pEvents
A CXTPCalendarEvents pointer that points to the collection of events to be found.
dtStart
A COleDateTime object that contains the start date of the search interval.
dtEnd
A COleDateTime object that contains the end date of search interval.

Returns

A BOOL. The base class implementation alway returns TRUE. This function should return TRUE if successful. FALSE otherwise.

See Also

CXTPCalendarEvents

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetCustomProperties Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetCustomProperties Method

Get custom (named, user defined) properties collection.

CXTPCalendarCustomProperties* GetCustomProperties();
Returns

A pointer to CXTPCalendarCustomProperties object.

See Also

CXTPCalendarCustomProperties.

Body Source
CXTPCalendarCustomProperties* CXTPCalendarRecurrencePattern::GetCustomProperties() {
    return m_pCustomProperties;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetDuration Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetDuration Method

Call this member function to get the duration as a COleDateTimeSpan object.

virtual COleDateTimeSpan GetDuration() const;
Returns

A COleDateTimeSpan object with a duration interval.

See Also

SetDuration(COleDateTimeSpan spDuration, BOOL bKeepStart = TRUE)

Body Source
COleDateTimeSpan CXTPCalendarRecurrencePattern::GetDuration() const {
    return CXTPCalendarUtils::Minutes2Span(m_nDurationMinutes);
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetDurationMinutes Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetDurationMinutes Method

Call this member function to get a duration in minutes.

virtual int GetDurationMinutes() const;
Returns

Integer value of a duration in minutes

See Also

SetDurationMinutes(int nMinutes), GetDuration()

Body Source
int CXTPCalendarRecurrencePattern::GetDurationMinutes() const {
    return m_nDurationMinutes;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetEndAfterOccurrences Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetEndAfterOccurrences Method

This member function is used to obtain the "End After occurrences" recurrence pattern option.

virtual int GetEndAfterOccurrences() const;
Returns

An int that contains the occurrence count for the pattern end.

See Also

SetEndAfterOccurrences, GetPatternEndDate, IsNoEndDate

Body Source
int CXTPCalendarRecurrencePattern::GetEndAfterOccurrences() const {
    return m_PatternEnd.m_nEndAfterOccurrences;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetEndOccurrenceTime Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetEndOccurrenceTime Method

Call this member function to get the occurrence end date-time by its start time.

virtual COleDateTime GetEndOccurrenceTime(
    COleDateTime dtOccurrenceStartDate
) const;
Parameters

dtOccurrenceStartDate
A COleDateTime object that contains the date-time occurrence to identify.

Returns

A COleDateTime object containing the occurrence end date-time.

See Also

SetStartTime(COleDateTime dtStart)

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetExceptions Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetExceptions Method

This member function is used to return the read-only collection with the exception events.

virtual CXTPCalendarEventsPtr GetExceptions();
Returns

Smart pointer to a CXTPCalendarEvents object that contains the read-only collection of exception events.

See Also

CXTPCalendarEvent, CXTPCalendarEvent, RemoveAllExceptions()

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetMasterEvent Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetMasterEvent Method

This member function is used to obtain a pointer to the read-only interface of the master event.

virtual CXTPCalendarEventPtr GetMasterEvent() const;
Returns

Smart pointer to CXTPCalendarEvent object.

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetMasterEventID Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetMasterEventID Method

This member function is used to obtain the master event ID value.

virtual DWORD GetMasterEventID() const;
Returns

A DWORD that contains the master event ID value.

See Also

SetMasterEventID(DWORD dwEventID).

Body Source
DWORD CXTPCalendarRecurrencePattern::GetMasterEventID() const {
    return m_dwMasterEventID;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetOccReminders Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetOccReminders Method

This member function is used to retrieve a collection of reminders settings for occurrences of this recurrence pattern.

CXTPCalendarReminderForOccurrenceArray* GetOccReminders();
Returns

An array of CXTPCalendarReminderForoccurrence objects for every occurrence with configured Reminders settings.

See Also

CXTPCalendarReminderForoccurrenceArray overview

Body Source
CXTPCalendarReminderForOccurrenceArray* CXTPCalendarRecurrencePattern::GetOccReminders() {
    return &m_arOccReminders;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetOccurrences Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetOccurrences Method

This member function is used to obtain the occurrence dates from the pattern in the given interval.

virtual BOOL GetOccurrences(
    CXTPCalendarEvents* pEventsArray,
    COleDateTime dtStart,
    COleDateTime dtEnd,
    CXTPCalendarEvent* pMasterEvent
);
Parameters

pEventsArray
Pointer to a CXTPCalendarEvents object that contains the returned collection of slave events (occurrences).
dtStart
A COleDateTime object that contains the interval's begin date.
dtEnd
A COleDateTime object that contains the interval's end date.
pMasterEvent
Pointer to a CXTPCalendarEvent object that contains the master event.

See Also

CXTPCalendarEvents, CXTPCalendarEvent

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetOccurrencesDates Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetOccurrencesDates Method

This member function is used to obtain the occurrence dates from the pattern in the given interval.

virtual void GetOccurrencesDates(
    CXTPCalendarDatesArray& rArDates,
    COleDateTime dtStart,
    COleDateTime dtEnd
) const;
Parameters

rArDates
A CDatesArray reference to an array of dates to be returned.
dtStart
A COleDateTime object that contains the interval's begin date.
dtEnd
A COleDateTime object that contains the interval's end date.

See Also

CDatesArray

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetPatternEnd Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetPatternEnd Method

Call this method to retrieve the end pattern value.

virtual const XTP_CALENDAR_PATTERN_END& GetPatternEnd() const;
Returns

A reference of the associated pattern end structure.

See Also

XTP_CALENDAR_PATTERN_END, XTPCalendarPatternEnd

Body Source
const XTP_CALENDAR_PATTERN_END& CXTPCalendarRecurrencePattern::GetPatternEnd() const {
    return m_PatternEnd;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetPatternEndDate Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetPatternEndDate Method

Call this member function to obtain the end pattern DateTime.

virtual COleDateTime GetPatternEndDate() const;
Returns

A COleDateTime object that contains the parent's end DateTime.

See Also

SetPatternEndDate(COleDateTime dtEnd)

Body Source
COleDateTime CXTPCalendarRecurrencePattern::GetPatternEndDate() const {
    return m_PatternEnd.m_dtPatternEndDate;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetPatternID Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetPatternID Method

Returns a unique pattern ID.

virtual DWORD GetPatternID() const;
See Also

CXTPCalendarRecurrencePattern()

Body Source
DWORD CXTPCalendarRecurrencePattern::GetPatternID() const {
    return m_dwPatternID;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetPatternStartDate Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetPatternStartDate Method

Call this member function to obtain the start pattern DateTime.

virtual COleDateTime GetPatternStartDate() const;
Returns

A COleDateTime object containing the parent's start DateTime.

See Also

SetPatternStartTime(COleDateTime dtStart)

Body Source
COleDateTime CXTPCalendarRecurrencePattern::GetPatternStartDate() const {
    return m_dtPatternStartDate;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetRecurrenceOptions Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetRecurrenceOptions Method

This member function is used to obtain a set of recurrence options.

virtual const XTP_CALENDAR_RECURRENCE_OPTIONS& GetRecurrenceOptions() const;
Returns

Reference to an XTP_CALENDAR_RECURRENCE_OPTIONS struct.

See Also

XTP_CALENDAR_RECURRENCE_OPTIONS, SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS& Options)

Body Source
const XTP_CALENDAR_RECURRENCE_OPTIONS& CXTPCalendarRecurrencePattern::GetRecurrenceOptions() const {
    return m_Options;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetRecurrenceType Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetRecurrenceType Method

This member function is used to obtain the value of the recurrence type flag.

virtual int GetRecurrenceType() const;
Returns

An int that contains the previous value of the Recurrence type flag.

See Also

XTPCalendarEventRecurrenceType, XTP_CALENDAR_RECURRENCE_OPTIONS, SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS& Options)

Body Source
int CXTPCalendarRecurrencePattern::GetRecurrenceType() const {
    return m_Options.m_nRecurrenceType;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetStartOccurrenceTime Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetStartOccurrenceTime Method

Call this member function to get the occurrence start date-time.

virtual COleDateTime GetStartOccurrenceTime(
    COleDateTime dtOccurrenceStartDate
) const;
Parameters

dtOccurrenceStartDate
COleDateTime representing the start date.

Returns

A COleDateTime object that contains the parent's start date-time.

See Also

SetStartOccurrenceTime(COleDateTime dtStart)

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetStartTime Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetStartTime Method

Call this member function to get start date-time.

virtual COleDateTime GetStartTime() const;
Returns

COleDateTime object containing start date-time.

See Also

SetStartTime(COleDateTime dtStart)

Body Source
COleDateTime CXTPCalendarRecurrencePattern::GetStartTime() const {
    return m_dtStartTime;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::GetUseEndMethod Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::GetUseEndMethod Method

Call this method to retrieve the value of the "use end" flag.

virtual XTPCalendarPatternEnd GetUseEndMethod() const;
Returns

An int that contains the "use end" flag value.

See Also

XTPCalendarPatternEnd.

Body Source
XTPCalendarPatternEnd CXTPCalendarRecurrencePattern::GetUseEndMethod() const {
    return m_PatternEnd.m_nUseEnd;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::IsNoEndDate Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::IsNoEndDate Method

This member function is used to determines if the pattern has an end date.

virtual BOOL IsNoEndDate() const;
Returns

A BOOL. TRUE if the pattern end is not set. FALSE otherwise.

See Also

SetNoEndDate(), GetEndAfterOccurrences(), GetPatternEndDate()

Body Source
BOOL CXTPCalendarRecurrencePattern::IsNoEndDate() const {
    return (m_PatternEnd.m_nUseEnd == xtpCalendarPatternEndNoDate);
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::RemoveAllExceptions Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::RemoveAllExceptions Method

This member function is used to remove all of the exceptions from the master event.

virtual void RemoveAllExceptions();
See Also

RemoveException(CXTPCalendarEvent* pException, CXTPCalendarEvent* pMasterEventToUpdate = NULL), SetException(CXTPCalendarEvent* pException, CXTPCalendarEvent* pMasterEventToUpdate = NULL)

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::RemoveException Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::RemoveException Method

This member function is used to remove an exception from the master event.

virtual BOOL RemoveException(
    CXTPCalendarEvent* pException,
    CXTPCalendarEvent* pMasterEventToUpdate = NULL
);
Parameters

pException
A pointer to a CXTPCalendarEvent object that represents the exception.
pMasterEventToUpdate
A pointer to the CXTPCalendarEvent object from which the exception is removed.

Returns

TRUE is success; FALSE otherwise.

See Also

CXTPCalendarEvent, CXTPCalendarEvent, RemoveAllExceptions()

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetDurationMinutes Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetDurationMinutes Method

This member function is used to set the new duration value.

virtual void SetDurationMinutes(
    int nMinutes
);
Parameters

nMinutes
An int that contains the new duration value in minutes.

See Also

GetDurationMinutes()

Body Source
void CXTPCalendarRecurrencePattern::SetDurationMinutes(int nMinutes) {
    m_nDurationMinutes = nMinutes;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetEndAfterOccurrences Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetEndAfterOccurrences Method

This member function is used to set the "End After occurrences" recurrence pattern option.

virtual void SetEndAfterOccurrences(
    int nOccurrences
);
Parameters

nOccurrences
An int that contains the occurrence count for the pattern end.

See Also

GetEndAfterOccurrences, GetPatternEndDate, IsNoEndDate

Body Source
void CXTPCalendarRecurrencePattern::SetEndAfterOccurrences(int nOccurrences) {
    m_PatternEnd.m_nEndAfterOccurrences = nOccurrences;
    m_PatternEnd.m_nUseEnd = xtpCalendarPatternEndAfterOccurrences;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetException Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetException Method

This member function is used to add an exception to the master event.

virtual BOOL SetException(
    CXTPCalendarEvent* pException,
    CXTPCalendarEvent* pMasterEventToUpdate = NULL
);
Parameters

pException
A pointer to a CXTPCalendarEvent object which represents the exception.
pMasterEventToUpdate
A pointer to a CXTPCalendarEvent object that is updated with the exception.

Returns

A BOOL. TRUE if the update is successful. FALSE otherwise.

See Also

CXTPCalendarEvent, CXTPCalendarEvent

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetMasterEventID Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetMasterEventID Method

This member function is used to set the master event ID value.

virtual void SetMasterEventID(
    DWORD dwEventID
);
Parameters

dwEventID
A DWORD that contains the new master event ID value.

See Also

GetMasterEventID().

Body Source
void CXTPCalendarRecurrencePattern::SetMasterEventID(DWORD dwEventID) {
    m_dwMasterEventID = dwEventID;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetNoEndDate Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetNoEndDate Method

This member function is used to reset the pattern end date.

virtual void SetNoEndDate();
See Also

IsNoEndDate(), GetEndAfterOccurrences(), GetPatternEndDate()

Body Source
void CXTPCalendarRecurrencePattern::SetNoEndDate() {
    m_PatternEnd.m_nUseEnd = xtpCalendarPatternEndNoDate;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetOccReminder Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetOccReminder Method

This member function is used to setup an occurrence with new Reminder settings.

void SetOccReminder(
    CXTPCalendarEvent* pOccEvent,
    int nbIsReminder = xtpCalendarRmdPrm_DontChange,
    DATE dtNextReminderTime_Snoozed = xtpCalendarRmdPrm_DontChange
);
Parameters

pOccEvent
A CXTPCalendarEvent pointer that points to the occurrence event which is to be modified.
nbIsReminder
Trigger value showing whether to change enabled reminder flag for this occurrence or not.
dtNextReminderTime_Snoozed
Reminder snooze time.

See Also

GetOccReminders(), XTPEnumCalendarReminderForoccurrenceParameters overview

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetPatternEnd Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetPatternEnd Method

Call this method to set the end pattern value.

virtual void SetPatternEnd(
    const XTP_CALENDAR_PATTERN_END& patternEnd
);
Parameters

patternEnd
A reference to the source pattern end structure.

See Also

GetPatternEnd()

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetPatternEndDate Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetPatternEndDate Method

This member function is used to set the new end pattern date.

virtual void SetPatternEndDate(
    COleDateTime dtEnd
);
Parameters

dtEnd
A COleDateTime object that contains the new date value.

See Also

COleDateTime GetPatternEndDate()

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetPatternID Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetPatternID Method

This member function is used to assign an ID to a pattern.

void SetPatternID(
    DWORD dwID
);
Parameters

dwID
Identifier to set.

See Also

GetPatternID()

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetPatternStartDate Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetPatternStartDate Method

This member function is used to set the new start pattern date and time.

virtual void SetPatternStartDate(
    COleDateTime dtStart
);
Parameters

dtStart
A COleDateTime object that contains the new date value.

See Also

GetPatternStartTime()

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetRecurrenceOptions Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetRecurrenceOptions Method

This member function is used to set the recurrence options.

virtual void SetRecurrenceOptions(
    const XTP_CALENDAR_RECURRENCE_OPTIONS& Options
);
Parameters

Options
Reference to a XTP_CALENDAR_RECURRENCE_OPTIONS struct.

See Also

XTP_CALENDAR_RECURRENCE_OPTIONS, SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS& Options)

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::SetStartTime Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::SetStartTime Method

This member function is used to set the new start date and time.

virtual void SetStartTime(
    COleDateTime dtStart
);
Parameters

dtStart
A COleDateTime object that contains the new start date value.

See Also

GetStartTime()

Body Source
void CXTPCalendarRecurrencePattern::SetStartTime(COleDateTime dtStart) {
    m_dtStartTime = dtStart;
}
Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern::Update Method

CXTPCalendarRecurrencePattern Methods, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::Update Method

This member function is used to update the pattern data from the given pattern.

virtual BOOL Update(
    CXTPCalendarRecurrencePattern* pNewData
);
Parameters

pNewData
A pointer to a CXTPCalendarRecurrencePattern object that contains the pattern to update.

Returns

A pointer to a CXTPCalendarRecurrencePattern object that contains the updated pattern.

See Also

CXTPCalendarRecurrencePattern.

Group

CXTPCalendarRecurrencePattern Methods


CXTPCalendarRecurrencePattern Constructors

CXTPCalendarRecurrencePattern Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern Constructors
Class

CXTPCalendarRecurrencePattern Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPCalendarRecurrencePattern | Protected pattern constructor.


CXTPCalendarRecurrencePattern::CXTPCalendarRecurrencePattern Constructor

CXTPCalendarRecurrencePattern Constructors, CXTPCalendarRecurrencePattern Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::CXTPCalendarRecurrencePattern Constructor

Protected pattern constructor.

CXTPCalendarRecurrencePattern(
    CXTPCalendarData* pDataProvider
);
Parameters

pDataProvider
Pointer to a CXTPCalendarData object.

See Also

~CXTPCalendarEvent()

Group

CXTPCalendarRecurrencePattern Constructors


CXTPCalendarRecurrencePattern Destructors

CXTPCalendarRecurrencePattern Class, Legend, Public Methods
CXTPCalendarRecurrencePattern Destructors
Class

CXTPCalendarRecurrencePattern Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarRecurrencePattern | Default class destructor.


CXTPCalendarRecurrencePattern::~CXTPCalendarRecurrencePattern Destructor

CXTPCalendarRecurrencePattern Destructors, CXTPCalendarRecurrencePattern Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRecurrencePattern::~CXTPCalendarRecurrencePattern Destructor

Default class destructor.

virtual ~CXTPCalendarRecurrencePattern();
Remarks

Handles member items deallocation. Decreases reference of stored objects: CXTPCalendarEventLabels and CXTPCalendarRecurrencePattern.

Group

CXTPCalendarRecurrencePattern Destructors


CXTPCalendarReminder Class

XTPCalendarRemindersManager.h, Classes, Legend, Members, Topics, CXTPCalendarReminder Structures, CXTPCalendarReminder Enumerations, CXTPCalendarReminder Data Members, CXTPCalendarReminder Methods, CXTPCalendarReminder Constructors, CXTPCalendarReminder Destructors, CXTPCalendarReminder Constructors, CXTPCalendarReminder Data Members, CXTPCalendarReminder Destructors, CXTPCalendarReminder Enumerations, CXTPCalendarReminder Methods, CXTPCalendarReminder Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder Class

This class describes a reminder for calendar event and implements base properties and operations on reminder.

Class Hierarchy

class CXTPCalendarReminder;
File

XTPCalendarRemindersManager.h

Group

Classes

Legend
Structure
Enumeration
Data Member
protected
Method
virtual
CXTPCalendarReminder Constructors
CXTPCalendarReminder Constructors | Description
CXTPCalendarReminder | Default object constructor.
CXTPCalendarReminder Data Members
CXTPCalendarReminder Data Members | Description
m_dtEventStartTime | Store related event start time.
m_dtNextReminderTime | Store reminder activation date and time.
m_eEventType | Define related event type: recurrence or non-recurrence.
m_nMinutesBeforeStart | Store minutes before start event to activate reminder.
m_pEventDataProvider | Store related event data provider.
CXTPCalendarReminder Destructors
CXTPCalendarReminder Destructors | Description
~CXTPCalendarReminder | Default class destructor.
CXTPCalendarReminder Enumerations
CXTPCalendarReminder Enumerations | Description
EventType | This enum define the event type: recurrence or non-recurrence.
CXTPCalendarReminder Methods
CXTPCalendarReminder Methods | Description
Dismiss | Call this member function to Dismiss active reminder.
GetEvent | Retrieve calendar event for which this reminder is related.
GetMinutesBeforeStart | Call this member function to determine the number of minutes before the start of an event.
GetNextReminderTime | Call this member function to retrieve date and time when reminder is scheduled to be activated.
IsEqualID | Call this member function to determine are reminders objects have equal IDs (or are they represent the same reminder).
SetEvent | Set calendar event for which this reminder is related.
Snooze | Call this member function to Snooze active reminder.
CXTPCalendarReminder Structures
CXTPCalendarReminder Structures | Description
RecurrenceEventInfo | This structure contains data members to unambiguously define related recurrence event occurrence.


CXTPCalendarReminder Structures

CXTPCalendarReminder Class, Legend, Structures
CXTPCalendarReminder Structures
Class

CXTPCalendarReminder Class

Legend
Structure
Structures
Structure | Description
RecurrenceEventInfo | This structure contains data members to unambiguously define related recurrence event occurrence.


CXTPCalendarReminder::RecurrenceEventInfo Structure

XTPCalendarRemindersManager.h, CXTPCalendarReminder Structures, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::RecurrenceEventInfo Structure

This structure contains data members to unambiguously define related recurrence event occurrence.

struct RecurrenceEventInfo {
  DWORD m_dwMasterEventID;
  DATE m_dtOccurrenceStartTime;
  DATE m_dtOccurrenceEndTime;
};
File

XTPCalendarRemindersManager.h

Members

m_dwMasterEventID
Recurrence master event ID.
m_dtOccurrenceStartTime
Recurrence occurrence start time or recurrence exception original start time.
m_dtOccurrenceEndTime
Recurrence occurrence end time or recurrence exception original end time.

See Also

EventType

Group

CXTPCalendarReminder Structures


CXTPCalendarReminder Enumerations

Enumerations, CXTPCalendarReminder Class, Legend
CXTPCalendarReminder Enumerations
Enumerations
Enumeration | Description
EventType | This enum define the event type: recurrence or non-recurrence.
Class

CXTPCalendarReminder Class

Legend
Enumeration


CXTPCalendarReminder::EventType Enumeration

XTPCalendarRemindersManager.h, CXTPCalendarReminder Enumerations
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::EventType Enumeration

This enum define the event type: recurrence or non-recurrence.

enum EventType {
  evtNormal = 1,
  evtRecurrence = 2
};
File

XTPCalendarRemindersManager.h

Members

evtNormal
event type is recurrence.
evtRecurrence
event type is non-recurrence.

Group

CXTPCalendarReminder Enumerations


CXTPCalendarReminder Data Members

CXTPCalendarReminder Class, Legend, Protected Data Members
CXTPCalendarReminder Data Members
Class

CXTPCalendarReminder Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dtEventStartTime | Store related event start time.
m_dtNextReminderTime | Store reminder activation date and time.
m_eEventType | Define related event type: recurrence or non-recurrence.
m_nMinutesBeforeStart | Store minutes before start event to activate reminder.
m_pEventDataProvider | Store related event data provider.


CXTPCalendarReminder::m_dtEventStartTime Data Member

CXTPCalendarReminder Data Members, CXTPCalendarReminder Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::m_dtEventStartTime Data Member

Store related event start time.

COleDateTime m_dtEventStartTime;
Group

CXTPCalendarReminder Data Members


CXTPCalendarReminder::m_dtNextReminderTime Data Member

CXTPCalendarReminder Data Members, CXTPCalendarReminder Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::m_dtNextReminderTime Data Member

Store reminder activation date and time.

COleDateTime m_dtNextReminderTime;
Group

CXTPCalendarReminder Data Members


CXTPCalendarReminder::m_eEventType Data Member

CXTPCalendarReminder Data Members, CXTPCalendarReminder Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::m_eEventType Data Member

Define related event type: recurrence or non-recurrence.

EventType m_eEventType;
Group

CXTPCalendarReminder Data Members


CXTPCalendarReminder::m_nMinutesBeforeStart Data Member

CXTPCalendarReminder Data Members, CXTPCalendarReminder Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::m_nMinutesBeforeStart Data Member

Store minutes before start event to activate reminder.

int m_nMinutesBeforeStart;
Group

CXTPCalendarReminder Data Members


CXTPCalendarReminder::m_pEventDataProvider Data Member

CXTPCalendarReminder Data Members, CXTPCalendarReminder Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::m_pEventDataProvider Data Member

Store related event data provider.

CXTPCalendarData* m_pEventDataProvider;
Group

CXTPCalendarReminder Data Members


CXTPCalendarReminder Methods

CXTPCalendarReminder Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder Methods
Class

CXTPCalendarReminder Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
SetEvent | Set calendar event for which this reminder is related.
Public Methods
Public Methods
Public Method | Description
Dismiss | Call this member function to Dismiss active reminder.
GetEvent | Retrieve calendar event for which this reminder is related.
GetMinutesBeforeStart | Call this member function to determine the number of minutes before the start of an event.
GetNextReminderTime | Call this member function to retrieve date and time when reminder is scheduled to be activated.
IsEqualID | Call this member function to determine are reminders objects have equal IDs (or are they represent the same reminder).
Snooze | Call this member function to Snooze active reminder.


CXTPCalendarReminder::Dismiss Method

CXTPCalendarReminder Methods, CXTPCalendarReminder Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::Dismiss Method

Call this member function to Dismiss active reminder.

virtual BOOL Dismiss();
Returns

TRUE if operation is successful, FALSE otherwise.

Remarks

Reminder flag for corresponding event object is set to FALSE.

See Also

Snooze, GetEvent, CXTPCalendarRemindersManager::Dismiss

Body Source
BOOL CXTPCalendarReminder::Dismiss() {
    ASSERT(m_pOwnerMan);
    return m_pOwnerMan ? m_pOwnerMan->Dismiss(this) : FALSE;
}
Group

CXTPCalendarReminder Methods


CXTPCalendarReminder::GetEvent Method

CXTPCalendarReminder Methods, CXTPCalendarReminder Class
CXTPCalendarReminder::GetEvent Method

Retrieve calendar event for which this reminder is related.

virtual CXTPCalendarEventPtr GetEvent();
Returns

A pointer to calendar event object.

Group

CXTPCalendarReminder Methods


CXTPCalendarReminder::GetMinutesBeforeStart Method

CXTPCalendarReminder Methods, CXTPCalendarReminder Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::GetMinutesBeforeStart Method

Call this member function to determine the number of minutes before the start of an event.

virtual int GetMinutesBeforeStart();
Returns

An int that contains the number of Minutes before the start of an event.

See Also

CXTPCalendarEvent::GetReminderMinutesBeforeStart, GetEvent.

Body Source
int  CXTPCalendarReminder::GetMinutesBeforeStart() {
    return m_nMinutesBeforeStart;
}
Group

CXTPCalendarReminder Methods


CXTPCalendarReminder::GetNextReminderTime Method

CXTPCalendarReminder Methods, CXTPCalendarReminder Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::GetNextReminderTime Method

Call this member function to retrieve date and time when reminder is scheduled to be activated.

virtual COleDateTime GetNextReminderTime();
Returns

Reminder activation date and time.

Remarks

This value for non snoozed event is: EventStartTime - MinutesBeforeStart. For snoozed event this value is set when Snooze() method is called.

See Also

GetMinutesBeforeStart, Snooze, GetEvent.

Body Source
COleDateTime CXTPCalendarReminder::GetNextReminderTime() {
    return m_dtNextReminderTime;
}
Group

CXTPCalendarReminder Methods


CXTPCalendarReminder::IsEqualID Method

CXTPCalendarReminder Methods, CXTPCalendarReminder Class
CXTPCalendarReminder::IsEqualID Method

Call this member function to determine are reminders objects have equal IDs (or are they represent the same reminder).

virtual BOOL IsEqualID(
    const CXTPCalendarReminder* pReminder2
) const;
Parameters

pReminder2
A pointer to reminder object to compare.

Returns

TRUE if reminders objects have equal IDs, FALSE otherwise.

Group

CXTPCalendarReminder Methods


CXTPCalendarReminder::SetEvent Method

CXTPCalendarReminder Methods, CXTPCalendarReminder Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::SetEvent Method

Set calendar event for which this reminder is related.

virtual void SetEvent(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
A pointer to calendar event.

See Also

GetEvent

Group

CXTPCalendarReminder Methods


CXTPCalendarReminder::Snooze Method

CXTPCalendarReminder Methods, CXTPCalendarReminder Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::Snooze Method

Call this member function to Snooze active reminder.

virtual BOOL Snooze(
    int nMinutesAfterNow
);
Parameters

nMinutesAfterNow
A value in minutes to activate reminder again.

Returns

TRUE if operation is successful, FALSE otherwise.

See Also

Dismiss, GetNextReminderTime, GetEvent, CXTPCalendarRemindersManager::Snooze

Body Source
BOOL CXTPCalendarReminder::Snooze(int nMinutesAfterNow) {
    ASSERT(m_pOwnerMan);
    return m_pOwnerMan ? m_pOwnerMan->Snooze(this, nMinutesAfterNow) : FALSE;
}
Group

CXTPCalendarReminder Methods


CXTPCalendarReminder Constructors

CXTPCalendarReminder Class, Legend, Public Methods
CXTPCalendarReminder Constructors
Class

CXTPCalendarReminder Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarReminder | Default object constructor.


CXTPCalendarReminder::CXTPCalendarReminder Constructor

CXTPCalendarReminder Constructors, CXTPCalendarReminder Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::CXTPCalendarReminder Constructor

Default object constructor.

CXTPCalendarReminder(
    CXTPCalendarRemindersManager* pOwnerMan = NULL
);
Parameters

pOwnerMan
A pointer to the reminders manager which own this object.

See Also

~CXTPCalendarReminder()

Group

CXTPCalendarReminder Constructors


CXTPCalendarReminder Destructors

CXTPCalendarReminder Class, Legend, Public Methods
CXTPCalendarReminder Destructors
Class

CXTPCalendarReminder Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarReminder | Default class destructor.


CXTPCalendarReminder::~CXTPCalendarReminder Destructor

CXTPCalendarReminder Destructors, CXTPCalendarReminder Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminder::~CXTPCalendarReminder Destructor

Default class destructor.

virtual ~CXTPCalendarReminder();
Remarks

Handles member items deallocation.

See Also

CXTPCalendarReminder()

Group

CXTPCalendarReminder Destructors


CXTPCalendarReminderForOccurrence Class

XTPCalendarRecurrencePattern.h, Classes, Legend, Members, Topics, CXTPCalendarReminderForOccurrence Data Members, CXTPCalendarReminderForOccurrence Constructors, CXTPCalendarReminderForOccurrence Destructors, CXTPCalendarReminderForOccurrence Operators, CXTPCalendarReminderForOccurrence Constructors, CXTPCalendarReminderForOccurrence Data Members, CXTPCalendarReminderForOccurrence Destructors, CXTPCalendarReminderForOccurrence Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence Class

This structure describes a reminder for an occurrence of a recurrence event.

Class Hierarchy

class CXTPCalendarReminderForOccurrence;
File

XTPCalendarRecurrencePattern.h

Group

Classes

Legend
Data Member
Constructor
virtual
Operator
CXTPCalendarReminderForOccurrence Constructors
CXTPCalendarReminderForOccurrence Constructors | Description
CXTPCalendarReminderForOccurrence | Default object constructor.
CXTPCalendarReminderForOccurrence Data Members
CXTPCalendarReminderForOccurrence Data Members | Description
m_dtNextReminderTime_Snoozed | Date/time of the next reminder event.
m_dtOccurrenceEndTime | End time of the described occurrence.
m_dtOccurrenceStartTime | Start time of the described occurrence.
m_nbIsReminder | XTPEnumCalendarReminderForOccurrenceParameters
CXTPCalendarReminderForOccurrence Destructors
CXTPCalendarReminderForOccurrence Destructors | Description
~CXTPCalendarReminderForOccurrence | Default class destructor.
CXTPCalendarReminderForOccurrence Operators
CXTPCalendarReminderForOccurrence Operators | Description
= | Copy operator.


CXTPCalendarReminderForOccurrence Data Members

CXTPCalendarReminderForOccurrence Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence Data Members
Class

CXTPCalendarReminderForOccurrence Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_dtNextReminderTime_Snoozed | Date/time of the next reminder event.
m_dtOccurrenceEndTime | End time of the described occurrence.
m_dtOccurrenceStartTime | Start time of the described occurrence.
m_nbIsReminder | XTPEnumCalendarReminderForOccurrenceParameters


CXTPCalendarReminderForOccurrence::m_dtNextReminderTime_Snoozed Data Member

CXTPCalendarReminderForOccurrence Data Members, CXTPCalendarReminderForOccurrence Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence::m_dtNextReminderTime_Snoozed Data Member

Date/time of the next reminder event.

DATE m_dtNextReminderTime_Snoozed;
Group

CXTPCalendarReminderForOccurrence Data Members


CXTPCalendarReminderForOccurrence::m_dtOccurrenceEndTime Data Member

CXTPCalendarReminderForOccurrence Data Members, CXTPCalendarReminderForOccurrence Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence::m_dtOccurrenceEndTime Data Member

End time of the described occurrence.

DATE m_dtOccurrenceEndTime;
Group

CXTPCalendarReminderForOccurrence Data Members


CXTPCalendarReminderForOccurrence::m_dtOccurrenceStartTime Data Member

CXTPCalendarReminderForOccurrence Data Members, CXTPCalendarReminderForOccurrence Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence::m_dtOccurrenceStartTime Data Member

Start time of the described occurrence.

DATE m_dtOccurrenceStartTime;
Group

CXTPCalendarReminderForOccurrence Data Members


CXTPCalendarReminderForOccurrence::m_nbIsReminder Data Member

CXTPCalendarReminderForOccurrence Data Members, CXTPCalendarReminderForOccurrence Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence::m_nbIsReminder Data Member

XTPEnumCalendarReminderForOccurrenceParameters

int m_nbIsReminder;
Group

CXTPCalendarReminderForOccurrence Data Members


CXTPCalendarReminderForOccurrence Constructors

CXTPCalendarReminderForOccurrence Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence Constructors
Class

CXTPCalendarReminderForOccurrence Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarReminderForOccurrence | Default object constructor.


CXTPCalendarReminderForOccurrence::CXTPCalendarReminderForOccurrence Constructor

CXTPCalendarReminderForOccurrence Constructors, CXTPCalendarReminderForOccurrence Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence::CXTPCalendarReminderForOccurrence Constructor

Default object constructor.

CXTPCalendarReminderForOccurrence();
See Also

~CXTPCalendarReminderForOccurrence()

Group

CXTPCalendarReminderForOccurrence Constructors


CXTPCalendarReminderForOccurrence Destructors

CXTPCalendarReminderForOccurrence Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence Destructors
Class

CXTPCalendarReminderForOccurrence Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarReminderForOccurrence | Default class destructor.


CXTPCalendarReminderForOccurrence::~CXTPCalendarReminderForOccurrence Destructor

CXTPCalendarReminderForOccurrence Destructors, CXTPCalendarReminderForOccurrence Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence::~CXTPCalendarReminderForOccurrence Destructor

Default class destructor.

virtual ~CXTPCalendarReminderForOccurrence();
Remarks

Handles member items deallocation.

Group

CXTPCalendarReminderForOccurrence Destructors


CXTPCalendarReminderForOccurrence Operators

CXTPCalendarReminderForOccurrence Class, Legend, Public Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence Operators
Class

CXTPCalendarReminderForOccurrence Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Copy operator.


CXTPCalendarReminderForOccurrence::= Operator

CXTPCalendarReminderForOccurrence Operators, CXTPCalendarReminderForOccurrence Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrence::= Operator

Copy operator.

const CXTPCalendarReminderForOccurrence& operator =(
    const CXTPCalendarReminderForOccurrence& rSrc
);
Parameters

rSrc
Pointer to a source data object.

Returns

A Constant reference to updated object

See Also

CXTPCalendarReminderForOccurrence

Group

CXTPCalendarReminderForOccurrence Operators


CXTPCalendarReminderForOccurrenceArray Class

XTPCalendarRecurrencePattern.h, Classes, Legend, Members, Topics, CXTPCalendarReminderForOccurrenceArray Methods, CXTPCalendarReminderForOccurrenceArray Constructors, CXTPCalendarReminderForOccurrenceArray Destructors, CXTPCalendarReminderForOccurrenceArray Constructors, CXTPCalendarReminderForOccurrenceArray Destructors, CXTPCalendarReminderForOccurrenceArray Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray Class

This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it.

Class Hierarchy

class CXTPCalendarReminderForOccurrenceArray : public CArray<CXTPCalendarReminderForOccurrence, const CXTPCalendarReminderForOccurrence&>;
File

XTPCalendarRecurrencePattern.h

Group

Classes

Legend
Method
virtual
CXTPCalendarReminderForOccurrenceArray Constructors
CXTPCalendarReminderForOccurrenceArray Constructors | Description
CXTPCalendarReminderForOccurrenceArray | Default collection constructor.
CXTPCalendarReminderForOccurrenceArray Destructors
CXTPCalendarReminderForOccurrenceArray Destructors | Description
~CXTPCalendarReminderForOccurrenceArray | Default collection destructor.
CXTPCalendarReminderForOccurrenceArray Methods
CXTPCalendarReminderForOccurrenceArray Methods | Description
ClearProperties | An utility method which clears all occurrences custom properties which was previously set by Save method.
Find |
Load | Loads an array of occurrences information from Calendar Custom Properties object.
Save | Saves an array of occurrences information to the Calendar Custom Properties object.
UpdateOccIfNeed | Updates occurrence custom properties with the values from the array if necessary one is found there.
UpdateOccIfNeedEx | Updates occurrence custom properties with the values from the provided CXTPCalendarReminderForOccurrence structure.


CXTPCalendarReminderForOccurrenceArray Methods

CXTPCalendarReminderForOccurrenceArray Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray Methods
Class

CXTPCalendarReminderForOccurrenceArray Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
ClearProperties | An utility method which clears all occurrences custom properties which was previously set by Save method.
Find |
Load | Loads an array of occurrences information from Calendar Custom Properties object.
Save | Saves an array of occurrences information to the Calendar Custom Properties object.
UpdateOccIfNeed | Updates occurrence custom properties with the values from the array if necessary one is found there.
UpdateOccIfNeedEx | Updates occurrence custom properties with the values from the provided CXTPCalendarReminderForOccurrence structure.


CXTPCalendarReminderForOccurrenceArray::ClearProperties Method

CXTPCalendarReminderForOccurrenceArray Methods, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::ClearProperties Method

An utility method which clears all occurrences custom properties which was previously set by Save method.

static void ClearProperties(
    CXTPCalendarCustomProperties* pProps
);
Parameters

pProps
Pointer to CXTPCalendarCustomProperties object to be cleared.

See Also

Save(), Load()

Group

CXTPCalendarReminderForOccurrenceArray Methods


Find Method

CXTPCalendarReminderForOccurrenceArray Methods
Find Method
Overload List
Methods
Method | Description
CXTPCalendarReminderForOccurrenceArray::Find (CXTPCalendarEvent*) | Finds an index of the occurrence event.
CXTPCalendarReminderForOccurrenceArray::Find (DATE, DATE) | Finds an index of the occurrence event by its start and end time.
Group

CXTPCalendarReminderForOccurrenceArray Methods


CXTPCalendarReminderForOccurrenceArray::Find Method (CXTPCalendarEvent*)

Find Method, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::Find Method (CXTPCalendarEvent*)

Finds an index of the occurrence event.

int Find(
    CXTPCalendarEvent* pOccEvent
);
Parameters

pOccEvent
Pointer to the occurrence event object.

Returns

An index of the occurrence event object in the array if found; or -1 if not found.

See Also

Find()

Group

Find Method


CXTPCalendarReminderForOccurrenceArray::Find Method (DATE, DATE)

Find Method, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::Find Method (DATE, DATE)

Finds an index of the occurrence event by its start and end time.

int Find(
    DATE dtOccStartTime,
    DATE dtOccEndTime
);
Parameters

dtOccStartTime
Occurrence start time.
dtOccEndTime
Occurrence end time.

Returns

An index of the occurrence event object in the array if found; or -1 if not found.

See Also

Find()

Group

Find Method


CXTPCalendarReminderForOccurrenceArray::Load Method

CXTPCalendarReminderForOccurrenceArray Methods, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::Load Method

Loads an array of occurrences information from Calendar Custom Properties object.

BOOL Load(
    CXTPCalendarCustomProperties* pProps
);
Parameters

pProps
Pointer to a source CXTPCalendarCustomProperties object.

Returns

TRUE when loaded successfully; FALSE otherwise.

See Also

Save()

Group

CXTPCalendarReminderForOccurrenceArray Methods


CXTPCalendarReminderForOccurrenceArray::Save Method

CXTPCalendarReminderForOccurrenceArray Methods, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::Save Method

Saves an array of occurrences information to the Calendar Custom Properties object.

BOOL Save(
    CXTPCalendarCustomProperties* pProps,
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pProps
Pointer to a destination CXTPCalendarCustomProperties object.
pPattern
Pointer to the parent Recurrence Pattern object for those occurrences.

Returns

TRUE when saved successfully; FALSE otherwise.

See Also

Load()

Group

CXTPCalendarReminderForOccurrenceArray Methods


CXTPCalendarReminderForOccurrenceArray::UpdateOccIfNeed Method

CXTPCalendarReminderForOccurrenceArray Methods, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::UpdateOccIfNeed Method

Updates occurrence custom properties with the values from the array if necessary one is found there.

int UpdateOccIfNeed(
    CXTPCalendarEvent* pOccEvent,
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pOccEvent
Pointer to the occurrence event object.
pPattern
Pointer to the parent Recurrence Pattern object for those occurrences.

Returns

Non-zero if updated successfully; zero if update failed.

See Also

UpdateOccIfNeedEx

Group

CXTPCalendarReminderForOccurrenceArray Methods


CXTPCalendarReminderForOccurrenceArray::UpdateOccIfNeedEx Method

CXTPCalendarReminderForOccurrenceArray Methods, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::UpdateOccIfNeedEx Method

Updates occurrence custom properties with the values from the provided CXTPCalendarReminderForOccurrence structure.

static int UpdateOccIfNeedEx(
    CXTPCalendarEvent* pOccEvent,
    const CXTPCalendarReminderForOccurrence* pOccRmdData,
    CXTPCalendarRecurrencePattern* pPattern
);
Parameters

pOccEvent
Pointer to the occurrence event object.
pOccRmdData
Pointer to the Reminder data for the occurrence.
pPattern
Pointer to the parent Recurrence Pattern object for those occurrences.

Returns

Non-zero if updated successfully; zero if update failed.

See Also

CXTPCalendarReminderForOccurrence overview, UpdateOccIfNeed

Group

CXTPCalendarReminderForOccurrenceArray Methods


CXTPCalendarReminderForOccurrenceArray Constructors

CXTPCalendarReminderForOccurrenceArray Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray Constructors
Class

CXTPCalendarReminderForOccurrenceArray Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarReminderForOccurrenceArray | Default collection constructor.


CXTPCalendarReminderForOccurrenceArray::CXTPCalendarReminderForOccurrenceArray Constructor

CXTPCalendarReminderForOccurrenceArray Constructors, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::CXTPCalendarReminderForOccurrenceArray Constructor

Default collection constructor.

CXTPCalendarReminderForOccurrenceArray();
See Also

~CXTPCalendarReminderForOccurrenceArray()

Group

CXTPCalendarReminderForOccurrenceArray Constructors


CXTPCalendarReminderForOccurrenceArray Destructors

CXTPCalendarReminderForOccurrenceArray Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray Destructors
Class

CXTPCalendarReminderForOccurrenceArray Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarReminderForOccurrenceArray | Default collection destructor.


CXTPCalendarReminderForOccurrenceArray::~CXTPCalendarReminderForOccurrenceArray Destructor

CXTPCalendarReminderForOccurrenceArray Destructors, CXTPCalendarReminderForOccurrenceArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminderForOccurrenceArray::~CXTPCalendarReminderForOccurrenceArray Destructor

Default collection destructor.

virtual ~CXTPCalendarReminderForOccurrenceArray();
Remarks

Handles member item deallocation. Decreases reference of all stored CXTPCalendarReminderForOccurrence objects.

See Also

RemoveAll()

Group

CXTPCalendarReminderForOccurrenceArray Destructors


CXTPCalendarReminders Class

XTPCalendarRemindersManager.h, Classes, Legend, Members, Topics, CXTPCalendarReminders Methods, CXTPCalendarReminders Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminders Class

This class represents a simple array collection of CXTPCalendarReminder objects.

Class Hierarchy

class CXTPCalendarReminders : public CXTPCalendarPtrCollectionT<CXTPCalendarReminder>;
File

XTPCalendarRemindersManager.h

Group

Classes

Legend
Method
protected
virtual
CXTPCalendarReminders Methods
CXTPCalendarReminders Methods | Description
_RemoveDataForMasterEvent | Try to find and remove reminder(s) object(s) which are related to the recurrence master event specified.
Find |
RemoveDataForEvent | Try to find and remove reminder object which is related to the event specified.
Sort | Sort reminders by the event start time field.


CXTPCalendarReminders Methods

CXTPCalendarReminders Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarReminders Methods
Class

CXTPCalendarReminders Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_RemoveDataForMasterEvent | Try to find and remove reminder(s) object(s) which are related to the recurrence master event specified.
Public Methods
Public Methods
Public Method | Description
Find |
RemoveDataForEvent | Try to find and remove reminder object which is related to the event specified.
Sort | Sort reminders by the event start time field.


CXTPCalendarReminders::_RemoveDataForMasterEvent Method

CXTPCalendarReminders Methods, CXTPCalendarReminders Class
CXTPCalendarReminders::_RemoveDataForMasterEvent Method

Try to find and remove reminder(s) object(s) which are related to the recurrence master event specified.

virtual BOOL _RemoveDataForMasterEvent(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
A pointer to master event.

Returns

TRUE if the related reminder(s) object(s) was removed from the collection, FALSE otherwise.

Group

CXTPCalendarReminders Methods


Find Method

CXTPCalendarReminders Methods
Find Method
Overload List
Methods
Method | Description
CXTPCalendarReminders::Find (CXTPCalendarEvent*) | Finds a reminder object in the collection which is related to the event specified.
CXTPCalendarReminders::Find (DWORD, CXTPCalendarData*) | Finds a reminder object in the collection which is related to the specified event ID.
CXTPCalendarReminders::Find (const CXTPCalendarReminder*) | Finds a specified reminder object in the collection.
Group

CXTPCalendarReminders Methods


CXTPCalendarReminders::Find Method (CXTPCalendarEvent*)

Find Method, CXTPCalendarReminders Class, See Also
CXTPCalendarReminders::Find Method (CXTPCalendarEvent*)

Finds a reminder object in the collection which is related to the event specified.

virtual int Find(
    CXTPCalendarEvent* pEvent
) const;
Parameters

pEvent
A pointer to event.

Returns

Index of the related reminder object in the collection or -1 if such object is not present.

See Also

Find@CXTPCalendarReminder

Group

Find Method


CXTPCalendarReminders::Find Method (DWORD, CXTPCalendarData*)

Find Method, CXTPCalendarReminders Class, See Also
CXTPCalendarReminders::Find Method (DWORD, CXTPCalendarData*)

Finds a reminder object in the collection which is related to the specified event ID.

virtual int Find(
    DWORD dwEventID,
    CXTPCalendarData* pDP = NULL
) const;
Parameters

dwEventID
Event ID of normal event or Master event.
pDP
A pointer to event data provider.

Returns

Index of the related reminder object in the collection or -1 if such object is not present.

See Also

Find@CXTPCalendarReminder, Find@CXTPCalendarEvent

Group

Find Method


CXTPCalendarReminders::Find Method (const CXTPCalendarReminder*)

Find Method, CXTPCalendarReminders Class, See Also
CXTPCalendarReminders::Find Method (const CXTPCalendarReminder*)

Finds a specified reminder object in the collection.

virtual int Find(
    const CXTPCalendarReminder* pReminder
) const;
Parameters

pReminder
A pointer to reminder object to find.

Returns

Index of the equal reminder object in the collection or -1 if such object is not present.

Remarks

CXTPCalendarReminder::IsEqualID method is used to compare reminders.

See Also

Find@CXTPCalendarEvent

Group

Find Method


CXTPCalendarReminders::RemoveDataForEvent Method

CXTPCalendarReminders Methods, CXTPCalendarReminders Class
CXTPCalendarReminders::RemoveDataForEvent Method

Try to find and remove reminder object which is related to the event specified.

virtual BOOL RemoveDataForEvent(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
A pointer to event.

Returns

TRUE if the related reminder object is removed from the collection, FALSE otherwise.

Group

CXTPCalendarReminders Methods


CXTPCalendarReminders::Sort Method

CXTPCalendarReminders Methods, CXTPCalendarReminders Class
CXTPCalendarReminders::Sort Method

Sort reminders by the event start time field.

virtual void Sort();
Group

CXTPCalendarReminders Methods


CXTPCalendarRemindersManager Class

XTPCalendarRemindersManager.h, Classes, Legend, Members, Topics, CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Constructors, CXTPCalendarRemindersManager Destructors, CXTPCalendarRemindersManager Constructors, CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Destructors, CXTPCalendarRemindersManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager Class

This class is used to monitor and manage calendar events reminders. It will send notifications when active reminders list is changed - new reminder(s) come or some reminder(s) goes away.

Class Hierarchy

class CXTPCalendarRemindersManager : public CWnd;
File

XTPCalendarRemindersManager.h

Remarks

When Reminder manager starts it check all events which have Reminder flag set. Reminder for event is added to active reminders list when: Event->StartTime - Event->ReminderMinutesBeforeStart <= Now

There are 2 actions with reminder: Dismiss - reset Reminder flag for the event and remove reminder. Reminder never comes back;

Snooze - set new NextReminderTime value and remove reminder. Reminder will come back when NextReminderTime <= Now.

Some Reminder manager data stored in CalendarEvent custom properties (or RecurrencePattern custom properties) - this means if own events storage is used you have to save/load custom properties too.

StartMonitoring/StopMonitoring are used to start/stop reminders manager. These methods are called by the calendar control automatically when CXTPCalendarControl::EnableReminders() method is called.

GetActiveReminders is used to retrieve collection of active reminders.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarRemindersManager Constructors
CXTPCalendarRemindersManager Constructors | Description
CXTPCalendarRemindersManager | Default object constructor.
CXTPCalendarRemindersManager Data Members
CXTPCalendarRemindersManager Data Members | Description
m_arActiveReminders | Active reminders collection.
m_arWaitingReminders | Waiting reminders collection.
m_bMonitoringRunning | Flag indicate that reminders manager is started;
m_dtLastUpdateTime | Store last time when reminders data was loaded from the calendar resources.
m_pConnection | A pointer to the notification connection object.
m_pResourcesNf | A collection of calendar resources to be monitored.
m_spPeriod2Cache | Time period to cache data from the calendar resources.
CXTPCalendarRemindersManager Destructors
CXTPCalendarRemindersManager Destructors | Description
~CXTPCalendarRemindersManager | Default object destructor.
CXTPCalendarRemindersManager Methods
CXTPCalendarRemindersManager Methods | Description
Dismiss | Call this member function to Dismiss specified reminder.
DismissAll | Call this member function to Dismiss all active reminders.
GetActiveReminders | Call this method to retrieve active reminders collection.
GetActiveRemindersCount | Call this method to retrieve reminders count in the active reminders collection.
GetConnection | Obtain a pointer to the notification connection object.
IsMonitoringRunning | Call this method to determine is StartMonitoring was successfully called and reminders manager monitoring reminders.
NotifyReminders | This method is used to send XTP_NC_CALENDAR_ON_REMINDERS notification via connection object.
PostNotify_RemindersFire | Schedule to call NotifyReminders(xtpCalendarRemindersFire) in 500 ms.
RemoveAll | This method clear all reminders in reminders manager collections.
Snooze | Call this member function to Snooze specified reminder.
StartMonitoring | This method is used to attach to calendar resources (data provider) and start reminders monitoring.
StopMonitoring | This method is used to detach from calendar resources (data provider) and and clear all reminders in reminders manager.


CXTPCalendarRemindersManager Data Members

CXTPCalendarRemindersManager Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager Data Members
Class

CXTPCalendarRemindersManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arActiveReminders | Active reminders collection.
m_arWaitingReminders | Waiting reminders collection.
m_bMonitoringRunning | Flag indicate that reminders manager is started;
m_dtLastUpdateTime | Store last time when reminders data was loaded from the calendar resources.
m_pConnection | A pointer to the notification connection object.
m_pResourcesNf | A collection of calendar resources to be monitored.
m_spPeriod2Cache | Time period to cache data from the calendar resources.


CXTPCalendarRemindersManager::m_arActiveReminders Data Member

CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::m_arActiveReminders Data Member

Active reminders collection.

CXTPCalendarReminders m_arActiveReminders;
Group

CXTPCalendarRemindersManager Data Members


CXTPCalendarRemindersManager::m_arWaitingReminders Data Member

CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::m_arWaitingReminders Data Member

Waiting reminders collection.

CXTPCalendarReminders m_arWaitingReminders;
Group

CXTPCalendarRemindersManager Data Members


CXTPCalendarRemindersManager::m_bMonitoringRunning Data Member

CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::m_bMonitoringRunning Data Member

Flag indicate that reminders manager is started;

BOOL m_bMonitoringRunning;
Group

CXTPCalendarRemindersManager Data Members


CXTPCalendarRemindersManager::m_dtLastUpdateTime Data Member

CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::m_dtLastUpdateTime Data Member

Store last time when reminders data was loaded from the calendar resources.

COleDateTime m_dtLastUpdateTime;
Group

CXTPCalendarRemindersManager Data Members


CXTPCalendarRemindersManager::m_pConnection Data Member

CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::m_pConnection Data Member

A pointer to the notification connection object.

CXTPNotifyConnection* m_pConnection;
Group

CXTPCalendarRemindersManager Data Members


CXTPCalendarRemindersManager::m_pResourcesNf Data Member

CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::m_pResourcesNf Data Member

A collection of calendar resources to be monitored.

CXTPCalendarResourcesNf* m_pResourcesNf;
Group

CXTPCalendarRemindersManager Data Members


CXTPCalendarRemindersManager::m_spPeriod2Cache Data Member

CXTPCalendarRemindersManager Data Members, CXTPCalendarRemindersManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::m_spPeriod2Cache Data Member

Time period to cache data from the calendar resources.

COleDateTimeSpan m_spPeriod2Cache;
Group

CXTPCalendarRemindersManager Data Members


CXTPCalendarRemindersManager Methods

CXTPCalendarRemindersManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager Methods
Class

CXTPCalendarRemindersManager Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
NotifyReminders | This method is used to send XTP_NC_CALENDAR_ON_REMINDERS notification via connection object.
PostNotify_RemindersFire | Schedule to call NotifyReminders(xtpCalendarRemindersFire) in 500 ms.
RemoveAll | This method clear all reminders in reminders manager collections.
Public Methods
Public Methods
Public Method | Description
Dismiss | Call this member function to Dismiss specified reminder.
DismissAll | Call this member function to Dismiss all active reminders.
GetActiveReminders | Call this method to retrieve active reminders collection.
GetActiveRemindersCount | Call this method to retrieve reminders count in the active reminders collection.
GetConnection | Obtain a pointer to the notification connection object.
IsMonitoringRunning | Call this method to determine is StartMonitoring was successfully called and reminders manager monitoring reminders.
Snooze | Call this member function to Snooze specified reminder.
StartMonitoring | This method is used to attach to calendar resources (data provider) and start reminders monitoring.
StopMonitoring | This method is used to detach from calendar resources (data provider) and and clear all reminders in reminders manager.


CXTPCalendarRemindersManager::Dismiss Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::Dismiss Method

Call this member function to Dismiss specified reminder.

virtual BOOL Dismiss(
    CXTPCalendarReminder* pReminder
);
Parameters

pReminder
A pointer to reminder object

Returns

TRUE if operation is successful, FALSE otherwise.

Remarks

Reminder flag for corresponding event object is set to FALSE.

See Also

Snooze, CXTPCalendarReminder::Snooze, CXTPCalendarReminder::Dismiss

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::DismissAll Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::DismissAll Method

Call this member function to Dismiss all active reminders.

virtual BOOL DismissAll();
Returns

TRUE if operation is successful, FALSE otherwise.

Remarks

Reminder flag for each event object is set to FALSE.

See Also

Snooze, Dismiss, CXTPCalendarReminder::Snooze, CXTPCalendarReminder::Dismiss

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::GetActiveReminders Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::GetActiveReminders Method

Call this method to retrieve active reminders collection.

virtual void GetActiveReminders(
    CXTPCalendarReminders& rarActiveReminders
);
Parameters

rarActiveReminders
A reference to an array to retrieve active reminders.

See Also

GetActiveRemindersCount

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::GetActiveRemindersCount Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::GetActiveRemindersCount Method

Call this method to retrieve reminders count in the active reminders collection.

virtual int GetActiveRemindersCount();
Returns

Active reminders count.

Remarks

Can be useful to quick determine is active reminders collection empty without copy collection.

See Also

GetActiveReminders

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::GetConnection Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::GetConnection Method

Obtain a pointer to the notification connection object.

virtual CXTPNotifyConnection* GetConnection();
Returns

Connection object pointer.

Remarks

Used to subscribe (Advice) for notification events from the reminders manager.

See Also

CXTPNotifyConnection overview, IXTPNotificationSink overview

Body Source
CXTPNotifyConnection* CXTPCalendarRemindersManager::GetConnection() {
    return m_pConnection;
}
Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::IsMonitoringRunning Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::IsMonitoringRunning Method

Call this method to determine is StartMonitoring was successfully called and reminders manager monitoring reminders.

virtual BOOL IsMonitoringRunning() const;
Returns

TRUE if reminders manager active (started/running), FALSE otherwise.

See Also

StartMonitoring, StopMonitoring

Body Source
BOOL CXTPCalendarRemindersManager::IsMonitoringRunning() const {
    return m_bMonitoringRunning;
}
Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::NotifyReminders Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::NotifyReminders Method

This method is used to send XTP_NC_CALENDAR_ON_REMINDERS notification via connection object.

virtual void NotifyReminders(
    int eAction,
    LPARAM lParam = 0
);
Parameters

eAction
A reminders action. Value from enum XTPCalendarRemindersAction.
lParam
Reserved. Set to 0.

See Also

XTP_NC_CALENDAR_ON_REMINDERS, XTPCalendarRemindersAction.

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::PostNotify_RemindersFire Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::PostNotify_RemindersFire Method

Schedule to call NotifyReminders(xtpCalendarRemindersFire) in 500 ms.

virtual void PostNotify_RemindersFire();
See Also

NotifyReminders, XTP_NC_CALENDAR_ON_REMINDERS, XTPCalendarRemindersAction.

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::RemoveAll Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::RemoveAll Method

This method clear all reminders in reminders manager collections.

virtual void RemoveAll();
See Also

StopMonitoring

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::Snooze Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::Snooze Method

Call this member function to Snooze specified reminder.

virtual BOOL Snooze(
    CXTPCalendarReminder* pReminder,
    int nMinutesAfterNow
);
Parameters

pReminder
A pointer to reminder object
nMinutesAfterNow
A value in minutes to activate reminder again.

Returns

TRUE if operation is successful, FALSE otherwise.

See Also

Dismiss, CXTPCalendarReminder::Snooze, CXTPCalendarReminder::Dismiss, CXTPCalendarReminder::GetNextReminderTime

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::StartMonitoring Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::StartMonitoring Method

This method is used to attach to calendar resources (data provider) and start reminders monitoring.

virtual BOOL StartMonitoring(
    CXTPCalendarResources* pResources,
    COleDateTimeSpan spPeriod2Cache
);
Parameters

pResources
A pointer to calendar resources collection.
spPeriod2Cache
A time period for which reminder manager will read reminders from calendar resources (data provider).

Returns

TRUE if operation is successful, FALSE otherwise.

Remarks

To retrieve reminders CXTPCalendarData::GetUpcomingEvents() method is used. This can be a slow operation and using spPeriod2Cache parameter value we can control how often this method will be called.

For example calendar control use spPeriod2Cache = 2 hours by default. This means than GetUpcomingEvents will be called only once per 2 hours.

See Also

StopMonitoring

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager::StopMonitoring Method

CXTPCalendarRemindersManager Methods, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::StopMonitoring Method

This method is used to detach from calendar resources (data provider) and and clear all reminders in reminders manager.

virtual BOOL StopMonitoring();
Returns

TRUE if operation is successful, FALSE otherwise.

See Also

StartMonitoring

Group

CXTPCalendarRemindersManager Methods


CXTPCalendarRemindersManager Constructors

CXTPCalendarRemindersManager Class, Legend, Public Methods
CXTPCalendarRemindersManager Constructors
Class

CXTPCalendarRemindersManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarRemindersManager | Default object constructor.


CXTPCalendarRemindersManager::CXTPCalendarRemindersManager Constructor

CXTPCalendarRemindersManager Constructors, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::CXTPCalendarRemindersManager Constructor

Default object constructor.

CXTPCalendarRemindersManager();
See Also

~CXTPCalendarRemindersManager()

Group

CXTPCalendarRemindersManager Constructors


CXTPCalendarRemindersManager Destructors

CXTPCalendarRemindersManager Class, Legend, Public Methods
CXTPCalendarRemindersManager Destructors
Class

CXTPCalendarRemindersManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarRemindersManager | Default object destructor.


CXTPCalendarRemindersManager::~CXTPCalendarRemindersManager Destructor

CXTPCalendarRemindersManager Destructors, CXTPCalendarRemindersManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarRemindersManager::~CXTPCalendarRemindersManager Destructor

Default object destructor.

virtual ~CXTPCalendarRemindersManager();
See Also

CXTPCalendarRemindersManager()

Group

CXTPCalendarRemindersManager Destructors


CXTPCalendarResource Class

XTPCalendarResource.h, Classes, Legend, Members, Topics, CXTPCalendarResource Data Members, CXTPCalendarResource Methods, CXTPCalendarResource Constructors, CXTPCalendarResource Destructors, CXTPCalendarResource Constructors, CXTPCalendarResource Data Members, CXTPCalendarResource Destructors, CXTPCalendarResource Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource Class

Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of persons or resources.

Class Hierarchy

class CXTPCalendarResource;
File

XTPCalendarResource.h

Remarks

Each resource is to be drawn in the separate column on the calendar view. Each resource should have its own DataProvider. For example, events for peoples could be stored inside the Memory data provider (somebody's own or temporary events), and for other resources - inside a Database data provider (those events are not changed by the user). So, there is a possibility to use any combination of data providers in the same control.

See Also

CXTPCalendarControl, CXTPCalendarData

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarResource Constructors
CXTPCalendarResource Constructors | Description
CXTPCalendarResource | Default object constructor. Construct CXTPCalendarResource object.
CXTPCalendarResource Data Members
CXTPCalendarResource Data Members | Description
m_arScheduleIDs | which schedules are used for this resource.
m_bCloseDataProviderWhenDestroy | If TRUE - call Close() method if the data provider when control is destroyed.
m_pCalendarCtrl | Parent Calendar control
m_pDataProvider | Associated data provider
m_strResourceName | Text name of the resource
CXTPCalendarResource Destructors
CXTPCalendarResource Destructors | Description
~CXTPCalendarResource | Default class destructor.
CXTPCalendarResource Methods
CXTPCalendarResource Methods | Description
ExistsScheduleID | This member function determines whether a schedule with the specified ID exists or not.
FilterEventsByScheduleID | This member function used to remove events which are not from this resource.
GetDataProvider | This member function obtains a pointer to the current data provider instance.
GetName | This member function returns a string name of this resource object
GetSchedules | Call this member function to get the collection of all schedules ID's for this resource.
IsSchedulesSetEmpty | Call this member function to check whether schedules set in this resource is empty or not.
RetrieveDayEvents | Call this member function to get the collection of the day's events for this resource. All events from the applied schedules will be included.
SetDataProvider | This member function sets the custom data provider for the control.
SetName | This member function applies a new name to the resource object.


CXTPCalendarResource Data Members

CXTPCalendarResource Class, Legend, Protected Data Members
CXTPCalendarResource Data Members
Class

CXTPCalendarResource Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arScheduleIDs | which schedules are used for this resource.
m_bCloseDataProviderWhenDestroy | If TRUE - call Close() method if the data provider when control is destroyed.
m_pCalendarCtrl | Parent Calendar control
m_pDataProvider | Associated data provider
m_strResourceName | Text name of the resource


CXTPCalendarResource::m_arScheduleIDs Data Member

CXTPCalendarResource Data Members, CXTPCalendarResource Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::m_arScheduleIDs Data Member

which schedules are used for this resource.

CUIntArray m_arScheduleIDs;
Group

CXTPCalendarResource Data Members


CXTPCalendarResource::m_bCloseDataProviderWhenDestroy Data Member

CXTPCalendarResource Data Members, CXTPCalendarResource Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::m_bCloseDataProviderWhenDestroy Data Member

If TRUE - call Close() method if the data provider when control is destroyed.

BOOL m_bCloseDataProviderWhenDestroy;
Group

CXTPCalendarResource Data Members


CXTPCalendarResource::m_pCalendarCtrl Data Member

CXTPCalendarResource Data Members, CXTPCalendarResource Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::m_pCalendarCtrl Data Member

Parent Calendar control

CXTPCalendarControl* m_pCalendarCtrl;
Group

CXTPCalendarResource Data Members


CXTPCalendarResource::m_pDataProvider Data Member

CXTPCalendarResource Data Members, CXTPCalendarResource Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::m_pDataProvider Data Member

Associated data provider

CXTPCalendarData* m_pDataProvider;
Group

CXTPCalendarResource Data Members


CXTPCalendarResource::m_strResourceName Data Member

CXTPCalendarResource Data Members, CXTPCalendarResource Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::m_strResourceName Data Member

Text name of the resource

CString m_strResourceName;
Group

CXTPCalendarResource Data Members


CXTPCalendarResource Methods

CXTPCalendarResource Class, Legend, Public Methods
CXTPCalendarResource Methods
Class

CXTPCalendarResource Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
ExistsScheduleID | This member function determines whether a schedule with the specified ID exists or not.
FilterEventsByScheduleID | This member function used to remove events which are not from this resource.
GetDataProvider | This member function obtains a pointer to the current data provider instance.
GetName | This member function returns a string name of this resource object
GetSchedules | Call this member function to get the collection of all schedules ID's for this resource.
IsSchedulesSetEmpty | Call this member function to check whether schedules set in this resource is empty or not.
RetrieveDayEvents | Call this member function to get the collection of the day's events for this resource. All events from the applied schedules will be included.
SetDataProvider | This member function sets the custom data provider for the control.
SetName | This member function applies a new name to the resource object.


CXTPCalendarResource::ExistsScheduleID Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::ExistsScheduleID Method

This member function determines whether a schedule with the specified ID exists or not.

virtual BOOL ExistsScheduleID(
    UINT uScheduleID,
    BOOL bReturnTrueIfSchedulesSetEmpty = TRUE
);
Parameters

uScheduleID
A numeric ID of the schedule to check.
bReturnTrueIfSchedulesSetEmpty
TRUE by default. If there are no any schedules specified inside this resource, the Calendar will show (and process in other way) all events.

Returns

TRUE if a schedule ID exists in the Schedules collection for this resource; FALSE otherwise.

See Also

GetSchedules, IsSchedulesSetEmpty

Group

CXTPCalendarResource Methods


CXTPCalendarResource::FilterEventsByScheduleID Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::FilterEventsByScheduleID Method

This member function used to remove events which are not from this resource.

void FilterEventsByScheduleID(
    CXTPCalendarEvents* pEvents
);
Parameters

pEvents
An events collection to be filtered.

See Also

ExistsScheduleID

Group

CXTPCalendarResource Methods


CXTPCalendarResource::GetDataProvider Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::GetDataProvider Method

This member function obtains a pointer to the current data provider instance.

CXTPCalendarData* GetDataProvider();
Returns

A CXTPCalendarData pointer to the associated data provider object.

Remarks

Call this member function to obtain the data provider object currently used by this calendar control.

See Also

CXTPCalendarData overview, SetDataProvider

Body Source
CXTPCalendarData* CXTPCalendarResource::GetDataProvider() {
    ASSERT(this);
    return this ? m_pDataProvider : NULL;
}
Group

CXTPCalendarResource Methods


CXTPCalendarResource::GetName Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::GetName Method

This member function returns a string name of this resource object

virtual LPCTSTR GetName();
Returns

A string with the name of the resource object.

See Also

SetName

Body Source
LPCTSTR CXTPCalendarResource::GetName() {
    return m_strResourceName;
}
Group

CXTPCalendarResource Methods


CXTPCalendarResource::GetSchedules Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::GetSchedules Method

Call this member function to get the collection of all schedules ID's for this resource.

virtual CUIntArray* GetSchedules();
Returns

A pointer to CUIntArray collection which contains numeric ID's for all schedules existing in this resource.

See Also

CUIntArray overview, IsSchedulesSetEmpty, ExistsScheduleID

Body Source
CUIntArray* CXTPCalendarResource::GetSchedules() {
    return &m_arScheduleIDs;
}
Group

CXTPCalendarResource Methods


CXTPCalendarResource::IsSchedulesSetEmpty Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::IsSchedulesSetEmpty Method

Call this member function to check whether schedules set in this resource is empty or not.

virtual BOOL IsSchedulesSetEmpty() const;
Returns

TRUE when schedules set is empty for this resource; FALSE if at least 1 schedule exists.

See Also

GetSchedules, ExistsScheduleID

Body Source
BOOL CXTPCalendarResource::IsSchedulesSetEmpty() const {
    return m_arScheduleIDs.GetSize() == 0;
}
Group

CXTPCalendarResource Methods


CXTPCalendarResource::RetrieveDayEvents Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::RetrieveDayEvents Method

Call this member function to get the collection of the day's events for this resource. All events from the applied schedules will be included.

virtual CXTPCalendarEventsPtr RetrieveDayEvents(
    COleDateTime dtDay
);
Parameters

dtDay
A COleDateTime object that contains the day's date.

Returns

A pointer to a CXTPCalendarEvents object that contains the collection of the day's events.

See Also

CXTPCalendarEvents

Group

CXTPCalendarResource Methods


CXTPCalendarResource::SetDataProvider Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::SetDataProvider Method

This member function sets the custom data provider for the control.

void SetDataProvider(
    CXTPCalendarData* pDataProvider,
    BOOL bCloseDataProviderWhenDestroy = FALSE
);
Parameters

pDataProvider
Pointer to the custom data provider object.
bCloseDataProviderWhenDestroy
If this parameter TRUE the Close method of data provided will be called on this resource destruction.

Remarks

Call this member function to set the custom data provider that is currently used by this calendar control. Note that custom data provider must be a descendant of CXTPCalendarData.

See Also

CXTPCalendarData overview, GetDataProvider

Group

CXTPCalendarResource Methods


CXTPCalendarResource::SetName Method

CXTPCalendarResource Methods, CXTPCalendarResource Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::SetName Method

This member function applies a new name to the resource object.

virtual void SetName(
    LPCTSTR pcszResourceName
);
Parameters

pcszResourceName
A string with the new name for the resource

See Also

GetName

Body Source
void CXTPCalendarResource::SetName(LPCTSTR pcszResourceName) {
    ASSERT(pcszResourceName);
    m_strResourceName = pcszResourceName ? pcszResourceName : m_strResourceName;
}
Group

CXTPCalendarResource Methods


CXTPCalendarResource Constructors

CXTPCalendarResource Class, Legend, Public Methods
CXTPCalendarResource Constructors
Class

CXTPCalendarResource Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResource | Default object constructor. Construct CXTPCalendarResource object.


CXTPCalendarResource::CXTPCalendarResource Constructor

CXTPCalendarResource Constructors, CXTPCalendarResource Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::CXTPCalendarResource Constructor

Default object constructor. Construct CXTPCalendarResource object.

CXTPCalendarResource(
    CXTPCalendarControl* pCalendarCtrl = NULL
);
Parameters

pCalendarCtrl
Pointer to the parent Calendar control.

See Also

~CXTPCalendarResource

Group

CXTPCalendarResource Constructors


CXTPCalendarResource Destructors

CXTPCalendarResource Class, Legend, Public Methods
CXTPCalendarResource Destructors
Class

CXTPCalendarResource Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarResource | Default class destructor.


CXTPCalendarResource::~CXTPCalendarResource Destructor

CXTPCalendarResource Destructors, CXTPCalendarResource Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResource::~CXTPCalendarResource Destructor

Default class destructor.

virtual ~CXTPCalendarResource();
Remarks

Handles member items deallocation.

See Also

CXTPCalendarResource

Group

CXTPCalendarResource Destructors


CXTPCalendarResourceDescription Class

XTPCalendarResourcesManager.h, Classes, Legend, Members, Topics, CXTPCalendarResourceDescription Data Members, CXTPCalendarResourceDescription Constructors, CXTPCalendarResourceDescription Constructors, CXTPCalendarResourceDescription Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourceDescription Class

This class is a wrapper for CXTPCalendarResource class. It is needed for easier processing in scope of CXTPCalendarResourcesManager

Class Hierarchy

class CXTPCalendarResourceDescription;
File

XTPCalendarResourcesManager.h

Group

Classes

Legend
Data Member
Constructor
CXTPCalendarResourceDescription Constructors
CXTPCalendarResourceDescription Constructors | Description
CXTPCalendarResourceDescription | Default object constructor.
CXTPCalendarResourceDescription Data Members
CXTPCalendarResourceDescription Data Members | Description
m_bEnabled | This flag indicates is resource enabled.
m_bGenerateName | This flag indicates that resource name should be generated from the schedule(s) name(s).
m_ptrResource | A smart pointer to the resource object.


CXTPCalendarResourceDescription Data Members

CXTPCalendarResourceDescription Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourceDescription Data Members
Class

CXTPCalendarResourceDescription Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bEnabled | This flag indicates is resource enabled.
m_bGenerateName | This flag indicates that resource name should be generated from the schedule(s) name(s).
m_ptrResource | A smart pointer to the resource object.


CXTPCalendarResourceDescription::m_bEnabled Data Member

CXTPCalendarResourceDescription Data Members, CXTPCalendarResourceDescription Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourceDescription::m_bEnabled Data Member

This flag indicates is resource enabled.

BOOL m_bEnabled;
Group

CXTPCalendarResourceDescription Data Members


CXTPCalendarResourceDescription::m_bGenerateName Data Member

CXTPCalendarResourceDescription Data Members, CXTPCalendarResourceDescription Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourceDescription::m_bGenerateName Data Member

This flag indicates that resource name should be generated from the schedule(s) name(s).

BOOL m_bGenerateName;
Group

CXTPCalendarResourceDescription Data Members


CXTPCalendarResourceDescription::m_ptrResource Data Member

CXTPCalendarResourceDescription Data Members, CXTPCalendarResourceDescription Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourceDescription::m_ptrResource Data Member

A smart pointer to the resource object.

CXTPCalendarResourcePtr m_ptrResource;
Group

CXTPCalendarResourceDescription Data Members


CXTPCalendarResourceDescription Constructors

CXTPCalendarResourceDescription Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourceDescription Constructors
Class

CXTPCalendarResourceDescription Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResourceDescription | Default object constructor.


CXTPCalendarResourceDescription::CXTPCalendarResourceDescription Constructor

CXTPCalendarResourceDescription Constructors, CXTPCalendarResourceDescription Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourceDescription::CXTPCalendarResourceDescription Constructor

Default object constructor.

CXTPCalendarResourceDescription();
Group

CXTPCalendarResourceDescription Constructors


CXTPCalendarResources Class

XTPCalendarResource.h, Classes, Legend, Members, Topics, CXTPCalendarResources Constructors, CXTPCalendarResources Destructors, CXTPCalendarResources Constructors, CXTPCalendarResources Destructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResources Class

This class represents a simple array collection of CXTPCalendarResource objects.

Class Hierarchy

class CXTPCalendarResources : public CXTPCalendarPtrCollectionT<CXTPCalendarResource>;
File

XTPCalendarResource.h

See Also

CXTPCalendarPtrCollectionT

Group

Classes

Legend
Constructor
virtual
CXTPCalendarResources Constructors
CXTPCalendarResources Constructors | Description
CXTPCalendarResources | Default collection constructor.
CXTPCalendarResources Destructors
CXTPCalendarResources Destructors | Description
~CXTPCalendarResources | Default collection destructor.


CXTPCalendarResources Constructors

CXTPCalendarResources Class, Legend, Public Methods
CXTPCalendarResources Constructors
Class

CXTPCalendarResources Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResources | Default collection constructor.


CXTPCalendarResources::CXTPCalendarResources Constructor

CXTPCalendarResources Constructors, CXTPCalendarResources Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResources::CXTPCalendarResources Constructor

Default collection constructor.

CXTPCalendarResources();
See Also

~CXTPCalendarResources()

Group

CXTPCalendarResources Constructors


CXTPCalendarResources Destructors

CXTPCalendarResources Class, Legend, Public Methods
CXTPCalendarResources Destructors
Class

CXTPCalendarResources Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarResources | Default collection destructor.


CXTPCalendarResources::~CXTPCalendarResources Destructor

CXTPCalendarResources Destructors, CXTPCalendarResources Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResources::~CXTPCalendarResources Destructor

Default collection destructor.

virtual ~CXTPCalendarResources();
Remarks

Handles member item deallocation. Decreases reference of all stored CXTPCalendarResource objects.

See Also

RemoveAll()

Group

CXTPCalendarResources Destructors


CXTPCalendarResourcesManager Class

XTPCalendarResourcesManager.h, Classes, Legend, Members, Topics, CXTPCalendarResourcesManager Enumerations, CXTPCalendarResourcesManager Data Members, CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Constructors, CXTPCalendarResourcesManager Destructors, CXTPCalendarResourcesManager Constructors, CXTPCalendarResourcesManager Data Members, CXTPCalendarResourcesManager Destructors, CXTPCalendarResourcesManager Enumerations, CXTPCalendarResourcesManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager Class

This class is used as helper to manage calendar resources (and schedules) data configurations.

Class Hierarchy

class CXTPCalendarResourcesManager;
File

XTPCalendarResourcesManager.h

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
CXTPCalendarResourcesManager Constructors
CXTPCalendarResourcesManager Constructors | Description
CXTPCalendarResourcesManager | Default object constructor.
CXTPCalendarResourcesManager Data Members
CXTPCalendarResourcesManager Data Members | Description
m_arDataProviders | Data providers collection.
m_arResources | Resources collection.
CXTPCalendarResourcesManager Destructors
CXTPCalendarResourcesManager Destructors | Description
~CXTPCalendarResourcesManager | Default object destructor.
CXTPCalendarResourcesManager Enumerations
CXTPCalendarResourcesManager Enumerations | Description
XTPEnumCalendarDataProviderFlags | This enum specify a data provider flags.
CXTPCalendarResourcesManager Methods
CXTPCalendarResourcesManager Methods | Description
_Load | This method loads data providers and resources configuration from a storage.
_Save | This method save data providers and resources configuration to a storage.
_SaveCloseDPifNeed | This method is called to Save and Close data provider if these actions were specified in AddDataProvider or SetDataProvider methods.
AddDataProvider | Add a new data provider to data providers collection using specified Calendar connection string.
AddResource | Add a new data resource to calendar resources collection.
ApplyToCalendar | Set the active configuration (enabled resources) to calendar control.
DoExchangeCfg | This method reads or writes data providers and resources configuration from or to an storage.
GetDataProvider |
GetDataProvider_ConnStr | Retrieve a text Calendar connection string for data provider at specified index.
GetDataProvidersCount | Retrieve data providers count in the collection.
GetResource | Retrieve resource at specified index.
GetResourcesCount | Retrieve calendar data resources count in the collection.
LoadCfg | This method loads data providers and resources configuration from a specified file.
MoveResource | Move resource to a new position in the collection.
RemoveAll | Remove all resources and all data providers.
RemoveDataProvider | Remove data provider at specified index.
RemoveResource | Remove resource at specified index.
SaveCfg | This method writes data providers and resources configuration to a specified file.
SetDataProvider | Set a new data provider to data providers collection using specified Calendar connection string.


CXTPCalendarResourcesManager Enumerations

Enumerations, CXTPCalendarResourcesManager Class, Legend
CXTPCalendarResourcesManager Enumerations
Enumerations
Enumeration | Description
XTPEnumCalendarDataProviderFlags | This enum specify a data provider flags.
Class

CXTPCalendarResourcesManager Class

Legend
Enumeration


CXTPCalendarResourcesManager::XTPEnumCalendarDataProviderFlags Enumeration

XTPCalendarResourcesManager.h, CXTPCalendarResourcesManager Enumerations
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::XTPEnumCalendarDataProviderFlags Enumeration

This enum specify a data provider flags.

enum XTPEnumCalendarDataProviderFlags {
  xtpCalendarDPFUnknown = 0,
  xtpCalendarDPF_CreateIfNotExists = 0x001,
  xtpCalendarDPF_SaveOnDestroy = 0x010,
  xtpCalendarDPF_CloseOnDestroy = 0x020
};
File

XTPCalendarResourcesManager.h

Members

xtpCalendarDPFUnknown
Zero value flag
xtpCalendarDPF_CreateIfNotExists
Call Create method of data provider if Open method returns FALSE.
xtpCalendarDPF_SaveOnDestroy
Call Save method of data provider on Resources Manager destroy.
xtpCalendarDPF_CloseOnDestroy
Call Close method of data provider on Resources Manager destroy.

Group

CXTPCalendarResourcesManager Enumerations


CXTPCalendarResourcesManager Data Members

CXTPCalendarResourcesManager Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager Data Members
Class

CXTPCalendarResourcesManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arDataProviders | Data providers collection.
m_arResources | Resources collection.


CXTPCalendarResourcesManager::m_arDataProviders Data Member

CXTPCalendarResourcesManager Data Members, CXTPCalendarResourcesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::m_arDataProviders Data Member

Data providers collection.

CXTPCalendarPtrCollectionT<CXTPCalendarData> m_arDataProviders;
Group

CXTPCalendarResourcesManager Data Members


CXTPCalendarResourcesManager::m_arResources Data Member

CXTPCalendarResourcesManager Data Members, CXTPCalendarResourcesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::m_arResources Data Member

Resources collection.

CXTPCalendarPtrCollectionT<CXTPCalendarResourceDescription> m_arResources;
Group

CXTPCalendarResourcesManager Data Members


CXTPCalendarResourcesManager Methods

CXTPCalendarResourcesManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager Methods
Class

CXTPCalendarResourcesManager Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
_Load | This method loads data providers and resources configuration from a storage.
_Save | This method save data providers and resources configuration to a storage.
_SaveCloseDPifNeed | This method is called to Save and Close data provider if these actions were specified in AddDataProvider or SetDataProvider methods.
Public Methods
Public Methods
Public Method | Description
AddDataProvider | Add a new data provider to data providers collection using specified Calendar connection string.
AddResource | Add a new data resource to calendar resources collection.
ApplyToCalendar | Set the active configuration (enabled resources) to calendar control.
DoExchangeCfg | This method reads or writes data providers and resources configuration from or to an storage.
GetDataProvider |
GetDataProvider_ConnStr | Retrieve a text Calendar connection string for data provider at specified index.
GetDataProvidersCount | Retrieve data providers count in the collection.
GetResource | Retrieve resource at specified index.
GetResourcesCount | Retrieve calendar data resources count in the collection.
LoadCfg | This method loads data providers and resources configuration from a specified file.
MoveResource | Move resource to a new position in the collection.
RemoveAll | Remove all resources and all data providers.
RemoveDataProvider | Remove data provider at specified index.
RemoveResource | Remove resource at specified index.
SaveCfg | This method writes data providers and resources configuration to a specified file.
SetDataProvider | Set a new data provider to data providers collection using specified Calendar connection string.


CXTPCalendarResourcesManager::_Load Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::_Load Method

This method loads data providers and resources configuration from a storage.

void _Load(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize from.

See Also

_Save, LoadCfg, SaveCfg, DoExchangeCfg.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::_Save Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::_Save Method

This method save data providers and resources configuration to a storage.

void _Save(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to.

See Also

_Load, LoadCfg, SaveCfg, DoExchangeCfg.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::_SaveCloseDPifNeed Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::_SaveCloseDPifNeed Method

This method is called to Save and Close data provider if these actions were specified in AddDataProvider or SetDataProvider methods.

void _SaveCloseDPifNeed(
    CXTPCalendarData* pData
);
Parameters

pData
A pointer to data provider object.

See Also

AddDataProvider, SetDataProvider, XTPEnumCalendarDataProviderFlags.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::AddDataProvider Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::AddDataProvider Method

Add a new data provider to data providers collection using specified Calendar connection string.

BOOL AddDataProvider(
    LPCTSTR pcszConnectionString,
    int eDPFlags = xtpCalendarDPF_CreateIfNotExists
);
Parameters

pcszConnectionString
A text Calendar connection string.
eDPFlags
Additional flags to control data provider creation/Opening and destruction/Closing.

Returns

TRUE if operation is successful, FALSE otherwise.

See Also

SetDataProvider, XTPEnumCalendarDataProviderFlags, CXTPCalendarControl::CreateDataProvider, CXTPCalendarData overview.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::AddResource Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::AddResource Method

Add a new data resource to calendar resources collection.

BOOL AddResource(
    LPCTSTR pcszName,
    BOOL bEnabled
);
Parameters

pcszName
Resource name string.
bEnabled
Is resource enabled.

Returns

TRUE if operation is successful, FALSE otherwise.

See Also

GetResourcesCount, GetResource, RemoveResource, MoveResource.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::ApplyToCalendar Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::ApplyToCalendar Method

Set the active configuration (enabled resources) to calendar control.

void ApplyToCalendar(
    CXTPCalendarControl* pCalendar
);
Parameters

pCalendar
A pointer to calendar control.

See Also

CXTPCalendarControl::SetResources

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::DoExchangeCfg Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::DoExchangeCfg Method

This method reads or writes data providers and resources configuration from or to an storage.

void DoExchangeCfg(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

See Also

SaveCfg, LoadCfg.

Group

CXTPCalendarResourcesManager Methods


GetDataProvider Method

CXTPCalendarResourcesManager Methods
GetDataProvider Method
Overload List
Methods
Method | Description
CXTPCalendarResourcesManager::GetDataProvider (LPCTSTR, int*) | Call this method to find data provider by connection string.
CXTPCalendarResourcesManager::GetDataProvider (int) | Retrieve data provider at specified index.
Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::GetDataProvider Method (LPCTSTR, int*)

GetDataProvider Method, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::GetDataProvider Method (LPCTSTR, int*)

Call this method to find data provider by connection string.

CXTPCalendarData* GetDataProvider(
    LPCTSTR pcszConnectionString,
    int* pnIndex = NULL
);
Parameters

pcszConnectionString
A text Calendar connection string.
pnIndex
A pointer to receive data provider index in the collection.

Returns

Pointer to a data provider with specified connection string if such presents in the collection, NULL otherwise.

See Also

GetDataProvider_ConnStr

Group

GetDataProvider Method


CXTPCalendarResourcesManager::GetDataProvider Method (int)

GetDataProvider Method, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::GetDataProvider Method (int)

Retrieve data provider at specified index.

CXTPCalendarData* GetDataProvider(
    int nIndex
);
Parameters

nIndex
Zero based data provider index in the collection.

Returns

Data provider at specified index.

See Also

GetDataProvidersCount, AddDataProvider, SetDataProvider, RemoveDataProvider.

Group

GetDataProvider Method


CXTPCalendarResourcesManager::GetDataProvider_ConnStr Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::GetDataProvider_ConnStr Method

Retrieve a text Calendar connection string for data provider at specified index.

CString GetDataProvider_ConnStr(
    int nIndex
);
Parameters

nIndex
Zero based data provider index in the collection.

Returns

A text Calendar connection string.

See Also

GetDataProvider

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::GetDataProvidersCount Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::GetDataProvidersCount Method

Retrieve data providers count in the collection.

int GetDataProvidersCount() const;
Returns

Data providers count.

See Also

GetDataProvider, AddDataProvider, SetDataProvider, RemoveDataProvider.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::GetResource Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::GetResource Method

Retrieve resource at specified index.

CXTPCalendarResourceDescription* GetResource(
    int nIndex
);
Parameters

nIndex
Zero based resource index in the collection.

Returns

Calendar resource at specified index.

See Also

AddResource, GetResourcesCount, RemoveResource, MoveResource.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::GetResourcesCount Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::GetResourcesCount Method

Retrieve calendar data resources count in the collection.

int GetResourcesCount() const;
Returns

Calendar data resources count in the collection.

See Also

AddResource, GetResource, RemoveResource, MoveResource.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::LoadCfg Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::LoadCfg Method

This method loads data providers and resources configuration from a specified file.

BOOL LoadCfg(
    LPCTSTR pcszFile
);
Parameters

pcszFile
A file name to load configuration.

Returns

TRUE if operation is successful, FALSE otherwise.

See Also

SaveCfg, DoExchangeCfg.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::MoveResource Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::MoveResource Method

Move resource to a new position in the collection.

void MoveResource(
    int nIndex,
    int nNewIndex
);
Parameters

nIndex
Current zero based resource index in the collection.
nNewIndex
A new index to move resource to.

See Also

AddResource, GetResourcesCount, GetResource, RemoveResource.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::RemoveAll Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::RemoveAll Method

Remove all resources and all data providers.

void RemoveAll();
Remarks

Data providers will be saved and closed if this was specified for them.

See Also

XTPEnumCalendarDataProviderFlags

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::RemoveDataProvider Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::RemoveDataProvider Method

Remove data provider at specified index.

void RemoveDataProvider(
    int nIndex
);
Parameters

nIndex
Zero based data provider index in the collection.

See Also

GetDataProvidersCount, GetDataProvider, AddDataProvider, SetDataProvider.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::RemoveResource Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::RemoveResource Method

Remove resource at specified index.

void RemoveResource(
    int nIndex
);
Parameters

nIndex
Zero based resource index in the collection.

See Also

AddResource, GetResourcesCount, GetResource, MoveResource.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::SaveCfg Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::SaveCfg Method

This method writes data providers and resources configuration to a specified file.

BOOL SaveCfg(
    LPCTSTR pcszFile
);
Parameters

pcszFile
A file name to store configuration.

Returns

TRUE if operation is successful, FALSE otherwise.

See Also

LoadCfg, DoExchangeCfg.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager::SetDataProvider Method

CXTPCalendarResourcesManager Methods, CXTPCalendarResourcesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::SetDataProvider Method

Set a new data provider to data providers collection using specified Calendar connection string.

BOOL SetDataProvider(
    int nIndex,
    LPCTSTR pcszConnectionString,
    int eDPFlags = xtpCalendarDPF_CreateIfNotExists
);
Parameters

nIndex
Index of the data provider in the collection.
pcszConnectionString
A text Calendar connection string.
eDPFlags
Additional flags to control data provider creation/Opening and destruction/Closing.

Returns

TRUE if operation is successful, FALSE otherwise.

See Also

AddDataProvider, XTPEnumCalendarDataProviderFlags, CXTPCalendarControl::CreateDataProvider, CXTPCalendarData overview.

Group

CXTPCalendarResourcesManager Methods


CXTPCalendarResourcesManager Constructors

CXTPCalendarResourcesManager Class, Legend, Public Methods
CXTPCalendarResourcesManager Constructors
Class

CXTPCalendarResourcesManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResourcesManager | Default object constructor.


CXTPCalendarResourcesManager::CXTPCalendarResourcesManager Constructor

CXTPCalendarResourcesManager Constructors, CXTPCalendarResourcesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::CXTPCalendarResourcesManager Constructor

Default object constructor.

CXTPCalendarResourcesManager();
Group

CXTPCalendarResourcesManager Constructors


CXTPCalendarResourcesManager Destructors

CXTPCalendarResourcesManager Class, Legend, Public Methods
CXTPCalendarResourcesManager Destructors
Class

CXTPCalendarResourcesManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarResourcesManager | Default object destructor.


CXTPCalendarResourcesManager::~CXTPCalendarResourcesManager Destructor

CXTPCalendarResourcesManager Destructors, CXTPCalendarResourcesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesManager::~CXTPCalendarResourcesManager Destructor

Default object destructor.

virtual ~CXTPCalendarResourcesManager();
Group

CXTPCalendarResourcesManager Destructors


CXTPCalendarResourcesNf Class

XTPCalendarResource.h, Classes, Legend, Members, Topics, CXTPCalendarResourcesNf Methods, CXTPCalendarResourcesNf Constructors, CXTPCalendarResourcesNf Destructors, CXTPCalendarResourcesNf Constructors, CXTPCalendarResourcesNf Destructors, CXTPCalendarResourcesNf Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf Class

This class implements CXTPCalendarResource functionality with addition of notifications mechanism implemented by CXTPNotifySink.

Class Hierarchy

class CXTPCalendarResourcesNf : public CXTPCalendarResources, private CXTPNotifySink;
File

XTPCalendarResource.h

See Also

CXTPCalendarResource overview, CXTPNotifySink overview.

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarResourcesNf Constructors
CXTPCalendarResourcesNf Constructors | Description
CXTPCalendarResourcesNf | Default object constructor. Construct CXTPCalendarResourcesNf object.
CXTPCalendarResourcesNf Destructors
CXTPCalendarResourcesNf Destructors | Description
~CXTPCalendarResourcesNf | Default class destructor.
CXTPCalendarResourcesNf Methods
CXTPCalendarResourcesNf Methods | Description
FindByDataProvider | Call this member function to retrieve a resource object for specified data provider.
GetConnection | Obtain a pointer to the notification connection object.
GetResourcesGroupedByDP | Call this member function to retrieve a resources collection only for unique data providers.
OnEvent | This member function catches all the events from the associated data provider and forwards it to CXTPCalendarResourcesNf subscribers.
ReBuildInternalData | Rebuilds notification connection objects after changes in resources configuration. Call this member function after advising to notifications from connection pointers of the CXTPCalendarResourcesNf object


CXTPCalendarResourcesNf Methods

CXTPCalendarResourcesNf Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf Methods
Class

CXTPCalendarResourcesNf Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnEvent | This member function catches all the events from the associated data provider and forwards it to CXTPCalendarResourcesNf subscribers.
Public Methods
Public Methods
Public Method | Description
FindByDataProvider | Call this member function to retrieve a resource object for specified data provider.
GetConnection | Obtain a pointer to the notification connection object.
GetResourcesGroupedByDP | Call this member function to retrieve a resources collection only for unique data providers.
ReBuildInternalData | Rebuilds notification connection objects after changes in resources configuration. Call this member function after advising to notifications from connection pointers of the CXTPCalendarResourcesNf object


CXTPCalendarResourcesNf::FindByDataProvider Method

CXTPCalendarResourcesNf Methods, CXTPCalendarResourcesNf Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf::FindByDataProvider Method

Call this member function to retrieve a resource object for specified data provider.

CXTPCalendarResource* FindByDataProvider(
    CXTPCalendarData* pData
);
Returns

A pointer to the internal resource from collection which is rebuilt during the ReBuildInternalData method execution.

Remarks

This method returns a resource from temporary intermal collection.

See Also

GetResourcesGroupedByDP, ReBuildInternalData

Body Source
CXTPCalendarResource* CXTPCalendarResourcesNf::FindByDataProvider(CXTPCalendarData* pData) {
    return FindByDataProvider(GetResourcesGroupedByDP(), pData);
}
Group

CXTPCalendarResourcesNf Methods


CXTPCalendarResourcesNf::GetConnection Method

CXTPCalendarResourcesNf Methods, CXTPCalendarResourcesNf Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf::GetConnection Method

Obtain a pointer to the notification connection object.

virtual CXTPNotifyConnection* GetConnection();
Returns

Connection object pointer.

Remarks

Used to subscribe (Advice) for notification events from the control.

See Also

CXTPNotifyConnection overview, IXTPNotificationSink overview

Body Source
CXTPNotifyConnection* CXTPCalendarResourcesNf::GetConnection() {
    return m_pConnection;
}
Group

CXTPCalendarResourcesNf Methods


CXTPCalendarResourcesNf::GetResourcesGroupedByDP Method

CXTPCalendarResourcesNf Methods, CXTPCalendarResourcesNf Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf::GetResourcesGroupedByDP Method

Call this member function to retrieve a resources collection only for unique data providers.

virtual CXTPCalendarResources* GetResourcesGroupedByDP();
Returns

A pointer to the internal resources collection which is rebuilt during the ReBuildInternalData method execution.

Remarks

This method returns a collection of temporary resources objects having only unique data providers. It could be useful to retrieve a complete collection of events for further processing from all data providers in scope of resources collection, and in order not to retrieve duplicate events.

See Also

ReBuildInternalData

Body Source
CXTPCalendarResources* CXTPCalendarResourcesNf::GetResourcesGroupedByDP() {
    return &m_arResourcesGroupedByDP;
}
Group

CXTPCalendarResourcesNf Methods


CXTPCalendarResourcesNf::OnEvent Method

CXTPCalendarResourcesNf Methods, CXTPCalendarResourcesNf Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf::OnEvent Method

This member function catches all the events from the associated data provider and forwards it to CXTPCalendarResourcesNf subscribers.

virtual void OnEvent(
    XTP_NOTIFY_CODE dwNotifyCode,
    WPARAM wParam,
    LPARAM lParam,
    DWORD dwFlags
);
Parameters

dwNotifyCode
Events notification code
wParam
First user's parameter.
lParam
Second user's parameter.
dwFlags
Unused parameter.

Group

CXTPCalendarResourcesNf Methods


CXTPCalendarResourcesNf::ReBuildInternalData Method

CXTPCalendarResourcesNf Methods, CXTPCalendarResourcesNf Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf::ReBuildInternalData Method

Rebuilds notification connection objects after changes in resources configuration. Call this member function after advising to notifications from connection pointers of the CXTPCalendarResourcesNf object

virtual void ReBuildInternalData();
See Also

GetConnection, GetResourcesGroupedByDP

Group

CXTPCalendarResourcesNf Methods


CXTPCalendarResourcesNf Constructors

CXTPCalendarResourcesNf Class, Legend, Public Methods
CXTPCalendarResourcesNf Constructors
Class

CXTPCalendarResourcesNf Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResourcesNf | Default object constructor. Construct CXTPCalendarResourcesNf object.


CXTPCalendarResourcesNf::CXTPCalendarResourcesNf Constructor

CXTPCalendarResourcesNf Constructors, CXTPCalendarResourcesNf Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf::CXTPCalendarResourcesNf Constructor

Default object constructor. Construct CXTPCalendarResourcesNf object.

CXTPCalendarResourcesNf();
See Also

~CXTPCalendarResourcesNf

Group

CXTPCalendarResourcesNf Constructors


CXTPCalendarResourcesNf Destructors

CXTPCalendarResourcesNf Class, Legend, Public Methods
CXTPCalendarResourcesNf Destructors
Class

CXTPCalendarResourcesNf Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarResourcesNf | Default class destructor.


CXTPCalendarResourcesNf::~CXTPCalendarResourcesNf Destructor

CXTPCalendarResourcesNf Destructors, CXTPCalendarResourcesNf Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarResourcesNf::~CXTPCalendarResourcesNf Destructor

Default class destructor.

virtual ~CXTPCalendarResourcesNf();
Remarks

Handles member items deallocation.

See Also

CXTPCalendarResourcesNf

Group

CXTPCalendarResourcesNf Destructors


CXTPCalendarSchedule Class

XTPCalendarResource.h, Classes, Legend, Members, Topics, CXTPCalendarSchedule Data Members, CXTPCalendarSchedule Methods, CXTPCalendarSchedule Constructors, CXTPCalendarSchedule Destructors, CXTPCalendarSchedule Constructors, CXTPCalendarSchedule Data Members, CXTPCalendarSchedule Destructors, CXTPCalendarSchedule Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule Class

Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc).

This class implements base properties of the Schedule and operations on it.

Class Hierarchy

class CXTPCalendarSchedule;
File

XTPCalendarResource.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarSchedule Constructors
CXTPCalendarSchedule Constructors | Description
CXTPCalendarSchedule | Default object constructor. Construct CXTPCalendarSchedule object.
CXTPCalendarSchedule Data Members
CXTPCalendarSchedule Data Members | Description
m_pCustomProperties | Stores custom properties collection for this Schedule
m_strScheduleName | Stores Schedule Name
m_uScheduleID | Stores numeric positive ID of the schedule
CXTPCalendarSchedule Destructors
CXTPCalendarSchedule Destructors | Description
~CXTPCalendarSchedule | Default class destructor.
CXTPCalendarSchedule Methods
CXTPCalendarSchedule Methods | Description
GetCustomProperties | Get custom (named, user defined) properties collection.
GetID | This member function is used to obtain a unique schedule ID.
GetName | This member function is used to obtain the schedule name.
SetID | This member function is used to set a new ID value for a schedule.
SetName | This member function is used to set the schedule name text.


CXTPCalendarSchedule Data Members

CXTPCalendarSchedule Class, Legend, Protected Data Members
CXTPCalendarSchedule Data Members
Class

CXTPCalendarSchedule Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pCustomProperties | Stores custom properties collection for this Schedule
m_strScheduleName | Stores Schedule Name
m_uScheduleID | Stores numeric positive ID of the schedule


CXTPCalendarSchedule::m_pCustomProperties Data Member

CXTPCalendarSchedule Data Members, CXTPCalendarSchedule Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::m_pCustomProperties Data Member

Stores custom properties collection for this Schedule

CXTPCalendarCustomProperties* m_pCustomProperties;
Group

CXTPCalendarSchedule Data Members


CXTPCalendarSchedule::m_strScheduleName Data Member

CXTPCalendarSchedule Data Members, CXTPCalendarSchedule Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::m_strScheduleName Data Member

Stores Schedule Name

CString m_strScheduleName;
Group

CXTPCalendarSchedule Data Members


CXTPCalendarSchedule::m_uScheduleID Data Member

CXTPCalendarSchedule Data Members, CXTPCalendarSchedule Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::m_uScheduleID Data Member

Stores numeric positive ID of the schedule

UINT m_uScheduleID;
Group

CXTPCalendarSchedule Data Members


CXTPCalendarSchedule Methods

CXTPCalendarSchedule Class, Legend, Public Methods
CXTPCalendarSchedule Methods
Class

CXTPCalendarSchedule Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetCustomProperties | Get custom (named, user defined) properties collection.
GetID | This member function is used to obtain a unique schedule ID.
GetName | This member function is used to obtain the schedule name.
SetID | This member function is used to set a new ID value for a schedule.
SetName | This member function is used to set the schedule name text.


CXTPCalendarSchedule::GetCustomProperties Method

CXTPCalendarSchedule Methods, CXTPCalendarSchedule Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::GetCustomProperties Method

Get custom (named, user defined) properties collection.

CXTPCalendarCustomProperties* GetCustomProperties();
Returns

A pointer to CXTPCalendarCustomProperties object.

See Also

CXTPCalendarCustomProperties.

Body Source
CXTPCalendarCustomProperties* CXTPCalendarSchedule::GetCustomProperties() {
    return m_pCustomProperties;
}
Group

CXTPCalendarSchedule Methods


CXTPCalendarSchedule::GetID Method

CXTPCalendarSchedule Methods, CXTPCalendarSchedule Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::GetID Method

This member function is used to obtain a unique schedule ID.

UINT GetID() const;
See Also

CXTPCalendarSchedule, SetID

Body Source
UINT CXTPCalendarSchedule::GetID() const {
    return m_uScheduleID;
}
Group

CXTPCalendarSchedule Methods


CXTPCalendarSchedule::GetName Method

CXTPCalendarSchedule Methods, CXTPCalendarSchedule Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::GetName Method

This member function is used to obtain the schedule name.

LPCTSTR GetName() const;
Returns

A CString object that contains the schedule name text.

See Also

SetName

Body Source
LPCTSTR CXTPCalendarSchedule::GetName() const {
    return m_strScheduleName;
}
Group

CXTPCalendarSchedule Methods


CXTPCalendarSchedule::SetID Method

CXTPCalendarSchedule Methods, CXTPCalendarSchedule Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::SetID Method

This member function is used to set a new ID value for a schedule.

void SetID(
    UINT uScheduleID
);
Parameters

uScheduleID
A DWORD that contains the id value.

See Also

GetID

Body Source
void CXTPCalendarSchedule::SetID(UINT uScheduleID) {
    m_uScheduleID = uScheduleID;
}
Group

CXTPCalendarSchedule Methods


CXTPCalendarSchedule::SetName Method

CXTPCalendarSchedule Methods, CXTPCalendarSchedule Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::SetName Method

This member function is used to set the schedule name text.

void SetName(
    LPCTSTR pcszScheduleName
);
Parameters

pcszScheduleName
An LPCTSTR object that contains the string of text.

See Also

GetName

Body Source
void CXTPCalendarSchedule::SetName(LPCTSTR pcszScheduleName) {
    ASSERT(pcszScheduleName);
    m_strScheduleName = pcszScheduleName ? pcszScheduleName : _T("");
}
Group

CXTPCalendarSchedule Methods


CXTPCalendarSchedule Constructors

CXTPCalendarSchedule Class, Legend, Public Methods
CXTPCalendarSchedule Constructors
Class

CXTPCalendarSchedule Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarSchedule | Default object constructor. Construct CXTPCalendarSchedule object.


CXTPCalendarSchedule::CXTPCalendarSchedule Constructor

CXTPCalendarSchedule Constructors, CXTPCalendarSchedule Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::CXTPCalendarSchedule Constructor

Default object constructor. Construct CXTPCalendarSchedule object.

CXTPCalendarSchedule(
    UINT uScheduleID = 0,
    LPCTSTR pcszScheduleName = _T("")
);
Parameters

uScheduleID
A numeric positive ID of the schedule.
pcszScheduleName
A string name of the schedule (could be a name of the person, etc)

See Also

~CXTPCalendarSchedule

Group

CXTPCalendarSchedule Constructors


CXTPCalendarSchedule Destructors

CXTPCalendarSchedule Class, Legend, Public Methods
CXTPCalendarSchedule Destructors
Class

CXTPCalendarSchedule Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarSchedule | Default class destructor.


CXTPCalendarSchedule::~CXTPCalendarSchedule Destructor

CXTPCalendarSchedule Destructors, CXTPCalendarSchedule Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedule::~CXTPCalendarSchedule Destructor

Default class destructor.

virtual ~CXTPCalendarSchedule();
Remarks

Handles member items deallocation.

See Also

CXTPCalendarSchedule

Group

CXTPCalendarSchedule Destructors


CXTPCalendarSchedules Class

XTPCalendarResource.h, Classes, Legend, Members, Topics, CXTPCalendarSchedules Methods, CXTPCalendarSchedules Constructors, CXTPCalendarSchedules Destructors, CXTPCalendarSchedules Constructors, CXTPCalendarSchedules Destructors, CXTPCalendarSchedules Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedules Class

This class represents a simple array collection of CXTPCalendarSchedule objects.

Class Hierarchy

class CXTPCalendarSchedules : public CXTPCalendarPtrCollectionT<CXTPCalendarSchedule>;
File

XTPCalendarResource.h

Remarks

Array indexes always start at position 0.

As with a C array, the access time for indexed element of this array is constant and is independent of the array size.

See Also

CArray overview, CXTPCalendarSchedule overview.

Group

Classes

Legend
Method
protected
virtual
CXTPCalendarSchedules Constructors
CXTPCalendarSchedules Constructors | Description
CXTPCalendarSchedules | Default collection constructor.
CXTPCalendarSchedules Destructors
CXTPCalendarSchedules Destructors | Description
~CXTPCalendarSchedules | Default collection destructor.
CXTPCalendarSchedules Methods
CXTPCalendarSchedules Methods | Description
_GetNextID | Finds next available ID which does not exist in the array.
_Load | Call this member function to Load a schedule from the specified data object.
_Save | Call this member function to Store a schedule to the specified data object.
AddNewSchedule | Creates and adds a new schedule object by its name.
DoPropExchange | Call this member function to Store/Load a schedule using the specified data object.
FindIndex | Finds schedule index in the internal array by its ID.
GetScheduleName | Returns a name of the schedule by its numeric ID.
RemoveSchedule | Removes a schedule object from the array by its ID.
SetScheduleName | Sets a new schedule name by its numeric ID.


CXTPCalendarSchedules Methods

CXTPCalendarSchedules Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedules Methods
Class

CXTPCalendarSchedules Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_GetNextID | Finds next available ID which does not exist in the array.
_Load | Call this member function to Load a schedule from the specified data object.
_Save | Call this member function to Store a schedule to the specified data object.
Public Methods
Public Methods
Public Method | Description
AddNewSchedule | Creates and adds a new schedule object by its name.
DoPropExchange | Call this member function to Store/Load a schedule using the specified data object.
FindIndex | Finds schedule index in the internal array by its ID.
GetScheduleName | Returns a name of the schedule by its numeric ID.
RemoveSchedule | Removes a schedule object from the array by its ID.
SetScheduleName | Sets a new schedule name by its numeric ID.


CXTPCalendarSchedules::_GetNextID Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class
CXTPCalendarSchedules::_GetNextID Method

Finds next available ID which does not exist in the array.

virtual UINT _GetNextID() const;
Returns

Available ID which does not exist in the array.

Remarks

Function found max ID and returns it incremented by one.

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules::_Load Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class
CXTPCalendarSchedules::_Load Method

Call this member function to Load a schedule from the specified data object.

virtual void _Load(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source CXTPPropExchange data object reference.

Remarks

This member function is used to load schedule data from a specified storage.

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules::_Save Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class
CXTPCalendarSchedules::_Save Method

Call this member function to Store a schedule to the specified data object.

virtual void _Save(
    CXTPPropExchange* pPX
);
Parameters

pPX
Destination CXTPPropExchange data object reference.

Remarks

This member function is used to store schedule data to a storage.

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules::AddNewSchedule Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedules::AddNewSchedule Method

Creates and adds a new schedule object by its name.

virtual BOOL AddNewSchedule(
    LPCTSTR pcszScheduleName
);
Parameters

pcszScheduleName
String with the schedule name.

Returns

TRUE if added successfully; FALSE otherwise.

See Also

RemoveSchedule

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules::DoPropExchange Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class
CXTPCalendarSchedules::DoPropExchange Method

Call this member function to Store/Load a schedule using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.

Remarks

This member function is used to store or load schedule data to or from a storage.

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules::FindIndex Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class
CXTPCalendarSchedules::FindIndex Method

Finds schedule index in the internal array by its ID.

virtual int FindIndex(
    UINT uScheduleID
) const;
Parameters

uScheduleID
Label ID

Returns

Schedule index in the internal label array.

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules::GetScheduleName Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedules::GetScheduleName Method

Returns a name of the schedule by its numeric ID.

virtual LPCTSTR GetScheduleName(
    UINT uScheduleID
) const;
Parameters

uScheduleID
An ID of the schedule.

See Also

SetScheduleName

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules::RemoveSchedule Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedules::RemoveSchedule Method

Removes a schedule object from the array by its ID.

virtual BOOL RemoveSchedule(
    UINT uScheduleID
);
Parameters

uScheduleID
An ID of the schedule.

Returns

TRUE if object was found and removed from the array; FALSE otherwise.

See Also

AddNewSchedule

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules::SetScheduleName Method

CXTPCalendarSchedules Methods, CXTPCalendarSchedules Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedules::SetScheduleName Method

Sets a new schedule name by its numeric ID.

virtual void SetScheduleName(
    UINT uScheduleID,
    LPCTSTR pcszNewName
);
Parameters

uScheduleID
An ID of the schedule
pcszNewName
String of text for the new name of the schedule

See Also

GetScheduleName

Group

CXTPCalendarSchedules Methods


CXTPCalendarSchedules Constructors

CXTPCalendarSchedules Class, Legend, Public Methods
CXTPCalendarSchedules Constructors
Class

CXTPCalendarSchedules Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarSchedules | Default collection constructor.


CXTPCalendarSchedules::CXTPCalendarSchedules Constructor

CXTPCalendarSchedules Constructors, CXTPCalendarSchedules Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedules::CXTPCalendarSchedules Constructor

Default collection constructor.

CXTPCalendarSchedules();
See Also

~CXTPCalendarSchedules()

Group

CXTPCalendarSchedules Constructors


CXTPCalendarSchedules Destructors

CXTPCalendarSchedules Class, Legend, Public Methods
CXTPCalendarSchedules Destructors
Class

CXTPCalendarSchedules Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarSchedules | Default collection destructor.


CXTPCalendarSchedules::~CXTPCalendarSchedules Destructor

CXTPCalendarSchedules Destructors, CXTPCalendarSchedules Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarSchedules::~CXTPCalendarSchedules Destructor

Default collection destructor.

virtual ~CXTPCalendarSchedules();
Remarks

Handles member item deallocation. Decreases reference of all stored CXTPCalendarSchedule objects.

See Also

RemoveAll()

Group

CXTPCalendarSchedules Destructors


CXTPCalendarThemeBOOLValue Class

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarThemeBOOLValue Methods, CXTPCalendarThemeBOOLValue Constructors, CXTPCalendarThemeBOOLValue Operators, CXTPCalendarThemeBOOLValue Constructors, CXTPCalendarThemeBOOLValue Methods, CXTPCalendarThemeBOOLValue Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeBOOLValue Class

Helper class provides functionality to manage customized BOOL value objects.

Class Hierarchy

class CXTPCalendarThemeBOOLValue : public CXTPCalendarThemeCustomizableXValueT<BOOL, BOOL>;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Method
virtual
Operator
CXTPCalendarThemeBOOLValue Constructors
CXTPCalendarThemeBOOLValue Constructors | Description
CXTPCalendarThemeBOOLValue | Default object constructor.
CXTPCalendarThemeBOOLValue Methods
CXTPCalendarThemeBOOLValue Methods | Description
DoPX_Value | This method reads or writes value data from or to an storage.
CXTPCalendarThemeBOOLValue Operators
CXTPCalendarThemeBOOLValue Operators | Description
= | This member operator is use to set custom value.


CXTPCalendarThemeBOOLValue Methods

CXTPCalendarThemeBOOLValue Class, Legend, Public Methods
CXTPCalendarThemeBOOLValue Methods
Class

CXTPCalendarThemeBOOLValue Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPX_Value | This method reads or writes value data from or to an storage.


CXTPCalendarThemeBOOLValue::DoPX_Value Method

CXTPCalendarThemeBOOLValue Methods, CXTPCalendarThemeBOOLValue Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeBOOLValue::DoPX_Value Method

This method reads or writes value data from or to an storage.

virtual void DoPX_Value(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    BOOL& rXValue,
    BOOL bStandard
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
pcszPropName
A value name.
rXValue
Reference to value.
bStandard
Standard or Custom value.

See Also

DoPropExchange()

Body Source
virtual void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, BOOL& rXValue, BOOL bStandard)
{
    if (pPX->IsStoring())
    {
        if (bStandard && !m_bIsStandardSet ||
            !bStandard && !m_bIsCustomSet)
        {
            rXValue = FALSE;
        }
    }
    PX_Bool(pPX, pcszPropName, rXValue);
}
Group

CXTPCalendarThemeBOOLValue Methods


CXTPCalendarThemeBOOLValue Constructors

CXTPCalendarThemeBOOLValue Class, Legend, Public Methods
CXTPCalendarThemeBOOLValue Constructors
Class

CXTPCalendarThemeBOOLValue Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeBOOLValue | Default object constructor.


CXTPCalendarThemeBOOLValue::CXTPCalendarThemeBOOLValue Constructor

CXTPCalendarThemeBOOLValue Constructors, CXTPCalendarThemeBOOLValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeBOOLValue::CXTPCalendarThemeBOOLValue Constructor

Default object constructor.

CXTPCalendarThemeBOOLValue();
Body Source
CXTPCalendarThemeBOOLValue()
{
    m_ValueStandard = m_ValueCustom = FALSE;
}
Group

CXTPCalendarThemeBOOLValue Constructors


CXTPCalendarThemeBOOLValue Operators

CXTPCalendarThemeBOOLValue Class, Legend, Public Operators
CXTPCalendarThemeBOOLValue Operators
Class

CXTPCalendarThemeBOOLValue Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This member operator is use to set custom value.


CXTPCalendarThemeBOOLValue::= Operator

CXTPCalendarThemeBOOLValue Operators, CXTPCalendarThemeBOOLValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeBOOLValue::= Operator

This member operator is use to set custom value.

const CXTPCalendarThemeBOOLValue& operator =(
    BOOL bValue
);
Parameters

bValue
A new custom value.

Returns

Reference to this object.

Body Source
const CXTPCalendarThemeBOOLValue& operator=(BOOL bValue) {
    SetCustomValue(bValue);
    return *this;
}
Group

CXTPCalendarThemeBOOLValue Operators


CXTPCalendarThemeCustomizableXValueT Template

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarThemeCustomizableXValueT Data Members, CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Constructors, CXTPCalendarThemeCustomizableXValueT Destructors, CXTPCalendarThemeCustomizableXValueT Operators, CXTPCalendarThemeCustomizableXValueT Constructors, CXTPCalendarThemeCustomizableXValueT Data Members, CXTPCalendarThemeCustomizableXValueT Destructors, CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT Template

Helper class template provides functionality to manage customized value for the specified type.

Class Hierarchy

template <class _TValue, class _TValueRef = _TValue&>
class CXTPCalendarThemeCustomizableXValueT;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Data Member
protected
Method
virtual
Operator
CXTPCalendarThemeCustomizableXValueT Constructors
CXTPCalendarThemeCustomizableXValueT Constructors | Description
CXTPCalendarThemeCustomizableXValueT | Default object constructor.
CXTPCalendarThemeCustomizableXValueT Data Members
CXTPCalendarThemeCustomizableXValueT Data Members | Description
m_bAutoDestroy_Custom | Call DoDestroy for custom vale.
m_bAutoDestroy_Standard | Call DoDestroy for standard vale.
m_bIsCustomSet | Is custom value set.
m_bIsStandardSet | Is standard value set.
m_ValueCustom | Stores custom value.
m_ValueStandard | Stores default value.
CXTPCalendarThemeCustomizableXValueT Destructors
CXTPCalendarThemeCustomizableXValueT Destructors | Description
~CXTPCalendarThemeCustomizableXValueT | Default object destructor.
CXTPCalendarThemeCustomizableXValueT Methods
CXTPCalendarThemeCustomizableXValueT Methods | Description
CopySettings | This member function is use to set standard value using current value from the specified object.
DoDestroy | This member function is used to destroy objects of type _TValue if necessary (Close handles, free memory, ...).
DoPropExchange | This method reads or writes data from or to an storage.
DoPX_Value | This method reads or writes value data from or to an storage.
GetStandardValue | This member function is use to get standard value.
GetValue | This member function is use to get current value.
GetValueX | This member function is use to get current value.
IsCustomValue | This member function determines if the custom value is set and used.
IsDefaultValue | This member function is used to determine if the default value is set.
IsStandardValue | This member function determines if the standard value is set and used.
Serialize | This method reads or writes data from or to an archive.
SetCustomValue |
SetDefaultValue | This member function is used to reset the custom value.
SetStandardValue |
CXTPCalendarThemeCustomizableXValueT Operators
CXTPCalendarThemeCustomizableXValueT Operators | Description
_TValueRef | This member operator is use to get current value.
= | This member operator is use to set custom value.


CXTPCalendarThemeCustomizableXValueT Data Members

CXTPCalendarThemeCustomizableXValueT Template, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT Data Members
Template

CXTPCalendarThemeCustomizableXValueT Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoDestroy_Custom | Call DoDestroy for custom vale.
m_bAutoDestroy_Standard | Call DoDestroy for standard vale.
m_bIsCustomSet | Is custom value set.
m_bIsStandardSet | Is standard value set.
m_ValueCustom | Stores custom value.
m_ValueStandard | Stores default value.


CXTPCalendarThemeCustomizableXValueT::m_bAutoDestroy_Custom Data Member

CXTPCalendarThemeCustomizableXValueT Data Members, CXTPCalendarThemeCustomizableXValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::m_bAutoDestroy_Custom Data Member

Call DoDestroy for custom vale.

BOOL m_bAutoDestroy_Custom;
Group

CXTPCalendarThemeCustomizableXValueT Data Members


CXTPCalendarThemeCustomizableXValueT::m_bAutoDestroy_Standard Data Member

CXTPCalendarThemeCustomizableXValueT Data Members, CXTPCalendarThemeCustomizableXValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::m_bAutoDestroy_Standard Data Member

Call DoDestroy for standard vale.

BOOL m_bAutoDestroy_Standard;
Group

CXTPCalendarThemeCustomizableXValueT Data Members


CXTPCalendarThemeCustomizableXValueT::m_bIsCustomSet Data Member

CXTPCalendarThemeCustomizableXValueT Data Members, CXTPCalendarThemeCustomizableXValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::m_bIsCustomSet Data Member

Is custom value set.

BOOL m_bIsCustomSet;
Group

CXTPCalendarThemeCustomizableXValueT Data Members


CXTPCalendarThemeCustomizableXValueT::m_bIsStandardSet Data Member

CXTPCalendarThemeCustomizableXValueT Data Members, CXTPCalendarThemeCustomizableXValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::m_bIsStandardSet Data Member

Is standard value set.

BOOL m_bIsStandardSet;
Group

CXTPCalendarThemeCustomizableXValueT Data Members


CXTPCalendarThemeCustomizableXValueT::m_ValueCustom Data Member

CXTPCalendarThemeCustomizableXValueT Data Members, CXTPCalendarThemeCustomizableXValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::m_ValueCustom Data Member

Stores custom value.

_TValue m_ValueCustom;
Group

CXTPCalendarThemeCustomizableXValueT Data Members


CXTPCalendarThemeCustomizableXValueT::m_ValueStandard Data Member

CXTPCalendarThemeCustomizableXValueT Data Members, CXTPCalendarThemeCustomizableXValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::m_ValueStandard Data Member

Stores default value.

_TValue m_ValueStandard;
Group

CXTPCalendarThemeCustomizableXValueT Data Members


CXTPCalendarThemeCustomizableXValueT Methods

CXTPCalendarThemeCustomizableXValueT Template, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT Methods
Template

CXTPCalendarThemeCustomizableXValueT Template

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DoPX_Value | This method reads or writes value data from or to an storage.
Public Methods
Public Methods
Public Method | Description
CopySettings | This member function is use to set standard value using current value from the specified object.
DoDestroy | This member function is used to destroy objects of type _TValue if necessary (Close handles, free memory, ...).
DoPropExchange | This method reads or writes data from or to an storage.
GetStandardValue | This member function is use to get standard value.
GetValue | This member function is use to get current value.
GetValueX | This member function is use to get current value.
IsCustomValue | This member function determines if the custom value is set and used.
IsDefaultValue | This member function is used to determine if the default value is set.
IsStandardValue | This member function determines if the standard value is set and used.
Serialize | This method reads or writes data from or to an archive.
SetCustomValue |
SetDefaultValue | This member function is used to reset the custom value.
SetStandardValue |


CXTPCalendarThemeCustomizableXValueT::CopySettings Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::CopySettings Method

This member function is use to set standard value using current value from the specified object.

void CopySettings(
    const CXTPCalendarThemeCustomizableXValueT<_TValue, _TValueRef>& refSrc
);
Parameters

refSrc
Reference to a source object.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue, GetValue, IsStandardValue, IsCustomValue, GetStandardValue.

Body Source
void CopySettings(const CXTPCalendarThemeCustomizableXValueT<_TValue, _TValueRef>& refSrc)
{
    SetStandardValue(refSrc.GetValue());
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::DoDestroy Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::DoDestroy Method

This member function is used to destroy objects of type _TValue if necessary (Close handles, free memory, ...).

virtual void DoDestroy(
    _TValue& refValue
);
Parameters

refValue
An object reference to destroy.

Body Source
virtual void DoDestroy(_TValue& refValue){UNREFERENCED_PARAMETER(refValue);}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::DoPropExchange Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::DoPropExchange Method

This method reads or writes data from or to an storage.

virtual void DoPropExchange(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
pcszPropName
The name of the property being exchanged.

See Also

Serialize(), DoPX_Value()

Body Source
virtual void DoPropExchange(CXTPPropExchange* pPX, LPCTSTR pcszPropName)
{
    if (!pPX || !pcszPropName)
    {
        ASSERT(FALSE);
        return;
    }

    CXTPPropExchangeSection secData(pPX->GetSection(pcszPropName));
    if (pPX->IsStoring())
        secData->EmptySection();

    PX_Bool(&secData, _T("IsStandardSet"), m_bIsStandardSet);
    PX_Bool(&secData, _T("IsCustomSet"), m_bIsCustomSet);

    DoPX_Value(&secData, _T("Standard"), m_ValueStandard, TRUE);
    DoPX_Value(&secData, _T("Custom"), m_ValueCustom, FALSE);

}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::DoPX_Value Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::DoPX_Value Method

This method reads or writes value data from or to an storage.

virtual void DoPX_Value(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    _TValue& rXValue,
    BOOL bStandard
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
pcszPropName
A value name.
rXValue
Reference to value.
bStandard
Standard or Custom value.

See Also

DoPropExchange()

Body Source
virtual void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, _TValue& rXValue, BOOL bStandard)
{
    ASSERT(FALSE);
    UNREFERENCED_PARAMETER(pPX); UNREFERENCED_PARAMETER(pcszPropName); UNREFERENCED_PARAMETER(rXValue);
    UNREFERENCED_PARAMETER(bStandard);
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::GetStandardValue Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::GetStandardValue Method

This member function is use to get standard value.

virtual _TValueRef GetStandardValue() const;
Returns

Standard value.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue

Body Source
virtual _TValueRef GetStandardValue() const {
    return  m_ValueStandard;
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::GetValue Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::GetValue Method

This member function is use to get current value.

virtual _TValueRef GetValue() const;
Returns

Current value as _TValueRef.

Remarks

The default value is used if the custom value is not set. Otherwise, a custom value is used.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue

Body Source
virtual _TValueRef GetValue() const {
    return  m_bIsCustomSet ? m_ValueCustom : m_ValueStandard;
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::GetValueX Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::GetValueX Method

This member function is use to get current value.

virtual const _TValue& GetValueX() const;
Returns

Current value as const _TValue&.

Remarks

The default value is used if the custom value is not set. Otherwise, a custom value is used.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue

Body Source
virtual const _TValue& GetValueX() const {
    return  m_bIsCustomSet ? m_ValueCustom : m_ValueStandard;
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::IsCustomValue Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::IsCustomValue Method

This member function determines if the custom value is set and used.

virtual BOOL IsCustomValue() const;
Returns

TRUE if custom value is set, otherwise FALSE.

Body Source
virtual BOOL IsCustomValue() const {
    return m_bIsCustomSet;
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::IsDefaultValue Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::IsDefaultValue Method

This member function is used to determine if the default value is set.

virtual BOOL IsDefaultValue() const;
Returns

A BOOL. TRUE if the default value is set. FALSE otherwise.

Body Source
virtual BOOL IsDefaultValue() const {
    return !m_bIsCustomSet && !m_bIsStandardSet;
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::IsStandardValue Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::IsStandardValue Method

This member function determines if the standard value is set and used.

virtual BOOL IsStandardValue() const;
Returns

TRUE if standard value is set and custom value is not set, otherwise FALSE.

Body Source
virtual BOOL IsStandardValue() const {
    return !m_bIsCustomSet && m_bIsStandardSet;
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::Serialize Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::Serialize Method

This method reads or writes data from or to an archive.

virtual void Serialize(
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.

See Also

DoPropExchange()

Body Source
virtual void Serialize(CArchive& ar)
{
    // for simple types which can be easy serialized.
    // override for more complex cases

    if (ar.IsStoring())
    {
        ar << m_bIsStandardSet;
        ar << m_bIsCustomSet;

        ar << m_ValueStandard;
        ar << m_ValueCustom;
    }
    else
    {
        ASSERT(ar.IsLoading());

        ar >> m_bIsStandardSet;
        ar >> m_bIsCustomSet;

        ar >> m_ValueStandard;
        ar >> m_ValueCustom;

    }
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


SetCustomValue Method

CXTPCalendarThemeCustomizableXValueT Methods
SetCustomValue Method
Overload List
Methods
Method | Description
CXTPCalendarThemeCustomizableXValueT::SetCustomValue (_TValueRef) | This member function is used to set the custom value.
CXTPCalendarThemeCustomizableXValueT::SetCustomValue (_TValueRef, BOOL) | This member function is used to set the custom value.
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::SetCustomValue Method (_TValueRef, BOOL)

SetCustomValue Method, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::SetCustomValue Method (_TValueRef, BOOL)

This member function is used to set the custom value.

virtual void SetCustomValue(
    _TValueRef refValue,
    BOOL bAutoDestroy
);
virtual void SetCustomValue(
    _TValueRef refValue
);
Parameters

refValue
A custom value.
bAutoDestroy
This parameter indicates should be a value object destroyed when destroy or other value is set. If TRUE - DoDestroy will be called.

Remarks

Call this member function to set the custom value. If set, this value is used instead of default value.

See Also

SetStandardValue, SetDefaultValue

Body Source
virtual void SetCustomValue(_TValueRef refValue, BOOL bAutoDestroy)
{
    if (m_bIsCustomSet && m_bAutoDestroy_Custom) {
        DoDestroy(m_ValueCustom);
    }
    m_ValueCustom = refValue;

    m_bAutoDestroy_Custom = bAutoDestroy;
    m_bIsCustomSet = TRUE;
}

virtual void SetCustomValue(_TValueRef refValue)
{
    SetCustomValue(refValue, m_bAutoDestroy_Custom);
}
Group

SetCustomValue Method


CXTPCalendarThemeCustomizableXValueT::SetDefaultValue Method

CXTPCalendarThemeCustomizableXValueT Methods, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::SetDefaultValue Method

This member function is used to reset the custom value.

virtual void SetDefaultValue();
Remarks

Call this member function to ensure that the default value is used and not the custom value. If the default value is not set - method do nothing.

See Also

SetStandardValue, SetCustomValue

Body Source
virtual void SetDefaultValue()
{
    if (m_bIsStandardSet)
    {
        if (m_bIsCustomSet && m_bAutoDestroy_Custom) {
            DoDestroy(m_ValueCustom);
        }
        m_bIsCustomSet = FALSE;
        m_bAutoDestroy_Custom = FALSE;
    }
}
Group

CXTPCalendarThemeCustomizableXValueT Methods


SetStandardValue Method

CXTPCalendarThemeCustomizableXValueT Methods
SetStandardValue Method
Overload List
Methods
Method | Description
CXTPCalendarThemeCustomizableXValueT::SetStandardValue (_TValueRef) | This member function is used to set the standard value.
CXTPCalendarThemeCustomizableXValueT::SetStandardValue (_TValueRef, BOOL) | This member function is used to set the standard value.
Group

CXTPCalendarThemeCustomizableXValueT Methods


CXTPCalendarThemeCustomizableXValueT::SetStandardValue Method (_TValueRef, BOOL)

SetStandardValue Method, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::SetStandardValue Method (_TValueRef, BOOL)

This member function is used to set the standard value.

virtual void SetStandardValue(
    _TValueRef refValue,
    BOOL bAutoDestroy
);
virtual void SetStandardValue(
    _TValueRef refValue
);
Parameters

refValue
A standard value.
bAutoDestroy
This parameter indicates should be a value object destroyed when destroy or other value is set. If TRUE - DoDestroy will be called.

Remarks

Call this member function to set the standard value. This value is used as the default value if there is not a custom value set.

See Also

SetCustomValue, SetDefaultValue

Body Source
virtual void SetStandardValue(_TValueRef refValue, BOOL bAutoDestroy)
{
    if (m_bIsStandardSet && m_bAutoDestroy_Standard) {
        DoDestroy(m_ValueStandard);
    }
    m_ValueStandard = refValue;

    m_bAutoDestroy_Standard = bAutoDestroy;
    m_bIsStandardSet = TRUE;
}

virtual void SetStandardValue(_TValueRef refValue)
{
    SetStandardValue(refValue, m_bAutoDestroy_Standard);
}
Group

SetStandardValue Method


CXTPCalendarThemeCustomizableXValueT Constructors

CXTPCalendarThemeCustomizableXValueT Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT Constructors
Template

CXTPCalendarThemeCustomizableXValueT Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeCustomizableXValueT | Default object constructor.


CXTPCalendarThemeCustomizableXValueT::CXTPCalendarThemeCustomizableXValueT Constructor

CXTPCalendarThemeCustomizableXValueT Constructors, CXTPCalendarThemeCustomizableXValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::CXTPCalendarThemeCustomizableXValueT Constructor

Default object constructor.

CXTPCalendarThemeCustomizableXValueT();
Body Source
CXTPCalendarThemeCustomizableXValueT()
{
    m_bIsStandardSet = FALSE;
    m_bIsCustomSet = FALSE;

    m_bAutoDestroy_Standard = FALSE;
    m_bAutoDestroy_Custom = FALSE;

    m_ValueStandard = _TValue();
    m_ValueCustom = _TValue();
}
Group

CXTPCalendarThemeCustomizableXValueT Constructors


CXTPCalendarThemeCustomizableXValueT Destructors

CXTPCalendarThemeCustomizableXValueT Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT Destructors
Template

CXTPCalendarThemeCustomizableXValueT Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarThemeCustomizableXValueT | Default object destructor.


CXTPCalendarThemeCustomizableXValueT::~CXTPCalendarThemeCustomizableXValueT Destructor

CXTPCalendarThemeCustomizableXValueT Destructors, CXTPCalendarThemeCustomizableXValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::~CXTPCalendarThemeCustomizableXValueT Destructor

Default object destructor.

virtual ~CXTPCalendarThemeCustomizableXValueT();
Body Source
virtual ~CXTPCalendarThemeCustomizableXValueT()
{
    if (m_bAutoDestroy_Standard) {
        DoDestroy(m_ValueStandard);
    }
    if (m_bAutoDestroy_Custom) {
        DoDestroy(m_ValueCustom);
    }
}
Group

CXTPCalendarThemeCustomizableXValueT Destructors


CXTPCalendarThemeCustomizableXValueT Operators

CXTPCalendarThemeCustomizableXValueT Template, Legend, Public Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT Operators
Template

CXTPCalendarThemeCustomizableXValueT Template

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
_TValueRef | This member operator is use to get current value.
= | This member operator is use to set custom value.


CXTPCalendarThemeCustomizableXValueT::_TValueRef Operator

CXTPCalendarThemeCustomizableXValueT Operators, CXTPCalendarThemeCustomizableXValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::_TValueRef Operator

This member operator is use to get current value.

operator _TValueRef() const;
Returns

Current value.

Remarks

The default value is used if the custom value is not set. Otherwise, a custom value is used.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue, GetValue

Body Source
operator _TValueRef () const {
    return GetValue();
}
Group

CXTPCalendarThemeCustomizableXValueT Operators


CXTPCalendarThemeCustomizableXValueT::= Operator

CXTPCalendarThemeCustomizableXValueT Operators, CXTPCalendarThemeCustomizableXValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeCustomizableXValueT::= Operator

This member operator is use to set custom value.

const CXTPCalendarThemeCustomizableXValueT<_TValue, _TValueRef>& operator =(
    _TValueRef refValue
);
Parameters

refValue
A new custom value.

Returns

Reference to this object.

Body Source
const CXTPCalendarThemeCustomizableXValueT<_TValue, _TValueRef>& operator=(_TValueRef refValue) {
    SetCustomValue(refValue);
    return *this;
}
Group

CXTPCalendarThemeCustomizableXValueT Operators


CXTPCalendarThemeFontValue Class

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarThemeFontValue Methods, CXTPCalendarThemeFontValue Constructors, CXTPCalendarThemeFontValue Operators, CXTPCalendarThemeFontValue Constructors, CXTPCalendarThemeFontValue Methods, CXTPCalendarThemeFontValue Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeFontValue Class

Helper class provides functionality to manage font value objects.

Class Hierarchy

class CXTPCalendarThemeFontValue : public CXTPCalendarViewPartCustomizableValueT<CFont>;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Method
virtual
Operator
CXTPCalendarThemeFontValue Constructors
CXTPCalendarThemeFontValue Constructors | Description
CXTPCalendarThemeFontValue | Default constructor.
CXTPCalendarThemeFontValue Methods
CXTPCalendarThemeFontValue Methods | Description
CopySettings | This member function is use to set standard value using current value from the specified object.
Serialize | This method reads or writes data from or to an archive.
SetCustomValue |
SetStandardValue |
CXTPCalendarThemeFontValue Operators
CXTPCalendarThemeFontValue Operators | Description
= | This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.


CXTPCalendarThemeFontValue Methods

CXTPCalendarThemeFontValue Class, Legend, Public Methods
CXTPCalendarThemeFontValue Methods
Class

CXTPCalendarThemeFontValue Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
CopySettings | This member function is use to set standard value using current value from the specified object.
Serialize | This method reads or writes data from or to an archive.
SetCustomValue |
SetStandardValue |


CXTPCalendarThemeFontValue::CopySettings Method

CXTPCalendarThemeFontValue Methods, CXTPCalendarThemeFontValue Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeFontValue::CopySettings Method

This member function is use to set standard value using current value from the specified object.

void CopySettings(
    const CXTPCalendarThemeFontValue& refSrc
);
Parameters

refSrc
Reference to a source object.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue, GetValue, IsStandardValue, IsCustomValue, GetStandardValue.

Body Source
void CopySettings(const CXTPCalendarThemeFontValue& refSrc)
{
    SetStandardValue(refSrc.GetValue());
}
Group

CXTPCalendarThemeFontValue Methods


CXTPCalendarThemeFontValue::Serialize Method

CXTPCalendarThemeFontValue Methods, CXTPCalendarThemeFontValue Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeFontValue::Serialize Method

This method reads or writes data from or to an archive.

virtual void Serialize(
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.

See Also

DoPropExchange()

Group

CXTPCalendarThemeFontValue Methods


SetCustomValue Method

CXTPCalendarThemeFontValue Methods
SetCustomValue Method
Overload List
Methods
Method | Description
CXTPCalendarThemeFontValue::SetCustomValue (CFont*) | This member function is used to set the custom value.
CXTPCalendarThemeFontValue::SetCustomValue (LOGFONT*) | This member function is used to set the value for the custom font.
Group

CXTPCalendarThemeFontValue Methods


CXTPCalendarThemeFontValue::SetCustomValue Method (LOGFONT*)

SetCustomValue Method, CXTPCalendarThemeFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeFontValue::SetCustomValue Method (LOGFONT*)

This member function is used to set the value for the custom font.

virtual void SetCustomValue(
    LOGFONT* pLogFont
);
Parameters

pLogFont
A pointer to a LOGFONT structure that contains the custom font value.
pFont
A pointer to CFont object.

Remarks

Call this member function to set the custom font. If set, this font is used as the object value.

Body Source
virtual void SetCustomValue(LOGFONT* pLogFont)
{
    CFont* pFont = new CFont();
    if (pFont) {
        VERIFY(pFont->CreateFontIndirect(pLogFont));
    }
    TBase::SetCustomValue(pFont, TRUE);
}
Group

SetCustomValue Method


SetStandardValue Method

CXTPCalendarThemeFontValue Methods
SetStandardValue Method
Overload List
Methods
Method | Description
CXTPCalendarThemeFontValue::SetStandardValue (CFont*) | This member function is used to set the standard value.
CXTPCalendarThemeFontValue::SetStandardValue (LOGFONT*) | This member function is used to set the value for the standard font.
Group

CXTPCalendarThemeFontValue Methods


CXTPCalendarThemeFontValue::SetStandardValue Method (LOGFONT*)

SetStandardValue Method, CXTPCalendarThemeFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeFontValue::SetStandardValue Method (LOGFONT*)

This member function is used to set the value for the standard font.

virtual void SetStandardValue(
    LOGFONT* pLogFont
);
Parameters

pLogFont
A pointer to a LOGFONT structure that contains the standard font value.

Remarks

Call this member function to set the standard font. This font is used as the default font if there is not a custom font value set.

Body Source
virtual void SetStandardValue(LOGFONT* pLogFont)
{
    CFont* pFont = new CFont();
    if (pFont) {
        VERIFY(pFont->CreateFontIndirect(pLogFont));
    }
    TBase::SetStandardValue(pFont, TRUE);
}
Group

SetStandardValue Method


CXTPCalendarThemeFontValue Constructors

CXTPCalendarThemeFontValue Class, Legend, Public Methods
CXTPCalendarThemeFontValue Constructors
Class

CXTPCalendarThemeFontValue Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeFontValue | Default constructor.


CXTPCalendarThemeFontValue::CXTPCalendarThemeFontValue Constructor

CXTPCalendarThemeFontValue Constructors, CXTPCalendarThemeFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeFontValue::CXTPCalendarThemeFontValue Constructor

Default constructor.

CXTPCalendarThemeFontValue();
Body Source
CXTPCalendarThemeFontValue()
{
}
Group

CXTPCalendarThemeFontValue Constructors


CXTPCalendarThemeFontValue Operators

CXTPCalendarThemeFontValue Class, Legend, Public Operators
CXTPCalendarThemeFontValue Operators
Class

CXTPCalendarThemeFontValue Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.


CXTPCalendarThemeFontValue::= Operator

CXTPCalendarThemeFontValue Operators, CXTPCalendarThemeFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeFontValue::= Operator

This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.

const CXTPCalendarThemeFontValue& operator =(
    LOGFONT& rLogFont
);
Parameters

rLogFont
A reference to LOGFONT structure.

Returns

A reference to a CXTPCalendarViewPartFontValue.

Remarks

Creates a new custom font.

Body Source
const CXTPCalendarThemeFontValue& operator=(LOGFONT& rLogFont) {
    SetCustomValue(&rLogFont);
    return *this;
}
Group

CXTPCalendarThemeFontValue Operators


CXTPCalendarThemeIntValue Class

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarThemeIntValue Methods, CXTPCalendarThemeIntValue Constructors, CXTPCalendarThemeIntValue Operators, CXTPCalendarThemeIntValue Constructors, CXTPCalendarThemeIntValue Methods, CXTPCalendarThemeIntValue Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeIntValue Class

Helper class provides functionality to manage customized int value objects.

Class Hierarchy

class CXTPCalendarThemeIntValue : public CXTPCalendarThemeCustomizableXValueT<int, int>;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Method
virtual
Operator
CXTPCalendarThemeIntValue Constructors
CXTPCalendarThemeIntValue Constructors | Description
CXTPCalendarThemeIntValue | Default object constructor.
CXTPCalendarThemeIntValue Methods
CXTPCalendarThemeIntValue Methods | Description
DoPX_Value | This method reads or writes value data from or to an storage.
CXTPCalendarThemeIntValue Operators
CXTPCalendarThemeIntValue Operators | Description
= | This member operator is use to set custom value.


CXTPCalendarThemeIntValue Methods

CXTPCalendarThemeIntValue Class, Legend, Public Methods
CXTPCalendarThemeIntValue Methods
Class

CXTPCalendarThemeIntValue Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPX_Value | This method reads or writes value data from or to an storage.


CXTPCalendarThemeIntValue::DoPX_Value Method

CXTPCalendarThemeIntValue Methods, CXTPCalendarThemeIntValue Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeIntValue::DoPX_Value Method

This method reads or writes value data from or to an storage.

virtual void DoPX_Value(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    int& rXValue,
    BOOL bStandard
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
pcszPropName
A value name.
rXValue
Reference to value.
bStandard
Standard or Custom value.

See Also

DoPropExchange()

Body Source
virtual void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, int& rXValue, BOOL bStandard) {
    if (pPX->IsStoring())
    {
        if (bStandard && !m_bIsStandardSet ||
            !bStandard && !m_bIsCustomSet)
        {
            rXValue = 0;
        }
    }
    PX_Int(pPX, pcszPropName, rXValue);
}
Group

CXTPCalendarThemeIntValue Methods


CXTPCalendarThemeIntValue Constructors

CXTPCalendarThemeIntValue Class, Legend, Public Methods
CXTPCalendarThemeIntValue Constructors
Class

CXTPCalendarThemeIntValue Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeIntValue | Default object constructor.


CXTPCalendarThemeIntValue::CXTPCalendarThemeIntValue Constructor

CXTPCalendarThemeIntValue Constructors, CXTPCalendarThemeIntValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeIntValue::CXTPCalendarThemeIntValue Constructor

Default object constructor.

CXTPCalendarThemeIntValue();
Body Source
CXTPCalendarThemeIntValue()
{
    m_ValueStandard = m_ValueCustom = 0;
}
Group

CXTPCalendarThemeIntValue Constructors


CXTPCalendarThemeIntValue Operators

CXTPCalendarThemeIntValue Class, Legend, Public Operators
CXTPCalendarThemeIntValue Operators
Class

CXTPCalendarThemeIntValue Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This member operator is use to set custom value.


CXTPCalendarThemeIntValue::= Operator

CXTPCalendarThemeIntValue Operators, CXTPCalendarThemeIntValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeIntValue::= Operator

This member operator is use to set custom value.

const CXTPCalendarThemeIntValue& operator =(
    int nValue
);
Parameters

nValue
A new custom value.

Returns

Reference to this object.

Body Source
const CXTPCalendarThemeIntValue& operator=(int nValue) {
    SetCustomValue(nValue);
    return *this;
}
Group

CXTPCalendarThemeIntValue Operators


CXTPCalendarThemeRectValue Class

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarThemeRectValue Methods, CXTPCalendarThemeRectValue Constructors, CXTPCalendarThemeRectValue Operators, CXTPCalendarThemeRectValue Constructors, CXTPCalendarThemeRectValue Methods, CXTPCalendarThemeRectValue Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeRectValue Class

Helper class provides functionality to manage customized CRect value objects.

Class Hierarchy

class CXTPCalendarThemeRectValue : public CXTPCalendarThemeCustomizableXValueT<CRect, CRect>;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Method
virtual
Operator
CXTPCalendarThemeRectValue Constructors
CXTPCalendarThemeRectValue Constructors | Description
CXTPCalendarThemeRectValue | Default object constructor.
CXTPCalendarThemeRectValue Methods
CXTPCalendarThemeRectValue Methods | Description
DoPX_Value | This method reads or writes value data from or to an storage.
CXTPCalendarThemeRectValue Operators
CXTPCalendarThemeRectValue Operators | Description
= | This member operator is use to set custom value.


CXTPCalendarThemeRectValue Methods

CXTPCalendarThemeRectValue Class, Legend, Public Methods
CXTPCalendarThemeRectValue Methods
Class

CXTPCalendarThemeRectValue Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPX_Value | This method reads or writes value data from or to an storage.


CXTPCalendarThemeRectValue::DoPX_Value Method

CXTPCalendarThemeRectValue Methods, CXTPCalendarThemeRectValue Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeRectValue::DoPX_Value Method

This method reads or writes value data from or to an storage.

virtual void DoPX_Value(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    CRect& rXValue,
    BOOL bStandard
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
pcszPropName
A value name.
rXValue
Reference to value.
bStandard
Standard or Custom value.

See Also

DoPropExchange()

Body Source
virtual void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, CRect& rXValue, BOOL bStandard) {
    const CRect crcZero(0, 0, 0, 0);
    if (pPX->IsStoring())
    {
        if (bStandard && !m_bIsStandardSet ||
            !bStandard && !m_bIsCustomSet)
        {
            rXValue = crcZero;
        }
    }

    PX_Rect(pPX, pcszPropName, rXValue, crcZero);
}
Group

CXTPCalendarThemeRectValue Methods


CXTPCalendarThemeRectValue Constructors

CXTPCalendarThemeRectValue Class, Legend, Public Methods
CXTPCalendarThemeRectValue Constructors
Class

CXTPCalendarThemeRectValue Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeRectValue | Default object constructor.


CXTPCalendarThemeRectValue::CXTPCalendarThemeRectValue Constructor

CXTPCalendarThemeRectValue Constructors, CXTPCalendarThemeRectValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeRectValue::CXTPCalendarThemeRectValue Constructor

Default object constructor.

CXTPCalendarThemeRectValue();
Body Source
CXTPCalendarThemeRectValue()
{
    m_ValueStandard = m_ValueCustom = CRect(0, 0, 0, 0);
}
Group

CXTPCalendarThemeRectValue Constructors


CXTPCalendarThemeRectValue Operators

CXTPCalendarThemeRectValue Class, Legend, Public Operators
CXTPCalendarThemeRectValue Operators
Class

CXTPCalendarThemeRectValue Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This member operator is use to set custom value.


CXTPCalendarThemeRectValue::= Operator

CXTPCalendarThemeRectValue Operators, CXTPCalendarThemeRectValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeRectValue::= Operator

This member operator is use to set custom value.

const CXTPCalendarThemeRectValue& operator =(
    const CRect& rcValue
);
Parameters

rcValue
A new custom value.

Returns

Reference to this object.

Body Source
const CXTPCalendarThemeRectValue& operator=(const CRect& rcValue) {
    SetCustomValue((CRect&)rcValue);
    return *this;
}
Group

CXTPCalendarThemeRectValue Operators


CXTPCalendarThemeStringValue Class

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarThemeStringValue Methods, CXTPCalendarThemeStringValue Constructors, CXTPCalendarThemeStringValue Operators, CXTPCalendarThemeStringValue Constructors, CXTPCalendarThemeStringValue Methods, CXTPCalendarThemeStringValue Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeStringValue Class

Helper class provides functionality to manage customized string value objects.

Class Hierarchy

class CXTPCalendarThemeStringValue : public CXTPCalendarThemeCustomizableXValueT<CString, LPCTSTR>;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Method
protected
virtual
Operator
CXTPCalendarThemeStringValue Constructors
CXTPCalendarThemeStringValue Constructors | Description
CXTPCalendarThemeStringValue | Default constructor.
CXTPCalendarThemeStringValue Methods
CXTPCalendarThemeStringValue Methods | Description
DoDestroy | This member operator is use to destroy/clear value dada.
DoPX_Value | This method reads or writes value data from or to an storage.
CXTPCalendarThemeStringValue Operators
CXTPCalendarThemeStringValue Operators | Description
= | This member operator is use to set custom value.
const CString& | This member operator is use to get current value.


CXTPCalendarThemeStringValue Methods

CXTPCalendarThemeStringValue Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeStringValue Methods
Class

CXTPCalendarThemeStringValue Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DoDestroy | This member operator is use to destroy/clear value dada.
DoPX_Value | This method reads or writes value data from or to an storage.


CXTPCalendarThemeStringValue::DoDestroy Method

CXTPCalendarThemeStringValue Methods, CXTPCalendarThemeStringValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeStringValue::DoDestroy Method

This member operator is use to destroy/clear value dada.

virtual void DoDestroy(
    CString& refValue
);
Parameters

refValue
A value reference to destroy/clear data.

Body Source
virtual void DoDestroy(CString& refValue) {
    refValue.Empty();
}
Group

CXTPCalendarThemeStringValue Methods


CXTPCalendarThemeStringValue::DoPX_Value Method

CXTPCalendarThemeStringValue Methods, CXTPCalendarThemeStringValue Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeStringValue::DoPX_Value Method

This method reads or writes value data from or to an storage.

virtual void DoPX_Value(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    CString& rXValue,
    BOOL bStandard
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
pcszPropName
A value name.
rXValue
Reference to value.
bStandard
Standard or Custom value.

See Also

DoPropExchange()

Body Source
virtual void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, CString& rXValue, BOOL bStandard)
{
    if (pPX->IsStoring())
    {
        if (bStandard && !m_bIsStandardSet ||
            !bStandard && !m_bIsCustomSet)
        {
            rXValue.Empty();
        }
    }
    PX_String(pPX, pcszPropName, rXValue);
}
Group

CXTPCalendarThemeStringValue Methods


CXTPCalendarThemeStringValue Constructors

CXTPCalendarThemeStringValue Class, Legend, Public Methods
CXTPCalendarThemeStringValue Constructors
Class

CXTPCalendarThemeStringValue Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeStringValue | Default constructor.


CXTPCalendarThemeStringValue::CXTPCalendarThemeStringValue Constructor

CXTPCalendarThemeStringValue Constructors, CXTPCalendarThemeStringValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeStringValue::CXTPCalendarThemeStringValue Constructor

Default constructor.

CXTPCalendarThemeStringValue();
Body Source
CXTPCalendarThemeStringValue()
{
    m_bAutoDestroy_Standard = m_bAutoDestroy_Custom = TRUE;
}
Group

CXTPCalendarThemeStringValue Constructors


CXTPCalendarThemeStringValue Operators

CXTPCalendarThemeStringValue Class, Legend, Public Operators
CXTPCalendarThemeStringValue Operators
Class

CXTPCalendarThemeStringValue Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This member operator is use to set custom value.
const CString& | This member operator is use to get current value.


CXTPCalendarThemeStringValue::= Operator

CXTPCalendarThemeStringValue Operators, CXTPCalendarThemeStringValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeStringValue::= Operator

This member operator is use to set custom value.

const CXTPCalendarThemeStringValue& operator =(
    LPCTSTR pcszValue
);
Parameters

pcszValue
A new custom value.

Returns

Reference to this object.

Body Source
const CXTPCalendarThemeStringValue& operator=(LPCTSTR pcszValue) {
    SetCustomValue(pcszValue);
    return *this;
}
Group

CXTPCalendarThemeStringValue Operators


CXTPCalendarThemeStringValue::const CString& Operator

CXTPCalendarThemeStringValue Operators, CXTPCalendarThemeStringValue Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarThemeStringValue::const CString& Operator

This member operator is use to get current value.

operator const CString&() const;
Returns

A pointer to the current value.

Remarks

The default value is used if the custom value is not set. Otherwise, a custom value is used.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue, GetValue

Example

See example for SetCustomValue.

Body Source
operator const CString&() const {
    return GetValueX();
}
Group

CXTPCalendarThemeStringValue Operators


CXTPCalendarTimeScalePropertiesDlg Class

XTPCalendarDayViewTimeScale.h, Classes, Legend, Members, Topics, CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Constructors, CXTPCalendarTimeScalePropertiesDlg Constructors, CXTPCalendarTimeScalePropertiesDlg Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg Class

CXTPCalendarTimeScalePropertiesDlg dialog

This dialog allows to customize Calendar Time Scale part, set a proper time zone and it's description.

Class Hierarchy

class CXTPCalendarTimeScalePropertiesDlg : public CDialog;
File

XTPCalendarDayViewTimeScale.h

Group

Classes

Legend
Data Member
protected
Constructor
CXTPCalendarTimeScalePropertiesDlg Constructors
CXTPCalendarTimeScalePropertiesDlg Constructors | Description
CXTPCalendarTimeScalePropertiesDlg | Dialog class constructor.
CXTPCalendarTimeScalePropertiesDlg Data Members
CXTPCalendarTimeScalePropertiesDlg Data Members | Description
m_arTimeZones | A collection of timezones.
m_bAutoAdjustDayLight2 | A BOOL member which used to edit 'Auto Adjust Day Light' option for additional timezone
m_bShowScale2 | in, out] Store is additional timescale used or not.
m_btnAutoAdjustDayLight1 | A check box control to show 'Auto Adjust Day Light' option for main timezone
m_btnAutoAdjustDayLight2 | A check box control to edit 'Auto Adjust Day Light' option for additional timezone
m_cmbZones1 | A combobox to display main time zone
m_cmbZones2 | A combobox to edit additional time zone
m_edtCaption1 | An edit control for main time zone caption
m_edtCaption2 | An edit control for additional time zone caption
m_strCaption1 | in, out] Store Caption string for main timescale.
m_strCaption2 | in, out] Store Caption string for additional timescale.
m_tziScale2 | in, out] Store additional timescale data.


CXTPCalendarTimeScalePropertiesDlg Data Members

CXTPCalendarTimeScalePropertiesDlg Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg Data Members
Class

CXTPCalendarTimeScalePropertiesDlg Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arTimeZones | A collection of timezones.
m_bAutoAdjustDayLight2 | A BOOL member which used to edit 'Auto Adjust Day Light' option for additional timezone
m_btnAutoAdjustDayLight1 | A check box control to show 'Auto Adjust Day Light' option for main timezone
m_btnAutoAdjustDayLight2 | A check box control to edit 'Auto Adjust Day Light' option for additional timezone
m_cmbZones1 | A combobox to display main time zone
m_cmbZones2 | A combobox to edit additional time zone
m_edtCaption1 | An edit control for main time zone caption
m_edtCaption2 | An edit control for additional time zone caption
Public Data Members
Public Data Member | Description
m_bShowScale2 | in, out] Store is additional timescale used or not.
m_strCaption1 | in, out] Store Caption string for main timescale.
m_strCaption2 | in, out] Store Caption string for additional timescale.
m_tziScale2 | in, out] Store additional timescale data.


CXTPCalendarTimeScalePropertiesDlg::m_arTimeZones Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_arTimeZones Data Member

A collection of timezones.

CXTPCalendarTimeZones m_arTimeZones;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_bAutoAdjustDayLight2 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_bAutoAdjustDayLight2 Data Member

A BOOL member which used to edit 'Auto Adjust Day Light' option for additional timezone

BOOL m_bAutoAdjustDayLight2;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_bShowScale2 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_bShowScale2 Data Member

in, out] Store is additional timescale used or not.

BOOL m_bShowScale2;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_btnAutoAdjustDayLight1 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_btnAutoAdjustDayLight1 Data Member

A check box control to show 'Auto Adjust Day Light' option for main timezone

CButton m_btnAutoAdjustDayLight1;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_btnAutoAdjustDayLight2 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_btnAutoAdjustDayLight2 Data Member

A check box control to edit 'Auto Adjust Day Light' option for additional timezone

CButton m_btnAutoAdjustDayLight2;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_cmbZones1 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_cmbZones1 Data Member

A combobox to display main time zone

CComboBox m_cmbZones1;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_cmbZones2 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_cmbZones2 Data Member

A combobox to edit additional time zone

CComboBox m_cmbZones2;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_edtCaption1 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_edtCaption1 Data Member

An edit control for main time zone caption

CEdit m_edtCaption1;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_edtCaption2 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_edtCaption2 Data Member

An edit control for additional time zone caption

CEdit m_edtCaption2;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_strCaption1 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_strCaption1 Data Member

in, out] Store Caption string for main timescale.

CString m_strCaption1;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_strCaption2 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_strCaption2 Data Member

in, out] Store Caption string for additional timescale.

CString m_strCaption2;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg::m_tziScale2 Data Member

CXTPCalendarTimeScalePropertiesDlg Data Members, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::m_tziScale2 Data Member

in, out] Store additional timescale data.

TIME_ZONE_INFORMATION m_tziScale2;
Group

CXTPCalendarTimeScalePropertiesDlg Data Members


CXTPCalendarTimeScalePropertiesDlg Constructors

CXTPCalendarTimeScalePropertiesDlg Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg Constructors
Class

CXTPCalendarTimeScalePropertiesDlg Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTimeScalePropertiesDlg | Dialog class constructor.


CXTPCalendarTimeScalePropertiesDlg::CXTPCalendarTimeScalePropertiesDlg Constructor

CXTPCalendarTimeScalePropertiesDlg Constructors, CXTPCalendarTimeScalePropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeScalePropertiesDlg::CXTPCalendarTimeScalePropertiesDlg Constructor

Dialog class constructor.

CXTPCalendarTimeScalePropertiesDlg(
    CWnd* pParent = NULL,
    UINT nIDTemplate = CXTPCalendarTimeScalePropertiesDlg::IDD
);
Parameters

pParent
[in] Pointer to parent window. Can be NULL.
nIDTemplate
[in] Contains the ID number of a dialog-box template resource.

Group

CXTPCalendarTimeScalePropertiesDlg Constructors


CXTPCalendarTimeZone Class

XTPCalendarTimeZoneHelper.h, Classes, Legend, Members, Topics, CXTPCalendarTimeZone Data Members, CXTPCalendarTimeZone Methods, CXTPCalendarTimeZone Constructors, CXTPCalendarTimeZone Destructors, CXTPCalendarTimeZone Operators, CXTPCalendarTimeZone Constructors, CXTPCalendarTimeZone Data Members, CXTPCalendarTimeZone Destructors, CXTPCalendarTimeZone Methods, CXTPCalendarTimeZone Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZone Class

This class extend TIME_ZONE_INFORMATION structure.

Class Hierarchy

class CXTPCalendarTimeZone : public TIME_ZONE_INFORMATION;
File

XTPCalendarTimeZoneHelper.h

Remarks

It has additional data members to represent full information about time zone. Also it implements some helper functions and OLE interface methods.

See Also

TIME_ZONE_INFORMATION, CXTPCalendarTimeZones. MSDN Articles: INFO: Retrieving Time-Zone Information KB115231, Q115231

HOWTO: Change Time Zone Information Using Visual Basic KB221542, Q221542

Group

Classes

Legend
Data Member
protected
Method
virtual
Operator
CXTPCalendarTimeZone Constructors
CXTPCalendarTimeZone Constructors | Description
CXTPCalendarTimeZone |
CXTPCalendarTimeZone Data Members
CXTPCalendarTimeZone Data Members | Description
m_dwIndex | A time zone order index stored value.
m_strDisplayString | A time zone display string stored value.
CXTPCalendarTimeZone Destructors
CXTPCalendarTimeZone Destructors | Description
~CXTPCalendarTimeZone | Default object destructor.
CXTPCalendarTimeZone Methods
CXTPCalendarTimeZone Methods | Description
GetDisplayString | Get a time zone display string value.
GetIndex | Get a time zone order index value.
GetTimeZoneInfo | Get full information about the specified time zone.
IsEqual | Compare 2 time zones data.
CXTPCalendarTimeZone Operators
CXTPCalendarTimeZone Operators | Description
= | Copy operator.


CXTPCalendarTimeZone Data Members

CXTPCalendarTimeZone Class, Legend, Protected Data Members
CXTPCalendarTimeZone Data Members
Class

CXTPCalendarTimeZone Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dwIndex | A time zone order index stored value.
m_strDisplayString | A time zone display string stored value.


CXTPCalendarTimeZone::m_dwIndex Data Member

CXTPCalendarTimeZone Data Members, CXTPCalendarTimeZone Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZone::m_dwIndex Data Member

A time zone order index stored value.

DWORD m_dwIndex;
Group

CXTPCalendarTimeZone Data Members


CXTPCalendarTimeZone::m_strDisplayString Data Member

CXTPCalendarTimeZone Data Members, CXTPCalendarTimeZone Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZone::m_strDisplayString Data Member

A time zone display string stored value.

CString m_strDisplayString;
Group

CXTPCalendarTimeZone Data Members


CXTPCalendarTimeZone Methods

CXTPCalendarTimeZone Class, Legend, Public Methods
CXTPCalendarTimeZone Methods
Class

CXTPCalendarTimeZone Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetDisplayString | Get a time zone display string value.
GetIndex | Get a time zone order index value.
GetTimeZoneInfo | Get full information about the specified time zone.
IsEqual | Compare 2 time zones data.


CXTPCalendarTimeZone::GetDisplayString Method

CXTPCalendarTimeZone Methods, CXTPCalendarTimeZone Class
CXTPCalendarTimeZone::GetDisplayString Method

Get a time zone display string value.

CString GetDisplayString() const;
Returns

A string value like: "(GMT+02:00) Athens, Beirut, Istanbul, Minsk"

Group

CXTPCalendarTimeZone Methods


CXTPCalendarTimeZone::GetIndex Method

CXTPCalendarTimeZone Methods, CXTPCalendarTimeZone Class
CXTPCalendarTimeZone::GetIndex Method

Get a time zone order index value.

DWORD GetIndex() const;
Returns

A time zone order index value.

Remarks

This index value is used to sort time zones in the right order.

Group

CXTPCalendarTimeZone Methods


CXTPCalendarTimeZone::GetTimeZoneInfo Method

CXTPCalendarTimeZone Methods, CXTPCalendarTimeZone Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZone::GetTimeZoneInfo Method

Get full information about the specified time zone.

static CXTPCalendarTimeZonePtr GetTimeZoneInfo(
    const TIME_ZONE_INFORMATION* pTZIdata
);
Parameters

pTZIdata
Pointer to a time zone data object.

Returns

A smart pointer to CXTPCalendarTimeZone object.

Remarks

Retrieve additional information from the registry.

See Also

CXTPCalendarTimeZones

Group

CXTPCalendarTimeZone Methods


CXTPCalendarTimeZone::IsEqual Method

CXTPCalendarTimeZone Methods, CXTPCalendarTimeZone Class
CXTPCalendarTimeZone::IsEqual Method

Compare 2 time zones data.

BOOL IsEqual(
    const TIME_ZONE_INFORMATION* pTZI2
) const;
Parameters

pTZI2
Points to a TIME_ZONE_INFORMATION object.

Returns

TRUE - if time zones data related to the same time zone, otherwise - FALSE.

Group

CXTPCalendarTimeZone Methods


CXTPCalendarTimeZone Constructors

CXTPCalendarTimeZone Class, Legend, Public Methods
CXTPCalendarTimeZone Constructors
Class

CXTPCalendarTimeZone Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTimeZone |


CXTPCalendarTimeZone Constructor

CXTPCalendarTimeZone Constructors
CXTPCalendarTimeZone Constructor
Overload List
Constructors
Constructor | Description
CXTPCalendarTimeZone::CXTPCalendarTimeZone (const CXTPCalendarTimeZone*) | Default object constructor.
CXTPCalendarTimeZone::CXTPCalendarTimeZone (const TIME_ZONE_INFORMATION*) | Default object constructor.
Group

CXTPCalendarTimeZone Constructors


CXTPCalendarTimeZone::CXTPCalendarTimeZone Constructor (const TIME_ZONE_INFORMATION*)

CXTPCalendarTimeZone Constructor, CXTPCalendarTimeZone Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZone::CXTPCalendarTimeZone Constructor (const TIME_ZONE_INFORMATION*)

Default object constructor.

CXTPCalendarTimeZone(
    const TIME_ZONE_INFORMATION* pTZInfo = NULL
);
CXTPCalendarTimeZone(
    const CXTPCalendarTimeZone* pTZInfoEx
);
Parameters

pTZInfo
Pointer to a TIME_ZONE_INFORMATION data to initialize created object data.
pTZInfoEx
Pointer to a source data object.

See Also

~CXTPCalendarTimeZone(), TIME_ZONE_INFORMATION

Group

CXTPCalendarTimeZone Constructor


CXTPCalendarTimeZone Destructors

CXTPCalendarTimeZone Class, Legend, Public Methods
CXTPCalendarTimeZone Destructors
Class

CXTPCalendarTimeZone Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarTimeZone | Default object destructor.


CXTPCalendarTimeZone::~CXTPCalendarTimeZone Destructor

CXTPCalendarTimeZone Destructors, CXTPCalendarTimeZone Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZone::~CXTPCalendarTimeZone Destructor

Default object destructor.

virtual ~CXTPCalendarTimeZone();
See Also

CXTPCalendarTimeZone()

Group

CXTPCalendarTimeZone Destructors


CXTPCalendarTimeZone Operators

CXTPCalendarTimeZone Class, Legend, Public Operators
CXTPCalendarTimeZone Operators
Class

CXTPCalendarTimeZone Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Copy operator.


CXTPCalendarTimeZone::= Operator

CXTPCalendarTimeZone Operators, CXTPCalendarTimeZone Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZone::= Operator

Copy operator.

const CXTPCalendarTimeZone& operator =(
    const CXTPCalendarTimeZone& rTZInfo
);
Parameters

rTZInfo
Pointer to a source data object.

Returns

A Constant reference to updated object

See Also

CXTPCalendarTimeZone()

Group

CXTPCalendarTimeZone Operators


CXTPCalendarTimeZones Class

XTPCalendarTimeZoneHelper.h, Classes, Legend, Members, Topics, CXTPCalendarTimeZones Structures, CXTPCalendarTimeZones Data Members, CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Constructors, CXTPCalendarTimeZones Destructors, CXTPCalendarTimeZones Constructors, CXTPCalendarTimeZones Data Members, CXTPCalendarTimeZones Destructors, CXTPCalendarTimeZones Methods, See Also, CXTPCalendarTimeZones Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones Class

This class represents a simple array collection of CXTPCalendarTimeZone objects.

Class Hierarchy

class CXTPCalendarTimeZones;
File

XTPCalendarTimeZoneHelper.h

Remarks

Array indexes always start at position 0. An InitFromRegistry() method is used to read all time zones from the registry and add them to the collection. Also it implements some helper functions and OLE interface methods.

See Also

TIME_ZONE_INFORMATION, CXTPCalendarTimeZone. MSDN Articles: INFO: Retrieving Time-Zone Information KB115231, Q115231

HOWTO: Change Time Zone Information Using Visual Basic KB221542, Q221542

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTPCalendarTimeZones Constructors
CXTPCalendarTimeZones Constructors | Description
CXTPCalendarTimeZones | Default object constructor.
CXTPCalendarTimeZones Data Members
CXTPCalendarTimeZones Data Members | Description
m_arTZInfo | Collection to store CXTPCalendarTimeZone object pointers;
CXTPCalendarTimeZones Destructors
CXTPCalendarTimeZones Destructors | Description
~CXTPCalendarTimeZones | Default object destructor.
CXTPCalendarTimeZones Methods
CXTPCalendarTimeZones Methods | Description
Find | This method is used to find a time zone information using the specified time zone data.
GetAt | Call this method to get an element at the specified numeric index.
GetCount | This member function is used to obtain the number of elements in this collection.
GetRegBSTR | This method is used to read a UNICODE string value from the registry.
GetRegDWORD | This method is used to read a DWORD value from the registry.
GetRegStr | This method is used to read a string value from the registry.
GetRegTZI | This method is used to read a time zone information stored as binary value in the registry.
InitFromRegistry | Read all time zones from the registry and add them to the collection.
CXTPCalendarTimeZones Structures
CXTPCalendarTimeZones Structures | Description
REGISTRY_TIMEZONE_INFORMATION | This structure represents format of binary data stored in the "TZI" registry key.


CXTPCalendarTimeZones Structures

CXTPCalendarTimeZones Class, Legend, Structures
CXTPCalendarTimeZones Structures
Class

CXTPCalendarTimeZones Class

Legend
Structure
Structures
Structure | Description
REGISTRY_TIMEZONE_INFORMATION | This structure represents format of binary data stored in the "TZI" registry key.


CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION Structure

XTPCalendarTimeZoneHelper.h, CXTPCalendarTimeZones Structures, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION Structure

This structure represents format of binary data stored in the "TZI" registry key.

struct REGISTRY_TIMEZONE_INFORMATION {
  LONG Bias;
  LONG StandardBias;
  LONG DaylightBias;
  SYSTEMTIME StandardDate;
  SYSTEMTIME DaylightDate;
};
File

XTPCalendarTimeZoneHelper.h

Members

Bias
Current bias for local time translation on this computer, in minutes.
StandardBias
Bias value to be used during local time translations that occur during standard time.
DaylightBias
Bias value to be used during local time translations that occur during daylight saving time.
StandardDate
A SYSTEMTIME structure that contains a date and local time when the transition from daylight saving time to standard time occurs on this operating system.
DaylightDate
A SYSTEMTIME structure that contains a date and local time when the transition from standard time to daylight saving time occurs on this operating system.

See Also

Microsoft KB115231, TIME_ZONE_INFORMATION, XTP_CALENDAR_TZIRegValName_DATA, XTP_CALENDAR_TIMEZONESKEY_NT, XTP_CALENDAR_TIMEZONESKEY_9X

Group

CXTPCalendarTimeZones Structures


CXTPCalendarTimeZones Data Members

CXTPCalendarTimeZones Class, Legend, Protected Data Members
CXTPCalendarTimeZones Data Members
Class

CXTPCalendarTimeZones Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arTZInfo | Collection to store CXTPCalendarTimeZone object pointers;


CXTPCalendarTimeZones::m_arTZInfo Data Member

CXTPCalendarTimeZones Data Members, CXTPCalendarTimeZones Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones::m_arTZInfo Data Member

Collection to store CXTPCalendarTimeZone object pointers;

CXTPCalendarPtrCollectionT<CXTPCalendarTimeZone> m_arTZInfo;
Group

CXTPCalendarTimeZones Data Members


CXTPCalendarTimeZones Methods

CXTPCalendarTimeZones Class, Legend, Public Methods
CXTPCalendarTimeZones Methods
Class

CXTPCalendarTimeZones Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Find | This method is used to find a time zone information using the specified time zone data.
GetAt | Call this method to get an element at the specified numeric index.
GetCount | This member function is used to obtain the number of elements in this collection.
GetRegBSTR | This method is used to read a UNICODE string value from the registry.
GetRegDWORD | This method is used to read a DWORD value from the registry.
GetRegStr | This method is used to read a string value from the registry.
GetRegTZI | This method is used to read a time zone information stored as binary value in the registry.
InitFromRegistry | Read all time zones from the registry and add them to the collection.


CXTPCalendarTimeZones::Find Method

CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Class
CXTPCalendarTimeZones::Find Method

This method is used to find a time zone information using the specified time zone data.

CXTPCalendarTimeZone* Find(
    const TIME_ZONE_INFORMATION* pTZI2
) const;
Parameters

pTZI2
Pointer to a time zone data object.

Returns

The pointer to the first object in the collection that matches the requested time zone. NULL if the such object is not found.

Group

CXTPCalendarTimeZones Methods


CXTPCalendarTimeZones::GetAt Method

CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones::GetAt Method

Call this method to get an element at the specified numeric index.

CXTPCalendarTimeZone* GetAt(
    long nIndex
) const;
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetCount.

Returns

The pointer to the CXTPCalendarTimeZone element currently at this index.

See Also

GetCount()

Group

CXTPCalendarTimeZones Methods


CXTPCalendarTimeZones::GetCount Method

CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones::GetCount Method

This member function is used to obtain the number of elements in this collection.

int GetCount() const;
Returns

An int that contains the number of items in the collection.

See Also

GetAt()

Group

CXTPCalendarTimeZones Methods


CXTPCalendarTimeZones::GetRegBSTR Method

CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones::GetRegBSTR Method

This method is used to read a UNICODE string value from the registry.

static BOOL GetRegBSTR(
    HKEY hKey,
    LPCWSTR pcszValueNameW,
    BSTR& rbstrValue
);
Parameters

hKey
[in] Parent key handle.
pcszValueNameW
[in] Value key name in the UNICODE format.
rbstrValue
[out] BSTR object reference to store value.

Returns

TRUE - if successful, otherwise - FALSE.

Remarks

It is used to get UNICODE strings without conversion to MBCS. If rbstrValue parameter is not NULL the SysFreeString() API function is called to erase value.

See Also

GetRegStr()

Group

CXTPCalendarTimeZones Methods


CXTPCalendarTimeZones::GetRegDWORD Method

CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Class
CXTPCalendarTimeZones::GetRegDWORD Method

This method is used to read a DWORD value from the registry.

static BOOL GetRegDWORD(
    HKEY hKey,
    LPCTSTR pcszValueName,
    DWORD& rdwValue
);
Parameters

hKey
[in] Parent key handle.
pcszValueName
[in] Value key name.
rdwValue
[out] DWORD variable reference to store value.

Returns

TRUE - if successful, otherwise - FALSE.

Group

CXTPCalendarTimeZones Methods


CXTPCalendarTimeZones::GetRegStr Method

CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones::GetRegStr Method

This method is used to read a string value from the registry.

static BOOL GetRegStr(
    HKEY hKey,
    LPCTSTR pcszValueName,
    CString& rstrValue
);
Parameters

hKey
[in] Parent key handle.
pcszValueName
[in] Value key name.
rstrValue
[out] CString object reference to store value.

Returns

TRUE - if successful, otherwise - FALSE.

See Also

GetRegBSTR()

Group

CXTPCalendarTimeZones Methods


CXTPCalendarTimeZones::GetRegTZI Method

CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Class
CXTPCalendarTimeZones::GetRegTZI Method

This method is used to read a time zone information stored as binary value in the registry.

static BOOL GetRegTZI(
    HKEY hKey,
    LPCTSTR pcszValueName,
    REGISTRY_TIMEZONE_INFORMATION& rRegTZI
);
Parameters

hKey
[in] Parent key handle.
pcszValueName
[in] Value key name.
rRegTZI
[out] REGISTRY_TIMEZONE_INFORMATION object reference to store value.

Returns

TRUE - if successful, otherwise - FALSE.

Group

CXTPCalendarTimeZones Methods


CXTPCalendarTimeZones::InitFromRegistry Method

CXTPCalendarTimeZones Methods, CXTPCalendarTimeZones Class
CXTPCalendarTimeZones::InitFromRegistry Method

Read all time zones from the registry and add them to the collection.

BOOL InitFromRegistry();
Returns

TRUE - if all time zones where successfully read, otherwise - FALSE.

Group

CXTPCalendarTimeZones Methods


CXTPCalendarTimeZones Constructors

CXTPCalendarTimeZones Class, Legend, Public Methods
CXTPCalendarTimeZones Constructors
Class

CXTPCalendarTimeZones Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTimeZones | Default object constructor.


CXTPCalendarTimeZones::CXTPCalendarTimeZones Constructor

CXTPCalendarTimeZones Constructors, CXTPCalendarTimeZones Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones::CXTPCalendarTimeZones Constructor

Default object constructor.

CXTPCalendarTimeZones();
See Also

~CXTPCalendarTimeZones()

Group

CXTPCalendarTimeZones Constructors


CXTPCalendarTimeZones Destructors

CXTPCalendarTimeZones Class, Legend, Public Methods
CXTPCalendarTimeZones Destructors
Class

CXTPCalendarTimeZones Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarTimeZones | Default object destructor.


CXTPCalendarTimeZones::~CXTPCalendarTimeZones Destructor

CXTPCalendarTimeZones Destructors, CXTPCalendarTimeZones Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTimeZones::~CXTPCalendarTimeZones Destructor

Default object destructor.

virtual ~CXTPCalendarTimeZones();
See Also

CXTPCalendarTimeZones()

Group

CXTPCalendarTimeZones Destructors


CXTPCalendarTip Class

XTPCalendarTip.h, Classes, Legend, Members, Topics, CXTPCalendarTip Data Members, CXTPCalendarTip Methods, CXTPCalendarTip Constructors, CXTPCalendarTip Destructors, CXTPCalendarTip Constructors, CXTPCalendarTip Data Members, CXTPCalendarTip Destructors, CXTPCalendarTip Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTip Class

The CXTPCalendarTip class emulates the functionality of a "tool tip" control.

Class Hierarchy

class CXTPCalendarTip : public CWnd;
File

XTPCalendarTip.h

Remarks

The CXTPCalendarTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering over an item on the report area.

CXTPCalendarTip provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip.

This class is used by the report control internally.

See Also

CXTPCalendarControl

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarTip Constructors
CXTPCalendarTip Constructors | Description
CXTPCalendarTip | Constructs a CXTPCalendarTip object.
CXTPCalendarTip Data Members
CXTPCalendarTip Data Members | Description
m_bAdvancedMode | TRUE when advanced mode is on
m_pFont | Font for displaying tooltip text.
m_pParentWnd | Pointer to the parent report window.
m_pTheme | Pointer to associated Theme object
m_rcHover | Hover window coordinates.
m_strTooltipText | Tooltip text to display.
CXTPCalendarTip Destructors
CXTPCalendarTip Destructors | Description
~CXTPCalendarTip | Destroys a CXTPCalendarTip object and handles cleanup and de-allocation.
CXTPCalendarTip Methods
CXTPCalendarTip Methods | Description
Activate | Call this function to activate or deactivate a tool tip control.
CalcToolTipRect | This function is used to calculate tooltip rectangle.
Create | This member function is used to create a report tip window.
GetHoverRect | This function is used to obtain the coordinates of a tooltip hover rectangle.
GetTooltipText | This member function is used to obtain the tooltip text string.
IsAdvancedMode | This function is used to check whether advanced mode is enabled. Advanced mode means left mouse click handling.
SetAdvancedMode | This function is used to set advanced mode flag.
SetFont | This member function is used to set the tooltip text font.
SetHoverRect | This member function is used to set the coordinates of the tooltip hover rectangle.
SetTheme | This member function sets (or disable) the new control drawing theme.
SetTooltipText | This member function is used to set the new tooltip text.


CXTPCalendarTip Data Members

CXTPCalendarTip Class, Legend, Protected Data Members
CXTPCalendarTip Data Members
Class

CXTPCalendarTip Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAdvancedMode | TRUE when advanced mode is on
m_pFont | Font for displaying tooltip text.
m_pParentWnd | Pointer to the parent report window.
m_pTheme | Pointer to associated Theme object
m_rcHover | Hover window coordinates.
m_strTooltipText | Tooltip text to display.


CXTPCalendarTip::m_bAdvancedMode Data Member

CXTPCalendarTip Data Members, CXTPCalendarTip Class
CXTPCalendarTip::m_bAdvancedMode Data Member

TRUE when advanced mode is on

BOOL m_bAdvancedMode;
Group

CXTPCalendarTip Data Members


CXTPCalendarTip::m_pFont Data Member

CXTPCalendarTip Data Members, CXTPCalendarTip Class
CXTPCalendarTip::m_pFont Data Member

Font for displaying tooltip text.

CFont* m_pFont;
Group

CXTPCalendarTip Data Members


CXTPCalendarTip::m_pParentWnd Data Member

CXTPCalendarTip Data Members, CXTPCalendarTip Class
CXTPCalendarTip::m_pParentWnd Data Member

Pointer to the parent report window.

CWnd * m_pParentWnd;
Group

CXTPCalendarTip Data Members


CXTPCalendarTip::m_pTheme Data Member

CXTPCalendarTip Data Members, CXTPCalendarTip Class
CXTPCalendarTip::m_pTheme Data Member

Pointer to associated Theme object

CXTPCalendarTheme* m_pTheme;
Group

CXTPCalendarTip Data Members


CXTPCalendarTip::m_rcHover Data Member

CXTPCalendarTip Data Members, CXTPCalendarTip Class
CXTPCalendarTip::m_rcHover Data Member

Hover window coordinates.

CRect m_rcHover;
Group

CXTPCalendarTip Data Members


CXTPCalendarTip::m_strTooltipText Data Member

CXTPCalendarTip Data Members, CXTPCalendarTip Class
CXTPCalendarTip::m_strTooltipText Data Member

Tooltip text to display.

CString m_strTooltipText;
Group

CXTPCalendarTip Data Members


CXTPCalendarTip Methods

CXTPCalendarTip Class, Legend, Public Methods
CXTPCalendarTip Methods
Class

CXTPCalendarTip Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Activate | Call this function to activate or deactivate a tool tip control.
CalcToolTipRect | This function is used to calculate tooltip rectangle.
Create | This member function is used to create a report tip window.
GetHoverRect | This function is used to obtain the coordinates of a tooltip hover rectangle.
GetTooltipText | This member function is used to obtain the tooltip text string.
IsAdvancedMode | This function is used to check whether advanced mode is enabled. Advanced mode means left mouse click handling.
SetAdvancedMode | This function is used to set advanced mode flag.
SetFont | This member function is used to set the tooltip text font.
SetHoverRect | This member function is used to set the coordinates of the tooltip hover rectangle.
SetTheme | This member function sets (or disable) the new control drawing theme.
SetTooltipText | This member function is used to set the new tooltip text.


CXTPCalendarTip::Activate Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTip::Activate Method

Call this function to activate or deactivate a tool tip control.

void Activate(
    BOOL bActive,
    BOOL bAdvanced = FALSE
);
Parameters

bActive
A BOOL. Specifies whether the tool tip control is to be activated or deactivated.
bAdvanced
TRUE for advanced processing (Office2007 theme "add new appt")

Remarks

If bActivate is TRUE, the control is activated. If FALSE, it is deactivated.

When a tool tip control is active, the tool tip information appears when the cursor is on a tool that is registered with the control. When it is inactive, the tool tip information does not appear, even when the cursor is on a tool.

See Also

Create, CXTPCalendarTip::CXTPCalendarTip, SetTooltipText

Example

See Create method example.

Group

CXTPCalendarTip Methods


CXTPCalendarTip::CalcToolTipRect Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, See Also
CXTPCalendarTip::CalcToolTipRect Method

This function is used to calculate tooltip rectangle.

CSize CalcToolTipRect();
Returns

Size of the tooltip rectangle.

Remarks

Standard window DC and stored font and tooltip text are used.

See Also

SetTooltipText, SetFont.

Group

CXTPCalendarTip Methods


CXTPCalendarTip::Create Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTip::Create Method

This member function is used to create a report tip window.

virtual BOOL Create(
    CWnd* pParentWnd
);
Parameters

pParentWnd
A pointer to a CWnd that is the parent report control window.

Returns

TRUE if tip window is created successfully, FALSE otherwise.

Remarks

Construct an object in two steps. Call the constructor object and then call Create(), which initializes the window and attaches it to the parent window.

See Also

CXTPCalendarTip::CXTPCalendarTip, Activate

Example
void MyDialog::ShowToolTip(CRect rcTip, CXTPCalendarTip* pTipWnd)
{
    if (!pTipWnd->GetSafeHwnd())
    {
        pTipWnd->Create(this);
    }
    pTipWnd->SetHoverRect(rcTip);
    pTipWnd->Activate(TRUE);
}
Group

CXTPCalendarTip Methods


CXTPCalendarTip::GetHoverRect Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTip::GetHoverRect Method

This function is used to obtain the coordinates of a tooltip hover rectangle.

CRect GetHoverRect();
Returns

The coordinates of the tooltip hover rectangle in parent window coordinates.

See Also

SetHoverRect

Body Source
CRect CXTPCalendarTip::GetHoverRect() {
    return m_rcHover;
}
Group

CXTPCalendarTip Methods


CXTPCalendarTip::GetTooltipText Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTip::GetTooltipText Method

This member function is used to obtain the tooltip text string.

CString GetTooltipText();
Returns

A CString that contains the current tooltip text.

See Also

SetTooltipText

Body Source
CString CXTPCalendarTip::GetTooltipText() {
    return m_strTooltipText;
}
Group

CXTPCalendarTip Methods


CXTPCalendarTip::IsAdvancedMode Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Body Source
CXTPCalendarTip::IsAdvancedMode Method

This function is used to check whether advanced mode is enabled. Advanced mode means left mouse click handling.

BOOL IsAdvancedMode();
Returns

TRUE when advanced mode enabled (left mouse click handling).

Body Source
BOOL CXTPCalendarTip::IsAdvancedMode() {
    return m_bAdvancedMode;
}
Group

CXTPCalendarTip Methods


CXTPCalendarTip::SetAdvancedMode Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Body Source
CXTPCalendarTip::SetAdvancedMode Method

This function is used to set advanced mode flag.

void SetAdvancedMode(
    BOOL bMode = TRUE
);
Body Source
void CXTPCalendarTip::SetAdvancedMode(BOOL bMode) {
    m_bAdvancedMode = bMode;
}
Group

CXTPCalendarTip Methods


CXTPCalendarTip::SetFont Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Body Source
CXTPCalendarTip::SetFont Method

This member function is used to set the tooltip text font.

void SetFont(
    CFont* pFont
);
Parameters

pFont
A pointer to a CFont object that contains the new font.

Body Source
void CXTPCalendarTip::SetFont(CFont* pFont) {
    m_pFont = pFont;
}
Group

CXTPCalendarTip Methods


CXTPCalendarTip::SetHoverRect Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTip::SetHoverRect Method

This member function is used to set the coordinates of the tooltip hover rectangle.

void SetHoverRect(
    CRect rc
);
Parameters

rc
A CRect object that contains the new tooltip hover rectangle in the parent window coordinates.

Remarks

Called this member function before activating the tooltip window.

See Also

GetHoverRect

Body Source
void CXTPCalendarTip::SetHoverRect(CRect rc) {
    m_rcHover = rc;
    MoveWindow(rc);
}
Group

CXTPCalendarTip Methods


CXTPCalendarTip::SetTheme Method

CXTPCalendarTip Methods, CXTPCalendarTip Class
CXTPCalendarTip::SetTheme Method

This member function sets (or disable) the new control drawing theme.

void SetTheme(
    CXTPCalendarTheme* pTheme
);
Parameters

pTheme
A CXTPCalendarTheme pointer to the theme object. If pTheme is NULL - themes are disabled and regular painting is used.

Group

CXTPCalendarTip Methods


CXTPCalendarTip::SetTooltipText Method

CXTPCalendarTip Methods, CXTPCalendarTip Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTip::SetTooltipText Method

This member function is used to set the new tooltip text.

void SetTooltipText(
    LPCTSTR str
);
Parameters

str
An LPCSTR string that contains the new tooltip caption.

Remarks

Call this member function before activating the tooltip window.

See Also

GetTooltipText

Body Source
void CXTPCalendarTip::SetTooltipText(LPCTSTR str) {
    m_strTooltipText = str;
}
Group

CXTPCalendarTip Methods


CXTPCalendarTip Constructors

CXTPCalendarTip Class, Legend, Public Methods
CXTPCalendarTip Constructors
Class

CXTPCalendarTip Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTip | Constructs a CXTPCalendarTip object.


CXTPCalendarTip::CXTPCalendarTip Constructor

CXTPCalendarTip Constructors, CXTPCalendarTip Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTip::CXTPCalendarTip Constructor

Constructs a CXTPCalendarTip object.

CXTPCalendarTip();
Remarks

Construct a CXTPCalendarTip object in two steps. Call the constructor object and then call Create, which initializes the window and attaches it to the parent window.

See Also

CWnd, Create, Activate

Example
Declare a local CXTPCalendarTip object.
CXTPCalendarTip wndTip;

// Declare a dynamic CXTPCalendarTip object.
CXTPCalendarTip* pTipWnd = new CXTPCalendarTip;
Group

CXTPCalendarTip Constructors


CXTPCalendarTip Destructors

CXTPCalendarTip Class, Legend, Public Methods
CXTPCalendarTip Destructors
Class

CXTPCalendarTip Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarTip | Destroys a CXTPCalendarTip object and handles cleanup and de-allocation.


CXTPCalendarTip::~CXTPCalendarTip Destructor

CXTPCalendarTip Destructors, CXTPCalendarTip Class
CXTPCalendarTip::~CXTPCalendarTip Destructor

Destroys a CXTPCalendarTip object and handles cleanup and de-allocation.

virtual ~CXTPCalendarTip();
Group

CXTPCalendarTip Destructors


CXTPCalendarTypedPtrAutoDeleteArray Template

XTPCalendarPtrCollectionT.h, Classes, Legend, Members, Topics, CXTPCalendarTypedPtrAutoDeleteArray Methods, CXTPCalendarTypedPtrAutoDeleteArray Constructors, CXTPCalendarTypedPtrAutoDeleteArray Destructors, CXTPCalendarTypedPtrAutoDeleteArray Nested Types, CXTPCalendarTypedPtrAutoDeleteArray Constructors, CXTPCalendarTypedPtrAutoDeleteArray Destructors, CXTPCalendarTypedPtrAutoDeleteArray Methods, CXTPCalendarTypedPtrAutoDeleteArray Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray Template

This class represents a simple array collection of objects pointers.

Class Hierarchy

template <class BASE_CLASS, class PTR_TYPE>
class CXTPCalendarTypedPtrAutoDeleteArray : public CTypedPtrArray<BASE_CLASS, PTR_TYPE>;
File

XTPCalendarPtrCollectionT.h

Remarks

Parameters BASE_CLASS Base class of the typed pointer array class; must be an array class (CObArray or CPtrArray). PTR_TYPE Type of the elements stored in the base-class array.

Array indexes always start at position 0.

As with a C array, the access time for indexed element of this array is constant and is independent of the array size.

Overridden method RemoveAll() call delete operator for all not NULL elements before call RemoveAll() method from the base class.

RemoveAll() method is called from array destructor too.

See Also

CTypedPtrArray, CPtrArray, CObArray, CArray

Group

Classes

Legend
Method
virtual
CXTPCalendarTypedPtrAutoDeleteArray Constructors
CXTPCalendarTypedPtrAutoDeleteArray Constructors | Description
CXTPCalendarTypedPtrAutoDeleteArray | Default object constructor.
CXTPCalendarTypedPtrAutoDeleteArray Destructors
CXTPCalendarTypedPtrAutoDeleteArray Destructors | Description
~CXTPCalendarTypedPtrAutoDeleteArray | Default class destructor.
CXTPCalendarTypedPtrAutoDeleteArray Methods
CXTPCalendarTypedPtrAutoDeleteArray Methods | Description
RemoveAll | Removes all the elements from the array.
CXTPCalendarTypedPtrAutoDeleteArray Nested Types
CXTPCalendarTypedPtrAutoDeleteArray Nested Types | Description
TBase | Base class type definition


CXTPCalendarTypedPtrAutoDeleteArray Methods

CXTPCalendarTypedPtrAutoDeleteArray Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray Methods
Template

CXTPCalendarTypedPtrAutoDeleteArray Template

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RemoveAll | Removes all the elements from the array.


CXTPCalendarTypedPtrAutoDeleteArray::RemoveAll Method

CXTPCalendarTypedPtrAutoDeleteArray Methods, CXTPCalendarTypedPtrAutoDeleteArray Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray::RemoveAll Method

Removes all the elements from the array.

virtual void RemoveAll();
Remarks

Removes all the pointers from the array and deletes all stored objects.

Body Source
virtual void RemoveAll()
{
    for(int i = 0; i < GetSize(); i++)
    {
        PTR_TYPE pObj = GetAt(i);
        if (pObj) {
            delete pObj;
            SetAt(i, NULL);
        }
    }
    TBase::RemoveAll();
}
Group

CXTPCalendarTypedPtrAutoDeleteArray Methods


CXTPCalendarTypedPtrAutoDeleteArray Constructors

CXTPCalendarTypedPtrAutoDeleteArray Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray Constructors
Template

CXTPCalendarTypedPtrAutoDeleteArray Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTypedPtrAutoDeleteArray | Default object constructor.


CXTPCalendarTypedPtrAutoDeleteArray::CXTPCalendarTypedPtrAutoDeleteArray Constructor

CXTPCalendarTypedPtrAutoDeleteArray Constructors, CXTPCalendarTypedPtrAutoDeleteArray Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray::CXTPCalendarTypedPtrAutoDeleteArray Constructor

Default object constructor.

CXTPCalendarTypedPtrAutoDeleteArray();
Body Source
CXTPCalendarTypedPtrAutoDeleteArray() {}
Group

CXTPCalendarTypedPtrAutoDeleteArray Constructors


CXTPCalendarTypedPtrAutoDeleteArray Destructors

CXTPCalendarTypedPtrAutoDeleteArray Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray Destructors
Template

CXTPCalendarTypedPtrAutoDeleteArray Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarTypedPtrAutoDeleteArray | Default class destructor.


CXTPCalendarTypedPtrAutoDeleteArray::~CXTPCalendarTypedPtrAutoDeleteArray Destructor

CXTPCalendarTypedPtrAutoDeleteArray Destructors, CXTPCalendarTypedPtrAutoDeleteArray Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray::~CXTPCalendarTypedPtrAutoDeleteArray Destructor

Default class destructor.

virtual ~CXTPCalendarTypedPtrAutoDeleteArray();
Remarks

Handles member items deallocation.

Body Source
virtual ~CXTPCalendarTypedPtrAutoDeleteArray() {
    RemoveAll();
}
Group

CXTPCalendarTypedPtrAutoDeleteArray Destructors


CXTPCalendarTypedPtrAutoDeleteArray Nested Types

CXTPCalendarTypedPtrAutoDeleteArray Template, Public Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray Nested Types
Template

CXTPCalendarTypedPtrAutoDeleteArray Template

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition


CXTPCalendarTypedPtrAutoDeleteArray::TBase Nested Type

CXTPCalendarTypedPtrAutoDeleteArray Nested Types, CXTPCalendarTypedPtrAutoDeleteArray Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteArray::TBase Nested Type

Base class type definition

typedef CTypedPtrArray<BASE_CLASS, PTR_TYPE> TBase;
Group

CXTPCalendarTypedPtrAutoDeleteArray Nested Types


CXTPCalendarTypedPtrAutoDeleteMap Template

XTPCalendarPtrCollectionT.h, Classes, Legend, Members, Topics, CXTPCalendarTypedPtrAutoDeleteMap Methods, CXTPCalendarTypedPtrAutoDeleteMap Destructors, CXTPCalendarTypedPtrAutoDeleteMap Operators, CXTPCalendarTypedPtrAutoDeleteMap Destructors, CXTPCalendarTypedPtrAutoDeleteMap Methods, CXTPCalendarTypedPtrAutoDeleteMap Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap Template

This class represents a simple map of typed keys to typed objects pointers. Overridden methods SetAt, operator[], RemoveKey, RemoveAll, call delete for previously stored elements.

Class Hierarchy

template <class KEY, class TPtr>
class CXTPCalendarTypedPtrAutoDeleteMap : public CMap<KEY, KEY, TPtr, TPtr>;
File

XTPCalendarPtrCollectionT.h

Remarks

Parameters KEY class to key values. TPtr A pointer type of stored objects.

Overridden method RemoveAll() call delete operator for all not NULL spored elements before call RemoveAll() method from the base class.

RemoveAll() method is called from map destructor too.

See Also

CMap

Group

Classes

Legend
Method
virtual
Operator
CXTPCalendarTypedPtrAutoDeleteMap Destructors
CXTPCalendarTypedPtrAutoDeleteMap Destructors | Description
~CXTPCalendarTypedPtrAutoDeleteMap | Default class destructor.
CXTPCalendarTypedPtrAutoDeleteMap Methods
CXTPCalendarTypedPtrAutoDeleteMap Methods | Description
RemoveAll | Removes all the elements from the map.
RemoveKey | Removes element by it's key.
SetAt | Add a new (key, value) pair.
CXTPCalendarTypedPtrAutoDeleteMap Operators
CXTPCalendarTypedPtrAutoDeleteMap Operators | Description
[] | Lookup and add a new element if not there.


CXTPCalendarTypedPtrAutoDeleteMap Methods

CXTPCalendarTypedPtrAutoDeleteMap Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap Methods
Template

CXTPCalendarTypedPtrAutoDeleteMap Template

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RemoveAll | Removes all the elements from the map.
RemoveKey | Removes element by it's key.
SetAt | Add a new (key, value) pair.


CXTPCalendarTypedPtrAutoDeleteMap::RemoveAll Method

CXTPCalendarTypedPtrAutoDeleteMap Methods, CXTPCalendarTypedPtrAutoDeleteMap Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap::RemoveAll Method

Removes all the elements from the map.

virtual void RemoveAll(
    BOOL bDeletePtr = TRUE
);
Parameters

bDeletePtr
If TRUE, delete operator will be called for not null elements. Default value is TRUE.

Remarks

Removes all data from the map and deletes all stored objects if this specified by bDeletePtr parameter.

Body Source
virtual void RemoveAll(BOOL bDeletePtr = TRUE)
{
    if (bDeletePtr)
    {
        POSITION pos = GetStartPosition();
        while (pos)
        {
            KEY tmpKey;
            TPtr pValue = NULL;
            GetNextAssoc(pos, tmpKey, pValue);
            if (pValue)
                delete pValue;
        }
    }
    TBase::RemoveAll();
}
Group

CXTPCalendarTypedPtrAutoDeleteMap Methods


CXTPCalendarTypedPtrAutoDeleteMap::RemoveKey Method

CXTPCalendarTypedPtrAutoDeleteMap Methods, CXTPCalendarTypedPtrAutoDeleteMap Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap::RemoveKey Method

Removes element by it's key.

virtual BOOL RemoveKey(
    KEY key,
    BOOL bDeletePtr = TRUE
);
Parameters

key
A key.
bDeletePtr
If TRUE, delete operator will be called for not null element. Default value is TRUE.

Body Source
virtual BOOL RemoveKey(KEY key, BOOL bDeletePtr = TRUE)
{
    if (bDeletePtr)
        _DeletePtr(key);
    return TBase::RemoveKey(key);
}
Group

CXTPCalendarTypedPtrAutoDeleteMap Methods


CXTPCalendarTypedPtrAutoDeleteMap::SetAt Method

CXTPCalendarTypedPtrAutoDeleteMap Methods, CXTPCalendarTypedPtrAutoDeleteMap Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap::SetAt Method

Add a new (key, value) pair.

virtual void SetAt(
    KEY key,
    TPtr pValue,
    BOOL bDeletePrevPtr = TRUE
);
Parameters

key
A key.
pValue
A value.
bDeletePrevPtr
If TRUE, delete operator will be called for previous not null element.

Body Source
virtual void SetAt(KEY key, TPtr pValue, BOOL bDeletePrevPtr = TRUE)
{
    if (bDeletePrevPtr)
        _DeletePtr(key);
    TBase::SetAt(key, pValue);
}
Group

CXTPCalendarTypedPtrAutoDeleteMap Methods


CXTPCalendarTypedPtrAutoDeleteMap Destructors

CXTPCalendarTypedPtrAutoDeleteMap Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap Destructors
Template

CXTPCalendarTypedPtrAutoDeleteMap Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarTypedPtrAutoDeleteMap | Default class destructor.


CXTPCalendarTypedPtrAutoDeleteMap::~CXTPCalendarTypedPtrAutoDeleteMap Destructor

CXTPCalendarTypedPtrAutoDeleteMap Destructors, CXTPCalendarTypedPtrAutoDeleteMap Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap::~CXTPCalendarTypedPtrAutoDeleteMap Destructor

Default class destructor.

virtual ~CXTPCalendarTypedPtrAutoDeleteMap();
Remarks

Handles member items deallocation.

Body Source
virtual ~CXTPCalendarTypedPtrAutoDeleteMap()
{
    RemoveAll();
}
Group

CXTPCalendarTypedPtrAutoDeleteMap Destructors


CXTPCalendarTypedPtrAutoDeleteMap Operators

CXTPCalendarTypedPtrAutoDeleteMap Template, Legend, Public Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap Operators
Template

CXTPCalendarTypedPtrAutoDeleteMap Template

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
[] | Lookup and add a new element if not there.


CXTPCalendarTypedPtrAutoDeleteMap::[] Operator

CXTPCalendarTypedPtrAutoDeleteMap Operators, CXTPCalendarTypedPtrAutoDeleteMap Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarTypedPtrAutoDeleteMap::[] Operator

Lookup and add a new element if not there.

TPtr& operator [](
    KEY key
);
Parameters

key
A key.

Returns

A reference for value associated to a key (new value added if need).

Body Source
TPtr& operator[](KEY key)
{
    _DeletePtr(key);
    return TBase::operator[](key);
}
Group

CXTPCalendarTypedPtrAutoDeleteMap Operators


CXTPCalendarUIntArray Class

XTPCalendarEventLabel.h, Classes, Legend, Members, Topics, CXTPCalendarUIntArray Methods, CXTPCalendarUIntArray Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUIntArray Class

This class represents the collection of UINT elements.

Class Hierarchy

class CXTPCalendarUIntArray : public CXTPArrayT<UINT, UINT>;
File

XTPCalendarEventLabel.h

Remarks

It also implements and some useful operations on elements.

Group

Classes

Legend
Method
virtual
CXTPCalendarUIntArray Methods
CXTPCalendarUIntArray Methods | Description
DoPropExchange | Call this member function to Store/Load an collection data using the specified data object.
Find | Call this member function to find ID in the collection.
LoadFromString | Call this member function to read collection data from comma separated string.
RemoveID | Call this member function to remove ID from the collection.
SaveToString | Call this member function to store collection data as comma separated string.


CXTPCalendarUIntArray Methods

CXTPCalendarUIntArray Class, Legend, Public Methods
CXTPCalendarUIntArray Methods
Class

CXTPCalendarUIntArray Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Call this member function to Store/Load an collection data using the specified data object.
Find | Call this member function to find ID in the collection.
LoadFromString | Call this member function to read collection data from comma separated string.
RemoveID | Call this member function to remove ID from the collection.
SaveToString | Call this member function to store collection data as comma separated string.


CXTPCalendarUIntArray::DoPropExchange Method

CXTPCalendarUIntArray Methods, CXTPCalendarUIntArray Class
CXTPCalendarUIntArray::DoPropExchange Method

Call this member function to Store/Load an collection data using the specified data object.

virtual void DoPropExchange(
    CXTPPropExchange* pPX,
    LPCTSTR pcszSection,
    LPCTSTR pcszElement
);
Parameters

pPX
Source or destination CXTPPropExchange data object reference.
pcszSection
Section name for elements set.
pcszElement
Element value property name.

Remarks

This member function is used to store or load event data to or from a storage.

Group

CXTPCalendarUIntArray Methods


CXTPCalendarUIntArray::Find Method

CXTPCalendarUIntArray Methods, CXTPCalendarUIntArray Class
CXTPCalendarUIntArray::Find Method

Call this member function to find ID in the collection.

virtual int Find(
    UINT uID
) const;
Parameters

uID
ID to find.

Returns

Zero based index in the collection or -1 if element does not find.

Group

CXTPCalendarUIntArray Methods


CXTPCalendarUIntArray::LoadFromString Method

CXTPCalendarUIntArray Methods, CXTPCalendarUIntArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUIntArray::LoadFromString Method

Call this member function to read collection data from comma separated string.

virtual void LoadFromString(
    LPCTSTR pcszData
);
Parameters

pcszData
String with collection data.

See Also

SaveToString

Group

CXTPCalendarUIntArray Methods


CXTPCalendarUIntArray::RemoveID Method

CXTPCalendarUIntArray Methods, CXTPCalendarUIntArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUIntArray::RemoveID Method

Call this member function to remove ID from the collection.

virtual BOOL RemoveID(
    UINT uID
);
Parameters

uID
ID to remove.

Returns

TRUE if specified ID find and removed, FALSE otherwise.

See Also

CArray::RemoveAt, CArray::RemoveAll

Group

CXTPCalendarUIntArray Methods


CXTPCalendarUIntArray::SaveToString Method

CXTPCalendarUIntArray Methods, CXTPCalendarUIntArray Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUIntArray::SaveToString Method

Call this member function to store collection data as comma separated string.

virtual CString SaveToString() const;
Returns

Comma separated string with collection elements.

See Also

LoadFromString

Group

CXTPCalendarUIntArray Methods


CXTPCalendarUtils Template

XTPCalendarUtils.h, Classes, Legend, Members, Topics, CXTPCalendarUtils Methods, CXTPCalendarUtils Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils Template

Helper class with static member functions to perform common tasks with dates, events and other objects.

Class Hierarchy

template <class _Type>
class CXTPCalendarUtils;
File

XTPCalendarUtils.h

Group

Classes

Legend
Method
CXTPCalendarUtils Methods
CXTPCalendarUtils Methods | Description
_ResetDate_dbl | This function used to reset date part.
_ResetTime_dbl | This function used to reset time part.
_RoundDateTime_dbl | This function used to round date time value by add (subtract) half-second double value.
CalcDayOfMonth | This member function is used to calculate the day of the month from the provided COleDateTime object.
FormatTimeDuration | Format time duration like "3 minutes" or "1 week". Active locale setting are used.
GetActiveLCID | Returns active locale ID (current user locale or resource file locale)
GetCurrentTime | Returns current local time.
GetDateFormat |
GetDayOfWeekCount | This member function is used to count the bits in the specified bit mask.
GetDayOfWeekIndex | This member function is used to convert an XTPCalendarWeekDay enum value to a sequential week day number (from 1 to 7).
GetDayOfWeekMask | This member function is used to convert a sequential week day number (from 1 to 7) to a value from the enum XTPCalendarWeekDay.
GetDiff_Months | This member function is used to calculate differences between 2 dates in months.
GetDurationMinutes | This member function is used to determine the number of minutes between two DateTime objects.
GetEventPeriodDays | Call this member function to get an event duration as a number of days.
GetLocaleLong | This member function is used to retrieve information about a locale.
GetLocaleString | This member function is used to retrieve information about a locale.
GetMaxHeightFont | This function used to determine a font with maximum symbols height in an array of fonts.
GetMaxMonthDay | This member function is used to calculate the maximum month day number for a specified Year and Month in the dtDate parameter.
GetTimeFormat |
GetTimeFormatString_HrMin | Returns current time format string for hours and minutes.
GetWeekOfYear | This member function is used to calculate a week number of year.
IsEqual | This member function is used to compare two dates (and times).
IsUseResourceFileLocale | Determine which locale is used active locale: current user locale or resource file locale.
IsWin9x | This function is used to determine that program running on Windows 9x operation system family.
IsZeroTime | This member function is used to determine if the time part is equal to zero.
LoadString | Loads string using XTPResourceManager.
LoadString2 | Loads string using XTPResourceManager.
MakeDaysOfWeekMask_Mo_ | This member function is used to make the days mask from Monday until the specified day.
Minutes2Span | Converts a number of minutes to the corresponding COleDateTimeSpan object.
ParceTimeDuration_min | Parse a time duration string like "5 minutes", "2 hours", "1 day" or "3 weeks" and returns duration as total minutes. Active locale setting are used.
ParceTimeString_min | Parse a time string like "18:20" or "7:15 pm" and returns time as total minutes. Active locale setting are used.
ResetDate | This member function is used to reset (set to zero) the date part for the specified DateTime value.
ResetTime |
RetriveEventEndDate |
SetTime_235959 | This member function is used to update the time part to 23:59.
SetUseResourceFileLocale | Used to set which locale is used active locale: current user locale or resource file locale.
ShiftDate_Month |
ShiftDate_Year |
ShiftDateToWeekBegin | This member function is used to shift the specified date to the begin of the week.
SystemTimeToTzSpecificLocalTime | The SystemTimeToTzSpecificLocalTime function converts a time in Coordinated Universal Time (UTC) to a specified time zone's corresponding local time.
TrackMouseEvent | NEEDS COMMENT
UpdateDate |
UpdateMonthDay | This member function is used to safely update a month day in the specified date.
UpdateTime |


CXTPCalendarUtils Methods

CXTPCalendarUtils Template, Legend, Public Methods
CXTPCalendarUtils Methods
Template

CXTPCalendarUtils Template

Legend
Method
Public Methods
Public Methods
Public Method | Description
_ResetDate_dbl | This function used to reset date part.
_ResetTime_dbl | This function used to reset time part.
_RoundDateTime_dbl | This function used to round date time value by add (subtract) half-second double value.
CalcDayOfMonth | This member function is used to calculate the day of the month from the provided COleDateTime object.
FormatTimeDuration | Format time duration like "3 minutes" or "1 week". Active locale setting are used.
GetActiveLCID | Returns active locale ID (current user locale or resource file locale)
GetCurrentTime | Returns current local time.
GetDateFormat |
GetDayOfWeekCount | This member function is used to count the bits in the specified bit mask.
GetDayOfWeekIndex | This member function is used to convert an XTPCalendarWeekDay enum value to a sequential week day number (from 1 to 7).
GetDayOfWeekMask | This member function is used to convert a sequential week day number (from 1 to 7) to a value from the enum XTPCalendarWeekDay.
GetDiff_Months | This member function is used to calculate differences between 2 dates in months.
GetDurationMinutes | This member function is used to determine the number of minutes between two DateTime objects.
GetEventPeriodDays | Call this member function to get an event duration as a number of days.
GetLocaleLong | This member function is used to retrieve information about a locale.
GetLocaleString | This member function is used to retrieve information about a locale.
GetMaxHeightFont | This function used to determine a font with maximum symbols height in an array of fonts.
GetMaxMonthDay | This member function is used to calculate the maximum month day number for a specified Year and Month in the dtDate parameter.
GetTimeFormat |
GetTimeFormatString_HrMin | Returns current time format string for hours and minutes.
GetWeekOfYear | This member function is used to calculate a week number of year.
IsEqual | This member function is used to compare two dates (and times).
IsUseResourceFileLocale | Determine which locale is used active locale: current user locale or resource file locale.
IsWin9x | This function is used to determine that program running on Windows 9x operation system family.
IsZeroTime | This member function is used to determine if the time part is equal to zero.
LoadString | Loads string using XTPResourceManager.
LoadString2 | Loads string using XTPResourceManager.
MakeDaysOfWeekMask_Mo_ | This member function is used to make the days mask from Monday until the specified day.
Minutes2Span | Converts a number of minutes to the corresponding COleDateTimeSpan object.
ParceTimeDuration_min | Parse a time duration string like "5 minutes", "2 hours", "1 day" or "3 weeks" and returns duration as total minutes. Active locale setting are used.
ParceTimeString_min | Parse a time string like "18:20" or "7:15 pm" and returns time as total minutes. Active locale setting are used.
ResetDate | This member function is used to reset (set to zero) the date part for the specified DateTime value.
ResetTime |
RetriveEventEndDate |
SetTime_235959 | This member function is used to update the time part to 23:59.
SetUseResourceFileLocale | Used to set which locale is used active locale: current user locale or resource file locale.
ShiftDate_Month |
ShiftDate_Year |
ShiftDateToWeekBegin | This member function is used to shift the specified date to the begin of the week.
SystemTimeToTzSpecificLocalTime | The SystemTimeToTzSpecificLocalTime function converts a time in Coordinated Universal Time (UTC) to a specified time zone's corresponding local time.
TrackMouseEvent | NEEDS COMMENT
UpdateDate |
UpdateMonthDay | This member function is used to safely update a month day in the specified date.
UpdateTime |


CXTPCalendarUtils::_ResetDate_dbl Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::_ResetDate_dbl Method

This function used to reset date part.

static double _ResetDate_dbl(
    double dblDT
);
Parameters

dblDT
[in] A date time value in COLEDateTime double representation.

Returns

Time value (with zero date) in COLEDateTime double representation.

Body Source
double CXTPCalendarUtils::_ResetDate_dbl(double dblDT)
{
    double dblDate = _ResetTime_dbl(dblDT);
    double dblResult = dblDT > dblDate ? (dblDT - dblDate) : (dblDate - dblDT);

    double dblDate_raw = (double)((LONGLONG)dblDT);

    if (dblDate_raw != dblDate)
    {
        dblResult = _RoundDateTime_dbl(dblResult);
    }
    return dblResult;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::_ResetTime_dbl Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::_ResetTime_dbl Method

This function used to reset time part.

static double _ResetTime_dbl(
    double dblDT
);
Parameters

dblDT
[in] A date time value in COLEDateTime double representation.

Returns

Date value (with zero time) in COLEDateTime double representation.

Body Source
double CXTPCalendarUtils::_ResetTime_dbl(double dblDT)
{
    return (double)((LONGLONG)_RoundDateTime_dbl(dblDT));
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::_RoundDateTime_dbl Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::_RoundDateTime_dbl Method

This function used to round date time value by add (subtract) half-second double value.

static double _RoundDateTime_dbl(
    double dblDT
);
Parameters

dblDT
[in] A date time value in COLEDateTime double representation.

Returns

Rounded date time value in COLEDateTime double representation.

Body Source
double CXTPCalendarUtils::_RoundDateTime_dbl(double dblDT)
{
    return (dblDT >= 0 ? dblDT + XTP_HALF_SECOND : dblDT - XTP_HALF_SECOND);
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::CalcDayOfMonth Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::CalcDayOfMonth Method

This member function is used to calculate the day of the month from the provided COleDateTime object.

static BOOL CalcDayOfMonth(
    COleDateTime& rdtDate,
    int nWhichDay,
    int nWhichDayMask
);
Parameters

rdtDate
A COleDateTime object that contains the date to update with the valid year and month parts.
nWhichDay
An int that contains the value from the enum XTPCalendarWeek. This parameter specifies the sequential number of the day For example: First Friday.
nWhichDayMask
An int that contains the combination of values from the enums XTPCalendarWeekDay or the XTPCalendarWeekDay. This parameter, together with the nWhichDay parameter are used to specify the following logical values: Which Day of Month, Which WeekDay, Which WeekEndDay, Which day of week Su, Mo, ..., St. For example: Last day of Month, Second WeekEndDay, Fourth Monday.

Returns

A BOOL. TRUE if the value of this COleDateTime object was set successfully. FALSE otherwise.

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::FormatTimeDuration Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::FormatTimeDuration Method

Format time duration like "3 minutes" or "1 week". Active locale setting are used.

static CString FormatTimeDuration(
    int nMinutes,
    BOOL bRoundly
);
Parameters

nMinutes
Duration in minutes
bRoundly
If TRUE duration will be rounded to biggest scale, like 65 minutes will be formatted as "1 hour". If False duration will formatted exactly: 65 minutes as "65 minutes; 120 minutes as "2 hours".

Returns

Time duration as string like "5 minutes", "2 hours", "1 day", "3 weeks".

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetActiveLCID Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetActiveLCID Method

Returns active locale ID (current user locale or resource file locale)

static LCID GetActiveLCID();
Returns

LOCALE_USER_DEFAULT or resource file locale ID.

See Also

IsUseResourceFileLocale, SetUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, LOCALE_USER_DEFAULT

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetCurrentTime Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::GetCurrentTime Method

Returns current local time.

static COleDateTime GetCurrentTime();
Returns

COleDateTime object with the calculated local time value.

Group

CXTPCalendarUtils Methods


GetDateFormat Method

CXTPCalendarUtils Methods
GetDateFormat Method
Overload List
Methods
Method | Description
CXTPCalendarUtils::GetDateFormat (CONST COleDateTime&, LPCTSTR) | This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.
CXTPCalendarUtils::GetDateFormat (CONST SYSTEMTIME*, LPCTSTR) | This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetDateFormat Method (CONST SYSTEMTIME*, LPCTSTR)

GetDateFormat Method, CXTPCalendarUtils Template, See Also
CXTPCalendarUtils::GetDateFormat Method (CONST SYSTEMTIME*, LPCTSTR)

This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.

static CString GetDateFormat(
    CONST SYSTEMTIME* lpDate,
    LPCTSTR lpFormat
);
static CString GetDateFormat(
    CONST COleDateTime& dtDate,
    LPCTSTR lpFormat
);
Parameters

lpDate
Pointer to a SYSTEMTIME structure that contains the date information to be formatted. If this pointer is NULL, the function uses the current local system date.

lpFormat
Pointer to a format picture string that is used to form the date string. The format picture string must be zero terminated. If lpFormat is NULL, the function uses the date format of the specified locale.
dtDate
A date to be formatted.

Returns

A CString that contains the formatted date string.

Remarks

The function formats either a specified date or the local system date.

See Also

GetDateFormat

Group

GetDateFormat Method


CXTPCalendarUtils::GetDayOfWeekCount Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetDayOfWeekCount Method

This member function is used to count the bits in the specified bit mask.

static int GetDayOfWeekCount(
    int nDayOfWeekMask
);
Parameters

nDayOfWeekMask
An int that contains the mask from the enum XTPCalendarWeekDay.

Returns

An int that contains the integer value of the day 0f the week contained in the bit mask.

See Also

GetDayOfWeekMask, enum XTPCalendarWeekDay

Body Source
int CXTPCalendarUtils::GetDayOfWeekCount(int nDayOfWeekMask)
{
    int nCount = 0;
    for (int i = 1; i <= 7; i++)
    {
        int nTestMask = 1 << (i-1);
        if (nTestMask & nDayOfWeekMask)
        {
            nCount++;
        }
    }
    return nCount;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetDayOfWeekIndex Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetDayOfWeekIndex Method

This member function is used to convert an XTPCalendarWeekDay enum value to a sequential week day number (from 1 to 7).

static int GetDayOfWeekIndex(
    int nDayOfWeekMask
);
Parameters

nDayOfWeekMask
An int that contains the value from the enum XTPCalendarWeekDay.

Returns

An int that contains the sequential week day number. 1-Sunday, 2-Monday, ...

See Also

GetDayOfWeekMask, enum XTPCalendarWeekDay

return 1 = Sunday, 2 = Monday ...

Body Source
int CXTPCalendarUtils::GetDayOfWeekIndex(int nDayOfWeekMask) {
    for (int i = 1; i <= 7; i++)
    {
        int nTestMask = 1 << (i-1);
        if (nTestMask == nDayOfWeekMask){
            return i;
        }
    }
    ASSERT(FALSE);
    return 0;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetDayOfWeekMask Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetDayOfWeekMask Method

This member function is used to convert a sequential week day number (from 1 to 7) to a value from the enum XTPCalendarWeekDay.

static int GetDayOfWeekMask(
    int nWeekDay
);
Parameters

nWeekDay
An int that contains the sequential week day number. 1-Sunday, 2-Monday, ...

Returns

An int that contains the corresponding value from the enum XTPCalendarWeekDay.

See Also

GetDayOfWeekIndex, enum XTPCalendarWeekDay

Body Source
int CXTPCalendarUtils::GetDayOfWeekMask(int nWeekDay) {
    ASSERT(nWeekDay >= 1 && nWeekDay <= 7);

    int nRes = 1 << (nWeekDay-1);
    return nRes;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetDiff_Months Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetDiff_Months Method

This member function is used to calculate differences between 2 dates in months.

static int GetDiff_Months(
    const COleDateTime& dt1,
    const COleDateTime& dt2
);
Parameters

dt1
A COleDateTime object that contains the first DateTime value.
dt2
A COleDateTime object that contains the second DateTime value.

Returns

Months difference for dt1 - dt2.

See Also

COleDateTime overview

Body Source
int CXTPCalendarUtils::GetDiff_Months(const COleDateTime& dt1, const COleDateTime& dt2)
{
    int nYear1 = dt1.GetYear();
    int nMonth1 = dt1.GetMonth();

    int nYear2 = dt2.GetYear();
    int nMonth2 = dt2.GetMonth();

    int nYearDiff = nYear1 - nYear2;
    int nMonthDiff = nYearDiff * 12;

    nMonthDiff += nMonth1 - nMonth2;

    return nMonthDiff;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetDurationMinutes Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetDurationMinutes Method

This member function is used to determine the number of minutes between two DateTime objects.

static int GetDurationMinutes(
    const COleDateTime& dtStart,
    const COleDateTime& dtEnd,
    BOOL bAllDayEvent
);
Parameters

dtStart
A COleDateTime object that contains the beginning date.
dtEnd
A COleDateTime object that contains the end date.
bAllDayEvent
Calculate duration for all day event.

Returns

An int that contains the number of minutes between two DateTime objects.

Remarks

This is a utility function that is used to retrieve the number of minutes between two COleDateTime objects.

Body Source
int CXTPCalendarUtils::GetDurationMinutes(const COleDateTime& dtStart, const COleDateTime& dtEnd, BOOL bAllDayEvent)
{
    COleDateTimeSpan spDuration;
    if (bAllDayEvent)
    {
        spDuration = SetTime_235959(dtEnd) - ResetTime(dtStart);
    }
    else
    {
        spDuration = dtEnd - dtStart;
    }
    return (int)GETTOTAL_MINUTES_DTS(spDuration);
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetEventPeriodDays Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetEventPeriodDays Method

Call this member function to get an event duration as a number of days.

static int GetEventPeriodDays(
    const COleDateTime& dtStart,
    const COleDateTime& dtEnd
);
Parameters

dtStart
Event start time.
dtEnd
Event end time.

Returns

Integer value of an event duration in days.

See Also

CXTPCalendarEvent::GetDurationMinutes(), CXTPCalendarEvent::GetDuration()

Body Source
int CXTPCalendarUtils::GetEventPeriodDays(const COleDateTime& dtStart, const COleDateTime& dtEnd)
{
    COleDateTime dtStartDay = ResetTime(dtStart);
    COleDateTime dtEndDay = RetriveEventEndDate(dtStart, dtEnd);

    COleDateTimeSpan spDuration = dtEndDay - dtStartDay;
    int nDays = (int)GETTOTAL_DAYS_DTS(spDuration) + 1;

    return nDays;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetLocaleLong Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetLocaleLong Method

This member function is used to retrieve information about a locale.

static int GetLocaleLong(
    LCTYPE LCType
);
Parameters

LCType
An LCTYPE that specifies the type of locale information to retrieve. (for the LOCALE_USER_DEFAULT)

Returns

Integer value that contains the information about the locale.

See Also

GetLocaleInfo

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetLocaleString Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetLocaleString Method

This member function is used to retrieve information about a locale.

static CString GetLocaleString(
    LCTYPE LCType,
    int nMaxLength
);
Parameters

LCType
An LCTYPE that specifies the type of locale information to retrieve. (for the LOCALE_USER_DEFAULT)
nMaxLength
An int that contains the maximum string size to allocate for the corresponding buffer.

Returns

String value.

See Also

GetLocaleInfo

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetMaxHeightFont Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::GetMaxHeightFont Method

This function used to determine a font with maximum symbols height in an array of fonts.

static CFont* GetMaxHeightFont(
    CArray<CFont*, CFont*>& arFonts,
    CDC* pDC,
    int* pnMaxHeight = NULL
);
Parameters

arFonts
[in] A reference to array of fonts.
pDC
[in] A pointer to valid device context or NULL.
pnMaxHeight
[out] A pointer to int variable to store maximum font height or NULL.

Returns

A font from the provided array with maximum symbols height.

Remarks

if pDC is not NULL - the font height in device logical units is used. Otherwise the LOGFONT.lfHeight member is used as font height.

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetMaxMonthDay Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetMaxMonthDay Method

This member function is used to calculate the maximum month day number for a specified Year and Month in the dtDate parameter.

static int GetMaxMonthDay(
    COleDateTime dtDate
);
Parameters

dtDate
A COleDateTime date value.

Returns

An int that contains the maximum month day number. (30, 31, 28, 29)

Body Source
int CXTPCalendarUtils::GetMaxMonthDay(COleDateTime dtDate)
{
    SYSTEMTIME sysDate;
    if (!GETASSYSTEMTIME_DT(dtDate, sysDate))
        return 0;

    // days per month  -     _  jan feb mar apr may jun   jul aug sep oct nov dec
    static int arDays[13] = {0, 31, 28, 31, 30, 31, 30,   31, 31, 30, 31, 30, 31};
    if (sysDate.wMonth == 2 && 0 == (sysDate.wYear % 4))
    {
        return 29;
    }
    else
    {
        return arDays[sysDate.wMonth];
    }
}
Group

CXTPCalendarUtils Methods


GetTimeFormat Method

CXTPCalendarUtils Methods
GetTimeFormat Method
Overload List
Methods
Method | Description
CXTPCalendarUtils::GetTimeFormat (CONST COleDateTime&, LPCTSTR) | This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
CXTPCalendarUtils::GetTimeFormat (CONST SYSTEMTIME*, LPCTSTR) | This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
CXTPCalendarUtils::GetTimeFormat (int, int, LPCTSTR) | This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetTimeFormat Method (CONST SYSTEMTIME*, LPCTSTR)

GetTimeFormat Method, CXTPCalendarUtils Template, See Also
CXTPCalendarUtils::GetTimeFormat Method (CONST SYSTEMTIME*, LPCTSTR)

This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.

static CString GetTimeFormat(
    CONST SYSTEMTIME* lpTime,
    LPCTSTR lpFormat
);
static CString GetTimeFormat(
    CONST COleDateTime& dtTime,
    LPCTSTR lpFormat
);
static CString GetTimeFormat(
    int nHour,
    int nMinutes,
    LPCTSTR lpFormat
);
Parameters

lpTime
Pointer to a SYSTEMTIME structure that contains the time information to be formatted. If this pointer is NULL, the function uses the current local system time.

lpFormat
Pointer to a format picture string that is used to form the time string. The format picture string must be zero terminated. If lpFormat is NULL, the function uses the time format of the specified locale.
dtTime
A time to be formatted.

nHour
Hour of time to be formatted.
nMinutes
Minutes of time to be formatted.

Returns

A CString that contains the formatted time string.

Remarks

The function formats either a specified time or the local system time.

See Also

GetTimeFormat

Group

GetTimeFormat Method


CXTPCalendarUtils::GetTimeFormatString_HrMin Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::GetTimeFormatString_HrMin Method

Returns current time format string for hours and minutes.

static CString GetTimeFormatString_HrMin();
Returns

A time format string like: 'HH:mm', 'hh:mm tt', 'h:m t', ...

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::GetWeekOfYear Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::GetWeekOfYear Method

This member function is used to calculate a week number of year.

static int GetWeekOfYear(
    COleDateTime dtDate,
    int nFirstDayOfWeekIndex = 1
);
Parameters

dtDate
A COleDateTime object that contains the date to calculate the week of year.
nFirstDayOfWeekIndex
Index of the first day of week. Default value 1. 1-Sunday, 2-Monday, ...

Returns

A week number of year for the specified date.

See Also

COleDateTime overview

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::IsEqual Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::IsEqual Method

This member function is used to compare two dates (and times).

static BOOL IsEqual(
    const COleDateTime& dt1,
    const COleDateTime& dt2,
    BOOL bOneSecTimeDiff = FALSE
);
Parameters

dt1
A COleDateTime object that contains the first DateTime value.
dt2
A COleDateTime object that contains the second DateTime value.
bOneSecTimeDiff
A BOOL. Used to set the precision of the compare operation. If TRUE, then one second precision is used. If FALSE, then half a second precision is used.

Returns

A BOOL. TRUE if the dates differ by less than or equal to the specified precision. FALSE otherwise.

See Also

COleDateTime overview

Body Source
BOOL CXTPCalendarUtils::IsEqual(const COleDateTime& dt1, const COleDateTime& dt2, BOOL bOneSecTimeDiff)
{
    double dTimeDiff = bOneSecTimeDiff ? XTP_HALF_SECOND * 2 : XTP_HALF_SECOND;
    return dTimeDiff >= fabs(dt1 - dt2);
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::IsUseResourceFileLocale Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::IsUseResourceFileLocale Method

Determine which locale is used active locale: current user locale or resource file locale.

static BOOL IsUseResourceFileLocale();
Returns

TRUE if resource file locale is used active locale, FALSE otherwise.

See Also

SetUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, GetActiveLCID, LOCALE_USER_DEFAULT

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::IsWin9x Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::IsWin9x Method

This function is used to determine that program running on Windows 9x operation system family.

static BOOL IsWin9x();
Returns

TRUE for Windows 9x operation system, otherwise FALSE.

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::IsZeroTime Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::IsZeroTime Method

This member function is used to determine if the time part is equal to zero.

static BOOL IsZeroTime(
    const COleDateTime& dtDateTime
);
Parameters

dtDateTime
A COleDateTime object that contains the value to check.

Returns

A BOOL. TRUE if the time part is equal to zero. FALSE otherwise.

See Also

COleDateTime overview

Body Source
BOOL CXTPCalendarUtils::IsZeroTime(const COleDateTime& dtDateTime)
{
    double dTime = _ResetDate_dbl((double)dtDateTime);
    return fabs(dTime) < XTP_HALF_SECOND;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::LoadString Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::LoadString Method

Loads string using XTPResourceManager.

static CString LoadString(
    UINT nIDResource
);
Parameters

nIDResource
ID of the string in resource.

Returns

Loaded string or an empty string.

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::LoadString2 Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::LoadString2 Method

Loads string using XTPResourceManager.

static BOOL LoadString2(
    CString& rstrString,
    UINT nIDResource
);
Parameters

rstrString
[out] Reference to CString object to load string to.
nIDResource
ID of the string in resource.

Returns

TRUE if string loaded, FALSE otherwise.

Remarks

If string with such ID is not present in the resource - rstrString is not changed.

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::MakeDaysOfWeekMask_Mo_ Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::MakeDaysOfWeekMask_Mo_ Method

This member function is used to make the days mask from Monday until the specified day.

static int MakeDaysOfWeekMask_Mo_(
    int nEndWDay
);
Parameters

nEndWDay
An int that contains the sequential week day number. 1-Sunday, 2-Monday, ...

Returns

An int that contains the values set from the enum XTPCalendarWeekDay.

See Also

GetDayOfWeekIndex, enum XTPCalendarWeekDay

Body Source
int CXTPCalendarUtils::MakeDaysOfWeekMask_Mo_(int nEndWDay)
{
    int nMask = 0;
    for (int i = 1; i < nEndWDay; i++)
    {
        int nWDMask = CXTPCalendarUtils::GetDayOfWeekMask(i);
        nMask |= nWDMask;
    }
    return nMask;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::Minutes2Span Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::Minutes2Span Method

Converts a number of minutes to the corresponding COleDateTimeSpan object.

static COleDateTimeSpan Minutes2Span(
    int nMinutes
);
Parameters

nMinutes
A number of minutes in the time span.

Returns

Calculated COleDateTimeSpan object.

Body Source
COleDateTimeSpan CXTPCalendarUtils::Minutes2Span(int nMunutes)
{
    double dblSpan =  ((double)nMunutes) / (24 * 60);
    return COleDateTimeSpan(dblSpan);
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::ParceTimeDuration_min Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::ParceTimeDuration_min Method

Parse a time duration string like "5 minutes", "2 hours", "1 day" or "3 weeks" and returns duration as total minutes. Active locale setting are used.

static int ParceTimeDuration_min(
    LPCTSTR pcszTimeDuration
);
Parameters

pcszTimeDuration
time duration string like "5 minutes", "2 hours"

Returns

Time duration as total minutes.

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::ParceTimeString_min Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::ParceTimeString_min Method

Parse a time string like "18:20" or "7:15 pm" and returns time as total minutes. Active locale setting are used.

static int ParceTimeString_min(
    LPCTSTR pcszTime_HrMin
);
Parameters

pcszTime_HrMin
time string like "18:20" or "7:15 pm"

Returns

Time as total minutes.

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::ResetDate Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::ResetDate Method

This member function is used to reset (set to zero) the date part for the specified DateTime value.

static const COleDateTime ResetDate(
    const COleDateTime& dtDateTime
);
Parameters

dtDateTime
A COleDateTime DateTime value that contains the DateTime value to reset.

Returns

A COleDateTime object with the date part set equal to zero.

See Also

COleDateTime overview

Body Source
const COleDateTime CXTPCalendarUtils::ResetDate(const COleDateTime& dtDateTime)
{
    return (DATE)_ResetDate_dbl((double)dtDateTime);
}
Group

CXTPCalendarUtils Methods


ResetTime Method

CXTPCalendarUtils Methods
ResetTime Method
Overload List
Methods
Method | Description
CXTPCalendarUtils::ResetTime (const COleDateTime&) | This member function is used to reset (set to zero) the time part for the specified DateTime value.
CXTPCalendarUtils::ResetTime (const DATE) | This member function is used to reset (set to zero) the time part for the specified DateTime value.
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::ResetTime Method (const COleDateTime&)

ResetTime Method, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::ResetTime Method (const COleDateTime&)

This member function is used to reset (set to zero) the time part for the specified DateTime value.

static const COleDateTime ResetTime(
    const COleDateTime& dtDateTime
);
static const COleDateTime ResetTime(
    const DATE dtDateTime
);
Parameters

dtDateTime
A COleDateTime object that contains the time value to reset.

Returns

A COleDateTime object with the time part set equal to zero.

See Also

COleDateTime overview

Body Source
const COleDateTime CXTPCalendarUtils::ResetTime(const COleDateTime& dtDateTime)
{
    return (DATE)_ResetTime_dbl((double)dtDateTime);
}

const COleDateTime CXTPCalendarUtils::ResetTime(const DATE dtDateTime)
{
    return (DATE)_ResetTime_dbl((double)dtDateTime);
}
Group

ResetTime Method


RetriveEventEndDate Method

CXTPCalendarUtils Methods
RetriveEventEndDate Method
Overload List
Methods
Method | Description
CXTPCalendarUtils::RetriveEventEndDate (const COleDateTime&, const COleDateTime&) | Get event end date (date part only) value.
CXTPCalendarUtils::RetriveEventEndDate (const CXTPCalendarEvent*) | Get event end date (date part only) value.
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::RetriveEventEndDate Method (const CXTPCalendarEvent*)

RetriveEventEndDate Method, CXTPCalendarUtils Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::RetriveEventEndDate Method (const CXTPCalendarEvent*)

Get event end date (date part only) value.

static COleDateTime RetriveEventEndDate(
    const CXTPCalendarEvent* pEvent
);
static COleDateTime RetriveEventEndDate(
    const COleDateTime& dtStart,
    const COleDateTime& dtEnd
);
Parameters

pEvent
Event object.
dtStart
Event start time.
dtEnd
Event end time.

Returns

Date part of the event end DateTime.

Remarks

Useful when end DateTime has a zero time part and/or event start equal end.

See Also

COleDateTime overview

Group

RetriveEventEndDate Method


CXTPCalendarUtils::SetTime_235959 Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::SetTime_235959 Method

This member function is used to update the time part to 23:59.

static const COleDateTime SetTime_235959(
    const COleDateTime& dtDateTime
);
Parameters

dtDateTime
A COleDateTime object that contains the value used to update the time part.

Returns

A COleDateTime object that contains the updated time part.

See Also

COleDateTime overview

Body Source
const COleDateTime CXTPCalendarUtils::SetTime_235959(const COleDateTime& dtDateTime)
{
    double dDate = _ResetTime_dbl((double)dtDateTime);
    return (DATE)(dDate + 1 - XTP_HALF_SECOND * 2);
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::SetUseResourceFileLocale Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::SetUseResourceFileLocale Method

Used to set which locale is used active locale: current user locale or resource file locale.

static void SetUseResourceFileLocale(
    BOOL bUseResourceFileLocale
);
Parameters

bUseResourceFileLocale
If TRUE resource file locale will be used, if FALSE current user locale will be used.

See Also

IsUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, GetActiveLCID, LOCALE_USER_DEFAULT

Group

CXTPCalendarUtils Methods


ShiftDate_Month Method

CXTPCalendarUtils Methods
ShiftDate_Month Method
Overload List
Methods
Method | Description
CXTPCalendarUtils::ShiftDate_Month (COleDateTime &, int) | This member function is used to shift the specified date for the specified number of months.
CXTPCalendarUtils::ShiftDate_Month (COleDateTime &, int, int) | This member function is used to shift the specified date for the specified number of months.
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::ShiftDate_Month Method (COleDateTime &, int)

ShiftDate_Month Method, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::ShiftDate_Month Method (COleDateTime &, int)

This member function is used to shift the specified date for the specified number of months.

static BOOL ShiftDate_Month(
    COleDateTime & refDate,
    int nMonthCount
);
static BOOL ShiftDate_Month(
    COleDateTime & refDate,
    int nMonthCount,
    int nMonthDay
);
Parameters

refDate
A reference to the COleDateTime object to shift the date on.
nMonthCount
An int that contains the number of months shifted. Can be both positive and negative numbers.
nMonthDay
An int that contains the day of the month to set for a resulting date. If nMonthDay is grater then the maximum month day in the result month, then the maximum possible day is set.

Returns

A BOOL. TRUE if the value of this COleDateTime object was set successfully. FALSE otherwise.

Remarks

This is a utility function that is used to shift the specified date for the specific number of months.

See Also

COleDateTime overview

Body Source
BOOL CXTPCalendarUtils::ShiftDate_Month(COleDateTime &refDate, int nMonthCount)
{
    SYSTEMTIME sysDate;
    if (!GETASSYSTEMTIME_DT(refDate, sysDate))
        return FALSE;

    int nYearNew = sysDate.wYear + nMonthCount / 12;
    int nMonthNew = sysDate.wMonth + nMonthCount % 12;

    if (nMonthNew > 12)
    {
        nMonthNew -= 12 * (nMonthCount / abs(nMonthCount));
        nYearNew++;
    }
    else if (nMonthNew <= 0)
    {
        nYearNew--;
        nMonthNew += 12;

        ASSERT(nMonthNew >= 1 && nMonthNew <= 12);
    }

    return COleDateTime::valid == refDate.SetDate(nYearNew, nMonthNew, 1);
}

BOOL CXTPCalendarUtils::ShiftDate_Month(COleDateTime &refDate, int nMonthCount, int nMonthDay)
{
    if (ShiftDate_Month(refDate, nMonthCount))
    {
        BOOL bRes = UpdateMonthDay(refDate, nMonthDay);
        return bRes;
    }
    return FALSE;
}
Group

ShiftDate_Month Method


ShiftDate_Year Method

CXTPCalendarUtils Methods
ShiftDate_Year Method
Overload List
Methods
Method | Description
CXTPCalendarUtils::ShiftDate_Year (COleDateTime &, int) | This member function is used to shift the specified date for the specified number of years.
CXTPCalendarUtils::ShiftDate_Year (COleDateTime &, int, int) | This member function is used to shift the specified date for the specified number of years.
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::ShiftDate_Year Method (COleDateTime &, int)

ShiftDate_Year Method, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::ShiftDate_Year Method (COleDateTime &, int)

This member function is used to shift the specified date for the specified number of years.

static BOOL ShiftDate_Year(
    COleDateTime & refDate,
    int nYearCount
);
static BOOL ShiftDate_Year(
    COleDateTime & refDate,
    int nYearCount,
    int nMonthDay
);
Parameters

refDate
Reference to the COleDateTime object to shift the date on.
nYearCount
An int that contains the number of years to shift. Can be both positive and negative numbers.
nMonthDay
An int that contains the day of the month to set for the resulting date. If nMonthDay is grater then the maximum month day in the result month, then the maximum possible day is set.

Returns

A BOOL. TRUE if the value of this COleDateTime object is set successfully. FALSE otherwise.

Remarks

This is a utility function that is used to shift the specified date the specified number of years.

See Also

COleDateTime overview

Body Source
BOOL CXTPCalendarUtils::ShiftDate_Year(COleDateTime &refDate, int nYearCount)
{
    SYSTEMTIME sysDate;
    if (!GETASSYSTEMTIME_DT(refDate, sysDate))
    {
        return FALSE;
    }
    int nYearNew = sysDate.wYear + nYearCount;
    return COleDateTime::valid == refDate.SetDate(nYearNew, sysDate.wMonth, 1);
}

BOOL CXTPCalendarUtils::ShiftDate_Year(COleDateTime &refDate, int nYearCount, int nMonthDay)
{
    if (ShiftDate_Year(refDate, nYearCount))
    {
        BOOL bRes = UpdateMonthDay(refDate, nMonthDay);
        return bRes;
    }
    return FALSE;
}
Group

ShiftDate_Year Method


CXTPCalendarUtils::ShiftDateToWeekBegin Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::ShiftDateToWeekBegin Method

This member function is used to shift the specified date to the begin of the week.

static COleDateTime ShiftDateToWeekBegin(
    COleDateTime dtDate,
    int nFirstDayOfWeekIndex = 1
);
Parameters

dtDate
A COleDateTime object that contains the value to shift to the beginning of the week.
nFirstDayOfWeekIndex
Index of the first day of week. Default value 1. 1-Sunday, 2-Monday, ...

Returns

A COleDateTime object that contains the date of the first day of week before the specified date.

See Also

COleDateTime overview

Body Source
COleDateTime CXTPCalendarUtils::ShiftDateToWeekBegin(COleDateTime dtDate, int nFirstDayOfWeekIndex)
{
    dtDate = CXTPCalendarUtils::ResetTime(dtDate);

    int nShift = (dtDate.GetDayOfWeek() - nFirstDayOfWeekIndex + 7) % 7;
    if (nShift)
    {
        COleDateTimeSpan spShift(nShift, 0, 0, 0);
        dtDate -= spShift;
    }
    return dtDate;
}
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::SystemTimeToTzSpecificLocalTime Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::SystemTimeToTzSpecificLocalTime Method

The SystemTimeToTzSpecificLocalTime function converts a time in Coordinated Universal Time (UTC) to a specified time zone's corresponding local time.

static BOOL SystemTimeToTzSpecificLocalTime(
    const TIME_ZONE_INFORMATION* pTZI,
    const SYSTEMTIME* pUTime,
    SYSTEMTIME* pTzTime
);
Parameters

pTZI
[in] Pointer to a TIME_ZONE_INFORMATION structure that specifies the time zone of interest.
pUTime
[in] Pointer to a SYSTEMTIME structure that specifies a UTC. The function converts this universal time to the specified time zone's corresponding local time.
pTzTime
[out] Pointer to a SYSTEMTIME structure that receives the local time information.

Returns

If the function succeeds, the return value is nonzero, and the function sets the members of the SYSTEMTIME structure pointed to by pTzTime to the appropriate local time values.

See Also

SystemTimeToTzSpecificLocalTime() windows API function.

Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::TrackMouseEvent Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template
CXTPCalendarUtils::TrackMouseEvent Method

NEEDS COMMENT

static BOOL TrackMouseEvent(
    DWORD dwFlags,
    HWND hwndTrack,
    DWORD dwHoverTime = HOVER_DEFAULT
);
Group

CXTPCalendarUtils Methods


UpdateDate Method

CXTPCalendarUtils Methods
UpdateDate Method
Overload List
Methods
Method | Description
CXTPCalendarUtils::UpdateDate (const COleDateTime&, const COleDateTime&) | This member function is used to update the date part of the specified DateTime value.
CXTPCalendarUtils::UpdateDate (const COleDateTime&, int, int, int) | This member function is used to update the date part of the specified DateTime value.
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::UpdateDate Method (const COleDateTime&, const COleDateTime&)

UpdateDate Method, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::UpdateDate Method (const COleDateTime&, const COleDateTime&)

This member function is used to update the date part of the specified DateTime value.

static const COleDateTime UpdateDate(
    const COleDateTime& dtTime,
    const COleDateTime& dtDate
);
static const COleDateTime UpdateDate(
    const COleDateTime& dtTime,
    int nYear,
    int nMonth,
    int nDay
);
Parameters

dtTime
A COleDateTime object that contains the value used to update the date part.
dtDate
A COleDateTime object that contains the new date part.
nYear
An int that contains the new Year used in the date part.
nMonth
An int that contains the new Minutes used in the the date part.
nDay
An int that contains the new Day used in the date part.

Returns

A COleDateTime object that contains the updated date part.

See Also

COleDateTime overview

Body Source
const COleDateTime CXTPCalendarUtils::UpdateDate(const COleDateTime& dtTime, const COleDateTime& dtDate)
{
    double dDate = _ResetTime_dbl((double)dtDate);
    double dTime = _ResetDate_dbl((double)dtTime);
    return (DATE)(dDate + dTime);
}

const COleDateTime CXTPCalendarUtils::UpdateDate(const COleDateTime& dtTime, int nYear, int nMonth, int nDay)
{
    SYSTEMTIME stResult;
    if (!GETASSYSTEMTIME_DT(dtTime, stResult))
    {
        ASSERT(FALSE);
        return dtTime;
    }

    stResult.wYear  = (WORD)nYear;
    stResult.wMonth = (WORD)nMonth;
    stResult.wDay   = (WORD)nDay;

    return COleDateTime(stResult);
}
Group

UpdateDate Method


CXTPCalendarUtils::UpdateMonthDay Method

CXTPCalendarUtils Methods, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::UpdateMonthDay Method

This member function is used to safely update a month day in the specified date.

static BOOL UpdateMonthDay(
    COleDateTime & refDate,
    int nMonthDay
);
Parameters

refDate
Reference to the COleDateTime object to shift the date on.
nMonthDay
An int that contains the day of the month to set for the resulting date. If nMonthDay is grater then the maximum month day in the result month, then the maximum possible day is set.

Returns

A BOOL. TRUE if the value of this COleDateTime object was set successfully. FALSE otherwise.

Remarks

This is utility function is used to update the month day in the specified date.

See Also

COleDateTime overview

Body Source
BOOL CXTPCalendarUtils::UpdateMonthDay(COleDateTime &refDate, int nMonthDay)
{
    if (nMonthDay > 28)
    {
        int nMaxDay = GetMaxMonthDay(refDate);
        if (!nMaxDay)
        {
            return FALSE;
        }
        nMonthDay = min(nMonthDay, nMaxDay);
    }

    SYSTEMTIME sysDate;
    if (!GETASSYSTEMTIME_DT(refDate, sysDate))
        return FALSE;

    int nRes = refDate.SetDate(sysDate.wYear, sysDate.wMonth, nMonthDay);
    return nRes == 0;
}
Group

CXTPCalendarUtils Methods


UpdateTime Method

CXTPCalendarUtils Methods
UpdateTime Method
Overload List
Methods
Method | Description
CXTPCalendarUtils::UpdateTime (const COleDateTime&, const COleDateTime&) | This member function is used to update the time part for the specified DateTime value.
CXTPCalendarUtils::UpdateTime (const COleDateTime&, int, int, int) | This member function is used to update the time part for the specified DateTime value.
Group

CXTPCalendarUtils Methods


CXTPCalendarUtils::UpdateTime Method (const COleDateTime&, const COleDateTime&)

UpdateTime Method, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::UpdateTime Method (const COleDateTime&, const COleDateTime&)

This member function is used to update the time part for the specified DateTime value.

static const COleDateTime UpdateTime(
    const COleDateTime& dtDate,
    const COleDateTime& dtTime
);
Parameters

dtDate
A COleDateTime object that contains the value used to update the time part.
dtTime
A COleDateTime object that contains the new time part value.

Returns

A COleDateTime object that contains the updated time part.

See Also

COleDateTime overview

Body Source
const COleDateTime CXTPCalendarUtils::UpdateTime(const COleDateTime& dtDate, const COleDateTime& dtTime)
{
    double dDate = _ResetTime_dbl((double)dtDate);
    double dTime = _ResetDate_dbl((double)dtTime);
    return (DATE)(dDate + dTime);
}
Group

UpdateTime Method


CXTPCalendarUtils::UpdateTime Method (const COleDateTime&, int, int, int)

UpdateTime Method, CXTPCalendarUtils Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarUtils::UpdateTime Method (const COleDateTime&, int, int, int)

This member function is used to update the time part for the specified DateTime value.

static const COleDateTime UpdateTime(
    const COleDateTime& dtDate,
    int nHour,
    int nMinutes,
    int nSeconds
);
Parameters

dtDate
A COleDateTime object that contains the value that is used to update the time part.
nHour
An int that contains the new Hour in the time part.
nMinutes
An int that contains the new Minutes in the time part.
nSeconds
An int that contains the new Seconds in the time part.

Returns

A COleDateTime object that contains the updated time part.

See Also

COleDateTime overview

Body Source
const COleDateTime CXTPCalendarUtils::UpdateTime(const COleDateTime& dtDate, int nHour, int nMinutes, int nSeconds)
{
    SYSTEMTIME stResult;
    if (!GETASSYSTEMTIME_DT(dtDate, stResult))
    {
        ASSERT(FALSE);
        return dtDate;
    }

    stResult.wHour   = (WORD)nHour;
    stResult.wMinute = (WORD)nMinutes;
    stResult.wSecond = (WORD)nSeconds;

    return COleDateTime(stResult);
}
Group

UpdateTime Method


CXTPCalendarView Class

XTPCalendarView.h, Classes, Legend, Members, Topics, CXTPCalendarView Classes, CXTPCalendarView Structures, CXTPCalendarView Data Members, CXTPCalendarView Methods, CXTPCalendarView Constructors, CXTPCalendarView Destructors, CXTPCalendarView Classes, CXTPCalendarView Constructors, CXTPCalendarView Data Members, CXTPCalendarView Destructors, CXTPCalendarView Methods, See Also, CXTPCalendarView Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView Class

This class represents the view portion of the Calendar control.

Class Hierarchy

class CXTPCalendarView : public CXTPCalendarWMHandler;
File

XTPCalendarView.h

Remarks

It represents a specific view of the Control's associated events data and provides basic functionality on the data using user input through the keyboard and mouse.

The following predefined view implementations are available for the Calendar control:

  • Day and work week views - using CXTPCalendarDayView class.
  • Week view - using CXTPCalendarWeekView class.
  • Month view - using CXTPCalendarMonthView class.

Furthermore, any type of user defined view can also be implemented as a descendant of the CXTPCalendarView class.

A typical Calendar View model consists of a collection of corresponding ViewDay's, which realizes the contents on a square of one day. ViewDay in its turn contains a collection of ViewEvent's for the particular day, each of them represents a view of an CXTPCalendarEvent object.

See Also

CXTPCalendarDayView, CXTPCalendarWeekView, CXTPCalendarMonthView, CXTPCalendarViewDay, CXTPCalendarViewEvent

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
abstract
CXTPCalendarView Classes
CXTPCalendarView Classes | Description
CSelectionChanged_ContextData | This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary.
CSelectionChangedContext | Class CSelectionChangedContext used to avoid multiple sending of XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation.
CUndoBuffer | This helper class implements Undo/Redo events editing functionality.
CXTPCalendarView Constructors
CXTPCalendarView Constructors | Description
CXTPCalendarView | Default object constructor.
CXTPCalendarView Data Members
CXTPCalendarView Data Members | Description
m_bResetUndoBuffer | Clean undo buffer before add next undo action.
m_bScrollH_Disabled | Is horizontal scrolling disabled for a view.
m_bScrollV_Disabled | Is vertical scrolling disabled for a view.
m_bStartedClickInside | Is OnLButtonDown was inside view rect.
m_cntSelChanged | Counter on selection changes, is needed to redraw a view when necessary.
m_eDraggingMode | Editing event mode.
m_eUndoMode | Undo mode, see XTPCalendarUndoMode.
m_EventTimeFormat | Information used to format events times.
m_LastHitInfo | Last HitInfo data.
m_Layout | Layout data.
m_nKeyStateTimerID | Timer ID to check Keys state (like Control).
m_nTimerID_ShowToolTip | Timer ID of start show tooltip request.
m_nTimerID_StartEditSubject | Timer ID of edit event subject request.
m_pControl | Pointer to the owner control object.
m_pResources | Resources array
m_PrevUndoBuffer | Undo buffer data after last undo buffer clean.
m_pSelectedEvents | Selected Events;
m_ptrDraggingEventNew | Editing event object.
m_ptrDraggingEventOrig | Event object before start event editing.
m_ptrEditingViewEvent | Currently editing subject event view or event view requested to edit subject by timeout.
m_ptStartDragging | Request to start dragging operation from this point.
m_rcTooltip | Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
m_rcView | Client rect.
m_selectedBlock | Current selection.
m_spDraggingStartOffset | Start dragging operation offset from the beginning of the event.
m_strDayHeaderFormatDefaultLong | Day header Long date format default string.
m_strDayHeaderFormatDefaultMiddle | Day header Middle date format default string.
m_strDayHeaderFormatDefaultShort | Day header Short date format default string.
m_strDayHeaderFormatDefaultShortest | Day header Shortest date format default string.
m_strDayHeaderFormatLong | Day header Long date format custom string.
m_strDayHeaderFormatMiddle | Day header Middle date format custom string.
m_strDayHeaderFormatShort | Day header Short date format custom string.
m_strDayHeaderFormatShortest | Day header Shortest date format custom string.
m_strHeaderFormat | Day header active date format string.
m_UndoBuffer | Undo buffer object.
CXTPCalendarView Destructors
CXTPCalendarView Destructors | Description
~CXTPCalendarView | Default class destructor.
CXTPCalendarView Methods
CXTPCalendarView Methods | Description
_CalculateEventTimeFormat | This member function is used to create the time format string.
_CanSubjectEditor | This member function is used to determine if the specified editing operation command is possible for the event subject editor window.
_CopySelectedEvents | This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.
_GetDayHeaderFormat | This member function get custom or default day header date format string.
_GetMaxWidth | This member function is used to calculate, in pixels, the max date width for the specified format string.
_GetMaxWidthFormat | This function is used to calculates the max width of the date used in the specified format string.
_GetSubjectEditorWnd | This member function is used to obtain a pointer to the event subject editor window.
_GetViewDay | Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
_IsDragModeCopyMove | This method is used to determine Copy or Move dragging mode.
_ReadDefaultHeaderFormats | This member function is used to build day header date format default strings.
_ReadEventsFromClipboard | This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.
_RemoveYearPart | This member function is used to remove the year part from the specified format string.
_Undo | This member function is used to perform an undo/redo operation for the specified event.
AdjustLayout | This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
CalculateHeaderFormat | This member function creates the day header format string.
CancelDraggingEvent | This member function is used to cancel the event editing (dragging) operation.
CanCopy | Call this member function to determine if it is possible to perform a Copy operation.
CanCut | Call this member function to determine if it is possible to perform a Cut operation.
CanPaste | Call this member function to determine if it is possible to perform a Paste operation.
CanRedo | Call this member function to determine if a redo operation is possible for the subject editor.
CanUndo | Call this member function to determine if you can perform an undo operation for the subject editor.
CommitDraggingEvent | This member function is used to commit the event editing (dragging) operation.
Copy | This member function is used to perform a Copy operation.
Cut | This member function is used to perform a Cut operation.
Draw | This member function is used to draw the view content using the specified device context.
Draw2 | This member function is used to draw the view content using the specified device context.
EmptyUndoBuffer | This member function is used to erases the undo buffer.
EnableHScroll | This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
EnableVScroll | This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
EndEditSubject | This member function is used to finish the event subject editing.
FindEventToEditByTAB | This member function is used to obtain the next event view object used for editing events by pressing the TAB key.
FindLastSelectedDay | This member function is used to obtain the last selected day index.
FindViewEvent | This member function is used to obtain the event view object for the specified event and day.
FormatEventTime | This member function is used to format the time using the provided format.
GetCalendarControl | Call this member function to obtain a pointer to the Calendar Control object.
GetChildHandlerAt | Call this method to get a handler object at the specified numeric index.
GetChildHandlersCount | This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
GetDayHeaderFormat | Call this member function to determine the current format string.
GetDraggingEventNew | This member function is used to obtain the event object that is currently being edited. (i.e. dragging)
GetDraggingEventOrig | This member function is used to obtain the event object before the start of the event editing (dragging).
GetDraggingMode | Call this member function to determine the current dragging mode.
GetEventDurationMin | This member function is used to obtain the minimum event duration visible in the current view.
GetItemTextEventTimeMax | This member function is called by the calendar framework to retrieve event time string with maximum length (to reserve space).
GetLastSelectedDate | This member function is used to obtain the last selected day date.
GetLastSelectedViewEvent | This member function is used to obtain the last selected event view.
GetNextTimeEditByTAB | This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.
GetPaintManager | Call this member function to obtain the PaintManager object.
GetResources | Call this member function to obtain a pointer to the associated Calendar Resources collection object.
GetRowHeight | Call this member function to determine the row height required to display the event.
GetScrollBarInfoH | This member function is used to retrieve the information about a scroll bar state.
GetScrollBarInfoV | This member function is used to retrieve the information about a scroll bar state.
GetSelectedEvents | Call this member function to obtain a pointer to a selected event's views collection.
GetSelectedViewEvents | Call this member function to obtain a pointer to a selected event's views.
GetSelection | This member function is used to obtain the view's selection.
GetShowToolTipTimeOut | This member function is used to obtain the timeout value for displaying a tooltip.
GetStartEditSubjectTimeOut | This member function is used to obtain the time value after a mouse click event in the subject editing window.
GetSubjectEditorRect | Call this member function to obtain the bounding rectangle of the subject editor.
GetTheme | This member function obtains a pointer to the associated theme object.
GetTooltipRect | Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position
GetViewDay_ | Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
GetViewDayCount | Call this member function to obtain the number of "day views" in the view collection.
GetViewDayDate | Call this member function to obtain the date of the day view by the day's index.
GetViewRect | Call this member function to obtain the view's bounding rectangle.
GetViewType | Call this member function to obtain the view type flag.
HasSelectedViewEvent | Call this member function to determine if there are selected event view
HitTest | This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.
IsEditingSubject | Call this member function to determine if the subject is in an editable mode.
IsEditOperationDisabledNotify | This method is used to determine is specified editing operation disabled.
IsHScrollEnabled | This member function(s) is used to obtain status of the vertical or horizontal scrolling features of the view (by date or time).
IsSingleEventSelected | This member function is used to determine is just one event is selected.
IsTodayVisible | Call this member function to determine is Today day visible.
IsVScrollEnabled | This member function(s) is used to obtain status of the vertical or horizontal scrolling features of the view (by date or time).
KillTimer | This member function is used to destroy a timer event.
OnActivateView | This member function is called by the framework view is activated or deactivated.
OnBeforeDestroy | This member function is called by the framework before destroying the view.
OnBeforeEditOperationNotify |
OnBeforePasteNotify | This method is used to customize or disable paste editing operation.
OnChar | This member function is used to process keyboard events.
OnDragging | This member function is used to perform the event editing (dragging) operation step.
OnDraw | This member function performs all of the drawing logic of the calendar view.
OnEndDragging | This member function is used to finish the event editing (dragging) operation.
OnEventChanged_InDataProvider | This member function handles changing of an event in the associated data provider. It performs all the necessary validation of this action and returns an update result.
OnInPlaceCreateEvent | This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.
OnKeyDown | This member function is used to processes keyboard events.
OnLButtonDblClk | This member function is used to process mouse double-click events.
OnLButtonDown | This member function is used to processes left mouse button events.
OnLButtonUp | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
OnStartDragging | This member function is used to start the event editing (dragging).
OnSysKeyDown | This member function is used to processes system keyboard events.
OnTimer | The framework calls this member function after each interval specified in the SetTimer member function.
OnUpdateEditingSubject | Call this member function to set the new subject text for the editing event.
Paste | This member function is used to perform a Paste operation.
Populate | This member function is used to populate the view with data for all items contained in the view.
ProcessDaySelection | This member function is used to process the days selection that are selected with the mouse.
ProcessEventSelection | This member function is used to process events that are selected with the mouse.
Redo | This member function is used to perform a Redo operation.
RedrawControl | This member function is used to perform the redrawing of the control's layout.
ResetSelection | This member function resets the current selection - set it empty.
RetrieveDayEvents | Call this member function to get the collection of the day's events.
ScrollH | Scroll horizontally.
ScrollV | Scroll vertically.
SelectDay |
SelectDays | This member function is used to change the days selection depending on the previous state of the selection.
SelectEvent | This member function is used to select or un-select the provided event.
SelectionContains | This member function is used to determine if a date time value is contained inside the selection.
SelectViewEvent | This member function is used to select or un-select the provided event.
SendNotification | This member function is used to send a notification from the parent Calendar control.
SetDayHeaderFormatLong | This member function(s) is used to set date format string for the day view.
SetDayHeaderFormatMiddle | This member function(s) is used to set date format string for the day view.
SetDayHeaderFormatShort | This member function(s) is used to set date format string for the day view.
SetDayHeaderFormatShortest | This member function(s) is used to set date format string for the day view.
SetDraggingEvent | This member function is used to prepare the event to event editing (dragging) operation.
SetResources | This member function sets the new Resources collection for the view.
SetSelection | This member function sets the new selection for the view.
SetTimer | This member function is used to create a timer event.
ShowDay | This member function is used to show the specified day in the calendar view.
ShowToolTip | This member function is used to show/hide a ToolTip rectangle.
StartEditNewEventInplace | This member function is used to create a new event and start subject editing.
StartEditSubject | This member function is used to start the event subject editing.
Undo | This member function is used to perform an Undo operation.
UnselectAllEvents | Call this member function to un-select all of the events of the current view.
UpdateNextTimeEditByTAB | This member function is used to set the next date and time to start the find event view for editing events using the TAB key.
CXTPCalendarView Structures
CXTPCalendarView Structures | Description
SEventTimeFormatInfo |


CXTPCalendarView Classes

Classes, CXTPCalendarView Class
CXTPCalendarView Classes
Classes
Class | Description
CSelectionChanged_ContextData | This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary.
CSelectionChangedContext | Class CSelectionChangedContext used to avoid multiple sending of XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation.
CUndoBuffer | This helper class implements Undo/Redo events editing functionality.
Class

CXTPCalendarView Class


CXTPCalendarView::CSelectionChanged_ContextData Class

XTPCalendarView.h, CXTPCalendarView Classes, Legend, Members, Topics, CSelectionChanged_ContextData Data Members, CSelectionChanged_ContextData Constructors, CSelectionChanged_ContextData Constructors, CSelectionChanged_ContextData Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChanged_ContextData Class

This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary.

Class Hierarchy

class CSelectionChanged_ContextData;
File

XTPCalendarView.h

Group

CXTPCalendarView Classes

Legend
Data Member
Constructor
CSelectionChanged_ContextData Constructors
CSelectionChanged_ContextData Constructors | Description
CSelectionChanged_ContextData | Default object constructor.
CSelectionChanged_ContextData Data Members
CSelectionChanged_ContextData Data Members | Description
m_bRequest_Day | Days selection change send notification request.
m_bRequest_Event | Events selection change send notification request.
m_nLockCount | Selection change notification global Lock counter.
m_nLockCount_Day | Days selection change notification Lock counter.
m_nLockCount_Event | Events selection change notification Lock counter.


CSelectionChanged_ContextData Data Members

CXTPCalendarView::CSelectionChanged_ContextData Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CSelectionChanged_ContextData Data Members
Class

CXTPCalendarView::CSelectionChanged_ContextData Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bRequest_Day | Days selection change send notification request.
m_bRequest_Event | Events selection change send notification request.
m_nLockCount | Selection change notification global Lock counter.
m_nLockCount_Day | Days selection change notification Lock counter.
m_nLockCount_Event | Events selection change notification Lock counter.


CXTPCalendarView::CSelectionChanged_ContextData::m_bRequest_Day Data Member

CSelectionChanged_ContextData Data Members, CXTPCalendarView::CSelectionChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChanged_ContextData::m_bRequest_Day Data Member

Days selection change send notification request.

BOOL m_bRequest_Day;
Group

CSelectionChanged_ContextData Data Members


CXTPCalendarView::CSelectionChanged_ContextData::m_bRequest_Event Data Member

CSelectionChanged_ContextData Data Members, CXTPCalendarView::CSelectionChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChanged_ContextData::m_bRequest_Event Data Member

Events selection change send notification request.

BOOL m_bRequest_Event;
Group

CSelectionChanged_ContextData Data Members


CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount Data Member

CSelectionChanged_ContextData Data Members, CXTPCalendarView::CSelectionChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount Data Member

Selection change notification global Lock counter.

int m_nLockCount;
Group

CSelectionChanged_ContextData Data Members


CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount_Day Data Member

CSelectionChanged_ContextData Data Members, CXTPCalendarView::CSelectionChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount_Day Data Member

Days selection change notification Lock counter.

int m_nLockCount_Day;
Group

CSelectionChanged_ContextData Data Members


CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount_Event Data Member

CSelectionChanged_ContextData Data Members, CXTPCalendarView::CSelectionChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount_Event Data Member

Events selection change notification Lock counter.

int m_nLockCount_Event;
Group

CSelectionChanged_ContextData Data Members


CSelectionChanged_ContextData Constructors

CXTPCalendarView::CSelectionChanged_ContextData Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CSelectionChanged_ContextData Constructors
Class

CXTPCalendarView::CSelectionChanged_ContextData Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CSelectionChanged_ContextData | Default object constructor.


CXTPCalendarView::CSelectionChanged_ContextData::CSelectionChanged_ContextData Constructor

CSelectionChanged_ContextData Constructors, CXTPCalendarView::CSelectionChanged_ContextData Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChanged_ContextData::CSelectionChanged_ContextData Constructor

Default object constructor.

CSelectionChanged_ContextData();
Group

CSelectionChanged_ContextData Constructors


CXTPCalendarView::CSelectionChangedContext Class

XTPCalendarView.h, CXTPCalendarView Classes, Legend, Members, Topics, CSelectionChangedContext Constructors, CSelectionChangedContext Destructors, CSelectionChangedContext Constructors, CSelectionChangedContext Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChangedContext Class

Class CSelectionChangedContext used to avoid multiple sending of XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation.

Class Hierarchy

class CSelectionChangedContext;
File

XTPCalendarView.h

Group

CXTPCalendarView Classes

Legend
Constructor
virtual
CSelectionChangedContext Constructors
CSelectionChangedContext Constructors | Description
CSelectionChangedContext | Constructs a CSelectionChangedContext object.
CSelectionChangedContext Destructors
CSelectionChangedContext Destructors | Description
~CSelectionChangedContext | Destroys a CSelectionChangedContext object and send notification(s) if this is last locker object.


CSelectionChangedContext Constructors

CXTPCalendarView::CSelectionChangedContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CSelectionChangedContext Constructors
Class

CXTPCalendarView::CSelectionChangedContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CSelectionChangedContext | Constructs a CSelectionChangedContext object.


CXTPCalendarView::CSelectionChangedContext::CSelectionChangedContext Constructor

CSelectionChangedContext Constructors, CXTPCalendarView::CSelectionChangedContext Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChangedContext::CSelectionChangedContext Constructor

Constructs a CSelectionChangedContext object.

CSelectionChangedContext(
    CXTPCalendarView* pView,
    int eSelType = xtpCalendarSelectionUnknown
);
Parameters

pView
Pointer to parent CXTPCalendarView object.
eSelType
Value from enum XTPCalendarSelectionChanged. Changed selection type.

Remarks

eSelType = xtpCalendarSelectionUnknown only lock sending notifications.

See Also

XTP_NC_CALENDAR_SELECTION_CHANGED

Group

CSelectionChangedContext Constructors


CSelectionChangedContext Destructors

CXTPCalendarView::CSelectionChangedContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CSelectionChangedContext Destructors
Class

CXTPCalendarView::CSelectionChangedContext Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CSelectionChangedContext | Destroys a CSelectionChangedContext object and send notification(s) if this is last locker object.


CXTPCalendarView::CSelectionChangedContext::~CSelectionChangedContext Destructor

CSelectionChangedContext Destructors, CXTPCalendarView::CSelectionChangedContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CSelectionChangedContext::~CSelectionChangedContext Destructor

Destroys a CSelectionChangedContext object and send notification(s) if this is last locker object.

virtual ~CSelectionChangedContext();
Group

CSelectionChangedContext Destructors


CXTPCalendarView::CUndoBuffer Class

XTPCalendarView.h, CXTPCalendarView Classes, Legend, Members, Topics, CUndoBuffer Structures, CUndoBuffer Data Members, CUndoBuffer Methods, CUndoBuffer Constructors, CUndoBuffer Destructors, CUndoBuffer Constructors, CUndoBuffer Data Members, CUndoBuffer Destructors, CUndoBuffer Methods, CUndoBuffer Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer Class

This helper class implements Undo/Redo events editing functionality.

Class Hierarchy

class CUndoBuffer;
File

XTPCalendarView.h

Group

CXTPCalendarView Classes

Legend
Structure
Data Member
protected
Method
virtual
CUndoBuffer Constructors
CUndoBuffer Constructors | Description
CUndoBuffer | Default class constructor.
CUndoBuffer Data Members
CUndoBuffer Data Members | Description
m_arUndoActions | Array of editing/undo actions.
CUndoBuffer Destructors
CUndoBuffer Destructors | Description
~CUndoBuffer | Default class destructor.
CUndoBuffer Methods
CUndoBuffer Methods | Description
AddUndoAction | This member function is used to add an Undo action to the buffer.
GetCount | Call this member function to obtain the number of undo actions.
GetFirstUndoEvent | Call this member function to obtain the first undo event.
IsInUndoBuffer | This member function is used to search for an undo action for a specified event in the buffer.
RedoAllForEvent | This member function is used to search for last action for a specified event in the buffer.
RemoveAll | Call this member function to clear the Undo buffer.
Set | This member function is used to clear the current buffer of all undo actions and then add new undo actions to the buffer from the source object.
UndoAllForEvent | This member function is used to search for the first action for a specified event in the buffer.
CUndoBuffer Structures
CUndoBuffer Structures | Description
SUndoAction |


CUndoBuffer Structures

CXTPCalendarView::CUndoBuffer Class, Legend, Structures
CUndoBuffer Structures
Class

CXTPCalendarView::CUndoBuffer Class

Legend
Structure
Structures
Structure | Description
SUndoAction |


CXTPCalendarView::CUndoBuffer::SUndoAction Structure

XTPCalendarView.h, CUndoBuffer Structures, Legend, Members, Topics, SUndoAction Data Members, SUndoAction Constructors, SUndoAction Destructors, SUndoAction Operators, SUndoAction Constructors, SUndoAction Data Members, SUndoAction Destructors, SUndoAction Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::SUndoAction Structure
Class Hierarchy

struct SUndoAction {
  CXTPCalendarEventPtr ptrPrev;
  CXTPCalendarEventPtr ptrNew;
};
File

XTPCalendarView.h

Remarks

Helper structure to store editing/undo actions.

Group

CUndoBuffer Structures

Legend
Data Member
Constructor
virtual
Operator
SUndoAction Constructors
SUndoAction Constructors | Description
SUndoAction |
SUndoAction Data Members
SUndoAction Data Members | Description
ptrNew | Event instance after edit action.
ptrPrev | Event instance before edit action.
SUndoAction Destructors
SUndoAction Destructors | Description
~SUndoAction | Default class destructor.
SUndoAction Operators
SUndoAction Operators | Description
= | This is the overloaded assignment operator.


SUndoAction Data Members

CXTPCalendarView::CUndoBuffer::SUndoAction Structure, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
SUndoAction Data Members
Structure

CXTPCalendarView::CUndoBuffer::SUndoAction Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
ptrNew | Event instance after edit action.
ptrPrev | Event instance before edit action.


CXTPCalendarView::CUndoBuffer::SUndoAction::ptrNew Data Member

SUndoAction Data Members, CXTPCalendarView::CUndoBuffer::SUndoAction Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::SUndoAction::ptrNew Data Member

Event instance after edit action.

CXTPCalendarEventPtr ptrNew;
Group

SUndoAction Data Members


CXTPCalendarView::CUndoBuffer::SUndoAction::ptrPrev Data Member

SUndoAction Data Members, CXTPCalendarView::CUndoBuffer::SUndoAction Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::SUndoAction::ptrPrev Data Member

Event instance before edit action.

CXTPCalendarEventPtr ptrPrev;
Group

SUndoAction Data Members


SUndoAction Constructors

CXTPCalendarView::CUndoBuffer::SUndoAction Structure, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
SUndoAction Constructors
Structure

CXTPCalendarView::CUndoBuffer::SUndoAction Structure

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
SUndoAction |


SUndoAction Constructor

SUndoAction Constructors
SUndoAction Constructor
Overload List
Constructors
Constructor | Description
CXTPCalendarView::CUndoBuffer::SUndoAction::SUndoAction (CXTPCalendarEvent*, CXTPCalendarEvent*) | Default class constructor.
CXTPCalendarView::CUndoBuffer::SUndoAction::SUndoAction (const SUndoAction&) | Copy class constructor.
Group

SUndoAction Constructors


CXTPCalendarView::CUndoBuffer::SUndoAction::SUndoAction Constructor (CXTPCalendarEvent*, CXTPCalendarEvent*)

SUndoAction Constructor, CXTPCalendarView::CUndoBuffer::SUndoAction Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::SUndoAction::SUndoAction Constructor (CXTPCalendarEvent*, CXTPCalendarEvent*)

Default class constructor.

SUndoAction(
    CXTPCalendarEvent* pPrev = NULL,
    CXTPCalendarEvent* pNew = NULL
);
Parameters

pPrev
A CXTPCalendarEvent object that contains the instance before the edit action.
pNew
A CXTPCalendarEvent object that contains the instance after the edit action.

Body Source
SUndoAction(CXTPCalendarEvent* pPrev = NULL, CXTPCalendarEvent* pNew = NULL) :
ptrPrev(pPrev, TRUE), ptrNew(pNew, TRUE) {}
Group

SUndoAction Constructor


CXTPCalendarView::CUndoBuffer::SUndoAction::SUndoAction Constructor (const SUndoAction&)

SUndoAction Constructor, CXTPCalendarView::CUndoBuffer::SUndoAction Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::SUndoAction::SUndoAction Constructor (const SUndoAction&)

Copy class constructor.

SUndoAction(
    const SUndoAction& src
);
Parameters

src
A SUndoAction object that contains the source object.

Body Source
SUndoAction(const SUndoAction& src) {
    *this = src;
}
Group

SUndoAction Constructor


SUndoAction Destructors

CXTPCalendarView::CUndoBuffer::SUndoAction Structure, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
SUndoAction Destructors
Structure

CXTPCalendarView::CUndoBuffer::SUndoAction Structure

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~SUndoAction | Default class destructor.


CXTPCalendarView::CUndoBuffer::SUndoAction::~SUndoAction Destructor

SUndoAction Destructors, CXTPCalendarView::CUndoBuffer::SUndoAction Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::SUndoAction::~SUndoAction Destructor

Default class destructor.

virtual ~SUndoAction();
Body Source
virtual ~SUndoAction() {}
Group

SUndoAction Destructors


SUndoAction Operators

CXTPCalendarView::CUndoBuffer::SUndoAction Structure, Legend, Public Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
SUndoAction Operators
Structure

CXTPCalendarView::CUndoBuffer::SUndoAction Structure

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This is the overloaded assignment operator.


CXTPCalendarView::CUndoBuffer::SUndoAction::= Operator

SUndoAction Operators, CXTPCalendarView::CUndoBuffer::SUndoAction Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::SUndoAction::= Operator

This is the overloaded assignment operator.

const SUndoAction& operator =(
    const SUndoAction& src
);
Parameters

src
Source object.

Remarks

Copy class operator.

Body Source
const SUndoAction& operator=(const SUndoAction& src) {
    ptrPrev = src.ptrPrev;
    ptrNew = src.ptrNew;
    return *this;
}
Group

SUndoAction Operators


CUndoBuffer Data Members

CXTPCalendarView::CUndoBuffer Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CUndoBuffer Data Members
Class

CXTPCalendarView::CUndoBuffer Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arUndoActions | Array of editing/undo actions.


CXTPCalendarView::CUndoBuffer::m_arUndoActions Data Member

CUndoBuffer Data Members, CXTPCalendarView::CUndoBuffer Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::m_arUndoActions Data Member

Array of editing/undo actions.

CArray<SUndoAction, const SUndoAction&> m_arUndoActions;
Group

CUndoBuffer Data Members


CUndoBuffer Methods

CXTPCalendarView::CUndoBuffer Class, Legend, Public Methods
CUndoBuffer Methods
Class

CXTPCalendarView::CUndoBuffer Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddUndoAction | This member function is used to add an Undo action to the buffer.
GetCount | Call this member function to obtain the number of undo actions.
GetFirstUndoEvent | Call this member function to obtain the first undo event.
IsInUndoBuffer | This member function is used to search for an undo action for a specified event in the buffer.
RedoAllForEvent | This member function is used to search for last action for a specified event in the buffer.
RemoveAll | Call this member function to clear the Undo buffer.
Set | This member function is used to clear the current buffer of all undo actions and then add new undo actions to the buffer from the source object.
UndoAllForEvent | This member function is used to search for the first action for a specified event in the buffer.


CXTPCalendarView::CUndoBuffer::AddUndoAction Method

CUndoBuffer Methods, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::AddUndoAction Method

This member function is used to add an Undo action to the buffer.

void AddUndoAction(
    CXTPCalendarEvent* pPrev,
    CXTPCalendarEvent* pNew
);
Parameters

pPrev
A CXTPCalendarEvent object that contains the instance before the edit action.
pNew
A CXTPCalendarEvent that contains the instance after the edit action.

Body Source
void AddUndoAction(CXTPCalendarEvent* pPrev, CXTPCalendarEvent* pNew)
{
    CXTPCalendarEventPtr ptrPrevCopy = pPrev ? pPrev->CloneEvent() : NULL;
    CXTPCalendarEventPtr ptrNewCopy = pNew ? pNew->CloneEvent() : NULL;
    m_arUndoActions.Add(SUndoAction(ptrPrevCopy, ptrNewCopy));
}
Group

CUndoBuffer Methods


CXTPCalendarView::CUndoBuffer::GetCount Method

CUndoBuffer Methods, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::GetCount Method

Call this member function to obtain the number of undo actions.

int GetCount() const;
Returns

An int that contains the number of Undo actions.

Body Source
int GetCount() const {
    return (int)m_arUndoActions.GetSize();
}
Group

CUndoBuffer Methods


CXTPCalendarView::CUndoBuffer::GetFirstUndoEvent Method

CUndoBuffer Methods, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::GetFirstUndoEvent Method

Call this member function to obtain the first undo event.

CXTPCalendarEventPtr GetFirstUndoEvent();
Returns

A CXTPCalendarEvent object that contains the first undo event or NULL if there are no undo events.

Body Source
CXTPCalendarEventPtr GetFirstUndoEvent()
{
    int nCount = (int)m_arUndoActions.GetSize();
    if (nCount > 0)
    {
        SUndoAction& rAction = m_arUndoActions.ElementAt(0);
        if (rAction.ptrPrev) {
            return rAction.ptrPrev;
        }
        else if (rAction.ptrNew) {
            return rAction.ptrNew;
        }
    }
    return NULL;
}
Group

CUndoBuffer Methods


CXTPCalendarView::CUndoBuffer::IsInUndoBuffer Method

CUndoBuffer Methods, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::IsInUndoBuffer Method

This member function is used to search for an undo action for a specified event in the buffer.

BOOL IsInUndoBuffer(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
A CXTPCalendarEvent object to search for in the buffer.

Returns

A BOOL. TRUE if undo action for a specified event exists in the buffer. FALSE otherwise.

Body Source
BOOL IsInUndoBuffer(CXTPCalendarEvent* pEvent)
{
    int nCount = (int)m_arUndoActions.GetSize();
    for (int i = nCount-1; i >= 0; i--) {
        SUndoAction& rAction = m_arUndoActions.ElementAt(i);
        if (rAction.ptrPrev && rAction.ptrPrev->IsEqualIDs(pEvent) ||
            rAction.ptrNew && rAction.ptrNew->IsEqualIDs(pEvent))
        {
            return TRUE;
        }
    }
    return FALSE;
}
Group

CUndoBuffer Methods


CXTPCalendarView::CUndoBuffer::RedoAllForEvent Method

CUndoBuffer Methods, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::RedoAllForEvent Method

This member function is used to search for last action for a specified event in the buffer.

CXTPCalendarEventPtr RedoAllForEvent(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
A CXTPCalendarEvent object that contains the event to search for in the buffer.

Returns

A CXTPCalendarEvent that contains the latest event object from all of the editing actions or NULL if there are no events.

Body Source
CXTPCalendarEventPtr RedoAllForEvent(CXTPCalendarEvent* pEvent)
{
    CXTPCalendarEventPtr ptrResult;
    int nCount = (int)m_arUndoActions.GetSize();
    for (int i = nCount-1; i >= 0; i--)
    {
        SUndoAction& rAction = m_arUndoActions.ElementAt(i);
        if (rAction.ptrPrev && rAction.ptrPrev->IsEqualIDs(pEvent) ||
            rAction.ptrNew && rAction.ptrNew->IsEqualIDs(pEvent))
        {
            return rAction.ptrNew;
        }
    }
    return NULL;
}
Group

CUndoBuffer Methods


CXTPCalendarView::CUndoBuffer::RemoveAll Method

CUndoBuffer Methods, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::RemoveAll Method

Call this member function to clear the Undo buffer.

void RemoveAll();
Body Source
void RemoveAll() {
    m_arUndoActions.RemoveAll();
}
Group

CUndoBuffer Methods


CXTPCalendarView::CUndoBuffer::Set Method

CUndoBuffer Methods, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::Set Method

This member function is used to clear the current buffer of all undo actions and then add new undo actions to the buffer from the source object.

void Set(
    CUndoBuffer& rSrc
);
Parameters

rSrc
A CUndoBuffer object that contains the new undo actions to add to the undo buffer object.

Body Source
void Set(CUndoBuffer& rSrc) {
    m_arUndoActions.RemoveAll();
    m_arUndoActions.Append(rSrc.m_arUndoActions);
}
Group

CUndoBuffer Methods


CXTPCalendarView::CUndoBuffer::UndoAllForEvent Method

CUndoBuffer Methods, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::UndoAllForEvent Method

This member function is used to search for the first action for a specified event in the buffer.

CXTPCalendarEventPtr UndoAllForEvent(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
A CXTPCalendarEvent object that contains the event to search for in the buffer.

Returns

A CXTPCalendarEvent that contains the oldest event object from all of the editing actions or NULL if there are no events.

Body Source
CXTPCalendarEventPtr UndoAllForEvent(CXTPCalendarEvent* pEvent)
{
    int nCount = (int)m_arUndoActions.GetSize();
    for (int i = 0; i < nCount; i++)
    {
        SUndoAction& rAction = m_arUndoActions.ElementAt(i);
        if (rAction.ptrPrev && rAction.ptrPrev->IsEqualIDs(pEvent) ||
            rAction.ptrNew && rAction.ptrNew->IsEqualIDs(pEvent))
        {
            return rAction.ptrPrev;
        }
    }
    return NULL;
}
Group

CUndoBuffer Methods


CUndoBuffer Constructors

CXTPCalendarView::CUndoBuffer Class, Legend, Public Methods
CUndoBuffer Constructors
Class

CXTPCalendarView::CUndoBuffer Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CUndoBuffer | Default class constructor.


CXTPCalendarView::CUndoBuffer::CUndoBuffer Constructor

CUndoBuffer Constructors, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::CUndoBuffer Constructor

Default class constructor.

CUndoBuffer();
Body Source
CUndoBuffer() {}
Group

CUndoBuffer Constructors


CUndoBuffer Destructors

CXTPCalendarView::CUndoBuffer Class, Legend, Public Methods
CUndoBuffer Destructors
Class

CXTPCalendarView::CUndoBuffer Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CUndoBuffer | Default class destructor.


CXTPCalendarView::CUndoBuffer::~CUndoBuffer Destructor

CUndoBuffer Destructors, CXTPCalendarView::CUndoBuffer Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CUndoBuffer::~CUndoBuffer Destructor

Default class destructor.

virtual ~CUndoBuffer();
Body Source
virtual ~CUndoBuffer() {
    RemoveAll();
}
Group

CUndoBuffer Destructors


CXTPCalendarView Structures

CXTPCalendarView Class, Legend, Structures
CXTPCalendarView Structures
Class

CXTPCalendarView Class

Legend
Structure
Structures
Structure | Description
SEventTimeFormatInfo |


CXTPCalendarView::SEventTimeFormatInfo Structure

XTPCalendarView.h, CXTPCalendarView Structures, Legend, Members, Topics, SEventTimeFormatInfo Data Members, SEventTimeFormatInfo Constructors, SEventTimeFormatInfo Constructors, SEventTimeFormatInfo Data Members, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::SEventTimeFormatInfo Structure
Class Hierarchy

struct SEventTimeFormatInfo {
  CString strFormat;
  CString strAM;
  CString strPM;
  BOOL b24_HFormat;
};
File

XTPCalendarView.h

Remarks

This helper struct is used to group information which is necessary to format Start/End events times.

See Also

FormatEventTime, _CalculateEventTimeFormat.

Group

CXTPCalendarView Structures

Legend
Data Member
Constructor
SEventTimeFormatInfo Constructors
SEventTimeFormatInfo Constructors | Description
SEventTimeFormatInfo | Default object constructor.
SEventTimeFormatInfo Data Members
SEventTimeFormatInfo Data Members | Description
b24_HFormat | Is 24 hours time format.
strAM | AM symbol.
strFormat | Time format string.
strPM | PM symbol.


SEventTimeFormatInfo Data Members

CXTPCalendarView::SEventTimeFormatInfo Structure, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
SEventTimeFormatInfo Data Members
Structure

CXTPCalendarView::SEventTimeFormatInfo Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
b24_HFormat | Is 24 hours time format.
strAM | AM symbol.
strFormat | Time format string.
strPM | PM symbol.


CXTPCalendarView::SEventTimeFormatInfo::b24_HFormat Data Member

SEventTimeFormatInfo Data Members, CXTPCalendarView::SEventTimeFormatInfo Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::SEventTimeFormatInfo::b24_HFormat Data Member

Is 24 hours time format.

BOOL b24_HFormat;
Group

SEventTimeFormatInfo Data Members


CXTPCalendarView::SEventTimeFormatInfo::strAM Data Member

SEventTimeFormatInfo Data Members, CXTPCalendarView::SEventTimeFormatInfo Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::SEventTimeFormatInfo::strAM Data Member

AM symbol.

CString strAM;
Group

SEventTimeFormatInfo Data Members


CXTPCalendarView::SEventTimeFormatInfo::strFormat Data Member

SEventTimeFormatInfo Data Members, CXTPCalendarView::SEventTimeFormatInfo Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::SEventTimeFormatInfo::strFormat Data Member

Time format string.

CString strFormat;
Group

SEventTimeFormatInfo Data Members


CXTPCalendarView::SEventTimeFormatInfo::strPM Data Member

SEventTimeFormatInfo Data Members, CXTPCalendarView::SEventTimeFormatInfo Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::SEventTimeFormatInfo::strPM Data Member

PM symbol.

CString strPM;
Group

SEventTimeFormatInfo Data Members


SEventTimeFormatInfo Constructors

CXTPCalendarView::SEventTimeFormatInfo Structure, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
SEventTimeFormatInfo Constructors
Structure

CXTPCalendarView::SEventTimeFormatInfo Structure

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
SEventTimeFormatInfo | Default object constructor.


CXTPCalendarView::SEventTimeFormatInfo::SEventTimeFormatInfo Constructor

SEventTimeFormatInfo Constructors, CXTPCalendarView::SEventTimeFormatInfo Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::SEventTimeFormatInfo::SEventTimeFormatInfo Constructor

Default object constructor.

SEventTimeFormatInfo();
Body Source
SEventTimeFormatInfo() {b24_HFormat = FALSE;}
Group

SEventTimeFormatInfo Constructors


CXTPCalendarView Data Members

CXTPCalendarView Class, Legend, Protected Data Members
CXTPCalendarView Data Members
Class

CXTPCalendarView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bResetUndoBuffer | Clean undo buffer before add next undo action.
m_bScrollH_Disabled | Is horizontal scrolling disabled for a view.
m_bScrollV_Disabled | Is vertical scrolling disabled for a view.
m_bStartedClickInside | Is OnLButtonDown was inside view rect.
m_cntSelChanged | Counter on selection changes, is needed to redraw a view when necessary.
m_eDraggingMode | Editing event mode.
m_eUndoMode | Undo mode, see XTPCalendarUndoMode.
m_EventTimeFormat | Information used to format events times.
m_LastHitInfo | Last HitInfo data.
m_Layout | Layout data.
m_nKeyStateTimerID | Timer ID to check Keys state (like Control).
m_nTimerID_ShowToolTip | Timer ID of start show tooltip request.
m_nTimerID_StartEditSubject | Timer ID of edit event subject request.
m_pControl | Pointer to the owner control object.
m_pResources | Resources array
m_PrevUndoBuffer | Undo buffer data after last undo buffer clean.
m_pSelectedEvents | Selected Events;
m_ptrDraggingEventNew | Editing event object.
m_ptrDraggingEventOrig | Event object before start event editing.
m_ptrEditingViewEvent | Currently editing subject event view or event view requested to edit subject by timeout.
m_ptStartDragging | Request to start dragging operation from this point.
m_rcTooltip | Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
m_rcView | Client rect.
m_selectedBlock | Current selection.
m_spDraggingStartOffset | Start dragging operation offset from the beginning of the event.
m_strDayHeaderFormatDefaultLong | Day header Long date format default string.
m_strDayHeaderFormatDefaultMiddle | Day header Middle date format default string.
m_strDayHeaderFormatDefaultShort | Day header Short date format default string.
m_strDayHeaderFormatDefaultShortest | Day header Shortest date format default string.
m_strDayHeaderFormatLong | Day header Long date format custom string.
m_strDayHeaderFormatMiddle | Day header Middle date format custom string.
m_strDayHeaderFormatShort | Day header Short date format custom string.
m_strDayHeaderFormatShortest | Day header Shortest date format custom string.
m_strHeaderFormat | Day header active date format string.
m_UndoBuffer | Undo buffer object.


CXTPCalendarView::m_bResetUndoBuffer Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_bResetUndoBuffer Data Member

Clean undo buffer before add next undo action.

BOOL m_bResetUndoBuffer;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_bScrollH_Disabled Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_bScrollH_Disabled Data Member

Is horizontal scrolling disabled for a view.

BOOL m_bScrollH_Disabled;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_bScrollV_Disabled Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_bScrollV_Disabled Data Member

Is vertical scrolling disabled for a view.

BOOL m_bScrollV_Disabled;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_bStartedClickInside Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_bStartedClickInside Data Member

Is OnLButtonDown was inside view rect.

BOOL m_bStartedClickInside;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_cntSelChanged Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_cntSelChanged Data Member

Counter on selection changes, is needed to redraw a view when necessary.

CSelectionChanged_ContextData m_cntSelChanged;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_eDraggingMode Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_eDraggingMode Data Member

Editing event mode.

XTPCalendarDraggingMode m_eDraggingMode;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_eUndoMode Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_eUndoMode Data Member

Undo mode, see XTPCalendarUndoMode.

int m_eUndoMode;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_EventTimeFormat Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_EventTimeFormat Data Member

Information used to format events times.

SEventTimeFormatInfo m_EventTimeFormat;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_LastHitInfo Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_LastHitInfo Data Member

Last HitInfo data.

XTP_CALENDAR_HITTESTINFO m_LastHitInfo;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_Layout Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_Layout Data Member

Layout data.

XTP_VIEW_LAYOUT m_Layout;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_nKeyStateTimerID Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_nKeyStateTimerID Data Member

Timer ID to check Keys state (like Control).

UINT m_nKeyStateTimerID;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_nTimerID_ShowToolTip Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_nTimerID_ShowToolTip Data Member

Timer ID of start show tooltip request.

UINT m_nTimerID_ShowToolTip;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_nTimerID_StartEditSubject Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_nTimerID_StartEditSubject Data Member

Timer ID of edit event subject request.

UINT m_nTimerID_StartEditSubject;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_pControl Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_pControl Data Member

Pointer to the owner control object.

CXTPCalendarControl* m_pControl;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_pResources Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_pResources Data Member

Resources array

CXTPCalendarResources* m_pResources;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_PrevUndoBuffer Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_PrevUndoBuffer Data Member

Undo buffer data after last undo buffer clean.

CUndoBuffer m_PrevUndoBuffer;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_pSelectedEvents Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_pSelectedEvents Data Member

Selected Events;

CXTPCalendarViewEvents* m_pSelectedEvents;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_ptrDraggingEventNew Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_ptrDraggingEventNew Data Member

Editing event object.

CXTPCalendarEventPtr m_ptrDraggingEventNew;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_ptrDraggingEventOrig Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_ptrDraggingEventOrig Data Member

Event object before start event editing.

CXTPCalendarEventPtr m_ptrDraggingEventOrig;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_ptrEditingViewEvent Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_ptrEditingViewEvent Data Member

Currently editing subject event view or event view requested to edit subject by timeout.

CXTPCalendarViewEventPtr m_ptrEditingViewEvent;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_ptStartDragging Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_ptStartDragging Data Member

Request to start dragging operation from this point.

CPoint m_ptStartDragging;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_rcTooltip Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_rcTooltip Data Member

Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)

CRect m_rcTooltip;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_rcView Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_rcView Data Member

Client rect.

CRect m_rcView;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_selectedBlock Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_selectedBlock Data Member

Current selection.

XTP_CALENDAR_VIEWSELECTION m_selectedBlock;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_spDraggingStartOffset Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_spDraggingStartOffset Data Member

Start dragging operation offset from the beginning of the event.

COleDateTimeSpan m_spDraggingStartOffset;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strDayHeaderFormatDefaultLong Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strDayHeaderFormatDefaultLong Data Member

Day header Long date format default string.

CString m_strDayHeaderFormatDefaultLong;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strDayHeaderFormatDefaultMiddle Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strDayHeaderFormatDefaultMiddle Data Member

Day header Middle date format default string.

CString m_strDayHeaderFormatDefaultMiddle;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strDayHeaderFormatDefaultShort Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strDayHeaderFormatDefaultShort Data Member

Day header Short date format default string.

CString m_strDayHeaderFormatDefaultShort;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strDayHeaderFormatDefaultShortest Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strDayHeaderFormatDefaultShortest Data Member

Day header Shortest date format default string.

CString m_strDayHeaderFormatDefaultShortest;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strDayHeaderFormatLong Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strDayHeaderFormatLong Data Member

Day header Long date format custom string.

CString m_strDayHeaderFormatLong;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strDayHeaderFormatMiddle Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strDayHeaderFormatMiddle Data Member

Day header Middle date format custom string.

CString m_strDayHeaderFormatMiddle;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strDayHeaderFormatShort Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strDayHeaderFormatShort Data Member

Day header Short date format custom string.

CString m_strDayHeaderFormatShort;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strDayHeaderFormatShortest Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strDayHeaderFormatShortest Data Member

Day header Shortest date format custom string.

CString m_strDayHeaderFormatShortest;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_strHeaderFormat Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_strHeaderFormat Data Member

Day header active date format string.

CString m_strHeaderFormat;
Group

CXTPCalendarView Data Members


CXTPCalendarView::m_UndoBuffer Data Member

CXTPCalendarView Data Members, CXTPCalendarView Class
CXTPCalendarView::m_UndoBuffer Data Member

Undo buffer object.

CUndoBuffer m_UndoBuffer;
Group

CXTPCalendarView Data Members


CXTPCalendarView Methods

CXTPCalendarView Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView Methods
Class

CXTPCalendarView Class

Legend
Method
protected
virtual
abstract
Protected Methods
Protected Methods
Protected Method | Description
_CalculateEventTimeFormat | This member function is used to create the time format string.
_CanSubjectEditor | This member function is used to determine if the specified editing operation command is possible for the event subject editor window.
_CopySelectedEvents | This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.
_GetDayHeaderFormat | This member function get custom or default day header date format string.
_GetMaxWidth | This member function is used to calculate, in pixels, the max date width for the specified format string.
_GetMaxWidthFormat | This function is used to calculates the max width of the date used in the specified format string.
_GetSubjectEditorWnd | This member function is used to obtain a pointer to the event subject editor window.
_IsDragModeCopyMove | This method is used to determine Copy or Move dragging mode.
_ReadDefaultHeaderFormats | This member function is used to build day header date format default strings.
_ReadEventsFromClipboard | This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.
_RemoveYearPart | This member function is used to remove the year part from the specified format string.
_Undo | This member function is used to perform an undo/redo operation for the specified event.
GetEventDurationMin | This member function is used to obtain the minimum event duration visible in the current view.
IsEditOperationDisabledNotify | This method is used to determine is specified editing operation disabled.
KillTimer | This member function is used to destroy a timer event.
OnActivateView | This member function is called by the framework view is activated or deactivated.
OnBeforeDestroy | This member function is called by the framework before destroying the view.
OnBeforeEditOperationNotify |
OnBeforePasteNotify | This method is used to customize or disable paste editing operation.
OnEventChanged_InDataProvider | This member function handles changing of an event in the associated data provider. It performs all the necessary validation of this action and returns an update result.
OnInPlaceCreateEvent | This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.
OnTimer | The framework calls this member function after each interval specified in the SetTimer member function.
SendNotification | This member function is used to send a notification from the parent Calendar control.
SetTimer | This member function is used to create a timer event.
Public Methods
Public Methods
Public Method | Description
_GetViewDay | Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
AdjustLayout | This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
CalculateHeaderFormat | This member function creates the day header format string.
CancelDraggingEvent | This member function is used to cancel the event editing (dragging) operation.
CanCopy | Call this member function to determine if it is possible to perform a Copy operation.
CanCut | Call this member function to determine if it is possible to perform a Cut operation.
CanPaste | Call this member function to determine if it is possible to perform a Paste operation.
CanRedo | Call this member function to determine if a redo operation is possible for the subject editor.
CanUndo | Call this member function to determine if you can perform an undo operation for the subject editor.
CommitDraggingEvent | This member function is used to commit the event editing (dragging) operation.
Copy | This member function is used to perform a Copy operation.
Cut | This member function is used to perform a Cut operation.
Draw | This member function is used to draw the view content using the specified device context.
Draw2 | This member function is used to draw the view content using the specified device context.
EmptyUndoBuffer | This member function is used to erases the undo buffer.
EnableHScroll | This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
EnableVScroll | This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
EndEditSubject | This member function is used to finish the event subject editing.
FindEventToEditByTAB | This member function is used to obtain the next event view object used for editing events by pressing the TAB key.
FindLastSelectedDay | This member function is used to obtain the last selected day index.
FindViewEvent | This member function is used to obtain the event view object for the specified event and day.
FormatEventTime | This member function is used to format the time using the provided format.
GetCalendarControl | Call this member function to obtain a pointer to the Calendar Control object.
GetChildHandlerAt | Call this method to get a handler object at the specified numeric index.
GetChildHandlersCount | This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
GetDayHeaderFormat | Call this member function to determine the current format string.
GetDraggingEventNew | This member function is used to obtain the event object that is currently being edited. (i.e. dragging)
GetDraggingEventOrig | This member function is used to obtain the event object before the start of the event editing (dragging).
GetDraggingMode | Call this member function to determine the current dragging mode.
GetItemTextEventTimeMax | This member function is called by the calendar framework to retrieve event time string with maximum length (to reserve space).
GetLastSelectedDate | This member function is used to obtain the last selected day date.
GetLastSelectedViewEvent | This member function is used to obtain the last selected event view.
GetNextTimeEditByTAB | This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.
GetPaintManager | Call this member function to obtain the PaintManager object.
GetResources | Call this member function to obtain a pointer to the associated Calendar Resources collection object.
GetRowHeight | Call this member function to determine the row height required to display the event.
GetScrollBarInfoH | This member function is used to retrieve the information about a scroll bar state.
GetScrollBarInfoV | This member function is used to retrieve the information about a scroll bar state.
GetSelectedEvents | Call this member function to obtain a pointer to a selected event's views collection.
GetSelectedViewEvents | Call this member function to obtain a pointer to a selected event's views.
GetSelection | This member function is used to obtain the view's selection.
GetShowToolTipTimeOut | This member function is used to obtain the timeout value for displaying a tooltip.
GetStartEditSubjectTimeOut | This member function is used to obtain the time value after a mouse click event in the subject editing window.
GetSubjectEditorRect | Call this member function to obtain the bounding rectangle of the subject editor.
GetTheme | This member function obtains a pointer to the associated theme object.
GetTooltipRect | Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position
GetViewDay_ | Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
GetViewDayCount | Call this member function to obtain the number of "day views" in the view collection.
GetViewDayDate | Call this member function to obtain the date of the day view by the day's index.
GetViewRect | Call this member function to obtain the view's bounding rectangle.
GetViewType | Call this member function to obtain the view type flag.
HasSelectedViewEvent | Call this member function to determine if there are selected event view
HitTest | This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.
IsEditingSubject | Call this member function to determine if the subject is in an editable mode.
IsHScrollEnabled | This member function(s) is used to obtain status of the vertical or horizontal scrolling features of the view (by date or time).
IsSingleEventSelected | This member function is used to determine is just one event is selected.
IsTodayVisible | Call this member function to determine is Today day visible.
IsVScrollEnabled | This member function(s) is used to obtain status of the vertical or horizontal scrolling features of the view (by date or time).
OnChar | This member function is used to process keyboard events.
OnDragging | This member function is used to perform the event editing (dragging) operation step.
OnDraw | This member function performs all of the drawing logic of the calendar view.
OnEndDragging | This member function is used to finish the event editing (dragging) operation.
OnKeyDown | This member function is used to processes keyboard events.
OnLButtonDblClk | This member function is used to process mouse double-click events.
OnLButtonDown | This member function is used to processes left mouse button events.
OnLButtonUp | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
OnStartDragging | This member function is used to start the event editing (dragging).
OnSysKeyDown | This member function is used to processes system keyboard events.
OnUpdateEditingSubject | Call this member function to set the new subject text for the editing event.
Paste | This member function is used to perform a Paste operation.
Populate | This member function is used to populate the view with data for all items contained in the view.
ProcessDaySelection | This member function is used to process the days selection that are selected with the mouse.
ProcessEventSelection | This member function is used to process events that are selected with the mouse.
Redo | This member function is used to perform a Redo operation.
RedrawControl | This member function is used to perform the redrawing of the control's layout.
ResetSelection | This member function resets the current selection - set it empty.
RetrieveDayEvents | Call this member function to get the collection of the day's events.
ScrollH | Scroll horizontally.
ScrollV | Scroll vertically.
SelectDay |
SelectDays | This member function is used to change the days selection depending on the previous state of the selection.
SelectEvent | This member function is used to select or un-select the provided event.
SelectionContains | This member function is used to determine if a date time value is contained inside the selection.
SelectViewEvent | This member function is used to select or un-select the provided event.
SetDayHeaderFormatLong | This member function(s) is used to set date format string for the day view.
SetDayHeaderFormatMiddle | This member function(s) is used to set date format string for the day view.
SetDayHeaderFormatShort | This member function(s) is used to set date format string for the day view.
SetDayHeaderFormatShortest | This member function(s) is used to set date format string for the day view.
SetDraggingEvent | This member function is used to prepare the event to event editing (dragging) operation.
SetResources | This member function sets the new Resources collection for the view.
SetSelection | This member function sets the new selection for the view.
ShowDay | This member function is used to show the specified day in the calendar view.
ShowToolTip | This member function is used to show/hide a ToolTip rectangle.
StartEditNewEventInplace | This member function is used to create a new event and start subject editing.
StartEditSubject | This member function is used to start the event subject editing.
Undo | This member function is used to perform an Undo operation.
UnselectAllEvents | Call this member function to un-select all of the events of the current view.
UpdateNextTimeEditByTAB | This member function is used to set the next date and time to start the find event view for editing events using the TAB key.


CXTPCalendarView::_CalculateEventTimeFormat Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::_CalculateEventTimeFormat Method

This member function is used to create the time format string.

virtual void _CalculateEventTimeFormat();
Remarks

Call this member function to create the time format string based on the current locale.

Group

CXTPCalendarView Methods


CXTPCalendarView::_CanSubjectEditor Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::_CanSubjectEditor Method

This member function is used to determine if the specified editing operation command is possible for the event subject editor window.

virtual BOOL _CanSubjectEditor(
    UINT idEditCmd
);
Parameters

idEditCmd
A UINT that contains the editing operation command ID: ID_EDIT_UNDO, ID_EDIT_CUT, ID_EDIT_COPY, or ID_EDIT_PASTE.

Returns

A BOOL. TRUE - if the subject editing mode and specified editing operation are possible. FALSE otherwise.

Remarks

This function works correctly even when there is no subject editing mode.

Group

CXTPCalendarView Methods


CXTPCalendarView::_CopySelectedEvents Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::_CopySelectedEvents Method

This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.

virtual COleDataSource* _CopySelectedEvents(
    DWORD dwCopyFlags = 0
);
Parameters

dwCopyFlags
A DWORD that contains a set of flags from the enum XTPCalendarClipboardCopyFlags or user defined values.

Returns

If there are selected events, then the function returns a pointer to a new COleDataSource object. If there are no selected events, then the function returns NULL.

Remarks

COleDataSource->SetClipboard method must be called to place data into the clipboard. Keep in mind - SetClipboard calls InternalRelease.

See Also

_ReadEventsFromClipboard, XTPCalendarClipboardCopyFlags, XTPCALENDARCTRL_CF_EVENT, COleDataSource

Group

CXTPCalendarView Methods


CXTPCalendarView::_GetDayHeaderFormat Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::_GetDayHeaderFormat Method

This member function get custom or default day header date format string.

virtual CString _GetDayHeaderFormat(
    int nLevel
);
Parameters

nLevel
Format width level: 0 - Long, 1 - Middle, 2 - Short, 3 - Shortest.

Returns

Active header date format string for the specified width level.

Remarks

Returns m_strDayHeaderFormatXXX member value if is not empty, otherwise m_strDayHeaderFormatDefaultXXX member value is returned.

See Also

m_strDayHeaderFormatDefaultLong, m_strDayHeaderFormatDefaultMiddle, m_strDayHeaderFormatDefaultShort, m_strDayHeaderFormatDefaultShortest, m_strDayHeaderFormatLong, m_strDayHeaderFormatMiddle, m_strDayHeaderFormatShort, m_strDayHeaderFormatShortest.

Group

CXTPCalendarView Methods


CXTPCalendarView::_GetMaxWidth Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::_GetMaxWidth Method

This member function is used to calculate, in pixels, the max date width for the specified format string.

virtual int _GetMaxWidth(
    CDC* pDC,
    CString strFormat
);
Parameters

pDC
A pointer to a valid device context.
strFormat
A CString that contains the date format string.

Returns

An int that contains the maximum date width, in pixels.

Remarks

Use this member function to calculate the maximum width of the date string.

Group

CXTPCalendarView Methods


CXTPCalendarView::_GetMaxWidthFormat Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::_GetMaxWidthFormat Method

This function is used to calculates the max width of the date used in the specified format string.

virtual CString _GetMaxWidthFormat(
    CDC* pDC,
    CString strFormat,
    BOOL bMonth
);
Parameters

pDC
Pointer to a valid device context.
strFormat
A CString that contains the date format string.
bMonth
A BOOL. If TRUE, then calculate the max width for all the months in a year, otherwise calculate the max width for all week days.

Returns

A CString containing the name of the month or the name of the day of the week that has the maximum width.

Remarks

Use this member function to calculate the header format width.

Group

CXTPCalendarView Methods


CXTPCalendarView::_GetSubjectEditorWnd Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::_GetSubjectEditorWnd Method

This member function is used to obtain a pointer to the event subject editor window.

virtual CWnd* _GetSubjectEditorWnd();
Returns

Pointer to the CWnd or NULL.

Remarks

Works correctly even when not using a subject editing mode.

Group

CXTPCalendarView Methods


CXTPCalendarView::_IsDragModeCopyMove Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::_IsDragModeCopyMove Method

This method is used to determine Copy or Move dragging mode.

BOOL _IsDragModeCopyMove(
    int eDragMode
) const;
Parameters

eDragMode
A value from enum XTPCalendarDraggingMode.

Returns

TRUE if eDragMode == xtpCalendaDragModeCopy or eDragMode == xtpCalendaDragModeMove.

Body Source
BOOL CXTPCalendarView::_IsDragModeCopyMove(int eDragMode) const {
    return eDragMode == xtpCalendaDragModeCopy || eDragMode == xtpCalendaDragModeMove;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::_ReadDefaultHeaderFormats Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::_ReadDefaultHeaderFormats Method

This member function is used to build day header date format default strings.

virtual void _ReadDefaultHeaderFormats();
Remarks

This member function read locale settings and fill m_strDayHeaderFormatDefaultXXX members.

See Also

CalculateHeaderFormat(), m_strDayHeaderFormatDefaultLong, m_strDayHeaderFormatDefaultMiddle, m_strDayHeaderFormatDefaultShort, m_strDayHeaderFormatDefaultShortest.

Group

CXTPCalendarView Methods


CXTPCalendarView::_ReadEventsFromClipboard Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::_ReadEventsFromClipboard Method

This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.

virtual CXTPCalendarEventsPtr _ReadEventsFromClipboard(
    COleDataObject* pData,
    DWORD* pdwCopyFlags = NULL
);
Parameters

pData
A COleDataObject pointer to the data object.
pdwCopyFlags
A pointer to a DWORD that contains the CopyFlags. These flags are set in the _CopySelectedEvents call. The flag values are from the XTPCalendarClipboardCopyFlags enum or are user defined values.

Returns

A pointer to a CXTPCalendarEvents object. NULL - If there are no events in the clipboard. Otherwise, a pointer to a new CXTPCalendarEvents objects collection.

Remarks

COleDataSource->AttachClipboard method must be called to retrieve data from the clipboard.

See Also

_CopySelectedEvents, XTPCalendarClipboardCopyFlags, XTPCALENDARCTRL_CF_EVENT, COleDataSource

Group

CXTPCalendarView Methods


CXTPCalendarView::_RemoveYearPart Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::_RemoveYearPart Method

This member function is used to remove the year part from the specified format string.

virtual void _RemoveYearPart(
    CString& strFormat
);
Parameters

strFormat
[IN/OUT] A CString object that contains the date format string reference.

Remarks

This member function is used to calculate the header format.

Group

CXTPCalendarView Methods


CXTPCalendarView::_Undo Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::_Undo Method

This member function is used to perform an undo/redo operation for the specified event.

virtual BOOL _Undo(
    CXTPCalendarEvent* pEvent = NULL
);
Parameters

pEvent
A pointer to a CXTPCalendarEvent object that contains the undo/redo action.

Returns

A BOOL. TRUE if the undo operation is successful. FALSE otherwise.

See Also

Undo, Redo, m_UndoBuffer, m_eUndoMode, XTPCalendarUndoMode

Group

CXTPCalendarView Methods


CXTPCalendarView::AdjustLayout Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::AdjustLayout Method

This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcView,
    BOOL bCallPostAdjustLayout = TRUE
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcView,
    BOOL bCallPostAdjustLayout = TRUE
);
Parameters

pDC
Pointer to a valid device context.
rcView
A CRect that contains the coordinates for drawing the view.
bCallPostAdjustLayout
A BOOL. This is a flag that is used to call for additional adjustments. If TRUE, then additional adjustments are performed for multi day events. If FALSE, then no additional adjustments are made.

Remarks

Call Populate() prior adjusting layout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarView Methods


CXTPCalendarView::CalculateHeaderFormat Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::CalculateHeaderFormat Method

This member function creates the day header format string.

virtual void CalculateHeaderFormat(
    CDC* pDC,
    int nWidth,
    CFont* pTextFont
);
Parameters

pDC
Pointer to a valid device context.
nWidth
An int that contains the day header with in pixels.
pTextFont
A pointer to a CFont object that is used to calculate the text dimensions.

Remarks

Call this member function to create day header format string based on the current locale.

Group

CXTPCalendarView Methods


CXTPCalendarView::CancelDraggingEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::CancelDraggingEvent Method

This member function is used to cancel the event editing (dragging) operation.

virtual void CancelDraggingEvent();
Group

CXTPCalendarView Methods


CXTPCalendarView::CanCopy Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::CanCopy Method

Call this member function to determine if it is possible to perform a Copy operation.

virtual BOOL CanCopy();
Returns

A BOOL. TRUE if the copy operation is possible. FALSE otherwise.

Remarks

This member function is used to determine the possibility of performing a Copy operation in the subject editor.

Group

CXTPCalendarView Methods


CXTPCalendarView::CanCut Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::CanCut Method

Call this member function to determine if it is possible to perform a Cut operation.

virtual BOOL CanCut();
Returns

A BOOL. TRUE if the cut operation is possible. FALSE otherwise.

Remarks

This member function is used to determine the possibility of performing a Cut operation in the subject editor.

Group

CXTPCalendarView Methods


CXTPCalendarView::CanPaste Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::CanPaste Method

Call this member function to determine if it is possible to perform a Paste operation.

virtual BOOL CanPaste();
Returns

A BOOL. TRUE if the paste operation is possible. FALSE otherwise.

Remarks

This member function is used to determine the possibility of performing a Paste operation in the subject editor.

Group

CXTPCalendarView Methods


CXTPCalendarView::CanRedo Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::CanRedo Method

Call this member function to determine if a redo operation is possible for the subject editor.

virtual BOOL CanRedo();
Returns

A BOOL. TRUE if it is possible to perform a redo operation on the subject-editor. FALSE otherwise.

Group

CXTPCalendarView Methods


CXTPCalendarView::CanUndo Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::CanUndo Method

Call this member function to determine if you can perform an undo operation for the subject editor.

virtual BOOL CanUndo();
Returns

A BOOL. TRUE if there is the possibility to perform an undo operation. FALSE otherwise.

Group

CXTPCalendarView Methods


CXTPCalendarView::CommitDraggingEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::CommitDraggingEvent Method

This member function is used to commit the event editing (dragging) operation.

virtual BOOL CommitDraggingEvent();
Returns

A BOOL. TRUE if the event editing is successful. FALSE otherwise.

Group

CXTPCalendarView Methods


CXTPCalendarView::Copy Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::Copy Method

This member function is used to perform a Copy operation.

virtual BOOL Copy();
Returns

A BOOL. TRUE if the copy operation is successful. FALSE otherwise.

Remarks

Call this member function to perform a Copy operation in the subject editor's window.

Group

CXTPCalendarView Methods


CXTPCalendarView::Cut Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::Cut Method

This member function is used to perform a Cut operation.

virtual BOOL Cut();
Returns

A BOOL. TRUE if the cut operation is successful. FALSE otherwise.

Remarks

Call this member function to perform a Cut operation in the subject editor's window.

Group

CXTPCalendarView Methods


CXTPCalendarView::Draw Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::Draw Method

This member function is used to draw the view content using the specified device context.

virtual void Draw(
    CDC* pDC
);
virtual void Draw2(
    CDC* pDC
);
Parameters

pDC
A pointer to a valid device context.

Remarks

Call AdjustLayout() before calling Draw(). Draw2 is called from OnDraw instead of Draw when theme is set.

See Also

OnDraw, AdjustLayout

Body Source
virtual void Draw(CDC* pDC) {
    UNREFERENCED_PARAMETER(pDC);
}

virtual void Draw2(CDC* pDC) {
    UNREFERENCED_PARAMETER(pDC);
    //Draw(pDC);
}
Group

CXTPCalendarView Methods


CXTPCalendarView::EmptyUndoBuffer Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::EmptyUndoBuffer Method

This member function is used to erases the undo buffer.

virtual void EmptyUndoBuffer();
Body Source
void CXTPCalendarView::EmptyUndoBuffer() {
    m_UndoBuffer.RemoveAll();
    m_eUndoMode = xtpCalendarUndoModeUnknown;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::EnableVScroll Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::EnableVScroll Method

This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).

virtual void EnableVScroll(
    BOOL bEnable = TRUE
);
virtual void EnableHScroll(
    BOOL bEnable = TRUE
);
Parameters

bEnable
Set TRUE to enable scrolling, FALSE to disable.

Remarks

Vertical and horizontal scrolling are enabled by default.

Body Source
void CXTPCalendarView::EnableVScroll(BOOL bEnable) {
    m_bScrollV_Disabled = !bEnable;
}

void CXTPCalendarView::EnableHScroll(BOOL bEnable) {
    m_bScrollH_Disabled = !bEnable;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::EndEditSubject Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::EndEditSubject Method

This member function is used to finish the event subject editing.

virtual void EndEditSubject(
    XTPCalendarEndEditSubjectAction eAction,
    BOOL bUpdateControl = TRUE
);
Parameters

eAction
An XTPCalendarEndEditSubjectAction object that contains the value to commit or cancel the operation. See enum XTPCalendarEndEditSubjectAction.
bUpdateControl
A BOOL. If TRUE, then redraw the control immediately, otherwise perform only the specified action without redrawing.

Group

CXTPCalendarView Methods


CXTPCalendarView::FindEventToEditByTAB Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::FindEventToEditByTAB Method

This member function is used to obtain the next event view object used for editing events by pressing the TAB key.

virtual CXTPCalendarViewEvent* FindEventToEditByTAB(
    COleDateTime dtMinStart,
    BOOL bReverse,
    CXTPCalendarEvent* pAfterEvent = NULL
);
Parameters

dtMinStart
A COleDateTime object that contains the first date and time to start the search.
bReverse
If TRUE the reverse order is used, otherwise normal is used.
pAfterEvent
A CXTPCalendarEvent object that contains the last event object to search for.

Returns

A CXTPCalendarViewEvent object that contains the view object or NULL.

See Also

GetNextTimeEditByTAB, UpdateNextTimeEditByTAB

Group

CXTPCalendarView Methods


CXTPCalendarView::FindLastSelectedDay Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::FindLastSelectedDay Method

This member function is used to obtain the last selected day index.

int FindLastSelectedDay();
Returns

Index of the last selected day of -1.

See Also

GetLastSelectedDate()

Group

CXTPCalendarView Methods


CXTPCalendarView::FindViewEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::FindViewEvent Method

This member function is used to obtain the event view object for the specified event and day.

virtual CXTPCalendarViewEvent* FindViewEvent(
    CXTPCalendarEvent* pEvent,
    COleDateTime dtDay
);
Parameters

pEvent
A CXTPCalendarEvent object that contains the value to search for.
dtDay
A COleDateTime object that contains the day that corresponds to the event object.

Returns

A CXTPCalendarViewEvent object that contains the view object or NULL.

Group

CXTPCalendarView Methods


CXTPCalendarView::FormatEventTime Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::FormatEventTime Method

This member function is used to format the time using the provided format.

virtual CString FormatEventTime(
    COleDateTime dtTime
);
Parameters

dtTime
Date-time value to format time part.

Returns

A CString object containing the formatted time string.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetCalendarControl Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetCalendarControl Method

Call this member function to obtain a pointer to the Calendar Control object.

virtual CXTPCalendarControl* GetCalendarControl();
Returns

A pointer to the CXTPCalendarControl object.

See Also

CXTPCalendarControl

Body Source
CXTPCalendarControl* CXTPCalendarView::GetCalendarControl() {

    ASSERT(this && m_pControl);
    return this ? m_pControl : NULL;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetChildHandlerAt Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetChildHandlerAt Method

Call this method to get a handler object at the specified numeric index.

virtual CXTPCalendarWMHandler* GetChildHandlerAt(
    int nIndex
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns

The pointer to the CXTPCalendarWMHandler element currently at this index.

Remarks

Returns the array element at the specified index.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetChildHandlersCount Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetChildHandlersCount Method

This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.

virtual int GetChildHandlersCount();
Returns

A count of descendant handlers.

Remarks

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

See Also

CXTPCalendarWMHandler overview

Body Source
int CXTPCalendarView::GetChildHandlersCount() {
    return GetViewDayCount();
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetDayHeaderFormat Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetDayHeaderFormat Method

Call this member function to determine the current format string.

virtual CString GetDayHeaderFormat();
Returns

A CString object that contains the format string.

Body Source
CString CXTPCalendarView::GetDayHeaderFormat() {
    return m_strHeaderFormat;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetDraggingEventNew Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetDraggingEventNew Method

This member function is used to obtain the event object that is currently being edited. (i.e. dragging)

virtual CXTPCalendarEvent* GetDraggingEventNew();
Returns

A pointer to a CXTPCalendarEvent object or NULL.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetDraggingEventOrig Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetDraggingEventOrig Method

This member function is used to obtain the event object before the start of the event editing (dragging).

virtual CXTPCalendarEvent* GetDraggingEventOrig();
Returns

A pointer to a CXTPCalendarEvent object before the start the event editing or NULL.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetDraggingMode Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetDraggingMode Method

Call this member function to determine the current dragging mode.

virtual XTPCalendarDraggingMode GetDraggingMode() const;
Returns

An XTPCalendarDraggingModeFlag object that contains the current dragging mode.

See Also

XTPCalendarDraggingMode

Body Source
XTPCalendarDraggingMode CXTPCalendarView::GetDraggingMode() const {
    return m_eDraggingMode;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetEventDurationMin Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetEventDurationMin Method

This member function is used to obtain the minimum event duration visible in the current view.

virtual COleDateTimeSpan GetEventDurationMin() const;
Returns

A COleDateTimeSpan object that contains the minimum duration of the event.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetItemTextEventTimeMax Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetItemTextEventTimeMax Method

This member function is called by the calendar framework to retrieve event time string with maximum length (to reserve space).

virtual CString GetItemTextEventTimeMax();
Returns

A maximum time string.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetLastSelectedDate Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetLastSelectedDate Method

This member function is used to obtain the last selected day date.

COleDateTime GetLastSelectedDate();
Returns

Date of the last selected day or the middle view day date.

See Also

FindLastSelectedDay(), GetSelection(), SetSelection().

Group

CXTPCalendarView Methods


CXTPCalendarView::GetLastSelectedViewEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetLastSelectedViewEvent Method

This member function is used to obtain the last selected event view.

CXTPCalendarViewEvent* GetLastSelectedViewEvent();
Returns

A pointer to last selected event view or NULL.

See Also

CXTPCalendarViewEvent, GetSelectedViewEvents().

Group

CXTPCalendarView Methods


CXTPCalendarView::GetNextTimeEditByTAB Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetNextTimeEditByTAB Method

This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.

virtual COleDateTime GetNextTimeEditByTAB();
Returns

A COleDateTime object that contains the next date and time.

See Also

FindEventToEditByTAB, UpdateNextTimeEditByTAB

Group

CXTPCalendarView Methods


CXTPCalendarView::GetPaintManager Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetPaintManager Method

Call this member function to obtain the PaintManager object.

virtual CXTPCalendarPaintManager* GetPaintManager();
Returns

A pointer to the CXTPCalendarPaintManager object.

See Also

CXTPCalendarPaintManager, GetTheme

Group

CXTPCalendarView Methods


CXTPCalendarView::GetResources Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetResources Method

Call this member function to obtain a pointer to the associated Calendar Resources collection object.

virtual CXTPCalendarResources* GetResources();
Returns

A pointer to the CXTPCalendarResources collection object.

See Also

CXTPCalendarResources overview, CXTPCalendarResource overview

Group

CXTPCalendarView Methods


CXTPCalendarView::GetRowHeight Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetRowHeight Method

Call this member function to determine the row height required to display the event.

virtual int GetRowHeight() const;
Returns

An int that contains the height of the row required to display a single event.

Body Source
int CXTPCalendarView::GetRowHeight() const {
    return m_Layout.m_nRowHeight;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetScrollBarInfoH Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetScrollBarInfoH Method

This member function is used to retrieve the information about a scroll bar state.

virtual BOOL GetScrollBarInfoH(
    SCROLLINFO* pSI,
    int* pnScrollStep = NULL
);
Parameters

pSI
A SCROLLINFO pointer that contains information about the current state of the scroll bar.
pnScrollStep
A pointer to int to receive scroll step. Can be NULL.

Returns

A BOOL. The base class definition always returns FALSE. The derived class definition should return TRUE if the function is successful. Return FALSE otherwise.

Body Source
virtual BOOL GetScrollBarInfoH(SCROLLINFO* pSI, int* pnScrollStep = NULL) {
    UNREFERENCED_PARAMETER(pSI); UNREFERENCED_PARAMETER(pnScrollStep);
    return FALSE;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetScrollBarInfoV Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetScrollBarInfoV Method

This member function is used to retrieve the information about a scroll bar state.

virtual BOOL GetScrollBarInfoV(
    SCROLLINFO* pSI
);
Parameters

pSI
A SCROLLINFO pointer that contains information about the current state of the scroll bar.

Returns

A BOOL. The base class definition always returns FALSE. The derived class definition should return TRUE if the function is successful. Return FALSE otherwise.

Body Source
virtual BOOL GetScrollBarInfoV(SCROLLINFO* pSI) {
    UNREFERENCED_PARAMETER(pSI);
    return FALSE;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetSelectedEvents Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetSelectedEvents Method

Call this member function to obtain a pointer to a selected event's views collection.

virtual CXTPCalendarViewEventsPtr GetSelectedEvents();
Returns

A smart pointer to a CXTPCalendarEvents object that contains the selected events.

Remarks

Tims method returns one event view instance for a one event. (multi day event has a separate view event object for each day).

See Also

GetSelectedViewEvents(), CXTPCalendarViewEvents

Group

CXTPCalendarView Methods


CXTPCalendarView::GetSelectedViewEvents Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetSelectedViewEvents Method

Call this member function to obtain a pointer to a selected event's views.

virtual CXTPCalendarViewEvents* GetSelectedViewEvents();
Returns

A pointer to a CXTPCalendarViewEvents object that contains the selected event views.

Remarks

Tims method may return few event views instances for a one event. (multi day event has a separate view event object for each day).

See Also

CXTPCalendarViewEvents, CXTPCalendarViewDay, SelectDay(COleDateTime dtSelDay, BOOL bSelect), GetSelectedEvents()

Group

CXTPCalendarView Methods


CXTPCalendarView::GetSelection Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetSelection Method

This member function is used to obtain the view's selection.

virtual BOOL GetSelection(
    COleDateTime* pBegin = NULL,
    COleDateTime* pEnd = NULL,
    BOOL* pbAllDayEvent = NULL,
    int* pnGroupIndex = NULL,
    COleDateTimeSpan* pspSelectionResolution = NULL
);
Parameters

pBegin
A pointer to the COleDateTime object that contains the beginning of the selection.
pEnd
A pointer to the COleDateTime object that contains the ending of the selection.
pbAllDayEvent
A pointer to the BOOL variable that contains the AllDayEvent attribute of the selection (used in the day view only).
pnGroupIndex
A pointer to int to receive group index.
pspSelectionResolution
A pointer to the COleDateTimeSpan object that contains the selection unit length. (i.e. 1 day, 1 Hour, ... 5 min)

Returns

A BOOL. TRUE if the selection is returned successfully. FALSE otherwise.

Remarks

Call this member function to fill the provided COleDateTime objects with the values of the selection beginning, ending, and selection unit length.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetShowToolTipTimeOut Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetShowToolTipTimeOut Method

This member function is used to obtain the timeout value for displaying a tooltip.

virtual UINT GetShowToolTipTimeOut() const;
Returns

A UINT that contains the value of timeout in milliseconds.

Body Source
UINT CXTPCalendarView::GetShowToolTipTimeOut() const {
    return XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetStartEditSubjectTimeOut Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetStartEditSubjectTimeOut Method

This member function is used to obtain the time value after a mouse click event in the subject editing window.

virtual UINT GetStartEditSubjectTimeOut() const;
Returns

A UINT that contains the timeout value in milliseconds before the start event subject editing.

Body Source
UINT CXTPCalendarView::GetStartEditSubjectTimeOut() const {
    return XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetSubjectEditorRect Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetSubjectEditorRect Method

Call this member function to obtain the bounding rectangle of the subject editor.

virtual CRect GetSubjectEditorRect() const;
Returns

A CRect object that contains the current coordinates of the subject editor.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetTheme Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetTheme Method

This member function obtains a pointer to the associated theme object.

virtual CXTPCalendarTheme* GetTheme();
Returns

A CXTPCalendarTheme pointer to the associated theme object or NULL.

Remarks

It calls CXTPCalendarControl::GetTheme() method.

See Also

CXTPCalendarControl::GetTheme, GetPaintManager

Group

CXTPCalendarView Methods


CXTPCalendarView::GetTooltipRect Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetTooltipRect Method

Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position

virtual CRect GetTooltipRect(
    const CPoint& ptHit,
    const XTP_CALENDAR_HITTESTINFO& hitInfo
);
Returns

A CRect object with relative coordinates of the tooltip.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetViewDay_ Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetViewDay_ Method

Call this member function to obtain the CXTPCalendarViewDay object by the day's index.

virtual CXTPCalendarViewDay* GetViewDay_(
    int nIndex
) = 0;
virtual CXTPCalendarViewDay* _GetViewDay(
    const COleDateTime& dtDay
);
Parameters

nIndex
An int that is used as the day view index in the view collection.
dtDay
A day date to find.

Returns

A pointer to a CXTPCalendarViewDay object.

Remarks

Index numbers start with 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

See Also

GetViewDayCount()

Group

CXTPCalendarView Methods


CXTPCalendarView::GetViewDayCount Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::GetViewDayCount Method

Call this member function to obtain the number of "day views" in the view collection.

virtual int GetViewDayCount() = 0;
Returns

An int that contains the the number of "day views" in the view collection.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarView Methods


CXTPCalendarView::GetViewDayDate Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetViewDayDate Method

Call this member function to obtain the date of the day view by the day's index.

virtual COleDateTime GetViewDayDate(
    int nIndex
) = 0;
Parameters

nIndex
An int that contains the day view index in the view collection.

Returns

A COleDateTime object that contains the day view date and time.

Remarks

Indexed number starts from 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

See Also

GetViewDayCount()

Group

CXTPCalendarView Methods


CXTPCalendarView::GetViewRect Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::GetViewRect Method

Call this member function to obtain the view's bounding rectangle.

CRect GetViewRect();
Returns

A CRect object that contains the view's bounding rectangle coordinates.

Body Source
CRect CXTPCalendarView::GetViewRect() {
    return m_rcView;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::GetViewType Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::GetViewType Method

Call this member function to obtain the view type flag.

virtual XTPCalendarViewType GetViewType() = 0;
Returns

A XTPCalendarViewType view type flag.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

See Also

XTPCalendarViewType

Group

CXTPCalendarView Methods


CXTPCalendarView::HasSelectedViewEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::HasSelectedViewEvent Method

Call this member function to determine if there are selected event view

virtual BOOL HasSelectedViewEvent();
See Also

GetSelectedViewEvents

Group

CXTPCalendarView Methods


CXTPCalendarView::HitTest Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::HitTest Method

This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.

virtual BOOL HitTest(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO* pHitTest
) = 0;
Parameters

pt
A CPoint that contains the coordinates of the point to test.
pHitTest
A pointer a XTP_CALENDAR_HITTESTINFO structure.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

See Also

XTP_CALENDAR_HITTESTINFO

Group

CXTPCalendarView Methods


CXTPCalendarView::IsEditingSubject Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::IsEditingSubject Method

Call this member function to determine if the subject is in an editable mode.

virtual BOOL IsEditingSubject() const;
Returns

A BOOL. TRUE if the subject is ready for editing. FALSE otherwise.

Body Source
BOOL CXTPCalendarView::IsEditingSubject() const {
    return m_ptrEditingViewEvent != NULL;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::IsEditOperationDisabledNotify Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::IsEditOperationDisabledNotify Method

This method is used to determine is specified editing operation disabled.

BOOL IsEditOperationDisabledNotify(
    XTPCalendarEditOperation eOperation,
    CXTPCalendarViewEvent* pEventView
);
Parameters

eOperation
A value from enum XTPCalendarEditOperation.
pEventView
A pointer to event view.

Returns

TRUE if specified editing operation disabled, otherwise FALSE.

See Also

XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED, XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTPCalendarEditOperation.

Group

CXTPCalendarView Methods


CXTPCalendarView::IsHScrollEnabled Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::IsHScrollEnabled Method

This member function(s) is used to obtain status of the vertical or horizontal scrolling features of the view (by date or time).

virtual BOOL IsHScrollEnabled();
virtual BOOL IsVScrollEnabled();
Returns

TRUE if scrolling enabled, FALSE otherwise.

Body Source
BOOL CXTPCalendarView::IsHScrollEnabled() {
    return !m_bScrollH_Disabled;
}

BOOL CXTPCalendarView::IsVScrollEnabled() {
    return !m_bScrollV_Disabled;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::IsSingleEventSelected Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::IsSingleEventSelected Method

This member function is used to determine is just one event is selected.

BOOL IsSingleEventSelected();
Returns

TRUE - if only one event is selected, FALSE - if no events are selected or if more than one event is selected.

See Also

GetSelectedViewEvents(), SelectViewEvent(), SelectEvent().

Group

CXTPCalendarView Methods


CXTPCalendarView::IsTodayVisible Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::IsTodayVisible Method

Call this member function to determine is Today day visible.

virtual BOOL IsTodayVisible();
Returns

A BOOL. TRUE if Today day is visible, FALSE otherwise.

Group

CXTPCalendarView Methods


CXTPCalendarView::KillTimer Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::KillTimer Method

This member function is used to destroy a timer event.

virtual void KillTimer(
    UINT uTimerID
);
Parameters

uTimerID
A UINT that is used to specify the identifier of the timer.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnActivateView Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::OnActivateView Method

This member function is called by the framework view is activated or deactivated.

virtual void OnActivateView(
    BOOL bActivate,
    CXTPCalendarView* pActivateView,
    CXTPCalendarView* pInactiveView
);
Parameters

bActivate
Indicates whether the view is being activated or deactivated.
pActivateView
Points to the view object that is being activated.
pInactiveView
Points to the view object that is being deactivated.

Remarks

Override this member function to handle activated/deactivated events.

See Also

CXTPCalendarControl::SwitchActiveView(XTPCalendarViewType eView), CXTPCalendarControl::SetActiveView(CXTPCalendarView* pView)

Group

CXTPCalendarView Methods


CXTPCalendarView::OnBeforeDestroy Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnBeforeDestroy Method

This member function is called by the framework before destroying the view.

virtual void OnBeforeDestroy();
Group

CXTPCalendarView Methods


OnBeforeEditOperationNotify Method

CXTPCalendarView Methods
OnBeforeEditOperationNotify Method
Overload List
Methods
Method | Description
CXTPCalendarView::OnBeforeEditOperationNotify (XTPCalendarEditOperation, CXTPCalendarViewEvent*) | This method is used to customize or disable specified editing operation.
CXTPCalendarView::OnBeforeEditOperationNotify (XTPCalendarEditOperation, CXTPCalendarViewEvents*) | This method is used to customize or disable specified editing operation.
Group

CXTPCalendarView Methods


CXTPCalendarView::OnBeforeEditOperationNotify Method (XTPCalendarEditOperation, CXTPCalendarViewEvent*)

OnBeforeEditOperationNotify Method, CXTPCalendarView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::OnBeforeEditOperationNotify Method (XTPCalendarEditOperation, CXTPCalendarViewEvent*)

This method is used to customize or disable specified editing operation.

BOOL OnBeforeEditOperationNotify(
    XTPCalendarEditOperation eOperation,
    CXTPCalendarViewEvent* pEventView
);
BOOL OnBeforeEditOperationNotify(
    XTPCalendarEditOperation eOperation,
    CXTPCalendarViewEvents* pEventViews
);
Parameters

eOperation
A value from enum XTPCalendarEditOperation.
pEventView
A pointer to event view.

Returns

TRUE if specified editing operation disabled or handled, otherwise FALSE.

See Also

XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED, XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTPCalendarEditOperation.

Group

OnBeforeEditOperationNotify Method


CXTPCalendarView::OnBeforePasteNotify Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::OnBeforePasteNotify Method

This method is used to customize or disable paste editing operation.

BOOL OnBeforePasteNotify(
    CXTPCalendarEvent* pEvent,
    BOOL bPasteWillChangeExistingEvent
);
Parameters

pEvent
A pointer to event prepared for paste.
bPasteWillChangeExistingEvent
If this parameter is TRUE, the new event will not be added, just existing event will be updated. Used for creating recurrence event exceptions by cut operation.

Returns

TRUE if paste editing operation disabled or handled, otherwise FALSE.

See Also

XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED, XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTPCalendarEditOperation.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnChar Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnChar Method

This member function is used to process keyboard events.

virtual void OnChar(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT that contains the character code value of the key.
nRepCnt
A UINT that is used to count the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT that contains the Scan code, key-transition code, previous key state, and the context code.

Remarks

This method is called by the CalendarControl when a keystroke translates to a nonsystem character.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnDragging Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnDragging Method

This member function is used to perform the event editing (dragging) operation step.

virtual BOOL OnDragging(
    CPoint point,
    XTP_CALENDAR_HITTESTINFO* pHitTest
);
Parameters

point
A CPoint that contains the mouse position coordinates.
pHitTest
A pointer to a XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from the specified point.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnDraw Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnDraw Method

This member function performs all of the drawing logic of the calendar view.

virtual void OnDraw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnEndDragging Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnEndDragging Method

This member function is used to finish the event editing (dragging) operation.

virtual BOOL OnEndDragging(
    CPoint point,
    XTP_CALENDAR_HITTESTINFO* pHitInfo
);
Parameters

point
A CPoint that contains the mouse position coordinates.
pHitInfo
A pointer to a XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from the specified point.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnEventChanged_InDataProvider Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::OnEventChanged_InDataProvider Method

This member function handles changing of an event in the associated data provider. It performs all the necessary validation of this action and returns an update result.

virtual XTPEnumCalendarUpdateResult OnEventChanged_InDataProvider(
    XTP_NOTIFY_CODE nfCode,
    CXTPCalendarEvent* pEvent
);
Parameters

nfCode
Notification code of the data provider update operation.
pEvent
A pointer to a CXTPCalendarEvent object that was changed.

Returns

A code of the update action to be performed in the view.

See Also

XTP_NOTIFY_CODE overview, XTPEnumCalendarUpdateResult overview

Group

CXTPCalendarView Methods


CXTPCalendarView::OnInPlaceCreateEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::OnInPlaceCreateEvent Method

This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.

BOOL OnInPlaceCreateEvent(
    LPCTSTR pcszInitialSubject
);
Parameters

pcszInitialSubject
A pointer to the string which contains initial subject value for new event (generally initial char).

Returns

TRUE if In-place create event editing operation disabled or handled, otherwise FALSE.

See Also

XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED, XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTPCalendarEditOperation.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnKeyDown Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnKeyDown Method

This member function is used to processes keyboard events.

virtual void OnKeyDown(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT that is used to identify the virtual key code of the given key.
nRepCnt
A UINT that is used to count the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT that contains the Scan code, key-transition code, previous key state, and the context code.

Remarks

This method is called by the CalendarControl when the user presses keys on the keyboard.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnLButtonDblClk Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnLButtonDblClk Method

This member function is used to process mouse double-click events.

virtual BOOL OnLButtonDblClk(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user presses, releases, and then presses the left mouse button again within the system's double-click time limit.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnLButtonDown Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnLButtonDown Method

This member function is used to processes left mouse button events.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicates whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user presses the left mouse button.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnLButtonUp Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnLButtonUp Method

This member function is used to processes left mouse button events.

virtual BOOL OnLButtonUp(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user releases the left mouse button.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnMouseMove Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnMouseMove Method

This member function is used to processes mouse movement events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnStartDragging Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnStartDragging Method

This member function is used to start the event editing (dragging).

virtual void OnStartDragging(
    CPoint point,
    XTP_CALENDAR_HITTESTINFO* pHitTest
);
Parameters

point
A CPoint that contains the mouse position with the coordinates to start the event editing (dragging).
pHitTest
A pointer to a XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from a specified point.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnSysKeyDown Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnSysKeyDown Method

This member function is used to processes system keyboard events.

virtual BOOL OnSysKeyDown(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT that specifies the virtual key code of the given key.
nRepCnt
A UINT that contains the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT that contains the scan code, key-transition code, previous key state, and the context code.

Remarks

This method is called by the CalendarControl when the user presses keys on the keyboard.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnTimer Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnTimer Method

The framework calls this member function after each interval specified in the SetTimer member function.

virtual BOOL OnTimer(
    UINT_PTR uTimerID
);
Parameters

uTimerID
A UINT that is used to specify the identifier of the timer.

Group

CXTPCalendarView Methods


CXTPCalendarView::OnUpdateEditingSubject Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::OnUpdateEditingSubject Method

Call this member function to set the new subject text for the editing event.

virtual void OnUpdateEditingSubject(
    CString strNewSubject
);
Parameters

strNewSubject
New subject value.

Group

CXTPCalendarView Methods


CXTPCalendarView::Paste Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::Paste Method

This member function is used to perform a Paste operation.

virtual BOOL Paste();
Returns

A BOOL. TRUE if the paste operation is successful. FALSE otherwise.

Remarks

Call this member function to perform a Paste operation in the subject editor's window.

Group

CXTPCalendarView Methods


CXTPCalendarView::Populate Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::Populate Method

This member function is used to populate the view with data for all items contained in the view.

virtual void Populate();
Group

CXTPCalendarView Methods


CXTPCalendarView::ProcessDaySelection Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::ProcessDaySelection Method

This member function is used to process the days selection that are selected with the mouse.

virtual void ProcessDaySelection(
    XTP_CALENDAR_HITTESTINFO* pInfo,
    UINT nFlags
);
Parameters

pInfo
A pointer to a XTP_CALENDAR_HITTESTINFO struct that contains HitTest information about the current mouse position.
nFlags
A UINT that contains the current state of the additional mouse and keyboard buttons. Like MK_SHIFT, ...

See Also

SelectDays

Group

CXTPCalendarView Methods


CXTPCalendarView::ProcessEventSelection Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::ProcessEventSelection Method

This member function is used to process events that are selected with the mouse.

virtual void ProcessEventSelection(
    XTP_CALENDAR_HITTESTINFO* pInfo,
    UINT nFlags
);
Parameters

pInfo
A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains HitTest information about current mouse position.
nFlags
A UINT that contains the current state of the additional mouse and keyboard buttons. Like MK_SHIFT, ...

Group

CXTPCalendarView Methods


CXTPCalendarView::Redo Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::Redo Method

This member function is used to perform a Redo operation.

virtual BOOL Redo();
Returns

A BOOL. TRUE if the redo operation is successful. FALSE otherwise.

Group

CXTPCalendarView Methods


CXTPCalendarView::RedrawControl Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::RedrawControl Method

This member function is used to perform the redrawing of the control's layout.

virtual void RedrawControl();
Remarks

Call AdjystLayout() prior to redrawing the control.

Group

CXTPCalendarView Methods


CXTPCalendarView::ResetSelection Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::ResetSelection Method

This member function resets the current selection - set it empty.

void ResetSelection();
Remarks

Call this member function to programmatically clear the current selection.

Group

CXTPCalendarView Methods


CXTPCalendarView::RetrieveDayEvents Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::RetrieveDayEvents Method

Call this member function to get the collection of the day's events.

virtual CXTPCalendarEventsPtr RetrieveDayEvents(
    CXTPCalendarResource* pRC,
    COleDateTime dtDay
);
Parameters

pRC
A pointer to calendar resource object.
dtDay
A COleDateTime object that contains the day's date.

Returns

A pointer to a CXTPCalendarEvents object that contains the collection of the day's events.

See Also

CXTPCalendarEvents

Group

CXTPCalendarView Methods


CXTPCalendarView::ScrollH Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::ScrollH Method

Scroll horizontally.

virtual void ScrollH(
    int nPos,
    int nPos_raw
);
Parameters

nPos
An int that contains the position value.
nPos_raw
An int that contains the raw position value.

Remarks

This member function is used to horizontal scroll the contents of the view.

Body Source
virtual void ScrollH(int nPos, int nPos_raw) {
    UNREFERENCED_PARAMETER(nPos);
    UNREFERENCED_PARAMETER(nPos_raw);
}
Group

CXTPCalendarView Methods


CXTPCalendarView::ScrollV Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::ScrollV Method

Scroll vertically.

virtual void ScrollV(
    int nPos,
    int nPos_raw
);
Parameters

nPos
An int that contains the position value.
nPos_raw
An int that contains the raw position value.

Remarks

This member function is used to vertical scroll the contents of the view.

Body Source
virtual void ScrollV(int nPos, int nPos_raw) {
    UNREFERENCED_PARAMETER(nPos);
    UNREFERENCED_PARAMETER(nPos_raw);
}
Group

CXTPCalendarView Methods


SelectDay Method

CXTPCalendarView Methods
SelectDay Method
Overload List
Methods
Method | Description
CXTPCalendarView::SelectDay (COleDateTime, int) | This member function is used to select or un-select the day identified by the provided date.
CXTPCalendarView::SelectDay (CXTPCalendarViewDay*, int) | This member function is used to select or un-select the provided day, including all of the day's events.
Group

CXTPCalendarView Methods


CXTPCalendarView::SelectDay Method (COleDateTime, int)

SelectDay Method, CXTPCalendarView Class, See Also
CXTPCalendarView::SelectDay Method (COleDateTime, int)

This member function is used to select or un-select the day identified by the provided date.

virtual void SelectDay(
    COleDateTime dtSelDay,
    int nGroupIndex = 0
);
Parameters

dtSelDay
A COleDateTime object that contains a date time value.
nGroupIndex
A group index to select.

See Also

CXTPCalendarViewDay, SelectDay

Group

SelectDay Method


CXTPCalendarView::SelectDay Method (CXTPCalendarViewDay*, int)

SelectDay Method, CXTPCalendarView Class, See Also
CXTPCalendarView::SelectDay Method (CXTPCalendarViewDay*, int)

This member function is used to select or un-select the provided day, including all of the day's events.

virtual void SelectDay(
    CXTPCalendarViewDay* pDay,
    int nGroupIndex = 0
);
Parameters

pDay
A pointer to a CXTPCalendarViewDay object.
nGroupIndex
A group index to select.

See Also

CXTPCalendarViewDay, SelectDay(COleDateTime dtSelDay, BOOL bSelect)

Group

SelectDay Method


CXTPCalendarView::SelectDays Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::SelectDays Method

This member function is used to change the days selection depending on the previous state of the selection.

virtual void SelectDays(
    COleDateTime dtNewSel
);
Parameters

dtNewSel
A COleDateTime object that contains the day date where the selection has moved.

Group

CXTPCalendarView Methods


CXTPCalendarView::SelectEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::SelectEvent Method

This member function is used to select or un-select the provided event.

virtual void SelectEvent(
    CXTPCalendarEvent* pEvent,
    BOOL bSelect = TRUE
);
Parameters

pEvent
A pointer to the CXTPCalendarEvent object.
bSelect
A BOOL. If TRUE, then select the event. If FALSE, then un-select the event.

Remarks

This method doesn't redraw control's window in order to avoid blinking when executed in groups (like selecting a number of events). So far, you'll have to call Calendar.RedrawControl after that.

See Also

SelectViewEvent(), CXTPCalendarEvent

Group

CXTPCalendarView Methods


CXTPCalendarView::SelectionContains Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::SelectionContains Method

This member function is used to determine if a date time value is contained inside the selection.

BOOL SelectionContains(
    COleDateTime date,
    int nGroupIndex = -1,
    BOOL* pbAllDaySelection = NULL
);
Parameters

date
A COleDateTime object that contains a date time value.
nGroupIndex
A group index or -1 for any group.
pbAllDaySelection
A pointer to BOOL to receive is selection All Day.

Returns

TRUE - If date is contained inside the selection. FALSE otherwise.

Group

CXTPCalendarView Methods


CXTPCalendarView::SelectViewEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::SelectViewEvent Method

This member function is used to select or un-select the provided event.

void SelectViewEvent(
    CXTPCalendarViewEvent* pViewEvent,
    BOOL bSelect = TRUE
);
Parameters

pViewEvent
A pointer to the CXTPCalendarViewEvent object.
bSelect
A BOOL. If TRUE, then select the event. If FALSE, then un-select the event.

Remarks

This method doesn't redraw control's window in order to avoid blinking when executed in groups (like selecting a number of events). So far, you'll have to call Calendar.RedrawControl after that.

See Also

SelectEvent(), CXTPCalendarViewEvent

Group

CXTPCalendarView Methods


CXTPCalendarView::SendNotification Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::SendNotification Method

This member function is used to send a notification from the parent Calendar control.

virtual void SendNotification(
    XTP_NOTIFY_CODE EventCode,
    WPARAM wParam = 0,
    LPARAM lParam = 0
);
Parameters

EventCode
A XTP_NOTIFY_CODE that contains the specific code of the event.
wParam
A DWORD that contains the first custom parameter. Depends on the event type. See specific event description for details.
lParam
A DWORD that contains the second custom parameter. Depends on the event type. See specific event description for details.

Remarks

This member function is called internally from inside the class when a notification is sent to all listeners.

See Also

XTP_NOTIFY_CODE

Group

CXTPCalendarView Methods


CXTPCalendarView::SetDayHeaderFormatLong Method

CXTPCalendarView Methods, CXTPCalendarView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::SetDayHeaderFormatLong Method

This member function(s) is used to set date format string for the day view.

virtual void SetDayHeaderFormatLong(
    LPCTSTR pcszCustomFormat
);
virtual void SetDayHeaderFormatMiddle(
    LPCTSTR pcszCustomFormat
);
virtual void SetDayHeaderFormatShort(
    LPCTSTR pcszCustomFormat
);
virtual void SetDayHeaderFormatShortest(
    LPCTSTR pcszCustomFormat
);
Parameters

pcszCustomFormat
Date format string.

Remarks

Long, Middle, Short and Shortest format strings are used for different header widths. Calendar control select the longest format which can be drawn for active day header width. By default these format strings are build using locale settings and SetDayHeaderFormatXXX methods should be used to customize default settings.

Body Source
void CXTPCalendarView::SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat) {
    m_strDayHeaderFormatLong = pcszCustomFormat;
}

void CXTPCalendarView::SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat) {
    m_strDayHeaderFormatMiddle = pcszCustomFormat;
}

void CXTPCalendarView::SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat) {
    m_strDayHeaderFormatShort = pcszCustomFormat;
}

void CXTPCalendarView::SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat) {
    m_strDayHeaderFormatShortest = pcszCustomFormat;
}
Group

CXTPCalendarView Methods


CXTPCalendarView::SetDraggingEvent Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::SetDraggingEvent Method

This member function is used to prepare the event to event editing (dragging) operation.

virtual BOOL SetDraggingEvent(
    CXTPCalendarEvent* pEventOrig
);
Parameters

pEventOrig
Pointer to an initial event for the dragging.

Returns

A BOOL. TRUE if the event editing is successful. FALSE otherwise.

Group

CXTPCalendarView Methods


CXTPCalendarView::SetResources Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::SetResources Method

This member function sets the new Resources collection for the view.

virtual void SetResources(
    CXTPCalendarResources* pResources
);
Parameters

pResources
A pointer to the CXTPCalendarResources collection object.

Remarks

Call this member function to programmatically set the new Resources collection for the view.

Group

CXTPCalendarView Methods


CXTPCalendarView::SetSelection Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::SetSelection Method

This member function sets the new selection for the view.

void SetSelection(
    const COleDateTime& dtBegin,
    const COleDateTime& dtEnd,
    BOOL bAllDayEvent = FALSE,
    int nGroupIndex = 0
);
Parameters

dtBegin
Selection beginning time.
dtEnd
Selection ending time.
bAllDayEvent
Selection AllDayEvent attribute (used in the day view only).
nGroupIndex
A group index.

Remarks

Call this member function to programmatically set the new selection beginning and ending for the view.

Group

CXTPCalendarView Methods


CXTPCalendarView::SetTimer Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::SetTimer Method

This member function is used to create a timer event.

virtual UINT SetTimer(
    UINT uTimeOut_ms
);
Parameters

uTimeOut_ms
A UINT that contains the duration of the timer event in milliseconds.

Returns

A UINT that contains the identifier of the timer.

Group

CXTPCalendarView Methods


CXTPCalendarView::ShowDay Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::ShowDay Method

This member function is used to show the specified day in the calendar view.

virtual void ShowDay(
    const COleDateTime& date,
    BOOL bSelect = TRUE
) = 0;
Parameters

date
A COleDateTime object that contains the date to show.
bSelect
TRUE to select the specified day after showing, FALSE otherwise. TRUE is the default value.

Remarks

Call this member function to show only the specified day in the calendar view.

Group

CXTPCalendarView Methods


CXTPCalendarView::ShowToolTip Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::ShowToolTip Method

This member function is used to show/hide a ToolTip rectangle.

virtual void ShowToolTip(
    BOOL bShow = TRUE
);
Parameters

bShow
TRUE to show a tooltip, FALSE to hide it.

Group

CXTPCalendarView Methods


CXTPCalendarView::StartEditNewEventInplace Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::StartEditNewEventInplace Method

This member function is used to create a new event and start subject editing.

virtual void StartEditNewEventInplace(
    LPCTSTR pcszInitialSubject
);
Parameters

pcszInitialSubject
A pointer to the string which contains initial subject value for new event (generally initial char).

Group

CXTPCalendarView Methods


CXTPCalendarView::StartEditSubject Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::StartEditSubject Method

This member function is used to start the event subject editing.

virtual void StartEditSubject(
    CXTPCalendarViewEvent* pViewEvent
);
Parameters

pViewEvent
A pointer to a CXTPCalendarViewEvent event view that is used to edit the subject.

Group

CXTPCalendarView Methods


CXTPCalendarView::Undo Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::Undo Method

This member function is used to perform an Undo operation.

virtual BOOL Undo();
Returns

A BOOL. TRUE if the undo operation is successful. FALSE otherwise.

Group

CXTPCalendarView Methods


CXTPCalendarView::UnselectAllEvents Method

CXTPCalendarView Methods, CXTPCalendarView Class
CXTPCalendarView::UnselectAllEvents Method

Call this member function to un-select all of the events of the current view.

virtual void UnselectAllEvents();
Group

CXTPCalendarView Methods


CXTPCalendarView::UpdateNextTimeEditByTAB Method

CXTPCalendarView Methods, CXTPCalendarView Class, See Also
CXTPCalendarView::UpdateNextTimeEditByTAB Method

This member function is used to set the next date and time to start the find event view for editing events using the TAB key.

virtual void UpdateNextTimeEditByTAB(
    COleDateTime dtNext,
    BOOL bReverse,
    BOOL bReset = FALSE
);
Parameters

dtNext
A COleDateTime object that contains the next date and time to start the find event view.
bReverse
If TRUE the reverse order is used, otherwise normal is used.
bReset
If TRUE the next time is set to the start (or end) iteration position.

See Also

GetNextTimeEditByTAB, FindEventToEditByTAB

Group

CXTPCalendarView Methods


CXTPCalendarView Constructors

CXTPCalendarView Class, Legend, Public Methods
CXTPCalendarView Constructors
Class

CXTPCalendarView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarView | Default object constructor.


CXTPCalendarView::CXTPCalendarView Constructor

CXTPCalendarView Constructors, CXTPCalendarView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarView::CXTPCalendarView Constructor

Default object constructor.

CXTPCalendarView(
    CXTPCalendarControl* pCalendarControl
);
Parameters

pCalendarControl
A Pointer to CXTPCalendarControl object.

See Also

~CXTPCalendarEvent()

Group

CXTPCalendarView Constructors


CXTPCalendarView Destructors

CXTPCalendarView Class, Legend, Public Methods
CXTPCalendarView Destructors
Class

CXTPCalendarView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarView | Default class destructor.


CXTPCalendarView::~CXTPCalendarView Destructor

CXTPCalendarView Destructors, CXTPCalendarView Class
CXTPCalendarView::~CXTPCalendarView Destructor

Default class destructor.

virtual ~CXTPCalendarView();
Remarks

Handles member items deallocation.

Group

CXTPCalendarView Destructors


CXTPCalendarViewDay Class

XTPCalendarViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarViewDay Data Members, CXTPCalendarViewDay Methods, CXTPCalendarViewDay Constructors, CXTPCalendarViewDay Destructors, CXTPCalendarViewDay Constructors, CXTPCalendarViewDay Data Members, CXTPCalendarViewDay Destructors, CXTPCalendarViewDay Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay Class

This class represents the day view portion of the CalendarView.

Class Hierarchy

class CXTPCalendarViewDay : public CXTPCalendarWMHandler;
File

XTPCalendarViewDay.h

Remarks

It represents a specific view of the CalendarView's associated events data grouped by one day and provides basic functionality on this data using user input through the keyboard and the mouse.

These are the predefined view implementations available for the Calendar control:

  • Day and work week day views - Using the CXTPCalendarDayViewDay class.
  • Week day view - Using the CXTPCalendarWeekViewDay class.
  • Month day view - Using the CXTPCalendarMonthViewDay class.

Furthermore, any user defined day view may also be implemented as a descendant of the CXTPCalendarViewDay class.

A typical day view model consists of a collection of ViewEvent's for the particular day, each of them represents a view of an CXTPCalendarEvent object.

See Also

CXTPCalendarViewDayT, CXTPCalendarDayViewDay, CXTPCalendarWeekViewDay, CXTPCalendarMonthViewDay, CXTPCalendarView, CXTPCalendarViewEvent

Group

Classes

Legend
Data Member
protected
Method
virtual
abstract
CXTPCalendarViewDay Constructors
CXTPCalendarViewDay Constructors | Description
CXTPCalendarViewDay | Default object constructor. Construct CXTPCalendarViewDay object.
CXTPCalendarViewDay Data Members
CXTPCalendarViewDay Data Members | Description
m_dtDate | Day date.
m_Layout | Layout data.
m_pResources | Resources array
CXTPCalendarViewDay Destructors
CXTPCalendarViewDay Destructors | Description
~CXTPCalendarViewDay | Default class destructor.
CXTPCalendarViewDay Methods
CXTPCalendarViewDay Methods | Description
_NoAllEventsAreVisible | Call this member function to determine if all day's event views are visible.
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
Draw | This member function is used to draw the view contents using the specified device context.
GetCalendarControl | Call this member function to obtain a pointer to a CXTPCalendarControl object.
GetChildHandlerAt | Call this method to get a resource group view object at the specified numeric index.
GetChildHandlersCount | This member function is used to obtain the number of resource group views elements in the collection.
GetDayDate | Call this member function to obtain a day date value.
GetDayIndex | This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.
GetDayRect | Call this member function to obtain the day view rectangle coordinates.
GetExpandSignRect | Call this member function to obtain the expand sign rectangle.
GetResources | Call this member function to obtain a pointer to the associated Calendar Resources collection object.
GetView_ | Call this member function to obtain a pointer to a CXTPCalendarView object.
GetViewEvent_ | Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
GetViewEventsCount | Call this member function to obtain the number of event views in the day view collection.
GetViewGroup_ | Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.
GetViewGroupsCount | Call this member function to obtain the number of resource group views in the view day collection.
HitTest | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
IsExpanded | Call this member function to determine if there are event views invisible because the boundaries of the day view are hidden, and the day view should display the expand sign.
IsSelected | Call this member function to determine if the day view is selected.
KillTimer | This member function is used to destroy a timer event.
OnPrePopulateDay | This member function is used to allow some customization before show events.
Populate | This member function is used to populate the view with data for all items contained in the view.
SetDayDate | Call this member function to obtain the day date value.
SetDayRect | This member function is used to set the day view rectangle coordinates.
SetResources | This member function sets the new Resources collection for the view day.
SetSelected | This member function is used to set the day view as selected
SetTimer | This member function is used to create a timer event.
UserAction_OnExpandDay | This member function used to process user action xtpCalendarUserAction_OnExpandDay.


CXTPCalendarViewDay Data Members

CXTPCalendarViewDay Class, Legend, Protected Data Members
CXTPCalendarViewDay Data Members
Class

CXTPCalendarViewDay Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dtDate | Day date.
m_Layout | Layout data.
m_pResources | Resources array


CXTPCalendarViewDay::m_dtDate Data Member

CXTPCalendarViewDay Data Members, CXTPCalendarViewDay Class
CXTPCalendarViewDay::m_dtDate Data Member

Day date.

COleDateTime m_dtDate;
Group

CXTPCalendarViewDay Data Members


CXTPCalendarViewDay::m_Layout Data Member

CXTPCalendarViewDay Data Members, CXTPCalendarViewDay Class
CXTPCalendarViewDay::m_Layout Data Member

Layout data.

XTP_VIEW_DAY_LAYOUT m_Layout;
Group

CXTPCalendarViewDay Data Members


CXTPCalendarViewDay::m_pResources Data Member

CXTPCalendarViewDay Data Members, CXTPCalendarViewDay Class
CXTPCalendarViewDay::m_pResources Data Member

Resources array

CXTPCalendarResources* m_pResources;
Group

CXTPCalendarViewDay Data Members


CXTPCalendarViewDay Methods

CXTPCalendarViewDay Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay Methods
Class

CXTPCalendarViewDay Class

Legend
Method
virtual
abstract
protected
Protected Methods
Protected Methods
Protected Method | Description
OnPrePopulateDay | This member function is used to allow some customization before show events.
Public Methods
Public Methods
Public Method | Description
_NoAllEventsAreVisible | Call this member function to determine if all day's event views are visible.
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
Draw | This member function is used to draw the view contents using the specified device context.
GetCalendarControl | Call this member function to obtain a pointer to a CXTPCalendarControl object.
GetChildHandlerAt | Call this method to get a resource group view object at the specified numeric index.
GetChildHandlersCount | This member function is used to obtain the number of resource group views elements in the collection.
GetDayDate | Call this member function to obtain a day date value.
GetDayIndex | This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.
GetDayRect | Call this member function to obtain the day view rectangle coordinates.
GetExpandSignRect | Call this member function to obtain the expand sign rectangle.
GetResources | Call this member function to obtain a pointer to the associated Calendar Resources collection object.
GetView_ | Call this member function to obtain a pointer to a CXTPCalendarView object.
GetViewEvent_ | Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
GetViewEventsCount | Call this member function to obtain the number of event views in the day view collection.
GetViewGroup_ | Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.
GetViewGroupsCount | Call this member function to obtain the number of resource group views in the view day collection.
HitTest | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
IsExpanded | Call this member function to determine if there are event views invisible because the boundaries of the day view are hidden, and the day view should display the expand sign.
IsSelected | Call this member function to determine if the day view is selected.
KillTimer | This member function is used to destroy a timer event.
Populate | This member function is used to populate the view with data for all items contained in the view.
SetDayDate | Call this member function to obtain the day date value.
SetDayRect | This member function is used to set the day view rectangle coordinates.
SetResources | This member function sets the new Resources collection for the view day.
SetSelected | This member function is used to set the day view as selected
SetTimer | This member function is used to create a timer event.
UserAction_OnExpandDay | This member function used to process user action xtpCalendarUserAction_OnExpandDay.


CXTPCalendarViewDay::_NoAllEventsAreVisible Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::_NoAllEventsAreVisible Method

Call this member function to determine if all day's event views are visible.

virtual BOOL _NoAllEventsAreVisible();
Returns

A BOOL. TRUE if there is at least one event that is completely invisible. FALSE otherwise.

Remarks

This function is used for determining if the expanding sings are drawn.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::AdjustLayout Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcDay
);
Parameters

pDC
A pointer to a valid device context.
rcDay
A CRect object that contains the rectangle coordinates that are used to draw the view.

Remarks

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout().

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::Draw Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::Draw Method

This member function is used to draw the view contents using the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
A pointer to a valid device context.

Remarks

Call AdjustLayout() before calling Draw().

See Also

AdjustLayout(CRect rcDay)

Body Source
virtual void Draw(CDC* pDC) {
    UNREFERENCED_PARAMETER(pDC);
}
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetCalendarControl Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::GetCalendarControl Method

Call this member function to obtain a pointer to a CXTPCalendarControl object.

virtual CXTPCalendarControl* GetCalendarControl();
Returns

A pointer to a CXTPCalendarControl object.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetChildHandlerAt Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::GetChildHandlerAt Method

Call this method to get a resource group view object at the specified numeric index.

virtual CXTPCalendarWMHandler* GetChildHandlerAt(
    int nIndex
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns

The pointer to the CXTPCalendarWMHandler element currently at this index.

Remarks

Returns the array element at the specified index.

Body Source
virtual CXTPCalendarWMHandler* GetChildHandlerAt(int nIndex) {
    ASSERT_KINDOF(CXTPCalendarWMHandler, GetViewGroup_(nIndex));
    return GetViewGroup_(nIndex);
}
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetChildHandlersCount Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::GetChildHandlersCount Method

This member function is used to obtain the number of resource group views elements in the collection.

virtual int GetChildHandlersCount();
Returns

A count of resource group views elements.

Remarks

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

Body Source
virtual int GetChildHandlersCount() { return GetViewGroupsCount(); }
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetDayDate Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::GetDayDate Method

Call this member function to obtain a day date value.

virtual COleDateTime GetDayDate() const;
Returns

A COleDateTime object containing the day's date.

See Also

SetDayDate(COleDateTime dtDayDate)

Body Source
COleDateTime CXTPCalendarViewDay::GetDayDate() const {
    return m_dtDate;
}
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetDayIndex Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::GetDayIndex Method

This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.

virtual int GetDayIndex() const;
Returns

An int that contains the index of the "this" day in the Calendar Day View.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetDayRect Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::GetDayRect Method

Call this member function to obtain the day view rectangle coordinates.

virtual CRect GetDayRect();
Returns

A CRect object containing the day view rectangle coordinates.

See Also

SetDayRect(CRect rcDay)

Body Source
CRect CXTPCalendarViewDay::GetDayRect() {
    return m_Layout.m_rcDay;
}
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetExpandSignRect Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::GetExpandSignRect Method

Call this member function to obtain the expand sign rectangle.

virtual CRect GetExpandSignRect();
Returns

A CRect object that contains the expand sign rectangle coordinates.

Body Source
CRect CXTPCalendarViewDay::GetExpandSignRect() {
    return m_Layout.m_rcExpandSign;
}
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetResources Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::GetResources Method

Call this member function to obtain a pointer to the associated Calendar Resources collection object.

virtual CXTPCalendarResources* GetResources();
Returns

A pointer to the CXTPCalendarResources collection object.

See Also

CXTPCalendarResources overview, CXTPCalendarResource overview

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetView_ Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::GetView_ Method

Call this member function to obtain a pointer to a CXTPCalendarView object.

virtual CXTPCalendarView* GetView_() const = 0;
Returns

A pointer to a CXTPCalendarView object.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetViewEvent_ Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::GetViewEvent_ Method

Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.

virtual CXTPCalendarViewEvent* GetViewEvent_(
    int nIndex
);
Parameters

nIndex
An int that contains the event view index in the day view collection.

Returns

A pointer to a CXTPCalendarViewEvent object.

Remarks

Index number starts with 0 and cannot be negative. This function left for for compatibility with previous versions and only for singe resource group mode.

See Also

GetViewEventsCount()

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetViewEventsCount Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::GetViewEventsCount Method

Call this member function to obtain the number of event views in the day view collection.

virtual int GetViewEventsCount();
Returns

An int that contains the number of event views.

Remarks

This function left for for compatibility with previous versions and only for singe resource group mode.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetViewGroup_ Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::GetViewGroup_ Method

Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.

virtual CXTPCalendarViewGroup* GetViewGroup_(
    int nIndex
) = 0;
Parameters

nIndex
An int that contains the group view index in the day view collection.

Returns

A pointer to a CXTPCalendarViewGroup object.

Remarks

Index number starts with 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

See Also

GetViewGroupsCount()

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::GetViewGroupsCount Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::GetViewGroupsCount Method

Call this member function to obtain the number of resource group views in the view day collection.

virtual int GetViewGroupsCount() = 0;
Returns

An int that contains the number of event views.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::HitTest Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::HitTest Method

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.

virtual BOOL HitTest(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO* pHitTest
) = 0;
Parameters

pt
A CPoint object that contains the coordinates of the point to test.
pHitTest
A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains information about the point to test.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

See Also

XTP_CALENDAR_HITTESTINFO

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::IsExpanded Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::IsExpanded Method

Call this member function to determine if there are event views invisible because the boundaries of the day view are hidden, and the day view should display the expand sign.

virtual BOOL IsExpanded();
Returns

A BOOL. TRUE if there are invisible views. FALSE otherwise.

Body Source
BOOL CXTPCalendarViewDay::IsExpanded() {
    return m_Layout.m_rcExpandSign.Width() > 0 ? TRUE : FALSE;
}
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::IsSelected Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::IsSelected Method

Call this member function to determine if the day view is selected.

virtual BOOL IsSelected() const;
Returns

A BOOL. TRUE if the day view is selected. FALSE otherwise.

See Also

SetSelected(bSet)

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::KillTimer Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::KillTimer Method

This member function is used to destroy a timer event.

virtual void KillTimer(
    UINT uTimerID
);
Parameters

uTimerID
A UINT that specifies the identifier of the timer.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::OnPrePopulateDay Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::OnPrePopulateDay Method

This member function is used to allow some customization before show events.

virtual void OnPrePopulateDay();
Remarks

Default implementation send XTP_NC_CALENDAR_PREPOPULATE_DAY notification.

See Also

XTP_NC_CALENDAR_PREPOPULATE

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::Populate Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::Populate Method

This member function is used to populate the view with data for all items contained in the view.

virtual void Populate(
    COleDateTime dtDayDate
) = 0;
Parameters

dtDayDate
A COleDateTime object that contains the day's date.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::SetDayDate Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::SetDayDate Method

Call this member function to obtain the day date value.

virtual COleDateTime SetDayDate(
    COleDateTime dtDayDate
);
Parameters

dtDayDate
A COleDateTime object that contains the new day's date value.

Returns

A COleDateTime object that contains the previous day's date value.

See Also

GetDayDate()

Body Source
COleDateTime CXTPCalendarViewDay::SetDayDate(COleDateTime dtDayDate) {
    COleDateTime dtOld(m_dtDate);
    m_dtDate = CXTPCalendarUtils::ResetTime(dtDayDate);
    return dtOld;
}
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::SetDayRect Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::SetDayRect Method

This member function is used to set the day view rectangle coordinates.

virtual void SetDayRect(
    CRect rcDay
);
Parameters

rcDay
A CRect object containing the new rectangle coordinates.

See Also

GetDayRect()

Body Source
void CXTPCalendarViewDay::SetDayRect(CRect rcDay) {
    m_Layout.m_rcDay.CopyRect(rcDay);
}
Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::SetResources Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::SetResources Method

This member function sets the new Resources collection for the view day.

virtual void SetResources(
    CXTPCalendarResources* pResources
);
Parameters

pResources
A pointer to the CXTPCalendarResources collection object.

Remarks

Call this member function to programmatically set the new Resources collection for the view day.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::SetSelected Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::SetSelected Method

This member function is used to set the day view as selected

virtual void SetSelected();
See Also

IsSelected()

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::SetTimer Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class
CXTPCalendarViewDay::SetTimer Method

This member function is used to create a timer event.

virtual UINT SetTimer(
    UINT uTimeOut_ms
);
Parameters

uTimeOut_ms
A UINT that contains the duration of the timer in milliseconds.

Returns

A UINT that is the identifier of the timer.

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay::UserAction_OnExpandDay Method

CXTPCalendarViewDay Methods, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::UserAction_OnExpandDay Method

This member function used to process user action xtpCalendarUserAction_OnExpandDay.

virtual BOOL UserAction_OnExpandDay(
    XTPCalendarExpandDayButton eButton
);
Parameters

eButton
[in] a button from which this action comes.

Returns

TRUE if action was handled by user and default processing must be skipped, FALSE otherwise.

Remarks

Implementation send a XTP_NC_CALENDAR_USERACTION notification.

See Also

XTP_NC_CALENDAR_USERACTION

Group

CXTPCalendarViewDay Methods


CXTPCalendarViewDay Constructors

CXTPCalendarViewDay Class, Legend, Public Methods
CXTPCalendarViewDay Constructors
Class

CXTPCalendarViewDay Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewDay | Default object constructor. Construct CXTPCalendarViewDay object.


CXTPCalendarViewDay::CXTPCalendarViewDay Constructor

CXTPCalendarViewDay Constructors, CXTPCalendarViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDay::CXTPCalendarViewDay Constructor

Default object constructor. Construct CXTPCalendarViewDay object.

CXTPCalendarViewDay(
    CXTPCalendarView* pView
);
Parameters

pView
Pointer to CXTPCalendarView object.

See Also

~CXTPCalendarViewDay()

Group

CXTPCalendarViewDay Constructors


CXTPCalendarViewDay Destructors

CXTPCalendarViewDay Class, Legend, Public Methods
CXTPCalendarViewDay Destructors
Class

CXTPCalendarViewDay Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewDay | Default class destructor.


CXTPCalendarViewDay::~CXTPCalendarViewDay Destructor

CXTPCalendarViewDay Destructors, CXTPCalendarViewDay Class
CXTPCalendarViewDay::~CXTPCalendarViewDay Destructor

Default class destructor.

virtual ~CXTPCalendarViewDay();
Remarks

Handles member item deallocation.

Group

CXTPCalendarViewDay Destructors


CXTPCalendarViewDayT Template

XTPCalendarViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarViewDayT Data Members, CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Constructors, CXTPCalendarViewDayT Destructors, CXTPCalendarViewDayT Nested Types, CXTPCalendarViewDayT Constructors, CXTPCalendarViewDayT Data Members, CXTPCalendarViewDayT Destructors, CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT Template

This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class.

Class Hierarchy

template <class _TView, class _TViewGroup, class _THitTest, class _TPThis >
class CXTPCalendarViewDayT : public CXTPCalendarViewDay;
File

XTPCalendarViewDay.h

Remarks

It is used as a part of the calendar control framework to build ViewDay layer of View->DayView->ViewDay typed objects hierarchy. These are template parameters: _TView - Type of owner View object. _TViewGroup - Type of View Resource objects stored in View Day. _THitTest - Type of HitTest struct, used as parameter in the member functions. _TPThis - The last derived class type in the class hierarchy.

You must provide all of the above parameters.

See Also

CXTPCalendarViewDay

Group

Classes

Legend
Data Member
protected
Method
virtual
abstract
CXTPCalendarViewDayT Constructors
CXTPCalendarViewDayT Constructors | Description
CXTPCalendarViewDayT | Default object constructor.
CXTPCalendarViewDayT Data Members
CXTPCalendarViewDayT Data Members | Description
m_arViewGroups | Storage for views of groups.
CXTPCalendarViewDayT Destructors
CXTPCalendarViewDayT Destructors | Description
~CXTPCalendarViewDayT | Default class destructor.
CXTPCalendarViewDayT Methods
CXTPCalendarViewDayT Methods | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
FillHitTestEx | This member function is used to fill the pHitTest structure members with the default values for the current day view object.
GetPThis | Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.
GetView | This member function is used to obtain the owner view object.
GetView_ | This member function is used to obtain a pointer to the owner view object.
GetViewGroup | Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resource's index.
GetViewGroup_ | Call this member function to obtain a pointer to the base CXTPCalendarViewGroup* object that corresponds to the resource's index.
GetViewGroupsCount | Call this member function to obtain the number of resource views in the day view collection.
HitTest | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.
HitTestEx | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.
NoAllEventsAreVisible | Call this member function to determine if all of the day's event views are not visible and to calculate the rectangle for the ExpandSign.
Populate | This member function is used to populate the view with data for all resource items contained in the view.
CXTPCalendarViewDayT Nested Types
CXTPCalendarViewDayT Nested Types | Description
TView |
TViewGroupsCollection |


CXTPCalendarViewDayT Data Members

CXTPCalendarViewDayT Template, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT Data Members
Template

CXTPCalendarViewDayT Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arViewGroups | Storage for views of groups.


CXTPCalendarViewDayT::m_arViewGroups Data Member

CXTPCalendarViewDayT Data Members, CXTPCalendarViewDayT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::m_arViewGroups Data Member

Storage for views of groups.

TViewGroupsCollection m_arViewGroups;
Group

CXTPCalendarViewDayT Data Members


CXTPCalendarViewDayT Methods

CXTPCalendarViewDayT Template, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT Methods
Template

CXTPCalendarViewDayT Template

Legend
Method
virtual
abstract
protected
Protected Methods
Protected Methods
Protected Method | Description
GetPThis | Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
FillHitTestEx | This member function is used to fill the pHitTest structure members with the default values for the current day view object.
GetView | This member function is used to obtain the owner view object.
GetView_ | This member function is used to obtain a pointer to the owner view object.
GetViewGroup | Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resource's index.
GetViewGroup_ | Call this member function to obtain a pointer to the base CXTPCalendarViewGroup* object that corresponds to the resource's index.
GetViewGroupsCount | Call this member function to obtain the number of resource views in the day view collection.
HitTest | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.
HitTestEx | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.
NoAllEventsAreVisible | Call this member function to determine if all of the day's event views are not visible and to calculate the rectangle for the ExpandSign.
Populate | This member function is used to populate the view with data for all resource items contained in the view.


CXTPCalendarViewDayT::AdjustLayout Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcDay
);
Parameters

pDC
A pointer to a valid device context.
rcDay
A CRect object that contains the rectangle coordinates that are used to draw the view.

Remarks

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout().

Body Source
virtual void AdjustLayout(CDC* pDC, const CRect& rcDay)
{
    CXTPCalendarViewDay::AdjustLayout(pDC, rcDay);

    int nCount = GetViewGroupsCount();
    for (int i = 0; i < nCount; i++)
    {
        CXTPCalendarViewGroup* pViewGroup = GetViewGroup_(i);
        ASSERT(pViewGroup);
        if (pViewGroup) {
            pViewGroup->AdjustLayout(pDC, rcDay);
        }
    }
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::FillHitTestEx Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template
CXTPCalendarViewDayT::FillHitTestEx Method

This member function is used to fill the pHitTest structure members with the default values for the current day view object.

virtual void FillHitTestEx(
    _THitTest* pHitTest
) = 0;
Parameters

pHitTest
A Pointer to a _THitTest structure.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::GetPThis Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template
CXTPCalendarViewDayT::GetPThis Method

Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.

virtual _TPThis* GetPThis() = 0;
Returns

Pointer to this object as last derived class type.

Remarks

_TPThis - The last derived class type in the class hierarchy. This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::GetView Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::GetView Method

This member function is used to obtain the owner view object.

_TView* GetView() const;
Returns

A _TView template pointer to the owner view object.

See Also

GetView_

Body Source
_TView* GetView() const {
    ASSERT(this);
    return this ? m_pView : NULL;
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::GetView_ Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::GetView_ Method

This member function is used to obtain a pointer to the owner view object.

virtual CXTPCalendarView* GetView_() const;
Returns

A CXTPCalendarView pointer to the owner view object.

See Also

GetView

Body Source
virtual CXTPCalendarView* GetView_() const {
    ASSERT(this);
    return this ? (CXTPCalendarView*)m_pView : NULL;
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::GetViewGroup Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::GetViewGroup Method

Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resource's index.

virtual _TViewGroup* GetViewGroup(
    int nIndex
);
Parameters

nIndex
An int that contains the resource view index in the day view collection.

Returns

A pointer to a _TViewGroup template object.

Remarks

Index number starts with 0 and cannot be negative.

See Also

GetViewGroupsCount(), GetViewGroup_()

Body Source
virtual _TViewGroup* GetViewGroup(int nIndex)
{
    ASSERT(this);
    if (!this) {
        return NULL;
    }
    int nCount = m_arViewGroups.GetCount();
    ASSERT(nIndex >= 0 && nIndex < nCount);
    return (nIndex >= 0 && nIndex < nCount) ? m_arViewGroups.GetAt(nIndex) : NULL;
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::GetViewGroup_ Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::GetViewGroup_ Method

Call this member function to obtain a pointer to the base CXTPCalendarViewGroup* object that corresponds to the resource's index.

virtual CXTPCalendarViewGroup* GetViewGroup_(
    int nIndex
);
Parameters

nIndex
An int that contains the resource view index in the day view collection.

Returns

A pointer to a base of the _TViewGroup template object.

Remarks

Index number starts with 0 and cannot be negative.

See Also

GetViewGroupsCount(), GetViewGroup()

Body Source
virtual CXTPCalendarViewGroup* GetViewGroup_(int nIndex)
{
    ASSERT(this);
    _TViewGroup* pViewGroup = this ? GetViewGroup(nIndex) : NULL;
    return pViewGroup;
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::GetViewGroupsCount Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::GetViewGroupsCount Method

Call this member function to obtain the number of resource views in the day view collection.

virtual int GetViewGroupsCount();
Returns

An int that contains the number of resource views.

Body Source
virtual int GetViewGroupsCount() {
    return m_arViewGroups.GetCount();
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::HitTest Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::HitTest Method

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.

virtual BOOL HitTest(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO* pHitTest
);
Parameters

pt
A CPoint object that contains the coordinates of the point to test.
pHitTest
A pointer to a XTP_CALENDAR_HITTESTINFO struct that contains information about the point to test.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

Implements standard functionality for the HitTest method.

See Also

XTP_CALENDAR_HITTESTINFO

Body Source
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest)
{
    _THitTest hitInfo;
    BOOL bRes = HitTestEx(pt, &hitInfo);
    if (bRes && pHitTest) {
        *pHitTest = (XTP_CALENDAR_HITTESTINFO)hitInfo;
    }
    return bRes;
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::HitTestEx Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::HitTestEx Method

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.

virtual BOOL HitTestEx(
    CPoint pt,
    _THitTest* pHitTest
);
Parameters

pt
A CPoint that contains the coordinates of the point test.
pHitTest
A pointer to a _THitTest structure.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

Implements standard functionality for the HitTestEx method.

See Also

XTP_CALENDAR_HITTESTINFO

Body Source
virtual BOOL HitTestEx(CPoint pt, _THitTest* pHitTest)
{
    if (!pHitTest) {
        ASSERT(FALSE);
        return FALSE;
    }

    if (!m_Layout.m_rcDay.PtInRect(pt)) {
        return FALSE;
    }

    if (m_Layout.m_rcDayHeader.PtInRect(pt)) {
        FillHitTestEx(pHitTest);
        pHitTest->uHitCode = xtpCalendarHitTestDayHeader;
        return TRUE;
    }

    if (m_Layout.m_rcExpandSign.PtInRect(pt) &&
        !XTP_SAFE_GET1(GetView_(), GetTheme(), NULL))
    {
        FillHitTestEx(pHitTest);
        pHitTest->uHitCode = xtpCalendarHitTestDayExpandButton;
        return TRUE;
    }

    int nCount = GetViewGroupsCount();
    for (int i = 0; i < nCount; i++)
    {
        _TViewGroup* pViewGroup = GetViewGroup(i);
        ASSERT(pViewGroup);
        if (pViewGroup && pViewGroup->HitTestEx(pt, pHitTest))
        {
            ASSERT(!pHitTest->pViewGroup || pHitTest->pViewGroup == pViewGroup);
            pHitTest->nGroup = i;
            pHitTest->pViewGroup = pViewGroup;
            return TRUE;
        }
    }

    FillHitTestEx(pHitTest);
    pHitTest->uHitCode = xtpCalendarHitTestDayArea;
    return TRUE;
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::NoAllEventsAreVisible Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::NoAllEventsAreVisible Method

Call this member function to determine if all of the day's event views are not visible and to calculate the rectangle for the ExpandSign.

virtual BOOL NoAllEventsAreVisible();
Parameters

pDC
A pointer to a valid device context.

Returns

TRUE if there are invisible event views. FALSE otherwise.

See Also

CXTPCalendarViewDay::_NoAllEventsAreVisible

Body Source
virtual BOOL NoAllEventsAreVisible()
{
    if (CXTPCalendarViewDay::_NoAllEventsAreVisible())
    {
        if (GetView_() && !GetView_()->GetTheme())
        {
            CSize szBm = XTP_SAFE_GET2(GetView_(), GetPaintManager(), GetExpandSignSize(), CSize(0) );
            m_Layout.m_rcExpandSign.SetRect(m_Layout.m_rcDay.right - szBm.cx, m_Layout.m_rcDay.bottom - szBm.cy,
                m_Layout.m_rcDay.right, m_Layout.m_rcDay.bottom);
        }
        return TRUE;
    }
    else
    {
        m_Layout.m_rcExpandSign.SetRect(m_Layout.m_rcDay.right, m_Layout.m_rcDay.bottom,
            m_Layout.m_rcDay.right, m_Layout.m_rcDay.bottom);
        return FALSE;
    }
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT::Populate Method

CXTPCalendarViewDayT Methods, CXTPCalendarViewDayT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::Populate Method

This member function is used to populate the view with data for all resource items contained in the view.

virtual void Populate(
    COleDateTime dtDayDate
);
Parameters

dtDayDate
A COleDateTime object that contains the day's date.

Remarks

This function provides common functionality for all CXTPCalendarViewDay - derived classes.

Body Source
virtual void Populate(COleDateTime dtDayDate)
{
    m_dtDate = CXTPCalendarUtils::ResetTime(dtDayDate);
    m_arViewGroups.RemoveAll();

    if (!GetView_()) {
        return;
    }

    OnPrePopulateDay();

    CXTPCalendarResources* pResources = GetResources();
    if (!pResources)
        return;

    _TViewGroup* pGroup = new _TViewGroup(GetPThis());
    if (!pGroup) {
        return;
    }
    m_arViewGroups.Add(pGroup);

    pGroup->SetResources(pResources);
    pGroup->Populate(m_dtDate);
}
Group

CXTPCalendarViewDayT Methods


CXTPCalendarViewDayT Constructors

CXTPCalendarViewDayT Template, Legend, Public Methods
CXTPCalendarViewDayT Constructors
Template

CXTPCalendarViewDayT Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewDayT | Default object constructor.


CXTPCalendarViewDayT::CXTPCalendarViewDayT Constructor

CXTPCalendarViewDayT Constructors, CXTPCalendarViewDayT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::CXTPCalendarViewDayT Constructor

Default object constructor.

CXTPCalendarViewDayT(
    _TView* pView
);
Parameters

pView
Pointer to owner view object.

See Also

~CXTPCalendarViewDayT()

Body Source
CXTPCalendarViewDayT(_TView* pView) : CXTPCalendarViewDay((CXTPCalendarView*)pView)
{
    m_pView = pView;
}
Group

CXTPCalendarViewDayT Constructors


CXTPCalendarViewDayT Destructors

CXTPCalendarViewDayT Template, Legend, Public Methods
CXTPCalendarViewDayT Destructors
Template

CXTPCalendarViewDayT Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewDayT | Default class destructor.


CXTPCalendarViewDayT::~CXTPCalendarViewDayT Destructor

CXTPCalendarViewDayT Destructors, CXTPCalendarViewDayT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::~CXTPCalendarViewDayT Destructor

Default class destructor.

virtual ~CXTPCalendarViewDayT();
Remarks

Handles class members deallocation.

Body Source
virtual ~CXTPCalendarViewDayT() {
}
Group

CXTPCalendarViewDayT Destructors


CXTPCalendarViewDayT Nested Types

CXTPCalendarViewDayT Template, Public Nested Types
CXTPCalendarViewDayT Nested Types
Template

CXTPCalendarViewDayT Template

Public Nested Types
Public Nested Type | Description
TView |
TViewGroupsCollection |


CXTPCalendarViewDayT::TView Nested Type

CXTPCalendarViewDayT Nested Types, CXTPCalendarViewDayT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::TView Nested Type
typedef _TView TView;
Remarks

Owner view class type definition.

Group

CXTPCalendarViewDayT Nested Types


CXTPCalendarViewDayT::TViewGroupsCollection Nested Type

CXTPCalendarViewDayT Nested Types, CXTPCalendarViewDayT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewDayT::TViewGroupsCollection Nested Type
typedef CXTPCalendarPtrCollectionT< _TViewGroup > TViewGroupsCollection;
Remarks

Resource views collection type definition.

Group

CXTPCalendarViewDayT Nested Types


CXTPCalendarViewEvent Class

XTPCalendarViewEvent.h, Classes, Legend, Members, Topics, CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Constructors, CXTPCalendarViewEvent Destructors, CXTPCalendarViewEvent Constructors, CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Destructors, CXTPCalendarViewEvent Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent Class

This class represents an event view portion of the CalendarViewGroup.

Class Hierarchy

class CXTPCalendarViewEvent : public CXTPCalendarWMHandler;
File

XTPCalendarViewEvent.h

Remarks

It represents a specific view of the event associated data according to various view types and display settings and provides basic functionality on this data using user input through keyboard and mouse.

These are the predefined view implementations available for the Calendar control:

  • Day and work week event views - Using the CXTPCalendarDayViewEvent class.
  • Week event view - Using the CXTPCalendarWeekViewEvent class.
  • Month view view - Using the CXTPCalendarMonthViewEvent class.

Furthermore, any type of user defined event view may also be implemented as a descendant of the CXTPCalendarViewEvent class.

See Also

CXTPCalendarDayViewEvent, CXTPCalendarWeekViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup

Group

Classes

Legend
Data Member
protected
Method
virtual
abstract
CXTPCalendarViewEvent Constructors
CXTPCalendarViewEvent Constructors | Description
CXTPCalendarViewEvent | Default object constructor.
CXTPCalendarViewEvent Data Members
CXTPCalendarViewEvent Data Members | Description
m_bMultyDayTextAlign | Flag indicates special text alignment for multi day event.
m_bSelected | Event view selected flag.
m_bTextOutOfBorders | Flag indicates text out of event borders.
m_nEventPlaceNumber | Event view place number (sequential identifier).
m_nMultiDayEventFlags | Multi day event flags packed into integer by bitwise operations.
m_nTimerID_ShowToolTip | Identifier of timer event to show tooltip with delay.
m_pMasterView | Pointer to Master event view object.
m_pSubjectEditor | Pointer to subject editor.
m_ptrEvent | Pointer to the displayed event object.
m_pUIElement | Store pointer to CXTPMarkupUIElement object.
m_rcEndTime | Rectangle to display end time event view.
m_rcEvent | Event view rectangle.
m_rcEventMax | Event view rectangle margins.
m_rcFirstClock | Rectangle to draw clock in the beginning of the first day of multi day event.
m_rcLastClock | Rectangle to draw clock at the end of the last day of multi day event.
m_rcMeetingGlyph | Rectangle to draw meeting glyph event view.
m_rcPrivateGlyph | Rectangle to draw private glyph event view.
m_rcRecurrenceGlyph | Rectangle to draw recurrence glyph event view.
m_rcReminderGlyph | Rectangle to draw reminder glyph event view.
m_rcStartTime | Rectangle to display start time day event view.
m_rcSubjectEditor | Subject editor rectangle.
m_rcText | Rectangle to display event text in event view.
m_rcToolTip | Tool tip rectangle.
m_strUIElementText | Store last markup text for which m_pUIElement object was updated.
m_szText | Sizes of displayed text.
CXTPCalendarViewEvent Destructors
CXTPCalendarViewEvent Destructors | Description
~CXTPCalendarViewEvent | Default class destructor.
CXTPCalendarViewEvent Methods
CXTPCalendarViewEvent Methods | Description
_MoveRectY | This member function is used to move the rectangle vertically.
AddMultiDayEvent_Slave | This member function is used to add a Slave event view to the Master event view.
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.
AdjustMultidayEvent | This member function is used to adjust a multi day view's layout depending on the provided rectangle coordinates.
AdjustSubjectEditor | This member function is used to perform adjustments of the subject editor area.
CalcIconsRect | This member function is used to adjust the icons rectangle used to draw the event view icons.
ChangeEventPlace | This function is used to change the event place number.
Draw | This member function is used to draw the view content using the specified device context.
EndEditSubject | This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.
FormatEventTime | This member function is used to format the event's time as a string with a predefined format.
GetCalendarControl | Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
GetEditingSubjectFromEditor | Call this member function to obtain an edited subject.
GetEndTimeRect | This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.
GetEvent | Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.
GetEventPlaceNumber | This member function is used to obtain the place number of the event view.
GetEventRect | This member function is used to obtain the event view's bounding rectangle.
GetFirstClockRect | This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.
GetItemText | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextBody | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextEndTime | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextLocation | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextStartTime | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextSubject | These member functions are used to obtain event subject, location, body and others items text.
GetLastClockRect | This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of multi day event.
GetMarkupText | This member functions are used to obtain markup template text.
GetMarkupUIElement | This member functions are used to get stored CXTPMarkupUIElement object.
GetMeetingGlyphRect | This member function obtains the rectangle coordinates for displaying the meeting icon.
GetMultiDayEventFlags | This member function is used to obtain the multi day event state flags.
GetPrivateGlyphRect | This member function is used to obtain the rectangle coordinates used for displaying the private icon.
GetRecurrenceGlyphRect | This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.
GetReminderGlyphRect | This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
GetShowToolTipTimeOut | This member function is used to obtain the timeout value for displaying a tooltip.
GetStartTimeRect | This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.
GetSubjectEditor | This member function is used to obtain the event's subject editor window.
GetSubjectEditorFont | This member function is used to obtain a pointer to the editor window font.
GetSubjectEditorRect | This member function is used to obtain the subject editor rectangle coordinates.
GetSubjectEditorStyles | like multi-line
GetTextRect | This member function is used to obtain the rectangle coordinates used for displaying the event's subject.
GetToolText | This member function is used to obtain tooltip text for the event view.
GetViewEventRect | This member function is used to obtain the rectangle coordinates for the event's rectangle.
GetViewEventRectMax | This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.
GetViewGroup_ | Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
HideToolTip | This member function is used to hide the ToolTip rectangle.
HitTest | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.
IsEditingSubject | Call this member function to determine if the event's subject is currently being edited.
IsMultidayEvent | Call this member function to determine if the given event view is a multi-day event.
IsMultyDayTextAlign | This member function is used to obtain the flag to determine if multi day text align mode is on.
IsSelected | Call this member function to determine if the given event view is selected.
IsShowingToolTip | Call this member function to determine if the event's tooltip is visible.
IsTextOutOfBorders | This member function is used to determine if the text size exceeds the event view bounds.
IsVisible | Call this member function to determine if this event view is visible on the screen.
KillTimer | This member function is used to destroy a timer event.
OnBeforeDestroy | Called by the framework before the destroy() function is called.
OnMouseMove | This member function is used to process mouse movement events.
OnPostAdjustLayout | This member function is used to perform additional adjustments in some kinds of views.
OnTimer | The framework calls this member function after each interval specified in the SetTimer member function.
SetMultiDayEvent_MasterSlave | This member function is used to set the multi day event Master/Slave state.
SetSelected | This member function is used to set the day view as select or unselected.
SetTextOutOfBorders | This member function is used to set a flag to determine if the text size exceeds the event view bounds.
SetTimer | This member function is used to create a timer event.
ShowToolTip | This member function is used to show a ToolTip rectangle.
StartEditSubject | This member function is used to create and to show the subject editor.


CXTPCalendarViewEvent Data Members

CXTPCalendarViewEvent Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent Data Members
Class

CXTPCalendarViewEvent Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bMultyDayTextAlign | Flag indicates special text alignment for multi day event.
m_bSelected | Event view selected flag.
m_bTextOutOfBorders | Flag indicates text out of event borders.
m_nEventPlaceNumber | Event view place number (sequential identifier).
m_nTimerID_ShowToolTip | Identifier of timer event to show tooltip with delay.
m_pMasterView | Pointer to Master event view object.
m_pSubjectEditor | Pointer to subject editor.
m_ptrEvent | Pointer to the displayed event object.
Public Data Members
Public Data Member | Description
m_nMultiDayEventFlags | Multi day event flags packed into integer by bitwise operations.
m_pUIElement | Store pointer to CXTPMarkupUIElement object.
m_rcEndTime | Rectangle to display end time event view.
m_rcEvent | Event view rectangle.
m_rcEventMax | Event view rectangle margins.
m_rcFirstClock | Rectangle to draw clock in the beginning of the first day of multi day event.
m_rcLastClock | Rectangle to draw clock at the end of the last day of multi day event.
m_rcMeetingGlyph | Rectangle to draw meeting glyph event view.
m_rcPrivateGlyph | Rectangle to draw private glyph event view.
m_rcRecurrenceGlyph | Rectangle to draw recurrence glyph event view.
m_rcReminderGlyph | Rectangle to draw reminder glyph event view.
m_rcStartTime | Rectangle to display start time day event view.
m_rcSubjectEditor | Subject editor rectangle.
m_rcText | Rectangle to display event text in event view.
m_rcToolTip | Tool tip rectangle.
m_strUIElementText | Store last markup text for which m_pUIElement object was updated.
m_szText | Sizes of displayed text.


CXTPCalendarViewEvent::m_bMultyDayTextAlign Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_bMultyDayTextAlign Data Member

Flag indicates special text alignment for multi day event.

BOOL m_bMultyDayTextAlign;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_bSelected Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_bSelected Data Member

Event view selected flag.

BOOL m_bSelected;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_bTextOutOfBorders Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_bTextOutOfBorders Data Member

Flag indicates text out of event borders.

BOOL m_bTextOutOfBorders;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_nEventPlaceNumber Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_nEventPlaceNumber Data Member

Event view place number (sequential identifier).

int m_nEventPlaceNumber;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_nMultiDayEventFlags Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_nMultiDayEventFlags Data Member

Multi day event flags packed into integer by bitwise operations.

int m_nMultiDayEventFlags;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_nTimerID_ShowToolTip Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_nTimerID_ShowToolTip Data Member

Identifier of timer event to show tooltip with delay.

UINT m_nTimerID_ShowToolTip;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_pMasterView Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_pMasterView Data Member

Pointer to Master event view object.

CXTPCalendarViewEvent* m_pMasterView;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_pSubjectEditor Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_pSubjectEditor Data Member

Pointer to subject editor.

CXTPCalendarViewEventSubjectEditor* m_pSubjectEditor;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_ptrEvent Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_ptrEvent Data Member

Pointer to the displayed event object.

CXTPCalendarEvent* m_ptrEvent;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_pUIElement Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_pUIElement Data Member

Store pointer to CXTPMarkupUIElement object.

CXTPMarkupUIElement* m_pUIElement;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcEndTime Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcEndTime Data Member

Rectangle to display end time event view.

CXTPEmptyRect m_rcEndTime;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcEvent Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcEvent Data Member

Event view rectangle.

CXTPEmptyRect m_rcEvent;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcEventMax Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcEventMax Data Member

Event view rectangle margins.

CXTPEmptyRect m_rcEventMax;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcFirstClock Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcFirstClock Data Member

Rectangle to draw clock in the beginning of the first day of multi day event.

CXTPEmptyRect m_rcFirstClock;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcLastClock Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcLastClock Data Member

Rectangle to draw clock at the end of the last day of multi day event.

CXTPEmptyRect m_rcLastClock;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcMeetingGlyph Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcMeetingGlyph Data Member

Rectangle to draw meeting glyph event view.

CXTPEmptyRect m_rcMeetingGlyph;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcPrivateGlyph Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcPrivateGlyph Data Member

Rectangle to draw private glyph event view.

CXTPEmptyRect m_rcPrivateGlyph;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcRecurrenceGlyph Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcRecurrenceGlyph Data Member

Rectangle to draw recurrence glyph event view.

CXTPEmptyRect m_rcRecurrenceGlyph;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcReminderGlyph Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcReminderGlyph Data Member

Rectangle to draw reminder glyph event view.

CXTPEmptyRect m_rcReminderGlyph;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcStartTime Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcStartTime Data Member

Rectangle to display start time day event view.

CXTPEmptyRect m_rcStartTime;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcSubjectEditor Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcSubjectEditor Data Member

Subject editor rectangle.

CXTPEmptyRect m_rcSubjectEditor;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcText Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcText Data Member

Rectangle to display event text in event view.

CXTPEmptyRect m_rcText;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_rcToolTip Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_rcToolTip Data Member

Tool tip rectangle.

CXTPEmptyRect m_rcToolTip;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_strUIElementText Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_strUIElementText Data Member

Store last markup text for which m_pUIElement object was updated.

CString m_strUIElementText;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent::m_szText Data Member

CXTPCalendarViewEvent Data Members, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::m_szText Data Member

Sizes of displayed text.

CSize m_szText;
Group

CXTPCalendarViewEvent Data Members


CXTPCalendarViewEvent Methods

CXTPCalendarViewEvent Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent Methods
Class

CXTPCalendarViewEvent Class

Legend
Method
protected
virtual
abstract
Protected Methods
Protected Methods
Protected Method | Description
_MoveRectY | This member function is used to move the rectangle vertically.
AdjustMultidayEvent | This member function is used to adjust a multi day view's layout depending on the provided rectangle coordinates.
CalcIconsRect | This member function is used to adjust the icons rectangle used to draw the event view icons.
ChangeEventPlace | This function is used to change the event place number.
GetShowToolTipTimeOut | This member function is used to obtain the timeout value for displaying a tooltip.
GetSubjectEditorFont | This member function is used to obtain a pointer to the editor window font.
GetSubjectEditorStyles | like multi-line
GetToolText | This member function is used to obtain tooltip text for the event view.
KillTimer | This member function is used to destroy a timer event.
OnBeforeDestroy | Called by the framework before the destroy() function is called.
OnMouseMove | This member function is used to process mouse movement events.
OnTimer | The framework calls this member function after each interval specified in the SetTimer member function.
SetTimer | This member function is used to create a timer event.
Public Methods
Public Methods
Public Method | Description
AddMultiDayEvent_Slave | This member function is used to add a Slave event view to the Master event view.
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.
AdjustSubjectEditor | This member function is used to perform adjustments of the subject editor area.
Draw | This member function is used to draw the view content using the specified device context.
EndEditSubject | This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.
FormatEventTime | This member function is used to format the event's time as a string with a predefined format.
GetCalendarControl | Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
GetEditingSubjectFromEditor | Call this member function to obtain an edited subject.
GetEndTimeRect | This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.
GetEvent | Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.
GetEventPlaceNumber | This member function is used to obtain the place number of the event view.
GetEventRect | This member function is used to obtain the event view's bounding rectangle.
GetFirstClockRect | This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.
GetItemText | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextBody | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextEndTime | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextLocation | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextStartTime | These member functions are used to obtain event subject, location, body and others items text.
GetItemTextSubject | These member functions are used to obtain event subject, location, body and others items text.
GetLastClockRect | This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of multi day event.
GetMarkupText | This member functions are used to obtain markup template text.
GetMarkupUIElement | This member functions are used to get stored CXTPMarkupUIElement object.
GetMeetingGlyphRect | This member function obtains the rectangle coordinates for displaying the meeting icon.
GetMultiDayEventFlags | This member function is used to obtain the multi day event state flags.
GetPrivateGlyphRect | This member function is used to obtain the rectangle coordinates used for displaying the private icon.
GetRecurrenceGlyphRect | This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.
GetReminderGlyphRect | This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
GetStartTimeRect | This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.
GetSubjectEditor | This member function is used to obtain the event's subject editor window.
GetSubjectEditorRect | This member function is used to obtain the subject editor rectangle coordinates.
GetTextRect | This member function is used to obtain the rectangle coordinates used for displaying the event's subject.
GetViewEventRect | This member function is used to obtain the rectangle coordinates for the event's rectangle.
GetViewEventRectMax | This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.
GetViewGroup_ | Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
HideToolTip | This member function is used to hide the ToolTip rectangle.
HitTest | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.
IsEditingSubject | Call this member function to determine if the event's subject is currently being edited.
IsMultidayEvent | Call this member function to determine if the given event view is a multi-day event.
IsMultyDayTextAlign | This member function is used to obtain the flag to determine if multi day text align mode is on.
IsSelected | Call this member function to determine if the given event view is selected.
IsShowingToolTip | Call this member function to determine if the event's tooltip is visible.
IsTextOutOfBorders | This member function is used to determine if the text size exceeds the event view bounds.
IsVisible | Call this member function to determine if this event view is visible on the screen.
OnPostAdjustLayout | This member function is used to perform additional adjustments in some kinds of views.
SetMultiDayEvent_MasterSlave | This member function is used to set the multi day event Master/Slave state.
SetSelected | This member function is used to set the day view as select or unselected.
SetTextOutOfBorders | This member function is used to set a flag to determine if the text size exceeds the event view bounds.
ShowToolTip | This member function is used to show a ToolTip rectangle.
StartEditSubject | This member function is used to create and to show the subject editor.


CXTPCalendarViewEvent::_MoveRectY Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::_MoveRectY Method

This member function is used to move the rectangle vertically.

static void _MoveRectY(
    int nYbasePrev,
    int nYbaseNew,
    CRect& rRC
);
Parameters

nYbasePrev
An int that contains the previous position.
nYbaseNew
An int that contains the new position.
rRC
A CRect that contains the rectangle coordinates.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::AddMultiDayEvent_Slave Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::AddMultiDayEvent_Slave Method

This member function is used to add a Slave event view to the Master event view.

virtual void AddMultiDayEvent_Slave(
    CXTPCalendarViewEvent* pSlaveView,
    int nMasterEventPlace
);
Parameters

pSlaveView
A CXTPCalendarViewEvent pointer to the Slave event view object.
nMasterEventPlace
An int that contains the Master event place number.

Remarks

For multi day event only.

See Also

SetMultiDayEvent_MasterSlave

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::AdjustLayout Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcEventMax,
    int nEventPlaceNumber
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcEventMax,
    int nEventPlaceNumber
) = 0;
Parameters

pDC
A pointer to a valid device context.
rcEventMax
A CRect that contains the rectangle coordinates used to draw the view.
nEventPlaceNumber
An int that contains the sequential place number.

Remarks

Call Populate(COleDateTime dtDayDate) prior to adjust layout.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::AdjustMultidayEvent Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::AdjustMultidayEvent Method

This member function is used to adjust a multi day view's layout depending on the provided rectangle coordinates.

virtual void AdjustMultidayEvent(
    CRect rcEventMax,
    int nEventPlaceNumber
);
Parameters

rcEventMax
A CRect that contains the rectangle coordinates used to draw the view.
nEventPlaceNumber
An int that contains the sequential place number.

Remarks

Call this member function to perform special adjustment of multi day events that must be drawn together through a number of sequential days in some views. Call Populate(COleDateTime dtDayDate) prior to adjust layout.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::AdjustSubjectEditor Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::AdjustSubjectEditor Method

This member function is used to perform adjustments of the subject editor area.

virtual void AdjustSubjectEditor();
Remarks

Call this member function to perform adjustment of subject editor rectangle.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::CalcIconsRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::CalcIconsRect Method

This member function is used to adjust the icons rectangle used to draw the event view icons.

virtual int CalcIconsRect(
    CRect rc
);
Parameters

rc
A CRect that contains the coordinates used to draw the view.

Remarks

Call this member function to calculate rectangles used to draw event view icons depending on what glyphs must be drawn and based on the event view rect.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::ChangeEventPlace Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::ChangeEventPlace Method

This function is used to change the event place number.

virtual void ChangeEventPlace(
    int nNewPlace
);
Parameters

nNewPlace
new event place number.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::Draw Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::Draw Method

This member function is used to draw the view content using the specified device context.

virtual void Draw(
    CDC* pDC
) = 0;
Parameters

pDC
A pointer to a valid device context.

Remarks

Call AdjustLayout() before calling Draw(). This is a pure virtual function. This function must be defined in the derived class.

See Also

AdjustLayout()

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::EndEditSubject Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::EndEditSubject Method

This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.

virtual CString EndEditSubject();
Returns

A CString object containing the edited subject text.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::FormatEventTime Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::FormatEventTime Method

This member function is used to format the event's time as a string with a predefined format.

virtual CString FormatEventTime(
    COleDateTime dtTime
);
Parameters

dtTime
A COleDateTime time object that contains the value to format.

Returns

A CString object that contains the formatted time.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetCalendarControl Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::GetCalendarControl Method

Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.

CXTPCalendarControl* GetCalendarControl();
Returns

A pointer to a CXTPCalendarViewDay object.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetEditingSubjectFromEditor Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::GetEditingSubjectFromEditor Method

Call this member function to obtain an edited subject.

virtual CString GetEditingSubjectFromEditor();
Returns

A CString object containing the edited subject.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetEndTimeRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetEndTimeRect Method

This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.

virtual CRect GetEndTimeRect();
Returns

A CRect object containing the clocks rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetEndTimeRect() {
    return m_rcEndTime;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetEvent Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetEvent Method

Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.

CXTPCalendarEvent* GetEvent();
Returns

A pointer to a CXTPCalendarEvent object.

Body Source
CXTPCalendarEvent* CXTPCalendarViewEvent::GetEvent() {
    return m_ptrEvent;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetEventPlaceNumber Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetEventPlaceNumber Method

This member function is used to obtain the place number of the event view.

virtual int GetEventPlaceNumber() const;
Returns

An int that contains the event's view place number.

Body Source
int CXTPCalendarViewEvent::GetEventPlaceNumber() const {
    return m_nEventPlaceNumber;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetEventRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetEventRect Method

This member function is used to obtain the event view's bounding rectangle.

CRect GetEventRect() const;
Returns

A CRect object with the bounding rectangle's coordinates.

Remarks

Use this member function to obtain the event view's bounding rectangle coordinates.

Body Source
CRect CXTPCalendarViewEvent::GetEventRect() const {
    return m_rcEvent;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetFirstClockRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetFirstClockRect Method

This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.

virtual CRect GetFirstClockRect();
Returns

A CRect object containing the clocks rectangle coordinates.

Body Source
CRect CXTPCalendarViewEvent::GetFirstClockRect() {
    return m_rcFirstClock;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetItemTextSubject Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetItemTextSubject Method

These member functions are used to obtain event subject, location, body and others items text.

virtual CString GetItemTextSubject();
virtual CString GetItemTextLocation();
virtual CString GetItemTextBody();
virtual CString GetItemTextStartTime();
virtual CString GetItemTextEndTime();
virtual CString GetItemText(
    DWORD dwItemFlag,
    LPCTSTR pcszDefaultText = NULL
);
Parameters

dwItemFlag
[in] Flags from enum XTPCalendarGetItemText which specify event item.
pcszDefaultText
[in] Pointer to default item text or NULL to generate default text automatically.

Remarks

If AskItemTextFlags has xtpCalendarItemText_EventXXX flags set - XTP_NC_CALENDAR_GETITEMTEXT notification is sent to customize standard text.

See Also

XTPCalendarGetItemText,XTPCalendarGetItemTextEx, XTP_NC_CALENDAR_GETITEMTEXT, CXTPCalendarControl::GetAskItemTextFlags, CXTPCalendarControlPaintManager::GetAskItemTextFlags, CXTPCalendarControlPaintManager::SetAskItemTextFlags, CXTPCalendarTheme::GetAskItemTextFlags, CXTPCalendarTheme::SetAskItemTextFlags

Body Source
CString CXTPCalendarViewEvent::GetItemTextSubject() {
    return GetItemText(xtpCalendarItemText_EventSubject);
}

CString CXTPCalendarViewEvent::GetItemTextLocation() {
    return GetItemText(xtpCalendarItemText_EventLocation);
}

CString CXTPCalendarViewEvent::GetItemTextBody() {
    return GetItemText(xtpCalendarItemText_EventBody);
}

CString CXTPCalendarViewEvent::GetItemTextStartTime() {
    return GetItemText(xtpCalendarItemText_EventStartTimeText);
}

CString CXTPCalendarViewEvent::GetItemTextEndTime() {
    return GetItemText(xtpCalendarItemText_EventEndTimeText);
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetLastClockRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetLastClockRect Method

This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of multi day event.

virtual CRect GetLastClockRect();
Returns

A CRect object containing the clocks rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetLastClockRect() {
    return m_rcLastClock;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetMarkupText Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::GetMarkupText Method

This member functions are used to obtain markup template text.

virtual CString GetMarkupText();
Returns

String with prepared markup text.

Remarks

It internally call GetItemText to replace markup template parameters: [ul] [li] /Calendar/Events/Event/Subject [li] /Calendar/Events/Event/Location [li] /Calendar/Events/Event/Body [li] /Calendar/Events/Event/StartTime [li] /Calendar/Events/Event/EndTime

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetMarkupUIElement Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::GetMarkupUIElement Method

This member functions are used to get stored CXTPMarkupUIElement object.

virtual CXTPMarkupUIElement* GetMarkupUIElement();
Returns

A pointer to CXTPMarkupUIElement object.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetMeetingGlyphRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetMeetingGlyphRect Method

This member function obtains the rectangle coordinates for displaying the meeting icon.

virtual CRect GetMeetingGlyphRect();
Returns

A CRect object containing the glyph rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetMeetingGlyphRect() {
    return m_rcMeetingGlyph;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetMultiDayEventFlags Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetMultiDayEventFlags Method

This member function is used to obtain the multi day event state flags.

virtual int GetMultiDayEventFlags() const;
Returns

An int that contains the event state flags.

See Also

XTPCalendarMultiDayEventFlags

Body Source
int CXTPCalendarViewEvent::GetMultiDayEventFlags() const {
    return m_nMultiDayEventFlags;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetPrivateGlyphRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetPrivateGlyphRect Method

This member function is used to obtain the rectangle coordinates used for displaying the private icon.

virtual CRect GetPrivateGlyphRect();
Returns

A CRect object containing the glyph rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetPrivateGlyphRect() {
    return m_rcPrivateGlyph;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetRecurrenceGlyphRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetRecurrenceGlyphRect Method

This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.

virtual CRect GetRecurrenceGlyphRect();
Returns

A CRect object containing the glyph rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetRecurrenceGlyphRect() {
    return m_rcRecurrenceGlyph;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetReminderGlyphRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetReminderGlyphRect Method

This member function is used to obtain the rectangle coordinates for displaying the remainder icon.

virtual CRect GetReminderGlyphRect();
Returns

A CRect object containing the glyph rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetReminderGlyphRect() {
    return m_rcReminderGlyph;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetShowToolTipTimeOut Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetShowToolTipTimeOut Method

This member function is used to obtain the timeout value for displaying a tooltip.

virtual UINT GetShowToolTipTimeOut() const;
Returns

A UINT that contains the value of timeout in milliseconds.

Body Source
UINT CXTPCalendarViewEvent::GetShowToolTipTimeOut() const {
    return XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetStartTimeRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetStartTimeRect Method

This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.

virtual CRect GetStartTimeRect();
Returns

A CRect object containing the clocks rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetStartTimeRect() {
    return m_rcStartTime;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetSubjectEditor Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetSubjectEditor Method

This member function is used to obtain the event's subject editor window.

virtual CWnd* GetSubjectEditor();
Returns

A pointer to the CWnd or NULL.

Body Source
CWnd* CXTPCalendarViewEvent::GetSubjectEditor() {
    return m_pSubjectEditor;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetSubjectEditorFont Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetSubjectEditorFont Method

This member function is used to obtain a pointer to the editor window font.

virtual CFont* GetSubjectEditorFont();
Returns

A pointer to a CFont object that contains the editor window font.

Body Source
CFont* CXTPCalendarViewEvent::GetSubjectEditorFont() {
    return NULL;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetSubjectEditorRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetSubjectEditorRect Method

This member function is used to obtain the subject editor rectangle coordinates.

virtual CRect GetSubjectEditorRect() const;
Returns

A CRect object containing the subject editor rectangle coordinates.

Body Source
CRect CXTPCalendarViewEvent::GetSubjectEditorRect() const {
    return m_rcSubjectEditor;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetSubjectEditorStyles Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetSubjectEditorStyles Method

like multi-line

virtual DWORD GetSubjectEditorStyles();
Body Source
DWORD CXTPCalendarViewEvent::GetSubjectEditorStyles() {
    return ES_AUTOHSCROLL | ES_NOHIDESEL;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetTextRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetTextRect Method

This member function is used to obtain the rectangle coordinates used for displaying the event's subject.

virtual CRect GetTextRect();
Returns

A CRect object containing the text rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetTextRect() {
    return m_rcText;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetToolText Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::GetToolText Method

This member function is used to obtain tooltip text for the event view.

virtual CString GetToolText();
Returns

A CString object containing the tooltip text.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetViewEventRect Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetViewEventRect Method

This member function is used to obtain the rectangle coordinates for the event's rectangle.

virtual CRect GetViewEventRect();
Returns

A CRect object containing the event's rectangle.

Body Source
CRect CXTPCalendarViewEvent::GetViewEventRect() {
    return m_rcEvent;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetViewEventRectMax Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::GetViewEventRectMax Method

This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.

virtual CRect GetViewEventRectMax();
Returns

A CRect object containing the event's maximum rectangle dimensions.

Body Source
CRect CXTPCalendarViewEvent::GetViewEventRectMax() {
    return m_rcEventMax;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::GetViewGroup_ Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::GetViewGroup_ Method

Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.

virtual CXTPCalendarViewGroup* GetViewGroup_() const = 0;
Returns

A pointer to the CXTPCalendarViewDay object.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::HideToolTip Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::HideToolTip Method

This member function is used to hide the ToolTip rectangle.

virtual void HideToolTip();
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::HitTest Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::HitTest Method

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.

virtual BOOL HitTest(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO* pHitTest
) = 0;
Parameters

pt
A CPoint that contains the coordinates of the point to test.
pHitTest
A pointer to an XTP_CALENDAR_HITTESTINFO structure.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

See Also

XTP_CALENDAR_HITTESTINFO

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::IsEditingSubject Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::IsEditingSubject Method

Call this member function to determine if the event's subject is currently being edited.

virtual BOOL IsEditingSubject() const;
Returns

A BOOL. TRUE if the subject is being edited. FALSE otherwise.

Body Source
BOOL CXTPCalendarViewEvent::IsEditingSubject() const {
    return m_pSubjectEditor != NULL;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::IsMultidayEvent Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::IsMultidayEvent Method

Call this member function to determine if the given event view is a multi-day event.

virtual BOOL IsMultidayEvent();
Returns

A BOOL. TRUE if the event view is a multi-day event. FALSE otherwise.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::IsMultyDayTextAlign Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::IsMultyDayTextAlign Method

This member function is used to obtain the flag to determine if multi day text align mode is on.

virtual BOOL IsMultyDayTextAlign();
Returns

A BOOL. TRUE if multi day text align mode is on. FALSE otherwise.

Remarks

Multi day text align mode means that all event items align to the center.

Body Source
BOOL CXTPCalendarViewEvent::IsMultyDayTextAlign() {
    return m_bMultyDayTextAlign;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::IsSelected Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::IsSelected Method

Call this member function to determine if the given event view is selected.

virtual BOOL IsSelected() const;
Returns

A BOOL. TRUE if the event view is selected. FALSE otherwise.

See Also

SetSelected(bSet)

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::IsShowingToolTip Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::IsShowingToolTip Method

Call this member function to determine if the event's tooltip is visible.

virtual BOOL IsShowingToolTip();
Returns

A BOOL. TRUE if the subject is visible. FALSE otherwise.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::IsTextOutOfBorders Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::IsTextOutOfBorders Method

This member function is used to determine if the text size exceeds the event view bounds.

virtual BOOL IsTextOutOfBorders();
Returns

A BOOL. TRUE if text size exceeds the event view bounds. FALSE otherwise.

Body Source
BOOL CXTPCalendarViewEvent::IsTextOutOfBorders() {
    return m_bTextOutOfBorders;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::IsVisible Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::IsVisible Method

Call this member function to determine if this event view is visible on the screen.

virtual BOOL IsVisible() = 0;
Returns

A BOOL. TRUE if the event view is visible. FALSE otherwise.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::KillTimer Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::KillTimer Method

This member function is used to destroy a timer event.

virtual void KillTimer(
    UINT uTimerID
);
Parameters

uTimerID
A UINT that specifies the identifier of the timer.

Returns

For the derived classes. This member function should return TRUE if successful. FALSE otherwise.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::OnBeforeDestroy Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::OnBeforeDestroy Method

Called by the framework before the destroy() function is called.

virtual void OnBeforeDestroy();
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::OnMouseMove Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::OnMouseMove Method

This member function is used to process mouse movement events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that indicates whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarViewGroup when the user moves the mouse cursor or stylus.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::OnPostAdjustLayout Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::OnPostAdjustLayout Method

This member function is used to perform additional adjustments in some kinds of views.

virtual void OnPostAdjustLayout();
Remarks

Call this member function to perform additional adjustments after all adjustment activities are completed.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::OnTimer Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::OnTimer Method

The framework calls this member function after each interval specified in the SetTimer member function.

virtual BOOL OnTimer(
    UINT_PTR uTimerID
);
Parameters

uTimerID
A UINT that specifies the identifier of the timer.

Returns

A BOOL. TRUE if successful. FALSE otherwise.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::SetMultiDayEvent_MasterSlave Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::SetMultiDayEvent_MasterSlave Method

This member function is used to set the multi day event Master/Slave state.

virtual void SetMultiDayEvent_MasterSlave(
    BOOL bMaster,
    CXTPCalendarViewEvent* pMasterView
);
Parameters

bMaster
A BOOL. Used to indicate Master or Slave state. TRUE if in the Master state. FALSE if in the Slave state.
pMasterView
A CXTPCalendarViewEvent pointer to the Master event view object.

Remarks

Master/Slave states are used to draw a multi day event. Such event are drawn not as a few events for a few days, but as one big event for a few days, or a few big events for a few days. For this purposes, the first event view in the chain is marked as Master and other events views in this chain are marked as Slave. Event view's chain is the set of events views which can be drawn continuously in the one row. On adjust layout process width of the Master event view rect is extended to cover last Slave event view rect in the chain and only master event view are drawn because it covers Slave evens views too. Slave events views look hidden and they are used for adjusting process (to reserve place on the screen and for other purposes).One multi day event can have few Master events. This depends on screen positions of days event parts.

See Also

AddMultiDayEvent_Slave

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::SetSelected Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::SetSelected Method

This member function is used to set the day view as select or unselected.

virtual void SetSelected(
    BOOL bSet = TRUE
);
Parameters

bSet
A BOOL. If TRUE, then set the flag as selected. Otherwise, set the flag as unselected.

See Also

IsSelected()

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::SetTextOutOfBorders Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::SetTextOutOfBorders Method

This member function is used to set a flag to determine if the text size exceeds the event view bounds.

virtual void SetTextOutOfBorders(
    BOOL bOutOfBorders
);
Parameters

bOutOfBorders
A BOOL. TRUE if the text is out of the borders. FALSE otherwise.

Body Source
void CXTPCalendarViewEvent::SetTextOutOfBorders(BOOL bOutOfBorders) {
    m_bTextOutOfBorders = bOutOfBorders;
}
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::SetTimer Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::SetTimer Method

This member function is used to create a timer event.

virtual UINT SetTimer(
    UINT uTimeOut_ms
);
Parameters

uTimeOut_ms
A UINT that specifies the duration of the timer in milliseconds.

Returns

The identifier of the timer.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::ShowToolTip Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::ShowToolTip Method

This member function is used to show a ToolTip rectangle.

virtual void ShowToolTip();
Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent::StartEditSubject Method

CXTPCalendarViewEvent Methods, CXTPCalendarViewEvent Class
CXTPCalendarViewEvent::StartEditSubject Method

This member function is used to create and to show the subject editor.

virtual CXTPCalendarViewEvent* StartEditSubject();
Returns

A pointer to a CXTPCalendarViewEvent object for which editor is created.

Remarks

Subject is created only for the Master event if the event is a multi day event. If this member function is called for a slave event, then the editing process is passed to the master event.

Group

CXTPCalendarViewEvent Methods


CXTPCalendarViewEvent Constructors

CXTPCalendarViewEvent Class, Legend, Public Methods
CXTPCalendarViewEvent Constructors
Class

CXTPCalendarViewEvent Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEvent | Default object constructor.


CXTPCalendarViewEvent::CXTPCalendarViewEvent Constructor

CXTPCalendarViewEvent Constructors, CXTPCalendarViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::CXTPCalendarViewEvent Constructor

Default object constructor.

CXTPCalendarViewEvent(
    CXTPCalendarEvent* pEvent,
    CXTPCalendarViewGroup* pViewGroup
);
Parameters

pEvent
A pointer to a CXTPCalendarEvent object.
pViewGroup
A pointer to a CXTPCalendarViewGroup object.

See Also

~CXTPCalendarViewEvent()

Group

CXTPCalendarViewEvent Constructors


CXTPCalendarViewEvent Destructors

CXTPCalendarViewEvent Class, Legend, Public Methods
CXTPCalendarViewEvent Destructors
Class

CXTPCalendarViewEvent Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewEvent | Default class destructor.


CXTPCalendarViewEvent::~CXTPCalendarViewEvent Destructor

CXTPCalendarViewEvent Destructors, CXTPCalendarViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvent::~CXTPCalendarViewEvent Destructor

Default class destructor.

virtual ~CXTPCalendarViewEvent();
Group

CXTPCalendarViewEvent Destructors


CXTPCalendarViewEvents Class

XTPCalendarViewEvent.h, Classes, Legend, Members, Topics, CXTPCalendarViewEvents Methods, CXTPCalendarViewEvents Constructors, CXTPCalendarViewEvents Destructors, CXTPCalendarViewEvents Constructors, CXTPCalendarViewEvents Destructors, CXTPCalendarViewEvents Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvents Class

This class used as collection of Event View object.

Class Hierarchy

class CXTPCalendarViewEvents : public CXTPCalendarPtrCollectionT<CXTPCalendarViewEvent>;
File

XTPCalendarViewEvent.h

See Also

CXTPCalendarPtrCollectionT

Group

Classes

Legend
Method
virtual
CXTPCalendarViewEvents Constructors
CXTPCalendarViewEvents Constructors | Description
CXTPCalendarViewEvents | Default class constructor.
CXTPCalendarViewEvents Destructors
CXTPCalendarViewEvents Destructors | Description
~CXTPCalendarViewEvents | Default class destructor.
CXTPCalendarViewEvents Methods
CXTPCalendarViewEvents Methods | Description
Find | This member function finds first event view index in the collection using event object.
Remove | This member function finds all event views for event object and removes them from the array.


CXTPCalendarViewEvents Methods

CXTPCalendarViewEvents Class, Legend, Public Methods
CXTPCalendarViewEvents Methods
Class

CXTPCalendarViewEvents Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Find | This member function finds first event view index in the collection using event object.
Remove | This member function finds all event views for event object and removes them from the array.


CXTPCalendarViewEvents::Find Method

CXTPCalendarViewEvents Methods, CXTPCalendarViewEvents Class
CXTPCalendarViewEvents::Find Method

This member function finds first event view index in the collection using event object.

virtual int Find(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
A pointer to a CXTPCalendarEvent object.

Returns

-1 if event view is not found, otherwise an integer index that is greater than or equal to 0 and less than the value returned by GetCount.

Group

CXTPCalendarViewEvents Methods


CXTPCalendarViewEvents::Remove Method

CXTPCalendarViewEvents Methods, CXTPCalendarViewEvents Class
CXTPCalendarViewEvents::Remove Method

This member function finds all event views for event object and removes them from the array.

virtual void Remove(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
A pointer to a CXTPCalendarEvent object.

Group

CXTPCalendarViewEvents Methods


CXTPCalendarViewEvents Constructors

CXTPCalendarViewEvents Class, Legend, Public Methods
CXTPCalendarViewEvents Constructors
Class

CXTPCalendarViewEvents Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEvents | Default class constructor.


CXTPCalendarViewEvents::CXTPCalendarViewEvents Constructor

CXTPCalendarViewEvents Constructors, CXTPCalendarViewEvents Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvents::CXTPCalendarViewEvents Constructor

Default class constructor.

CXTPCalendarViewEvents();
Group

CXTPCalendarViewEvents Constructors


CXTPCalendarViewEvents Destructors

CXTPCalendarViewEvents Class, Legend, Public Methods
CXTPCalendarViewEvents Destructors
Class

CXTPCalendarViewEvents Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewEvents | Default class destructor.


CXTPCalendarViewEvents::~CXTPCalendarViewEvents Destructor

CXTPCalendarViewEvents Destructors, CXTPCalendarViewEvents Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEvents::~CXTPCalendarViewEvents Destructor

Default class destructor.

virtual ~CXTPCalendarViewEvents();
Group

CXTPCalendarViewEvents Destructors


CXTPCalendarViewEventSubjectEditor Class

XTPCalendarViewEvent.h, Classes, Legend, Members, Topics, CXTPCalendarViewEventSubjectEditor Data Members, CXTPCalendarViewEventSubjectEditor Constructors, CXTPCalendarViewEventSubjectEditor Destructors, CXTPCalendarViewEventSubjectEditor Constructors, CXTPCalendarViewEventSubjectEditor Data Members, CXTPCalendarViewEventSubjectEditor Destructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor Class

This class is used to edit event subject.

Class Hierarchy

class CXTPCalendarViewEventSubjectEditor : public CEdit;
File

XTPCalendarViewEvent.h

Remarks

All massages received by this window are sent to the parent calendar control before they are processed. Some of them are handled by parent calendar control object.

See Also

CXTPCalendarControl::OnWndMsg_Children()

Group

Classes

Legend
Data Member
protected
Constructor
virtual
CXTPCalendarViewEventSubjectEditor Constructors
CXTPCalendarViewEventSubjectEditor Constructors | Description
CXTPCalendarViewEventSubjectEditor | Default object constructor.
CXTPCalendarViewEventSubjectEditor Data Members
CXTPCalendarViewEventSubjectEditor Data Members | Description
m_pOwner | Stored pointer to the owner calendar control object.
CXTPCalendarViewEventSubjectEditor Destructors
CXTPCalendarViewEventSubjectEditor Destructors | Description
~CXTPCalendarViewEventSubjectEditor | Default class destructor.


CXTPCalendarViewEventSubjectEditor Data Members

CXTPCalendarViewEventSubjectEditor Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor Data Members
Class

CXTPCalendarViewEventSubjectEditor Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pOwner | Stored pointer to the owner calendar control object.


CXTPCalendarViewEventSubjectEditor::m_pOwner Data Member

CXTPCalendarViewEventSubjectEditor Data Members, CXTPCalendarViewEventSubjectEditor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor::m_pOwner Data Member

Stored pointer to the owner calendar control object.

CXTPCalendarControl* m_pOwner;
Group

CXTPCalendarViewEventSubjectEditor Data Members


CXTPCalendarViewEventSubjectEditor Constructors

CXTPCalendarViewEventSubjectEditor Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor Constructors
Class

CXTPCalendarViewEventSubjectEditor Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEventSubjectEditor | Default object constructor.


CXTPCalendarViewEventSubjectEditor::CXTPCalendarViewEventSubjectEditor Constructor

CXTPCalendarViewEventSubjectEditor Constructors, CXTPCalendarViewEventSubjectEditor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor::CXTPCalendarViewEventSubjectEditor Constructor

Default object constructor.

CXTPCalendarViewEventSubjectEditor(
    CXTPCalendarControl* pOwner
);
Parameters

pOwner
A pointer to a owner calendar control object.

See Also

~CXTPCalendarViewEventSubjectEditor()

Group

CXTPCalendarViewEventSubjectEditor Constructors


CXTPCalendarViewEventSubjectEditor Destructors

CXTPCalendarViewEventSubjectEditor Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor Destructors
Class

CXTPCalendarViewEventSubjectEditor Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewEventSubjectEditor | Default class destructor.


CXTPCalendarViewEventSubjectEditor::~CXTPCalendarViewEventSubjectEditor Destructor

CXTPCalendarViewEventSubjectEditor Destructors, CXTPCalendarViewEventSubjectEditor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor::~CXTPCalendarViewEventSubjectEditor Destructor

Default class destructor.

virtual ~CXTPCalendarViewEventSubjectEditor();
Group

CXTPCalendarViewEventSubjectEditor Destructors


CXTPCalendarViewEventSubjectEditor2007 Class

XTPCalendarThemeOffice2007.h, Classes, Legend, Members, Topics, CXTPCalendarViewEventSubjectEditor2007 Data Members, CXTPCalendarViewEventSubjectEditor2007 Constructors, CXTPCalendarViewEventSubjectEditor2007 Destructors, CXTPCalendarViewEventSubjectEditor2007 Constructors, CXTPCalendarViewEventSubjectEditor2007 Data Members, CXTPCalendarViewEventSubjectEditor2007 Destructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007 Class

This class is used to edit event subject in Office 2007 Theme.

Class Hierarchy

class CXTPCalendarViewEventSubjectEditor2007 : public CXTPCalendarViewEventSubjectEditor;
File

XTPCalendarThemeOffice2007.h

Remarks

This class is derived from CXTPCalendarViewEventSubjectEditor and draw editor background in Office 2007 Theme event object style or use no background (transparent background).

See Also

CXTPCalendarViewEventSubjectEditor

Group

Classes

Legend
Data Member
protected
Constructor
virtual
CXTPCalendarViewEventSubjectEditor2007 Constructors
CXTPCalendarViewEventSubjectEditor2007 Constructors | Description
CXTPCalendarViewEventSubjectEditor2007 | Default object constructor.
CXTPCalendarViewEventSubjectEditor2007 Data Members
CXTPCalendarViewEventSubjectEditor2007 Data Members | Description
m_grclrBk | Subject Editor background color (or gradient colors).
m_pTheme2007 | Stored pointer to the owner theme.
m_pViewEvent | Stored pointer to the editing event object.
CXTPCalendarViewEventSubjectEditor2007 Destructors
CXTPCalendarViewEventSubjectEditor2007 Destructors | Description
~CXTPCalendarViewEventSubjectEditor2007 | Default class destructor.


CXTPCalendarViewEventSubjectEditor2007 Data Members

CXTPCalendarViewEventSubjectEditor2007 Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007 Data Members
Class

CXTPCalendarViewEventSubjectEditor2007 Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_grclrBk | Subject Editor background color (or gradient colors).
m_pTheme2007 | Stored pointer to the owner theme.
m_pViewEvent | Stored pointer to the editing event object.


CXTPCalendarViewEventSubjectEditor2007::m_grclrBk Data Member

CXTPCalendarViewEventSubjectEditor2007 Data Members, CXTPCalendarViewEventSubjectEditor2007 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007::m_grclrBk Data Member

Subject Editor background color (or gradient colors).

CXTPPaintManagerColorGradient m_grclrBk;
Group

CXTPCalendarViewEventSubjectEditor2007 Data Members


CXTPCalendarViewEventSubjectEditor2007::m_pTheme2007 Data Member

CXTPCalendarViewEventSubjectEditor2007 Data Members, CXTPCalendarViewEventSubjectEditor2007 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007::m_pTheme2007 Data Member

Stored pointer to the owner theme.

CXTPCalendarThemeOffice2007* m_pTheme2007;
Group

CXTPCalendarViewEventSubjectEditor2007 Data Members


CXTPCalendarViewEventSubjectEditor2007::m_pViewEvent Data Member

CXTPCalendarViewEventSubjectEditor2007 Data Members, CXTPCalendarViewEventSubjectEditor2007 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007::m_pViewEvent Data Member

Stored pointer to the editing event object.

CXTPCalendarViewEvent* m_pViewEvent;
Group

CXTPCalendarViewEventSubjectEditor2007 Data Members


CXTPCalendarViewEventSubjectEditor2007 Constructors

CXTPCalendarViewEventSubjectEditor2007 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007 Constructors
Class

CXTPCalendarViewEventSubjectEditor2007 Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEventSubjectEditor2007 | Default object constructor.


CXTPCalendarViewEventSubjectEditor2007::CXTPCalendarViewEventSubjectEditor2007 Constructor

CXTPCalendarViewEventSubjectEditor2007 Constructors, CXTPCalendarViewEventSubjectEditor2007 Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007::CXTPCalendarViewEventSubjectEditor2007 Constructor

Default object constructor.

CXTPCalendarViewEventSubjectEditor2007(
    CXTPCalendarControl* pOwner,
    CXTPCalendarViewEvent* pViewEvent,
    CXTPCalendarThemeOffice2007* pTheme2007
);
Parameters

pOwner
A pointer to an owner calendar control object.
pViewEvent
A pointer to an editing event view object.
pTheme2007
A pointer to an owner theme.

See Also

~CXTPCalendarViewEventSubjectEditor2007()

Group

CXTPCalendarViewEventSubjectEditor2007 Constructors


CXTPCalendarViewEventSubjectEditor2007 Destructors

CXTPCalendarViewEventSubjectEditor2007 Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007 Destructors
Class

CXTPCalendarViewEventSubjectEditor2007 Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewEventSubjectEditor2007 | Default class destructor.


CXTPCalendarViewEventSubjectEditor2007::~CXTPCalendarViewEventSubjectEditor2007 Destructor

CXTPCalendarViewEventSubjectEditor2007 Destructors, CXTPCalendarViewEventSubjectEditor2007 Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventSubjectEditor2007::~CXTPCalendarViewEventSubjectEditor2007 Destructor

Default class destructor.

virtual ~CXTPCalendarViewEventSubjectEditor2007();
Group

CXTPCalendarViewEventSubjectEditor2007 Destructors


CXTPCalendarViewEventT Template

XTPCalendarViewEvent.h, Classes, Legend, Members, Topics, CXTPCalendarViewEventT Methods, CXTPCalendarViewEventT Constructors, CXTPCalendarViewEventT Destructors, CXTPCalendarViewEventT Constructors, CXTPCalendarViewEventT Destructors, CXTPCalendarViewEventT Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventT Template

This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.

Class Hierarchy

template <class _TViewGroup, class _THitTest>
class CXTPCalendarViewEventT : public CXTPCalendarViewEvent;
File

XTPCalendarViewEvent.h

Remarks

This class template customizes, overrides and implements some functionality for the CXTPCalendarViewEvent base class. It is used as a part of the calendar control framework to build ViewEvent layer of View->DayView->ViewEvent typed objects hierarchy. These are the template parameters: _TViewGroup - Type of View Day objects stored in View _THitTest - Type of HitTest struct, used as parameter in the member functions.

All of the above parameters are required.

See Also

CXTPCalendarViewEvent

Group

Classes

Legend
Method
virtual
abstract
CXTPCalendarViewEventT Constructors
CXTPCalendarViewEventT Constructors | Description
CXTPCalendarViewEventT | Default object constructor.
CXTPCalendarViewEventT Destructors
CXTPCalendarViewEventT Destructors | Description
~CXTPCalendarViewEventT | Default class destructor.
CXTPCalendarViewEventT Methods
CXTPCalendarViewEventT Methods | Description
GetViewGroup | This member function is used to obtain a pointer to a DayView object.
GetViewGroup_ | This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayView object.
HitTest | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.
HitTestEx | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a _THitTest template parameter.


CXTPCalendarViewEventT Methods

CXTPCalendarViewEventT Template, Legend, Public Methods
CXTPCalendarViewEventT Methods
Template

CXTPCalendarViewEventT Template

Legend
Method
virtual
abstract
Public Methods
Public Methods
Public Method | Description
GetViewGroup | This member function is used to obtain a pointer to a DayView object.
GetViewGroup_ | This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayView object.
HitTest | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.
HitTestEx | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a _THitTest template parameter.


CXTPCalendarViewEventT::GetViewGroup Method

CXTPCalendarViewEventT Methods, CXTPCalendarViewEventT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventT::GetViewGroup Method

This member function is used to obtain a pointer to a DayView object.

_TViewGroup* GetViewGroup() const;
Returns

A pointer to a DayView object, the type of the returned pointer is determined by the _TViewGroup template parameter.

Remarks

Call this member function to obtain a pointer to a DayView object which stores the ViewEvent. The _TViewGroup template parameter is used to determine the type of the returned pointer.

See Also

GetViewGroup_()

Body Source
_TViewGroup* GetViewGroup() const{
    ASSERT(this);
    return this ? m_pViewGroup : NULL;
}
Group

CXTPCalendarViewEventT Methods


CXTPCalendarViewEventT::GetViewGroup_ Method

CXTPCalendarViewEventT Methods, CXTPCalendarViewEventT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventT::GetViewGroup_ Method

This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayView object.

virtual CXTPCalendarViewGroup* GetViewGroup_() const;
Returns

A pointer to a base CXTPCalendarViewGroup object.

Remarks

Call this member function to obtain a pointer to a DayView object which stores the ViewEvent.

See Also

GetViewGroup()

Body Source
virtual CXTPCalendarViewGroup* GetViewGroup_() const {
    ASSERT(this);
    return this ? (CXTPCalendarViewGroup*)m_pViewGroup : NULL;
}
Group

CXTPCalendarViewEventT Methods


CXTPCalendarViewEventT::HitTest Method

CXTPCalendarViewEventT Methods, CXTPCalendarViewEventT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventT::HitTest Method

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.

virtual BOOL HitTest(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO* pHitTest
);
Parameters

pt
A CPoint that contains the coordinates of the point to test.
pHitTest
A pointer to a XTP_CALENDAR_HITTESTINFO structure that contains information about the point to test.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

See Also

XTP_CALENDAR_HITTESTINFO

Body Source
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest)
{
    _THitTest hitInfo;
    BOOL bRes = HitTestEx(pt, &hitInfo);
    if (bRes && pHitTest) {
        *pHitTest = (XTP_CALENDAR_HITTESTINFO)hitInfo;
    }
    return bRes;
}
Group

CXTPCalendarViewEventT Methods


CXTPCalendarViewEventT::HitTestEx Method

CXTPCalendarViewEventT Methods, CXTPCalendarViewEventT Template, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventT::HitTestEx Method

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a _THitTest template parameter.

virtual BOOL HitTestEx(
    CPoint pt,
    _THitTest* pHitTest
) = 0;
Parameters

pt
A CPoint that contains the coordinates of the point to test.
pHitTest
A pointer to a _THitTest. Template parameter specifies the type of HitTest info structure.

Returns

TRUE if item is found. FALSE otherwise.

See Also

XTP_CALENDAR_HITTESTINFO

Group

CXTPCalendarViewEventT Methods


CXTPCalendarViewEventT Constructors

CXTPCalendarViewEventT Template, Legend, Public Methods
CXTPCalendarViewEventT Constructors
Template

CXTPCalendarViewEventT Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEventT | Default object constructor.


CXTPCalendarViewEventT::CXTPCalendarViewEventT Constructor

CXTPCalendarViewEventT Constructors, CXTPCalendarViewEventT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventT::CXTPCalendarViewEventT Constructor

Default object constructor.

CXTPCalendarViewEventT(
    CXTPCalendarEvent* pEvent,
    _TViewGroup* pViewGroup
);
Parameters

pEvent
Pointer to CXTPCalendarEvent object.
pViewGroup
Template parameter specifies type of VIew Day object.

See Also

~CXTPCalendarViewEventT()

Body Source
CXTPCalendarViewEventT(CXTPCalendarEvent* pEvent, _TViewGroup* pViewGroup) :
    CXTPCalendarViewEvent(pEvent, (CXTPCalendarViewGroup*)pViewGroup) {
        m_pViewGroup = pViewGroup;
}
Group

CXTPCalendarViewEventT Constructors


CXTPCalendarViewEventT Destructors

CXTPCalendarViewEventT Template, Legend, Public Methods
CXTPCalendarViewEventT Destructors
Template

CXTPCalendarViewEventT Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewEventT | Default class destructor.


CXTPCalendarViewEventT::~CXTPCalendarViewEventT Destructor

CXTPCalendarViewEventT Destructors, CXTPCalendarViewEventT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewEventT::~CXTPCalendarViewEventT Destructor

Default class destructor.

virtual ~CXTPCalendarViewEventT();
Body Source
virtual ~CXTPCalendarViewEventT() {
}
Group

CXTPCalendarViewEventT Destructors


CXTPCalendarViewGroup Class

XTPCalendarViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarViewGroup Data Members, CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Constructors, CXTPCalendarViewGroup Destructors, CXTPCalendarViewGroup Nested Types, CXTPCalendarViewGroup Constructors, CXTPCalendarViewGroup Data Members, CXTPCalendarViewGroup Destructors, CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup Class

Regular schema:

  • CalendarView consists of CalendarView(s)Day
  • CalendarViewDay consists of CalendarView(s)Resource
  • CalendarViewGroup contains CalendarView(s)Event

ViewGroup draws a single resource depending on the type of parent day view.

Class Hierarchy

class CXTPCalendarViewGroup : public CXTPCalendarWMHandler;
File

XTPCalendarViewDay.h

Group

Classes

Legend
Data Member
protected
Method
virtual
abstract
CXTPCalendarViewGroup Constructors
CXTPCalendarViewGroup Constructors | Description
CXTPCalendarViewGroup | Default object constructor. Construct CXTPCalendarViewGroup object.
CXTPCalendarViewGroup Data Members
CXTPCalendarViewGroup Data Members | Description
m_Layout | This group view client coordinates.
m_pResources | An associated resource object.
CXTPCalendarViewGroup Destructors
CXTPCalendarViewGroup Destructors | Description
~CXTPCalendarViewGroup | Default class destructor.
CXTPCalendarViewGroup Methods
CXTPCalendarViewGroup Methods | Description
AddResource | Adds a new Resource object into the collection of resources for this Group View.
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
Draw | This member function is used to draw the view contents using the specified device context.
ExchangeEventPlace | This member function is used to exchange event view positions.
GetCaption | This member function is used to obtain a group's view caption.
GetChildHandlerAt | Call this method to get a event view object at the specified numeric index.
GetChildHandlersCount | This member function is used to obtain the number of event views elements in this Group View.
GetDataProvider | Returns data provider for this view group.
GetGroupIndex | This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.
GetHeaderRect | Call this member function to obtain the group's header rectangle area.
GetRect | Call this member function to obtain the group's rectangle area.
GetResources | Obtain a pointer to collection of Calendar Resources.
GetScheduleID | Returns default Schedule ID - the first existing one.
GetTooltipRect | Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position
GetViewDay_ | Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
GetViewEvent_ | Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
GetViewEventByEvent_ | Call this member function to obtain a pointer a CXTPCalendarViewEvent object that is identified by the corresponding event object.
GetViewEventByPlace_ | Call this member function to obtain an event view object identified by its event place number.
GetViewEventsCount | Call this member function to obtain the number of event views in the day view collection.
HitTest | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
KillTimer | This member function is used to destroy a timer event.
OnPrePopulate | This member function is used to allow some customization before show events.
Populate | This member function is used to populate the view with data for all items contained in the view.
SetResources | Assigns a new Resources collection to this Group View.
SetTimer | This member function is used to create a timer event.
CXTPCalendarViewGroup Nested Types
CXTPCalendarViewGroup Nested Types | Description
TBase | Base class shortcut


CXTPCalendarViewGroup Data Members

CXTPCalendarViewGroup Class, Legend, Protected Data Members
CXTPCalendarViewGroup Data Members
Class

CXTPCalendarViewGroup Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_Layout | This group view client coordinates.
m_pResources | An associated resource object.


CXTPCalendarViewGroup::m_Layout Data Member

CXTPCalendarViewGroup Data Members, CXTPCalendarViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::m_Layout Data Member

This group view client coordinates.

XTP_VIEW_GROUP_LAYOUT m_Layout;
Group

CXTPCalendarViewGroup Data Members


CXTPCalendarViewGroup::m_pResources Data Member

CXTPCalendarViewGroup Data Members, CXTPCalendarViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::m_pResources Data Member

An associated resource object.

CXTPCalendarResources* m_pResources;
Group

CXTPCalendarViewGroup Data Members


CXTPCalendarViewGroup Methods

CXTPCalendarViewGroup Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup Methods
Class

CXTPCalendarViewGroup Class

Legend
Method
virtual
abstract
protected
Protected Methods
Protected Methods
Protected Method | Description
ExchangeEventPlace | This member function is used to exchange event view positions.
KillTimer | This member function is used to destroy a timer event.
OnPrePopulate | This member function is used to allow some customization before show events.
SetTimer | This member function is used to create a timer event.
Public Methods
Public Methods
Public Method | Description
AddResource | Adds a new Resource object into the collection of resources for this Group View.
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
Draw | This member function is used to draw the view contents using the specified device context.
GetCaption | This member function is used to obtain a group's view caption.
GetChildHandlerAt | Call this method to get a event view object at the specified numeric index.
GetChildHandlersCount | This member function is used to obtain the number of event views elements in this Group View.
GetDataProvider | Returns data provider for this view group.
GetGroupIndex | This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.
GetHeaderRect | Call this member function to obtain the group's header rectangle area.
GetRect | Call this member function to obtain the group's rectangle area.
GetResources | Obtain a pointer to collection of Calendar Resources.
GetScheduleID | Returns default Schedule ID - the first existing one.
GetTooltipRect | Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position
GetViewDay_ | Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
GetViewEvent_ | Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
GetViewEventByEvent_ | Call this member function to obtain a pointer a CXTPCalendarViewEvent object that is identified by the corresponding event object.
GetViewEventByPlace_ | Call this member function to obtain an event view object identified by its event place number.
GetViewEventsCount | Call this member function to obtain the number of event views in the day view collection.
HitTest | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
Populate | This member function is used to populate the view with data for all items contained in the view.
SetResources | Assigns a new Resources collection to this Group View.


CXTPCalendarViewGroup::AddResource Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::AddResource Method

Adds a new Resource object into the collection of resources for this Group View.

virtual void AddResource(
    CXTPCalendarResource* pResource,
    BOOL bWithAddRef
);
Parameters

pResource
Pointer to the added CXTPCalendarResource object.
bWithAddRef
Set this value to TRUE to increment the reference count of the inserted object, FALSE to insert object without incrementing reference count.

See Also

CXTPCalendarResources::Add

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::AdjustLayout Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcGroup
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcGroup
);
Parameters

pDC
Pointer to a valid device context.
rcGroup
A CRect object that contains the rectangle coordinates that are used to draw the view.

Remarks

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::Draw Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::Draw Method

This member function is used to draw the view contents using the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
A pointer to a valid device context.

Remarks

Call AdjustLayout() before calling Draw().

See Also

AdjustLayout(CRect rcGroup)

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::ExchangeEventPlace Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::ExchangeEventPlace Method

This member function is used to exchange event view positions.

virtual void ExchangeEventPlace(
    CXTPCalendarViewEvent* pViewEvent,
    int nNewPlace
);
Parameters

pViewEvent
A pointer to a CXTPCalendarViewEvent object.
nNewPlace
An int that contains the new event view position.

Remarks

Each event view has a unique position number for the day. In the simple case, this is the row number used to draw the event view. This function is used to avoid duplicating position numbers.

See Also

CXTPCalendarViewEvent::ChangeEventPlace, CXTPCalendarViewEvent::GetEventPlaceNumber, CXTPCalendarViewEvent::AddMultiDayEvent_Slave, CXTPCalendarViewEvent::AdjustLayout

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetCaption Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::GetCaption Method

This member function is used to obtain a group's view caption.

virtual CString GetCaption();
Returns

A CString object that contains the group's view caption.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetChildHandlerAt Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetChildHandlerAt Method

Call this method to get a event view object at the specified numeric index.

virtual CXTPCalendarWMHandler* GetChildHandlerAt(
    int nIndex
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns

The pointer to the descendant of CXTPCalendarWMHandler element currently at this index.

Remarks

Returns the array element at the specified index.

See Also

GetChildHandlersCount

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetChildHandlersCount Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetChildHandlersCount Method

This member function is used to obtain the number of event views elements in this Group View.

virtual int GetChildHandlersCount();
Returns

A count of event views elements.

Remarks

Call this method to retrieve the number of elements in the array of event views inside this Group View. Because indexes are zero-based, the size is 1 greater than the largest index.

See Also

GetChildHandlerAt

Body Source
int CXTPCalendarViewGroup::GetChildHandlersCount() {
    return GetViewEventsCount();
}
Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetDataProvider Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetDataProvider Method

Returns data provider for this view group.

virtual CXTPCalendarData* GetDataProvider();
Returns

A pointer to the data provider object if it was previously set; otherwise, returns NULL.

See Also

CXTPCalendarData overview

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetGroupIndex Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::GetGroupIndex Method

This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.

virtual int GetGroupIndex() const;
Returns

An int that contains the index of the "this" day in the Calendar Day View.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetHeaderRect Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetHeaderRect Method

Call this member function to obtain the group's header rectangle area.

virtual CRect GetHeaderRect();
Returns

A CRect that contains the rectangle coordinates of the group view header part in client coordinates of the parent's CXTPDatePickerControl object.

See Also

GetRect

Body Source
virtual CRect GetHeaderRect()
{
    return m_Layout.m_rcGroupHeader;
}
Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetRect Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetRect Method

Call this member function to obtain the group's rectangle area.

virtual CRect GetRect();
Returns

A CRect that contains the rectangle coordinates of the group view in client coordinates of the parent's CXTPDatePickerControl object.

See Also

GetHeaderRect

Body Source
virtual CRect GetRect()
{
    return m_Layout.m_rcGroup;
}
Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetResources Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetResources Method

Obtain a pointer to collection of Calendar Resources.

virtual CXTPCalendarResources* GetResources();
Returns

CXTPCalendarResources pointer.

Remarks

Use this method to retrieve a pointer to the Calendar Resources collection of this Group View.

See Also

CXTPCalendarResources overview, SetResources, AddResource

Body Source
CXTPCalendarResources* CXTPCalendarViewGroup::GetResources() {
    return m_pResources;
}
Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetScheduleID Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::GetScheduleID Method

Returns default Schedule ID - the first existing one.

virtual UINT GetScheduleID();
Returns

The first existing Schedule ID or XTP_CALENDAR_UNKNOWN_SCHEDULE_ID if not found.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetTooltipRect Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::GetTooltipRect Method

Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment"). Tooltip rectangle is calculated basing on the current mouse position

virtual CRect GetTooltipRect(
    const CPoint& ptHit,
    const XTP_CALENDAR_HITTESTINFO& hitInfo
);
Returns

A CRect object with relative coordinates of the tooltip.

Remarks

This member function always returns an empty rectangle. Actual tooltip rectangle is calculated by ViewGroups of specific views (currently DayView and MonthView are supported).

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetViewDay_ Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::GetViewDay_ Method

Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.

virtual CXTPCalendarViewDay* GetViewDay_() const = 0;
Returns

A pointer to the CXTPCalendarViewDay object.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetViewEvent_ Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetViewEvent_ Method

Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.

virtual CXTPCalendarViewEvent* GetViewEvent_(
    int nIndex
) = 0;
Parameters

nIndex
An int that contains the event view index in the day view collection.

Returns

A pointer to a CXTPCalendarViewEvent object.

Remarks

Index number starts with 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

See Also

GetViewEventsCount()

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetViewEventByEvent_ Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetViewEventByEvent_ Method

Call this member function to obtain a pointer a CXTPCalendarViewEvent object that is identified by the corresponding event object.

virtual CXTPCalendarViewEvent* GetViewEventByEvent_(
    CXTPCalendarEvent* pEvent
);
Parameters

pEvent
Pointer to a CXTPCalendarEvent object.

Returns

A pointer to a CXTPCalendarViewEvent object.

See Also

CXTPCalendarEvent, CXTPCalendarViewEvent

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetViewEventByPlace_ Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::GetViewEventByPlace_ Method

Call this member function to obtain an event view object identified by its event place number.

virtual CXTPCalendarViewEvent* GetViewEventByPlace_(
    int nEventPlace
);
Parameters

nEventPlace
An int that contains the ViewEvent place identifier.

Returns

A pointer to a CXTPCalendarViewEvent object.

See Also

CXTPCalendarEvent, CXTPCalendarViewEvent

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::GetViewEventsCount Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::GetViewEventsCount Method

Call this member function to obtain the number of event views in the day view collection.

virtual int GetViewEventsCount() = 0;
Returns

An int that contains the number of event views.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::HitTest Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::HitTest Method

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.

virtual BOOL HitTest(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO* pHitTest
) = 0;
Parameters

pt
A CPoint object that contains the coordinates of the point to test.
pHitTest
A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains information about the point to test.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

See Also

XTP_CALENDAR_HITTESTINFO

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::KillTimer Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::KillTimer Method

This member function is used to destroy a timer event.

virtual void KillTimer(
    UINT uTimerID
);
Parameters

uTimerID
A UINT that specifies the identifier of the timer.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::OnPrePopulate Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::OnPrePopulate Method

This member function is used to allow some customization before show events.

virtual void OnPrePopulate(
    CXTPCalendarEvents* pEvents
);
Parameters

pEvents
A pointer to events array to draw.

Remarks

Default implementation send XTP_NC_CALENDAR_PREPOPULATE notification.

See Also

XTP_NC_CALENDAR_PREPOPULATE

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::Populate Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::Populate Method

This member function is used to populate the view with data for all items contained in the view.

virtual void Populate(
    COleDateTime dtDayDate
) = 0;
Parameters

dtDayDate
A COleDateTime object that contains the day's date.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::SetResources Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::SetResources Method

Assigns a new Resources collection to this Group View.

virtual void SetResources(
    CXTPCalendarResources* pResources
);
Parameters

pResources
Pointer to the new Resources collection to be copied into internal collections of this Group View.

See Also

GetResources, AddResource

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup::SetTimer Method

CXTPCalendarViewGroup Methods, CXTPCalendarViewGroup Class
CXTPCalendarViewGroup::SetTimer Method

This member function is used to create a timer event.

virtual UINT SetTimer(
    UINT uTimeOut_ms
);
Parameters

uTimeOut_ms
A UINT that contains the duration of the timer in milliseconds.

Returns

A UINT that is the identifier of the timer.

Group

CXTPCalendarViewGroup Methods


CXTPCalendarViewGroup Constructors

CXTPCalendarViewGroup Class, Legend, Public Methods
CXTPCalendarViewGroup Constructors
Class

CXTPCalendarViewGroup Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewGroup | Default object constructor. Construct CXTPCalendarViewGroup object.


CXTPCalendarViewGroup::CXTPCalendarViewGroup Constructor

CXTPCalendarViewGroup Constructors, CXTPCalendarViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::CXTPCalendarViewGroup Constructor

Default object constructor. Construct CXTPCalendarViewGroup object.

CXTPCalendarViewGroup();
See Also

~CXTPCalendarViewGroup()

Group

CXTPCalendarViewGroup Constructors


CXTPCalendarViewGroup Destructors

CXTPCalendarViewGroup Class, Legend, Public Methods
CXTPCalendarViewGroup Destructors
Class

CXTPCalendarViewGroup Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewGroup | Default class destructor.


CXTPCalendarViewGroup::~CXTPCalendarViewGroup Destructor

CXTPCalendarViewGroup Destructors, CXTPCalendarViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::~CXTPCalendarViewGroup Destructor

Default class destructor.

virtual ~CXTPCalendarViewGroup();
Remarks

Handles member item deallocation.

Group

CXTPCalendarViewGroup Destructors


CXTPCalendarViewGroup Nested Types

CXTPCalendarViewGroup Class, Public Nested Types
CXTPCalendarViewGroup Nested Types
Class

CXTPCalendarViewGroup Class

Public Nested Types
Public Nested Type | Description
TBase | Base class shortcut


CXTPCalendarViewGroup::TBase Nested Type

CXTPCalendarViewGroup Nested Types, CXTPCalendarViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroup::TBase Nested Type

Base class shortcut

typedef CXTPCalendarWMHandler TBase;
Group

CXTPCalendarViewGroup Nested Types


CXTPCalendarViewGroupT Template

XTPCalendarViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarViewGroupT Data Members, CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Constructors, CXTPCalendarViewGroupT Destructors, CXTPCalendarViewGroupT Nested Types, CXTPCalendarViewGroupT Constructors, CXTPCalendarViewGroupT Data Members, CXTPCalendarViewGroupT Destructors, CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT Template

This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class.

Class Hierarchy

template <class _TViewDay, class _TViewEvent, class _THitTest, class _TPThis>
class CXTPCalendarViewGroupT : public CXTPCalendarViewGroup;
File

XTPCalendarViewDay.h

Remarks

It is used as a part of the calendar control framework to build ViewGroup layer of View->DayView->ViewDay->ViewGroup typed objects hierarchy. These are template parameters: _TView - Type of owner View object. _TViewEvent - Type of View Event objects stored in Group View. _THitTest - Type of HitTest struct, used as parameter in the member functions. _TPThis - The last derived class type in the class hierarchy.

You must provide all of the above parameters.

See Also

CXTPCalendarViewGroup

Group

Classes

Legend
Data Member
protected
Method
abstract
virtual
CXTPCalendarViewGroupT Constructors
CXTPCalendarViewGroupT Constructors | Description
CXTPCalendarViewGroupT | Default object constructor.
CXTPCalendarViewGroupT Data Members
CXTPCalendarViewGroupT Data Members | Description
m_arEvents | Storage for events views.
CXTPCalendarViewGroupT Destructors
CXTPCalendarViewGroupT Destructors | Description
~CXTPCalendarViewGroupT | Default class destructor.
CXTPCalendarViewGroupT Methods
CXTPCalendarViewGroupT Methods | Description
FillHitTestEx | This member function is used to fill the pHitTest structure members with the default values for the current group view object.
GetPThis | Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.
GetViewDay | This member function is used to obtain the owner view object.
GetViewDay_ | This member function is used to obtain a pointer to the owner view object.
GetViewEvent | Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event's index.
GetViewEvent_ | Call this member function to obtain a pointer to the base CXTPCalendarViewEvent* object that corresponds to the event's index.
GetViewEventsCount | Call this member function to obtain the number of event views in the day view collection.
HitTest | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.
HitTestEx | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.
Populate | This member function is used to populate the view with data for all event items contained in the view.
CXTPCalendarViewGroupT Nested Types
CXTPCalendarViewGroupT Nested Types | Description
TViewDay |
TViewEventsCollection |


CXTPCalendarViewGroupT Data Members

CXTPCalendarViewGroupT Template, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT Data Members
Template

CXTPCalendarViewGroupT Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arEvents | Storage for events views.


CXTPCalendarViewGroupT::m_arEvents Data Member

CXTPCalendarViewGroupT Data Members, CXTPCalendarViewGroupT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::m_arEvents Data Member

Storage for events views.

TViewEventsCollection m_arEvents;
Group

CXTPCalendarViewGroupT Data Members


CXTPCalendarViewGroupT Methods

CXTPCalendarViewGroupT Template, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT Methods
Template

CXTPCalendarViewGroupT Template

Legend
Method
abstract
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetPThis | Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.
Public Methods
Public Methods
Public Method | Description
FillHitTestEx | This member function is used to fill the pHitTest structure members with the default values for the current group view object.
GetViewDay | This member function is used to obtain the owner view object.
GetViewDay_ | This member function is used to obtain a pointer to the owner view object.
GetViewEvent | Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event's index.
GetViewEvent_ | Call this member function to obtain a pointer to the base CXTPCalendarViewEvent* object that corresponds to the event's index.
GetViewEventsCount | Call this member function to obtain the number of event views in the day view collection.
HitTest | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.
HitTestEx | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.
Populate | This member function is used to populate the view with data for all event items contained in the view.


CXTPCalendarViewGroupT::FillHitTestEx Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::FillHitTestEx Method

This member function is used to fill the pHitTest structure members with the default values for the current group view object.

virtual void FillHitTestEx(
    _THitTest* pHitTest
) = 0;
Parameters

pHitTest
A Pointer to a _THitTest structure.

Remarks

This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::GetPThis Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::GetPThis Method

Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.

virtual _TPThis* GetPThis() = 0;
Returns

Pointer to this object as last derived class type.

Remarks

_TPThis - The last derived class type in the class hierarchy. This is a pure virtual function. This function must be defined in the derived class.

Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::GetViewDay Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::GetViewDay Method

This member function is used to obtain the owner view object.

_TViewDay* GetViewDay() const;
Returns

A _TView template pointer to the owner view object.

See Also

GetView_

Body Source
_TViewDay* GetViewDay() const {
    ASSERT(this);
    return this ? m_pViewDay : NULL;
}
Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::GetViewDay_ Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::GetViewDay_ Method

This member function is used to obtain a pointer to the owner view object.

virtual CXTPCalendarViewDay* GetViewDay_() const;
Returns

A CXTPCalendarView pointer to the owner view object.

See Also

GetView

Body Source
virtual CXTPCalendarViewDay* GetViewDay_() const {
    ASSERT(this);
    return this ? (CXTPCalendarViewDay*)m_pViewDay : NULL;
}
Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::GetViewEvent Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::GetViewEvent Method

Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event's index.

virtual _TViewEvent* GetViewEvent(
    int nIndex
);
Parameters

nIndex
An int that contains the event view index in the day view collection.

Returns

A pointer to a _TViewEvent template object.

Remarks

Index number starts with 0 and cannot be negative.

See Also

GetViewEventsCount(), GetViewEvent_()

Body Source
virtual _TViewEvent* GetViewEvent(int nIndex)
{
    ASSERT(this);
    if (!this) {
        return NULL;
    }
    int nCount = m_arEvents.GetCount();
    ASSERT(nIndex >= 0 && nIndex < nCount);
    return (nIndex >= 0 && nIndex < nCount) ? m_arEvents.GetAt(nIndex) : NULL;
}
Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::GetViewEvent_ Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::GetViewEvent_ Method

Call this member function to obtain a pointer to the base CXTPCalendarViewEvent* object that corresponds to the event's index.

virtual CXTPCalendarViewEvent* GetViewEvent_(
    int nIndex
);
Parameters

nIndex
An int that contains the event view index in the day view collection.

Returns

A pointer to a base of the _TViewEvent template object.

Remarks

Index number starts with 0 and cannot be negative.

See Also

GetViewEventsCount(), GetViewEvent()

Body Source
virtual CXTPCalendarViewEvent* GetViewEvent_(int nIndex)
{
    ASSERT(this);
    _TViewEvent* pViewEvent = this ? GetViewEvent(nIndex) : NULL;
    return pViewEvent;
}
Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::GetViewEventsCount Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::GetViewEventsCount Method

Call this member function to obtain the number of event views in the day view collection.

virtual int GetViewEventsCount();
Returns

An int that contains the number of event views.

Body Source
virtual int GetViewEventsCount() {
    return m_arEvents.GetCount();
}
Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::HitTest Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::HitTest Method

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.

virtual BOOL HitTest(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO* pHitTest
);
Parameters

pt
A CPoint object that contains the coordinates of the point to test.
pHitTest
A pointer to a XTP_CALENDAR_HITTESTINFO struct that contains information about the point to test.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

Implements standard functionality for the HitTest method.

See Also

XTP_CALENDAR_HITTESTINFO

Body Source
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest)
{
    _THitTest hitInfo;
    BOOL bRes = HitTestEx(pt, &hitInfo);
    if (bRes && pHitTest) {
        *pHitTest = (XTP_CALENDAR_HITTESTINFO)hitInfo;
    }
    return bRes;
}
Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::HitTestEx Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::HitTestEx Method

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.

virtual BOOL HitTestEx(
    CPoint pt,
    _THitTest* pHitTest
);
Parameters

pt
A CPoint that contains the coordinates of the point test.
pHitTest
A pointer to a _THitTest structure.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

Implements standard functionality for the HitTestEx method.

See Also

XTP_CALENDAR_HITTESTINFO

Body Source
virtual BOOL HitTestEx(CPoint pt, _THitTest* pHitTest)
{
    if (!pHitTest) {
        ASSERT(FALSE);
        return FALSE;
    }

    if (!m_Layout.m_rcGroup.PtInRect(pt)) {
        return FALSE;
    }

    if (m_Layout.m_rcGroupHeader.PtInRect(pt)) {
        FillHitTestEx(pHitTest);
        pHitTest->uHitCode = xtpCalendarHitTestGroupHeader;
        return TRUE;
    }

    int nCount = GetViewEventsCount();
    for (int i = 0; i < nCount; i++)
    {
        _TViewEvent* pViewEvent = GetViewEvent(i);
        ASSERT(pViewEvent);
        if (pViewEvent && pViewEvent->HitTestEx(pt, pHitTest))
        {
            ASSERT(!pHitTest->pViewEvent || pHitTest->pViewEvent == pViewEvent);
            pHitTest->nEvent = i;
            pHitTest->pViewEvent = pViewEvent;
            return TRUE;
        }
    }
    FillHitTestEx(pHitTest);
    pHitTest->uHitCode = xtpCalendarHitTestGroupArea;
    return TRUE;
}
Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT::Populate Method

CXTPCalendarViewGroupT Methods, CXTPCalendarViewGroupT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::Populate Method

This member function is used to populate the view with data for all event items contained in the view.

virtual void Populate(
    COleDateTime dtDayDate
);
Parameters

dtDayDate
A COleDateTime object that contains the day's date.

Remarks

This function provides common functionality for all CXTPCalendarViewGroup - derived classes.

Body Source
virtual void Populate(COleDateTime dtDayDate)
{
    dtDayDate = CXTPCalendarUtils::ResetTime(dtDayDate);

    m_arEvents.RemoveAll();

    CXTPCalendarEventsPtr ptrEventsAr = new CXTPCalendarEvents();
    CXTPCalendarView* pView = XTP_SAFE_GET1(GetViewDay_(), GetView_(), NULL);
    if (!GetResources() || !pView || !ptrEventsAr) {
        return;
    }

    int nResourcesCount = GetResources()->GetCount();
    for (int nRc = 0; nRc < nResourcesCount; nRc++)
    {
        CXTPCalendarResource* pRC = GetResources()->GetAt(nRc);
        if (!pRC) {
            continue;
        }
        // to support dragging common mechanism "pView->RetrieveDayEvents" is used.
        CXTPCalendarEventsPtr ptrEvents = pView->RetrieveDayEvents(pRC, dtDayDate);
        if (!ptrEvents) {
            continue;
        }

        // append events
        ptrEventsAr->Append(ptrEvents);
    }

    // sort events by start time and some other criteria
    ptrEventsAr->Sort(CXTPCalendarEvents::CompareEvents_ForView);

    //---------------------
    CXTPCalendarEvent* pDragNew = XTP_SAFE_GET2(GetViewDay_(), GetView_(), GetDraggingEventNew(), NULL);
    CXTPCalendarEvent* pDragOrig = XTP_SAFE_GET2(GetViewDay_(), GetView_(), GetDraggingEventOrig(), NULL);

    // remove duplicated events
    int nCount = ptrEventsAr->GetCount();
    for (int nEvent = nCount - 2; nEvent >= 0; nEvent--)
    {
        CXTPCalendarEvent* pEvent0 = ptrEventsAr->GetAt(nEvent);
        CXTPCalendarEvent* pEvent1 = ptrEventsAr->GetAt(nEvent + 1);
        if (!pEvent0 || !pEvent1) {
            ASSERT(FALSE);
            continue;
        }
        if (pEvent0 == pDragNew || pEvent1 == pDragNew) {
            continue;
        }

        if (pEvent0->GetDataProvider() == pEvent1->GetDataProvider() &&
            pEvent0->IsEqualIDs(pEvent1))
        {
            ASSERT(pEvent0->GetScheduleID() == pEvent1->GetScheduleID());
            ptrEventsAr->RemoveAt(nEvent + 1);
        }
    }

    // dragging support
    if (pDragNew && !pDragOrig)
    {
        int nFIdx = ptrEventsAr->Find(pDragNew);
        if (nFIdx > 0)
        {
            ptrEventsAr->InsertAt(0, pDragNew, TRUE);
            ptrEventsAr->RemoveAt(nFIdx+1);
        }
    }

    // to allow some customization before show events
    OnPrePopulate(ptrEventsAr);

    // Create events views:
    nCount = ptrEventsAr->GetCount();
    for (int nEventId = 0; nEventId < nCount; nEventId++)
    {
        CXTPCalendarEvent* pEvent = ptrEventsAr->GetAt(nEventId);
        if (!pEvent) {
            ASSERT(FALSE);
            continue;
        }

        // the same checking is in the data provider.
        // check again for dragging event.
        if (!(pEvent->GetStartTime() < dtDayDate &&
            CXTPCalendarUtils::IsEqual(pEvent->GetEndTime(), dtDayDate)) )
        {
            m_arEvents.Add(new _TViewEvent(pEvent, GetPThis()));
        }

        if (dtDayDate < CXTPCalendarUtils::ResetTime(pEvent->GetStartTime()) ||
            dtDayDate > CXTPCalendarUtils::ResetTime(pEvent->GetEndTime()) )
        {
            ASSERT(FALSE);
            TRACE(_T("ERROR data: Day: %s  EVENT {%s - %s} \n"),
                (LPCTSTR)dtDayDate.Format(_T("#%Y-%m-%d#")),
                (LPCTSTR)CXTPCalendarUtils::ResetTime(pEvent->GetStartTime()).Format(_T("#%Y-%m-%d#")),
                (LPCTSTR)CXTPCalendarUtils::ResetTime(pEvent->GetEndTime()).Format(_T("#%Y-%m-%d#"))
                );
        }
    }
}
Group

CXTPCalendarViewGroupT Methods


CXTPCalendarViewGroupT Constructors

CXTPCalendarViewGroupT Template, Legend, Public Methods
CXTPCalendarViewGroupT Constructors
Template

CXTPCalendarViewGroupT Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewGroupT | Default object constructor.


CXTPCalendarViewGroupT::CXTPCalendarViewGroupT Constructor

CXTPCalendarViewGroupT Constructors, CXTPCalendarViewGroupT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::CXTPCalendarViewGroupT Constructor

Default object constructor.

CXTPCalendarViewGroupT(
    _TViewDay* pViewDay
);
Parameters

pViewDay
Pointer to owner view Day object.

See Also

~CXTPCalendarViewGroupT()

Body Source
CXTPCalendarViewGroupT(_TViewDay* pViewDay)
{
    m_pViewDay = pViewDay;
}
Group

CXTPCalendarViewGroupT Constructors


CXTPCalendarViewGroupT Destructors

CXTPCalendarViewGroupT Template, Legend, Public Methods
CXTPCalendarViewGroupT Destructors
Template

CXTPCalendarViewGroupT Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewGroupT | Default class destructor.


CXTPCalendarViewGroupT::~CXTPCalendarViewGroupT Destructor

CXTPCalendarViewGroupT Destructors, CXTPCalendarViewGroupT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::~CXTPCalendarViewGroupT Destructor

Default class destructor.

virtual ~CXTPCalendarViewGroupT();
Remarks

Handles class members deallocation.

Body Source
virtual ~CXTPCalendarViewGroupT() {
}
Group

CXTPCalendarViewGroupT Destructors


CXTPCalendarViewGroupT Nested Types

CXTPCalendarViewGroupT Template, Public Nested Types
CXTPCalendarViewGroupT Nested Types
Template

CXTPCalendarViewGroupT Template

Public Nested Types
Public Nested Type | Description
TViewDay |
TViewEventsCollection |


CXTPCalendarViewGroupT::TViewDay Nested Type

CXTPCalendarViewGroupT Nested Types, CXTPCalendarViewGroupT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::TViewDay Nested Type
typedef _TViewDay TViewDay;
Remarks

Owner view class type definition.

Group

CXTPCalendarViewGroupT Nested Types


CXTPCalendarViewGroupT::TViewEventsCollection Nested Type

CXTPCalendarViewGroupT Nested Types, CXTPCalendarViewGroupT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewGroupT::TViewEventsCollection Nested Type
typedef CXTPCalendarPtrCollectionT< _TViewEvent > TViewEventsCollection;
Remarks

Event views collection type definition.

Group

CXTPCalendarViewGroupT Nested Types


CXTPCalendarViewPart Class

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarViewPart Data Members, CXTPCalendarViewPart Methods, CXTPCalendarViewPart Constructors, CXTPCalendarViewPart Destructors, CXTPCalendarViewPart Constructors, CXTPCalendarViewPart Data Members, CXTPCalendarViewPart Destructors, CXTPCalendarViewPart Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart Class

Helper base class to implement parts for calendar paint manager. objects.

Class Hierarchy

class CXTPCalendarViewPart;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarViewPart Constructors
CXTPCalendarViewPart Constructors | Description
CXTPCalendarViewPart | Default constructor.
CXTPCalendarViewPart Data Members
CXTPCalendarViewPart Data Members | Description
m_clrBackground | Stores color settings used to to fill background of UI item.
m_clrTextColor | Stores color settings used to display text.
m_fntText | Stores font settings used to display text.
m_pPaintManager | Pointer to containing CXTPCalendarPaintManager object
m_pParentPart | Pointer to the parent CXTPCalendarViewPart object.
CXTPCalendarViewPart Destructors
CXTPCalendarViewPart Destructors | Description
~CXTPCalendarViewPart | Default destructor.
CXTPCalendarViewPart Methods
CXTPCalendarViewPart Methods | Description
DrawLine_CenterLR | This member function is used to draw a single line text in the center of the rect. If rect width is not enough to draw all chars - text is aligned to left (or right, see nFormat) or the rect.
DrawLineEx | This member function is used to draw a single line text in the rect. If rect width is not enough to draw all chars - nFormatSmall flags are used, otherwise nFormatNormal flags are used.
DrawText | This member function is used to display the text using the custom font and color.
GetBackgroundColor | This member function is used to obtain the color used to fill the background of UI elements.
GetTextColor | This member function is used to obtain the color used to display text.
GetTextExtent | This member function is used to calculate the size of the area required to display the given text.
GetTextFont | This member function is used to obtain a pointer to a CFont object that contains the font that is used for displaying the text.
RefreshMetrics | This member function is used to set graphical related parameters equal to the system settings.
SetBackgroundColor | This member function is used to set the new color used to fill the background.
SetTextColor | This member function is used to set the new color used to display the text.
SetTextFont | This member function is used to set the new font used to display the text.


CXTPCalendarViewPart Data Members

CXTPCalendarViewPart Class, Legend, Protected Data Members
CXTPCalendarViewPart Data Members
Class

CXTPCalendarViewPart Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrBackground | Stores color settings used to to fill background of UI item.
m_clrTextColor | Stores color settings used to display text.
m_fntText | Stores font settings used to display text.
m_pPaintManager | Pointer to containing CXTPCalendarPaintManager object
m_pParentPart | Pointer to the parent CXTPCalendarViewPart object.


CXTPCalendarViewPart::m_clrBackground Data Member

CXTPCalendarViewPart Data Members, CXTPCalendarViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::m_clrBackground Data Member

Stores color settings used to to fill background of UI item.

CXTPPaintManagerColor m_clrBackground;
Group

CXTPCalendarViewPart Data Members


CXTPCalendarViewPart::m_clrTextColor Data Member

CXTPCalendarViewPart Data Members, CXTPCalendarViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::m_clrTextColor Data Member

Stores color settings used to display text.

CXTPPaintManagerColor m_clrTextColor;
Group

CXTPCalendarViewPart Data Members


CXTPCalendarViewPart::m_fntText Data Member

CXTPCalendarViewPart Data Members, CXTPCalendarViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::m_fntText Data Member

Stores font settings used to display text.

CXTPCalendarViewPartFontValue m_fntText;
Group

CXTPCalendarViewPart Data Members


CXTPCalendarViewPart::m_pPaintManager Data Member

CXTPCalendarViewPart Data Members, CXTPCalendarViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::m_pPaintManager Data Member

Pointer to containing CXTPCalendarPaintManager object

CXTPCalendarPaintManager* m_pPaintManager;
Group

CXTPCalendarViewPart Data Members


CXTPCalendarViewPart::m_pParentPart Data Member

CXTPCalendarViewPart Data Members, CXTPCalendarViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::m_pParentPart Data Member

Pointer to the parent CXTPCalendarViewPart object.

CXTPCalendarViewPart* m_pParentPart;
Group

CXTPCalendarViewPart Data Members


CXTPCalendarViewPart Methods

CXTPCalendarViewPart Class, Legend, Public Methods
CXTPCalendarViewPart Methods
Class

CXTPCalendarViewPart Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawLine_CenterLR | This member function is used to draw a single line text in the center of the rect. If rect width is not enough to draw all chars - text is aligned to left (or right, see nFormat) or the rect.
DrawLineEx | This member function is used to draw a single line text in the rect. If rect width is not enough to draw all chars - nFormatSmall flags are used, otherwise nFormatNormal flags are used.
DrawText | This member function is used to display the text using the custom font and color.
GetBackgroundColor | This member function is used to obtain the color used to fill the background of UI elements.
GetTextColor | This member function is used to obtain the color used to display text.
GetTextExtent | This member function is used to calculate the size of the area required to display the given text.
GetTextFont | This member function is used to obtain a pointer to a CFont object that contains the font that is used for displaying the text.
RefreshMetrics | This member function is used to set graphical related parameters equal to the system settings.
SetBackgroundColor | This member function is used to set the new color used to fill the background.
SetTextColor | This member function is used to set the new color used to display the text.
SetTextFont | This member function is used to set the new font used to display the text.


CXTPCalendarViewPart::DrawLine_CenterLR Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::DrawLine_CenterLR Method

This member function is used to draw a single line text in the center of the rect. If rect width is not enough to draw all chars - text is aligned to left (or right, see nFormat) or the rect.

void DrawLine_CenterLR(
    CDC* pDC,
    const CString& str,
    LPRECT lpRect,
    UINT nFormat
);
Parameters

pDC
A pointer to a valid device context.
str
A CString that contains the text to display.
lpRect
An LPRECT that contains the rectangle coordinates used to display the text.
nFormat
A UINT that contains additional format parameters as combination of flags: DT_VCENTER, DT_LEFT, DT_RIGHT or 0.

Body Source
void DrawLine_CenterLR(CDC* pDC, const CString& str, LPRECT lpRect, UINT nFormat)
{
    CFont* pOldFont = pDC->SelectObject(&GetTextFont());
    pDC->SetTextColor(GetTextColor());
    nFormat |= DT_NOPREFIX | DT_SINGLELINE;

    int nLeftRight = nFormat & (DT_LEFT | DT_RIGHT);
    nFormat &= ~(DT_CENTER | DT_LEFT | DT_RIGHT);

    CSize sz = pDC->GetTextExtent(str);
    if (sz.cx < labs(lpRect->right - lpRect->left) ) {
        nFormat |= DT_CENTER;
    }
    else
    {
        nFormat |= nLeftRight ? nLeftRight : DT_LEFT;
    }

    pDC->DrawText(str, lpRect, nFormat);

    pDC->SelectObject(pOldFont);
}
Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::DrawLineEx Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::DrawLineEx Method

This member function is used to draw a single line text in the rect. If rect width is not enough to draw all chars - nFormatSmall flags are used, otherwise nFormatNormal flags are used.

void DrawLineEx(
    CDC* pDC,
    const CString& str,
    LPRECT lpRect,
    UINT nFormatNormal,
    UINT nFormatSmall
);
Parameters

pDC
A pointer to a valid device context.
str
A CString that contains the text to display.
lpRect
An LPRECT that contains the rectangle coordinates used to display the text.
nFormatNormal
A UINT that contains format parameters when rect width is enough to draw all text chars.
nFormatSmall
A UINT that contains format parameters when rect width is not enough to draw all text chars.

Body Source
void DrawLineEx(CDC* pDC, const CString& str, LPRECT lpRect, UINT nFormatNormal, UINT nFormatSmall)
{
    CFont* pOldFont = pDC->SelectObject(&GetTextFont());
    pDC->SetTextColor(GetTextColor());
    UINT nFormat = 0;

    CSize sz = pDC->GetTextExtent(str);
    if (sz.cx < labs(lpRect->right - lpRect->left) ) {
        nFormat = nFormatNormal | DT_NOPREFIX | DT_SINGLELINE;
    }
    else
    {
        nFormat = nFormatSmall | DT_NOPREFIX | DT_SINGLELINE;
    }

    pDC->DrawText(str, lpRect, nFormat);

    pDC->SelectObject(pOldFont);
}
Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::DrawText Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::DrawText Method

This member function is used to display the text using the custom font and color.

void DrawText(
    CDC* pDC,
    const CString& str,
    LPRECT lpRect,
    UINT nFormat
);
Parameters

pDC
A pointer to a valid device context.
str
A CString that contains the text to display.
lpRect
An LPRECT that contains the rectangle coordinates used to display the text.
nFormat
A UINT that contains additional format parameters.

Body Source
void DrawText(CDC* pDC, const CString& str, LPRECT lpRect, UINT nFormat) {
    CFont* pOldFont = pDC->SelectObject(&GetTextFont());
    pDC->SetTextColor(GetTextColor());
    nFormat |= DT_NOPREFIX;
    pDC->DrawText(str, lpRect, nFormat);
    pDC->SelectObject(pOldFont);
}
Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::GetBackgroundColor Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class
CXTPCalendarViewPart::GetBackgroundColor Method

This member function is used to obtain the color used to fill the background of UI elements.

virtual COLORREF GetBackgroundColor();
Returns

A COLORREF that contains the value of the background color.

Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::GetTextColor Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class
CXTPCalendarViewPart::GetTextColor Method

This member function is used to obtain the color used to display text.

virtual COLORREF GetTextColor();
Returns

A COLORREF that contains the value of text color.

Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::GetTextExtent Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::GetTextExtent Method

This member function is used to calculate the size of the area required to display the given text.

CSize GetTextExtent(
    CDC* pDC,
    const CString& str
);
Parameters

pDC
A pointer to a valid device context.
str
A CString that contains the string of text to display.

Returns

A CSize object that contains the dimensions required to display the text.

Body Source
CSize GetTextExtent(CDC* pDC, const CString& str) {
    CFont* pOldFont = pDC->SelectObject(&GetTextFont());
    CSize sz = pDC->GetTextExtent(str);
    pDC->SelectObject(pOldFont);
    return sz;
}
Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::GetTextFont Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class
CXTPCalendarViewPart::GetTextFont Method

This member function is used to obtain a pointer to a CFont object that contains the font that is used for displaying the text.

virtual CFont& GetTextFont();
Returns

A reference to a CFont object that contains the font used to display the text.

Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::RefreshMetrics Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class
CXTPCalendarViewPart::RefreshMetrics Method

This member function is used to set graphical related parameters equal to the system settings.

virtual void RefreshMetrics();
Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::SetBackgroundColor Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::SetBackgroundColor Method

This member function is used to set the new color used to fill the background.

void SetBackgroundColor(
    COLORREF clr
);
Parameters

clr
A COLORREF that contains the new color value.

Body Source
void SetBackgroundColor(COLORREF clr) {
    m_clrBackground = clr;
}
Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::SetTextColor Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::SetTextColor Method

This member function is used to set the new color used to display the text.

void SetTextColor(
    COLORREF clr
);
Parameters

clr
A COLORREF that contains the new color value.

Body Source
void SetTextColor(COLORREF clr) {
    m_clrTextColor = clr;
}
Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart::SetTextFont Method

CXTPCalendarViewPart Methods, CXTPCalendarViewPart Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::SetTextFont Method

This member function is used to set the new font used to display the text.

void SetTextFont(
    LOGFONT* pLogFont
);
Parameters

pLogFont
A pointer to a LOGFONT struct that contains the new font used to display the text.

Body Source
void SetTextFont(LOGFONT* pLogFont) {
    m_fntText = pLogFont;
}
Group

CXTPCalendarViewPart Methods


CXTPCalendarViewPart Constructors

CXTPCalendarViewPart Class, Legend, Public Methods
CXTPCalendarViewPart Constructors
Class

CXTPCalendarViewPart Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewPart | Default constructor.


CXTPCalendarViewPart::CXTPCalendarViewPart Constructor

CXTPCalendarViewPart Constructors, CXTPCalendarViewPart Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPart::CXTPCalendarViewPart Constructor

Default constructor.

CXTPCalendarViewPart(
    CXTPCalendarViewPart* pParentPart = NULL
);
Parameters

pParentPart
Pointer to parent class, can be NULL.

Group

CXTPCalendarViewPart Constructors


CXTPCalendarViewPart Destructors

CXTPCalendarViewPart Class, Legend, Public Methods
CXTPCalendarViewPart Destructors
Class

CXTPCalendarViewPart Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewPart | Default destructor.


CXTPCalendarViewPart::~CXTPCalendarViewPart Destructor

CXTPCalendarViewPart Destructors, CXTPCalendarViewPart Class
CXTPCalendarViewPart::~CXTPCalendarViewPart Destructor

Default destructor.

virtual ~CXTPCalendarViewPart();
Group

CXTPCalendarViewPart Destructors


CXTPCalendarViewPartBrushValue Class

XTPCalendarViewPart.h, Classes
CXTPCalendarViewPartBrushValue Class

Helper class provides functionality to manage brush value objects.

Class Hierarchy

class CXTPCalendarViewPartBrushValue : public CXTPCalendarViewPartCustomizableValueT<CBrush>;
File

XTPCalendarViewPart.h

Group

Classes


CXTPCalendarViewPartCustomizableValueT Template

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarViewPartCustomizableValueT Data Members, CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Constructors, CXTPCalendarViewPartCustomizableValueT Destructors, CXTPCalendarViewPartCustomizableValueT Operators, CXTPCalendarViewPartCustomizableValueT Constructors, CXTPCalendarViewPartCustomizableValueT Data Members, CXTPCalendarViewPartCustomizableValueT Destructors, CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT Template

Helper class template provides functionality to manage customized value for the specified class objects.

Class Hierarchy

template <class _TValue>
class CXTPCalendarViewPartCustomizableValueT;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Data Member
protected
Method
virtual
Operator
CXTPCalendarViewPartCustomizableValueT Constructors
CXTPCalendarViewPartCustomizableValueT Constructors | Description
CXTPCalendarViewPartCustomizableValueT | Default object constructor.
CXTPCalendarViewPartCustomizableValueT Data Members
CXTPCalendarViewPartCustomizableValueT Data Members | Description
m_bAutoDelete_Custom | Call operator delete for the custom value.
m_bAutoDelete_Standard | Call operator delete for the standard value.
m_pValueCustom | Stores custom value.
m_pValueStandard | Stores default value.
CXTPCalendarViewPartCustomizableValueT Destructors
CXTPCalendarViewPartCustomizableValueT Destructors | Description
~CXTPCalendarViewPartCustomizableValueT | Default object destructor.
CXTPCalendarViewPartCustomizableValueT Methods
CXTPCalendarViewPartCustomizableValueT Methods | Description
CopySettings | This member function is use to set standard value using current value from the specified object.
GetStandardValue | This member function is use to get standard value.
GetValue | This member function is use to get current value.
IsCustomValue | This member function determines if the custom value is set and used.
IsDefaultValue | This member function is used to determine if the default value is set.
IsStandardValue | This member function determines if the standard value is set and used.
SetCustomValue | This member function is used to set the custom value.
SetDefaultValue | This member function is used to reset the custom value.
SetStandardValue | This member function is used to set the standard value.
CXTPCalendarViewPartCustomizableValueT Operators
CXTPCalendarViewPartCustomizableValueT Operators | Description
_TValue* | This member operator is use to get current value.
-> | Get a current value object.


CXTPCalendarViewPartCustomizableValueT Data Members

CXTPCalendarViewPartCustomizableValueT Template, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT Data Members
Template

CXTPCalendarViewPartCustomizableValueT Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoDelete_Custom | Call operator delete for the custom value.
m_bAutoDelete_Standard | Call operator delete for the standard value.
m_pValueCustom | Stores custom value.
m_pValueStandard | Stores default value.


CXTPCalendarViewPartCustomizableValueT::m_bAutoDelete_Custom Data Member

CXTPCalendarViewPartCustomizableValueT Data Members, CXTPCalendarViewPartCustomizableValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::m_bAutoDelete_Custom Data Member

Call operator delete for the custom value.

BOOL m_bAutoDelete_Custom;
Group

CXTPCalendarViewPartCustomizableValueT Data Members


CXTPCalendarViewPartCustomizableValueT::m_bAutoDelete_Standard Data Member

CXTPCalendarViewPartCustomizableValueT Data Members, CXTPCalendarViewPartCustomizableValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::m_bAutoDelete_Standard Data Member

Call operator delete for the standard value.

BOOL m_bAutoDelete_Standard;
Group

CXTPCalendarViewPartCustomizableValueT Data Members


CXTPCalendarViewPartCustomizableValueT::m_pValueCustom Data Member

CXTPCalendarViewPartCustomizableValueT Data Members, CXTPCalendarViewPartCustomizableValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::m_pValueCustom Data Member

Stores custom value.

_TValue* m_pValueCustom;
Group

CXTPCalendarViewPartCustomizableValueT Data Members


CXTPCalendarViewPartCustomizableValueT::m_pValueStandard Data Member

CXTPCalendarViewPartCustomizableValueT Data Members, CXTPCalendarViewPartCustomizableValueT Template
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::m_pValueStandard Data Member

Stores default value.

_TValue* m_pValueStandard;
Group

CXTPCalendarViewPartCustomizableValueT Data Members


CXTPCalendarViewPartCustomizableValueT Methods

CXTPCalendarViewPartCustomizableValueT Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT Methods
Template

CXTPCalendarViewPartCustomizableValueT Template

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
CopySettings | This member function is use to set standard value using current value from the specified object.
GetStandardValue | This member function is use to get standard value.
GetValue | This member function is use to get current value.
IsCustomValue | This member function determines if the custom value is set and used.
IsDefaultValue | This member function is used to determine if the default value is set.
IsStandardValue | This member function determines if the standard value is set and used.
SetCustomValue | This member function is used to set the custom value.
SetDefaultValue | This member function is used to reset the custom value.
SetStandardValue | This member function is used to set the standard value.


CXTPCalendarViewPartCustomizableValueT::CopySettings Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::CopySettings Method

This member function is use to set standard value using current value from the specified object.

void CopySettings(
    const CXTPCalendarViewPartCustomizableValueT<_TValue>& refSrc
);
Parameters

refSrc
Reference to a source object.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue, GetValue, IsStandardValue, IsCustomValue, GetStandardValue.

Body Source
void CopySettings(const CXTPCalendarViewPartCustomizableValueT<_TValue>& refSrc)
{
    SetStandardValue(refSrc.GetValue(), FALSE);
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT::GetStandardValue Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::GetStandardValue Method

This member function is use to get standard value.

virtual _TValue* GetStandardValue() const;
Returns

A pointer to the standard value.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue, operator _TValue*

Example

See example for SetCustomValue.

Body Source
virtual _TValue* GetStandardValue() const {
    return  m_pValueStandard;
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT::GetValue Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::GetValue Method

This member function is use to get current value.

virtual _TValue* GetValue() const;
Returns

A pointer to the current value.

Remarks

The default value is used if the custom value is not set. Otherwise, a custom value is used.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue, operator _TValue*

Example

See example for SetCustomValue.

Body Source
virtual _TValue* GetValue() const {
    return  m_pValueCustom ? m_pValueCustom : m_pValueStandard;
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT::IsCustomValue Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::IsCustomValue Method

This member function determines if the custom value is set and used.

virtual BOOL IsCustomValue() const;
Returns

TRUE if custom value is set, otherwise FALSE.

Body Source
virtual BOOL IsCustomValue() const {
    return m_pValueCustom != NULL;
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT::IsDefaultValue Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::IsDefaultValue Method

This member function is used to determine if the default value is set.

virtual BOOL IsDefaultValue() const;
Returns

A BOOL. TRUE if the default value is set. FALSE otherwise.

Body Source
virtual BOOL IsDefaultValue() const {
    return (m_pValueCustom == NULL) && (m_pValueStandard == NULL);
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT::IsStandardValue Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::IsStandardValue Method

This member function determines if the standard value is set and used.

virtual BOOL IsStandardValue() const;
Returns

TRUE if standard value is set and custom value is not set, otherwise FALSE.

Body Source
virtual BOOL IsStandardValue() const {
    return (m_pValueCustom == NULL) && (m_pValueStandard != NULL);
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT::SetCustomValue Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::SetCustomValue Method

This member function is used to set the custom value.

virtual void SetCustomValue(
    _TValue* pValue,
    BOOL bAutoDelete
);
virtual void SetCustomValue(
    CFont* pFont
);
Parameters

pValue
A pointer to a value object.
bAutoDelete
This parameter indicates should be a value object deleted when destroy or other value is set. If TRUE - value object will be deleted automatically.

Remarks

Call this member function to set the custom value. If set, this value is used instead of default value.

See Also

SetStandardValue, SetDefaultValue

Example
     class CMyClass
     {
     public:
         CMyClass();

         void Draw(CDC* pDC, CRect& rcRect, BOOL bCustom);
         // ...
         CBrush m_brushBusy_Custom;

         CXTPCalendarViewPartBrushValue m_brushVal_auto;
         CXTPCalendarViewPartBrushValue m_brushVal_static;
     };

     CMyClass::CMyClass()
     {
         m_brushBusy_Custom.CreateSolidBrush(RGB(0, 0, 0xFF));

         m_brushVal_auto.SetStandardValue(new CBrush(RGB(0xFF, 0xFF, 0xFF)), TRUE);
         m_brushVal_static.SetStandardValue(&m_brushBusy_Custom, FALSE);
     }

     void CMyClass::Draw(CDC* pDC, CRect& rcRect, BOOL bCustom)
     {
         if (bCustom) {
             m_brushVal_auto.SetCustomValue(new CBrush(RGB(0, 0, 0)), TRUE);
             m_brushVal_static.SetCustomValue(new CBrush(RGB(255, 255, 255)), TRUE);
         }
         else {
             // Reset to standard value
             m_brushVal_auto.SetDefaultValue();
             m_brushVal_static.SetDefaultValue();
         }

         pDC->FillRect(&rcRect, (CBrush*)m_brushVal_auto);

         CBrush* pBrushOld = pDC->SelectObject(m_brushVal_static.GetValue());
         // ....
         pDC->SelectObject(pBrushOld);
     }
Body Source
virtual void SetCustomValue(_TValue* pValue, BOOL bAutoDelete)
{
    if (m_bAutoDelete_Custom) {
        SAFE_DELETE(m_pValueCustom);
    }
    m_pValueCustom = pValue;
    m_bAutoDelete_Custom = bAutoDelete;
}

virtual void SetCustomValue(CFont* pFont)
{
    //may be not safe when few CXTPCalendarThemeFontValue objects use the same CFont* pointer.
    //
    //TBase::SetCustomValue(pFont, FALSE);

    if (!pFont)
    {
        TBase::SetStandardValue(pFont, FALSE);
        return;
    }

    LOGFONT lfFont;
    int nRes = pFont->GetLogFont(&lfFont);
    ASSERT(nRes);
    if(nRes)
        SetCustomValue(&lfFont);
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT::SetDefaultValue Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::SetDefaultValue Method

This member function is used to reset the custom value.

virtual void SetDefaultValue();
Remarks

Call this member function to ensure that the default value is used and not the custom value. If the default value is not set - method do nothing.

See Also

SetStandardValue, SetCustomValue

Example

See example for SetCustomValue.

Body Source
virtual void SetDefaultValue()
{
    if (m_pValueStandard)
    {
        if (m_bAutoDelete_Custom) {
            SAFE_DELETE(m_pValueCustom);
        }
        m_pValueCustom = NULL;
    }
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT::SetStandardValue Method

CXTPCalendarViewPartCustomizableValueT Methods, CXTPCalendarViewPartCustomizableValueT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::SetStandardValue Method

This member function is used to set the standard value.

virtual void SetStandardValue(
    _TValue* pValue,
    BOOL bAutoDelete
);
virtual void SetStandardValue(
    CFont* pFont
);
Parameters

pValue
A pointer to a value object.
bAutoDelete
This parameter indicates should be a value object deleted when destroy or other value is set. If TRUE - value object will be deleted automatically.

Remarks

Call this member function to set the standard value. This value is used as the default value if there is not a custom value set.

See Also

SetCustomValue, SetDefaultValue

Example

See example for SetCustomValue.

Body Source
virtual void SetStandardValue(_TValue* pValue, BOOL bAutoDelete)
{
    if (m_bAutoDelete_Standard) {
        SAFE_DELETE(m_pValueStandard);
    }
    m_pValueStandard = pValue;
    m_bAutoDelete_Standard = bAutoDelete;
}

virtual void SetStandardValue(CFont* pFont)
{
    //may be not safe when few CXTPCalendarThemeFontValue objects use the same CFont* pointer.
    //
    //TBase::SetStandardValue(pFont, FALSE);

    if (!pFont)
    {
        TBase::SetStandardValue(pFont, FALSE);
        return;
    }

    LOGFONT lfFont;
    int nRes = pFont->GetLogFont(&lfFont);
    ASSERT(nRes);
    if(nRes)
        SetStandardValue(&lfFont);
}
Group

CXTPCalendarViewPartCustomizableValueT Methods


CXTPCalendarViewPartCustomizableValueT Constructors

CXTPCalendarViewPartCustomizableValueT Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT Constructors
Template

CXTPCalendarViewPartCustomizableValueT Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewPartCustomizableValueT | Default object constructor.


CXTPCalendarViewPartCustomizableValueT::CXTPCalendarViewPartCustomizableValueT Constructor

CXTPCalendarViewPartCustomizableValueT Constructors, CXTPCalendarViewPartCustomizableValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::CXTPCalendarViewPartCustomizableValueT Constructor

Default object constructor.

CXTPCalendarViewPartCustomizableValueT();
Body Source
CXTPCalendarViewPartCustomizableValueT()
{
    m_pValueStandard = NULL;
    m_bAutoDelete_Standard = FALSE;

    m_pValueCustom = NULL;
    m_bAutoDelete_Custom = FALSE;
}
Group

CXTPCalendarViewPartCustomizableValueT Constructors


CXTPCalendarViewPartCustomizableValueT Destructors

CXTPCalendarViewPartCustomizableValueT Template, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT Destructors
Template

CXTPCalendarViewPartCustomizableValueT Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewPartCustomizableValueT | Default object destructor.


CXTPCalendarViewPartCustomizableValueT::~CXTPCalendarViewPartCustomizableValueT Destructor

CXTPCalendarViewPartCustomizableValueT Destructors, CXTPCalendarViewPartCustomizableValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::~CXTPCalendarViewPartCustomizableValueT Destructor

Default object destructor.

virtual ~CXTPCalendarViewPartCustomizableValueT();
Body Source
virtual ~CXTPCalendarViewPartCustomizableValueT()
{
    if (m_bAutoDelete_Standard) {
        SAFE_DELETE(m_pValueStandard);
    }
    if (m_bAutoDelete_Custom) {
        SAFE_DELETE(m_pValueCustom);
    }
}
Group

CXTPCalendarViewPartCustomizableValueT Destructors


CXTPCalendarViewPartCustomizableValueT Operators

CXTPCalendarViewPartCustomizableValueT Template, Legend, Public Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT Operators
Template

CXTPCalendarViewPartCustomizableValueT Template

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
_TValue* | This member operator is use to get current value.
-> | Get a current value object.


CXTPCalendarViewPartCustomizableValueT::_TValue* Operator

CXTPCalendarViewPartCustomizableValueT Operators, CXTPCalendarViewPartCustomizableValueT Template, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::_TValue* Operator

This member operator is use to get current value.

operator _TValue*() const;
Returns

A pointer to the current value.

Remarks

The default value is used if the custom value is not set. Otherwise, a custom value is used.

See Also

SetStandardValue, SetCustomValue, SetDefaultValue, GetValue

Example

See example for SetCustomValue.

Body Source
operator _TValue* () const {
    return GetValue();
}
Group

CXTPCalendarViewPartCustomizableValueT Operators


CXTPCalendarViewPartCustomizableValueT::-> Operator

CXTPCalendarViewPartCustomizableValueT Operators, CXTPCalendarViewPartCustomizableValueT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartCustomizableValueT::-> Operator

Get a current value object.

_TValue* operator ->();
Returns

Pointer to the current value object.

Body Source
_TValue* operator->() {
    return GetValue();
}
Group

CXTPCalendarViewPartCustomizableValueT Operators


CXTPCalendarViewPartFontValue Class

XTPCalendarViewPart.h, Classes, Legend, Members, Topics, CXTPCalendarViewPartFontValue Data Members, CXTPCalendarViewPartFontValue Methods, CXTPCalendarViewPartFontValue Constructors, CXTPCalendarViewPartFontValue Operators, CXTPCalendarViewPartFontValue Constructors, CXTPCalendarViewPartFontValue Data Members, CXTPCalendarViewPartFontValue Methods, CXTPCalendarViewPartFontValue Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue Class

Helper class provides functionality to manage font settings for various graphical elements of control.

Class Hierarchy

class CXTPCalendarViewPartFontValue;
File

XTPCalendarViewPart.h

Group

Classes

Legend
Data Member
protected
Method
Operator
CXTPCalendarViewPartFontValue Constructors
CXTPCalendarViewPartFontValue Constructors | Description
CXTPCalendarViewPartFontValue | Default constructor.
CXTPCalendarViewPartFontValue Data Members
CXTPCalendarViewPartFontValue Data Members | Description
m_fntCustomValue | Stores custom font.
m_fntStandardValue | Stores default font.
CXTPCalendarViewPartFontValue Methods
CXTPCalendarViewPartFontValue Methods | Description
IsDefaultValue | This member function is used to determine if the default font value is set.
SetDefaultValue | This member function is used to delete the custom font and to set the default font value as the default font.
SetStandardValue | This member function is used to set the value for the standard font.
CXTPCalendarViewPartFontValue Operators
CXTPCalendarViewPartFontValue Operators | Description
= | This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.
-> | Get a current value object.
CFont& | This member function is use to overload the function call operator for the CXTPCalendarViewPartFontValue class.
CFont* | This member function is use to overload the function call operator for the CXTPCalendarViewPartFontValue class.


CXTPCalendarViewPartFontValue Data Members

CXTPCalendarViewPartFontValue Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue Data Members
Class

CXTPCalendarViewPartFontValue Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_fntCustomValue | Stores custom font.
m_fntStandardValue | Stores default font.


CXTPCalendarViewPartFontValue::m_fntCustomValue Data Member

CXTPCalendarViewPartFontValue Data Members, CXTPCalendarViewPartFontValue Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::m_fntCustomValue Data Member

Stores custom font.

CFont m_fntCustomValue;
Group

CXTPCalendarViewPartFontValue Data Members


CXTPCalendarViewPartFontValue::m_fntStandardValue Data Member

CXTPCalendarViewPartFontValue Data Members, CXTPCalendarViewPartFontValue Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::m_fntStandardValue Data Member

Stores default font.

CFont m_fntStandardValue;
Group

CXTPCalendarViewPartFontValue Data Members


CXTPCalendarViewPartFontValue Methods

CXTPCalendarViewPartFontValue Class, Legend, Public Methods
CXTPCalendarViewPartFontValue Methods
Class

CXTPCalendarViewPartFontValue Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
IsDefaultValue | This member function is used to determine if the default font value is set.
SetDefaultValue | This member function is used to delete the custom font and to set the default font value as the default font.
SetStandardValue | This member function is used to set the value for the standard font.


CXTPCalendarViewPartFontValue::IsDefaultValue Method

CXTPCalendarViewPartFontValue Methods, CXTPCalendarViewPartFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::IsDefaultValue Method

This member function is used to determine if the default font value is set.

BOOL IsDefaultValue();
Returns

A BOOL. TRUE if the default value is set. FALSE otherwise.

Body Source
BOOL IsDefaultValue() {
    return (m_fntCustomValue.GetSafeHandle() == NULL) && (m_fntStandardValue.GetSafeHandle() == NULL);
}
Group

CXTPCalendarViewPartFontValue Methods


CXTPCalendarViewPartFontValue::SetDefaultValue Method

CXTPCalendarViewPartFontValue Methods, CXTPCalendarViewPartFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::SetDefaultValue Method

This member function is used to delete the custom font and to set the default font value as the default font.

void SetDefaultValue();
Remarks

Call this member function to ensure that the default font is used and not the custom font.

Body Source
void SetDefaultValue() {
    m_fntCustomValue.DeleteObject();
}
Group

CXTPCalendarViewPartFontValue Methods


CXTPCalendarViewPartFontValue::SetStandardValue Method

CXTPCalendarViewPartFontValue Methods, CXTPCalendarViewPartFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::SetStandardValue Method

This member function is used to set the value for the standard font.

void SetStandardValue(
    LOGFONT* pLogFont
);
Parameters

pLogFont
A pointer to a LOGFONT structure that contains the standard font value.

Remarks

Call this member function to set the standard font. This font is used as the default font if there is not a custom font value set.

Body Source
void SetStandardValue(LOGFONT* pLogFont)
{
    m_fntStandardValue.DeleteObject();
    m_fntStandardValue.CreateFontIndirect(pLogFont);
}
Group

CXTPCalendarViewPartFontValue Methods


CXTPCalendarViewPartFontValue Constructors

CXTPCalendarViewPartFontValue Class, Legend, Public Methods
CXTPCalendarViewPartFontValue Constructors
Class

CXTPCalendarViewPartFontValue Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewPartFontValue | Default constructor.


CXTPCalendarViewPartFontValue::CXTPCalendarViewPartFontValue Constructor

CXTPCalendarViewPartFontValue Constructors, CXTPCalendarViewPartFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::CXTPCalendarViewPartFontValue Constructor

Default constructor.

CXTPCalendarViewPartFontValue();
Body Source
CXTPCalendarViewPartFontValue()
{

}
Group

CXTPCalendarViewPartFontValue Constructors


CXTPCalendarViewPartFontValue Operators

CXTPCalendarViewPartFontValue Class, Legend, Public Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue Operators
Class

CXTPCalendarViewPartFontValue Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.
-> | Get a current value object.
CFont& | This member function is use to overload the function call operator for the CXTPCalendarViewPartFontValue class.
CFont* | This member function is use to overload the function call operator for the CXTPCalendarViewPartFontValue class.


CXTPCalendarViewPartFontValue::= Operator

CXTPCalendarViewPartFontValue Operators, CXTPCalendarViewPartFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::= Operator

This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.

const CXTPCalendarViewPartFontValue& operator =(
    LOGFONT* pLogFont
);
Parameters

pLogFont
A pointer to a LOGFONT structure.

Returns

A reference to a CXTPCalendarViewPartFontValue.

Remarks

Creates a new custom font.

Body Source
const CXTPCalendarViewPartFontValue& operator=(LOGFONT* pLogFont) {
    m_fntCustomValue.DeleteObject();
    if (pLogFont) m_fntCustomValue.CreateFontIndirect(pLogFont);
    return *this;
}
Group

CXTPCalendarViewPartFontValue Operators


CXTPCalendarViewPartFontValue::-> Operator

CXTPCalendarViewPartFontValue Operators, CXTPCalendarViewPartFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::-> Operator

Get a current value object.

CFont* operator ->();
Returns

Pointer to the current value object.

Body Source
CFont* operator->() {
    return (m_fntCustomValue.GetSafeHandle() == 0) ? &m_fntStandardValue : &m_fntCustomValue;
}
Group

CXTPCalendarViewPartFontValue Operators


CXTPCalendarViewPartFontValue::CFont& Operator

CXTPCalendarViewPartFontValue Operators, CXTPCalendarViewPartFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::CFont& Operator

This member function is use to overload the function call operator for the CXTPCalendarViewPartFontValue class.

operator CFont&();
Returns

A reference to a CFont object that contains either the standard font value or the custom font value.

Remarks

Use the default font if the custom font does not work. Otherwise, use a custom font.

Body Source
operator CFont& () {
    return  (m_fntCustomValue.GetSafeHandle() == 0) ? m_fntStandardValue : m_fntCustomValue;
}
Group

CXTPCalendarViewPartFontValue Operators


CXTPCalendarViewPartFontValue::CFont* Operator

CXTPCalendarViewPartFontValue Operators, CXTPCalendarViewPartFontValue Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewPartFontValue::CFont* Operator

This member function is use to overload the function call operator for the CXTPCalendarViewPartFontValue class.

operator CFont*();
Returns

A pointer to a CFont object that contains either the standard font value or the custom font value.

Remarks

Use the default font if the custom font does not work. Otherwise, use a custom font.

Body Source
operator CFont* () {
    return  (m_fntCustomValue.GetSafeHandle() == 0) ? &m_fntStandardValue : &m_fntCustomValue;
}
Group

CXTPCalendarViewPartFontValue Operators


CXTPCalendarViewT Template

XTPCalendarView.h, Classes, Legend, Members, Topics, CXTPCalendarViewT Data Members, CXTPCalendarViewT Methods, CXTPCalendarViewT Constructors, CXTPCalendarViewT Destructors, CXTPCalendarViewT Constructors, CXTPCalendarViewT Data Members, CXTPCalendarViewT Destructors, CXTPCalendarViewT Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT Template

This template class represents a view portion of the Calendar control.

Class Hierarchy

template <class _TViewDay, class _THitTest >
class CXTPCalendarViewT : public CXTPCalendarView;
File

XTPCalendarView.h

Remarks

It represents a specific view of the Control's associated events data and provides basic functionality on this data using user input through the keyboard and the mouse. It is used as a part of the calendar control framework to build View layer of View->DayView->ViewEvent typed objects hierarchy. These are the template parameters: _TViewDay - Type of View Day objects stored in View. _TViewEvent - Type of View Event objects stored in View Day. _THitTest - Type of HitTest struct, used as parameter in the member functions.

You must provide all of the above parameters.

These are the predefined view implementations available for the Calendar control:

  • Day and work week views - Using the CXTPCalendarDayView class.
  • Week view - Using the CXTPCalendarWeekView class.
  • Month view - Using the CXTPCalendarMonthView class.

Furthermore, any type of user defined view may also be implemented as a descendant of the CXTPCalendarView class.

A typical Calendar View model consists of a collection of corresponding ViewDay's, which realizes the contents on a square of one day. ViewDay in turn contains a collection of ViewEvent's for the particular day, each of them represents a view of an CXTPCalendarEvent object.

See Also

CXTPCalendarDayView, CXTPCalendarWeekView, CXTPCalendarMonthView, CXTPCalendarViewDay, CXTPCalendarViewEvent

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPCalendarViewT Constructors
CXTPCalendarViewT Constructors | Description
CXTPCalendarViewT | Default object constructor.
CXTPCalendarViewT Data Members
CXTPCalendarViewT Data Members | Description
m_arDays | Stores the view day collection.
CXTPCalendarViewT Destructors
CXTPCalendarViewT Destructors | Description
~CXTPCalendarViewT | Default class destructor.
CXTPCalendarViewT Methods
CXTPCalendarViewT Methods | Description
GetViewDay | Call this member function to obtain a _TViewDay object corresponding with the day's index.
GetViewDay_ | Call this member function to get the CXTPCalendarViewDay object by day's index.
GetViewDayCount | Call this member function to obtain the number of day views in the view collection.
GetViewType | Call this member function to obtain the view type flag.
HitTest | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
HitTestEx | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a _THitTest object.


CXTPCalendarViewT Data Members

CXTPCalendarViewT Template, Legend, Protected Data Members
CXTPCalendarViewT Data Members
Template

CXTPCalendarViewT Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arDays | Stores the view day collection.


CXTPCalendarViewT::m_arDays Data Member

CXTPCalendarViewT Data Members, CXTPCalendarViewT Template
CXTPCalendarViewT::m_arDays Data Member

Stores the view day collection.

CXTPCalendarPtrCollectionT< _TViewDay > m_arDays;
Group

CXTPCalendarViewT Data Members


CXTPCalendarViewT Methods

CXTPCalendarViewT Template, Legend, Public Methods
CXTPCalendarViewT Methods
Template

CXTPCalendarViewT Template

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetViewDay | Call this member function to obtain a _TViewDay object corresponding with the day's index.
GetViewDay_ | Call this member function to get the CXTPCalendarViewDay object by day's index.
GetViewDayCount | Call this member function to obtain the number of day views in the view collection.
GetViewType | Call this member function to obtain the view type flag.
HitTest | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
HitTestEx | This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a _THitTest object.


CXTPCalendarViewT::GetViewDay Method

CXTPCalendarViewT Methods, CXTPCalendarViewT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT::GetViewDay Method

Call this member function to obtain a _TViewDay object corresponding with the day's index.

virtual _TViewDay* GetViewDay(
    int nIndex
);
Parameters

nIndex
An int that contains the day view index in the view collection.

Returns

If the day's index is valid, then the function returns a pointer to a _TViewDay object that corresponds with the day's index. Otherwise, the function returns NULL.

Remarks

Index numbers start with 0 and cannot be negative.

See Also

GetViewDayCount()

Body Source
virtual _TViewDay*  GetViewDay(int nIndex)
{
    ASSERT(this);
    if (!this) {
        return NULL;
    }

    int nCount = m_arDays.GetCount();
    ASSERT(nIndex >= 0 && nIndex < nCount);
    return (nIndex >= 0 && nIndex < nCount) ? m_arDays.GetAt(nIndex) : NULL;
}
Group

CXTPCalendarViewT Methods


CXTPCalendarViewT::GetViewDay_ Method

CXTPCalendarViewT Methods, CXTPCalendarViewT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT::GetViewDay_ Method

Call this member function to get the CXTPCalendarViewDay object by day's index.

virtual CXTPCalendarViewDay* GetViewDay_(
    int nIndex
);
Parameters

nIndex
An int that contains the day view index in the view collection.

Returns

A pointer to a CXTPCalendarViewDay object.

Remarks

Index numbers start with 0 and cannot be negative.

See Also

GetViewDayCount()

Body Source
virtual CXTPCalendarViewDay* GetViewDay_(int nIndex)
{
    ASSERT(this);
    _TViewDay* pViewDay = this ? GetViewDay(nIndex) : NULL;
    return pViewDay;
}
Group

CXTPCalendarViewT Methods


CXTPCalendarViewT::GetViewDayCount Method

CXTPCalendarViewT Methods, CXTPCalendarViewT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT::GetViewDayCount Method

Call this member function to obtain the number of day views in the view collection.

virtual int GetViewDayCount();
Returns

An int that contains the number of day views.

Body Source
virtual int GetViewDayCount() {
    return m_arDays.GetCount();
}
Group

CXTPCalendarViewT Methods


CXTPCalendarViewT::GetViewType Method

CXTPCalendarViewT Methods, CXTPCalendarViewT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT::GetViewType Method

Call this member function to obtain the view type flag.

virtual XTPCalendarViewType GetViewType();
Returns

An XTPCalendarViewType object that contains the view type flag.

See Also

XTPCalendarViewType

Body Source
virtual XTPCalendarViewType GetViewType() {
    return m_nViewType;
}
Group

CXTPCalendarViewT Methods


CXTPCalendarViewT::HitTest Method

CXTPCalendarViewT Methods, CXTPCalendarViewT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT::HitTest Method

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.

virtual BOOL HitTest(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO* pHitTest
);
Parameters

pt
A CPoint object that contains the coordinates of the point to test.
pHitTest
A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains information about the point to test.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

See Also

XTP_CALENDAR_HITTESTINFO

Body Source
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest)
{
    ASSERT(pHitTest);

    _THitTest hitInfo;
    BOOL bRes = HitTestEx(pt, &hitInfo);
    if (bRes && pHitTest) {
        *pHitTest = (XTP_CALENDAR_HITTESTINFO)hitInfo;
    }
    return bRes;
}
Group

CXTPCalendarViewT Methods


CXTPCalendarViewT::HitTestEx Method

CXTPCalendarViewT Methods, CXTPCalendarViewT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT::HitTestEx Method

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a _THitTest object.

virtual BOOL HitTestEx(
    CPoint pt,
    _THitTest* pHitTest
);
Parameters

pt
A CPoint object that contains the coordinates of the point to test.
pHitTest
A pointer to the template parameter _THitTest object that contains information on the point to test.

Returns

TRUE if item found; FALSE otherwise.

Body Source
virtual BOOL HitTestEx(CPoint pt, _THitTest* pHitTest)
{
    if (!pHitTest) {
        ASSERT(FALSE);
        return FALSE;
    }
    int nCount = GetViewDayCount();
    for (int i = 0; i < nCount; i++)
    {
        _TViewDay* pViewDay = GetViewDay(i);
        ASSERT(pViewDay);
        if (pViewDay && pViewDay->HitTestEx(pt, pHitTest))
        {
            ASSERT(!pHitTest->pViewDay || pHitTest->pViewDay == pViewDay);

            pHitTest->nDay = i;
            pHitTest->pViewDay = pViewDay;
            return TRUE;
        }
    }
    return FALSE;
}
Group

CXTPCalendarViewT Methods


CXTPCalendarViewT Constructors

CXTPCalendarViewT Template, Legend, Public Methods
CXTPCalendarViewT Constructors
Template

CXTPCalendarViewT Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewT | Default object constructor.


CXTPCalendarViewT::CXTPCalendarViewT Constructor

CXTPCalendarViewT Constructors, CXTPCalendarViewT Template, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT::CXTPCalendarViewT Constructor

Default object constructor.

CXTPCalendarViewT(
    CXTPCalendarControl* pCalendarControl,
    XTPCalendarViewType nViewType
);
Parameters

pCalendarControl
A pointer to a CXTPCalendarControlT object.
nViewType
An XTPCalendarViewType object that contains the view type identifier.

See Also

XTPCalendarViewType, ~CXTPCalendarEventT()

Body Source
CXTPCalendarViewT (CXTPCalendarControl* pCalendarControl, XTPCalendarViewType nViewType) :
    CXTPCalendarView(pCalendarControl)
{
    m_nViewType = nViewType;
}
Group

CXTPCalendarViewT Constructors


CXTPCalendarViewT Destructors

CXTPCalendarViewT Template, Legend, Public Methods
CXTPCalendarViewT Destructors
Template

CXTPCalendarViewT Template

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarViewT | Default class destructor.


CXTPCalendarViewT::~CXTPCalendarViewT Destructor

CXTPCalendarViewT Destructors, CXTPCalendarViewT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarViewT::~CXTPCalendarViewT Destructor

Default class destructor.

virtual ~CXTPCalendarViewT();
Remarks

Handles member item deallocation.

Body Source
virtual ~CXTPCalendarViewT() {
}
Group

CXTPCalendarViewT Destructors


CXTPCalendarWeekView Class

XTPCalendarWeekView.h, Classes, Legend, Members, Topics, CXTPCalendarWeekView Structures, CXTPCalendarWeekView Data Members, CXTPCalendarWeekView Methods, CXTPCalendarWeekView Constructors, CXTPCalendarWeekView Destructors, CXTPCalendarWeekView Nested Types, CXTPCalendarWeekView Constructors, CXTPCalendarWeekView Data Members, CXTPCalendarWeekView Destructors, CXTPCalendarWeekView Methods, CXTPCalendarWeekView Nested Types, See Also, CXTPCalendarWeekView Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView Class

This class implements a specific view portion of the Calendar control - called Week view.

Class Hierarchy

class CXTPCalendarWeekView : public CXTPCalendarViewT< CXTPCalendarWeekViewDay, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW>;
File

XTPCalendarWeekView.h

Remarks

The Week view can be shown as one week, consisting of 7 days, as a normal week contains. Weekend days of the week are drawn compressed, which means that 2 weekend days will be drawn in a rectangle of a usual day. Each day is represented by a CXTPCalendarWeekViewDay class.

See Also

CXTPCalendarView, CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTPCalendarWeekView Constructors
CXTPCalendarWeekView Constructors | Description
CXTPCalendarWeekView | Default object constructor.
CXTPCalendarWeekView Data Members
CXTPCalendarWeekView Data Members | Description
m_dtBeginDate | First date of week (Monday's date).
m_LayoutX | Layout data.
m_nCurrPos | Current scrollbar position.
m_nFirstDayOfWeekIndex | Index for first weekday.
CXTPCalendarWeekView Destructors
CXTPCalendarWeekView Destructors | Description
~CXTPCalendarWeekView | Default class destructor.
CXTPCalendarWeekView Methods
CXTPCalendarWeekView Methods | Description
AdjustFirstDayOfWeek | Call this member function to adjust the first day of the week.
AdjustLayout | This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the view contents using the specified device context.
Draw2 | This member function is used to draw the view contents using the specified device context.
GetBeginDate | This member function is used to obtain the date of the current week's Monday.
GetDayHeaderHeight | This member function is used to obtain the header height of a day.
GetDayHeidht | This member function is used to obtain the height of a week's day rectangle.
GetDayWidth | This member function is used to obtain the width of the weeks day rectangle.
GetScrollBarInfoV | This member function is used to retrieve information about a scroll bar state.
GetViewDayDate | Call this member function to obtain the date of a day view by the day's index.
OnKeyDown | This member function is used to process keyboard on-key-down events.
Populate | This member function is used to populate the view with data for all items contained in the view.
ScrollV | This member function is used to scroll the contents of a view.
SetBeginDate | This member function is used to set the date of a week's Monday.
ShowDay | This member function is used to show the specified day in the calendar view.
CXTPCalendarWeekView Nested Types
CXTPCalendarWeekView Nested Types | Description
TBase | Base class type definition.
CXTPCalendarWeekView Structures
CXTPCalendarWeekView Structures | Description
XTP_WEEK_VIEW_LAYOUT | This struct store a Week View layout.


CXTPCalendarWeekView Structures

CXTPCalendarWeekView Class, Legend, Structures
CXTPCalendarWeekView Structures
Class

CXTPCalendarWeekView Class

Legend
Structure
Structures
Structure | Description
XTP_WEEK_VIEW_LAYOUT | This struct store a Week View layout.


CXTPCalendarWeekView::XTP_WEEK_VIEW_LAYOUT Structure

XTPCalendarWeekView.h, CXTPCalendarWeekView Structures
CXTPCalendarWeekView::XTP_WEEK_VIEW_LAYOUT Structure

This struct store a Week View layout.

struct XTP_WEEK_VIEW_LAYOUT {
  int m_nGridColumns;
  int m_nDayHeaderHeight;
  int m_nDayWidth;
  int m_nDayHeidht;
};
File

XTPCalendarWeekView.h

Members

m_nGridColumns
Number of columns in a week day grid.
m_nDayHeaderHeight
Height of a day header.
m_nDayWidth
Width of day rectangle.
m_nDayHeidht
Height of day rectangle.

Group

CXTPCalendarWeekView Structures


CXTPCalendarWeekView Data Members

CXTPCalendarWeekView Class, Legend, Protected Data Members
CXTPCalendarWeekView Data Members
Class

CXTPCalendarWeekView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dtBeginDate | First date of week (Monday's date).
m_LayoutX | Layout data.
m_nCurrPos | Current scrollbar position.
m_nFirstDayOfWeekIndex | Index for first weekday.


CXTPCalendarWeekView::m_dtBeginDate Data Member

CXTPCalendarWeekView Data Members, CXTPCalendarWeekView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::m_dtBeginDate Data Member

First date of week (Monday's date).

COleDateTime m_dtBeginDate;
Group

CXTPCalendarWeekView Data Members


CXTPCalendarWeekView::m_LayoutX Data Member

CXTPCalendarWeekView Data Members, CXTPCalendarWeekView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::m_LayoutX Data Member

Layout data.

XTP_WEEK_VIEW_LAYOUT m_LayoutX;
Group

CXTPCalendarWeekView Data Members


CXTPCalendarWeekView::m_nCurrPos Data Member

CXTPCalendarWeekView Data Members, CXTPCalendarWeekView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::m_nCurrPos Data Member

Current scrollbar position.

int m_nCurrPos;
Group

CXTPCalendarWeekView Data Members


CXTPCalendarWeekView::m_nFirstDayOfWeekIndex Data Member

CXTPCalendarWeekView Data Members, CXTPCalendarWeekView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::m_nFirstDayOfWeekIndex Data Member

Index for first weekday.

int m_nFirstDayOfWeekIndex;
Group

CXTPCalendarWeekView Data Members


CXTPCalendarWeekView Methods

CXTPCalendarWeekView Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView Methods
Class

CXTPCalendarWeekView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AdjustFirstDayOfWeek | Call this member function to adjust the first day of the week.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the view contents using the specified device context.
Draw2 | This member function is used to draw the view contents using the specified device context.
GetBeginDate | This member function is used to obtain the date of the current week's Monday.
GetDayHeaderHeight | This member function is used to obtain the header height of a day.
GetDayHeidht | This member function is used to obtain the height of a week's day rectangle.
GetDayWidth | This member function is used to obtain the width of the weeks day rectangle.
GetScrollBarInfoV | This member function is used to retrieve information about a scroll bar state.
GetViewDayDate | Call this member function to obtain the date of a day view by the day's index.
OnKeyDown | This member function is used to process keyboard on-key-down events.
Populate | This member function is used to populate the view with data for all items contained in the view.
ScrollV | This member function is used to scroll the contents of a view.
SetBeginDate | This member function is used to set the date of a week's Monday.
ShowDay | This member function is used to show the specified day in the calendar view.


CXTPCalendarWeekView::AdjustFirstDayOfWeek Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class
CXTPCalendarWeekView::AdjustFirstDayOfWeek Method

Call this member function to adjust the first day of the week.

virtual void AdjustFirstDayOfWeek();
Remarks

The first day of the week depends on regions.

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::AdjustLayout Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class
CXTPCalendarWeekView::AdjustLayout Method

This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcView,
    BOOL bCallPostAdjustLayout = TRUE
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcView,
    BOOL bCallPostAdjustLayout = TRUE
);
Parameters

pDC
A pointer to a valid device context.
rcView
A CRect that contains the rectangle coordinates used to draw the view.
bCallPostAdjustLayout
A BOOL. Flag used to call additional adjustments.

Remarks

Call Populate() prior calling adjust AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::Draw Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::Draw Method

This member function is used to draw the view contents using the specified device context.

virtual void Draw(
    CDC* pDC
);
virtual void Draw2(
    CDC* pDC
);
Parameters

pDC
A pointer to a valid device context.

Remarks

Call AdjustLayout() before calling Draw(). Draw2 is called by calendar control instead of Draw when theme is set.

See Also

AdjustLayout().

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::GetBeginDate Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::GetBeginDate Method

This member function is used to obtain the date of the current week's Monday.

COleDateTime GetBeginDate() const;
Returns

A COleDateTime object that contains the current week's Monday date.

See Also

SetBeginDate()

Body Source
COleDateTime CXTPCalendarWeekView::GetBeginDate() const {
    return m_dtBeginDate;
}
Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::GetDayHeaderHeight Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::GetDayHeaderHeight Method

This member function is used to obtain the header height of a day.

int GetDayHeaderHeight() const;
Returns

An int that contains the height of a row required to display a single event.

Body Source
int CXTPCalendarWeekView::GetDayHeaderHeight() const {
    return m_LayoutX.m_nDayHeaderHeight;
}
Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::GetDayHeidht Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::GetDayHeidht Method

This member function is used to obtain the height of a week's day rectangle.

int GetDayHeidht() const;
Returns

An int that contains the height of a day rectangle.

Body Source
int CXTPCalendarWeekView::GetDayHeidht() const {
    return m_LayoutX.m_nDayHeidht;
}
Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::GetDayWidth Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::GetDayWidth Method

This member function is used to obtain the width of the weeks day rectangle.

int GetDayWidth() const;
Returns

An int that contains the width of the day rectangle.

Body Source
int CXTPCalendarWeekView::GetDayWidth() const {
    return m_LayoutX.m_nDayWidth;
}
Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::GetScrollBarInfoV Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class
CXTPCalendarWeekView::GetScrollBarInfoV Method

This member function is used to retrieve information about a scroll bar state.

virtual BOOL GetScrollBarInfoV(
    SCROLLINFO* pSI
);
Parameters

pSI
A pointer to a scrollbar information structure.

Returns

A BOOL. This function should return TRUE to indicate success. FALSE otherwise.

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::GetViewDayDate Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::GetViewDayDate Method

Call this member function to obtain the date of a day view by the day's index.

virtual COleDateTime GetViewDayDate(
    int nIndex
);
Parameters

nIndex
An int that contains the day view index in the view collection.

Returns

A COleDateTime object that contains the day view date and time.

Remarks

Index number starts with 0 and cannot be negative.

See Also

GetViewDayCount()

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::OnKeyDown Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class
CXTPCalendarWeekView::OnKeyDown Method

This member function is used to process keyboard on-key-down events.

virtual void OnKeyDown(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT that contains the virtual key code of the given key.
nRepCnt
A UINT that contains the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT that contains the scan code, key-transition code, previous key state, and the context code.

Remarks

This method is called by the CalendarControl when the user presses keys on the keyboard.

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::Populate Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class
CXTPCalendarWeekView::Populate Method

This member function is used to populate the view with data for all items contained in the view.

virtual void Populate();
Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::ScrollV Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::ScrollV Method

This member function is used to scroll the contents of a view.

virtual void ScrollV(
    int nPos,
    int nPos_raw
);
Parameters

nPos
An int that contains the position value.
nPos_raw
An int that contains the raw position value.

Remarks

ScrollV internally uses Populate() to fill the new view data.

See Also

Populate().

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::SetBeginDate Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::SetBeginDate Method

This member function is used to set the date of a week's Monday.

void SetBeginDate(
    COleDateTime dtNewBeginDate
);
Parameters

dtNewBeginDate
A COleDateTime object that contains the date of Monday.

Remarks

Call this member function to set the date of a week to the Monday of the current week.

See Also

GetBeginDate()

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView::ShowDay Method

CXTPCalendarWeekView Methods, CXTPCalendarWeekView Class
CXTPCalendarWeekView::ShowDay Method

This member function is used to show the specified day in the calendar view.

virtual void ShowDay(
    const COleDateTime& date,
    BOOL bSelect = TRUE
);
Parameters

date
A COleDateTime object that contains the date to show.
bSelect
TRUE to select the specified day after showing, FALSE otherwise. TRUE is the default value.

Remarks

Call this member function to show only the specified day in the calendar view.

Group

CXTPCalendarWeekView Methods


CXTPCalendarWeekView Constructors

CXTPCalendarWeekView Class, Legend, Public Methods
CXTPCalendarWeekView Constructors
Class

CXTPCalendarWeekView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWeekView | Default object constructor.


CXTPCalendarWeekView::CXTPCalendarWeekView Constructor

CXTPCalendarWeekView Constructors, CXTPCalendarWeekView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::CXTPCalendarWeekView Constructor

Default object constructor.

CXTPCalendarWeekView(
    CXTPCalendarControl* pCalendarControl
);
Parameters

pCalendarControl
Pointer to CXTPCalendarControl object.

See Also

~CXTPCalendarEvent()

Group

CXTPCalendarWeekView Constructors


CXTPCalendarWeekView Destructors

CXTPCalendarWeekView Class, Legend, Public Methods
CXTPCalendarWeekView Destructors
Class

CXTPCalendarWeekView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarWeekView | Default class destructor.


CXTPCalendarWeekView::~CXTPCalendarWeekView Destructor

CXTPCalendarWeekView Destructors, CXTPCalendarWeekView Class
CXTPCalendarWeekView::~CXTPCalendarWeekView Destructor

Default class destructor.

virtual ~CXTPCalendarWeekView();
Remarks

Handles member items deallocation.

Group

CXTPCalendarWeekView Destructors


CXTPCalendarWeekView Nested Types

CXTPCalendarWeekView Class, Public Nested Types
CXTPCalendarWeekView Nested Types
Class

CXTPCalendarWeekView Class

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition.


CXTPCalendarWeekView::TBase Nested Type

CXTPCalendarWeekView Nested Types, CXTPCalendarWeekView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekView::TBase Nested Type

Base class type definition.

typedef CXTPCalendarViewT< CXTPCalendarWeekViewDay, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW> TBase;
Group

CXTPCalendarWeekView Nested Types


CXTPCalendarWeekViewDay Class

XTPCalendarWeekViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Constructors, CXTPCalendarWeekViewDay Destructors, CXTPCalendarWeekViewDay Nested Types, CXTPCalendarWeekViewDay Constructors, CXTPCalendarWeekViewDay Destructors, CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay Class

This class represents a day view portion of the CalendarWeekView.

Class Hierarchy

class CXTPCalendarWeekViewDay : public CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW, CXTPCalendarWeekViewDay >;
File

XTPCalendarWeekViewDay.h

Remarks

It represents a specific view of the CalendarView's associated events data grouped by one day and provides basic functionality on this data using user input through the keyboard and mouse.

CXTPCalendarWeekViewDay is based on the CXTPCalendarViewDayT template class. CXTPCalendarWeekViewDay inherits basic behavior from the CXTPCalendarViewDayT class. Furthermore, class CXTPCalendarWeekViewDayand overlaps and adds some functionality for its own behavior and look.

See Also

CXTPCalendarViewDay, CXTPCalendarViewDayT

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarWeekViewDay Constructors
CXTPCalendarWeekViewDay Constructors | Description
CXTPCalendarWeekViewDay | Default object constructor. Construct CXTPCalendarWeekViewDay object.
CXTPCalendarWeekViewDay Destructors
CXTPCalendarWeekViewDay Destructors | Description
~CXTPCalendarWeekViewDay | Default class destructor.
CXTPCalendarWeekViewDay Methods
CXTPCalendarWeekViewDay Methods | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the view content using the specified device context.
FillHitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.
GetCaption | This member function is used to obtain a single day's view caption.
GetDayEventsRect | This function is used to obtain a portion of a day rectangle used to draw event views.
GetPThis | This member function is used to obtain a pointer to itself.
HitTestEx | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.
OnLButtonDown | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
CXTPCalendarWeekViewDay Nested Types
CXTPCalendarWeekViewDay Nested Types | Description
TBase | Base class type definition.


CXTPCalendarWeekViewDay Methods

CXTPCalendarWeekViewDay Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay Methods
Class

CXTPCalendarWeekViewDay Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetPThis | This member function is used to obtain a pointer to itself.
OnLButtonDown | This member function is used to processes left mouse button events.
OnMouseMove | This member function is used to processes mouse movement events.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
Draw | This member function is used to draw the view content using the specified device context.
FillHitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.
GetCaption | This member function is used to obtain a single day's view caption.
GetDayEventsRect | This function is used to obtain a portion of a day rectangle used to draw event views.
HitTestEx | This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.


CXTPCalendarWeekViewDay::AdjustLayout Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcDay
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcDay
);
Parameters

pDC
A pointer to a valid device context.
rcDay
A CRect object that contains the rectangle coordinates used to draw the day view.

Remarks

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout().

Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay::Draw Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::Draw Method

This member function is used to draw the view content using the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
A pointer to a valid device context.

Remarks

Call AdjustLayout() before calling Draw().

See Also

AdjustLayout(CRect rcDay)

Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay::FillHitTestEx Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::FillHitTestEx Method

This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.

virtual void FillHitTestEx(
    XTP_CALENDAR_HITTESTINFO_WEEK_VIEW* pInfo
);
Parameters

pInfo
A pointer to a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW struct.

Remarks

Call this member function to gather hit test information from the week view.

See Also

XTP_CALENDAR_HITTESTINFO_WEEK_VIEW

Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay::GetCaption Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::GetCaption Method

This member function is used to obtain a single day's view caption.

virtual CString GetCaption();
Returns

A CString object that contains the day's view caption.

Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay::GetDayEventsRect Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::GetDayEventsRect Method

This function is used to obtain a portion of a day rectangle used to draw event views.

CRect GetDayEventsRect() const;
Returns

A CRect object that contains the rectangle coordinates.

Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay::GetPThis Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::GetPThis Method

This member function is used to obtain a pointer to itself.

virtual CXTPCalendarWeekViewDay* GetPThis();
Returns

A pointer to a CXTPCalendarWeekViewDay object.

Body Source
CXTPCalendarWeekViewDay* CXTPCalendarWeekViewDay::GetPThis() {
    return this;
}
Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay::HitTestEx Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::HitTestEx Method

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the _THitTest template object.

virtual BOOL HitTestEx(
    CPoint pt,
    XTP_CALENDAR_HITTESTINFO_WEEK_VIEW* pHitTest
);
Parameters

pt
A CPoint that contains the coordinates of the point test.
pHitTest
A pointer to a _THitTest structure.

Returns

A BOOL. TRUE if the item is found. FALSE otherwise.

Remarks

Implements standard functionality for the HitTestEx method.

See Also

XTP_CALENDAR_HITTESTINFO

Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay::OnLButtonDown Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::OnLButtonDown Method

This member function is used to processes left mouse button events.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicates whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user presses the left mouse button.

Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay::OnMouseMove Method

CXTPCalendarWeekViewDay Methods, CXTPCalendarWeekViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::OnMouseMove Method

This member function is used to processes mouse movement events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Group

CXTPCalendarWeekViewDay Methods


CXTPCalendarWeekViewDay Constructors

CXTPCalendarWeekViewDay Class, Legend, Public Methods
CXTPCalendarWeekViewDay Constructors
Class

CXTPCalendarWeekViewDay Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWeekViewDay | Default object constructor. Construct CXTPCalendarWeekViewDay object.


CXTPCalendarWeekViewDay::CXTPCalendarWeekViewDay Constructor

CXTPCalendarWeekViewDay Constructors, CXTPCalendarWeekViewDay Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::CXTPCalendarWeekViewDay Constructor

Default object constructor. Construct CXTPCalendarWeekViewDay object.

CXTPCalendarWeekViewDay(
    CXTPCalendarWeekView* pWeekView
);
Parameters

pWeekView
Pointer to CXTPCalendarWeekView object.

See Also

~CXTPCalendarWeekViewDay()

Group

CXTPCalendarWeekViewDay Constructors


CXTPCalendarWeekViewDay Destructors

CXTPCalendarWeekViewDay Class, Legend, Public Methods
CXTPCalendarWeekViewDay Destructors
Class

CXTPCalendarWeekViewDay Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarWeekViewDay | Default class destructor.


CXTPCalendarWeekViewDay::~CXTPCalendarWeekViewDay Destructor

CXTPCalendarWeekViewDay Destructors, CXTPCalendarWeekViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::~CXTPCalendarWeekViewDay Destructor

Default class destructor.

virtual ~CXTPCalendarWeekViewDay();
Remarks

Handles member items deallocation.

Group

CXTPCalendarWeekViewDay Destructors


CXTPCalendarWeekViewDay Nested Types

CXTPCalendarWeekViewDay Class, Public Nested Types
CXTPCalendarWeekViewDay Nested Types
Class

CXTPCalendarWeekViewDay Class

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition.


CXTPCalendarWeekViewDay::TBase Nested Type

CXTPCalendarWeekViewDay Nested Types, CXTPCalendarWeekViewDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewDay::TBase Nested Type

Base class type definition.

typedef CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW, CXTPCalendarWeekViewDay> TBase;
Group

CXTPCalendarWeekViewDay Nested Types


CXTPCalendarWeekViewEvent Class

XTPCalendarWeekViewEvent.h, Classes, Legend, Members, Topics, CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Constructors, CXTPCalendarWeekViewEvent Destructors, CXTPCalendarWeekViewEvent Nested Types, CXTPCalendarWeekViewEvent Constructors, CXTPCalendarWeekViewEvent Destructors, CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent Class

This class represents an event view portion of the CalendarWeekViewDay.

Class Hierarchy

class CXTPCalendarWeekViewEvent : public CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW >;
File

XTPCalendarWeekViewEvent.h

Remarks

It represents a specific view of the event associated data according to various view types and display settings and provides basic functionality on this data using user input through the keyboard and mouse.

CXTPCalendarWeekViewEvent is based on CXTPCalendarViewEventT template class. CXTPCalendarWeekViewEvent inherits basic behavior from CXTPCalendarViewEventT. Furthermore, CXTPCalendarWeekViewEvent overlaps some functionality in CXTPCalendarViewEventT and also adds some new functionality for its own behavior and look.

See Also

CXTPCalendarViewEvent, CXTPCalendarViewEventT

Group

Classes

Legend
Method
virtual
protected
CXTPCalendarWeekViewEvent Constructors
CXTPCalendarWeekViewEvent Constructors | Description
CXTPCalendarWeekViewEvent | Default object constructor.
CXTPCalendarWeekViewEvent Destructors
CXTPCalendarWeekViewEvent Destructors | Description
~CXTPCalendarWeekViewEvent | Default class destructor.
CXTPCalendarWeekViewEvent Methods
CXTPCalendarWeekViewEvent Methods | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
CalcIconsRect | This member function is used to adjust rectangles used to draw event view icons.
Draw | This member function is used to draw the view content using the specified device context.
GetSubjectEditorFont | Call this member function to determine the editor window font.
GetViewRect | Call this member function to get the day view rectangle coordinates.
HitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.
IsShowEndTime | Call this member function to determine the value of the "show end time" flag.
IsTimeAsClock | Call this member function to determine the value of the "show time as clock" flag.
IsVisible | Call this member function to determine if the "view visible" flag is set.
OnPostAdjustLayout | This member function is used to perform additional adjustments.
CXTPCalendarWeekViewEvent Nested Types
CXTPCalendarWeekViewEvent Nested Types | Description
TBase | Base class type definition.


CXTPCalendarWeekViewEvent Methods

CXTPCalendarWeekViewEvent Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent Methods
Class

CXTPCalendarWeekViewEvent Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetSubjectEditorFont | Call this member function to determine the editor window font.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
AdjustLayout2 | This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
CalcIconsRect | This member function is used to adjust rectangles used to draw event view icons.
Draw | This member function is used to draw the view content using the specified device context.
GetViewRect | Call this member function to get the day view rectangle coordinates.
HitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.
IsShowEndTime | Call this member function to determine the value of the "show end time" flag.
IsTimeAsClock | Call this member function to determine the value of the "show time as clock" flag.
IsVisible | Call this member function to determine if the "view visible" flag is set.
OnPostAdjustLayout | This member function is used to perform additional adjustments.


CXTPCalendarWeekViewEvent::AdjustLayout Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::AdjustLayout Method

This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.

virtual void AdjustLayout(
    CDC* pDC,
    const CRect& rcEventMax,
    int nEventPlaceNumber
);
virtual void AdjustLayout2(
    CDC* pDC,
    const CRect& rcEventMax,
    int nEventPlaceNumber
);
Parameters

pDC
A pointer to a valid device context.
rcEventMax
An int that contains the rectangle coordinates used to draw the view.
nEventPlaceNumber
An int that contains the sequential place number.

Remarks

Call Populate(COleDateTime dtDayDate) prior calling AdjustLayout().

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::CalcIconsRect Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::CalcIconsRect Method

This member function is used to adjust rectangles used to draw event view icons.

virtual int CalcIconsRect(
    CRect rc
);
Parameters

rc
A CRect that contains the rectangle coordinates used to draw the view.

Remarks

Call this member function to calculate rectangles to draw event view icons. Depends on what glyphs should be drawn based on the event view rect.

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::Draw Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::Draw Method

This member function is used to draw the view content using the specified device context.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
A pointer to a valid device context.

Remarks

Call AdjustLayout() before calling Draw().

See Also

AdjustLayout(CRect rcDay)

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::GetSubjectEditorFont Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::GetSubjectEditorFont Method

Call this member function to determine the editor window font.

virtual CFont* GetSubjectEditorFont();
Returns

A pointer to a CFont object that contains the editor window font.

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::GetViewRect Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::GetViewRect Method

Call this member function to get the day view rectangle coordinates.

CRect GetViewRect();
Returns

A CRect object with the day rectangle coordinates.

See Also

SetDayRect(CRect rcDay)

Body Source
CRect CXTPCalendarWeekViewEvent::GetViewRect() {
    return m_rcEvent;
}
Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::HitTestEx Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::HitTestEx Method

This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.

virtual BOOL HitTestEx(
    CPoint point,
    XTP_CALENDAR_HITTESTINFO_WEEK_VIEW* pInfo
);
Parameters

point
A CPoint object that contains the point to test.
pInfo
A pointer to a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW struct.

Remarks

Call this member function to gather hit test information from the day view.

See Also

XTP_CALENDAR_HITTESTINFO_WEEK_VIEW

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::IsShowEndTime Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::IsShowEndTime Method

Call this member function to determine the value of the "show end time" flag.

BOOL IsShowEndTime();
Returns

A BOOL. TRUE if "show end time" flag is set. FALSE otherwise.

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::IsTimeAsClock Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::IsTimeAsClock Method

Call this member function to determine the value of the "show time as clock" flag.

BOOL IsTimeAsClock();
Returns

A BOOL. TRUE if the "show time as clock" flag is set. FALSE otherwise.

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::IsVisible Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::IsVisible Method

Call this member function to determine if the "view visible" flag is set.

virtual BOOL IsVisible();
Returns

A BOOL. TRUE if the "view visible" is set. FALSE otherwise.

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent::OnPostAdjustLayout Method

CXTPCalendarWeekViewEvent Methods, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::OnPostAdjustLayout Method

This member function is used to perform additional adjustments.

virtual void OnPostAdjustLayout();
Remarks

Call this member function to perform additional adjustments after all adjustment activities are completed.

Group

CXTPCalendarWeekViewEvent Methods


CXTPCalendarWeekViewEvent Constructors

CXTPCalendarWeekViewEvent Class, Legend, Public Methods
CXTPCalendarWeekViewEvent Constructors
Class

CXTPCalendarWeekViewEvent Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWeekViewEvent | Default object constructor.


CXTPCalendarWeekViewEvent::CXTPCalendarWeekViewEvent Constructor

CXTPCalendarWeekViewEvent Constructors, CXTPCalendarWeekViewEvent Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::CXTPCalendarWeekViewEvent Constructor

Default object constructor.

CXTPCalendarWeekViewEvent(
    CXTPCalendarEvent* pEvent,
    CXTPCalendarWeekViewGroup* pViewGroup
);
Parameters

pEvent
A pointer to a CXTPCalendarEvent.
pViewGroup
A pointer to a CXTPCalendarWeekViewGroup object.

See Also

~CXTPCalendarWeekViewDay()

Group

CXTPCalendarWeekViewEvent Constructors


CXTPCalendarWeekViewEvent Destructors

CXTPCalendarWeekViewEvent Class, Legend, Public Methods
CXTPCalendarWeekViewEvent Destructors
Class

CXTPCalendarWeekViewEvent Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarWeekViewEvent | Default class destructor.


CXTPCalendarWeekViewEvent::~CXTPCalendarWeekViewEvent Destructor

CXTPCalendarWeekViewEvent Destructors, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::~CXTPCalendarWeekViewEvent Destructor

Default class destructor.

virtual ~CXTPCalendarWeekViewEvent();
Group

CXTPCalendarWeekViewEvent Destructors


CXTPCalendarWeekViewEvent Nested Types

CXTPCalendarWeekViewEvent Class, Public Nested Types
CXTPCalendarWeekViewEvent Nested Types
Class

CXTPCalendarWeekViewEvent Class

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition.


CXTPCalendarWeekViewEvent::TBase Nested Type

CXTPCalendarWeekViewEvent Nested Types, CXTPCalendarWeekViewEvent Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewEvent::TBase Nested Type

Base class type definition.

typedef CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW> TBase;
Group

CXTPCalendarWeekViewEvent Nested Types


CXTPCalendarWeekViewGroup Class

XTPCalendarWeekViewDay.h, Classes, Legend, Members, Topics, CXTPCalendarWeekViewGroup Methods, CXTPCalendarWeekViewGroup Constructors, CXTPCalendarWeekViewGroup Destructors, CXTPCalendarWeekViewGroup Nested Types, CXTPCalendarWeekViewGroup Constructors, CXTPCalendarWeekViewGroup Destructors, CXTPCalendarWeekViewGroup Methods, CXTPCalendarWeekViewGroup Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewGroup Class

This class represents a single resource view portion of the Calendar Week View.

Class Hierarchy

class CXTPCalendarWeekViewGroup : public CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW, CXTPCalendarWeekViewGroup >;
File

XTPCalendarWeekViewDay.h

Remarks

It represents a specific view of the CalendarView's associated events data grouped by one day and one resource group. And provides basic functionality on this data using user input through keyboard and mouse.

See Also

CXTPCalendarWeekViewDay

Group

Classes

Legend
Method
protected
virtual
CXTPCalendarWeekViewGroup Constructors
CXTPCalendarWeekViewGroup Constructors | Description
CXTPCalendarWeekViewGroup | Default object constructor. Construct CXTPCalendarWeekViewGroup object.
CXTPCalendarWeekViewGroup Destructors
CXTPCalendarWeekViewGroup Destructors | Description
~CXTPCalendarWeekViewGroup | Default class destructor.
CXTPCalendarWeekViewGroup Methods
CXTPCalendarWeekViewGroup Methods | Description
FillHitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.
CXTPCalendarWeekViewGroup Nested Types
CXTPCalendarWeekViewGroup Nested Types | Description
TBase | Base class type definition.


CXTPCalendarWeekViewGroup Methods

CXTPCalendarWeekViewGroup Class, Legend, Protected Methods
CXTPCalendarWeekViewGroup Methods
Class

CXTPCalendarWeekViewGroup Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
FillHitTestEx | This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.


CXTPCalendarWeekViewGroup::FillHitTestEx Method

CXTPCalendarWeekViewGroup Methods, CXTPCalendarWeekViewGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewGroup::FillHitTestEx Method

This member function is used to fill a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW structure.

virtual void FillHitTestEx(
    XTP_CALENDAR_HITTESTINFO_WEEK_VIEW* pHitTest
);
Parameters

pHitTest
A pointer to a XTP_CALENDAR_HITTESTINFO_WEEK_VIEW struct.

Remarks

Call this member function to gather hit test information from the week view group.

See Also

XTP_CALENDAR_HITTESTINFO_WEEK_VIEW

Group

CXTPCalendarWeekViewGroup Methods


CXTPCalendarWeekViewGroup Constructors

CXTPCalendarWeekViewGroup Class, Legend, Public Methods
CXTPCalendarWeekViewGroup Constructors
Class

CXTPCalendarWeekViewGroup Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWeekViewGroup | Default object constructor. Construct CXTPCalendarWeekViewGroup object.


CXTPCalendarWeekViewGroup::CXTPCalendarWeekViewGroup Constructor

CXTPCalendarWeekViewGroup Constructors, CXTPCalendarWeekViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewGroup::CXTPCalendarWeekViewGroup Constructor

Default object constructor. Construct CXTPCalendarWeekViewGroup object.

CXTPCalendarWeekViewGroup(
    CXTPCalendarWeekViewDay* pViewDay
);
Parameters

pViewDay
Pointer to CXTPCalendarWeekViewDay object.

Group

CXTPCalendarWeekViewGroup Constructors


CXTPCalendarWeekViewGroup Destructors

CXTPCalendarWeekViewGroup Class, Legend, Public Methods
CXTPCalendarWeekViewGroup Destructors
Class

CXTPCalendarWeekViewGroup Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCalendarWeekViewGroup | Default class destructor.


CXTPCalendarWeekViewGroup::~CXTPCalendarWeekViewGroup Destructor

CXTPCalendarWeekViewGroup Destructors, CXTPCalendarWeekViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewGroup::~CXTPCalendarWeekViewGroup Destructor

Default class destructor.

virtual ~CXTPCalendarWeekViewGroup();
Remarks

Handles class members deallocation.

Group

CXTPCalendarWeekViewGroup Destructors


CXTPCalendarWeekViewGroup Nested Types

CXTPCalendarWeekViewGroup Class, Public Nested Types
CXTPCalendarWeekViewGroup Nested Types
Class

CXTPCalendarWeekViewGroup Class

Public Nested Types
Public Nested Type | Description
TBase | Base class type definition.


CXTPCalendarWeekViewGroup::TBase Nested Type

CXTPCalendarWeekViewGroup Nested Types, CXTPCalendarWeekViewGroup Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWeekViewGroup::TBase Nested Type

Base class type definition.

typedef CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW, CXTPCalendarWeekViewGroup > TBase;
Group

CXTPCalendarWeekViewGroup Nested Types


CXTPCalendarWMHandler Class

XTPCalendarView.h, Classes, Legend, Members, Topics, CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Constructors, CXTPCalendarWMHandler Constructors, CXTPCalendarWMHandler Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWMHandler Class

This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.

Class Hierarchy

class CXTPCalendarWMHandler;
File

XTPCalendarView.h

Remarks

All calendar views are derived from this class. When a message is handled by main Calendar control window (CXTPCalendarControl class), it is then forwarded down to views by hierarchy. control -> day/week/month -> single day -> resource group -> event

Group

Classes

Legend
Method
virtual
CXTPCalendarWMHandler Constructors
CXTPCalendarWMHandler Constructors | Description
CXTPCalendarWMHandler | Default object constructor.
CXTPCalendarWMHandler Methods
CXTPCalendarWMHandler Methods | Description
GetChildHandlerAt | Call this method to get a handler object at the specified numeric index.
GetChildHandlersCount | This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
OnBeforeDestroy | This member function is called by the framework before destroying the view.
OnChar | This member function is used to processes keyboard events.
OnKeyDown | This member function is used to process key-down keyboard events.
OnKeyUp | This member function is used to process key-up keyboard events.
OnLButtonDblClk | This member function is used to process left mouse button double click events.
OnLButtonDown | This member function is used to process left mouse button down events.
OnLButtonUp | This member function is used to process left mouse button up events.
OnMouseMove | This member function is used to process mouse movement events.
OnPostAdjustLayout | This member function is used to perform additional adjustments in some kinds of views.
OnSysKeyDown | This member function is used to process key-up keyboard events.
OnTimer | The framework calls this member function after each interval specified in the SetTimer member function.


CXTPCalendarWMHandler Methods

CXTPCalendarWMHandler Class, Legend, Public Methods
CXTPCalendarWMHandler Methods
Class

CXTPCalendarWMHandler Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetChildHandlerAt | Call this method to get a handler object at the specified numeric index.
GetChildHandlersCount | This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
OnBeforeDestroy | This member function is called by the framework before destroying the view.
OnChar | This member function is used to processes keyboard events.
OnKeyDown | This member function is used to process key-down keyboard events.
OnKeyUp | This member function is used to process key-up keyboard events.
OnLButtonDblClk | This member function is used to process left mouse button double click events.
OnLButtonDown | This member function is used to process left mouse button down events.
OnLButtonUp | This member function is used to process left mouse button up events.
OnMouseMove | This member function is used to process mouse movement events.
OnPostAdjustLayout | This member function is used to perform additional adjustments in some kinds of views.
OnSysKeyDown | This member function is used to process key-up keyboard events.
OnTimer | The framework calls this member function after each interval specified in the SetTimer member function.


CXTPCalendarWMHandler::GetChildHandlerAt Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::GetChildHandlerAt Method

Call this method to get a handler object at the specified numeric index.

virtual CXTPCalendarWMHandler* GetChildHandlerAt(
    int nIndex
);
Parameters

nIndex
An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns

The pointer to the CXTPCalendarWMHandler element currently at this index.

Remarks

Returns the array element at the specified index.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::GetChildHandlersCount Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWMHandler::GetChildHandlersCount Method

This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.

virtual int GetChildHandlersCount();
Returns

A count of descendant handlers.

Remarks

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

This number shows a count of single day views for a day/week/month view, a number of resource groups for a single day view, a number of event views for a resource group view, and so on.

See Also

CXTPCalendarWMHandler overview

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnBeforeDestroy Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnBeforeDestroy Method

This member function is called by the framework before destroying the view.

virtual void OnBeforeDestroy();
Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnChar Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnChar Method

This member function is used to processes keyboard events.

virtual void OnChar(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT that contains the character code value of the key.
nRepCnt
A UINT that is used to count the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT that contains the Scan code, key-transition code, previous key state, and the context code.

Remarks

This method is called by the CalendarControl when a keystroke translates to a nonsystem character.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnKeyDown Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnKeyDown Method

This member function is used to process key-down keyboard events.

virtual void OnKeyDown(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT that specifies the virtual key code of the given key.
nRepCnt
A UINT that specifies the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT that specifies the scan code, key-transition code, previous key state, and the context code.

Remarks

This method is called by the CalendarView when the user presses keys on the keyboard.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnKeyUp Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnKeyUp Method

This member function is used to process key-up keyboard events.

virtual void OnKeyUp(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT that specifies the virtual key code of the given key.
nRepCnt
A UINT that specifies the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT that specifies the scan code, key-transition code, previous key state, and the context code.

Remarks

This method is called by the CalendarView when the user releases keys on the keyboard.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnLButtonDblClk Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnLButtonDblClk Method

This member function is used to process left mouse button double click events.

virtual BOOL OnLButtonDblClk(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
An int that indicates whether various virtual keys are down.
point
A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarView when the user double clicks the left mouse button.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnLButtonDown Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnLButtonDown Method

This member function is used to process left mouse button down events.

virtual BOOL OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
An int that indicates whether various virtual keys are down.
point
A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarView when the user presses the left mouse button.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnLButtonUp Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnLButtonUp Method

This member function is used to process left mouse button up events.

virtual BOOL OnLButtonUp(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
An int that indicates whether various virtual keys are down.
point
A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarView when the user releases the left mouse button.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnMouseMove Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnMouseMove Method

This member function is used to process mouse movement events.

virtual void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that indicates whether various virtual keys are down.
point
A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Remarks

This method is called by the CalendarView when the user moves the mouse cursor or stylus.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnPostAdjustLayout Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnPostAdjustLayout Method

This member function is used to perform additional adjustments in some kinds of views.

virtual void OnPostAdjustLayout();
Remarks

Call this member function to perform additional adjustments after all adjustment activities are completed.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnSysKeyDown Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnSysKeyDown Method

This member function is used to process key-up keyboard events.

virtual BOOL OnSysKeyDown(
    UINT nChar,
    UINT nRepCnt,
    UINT nFlags
);
Parameters

nChar
A UINT that specifies the virtual key code of the given key.
nRepCnt
A UINT that specifies the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags
A UINT that specifies the scan code, key-transition code, previous key state, and the context code.

Remarks

This method is called by the CalendarView when the user presses keys on the keyboard.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler::OnTimer Method

CXTPCalendarWMHandler Methods, CXTPCalendarWMHandler Class
CXTPCalendarWMHandler::OnTimer Method

The framework calls this member function after each interval specified in the SetTimer member function.

virtual BOOL OnTimer(
    UINT_PTR uTimerID
);
Parameters

uTimerID
A UINT that is used to specify the identifier of the timer.

Group

CXTPCalendarWMHandler Methods


CXTPCalendarWMHandler Constructors

CXTPCalendarWMHandler Class, Legend, Public Methods
CXTPCalendarWMHandler Constructors
Class

CXTPCalendarWMHandler Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWMHandler | Default object constructor.


CXTPCalendarWMHandler::CXTPCalendarWMHandler Constructor

CXTPCalendarWMHandler Constructors, CXTPCalendarWMHandler Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCalendarWMHandler::CXTPCalendarWMHandler Constructor

Default object constructor.

CXTPCalendarWMHandler();
Group

CXTPCalendarWMHandler Constructors


CXTPDatePickerButton Class

XTPDatePickerControl.h, Classes, Legend, Members, Topics, CXTPDatePickerButton Data Members, CXTPDatePickerButton Methods, CXTPDatePickerButton Constructors, CXTPDatePickerButton Destructors, CXTPDatePickerButton Constructors, CXTPDatePickerButton Data Members, CXTPDatePickerButton Destructors, CXTPDatePickerButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton Class

This class represents a DatePicker button.

Class Hierarchy

class CXTPDatePickerButton;
File

XTPDatePickerControl.h

Remarks

CXTPDatePickerButton provides storage for all parameters needed to display and handle a button.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDatePickerButton Constructors
CXTPDatePickerButton Constructors | Description
CXTPDatePickerButton | Default button constructor.
CXTPDatePickerButton Data Members
CXTPDatePickerButton Data Members | Description
m_bHighlight | This member variable is used to indicate if a button is highlighted.
m_bPressed | This member variable is used to indicate if a button is pressed.
m_bVisible | This member variable is used to indicate if a button is visible.
m_nID | This member variable is used to specify the identifier of the button.
m_rcButton | This member variable is used to specify the bounding rectangle coordinates of a button.
m_strCaption | This member variable is used to specify the caption of the button.
CXTPDatePickerButton Destructors
CXTPDatePickerButton Destructors | Description
~CXTPDatePickerButton | Destroys a CXTPDatePickerButton object, handles cleanup and de-allocation.
CXTPDatePickerButton Methods
CXTPDatePickerButton Methods | Description
GetCaption | Get a button caption.
SetCaption | Set a button caption.


CXTPDatePickerButton Data Members

CXTPDatePickerButton Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton Data Members
Class

CXTPDatePickerButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_strCaption | This member variable is used to specify the caption of the button.
Public Data Members
Public Data Member | Description
m_bHighlight | This member variable is used to indicate if a button is highlighted.
m_bPressed | This member variable is used to indicate if a button is pressed.
m_bVisible | This member variable is used to indicate if a button is visible.
m_nID | This member variable is used to specify the identifier of the button.
m_rcButton | This member variable is used to specify the bounding rectangle coordinates of a button.


CXTPDatePickerButton::m_bHighlight Data Member

CXTPDatePickerButton Data Members, CXTPDatePickerButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::m_bHighlight Data Member

This member variable is used to indicate if a button is highlighted.

BOOL m_bHighlight;
Group

CXTPDatePickerButton Data Members


CXTPDatePickerButton::m_bPressed Data Member

CXTPDatePickerButton Data Members, CXTPDatePickerButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::m_bPressed Data Member

This member variable is used to indicate if a button is pressed.

BOOL m_bPressed;
Group

CXTPDatePickerButton Data Members


CXTPDatePickerButton::m_bVisible Data Member

CXTPDatePickerButton Data Members, CXTPDatePickerButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::m_bVisible Data Member

This member variable is used to indicate if a button is visible.

BOOL m_bVisible;
Group

CXTPDatePickerButton Data Members


CXTPDatePickerButton::m_nID Data Member

CXTPDatePickerButton Data Members, CXTPDatePickerButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::m_nID Data Member

This member variable is used to specify the identifier of the button.

int m_nID;
Group

CXTPDatePickerButton Data Members


CXTPDatePickerButton::m_rcButton Data Member

CXTPDatePickerButton Data Members, CXTPDatePickerButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::m_rcButton Data Member

This member variable is used to specify the bounding rectangle coordinates of a button.

CRect m_rcButton;
Group

CXTPDatePickerButton Data Members


CXTPDatePickerButton::m_strCaption Data Member

CXTPDatePickerButton Data Members, CXTPDatePickerButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::m_strCaption Data Member

This member variable is used to specify the caption of the button.

CString m_strCaption;
Group

CXTPDatePickerButton Data Members


CXTPDatePickerButton Methods

CXTPDatePickerButton Class, Legend, Public Methods
CXTPDatePickerButton Methods
Class

CXTPDatePickerButton Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetCaption | Get a button caption.
SetCaption | Set a button caption.


CXTPDatePickerButton::GetCaption Method

CXTPDatePickerButton Methods, CXTPDatePickerButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::GetCaption Method

Get a button caption.

virtual CString GetCaption();
Returns

Returns a button caption.

Remarks

Load from resources string using ID stored in m_nID member or value which was set by SetCaption() call.

See Also

m_nID, SetCaption

Group

CXTPDatePickerButton Methods


CXTPDatePickerButton::SetCaption Method

CXTPDatePickerButton Methods, CXTPDatePickerButton Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::SetCaption Method

Set a button caption.

virtual void SetCaption(
    LPCTSTR pcszCaption
);
Parameters

pcszCaption
A caption string.

Remarks

If pcszCaption is empty string - GetCaption will the m_nID to load caption string from resources.

See Also

GetCaption, m_nID

Group

CXTPDatePickerButton Methods


CXTPDatePickerButton Constructors

CXTPDatePickerButton Class, Legend, Public Methods
CXTPDatePickerButton Constructors
Class

CXTPDatePickerButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerButton | Default button constructor.


CXTPDatePickerButton::CXTPDatePickerButton Constructor

CXTPDatePickerButton Constructors, CXTPDatePickerButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::CXTPDatePickerButton Constructor

Default button constructor.

CXTPDatePickerButton();
Remarks

Default button constructor handles all necessary initialization.

Group

CXTPDatePickerButton Constructors


CXTPDatePickerButton Destructors

CXTPDatePickerButton Class, Legend, Public Methods
CXTPDatePickerButton Destructors
Class

CXTPDatePickerButton Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDatePickerButton | Destroys a CXTPDatePickerButton object, handles cleanup and de-allocation.


CXTPDatePickerButton::~CXTPDatePickerButton Destructor

CXTPDatePickerButton Destructors, CXTPDatePickerButton Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButton::~CXTPDatePickerButton Destructor

Destroys a CXTPDatePickerButton object, handles cleanup and de-allocation.

virtual ~CXTPDatePickerButton();
Body Source
virtual ~CXTPDatePickerButton()
{
}
Group

CXTPDatePickerButton Destructors


CXTPDatePickerButtons Class

XTPDatePickerControl.h, Classes, Legend, Members, Topics, CXTPDatePickerButtons Methods, CXTPDatePickerButtons Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerButtons Class

Class CXTPDatePickerButtons represents a collection of buttons.

Class Hierarchy

class CXTPDatePickerButtons : public CArray<CXTPDatePickerButton*, CXTPDatePickerButton*>;
File

XTPDatePickerControl.h

Remarks

CXTPDatePickerButtons inherits most of the behavior of the standard MFC CArray. The DatePicker control can display and handle any number of buttons. CXTPDatePickerButtons provides the basic functionality to handle the collection.

Create a CXTPDatePickerButtons object by calling the default constructor without parameters. Furthermore, add buttons to collection using standard CArray member functions.

See Also

CArray

Group

Classes

Legend
Method
CXTPDatePickerButtons Methods
CXTPDatePickerButtons Methods | Description
Find | This member function finds buttons by their ID property.
GetVisibleButtonCount | Call this member function to retrieve the current count of visible buttons.
HitTest | This member function determines which button is affected by the mouse pointer.


CXTPDatePickerButtons Methods

CXTPDatePickerButtons Class, Legend, Public Methods
CXTPDatePickerButtons Methods
Class

CXTPDatePickerButtons Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Find | This member function finds buttons by their ID property.
GetVisibleButtonCount | Call this member function to retrieve the current count of visible buttons.
HitTest | This member function determines which button is affected by the mouse pointer.


CXTPDatePickerButtons::Find Method

CXTPDatePickerButtons Methods, CXTPDatePickerButtons Class
CXTPDatePickerButtons::Find Method

This member function finds buttons by their ID property.

CXTPDatePickerButton* Find(
    int nID
) const;
Parameters

nID
An int that contains the ID to search for.

Returns

A pointer to the CXTPDatePickerButton structure. NULL if no matching button ID is found.

Remarks

Walks through the collection and looks for the button with the provided ID.

Group

CXTPDatePickerButtons Methods


CXTPDatePickerButtons::GetVisibleButtonCount Method

CXTPDatePickerButtons Methods, CXTPDatePickerButtons Class
CXTPDatePickerButtons::GetVisibleButtonCount Method

Call this member function to retrieve the current count of visible buttons.

int GetVisibleButtonCount() const;
Returns

Integer value that contains the current number of visible buttons that are in the collection.

Group

CXTPDatePickerButtons Methods


CXTPDatePickerButtons::HitTest Method

CXTPDatePickerButtons Methods, CXTPDatePickerButtons Class
CXTPDatePickerButtons::HitTest Method

This member function determines which button is affected by the mouse pointer.

CXTPDatePickerButton* HitTest(
    CPoint point
) const;
Parameters

point
Point to test.

Returns

The DatePicker button at the specified position, if any, otherwise NULL.

Remarks

Call this member function to test a mouse event occurring on one of the buttons rectangle areas. If no buttons are found then NULL is returned.

Group

CXTPDatePickerButtons Methods


CXTPDatePickerControl Class

XTPDatePickerControl.h, Classes, Legend, Members, Topics, CXTPDatePickerControl Enumerations, CXTPDatePickerControl Data Members, CXTPDatePickerControl Methods, CXTPDatePickerControl Constructors, CXTPDatePickerControl Destructors, CXTPDatePickerControl Constructors, CXTPDatePickerControl Data Members, CXTPDatePickerControl Destructors, CXTPDatePickerControl Enumerations, CXTPDatePickerControl Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl Class

Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.

Class Hierarchy

class CXTPDatePickerControl : public CWnd;
File

XTPDatePickerControl.h

Remarks

A CXTPDatePickerControl object implements a calendar-like user interface. This provides the user with a very intuitive and recognizable method of entering or selecting a date. The control also provides the application with the means to obtain and set the date information in the control using existing data types. By default, the date picker control displays the current day and month. However, the user is able to scroll to the previous and next months and select a specific month and/or year. The user can select a date or a range of dates. Also, the user can change the display by:

  • Scrolling backward and forward, from month to month.
  • Clicking the Today text to select the current day.
  • Clicking the None text to remove the selection.
  • Picking a month or a year from a pop-up menu.

The date picker control is customize by applying a variety of additional settings. Look at the control's class members list to see available customization options.

The date picker control can display more than one month, and it can indicate special days (such as holidays) by modifying the date's style. Furthermore, CXTPDatePickerControl contains methods similar to the MFC CMonthCalCtrl. Use the methods in the same way as the MFC CMonthCalCtrl.

See Also

CMonthCalCtrl

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
CXTPDatePickerControl Constructors
CXTPDatePickerControl Constructors | Description
CXTPDatePickerControl | Default constructor is used to construct a CXTPDatePickerControl object.
CXTPDatePickerControl Data Members
CXTPDatePickerControl Data Members | Description
m_arDayOfWeekNames | This member variable contains the day abbreviation for drawing in the month header.
m_arMonthNames | This member variable contains the localized month names values.
m_arrButtons | This member variable is an array of control buttons.
m_arrMonths | This member variable is an internal storage for the month items.
m_bAllowNoncontinuousSelection | TRUE to allow Noncontinuous selection
m_bAutoSize | This member variable is used as the AutoSize flag.
m_bChanged | This member variable is used to determine if the control requires redrawing.
m_bDeleteOnFinalRelease | Delete self OnFinalRelease() call.
m_bHighlightToday | This member variable is used as a flag to determine if the "Today" date is highlighted.
m_bIsModal | This member variable is used to specify if the control is used as a pop-up window.
m_bmpCache | This member variable is a cached window bitmap.
m_bMultiSelectionMode | TRUE if multiselection mode enabled (i.e.
m_borderStyle | This member variable is a flag that determines if the control displays a 3D border.
m_bRightToLeft | TRUE to display calendar components in Right-To-Left (RTL) format
m_bSelectWeek | TRUE when user is started selecting the whole week.
m_bShowNonMonthDays | This member variable is a flag that determines if the "non month days" are displayed.
m_bShowWeekNumbers | This member variable is a flag that determines if the "week numbers" are displayed.
m_dtFirstClicked | This member variable is used to specify the day that was clicked before starting the mouse selection.
m_dtFirstMonth | This member variable is used to specify the first month in the grid.
m_dtFocused | This member variable is used to specify the focused day.
m_dtFSelBase | This member variable is used to specify start day of the continuous selection.
m_dtLastClicked | This member variable is used to specify the day that was clicked last in the mouse selection.
m_dtMaxRange | This member variable specifies the maximum allowable date for a date picker control.
m_dtMinRange | This member variable specifies the minimum allowable date for a date picker control.
m_dtToday | This member variable is used to specify the "Today" date for a date picker control.
m_mouseMode | This member variable is used to specify the current Mouse operating mode.
m_nColumns | This member variable is used to specify the number of columns in the column month's grid.
m_nFirstDayOfWeek | This member variable is used to specify the first day of the week to display (1-Sunday, 2-Monday ...
m_nFirstWeekOfYearDays | This member variable is used to specify the number of days of the new year in the first week of this year.
m_nLockUpdateCount | This member variable is used as a counter that is used to count the update locks.
m_nMaxSelectionDays | This member variable is used to specify the maximum number of selected days.
m_nMonthDelta | This member variable is used to specify the number of months set as the control's scroll rate.
m_nRows | This member variable is used to specify the number of rows in the column month's grid.
m_nTimerID | This member variable is used to specify the control timer ID.
m_pButtonCaptured | Pointer to a date picker button
m_pCallbackParam | This member variable is a pointer to the user's additional parameter for the callback function.
m_pConnect | This member variable is a connection object that is used to send notifications.
m_pfnCallback | This member variable is a pointer to the user's IsSpecialDay function.
m_pListControl | This member variable is used to specify the "header month list" pop-up control.
m_pPaintManager | This member variable is a pointer to the paint manager.
m_pSelectedDays | This member variable is a collection of selected days.
m_rcControl | This data member is used to store the control drawing coordinates.
m_rcGrid | Months grid rect.
CXTPDatePickerControl Destructors
CXTPDatePickerControl Destructors | Description
~CXTPDatePickerControl | Destroys a CXTPDatePickerControl object, handles cleanup and de-allocation.
CXTPDatePickerControl Enumerations
CXTPDatePickerControl Enumerations | Description
DatePickerMouseMode | Enumeration of operational mouse modes.
CXTPDatePickerControl Methods
CXTPDatePickerControl Methods | Description
_RedrawControl | This member function redraws the control windows.
AddButton | This member function adds one more buttons to the control.
AdjustLayout |
AllowNoncontinuousSelection | This member function sets the flag which shows whether control allows non-continuous days selection or not.
CalcButtonBandRect | Call this member function to calculate and set the buttons band rectangle.
CalcButtonSize | This member function calculates the size of the button.
ClearFocus | This function clear focused attribute if it is set.
ClearMonths | This member function is used to cleanup the month's array.
Create | This member function is used to create the Date Picker Control Window.
CreateMonthArray | This member function creates the internal month array.
Deselect | Call this member function to de-select the specified day.
DrawButtons | Call this member function to draw the calendar's buttons.
EnsureVisible | Call this member function to ensure that the COleDateTime item is visible.
EnsureVisibleFocus | Call this member function to ensure that the focused item is visible.
EnsureVisibleSelection | Call this member function to ensure that the selection range is visible.
GetBorderStyle | Call this member function to determine if the border is visible.
GetButton | This member function returns a pointer to the CXTPDatePickerButton object using its numeric index.
GetButtonCount | This member function returns the number of CXTPDatePickerButton items shown on the control.
GetCallbackDayMetrics | This member function returns the day metrics callback function.
GetCols | Call this member function to obtain the number of columns in the months grid.
GetConnection | This member function obtains a notification connection object pointer.
GetCurSel | This member function retrieves the system time as indicated by the currently-selected date.
GetDayMetrics | This member function returns the day item drawing metrics.
GetDayOfWeekName | This member function returns the DayOfWeek name associated with the integer value of nDayOfWeek.
GetFirstDayOfWeek | This member function obtains the first day of the week that is displayed in the leftmost column of the calendar.
GetFirstWeekOfYearDays | This member function obtains the current required number of year days in the first week of the year.
GetHighlightToday | Call this member function to determine whether the "Today" cell highlighting is enabled or disabled.
GetMaxSelCount | This member function retrieves the current maximum number of days that can be selected in a date picker control.
GetMinReqRect |
GetMonthDelta | This member function retrieves the scroll rate for the date picker control.
GetMonthName | This member function returns the month name of the given integer value.
GetMonthRange | This member function retrieves date information representing the high and low limits of a date picker control's display.
GetPaintManager | This member function returns a pointer to the associated paint manager.
GetPaintTheme | This member function is used to obtain current paint theme.
GetRange | This member function retrieves the current minimum and maximum dates set in a date picker control.
GetRows | Call this member function to obtain the number of rows in the months grid.
GetSelectedDays | Returns a collection of the days, selected in the date picker.
GetSelRange | This member function retrieves date information representing the upper and lower limits of the date range currently selected by the user.
GetShowNonMonthDays | Call this member function to determine if the non-month days are visible.
GetShowWeekNumbers | Call this member function to determine if the week numbers are visible.
GetToday | This member function retrieves the date information for the date specified as "Today" for the date picker control.
GetVisibleRange | This member function retrieves first and last displayed days dates.
GoModal | This member function implements pop-up window behavior for the Date Picker control.
HitTest |
InitNames | This member function initializes the month and day names depending on localization.
IsAllowNoncontinuousSelection | This member function returns the flag which shows whether control allows non-continuous days selection or not.
IsAutoSize | This function is called to determine if AutoSize mode is set.
IsFocused | This function checks a specific date to determine if it is focused.
IsModal | Is the control runs in modal mode.
IsMultiSelectionMode | Determines if the multiple selection mode is enabled.
IsNoneButtonVisible | This function returns the boolean visibility flag of the "None" button.
IsSelected | This function checks a specific date to determine if it is contained in the control's selection.
IsTodayButtonVisible | This member function is used to obtain the value of the visibility flag for the "Today" button.
OnButtonClick | This member function is used to process the control's button clicks.
OnDraw | This member function is used to perform all drawing logic.
Populate | This member function performs control population, creating the view from the data.
PreSubclassWindow | This member function is called by the framework to allow other necessary sub-classing to occur before the window is sub-classed.
ProcessButtons | This member function is used to implement the button behavior.
RedrawControl | This member function redraws the control windows.
RegisterWindowClass | This member function registers the window class if it has not already been registered.
ScrollLeft | This member function scrolls the control's months grid to the left by the specified number of months.
ScrollRight | This member function scrolls the control's months grid to the right by the specified amount of months.
Select | Call this member function to select a specific day.
SendMessageToParent | Call this member function to send notifications to the parent window.
SendNotification | This member function sends a notification to all control's event subscribers.
SetAutoSize | This function sets the AutoSize mode.
SetBorderStyle | Call this member function to set borders style around the control.
SetButtonRect | Call this member function to calculate and set the buttons bounding rectangle.
SetButtonsVisible | This function sets visibility for the "Today" and "None" buttons.
SetCallbackDayMetrics | This member function sets the user defined day metrics callback function.
SetCurSel | This member function sets the currently selected date for the date picker control.
SetDayOfWeekName | This member function sets the user-defined DayOfWeek name.
SetFirstDayOfWeek | This member function sets the day of the week that is displayed in the leftmost column of the calendar.
SetFirstWeekOfYearDays | This member function sets the required number of this year days in the first week of the year.
SetGridDimentions | This member function sets new dimensions for the month grid.
SetGridSize | Call this member function to set the number of months in the control's grid.
SetHighlightToday | Call this member function to enable or disable highlighting of the "Today" cell.
SetLayoutRTL | Call this member to set right-to-left mode.
SetMaxSelCount | This member function sets the maximum number of days that can be selected in a date picker control.
SetMonthDelta | This member function sets the scroll rate for the date picker control.
SetMonthName | This member function sets the user-defined month name.
SetMultiSelectionMode | Enables/disables the multiple selection mode for the control.
SetPaintTheme | This member function is used to set current paint theme.
SetRange | This member function sets the minimum and maximum allowable dates for a date picker control.
SetSelRange | This member function sets the selection for a date picker control to a given date range.
SetShowNonMonthDays | Call this member function to show or hide non-month days.
SetShowWeekNumbers | Call this member function to show or hide the week numbers.
SetTheme | This member function sets the new control drawing theme.
SetToday | This member function sets the calendar control to the current day.
ShiftDate | This function shifts the specified date for the specified number of months.
ShowListHeader | This member function shows a CXTPDatePickerList control at the coordinates specified by rcHeader.
SizeMinReq | This member function adjusts the date picker control to the minimum size required to display one month.


CXTPDatePickerControl Enumerations

Enumerations, CXTPDatePickerControl Class, Legend
CXTPDatePickerControl Enumerations
Enumerations
Enumeration | Description
DatePickerMouseMode | Enumeration of operational mouse modes.
Class

CXTPDatePickerControl Class

Legend
Enumeration


CXTPDatePickerControl::DatePickerMouseMode Enumeration

XTPDatePickerControl.h, CXTPDatePickerControl Enumerations
CXTPDatePickerControl::DatePickerMouseMode Enumeration

Enumeration of operational mouse modes.

enum DatePickerMouseMode {
  mouseNothing,
  mouseScrollingLeft,
  mouseScrollingRight,
  mouseSelecting,
  mouseDeselecting,
  mouseTrackingHeaderList
};
File

XTPDatePickerControl.h

Members

mouseNothing
No mouse activity by the user.
mouseScrollingLeft
User pressed left scroll triangle and is holding the button.
mouseScrollingRight
User pressed right scroll triangle and is holding the button.
mouseSelecting
User pressed left mouse down on unselected day item and is now selecting a range of day items.
mouseDeselecting
User pressed left mouse down on selected day item and is now de-selecting a range of day items.
mouseTrackingHeaderList
User is tracking pop-up month list window.

Remarks

DatePickerControl handles several Mouse states. This enumeration helps to clearly identify each of these states.

Group

CXTPDatePickerControl Enumerations


CXTPDatePickerControl Data Members

CXTPDatePickerControl Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl Data Members
Class

CXTPDatePickerControl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arDayOfWeekNames | This member variable contains the day abbreviation for drawing in the month header.
m_arMonthNames | This member variable contains the localized month names values.
m_arrButtons | This member variable is an array of control buttons.
m_arrMonths | This member variable is an internal storage for the month items.
m_bAllowNoncontinuousSelection | TRUE to allow Noncontinuous selection
m_bAutoSize | This member variable is used as the AutoSize flag.
m_bChanged | This member variable is used to determine if the control requires redrawing.
m_bHighlightToday | This member variable is used as a flag to determine if the "Today" date is highlighted.
m_bIsModal | This member variable is used to specify if the control is used as a pop-up window.
m_bmpCache | This member variable is a cached window bitmap.
m_bMultiSelectionMode | TRUE if multiselection mode enabled (i.e.
m_borderStyle | This member variable is a flag that determines if the control displays a 3D border.
m_bRightToLeft | TRUE to display calendar components in Right-To-Left (RTL) format
m_bSelectWeek | TRUE when user is started selecting the whole week.
m_bShowNonMonthDays | This member variable is a flag that determines if the "non month days" are displayed.
m_bShowWeekNumbers | This member variable is a flag that determines if the "week numbers" are displayed.
m_dtFirstClicked | This member variable is used to specify the day that was clicked before starting the mouse selection.
m_dtFirstMonth | This member variable is used to specify the first month in the grid.
m_dtFocused | This member variable is used to specify the focused day.
m_dtFSelBase | This member variable is used to specify start day of the continuous selection.
m_dtLastClicked | This member variable is used to specify the day that was clicked last in the mouse selection.
m_dtMaxRange | This member variable specifies the maximum allowable date for a date picker control.
m_dtMinRange | This member variable specifies the minimum allowable date for a date picker control.
m_dtToday | This member variable is used to specify the "Today" date for a date picker control.
m_mouseMode | This member variable is used to specify the current Mouse operating mode.
m_nColumns | This member variable is used to specify the number of columns in the column month's grid.
m_nFirstDayOfWeek | This member variable is used to specify the first day of the week to display (1-Sunday, 2-Monday ...
m_nFirstWeekOfYearDays | This member variable is used to specify the number of days of the new year in the first week of this year.
m_nLockUpdateCount | This member variable is used as a counter that is used to count the update locks.
m_nMaxSelectionDays | This member variable is used to specify the maximum number of selected days.
m_nMonthDelta | This member variable is used to specify the number of months set as the control's scroll rate.
m_nRows | This member variable is used to specify the number of rows in the column month's grid.
m_nTimerID | This member variable is used to specify the control timer ID.
m_pButtonCaptured | Pointer to a date picker button
m_pCallbackParam | This member variable is a pointer to the user's additional parameter for the callback function.
m_pConnect | This member variable is a connection object that is used to send notifications.
m_pfnCallback | This member variable is a pointer to the user's IsSpecialDay function.
m_pListControl | This member variable is used to specify the "header month list" pop-up control.
m_pPaintManager | This member variable is a pointer to the paint manager.
m_pSelectedDays | This member variable is a collection of selected days.
m_rcControl | This data member is used to store the control drawing coordinates.
m_rcGrid | Months grid rect.
Public Data Members
Public Data Member | Description
m_bDeleteOnFinalRelease | Delete self OnFinalRelease() call.


CXTPDatePickerControl::m_arDayOfWeekNames Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_arDayOfWeekNames Data Member

This member variable contains the day abbreviation for drawing in the month header.

CString* m_arDayOfWeekNames;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_arMonthNames Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_arMonthNames Data Member

This member variable contains the localized month names values.

CString* m_arMonthNames;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_arrButtons Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_arrButtons Data Member

This member variable is an array of control buttons.

CXTPDatePickerButtons m_arrButtons;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_arrMonths Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_arrMonths Data Member

This member variable is an internal storage for the month items.

CArray<CXTPDatePickerItemMonth*, CXTPDatePickerItemMonth*> m_arrMonths;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bAllowNoncontinuousSelection Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bAllowNoncontinuousSelection Data Member

TRUE to allow Noncontinuous selection

BOOL m_bAllowNoncontinuousSelection;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bAutoSize Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bAutoSize Data Member

This member variable is used as the AutoSize flag.

BOOL m_bAutoSize;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bChanged Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bChanged Data Member

This member variable is used to determine if the control requires redrawing.

BOOL m_bChanged;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bDeleteOnFinalRelease Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bDeleteOnFinalRelease Data Member

Delete self OnFinalRelease() call.

BOOL m_bDeleteOnFinalRelease;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bHighlightToday Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bHighlightToday Data Member

This member variable is used as a flag to determine if the "Today" date is highlighted.

BOOL m_bHighlightToday;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bIsModal Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bIsModal Data Member

This member variable is used to specify if the control is used as a pop-up window.

BOOL m_bIsModal;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bmpCache Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bmpCache Data Member

This member variable is a cached window bitmap.

CBitmap m_bmpCache;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bMultiSelectionMode Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bMultiSelectionMode Data Member

TRUE if multiselection mode enabled (i.e.

BOOL m_bMultiSelectionMode;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_borderStyle Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_borderStyle Data Member

This member variable is a flag that determines if the control displays a 3D border.

XTPDatePickerBorderStyle m_borderStyle;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bRightToLeft Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bRightToLeft Data Member

TRUE to display calendar components in Right-To-Left (RTL) format

BOOL m_bRightToLeft;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bSelectWeek Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bSelectWeek Data Member

TRUE when user is started selecting the whole week.

BOOL m_bSelectWeek;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bShowNonMonthDays Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bShowNonMonthDays Data Member

This member variable is a flag that determines if the "non month days" are displayed.

BOOL m_bShowNonMonthDays;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_bShowWeekNumbers Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_bShowWeekNumbers Data Member

This member variable is a flag that determines if the "week numbers" are displayed.

BOOL m_bShowWeekNumbers;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_dtFirstClicked Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_dtFirstClicked Data Member

This member variable is used to specify the day that was clicked before starting the mouse selection.

COleDateTime m_dtFirstClicked;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_dtFirstMonth Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_dtFirstMonth Data Member

This member variable is used to specify the first month in the grid.

COleDateTime m_dtFirstMonth;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_dtFocused Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_dtFocused Data Member

This member variable is used to specify the focused day.

COleDateTime m_dtFocused;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_dtFSelBase Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_dtFSelBase Data Member

This member variable is used to specify start day of the continuous selection.

COleDateTime m_dtFSelBase;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_dtLastClicked Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_dtLastClicked Data Member

This member variable is used to specify the day that was clicked last in the mouse selection.

COleDateTime m_dtLastClicked;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_dtMaxRange Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_dtMaxRange Data Member

This member variable specifies the maximum allowable date for a date picker control.

COleDateTime m_dtMaxRange;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_dtMinRange Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_dtMinRange Data Member

This member variable specifies the minimum allowable date for a date picker control.

COleDateTime m_dtMinRange;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_dtToday Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_dtToday Data Member

This member variable is used to specify the "Today" date for a date picker control.

COleDateTime m_dtToday;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_mouseMode Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_mouseMode Data Member

This member variable is used to specify the current Mouse operating mode.

DatePickerMouseMode m_mouseMode;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_nColumns Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_nColumns Data Member

This member variable is used to specify the number of columns in the column month's grid.

int m_nColumns;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_nFirstDayOfWeek Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_nFirstDayOfWeek Data Member

This member variable is used to specify the first day of the week to display (1-Sunday, 2-Monday ...

int m_nFirstDayOfWeek;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_nFirstWeekOfYearDays Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_nFirstWeekOfYearDays Data Member

This member variable is used to specify the number of days of the new year in the first week of this year.

int m_nFirstWeekOfYearDays;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_nLockUpdateCount Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_nLockUpdateCount Data Member

This member variable is used as a counter that is used to count the update locks.

int m_nLockUpdateCount;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_nMaxSelectionDays Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_nMaxSelectionDays Data Member

This member variable is used to specify the maximum number of selected days.

int m_nMaxSelectionDays;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_nMonthDelta Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_nMonthDelta Data Member

This member variable is used to specify the number of months set as the control's scroll rate.

int m_nMonthDelta;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_nRows Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_nRows Data Member

This member variable is used to specify the number of rows in the column month's grid.

int m_nRows;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_nTimerID Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_nTimerID Data Member

This member variable is used to specify the control timer ID.

int m_nTimerID;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_pButtonCaptured Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_pButtonCaptured Data Member

Pointer to a date picker button

CXTPDatePickerButton* m_pButtonCaptured;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_pCallbackParam Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_pCallbackParam Data Member

This member variable is a pointer to the user's additional parameter for the callback function.

void* m_pCallbackParam;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_pConnect Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_pConnect Data Member

This member variable is a connection object that is used to send notifications.

CXTPNotifyConnection* m_pConnect;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_pfnCallback Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_pfnCallback Data Member

This member variable is a pointer to the user's IsSpecialDay function.

PFNITEMMETRICS m_pfnCallback;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_pListControl Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_pListControl Data Member

This member variable is used to specify the "header month list" pop-up control.

CXTPDatePickerList* m_pListControl;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_pPaintManager Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_pPaintManager Data Member

This member variable is a pointer to the paint manager.

CXTPDatePickerPaintManager* m_pPaintManager;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_pSelectedDays Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_pSelectedDays Data Member

This member variable is a collection of selected days.

CXTPDatePickerDaysCollection* m_pSelectedDays;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_rcControl Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_rcControl Data Member

This data member is used to store the control drawing coordinates.

CRect m_rcControl;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl::m_rcGrid Data Member

CXTPDatePickerControl Data Members, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::m_rcGrid Data Member

Months grid rect.

CRect m_rcGrid;
Group

CXTPDatePickerControl Data Members


CXTPDatePickerControl Methods

CXTPDatePickerControl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl Methods
Class

CXTPDatePickerControl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_RedrawControl | This member function redraws the control windows.
CalcButtonBandRect | Call this member function to calculate and set the buttons band rectangle.
CalcButtonSize | This member function calculates the size of the button.
ClearMonths | This member function is used to cleanup the month's array.
CreateMonthArray | This member function creates the internal month array.
DrawButtons | Call this member function to draw the calendar's buttons.
InitNames | This member function initializes the month and day names depending on localization.
OnButtonClick | This member function is used to process the control's button clicks.
OnDraw | This member function is used to perform all drawing logic.
Populate | This member function performs control population, creating the view from the data.
PreSubclassWindow | This member function is called by the framework to allow other necessary sub-classing to occur before the window is sub-classed.
ProcessButtons | This member function is used to implement the button behavior.
SendNotification | This member function sends a notification to all control's event subscribers.
SetButtonRect | Call this member function to calculate and set the buttons bounding rectangle.
SetGridDimentions | This member function sets new dimensions for the month grid.
ShiftDate | This function shifts the specified date for the specified number of months.
ShowListHeader | This member function shows a CXTPDatePickerList control at the coordinates specified by rcHeader.
Public Methods
Public Methods
Public Method | Description
AddButton | This member function adds one more buttons to the control.
AdjustLayout |
AllowNoncontinuousSelection | This member function sets the flag which shows whether control allows non-continuous days selection or not.
ClearFocus | This function clear focused attribute if it is set.
Create | This member function is used to create the Date Picker Control Window.
Deselect | Call this member function to de-select the specified day.
EnsureVisible | Call this member function to ensure that the COleDateTime item is visible.
EnsureVisibleFocus | Call this member function to ensure that the focused item is visible.
EnsureVisibleSelection | Call this member function to ensure that the selection range is visible.
GetBorderStyle | Call this member function to determine if the border is visible.
GetButton | This member function returns a pointer to the CXTPDatePickerButton object using its numeric index.
GetButtonCount | This member function returns the number of CXTPDatePickerButton items shown on the control.
GetCallbackDayMetrics | This member function returns the day metrics callback function.
GetCols | Call this member function to obtain the number of columns in the months grid.
GetConnection | This member function obtains a notification connection object pointer.
GetCurSel | This member function retrieves the system time as indicated by the currently-selected date.
GetDayMetrics | This member function returns the day item drawing metrics.
GetDayOfWeekName | This member function returns the DayOfWeek name associated with the integer value of nDayOfWeek.
GetFirstDayOfWeek | This member function obtains the first day of the week that is displayed in the leftmost column of the calendar.
GetFirstWeekOfYearDays | This member function obtains the current required number of year days in the first week of the year.
GetHighlightToday | Call this member function to determine whether the "Today" cell highlighting is enabled or disabled.
GetMaxSelCount | This member function retrieves the current maximum number of days that can be selected in a date picker control.
GetMinReqRect |
GetMonthDelta | This member function retrieves the scroll rate for the date picker control.
GetMonthName | This member function returns the month name of the given integer value.
GetMonthRange | This member function retrieves date information representing the high and low limits of a date picker control's display.
GetPaintManager | This member function returns a pointer to the associated paint manager.
GetPaintTheme | This member function is used to obtain current paint theme.
GetRange | This member function retrieves the current minimum and maximum dates set in a date picker control.
GetRows | Call this member function to obtain the number of rows in the months grid.
GetSelectedDays | Returns a collection of the days, selected in the date picker.
GetSelRange | This member function retrieves date information representing the upper and lower limits of the date range currently selected by the user.
GetShowNonMonthDays | Call this member function to determine if the non-month days are visible.
GetShowWeekNumbers | Call this member function to determine if the week numbers are visible.
GetToday | This member function retrieves the date information for the date specified as "Today" for the date picker control.
GetVisibleRange | This member function retrieves first and last displayed days dates.
GoModal | This member function implements pop-up window behavior for the Date Picker control.
HitTest |
IsAllowNoncontinuousSelection | This member function returns the flag which shows whether control allows non-continuous days selection or not.
IsAutoSize | This function is called to determine if AutoSize mode is set.
IsFocused | This function checks a specific date to determine if it is focused.
IsModal | Is the control runs in modal mode.
IsMultiSelectionMode | Determines if the multiple selection mode is enabled.
IsNoneButtonVisible | This function returns the boolean visibility flag of the "None" button.
IsSelected | This function checks a specific date to determine if it is contained in the control's selection.
IsTodayButtonVisible | This member function is used to obtain the value of the visibility flag for the "Today" button.
RedrawControl | This member function redraws the control windows.
RegisterWindowClass | This member function registers the window class if it has not already been registered.
ScrollLeft | This member function scrolls the control's months grid to the left by the specified number of months.
ScrollRight | This member function scrolls the control's months grid to the right by the specified amount of months.
Select | Call this member function to select a specific day.
SendMessageToParent | Call this member function to send notifications to the parent window.
SetAutoSize | This function sets the AutoSize mode.
SetBorderStyle | Call this member function to set borders style around the control.
SetButtonsVisible | This function sets visibility for the "Today" and "None" buttons.
SetCallbackDayMetrics | This member function sets the user defined day metrics callback function.
SetCurSel | This member function sets the currently selected date for the date picker control.
SetDayOfWeekName | This member function sets the user-defined DayOfWeek name.
SetFirstDayOfWeek | This member function sets the day of the week that is displayed in the leftmost column of the calendar.
SetFirstWeekOfYearDays | This member function sets the required number of this year days in the first week of the year.
SetGridSize | Call this member function to set the number of months in the control's grid.
SetHighlightToday | Call this member function to enable or disable highlighting of the "Today" cell.
SetLayoutRTL | Call this member to set right-to-left mode.
SetMaxSelCount | This member function sets the maximum number of days that can be selected in a date picker control.
SetMonthDelta | This member function sets the scroll rate for the date picker control.
SetMonthName | This member function sets the user-defined month name.
SetMultiSelectionMode | Enables/disables the multiple selection mode for the control.
SetPaintTheme | This member function is used to set current paint theme.
SetRange | This member function sets the minimum and maximum allowable dates for a date picker control.
SetSelRange | This member function sets the selection for a date picker control to a given date range.
SetShowNonMonthDays | Call this member function to show or hide non-month days.
SetShowWeekNumbers | Call this member function to show or hide the week numbers.
SetTheme | This member function sets the new control drawing theme.
SetToday | This member function sets the calendar control to the current day.
SizeMinReq | This member function adjusts the date picker control to the minimum size required to display one month.


CXTPDatePickerControl::_RedrawControl Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::_RedrawControl Method

This member function redraws the control windows.

virtual void _RedrawControl(
    BOOL bUpdateNow
);
Parameters

bUpdateNow
if TRUE the CWnd::UpdateWindow() will be called, otherwise only CWnd::Invalidate() will be called.

Remarks

Call this member function to redraw all control windows according to the stored parameter values.

See Also

RedrawControl

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::AddButton Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::AddButton Method

This member function adds one more buttons to the control.

virtual void AddButton(
    UINT nID
);
Parameters

nID
ID of the string resource item. This is the caption of the new button.

Remarks

Call this member function to add one more CXTPDatePickerButton objects to the control's collection.

See Also

GetButton, GetButtonCount

Group

CXTPDatePickerControl Methods


AdjustLayout Method

CXTPDatePickerControl Methods
AdjustLayout Method
Overload List
Methods
Method | Description
CXTPDatePickerControl::AdjustLayout () | This member function adjusts the layout of all sub-items depending on the current window client size.
CXTPDatePickerControl::AdjustLayout (CRect) | This member function adjusts the layout of all sub-items depending on the current window client size.
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::AdjustLayout Method ()

AdjustLayout Method, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::AdjustLayout Method ()

This member function adjusts the layout of all sub-items depending on the current window client size.

virtual void AdjustLayout();
virtual void AdjustLayout(
    CRect rcClient
);
Parameters

rcClient
A CRect that contains the coordinates of the control.

Remarks

AdjustLayout depends on the AutoSize flag (changing control size or item fonts correspondingly).

See Also

AdjustLayout(CRect rcClient), IsAutoSize

Body Source
void CXTPDatePickerControl::AdjustLayout() {
    InitNames();
    AdjustLayout(m_rcControl);
}
Group

AdjustLayout Method


CXTPDatePickerControl::AllowNoncontinuousSelection Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::AllowNoncontinuousSelection Method

This member function sets the flag which shows whether control allows non-continuous days selection or not.

virtual void AllowNoncontinuousSelection(
    BOOL bAllow = TRUE
);
Parameters

bAllow
TRUE to allow non-continuous days selection (default value), FALSE to disallow.

Remarks

Allowing continuous days selection means that user will be able to select only a single days interval between 2 dates, where all dates will be selected inside. Non-continuous days selection means that user will be able to select any specific dates totally up to MaxSelCount count.

See Also

IsAllowNoncontinuousSelection, SetMaxSelCount, GetMaxSelCount

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::CalcButtonBandRect Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::CalcButtonBandRect Method

Call this member function to calculate and set the buttons band rectangle.

virtual void CalcButtonBandRect();
Remarks

The band rectangle is a box that is drawn around the button to highlight the button.

See Also

SetButtonRect, CalcButtonSize

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::CalcButtonSize Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::CalcButtonSize Method

This member function calculates the size of the button.

virtual CSize CalcButtonSize() const;
Returns

CSize object with button size.

See Also

SetButtonRect, CalcButtonBandRect

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::ClearFocus Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::ClearFocus Method

This function clear focused attribute if it is set.

virtual void ClearFocus();
Remarks

Focused item is used only for the keyboard navigation and selecting. It is initialized by keyboard using first day of the current selection or if selection is empty the first day of the first visible month is used. Focused item is cleared by mouse or by set selection externally.

See Also

IsFocused

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::ClearMonths Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::ClearMonths Method

This member function is used to cleanup the month's array.

virtual void ClearMonths();
See Also

Populate

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::Create Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class
CXTPDatePickerControl::Create Method

This member function is used to create the Date Picker Control Window.

virtual BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID,
    CCreateContext* pContext = NULL
);
Parameters

dwStyle
Specifies the window style attributes.
rect
A RECT object that contains the coordinates of the window, in the client coordinates of pParentWnd.
pParentWnd
A CWnd pointer to the parent window.
nID
A UINT that contains the ID of the child window.
pContext
A CCreateContext pointer that contains the create context of the window.

Returns

Nonzero if successful. Otherwise 0.

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::CreateMonthArray Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::CreateMonthArray Method

This member function creates the internal month array.

virtual void CreateMonthArray();
Remarks

Fills the internal month array with the new DatPickerItemMonth objects, using the values of the initialized data members.

See Also

Populate

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::Deselect Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::Deselect Method

Call this member function to de-select the specified day.

virtual void Deselect(
    const COleDateTime& dtDay
);
Parameters

dtDay
Date to be deselected.

Remarks

This member function removes the provided day from the control's selected days collection.

See Also

Select, IsSelected

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::DrawButtons Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::DrawButtons Method

Call this member function to draw the calendar's buttons.

virtual void DrawButtons(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

See Also

OnDraw

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::EnsureVisible Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::EnsureVisible Method

Call this member function to ensure that the COleDateTime item is visible.

virtual void EnsureVisible(
    const COleDateTime& dtDate
);
Parameters

dtDate
The date to test.

Remarks

If necessary, the function scrolls the month grid on the control to make the day visible.

See Also

EnsureVisibleSelection

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::EnsureVisibleFocus Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::EnsureVisibleFocus Method

Call this member function to ensure that the focused item is visible.

virtual void EnsureVisibleFocus();
Remarks

Focused item is used only for the keyboard navigation and selecting. It is initialized by keyboard using first day of the current selection or if selection is empty the first day of the first visible month is used. Focused item is cleared by mouse or by set selection externally.

See Also

EnsureVisible, EnsureVisibleSelection

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::EnsureVisibleSelection Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::EnsureVisibleSelection Method

Call this member function to ensure that the selection range is visible.

virtual void EnsureVisibleSelection();
Remarks

If necessary, the function scrolls the month grid on the control to make all selected days visible.

See Also

EnsureVisible, EnsureVisibleFocus

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetBorderStyle Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetBorderStyle Method

Call this member function to determine if the border is visible.

virtual XTPDatePickerBorderStyle GetBorderStyle() const;
Returns

XTPDatePickerBorderStyle value that specifies the border style.

See Also

SetBorderStyle, CXTPDatePickerPaintManager::DrawBorder, XTPDatePickerBorderStyle

Body Source
XTPDatePickerBorderStyle CXTPDatePickerControl::GetBorderStyle() const{
    return m_borderStyle;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetButton Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetButton Method

This member function returns a pointer to the CXTPDatePickerButton object using its numeric index.

virtual CXTPDatePickerButton* GetButton(
    int nIndex
) const;
Parameters

nIndex
The index of the CXTPDatePickerButton to retrieve.

Returns

A pointer to the CXTPDatePickerButton object.

Remarks

Call this member function to retrieve a pointer to the button object using its numeric index.

See Also

GetButtonCount, AddButton

Body Source
CXTPDatePickerButton* CXTPDatePickerControl::GetButton(int nIndex) const {
    return m_arrButtons[nIndex];
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetButtonCount Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetButtonCount Method

This member function returns the number of CXTPDatePickerButton items shown on the control.

virtual int GetButtonCount() const;
Returns

A number of CXTPDatePickerButton items shown on the control.

Remarks

Call this member function to determine the number of buttons currently used on the control.

See Also

GetButton, AddButton

Body Source
int CXTPDatePickerControl::GetButtonCount() const{
    return (int)m_arrButtons.GetSize();
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetCallbackDayMetrics Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetCallbackDayMetrics Method

This member function returns the day metrics callback function.

virtual PFNITEMMETRICS GetCallbackDayMetrics();
Returns

Pointer to the callback function.

Remarks

Call this member function to obtain a pointer to the user defined day metrics callback function.

See Also

PFNITEMMETRICS, SetCallbackDayMetrics, GetDayMetrics

Body Source
PFNITEMMETRICS CXTPDatePickerControl::GetCallbackDayMetrics() {
    return m_pfnCallback;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetCols Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetCols Method

Call this member function to obtain the number of columns in the months grid.

virtual int GetCols();
Returns

An int that contains the number of columns in the control's months grid.

See Also

GetRows, SetGridSize

Body Source
int CXTPDatePickerControl::GetCols() {
    return m_nColumns;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetConnection Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetConnection Method

This member function obtains a notification connection object pointer.

virtual CXTPNotifyConnection* GetConnection();
Returns

A CXTPNotifyConnection pointer to the connection object.

Remarks

Used to subscribe (Advice) for notifications events from the control.

See Also

CXTPNotifyConnectionoverview, IXTPNotificationSink overview

Body Source
CXTPNotifyConnection* CXTPDatePickerControl::GetConnection() {
    return m_pConnect;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetCurSel Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetCurSel Method

This member function retrieves the system time as indicated by the currently-selected date.

virtual BOOL GetCurSel(
    COleDateTime& refDateTime
) const;
Parameters

refDateTime
A reference to a COleDateTime object. Receives the currently selected time.

Returns

A BOOL that indicates the success of the function.

TRUE if the function is successfully able to retrieve the system time.

FALSE if more than one date is selected.

Remarks

This member function fails if more than 1 date is selected.

See Also

SetCurSel, CMonthCalCtrl::GetCurSel

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetDayMetrics Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetDayMetrics Method

This member function returns the day item drawing metrics.

virtual void GetDayMetrics(
    COleDateTime& dtDay,
    XTP_DAYITEM_METRICS* pDayMetics
);
Parameters

dtDay
Reference to the DateTime value to check.
pDayMetics
Pointer to the day metrics structure.

Remarks

Determines whether or not a given date is special. This function calls a callback function to make this determination.

See Also

GetCallbackDayMetrics, SetCallbackDayMetrics

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetDayOfWeekName Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetDayOfWeekName Method

This member function returns the DayOfWeek name associated with the integer value of nDayOfWeek.

CString GetDayOfWeekName(
    int nDayOfWeek
) const;
Parameters

nDayOfWeek
DayOfWeek number.

Returns

If nDayOfWeek is a valid integer value, then the function returns the name of the week associated with the integer value of nDayOfWeek. If nDayOfWeek is not a valid integer value, then the function returns an empty string.

Remarks

Valid day-of-week range is between 1 and 7, where 1 = Sunday, 2 = Monday, and so on.

See Also

SetDayOfWeekName, SetMonthName, GetMonthName

Body Source
CString CXTPDatePickerControl::GetDayOfWeekName(int nDayOfWeek) const {
    return nDayOfWeek >= 1 && nDayOfWeek <= 7 ? m_arDayOfWeekNames[nDayOfWeek - 1] : _T("");
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetFirstDayOfWeek Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetFirstDayOfWeek Method

This member function obtains the first day of the week that is displayed in the leftmost column of the calendar.

virtual int GetFirstDayOfWeek();
Returns

An integer value that represents the first day of the week. The days of the week are represented as integers, as follows.

  • 1 - Sunday
  • 2 - Monday
  • 3 - Tuesday
  • 4 - Wednesday
  • 5 - Thursday
  • 6 - Friday
  • 7 - Saturday
See Also

SetFirstDayOfWeek

Body Source
int CXTPDatePickerControl::GetFirstDayOfWeek() {
    return m_nFirstDayOfWeek;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetFirstWeekOfYearDays Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetFirstWeekOfYearDays Method

This member function obtains the current required number of year days in the first week of the year.

virtual int GetFirstWeekOfYearDays();
Returns

An integer value that represents the required number of days of the new year in the first week of this year. The value should be between 1 (by default) and 7 (full week).

See Also

SetFirstWeekOfYearDays

Body Source
int CXTPDatePickerControl::GetFirstWeekOfYearDays() {
    return m_nFirstWeekOfYearDays;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetHighlightToday Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetHighlightToday Method

Call this member function to determine whether the "Today" cell highlighting is enabled or disabled.

virtual BOOL GetHighlightToday();
Returns

A BOOL that indicates if the "Today" cell is highlighted.

TRUE if the "Today" cell is highlighted. Otherwise FALSE.

Remarks

This member function returns a boolean flag that specifies the "Today" button highlighting mode.

See Also

GetHighlightToday, SetToday, GetToday, CXTPDatePickerPaintManager::GetHighlightTodayColor

Body Source
BOOL CXTPDatePickerControl::GetHighlightToday() {
    return m_bHighlightToday;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetMaxSelCount Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetMaxSelCount Method

This member function retrieves the current maximum number of days that can be selected in a date picker control.

virtual int GetMaxSelCount() const;
Returns

An integer value that represents the total number of days that can be selected for the control. XTP_SELECTION_INFINITE if selection is not bounded.

Remarks

This member function implements the behavior of the CMonthCalCtrl::GetMaxSelCount function.

See Also

SetMaxSelCount, CMonthCalCtrl::GetMaxSelCount, AllowNoncontinuousSelection

Body Source
int CXTPDatePickerControl::GetMaxSelCount() const {
    return m_nMaxSelectionDays;
}
Group

CXTPDatePickerControl Methods


GetMinReqRect Method

CXTPDatePickerControl Methods
GetMinReqRect Method
Overload List
Methods
Method | Description
CXTPDatePickerControl::GetMinReqRect (RECT*) | This member function retrieves the minimum size required to show a full month in the date picker control or a specified number of full month items in a date picker control.
CXTPDatePickerControl::GetMinReqRect (RECT*, int, int) | This member function retrieves the minimum size required to show a full month in the date picker control or a specified number of full month items in a date picker control.
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetMinReqRect Method (RECT*)

GetMinReqRect Method, CXTPDatePickerControl Class, See Also
CXTPDatePickerControl::GetMinReqRect Method (RECT*)

This member function retrieves the minimum size required to show a full month in the date picker control or a specified number of full month items in a date picker control.

virtual BOOL GetMinReqRect(
    RECT* pRect
) const;
virtual BOOL GetMinReqRect(
    RECT* pRect,
    int nRows,
    int nCols
) const;
Parameters

pRect
A pointer to a RECT structure that receives the bounding rectangle information. This parameter must be a valid address and cannot be NULL.
nRows
A number of months in a row inside the calculated rectangle.
nCols
A number of months in a column inside the calculated rectangle.

Returns

If successful, this member function returns nonzero and pRect receives the applicable bounding rectangle information. If unsuccessful, the member function returns 0.

Remarks

This member function implements the behavior of the CMonthCalCtrl::GetMinReqRect function.

GetMinReqRect(RECT* pRect, int nRows, int nCols) retrieves the minimum size required to show a specified number of full month items in a date picker control. The functionality implemented by this function is similar to the CMonthCalCtrl::GetMinReqRect, but instead of calculating a rectangle size for 1 month only, it can also calculate a rectangle size for any specified number of month items.

See Also

CMonthCalCtrl::GetMinReqRect

Group

GetMinReqRect Method


CXTPDatePickerControl::GetMonthDelta Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetMonthDelta Method

This member function retrieves the scroll rate for the date picker control.

virtual int GetMonthDelta() const;
Returns

The scroll rate for the date picker control.

Remarks

This member function implements the behavior of the CMonthCalCtrl::GetMonthDelta function. The scroll rate is the number of months that the control moves its display when the user clicks a scroll button once.

See Also

SetMonthDelta, CMonthCalCtrl::GetMonthDelta

Body Source
int CXTPDatePickerControl::GetMonthDelta() const {
    return m_nMonthDelta ? m_nMonthDelta : 1;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetMonthName Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetMonthName Method

This member function returns the month name of the given integer value.

CString GetMonthName(
    int nMonth
) const;
Parameters

nMonth
Month number. The valid range is 1 <= nMonth >= 12.

Returns

If nMonth is a valid integer value, then the function returns the name of the month. If nMonth is not valid, then the function returns an empty string.

Remarks

Call this member function to retrieve the name of the month which was previously set by SetMonthName function. If month name was not set by SetMonthName function, it will return the default value, which is the default localized month name.

See Also

SetMonthName, SetDayOfWeekName, GetDayOfWeekName

Body Source
CString CXTPDatePickerControl::GetMonthName(int nMonth) const {
    return nMonth >= 1 && nMonth <= 12 ? m_arMonthNames[nMonth - 1] : _T("");
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetMonthRange Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetMonthRange Method

This member function retrieves date information representing the high and low limits of a date picker control's display.

virtual int GetMonthRange(
    COleDateTime& refMinRange,
    COleDateTime& refMaxRange,
    DWORD dwFlags
) const;
Parameters

refMinRange
A reference to a COleDateTime object containing the minimum date allowed.
refMaxRange
A reference to a COleDateTime object containing the maximum date allowed.
dwFlags
Value specifying the scope of the range limits to be retrieved. This value must be one of the following

  • GMR_DAYSTATE - Include preceding and

trailing months of visible range that are only partially displayed.

  • GMR_VISIBLE - Include only those months

that are entirely displayed.

Returns

An integer that represents the range, in months, spanned by the two limits indicated by refMinRange and refMaxRange.

Remarks

This member function implements the behavior of the CMonthCalCtrl::GetMonthRange function.

See Also

CMonthCalCtrl::GetMonthRange

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetPaintManager Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetPaintManager Method

This member function returns a pointer to the associated paint manager.

virtual CXTPDatePickerPaintManager* GetPaintManager();
Returns

Pointer to the paint manager object.

Remarks

Call this member function to obtain a pointer to the paint manager object. The paint manager object is used for drawing the date picker window.

See Also

SetTheme

Body Source
CXTPDatePickerPaintManager* CXTPDatePickerControl::GetPaintManager() {
    return m_pPaintManager;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetPaintTheme Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class
CXTPDatePickerControl::GetPaintTheme Method

This member function is used to obtain current paint theme.

virtual XTPCalendarTheme GetPaintTheme() const;
Returns

A paint theme ID from enum XTPCalendarTheme.

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetRange Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetRange Method

This member function retrieves the current minimum and maximum dates set in a date picker control.

virtual DWORD GetRange(
    COleDateTime* pMinRange,
    COleDateTime* pMaxRange
) const;
Parameters

pMinRange
A pointer to a COleDateTime object containing the date at the lowest end of the range.
pMaxRange
A pointer to a COleDateTime object containing the date at the highest end of the range.

Returns

A DWORD that can be zero (no limits are set) or a combination of the following values that specify limit information.

  • GDTR_MAX - A maximum limit is set for the control. pMaxRange is valid and contains the applicable date information.
  • GDTR_MIN - A minimum limit is set for the control. pMinRange is valid and contains the applicable date information.
Remarks

This member function implements the behavior of the CMonthCalCtrl::GetRange function.

See Also

SetRange, CMonthCalCtrl::GetRange

Example

See CMonthCalCtrl::GetRange documentation for the example.

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetRows Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetRows Method

Call this member function to obtain the number of rows in the months grid.

virtual int GetRows();
Returns

The number of rows in the control's months grid.

See Also

GetCols, SetGridSize

Body Source
int CXTPDatePickerControl::GetRows() {
    return m_nRows;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetSelectedDays Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetSelectedDays Method

Returns a collection of the days, selected in the date picker.

virtual CXTPDatePickerDaysCollection* GetSelectedDays();
Returns

Pointer to the collection of the selected days. If you want to use pointer to this collection lately in your code, you should increment and decrement references to the object manually.

Remarks

Call this member function to return a CXTPDatePickerDaysCollection collection of the days, selected in the date picker control.

See Also

m_pSelectedDays

Body Source
CXTPDatePickerDaysCollection* CXTPDatePickerControl::GetSelectedDays() {
    return m_pSelectedDays;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetSelRange Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetSelRange Method

This member function retrieves date information representing the upper and lower limits of the date range currently selected by the user.

virtual BOOL GetSelRange(
    COleDateTime& refMinRange,
    COleDateTime& refMaxRange
) const;
Parameters

refMinRange
A reference to a COleDateTime object containing the minimum date allowed.
refMaxRange
A reference to a COleDateTime object containing the maximum date allowed.

Returns

Nonzero if successful. Otherwise 0.

Remarks

This member function implements the behavior of the CMonthCalCtrl::GetSelRange function.

See Also

SetSelRange, CMonthCalCtrl::GetSelRange

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetShowNonMonthDays Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetShowNonMonthDays Method

Call this member function to determine if the non-month days are visible.

virtual BOOL GetShowNonMonthDays();
Returns

A boolean value that specifies if the "non-month days" are visible.

TRUE if non-month days are visible.

FALSE otherwise.

Remarks

Non-month days are shown in a special color or font just before and after regular days of a specific month.

Notes

For a control showing more than 1 month, non-month days are shown before the first month, and after the last month.

See Also

SetShowNonMonthDays, CXTPDatePickerPaintManager::GetNonMonthDayBackColor, CXTPDatePickerPaintManager::GetNonMonthDayTextColor, CXTPDatePickerPaintManager::GetNonMonthDayTextFont

Body Source
BOOL CXTPDatePickerControl::GetShowNonMonthDays() {
    return m_bShowNonMonthDays;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetShowWeekNumbers Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetShowWeekNumbers Method

Call this member function to determine if the week numbers are visible.

virtual BOOL GetShowWeekNumbers();
Returns

Boolean value that determines if the week numbers are set to be shown.

TRUE - If the week numbers are visible.

FALSE - If the week numbers are not visible.

Remarks

The week numbers are shown for each week in each month as the very left column of the month, separated by the vertical line from the other week days. This member function determines if the week numbers are shown.

See Also

SetShowWeekNumbers, CXTPDatePickerPaintManager::GetWeekNumbersBackColor, CXTPDatePickerPaintManager::GetWeekNumbersTextColor, CXTPDatePickerPaintManager::GetWeekNumbersTextFont

Body Source
BOOL CXTPDatePickerControl::GetShowWeekNumbers() {
    return m_bShowWeekNumbers;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetToday Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetToday Method

This member function retrieves the date information for the date specified as "Today" for the date picker control.

virtual BOOL GetToday(
    COleDateTime& refDateTime
) const;
Parameters

refDateTime
A reference to a COleDateTime object indicating the current day.

Returns

Nonzero if successful. Otherwise 0.

Remarks

This member function implements the behavior of the CMonthCalCtrl::GetToday function.

See Also

GetHighlightToday, SetHighlightToday, SetToday, CMonthCalCtrl::GetToday

Body Source
BOOL CXTPDatePickerControl::GetToday(COleDateTime& refDateTime) const {
    refDateTime = m_dtToday;
    return TRUE;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GetVisibleRange Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GetVisibleRange Method

This member function retrieves first and last displayed days dates.

virtual BOOL GetVisibleRange(
    COleDateTime& refFirstVisibleDay,
    COleDateTime& refLastVisibleDay
) const;
Parameters

refFirstVisibleDay
A first displayed day date.
refLastVisibleDay
A last displayed day date.

Returns

TRUE if succeeded, otherwise FALSE;

See Also

GetMonthRange

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::GoModal Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::GoModal Method

This member function implements pop-up window behavior for the Date Picker control.

virtual BOOL GoModal(
    const RECT& rect,
    CWnd* pParentWnd = NULL
);
Parameters

rect
Rectangle that contains the size and position of the window, in client coordinates of pParentWnd.
pParentWnd
Pointer to the parent window.

Returns

TRUE if successful, FALSE otherwise.

See Also

IsModal

Group

CXTPDatePickerControl Methods


HitTest Method

CXTPDatePickerControl Methods
HitTest Method
Overload List
Methods
Method | Description
CXTPDatePickerControl::HitTest (CPoint) | This member function finds the month item at the provided point.
CXTPDatePickerControl::HitTest (PMCHITTESTINFO) | This member function finds the month item at the provided point.
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::HitTest Method (CPoint)

HitTest Method, CXTPDatePickerControl Class, See Also
CXTPDatePickerControl::HitTest Method (CPoint)

This member function finds the month item at the provided point.

virtual CXTPDatePickerItemMonth* HitTest(
    CPoint ptMouse
);
virtual DWORD HitTest(
    PMCHITTESTINFO pMCHitTest
);
Parameters

ptMouse
The mouse coordinates to test.
pMCHitTest
A pointer to a MCHITTESTINFO structure containing hit testing points for the date picker control.

Returns

A pointer to the month item where the mouse was clicked. Returns NULL if the mouse was clicked outside the months grid area.

HitTest(PMCHITTESTINFO pMCHitTest) returns a DWORD value. Equal to the uHit member of the MCHITTESTINFO structure.

Remarks

Call this function to retrieve a pointer to the month item at the specified position.

This HitTest(PMCHITTESTINFO pMCHitTest) function determines which date portion of the picker control, if any, is at a specified position. It implements the behavior of the CMonthCalCtrl::HitTest function.

See Also

HitTest, CMonthCalCtrl::HitTest, MCHITTESTINFO

Group

HitTest Method


CXTPDatePickerControl::InitNames Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::InitNames Method

This member function initializes the month and day names depending on localization.

virtual void InitNames();
Remarks

This is an internal initialization function that reads the system user locale defaults and fills the month and day of the week arrays with the locale defaults.

See Also

GetMonthName, SetMonthName, GetDayOfWeekName, SetDayOfWeekName

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::IsAllowNoncontinuousSelection Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::IsAllowNoncontinuousSelection Method

This member function returns the flag which shows whether control allows non-continuous days selection or not.

virtual BOOL IsAllowNoncontinuousSelection();
Returns

TRUE when non-continuous days selection is allowed, FALSE otherwise.

Remarks

Allowing continuous days selection means that user will be able to select only a single days interval between 2 dates, where all dates will be selected inside. Non-continuous days selection means that user will be able to select any specific dates totally up to MaxSelCount count.

See Also

AllowNoncontinuousSelection, SetMaxSelCount, GetMaxSelCount

Body Source
BOOL CXTPDatePickerControl::IsAllowNoncontinuousSelection() {
    return m_bAllowNoncontinuousSelection;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::IsAutoSize Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::IsAutoSize Method

This function is called to determine if AutoSize mode is set.

virtual BOOL IsAutoSize();
Returns

A boolean value that specifies is AutoSize is enabled.

TRUE if AutoSize is enabled.

Otherwise return FALSE.

Remarks

Call this member function to determine whether the control's auto size mode is enabled.

See Also

SetAutoSize

Body Source
BOOL CXTPDatePickerControl::IsAutoSize() {
    return m_bAutoSize;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::IsFocused Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::IsFocused Method

This function checks a specific date to determine if it is focused.

virtual BOOL IsFocused(
    const COleDateTime& dtDay
) const;
Parameters

dtDay
A date to check.

Returns

TRUE when the day is focused, FALSE otherwise.

Remarks

Focused item is used only for the keyboard navigation and selecting. It is initialized by keyboard using first day of the current selection or if selection is empty the first day of the first visible month is used. Focused item is cleared by mouse or by set selection externally.

See Also

ClearFocus

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::IsModal Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::IsModal Method

Is the control runs in modal mode.

virtual BOOL IsModal() const;
Returns

TRUE when the control is used as a pop-up window, FALSE otherwise.

See Also

GoModal

Body Source
BOOL CXTPDatePickerControl::IsModal() const {
    return m_bIsModal;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::IsMultiSelectionMode Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::IsMultiSelectionMode Method

Determines if the multiple selection mode is enabled.

BOOL IsMultiSelectionMode() const;
Returns

TRUE if the multiple selection mode is enabled.

See Also

SetMultiSelectionMode

Body Source
BOOL CXTPDatePickerControl::IsMultiSelectionMode() const {
    return m_bMultiSelectionMode;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::IsNoneButtonVisible Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::IsNoneButtonVisible Method

This function returns the boolean visibility flag of the "None" button.

virtual BOOL IsNoneButtonVisible();
Returns

A boolean value that specifies if the "None" button is visible.

TRUE when the "None" button is visible.

Otherwise FALSE.

Remarks

Call this member function to determine the visibility of the "None" service button.

See Also

IsTodayButtonVisible, SetButtonsVisible

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::IsSelected Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::IsSelected Method

This function checks a specific date to determine if it is contained in the control's selection.

virtual BOOL IsSelected(
    const COleDateTime& dtDay
) const;
Parameters

dtDay
A date to check.

Returns

A boolean value that specifies if the date is contained in the current selection.

TRUE when the day is selected.

Otherwise FALSE.

Remarks

Call this member function to determine whether dtDay is selected.

See Also

Select, Deselect

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::IsTodayButtonVisible Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::IsTodayButtonVisible Method

This member function is used to obtain the value of the visibility flag for the "Today" button.

virtual BOOL IsTodayButtonVisible();
Returns

A boolean value that specifies if the "Today" button is visible.

TRUE if the "Today" button is visible.

Otherwise FALSE.

Remarks

Call this member function to determine the visibility of the "Today" service button.

See Also

IsNoneButtonVisible, SetButtonsVisible

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::OnButtonClick Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::OnButtonClick Method

This member function is used to process the control's button clicks.

virtual void OnButtonClick(
    UINT nID
);
Parameters

nID
Date picker button ID (could be XTP_IDS_DATEPICKER_TODAY or XTP_IDS_DATEPICKER_NONE)

Remarks

This member function performs internal button click processing and sends a XTP_NC_DATEPICKER_BUTTON_CLICK notification to the parent window.

See Also

SendMessageToParent

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::OnDraw Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::OnDraw Method

This member function is used to perform all drawing logic.

virtual void OnDraw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

See Also

DrawButtons

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::Populate Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::Populate Method

This member function performs control population, creating the view from the data.

virtual void Populate();
Remarks

Creates a new month collection for the control, populating it with the new objects created according to the stored properties and settings. Call this member function if the number of months to show needs adjusting.

See Also

ClearMonths

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::PreSubclassWindow Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::PreSubclassWindow Method

This member function is called by the framework to allow other necessary sub-classing to occur before the window is sub-classed.

virtual void PreSubclassWindow();
Remarks

This member function is used to call some internal initialization functions like AdjustLayout() immediately after instantiating the DatePickerControl object.

See Also

Create, CXTPDatePickerControl::CXTPDatePickerControl

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::ProcessButtons Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class
CXTPDatePickerControl::ProcessButtons Method

This member function is used to implement the button behavior.

virtual void ProcessButtons(
    CPoint point
);
Parameters

point
Current mouse position.

Remarks

This member function is called from the following member functions: OnLButtonDown, OnLButtonDblClk, OnLButtonUp, OnMouseLeave, and OnMouseMove.

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::RedrawControl Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::RedrawControl Method

This member function redraws the control windows.

virtual void RedrawControl();
Remarks

Call this member function to redraw all control windows according to the stored parameter values. The window will be updated immediately: CWnd::UpdateWindow() will be called.

See Also

_RedrawControl

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::RegisterWindowClass Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class
CXTPDatePickerControl::RegisterWindowClass Method

This member function registers the window class if it has not already been registered.

virtual BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

A boolean value that specifies if the window is successfully registered.

TRUE if the window class is successfully registered.

Otherwise FALSE.

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::ScrollLeft Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::ScrollLeft Method

This member function scrolls the control's months grid to the left by the specified number of months.

virtual void ScrollLeft(
    int nMonthCount = 1
);
Parameters

nMonthCount
Integer value that specifies how many months to scroll. The default value is 1.

Remarks

Call this member function to scroll the months grid to the left by nMonthCount positions.

See Also

ScrollRight

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::ScrollRight Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::ScrollRight Method

This member function scrolls the control's months grid to the right by the specified amount of months.

virtual void ScrollRight(
    int nMonthCount = 1
);
Parameters

nMonthCount
Integer value that specifies how many months to scroll. The default value is 1.

Remarks

Call this member function to scroll the months grid to the right by nMonthCount positions.

See Also

ScrollLeft

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::Select Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::Select Method

Call this member function to select a specific day.

virtual void Select(
    const COleDateTime& dtDay
);
Parameters

dtDay
Date to be selected.

Remarks

This function determines if one more item can be added to the collection of selected days. If yes, then the selected day is added to the list of selected items.

See Also

Deselect, IsSelected

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SendMessageToParent Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SendMessageToParent Method

Call this member function to send notifications to the parent window.

virtual LRESULT SendMessageToParent(
    int nMessage,
    NMHDR* pNMHDR = NULL
);
Parameters

nMessage
An int that contains the identifier of the message. See remarks section for a list of valid values.
pNMHDR
Pointer to the XTP_NC_DATEPICKER_BUTTON notification structure.

Returns

An LRESULT that is used to indicate the success of the function. Non-zero if the message is sent successfully, zero otherwise.

Remarks

The following values are valid for nMessage:

  • XTP_NC_DATEPICKER_BUTTON_CLICK - Notifies that one of date picker buttons was clicked.
  • XTP_NC_DATEPICKER_SELECTION_CHANGED - Notifies that the date picker selection has changed.

This function notifies the parent window that something happened. For the example of how to catch these messages see below.

Example
// First, add the message handler to your message map.
ON_NOTIFY(XTP_NC_DATEPICKER_BUTTON_CLICK, 1000, OnButtonPressed)

// Then implement the message handler like the example below
void YourDlg::OnButtonPressed(NMHDR* pNotifyStruct, LRESULT*)
{
    XTP_NC_DATEPICKER_BUTTON* pNMButton = (XTP_NC_DATEPICKER_BUTTON*)pNotifyStruct;

    switch (pNMButton->nID)
    {
        case XTP_IDS_DATEPICKER_TODAY:
            TRACE(_T("TODAY BUTTON PRESSEDn"));
            break;
        case XTP_IDS_DATEPICKER_NONE:
            TRACE(_T("NONE BUTTON PRESSEDn"));
            break;
    }
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SendNotification Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SendNotification Method

This member function sends a notification to all control's event subscribers.

virtual void SendNotification(
    XTP_NOTIFY_CODE EventCode,
    WPARAM wParam = 0,
    LPARAM lParam = 0
);
Parameters

EventCode
The specific code of the event.
wParam
First custom parameter. Depends on the event type. See specific event description for details.
lParam
Second custom parameter. Depends on the event type. See specific event description for details.

Remarks

This member function is called internally from inside the control when a notification is sent to all notification listeners.

See Also

XTP_NOTIFICATIONCODE, GetConnection

Body Source
void CXTPDatePickerControl::SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam , LPARAM lParam) {
    m_pConnect->SendEvent(EventCode, wParam, lParam);
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetAutoSize Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetAutoSize Method

This function sets the AutoSize mode.

virtual void SetAutoSize(
    BOOL bAuto = TRUE
);
Parameters

bAuto
Boolean value. If bAuto is TRUE, then AutoSize is enabled. If this parameter is FALSE, then AutoSize is disabled.

Remarks

Set AutoSize mode to TRUE if you want the control to automatically calculate the number of month items according to control's size. When this mode is enabled and there is enough space on control's client area, the control adds a row or a column of month items and centers them both horizontally and vertically.

See Also

IsAutoSize

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetBorderStyle Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetBorderStyle Method

Call this member function to set borders style around the control.

virtual void SetBorderStyle(
    XTPDatePickerBorderStyle borderStyle
);
Parameters

borderStyle
XTPDatePickerBorderStyle value determines whether border style

See Also

GetBorderStyle, CXTPDatePickerPaintManager::DrawBorder, XTPDatePickerBorderStyle

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetButtonRect Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetButtonRect Method

Call this member function to calculate and set the buttons bounding rectangle.

virtual void SetButtonRect();
See Also

CalcButtonSize, CalcButtonBandRect

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetButtonsVisible Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetButtonsVisible Method

This function sets visibility for the "Today" and "None" buttons.

virtual void SetButtonsVisible(
    BOOL bShowToday,
    BOOL bShowNone
);
Parameters

bShowToday
Provide TRUE to show the "Today" button, or FALSE to hide it.
bShowNone
Provide TRUE to show the "None" button, or FALSE to hide it.

Remarks

Call this member function to hide or show any of the control's service buttons.

See Also

IsTodayButtonVisible, IsNoneButtonVisible

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetCallbackDayMetrics Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetCallbackDayMetrics Method

This member function sets the user defined day metrics callback function.

virtual void SetCallbackDayMetrics(
    PFNITEMMETRICS pFunc,
    void* pParam = NULL
);
Parameters

pFunc
Pointer to the callback function.
pParam
Pointer to any user defined parameter provided to the callback function.

Remarks

Call this member function to set up the user defined callback function to manipulate the 'special day's attributes'.

See Also

PFNITEMMETRICS, GetCallbackDayMetrics, GetDayMetrics

Body Source
void CXTPDatePickerControl::SetCallbackDayMetrics(PFNITEMMETRICS pFunc, void* pParam) {
    m_pfnCallback = pFunc;
    m_pCallbackParam = pParam;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetCurSel Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetCurSel Method

This member function sets the currently selected date for the date picker control.

virtual BOOL SetCurSel(
    const COleDateTime& refDateTime
);
Parameters

refDateTime
A reference to a COleDateTime object, which contains a date to select.

Returns

Nonzero if successful. Otherwise 0.

Remarks

This member function clears the selection of a date picker control and selects a specified date.

See Also

GetCurSel, CMonthCalCtrl::GetCurSel

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetDayOfWeekName Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetDayOfWeekName Method

This member function sets the user-defined DayOfWeek name.

void SetDayOfWeekName(
    int nDayOfWeek,
    LPCTSTR strDayOfWeekName
);
Parameters

nDayOfWeek
DayOfWeek number to set new name for.
strDayOfWeekName
New DayOfWeek name.

Remarks

Valid day-of-week range is between 1 and 7, where 1 = Sunday, 2 = Monday, and so on.

See Also

GetDayOfWeekName, SetMonthName, GetMonthName

Body Source
void CXTPDatePickerControl::SetDayOfWeekName(int nDayOfWeek, LPCTSTR strDayOfWeekName) {
    ASSERT(nDayOfWeek >= 1 && nDayOfWeek <= 7);
    m_arDayOfWeekNames[nDayOfWeek - 1] = strDayOfWeekName;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetFirstDayOfWeek Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetFirstDayOfWeek Method

This member function sets the day of the week that is displayed in the leftmost column of the calendar.

virtual void SetFirstDayOfWeek(
    int nDay
);
Parameters

nDay
An integer value representing which day is set as the first day of the week. This value must be one of the day numbers. See GetFirstDayOfWeek for a description of the day numbers.

See Also

GetFirstDayOfWeek

Body Source
void CXTPDatePickerControl::SetFirstDayOfWeek(int nDay) {
    ASSERT(nDay >= 1 && nDay <= 7);
    if (nDay >= 1 && nDay <= 7 && nDay != m_nFirstDayOfWeek)
    {
        m_nFirstDayOfWeek = nDay;
        Populate();
    }
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetFirstWeekOfYearDays Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetFirstWeekOfYearDays Method

This member function sets the required number of this year days in the first week of the year.

virtual void SetFirstWeekOfYearDays(
    int nDays
);
Parameters

nDays
An integer value representing the required number of days of the new year in the first week of the year. The value should be between 1 (default) and 7 (full week).

See Also

GetFirstWeekOfYearDay

Example
// Setup German style of week numbers calculation.
pMyDatePicker->SetFirstWeekOfYearDays(4);
Body Source
void CXTPDatePickerControl::SetFirstWeekOfYearDays(int nDays) {
    ASSERT(nDays >= 1 && nDays <= 7);
    if (nDays >= 1 && nDays <= 7 && nDays != m_nFirstWeekOfYearDays)
    {
        m_nFirstWeekOfYearDays = nDays;
        RedrawControl();
    }
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetGridDimentions Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetGridDimentions Method

This member function sets new dimensions for the month grid.

virtual CSize SetGridDimentions(
    CRect rcGrid
);
Parameters

rcGrid
New rectangle coordinates of the Grid area.

Remarks

Calculates and sets Grid dimensions (rows and columns count) for the grid size.

See Also

AdjustLayout

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetGridSize Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetGridSize Method

Call this member function to set the number of months in the control's grid.

virtual void SetGridSize(
    int nRows,
    int nCols
);
Parameters

nRows
An int that contains the new rows count value.
nCols
An int that contains the new columns count value.

Remarks

This member function is called in the AutoSize mode. It sets the new number of columns and rows in the control's months grid. Also, the function redraws each month within the existing control's coordinates, reducing or enlarging the size of each month item as necessary.

Notes

This function does nothing when AutoSize mode is enabled.

See Also

GetRows, GetCols

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetHighlightToday Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetHighlightToday Method

Call this member function to enable or disable highlighting of the "Today" cell.

virtual void SetHighlightToday(
    BOOL bValue
);
Parameters

bValue
Boolean value determines if the "Today" cell is highlighted.

Remarks

The "Today" cell is determined and changed using the SetToday and GetToday member functions. When highlighting is enabled, the cell is surrounded by a rectangle frame of the specific color.

See Also

GetHighlightToday, SetToday, GetToday, CXTPDatePickerPaintManager::GetHighlightTodayColor

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetLayoutRTL Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class
CXTPDatePickerControl::SetLayoutRTL Method

Call this member to set right-to-left mode.

virtual void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetMaxSelCount Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetMaxSelCount Method

This member function sets the maximum number of days that can be selected in a date picker control.

virtual void SetMaxSelCount(
    int nMax = XTP_SELECTION_INFINITE
);
Parameters

nMax
The value that is set to represent the maximum number of selectable days. XTP_SELECTION_INFINITE if selection is not bounded.

Remarks

This member function implements the behavior of the CMonthCalCtrl::SetMaxSelCount function.

See Also

GetMaxSelCount, AllowNoncontinuousSelection, CMonthCalCtrl::SetMaxSelCount

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetMonthDelta Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetMonthDelta Method

This member function sets the scroll rate for the date picker control.

virtual void SetMonthDelta(
    int iDelta
);
Parameters

iDelta
The number of months set as the control's scroll rate. If this value is zero, the month delta is reset to the default, which is the number of months displayed in the control.

Remarks

This member function implements the behavior of the CMonthCalCtrl::SetMonthDelta function.

See Also

GetMonthDelta, CMonthCalCtrl::SetMonthDelta

Body Source
void CXTPDatePickerControl::SetMonthDelta(int iDelta) {
    m_nMonthDelta = iDelta;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetMonthName Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetMonthName Method

This member function sets the user-defined month name.

void SetMonthName(
    int nMonth,
    LPCTSTR strMonthName
);
Parameters

nMonth
An int that contains the Month number corresponding to the month name. i.e. 1 = January, 2 = February, 3 = March, ... Valid values are from 1 to 12.
strMonthName
A CString that contains the New month name.

Remarks

Use this function to change the shown month name to any preferred or localized values.

See Also

GetMonthName, SetDayOfWeekName, GetDayOfWeekName

Body Source
void CXTPDatePickerControl::SetMonthName(int nMonth, LPCTSTR strMonthName) {
    ASSERT(nMonth >= 1 && nMonth <= 12);
    m_arMonthNames[nMonth - 1] = strMonthName;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetMultiSelectionMode Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetMultiSelectionMode Method

Enables/disables the multiple selection mode for the control.

void SetMultiSelectionMode(
    BOOL bMultiSelectionMode
);
Parameters

bMultiSelectionMode
TRUE for enabling, FALSE for disabling.

Remarks

Sets the flag that determines whether the report is in multiple selection mode.

See Also

IsMultiSelectionMode

Body Source
void CXTPDatePickerControl::SetMultiSelectionMode(BOOL bMultiSelectionMode) {
    m_bMultiSelectionMode = bMultiSelectionMode;
}
Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetPaintTheme Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class
CXTPDatePickerControl::SetPaintTheme Method

This member function is used to set current paint theme.

virtual void SetPaintTheme(
    XTPCalendarTheme ePaintTheme
);
Parameters

ePaintTheme
A paint theme ID from enum XTPCalendarTheme.

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetRange Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetRange Method

This member function sets the minimum and maximum allowable dates for a date picker control.

virtual BOOL SetRange(
    const COleDateTime* pMinRange,
    const COleDateTime* pMaxRange
);
Parameters

pMinRange
A pointer to a COleDateTime object containing the date at the lowest end of the range.
pMaxRange
A pointer to a COleDateTime object containing the date at the highest end of the range.

Returns

Nonzero if successful. Otherwise 0.

Remarks

This member function implements the behavior of the CMonthCalCtrl::GetRange function.

See Also

GetRange, CMonthCalCtrl::SetRange

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetSelRange Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetSelRange Method

This member function sets the selection for a date picker control to a given date range.

virtual BOOL SetSelRange(
    const COleDateTime& refMinRange,
    const COleDateTime& refMaxRange
);
Parameters

refMinRange
A reference to a COleDateTime object containing the date at the lowest end of the range.
refMaxRange
A reference to a COleDateTime object containing the date at the highest end of the range.

Returns

Nonzero if successful. Otherwise 0.

Remarks

This member function implements the behavior of the CMonthCalCtrl::SetSelRange function.

Please note that this method doesn't refresh the control, and in order to update control's picture you'll have to call RedrawControl method after changing a selection.

See Also

GetSelRange, CMonthCalCtrl::SetSelRange

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetShowNonMonthDays Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetShowNonMonthDays Method

Call this member function to show or hide non-month days.

virtual void SetShowNonMonthDays(
    BOOL bShow
);
Parameters

bShow
Boolean value determines if the non month days are shown. TRUE If the non-month days are visible. FALSE If the non-month days are not visible.

Remarks

Non-month days are shown in a special color or font. Non-month days are shown just before and after regular days of a specific month.

Notes

For a control showing more than 1 month, non-month days will be shown before the first month, and after the last one.

See Also

GetShowNonMonthDays, CXTPDatePickerPaintManager::GetNonMonthDayBackColor, CXTPDatePickerPaintManager::GetNonMonthDayTextColor, CXTPDatePickerPaintManager::GetNonMonthDayTextFont

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetShowWeekNumbers Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetShowWeekNumbers Method

Call this member function to show or hide the week numbers.

virtual void SetShowWeekNumbers(
    BOOL bValue
);
Parameters

bValue
Boolean value determines whether week numbers are visible.

Remarks

Week numbers are shown for each week in each month at the very left column of the month, separated by the vertical line from the other week days. This member function controls the visibility mode of the week numbers.

See Also

GetShowWeekNumbers, CXTPDatePickerPaintManager::GetWeekNumbersBackColor, CXTPDatePickerPaintManager::GetWeekNumbersTextColor, CXTPDatePickerPaintManager::GetWeekNumbersTextFont

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetTheme Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetTheme Method

This member function sets the new control drawing theme.

virtual void SetTheme(
    CXTPDatePickerPaintManager* pPaintManager = NULL
);
Parameters

pPaintManager
Pointer of the new paint manager object or derived class like CXTPDatePickerThemeOffice2007. if NULL - the default paint manager object is set.

Remarks

Call this member function to set the paint manager object that is used for drawing a date picker window.

See Also

GetPaintManager

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SetToday Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SetToday Method

This member function sets the calendar control to the current day.

virtual void SetToday(
    const COleDateTime& refDateTime
);
Parameters

refDateTime
A reference to a COleDateTime object that contains the current date.

Remarks

This member function implements the behavior of the CMonthCalCtrl::SetToday function.

See Also

GetHighlightToday, SetHighlightToday, SetToday, GetToday, CMonthCalCtrl::SetToday

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::ShiftDate Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::ShiftDate Method

This function shifts the specified date for the specified number of months.

static BOOL ShiftDate(
    COleDateTime & refDate,
    int nMonthCount
);
Parameters

refDate
Reference to the COleDateTime object to shift the date on.
nMonthCount
Number of months used for shifting. Can be both positive and negative numbers.

Returns

A BOOL value that specifies if the function is successful.

Return zero if the value of this COleDateTime object is set successfully.

Otherwise return 1.

Remarks

This is a utility function that is used to shift the specified date for a specific number of months.

See Also

COleDateTime overview

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::ShowListHeader Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::ShowListHeader Method

This member function shows a CXTPDatePickerList control at the coordinates specified by rcHeader.

virtual void ShowListHeader(
    CRect rcHeader,
    COleDateTime dtMonth
);
Parameters

rcHeader
The coordinates of the list window.
dtMonth
The month date to start from.

Remarks

Call this member function to force showing of the months pop-up list control.

See Also

CXTPDatePickerList overview

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl::SizeMinReq Method

CXTPDatePickerControl Methods, CXTPDatePickerControl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::SizeMinReq Method

This member function adjusts the date picker control to the minimum size required to display one month.

virtual BOOL SizeMinReq(
    BOOL bRepaint = TRUE
);
Parameters

bRepaint
A BOOL that specifies whether the control is to be repainted. By default, TRUE. If FALSE, no repainting occurs.

Returns

Nonzero if the date picker control is sized to its minimum. Otherwise 0.

Remarks

Calling SizeMinReq successfully displays the entire date picker control for one month's calendar.

See Also

GetMinReqRect, CMonthCalCtrl::SizeMinReq

Group

CXTPDatePickerControl Methods


CXTPDatePickerControl Constructors

CXTPDatePickerControl Class, Legend, Public Methods
CXTPDatePickerControl Constructors
Class

CXTPDatePickerControl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerControl | Default constructor is used to construct a CXTPDatePickerControl object.


CXTPDatePickerControl::CXTPDatePickerControl Constructor

CXTPDatePickerControl Constructors, CXTPDatePickerControl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::CXTPDatePickerControl Constructor

Default constructor is used to construct a CXTPDatePickerControl object.

CXTPDatePickerControl();
Remarks

Construct a CXTPDatePickerControl object in two steps. First, call the constructor CXTPDatePickerControl and then call the Create method, which initializes the window.

See Also

Create

Example
// Declare a local CXTPDatePickerControl object.
CXTPDatePickerControl myDatePicker;

// Declare a dynamic CXTPDatePickerControl object.
CXTPDatePickerControl* pMyDatePicker = new CXTPDatePickerControl();

// Create a window
if (!myDatePicker.Create(WS_CHILD | WS_TABSTOP | WS_VISIBLE, CRect(0, 0, 200, 200), this, ID_DATEPICKER_CONTROL))
{
    TRACE(_T("Failed to create the date picker window\n"));
}
Group

CXTPDatePickerControl Constructors


CXTPDatePickerControl Destructors

CXTPDatePickerControl Class, Legend, Public Methods
CXTPDatePickerControl Destructors
Class

CXTPDatePickerControl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDatePickerControl | Destroys a CXTPDatePickerControl object, handles cleanup and de-allocation.


CXTPDatePickerControl::~CXTPDatePickerControl Destructor

CXTPDatePickerControl Destructors, CXTPDatePickerControl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerControl::~CXTPDatePickerControl Destructor

Destroys a CXTPDatePickerControl object, handles cleanup and de-allocation.

virtual ~CXTPDatePickerControl();
Group

CXTPDatePickerControl Destructors


CXTPDatePickerDaysCollection Class

XTPDatePickerDaysCollection.h, Classes, Legend, Members, Topics, CXTPDatePickerDaysCollection Structures, CXTPDatePickerDaysCollection Data Members, CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Constructors, CXTPDatePickerDaysCollection Destructors, CXTPDatePickerDaysCollection Constructors, CXTPDatePickerDaysCollection Data Members, CXTPDatePickerDaysCollection Destructors, CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection Class
Class Hierarchy

class CXTPDatePickerDaysCollection;
File

XTPDatePickerDaysCollection.h

Remarks

Class CXTPDatePickerDaysCollection provides facilities to build various collection of days, for using in groups. For example, the selected days collection. To create an object of this class, simply call the constructor and provide a pointer to the DatePicker controller.

Group

Classes

Legend
Structure
Data Member
protected
Method
virtual
CXTPDatePickerDaysCollection Constructors
CXTPDatePickerDaysCollection Constructors | Description
CXTPDatePickerDaysCollection | Default collection constructor.
CXTPDatePickerDaysCollection Data Members
CXTPDatePickerDaysCollection Data Members | Description
m_arrSelectedBlocks | Contains an array of the selected dates blocks.
m_pControl | This member variable is a pointer to the parent control.
CXTPDatePickerDaysCollection Destructors
CXTPDatePickerDaysCollection Destructors | Description
~CXTPDatePickerDaysCollection | Default collection destructor.
CXTPDatePickerDaysCollection Methods
CXTPDatePickerDaysCollection Methods | Description
Add | Call this member function to add a day to the collection.
Clear | Call this member function to clear the day collection.
Contains | Call this member function to determine if a day is contained in the collection.
GetMinMaxRange | Call this member function to determine the minimum and the maximum day in the collection.
GetSelectedBlock | Call this member function to get the selected block by its index.
GetSelectedBlocksCount | Call this member function to count the number of selected blocks.
GetSelectedDaysCount | Call this member function to count the number of days in the collection.
Remove | Call this member function to remove a day from the collection.
Select | Call this member function to select a day
SelectRange | Call this member function to select days
CXTPDatePickerDaysCollection Structures
CXTPDatePickerDaysCollection Structures | Description
SELECTED_BLOCK | Selected block structure. Each member is represented by an integer part of a corresponding COleDateTime value.


CXTPDatePickerDaysCollection Structures

CXTPDatePickerDaysCollection Class, Legend, Structures
CXTPDatePickerDaysCollection Structures
Class

CXTPDatePickerDaysCollection Class

Legend
Structure
Structures
Structure | Description
SELECTED_BLOCK | Selected block structure. Each member is represented by an integer part of a corresponding COleDateTime value.


CXTPDatePickerDaysCollection::SELECTED_BLOCK Structure

XTPDatePickerDaysCollection.h, CXTPDatePickerDaysCollection Structures, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::SELECTED_BLOCK Structure

Selected block structure. Each member is represented by an integer part of a corresponding COleDateTime value.

struct SELECTED_BLOCK {
  long nDateBegin;
  long nDateEnd;
};
File

XTPDatePickerDaysCollection.h

Members

nDateBegin
Begin date
nDateEnd
End date

Example

You can create COleDateTime in a following manner:

COleDateTime dtValue;
dtValue = (DATE)(double)block.nDateBegin;
Group

CXTPDatePickerDaysCollection Structures


CXTPDatePickerDaysCollection Data Members

CXTPDatePickerDaysCollection Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection Data Members
Class

CXTPDatePickerDaysCollection Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrSelectedBlocks | Contains an array of the selected dates blocks.
m_pControl | This member variable is a pointer to the parent control.


CXTPDatePickerDaysCollection::m_arrSelectedBlocks Data Member

CXTPDatePickerDaysCollection Data Members, CXTPDatePickerDaysCollection Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::m_arrSelectedBlocks Data Member

Contains an array of the selected dates blocks.

CArray<SELECTED_BLOCK, SELECTED_BLOCK&> m_arrSelectedBlocks;
Group

CXTPDatePickerDaysCollection Data Members


CXTPDatePickerDaysCollection::m_pControl Data Member

CXTPDatePickerDaysCollection Data Members, CXTPDatePickerDaysCollection Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::m_pControl Data Member

This member variable is a pointer to the parent control.

CXTPDatePickerControl* m_pControl;
Group

CXTPDatePickerDaysCollection Data Members


CXTPDatePickerDaysCollection Methods

CXTPDatePickerDaysCollection Class, Legend, Public Methods
CXTPDatePickerDaysCollection Methods
Class

CXTPDatePickerDaysCollection Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Add | Call this member function to add a day to the collection.
Clear | Call this member function to clear the day collection.
Contains | Call this member function to determine if a day is contained in the collection.
GetMinMaxRange | Call this member function to determine the minimum and the maximum day in the collection.
GetSelectedBlock | Call this member function to get the selected block by its index.
GetSelectedBlocksCount | Call this member function to count the number of selected blocks.
GetSelectedDaysCount | Call this member function to count the number of days in the collection.
Remove | Call this member function to remove a day from the collection.
Select | Call this member function to select a day
SelectRange | Call this member function to select days


CXTPDatePickerDaysCollection::Add Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::Add Method

Call this member function to add a day to the collection.

void Add(
    const COleDateTime& dtDay
);
Parameters

dtDay
Date of a day, the key of the new element.

Remarks

The primary means to insert an element into a map. First, search for the key. If the key is found, then the corresponding value is changed. Otherwise, a new key-value pair is created an added to the map.

See Also

Remove

Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::Clear Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::Clear Method

Call this member function to clear the day collection.

void Clear();
Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::Contains Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::Contains Method

Call this member function to determine if a day is contained in the collection.

BOOL Contains(
    const COleDateTime& dtDay
) const;
Parameters

dtDay
Date of a day. The key that identifies the element to search for.

Returns

Nonzero if the element was found. Otherwise 0.

Remarks

This function uses a hash algorithm to quickly find the map element using a key that exactly matches the given key.

Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::GetMinMaxRange Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::GetMinMaxRange Method

Call this member function to determine the minimum and the maximum day in the collection.

BOOL GetMinMaxRange(
    COleDateTime& refMinRange,
    COleDateTime& refMaxRange
) const;
Parameters

refMinRange
A COleDateTime reference to the minimum date storage variable.
refMaxRange
A COleDateTime reference to maximum date storage variable.

Returns

A boolean value. TRUE if successful. Otherwise FALSE.

Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::GetSelectedBlock Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::GetSelectedBlock Method

Call this member function to get the selected block by its index.

SELECTED_BLOCK GetSelectedBlock(
    int nIndex
);
Parameters

nIndex
Selected block to retrieve.

Body Source
CXTPDatePickerDaysCollection::SELECTED_BLOCK CXTPDatePickerDaysCollection::GetSelectedBlock(int nIndex) {
    ASSERT(nIndex >= 0 && nIndex < (int)m_arrSelectedBlocks.GetSize());
    return m_arrSelectedBlocks[nIndex];
}
Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::GetSelectedBlocksCount Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::GetSelectedBlocksCount Method

Call this member function to count the number of selected blocks.

int GetSelectedBlocksCount();
Returns

An integer value representing the number of selected blocks.

Body Source
int CXTPDatePickerDaysCollection::GetSelectedBlocksCount() {
    return (int)m_arrSelectedBlocks.GetSize();
}
Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::GetSelectedDaysCount Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::GetSelectedDaysCount Method

Call this member function to count the number of days in the collection.

int GetSelectedDaysCount();
Returns

An integer value representing the number of day items in the collection.

Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::Remove Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::Remove Method

Call this member function to remove a day from the collection.

void Remove(
    const COleDateTime& dtDay
);
Parameters

dtDay
A COleDateTime reference that contains the date of a day. The key for the element to be removed.

Remarks

Searches the map for the entry corresponding to the supplied key. If the key is found, then the entry is removed.

See Also

Add(COleDateTime&)

Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::Select Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::Select Method

Call this member function to select a day

void Select(
    const COleDateTime& dtDay
);
Parameters

dtDay
Date of a day, the key of the new element.

See Also

Add, SelectRange

Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection::SelectRange Method

CXTPDatePickerDaysCollection Methods, CXTPDatePickerDaysCollection Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::SelectRange Method

Call this member function to select days

void SelectRange(
    const COleDateTime& dtDayBegin,
    const COleDateTime& dtDayEnd
);
Parameters

dtDayBegin
First Date of a day
dtDayEnd
Last Date of a day

See Also

Select

Group

CXTPDatePickerDaysCollection Methods


CXTPDatePickerDaysCollection Constructors

CXTPDatePickerDaysCollection Class, Legend, Public Methods
CXTPDatePickerDaysCollection Constructors
Class

CXTPDatePickerDaysCollection Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerDaysCollection | Default collection constructor.


CXTPDatePickerDaysCollection::CXTPDatePickerDaysCollection Constructor

CXTPDatePickerDaysCollection Constructors, CXTPDatePickerDaysCollection Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::CXTPDatePickerDaysCollection Constructor

Default collection constructor.

CXTPDatePickerDaysCollection(
    CXTPDatePickerControl* pControl
);
Parameters

pControl
Pointer to the DatePicker control object.

Remarks

Handles initial initialization.

Group

CXTPDatePickerDaysCollection Constructors


CXTPDatePickerDaysCollection Destructors

CXTPDatePickerDaysCollection Class, Legend, Public Methods
CXTPDatePickerDaysCollection Destructors
Class

CXTPDatePickerDaysCollection Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDatePickerDaysCollection | Default collection destructor.


CXTPDatePickerDaysCollection::~CXTPDatePickerDaysCollection Destructor

CXTPDatePickerDaysCollection Destructors, CXTPDatePickerDaysCollection Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerDaysCollection::~CXTPDatePickerDaysCollection Destructor

Default collection destructor.

virtual ~CXTPDatePickerDaysCollection();
Remarks

Handles member item deallocation.

See Also

Clear()

Group

CXTPDatePickerDaysCollection Destructors


CXTPDatePickerItemDay Class

XTPDatePickerItemDay.h, Classes, Legend, Members, Topics, CXTPDatePickerItemDay Data Members, CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Constructors, CXTPDatePickerItemDay Destructors, CXTPDatePickerItemDay Constructors, CXTPDatePickerItemDay Data Members, CXTPDatePickerItemDay Destructors, CXTPDatePickerItemDay Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay Class

Class CXTPDatePickerItemDay represents one displayed day item in the calendar.

Class Hierarchy

class CXTPDatePickerItemDay;
File

XTPDatePickerItemDay.h

Remarks

To create the object, call the constructor and provide pointers to the parent CXTPDatePickerControl and CXTPDatePickerItemMonth objects and a date value corresponding to its displayed day.

See Also

CXTPDatePickerControl, CXTPDatePickerItemMonth

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDatePickerItemDay Constructors
CXTPDatePickerItemDay Constructors | Description
CXTPDatePickerItemDay | Default collection constructor.
CXTPDatePickerItemDay Data Members
CXTPDatePickerItemDay Data Members | Description
m_bVisible | This member variable is used as a flag to specify if the day item is visible.The flag values are TRUE if the day item is drawn, otherwise FALSE.
m_dtDay | This member variable is used to specify the visible day date, represented by this Day item.
m_pControl | This member variable is a pointer to the parent date picker control.
m_pMonth | This member variable is a pointer to the parent month item.
m_rcDay | This member variable is used to specify the coordinates of the day spot.
CXTPDatePickerItemDay Destructors
CXTPDatePickerItemDay Destructors | Description
~CXTPDatePickerItemDay | Default collection destructor.
CXTPDatePickerItemDay Methods
CXTPDatePickerItemDay Methods | Description
Draw | Call this member function to draw a day item.
GetDate | Call this member function to get the date of the day.
GetDatePickerControl | This member function is used to get a parent date picker object.
GetMonth | This member function is used to get a parent month object.
GetRect | Call this member function to obtain the day's rectangle area.
IsToday | This member function is used to determine if the day is the "Today" date.
IsVisible | Call this member function to determine if the day is visible.
SetRect | Call this member function to set the day's rectangle area.


CXTPDatePickerItemDay Data Members

CXTPDatePickerItemDay Class, Legend, Protected Data Members
CXTPDatePickerItemDay Data Members
Class

CXTPDatePickerItemDay Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bVisible | This member variable is used as a flag to specify if the day item is visible.The flag values are TRUE if the day item is drawn, otherwise FALSE.
m_dtDay | This member variable is used to specify the visible day date, represented by this Day item.
m_pControl | This member variable is a pointer to the parent date picker control.
m_pMonth | This member variable is a pointer to the parent month item.
m_rcDay | This member variable is used to specify the coordinates of the day spot.


CXTPDatePickerItemDay::m_bVisible Data Member

CXTPDatePickerItemDay Data Members, CXTPDatePickerItemDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::m_bVisible Data Member

This member variable is used as a flag to specify if the day item is visible.The flag values are TRUE if the day item is drawn, otherwise FALSE.

BOOL m_bVisible;
Group

CXTPDatePickerItemDay Data Members


CXTPDatePickerItemDay::m_dtDay Data Member

CXTPDatePickerItemDay Data Members, CXTPDatePickerItemDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::m_dtDay Data Member

This member variable is used to specify the visible day date, represented by this Day item.

COleDateTime m_dtDay;
Group

CXTPDatePickerItemDay Data Members


CXTPDatePickerItemDay::m_pControl Data Member

CXTPDatePickerItemDay Data Members, CXTPDatePickerItemDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::m_pControl Data Member

This member variable is a pointer to the parent date picker control.

CXTPDatePickerControl* m_pControl;
Group

CXTPDatePickerItemDay Data Members


CXTPDatePickerItemDay::m_pMonth Data Member

CXTPDatePickerItemDay Data Members, CXTPDatePickerItemDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::m_pMonth Data Member

This member variable is a pointer to the parent month item.

CXTPDatePickerItemMonth* m_pMonth;
Group

CXTPDatePickerItemDay Data Members


CXTPDatePickerItemDay::m_rcDay Data Member

CXTPDatePickerItemDay Data Members, CXTPDatePickerItemDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::m_rcDay Data Member

This member variable is used to specify the coordinates of the day spot.

CRect m_rcDay;
Group

CXTPDatePickerItemDay Data Members


CXTPDatePickerItemDay Methods

CXTPDatePickerItemDay Class, Legend, Public Methods
CXTPDatePickerItemDay Methods
Class

CXTPDatePickerItemDay Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Draw | Call this member function to draw a day item.
GetDate | Call this member function to get the date of the day.
GetDatePickerControl | This member function is used to get a parent date picker object.
GetMonth | This member function is used to get a parent month object.
GetRect | Call this member function to obtain the day's rectangle area.
IsToday | This member function is used to determine if the day is the "Today" date.
IsVisible | Call this member function to determine if the day is visible.
SetRect | Call this member function to set the day's rectangle area.


CXTPDatePickerItemDay::Draw Method

CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Class
CXTPDatePickerItemDay::Draw Method

Call this member function to draw a day item.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Group

CXTPDatePickerItemDay Methods


CXTPDatePickerItemDay::GetDate Method

CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::GetDate Method

Call this member function to get the date of the day.

COleDateTime GetDate();
Returns

The date of the day shown.

See Also

CXTPDatePickerItemDay::CXTPDatePickerItemDay

Body Source
COleDateTime CXTPDatePickerItemDay::GetDate() {
    return m_dtDay;
}
Group

CXTPDatePickerItemDay Methods


CXTPDatePickerItemDay::GetDatePickerControl Method

CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::GetDatePickerControl Method

This member function is used to get a parent date picker object.

CXTPDatePickerControl* GetDatePickerControl();
Returns

A pointer to CXTPDatePickerControl parent object.

Body Source
CXTPDatePickerControl* CXTPDatePickerItemDay::GetDatePickerControl()
{
    return m_pControl;
}
Group

CXTPDatePickerItemDay Methods


CXTPDatePickerItemDay::GetMonth Method

CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::GetMonth Method

This member function is used to get a parent month object.

CXTPDatePickerItemMonth* GetMonth() const;
Returns

A pointer to CXTPDatePickerItemMonth object which is an owner of this day object.

Body Source
CXTPDatePickerItemMonth* CXTPDatePickerItemDay::GetMonth() const {
    return m_pMonth;
}
Group

CXTPDatePickerItemDay Methods


CXTPDatePickerItemDay::GetRect Method

CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::GetRect Method

Call this member function to obtain the day's rectangle area.

CRect GetRect();
Returns

A CRect that contains the rectangle coordinates of the day item in client coordinates of the parent's CXTPDatePickerControl object.

See Also

SetRect(const CRect& rcDay)

Body Source
CRect CXTPDatePickerItemDay::GetRect() {
    return m_rcDay;
}
Group

CXTPDatePickerItemDay Methods


CXTPDatePickerItemDay::IsToday Method

CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Class
CXTPDatePickerItemDay::IsToday Method

This member function is used to determine if the day is the "Today" date.

BOOL IsToday(
    COleDateTime & dt
);
Parameters

dt
Reference to the COleDateTime object representing the date to check.

Returns

A BOOL that indicates if the day is the "Today" date. TRUE if the day is the "Today" date. Otherwise FALSE.

Group

CXTPDatePickerItemDay Methods


CXTPDatePickerItemDay::IsVisible Method

CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::IsVisible Method

Call this member function to determine if the day is visible.

BOOL IsVisible();
Returns

Boolean value that determines if the day item is visible. TRUE if the day is visible. FALSE otherwise.

Body Source
BOOL CXTPDatePickerItemDay::IsVisible() {
    return m_bVisible;
}
Group

CXTPDatePickerItemDay Methods


CXTPDatePickerItemDay::SetRect Method

CXTPDatePickerItemDay Methods, CXTPDatePickerItemDay Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::SetRect Method

Call this member function to set the day's rectangle area.

void SetRect(
    const CRect& rcDay
);
Parameters

rcDay
Day rectangle in client CXTPDatePickerControl coordinates.

See Also

GetRect()

Body Source
void CXTPDatePickerItemDay::SetRect(const CRect& rcDay) {
    m_rcDay = rcDay;
}
Group

CXTPDatePickerItemDay Methods


CXTPDatePickerItemDay Constructors

CXTPDatePickerItemDay Class, Legend, Public Methods
CXTPDatePickerItemDay Constructors
Class

CXTPDatePickerItemDay Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerItemDay | Default collection constructor.


CXTPDatePickerItemDay::CXTPDatePickerItemDay Constructor

CXTPDatePickerItemDay Constructors, CXTPDatePickerItemDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::CXTPDatePickerItemDay Constructor

Default collection constructor.

CXTPDatePickerItemDay(
    CXTPDatePickerControl* pControl,
    CXTPDatePickerItemMonth* pMonth,
    COleDateTime dtDay
);
Parameters

pControl
Pointer to the DatePicker control.
pMonth
Pointer to the corresponding Month item.
dtDay
Date value.

Remarks

Handles initial initialization.

Group

CXTPDatePickerItemDay Constructors


CXTPDatePickerItemDay Destructors

CXTPDatePickerItemDay Class, Legend, Public Methods
CXTPDatePickerItemDay Destructors
Class

CXTPDatePickerItemDay Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDatePickerItemDay | Default collection destructor.


CXTPDatePickerItemDay::~CXTPDatePickerItemDay Destructor

CXTPDatePickerItemDay Destructors, CXTPDatePickerItemDay Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemDay::~CXTPDatePickerItemDay Destructor

Default collection destructor.

virtual ~CXTPDatePickerItemDay();
Remarks

Handles member item deallocation.

Group

CXTPDatePickerItemDay Destructors


CXTPDatePickerItemMonth Class

XTPDatePickerItemMonth.h, Classes, Legend, Members, Topics, CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Constructors, CXTPDatePickerItemMonth Destructors, CXTPDatePickerItemMonth Constructors, CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Destructors, CXTPDatePickerItemMonth Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth Class

Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.

Class Hierarchy

class CXTPDatePickerItemMonth;
File

XTPDatePickerItemMonth.h

Remarks

Call the constructor to create the object and provide a pointer to the DatePicker control. The date value corresponds to the first day of the month and the grid coordinates. It is not necessary to add day items to the month item after creation. The month item constructor calls the day item constructor and fills the day items.

See Also

CXTPDatePickerItemDay

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDatePickerItemMonth Constructors
CXTPDatePickerItemMonth Constructors | Description
CXTPDatePickerItemMonth | Default CXTPDatePickerItemMonth object constructor.
CXTPDatePickerItemMonth Data Members
CXTPDatePickerItemMonth Data Members | Description
m_arrDays | This member variable is a CArray<CXTPDatePickerItemDay*, CXTPDatePickerItemDay*> object that is used as an internal storage area for the day items.
m_bShowDaysAfter | This member variable is a BOOL that is used to indicate if the "days after this month" are visible.
m_bShowDaysBefore | This member variable is a BOOL that is used to determine if the "days before this month" are visible.
m_bShowLeftScroll | This member variable is a BOOL that is used to determine if the "left scroll triangle" is visible.
m_bShowRightScroll | This member variable is a BOOL that is used to determine if the "right scroll triangle" is visible.
m_dtMonth | This member variable is COleDateTime object that is used as the date with the month definition for the month item.
m_nColumn | This member variable is an int that is used for the column month index.
m_nRow | This member variable is an int that is used for the row month index.
m_pControl | This member variable is a CXTPDatePickerControl object pointer to the parent control
m_rcDaysArea | This member variable is a CRect object that contains the coordinates of the month's "all days" area.
m_rcDaysOfWeek | This member variable is a CRect object that contains the coordinates of the month's "week days" area.
m_rcHeader | This member variable is a CRect object that contains the coordinates of the month's header area.
m_rcLeftScroll | This member variable is a CRect object that contains the coordinates of the left scroll triangle area.
m_rcMonth | This member variable is a CRect object that contains the coordinates of the total month's area.
m_rcRightScroll | This member variable is a CRect object that contains the coordinates of the right scroll triangle area.
m_rcWeekNumbers | This member variable is a CRect object that contains the coordinates of the month's week numbers area.
CXTPDatePickerItemMonth Destructors
CXTPDatePickerItemMonth Destructors | Description
~CXTPDatePickerItemMonth | Default collection destructor.
CXTPDatePickerItemMonth Methods
CXTPDatePickerItemMonth Methods | Description
AdjustLayout | Call this member function to adjust the layout of all sub-items.
AutoAdjustLayout | This member function is used to calculate the size of the header, days of week, week numbers, and the scrolling triangles bounding rectangles.
ByFontAdjustLayout | Call this member function to calculate sizes and counts by font metrics.
ClearDays | Call this member function to cleanup the days array.
Draw | Call this member function to perform drawing logic.
GetDay | Call this member function to obtain the day item by its index in the day collection of the month.
GetDayCount | Call this member function to obtain the number of day items in the month collection.
GetMonth | Call this member function to obtain the month date.
GetShowDaysAfter | Call this member function to determine whether to show the days after this month.
GetShowDaysBefore | Call this member function to determine if the days before a given month are displayed.
GetShowLeftScroll | Call this member function to determine if the left scroll triangle is visible.
GetShowRightScroll | Call this member function to determine if the right scroll triangle is visible.
HitTest | Call this function to return the day where the mouse cursor was located when the left mouse button was clicked.
OnLButtonDown | This member function is called to process left button down mouse messages.
OnLButtonUp | This member function is called to process left button up mouse messages.
OnMouseMove | This function is called to process mouse move messages.
OnSetCursor | This member function is called to process changing cursor message.
PopulateDays | Call this member function to populate the day objects.
SetShowDaysAfter | Call this member function to set whether days after this month are shown.
SetShowDaysBefore | Call this member function to set whether days before this month are shown.
SetShowScrolling | Call this member function to add the left and the right scrolling triangles.


CXTPDatePickerItemMonth Data Members

CXTPDatePickerItemMonth Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth Data Members
Class

CXTPDatePickerItemMonth Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrDays | This member variable is a CArray<CXTPDatePickerItemDay*, CXTPDatePickerItemDay*> object that is used as an internal storage area for the day items.
m_bShowDaysAfter | This member variable is a BOOL that is used to indicate if the "days after this month" are visible.
m_bShowDaysBefore | This member variable is a BOOL that is used to determine if the "days before this month" are visible.
m_bShowLeftScroll | This member variable is a BOOL that is used to determine if the "left scroll triangle" is visible.
m_bShowRightScroll | This member variable is a BOOL that is used to determine if the "right scroll triangle" is visible.
m_dtMonth | This member variable is COleDateTime object that is used as the date with the month definition for the month item.
m_nColumn | This member variable is an int that is used for the column month index.
m_nRow | This member variable is an int that is used for the row month index.
m_pControl | This member variable is a CXTPDatePickerControl object pointer to the parent control
m_rcDaysArea | This member variable is a CRect object that contains the coordinates of the month's "all days" area.
m_rcDaysOfWeek | This member variable is a CRect object that contains the coordinates of the month's "week days" area.
m_rcHeader | This member variable is a CRect object that contains the coordinates of the month's header area.
m_rcLeftScroll | This member variable is a CRect object that contains the coordinates of the left scroll triangle area.
m_rcMonth | This member variable is a CRect object that contains the coordinates of the total month's area.
m_rcRightScroll | This member variable is a CRect object that contains the coordinates of the right scroll triangle area.
m_rcWeekNumbers | This member variable is a CRect object that contains the coordinates of the month's week numbers area.


CXTPDatePickerItemMonth::m_arrDays Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_arrDays Data Member

This member variable is a CArray<CXTPDatePickerItemDay*, CXTPDatePickerItemDay*> object that is used as an internal storage area for the day items.

CArray<CXTPDatePickerItemDay*, CXTPDatePickerItemDay*> m_arrDays;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_bShowDaysAfter Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_bShowDaysAfter Data Member

This member variable is a BOOL that is used to indicate if the "days after this month" are visible.

BOOL m_bShowDaysAfter;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_bShowDaysBefore Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_bShowDaysBefore Data Member

This member variable is a BOOL that is used to determine if the "days before this month" are visible.

BOOL m_bShowDaysBefore;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_bShowLeftScroll Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_bShowLeftScroll Data Member

This member variable is a BOOL that is used to determine if the "left scroll triangle" is visible.

BOOL m_bShowLeftScroll;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_bShowRightScroll Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_bShowRightScroll Data Member

This member variable is a BOOL that is used to determine if the "right scroll triangle" is visible.

BOOL m_bShowRightScroll;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_dtMonth Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_dtMonth Data Member

This member variable is COleDateTime object that is used as the date with the month definition for the month item.

COleDateTime m_dtMonth;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_nColumn Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_nColumn Data Member

This member variable is an int that is used for the column month index.

int m_nColumn;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_nRow Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_nRow Data Member

This member variable is an int that is used for the row month index.

int m_nRow;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_pControl Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_pControl Data Member

This member variable is a CXTPDatePickerControl object pointer to the parent control

CXTPDatePickerControl* m_pControl;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_rcDaysArea Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_rcDaysArea Data Member

This member variable is a CRect object that contains the coordinates of the month's "all days" area.

CRect m_rcDaysArea;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_rcDaysOfWeek Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_rcDaysOfWeek Data Member

This member variable is a CRect object that contains the coordinates of the month's "week days" area.

CRect m_rcDaysOfWeek;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_rcHeader Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_rcHeader Data Member

This member variable is a CRect object that contains the coordinates of the month's header area.

CRect m_rcHeader;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_rcLeftScroll Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_rcLeftScroll Data Member

This member variable is a CRect object that contains the coordinates of the left scroll triangle area.

CRect m_rcLeftScroll;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_rcMonth Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_rcMonth Data Member

This member variable is a CRect object that contains the coordinates of the total month's area.

CRect m_rcMonth;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_rcRightScroll Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_rcRightScroll Data Member

This member variable is a CRect object that contains the coordinates of the right scroll triangle area.

CRect m_rcRightScroll;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth::m_rcWeekNumbers Data Member

CXTPDatePickerItemMonth Data Members, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::m_rcWeekNumbers Data Member

This member variable is a CRect object that contains the coordinates of the month's week numbers area.

CRect m_rcWeekNumbers;
Group

CXTPDatePickerItemMonth Data Members


CXTPDatePickerItemMonth Methods

CXTPDatePickerItemMonth Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth Methods
Class

CXTPDatePickerItemMonth Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
AutoAdjustLayout | This member function is used to calculate the size of the header, days of week, week numbers, and the scrolling triangles bounding rectangles.
ByFontAdjustLayout | Call this member function to calculate sizes and counts by font metrics.
ClearDays | Call this member function to cleanup the days array.
OnLButtonDown | This member function is called to process left button down mouse messages.
OnLButtonUp | This member function is called to process left button up mouse messages.
OnMouseMove | This function is called to process mouse move messages.
OnSetCursor | This member function is called to process changing cursor message.
PopulateDays | Call this member function to populate the day objects.
Public Methods
Public Methods
Public Method | Description
AdjustLayout | Call this member function to adjust the layout of all sub-items.
Draw | Call this member function to perform drawing logic.
GetDay | Call this member function to obtain the day item by its index in the day collection of the month.
GetDayCount | Call this member function to obtain the number of day items in the month collection.
GetMonth | Call this member function to obtain the month date.
GetShowDaysAfter | Call this member function to determine whether to show the days after this month.
GetShowDaysBefore | Call this member function to determine if the days before a given month are displayed.
GetShowLeftScroll | Call this member function to determine if the left scroll triangle is visible.
GetShowRightScroll | Call this member function to determine if the right scroll triangle is visible.
HitTest | Call this function to return the day where the mouse cursor was located when the left mouse button was clicked.
SetShowDaysAfter | Call this member function to set whether days after this month are shown.
SetShowDaysBefore | Call this member function to set whether days before this month are shown.
SetShowScrolling | Call this member function to add the left and the right scrolling triangles.


CXTPDatePickerItemMonth::AdjustLayout Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::AdjustLayout Method

Call this member function to adjust the layout of all sub-items.

void AdjustLayout(
    CRect rcClient,
    BOOL bIsAuto = FALSE
);
Parameters

rcClient
A CRect object that contains the coordinates of the control.
bIsAuto
A BOOL that determines the method that is used to adjust the layout: If TRUE - The layout is adjusted depending on the given control client area rectangle. If FALSE - The layout calculations depend on the current display settings of all included items (day items, header items) and the current device context.

Remarks

Adjusts the layout of all sub-items in two different ways depending on the bIsAuto parameter. If bIsAuto = TRUE, then the layout is adjusted depending on the given control's client area rectangle. In this case the given count of month items is adjusted to fit the client area. If bIsAuto = FALSE, then the layout calculation depends on the current display settings of all included items (day items, header items) and the current device context. In this case the size of one month item is calculated first, this then determines the count of the month items that fit into the control's client rectangle. Note: The second method is the default mode.

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::AutoAdjustLayout Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::AutoAdjustLayout Method

This member function is used to calculate the size of the header, days of week, week numbers, and the scrolling triangles bounding rectangles.

void AutoAdjustLayout(
    CRect rcClient
);
Parameters

rcClient
A CRect object that contains the coordinates that specifies where the control is drawn.

Remarks

This member function implements one of the branches of AdjustLayout(). If TRUE, then the layout is adjusted depending on the given control client area rectangle. In this case, the given count of month items is adjusted to fit the client area.

See Also

AdjustLayout()

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::ByFontAdjustLayout Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::ByFontAdjustLayout Method

Call this member function to calculate sizes and counts by font metrics.

void ByFontAdjustLayout(
    CRect rcClient
);
Parameters

rcClient
A CRect object that contains the coordinates of the control and the location where the control is drawn.

Remarks

This member function implements one of the branches of AdjustLayout(). If FALSE - The calculated layout depends on correct display settings of all included items (day items, header items) and current device context. In this case, the size of one month item is calculated first, then it determines the count of month items that fit into the control client rectangle.

See Also

AdjustLayout()

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::ClearDays Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::ClearDays Method

Call this member function to cleanup the days array.

void ClearDays();
Remarks

Handles cleanup of days collection, including each day item.

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::Draw Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::Draw Method

Call this member function to perform drawing logic.

virtual void Draw(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Remarks

This function performs all drawing logic. This member function is used to display the month item. It does not perform any adjustments or size corrections. You must call AdjustLayout(CRect rcClient, BOOL bIsAuto = FALSE) first to handle all adjustments.

See Also

AdjustLayout(CRect rcClient, BOOL bIsAuto = FALSE)

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::GetDay Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::GetDay Method

Call this member function to obtain the day item by its index in the day collection of the month.

CXTPDatePickerItemDay* GetDay(
    int nIndex
);
Parameters

nIndex
An int that contains the zero-based index value.

Returns

A pointer to a CXTPDatePickerItemDay object or NULL if the index is invalid.

Remarks

If the index value is less than 0 and greater then the value returned by GetDayCount() the function returns NULL.

See Also

GetDayCount()

Example
// Enumerate the month array.
CPoint point (100, 100);
int nDayCount = GetDayCount();
for (int nDay = 0; nDay < nDayCount; nDay++)
{
    CXTPDatePickerItemDay* pDay = GetDay(nDay);
    if (pDay && pDay->GetRect().PtInRect(point) && pDay->IsVisible())
    return pDay;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::GetDayCount Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::GetDayCount Method

Call this member function to obtain the number of day items in the month collection.

int GetDayCount() const;
Returns

An int that contains the number of items stored in the collection.

See Also

GetDay(int nIndex)

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::GetMonth Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::GetMonth Method

Call this member function to obtain the month date.

COleDateTime GetMonth();
Returns

A ColeDateTime object that contains the month date for which this item represents.

Remarks

Use this member function to identify the month by date. Use the date that corresponds to the first day of the month.

Body Source
COleDateTime CXTPDatePickerItemMonth::GetMonth() {
    return m_dtMonth;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::GetShowDaysAfter Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::GetShowDaysAfter Method

Call this member function to determine whether to show the days after this month.

BOOL GetShowDaysAfter();
Returns

Boolean value determines whether to show the days after this month. TRUE - If the days after this month are visible. FALSE - If the days after this month are not visible.

Remarks

This option allows changing the behavior of the control in the following way: If the last day of the month is Wednesday you may wish to leave places for the remaining day items empty or display the beginning days from the next month item.

See Also

GetShowDaysBefore()

Body Source
BOOL CXTPDatePickerItemMonth::GetShowDaysAfter() {
    return m_bShowDaysAfter;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::GetShowDaysBefore Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::GetShowDaysBefore Method

Call this member function to determine if the days before a given month are displayed.

BOOL GetShowDaysBefore();
Returns

Boolean value that determines if the days before this month are visible. TRUE if the days before this month are visible. Otherwise FALSE.

Remarks

This option allows changing the behavior of the control in the following way: If the first day of the month is Wednesday you may wish to leave places for Monday and Tuesday items empty to display the last days from previous month item.

See Also

SetShowDaysBefore(BOOL bShow), SetShowDaysAfter(BOOL bShow), GetShowDaysAfter()

Body Source
BOOL CXTPDatePickerItemMonth::GetShowDaysBefore() {
    return m_bShowDaysBefore;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::GetShowLeftScroll Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::GetShowLeftScroll Method

Call this member function to determine if the left scroll triangle is visible.

BOOL GetShowLeftScroll();
Returns

Boolean value determines if the left scroll triangle is visible. TRUE - If the left scroll triangle is visible. FALSE - If the left scroll triangle is not visible.

Remarks

This option allows using scrolling facilities to find and work with month items that currently are not shown in the control. ScrollV to desired month item using the scroll triangle icon.

See Also

GetShowRightScroll, SetShowScrolling

Body Source
BOOL CXTPDatePickerItemMonth::GetShowLeftScroll() {
    return m_bShowLeftScroll;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::GetShowRightScroll Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::GetShowRightScroll Method

Call this member function to determine if the right scroll triangle is visible.

BOOL GetShowRightScroll();
Returns

Boolean value that determines if the right scroll triangle is visible. TRUE - If the right scroll triangle is visible. FALSE - If the right scroll triangle is not visible.

Remarks

This option allows scrolling facilities to find and work with month items that currently are not shown in the control. ScrollV to desired month item using the scroll triangle icon.

See Also

GetShowLeftScroll, SetShowScrolling

Body Source
BOOL CXTPDatePickerItemMonth::GetShowRightScroll() {
    return m_bShowRightScroll;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::HitTest Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::HitTest Method

Call this function to return the day where the mouse cursor was located when the left mouse button was clicked.

CXTPDatePickerItemDay* HitTest(
    CPoint point,
    BOOL bCheckVisible = TRUE
);
Parameters

point
A CPoint object that specifies the x- and y- coordinates of the cursor.
bCheckVisible
TRUE when check visibility flag of the day item. If this parameter is FALSE, the method would return pointer to the corresponding day item even if this day is hidden (for example days from previous month). It is TRUE by default.

Returns

Returns a pointer to the affected day item. Returns NULL if the left mouse button was clicked outside any day area.

Remarks

This member function is heavily used by all event handlers to determine the item that was disturbed by the mouse pointer. If item was found, then the function returns a pointer to item, otherwise NULL is returned.

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::OnLButtonDown Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::OnLButtonDown Method

This member function is called to process left button down mouse messages.

void OnLButtonDown(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that is used to indicate whether various virtual keys are down.
point
A CPoint object that specifies the x- and y- coordinates of the cursor.

Remarks

This function is called from control event handlers.

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::OnLButtonUp Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::OnLButtonUp Method

This member function is called to process left button up mouse messages.

void OnLButtonUp(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that indicates whether various virtual keys are down.
point
A CPoint object that specifies the x- and y- coordinates of the cursor.

Remarks

This function is called from control event handlers.

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::OnMouseMove Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::OnMouseMove Method

This function is called to process mouse move messages.

void OnMouseMove(
    UINT nFlags,
    CPoint point
);
Parameters

nFlags
A UINT that indicates whether various virtual keys are down.
point
A CPoint object that specifies the x- and y- coordinates of the cursor.

Remarks

This function is called from control event handlers.

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::OnSetCursor Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::OnSetCursor Method

This member function is called to process changing cursor message.

BOOL OnSetCursor(
    CPoint point
);
Parameters

point
A CPoint object that specifies the x- and y- coordinates of the cursor.

Returns

Nonzero to halt further processing, or 0 to continue.

Remarks

This function is called from control event handlers.

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::PopulateDays Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::PopulateDays Method

Call this member function to populate the day objects.

void PopulateDays();
Remarks

Creates days objects based on the current settings.

Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::SetShowDaysAfter Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::SetShowDaysAfter Method

Call this member function to set whether days after this month are shown.

void SetShowDaysAfter(
    BOOL bShow
);
Parameters

bShow
Boolean value that determines if the days after this month are displayed.

TRUE if the days after this month are visible.

FALSE if the days after this month are not visible.

Remarks

This option allows changing the behavior of the control in the following way: If the last day of month is Wednesday you may wish to leave places for remaining day items empty or display the beginning days from next month item.

See Also

GetShowDaysAfter()

Body Source
void CXTPDatePickerItemMonth::SetShowDaysAfter(BOOL bShow) {
    m_bShowDaysAfter = bShow;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::SetShowDaysBefore Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::SetShowDaysBefore Method

Call this member function to set whether days before this month are shown.

void SetShowDaysBefore(
    BOOL bShow
);
Parameters

bShow
Boolean value that determines if the days before this month are displayed.

TRUE if the days before this month are shown.

FALSE if the days before this month are not shown.

Remarks

This option allows changing the behavior of the control in the following way: If the first day of the month is Wednesday you may leave places for Monday and Tuesday items empty or display the last days from the previous month item.

See Also

GetShowDaysBefore()

Body Source
void CXTPDatePickerItemMonth::SetShowDaysBefore(BOOL bShow) {
    m_bShowDaysBefore = bShow;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth::SetShowScrolling Method

CXTPDatePickerItemMonth Methods, CXTPDatePickerItemMonth Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::SetShowScrolling Method

Call this member function to add the left and the right scrolling triangles.

void SetShowScrolling(
    BOOL bLeftScroll,
    BOOL bRightScroll
);
Parameters

bLeftScroll
Boolean value determines if the left scroll triangle is visible.

TRUE Left scrolling triangle is visible. Right scrolling triangle is visible.

FALSE Left scrolling triangle is not visible. Right scrolling triangle is not visible.

bRightScroll
Boolean value determines if the right scroll triangle is visible.

Remarks

This option allows scrolling facilities to find and work with month items that currently aren't shown in the control. ScrollV to the desired month item using the scroll triangle icon. In some cases scrolling is not needed, and you can hide one or both scrolling triangles.

See Also

GetShowLeftScroll, GetShowRightScroll

Body Source
void CXTPDatePickerItemMonth::SetShowScrolling(BOOL bLeftScroll, BOOL bRightScroll) {
    m_bShowLeftScroll = bLeftScroll;
    m_bShowRightScroll = bRightScroll;
}
Group

CXTPDatePickerItemMonth Methods


CXTPDatePickerItemMonth Constructors

CXTPDatePickerItemMonth Class, Legend, Public Methods
CXTPDatePickerItemMonth Constructors
Class

CXTPDatePickerItemMonth Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerItemMonth | Default CXTPDatePickerItemMonth object constructor.


CXTPDatePickerItemMonth::CXTPDatePickerItemMonth Constructor

CXTPDatePickerItemMonth Constructors, CXTPDatePickerItemMonth Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::CXTPDatePickerItemMonth Constructor

Default CXTPDatePickerItemMonth object constructor.

CXTPDatePickerItemMonth(
    CXTPDatePickerControl* pControl,
    COleDateTime dtMonth,
    int nRow,
    int nCol
);
Parameters

pControl
A CXTPDatePickerControl pointer to the parent DatePicker control.
dtMonth
A COleDateTime object date of the first day of the month.
nRow
An int that contains the vertical coordinate of the month in the control's months grid.
nCol
An int that contains the horizontal coordinate of the month in the control's months grid.

Remarks

Handles initial initialization, populates the month item with the corresponding day items.

See Also

PopulateDays(), CXTPDatePickerItemDay

Group

CXTPDatePickerItemMonth Constructors


CXTPDatePickerItemMonth Destructors

CXTPDatePickerItemMonth Class, Legend, Public Methods
CXTPDatePickerItemMonth Destructors
Class

CXTPDatePickerItemMonth Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDatePickerItemMonth | Default collection destructor.


CXTPDatePickerItemMonth::~CXTPDatePickerItemMonth Destructor

CXTPDatePickerItemMonth Destructors, CXTPDatePickerItemMonth Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerItemMonth::~CXTPDatePickerItemMonth Destructor

Default collection destructor.

virtual ~CXTPDatePickerItemMonth();
Remarks

Handles member items deallocation.

See Also

ClearDays()

Group

CXTPDatePickerItemMonth Destructors


CXTPDatePickerList Class

XTPDatePickerList.h, Classes, Legend, Members, Topics, CXTPDatePickerList Methods, CXTPDatePickerList Constructors, CXTPDatePickerList Destructors, CXTPDatePickerList Constructors, CXTPDatePickerList Destructors, CXTPDatePickerList Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerList Class

This class provides the functionality of a list control which displays month names.

Class Hierarchy

class CXTPDatePickerList : public CWnd;
File

XTPDatePickerList.h

Remarks

The CXTPDatePickerList provides a functionality of a list control which displays a collection of month names in a pop-up list window, allowing the user to scroll up and down and to choose any specific month for further selecting in the date picker control.

See Also

CMonthCalCtrl

Group

Classes

Legend
Method
protected
virtual
CXTPDatePickerList Constructors
CXTPDatePickerList Constructors | Description
CXTPDatePickerList | Constructs a CXTPDatePickerList object.
CXTPDatePickerList Destructors
CXTPDatePickerList Destructors | Description
~CXTPDatePickerList | Destroys a CXTPDatePickerList object, handles cleanup and de-allocation.
CXTPDatePickerList Methods
CXTPDatePickerList Methods | Description
Create | Creates the List Window with position and sizes.
GetListSize | Calculates size of list by font and control sizes.
GetMonthInterval | Returns an interval between start month and selected month.
IsSelected | Determines whether an item is selected.
ScrollDown | Implements scroll down functionality.
ScrollUp | Implements scroll up functionality


CXTPDatePickerList Methods

CXTPDatePickerList Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerList Methods
Class

CXTPDatePickerList Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
GetListSize | Calculates size of list by font and control sizes.
IsSelected | Determines whether an item is selected.
Public Methods
Public Methods
Public Method | Description
Create | Creates the List Window with position and sizes.
GetMonthInterval | Returns an interval between start month and selected month.
ScrollDown | Implements scroll down functionality.
ScrollUp | Implements scroll up functionality


CXTPDatePickerList::Create Method

CXTPDatePickerList Methods, CXTPDatePickerList Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerList::Create Method

Creates the List Window with position and sizes.

BOOL Create(
    CRect rcList
);
Parameters

rcList
Rectangle determining list window position and size.

Returns

Nonzero if successful; otherwise 0.

Remarks

Construct a CXTPDatePickerList object in two steps. First, call the constructor CXTPDatePickerList and then call Create method, which initializes the window.

See Also

CXTPDatePickerList::CXTPDatePickerList

Example

For the example, see CXTPDatePickerList::CXTPDatePickerList.

Group

CXTPDatePickerList Methods


CXTPDatePickerList::GetListSize Method

CXTPDatePickerList Methods, CXTPDatePickerList Class
CXTPDatePickerList::GetListSize Method

Calculates size of list by font and control sizes.

CSize GetListSize();
Returns

A size of the list to create.

Group

CXTPDatePickerList Methods


CXTPDatePickerList::GetMonthInterval Method

CXTPDatePickerList Methods, CXTPDatePickerList Class
CXTPDatePickerList::GetMonthInterval Method

Returns an interval between start month and selected month.

int GetMonthInterval();
Returns

A number of months between start month and selected one.

Remarks

Call this member function at any time to determine which month is currently selected in the list.

Group

CXTPDatePickerList Methods


CXTPDatePickerList::IsSelected Method

CXTPDatePickerList Methods, CXTPDatePickerList Class
CXTPDatePickerList::IsSelected Method

Determines whether an item is selected.

BOOL IsSelected(
    int nX,
    CRect rcItem
);
Parameters

nX
Item zero-based numeric index from the beginning of the list.
rcItem
Coordinates of the item to check.

Returns

TRUE if item is selected, FALSE otherwise.

Group

CXTPDatePickerList Methods


CXTPDatePickerList::ScrollDown Method

CXTPDatePickerList Methods, CXTPDatePickerList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerList::ScrollDown Method

Implements scroll down functionality.

void ScrollDown(
    int nCount = 1
);
Parameters

nCount
determines how many positions will be scrolled.

Remarks

Call this member function to scroll the list with months down by a specified amount of items.

See Also

ScrollUp

Group

CXTPDatePickerList Methods


CXTPDatePickerList::ScrollUp Method

CXTPDatePickerList Methods, CXTPDatePickerList Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerList::ScrollUp Method

Implements scroll up functionality

void ScrollUp(
    int nCount = 1
);
Parameters

nCount
Determines how many positions will be scrolled.

Remarks

Call this member function to scroll the list with months up by a specified amount of items.

See Also

ScrollDown

Group

CXTPDatePickerList Methods


CXTPDatePickerList Constructors

CXTPDatePickerList Class, Legend, Public Methods
CXTPDatePickerList Constructors
Class

CXTPDatePickerList Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerList | Constructs a CXTPDatePickerList object.


CXTPDatePickerList::CXTPDatePickerList Constructor

CXTPDatePickerList Constructors, CXTPDatePickerList Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerList::CXTPDatePickerList Constructor

Constructs a CXTPDatePickerList object.

CXTPDatePickerList(
    CXTPDatePickerControl* pControl,
    COleDateTime dtStartMonth
);
Parameters

pControl
Pointer to the parent CXTPDatePickerControl object
dtStartMonth
A date containing the month which will be created as the central item in the list.

Remarks

Construct a CXTPDatePickerList object in two steps. First, call the constructor CXTPDatePickerList and then call Create method, which initializes the window.

See Also

Create

Example
// Declare a dynamic CXTPDatePickerList object.
pListControl = new CXTPDatePickerList(pDatePickerWnd, dtMonthToShow);

// create control
pListControl->Create(rcHeader);
Group

CXTPDatePickerList Constructors


CXTPDatePickerList Destructors

CXTPDatePickerList Class, Legend, Public Methods
CXTPDatePickerList Destructors
Class

CXTPDatePickerList Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDatePickerList | Destroys a CXTPDatePickerList object, handles cleanup and de-allocation.


CXTPDatePickerList::~CXTPDatePickerList Destructor

CXTPDatePickerList Destructors, CXTPDatePickerList Class
CXTPDatePickerList::~CXTPDatePickerList Destructor

Destroys a CXTPDatePickerList object, handles cleanup and de-allocation.

virtual ~CXTPDatePickerList();
Group

CXTPDatePickerList Destructors


CXTPDatePickerPaintManager Class

XTPDatePickerPaintManager.h, Classes, Legend, Members, Topics, CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Constructors, CXTPDatePickerPaintManager Destructors, CXTPDatePickerPaintManager Constructors, CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Destructors, CXTPDatePickerPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager Class

Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.

Class Hierarchy

class CXTPDatePickerPaintManager;
File

XTPDatePickerPaintManager.h

Remarks

Utility class, handles most of the drawing activities. It stores all settings needed by the control to perform drawing operations : fonts, colors, styles for all others classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with the device context. Can be overridden to provide another look and feel for the control. Thus, you have an easy way to change the "skin" of your control. Provide your own implementation of CXTPDatePickerPaintManager and do not change the functionality all other classes of the control.

Create a DatePickerPaintManager by calling its constructor. Furthermore, call the "get" and "set" functions to change the settings as needed.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPDatePickerPaintManager Constructors
CXTPDatePickerPaintManager Constructors | Description
CXTPDatePickerPaintManager | Default paint manager constructor.
CXTPDatePickerPaintManager Data Members
CXTPDatePickerPaintManager Data Members | Description
m_bEnableTheme | This member variable is a BOOL that is used to indicate if Luna colors are enabled.
m_clr3DLight | This member variable is a COLORREF object that is used to specify the color for light areas
m_clr3DShadow | This member variable is a COLORREF object that is used to specify the color for shadow areas.
m_clrBtnFace | This member variable is a COLORREF object that is used as the basic color for buttons.
m_clrBtnText | This member variable is a COLORREF object that is used as the color for the button text.
m_clrControlBack | This member variable is a COLORREF object that is used as the background color of the control.
m_clrDayBack | This member variable is a COLORREF object that is used as the background color of the normal day item.
m_clrDaysOfWeekBack | This member variable is a COLORREF object that is used for the background color of the days of weeks area.
m_clrDaysOfWeekText | This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
m_clrDayText | This member variable is a COLORREF object that is used as the color of the usual day item.
m_clrHeaderBack | This member variable is a COLORREF object that is used as the background color of the month header area.
m_clrHeaderText | This member variable is a COLORREF object that is used as the text color of the month header area.
m_clrHighlightToday | This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
m_clrListControlBack | This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
m_clrListControlText | This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
m_clrNonMonthDayBack | This member variable is a COLORREF object that is used as the background color of the non month day item.
m_clrNonMonthDayText | This member variable is a COLORREF object that is used as the color of the non month day item.
m_clrSelectedDayBack | This member variable is a COLORREF object that is used as the background color of the selected day item.
m_clrSelectedDayText | This member variable is a COLORREF object that is used as the color of the selected day item.
m_clrStaticBorder | Static border color
m_clrWeekNumbersBack | This member variable is a COLORREF object that is used as the background color of the week numbers area.
m_clrWeekNumbersText | This member variable is a COLORREF object that is used as the text color of the week numbers items.
m_clrWindow | This member variable is a COLORREF object that is used as the Color of the window.
m_fontButton | This member variable is a CFont object that is used as the font for the button text.
m_fontDay | This member variable is a CFont object that is used for the font of the usual day item.
m_fontDayBold | This member variable is a CFont object that is used for the font of the bold day item.
m_fontDaysOfWeek | This member variable is a CFont object that is used as the font for the days of weeks text.
m_fontHeader | This member variable is a CFont object that is used as the font for the header text.
m_fontListControl | This member variable is a CFont object that is used as the font for the pop-up month list control.
m_fontNonMonthDay | This member variable is a CFont object that is used as the font for the non month day item.
m_fontWeekNumbers | This member variable is a CFont object that is used as the font for the week number items text.
m_hCursorBack | Back cursor for week selection
m_nPaintTheme | Store the Paint Theme;
m_pControl | Stores a pointer to owner control.
m_themeButton | This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
CXTPDatePickerPaintManager Destructors
CXTPDatePickerPaintManager Destructors | Description
~CXTPDatePickerPaintManager | Default paint manager destructor.
CXTPDatePickerPaintManager Methods
CXTPDatePickerPaintManager Methods | Description
CalcDayOfWeekRect | This member function calculates the "day of week names" bounding rectangle coordinates.
CalcDayRect | This member function is used to calculate the day's bounding rectangle coordinates.
CalcMonthHeaderRect | This member function calculates the month's header bounding rectangle coordinates.
CalcMonthRect | This member function calculates the month's bounding rectangle coordinates.
CalcWeekNumbersRect | This member function calculates the "week numbers" bounding rectangle coordinates.
DrawBackground | This member function is called to fill the control's background.
DrawBorder | This member function draws a border around the control.
DrawButton | This member function is used to draw the control's buttons.
DrawDay | Call this member function to draw a single month day in the month area.
DrawDaysOfWeek | Call this member function to draw the days of the week in the month header.
DrawMonthHeader | Call this member function to draw the month header in the month area.
DrawScrollTriangle | This member function draws scrolling triangles on the highest bounded month headers.
DrawWeekNumbers | Call this member function to draw the week numbers in the month area.
EnableTheme | This member function is used to switch "Themes".
GetButtonFont | This member function is used to obtain the button's font object.
GetControl | This member function is used to get a parent date picker object.
GetControlBackColor | This member function is used to obtain the control's background color.
GetCursorBack | This member function is used to obtain the back cursor used for weeks selection.
GetDayBackColor | This member function is used to obtain the background color of the standard day item.
GetDaysOfWeekBackColor | This member function returns the background color of the days of weeks area.
GetDaysOfWeekTextColor | This member function obtains the text color of the days of weeks area.
GetDaysOfWeekTextFont | This member function obtains the font of the days of weeks area text.
GetDayTextColor | This member function is used to obtain the color of the standard day item.
GetDayTextFont | This member function is used to obtain a pointer to the font for the standard day item.
GetDayTextFontBold | This member function is used to obtain a pointer to the font for the bolded day item.
GetHeaderBackColor | This member function obtains the background color of the month header area.
GetHeaderTextColor | This member function obtains the text color of the month header area.
GetHeaderTextFont | This member function obtains the font of the month header area text.
GetHighlightTodayColor | This member function obtains the highlighting color of the "Today" item.
GetListControlBackColor | This member function obtains the background color of the pop-up month list control.
GetListControlTextColor | This member function obtains the text color of the pop-up month list control.
GetListControlTextFont | This member function obtains the font of the pop-up month list control.
GetNonMonthDayBackColor | This member function is used to obtain the background color of the non-month day item.
GetNonMonthDayTextColor | This member function is used to obtain the color of the non-month day item.
GetNonMonthDayTextFont | This member function is used to obtain the font of the non-month day item.
GetPaintTheme | This member function is used to obtain current paint theme.
GetSelectedDayBackColor | This member function is used to obtain the background color of the selected day item.
GetSelectedDayTextColor | This member function obtains the color of the selected day item.
GetWeekNumbersBackColor | This member function obtains the background color of the week numbers area.
GetWeekNumbersTextColor | This member function obtains the text color of the week numbers items.
GetWeekNumbersTextFont | This member function obtains the font of the week numbers items.
RefreshMetrics | This member function performs initialization for the Paint Manager.
SetButtonFont | This member function sets the button's font.
SetButtonFontIndirect | This member function sets the button's font using a LOGFONT structure.
SetControl | This member function is used to set a parent date picker object.
SetFontIndirect | This member function is used to set the control's default font using a LOGFONT structure.
SetPaintTheme | This member function is used to set current paint theme.
Triangle | This member function is used to draw a black triangle.


CXTPDatePickerPaintManager Data Members

CXTPDatePickerPaintManager Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager Data Members
Class

CXTPDatePickerPaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bEnableTheme | This member variable is a BOOL that is used to indicate if Luna colors are enabled.
m_clr3DLight | This member variable is a COLORREF object that is used to specify the color for light areas
m_clr3DShadow | This member variable is a COLORREF object that is used to specify the color for shadow areas.
m_clrBtnFace | This member variable is a COLORREF object that is used as the basic color for buttons.
m_clrBtnText | This member variable is a COLORREF object that is used as the color for the button text.
m_clrControlBack | This member variable is a COLORREF object that is used as the background color of the control.
m_clrDayBack | This member variable is a COLORREF object that is used as the background color of the normal day item.
m_clrDaysOfWeekBack | This member variable is a COLORREF object that is used for the background color of the days of weeks area.
m_clrDaysOfWeekText | This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
m_clrDayText | This member variable is a COLORREF object that is used as the color of the usual day item.
m_clrHeaderBack | This member variable is a COLORREF object that is used as the background color of the month header area.
m_clrHeaderText | This member variable is a COLORREF object that is used as the text color of the month header area.
m_clrHighlightToday | This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
m_clrListControlBack | This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
m_clrListControlText | This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
m_clrNonMonthDayBack | This member variable is a COLORREF object that is used as the background color of the non month day item.
m_clrNonMonthDayText | This member variable is a COLORREF object that is used as the color of the non month day item.
m_clrSelectedDayBack | This member variable is a COLORREF object that is used as the background color of the selected day item.
m_clrSelectedDayText | This member variable is a COLORREF object that is used as the color of the selected day item.
m_clrStaticBorder | Static border color
m_clrWeekNumbersBack | This member variable is a COLORREF object that is used as the background color of the week numbers area.
m_clrWeekNumbersText | This member variable is a COLORREF object that is used as the text color of the week numbers items.
m_clrWindow | This member variable is a COLORREF object that is used as the Color of the window.
m_fontButton | This member variable is a CFont object that is used as the font for the button text.
m_fontDay | This member variable is a CFont object that is used for the font of the usual day item.
m_fontDayBold | This member variable is a CFont object that is used for the font of the bold day item.
m_fontDaysOfWeek | This member variable is a CFont object that is used as the font for the days of weeks text.
m_fontHeader | This member variable is a CFont object that is used as the font for the header text.
m_fontListControl | This member variable is a CFont object that is used as the font for the pop-up month list control.
m_fontNonMonthDay | This member variable is a CFont object that is used as the font for the non month day item.
m_fontWeekNumbers | This member variable is a CFont object that is used as the font for the week number items text.
m_hCursorBack | Back cursor for week selection
m_nPaintTheme | Store the Paint Theme;
m_pControl | Stores a pointer to owner control.
m_themeButton | This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.


CXTPDatePickerPaintManager::m_bEnableTheme Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_bEnableTheme Data Member

This member variable is a BOOL that is used to indicate if Luna colors are enabled.

BOOL m_bEnableTheme;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clr3DLight Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clr3DLight Data Member

This member variable is a COLORREF object that is used to specify the color for light areas

COLORREF m_clr3DLight;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clr3DShadow Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clr3DShadow Data Member

This member variable is a COLORREF object that is used to specify the color for shadow areas.

COLORREF m_clr3DShadow;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrBtnFace Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrBtnFace Data Member

This member variable is a COLORREF object that is used as the basic color for buttons.

COLORREF m_clrBtnFace;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrBtnText Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrBtnText Data Member

This member variable is a COLORREF object that is used as the color for the button text.

COLORREF m_clrBtnText;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrControlBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrControlBack Data Member

This member variable is a COLORREF object that is used as the background color of the control.

COLORREF m_clrControlBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrDayBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrDayBack Data Member

This member variable is a COLORREF object that is used as the background color of the normal day item.

COLORREF m_clrDayBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrDaysOfWeekBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrDaysOfWeekBack Data Member

This member variable is a COLORREF object that is used for the background color of the days of weeks area.

COLORREF m_clrDaysOfWeekBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrDaysOfWeekText Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrDaysOfWeekText Data Member

This member variable is a COLORFEF object that is used as the text color of the days of weeks area.

COLORREF m_clrDaysOfWeekText;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrDayText Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrDayText Data Member

This member variable is a COLORREF object that is used as the color of the usual day item.

COLORREF m_clrDayText;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrHeaderBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrHeaderBack Data Member

This member variable is a COLORREF object that is used as the background color of the month header area.

COLORREF m_clrHeaderBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrHeaderText Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrHeaderText Data Member

This member variable is a COLORREF object that is used as the text color of the month header area.

COLORREF m_clrHeaderText;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrHighlightToday Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrHighlightToday Data Member

This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.

COLORREF m_clrHighlightToday;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrListControlBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrListControlBack Data Member

This member variable is a COLORREF object that is used as the background color of the pop-up month list control.

COLORREF m_clrListControlBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrListControlText Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrListControlText Data Member

This member variable is a COLORREF object that is used as the text color of the pop-up month list control.

COLORREF m_clrListControlText;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrNonMonthDayBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrNonMonthDayBack Data Member

This member variable is a COLORREF object that is used as the background color of the non month day item.

COLORREF m_clrNonMonthDayBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrNonMonthDayText Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrNonMonthDayText Data Member

This member variable is a COLORREF object that is used as the color of the non month day item.

COLORREF m_clrNonMonthDayText;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrSelectedDayBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrSelectedDayBack Data Member

This member variable is a COLORREF object that is used as the background color of the selected day item.

COLORREF m_clrSelectedDayBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrSelectedDayText Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrSelectedDayText Data Member

This member variable is a COLORREF object that is used as the color of the selected day item.

COLORREF m_clrSelectedDayText;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrStaticBorder Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrStaticBorder Data Member

Static border color

COLORREF m_clrStaticBorder;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrWeekNumbersBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrWeekNumbersBack Data Member

This member variable is a COLORREF object that is used as the background color of the week numbers area.

COLORREF m_clrWeekNumbersBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrWeekNumbersText Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrWeekNumbersText Data Member

This member variable is a COLORREF object that is used as the text color of the week numbers items.

COLORREF m_clrWeekNumbersText;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_clrWindow Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_clrWindow Data Member

This member variable is a COLORREF object that is used as the Color of the window.

COLORREF m_clrWindow;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_fontButton Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_fontButton Data Member

This member variable is a CFont object that is used as the font for the button text.

CFont m_fontButton;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_fontDay Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_fontDay Data Member

This member variable is a CFont object that is used for the font of the usual day item.

CFont m_fontDay;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_fontDayBold Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_fontDayBold Data Member

This member variable is a CFont object that is used for the font of the bold day item.

CFont m_fontDayBold;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_fontDaysOfWeek Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_fontDaysOfWeek Data Member

This member variable is a CFont object that is used as the font for the days of weeks text.

CFont m_fontDaysOfWeek;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_fontHeader Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_fontHeader Data Member

This member variable is a CFont object that is used as the font for the header text.

CFont m_fontHeader;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_fontListControl Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_fontListControl Data Member

This member variable is a CFont object that is used as the font for the pop-up month list control.

CFont m_fontListControl;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_fontNonMonthDay Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_fontNonMonthDay Data Member

This member variable is a CFont object that is used as the font for the non month day item.

CFont m_fontNonMonthDay;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_fontWeekNumbers Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_fontWeekNumbers Data Member

This member variable is a CFont object that is used as the font for the week number items text.

CFont m_fontWeekNumbers;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_hCursorBack Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_hCursorBack Data Member

Back cursor for week selection

HCURSOR m_hCursorBack;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_nPaintTheme Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_nPaintTheme Data Member

Store the Paint Theme;

XTPCalendarTheme m_nPaintTheme;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_pControl Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_pControl Data Member

Stores a pointer to owner control.

CXTPDatePickerControl* m_pControl;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager::m_themeButton Data Member

CXTPDatePickerPaintManager Data Members, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::m_themeButton Data Member

This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.

CXTPWinThemeWrapper m_themeButton;
Group

CXTPDatePickerPaintManager Data Members


CXTPDatePickerPaintManager Methods

CXTPDatePickerPaintManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager Methods
Class

CXTPDatePickerPaintManager Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetControl | This member function is used to get a parent date picker object.
GetPaintTheme | This member function is used to obtain current paint theme.
SetControl | This member function is used to set a parent date picker object.
SetPaintTheme | This member function is used to set current paint theme.
Triangle | This member function is used to draw a black triangle.
Public Methods
Public Methods
Public Method | Description
CalcDayOfWeekRect | This member function calculates the "day of week names" bounding rectangle coordinates.
CalcDayRect | This member function is used to calculate the day's bounding rectangle coordinates.
CalcMonthHeaderRect | This member function calculates the month's header bounding rectangle coordinates.
CalcMonthRect | This member function calculates the month's bounding rectangle coordinates.
CalcWeekNumbersRect | This member function calculates the "week numbers" bounding rectangle coordinates.
DrawBackground | This member function is called to fill the control's background.
DrawBorder | This member function draws a border around the control.
DrawButton | This member function is used to draw the control's buttons.
DrawDay | Call this member function to draw a single month day in the month area.
DrawDaysOfWeek | Call this member function to draw the days of the week in the month header.
DrawMonthHeader | Call this member function to draw the month header in the month area.
DrawScrollTriangle | This member function draws scrolling triangles on the highest bounded month headers.
DrawWeekNumbers | Call this member function to draw the week numbers in the month area.
EnableTheme | This member function is used to switch "Themes".
GetButtonFont | This member function is used to obtain the button's font object.
GetControlBackColor | This member function is used to obtain the control's background color.
GetCursorBack | This member function is used to obtain the back cursor used for weeks selection.
GetDayBackColor | This member function is used to obtain the background color of the standard day item.
GetDaysOfWeekBackColor | This member function returns the background color of the days of weeks area.
GetDaysOfWeekTextColor | This member function obtains the text color of the days of weeks area.
GetDaysOfWeekTextFont | This member function obtains the font of the days of weeks area text.
GetDayTextColor | This member function is used to obtain the color of the standard day item.
GetDayTextFont | This member function is used to obtain a pointer to the font for the standard day item.
GetDayTextFontBold | This member function is used to obtain a pointer to the font for the bolded day item.
GetHeaderBackColor | This member function obtains the background color of the month header area.
GetHeaderTextColor | This member function obtains the text color of the month header area.
GetHeaderTextFont | This member function obtains the font of the month header area text.
GetHighlightTodayColor | This member function obtains the highlighting color of the "Today" item.
GetListControlBackColor | This member function obtains the background color of the pop-up month list control.
GetListControlTextColor | This member function obtains the text color of the pop-up month list control.
GetListControlTextFont | This member function obtains the font of the pop-up month list control.
GetNonMonthDayBackColor | This member function is used to obtain the background color of the non-month day item.
GetNonMonthDayTextColor | This member function is used to obtain the color of the non-month day item.
GetNonMonthDayTextFont | This member function is used to obtain the font of the non-month day item.
GetSelectedDayBackColor | This member function is used to obtain the background color of the selected day item.
GetSelectedDayTextColor | This member function obtains the color of the selected day item.
GetWeekNumbersBackColor | This member function obtains the background color of the week numbers area.
GetWeekNumbersTextColor | This member function obtains the text color of the week numbers items.
GetWeekNumbersTextFont | This member function obtains the font of the week numbers items.
RefreshMetrics | This member function performs initialization for the Paint Manager.
SetButtonFont | This member function sets the button's font.
SetButtonFontIndirect | This member function sets the button's font using a LOGFONT structure.
SetFontIndirect | This member function is used to set the control's default font using a LOGFONT structure.


CXTPDatePickerPaintManager::CalcDayOfWeekRect Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::CalcDayOfWeekRect Method

This member function calculates the "day of week names" bounding rectangle coordinates.

virtual CSize CalcDayOfWeekRect(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Returns

A CSize object that contains the "day of week names" rectangle coordinates.

Remarks

Calculates the "day of week names" bounding rectangle coordinates for the given device context's current header font.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::CalcDayRect Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::CalcDayRect Method

This member function is used to calculate the day's bounding rectangle coordinates.

virtual CSize CalcDayRect(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Returns

A CSize object containing the day's bounding rectangle coordinates.

Remarks

This member function calculates the day's bounding rectangle coordinates for the given device context current day's font.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::CalcMonthHeaderRect Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::CalcMonthHeaderRect Method

This member function calculates the month's header bounding rectangle coordinates.

virtual CSize CalcMonthHeaderRect(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Returns

A CSize object containing the month's header bounding rectangle coordinates.

Remarks

This member function calculates the month's header bounding rectangle coordinates for the given device context's current header font.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::CalcMonthRect Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::CalcMonthRect Method

This member function calculates the month's bounding rectangle coordinates.

virtual CSize CalcMonthRect(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Returns

A CSize object that contains the month's bounding rectangle coordinates.

Remarks

Calculates the Month's bounding rectangle coordinates for the given device context's current header font.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::CalcWeekNumbersRect Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::CalcWeekNumbersRect Method

This member function calculates the "week numbers" bounding rectangle coordinates.

virtual CSize CalcWeekNumbersRect(
    CDC* pDC
);
Parameters

pDC
Pointer to a valid device context.

Returns

A CSize object that contains the "week numbers" bounding rectangle coordinates.

Remarks

Calculates the "week numbers" bounding rectangle coordinates for the given device context's current header font.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::DrawBackground Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::DrawBackground Method

This member function is called to fill the control's background.

virtual void DrawBackground(
    CDC* pDC,
    CRect rcClient
);
Parameters

pDC
Pointer to a valid device context.
rcClient
A CRect that contains the control's client area rectangle coordinates.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::DrawBorder Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::DrawBorder Method

This member function draws a border around the control.

virtual void DrawBorder(
    CDC* pDC,
    const CXTPDatePickerControl* pControl,
    CRect& rcClient,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context.
pControl
Pointer to a CXTPDatePickerControl object.
rcClient
A CRect that contains the control's client area rectangle coordinates.
bDraw
TRUE to draw else Adjust client rectangle.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::DrawButton Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::DrawButton Method

This member function is used to draw the control's buttons.

virtual void DrawButton(
    CDC* pDC,
    const CRect&,
    const CString& strButton,
    BOOL bIsDown,
    BOOL bIsHighLight
);
Parameters

pDC
Pointer to a valid device context.
strButton
A CString that contains the string of the button's text.
bIsDown
A BOOL that determines if the button is down or up.
bIsHighLight
A BOOL that determines if the button is highlighted.
rcButton
A CRect that contains the button area bounding rectangle coordinates.
bDrawText
TRUE to draw button text

Remarks

Use this member function to draw buttons in the appropriate state. The state depends on the bIsDown parameter, the button may be drawn pressed or released. Furthermore, depending on the bIsHighLight, the button may be drawn with highlighted borders.

Example
for (int i = 0; i < GetButtonCount(); i++)
{
    CXTPDatePickerButton* pButton = GetButton(i);
    if (pButton->m_bVisible)
    DrawButton(pDC, pButton->m_rcButton, pButton->m_strCaption,
    pButton->m_bPressed, pButton->m_bHighlight);
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::DrawDay Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::DrawDay Method

Call this member function to draw a single month day in the month area.

virtual BOOL DrawDay(
    CDC* pDC,
    CXTPDatePickerItemDay* pDay
);
Parameters

pDC
Pointer to a valid device context.
pDay
Pointer to day object.

Remarks

It is called from CXTPDatePickerItemDay implementation. You can override it to customize drawing.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::DrawDaysOfWeek Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::DrawDaysOfWeek Method

Call this member function to draw the days of the week in the month header.

virtual void DrawDaysOfWeek(
    CDC* pDC,
    CXTPDatePickerItemMonth* pMonth
);
Parameters

pDC
Pointer to a valid device context.
pMonth
Pointer to month object.

Remarks

It is called from CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::DrawMonthHeader Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::DrawMonthHeader Method

Call this member function to draw the month header in the month area.

virtual void DrawMonthHeader(
    CDC* pDC,
    CXTPDatePickerItemMonth* pMonth
);
Parameters

pDC
Pointer to a valid device context.
pMonth
Pointer to month object.

Remarks

It is called from CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::DrawScrollTriangle Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::DrawScrollTriangle Method

This member function draws scrolling triangles on the highest bounded month headers.

virtual void DrawScrollTriangle(
    CDC* pDC,
    CRect rcSpot,
    BOOL bLeftDirection,
    COLORREF clrColor = 0
);
Parameters

pDC
Pointer to a valid device context.
rcSpot
A CRect object that contains the coordinates of the triangle spot area.
bLeftDirection
A BOOL that is used to determine the triangle direction. TRUE the left scrolling triangle is drawn.FALSE the right scrolling triangle is drawn.
clrColor
The triangle color

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::DrawWeekNumbers Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::DrawWeekNumbers Method

Call this member function to draw the week numbers in the month area.

virtual void DrawWeekNumbers(
    CDC* pDC,
    CXTPDatePickerItemMonth* pMonth
);
Parameters

pDC
Pointer to a valid device context.
pMonth
Pointer to month object.

Remarks

It is called from CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::EnableTheme Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::EnableTheme Method

This member function is used to switch "Themes".

virtual void EnableTheme(
    BOOL bEnableTheme
);
Parameters

bEnableTheme
A BOOL that is used as a flag to indicate if themes are enabled. Set to TRUE if Themes are enabled, FALSE Themes not enabled.

Body Source
void CXTPDatePickerPaintManager::EnableTheme(BOOL bEnableTheme) {
    m_bEnableTheme = bEnableTheme;
    RefreshMetrics();
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetButtonFont Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetButtonFont Method

This member function is used to obtain the button's font object.

CFont* GetButtonFont();
Returns

A pointer to the button's CFont object.

See Also

SetButtonFontIndirect(LOGFONT* lFont), SetButtonFont(CFont* fontButton)

Body Source
CFont* CXTPDatePickerPaintManager::GetButtonFont(){
    return &m_fontButton;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetControl Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetControl Method

This member function is used to get a parent date picker object.

virtual CXTPDatePickerControl* GetControl();
Returns

A pointer to CXTPDatePickerControl parent object.

Body Source
CXTPDatePickerControl* CXTPDatePickerPaintManager::GetControl() {
    return m_pControl;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetControlBackColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetControlBackColor Method

This member function is used to obtain the control's background color.

virtual COLORREF GetControlBackColor();
Returns

Color used for filling the controls client rectangle.

Body Source
COLORREF CXTPDatePickerPaintManager::GetControlBackColor() {
    return m_clrControlBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetCursorBack Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetCursorBack Method

This member function is used to obtain the back cursor used for weeks selection.

virtual HCURSOR GetCursorBack();
Returns

A handle of the loaded cursor.

Body Source
HCURSOR CXTPDatePickerPaintManager::GetCursorBack() {
    return m_hCursorBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetDayBackColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetDayBackColor Method

This member function is used to obtain the background color of the standard day item.

virtual COLORREF GetDayBackColor();
Returns

A COLORREF object that contains the background color of the standard day item.

Body Source
COLORREF CXTPDatePickerPaintManager::GetDayBackColor() {
    return m_clrDayBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetDaysOfWeekBackColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetDaysOfWeekBackColor Method

This member function returns the background color of the days of weeks area.

virtual COLORREF GetDaysOfWeekBackColor();
Returns

A COLORREF object containing the background color of the days of weeks area.

Body Source
COLORREF CXTPDatePickerPaintManager::GetDaysOfWeekBackColor() {
    return m_clrDaysOfWeekBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetDaysOfWeekTextColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetDaysOfWeekTextColor Method

This member function obtains the text color of the days of weeks area.

virtual COLORREF GetDaysOfWeekTextColor();
Returns

A COLORREF object containing the text color of the days of weeks area.

Body Source
COLORREF CXTPDatePickerPaintManager::GetDaysOfWeekTextColor() {
    return m_clrDaysOfWeekText;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetDaysOfWeekTextFont Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetDaysOfWeekTextFont Method

This member function obtains the font of the days of weeks area text.

CFont* GetDaysOfWeekTextFont();
Returns

A pointer to a CFont object that contains the font of the days of weeks area text.

Body Source
CFont* CXTPDatePickerPaintManager::GetDaysOfWeekTextFont() {
    return &m_fontDaysOfWeek;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetDayTextColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetDayTextColor Method

This member function is used to obtain the color of the standard day item.

virtual COLORREF GetDayTextColor();
Returns

A COLORREF object that contains the color of the standard day item.

Body Source
COLORREF CXTPDatePickerPaintManager::GetDayTextColor() {
    return m_clrDayText;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetDayTextFont Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetDayTextFont Method

This member function is used to obtain a pointer to the font for the standard day item.

virtual CFont* GetDayTextFont();
Returns

A pointer to a CFont object that contains the standard day item font.

Example
// Get the font and extract a LOGGFONT structure.
LOGFONT lf;
GetDayTextFont()->GetLogFont(&lf);
// Create new italic font.
lf.lfItalic = 1;
CFont fontItalic;
Italic.CreateFontIndirect(&lf);
Body Source
CFont* CXTPDatePickerPaintManager::GetDayTextFont() {
    return &m_fontDay;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetDayTextFontBold Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetDayTextFontBold Method

This member function is used to obtain a pointer to the font for the bolded day item.

virtual CFont* GetDayTextFontBold();
Returns

A pointer to a CFont object that contains the bold day item font.

Body Source
CFont* CXTPDatePickerPaintManager::GetDayTextFontBold() {
    return &m_fontDayBold;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetHeaderBackColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetHeaderBackColor Method

This member function obtains the background color of the month header area.

virtual COLORREF GetHeaderBackColor();
Returns

A COLORREF object containing the background color of the month header area.

Body Source
COLORREF CXTPDatePickerPaintManager::GetHeaderBackColor() {
    return m_clrHeaderBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetHeaderTextColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetHeaderTextColor Method

This member function obtains the text color of the month header area.

virtual COLORREF GetHeaderTextColor();
Returns

A COLORREF object containing the text color of the month header area.

Body Source
COLORREF CXTPDatePickerPaintManager::GetHeaderTextColor() {
    return m_clrHeaderText;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetHeaderTextFont Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetHeaderTextFont Method

This member function obtains the font of the month header area text.

CFont* GetHeaderTextFont();
Returns

A CFont object that contains the font of the month header area text.

Body Source
CFont* CXTPDatePickerPaintManager::GetHeaderTextFont() {
    return &m_fontHeader;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetHighlightTodayColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetHighlightTodayColor Method

This member function obtains the highlighting color of the "Today" item.

virtual COLORREF GetHighlightTodayColor();
Returns

A COLORREF object that contains the highlighting color of the "Today" item.

Body Source
COLORREF CXTPDatePickerPaintManager::GetHighlightTodayColor() {
    return m_clrHighlightToday;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetListControlBackColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetListControlBackColor Method

This member function obtains the background color of the pop-up month list control.

virtual COLORREF GetListControlBackColor();
Returns

A COLORREF object that contains the background color of the pop-up month list control.

Body Source
COLORREF CXTPDatePickerPaintManager::GetListControlBackColor() {
    return m_clrListControlBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetListControlTextColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetListControlTextColor Method

This member function obtains the text color of the pop-up month list control.

virtual COLORREF GetListControlTextColor();
Returns

A COLORREF object that contains the text color of the pop-up month list control.

Body Source
COLORREF CXTPDatePickerPaintManager::GetListControlTextColor() {
    return m_clrListControlText;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetListControlTextFont Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetListControlTextFont Method

This member function obtains the font of the pop-up month list control.

CFont* GetListControlTextFont();
Returns

A pointer to a CFont object that contains the font of the pop-up month list control.

Body Source
CFont* CXTPDatePickerPaintManager::GetListControlTextFont() {
    return &m_fontListControl;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetNonMonthDayBackColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetNonMonthDayBackColor Method

This member function is used to obtain the background color of the non-month day item.

virtual COLORREF GetNonMonthDayBackColor();
Returns

A COLORREF object that contains the background color of the non month day item.

Body Source
COLORREF CXTPDatePickerPaintManager::GetNonMonthDayBackColor() {
    return m_clrNonMonthDayBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetNonMonthDayTextColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetNonMonthDayTextColor Method

This member function is used to obtain the color of the non-month day item.

virtual COLORREF GetNonMonthDayTextColor();
Returns

A COLORREF object that contains the color of the non-month day item.

Body Source
COLORREF CXTPDatePickerPaintManager::GetNonMonthDayTextColor() {
    return m_clrNonMonthDayText;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetNonMonthDayTextFont Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetNonMonthDayTextFont Method

This member function is used to obtain the font of the non-month day item.

CFont* GetNonMonthDayTextFont();
Returns

Pointer to a CFont object that contains the font of the non-month day item.

Example
// Get the font and extract a LOGGFONT structure.
LOGFONT lf;
GetNonMonthDayTextFont->GetLogFont(&lf);
// Create new old font
lf.lfWeight = FW_BOLD;
CFont fontBold;
fntBold.CreateFontIndirect(&lf);
Body Source
CFont* CXTPDatePickerPaintManager::GetNonMonthDayTextFont() {
    return &m_fontNonMonthDay;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetPaintTheme Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetPaintTheme Method

This member function is used to obtain current paint theme.

virtual XTPCalendarTheme GetPaintTheme() const;
Returns

A paint theme ID from enum XTPCalendarTheme.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetSelectedDayBackColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetSelectedDayBackColor Method

This member function is used to obtain the background color of the selected day item.

virtual COLORREF GetSelectedDayBackColor();
Returns

A COLORREF object that contains the background color of the selected day item.

Body Source
COLORREF CXTPDatePickerPaintManager::GetSelectedDayBackColor() {
    return m_clrSelectedDayBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetSelectedDayTextColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetSelectedDayTextColor Method

This member function obtains the color of the selected day item.

virtual COLORREF GetSelectedDayTextColor();
Returns

A COLORREF object that contains the color of the selected day item.

Body Source
COLORREF CXTPDatePickerPaintManager::GetSelectedDayTextColor() {
    return m_clrSelectedDayText;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetWeekNumbersBackColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetWeekNumbersBackColor Method

This member function obtains the background color of the week numbers area.

virtual COLORREF GetWeekNumbersBackColor();
Returns

A COLORREF object that contains the background color of the week numbers area.

Body Source
COLORREF CXTPDatePickerPaintManager::GetWeekNumbersBackColor() {
    return m_clrWeekNumbersBack;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetWeekNumbersTextColor Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetWeekNumbersTextColor Method

This member function obtains the text color of the week numbers items.

virtual COLORREF GetWeekNumbersTextColor();
Returns

A COLORREF object that contains the text color of the week numbers items.

Body Source
COLORREF CXTPDatePickerPaintManager::GetWeekNumbersTextColor() {
    return m_clrWeekNumbersText;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::GetWeekNumbersTextFont Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::GetWeekNumbersTextFont Method

This member function obtains the font of the week numbers items.

CFont* GetWeekNumbersTextFont();
Returns

A pointer to a CFont object that contains the font of the week numbers items.

Body Source
CFont* CXTPDatePickerPaintManager::GetWeekNumbersTextFont() {
    return &m_fontWeekNumbers;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::RefreshMetrics Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::RefreshMetrics Method

This member function performs initialization for the Paint Manager.

virtual void RefreshMetrics();
Remarks

Initializes all drawing defaults (fonts, colors, etc.). Most of defaults are system defaults.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::SetButtonFont Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::SetButtonFont Method

This member function sets the button's font.

void SetButtonFont(
    CFont* fontButton
);
Parameters

fontButton
A CFont pointer to the button's font object.

Remarks

Call this function to set the new button's font from the provided CFont object.

See Also

SetButtonFontIndirect(LOGFONT*), GetButtonFont()

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::SetButtonFontIndirect Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::SetButtonFontIndirect Method

This member function sets the button's font using a LOGFONT structure.

void SetButtonFontIndirect(
    LOGFONT* lFont
);
Parameters

lFont
Pointer to the LOGFONT structure.

Remarks

This member function creates and sets the new button's font from the given LOGFONT structure.

See Also

SetButtonFont(CFont*), GetButtonFont()

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::SetControl Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::SetControl Method

This member function is used to set a parent date picker object.

virtual void SetControl(
    CXTPDatePickerControl* pControl
);
Parameters

pControl
Pointer to a parent control when assigned or NULL when detached.

Remarks

Called from CXTPDatePickerControl implementation when paint manager (or derived theme) assigned or detached.

Body Source
void CXTPDatePickerPaintManager::SetControl(CXTPDatePickerControl*   pControl) {
    m_pControl = pControl;
}
Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::SetFontIndirect Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::SetFontIndirect Method

This member function is used to set the control's default font using a LOGFONT structure.

void SetFontIndirect(
    LOGFONT* lFont
);
Parameters

lFont
Pointer to the LOGFONT structure.

Remarks

This member function creates and sets the control's new default font from the given LOGFONT structure.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::SetPaintTheme Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::SetPaintTheme Method

This member function is used to set current paint theme.

virtual void SetPaintTheme(
    XTPCalendarTheme ePaintTheme
);
Parameters

ePaintTheme
A paint theme ID from enum XTPCalendarTheme.

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager::Triangle Method

CXTPDatePickerPaintManager Methods, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::Triangle Method

This member function is used to draw a black triangle.

virtual void Triangle(
    CDC* pDC,
    CPoint pt0,
    CPoint pt1,
    CPoint pt2,
    COLORREF clrColor = 0
);
Parameters

pDC
Pointer to a valid device context.
pt0
Apex coordinate.
pt1
Apex coordinate.
pt2
Apex coordinate.
clrColor
The triangle color

Group

CXTPDatePickerPaintManager Methods


CXTPDatePickerPaintManager Constructors

CXTPDatePickerPaintManager Class, Legend, Public Methods
CXTPDatePickerPaintManager Constructors
Class

CXTPDatePickerPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerPaintManager | Default paint manager constructor.


CXTPDatePickerPaintManager::CXTPDatePickerPaintManager Constructor

CXTPDatePickerPaintManager Constructors, CXTPDatePickerPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::CXTPDatePickerPaintManager Constructor

Default paint manager constructor.

CXTPDatePickerPaintManager();
Remarks

Handles initial initialization.

See Also

RefreshMetrics()

Group

CXTPDatePickerPaintManager Constructors


CXTPDatePickerPaintManager Destructors

CXTPDatePickerPaintManager Class, Legend, Public Methods
CXTPDatePickerPaintManager Destructors
Class

CXTPDatePickerPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDatePickerPaintManager | Default paint manager destructor.


CXTPDatePickerPaintManager::~CXTPDatePickerPaintManager Destructor

CXTPDatePickerPaintManager Destructors, CXTPDatePickerPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDatePickerPaintManager::~CXTPDatePickerPaintManager Destructor

Default paint manager destructor.

virtual ~CXTPDatePickerPaintManager();
Remarks

Handles member item deallocation.

Group

CXTPDatePickerPaintManager Destructors


CXTPDatePickerTheme Class

XTPDatePickerPaintManager.h, Classes, See Also
CXTPDatePickerTheme Class

Abstract class CXTPDatePickerTheme is derived from CXTPDatePickerPaintManager and handles most of the drawing activities for the DatePicker control. This class must be used as a base to create different themes implementations (like CXTPDatePickerThemeOffice2007).

Class Hierarchy

class CXTPDatePickerTheme : public CXTPDatePickerPaintManager;
File

XTPDatePickerPaintManager.h

Remarks

The difference from paint manager that it has own drawing parameters set to customize DatePicker control - like in the CXTPCalendarTheme for CalendarControl. PaintManager drawing parameters are valid too, but changing of them will take no effects.

See Also

CXTPDatePickerThemeOffice2007

Group

Classes


CXTPDatePickerThemeOffice2007 Class

XTPDatePickerPaintManager.h, Classes, Example, See Also
CXTPDatePickerThemeOffice2007 Class

Class CXTPDatePickerThemeOffice2007 is derived from CXTPDatePickerTheme is implement Office 2007 style for DatePicker control.

Class Hierarchy

class CXTPDatePickerThemeOffice2007 : public CXTPDatePickerTheme;
File

XTPDatePickerPaintManager.h

See Also

CXTPDatePickerThemeOffice2007

Example
     if (m_bThemeOffice2007)
     {
         CXTPDatePickerThemeOffice2007* pTheme2007 = new CXTPDatePickerThemeOffice2007;
         m_wndDatePicker.SetTheme(pTheme2007);
     }
     else
     {
         m_wndDatePicker.SetTheme(NULL);
     }
Group

Classes


CXTPTopLevelWndMsgNotifier Class

XTPTopLevelWndMsgNotifier.h, Classes, Legend, Members, Topics, CXTPTopLevelWndMsgNotifier Enumerations, CXTPTopLevelWndMsgNotifier Methods, CXTPTopLevelWndMsgNotifier Constructors, CXTPTopLevelWndMsgNotifier Destructors, CXTPTopLevelWndMsgNotifier Constructors, CXTPTopLevelWndMsgNotifier Destructors, CXTPTopLevelWndMsgNotifier Enumerations, CXTPTopLevelWndMsgNotifier Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTopLevelWndMsgNotifier Class

This class is used to catch windows messages, which system sends to top-level windows and to send them to subscribers windows. The following messages are supported: WM_TIMECHANGE WM_SYSCOLORCHANGE

Class Hierarchy

class CXTPTopLevelWndMsgNotifier : public CWnd;
File

XTPTopLevelWndMsgNotifier.h

See Also

WM_TIMECHANGE, WM_SYSCOLORCHANGE.

Group

Classes

Legend
Enumeration
Method
protected
virtual
CXTPTopLevelWndMsgNotifier Constructors
CXTPTopLevelWndMsgNotifier Constructors | Description
CXTPTopLevelWndMsgNotifier | Default object constructor.
CXTPTopLevelWndMsgNotifier Destructors
CXTPTopLevelWndMsgNotifier Destructors | Description
~CXTPTopLevelWndMsgNotifier | Default object destructor.
CXTPTopLevelWndMsgNotifier Enumerations
CXTPTopLevelWndMsgNotifier Enumerations | Description
EnumParams | This enum contains additional parameter value(s).
CXTPTopLevelWndMsgNotifier Methods
CXTPTopLevelWndMsgNotifier Methods | Description
Advise | Advice CWnd object to receive specified top-level windows message(s).
CreateWnd | This method is used to Create a CWnd object.
Unadvise | Unadvise CWnd object from receive specified top-level windows message(s).


CXTPTopLevelWndMsgNotifier Enumerations

Enumerations, CXTPTopLevelWndMsgNotifier Class, Legend
CXTPTopLevelWndMsgNotifier Enumerations
Enumerations
Enumeration | Description
EnumParams | This enum contains additional parameter value(s).
Class

CXTPTopLevelWndMsgNotifier Class

Legend
Enumeration


CXTPTopLevelWndMsgNotifier::EnumParams Enumeration

XTPTopLevelWndMsgNotifier.h, CXTPTopLevelWndMsgNotifier Enumerations
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTopLevelWndMsgNotifier::EnumParams Enumeration

This enum contains additional parameter value(s).

enum EnumParams {
  msgAll = 0
};
File

XTPTopLevelWndMsgNotifier.h

Members

msgAll
This value means all messages or any message.

Group

CXTPTopLevelWndMsgNotifier Enumerations


CXTPTopLevelWndMsgNotifier Methods

CXTPTopLevelWndMsgNotifier Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTopLevelWndMsgNotifier Methods
Class

CXTPTopLevelWndMsgNotifier Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
CreateWnd | This method is used to Create a CWnd object.
Public Methods
Public Methods
Public Method | Description
Advise | Advice CWnd object to receive specified top-level windows message(s).
Unadvise | Unadvise CWnd object from receive specified top-level windows message(s).


CXTPTopLevelWndMsgNotifier::Advise Method

CXTPTopLevelWndMsgNotifier Methods, CXTPTopLevelWndMsgNotifier Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTopLevelWndMsgNotifier::Advise Method

Advice CWnd object to receive specified top-level windows message(s).

void Advise(
    CWnd* pWnd,
    UINT uWndMsg = msgAll
);
Parameters

pWnd
[in] A pointer to client window.
uWndMsg
[in] Windows message ID.

Remarks

If uWndMsg is msgAll than all supported messages will be sent to client window. Se Also: Unadvise.

Group

CXTPTopLevelWndMsgNotifier Methods


CXTPTopLevelWndMsgNotifier::CreateWnd Method

CXTPTopLevelWndMsgNotifier Methods, CXTPTopLevelWndMsgNotifier Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTopLevelWndMsgNotifier::CreateWnd Method

This method is used to Create a CWnd object.

BOOL CreateWnd();
Returns

TRUE is successful< FALSE otherwise.

Remarks

A simple top-level window will be created.

Group

CXTPTopLevelWndMsgNotifier Methods


CXTPTopLevelWndMsgNotifier::Unadvise Method

CXTPTopLevelWndMsgNotifier Methods, CXTPTopLevelWndMsgNotifier Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTopLevelWndMsgNotifier::Unadvise Method

Unadvise CWnd object from receive specified top-level windows message(s).

void Unadvise(
    CWnd* pWnd,
    UINT uWndMsg = msgAll
);
Parameters

pWnd
[in] A pointer to client window.
uWndMsg
[in] Windows message ID.

Remarks

If uWndMsg is msgAll unadvised from all supported messages. Se Also: Advise.

Group

CXTPTopLevelWndMsgNotifier Methods


CXTPTopLevelWndMsgNotifier Constructors

CXTPTopLevelWndMsgNotifier Class, Legend, Public Methods
CXTPTopLevelWndMsgNotifier Constructors
Class

CXTPTopLevelWndMsgNotifier Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTopLevelWndMsgNotifier | Default object constructor.


CXTPTopLevelWndMsgNotifier::CXTPTopLevelWndMsgNotifier Constructor

CXTPTopLevelWndMsgNotifier Constructors, CXTPTopLevelWndMsgNotifier Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTopLevelWndMsgNotifier::CXTPTopLevelWndMsgNotifier Constructor

Default object constructor.

CXTPTopLevelWndMsgNotifier();
Group

CXTPTopLevelWndMsgNotifier Constructors


CXTPTopLevelWndMsgNotifier Destructors

CXTPTopLevelWndMsgNotifier Class, Legend, Public Methods
CXTPTopLevelWndMsgNotifier Destructors
Class

CXTPTopLevelWndMsgNotifier Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTopLevelWndMsgNotifier | Default object destructor.


CXTPTopLevelWndMsgNotifier::~CXTPTopLevelWndMsgNotifier Destructor

CXTPTopLevelWndMsgNotifier Destructors, CXTPTopLevelWndMsgNotifier Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTopLevelWndMsgNotifier::~CXTPTopLevelWndMsgNotifier Destructor

Default object destructor.

virtual ~CXTPTopLevelWndMsgNotifier();
Group

CXTPTopLevelWndMsgNotifier Destructors


XTP_CALENDAR_RECURRENCE_OPTIONS Structure

XTPCalendarRecurrencePattern.h, Classes, Legend, Members, Topics, XTP_CALENDAR_RECURRENCE_OPTIONS Structures, XTP_CALENDAR_RECURRENCE_OPTIONS Data Members, XTP_CALENDAR_RECURRENCE_OPTIONS Methods, XTP_CALENDAR_RECURRENCE_OPTIONS Data Members, XTP_CALENDAR_RECURRENCE_OPTIONS Methods, See Also, XTP_CALENDAR_RECURRENCE_OPTIONS Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS Structure

This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data.

Class Hierarchy

struct XTP_CALENDAR_RECURRENCE_OPTIONS {
  struct PATTERN_DAILY {
    BOOL bEveryWeekDayOnly;
    int nIntervalDays;
  };
  struct PATTERN_WEEKLY {
    int nIntervalWeeks;
    int nDayOfWeekMask;
  };
  struct PATTERN_MONTHLY {
    int nIntervalMonths;
    int nDayOfMonth;
  };
  struct PATTERN_MONTHNTH {
    int nIntervalMonths;
    int nWhichDay;
    int nWhichDayMask;
  };
  struct PATTERN_YEARLY {
    int nMonthOfYear;
    int nDayOfMonth;
  };
  struct PATTERN_YEARNTH {
    int nWhichDay;
    int nWhichDayMask;
    int nMonthOfYear;
  };
  XTPCalendarEventRecurrenceType m_nRecurrenceType;
  union {
    PATTERN_DAILY m_Daily;
    PATTERN_WEEKLY m_Weekly;
    PATTERN_MONTHLY m_Monthly;
    PATTERN_MONTHNTH m_MonthNth;
    PATTERN_YEARLY m_Yearly;
    PATTERN_YEARNTH m_YearNth;
  };
};
File

XTPCalendarRecurrencePattern.h

See Also

XTPCalendarEventRecurrenceType, XTPCalendarWeekDay, XTPCalendarWeekDay_Masks, XTPCalendarWeekDay, XTPCalendarWeek, CXTPRecurrencePattern

Group

Classes

Legend
Structure
Data Member
Method
XTP_CALENDAR_RECURRENCE_OPTIONS Data Members
XTP_CALENDAR_RECURRENCE_OPTIONS Data Members | Description
m_nRecurrenceType | Recurrence type, See Also: XTPCalendarEventRecurrenceType.
XTP_CALENDAR_RECURRENCE_OPTIONS Methods
XTP_CALENDAR_RECURRENCE_OPTIONS Methods | Description
GetData | Saves this object data as 4 long values.
SetData | Restore this object data from 4 long values previously retrieved using GetData() member function.
XTP_CALENDAR_RECURRENCE_OPTIONS Structures
XTP_CALENDAR_RECURRENCE_OPTIONS Structures | Description
PATTERN_DAILY | Defines a group of parameters to describe the Daily pattern.
PATTERN_MONTHLY | Defines a group of parameters to describe the Month pattern.
PATTERN_MONTHNTH | Defines a group of parameters to describe the Month pattern.
PATTERN_WEEKLY | Defines a group of parameters to describe the Weekly pattern.
PATTERN_YEARLY | Defines a group of parameters to describe the Year pattern.
PATTERN_YEARNTH | Defines a group of parameters to describe the Year pattern.


XTP_CALENDAR_RECURRENCE_OPTIONS Structures

XTP_CALENDAR_RECURRENCE_OPTIONS Structure, Legend, Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS Structures
Structure

XTP_CALENDAR_RECURRENCE_OPTIONS Structure

Legend
Structure
Structures
Structure | Description
PATTERN_DAILY | Defines a group of parameters to describe the Daily pattern.
PATTERN_MONTHLY | Defines a group of parameters to describe the Month pattern.
PATTERN_MONTHNTH | Defines a group of parameters to describe the Month pattern.
PATTERN_WEEKLY | Defines a group of parameters to describe the Weekly pattern.
PATTERN_YEARLY | Defines a group of parameters to describe the Year pattern.
PATTERN_YEARNTH | Defines a group of parameters to describe the Year pattern.


XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY Structure

XTPCalendarRecurrencePattern.h, XTP_CALENDAR_RECURRENCE_OPTIONS Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY Structure

Defines a group of parameters to describe the Daily pattern.

struct PATTERN_DAILY {
  BOOL bEveryWeekDayOnly;
  int nIntervalDays;
};
File

XTPCalendarRecurrencePattern.h

Members

bEveryWeekDayOnly
Flag determines if the event occurs every week day.
nIntervalDays
Event occurs every nIntervalDays days beginning from a start date.

Group

XTP_CALENDAR_RECURRENCE_OPTIONS Structures


XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY Structure

XTPCalendarRecurrencePattern.h, XTP_CALENDAR_RECURRENCE_OPTIONS Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY Structure

Defines a group of parameters to describe the Month pattern.

struct PATTERN_MONTHLY {
  int nIntervalMonths;
  int nDayOfMonth;
};
File

XTPCalendarRecurrencePattern.h

Members

nIntervalMonths
Event occurs every nIntervalMonths with the first month beginning from the start date.
nDayOfMonth
Determines the day of the month when an event occurs.

Group

XTP_CALENDAR_RECURRENCE_OPTIONS Structures


XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH Structure

XTPCalendarRecurrencePattern.h, XTP_CALENDAR_RECURRENCE_OPTIONS Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH Structure

Defines a group of parameters to describe the Month pattern.

struct PATTERN_MONTHNTH {
  int nIntervalMonths;
  int nWhichDay;
  int nWhichDayMask;
};
File

XTPCalendarRecurrencePattern.h

Members

nIntervalMonths
Event occurs every nIntervalMonths month beginning from start date.
nWhichDay
Determines the day of the month or nth order of day.
nWhichDayMask
Weekday code.

Group

XTP_CALENDAR_RECURRENCE_OPTIONS Structures


XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY Structure

XTPCalendarRecurrencePattern.h, XTP_CALENDAR_RECURRENCE_OPTIONS Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY Structure

Defines a group of parameters to describe the Weekly pattern.

struct PATTERN_WEEKLY {
  int nIntervalWeeks;
  int nDayOfWeekMask;
};
File

XTPCalendarRecurrencePattern.h

Members

nIntervalWeeks
Event occurs every nIntervalWeeks with the first week beginning from a start date.
nDayOfWeekMask
Determines the days of the week when an event occurs.

Group

XTP_CALENDAR_RECURRENCE_OPTIONS Structures


XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY Structure

XTPCalendarRecurrencePattern.h, XTP_CALENDAR_RECURRENCE_OPTIONS Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY Structure

Defines a group of parameters to describe the Year pattern.

struct PATTERN_YEARLY {
  int nMonthOfYear;
  int nDayOfMonth;
};
File

XTPCalendarRecurrencePattern.h

Members

nMonthOfYear
The month of every year that the event occurs on.
nDayOfMonth
The day of month that the event occurs on.

Group

XTP_CALENDAR_RECURRENCE_OPTIONS Structures


XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH Structure

XTPCalendarRecurrencePattern.h, XTP_CALENDAR_RECURRENCE_OPTIONS Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH Structure

Defines a group of parameters to describe the Year pattern.

struct PATTERN_YEARNTH {
  int nWhichDay;
  int nWhichDayMask;
  int nMonthOfYear;
};
File

XTPCalendarRecurrencePattern.h

Members

nWhichDay
Determines the day of the month or the nth order of the day.
nWhichDayMask
Weekday code.
nMonthOfYear
Month of the year.

Group

XTP_CALENDAR_RECURRENCE_OPTIONS Structures


XTP_CALENDAR_RECURRENCE_OPTIONS Data Members

XTP_CALENDAR_RECURRENCE_OPTIONS Structure, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS Data Members
Structure

XTP_CALENDAR_RECURRENCE_OPTIONS Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
m_nRecurrenceType | Recurrence type, See Also: XTPCalendarEventRecurrenceType.


XTP_CALENDAR_RECURRENCE_OPTIONS::m_nRecurrenceType Data Member

XTP_CALENDAR_RECURRENCE_OPTIONS Data Members, XTP_CALENDAR_RECURRENCE_OPTIONS Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::m_nRecurrenceType Data Member

Recurrence type, See Also: XTPCalendarEventRecurrenceType.

XTPCalendarEventRecurrenceType m_nRecurrenceType;
Group

XTP_CALENDAR_RECURRENCE_OPTIONS Data Members


XTP_CALENDAR_RECURRENCE_OPTIONS Methods

XTP_CALENDAR_RECURRENCE_OPTIONS Structure, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS Methods
Structure

XTP_CALENDAR_RECURRENCE_OPTIONS Structure

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetData | Saves this object data as 4 long values.
SetData | Restore this object data from 4 long values previously retrieved using GetData() member function.


XTP_CALENDAR_RECURRENCE_OPTIONS::GetData Method

XTP_CALENDAR_RECURRENCE_OPTIONS Methods, XTP_CALENDAR_RECURRENCE_OPTIONS Structure, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::GetData Method

Saves this object data as 4 long values.

void GetData(
    long& rnData1,
    long& rnData2,
    long& rnData3,
    long& rnData4
);
Parameters

rnData1
[out] Reference to data variable number 1
rnData2
[out] Reference to data variable number 2
rnData3
[out] Reference to data variable number 3
rnData4
[out] Reference to data variable number 4

Remarks

Useful to save data in data storage;

See Also

SetData()

Body Source
void GetData(long& rnData1, long& rnData2, long& rnData3, long& rnData4)
{
    rnData1 = m_nRecurrenceType;
    rnData2 = m_YearNth.nWhichDay;
    rnData3 = m_YearNth.nWhichDayMask;
    rnData4 = m_YearNth.nMonthOfYear;
}
Group

XTP_CALENDAR_RECURRENCE_OPTIONS Methods


XTP_CALENDAR_RECURRENCE_OPTIONS::SetData Method

XTP_CALENDAR_RECURRENCE_OPTIONS Methods, XTP_CALENDAR_RECURRENCE_OPTIONS Structure, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_RECURRENCE_OPTIONS::SetData Method

Restore this object data from 4 long values previously retrieved using GetData() member function.

void SetData(
    long nData1,
    long nData2,
    long nData3,
    long nData4
);
Parameters

rnData1
[in] data value number 1
rnData2
[in] data value number 2
rnData3
[in] data value number 3
rnData4
[in] data value number 4

Remarks

Useful to load data from data storage;

See Also

GetData()

Body Source
void SetData(long nData1, long nData2, long nData3, long nData4)
{
    ASSERT(nData1 >= 0 && nData1 <= 6); // just to check.

    m_nRecurrenceType = (XTPCalendarEventRecurrenceType)nData1;
    m_YearNth.nWhichDay = nData2;
    m_YearNth.nWhichDayMask = nData3;
    m_YearNth.nMonthOfYear = nData4;
}
Group

XTP_CALENDAR_RECURRENCE_OPTIONS Methods


XTP_DAYITEM_METRICS Structure

XTPDatePickerControl.h, Classes, Legend, Members, Topics, XTP_DAYITEM_METRICS Data Members, XTP_DAYITEM_METRICS Methods, XTP_DAYITEM_METRICS Data Members, XTP_DAYITEM_METRICS Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_DAYITEM_METRICS Structure

This structure represents a set of parameters which are used to display day items.

  1. There could be customized foreground and background colors.
  2. Also you can text font for the displayed day text.
  3. And as the last thing you can customize a day picture displayed there, using OLE PICTUREDISP interface and OleSetPicture method.
Class Hierarchy

struct XTP_DAYITEM_METRICS {
  COLORREF clrForeground;
  COLORREF clrBackground;
};
File

XTPDatePickerControl.h

Group

Classes

Legend
Data Member
Method
XTP_DAYITEM_METRICS Data Members
XTP_DAYITEM_METRICS Data Members | Description
clrBackground | A COLORREF object that contains the item's background color.
clrForeground | A COLORREF object that contains the item's foreground color.
XTP_DAYITEM_METRICS Methods
XTP_DAYITEM_METRICS Methods | Description
GetFont | Get day item font..
SetFont | Set a new font for the day item.


XTP_DAYITEM_METRICS Data Members

XTP_DAYITEM_METRICS Structure, Legend, Public Data Members
XTP_DAYITEM_METRICS Data Members
Structure

XTP_DAYITEM_METRICS Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
clrBackground | A COLORREF object that contains the item's background color.
clrForeground | A COLORREF object that contains the item's foreground color.


XTP_DAYITEM_METRICS::clrBackground Data Member

XTP_DAYITEM_METRICS Data Members, XTP_DAYITEM_METRICS Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_DAYITEM_METRICS::clrBackground Data Member

A COLORREF object that contains the item's background color.

COLORREF clrBackground;
Group

XTP_DAYITEM_METRICS Data Members


XTP_DAYITEM_METRICS::clrForeground Data Member

XTP_DAYITEM_METRICS Data Members, XTP_DAYITEM_METRICS Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_DAYITEM_METRICS::clrForeground Data Member

A COLORREF object that contains the item's foreground color.

COLORREF clrForeground;
Group

XTP_DAYITEM_METRICS Data Members


XTP_DAYITEM_METRICS Methods

XTP_DAYITEM_METRICS Structure, Legend, Public Methods
XTP_DAYITEM_METRICS Methods
Structure

XTP_DAYITEM_METRICS Structure

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetFont | Get day item font..
SetFont | Set a new font for the day item.


XTP_DAYITEM_METRICS::GetFont Method

XTP_DAYITEM_METRICS Methods, XTP_DAYITEM_METRICS Structure
XTP_DAYITEM_METRICS::GetFont Method

Get day item font..

CFont* GetFont();
Remarks

Return a day font stored by the structure.

Group

XTP_DAYITEM_METRICS Methods


XTP_DAYITEM_METRICS::SetFont Method

XTP_DAYITEM_METRICS Methods, XTP_DAYITEM_METRICS Structure
XTP_DAYITEM_METRICS::SetFont Method

Set a new font for the day item.

void SetFont(
    CFont* pFont
);
Parameters

pFont
Pointer to a CFont object.

Group

XTP_DAYITEM_METRICS Methods


Functions

Functions, Legend, Calendar
Functions
Functions
Function | Description
PX_Color | Call this function within your class's DoPropExchange member function to serialize or initialize a COLORREF property. The property's value is read from or written to the variable referenced by refColor, as appropriate.
PX_Color | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Color property. The property's value is read from or written to the variable referenced by refColor, as appropriate.
PX_Font | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Font property. The property's value is read from or written to the variable referenced by refFont, as appropriate.
PX_Font | Call this function within your class's DoPropExchange member function to serialize or initialize a LOGFONT property. The property's value is read from or written to the variable referenced by rLogFont, as appropriate.
PX_GrColor | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property. The property's value is read from or written to the variable referenced by refGrColor, as appropriate.
xtpCalendarDateTime_max | Defines an upper bound of the time frame for the Calendar control.
xtpCalendarDateTime_min | Defines a lower bound of the time frame for the Calendar control.
XTPGetTopLevelWndMsgNotifier | This global function is used to get library static common top-level window object to catch windows messages, which system sends to top-level windows (like WM_TIMECHANGE, WM_SYSCOLORCHANGE).
Module

Calendar

Legend
Method


PX_Color Function

XTPCalendarViewPart.h, Functions
PX_Color Function

Call this function within your class's DoPropExchange member function to serialize or initialize a COLORREF property. The property's value is read from or written to the variable referenced by refColor, as appropriate.

BOOL PX_Color(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    COLORREF& refColor
);
File

XTPCalendarViewPart.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pcszPropName
The name of the property being exchanged.
refColor
Reference to the variable where the property is stored.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Color Function

XTPCalendarViewPart.h, Functions
PX_Color Function

Call this function within your class's DoPropExchange member function to serialize or initialize a customized Color property. The property's value is read from or written to the variable referenced by refColor, as appropriate.

BOOL PX_Color(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    CXTPPaintManagerColor& refColor
);
File

XTPCalendarViewPart.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pcszPropName
The name of the property being exchanged.
refColor
Reference to the variable where the property is stored.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Font Function

XTPCalendarViewPart.h, Functions
PX_Font Function

Call this function within your class's DoPropExchange member function to serialize or initialize a customized Font property. The property's value is read from or written to the variable referenced by refFont, as appropriate.

BOOL PX_Font(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    CXTPCalendarThemeFontValue& refFont
);
File

XTPCalendarViewPart.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pcszPropName
The name of the property being exchanged.
refFont
Reference to the variable where the property is stored.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Font Function

XTPCalendarViewPart.h, Functions
PX_Font Function

Call this function within your class's DoPropExchange member function to serialize or initialize a LOGFONT property. The property's value is read from or written to the variable referenced by rLogFont, as appropriate.

BOOL PX_Font(
    CXTPPropExchange* pPX,
    LPCTSTR pcszPropName,
    LOGFONT& rLogFont
);
File

XTPCalendarViewPart.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pcszPropName
The name of the property being exchanged.
rLogFont
Reference to the variable where the property is stored.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_GrColor Function

XTPCalendarViewPart.h, Functions
PX_GrColor Function

Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property. The property's value is read from or written to the variable referenced by refGrColor, as appropriate.

BOOL PX_GrColor(
    CXTPPropExchange* pPX,
    LPCTSTR psczPropName,
    CXTPPaintManagerColorGradient& refGrColor
);
File

XTPCalendarViewPart.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
refGrColor
Reference to the variable where the property is stored.
pcszPropName
The name of the property being exchanged.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


xtpCalendarDateTime_max Function

XTPCalendarUtils.h, Functions, See Also
xtpCalendarDateTime_max Function

Defines an upper bound of the time frame for the Calendar control.

static const COleDateTime xtpCalendarDateTime_max(
    9999,
    12,
    31,
    0,
    0,
    0
);
File

XTPCalendarUtils.h

See Also

xtpCalendarDateTime_min

Group

Functions


xtpCalendarDateTime_min Function

XTPCalendarUtils.h, Functions, See Also
xtpCalendarDateTime_min Function

Defines a lower bound of the time frame for the Calendar control.

static const COleDateTime xtpCalendarDateTime_min(
    100,
    1,
    1,
    0,
    0,
    0
);
File

XTPCalendarUtils.h

See Also

xtpCalendarDateTime_max

Group

Functions


XTPGetTopLevelWndMsgNotifier Function

XTPTopLevelWndMsgNotifier.h, Functions
XTPGetTopLevelWndMsgNotifier Function

This global function is used to get library static common top-level window object to catch windows messages, which system sends to top-level windows (like WM_TIMECHANGE, WM_SYSCOLORCHANGE).

CXTPTopLevelWndMsgNotifier* XTPGetTopLevelWndMsgNotifier();
File

XTPTopLevelWndMsgNotifier.h

Returns

A pointer to CXTPTopLevelWndMsgNotifier object.

Remarks

Using CXTPTopLevelWndMsgNotifier you can advise your non-top-level (child) windows to receive these messages.

Group

Functions


Structs, Records, Enums

Enumerations, Legend, Calendar, Structures
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPCalendarAdditionalOptions | Enumerates additional calendar options flags.
XTPCalendarBeforeDrawThemeObject | This enum defines a set of calendar theme items for which XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification is sent.
XTPCalendarClipboardCopyFlags | Enumerates additional flags used in clipboard operations.
XTPCalendarClockAlignFlags |
XTPCalendarCurrentTimeMarkFlags | Enumerates flags to CXTPCalendarOptions.nDayView_CurrentTimeMarkVisible member. This set of flags define when Current Time Mark on the timescale is visible.
XTPCalendarDataProvider | Enumeration used to determine the calendar data provider in use.
XTPCalendarDataProviderCacheMode | Enumerates DB Provider cache modes.
XTPCalendarDayViewScrollDirection | Enumeration used to determine the scroll direction.
XTPCalendarDraggingMode | Enumerates allowable dragging mode state codes.
XTPCalendarEditOperation | Enumerates customizable event edit operations.
XTPCalendarEndEditSubjectAction | Enumerates allowable flags for driving subject editors.
XTPCalendarEventBusyStatus | Enumerates busy status values.
XTPCalendarEventCaptionFormat | Enumerates allowable formats for event caption.
XTPCalendarEventCategories | Enumerates standard Event Categories for office 2007 theme.
XTPCalendarEventIconIDs | Icons IDs set to be used with calendar event custom icons to customize standard event glyphs.
XTPCalendarEventImportance | Enumerates importance level values.
XTPCalendarEventRecurrenceState | Enumerates recurrence states.
XTPCalendarEventRecurrenceType | Enumerates Recurrence Pattern Types.
XTPCalendarExpandDayButton | This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action.
XTPCalendarGetItemText | This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.
XTPCalendarGetItemTextEx | This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification. These flags are used for office 2007 theme only.
XTPCalendarHitTestCode | Enumerates allowable hit test codes.
XTPCalendarMouseMode | Enumeration of operational mouse modes.
XTPCalendarMultiDayEventFlags | Enumerates defined flags for multi day event states.
XTPCalendarPatternEnd | Specify the end of the recurrence pattern type.
XTPCalendarRemindersAction | Enumeration of possible Calendar Reminder notification actions.
XTPCalendarScrollDayButton | This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action. (valid for office 2007 theme only)
XTPCalendarSelectionChanged | Enumerates calendar selection types.
XTPCalendarTheme | Paint themes used by calendar.
XTPCalendarUndoMode | Enumerates flags to identify undo mode.
XTPCalendarUpdateOptions | Contains bit-masks for adjusting the calendar control.
XTPCalendarUserAction | This enum defines set of user actions which can be customized.
XTPCalendarViewChangedUpdateOptions | This enumeration contains options for CXTPCalendarControl::CViewChangedContext.
XTPCalendarViewType | Enumeration used to determine the calendar view type in use.
XTPCalendarWeek | Enumerates a sequence numbers for days.
XTPCalendarWeekDay | Enumerates Day of Weeks codes.
XTPDatePickerBorderStyle | Border style of Date picker control
XTPEnumCalendarReminderForOccurrenceParameters | Enumerates parameters used in configuring reminders for recurrence patterns occurrences.
Module

Calendar

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_CALENDAR_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification.
XTP_CALENDAR_GETITEMTEXT_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_GETITEMTEXT notification.
XTP_CALENDAR_HITTESTINFO | Basic set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_HITTESTINFO_DAY_VIEW | Enhanced set of parameters for hit test operations on calendar day view area.
XTP_CALENDAR_HITTESTINFO_MONTH_VIEW | Set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_HITTESTINFO_WEEK_VIEW | Set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_MONTHVIEW_DAYPOS | Defines a set of data and methods to easily manipulate with day positions in month view. Used to convert Week/Day indexes pair to sequential integer value and vice versa.
XTP_CALENDAR_PATTERN_END | This structure describes parameters of the end of the recurrence pattern type.
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.
XTP_CALENDAR_USERACTION_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_USERACTION notification.
XTP_CALENDAR_VIEWSELECTION | Structure contains the calendar day view selection block.
XTP_CALENDAR_WPARAM2 | Doubled custom parameter for notifications. Used when single WPARAM is not enough.
XTP_EVENT_DRAG_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_DragXXX.
XTP_EVENT_EDIT_OPERATION_PARAMS | This structure is used as a generic and base class for customize edit event notifications.
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent.
XTP_EVENT_PASTE_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_Paste.
XTP_NC_DATEPICKER_BUTTON | Structure used to send button notification messages.


XTP_CALENDAR_DAYVIEWCELL_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_DAYVIEWCELL_PARAMS Structure

Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification.

struct XTP_CALENDAR_DAYVIEWCELL_PARAMS {
  int nIndex;
  DATE dtBeginTime;
  BOOL bSelected;
  COLORREF clrBackgroundColor;
};
File

XTPCalendarNotifications.h

Members

nIndex
in] Cell index.
dtBeginTime
in] Begin cell date and time.
bSelected
in] Is cell selected.
clrBackgroundColor
in/out] Background cell color.

Remarks

This structure defines day view cell (exclude all day events area) drawing attributes.

See Also

XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL

Group

Structs, Records, Enums


XTP_CALENDAR_GETITEMTEXT_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_GETITEMTEXT_PARAMS Structure

Set of parameters transferred from calendar items for XTP_NC_CALENDAR_GETITEMTEXT notification.

struct XTP_CALENDAR_GETITEMTEXT_PARAMS {
  int nItem;
  CString* pstrText;
  CXTPCalendarViewEvent* pViewEvent;
  CXTPCalendarViewDay* pViewDay;
  int nWeekDay;
};
File

XTPCalendarNotifications.h

Members

nItem
in] One of the values from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx;
pstrText
in, out] - Pointer to item text;
pViewEvent
in] Pointer to a ViewEvent object or NULL.
pViewDay
in] Pointer to a ViewDay object or NULL.
nWeekDay
in] Zero or Week day number as: 1 - Sunday, 2 - Monday, ...

Remarks

This structure defines an calendar item, item data and in-out item text to customize.

See Also

XTP_NC_CALENDAR_GETITEMTEXTL, XTPCalendarGetItemText, XTPCalendarGetItemTextEx.

Group

Structs, Records, Enums


XTP_CALENDAR_HITTESTINFO Structure

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTP_CALENDAR_HITTESTINFO Structure

Basic set of parameters transferred from calendar items to mouse handlers.

struct XTP_CALENDAR_HITTESTINFO {
  COleDateTime dt;
  BOOL bTimePartValid;
  int uHitCode;
  int nDay;
  int nGroup;
  int nEvent;
  CXTPCalendarViewDay* pViewDay;
  CXTPCalendarViewGroup* pViewGroup;
  CXTPCalendarViewEvent* pViewEvent;
};
File

XTPCalendarDefines.h

Members

dt
Time stamp on the specified point.
bTimePartValid
Specifies whether date's time part is valid, i.e.
uHitCode
A bitwise combination of XTPCalendarHitTestCode constants.
nDay
Number of the day.
nGroup
Number of the group.
nEvent
ID of the specified event.
pViewDay
Pointer to affected CXTPCalendarViewDay object.
pViewGroup
Pointer to affected CXTPCalendarViewGroup object.
pViewEvent
Pointer to affected CXTPCalendarViewEvent object.

Remarks

This structure groups together all essential parameters used in items processing activities. It is a basic structure for all particular calendar's structures.

See Also

XTP_CALENDAR_HITTESTINFO_DAY_VIEW, XTP_CALENDAR_HITTESTINFO_WEEK_VIEW, XTP_CALENDAR_HITTESTINFO_MONTH_VIEW

Group

Structs, Records, Enums


XTP_CALENDAR_HITTESTINFO_DAY_VIEW Structure

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTP_CALENDAR_HITTESTINFO_DAY_VIEW Structure

Enhanced set of parameters for hit test operations on calendar day view area.

struct XTP_CALENDAR_HITTESTINFO_DAY_VIEW : public XTP_CALENDAR_HITTESTINFO {
  POINT pt;
};
File

XTPCalendarDefines.h

Members

pt
Point where the mouse was clicked in client coordinates.

Remarks

This enumeration enhances XTP_CALENDAR_HITTESTINFO set of parameters by specific calendar day view items.

See Also

XTP_CALENDAR_HITTESTINFO

Group

Structs, Records, Enums


XTP_CALENDAR_HITTESTINFO_MONTH_VIEW Structure

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTP_CALENDAR_HITTESTINFO_MONTH_VIEW Structure

Set of parameters transferred from calendar items to mouse handlers.

struct XTP_CALENDAR_HITTESTINFO_MONTH_VIEW : public XTP_CALENDAR_HITTESTINFO {
  XTP_CALENDAR_MONTHVIEW_DAYPOS dayPOS;
};
File

XTPCalendarDefines.h

Members

dayPOS
Day position.

Remarks

This structure groups together all essential parameters used in items processing activities. It is a basic structure for all particular calendar's structures.

See Also

XTP_CALENDAR_HITTESTINFO, XTP_CALENDAR_MONTHVIEW_DAYPOS

Group

Structs, Records, Enums


XTP_CALENDAR_HITTESTINFO_WEEK_VIEW Structure

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTP_CALENDAR_HITTESTINFO_WEEK_VIEW Structure

Set of parameters transferred from calendar items to mouse handlers.

struct XTP_CALENDAR_HITTESTINFO_WEEK_VIEW : public XTP_CALENDAR_HITTESTINFO {
};
File

XTPCalendarDefines.h

See Also

XTP_CALENDAR_HITTESTINFO

Group

Structs, Records, Enums


XTP_CALENDAR_MONTHVIEW_DAYPOS Structure

XTPCalendarDefines.h, Structs, Records, Enums
XTP_CALENDAR_MONTHVIEW_DAYPOS Structure

Defines a set of data and methods to easily manipulate with day positions in month view. Used to convert Week/Day indexes pair to sequential integer value and vice versa.

struct XTP_CALENDAR_MONTHVIEW_DAYPOS {
  int nWeekIndex;
  int nWeekDayIndex;
};
File

XTPCalendarDefines.h

Members

nWeekIndex
Week index.
nWeekDayIndex
Week day cell index.

Group

Structs, Records, Enums


XTP_CALENDAR_PATTERN_END Structure

XTPCalendarDefines.h, Structs, Records, Enums
XTP_CALENDAR_PATTERN_END Structure

This structure describes parameters of the end of the recurrence pattern type.

struct XTP_CALENDAR_PATTERN_END {
  XTPCalendarPatternEnd m_nUseEnd;
  COleDateTime m_dtPatternEndDate;
  int m_nEndAfterOccurrences;
};
File

XTPCalendarDefines.h

Members

m_nUseEnd
End type.
m_dtPatternEndDate
End date.
m_nEndAfterOccurrences
End number of occurrences.

Group

Structs, Records, Enums


XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS Structure

Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.

struct XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS {
  int nIndex;
  DATE dtBeginTime;
  BOOL bSelected;
  BOOL bWorkCell;
  CXTPCalendarDayViewGroup* pViewGroup;
};
File

XTPCalendarNotifications.h

Members

nIndex
in] Cell index.
dtBeginTime
in] Begin cell date and time.
bSelected
in] Is cell selected.
bWorkCell
in] The cell is work (or non-work).
pViewGroup
in] Owner group.

Remarks

This structure defines day view cell (exclude all day events area) drawing attributes.

See Also

XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT

Group

Structs, Records, Enums


XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS Structure

Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.

struct XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS {
  int nTimeScale;
  int nIndex;
  DATE dtBeginTime;
  int nMinutes;
};
File

XTPCalendarNotifications.h

Members

nTimeScale
in] Time scale number {1 - main, 2 - additional
nIndex
in] Cell index.
dtBeginTime
in] Begin cell time.
nMinutes
in] SubCell Minutes value {0, 5, 10, ...} or -1 for cell hour.

Remarks

This structure defines day timescale cell drawing attributes.

See Also

XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT

Group

Structs, Records, Enums


XTP_CALENDAR_USERACTION_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_USERACTION_PARAMS Structure

Set of parameters transferred from calendar items for XTP_NC_CALENDAR_USERACTION notification.

struct XTP_CALENDAR_USERACTION_PARAMS {
  struct EXPANDDAYBUTTONACTION_PARAMS {
    XTPCalendarExpandDayButton nButton;
    CXTPCalendarViewDay* pViewDay;
  };
  struct SCROLLDAYBUTTONACTION_PARAMS {
    XTPCalendarScrollDayButton nButton;
    CXTPCalendarDayViewGroup* pViewGroup;
  };
  XTPCalendarUserAction m_eAction;
  union {
    EXPANDDAYBUTTONACTION_PARAMS m_ExpandDayButton;
    SCROLLDAYBUTTONACTION_PARAMS m_ScrollDayButton;
  };
};
File

XTPCalendarNotifications.h

Members

nButton
in] from XTPCalendarExpandDayButton
pViewDay
in] Pointer to a ViewDay object or NULL.
pViewGroup
in] Pointer to a ViewDay object or NULL.
m_eAction
in] A value from XTPCalendarUserAction
m_ExpandDayButton
Parameters for xtpCalendarUserAction_OnExpandDay user action.
m_ScrollDayButton
Parameters for xtpCalendarUserAction_OnScrollDay user action.

See Also

XTPCalendarUserAction

Group

Structs, Records, Enums


XTP_CALENDAR_VIEWSELECTION Structure

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTP_CALENDAR_VIEWSELECTION Structure

Structure contains the calendar day view selection block.

struct XTP_CALENDAR_VIEWSELECTION {
  int nGroupIndex;
  COleDateTime dtBegin;
  COleDateTime dtEnd;
  BOOL bAllDayEvent;
};
File

XTPCalendarDefines.h

Members

nGroupIndex
Numeric index of the corresponding resource group.
dtBegin
Selection start time.
dtEnd
Selection finish time.
bAllDayEvent
TRUE when all day is selected, FALSE otherwise.

Remarks

This structure describes a selection bounds on the calendar day view.

See Also

CXTPCalendarDayView

Group

Structs, Records, Enums


XTP_CALENDAR_WPARAM2 Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_CALENDAR_WPARAM2 Structure

Doubled custom parameter for notifications. Used when single WPARAM is not enough.

struct XTP_CALENDAR_WPARAM2 {
  WPARAM wParam1;
  WPARAM wParam2;
};
File

XTPCalendarNotifications.h

Members

wParam1
First custom parameter
wParam2
Second custom parameter

See Also

WPARAM

Group

Structs, Records, Enums


XTP_EVENT_DRAG_OPERATION_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EVENT_DRAG_OPERATION_PARAMS Structure

This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_DragXXX.

struct XTP_EVENT_DRAG_OPERATION_PARAMS : public XTP_EVENT_EDIT_OPERATION_PARAMS {
  CXTPCalendarEvent* pDraggingEvent;
  CXTPCalendarEvent* pDraggingEventNew;
};
File

XTPCalendarNotifications.h

Members

pDraggingEvent
A pointer to event before dragging operation.
pDraggingEventNew
A pointer to event after dragging operation.

Remarks

Used only with XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED notification.

See Also

XTPCalendarEditOperation, XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTP_EVENT_EDIT_OPERATION_PARAMS

Group

Structs, Records, Enums


XTP_EVENT_EDIT_OPERATION_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EVENT_EDIT_OPERATION_PARAMS Structure

This structure is used as a generic and base class for customize edit event notifications.

struct XTP_EVENT_EDIT_OPERATION_PARAMS {
  XTPCalendarEditOperation eOperation;
  CXTPCalendarViewEvents* pEventViews;
};
File

XTPCalendarNotifications.h

Members

eOperation
Edit operation.
pEventViews
Event views array with events set for edit operation.

See Also

XTPCalendarEditOperation, XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED, XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTP_EVENT_PASTE_OPERATION_PARAMS, XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS

Group

Structs, Records, Enums


XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS Structure

This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent.

struct XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS : public XTP_EVENT_EDIT_OPERATION_PARAMS {
  LPCTSTR pcszInitialSubject;
};
File

XTPCalendarNotifications.h

Members

pcszInitialSubject
A pointer to the string which contains initial subject value for new event (generally initial char).

See Also

XTPCalendarEditOperation, XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED, XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTP_EVENT_EDIT_OPERATION_PARAMS

Group

Structs, Records, Enums


XTP_EVENT_PASTE_OPERATION_PARAMS Structure

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EVENT_PASTE_OPERATION_PARAMS Structure

This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_Paste.

struct XTP_EVENT_PASTE_OPERATION_PARAMS : public XTP_EVENT_EDIT_OPERATION_PARAMS {
  CXTPCalendarEvent* pEvent;
  BOOL bPasteWillChangeExistingEvent;
};
File

XTPCalendarNotifications.h

Members

pEvent
A pointer to event prepared for paste.
bPasteWillChangeExistingEvent
If this member is TRUE, the new event will not be added, just existing event will be updated.

See Also

XTPCalendarEditOperation, XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED, XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTP_EVENT_EDIT_OPERATION_PARAMS

Group

Structs, Records, Enums


XTP_NC_DATEPICKER_BUTTON Structure

XTPDatePickerControl.h, Structs, Records, Enums
XTP_NC_DATEPICKER_BUTTON Structure

Structure used to send button notification messages.

struct XTP_NC_DATEPICKER_BUTTON {
  NMHDR hdr;
  int nID;
};
File

XTPDatePickerControl.h

Members

hdr
Contains information about a notification message.
nID
Date picker button ID (could be XTP_IDS_DATEPICKER_TODAY or XTP_IDS_DATEPICKER_NONE)

Remarks

This structure represents a set of parameters which are sent to the Main window in a WM_NOTIFY message from DatePicker control and notify the main window when a button event occurs.

Group

Structs, Records, Enums


XTPCalendarAdditionalOptions Enumeration

XTPCalendarOptions.h, Structs, Records, Enums
XTPCalendarAdditionalOptions Enumeration

Enumerates additional calendar options flags.

enum XTPCalendarAdditionalOptions {
  xtpCalendarOptMonthViewShowStartTimeAlways = 0x00000001,
  xtpCalendarOptMonthViewShowEndTimeAlways = 0x00000002,
  xtpCalendarOptWeekViewShowStartTimeAlways = 0x00000004,
  xtpCalendarOptWeekViewShowEndTimeAlways = 0x00000008,
  xtpCalendarOptDayViewNoWordBreak = 0x00000010
};
File

XTPCalendarOptions.h

Members

xtpCalendarOptMonthViewShowStartTimeAlways
define option to always show event start time in the month view.
xtpCalendarOptMonthViewShowEndTimeAlways
define option to always show event end time in the month view.
xtpCalendarOptWeekViewShowStartTimeAlways
define option to always show event start time in the week view.
xtpCalendarOptWeekViewShowEndTimeAlways
define option to always show event end time in the week view.
xtpCalendarOptDayViewNoWordBreak
define option to draw event text without word break in the day view.

Group

Structs, Records, Enums


XTPCalendarBeforeDrawThemeObject Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarBeforeDrawThemeObject Enumeration

This enum defines a set of calendar theme items for which XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification is sent.

enum XTPCalendarBeforeDrawThemeObject {
  xtpCalendarBeforeDraw_DayViewTimeScale = 0x00000001,
  xtpCalendarBeforeDraw_DayViewTimeScaleCaption = 0x00000002,
  xtpCalendarBeforeDraw_DayViewTimeScaleCell = 0x00000004,
  xtpCalendarBeforeDraw_DayViewDay = 0x00000010,
  xtpCalendarBeforeDraw_DayViewDayGroup = 0x00000020,
  xtpCalendarBeforeDraw_DayViewCell = 0x00000040,
  xtpCalendarBeforeDraw_DayViewEvent = 0x00000080,
  xtpCalendarBeforeDraw_MonthViewDay = 0x00001000,
  xtpCalendarBeforeDraw_MonthViewEvent = 0x00002000,
  xtpCalendarBeforeDraw_MonthViewWeekDayHeader = 0x00004000,
  xtpCalendarBeforeDraw_MonthViewWeekHeader = 0x00008000,
  xtpCalendarBeforeDraw_WeekViewDay = 0x00100000,
  xtpCalendarBeforeDraw_WeekViewEvent = 0x00200000
};
File

XTPCalendarNotifications.h

Members

xtpCalendarBeforeDraw_DayViewTimeScale
dwParam2 - [in] nTimeScale = {1 - main, 2 - additional
xtpCalendarBeforeDraw_DayViewTimeScaleCaption
dwParam2 - [in] nTimeScale = {1 - main, 2 - additional};
xtpCalendarBeforeDraw_DayViewTimeScaleCell
dwParam2 - [in] XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
xtpCalendarBeforeDraw_DayViewDay
dwParam2 - [in] CXTPCalendarDayViewDay
xtpCalendarBeforeDraw_DayViewDayGroup
dwParam2 - [in] CXTPCalendarDayViewGroup
xtpCalendarBeforeDraw_DayViewCell
dwParam2 - [in] XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
xtpCalendarBeforeDraw_DayViewEvent
dwParam2 - [in] CXTPCalendarDayViewEvent
xtpCalendarBeforeDraw_MonthViewDay
dwParam2 - [in] CXTPCalendarMonthViewDay
xtpCalendarBeforeDraw_MonthViewEvent
dwParam2 - [in] CXTPCalendarMonthViewEvent
xtpCalendarBeforeDraw_MonthViewWeekDayHeader
dwParam2 - [in] WeekDay = {1-Sun, 2-Mon, ...}, -1 for common part;
xtpCalendarBeforeDraw_MonthViewWeekHeader
dwParam2 - [in] WeekIndex={0...N}, -1 for common part;
xtpCalendarBeforeDraw_WeekViewDay
dwParam2 - [in] CXTPCalendarWeekViewDay
xtpCalendarBeforeDraw_WeekViewEvent
dwParam2 - [in] CXTPCalendarWeekViewEvent

See Also

XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT

Group

Structs, Records, Enums


XTPCalendarClipboardCopyFlags Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarClipboardCopyFlags Enumeration

Enumerates additional flags used in clipboard operations.

enum XTPCalendarClipboardCopyFlags {
  xtpCalendarCopyFlagROccurrence2RException = 0x0001,
  xtpCalendarCopyFlagKeepRException = 0x0002,
  xtpCalendarCopyFlagClearCBAfterPaste = 0x0004,
  xtpCalendarCopyFlagCutMask = xtpCalendarCopyFlagROccurrence2RException|xtpCalendarCopyFlagKeepRException|xtpCalendarCopyFlagClearCBAfterPaste
};
File

XTPCalendarDefines.h

Members

xtpCalendarCopyFlagROccurrence2RException
Convert recurrence Occurrence to Exception before paste.
xtpCalendarCopyFlagKeepRException
Keep recurrence Exception event state before paste.
xtpCalendarCopyFlagClearCBAfterPaste
Clear clipboard after paste.
xtpCalendarCopyFlagCutMask
Default flags for Cut operation.

Group

Structs, Records, Enums


XTPCalendarClockAlignFlags Enumeration

XTPCalendarPaintManager.h, Structs, Records, Enums
XTPCalendarClockAlignFlags Enumeration
enum XTPCalendarClockAlignFlags {
  xtpCalendarClockAlignLeft = 0x01,
  xtpCalendarClockAlignCenter = 0x02,
  xtpCalendarClockAlignRight = 0x04
};
File

XTPCalendarPaintManager.h

Members

xtpCalendarClockAlignLeft
Align to the left side of the rectangle area.
xtpCalendarClockAlignCenter
Align on the middle of the rectangle area.
xtpCalendarClockAlignRight
Align to the right side of the rectangle area.

Remarks

Determines allowable values for the alignment of clock images used by the DrawClock function.

Group

Structs, Records, Enums


XTPCalendarCurrentTimeMarkFlags Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarCurrentTimeMarkFlags Enumeration

Enumerates flags to CXTPCalendarOptions.nDayView_CurrentTimeMarkVisible member. This set of flags define when Current Time Mark on the timescale is visible.

enum XTPCalendarCurrentTimeMarkFlags {
  xtpCalendarCurrentTimeMarkNone = 0,
  xtpCalendarCurrentTimeMarkVisibleForToday = 1,
  xtpCalendarCurrentTimeMarkVisibleAlways = 2,
  xtpCalendarCurrentTimeMarkPrinted = 4
};
File

XTPCalendarDefines.h

Members

xtpCalendarCurrentTimeMarkNone
Time Mark invisible.
xtpCalendarCurrentTimeMarkVisibleForToday
Time Mark visible if today day is visible.
xtpCalendarCurrentTimeMarkVisibleAlways
Time Mark always visible.
xtpCalendarCurrentTimeMarkPrinted
If this flag set - Time Mark is visible for printed calendar also, otherwise it is hidden when printing.

Group

Structs, Records, Enums


XTPCalendarDataProvider Enumeration

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTPCalendarDataProvider Enumeration

Enumeration used to determine the calendar data provider in use.

enum XTPCalendarDataProvider {
  xtpCalendarDataProviderUnknown = 0,
  xtpCalendarDataProviderMemory = 1,
  xtpCalendarDataProviderDatabase = 2,
  xtpCalendarDataProviderMAPI = 3,
  xtpCalendarDataProviderCustom = 4
};
File

XTPCalendarDefines.h

Members

xtpCalendarDataProviderUnknown
Unknown data provider
xtpCalendarDataProviderMemory
Memory data provider - CXTPCalendarMemoryDataProvider.
xtpCalendarDataProviderDatabase
Database data provider - CXTPCalendarDatabaseDataProvider.
xtpCalendarDataProviderMAPI
MAPI (Exchange server) data provider - CXTPCalendarMAPIDataProvider.
xtpCalendarDataProviderCustom
Custom data provider - CXTPCalendarCustomDataProvider.

Remarks

This enumeration contains all available data provider types.

See Also

CXTPCalendarData, CXTPCalendarMemoryDataProvider, CXTPCalendarDatabaseDataProvider

Group

Structs, Records, Enums


XTPCalendarDataProviderCacheMode Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarDataProviderCacheMode Enumeration

Enumerates DB Provider cache modes.

enum XTPCalendarDataProviderCacheMode {
  xtpCalendarDPCacheModeOff = 0x000,
  xtpCalendarDPCacheModeOnRepeat = 0x001,
  xtpCalendarDPCacheModeOnClear = 0x002,
  xtpCalendarDPCacheModeOnMask = 0x00F
};
File

XTPCalendarDefines.h

Members

xtpCalendarDPCacheModeOff
Cache is not used.
xtpCalendarDPCacheModeOnRepeat
Repeat all event manipulations in cache.
xtpCalendarDPCacheModeOnClear
Clear cache after every event manipulation.
xtpCalendarDPCacheModeOnMask
Cache mode on mask.

Group

Structs, Records, Enums


XTPCalendarDayViewScrollDirection Enumeration

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTPCalendarDayViewScrollDirection Enumeration

Enumeration used to determine the scroll direction.

enum XTPCalendarDayViewScrollDirection {
  xtpCalendarDayViewScrollUp,
  xtpCalendarDayViewScrollDown,
  xtpCalendarDayViewScrollNotNeeded
};
File

XTPCalendarDefines.h

Members

xtpCalendarDayViewScrollUp
ScrollV Up.
xtpCalendarDayViewScrollDown
ScrollV Down.
xtpCalendarDayViewScrollNotNeeded
Scrolling not needed.

Remarks

The enumeration determines if scrolling is necessary based on the scroll mode(up, down, or NotNeeded.)

See Also

CXTPCalendarDayView

Group

Structs, Records, Enums


XTPCalendarDraggingMode Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarDraggingMode Enumeration

Enumerates allowable dragging mode state codes.

enum XTPCalendarDraggingMode {
  xtpCalendaDragModeUnknown = 0,
  xtpCalendaDragModeCopy = 1,
  xtpCalendaDragModeMove = 2,
  xtpCalendaDragModeResizeBegin = 3,
  xtpCalendaDragModeResizeEnd = 4,
  xtpCalendaDragModeEditSubject = 5
};
File

XTPCalendarDefines.h

Members

xtpCalendaDragModeUnknown
No dragging mode.
xtpCalendaDragModeCopy
Copying event.
xtpCalendaDragModeMove
Moving event.
xtpCalendaDragModeResizeBegin
Resizing event begin.
xtpCalendaDragModeResizeEnd
Resizing event end.
xtpCalendaDragModeEditSubject
Editing event subject.

Group

Structs, Records, Enums


XTPCalendarEditOperation Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums
XTPCalendarEditOperation Enumeration

Enumerates customizable event edit operations.

enum XTPCalendarEditOperation {
  xtpCalendarEO_Unknown = 0,
  xtpCalendarEO_DragCopy = xtpCalendaDragModeCopy,
  xtpCalendarEO_DragMove = xtpCalendaDragModeMove,
  xtpCalendarEO_DragResizeBegin = xtpCalendaDragModeResizeBegin,
  xtpCalendarEO_DragResizeEnd = xtpCalendaDragModeResizeEnd,
  xtpCalendarEO_EditSubject_ByF2,
  xtpCalendarEO_EditSubject_ByMouseClick,
  xtpCalendarEO_EditSubject_ByTab,
  xtpCalendarEO_EditSubject_AfterEventResize,
  xtpCalendarEO_Cut,
  xtpCalendarEO_Copy,
  xtpCalendarEO_Paste,
  xtpCalendarEO_DeleteSelectedEvents,
  xtpCalendarEO_DeleteEvent,
  xtpCalendarEO_InPlaceCreateEvent
};
File

XTPCalendarNotifications.h

Members

xtpCalendarEO_Unknown
Unknown operation value.
xtpCalendarEO_DragCopy
Drag copy event.
xtpCalendarEO_DragMove
Drag move event
xtpCalendarEO_DragResizeBegin
Drag Resizing event begin.
xtpCalendarEO_DragResizeEnd
Drag Resizing event end.
xtpCalendarEO_EditSubject_ByF2
In-place edit event subject by F2.
xtpCalendarEO_EditSubject_ByMouseClick
In-place edit event subject by Mouse Click.
xtpCalendarEO_EditSubject_ByTab
In-place edit event subject by TAB.
xtpCalendarEO_EditSubject_AfterEventResize
In-place edit event subject after event resize.
xtpCalendarEO_Cut
Cut events
xtpCalendarEO_Copy
Copy events
xtpCalendarEO_Paste
Paste event.
xtpCalendarEO_DeleteSelectedEvents
Delete selected events.
xtpCalendarEO_DeleteEvent
Delete event.
xtpCalendarEO_InPlaceCreateEvent
In-place event creation.

Group

Structs, Records, Enums


XTPCalendarEndEditSubjectAction Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarEndEditSubjectAction Enumeration

Enumerates allowable flags for driving subject editors.

enum XTPCalendarEndEditSubjectAction {
  xtpCalendarEditSubjectUnknown = 0,
  xtpCalendarEditSubjectCommit = 1,
  xtpCalendarEditSubjectCancel = 2
};
File

XTPCalendarDefines.h

Members

xtpCalendarEditSubjectUnknown
Action is undefined.
xtpCalendarEditSubjectCommit
Apply and commit dragging.
xtpCalendarEditSubjectCancel
Cancel editing and dragging changes.

Group

Structs, Records, Enums


XTPCalendarEventBusyStatus Enumeration

XTPCalendarDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarEventBusyStatus Enumeration

Enumerates busy status values.

enum XTPCalendarEventBusyStatus {
  xtpCalendarBusyStatusUnknown = -1,
  xtpCalendarBusyStatusFree = 0,
  xtpCalendarBusyStatusTentative = 1,
  xtpCalendarBusyStatusBusy = 2,
  xtpCalendarBusyStatusOutOfOffice = 3
};
File

XTPCalendarDefines.h

Members

xtpCalendarBusyStatusUnknown
Typed unknown value.
xtpCalendarBusyStatusFree
Free event status.
xtpCalendarBusyStatusTentative
Tentative event status.
xtpCalendarBusyStatusBusy
Busy event status.
xtpCalendarBusyStatusOutOfOffice
OutOfOffice event status.

See Also

CXTPCalendarEvent::SetBusyStatus

Example
CXTPCalendarData* pData;
CXTPCalendarEventPtr ptrEvent = pData->CreateNewEvent();
ptrEvent->SetBusyStatus(xtpCalendarBusyStatusTentative);
VERIFY(pCalendarData->AddEvent(ptrEvent));
Group

Structs, Records, Enums


XTPCalendarEventCaptionFormat Enumeration

XTPCalendarViewEvent.h, Structs, Records, Enums
XTPCalendarEventCaptionFormat Enumeration

Enumerates allowable formats for event caption.

enum XTPCalendarEventCaptionFormat {
  xtpCalendarCaptionFormatUnknown = 0,
  xtpCalendarCaptionFormatSubject = 1,
  xtpCalendarCaptionFormatStartSubject = 2,
  xtpCalendarCaptionFormatStartEndSubject = 3
};
File

XTPCalendarViewEvent.h

Members

xtpCalendarCaptionFormatUnknown
Undefined format.
xtpCalendarCaptionFormatSubject
Caption displays subject.
xtpCalendarCaptionFormatStartSubject
Besides subject displays start time.
xtpCalendarCaptionFormatStartEndSubject
Besides subject displays start and end time.

Group

Structs, Records, Enums


XTPCalendarEventCategories Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarEventCategories Enumeration

Enumerates standard Event Categories for office 2007 theme.

enum XTPCalendarEventCategories {
  xtpCalendarEventCategoryUnknown = 0,
  xtpCalendarEventCategoryYellow = 1,
  xtpCalendarEventCategoryGreen = 2,
  xtpCalendarEventCategoryRed = 3,
  xtpCalendarEventCategoryPink = 4,
  xtpCalendarEventCategoryOrange = 5,
  xtpCalendarEventCategoryBlue = 6
};
File

XTPCalendarDefines.h

Members

xtpCalendarEventCategoryUnknown
Typed unknown value.
xtpCalendarEventCategoryYellow
The Yellow category ID.
xtpCalendarEventCategoryGreen
The Green category ID.
xtpCalendarEventCategoryRed
The Red category ID.
xtpCalendarEventCategoryPink
The Pink category ID.
xtpCalendarEventCategoryOrange
The Orange category ID.
xtpCalendarEventCategoryBlue
The Blue category ID.

Group

Structs, Records, Enums


XTPCalendarEventIconIDs Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarEventIconIDs Enumeration

Icons IDs set to be used with calendar event custom icons to customize standard event glyphs.

enum XTPCalendarEventIconIDs {
  xtpCalendarEventIconIDReminder = -1,
  xtpCalendarEventIconIDOccurrence = -2,
  xtpCalendarEventIconIDException = -3,
  xtpCalendarEventIconIDMeeting = -4,
  xtpCalendarEventIconIDPrivate = -5
};
File

XTPCalendarDefines.h

Members

xtpCalendarEventIconIDReminder
Reminder glyph ID.
xtpCalendarEventIconIDOccurrence
Recurrence glyph ID.
xtpCalendarEventIconIDException
Recurrence exception glyph ID.
xtpCalendarEventIconIDMeeting
Meeting glyph ID.
xtpCalendarEventIconIDPrivate
Private glyph ID.

Group

Structs, Records, Enums


XTPCalendarEventImportance Enumeration

XTPCalendarDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarEventImportance Enumeration

Enumerates importance level values.

enum XTPCalendarEventImportance {
  xtpCalendarImportanceUnknown = -1,
  xtpCalendarImportanceLow = 0,
  xtpCalendarImportanceNormal = 1,
  xtpCalendarImportanceHigh = 2
};
File

XTPCalendarDefines.h

Members

xtpCalendarImportanceUnknown
Typed unknown value.
xtpCalendarImportanceLow
Low importance level.
xtpCalendarImportanceNormal
Normal importance level.
xtpCalendarImportanceHigh
High importance level.

See Also

CXTPCalendarEvent::SetImportance

Example
CXTPCalendarData* pData;
CXTPCalendarEventPtr ptrEvent = pData->CreateNewEvent();
ptrEvent->SetImportance(xtpCalendarImportanceHigh);
VERIFY(pCalendarData->AddEvent(ptrEvent));
Group

Structs, Records, Enums


XTPCalendarEventRecurrenceState Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarEventRecurrenceState Enumeration

Enumerates recurrence states.

enum XTPCalendarEventRecurrenceState {
  xtpCalendarRecurrenceNotRecurring = 0,
  xtpCalendarRecurrenceMaster = 1,
  xtpCalendarRecurrenceOccurrence = 2,
  xtpCalendarRecurrenceException = 3
};
File

XTPCalendarDefines.h

Members

xtpCalendarRecurrenceNotRecurring
Event is not recurring.
xtpCalendarRecurrenceMaster
Event is a Master (template to generate occurrences).
xtpCalendarRecurrenceOccurrence
Event is Occurrence.
xtpCalendarRecurrenceException
Event is Exception (changed occurrence).

Group

Structs, Records, Enums


XTPCalendarEventRecurrenceType Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarEventRecurrenceType Enumeration

Enumerates Recurrence Pattern Types.

enum XTPCalendarEventRecurrenceType {
  xtpCalendarRecurrenceUnknown = 0,
  xtpCalendarRecurrenceDaily = 1,
  xtpCalendarRecurrenceWeekly = 2,
  xtpCalendarRecurrenceMonthly = 3,
  xtpCalendarRecurrenceMonthNth = 4,
  xtpCalendarRecurrenceYearly = 5,
  xtpCalendarRecurrenceYearNth = 6
};
File

XTPCalendarDefines.h

Members

xtpCalendarRecurrenceUnknown
Typed unknown value.
xtpCalendarRecurrenceDaily
Every N days.
xtpCalendarRecurrenceWeekly
Every N weeks on specified 'DaysMask'.
xtpCalendarRecurrenceMonthly
D day of every N months.
xtpCalendarRecurrenceMonthNth
The first, second, ...
xtpCalendarRecurrenceYearly
Every month(M) day(D).
xtpCalendarRecurrenceYearNth
The first, second, ...

Group

Structs, Records, Enums


XTPCalendarExpandDayButton Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarExpandDayButton Enumeration

This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action.

enum XTPCalendarExpandDayButton {
  xtpCalendarExpandDayButton_MonthView = 0x01,
  xtpCalendarExpandDayButton_WeekView = 0x02
};
File

XTPCalendarNotifications.h

Members

xtpCalendarExpandDayButton_MonthView
Defines Month view expand button.
xtpCalendarExpandDayButton_WeekView
Defines Week view expand button.

See Also

XTP_NC_CALENDAR_USERACTION, XTP_CALENDAR_USERACTION_PARAMS

Group

Structs, Records, Enums


XTPCalendarGetItemText Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarGetItemText Enumeration

This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.

enum XTPCalendarGetItemText {
  xtpCalendarItemText_EventSubject = 0x00000001,
  xtpCalendarItemText_EventLocation = 0x00000002,
  xtpCalendarItemText_DayViewDayHeader = 0x00000004,
  xtpCalendarItemText_WeekViewDayHeader = 0x00000008,
  xtpCalendarItemText_MonthViewDayHeader = 0x00000010,
  xtpCalendarItemText_MonthViewWeekDayHeader = 0x00000020,
  xtpCalendarItemText_EventToolTipText = 0x00000040,
  xtpCalendarItemText_EventStartTimeText = 0x00000100,
  xtpCalendarItemText_EventEndTimeText = 0x00000200
};
File

XTPCalendarNotifications.h

Members

xtpCalendarItemText_EventSubject
Send request to customize Event subject text before draw it.
xtpCalendarItemText_EventLocation
Send request to customize Event location text before draw it.
xtpCalendarItemText_DayViewDayHeader
Send request to customize Day view day header text.
xtpCalendarItemText_WeekViewDayHeader
Send request to customize Week view day header text.
xtpCalendarItemText_MonthViewDayHeader
Send request to customize Month view day header text.
xtpCalendarItemText_MonthViewWeekDayHeader
Send request to customize month view week day header text.
xtpCalendarItemText_EventToolTipText
Send request to customize event tooltip text.
xtpCalendarItemText_EventStartTimeText
Send request to customize event start time text.
xtpCalendarItemText_EventEndTimeText
Send request to customize event end time text.

See Also

XTPCalendarGetItemTextEx, XTP_NC_CALENDAR_GETITEMTEXT, CXTPCalendarControl::GetAskItemTextFlags, CXTPCalendarControlPaintManager::GetAskItemTextFlags, CXTPCalendarControlPaintManager::SetAskItemTextFlags, CXTPCalendarTheme::GetAskItemTextFlags, CXTPCalendarTheme::SetAskItemTextFlags

Group

Structs, Records, Enums


XTPCalendarGetItemTextEx Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarGetItemTextEx Enumeration

This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification. These flags are used for office 2007 theme only.

enum XTPCalendarGetItemTextEx {
  xtpCalendarItemText_EventBody = 0x00010000,
  xtpCalendarItemText_EventMarkupTemplate = 0x04000000,
  xtpCalendarItemText_DayViewDayHeaderLeft = 0x00020000,
  xtpCalendarItemText_DayViewDayHeaderCenter = 0x00040000,
  xtpCalendarItemText_DayViewDayHeaderRight = 0x00080000,
  xtpCalendarItemText_WeekViewDayHeaderLeft = 0x00100000,
  xtpCalendarItemText_WeekViewDayHeaderCenter = 0x00200000,
  xtpCalendarItemText_WeekViewDayHeaderRight = 0x00400000,
  xtpCalendarItemText_MonthViewDayHeaderLeft = 0x00800000,
  xtpCalendarItemText_MonthViewDayHeaderCenter = 0x01000000,
  xtpCalendarItemText_MonthViewDayHeaderRight = 0x02000000
};
File

XTPCalendarNotifications.h

Members

xtpCalendarItemText_EventBody
Send request to customize Event body text before draw it.
xtpCalendarItemText_EventMarkupTemplate
Send request to set Event Markup Template text before draw it.
xtpCalendarItemText_DayViewDayHeaderLeft
Send request to customize Day view day header text on the left.
xtpCalendarItemText_DayViewDayHeaderCenter
Send request to customize Day view day header text on the center.
xtpCalendarItemText_DayViewDayHeaderRight
Send request to customize Day view day header text on the right.
xtpCalendarItemText_WeekViewDayHeaderLeft
Send request to customize Week view day header text on the left.
xtpCalendarItemText_WeekViewDayHeaderCenter
Send request to customize Week view day header text on the center.
xtpCalendarItemText_WeekViewDayHeaderRight
Send request to customize Week view day header text on the right.
xtpCalendarItemText_MonthViewDayHeaderLeft
Send request to customize Month view day header text on the left.
xtpCalendarItemText_MonthViewDayHeaderCenter
Send request to customize Month view day header text on the center.
xtpCalendarItemText_MonthViewDayHeaderRight
Send request to customize Month view day header text on the right.

See Also

XTPCalendarGetItemText, XTP_NC_CALENDAR_GETITEMTEXT, CXTPCalendarControl::GetAskItemTextFlags, CXTPCalendarControlPaintManager::GetAskItemTextFlags, CXTPCalendarControlPaintManager::SetAskItemTextFlags, CXTPCalendarTheme::GetAskItemTextFlags, CXTPCalendarTheme::SetAskItemTextFlags

Group

Structs, Records, Enums


XTPCalendarHitTestCode Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarHitTestCode Enumeration

Enumerates allowable hit test codes.

enum XTPCalendarHitTestCode {
  xtpCalendarHitTestUnknown = 0,
  xtpCalendarHitTestDayArea = 0x000001,
  xtpCalendarHitTestDayHeader = 0x000002,
  xtpCalendarHitTestDayExpandButton = 0x000004,
  xtpCalendarHitTestGroupArea = xtpCalendarHitTestDayArea,
  xtpCalendarHitTestGroupHeader = 0x000008,
  xtpCalendarHitTestDay_Mask = 0x00000F,
  xtpCalendarHitTestEventDragArea = 0x000010,
  xtpCalendarHitTestEventTextArea = 0x000020,
  xtpCalendarHitTestEventResizeVArea = 0x000100,
  xtpCalendarHitTestEventResizeHArea = 0x000200,
  xtpCalendarHitTestEventResizeArea_Mask = xtpCalendarHitTestEventResizeVArea|xtpCalendarHitTestEventResizeHArea,
  xtpCalendarHitTestEventResizeBegin = 0x000400,
  xtpCalendarHitTestEventResizeEnd = 0x000800,
  xtpCalendarHitTestEvent_Mask = 0x000FF0,
  xtpCalendarHitTestDayViewTimeScale = 0x001000,
  xtpCalendarHitTestDayViewCell = 0x002000,
  xtpCalendarHitTestDayViewAllDayEvent = 0x004000,
  xtpCalendarHitTestDayViewScrollUp = 0x010000,
  xtpCalendarHitTestDayViewScrollDown = 0x020000,
  xtpCalendarHitTestDayView_Mask = 0x0FF000,
  xtpCalendarHitTestPrevEventButton = 0x100000,
  xtpCalendarHitTestNextEventButton = 0x200000
};
File

XTPCalendarDefines.h

Members

xtpCalendarHitTestUnknown
The position is unknown or does not belong to our control.
xtpCalendarHitTestDayArea
The position is inside the days area.
xtpCalendarHitTestDayHeader
The position is inside control's header.
xtpCalendarHitTestDayExpandButton
The position is over Expand day button icon.
xtpCalendarHitTestGroupArea
The position is inside a group area (formerly day).
xtpCalendarHitTestGroupHeader
The position is inside Group (resource) header.
xtpCalendarHitTestDay_Mask
The mask for any position inside days area with the header.
xtpCalendarHitTestEventDragArea
The position is on Event drag area.
xtpCalendarHitTestEventTextArea
The position is on Event text view area.
xtpCalendarHitTestEventResizeVArea
Event vertical resize area.
xtpCalendarHitTestEventResizeHArea
Event horizontal resize area.
xtpCalendarHitTestEventResizeArea_Mask
The mask for both event resize areas.
xtpCalendarHitTestEventResizeBegin
Event start resizing area.
xtpCalendarHitTestEventResizeEnd
Event end resizing area.
xtpCalendarHitTestEvent_Mask
The mask for event area at whole.
xtpCalendarHitTestDayViewTimeScale
Time scale part of the day view.
xtpCalendarHitTestDayViewCell
Day view cells - its general part.
xtpCalendarHitTestDayViewAllDayEvent
All day zone on the day view.
xtpCalendarHitTestDayViewScrollUp
DayView Scroll Up button.
xtpCalendarHitTestDayViewScrollDown
DayView Scroll Down button.
xtpCalendarHitTestDayView_Mask
The mask for all DayView areas.
xtpCalendarHitTestPrevEventButton
Go to Rrevious event button.
xtpCalendarHitTestNextEventButton
Go to Next event button.

Remarks

ResizeV, ResizeH flags are used together with ResizeBegin or ResizeEnd.

Group

Structs, Records, Enums


XTPCalendarMouseMode Enumeration

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTPCalendarMouseMode Enumeration

Enumeration of operational mouse modes.

enum XTPCalendarMouseMode {
  xtpCalendarMouseNothing,
  xtpCalendarMouseEventPreResizeV,
  xtpCalendarMouseEventPreResizeH,
  xtpCalendarMouseEventPreDrag,
  xtpCalendarMouseEventResizingV,
  xtpCalendarMouseEventResizingH,
  xtpCalendarMouseEventDragCopy,
  xtpCalendarMouseEventDragMove,
  xtpCalendarMouseEventDraggingOut
};
File

XTPCalendarDefines.h

Members

xtpCalendarMouseNothing
User is doing nothing - just watching to the control.
xtpCalendarMouseEventPreResizeV
User is moving mouse under event view vertical "resize" area.
xtpCalendarMouseEventPreResizeH
User is moving mouse under event view horizontal "resize" area.
xtpCalendarMouseEventPreDrag
User is moving mouse under event view "drag" area.
xtpCalendarMouseEventResizingV
User is resizing event vertically (holding mouse left button down).
xtpCalendarMouseEventResizingH
User is resizing event horizontally (holding mouse left button down).
xtpCalendarMouseEventDragCopy
User is dragging event view (holding left mouse button down).
xtpCalendarMouseEventDragMove
User is dragging event view (holding left mouse button down and Control key is down).
xtpCalendarMouseEventDraggingOut
User is dragging event out of dragging area.

Remarks

Calendar Control has several Mouse states that handled by control. This enumeration helps to clearly identify each of these

  • Sends Notifications:
  • Sends Messages:
Group

Structs, Records, Enums


XTPCalendarMultiDayEventFlags Enumeration

XTPCalendarViewEvent.h, Structs, Records, Enums
XTPCalendarMultiDayEventFlags Enumeration

Enumerates defined flags for multi day event states.

enum XTPCalendarMultiDayEventFlags {
  xtpCalendarMultiDayUnknown = 0,
  xtpCalendarMultiDayNoMultiDay = 0x01,
  xtpCalendarMultiDayFirst = 0x02,
  xtpCalendarMultiDayMiddle = 0x04,
  xtpCalendarMultiDayLast = 0x08,
  xtpCalendarMultiDayFMLmask = xtpCalendarMultiDayFirst|xtpCalendarMultiDayMiddle|xtpCalendarMultiDayLast,
  xtpCalendarMultiDayMaster = 0x10,
  xtpCalendarMultiDaySlave = 0x20,
  xtpCalendarMultiDayMSmask = xtpCalendarMultiDayMaster|xtpCalendarMultiDaySlave
};
File

XTPCalendarViewEvent.h

Members

xtpCalendarMultiDayUnknown
Undefined multi day event.
xtpCalendarMultiDayNoMultiDay
Not a multi day event.
xtpCalendarMultiDayFirst
First portion of a multi day event.
xtpCalendarMultiDayMiddle
Middle portion of a multi day event.
xtpCalendarMultiDayLast
Last portion of a multi day event.
xtpCalendarMultiDayFMLmask
Combined flag.
xtpCalendarMultiDayMaster
First portion of a multi day event.
xtpCalendarMultiDaySlave
Rest of the event views (besides Master).
xtpCalendarMultiDayMSmask
Combines flag.

Group

Structs, Records, Enums


XTPCalendarPatternEnd Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarPatternEnd Enumeration

Specify the end of the recurrence pattern type.

enum XTPCalendarPatternEnd {
  xtpCalendarPatternEndDate,
  xtpCalendarPatternEndAfterOccurrences,
  xtpCalendarPatternEndNoDate
};
File

XTPCalendarDefines.h

Members

xtpCalendarPatternEndDate
End of the recurrence pattern specified by the date.
xtpCalendarPatternEndAfterOccurrences
End of the recurrence pattern specified by the occurrences amount.
xtpCalendarPatternEndNoDate
Recurrence pattern has no End.

Group

Structs, Records, Enums


XTPCalendarRemindersAction Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarRemindersAction Enumeration

Enumeration of possible Calendar Reminder notification actions.

enum XTPCalendarRemindersAction {
  xtpCalendarRemindersMonitoringStarted = 1,
  xtpCalendarRemindersMonitoringStopped = 2,
  xtpCalendarRemindersFire = 3,
  xtpCalendarReminderSnoozed = 4,
  xtpCalendarReminderDismissed = 5,
  xtpCalendarReminderDismissedAll = 6
};
File

XTPCalendarNotifications.h

Members

xtpCalendarRemindersMonitoringStarted
Sends after monitoring has started (end of executing CXTPCalendarRemindersManager::StartMonitoring)
xtpCalendarRemindersMonitoringStopped
Sends when monitoring has stopped (CXTPCalendarRemindersManager::StopMonitoring)
xtpCalendarRemindersFire
Main notification, when reminder is executed.
xtpCalendarReminderSnoozed
When 1 pending reminder was snoozed.
xtpCalendarReminderDismissed
When 1 pending reminder was dismissed.
xtpCalendarReminderDismissedAll
When all pending reminders were dismissed.

Remarks

Members of this enumerations are used as an additional parameters of the XTP_NC_CALENDAR_ON_REMINDERS notification

See Also

XTP_NC_CALENDAR_ON_REMINDERS notification

Group

Structs, Records, Enums


XTPCalendarScrollDayButton Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarScrollDayButton Enumeration

This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action. (valid for office 2007 theme only)

enum XTPCalendarScrollDayButton {
  xtpCalendarScrollDayButton_DayViewUp = xtpCalendarHitTestDayViewScrollUp,
  xtpCalendarScrollDayButton_DayViewDown = xtpCalendarHitTestDayViewScrollDown
};
File

XTPCalendarNotifications.h

Members

xtpCalendarScrollDayButton_DayViewUp
Defines Day view Scroll Up button.
xtpCalendarScrollDayButton_DayViewDown
Defines Day view Scroll Down button.

See Also

XTP_NC_CALENDAR_USERACTION, XTP_CALENDAR_USERACTION_PARAMS

Group

Structs, Records, Enums


XTPCalendarSelectionChanged Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums
XTPCalendarSelectionChanged Enumeration

Enumerates calendar selection types.

enum XTPCalendarSelectionChanged {
  xtpCalendarSelectionUnknown = 0,
  xtpCalendarSelectionDays = 1,
  xtpCalendarSelectionEvents = 2
};
File

XTPCalendarNotifications.h

Members

xtpCalendarSelectionUnknown
Unknown selection value.
xtpCalendarSelectionDays
Days (or day hours for day view) selection.
xtpCalendarSelectionEvents
Events selection.

Group

Structs, Records, Enums


XTPCalendarTheme Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarTheme Enumeration

Paint themes used by calendar.

enum XTPCalendarTheme {
  xtpCalendarThemeOffice2000,
  xtpCalendarThemeOfficeXP,
  xtpCalendarThemeOffice2003,
  xtpCalendarThemeOffice2007
};
File

XTPCalendarDefines.h

Members

xtpCalendarThemeOffice2000
Office 2000 theme.
xtpCalendarThemeOfficeXP
Office XP theme.
xtpCalendarThemeOffice2003
Office 2003 theme.
xtpCalendarThemeOffice2007
Office 2007 theme.

Group

Structs, Records, Enums


XTPCalendarUndoMode Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarUndoMode Enumeration

Enumerates flags to identify undo mode.

enum XTPCalendarUndoMode {
  xtpCalendarUndoModeUnknown = 0,
  xtpCalendarUndoModeUndo = 1,
  xtpCalendarUndoModeRedo = 2
};
File

XTPCalendarDefines.h

Members

xtpCalendarUndoModeUnknown
Undo mode is undefined.
xtpCalendarUndoModeUndo
Undo action is pending.
xtpCalendarUndoModeRedo
Redo action is pending.

Group

Structs, Records, Enums


XTPCalendarUpdateOptions Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarUpdateOptions Enumeration

Contains bit-masks for adjusting the calendar control.

enum XTPCalendarUpdateOptions {
  xtpCalendarUpdateLayout = 0x0001,
  xtpCalendarUpdateScrollBar = 0x0002,
  xtpCalendarUpdateRedraw = 0x0004,
  xtpCalendarUpdateAll = 0x000F,
  xtpCalendarUpdateRedrawIfNeed = 0x0010
};
File

XTPCalendarDefines.h

Members

xtpCalendarUpdateLayout
Adjust positions of control's elements.
xtpCalendarUpdateScrollBar
Recalculate control's scrollbar positions.
xtpCalendarUpdateRedraw
Redraw control picture.
xtpCalendarUpdateAll
Redraw all portions of the control on exiting adjuster scope.
xtpCalendarUpdateRedrawIfNeed
Redraw control's picture if needed.

Remarks

This enumeration contains bit masks for using with CXTPCalendarControl::CUpdateContext. Depending on members of this enum there will be specific redrawing functionality called on exiting adjuster's scope.

Group

Structs, Records, Enums


XTPCalendarUserAction Enumeration

XTPCalendarNotifications.h, Structs, Records, Enums, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarUserAction Enumeration

This enum defines set of user actions which can be customized.

enum XTPCalendarUserAction {
  xtpCalendarUserAction_OnExpandDay = 0x80000000,
  xtpCalendarUserAction_OnScrollDay = 0x40000000
};
File

XTPCalendarNotifications.h

Members

xtpCalendarUserAction_OnExpandDay
Expand Day button was clicked for month or week view.
xtpCalendarUserAction_OnScrollDay
Expand Day button was clicked for day view.

See Also

XTP_NC_CALENDAR_USERACTION, XTP_CALENDAR_USERACTION_PARAMS

Group

Structs, Records, Enums


XTPCalendarViewChangedUpdateOptions Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarViewChangedUpdateOptions Enumeration

This enumeration contains options for CXTPCalendarControl::CViewChangedContext.

enum XTPCalendarViewChangedUpdateOptions {
  xtpCalendarViewChangedSend = 1,
  xtpCalendarViewChangedLock = 2
};
File

XTPCalendarDefines.h

Members

xtpCalendarViewChangedSend
Set send request for XTP_NC_CALENDARVIEWWASCHANGED notification and lock sending.
xtpCalendarViewChangedLock
Lock sending only, send request for XTP_NC_CALENDARVIEWWASCHANGED notification is not set.

Group

Structs, Records, Enums


XTPCalendarViewType Enumeration

XTPCalendarDefines.h, Structs, Records, Enums, See Also
XTPCalendarViewType Enumeration

Enumeration used to determine the calendar view type in use.

enum XTPCalendarViewType {
  xtpCalendarDayView,
  xtpCalendarWorkWeekView,
  xtpCalendarWeekView,
  xtpCalendarMonthView,
  xtpCalendarFullWeekView
};
File

XTPCalendarDefines.h

Members

xtpCalendarDayView
Day view - CXTPCalendarDayView
xtpCalendarWorkWeekView
Day view - CXTPCalendarDayView.
xtpCalendarWeekView
Week view - CXTPCalendarWeekView
xtpCalendarMonthView
Month view - CXTPCalendarMonthView
xtpCalendarFullWeekView
Day view - CXTPCalendarDayView.

Remarks

This enumeration contains all available Calendar view types.

See Also

CXTPCalendarView, CXTPCalendarDayView, CXTPCalendarWeekView, CXTPCalendarMonthView

Group

Structs, Records, Enums


XTPCalendarWeek Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarWeek Enumeration

Enumerates a sequence numbers for days.

enum XTPCalendarWeek {
  xtpCalendarWeekFirst = 1,
  xtpCalendarWeekSecond = 2,
  xtpCalendarWeekThird = 3,
  xtpCalendarWeekFourth = 4,
  xtpCalendarWeekLast = 5
};
File

XTPCalendarDefines.h

Members

xtpCalendarWeekFirst
First
xtpCalendarWeekSecond
Second
xtpCalendarWeekThird
Third
xtpCalendarWeekFourth
Fourth
xtpCalendarWeekLast
Last

Group

Structs, Records, Enums


XTPCalendarWeekDay Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPCalendarWeekDay Enumeration

Enumerates Day of Weeks codes.

enum XTPCalendarWeekDay {
  xtpCalendarDaySunday = 0x001,
  xtpCalendarDayMonday = 0x002,
  xtpCalendarDayTuesday = 0x004,
  xtpCalendarDayWednesday = 0x008,
  xtpCalendarDayThursday = 0x010,
  xtpCalendarDayFriday = 0x020,
  xtpCalendarDaySaturday = 0x040,
  xtpCalendarDayAllWeek = xtpCalendarDayMonday|xtpCalendarDayTuesday|xtpCalendarDayWednesday|xtpCalendarDayThursday|xtpCalendarDayFriday|xtpCalendarDaySaturday|xtpCalendarDaySunday,
  xtpCalendarDaySaSu = xtpCalendarDaySaturday|xtpCalendarDaySunday,
  xtpCalendarDayMo_Fr = xtpCalendarDayAllWeek^xtpCalendarDaySaSu
};
File

XTPCalendarDefines.h

Members

xtpCalendarDaySunday
Sunday
xtpCalendarDayMonday
Monday
xtpCalendarDayTuesday
Tuesday
xtpCalendarDayWednesday
Wednesday
xtpCalendarDayThursday
Thursday
xtpCalendarDayFriday
Friday
xtpCalendarDaySaturday
Saturday
xtpCalendarDayAllWeek
All week mask.
xtpCalendarDaySaSu
Saturday, Sunday mask.
xtpCalendarDayMo_Fr
Monday to Friday mask.

Group

Structs, Records, Enums


XTPDatePickerBorderStyle Enumeration

XTPDatePickerControl.h, Structs, Records, Enums
XTPDatePickerBorderStyle Enumeration

Border style of Date picker control

enum XTPDatePickerBorderStyle {
  xtpDatePickerBorderNone,
  xtpDatePickerBorder3D,
  xtpDatePickerBorderOffice,
  xtpDatePickerBorderStatic
};
File

XTPDatePickerControl.h

Members

xtpDatePickerBorderNone
No border.
xtpDatePickerBorder3D
3D border.
xtpDatePickerBorderOffice
Office-like border
xtpDatePickerBorderStatic
Static border.

Group

Structs, Records, Enums


XTPEnumCalendarReminderForOccurrenceParameters Enumeration

XTPCalendarDefines.h, Structs, Records, Enums
XTPEnumCalendarReminderForOccurrenceParameters Enumeration

Enumerates parameters used in configuring reminders for recurrence patterns occurrences.

enum XTPEnumCalendarReminderForOccurrenceParameters {
  xtpCalendarRmdPrm_Default = LONG_MAX,
  xtpCalendarRmdPrm_DontChange = LONG_MIN
};
File

XTPCalendarDefines.h

Members

xtpCalendarRmdPrm_Default
Set default reminders value.
xtpCalendarRmdPrm_DontChange
Do not change reminders time value.

Group

Structs, Records, Enums


Types

Calendar, Types
Types
Module

Calendar

Types
Type | Description
CXTPCalendarDatesArray | Type definition for an array of dates.


CXTPCalendarDatesArray Type

XTPCalendarDefines.h, Types
CXTPCalendarDatesArray Type

Type definition for an array of dates.

typedef CArray<COleDateTime, COleDateTime&> CXTPCalendarDatesArray;
File

XTPCalendarDefines.h

Group

Types


Variables

Calendar, Variables
Variables
Module

Calendar

Variables
Variable | Description
cszCalendarMarkupPrm_Subject | Markup template params
cszEventCustProp_CategoryIDs | String name of the corresponding property.
cszEventCustProp_IconsIDs | String name of the corresponding property.
cszEventCustProp_MarkupTemplate | String name of the MarkupTemplate property.
cszEventCustProp_NextReminderTime_Snoozed | String name of the corresponding property.
cszProcess_RecurrencePatternID | String name for a corresponding property
cszProcess_RecurrenceState | String name for a corresponding property
WM_XTP_CALENDAR_BASE | The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use by private window classes, usually of the form WM_XTP_CALENDAR_BASE+X, where X is an integer value.
XTP_DATEPICKER_TIMER_INTERVAL | Date picker timer interval.
XTP_DATEPICKER_TIMERID | Date picker timer ID.
XTP_ID_CALENDAR_CONTROL | Identifier of Calendar control child window of CXTPCalendarControlView.
XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL | This notification is sent for each calendar day view cell before draw. You may customize clrBackgroundColor member of provided XTP_CALENDAR_DAYVIEWCELL_PARAMS structure. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT | This notification is sent for calendar theme items before draw. You may customize corresponding theme part for each object in this message. Any object part changes which made in this notification handler will be discarded when object draw finished. This let you dynamically customize each calendar item. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION | This notification is sent to customize or disable specified editing operation. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_DoCreate_Event | This notification is used as analog of overridable method CXTPCalendarData::DoCreate_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoCreate_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoCreate_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoDelete_Event | This notification is used as analog of overridable method CXTPCalendarData::DoDelete_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoDelete_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoDelete_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoGetAllEvents_raw | This notification is used as analog of overridable method CXTPCalendarData::DoGetAllEvents_raw. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoGetUpcomingEvents | This notification is used as analog of overridable method CXTPCalendarData::DoGetUpcomingEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRead_Event | This notification is used as analog of overridable method CXTPCalendarData::DoRead_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRead_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoRead_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRemoveAllEvents | This notification is used as analog of overridable method CXTPCalendarData::DoRemoveAllEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRetrieveDayEvents | This notification is used as analog of overridable method CXTPCalendarData::DoRetrieveDayEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoUpdate_Event | This notification is used as analog of overridable method CXTPCalendarData::DoUpdate_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoUpdate_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoUpdate_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_GETGROPVIEWCAPTION | This notification is sent when selection is changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_GETITEMTEXT | This notification is sent for calendar items which defines in AskItemTextFlags property.
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED | This notification is sent to determine is specified editing operation disabled. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_ON_REMINDERS | On RButtonUp event. Sender - CXTPCalendarRemindersManager
XTP_NC_CALENDAR_PREPOPULATE | This notification is sent when calendar is populating. lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_PREPOPULATE_DAY | This notification is sent when calendar is populating. lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED | Calendar Control data provider (resources) where changed. SetDataProvider() or SetResources() methods where called. Sender - CXTPCalendarControl, CXTPCalendarView.
XTP_NC_CALENDAR_SELECTION_CHANGED | This notification is sent when selection is changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_THEME_CHANGED | This notification is sent when calendar paint theme changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_USERACTION | This notification send for when user action defined in XTPCalendarUserAction enum happened. Parameters wParam - [in] A pointer to XTP_CALENDAR_USERACTION_PARAMS structure. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if specified action is handled (to Cancel default processing) , otherwise FALSE. Initial value is FALSE.
XTP_NC_CALENDARCONTEXTMENU | A Context Menu should be displayed for the Calendar Control. Sender - CXTPCalendarControl
XTP_NC_CALENDARDATAPROVIDERWASCHANGED | Calendar Control data provider (resources) where changed. SetDataProvider() or SetResources() methods where called. Sender - CXTPCalendarControl, CXTPCalendarView.
XTP_NC_CALENDAREVENTWASADDED | New event has just been added to the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDAREVENTWASCHANGED | Event has just been changed in the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDAREVENTWASDELETED | Event has just been deleted from the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDARKEYDOWN | On KeyDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONDBLCLICK | On LButtonDblClick event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONDOWN | On LButtonDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONUP | On LButtonUp event. Sender - CXTPCalendarControl
XTP_NC_CALENDARMOUSEMOVE | On MouseMove event. Sender - CXTPCalendarControl
XTP_NC_CALENDAROPTIONSWASCHANGED | Calendar Control options was changed. Sender - CXTPCalendarControl
XTP_NC_CALENDARRBUTTONDOWN | On RButtonDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARRBUTTONUP | On RButtonUp event. Sender - CXTPCalendarControl
XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED | Calendar Control Day view time scale was changed. Sender - CXTPCalendarControl
XTP_NC_CALENDARVIEWWASCHANGED | Current Calendar Control view type(day, week, ...) or content was changed. Sender - CXTPCalendarControl
XTP_NC_DATEPICKER_BUTTON_CLICK | Notify ID to parent window.
XTP_NC_DATEPICKER_SELECTION_CHANGED | Notify ID to parent window.
XTP_NC_DATEPICKERBEFOREGOMODAL | This is a notification ID that is used to indicate that the Date Picker is before run in modal mode (pop-up window), window has already created.
XTP_NC_DATEPICKERBUTTONCLICKED | This is a notification ID that is used to indicate mouse button clicks on a control.
XTP_NC_DATEPICKERGETDAYMETRICS | This notification is used to get day item metrics. Sender - CXTPDatePickerControl.
XTP_NC_DATEPICKERMONTHCHANGED | This is a notification ID that is used to indicate that the Date Picker is populated.
XTP_NC_DATEPICKERMOUSEMOVE | This is a notification ID that is used to indicate mouse move under a control.
XTP_NC_DATEPICKERSELECTIONCHANGED | This is a notification ID that is used to indicate that the selection has changed.
XTP_SELECTION_INFINITE | Infinite number of selected days.
XTP_WM_TIME_ZONE_CHANGED | Define windows message which send by CXTPTopLevelWndMsgNotifier when current timezone is changed.
XTP_WM_TIME_ZONE_CHANGED_MSG | Define name for XTP_WM_TIME_ZONE_CHANGED windows message.
xtp_wm_UserAction | A message identifier of the Calendar User Action custom message
XTPCALENDARCTRL_CF_EVENT |
XTPCALENDARCTRL_CLASSNAME | Custom class name for the Calendar control window
XTPCALENDARCTRL_USERACTION | String name of the calendar switch view custom message


cszCalendarMarkupPrm_Subject Variable

XTPCalendarDefines.h, Variables
cszCalendarMarkupPrm_Subject Variable

Markup template params

const LPCTSTR cszCalendarMarkupPrm_Subject = _T("/Calendar/Events/Event/Subject");
File

XTPCalendarDefines.h

Group

Variables


cszEventCustProp_CategoryIDs Variable

XTPCalendarDefines.h, Variables
cszEventCustProp_CategoryIDs Variable

String name of the corresponding property.

const LPCTSTR cszEventCustProp_CategoryIDs = _T("*xtp*Categories");
File

XTPCalendarDefines.h

Group

Variables


cszEventCustProp_IconsIDs Variable

XTPCalendarDefines.h, Variables
cszEventCustProp_IconsIDs Variable

String name of the corresponding property.

const LPCTSTR cszEventCustProp_IconsIDs = _T("*xtp*CustomIcons");
File

XTPCalendarDefines.h

Group

Variables


cszEventCustProp_MarkupTemplate Variable

XTPCalendarDefines.h, Variables
cszEventCustProp_MarkupTemplate Variable

String name of the MarkupTemplate property.

const LPCTSTR cszEventCustProp_MarkupTemplate = _T("xtpMarkupTemplate");
File

XTPCalendarDefines.h

Group

Variables


cszEventCustProp_NextReminderTime_Snoozed Variable

XTPCalendarDefines.h, Variables
cszEventCustProp_NextReminderTime_Snoozed Variable

String name of the corresponding property.

const LPCTSTR cszEventCustProp_NextReminderTime_Snoozed = _T("*xtp*NextReminderTime_Snoozed");
File

XTPCalendarDefines.h

Group

Variables


cszProcess_RecurrencePatternID Variable

XTPCalendarData.h, Variables
cszProcess_RecurrencePatternID Variable

String name for a corresponding property

const LPCTSTR cszProcess_RecurrencePatternID = _T("process_RecurrencePatternID");
File

XTPCalendarData.h

Group

Variables


cszProcess_RecurrenceState Variable

XTPCalendarData.h, Variables
cszProcess_RecurrenceState Variable

String name for a corresponding property

const LPCTSTR cszProcess_RecurrenceState = _T("process_RecurrenceState");
File

XTPCalendarData.h

Group

Variables


WM_XTP_CALENDAR_BASE Variable

XTPCalendarDefines.h, Variables, See Also
WM_XTP_CALENDAR_BASE Variable

The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use by private window classes, usually of the form WM_XTP_CALENDAR_BASE+X, where X is an integer value.

const UINT WM_XTP_CALENDAR_BASE = (WM_USER + 9600);
File

XTPCalendarDefines.h

See Also

WM_USER overview

Group

Variables


XTP_DATEPICKER_TIMER_INTERVAL Variable

XTPDatePickerControl.h, Variables
XTP_DATEPICKER_TIMER_INTERVAL Variable

Date picker timer interval.

const UINT XTP_DATEPICKER_TIMER_INTERVAL = 200;
File

XTPDatePickerControl.h

Group

Variables


XTP_DATEPICKER_TIMERID Variable

XTPDatePickerControl.h, Variables
XTP_DATEPICKER_TIMERID Variable

Date picker timer ID.

const UINT XTP_DATEPICKER_TIMERID = 255;
File

XTPDatePickerControl.h

Group

Variables


XTP_ID_CALENDAR_CONTROL Variable

XTPCalendarControlView.h, Variables
XTP_ID_CALENDAR_CONTROL Variable

Identifier of Calendar control child window of CXTPCalendarControlView.

const UINT XTP_ID_CALENDAR_CONTROL = 100;
File

XTPCalendarControlView.h

Group

Variables


XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL Variable

This notification is sent for each calendar day view cell before draw. You may customize clrBackgroundColor member of provided XTP_CALENDAR_DAYVIEWCELL_PARAMS structure. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL = (WM_XTP_CALENDAR_BASE + 37);
File

XTPCalendarNotifications.h

Remarks

Parameters wParam - [in] CXTPCalendarViewGroup* - A pointer to Group View. lParam - [in/out] XTP_CALENDAR_DAYVIEWCELL_PARAMS* - A pointer to cell parameters.

Group

Variables


XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT Variable

This notification is sent for calendar theme items before draw. You may customize corresponding theme part for each object in this message. Any object part changes which made in this notification handler will be discarded when object draw finished. This let you dynamically customize each calendar item.

Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT = (WM_XTP_CALENDAR_BASE + 38);
File

XTPCalendarNotifications.h

Remarks

This notification send only for theme objects defined in BeforeDrawFlags.

See Also

CXTPCalendarTheme::GetBeforeDrawFlags, CXTPCalendarTheme::SetBeforeDrawFlags Parameters wParam - [in] An object ID from XTPCalendarBeforeDrawThemeObject enum. lParam - [in] An additional parameter defined for each item in XTPCalendarBeforeDrawThemeObject.

Group

Variables


XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION Variable

This notification is sent to customize or disable specified editing operation. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION = (WM_XTP_CALENDAR_BASE + 19);
File

XTPCalendarNotifications.h

Remarks

This notification is sent only once before edit operation. The XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION notification is sent every time before this notification.

Parameters wParam - [in] A pointer to XTP_EVENT_EDIT_OPERATION_PARAMS structure or to derived structure depends on eOperation member value. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if specified editing operation is handled, otherwise FALSE. Initial value is FALSE.

See Also

XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED, XTPCalendarEditOperation, XTP_EVENT_EDIT_OPERATION_PARAMS, XTP_EVENT_PASTE_OPERATION_PARAMS, XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS

Group

Variables


XTP_NC_CALENDAR_DoCreate_Event Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoCreate_Event Variable

This notification is used as analog of overridable method CXTPCalendarData::DoCreate_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoCreate_Event = (WM_XTP_CALENDAR_BASE + 27);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer as XTP_CALENDAR_WPARAM2* where : wParam1 - [in] A pointer to calendar event object as CXTPCalendarEvent*; wParam2 - [out] A pointer to newly created event ID as DWORD*; lParam - [out] A pointer to result of operation as BOOL*;

See Also

CXTPCalendarCustomDataProvider::DoCreate_Event

Group

Variables


XTP_NC_CALENDAR_DoCreate_RPattern Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoCreate_RPattern Variable

This notification is used as analog of overridable method CXTPCalendarData::DoCreate_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoCreate_RPattern = (WM_XTP_CALENDAR_BASE + 30);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer as XTP_CALENDAR_WPARAM2* where : wParam1 - [in] A pointer to recurrence pattern object as CXTPCalendarRecurrencePattern*; wParam2 - [out] A pointer to newly created recurrence pattern ID as DWORD*; lParam - [out] A pointer to result of operation as BOOL*;

See Also

CXTPCalendarCustomDataProvider::DoCreate_RPattern

Group

Variables


XTP_NC_CALENDAR_DoDelete_Event Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoDelete_Event Variable

This notification is used as analog of overridable method CXTPCalendarData::DoDelete_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoDelete_Event = (WM_XTP_CALENDAR_BASE + 29);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer to calendar event object as CXTPCalendarEvent*; lParam - [out] A pointer to result of operation as BOOL*;

See Also

CXTPCalendarCustomDataProvider::DoDelete_Event

Group

Variables


XTP_NC_CALENDAR_DoDelete_RPattern Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoDelete_RPattern Variable

This notification is used as analog of overridable method CXTPCalendarData::DoDelete_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoDelete_RPattern = (WM_XTP_CALENDAR_BASE + 32);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer to recurrence pattern object as CXTPCalendarRecurrencePattern*; lParam - [out] A pointer to result of operation as BOOL*;

See Also

CXTPCalendarCustomDataProvider::DoDelete_RPattern

Group

Variables


XTP_NC_CALENDAR_DoGetAllEvents_raw Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoGetAllEvents_raw Variable

This notification is used as analog of overridable method CXTPCalendarData::DoGetAllEvents_raw. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoGetAllEvents_raw = (WM_XTP_CALENDAR_BASE + 33);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - Unused (=0); lParam - [in/out] A pointer to pointer to events array as CXTPCalendarEventsPtr*;

See Also

CXTPCalendarCustomDataProvider::DoGetAllEvents_raw

Group

Variables


XTP_NC_CALENDAR_DoGetUpcomingEvents Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoGetUpcomingEvents Variable

This notification is used as analog of overridable method CXTPCalendarData::DoGetUpcomingEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoGetUpcomingEvents = (WM_XTP_CALENDAR_BASE + 34);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer as XTP_CALENDAR_WPARAM2* where : wParam1 - [in] As COleDateTime*; Start date and time of a specified period; wParam2 - [in] As COleDateTimeSpan*; A duration of a specified period; lParam - [in/out] A pointer to pointer to events array as CXTPCalendarEventsPtr*;

See Also

CXTPCalendarCustomDataProvider::DoGetUpcomingEvents

Group

Variables


XTP_NC_CALENDAR_DoRead_Event Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoRead_Event Variable

This notification is used as analog of overridable method CXTPCalendarData::DoRead_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRead_Event = (WM_XTP_CALENDAR_BASE + 25);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] An event ID to read as DWORD; lParam - [in/out] A pointer to pointer to event as CXTPCalendarEventPtr*;

See Also

CXTPCalendarCustomDataProvider::DoRead_Event

Group

Variables


XTP_NC_CALENDAR_DoRead_RPattern Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoRead_RPattern Variable

This notification is used as analog of overridable method CXTPCalendarData::DoRead_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRead_RPattern = (WM_XTP_CALENDAR_BASE + 26);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] An recurrence pattern ID to read as DWORD; lParam - [in/out] A pointer to pointer to recurrence pattern as CXTPCalendarRecurrencePatternPtr*;

See Also

CXTPCalendarCustomDataProvider::DoRead_RPattern

Group

Variables


XTP_NC_CALENDAR_DoRemoveAllEvents Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoRemoveAllEvents Variable

This notification is used as analog of overridable method CXTPCalendarData::DoRemoveAllEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRemoveAllEvents = (WM_XTP_CALENDAR_BASE + 24);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications.

See Also

CXTPCalendarCustomDataProvider::DoRemoveAllEvents

Group

Variables


XTP_NC_CALENDAR_DoRetrieveDayEvents Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoRetrieveDayEvents Variable

This notification is used as analog of overridable method CXTPCalendarData::DoRetrieveDayEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRetrieveDayEvents = (WM_XTP_CALENDAR_BASE + 23);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A day date as XTP_DATE_VALUE; lParam - [in/out] A pointer to pointer to events array as CXTPCalendarEventsPtr*;

See Also

CXTPCalendarCustomDataProvider::DoRetrieveDayEvents

Group

Variables


XTP_NC_CALENDAR_DoUpdate_Event Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoUpdate_Event Variable

This notification is used as analog of overridable method CXTPCalendarData::DoUpdate_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoUpdate_Event = (WM_XTP_CALENDAR_BASE + 28);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer to calendar event object as CXTPCalendarEvent*; lParam - [out] A pointer to result of operation as BOOL*;

See Also

CXTPCalendarCustomDataProvider::DoUpdate_Event

Group

Variables


XTP_NC_CALENDAR_DoUpdate_RPattern Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_DoUpdate_RPattern Variable

This notification is used as analog of overridable method CXTPCalendarData::DoUpdate_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoUpdate_RPattern = (WM_XTP_CALENDAR_BASE + 31);
File

XTPCalendarNotifications.h

Remarks

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer to recurrence pattern object as CXTPCalendarRecurrencePattern*; lParam - [out] A pointer to result of operation as BOOL*;

See Also

CXTPCalendarCustomDataProvider::DoUpdate_RPattern

Group

Variables


XTP_NC_CALENDAR_GETGROPVIEWCAPTION Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_GETGROPVIEWCAPTION Variable

This notification is sent when selection is changed. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_GETGROPVIEWCAPTION = (WM_XTP_CALENDAR_BASE + 35);
File

XTPCalendarNotifications.h

Remarks

Parameters wParam - [in] CXTPCalendarViewGroup* - A pointer to Group View. lParam - [in/out] CString* pointer to caption string.

See Also

CXTPCalendarViewGroup::GetCaption

Group

Variables


XTP_NC_CALENDAR_GETITEMTEXT Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_GETITEMTEXT Variable

This notification is sent for calendar items which defines in AskItemTextFlags property.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_GETITEMTEXT = (WM_XTP_CALENDAR_BASE + 39);
File

XTPCalendarNotifications.h

Remarks

Parameters wParam - [in/out] XTP_CALENDAR_GETITEMTEXT_PARAMS*. lParam - 0.

See Also

XTPCalendarGetItemTextEx, XTP_CALENDAR_GETITEMTEXT_PARAMS, CXTPCalendarControl::GetAskItemTextFlags, CXTPCalendarControlPaintManager::GetAskItemTextFlags, CXTPCalendarControlPaintManager::SetAskItemTextFlags, CXTPCalendarTheme::GetAskItemTextFlags, CXTPCalendarTheme::SetAskItemTextFlags

Group

Variables


XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED Variable

This notification is sent to determine is specified editing operation disabled. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED = (WM_XTP_CALENDAR_BASE + 18);
File

XTPCalendarNotifications.h

Remarks

This notification may be sent several times before edit operation to update user interface state in the right way (set corresponding mouse cursor for example). The XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION notification is sent only once before edit operation.

Parameters wParam - [in] A pointer to XTP_EVENT_EDIT_OPERATION_PARAMS structure or to derived structure depends on eOperation member value. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if to disable specified editing operation, otherwise FALSE. Initial value is FALSE.

See Also

XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION, XTPCalendarEditOperation, XTP_EVENT_EDIT_OPERATION_PARAMS, XTP_EVENT_PASTE_OPERATION_PARAMS, XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS

Group

Variables


XTP_NC_CALENDAR_ON_REMINDERS Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDAR_ON_REMINDERS Variable

On RButtonUp event. Sender - CXTPCalendarRemindersManager

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_ON_REMINDERS = (WM_XTP_CALENDAR_BASE + 22);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = XTPCalendarRemindersAction, lParam = 0 or CXTPCalendarReminder*. See XTPCalendarRemindersAction.

Group

Variables


XTP_NC_CALENDAR_PREPOPULATE Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_PREPOPULATE Variable

This notification is sent when calendar is populating. lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection.

Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_PREPOPULATE = (WM_XTP_CALENDAR_BASE + 36);
File

XTPCalendarNotifications.h

Remarks

Parameters wParam - [in] CXTPCalendarViewGroup* - A pointer to Group View. lParam - [in/out] CXTPCalendarEvents* - A pointer to events array to draw.

See Also

CXTPCalendarControl::Populate, XTP_NC_CALENDAR_PREPOPULATE_DAY.

Group

Variables


XTP_NC_CALENDAR_PREPOPULATE_DAY Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_PREPOPULATE_DAY Variable

This notification is sent when calendar is populating. lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection.

Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_PREPOPULATE_DAY = (WM_XTP_CALENDAR_BASE + 41);
File

XTPCalendarNotifications.h

Remarks

Parameters wParam - [in] CXTPCalendarViewDay* - A pointer to View Day. lParam - unused.

See Also

CXTPCalendarControl::Populate, XTP_NC_CALENDAR_PREPOPULATE

Group

Variables


XTP_NC_CALENDAR_SELECTION_CHANGED Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_SELECTION_CHANGED Variable

This notification is sent when selection is changed. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_SELECTION_CHANGED = (WM_XTP_CALENDAR_BASE + 20);
File

XTPCalendarNotifications.h

Remarks

Parameters wParam - [in] A value from XTPCalendarSelectionChanged enum. lParam - unused

See Also

XTPCalendarSelectionChanged

Group

Variables


XTP_NC_CALENDAR_THEME_CHANGED Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_THEME_CHANGED Variable

This notification is sent when calendar paint theme changed. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_THEME_CHANGED = (WM_XTP_CALENDAR_BASE + 42);
File

XTPCalendarNotifications.h

Remarks

Parameters wParam - unused. lParam - unused.

See Also

XTP_NC_CALENDARVIEWWASCHANGED

Group

Variables


XTP_NC_CALENDAR_USERACTION Variable

XTPCalendarNotifications.h, Variables, See Also
XTP_NC_CALENDAR_USERACTION Variable

This notification send for when user action defined in XTPCalendarUserAction enum happened. Parameters wParam - [in] A pointer to XTP_CALENDAR_USERACTION_PARAMS structure. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if specified action is handled (to Cancel default processing) , otherwise FALSE. Initial value is FALSE.

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_USERACTION = (WM_XTP_CALENDAR_BASE + 40);
File

XTPCalendarNotifications.h

See Also

XTP_CALENDAR_USERACTION_PARAMS, XTPCalendarUserAction

Group

Variables


XTP_NC_CALENDARCONTEXTMENU Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARCONTEXTMENU Variable

A Context Menu should be displayed for the Calendar Control. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARCONTEXTMENU = (WM_XTP_CALENDAR_BASE + 8);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 'Clicked Point', lParam = 0

Group

Variables


XTP_NC_CALENDARDATAPROVIDERWASCHANGED Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARDATAPROVIDERWASCHANGED Variable

Calendar Control data provider (resources) where changed. SetDataProvider() or SetResources() methods where called. Sender - CXTPCalendarControl, CXTPCalendarView.

const XTP_NOTIFY_CODE XTP_NC_CALENDARDATAPROVIDERWASCHANGED = (WM_XTP_CALENDAR_BASE + 17);
const XTP_NOTIFY_CODE XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED = XTP_NC_CALENDARDATAPROVIDERWASCHANGED;
File

XTPCalendarNotifications.h

Remarks

Parameters wParam = 0 if Calendar control resources where changed, 1 when CalendarView resources where changed. 2 when CalendarViewDay resources where changed. lParam = NULL if wParam == 0, CXTPCalendarView* if wParam == 1, CXTPCalendarViewDay* if wParam == 2.

Group

Variables


XTP_NC_CALENDAREVENTWASADDED Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDAREVENTWASADDED Variable

New event has just been added to the data provider. Sender - CXTPCalendarData, CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASADDED = (WM_XTP_CALENDAR_BASE + 1);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = EventID, lParam = CXTPCalendarEvent*

Group

Variables


XTP_NC_CALENDAREVENTWASCHANGED Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDAREVENTWASCHANGED Variable

Event has just been changed in the data provider. Sender - CXTPCalendarData, CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASCHANGED = (WM_XTP_CALENDAR_BASE + 3);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = EventID, lParam = CXTPCalendarEvent*

Group

Variables


XTP_NC_CALENDAREVENTWASDELETED Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDAREVENTWASDELETED Variable

Event has just been deleted from the data provider. Sender - CXTPCalendarData, CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASDELETED = (WM_XTP_CALENDAR_BASE + 2);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = EventID, lParam = CXTPCalendarEvent*

Group

Variables


XTP_NC_CALENDARKEYDOWN Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARKEYDOWN Variable

On KeyDown event. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARKEYDOWN = (WM_XTP_CALENDAR_BASE + 13);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 'key was pressed', lParam = 0

Group

Variables


XTP_NC_CALENDARLBUTTONDBLCLICK Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARLBUTTONDBLCLICK Variable

On LButtonDblClick event. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONDBLCLICK = (WM_XTP_CALENDAR_BASE + 10);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 'Clicked Point', lParam = 0

Group

Variables


XTP_NC_CALENDARLBUTTONDOWN Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARLBUTTONDOWN Variable

On LButtonDown event. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONDOWN = (WM_XTP_CALENDAR_BASE + 9);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 'Clicked Point', lParam = 0

Group

Variables


XTP_NC_CALENDARLBUTTONUP Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARLBUTTONUP Variable

On LButtonUp event. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONUP = (WM_XTP_CALENDAR_BASE + 11);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 'Clicked Point', lParam = 0

Group

Variables


XTP_NC_CALENDARMOUSEMOVE Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARMOUSEMOVE Variable

On MouseMove event. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARMOUSEMOVE = (WM_XTP_CALENDAR_BASE + 12);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 'Clicked Point', lParam = 0

Group

Variables


XTP_NC_CALENDAROPTIONSWASCHANGED Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDAROPTIONSWASCHANGED Variable

Calendar Control options was changed. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDAROPTIONSWASCHANGED = (WM_XTP_CALENDAR_BASE + 16);
File

XTPCalendarNotifications.h

Remarks

Parameters wParam = -1 or XTPCalendarViewType enum value. Specify global option (-1) or which kind of view changed option is related. lParam = 0

Group

Variables


XTP_NC_CALENDARRBUTTONDOWN Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARRBUTTONDOWN Variable

On RButtonDown event. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARRBUTTONDOWN = (WM_XTP_CALENDAR_BASE + 14);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 'Clicked Point', lParam = 0

Group

Variables


XTP_NC_CALENDARRBUTTONUP Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARRBUTTONUP Variable

On RButtonUp event. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARRBUTTONUP = (WM_XTP_CALENDAR_BASE + 21);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 'Clicked Point', lParam = 0

Group

Variables


XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED Variable

Calendar Control Day view time scale was changed. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED = (WM_XTP_CALENDAR_BASE + 15);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 0, lParam = 0

Group

Variables


XTP_NC_CALENDARVIEWWASCHANGED Variable

XTPCalendarNotifications.h, Variables
XTP_NC_CALENDARVIEWWASCHANGED Variable

Current Calendar Control view type(day, week, ...) or content was changed. Sender - CXTPCalendarControl

const XTP_NOTIFY_CODE XTP_NC_CALENDARVIEWWASCHANGED = (WM_XTP_CALENDAR_BASE + 7);
File

XTPCalendarNotifications.h

Remarks

Parameters - wParam = 0, lParam = 0

Group

Variables


XTP_NC_DATEPICKER_BUTTON_CLICK Variable

XTPDatePickerControl.h, Variables
XTP_NC_DATEPICKER_BUTTON_CLICK Variable

Notify ID to parent window.

const UINT XTP_NC_DATEPICKER_BUTTON_CLICK = (NM_FIRST - 50);
File

XTPDatePickerControl.h

Group

Variables


XTP_NC_DATEPICKER_SELECTION_CHANGED Variable

XTPDatePickerControl.h, Variables
XTP_NC_DATEPICKER_SELECTION_CHANGED Variable

Notify ID to parent window.

const UINT XTP_NC_DATEPICKER_SELECTION_CHANGED = (NM_FIRST - 51);
File

XTPDatePickerControl.h

Group

Variables


XTP_NC_DATEPICKERBEFOREGOMODAL Variable

XTPDatePickerNotifications.h, Variables, Example, See Also
XTP_NC_DATEPICKERBEFOREGOMODAL Variable

This is a notification ID that is used to indicate that the Date Picker is before run in modal mode (pop-up window), window has already created.

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERBEFOREGOMODAL = (WM_XTP_CALENDAR_BASE + 82);
File

XTPDatePickerNotifications.h

Remarks

There are two DWORD parameters that are reserved for user defined purposes.

See Also

DECLARE_XTPSINK;

Example
// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERBEFOREGOMODAL, &CXTPCalendarController::OnEvent_DatePicker);

// Somewhere in your program in a function that is used to capture mouse click events.
// Send an XTP_NC_DATEPICKERSELECTIONCHANGED notification message.

SendNotification(XTP_NC_DATEPICKERBEFOREGOMODAL);
Group

Variables


XTP_NC_DATEPICKERBUTTONCLICKED Variable

XTPDatePickerNotifications.h, Variables, Example, See Also
XTP_NC_DATEPICKERBUTTONCLICKED Variable

This is a notification ID that is used to indicate mouse button clicks on a control.

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERBUTTONCLICKED = (WM_XTP_CALENDAR_BASE + 80);
File

XTPDatePickerNotifications.h

Remarks

There are two DWORD parameters that are reserved for user defined purposes. An example is to use the first user defined parameter as a button ID. wParam = ButtonID, lParam = 0; The second parameter is not used. This example is useful for sending notifications when a button is clicked.

See Also

DECLARE_XTPSINK

Example
// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

// m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERBUTTONCLICKED, &CXTPCalendarController::OnEvent_DatePicker);

// Somewhere in your program in a function that is used to capture mouse click events.
// Send an XTP_NC_DATEPICKERBUTTONCLICKED notification message with
// the accompanying button ID as a parameter.

XTP_NC_DATEPICKER_BUTTON nm; // Structure used to send notification messages.
nm.nID = nID;                // Get the ID of the button.

SendNotification(XTP_NC_DATEPICKERBUTTONCLICKED, nID);
Group

Variables


XTP_NC_DATEPICKERGETDAYMETRICS Variable

XTPDatePickerNotifications.h, Variables, See Also
XTP_NC_DATEPICKERGETDAYMETRICS Variable

This notification is used to get day item metrics. Sender - CXTPDatePickerControl.

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERGETDAYMETRICS = (WM_XTP_CALENDAR_BASE + 85);
File

XTPDatePickerNotifications.h

Remarks

It is sent before a CallBack function call. Parameters wParam - [in] A day date as XTP_DATE_VALUE; lParam - [in/out] A pointer to day metrics as XTP_DAYITEM_METRICS*.

See Also

CXTPDatePickerControl::GetDayMetrics, CXTPDatePickerControl::SetCallbackDayMetrics.

Group

Variables


XTP_NC_DATEPICKERMONTHCHANGED Variable

XTPDatePickerNotifications.h, Variables, Example, See Also
XTP_NC_DATEPICKERMONTHCHANGED Variable

This is a notification ID that is used to indicate that the Date Picker is populated.

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERMONTHCHANGED = (WM_XTP_CALENDAR_BASE + 84);
File

XTPDatePickerNotifications.h

Remarks

Date picker is populating when months scrolled, month count changed, or some other properties and settings where changed.

See Also

DECLARE_XTPSINK;

Example
// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERMONTHCHANGED, &CXTPCalendarController::OnEvent_DatePicker);
Group

Variables


XTP_NC_DATEPICKERMOUSEMOVE Variable

XTPDatePickerNotifications.h, Variables, Example, See Also
XTP_NC_DATEPICKERMOUSEMOVE Variable

This is a notification ID that is used to indicate mouse move under a control.

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERMOUSEMOVE = (WM_XTP_CALENDAR_BASE + 83);
File

XTPDatePickerNotifications.h

Remarks

There are two DWORD parameters that are reserved for user defined purposes. An example is to use the first user parameters as traced coordinates. wParam = x, lParam = y; The second parameter is not used. This example is useful for sending notifications when a button is clicked.

See Also

DECLARE_XTPSINK

Example
// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

// m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERMOUSEMOVE, &CXTPCalendarController::OnEvent_DatePicker);

// Somewhere in your program in a function that is used to capture mouse move events.
// Send an XTP_NC_DATEPICKERMOUSEMOVE notification message with
// the accompanying mouse coordinates as parameters.
Group

Variables


XTP_NC_DATEPICKERSELECTIONCHANGED Variable

XTPDatePickerNotifications.h, Variables, Example, See Also
XTP_NC_DATEPICKERSELECTIONCHANGED Variable

This is a notification ID that is used to indicate that the selection has changed.

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERSELECTIONCHANGED = (WM_XTP_CALENDAR_BASE + 81);
File

XTPDatePickerNotifications.h

Remarks

There are two DWORD parameters that are reserved for user defined purposes.

See Also

DECLARE_XTPSINK

Example
// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERSELECTIONCHANGED, &CXTPCalendarController::OnEvent_DatePicker);

// Somewhere in your program in a function that is used to capture mouse click events.
// Send an XTP_NC_DATEPICKERSELECTIONCHANGED notification message.

SendNotification(XTP_NC_DATEPICKERSELECTIONCHANGED);
Group

Variables


XTP_SELECTION_INFINITE Variable

XTPDatePickerControl.h, Variables
XTP_SELECTION_INFINITE Variable

Infinite number of selected days.

const UINT XTP_SELECTION_INFINITE = (UINT)-1;
File

XTPDatePickerControl.h

Group

Variables


XTP_WM_TIME_ZONE_CHANGED Variable

XTPTopLevelWndMsgNotifier.h, Variables
XTP_WM_TIME_ZONE_CHANGED Variable

Define windows message which send by CXTPTopLevelWndMsgNotifier when current timezone is changed.

const UINT XTP_WM_TIME_ZONE_CHANGED = RegisterWindowMessage(XTP_WM_TIME_ZONE_CHANGED_MSG);
File

XTPTopLevelWndMsgNotifier.h

Group

Variables


XTP_WM_TIME_ZONE_CHANGED_MSG Variable

XTPTopLevelWndMsgNotifier.h, Variables
XTP_WM_TIME_ZONE_CHANGED_MSG Variable

Define name for XTP_WM_TIME_ZONE_CHANGED windows message.

LPCTSTR XTP_WM_TIME_ZONE_CHANGED_MSG = _T("XTP_WM_TimeZoneChanged");
File

XTPTopLevelWndMsgNotifier.h

Group

Variables


xtp_wm_UserAction Variable

XTPCalendarDefines.h, Variables
xtp_wm_UserAction Variable

A message identifier of the Calendar User Action custom message

const UINT xtp_wm_UserAction = RegisterWindowMessage( XTPCALENDARCTRL_USERACTION );
File

XTPCalendarDefines.h

Group

Variables


XTPCALENDARCTRL_CF_EVENT Variable

XTPCalendarView.h, Variables
XTPCALENDARCTRL_CF_EVENT Variable
const LPCTSTR XTPCALENDARCTRL_CF_EVENT = _T("XTPCalendar_CF_Event");
File

XTPCalendarView.h

Remarks

Calendar events clipboard format name.

Group

Variables


XTPCALENDARCTRL_CLASSNAME Variable

XTPCalendarDefines.h, Variables
XTPCALENDARCTRL_CLASSNAME Variable

Custom class name for the Calendar control window

const LPCTSTR XTPCALENDARCTRL_CLASSNAME = _T("XTPCalendar");
File

XTPCalendarDefines.h

Group

Variables


XTPCALENDARCTRL_USERACTION Variable

XTPCalendarDefines.h, Variables
XTPCALENDARCTRL_USERACTION Variable

String name of the calendar switch view custom message

const LPCTSTR XTPCALENDARCTRL_USERACTION = _T("XTPCalendarUserAction");
File

XTPCalendarDefines.h

Group

Variables


Macros

Macros, Calendar
Macros
Macros
Macro | Description
BEGIN_VIEW_PART | This helper macro is used to declare paint manager drawing parts. theClass - Part name. parentClass - Parent part name. There are two paint manager methods available to access declared part object: CPartName* GetPartName(); void SetPartName(CPartName* pPart); Where PartName is the name of the declared part.
END_VIEW_PART | This helper macro is used to declare paint manager drawing parts. theClass - Part name.
XTP_CALENDAR_DEFAULT_LABEL_ID | Define event label ID which is used by default for a new event. (Valid for default labels list only)
XTP_CALENDAR_DEFAULT_REMINDER_MINUTES | Define default reminders value minutes which is for a new event.
XTP_CALENDAR_DISABLED_COLOR_DARK | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_CALENDAR_DISABLED_COLOR_LIGHT | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX | Define maximum text length for calendar event subject, location or body which will be drawn on the screen. Used to optimize drawing performance.
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX | Define maximum count of weeks which can be shown in the Month View.
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN | Define minimum count of weeks which can be shown in the Month View.
XTP_CALENDAR_NONE_LABEL_ID | Define event label ID which signifies no label. (Valid for default labels list only)
XTP_CALENDAR_OFFICE2007_FONT_NAME | The font name for Office 2007 theme
XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS | Timeout before appearing event tool tip window.
XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS | Timeout before appearing event tool tip window.
XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS |
XTP_CALENDAR_TIMEZONESKEY_9X | The location in the registry that contains time zone information for Windows 9x family.
XTP_CALENDAR_TIMEZONESKEY_NT | The location in the registry that contains time zone information for Windows NT family (NT/2000/XP).
XTP_CALENDAR_TZIRegValName_DATA | Registry key name for some TIME_ZONE_INFORMATION structure members.
XTP_CALENDAR_TZIRegValName_DaylightName | Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_DaylightNameW | Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_DisplayStr | Registry key name for a time zone display string value. For example: "(GMT+02:00) Athens, Beirut, Istanbul, Minsk"
XTP_CALENDAR_TZIRegValName_Index | Registry key name for a time zone order index value.
XTP_CALENDAR_TZIRegValName_StandardName | Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_StandardNameW | Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_UNKNOWN_EVENT_ID | Define unknown event ID.
XTP_CALENDAR_UNKNOWN_LABEL_ID | Define unknown event label ID.
XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID | Define an unknown recurrence pattern ID.
XTP_CALENDAR_UNKNOWN_SCHEDULE_ID | Define unknown schedule ID.
XTP_EVENTS_STORAGE_HASH_TABLE_SIZE | Define events storage hash table size. Should be a prime number! like: 503, 1021, 1511, 2003, 3001, 4001, 5003, 6007, 8009, 12007, 16001, 32003, 48017, 64007
XTP_HALF_SECOND |
XTP_OBJECT_CACHE_HASH_TABLE_SIZE | Cache table size.
Module

Calendar


BEGIN_VIEW_PART Macro

XTPCalendarPaintManager.h, Macros, Example, See Also
BEGIN_VIEW_PART Macro

This helper macro is used to declare paint manager drawing parts. theClass - Part name. parentClass - Parent part name. There are two paint manager methods available to access declared part object: CPartName* GetPartName(); void SetPartName(CPartName* pPart); Where PartName is the name of the declared part.

#define BEGIN_VIEW_PART(theClass, parentClass)
File

XTPCalendarPaintManager.h

See Also

END_VIEW_PART, CXTPCalendarPaintManager

Example
declaration in the paint manager class
BEGIN_VIEW_PART(PartClass1, ParentPartClass1)
...
END_VIEW_PART(PartClass1)

// in the implementation
CPaintManagerClassName::CPartClass1* pPart1 = pPainManObj->GetPartClass1();
Group

Macros


END_VIEW_PART Macro

XTPCalendarPaintManager.h, Macros, See Also
END_VIEW_PART Macro

This helper macro is used to declare paint manager drawing parts. theClass - Part name.

#define END_VIEW_PART(theClass)
File

XTPCalendarPaintManager.h

See Also

BEGIN_VIEW_PART, CXTPCalendarPaintManager

Group

Macros


XTP_CALENDAR_DEFAULT_LABEL_ID Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_DEFAULT_LABEL_ID Macro

Define event label ID which is used by default for a new event. (Valid for default labels list only)

#define XTP_CALENDAR_DEFAULT_LABEL_ID 0
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_DEFAULT_REMINDER_MINUTES Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_DEFAULT_REMINDER_MINUTES Macro

Define default reminders value minutes which is for a new event.

#define XTP_CALENDAR_DEFAULT_REMINDER_MINUTES 15
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_DISABLED_COLOR_LIGHT Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_DISABLED_COLOR_LIGHT Macro

Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.

#define XTP_EDIT_DISABLED_COLOR_DARK RGB(128, 128, 128) //<COMBINE XTP_CALENDAR_DISABLED_COLOR_LIGHT>
#define XTP_CALENDAR_DISABLED_COLOR_LIGHT RGB(250, 250, 250)
#define XTP_CALENDAR_DISABLED_COLOR_DARK RGB(128, 128, 128) //<COMBINE XTP_CALENDAR_DISABLED_COLOR_LIGHT>
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX Macro

Define maximum text length for calendar event subject, location or body which will be drawn on the screen. Used to optimize drawing performance.

#define XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX 255
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX Macro

XTPCalendarMonthView.h, Macros, See Also
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX Macro

Define maximum count of weeks which can be shown in the Month View.

#define XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX 6
File

XTPCalendarMonthView.h

See Also

CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount, CXTPCalendarMonthView::CMonthViewGrid::SetWeeksCount, XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN

Group

Macros


XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN Macro

XTPCalendarMonthView.h, Macros, See Also
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN Macro

Define minimum count of weeks which can be shown in the Month View.

#define XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN 2
File

XTPCalendarMonthView.h

See Also

CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount, CXTPCalendarMonthView::CMonthViewGrid::SetWeeksCount, XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX

Group

Macros


XTP_CALENDAR_NONE_LABEL_ID Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_NONE_LABEL_ID Macro

Define event label ID which signifies no label. (Valid for default labels list only)

#define XTP_CALENDAR_NONE_LABEL_ID 0
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_OFFICE2007_FONT_NAME Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_OFFICE2007_FONT_NAME Macro

The font name for Office 2007 theme

#define XTP_CALENDAR_OFFICE2007_FONT_NAME _T("Segoe UI")
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS Macro

Timeout before appearing event tool tip window.

#define XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS 400
#define XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS 1400 //<COMBINE XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS>
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS Macro

XTPCalendarView.h, Macros
XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS Macro
#define XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS 400
File

XTPCalendarView.h

Remarks

Timeout before appearing in the event subject editor window.

Group

Macros


XTP_CALENDAR_TIMEZONESKEY_9X Macro

XTPCalendarDefines.h, Macros, See Also
XTP_CALENDAR_TIMEZONESKEY_9X Macro

The location in the registry that contains time zone information for Windows 9x family.

#define XTP_CALENDAR_TIMEZONESKEY_9X _T("SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Time Zones")
File

XTPCalendarDefines.h

See Also

Microsoft KB221542

Group

Macros


XTP_CALENDAR_TIMEZONESKEY_NT Macro

XTPCalendarDefines.h, Macros, See Also
XTP_CALENDAR_TIMEZONESKEY_NT Macro

The location in the registry that contains time zone information for Windows NT family (NT/2000/XP).

#define XTP_CALENDAR_TIMEZONESKEY_NT _T("SOFTWARE\\Microsoft\\Windows NT\\CurrentVersion\\Time Zones")
File

XTPCalendarDefines.h

See Also

Microsoft KB221542

Group

Macros


XTP_CALENDAR_TZIRegValName_DATA Macro

XTPCalendarDefines.h, Macros, See Also
XTP_CALENDAR_TZIRegValName_DATA Macro

Registry key name for some TIME_ZONE_INFORMATION structure members.

#define XTP_CALENDAR_TZIRegValName_DATA _T("TZI")
File

XTPCalendarDefines.h

See Also

Microsoft KB115231, CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION

Group

Macros


XTP_CALENDAR_TZIRegValName_DaylightName Macro

XTPCalendarDefines.h, Macros, See Also
XTP_CALENDAR_TZIRegValName_DaylightName Macro

Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.

#define XTP_CALENDAR_TZIRegValName_DaylightName _T("Dlt")
#define XTP_CALENDAR_TZIRegValName_DaylightNameW L"Dlt"
File

XTPCalendarDefines.h

See Also

TIME_ZONE_INFORMATION WinAPI structure

Group

Macros


XTP_CALENDAR_TZIRegValName_DisplayStr Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_TZIRegValName_DisplayStr Macro

Registry key name for a time zone display string value. For example: "(GMT+02:00) Athens, Beirut, Istanbul, Minsk"

#define XTP_CALENDAR_TZIRegValName_DisplayStr _T("Display")
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_TZIRegValName_Index Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_TZIRegValName_Index Macro

Registry key name for a time zone order index value.

#define XTP_CALENDAR_TZIRegValName_Index _T("Index")
File

XTPCalendarDefines.h

Remarks

This index value is used to sort time zones in the right order.

Group

Macros


XTP_CALENDAR_TZIRegValName_StandardName Macro

XTPCalendarDefines.h, Macros, See Also
XTP_CALENDAR_TZIRegValName_StandardName Macro

Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.

#define XTP_CALENDAR_TZIRegValName_StandardName _T("Std")
#define XTP_CALENDAR_TZIRegValName_StandardNameW L"Std"
File

XTPCalendarDefines.h

See Also

TIME_ZONE_INFORMATION WinAPI structure

Group

Macros


XTP_CALENDAR_UNKNOWN_EVENT_ID Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_UNKNOWN_EVENT_ID Macro

Define unknown event ID.

#define XTP_CALENDAR_UNKNOWN_EVENT_ID 0
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_UNKNOWN_LABEL_ID Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_UNKNOWN_LABEL_ID Macro

Define unknown event label ID.

#define XTP_CALENDAR_UNKNOWN_LABEL_ID -1
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID Macro

Define an unknown recurrence pattern ID.

#define XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID 0
File

XTPCalendarDefines.h

Group

Macros


XTP_CALENDAR_UNKNOWN_SCHEDULE_ID Macro

XTPCalendarDefines.h, Macros
XTP_CALENDAR_UNKNOWN_SCHEDULE_ID Macro

Define unknown schedule ID.

#define XTP_CALENDAR_UNKNOWN_SCHEDULE_ID 0
File

XTPCalendarDefines.h

Group

Macros


XTP_EVENTS_STORAGE_HASH_TABLE_SIZE Macro

XTPCalendarMemoryDataProvider.h, Macros, See Also
XTP_EVENTS_STORAGE_HASH_TABLE_SIZE Macro

Define events storage hash table size. Should be a prime number! like: 503, 1021, 1511, 2003, 3001, 4001, 5003, 6007, 8009, 12007, 16001, 32003, 48017, 64007

#define XTP_EVENTS_STORAGE_HASH_TABLE_SIZE 4001
File

XTPCalendarMemoryDataProvider.h

See Also

CXTPCalendarData::EventsMapByID_T overview, CMap overview

Group

Macros


XTP_HALF_SECOND Macro

XTPCalendarUtils.h, Macros, See Also
XTP_HALF_SECOND Macro
#define XTP_HALF_SECOND (1.0/172800.0)
File

XTPCalendarUtils.h

Remarks

Half a second, expressed in days.

See Also

COleDateTime overview.

Group

Macros


XTP_OBJECT_CACHE_HASH_TABLE_SIZE Macro

XTPCalendarData.h, Macros
XTP_OBJECT_CACHE_HASH_TABLE_SIZE Macro

Cache table size.

#define XTP_OBJECT_CACHE_HASH_TABLE_SIZE 1021
File

XTPCalendarData.h

Remarks

Should be a prime number! like: 503, 1021, 1511, 2003, 3001, 4001, 5003, 6007, 8009, 12007, 16001, 32003, 48017, 64007

Group

Macros


Files

Files, Calendar
Files
Files
File | Description
XTPCalendarControl.h | XTPCalendarControl.h: interface for the CXTPCalendarControl class.
XTPCalendarController.h | XTPCalendarController.h: interface for the CXTPCalendarController class.
XTPCalendarControlView.h | XTPCalendarControlView.h: interface for the CXTPCalendarControlView class.
XTPCalendarCustomDataProvider.h | XTPCalendarCustomDataProvider.h: interface for the CXTPCalendarCustomProperties class.
XTPCalendarCustomProperties.h | XTPCalendarCustomProperties.h: interface for the CXTPCalendarCustomProperties class.
XTPCalendarData.h | XTPCalendarData.h: interface for the CXTPCalendarData class.
XTPCalendarDatabaseDataProvider.h | XTPCalendarDatabaseDataProvider.h: interface for the CXTPCalendarDatabaseDataProvider class.
XTPCalendarDayView.h | XTPCalendarDayView.h: interface for the CXTPCalendarDayView class.
XTPCalendarDayViewDay.h | XTPCalendarDayViewDay.h: interface for the CXTPCalendarDayViewDay class.
XTPCalendarDayViewEvent.h | XTPCalendarDayViewEvent.h: interface for the CXTPCalendarDayViewEvent class.
XTPCalendarDayViewTimeScale.h | XTPCalendarDayViewTimeScale.h: interface for the CXTPCalendarDayViewTimeScale class.
XTPCalendarDefines.h | XTPCalendarDefines.h: interface for the CXTPCalendarEvent class.
XTPCalendarEvent.h | XTPCalendarEvent.h: interface for the CXTPCalendarEvent class.
XTPCalendarEventLabel.h | XTPCalendarEventLabel.h: interface for the CXTPCalendarEventLabel and CXTPCalendarEventLabels classes.
XTPCalendarEvents.h | XTPCalendarEvents.h: CXTPCalendarEvents template.
XTPCalendarMAPIDataProvider.h | XTPCalendarMAPIDataProvider.h: interface for the CXTPCalendarData class.
XTPCalendarMAPIWrapper.h | XTPCalendarMAPIWrapper.h: interface for the CXTPCalendarMAPIWrapper class.
XTPCalendarMemoryDataProvider.h | XTPCalendarMemoryDataProvider.h: interface for the CXTPCalendarMemoryDataProvider class.
XTPCalendarMonthView.h | XTPCalendarMonthView.h: interface for the CXTPCalendarMonthView class.
XTPCalendarMonthViewDay.h | XTPCalendarMonthViewDay.h: interface for the CXTPCalendarMonthViewDay class.
XTPCalendarMonthViewEvent.h | XTPCalendarMonthViewEvent.h: interface for the CXTPCalendarMonthViewEvent class.
XTPCalendarNotifications.h | XTPCalendarNotifications.h: unique notifications identifiers for CXTPCalendarControl class.
XTPCalendarOccurSeriesChooseDlg.h | XTPCalendarOccurSeriesChooseDlg.h interface for CXTPCalendarOccurSeriesChooseDlg class.
XTPCalendarOptions.h | XTPCalendarOptions.h: interface for the CXTPCalendarOptions class.
XTPCalendarPaintManager.h | XTPCalendarControlPaintManager.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarPtrCollectionT.h | XTPCalendarPtrCollectionT.h: CXTPCalendarPtrCollectionT template.
XTPCalendarPtrs.h | XtpCalendarPtrs.h: This file is a part of the XTREME CALENDAR MFC class library.
XTPCalendarRecurrencePattern.h | XTPCalendarRecurrencePattern.h: interface for the CXTPCalendarRecurrencePattern class.
XTPCalendarRemindersManager.h | XTPCalendarRemindersManager.h: interface for the CXTPCalendarRemindersManager class.
XTPCalendarResource.h | XTPCalendarResource.h: interface for the CXTPCalendarResource class.
XTPCalendarResourcesManager.h | XTPCalendarResourcesManager.h: interface for the CXTPCalendarResourcesManager class.
XTPCalendarTheme.h | XTPCalendarTheme.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarThemeOffice2007.h | XTPCalendarThemeOffice2007.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarTimeZoneHelper.h | XTPCalendarTimeZoneHelper.h: interfaces for Time Zone Helper classes.
XTPCalendarTip.h | XTPCalendarTip.h: interface for the CXTPCalendarTip class.
XTPCalendarUtils.h | XTPCalendarUtils.h: interface for the CXTPCalendarUtils class.
XTPCalendarView.h | XTPCalendarView.h: interface for the CXTPCalendarView class.
XTPCalendarViewDay.h | XTPCalendarViewDay.h: interface for the CXTPCalendarViewDay class.
XTPCalendarViewEvent.h | XTPCalendarViewEvent.h: interface for the CXTPCalendarViewEvent class.
XTPCalendarViewPart.h | XTPCalendarViewPart.h: interface for the CXTPCalendarViewPart class.
XTPCalendarWeekView.h | XTPCalendarWeekView.h: interface for the CXTPCalendarWeekView class.
XTPCalendarWeekViewDay.h | XTPCalendarWeekViewDay.h: interface for the CXTPCalendarWeekViewDay class.
XTPCalendarWeekViewEvent.h | XTPCalendarWeekViewEvent.h: interface for the CXTPCalendarWeekViewEvent class.
XTPDatePickerControl.h | XTPDatePickerControl.h: interface for the CXTPDatePickerControl class.
XTPDatePickerDaysCollection.h | XTPDatePickerDaysCollection.h: interface for the CXTPDatePickerDaysCollection class.
XTPDatePickerItemDay.h | XTPDatePickerItemDay.h: interface for the CXTPDatePickerItemDay class.
XTPDatePickerItemMonth.h | XTPDatePickerItemMonth.h: interface for the CXTPDatePickerItemMonth class.
XTPDatePickerList.h | XTPDatePickerItemList.h: interface for the CXTPDatePickerItemList class.
XTPDatePickerNotifications.h | XTPDatePickerNotifications.h: interface for the CXTPDatePickerData class.
XTPDatePickerPaintManager.h | XTPDatePickerPaintManager.h: interface for the CXTPDatePickerPaintManager class.
XTPTopLevelWndMsgNotifier.h | XTPTopLevelWndMsgNotifier.h: interface for the CXTPTopLevelWndMsgNotifier class.
Module

Calendar


XTPCalendarControl.h

Classes, Files
XTPCalendarControl.h

XTPCalendarControl.h: interface for the CXTPCalendarControl class.

Classes
Class | Description
CXTPCalendarControl | Class CXTPCalendarControl implements the calendar's view interface.
Group

Files


XTPCalendarController.h

Classes, Files
XTPCalendarController.h

XTPCalendarController.h: interface for the CXTPCalendarController class.

Classes
Class | Description
CXTPCalendarController | Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object.
Group

Files


XTPCalendarControlView.h

Classes, Files, Variables
XTPCalendarControlView.h

XTPCalendarControlView.h: interface for the CXTPCalendarControlView class.

Classes
Class | Description
CXTPCalendarControlView | The CXTPCalendarControlView class provides an implementation of the Calendar control as view class. Use GetCalendarCtrl() method to access methods of CXTPCalendarControl
CXTPCalendarControlViewPrintOptions | Describes printing options for the Calendar Control.
CXTPCalendarPageSetupDialog | Customized Calendar control page setup dialog.
Group

Files

Variables
Variable | Description
XTP_ID_CALENDAR_CONTROL | Identifier of Calendar control child window of CXTPCalendarControlView.


XTPCalendarCustomDataProvider.h

Classes, Files
XTPCalendarCustomDataProvider.h

XTPCalendarCustomDataProvider.h: interface for the CXTPCalendarCustomProperties class.

Classes
Class | Description
CXTPCalendarCustomDataProvider | Custom implementation of XTPCalendarData based on notifications.
Group

Files


XTPCalendarCustomProperties.h

Classes, Files
XTPCalendarCustomProperties.h

XTPCalendarCustomProperties.h: interface for the CXTPCalendarCustomProperties class.

Classes
Class | Description
CXTPCalendarCustomProperties | This class is used to store properties collection.
Group

Files


XTPCalendarData.h

Classes, Files, Macros, Variables
XTPCalendarData.h

XTPCalendarData.h: interface for the CXTPCalendarData class.

Classes
Class | Description
CXTPCalendarData | This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added,
Group

Files

Macros
Macro | Description
XTP_OBJECT_CACHE_HASH_TABLE_SIZE | Cache table size.
Variables
Variable | Description
cszProcess_RecurrencePatternID | String name for a corresponding property
cszProcess_RecurrenceState | String name for a corresponding property


XTPCalendarDatabaseDataProvider.h

Classes, Files
XTPCalendarDatabaseDataProvider.h

XTPCalendarDatabaseDataProvider.h: interface for the CXTPCalendarDatabaseDataProvider class.

Classes
Class | Description
CXTPCalendarDatabaseDataProvider | This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.
Group

Files


XTPCalendarDayView.h

Classes, Files
XTPCalendarDayView.h

XTPCalendarDayView.h: interface for the CXTPCalendarDayView class.

Classes
Class | Description
CXTPCalendarDayView | This class implements a specific view portion of the Calendar control - called Day view.
Group

Files


XTPCalendarDayViewDay.h

Classes, Files
XTPCalendarDayViewDay.h

XTPCalendarDayViewDay.h: interface for the CXTPCalendarDayViewDay class.

Classes
Class | Description
CXTPCalendarDayViewDay | This class represents a day view portion of the Calendar Day View.
CXTPCalendarDayViewGroup | This class represents a single resource view portion of the Calendar Day View.
Group

Files


XTPCalendarDayViewEvent.h

Classes, Files
XTPCalendarDayViewEvent.h

XTPCalendarDayViewEvent.h: interface for the CXTPCalendarDayViewEvent class.

Classes
Class | Description
CXTPCalendarDayViewEvent | This class represents an event view portion of the CalendarDayViewDay.
Group

Files


XTPCalendarDayViewTimeScale.h

Classes, Files
XTPCalendarDayViewTimeScale.h

XTPCalendarDayViewTimeScale.h: interface for the CXTPCalendarDayViewTimeScale class.

Classes
Class | Description
CXTPCalendarDayViewTimeScale | This class implements a specific view portion of the Calendar Day view - called Time scale.
CXTPCalendarTimeScalePropertiesDlg | CXTPCalendarTimeScalePropertiesDlg dialog This dialog allows to customize Calendar Time Scale part, set a proper time zone and it's description.
Group

Files


XTPCalendarDefines.h

Enumerations, Files, Legend, Macros, Types, Variables, Structures
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCalendarDefines.h

XTPCalendarDefines.h: interface for the CXTPCalendarEvent class.

Enumerations
Enumeration | Description
XTPCalendarClipboardCopyFlags | Enumerates additional flags used in clipboard operations.
XTPCalendarCurrentTimeMarkFlags | Enumerates flags to CXTPCalendarOptions.nDayView_CurrentTimeMarkVisible member. This set of flags define when Current Time Mark on the timescale is visible.
XTPCalendarDataProvider | Enumeration used to determine the calendar data provider in use.
XTPCalendarDataProviderCacheMode | Enumerates DB Provider cache modes.
XTPCalendarDayViewScrollDirection | Enumeration used to determine the scroll direction.
XTPCalendarDraggingMode | Enumerates allowable dragging mode state codes.
XTPCalendarEndEditSubjectAction | Enumerates allowable flags for driving subject editors.
XTPCalendarEventBusyStatus | Enumerates busy status values.
XTPCalendarEventCategories | Enumerates standard Event Categories for office 2007 theme.
XTPCalendarEventIconIDs | Icons IDs set to be used with calendar event custom icons to customize standard event glyphs.
XTPCalendarEventImportance | Enumerates importance level values.
XTPCalendarEventRecurrenceState | Enumerates recurrence states.
XTPCalendarEventRecurrenceType | Enumerates Recurrence Pattern Types.
XTPCalendarHitTestCode | Enumerates allowable hit test codes.
XTPCalendarMouseMode | Enumeration of operational mouse modes.
XTPCalendarPatternEnd | Specify the end of the recurrence pattern type.
XTPCalendarTheme | Paint themes used by calendar.
XTPCalendarUndoMode | Enumerates flags to identify undo mode.
XTPCalendarUpdateOptions | Contains bit-masks for adjusting the calendar control.
XTPCalendarViewChangedUpdateOptions | This enumeration contains options for CXTPCalendarControl::CViewChangedContext.
XTPCalendarViewType | Enumeration used to determine the calendar view type in use.
XTPCalendarWeek | Enumerates a sequence numbers for days.
XTPCalendarWeekDay | Enumerates Day of Weeks codes.
XTPEnumCalendarReminderForOccurrenceParameters | Enumerates parameters used in configuring reminders for recurrence patterns occurrences.
Group

Files

Macros
Macro | Description
XTP_CALENDAR_DEFAULT_LABEL_ID | Define event label ID which is used by default for a new event. (Valid for default labels list only)
XTP_CALENDAR_DEFAULT_REMINDER_MINUTES | Define default reminders value minutes which is for a new event.
XTP_CALENDAR_DISABLED_COLOR_DARK | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_CALENDAR_DISABLED_COLOR_LIGHT | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX | Define maximum text length for calendar event subject, location or body which will be drawn on the screen. Used to optimize drawing performance.
XTP_CALENDAR_NONE_LABEL_ID | Define event label ID which signifies no label. (Valid for default labels list only)
XTP_CALENDAR_OFFICE2007_FONT_NAME | The font name for Office 2007 theme
XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS | Timeout before appearing event tool tip window.
XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS | Timeout before appearing event tool tip window.
XTP_CALENDAR_TIMEZONESKEY_9X | The location in the registry that contains time zone information for Windows 9x family.
XTP_CALENDAR_TIMEZONESKEY_NT | The location in the registry that contains time zone information for Windows NT family (NT/2000/XP).
XTP_CALENDAR_TZIRegValName_DATA | Registry key name for some TIME_ZONE_INFORMATION structure members.
XTP_CALENDAR_TZIRegValName_DaylightName | Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_DaylightNameW | Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_DisplayStr | Registry key name for a time zone display string value. For example: "(GMT+02:00) Athens, Beirut, Istanbul, Minsk"
XTP_CALENDAR_TZIRegValName_Index | Registry key name for a time zone order index value.
XTP_CALENDAR_TZIRegValName_StandardName | Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_StandardNameW | Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_UNKNOWN_EVENT_ID | Define unknown event ID.
XTP_CALENDAR_UNKNOWN_LABEL_ID | Define unknown event label ID.
XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID | Define an unknown recurrence pattern ID.
XTP_CALENDAR_UNKNOWN_SCHEDULE_ID | Define unknown schedule ID.
Types
Type | Description
CXTPCalendarDatesArray | Type definition for an array of dates.
Variables
Variable | Description
cszCalendarMarkupPrm_Subject | Markup template params
cszEventCustProp_CategoryIDs | String name of the corresponding property.
cszEventCustProp_IconsIDs | String name of the corresponding property.
cszEventCustProp_MarkupTemplate | String name of the MarkupTemplate property.
cszEventCustProp_NextReminderTime_Snoozed | String name of the corresponding property.
WM_XTP_CALENDAR_BASE | The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use by private window classes, usually of the form WM_XTP_CALENDAR_BASE+X, where X is an integer value.
xtp_wm_UserAction | A message identifier of the Calendar User Action custom message
XTPCALENDARCTRL_CLASSNAME | Custom class name for the Calendar control window
XTPCALENDARCTRL_USERACTION | String name of the calendar switch view custom message
Legend
Structure
Enumeration
Structures
Structure | Description
XTP_CALENDAR_HITTESTINFO | Basic set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_HITTESTINFO_DAY_VIEW | Enhanced set of parameters for hit test operations on calendar day view area.
XTP_CALENDAR_HITTESTINFO_MONTH_VIEW | Set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_HITTESTINFO_WEEK_VIEW | Set of parameters transferred from calendar items to mouse handlers.
XTP_CALENDAR_MONTHVIEW_DAYPOS | Defines a set of data and methods to easily manipulate with day positions in month view. Used to convert Week/Day indexes pair to sequential integer value and vice versa.
XTP_CALENDAR_PATTERN_END | This structure describes parameters of the end of the recurrence pattern type.
XTP_CALENDAR_VIEWSELECTION | Structure contains the calendar day view selection block.


XTPCalendarEvent.h

Classes, Files
XTPCalendarEvent.h

XTPCalendarEvent.h: interface for the CXTPCalendarEvent class.

Classes
Class | Description
CXTPCalendarEvent | This class represents the data of a single Event used in the Calendar control.
Group

Files


XTPCalendarEventLabel.h

Classes, Files
XTPCalendarEventLabel.h

XTPCalendarEventLabel.h: interface for the CXTPCalendarEventLabel and CXTPCalendarEventLabels classes.

Classes
Class | Description
CXTPCalendarEventCategories | This class is used as a collection of CXTPCalendarEventCategory objects.
CXTPCalendarEventCategory | This class define Calendar Event Category properties. Visual effects for Event Categories (event and day's cells background colors) implemented in Office 2007 theme only. If one or more categories set for event - the category's colors are used, otherwise label's colors used (is label defined). For Office 2003 theme label's colors used in any case.
CXTPCalendarEventCategoryIDs | This class represents the collection of event categories IDs.
CXTPCalendarEventLabel | This class define Calendar Event label properties.
CXTPCalendarEventLabels | This class is used as a collection of CXTPCalendarEventLabel objects.
CXTPCalendarIconIDs | This class represents the collection of custom icons IDs.
CXTPCalendarUIntArray | This class represents the collection of UINT elements.
Group

Files


XTPCalendarEvents.h

Classes, Files
XTPCalendarEvents.h

XTPCalendarEvents.h: CXTPCalendarEvents template.

Classes
Class | Description
CXTPCalendarEvents | This class represents a simple array collection of CXTPCalendarEvent objects.
Group

Files


XTPCalendarMAPIDataProvider.h

Classes, Files
XTPCalendarMAPIDataProvider.h

XTPCalendarMAPIDataProvider.h: interface for the CXTPCalendarData class.

Classes
Class | Description
CXTPCalendarMAPIDataProvider | This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.
Group

Files


XTPCalendarMAPIWrapper.h

Classes, Files
XTPCalendarMAPIWrapper.h

XTPCalendarMAPIWrapper.h: interface for the CXTPCalendarMAPIWrapper class.

Classes
Class | Description
CXTPCalendarMAPIWrapper | The CXTPCalendarMAPIWrapper class wraps the mapi32.dll API.
Group

Files


XTPCalendarMemoryDataProvider.h

Classes, Files, Macros
XTPCalendarMemoryDataProvider.h

XTPCalendarMemoryDataProvider.h: interface for the CXTPCalendarMemoryDataProvider class.

Classes
Class | Description
CXTPCalendarMemoryDataProvider | This class implements an abstract representation of the data used in the XTPCalendarData class.
Group

Files

Macros
Macro | Description
XTP_EVENTS_STORAGE_HASH_TABLE_SIZE | Define events storage hash table size. Should be a prime number! like: 503, 1021, 1511, 2003, 3001, 4001, 5003, 6007, 8009, 12007, 16001, 32003, 48017, 64007


XTPCalendarMonthView.h

Classes, Files, Macros
XTPCalendarMonthView.h

XTPCalendarMonthView.h: interface for the CXTPCalendarMonthView class.

Classes
Class | Description
CXTPCalendarMonthView | This class implements a specific view portion of the Calendar control - called Month view.
Group

Files

Macros
Macro | Description
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX | Define maximum count of weeks which can be shown in the Month View.
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN | Define minimum count of weeks which can be shown in the Month View.


XTPCalendarMonthViewDay.h

Classes, Files
XTPCalendarMonthViewDay.h

XTPCalendarMonthViewDay.h: interface for the CXTPCalendarMonthViewDay class.

Classes
Class | Description
CXTPCalendarMonthViewDay | This class represents a day view portion of the CalendarMonthView.
CXTPCalendarMonthViewGroup | This class represents a single resource view portion of the Calendar Month View.
Group

Files


XTPCalendarMonthViewEvent.h

Classes, Files
XTPCalendarMonthViewEvent.h

XTPCalendarMonthViewEvent.h: interface for the CXTPCalendarMonthViewEvent class.

Classes
Class | Description
CXTPCalendarMonthViewEvent | This class represents an event view portion of the CalendarMonthViewDay.
Group

Files


XTPCalendarNotifications.h

Enumerations, Files, Legend, Variables, Structures
XTPCalendarNotifications.h

XTPCalendarNotifications.h: unique notifications identifiers for CXTPCalendarControl class.

Enumerations
Enumeration | Description
XTPCalendarBeforeDrawThemeObject | This enum defines a set of calendar theme items for which XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification is sent.
XTPCalendarEditOperation | Enumerates customizable event edit operations.
XTPCalendarExpandDayButton | This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action.
XTPCalendarGetItemText | This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.
XTPCalendarGetItemTextEx | This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification. These flags are used for office 2007 theme only.
XTPCalendarRemindersAction | Enumeration of possible Calendar Reminder notification actions.
XTPCalendarScrollDayButton | This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action. (valid for office 2007 theme only)
XTPCalendarSelectionChanged | Enumerates calendar selection types.
XTPCalendarUserAction | This enum defines set of user actions which can be customized.
Group

Files

Variables
Variable | Description
XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL | This notification is sent for each calendar day view cell before draw. You may customize clrBackgroundColor member of provided XTP_CALENDAR_DAYVIEWCELL_PARAMS structure. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT | This notification is sent for calendar theme items before draw. You may customize corresponding theme part for each object in this message. Any object part changes which made in this notification handler will be discarded when object draw finished. This let you dynamically customize each calendar item. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION | This notification is sent to customize or disable specified editing operation. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_DoCreate_Event | This notification is used as analog of overridable method CXTPCalendarData::DoCreate_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoCreate_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoCreate_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoDelete_Event | This notification is used as analog of overridable method CXTPCalendarData::DoDelete_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoDelete_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoDelete_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoGetAllEvents_raw | This notification is used as analog of overridable method CXTPCalendarData::DoGetAllEvents_raw. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoGetUpcomingEvents | This notification is used as analog of overridable method CXTPCalendarData::DoGetUpcomingEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRead_Event | This notification is used as analog of overridable method CXTPCalendarData::DoRead_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRead_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoRead_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRemoveAllEvents | This notification is used as analog of overridable method CXTPCalendarData::DoRemoveAllEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoRetrieveDayEvents | This notification is used as analog of overridable method CXTPCalendarData::DoRetrieveDayEvents. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoUpdate_Event | This notification is used as analog of overridable method CXTPCalendarData::DoUpdate_Event. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_DoUpdate_RPattern | This notification is used as analog of overridable method CXTPCalendarData::DoUpdate_RPattern. Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.
XTP_NC_CALENDAR_GETGROPVIEWCAPTION | This notification is sent when selection is changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_GETITEMTEXT | This notification is sent for calendar items which defines in AskItemTextFlags property.
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED | This notification is sent to determine is specified editing operation disabled. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_ON_REMINDERS | On RButtonUp event. Sender - CXTPCalendarRemindersManager
XTP_NC_CALENDAR_PREPOPULATE | This notification is sent when calendar is populating. lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_PREPOPULATE_DAY | This notification is sent when calendar is populating. lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED | Calendar Control data provider (resources) where changed. SetDataProvider() or SetResources() methods where called. Sender - CXTPCalendarControl, CXTPCalendarView.
XTP_NC_CALENDAR_SELECTION_CHANGED | This notification is sent when selection is changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_THEME_CHANGED | This notification is sent when calendar paint theme changed. Sender - CXTPCalendarControl
XTP_NC_CALENDAR_USERACTION | This notification send for when user action defined in XTPCalendarUserAction enum happened. Parameters wParam - [in] A pointer to XTP_CALENDAR_USERACTION_PARAMS structure. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if specified action is handled (to Cancel default processing) , otherwise FALSE. Initial value is FALSE.
XTP_NC_CALENDARCONTEXTMENU | A Context Menu should be displayed for the Calendar Control. Sender - CXTPCalendarControl
XTP_NC_CALENDARDATAPROVIDERWASCHANGED | Calendar Control data provider (resources) where changed. SetDataProvider() or SetResources() methods where called. Sender - CXTPCalendarControl, CXTPCalendarView.
XTP_NC_CALENDAREVENTWASADDED | New event has just been added to the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDAREVENTWASCHANGED | Event has just been changed in the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDAREVENTWASDELETED | Event has just been deleted from the data provider. Sender - CXTPCalendarData, CXTPCalendarControl
XTP_NC_CALENDARKEYDOWN | On KeyDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONDBLCLICK | On LButtonDblClick event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONDOWN | On LButtonDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARLBUTTONUP | On LButtonUp event. Sender - CXTPCalendarControl
XTP_NC_CALENDARMOUSEMOVE | On MouseMove event. Sender - CXTPCalendarControl
XTP_NC_CALENDAROPTIONSWASCHANGED | Calendar Control options was changed. Sender - CXTPCalendarControl
XTP_NC_CALENDARRBUTTONDOWN | On RButtonDown event. Sender - CXTPCalendarControl
XTP_NC_CALENDARRBUTTONUP | On RButtonUp event. Sender - CXTPCalendarControl
XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED | Calendar Control Day view time scale was changed. Sender - CXTPCalendarControl
XTP_NC_CALENDARVIEWWASCHANGED | Current Calendar Control view type(day, week, ...) or content was changed. Sender - CXTPCalendarControl
Legend
Structure
Enumeration
Structures
Structure | Description
XTP_CALENDAR_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification.
XTP_CALENDAR_GETITEMTEXT_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_GETITEMTEXT notification.
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.
XTP_CALENDAR_USERACTION_PARAMS | Set of parameters transferred from calendar items for XTP_NC_CALENDAR_USERACTION notification.
XTP_CALENDAR_WPARAM2 | Doubled custom parameter for notifications. Used when single WPARAM is not enough.
XTP_EVENT_DRAG_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_DragXXX.
XTP_EVENT_EDIT_OPERATION_PARAMS | This structure is used as a generic and base class for customize edit event notifications.
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent.
XTP_EVENT_PASTE_OPERATION_PARAMS | This structure is with notifications for customize edit event notifications when eOperation is xtpCalendarEO_Paste.


XTPCalendarOccurSeriesChooseDlg.h

Classes, Files
XTPCalendarOccurSeriesChooseDlg.h

XTPCalendarOccurSeriesChooseDlg.h interface for CXTPCalendarOccurSeriesChooseDlg class.

Classes
Class | Description
CXTPCalendarOccurSeriesChooseDlg | This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern).
Group

Files


XTPCalendarOptions.h

Classes, Enumerations, Files, Legend
XTPCalendarOptions.h

XTPCalendarOptions.h: interface for the CXTPCalendarOptions class.

Classes
Class | Description
CXTPCalendarOptions | Structure contains all calendar options.
Enumerations
Enumeration | Description
XTPCalendarAdditionalOptions | Enumerates additional calendar options flags.
Group

Files

Legend
Enumeration


XTPCalendarPaintManager.h

Classes, Enumerations, Files, Legend, Macros
XTPCalendarPaintManager.h

XTPCalendarControlPaintManager.h: interface for the CXTPCalendarControlPaintManager class.

Classes
Class | Description
CXTPCalendarPaintManager | Utility class, handles most of the drawing activities.
Enumerations
Enumeration | Description
XTPCalendarClockAlignFlags |
Group

Files

Macros
Macro | Description
BEGIN_VIEW_PART | This helper macro is used to declare paint manager drawing parts. theClass - Part name. parentClass - Parent part name. There are two paint manager methods available to access declared part object: CPartName* GetPartName(); void SetPartName(CPartName* pPart); Where PartName is the name of the declared part.
END_VIEW_PART | This helper macro is used to declare paint manager drawing parts. theClass - Part name.
Legend
Enumeration


XTPCalendarPtrCollectionT.h

Files, Legend, Templates
XTPCalendarPtrCollectionT.h

XTPCalendarPtrCollectionT.h: CXTPCalendarPtrCollectionT template.

Group

Files

Templates
Template | Description
CXTPCalendarPtrCollectionT | This class represents a simple array collection of objects.
CXTPCalendarTypedPtrAutoDeleteArray | This class represents a simple array collection of objects pointers.
CXTPCalendarTypedPtrAutoDeleteMap | This class represents a simple map of typed keys to typed objects pointers. Overridden methods SetAt, operator[], RemoveKey, RemoveAll, call delete for previously stored elements.
Legend
Template


XTPCalendarPtrs.h

Files
XTPCalendarPtrs.h

XtpCalendarPtrs.h:

This file is a part of the XTREME CALENDAR MFC class library.

Group

Files


XTPCalendarRecurrencePattern.h

Classes, Files, Legend, Structures
XTPCalendarRecurrencePattern.h

XTPCalendarRecurrencePattern.h: interface for the CXTPCalendarRecurrencePattern class.

Classes
Class | Description
CXTPCalendarRecurrencePattern | This class represents a recurrence pattern and stores data to build schedule for recurrence events.
CXTPCalendarReminderForOccurrence | This structure describes a reminder for an occurrence of a recurrence event.
CXTPCalendarReminderForOccurrenceArray | This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it.
Group

Files

Legend
Structure
Structures
Structure | Description
XTP_CALENDAR_RECURRENCE_OPTIONS | This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data.


XTPCalendarRemindersManager.h

Classes, Files
XTPCalendarRemindersManager.h

XTPCalendarRemindersManager.h: interface for the CXTPCalendarRemindersManager class.

Classes
Class | Description
CXTPCalendarReminder | This class describes a reminder for calendar event and implements base properties and operations on reminder.
CXTPCalendarReminders | This class represents a simple array collection of CXTPCalendarReminder objects.
CXTPCalendarRemindersManager | This class is used to monitor and manage calendar events reminders. It will send notifications when active reminders list is changed - new reminder(s) come or some reminder(s) goes away.
Group

Files


XTPCalendarResource.h

Classes, Files
XTPCalendarResource.h

XTPCalendarResource.h: interface for the CXTPCalendarResource class.

Classes
Class | Description
CXTPCalendarResource | Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of persons or resources.
CXTPCalendarResources | This class represents a simple array collection of CXTPCalendarResource objects.
CXTPCalendarResourcesNf | This class implements CXTPCalendarResource functionality with addition of notifications mechanism implemented by CXTPNotifySink.
CXTPCalendarSchedule | Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc). This class implements base properties of the Schedule and operations on it.
CXTPCalendarSchedules | This class represents a simple array collection of CXTPCalendarSchedule objects.
Group

Files


XTPCalendarResourcesManager.h

Classes, Files
XTPCalendarResourcesManager.h

XTPCalendarResourcesManager.h: interface for the CXTPCalendarResourcesManager class.

Classes
Class | Description
CXTPCalendarResourceDescription | This class is a wrapper for CXTPCalendarResource class. It is needed for easier processing in scope of CXTPCalendarResourcesManager
CXTPCalendarResourcesManager | This class is used as helper to manage calendar resources (and schedules) data configurations.
Group

Files


XTPCalendarTheme.h

Files
XTPCalendarTheme.h

XTPCalendarTheme.h: interface for the CXTPCalendarControlPaintManager class.

Group

Files


XTPCalendarThemeOffice2007.h

Classes, Files
XTPCalendarThemeOffice2007.h

XTPCalendarThemeOffice2007.h: interface for the CXTPCalendarControlPaintManager class.

Classes
Class | Description
CXTPCalendarViewEventSubjectEditor2007 | This class is used to edit event subject in Office 2007 Theme.
Group

Files


XTPCalendarTimeZoneHelper.h

Classes, Files
XTPCalendarTimeZoneHelper.h

XTPCalendarTimeZoneHelper.h: interfaces for Time Zone Helper classes.

Classes
Class | Description
CXTPCalendarTimeZone | This class extend TIME_ZONE_INFORMATION structure.
CXTPCalendarTimeZones | This class represents a simple array collection of CXTPCalendarTimeZone objects.
Group

Files


XTPCalendarTip.h

Classes, Files
XTPCalendarTip.h

XTPCalendarTip.h: interface for the CXTPCalendarTip class.

Classes
Class | Description
CXTPCalendarTip | The CXTPCalendarTip class emulates the functionality of a "tool tip" control.
Group

Files


XTPCalendarUtils.h

Functions, Files, Legend, Macros, Templates
XTPCalendarUtils.h

XTPCalendarUtils.h: interface for the CXTPCalendarUtils class.

Functions
Function | Description
xtpCalendarDateTime_max | Defines an upper bound of the time frame for the Calendar control.
xtpCalendarDateTime_min | Defines a lower bound of the time frame for the Calendar control.
Group

Files

Macros
Macro | Description
XTP_HALF_SECOND |
Templates
Template | Description
CXTPAutoResetValue | Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy. Can be useful to lock some data or actions via flags and unlock automatically.
CXTPCalendarUtils | Helper class with static member functions to perform common tasks with dates, events and other objects.
Legend
Template
Method


XTPCalendarView.h

Classes, Files, Legend, Macros, Templates, Variables
XTPCalendarView.h

XTPCalendarView.h: interface for the CXTPCalendarView class.

Classes
Class | Description
CXTPCalendarView | This class represents the view portion of the Calendar control.
CXTPCalendarWMHandler | This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
Group

Files

Macros
Macro | Description
XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS |
Templates
Template | Description
CXTPCalendarViewT | This template class represents a view portion of the Calendar control.
Variables
Variable | Description
XTPCALENDARCTRL_CF_EVENT |
Legend
Template


XTPCalendarViewDay.h

Classes, Files, Legend, Templates
XTPCalendarViewDay.h

XTPCalendarViewDay.h: interface for the CXTPCalendarViewDay class.

Classes
Class
Description
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
CXTPCalendarViewGroup
Regular schema:

  • CalendarView consists of CalendarView(s)Day
  • CalendarViewDay consists of CalendarView(s)Resource
  • CalendarViewGroup contains CalendarView(s)Event

ViewGroup draws a single resource depending on the type of parent day view.

Group

Files

Templates
Template | Description
CXTPCalendarViewDayT | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class.
CXTPCalendarViewGroupT | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class.
Legend
Template


XTPCalendarViewEvent.h

Classes, Enumerations, Files, Legend, Templates
XTPCalendarViewEvent.h

XTPCalendarViewEvent.h: interface for the CXTPCalendarViewEvent class.

Classes
Class | Description
CXTPCalendarViewEvent | This class represents an event view portion of the CalendarViewGroup.
CXTPCalendarViewEvents | This class used as collection of Event View object.
CXTPCalendarViewEventSubjectEditor | This class is used to edit event subject.
Enumerations
Enumeration | Description
XTPCalendarEventCaptionFormat | Enumerates allowable formats for event caption.
XTPCalendarMultiDayEventFlags | Enumerates defined flags for multi day event states.
Group

Files

Templates
Template | Description
CXTPCalendarViewEventT | This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.
Legend
Template
Enumeration


XTPCalendarViewPart.h

Classes, Functions, Files, Legend, Templates
XTPCalendarViewPart.h

XTPCalendarViewPart.h: interface for the CXTPCalendarViewPart class.

Classes
Class | Description
CXTPCalendarThemeBOOLValue | Helper class provides functionality to manage customized BOOL value objects.
CXTPCalendarThemeFontValue | Helper class provides functionality to manage font value objects.
CXTPCalendarThemeIntValue | Helper class provides functionality to manage customized int value objects.
CXTPCalendarThemeRectValue | Helper class provides functionality to manage customized CRect value objects.
CXTPCalendarThemeStringValue | Helper class provides functionality to manage customized string value objects.
CXTPCalendarViewPart | Helper base class to implement parts for calendar paint manager. objects.
CXTPCalendarViewPartBrushValue | Helper class provides functionality to manage brush value objects.
CXTPCalendarViewPartFontValue | Helper class provides functionality to manage font settings for various graphical elements of control.
Functions
Function | Description
PX_Color | Call this function within your class's DoPropExchange member function to serialize or initialize a COLORREF property. The property's value is read from or written to the variable referenced by refColor, as appropriate.
PX_Color | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Color property. The property's value is read from or written to the variable referenced by refColor, as appropriate.
PX_Font | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Font property. The property's value is read from or written to the variable referenced by refFont, as appropriate.
PX_Font | Call this function within your class's DoPropExchange member function to serialize or initialize a LOGFONT property. The property's value is read from or written to the variable referenced by rLogFont, as appropriate.
PX_GrColor | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property. The property's value is read from or written to the variable referenced by refGrColor, as appropriate.
Group

Files

Templates
Template | Description
CXTPCalendarThemeCustomizableXValueT | Helper class template provides functionality to manage customized value for the specified type.
CXTPCalendarViewPartCustomizableValueT | Helper class template provides functionality to manage customized value for the specified class objects.
Legend
Template
Method


XTPCalendarWeekView.h

Classes, Files
XTPCalendarWeekView.h

XTPCalendarWeekView.h: interface for the CXTPCalendarWeekView class.

Classes
Class | Description
CXTPCalendarWeekView | This class implements a specific view portion of the Calendar control - called Week view.
Group

Files


XTPCalendarWeekViewDay.h

Classes, Files
XTPCalendarWeekViewDay.h

XTPCalendarWeekViewDay.h: interface for the CXTPCalendarWeekViewDay class.

Classes
Class | Description
CXTPCalendarWeekViewDay | This class represents a day view portion of the CalendarWeekView.
CXTPCalendarWeekViewGroup | This class represents a single resource view portion of the Calendar Week View.
Group

Files


XTPCalendarWeekViewEvent.h

Classes, Files
XTPCalendarWeekViewEvent.h

XTPCalendarWeekViewEvent.h: interface for the CXTPCalendarWeekViewEvent class.

Classes
Class | Description
CXTPCalendarWeekViewEvent | This class represents an event view portion of the CalendarWeekViewDay.
Group

Files


XTPDatePickerControl.h

Classes, Enumerations, Files, Legend, Variables, Structures
XTPDatePickerControl.h

XTPDatePickerControl.h: interface for the CXTPDatePickerControl class.

Classes
Class | Description
CXTPDatePickerButton | This class represents a DatePicker button.
CXTPDatePickerButtons | Class CXTPDatePickerButtons represents a collection of buttons.
CXTPDatePickerControl | Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Enumerations
Enumeration | Description
XTPDatePickerBorderStyle | Border style of Date picker control
Group

Files

Variables
Variable | Description
XTP_DATEPICKER_TIMER_INTERVAL | Date picker timer interval.
XTP_DATEPICKER_TIMERID | Date picker timer ID.
XTP_NC_DATEPICKER_BUTTON_CLICK | Notify ID to parent window.
XTP_NC_DATEPICKER_SELECTION_CHANGED | Notify ID to parent window.
XTP_SELECTION_INFINITE | Infinite number of selected days.
Legend
Structure
Enumeration
Structures
Structure
Description
XTP_DAYITEM_METRICS
This structure represents a set of parameters which are used to display day items.

  1. There could be customized foreground and background colors.
  2. Also you can text font for the displayed day text.
  3. And as the last thing you can customize a day picture displayed there, using OLE PICTUREDISP interface and OleSetPicture method.

XTP_NC_DATEPICKER_BUTTON
Structure used to send button notification messages.


XTPDatePickerDaysCollection.h

Classes, Files
XTPDatePickerDaysCollection.h

XTPDatePickerDaysCollection.h: interface for the CXTPDatePickerDaysCollection class.

Classes
Class | Description
CXTPDatePickerDaysCollection |
Group

Files


XTPDatePickerItemDay.h

Classes, Files
XTPDatePickerItemDay.h

XTPDatePickerItemDay.h: interface for the CXTPDatePickerItemDay class.

Classes
Class | Description
CXTPDatePickerItemDay | Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
Group

Files


XTPDatePickerItemMonth.h

Classes, Files
XTPDatePickerItemMonth.h

XTPDatePickerItemMonth.h: interface for the CXTPDatePickerItemMonth class.

Classes
Class | Description
CXTPDatePickerItemMonth | Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
Group

Files


XTPDatePickerList.h

Classes, Files
XTPDatePickerList.h

XTPDatePickerItemList.h: interface for the CXTPDatePickerItemList class.

Classes
Class | Description
CXTPDatePickerList | This class provides the functionality of a list control which displays month names.
Group

Files


XTPDatePickerNotifications.h

Files, Variables
XTPDatePickerNotifications.h

XTPDatePickerNotifications.h: interface for the CXTPDatePickerData class.

Group

Files

Variables
Variable | Description
XTP_NC_DATEPICKERBEFOREGOMODAL | This is a notification ID that is used to indicate that the Date Picker is before run in modal mode (pop-up window), window has already created.
XTP_NC_DATEPICKERBUTTONCLICKED | This is a notification ID that is used to indicate mouse button clicks on a control.
XTP_NC_DATEPICKERGETDAYMETRICS | This notification is used to get day item metrics. Sender - CXTPDatePickerControl.
XTP_NC_DATEPICKERMONTHCHANGED | This is a notification ID that is used to indicate that the Date Picker is populated.
XTP_NC_DATEPICKERMOUSEMOVE | This is a notification ID that is used to indicate mouse move under a control.
XTP_NC_DATEPICKERSELECTIONCHANGED | This is a notification ID that is used to indicate that the selection has changed.


XTPDatePickerPaintManager.h

Classes, Files
XTPDatePickerPaintManager.h

XTPDatePickerPaintManager.h: interface for the CXTPDatePickerPaintManager class.

Classes
Class | Description
CXTPDatePickerPaintManager | Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
CXTPDatePickerTheme | Abstract class CXTPDatePickerTheme is derived from CXTPDatePickerPaintManager and handles most of the drawing activities for the DatePicker control. This class must be used as a base to create different themes implementations (like CXTPDatePickerThemeOffice2007).
CXTPDatePickerThemeOffice2007 | Class CXTPDatePickerThemeOffice2007 is derived from CXTPDatePickerTheme is implement Office 2007 style for DatePicker control.
Group

Files


XTPTopLevelWndMsgNotifier.h

Classes, Functions, Files, Legend, Variables
XTPTopLevelWndMsgNotifier.h

XTPTopLevelWndMsgNotifier.h: interface for the CXTPTopLevelWndMsgNotifier class.

Classes
Class | Description
CXTPTopLevelWndMsgNotifier | This class is used to catch windows messages, which system sends to top-level windows and to send them to subscribers windows. The following messages are supported: WM_TIMECHANGE WM_SYSCOLORCHANGE
Functions
Function | Description
XTPGetTopLevelWndMsgNotifier | This global function is used to get library static common top-level window object to catch windows messages, which system sends to top-level windows (like WM_TIMECHANGE, WM_SYSCOLORCHANGE).
Group

Files

Variables
Variable | Description
XTP_WM_TIME_ZONE_CHANGED | Define windows message which send by CXTPTopLevelWndMsgNotifier when current timezone is changed.
XTP_WM_TIME_ZONE_CHANGED_MSG | Define name for XTP_WM_TIME_ZONE_CHANGED windows message.
Legend
Method


Common Files

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Functions, Macros, Structs, Records, Enums, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Common Files

Codejock Software's Common Files contain utilities that help aid developers with common programming tasks.

Here you will support classes to automatically select and free GDI objects, automatically initialize window and client CRect objects, perform custom image drawing, manage application resources and more.

Group

Xtreme Toolkit Pro v12.0

Legend
Template
Method
Enumeration
Classes
Class
Description
CXTMaskEditT
CXTMaskEditT is a template class. It allows text masking to be applied to the control to format it for special editing restrictions.
CXTPBitmapDC
CXTPBitmapDC is a helper class used to select a bitmap into the device context specified by hDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPBrushDC
CXTPBrushDC is a helper class used to create a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC. When destroyed, the class selects the previous brush back into the device context to handle GDI resource cleanup.
CXTPBufferDC
CXTPBufferDC is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPBufferDCEx
CXTPBufferDCEx is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPClientCursorPos
CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates.
CXTPClientRect
CXTPClientRect is a helper class used to retrieve the client area for a specified window.
CXTPColorManager
CXTPColorManager is a stand alone class. This object is used for manipulation of RGB values.
CXTPCompatibleDC
CXTPCompatibleDC is a helper class used to create a memory device context (DC) compatible with the device specified by pDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPCriticalSection
Critical Section Wrapper
CXTPDrawHelpers
CXTPDrawHelpers is a helper class used to perform specialized drawing tasks. You can use this class to perform such tasks as gradient fills and blending colors.
CXTPEmptyRect
CXTPEmptyRect is a helper class used to instantiate an empty CRect object.
CXTPEmptySize
CXTPEmptySize is a helper class used to instantiate an empty CSize object.
CXTPFontDC
CXTPFontDC is a helper class used to select a font into the device context specified by pDC. When destroyed, the class selects the previous font back into the device context to handle GDI resource cleanup.
CXTPImageManager
CXTPImageManager is a stand alone class. It is used to manipulate icons.
CXTPImageManagerIcon
Icons holder class.
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is HICON wrapper class.
CXTPImageManagerIconSet
CXTPImageManagerIconSet represents the collection of icons for specified identifier.
CXTPLockGuard
Critical Sections Lock/Unlock helper
CXTPModuleHandle
CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods
CXTPMouseMonitor
The class CXTPMouseMonitor is a helper class that is used to monitor mouse messages for in-place controls. This class is used in XTPPropertyGridInPlaceList and XTPReportInplaceControls.
CXTPMultiMonitor
MultiMonitor API wrapper class
CXTPNoFlickerWnd
CXTPNoFlickerWnd is a TBase derived general purpose template helper class. CXTPNoFlickerWnd class is used for drawing flicker free controls. To use, instantiate the template using any CWnd derived class. For example, to create a tab control that is flicker free you would use the following declaration:
CXTPOfficeBorder
CXTPOfficeBorder is a template class used for windows that require a thin border. This class can be used as the base class for any CWnd derived class to display an Office style non-client border.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and application defined colors.
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and dark gradient colors.
CXTPPenDC
CXTPPenDC is a helper class used to create a pen using the color specified by crColor. The pen is then selected into the device context specified by hDC. When destroyed, the class selects the previous pen back into the device context to handle GDI resource cleanup.
CXTPPrinterInfo
Helper class which provide currently selected printer information.
CXTPPrintOptions
This class used as a base class to store printing options. It contains a base properties and operations for printing tasks.
CXTPPrintPageHeaderFooter
This class used to define printed page header or footer. Also some calculation and drawing functionality are provided. Used as member of printing options.
CXTPPropExchange
CXTPPropExchange is standalone pure class. The CXTPPropExchange class allows you to save a complex network of objects in a permanent binary or text form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
You can use one of derived classes:

  • CXTPPropExchangeArchive to serialize to archive,
  • CXTPPropExchangeRegistry to serialize to registry key,
  • CXTPPropExchangeXMLNode to serialize to XML node.

CXTPPropExchangeArchive
CXTPPropExchangeArchive is CXTPPropExchange derived class. The CXTPPropExchangeArchive class allows you to save a complex network of objects in a permanent binary form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class. It used by CXTPPropExchange to enumerate child sections.
CXTPPropExchangeIniFile
CXTPPropExchangeIniFile is CXTPPropExchange derived class. The CXTPPropExchangeIniFile class allows you to save a complex network of objects in a ini file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeRegistry
CXTPPropExchangeRegistry is CXTPPropExchange derived class. The CXTPPropExchangeRegistry class allows you to save a complex network of objects in a system registry that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeSection
CXTPPropExchangeSection is standalone class. It is used to delete memory allocated by CXTPPropExchange::GetSection.
CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class. The CXTPPropExchangeXMLNode class allows you to save a complex network of objects in a XML file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPResourceManager
Standalone class used to managed toolkit resources.
CXTPResourceManagerXML
Class used to managed toolkit resources from XML file
CXTPSplitterTracker
CXTPSplitterTracker is a stand alone class. It is used to track a splitter rectangle.
CXTPSystemVersion
CXTPSystemVersion is a OSVERSIONINFO derived class. This class wraps the Win32 API GetVersionEx(...), used to get the current Windows OS version. CXTPSystemVersion is a single instance, or "singleton" object, that is accessed with the Get() method.
CXTPTempColorMask
CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks. When the destructor is called the default mask is reset for XTPImageManager.
CXTPToolTipContext
CXTPToolTipContext is a CCmdTarget derived class. It allows to change options for tool tips of parent object.
CXTPToolTipContextToolTip
CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips.
CXTPTransparentBitmap
CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap. Also, this class is used to convert a transparent BitMap into a transparent icon.
CXTPWindowRect
CXTPWindowRect is a helper class used to retrieve the screen size for a specified window.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API. You can use this class for rendering Windows XP themes for owner drawn controls.
Files
File | Description
XTMaskEditT.h | XTMaskEditT.h interface for the CXTMaskEditT class.
XTPColorManager.h | XTPColorManager.h: interface for the CXTPColorManager class.
XTPDrawHelpers.h | XTPDrawHelpers.h: interface for the CXTPDrawHelpers class.
XTPImageManager.h | XTPImageManager.h : interface for the CXTPImageManager class.
XTPMacros.h | XTPMacros.h : common macros This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPPropExchange.h | XTPPropExchange.h: interface for the CXTPPropExchange class.
XTPResourceManager.h | XTPResourceManager.h: interface for the CXTPResourceManager class.
XTPSystemHelpers.h | XTPSystemHelpers This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPToolTipContext.h | XTPToolTipContext.h: interface for the CXTPToolTipContext class.
XTPWinThemeWrapper.h | XTPWinThemeWrapper.h: interface for the CXTPWinThemeWrapper class.
Functions
Function | Description
GetMSO2003Color | Call this function to get the MS Office color represented by nIndex.
GetXtremeColor | Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetColor for more details.
PX_Blob | Call this function within your class's DoPropExchange member function to serialize BYTE array.
PX_Bool | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Bool | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Bstr | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Byte | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BYTE. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DateTime | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleDateTime. The property's value is read from or written to the variable referenced by dtValue, as appropriate.
PX_Double | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Double | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DWord | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DWord | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Float | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Float | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Int | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Int | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Long | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Long | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Point | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT. The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Rect | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT. The property's value is read from or written to the variable referenced by rcValue, as appropriate. If rcDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_RuntimeClass | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type CRuntimeClass. The property's value is read from or written to the variable referenced by pClass, as appropriate. If pDefaultClass is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Serialize | Call this function within your class's DoPropExchange member function to serialize object.
PX_Short | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Short | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Size | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE. The property's value is read from or written to the variable referenced by szValue, as appropriate. If szDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_String | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_String | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UI8 | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONGLONG. The property's value is read from or written to the variable referenced by ullValue, as appropriate. If ullDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_ULong | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_ULong | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UShort | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UShort | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Variant | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleVariant. The property's value is read from or written to the variable referenced by variant, as appropriate. If variantDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
RefreshXtremeColors | This global function will refresh the display element colors defined in the CXTPColorManager class.
XTPColorManager | Call this function to access CXTPColorManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPColorManager.
XTPDrawHelpers | Call this function to access CXTPDrawHelpers members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPDrawHelpers.
XTPGetPrinterDeviceDefaults | Prepare a printer device context for printing and calculates DEVMODE and DEVNAMES values.
XTPMultiMonitor | Call this function to access CXTPMultiMonitor members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPMultiMonitor.
XTPResourceManager | Call this function to access CXTPResourceManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPResourceManager.
XTPSystemVersion | The XTPSystemVersion function is used for access to the CXTPSystemVersion class.
Macros
Macro | Description
SAFE_CALLPTR | Checks object pointer and if not NULL calls a specified function.
SAFE_DELETE | Frees dynamically allocated memory.
SAFE_DELETE_AR | Frees dynamically allocated memory for an array.
SAFE_DELETE_HICON | Destroys an icon and frees any memory the icon occupied.
SAFE_DELETE_OBJ | Destroys a GDI object and frees the handle.
SAFE_RELEASE | Decrements the reference count for the specified object.
XT_ASSERT_MSG | XT_ASSERT_MSG is similar to ASSERT, except that it allows a custom message to be specified.
XTOSVersionInfo | Depricated
Structs, Records, Enums
Struct, Record, Enum | Description
XTPCurrentSystemTheme | Enumeration used to determine the current Windows XP theme in use
XTPImageState | Image state enumerators.
XTPToolTipStyle | Enumeration used to determine styles for tooltips
Variables
Variable | Description
XPCOLOR_3DFACE | Retrieves the current color of the specified XP display element.
XPCOLOR_3DSHADOW | Retrieves the current color of the specified XP display element.
XPCOLOR_BASE | Retrieves the current color of the specified XP display element.
XPCOLOR_CHECKED_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_DISABLED | Retrieves the current color of the specified XP display element.
XPCOLOR_EDITCTRLBORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_FLOATBAR_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_FRAME | Retrieves the current color of the specified XP display element.
XPCOLOR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_CHECKED | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_CHECKED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_DISABLED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_PUSHED | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_PUSHED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_ICONSHADDOW | Retrieves the current color of the specified XP display element.
XPCOLOR_LABEL | Retrieves the current color of the specified XP display element.
XPCOLOR_LAST | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_EXPANDED | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_PUSHED_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_SEPARATOR | Retrieves the current color of the specified XP display element.
XPCOLOR_SHADOW_FACTOR | Retrieves the current color of the specified XP display element.
XPCOLOR_SPLITTER_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_STATICFRAME | Retrieves the current color of the specified XP display element.
XPCOLOR_TAB_INACTIVE_BACK | Retrieves the current color of the specified XP display element.
XPCOLOR_TAB_INACTIVE_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_GRIPPER | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_TEXT | Retrieves the current color of the specified XP display element.


Common Files Hierarchy

Common Files
Common Files Hierarchy

Module

Common Files


Classes

Classes, Legend, Common Files, Templates
Classes
Classes
Class
Description
CXTPBitmapDC
CXTPBitmapDC is a helper class used to select a bitmap into the device context specified by hDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPBrushDC
CXTPBrushDC is a helper class used to create a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC. When destroyed, the class selects the previous brush back into the device context to handle GDI resource cleanup.
CXTPBufferDC
CXTPBufferDC is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPBufferDCEx
CXTPBufferDCEx is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPClientCursorPos
CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates.
CXTPClientRect
CXTPClientRect is a helper class used to retrieve the client area for a specified window.
CXTPColorManager
CXTPColorManager is a stand alone class. This object is used for manipulation of RGB values.
CXTPCompatibleDC
CXTPCompatibleDC is a helper class used to create a memory device context (DC) compatible with the device specified by pDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPCriticalSection
Critical Section Wrapper
CXTPDrawHelpers
CXTPDrawHelpers is a helper class used to perform specialized drawing tasks. You can use this class to perform such tasks as gradient fills and blending colors.
CXTPEmptyRect
CXTPEmptyRect is a helper class used to instantiate an empty CRect object.
CXTPEmptySize
CXTPEmptySize is a helper class used to instantiate an empty CSize object.
CXTPFontDC
CXTPFontDC is a helper class used to select a font into the device context specified by pDC. When destroyed, the class selects the previous font back into the device context to handle GDI resource cleanup.
CXTPImageManager
CXTPImageManager is a stand alone class. It is used to manipulate icons.
CXTPImageManagerIcon
Icons holder class.
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is HICON wrapper class.
CXTPImageManagerIconSet
CXTPImageManagerIconSet represents the collection of icons for specified identifier.
CXTPLockGuard
Critical Sections Lock/Unlock helper
CXTPModuleHandle
CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods
CXTPMouseMonitor
The class CXTPMouseMonitor is a helper class that is used to monitor mouse messages for in-place controls. This class is used in XTPPropertyGridInPlaceList and XTPReportInplaceControls.
CXTPMultiMonitor
MultiMonitor API wrapper class
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and application defined colors.
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and dark gradient colors.
CXTPPenDC
CXTPPenDC is a helper class used to create a pen using the color specified by crColor. The pen is then selected into the device context specified by hDC. When destroyed, the class selects the previous pen back into the device context to handle GDI resource cleanup.
CXTPPrinterInfo
Helper class which provide currently selected printer information.
CXTPPrintOptions
This class used as a base class to store printing options. It contains a base properties and operations for printing tasks.
CXTPPrintPageHeaderFooter
This class used to define printed page header or footer. Also some calculation and drawing functionality are provided. Used as member of printing options.
CXTPPropExchange
CXTPPropExchange is standalone pure class. The CXTPPropExchange class allows you to save a complex network of objects in a permanent binary or text form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
You can use one of derived classes:

  • CXTPPropExchangeArchive to serialize to archive,
  • CXTPPropExchangeRegistry to serialize to registry key,
  • CXTPPropExchangeXMLNode to serialize to XML node.

CXTPPropExchangeArchive
CXTPPropExchangeArchive is CXTPPropExchange derived class. The CXTPPropExchangeArchive class allows you to save a complex network of objects in a permanent binary form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class. It used by CXTPPropExchange to enumerate child sections.
CXTPPropExchangeIniFile
CXTPPropExchangeIniFile is CXTPPropExchange derived class. The CXTPPropExchangeIniFile class allows you to save a complex network of objects in a ini file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeRegistry
CXTPPropExchangeRegistry is CXTPPropExchange derived class. The CXTPPropExchangeRegistry class allows you to save a complex network of objects in a system registry that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeSection
CXTPPropExchangeSection is standalone class. It is used to delete memory allocated by CXTPPropExchange::GetSection.
CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class. The CXTPPropExchangeXMLNode class allows you to save a complex network of objects in a XML file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPResourceManager
Standalone class used to managed toolkit resources.
CXTPResourceManagerXML
Class used to managed toolkit resources from XML file
CXTPSplitterTracker
CXTPSplitterTracker is a stand alone class. It is used to track a splitter rectangle.
CXTPSystemVersion
CXTPSystemVersion is a OSVERSIONINFO derived class. This class wraps the Win32 API GetVersionEx(...), used to get the current Windows OS version. CXTPSystemVersion is a single instance, or "singleton" object, that is accessed with the Get() method.
CXTPTempColorMask
CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks. When the destructor is called the default mask is reset for XTPImageManager.
CXTPToolTipContext
CXTPToolTipContext is a CCmdTarget derived class. It allows to change options for tool tips of parent object.
CXTPToolTipContextToolTip
CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips.
CXTPTransparentBitmap
CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap. Also, this class is used to convert a transparent BitMap into a transparent icon.
CXTPWindowRect
CXTPWindowRect is a helper class used to retrieve the screen size for a specified window.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API. You can use this class for rendering Windows XP themes for owner drawn controls.
Module

Common Files

Templates
Template | Description
CXTMaskEditT | CXTMaskEditT is a template class. It allows text masking to be applied to the control to format it for special editing restrictions.
CXTPNoFlickerWnd | CXTPNoFlickerWnd is a TBase derived general purpose template helper class. CXTPNoFlickerWnd class is used for drawing flicker free controls. To use, instantiate the template using any CWnd derived class. For example, to create a tab control that is flicker free you would use the following declaration:
CXTPOfficeBorder | CXTPOfficeBorder is a template class used for windows that require a thin border. This class can be used as the base class for any CWnd derived class to display an Office style non-client border.
Legend
Template


CXTMaskEditT Template

XTMaskEditT.h, Classes, Legend, Members, Topics, CXTMaskEditT Data Members, CXTMaskEditT Methods, CXTMaskEditT Constructors, CXTMaskEditT Constructors, CXTMaskEditT Data Members, CXTMaskEditT Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMaskEditT Template

CXTMaskEditT is a template class. It allows text masking to be applied to the control to format it for special editing restrictions.

Class Hierarchy

template <class TBase>
class CXTMaskEditT : public TBase;
File

XTMaskEditT.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTMaskEditT Constructors
CXTMaskEditT Constructors | Description
CXTMaskEditT | Constructs a CXTMaskEditT object
CXTMaskEditT Data Members
CXTMaskEditT Data Members | Description
m_bModified | TRUE if mask edit has been modified.
m_bOverType | TRUE to over type the text, set with VK_INSERT key press.
m_bRedo | TRUE to redo, or FALSE to undo.
m_bUpdateUndo | TRUE to update undo
m_bUseMask | TRUE to use the edit mask.
m_chPrompt | Prompt character used to identify the text entry.
m_nEndChar | Current position of the first non-selected character past the end of the current selection.
m_nStartChar | Current position of the first character in the current selection.
m_strDefault | Contains the edit controls default display text.
m_strLiteral | Literal format that restricts where the user can enter text.
m_strMask | Buffer that holds the actual edit mask value.
m_strRedoBuffer | Holds the contents of the redo buffer.
m_strUndoBuffer | Holds the contents of the undo buffer.
m_strWindowText | Buffer that holds the actual edit text.
CXTMaskEditT Methods
CXTMaskEditT Methods | Description
CanOverType | This member function is called to determine if type over has been enabled.
CanUseMask | This member function is called to determine if the mask for the edit control can be used.
CheckChar | This member function is used internally to validate the character indicated by 'nChar'.
ConvertUnicodeAlpha | Converts character to Upper/Lower case.
CopyToClipboard | Copies text to system clipboard
DeleteCharAt | Deletes character in specified position
GetMaskedText | Retrieves masked text of the control
GetPromptChar | This member function retrieves the character that is currently used as the mask prompt. The mask prompt indicates that the field is editable.
GetPromptString | This helper member function retrieves the string contains nLength prompt characters.
InsertCharAt | Inserts character to specified position.
IsModified | This member function is called to determine if the text has been modified.
MaskClear | This member function is called to clear the current text selection.
MaskCopy | This member function is called to perform a copy operation using the currently selected text.
MaskCut | This member function is called to perform a cut operation using the currently selected text.
MaskDeleteSel | This member function is called to delete the selection.
MaskPaste | This member function is called to perform a paste operation using the current clipboard text.
MaskReplaceSel | This member function is called to perform a replace operation using the currently selected text.
MaskSelectAll | This member function is called to select all text in the mask edit control.
MaskUndo | This member function is called to undo the previous action.
OnCommand | The framework calls this member function when the user selects an item from a menu
PosInRange | This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
PreTranslateMessage | Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
ProcessMask | This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
SetEditMask | This member function will set the mask for the edit control.
SetMaskedText | This method called to set masked text for the edit control.
SetOverType | This member function is called to enable or disable type over, also known as insert mode.
SetPromptChar | This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
SetUseMask | Call this member function to enable or disable the mask for the mask edit control.


CXTMaskEditT Data Members

CXTMaskEditT Template, Legend, Protected Data Members
CXTMaskEditT Data Members
Template

CXTMaskEditT Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bModified | TRUE if mask edit has been modified.
m_bOverType | TRUE to over type the text, set with VK_INSERT key press.
m_bRedo | TRUE to redo, or FALSE to undo.
m_bUpdateUndo | TRUE to update undo
m_bUseMask | TRUE to use the edit mask.
m_chPrompt | Prompt character used to identify the text entry.
m_nEndChar | Current position of the first non-selected character past the end of the current selection.
m_nStartChar | Current position of the first character in the current selection.
m_strDefault | Contains the edit controls default display text.
m_strLiteral | Literal format that restricts where the user can enter text.
m_strMask | Buffer that holds the actual edit mask value.
m_strRedoBuffer | Holds the contents of the redo buffer.
m_strUndoBuffer | Holds the contents of the undo buffer.
m_strWindowText | Buffer that holds the actual edit text.


CXTMaskEditT::m_bModified Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_bModified Data Member

TRUE if mask edit has been modified.

BOOL m_bModified;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_bOverType Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_bOverType Data Member

TRUE to over type the text, set with VK_INSERT key press.

BOOL m_bOverType;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_bRedo Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_bRedo Data Member

TRUE to redo, or FALSE to undo.

BOOL m_bRedo;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_bUpdateUndo Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_bUpdateUndo Data Member

TRUE to update undo

BOOL m_bUpdateUndo;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_bUseMask Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_bUseMask Data Member

TRUE to use the edit mask.

BOOL m_bUseMask;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_chPrompt Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_chPrompt Data Member

Prompt character used to identify the text entry.

TCHAR m_chPrompt;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_nEndChar Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_nEndChar Data Member

Current position of the first non-selected character past the end of the current selection.

int m_nEndChar;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_nStartChar Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_nStartChar Data Member

Current position of the first character in the current selection.

int m_nStartChar;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_strDefault Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_strDefault Data Member

Contains the edit controls default display text.

CString m_strDefault;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_strLiteral Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_strLiteral Data Member

Literal format that restricts where the user can enter text.

CString m_strLiteral;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_strMask Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_strMask Data Member

Buffer that holds the actual edit mask value.

CString m_strMask;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_strRedoBuffer Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_strRedoBuffer Data Member

Holds the contents of the redo buffer.

CString m_strRedoBuffer;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_strUndoBuffer Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_strUndoBuffer Data Member

Holds the contents of the undo buffer.

CString m_strUndoBuffer;
Group

CXTMaskEditT Data Members


CXTMaskEditT::m_strWindowText Data Member

CXTMaskEditT Data Members, CXTMaskEditT Template
CXTMaskEditT::m_strWindowText Data Member

Buffer that holds the actual edit text.

CString m_strWindowText;
Group

CXTMaskEditT Data Members


CXTMaskEditT Methods

CXTMaskEditT Template, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMaskEditT Methods
Template

CXTMaskEditT Template

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnCommand | The framework calls this member function when the user selects an item from a menu
Public Methods
Public Methods
Public Method | Description
CanOverType | This member function is called to determine if type over has been enabled.
CanUseMask | This member function is called to determine if the mask for the edit control can be used.
CheckChar | This member function is used internally to validate the character indicated by 'nChar'.
ConvertUnicodeAlpha | Converts character to Upper/Lower case.
CopyToClipboard | Copies text to system clipboard
DeleteCharAt | Deletes character in specified position
GetMaskedText | Retrieves masked text of the control
GetPromptChar | This member function retrieves the character that is currently used as the mask prompt. The mask prompt indicates that the field is editable.
GetPromptString | This helper member function retrieves the string contains nLength prompt characters.
InsertCharAt | Inserts character to specified position.
IsModified | This member function is called to determine if the text has been modified.
MaskClear | This member function is called to clear the current text selection.
MaskCopy | This member function is called to perform a copy operation using the currently selected text.
MaskCut | This member function is called to perform a cut operation using the currently selected text.
MaskDeleteSel | This member function is called to delete the selection.
MaskPaste | This member function is called to perform a paste operation using the current clipboard text.
MaskReplaceSel | This member function is called to perform a replace operation using the currently selected text.
MaskSelectAll | This member function is called to select all text in the mask edit control.
MaskUndo | This member function is called to undo the previous action.
PosInRange | This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
PreTranslateMessage | Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
ProcessMask | This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
SetEditMask | This member function will set the mask for the edit control.
SetMaskedText | This method called to set masked text for the edit control.
SetOverType | This member function is called to enable or disable type over, also known as insert mode.
SetPromptChar | This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
SetUseMask | Call this member function to enable or disable the mask for the mask edit control.


CXTMaskEditT::CanOverType Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::CanOverType Method

This member function is called to determine if type over has been enabled.

BOOL CanOverType() const;
Returns

TRUE if type over is enabled, otherwise returns FALSE.

Body Source
BOOL CanOverType() const {
    return m_bOverType;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::CanUseMask Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::CanUseMask Method

This member function is called to determine if the mask for the edit control can be used.

BOOL CanUseMask() const;
Returns

TRUE if the mask can be used, otherwise returns FALSE.

Body Source
BOOL CanUseMask() const {
    return m_bUseMask && m_hWnd && ((GetStyle() & ES_READONLY) == 0) && !m_strMask.IsEmpty();
}
Group

CXTMaskEditT Methods


CXTMaskEditT::CheckChar Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::CheckChar Method

This member function is used internally to validate the character indicated by 'nChar'.

virtual BOOL CheckChar(
    TCHAR& nChar,
    int nPos
);
Parameters

nChar
Contains the character code value of the key.
nPos
Sting length.

Returns

TRUE if successful, otherwise returns FALSE.

Body Source
virtual BOOL CheckChar(TCHAR& nChar, int nPos)
{
    // do not use mask
    if (!CanUseMask())
        return FALSE;

    // control character, OK
    if (!IsPrintChar(nChar))
        return TRUE;

    // make sure the string is not longer than the mask
    if (nPos >= m_strMask.GetLength())
        return FALSE;

    if (!IsPromptPos(nPos))
        return FALSE;

    return ProcessMask(nChar, nPos);
}
Group

CXTMaskEditT Methods


CXTMaskEditT::ConvertUnicodeAlpha Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::ConvertUnicodeAlpha Method

Converts character to Upper/Lower case.

TCHAR ConvertUnicodeAlpha(
    TCHAR nChar,
    BOOL bUpperCase
) const;
Parameters

nChar
Char to be converted
bUpperCase
TRUE to convert to upper case

Returns

Converted character.

Body Source
TCHAR ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const
{
    CString strTemp(nChar);
    if (bUpperCase) strTemp.MakeUpper(); else strTemp.MakeLower();
    return strTemp[0];
}
Group

CXTMaskEditT Methods


CXTMaskEditT::CopyToClipboard Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::CopyToClipboard Method

Copies text to system clipboard

BOOL CopyToClipboard(
    const CString& strText
);
Parameters

strText
Text to be copied

Returns

TRUE if successful; otherwise returns FALSE

Body Source
BOOL CopyToClipboard(const CString& strText)
{
    if (!OpenClipboard())
        return FALSE;

    ::EmptyClipboard();

    int iLen = (strText.GetLength() + 1) * sizeof(TCHAR);

    HGLOBAL hglbCopy = ::GlobalAlloc(GMEM_MOVEABLE, iLen);

    if (hglbCopy == NULL)
    {
        ::CloseClipboard();
        return FALSE;
    }

    LPTSTR lptstrCopy = (TCHAR*)GlobalLock(hglbCopy);
    STRCPY_S(lptstrCopy, strText.GetLength() + 1, (LPCTSTR)strText);
    GlobalUnlock(hglbCopy);

#ifndef _UNICODE
    ::SetClipboardData(CF_TEXT, hglbCopy);
#else
    ::SetClipboardData(CF_UNICODETEXT, hglbCopy);
#endif

    if (!::CloseClipboard())
        return FALSE;

    return TRUE;

}
Group

CXTMaskEditT Methods


CXTMaskEditT::DeleteCharAt Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::DeleteCharAt Method

Deletes character in specified position

void DeleteCharAt(
    int iPos
);
Parameters

iPos
Position for character to be deleted.

Body Source
void DeleteCharAt(int iPos)
{
    ASSERT(PosInRange(iPos));

    if (!PosInRange(iPos))
        return;

    CString strMaskedText = GetMaskedText(iPos + 1) + m_chPrompt;

    SetMaskedText(strMaskedText, iPos, FALSE);
}
Group

CXTMaskEditT Methods


CXTMaskEditT::GetMaskedText Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::GetMaskedText Method

Retrieves masked text of the control

CString GetMaskedText(
    int nStartPos = 0,
    int nEndPos = -1
) const;
Parameters

nStartPos
Start position
nEndPos
End position

Returns

Masked text of the control.

Body Source
CString GetMaskedText(int nStartPos = 0, int nEndPos = -1) const
{
    if (nEndPos == -1)
        nEndPos = m_strWindowText.GetLength();
    else
        nEndPos = min(nEndPos, m_strWindowText.GetLength());

    CString strBuffer;

    for (int i = nStartPos; i < nEndPos; ++i)
    {
        if (IsPromptPos(i))
        {
            strBuffer += m_strWindowText[i];
        }
    }

    return strBuffer;

}
Group

CXTMaskEditT Methods


CXTMaskEditT::GetPromptChar Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::GetPromptChar Method

This member function retrieves the character that is currently used as the mask prompt. The mask prompt indicates that the field is editable.

TCHAR GetPromptChar() const;
Returns

A TCHAR data type.

Body Source
TCHAR GetPromptChar() const {
    return m_chPrompt;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::GetPromptString Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::GetPromptString Method

This helper member function retrieves the string contains nLength prompt characters.

CString GetPromptString(
    int nLength
) const;
Parameters

nLength
Length of string to create.

Returns

CString contains nLength prompt characters

Body Source
CString GetPromptString(int nLength) const {
    CString strPrompt;

    while (nLength--)
        strPrompt += m_chPrompt;

    return strPrompt;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::InsertCharAt Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::InsertCharAt Method

Inserts character to specified position.

void InsertCharAt(
    int iPos,
    TCHAR nChar
);
Parameters

iPos
Position to insert
nChar
Character to be inserted

Body Source
void InsertCharAt(int iPos, TCHAR nChar)
{
    ASSERT(PosInRange(iPos));

    if (!PosInRange(iPos))
        return;

    CString strMaskedText = CString(nChar) + GetMaskedText(iPos);

    SetMaskedText(strMaskedText, iPos, FALSE);
}
Group

CXTMaskEditT Methods


CXTMaskEditT::IsModified Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::IsModified Method

This member function is called to determine if the text has been modified.

BOOL IsModified() const;
Returns

TRUE if the text has changed, otherwise returns FALSE.

Body Source
BOOL IsModified() const {
    return m_bModified;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::MaskClear Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::MaskClear Method

This member function is called to clear the current text selection.

afx_msg BOOL MaskClear();
Body Source
afx_msg BOOL MaskClear()
{
    if (!CanUseMask())
        return (BOOL)DefWindowProc(WM_CLEAR, 0, 0);

    GetMaskState();

    MaskDeleteSel();

    SetMaskState();

    return TRUE;

}
Group

CXTMaskEditT Methods


CXTMaskEditT::MaskCopy Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::MaskCopy Method

This member function is called to perform a copy operation using the currently selected text.

afx_msg BOOL MaskCopy();
Body Source
afx_msg BOOL MaskCopy()
{
    if (!CanUseMask())
        return (BOOL)DefWindowProc(WM_COPY, 0, 0);

    GetMaskState();

    CString strMaskedText = GetMaskedText(m_nStartChar, m_nEndChar);
    CopyToClipboard(strMaskedText);

    return TRUE;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::MaskCut Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::MaskCut Method

This member function is called to perform a cut operation using the currently selected text.

afx_msg BOOL MaskCut();
Body Source
afx_msg BOOL MaskCut()
{
    if (!CanUseMask())
        return (BOOL)DefWindowProc(WM_CUT, 0, 0);

    MaskCopy();
    MaskClear();

    return TRUE;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::MaskDeleteSel Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::MaskDeleteSel Method

This member function is called to delete the selection.

void MaskDeleteSel();
Body Source
void MaskDeleteSel()
{
    if (m_nStartChar == m_nEndChar)
        return;

    CString strMaskedText = GetMaskedText(m_nEndChar);
    SetMaskedText(strMaskedText, m_nStartChar, FALSE);

    m_nEndChar = m_nStartChar;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::MaskPaste Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::MaskPaste Method

This member function is called to perform a paste operation using the current clipboard text.

afx_msg BOOL MaskPaste();
Body Source
afx_msg BOOL MaskPaste()
{
    if (!CanUseMask())
        return (BOOL)DefWindowProc(WM_PASTE, 0, 0);

    GetMaskState();

    if (!OpenClipboard())
        return FALSE;

#ifndef _UNICODE
    HGLOBAL hglbPaste = ::GetClipboardData(CF_TEXT);
#else
    HGLOBAL hglbPaste = ::GetClipboardData(CF_UNICODETEXT);
#endif

    if (hglbPaste != NULL)
    {
        TCHAR* lpszClipboard = (TCHAR*)GlobalLock(hglbPaste);

        MaskReplaceSel(lpszClipboard);

        GlobalUnlock(hglbPaste);

        SetMaskState();
    }
    ::CloseClipboard();

    return TRUE;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::MaskReplaceSel Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::MaskReplaceSel Method

This member function is called to perform a replace operation using the currently selected text.

void MaskReplaceSel(
    LPCTSTR lpszNewText
);
Parameters

lpszNewText
Text to replace.

Body Source
void MaskReplaceSel(LPCTSTR lpszNewText)
{

    ASSERT(CanUseMask());

    if (m_nStartChar != m_nEndChar)
        MaskDeleteSel();

    int x = m_nStartChar, nNewTextLen = (int)_tcslen(lpszNewText);
    int nWindowTextLen = m_strWindowText.GetLength();

    if (x >= nWindowTextLen)
        return;

    for (int i = 0; i < nNewTextLen; ++i)
    {
        TCHAR ch = lpszNewText[i];

        if (ch == m_chPrompt || CheckChar(ch, x))
        {
            InsertCharAt(x, ch);
            x++;

            while (x < nWindowTextLen && !IsPromptPos(x))
                x++;

            if (x >= m_strWindowText.GetLength())
                break;
        }
    }
    CorrectPosition(x);
    m_nStartChar = m_nEndChar = x;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::MaskSelectAll Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::MaskSelectAll Method

This member function is called to select all text in the mask edit control.

afx_msg void MaskSelectAll();
Body Source
afx_msg void MaskSelectAll()
{
    if (!CanUseMask())
    {
        SetSel(0, -1);
    }
    else
    {
        m_nStartChar = 0;
        CorrectPosition(m_nStartChar);
        SetSel(m_nStartChar, -1);
    }
}
Group

CXTMaskEditT Methods


CXTMaskEditT::MaskUndo Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::MaskUndo Method

This member function is called to undo the previous action.

afx_msg BOOL MaskUndo();
Body Source
afx_msg BOOL MaskUndo()
{
    if (!CanUseMask())
    {
        return (BOOL)DefWindowProc(EM_UNDO, 0, 0);
    }
    else
    {
        MaskGetSel();

        if (m_bRedo)
        {
            SetWindowText(m_strRedoBuffer);
        }
        else
        {
            GetWindowText(m_strRedoBuffer);
            SetWindowText(m_strUndoBuffer);
        }

        m_bRedo = !m_bRedo;
        m_bModified = TRUE;

        m_nEndChar = m_nStartChar;
        SetSel(m_nStartChar, m_nEndChar);
    }

    return TRUE;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::OnCommand Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::OnCommand Method

The framework calls this member function when the user selects an item from a menu

virtual BOOL OnCommand(
    WPARAM wParam,
    LPARAM lParam
);
Parameters

wParam
The low-order word of wParam identifies the command ID of the menu item, control, or accelerator. The high-order word of wParam specifies the notification message if the message is from a control. If the message is from an accelerator, the high-order word is 1. If the message is from a menu, the high-order word is 0
lParam
Identifies the control that sends the message if the message is from a control. Otherwise, lParam is 0.

Returns

An application returns nonzero if it processes this message; otherwise 0.

Body Source
virtual BOOL OnCommand(WPARAM wParam, LPARAM lParam)
{
    switch (LOWORD(wParam))
    {
        case ID_EDIT_CUT:
            MaskCut();
            return TRUE;

        case ID_EDIT_COPY:
            MaskCopy();
            return TRUE;

        case ID_EDIT_PASTE:
            MaskPaste();
            return TRUE;

        case ID_EDIT_CLEAR:
            MaskClear();
            return TRUE;

        case ID_EDIT_UNDO:
            MaskUndo();
            return TRUE;

        case ID_EDIT_SELECT_ALL:
            MaskSelectAll();
            return TRUE;
    }
    return TBase::OnCommand(wParam, lParam);
}
Group

CXTMaskEditT Methods


CXTMaskEditT::PosInRange Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::PosInRange Method

This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.

BOOL PosInRange(
    int iPos
) const;
Parameters

iPos
Index of the character to check.

Returns

TRUE if the index is valid, otherwise returns FALSE.

Body Source
BOOL PosInRange(int iPos) const {
    return ((iPos >= 0) && (iPos < m_strLiteral.GetLength()));
}
Group

CXTMaskEditT Methods


CXTMaskEditT::PreTranslateMessage Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::PreTranslateMessage Method

Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.

virtual BOOL PreTranslateMessage(
    MSG* pMsg
);
Parameters

pMsg
Points to a MSG structure that contains the message to process.

Returns

Nonzero if the message was translated and should not be dispatched; 0 if the message was not translated and should be dispatched.

Body Source
virtual BOOL PreTranslateMessage(MSG* pMsg)
{
    if (!CanUseMask())
        return TBase::PreTranslateMessage(pMsg);

    // intercept Ctrl+C (copy), Ctrl+V (paste), Ctrl+X (cut) and Ctrl+Z (undo)
    // before CEdit base class gets a hold of them.

    if (pMsg->message == WM_KEYDOWN)
    {
        if (::GetKeyState(VK_SUBTRACT) < 0)
        {
            OnChar('-', 1, 1);
            return TRUE;
        }

        if (::GetKeyState(VK_ADD) < 0)
        {
            OnChar('+', 1, 1);
            return TRUE;
        }

        if (::GetKeyState(VK_CONTROL) < 0)
        {
            switch (pMsg->wParam)
            {
            case 'X':
            case 'x':
                {
                    MaskCut();
                    return TRUE;
                }

            case 'C':
            case 'c':
                {
                    MaskCopy();
                    return TRUE;
                }

            case 'V':
            case 'v':
                {
                    MaskPaste();
                    return TRUE;
                }

            case 'Z':
            case 'z':
                {
                    MaskUndo();
                    return TRUE;
                }
            }
        }

    }

    return TBase::PreTranslateMessage(pMsg);

}
Group

CXTMaskEditT Methods


CXTMaskEditT::ProcessMask Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::ProcessMask Method

This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.

virtual BOOL ProcessMask(
    TCHAR& nChar,
    int nEndPos
);
Parameters

nChar
Contains the character code value of the key.
nEndPos
Index of character in display string.

Returns

TRUE if successful, otherwise returns FALSE.

Body Source
virtual BOOL ProcessMask(TCHAR& nChar, int nEndPos)
{
    ASSERT(nEndPos < m_strMask.GetLength());
    if (nEndPos < 0 || nEndPos >= m_strMask.GetLength())
        return FALSE;

    // check the key against the mask
    switch (m_strMask.GetAt(nEndPos))
    {
    case '0':       // digit only //completely changed this
        return _istdigit(nChar);

    case '9':       // digit or space
        return _istdigit(nChar) || _istspace(nChar);

    case '#':       // digit or space or '+' or '-'
        return _istdigit(nChar) || (_istspace(nChar) || nChar == _T('-') || nChar == _T('+'));

    case 'd':       // decimal
        return _istdigit(nChar) || (_istspace(nChar) || nChar == _T('-') || nChar == _T('+') || nChar == _T('.') || nChar == _T(','));

    case 'L':       // alpha only
        return IsAlphaChar(nChar);

    case '?':       // alpha or space
        return IsAlphaChar(nChar) || _istspace(nChar);

    case 'A':       // alpha numeric only
        return _istalnum(nChar) || IsAlphaChar(nChar);

    case 'a':       // alpha numeric or space
        return _istalnum(nChar) || IsAlphaChar(nChar) || _istspace(nChar);

    case '&':       // all print character only
        return IsPrintChar(nChar);

    case 'H':       // hex digit
        return _istxdigit(nChar);

    case 'X':       // hex digit or space
        return _istxdigit(nChar) || _istspace(nChar);

    case '>':
        if (IsAlphaChar(nChar))
        {
            nChar = ConvertUnicodeAlpha(nChar, TRUE);
            return TRUE;
        }
        return FALSE;

    case '<':
        if (IsAlphaChar(nChar))
        {
            nChar = ConvertUnicodeAlpha(nChar, FALSE);
            return TRUE;
        }
        return FALSE;
    }

    return FALSE;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::SetEditMask Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::SetEditMask Method

This member function will set the mask for the edit control.

virtual BOOL SetEditMask(
    LPCTSTR lpszMask,
    LPCTSTR lpszLiteral,
    LPCTSTR lpszDefault = NULL
);
Parameters

lpszMask
The format for the mask field. For example, if you wanted to set the mask for a phone number, and you only wanted digits to be entered, your mask might look like this; _T("(000) 000-0000").
lpszLiteral
The literal format is entered here. Wherever you place an underscore ('_') is where the user will be allowed to enter data only. Using the phone number example; _T("(___) ___-____").
lpszDefault
Text that is to be displayed when the control is initialized. For example; _T("(800) 555-1212"). If NULL, 'lpszLiteral' is used to initialize the edit text.

Remarks

The values that can be set are:

Mask Character | Description
0 | Numeric (0-9)
9 | Numeric (0-9) or space (' ')
# | Numeric (0-9) or space (' ') or ('+') or ('-')
L | Alpha (a-Z)
? | Alpha (a-Z) or space (' ')
A | Alpha numeric (0-9 and a-Z)
a | Alpha numeric (0-9 and a-Z) or space (' ')
& | All print character only
H | Hex digit (0-9 and A-F)
X | Hex digit (0-9 and A-F) and space (' ')
> | Forces characters to upper case (A-Z)
< | Forces characters to lower case (a-z)
Body Source
virtual BOOL SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
{
    ASSERT(lpszMask);
    ASSERT(lpszLiteral);

    // initialize the mask for the control.
    m_strMask    = lpszMask;
    m_strLiteral = lpszLiteral;

    ASSERT(m_strMask.GetLength() == m_strLiteral.GetLength());

    if (m_strMask.GetLength() != m_strLiteral.GetLength())
        return FALSE;

    if (lpszDefault == NULL)
    {
        m_strWindowText = m_strDefault = lpszLiteral;
    }
    else
    {
        m_strWindowText = m_strDefault = lpszDefault;

        if (m_strDefault.GetLength() != m_strLiteral.GetLength())
        {
            SetMaskedText(m_strDefault, 0, FALSE);
            m_strDefault = m_strWindowText;
        }
    }

    ASSERT(m_strWindowText.GetLength() == m_strLiteral.GetLength());

    // set the window text for the control.
    m_bRedo = FALSE;
    m_bModified = FALSE;
    SetWindowText(m_strWindowText);

    m_strUndoBuffer = m_strWindowText;
    return TRUE;

}
Group

CXTMaskEditT Methods


CXTMaskEditT::SetMaskedText Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::SetMaskedText Method

This method called to set masked text for the edit control.

void SetMaskedText(
    LPCTSTR lpszMaskedText,
    int iPos = 0,
    BOOL bUpdateWindow = TRUE
);
Parameters

lpszMaskedText
Text string without mask.
iPos
Start position from which current masked text will be updated. Default value 0 (the first position).
bUpdateWindow
If TRUE - edit control window text and selection will be updated, otherwise only internal members take changes.

Remarks

If a mask is used, then the mask will be applied to the text in lpszMaskedText.

Body Source
void SetMaskedText(LPCTSTR lpszMaskedText, int iPos = 0, BOOL bUpdateWindow = TRUE)
{
    int nMaskedTextLength = (int)_tcslen(lpszMaskedText);

    m_strWindowText = m_strWindowText.Left(iPos);
    int nIndex = 0;

    for (; (iPos <  m_strLiteral.GetLength()) && (nIndex < nMaskedTextLength) ; iPos++)
    {
        TCHAR uChar = lpszMaskedText[nIndex];

        if (IsPromptPos(iPos) && ((uChar == m_chPrompt) || ProcessMask(uChar, iPos)))
        {
            m_strWindowText += (TCHAR)uChar;
            nIndex ++;
        }
        else
        {
            m_strWindowText += m_strLiteral[iPos];
        }
    }

    if (bUpdateWindow)
    {
        SetMaskState(FALSE);
    }
    else
    {
        CorrectWindowText();
    }
}
Group

CXTMaskEditT Methods


CXTMaskEditT::SetOverType Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::SetOverType Method

This member function is called to enable or disable type over, also known as insert mode.

void SetOverType(
    BOOL bOverType
);
Parameters

bOverType
TRUE to enable type over.

Body Source
void SetOverType(BOOL bOverType) {
    m_bOverType = bOverType;
}
Group

CXTMaskEditT Methods


CXTMaskEditT::SetPromptChar Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::SetPromptChar Method

This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.

void SetPromptChar(
    TCHAR ch,
    BOOL bAutoReplace = TRUE
);
Parameters

ch
A TCHAR data type.
bAutoReplace
TRUE to auto replace

Body Source
void SetPromptChar(TCHAR ch, BOOL bAutoReplace = TRUE)
{
    if (m_chPrompt == ch)
        return;

    if (bAutoReplace)
    {
        GetMaskState();

        for (int i = 0; i < m_strLiteral.GetLength(); i++)
            if (m_strLiteral[i] == m_chPrompt) m_strLiteral.SetAt(i, ch);

        for (int j = 0; j < m_strWindowText.GetLength(); j++)
            if (m_strWindowText[j] == m_chPrompt) m_strWindowText.SetAt(j, ch);

        SetMaskState();
    }

    m_chPrompt = ch;

}
Group

CXTMaskEditT Methods


CXTMaskEditT::SetUseMask Method

CXTMaskEditT Methods, CXTMaskEditT Template, Body Source
CXTMaskEditT::SetUseMask Method

Call this member function to enable or disable the mask for the mask edit control.

void SetUseMask(
    BOOL bUseMask
);
Parameters

bUseMask
TRUE to enable the mask. FALSE to disable the mask.

Body Source
void SetUseMask(BOOL bUseMask) {
    m_bUseMask = bUseMask;
}
Group

CXTMaskEditT Methods


CXTMaskEditT Constructors

CXTMaskEditT Template, Legend, Public Methods
CXTMaskEditT Constructors
Template

CXTMaskEditT Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTMaskEditT | Constructs a CXTMaskEditT object


CXTMaskEditT::CXTMaskEditT Constructor

CXTMaskEditT Constructors, CXTMaskEditT Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTMaskEditT::CXTMaskEditT Constructor

Constructs a CXTMaskEditT object

CXTMaskEditT();
Body Source
CXTMaskEditT()
    : m_nStartChar(0)
    , m_nEndChar(0)
    , m_bOverType(FALSE)
    , m_bUseMask(TRUE)
    , m_bRedo(FALSE)
    , m_bModified(FALSE)
    , m_strWindowText(_T(""))
    , m_strMask(_T(""))
    , m_strLiteral(_T(""))
    , m_strDefault(_T(""))
    , m_strUndoBuffer(_T(""))
    , m_chPrompt(_T('_'))
    , m_bUpdateUndo(TRUE)
{
}
Group

CXTMaskEditT Constructors


CXTPBitmapDC Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPBitmapDC Data Members, CXTPBitmapDC Methods, CXTPBitmapDC Constructors, CXTPBitmapDC Destructors, CXTPBitmapDC Constructors, CXTPBitmapDC Data Members, CXTPBitmapDC Destructors, CXTPBitmapDC Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPBitmapDC Class

CXTPBitmapDC is a helper class used to select a bitmap into the device context specified by hDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.

Class Hierarchy

class CXTPBitmapDC;
File

XTPDrawHelpers.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPBitmapDC Constructors
CXTPBitmapDC Constructors | Description
CXTPBitmapDC |
CXTPBitmapDC Data Members
CXTPBitmapDC Data Members | Description
m_hDC | Device context handle.
m_hOldBitmap | Handle to the previously selected bitmap.
CXTPBitmapDC Destructors
CXTPBitmapDC Destructors | Description
~CXTPBitmapDC | Destroys a CXTPBitmapDC object, handles cleanup and de- allocation.
CXTPBitmapDC Methods
CXTPBitmapDC Methods | Description
SetBitmap | Call this member function to change the bitmap selected by the device context.


CXTPBitmapDC Data Members

CXTPBitmapDC Class, Legend, Protected Data Members
CXTPBitmapDC Data Members
Class

CXTPBitmapDC Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hDC | Device context handle.
m_hOldBitmap | Handle to the previously selected bitmap.


CXTPBitmapDC::m_hDC Data Member

CXTPBitmapDC Data Members, CXTPBitmapDC Class
CXTPBitmapDC::m_hDC Data Member

Device context handle.

HDC m_hDC;
Group

CXTPBitmapDC Data Members


CXTPBitmapDC::m_hOldBitmap Data Member

CXTPBitmapDC Data Members, CXTPBitmapDC Class
CXTPBitmapDC::m_hOldBitmap Data Member

Handle to the previously selected bitmap.

HGDIOBJ m_hOldBitmap;
Group

CXTPBitmapDC Data Members


CXTPBitmapDC Methods

CXTPBitmapDC Class, Legend, Public Methods
CXTPBitmapDC Methods
Class

CXTPBitmapDC Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetBitmap | Call this member function to change the bitmap selected by the device context.


CXTPBitmapDC::SetBitmap Method

CXTPBitmapDC Methods, CXTPBitmapDC Class
CXTPBitmapDC::SetBitmap Method

Call this member function to change the bitmap selected by the device context.

void SetBitmap(
    CBitmap* pBitmap
);
Parameters

pBitmap
Pointer to a CBitmap object to select into the device context.

Group

CXTPBitmapDC Methods


CXTPBitmapDC Constructors

CXTPBitmapDC Class, Legend, Public Methods
CXTPBitmapDC Constructors
Class

CXTPBitmapDC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPBitmapDC |


CXTPBitmapDC Constructor

CXTPBitmapDC Constructors
CXTPBitmapDC Constructor
Overload List
Constructors
Constructor | Description
CXTPBitmapDC::CXTPBitmapDC (CDC*, CBitmap*) | Constructs a CXTPBitmapDC object and selects the specified bitmap into the device context specified by pDC.
CXTPBitmapDC::CXTPBitmapDC (CDC*, HBITMAP) | Constructs a CXTPBitmapDC object and selects the specified bitmap into the device context specified by pDC.
Group

CXTPBitmapDC Constructors


CXTPBitmapDC::CXTPBitmapDC Constructor (CDC*, CBitmap*)

CXTPBitmapDC Constructor, CXTPBitmapDC Class
CXTPBitmapDC::CXTPBitmapDC Constructor (CDC*, CBitmap*)

Constructs a CXTPBitmapDC object and selects the specified bitmap into the device context specified by pDC.

CXTPBitmapDC(
    CDC* pDC,
    CBitmap* pBitmap
);
CXTPBitmapDC(
    CDC* pDC,
    HBITMAP hBitmap
);
Parameters

pDC
Pointer to a valid device context.
pBitmap
Pointer to a CBitmap object to select into the device context.
hBitmap
Bitmap handle

Group

CXTPBitmapDC Constructor


CXTPBitmapDC Destructors

CXTPBitmapDC Class, Legend, Public Methods
CXTPBitmapDC Destructors
Class

CXTPBitmapDC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPBitmapDC | Destroys a CXTPBitmapDC object, handles cleanup and de- allocation.


CXTPBitmapDC::~CXTPBitmapDC Destructor

CXTPBitmapDC Destructors, CXTPBitmapDC Class
CXTPBitmapDC::~CXTPBitmapDC Destructor

Destroys a CXTPBitmapDC object, handles cleanup and de- allocation.

virtual ~CXTPBitmapDC();
Group

CXTPBitmapDC Destructors


CXTPBrushDC Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPBrushDC Data Members, CXTPBrushDC Methods, CXTPBrushDC Constructors, CXTPBrushDC Destructors, CXTPBrushDC Constructors, CXTPBrushDC Data Members, CXTPBrushDC Destructors, CXTPBrushDC Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPBrushDC Class

CXTPBrushDC is a helper class used to create a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC. When destroyed, the class selects the previous brush back into the device context to handle GDI resource cleanup.

Class Hierarchy

class CXTPBrushDC;
File

XTPDrawHelpers.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPBrushDC Constructors
CXTPBrushDC Constructors | Description
CXTPBrushDC | Constructs a CXTPBrushDC object and creates a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC.
CXTPBrushDC Data Members
CXTPBrushDC Data Members | Description
m_brush | Brush selected into device context.
m_hDC | Device context handle.
m_hOldBrush | Handle to the previously selected brush.
CXTPBrushDC Destructors
CXTPBrushDC Destructors | Description
~CXTPBrushDC | Destroys a CXTPBrushDC object, handles cleanup and de- allocation.
CXTPBrushDC Methods
CXTPBrushDC Methods | Description
Color | Call this member function to change the color used by the device context brush.


CXTPBrushDC Data Members

CXTPBrushDC Class, Legend, Protected Data Members
CXTPBrushDC Data Members
Class

CXTPBrushDC Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_brush | Brush selected into device context.
m_hDC | Device context handle.
m_hOldBrush | Handle to the previously selected brush.


CXTPBrushDC::m_brush Data Member

CXTPBrushDC Data Members, CXTPBrushDC Class
CXTPBrushDC::m_brush Data Member

Brush selected into device context.

CBrush m_brush;
Group

CXTPBrushDC Data Members


CXTPBrushDC::m_hDC Data Member

CXTPBrushDC Data Members, CXTPBrushDC Class
CXTPBrushDC::m_hDC Data Member

Device context handle.

HDC m_hDC;
Group

CXTPBrushDC Data Members


CXTPBrushDC::m_hOldBrush Data Member

CXTPBrushDC Data Members, CXTPBrushDC Class
CXTPBrushDC::m_hOldBrush Data Member

Handle to the previously selected brush.

HBRUSH m_hOldBrush;
Group

CXTPBrushDC Data Members


CXTPBrushDC Methods

CXTPBrushDC Class, Legend, Public Methods
CXTPBrushDC Methods
Class

CXTPBrushDC Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Color | Call this member function to change the color used by the device context brush.


CXTPBrushDC::Color Method

CXTPBrushDC Methods, CXTPBrushDC Class
CXTPBrushDC::Color Method

Call this member function to change the color used by the device context brush.

void Color(
    COLORREF crColor
);
Parameters

crColor
RGB value to change the brush color to.

Group

CXTPBrushDC Methods


CXTPBrushDC Constructors

CXTPBrushDC Class, Legend, Public Methods
CXTPBrushDC Constructors
Class

CXTPBrushDC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPBrushDC | Constructs a CXTPBrushDC object and creates a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC.


CXTPBrushDC::CXTPBrushDC Constructor

CXTPBrushDC Constructors, CXTPBrushDC Class
CXTPBrushDC::CXTPBrushDC Constructor

Constructs a CXTPBrushDC object and creates a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC.

CXTPBrushDC(
    HDC hDC,
    COLORREF crColor
);
Parameters

hDC
Handle to a valid device context.
crColor
RGB value used to create brush.

Group

CXTPBrushDC Constructors


CXTPBrushDC Destructors

CXTPBrushDC Class, Legend, Public Methods
CXTPBrushDC Destructors
Class

CXTPBrushDC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPBrushDC | Destroys a CXTPBrushDC object, handles cleanup and de- allocation.


CXTPBrushDC::~CXTPBrushDC Destructor

CXTPBrushDC Destructors, CXTPBrushDC Class
CXTPBrushDC::~CXTPBrushDC Destructor

Destroys a CXTPBrushDC object, handles cleanup and de- allocation.

virtual ~CXTPBrushDC();
Group

CXTPBrushDC Destructors


CXTPBufferDC Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPBufferDC Data Members, CXTPBufferDC Methods, CXTPBufferDC Constructors, CXTPBufferDC Destructors, CXTPBufferDC Constructors, CXTPBufferDC Data Members, CXTPBufferDC Destructors, CXTPBufferDC Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPBufferDC Class

CXTPBufferDC is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.

Class Hierarchy

class CXTPBufferDC : public CDC;
File

XTPDrawHelpers.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPBufferDC Constructors
CXTPBufferDC Constructors | Description
CXTPBufferDC |
CXTPBufferDC Data Members
CXTPBufferDC Data Members | Description
m_bitmap | Bitmap in memory device context
m_hDestDC | Handle to the destination device context.
m_hOldBitmap | Handle to the previously selected bitmap.
m_rect | Size of the area to paint.
CXTPBufferDC Destructors
CXTPBufferDC Destructors | Description
~CXTPBufferDC | Destroys a CXTPBufferDC object, handles cleanup and de- allocation.
CXTPBufferDC Methods
CXTPBufferDC Methods | Description
Discard | This member function is called to set the valid flag to false so that the off screen device context will not be drawn.
GetDestDC | Call this method to retrieve a CDC pointer to the destination device context.


CXTPBufferDC Data Members

CXTPBufferDC Class, Legend, Protected Data Members
CXTPBufferDC Data Members
Class

CXTPBufferDC Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bitmap | Bitmap in memory device context
m_hDestDC | Handle to the destination device context.
m_hOldBitmap | Handle to the previously selected bitmap.
m_rect | Size of the area to paint.


CXTPBufferDC::m_bitmap Data Member

CXTPBufferDC Data Members, CXTPBufferDC Class
CXTPBufferDC::m_bitmap Data Member

Bitmap in memory device context

CBitmap m_bitmap;
Group

CXTPBufferDC Data Members


CXTPBufferDC::m_hDestDC Data Member

CXTPBufferDC Data Members, CXTPBufferDC Class
CXTPBufferDC::m_hDestDC Data Member

Handle to the destination device context.

HDC m_hDestDC;
Group

CXTPBufferDC Data Members


CXTPBufferDC::m_hOldBitmap Data Member

CXTPBufferDC Data Members, CXTPBufferDC Class
CXTPBufferDC::m_hOldBitmap Data Member

Handle to the previously selected bitmap.

HGDIOBJ m_hOldBitmap;
Group

CXTPBufferDC Data Members


CXTPBufferDC::m_rect Data Member

CXTPBufferDC Data Members, CXTPBufferDC Class
CXTPBufferDC::m_rect Data Member

Size of the area to paint.

CRect m_rect;
Group

CXTPBufferDC Data Members


CXTPBufferDC Methods

CXTPBufferDC Class, Legend, Public Methods
CXTPBufferDC Methods
Class

CXTPBufferDC Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Discard | This member function is called to set the valid flag to false so that the off screen device context will not be drawn.
GetDestDC | Call this method to retrieve a CDC pointer to the destination device context.


CXTPBufferDC::Discard Method

CXTPBufferDC Methods, CXTPBufferDC Class
CXTPBufferDC::Discard Method

This member function is called to set the valid flag to false so that the off screen device context will not be drawn.

void Discard();
Group

CXTPBufferDC Methods


CXTPBufferDC::GetDestDC Method

CXTPBufferDC Methods, CXTPBufferDC Class
CXTPBufferDC::GetDestDC Method

Call this method to retrieve a CDC pointer to the destination device context.

CDC* GetDestDC();
Group

CXTPBufferDC Methods


CXTPBufferDC Constructors

CXTPBufferDC Class, Legend, Public Methods
CXTPBufferDC Constructors
Class

CXTPBufferDC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPBufferDC |


CXTPBufferDC Constructor

CXTPBufferDC Constructors
CXTPBufferDC Constructor
Overload List
Constructors
Constructor | Description
CXTPBufferDC::CXTPBufferDC (CPaintDC&) | Constructs a CXTPBufferDC object used to create a memory device context used to draw to an off-screen bitmap.
CXTPBufferDC::CXTPBufferDC (HDC, const CRect&) | Constructs a CXTPBufferDC object used to create a memory device context used to draw to an off-screen bitmap.
Group

CXTPBufferDC Constructors


CXTPBufferDC::CXTPBufferDC Constructor (CPaintDC&)

CXTPBufferDC Constructor, CXTPBufferDC Class
CXTPBufferDC::CXTPBufferDC Constructor (CPaintDC&)

Constructs a CXTPBufferDC object used to create a memory device context used to draw to an off-screen bitmap.

CXTPBufferDC(
    CPaintDC& paintDC
);
Parameters

paintDC
Handle to the destination device context the memory

Group

CXTPBufferDC Constructor


CXTPBufferDC::CXTPBufferDC Constructor (HDC, const CRect&)

CXTPBufferDC Constructor, CXTPBufferDC Class
CXTPBufferDC::CXTPBufferDC Constructor (HDC, const CRect&)

Constructs a CXTPBufferDC object used to create a memory device context used to draw to an off-screen bitmap.

CXTPBufferDC(
    HDC hDestDC,
    const CRect& rcPaint
);
Parameters

hDestDC
Handle to the destination device context the memory device is BitBlt to.
rcPaint
Size of the area to paint.

Group

CXTPBufferDC Constructor


CXTPBufferDC Destructors

CXTPBufferDC Class, Legend, Public Methods
CXTPBufferDC Destructors
Class

CXTPBufferDC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPBufferDC | Destroys a CXTPBufferDC object, handles cleanup and de- allocation.


CXTPBufferDC::~CXTPBufferDC Destructor

CXTPBufferDC Destructors, CXTPBufferDC Class
CXTPBufferDC::~CXTPBufferDC Destructor

Destroys a CXTPBufferDC object, handles cleanup and de- allocation.

virtual ~CXTPBufferDC();
Group

CXTPBufferDC Destructors


CXTPBufferDCEx Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPBufferDCEx Data Members, CXTPBufferDCEx Constructors, CXTPBufferDCEx Destructors, CXTPBufferDCEx Constructors, CXTPBufferDCEx Data Members, CXTPBufferDCEx Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPBufferDCEx Class

CXTPBufferDCEx is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.

Class Hierarchy

class CXTPBufferDCEx : public CDC;
File

XTPDrawHelpers.h

Group

Classes

Legend
Data Member
protected
Constructor
virtual
CXTPBufferDCEx Constructors
CXTPBufferDCEx Constructors | Description
CXTPBufferDCEx | Constructs a CXTPBufferDCEx object used to create a memory device context used to draw to an off-screen bitmap.
CXTPBufferDCEx Data Members
CXTPBufferDCEx Data Members | Description
m_bitmap | Bitmap in memory device context
m_hDestDC | Handle to the destination device context.
m_hOldBitmap | Handle to the previously selected bitmap.
m_rect | Size of the area to paint.
CXTPBufferDCEx Destructors
CXTPBufferDCEx Destructors | Description
~CXTPBufferDCEx | Destroys a CXTPBufferDC object, handles cleanup and de- allocation.


CXTPBufferDCEx Data Members

CXTPBufferDCEx Class, Legend, Protected Data Members
CXTPBufferDCEx Data Members
Class

CXTPBufferDCEx Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bitmap | Bitmap in memory device context
m_hDestDC | Handle to the destination device context.
m_hOldBitmap | Handle to the previously selected bitmap.
m_rect | Size of the area to paint.


CXTPBufferDCEx::m_bitmap Data Member

CXTPBufferDCEx Data Members, CXTPBufferDCEx Class
CXTPBufferDCEx::m_bitmap Data Member

Bitmap in memory device context

HBITMAP m_bitmap;
Group

CXTPBufferDCEx Data Members


CXTPBufferDCEx::m_hDestDC Data Member

CXTPBufferDCEx Data Members, CXTPBufferDCEx Class
CXTPBufferDCEx::m_hDestDC Data Member

Handle to the destination device context.

HDC m_hDestDC;
Group

CXTPBufferDCEx Data Members


CXTPBufferDCEx::m_hOldBitmap Data Member

CXTPBufferDCEx Data Members, CXTPBufferDCEx Class
CXTPBufferDCEx::m_hOldBitmap Data Member

Handle to the previously selected bitmap.

HGDIOBJ m_hOldBitmap;
Group

CXTPBufferDCEx Data Members


CXTPBufferDCEx::m_rect Data Member

CXTPBufferDCEx Data Members, CXTPBufferDCEx Class
CXTPBufferDCEx::m_rect Data Member

Size of the area to paint.

CRect m_rect;
Group

CXTPBufferDCEx Data Members


CXTPBufferDCEx Constructors

CXTPBufferDCEx Class, Legend, Public Methods
CXTPBufferDCEx Constructors
Class

CXTPBufferDCEx Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPBufferDCEx | Constructs a CXTPBufferDCEx object used to create a memory device context used to draw to an off-screen bitmap.


CXTPBufferDCEx::CXTPBufferDCEx Constructor

CXTPBufferDCEx Constructors, CXTPBufferDCEx Class
CXTPBufferDCEx::CXTPBufferDCEx Constructor

Constructs a CXTPBufferDCEx object used to create a memory device context used to draw to an off-screen bitmap.

CXTPBufferDCEx(
    HDC hDestDC,
    const CRect rcPaint
);
Parameters

hDestDC
Handle to the destination device context the memory device is BitBlt to.
rcPaint
Size of the area to paint.

Group

CXTPBufferDCEx Constructors


CXTPBufferDCEx Destructors

CXTPBufferDCEx Class, Legend, Public Methods
CXTPBufferDCEx Destructors
Class

CXTPBufferDCEx Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPBufferDCEx | Destroys a CXTPBufferDC object, handles cleanup and de- allocation.


CXTPBufferDCEx::~CXTPBufferDCEx Destructor

CXTPBufferDCEx Destructors, CXTPBufferDCEx Class
CXTPBufferDCEx::~CXTPBufferDCEx Destructor

Destroys a CXTPBufferDC object, handles cleanup and de- allocation.

virtual ~CXTPBufferDCEx();
Group

CXTPBufferDCEx Destructors


CXTPClientCursorPos Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPClientCursorPos Constructors, CXTPClientCursorPos Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPClientCursorPos Class

CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates.

Class Hierarchy

class CXTPClientCursorPos : public CPoint;
File

XTPDrawHelpers.h

Group

Classes

Legend
Constructor
CXTPClientCursorPos Constructors
CXTPClientCursorPos Constructors | Description
CXTPClientCursorPos | Constructs a CXTPClientCursorPos object used to retrieve the cursor position in client coordinates.


CXTPClientCursorPos Constructors

CXTPClientCursorPos Class, Legend, Public Methods
CXTPClientCursorPos Constructors
Class

CXTPClientCursorPos Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPClientCursorPos | Constructs a CXTPClientCursorPos object used to retrieve the cursor position in client coordinates.


CXTPClientCursorPos::CXTPClientCursorPos Constructor

CXTPClientCursorPos Constructors, CXTPClientCursorPos Class
CXTPClientCursorPos::CXTPClientCursorPos Constructor

Constructs a CXTPClientCursorPos object used to retrieve the cursor position in client coordinates.

CXTPClientCursorPos(
    CWnd* pWnd
);
Parameters

pWnd
Pointer to the window that contains the client area to get the cursor position for.

Group

CXTPClientCursorPos Constructors


CXTPClientRect Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPClientRect Constructors, CXTPClientRect Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPClientRect Class

CXTPClientRect is a helper class used to retrieve the client area for a specified window.

Class Hierarchy

class CXTPClientRect : public CRect;
File

XTPDrawHelpers.h

Group

Classes

Legend
Constructor
CXTPClientRect Constructors
CXTPClientRect Constructors | Description
CXTPClientRect |


CXTPClientRect Constructors

CXTPClientRect Class, Legend, Public Methods
CXTPClientRect Constructors
Class

CXTPClientRect Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPClientRect |


CXTPClientRect Constructor

CXTPClientRect Constructors
CXTPClientRect Constructor
Overload List
Constructors
Constructor | Description
CXTPClientRect::CXTPClientRect (HWND) | Constructs a CXTPClientRect object used to retrieve the client area for the specified window.
CXTPClientRect::CXTPClientRect (const CWnd*) | Constructs a CXTPClientRect object used to retrieve the client area for the specified window.
Group

CXTPClientRect Constructors


CXTPClientRect::CXTPClientRect Constructor (HWND)

CXTPClientRect Constructor, CXTPClientRect Class
CXTPClientRect::CXTPClientRect Constructor (HWND)

Constructs a CXTPClientRect object used to retrieve the client area for the specified window.

CXTPClientRect(
    HWND hWnd
);
CXTPClientRect(
    const CWnd* pWnd
);
Parameters

hWnd
Handle to the window to retrieve the client area for.
pWnd
Points to the window to retrieve the client area for.

Group

CXTPClientRect Constructor


CXTPColorManager Class

XTPColorManager.h, Classes, Legend, Members, Topics, CXTPColorManager Data Members, CXTPColorManager Methods, CXTPColorManager Nested Types, CXTPColorManager Data Members, CXTPColorManager Methods, CXTPColorManager Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPColorManager Class

CXTPColorManager is a stand alone class. This object is used for manipulation of RGB values.

Class Hierarchy

class CXTPColorManager;
File

XTPColorManager.h

See Also

XTPColorManager

Group

Classes

Legend
Data Member
Method
CXTPColorManager Data Members
CXTPColorManager Data Members | Description
grcCaption | Office 2003 Caption gradient color.
grcDockBar | Office 2003 Dockbar gradient color.
grcLunaChecked | Office 2003 checked button gradient color.
grcLunaPushed | Office 2003 pushed button gradient color.
grcLunaSelected | Office 2003 selected button gradient color.
grcMenu | Office 2003 Menu sidebar gradient color.
grcMenuExpanded | Office 2003 Expanded menu sidebar gradient color.
grcMenuItemPopup | Office 2003 Menu item popup gradient color.
grcShortcutBarGripper | Office 2003 Shortcut bar gripper.
grcToolBar | Office 2003 ToolBar gradient color.
m_bEnableLunaBlueForAeroTheme | TRUE if Office2003 blue theme will be used for xtpSystemThemeAero
m_bEnableLunaBlueForRoyaleTheme | TRUE if Office2003 blue theme will be used for xtpSystemThemeRoyale
CXTPColorManager Methods
CXTPColorManager Methods | Description
DisableLunaColors | Call this member function to disable the luna (Blue, Olive and Green) colors for Office 2003 theme for Windows XP and later operating systems.
GetColor | Retrieves the current color of the specified XP display element.
GetCurrentSystemTheme | Call this member function to determine the current Windows XP theme in use.
GetLunaColor | Call this member function to get the Luna color specified by nIndes.
GetWinThemeWrapperTheme | Call this member function to determine the current Windows XP theme in use.
IsLowResolution | Call this member function to determine if the system display is set to low resolution.
IsLunaColorsDisabled | Determines if Luna colors for Office 2003 style is disabled.
LightColor | Call this member function to blend the light and dark colors by the amount specified in nDelta.
RefreshColors | This function will refresh the display element colors defined in the CXTPColorManager object.
RefreshLunaColors | Call this member to set the Office 2003 Luna colors for each element to correspond with the current Windows XP visual style.
SetColor | Call this member to set the color for the specified index. See GetColor for a complete list of index values.
SetColors | Call this member to set the colors for each element to the color in the specified color array.
SetGetSysColorPtr | This method replace standard GetSysColor to application defined.
SetLunaTheme | Call this method to force system theme.
CXTPColorManager Nested Types
CXTPColorManager Nested Types | Description
PFNGETSYSCOLOR | Application-defined callback function used with the SetGetSysColorPtr function.


CXTPColorManager Data Members

CXTPColorManager Class, Legend, Public Data Members
CXTPColorManager Data Members
Class

CXTPColorManager Class

Legend
Data Member
Public Data Members
Public Data Member | Description
grcCaption | Office 2003 Caption gradient color.
grcDockBar | Office 2003 Dockbar gradient color.
grcLunaChecked | Office 2003 checked button gradient color.
grcLunaPushed | Office 2003 pushed button gradient color.
grcLunaSelected | Office 2003 selected button gradient color.
grcMenu | Office 2003 Menu sidebar gradient color.
grcMenuExpanded | Office 2003 Expanded menu sidebar gradient color.
grcMenuItemPopup | Office 2003 Menu item popup gradient color.
grcShortcutBarGripper | Office 2003 Shortcut bar gripper.
grcToolBar | Office 2003 ToolBar gradient color.
m_bEnableLunaBlueForAeroTheme | TRUE if Office2003 blue theme will be used for xtpSystemThemeAero
m_bEnableLunaBlueForRoyaleTheme | TRUE if Office2003 blue theme will be used for xtpSystemThemeRoyale


CXTPColorManager::grcCaption Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcCaption Data Member

Office 2003 Caption gradient color.

CXTPPaintManagerColorGradient grcCaption;
Group

CXTPColorManager Data Members


CXTPColorManager::grcDockBar Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcDockBar Data Member

Office 2003 Dockbar gradient color.

CXTPPaintManagerColorGradient grcDockBar;
Group

CXTPColorManager Data Members


CXTPColorManager::grcLunaChecked Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcLunaChecked Data Member

Office 2003 checked button gradient color.

CXTPPaintManagerColorGradient grcLunaChecked;
Group

CXTPColorManager Data Members


CXTPColorManager::grcLunaPushed Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcLunaPushed Data Member

Office 2003 pushed button gradient color.

CXTPPaintManagerColorGradient grcLunaPushed;
Group

CXTPColorManager Data Members


CXTPColorManager::grcLunaSelected Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcLunaSelected Data Member

Office 2003 selected button gradient color.

CXTPPaintManagerColorGradient grcLunaSelected;
Group

CXTPColorManager Data Members


CXTPColorManager::grcMenu Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcMenu Data Member

Office 2003 Menu sidebar gradient color.

CXTPPaintManagerColorGradient grcMenu;
Group

CXTPColorManager Data Members


CXTPColorManager::grcMenuExpanded Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcMenuExpanded Data Member

Office 2003 Expanded menu sidebar gradient color.

CXTPPaintManagerColorGradient grcMenuExpanded;
Group

CXTPColorManager Data Members


CXTPColorManager::grcMenuItemPopup Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcMenuItemPopup Data Member

Office 2003 Menu item popup gradient color.

CXTPPaintManagerColorGradient grcMenuItemPopup;
Group

CXTPColorManager Data Members


CXTPColorManager::grcShortcutBarGripper Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcShortcutBarGripper Data Member

Office 2003 Shortcut bar gripper.

CXTPPaintManagerColorGradient grcShortcutBarGripper;
Group

CXTPColorManager Data Members


CXTPColorManager::grcToolBar Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::grcToolBar Data Member

Office 2003 ToolBar gradient color.

CXTPPaintManagerColorGradient grcToolBar;
Group

CXTPColorManager Data Members


CXTPColorManager::m_bEnableLunaBlueForAeroTheme Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::m_bEnableLunaBlueForAeroTheme Data Member

TRUE if Office2003 blue theme will be used for xtpSystemThemeAero

BOOL m_bEnableLunaBlueForAeroTheme;
Group

CXTPColorManager Data Members


CXTPColorManager::m_bEnableLunaBlueForRoyaleTheme Data Member

CXTPColorManager Data Members, CXTPColorManager Class
CXTPColorManager::m_bEnableLunaBlueForRoyaleTheme Data Member

TRUE if Office2003 blue theme will be used for xtpSystemThemeRoyale

BOOL m_bEnableLunaBlueForRoyaleTheme;
Group

CXTPColorManager Data Members


CXTPColorManager Methods

CXTPColorManager Class, Legend, Public Methods
CXTPColorManager Methods
Class

CXTPColorManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DisableLunaColors | Call this member function to disable the luna (Blue, Olive and Green) colors for Office 2003 theme for Windows XP and later operating systems.
GetColor | Retrieves the current color of the specified XP display element.
GetCurrentSystemTheme | Call this member function to determine the current Windows XP theme in use.
GetLunaColor | Call this member function to get the Luna color specified by nIndes.
GetWinThemeWrapperTheme | Call this member function to determine the current Windows XP theme in use.
IsLowResolution | Call this member function to determine if the system display is set to low resolution.
IsLunaColorsDisabled | Determines if Luna colors for Office 2003 style is disabled.
LightColor | Call this member function to blend the light and dark colors by the amount specified in nDelta.
RefreshColors | This function will refresh the display element colors defined in the CXTPColorManager object.
RefreshLunaColors | Call this member to set the Office 2003 Luna colors for each element to correspond with the current Windows XP visual style.
SetColor | Call this member to set the color for the specified index. See GetColor for a complete list of index values.
SetColors | Call this member to set the colors for each element to the color in the specified color array.
SetGetSysColorPtr | This method replace standard GetSysColor to application defined.
SetLunaTheme | Call this method to force system theme.


CXTPColorManager::DisableLunaColors Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::DisableLunaColors Method

Call this member function to disable the luna (Blue, Olive and Green) colors for Office 2003 theme for Windows XP and later operating systems.

void DisableLunaColors(
    BOOL bDisable = TRUE
);
Parameters

bDisable
TRUE to disable luna colors, otherwise FALSE.

Group

CXTPColorManager Methods


CXTPColorManager::GetColor Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::GetColor Method

Retrieves the current color of the specified XP display element.

COLORREF GetColor(
    int nIndex
) const;
Parameters

nIndex
Specifies the display element whose color is to be retrieved. This parameter can be one of the following values displayed in the table below:

Returns

The red, green, blue (RGB) color value of the given element.

Remarks

Display elements are the parts of a window and the display that appear on the system display screen. The function returns the red, green, blue (RGB) color value of the given element. To provide a consistent look to all Windows applications, the operating system provides and maintains global settings that define the colors of various aspects of the display. These settings as a group are sometimes referred to as a "color scheme." To view the current color settings, click Control Panel, double-click the Display icon, and then click the "Appearance" tab.

Constant | Value | Description
COLOR_SCROLLBAR | 0 | Scroll bar color
COLOR_BACKGROUND | 1 | Desktop color
COLOR_ACTIVECAPTION | 2 | Color of the title bar for the active window, Specifies the left side color in the color gradient of an active window's title bar if the gradient effect is enabled.
COLOR_INACTIVECAPTION | 3 | Color of the title bar for the inactive window, Specifies the left side color in the color gradient of an inactive window's title bar if the gradient effect is enabled.
COLOR_MENU | 4 | Menu background color
COLOR_WINDOW | 5 | Window background color
COLOR_WINDOWFRAME | 6 | Window frame color
COLOR_MENUTEXT | 7 | Color of text on menus
COLOR_WINDOWTEXT | 8 | Color of text in windows
COLOR_CAPTIONTEXT | 9 | Color of text in caption, size box, and scroll arrow
COLOR_ACTIVEBORDER | 10 | Border color of active window
COLOR_INACTIVEBORDER | 11 | Border color of inactive window
COLOR_APPWORKSPACE | 12 | Background color of multiple-document interface (MDI) applications
COLOR_HIGHLIGHT | 13 | Background color of items selected in a control
COLOR_HIGHLIGHTTEXT | 14 | Text color of items selected in a control
COLOR_BTNFACE | 15 | Face color for three-dimensional display elements and for dialog box backgrounds.
COLOR_BTNSHADOW | 16 | Color of shading on the edge of command buttons
COLOR_GRAYTEXT | 17 | Grayed (disabled) text
COLOR_BTNTEXT | 18 | Text color on push buttons
COLOR_INACTIVECAPTIONTEXT | 19 | Color of text in an inactive caption
COLOR_BTNHIGHLIGHT | 20 | Highlight color for 3-D display elements
COLOR_3DDKSHADOW | 21 | Darkest shadow color for 3-D display elements
COLOR_3DLIGHT | 22 | Second lightest 3-D color after 3DHighlight, Light color for three-dimensional display elements (for edges facing the light source.)
COLOR_INFOTEXT | 23 | Color of text in ToolTips
COLOR_INFOBK | 24 | Background color of ToolTips
COLOR_HOTLIGHT | 26 | Color for a hot-tracked item. Single clicking a hot-tracked item executes the item.
COLOR_GRADIENTACTIVECAPTION | 27 | Right side color in the color gradient of an active window's title bar. COLOR_ACTIVECAPTION specifies the left side color.
COLOR_GRADIENTINACTIVECAPTION | 28 | Right side color in the color gradient of an inactive window's title bar. COLOR_INACTIVECAPTION specifies the left side color.
XPCOLOR_TOOLBAR_FACE | 30 | XP toolbar background color.
XPCOLOR_HIGHLIGHT | 31 | XP menu item selected color.
XPCOLOR_HIGHLIGHT_BORDER | 32 | XP menu item selected border color.
XPCOLOR_HIGHLIGHT_PUSHED | 33 | XP menu item pushed color.
XPCOLOR_HIGHLIGHT_CHECKED | 36 | XP menu item checked color.
XPCOLOR_HIGHLIGHT_CHECKED_BORDER | 37 | An RGB value that represents the XP menu item checked border color.
XPCOLOR_ICONSHADDOW | 34 | XP menu item icon shadow.
XPCOLOR_GRAYTEXT | 35 | XP menu item disabled text color.
XPCOLOR_TOOLBAR_GRIPPER | 38 | XP toolbar gripper color.
XPCOLOR_SEPARATOR | 39 | XP toolbar separator color.
XPCOLOR_DISABLED | 40 | XP menu icon disabled color.
XPCOLOR_MENUBAR_FACE | 41 | XP menu item57- text background color.
XPCOLOR_MENUBAR_EXPANDED | 42 | XP hidden menu commands background color.
XPCOLOR_MENUBAR_BORDER | 43 | XP menu border color.
XPCOLOR_MENUBAR_TEXT | 44 | XP menu item text color.
XPCOLOR_HIGHLIGHT_TEXT | 45 | XP menu item selected text color.
XPCOLOR_TOOLBAR_TEXT | 46 | XP toolbar text color.
XPCOLOR_PUSHED_TEXT | 47 | XP toolbar pushed text color.
XPCOLOR_TAB_INACTIVE_BACK | 48 | XP inactive tab background color.
XPCOLOR_TAB_INACTIVE_TEXT | 49 | XP inactive tab text color.
XPCOLOR_HIGHLIGHT_PUSHED_BORDER | 50 | An RGB value that represents the XP border color for pushed in 3D elements.
XPCOLOR_CHECKED_TEXT | 45 | XP color for text displayed in a checked button.
XPCOLOR_3DFACE | 51 | XP face color for three- dimensional display elements and for dialog box backgrounds.
XPCOLOR_3DSHADOW | 52 | XP shadow color for three-dimensional display elements (for edges facing away from the light source).
XPCOLOR_EDITCTRLBORDER | 53 | XP color for the border color of edit controls.
XPCOLOR_FRAME | 54 | Office 2003 frame color.
XPCOLOR_SPLITTER_FACE | 55 | XP splitter face color.
XPCOLOR_LABEL | 56 | Color for label control (xtpControlLabel)
XPCOLOR_STATICFRAME | 57 | WinXP Static frame color
Group

CXTPColorManager Methods


CXTPColorManager::GetCurrentSystemTheme Method

CXTPColorManager Methods, CXTPColorManager Class, See Also
CXTPColorManager::GetCurrentSystemTheme Method

Call this member function to determine the current Windows XP theme in use.

XTPCurrentSystemTheme GetCurrentSystemTheme() const;
Returns

A XTPCurrentSystemTheme enumeration that represents the current Windows theme in use, can be one of the following values:

  • xtpSystemThemeUnknown Indicates no known theme in use
  • xtpSystemThemeBlue Indicates blue theme in use
  • xtpSystemThemeOlive Indicates olive theme in use
  • xtpSystemThemeSilver Indicates silver theme in use
See Also

SetLunaTheme, RefreshLunaColors

Group

CXTPColorManager Methods


CXTPColorManager::GetLunaColor Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::GetLunaColor Method

Call this member function to get the Luna color specified by nIndes.

COLORREF GetLunaColor(
    int nIndex
) const;
Parameters

nIndex
Specifies the display element whose color is to be retrieved.

Returns

An RGB color value representing the Luna color.

Group

CXTPColorManager Methods


CXTPColorManager::GetWinThemeWrapperTheme Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::GetWinThemeWrapperTheme Method

Call this member function to determine the current Windows XP theme in use.

XTPCurrentSystemTheme GetWinThemeWrapperTheme() const;
Returns

A XTPCurrentSystemTheme enumeration that represents the current Windows theme in use, can be one of the following values:

  • xtpSystemThemeUnknown Indicates no known theme in use
  • xtpSystemThemeBlue Indicates blue theme in use
  • xtpSystemThemeOlive Indicates olive theme in use
  • xtpSystemThemeSilver Indicates silver theme in use
Group

CXTPColorManager Methods


CXTPColorManager::IsLowResolution Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::IsLowResolution Method

Call this member function to determine if the system display is set to low resolution.

BOOL IsLowResolution(
    HDC hDC = 0
);
Parameters

hDC
Handle to a device context, if NULL the desktop window device context is used.

Returns

TRUE if the system display is set to low resolution, otherwise FALSE.

Group

CXTPColorManager Methods


CXTPColorManager::IsLunaColorsDisabled Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::IsLunaColorsDisabled Method

Determines if Luna colors for Office 2003 style is disabled.

BOOL IsLunaColorsDisabled() const;
Returns

TRUE if the luna colors are disabled, otherwise FALSE.

Group

CXTPColorManager Methods


CXTPColorManager::LightColor Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::LightColor Method

Call this member function to blend the light and dark colors by the amount specified in nDelta.

COLORREF LightColor(
    COLORREF clrLight,
    COLORREF clrDark,
    int nDelta
) const;
Parameters

clrLight
RGB light color
clrDark
RGB dark color
nDelta
Amount saturation to blend colors.

Returns

An RGB color value representing the two blended colors.

Group

CXTPColorManager Methods


CXTPColorManager::RefreshColors Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::RefreshColors Method

This function will refresh the display element colors defined in the CXTPColorManager object.

void RefreshColors();
Group

CXTPColorManager Methods


CXTPColorManager::RefreshLunaColors Method

CXTPColorManager Methods, CXTPColorManager Class, See Also
CXTPColorManager::RefreshLunaColors Method

Call this member to set the Office 2003 Luna colors for each element to correspond with the current Windows XP visual style.

void RefreshLunaColors();
See Also

SetColor, SetColors

Group

CXTPColorManager Methods


CXTPColorManager::SetColor Method

CXTPColorManager Methods, CXTPColorManager Class, See Also
CXTPColorManager::SetColor Method

Call this member to set the color for the specified index. See GetColor for a complete list of index values.

void SetColor(
    int nIndex,
    COLORREF clrValue
);
Parameters

nIndex
Color index.
clrValue
RGB color value to set.

See Also

SetColors

Group

CXTPColorManager Methods


CXTPColorManager::SetColors Method

CXTPColorManager Methods, CXTPColorManager Class, See Also
CXTPColorManager::SetColors Method

Call this member to set the colors for each element to the color in the specified color array.

void SetColors(
    int cElements,
    const int* lpaElements,
    const COLORREF* lpaRgbValues
);
Parameters

cElements
Number of elements in array.
lpaElements
Array of elements.
lpaRgbValues
Array of RGB values.

See Also

SetColor

Group

CXTPColorManager Methods


CXTPColorManager::SetGetSysColorPtr Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::SetGetSysColorPtr Method

This method replace standard GetSysColor to application defined.

void SetGetSysColorPtr(
    PFNGETSYSCOLOR pfnGetSysColor
);
Parameters

pfnGetSysColor
Pointer to the PFNGETSYSCOLOR procedure

Group

CXTPColorManager Methods


CXTPColorManager::SetLunaTheme Method

CXTPColorManager Methods, CXTPColorManager Class
CXTPColorManager::SetLunaTheme Method

Call this method to force system theme.

void SetLunaTheme(
    XTPCurrentSystemTheme systemTheme
);
Parameters

systemTheme
theme to use. Can be any of the values listed in the Remarks section.

Remarks

theme can be one of the following:

  • xtpSystemThemeUnknown Disables luna theme support.
  • xtpSystemThemeBlue Enables blue theme
  • xtpSystemThemeOlive Enables olive theme
  • xtpSystemThemeSilver Enables silver theme
Group

CXTPColorManager Methods


CXTPColorManager Nested Types

CXTPColorManager Class, Public Nested Types
CXTPColorManager Nested Types
Class

CXTPColorManager Class

Public Nested Types
Public Nested Type | Description
PFNGETSYSCOLOR | Application-defined callback function used with the SetGetSysColorPtr function.


CXTPColorManager::PFNGETSYSCOLOR Nested Type

CXTPColorManager Nested Types, CXTPColorManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPColorManager::PFNGETSYSCOLOR Nested Type

Application-defined callback function used with the SetGetSysColorPtr function.

typedef DWORD (__stdcall * PFNGETSYSCOLOR)(int nIndex);
See Also

SetGetSysColorPtr

Group

CXTPColorManager Nested Types


CXTPCompatibleDC Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPCompatibleDC Data Members, CXTPCompatibleDC Constructors, CXTPCompatibleDC Destructors, CXTPCompatibleDC Constructors, CXTPCompatibleDC Data Members, CXTPCompatibleDC Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCompatibleDC Class

CXTPCompatibleDC is a helper class used to create a memory device context (DC) compatible with the device specified by pDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.

Class Hierarchy

class CXTPCompatibleDC : public CDC;
File

XTPDrawHelpers.h

Group

Classes

Legend
Data Member
protected
Constructor
virtual
CXTPCompatibleDC Constructors
CXTPCompatibleDC Constructors | Description
CXTPCompatibleDC |
CXTPCompatibleDC Data Members
CXTPCompatibleDC Data Members | Description
m_hOldBitmap | Pointer to the previously selected bitmap.
CXTPCompatibleDC Destructors
CXTPCompatibleDC Destructors | Description
~CXTPCompatibleDC | Destroys a CXTPCompatibleDC object, handles cleanup and de- allocation.


CXTPCompatibleDC Data Members

CXTPCompatibleDC Class, Legend, Protected Data Members
CXTPCompatibleDC Data Members
Class

CXTPCompatibleDC Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hOldBitmap | Pointer to the previously selected bitmap.


CXTPCompatibleDC::m_hOldBitmap Data Member

CXTPCompatibleDC Data Members, CXTPCompatibleDC Class
CXTPCompatibleDC::m_hOldBitmap Data Member

Pointer to the previously selected bitmap.

HBITMAP m_hOldBitmap;
Group

CXTPCompatibleDC Data Members


CXTPCompatibleDC Constructors

CXTPCompatibleDC Class, Legend, Public Methods
CXTPCompatibleDC Constructors
Class

CXTPCompatibleDC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCompatibleDC |


CXTPCompatibleDC Constructor

CXTPCompatibleDC Constructors
CXTPCompatibleDC Constructor
Overload List
Constructors
Constructor | Description
CXTPCompatibleDC::CXTPCompatibleDC (CDC*, CBitmap*) | Constructs a CXTPCompatibleDC object and creates a memory device context (DC) compatible with the device specified by pDC. The bitmap specified by pBitmap is then selected into the device context.
CXTPCompatibleDC::CXTPCompatibleDC (CDC*, HBITMAP) | Constructs a CXTPCompatibleDC object and creates a memory device context (DC) compatible with the device specified by pDC. The bitmap specified by pBitmap is then selected into the device context.
Group

CXTPCompatibleDC Constructors


CXTPCompatibleDC::CXTPCompatibleDC Constructor (CDC*, CBitmap*)

CXTPCompatibleDC Constructor, CXTPCompatibleDC Class
CXTPCompatibleDC::CXTPCompatibleDC Constructor (CDC*, CBitmap*)

Constructs a CXTPCompatibleDC object and creates a memory device context (DC) compatible with the device specified by pDC. The bitmap specified by pBitmap is then selected into the device context.

CXTPCompatibleDC(
    CDC* pDC,
    CBitmap* pBitmap
);
CXTPCompatibleDC(
    CDC* pDC,
    HBITMAP hBitmap
);
Parameters

pDC
Points to a valid device context.
pBitmap
Points to the previously selected bitmap.
hBitmap
Points to the previously selected bitmap.

Group

CXTPCompatibleDC Constructor


CXTPCompatibleDC Destructors

CXTPCompatibleDC Class, Legend, Public Methods
CXTPCompatibleDC Destructors
Class

CXTPCompatibleDC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCompatibleDC | Destroys a CXTPCompatibleDC object, handles cleanup and de- allocation.


CXTPCompatibleDC::~CXTPCompatibleDC Destructor

CXTPCompatibleDC Destructors, CXTPCompatibleDC Class
CXTPCompatibleDC::~CXTPCompatibleDC Destructor

Destroys a CXTPCompatibleDC object, handles cleanup and de- allocation.

virtual ~CXTPCompatibleDC();
Group

CXTPCompatibleDC Destructors


CXTPCriticalSection Class

XTPSystemHelpers.h, Classes, Legend, Members, Topics, CXTPCriticalSection Methods, CXTPCriticalSection Constructors, CXTPCriticalSection Destructors, CXTPCriticalSection Operators, CXTPCriticalSection Constructors, CXTPCriticalSection Destructors, CXTPCriticalSection Methods, CXTPCriticalSection Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCriticalSection Class

Critical Section Wrapper

Class Hierarchy

class CXTPCriticalSection;
File

XTPSystemHelpers.h

Group

Classes

Legend
Method
Operator
CXTPCriticalSection Constructors
CXTPCriticalSection Constructors | Description
CXTPCriticalSection | Constructs a CXTPCriticalSection object
CXTPCriticalSection Destructors
CXTPCriticalSection Destructors | Description
~CXTPCriticalSection | Destroys a CXTPCriticalSection object, handles cleanup and deallocation
CXTPCriticalSection Methods
CXTPCriticalSection Methods | Description
EnterCritical | The EnterCriticalSection function waits for ownership of the specified critical section object
LeaveCritical | The LeaveCriticalSection function releases ownership of the specified critical section object
CXTPCriticalSection Operators
CXTPCriticalSection Operators | Description
CRITICAL_SECTION& | Returns CRITICAL_SECTION reference


CXTPCriticalSection Methods

CXTPCriticalSection Class, Legend, Public Methods
CXTPCriticalSection Methods
Class

CXTPCriticalSection Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
EnterCritical | The EnterCriticalSection function waits for ownership of the specified critical section object
LeaveCritical | The LeaveCriticalSection function releases ownership of the specified critical section object


CXTPCriticalSection::EnterCritical Method

CXTPCriticalSection Methods, CXTPCriticalSection Class
CXTPCriticalSection::EnterCritical Method

The EnterCriticalSection function waits for ownership of the specified critical section object

void EnterCritical();
Group

CXTPCriticalSection Methods


CXTPCriticalSection::LeaveCritical Method

CXTPCriticalSection Methods, CXTPCriticalSection Class
CXTPCriticalSection::LeaveCritical Method

The LeaveCriticalSection function releases ownership of the specified critical section object

void LeaveCritical();
Group

CXTPCriticalSection Methods


CXTPCriticalSection Constructors

CXTPCriticalSection Class, Legend, Public Methods
CXTPCriticalSection Constructors
Class

CXTPCriticalSection Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPCriticalSection | Constructs a CXTPCriticalSection object


CXTPCriticalSection::CXTPCriticalSection Constructor

CXTPCriticalSection Constructors, CXTPCriticalSection Class
CXTPCriticalSection::CXTPCriticalSection Constructor

Constructs a CXTPCriticalSection object

CXTPCriticalSection();
Group

CXTPCriticalSection Constructors


CXTPCriticalSection Destructors

CXTPCriticalSection Class, Legend, Public Methods
CXTPCriticalSection Destructors
Class

CXTPCriticalSection Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPCriticalSection | Destroys a CXTPCriticalSection object, handles cleanup and deallocation


CXTPCriticalSection::~CXTPCriticalSection Destructor

CXTPCriticalSection Destructors, CXTPCriticalSection Class
CXTPCriticalSection::~CXTPCriticalSection Destructor

Destroys a CXTPCriticalSection object, handles cleanup and deallocation

~CXTPCriticalSection();
Group

CXTPCriticalSection Destructors


CXTPCriticalSection Operators

CXTPCriticalSection Class, Legend, Public Operators
CXTPCriticalSection Operators
Class

CXTPCriticalSection Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
CRITICAL_SECTION& | Returns CRITICAL_SECTION reference


CXTPCriticalSection::CRITICAL_SECTION& Operator

CXTPCriticalSection Operators, CXTPCriticalSection Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPCriticalSection::CRITICAL_SECTION& Operator

Returns CRITICAL_SECTION reference

operator CRITICAL_SECTION&();
Body Source
operator CRITICAL_SECTION& () {
    return m_csMutex;
}
Group

CXTPCriticalSection Operators


CXTPDrawHelpers Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPDrawHelpers Methods, CXTPDrawHelpers Constructors, CXTPDrawHelpers Destructors, CXTPDrawHelpers Nested Types, CXTPDrawHelpers Constructors, CXTPDrawHelpers Destructors, CXTPDrawHelpers Methods, CXTPDrawHelpers Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPDrawHelpers Class

CXTPDrawHelpers is a helper class used to perform specialized drawing tasks. You can use this class to perform such tasks as gradient fills and blending colors.

Class Hierarchy

class CXTPDrawHelpers;
File

XTPDrawHelpers.h

Group

Classes

Legend
Method
virtual
CXTPDrawHelpers Constructors
CXTPDrawHelpers Constructors | Description
CXTPDrawHelpers | Constructs a CXTPDrawHelpers object.
CXTPDrawHelpers Destructors
CXTPDrawHelpers Destructors | Description
~CXTPDrawHelpers | Destroys a CXCSplitPath object, handles cleanup and de- allocation.
CXTPDrawHelpers Methods
CXTPDrawHelpers Methods | Description
BlendColors | Call this member function to blend the colors specified by crA and crB.
BlurPoints | Call this member function to blur the color value for the points specified by pts
DarkenColor | Call this member function to get dark color from specified by lColor
DrawLine | Call this member function to draw a vertical or horizontal line using the specified device context.
ExcludeCorners | Call this member to exclude the pixels for each corner of the area specified by rc.
FontExists | Call this member function to determine if the specified font exists.
GetDefaultFontName | Retrieves DEFAULT_GUI_FONT font name.
GetVerticalFontName | Retrieves vertical font name
GradientFill |
HSLtoRGB | Call this member function to convert a color from HSL to RGB color model.
IsContextRTL |
IsFastFillAvailable | Determines if GradientFill from msimg32.dll available.
IsLowResolution | Call this member function to determine if the system display is set to low resolution.
IsTopParentActive | Determines if top level parent is active for window handle
KeyToLayout | Call this member function to switch Left and Right keys if window in Right To Left layout
LightenColor | Call this member function to get light color from specified by lColor
RegisterWndClass | Register class helper.
RGBtoHSL | Call this member function to convert a color from RGB to HSL color model.
ScreenToWindow | Converts the screen coordinates of a given point on the display to window coordinates.
SetContextRTL |
StripMnemonics |
Triangle |
CXTPDrawHelpers Nested Types
CXTPDrawHelpers Nested Types | Description
PFNALPHABLEND | AlphaBlend function declaration
PFNGRADIENTFILL | Function pointer used to access the Windows API GradientFill function.


CXTPDrawHelpers Methods

CXTPDrawHelpers Class, Legend, Public Methods
CXTPDrawHelpers Methods
Class

CXTPDrawHelpers Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
BlendColors | Call this member function to blend the colors specified by crA and crB.
BlurPoints | Call this member function to blur the color value for the points specified by pts
DarkenColor | Call this member function to get dark color from specified by lColor
DrawLine | Call this member function to draw a vertical or horizontal line using the specified device context.
ExcludeCorners | Call this member to exclude the pixels for each corner of the area specified by rc.
FontExists | Call this member function to determine if the specified font exists.
GetDefaultFontName | Retrieves DEFAULT_GUI_FONT font name.
GetVerticalFontName | Retrieves vertical font name
GradientFill |
HSLtoRGB | Call this member function to convert a color from HSL to RGB color model.
IsContextRTL |
IsFastFillAvailable | Determines if GradientFill from msimg32.dll available.
IsLowResolution | Call this member function to determine if the system display is set to low resolution.
IsTopParentActive | Determines if top level parent is active for window handle
KeyToLayout | Call this member function to switch Left and Right keys if window in Right To Left layout
LightenColor | Call this member function to get light color from specified by lColor
RegisterWndClass | Register class helper.
RGBtoHSL | Call this member function to convert a color from RGB to HSL color model.
ScreenToWindow | Converts the screen coordinates of a given point on the display to window coordinates.
SetContextRTL |
StripMnemonics |
Triangle |


CXTPDrawHelpers::BlendColors Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::BlendColors Method

Call this member function to blend the colors specified by crA and crB.

static COLORREF BlendColors(
    COLORREF crA,
    COLORREF crB,
    double fAmountA
);
Parameters

crA
RGB value to blend
crB
RGB value to blend
fAmountA
The amount that crA saturates crB.

Returns

An RGB value that represents the blended color.

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::BlurPoints Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::BlurPoints Method

Call this member function to blur the color value for the points specified by pts

void BlurPoints(
    CDC* pDC,
    LPPOINT pts,
    int nCount
);
Parameters

pDC
Points to the device context
pts
Array of points to blur
nCount
Number of points in array.

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::DarkenColor Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class, See Also
CXTPDrawHelpers::DarkenColor Method

Call this member function to get dark color from specified by lColor

static COLORREF DarkenColor(
    long lScale,
    COLORREF lColor
);
Parameters

lScale
Scale value
lColor
RGB value to get

See Also

LightenColor

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::DrawLine Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::DrawLine Method

Call this member function to draw a vertical or horizontal line using the specified device context.

static BOOL DrawLine(
    CDC* pDC,
    int xPos,
    int yPos,
    int nLength,
    int nHeight,
    COLORREF crLine
);
Parameters

pDC
Points to the device context
xPos
Specifies the logical x-coordinate of the start position.
yPos
Specifies the logical y-coordinate of the start position.
nLength
Specifies the length of the line to draw, for vertical lines set this value to 0.
nHeight
Specifies the height of the line to draw, for horizontal lines set this value to 0.
crLine
Specifies the RGB color value used to draw the line.

Returns

TRUE if the specified device context is valid, otherwise FALSE.

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::ExcludeCorners Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::ExcludeCorners Method

Call this member to exclude the pixels for each corner of the area specified by rc.

void ExcludeCorners(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Points to the device context
rc
Area to exclude corners from

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::FontExists Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::FontExists Method

Call this member function to determine if the specified font exists.

static BOOL FontExists(
    LPCTSTR lpszFaceName
);
Parameters

lpszFaceName
A NULL terminated string that represents the font face name.

Returns

TRUE if the font was found, otherwise FALSE.

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::GetDefaultFontName Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::GetDefaultFontName Method

Retrieves DEFAULT_GUI_FONT font name.

static CString GetDefaultFontName();
Returns

Face name of DEFAULT_GUI_FONT font.

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::GetVerticalFontName Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::GetVerticalFontName Method

Retrieves vertical font name

static CString GetVerticalFontName(
    BOOL bUseOfficeFont
);
Parameters

bUseOfficeFont
TRUE to use "Tahoma" font if exists.

Returns

Face name of vertical font.

Group

CXTPDrawHelpers Methods


GradientFill Method

CXTPDrawHelpers Methods
GradientFill Method
Overload List
Methods
Method | Description
CXTPDrawHelpers::GradientFill (CDC*, LPCRECT, COLORREF, COLORREF, BOOL) | Call this member function to perform a gradient fill using the specified COLORREF values crFrom and crTo.
CXTPDrawHelpers::GradientFill (CDC*, LPCRECT, COLORREF, COLORREF, BOOL, LPCRECT) | Call this member function to perform a gradient fill using the specified COLORREF values crFrom and crTo.
CXTPDrawHelpers::GradientFill (CDC*, LPCRECT, const CXTPPaintManagerColorGradient&, BOOL, LPCRECT) | Call this member function to perform a gradient fill using the specified COLORREF values crFrom and crTo.
CXTPDrawHelpers::GradientFill (HDC, PTRIVERTEX, ULONG, PVOID, ULONG, ULONG) | Call this member function to perform a gradient fill using the specified COLORREF values crFrom and crTo.
Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::GradientFill Method (CDC*, LPCRECT, COLORREF, COLORREF, BOOL)

GradientFill Method, CXTPDrawHelpers Class
CXTPDrawHelpers::GradientFill Method (CDC*, LPCRECT, COLORREF, COLORREF, BOOL)

Call this member function to perform a gradient fill using the specified COLORREF values crFrom and crTo.

void GradientFill(
    CDC* pDC,
    LPCRECT lpRect,
    COLORREF crFrom,
    COLORREF crTo,
    BOOL bHorz
);
void GradientFill(
    CDC* pDC,
    LPCRECT lpRect,
    COLORREF crFrom,
    COLORREF crTo,
    BOOL bHorz,
    LPCRECT lpRectClip
);
void GradientFill(
    CDC* pDC,
    LPCRECT lpRect,
    const CXTPPaintManagerColorGradient& grc,
    BOOL bHorz,
    LPCRECT lpRectClip = NULL
);
BOOL GradientFill(
    HDC hdc,
    PTRIVERTEX pVertex,
    ULONG dwNumVertex,
    PVOID pMesh,
    ULONG dwNumMesh,
    ULONG dwMode
);
Parameters

pDC
Points to the device context
lpRect
Size of area to fill
crFrom
RGB value to start from
crTo
RGB value to fill to
bHorz
TRUE if fill is horizontal.
lpRectClip
Pointer to a RECT structure that contains a clipping rectangle. This parameter is optional and may be set to NULL.
grc
CXTPPaintManagerColorGradient struct containing start from and fill to RGB color values.
hdc
Handle to a device context.
pVertex
Pointer to an array of TRIVERTEX structures that each define a triangle vertex.
dwNumVertex
The number of vertices.
pMesh
Array of GRADIENT_TRIANGLE structures in triangle mode, or an array of GRADIENT_RECT structures in rectangle mode.
dwNumMesh
The number of elements (triangles or rectangles) in pMesh.
dwMode
Specifies gradient fill mode. For a list of possible values, see GradientFill in the Platform SDK.

Returns

The HDC version TRUE if successful; otherwise FALSE.

Remarks

Call this member function to fill rectangle and triangle structures with color that smoothly fades from one side to the other.

Group

GradientFill Method


CXTPDrawHelpers::HSLtoRGB Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class, See Also
CXTPDrawHelpers::HSLtoRGB Method

Call this member function to convert a color from HSL to RGB color model.

static COLORREF HSLtoRGB(
    COLORREF hsl
);
Parameters

hsl
HSL color to convert

Returns

An RGB representation of the specified color.

See Also

HueToRGB, RGBtoHSL

Group

CXTPDrawHelpers Methods


IsContextRTL Method

CXTPDrawHelpers Methods
IsContextRTL Method
Overload List
Methods
Method | Description
CXTPDrawHelpers::IsContextRTL (CDC*) | Determines if layout of a device context right to left.
CXTPDrawHelpers::IsContextRTL (HDC) | Determines if layout of a device context right to left.
Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::IsContextRTL Method (CDC*)

IsContextRTL Method, CXTPDrawHelpers Class
CXTPDrawHelpers::IsContextRTL Method (CDC*)

Determines if layout of a device context right to left.

static BOOL IsContextRTL(
    CDC* pDC
);
static BOOL IsContextRTL(
    HDC hDC
);
Parameters

pDC
Device context to test
hDC
Device context to test

Group

IsContextRTL Method


CXTPDrawHelpers::IsFastFillAvailable Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class, Body Source
CXTPDrawHelpers::IsFastFillAvailable Method

Determines if GradientFill from msimg32.dll available.

BOOL IsFastFillAvailable() const;
Returns

TRUE if GradientFill can be used

Body Source
BOOL CXTPDrawHelpers::IsFastFillAvailable() const {
    return m_pfnFastGradientFill != NULL;
}
Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::IsLowResolution Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::IsLowResolution Method

Call this member function to determine if the system display is set to low resolution.

static BOOL IsLowResolution(
    HDC hDC = 0
);
Parameters

hDC
Handle to a device context, if NULL the desktop window device context is used.

Returns

TRUE if the system display is set to low resolution, otherwise FALSE.

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::IsTopParentActive Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::IsTopParentActive Method

Determines if top level parent is active for window handle

static BOOL IsTopParentActive(
    HWND hWnd
);
Parameters

hWnd
Window handle to test

Returns

TRUE if top level parent is active.

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::KeyToLayout Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::KeyToLayout Method

Call this member function to switch Left and Right keys if window in Right To Left layout

static void KeyToLayout(
    CWnd* pWnd,
    UINT& nChar
);
Parameters

pWnd
Window to test
nChar
Virtual key, passed to OnKeyDown member.

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::LightenColor Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class, See Also
CXTPDrawHelpers::LightenColor Method

Call this member function to get light color from specified by lColor

static COLORREF LightenColor(
    long lScale,
    COLORREF lColor
);
Parameters

lScale
Scale value
lColor
RGB value to get

See Also

DarkenColor

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::RegisterWndClass Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::RegisterWndClass Method

Register class helper.

static BOOL RegisterWndClass(
    HINSTANCE hInstance,
    LPCTSTR lpszClassName,
    UINT style,
    HICON hIcon = 0
);
Parameters

hInstance
Handle to the instance that contains the window procedure for the class.
lpszClassName
Pointer to a null-terminated string or is an atom
style
Specifies the class style(s).
hIcon
Handle to the class icon

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::RGBtoHSL Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class, See Also
CXTPDrawHelpers::RGBtoHSL Method

Call this member function to convert a color from RGB to HSL color model.

static COLORREF RGBtoHSL(
    COLORREF rgb
);
Parameters

rgb
RGB color to convert

Returns

An HSL representation of the specified color.

See Also

HSLtoRGB

Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::ScreenToWindow Method

CXTPDrawHelpers Methods, CXTPDrawHelpers Class
CXTPDrawHelpers::ScreenToWindow Method

Converts the screen coordinates of a given point on the display to window coordinates.

static void ScreenToWindow(
    CWnd* pWnd,
    LPPOINT lpPoint
);
Parameters

pWnd
window whose area is used for the conversion
lpPoint
Points to a CPoint object or POINT structure that contains the screen coordinates to be converted.

Group

CXTPDrawHelpers Methods


SetContextRTL Method

CXTPDrawHelpers Methods
SetContextRTL Method
Overload List
Methods
Method | Description
CXTPDrawHelpers::SetContextRTL (CDC*, BOOL) | Cal this method to set right to left layout for device context
CXTPDrawHelpers::SetContextRTL (HDC, BOOL) | Cal this method to set right to left layout for device context
Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::SetContextRTL Method (CDC*, BOOL)

SetContextRTL Method, CXTPDrawHelpers Class
CXTPDrawHelpers::SetContextRTL Method (CDC*, BOOL)

Cal this method to set right to left layout for device context

static void SetContextRTL(
    CDC* pDC,
    BOOL bLayoutRTL
);
static void SetContextRTL(
    HDC hDC,
    BOOL bLayoutRTL
);
Parameters

pDC
Device context to set layout
bLayoutRTL
TRUE to set right to left layout
hDC
Device context to set layout

Group

SetContextRTL Method


StripMnemonics Method

CXTPDrawHelpers Methods
StripMnemonics Method
Overload List
Methods
Method | Description
CXTPDrawHelpers::StripMnemonics (CString&) | This member function will search a string, strip off the mnemonic '&', and reformat the string.
CXTPDrawHelpers::StripMnemonics (LPTSTR) | This member function will search a string, strip off the mnemonic '&', and reformat the string.
Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::StripMnemonics Method (CString&)

StripMnemonics Method, CXTPDrawHelpers Class
CXTPDrawHelpers::StripMnemonics Method (CString&)

This member function will search a string, strip off the mnemonic '&', and reformat the string.

static void StripMnemonics(
    CString& strClear
);
static void StripMnemonics(
    LPTSTR lpszClear
);
Parameters

strClear
Text needed to strip.
lpszClear
Text needed to strip.

Group

StripMnemonics Method


Triangle Method

CXTPDrawHelpers Methods
Triangle Method
Overload List
Methods
Method | Description
CXTPDrawHelpers::Triangle (CDC*, CPoint, CPoint, CPoint) | Call this member function to draw a triangle onto the specified device context.
CXTPDrawHelpers::Triangle (CDC*, CPoint, CPoint, CPoint, COLORREF) | Call this member function to draw a triangle onto the specified device context.
Group

CXTPDrawHelpers Methods


CXTPDrawHelpers::Triangle Method (CDC*, CPoint, CPoint, CPoint, COLORREF)

Triangle Method, CXTPDrawHelpers Class
CXTPDrawHelpers::Triangle Method (CDC*, CPoint, CPoint, CPoint, COLORREF)

Call this member function to draw a triangle onto the specified device context.

static void Triangle(
    CDC* pDC,
    CPoint pt0,
    CPoint pt1,
    CPoint pt2,
    COLORREF clr
);
static void Triangle(
    CDC* pDC,
    CPoint pt0,
    CPoint pt1,
    CPoint pt2
);
Parameters

pDC
Points to the device context
pt0
First point of the triangle
pt1
Second point of the triangle
pt2
Third point of the triangle
clr
An RGB value that represents the fill color.

Group

Triangle Method


CXTPDrawHelpers Constructors

CXTPDrawHelpers Class, Legend, Public Methods
CXTPDrawHelpers Constructors
Class

CXTPDrawHelpers Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPDrawHelpers | Constructs a CXTPDrawHelpers object.


CXTPDrawHelpers::CXTPDrawHelpers Constructor

CXTPDrawHelpers Constructors, CXTPDrawHelpers Class
CXTPDrawHelpers::CXTPDrawHelpers Constructor

Constructs a CXTPDrawHelpers object.

CXTPDrawHelpers();
Group

CXTPDrawHelpers Constructors


CXTPDrawHelpers Destructors

CXTPDrawHelpers Class, Legend, Public Methods
CXTPDrawHelpers Destructors
Class

CXTPDrawHelpers Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPDrawHelpers | Destroys a CXCSplitPath object, handles cleanup and de- allocation.


CXTPDrawHelpers::~CXTPDrawHelpers Destructor

CXTPDrawHelpers Destructors, CXTPDrawHelpers Class
CXTPDrawHelpers::~CXTPDrawHelpers Destructor

Destroys a CXCSplitPath object, handles cleanup and de- allocation.

virtual ~CXTPDrawHelpers();
Group

CXTPDrawHelpers Destructors


CXTPDrawHelpers Nested Types

CXTPDrawHelpers Class, Public Nested Types
CXTPDrawHelpers Nested Types
Class

CXTPDrawHelpers Class

Public Nested Types
Public Nested Type | Description
PFNALPHABLEND | AlphaBlend function declaration
PFNGRADIENTFILL | Function pointer used to access the Windows API GradientFill function.


CXTPDrawHelpers::PFNALPHABLEND Nested Type

CXTPDrawHelpers Nested Types, CXTPDrawHelpers Class
CXTPDrawHelpers::PFNALPHABLEND Nested Type

AlphaBlend function declaration

typedef BOOL (__stdcall * PFNALPHABLEND)(HDC, int, int, int, int, HDC, int, int, int, int, BLENDFUNCTION);
Group

CXTPDrawHelpers Nested Types


CXTPDrawHelpers::PFNGRADIENTFILL Nested Type

CXTPDrawHelpers Nested Types, CXTPDrawHelpers Class
CXTPDrawHelpers::PFNGRADIENTFILL Nested Type

Function pointer used to access the Windows API GradientFill function.

typedef BOOL (__stdcall * PFNGRADIENTFILL)(HDC, PTRIVERTEX, ULONG, PVOID, ULONG, ULONG);
Group

CXTPDrawHelpers Nested Types


CXTPEmptyRect Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPEmptyRect Constructors, CXTPEmptyRect Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPEmptyRect Class

CXTPEmptyRect is a helper class used to instantiate an empty CRect object.

Class Hierarchy

class CXTPEmptyRect : public CRect;
File

XTPDrawHelpers.h

Group

Classes

Legend
Constructor
CXTPEmptyRect Constructors
CXTPEmptyRect Constructors | Description
CXTPEmptyRect | Constructs a CXTPEmptyRect object used to instantiate an empty CRect object.


CXTPEmptyRect Constructors

CXTPEmptyRect Class, Legend, Public Methods
CXTPEmptyRect Constructors
Class

CXTPEmptyRect Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPEmptyRect | Constructs a CXTPEmptyRect object used to instantiate an empty CRect object.


CXTPEmptyRect::CXTPEmptyRect Constructor

CXTPEmptyRect Constructors, CXTPEmptyRect Class
CXTPEmptyRect::CXTPEmptyRect Constructor

Constructs a CXTPEmptyRect object used to instantiate an empty CRect object.

CXTPEmptyRect();
Group

CXTPEmptyRect Constructors


CXTPEmptySize Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPEmptySize Methods, CXTPEmptySize Constructors, CXTPEmptySize Operators, CXTPEmptySize Constructors, CXTPEmptySize Methods, CXTPEmptySize Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPEmptySize Class

CXTPEmptySize is a helper class used to instantiate an empty CSize object.

Class Hierarchy

class CXTPEmptySize : public CSize;
File

XTPDrawHelpers.h

Group

Classes

Legend
Method
Operator
CXTPEmptySize Constructors
CXTPEmptySize Constructors | Description
CXTPEmptySize | Constructs a CXTPEmptySize object used to instantiate an empty CSize object.
CXTPEmptySize Methods
CXTPEmptySize Methods | Description
SetSizeEmpty | Makes CXTPEmptySize a null size by setting all coordinates to zero.
CXTPEmptySize Operators
CXTPEmptySize Operators | Description
= | Assigns srcSize to CSize.


CXTPEmptySize Methods

CXTPEmptySize Class, Legend, Public Methods
CXTPEmptySize Methods
Class

CXTPEmptySize Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetSizeEmpty | Makes CXTPEmptySize a null size by setting all coordinates to zero.


CXTPEmptySize::SetSizeEmpty Method

CXTPEmptySize Methods, CXTPEmptySize Class
CXTPEmptySize::SetSizeEmpty Method

Makes CXTPEmptySize a null size by setting all coordinates to zero.

void SetSizeEmpty();
Group

CXTPEmptySize Methods


CXTPEmptySize Constructors

CXTPEmptySize Class, Legend, Public Methods
CXTPEmptySize Constructors
Class

CXTPEmptySize Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPEmptySize | Constructs a CXTPEmptySize object used to instantiate an empty CSize object.


CXTPEmptySize::CXTPEmptySize Constructor

CXTPEmptySize Constructors, CXTPEmptySize Class
CXTPEmptySize::CXTPEmptySize Constructor

Constructs a CXTPEmptySize object used to instantiate an empty CSize object.

CXTPEmptySize();
Group

CXTPEmptySize Constructors


CXTPEmptySize Operators

CXTPEmptySize Class, Legend, Public Operators
CXTPEmptySize Operators
Class

CXTPEmptySize Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Assigns srcSize to CSize.


CXTPEmptySize::= Operator

CXTPEmptySize Operators, CXTPEmptySize Class
CXTPEmptySize::= Operator

Assigns srcSize to CSize.

const SIZE& operator =(
    const SIZE& srcSize
);
Parameters

srcSize
Refers to a source size. Can be a SIZE or CSize.

Group

CXTPEmptySize Operators


CXTPFontDC Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPFontDC Data Members, CXTPFontDC Methods, CXTPFontDC Constructors, CXTPFontDC Destructors, CXTPFontDC Constructors, CXTPFontDC Data Members, CXTPFontDC Destructors, CXTPFontDC Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPFontDC Class

CXTPFontDC is a helper class used to select a font into the device context specified by pDC. When destroyed, the class selects the previous font back into the device context to handle GDI resource cleanup.

Class Hierarchy

class CXTPFontDC;
File

XTPDrawHelpers.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPFontDC Constructors
CXTPFontDC Constructors | Description
CXTPFontDC |
CXTPFontDC Data Members
CXTPFontDC Data Members | Description
m_clrOldTextColor | Stored an initial text color from the device context.
m_pDC | Stored pointer to a device context.
m_pOldFont | Stored pointer to an initial font from the device context.
CXTPFontDC Destructors
CXTPFontDC Destructors | Description
~CXTPFontDC | Destroys a CXTPFontDC object, handles cleanup and de- allocation.
CXTPFontDC Methods
CXTPFontDC Methods | Description
ReleaseColor | Call this member function to set the initial text color back into the device context.
ReleaseFont | Call this member function to select the initial font back into the device context.
SetColor | Call this member function to change the text color set in the device context.
SetFont | Call this member function to change the font selected by the device context.
SetFontColor | Call this member function to change the font and color selected by the device context.


CXTPFontDC Data Members

CXTPFontDC Class, Legend, Protected Data Members
CXTPFontDC Data Members
Class

CXTPFontDC Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrOldTextColor | Stored an initial text color from the device context.
m_pDC | Stored pointer to a device context.
m_pOldFont | Stored pointer to an initial font from the device context.


CXTPFontDC::m_clrOldTextColor Data Member

CXTPFontDC Data Members, CXTPFontDC Class
CXTPFontDC::m_clrOldTextColor Data Member

Stored an initial text color from the device context.

COLORREF m_clrOldTextColor;
Group

CXTPFontDC Data Members


CXTPFontDC::m_pDC Data Member

CXTPFontDC Data Members, CXTPFontDC Class
CXTPFontDC::m_pDC Data Member

Stored pointer to a device context.

CDC* m_pDC;
Group

CXTPFontDC Data Members


CXTPFontDC::m_pOldFont Data Member

CXTPFontDC Data Members, CXTPFontDC Class
CXTPFontDC::m_pOldFont Data Member

Stored pointer to an initial font from the device context.

CFont* m_pOldFont;
Group

CXTPFontDC Data Members


CXTPFontDC Methods

CXTPFontDC Class, Legend, Public Methods
CXTPFontDC Methods
Class

CXTPFontDC Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
ReleaseColor | Call this member function to set the initial text color back into the device context.
ReleaseFont | Call this member function to select the initial font back into the device context.
SetColor | Call this member function to change the text color set in the device context.
SetFont | Call this member function to change the font selected by the device context.
SetFontColor | Call this member function to change the font and color selected by the device context.


CXTPFontDC::ReleaseColor Method

CXTPFontDC Methods, CXTPFontDC Class
CXTPFontDC::ReleaseColor Method

Call this member function to set the initial text color back into the device context.

void ReleaseColor();
Remarks

This method is also called from the destructor.

Group

CXTPFontDC Methods


CXTPFontDC::ReleaseFont Method

CXTPFontDC Methods, CXTPFontDC Class
CXTPFontDC::ReleaseFont Method

Call this member function to select the initial font back into the device context.

void ReleaseFont();
Remarks

This method is also called from the destructor.

Group

CXTPFontDC Methods


CXTPFontDC::SetColor Method

CXTPFontDC Methods, CXTPFontDC Class
CXTPFontDC::SetColor Method

Call this member function to change the text color set in the device context.

void SetColor(
    COLORREF clrTextColor
);
Parameters

clrTextColor
Text color to set in the DC.

Group

CXTPFontDC Methods


CXTPFontDC::SetFont Method

CXTPFontDC Methods, CXTPFontDC Class
CXTPFontDC::SetFont Method

Call this member function to change the font selected by the device context.

void SetFont(
    CFont* pFont
);
Parameters

pFont
Pointer to a CFont object to select into the device context.

Group

CXTPFontDC Methods


CXTPFontDC::SetFontColor Method

CXTPFontDC Methods, CXTPFontDC Class
CXTPFontDC::SetFontColor Method

Call this member function to change the font and color selected by the device context.

void SetFontColor(
    CFont* pFont,
    COLORREF clrTextColor
);
Parameters

pFont
Pointer to a CFont object to select into the device context.
clrTextColor
Text color to set in the DC.

Group

CXTPFontDC Methods


CXTPFontDC Constructors

CXTPFontDC Class, Legend, Public Methods
CXTPFontDC Constructors
Class

CXTPFontDC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPFontDC |


CXTPFontDC Constructor

CXTPFontDC Constructors
CXTPFontDC Constructor
Overload List
Constructors
Constructor | Description
CXTPFontDC::CXTPFontDC (CDC*, CFont*) | Constructs a CXTPFontDC object and selects the specified font into the device context specified by pDC.
CXTPFontDC::CXTPFontDC (CDC*, CFont*, COLORREF) | Constructs a CXTPFontDC object and selects the specified font into the device context specified by pDC.
Group

CXTPFontDC Constructors


CXTPFontDC::CXTPFontDC Constructor (CDC*, CFont*)

CXTPFontDC Constructor, CXTPFontDC Class
CXTPFontDC::CXTPFontDC Constructor (CDC*, CFont*)

Constructs a CXTPFontDC object and selects the specified font into the device context specified by pDC.

CXTPFontDC(
    CDC* pDC,
    CFont* pFont = NULL
);
CXTPFontDC(
    CDC* pDC,
    CFont* pFont,
    COLORREF clrTextColor
);
Parameters

pDC
Pointer to a valid device context.
pFont
Pointer to a CFont object to select into the device context.
clrTextColor
Text color to set in the DC.

Group

CXTPFontDC Constructor


CXTPFontDC Destructors

CXTPFontDC Class, Legend, Public Methods
CXTPFontDC Destructors
Class

CXTPFontDC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPFontDC | Destroys a CXTPFontDC object, handles cleanup and de- allocation.


CXTPFontDC::~CXTPFontDC Destructor

CXTPFontDC Destructors, CXTPFontDC Class
CXTPFontDC::~CXTPFontDC Destructor

Destroys a CXTPFontDC object, handles cleanup and de- allocation.

virtual ~CXTPFontDC();
Group

CXTPFontDC Destructors


CXTPImageManager Class

XTPImageManager.h, Classes, Legend, Members, Topics, CXTPImageManager Data Members, CXTPImageManager Methods, CXTPImageManager Constructors, CXTPImageManager Destructors, CXTPImageManager Constructors, CXTPImageManager Data Members, CXTPImageManager Destructors, CXTPImageManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManager Class

CXTPImageManager is a stand alone class. It is used to manipulate icons.

Class Hierarchy

class CXTPImageManager;
File

XTPImageManager.h

Group

Classes

Legend
Data Member
Method
CXTPImageManager Constructors
CXTPImageManager Constructors | Description
CXTPImageManager | Constructs a CXTPImageManager object.
CXTPImageManager Data Members
CXTPImageManager Data Members | Description
m_bAutoResample | TRUE to automatically re-sample alpha bitmaps if msimg32 not found.
m_bUseResources | TRUE to create single bitmap for all icons
m_dDisabledAlphaFactor | Alpha factor of disabled icons.
m_dDisabledBrightnessFactor | Brightness factor of disabled icons.
m_nAlphaClipFormat | Clipboard format of icons.
m_nImageClipFormat | Clipboard format of icons.
CXTPImageManager Destructors
CXTPImageManager Destructors | Description
~CXTPImageManager | Destroys a CXTPImageManager object, handles cleanup and deallocation.
CXTPImageManager Methods
CXTPImageManager Methods | Description
AddCustomIcon | This method used by CommandBars to add custom icons
AddIcons | Adds the icons from another image manager.
AlphaBlend | The AlphaBlend function displays bitmaps that have transparent or semitransparent pixels.
BlackWhiteBitmap | This function make a rectangle on device context as gray scale.
Create32BPPDIBSection | This helper method creates 32bit bitmap
DisableBitmap | This function make a rectangle on device context as disabled.
DoPropExchange |
DrawReverted | Mirrors images around the y-axis, useful in RTL (Right-To-Left) Languages.
GetBitmapMaskColor |
GetIconSet | Call this member to get the icons set with the specified Id.
GetImage | Call this member to get the icons with the specified Id and width.
GetImageList | Call this member to get the icons set with the specified Id from an image list.
GetImages | Retrieves a collection of images.
GetMaskColor | Retrieves color mask.
IsAlphaBitmapResource | Checks if bitmap with specified resource has alpha channel.
IsAlphaIconsImageListSupported | Determines if the OS supports alpha image list.
IsAlphaIconsSupported | Determines if the OS supports alpha icons.
IsDrawReverted | Checks if the icons are drawn mirroredreverted.
IsPrimaryImageExists | Call this method to determine if non scaled image exists in image manager
Lookup | Checks if icons set exists with the specified ID.
RefreshAll | Redraws all icons.
RemoveAll | Removes all icons.
RemoveIcon | Removes the specified icon.
ResampleAlphaLayer |
Serialize |
SetIcon |
SetIconFromIcoFile | This method loads icon from ico file
SetIcons |
SetImageList |
SetMaskColor | Call this method to set the color mask of the bitmaps that will be added.
TransparentBlt | The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.


CXTPImageManager Data Members

CXTPImageManager Class, Legend, Public Data Members
CXTPImageManager Data Members
Class

CXTPImageManager Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bAutoResample | TRUE to automatically re-sample alpha bitmaps if msimg32 not found.
m_bUseResources | TRUE to create single bitmap for all icons
m_dDisabledAlphaFactor | Alpha factor of disabled icons.
m_dDisabledBrightnessFactor | Brightness factor of disabled icons.
m_nAlphaClipFormat | Clipboard format of icons.
m_nImageClipFormat | Clipboard format of icons.


CXTPImageManager::m_bAutoResample Data Member

CXTPImageManager Data Members, CXTPImageManager Class
CXTPImageManager::m_bAutoResample Data Member

TRUE to automatically re-sample alpha bitmaps if msimg32 not found.

BOOL m_bAutoResample;
Group

CXTPImageManager Data Members


CXTPImageManager::m_bUseResources Data Member

CXTPImageManager Data Members, CXTPImageManager Class
CXTPImageManager::m_bUseResources Data Member

TRUE to create single bitmap for all icons

BOOL m_bUseResources;
Group

CXTPImageManager Data Members


CXTPImageManager::m_dDisabledAlphaFactor Data Member

CXTPImageManager Data Members, CXTPImageManager Class
CXTPImageManager::m_dDisabledAlphaFactor Data Member

Alpha factor of disabled icons.

double m_dDisabledAlphaFactor;
Group

CXTPImageManager Data Members


CXTPImageManager::m_dDisabledBrightnessFactor Data Member

CXTPImageManager Data Members, CXTPImageManager Class
CXTPImageManager::m_dDisabledBrightnessFactor Data Member

Brightness factor of disabled icons.

double m_dDisabledBrightnessFactor;
Group

CXTPImageManager Data Members


CXTPImageManager::m_nAlphaClipFormat Data Member

CXTPImageManager Data Members, CXTPImageManager Class
CXTPImageManager::m_nAlphaClipFormat Data Member

Clipboard format of icons.

CLIPFORMAT m_nAlphaClipFormat;
Group

CXTPImageManager Data Members


CXTPImageManager::m_nImageClipFormat Data Member

CXTPImageManager Data Members, CXTPImageManager Class
CXTPImageManager::m_nImageClipFormat Data Member

Clipboard format of icons.

CLIPFORMAT m_nImageClipFormat;
Group

CXTPImageManager Data Members


CXTPImageManager Methods

CXTPImageManager Class, Legend, Public Methods
CXTPImageManager Methods
Class

CXTPImageManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddCustomIcon | This method used by CommandBars to add custom icons
AddIcons | Adds the icons from another image manager.
AlphaBlend | The AlphaBlend function displays bitmaps that have transparent or semitransparent pixels.
BlackWhiteBitmap | This function make a rectangle on device context as gray scale.
Create32BPPDIBSection | This helper method creates 32bit bitmap
DisableBitmap | This function make a rectangle on device context as disabled.
DoPropExchange |
DrawReverted | Mirrors images around the y-axis, useful in RTL (Right-To-Left) Languages.
GetBitmapMaskColor |
GetIconSet | Call this member to get the icons set with the specified Id.
GetImage | Call this member to get the icons with the specified Id and width.
GetImageList | Call this member to get the icons set with the specified Id from an image list.
GetImages | Retrieves a collection of images.
GetMaskColor | Retrieves color mask.
IsAlphaBitmapResource | Checks if bitmap with specified resource has alpha channel.
IsAlphaIconsImageListSupported | Determines if the OS supports alpha image list.
IsAlphaIconsSupported | Determines if the OS supports alpha icons.
IsDrawReverted | Checks if the icons are drawn mirroredreverted.
IsPrimaryImageExists | Call this method to determine if non scaled image exists in image manager
Lookup | Checks if icons set exists with the specified ID.
RefreshAll | Redraws all icons.
RemoveAll | Removes all icons.
RemoveIcon | Removes the specified icon.
ResampleAlphaLayer |
Serialize |
SetIcon |
SetIconFromIcoFile | This method loads icon from ico file
SetIcons |
SetImageList |
SetMaskColor | Call this method to set the color mask of the bitmaps that will be added.
TransparentBlt | The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.


CXTPImageManager::AddCustomIcon Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::AddCustomIcon Method

This method used by CommandBars to add custom icons

UINT AddCustomIcon(
    const CXTPImageManagerIconHandle& hIcon
);
Parameters

hIcon
Icon Handler to be added

Returns

Identifier of new added icon.

Group

CXTPImageManager Methods


CXTPImageManager::AddIcons Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::AddIcons Method

Adds the icons from another image manager.

void AddIcons(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
A pointer to another image manager. The icons in pImageManager will be added to this image manager.

Group

CXTPImageManager Methods


CXTPImageManager::AlphaBlend Method

CXTPImageManager Methods, CXTPImageManager Class, See Also
CXTPImageManager::AlphaBlend Method

The AlphaBlend function displays bitmaps that have transparent or semitransparent pixels.

BOOL AlphaBlend(
    HDC hdcDest,
    const CRect& rcDest,
    HDC hdcSrc,
    const CRect& rcSrc
) const;
Parameters

hdcDest
handle to destination DC
rcDest
destination rectangle
hdcSrc
handle to source DC
rcSrc
source rectangle

Returns

If the function succeeds, the return value is TRUE.

See Also

TransparentBlt

Group

CXTPImageManager Methods


CXTPImageManager::BlackWhiteBitmap Method

CXTPImageManager Methods, CXTPImageManager Class, See Also
CXTPImageManager::BlackWhiteBitmap Method

This function make a rectangle on device context as gray scale.

BOOL BlackWhiteBitmap(
    HDC hDC,
    const CRect& rcRect,
    int nBlackAndWhiteContrast = 0
);
Parameters

hDC
A handle to DC
rcRect
A rectangle to be disabled
nBlackAndWhiteContrast
Black-white contrast as integer from 0 to 255

Returns

If the function succeeds, the return value is TRUE.

See Also

DisableBitmap

Group

CXTPImageManager Methods


CXTPImageManager::Create32BPPDIBSection Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::Create32BPPDIBSection Method

This helper method creates 32bit bitmap

static HBITMAP Create32BPPDIBSection(
    HDC hDC,
    int iWidth,
    int iHeight,
    LPBYTE* lpBits = NULL
);
Parameters

hDC
Pointer to valid context (can be NULL)
iWidth
Width of bitmap
iHeight
Height of bitmap
lpBits
Pointer to bits to return

Returns

Bitmap handle was created.

Group

CXTPImageManager Methods


CXTPImageManager::DisableBitmap Method

CXTPImageManager Methods, CXTPImageManager Class, See Also
CXTPImageManager::DisableBitmap Method

This function make a rectangle on device context as disabled.

BOOL DisableBitmap(
    HDC hDC,
    const CRect& rcRect,
    COLORREF clrDisabledLight = (COLORREF)-1,
    COLORREF clrDisabledDark = (COLORREF)-1
);
Parameters

hDC
A handle to DC
rcRect
A rectangle to be disabled
clrDisabledLight
The lightest color of icon to generate
clrDisabledDark
The darkest color of icon to generate

Returns

If the function succeeds, the return value is TRUE.

See Also

BlackWhiteBitmap

Group

CXTPImageManager Methods


DoPropExchange Method

CXTPImageManager Methods
DoPropExchange Method
Overload List
Methods
Method | Description
CXTPImageManager::DoPropExchange (CXTPPropExchange*) | Reads or writes icons from or to an archive.
CXTPImageManager::DoPropExchange (UINT, CXTPPropExchange*) | Reads or writes icons from or to an archive.
Group

CXTPImageManager Methods


CXTPImageManager::DoPropExchange Method (CXTPPropExchange*)

DoPropExchange Method, CXTPImageManager Class
CXTPImageManager::DoPropExchange Method (CXTPPropExchange*)

Reads or writes icons from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
void DoPropExchange(
    UINT nCommand,
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.
nCommand
Specified command to serialize.
ar
A CArchive object to serialize to or from.

Group

DoPropExchange Method


CXTPImageManager::DrawReverted Method

CXTPImageManager Methods, CXTPImageManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManager::DrawReverted Method

Mirrors images around the y-axis, useful in RTL (Right-To-Left) Languages.

void DrawReverted(
    BOOL bDrawReverted
);
Parameters

bDrawReverted
If TRUE, images are "flipped" or Mirrored. This should be used when displaying images in an application that uses RTL (Right-To-Left) Languages.

Body Source
void CXTPImageManager::DrawReverted(BOOL bDrawReverted) {
    m_bDrawReverted = bDrawReverted;
}
Group

CXTPImageManager Methods


GetBitmapMaskColor Method

CXTPImageManager Methods
GetBitmapMaskColor Method
Overload List
Methods
Method | Description
CXTPImageManager::GetBitmapMaskColor (CBitmap&, CPoint) | Retrieves color of top-left pixel.
CXTPImageManager::GetBitmapMaskColor (UINT, CPoint) | Retrieves color of top-left pixel.
Group

CXTPImageManager Methods


CXTPImageManager::GetBitmapMaskColor Method (CBitmap&, CPoint)

GetBitmapMaskColor Method, CXTPImageManager Class
CXTPImageManager::GetBitmapMaskColor Method (CBitmap&, CPoint)

Retrieves color of top-left pixel.

static COLORREF GetBitmapMaskColor(
    CBitmap& bmp,
    CPoint pt = 0
);
static COLORREF GetBitmapMaskColor(
    UINT nIDBitmap,
    CPoint pt = 0
);
Parameters

bmp
CBitmap reference.
pt
location of pixel to retrieve.
nIDBitmap
Bitmap identifier.

Returns

COLORREF that will be used as transparent color.

Group

GetBitmapMaskColor Method


CXTPImageManager::GetIconSet Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::GetIconSet Method

Call this member to get the icons set with the specified Id.

CXTPImageManagerIconSet* GetIconSet(
    UINT nCommand
) const;
Parameters

nCommand
ID of the icon set to be retrieved

Returns

A pointer to a CXTPImageManagerIconSet object

Group

CXTPImageManager Methods


CXTPImageManager::GetImage Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::GetImage Method

Call this member to get the icons with the specified Id and width.

CXTPImageManagerIcon* GetImage(
    UINT nCommand,
    int nWidth = 16
) const;
Parameters

nCommand
ID of the icon to be retrieved
nWidth
Width of the icon to be retrieved

Returns

A pointer to a CXTPImageManagerIcon

Group

CXTPImageManager Methods


CXTPImageManager::GetImageList Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::GetImageList Method

Call this member to get the icons set with the specified Id from an image list.

CXTPImageManagerImageList* GetImageList(
    UINT nCommand
) const;
Parameters

nCommand
ID of the icon set to be retrieved

Returns

A pointer to a CXTPImageManagerImageList object

Group

CXTPImageManager Methods


CXTPImageManager::GetImages Method

CXTPImageManager Methods, CXTPImageManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManager::GetImages Method

Retrieves a collection of images.

CMap<UINT, UINT, CXTPImageManagerIconSet*, CXTPImageManagerIconSet*>* GetImages();
Returns

A CMap object

Body Source
CMap<UINT, UINT, CXTPImageManagerIconSet*, CXTPImageManagerIconSet*>* CXTPImageManager::GetImages() {
    return  &m_mapImages;
}
Group

CXTPImageManager Methods


CXTPImageManager::GetMaskColor Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::GetMaskColor Method

Retrieves color mask.

COLORREF GetMaskColor() const;
Returns

Current color mask.

Group

CXTPImageManager Methods


CXTPImageManager::IsAlphaBitmapResource Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::IsAlphaBitmapResource Method

Checks if bitmap with specified resource has alpha channel.

static BOOL IsAlphaBitmapResource(
    UINT nIDResourceBitmap
);
Parameters

nIDResourceBitmap
Resource identifier of the bitmap to check.

Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPImageManager Methods


CXTPImageManager::IsAlphaIconsImageListSupported Method

CXTPImageManager Methods, CXTPImageManager Class, See Also
CXTPImageManager::IsAlphaIconsImageListSupported Method

Determines if the OS supports alpha image list.

static BOOL IsAlphaIconsImageListSupported();
Returns

TRUE if successful; otherwise returns FALSE

See Also

IsAlphaIconsSupported

Group

CXTPImageManager Methods


CXTPImageManager::IsAlphaIconsSupported Method

CXTPImageManager Methods, CXTPImageManager Class, See Also
CXTPImageManager::IsAlphaIconsSupported Method

Determines if the OS supports alpha icons.

BOOL IsAlphaIconsSupported() const;
Returns

TRUE if successful; otherwise returns FALSE.

See Also

IsAlphaIconsImageListSupported

Group

CXTPImageManager Methods


CXTPImageManager::IsDrawReverted Method

CXTPImageManager Methods, CXTPImageManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManager::IsDrawReverted Method

Checks if the icons are drawn mirroredreverted.

BOOL IsDrawReverted() const;
Returns

TRUE if icons are drawn reverted; FALSE if drawn normal.

Body Source
BOOL CXTPImageManager::IsDrawReverted() const {
    return m_bDrawReverted;
}
Group

CXTPImageManager Methods


CXTPImageManager::IsPrimaryImageExists Method

CXTPImageManager Methods, CXTPImageManager Class, See Also
CXTPImageManager::IsPrimaryImageExists Method

Call this method to determine if non scaled image exists in image manager

BOOL IsPrimaryImageExists(
    UINT nCommand,
    int nWidth
) const;
Parameters

nCommand
Image identifier to check
nWidth
Image width to check

Returns

TRUE if image non scaled image exists.

See Also

GetImage

Group

CXTPImageManager Methods


CXTPImageManager::Lookup Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::Lookup Method

Checks if icons set exists with the specified ID.

BOOL Lookup(
    UINT nCommand
) const;
Parameters

nCommand
Identifier needed to check.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPImageManager Methods


CXTPImageManager::RefreshAll Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::RefreshAll Method

Redraws all icons.

void RefreshAll();
Group

CXTPImageManager Methods


CXTPImageManager::RemoveAll Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::RemoveAll Method

Removes all icons.

void RemoveAll();
Group

CXTPImageManager Methods


CXTPImageManager::RemoveIcon Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::RemoveIcon Method

Removes the specified icon.

void RemoveIcon(
    UINT nIDCommand
);
Parameters

nIDCommand
Id of icon to be removed

Group

CXTPImageManager Methods


ResampleAlphaLayer Method

CXTPImageManager Methods
ResampleAlphaLayer Method
Overload List
Methods
Method | Description
CXTPImageManager::ResampleAlphaLayer (HBITMAP, COLORREF) | This method creates 24bit bitmap from 32bit alpha bitmaps to draw it in old OSes
CXTPImageManager::ResampleAlphaLayer (UINT, COLORREF) | This method creates 24bit bitmap from 32bit alpha bitmaps to draw it in old OSes
Group

CXTPImageManager Methods


CXTPImageManager::ResampleAlphaLayer Method (HBITMAP, COLORREF)

ResampleAlphaLayer Method, CXTPImageManager Class
CXTPImageManager::ResampleAlphaLayer Method (HBITMAP, COLORREF)

This method creates 24bit bitmap from 32bit alpha bitmaps to draw it in old OSes

static HBITMAP ResampleAlphaLayer(
    HBITMAP bmpAlpha,
    COLORREF clrMask
);
static HBITMAP ResampleAlphaLayer(
    UINT nIDBitmap,
    COLORREF clrMask
);
Parameters

bmpAlpha
Resource bitmap identifier.
clrMask
Mask color to be used
nIDBitmap
Resource bitmap identifier.

Returns

Reduced bitmap handler.

Group

ResampleAlphaLayer Method


Serialize Method

CXTPImageManager Methods
Serialize Method
Overload List
Methods
Method | Description
CXTPImageManager::Serialize (CArchive&) | Reads or writes icons from or to an archive.
CXTPImageManager::Serialize (UINT, CArchive&) | Reads or writes icons from or to an archive.
Group

CXTPImageManager Methods


CXTPImageManager::Serialize Method (CArchive&)

Serialize Method, CXTPImageManager Class
CXTPImageManager::Serialize Method (CArchive&)

Reads or writes icons from or to an archive.

void Serialize(
    CArchive& ar
);
void Serialize(
    UINT nCommand,
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.
nCommand
Specified command to serialize.
pPX
A CXTPPropExchange object to serialize to or from.

Group

Serialize Method


SetIcon Method

CXTPImageManager Methods
SetIcon Method
Overload List
Methods
Method | Description
CXTPImageManager::SetIcon (LPCTSTR, UINT, CSize, XTPImageState) |
CXTPImageManager::SetIcon (UINT, UINT, CSize, XTPImageState) |
CXTPImageManager::SetIcon (const CXTPImageManagerIconHandle&, UINT, CSize, XTPImageState) | Adds the icon.
Group

CXTPImageManager Methods


CXTPImageManager::SetIcon Method (LPCTSTR, UINT, CSize, XTPImageState)

SetIcon Method, CXTPImageManager Class
CXTPImageManager::SetIcon Method (LPCTSTR, UINT, CSize, XTPImageState)
BOOL SetIcon(
    LPCTSTR lpszResourceIcon,
    UINT nIDCommand,
    CSize szIcon = 0,
    XTPImageState imageState = xtpImageNormal
);
Group

SetIcon Method


CXTPImageManager::SetIcon Method (UINT, UINT, CSize, XTPImageState)

SetIcon Method, CXTPImageManager Class
CXTPImageManager::SetIcon Method (UINT, UINT, CSize, XTPImageState)
BOOL SetIcon(
    UINT nIDResourceIcon,
    UINT nIDCommand,
    CSize szIcon = 0,
    XTPImageState imageState = xtpImageNormal
);
Group

SetIcon Method


CXTPImageManager::SetIcon Method (const CXTPImageManagerIconHandle&, UINT, CSize, XTPImageState)

SetIcon Method, CXTPImageManager Class, See Also
CXTPImageManager::SetIcon Method (const CXTPImageManagerIconHandle&, UINT, CSize, XTPImageState)

Adds the icon.

BOOL SetIcon(
    const CXTPImageManagerIconHandle& hIcon,
    UINT nIDCommand,
    CSize szIcon = 0,
    XTPImageState imageState = xtpImageNormal
);
Parameters

hIcon
Icon handle to add
nIDCommand
Icon identifier.
szIcon
Size of the icons.
imageState
Images state.
nIDResourceIcon
Icon resource identifier

Returns

TRUE if successful; otherwise returns FALSE

See Also

XTPImageState, SetIcons

Group

SetIcon Method


CXTPImageManager::SetIconFromIcoFile Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::SetIconFromIcoFile Method

This method loads icon from ico file

BOOL SetIconFromIcoFile(
    LPCTSTR lpszFileName,
    UINT nIDCommand,
    CSize szIcon,
    XTPImageState imageState
);
Parameters

lpszFileName
Path to ico file
nIDCommand
Icon command
szIcon
Size of the icons.
imageState
Images state.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPImageManager Methods


SetIcons Method

CXTPImageManager Methods
SetIcons Method
Overload List
Methods
Method | Description
CXTPImageManager::SetIcons (CBitmap&, UINT*, int, CSize, XTPImageState, BOOL) | Adds the icons.
CXTPImageManager::SetIcons (CImageList&, UINT*, int, CSize, XTPImageState) | Adds the icons.
CXTPImageManager::SetIcons (LPCTSTR, UINT*, int, CSize, XTPImageState) | Adds the icons.
CXTPImageManager::SetIcons (UINT, CBitmap&, XTPImageState) | Adds the icons.
CXTPImageManager::SetIcons (UINT, CImageList&, XTPImageState) | Adds the icons.
CXTPImageManager::SetIcons (UINT, UINT, XTPImageState) | Adds the icons.
CXTPImageManager::SetIcons (UINT, UINT*, int, CSize, XTPImageState) | Adds the icons.
CXTPImageManager::SetIcons (UINT, XTPImageState) | Adds the icons.
Group

CXTPImageManager Methods


CXTPImageManager::SetIcons Method (UINT, XTPImageState)

SetIcons Method, CXTPImageManager Class, Example, See Also
CXTPImageManager::SetIcons Method (UINT, XTPImageState)

Adds the icons.

BOOL SetIcons(
    UINT nIDResourceToolBar,
    XTPImageState imageState = xtpImageNormal
);
BOOL SetIcons(
    UINT nIDResourceToolBar,
    UINT nIDResourceBitmap,
    XTPImageState imageState = xtpImageNormal
);
BOOL SetIcons(
    CBitmap& bmpIcons,
    UINT* pCommands,
    int nCount,
    CSize szIcon,
    XTPImageState imageState = xtpImageNormal,
    BOOL bAlpha = FALSE
);
BOOL SetIcons(
    UINT nIDResourceToolBar,
    CBitmap& bmpIcons,
    XTPImageState imageState = xtpImageNormal
);
BOOL SetIcons(
    UINT nIDResourceBitmap,
    UINT* pCommands,
    int nCount,
    CSize szIcon,
    XTPImageState imageState = xtpImageNormal
);
BOOL SetIcons(
    LPCTSTR lpszResourceBitmap,
    UINT* pCommands,
    int nCount,
    CSize szIcon,
    XTPImageState imageState = xtpImageNormal
);
BOOL SetIcons(
    CImageList& imlIcons,
    UINT* pCommands,
    int nCount,
    CSize szIcon,
    XTPImageState imageState = xtpImageNormal
);
BOOL SetIcons(
    UINT nIDResourceToolBar,
    CImageList& imlIcons,
    XTPImageState imageState = xtpImageNormal
);
Parameters

nIDResourceToolBar
Toolbar resource identifier
imageState
Images state.
nIDResourceBitmap
Bitmap resource identifier
bmpIcons
Bitmap containing icons to be added.
pCommands
Pointer to an array of IDs.
nCount
Number of elements in the array pointed to by lpIDArray.
szIcon
Size of the icons.
bAlpha
TRUE if bitmap has alpha channel.
lpszResourceBitmap
Bitmap resource identifier
imlIcons
Image list containing the icons to be added.

Returns

TRUE if successful; otherwise returns FALSE

See Also

XTPImageState, SetIcon

Example
static UINT buttons[] =
{
    ID_BACK,
    ID_FORWARD,
    ID_STOP,
    ID_REFRESH,
    ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16, 16), xtpImageNormal);
XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons, _countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24, 24), xtpImageNormal);
XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons, _countof(buttons), CSize(24, 24), xtpImageHot);
Group

SetIcons Method


SetImageList Method

CXTPImageManager Methods
SetImageList Method
Overload List
Methods
Method | Description
CXTPImageManager::SetImageList (HIMAGELIST, int, BOOL) | Call this to attach images from a HIMAGELIST control to the image manager
CXTPImageManager::SetImageList (UINT, int, int, COLORREF) | Call this to create system HIMAGELIST from bitmap and add it to image manager
Group

CXTPImageManager Methods


CXTPImageManager::SetImageList Method (HIMAGELIST, int, BOOL)

SetImageList Method, CXTPImageManager Class
CXTPImageManager::SetImageList Method (HIMAGELIST, int, BOOL)

Call this to attach images from a HIMAGELIST control to the image manager

BOOL SetImageList(
    HIMAGELIST hImageList,
    int nBaseCommand,
    BOOL bDestoryImageList = FALSE
);
Parameters

hImageList
Pointer to an imagelist that holds icons
nBaseCommand
ID to start numbering icons from the imagelist
bDestoryImageList
Destroy imagelist control after the icons are copied to the imagemanager

Group

SetImageList Method


CXTPImageManager::SetImageList Method (UINT, int, int, COLORREF)

SetImageList Method, CXTPImageManager Class, See Also
CXTPImageManager::SetImageList Method (UINT, int, int, COLORREF)

Call this to create system HIMAGELIST from bitmap and add it to image manager

BOOL SetImageList(
    UINT nIDResourceBitmap,
    int cx,
    int nBaseCommand = 0,
    COLORREF clrMask = (COLORREF)-1
);
Parameters

nIDResourceBitmap
Bitmap resource identifier
cx
Width of the icons
nBaseCommand
ID to start numbering icons from the imagelist
clrMask
Mask color for bitmap

Remarks

SetIcons method loads bitmaps and creates HICON for each icon in bitmap, SetImageList creates only one HIMAGELIST. use SetImageList to create only one GDI object for all icons.

See Also

SetIcons

Group

SetImageList Method


CXTPImageManager::SetMaskColor Method

CXTPImageManager Methods, CXTPImageManager Class
CXTPImageManager::SetMaskColor Method

Call this method to set the color mask of the bitmaps that will be added.

COLORREF SetMaskColor(
    COLORREF clrMask
);
Parameters

clrMask
Mask color to be set.

Returns

Previous color mask.

Group

CXTPImageManager Methods


CXTPImageManager::TransparentBlt Method

CXTPImageManager Methods, CXTPImageManager Class, See Also
CXTPImageManager::TransparentBlt Method

The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.

BOOL TransparentBlt(
    HDC hdcDest,
    const CRect& rcDest,
    HDC hdcSrc,
    const CRect& rcSrc,
    UINT crTransparent
) const;
Parameters

hdcDest
handle to destination DC
rcDest
destination rectangle
hdcSrc
handle to source DC
rcSrc
source rectangle
crTransparent
color to make transparent

Returns

If the function succeeds, the return value is TRUE.

See Also

AlphaBlend

Group

CXTPImageManager Methods


CXTPImageManager Constructors

CXTPImageManager Class, Legend, Public Methods
CXTPImageManager Constructors
Class

CXTPImageManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageManager | Constructs a CXTPImageManager object.


CXTPImageManager::CXTPImageManager Constructor

CXTPImageManager Constructors, CXTPImageManager Class
CXTPImageManager::CXTPImageManager Constructor

Constructs a CXTPImageManager object.

CXTPImageManager();
Group

CXTPImageManager Constructors


CXTPImageManager Destructors

CXTPImageManager Class, Legend, Public Methods
CXTPImageManager Destructors
Class

CXTPImageManager Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPImageManager | Destroys a CXTPImageManager object, handles cleanup and deallocation.


CXTPImageManager::~CXTPImageManager Destructor

CXTPImageManager Destructors, CXTPImageManager Class
CXTPImageManager::~CXTPImageManager Destructor

Destroys a CXTPImageManager object, handles cleanup and deallocation.

~CXTPImageManager();
Group

CXTPImageManager Destructors


CXTPImageManagerIcon Class

XTPImageManager.h, Classes, Legend, Members, Topics, CXTPImageManagerIcon Data Members, CXTPImageManagerIcon Methods, CXTPImageManagerIcon Constructors, CXTPImageManagerIcon Destructors, CXTPImageManagerIcon Constructors, CXTPImageManagerIcon Data Members, CXTPImageManagerIcon Destructors, CXTPImageManagerIcon Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIcon Class

Icons holder class.

Class Hierarchy

class CXTPImageManagerIcon;
File

XTPImageManager.h

Group

Classes

Legend
Data Member
Method
CXTPImageManagerIcon Constructors
CXTPImageManagerIcon Constructors | Description
CXTPImageManagerIcon |
CXTPImageManagerIcon Data Members
CXTPImageManagerIcon Data Members | Description
m_bDrawComposited | Draw on Vista composited rects.
CXTPImageManagerIcon Destructors
CXTPImageManagerIcon Destructors | Description
~CXTPImageManagerIcon | Destroys a CXTPImageManagerIcon object, handles cleanup and deallocation.
CXTPImageManagerIcon Methods
CXTPImageManagerIcon Methods | Description
CopyAlphaBitmap | Copies alpha bitmap.
CreateDisabledIcon | Creates a disabled icon.
Draw |
DrawAlphaBitmap | The DrawAlphaBitmap function displays bitmaps that have transparent or semitransparent pixels.
DrawIconComposited | Call this method to draw non-alpha icon in composited Vista Glass rectangle
DrawMono | Draws the image using the brush specified by the clrBrush parameter.
GetBitmapBits | This helper method retrieves information about alpha bitmap and its alpha bits.
GetCheckedIcon | Retrieves the shadow for the icon.
GetDisabledIcon | Retrieves the disabled icon.
GetExtent |
GetFadedIcon | Retrieves the faded icon.
GetHeight | Retrieves the icon height.
GetHotIcon | Retrieves hot icon.
GetIcon |
GetID | Retrieves the image identifier.
GetPressedIcon | Retrieves the pressed icon.
GetShadowIcon | Retrieves the shadow for the icon.
GetWidth | Retrieves the icon width.
HasDisabledIcon | Determines if disabled icon exists
InvertAlphaBitmap | This method is called to create mirror copy of bitmap
IsAlpha | Checks if the image has alpha channel.
IsAlphaBitmapFile | This method tests if file is alpha bitmap.
IsAlphaBitmapResource | Checks if bitmap with specified resource has alpha channel.
IsPngBitmapFile | This method tests if file is png image.
IsPngBitmapResource | Checks if bitmap with specified resource is png resource.
IsScaled | Checks if icons was scaled from another CXTPImageManagerIcon object.
LoadAlphaBitmap |
LoadAlphaIcon | This method loads alpha bitmap from icon file.
LoadBitmapFromFile | This method loads bitmap from file on disk
LoadBitmapFromResource |
PreMultiplyAlphaBitmap | Creates valid alpha bits to use in AlphaBlend.
Refresh | Redraw Fade and Shadow icons.
ScaleToFit | Use this method to scale icon.
Serialize | Reads or writes this object from or to an archive.
SerializeIcon | Reads or writes this object from or to an archive.
SetCheckedIcon | Sets the checked icon.
SetDisabledIcon | Sets the disabled icon.
SetHotIcon | Sets the hot icon.
SetIcon |
SetNormalIcon | Sets the icon.
SetPressedIcon | Sets the pressed icon.


CXTPImageManagerIcon Data Members

CXTPImageManagerIcon Class, Legend, Public Data Members
CXTPImageManagerIcon Data Members
Class

CXTPImageManagerIcon Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bDrawComposited | Draw on Vista composited rects.


CXTPImageManagerIcon::m_bDrawComposited Data Member

CXTPImageManagerIcon Data Members, CXTPImageManagerIcon Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIcon::m_bDrawComposited Data Member

Draw on Vista composited rects.

BOOL m_bDrawComposited;
Group

CXTPImageManagerIcon Data Members


CXTPImageManagerIcon Methods

CXTPImageManagerIcon Class, Legend, Public Methods
CXTPImageManagerIcon Methods
Class

CXTPImageManagerIcon Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
CopyAlphaBitmap | Copies alpha bitmap.
CreateDisabledIcon | Creates a disabled icon.
Draw |
DrawAlphaBitmap | The DrawAlphaBitmap function displays bitmaps that have transparent or semitransparent pixels.
DrawIconComposited | Call this method to draw non-alpha icon in composited Vista Glass rectangle
DrawMono | Draws the image using the brush specified by the clrBrush parameter.
GetBitmapBits | This helper method retrieves information about alpha bitmap and its alpha bits.
GetCheckedIcon | Retrieves the shadow for the icon.
GetDisabledIcon | Retrieves the disabled icon.
GetExtent |
GetFadedIcon | Retrieves the faded icon.
GetHeight | Retrieves the icon height.
GetHotIcon | Retrieves hot icon.
GetIcon |
GetID | Retrieves the image identifier.
GetPressedIcon | Retrieves the pressed icon.
GetShadowIcon | Retrieves the shadow for the icon.
GetWidth | Retrieves the icon width.
HasDisabledIcon | Determines if disabled icon exists
InvertAlphaBitmap | This method is called to create mirror copy of bitmap
IsAlpha | Checks if the image has alpha channel.
IsAlphaBitmapFile | This method tests if file is alpha bitmap.
IsAlphaBitmapResource | Checks if bitmap with specified resource has alpha channel.
IsPngBitmapFile | This method tests if file is png image.
IsPngBitmapResource | Checks if bitmap with specified resource is png resource.
IsScaled | Checks if icons was scaled from another CXTPImageManagerIcon object.
LoadAlphaBitmap |
LoadAlphaIcon | This method loads alpha bitmap from icon file.
LoadBitmapFromFile | This method loads bitmap from file on disk
LoadBitmapFromResource |
PreMultiplyAlphaBitmap | Creates valid alpha bits to use in AlphaBlend.
Refresh | Redraw Fade and Shadow icons.
ScaleToFit | Use this method to scale icon.
Serialize | Reads or writes this object from or to an archive.
SerializeIcon | Reads or writes this object from or to an archive.
SetCheckedIcon | Sets the checked icon.
SetDisabledIcon | Sets the disabled icon.
SetHotIcon | Sets the hot icon.
SetIcon |
SetNormalIcon | Sets the icon.
SetPressedIcon | Sets the pressed icon.


CXTPImageManagerIcon::CopyAlphaBitmap Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::CopyAlphaBitmap Method

Copies alpha bitmap.

static HBITMAP CopyAlphaBitmap(
    HBITMAP hBitmap,
    LPBYTE* lpBits = NULL
);
Parameters

hBitmap
Bitmap handler to be copied.

Returns

new alpha bitmap handler.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::CreateDisabledIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::CreateDisabledIcon Method

Creates a disabled icon.

void CreateDisabledIcon(
    COLORREF clrDisabledLight = (COLORREF)-1,
    COLORREF clrDisabledDark = (COLORREF)-1
);
Parameters

clrDisabledLight
The lightest color of icon to generate
clrDisabledDark
The darkest color of icon to generate

Group

CXTPImageManagerIcon Methods


Draw Method

CXTPImageManagerIcon Methods
Draw Method
Overload List
Methods
Method | Description
CXTPImageManagerIcon::Draw (CDC*, CPoint) | Draws the image in specified location.
CXTPImageManagerIcon::Draw (CDC*, CPoint, CSize) | Draws the image in specified location.
CXTPImageManagerIcon::Draw (CDC*, CPoint, CXTPImageManagerIconHandle&, CSize) | Draws the image in specified location.
Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::Draw Method (CDC*, CPoint)

Draw Method, CXTPImageManagerIcon Class
CXTPImageManagerIcon::Draw Method (CDC*, CPoint)

Draws the image in specified location.

void Draw(
    CDC* pDC,
    CPoint pt
);
void Draw(
    CDC* pDC,
    CPoint pt,
    CSize szIcon
);
void Draw(
    CDC* pDC,
    CPoint pt,
    CXTPImageManagerIconHandle& hIcon,
    CSize szIcon = 0
);
Parameters

pDC
Destination device context.
pt
Specifies the location of the image
szIcon
Specifies the size of the image.
hIcon
A handle to an icon.

Group

Draw Method


CXTPImageManagerIcon::DrawAlphaBitmap Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::DrawAlphaBitmap Method

The DrawAlphaBitmap function displays bitmaps that have transparent or semitransparent pixels.

static void DrawAlphaBitmap(
    CDC* pDC,
    HBITMAP hBitmap,
    CPoint ptDest,
    CSize szDest,
    CPoint ptSrc = 0,
    CSize szSrc = 0
);
Parameters

pDC
Pointer to destination device context
hBitmap
Alpha bitmap handler
ptDest
upper-left corner of the destination rectangle
szDest
Destination size
ptSrc
upper-left corner of the source rectangle
szSrc
Source size

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::DrawIconComposited Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::DrawIconComposited Method

Call this method to draw non-alpha icon in composited Vista Glass rectangle

static void DrawIconComposited(
    CDC* pDC,
    CPoint pt,
    CSize szIcon,
    HICON hIcon
);
Parameters

pDC
Pointer to device context
pt
Pointer to draw icon
szIcon
Size of the icon
hIcon
Icon handle to draw

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::DrawMono Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::DrawMono Method

Draws the image using the brush specified by the clrBrush parameter.

void DrawMono(
    CDC* pDC,
    CPoint pt,
    CXTPImageManagerIconHandle& hIcon,
    CSize szIcon,
    COLORREF clrBrush
);
Parameters

pDC
Destination device context.
pt
Specifies the location of the image.
hIcon
A handle to an icon.
clrBrush
color of the brush used to draw the image.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetBitmapBits Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetBitmapBits Method

This helper method retrieves information about alpha bitmap and its alpha bits.

static BOOL GetBitmapBits(
    CDC& dcSrc,
    HBITMAP hBitmap,
    PBITMAPINFO& pbmi,
    LPVOID& pBits,
    UINT& nSize
);
Parameters

dcSrc
Reference to CDC
hBitmap
Alpha bitmap
pbmi
Bitmap information
pBits
Bitmap bits
nSize
Size of bits array

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetCheckedIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetCheckedIcon Method

Retrieves the shadow for the icon.

CXTPImageManagerIconHandle& GetCheckedIcon();
Returns

Icon handle.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetDisabledIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetDisabledIcon Method

Retrieves the disabled icon.

CXTPImageManagerIconHandle& GetDisabledIcon(
    BOOL bCreateIfNotExists = TRUE
);
Parameters

bCreateIfNotExists
Create if image not exists.

Returns

Icon handle.

Group

CXTPImageManagerIcon Methods


GetExtent Method

CXTPImageManagerIcon Methods
GetExtent Method
Overload List
Methods
Method | Description
CXTPImageManagerIcon::GetExtent () | Retrieves the size of the icon.
CXTPImageManagerIcon::GetExtent (HICON) | Retrieves the size of the icon.
Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetExtent Method ()

GetExtent Method, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetExtent Method ()

Retrieves the size of the icon.

CSize GetExtent() const;
static CSize GetExtent(
    HICON hIcon
);
Parameters

hIcon
Icon handle.

Returns

Size of the icon.

Group

GetExtent Method


CXTPImageManagerIcon::GetFadedIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetFadedIcon Method

Retrieves the faded icon.

CXTPImageManagerIconHandle& GetFadedIcon();
Returns

Icon handle.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetHeight Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetHeight Method

Retrieves the icon height.

int GetHeight() const;
Returns

Height of the icon.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetHotIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetHotIcon Method

Retrieves hot icon.

CXTPImageManagerIconHandle& GetHotIcon();
Returns

Icon handle.

Group

CXTPImageManagerIcon Methods


GetIcon Method

CXTPImageManagerIcon Methods
GetIcon Method
Overload List
Methods
Method | Description
CXTPImageManagerIcon::GetIcon () | Retrieves the icon handle.
CXTPImageManagerIcon::GetIcon (XTPImageState) | Retrieves the icon handle.
Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetIcon Method ()

GetIcon Method, CXTPImageManagerIcon Class, See Also
CXTPImageManagerIcon::GetIcon Method ()

Retrieves the icon handle.

CXTPImageManagerIconHandle& GetIcon();
CXTPImageManagerIconHandle& GetIcon(
    XTPImageState imageState
);
Parameters

imageState
Image state for icon to retrieve

Returns

Icon handle.

See Also

XTPImageState

Group

GetIcon Method


CXTPImageManagerIcon::GetID Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetID Method

Retrieves the image identifier.

UINT GetID() const;
Returns

Identifier of the image

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetPressedIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetPressedIcon Method

Retrieves the pressed icon.

CXTPImageManagerIconHandle& GetPressedIcon();
Returns

Icon handle.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetShadowIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetShadowIcon Method

Retrieves the shadow for the icon.

CXTPImageManagerIconHandle& GetShadowIcon();
Returns

Icon handle.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::GetWidth Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::GetWidth Method

Retrieves the icon width.

int GetWidth() const;
Returns

Width of the icon.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::HasDisabledIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::HasDisabledIcon Method

Determines if disabled icon exists

BOOL HasDisabledIcon() const;
Returns

TRUE if disabled icon exists

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::InvertAlphaBitmap Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::InvertAlphaBitmap Method

This method is called to create mirror copy of bitmap

static HBITMAP InvertAlphaBitmap(
    HBITMAP hBitmap
);
Parameters

hBitmap
Bitmap handle to make copy

Returns

new mirror bitmap

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::IsAlpha Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::IsAlpha Method

Checks if the image has alpha channel.

BOOL IsAlpha() const;
Returns

TRUE if the image has alpha channel; otherwise returns FALSE

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::IsAlphaBitmapFile Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::IsAlphaBitmapFile Method

This method tests if file is alpha bitmap.

static BOOL IsAlphaBitmapFile(
    LPCTSTR pszFileName
);
Parameters

pszFileName
File path.

Returns

TRUE if file is alpha bitmap

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::IsAlphaBitmapResource Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::IsAlphaBitmapResource Method

Checks if bitmap with specified resource has alpha channel.

static BOOL IsAlphaBitmapResource(
    HMODULE hModule,
    LPCTSTR lpBitmapName
);
Parameters

hModule
Module of the bitmap to check.
lpBitmapName
Resource name of the bitmap to check.

Returns

TRUE if bitmap has alpha channel; otherwise returns FALSE.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::IsPngBitmapFile Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::IsPngBitmapFile Method

This method tests if file is png image.

static BOOL IsPngBitmapFile(
    LPCTSTR pszFileName
);
Parameters

pszFileName
File path.

Returns

TRUE if file is png image

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::IsPngBitmapResource Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::IsPngBitmapResource Method

Checks if bitmap with specified resource is png resource.

static BOOL IsPngBitmapResource(
    HMODULE hModule,
    LPCTSTR lpBitmapName
);
Parameters

hModule
Module of the bitmap to check.
lpBitmapName
Resource name of the bitmap to check.

Returns

TRUE if bitmap is png resource; otherwise returns FALSE.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::IsScaled Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIcon::IsScaled Method

Checks if icons was scaled from another CXTPImageManagerIcon object.

BOOL IsScaled() const;
Body Source
BOOL CXTPImageManagerIcon::IsScaled() const {
    return FALSE;
}
Group

CXTPImageManagerIcon Methods


LoadAlphaBitmap Method

CXTPImageManagerIcon Methods
LoadAlphaBitmap Method
Overload List
Methods
Method | Description
CXTPImageManagerIcon::LoadAlphaBitmap (HMODULE, LPCTSTR) | This method loads Alpha bitmap from resource file
CXTPImageManagerIcon::LoadAlphaBitmap (UINT) | This method loads Alpha bitmap from resource file
Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::LoadAlphaBitmap Method (UINT)

LoadAlphaBitmap Method, CXTPImageManagerIcon Class
CXTPImageManagerIcon::LoadAlphaBitmap Method (UINT)

This method loads Alpha bitmap from resource file

static HBITMAP LoadAlphaBitmap(
    UINT nIDResource
);
static HBITMAP LoadAlphaBitmap(
    HMODULE hModule,
    LPCTSTR lpszResource
);
Parameters

nIDResource
Resource identifier
hModule
Handle to the instance of the module whose executable file contains the bitmap to be loaded.
lpszResource
Long pointer to a null-terminated string that contains the name of the bitmap resource to be loaded

Returns

Alpha bitmap handler.

Remarks

Don't use LoadImage to load alpha bitmap, it loose alpha channel in some Windows.

Group

LoadAlphaBitmap Method


CXTPImageManagerIcon::LoadAlphaIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::LoadAlphaIcon Method

This method loads alpha bitmap from icon file.

static HBITMAP LoadAlphaIcon(
    LPCTSTR pszFileName,
    int nWidth
);
Parameters

pszFileName
File path.
nWidth
Icon width to load.

Returns

Alpha bitmap if icon with specified width was found; otherwise returns NULL.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::LoadBitmapFromFile Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::LoadBitmapFromFile Method

This method loads bitmap from file on disk

static HBITMAP LoadBitmapFromFile(
    LPCTSTR lpszFileName,
    BOOL* lbAlphaBitmap = NULL
);
Parameters

lpszFileName
File name of bitmap or png file
lbAlphaBitmap
Determines if bitmap contained alpha layer

Returns

Bitmap handler.

Remarks

This method loads png or bitmap from file

Group

CXTPImageManagerIcon Methods


LoadBitmapFromResource Method

CXTPImageManagerIcon Methods
LoadBitmapFromResource Method
Overload List
Methods
Method | Description
CXTPImageManagerIcon::LoadBitmapFromResource (HMODULE, LPCTSTR, BOOL*) | This method loads Alpha bitmap from resource file
CXTPImageManagerIcon::LoadBitmapFromResource (LPCTSTR, BOOL*) | This method loads Alpha bitmap from resource file
Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::LoadBitmapFromResource Method (LPCTSTR, BOOL*)

LoadBitmapFromResource Method, CXTPImageManagerIcon Class
CXTPImageManagerIcon::LoadBitmapFromResource Method (LPCTSTR, BOOL*)

This method loads Alpha bitmap from resource file

static HBITMAP LoadBitmapFromResource(
    LPCTSTR lpszResource,
    BOOL* lbAlphaBitmap
);
static HBITMAP LoadBitmapFromResource(
    HMODULE hModule,
    LPCTSTR lpszResource,
    BOOL* lbAlphaBitmap
);
Parameters

lpszResource
Long pointer to a null-terminated string that contains the name of the bitmap resource to be loaded
lbAlphaBitmap
Determines if bitmap contained alpha layer
hModule
Handle to the instance of the module whose executable file contains the bitmap to be loaded.

Returns

Alpha bitmap handler.

Remarks

This method loads png or bitmap resource from file

Group

LoadBitmapFromResource Method


CXTPImageManagerIcon::PreMultiplyAlphaBitmap Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIcon::PreMultiplyAlphaBitmap Method

Creates valid alpha bits to use in AlphaBlend.

static HBITMAP PreMultiplyAlphaBitmap(
    HBITMAP hBitmap,
    BOOL* pbAlpha = NULL,
    LPBYTE* lpBits = NULL
);
Parameters

hBitmap
Alpha bitmap handler

Returns

Valid alpha bits

See Also

BLENDFUNCTION, AlphaBlend

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::Refresh Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::Refresh Method

Redraw Fade and Shadow icons.

void Refresh();
Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::ScaleToFit Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::ScaleToFit Method

Use this method to scale icon.

static HICON ScaleToFit(
    HICON hIcon,
    CSize szExtent,
    int nWidth
);
Parameters

hIcon
Icon to be scaled.
szExtent
Source icon size.
nWidth
With of result icon.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::Serialize Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::Serialize Method

Reads or writes this object from or to an archive.

void Serialize(
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::SerializeIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SerializeIcon Method

Reads or writes this object from or to an archive.

void SerializeIcon(
    CXTPImageManagerIconHandle& hIcon,
    CArchive& ar,
    long nSchema
);
Parameters

hIcon
Icon to be serialized
ar
A CArchive object to serialize to or from.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::SetCheckedIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SetCheckedIcon Method

Sets the checked icon.

void SetCheckedIcon(
    const CXTPImageManagerIconHandle& hIcon
);
Parameters

hIcon
Icon handle to set.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::SetDisabledIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SetDisabledIcon Method

Sets the disabled icon.

void SetDisabledIcon(
    const CXTPImageManagerIconHandle& hIcon
);
Parameters

hIcon
Icon handle to set.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::SetHotIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SetHotIcon Method

Sets the hot icon.

void SetHotIcon(
    const CXTPImageManagerIconHandle& hIcon
);
Parameters

hIcon
Icon handle to set.

Group

CXTPImageManagerIcon Methods


SetIcon Method

CXTPImageManagerIcon Methods
SetIcon Method
Overload List
Methods
Method | Description
CXTPImageManagerIcon::SetIcon (UINT, int, int) |
CXTPImageManagerIcon::SetIcon (const CXTPImageManagerIconHandle&) | Sets the icon.
CXTPImageManagerIcon::SetIcon (const CXTPImageManagerIconHandle&, XTPImageState) |
Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::SetIcon Method (UINT, int, int)

SetIcon Method, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SetIcon Method (UINT, int, int)
BOOL SetIcon(
    UINT nIDResourceIcon,
    int nWidth,
    int nHeight
);
Group

SetIcon Method


CXTPImageManagerIcon::SetIcon Method (const CXTPImageManagerIconHandle&)

SetIcon Method, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SetIcon Method (const CXTPImageManagerIconHandle&)

Sets the icon.

BOOL SetIcon(
    const CXTPImageManagerIconHandle& hIcon
);
Parameters

hIcon
Icon handle to set.
nIDResourceIcon
Icon resource identifier.
nWidth
Width of icon.
nHeight
Height of icon.

Returns

TRUE if successful; otherwise returns FALSE

Group

SetIcon Method


CXTPImageManagerIcon::SetIcon Method (const CXTPImageManagerIconHandle&, XTPImageState)

SetIcon Method, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SetIcon Method (const CXTPImageManagerIconHandle&, XTPImageState)
BOOL SetIcon(
    const CXTPImageManagerIconHandle& hIcon,
    XTPImageState imageState
);
Group

SetIcon Method


CXTPImageManagerIcon::SetNormalIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SetNormalIcon Method

Sets the icon.

void SetNormalIcon(
    const CXTPImageManagerIconHandle& hIcon
);
Parameters

hIcon
Icon handle to set.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon::SetPressedIcon Method

CXTPImageManagerIcon Methods, CXTPImageManagerIcon Class
CXTPImageManagerIcon::SetPressedIcon Method

Sets the pressed icon.

void SetPressedIcon(
    const CXTPImageManagerIconHandle& hIcon
);
Parameters

hIcon
Icon handle to set.

Group

CXTPImageManagerIcon Methods


CXTPImageManagerIcon Constructors

CXTPImageManagerIcon Class, Legend, Public Methods
CXTPImageManagerIcon Constructors
Class

CXTPImageManagerIcon Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageManagerIcon |


CXTPImageManagerIcon Constructor

CXTPImageManagerIcon Constructors
CXTPImageManagerIcon Constructor
Overload List
Constructors
Constructor | Description
CXTPImageManagerIcon::CXTPImageManagerIcon (UINT, int, int, CXTPImageManagerIconSet*) | Constructs a CXTPImageManagerIcon object.
CXTPImageManagerIcon::CXTPImageManagerIcon (UINT, int, int, CXTPImageManagerImageList*) | Constructs a CXTPImageManagerIcon object.
Group

CXTPImageManagerIcon Constructors


CXTPImageManagerIcon::CXTPImageManagerIcon Constructor (UINT, int, int, CXTPImageManagerIconSet*)

CXTPImageManagerIcon Constructor, CXTPImageManagerIcon Class
CXTPImageManagerIcon::CXTPImageManagerIcon Constructor (UINT, int, int, CXTPImageManagerIconSet*)

Constructs a CXTPImageManagerIcon object.

CXTPImageManagerIcon(
    UINT nID,
    int nWidth,
    int nHeight,
    CXTPImageManagerIconSet* pIconSet = NULL
);
CXTPImageManagerIcon(
    UINT nID,
    int nWidth,
    int nHeight,
    CXTPImageManagerImageList* pImageList
);
Parameters

nID
Icon identifier.
nWidth
Initial width for the icon.
nHeight
Initial height for the icon.
pIconSet
Parent icon set icon will belong.
pImageList
Parent icon set icon will belong.

Group

CXTPImageManagerIcon Constructor


CXTPImageManagerIcon Destructors

CXTPImageManagerIcon Class, Legend, Public Methods
CXTPImageManagerIcon Destructors
Class

CXTPImageManagerIcon Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPImageManagerIcon | Destroys a CXTPImageManagerIcon object, handles cleanup and deallocation.


CXTPImageManagerIcon::~CXTPImageManagerIcon Destructor

CXTPImageManagerIcon Destructors, CXTPImageManagerIcon Class
CXTPImageManagerIcon::~CXTPImageManagerIcon Destructor

Destroys a CXTPImageManagerIcon object, handles cleanup and deallocation.

~CXTPImageManagerIcon();
Group

CXTPImageManagerIcon Destructors


CXTPImageManagerIconHandle Class

XTPImageManager.h, Classes, Legend, Members, Topics, CXTPImageManagerIconHandle Data Members, CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Constructors, CXTPImageManagerIconHandle Destructors, CXTPImageManagerIconHandle Operators, CXTPImageManagerIconHandle Constructors, CXTPImageManagerIconHandle Data Members, CXTPImageManagerIconHandle Destructors, CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle Class

CXTPImageManagerIconHandle is HICON wrapper class.

Class Hierarchy

class CXTPImageManagerIconHandle;
File

XTPImageManager.h

Group

Classes

Legend
Data Member
protected
Method
Operator
CXTPImageManagerIconHandle Constructors
CXTPImageManagerIconHandle Constructors | Description
CXTPImageManagerIconHandle |
CXTPImageManagerIconHandle Data Members
CXTPImageManagerIconHandle Data Members | Description
m_bClearHandles | TRUE if object must destroy handlers.
m_hBitmap | The underlying Alpha bitmap handler for this CXTPImageManagerIconHandle object.
m_hIcon | The underlying HICON handler for this CXTPImageManagerIconHandle object.
m_pBits | Alpha bitmap bits;
CXTPImageManagerIconHandle Destructors
CXTPImageManagerIconHandle Destructors | Description
~CXTPImageManagerIconHandle | Destroys a CXTPImageManagerIconHandle object, handles cleanup and deallocation
CXTPImageManagerIconHandle Methods
CXTPImageManagerIconHandle Methods | Description
Clear | Release bitmap and icon handlers
CopyHandle |
CreateIconFromResource |
GetBitmap | Retrieves bitmap handle
GetExtent | Retrieves the size of the icon.
GetIcon | Retrieves the icon handle.
IsAlpha | Checks if the image has alpha channel.
IsEmpty | Returns TRUE if class has no icon.
PreMultiply | Create alpha bitmap with valid alpha layer.
CXTPImageManagerIconHandle Operators
CXTPImageManagerIconHandle Operators | Description
= |
HICON | This operator returns a HICON object whose value is copied from this CXTPImageManagerIconHandle object.


CXTPImageManagerIconHandle Data Members

CXTPImageManagerIconHandle Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle Data Members
Class

CXTPImageManagerIconHandle Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bClearHandles | TRUE if object must destroy handlers.
m_hBitmap | The underlying Alpha bitmap handler for this CXTPImageManagerIconHandle object.
m_hIcon | The underlying HICON handler for this CXTPImageManagerIconHandle object.
m_pBits | Alpha bitmap bits;


CXTPImageManagerIconHandle::m_bClearHandles Data Member

CXTPImageManagerIconHandle Data Members, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::m_bClearHandles Data Member

TRUE if object must destroy handlers.

BOOL m_bClearHandles;
Group

CXTPImageManagerIconHandle Data Members


CXTPImageManagerIconHandle::m_hBitmap Data Member

CXTPImageManagerIconHandle Data Members, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::m_hBitmap Data Member

The underlying Alpha bitmap handler for this CXTPImageManagerIconHandle object.

HBITMAP m_hBitmap;
Group

CXTPImageManagerIconHandle Data Members


CXTPImageManagerIconHandle::m_hIcon Data Member

CXTPImageManagerIconHandle Data Members, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::m_hIcon Data Member

The underlying HICON handler for this CXTPImageManagerIconHandle object.

HICON m_hIcon;
Group

CXTPImageManagerIconHandle Data Members


CXTPImageManagerIconHandle::m_pBits Data Member

CXTPImageManagerIconHandle Data Members, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::m_pBits Data Member

Alpha bitmap bits;

LPBYTE m_pBits;
Group

CXTPImageManagerIconHandle Data Members


CXTPImageManagerIconHandle Methods

CXTPImageManagerIconHandle Class, Legend, Public Methods
CXTPImageManagerIconHandle Methods
Class

CXTPImageManagerIconHandle Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Clear | Release bitmap and icon handlers
CopyHandle |
CreateIconFromResource |
GetBitmap | Retrieves bitmap handle
GetExtent | Retrieves the size of the icon.
GetIcon | Retrieves the icon handle.
IsAlpha | Checks if the image has alpha channel.
IsEmpty | Returns TRUE if class has no icon.
PreMultiply | Create alpha bitmap with valid alpha layer.


CXTPImageManagerIconHandle::Clear Method

CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::Clear Method

Release bitmap and icon handlers

void Clear();
Group

CXTPImageManagerIconHandle Methods


CopyHandle Method

CXTPImageManagerIconHandle Methods
CopyHandle Method
Overload List
Methods
Method | Description
CXTPImageManagerIconHandle::CopyHandle (HBITMAP) | Copies data from an HBITMAP or CXTPImageManagerIconHandle object
CXTPImageManagerIconHandle::CopyHandle (const CXTPImageManagerIconHandle&) | Copies data from an HBITMAP or CXTPImageManagerIconHandle object
Group

CXTPImageManagerIconHandle Methods


CXTPImageManagerIconHandle::CopyHandle Method (HBITMAP)

CopyHandle Method, CXTPImageManagerIconHandle Class
CXTPImageManagerIconHandle::CopyHandle Method (HBITMAP)

Copies data from an HBITMAP or CXTPImageManagerIconHandle object

void CopyHandle(
    HBITMAP hBitmap
);
void CopyHandle(
    const CXTPImageManagerIconHandle& handle
);
Parameters

hBitmap
Alpha bitmap handler
handle
CXTPImageManagerIconHandle object

Group

CopyHandle Method


CreateIconFromResource Method

CXTPImageManagerIconHandle Methods
CreateIconFromResource Method
Overload List
Methods
Method | Description
CXTPImageManagerIconHandle::CreateIconFromResource (HINSTANCE, LPCTSTR, CSize, BOOL) | Creates an icon from resource bits describing the icon.
CXTPImageManagerIconHandle::CreateIconFromResource (LPCTSTR, CSize, BOOL) | Creates an icon from resource bits describing the icon.
Group

CXTPImageManagerIconHandle Methods


CXTPImageManagerIconHandle::CreateIconFromResource Method (LPCTSTR, CSize, BOOL)

CreateIconFromResource Method, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::CreateIconFromResource Method (LPCTSTR, CSize, BOOL)

Creates an icon from resource bits describing the icon.

BOOL CreateIconFromResource(
    LPCTSTR lpszResourceName,
    CSize szIcon,
    BOOL bGroupResource = TRUE
);
BOOL CreateIconFromResource(
    HINSTANCE hInst,
    LPCTSTR lpszResourceName,
    CSize szIcon,
    BOOL bGroupResource
);
Parameters

lpszResourceName
Resource name identifier
szIcon
Specifies the desired width and height, in pixels, of the icon.
bGroupResource
TRUE to check if RT_GROUP_ICON resource exists.
hInst
Application instance handler

Returns

TRUE if successful; otherwise returns FALSE.

Group

CreateIconFromResource Method


CXTPImageManagerIconHandle::GetBitmap Method

CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::GetBitmap Method

Retrieves bitmap handle

HBITMAP GetBitmap() const;
Returns

32bit alpha bitmap

Group

CXTPImageManagerIconHandle Methods


CXTPImageManagerIconHandle::GetExtent Method

CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::GetExtent Method

Retrieves the size of the icon.

CSize GetExtent() const;
Returns

Size of the icon.

Group

CXTPImageManagerIconHandle Methods


CXTPImageManagerIconHandle::GetIcon Method

CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::GetIcon Method

Retrieves the icon handle.

HICON GetIcon() const;
Returns

Icon handle.

Group

CXTPImageManagerIconHandle Methods


CXTPImageManagerIconHandle::IsAlpha Method

CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::IsAlpha Method

Checks if the image has alpha channel.

BOOL IsAlpha() const;
Returns

TRUE if the image has alpha channel; otherwise returns FALSE

Group

CXTPImageManagerIconHandle Methods


CXTPImageManagerIconHandle::IsEmpty Method

CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::IsEmpty Method

Returns TRUE if class has no icon.

BOOL IsEmpty() const;
Returns

TRUE if m_hIcon member is NULL.

Group

CXTPImageManagerIconHandle Methods


CXTPImageManagerIconHandle::PreMultiply Method

CXTPImageManagerIconHandle Methods, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::PreMultiply Method

Create alpha bitmap with valid alpha layer.

LPBYTE PreMultiply();
Returns

TRUE if successful; otherwise returns FALSE.

Group

CXTPImageManagerIconHandle Methods


CXTPImageManagerIconHandle Constructors

CXTPImageManagerIconHandle Class, Legend, Public Methods
CXTPImageManagerIconHandle Constructors
Class

CXTPImageManagerIconHandle Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageManagerIconHandle |


CXTPImageManagerIconHandle Constructor

CXTPImageManagerIconHandle Constructors
CXTPImageManagerIconHandle Constructor
Overload List
Constructors
Constructor | Description
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle () | Constructs a CXTPImageManagerIconHandle object
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle (HBITMAP) | Constructs a CXTPImageManagerIconHandle object
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle (HICON, BOOL) | Constructs a CXTPImageManagerIconHandle object
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle (const CXTPImageManagerIconHandle&) | Constructs a CXTPImageManagerIconHandle object
Group

CXTPImageManagerIconHandle Constructors


CXTPImageManagerIconHandle::CXTPImageManagerIconHandle Constructor ()

CXTPImageManagerIconHandle Constructor, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle Constructor ()

Constructs a CXTPImageManagerIconHandle object

CXTPImageManagerIconHandle();
CXTPImageManagerIconHandle(
    HICON hIcon,
    BOOL bUseResources = TRUE
);
CXTPImageManagerIconHandle(
    HBITMAP hBitmap
);
CXTPImageManagerIconHandle(
    const CXTPImageManagerIconHandle& hHandle
);
Parameters

hIcon
Icon handle
hBitmap
Bitmap handle
hHandle
CXTPImageManagerIconHandle reference

Group

CXTPImageManagerIconHandle Constructor


CXTPImageManagerIconHandle Destructors

CXTPImageManagerIconHandle Class, Legend, Public Methods
CXTPImageManagerIconHandle Destructors
Class

CXTPImageManagerIconHandle Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPImageManagerIconHandle | Destroys a CXTPImageManagerIconHandle object, handles cleanup and deallocation


CXTPImageManagerIconHandle::~CXTPImageManagerIconHandle Destructor

CXTPImageManagerIconHandle Destructors, CXTPImageManagerIconHandle Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::~CXTPImageManagerIconHandle Destructor

Destroys a CXTPImageManagerIconHandle object, handles cleanup and deallocation

~CXTPImageManagerIconHandle();
Group

CXTPImageManagerIconHandle Destructors


CXTPImageManagerIconHandle Operators

CXTPImageManagerIconHandle Class, Legend, Public Operators
CXTPImageManagerIconHandle Operators
Class

CXTPImageManagerIconHandle Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= |
HICON | This operator returns a HICON object whose value is copied from this CXTPImageManagerIconHandle object.


= Operator

CXTPImageManagerIconHandle Operators
= Operator
Overload List
Operators
Operator | Description
CXTPImageManagerIconHandle::= (const HBITMAP) | This operator assigns the alpha bitmap handler to a CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle::= (const HICON) | This operator assigns the icon handler to a CXTPImageManagerIconHandle object.
Group

CXTPImageManagerIconHandle Operators


CXTPImageManagerIconHandle::= Operator (const HBITMAP)

= Operator, CXTPImageManagerIconHandle Class
CXTPImageManagerIconHandle::= Operator (const HBITMAP)

This operator assigns the alpha bitmap handler to a CXTPImageManagerIconHandle object.

const CXTPImageManagerIconHandle& operator =(
    const HBITMAP hBitmap
);
Parameters

hBitmap
Alpha bitmap handler

Group

= Operator


CXTPImageManagerIconHandle::= Operator (const HICON)

= Operator, CXTPImageManagerIconHandle Class
CXTPImageManagerIconHandle::= Operator (const HICON)

This operator assigns the icon handler to a CXTPImageManagerIconHandle object.

const CXTPImageManagerIconHandle& operator =(
    const HICON hIcon
);
Parameters

hIcon
source icon handler

Group

= Operator


CXTPImageManagerIconHandle::HICON Operator

CXTPImageManagerIconHandle Operators, CXTPImageManagerIconHandle Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconHandle::HICON Operator

This operator returns a HICON object whose value is copied from this CXTPImageManagerIconHandle object.

operator HICON() const;
Returns

HICON handle.

Body Source
CXTPImageManagerIconHandle::operator HICON() const {
    return m_hIcon;
}
Group

CXTPImageManagerIconHandle Operators


CXTPImageManagerIconSet Class

XTPImageManager.h, Classes, Legend, Members, Topics, CXTPImageManagerIconSet Methods, CXTPImageManagerIconSet Constructors, CXTPImageManagerIconSet Destructors, CXTPImageManagerIconSet Nested Types, CXTPImageManagerIconSet Constructors, CXTPImageManagerIconSet Destructors, CXTPImageManagerIconSet Methods, CXTPImageManagerIconSet Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet Class

CXTPImageManagerIconSet represents the collection of icons for specified identifier.

Class Hierarchy

class CXTPImageManagerIconSet;
File

XTPImageManager.h

Group

Classes

Legend
Method
CXTPImageManagerIconSet Constructors
CXTPImageManagerIconSet Constructors | Description
CXTPImageManagerIconSet | Constructs a CXTPImageManagerIconSet object.
CXTPImageManagerIconSet Destructors
CXTPImageManagerIconSet Destructors | Description
~CXTPImageManagerIconSet | Destroys a CXTPImageManagerIconSet object, handles cleanup and deallocation.
CXTPImageManagerIconSet Methods
CXTPImageManagerIconSet Methods | Description
GetIcon | Call this member to get the icon with the specified width
GetIcons | Retrieves the collection of icons
GetID | Retrieves the identifier of the collection set.
RefreshAll | Redraws all icons.
RemoveAll | Removes all icons
CXTPImageManagerIconSet Nested Types
CXTPImageManagerIconSet Nested Types | Description
CIconSetMap | Icons collection.


CXTPImageManagerIconSet Methods

CXTPImageManagerIconSet Class, Legend, Public Methods
CXTPImageManagerIconSet Methods
Class

CXTPImageManagerIconSet Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetIcon | Call this member to get the icon with the specified width
GetIcons | Retrieves the collection of icons
GetID | Retrieves the identifier of the collection set.
RefreshAll | Redraws all icons.
RemoveAll | Removes all icons


CXTPImageManagerIconSet::GetIcon Method

CXTPImageManagerIconSet Methods, CXTPImageManagerIconSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet::GetIcon Method

Call this member to get the icon with the specified width

CXTPImageManagerIcon* GetIcon(
    UINT nWidth,
    BOOL bScaled = TRUE
);
Parameters

nWidth
Width of the icon to retrieve.
bScaled
TRUE to scale icon.

Returns

A pointer to a CXTPImageManagerIcon object

Group

CXTPImageManagerIconSet Methods


CXTPImageManagerIconSet::GetIcons Method

CXTPImageManagerIconSet Methods, CXTPImageManagerIconSet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet::GetIcons Method

Retrieves the collection of icons

CIconSetMap* GetIcons();
Returns

A pointer to a CIconSetMap object

Body Source
CXTPImageManagerIconSet::CIconSetMap* CXTPImageManagerIconSet::GetIcons() {
    return &m_mapIcons;
}
Group

CXTPImageManagerIconSet Methods


CXTPImageManagerIconSet::GetID Method

CXTPImageManagerIconSet Methods, CXTPImageManagerIconSet Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet::GetID Method

Retrieves the identifier of the collection set.

UINT GetID() const;
Returns

Identifier of icons.

Body Source
UINT CXTPImageManagerIconSet::GetID() const {
    return m_nID;
}
Group

CXTPImageManagerIconSet Methods


CXTPImageManagerIconSet::RefreshAll Method

CXTPImageManagerIconSet Methods, CXTPImageManagerIconSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet::RefreshAll Method

Redraws all icons.

void RefreshAll();
Group

CXTPImageManagerIconSet Methods


CXTPImageManagerIconSet::RemoveAll Method

CXTPImageManagerIconSet Methods, CXTPImageManagerIconSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet::RemoveAll Method

Removes all icons

void RemoveAll();
Group

CXTPImageManagerIconSet Methods


CXTPImageManagerIconSet Constructors

CXTPImageManagerIconSet Class, Legend, Public Methods
CXTPImageManagerIconSet Constructors
Class

CXTPImageManagerIconSet Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageManagerIconSet | Constructs a CXTPImageManagerIconSet object.


CXTPImageManagerIconSet::CXTPImageManagerIconSet Constructor

CXTPImageManagerIconSet Constructors, CXTPImageManagerIconSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet::CXTPImageManagerIconSet Constructor

Constructs a CXTPImageManagerIconSet object.

CXTPImageManagerIconSet(
    UINT nID,
    CXTPImageManager* pImageManager
);
Parameters

nID
Icon set identifier.
pImageManager
Parent image manager CXTPImageManagerIconSet belongs.

Group

CXTPImageManagerIconSet Constructors


CXTPImageManagerIconSet Destructors

CXTPImageManagerIconSet Class, Legend, Public Methods
CXTPImageManagerIconSet Destructors
Class

CXTPImageManagerIconSet Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPImageManagerIconSet | Destroys a CXTPImageManagerIconSet object, handles cleanup and deallocation.


CXTPImageManagerIconSet::~CXTPImageManagerIconSet Destructor

CXTPImageManagerIconSet Destructors, CXTPImageManagerIconSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet::~CXTPImageManagerIconSet Destructor

Destroys a CXTPImageManagerIconSet object, handles cleanup and deallocation.

~CXTPImageManagerIconSet();
Group

CXTPImageManagerIconSet Destructors


CXTPImageManagerIconSet Nested Types

CXTPImageManagerIconSet Class, Public Nested Types
CXTPImageManagerIconSet Nested Types
Class

CXTPImageManagerIconSet Class

Public Nested Types
Public Nested Type | Description
CIconSetMap | Icons collection.


CXTPImageManagerIconSet::CIconSetMap Nested Type

CXTPImageManagerIconSet Nested Types, CXTPImageManagerIconSet Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPImageManagerIconSet::CIconSetMap Nested Type

Icons collection.

typedef CMap<UINT, UINT, CXTPImageManagerIcon*, CXTPImageManagerIcon*> CIconSetMap;
Group

CXTPImageManagerIconSet Nested Types


CXTPLockGuard Class

XTPSystemHelpers.h, Classes, Legend, Members, Topics, CXTPLockGuard Methods, CXTPLockGuard Constructors, CXTPLockGuard Destructors, CXTPLockGuard Constructors, CXTPLockGuard Destructors, CXTPLockGuard Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPLockGuard Class

Critical Sections Lock/Unlock helper

Class Hierarchy

class CXTPLockGuard;
File

XTPSystemHelpers.h

Group

Classes

Legend
Method
CXTPLockGuard Constructors
CXTPLockGuard Constructors | Description
CXTPLockGuard | Constructs a CXTPLockGuard object
CXTPLockGuard Destructors
CXTPLockGuard Destructors | Description
~CXTPLockGuard | Destroys a CXTPCriticalSection object, handles cleanup and deallocation
CXTPLockGuard Methods
CXTPLockGuard Methods | Description
LockThread | This method call EnterCritical of key object
UnLockThread | This method call LeaveCritical of key object


CXTPLockGuard Methods

CXTPLockGuard Class, Legend, Public Methods
CXTPLockGuard Methods
Class

CXTPLockGuard Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
LockThread | This method call EnterCritical of key object
UnLockThread | This method call LeaveCritical of key object


CXTPLockGuard::LockThread Method

CXTPLockGuard Methods, CXTPLockGuard Class
CXTPLockGuard::LockThread Method

This method call EnterCritical of key object

void LockThread();
Group

CXTPLockGuard Methods


CXTPLockGuard::UnLockThread Method

CXTPLockGuard Methods, CXTPLockGuard Class
CXTPLockGuard::UnLockThread Method

This method call LeaveCritical of key object

void UnLockThread();
Group

CXTPLockGuard Methods


CXTPLockGuard Constructors

CXTPLockGuard Class, Legend, Public Methods
CXTPLockGuard Constructors
Class

CXTPLockGuard Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPLockGuard | Constructs a CXTPLockGuard object


CXTPLockGuard::CXTPLockGuard Constructor

CXTPLockGuard Constructors, CXTPLockGuard Class
CXTPLockGuard::CXTPLockGuard Constructor

Constructs a CXTPLockGuard object

CXTPLockGuard(
    CRITICAL_SECTION& key
);
Parameters

key
CRITICAL_SECTION used to lock thread

Group

CXTPLockGuard Constructors


CXTPLockGuard Destructors

CXTPLockGuard Class, Legend, Public Methods
CXTPLockGuard Destructors
Class

CXTPLockGuard Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPLockGuard | Destroys a CXTPCriticalSection object, handles cleanup and deallocation


CXTPLockGuard::~CXTPLockGuard Destructor

CXTPLockGuard Destructors, CXTPLockGuard Class
CXTPLockGuard::~CXTPLockGuard Destructor

Destroys a CXTPCriticalSection object, handles cleanup and deallocation

~CXTPLockGuard();
Group

CXTPLockGuard Destructors


CXTPModuleHandle Class

XTPSystemHelpers.h, Classes, Legend, Members, Topics, CXTPModuleHandle Enumerations, CXTPModuleHandle Methods, CXTPModuleHandle Constructors, CXTPModuleHandle Destructors, CXTPModuleHandle Operators, CXTPModuleHandle Constructors, CXTPModuleHandle Destructors, CXTPModuleHandle Enumerations, CXTPModuleHandle Methods, CXTPModuleHandle Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPModuleHandle Class

CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods

Class Hierarchy

class CXTPModuleHandle;
File

XTPSystemHelpers.h

Group

Classes

Legend
Enumeration
Method
virtual
Operator
CXTPModuleHandle Constructors
CXTPModuleHandle Constructors | Description
CXTPModuleHandle |
CXTPModuleHandle Destructors
CXTPModuleHandle Destructors | Description
~CXTPModuleHandle | Destroys a CXTPModuleHandle object, handles cleanup and deallocation
CXTPModuleHandle Enumerations
CXTPModuleHandle Enumerations | Description
XTPModuleState | Module state
CXTPModuleHandle Methods
CXTPModuleHandle Methods | Description
FreeLibrary | The FreeLibrary function decrements the reference count of the loaded dynamic-link library (DLL).
GetHandle | This method returns a handle to the module indicating success. NULL indicates failure.
GetModuleHandle | The GetModuleHandle function retrieves a module handle for the specified module if the file has been mapped into the address space of the calling process.
GetModuleState | Returns module state
GetName | Returns Path to loaded library
GetProcAddress | The GetProcAddress function retrieves the address of the specified exported dynamic-link library (DLL) function.
GetVersion | Use this member function to return the version number of the module attached to this CLoadLibrary object. The high-order word of the return value represents the major version number and the low-order word of the returned value represents the minor version number.
Init | Call this method to LoadLibrary
LoadLibrary | This member function is called to load the library specified by 'lpszModule'. Once the library is loaded, you can retrieve the instance handle by using the HINSTANCE operator.
CXTPModuleHandle Operators
CXTPModuleHandle Operators | Description
HMODULE | This overloaded operator returns a handle to the module indicating success. NULL indicates failure.


CXTPModuleHandle Enumerations

Enumerations, CXTPModuleHandle Class, Legend
CXTPModuleHandle Enumerations
Enumerations
Enumeration | Description
XTPModuleState | Module state
Class

CXTPModuleHandle Class

Legend
Enumeration


CXTPModuleHandle::XTPModuleState Enumeration

XTPSystemHelpers.h, CXTPModuleHandle Enumerations
CXTPModuleHandle::XTPModuleState Enumeration

Module state

enum XTPModuleState {
  xtpModNone,
  xtpModMapped,
  xtpModLoaded
};
File

XTPSystemHelpers.h

Members

xtpModNone
Indicates no module found.
xtpModMapped
Indicates the module handle was set using GetModuleHandle
xtpModLoaded
Indicates the module handle was set using LoadLibrary.

Group

CXTPModuleHandle Enumerations


CXTPModuleHandle Methods

CXTPModuleHandle Class, Legend, Public Methods
CXTPModuleHandle Methods
Class

CXTPModuleHandle Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
FreeLibrary | The FreeLibrary function decrements the reference count of the loaded dynamic-link library (DLL).
GetHandle | This method returns a handle to the module indicating success. NULL indicates failure.
GetModuleHandle | The GetModuleHandle function retrieves a module handle for the specified module if the file has been mapped into the address space of the calling process.
GetModuleState | Returns module state
GetName | Returns Path to loaded library
GetProcAddress | The GetProcAddress function retrieves the address of the specified exported dynamic-link library (DLL) function.
GetVersion | Use this member function to return the version number of the module attached to this CLoadLibrary object. The high-order word of the return value represents the major version number and the low-order word of the returned value represents the minor version number.
Init | Call this method to LoadLibrary
LoadLibrary | This member function is called to load the library specified by 'lpszModule'. Once the library is loaded, you can retrieve the instance handle by using the HINSTANCE operator.


CXTPModuleHandle::FreeLibrary Method

CXTPModuleHandle Methods, CXTPModuleHandle Class
CXTPModuleHandle::FreeLibrary Method

The FreeLibrary function decrements the reference count of the loaded dynamic-link library (DLL).

BOOL FreeLibrary();
Group

CXTPModuleHandle Methods


CXTPModuleHandle::GetHandle Method

CXTPModuleHandle Methods, CXTPModuleHandle Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPModuleHandle::GetHandle Method

This method returns a handle to the module indicating success. NULL indicates failure.

HMODULE GetHandle() const;
Returns

A handle to the module if successful, otherwise returns NULL.

Body Source
HMODULE CXTPModuleHandle::GetHandle() const {
    return m_hModule;
}
Group

CXTPModuleHandle Methods


CXTPModuleHandle::GetModuleHandle Method

CXTPModuleHandle Methods, CXTPModuleHandle Class
CXTPModuleHandle::GetModuleHandle Method

The GetModuleHandle function retrieves a module handle for the specified module if the file has been mapped into the address space of the calling process.

BOOL GetModuleHandle(
    LPCTSTR lpszModuleName
);
Parameters

lpModuleName
Pointer to a null-terminated string that contains the name of the module (either a .dll or .exe file).

Group

CXTPModuleHandle Methods


CXTPModuleHandle::GetModuleState Method

CXTPModuleHandle Methods, CXTPModuleHandle Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPModuleHandle::GetModuleState Method

Returns module state

XTPModuleState GetModuleState() const;
Body Source
CXTPModuleHandle::XTPModuleState CXTPModuleHandle::GetModuleState() const {
    return m_eModuleState;
}
Group

CXTPModuleHandle Methods


CXTPModuleHandle::GetName Method

CXTPModuleHandle Methods, CXTPModuleHandle Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPModuleHandle::GetName Method

Returns Path to loaded library

CString GetName() const;
Body Source
CString CXTPModuleHandle::GetName() const {
    return m_strModuleName;
}
Group

CXTPModuleHandle Methods


CXTPModuleHandle::GetProcAddress Method

CXTPModuleHandle Methods, CXTPModuleHandle Class
CXTPModuleHandle::GetProcAddress Method

The GetProcAddress function retrieves the address of the specified exported dynamic-link library (DLL) function.

BOOL GetProcAddress(
    FARPROC* ppFnPtr,
    LPCSTR lpProcName,
    DWORD dwMinVer = NULL
);
Group

CXTPModuleHandle Methods


CXTPModuleHandle::GetVersion Method

CXTPModuleHandle Methods, CXTPModuleHandle Class
CXTPModuleHandle::GetVersion Method

Use this member function to return the version number of the module attached to this CLoadLibrary object. The high-order word of the return value represents the major version number and the low-order word of the returned value represents the minor version number.

DWORD GetVersion();
Returns

A DWORD value if successful, otherwise 0L.

Group

CXTPModuleHandle Methods


CXTPModuleHandle::Init Method

CXTPModuleHandle Methods, CXTPModuleHandle Class
CXTPModuleHandle::Init Method

Call this method to LoadLibrary

BOOL Init(
    LPCTSTR lpszModuleName
);
Group

CXTPModuleHandle Methods


CXTPModuleHandle::LoadLibrary Method

CXTPModuleHandle Methods, CXTPModuleHandle Class
CXTPModuleHandle::LoadLibrary Method

This member function is called to load the library specified by 'lpszModule'. Once the library is loaded, you can retrieve the instance handle by using the HINSTANCE operator.

BOOL LoadLibrary(
    LPCTSTR lpszModuleName
);
Parameters

lpszModuleName
Pointer to a null-terminated string that names the .DLL file. The name specified is the filename of the module and is not related to the name stored in the library module itself, as specified by the LIBRARY keyword in the module- definition (.DEF) file. If the string specifies a path but the file does not exist in the specified directory, the function fails. When specifying a path, be sure to use backslashes (), not forward slashes (/).

Group

CXTPModuleHandle Methods


CXTPModuleHandle Constructors

CXTPModuleHandle Class, Legend, Public Methods
CXTPModuleHandle Constructors
Class

CXTPModuleHandle Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPModuleHandle |


CXTPModuleHandle Constructor

CXTPModuleHandle Constructors
CXTPModuleHandle Constructor
Overload List
Constructors
Constructor | Description
CXTPModuleHandle::CXTPModuleHandle () | Constructs a CXTPModuleHandle object.
CXTPModuleHandle::CXTPModuleHandle (LPCTSTR) | Constructs a CXTPModuleHandle object.
Group

CXTPModuleHandle Constructors


CXTPModuleHandle::CXTPModuleHandle Constructor ()

CXTPModuleHandle Constructor, CXTPModuleHandle Class
CXTPModuleHandle::CXTPModuleHandle Constructor ()

Constructs a CXTPModuleHandle object.

CXTPModuleHandle();
Group

CXTPModuleHandle Constructor


CXTPModuleHandle::CXTPModuleHandle Constructor (LPCTSTR)

CXTPModuleHandle Constructor, CXTPModuleHandle Class
CXTPModuleHandle::CXTPModuleHandle Constructor (LPCTSTR)

Constructs a CXTPModuleHandle object.

CXTPModuleHandle(
    LPCTSTR lpszModuleName
);
Parameters

lpszModuleName
Pointer to a null-terminated string that names the .DLL file. The name specified is the filename of the module and is not related to the name stored in the library module itself, as specified by the LIBRARY keyword in the module- definition (.DEF) file. If the string specifies a path but the file does not exist in the specified directory, the function fails. When specifying a path, be sure to use backslashes (), not forward slashes (/).

Group

CXTPModuleHandle Constructor


CXTPModuleHandle Destructors

CXTPModuleHandle Class, Legend, Public Methods
CXTPModuleHandle Destructors
Class

CXTPModuleHandle Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPModuleHandle | Destroys a CXTPModuleHandle object, handles cleanup and deallocation


CXTPModuleHandle::~CXTPModuleHandle Destructor

CXTPModuleHandle Destructors, CXTPModuleHandle Class
CXTPModuleHandle::~CXTPModuleHandle Destructor

Destroys a CXTPModuleHandle object, handles cleanup and deallocation

virtual ~CXTPModuleHandle();
Group

CXTPModuleHandle Destructors


CXTPModuleHandle Operators

CXTPModuleHandle Class, Legend, Public Operators
CXTPModuleHandle Operators
Class

CXTPModuleHandle Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
HMODULE | This overloaded operator returns a handle to the module indicating success. NULL indicates failure.


CXTPModuleHandle::HMODULE Operator

CXTPModuleHandle Operators, CXTPModuleHandle Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPModuleHandle::HMODULE Operator

This overloaded operator returns a handle to the module indicating success. NULL indicates failure.

operator HMODULE() const;
Returns

A handle to the module if successful, otherwise returns NULL.

Body Source
CXTPModuleHandle::operator HMODULE () const {
    return m_hModule;
}
Group

CXTPModuleHandle Operators


CXTPMouseMonitor Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPMouseMonitor Methods, CXTPMouseMonitor Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseMonitor Class

The class CXTPMouseMonitor is a helper class that is used to monitor mouse messages for in-place controls. This class is used in XTPPropertyGridInPlaceList and XTPReportInplaceControls.

Class Hierarchy

class CXTPMouseMonitor;
File

XTPDrawHelpers.h

Group

Classes

Legend
Method
protected
CXTPMouseMonitor Methods
CXTPMouseMonitor Methods | Description
IsMouseHooked | Call this function to determine if mouse messages was hooked.
MouseProc | The MouseProc hook procedure is an application-defined or library-defined callback function used with the SetWindowsHookEx function. The system calls this function whenever an application calls the GetMessage or PeekMessage function and there is a mouse message to be processed.
SetupHook | Call this function to set up a hook to monitor mouse messages.


CXTPMouseMonitor Methods

CXTPMouseMonitor Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMouseMonitor Methods
Class

CXTPMouseMonitor Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
MouseProc | The MouseProc hook procedure is an application-defined or library-defined callback function used with the SetWindowsHookEx function. The system calls this function whenever an application calls the GetMessage or PeekMessage function and there is a mouse message to be processed.
Public Methods
Public Methods
Public Method | Description
IsMouseHooked | Call this function to determine if mouse messages was hooked.
SetupHook | Call this function to set up a hook to monitor mouse messages.


CXTPMouseMonitor::IsMouseHooked Method

CXTPMouseMonitor Methods, CXTPMouseMonitor Class
CXTPMouseMonitor::IsMouseHooked Method

Call this function to determine if mouse messages was hooked.

static BOOL IsMouseHooked();
Group

CXTPMouseMonitor Methods


CXTPMouseMonitor::MouseProc Method

CXTPMouseMonitor Methods, CXTPMouseMonitor Class
CXTPMouseMonitor::MouseProc Method

The MouseProc hook procedure is an application-defined or library-defined callback function used with the SetWindowsHookEx function. The system calls this function whenever an application calls the GetMessage or PeekMessage function and there is a mouse message to be processed.

static LRESULT CALLBACK MouseProc(
    int nCode,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

nCode
Specifies a code the hook procedure uses to determine how to process the message. This parameter can be one of the following values: HC_ACTION and HC_NOREMOVE.
wParam
Specifies the identifier of the mouse message.
lParam
Pointer to a MOUSEHOOKSTRUCT structure.
HC_ACTION
The wParam and lParam parameters contain information about a mouse message.
HC_NOREMOVE
The wParam and lParam parameters contain information about a mouse message, and the mouse message has not been removed from the message queue. (An application called the PeekMessage function, specifying the PM_NOREMOVE flag.)

Returns

If nCode is less than zero, the hook procedure must return the value returned by CallNextHookEx. If nCode is greater than or equal to zero, and the hook procedure did not process the message, it is highly recommended that you call CallNextHookEx and return the value it returns; otherwise, other applications that have installed WH_MOUSE hooks will not receive hook notifications and may behave incorrectly as a result. If the hook procedure processed the message, it may return a nonzero value to prevent the system from passing the message to the target window procedure.

Group

CXTPMouseMonitor Methods


CXTPMouseMonitor::SetupHook Method

CXTPMouseMonitor Methods, CXTPMouseMonitor Class
CXTPMouseMonitor::SetupHook Method

Call this function to set up a hook to monitor mouse messages.

static void SetupHook(
    CWnd* pWndMonitor
);
Parameters

pWndMonitor
A pointer to a CWnd object. Used to determine which monitor currently contains the mouse cursor.

Group

CXTPMouseMonitor Methods


CXTPMultiMonitor Class

XTPSystemHelpers.h, Classes, Legend, Members, Topics, CXTPMultiMonitor Methods, CXTPMultiMonitor Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPMultiMonitor Class

MultiMonitor API wrapper class

Class Hierarchy

class CXTPMultiMonitor;
File

XTPSystemHelpers.h

Group

Classes

Legend
Method
CXTPMultiMonitor Methods
CXTPMultiMonitor Methods | Description
GetScreenArea |
GetWorkArea |


CXTPMultiMonitor Methods

CXTPMultiMonitor Class, Legend, Public Methods
CXTPMultiMonitor Methods
Class

CXTPMultiMonitor Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetScreenArea |
GetWorkArea |


GetScreenArea Method

CXTPMultiMonitor Methods
GetScreenArea Method
Overload List
Methods
Method | Description
CXTPMultiMonitor::GetScreenArea (HWND) | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CXTPMultiMonitor::GetScreenArea (LPCRECT) | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CXTPMultiMonitor::GetScreenArea (const CWnd*) | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CXTPMultiMonitor::GetScreenArea (const POINT&) | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
Group

CXTPMultiMonitor Methods


GetWorkArea Method

CXTPMultiMonitor Methods
GetWorkArea Method
Overload List
Methods
Method | Description
CXTPMultiMonitor::GetWorkArea () | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CXTPMultiMonitor::GetWorkArea (HWND) | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CXTPMultiMonitor::GetWorkArea (LPCRECT) | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CXTPMultiMonitor::GetWorkArea (const CWnd*) | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CXTPMultiMonitor::GetWorkArea (const POINT&) | This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
Group

CXTPMultiMonitor Methods


CXTPMultiMonitor::GetWorkArea Method ()

GetWorkArea Method, CXTPMultiMonitor Class
CXTPMultiMonitor::GetWorkArea Method ()

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

CRect GetWorkArea();
CRect GetWorkArea(
    const POINT& point
);
CRect GetWorkArea(
    LPCRECT rect
);
CRect GetWorkArea(
    const CWnd* pWnd
);
CRect GetWorkArea(
    HWND hWnd
);
CRect GetScreenArea(
    const CWnd* pWnd
);
CRect GetScreenArea(
    HWND hWnd
);
CRect GetScreenArea(
    const POINT& point
);
CRect GetScreenArea(
    LPCRECT rect
);
Parameters

point
Point of interest.
rect
Reference to a CRect class that specifies the coordinates of the rectangle of interest in virtual screen coordinates.
pWnd
Pointer to the window of interest.
hWnd
Handle to the window of interest.

Returns

If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

Group

GetWorkArea Method


CXTPNoFlickerWnd Template

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPNoFlickerWnd Data Members, CXTPNoFlickerWnd Methods, CXTPNoFlickerWnd Constructors, CXTPNoFlickerWnd Constructors, CXTPNoFlickerWnd Data Members, Example, CXTPNoFlickerWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPNoFlickerWnd Template

CXTPNoFlickerWnd is a TBase derived general purpose template helper class. CXTPNoFlickerWnd class is used for drawing flicker free controls. To use, instantiate the template using any CWnd derived class. For example, to create a tab control that is flicker free you would use the following declaration:

Class Hierarchy

template <class TBase>
class CXTPNoFlickerWnd : public TBase;
File

XTPDrawHelpers.h

Example

The following example demonstrates how to use CXTPNoFlickerWnd to create a flicker free object.

CXTPNoFlickerWnd <CTabCtrl> m_tabCtrl;
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPNoFlickerWnd Constructors
CXTPNoFlickerWnd Constructors | Description
CXTPNoFlickerWnd | Constructs a CXTPNoFlickerWnd object.
CXTPNoFlickerWnd Data Members
CXTPNoFlickerWnd Data Members | Description
m_crBack | An RGB value.
CXTPNoFlickerWnd Methods
CXTPNoFlickerWnd Methods | Description
GetBackColor | This member function is called to retrieve the background fill color for the flicker free control.
SetBackColor | This member function is called to set the background fill color for the flicker free control.
WindowProc | This method provides a CE procedure (WindowProc) for a CWnd object. It dispatches messages through the window message map. The return value depends on the message.


CXTPNoFlickerWnd Data Members

CXTPNoFlickerWnd Template, Legend, Protected Data Members
CXTPNoFlickerWnd Data Members
Template

CXTPNoFlickerWnd Template

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_crBack | An RGB value.


CXTPNoFlickerWnd::m_crBack Data Member

CXTPNoFlickerWnd Data Members, CXTPNoFlickerWnd Template
CXTPNoFlickerWnd::m_crBack Data Member

An RGB value.

COLORREF m_crBack;
Group

CXTPNoFlickerWnd Data Members


CXTPNoFlickerWnd Methods

CXTPNoFlickerWnd Template, Legend, Public Methods
CXTPNoFlickerWnd Methods
Template

CXTPNoFlickerWnd Template

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetBackColor | This member function is called to retrieve the background fill color for the flicker free control.
SetBackColor | This member function is called to set the background fill color for the flicker free control.
WindowProc | This method provides a CE procedure (WindowProc) for a CWnd object. It dispatches messages through the window message map. The return value depends on the message.


CXTPNoFlickerWnd::GetBackColor Method

CXTPNoFlickerWnd Methods, CXTPNoFlickerWnd Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPNoFlickerWnd::GetBackColor Method

This member function is called to retrieve the background fill color for the flicker free control.

COLORREF GetBackColor();
Returns

An RGB value.

Body Source
COLORREF GetBackColor()
{
    return m_crBack;
}
Group

CXTPNoFlickerWnd Methods


CXTPNoFlickerWnd::SetBackColor Method

CXTPNoFlickerWnd Methods, CXTPNoFlickerWnd Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPNoFlickerWnd::SetBackColor Method

This member function is called to set the background fill color for the flicker free control.

void SetBackColor(
    COLORREF crBack
);
Parameters

crBack
An RGB value.

Body Source
void SetBackColor(COLORREF crBack)
{
    m_crBack = crBack;
}
Group

CXTPNoFlickerWnd Methods


CXTPNoFlickerWnd::WindowProc Method

CXTPNoFlickerWnd Methods, CXTPNoFlickerWnd Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPNoFlickerWnd::WindowProc Method

This method provides a CE procedure (WindowProc) for a CWnd object. It dispatches messages through the window message map. The return value depends on the message.

virtual LRESULT WindowProc(
    UINT message,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

message
Specifies the Windows message to be processed.
wParam
Provides additional information used in processing the message. The parameter value depends on the message.
lParam
Provides additional information used in processing the message. The parameter value depends on the message.

Returns

An LRESULT object.

Body Source
virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam)
{
    switch (message)
    {
    case WM_PAINT:
        {
            CPaintDC dc(this);

            // Get the client rect, and paint to a memory device context.
            // This will help reduce screen flicker.  Pass the memory
            // device context to the default window procedure to do
            // default painting.

            CRect rc;
            GetClientRect(&rc);

            CXTPBufferDC memDC(dc.GetSafeHdc(), rc);
            memDC.FillSolidRect(rc, m_crBack);

            return TBase::DefWindowProc(WM_PAINT,
                (WPARAM)memDC.m_hDC, 0);
        }

    case WM_ERASEBKGND:
        {
            return TRUE;
        }
    }

    return TBase::WindowProc(message, wParam, lParam);
}
Group

CXTPNoFlickerWnd Methods


CXTPNoFlickerWnd Constructors

CXTPNoFlickerWnd Template, Legend, Public Methods
CXTPNoFlickerWnd Constructors
Template

CXTPNoFlickerWnd Template

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPNoFlickerWnd | Constructs a CXTPNoFlickerWnd object.


CXTPNoFlickerWnd::CXTPNoFlickerWnd Constructor

CXTPNoFlickerWnd Constructors, CXTPNoFlickerWnd Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPNoFlickerWnd::CXTPNoFlickerWnd Constructor

Constructs a CXTPNoFlickerWnd object.

CXTPNoFlickerWnd();
Body Source
CXTPNoFlickerWnd()
{
    m_crBack = ::GetSysColor(COLOR_3DFACE);
}
Group

CXTPNoFlickerWnd Constructors


CXTPOfficeBorder Template

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPOfficeBorder Methods, Example, CXTPOfficeBorder Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOfficeBorder Template

CXTPOfficeBorder is a template class used for windows that require a thin border. This class can be used as the base class for any CWnd derived class to display an Office style non-client border.

Class Hierarchy

template <class TBase, bool bCalcSize = true>
class CXTPOfficeBorder : public TBase;
File

XTPDrawHelpers.h

Parameters

TBase
Object class name.
bCalcSize
'true' to remove non-client edge and adjust borders to 1 pixel, 'false' to only draw 1 pixel border.

Example

Sample code demonstrates how to use the CXTPOfficeBorder template class with your base class.

class CTreeCtrlEx : public CXTPOfficeBorder<CXTTreeCtrl>
{
    ...
};

Sample code demonstrates how to use the CXTPOfficeBorder template class with a member variable.

class CMyView : public CView
{
    ...
protected:
    CXTPOfficeBorder<CEdit,false> m_edit;
};
Group

Classes

Legend
Method
protected
virtual
CXTPOfficeBorder Methods
CXTPOfficeBorder Methods | Description
GetBorderColor | Call this function to return the color used for drawing non-client Office style borders for the active current theme.


CXTPOfficeBorder Methods

CXTPOfficeBorder Template, Legend, Protected Methods
CXTPOfficeBorder Methods
Template

CXTPOfficeBorder Template

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetBorderColor | Call this function to return the color used for drawing non-client Office style borders for the active current theme.


CXTPOfficeBorder::GetBorderColor Method

CXTPOfficeBorder Methods, CXTPOfficeBorder Template, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPOfficeBorder::GetBorderColor Method

Call this function to return the color used for drawing non-client Office style borders for the active current theme.

virtual COLORREF GetBorderColor(
    bool bTopLeft
) const;
Parameters

bTopLeft
'true' to return the top-left border color, 'false' to return the bottom-right border color.

Returns

An RGB color value that represents the non-client border color.

Body Source
virtual COLORREF GetBorderColor(bool bTopLeft) const
    {

//{{AFX_CODEJOCK_PRIVATE
#ifndef _XTP_ACTIVEX
#if defined(_XTP_INCLUDE_COMMANDBARS)

        switch (XTPPaintManager()->BaseTheme())
        {
        case xtpThemeOfficeXP:
        case xtpThemeOffice2000:  return GetXtremeColor(bTopLeft? COLOR_3DSHADOW: COLOR_3DHIGHLIGHT);
        case xtpThemeOffice2003:  return GetXtremeColor(XPCOLOR_FRAME);
        case xtpThemeNativeWinXP: return GetXtremeColor(XPCOLOR_STATICFRAME);
        }

#elif defined(_XTP_INCLUDE_CONTROLS)

        switch (XTThemeManager()->GetTheme())
        {
        case xtThemeOfficeXP:
        case xtThemeDefault:     return GetXtremeColor(bTopLeft? COLOR_3DSHADOW: COLOR_3DHIGHLIGHT);
        case xtThemeOffice2003:  return GetXtremeColor(XPCOLOR_FRAME);
        default:                 return GetXtremeColor(XPCOLOR_STATICFRAME);
        }

#endif
#endif
//}}AFX_CODEJOCK_PRIVATE

        return GetXtremeColor(XPCOLOR_3DSHADOW);
    }
Group

CXTPOfficeBorder Methods


CXTPPaintManagerColor Class

XTPColorManager.h, Classes, Legend, Members, Topics, CXTPPaintManagerColor Data Members, CXTPPaintManagerColor Methods, CXTPPaintManagerColor Constructors, CXTPPaintManagerColor Operators, CXTPPaintManagerColor Constructors, CXTPPaintManagerColor Data Members, CXTPPaintManagerColor Methods, CXTPPaintManagerColor Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor Class

The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and application defined colors.

Class Hierarchy

class CXTPPaintManagerColor;
File

XTPColorManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
Operator
CXTPPaintManagerColor Constructors
CXTPPaintManagerColor Constructors | Description
CXTPPaintManagerColor |
CXTPPaintManagerColor Data Members
CXTPPaintManagerColor Data Members | Description
m_clrCustomValue | Application defined color
m_clrStandardValue | Standard color
CXTPPaintManagerColor Methods
CXTPPaintManagerColor Methods | Description
GetStandardColor | This member function will retrieves the default color for the CXTPPaintManagerColor class.
IsCustomValue | This member function determines if the custom color is set and used.
IsDefaultValue | This member function determines if application defined colors are used.
IsStandardValue | This member function determines if the standard color is set and used.
Serialize | This method reads or writes data from or to an archive.
SetCustomValue | This member function will sets the application defined color for the CXTPPaintManagerColor class.
SetDefaultValue | This member function will remove the application defined color (if any) that was defined for the CXTPPaintManagerColor class.
SetStandardValue | This member function will sets the default color for the CXTPPaintManagerColor class.
CXTPPaintManagerColor Operators
CXTPPaintManagerColor Operators | Description
= |
COLORREF | Operator used to retrieve an RGB color value that represents the current color defined for the CXTPPaintManagerColor class.


CXTPPaintManagerColor Data Members

CXTPPaintManagerColor Class, Legend, Protected Data Members
CXTPPaintManagerColor Data Members
Class

CXTPPaintManagerColor Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrCustomValue | Application defined color
m_clrStandardValue | Standard color


CXTPPaintManagerColor::m_clrCustomValue Data Member

CXTPPaintManagerColor Data Members, CXTPPaintManagerColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::m_clrCustomValue Data Member

Application defined color

COLORREF m_clrCustomValue;
Group

CXTPPaintManagerColor Data Members


CXTPPaintManagerColor::m_clrStandardValue Data Member

CXTPPaintManagerColor Data Members, CXTPPaintManagerColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::m_clrStandardValue Data Member

Standard color

COLORREF m_clrStandardValue;
Group

CXTPPaintManagerColor Data Members


CXTPPaintManagerColor Methods

CXTPPaintManagerColor Class, Legend, Public Methods
CXTPPaintManagerColor Methods
Class

CXTPPaintManagerColor Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetStandardColor | This member function will retrieves the default color for the CXTPPaintManagerColor class.
IsCustomValue | This member function determines if the custom color is set and used.
IsDefaultValue | This member function determines if application defined colors are used.
IsStandardValue | This member function determines if the standard color is set and used.
Serialize | This method reads or writes data from or to an archive.
SetCustomValue | This member function will sets the application defined color for the CXTPPaintManagerColor class.
SetDefaultValue | This member function will remove the application defined color (if any) that was defined for the CXTPPaintManagerColor class.
SetStandardValue | This member function will sets the default color for the CXTPPaintManagerColor class.


CXTPPaintManagerColor::GetStandardColor Method

CXTPPaintManagerColor Methods, CXTPPaintManagerColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::GetStandardColor Method

This member function will retrieves the default color for the CXTPPaintManagerColor class.

COLORREF GetStandardColor() const;
Returns

An RGB value that represents the default color.

Body Source
COLORREF CXTPPaintManagerColor::GetStandardColor() const {
    return m_clrStandardValue;
}
Group

CXTPPaintManagerColor Methods


CXTPPaintManagerColor::IsCustomValue Method

CXTPPaintManagerColor Methods, CXTPPaintManagerColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::IsCustomValue Method

This member function determines if the custom color is set and used.

BOOL IsCustomValue() const;
Returns

TRUE if custom color is set, otherwise FALSE.

Body Source
BOOL CXTPPaintManagerColor::IsCustomValue() const {
    return m_clrCustomValue != COLORREF_NULL;
}
Group

CXTPPaintManagerColor Methods


CXTPPaintManagerColor::IsDefaultValue Method

CXTPPaintManagerColor Methods, CXTPPaintManagerColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::IsDefaultValue Method

This member function determines if application defined colors are used.

BOOL IsDefaultValue() const;
Returns

TRUE if application defined colors are used, otherwise FALSE.

Body Source
BOOL CXTPPaintManagerColor::IsDefaultValue() const {
    return (m_clrCustomValue == COLORREF_NULL) && (m_clrStandardValue == COLORREF_NULL);
}
Group

CXTPPaintManagerColor Methods


CXTPPaintManagerColor::IsStandardValue Method

CXTPPaintManagerColor Methods, CXTPPaintManagerColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::IsStandardValue Method

This member function determines if the standard color is set and used.

BOOL IsStandardValue() const;
Returns

TRUE if standard color is set and custom color is not set, otherwise FALSE.

Body Source
BOOL CXTPPaintManagerColor::IsStandardValue() const {
    return (m_clrCustomValue == COLORREF_NULL) && (m_clrStandardValue != COLORREF_NULL);
}
Group

CXTPPaintManagerColor Methods


CXTPPaintManagerColor::Serialize Method

CXTPPaintManagerColor Methods, CXTPPaintManagerColor Class
CXTPPaintManagerColor::Serialize Method

This method reads or writes data from or to an archive.

virtual void Serialize(
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.

Group

CXTPPaintManagerColor Methods


CXTPPaintManagerColor::SetCustomValue Method

CXTPPaintManagerColor Methods, CXTPPaintManagerColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::SetCustomValue Method

This member function will sets the application defined color for the CXTPPaintManagerColor class.

void SetCustomValue(
    COLORREF clr
);
Parameters

clr
n RGB value that represents application defined color to set.

Body Source
void CXTPPaintManagerColor::SetCustomValue(COLORREF clr) {
    m_clrCustomValue = clr;
}
Group

CXTPPaintManagerColor Methods


CXTPPaintManagerColor::SetDefaultValue Method

CXTPPaintManagerColor Methods, CXTPPaintManagerColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::SetDefaultValue Method

This member function will remove the application defined color (if any) that was defined for the CXTPPaintManagerColor class.

void SetDefaultValue();
Body Source
void CXTPPaintManagerColor::SetDefaultValue() {
    m_clrCustomValue = COLORREF_NULL;
}
Group

CXTPPaintManagerColor Methods


CXTPPaintManagerColor::SetStandardValue Method

CXTPPaintManagerColor Methods, CXTPPaintManagerColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::SetStandardValue Method

This member function will sets the default color for the CXTPPaintManagerColor class.

void SetStandardValue(
    COLORREF clr
);
Parameters

clr
n RGB value that represents default color to set.

Body Source
void CXTPPaintManagerColor::SetStandardValue(COLORREF clr) {
    m_clrStandardValue = clr;
}
Group

CXTPPaintManagerColor Methods


CXTPPaintManagerColor Constructors

CXTPPaintManagerColor Class, Legend, Public Methods
CXTPPaintManagerColor Constructors
Class

CXTPPaintManagerColor Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPaintManagerColor |


CXTPPaintManagerColor Constructor

CXTPPaintManagerColor Constructors
CXTPPaintManagerColor Constructor
Overload List
Constructors
Constructor | Description
CXTPPaintManagerColor::CXTPPaintManagerColor () | Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for the class
CXTPPaintManagerColor::CXTPPaintManagerColor (COLORREF) | Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for the class
Group

CXTPPaintManagerColor Constructors


CXTPPaintManagerColor::CXTPPaintManagerColor Constructor ()

CXTPPaintManagerColor Constructor, CXTPPaintManagerColor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::CXTPPaintManagerColor Constructor ()

Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for the class

CXTPPaintManagerColor();
CXTPPaintManagerColor(
    COLORREF clr
);
Parameters

clr
n RGB value that represents default color to set.

See Also

SetStandardValue, SetCustomValue

Group

CXTPPaintManagerColor Constructor


CXTPPaintManagerColor Operators

CXTPPaintManagerColor Class, Legend, Public Operators
CXTPPaintManagerColor Operators
Class

CXTPPaintManagerColor Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= |
COLORREF | Operator used to retrieve an RGB color value that represents the current color defined for the CXTPPaintManagerColor class.


= Operator

CXTPPaintManagerColor Operators
= Operator
Overload List
Operators
Operator | Description
CXTPPaintManagerColor::= (COLORREF) | This operator assigns a new COLORREF value for the application defined color
CXTPPaintManagerColor::= (const CXTPPaintManagerColor&) | This operator assigns a new COLORREF value for the application defined color
Group

CXTPPaintManagerColor Operators


CXTPPaintManagerColor::= Operator (COLORREF)

= Operator, CXTPPaintManagerColor Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::= Operator (COLORREF)

This operator assigns a new COLORREF value for the application defined color

const CXTPPaintManagerColor& operator =(
    COLORREF clr
);
const CXTPPaintManagerColor& operator =(
    const CXTPPaintManagerColor& refclr
);
Parameters

clr
RGB value that represents application defined color to set.
refclr
Reference to CXTPPaintManagerColor value that represents application defined color to set.

See Also

SetStandardValue, SetCustomValue

Body Source
const CXTPPaintManagerColor& CXTPPaintManagerColor::operator=(COLORREF clr) {
    SetCustomValue(clr); return *this;
}

const CXTPPaintManagerColor& CXTPPaintManagerColor::operator=(const CXTPPaintManagerColor& clr) {
    m_clrCustomValue = clr.m_clrCustomValue;
    m_clrStandardValue = clr.m_clrStandardValue;
    return *this;
}
Group

= Operator


CXTPPaintManagerColor::COLORREF Operator

CXTPPaintManagerColor Operators, CXTPPaintManagerColor Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColor::COLORREF Operator

Operator used to retrieve an RGB color value that represents the current color defined for the CXTPPaintManagerColor class.

operator COLORREF() const;
Returns

An RGB value that represents the current color.

Body Source
CXTPPaintManagerColor::operator COLORREF() const{
    return  (m_clrCustomValue == COLORREF_NULL) ? m_clrStandardValue : m_clrCustomValue;
}
Group

CXTPPaintManagerColor Operators


CXTPPaintManagerColorGradient Class

XTPColorManager.h, Classes, Legend, Members, Topics, CXTPPaintManagerColorGradient Data Members, CXTPPaintManagerColorGradient Methods, CXTPPaintManagerColorGradient Constructors, CXTPPaintManagerColorGradient Operators, CXTPPaintManagerColorGradient Constructors, CXTPPaintManagerColorGradient Data Members, CXTPPaintManagerColorGradient Methods, CXTPPaintManagerColorGradient Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient Class

The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and dark gradient colors.

Class Hierarchy

class CXTPPaintManagerColorGradient;
File

XTPColorManager.h

See Also

CXTPPaintManagerColor

Group

Classes

Legend
Data Member
Method
virtual
Operator
CXTPPaintManagerColorGradient Constructors
CXTPPaintManagerColorGradient Constructors | Description
CXTPPaintManagerColorGradient |
CXTPPaintManagerColorGradient Data Members
CXTPPaintManagerColorGradient Data Members | Description
clrDark | Dark color.
clrLight | Light color.
fGradientFactor | Gradient divider factor
CXTPPaintManagerColorGradient Methods
CXTPPaintManagerColorGradient Methods | Description
IsNull | Determines if the CXTPPaintManagerColorGradient object's colors have been initialized.
Serialize | This method reads or writes data from or to an archive.
SetCustomValue |
SetStandardValue |
CXTPPaintManagerColorGradient Operators
CXTPPaintManagerColorGradient Operators | Description
= | This operator copy all values from the specified source object;
COLORREF | Operator used to retrieve an RGB color value that represents the dark gradient color used for the CXTPPaintManagerColorGradient class.
CXTPPaintManagerColor& | Retrieves a reference to the CXTPPaintManagerColor dark gradient color member.


CXTPPaintManagerColorGradient Data Members

CXTPPaintManagerColorGradient Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient Data Members
Class

CXTPPaintManagerColorGradient Class

Legend
Data Member
Public Data Members
Public Data Member | Description
clrDark | Dark color.
clrLight | Light color.
fGradientFactor | Gradient divider factor


CXTPPaintManagerColorGradient::clrDark Data Member

CXTPPaintManagerColorGradient Data Members, CXTPPaintManagerColorGradient Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::clrDark Data Member

Dark color.

CXTPPaintManagerColor clrDark;
Group

CXTPPaintManagerColorGradient Data Members


CXTPPaintManagerColorGradient::clrLight Data Member

CXTPPaintManagerColorGradient Data Members, CXTPPaintManagerColorGradient Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::clrLight Data Member

Light color.

CXTPPaintManagerColor clrLight;
Group

CXTPPaintManagerColorGradient Data Members


CXTPPaintManagerColorGradient::fGradientFactor Data Member

CXTPPaintManagerColorGradient Data Members, CXTPPaintManagerColorGradient Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::fGradientFactor Data Member

Gradient divider factor

float fGradientFactor;
Group

CXTPPaintManagerColorGradient Data Members


CXTPPaintManagerColorGradient Methods

CXTPPaintManagerColorGradient Class, Legend, Public Methods
CXTPPaintManagerColorGradient Methods
Class

CXTPPaintManagerColorGradient Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
IsNull | Determines if the CXTPPaintManagerColorGradient object's colors have been initialized.
Serialize | This method reads or writes data from or to an archive.
SetCustomValue |
SetStandardValue |


CXTPPaintManagerColorGradient::IsNull Method

CXTPPaintManagerColorGradient Methods, CXTPPaintManagerColorGradient Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::IsNull Method

Determines if the CXTPPaintManagerColorGradient object's colors have been initialized.

BOOL IsNull() const;
Returns

TRUE if both light and dark gradient colors have not been initialized, otherwise FALSE.

Body Source
BOOL CXTPPaintManagerColorGradient::IsNull() const {
    return ((clrDark == COLORREF_NULL) && (clrLight == COLORREF_NULL));
}
Group

CXTPPaintManagerColorGradient Methods


CXTPPaintManagerColorGradient::Serialize Method

CXTPPaintManagerColorGradient Methods, CXTPPaintManagerColorGradient Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::Serialize Method

This method reads or writes data from or to an archive.

virtual void Serialize(
    CArchive& ar
);
Parameters

ar
A CArchive object to serialize to or from.

Group

CXTPPaintManagerColorGradient Methods


SetCustomValue Method

CXTPPaintManagerColorGradient Methods
SetCustomValue Method
Overload List
Methods
Method | Description
CXTPPaintManagerColorGradient::SetCustomValue (COLORREF, COLORREF) | This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.
CXTPPaintManagerColorGradient::SetCustomValue (CXTPPaintManagerColorGradient&) | This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.
CXTPPaintManagerColorGradient::SetCustomValue (const COLORREF) | This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.
Group

CXTPPaintManagerColorGradient Methods


CXTPPaintManagerColorGradient::SetCustomValue Method (const COLORREF)

SetCustomValue Method, CXTPPaintManagerColorGradient Class
CXTPPaintManagerColorGradient::SetCustomValue Method (const COLORREF)

This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.

void SetCustomValue(
    const COLORREF clr
);
void SetCustomValue(
    CXTPPaintManagerColorGradient& clrref
);
void SetCustomValue(
    COLORREF clrLight,
    COLORREF clrDark
);
Parameters

clr
An RGB COLORREF value representing the dark and light colors.
clrref
An reference to CXTPPaintManagerColorGradient value representing the dark and light colors.
clrLight
An RGB COLORREF value representing the light color.
clrDark
An RGB COLORREF value representing the dark color.

Group

SetCustomValue Method


SetStandardValue Method

CXTPPaintManagerColorGradient Methods
SetStandardValue Method
Overload List
Methods
Method | Description
CXTPPaintManagerColorGradient::SetStandardValue (COLORREF, COLORREF, float) | This member function sets the value of the default dark and light colors equal to the specified COLORREF value.
CXTPPaintManagerColorGradient::SetStandardValue (CXTPPaintManagerColorGradient&) | This member function sets the value of the default dark and light colors equal to the specified COLORREF value.
CXTPPaintManagerColorGradient::SetStandardValue (const COLORREF) | This member function sets the value of the default dark and light colors equal to the specified COLORREF value.
Group

CXTPPaintManagerColorGradient Methods


CXTPPaintManagerColorGradient::SetStandardValue Method (const COLORREF)

SetStandardValue Method, CXTPPaintManagerColorGradient Class
CXTPPaintManagerColorGradient::SetStandardValue Method (const COLORREF)

This member function sets the value of the default dark and light colors equal to the specified COLORREF value.

void SetStandardValue(
    const COLORREF clr
);
void SetStandardValue(
    CXTPPaintManagerColorGradient& clrref
);
void SetStandardValue(
    COLORREF clrLight,
    COLORREF clrDark,
    float fGradientFactor = 0.5f
);
Parameters

clr
An RGB COLORREF value representing the dark and light colors.
clrref
An reference to CXTPPaintManagerColorGradient value representing the dark and light colors.
clrLight
An RGB COLORREF value representing the light color.
clrDark
An RGB COLORREF value representing the dark color.
fGradientFactor
Gradient divider factor

Group

SetStandardValue Method


CXTPPaintManagerColorGradient Constructors

CXTPPaintManagerColorGradient Class, Legend, Public Methods
CXTPPaintManagerColorGradient Constructors
Class

CXTPPaintManagerColorGradient Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPaintManagerColorGradient |


CXTPPaintManagerColorGradient Constructor

CXTPPaintManagerColorGradient Constructors
CXTPPaintManagerColorGradient Constructor
Overload List
Constructors
Constructor | Description
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient () | Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient (COLORREF, COLORREF) | Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient (const COLORREF) | Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient (const CXTPPaintManagerColor) | Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.
Group

CXTPPaintManagerColorGradient Constructors


CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient Constructor ()

CXTPPaintManagerColorGradient Constructor, CXTPPaintManagerColorGradient Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient Constructor ()

Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.

CXTPPaintManagerColorGradient();
CXTPPaintManagerColorGradient(
    const COLORREF clr
);
CXTPPaintManagerColorGradient(
    const CXTPPaintManagerColor clr
);
CXTPPaintManagerColorGradient(
    COLORREF clrLight,
    COLORREF clrDark
);
Parameters

clr
An RGB COLORREF value representing the dark and light colors.
clrLight
An RGB COLORREF value representing the light color.
clrDark
An RGB COLORREF value representing the dark color.

See Also

SetStandardValue, SetCustomValue

Group

CXTPPaintManagerColorGradient Constructor


CXTPPaintManagerColorGradient Operators

CXTPPaintManagerColorGradient Class, Legend, Public Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient Operators
Class

CXTPPaintManagerColorGradient Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | This operator copy all values from the specified source object;
COLORREF | Operator used to retrieve an RGB color value that represents the dark gradient color used for the CXTPPaintManagerColorGradient class.
CXTPPaintManagerColor& | Retrieves a reference to the CXTPPaintManagerColor dark gradient color member.


CXTPPaintManagerColorGradient::= Operator

CXTPPaintManagerColorGradient Operators, CXTPPaintManagerColorGradient Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::= Operator

This operator copy all values from the specified source object;

const CXTPPaintManagerColorGradient& operator =(
    const CXTPPaintManagerColorGradient& refSrc
);
Parameters

refSrc
Reference to CXTPPaintManagerColorGradient source object.

See Also

SetStandardValue, SetCustomValue

Body Source
const CXTPPaintManagerColorGradient& CXTPPaintManagerColorGradient::operator=(const CXTPPaintManagerColorGradient& refSrc) {
    clrLight = refSrc.clrLight;
    clrDark = refSrc.clrDark;
    fGradientFactor = refSrc.fGradientFactor;
    return *this;
}
Group

CXTPPaintManagerColorGradient Operators


CXTPPaintManagerColorGradient::COLORREF Operator

CXTPPaintManagerColorGradient Operators, CXTPPaintManagerColorGradient Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::COLORREF Operator

Operator used to retrieve an RGB color value that represents the dark gradient color used for the CXTPPaintManagerColorGradient class.

operator COLORREF() const;
Returns

An RGB value that represents the dark gradient color.

Body Source
CXTPPaintManagerColorGradient::operator COLORREF () const {
    return clrDark;
}
Group

CXTPPaintManagerColorGradient Operators


CXTPPaintManagerColorGradient::CXTPPaintManagerColor& Operator

CXTPPaintManagerColorGradient Operators, CXTPPaintManagerColorGradient Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPaintManagerColorGradient::CXTPPaintManagerColor& Operator

Retrieves a reference to the CXTPPaintManagerColor dark gradient color member.

operator CXTPPaintManagerColor&();
Returns

A reference to the CXTPPaintManagerColor dark gradient color used for the CXTPPaintManagerColorGradient class.

Body Source
CXTPPaintManagerColorGradient::operator CXTPPaintManagerColor& () {
    return clrDark;
}
Group

CXTPPaintManagerColorGradient Operators


CXTPPenDC Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPPenDC Data Members, CXTPPenDC Methods, CXTPPenDC Constructors, CXTPPenDC Destructors, CXTPPenDC Constructors, CXTPPenDC Data Members, CXTPPenDC Destructors, CXTPPenDC Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPenDC Class

CXTPPenDC is a helper class used to create a pen using the color specified by crColor. The pen is then selected into the device context specified by hDC. When destroyed, the class selects the previous pen back into the device context to handle GDI resource cleanup.

Class Hierarchy

class CXTPPenDC;
File

XTPDrawHelpers.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPenDC Constructors
CXTPPenDC Constructors | Description
CXTPPenDC |
CXTPPenDC Data Members
CXTPPenDC Data Members | Description
m_hDC | Device context handle.
m_hOldPen | Handle to the previously selected pen.
m_pen | Pen selected into device context.
CXTPPenDC Destructors
CXTPPenDC Destructors | Description
~CXTPPenDC | Destroys a CXTPPenDC object, handles cleanup and de- allocation.
CXTPPenDC Methods
CXTPPenDC Methods | Description
Color |


CXTPPenDC Data Members

CXTPPenDC Class, Legend, Protected Data Members
CXTPPenDC Data Members
Class

CXTPPenDC Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hDC | Device context handle.
m_hOldPen | Handle to the previously selected pen.
m_pen | Pen selected into device context.


CXTPPenDC::m_hDC Data Member

CXTPPenDC Data Members, CXTPPenDC Class
CXTPPenDC::m_hDC Data Member

Device context handle.

HDC m_hDC;
Group

CXTPPenDC Data Members


CXTPPenDC::m_hOldPen Data Member

CXTPPenDC Data Members, CXTPPenDC Class
CXTPPenDC::m_hOldPen Data Member

Handle to the previously selected pen.

HPEN m_hOldPen;
Group

CXTPPenDC Data Members


CXTPPenDC::m_pen Data Member

CXTPPenDC Data Members, CXTPPenDC Class
CXTPPenDC::m_pen Data Member

Pen selected into device context.

CPen m_pen;
Group

CXTPPenDC Data Members


CXTPPenDC Methods

CXTPPenDC Class, Legend, Public Methods
CXTPPenDC Methods
Class

CXTPPenDC Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Color |


Color Method

CXTPPenDC Methods
Color Method
Overload List
Methods
Method | Description
CXTPPenDC::Color () | Call this member function to retrieve or change the color used by the device context pen.
CXTPPenDC::Color (COLORREF) | Call this member function to retrieve or change the color used by the device context pen.
Group

CXTPPenDC Methods


CXTPPenDC::Color Method ()

Color Method, CXTPPenDC Class
CXTPPenDC::Color Method ()

Call this member function to retrieve or change the color used by the device context pen.

COLORREF Color();
void Color(
    COLORREF crColor
);
Parameters

crColor
RGB value to change the pen color to.

Returns

The no argument version returns an RGB value that represents the selected pen color.

Remarks

The No argument version is used to retrieve the color used by the device context pen.

Group

Color Method


CXTPPenDC Constructors

CXTPPenDC Class, Legend, Public Methods
CXTPPenDC Constructors
Class

CXTPPenDC Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPenDC |


CXTPPenDC Constructor

CXTPPenDC Constructors
CXTPPenDC Constructor
Overload List
Constructors
Constructor | Description
CXTPPenDC::CXTPPenDC (CDC*, CPen*) | Constructs a CXTPPenDC object using an existing CPen object. The pen is then selected into the device context specified by hDC.
CXTPPenDC::CXTPPenDC (HDC, COLORREF) | Constructs a CXTPPenDC object using an existing CPen object. The pen is then selected into the device context specified by hDC.
Group

CXTPPenDC Constructors


CXTPPenDC::CXTPPenDC Constructor (CDC*, CPen*)

CXTPPenDC Constructor, CXTPPenDC Class
CXTPPenDC::CXTPPenDC Constructor (CDC*, CPen*)

Constructs a CXTPPenDC object using an existing CPen object. The pen is then selected into the device context specified by hDC.

CXTPPenDC(
    CDC* pDC,
    CPen* pPen
);
CXTPPenDC(
    HDC hDC,
    COLORREF crColor
);
Parameters

pDC
Pointer to a valid device context.
pPen
Pointer to a CPen object to select into the device context.
hDC
Handle to a valid device context.
crColor
RGB value used to create pen.

Remarks

The crColor version constructs a CXTPPenDC object and creates a pen using the color specified by crColor. The pen is then selected into the device context specified by hDC.

Group

CXTPPenDC Constructor


CXTPPenDC Destructors

CXTPPenDC Class, Legend, Public Methods
CXTPPenDC Destructors
Class

CXTPPenDC Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPenDC | Destroys a CXTPPenDC object, handles cleanup and de- allocation.


CXTPPenDC::~CXTPPenDC Destructor

CXTPPenDC Destructors, CXTPPenDC Class
CXTPPenDC::~CXTPPenDC Destructor

Destroys a CXTPPenDC object, handles cleanup and de- allocation.

virtual ~CXTPPenDC();
Group

CXTPPenDC Destructors


CXTPPrinterInfo Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPPrinterInfo Enumerations, CXTPPrinterInfo Methods, CXTPPrinterInfo Constructors, CXTPPrinterInfo Destructors, CXTPPrinterInfo Constructors, CXTPPrinterInfo Destructors, CXTPPrinterInfo Enumerations, CXTPPrinterInfo Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrinterInfo Class

Helper class which provide currently selected printer information.

Class Hierarchy

class CXTPPrinterInfo;
File

XTPDrawHelpers.h

Group

Classes

Legend
Enumeration
Method
protected
virtual
CXTPPrinterInfo Constructors
CXTPPrinterInfo Constructors | Description
CXTPPrinterInfo | Default object constructor.
CXTPPrinterInfo Destructors
CXTPPrinterInfo Destructors | Description
~CXTPPrinterInfo | Default object destructor.
CXTPPrinterInfo Enumerations
CXTPPrinterInfo Enumerations | Description
XTPEnumDeviceName | This enum defines some printer properties IDs.
CXTPPrinterInfo Methods
CXTPPrinterInfo Methods | Description
_GetNameOffset | This member function returns name offset by name ID.
GetName | Call this member function to retrieve currently selected printer Driver name, Device name or Port name.


CXTPPrinterInfo Enumerations

Enumerations, CXTPPrinterInfo Class, Legend
CXTPPrinterInfo Enumerations
Enumerations
Enumeration | Description
XTPEnumDeviceName | This enum defines some printer properties IDs.
Class

CXTPPrinterInfo Class

Legend
Enumeration


CXTPPrinterInfo::XTPEnumDeviceName Enumeration

XTPDrawHelpers.h, CXTPPrinterInfo Enumerations, See Also
CXTPPrinterInfo::XTPEnumDeviceName Enumeration

This enum defines some printer properties IDs.

enum XTPEnumDeviceName {
  xtpDevName_Driver = 0,
  xtpDevName_Device = 1,
  xtpDevName_Port = 2
};
File

XTPDrawHelpers.h

Members

xtpDevName_Driver
Define Driver name property.
xtpDevName_Device
Define Device name property.
xtpDevName_Port
Define Port name property.

See Also

GetName

Group

CXTPPrinterInfo Enumerations


CXTPPrinterInfo Methods

CXTPPrinterInfo Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrinterInfo Methods
Class

CXTPPrinterInfo Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
_GetNameOffset | This member function returns name offset by name ID.
Public Methods
Public Methods
Public Method | Description
GetName | Call this member function to retrieve currently selected printer Driver name, Device name or Port name.


CXTPPrinterInfo::_GetNameOffset Method

CXTPPrinterInfo Methods, CXTPPrinterInfo Class, See Also
CXTPPrinterInfo::_GetNameOffset Method

This member function returns name offset by name ID.

WORD _GetNameOffset(
    LPDEVNAMES pDevNames,
    XTPEnumDeviceName eNameID
);
Parameters

pDevNames
[in] A pointer to DEVNAMES structure.
eNameID
[in] Name ID.

Returns

name Offset in chars.

See Also

XTPEnumDeviceName, DEVNAMES

Group

CXTPPrinterInfo Methods


CXTPPrinterInfo::GetName Method

CXTPPrinterInfo Methods, CXTPPrinterInfo Class, See Also
CXTPPrinterInfo::GetName Method

Call this member function to retrieve currently selected printer Driver name, Device name or Port name.

CString GetName(
    XTPEnumDeviceName eNameID
);
Parameters

eNameID
[in] A value from XTPEnumDeviceName enum which specify property.

Returns

A string with requested name.

See Also

XTPEnumDeviceName

Group

CXTPPrinterInfo Methods


CXTPPrinterInfo Constructors

CXTPPrinterInfo Class, Legend, Public Methods
CXTPPrinterInfo Constructors
Class

CXTPPrinterInfo Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPrinterInfo | Default object constructor.


CXTPPrinterInfo::CXTPPrinterInfo Constructor

CXTPPrinterInfo Constructors, CXTPPrinterInfo Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrinterInfo::CXTPPrinterInfo Constructor

Default object constructor.

CXTPPrinterInfo();
See Also

~CXTPPrinterInfo

Group

CXTPPrinterInfo Constructors


CXTPPrinterInfo Destructors

CXTPPrinterInfo Class, Legend, Public Methods
CXTPPrinterInfo Destructors
Class

CXTPPrinterInfo Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPrinterInfo | Default object destructor.


CXTPPrinterInfo::~CXTPPrinterInfo Destructor

CXTPPrinterInfo Destructors, CXTPPrinterInfo Class, See Also
CXTPPrinterInfo::~CXTPPrinterInfo Destructor

Default object destructor.

virtual ~CXTPPrinterInfo();
See Also

CXTPPrinterInfo

Group

CXTPPrinterInfo Destructors


CXTPPrintOptions Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPPrintOptions Data Members, CXTPPrintOptions Methods, CXTPPrintOptions Constructors, CXTPPrintOptions Destructors, CXTPPrintOptions Constructors, CXTPPrintOptions Data Members, CXTPPrintOptions Destructors, CXTPPrintOptions Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintOptions Class

This class used as a base class to store printing options. It contains a base properties and operations for printing tasks.

Class Hierarchy

class CXTPPrintOptions;
File

XTPDrawHelpers.h

See Also

CXTPPrintPageHeaderFooter

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPrintOptions Constructors
CXTPPrintOptions Constructors | Description
CXTPPrintOptions | Default Object constructor.
CXTPPrintOptions Data Members
CXTPPrintOptions Data Members | Description
m_bBlackWhitePrinting | Store printing mode: Color or Black&White.
m_nBlackWhiteContrast | Black&White printing contrast: 0 ...
m_pPageFooter | A page Footer properties.
m_pPageHeader | A page Header properties.
m_rcMargins | Margins (mm*100 or inches*1000)
CXTPPrintOptions Destructors
CXTPPrintOptions Destructors | Description
~CXTPPrintOptions | Default Object destructor.
CXTPPrintOptions Methods
CXTPPrintOptions Methods | Description
GetActiveLCID | Override this member function in derived class to specify active locale ID.
GetMarginsHimetric | Call this member function to get margins in Himetric units.
GetMarginsLP | Call this member function to get margins in Logical points.
GetPageFooter | Returns a page Footer properties.
GetPageHeader | Returns a page Header properties.
IsMarginsMeasureInches | Call this member function to determine margins measure: inches or millimeters (mm*100 or inches*1000).
Set | Call this member function to copy members from specified source object.


CXTPPrintOptions Data Members

CXTPPrintOptions Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintOptions Data Members
Class

CXTPPrintOptions Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pPageFooter | A page Footer properties.
m_pPageHeader | A page Header properties.
Public Data Members
Public Data Member | Description
m_bBlackWhitePrinting | Store printing mode: Color or Black&White.
m_nBlackWhiteContrast | Black&White printing contrast: 0 ...
m_rcMargins | Margins (mm*100 or inches*1000)


CXTPPrintOptions::m_bBlackWhitePrinting Data Member

CXTPPrintOptions Data Members, CXTPPrintOptions Class
CXTPPrintOptions::m_bBlackWhitePrinting Data Member

Store printing mode: Color or Black&White.

BOOL m_bBlackWhitePrinting;
Group

CXTPPrintOptions Data Members


CXTPPrintOptions::m_nBlackWhiteContrast Data Member

CXTPPrintOptions Data Members, CXTPPrintOptions Class
CXTPPrintOptions::m_nBlackWhiteContrast Data Member

Black&White printing contrast: 0 ...

int m_nBlackWhiteContrast;
Group

CXTPPrintOptions Data Members


CXTPPrintOptions::m_pPageFooter Data Member

CXTPPrintOptions Data Members, CXTPPrintOptions Class
CXTPPrintOptions::m_pPageFooter Data Member

A page Footer properties.

CXTPPrintPageHeaderFooter* m_pPageFooter;
Group

CXTPPrintOptions Data Members


CXTPPrintOptions::m_pPageHeader Data Member

CXTPPrintOptions Data Members, CXTPPrintOptions Class
CXTPPrintOptions::m_pPageHeader Data Member

A page Header properties.

CXTPPrintPageHeaderFooter* m_pPageHeader;
Group

CXTPPrintOptions Data Members


CXTPPrintOptions::m_rcMargins Data Member

CXTPPrintOptions Data Members, CXTPPrintOptions Class
CXTPPrintOptions::m_rcMargins Data Member

Margins (mm*100 or inches*1000)

CRect m_rcMargins;
Group

CXTPPrintOptions Data Members


CXTPPrintOptions Methods

CXTPPrintOptions Class, Legend, Public Methods
CXTPPrintOptions Methods
Class

CXTPPrintOptions Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetActiveLCID | Override this member function in derived class to specify active locale ID.
GetMarginsHimetric | Call this member function to get margins in Himetric units.
GetMarginsLP | Call this member function to get margins in Logical points.
GetPageFooter | Returns a page Footer properties.
GetPageHeader | Returns a page Header properties.
IsMarginsMeasureInches | Call this member function to determine margins measure: inches or millimeters (mm*100 or inches*1000).
Set | Call this member function to copy members from specified source object.


CXTPPrintOptions::GetActiveLCID Method

CXTPPrintOptions Methods, CXTPPrintOptions Class
CXTPPrintOptions::GetActiveLCID Method

Override this member function in derived class to specify active locale ID.

virtual LCID GetActiveLCID();
Returns

Locale ID. Base implementation returns LOCALE_USER_DEFAULT;

Group

CXTPPrintOptions Methods


CXTPPrintOptions::GetMarginsHimetric Method

CXTPPrintOptions Methods, CXTPPrintOptions Class, See Also
CXTPPrintOptions::GetMarginsHimetric Method

Call this member function to get margins in Himetric units.

virtual CRect GetMarginsHimetric();
Returns

Returns margins in Himetric units.

See Also

m_rcMargins, GetMarginsLP

Group

CXTPPrintOptions Methods


CXTPPrintOptions::GetMarginsLP Method

CXTPPrintOptions Methods, CXTPPrintOptions Class, See Also
CXTPPrintOptions::GetMarginsLP Method

Call this member function to get margins in Logical points.

virtual CRect GetMarginsLP(
    CDC* pDC
);
Parameters

pDC
[in] A pointer to device context.

Returns

Returns margins in Logical units.

See Also

m_rcMargins, GetMarginsHimetric

Group

CXTPPrintOptions Methods


CXTPPrintOptions::GetPageFooter Method

CXTPPrintOptions Methods, CXTPPrintOptions Class, See Also
CXTPPrintOptions::GetPageFooter Method

Returns a page Footer properties.

CXTPPrintPageHeaderFooter* GetPageFooter();
See Also

GetPageHeader

Group

CXTPPrintOptions Methods


CXTPPrintOptions::GetPageHeader Method

CXTPPrintOptions Methods, CXTPPrintOptions Class, See Also
CXTPPrintOptions::GetPageHeader Method

Returns a page Header properties.

CXTPPrintPageHeaderFooter* GetPageHeader();
See Also

GetPageFooter

Group

CXTPPrintOptions Methods


CXTPPrintOptions::IsMarginsMeasureInches Method

CXTPPrintOptions Methods, CXTPPrintOptions Class, See Also
CXTPPrintOptions::IsMarginsMeasureInches Method

Call this member function to determine margins measure: inches or millimeters (mm*100 or inches*1000).

virtual BOOL IsMarginsMeasureInches();
Returns

Returns TRUE if margins measure in inches, FALSE otherwise.

See Also

m_rcMargins, GetMarginsHimetric, GetMarginsLP

Group

CXTPPrintOptions Methods


CXTPPrintOptions::Set Method

CXTPPrintOptions Methods, CXTPPrintOptions Class
CXTPPrintOptions::Set Method

Call this member function to copy members from specified source object.

void Set(
    const CXTPPrintOptions* pSrc
);
Parameters

pSrc
A pointer to source object to copy data.

Group

CXTPPrintOptions Methods


CXTPPrintOptions Constructors

CXTPPrintOptions Class, Legend, Public Methods
CXTPPrintOptions Constructors
Class

CXTPPrintOptions Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPrintOptions | Default Object constructor.


CXTPPrintOptions::CXTPPrintOptions Constructor

CXTPPrintOptions Constructors, CXTPPrintOptions Class
CXTPPrintOptions::CXTPPrintOptions Constructor

Default Object constructor.

CXTPPrintOptions();
Group

CXTPPrintOptions Constructors


CXTPPrintOptions Destructors

CXTPPrintOptions Class, Legend, Public Methods
CXTPPrintOptions Destructors
Class

CXTPPrintOptions Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPrintOptions | Default Object destructor.


CXTPPrintOptions::~CXTPPrintOptions Destructor

CXTPPrintOptions Destructors, CXTPPrintOptions Class
CXTPPrintOptions::~CXTPPrintOptions Destructor

Default Object destructor.

virtual ~CXTPPrintOptions();
Group

CXTPPrintOptions Destructors


CXTPPrintPageHeaderFooter Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Methods, CXTPPrintPageHeaderFooter Constructors, CXTPPrintPageHeaderFooter Destructors, CXTPPrintPageHeaderFooter Constructors, CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Destructors, CXTPPrintPageHeaderFooter Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter Class

This class used to define printed page header or footer. Also some calculation and drawing functionality are provided. Used as member of printing options.

Class Hierarchy

class CXTPPrintPageHeaderFooter;
File

XTPDrawHelpers.h

See Also

CXTPPrintOptions

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPrintPageHeaderFooter Constructors
CXTPPrintPageHeaderFooter Constructors | Description
CXTPPrintPageHeaderFooter | Object constructor.
CXTPPrintPageHeaderFooter Data Members
CXTPPrintPageHeaderFooter Data Members | Description
m_bHeader | If TRUE object represents a Header, otherwise footer.
m_clrColor | Text color
m_lfFont | Font details
m_pOwner | Store pointer to owner object.
m_strCenter | A string to show with center align
m_strFormatString | Text as Format string
m_strLeft | A string to show with left align
m_strRight | A string to show with right align
CXTPPrintPageHeaderFooter Destructors
CXTPPrintPageHeaderFooter Destructors | Description
~CXTPPrintPageHeaderFooter | Default object destructor.
CXTPPrintPageHeaderFooter Methods
CXTPPrintPageHeaderFooter Methods | Description
Clear | Call this member function to clear all members values.
Draw | Call this member function to draw header or footer on the device context.
FormatTexts | Call this member function to format footer or header using format string specified in m_strFormatString member. The formatted text is copied in following members: m_strLeft, m_strCenter, m_strRight. If m_strFormatString is empty - FormatTexts do nothing.
IsEmpty | Returns TRUE if all strings are empty
Set | Call this member function to copy members from specified source object.


CXTPPrintPageHeaderFooter Data Members

CXTPPrintPageHeaderFooter Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter Data Members
Class

CXTPPrintPageHeaderFooter Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bHeader | If TRUE object represents a Header, otherwise footer.
m_pOwner | Store pointer to owner object.
Public Data Members
Public Data Member | Description
m_clrColor | Text color
m_lfFont | Font details
m_strCenter | A string to show with center align
m_strFormatString | Text as Format string
m_strLeft | A string to show with left align
m_strRight | A string to show with right align


CXTPPrintPageHeaderFooter::m_bHeader Data Member

CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::m_bHeader Data Member

If TRUE object represents a Header, otherwise footer.

BOOL m_bHeader;
Group

CXTPPrintPageHeaderFooter Data Members


CXTPPrintPageHeaderFooter::m_clrColor Data Member

CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::m_clrColor Data Member

Text color

COLORREF m_clrColor;
Group

CXTPPrintPageHeaderFooter Data Members


CXTPPrintPageHeaderFooter::m_lfFont Data Member

CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::m_lfFont Data Member

Font details

LOGFONT m_lfFont;
Group

CXTPPrintPageHeaderFooter Data Members


CXTPPrintPageHeaderFooter::m_pOwner Data Member

CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::m_pOwner Data Member

Store pointer to owner object.

CXTPPrintOptions* m_pOwner;
Group

CXTPPrintPageHeaderFooter Data Members


CXTPPrintPageHeaderFooter::m_strCenter Data Member

CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::m_strCenter Data Member

A string to show with center align

CString m_strCenter;
Group

CXTPPrintPageHeaderFooter Data Members


CXTPPrintPageHeaderFooter::m_strFormatString Data Member

CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::m_strFormatString Data Member

Text as Format string

CString m_strFormatString;
Group

CXTPPrintPageHeaderFooter Data Members


CXTPPrintPageHeaderFooter::m_strLeft Data Member

CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::m_strLeft Data Member

A string to show with left align

CString m_strLeft;
Group

CXTPPrintPageHeaderFooter Data Members


CXTPPrintPageHeaderFooter::m_strRight Data Member

CXTPPrintPageHeaderFooter Data Members, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::m_strRight Data Member

A string to show with right align

CString m_strRight;
Group

CXTPPrintPageHeaderFooter Data Members


CXTPPrintPageHeaderFooter Methods

CXTPPrintPageHeaderFooter Class, Legend, Public Methods
CXTPPrintPageHeaderFooter Methods
Class

CXTPPrintPageHeaderFooter Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Clear | Call this member function to clear all members values.
Draw | Call this member function to draw header or footer on the device context.
FormatTexts | Call this member function to format footer or header using format string specified in m_strFormatString member. The formatted text is copied in following members: m_strLeft, m_strCenter, m_strRight. If m_strFormatString is empty - FormatTexts do nothing.
IsEmpty | Returns TRUE if all strings are empty
Set | Call this member function to copy members from specified source object.


CXTPPrintPageHeaderFooter::Clear Method

CXTPPrintPageHeaderFooter Methods, CXTPPrintPageHeaderFooter Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::Clear Method

Call this member function to clear all members values.

virtual void Clear();
See Also

Set

Group

CXTPPrintPageHeaderFooter Methods


CXTPPrintPageHeaderFooter::Draw Method

CXTPPrintPageHeaderFooter Methods, CXTPPrintPageHeaderFooter Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::Draw Method

Call this member function to draw header or footer on the device context.

virtual void Draw(
    CDC* pDC,
    CRect& rcRect,
    BOOL bCalculateOnly = FALSE
);
Parameters

pDC
[in] A pointer to device context.
rcRect
[in, out] A reference to bounding rectangle. After function call this member contains rect necessary to draw header or footer. Header is aligned to top of passed bounding rectangle, footer to bottom.
bCalculateOnly
If this parameter TRUE - the only rectangle calculated, without drawing.

See Also

FormatTexts, m_strLeft, m_strCenter, m_strRight

Group

CXTPPrintPageHeaderFooter Methods


CXTPPrintPageHeaderFooter::FormatTexts Method

CXTPPrintPageHeaderFooter Methods, CXTPPrintPageHeaderFooter Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::FormatTexts Method

Call this member function to format footer or header using format string specified in m_strFormatString member. The formatted text is copied in following members: m_strLeft, m_strCenter, m_strRight. If m_strFormatString is empty - FormatTexts do nothing.

virtual void FormatTexts(
    CPrintInfo* pInfo,
    LPCTSTR pcszWndTitle
);
Parameters

pInfo
[in] Printing context.
pcszWndTitle
[in] Pointer to window title (for &w format string specifier).

Remarks

FormatTexts should be called before Draw call. Format specifiers the same as in Internet Explorer: [ul] [li]&d Date in short format (as specified by Regional Settings in Control Panel) [li]&D Date in long format (as specified by Regional Settings in Control Panel)

[li]&t Time in the format specified by Regional Settings in Control Panel [li]&T Time in 24-hour format

[li]&p Current page number [li]&P Total number of pages

[li]&b The text immediately following these characters as centered. [li]&b&b The text immediately following the first "&b" as centered, and the text following the second "&b" as right-justified.

[li]&w Window title

[li]&& A single ampersand (&) [li]n new line marker [/ul]

See Also

m_strFormatString, m_strLeft, m_strCenter, m_strRight

Group

CXTPPrintPageHeaderFooter Methods


CXTPPrintPageHeaderFooter::IsEmpty Method

CXTPPrintPageHeaderFooter Methods, CXTPPrintPageHeaderFooter Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::IsEmpty Method

Returns TRUE if all strings are empty

virtual BOOL IsEmpty();
Group

CXTPPrintPageHeaderFooter Methods


CXTPPrintPageHeaderFooter::Set Method

CXTPPrintPageHeaderFooter Methods, CXTPPrintPageHeaderFooter Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::Set Method

Call this member function to copy members from specified source object.

virtual void Set(
    const CXTPPrintPageHeaderFooter* pSrc
);
Parameters

pSrc
A pointer to source object to copy data.

See Also

Clear

Group

CXTPPrintPageHeaderFooter Methods


CXTPPrintPageHeaderFooter Constructors

CXTPPrintPageHeaderFooter Class, Legend, Public Methods
CXTPPrintPageHeaderFooter Constructors
Class

CXTPPrintPageHeaderFooter Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPrintPageHeaderFooter | Object constructor.


CXTPPrintPageHeaderFooter::CXTPPrintPageHeaderFooter Constructor

CXTPPrintPageHeaderFooter Constructors, CXTPPrintPageHeaderFooter Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::CXTPPrintPageHeaderFooter Constructor

Object constructor.

CXTPPrintPageHeaderFooter(
    CXTPPrintOptions* pOwner,
    BOOL bHeader
);
Parameters

pOwner
A pointer to owner object.
bHeader
If TRUE object represents a Header, otherwise footer.

See Also

CXTPPrintOptions

Group

CXTPPrintPageHeaderFooter Constructors


CXTPPrintPageHeaderFooter Destructors

CXTPPrintPageHeaderFooter Class, Legend, Public Methods
CXTPPrintPageHeaderFooter Destructors
Class

CXTPPrintPageHeaderFooter Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPrintPageHeaderFooter | Default object destructor.


CXTPPrintPageHeaderFooter::~CXTPPrintPageHeaderFooter Destructor

CXTPPrintPageHeaderFooter Destructors, CXTPPrintPageHeaderFooter Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPrintPageHeaderFooter::~CXTPPrintPageHeaderFooter Destructor

Default object destructor.

virtual ~CXTPPrintPageHeaderFooter();
See Also

CXTPPrintPageHeaderFooter

Group

CXTPPrintPageHeaderFooter Destructors


CXTPPropExchange Class

XTPPropExchange.h, Classes, Legend, Members, Topics, CXTPPropExchange Data Members, CXTPPropExchange Methods, CXTPPropExchange Constructors, CXTPPropExchange Destructors, CXTPPropExchange Constructors, CXTPPropExchange Data Members, CXTPPropExchange Destructors, Example, CXTPPropExchange Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange Class

CXTPPropExchange is standalone pure class. The CXTPPropExchange class allows you to save a complex network of objects in a permanent binary or text form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

You can use one of derived classes:

  • CXTPPropExchangeArchive to serialize to archive,
  • CXTPPropExchangeRegistry to serialize to registry key,
  • CXTPPropExchangeXMLNode to serialize to XML node.
Class Hierarchy

class CXTPPropExchange;
File

XTPPropExchange.h

Example
CXTPPropExchangeXMLNode px(TRUE, 0, _T("Settings"));
if (px.LoadFromFile(m_strIniFileName))
{
    m_wndTaskPanel.GetGroups()->DoPropExchange(&px);
}
Group

Classes

Legend
Data Member
protected
Method
virtual
abstract
CXTPPropExchange Constructors
CXTPPropExchange Constructors | Description
CXTPPropExchange | Constructs a CXTPPropExchange object.
CXTPPropExchange Data Members
CXTPPropExchange Data Members | Description
m_bChildSection | TRUE if section is child
m_bEmptySection | TRUE if EmptySection method was called.
m_bInitialized | TRUE if section was initialized.
m_bLoading | TRUE if properties are being loaded to the class.
m_bUseDefaultOnLoad | TRUE if default values must be used in load process.
m_bUseDefaultOnSave | TRUE if default values must be used in save process.
m_dwData | User defined 32-bit value.
m_lcidDateTime | User regional language
m_nSchema | Schema of object.
m_pOwner | User defined Owner value.
CXTPPropExchange Destructors
CXTPPropExchange Destructors | Description
~CXTPPropExchange | Destroys a CXTPPropExchange object, handles cleanup and de- allocation.
CXTPPropExchange Methods
CXTPPropExchange Methods | Description
EmptySection | Call this method to free section information before storing
ExchangeBlobProp | This method serializes a property that stores binary large object (BLOB) data.
ExchangeLocale | Call this function to serialize or initialize the state of a user locale
ExchangeObjectInstance | Exchanges a class instance.
ExchangeProp | Exchanges a property between a storage and the class.
ExchangeRuntimeClass | Exchanges a CRuntimeClass between a storage and the class.
ExchangeSchema | Call this function to serialize or initialize the state of a class's version information
GetArchive | This method create new Archive to serialize.
GetEnumerator | Call this method to enumerate child sections.
GetSchema | Call this function from the DoPropExchange function to determine the version of the object that is currently being de-serialized
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
InitSection | This methods is called to copy internal data from root section.
IsAllowBlobValues | Call this method to determine if storage allows exchange plain blob values.
IsAllowDefaultValues | Call this method to determine if storage supported default values.
IsLoading | This method determines whether properties are being loaded to the class or stored from it.
IsRootSection | Determines if CXTPPropExchange is used as root section
IsStoring | This method determines whether properties are being loaded to the class or stored from it.
OnBeforeExchange | This method is called before exchange properties.
Read | Reads a specified number of bytes.
ReadCount | Use this member function to read DWORD number from storage
ReleaseArchive | This method releases CArchive pointer.
UseDefaultOnLoad | Call this method to use default values specified in PX_* functions while load process.
UseDefaultOnSave | Call this method to use default values specified in PX_* functions while save process.
Write | Writes a specified number of bytes.
WriteCount | Use this member function to Write DWORD number to storage


CXTPPropExchange Data Members

CXTPPropExchange Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange Data Members
Class

CXTPPropExchange Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bChildSection | TRUE if section is child
m_bEmptySection | TRUE if EmptySection method was called.
m_bInitialized | TRUE if section was initialized.
m_bLoading | TRUE if properties are being loaded to the class.
m_bUseDefaultOnLoad | TRUE if default values must be used in load process.
m_bUseDefaultOnSave | TRUE if default values must be used in save process.
m_nSchema | Schema of object.
Public Data Members
Public Data Member | Description
m_dwData | User defined 32-bit value.
m_lcidDateTime | User regional language
m_pOwner | User defined Owner value.


CXTPPropExchange::m_bChildSection Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_bChildSection Data Member

TRUE if section is child

BOOL m_bChildSection;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_bEmptySection Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_bEmptySection Data Member

TRUE if EmptySection method was called.

BOOL m_bEmptySection;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_bInitialized Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_bInitialized Data Member

TRUE if section was initialized.

BOOL m_bInitialized;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_bLoading Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_bLoading Data Member

TRUE if properties are being loaded to the class.

BOOL m_bLoading;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_bUseDefaultOnLoad Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_bUseDefaultOnLoad Data Member

TRUE if default values must be used in load process.

BOOL m_bUseDefaultOnLoad;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_bUseDefaultOnSave Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_bUseDefaultOnSave Data Member

TRUE if default values must be used in save process.

BOOL m_bUseDefaultOnSave;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_dwData Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_dwData Data Member

User defined 32-bit value.

DWORD_PTR m_dwData;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_lcidDateTime Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_lcidDateTime Data Member

User regional language

LCID m_lcidDateTime;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_nSchema Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_nSchema Data Member

Schema of object.

UINT m_nSchema;
Group

CXTPPropExchange Data Members


CXTPPropExchange::m_pOwner Data Member

CXTPPropExchange Data Members, CXTPPropExchange Class
CXTPPropExchange::m_pOwner Data Member

User defined Owner value.

CObject* m_pOwner;
Group

CXTPPropExchange Data Members


CXTPPropExchange Methods

CXTPPropExchange Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange Methods
Class

CXTPPropExchange Class

Legend
Method
virtual
abstract
protected
Protected Methods
Protected Methods
Protected Method | Description
InitSection | This methods is called to copy internal data from root section.
Public Methods
Public Methods
Public Method | Description
EmptySection | Call this method to free section information before storing
ExchangeBlobProp | This method serializes a property that stores binary large object (BLOB) data.
ExchangeLocale | Call this function to serialize or initialize the state of a user locale
ExchangeObjectInstance | Exchanges a class instance.
ExchangeProp | Exchanges a property between a storage and the class.
ExchangeRuntimeClass | Exchanges a CRuntimeClass between a storage and the class.
ExchangeSchema | Call this function to serialize or initialize the state of a class's version information
GetArchive | This method create new Archive to serialize.
GetEnumerator | Call this method to enumerate child sections.
GetSchema | Call this function from the DoPropExchange function to determine the version of the object that is currently being de-serialized
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
IsAllowBlobValues | Call this method to determine if storage allows exchange plain blob values.
IsAllowDefaultValues | Call this method to determine if storage supported default values.
IsLoading | This method determines whether properties are being loaded to the class or stored from it.
IsRootSection | Determines if CXTPPropExchange is used as root section
IsStoring | This method determines whether properties are being loaded to the class or stored from it.
OnBeforeExchange | This method is called before exchange properties.
Read | Reads a specified number of bytes.
ReadCount | Use this member function to read DWORD number from storage
ReleaseArchive | This method releases CArchive pointer.
UseDefaultOnLoad | Call this method to use default values specified in PX_* functions while load process.
UseDefaultOnSave | Call this method to use default values specified in PX_* functions while save process.
Write | Writes a specified number of bytes.
WriteCount | Use this member function to Write DWORD number to storage


CXTPPropExchange::EmptySection Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::EmptySection Method

Call this method to free section information before storing

virtual void EmptySection();
Group

CXTPPropExchange Methods


CXTPPropExchange::ExchangeBlobProp Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::ExchangeBlobProp Method

This method serializes a property that stores binary large object (BLOB) data.

virtual BOOL ExchangeBlobProp(
    LPCTSTR pszPropName,
    BYTE*& pData,
    DWORD& nBytes
);
Parameters

pszPropName
The name of the property being exchanged.
pData
A pointer to a user-supplied buffer that contains the data to be serialized
nBytes
An integer that specifies the number of bytes to be read or written.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

CXTPPropExchange Methods


CXTPPropExchange::ExchangeLocale Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::ExchangeLocale Method

Call this function to serialize or initialize the state of a user locale

void ExchangeLocale();
Group

CXTPPropExchange Methods


CXTPPropExchange::ExchangeObjectInstance Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::ExchangeObjectInstance Method

Exchanges a class instance.

virtual BOOL ExchangeObjectInstance(
    CObject*& pObject,
    CRuntimeClass* pObjectRuntime
);
Parameters

pObject
Object being exchanged.
pObjectRuntime
Default RUntime class of object

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

CXTPPropExchange Methods


CXTPPropExchange::ExchangeProp Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::ExchangeProp Method

Exchanges a property between a storage and the class.

virtual BOOL ExchangeProp(
    LPCTSTR pszPropName,
    VARTYPE vtProp,
    void* pvProp,
    const void* pvDefault = NULL
) = 0;
Parameters

pszPropName
The name of the property being exchanged.
vtProp
A symbol specifying the type of the property being exchanged.
pvProp
A pointer to the property's value.
pvDefault
Pointer to a default value for the property.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Remarks

Possible values of properties are:

Symbol | Property Type
VT_I2 | short
VT_I4 | long
VT_BOOL | BOOL
VT_BSTR | CString
VT_CY | CY
VT_R4 | float
VT_R8 | double
Group

CXTPPropExchange Methods


CXTPPropExchange::ExchangeRuntimeClass Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::ExchangeRuntimeClass Method

Exchanges a CRuntimeClass between a storage and the class.

virtual BOOL ExchangeRuntimeClass(
    LPCTSTR pszPropName,
    CRuntimeClass*& pClass,
    CRuntimeClass* pDefaultClass
);
Parameters

pszPropName
The name of the property being exchanged.
pClass
CRuntimeClass class pointer.
pDefaultClass
Pointer to a default runtime class for the property.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

CXTPPropExchange Methods


CXTPPropExchange::ExchangeSchema Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::ExchangeSchema Method

Call this function to serialize or initialize the state of a class's version information

void ExchangeSchema();
Group

CXTPPropExchange Methods


CXTPPropExchange::GetArchive Method

CXTPPropExchange Methods, CXTPPropExchange Class, See Also
CXTPPropExchange::GetArchive Method

This method create new Archive to serialize.

virtual CArchive* GetArchive(
    LPCTSTR pszPropName
);
Parameters

pszPropName
The name of the property being exchanged.

Returns

CArchive pointer. You must call ReleaseArchive to free memory.

See Also

ReleaseArchive

Group

CXTPPropExchange Methods


CXTPPropExchange::GetEnumerator Method

CXTPPropExchange Methods, CXTPPropExchange Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::GetEnumerator Method

Call this method to enumerate child sections.

virtual CXTPPropExchangeEnumerator* GetEnumerator(
    LPCTSTR lpszSection
);
Parameters

lpszSection
child section name.

Returns

Returns an enumerator for child sections.

See Also

CXTPPropExchangeEnumerator

Example
extern CXTPPropExchange* pPX;

CXTPPropExchangeEnumeratorPtr pEnumerator(pPX->GetEnumerator(_T("Icon")));
POSITION posEnum = pEnumerator->GetPosition();

while (posEnum)
{
    CXTPPropExchangeSection secIcon(pEnumerator->GetNext(posEnum));
}
Group

CXTPPropExchange Methods


CXTPPropExchange::GetSchema Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::GetSchema Method

Call this function from the DoPropExchange function to determine the version of the object that is currently being de-serialized

UINT GetSchema() const;
Returns

During de-serialization, the version of the object being read.

Body Source
UINT CXTPPropExchange::GetSchema() const {
    return m_nSchema;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::GetSection Method

CXTPPropExchange Methods, CXTPPropExchange Class, Example
CXTPPropExchange::GetSection Method

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

virtual CXTPPropExchange* GetSection(
    LPCTSTR lpszSection
) = 0;
Parameters

lpszSection
The name of the section.

Returns

CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example
CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);
Group

CXTPPropExchange Methods


CXTPPropExchange::InitSection Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::InitSection Method

This methods is called to copy internal data from root section.

void InitSection(
    CXTPPropExchange* pRootSection
);
Parameters

pRootSection
Parent section

Group

CXTPPropExchange Methods


CXTPPropExchange::IsAllowBlobValues Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::IsAllowBlobValues Method

Call this method to determine if storage allows exchange plain blob values.

virtual BOOL IsAllowBlobValues() const;
Returns

TRUE if storage allows exchange plain blob values.

Body Source
BOOL CXTPPropExchange::IsAllowBlobValues() const {
    return FALSE;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::IsAllowDefaultValues Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::IsAllowDefaultValues Method

Call this method to determine if storage supported default values.

virtual BOOL IsAllowDefaultValues() const;
Returns

TRUE if storage allows default values

Body Source
BOOL CXTPPropExchange::IsAllowDefaultValues() const {
    return TRUE;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::IsLoading Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::IsLoading Method

This method determines whether properties are being loaded to the class or stored from it.

BOOL IsLoading() const;
Returns

Nonzero if properties are being loaded; otherwise, it is zero.

Body Source
BOOL CXTPPropExchange::IsLoading() const {
    return m_bLoading;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::IsRootSection Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::IsRootSection Method

Determines if CXTPPropExchange is used as root section

BOOL IsRootSection() const;
Returns

TRUE if CXTPPropExchange object it root section.

Remarks

Used only in CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry classes

See Also

GetSection

Body Source
BOOL CXTPPropExchange::IsRootSection() const {
    return !m_bChildSection;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::IsStoring Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::IsStoring Method

This method determines whether properties are being loaded to the class or stored from it.

BOOL IsStoring() const;
Returns

Nonzero if the properties are currently being used for storing; otherwise 0.

Body Source
BOOL CXTPPropExchange::IsStoring() const {
    return !m_bLoading;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::OnBeforeExchange Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::OnBeforeExchange Method

This method is called before exchange properties.

virtual BOOL OnBeforeExchange();
Returns

TRUE if storage ready to exchange properties.

Body Source
BOOL CXTPPropExchange::OnBeforeExchange() {
    m_bInitialized = TRUE;
    return TRUE;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::Read Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::Read Method

Reads a specified number of bytes.

virtual UINT Read(
    LPCTSTR pszPropName,
    void* lpBuf,
    UINT nCount
);
Parameters

pszPropName
The name of the property being exchanged.
lpBuf
A pointer to a user-supplied buffer that is to receive the data
nCount
An unsigned integer specifying the number of bytes to be read from the archive.

Returns

An unsigned integer containing the number of bytes actually read.

Group

CXTPPropExchange Methods


CXTPPropExchange::ReadCount Method

CXTPPropExchange Methods, CXTPPropExchange Class, See Also
CXTPPropExchange::ReadCount Method

Use this member function to read DWORD number from storage

virtual DWORD ReadCount();
Returns

DWORD number

See Also

WriteCount

Group

CXTPPropExchange Methods


CXTPPropExchange::ReleaseArchive Method

CXTPPropExchange Methods, CXTPPropExchange Class, See Also
CXTPPropExchange::ReleaseArchive Method

This method releases CArchive pointer.

virtual void ReleaseArchive(
    LPCTSTR pszPropName,
    CArchive* pArchive
);
Parameters

pszPropName
The name of the property being exchanged.
pArchive
Archive pointer was previously returned by GetArchive member.

See Also

GetArchive

Group

CXTPPropExchange Methods


CXTPPropExchange::UseDefaultOnLoad Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::UseDefaultOnLoad Method

Call this method to use default values specified in PX_* functions while load process.

void UseDefaultOnLoad(
    BOOL bUseDefaultOnLoad = TRUE
);
Parameters

bUseDefaultOnLoad
TRUE to use default value; FALSE to ignore it.

See Also

UseDefaultOnSave, PX_String, PX_Int, PX_Bool

Body Source
void CXTPPropExchange::UseDefaultOnLoad(BOOL bUseDefaultOnLoad) {
    m_bUseDefaultOnLoad = bUseDefaultOnLoad;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::UseDefaultOnSave Method

CXTPPropExchange Methods, CXTPPropExchange Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchange::UseDefaultOnSave Method

Call this method to use default values specified in PX_* functions while save process.

void UseDefaultOnSave(
    BOOL bUseDefaultOnSave = TRUE
);
Parameters

bUseDefaultOnSave
TRUE to use default value; FALSE to ignore it.

See Also

UseDefaultOnLoad, PX_String, PX_Int, PX_Bool

Body Source
void CXTPPropExchange::UseDefaultOnSave(BOOL bUseDefaultOnSave) {
    m_bUseDefaultOnSave = bUseDefaultOnSave;
}
Group

CXTPPropExchange Methods


CXTPPropExchange::Write Method

CXTPPropExchange Methods, CXTPPropExchange Class
CXTPPropExchange::Write Method

Writes a specified number of bytes.

virtual void Write(
    LPCTSTR pszPropName,
    const void* lpBuf,
    UINT nCount
);
Parameters

pszPropName
The name of the property being exchanged.
lpBuf
A pointer to a user-supplied buffer that contains the data to be written.
nCount
An integer that specifies the number of bytes to be written.

Group

CXTPPropExchange Methods


CXTPPropExchange::WriteCount Method

CXTPPropExchange Methods, CXTPPropExchange Class, See Also
CXTPPropExchange::WriteCount Method

Use this member function to Write DWORD number to storage

virtual void WriteCount(
    DWORD dwCount
);
Parameters

dwCount
DWORD number

See Also

ReadCount

Group

CXTPPropExchange Methods


CXTPPropExchange Constructors

CXTPPropExchange Class, Legend, Public Methods
CXTPPropExchange Constructors
Class

CXTPPropExchange Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchange | Constructs a CXTPPropExchange object.


CXTPPropExchange::CXTPPropExchange Constructor

CXTPPropExchange Constructors, CXTPPropExchange Class
CXTPPropExchange::CXTPPropExchange Constructor

Constructs a CXTPPropExchange object.

CXTPPropExchange();
Group

CXTPPropExchange Constructors


CXTPPropExchange Destructors

CXTPPropExchange Class, Legend, Public Methods
CXTPPropExchange Destructors
Class

CXTPPropExchange Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropExchange | Destroys a CXTPPropExchange object, handles cleanup and de- allocation.


CXTPPropExchange::~CXTPPropExchange Destructor

CXTPPropExchange Destructors, CXTPPropExchange Class
CXTPPropExchange::~CXTPPropExchange Destructor

Destroys a CXTPPropExchange object, handles cleanup and de- allocation.

virtual ~CXTPPropExchange();
Group

CXTPPropExchange Destructors


CXTPPropExchangeArchive Class

XTPPropExchange.h, Classes, Legend, Members, Topics, CXTPPropExchangeArchive Data Members, CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Constructors, CXTPPropExchangeArchive Constructors, CXTPPropExchangeArchive Data Members, Example, CXTPPropExchangeArchive Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive Class

CXTPPropExchangeArchive is CXTPPropExchange derived class. The CXTPPropExchangeArchive class allows you to save a complex network of objects in a permanent binary form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

Class Hierarchy

class CXTPPropExchangeArchive : public CXTPPropExchange;
File

XTPPropExchange.h

Example
CFile myFile("myfile", CFile::modeCreate | CFile::modeWrite);

// Create a storing archive.
CArchive arStore(&myFile, CArchive::store);
CXTPPropExchangeArchive px(arStore);
PX_String(&px, _T("Caption"), m_strCaption);
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropExchangeArchive Constructors
CXTPPropExchangeArchive Constructors | Description
CXTPPropExchangeArchive | Constructs a CXTPPropExchangeArchive object.
CXTPPropExchangeArchive Data Members
CXTPPropExchangeArchive Data Members | Description
m_ar | Contains the underlying CArchive for this CXTPPropExchangeArchive object.
CXTPPropExchangeArchive Methods
CXTPPropExchangeArchive Methods | Description
ExchangeBlobProp | This method serializes a property that stores binary large object (BLOB) data.
ExchangeObjectInstance | Exchanges a class instance.
ExchangeProp | Exchanges a property between a storage medium and the control.
ExchangeRuntimeClass | Exchanges a CRuntimeClass between a storage and the class.
GetArchive | This method create new Archive to serialize.
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
IsAllowBlobValues | Call this method to determine if storage allows exchange plain blob values.
IsAllowDefaultValues | Call this method to determine if storage supported default values.
Read | Reads a specified number of bytes.
ReadCount | Use this member function to read DWORD number from storage
ReleaseArchive | This method releases CArchive pointer.
Write | Writes a specified number of bytes.
WriteCount | Use this member function to write DWORD number to storage


CXTPPropExchangeArchive Data Members

CXTPPropExchangeArchive Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive Data Members
Class

CXTPPropExchangeArchive Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_ar | Contains the underlying CArchive for this CXTPPropExchangeArchive object.


CXTPPropExchangeArchive::m_ar Data Member

CXTPPropExchangeArchive Data Members, CXTPPropExchangeArchive Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::m_ar Data Member

Contains the underlying CArchive for this CXTPPropExchangeArchive object.

CSelfArchive& m_ar;
Group

CXTPPropExchangeArchive Data Members


CXTPPropExchangeArchive Methods

CXTPPropExchangeArchive Class, Legend, Public Methods
CXTPPropExchangeArchive Methods
Class

CXTPPropExchangeArchive Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
ExchangeBlobProp | This method serializes a property that stores binary large object (BLOB) data.
ExchangeObjectInstance | Exchanges a class instance.
ExchangeProp | Exchanges a property between a storage medium and the control.
ExchangeRuntimeClass | Exchanges a CRuntimeClass between a storage and the class.
GetArchive | This method create new Archive to serialize.
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
IsAllowBlobValues | Call this method to determine if storage allows exchange plain blob values.
IsAllowDefaultValues | Call this method to determine if storage supported default values.
Read | Reads a specified number of bytes.
ReadCount | Use this member function to read DWORD number from storage
ReleaseArchive | This method releases CArchive pointer.
Write | Writes a specified number of bytes.
WriteCount | Use this member function to write DWORD number to storage


CXTPPropExchangeArchive::ExchangeBlobProp Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::ExchangeBlobProp Method

This method serializes a property that stores binary large object (BLOB) data.

virtual BOOL ExchangeBlobProp(
    LPCTSTR pszPropName,
    BYTE*& pData,
    DWORD& nBytes
);
Parameters

pszPropName
The name of the property being exchanged.
pData
A pointer to a user-supplied buffer that contains the data to be serialized
nBytes
An integer that specifies the number of bytes to be read or written.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::ExchangeObjectInstance Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::ExchangeObjectInstance Method

Exchanges a class instance.

virtual BOOL ExchangeObjectInstance(
    CObject*& pObject,
    CRuntimeClass* pObjectRuntime
);
Parameters

pObject
Object being exchanged.
pObjectRuntime
Default RUntime class of object

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::ExchangeProp Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::ExchangeProp Method

Exchanges a property between a storage medium and the control.

virtual BOOL ExchangeProp(
    LPCTSTR pszPropName,
    VARTYPE vtProp,
    void* pvProp,
    const void* pvDefault = NULL
);
Parameters

pszPropName
The name of the property being exchanged.
vtProp
A symbol specifying the type of the property being exchanged.
pvProp
A pointer to the property's value.
pvDefault
Pointer to a default value for the property.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Remarks

Possible values of properties are:

Symbol | Property Type
VT_I2 | short
VT_I4 | long
VT_BOOL | BOOL
VT_BSTR | CString
VT_CY | CY
VT_R4 | float
VT_R8 | double
Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::ExchangeRuntimeClass Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::ExchangeRuntimeClass Method

Exchanges a CRuntimeClass between a storage and the class.

virtual BOOL ExchangeRuntimeClass(
    LPCTSTR pszPropName,
    CRuntimeClass*& pClass,
    CRuntimeClass* pDefaultClass
);
Parameters

pszPropName
The name of the property being exchanged.
pClass
CRuntimeClass class pointer.
pDefaultClass
Pointer to a default runtime class for the property.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::GetArchive Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::GetArchive Method

This method create new Archive to serialize.

virtual CArchive* GetArchive(
    LPCTSTR pszPropName
);
Parameters

pszPropName
The name of the property being exchanged.

Returns

CArchive pointer. You must call ReleaseArchive to free memory.

See Also

ReleaseArchive

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::GetSection Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::GetSection Method

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

CXTPPropExchange* GetSection(
    LPCTSTR lpszSection
);
Parameters

lpszSection
The name of the section.

Returns

CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example
CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);
Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::IsAllowBlobValues Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::IsAllowBlobValues Method

Call this method to determine if storage allows exchange plain blob values.

virtual BOOL IsAllowBlobValues() const;
Returns

TRUE if storage allows exchange plain blob values.

Body Source
BOOL CXTPPropExchangeArchive::IsAllowBlobValues() const {
    return TRUE;
}
Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::IsAllowDefaultValues Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::IsAllowDefaultValues Method

Call this method to determine if storage supported default values.

virtual BOOL IsAllowDefaultValues() const;
Returns

TRUE if storage allows default values

Body Source
BOOL CXTPPropExchangeArchive::IsAllowDefaultValues() const {
    return FALSE;
}
Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::Read Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::Read Method

Reads a specified number of bytes.

virtual UINT Read(
    LPCTSTR pszPropName,
    void* lpBuf,
    UINT nCount
);
Parameters

pszPropName
The name of the property being exchanged.
lpBuf
A pointer to a user-supplied buffer that is to receive the data
nCount
An unsigned integer specifying the number of bytes to be read from the archive.

Returns

An unsigned integer containing the number of bytes actually read.

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::ReadCount Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::ReadCount Method

Use this member function to read DWORD number from storage

virtual DWORD ReadCount();
Returns

DWORD number

See Also

WriteCount

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::ReleaseArchive Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::ReleaseArchive Method

This method releases CArchive pointer.

virtual void ReleaseArchive(
    LPCTSTR pszPropName,
    CArchive* pArchive
);
Parameters

pszPropName
The name of the property being exchanged.
pArchive
Archive pointer was previously returned by GetArchive member.

See Also

GetArchive

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::Write Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::Write Method

Writes a specified number of bytes.

virtual void Write(
    LPCTSTR pszPropName,
    const void* lpBuf,
    UINT nCount
);
Parameters

pszPropName
The name of the property being exchanged.
lpBuf
A pointer to a user-supplied buffer that contains the data to be written.
nCount
An integer that specifies the number of bytes to be written.

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive::WriteCount Method

CXTPPropExchangeArchive Methods, CXTPPropExchangeArchive Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::WriteCount Method

Use this member function to write DWORD number to storage

virtual void WriteCount(
    DWORD dwCount
);
Parameters

dwCount
DWORD number

See Also

ReadCount

Group

CXTPPropExchangeArchive Methods


CXTPPropExchangeArchive Constructors

CXTPPropExchangeArchive Class, Legend, Public Methods
CXTPPropExchangeArchive Constructors
Class

CXTPPropExchangeArchive Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeArchive | Constructs a CXTPPropExchangeArchive object.


CXTPPropExchangeArchive::CXTPPropExchangeArchive Constructor

CXTPPropExchangeArchive Constructors, CXTPPropExchangeArchive Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeArchive::CXTPPropExchangeArchive Constructor

Constructs a CXTPPropExchangeArchive object.

CXTPPropExchangeArchive(
    CArchive& ar
);
Parameters

ar
A reference to the CArchive object that is the ultimate source or destination of the persistent data.

Group

CXTPPropExchangeArchive Constructors


CXTPPropExchangeEnumerator Class

XTPPropExchange.h, Classes, Legend, Members, Topics, CXTPPropExchangeEnumerator Data Members, CXTPPropExchangeEnumerator Methods, CXTPPropExchangeEnumerator Constructors, CXTPPropExchangeEnumerator Destructors, CXTPPropExchangeEnumerator Constructors, CXTPPropExchangeEnumerator Data Members, CXTPPropExchangeEnumerator Destructors, Example, CXTPPropExchangeEnumerator Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator Class

CXTPPropExchangeEnumerator is standalone class. It used by CXTPPropExchange to enumerate child sections.

Class Hierarchy

class CXTPPropExchangeEnumerator;
File

XTPPropExchange.h

See Also

CXTPPropExchange, CXTPPropExchange::GetEnumerator

Example
extern CXTPPropExchange* pPX;

CXTPPropExchangeEnumeratorPtr pEnumerator(pPX->GetEnumerator(_T("Icon")));
POSITION posEnum = pEnumerator->GetPosition();

while (posEnum)
{
    CXTPPropExchangeSection secIcon(pEnumerator->GetNext(posEnum));
}
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropExchangeEnumerator Constructors
CXTPPropExchangeEnumerator Constructors | Description
CXTPPropExchangeEnumerator | Constructs a CXTPPropExchangeEnumerator object.
CXTPPropExchangeEnumerator Data Members
CXTPPropExchangeEnumerator Data Members | Description
m_nCount | Count of items to load.
m_pContainer | Parent section of enumerator
m_strSectionName | Enumerator section name
CXTPPropExchangeEnumerator Destructors
CXTPPropExchangeEnumerator Destructors | Description
~CXTPPropExchangeEnumerator | Destroys a CXTPPropExchangeEnumerator object, handles cleanup and de- allocation.
CXTPPropExchangeEnumerator Methods
CXTPPropExchangeEnumerator Methods | Description
GetNext | Call this method to get next enumerable section to load.
GetPosition | Call this method to init enumerable section


CXTPPropExchangeEnumerator Data Members

CXTPPropExchangeEnumerator Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator Data Members
Class

CXTPPropExchangeEnumerator Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nCount | Count of items to load.
m_pContainer | Parent section of enumerator
m_strSectionName | Enumerator section name


CXTPPropExchangeEnumerator::m_nCount Data Member

CXTPPropExchangeEnumerator Data Members, CXTPPropExchangeEnumerator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator::m_nCount Data Member

Count of items to load.

DWORD m_nCount;
Group

CXTPPropExchangeEnumerator Data Members


CXTPPropExchangeEnumerator::m_pContainer Data Member

CXTPPropExchangeEnumerator Data Members, CXTPPropExchangeEnumerator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator::m_pContainer Data Member

Parent section of enumerator

CXTPPropExchange* m_pContainer;
Group

CXTPPropExchangeEnumerator Data Members


CXTPPropExchangeEnumerator::m_strSectionName Data Member

CXTPPropExchangeEnumerator Data Members, CXTPPropExchangeEnumerator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator::m_strSectionName Data Member

Enumerator section name

CString m_strSectionName;
Group

CXTPPropExchangeEnumerator Data Members


CXTPPropExchangeEnumerator Methods

CXTPPropExchangeEnumerator Class, Legend, Public Methods
CXTPPropExchangeEnumerator Methods
Class

CXTPPropExchangeEnumerator Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetNext | Call this method to get next enumerable section to load.
GetPosition | Call this method to init enumerable section


CXTPPropExchangeEnumerator::GetNext Method

CXTPPropExchangeEnumerator Methods, CXTPPropExchangeEnumerator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator::GetNext Method

Call this method to get next enumerable section to load.

virtual CXTPPropExchange* GetNext(
    POSITION& pos
);
Parameters

pos
A reference to a POSITION value returned by a previous GetNext, GetPosition, or other member function call.

Group

CXTPPropExchangeEnumerator Methods


CXTPPropExchangeEnumerator::GetPosition Method

CXTPPropExchangeEnumerator Methods, CXTPPropExchangeEnumerator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator::GetPosition Method

Call this method to init enumerable section

virtual POSITION GetPosition(
    DWORD dwCount = 0,
    BOOL bCompactMode = TRUE
);
Parameters

dwCount
Count of items to be stored.
bCompactMode
TRUE to use "compact mode" of XML nodes.

Returns

A POSITION value that can be used for iteration; NULL if the section is empty.

Group

CXTPPropExchangeEnumerator Methods


CXTPPropExchangeEnumerator Constructors

CXTPPropExchangeEnumerator Class, Legend, Public Methods
CXTPPropExchangeEnumerator Constructors
Class

CXTPPropExchangeEnumerator Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeEnumerator | Constructs a CXTPPropExchangeEnumerator object.


CXTPPropExchangeEnumerator::CXTPPropExchangeEnumerator Constructor

CXTPPropExchangeEnumerator Constructors, CXTPPropExchangeEnumerator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator::CXTPPropExchangeEnumerator Constructor

Constructs a CXTPPropExchangeEnumerator object.

CXTPPropExchangeEnumerator(
    CXTPPropExchange* pContainer,
    LPCTSTR lpszSection
);
Parameters

pContainer
Parent section of enumerator
lpszSection
Enumerator section name

Group

CXTPPropExchangeEnumerator Constructors


CXTPPropExchangeEnumerator Destructors

CXTPPropExchangeEnumerator Class, Legend, Public Methods
CXTPPropExchangeEnumerator Destructors
Class

CXTPPropExchangeEnumerator Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropExchangeEnumerator | Destroys a CXTPPropExchangeEnumerator object, handles cleanup and de- allocation.


CXTPPropExchangeEnumerator::~CXTPPropExchangeEnumerator Destructor

CXTPPropExchangeEnumerator Destructors, CXTPPropExchangeEnumerator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeEnumerator::~CXTPPropExchangeEnumerator Destructor

Destroys a CXTPPropExchangeEnumerator object, handles cleanup and de- allocation.

virtual ~CXTPPropExchangeEnumerator();
Group

CXTPPropExchangeEnumerator Destructors


CXTPPropExchangeIniFile Class

XTPPropExchange.h, Classes, Legend, Members, Topics, CXTPPropExchangeIniFile Data Members, CXTPPropExchangeIniFile Methods, CXTPPropExchangeIniFile Constructors, CXTPPropExchangeIniFile Destructors, CXTPPropExchangeIniFile Constructors, CXTPPropExchangeIniFile Data Members, CXTPPropExchangeIniFile Destructors, Example, CXTPPropExchangeIniFile Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile Class

CXTPPropExchangeIniFile is CXTPPropExchange derived class. The CXTPPropExchangeIniFile class allows you to save a complex network of objects in a ini file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

Class Hierarchy

class CXTPPropExchangeIniFile : public CXTPPropExchange;
File

XTPPropExchange.h

Example
CXTPPropExchangeIniFile px(TRUE, 0, _T("Settings"));
if (px.LoadFromFile(m_strIniFileName))
{
    m_wndTaskPanel.GetGroups()->DoPropExchange(&px);
}
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropExchangeIniFile Constructors
CXTPPropExchangeIniFile Constructors | Description
CXTPPropExchangeIniFile | Constructs CXTPPropExchangeIniFile a object.
CXTPPropExchangeIniFile Data Members
CXTPPropExchangeIniFile Data Members | Description
m_bTempFile | TRUE if temporary file was created.
m_strFileName | Temporary file name.
m_strSectionName | Section name.
CXTPPropExchangeIniFile Destructors
CXTPPropExchangeIniFile Destructors | Description
~CXTPPropExchangeIniFile | Destroys a CXTPPropExchangeIniFile object, handles cleanup and de- allocation.
CXTPPropExchangeIniFile Methods
CXTPPropExchangeIniFile Methods | Description
AssignFile | Assign ini file to CXTPPropExchangeIniFile class.
EmptySection | Call this method to free section information before storing
ExchangeProp | Exchanges a property between a storage medium and the control.
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
LoadFromFile | Loads the contents of an existing ini file.
OnBeforeExchange | This method is called before exchange properties.
SaveToFile | Saves an ini file to the specified location.


CXTPPropExchangeIniFile Data Members

CXTPPropExchangeIniFile Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile Data Members
Class

CXTPPropExchangeIniFile Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bTempFile | TRUE if temporary file was created.
m_strFileName | Temporary file name.
m_strSectionName | Section name.


CXTPPropExchangeIniFile::m_bTempFile Data Member

CXTPPropExchangeIniFile Data Members, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::m_bTempFile Data Member

TRUE if temporary file was created.

BOOL m_bTempFile;
Group

CXTPPropExchangeIniFile Data Members


CXTPPropExchangeIniFile::m_strFileName Data Member

CXTPPropExchangeIniFile Data Members, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::m_strFileName Data Member

Temporary file name.

CString m_strFileName;
Group

CXTPPropExchangeIniFile Data Members


CXTPPropExchangeIniFile::m_strSectionName Data Member

CXTPPropExchangeIniFile Data Members, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::m_strSectionName Data Member

Section name.

CString m_strSectionName;
Group

CXTPPropExchangeIniFile Data Members


CXTPPropExchangeIniFile Methods

CXTPPropExchangeIniFile Class, Legend, Public Methods
CXTPPropExchangeIniFile Methods
Class

CXTPPropExchangeIniFile Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AssignFile | Assign ini file to CXTPPropExchangeIniFile class.
EmptySection | Call this method to free section information before storing
ExchangeProp | Exchanges a property between a storage medium and the control.
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
LoadFromFile | Loads the contents of an existing ini file.
OnBeforeExchange | This method is called before exchange properties.
SaveToFile | Saves an ini file to the specified location.


CXTPPropExchangeIniFile::AssignFile Method

CXTPPropExchangeIniFile Methods, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::AssignFile Method

Assign ini file to CXTPPropExchangeIniFile class.

void AssignFile(
    LPCTSTR lpszFileName
);
Parameters

lpszFileName
A CString value that contains the name of a file to be loaded/saved

Group

CXTPPropExchangeIniFile Methods


CXTPPropExchangeIniFile::EmptySection Method

CXTPPropExchangeIniFile Methods, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::EmptySection Method

Call this method to free section information before storing

virtual void EmptySection();
Group

CXTPPropExchangeIniFile Methods


CXTPPropExchangeIniFile::ExchangeProp Method

CXTPPropExchangeIniFile Methods, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::ExchangeProp Method

Exchanges a property between a storage medium and the control.

virtual BOOL ExchangeProp(
    LPCTSTR pszPropName,
    VARTYPE vtProp,
    void* pvProp,
    const void* pvDefault = NULL
);
Parameters

pszPropName
The name of the property being exchanged.
vtProp
A symbol specifying the type of the property being exchanged.
pvProp
A pointer to the property's value.
pvDefault
Pointer to a default value for the property.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Remarks

Possible values of properties are:

Symbol | Property Type
VT_I2 | short
VT_I4 | long
VT_BOOL | BOOL
VT_BSTR | CString
VT_CY | CY
VT_R4 | float
VT_R8 | double
Group

CXTPPropExchangeIniFile Methods


CXTPPropExchangeIniFile::GetSection Method

CXTPPropExchangeIniFile Methods, CXTPPropExchangeIniFile Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::GetSection Method

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

virtual CXTPPropExchange* GetSection(
    LPCTSTR lpszSection
);
Parameters

lpszSection
The name of the section.

Returns

CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example
CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);
Group

CXTPPropExchangeIniFile Methods


CXTPPropExchangeIniFile::LoadFromFile Method

CXTPPropExchangeIniFile Methods, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::LoadFromFile Method

Loads the contents of an existing ini file.

BOOL LoadFromFile(
    LPCTSTR lpszFileName
);
Parameters

lpszFileName
A CString value that contains the name of a file to be loaded

Returns

TRUE if successful; otherwise 0.

Group

CXTPPropExchangeIniFile Methods


CXTPPropExchangeIniFile::OnBeforeExchange Method

CXTPPropExchangeIniFile Methods, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::OnBeforeExchange Method

This method is called before exchange properties.

virtual BOOL OnBeforeExchange();
Returns

TRUE if storage ready to exchange properties.

Group

CXTPPropExchangeIniFile Methods


CXTPPropExchangeIniFile::SaveToFile Method

CXTPPropExchangeIniFile Methods, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::SaveToFile Method

Saves an ini file to the specified location.

void SaveToFile(
    LPCTSTR strFileName
);
Parameters

strFileName
Destination file name.

Group

CXTPPropExchangeIniFile Methods


CXTPPropExchangeIniFile Constructors

CXTPPropExchangeIniFile Class, Legend, Public Methods
CXTPPropExchangeIniFile Constructors
Class

CXTPPropExchangeIniFile Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeIniFile | Constructs CXTPPropExchangeIniFile a object.


CXTPPropExchangeIniFile::CXTPPropExchangeIniFile Constructor

CXTPPropExchangeIniFile Constructors, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::CXTPPropExchangeIniFile Constructor

Constructs CXTPPropExchangeIniFile a object.

CXTPPropExchangeIniFile(
    BOOL bLoading,
    LPCTSTR lpszParentSection,
    LPCTSTR lpszSection
);
Parameters

bLoading
A flag that specifies whether objects will be loaded from or stored.
lpszParentSection
Root section. Can be NULL.
lpszSection
Points to a null-terminated string that specifies the section containing the entry.

Group

CXTPPropExchangeIniFile Constructors


CXTPPropExchangeIniFile Destructors

CXTPPropExchangeIniFile Class, Legend, Public Methods
CXTPPropExchangeIniFile Destructors
Class

CXTPPropExchangeIniFile Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropExchangeIniFile | Destroys a CXTPPropExchangeIniFile object, handles cleanup and de- allocation.


CXTPPropExchangeIniFile::~CXTPPropExchangeIniFile Destructor

CXTPPropExchangeIniFile Destructors, CXTPPropExchangeIniFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeIniFile::~CXTPPropExchangeIniFile Destructor

Destroys a CXTPPropExchangeIniFile object, handles cleanup and de- allocation.

~CXTPPropExchangeIniFile();
Group

CXTPPropExchangeIniFile Destructors


CXTPPropExchangeRegistry Class

XTPPropExchange.h, Classes, Legend, Members, Topics, CXTPPropExchangeRegistry Data Members, CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Constructors, CXTPPropExchangeRegistry Destructors, CXTPPropExchangeRegistry Constructors, CXTPPropExchangeRegistry Data Members, CXTPPropExchangeRegistry Destructors, Example, CXTPPropExchangeRegistry Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry Class

CXTPPropExchangeRegistry is CXTPPropExchange derived class. The CXTPPropExchangeRegistry class allows you to save a complex network of objects in a system registry that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

Class Hierarchy

class CXTPPropExchangeRegistry : public CXTPPropExchange;
File

XTPPropExchange.h

Example
HKEY hKey = AfxGetApp()->GetAppRegistryKey();
CXTPPropExchangeRegistry px(FALSE, hKey, szSection);
DoPropExchange(&px);
RegCloseKey(hKey);
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropExchangeRegistry Constructors
CXTPPropExchangeRegistry Constructors | Description
CXTPPropExchangeRegistry | Constructs CXTPPropExchangeRegistry a object.
CXTPPropExchangeRegistry Data Members
CXTPPropExchangeRegistry Data Members | Description
m_bCloseParentKey | TRUE to automatically close parent key
m_hParentKey | Parent registry key
m_hSectionKey | Current registry key
m_strSectionName | Section name
CXTPPropExchangeRegistry Destructors
CXTPPropExchangeRegistry Destructors | Description
~CXTPPropExchangeRegistry | Destroys a CXTPPropExchangeRegistry object, handles cleanup and de- allocation.
CXTPPropExchangeRegistry Methods
CXTPPropExchangeRegistry Methods | Description
EmptySection | Call this method to free section information before storing
ExchangeBlobProp | This method serializes a property that stores binary large object (BLOB) data.
ExchangeProp | Exchanges a property between a storage medium and the control.
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
IsAllowBlobValues | Call this method to determine if storage allows exchange plain blob values.
IsPropertyExists | Call this method to check if property entry exists.
IsSectionExists | Call this method to check if section exists.
OnBeforeExchange | This method is called before exchange properties.


CXTPPropExchangeRegistry Data Members

CXTPPropExchangeRegistry Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry Data Members
Class

CXTPPropExchangeRegistry Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bCloseParentKey | TRUE to automatically close parent key
m_hParentKey | Parent registry key
m_hSectionKey | Current registry key
m_strSectionName | Section name


CXTPPropExchangeRegistry::m_bCloseParentKey Data Member

CXTPPropExchangeRegistry Data Members, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::m_bCloseParentKey Data Member

TRUE to automatically close parent key

BOOL m_bCloseParentKey;
Group

CXTPPropExchangeRegistry Data Members


CXTPPropExchangeRegistry::m_hParentKey Data Member

CXTPPropExchangeRegistry Data Members, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::m_hParentKey Data Member

Parent registry key

HKEY m_hParentKey;
Group

CXTPPropExchangeRegistry Data Members


CXTPPropExchangeRegistry::m_hSectionKey Data Member

CXTPPropExchangeRegistry Data Members, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::m_hSectionKey Data Member

Current registry key

HKEY m_hSectionKey;
Group

CXTPPropExchangeRegistry Data Members


CXTPPropExchangeRegistry::m_strSectionName Data Member

CXTPPropExchangeRegistry Data Members, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::m_strSectionName Data Member

Section name

CString m_strSectionName;
Group

CXTPPropExchangeRegistry Data Members


CXTPPropExchangeRegistry Methods

CXTPPropExchangeRegistry Class, Legend, Public Methods
CXTPPropExchangeRegistry Methods
Class

CXTPPropExchangeRegistry Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
EmptySection | Call this method to free section information before storing
ExchangeBlobProp | This method serializes a property that stores binary large object (BLOB) data.
ExchangeProp | Exchanges a property between a storage medium and the control.
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
IsAllowBlobValues | Call this method to determine if storage allows exchange plain blob values.
IsPropertyExists | Call this method to check if property entry exists.
IsSectionExists | Call this method to check if section exists.
OnBeforeExchange | This method is called before exchange properties.


CXTPPropExchangeRegistry::EmptySection Method

CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::EmptySection Method

Call this method to free section information before storing

virtual void EmptySection();
Group

CXTPPropExchangeRegistry Methods


CXTPPropExchangeRegistry::ExchangeBlobProp Method

CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::ExchangeBlobProp Method

This method serializes a property that stores binary large object (BLOB) data.

virtual BOOL ExchangeBlobProp(
    LPCTSTR pszPropName,
    BYTE*& pData,
    DWORD& nBytes
);
Parameters

pszPropName
The name of the property being exchanged.
pData
A pointer to a user-supplied buffer that contains the data to be serialized
nBytes
An integer that specifies the number of bytes to be read or written.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

CXTPPropExchangeRegistry Methods


CXTPPropExchangeRegistry::ExchangeProp Method

CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::ExchangeProp Method

Exchanges a property between a storage medium and the control.

virtual BOOL ExchangeProp(
    LPCTSTR pszPropName,
    VARTYPE vtProp,
    void* pvProp,
    const void* pvDefault = NULL
);
Parameters

pszPropName
The name of the property being exchanged.
vtProp
A symbol specifying the type of the property being exchanged.
pvProp
A pointer to the property's value.
pvDefault
Pointer to a default value for the property.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Remarks

Possible values of properties are:

Symbol | Property Type
VT_I2 | short
VT_I4 | long
VT_BOOL | BOOL
VT_BSTR | CString
VT_CY | CY
VT_R4 | float
VT_R8 | double
Group

CXTPPropExchangeRegistry Methods


CXTPPropExchangeRegistry::GetSection Method

CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::GetSection Method

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

virtual CXTPPropExchange* GetSection(
    LPCTSTR lpszSection
);
Parameters

lpszSection
The name of the section.

Returns

CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example
CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);
Group

CXTPPropExchangeRegistry Methods


CXTPPropExchangeRegistry::IsAllowBlobValues Method

CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::IsAllowBlobValues Method

Call this method to determine if storage allows exchange plain blob values.

virtual BOOL IsAllowBlobValues() const;
Returns

TRUE if storage allows exchange plain blob values.

Body Source
BOOL CXTPPropExchangeRegistry::IsAllowBlobValues() const {
    return TRUE;
}
Group

CXTPPropExchangeRegistry Methods


CXTPPropExchangeRegistry::IsPropertyExists Method

CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::IsPropertyExists Method

Call this method to check if property entry exists.

BOOL IsPropertyExists(
    LPCTSTR pszPropName
);
Parameters

pszPropName
The name of the property being checked.

Group

CXTPPropExchangeRegistry Methods


CXTPPropExchangeRegistry::IsSectionExists Method

CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::IsSectionExists Method

Call this method to check if section exists.

BOOL IsSectionExists(
    LPCTSTR lpszSection
);
Parameters

lpszSection
The name of the section being checked.

Group

CXTPPropExchangeRegistry Methods


CXTPPropExchangeRegistry::OnBeforeExchange Method

CXTPPropExchangeRegistry Methods, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::OnBeforeExchange Method

This method is called before exchange properties.

virtual BOOL OnBeforeExchange();
Returns

TRUE if storage ready to exchange properties.

Group

CXTPPropExchangeRegistry Methods


CXTPPropExchangeRegistry Constructors

CXTPPropExchangeRegistry Class, Legend, Public Methods
CXTPPropExchangeRegistry Constructors
Class

CXTPPropExchangeRegistry Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeRegistry | Constructs CXTPPropExchangeRegistry a object.


CXTPPropExchangeRegistry::CXTPPropExchangeRegistry Constructor

CXTPPropExchangeRegistry Constructors, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::CXTPPropExchangeRegistry Constructor

Constructs CXTPPropExchangeRegistry a object.

CXTPPropExchangeRegistry(
    BOOL bLoading,
    HKEY hParentKey,
    LPCTSTR lpszSection
);
Parameters

bLoading
A flag that specifies whether objects will be loaded from or stored.
hParentKey
Root HKEY
lpszSection
Points to a null-terminated string that specifies the section containing the entry.

Group

CXTPPropExchangeRegistry Constructors


CXTPPropExchangeRegistry Destructors

CXTPPropExchangeRegistry Class, Legend, Public Methods
CXTPPropExchangeRegistry Destructors
Class

CXTPPropExchangeRegistry Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropExchangeRegistry | Destroys a CXTPPropExchangeRegistry object, handles cleanup and de- allocation.


CXTPPropExchangeRegistry::~CXTPPropExchangeRegistry Destructor

CXTPPropExchangeRegistry Destructors, CXTPPropExchangeRegistry Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeRegistry::~CXTPPropExchangeRegistry Destructor

Destroys a CXTPPropExchangeRegistry object, handles cleanup and de- allocation.

~CXTPPropExchangeRegistry();
Group

CXTPPropExchangeRegistry Destructors


CXTPPropExchangeSection Class

XTPPropExchange.h, Classes, Legend, Members, Topics, CXTPPropExchangeSection Constructors, CXTPPropExchangeSection Destructors, CXTPPropExchangeSection Constructors, CXTPPropExchangeSection Destructors, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeSection Class

CXTPPropExchangeSection is standalone class. It is used to delete memory allocated by CXTPPropExchange::GetSection.

Class Hierarchy

class CXTPPropExchangeSection;
File

XTPPropExchange.h

Example
CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
Group

Classes

Legend
Constructor
CXTPPropExchangeSection Constructors
CXTPPropExchangeSection Constructors | Description
CXTPPropExchangeSection |
CXTPPropExchangeSection Destructors
CXTPPropExchangeSection Destructors | Description
~CXTPPropExchangeSection | Destroys a CXTPPropExchangeSection object, handles cleanup and de- allocation.


CXTPPropExchangeSection Constructors

CXTPPropExchangeSection Class, Legend, Public Methods
CXTPPropExchangeSection Constructors
Class

CXTPPropExchangeSection Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeSection |


CXTPPropExchangeSection Constructor

CXTPPropExchangeSection Constructors
CXTPPropExchangeSection Constructor
Overload List
Constructors
Constructor | Description
CXTPPropExchangeSection::CXTPPropExchangeSection (BOOL, LPCTSTR) | Constructs CXTPPropExchangeSection object and automatically assign m_pPX .
CXTPPropExchangeSection::CXTPPropExchangeSection (CXTPPropExchange*) | Constructs CXTPPropExchangeSection a object.
Group

CXTPPropExchangeSection Constructors


CXTPPropExchangeSection::CXTPPropExchangeSection Constructor (BOOL, LPCTSTR)

CXTPPropExchangeSection Constructor, CXTPPropExchangeSection Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeSection::CXTPPropExchangeSection Constructor (BOOL, LPCTSTR)

Constructs CXTPPropExchangeSection object and automatically assign m_pPX .

CXTPPropExchangeSection(
    BOOL bLoading,
    LPCTSTR lpszSection
);
Parameters

bLoading
TRUE to load
lpszSection
Section of registry

Body Source
CXTPPropExchangeSection(BOOL bLoading, LPCTSTR lpszSection)
{
    if (AfxGetApp()->m_pszRegistryKey)
    {
        m_pPX = new CXTPPropExchangeRegistry(bLoading, 0, lpszSection);
    }
    else
    {
        CXTPPropExchangeIniFile *pPX = new CXTPPropExchangeIniFile(bLoading, 0, lpszSection);
        pPX->AssignFile(AfxGetApp()->m_pszProfileName);
        m_pPX = pPX;
    }
}
Group

CXTPPropExchangeSection Constructor


CXTPPropExchangeSection::CXTPPropExchangeSection Constructor (CXTPPropExchange*)

CXTPPropExchangeSection Constructor, CXTPPropExchangeSection Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeSection::CXTPPropExchangeSection Constructor (CXTPPropExchange*)

Constructs CXTPPropExchangeSection a object.

explicit CXTPPropExchangeSection(
    CXTPPropExchange* pPX
);
Parameters

pPX
pointer to the CXTPPropExchange object that is the ultimate source or destination of the persistent data.

Body Source
explicit CXTPPropExchangeSection(CXTPPropExchange* pPX)
    : m_pPX(pPX) {
}
Group

CXTPPropExchangeSection Constructor


CXTPPropExchangeSection Destructors

CXTPPropExchangeSection Class, Legend, Public Methods
CXTPPropExchangeSection Destructors
Class

CXTPPropExchangeSection Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPPropExchangeSection | Destroys a CXTPPropExchangeSection object, handles cleanup and de- allocation.


CXTPPropExchangeSection::~CXTPPropExchangeSection Destructor

CXTPPropExchangeSection Destructors, CXTPPropExchangeSection Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeSection::~CXTPPropExchangeSection Destructor

Destroys a CXTPPropExchangeSection object, handles cleanup and de- allocation.

~CXTPPropExchangeSection();
Body Source
~CXTPPropExchangeSection() {
    if (m_pPX) {
        m_pPX->InternalRelease();
    }
}
Group

CXTPPropExchangeSection Destructors


CXTPPropExchangeXMLNode Class

XTPPropExchange.h, Classes, Legend, Members, Topics, CXTPPropExchangeXMLNode Data Members, CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Constructors, CXTPPropExchangeXMLNode Constructors, CXTPPropExchangeXMLNode Data Members, Example, CXTPPropExchangeXMLNode Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode Class

CXTPPropExchangeXMLNode is CXTPPropExchange derived class. The CXTPPropExchangeXMLNode class allows you to save a complex network of objects in a XML file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

Class Hierarchy

class CXTPPropExchangeXMLNode : public CXTPPropExchange;
File

XTPPropExchange.h

Example
CXTPPropExchangeXMLNode px(TRUE, 0, _T("Settings"));
if (px.LoadFromFile(m_strIniFileName))
{
    m_wndTaskPanel.GetGroups()->DoPropExchange(&px);
}
Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPPropExchangeXMLNode Constructors
CXTPPropExchangeXMLNode Constructors | Description
CXTPPropExchangeXMLNode | Constructs CXTPPropExchangeXMLNode a object.
CXTPPropExchangeXMLNode Data Members
CXTPPropExchangeXMLNode Data Members | Description
m_bCompactMode | TRUE to use compact mode.
m_strEncoding | XML encoding.
m_strSectionName | Section name
m_xmlDocPtr | XML Document pointer
m_xmlParentNode | XML Parent node pointer
m_xmlSectionNode | XML Section node pointer
CXTPPropExchangeXMLNode Methods
CXTPPropExchangeXMLNode Methods | Description
EmptySection | Call this method to free section information before storing
ExchangeProp | Exchanges a property between a storage medium and the control.
GetEntryNode | Retrieves entry node which the value is to be written.
GetEnumerator | Call this method to enumerate child sections.
GetProfileNode | Retrieves profile node.
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
GetSectionName | Retrieves section name of the XML node.
GetSectionNode | Call this member to get access to dom xml node for current section
GetXML | Retrieves the XML representation of the node and all its descendants.
IsPropertyExists | Call this method to check if property entry exists.
IsSectionExists | Call this method to check if section exists.
IsXMLSupported | Determines if XML installed in System (IE 4.0)
LoadFromFile | Loads the contents of an existing file into a XML.
LoadFromString |
OnBeforeExchange | This method is called before exchange properties.
PutSection | Call this member to append one section to another
SaveToFile | Saves an XML document to the specified location.
SetCompactMode | Call this method to store data in compact mode (To use node attributes instead nodes)
SetEncoding | Call this method to set encoding for XML output
SetLoading | Call this member to change loading flag.


CXTPPropExchangeXMLNode Data Members

CXTPPropExchangeXMLNode Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode Data Members
Class

CXTPPropExchangeXMLNode Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bCompactMode | TRUE to use compact mode.
m_strEncoding | XML encoding.
m_strSectionName | Section name
m_xmlDocPtr | XML Document pointer
m_xmlParentNode | XML Parent node pointer
m_xmlSectionNode | XML Section node pointer


CXTPPropExchangeXMLNode::m_bCompactMode Data Member

CXTPPropExchangeXMLNode Data Members, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::m_bCompactMode Data Member

TRUE to use compact mode.

BOOL m_bCompactMode;
Group

CXTPPropExchangeXMLNode Data Members


CXTPPropExchangeXMLNode::m_strEncoding Data Member

CXTPPropExchangeXMLNode Data Members, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::m_strEncoding Data Member

XML encoding.

CString m_strEncoding;
Group

CXTPPropExchangeXMLNode Data Members


CXTPPropExchangeXMLNode::m_strSectionName Data Member

CXTPPropExchangeXMLNode Data Members, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::m_strSectionName Data Member

Section name

CString m_strSectionName;
Group

CXTPPropExchangeXMLNode Data Members


CXTPPropExchangeXMLNode::m_xmlDocPtr Data Member

CXTPPropExchangeXMLNode Data Members, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::m_xmlDocPtr Data Member

XML Document pointer

CXTPDOMDocumentPtr m_xmlDocPtr;
Group

CXTPPropExchangeXMLNode Data Members


CXTPPropExchangeXMLNode::m_xmlParentNode Data Member

CXTPPropExchangeXMLNode Data Members, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::m_xmlParentNode Data Member

XML Parent node pointer

CXTPDOMNodePtr m_xmlParentNode;
Group

CXTPPropExchangeXMLNode Data Members


CXTPPropExchangeXMLNode::m_xmlSectionNode Data Member

CXTPPropExchangeXMLNode Data Members, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::m_xmlSectionNode Data Member

XML Section node pointer

CXTPDOMNodePtr m_xmlSectionNode;
Group

CXTPPropExchangeXMLNode Data Members


CXTPPropExchangeXMLNode Methods

CXTPPropExchangeXMLNode Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode Methods
Class

CXTPPropExchangeXMLNode Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
GetEntryNode | Retrieves entry node which the value is to be written.
GetProfileNode | Retrieves profile node.
Public Methods
Public Methods
Public Method | Description
EmptySection | Call this method to free section information before storing
ExchangeProp | Exchanges a property between a storage medium and the control.
GetEnumerator | Call this method to enumerate child sections.
GetSection | This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
GetSectionName | Retrieves section name of the XML node.
GetSectionNode | Call this member to get access to dom xml node for current section
GetXML | Retrieves the XML representation of the node and all its descendants.
IsPropertyExists | Call this method to check if property entry exists.
IsSectionExists | Call this method to check if section exists.
IsXMLSupported | Determines if XML installed in System (IE 4.0)
LoadFromFile | Loads the contents of an existing file into a XML.
LoadFromString |
OnBeforeExchange | This method is called before exchange properties.
PutSection | Call this member to append one section to another
SaveToFile | Saves an XML document to the specified location.
SetCompactMode | Call this method to store data in compact mode (To use node attributes instead nodes)
SetEncoding | Call this method to set encoding for XML output
SetLoading | Call this member to change loading flag.


CXTPPropExchangeXMLNode::EmptySection Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::EmptySection Method

Call this method to free section information before storing

virtual void EmptySection();
Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::ExchangeProp Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::ExchangeProp Method

Exchanges a property between a storage medium and the control.

virtual BOOL ExchangeProp(
    LPCTSTR pszPropName,
    VARTYPE vtProp,
    void* pvProp,
    const void* pvDefault = NULL
);
Parameters

pszPropName
The name of the property being exchanged.
vtProp
A symbol specifying the type of the property being exchanged.
pvProp
A pointer to the property's value.
pvDefault
Pointer to a default value for the property.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Remarks

Possible values of properties are:

Symbol | Property Type
VT_I2 | short
VT_I4 | long
VT_BOOL | BOOL
VT_BSTR | CString
VT_CY | CY
VT_R4 | float
VT_R8 | double
Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::GetEntryNode Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::GetEntryNode Method

Retrieves entry node which the value is to be written.

CXTPDOMNodePtr GetEntryNode(
    LPCTSTR lpszEntry,
    BOOL bCreate
);
Parameters

lpszEntry
Points to a null-terminated string that contains the entry into which the value is to be written.
bCreate
TRUE to create if doesn't exist;

Returns

Entry node to be used

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::GetEnumerator Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::GetEnumerator Method

Call this method to enumerate child sections.

virtual CXTPPropExchangeEnumerator* GetEnumerator(
    LPCTSTR lpszSection
);
Parameters

lpszSection
child section name.

Returns

Returns an enumerator for child sections.

See Also

CXTPPropExchangeEnumerator

Example
extern CXTPPropExchange* pPX;

CXTPPropExchangeEnumeratorPtr pEnumerator(pPX->GetEnumerator(_T("Icon")));
POSITION posEnum = pEnumerator->GetPosition();

while (posEnum)
{
    CXTPPropExchangeSection secIcon(pEnumerator->GetNext(posEnum));
}
Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::GetProfileNode Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::GetProfileNode Method

Retrieves profile node.

CXTPDOMNodePtr GetProfileNode(
    LPCTSTR lpszSection
);
Parameters

lpszSection
Section name of profile node

Returns

Profile node.to be used

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::GetSection Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::GetSection Method

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

virtual CXTPPropExchange* GetSection(
    LPCTSTR lpszSection
);
Parameters

lpszSection
The name of the section.

Returns

CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example
CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);
Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::GetSectionName Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::GetSectionName Method

Retrieves section name of the XML node.

CString GetSectionName();
Returns

Name of the XML node.

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::GetSectionNode Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::GetSectionNode Method

Call this member to get access to dom xml node for current section

CXTPDOMNodePtr GetSectionNode() const;
Body Source
CXTPDOMNodePtr GetSectionNode() const {
    return m_xmlSectionNode;
}
Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::GetXML Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::GetXML Method

Retrieves the XML representation of the node and all its descendants.

CString GetXML(
    BOOL bFormatted = FALSE
);
Parameters

bFormatted
TRUE to format XML output

Returns

XML representation of this node and all its descendants.

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::IsPropertyExists Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::IsPropertyExists Method

Call this method to check if property entry exists.

BOOL IsPropertyExists(
    LPCTSTR pszPropName
);
Parameters

pszPropName
The name of the property being checked.

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::IsSectionExists Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::IsSectionExists Method

Call this method to check if section exists.

BOOL IsSectionExists(
    LPCTSTR lpszSection
);
Parameters

lpszSection
The name of the section being checked.

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::IsXMLSupported Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::IsXMLSupported Method

Determines if XML installed in System (IE 4.0)

static BOOL IsXMLSupported();
Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::LoadFromFile Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::LoadFromFile Method

Loads the contents of an existing file into a XML.

BOOL LoadFromFile(
    LPCTSTR lpszFileName
);
Parameters

lpszFileName
A CString value that contains the name of a file to be loaded into the XML

Returns

TRUE if successful; otherwise 0.

Group

CXTPPropExchangeXMLNode Methods


LoadFromString Method

CXTPPropExchangeXMLNode Methods
LoadFromString Method
Overload List
Methods
Method | Description
CXTPPropExchangeXMLNode::LoadFromString (BSTR) | Loads the contents of string to XML.
CXTPPropExchangeXMLNode::LoadFromString (LPCSTR) | Loads the contents of string to XML.
CXTPPropExchangeXMLNode::LoadFromString (LPCWSTR) | Loads the contents of string to XML.
Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::LoadFromString Method (LPCSTR)

LoadFromString Method, CXTPPropExchangeXMLNode Class
CXTPPropExchangeXMLNode::LoadFromString Method (LPCSTR)

Loads the contents of string to XML.

BOOL LoadFromString(
    LPCSTR lpszState
);
BOOL LoadFromString(
    LPCWSTR lpszState
);
BOOL LoadFromString(
    BSTR bstrState
);
Parameters

lpszState
A pointer to a value that contains XML nodes
bstrState
BSTR value that contains XML nodes

Returns

TRUE if successful; otherwise 0.

Group

LoadFromString Method


CXTPPropExchangeXMLNode::OnBeforeExchange Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::OnBeforeExchange Method

This method is called before exchange properties.

virtual BOOL OnBeforeExchange();
Returns

TRUE if storage ready to exchange properties.

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::PutSection Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::PutSection Method

Call this member to append one section to another

BOOL PutSection(
    CXTPPropExchangeXMLNode* pNode
);
Parameters

pNode
Section to be append.

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::SaveToFile Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::SaveToFile Method

Saves an XML document to the specified location.

HRESULT SaveToFile(
    LPCTSTR lpszFileName,
    BOOL bFormatted = TRUE
);
Parameters

lpszFileName
Destination file name.
bFormatted
TRUE to format XML output

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::SetCompactMode Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::SetCompactMode Method

Call this method to store data in compact mode (To use node attributes instead nodes)

void SetCompactMode(
    BOOL bCompactMode
);
Parameters

bCompactMode
TRUE to use compact mode (default)

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::SetEncoding Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::SetEncoding Method

Call this method to set encoding for XML output

void SetEncoding(
    LPCTSTR lpszEncoding
);
Parameters

lpszEncoding
encoding that will be used in XML file

Remarks

Default encoding is UTF-8

Example
px.SetEncoding(_T("windows-1251"));
Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode::SetLoading Method

CXTPPropExchangeXMLNode Methods, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::SetLoading Method

Call this member to change loading flag.

void SetLoading(
    BOOL bLoading
);
Parameters

bLoading
A flag that specifies whether objects will be loaded from or stored.

Group

CXTPPropExchangeXMLNode Methods


CXTPPropExchangeXMLNode Constructors

CXTPPropExchangeXMLNode Class, Legend, Public Methods
CXTPPropExchangeXMLNode Constructors
Class

CXTPPropExchangeXMLNode Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeXMLNode | Constructs CXTPPropExchangeXMLNode a object.


CXTPPropExchangeXMLNode::CXTPPropExchangeXMLNode Constructor

CXTPPropExchangeXMLNode Constructors, CXTPPropExchangeXMLNode Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPPropExchangeXMLNode::CXTPPropExchangeXMLNode Constructor

Constructs CXTPPropExchangeXMLNode a object.

CXTPPropExchangeXMLNode(
    BOOL bLoading,
    CXTPDOMNodePtr xmlParentNode,
    LPCTSTR lpszSection
);
Parameters

bLoading
A flag that specifies whether objects will be loaded from or stored.
xmlParentNode
Parent node element. Can be NULL.
lpszSection
Points to a null-terminated string that specifies the section containing the entry.

Group

CXTPPropExchangeXMLNode Constructors


CXTPResourceManager Class

XTPResourceManager.h, Classes, Legend, Members, Topics, CXTPResourceManager Classes, CXTPResourceManager Data Members, CXTPResourceManager Methods, CXTPResourceManager Constructors, CXTPResourceManager Destructors, CXTPResourceManager Classes, CXTPResourceManager Constructors, CXTPResourceManager Data Members, CXTPResourceManager Destructors, CXTPResourceManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager Class

Standalone class used to managed toolkit resources.

Class Hierarchy

class CXTPResourceManager : public CNoTrackObject;
File

XTPResourceManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPResourceManager Classes
CXTPResourceManager Classes | Description
CManageState | CManageState is used internally by the toolkit to switch module states. Specifically, the class enables the toolkit to read its own .dll resources, and not that of the host application (or .dll). Future versions of the class may handle other such details
CXTPResourceManager Constructors
CXTPResourceManager Constructors | Description
CXTPResourceManager | Constructs a CXTPResourceManager object.
CXTPResourceManager Data Members
CXTPResourceManager Data Members | Description
m_bValid | TRUE if Resource manager is valid.
m_hModXTResource | Handle to toolkit resource.
m_hResourceFile | Resource file handle.
m_managerInstance | Manager instance.
m_pLanguageInfo | Resource language
CXTPResourceManager Destructors
CXTPResourceManager Destructors | Description
~CXTPResourceManager | Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.
CXTPResourceManager Methods
CXTPResourceManager Methods | Description
Close | This method free used resource. Call it in ExitInstance of your application if you use external resource file.
CreateIconFromResource | The CreateIconFromResource function creates a new icon from the specified modules icon resource.
GetResourceHandle | Call this member function to return the library resource handle.
GetResourceLanguage | Call this static method to determine what language has resources
GetResourcesLangID | Get current resource language ID.
LoadBitmap | Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object
LoadCursor | Reads a Windows cursor resource, identified by nID, into an existing cursor object
LoadDialogTemplate | Reads a Windows dialog resource, identified by pszResource
LoadDialogTemplate2 | Reads a Windows dialog template identified by pszResource into the memory.
LoadFailed | This method is called to notify developer that load resources was failed.
LoadHTML | Reads a Windows HTML resource, identified by nIDResource, into an existing CString object.
LoadIcon |
LoadMenu | Reads a Windows menu resource, identified by nID, into an existing CMenu object
LoadString |
LoadToolBar | Call this member function to load the toolbar specified by CToolBar and nIDResource.
SetResourceFile | Call this member to set resource file to be used (dll or xml)
SetResourceHandle | Call this member to set the resource handle for the calling module.
SetResourceManager | Call this method to set application defined Resource manager
ShowMessageBox | Displays a message box on the screen
UpdateResourcesLangID | This method check resource identifier of loaded resources


CXTPResourceManager Classes

Classes, CXTPResourceManager Class
CXTPResourceManager Classes
Classes
Class | Description
CManageState | CManageState is used internally by the toolkit to switch module states. Specifically, the class enables the toolkit to read its own .dll resources, and not that of the host application (or .dll). Future versions of the class may handle other such details
Class

CXTPResourceManager Class


CXTPResourceManager::CManageState Class

XTPResourceManager.h, CXTPResourceManager Classes, Legend, Members, Topics, CManageState Data Members, CManageState Methods, CManageState Constructors, CManageState Destructors, CManageState Constructors, CManageState Data Members, CManageState Destructors, CManageState Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::CManageState Class

CManageState is used internally by the toolkit to switch module states. Specifically, the class enables the toolkit to read its own .dll resources, and not that of the host application (or .dll). Future versions of the class may handle other such details

Class Hierarchy

class CManageState;
File

XTPResourceManager.h

Group

CXTPResourceManager Classes

Legend
Data Member
protected
Method
CManageState Constructors
CManageState Constructors | Description
CManageState | Constructs a CManageState object
CManageState Data Members
CManageState Data Members | Description
m_bSet | true to set
m_hModOldResource | Handle to previous resource.
CManageState Destructors
CManageState Destructors | Description
~CManageState | Destroys a CManageState object, handles clean up and deallocation
CManageState Methods
CManageState Methods | Description
Redo | Call this member function to REDO managed state
Undo | Call this member function to UNDO managed state


CManageState Data Members

CXTPResourceManager::CManageState Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CManageState Data Members
Class

CXTPResourceManager::CManageState Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bSet | true to set
m_hModOldResource | Handle to previous resource.


CXTPResourceManager::CManageState::m_bSet Data Member

CManageState Data Members, CXTPResourceManager::CManageState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::CManageState::m_bSet Data Member

true to set

bool m_bSet;
Group

CManageState Data Members


CXTPResourceManager::CManageState::m_hModOldResource Data Member

CManageState Data Members, CXTPResourceManager::CManageState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::CManageState::m_hModOldResource Data Member

Handle to previous resource.

HMODULE m_hModOldResource;
Group

CManageState Data Members


CManageState Methods

CXTPResourceManager::CManageState Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CManageState Methods
Class

CXTPResourceManager::CManageState Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Redo | Call this member function to REDO managed state
Undo | Call this member function to UNDO managed state


CXTPResourceManager::CManageState::Redo Method

CManageState Methods, CXTPResourceManager::CManageState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::CManageState::Redo Method

Call this member function to REDO managed state

void Redo();
Group

CManageState Methods


CXTPResourceManager::CManageState::Undo Method

CManageState Methods, CXTPResourceManager::CManageState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::CManageState::Undo Method

Call this member function to UNDO managed state

void Undo();
Group

CManageState Methods


CManageState Constructors

CXTPResourceManager::CManageState Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CManageState Constructors
Class

CXTPResourceManager::CManageState Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CManageState | Constructs a CManageState object


CXTPResourceManager::CManageState::CManageState Constructor

CManageState Constructors, CXTPResourceManager::CManageState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::CManageState::CManageState Constructor

Constructs a CManageState object

CManageState();
Group

CManageState Constructors


CManageState Destructors

CXTPResourceManager::CManageState Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CManageState Destructors
Class

CXTPResourceManager::CManageState Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CManageState | Destroys a CManageState object, handles clean up and deallocation


CXTPResourceManager::CManageState::~CManageState Destructor

CManageState Destructors, CXTPResourceManager::CManageState Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::CManageState::~CManageState Destructor

Destroys a CManageState object, handles clean up and deallocation

~CManageState();
Group

CManageState Destructors


CXTPResourceManager Data Members

CXTPResourceManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager Data Members
Class

CXTPResourceManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bValid | TRUE if Resource manager is valid.
m_hModXTResource | Handle to toolkit resource.
m_hResourceFile | Resource file handle.
m_pLanguageInfo | Resource language
Public Data Members
Public Data Member | Description
m_managerInstance | Manager instance.


CXTPResourceManager::m_bValid Data Member

CXTPResourceManager Data Members, CXTPResourceManager Class
CXTPResourceManager::m_bValid Data Member

TRUE if Resource manager is valid.

BOOL m_bValid;
Group

CXTPResourceManager Data Members


CXTPResourceManager::m_hModXTResource Data Member

CXTPResourceManager Data Members, CXTPResourceManager Class
CXTPResourceManager::m_hModXTResource Data Member

Handle to toolkit resource.

HMODULE m_hModXTResource;
Group

CXTPResourceManager Data Members


CXTPResourceManager::m_hResourceFile Data Member

CXTPResourceManager Data Members, CXTPResourceManager Class
CXTPResourceManager::m_hResourceFile Data Member

Resource file handle.

HMODULE m_hResourceFile;
Group

CXTPResourceManager Data Members


CXTPResourceManager::m_managerInstance Data Member

CXTPResourceManager Data Members, CXTPResourceManager Class
CXTPResourceManager::m_managerInstance Data Member

Manager instance.

CProcessLocal<CXTPResourceManager> m_managerInstance;
Group

CXTPResourceManager Data Members


CXTPResourceManager::m_pLanguageInfo Data Member

CXTPResourceManager Data Members, CXTPResourceManager Class
CXTPResourceManager::m_pLanguageInfo Data Member

Resource language

XTP_RESOURCEMANAGER_LANGINFO* m_pLanguageInfo;
Group

CXTPResourceManager Data Members


CXTPResourceManager Methods

CXTPResourceManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager Methods
Class

CXTPResourceManager Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
LoadFailed | This method is called to notify developer that load resources was failed.
UpdateResourcesLangID | This method check resource identifier of loaded resources
Public Methods
Public Methods
Public Method | Description
Close | This method free used resource. Call it in ExitInstance of your application if you use external resource file.
CreateIconFromResource | The CreateIconFromResource function creates a new icon from the specified modules icon resource.
GetResourceHandle | Call this member function to return the library resource handle.
GetResourceLanguage | Call this static method to determine what language has resources
GetResourcesLangID | Get current resource language ID.
LoadBitmap | Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object
LoadCursor | Reads a Windows cursor resource, identified by nID, into an existing cursor object
LoadDialogTemplate | Reads a Windows dialog resource, identified by pszResource
LoadDialogTemplate2 | Reads a Windows dialog template identified by pszResource into the memory.
LoadHTML | Reads a Windows HTML resource, identified by nIDResource, into an existing CString object.
LoadIcon |
LoadMenu | Reads a Windows menu resource, identified by nID, into an existing CMenu object
LoadString |
LoadToolBar | Call this member function to load the toolbar specified by CToolBar and nIDResource.
SetResourceFile | Call this member to set resource file to be used (dll or xml)
SetResourceHandle | Call this member to set the resource handle for the calling module.
SetResourceManager | Call this method to set application defined Resource manager
ShowMessageBox | Displays a message box on the screen


CXTPResourceManager::Close Method

CXTPResourceManager Methods, CXTPResourceManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::Close Method

This method free used resource. Call it in ExitInstance of your application if you use external resource file.

virtual void Close();
See Also

SetResourceFile

Group

CXTPResourceManager Methods


CXTPResourceManager::CreateIconFromResource Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::CreateIconFromResource Method

The CreateIconFromResource function creates a new icon from the specified modules icon resource.

virtual HICON CreateIconFromResource(
    HMODULE hModule,
    LPCTSTR lpszID,
    CSize iconSize
);
Parameters

hModule
[in] Handle to the module whose executable file contains the icon resource.
lpszID
[in] Specifies the name of the icon to load.
iconSize
[in] Specifies the width and height in pixels of the icon.

Returns

If the function succeeds, the return value is a handle to the icon or cursor. If the function fails, the return value is NULL. To get extended error information, call GetLastError.

Group

CXTPResourceManager Methods


CXTPResourceManager::GetResourceHandle Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::GetResourceHandle Method

Call this member function to return the library resource handle.

HMODULE GetResourceHandle() const;
Returns

Returns the resource handle defined for the library.

Group

CXTPResourceManager Methods


CXTPResourceManager::GetResourceLanguage Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::GetResourceLanguage Method

Call this static method to determine what language has resources

static WORD GetResourceLanguage(
    HMODULE hResModule
);
Parameters

hResModule
Resource instance

Group

CXTPResourceManager Methods


CXTPResourceManager::GetResourcesLangID Method

CXTPResourceManager Methods, CXTPResourceManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::GetResourcesLangID Method

Get current resource language ID.

virtual WORD GetResourcesLangID();
Returns

Current resource language ID.

Remarks

Value for default resource is (LANG_ENGLISH, SUBLANG_ENGLISH_US)

Body Source
WORD CXTPResourceManager::GetResourcesLangID() {
    return m_pLanguageInfo->wLanguage;
}
Group

CXTPResourceManager Methods


CXTPResourceManager::LoadBitmap Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::LoadBitmap Method

Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object

virtual BOOL LoadBitmap(
    CBitmap* pBitmap,
    UINT nIDResource
);
Parameters

pBitmap
Result CBitmap pointer
nIDResource
A Windows bitmap resource ID.

Returns

Nonzero if resource load was successful; otherwise 0.

Group

CXTPResourceManager Methods


CXTPResourceManager::LoadCursor Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::LoadCursor Method

Reads a Windows cursor resource, identified by nID, into an existing cursor object

virtual HCURSOR LoadCursor(
    UINT nIDResource
);
Parameters

nIDResource
A Windows cursor resource ID.

Returns

Nonzero if resource load was successful; otherwise 0.

Group

CXTPResourceManager Methods


CXTPResourceManager::LoadDialogTemplate Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::LoadDialogTemplate Method

Reads a Windows dialog resource, identified by pszResource

virtual LPCDLGTEMPLATE LoadDialogTemplate(
    UINT nIDResource
);
Parameters

nIDResource
A Windows dialog resource ID.

Returns

LPCDLGTEMPLATE pointer if resource load was successful; otherwise 0.

Group

CXTPResourceManager Methods


CXTPResourceManager::LoadDialogTemplate2 Method

CXTPResourceManager Methods, CXTPResourceManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::LoadDialogTemplate2 Method

Reads a Windows dialog template identified by pszResource into the memory.

virtual HGLOBAL LoadDialogTemplate2(
    LPCTSTR pszTemplate
);
Parameters

pszResource
A Windows dialog resource ID.

Returns

HGLOBAL handle if resource load was successful; otherwise 0.

Remarks

Can be useful to load custom templates for common dialogs. To access dialog template data use LockResource() API function.

See Also

LoadDialogTemplate()

Group

CXTPResourceManager Methods


CXTPResourceManager::LoadFailed Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::LoadFailed Method

This method is called to notify developer that load resources was failed.

BOOL LoadFailed();
Group

CXTPResourceManager Methods


CXTPResourceManager::LoadHTML Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::LoadHTML Method

Reads a Windows HTML resource, identified by nIDResource, into an existing CString object.

virtual BOOL LoadHTML(
    CString* pText,
    UINT nIDResource
);
Parameters

nIDResource
A Windows bitmap resource ID.
pString
Output string pointer

Returns

Nonzero if resource load was successful; otherwise 0.

Group

CXTPResourceManager Methods


LoadIcon Method

CXTPResourceManager Methods
LoadIcon Method
Overload List
Methods
Method | Description
CXTPResourceManager::LoadIcon (LPCTSTR, CSize) | The LoadIcon function loads an icon by locating its resource handle.
CXTPResourceManager::LoadIcon (int, CSize) | The LoadIcon function loads an icon by locating its resource handle.
Group

CXTPResourceManager Methods


CXTPResourceManager::LoadIcon Method (LPCTSTR, CSize)

LoadIcon Method, CXTPResourceManager Class
CXTPResourceManager::LoadIcon Method (LPCTSTR, CSize)

The LoadIcon function loads an icon by locating its resource handle.

virtual HICON LoadIcon(
    LPCTSTR lpszID,
    CSize iconSize
);
Parameters

lpszID
[in] Specifies the name of the icon to load.
iconSize
[in] Specifies the width and height in pixels of the icon.

Returns

If the function succeeds, the return value is the handle of the newly loaded icon. If the function fails, the return value is NULL. To get extended error information, call GetLastError.

Group

LoadIcon Method


CXTPResourceManager::LoadIcon Method (int, CSize)

LoadIcon Method, CXTPResourceManager Class
CXTPResourceManager::LoadIcon Method (int, CSize)

The LoadIcon function loads an icon by locating its resource handle.

virtual HICON LoadIcon(
    int nID,
    CSize iconSize
);
Parameters

nID
[in] Specifies the resource id of the icon to load.
iconSize
[in] Specifies the width and height in pixels of the icon.

Returns

If the function succeeds, the return value is the handle of the newly loaded icon. If the function fails, the return value is NULL. To get extended error information, call GetLastError.

Group

LoadIcon Method


CXTPResourceManager::LoadMenu Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::LoadMenu Method

Reads a Windows menu resource, identified by nID, into an existing CMenu object

virtual BOOL LoadMenu(
    CMenu* lpMenu,
    UINT nIDResource
);
Parameters

lpMenu
Output menu pointer
nIDResource
A Windows menu resource ID.

Returns

Nonzero if resource load was successful; otherwise 0.

Group

CXTPResourceManager Methods


LoadString Method

CXTPResourceManager Methods
LoadString Method
Overload List
Methods
Method | Description
CXTPResourceManager::LoadString (CString*, UINT) | Reads a Windows string resource, identified by nID, into an existing CString object
CXTPResourceManager::LoadString (UINT, BOOL*) | Reads a Windows string resource, identified by nID.
Group

CXTPResourceManager Methods


CXTPResourceManager::LoadString Method (CString*, UINT)

LoadString Method, CXTPResourceManager Class
CXTPResourceManager::LoadString Method (CString*, UINT)

Reads a Windows string resource, identified by nID, into an existing CString object

virtual BOOL LoadString(
    CString* pString,
    UINT nIDResource
);
Parameters

pString
Output string pointer
nIDResource
A Windows string resource ID.

Returns

Nonzero if resource load was successful; otherwise 0.

Group

LoadString Method


CXTPResourceManager::LoadString Method (UINT, BOOL*)

LoadString Method, CXTPResourceManager Class, Body Source
CXTPResourceManager::LoadString Method (UINT, BOOL*)

Reads a Windows string resource, identified by nID.

virtual CString LoadString(
    UINT nIDResource,
    BOOL* pbError = NULL
);
Parameters

nIDResource
A Windows string resource ID.
pbError
Pointer to a BOOL variable to report was resource load successful or not. (Optional).

Returns

Loaded string or empty string if such string ID does not find in resource.

Body Source
CString CXTPResourceManager::LoadString(UINT nIDResource, BOOL* pbError) {
    CString str;
    BOOL bRes = LoadString(&str, nIDResource);
    ASSERT(bRes);
    if (pbError) *pbError = !bRes;
    return str;
}
Group

LoadString Method


CXTPResourceManager::LoadToolBar Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::LoadToolBar Method

Call this member function to load the toolbar specified by CToolBar and nIDResource.

virtual BOOL LoadToolBar(
    CToolBar* pToolBar,
    UINT nIDResource
);
Parameters

pToolBar
Result CToolBar pointer
nIDResource
Resource ID of the toolbar to be loaded.

Returns

Nonzero if resource load was successful; otherwise 0.

Group

CXTPResourceManager Methods


CXTPResourceManager::SetResourceFile Method

CXTPResourceManager Methods, CXTPResourceManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManager::SetResourceFile Method

Call this member to set resource file to be used (dll or xml)

void SetResourceFile(
    const CString& strResourceFile
);
Parameters

strResourceFile
Resource file to be used.

Remarks

Call Close method in ExitInstance of your application to free resources.

See Also

Close, SetResourceHandle

Group

CXTPResourceManager Methods


CXTPResourceManager::SetResourceHandle Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::SetResourceHandle Method

Call this member to set the resource handle for the calling module.

void SetResourceHandle(
    HMODULE hModRes
);
Parameters

hModRes
Handle to modules resource.

Group

CXTPResourceManager Methods


CXTPResourceManager::SetResourceManager Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::SetResourceManager Method

Call this method to set application defined Resource manager

BOOL SetResourceManager(
    CXTPResourceManager* pResourceManager
);
Parameters

pResourceManager
Application defined Resource manager

Returns

TRUE if successful; otherwise 0.

Group

CXTPResourceManager Methods


CXTPResourceManager::ShowMessageBox Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::ShowMessageBox Method

Displays a message box on the screen

int ShowMessageBox(
    UINT nIDPrompt,
    UINT nType = MB_OK
);
Parameters

nIDPrompt
A unique ID used to reference a string in the string table.
nType
The style of the message box.

Returns

See AfxMessageBox return values list

Group

CXTPResourceManager Methods


CXTPResourceManager::UpdateResourcesLangID Method

CXTPResourceManager Methods, CXTPResourceManager Class
CXTPResourceManager::UpdateResourcesLangID Method

This method check resource identifier of loaded resources

virtual void UpdateResourcesLangID();
Group

CXTPResourceManager Methods


CXTPResourceManager Constructors

CXTPResourceManager Class, Legend, Public Methods
CXTPResourceManager Constructors
Class

CXTPResourceManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPResourceManager | Constructs a CXTPResourceManager object.


CXTPResourceManager::CXTPResourceManager Constructor

CXTPResourceManager Constructors, CXTPResourceManager Class
CXTPResourceManager::CXTPResourceManager Constructor

Constructs a CXTPResourceManager object.

CXTPResourceManager();
Group

CXTPResourceManager Constructors


CXTPResourceManager Destructors

CXTPResourceManager Class, Legend, Public Methods
CXTPResourceManager Destructors
Class

CXTPResourceManager Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPResourceManager | Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.


CXTPResourceManager::~CXTPResourceManager Destructor

CXTPResourceManager Destructors, CXTPResourceManager Class
CXTPResourceManager::~CXTPResourceManager Destructor

Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.

~CXTPResourceManager();
Group

CXTPResourceManager Destructors


CXTPResourceManagerXML Class

XTPResourceManager.h, Classes, Legend, Members, Topics, CXTPResourceManagerXML Methods, CXTPResourceManagerXML Constructors, CXTPResourceManagerXML Destructors, CXTPResourceManagerXML Constructors, CXTPResourceManagerXML Destructors, CXTPResourceManagerXML Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManagerXML Class

Class used to managed toolkit resources from XML file

Class Hierarchy

class CXTPResourceManagerXML : public CXTPResourceManager;
File

XTPResourceManager.h

Group

Classes

Legend
Method
virtual
protected
CXTPResourceManagerXML Constructors
CXTPResourceManagerXML Constructors | Description
CXTPResourceManagerXML |
CXTPResourceManagerXML Destructors
CXTPResourceManagerXML Destructors | Description
~CXTPResourceManagerXML | Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.
CXTPResourceManagerXML Methods
CXTPResourceManagerXML Methods | Description
Close | This method free used resource. Call it in ExitInstance of your application if you use external resource file.
LoadDialogTemplate | Reads a Windows dialog resource, identified by pszResource
LoadMenu | Reads a Windows menu resource, identified by nID, into an existing CMenu object
LoadString | Reads a Windows string resource, identified by nID, into an existing CString object
UpdateResourcesLangID | This method check resource identifier of loaded resources


CXTPResourceManagerXML Methods

CXTPResourceManagerXML Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManagerXML Methods
Class

CXTPResourceManagerXML Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
UpdateResourcesLangID | This method check resource identifier of loaded resources
Public Methods
Public Methods
Public Method | Description
Close | This method free used resource. Call it in ExitInstance of your application if you use external resource file.
LoadDialogTemplate | Reads a Windows dialog resource, identified by pszResource
LoadMenu | Reads a Windows menu resource, identified by nID, into an existing CMenu object
LoadString | Reads a Windows string resource, identified by nID, into an existing CString object


CXTPResourceManagerXML::Close Method

CXTPResourceManagerXML Methods, CXTPResourceManagerXML Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManagerXML::Close Method

This method free used resource. Call it in ExitInstance of your application if you use external resource file.

virtual void Close();
See Also

SetResourceFile

Group

CXTPResourceManagerXML Methods


CXTPResourceManagerXML::LoadDialogTemplate Method

CXTPResourceManagerXML Methods, CXTPResourceManagerXML Class
CXTPResourceManagerXML::LoadDialogTemplate Method

Reads a Windows dialog resource, identified by pszResource

virtual LPCDLGTEMPLATE LoadDialogTemplate(
    UINT nIDResource
);
Parameters

nIDResource
A Windows dialog resource ID.

Returns

LPCDLGTEMPLATE pointer if resource load was successful; otherwise 0.

Group

CXTPResourceManagerXML Methods


CXTPResourceManagerXML::LoadMenu Method

CXTPResourceManagerXML Methods, CXTPResourceManagerXML Class
CXTPResourceManagerXML::LoadMenu Method

Reads a Windows menu resource, identified by nID, into an existing CMenu object

virtual BOOL LoadMenu(
    CMenu* lpMenu,
    UINT nIDResource
);
Parameters

lpMenu
Output menu pointer
nIDResource
A Windows menu resource ID.

Returns

Nonzero if resource load was successful; otherwise 0.

Group

CXTPResourceManagerXML Methods


CXTPResourceManagerXML::LoadString Method

CXTPResourceManagerXML Methods, CXTPResourceManagerXML Class
CXTPResourceManagerXML::LoadString Method

Reads a Windows string resource, identified by nID, into an existing CString object

virtual BOOL LoadString(
    CString* pString,
    UINT nIDResource
);
Parameters

pString
Output string pointer
nIDResource
A Windows string resource ID.

Returns

Nonzero if resource load was successful; otherwise 0.

Group

CXTPResourceManagerXML Methods


CXTPResourceManagerXML::UpdateResourcesLangID Method

CXTPResourceManagerXML Methods, CXTPResourceManagerXML Class
CXTPResourceManagerXML::UpdateResourcesLangID Method

This method check resource identifier of loaded resources

virtual void UpdateResourcesLangID();
Group

CXTPResourceManagerXML Methods


CXTPResourceManagerXML Constructors

CXTPResourceManagerXML Class, Legend, Public Methods
CXTPResourceManagerXML Constructors
Class

CXTPResourceManagerXML Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPResourceManagerXML |


CXTPResourceManagerXML Constructor

CXTPResourceManagerXML Constructors
CXTPResourceManagerXML Constructor
Overload List
Constructors
Constructor | Description
CXTPResourceManagerXML::CXTPResourceManagerXML (CXTPPropExchangeXMLNode*) | Constructs a CXTPResourceManagerXML object.
CXTPResourceManagerXML::CXTPResourceManagerXML (LPCTSTR) | Constructs a CXTPResourceManagerXML object.
Group

CXTPResourceManagerXML Constructors


CXTPResourceManagerXML::CXTPResourceManagerXML Constructor (LPCTSTR)

CXTPResourceManagerXML Constructor, CXTPResourceManagerXML Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManagerXML::CXTPResourceManagerXML Constructor (LPCTSTR)

Constructs a CXTPResourceManagerXML object.

CXTPResourceManagerXML(
    LPCTSTR lpszFileName
);
CXTPResourceManagerXML(
    CXTPPropExchangeXMLNode* pResourceRoot
);
Parameters

lpszFileName
XML file path
pResourceRoot
Base XML Node

Group

CXTPResourceManagerXML Constructor


CXTPResourceManagerXML Destructors

CXTPResourceManagerXML Class, Legend, Public Methods
CXTPResourceManagerXML Destructors
Class

CXTPResourceManagerXML Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPResourceManagerXML | Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.


CXTPResourceManagerXML::~CXTPResourceManagerXML Destructor

CXTPResourceManagerXML Destructors, CXTPResourceManagerXML Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPResourceManagerXML::~CXTPResourceManagerXML Destructor

Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.

~CXTPResourceManagerXML();
Group

CXTPResourceManagerXML Destructors


CXTPSplitterTracker Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPSplitterTracker Methods, CXTPSplitterTracker Constructors, CXTPSplitterTracker Constructors, CXTPSplitterTracker Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSplitterTracker Class

CXTPSplitterTracker is a stand alone class. It is used to track a splitter rectangle.

Class Hierarchy

class CXTPSplitterTracker;
File

XTPDrawHelpers.h

Group

Classes

Legend
Method
CXTPSplitterTracker Constructors
CXTPSplitterTracker Constructors | Description
CXTPSplitterTracker | Constructs a CXTPSplitterTracker object.
CXTPSplitterTracker Methods
CXTPSplitterTracker Methods | Description
SetBoundRect | Controls the accumulation of bounding-rectangle information for the specified device context.
Track | This method is called to track size of the splitter.


CXTPSplitterTracker Methods

CXTPSplitterTracker Class, Legend, Public Methods
CXTPSplitterTracker Methods
Class

CXTPSplitterTracker Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetBoundRect | Controls the accumulation of bounding-rectangle information for the specified device context.
Track | This method is called to track size of the splitter.


CXTPSplitterTracker::SetBoundRect Method

CXTPSplitterTracker Methods, CXTPSplitterTracker Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSplitterTracker::SetBoundRect Method

Controls the accumulation of bounding-rectangle information for the specified device context.

void SetBoundRect(
    CRect rcBoundRect
);
Parameters

rcBoundRect
A CRect object that specifies the boundaries of the bounding rectangle.

Body Source
void CXTPSplitterTracker::SetBoundRect(CRect rcBoundRect) {
    m_rcBoundRect = rcBoundRect;
}
Group

CXTPSplitterTracker Methods


CXTPSplitterTracker::Track Method

CXTPSplitterTracker Methods, CXTPSplitterTracker Class
CXTPSplitterTracker::Track Method

This method is called to track size of the splitter.

BOOL Track(
    CWnd* pTrackWnd,
    CRect rcAvail,
    CRect& rectTracker,
    CPoint point,
    BOOL bHoriz
);
Parameters

pTrackWnd
Pointer to a CWnd object.
rcAvail
Available rectangle of tracking.
rectTracker
Current rectangle of tracking.
point
Starting point.
bHoriz
TRUE to track horizontally.

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPSplitterTracker Methods


CXTPSplitterTracker Constructors

CXTPSplitterTracker Class, Legend, Public Methods
CXTPSplitterTracker Constructors
Class

CXTPSplitterTracker Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSplitterTracker | Constructs a CXTPSplitterTracker object.


CXTPSplitterTracker::CXTPSplitterTracker Constructor

CXTPSplitterTracker Constructors, CXTPSplitterTracker Class
CXTPSplitterTracker::CXTPSplitterTracker Constructor

Constructs a CXTPSplitterTracker object.

CXTPSplitterTracker(
    BOOL bSolid = FALSE
);
Parameters

bSolid
TRUE to use solid tracker; FALSE for HalftoneBrush.

Group

CXTPSplitterTracker Constructors


CXTPSystemVersion Class

XTPSystemHelpers.h, Classes, Legend, Members, Topics, CXTPSystemVersion Methods, CXTPSystemVersion Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSystemVersion Class

CXTPSystemVersion is a OSVERSIONINFO derived class. This class wraps the Win32 API GetVersionEx(...), used to get the current Windows OS version. CXTPSystemVersion is a single instance, or "singleton" object, that is accessed with the Get() method.

Class Hierarchy

class CXTPSystemVersion : public OSVERSIONINFO;
File

XTPSystemHelpers.h

Group

Classes

Legend
Method
CXTPSystemVersion Methods
CXTPSystemVersion Methods | Description
GetComCtlVersion | Use this member function to return the version number of the comctl32.dll. The high-order word of the return value represents the major version number and the low-order word of the returned value represents the minor version number.
IsClearTypeTextQualitySupported | Determines if ClearType text is supported by current OS
IsLayoutRTLSupported | Determines if right-to-left (RTL) formatting is supported by current OS
IsWin2K | Call this member function to check whether or not the operating system is Windows 2000.
IsWin2KOrGreater | Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 2000 or a later version.
IsWin31 | Call this member function to check whether or not the operating system is Windows 3.1.
IsWin31OrGreater | Call this member function to check whether or not the operating system is greater than or equal to Windows 3.1.
IsWin95 | Call this member function to check whether or not the operating system is Windows 95.
IsWin95OrGreater | Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 95 or a later version.
IsWin98 | Call this member function to check whether or not the operating system is Windows 98.
IsWin98OrGreater | Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 98 or a later version.
IsWin9x | Call this member function to check whether or not the operating system is of the Windows 9x family
IsWinME | Call this member function to check whether or not the operating system is Windows ME.
IsWinMEOrGreater | Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows ME or a later version.
IsWinNT4 | Call this member function to check whether or not the operating system is Windows NT 4.
IsWinNT4OrGreater | Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows NT 4 or a later version.
IsWinVistaOrGreater | Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows Vista or a later version.
IsWinXP | Call this member function to check whether or not the operating system is Windows XP.
IsWinXPOrGreater | Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows XP or a later version.


CXTPSystemVersion Methods

CXTPSystemVersion Class, Legend, Public Methods
CXTPSystemVersion Methods
Class

CXTPSystemVersion Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetComCtlVersion | Use this member function to return the version number of the comctl32.dll. The high-order word of the return value represents the major version number and the low-order word of the returned value represents the minor version number.
IsClearTypeTextQualitySupported | Determines if ClearType text is supported by current OS
IsLayoutRTLSupported | Determines if right-to-left (RTL) formatting is supported by current OS
IsWin2K | Call this member function to check whether or not the operating system is Windows 2000.
IsWin2KOrGreater | Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 2000 or a later version.
IsWin31 | Call this member function to check whether or not the operating system is Windows 3.1.
IsWin31OrGreater | Call this member function to check whether or not the operating system is greater than or equal to Windows 3.1.
IsWin95 | Call this member function to check whether or not the operating system is Windows 95.
IsWin95OrGreater | Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 95 or a later version.
IsWin98 | Call this member function to check whether or not the operating system is Windows 98.
IsWin98OrGreater | Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 98 or a later version.
IsWin9x | Call this member function to check whether or not the operating system is of the Windows 9x family
IsWinME | Call this member function to check whether or not the operating system is Windows ME.
IsWinMEOrGreater | Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows ME or a later version.
IsWinNT4 | Call this member function to check whether or not the operating system is Windows NT 4.
IsWinNT4OrGreater | Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows NT 4 or a later version.
IsWinVistaOrGreater | Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows Vista or a later version.
IsWinXP | Call this member function to check whether or not the operating system is Windows XP.
IsWinXPOrGreater | Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows XP or a later version.


CXTPSystemVersion::GetComCtlVersion Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::GetComCtlVersion Method

Use this member function to return the version number of the comctl32.dll. The high-order word of the return value represents the major version number and the low-order word of the returned value represents the minor version number.

DWORD GetComCtlVersion() const;
Returns

A DWORD value if successful, otherwise 0L.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsClearTypeTextQualitySupported Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsClearTypeTextQualitySupported Method

Determines if ClearType text is supported by current OS

BOOL IsClearTypeTextQualitySupported();
Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsLayoutRTLSupported Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsLayoutRTLSupported Method

Determines if right-to-left (RTL) formatting is supported by current OS

BOOL IsLayoutRTLSupported();
Returns

TRUE if right-to-left (RTL) formatting is supported.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin2K Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin2K Method

Call this member function to check whether or not the operating system is Windows 2000.

bool IsWin2K() const;
Returns

true if the OS is Windows 2000, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin2KOrGreater Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin2KOrGreater Method

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 2000 or a later version.

bool IsWin2KOrGreater() const;
Returns

true if the OS is of the Windows NT family, and is Windows 2000 or a later version, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin31 Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin31 Method

Call this member function to check whether or not the operating system is Windows 3.1.

bool IsWin31() const;
Returns

true if the OS is Windows 3.1, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin31OrGreater Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin31OrGreater Method

Call this member function to check whether or not the operating system is greater than or equal to Windows 3.1.

bool IsWin31OrGreater() const;
Returns

true if the OS is greater than or equal to Windows 3.1, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin95 Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin95 Method

Call this member function to check whether or not the operating system is Windows 95.

bool IsWin95() const;
Returns

true if the OS is Windows 95, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin95OrGreater Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin95OrGreater Method

Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 95 or a later version.

bool IsWin95OrGreater() const;
Returns

true if the OS is of the Windows 9x family, and is Windows 95 or a later version, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin98 Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin98 Method

Call this member function to check whether or not the operating system is Windows 98.

bool IsWin98() const;
Returns

true if the OS is Windows 98, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin98OrGreater Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin98OrGreater Method

Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 98 or a later version.

bool IsWin98OrGreater() const;
Returns

true if the OS is of the Windows 9x family, and is Windows 98 or a later version, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWin9x Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWin9x Method

Call this member function to check whether or not the operating system is of the Windows 9x family

bool IsWin9x() const;
Returns

true if the OS is of the Windows 9x family

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWinME Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWinME Method

Call this member function to check whether or not the operating system is Windows ME.

bool IsWinME() const;
Returns

true if the OS is Windows ME, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWinMEOrGreater Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWinMEOrGreater Method

Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows ME or a later version.

bool IsWinMEOrGreater() const;
Returns

true if the OS is of the Windows 9x family, and is Windows ME or a later version, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWinNT4 Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWinNT4 Method

Call this member function to check whether or not the operating system is Windows NT 4.

bool IsWinNT4() const;
Returns

true if the OS is Windows NT 4, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWinNT4OrGreater Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWinNT4OrGreater Method

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows NT 4 or a later version.

bool IsWinNT4OrGreater() const;
Returns

true if the OS is of the Windows NT family, and is Windows NT 4 or a later version, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWinVistaOrGreater Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWinVistaOrGreater Method

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows Vista or a later version.

bool IsWinVistaOrGreater() const;
Returns

true if the OS is of the Windows NT family, and is Windows Vista or a later version, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWinXP Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWinXP Method

Call this member function to check whether or not the operating system is Windows XP.

bool IsWinXP() const;
Returns

true if the OS is Windows XP, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPSystemVersion::IsWinXPOrGreater Method

CXTPSystemVersion Methods, CXTPSystemVersion Class
CXTPSystemVersion::IsWinXPOrGreater Method

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows XP or a later version.

bool IsWinXPOrGreater() const;
Returns

true if the OS is of the Windows NT family, and is Windows XP or a later version, otherwise returns false.

Group

CXTPSystemVersion Methods


CXTPTempColorMask Class

XTPImageManager.h, Classes, Legend, Members, Topics, CXTPTempColorMask Constructors, CXTPTempColorMask Destructors, CXTPTempColorMask Constructors, CXTPTempColorMask Destructors, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTempColorMask Class

CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks. When the destructor is called the default mask is reset for XTPImageManager.

Class Hierarchy

class CXTPTempColorMask;
File

XTPImageManager.h

See Also

CXTPImageManager::GetMaskColor, CXTPImageManager::SetMaskColor, CXTPPaintManagerColor::GetStandardColor

Example

The following example demonstrates using CXTPTempColorMask.

   // temporarily change the mask color.
   CXTPTempColorMask mask(RGB(0,255,0));
   XTPImageManager()->SetIcons(IDB_FAVORITES,
       icons, _countof(icons) CSize(16,16));

   // set another mask color, CXTPTempColorMask will handle resetting
   // the default color mask when it is destroyed.
   XTPImageManager()->SetMaskColor(RGB(255,0,255));
   XTPImageManager()->SetIcons(IDR_TOOLBAR_MASKED,
       buttons, _countof(buttons), CSize(16,16), xtpImageNormal);
Group

Classes

Legend
Constructor
virtual
CXTPTempColorMask Constructors
CXTPTempColorMask Constructors | Description
CXTPTempColorMask | Constructs a CXTPTempColorMask object and initializes the application defined mask color and saves the default mask color used by XTPImageManager.
CXTPTempColorMask Destructors
CXTPTempColorMask Destructors | Description
~CXTPTempColorMask | Destructor for CXTPTempColorMask. Resets the default mask color used by XTPImageManager back to its original color value.


CXTPTempColorMask Constructors

CXTPTempColorMask Class, Legend, Public Methods
CXTPTempColorMask Constructors
Class

CXTPTempColorMask Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTempColorMask | Constructs a CXTPTempColorMask object and initializes the application defined mask color and saves the default mask color used by XTPImageManager.


CXTPTempColorMask::CXTPTempColorMask Constructor

CXTPTempColorMask Constructors, CXTPTempColorMask Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTempColorMask::CXTPTempColorMask Constructor

Constructs a CXTPTempColorMask object and initializes the application defined mask color and saves the default mask color used by XTPImageManager.

CXTPTempColorMask(
    COLORREF crNewMask
);
Parameters

crNewMask
An RGB value that represents the new color mask value used by XTPImageManager.

Body Source
CXTPTempColorMask::CXTPTempColorMask(COLORREF crNewMask) {
    m_crMask = XTPImageManager()->SetMaskColor(crNewMask);
}
Group

CXTPTempColorMask Constructors


CXTPTempColorMask Destructors

CXTPTempColorMask Class, Legend, Public Methods
CXTPTempColorMask Destructors
Class

CXTPTempColorMask Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTempColorMask | Destructor for CXTPTempColorMask. Resets the default mask color used by XTPImageManager back to its original color value.


CXTPTempColorMask::~CXTPTempColorMask Destructor

CXTPTempColorMask Destructors, CXTPTempColorMask Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTempColorMask::~CXTPTempColorMask Destructor

Destructor for CXTPTempColorMask. Resets the default mask color used by XTPImageManager back to its original color value.

virtual ~CXTPTempColorMask();
Body Source
CXTPTempColorMask::~CXTPTempColorMask() {
    XTPImageManager()->SetMaskColor(m_crMask);
}
Group

CXTPTempColorMask Destructors


CXTPToolTipContext Class

XTPToolTipContext.h, Classes, Legend, Members, Topics, CXTPToolTipContext Data Members, CXTPToolTipContext Methods, CXTPToolTipContext Constructors, CXTPToolTipContext Destructors, CXTPToolTipContext Constructors, CXTPToolTipContext Data Members, CXTPToolTipContext Destructors, CXTPToolTipContext Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext Class

CXTPToolTipContext is a CCmdTarget derived class. It allows to change options for tool tips of parent object.

Class Hierarchy

class CXTPToolTipContext;
File

XTPToolTipContext.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPToolTipContext Constructors
CXTPToolTipContext Constructors | Description
CXTPToolTipContext | Constructs a CXTPToolTipContext object.
CXTPToolTipContext Data Members
CXTPToolTipContext Data Members | Description
m_bShowImage | TRUE to show images in tooltip
m_bShowTitleAndDescription | TRUE to show title and description for tooltip.
m_clrTipBkColor | Background color in a tooltip window
m_clrTipTextColor | Text color in a tooltip window.
m_dwComCtlVersion | CommCtrl.dll version
m_dwStyle | Tooltip style
m_fnt | Font of the tool tip
m_fntTitle | Font of the tool tip
m_lastInfo | Last tooltip info.
m_nDelayAutoPop | the length of time a tooltip window remains visible if the pointer is stationary within a tool's bounding rectangle.
m_nDelayInitial | The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.
m_nDelayReshow | The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.
m_nIconTitle | Icon title for extended tooltip
m_nImageBase | This value will be added to tool identifier to retrieve image for tip.
m_nImageSize | Size of images in tooltip
m_nMaxTipWidth | Maximum width of tooltip window
m_pModuleContext | Tooltip for current module
m_pToolTip | Owned Tooltip window
m_rcMargin | Margin or "padding" placed around the tooltip text.
m_toolStyle | Tooltip style
CXTPToolTipContext Destructors
CXTPToolTipContext Destructors | Description
~CXTPToolTipContext | Destroys a CXTPToolTipContext object, handles cleanup and deallocation
CXTPToolTipContext Methods
CXTPToolTipContext Methods | Description
CancelToolTips | Call this member function to remove a tooltip from the screen if a tooltip is currently displayed.
CreateToolTip | This method is called to create tooltip window. You can override it to create custom tool tip derived from CXTPToolTipContextToolTip
GetControlStyle | Retrieves control style
GetMargin | Retrieves the top, left, bottom, and right margins set for a tooltip window
GetMaxTipWidth | Retrieves the maximum width for a tooltip window.
GetStyle | Call this member to get the style of the tooltip.
GetTipBkColor | Retrieves the background color in a tooltip window.
GetTipTextColor | Retrieves the text color in a tooltip window.
IsBalloonStyleSupported | Call this method to determine if Balloon tooltips supported by the system.
IsShowTitleAndDescription | Determines if TitleAndDescription option was set
ModifyToolTipStyle | Modifies the styles of the tool tip.
SetDelayTime | Call this function to set the delay time for a tool tip control. The delay time is the length of time the cursor must remain on a tool before the tool tip window appears. The default delay time is 500 milliseconds.
SetFont | Call this method to set custom font for tooltips
SetFontIndirect | Call this method to set custom font for tooltips
SetMargin | Sets the top, left, bottom, and right margins for a tooltip window
SetMaxTipWidth | Sets the maximum width for a tooltip window.
SetStyle | Call this member to set the style of the tooltip.
SetTipBkColor | Sets the background color in a tooltip window.
SetTipTextColor | Sets the text color in a tooltip window.
SetToolTipCtrl | Call this method to set custom tooltip ctrl
ShowImage | Call this method to show image in tooltip
ShowTitleAndDescription | Call this method to show title and description part of tooltip window.


CXTPToolTipContext Data Members

CXTPToolTipContext Class, Legend, Protected Data Members
CXTPToolTipContext Data Members
Class

CXTPToolTipContext Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bShowImage | TRUE to show images in tooltip
m_bShowTitleAndDescription | TRUE to show title and description for tooltip.
m_clrTipBkColor | Background color in a tooltip window
m_clrTipTextColor | Text color in a tooltip window.
m_dwComCtlVersion | CommCtrl.dll version
m_dwStyle | Tooltip style
m_fnt | Font of the tool tip
m_fntTitle | Font of the tool tip
m_lastInfo | Last tooltip info.
m_nDelayAutoPop | the length of time a tooltip window remains visible if the pointer is stationary within a tool's bounding rectangle.
m_nDelayInitial | The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.
m_nDelayReshow | The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.
m_nIconTitle | Icon title for extended tooltip
m_nImageBase | This value will be added to tool identifier to retrieve image for tip.
m_nImageSize | Size of images in tooltip
m_nMaxTipWidth | Maximum width of tooltip window
m_pModuleContext | Tooltip for current module
m_pToolTip | Owned Tooltip window
m_rcMargin | Margin or "padding" placed around the tooltip text.
m_toolStyle | Tooltip style


CXTPToolTipContext::m_bShowImage Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_bShowImage Data Member

TRUE to show images in tooltip

BOOL m_bShowImage;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_bShowTitleAndDescription Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_bShowTitleAndDescription Data Member

TRUE to show title and description for tooltip.

BOOL m_bShowTitleAndDescription;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_clrTipBkColor Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_clrTipBkColor Data Member

Background color in a tooltip window

COLORREF m_clrTipBkColor;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_clrTipTextColor Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_clrTipTextColor Data Member

Text color in a tooltip window.

COLORREF m_clrTipTextColor;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_dwComCtlVersion Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_dwComCtlVersion Data Member

CommCtrl.dll version

DWORD m_dwComCtlVersion;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_dwStyle Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_dwStyle Data Member

Tooltip style

DWORD m_dwStyle;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_fnt Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_fnt Data Member

Font of the tool tip

CFont m_fnt;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_fntTitle Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_fntTitle Data Member

Font of the tool tip

CFont m_fntTitle;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_lastInfo Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_lastInfo Data Member

Last tooltip info.

XTP_TOOLTIP_TOOLINFO_EX m_lastInfo;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_nDelayAutoPop Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_nDelayAutoPop Data Member

the length of time a tooltip window remains visible if the pointer is stationary within a tool's bounding rectangle.

int m_nDelayAutoPop;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_nDelayInitial Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_nDelayInitial Data Member

The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.

int m_nDelayInitial;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_nDelayReshow Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_nDelayReshow Data Member

The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.

int m_nDelayReshow;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_nIconTitle Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_nIconTitle Data Member

Icon title for extended tooltip

int m_nIconTitle;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_nImageBase Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_nImageBase Data Member

This value will be added to tool identifier to retrieve image for tip.

int m_nImageBase;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_nImageSize Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_nImageSize Data Member

Size of images in tooltip

BOOL m_nImageSize;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_nMaxTipWidth Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_nMaxTipWidth Data Member

Maximum width of tooltip window

int m_nMaxTipWidth;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_pModuleContext Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_pModuleContext Data Member

Tooltip for current module

CXTPToolTipContext* m_pModuleContext;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_pToolTip Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_pToolTip Data Member

Owned Tooltip window

CWnd* m_pToolTip;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_rcMargin Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_rcMargin Data Member

Margin or "padding" placed around the tooltip text.

CRect m_rcMargin;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext::m_toolStyle Data Member

CXTPToolTipContext Data Members, CXTPToolTipContext Class
CXTPToolTipContext::m_toolStyle Data Member

Tooltip style

XTPToolTipStyle m_toolStyle;
Group

CXTPToolTipContext Data Members


CXTPToolTipContext Methods

CXTPToolTipContext Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext Methods
Class

CXTPToolTipContext Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CreateToolTip | This method is called to create tooltip window. You can override it to create custom tool tip derived from CXTPToolTipContextToolTip
Public Methods
Public Methods
Public Method | Description
CancelToolTips | Call this member function to remove a tooltip from the screen if a tooltip is currently displayed.
GetControlStyle | Retrieves control style
GetMargin | Retrieves the top, left, bottom, and right margins set for a tooltip window
GetMaxTipWidth | Retrieves the maximum width for a tooltip window.
GetStyle | Call this member to get the style of the tooltip.
GetTipBkColor | Retrieves the background color in a tooltip window.
GetTipTextColor | Retrieves the text color in a tooltip window.
IsBalloonStyleSupported | Call this method to determine if Balloon tooltips supported by the system.
IsShowTitleAndDescription | Determines if TitleAndDescription option was set
ModifyToolTipStyle | Modifies the styles of the tool tip.
SetDelayTime | Call this function to set the delay time for a tool tip control. The delay time is the length of time the cursor must remain on a tool before the tool tip window appears. The default delay time is 500 milliseconds.
SetFont | Call this method to set custom font for tooltips
SetFontIndirect | Call this method to set custom font for tooltips
SetMargin | Sets the top, left, bottom, and right margins for a tooltip window
SetMaxTipWidth | Sets the maximum width for a tooltip window.
SetStyle | Call this member to set the style of the tooltip.
SetTipBkColor | Sets the background color in a tooltip window.
SetTipTextColor | Sets the text color in a tooltip window.
SetToolTipCtrl | Call this method to set custom tooltip ctrl
ShowImage | Call this method to show image in tooltip
ShowTitleAndDescription | Call this method to show title and description part of tooltip window.


CXTPToolTipContext::CancelToolTips Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::CancelToolTips Method

Call this member function to remove a tooltip from the screen if a tooltip is currently displayed.

void CancelToolTips();
Group

CXTPToolTipContext Methods


CXTPToolTipContext::CreateToolTip Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::CreateToolTip Method

This method is called to create tooltip window. You can override it to create custom tool tip derived from CXTPToolTipContextToolTip

virtual CWnd* CreateToolTip(
    CWnd* pOwner
);
Parameters

pOwner
Specifies the tool tip control's parent window.

Returns

New tool tip window.

Group

CXTPToolTipContext Methods


CXTPToolTipContext::GetControlStyle Method

CXTPToolTipContext Methods, CXTPToolTipContext Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext::GetControlStyle Method

Retrieves control style

DWORD GetControlStyle() const;
See Also

ModifyToolTipStyle

Body Source
DWORD CXTPToolTipContext::GetControlStyle() const {
    return m_dwStyle;
}
Group

CXTPToolTipContext Methods


CXTPToolTipContext::GetMargin Method

CXTPToolTipContext Methods, CXTPToolTipContext Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext::GetMargin Method

Retrieves the top, left, bottom, and right margins set for a tooltip window

CRect GetMargin() const;
Body Source
CRect CXTPToolTipContext::GetMargin() const {
    return m_rcMargin;
}
Group

CXTPToolTipContext Methods


CXTPToolTipContext::GetMaxTipWidth Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::GetMaxTipWidth Method

Retrieves the maximum width for a tooltip window.

int GetMaxTipWidth() const;
Returns

Returns an INT value that represents the maximum tooltip width, in pixels

Group

CXTPToolTipContext Methods


CXTPToolTipContext::GetStyle Method

CXTPToolTipContext Methods, CXTPToolTipContext Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext::GetStyle Method

Call this member to get the style of the tooltip.

XTPToolTipStyle GetStyle() const;
See Also

SetStyle, XTPToolTipStyle

Group

CXTPToolTipContext Methods


CXTPToolTipContext::GetTipBkColor Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::GetTipBkColor Method

Retrieves the background color in a tooltip window.

COLORREF GetTipBkColor() const;
Returns

Returns a COLORREF value that represents the background color.

Group

CXTPToolTipContext Methods


CXTPToolTipContext::GetTipTextColor Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::GetTipTextColor Method

Retrieves the text color in a tooltip window.

COLORREF GetTipTextColor() const;
Returns

Returns a COLORREF value that represents the text color.

Group

CXTPToolTipContext Methods


CXTPToolTipContext::IsBalloonStyleSupported Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::IsBalloonStyleSupported Method

Call this method to determine if Balloon tooltips supported by the system.

BOOL IsBalloonStyleSupported() const;
Group

CXTPToolTipContext Methods


CXTPToolTipContext::IsShowTitleAndDescription Method

CXTPToolTipContext Methods, CXTPToolTipContext Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext::IsShowTitleAndDescription Method

Determines if TitleAndDescription option was set

BOOL IsShowTitleAndDescription() const;
Returns

TRUE if description is visible for tooltips

See Also

ShowTitleAndDescription

Body Source
BOOL CXTPToolTipContext::IsShowTitleAndDescription() const {
    return m_bShowTitleAndDescription;
}
Group

CXTPToolTipContext Methods


CXTPToolTipContext::ModifyToolTipStyle Method

CXTPToolTipContext Methods, CXTPToolTipContext Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext::ModifyToolTipStyle Method

Modifies the styles of the tool tip.

void ModifyToolTipStyle(
    DWORD dwRemove,
    DWORD dwAdd
);
Parameters

dwRemove
Styles to remove.
dwAdd
Styles to add.

Example
m_wndToolBox.GetToolTipContext()->ModifyToolTipStyle(TTS_NOPREFIX, 0);
Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetDelayTime Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::SetDelayTime Method

Call this function to set the delay time for a tool tip control. The delay time is the length of time the cursor must remain on a tool before the tool tip window appears. The default delay time is 500 milliseconds.

void SetDelayTime(
    DWORD dwDuration,
    int iTime
);
Parameters

dwDuration
Flag that specifies which duration value will be retrieved. See CToolTipCtrl::GetDelayTime for a description of the valid values.
iTime
The specified delay time, in milliseconds.

Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetFont Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::SetFont Method

Call this method to set custom font for tooltips

void SetFont(
    CFont* pFont
);
Parameters

pFont
Font to be set

Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetFontIndirect Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::SetFontIndirect Method

Call this method to set custom font for tooltips

void SetFontIndirect(
    LOGFONT* lpLogFont
);
Parameters

lpLogFont
Font to be set

Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetMargin Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::SetMargin Method

Sets the top, left, bottom, and right margins for a tooltip window

void SetMargin(
    LPCRECT lprc
);
Parameters

lprc
Address of a RECT structure that contains the margin information to be set.

Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetMaxTipWidth Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::SetMaxTipWidth Method

Sets the maximum width for a tooltip window.

void SetMaxTipWidth(
    int iWidth
);
Parameters

iWidth
Maximum tooltip window width to be set.

Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetStyle Method

CXTPToolTipContext Methods, CXTPToolTipContext Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext::SetStyle Method

Call this member to set the style of the tooltip.

void SetStyle(
    XTPToolTipStyle toolStyle
);
Parameters

toolStyle
The style to be set. Can be any of the values listed in the Remarks section.

Remarks

toolStyle parameter can be one of the following:

  • xtpToolTipStandard Standard tooltip window style
  • xtpToolTipBalloon Balloon tooltip window style
  • xtpToolTipOffice Office tooltip window style
See Also

GetStyle, XTPToolTipStyle

Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetTipBkColor Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::SetTipBkColor Method

Sets the background color in a tooltip window.

void SetTipBkColor(
    COLORREF clr
);
Parameters

clr
New background color.

Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetTipTextColor Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::SetTipTextColor Method

Sets the text color in a tooltip window.

void SetTipTextColor(
    COLORREF clr
);
Parameters

clr
New text color.

Group

CXTPToolTipContext Methods


CXTPToolTipContext::SetToolTipCtrl Method

CXTPToolTipContext Methods, CXTPToolTipContext Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext::SetToolTipCtrl Method

Call this method to set custom tooltip ctrl

void SetToolTipCtrl(
    CXTPToolTipContextToolTip* pToolTipCtrl
);
Parameters

pToolTipCtrl
new tooltip to be set

Example
pCommandBars->GetTooltipContext()->SetToolTipCtrl(new CMyTooltip());
Group

CXTPToolTipContext Methods


CXTPToolTipContext::ShowImage Method

CXTPToolTipContext Methods, CXTPToolTipContext Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContext::ShowImage Method

Call this method to show image in tooltip

void ShowImage(
    BOOL bShowImage,
    int nImageBase = 0,
    int nImageSize = ICON_BIG
);
Parameters

bShowImage
TRUE to show image
nImageBase
Image base
nImageSize
Size of image in tooltip. By default largest image used.

See Also

ShowTitleAndDescription

Group

CXTPToolTipContext Methods


CXTPToolTipContext::ShowTitleAndDescription Method

CXTPToolTipContext Methods, CXTPToolTipContext Class
CXTPToolTipContext::ShowTitleAndDescription Method

Call this method to show title and description part of tooltip window.

void ShowTitleAndDescription(
    BOOL bShowTitleAndDescription = TRUE,
    int nIconTitle = TTI_INFO
);
Parameters

bShowTitleAndDescription
TRUE to show title and description part
nIconTitle
Icon to be set

Remarks

Allow only if Internet Explorer 5.0 installed.

Group

CXTPToolTipContext Methods


CXTPToolTipContext Constructors

CXTPToolTipContext Class, Legend, Public Methods
CXTPToolTipContext Constructors
Class

CXTPToolTipContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPToolTipContext | Constructs a CXTPToolTipContext object.


CXTPToolTipContext::CXTPToolTipContext Constructor

CXTPToolTipContext Constructors, CXTPToolTipContext Class
CXTPToolTipContext::CXTPToolTipContext Constructor

Constructs a CXTPToolTipContext object.

CXTPToolTipContext();
Group

CXTPToolTipContext Constructors


CXTPToolTipContext Destructors

CXTPToolTipContext Class, Legend, Public Methods
CXTPToolTipContext Destructors
Class

CXTPToolTipContext Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPToolTipContext | Destroys a CXTPToolTipContext object, handles cleanup and deallocation


CXTPToolTipContext::~CXTPToolTipContext Destructor

CXTPToolTipContext Destructors, CXTPToolTipContext Class
CXTPToolTipContext::~CXTPToolTipContext Destructor

Destroys a CXTPToolTipContext object, handles cleanup and deallocation

virtual ~CXTPToolTipContext();
Group

CXTPToolTipContext Destructors


CXTPToolTipContextToolTip Class

XTPToolTipContext.h, Classes, Legend, Members, Topics, CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Methods, CXTPToolTipContextToolTip Constructors, CXTPToolTipContextToolTip Destructors, CXTPToolTipContextToolTip Constructors, CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Destructors, CXTPToolTipContextToolTip Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip Class

CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips.

Class Hierarchy

class CXTPToolTipContextToolTip : public CWnd;
File

XTPToolTipContext.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPToolTipContextToolTip Constructors
CXTPToolTipContextToolTip Constructors | Description
CXTPToolTipContextToolTip | Constructs a CXTPToolTipContextToolTip object
CXTPToolTipContextToolTip Data Members
CXTPToolTipContextToolTip Data Members | Description
m_arrTools | Tool tips item array
m_bActive | TRUE if tracking is active
m_dwLastTip | Last tool tip time.
m_hHookMouse | Mouse hook
m_nDelayInitial | The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.
m_nDelayReshow | The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.
m_nDelayTimer | Hover timer
m_pContext | Pointer to parent context class
m_pIcon | Image
m_pWndMonitor | Mouse monitor pointer
m_strTitle | Title of tooltip if enabled.
m_toolDelay | Currently delayed tip
m_toolDisabled | Currently ignored tip
m_toolVisible | Currently visible tip
CXTPToolTipContextToolTip Destructors
CXTPToolTipContextToolTip Destructors | Description
~CXTPToolTipContextToolTip | Destroys a CXTPToolTipContextToolTip object, handles cleanup and deallocation
CXTPToolTipContextToolTip Methods
CXTPToolTipContextToolTip Methods | Description
DrawBackground | This method is called to draw background of tool tip.
DrawEntry | This method is called to draw face of tool tip.
GetToolSize | This method is called to retrieve size of tool tip to show


CXTPToolTipContextToolTip Data Members

CXTPToolTipContextToolTip Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip Data Members
Class

CXTPToolTipContextToolTip Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrTools | Tool tips item array
m_bActive | TRUE if tracking is active
m_dwLastTip | Last tool tip time.
m_hHookMouse | Mouse hook
m_nDelayInitial | The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.
m_nDelayReshow | The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.
m_nDelayTimer | Hover timer
m_pContext | Pointer to parent context class
m_pIcon | Image
m_pWndMonitor | Mouse monitor pointer
m_strTitle | Title of tooltip if enabled.
m_toolDelay | Currently delayed tip
m_toolDisabled | Currently ignored tip
m_toolVisible | Currently visible tip


CXTPToolTipContextToolTip::m_arrTools Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_arrTools Data Member

Tool tips item array

CArray<TOOLITEM*, TOOLITEM*> m_arrTools;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_bActive Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_bActive Data Member

TRUE if tracking is active

BOOL m_bActive;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_dwLastTip Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_dwLastTip Data Member

Last tool tip time.

DWORD m_dwLastTip;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_hHookMouse Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_hHookMouse Data Member

Mouse hook

HHOOK m_hHookMouse;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_nDelayInitial Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_nDelayInitial Data Member

The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.

UINT m_nDelayInitial;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_nDelayReshow Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_nDelayReshow Data Member

The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.

UINT m_nDelayReshow;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_nDelayTimer Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_nDelayTimer Data Member

Hover timer

UINT_PTR m_nDelayTimer;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_pContext Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_pContext Data Member

Pointer to parent context class

CXTPToolTipContext* m_pContext;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_pIcon Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_pIcon Data Member

Image

CXTPImageManagerIcon* m_pIcon;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_pWndMonitor Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_pWndMonitor Data Member

Mouse monitor pointer

CXTPToolTipContextToolTip* m_pWndMonitor;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_strTitle Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_strTitle Data Member

Title of tooltip if enabled.

CString m_strTitle;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_toolDelay Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_toolDelay Data Member

Currently delayed tip

TOOLITEM m_toolDelay;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_toolDisabled Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_toolDisabled Data Member

Currently ignored tip

TOOLITEM m_toolDisabled;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip::m_toolVisible Data Member

CXTPToolTipContextToolTip Data Members, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::m_toolVisible Data Member

Currently visible tip

TOOLITEM m_toolVisible;
Group

CXTPToolTipContextToolTip Data Members


CXTPToolTipContextToolTip Methods

CXTPToolTipContextToolTip Class, Legend, Protected Methods
CXTPToolTipContextToolTip Methods
Class

CXTPToolTipContextToolTip Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawBackground | This method is called to draw background of tool tip.
DrawEntry | This method is called to draw face of tool tip.
GetToolSize | This method is called to retrieve size of tool tip to show


CXTPToolTipContextToolTip::DrawBackground Method

CXTPToolTipContextToolTip Methods, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::DrawBackground Method

This method is called to draw background of tool tip.

virtual void DrawBackground(
    CDC* pDC,
    TOOLITEM* lpToolInfo,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
lpToolInfo
Pointer to tooltip specific information
rc
Client rectangle

Group

CXTPToolTipContextToolTip Methods


CXTPToolTipContextToolTip::DrawEntry Method

CXTPToolTipContextToolTip Methods, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::DrawEntry Method

This method is called to draw face of tool tip.

virtual void DrawEntry(
    CDC* pDC,
    TOOLITEM* lpToolInfo,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
lpToolInfo
Pointer to tooltip specific information
rc
Client rectangle

Group

CXTPToolTipContextToolTip Methods


CXTPToolTipContextToolTip::GetToolSize Method

CXTPToolTipContextToolTip Methods, CXTPToolTipContextToolTip Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::GetToolSize Method

This method is called to retrieve size of tool tip to show

virtual CSize GetToolSize(
    TOOLITEM* lpToolInfo
);
Parameters

lpToolInfo
Pointer to tooltip specific information

Returns

Size of new tool tip.

See Also

DrawEntry

Group

CXTPToolTipContextToolTip Methods


CXTPToolTipContextToolTip Constructors

CXTPToolTipContextToolTip Class, Legend, Public Methods
CXTPToolTipContextToolTip Constructors
Class

CXTPToolTipContextToolTip Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPToolTipContextToolTip | Constructs a CXTPToolTipContextToolTip object


CXTPToolTipContextToolTip::CXTPToolTipContextToolTip Constructor

CXTPToolTipContextToolTip Constructors, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::CXTPToolTipContextToolTip Constructor

Constructs a CXTPToolTipContextToolTip object

CXTPToolTipContextToolTip(
    CXTPToolTipContext* pContext
);
Parameters

pContext
Pointer to parent tooltip context

Group

CXTPToolTipContextToolTip Constructors


CXTPToolTipContextToolTip Destructors

CXTPToolTipContextToolTip Class, Legend, Public Methods
CXTPToolTipContextToolTip Destructors
Class

CXTPToolTipContextToolTip Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPToolTipContextToolTip | Destroys a CXTPToolTipContextToolTip object, handles cleanup and deallocation


CXTPToolTipContextToolTip::~CXTPToolTipContextToolTip Destructor

CXTPToolTipContextToolTip Destructors, CXTPToolTipContextToolTip Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPToolTipContextToolTip::~CXTPToolTipContextToolTip Destructor

Destroys a CXTPToolTipContextToolTip object, handles cleanup and deallocation

virtual ~CXTPToolTipContextToolTip();
Group

CXTPToolTipContextToolTip Destructors


CXTPTransparentBitmap Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPTransparentBitmap Data Members, CXTPTransparentBitmap Methods, CXTPTransparentBitmap Constructors, CXTPTransparentBitmap Constructors, CXTPTransparentBitmap Data Members, CXTPTransparentBitmap Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTransparentBitmap Class

CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap. Also, this class is used to convert a transparent BitMap into a transparent icon.

Class Hierarchy

class CXTPTransparentBitmap;
File

XTPDrawHelpers.h

Group

Classes

Legend
Data Member
protected
Method
CXTPTransparentBitmap Constructors
CXTPTransparentBitmap Constructors | Description
CXTPTransparentBitmap | Constructor. Construct a new CXTPTransparentBitmap from a handle to an existing BitMap.
CXTPTransparentBitmap Data Members
CXTPTransparentBitmap Data Members | Description
m_hBitmap | A handle to a BtiMap.
CXTPTransparentBitmap Methods
CXTPTransparentBitmap Methods | Description
ConvertToIcon | Call this function to create an icon based on the BitMap.
GetTransparentColor | Call this function to get the transparent color of the BitMap.


CXTPTransparentBitmap Data Members

CXTPTransparentBitmap Class, Legend, Protected Data Members
CXTPTransparentBitmap Data Members
Class

CXTPTransparentBitmap Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hBitmap | A handle to a BtiMap.


CXTPTransparentBitmap::m_hBitmap Data Member

CXTPTransparentBitmap Data Members, CXTPTransparentBitmap Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTransparentBitmap::m_hBitmap Data Member

A handle to a BtiMap.

HBITMAP m_hBitmap;
Group

CXTPTransparentBitmap Data Members


CXTPTransparentBitmap Methods

CXTPTransparentBitmap Class, Legend, Public Methods
CXTPTransparentBitmap Methods
Class

CXTPTransparentBitmap Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
ConvertToIcon | Call this function to create an icon based on the BitMap.
GetTransparentColor | Call this function to get the transparent color of the BitMap.


CXTPTransparentBitmap::ConvertToIcon Method

CXTPTransparentBitmap Methods, CXTPTransparentBitmap Class
CXTPTransparentBitmap::ConvertToIcon Method

Call this function to create an icon based on the BitMap.

HICON ConvertToIcon() const;
Returns

NULL if the BitMap is NULL. NULL if the width or height of the BitMap is 0. Otherwise, a handle to the icon created from the BitMap.

Group

CXTPTransparentBitmap Methods


CXTPTransparentBitmap::GetTransparentColor Method

CXTPTransparentBitmap Methods, CXTPTransparentBitmap Class
CXTPTransparentBitmap::GetTransparentColor Method

Call this function to get the transparent color of the BitMap.

COLORREF GetTransparentColor() const;
Returns

-1 if the BitMap is NULL. Otherwise, a COLORREF that contains the transparent color of the BitMap.

Group

CXTPTransparentBitmap Methods


CXTPTransparentBitmap Constructors

CXTPTransparentBitmap Class, Legend, Public Methods
CXTPTransparentBitmap Constructors
Class

CXTPTransparentBitmap Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTransparentBitmap | Constructor. Construct a new CXTPTransparentBitmap from a handle to an existing BitMap.


CXTPTransparentBitmap::CXTPTransparentBitmap Constructor

CXTPTransparentBitmap Constructors, CXTPTransparentBitmap Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTransparentBitmap::CXTPTransparentBitmap Constructor

Constructor. Construct a new CXTPTransparentBitmap from a handle to an existing BitMap.

CXTPTransparentBitmap(
    HBITMAP hBitmap
);
Parameters

hBitmap
Handle to an existing BitMap.

Group

CXTPTransparentBitmap Constructors


CXTPWindowRect Class

XTPDrawHelpers.h, Classes, Legend, Members, Topics, CXTPWindowRect Constructors, CXTPWindowRect Constructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPWindowRect Class

CXTPWindowRect is a helper class used to retrieve the screen size for a specified window.

Class Hierarchy

class CXTPWindowRect : public CRect;
File

XTPDrawHelpers.h

Group

Classes

Legend
Constructor
CXTPWindowRect Constructors
CXTPWindowRect Constructors | Description
CXTPWindowRect |


CXTPWindowRect Constructors

CXTPWindowRect Class, Legend, Public Methods
CXTPWindowRect Constructors
Class

CXTPWindowRect Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPWindowRect |


CXTPWindowRect Constructor

CXTPWindowRect Constructors
CXTPWindowRect Constructor
Overload List
Constructors
Constructor | Description
CXTPWindowRect::CXTPWindowRect (HWND) | Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.
CXTPWindowRect::CXTPWindowRect (const CWnd*) | Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.
Group

CXTPWindowRect Constructors


CXTPWindowRect::CXTPWindowRect Constructor (HWND)

CXTPWindowRect Constructor, CXTPWindowRect Class
CXTPWindowRect::CXTPWindowRect Constructor (HWND)

Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.

CXTPWindowRect(
    HWND hWnd
);
CXTPWindowRect(
    const CWnd* pWnd
);
Parameters

hWnd
Handle to the window to retrieve the screen size for.
pWnd
Points to the window to retrieve the screen size for.

Group

CXTPWindowRect Constructor


CXTPWinThemeWrapper Class

XTPWinThemeWrapper.h, Classes, Legend, Members, Topics, CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Constructors, CXTPWinThemeWrapper Destructors, CXTPWinThemeWrapper Constructors, CXTPWinThemeWrapper Destructors, CXTPWinThemeWrapper Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPWinThemeWrapper Class

The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API. You can use this class for rendering Windows XP themes for owner drawn controls.

Class Hierarchy

class CXTPWinThemeWrapper;
File

XTPWinThemeWrapper.h

Group

Classes

Legend
Method
virtual
CXTPWinThemeWrapper Constructors
CXTPWinThemeWrapper Constructors | Description
CXTPWinThemeWrapper | Constructs a CXTPWinThemeWrapper object.
CXTPWinThemeWrapper Destructors
CXTPWinThemeWrapper Destructors | Description
~CXTPWinThemeWrapper | Destroys a CXTPWinThemeWrapper object, handles cleanup and deallocation.
CXTPWinThemeWrapper Methods
CXTPWinThemeWrapper Methods | Description
BeginBufferedPaint | Begins a buffered paint operation
CloseThemeData | Closes the theme data handle. CXTPWinThemeWrapper will do this automatically when destroyed or when OpenThemeData is called. Your window should handle the WM_THEMECHANGED message when called followed by a call to OpenThemeData.
DrawThemeBackground | Draws the theme-specified border and fill for the "iPartId" and "iStateId". This could be based on a bitmap file, a border and fill, or other image description.
DrawThemeBackgroundEx | Draws the theme-specified border and fill for the "iPartId" and "iStateId". This could be based on a bitmap file, a border and fill, or other image description.
DrawThemeEdge | Similar to the DrawEdge() API, but uses part colors and is high-DPI aware
DrawThemeIcon | Draws an image within an imagelist based on a (possible) theme-defined effect.
DrawThemeParentBackground | Used by partially-transparent or alpha-blended child controls to draw the part of their parent that they appear in front of.
DrawThemeText | Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".
DrawThemeTextEx | Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".
EnableThemeDialogTexture | Enables/disables dialog background theme. This method can be used to tailor dialog compatibility with child windows and controls that may or may not coordinate the rendering of their client area backgrounds with that of their parent dialog in a manner that supports seamless background texturing.
EnableTheming | Enables or disables theming for the current user in the current and future sessions.
EndBufferedPaint | Completes a buffered paint operation and frees the associated buffered paint handle
GetCurrentThemeName | Get the name of the current theme in-use. Optionally, return the ColorScheme name and the Size name of the theme.
GetThemeAppProperties | Retrieves the property flags that control how visual styles are applied in the current application.
GetThemeBackgroundContentRect | Gets the size of the content for the theme-defined background. This is usually the area inside the borders or Margins.
GetThemeBackgroundExtent | Calculates the size/location of the theme-specified background based on the "pContentRect".
GetThemeBackgroundRegion | Computes the region for a regular or partially transparent theme-specified background that is bound by the specified "pRect". If the rectangle is empty, sets the hRgn to NULL and return S_FALSE.
GetThemeBool | Get the value for the specified BOOL property
GetThemeColor | Get the value for the specified COLOR property
GetThemeDocumentationProperty | Get the value for the specified property name from the [documentation] section of the themes.ini file for the specified theme. If the property has been localized in the theme files string table, the localized version of the property value is returned.
GetThemeEnumValue | Get the value for the specified ENUM property
GetThemeFilename | Get the value for the specified FILENAME property.
GetThemeFont | Get the value for the specified font property
GetThemeInt | Get the value for the specified int property
GetThemeIntList | Get the value for the specified INTLIST struct
GetThemeMargins | Get the value for the specified MARGINS property
GetThemeMetric | Get the value for the specified metric/size property
GetThemePartSize | Returns the specified size of the theme part
GetThemePosition | Get the value for the specified position property
GetThemePropertyOrigin | Searches for the specified theme property and sets "pOrigin" to indicate where it was found (or not found)
GetThemeRect | Get the value for the specified RECT property
GetThemeString | Get the value for the specified string property
GetThemeSysBool | Get the boolean value of specified System metric.
GetThemeSysColor | Get the value of the specified System color.
GetThemeSysColorBrush | Get the brush for the specified System color.
GetThemeSysFont | Get the LOGFONT for the specified System font.
GetThemeSysInt | Get the value of specified System int.
GetThemeSysSize | Get the value of the specified System size metric. (scaled for the current logical screen dpi)
GetThemeSysString | Get the value of specified System string metric.
GetThemeTextExtent | Calculates the size/location of the specified text when rendered in the Theme Font.
GetThemeTextMetrics | Returns info about the theme-specified font for the part/ state passed in.
GetWindowTheme | If window is themed, returns its most recent HTHEME from OpenThemeData() - Otherwise, returns NULL.
HitTestThemeBackground | Returns a HitTestCode (a subset of the values returned by WM_NCHITTEST) for the point "ptTest" within the theme- specified background (bound by pRect). "pRect" and "ptTest" should both be in the same coordinate system (client, screen, etc).
IsAppThemed | Reports whether the current application's user interface displays using visual styles.
IsAppThemeReady | Call this member function to determine if the application should display Windows XP themes. IsAppThemeReady() will first check to see if the operating system supports Windows XP theme display, then checks to see if the application has any controls that are able to display Windows XP themes, then finally checks to see if the application has included a manifest file.
IsThemeActive | Can be used to test if a system theme is active for the current user session. use the API "IsAppThemed()" to test if a theme is active for the calling process.
IsThemeBackgroundPartiallyTransparent | Returns TRUE if the theme specified background for the part/ state has transparent pieces or alpha-blended pieces.
IsThemeDialogTextureEnabled | Reports whether the dialog supports background texturing.
IsThemePartDefined | Returns TRUE if the theme has defined parameters for the specified "iPartID" and "iStateID".
OpenThemeData | Open the theme data for the specified HWND and semi-colon separated list of class names. OpenThemeData() will try each class name, one at a time, and use the first matching theme info found.
SetThemeAppProperties | Sets the flags that control theming within the app
SetThemeWrapperPtr | This method is used to set user defined wrappers
SetWindowTheme | Redirects an existing Window to use a different section of the current theme information than its class normally asks for.
ThemeAppProperties | Retrieves the property flags that control how visual styles are applied in the current application.
ThemeDataOpen | Call this member function to determine if OpenThemeData() was called to open theme information for a particular window.


CXTPWinThemeWrapper Methods

CXTPWinThemeWrapper Class, Legend, Public Methods
CXTPWinThemeWrapper Methods
Class

CXTPWinThemeWrapper Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
BeginBufferedPaint | Begins a buffered paint operation
CloseThemeData | Closes the theme data handle. CXTPWinThemeWrapper will do this automatically when destroyed or when OpenThemeData is called. Your window should handle the WM_THEMECHANGED message when called followed by a call to OpenThemeData.
DrawThemeBackground | Draws the theme-specified border and fill for the "iPartId" and "iStateId". This could be based on a bitmap file, a border and fill, or other image description.
DrawThemeBackgroundEx | Draws the theme-specified border and fill for the "iPartId" and "iStateId". This could be based on a bitmap file, a border and fill, or other image description.
DrawThemeEdge | Similar to the DrawEdge() API, but uses part colors and is high-DPI aware
DrawThemeIcon | Draws an image within an imagelist based on a (possible) theme-defined effect.
DrawThemeParentBackground | Used by partially-transparent or alpha-blended child controls to draw the part of their parent that they appear in front of.
DrawThemeText | Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".
DrawThemeTextEx | Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".
EnableThemeDialogTexture | Enables/disables dialog background theme. This method can be used to tailor dialog compatibility with child windows and controls that may or may not coordinate the rendering of their client area backgrounds with that of their parent dialog in a manner that supports seamless background texturing.
EnableTheming | Enables or disables theming for the current user in the current and future sessions.
EndBufferedPaint | Completes a buffered paint operation and frees the associated buffered paint handle
GetCurrentThemeName | Get the name of the current theme in-use. Optionally, return the ColorScheme name and the Size name of the theme.
GetThemeAppProperties | Retrieves the property flags that control how visual styles are applied in the current application.
GetThemeBackgroundContentRect | Gets the size of the content for the theme-defined background. This is usually the area inside the borders or Margins.
GetThemeBackgroundExtent | Calculates the size/location of the theme-specified background based on the "pContentRect".
GetThemeBackgroundRegion | Computes the region for a regular or partially transparent theme-specified background that is bound by the specified "pRect". If the rectangle is empty, sets the hRgn to NULL and return S_FALSE.
GetThemeBool | Get the value for the specified BOOL property
GetThemeColor | Get the value for the specified COLOR property
GetThemeDocumentationProperty | Get the value for the specified property name from the [documentation] section of the themes.ini file for the specified theme. If the property has been localized in the theme files string table, the localized version of the property value is returned.
GetThemeEnumValue | Get the value for the specified ENUM property
GetThemeFilename | Get the value for the specified FILENAME property.
GetThemeFont | Get the value for the specified font property
GetThemeInt | Get the value for the specified int property
GetThemeIntList | Get the value for the specified INTLIST struct
GetThemeMargins | Get the value for the specified MARGINS property
GetThemeMetric | Get the value for the specified metric/size property
GetThemePartSize | Returns the specified size of the theme part
GetThemePosition | Get the value for the specified position property
GetThemePropertyOrigin | Searches for the specified theme property and sets "pOrigin" to indicate where it was found (or not found)
GetThemeRect | Get the value for the specified RECT property
GetThemeString | Get the value for the specified string property
GetThemeSysBool | Get the boolean value of specified System metric.
GetThemeSysColor | Get the value of the specified System color.
GetThemeSysColorBrush | Get the brush for the specified System color.
GetThemeSysFont | Get the LOGFONT for the specified System font.
GetThemeSysInt | Get the value of specified System int.
GetThemeSysSize | Get the value of the specified System size metric. (scaled for the current logical screen dpi)
GetThemeSysString | Get the value of specified System string metric.
GetThemeTextExtent | Calculates the size/location of the specified text when rendered in the Theme Font.
GetThemeTextMetrics | Returns info about the theme-specified font for the part/ state passed in.
GetWindowTheme | If window is themed, returns its most recent HTHEME from OpenThemeData() - Otherwise, returns NULL.
HitTestThemeBackground | Returns a HitTestCode (a subset of the values returned by WM_NCHITTEST) for the point "ptTest" within the theme- specified background (bound by pRect). "pRect" and "ptTest" should both be in the same coordinate system (client, screen, etc).
IsAppThemed | Reports whether the current application's user interface displays using visual styles.
IsAppThemeReady | Call this member function to determine if the application should display Windows XP themes. IsAppThemeReady() will first check to see if the operating system supports Windows XP theme display, then checks to see if the application has any controls that are able to display Windows XP themes, then finally checks to see if the application has included a manifest file.
IsThemeActive | Can be used to test if a system theme is active for the current user session. use the API "IsAppThemed()" to test if a theme is active for the calling process.
IsThemeBackgroundPartiallyTransparent | Returns TRUE if the theme specified background for the part/ state has transparent pieces or alpha-blended pieces.
IsThemeDialogTextureEnabled | Reports whether the dialog supports background texturing.
IsThemePartDefined | Returns TRUE if the theme has defined parameters for the specified "iPartID" and "iStateID".
OpenThemeData | Open the theme data for the specified HWND and semi-colon separated list of class names. OpenThemeData() will try each class name, one at a time, and use the first matching theme info found.
SetThemeAppProperties | Sets the flags that control theming within the app
SetThemeWrapperPtr | This method is used to set user defined wrappers
SetWindowTheme | Redirects an existing Window to use a different section of the current theme information than its class normally asks for.
ThemeAppProperties | Retrieves the property flags that control how visual styles are applied in the current application.
ThemeDataOpen | Call this member function to determine if OpenThemeData() was called to open theme information for a particular window.


CXTPWinThemeWrapper::BeginBufferedPaint Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPWinThemeWrapper::BeginBufferedPaint Method

Begins a buffered paint operation

HPAINTBUFFER BeginBufferedPaint(
    HDC hdcTarget,
    const RECT* prcTarget,
    XTP_UX_BUFFERFORMAT dwFormat,
    XTP_UX_PAINTPARAMS * pPaintParams,
    HDC * phdc
);
Parameters

hdcTarget
Handle of the target device context (DC) on which the buffer will be painted.
prcTarget
Pointer to a RECT structure that specifies the area of the target DC in which to paint.
dwFormat
A member of the BP_BUFFERFORMAT enumeration that specifies the format of the buffer.
pPaintParams
[in] Pointer to a BP_PAINTPARAMS structure that defines the paint operation parameters. This value can be NULL.
phdc
[out] When this function returns, this value points to the handle of the new device context.

Returns

A handle to the buffered paint context

See Also

EndBufferedPaint

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::CloseThemeData Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::CloseThemeData Method

Closes the theme data handle. CXTPWinThemeWrapper will do this automatically when destroyed or when OpenThemeData is called. Your window should handle the WM_THEMECHANGED message when called followed by a call to OpenThemeData.

void CloseThemeData();
Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::DrawThemeBackground Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::DrawThemeBackground Method

Draws the theme-specified border and fill for the "iPartId" and "iStateId". This could be based on a bitmap file, a border and fill, or other image description.

HRESULT DrawThemeBackground(
    HDC hDC,
    int iPartID,
    int iStateID,
    const RECT * pRect,
    const RECT* pClipRect
);
Parameters

hDC
HDC to draw into
iPartID
Part number to draw
iStateID
State number (of the part) to draw
pRect
Defines the size/location of the part
pClipRect
Optional clipping rect (don't draw outside it)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::DrawThemeBackgroundEx Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::DrawThemeBackgroundEx Method

Draws the theme-specified border and fill for the "iPartId" and "iStateId". This could be based on a bitmap file, a border and fill, or other image description.

HRESULT DrawThemeBackgroundEx(
    HDC hDC,
    int iPartID,
    int iStateID,
    const RECT * pRect,
    const PDTBGOPTS pOptions
);
Parameters

hDC
HDC to draw into
iPartID
Part number to draw
iStateID
State number (of the part) to draw
pRect
Defines the size/location of the part
pOptions
Pointer to optional parameters.

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::DrawThemeEdge Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::DrawThemeEdge Method

Similar to the DrawEdge() API, but uses part colors and is high-DPI aware

HRESULT DrawThemeEdge(
    HDC hDC,
    int iPartID,
    int iStateID,
    const RECT * pDestRect,
    UINT uEdge,
    UINT uFlags,
    RECT* pContentRect
);
Parameters

hDC
HDC to draw into
iPartID
Part number to draw.
iStateID
State number of part
pDestRect
The RECT used to draw the line(s)
uEdge
Same as DrawEdge() API
uFlags
Same as DrawEdge() API
pContentRect
Receives the interior rect if (uFlags & BF_ADJUST)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::DrawThemeIcon Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::DrawThemeIcon Method

Draws an image within an imagelist based on a (possible) theme-defined effect.

HRESULT DrawThemeIcon(
    HDC hDC,
    int iPartID,
    int iStateID,
    const RECT* pRect,
    HIMAGELIST himl,
    int iImageIndex
);
Parameters

hDC
HDC to draw into
iPartID
Part number to draw.
iStateID
State number of part
pRect
The RECT to draw the image within
himl
Handle to IMAGELIST
iImageIndex
Index into IMAGELIST (which icon to draw)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::DrawThemeParentBackground Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::DrawThemeParentBackground Method

Used by partially-transparent or alpha-blended child controls to draw the part of their parent that they appear in front of.

HRESULT DrawThemeParentBackground(
    HWND hWnd,
    HDC hDC,
    RECT* pRect
);
Parameters

hWnd
Handle of the child control
hDC
HDC of the child control
pRect
(optional) rect that defines the area to be Drawn (CHILD coordinates)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::DrawThemeText Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::DrawThemeText Method

Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".

HRESULT DrawThemeText(
    HDC hDC,
    int iPartID,
    int iStateID,
    LPCWSTR pszText,
    int iCharCount,
    DWORD dwTextFlags,
    DWORD dwTextFlags2,
    const RECT* pRect
);
Parameters

hDC
HDC to draw into
iPartID
Part number to draw
iStateID
State number (of the part) to draw
pszText
Actual text to draw
iCharCount
Number of chars to draw (-1 for all)
dwTextFlags
Same as DrawText() "uFormat" param
dwTextFlags2
Additional drawing options
pRect
Defines the size/location of the part

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::DrawThemeTextEx Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::DrawThemeTextEx Method

Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".

HRESULT DrawThemeTextEx(
    HDC hdc,
    int iPartId,
    int iStateId,
    LPCWSTR pszText,
    int cchText,
    DWORD dwTextFlags,
    LPRECT pRect,
    const XTP_UX_DTTOPTS * pOptions
);
Parameters

iPartId
Part number to draw
iStateId
State number (of the part) to draw
pszText
Actual text to draw
cchText
Number of chars to draw (-1 for all)
dwTextFlags
Same as DrawText() "uFormat" param
pRect
Defines the size/location of the part
pOptions
Additional drawing options
hDC
HDC to draw into

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::EnableThemeDialogTexture Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::EnableThemeDialogTexture Method

Enables/disables dialog background theme. This method can be used to tailor dialog compatibility with child windows and controls that may or may not coordinate the rendering of their client area backgrounds with that of their parent dialog in a manner that supports seamless background texturing.

HRESULT EnableThemeDialogTexture(
    HWND hWnd,
    DWORD dwFlags
);
Parameters

hWnd
The window handle of the target dialog
dwFlags
ETDT_ENABLE to enable the theme-defined dialog background texturing, ETDT_DISABLE to disable background texturing, ETDT_ENABLETAB to enable the theme-defined background texturing using the Tab texture

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::EnableTheming Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::EnableTheming Method

Enables or disables theming for the current user in the current and future sessions.

HRESULT EnableTheming(
    BOOL bEnable
);
Parameters

bEnable
If FALSE, disable theming & turn themes off. if TRUE, enable theming and, if user previously had a theme active, make it active now.

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::EndBufferedPaint Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPWinThemeWrapper::EndBufferedPaint Method

Completes a buffered paint operation and frees the associated buffered paint handle

void EndBufferedPaint(
    HPAINTBUFFER hBufferedPaint,
    BOOL fUpdateTarget
);
Parameters

hBufferedPaint
Handle of the buffered paint context, obtained through BeginBufferedPaint
fUpdateTarget
TRUE to copy the buffer to the target device context (DC)

See Also

BeginBufferedPaint

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetCurrentThemeName Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetCurrentThemeName Method

Get the name of the current theme in-use. Optionally, return the ColorScheme name and the Size name of the theme.

HRESULT GetCurrentThemeName(
    LPWSTR pszThemeFileName,
    int dwMaxNameChars,
    LPWSTR pszColorBuff,
    int cchMaxColorChars,
    LPWSTR pszSizeBuff,
    int cchMaxSizeChars
);
Parameters

pszThemeFileName
Receives the theme path & filename
dwMaxNameChars
Max chars allowed in pszNameBuff
pszColorBuff
(optional) receives the canonical color scheme name (not the display name)
cchMaxColorChars
Max chars allowed in pszColorBuff
pszSizeBuff
(optional) receives the canonical size name (not the display name)
cchMaxSizeChars
Max chars allowed in pszSizeBuff

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeAppProperties Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeAppProperties Method

Retrieves the property flags that control how visual styles are applied in the current application.

DWORD GetThemeAppProperties();
Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeBackgroundContentRect Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeBackgroundContentRect Method

Gets the size of the content for the theme-defined background. This is usually the area inside the borders or Margins.

HRESULT GetThemeBackgroundContentRect(
    HDC hDC,
    int iPartID,
    int iStateID,
    const RECT * pBoundingRect,
    RECT* pContentRect
);
Parameters

hDC
(optional) device content to be used for drawing
iPartID
Part number to draw
iStateID
State number (of the part) to draw
pBoundingRect
The outer RECT of the part being drawn
pContentRect
RECT to receive the content area

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeBackgroundExtent Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeBackgroundExtent Method

Calculates the size/location of the theme-specified background based on the "pContentRect".

HRESULT GetThemeBackgroundExtent(
    HDC hDC,
    int iPartID,
    int iStateID,
    const RECT * pContentRect,
    RECT* pExtentRect
);
Parameters

hDC
(optional) device content to be used for drawing
iPartID
Part number to draw
iStateID
State number (of the part) to draw
pContentRect
RECT that defines the content area
pExtentRect
RECT to receive the overall size/location of part

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeBackgroundRegion Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeBackgroundRegion Method

Computes the region for a regular or partially transparent theme-specified background that is bound by the specified "pRect". If the rectangle is empty, sets the hRgn to NULL and return S_FALSE.

HRESULT GetThemeBackgroundRegion(
    HDC hDC,
    int iPartID,
    int iStateID,
    const RECT * pRect,
    HRGN* pRegion
);
Parameters

hDC
Optional hDC to draw into (DPI scaling)
iPartID
Part number to draw.
iStateID
State number (of the part)
pRect
The RECT used to draw the part
pRegion
Receives handle to calculated region

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeBool Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeBool Method

Get the value for the specified BOOL property

HRESULT GetThemeBool(
    int iPartID,
    int iStateID,
    int iPropID,
    BOOL* pfVal
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
pfVal
Receives the value of the property

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeColor Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeColor Method

Get the value for the specified COLOR property

HRESULT GetThemeColor(
    int iPartID,
    int iStateID,
    int iPropID,
    COLORREF* pColor
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
pColor
Receives the value of the property

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeDocumentationProperty Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeDocumentationProperty Method

Get the value for the specified property name from the [documentation] section of the themes.ini file for the specified theme. If the property has been localized in the theme files string table, the localized version of the property value is returned.

HRESULT GetThemeDocumentationProperty(
    LPCWSTR pszThemeName,
    LPCWSTR pszPropertyName,
    LPWSTR pszValueBuff,
    int cchMaxValChars
);
Parameters

pszThemeName
Filename of the theme file to query
pszPropertyName
Name of the string property to retrieve a value for
pszValueBuff
Receives the property string value
cchMaxValChars
Max chars allowed in pszValueBuff

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeEnumValue Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeEnumValue Method

Get the value for the specified ENUM property

HRESULT GetThemeEnumValue(
    int iPartID,
    int iStateID,
    int iPropID,
    int* piVal
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
piVal
Receives the value of the enum (cast to int*)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeFilename Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeFilename Method

Get the value for the specified FILENAME property.

HRESULT GetThemeFilename(
    int iPartID,
    int iStateID,
    int iPropID,
    LPWSTR pszThemeFilename,
    int cchMaxBuffChars
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to search for
pszThemeFilename
Output buffer to receive the filename
cchMaxBuffChars
The size of the return buffer, in chars

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeFont Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeFont Method

Get the value for the specified font property

HRESULT GetThemeFont(
    HDC hDC,
    int iPartID,
    int iStateID,
    int iPropID,
    LOGFONT* pFont
);
Parameters

hDC
(optional) hDC to be drawn to (DPI scaling)
iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
pFont
Receives the value of the LOGFONT property (scaled for the current logical screen dpi)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeInt Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeInt Method

Get the value for the specified int property

HRESULT GetThemeInt(
    int iPartID,
    int iStateID,
    int iPropID,
    int* piVal
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
piVal
Receives the value of the property

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeIntList Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeIntList Method

Get the value for the specified INTLIST struct

HRESULT GetThemeIntList(
    int iPartID,
    int iStateID,
    int iPropID,
    INTLIST* pIntList
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
pIntList
Receives the value of the INTLIST property

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeMargins Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeMargins Method

Get the value for the specified MARGINS property

HRESULT GetThemeMargins(
    HDC hDC,
    int iPartID,
    int iStateID,
    int iPropID,
    RECT * pRect,
    MARGINS* pMargins
);
Parameters

hDC
(optional) hDC to be used for drawing
iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
pRect
RECT for area to be drawn into
pMargins
Receives the value of the MARGINS property

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeMetric Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeMetric Method

Get the value for the specified metric/size property

HRESULT GetThemeMetric(
    HDC hDC,
    int iPartID,
    int iStateID,
    int iPropID,
    int* piVal
);
Parameters

hDC
(optional) hDC to be drawn into (DPI scaling)
iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
piVal
Receives the value of the property

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemePartSize Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemePartSize Method

Returns the specified size of the theme part

HRESULT GetThemePartSize(
    HDC hDC,
    int iPartID,
    int iStateID,
    RECT * pRect,
    THEMESIZE eSize,
    SIZE* pSize
);
Parameters

hDC
HDC to select font into & measure against
iPartID
Part number to retrieve size for
iStateID
State number (of the part)
pRect
(optional) rect for part drawing destination
eSize
The type of size to be retrieved
pSize
Receives the specified size of the part

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemePosition Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemePosition Method

Get the value for the specified position property

HRESULT GetThemePosition(
    int iPartID,
    int iStateID,
    int iPropID,
    POINT* pPoint
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
pPoint
Receives the value of the position property

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemePropertyOrigin Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemePropertyOrigin Method

Searches for the specified theme property and sets "pOrigin" to indicate where it was found (or not found)

HRESULT GetThemePropertyOrigin(
    int iPartID,
    int iStateID,
    int iPropID,
    PROPERTYORIGIN* pOrigin
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to search for
pOrigin
Receives the value of the property origin

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeRect Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeRect Method

Get the value for the specified RECT property

HRESULT GetThemeRect(
    int iPartID,
    int iStateID,
    int iPropID,
    RECT* pRect
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
pRect
Receives the value of the RECT property

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeString Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeString Method

Get the value for the specified string property

HRESULT GetThemeString(
    int iPartID,
    int iStateID,
    int iPropID,
    LPWSTR pszBuff,
    int cchMaxBuffChars
);
Parameters

iPartID
Part number
iStateID
State number of part
iPropID
The property number to get the value for
pszBuff
Receives the string property value
cchMaxBuffChars
Max. number of chars allowed in pszBuff

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeSysBool Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeSysBool Method

Get the boolean value of specified System metric.

BOOL GetThemeSysBool(
    int iBoolID
);
Parameters

iBoolID
The TMT_XXX BOOL number (first BOOL is TMT_FLATMENUS)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeSysColor Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeSysColor Method

Get the value of the specified System color.

COLORREF GetThemeSysColor(
    int iColorID
);
Parameters

iColorID
The system color index defined in winuser.h

Returns

The value of the specified system color.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeSysColorBrush Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeSysColorBrush Method

Get the brush for the specified System color.

HBRUSH GetThemeSysColorBrush(
    int iColorID
);
Parameters

iColorID
The system color index defined in winuser.h

Returns

Handle to brush data.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeSysFont Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeSysFont Method

Get the LOGFONT for the specified System font.

HRESULT GetThemeSysFont(
    int iFontID,
    LOGFONT* pLF
);
Parameters

iFontID
The TMT_XXX font number (first font is TMT_CAPTIONFONT)
pLF
Ptr to LOGFONT to receive the font value. (scaled for the current logical screen dpi)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeSysInt Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeSysInt Method

Get the value of specified System int.

HRESULT GetThemeSysInt(
    int iIntID,
    int* piValue
);
Parameters

iIntID
Must be one of the following values: TMT_DPIX TMT_DPIY TMT_MINCOLORDEPTH
piValue
Ptr to int to receive value

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeSysSize Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeSysSize Method

Get the value of the specified System size metric. (scaled for the current logical screen dpi)

int GetThemeSysSize(
    int iSizeID
);
Parameters

iSizeID
The following values are supported: SM_CXBORDER (border width) SM_CXVSCROLL (scrollbar width) SM_CYHSCROLL (scrollbar height) SM_CXSIZE (caption width) SM_CYSIZE (caption height) SM_CXSMSIZE (small caption width) SM_CYSMSIZE (small caption height) SM_CXMENUSIZE (menubar width) SM_CYMENUSIZE (menubar height)

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeSysString Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeSysString Method

Get the value of specified System string metric.

HRESULT GetThemeSysString(
    int iStringID,
    LPWSTR pszStringBuff,
    int cchMaxStringChars
);
Parameters

iStringID
Must be one of the following values: TMT_CSSNAME TMT_XMLNAME
pszStringBuff
The buffer to receive the string value
cchMaxStringChars
Max. number of chars that pszStringBuff can hold

Returns

The size in dots per inch (DPI) scaled for the current logical screen.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeTextExtent Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeTextExtent Method

Calculates the size/location of the specified text when rendered in the Theme Font.

HRESULT GetThemeTextExtent(
    HDC hDC,
    int iPartID,
    int iStateID,
    LPCWSTR pszText,
    int iCharCount,
    DWORD dwTextFlags,
    const RECT * pBoundingRect,
    RECT* pExtentRect
);
Parameters

hDC
HDC to select font & measure into
iPartID
Part number to draw.
iStateID
State number (of the part)
pszText
The text to be measured
iCharCount
Number of chars to draw (-1 for all)
dwTextFlags
Same as DrawText() "uFormat" param
pBoundingRect
Optional: to control layout of text
pExtentRect
Receives the RECT for text size/location

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetThemeTextMetrics Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetThemeTextMetrics Method

Returns info about the theme-specified font for the part/ state passed in.

HRESULT GetThemeTextMetrics(
    HDC hDC,
    int iPartID,
    int iStateID,
    TEXTMETRIC* ptm
);
Parameters

hDC
Optional: hDC for screen context
iPartID
Part number to draw.
iStateID
State number (of the part)
ptm
Receives the font info

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::GetWindowTheme Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::GetWindowTheme Method

If window is themed, returns its most recent HTHEME from OpenThemeData() - Otherwise, returns NULL.

HTHEME GetWindowTheme(
    HWND hWnd
);
Parameters

hWnd
The window to get the HTHEME of

Returns

The most recent theme handle from OpenThemeData.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::HitTestThemeBackground Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::HitTestThemeBackground Method

Returns a HitTestCode (a subset of the values returned by WM_NCHITTEST) for the point "ptTest" within the theme- specified background (bound by pRect). "pRect" and "ptTest" should both be in the same coordinate system (client, screen, etc).

HRESULT HitTestThemeBackground(
    HDC hDC,
    int iPartID,
    int iStateID,
    DWORD dwOptions,
    const RECT * pRect,
    HRGN hRgn,
    POINT ptTest,
    WORD* pwHitTestCode
);
Parameters

hDC
HDC to draw into
iPartID
Part number to test against
iStateID
State number (of the part)
dwOptions
HTTB_xxx constants
pRect
The RECT used to draw the part
hRgn
Optional region to use; must be in same coordinates as pRect and pTest.
ptTest
The hit point to be tested
pwHitTestCode
Receives the returned hit test code - One of: HTNOWHERE, HTLEFT, HTTOPLEFT, HTBOTTOMLEFT, HTRIGHT, HTTOPRIGHT, HTBOTTOMRIGHT, HTTOP, HTBOTTOM, HTCLIENT

Returns

Returns S_OK if successful, or an error value otherwise.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::IsAppThemed Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::IsAppThemed Method

Reports whether the current application's user interface displays using visual styles.

BOOL IsAppThemed() const;
Returns

Returns one of the following values. TRUE - The application has a visual style applied. FALSE - The application does not have a visual style applied.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::IsAppThemeReady Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::IsAppThemeReady Method

Call this member function to determine if the application should display Windows XP themes. IsAppThemeReady() will first check to see if the operating system supports Windows XP theme display, then checks to see if the application has any controls that are able to display Windows XP themes, then finally checks to see if the application has included a manifest file.

BOOL IsAppThemeReady() const;
Returns

TRUE if the application can display Windows XP themes, otherwise FALSE.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::IsThemeActive Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::IsThemeActive Method

Can be used to test if a system theme is active for the current user session. use the API "IsAppThemed()" to test if a theme is active for the calling process.

BOOL IsThemeActive() const;
Returns

Returns one of the following values: TRUE - A visual style is enabled, and windows with visual styles applied should call OpenThemeData to start using theme drawing services. FALSE - A visual style is not enabled, and the window message handler does not need to make another call to IsThemeActive until it receives a WM_THEMECHANGED message.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::IsThemeBackgroundPartiallyTransparent Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::IsThemeBackgroundPartiallyTransparent Method

Returns TRUE if the theme specified background for the part/ state has transparent pieces or alpha-blended pieces.

BOOL IsThemeBackgroundPartiallyTransparent(
    int iPartID,
    int iStateID
);
Parameters

iPartID
Part number
iStateID
State number of part

Returns

Returns one of the following values. TRUE - The theme-specified background for a particular iPartId and iStateId has transparent pieces or alpha- blended pieces. FALSE - The theme-specified background for a particular iPartId and iStateId does not have transparent pieces or alpha-blended pieces.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::IsThemeDialogTextureEnabled Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::IsThemeDialogTextureEnabled Method

Reports whether the dialog supports background texturing.

BOOL IsThemeDialogTextureEnabled();
Returns

Returns one of the following values. TRUE - Background texturing is supported. FALSE - Background texturing is not supported.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::IsThemePartDefined Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::IsThemePartDefined Method

Returns TRUE if the theme has defined parameters for the specified "iPartID" and "iStateID".

BOOL IsThemePartDefined(
    int iPartID,
    int iStateID
);
Parameters

iPartID
Part number to find definition for
iStateID
State number of part

Returns

Returns one of the following values. TRUE - The theme has defined parameters for the specified iPartId and iStateId FALSE - The theme does not have defined parameters for the specified iPartId and iStateId

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::OpenThemeData Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::OpenThemeData Method

Open the theme data for the specified HWND and semi-colon separated list of class names. OpenThemeData() will try each class name, one at a time, and use the first matching theme info found.

void OpenThemeData(
    HWND hWnd,
    LPCWSTR pszClassList
);
Parameters

hWnd
Window handle of the control/window to be themed.
pszClassList
Class name (or list of names) to match to theme data section. if the list contains more than one name, the names are tested one at a time for a match. If a match is found, OpenThemeData() returns a theme handle associated with the matching class. This param is a list (instead of just a single class name) to provide the class an opportunity to get the "best" match between the class and the current theme. For example, a button might pass L"OkButton, Button" if its ID=ID_OK. If the current theme has an entry for OkButton, that will be used. Otherwise, we fall back on the normal Button entry.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::SetThemeAppProperties Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::SetThemeAppProperties Method

Sets the flags that control theming within the app

void SetThemeAppProperties(
    DWORD dwFlags
);
Parameters

dwFlags
The flag values to be set

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::SetThemeWrapperPtr Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::SetThemeWrapperPtr Method

This method is used to set user defined wrappers

void SetThemeWrapperPtr(
    int nThemeWrapper,
    LPVOID lpWrapperPtr
);
Parameters

nThemeWrapper
Wrapper id.
lpWrapperPtr
Wrapper pointer

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::SetWindowTheme Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::SetWindowTheme Method

Redirects an existing Window to use a different section of the current theme information than its class normally asks for.

HRESULT SetWindowTheme(
    HWND hWnd,
    LPCWSTR pszSubAppName,
    LPCWSTR pszSubIdList
);
Parameters

hWnd
The handle of the window (cannot be NULL)
pszSubAppName
App (group) name to use in place of the calling app's name. If NULL, the actual calling app name will be used.
pszSubIdList
Semicolon separated list of class Id names to use in place of actual list passed by the window's class. if NULL, the id list from the calling class is used.

Returns

Returns S_OK if successful, or an error value otherwise.

Remarks

The Theme Manager will remember the "pszSubAppName" and the "pszSubIdList" associations thru the lifetime of the window (even if themes are subsequently changed). The window is sent a "WM_THEMECHANGED" msg at the end of this call, so that the new theme can be found and applied. When "pszSubAppName" or "pszSubIdList" are NULL, the Theme Manager removes the previously remember association. To turn off theme-ing for the specified window, you can pass an empty string (L"") so it won't match any section entries.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::ThemeAppProperties Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::ThemeAppProperties Method

Retrieves the property flags that control how visual styles are applied in the current application.

DWORD ThemeAppProperties();
Returns

The following return values are bit flags combined with a logical OR operator. STAP_ALLOW_NONCLIENT - Specifies that the non-client areas of application windows have visual styles applied. STAP_ALLOW_CONTROLS - Specifies that controls in application windows have visual styles applied. STAP_ALLOW_WEBCONTENT - Specifies that all web content displayed in an application is rendered using visual styles.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper::ThemeDataOpen Method

CXTPWinThemeWrapper Methods, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::ThemeDataOpen Method

Call this member function to determine if OpenThemeData() was called to open theme information for a particular window.

BOOL ThemeDataOpen() const;
Returns

TRUE if theme information was loaded, otherwise FALSE.

Group

CXTPWinThemeWrapper Methods


CXTPWinThemeWrapper Constructors

CXTPWinThemeWrapper Class, Legend, Public Methods
CXTPWinThemeWrapper Constructors
Class

CXTPWinThemeWrapper Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPWinThemeWrapper | Constructs a CXTPWinThemeWrapper object.


CXTPWinThemeWrapper::CXTPWinThemeWrapper Constructor

CXTPWinThemeWrapper Constructors, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::CXTPWinThemeWrapper Constructor

Constructs a CXTPWinThemeWrapper object.

CXTPWinThemeWrapper(
    BOOL bUseSkinFramework = TRUE
);
Parameters

bUseSkinFramework
TRUE to use skinframework.

Group

CXTPWinThemeWrapper Constructors


CXTPWinThemeWrapper Destructors

CXTPWinThemeWrapper Class, Legend, Public Methods
CXTPWinThemeWrapper Destructors
Class

CXTPWinThemeWrapper Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPWinThemeWrapper | Destroys a CXTPWinThemeWrapper object, handles cleanup and deallocation.


CXTPWinThemeWrapper::~CXTPWinThemeWrapper Destructor

CXTPWinThemeWrapper Destructors, CXTPWinThemeWrapper Class
CXTPWinThemeWrapper::~CXTPWinThemeWrapper Destructor

Destroys a CXTPWinThemeWrapper object, handles cleanup and deallocation.

virtual ~CXTPWinThemeWrapper();
Group

CXTPWinThemeWrapper Destructors


Functions

Functions, Legend, Common Files
Functions
Functions
Function | Description
GetMSO2003Color | Call this function to get the MS Office color represented by nIndex.
GetXtremeColor | Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetColor for more details.
PX_Blob | Call this function within your class's DoPropExchange member function to serialize BYTE array.
PX_Bool | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Bool | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Bstr | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Byte | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BYTE. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DateTime | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleDateTime. The property's value is read from or written to the variable referenced by dtValue, as appropriate.
PX_Double | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Double | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DWord | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DWord | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Float | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Float | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Int | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Int | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Long | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Long | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Point | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT. The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Rect | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT. The property's value is read from or written to the variable referenced by rcValue, as appropriate. If rcDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_RuntimeClass | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type CRuntimeClass. The property's value is read from or written to the variable referenced by pClass, as appropriate. If pDefaultClass is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Serialize | Call this function within your class's DoPropExchange member function to serialize object.
PX_Short | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Short | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Size | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE. The property's value is read from or written to the variable referenced by szValue, as appropriate. If szDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_String | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_String | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UI8 | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONGLONG. The property's value is read from or written to the variable referenced by ullValue, as appropriate. If ullDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_ULong | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_ULong | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UShort | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UShort | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Variant | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleVariant. The property's value is read from or written to the variable referenced by variant, as appropriate. If variantDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
RefreshXtremeColors | This global function will refresh the display element colors defined in the CXTPColorManager class.
XTPColorManager | Call this function to access CXTPColorManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPColorManager.
XTPDrawHelpers | Call this function to access CXTPDrawHelpers members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPDrawHelpers.
XTPGetPrinterDeviceDefaults | Prepare a printer device context for printing and calculates DEVMODE and DEVNAMES values.
XTPMultiMonitor | Call this function to access CXTPMultiMonitor members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPMultiMonitor.
XTPResourceManager | Call this function to access CXTPResourceManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPResourceManager.
XTPSystemVersion | The XTPSystemVersion function is used for access to the CXTPSystemVersion class.
Module

Common Files

Legend
Method


GetMSO2003Color Function

XTPColorManager.h, Functions, Body Source, Example, See Also
GetMSO2003Color Function

Call this function to get the MS Office color represented by nIndex.

COLORREF GetMSO2003Color(
    UINT nIndex
);
File

XTPColorManager.h

Parameters

nIndex
Specifies the display element whose color is to be retrieved.

Returns

An RGB color value representing the color value of the MS Office color.

See Also

CXTPColorManager::GetColor

Example
switch (XTPColorManager()->GetCurrentSystemTheme())
{
     case xtpSystemThemeBlue:
     case xtpSystemThemeOlive:
     case xtpSystemThemeSilver:
          m_clr3DFacePushed.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT_PUSHED));
          m_clr3DFaceHilite.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT));
          m_clrBtnTextPushed.SetStandardValue(GetMSO2003Color(XPCOLOR_PUSHED_TEXT));
          m_clrBtnTextHilite.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT_TEXT));
          m_clrBorder3DShadow.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT_BORDER));
          m_clrBorder3DHilite.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT_BORDER));
          break;
}
Body Source
COLORREF GetMSO2003Color(UINT nIndex) {
    return XTPColorManager()->GetLunaColor(nIndex);
}
Group

Functions


GetXtremeColor Function

XTPColorManager.h, Functions, Body Source, Example, See Also
GetXtremeColor Function

Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetColor for more details.

COLORREF GetXtremeColor(
    UINT nIndex
);
File

XTPColorManager.h

Parameters

nIndex
Specifies the display element whose color is to be retrieved.

Returns

The red, green, blue (RGB) color value of the given element.

See Also

CXTPColorManager::GetColor

Example
if (eState == xtMouseNormal)
{
    pDC->Draw3dRect(rcItem,
        GetXtremeColor(COLOR_3DFACE),
        GetXtremeColor(COLOR_3DFACE));
}
Body Source
COLORREF GetXtremeColor(UINT nIndex) {
    return XTPColorManager()->GetColor(nIndex);
}
Group

Functions


PX_Blob Function

XTPPropExchange.h, Functions
PX_Blob Function

Call this function within your class's DoPropExchange member function to serialize BYTE array.

BOOL PX_Blob(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    BYTE*& pData,
    DWORD& nBytes
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
pData
Byte array
nBytes
Size of Byte array.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Bool Function

XTPPropExchange.h, Functions
PX_Bool Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Bool(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    BOOL& bValue
);
BOOL PX_Bool(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    BOOL& bValue,
    BOOL bDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
bValue
Reference to the variable where the property is stored (typically a member variable of your class).
bDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Bstr Function

XTPPropExchange.h, Functions
PX_Bstr Function

Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Bstr(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    BSTR& bstrValue,
    BSTR bstrDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
bstrValue
Reference to the variable where the property is stored (typically a member variable of your class).
bstrDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Byte Function

XTPPropExchange.h, Functions
PX_Byte Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BYTE. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Byte(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    BYTE& nValue,
    BYTE nDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
nValue
Reference to the variable where the property is stored (typically a member variable of your class).
nDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_DateTime Function

XTPPropExchange.h, Functions
PX_DateTime Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleDateTime. The property's value is read from or written to the variable referenced by dtValue, as appropriate.

BOOL PX_DateTime(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    COleDateTime& dtValue
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
dtValue
Reference to the variable where the property is stored (typically a member variable of your class).

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Double Function

XTPPropExchange.h, Functions
PX_Double Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Double(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    double& doubleValue
);
BOOL PX_Double(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    double& doubleValue,
    double doubleDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
doubleValue
Reference to the variable where the property is stored (typically a member variable of your class).
doubleDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_DWord Function

XTPPropExchange.h, Functions
PX_DWord Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_DWord(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    DWORD& dwValue
);
BOOL PX_DWord(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    DWORD& dwValue,
    DWORD dwDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
dwValue
Reference to the variable where the property is stored (typically a member variable of your class).
dwDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Float Function

XTPPropExchange.h, Functions
PX_Float Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Float(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    float& floatValue
);
BOOL PX_Float(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    float& floatValue,
    float floatDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
floatValue
Reference to the variable where the property is stored (typically a member variable of your class).
floatDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Int Function

XTPPropExchange.h, Functions
PX_Int Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Int(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    int& nValue
);
BOOL PX_Int(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    int& nValue,
    int nDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
nValue
Reference to the variable where the property is stored (typically a member variable of your class).
nDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Long Function

XTPPropExchange.h, Functions
PX_Long Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Long(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    long& lValue
);
BOOL PX_Long(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    long& lValue,
    long lDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
lValue
Reference to the variable where the property is stored (typically a member variable of your class).
lDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Point Function

XTPPropExchange.h, Functions
PX_Point Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT. The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Point(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    POINT& ptValue,
    POINT ptDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
ptValue
Reference to the variable where the property is stored (typically a member variable of your class).
ptDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Rect Function

XTPPropExchange.h, Functions
PX_Rect Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT. The property's value is read from or written to the variable referenced by rcValue, as appropriate. If rcDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Rect(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    RECT& rcValue,
    RECT rcDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
rcValue
Reference to the variable where the property is stored (typically a member variable of your class).
rcDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_RuntimeClass Function

XTPPropExchange.h, Functions
PX_RuntimeClass Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type CRuntimeClass. The property's value is read from or written to the variable referenced by pClass, as appropriate. If pDefaultClass is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_RuntimeClass(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    CRuntimeClass*& pClass,
    CRuntimeClass* pDefaultClass
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
pClass
Reference to the variable where the property is stored (typically a member variable of your class).
pDefaultClass
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Serialize Function

XTPPropExchange.h, Functions
PX_Serialize Function

Call this function within your class's DoPropExchange member function to serialize object.

BOOL PX_Serialize(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    CObject* pObject
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
pObject
Object you need to serialize

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Short Function

XTPPropExchange.h, Functions
PX_Short Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Short(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    short& sValue
);
BOOL PX_Short(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    short& sValue,
    short sDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
sValue
Reference to the variable where the property is stored (typically a member variable of your class).
sDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Size Function

XTPPropExchange.h, Functions
PX_Size Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE. The property's value is read from or written to the variable referenced by szValue, as appropriate. If szDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Size(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    SIZE& szValue,
    SIZE szDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
szValue
Reference to the variable where the property is stored (typically a member variable of your class).
szDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_String Function

XTPPropExchange.h, Functions
PX_String Function

Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_String(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    CString& strValue
);
BOOL PX_String(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    CString& strValue,
    LPCTSTR lpszDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
strValue
Reference to the variable where the property is stored (typically a member variable of your class).
lpszDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_UI8 Function

XTPPropExchange.h, Functions
PX_UI8 Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONGLONG. The property's value is read from or written to the variable referenced by ullValue, as appropriate. If ullDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_UI8(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    ULONGLONG& ullValue,
    ULONGLONG ullDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
ullValue
Reference to the variable where the property is stored (typically a member variable of your class).
ullDefault
Default value for the property.

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_ULong Function

XTPPropExchange.h, Functions
PX_ULong Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_ULong(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    ULONG& ulValue
);
BOOL PX_ULong(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    ULONG& ulValue,
    ULONG ulDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
ulValue
Reference to the variable where the property is stored (typically a member variable of your class).
ulDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_UShort Function

XTPPropExchange.h, Functions
PX_UShort Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_UShort(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    USHORT& usValue
);
BOOL PX_UShort(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    USHORT& usValue,
    USHORT usDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
usValue
Reference to the variable where the property is stored (typically a member variable of your class).
usDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


PX_Variant Function

XTPPropExchange.h, Functions
PX_Variant Function

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleVariant. The property's value is read from or written to the variable referenced by variant, as appropriate. If variantDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

BOOL PX_Variant(
    CXTPPropExchange* pPX,
    LPCTSTR pszPropName,
    COleVariant& variant,
    COleVariant variantDefault
);
File

XTPPropExchange.h

Parameters

pPX
Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName
The name of the property being exchanged.
variant
Reference to the variable where the property is stored (typically a member variable of your class).
variantDefault
Default value for the property

Returns

Nonzero if the exchange was successful; 0 if unsuccessful.

Group

Functions


RefreshXtremeColors Function

XTPColorManager.h, Functions, See Also
RefreshXtremeColors Function

This global function will refresh the display element colors defined in the CXTPColorManager class.

void RefreshXtremeColors();
File

XTPColorManager.h

See Also

CXTPColorManager::RefreshColors

Group

Functions


XTPColorManager Function

XTPColorManager.h, Functions, Body Source, Example
XTPColorManager Function

Call this function to access CXTPColorManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPColorManager.

CXTPColorManager* XTPColorManager();
File

XTPColorManager.h

Example
COLORREF cr = XTPColorManager()->GetColor(nIndex);
Body Source
CXTPColorManager* XTPColorManager() {
    return &CXTPColorManager::Instance();
}
Group

Functions


XTPDrawHelpers Function

XTPDrawHelpers.h, Functions, Example
XTPDrawHelpers Function

Call this function to access CXTPDrawHelpers members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPDrawHelpers.

CXTPDrawHelpers* XTPDrawHelpers();
File

XTPDrawHelpers.h

Example
BOOL bLowRes = XTPDrawHelpers()->IsLowResolution();
Group

Functions


XTPGetPrinterDeviceDefaults Function

XTPDrawHelpers.h, Functions, See Also
XTPGetPrinterDeviceDefaults Function

Prepare a printer device context for printing and calculates DEVMODE and DEVNAMES values.

BOOL XTPGetPrinterDeviceDefaults(
    HGLOBAL& ref_hDevMode,
    HGLOBAL& ref_hDevNames
);
File

XTPDrawHelpers.h

Parameters

ref_hDevMode
Reference to a handle of a movable global memory object that contains a DEVMODE structure.
ref_hDevNames
Reference to a handle of a movable global memory object that contains a DEVNAMES structure.

Returns

Nonzero if successful; otherwise 0.

See Also

CWinApp::GetPrinterDeviceDefaults, DEVMODE, DEVNAMES

Group

Functions


XTPMultiMonitor Function

XTPSystemHelpers.h, Functions, Example
XTPMultiMonitor Function

Call this function to access CXTPMultiMonitor members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPMultiMonitor.

CXTPMultiMonitor* XTPMultiMonitor();
File

XTPSystemHelpers.h

Example
CRect rcWork = XTPMultiMonitor()->GetWorkArea();
Group

Functions


XTPResourceManager Function

XTPResourceManager.h, Functions, Example
XTPResourceManager Function

Call this function to access CXTPResourceManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPResourceManager.

CXTPResourceManager* XTPResourceManager();
File

XTPResourceManager.h

Example
XTPResourceManager()->LoadString(&m_strNoFieldsAvailable,
    XTP_IDS_REPORT_NOFIELDSAVAILABLE);
Group

Functions


XTPSystemVersion Function

XTPSystemHelpers.h, Functions, Example, See Also
XTPSystemVersion Function

The XTPSystemVersion function is used for access to the CXTPSystemVersion class.

CXTPSystemVersion* XTPSystemVersion();
File

XTPSystemHelpers.h

Returns

A pointer to the one and only CXTPSystemVersion instance.

Remarks

Call this function to access CXTPSystemVersion members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPSystemVersion.

See Also

CXTPSystemVersion

Example

The following example demonstrates the use of XTPSystemVersion.

bool bIsWinNT = XTPSystemVersion()->IsWinNT4();
Group

Functions


Structs, Records, Enums

Enumerations, Legend, Common Files
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPCurrentSystemTheme | Enumeration used to determine the current Windows XP theme in use
XTPImageState | Image state enumerators.
XTPToolTipStyle | Enumeration used to determine styles for tooltips
Module

Common Files

Legend
Enumeration


XTPCurrentSystemTheme Enumeration

XTPColorManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPCurrentSystemTheme Enumeration

Enumeration used to determine the current Windows XP theme in use

enum XTPCurrentSystemTheme {
  xtpSystemThemeUnknown,
  xtpSystemThemeBlue,
  xtpSystemThemeOlive,
  xtpSystemThemeSilver,
  xtpSystemThemeRoyale,
  xtpSystemThemeAero,
  xtpSystemThemeAuto,
  xtpSystemThemeDefault
};
File

XTPColorManager.h

Members

xtpSystemThemeUnknown
No known theme in use
xtpSystemThemeBlue
Luna Blue Windows XP theme in use
xtpSystemThemeOlive
Luna Olive Windows XP theme in use
xtpSystemThemeSilver
Luna Silver Windows XP theme in use
xtpSystemThemeRoyale
Royale Windows XP theme in use
xtpSystemThemeAero
Aero Vista theme in use
xtpSystemThemeAuto
Use OS theme.
xtpSystemThemeDefault
Default theme (xtpSystemThemeAuto)

See Also

CXTPColorManager::GetCurrentSystemTheme

Example
XTPCurrentSystemTheme systemTheme = XTPColorManager()->GetCurrentSystemTheme();

Group

Structs, Records, Enums


XTPImageState Enumeration

XTPImageManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPImageState Enumeration

Image state enumerators.

enum XTPImageState {
  xtpImageNormal,
  xtpImageDisabled,
  xtpImageHot,
  xtpImageChecked,
  xtpImagePressed
};
File

XTPImageManager.h

Members

xtpImageNormal
Normal image.
xtpImageDisabled
Disabled image.
xtpImageHot
Hot image.
xtpImageChecked
Checked(selected) image.
xtpImagePressed
Pressed image.

See Also

CXTPImageManager::SetIcon, CXTPImageManager::SetIcons

Example
// Set Icons
pCommandBars->GetImageManager()->SetIcons(IDR_MAINFRAME, xtpImageNormal);
pCommandBars->GetImageManager()->SetIcons(IDR_MAINFRAME, IDR_MAINFRAME_HOT, xtpImageHot);
Group

Structs, Records, Enums


XTPToolTipStyle Enumeration

XTPToolTipContext.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPToolTipStyle Enumeration

Enumeration used to determine styles for tooltips

enum XTPToolTipStyle {
  xtpToolTipStandard,
  xtpToolTipBalloon,
  xtpToolTipOffice,
  xtpToolTipRTF,
  xtpToolTipLuna,
  xtpToolTipOffice2007,
  xtpToolTipHTML,
  xtpToolTipMarkup
};
File

XTPToolTipContext.h

Members

xtpToolTipStandard
Standard tooltip window style
xtpToolTipBalloon
Balloon tooltip window style
xtpToolTipOffice
Office tooltip window style
xtpToolTipRTF
RTF tooltip window style
xtpToolTipLuna
Luna tooltip window style
xtpToolTipOffice2007
Office 2007 window style
xtpToolTipHTML
HTML tooltip style
xtpToolTipMarkup
HTML tooltip style

See Also

CXTPToolTipContext::SetStyle

Example
pCommandBars->GetToolTipContext()->SetStyle(xtpToolTipBalloon);
Group

Structs, Records, Enums


Macros

Macros, Common Files
Macros
Macros
Macro | Description
SAFE_CALLPTR | Checks object pointer and if not NULL calls a specified function.
SAFE_DELETE | Frees dynamically allocated memory.
SAFE_DELETE_AR | Frees dynamically allocated memory for an array.
SAFE_DELETE_HICON | Destroys an icon and frees any memory the icon occupied.
SAFE_DELETE_OBJ | Destroys a GDI object and frees the handle.
SAFE_RELEASE | Decrements the reference count for the specified object.
XT_ASSERT_MSG | XT_ASSERT_MSG is similar to ASSERT, except that it allows a custom message to be specified.
XTOSVersionInfo | Depricated
Module

Common Files


SAFE_CALLPTR Macro

XTPMacros.h, Macros, Example
SAFE_CALLPTR Macro

Checks object pointer and if not NULL calls a specified function.

#define SAFE_CALLPTR(classPointer, functionName)
File

XTPMacros.h

Parameters

classPointer
Pointer to the class that contains the function to call.
functionName
Name of the function to call.

Remarks

This macro will first check to see if the class specified by classPointer is NULL. If the class is not NULL, the macro calls the function specified by functionName.

Example
 SAFE_CALLPTR(m_pItem, OnConstraintsChanged());
Group

Macros


SAFE_DELETE Macro

XTPMacros.h, Macros, Example
SAFE_DELETE Macro

Frees dynamically allocated memory.

#define SAFE_DELETE(ptr)
File

XTPMacros.h

Parameters

ptr
Points to the memory to free.

Remarks

This macro will first check to see if the block of memory specified by ptr is NULL. If ptr is not NULL, SAFE_DELETE will deallocate the block of memory and set its value to NULL. The pointer argument must refer to a block of memory previously allocated for an object created with the new operator.

Example
CName* pName = new CName;          // Allocate memory for the object
pName->SetName("Firstname", "Lastname");
SAFE_DELETE(pName);                // Deallocate memory for the object
ASSERT(pName == NULL);
Group

Macros


SAFE_DELETE_AR Macro

XTPMacros.h, Macros, Example
SAFE_DELETE_AR Macro

Frees dynamically allocated memory for an array.

#define SAFE_DELETE_AR(ptr)
File

XTPMacros.h

Parameters

ptr
Points to the memory array to free.

Remarks

This macro will first check to see if the block of memory specified by ptr is NULL. If ptr is not NULL, SAFE_DELETE_AR will deallocate the block of memory and set its value to NULL. The pointer argument must refer to a block of memory previously allocated for an object created with the new operator.

Example
char* pCharArray = new char[256];  // Allocate memory for the array
strcpy(pCharArray, "Array of characters");
SAFE_DELETE_AR(pCharArray);        // Deallocate memory for the array
ASSERT(pCharArray == NULL);
Group

Macros


SAFE_DELETE_HICON Macro

XTPMacros.h, Macros, Example
SAFE_DELETE_HICON Macro

Destroys an icon and frees any memory the icon occupied.

#define SAFE_DELETE_HICON(hIcon)
File

XTPMacros.h

Parameters

hIcon
Handle to the icon to free.

Remarks

This macro will first check to see if the icon handle specified by hIcon is NULL. If hIcon is not NULL, SAFE_DELETE_HICON will destroy the icon handle and set its value to NULL.

Example
HICON hIcon = XTPResourceManager()->LoadIcon(
    MAKEINTRESOURCE(dwID), item.size);
::DrawIconEx(pDC->GetSafeHdc(), point.x, point.y, hIcon,
    size.cx, size.cy, 0, NULL, DI_NORMAL);
SAFE_DELETE_HICON(hIcon);
ASSERT(hIcon == NULL);
Group

Macros


SAFE_DELETE_OBJ Macro

XTPMacros.h, Macros, Example
SAFE_DELETE_OBJ Macro

Destroys a GDI object and frees the handle.

#define SAFE_DELETE_OBJ(obj)
File

XTPMacros.h

Parameters

obj
Handle to the GDI object free.

Remarks

This macro will first check to see if the GDI object specified by obj is NULL. If obj is not NULL, SAFE_DELETE_OBJ will delete the GDI object and set its value to NULL.

Example
extern CFont m_font;
extern LOGFONT lf;
SAFE_DELETE_OBJ(m_font);
m_font.CreateFontIndirect(&lf);
Group

Macros


SAFE_RELEASE Macro

XTPMacros.h, Macros, See Also
SAFE_RELEASE Macro

Decrements the reference count for the specified object.

#define SAFE_RELEASE(comPointer)
File

XTPMacros.h

Parameters

comPointer
Points to the COM object to release.

Remarks

This macro will first check to see if the COM object specified by comPointer is NULL. If the object is not NULL, the macro calls IUnknown::Release COM object specified by comPointer and set its value to NULL.

See Also

IUnknown::Release

Group

Macros


XT_ASSERT_MSG Macro

XTPMacros.h, Macros, Example, See Also
XT_ASSERT_MSG Macro

XT_ASSERT_MSG is similar to ASSERT, except that it allows a custom message to be specified.

#define XT_ASSERT_MSG(exp, msg)
File

XTPMacros.h

Parameters

exp
Specifies an expression (including pointer values) that evaluates to nonzero or 0.
msg
Specifies a NULL terminated user defined string of the message to display to the user.

Remarks

Evaluates its argument. If the result is 0, the macro prints a diagnostic message and aborts the program. If the condition is nonzero, it does nothing.

The diagnostic message has the form "assertion failed in file name in line num.

where name is the name of the source file, and num is the line number of the assertion that failed in the source file.

In the Release version of MFC, XT_ASSERT_MSG does not evaluate the expression and thus will not interrupt the program. If the expression must be evaluated regardless of environment, use the VERIFY macro in place of XT_ASSERT_MSG.

Note This function is available only in the Debug version of MFC.

See Also

ASSERT, VERIFY

Example
// example for XT_ASSERT_MSG
CAge* pAge = new CAge(21); // CAge is derived from CObject.

// Terminates program only if pAge is NOT a CAge*.
XT_ASSERT_MSG(pAge!= NULL, _T("Failed to allocate memory."));
XT_ASSERT_MSG(pAge->IsKindOf(RUNTIME_CLASS(CAge)), _T("This is not a CAge object."));
Group

Macros


XTOSVersionInfo Macro

XTPSystemHelpers.h, Macros
XTOSVersionInfo Macro

Depricated

#define XTOSVersionInfo XTPSystemVersion
File

XTPSystemHelpers.h

Group

Macros


Files

Files, Common Files
Files
Files
File | Description
XTMaskEditT.h | XTMaskEditT.h interface for the CXTMaskEditT class.
XTPColorManager.h | XTPColorManager.h: interface for the CXTPColorManager class.
XTPDrawHelpers.h | XTPDrawHelpers.h: interface for the CXTPDrawHelpers class.
XTPImageManager.h | XTPImageManager.h : interface for the CXTPImageManager class.
XTPMacros.h | XTPMacros.h : common macros This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPPropExchange.h | XTPPropExchange.h: interface for the CXTPPropExchange class.
XTPResourceManager.h | XTPResourceManager.h: interface for the CXTPResourceManager class.
XTPSystemHelpers.h | XTPSystemHelpers This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPToolTipContext.h | XTPToolTipContext.h: interface for the CXTPToolTipContext class.
XTPWinThemeWrapper.h | XTPWinThemeWrapper.h: interface for the CXTPWinThemeWrapper class.
Module

Common Files


XTMaskEditT.h

Files, Legend, Templates
XTMaskEditT.h

XTMaskEditT.h interface for the CXTMaskEditT class.

Group

Files

Templates
Template | Description
CXTMaskEditT | CXTMaskEditT is a template class. It allows text masking to be applied to the control to format it for special editing restrictions.
Legend
Template


XTPColorManager.h

Classes, Enumerations, Functions, Files, Legend, Variables
XTPColorManager.h

XTPColorManager.h: interface for the CXTPColorManager class.

Classes
Class | Description
CXTPColorManager | CXTPColorManager is a stand alone class. This object is used for manipulation of RGB values.
CXTPPaintManagerColor | The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and application defined colors.
CXTPPaintManagerColorGradient | The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and dark gradient colors.
Enumerations
Enumeration | Description
XTPCurrentSystemTheme | Enumeration used to determine the current Windows XP theme in use
Functions
Function | Description
GetMSO2003Color | Call this function to get the MS Office color represented by nIndex.
GetXtremeColor | Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetColor for more details.
RefreshXtremeColors | This global function will refresh the display element colors defined in the CXTPColorManager class.
XTPColorManager | Call this function to access CXTPColorManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPColorManager.
Group

Files

Variables
Variable | Description
XPCOLOR_3DFACE | Retrieves the current color of the specified XP display element.
XPCOLOR_3DSHADOW | Retrieves the current color of the specified XP display element.
XPCOLOR_BASE | Retrieves the current color of the specified XP display element.
XPCOLOR_CHECKED_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_DISABLED | Retrieves the current color of the specified XP display element.
XPCOLOR_EDITCTRLBORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_FLOATBAR_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_FRAME | Retrieves the current color of the specified XP display element.
XPCOLOR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_CHECKED | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_CHECKED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_DISABLED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_PUSHED | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_PUSHED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_ICONSHADDOW | Retrieves the current color of the specified XP display element.
XPCOLOR_LABEL | Retrieves the current color of the specified XP display element.
XPCOLOR_LAST | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_EXPANDED | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_PUSHED_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_SEPARATOR | Retrieves the current color of the specified XP display element.
XPCOLOR_SHADOW_FACTOR | Retrieves the current color of the specified XP display element.
XPCOLOR_SPLITTER_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_STATICFRAME | Retrieves the current color of the specified XP display element.
XPCOLOR_TAB_INACTIVE_BACK | Retrieves the current color of the specified XP display element.
XPCOLOR_TAB_INACTIVE_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_GRIPPER | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_TEXT | Retrieves the current color of the specified XP display element.
Legend
Enumeration
Method


XTPDrawHelpers.h

Classes, Functions, Files, Legend, Templates
XTPDrawHelpers.h

XTPDrawHelpers.h: interface for the CXTPDrawHelpers class.

Classes
Class | Description
CXTPBitmapDC | CXTPBitmapDC is a helper class used to select a bitmap into the device context specified by hDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPBrushDC | CXTPBrushDC is a helper class used to create a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC. When destroyed, the class selects the previous brush back into the device context to handle GDI resource cleanup.
CXTPBufferDC | CXTPBufferDC is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPBufferDCEx | CXTPBufferDCEx is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPClientCursorPos | CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates.
CXTPClientRect | CXTPClientRect is a helper class used to retrieve the client area for a specified window.
CXTPCompatibleDC | CXTPCompatibleDC is a helper class used to create a memory device context (DC) compatible with the device specified by pDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPDrawHelpers | CXTPDrawHelpers is a helper class used to perform specialized drawing tasks. You can use this class to perform such tasks as gradient fills and blending colors.
CXTPEmptyRect | CXTPEmptyRect is a helper class used to instantiate an empty CRect object.
CXTPEmptySize | CXTPEmptySize is a helper class used to instantiate an empty CSize object.
CXTPFontDC | CXTPFontDC is a helper class used to select a font into the device context specified by pDC. When destroyed, the class selects the previous font back into the device context to handle GDI resource cleanup.
CXTPMouseMonitor | The class CXTPMouseMonitor is a helper class that is used to monitor mouse messages for in-place controls. This class is used in XTPPropertyGridInPlaceList and XTPReportInplaceControls.
CXTPPenDC | CXTPPenDC is a helper class used to create a pen using the color specified by crColor. The pen is then selected into the device context specified by hDC. When destroyed, the class selects the previous pen back into the device context to handle GDI resource cleanup.
CXTPPrinterInfo | Helper class which provide currently selected printer information.
CXTPPrintOptions | This class used as a base class to store printing options. It contains a base properties and operations for printing tasks.
CXTPPrintPageHeaderFooter | This class used to define printed page header or footer. Also some calculation and drawing functionality are provided. Used as member of printing options.
CXTPSplitterTracker | CXTPSplitterTracker is a stand alone class. It is used to track a splitter rectangle.
CXTPTransparentBitmap | CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap. Also, this class is used to convert a transparent BitMap into a transparent icon.
CXTPWindowRect | CXTPWindowRect is a helper class used to retrieve the screen size for a specified window.
Functions
Function | Description
XTPDrawHelpers | Call this function to access CXTPDrawHelpers members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPDrawHelpers.
XTPGetPrinterDeviceDefaults | Prepare a printer device context for printing and calculates DEVMODE and DEVNAMES values.
Group

Files

Templates
Template | Description
CXTPNoFlickerWnd | CXTPNoFlickerWnd is a TBase derived general purpose template helper class. CXTPNoFlickerWnd class is used for drawing flicker free controls. To use, instantiate the template using any CWnd derived class. For example, to create a tab control that is flicker free you would use the following declaration:
CXTPOfficeBorder | CXTPOfficeBorder is a template class used for windows that require a thin border. This class can be used as the base class for any CWnd derived class to display an Office style non-client border.
Legend
Template
Method


XTPImageManager.h

Classes, Enumerations, Files, Legend
XTPImageManager.h

XTPImageManager.h : interface for the CXTPImageManager class.

Classes
Class | Description
CXTPImageManager | CXTPImageManager is a stand alone class. It is used to manipulate icons.
CXTPImageManagerIcon | Icons holder class.
CXTPImageManagerIconHandle | CXTPImageManagerIconHandle is HICON wrapper class.
CXTPImageManagerIconSet | CXTPImageManagerIconSet represents the collection of icons for specified identifier.
CXTPTempColorMask | CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks. When the destructor is called the default mask is reset for XTPImageManager.
Enumerations
Enumeration | Description
XTPImageState | Image state enumerators.
Group

Files

Legend
Enumeration


XTPMacros.h

Files, Macros
XTPMacros.h

XTPMacros.h : common macros

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Group

Files

Macros
Macro | Description
SAFE_CALLPTR | Checks object pointer and if not NULL calls a specified function.
SAFE_DELETE | Frees dynamically allocated memory.
SAFE_DELETE_AR | Frees dynamically allocated memory for an array.
SAFE_DELETE_HICON | Destroys an icon and frees any memory the icon occupied.
SAFE_DELETE_OBJ | Destroys a GDI object and frees the handle.
SAFE_RELEASE | Decrements the reference count for the specified object.
XT_ASSERT_MSG | XT_ASSERT_MSG is similar to ASSERT, except that it allows a custom message to be specified.


XTPPropExchange.h

Classes, Functions, Files, Legend
XTPPropExchange.h

XTPPropExchange.h: interface for the CXTPPropExchange class.

Classes
Class
Description
CXTPPropExchange
CXTPPropExchange is standalone pure class. The CXTPPropExchange class allows you to save a complex network of objects in a permanent binary or text form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
You can use one of derived classes:

  • CXTPPropExchangeArchive to serialize to archive,
  • CXTPPropExchangeRegistry to serialize to registry key,
  • CXTPPropExchangeXMLNode to serialize to XML node.

CXTPPropExchangeArchive
CXTPPropExchangeArchive is CXTPPropExchange derived class. The CXTPPropExchangeArchive class allows you to save a complex network of objects in a permanent binary form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class. It used by CXTPPropExchange to enumerate child sections.
CXTPPropExchangeIniFile
CXTPPropExchangeIniFile is CXTPPropExchange derived class. The CXTPPropExchangeIniFile class allows you to save a complex network of objects in a ini file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeRegistry
CXTPPropExchangeRegistry is CXTPPropExchange derived class. The CXTPPropExchangeRegistry class allows you to save a complex network of objects in a system registry that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeSection
CXTPPropExchangeSection is standalone class. It is used to delete memory allocated by CXTPPropExchange::GetSection.
CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class. The CXTPPropExchangeXMLNode class allows you to save a complex network of objects in a XML file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
Functions
Function | Description
PX_Blob | Call this function within your class's DoPropExchange member function to serialize BYTE array.
PX_Bool | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Bool | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Bstr | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Byte | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BYTE. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DateTime | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleDateTime. The property's value is read from or written to the variable referenced by dtValue, as appropriate.
PX_Double | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Double | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DWord | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DWord | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Float | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Float | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Int | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Int | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Long | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Long | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Point | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT. The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Rect | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT. The property's value is read from or written to the variable referenced by rcValue, as appropriate. If rcDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_RuntimeClass | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type CRuntimeClass. The property's value is read from or written to the variable referenced by pClass, as appropriate. If pDefaultClass is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Serialize | Call this function within your class's DoPropExchange member function to serialize object.
PX_Short | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Short | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Size | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE. The property's value is read from or written to the variable referenced by szValue, as appropriate. If szDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_String | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_String | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UI8 | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONGLONG. The property's value is read from or written to the variable referenced by ullValue, as appropriate. If ullDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_ULong | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_ULong | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UShort | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UShort | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Variant | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleVariant. The property's value is read from or written to the variable referenced by variant, as appropriate. If variantDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
Group

Files

Legend
Method


XTPResourceManager.h

Classes, Functions, Files, Legend
XTPResourceManager.h

XTPResourceManager.h: interface for the CXTPResourceManager class.

Classes
Class | Description
CXTPResourceManager | Standalone class used to managed toolkit resources.
CXTPResourceManagerXML | Class used to managed toolkit resources from XML file
Functions
Function | Description
XTPResourceManager | Call this function to access CXTPResourceManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPResourceManager.
Group

Files

Legend
Method


XTPSystemHelpers.h

Classes, Functions, Files, Legend, Macros
XTPSystemHelpers.h

XTPSystemHelpers

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPCriticalSection | Critical Section Wrapper
CXTPLockGuard | Critical Sections Lock/Unlock helper
CXTPModuleHandle | CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods
CXTPMultiMonitor | MultiMonitor API wrapper class
CXTPSystemVersion | CXTPSystemVersion is a OSVERSIONINFO derived class. This class wraps the Win32 API GetVersionEx(...), used to get the current Windows OS version. CXTPSystemVersion is a single instance, or "singleton" object, that is accessed with the Get() method.
Functions
Function | Description
XTPMultiMonitor | Call this function to access CXTPMultiMonitor members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPMultiMonitor.
XTPSystemVersion | The XTPSystemVersion function is used for access to the CXTPSystemVersion class.
Group

Files

Macros
Macro | Description
XTOSVersionInfo | Depricated
Legend
Method


XTPToolTipContext.h

Classes, Enumerations, Files, Legend
XTPToolTipContext.h

XTPToolTipContext.h: interface for the CXTPToolTipContext class.

Classes
Class | Description
CXTPToolTipContext | CXTPToolTipContext is a CCmdTarget derived class. It allows to change options for tool tips of parent object.
CXTPToolTipContextToolTip | CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips.
Enumerations
Enumeration | Description
XTPToolTipStyle | Enumeration used to determine styles for tooltips
Group

Files

Legend
Enumeration


XTPWinThemeWrapper.h

Classes, Files
XTPWinThemeWrapper.h

XTPWinThemeWrapper.h: interface for the CXTPWinThemeWrapper class.

Classes
Class | Description
CXTPWinThemeWrapper | The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API. You can use this class for rendering Windows XP themes for owner drawn controls.
Group

Files


Task Panel

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Structs, Records, Enums, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Task Panel

Codejock Software's Xtreme Task Panel provides Windows developers with features similar to the Task Panels seen in Microsoft® Office and Windows Explorer.

You can easily manage your application shortcuts and have a unique way of displaying information to the end user.

Group

Xtreme Toolkit Pro v12.0

Legend
Structure
Enumeration
Classes
Class | Description
CXTPTaskPanel | CXTPTaskPanel is a CWnd derived class. It is used to implement an Explorer and Office-like Task Panel control.
CXTPTaskPanelExplorerTheme | Class that represents an Explorer style theme.
CXTPTaskPanelExplorerThemePlain | The CXTPTaskPanelExplorerThemePlain class is used to enable a classic Explorer style theme.
CXTPTaskPanelGroup | CXTPTaskPanelGroup is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single group.
CXTPTaskPanelGroupItem | CXTPTaskPanelGroupItem is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single item of the group.
CXTPTaskPanelGroupItems | CXTPTaskPanelGroupItems is a CXTPTaskPanelItems derived class. It is used as collection of items in the group.
CXTPTaskPanelGroups | CXTPTaskPanelGroups is a CXTPTaskPanelItems derived class. It is used as a collection of groups in the control.
CXTPTaskPanelItem | CXTPTaskPanelItem is a CCmdTarget derived class. It is used in TaskPanel control as parent for CXTPTaskPanelGroupItem and CXTPTaskPanelGroup classes.
CXTPTaskPanelItems | CXTPTaskPanelItems is a CCmdTarget derived class. It is used as collection of CXTPTaskPanelItem classes.
CXTPTaskPanelListViewOffice2003Theme | The CXTPTaskPanelListViewOffice2003Theme class is used to enable a List View Office 2003 style theme.
CXTPTaskPanelListViewOfficeXPTheme | The CXTPTaskPanelListViewOfficeXPTheme class is used to enable a List View Office XP style theme.
CXTPTaskPanelListViewTheme | The CXTPTaskPanelListViewTheme class is used to enable a List View style theme.
CXTPTaskPanelOffice2003Theme | Class that represents an Office 2003 style theme.
CXTPTaskPanelOffice2003ThemePlain | The CXTPTaskPanelOffice2003ThemePlain class is used to enable a classic Office 2003 style theme.
CXTPTaskPanelOfficeXPThemePlain | The CXTPTaskPanelOfficeXPThemePlain class is used to enable a classic Office XP style theme.
CXTPTaskPanelPaintManager | Standalone class used by CXTPTaskPanel as paint manager.
CXTPTaskPanelPaintManagerPlain | Base class theme that all other themes are derived from. Use this class when creating a custom theme.
CXTPTaskPanelScrollButton | CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button.
CXTPTaskPanelShortcutBarOffice2003Theme | CXTPTaskPanelShortcutBarOffice2003Theme is a CXTPTaskPanelListViewOffice2003Theme derived class used to enable an Office 2003 ShortcutBar style theme.
CXTPTaskPanelShortcutBarOffice2007Theme | CXTPTaskPanelShortcutBarOffice2007Theme is a CXTPTaskPanelShortcutBarOffice2003Theme derived class used to enable an Office 2007 ShortcutBar style theme.
CXTPTaskPanelToolboxTheme | The CXTPTaskPanelToolboxTheme class is used to enable a Toolbox style theme.
CXTPTaskPanelToolboxWhidbeyTheme | The CXTPTaskPanelToolboxWhidbeyTheme class is used to enable a VS.NET Whidbey style theme.
Files
File | Description
XTPTaskPanel.h | XTPTaskPanel.h interface for the CXTPTaskPanel class.
XTPTaskPanelDefines.h | XTPTaskPanelDefines.h This file is a part of the XTREME TASKPANEL MFC class library.
XTPTaskPanelGroup.h | XTPTaskPanelGroup.h interface for the CXTPTaskPanelGroup class.
XTPTaskPanelGroupItem.h | XTPTaskPanelGroupItem.h interface for the CXTPTaskPanelGroupItem class.
XTPTaskPanelItem.h | XTPTaskPanelItem.h interface for the CXTPTaskPanelItem class.
XTPTaskPanelItems.h | XTPTaskPanelItems.h interface for the CXTPTaskPanelItems class.
XTPTaskPanelPaintManager.h | XTPTaskPanelPaintManager.h interface for the CXTPTaskPanelPaintManager class.
Structs, Records, Enums
Struct, Record, Enum | Description
XTP_TASKPANEL_GROUPCOLORS | Structure used to store task panel group colorization information for various parts of the group.
XTP_TPNENDLABELEDIT | This structure passed as parameter when XTP_TPN_ENDLABELEDIT event occur.
XTP_TPNGROUPEXPANDING | This structure passed as parameter when XTP_TPN_GROUPEXPANDING event occur.
XTPTaskPanelAnimation | XTPTaskPanelAnimation is an enumeration used by CXTPTaskPanel to set the animation of the control.
XTPTaskPanelBehaviour | XTPTaskPanelBehaviour is an enumeration used by CXTPTaskPanel and CXTPTaskPanelGroup to set the behavior of the groups in the TaskPanel.
XTPTaskPanelGripper | Enumeration used to indicate which type of gripper is drawn on task panel group headers. This can be used when creating custom themes or you can override the predefined themes to change there grippers if drawn in the group headers.
XTPTaskPanelHotTrackStyle | XTPTaskPanelHotTrackStyle is an enumeration used by CXTPTaskPanel to set the hot tracking style used for CXTPTaskPanelItems. Hot tracking is how the items look as you move the mouse pointer over them.
XTPTaskPanelItemAllowDrag | XTPTaskPanelItemAllowDrag is an enumeration used by CXTPTaskPanel to specify the drag options
XTPTaskPanelItemLayout | XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the items are laid out in the group(s). Each group can have a different layout or they can all be the same.
XTPTaskPanelItemType | XTPTaskPanelItemType is an enumeration used by CXTPTaskPanelItem to specify the type of the item.
XTPTaskPanelPaintTheme | XTPTaskPanelPaintTheme is an enumeration used by CXTPTaskPanel to set the theme of the control.
Variables
Variable | Description
XTP_ACTION_CANCEL | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_CLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_DBLCLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ENDLABELEDIT | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_FOCUSEDITEMCHANGED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_GROUPEXPANDED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_GROUPEXPANDING | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_HOTITEMCHANGED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ITEMDROP | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ITEMREMOVED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_RCLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_STARTDRAG | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTPWM_TASKPANEL_NOTIFY | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel


Task Panel Hierarchy

Task Panel
Task Panel Hierarchy

Module

Task Panel


Classes

Classes, Task Panel
Classes
Classes
Class | Description
CXTPTaskPanel | CXTPTaskPanel is a CWnd derived class. It is used to implement an Explorer and Office-like Task Panel control.
CXTPTaskPanelExplorerTheme | Class that represents an Explorer style theme.
CXTPTaskPanelExplorerThemePlain | The CXTPTaskPanelExplorerThemePlain class is used to enable a classic Explorer style theme.
CXTPTaskPanelGroup | CXTPTaskPanelGroup is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single group.
CXTPTaskPanelGroupItem | CXTPTaskPanelGroupItem is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single item of the group.
CXTPTaskPanelGroupItems | CXTPTaskPanelGroupItems is a CXTPTaskPanelItems derived class. It is used as collection of items in the group.
CXTPTaskPanelGroups | CXTPTaskPanelGroups is a CXTPTaskPanelItems derived class. It is used as a collection of groups in the control.
CXTPTaskPanelItem | CXTPTaskPanelItem is a CCmdTarget derived class. It is used in TaskPanel control as parent for CXTPTaskPanelGroupItem and CXTPTaskPanelGroup classes.
CXTPTaskPanelItems | CXTPTaskPanelItems is a CCmdTarget derived class. It is used as collection of CXTPTaskPanelItem classes.
CXTPTaskPanelListViewOffice2003Theme | The CXTPTaskPanelListViewOffice2003Theme class is used to enable a List View Office 2003 style theme.
CXTPTaskPanelListViewOfficeXPTheme | The CXTPTaskPanelListViewOfficeXPTheme class is used to enable a List View Office XP style theme.
CXTPTaskPanelListViewTheme | The CXTPTaskPanelListViewTheme class is used to enable a List View style theme.
CXTPTaskPanelOffice2003Theme | Class that represents an Office 2003 style theme.
CXTPTaskPanelOffice2003ThemePlain | The CXTPTaskPanelOffice2003ThemePlain class is used to enable a classic Office 2003 style theme.
CXTPTaskPanelOfficeXPThemePlain | The CXTPTaskPanelOfficeXPThemePlain class is used to enable a classic Office XP style theme.
CXTPTaskPanelPaintManager | Standalone class used by CXTPTaskPanel as paint manager.
CXTPTaskPanelPaintManagerPlain | Base class theme that all other themes are derived from. Use this class when creating a custom theme.
CXTPTaskPanelScrollButton | CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button.
CXTPTaskPanelShortcutBarOffice2003Theme | CXTPTaskPanelShortcutBarOffice2003Theme is a CXTPTaskPanelListViewOffice2003Theme derived class used to enable an Office 2003 ShortcutBar style theme.
CXTPTaskPanelShortcutBarOffice2007Theme | CXTPTaskPanelShortcutBarOffice2007Theme is a CXTPTaskPanelShortcutBarOffice2003Theme derived class used to enable an Office 2007 ShortcutBar style theme.
CXTPTaskPanelToolboxTheme | The CXTPTaskPanelToolboxTheme class is used to enable a Toolbox style theme.
CXTPTaskPanelToolboxWhidbeyTheme | The CXTPTaskPanelToolboxWhidbeyTheme class is used to enable a VS.NET Whidbey style theme.
Module

Task Panel


CXTPTaskPanel Class

XTPTaskPanel.h, Classes, Legend, Members, Topics, CXTPTaskPanel Classes, CXTPTaskPanel Data Members, CXTPTaskPanel Methods, CXTPTaskPanel Constructors, CXTPTaskPanel Destructors, CXTPTaskPanel Classes, CXTPTaskPanel Constructors, CXTPTaskPanel Data Members, CXTPTaskPanel Destructors, CXTPTaskPanel Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel Class

CXTPTaskPanel is a CWnd derived class. It is used to implement an Explorer and Office-like Task Panel control.

Class Hierarchy

class CXTPTaskPanel : public CWnd;
File

XTPTaskPanel.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTaskPanel Classes
CXTPTaskPanel Classes | Description
CRepositionContext | CRepositionContext is helper class to lock/unlock redraw of Task Panel
CXTPTaskPanel Constructors
CXTPTaskPanel Constructors | Description
CXTPTaskPanel | Constructs a TaskPanel object
CXTPTaskPanel Data Members
CXTPTaskPanel Data Members | Description
m_bAcceptFocus | TRUE if control accept focus.
m_bAllowDrop | TRUE to allow task panel group items to be dropped inside the task panel, FALSE to only allow items to be dropped outside the task panel.
m_bAnimation | TRUE if animation enabled.
m_bDrawFocusRect | TRUE to draw focused rectangle drawn around the item when the Up and Down arrows are used to navigate the items in the TaskPanel.
m_bExpandable | TRUE if groups are expandable.
m_bGrabbingFocus | TRUE if control move focus to itself.
m_bInUpdateScrollBar | TRUE is the CXTPTaskPanel::UpdateScrollBar() method is currently in use (Scrollbar is currently being updated).
m_bMultiColumn | TRUE is multiple columns are used to display items in a group.
m_bScrollVisible | TRUE if scroll bar is visible.
m_bSelectItemOnFocus | TRUE if items receive focus when they are clicked.
m_bSingleSelection | TRUE to use focused item as selected.
m_bTimerGroupHover | TRUE if Timer for Hover event is currently set.
m_cfItem | Clipboard format.
m_eAnimation | Current animation state.
m_hHandCursor | Hand cursor.
m_hotTrackStyle | Currently set hot tracking style.
m_itemLayout | Currently set item layout.
m_nAllowDrag | TRUE to allow task panel group items to be dragged.
m_nAnimateTimer | Timer identifier for animation.
m_nAnimationStep | Current step of animation.
m_nClientHeight | Group client height.
m_nColumnWidth | Width of task panel columns when m_bMultiColumn is TRUE.
m_nGroupMinClientHeight | Group minimum client height
m_nGroupSpacing | Amount of space placed between groups.
m_nLockRedraw | TRUE when control is locked.
m_nOldClientHeight | Old group client height.
m_nOLEDropMode | TRUE if ActiveX OLEDropMode used
m_pActiveGroup | Pointer to currently active group.
m_paintTheme | Current theme.
m_panelBehaviour | Currently set TaskPanel behavior.
m_pAnimation | Animation context
m_pDropTarget | Internal drag'n'drop helper.
m_pGroups | Collection of groups.
m_pImageManager | Image manager of task panel.
m_pItemDragging | Pointer to item currently being dragged.
m_pItemDragOver | Pointer to item under mouse cursor with dragged icon.
m_pItemFocused | Currently focused item.
m_pItemHot | Currently hot item.
m_pItemPressed | Currently pressed item.
m_pPaintManager | Current Paint Manager.
m_pScrollButton | Scroll buttons of the task panel.
m_pToolTipContext | Tooltip Context.
m_ptPressed | Point on task panel that was clicked.
m_rcMargins | Outer margins of groups.
m_szGroupIcon | Size of icons displayed in group captions.
m_szItemIcon | Size of group item icons.
CXTPTaskPanel Destructors
CXTPTaskPanel Destructors | Description
~CXTPTaskPanel | Destroys a CXTPTaskPanel object, handles cleanup and deallocation.
CXTPTaskPanel Methods
CXTPTaskPanel Methods | Description
AddGroup | Call this member to add a new group.
AllowDrag | Call this member to specify whether you can drag items within the TaskPanel and from the TaskPanel to other object.
AllowDrop | Call this member to specify whether you can drop items within the TaskPanel from other objects to the TaskPanel.
AnimateGroups | This member is called to animate the groups when animation is enabled.
CheckScrollButtonMouseOver | This member is called to determine if the mouse cursor is positioned over one of the group scroll buttons.
Create | This method creates the TaskPanel control.
DrawFocusRect | Call this member to draw a focus rectangle around a CXTPTaskPanelGroupItem CXTPTaskPanelItem when the Up and Down arrows are used to navigate the items in the TaskPanel.
EnableAnimation | Call this method to enable animation for TaskPanel
EnableMarkup | Call this method to enable markup for tab captions
EnsureVisible | Call this member to make sure that an item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.
ExpandGroup | Call this member to expand or collapse a group.
FindGroup | Call this member to find a group with specified identifier.
FindItem | Call this member to find a CXTPTaskPanelGroupItem with the specified identifier.
GetActiveGroup | Call this member to get the currently active group.
GetAnimation | Call this method to get animation type.
GetAt | This method retrieves a group with specified index.
GetBehaviour | Call this member to determine the behavior the TaskPanel is using.
GetClientHeight | Retrieves the current height of a client area.
GetClipboardFormat | Call this member to get the current clipboard format.
GetColumnWidth | Determines the width in pixels of all columns in a multicolumn task panel
GetCurrentTheme | Call this member to get the current visual theme.
GetFocusedItem | Call this method to get focused item.
GetGroupCount | Call this member to determine the number of groups.
GetGroupIconSize | Call this member to retrieve the size used to display group icons.
GetGroups | Call this member to get group collection of TaskPanel control.
GetHotItem | Call this member to retrieve the current "hot" item.
GetHotTrackStyle | Call this member to determine the type of hot tracking currently used.
GetImageManager | Retrieves Image manager associated with Task Panel.
GetItemIconSize | Call this member to retrieve the size used to display item icons.
GetItemLayout | Call this member to determine the item layout currently used.
GetMargins | Call this member to get the outer margins of groups in the task panel.
GetMarkupContext | Returns markup context
GetMinimumGroupClientHeight | Retrieves minimum client height for all groups
GetNextItem | Call this method to get next item in tab order.
GetNextVisibleGroup | This method is called to find next visible group
GetPaintManager | Call this member to get the current paint manager.
GetScrollButton | Call this member to retrieve a pointer to a group scroll button.
GetScrollOffset | Call this method to get scroll offset.
GetToolTipContext | Call this method to get tooltip context pointer.
HitTestGroup | This method determines where a point lies in a specified group.
HitTestItem | This method determines where a point lies in a specified item.
HitTestScrollButton | This method determines where a point lies in a specified group scroll button.
IsDirty | This member is called to determine if the current group position is "dirty" i.e. Moving during animation.
IsDrawFocusRect | Call this member to determine if a focus rectangle is drawn around items when the Up and Down arrows are used to navigate items.
IsExpandable | Call this method to determine if groups are expandable
IsExplorerBehaviour | Call this member to determine if the Explorer behavior is currently being used.
IsGroupExpanded | Call this member to determine if a group is currently expanded or collapsed.
IsMultiColumn | Determines if multi column enabled.
IsSingleSelection | Call this method to get Single Selection property of control.
NavigateItems | Call this method to enable navigate items using Tab key.
NotifyOwner | This member is called to notify the parent window that an event has occurred in the task panel.
OnClick | This method is called when user clicks on the specified item.
OnClickScrollButton | The member is called when a group scroll button is clicked.
OnClientHeightChanged | This method is called when client height was changed
OnDragOver | This member is called when an item is dragged over the task panel.
OnDraw | Called by the framework to draw the task panel using the specified device context.
OnDrop | This member is called when an item has been dropped into the task panel.
OnEndLabelEdit | This method is called when the caption of an item is finished being editedrenamed.
OnItemRemoved | This member is called when an item has been removed from the task panel.
OnSrollChanged | This member is called then the task panel's scroll bar has been scrolled.
OnStartGroupDrag | This member is called when a group is just starting to be dragged.
OnStartItemDrag | This member is called when a group item is just starting to be dragged.
Redraw | The framework calls this member function to redraw the TaskPanel.
RegisterWindowClass | Register the window class if it has not already been registered.
RenameItem | Call this member to change the caption of a CXTPTaskPanelGroup or CXTPTaskPanelItem. When the RenameItem method is called, an edit box appears on the group caption allowing you to type in a new name.
Reposition | Call this method to reposition the groups in the task panel.
RepositionScrollButtons | This member is called to reposition the group scroll buttons.
SetAnimation | Call this method to set animation of the TaskPanel control
SetBehaviour | Call this member to specify the behavior of the TaskPanel. The TaskPanel can behave like a ToolBox, List View, or Explorer.
SetColumnWidth | Sets the width in pixels of all columns in a multicolumn task panel
SetCustomTheme | Call this member to set a custom theme.
SetExpandable | Call this method to set groups to expandable.
SetFocusedItem | Call this method to focus the specified item.
SetGroupIconSize | Call this member function to specify the size of the group icons used in the TaskPanel.
SetGroupImageList | Assigns an image list to a TaskPanel's groups.
SetHotItem | Call this method to set hot item of the TaskPanel control.
SetHotTrackStyle | Call this member to set the type of hot tracking that is used when the mouse is moved over a group or item.
SetIconSize | Call this member function to specify the size of the Icons used in the TaskPanel.
SetImageList | Assigns an image list to a TaskPanel control.
SetImageManager | Call this method to assign new image manager.
SetItemLayout | Call this member to specify the item layout of the XTPTaskPanelItems. Layouts include text only, image only, image and text, and image with text below the image. This applies to all groups unless each groups layout is set individually.
SetLayoutRTL | Call this member to set right-to-left mode.
SetLockRedraw | Call this method to lock/unlock redraw of controls.
SetMargins | Call this method to set group outer margins.
SetMinimumGroupClientHeight | Call this method to set minimum client height for all groups
SetMultiColumn | Call this member to set multi column groups.
SetSelectItemOnFocus | Call this member to specify whether items will receive focus when they are clicked. If bSelect is TRUE, the item clicked receives focus and the previously focused item loses focus. This must be FALSE to use toggle buttons or to allow multiple items to have focus.
SetSingleSelection | Call this method to allow only one item to be selected.
SetTheme | Call this member to switch the visual theme of the TaskPanel control.
UpdateScrollBar | This method is called to update the task panel's scroll bar.
UpdateScrollButtons | This member is called to update the enableddisabled state of the group scroll buttons.


CXTPTaskPanel Classes

Classes, CXTPTaskPanel Class
CXTPTaskPanel Classes
Classes
Class | Description
CRepositionContext | CRepositionContext is helper class to lock/unlock redraw of Task Panel
Class

CXTPTaskPanel Class


CXTPTaskPanel::CRepositionContext Class

XTPTaskPanel.h, CXTPTaskPanel Classes, Legend, Members, Topics, CRepositionContext Data Members, CRepositionContext Constructors, CRepositionContext Destructors, CRepositionContext Constructors, CRepositionContext Data Members, CRepositionContext Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::CRepositionContext Class

CRepositionContext is helper class to lock/unlock redraw of Task Panel

Class Hierarchy

class CRepositionContext;
File

XTPTaskPanel.h

Group

CXTPTaskPanel Classes

Legend
Data Member
protected
Constructor
CRepositionContext Constructors
CRepositionContext Constructors | Description
CRepositionContext | Constructs a CRepositionContext object.
CRepositionContext Data Members
CRepositionContext Data Members | Description
m_pTaskPanel | Parent Task Panel class
CRepositionContext Destructors
CRepositionContext Destructors | Description
~CRepositionContext | Destroys a CRepositionContext object, handles cleanup and deallocation.


CRepositionContext Data Members

CXTPTaskPanel::CRepositionContext Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CRepositionContext Data Members
Class

CXTPTaskPanel::CRepositionContext Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_pTaskPanel | Parent Task Panel class


CXTPTaskPanel::CRepositionContext::m_pTaskPanel Data Member

CRepositionContext Data Members, CXTPTaskPanel::CRepositionContext Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::CRepositionContext::m_pTaskPanel Data Member

Parent Task Panel class

CXTPTaskPanel* m_pTaskPanel;
Group

CRepositionContext Data Members


CRepositionContext Constructors

CXTPTaskPanel::CRepositionContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CRepositionContext Constructors
Class

CXTPTaskPanel::CRepositionContext Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CRepositionContext | Constructs a CRepositionContext object.


CXTPTaskPanel::CRepositionContext::CRepositionContext Constructor

CRepositionContext Constructors, CXTPTaskPanel::CRepositionContext Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::CRepositionContext::CRepositionContext Constructor

Constructs a CRepositionContext object.

CRepositionContext(
    CXTPTaskPanel* pTaskPanel
);
Parameters

pTaskPanel
Parent task panel class.

Body Source
CRepositionContext(CXTPTaskPanel* pTaskPanel)
    : m_pTaskPanel(pTaskPanel)
{
    if (m_pTaskPanel) m_pTaskPanel->SetLockRedraw(TRUE);
}
Group

CRepositionContext Constructors


CRepositionContext Destructors

CXTPTaskPanel::CRepositionContext Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CRepositionContext Destructors
Class

CXTPTaskPanel::CRepositionContext Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CRepositionContext | Destroys a CRepositionContext object, handles cleanup and deallocation.


CXTPTaskPanel::CRepositionContext::~CRepositionContext Destructor

CRepositionContext Destructors, CXTPTaskPanel::CRepositionContext Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::CRepositionContext::~CRepositionContext Destructor

Destroys a CRepositionContext object, handles cleanup and deallocation.

~CRepositionContext();
Body Source
~CRepositionContext()
{
    if (m_pTaskPanel) m_pTaskPanel->SetLockRedraw(FALSE);
}
Group

CRepositionContext Destructors


CXTPTaskPanel Data Members

CXTPTaskPanel Class, Legend, Protected Data Members
CXTPTaskPanel Data Members
Class

CXTPTaskPanel Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAcceptFocus | TRUE if control accept focus.
m_bAllowDrop | TRUE to allow task panel group items to be dropped inside the task panel, FALSE to only allow items to be dropped outside the task panel.
m_bAnimation | TRUE if animation enabled.
m_bDrawFocusRect | TRUE to draw focused rectangle drawn around the item when the Up and Down arrows are used to navigate the items in the TaskPanel.
m_bExpandable | TRUE if groups are expandable.
m_bGrabbingFocus | TRUE if control move focus to itself.
m_bInUpdateScrollBar | TRUE is the CXTPTaskPanel::UpdateScrollBar() method is currently in use (Scrollbar is currently being updated).
m_bMultiColumn | TRUE is multiple columns are used to display items in a group.
m_bScrollVisible | TRUE if scroll bar is visible.
m_bSelectItemOnFocus | TRUE if items receive focus when they are clicked.
m_bSingleSelection | TRUE to use focused item as selected.
m_bTimerGroupHover | TRUE if Timer for Hover event is currently set.
m_cfItem | Clipboard format.
m_eAnimation | Current animation state.
m_hHandCursor | Hand cursor.
m_hotTrackStyle | Currently set hot tracking style.
m_itemLayout | Currently set item layout.
m_nAllowDrag | TRUE to allow task panel group items to be dragged.
m_nAnimateTimer | Timer identifier for animation.
m_nAnimationStep | Current step of animation.
m_nClientHeight | Group client height.
m_nColumnWidth | Width of task panel columns when m_bMultiColumn is TRUE.
m_nGroupMinClientHeight | Group minimum client height
m_nGroupSpacing | Amount of space placed between groups.
m_nLockRedraw | TRUE when control is locked.
m_nOldClientHeight | Old group client height.
m_nOLEDropMode | TRUE if ActiveX OLEDropMode used
m_pActiveGroup | Pointer to currently active group.
m_paintTheme | Current theme.
m_panelBehaviour | Currently set TaskPanel behavior.
m_pAnimation | Animation context
m_pDropTarget | Internal drag'n'drop helper.
m_pGroups | Collection of groups.
m_pImageManager | Image manager of task panel.
m_pItemDragging | Pointer to item currently being dragged.
m_pItemDragOver | Pointer to item under mouse cursor with dragged icon.
m_pItemFocused | Currently focused item.
m_pItemHot | Currently hot item.
m_pItemPressed | Currently pressed item.
m_pPaintManager | Current Paint Manager.
m_pScrollButton | Scroll buttons of the task panel.
m_pToolTipContext | Tooltip Context.
m_ptPressed | Point on task panel that was clicked.
m_rcMargins | Outer margins of groups.
m_szGroupIcon | Size of icons displayed in group captions.
m_szItemIcon | Size of group item icons.


CXTPTaskPanel::m_bAcceptFocus Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bAcceptFocus Data Member

TRUE if control accept focus.

BOOL m_bAcceptFocus;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bAllowDrop Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bAllowDrop Data Member

TRUE to allow task panel group items to be dropped inside the task panel, FALSE to only allow items to be dropped outside the task panel.

BOOL m_bAllowDrop;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bAnimation Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bAnimation Data Member

TRUE if animation enabled.

BOOL m_bAnimation;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bDrawFocusRect Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bDrawFocusRect Data Member

TRUE to draw focused rectangle drawn around the item when the Up and Down arrows are used to navigate the items in the TaskPanel.

BOOL m_bDrawFocusRect;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bExpandable Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bExpandable Data Member

TRUE if groups are expandable.

BOOL m_bExpandable;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bGrabbingFocus Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bGrabbingFocus Data Member

TRUE if control move focus to itself.

BOOL m_bGrabbingFocus;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bInUpdateScrollBar Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bInUpdateScrollBar Data Member

TRUE is the CXTPTaskPanel::UpdateScrollBar() method is currently in use (Scrollbar is currently being updated).

BOOL m_bInUpdateScrollBar;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bMultiColumn Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bMultiColumn Data Member

TRUE is multiple columns are used to display items in a group.

BOOL m_bMultiColumn;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bScrollVisible Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bScrollVisible Data Member

TRUE if scroll bar is visible.

BOOL m_bScrollVisible;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bSelectItemOnFocus Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bSelectItemOnFocus Data Member

TRUE if items receive focus when they are clicked.

BOOL m_bSelectItemOnFocus;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bSingleSelection Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bSingleSelection Data Member

TRUE to use focused item as selected.

BOOL m_bSingleSelection;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_bTimerGroupHover Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_bTimerGroupHover Data Member

TRUE if Timer for Hover event is currently set.

BOOL m_bTimerGroupHover;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_cfItem Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_cfItem Data Member

Clipboard format.

CLIPFORMAT m_cfItem;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_eAnimation Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_eAnimation Data Member

Current animation state.

XTPTaskPanelAnimation m_eAnimation;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_hHandCursor Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_hHandCursor Data Member

Hand cursor.

HCURSOR m_hHandCursor;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_hotTrackStyle Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_hotTrackStyle Data Member

Currently set hot tracking style.

XTPTaskPanelHotTrackStyle m_hotTrackStyle;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_itemLayout Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_itemLayout Data Member

Currently set item layout.

XTPTaskPanelItemLayout m_itemLayout;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nAllowDrag Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nAllowDrag Data Member

TRUE to allow task panel group items to be dragged.

long m_nAllowDrag;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nAnimateTimer Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nAnimateTimer Data Member

Timer identifier for animation.

UINT_PTR m_nAnimateTimer;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nAnimationStep Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nAnimationStep Data Member

Current step of animation.

int m_nAnimationStep;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nClientHeight Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nClientHeight Data Member

Group client height.

int m_nClientHeight;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nColumnWidth Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nColumnWidth Data Member

Width of task panel columns when m_bMultiColumn is TRUE.

int m_nColumnWidth;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nGroupMinClientHeight Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nGroupMinClientHeight Data Member

Group minimum client height

int m_nGroupMinClientHeight;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nGroupSpacing Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nGroupSpacing Data Member

Amount of space placed between groups.

int m_nGroupSpacing;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nLockRedraw Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nLockRedraw Data Member

TRUE when control is locked.

BOOL m_nLockRedraw;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nOldClientHeight Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nOldClientHeight Data Member

Old group client height.

int m_nOldClientHeight;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_nOLEDropMode Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_nOLEDropMode Data Member

TRUE if ActiveX OLEDropMode used

long m_nOLEDropMode;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pActiveGroup Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pActiveGroup Data Member

Pointer to currently active group.

CXTPTaskPanelGroup* m_pActiveGroup;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_paintTheme Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_paintTheme Data Member

Current theme.

XTPTaskPanelPaintTheme m_paintTheme;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_panelBehaviour Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_panelBehaviour Data Member

Currently set TaskPanel behavior.

XTPTaskPanelBehaviour m_panelBehaviour;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pAnimation Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pAnimation Data Member

Animation context

CXTPTaskPanelAnimation* m_pAnimation;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pDropTarget Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pDropTarget Data Member

Internal drag'n'drop helper.

CPanelDropTarget* m_pDropTarget;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pGroups Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pGroups Data Member

Collection of groups.

CXTPTaskPanelGroups* m_pGroups;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pImageManager Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pImageManager Data Member

Image manager of task panel.

CXTPImageManager* m_pImageManager;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pItemDragging Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pItemDragging Data Member

Pointer to item currently being dragged.

CXTPTaskPanelItem* m_pItemDragging;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pItemDragOver Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pItemDragOver Data Member

Pointer to item under mouse cursor with dragged icon.

CXTPTaskPanelItem* m_pItemDragOver;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pItemFocused Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pItemFocused Data Member

Currently focused item.

CXTPTaskPanelItem* m_pItemFocused;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pItemHot Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pItemHot Data Member

Currently hot item.

CXTPTaskPanelItem* m_pItemHot;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pItemPressed Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pItemPressed Data Member

Currently pressed item.

CXTPTaskPanelItem* m_pItemPressed;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pPaintManager Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pPaintManager Data Member

Current Paint Manager.

CXTPTaskPanelPaintManager* m_pPaintManager;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pScrollButton Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pScrollButton Data Member

Scroll buttons of the task panel.

CXTPTaskPanelScrollButton* m_pScrollButton[2];
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_pToolTipContext Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_pToolTipContext Data Member

Tooltip Context.

CXTPToolTipContext* m_pToolTipContext;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_ptPressed Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_ptPressed Data Member

Point on task panel that was clicked.

CPoint m_ptPressed;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_rcMargins Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_rcMargins Data Member

Outer margins of groups.

CRect m_rcMargins;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_szGroupIcon Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_szGroupIcon Data Member

Size of icons displayed in group captions.

CSize m_szGroupIcon;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel::m_szItemIcon Data Member

CXTPTaskPanel Data Members, CXTPTaskPanel Class
CXTPTaskPanel::m_szItemIcon Data Member

Size of group item icons.

CSize m_szItemIcon;
Group

CXTPTaskPanel Data Members


CXTPTaskPanel Methods

CXTPTaskPanel Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel Methods
Class

CXTPTaskPanel Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
CheckScrollButtonMouseOver | This member is called to determine if the mouse cursor is positioned over one of the group scroll buttons.
GetNextVisibleGroup | This method is called to find next visible group
IsExplorerBehaviour | Call this member to determine if the Explorer behavior is currently being used.
OnClickScrollButton | The member is called when a group scroll button is clicked.
OnClientHeightChanged | This method is called when client height was changed
OnDragOver | This member is called when an item is dragged over the task panel.
OnDrop | This member is called when an item has been dropped into the task panel.
OnEndLabelEdit | This method is called when the caption of an item is finished being editedrenamed.
OnItemRemoved | This member is called when an item has been removed from the task panel.
OnStartGroupDrag | This member is called when a group is just starting to be dragged.
OnStartItemDrag | This member is called when a group item is just starting to be dragged.
RepositionScrollButtons | This member is called to reposition the group scroll buttons.
UpdateScrollBar | This method is called to update the task panel's scroll bar.
UpdateScrollButtons | This member is called to update the enableddisabled state of the group scroll buttons.
Public Methods
Public Methods
Public Method | Description
AddGroup | Call this member to add a new group.
AllowDrag | Call this member to specify whether you can drag items within the TaskPanel and from the TaskPanel to other object.
AllowDrop | Call this member to specify whether you can drop items within the TaskPanel from other objects to the TaskPanel.
AnimateGroups | This member is called to animate the groups when animation is enabled.
Create | This method creates the TaskPanel control.
DrawFocusRect | Call this member to draw a focus rectangle around a CXTPTaskPanelGroupItem CXTPTaskPanelItem when the Up and Down arrows are used to navigate the items in the TaskPanel.
EnableAnimation | Call this method to enable animation for TaskPanel
EnableMarkup | Call this method to enable markup for tab captions
EnsureVisible | Call this member to make sure that an item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.
ExpandGroup | Call this member to expand or collapse a group.
FindGroup | Call this member to find a group with specified identifier.
FindItem | Call this member to find a CXTPTaskPanelGroupItem with the specified identifier.
GetActiveGroup | Call this member to get the currently active group.
GetAnimation | Call this method to get animation type.
GetAt | This method retrieves a group with specified index.
GetBehaviour | Call this member to determine the behavior the TaskPanel is using.
GetClientHeight | Retrieves the current height of a client area.
GetClipboardFormat | Call this member to get the current clipboard format.
GetColumnWidth | Determines the width in pixels of all columns in a multicolumn task panel
GetCurrentTheme | Call this member to get the current visual theme.
GetFocusedItem | Call this method to get focused item.
GetGroupCount | Call this member to determine the number of groups.
GetGroupIconSize | Call this member to retrieve the size used to display group icons.
GetGroups | Call this member to get group collection of TaskPanel control.
GetHotItem | Call this member to retrieve the current "hot" item.
GetHotTrackStyle | Call this member to determine the type of hot tracking currently used.
GetImageManager | Retrieves Image manager associated with Task Panel.
GetItemIconSize | Call this member to retrieve the size used to display item icons.
GetItemLayout | Call this member to determine the item layout currently used.
GetMargins | Call this member to get the outer margins of groups in the task panel.
GetMarkupContext | Returns markup context
GetMinimumGroupClientHeight | Retrieves minimum client height for all groups
GetNextItem | Call this method to get next item in tab order.
GetPaintManager | Call this member to get the current paint manager.
GetScrollButton | Call this member to retrieve a pointer to a group scroll button.
GetScrollOffset | Call this method to get scroll offset.
GetToolTipContext | Call this method to get tooltip context pointer.
HitTestGroup | This method determines where a point lies in a specified group.
HitTestItem | This method determines where a point lies in a specified item.
HitTestScrollButton | This method determines where a point lies in a specified group scroll button.
IsDirty | This member is called to determine if the current group position is "dirty" i.e. Moving during animation.
IsDrawFocusRect | Call this member to determine if a focus rectangle is drawn around items when the Up and Down arrows are used to navigate items.
IsExpandable | Call this method to determine if groups are expandable
IsGroupExpanded | Call this member to determine if a group is currently expanded or collapsed.
IsMultiColumn | Determines if multi column enabled.
IsSingleSelection | Call this method to get Single Selection property of control.
NavigateItems | Call this method to enable navigate items using Tab key.
NotifyOwner | This member is called to notify the parent window that an event has occurred in the task panel.
OnClick | This method is called when user clicks on the specified item.
OnDraw | Called by the framework to draw the task panel using the specified device context.
OnSrollChanged | This member is called then the task panel's scroll bar has been scrolled.
Redraw | The framework calls this member function to redraw the TaskPanel.
RegisterWindowClass | Register the window class if it has not already been registered.
RenameItem | Call this member to change the caption of a CXTPTaskPanelGroup or CXTPTaskPanelItem. When the RenameItem method is called, an edit box appears on the group caption allowing you to type in a new name.
Reposition | Call this method to reposition the groups in the task panel.
SetAnimation | Call this method to set animation of the TaskPanel control
SetBehaviour | Call this member to specify the behavior of the TaskPanel. The TaskPanel can behave like a ToolBox, List View, or Explorer.
SetColumnWidth | Sets the width in pixels of all columns in a multicolumn task panel
SetCustomTheme | Call this member to set a custom theme.
SetExpandable | Call this method to set groups to expandable.
SetFocusedItem | Call this method to focus the specified item.
SetGroupIconSize | Call this member function to specify the size of the group icons used in the TaskPanel.
SetGroupImageList | Assigns an image list to a TaskPanel's groups.
SetHotItem | Call this method to set hot item of the TaskPanel control.
SetHotTrackStyle | Call this member to set the type of hot tracking that is used when the mouse is moved over a group or item.
SetIconSize | Call this member function to specify the size of the Icons used in the TaskPanel.
SetImageList | Assigns an image list to a TaskPanel control.
SetImageManager | Call this method to assign new image manager.
SetItemLayout | Call this member to specify the item layout of the XTPTaskPanelItems. Layouts include text only, image only, image and text, and image with text below the image. This applies to all groups unless each groups layout is set individually.
SetLayoutRTL | Call this member to set right-to-left mode.
SetLockRedraw | Call this method to lock/unlock redraw of controls.
SetMargins | Call this method to set group outer margins.
SetMinimumGroupClientHeight | Call this method to set minimum client height for all groups
SetMultiColumn | Call this member to set multi column groups.
SetSelectItemOnFocus | Call this member to specify whether items will receive focus when they are clicked. If bSelect is TRUE, the item clicked receives focus and the previously focused item loses focus. This must be FALSE to use toggle buttons or to allow multiple items to have focus.
SetSingleSelection | Call this method to allow only one item to be selected.
SetTheme | Call this member to switch the visual theme of the TaskPanel control.


CXTPTaskPanel::AddGroup Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::AddGroup Method

Call this member to add a new group.

CXTPTaskPanelGroup* AddGroup(
    UINT nID,
    int nImage = -1
);
Parameters

nID
Identifier of the group to be added.
nImage
Image index of group to be added.

Returns

A pointer to the created CXTPTaskPanelGroup class

See Also

SetGroupImageList

Group

CXTPTaskPanel Methods


CXTPTaskPanel::AllowDrag Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::AllowDrag Method

Call this member to specify whether you can drag items within the TaskPanel and from the TaskPanel to other object.

void AllowDrag(
    long nAllowDrag = xtpTaskItemAllowDragDefault
);
Parameters

nAllowDrag
Drag options

Remarks

dragOptions parameter can be one or more of the following values:

  • xtpTaskItemAllowDragCopyWithinGroup To allow copy within group only
  • xtpTaskItemAllowDragCopyWithinControl To allow copy within task panel only
  • xtpTaskItemAllowDragCopyOutsideControl To allow copy outside task panel only
  • xtpTaskItemAllowDragCopy To allow copy operation
  • xtpTaskItemAllowDragMoveWithinGroup To allow move within group only
  • xtpTaskItemAllowDragMoveWithinControl To allow move within task panel only
  • xtpTaskItemAllowDragMoveOutsideControl To allow move outside task panel only
  • xtpTaskItemAllowDragMove To allow move operation
  • xtpTaskItemAllowDragAll To allow all drag operations
See Also

AllowDrop, XTPTaskPanelItemAllowDrag

Group

CXTPTaskPanel Methods


CXTPTaskPanel::AllowDrop Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::AllowDrop Method

Call this member to specify whether you can drop items within the TaskPanel from other objects to the TaskPanel.

void AllowDrop(
    BOOL bAllowDrop
);
Parameters

bAllowDrop
TRUE to allow task panel group items to be dropped inside the task panel, FALSE to only allow items to be dropped outside the task panel.

See Also

AllowDrag

Body Source
void CXTPTaskPanel::AllowDrop(BOOL bAllowDrop) {
    m_bAllowDrop = bAllowDrop;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::AnimateGroups Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::AnimateGroups Method

This member is called to animate the groups when animation is enabled.

BOOL AnimateGroups(
    BOOL bCheckDirty = TRUE
);
Parameters

bCheckDirty
TRUE if the group(s) have not reached their target location during animation, FALSE if the group(s) have reached their target location.

Returns

TRUE if the group(s) are still dirty (has not reached their target location), FALSE if the group(s) have moved to their target location.

Remarks

This is called when the expandcollapse button is pressed in the group caption causing the group to expandcontract.

See Also

SetAnimation, GetAnimation, CXTPTaskPanelGroup::OnAnimate, CXTPTaskPanelGroup::m_rcGroupTarget, CXTPTaskPanelGroup::m_rcGroupCurrent, CXTPTaskPanelGroup::IsExpanding, CXTPTaskPanelGroup::IsExpanded, CXTPTaskPanelGroup::SetExpanded

Group

CXTPTaskPanel Methods


CXTPTaskPanel::CheckScrollButtonMouseOver Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::CheckScrollButtonMouseOver Method

This member is called to determine if the mouse cursor is positioned over one of the group scroll buttons.

void CheckScrollButtonMouseOver(
    CPoint point
);
Parameters

point
CPoint object that specifies the x and y to be tested.

Remarks

If the mouse cursor is over a group scroll button, then the buttons appearance is changed to "hot" is the button is enabled. When the mouse cursor leaves the button, the appearance is returned to normal.

OnMouseMove and OnMouseLeave call CheckScrollButtonMouseOver to update the appearance of the group scroll buttons.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::Create Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::Create Method

This method creates the TaskPanel control.

BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Style for the TaskPanel.
rect
Specifies the size and position of the TaskPanel control.
pParentWnd
Specifies the parent window of the TaskPanel control.
nID
Specifies the TaskPanel control ID.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::DrawFocusRect Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::DrawFocusRect Method

Call this member to draw a focus rectangle around a CXTPTaskPanelGroupItem CXTPTaskPanelItem when the Up and Down arrows are used to navigate the items in the TaskPanel.

void DrawFocusRect(
    BOOL bAccept
);
Parameters

bAccept
TRUE if the focus rectangle is to be drawn, FALSE otherwise.

See Also

IsDrawFocusRect

Body Source
void CXTPTaskPanel::DrawFocusRect(BOOL bAccept) {
    m_bAcceptFocus = bAccept;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::EnableAnimation Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::EnableAnimation Method

Call this method to enable animation for TaskPanel

void EnableAnimation(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable animation; FALSE to disable

Group

CXTPTaskPanel Methods


CXTPTaskPanel::EnableMarkup Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::EnableMarkup Method

Call this method to enable markup for tab captions

void EnableMarkup(
    BOOL bEnable = TRUE
);
Parameters

bEnable
TRUE to enable markup

Group

CXTPTaskPanel Methods


CXTPTaskPanel::EnsureVisible Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::EnsureVisible Method

Call this member to make sure that an item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.

void EnsureVisible(
    CXTPTaskPanelItem* pItem
);
Parameters

pItem
Item that should be visible.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::ExpandGroup Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::ExpandGroup Method

Call this member to expand or collapse a group.

virtual void ExpandGroup(
    CXTPTaskPanelGroup* pGroup,
    BOOL bExpanded
);
Parameters

pGroup
CXTPTaskPanelGroup to be expanded or closed
bExpanded
TRUE to expand group, FALSE to collapse group

See Also

CXTPTaskPanelGroup::SetExpandable, CXTPTaskPanelGroup::IsExpandable

Group

CXTPTaskPanel Methods


CXTPTaskPanel::FindGroup Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::FindGroup Method

Call this member to find a group with specified identifier.

CXTPTaskPanelGroup* FindGroup(
    UINT nID
) const;
Parameters

nID
Identifier of group to be found.

Returns

A pointer to group if successful; otherwise returns NULL.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::FindItem Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::FindItem Method

Call this member to find a CXTPTaskPanelGroupItem with the specified identifier.

CXTPTaskPanelGroupItem* FindItem(
    UINT nID
) const;
Parameters

nID
Identifier of the CXTPTaskPanelGroupItem to be found.

Returns

A pointer to CXTPTaskPanelGroupItem if successful; otherwise returns NULL.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetActiveGroup Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetActiveGroup Method

Call this member to get the currently active group.

CXTPTaskPanelGroup* GetActiveGroup() const;
Returns

Pointer to the active CXTPTaskPanelGroup.

Body Source
CXTPTaskPanelGroup* CXTPTaskPanel::GetActiveGroup() const {
    return m_pActiveGroup;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetAnimation Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::GetAnimation Method

Call this method to get animation type.

XTPTaskPanelAnimation GetAnimation() const;
Returns

Animation type of TaskPanel control.

See Also

CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanelGroup::IsDirty, CXTPTaskPanelGroup::OnAnimate, XTPTaskPanelAnimation

Body Source
XTPTaskPanelAnimation CXTPTaskPanel::GetAnimation() const {
    return m_eAnimation;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetAt Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetAt Method

This method retrieves a group with specified index.

CXTPTaskPanelGroup* GetAt(
    int nIndex
) const;
Parameters

nIndex
Specifies the zero-based index of the group to retrieve.

Returns

A pointer to a CXTPTaskPanelGroup object.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetBehaviour Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetBehaviour Method

Call this member to determine the behavior the TaskPanel is using.

XTPTaskPanelBehaviour GetBehaviour() const;
Returns

The currently set XTPTaskPanelBehaviour.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetClientHeight Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetClientHeight Method

Retrieves the current height of a client area.

int GetClientHeight() const;
Returns

Current height of a client area

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetClipboardFormat Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetClipboardFormat Method

Call this member to get the current clipboard format.

static CLIPFORMAT GetClipboardFormat();
Returns

Current CLIPFORMAT clipboard format.

Body Source
CLIPFORMAT AFX_CDECL CXTPTaskPanel::GetClipboardFormat() {
    return m_cfItem;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetColumnWidth Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::GetColumnWidth Method

Determines the width in pixels of all columns in a multicolumn task panel

int GetColumnWidth() const;
Returns

The width in pixels of all columns.

See Also

SetMultiColumn, SetColumnWidth

Body Source
int CXTPTaskPanel::GetColumnWidth() const {
    return m_nColumnWidth;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetCurrentTheme Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::GetCurrentTheme Method

Call this member to get the current visual theme.

XTPTaskPanelPaintTheme GetCurrentTheme() const;
Returns

The current theme.

See Also

CXTPTaskPanel::SetTheme

Body Source
XTPTaskPanelPaintTheme CXTPTaskPanel::GetCurrentTheme() const {
    return m_paintTheme;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetFocusedItem Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetFocusedItem Method

Call this method to get focused item.

CXTPTaskPanelItem* GetFocusedItem() const;
Returns

Item currently focused.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetGroupCount Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetGroupCount Method

Call this member to determine the number of groups.

int GetGroupCount() const;
Returns

Number of the group.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetGroupIconSize Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetGroupIconSize Method

Call this member to retrieve the size used to display group icons.

CSize GetGroupIconSize() const;
Returns

Size of group icons.

Remarks

By default, item icons are 32x32. To change this size you must specify the size in m_szGroupIcon.

m_szGroupIcon = CSize(32, 32)"
Body Source
CSize CXTPTaskPanel::GetGroupIconSize() const {
    return m_szGroupIcon;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetGroups Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetGroups Method

Call this member to get group collection of TaskPanel control.

CXTPTaskPanelItems* GetGroups() const;
Returns

A pointer to CXTPTaskPanelItems class that represents the groups of TaskPanel.

Body Source
CXTPTaskPanelItems* CXTPTaskPanel::GetGroups() const {
    return (CXTPTaskPanelItems*)m_pGroups;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetHotItem Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetHotItem Method

Call this member to retrieve the current "hot" item.

CXTPTaskPanelItem* GetHotItem() const;
Returns

Retrieves the current hot item.

Body Source
CXTPTaskPanelItem* CXTPTaskPanel::GetHotItem() const {
    return m_pItemHot;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetHotTrackStyle Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetHotTrackStyle Method

Call this member to determine the type of hot tracking currently used.

XTPTaskPanelHotTrackStyle GetHotTrackStyle() const;
Returns

The current XTPTaskPanelHotTrackStyle used.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetImageManager Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetImageManager Method

Retrieves Image manager associated with Task Panel.

CXTPImageManager* GetImageManager() const;
Returns

Pointer to the image manager object that stores the images in the task panel.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetItemIconSize Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetItemIconSize Method

Call this member to retrieve the size used to display item icons.

CSize GetItemIconSize() const;
Returns

Size of item icons.

Remarks

By default, item icons are 16x16. To change this size you must specify the size in m_szItemIcon. "m_szItemIcon = CSize(16, 16)"

Body Source
CSize CXTPTaskPanel::GetItemIconSize() const {
    return m_szItemIcon;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetItemLayout Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetItemLayout Method

Call this member to determine the item layout currently used.

XTPTaskPanelItemLayout GetItemLayout() const;
Returns

The currently set XTPTaskPanelItemLayout.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetMargins Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetMargins Method

Call this member to get the outer margins of groups in the task panel.

CRect GetMargins() const;
Returns

Outer group margins.

Body Source
CRect CXTPTaskPanel::GetMargins() const {
    return m_rcMargins;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetMarkupContext Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetMarkupContext Method

Returns markup context

CXTPMarkupContext* GetMarkupContext() const;
Body Source
CXTPMarkupContext* CXTPTaskPanel::GetMarkupContext() const {
    return m_pMarkupContext;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetMinimumGroupClientHeight Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::GetMinimumGroupClientHeight Method

Retrieves minimum client height for all groups

int GetMinimumGroupClientHeight() const;
Returns

Minimum client height

Body Source
int CXTPTaskPanel::GetMinimumGroupClientHeight() const {
    return m_nGroupMinClientHeight;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetNextItem Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetNextItem Method

Call this method to get next item in tab order.

CXTPTaskPanelItem* GetNextItem(
    CXTPTaskPanelItem* pItem,
    int nDirection,
    BOOL bTab,
    BOOL bSkipRowItems = TRUE
) const;
Parameters

pItem
Current item.
nDirection
Direction to find (1 to forward, -1 to backward)
bTab
TRUE to use tabulation.
bSkipRowItems
TRUE to get next item in next row.

Returns

Next item.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetNextVisibleGroup Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetNextVisibleGroup Method

This method is called to find next visible group

CXTPTaskPanelGroup* GetNextVisibleGroup(
    int nIndex,
    int nDirection = +1
) const;
Parameters

nIndex
Index of group to start search
nDirection
Direction to search

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetPaintManager Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::GetPaintManager Method

Call this member to get the current paint manager.

CXTPTaskPanelPaintManager* GetPaintManager() const;
Returns

The current paint manager.

See Also

CXTPTaskPanel::SetTheme

Body Source
CXTPTaskPanelPaintManager* CXTPTaskPanel::GetPaintManager() const {
    return m_pPaintManager;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetScrollButton Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::GetScrollButton Method

Call this member to retrieve a pointer to a group scroll button.

CXTPTaskPanelScrollButton* GetScrollButton(
    BOOL bScrollUp
) const;
Parameters

bScrollUp
TRUE to retrieve the Up scroll button, FALSE to retrieve the Down scroll button.

Returns

Pointer to the specified group scroll button.

See Also

CXTPTaskPanelScrollButton, m_pScrollButton

Body Source
CXTPTaskPanelScrollButton* CXTPTaskPanel::GetScrollButton(BOOL bScrollUp) const {
    return bScrollUp ? m_pScrollButton[TRUE] : m_pScrollButton[FALSE];
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetScrollOffset Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::GetScrollOffset Method

Call this method to get scroll offset.

int GetScrollOffset() const;
Returns

Scroll offset.

Remarks

This returns the scroll offset of the scroll bar that is displayed to scroll the entire task panel. This does return the offset to the scroll bar placed inside a task panel group. The task panel group offset can be retrieved with CXTPTaskPanelGroup::GetScrollOffsetPos and CXTPTaskPanelGroup::GetOffsetItem

See Also

CXTPTaskPanelGroup::GetOffsetItem, CXTPTaskPanelGroup::GetScrollOffsetPos

Group

CXTPTaskPanel Methods


CXTPTaskPanel::GetToolTipContext Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Group

CXTPTaskPanel Methods


CXTPTaskPanel::HitTestGroup Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::HitTestGroup Method

This method determines where a point lies in a specified group.

CXTPTaskPanelGroup* HitTestGroup(
    CPoint pt,
    BOOL* pbCaption = NULL
) const;
Parameters

pt
Specifies the point to be tested.
pbCaption
Pointer to BOOL value to return if point lies on group caption.

Returns

A pointer to a CXTPTaskPanelGroup item that occupies the specified point or NULL if no group occupies the point.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::HitTestItem Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::HitTestItem Method

This method determines where a point lies in a specified item.

CXTPTaskPanelItem* HitTestItem(
    CPoint pt,
    BOOL bClientAvail = FALSE
) const;
Parameters

pt
Specifies the point to be tested.
bClientAvail
TRUE to return group item if point lies in its client area.

Returns

A pointer to a CXTPTaskPanelItem item that occupies the specified point or NULL if no item occupies the point.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::HitTestScrollButton Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::HitTestScrollButton Method

This method determines where a point lies in a specified group scroll button.

CXTPTaskPanelScrollButton* HitTestScrollButton(
    CPoint point
) const;
Parameters

point
CPoint object that specifies the x and y to be tested.

Returns

A pointer to a CXTPTaskPanelScrollButton item that occupies the specified point or 0 (zero) if no group scroll button occupies the point.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::IsDirty Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::IsDirty Method

This member is called to determine if the current group position is "dirty" i.e. Moving during animation.

BOOL IsDirty() const;
Returns

TRUE if current position of group is dirty.

Remarks

During animation, the group moves from it's oldcurrent position to the newtarget position. IsDirty indicates that the animation has not finished yet and its current position is <> to the target position. The oldcurrent position is stored in m_rcGroupCurrent, and the newtarget position is stored in m_rcGroupTarget.

Animation occurs when the task panel first becomes visible and when the expandcollapse button is clicked in the group caption.

See Also

AnimateGroups, SetAnimation, GetAnimation, CXTPTaskPanelGroup::OnAnimate, CXTPTaskPanelGroup::m_rcGroupTarget, CXTPTaskPanelGroup::m_rcGroupCurrent, CXTPTaskPanelGroup::IsExpanding, CXTPTaskPanelGroup::IsExpanded, CXTPTaskPanelGroup::SetExpanded

Group

CXTPTaskPanel Methods


CXTPTaskPanel::IsDrawFocusRect Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::IsDrawFocusRect Method

Call this member to determine if a focus rectangle is drawn around items when the Up and Down arrows are used to navigate items.

BOOL IsDrawFocusRect() const;
Returns

TRUE to draw a focus rectangle around an item when the Up and Down arrows are used to navigate the items in the TaskPanel.

See Also

DrawFocusRect

Group

CXTPTaskPanel Methods


CXTPTaskPanel::IsExpandable Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::IsExpandable Method

Call this method to determine if groups are expandable

BOOL IsExpandable() const;
Returns

TRUE if groups are expandable, FALSE otherwise.

Body Source
BOOL CXTPTaskPanel::IsExpandable() const {
    return m_bExpandable;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::IsExplorerBehaviour Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::IsExplorerBehaviour Method

Call this member to determine if the Explorer behavior is currently being used.

BOOL IsExplorerBehaviour() const;
Returns

TRUE if the Explorer behavior is used, FALSE if a different behavior is used.

See Also

SetBehaviour, GetBehaviour, XTPTaskPanelBehaviour

Body Source
BOOL CXTPTaskPanel::IsExplorerBehaviour() const {
    return m_panelBehaviour == xtpTaskPanelBehaviourExplorer;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::IsGroupExpanded Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::IsGroupExpanded Method

Call this member to determine if a group is currently expanded or collapsed.

BOOL IsGroupExpanded(
    const CXTPTaskPanelGroup* pGroup
) const;
Parameters

pGroup
CXTPTaskPanelGroup to test.

Returns

TRUE if the group is currently expanded, FALSE if it is closed

Group

CXTPTaskPanel Methods


CXTPTaskPanel::IsMultiColumn Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::IsMultiColumn Method

Determines if multi column enabled.

BOOL IsMultiColumn() const;
Returns

TRUE if multi column of groups enabled

See Also

SetMultiColumn, SetColumnWidth

Body Source
BOOL CXTPTaskPanel::IsMultiColumn() const {
    return m_bMultiColumn;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::IsSingleSelection Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::IsSingleSelection Method

Call this method to get Single Selection property of control.

BOOL IsSingleSelection() const;
See Also

SetSingleSelection, SetSelectItemOnFocus

Body Source
BOOL CXTPTaskPanel::IsSingleSelection() const {
    return m_bSingleSelection;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::NavigateItems Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::NavigateItems Method

Call this method to enable navigate items using Tab key.

void NavigateItems(
    BOOL bTabItems
);
Parameters

bTabItems
TRUE to navigate items in the taskpanel using the tab key.

Body Source
void CXTPTaskPanel::NavigateItems(BOOL bTabItems) {
    m_bTabItems = bTabItems;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::NotifyOwner Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::NotifyOwner Method

This member is called to notify the parent window that an event has occurred in the task panel.

virtual LRESULT NotifyOwner(
    WPARAM wParam,
    LPARAM lParam
);
Parameters

wParam
Specifies which event has occurred.
lParam
Additional message-specific information.

Remarks

wParam parameter can be one of the following values:

  • XTP_TPN_CLICK Indicates the user clicked a TaskPanel item.
  • XTP_TPN_RCLICK Indicates the user pressed the right mouse button on a TaskPanel item.
  • XTP_TPN_STARTDRAG Indicates the user started to dragging an item. You can return XTP_ACTION_CANCEL to cancel the drag.
  • XTP_TPN_ENDLABELEDIT Indicates the user starts to rename an item.
  • XTP_TPN_ITEMDROP Indicates the user dropped item in task panel.
  • XTP_TPN_GROUPEXPANDING Indicates the group is about to be expanded. lParam contains XTP_TPNGROUPEXPANDING pointer. You can return XTP_ACTION_CANCEL to ignore expanding.
  • XTP_TPN_GROUPEXPANDED Indicates the user has expanded a group.

The following method in the task panel use NotifyOwner to send messages:

  • CXTPTaskPanelGroup::OnAnimate
  • CXTPTaskPanel::ExpandGroup lParam contains XTP_TPNGROUPEXPANDING pointer. You can return XTP_ACTION_CANCEL to ignore expanding.
  • CXTPTaskPanel::OnDrop lParam contains item dropped.
  • CXTPTaskPanel::OnStartItemDrag lParam contains item dragged.
  • CXTPTaskPanel::OnRButtonDown lParam contains item right-clicked.
  • CXTPTaskPanel::OnClick lParam contains item clicked.
  • CXTPTaskPanel::OnEndLabelEdit lParam contains item who's caption is being renamed.
See Also

XTPWM_TASKPANEL_NOTIFY

Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnClick Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::OnClick Method

This method is called when user clicks on the specified item.

virtual void OnClick(
    CXTPTaskPanelGroupItem* pItem
);
Parameters

pItem
Pointer to clicked item.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnClickScrollButton Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::OnClickScrollButton Method

The member is called when a group scroll button is clicked.

void OnClickScrollButton(
    CXTPTaskPanelScrollButton* pScrollButton
);
Parameters

pScrollButton
Pointer to the group scroll button that was clicked.

Remarks

OnLButtonDown calls OnClickScrollButton when a group scroll button is clicked.

See Also

CXTPTaskPanelScrollButton, m_pScrollButton

Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnClientHeightChanged Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::OnClientHeightChanged Method

This method is called when client height was changed

virtual void OnClientHeightChanged();
Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnDragOver Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::OnDragOver Method

This member is called when an item is dragged over the task panel.

virtual DROPEFFECT OnDragOver(
    COleDataObject* pDataObject,
    DWORD dwKeyState,
    CPoint point
);
Parameters

pDataObject
Points to the COleDataObject being dragged over the drop target.
dwKeyState
State of keys on keyboard. Contains the state of the modifier keys. This is a combination of any number of the following: MK_CONTROL, MK_SHIFT, MK_ALT, MK_LBUTTON, MK_MBUTTON, and MK_RBUTTON.
point
The current mouse position relative to the task panel.

Returns

A value from the DROPEFFECT enumerated type, which indicates the type of drop that would occur if the user dropped the object at this position. The type of drop often depends on the current key state as indicated by dwKeyState. A standard mapping of keystates to DROPEFFECT values is:

  • DROPEFFECT_NONE The data object cannot be dropped in this window.
  • DROPEFFECT_COPY for MK_CONTROL Creates a copy of the dropped object.
  • DROPEFFECT_MOVE for MK_ALT Creates a copy of the dropped object and delete the original object. This is typically the default drop effect, when the view can accept the data object.
Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnDraw Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::OnDraw Method

Called by the framework to draw the task panel using the specified device context.

virtual void OnDraw(
    CDC* pDC,
    CRect rcClipBox
);
Parameters

pDC
Pointer to a valid device context.

Remarks

OnDraw calls the CXTPTaskPanelGroup::OnPaint method for each group in the task panel. OnPaint also calls CXTPTaskPanelPaintManager::FillTaskPanel and CXTPTaskPanelPaintManager::DrawScrollButton

Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnDrop Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::OnDrop Method

This member is called when an item has been dropped into the task panel.

virtual BOOL OnDrop(
    COleDataObject* pDataObject,
    DROPEFFECT dropEffect,
    CPoint point
);
Parameters

pDataObject
Points to the COleDataObject that is dropped into the drop target.
dropEffect
The drop effect that the user has requested. Can be any of the values listed in the Remarks section.
point
The current mouse position relative to the task panel.

Returns

TRUE if the drop was successful, otherwise FALSE.

Remarks

The dropEffect parameter can be one of the following values:

  • DROPEFFECT_COPY Creates a copy of the data object being dropped.
  • DROPEFFECT_MOVE Moves the data object to the current mouse location.
Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnEndLabelEdit Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::OnEndLabelEdit Method

This method is called when the caption of an item is finished being editedrenamed.

virtual void OnEndLabelEdit(
    CXTPTaskPanelItem* pItem,
    LPCTSTR str
);
Parameters

pItem
Item being edited.
str
New caption of item.

Remarks

This member is called after RenameItem.

See Also

RenameItem

Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnItemRemoved Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::OnItemRemoved Method

This member is called when an item has been removed from the task panel.

virtual void OnItemRemoved(
    CXTPTaskPanelItem* pItem
);
Parameters

pItem
Item that was removed.

Remarks

CXTPTaskPanelItems::Clear and CXTPTaskPanelItems::RemoveAt call OnItemRemoved.

See Also

CXTPTaskPanelItems::Clear, CXTPTaskPanelItems::RemoveAt

Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnSrollChanged Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::OnSrollChanged Method

This member is called then the task panel's scroll bar has been scrolled.

void OnSrollChanged(
    int nCurPos
);
Parameters

nCurPos
Position on scroll bar to scroll to.

Remarks

This member is called when the scroll bar that is displayed to scroll the entire task panel is scrolled. This does not get called when the scroll bar placed inside a task panel group is scrolled.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnStartGroupDrag Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::OnStartGroupDrag Method

This member is called when a group is just starting to be dragged.

virtual void OnStartGroupDrag(
    CXTPTaskPanelItem* pItem
);
Parameters

pItem
Group being dragged.

Remarks

OnMouseMove calls OnStartGroupDrag is a group is dragged.

See Also

OnStartItemDrag, OnMouseMove

Group

CXTPTaskPanel Methods


CXTPTaskPanel::OnStartItemDrag Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::OnStartItemDrag Method

This member is called when a group item is just starting to be dragged.

virtual void OnStartItemDrag(
    CXTPTaskPanelGroupItem* pItem
);
Parameters

pItem
Group item being dragged.

Remarks

OnMouseMove calls OnStartItemDrag is a group item is dragged.

See Also

OnStartGroupDrag, OnMouseMove

Group

CXTPTaskPanel Methods


CXTPTaskPanel::Redraw Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::Redraw Method

The framework calls this member function to redraw the TaskPanel.

void Redraw(
    LPCRECT lpRect = NULL,
    BOOL bAnimate = FALSE
);
Parameters

lpRect
The rectangular area of the bar that is invalid.
bAnimate
TRUE to animate changes in bounding rectangle.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::RegisterWindowClass Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::RegisterWindowClass Method

Register the window class if it has not already been registered.

BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

TRUE if the window class was successfully registered.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::RenameItem Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::RenameItem Method

Call this member to change the caption of a CXTPTaskPanelGroup or CXTPTaskPanelItem. When the RenameItem method is called, an edit box appears on the group caption allowing you to type in a new name.

void RenameItem(
    CXTPTaskPanelItem* pItem
);
Parameters

pItem
TaskPanelGroup or TaskPanelItem who's caption will be renamed.

Remarks

OnEndLabelEdit is called when the user has finished editing the caption of the item. This causes NotifyOwner to send a message to the parent that the caption is finished being edited.

See Also

OnEndLabelEdit

Group

CXTPTaskPanel Methods


CXTPTaskPanel::Reposition Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::Reposition Method

Call this method to reposition the groups in the task panel.

void Reposition(
    BOOL bRecalcOnly = TRUE
);
Parameters

bRecalcOnly
TRUE to recalculate only without positioning.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::RepositionScrollButtons Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::RepositionScrollButtons Method

This member is called to reposition the group scroll buttons.

void RepositionScrollButtons();
Remarks

Reposition and AnimateGroups call RepositionScrollButtons when the groups in the task panel need to be repositioned. I.e. During animation while the group is expanding or collapsing.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetAnimation Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::SetAnimation Method

Call this method to set animation of the TaskPanel control

void SetAnimation(
    XTPTaskPanelAnimation panelAnimation
);
Parameters

panelAnimation
Animation type to be set. Can be any of the values listed in the Remarks section.

Remarks

Animation type can be one of the following:

  • xtpTaskPanelAnimationYes Default value, enables animation.
  • xtpTaskPanelAnimationNo Disables animation.
  • xtpTaskPanelAnimationSystem Use system settings to determine animation.
See Also

CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::GetAnimation, CXTPTaskPanelGroup::IsDirty, CXTPTaskPanelGroup::OnAnimate, XTPTaskPanelAnimation

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetBehaviour Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::SetBehaviour Method

Call this member to specify the behavior of the TaskPanel. The TaskPanel can behave like a ToolBox, List View, or Explorer.

void SetBehaviour(
    XTPTaskPanelBehaviour panelBehaviour
);
Parameters

panelBehaviour
The desired XTPTaskPanelBehaviour.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetColumnWidth Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::SetColumnWidth Method

Sets the width in pixels of all columns in a multicolumn task panel

void SetColumnWidth(
    int nColumnWidth
);
Parameters

nColumnWidth
Specifies the width in pixels of all columns.

See Also

SetMultiColumn, GetColumnWidth

Body Source
void CXTPTaskPanel::SetColumnWidth(int nColumnWidth) {
    m_nColumnWidth = nColumnWidth;
    Reposition();
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetCustomTheme Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::SetCustomTheme Method

Call this member to set a custom theme.

void SetCustomTheme(
    CXTPTaskPanelPaintManager* pPaintManager
);
Parameters

pPaintManager
New paint manager.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetExpandable Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::SetExpandable Method

Call this method to set groups to expandable.

void SetExpandable(
    BOOL bExpandable
);
Parameters

bExpandable
TRUE if TaskPanel groups are expandable.

Body Source
void CXTPTaskPanel::SetExpandable(BOOL bExpandable) {
    m_bExpandable = bExpandable;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetFocusedItem Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::SetFocusedItem Method

Call this method to focus the specified item.

virtual void SetFocusedItem(
    CXTPTaskPanelItem* pItem,
    BOOL bDrawFocusRect = FALSE,
    BOOL bSetFocus = TRUE
);
Parameters

pItem
Item to be focused.
bDrawFocusRect
TRUE to draw focused rect.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetGroupIconSize Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::SetGroupIconSize Method

Call this member function to specify the size of the group icons used in the TaskPanel.

void SetGroupIconSize(
    CSize szIcon
);
Parameters

szIcon
Size of icons used.

Body Source
void CXTPTaskPanel::SetGroupIconSize(CSize szIcon) {
    m_szGroupIcon = szIcon;
    Reposition();
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetGroupImageList Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::SetGroupImageList Method

Assigns an image list to a TaskPanel's groups.

void SetGroupImageList(
    CImageList* pImageList,
    CSize szGroupIcon = CSize(32, 32)
);
Parameters

pImageList
Pointer to the image list to be assigned to the groups of TaskPanel. This parameter can be NULL to update size of group icons.
szGroupIcon
Groups icon size to be used.

See Also

SetImageList, GetImageManager

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetHotItem Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::SetHotItem Method

Call this method to set hot item of the TaskPanel control.

void SetHotItem(
    CXTPTaskPanelItem* pItem
);
Parameters

pItem
Item to be hot.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetHotTrackStyle Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::SetHotTrackStyle Method

Call this member to set the type of hot tracking that is used when the mouse is moved over a group or item.

void SetHotTrackStyle(
    XTPTaskPanelHotTrackStyle hotTrackStyle
);
Parameters

hotTrackStyle
The desired XTPTaskPanelHotTrackStyle.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetIconSize Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::SetIconSize Method

Call this member function to specify the size of the Icons used in the TaskPanel.

void SetIconSize(
    CSize szIcon
);
Parameters

szIcon
Size of icons used.

Body Source
void CXTPTaskPanel::SetIconSize(CSize szIcon) {
    m_szItemIcon = szIcon;
    Reposition();
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetImageList Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::SetImageList Method

Assigns an image list to a TaskPanel control.

void SetImageList(
    CImageList* pImageList,
    CSize szItemIcon = CSize(16, 16)
);
Parameters

pImageList
Pointer to the image list to be assigned to the TaskPanel control. This parameter can be NULL to update size of item icons.
szItemIcon
Items icon size to be used.

See Also

SetGroupImageList, GetImageManager

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetImageManager Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::SetImageManager Method

Call this method to assign new image manager.

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Pointer to the image manager object that stores the images in the task panel.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetItemLayout Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::SetItemLayout Method

Call this member to specify the item layout of the XTPTaskPanelItems. Layouts include text only, image only, image and text, and image with text below the image. This applies to all groups unless each groups layout is set individually.

void SetItemLayout(
    XTPTaskPanelItemLayout itemLayout
);
Parameters

itemLayout
The desired XTPTaskPanelItemLayout.

See Also

CXTPTaskPanelGroup::SetItemLayout

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetLayoutRTL Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::SetLayoutRTL Method

Call this member to set right-to-left mode.

void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetLockRedraw Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::SetLockRedraw Method

Call this method to lock/unlock redraw of controls.

void SetLockRedraw(
    BOOL bLockRedraw
);
Parameters

bLockRedraw
TRUE to lock redraw.

Remarks

bLockRedraw should be TRUE when you want to add a lot of items and don't want CXTPTaskPanel::Reposition and CXTPTaskPanel::ReDraw called each time an item is added.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetMargins Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::SetMargins Method

Call this method to set group outer margins.

void SetMargins(
    long nLeft,
    long nTop,
    long nRight,
    long nBottom,
    long nMiddle
);
Parameters

nLeft
Left margin.
nTop
Top margin,
nRight
Right margin,
nBottom
Bottom margin.
nMiddle
Margin between groups.

Remarks

This is used as the default margins for all groups.

See Also

GetMargins, CXTPTaskPanelPaintManager::GetGroupSpacing, CXTPTaskPanelPaintManager::GetGroupOuterMargins, CXTPTaskPanelPaintManager::GetGroupInnerMargins CXTPTaskPanelPaintManager::GetControlMargins

Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetMinimumGroupClientHeight Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source
CXTPTaskPanel::SetMinimumGroupClientHeight Method

Call this method to set minimum client height for all groups

void SetMinimumGroupClientHeight(
    int nMinClientHeight
);
Parameters

nMinClientHeight
Minimum client height

Body Source
void CXTPTaskPanel::SetMinimumGroupClientHeight(int nMinClientHeight) {
    m_nGroupMinClientHeight = nMinClientHeight;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetMultiColumn Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::SetMultiColumn Method

Call this member to set multi column groups.

void SetMultiColumn(
    BOOL bMultiColumn
);
Parameters

bMultiColumn
TRUE to set multicolumn groups

See Also

IsMultiColumn, SetColumnWidth

Body Source
void CXTPTaskPanel::SetMultiColumn(BOOL bMultiColumn) {
    m_bMultiColumn = bMultiColumn;
    Reposition();
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetSelectItemOnFocus Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::SetSelectItemOnFocus Method

Call this member to specify whether items will receive focus when they are clicked. If bSelect is TRUE, the item clicked receives focus and the previously focused item loses focus. This must be FALSE to use toggle buttons or to allow multiple items to have focus.

void SetSelectItemOnFocus(
    BOOL bSelect
);
Parameters

bSelect
TRUE if items will receive focus when they are clicked. If FALSE, items can be clicked, but they will not receive focus.

See Also

SetFocusedItem, GetFocusedItem

Body Source
void CXTPTaskPanel::SetSelectItemOnFocus(BOOL bSelect) {
    m_bSelectItemOnFocus = bSelect;
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetSingleSelection Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanel::SetSingleSelection Method

Call this method to allow only one item to be selected.

void SetSingleSelection(
    BOOL bSingleSelection = TRUE
);
Parameters

bSingleSelection
TRUE to use single selection.

See Also

IsSingleSelection, SetSelectItemOnFocus

Body Source
void CXTPTaskPanel::SetSingleSelection(BOOL bSingleSelection) {
    m_bSingleSelection = bSingleSelection;
    Reposition();
}
Group

CXTPTaskPanel Methods


CXTPTaskPanel::SetTheme Method

CXTPTaskPanel Methods, CXTPTaskPanel Class, See Also
CXTPTaskPanel::SetTheme Method

Call this member to switch the visual theme of the TaskPanel control.

void SetTheme(
    XTPTaskPanelPaintTheme paintTheme
);
Parameters

paintTheme
New visual theme. Can be any of the values listed in the Remarks section.

Remarks

paintTheme can be one of the following:

  • xtpTaskPanelThemeOffice2000 Enables Office 2000 style theme.
  • xtpTaskPanelThemeOffice2003 Enables Office 2003 style theme.
  • xtpTaskPanelThemeNativeWinXP Enables Explorer style theme.
  • xtpTaskPanelThemeOffice2000Plain Enables classic Office 2000 style theme.
  • xtpTaskPanelThemeOfficeXPPlain Enables classic Office XP style theme.
  • xtpTaskPanelThemeOffice2003Plain Enables classic Office 2003 style theme.
  • xtpTaskPanelThemeNativeWinXPPlain Enables classic Explorer style theme.
  • xtpTaskPanelThemeToolbox Enables VS.NET style Toolbox theme.
  • xtpTaskPanelThemeToolboxWhidbey Enables Whidbey VS 2005 style Toolbox theme.
  • xtpTaskPanelThemeListView Enables Standard List View theme.
  • xtpTaskPanelThemeListViewOfficeXP Enables Office XP List View theme.
  • xtpTaskPanelThemeListViewOffice2003 Enables Office 2003 List View theme.
  • xtpTaskPanelThemeShortcutBarOffice2003 Enables ShortcutBar Office 2003 theme.
See Also

CXTPTaskPanel::GetCurrentTheme

Group

CXTPTaskPanel Methods


CXTPTaskPanel::UpdateScrollBar Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::UpdateScrollBar Method

This method is called to update the task panel's scroll bar.

virtual void UpdateScrollBar();
Remarks

This updates the scroll bar that is displayed to scroll the entire task panel. This does not update the scroll bar placed inside a task panel group, they are updated with UpdateScrollButtons.

Group

CXTPTaskPanel Methods


CXTPTaskPanel::UpdateScrollButtons Method

CXTPTaskPanel Methods, CXTPTaskPanel Class
CXTPTaskPanel::UpdateScrollButtons Method

This member is called to update the enableddisabled state of the group scroll buttons.

void UpdateScrollButtons();
Remarks

RepositionScrollButtons, CXTPTaskPanelGroup::Scroll, and CXTPTaskPanelGroup::EnsureVisible call UpdateScrollButtons to update the state of the group scroll buttons.

Group

CXTPTaskPanel Methods


CXTPTaskPanel Constructors

CXTPTaskPanel Class, Legend, Public Methods
CXTPTaskPanel Constructors
Class

CXTPTaskPanel Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanel | Constructs a TaskPanel object


CXTPTaskPanel::CXTPTaskPanel Constructor

CXTPTaskPanel Constructors, CXTPTaskPanel Class
CXTPTaskPanel::CXTPTaskPanel Constructor

Constructs a TaskPanel object

CXTPTaskPanel();
Group

CXTPTaskPanel Constructors


CXTPTaskPanel Destructors

CXTPTaskPanel Class, Legend, Public Methods
CXTPTaskPanel Destructors
Class

CXTPTaskPanel Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTaskPanel | Destroys a CXTPTaskPanel object, handles cleanup and deallocation.


CXTPTaskPanel::~CXTPTaskPanel Destructor

CXTPTaskPanel Destructors, CXTPTaskPanel Class
CXTPTaskPanel::~CXTPTaskPanel Destructor

Destroys a CXTPTaskPanel object, handles cleanup and deallocation.

virtual ~CXTPTaskPanel();
Group

CXTPTaskPanel Destructors


CXTPTaskPanelExplorerTheme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelExplorerTheme Data Members, CXTPTaskPanelExplorerTheme Methods, CXTPTaskPanelExplorerTheme Constructors, CXTPTaskPanelExplorerTheme Constructors, CXTPTaskPanelExplorerTheme Data Members, CXTPTaskPanelExplorerTheme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerTheme Class

Class that represents an Explorer style theme.

Class Hierarchy

class CXTPTaskPanelExplorerTheme : public CXTPTaskPanelPaintManager;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Data Member
Method
CXTPTaskPanelExplorerTheme Constructors
CXTPTaskPanelExplorerTheme Constructors | Description
CXTPTaskPanelExplorerTheme | Constructs a CXTPTaskPanelExplorerTheme object.
CXTPTaskPanelExplorerTheme Data Members
CXTPTaskPanelExplorerTheme Data Members | Description
m_bExplorerTheme | TRUE to use Explorer theme under WinXP and to use office 2000 under older OSes.
CXTPTaskPanelExplorerTheme Methods
CXTPTaskPanelExplorerTheme Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelExplorerTheme Data Members

CXTPTaskPanelExplorerTheme Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerTheme Data Members
Class

CXTPTaskPanelExplorerTheme Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bExplorerTheme | TRUE to use Explorer theme under WinXP and to use office 2000 under older OSes.


CXTPTaskPanelExplorerTheme::m_bExplorerTheme Data Member

CXTPTaskPanelExplorerTheme Data Members, CXTPTaskPanelExplorerTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerTheme::m_bExplorerTheme Data Member

TRUE to use Explorer theme under WinXP and to use office 2000 under older OSes.

BOOL m_bExplorerTheme;
Group

CXTPTaskPanelExplorerTheme Data Members


CXTPTaskPanelExplorerTheme Methods

CXTPTaskPanelExplorerTheme Class, Legend, Public Methods
CXTPTaskPanelExplorerTheme Methods
Class

CXTPTaskPanelExplorerTheme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelExplorerTheme::RefreshMetrics Method

CXTPTaskPanelExplorerTheme Methods, CXTPTaskPanelExplorerTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelExplorerTheme Methods


CXTPTaskPanelExplorerTheme Constructors

CXTPTaskPanelExplorerTheme Class, Legend, Public Methods
CXTPTaskPanelExplorerTheme Constructors
Class

CXTPTaskPanelExplorerTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelExplorerTheme | Constructs a CXTPTaskPanelExplorerTheme object.


CXTPTaskPanelExplorerTheme::CXTPTaskPanelExplorerTheme Constructor

CXTPTaskPanelExplorerTheme Constructors, CXTPTaskPanelExplorerTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerTheme::CXTPTaskPanelExplorerTheme Constructor

Constructs a CXTPTaskPanelExplorerTheme object.

CXTPTaskPanelExplorerTheme();
Group

CXTPTaskPanelExplorerTheme Constructors


CXTPTaskPanelExplorerThemePlain Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelExplorerThemePlain Data Members, CXTPTaskPanelExplorerThemePlain Methods, CXTPTaskPanelExplorerThemePlain Constructors, CXTPTaskPanelExplorerThemePlain Constructors, CXTPTaskPanelExplorerThemePlain Data Members, CXTPTaskPanelExplorerThemePlain Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerThemePlain Class

The CXTPTaskPanelExplorerThemePlain class is used to enable a classic Explorer style theme.

Class Hierarchy

class CXTPTaskPanelExplorerThemePlain : public CXTPTaskPanelPaintManagerPlain;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Data Member
Method
CXTPTaskPanelExplorerThemePlain Constructors
CXTPTaskPanelExplorerThemePlain Constructors | Description
CXTPTaskPanelExplorerThemePlain | Constructs a CXTPTaskPanelExplorerThemePlain object.
CXTPTaskPanelExplorerThemePlain Data Members
CXTPTaskPanelExplorerThemePlain Data Members | Description
m_bExplorerTheme | TRUE to use Explorer theme under WinXP and to use Office 2000 under older OSes.
CXTPTaskPanelExplorerThemePlain Methods
CXTPTaskPanelExplorerThemePlain Methods | Description
DrawCaptionGripper | This method is called to draw gripper of the caption.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelExplorerThemePlain Data Members

CXTPTaskPanelExplorerThemePlain Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerThemePlain Data Members
Class

CXTPTaskPanelExplorerThemePlain Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bExplorerTheme | TRUE to use Explorer theme under WinXP and to use Office 2000 under older OSes.


CXTPTaskPanelExplorerThemePlain::m_bExplorerTheme Data Member

CXTPTaskPanelExplorerThemePlain Data Members, CXTPTaskPanelExplorerThemePlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerThemePlain::m_bExplorerTheme Data Member

TRUE to use Explorer theme under WinXP and to use Office 2000 under older OSes.

BOOL m_bExplorerTheme;
Group

CXTPTaskPanelExplorerThemePlain Data Members


CXTPTaskPanelExplorerThemePlain Methods

CXTPTaskPanelExplorerThemePlain Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerThemePlain Methods
Class

CXTPTaskPanelExplorerThemePlain Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawCaptionGripper | This method is called to draw gripper of the caption.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelExplorerThemePlain::DrawCaptionGripper Method

CXTPTaskPanelExplorerThemePlain Methods, CXTPTaskPanelExplorerThemePlain Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerThemePlain::DrawCaptionGripper Method

This method is called to draw gripper of the caption.

CRect DrawCaptionGripper(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be drawn.

Returns

Rectangle of caption after draw.

Remarks

The caption gripper is the button that allows the group to be expanded and collapsed.

If the current operating system is Windows Xp and the current theme is xtpSystemThemeBlue, xtpSystemThemeOlive, or xtpSystemThemeSilver then the gripper bitmap is loaded from the operating system. The WinXp gripper is created with CXTPTaskPanelPaintManager::CreateGripperBitmaps. For all other OS and themes, CXTPTaskPanelPaintManager::CreateGripperIcon is used to create an emulated version of the Windows Xp gripper.

If m_bExplorerTheme is FALSE, then CXTPTaskPanelPaintManager::DrawCaptionGripper is used to draw the gripper, so no bitmap is used.

If m_bExplorerTheme is TRUE, then CXTPTaskPanelPaintManager::DrawCaptionGripperBitmap is used to draw the gripper, this load a bitmap as mentioned before.

See Also

CXTPTaskPanelPaintManager::DrawCaptionGripperBitmap, CXTPTaskPanelPaintManager::DrawCaptionGripperSigns

Group

CXTPTaskPanelExplorerThemePlain Methods


CXTPTaskPanelExplorerThemePlain::RefreshMetrics Method

CXTPTaskPanelExplorerThemePlain Methods, CXTPTaskPanelExplorerThemePlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerThemePlain::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelExplorerThemePlain Methods


CXTPTaskPanelExplorerThemePlain Constructors

CXTPTaskPanelExplorerThemePlain Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerThemePlain Constructors
Class

CXTPTaskPanelExplorerThemePlain Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelExplorerThemePlain | Constructs a CXTPTaskPanelExplorerThemePlain object.


CXTPTaskPanelExplorerThemePlain::CXTPTaskPanelExplorerThemePlain Constructor

CXTPTaskPanelExplorerThemePlain Constructors, CXTPTaskPanelExplorerThemePlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelExplorerThemePlain::CXTPTaskPanelExplorerThemePlain Constructor

Constructs a CXTPTaskPanelExplorerThemePlain object.

CXTPTaskPanelExplorerThemePlain();
Group

CXTPTaskPanelExplorerThemePlain Constructors


CXTPTaskPanelGroup Class

XTPTaskPanelGroup.h, Classes, Legend, Members, Topics, CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Constructors, CXTPTaskPanelGroup Destructors, CXTPTaskPanelGroup Constructors, CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Destructors, CXTPTaskPanelGroup Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup Class

CXTPTaskPanelGroup is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single group.

Class Hierarchy

class CXTPTaskPanelGroup : public CXTPTaskPanelItem;
File

XTPTaskPanelGroup.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTaskPanelGroup Constructors
CXTPTaskPanelGroup Constructors | Description
CXTPTaskPanelGroup | Constructs a CXTPTaskPanelGroup object
CXTPTaskPanelGroup Data Members
CXTPTaskPanelGroup Data Members | Description
m_bCaptionVisible | TRUE if caption is visible.
m_bExpandable | TRUE if group is expandable.
m_bExpanded | TRUE if group is expanded.
m_bExpanding | TRUE if group is expanding now.
m_bSpecial | TRUE if group is special.
m_itemLayout | Currently set layout for the group.
m_nCaptionHeight | Height of caption.
m_nExpandedClientHeight | Expanded client height.
m_nItemsInRow | Number of group items in a row when using the xtpTaskPanelBehaviourToolbox XTPTaskPanelBehaviour.
m_nMinClientHeight | Minimum client height.
m_nScrollOffset | Scroll offset of group.
m_pItems | Collection of items.
m_rcGroupCurrent | Current rectangle of group during animation.
m_rcGroupTarget | Target rectangle of group during animation.
m_rcMarginsInner | Inner margins.
m_rcMarginsOuter | Outer margins.
m_szItemIcon | Size of group item icons.
CXTPTaskPanelGroup Destructors
CXTPTaskPanelGroup Destructors | Description
~CXTPTaskPanelGroup | Destroys a CXTPTaskPanelGroup object, handles cleanup and deallocation.
CXTPTaskPanelGroup Methods
CXTPTaskPanelGroup Methods | Description
AddControlItem | Call this method to add a new control item to group.
AddLinkItem | Call this method to add a new link item to group.
AddTextItem | Call this method to add a new text item to group.
CalcInsideHeight | This method is called to determine the area that can be used to draw the Active group if the behavior is not xtpTaskPanelBehaviourExplorer.
DoPropExchange | Reads or writes this object from or to an archive.
EnsureVisible | Call this member to make sure that an item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.
FindItem | Call this member to find item with specified identifier.
GetAt | This method retrieves an item with the specified index.
GetCaptionHeight | Call this member to get the height of the group caption.
GetCaptionRect | Call this method to get the rectangle of the caption.
GetClientRect | Call this method to get the current rectangle of the client.
GetExpandedClientHeight | Call this function to get the height of expanded group.
GetHitTestRect | Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group caption.
GetInnerMargins | Retrieves inner margins of group
GetInvalidateRect | Call this member to retrieve the rectangle of the "drawing zone"
GetItemCount | Call this member to determine the number of items that are in this group.
GetItemIconSize | Call this member too get the size used to draw group item icons.
GetItemLayout | Call this member to determine the item layout currently used for this group.
GetItems | Call this method to get collection of group items.
GetItemsInRow | Call this member to get the number of group items per row in the task panel group.
GetMinimumClientHeight | Retrieves minimum client height for individual group
GetNextVisibleItem | This method finds next visible item in specified direction.
GetOffsetItem | Call this member to get the index of the first visible item in group.
GetOuterMargins | Retrieves outer margins of group
GetScrollOffsetPos | This member is called to get the scroll offset of the first visible item in the group in pixels.
GetTargetCaptionRect | Call this method to get the target rectangle of caption.
GetTargetClientRect | Call this method to get the target rectangle of the client.
HitTest | This method determines where a point lies in a specified item.
IsAcceptFocus | Call this member to determine if the group can accept focus.
IsCaptionVisible | Retrieves if caption is visible.
IsChildItemDragOver | This member is called to check to see if the item currently being dragged over the group belongs to the group.
IsDirty | This member is called to determine if the current group position is "dirty" i.e. Moving during animation.
IsExpandable | Call this method to determine if group is expandable.
IsExpanded | Call this member to determine if the group is currently expanded.
IsExpanding | Call this member to determine if a group is currently expanding.
IsItemVisible | This method is called to determine if item is visible in the group
IsScrollButtonEnabled | Call this member to determine if a group scroll button is enabled.
IsSpecialGroup | Call this function to determine if the group is special. A If a group is special, it will appear in a different color than the other groups. Groups marked as special will be displayed differently than normal groups drawing the users attention to that particular group. This is an excellent way to show the user the "default" or important items
OnAnimate | This method is called when an animation step is executed.
OnCalcClientHeight | This method is called to calculate the group client area needed to display all items.
OnFillClient | This method is called when the task panel group client area is drawn.
OnPaint | This method is called to draw a group.
OnRemoved | This method is called when group was removed from parent groups collection
OnReposition | This method is called when a group is repositioned.
Scroll | Call this member to scroll to an item in the task panel group. When the group has scroll buttons.
SetClientBitmap | Call this member to draw a bitmap in the lower right corner of a task panel group.
SetExpandable | Call this method to set expandable state of group.
SetExpanded | Call this method to expand or collapse the group.
SetIconSize | Call this member to set the icon size of the group items.
SetItemLayout | Call this member to specify the item layout of the XTPTaskPanelItems in this group. Layouts include text only, image only, image and text, and image with text below the image. This will apply to this group only.
SetMinimumClientHeight | Call this method to set minimum client height for individual group
SetOffsetItem | This method is called to set index of the first visible item in the group
SetSelectedItem | Call this member to select a task panel group item. Multiple items can have focus if CXTPTaskPanel::m_bSelectItemOnFocus is FALSE.
SetSpecialGroup | Call this method to make the group special.
ShowCaption | Call this method to show or hide group's caption.


CXTPTaskPanelGroup Data Members

CXTPTaskPanelGroup Class, Legend, Protected Data Members
CXTPTaskPanelGroup Data Members
Class

CXTPTaskPanelGroup Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bCaptionVisible | TRUE if caption is visible.
m_bExpandable | TRUE if group is expandable.
m_bExpanded | TRUE if group is expanded.
m_bExpanding | TRUE if group is expanding now.
m_bSpecial | TRUE if group is special.
m_itemLayout | Currently set layout for the group.
m_nCaptionHeight | Height of caption.
m_nExpandedClientHeight | Expanded client height.
m_nItemsInRow | Number of group items in a row when using the xtpTaskPanelBehaviourToolbox XTPTaskPanelBehaviour.
m_nMinClientHeight | Minimum client height.
m_nScrollOffset | Scroll offset of group.
m_pItems | Collection of items.
m_rcGroupCurrent | Current rectangle of group during animation.
m_rcGroupTarget | Target rectangle of group during animation.
m_rcMarginsInner | Inner margins.
m_rcMarginsOuter | Outer margins.
m_szItemIcon | Size of group item icons.


CXTPTaskPanelGroup::m_bCaptionVisible Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_bCaptionVisible Data Member

TRUE if caption is visible.

BOOL m_bCaptionVisible;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_bExpandable Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_bExpandable Data Member

TRUE if group is expandable.

BOOL m_bExpandable;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_bExpanded Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_bExpanded Data Member

TRUE if group is expanded.

BOOL m_bExpanded;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_bExpanding Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_bExpanding Data Member

TRUE if group is expanding now.

BOOL m_bExpanding;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_bSpecial Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_bSpecial Data Member

TRUE if group is special.

BOOL m_bSpecial;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_itemLayout Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_itemLayout Data Member

Currently set layout for the group.

XTPTaskPanelItemLayout m_itemLayout;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_nCaptionHeight Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_nCaptionHeight Data Member

Height of caption.

int m_nCaptionHeight;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_nExpandedClientHeight Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_nExpandedClientHeight Data Member

Expanded client height.

int m_nExpandedClientHeight;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_nItemsInRow Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_nItemsInRow Data Member

Number of group items in a row when using the xtpTaskPanelBehaviourToolbox XTPTaskPanelBehaviour.

int m_nItemsInRow;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_nMinClientHeight Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_nMinClientHeight Data Member

Minimum client height.

int m_nMinClientHeight;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_nScrollOffset Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_nScrollOffset Data Member

Scroll offset of group.

int m_nScrollOffset;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_pItems Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_pItems Data Member

Collection of items.

CXTPTaskPanelGroupItems* m_pItems;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_rcGroupCurrent Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_rcGroupCurrent Data Member

Current rectangle of group during animation.

CRect m_rcGroupCurrent;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_rcGroupTarget Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_rcGroupTarget Data Member

Target rectangle of group during animation.

CRect m_rcGroupTarget;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_rcMarginsInner Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_rcMarginsInner Data Member

Inner margins.

CRect m_rcMarginsInner;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_rcMarginsOuter Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_rcMarginsOuter Data Member

Outer margins.

CRect m_rcMarginsOuter;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup::m_szItemIcon Data Member

CXTPTaskPanelGroup Data Members, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::m_szItemIcon Data Member

Size of group item icons.

CSize m_szItemIcon;
Group

CXTPTaskPanelGroup Data Members


CXTPTaskPanelGroup Methods

CXTPTaskPanelGroup Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup Methods
Class

CXTPTaskPanelGroup Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
CalcInsideHeight | This method is called to determine the area that can be used to draw the Active group if the behavior is not xtpTaskPanelBehaviourExplorer.
OnCalcClientHeight | This method is called to calculate the group client area needed to display all items.
OnRemoved | This method is called when group was removed from parent groups collection
Public Methods
Public Methods
Public Method | Description
AddControlItem | Call this method to add a new control item to group.
AddLinkItem | Call this method to add a new link item to group.
AddTextItem | Call this method to add a new text item to group.
DoPropExchange | Reads or writes this object from or to an archive.
EnsureVisible | Call this member to make sure that an item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.
FindItem | Call this member to find item with specified identifier.
GetAt | This method retrieves an item with the specified index.
GetCaptionHeight | Call this member to get the height of the group caption.
GetCaptionRect | Call this method to get the rectangle of the caption.
GetClientRect | Call this method to get the current rectangle of the client.
GetExpandedClientHeight | Call this function to get the height of expanded group.
GetHitTestRect | Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group caption.
GetInnerMargins | Retrieves inner margins of group
GetInvalidateRect | Call this member to retrieve the rectangle of the "drawing zone"
GetItemCount | Call this member to determine the number of items that are in this group.
GetItemIconSize | Call this member too get the size used to draw group item icons.
GetItemLayout | Call this member to determine the item layout currently used for this group.
GetItems | Call this method to get collection of group items.
GetItemsInRow | Call this member to get the number of group items per row in the task panel group.
GetMinimumClientHeight | Retrieves minimum client height for individual group
GetNextVisibleItem | This method finds next visible item in specified direction.
GetOffsetItem | Call this member to get the index of the first visible item in group.
GetOuterMargins | Retrieves outer margins of group
GetScrollOffsetPos | This member is called to get the scroll offset of the first visible item in the group in pixels.
GetTargetCaptionRect | Call this method to get the target rectangle of caption.
GetTargetClientRect | Call this method to get the target rectangle of the client.
HitTest | This method determines where a point lies in a specified item.
IsAcceptFocus | Call this member to determine if the group can accept focus.
IsCaptionVisible | Retrieves if caption is visible.
IsChildItemDragOver | This member is called to check to see if the item currently being dragged over the group belongs to the group.
IsDirty | This member is called to determine if the current group position is "dirty" i.e. Moving during animation.
IsExpandable | Call this method to determine if group is expandable.
IsExpanded | Call this member to determine if the group is currently expanded.
IsExpanding | Call this member to determine if a group is currently expanding.
IsItemVisible | This method is called to determine if item is visible in the group
IsScrollButtonEnabled | Call this member to determine if a group scroll button is enabled.
IsSpecialGroup | Call this function to determine if the group is special. A If a group is special, it will appear in a different color than the other groups. Groups marked as special will be displayed differently than normal groups drawing the users attention to that particular group. This is an excellent way to show the user the "default" or important items
OnAnimate | This method is called when an animation step is executed.
OnFillClient | This method is called when the task panel group client area is drawn.
OnPaint | This method is called to draw a group.
OnReposition | This method is called when a group is repositioned.
Scroll | Call this member to scroll to an item in the task panel group. When the group has scroll buttons.
SetClientBitmap | Call this member to draw a bitmap in the lower right corner of a task panel group.
SetExpandable | Call this method to set expandable state of group.
SetExpanded | Call this method to expand or collapse the group.
SetIconSize | Call this member to set the icon size of the group items.
SetItemLayout | Call this member to specify the item layout of the XTPTaskPanelItems in this group. Layouts include text only, image only, image and text, and image with text below the image. This will apply to this group only.
SetMinimumClientHeight | Call this method to set minimum client height for individual group
SetOffsetItem | This method is called to set index of the first visible item in the group
SetSelectedItem | Call this member to select a task panel group item. Multiple items can have focus if CXTPTaskPanel::m_bSelectItemOnFocus is FALSE.
SetSpecialGroup | Call this method to make the group special.
ShowCaption | Call this method to show or hide group's caption.


CXTPTaskPanelGroup::AddControlItem Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::AddControlItem Method

Call this method to add a new control item to group.

CXTPTaskPanelGroupItem* AddControlItem(
    HWND hWnd
);
Parameters

hWnd
Window Handle

Returns

A pointer to created CXTPTaskPanelGroupItem class

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::AddLinkItem Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::AddLinkItem Method

Call this method to add a new link item to group.

CXTPTaskPanelGroupItem* AddLinkItem(
    UINT nID,
    int nImage = -1
);
Parameters

nID
Identifier of item to be added.
nImage
Image index in TaskPanel image list.

Returns

A pointer to the created CXTPTaskPanelGroupItem class

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::AddTextItem Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::AddTextItem Method

Call this method to add a new text item to group.

CXTPTaskPanelGroupItem* AddTextItem(
    LPCTSTR strText
);
Parameters

strText
Items text

Returns

A pointer to created CXTPTaskPanelGroupItem class

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::CalcInsideHeight Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::CalcInsideHeight Method

This method is called to determine the area that can be used to draw the Active group if the behavior is not xtpTaskPanelBehaviourExplorer.

int CalcInsideHeight();
Returns

Height in pixels after group caption or available area.

See Also

OnCalcClientHeight

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::DoPropExchange Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::EnsureVisible Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::EnsureVisible Method

Call this member to make sure that an item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.

void EnsureVisible(
    CXTPTaskPanelGroupItem* pItem,
    BOOL bUpdateScrollButtons = TRUE
);
Parameters

pItem
Item that should be visible.
bUpdateScrollButtons
TRUE to update the scroll buttons, if needed, to reflect the position of the group.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::FindItem Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::FindItem Method

Call this member to find item with specified identifier.

CXTPTaskPanelGroupItem* FindItem(
    int nID
) const;
Parameters

nID
Identifier of the item to be found.

Returns

A pointer to item if successful; otherwise returns NULL.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetAt Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetAt Method

This method retrieves an item with the specified index.

CXTPTaskPanelGroupItem* GetAt(
    int nIndex
) const;
Parameters

nIndex
Specifies the zero-based index of the item to retrieve.

Returns

A pointer to a CXTPTaskPanelGroupItem object.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetCaptionHeight Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetCaptionHeight Method

Call this member to get the height of the group caption.

int GetCaptionHeight() const;
Returns

Height of group caption.

Body Source
int CXTPTaskPanelGroup::GetCaptionHeight() const {
    return m_nCaptionHeight;
}
Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetCaptionRect Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetCaptionRect Method

Call this method to get the rectangle of the caption.

CRect GetCaptionRect() const;
Returns

Caption rectangle.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetClientRect Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetClientRect Method

Call this method to get the current rectangle of the client.

CRect GetClientRect() const;
Returns

Client rectangle.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetExpandedClientHeight Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetExpandedClientHeight Method

Call this function to get the height of expanded group.

int GetExpandedClientHeight() const;
Returns

Client height of expanded group.

Body Source
int CXTPTaskPanelGroup::GetExpandedClientHeight() const {
    return m_nExpandedClientHeight;
}
Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetHitTestRect Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetHitTestRect Method

Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group caption.

virtual CRect GetHitTestRect() const;
Returns

The rectangle of the "tooltip zone" while the mouse is positioned over the group caption.

Remarks

The "tooltip zone" is the area that a tooltip will be displayed while the mouse is positioned over the group caption.

See Also

CXTPTaskPanelGroupItem::GetHitTestRect

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetInnerMargins Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetInnerMargins Method

Retrieves inner margins of group

CRect& GetInnerMargins();
Returns

Inner margins

Body Source
CRect& CXTPTaskPanelGroup::GetInnerMargins() {
    return m_rcMarginsInner;
}
Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetInvalidateRect Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetInvalidateRect Method

Call this member to retrieve the rectangle of the "drawing zone"

virtual CRect GetInvalidateRect() const;
See Also

CXTPTaskPanelGroupItem::GetHitTestRect

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetItemCount Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetItemCount Method

Call this member to determine the number of items that are in this group.

int GetItemCount() const;
Returns

Number of items in this group.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetItemIconSize Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetItemIconSize Method

Call this member too get the size used to draw group item icons.

CSize GetItemIconSize() const;
Returns

Currently set group item icon size.

See Also

SetItemIconSize

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetItemLayout Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetItemLayout Method

Call this member to determine the item layout currently used for this group.

XTPTaskPanelItemLayout GetItemLayout() const;
Returns

The currently set XTPTaskPanelItemLayout for this group.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetItems Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetItems Method

Call this method to get collection of group items.

CXTPTaskPanelItems* GetItems() const;
Returns

Collection of items of group

Body Source
CXTPTaskPanelItems* CXTPTaskPanelGroup::GetItems() const {
    ASSERT(m_pItems);
    return (CXTPTaskPanelItems*)m_pItems;
}
Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetItemsInRow Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetItemsInRow Method

Call this member to get the number of group items per row in the task panel group.

int GetItemsInRow() const;
Returns

The number of group items per row in the group.

See Also

If the task panel behavior is set to xtpTaskPanelBehaviourExplorer or xtpTaskPanelBehaviourList, then the number of items per row is always 1. If the behavior is set to xtpTaskPanelBehaviourToolbox, then there can be multiple items per row.

If the behavior is set to to xtpTaskPanelBehaviourExplorer or xtpTaskPanelBehaviourList, then the layout must be set to xtpTaskItemLayoutImages for multiple items on a row.

XTPTaskPanelBehaviour, XTPTaskPanelItemLayout, Scroll

Body Source
int CXTPTaskPanelGroup::GetItemsInRow() const {
    return m_nItemsInRow;
}
Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetMinimumClientHeight Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetMinimumClientHeight Method

Retrieves minimum client height for individual group

int GetMinimumClientHeight() const;
Returns

Minimum client height

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetNextVisibleItem Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetNextVisibleItem Method

This method finds next visible item in specified direction.

CXTPTaskPanelGroupItem* GetNextVisibleItem(
    int nIndex,
    int nDirection = +1
) const;
Parameters

nIndex
Index of the item to begin the searching with
nDirection
Direction to find (1 to forward, -1 to backward)

Returns

Next visible item; or NULL if not found.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetOffsetItem Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetOffsetItem Method

Call this member to get the index of the first visible item in group.

int GetOffsetItem() const;
Returns

Index of first visible item in group.

Remarks

This will return the index of the first visible item in the group, this is helpful when the items in the group are scrolled.

See Also

GetScrollOffsetPos, Scroll, GetItemCount, GetItemsInRow

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetOuterMargins Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetOuterMargins Method

Retrieves outer margins of group

CRect& GetOuterMargins();
Returns

Outer margins

Body Source
CRect& CXTPTaskPanelGroup::GetOuterMargins() {
    return m_rcMarginsOuter;
}
Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetScrollOffsetPos Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::GetScrollOffsetPos Method

This member is called to get the scroll offset of the first visible item in the group in pixels.

int GetScrollOffsetPos() const;
Returns

Scroll offset of first visible item in group in pixels.

Remarks

GetScrollOffsetPos returns the height in pixels that has been scrolled. GetOffsetItem gets the index of the first visible item.

See Also

Scroll, GetOffsetItem, GetItemCount, GetItemsInRow

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetTargetCaptionRect Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetTargetCaptionRect Method

Call this method to get the target rectangle of caption.

CRect GetTargetCaptionRect() const;
Returns

Target caption rectangle

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::GetTargetClientRect Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::GetTargetClientRect Method

Call this method to get the target rectangle of the client.

CRect GetTargetClientRect() const;
Returns

Target client rectangle

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::HitTest Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::HitTest Method

This method determines where a point lies in a specified item.

CXTPTaskPanelGroupItem* HitTest(
    CPoint pt,
    CRect* lpRect = 0
) const;
Parameters

pt
Specifies the point to be tested.
lpRect
Retrieves bounding rectangle of the item. Can be NULL if you don't need it.

Returns

A pointer to a CXTPTaskPanelGroupItem item that occupies the specified point or NULL if no item occupies the point.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsAcceptFocus Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::IsAcceptFocus Method

Call this member to determine if the group can accept focus.

BOOL IsAcceptFocus() const;
Returns

TRUE if the group can receive focus, FALSE if the group cannot receive focus.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsCaptionVisible Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::IsCaptionVisible Method

Retrieves if caption is visible.

BOOL IsCaptionVisible() const;
Returns

TRUE if caption is visible, FALSE if caption is hidden.

See Also

ShowCaption

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsChildItemDragOver Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::IsChildItemDragOver Method

This member is called to check to see if the item currently being dragged over the group belongs to the group.

BOOL IsChildItemDragOver() const;
Returns

TRUE if the item belongs to the group, FALSE otherwise.

Remarks

This checks to see if CSTPTaskPanel::m_pItemDragOver belongs to the group. This is used in the PaintManager to determine if an inverted rectangle must be drawn for the item. An inverted rectangle is only drawn when the XTPTaskPanelPaintTheme is set to xtpTaskPanelThemeToolbox.

See Also

XTPTaskPanelPaintTheme, CXTPTaskPanelToolboxTheme::DrawGroupCaption

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsDirty Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::IsDirty Method

This member is called to determine if the current group position is "dirty" i.e. Moving during animation.

BOOL IsDirty() const;
Returns

TRUE if current position of group is dirty.

Remarks

During animation, the group moves from it's oldcurrent position to the newtarget position. IsDirty indicates that the animation has not finished yet and its current position is <> to the target position. The oldcurrent position is stored in m_rcGroupCurrent, and the newtarget position is stored in m_rcGroupTarget.

Animation occurs when the task panel first becomes visible and when the expandcollapse button is clicked in the group caption.

See Also

CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, OnAnimate, m_rcGroupTarget, m_rcGroupCurrent

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsExpandable Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::IsExpandable Method

Call this method to determine if group is expandable.

BOOL IsExpandable() const;
Returns

TRUE is the groups is expandable, FALSE if it can't be expanded.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsExpanded Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::IsExpanded Method

Call this member to determine if the group is currently expanded.

BOOL IsExpanded() const;
Returns

TRUE if the group is expanded, FALSE if the group is collapsed.

See Also

SetExpanded, CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, IsExpanding

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsExpanding Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::IsExpanding Method

Call this member to determine if a group is currently expanding.

BOOL IsExpanding() const;
Returns

TRUE is group is currently in the process of expanding, FALSE otherwise.

See Also

SetExpanded, CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, IsExpanded

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsItemVisible Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::IsItemVisible Method

This method is called to determine if item is visible in the group

BOOL IsItemVisible(
    CXTPTaskPanelGroupItem* pItem,
    BOOL bAllowPart
) const;
Parameters

pItem
Item to test
bAllowPart
TRUE to allow partially visible item.

Returns

TRUE if item is visible; FALSE otherwise.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsScrollButtonEnabled Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::IsScrollButtonEnabled Method

Call this member to determine if a group scroll button is enabled.

BOOL IsScrollButtonEnabled(
    BOOL bScrollButtonUp
) const;
Parameters

bScrollButtonUp
If TRUE, check to see if the "scroll up" button is enabled, If FALSE, check to see if the "scroll down" button is enabled.

Returns

TRUE is the group scroll button is enabled, FALSE if the buttons is disabled.

Remarks

CXTPTaskPanel::UpdateScrollButtons uses this method to update the state of the scroll buttons.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::IsSpecialGroup Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::IsSpecialGroup Method

Call this function to determine if the group is special. A If a group is special, it will appear in a different color than the other groups. Groups marked as special will be displayed differently than normal groups drawing the users attention to that particular group. This is an excellent way to show the user the "default" or important items

BOOL IsSpecialGroup() const;
Returns

TRUE is the groups is special, FALSE otherwise.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::OnAnimate Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::OnAnimate Method

This method is called when an animation step is executed.

void OnAnimate(
    int nStep
);
Parameters

nStep
Step of animation.

Remarks

CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, OnReposition

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::OnCalcClientHeight Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::OnCalcClientHeight Method

This method is called to calculate the group client area needed to display all items.

virtual void OnCalcClientHeight(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
rc
Bounding rectangle of the task panel group.

See Also

CalcInsideHeight

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::OnFillClient Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::OnFillClient Method

This method is called when the task panel group client area is drawn.

virtual void OnFillClient(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
rc
CRect object specifying size of area.

Remarks

This method is called from CXTPTaskPanelPaintManager::DrawGroupClientFace when the group client face needs filled.

This method checks to see if a bitmap should be drawn in the lower right corner of the task panel group. Then it will drawn the bitmap if a bitmap was added. A bitmap can be added with the SetClientBitmap method.

See Also

SetClientBitmap

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::OnPaint Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::OnPaint Method

This method is called to draw a group.

void OnPaint(
    CDC* pDC
);
Parameters

pDC
Points to the client device context.

Remarks

OnPaint calls CXTPTaskPanelPaintManager::DrawGroupCaption and CXTPTaskPanelPaintManager::DrawGroupClient.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::OnRemoved Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::OnRemoved Method

This method is called when group was removed from parent groups collection

void OnRemoved();
Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::OnReposition Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::OnReposition Method

This method is called when a group is repositioned.

CRect OnReposition(
    CRect rc,
    BOOL bRecalcOnly = TRUE
);
Parameters

rc
new group's position.
bRecalcOnly
TRUE to recalculate only.

Returns

Target location of group (m_rcGroupTarget).

Remarks

During animation the groups need to be repositioned. This method will return the target location of the group.

CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, OnAnimate

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::Scroll Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::Scroll Method

Call this member to scroll to an item in the task panel group. When the group has scroll buttons.

void Scroll(
    int nDelta
);
Parameters

nDelta
Offset of item to scroll to. GetItemCount and GetOffsetItem can be used to determine which item you need to scroll to.

Remarks

The scroll offset starts at zero. The offset will remain at zero until the group's view is too small to display all of items. If the group is scrolled, the offset will increment by 1 for each item that is scrolled from the top. For example, If the top top items in the group are not visible, then the scroll offset is 4 (zero based index).

GetItemCount and GetOffsetItem can be used to determine which item to scroll to. Setting nDelta to 0 will scroll to the top of the group.

Notes

If there are more than 1 item in a row like when the XTPTaskPanelItemLayout is set to xtpTaskItemLayoutImages, then the offset will increment by GetItemsInRow.

See Also

GetScrollOffsetPos, GetOffsetItem, GetItemCount, GetItemsInRow

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetClientBitmap Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::SetClientBitmap Method

Call this member to draw a bitmap in the lower right corner of a task panel group.

void SetClientBitmap(
    UINT nID,
    COLORREF clrTransparent,
    int nBackgroundAlignemnt = DT_RIGHT | DT_BOTTOM
);
Parameters

nID
Bitmap resource identifier.
clrTransparent
Color in bitmap to make transparent when bAlpha is FALSE.
nBackgroundAlignemnt
Alignment of bitmap to draw

Remarks

The bitmap will always be in the lower right corner of the group, and will not move. The bitmap is drawn on the group in the OnFillClient method.

See Also

OnFillClient

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetExpandable Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::SetExpandable Method

Call this method to set expandable state of group.

void SetExpandable(
    BOOL bExpandable
);
Parameters

bExpandable
TRUE if group is expandable.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetExpanded Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::SetExpanded Method

Call this method to expand or collapse the group.

void SetExpanded(
    BOOL bExpanded
);
Parameters

bExpanded
TRUE to expand group; otherwise FALSE.

See Also

CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, IsExpanding, IsExpanded

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetIconSize Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::SetIconSize Method

Call this member to set the icon size of the group items.

void SetIconSize(
    CSize szItemIcon
);
Parameters

szItemIcon
Item icon size.

See Also

GetItemIconSize

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetItemLayout Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::SetItemLayout Method

Call this member to specify the item layout of the XTPTaskPanelItems in this group. Layouts include text only, image only, image and text, and image with text below the image. This will apply to this group only.

void SetItemLayout(
    XTPTaskPanelItemLayout itemLayout
);
Parameters

itemLayout
The desired XTPTaskPanelItemLayout for this group.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetMinimumClientHeight Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::SetMinimumClientHeight Method

Call this method to set minimum client height for individual group

void SetMinimumClientHeight(
    int nMinClientHeight
);
Parameters

nMinClientHeight
Minimum client height

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetOffsetItem Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::SetOffsetItem Method

This method is called to set index of the first visible item in the group

void SetOffsetItem(
    int nScrollOffset,
    BOOL bUpdateScrollButtons = TRUE
);
Parameters

nScrollOffset
First visible item in the group to be set
bUpdateScrollButtons
TRUE to refresh scroll buttons state.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetSelectedItem Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroup::SetSelectedItem Method

Call this member to select a task panel group item. Multiple items can have focus if CXTPTaskPanel::m_bSelectItemOnFocus is FALSE.

void SetSelectedItem(
    CXTPTaskPanelGroupItem* pItem
);
Parameters

pItem
Pointer to a task panel group item.

Remarks

Selected items will appear "pressed" or highlighted depending on the selected theme. Selected items will have XTPTaskPanelGroupItem::m_bSelected as TRUE.

See Also

XTPTaskPanelGroupItem::IsItemSelected, XTPTaskPanelGroupItem::SetItemSelected

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::SetSpecialGroup Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::SetSpecialGroup Method

Call this method to make the group special.

void SetSpecialGroup(
    BOOL bSpecial = TRUE
);
Parameters

bSpecial
TRUE if group is special.

Remarks

If a group is special, it will appear in a different color than the other groups. Groups marked as special will be displayed differently than normal groups drawing the users attention to that particular group. This is an excellent way to show the user the "default" or important items.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup::ShowCaption Method

CXTPTaskPanelGroup Methods, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::ShowCaption Method

Call this method to show or hide group's caption.

void ShowCaption(
    BOOL bShow
);
Parameters

bShow
TRUE to show caption; otherwise FALSE.

Group

CXTPTaskPanelGroup Methods


CXTPTaskPanelGroup Constructors

CXTPTaskPanelGroup Class, Legend, Public Methods
CXTPTaskPanelGroup Constructors
Class

CXTPTaskPanelGroup Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelGroup | Constructs a CXTPTaskPanelGroup object


CXTPTaskPanelGroup::CXTPTaskPanelGroup Constructor

CXTPTaskPanelGroup Constructors, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::CXTPTaskPanelGroup Constructor

Constructs a CXTPTaskPanelGroup object

CXTPTaskPanelGroup(
    CXTPTaskPanel* pPanel = NULL
);
Parameters

pPanel
Parent task panel pointer.

Group

CXTPTaskPanelGroup Constructors


CXTPTaskPanelGroup Destructors

CXTPTaskPanelGroup Class, Legend, Public Methods
CXTPTaskPanelGroup Destructors
Class

CXTPTaskPanelGroup Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTaskPanelGroup | Destroys a CXTPTaskPanelGroup object, handles cleanup and deallocation.


CXTPTaskPanelGroup::~CXTPTaskPanelGroup Destructor

CXTPTaskPanelGroup Destructors, CXTPTaskPanelGroup Class
CXTPTaskPanelGroup::~CXTPTaskPanelGroup Destructor

Destroys a CXTPTaskPanelGroup object, handles cleanup and deallocation.

virtual ~CXTPTaskPanelGroup();
Group

CXTPTaskPanelGroup Destructors


CXTPTaskPanelGroupItem Class

XTPTaskPanelGroupItem.h, Classes, Legend, Members, Topics, CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Constructors, CXTPTaskPanelGroupItem Destructors, CXTPTaskPanelGroupItem Constructors, CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Destructors, CXTPTaskPanelGroupItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem Class

CXTPTaskPanelGroupItem is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single item of the group.

Class Hierarchy

class CXTPTaskPanelGroupItem : public CXTPTaskPanelItem;
File

XTPTaskPanelGroupItem.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTaskPanelGroupItem Constructors
CXTPTaskPanelGroupItem Constructors | Description
CXTPTaskPanelGroupItem | Constructs a CXTPTaskPanelGroupItem object
CXTPTaskPanelGroupItem Data Members
CXTPTaskPanelGroupItem Data Members | Description
m_bAutoHeight | TRUE if item stretched inside its group.
m_bBold | TRUE to use bold font.
m_bmpPreview | Internally used.
m_bSelected | TRUE if the item is currently selected.
m_clrText | Text color
m_hWnd | Only used for items of type xtpTaskItemTypeControl, this is the control's child window
m_rcItem | Rectangle of the item.
m_rcMargins | Item's margins.
m_strDragText | Drag text of the item.
m_szItem | Size of item.
m_szPreview | Last preview bitmap size
CXTPTaskPanelGroupItem Destructors
CXTPTaskPanelGroupItem Destructors | Description
~CXTPTaskPanelGroupItem | Destroys a CXTPTaskPanelGroupItem object, handles cleanup and deallocation.
CXTPTaskPanelGroupItem Methods
CXTPTaskPanelGroupItem Methods | Description
DoPropExchange | Reads or writes this object from or to an archive.
GetBackColor | Call this member to retrieve the backcolor of this item.
GetDragText | Call this method to get text representing item dragged out of control.
GetHitTestRect | Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group item.
GetItemGroup | Retrieves the parent group of the item.
GetItemRect | Retrieves rectangle of the item.
GetMargins | Call this method to retrieve the margins of the item.
GetSize | Retrieves size of the item
GetTextColor | Call this member to get individual color for task panel item
IsAutoHeight | Determines if the item is stretched inside its group.
IsBold | Call this member to retrieve if the font is bold.
IsItemSelected | Call this member to determine if the item is currently selected. Note that multiple items can be selected at one time, but only one can have focus.
OnAnimate | This method is called when an animation step is executed.
OnDrawItem | This method is called to draw item in specified rectangle.
OnReposition | This method is called when item must be repositioned.
PrepareDrag | This member is called to cache a COleDataSource object that contains the group item being dragged.
SetBold | Call this method to set bold font for the item to be used.
SetControlHandle | This method attaches control handle to item.
SetDragText | Call this method to set text representing item dragged out of control.
SetItemRect | This method is called to set the bounding rectangle for the CXTPTaskPanelGroupItem.
SetItemSelected | Call this member to select this item. Multiple items can have focus if CXTPTaskPanel::m_bSelectItemOnFocus is FALSE.
SetSize | Call this method to set the size of the item.
SetTextColor | Call this member to set individual color for task panel item


CXTPTaskPanelGroupItem Data Members

CXTPTaskPanelGroupItem Class, Legend, Protected Data Members
CXTPTaskPanelGroupItem Data Members
Class

CXTPTaskPanelGroupItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAutoHeight | TRUE if item stretched inside its group.
m_bBold | TRUE to use bold font.
m_bmpPreview | Internally used.
m_bSelected | TRUE if the item is currently selected.
m_clrText | Text color
m_hWnd | Only used for items of type xtpTaskItemTypeControl, this is the control's child window
m_rcItem | Rectangle of the item.
m_rcMargins | Item's margins.
m_strDragText | Drag text of the item.
m_szItem | Size of item.
m_szPreview | Last preview bitmap size


CXTPTaskPanelGroupItem::m_bAutoHeight Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_bAutoHeight Data Member

TRUE if item stretched inside its group.

BOOL m_bAutoHeight;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_bBold Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_bBold Data Member

TRUE to use bold font.

BOOL m_bBold;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_bmpPreview Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_bmpPreview Data Member

Internally used.

CBitmap m_bmpPreview;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_bSelected Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_bSelected Data Member

TRUE if the item is currently selected.

BOOL m_bSelected;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_clrText Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_clrText Data Member

Text color

COLORREF m_clrText;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_hWnd Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_hWnd Data Member

Only used for items of type xtpTaskItemTypeControl, this is the control's child window

HWND m_hWnd;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_rcItem Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_rcItem Data Member

Rectangle of the item.

CRect m_rcItem;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_rcMargins Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_rcMargins Data Member

Item's margins.

CRect m_rcMargins;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_strDragText Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_strDragText Data Member

Drag text of the item.

CString m_strDragText;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_szItem Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_szItem Data Member

Size of item.

CSize m_szItem;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem::m_szPreview Data Member

CXTPTaskPanelGroupItem Data Members, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::m_szPreview Data Member

Last preview bitmap size

CSize m_szPreview;
Group

CXTPTaskPanelGroupItem Data Members


CXTPTaskPanelGroupItem Methods

CXTPTaskPanelGroupItem Class, Legend, Public Methods
CXTPTaskPanelGroupItem Methods
Class

CXTPTaskPanelGroupItem Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DoPropExchange | Reads or writes this object from or to an archive.
GetBackColor | Call this member to retrieve the backcolor of this item.
GetDragText | Call this method to get text representing item dragged out of control.
GetHitTestRect | Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group item.
GetItemGroup | Retrieves the parent group of the item.
GetItemRect | Retrieves rectangle of the item.
GetMargins | Call this method to retrieve the margins of the item.
GetSize | Retrieves size of the item
GetTextColor | Call this member to get individual color for task panel item
IsAutoHeight | Determines if the item is stretched inside its group.
IsBold | Call this member to retrieve if the font is bold.
IsItemSelected | Call this member to determine if the item is currently selected. Note that multiple items can be selected at one time, but only one can have focus.
OnAnimate | This method is called when an animation step is executed.
OnDrawItem | This method is called to draw item in specified rectangle.
OnReposition | This method is called when item must be repositioned.
PrepareDrag | This member is called to cache a COleDataSource object that contains the group item being dragged.
SetBold | Call this method to set bold font for the item to be used.
SetControlHandle | This method attaches control handle to item.
SetDragText | Call this method to set text representing item dragged out of control.
SetItemRect | This method is called to set the bounding rectangle for the CXTPTaskPanelGroupItem.
SetItemSelected | Call this member to select this item. Multiple items can have focus if CXTPTaskPanel::m_bSelectItemOnFocus is FALSE.
SetSize | Call this method to set the size of the item.
SetTextColor | Call this member to set individual color for task panel item


CXTPTaskPanelGroupItem::DoPropExchange Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::GetBackColor Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::GetBackColor Method

Call this member to retrieve the backcolor of this item.

COLORREF GetBackColor() const;
Returns

Backcolor of this item.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::GetDragText Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::GetDragText Method

Call this method to get text representing item dragged out of control.

virtual CString GetDragText() const;
Returns

Text will be dragged out.

Remarks

You can override it to create dynamic text.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::GetHitTestRect Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::GetHitTestRect Method

Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group item.

CRect GetHitTestRect() const;
Returns

The rectangle of the "tooltip zone" while the mouse is positioned over the group item.

Remarks

The "tooltip zone" is the area that a tooltip will be displayed while the mouse is positioned over the group item.

See Also

CXTPTaskPanelGroup::GetHitTestRect

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::GetItemGroup Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::GetItemGroup Method

Retrieves the parent group of the item.

CXTPTaskPanelGroup* GetItemGroup() const;
Returns

Parent group of the item.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::GetItemRect Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::GetItemRect Method

Retrieves rectangle of the item.

CRect GetItemRect() const;
Returns

Rectangle of the item.

Body Source
CRect CXTPTaskPanelGroupItem::GetItemRect() const {
    return m_rcItem;
}
Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::GetMargins Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::GetMargins Method

Call this method to retrieve the margins of the item.

CRect& GetMargins();
Returns

The margins of the item.

Body Source
CRect& CXTPTaskPanelGroupItem::GetMargins() {
    return m_rcMargins;
}
Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::GetSize Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::GetSize Method

Retrieves size of the item

CSize GetSize() const;
Returns

Size of the item.

See Also

SetSize

Body Source
CSize CXTPTaskPanelGroupItem::GetSize() const {
    return m_szItem;
}
Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::GetTextColor Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::GetTextColor Method

Call this member to get individual color for task panel item

COLORREF GetTextColor() const;
Body Source
COLORREF CXTPTaskPanelGroupItem::GetTextColor() const {
    return m_clrText;
}
Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::IsAutoHeight Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::IsAutoHeight Method

Determines if the item is stretched inside its group.

BOOL IsAutoHeight() const;
Returns

TRUE if item fill whole group height; FALSE if it has defined height.

Body Source
BOOL CXTPTaskPanelGroupItem::IsAutoHeight() const {
    return m_bAutoHeight;
}
Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::IsBold Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::IsBold Method

Call this member to retrieve if the font is bold.

BOOL IsBold() const;
Returns

TRUE is the font is bold, FALSE otherwise.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::IsItemSelected Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::IsItemSelected Method

Call this member to determine if the item is currently selected. Note that multiple items can be selected at one time, but only one can have focus.

BOOL IsItemSelected() const;
Returns

TRUE if the item is currently selected.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::OnAnimate Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::OnAnimate Method

This method is called when an animation step is executed.

void OnAnimate(
    int nStep
);
Parameters

nStep
Step of animation.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::OnDrawItem Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::OnDrawItem Method

This method is called to draw item in specified rectangle.

virtual void OnDrawItem(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
rc
Rectangle of item to draw.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::OnReposition Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::OnReposition Method

This method is called when item must be repositioned.

virtual CRect OnReposition(
    CRect rc
);
Parameters

rc
New rectangle of the item.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::PrepareDrag Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::PrepareDrag Method

This member is called to cache a COleDataSource object that contains the group item being dragged.

BOOL PrepareDrag(
    COleDataSource& srcItem,
    BOOL bCacheTextData = TRUE
);
Parameters

srcItem
COleDataSource object to cache.
bCacheTextData
TRUE to cache text presentation of object.

Returns

TRUE if successful, FALSE if CacheGlobalData returns NULL.

Remarks

This places the item being dragged onto the clipboard.

See Also

CreateFromOleData, CacheGlobalData, CopyToClipboard, PasteFromClipboard, PrepareDrag

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::SetBold Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::SetBold Method

Call this method to set bold font for the item to be used.

void SetBold(
    BOOL bBold = TRUE
);
Parameters

bBold
TRUE to use bold font.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::SetControlHandle Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::SetControlHandle Method

This method attaches control handle to item.

void SetControlHandle(
    HWND hWnd
);
Parameters

hWnd
Window handle to attach.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::SetDragText Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::SetDragText Method

Call this method to set text representing item dragged out of control.

void SetDragText(
    LPCTSTR lpszDragText
);
Parameters

lpszDragText
Dragged text of the item.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::SetItemRect Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::SetItemRect Method

This method is called to set the bounding rectangle for the CXTPTaskPanelGroupItem.

void SetItemRect(
    LPCRECT lpRect
);
Parameters

lpRect
Rectangle of the item.

Body Source
void CXTPTaskPanelGroupItem::SetItemRect(LPCRECT lpRect) {
    ::CopyRect(&m_rcItem, lpRect);
}
Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::SetItemSelected Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class
CXTPTaskPanelGroupItem::SetItemSelected Method

Call this member to select this item. Multiple items can have focus if CXTPTaskPanel::m_bSelectItemOnFocus is FALSE.

void SetItemSelected(
    BOOL bSelected
);
Parameters

bSelected
TRUE if the item will be selected, FALSE to no longer select the item.

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::SetSize Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::SetSize Method

Call this method to set the size of the item.

void SetSize(
    CSize szItem,
    BOOL bAutoHeight = FALSE
);
Parameters

szItem
Item size.
bAutoHeight
TRUE to stretch control in group.

See Also

GetSize

Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem::SetTextColor Method

CXTPTaskPanelGroupItem Methods, CXTPTaskPanelGroupItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::SetTextColor Method

Call this member to set individual color for task panel item

void SetTextColor(
    COLORREF clrText
);
Parameters

clrText
New text color to set

Body Source
void CXTPTaskPanelGroupItem::SetTextColor(COLORREF clr) {
    m_clrText = clr;
    RedrawPanel();
}
Group

CXTPTaskPanelGroupItem Methods


CXTPTaskPanelGroupItem Constructors

CXTPTaskPanelGroupItem Class, Legend, Public Methods
CXTPTaskPanelGroupItem Constructors
Class

CXTPTaskPanelGroupItem Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelGroupItem | Constructs a CXTPTaskPanelGroupItem object


CXTPTaskPanelGroupItem::CXTPTaskPanelGroupItem Constructor

CXTPTaskPanelGroupItem Constructors, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::CXTPTaskPanelGroupItem Constructor

Constructs a CXTPTaskPanelGroupItem object

CXTPTaskPanelGroupItem();
Group

CXTPTaskPanelGroupItem Constructors


CXTPTaskPanelGroupItem Destructors

CXTPTaskPanelGroupItem Class, Legend, Public Methods
CXTPTaskPanelGroupItem Destructors
Class

CXTPTaskPanelGroupItem Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTaskPanelGroupItem | Destroys a CXTPTaskPanelGroupItem object, handles cleanup and deallocation.


CXTPTaskPanelGroupItem::~CXTPTaskPanelGroupItem Destructor

CXTPTaskPanelGroupItem Destructors, CXTPTaskPanelGroupItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItem::~CXTPTaskPanelGroupItem Destructor

Destroys a CXTPTaskPanelGroupItem object, handles cleanup and deallocation.

virtual ~CXTPTaskPanelGroupItem();
Group

CXTPTaskPanelGroupItem Destructors


CXTPTaskPanelGroupItems Class

XTPTaskPanelItems.h, Classes, Legend, Members, Topics, CXTPTaskPanelGroupItems Methods, CXTPTaskPanelGroupItems Constructors, CXTPTaskPanelGroupItems Constructors, CXTPTaskPanelGroupItems Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItems Class

CXTPTaskPanelGroupItems is a CXTPTaskPanelItems derived class. It is used as collection of items in the group.

Class Hierarchy

class CXTPTaskPanelGroupItems : public CXTPTaskPanelItems;
File

XTPTaskPanelItems.h

Group

Classes

Legend
Method
virtual
CXTPTaskPanelGroupItems Constructors
CXTPTaskPanelGroupItems Constructors | Description
CXTPTaskPanelGroupItems | Constructs CXTPTaskPanelGroupItems object
CXTPTaskPanelGroupItems Methods
CXTPTaskPanelGroupItems Methods | Description
GetDefaultItemClass | Retrieves default runtime class of items in collection.


CXTPTaskPanelGroupItems Methods

CXTPTaskPanelGroupItems Class, Legend, Public Methods
CXTPTaskPanelGroupItems Methods
Class

CXTPTaskPanelGroupItems Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetDefaultItemClass | Retrieves default runtime class of items in collection.


CXTPTaskPanelGroupItems::GetDefaultItemClass Method

CXTPTaskPanelGroupItems Methods, CXTPTaskPanelGroupItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItems::GetDefaultItemClass Method

Retrieves default runtime class of items in collection.

virtual CRuntimeClass* GetDefaultItemClass() const;
Group

CXTPTaskPanelGroupItems Methods


CXTPTaskPanelGroupItems Constructors

CXTPTaskPanelGroupItems Class, Legend, Public Methods
CXTPTaskPanelGroupItems Constructors
Class

CXTPTaskPanelGroupItems Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelGroupItems | Constructs CXTPTaskPanelGroupItems object


CXTPTaskPanelGroupItems::CXTPTaskPanelGroupItems Constructor

CXTPTaskPanelGroupItems Constructors, CXTPTaskPanelGroupItems Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroupItems::CXTPTaskPanelGroupItems Constructor

Constructs CXTPTaskPanelGroupItems object

CXTPTaskPanelGroupItems(
    CXTPTaskPanel* pPanel
);
Parameters

pPanel
Points to a CXTPTaskPanel object

Group

CXTPTaskPanelGroupItems Constructors


CXTPTaskPanelGroups Class

XTPTaskPanelItems.h, Classes, Legend, Members, Topics, CXTPTaskPanelGroups Methods, CXTPTaskPanelGroups Constructors, CXTPTaskPanelGroups Constructors, CXTPTaskPanelGroups Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelGroups Class

CXTPTaskPanelGroups is a CXTPTaskPanelItems derived class. It is used as a collection of groups in the control.

Class Hierarchy

class CXTPTaskPanelGroups : public CXTPTaskPanelItems;
File

XTPTaskPanelItems.h

Group

Classes

Legend
Method
virtual
CXTPTaskPanelGroups Constructors
CXTPTaskPanelGroups Constructors | Description
CXTPTaskPanelGroups | Constructs a CXTPTaskPanelGroups object
CXTPTaskPanelGroups Methods
CXTPTaskPanelGroups Methods | Description
GetDefaultItemClass | Retrieves default runtime class of items in collection.


CXTPTaskPanelGroups Methods

CXTPTaskPanelGroups Class, Legend, Public Methods
CXTPTaskPanelGroups Methods
Class

CXTPTaskPanelGroups Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
GetDefaultItemClass | Retrieves default runtime class of items in collection.


CXTPTaskPanelGroups::GetDefaultItemClass Method

CXTPTaskPanelGroups Methods, CXTPTaskPanelGroups Class
CXTPTaskPanelGroups::GetDefaultItemClass Method

Retrieves default runtime class of items in collection.

virtual CRuntimeClass* GetDefaultItemClass() const;
Group

CXTPTaskPanelGroups Methods


CXTPTaskPanelGroups Constructors

CXTPTaskPanelGroups Class, Legend, Public Methods
CXTPTaskPanelGroups Constructors
Class

CXTPTaskPanelGroups Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelGroups | Constructs a CXTPTaskPanelGroups object


CXTPTaskPanelGroups::CXTPTaskPanelGroups Constructor

CXTPTaskPanelGroups Constructors, CXTPTaskPanelGroups Class
CXTPTaskPanelGroups::CXTPTaskPanelGroups Constructor

Constructs a CXTPTaskPanelGroups object

CXTPTaskPanelGroups(
    CXTPTaskPanel* pPanel
);
Parameters

pPanel
Points to a CXTPTaskPanel object

Group

CXTPTaskPanelGroups Constructors


CXTPTaskPanelItem Class

XTPTaskPanelItem.h, Classes, Legend, Members, Topics, CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Methods, CXTPTaskPanelItem Constructors, CXTPTaskPanelItem Destructors, CXTPTaskPanelItem Constructors, CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Destructors, CXTPTaskPanelItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem Class

CXTPTaskPanelItem is a CCmdTarget derived class. It is used in TaskPanel control as parent for CXTPTaskPanelGroupItem and CXTPTaskPanelGroup classes.

Class Hierarchy

class CXTPTaskPanelItem;
File

XTPTaskPanelItem.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTaskPanelItem Constructors
CXTPTaskPanelItem Constructors | Description
CXTPTaskPanelItem | Constructs a CXTPTaskPanelItem object
CXTPTaskPanelItem Data Members
CXTPTaskPanelItem Data Members | Description
m_bAllowDrop | TRUE if item can be dragged.
m_bEnabled | TRUE if item is enabled.
m_bVisible | TRUE if item is visible
m_dwData | The 32-bit value associated with the item
m_nAllowDrag | TRUE if item can be dropped.
m_nIconIndex | Icon index.
m_nID | Identifier.
m_nTextFormat | Format of caption text of item.
m_pItems | Collection of child items.
m_pPanel | Parent TaskPanel class
m_rcIconPadding | Paddingspacing placed around the item icon.
m_rcText | Size and location of caption text of item.
m_strCaption | Caption of the item.
m_strTooltip | Tooltip of the item.
m_typeItem | Type of the item.
CXTPTaskPanelItem Destructors
CXTPTaskPanelItem Destructors | Description
~CXTPTaskPanelItem | Destroys a CXTPTaskPanelItem object, handles cleanup and deallocation.
CXTPTaskPanelItem Methods
CXTPTaskPanelItem Methods | Description
AllowDrag | Call this member to enabledisable dragging of this item.
AllowDrop | Call this member to enabledisable dropping of this item.
CacheGlobalData | This member is called to store information about the class and group item currently being dragged to HGLOBAL.
CopyToClipboard | Call this member to copy this item to the clipboard.
CreateFromOleData | This member restores a COleDataSource object.
CreateFromOleFile | This member restores a COleDataSource object.
DoPropExchange | Reads or writes this object from or to an archive.
EnsureVisible | Call this member to make sure that the item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.
GetCaption | Call this member to retrieve the item's caption
GetEnabled | Retrieves the state of the item.
GetHitTestRect | Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group item.
GetIconIndex | Retrieves icon index.
GetIconPadding | Call this method to retrieve the padding around images of the item.
GetID | Call this method to get the identifier of the item.
GetImage | Call this method to retrieve the image of the item.
GetIndex | Call this member to retrieve the index of this item within the array of items.
GetInvalidateRect | Call this member to retrieve the rectangle of the "drawing zone"
GetItemData | This method retrieves the application-supplied 32-bit value associated with the item
GetItemFont | Call this member to retrieve the font used to display text for this item.
GetItemGroup | Call this member to get a pointer to the group that this item belong to.
GetPaintManager | Retrieves the paint manager
GetParentItems | Call this member to get a pointer to the array of items that this item belongs to. This allows you to access sibling groups andor items and determine the total number of siblings.
GetTaskPanel | Call this method to get parent TaskPanel control item belongs to
GetTextRect | This member is called to retrieve the size and location of the caption text for the item.
GetTooltip | Call this member to retrieve the item's tooltip
GetType | Retrieves the type of the item.
IsAcceptFocus | Call this method to determine if item can be focused.
IsAllowDrag | Call this member to determine if this item can be dragged.
IsAllowDrop | Call this member to determine if this item can be dropped.
IsGroup | Call this member to determine if this item is of type xtpTaskItemTypeGroup.
IsItemDragging | Call this member to determine if this item is currently dragging.
IsItemDragOver | Call this member to determine if another item is currently being dragged over this item.
IsItemFocused | Determines if item is focused.
IsItemHot | Determines if item is hot.
IsItemPressed | Determines if item is pressed.
IsVisible | Retrieves the visible state of the item.
OnRemoved | This method is called when item was removed from parent items collection
PasteFromClipboard | Call this member to cat a pointer to the last item placed in the clipboard.
RedrawPanel | Call this method to redraw the parent TaskPanel control.
Remove | Call this member to remove this item.
RepositionPanel | Call this method to reposition the groups in the task panel.
SetCaption | Call this method to set the caption of the item.
SetEnabled | Call this method to enable/disable the item.
SetIconIndex | Call this method to set icon associated with item.
SetID | Call this method to set the identifier of the item.
SetItemData | This method sets the 32-bit value associated with the item.
SetItemFont | Call this member to set the font used to display task panel item text. Can use custom font or the standard item font.
SetTextRect | This member is called to save the location of the text caption within the item.
SetTooltip | Associates ToolTip text with the item.
SetType | Call this method to set the type of the item.
SetVisible | Call this method to show/hide the item.


CXTPTaskPanelItem Data Members

CXTPTaskPanelItem Class, Legend, Protected Data Members
CXTPTaskPanelItem Data Members
Class

CXTPTaskPanelItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAllowDrop | TRUE if item can be dragged.
m_bEnabled | TRUE if item is enabled.
m_bVisible | TRUE if item is visible
m_dwData | The 32-bit value associated with the item
m_nAllowDrag | TRUE if item can be dropped.
m_nIconIndex | Icon index.
m_nID | Identifier.
m_nTextFormat | Format of caption text of item.
m_pItems | Collection of child items.
m_pPanel | Parent TaskPanel class
m_rcIconPadding | Paddingspacing placed around the item icon.
m_rcText | Size and location of caption text of item.
m_strCaption | Caption of the item.
m_strTooltip | Tooltip of the item.
m_typeItem | Type of the item.


CXTPTaskPanelItem::m_bAllowDrop Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_bAllowDrop Data Member

TRUE if item can be dragged.

BOOL m_bAllowDrop;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_bEnabled Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_bEnabled Data Member

TRUE if item is enabled.

BOOL m_bEnabled;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_bVisible Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_bVisible Data Member

TRUE if item is visible

BOOL m_bVisible;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_dwData Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_dwData Data Member

The 32-bit value associated with the item

DWORD_PTR m_dwData;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_nAllowDrag Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_nAllowDrag Data Member

TRUE if item can be dropped.

long m_nAllowDrag;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_nIconIndex Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_nIconIndex Data Member

Icon index.

int m_nIconIndex;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_nID Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_nID Data Member

Identifier.

UINT m_nID;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_nTextFormat Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_nTextFormat Data Member

Format of caption text of item.

UINT m_nTextFormat;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_pItems Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_pItems Data Member

Collection of child items.

CXTPTaskPanelItems* m_pItems;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_pPanel Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_pPanel Data Member

Parent TaskPanel class

CXTPTaskPanel* m_pPanel;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_rcIconPadding Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_rcIconPadding Data Member

Paddingspacing placed around the item icon.

CRect m_rcIconPadding;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_rcText Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_rcText Data Member

Size and location of caption text of item.

CRect m_rcText;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_strCaption Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_strCaption Data Member

Caption of the item.

CString m_strCaption;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_strTooltip Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_strTooltip Data Member

Tooltip of the item.

CString m_strTooltip;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem::m_typeItem Data Member

CXTPTaskPanelItem Data Members, CXTPTaskPanelItem Class
CXTPTaskPanelItem::m_typeItem Data Member

Type of the item.

XTPTaskPanelItemType m_typeItem;
Group

CXTPTaskPanelItem Data Members


CXTPTaskPanelItem Methods

CXTPTaskPanelItem Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem Methods
Class

CXTPTaskPanelItem Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnRemoved | This method is called when item was removed from parent items collection
Public Methods
Public Methods
Public Method | Description
AllowDrag | Call this member to enabledisable dragging of this item.
AllowDrop | Call this member to enabledisable dropping of this item.
CacheGlobalData | This member is called to store information about the class and group item currently being dragged to HGLOBAL.
CopyToClipboard | Call this member to copy this item to the clipboard.
CreateFromOleData | This member restores a COleDataSource object.
CreateFromOleFile | This member restores a COleDataSource object.
DoPropExchange | Reads or writes this object from or to an archive.
EnsureVisible | Call this member to make sure that the item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.
GetCaption | Call this member to retrieve the item's caption
GetEnabled | Retrieves the state of the item.
GetHitTestRect | Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group item.
GetIconIndex | Retrieves icon index.
GetIconPadding | Call this method to retrieve the padding around images of the item.
GetID | Call this method to get the identifier of the item.
GetImage | Call this method to retrieve the image of the item.
GetIndex | Call this member to retrieve the index of this item within the array of items.
GetInvalidateRect | Call this member to retrieve the rectangle of the "drawing zone"
GetItemData | This method retrieves the application-supplied 32-bit value associated with the item
GetItemFont | Call this member to retrieve the font used to display text for this item.
GetItemGroup | Call this member to get a pointer to the group that this item belong to.
GetPaintManager | Retrieves the paint manager
GetParentItems | Call this member to get a pointer to the array of items that this item belongs to. This allows you to access sibling groups andor items and determine the total number of siblings.
GetTaskPanel | Call this method to get parent TaskPanel control item belongs to
GetTextRect | This member is called to retrieve the size and location of the caption text for the item.
GetTooltip | Call this member to retrieve the item's tooltip
GetType | Retrieves the type of the item.
IsAcceptFocus | Call this method to determine if item can be focused.
IsAllowDrag | Call this member to determine if this item can be dragged.
IsAllowDrop | Call this member to determine if this item can be dropped.
IsGroup | Call this member to determine if this item is of type xtpTaskItemTypeGroup.
IsItemDragging | Call this member to determine if this item is currently dragging.
IsItemDragOver | Call this member to determine if another item is currently being dragged over this item.
IsItemFocused | Determines if item is focused.
IsItemHot | Determines if item is hot.
IsItemPressed | Determines if item is pressed.
IsVisible | Retrieves the visible state of the item.
PasteFromClipboard | Call this member to cat a pointer to the last item placed in the clipboard.
RedrawPanel | Call this method to redraw the parent TaskPanel control.
Remove | Call this member to remove this item.
RepositionPanel | Call this method to reposition the groups in the task panel.
SetCaption | Call this method to set the caption of the item.
SetEnabled | Call this method to enable/disable the item.
SetIconIndex | Call this method to set icon associated with item.
SetID | Call this method to set the identifier of the item.
SetItemData | This method sets the 32-bit value associated with the item.
SetItemFont | Call this member to set the font used to display task panel item text. Can use custom font or the standard item font.
SetTextRect | This member is called to save the location of the text caption within the item.
SetTooltip | Associates ToolTip text with the item.
SetType | Call this method to set the type of the item.
SetVisible | Call this method to show/hide the item.


CXTPTaskPanelItem::AllowDrag Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::AllowDrag Method

Call this member to enabledisable dragging of this item.

void AllowDrag(
    long nAllowDrag = xtpTaskItemAllowDragDefault
);
Parameters

nAllowDrag
Drag options

Remarks

dragOptions parameter can be one or more of the following values:

  • xtpTaskItemAllowDragCopyWithinGroup To allow copy within group only
  • xtpTaskItemAllowDragCopyWithinControl To allow copy within task panel only
  • xtpTaskItemAllowDragCopyOutsideControl To allow copy outside task panel only
  • xtpTaskItemAllowDragCopy To allow copy operation
  • xtpTaskItemAllowDragMoveWithinGroup To allow move within group only
  • xtpTaskItemAllowDragMoveWithinControl To allow move within task panel only
  • xtpTaskItemAllowDragMoveOutsideControl To allow move outside task panel only
  • xtpTaskItemAllowDragMove // To allow move operation
  • xtpTaskItemAllowDragAll To allow all drag operations
See Also

IsAllowDrag, XTPTaskPanelItemAllowDrag

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::AllowDrop Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::AllowDrop Method

Call this member to enabledisable dropping of this item.

void AllowDrop(
    BOOL bAllowDrop
);
Parameters

bAllowDrop
TRUE to allow this item to be dropped. FALSE to disabled dropping of this item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::CacheGlobalData Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::CacheGlobalData Method

This member is called to store information about the class and group item currently being dragged to HGLOBAL.

HGLOBAL CacheGlobalData();
Returns

HGLOBAL object containing information about item being dragged, NULL if an OLE or Archive exception is thrown while caching the data.

See Also

PrepareDrag, CreateFromOleData, CopyToClipboard, PasteFromClipboard

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::CopyToClipboard Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::CopyToClipboard Method

Call this member to copy this item to the clipboard.

void CopyToClipboard();
See Also

PasteFromClipboard, CreateFromOleData, CacheGlobalData, PasteFromClipboard, PrepareDrag

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::CreateFromOleData Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::CreateFromOleData Method

This member restores a COleDataSource object.

static CXTPTaskPanelItem* CreateFromOleData(
    COleDataObject* pDataObject
);
Parameters

pDataObject
COleDataSource object to restore.

Returns

Item that was stored in the COleDataSource object.

Remarks

This will restore the item that was cached using the PrepareDrag method.

See Also

PrepareDrag, CacheGlobalData, CopyToClipboard, PasteFromClipboard

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::CreateFromOleFile Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::CreateFromOleFile Method

This member restores a COleDataSource object.

static CXTPTaskPanelItem* CreateFromOleFile(
    CFile* pDataObject
);
Parameters

pDataObject
CFile with COleDataSource object to restore.

Returns

Item that was stored in the COleDataSource object.

Remarks

This will restore the item that was cached using the PrepareDrag method.

See Also

PrepareDrag, CacheGlobalData, CopyToClipboard, PasteFromClipboard

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::DoPropExchange Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::DoPropExchange Method

Reads or writes this object from or to an archive.

virtual void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::EnsureVisible Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::EnsureVisible Method

Call this member to make sure that the item is visible in the task panel. This will scroll the task panel and group that the item is in until the item is visible.

void EnsureVisible();
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetCaption Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem::GetCaption Method

Call this member to retrieve the item's caption

CString GetCaption() const;
Returns

A CString object containing caption of the item.

Body Source
CString CXTPTaskPanelItem::GetCaption() const {
    return m_strCaption;
}
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetEnabled Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetEnabled Method

Retrieves the state of the item.

BOOL GetEnabled() const;
Returns

TRUE if item is enabled; otherwise FALSE.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetHitTestRect Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::GetHitTestRect Method

Call this member to retrieve the rectangle of the "tooltip zone" while the mouse is positioned over the group item.

virtual CRect GetHitTestRect() const;
Returns

0 in base class implementation, returns the rectangle of the "tooltip zone" while the mouse is positioned over the group item in CXTPTaskPanelGroupItem implementation.

Remarks

The "tooltip zone" is the area that a tooltip will be displayed while the mouse is positioned over the group item.

The member is overridden in CXTPTaskPanelGroupItem.

See Also

CXTPTaskPanelGroupItem::GetHitTestRect

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetIconIndex Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetIconIndex Method

Retrieves icon index.

int GetIconIndex() const;
Returns

Icon index of item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetIconPadding Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem::GetIconPadding Method

Call this method to retrieve the padding around images of the item.

CRect& GetIconPadding();
Returns

The padding around images of the item.

Body Source
CRect& CXTPTaskPanelItem::GetIconPadding() {
    return m_rcIconPadding;
}
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetID Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetID Method

Call this method to get the identifier of the item.

UINT GetID() const;
Returns

Identifier of the item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetImage Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetImage Method

Call this method to retrieve the image of the item.

CXTPImageManagerIcon* GetImage(
    int nWidth
) const;
Parameters

nWidth
Width of the icon to be retrieved. (CXTPImageManagerIcon can have multiple image sizes for the same item.). If a 16x16 icon is to be retrieved, then pass in 16 for the width.

Returns

A pointer the CXTPImageManagerIcon image for this item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetIndex Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetIndex Method

Call this member to retrieve the index of this item within the array of items.

int GetIndex() const;
Returns

Index of item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetInvalidateRect Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::GetInvalidateRect Method

Call this member to retrieve the rectangle of the "drawing zone"

virtual CRect GetInvalidateRect() const;
See Also

CXTPTaskPanelGroupItem::GetHitTestRect

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetItemData Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem::GetItemData Method

This method retrieves the application-supplied 32-bit value associated with the item

DWORD_PTR GetItemData() const;
Returns

The 32-bit value associated with the item

Body Source
DWORD_PTR CXTPTaskPanelItem::GetItemData() const {
    return m_dwData;
}
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetItemFont Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetItemFont Method

Call this member to retrieve the font used to display text for this item.

CFont* GetItemFont() const;
Returns

The font used to display text for this item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetItemGroup Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetItemGroup Method

Call this member to get a pointer to the group that this item belong to.

virtual CXTPTaskPanelGroup* GetItemGroup() const;
Returns

Group that this item belongs to.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetPaintManager Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetPaintManager Method

Retrieves the paint manager

CXTPTaskPanelPaintManager* GetPaintManager() const;
Returns

A pointer to a CXTPTaskPanelPaintManager object

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetParentItems Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem::GetParentItems Method

Call this member to get a pointer to the array of items that this item belongs to. This allows you to access sibling groups andor items and determine the total number of siblings.

CXTPTaskPanelItems* GetParentItems() const;
Returns

Pointer to array collection holding sibling items of this item.

Body Source
CXTPTaskPanelItems* CXTPTaskPanelItem::GetParentItems() const {
    return m_pItems;
}
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetTaskPanel Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem::GetTaskPanel Method

Call this method to get parent TaskPanel control item belongs to

CXTPTaskPanel* GetTaskPanel() const;
Returns

Parent TaskPanel control.

Body Source
CXTPTaskPanel* CXTPTaskPanelItem::GetTaskPanel() const {
    ASSERT(m_pPanel != NULL);
    return m_pPanel;
}
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetTextRect Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetTextRect Method

This member is called to retrieve the size and location of the caption text for the item.

CRect GetTextRect(
    UINT* pFormat = 0
) const;
Parameters

pFormat
Format of text. (DT_LEFT, DT_CENTER, DT_RIGHT, DT_VCENTER)

Returns

The size and location of the caption text within the item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetTooltip Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem::GetTooltip Method

Call this member to retrieve the item's tooltip

CString GetTooltip() const;
Returns

The ToolTip text for the item.

Body Source
CString CXTPTaskPanelItem::GetTooltip() const {
    return m_strTooltip;
}
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::GetType Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::GetType Method

Retrieves the type of the item.

XTPTaskPanelItemType GetType() const;
Returns

Type of the item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsAcceptFocus Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::IsAcceptFocus Method

Call this method to determine if item can be focused.

virtual BOOL IsAcceptFocus() const;
Returns

TRUE if item can be focused; otherwise FALSE.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsAllowDrag Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::IsAllowDrag Method

Call this member to determine if this item can be dragged.

long IsAllowDrag() const;
Returns

TRUE if this item can be dragged, FALSE if it can't be dragged.

See Also

AllowDrag, XTPTaskPanelItemAllowDrag

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsAllowDrop Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::IsAllowDrop Method

Call this member to determine if this item can be dropped.

BOOL IsAllowDrop() const;
Returns

TRUE if this item can be dropped, FALSE if it can't be dropped.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsGroup Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::IsGroup Method

Call this member to determine if this item is of type xtpTaskItemTypeGroup.

BOOL IsGroup() const;
Returns

TRUE if the item is of type xtpTaskItemTypeGroup, FALSE otherwise.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsItemDragging Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::IsItemDragging Method

Call this member to determine if this item is currently dragging.

BOOL IsItemDragging() const;
Returns

TRUE if this item is currently dragging. FALSE if the item is not dragging.

See Also

IsItemDragOver

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsItemDragOver Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::IsItemDragOver Method

Call this member to determine if another item is currently being dragged over this item.

BOOL IsItemDragOver() const;
Returns

TRUE if another item is being dragged over this item, FALSE otherwise.

See Also

IsItemDragging

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsItemFocused Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::IsItemFocused Method

Determines if item is focused.

BOOL IsItemFocused() const;
Returns

TRUE if item is focused; otherwise FALSE.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsItemHot Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::IsItemHot Method

Determines if item is hot.

BOOL IsItemHot() const;
Returns

TRUE if item is hot; otherwise FALSE.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsItemPressed Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::IsItemPressed Method

Determines if item is pressed.

BOOL IsItemPressed() const;
Returns

TRUE if item is pressed; otherwise FALSE.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::IsVisible Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::IsVisible Method

Retrieves the visible state of the item.

BOOL IsVisible() const;
Returns

TRUE if item is visible; otherwise FALSE.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::OnRemoved Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem::OnRemoved Method

This method is called when item was removed from parent items collection

virtual void OnRemoved();
Body Source
void CXTPTaskPanelItem::OnRemoved() {

}
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::PasteFromClipboard Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::PasteFromClipboard Method

Call this member to cat a pointer to the last item placed in the clipboard.

static CXTPTaskPanelItem* PasteFromClipboard();
Returns

Pointer to last item placed in the clipboard.

See Also

CopyToClipboard, CreateFromOleData, CacheGlobalData, CopyToClipboard, PrepareDrag

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::RedrawPanel Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::RedrawPanel Method

Call this method to redraw the parent TaskPanel control.

void RedrawPanel(
    BOOL bAnimate = FALSE
) const;
Parameters

bAnimate
TRUE to animate changes

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::Remove Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::Remove Method

Call this member to remove this item.

void Remove();
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::RepositionPanel Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::RepositionPanel Method

Call this method to reposition the groups in the task panel.

void RepositionPanel() const;
Parameters

bRecalcOnly
TRUE to recalculate only without positioning.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetCaption Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::SetCaption Method

Call this method to set the caption of the item.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
The new caption of the item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetEnabled Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::SetEnabled Method

Call this method to enable/disable the item.

void SetEnabled(
    BOOL bEnabled
);
Parameters

bEnabled
TRUE to enable item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetIconIndex Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::SetIconIndex Method

Call this method to set icon associated with item.

void SetIconIndex(
    int nIndex
);
Parameters

nIndex
Index of the icon in the image list of parent TaskPanel control.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetID Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::SetID Method

Call this method to set the identifier of the item.

void SetID(
    UINT nID
);
Parameters

nID
The new identifier of the item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetItemData Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItem::SetItemData Method

This method sets the 32-bit value associated with the item.

void SetItemData(
    DWORD_PTR dwData
);
Parameters

dwData
Contains the new value to associate with the item.

Body Source
void CXTPTaskPanelItem::SetItemData(DWORD_PTR dwData) {
    m_dwData = dwData;
}
Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetItemFont Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::SetItemFont Method

Call this member to set the font used to display task panel item text. Can use custom font or the standard item font.

void SetItemFont(
    LOGFONT* pLogFont
);
Parameters

pLogFont
Font used to display task panel item text.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetTextRect Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class, See Also
CXTPTaskPanelItem::SetTextRect Method

This member is called to save the location of the text caption within the item.

void SetTextRect(
    CDC* pDC,
    CRect rc,
    UINT nFormat
);
Parameters

pDC
Pointer to a valid device context.
rc
CRect object specifying size of area.
nFormat
Format of caption text. (DT_LEFT, DT_CENTER, DT_RIGHT, DT_VCENTER)

Remarks

CXTPTaskPanelPaintManager::DrawItemCaption calls this to save the bounding rectangle of the text within the item.

See Also

CXTPTaskPanelPaintManager::DrawItemCaption

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetTooltip Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::SetTooltip Method

Associates ToolTip text with the item.

void SetTooltip(
    LPCTSTR lpszTooltip
);
Parameters

lpszTooltip
The ToolTip text to display when the mouse cursor is over the item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetType Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::SetType Method

Call this method to set the type of the item.

void SetType(
    XTPTaskPanelItemType typeItem
);
Parameters

typeItem
Type of the item

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem::SetVisible Method

CXTPTaskPanelItem Methods, CXTPTaskPanelItem Class
CXTPTaskPanelItem::SetVisible Method

Call this method to show/hide the item.

void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show item.

Group

CXTPTaskPanelItem Methods


CXTPTaskPanelItem Constructors

CXTPTaskPanelItem Class, Legend, Protected Methods
CXTPTaskPanelItem Constructors
Class

CXTPTaskPanelItem Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPTaskPanelItem | Constructs a CXTPTaskPanelItem object


CXTPTaskPanelItem::CXTPTaskPanelItem Constructor

CXTPTaskPanelItem Constructors, CXTPTaskPanelItem Class
CXTPTaskPanelItem::CXTPTaskPanelItem Constructor

Constructs a CXTPTaskPanelItem object

CXTPTaskPanelItem();
Group

CXTPTaskPanelItem Constructors


CXTPTaskPanelItem Destructors

CXTPTaskPanelItem Class, Legend, Protected Methods
CXTPTaskPanelItem Destructors
Class

CXTPTaskPanelItem Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPTaskPanelItem | Destroys a CXTPTaskPanelItem object, handles cleanup and deallocation.


CXTPTaskPanelItem::~CXTPTaskPanelItem Destructor

CXTPTaskPanelItem Destructors, CXTPTaskPanelItem Class
CXTPTaskPanelItem::~CXTPTaskPanelItem Destructor

Destroys a CXTPTaskPanelItem object, handles cleanup and deallocation.

virtual ~CXTPTaskPanelItem();
Group

CXTPTaskPanelItem Destructors


CXTPTaskPanelItems Class

XTPTaskPanelItems.h, Classes, Legend, Members, Topics, CXTPTaskPanelItems Data Members, CXTPTaskPanelItems Methods, CXTPTaskPanelItems Constructors, CXTPTaskPanelItems Destructors, CXTPTaskPanelItems Constructors, CXTPTaskPanelItems Data Members, CXTPTaskPanelItems Destructors, CXTPTaskPanelItems Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItems Class

CXTPTaskPanelItems is a CCmdTarget derived class. It is used as collection of CXTPTaskPanelItem classes.

Class Hierarchy

class CXTPTaskPanelItems;
File

XTPTaskPanelItems.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTaskPanelItems Constructors
CXTPTaskPanelItems Constructors | Description
CXTPTaskPanelItems | Constructs a CXTPTaskPanelItems object.
CXTPTaskPanelItems Data Members
CXTPTaskPanelItems Data Members | Description
m_arrItems | Array of items.
m_pOwner | Owner of items.
m_pPanel | Parent TaskPanel control.
CXTPTaskPanelItems Destructors
CXTPTaskPanelItems Destructors | Description
~CXTPTaskPanelItems | Destroys a CXTPTaskPanelItems object, handles cleanup and deallocation.
CXTPTaskPanelItems Methods
CXTPTaskPanelItems Methods | Description
Add | Call this member to add a new item to the collection.
Clear | Call this method to remove all items in the collection.
DoPropExchange | Reads or writes this object from or to an archive.
Find | Call this member function to find an item by its ID
GetAt | Call this member to return the item at the specified index
GetCount | Call this member to get count of items
GetDefaultItemClass | Retrieves default runtime class of items in collection.
GetFirstVisibleItem | Retrieves first visible item.
GetIndex | Call this member to get index of item in the collection of items.
GetLastVisibleItem | Retrieves last visible item.
GetNextVisibleIndex | This method finds next visible item index in specified direction.
GetOwner | Call this member function to get a pointer to the owner
InsertAt | Call this member to insert an item at a specific position within the collection of items.
Move | Call this member to move a GroupItem to the specified location within the collection of items.
Remove | Call this method to remove the specified item.
RemoveAt | Call this method to remove the specified item by its index.


CXTPTaskPanelItems Data Members

CXTPTaskPanelItems Class, Legend, Protected Data Members
CXTPTaskPanelItems Data Members
Class

CXTPTaskPanelItems Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrItems | Array of items.
m_pOwner | Owner of items.
m_pPanel | Parent TaskPanel control.


CXTPTaskPanelItems::m_arrItems Data Member

CXTPTaskPanelItems Data Members, CXTPTaskPanelItems Class
CXTPTaskPanelItems::m_arrItems Data Member

Array of items.

CArray<CXTPTaskPanelItem*, CXTPTaskPanelItem*> m_arrItems;
Group

CXTPTaskPanelItems Data Members


CXTPTaskPanelItems::m_pOwner Data Member

CXTPTaskPanelItems Data Members, CXTPTaskPanelItems Class
CXTPTaskPanelItems::m_pOwner Data Member

Owner of items.

CCmdTarget* m_pOwner;
Group

CXTPTaskPanelItems Data Members


CXTPTaskPanelItems::m_pPanel Data Member

CXTPTaskPanelItems Data Members, CXTPTaskPanelItems Class
CXTPTaskPanelItems::m_pPanel Data Member

Parent TaskPanel control.

CXTPTaskPanel* m_pPanel;
Group

CXTPTaskPanelItems Data Members


CXTPTaskPanelItems Methods

CXTPTaskPanelItems Class, Legend, Public Methods
CXTPTaskPanelItems Methods
Class

CXTPTaskPanelItems Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Add | Call this member to add a new item to the collection.
Clear | Call this method to remove all items in the collection.
DoPropExchange | Reads or writes this object from or to an archive.
Find | Call this member function to find an item by its ID
GetAt | Call this member to return the item at the specified index
GetCount | Call this member to get count of items
GetDefaultItemClass | Retrieves default runtime class of items in collection.
GetFirstVisibleItem | Retrieves first visible item.
GetIndex | Call this member to get index of item in the collection of items.
GetLastVisibleItem | Retrieves last visible item.
GetNextVisibleIndex | This method finds next visible item index in specified direction.
GetOwner | Call this member function to get a pointer to the owner
InsertAt | Call this member to insert an item at a specific position within the collection of items.
Move | Call this member to move a GroupItem to the specified location within the collection of items.
Remove | Call this method to remove the specified item.
RemoveAt | Call this method to remove the specified item by its index.


CXTPTaskPanelItems::Add Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::Add Method

Call this member to add a new item to the collection.

CXTPTaskPanelItem* Add(
    CXTPTaskPanelItem* pItem,
    UINT nID
);
Parameters

pItem
Points to a CXTPTaskPanelItem to be added.
nID
Identifier of the item.

Returns

A pointer to a CXTPTaskPanelItem object added.

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::Clear Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItems::Clear Method

Call this method to remove all items in the collection.

void Clear(
    BOOL bReposition = TRUE
);
Parameters

bReposition
TRUE to reposition items after remove.

See Also

CXTPTaskPanel::Reposition

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::DoPropExchange Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::DoPropExchange Method

Reads or writes this object from or to an archive.

void DoPropExchange(
    CXTPPropExchange* pPX
);
Parameters

pPX
A CXTPPropExchange object to serialize to or from.

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::Find Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::Find Method

Call this member function to find an item by its ID

CXTPTaskPanelItem* Find(
    UINT nID
) const;
Parameters

nID
Identifier of item to be found.

Returns

A pointer to item if successful; otherwise returns NULL.

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::GetAt Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItems::GetAt Method

Call this member to return the item at the specified index

CXTPTaskPanelItem* GetAt(
    int nIndex
) const;
Parameters

nIndex
Specifies the zero-based index of the item to retrieve.

Returns

A pointer to a CXTPTaskPanelItem object.

Body Source
CXTPTaskPanelItem* CXTPTaskPanelItems::GetAt(int nIndex) const
{
    return nIndex >= 0 && nIndex < m_arrItems.GetSize() ? m_arrItems.GetAt(nIndex) : NULL;
}
Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::GetCount Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItems::GetCount Method

Call this member to get count of items

int GetCount() const;
Returns

Number of items.

Body Source
int CXTPTaskPanelItems::GetCount() const
{
    return (int)m_arrItems.GetSize();
}
Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::GetDefaultItemClass Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::GetDefaultItemClass Method

Retrieves default runtime class of items in collection.

virtual CRuntimeClass* GetDefaultItemClass() const;
Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::GetFirstVisibleItem Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItems::GetFirstVisibleItem Method

Retrieves first visible item.

CXTPTaskPanelItem* GetFirstVisibleItem() const;
Returns

Pointer to first visible item in collection

See Also

GetLastVisibleItem, GetNextVisibleIndex

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::GetIndex Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::GetIndex Method

Call this member to get index of item in the collection of items.

int GetIndex(
    const CXTPTaskPanelItem* pItem
) const;
Parameters

pItem
Item to be tested

Returns

Index of item in collection.

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::GetLastVisibleItem Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItems::GetLastVisibleItem Method

Retrieves last visible item.

CXTPTaskPanelItem* GetLastVisibleItem() const;
Returns

Pointer to last visible item in collection

See Also

GetFirstVisibleItem, GetNextVisibleIndex

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::GetNextVisibleIndex Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItems::GetNextVisibleIndex Method

This method finds next visible item index in specified direction.

int GetNextVisibleIndex(
    int nIndex,
    int nDirection
) const;
Parameters

nIndex
Index of the item to begin the searching with.
nDirection
Direction to find (1 to forward, -1 to backward)

Returns

The index of the next visible item if successful, or -1 otherwise.

See Also

GetFirstVisibleItem, GetLastVisibleItem

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::GetOwner Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelItems::GetOwner Method

Call this member function to get a pointer to the owner

CCmdTarget* GetOwner() const;
Returns

A pointer to a CCmdTarget object owned by this collection

Body Source
CCmdTarget* CXTPTaskPanelItems::GetOwner() const
{
    return m_pOwner;
}
Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::InsertAt Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::InsertAt Method

Call this member to insert an item at a specific position within the collection of items.

CXTPTaskPanelItem* InsertAt(
    int nIndex,
    CXTPTaskPanelItem* pItem
);
Parameters

nIndex
Position in collectionarray to insert the new item.
pItem
Pointer to a valid task panel itemgroup.

Returns

A pointer to the newly inserted item.

Remarks

To move an item, use the MOVE function.

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::Move Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::Move Method

Call this member to move a GroupItem to the specified location within the collection of items.

void Move(
    CXTPTaskPanelItem* pItem,
    int nIndex
);
Parameters

pItem
GroupItem to be moved.
nIndex
New position of the item within the collection of items.

Remarks

A GroupItem will be displayed in the order that they are added to the collection of items. They are stored in a zero based array of items. The items position within the array can be changed by specifying an index to move the item to.

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::Remove Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::Remove Method

Call this method to remove the specified item.

void Remove(
    CXTPTaskPanelItem* pItem
);
Parameters

pItem
Item to be removed.

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems::RemoveAt Method

CXTPTaskPanelItems Methods, CXTPTaskPanelItems Class
CXTPTaskPanelItems::RemoveAt Method

Call this method to remove the specified item by its index.

void RemoveAt(
    int nIndex
);
Parameters

nIndex
Specifies the zero-based index of the item to remove.

Group

CXTPTaskPanelItems Methods


CXTPTaskPanelItems Constructors

CXTPTaskPanelItems Class, Legend, Public Methods
CXTPTaskPanelItems Constructors
Class

CXTPTaskPanelItems Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelItems | Constructs a CXTPTaskPanelItems object.


CXTPTaskPanelItems::CXTPTaskPanelItems Constructor

CXTPTaskPanelItems Constructors, CXTPTaskPanelItems Class
CXTPTaskPanelItems::CXTPTaskPanelItems Constructor

Constructs a CXTPTaskPanelItems object.

CXTPTaskPanelItems(
    CXTPTaskPanel* pPanel = NULL
);
Parameters

pPanel
Pointer to the task panel to add the items to.

Group

CXTPTaskPanelItems Constructors


CXTPTaskPanelItems Destructors

CXTPTaskPanelItems Class, Legend, Public Methods
CXTPTaskPanelItems Destructors
Class

CXTPTaskPanelItems Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTaskPanelItems | Destroys a CXTPTaskPanelItems object, handles cleanup and deallocation.


CXTPTaskPanelItems::~CXTPTaskPanelItems Destructor

CXTPTaskPanelItems Destructors, CXTPTaskPanelItems Class
CXTPTaskPanelItems::~CXTPTaskPanelItems Destructor

Destroys a CXTPTaskPanelItems object, handles cleanup and deallocation.

virtual ~CXTPTaskPanelItems();
Group

CXTPTaskPanelItems Destructors


CXTPTaskPanelListViewOffice2003Theme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelListViewOffice2003Theme Data Members, CXTPTaskPanelListViewOffice2003Theme Methods, CXTPTaskPanelListViewOffice2003Theme Constructors, CXTPTaskPanelListViewOffice2003Theme Constructors, CXTPTaskPanelListViewOffice2003Theme Data Members, CXTPTaskPanelListViewOffice2003Theme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme Class

The CXTPTaskPanelListViewOffice2003Theme class is used to enable a List View Office 2003 style theme.

Class Hierarchy

class CXTPTaskPanelListViewOffice2003Theme : public CXTPTaskPanelListViewOfficeXPTheme;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Data Member
Method
CXTPTaskPanelListViewOffice2003Theme Constructors
CXTPTaskPanelListViewOffice2003Theme Constructors | Description
CXTPTaskPanelListViewOffice2003Theme | Constructs a CXTPTaskPanelListViewOffice2003Theme object.
CXTPTaskPanelListViewOffice2003Theme Data Members
CXTPTaskPanelListViewOffice2003Theme Data Members | Description
m_grcHot | Color gradient used to colorize "hot" items for this theme.
m_grcPushed | Color gradient used to colorize "pushed" items for this theme.
CXTPTaskPanelListViewOffice2003Theme Methods
CXTPTaskPanelListViewOffice2003Theme Methods | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelListViewOffice2003Theme Data Members

CXTPTaskPanelListViewOffice2003Theme Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme Data Members
Class

CXTPTaskPanelListViewOffice2003Theme Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_grcHot | Color gradient used to colorize "hot" items for this theme.
m_grcPushed | Color gradient used to colorize "pushed" items for this theme.


CXTPTaskPanelListViewOffice2003Theme::m_grcHot Data Member

CXTPTaskPanelListViewOffice2003Theme Data Members, CXTPTaskPanelListViewOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme::m_grcHot Data Member

Color gradient used to colorize "hot" items for this theme.

CXTPPaintManagerColorGradient m_grcHot;
Group

CXTPTaskPanelListViewOffice2003Theme Data Members


CXTPTaskPanelListViewOffice2003Theme::m_grcPushed Data Member

CXTPTaskPanelListViewOffice2003Theme Data Members, CXTPTaskPanelListViewOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme::m_grcPushed Data Member

Color gradient used to colorize "pushed" items for this theme.

CXTPPaintManagerColorGradient m_grcPushed;
Group

CXTPTaskPanelListViewOffice2003Theme Data Members


CXTPTaskPanelListViewOffice2003Theme Methods

CXTPTaskPanelListViewOffice2003Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme Methods
Class

CXTPTaskPanelListViewOffice2003Theme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelListViewOffice2003Theme::DrawGroupCaptionBackground Method

CXTPTaskPanelListViewOffice2003Theme Methods, CXTPTaskPanelListViewOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme::DrawGroupCaptionBackground Method

This member is called to draw the background of the group caption.

CRect DrawGroupCaptionBackground(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
pGroup
Fill group caption of this group.
rc
Bounding rectangle of the group caption.

Returns

Bounding rectangle of group caption.

Remarks

This member will draw the normal, hot, and pressed background for the group caption. It will then fill the group caption with the Office 2003 color gradient.

Group

CXTPTaskPanelListViewOffice2003Theme Methods


CXTPTaskPanelListViewOffice2003Theme::RefreshMetrics Method

CXTPTaskPanelListViewOffice2003Theme Methods, CXTPTaskPanelListViewOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelListViewOffice2003Theme Methods


CXTPTaskPanelListViewOffice2003Theme Constructors

CXTPTaskPanelListViewOffice2003Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme Constructors
Class

CXTPTaskPanelListViewOffice2003Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelListViewOffice2003Theme | Constructs a CXTPTaskPanelListViewOffice2003Theme object.


CXTPTaskPanelListViewOffice2003Theme::CXTPTaskPanelListViewOffice2003Theme Constructor

CXTPTaskPanelListViewOffice2003Theme Constructors, CXTPTaskPanelListViewOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOffice2003Theme::CXTPTaskPanelListViewOffice2003Theme Constructor

Constructs a CXTPTaskPanelListViewOffice2003Theme object.

CXTPTaskPanelListViewOffice2003Theme();
Group

CXTPTaskPanelListViewOffice2003Theme Constructors


CXTPTaskPanelListViewOfficeXPTheme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelListViewOfficeXPTheme Methods, CXTPTaskPanelListViewOfficeXPTheme Constructors, CXTPTaskPanelListViewOfficeXPTheme Constructors, CXTPTaskPanelListViewOfficeXPTheme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOfficeXPTheme Class

The CXTPTaskPanelListViewOfficeXPTheme class is used to enable a List View Office XP style theme.

Class Hierarchy

class CXTPTaskPanelListViewOfficeXPTheme : public CXTPTaskPanelListViewTheme;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
CXTPTaskPanelListViewOfficeXPTheme Constructors
CXTPTaskPanelListViewOfficeXPTheme Constructors | Description
CXTPTaskPanelListViewOfficeXPTheme | Constructs a CXTPTaskPanelListViewOfficeXPTheme object.
CXTPTaskPanelListViewOfficeXPTheme Methods
CXTPTaskPanelListViewOfficeXPTheme Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelListViewOfficeXPTheme Methods

CXTPTaskPanelListViewOfficeXPTheme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOfficeXPTheme Methods
Class

CXTPTaskPanelListViewOfficeXPTheme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelListViewOfficeXPTheme::RefreshMetrics Method

CXTPTaskPanelListViewOfficeXPTheme Methods, CXTPTaskPanelListViewOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOfficeXPTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelListViewOfficeXPTheme Methods


CXTPTaskPanelListViewOfficeXPTheme Constructors

CXTPTaskPanelListViewOfficeXPTheme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOfficeXPTheme Constructors
Class

CXTPTaskPanelListViewOfficeXPTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelListViewOfficeXPTheme | Constructs a CXTPTaskPanelListViewOfficeXPTheme object.


CXTPTaskPanelListViewOfficeXPTheme::CXTPTaskPanelListViewOfficeXPTheme Constructor

CXTPTaskPanelListViewOfficeXPTheme Constructors, CXTPTaskPanelListViewOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewOfficeXPTheme::CXTPTaskPanelListViewOfficeXPTheme Constructor

Constructs a CXTPTaskPanelListViewOfficeXPTheme object.

CXTPTaskPanelListViewOfficeXPTheme();
Group

CXTPTaskPanelListViewOfficeXPTheme Constructors


CXTPTaskPanelListViewTheme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelListViewTheme Methods, CXTPTaskPanelListViewTheme Constructors, CXTPTaskPanelListViewTheme Constructors, CXTPTaskPanelListViewTheme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewTheme Class

The CXTPTaskPanelListViewTheme class is used to enable a List View style theme.

Class Hierarchy

class CXTPTaskPanelListViewTheme : public CXTPTaskPanelToolboxTheme;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
CXTPTaskPanelListViewTheme Constructors
CXTPTaskPanelListViewTheme Constructors | Description
CXTPTaskPanelListViewTheme | Constructs a CXTPTaskPanelListViewTheme object.
CXTPTaskPanelListViewTheme Methods
CXTPTaskPanelListViewTheme Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelListViewTheme Methods

CXTPTaskPanelListViewTheme Class, Legend, Public Methods
CXTPTaskPanelListViewTheme Methods
Class

CXTPTaskPanelListViewTheme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelListViewTheme::RefreshMetrics Method

CXTPTaskPanelListViewTheme Methods, CXTPTaskPanelListViewTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelListViewTheme Methods


CXTPTaskPanelListViewTheme Constructors

CXTPTaskPanelListViewTheme Class, Legend, Public Methods
CXTPTaskPanelListViewTheme Constructors
Class

CXTPTaskPanelListViewTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelListViewTheme | Constructs a CXTPTaskPanelListViewTheme object.


CXTPTaskPanelListViewTheme::CXTPTaskPanelListViewTheme Constructor

CXTPTaskPanelListViewTheme Constructors, CXTPTaskPanelListViewTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelListViewTheme::CXTPTaskPanelListViewTheme Constructor

Constructs a CXTPTaskPanelListViewTheme object.

CXTPTaskPanelListViewTheme();
Group

CXTPTaskPanelListViewTheme Constructors


CXTPTaskPanelOffice2003Theme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelOffice2003Theme Methods, CXTPTaskPanelOffice2003Theme Constructors, CXTPTaskPanelOffice2003Theme Constructors, CXTPTaskPanelOffice2003Theme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOffice2003Theme Class

Class that represents an Office 2003 style theme.

Class Hierarchy

class CXTPTaskPanelOffice2003Theme : public CXTPTaskPanelPaintManager;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
CXTPTaskPanelOffice2003Theme Constructors
CXTPTaskPanelOffice2003Theme Constructors | Description
CXTPTaskPanelOffice2003Theme | Constructs a CXTPTaskPanelOffice2003Theme object.
CXTPTaskPanelOffice2003Theme Methods
CXTPTaskPanelOffice2003Theme Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelOffice2003Theme Methods

CXTPTaskPanelOffice2003Theme Class, Legend, Public Methods
CXTPTaskPanelOffice2003Theme Methods
Class

CXTPTaskPanelOffice2003Theme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelOffice2003Theme::RefreshMetrics Method

CXTPTaskPanelOffice2003Theme Methods, CXTPTaskPanelOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOffice2003Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelOffice2003Theme Methods


CXTPTaskPanelOffice2003Theme Constructors

CXTPTaskPanelOffice2003Theme Class, Legend, Public Methods
CXTPTaskPanelOffice2003Theme Constructors
Class

CXTPTaskPanelOffice2003Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelOffice2003Theme | Constructs a CXTPTaskPanelOffice2003Theme object.


CXTPTaskPanelOffice2003Theme::CXTPTaskPanelOffice2003Theme Constructor

CXTPTaskPanelOffice2003Theme Constructors, CXTPTaskPanelOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOffice2003Theme::CXTPTaskPanelOffice2003Theme Constructor

Constructs a CXTPTaskPanelOffice2003Theme object.

CXTPTaskPanelOffice2003Theme();
Group

CXTPTaskPanelOffice2003Theme Constructors


CXTPTaskPanelOffice2003ThemePlain Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelOffice2003ThemePlain Methods, CXTPTaskPanelOffice2003ThemePlain Constructors, CXTPTaskPanelOffice2003ThemePlain Constructors, CXTPTaskPanelOffice2003ThemePlain Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOffice2003ThemePlain Class

The CXTPTaskPanelOffice2003ThemePlain class is used to enable a classic Office 2003 style theme.

Class Hierarchy

class CXTPTaskPanelOffice2003ThemePlain : public CXTPTaskPanelOfficeXPThemePlain;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
CXTPTaskPanelOffice2003ThemePlain Constructors
CXTPTaskPanelOffice2003ThemePlain Constructors | Description
CXTPTaskPanelOffice2003ThemePlain | Constructs a CXTPTaskPanelOffice2003ThemePlain object.
CXTPTaskPanelOffice2003ThemePlain Methods
CXTPTaskPanelOffice2003ThemePlain Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelOffice2003ThemePlain Methods

CXTPTaskPanelOffice2003ThemePlain Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOffice2003ThemePlain Methods
Class

CXTPTaskPanelOffice2003ThemePlain Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelOffice2003ThemePlain::RefreshMetrics Method

CXTPTaskPanelOffice2003ThemePlain Methods, CXTPTaskPanelOffice2003ThemePlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOffice2003ThemePlain::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelOffice2003ThemePlain Methods


CXTPTaskPanelOffice2003ThemePlain Constructors

CXTPTaskPanelOffice2003ThemePlain Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOffice2003ThemePlain Constructors
Class

CXTPTaskPanelOffice2003ThemePlain Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelOffice2003ThemePlain | Constructs a CXTPTaskPanelOffice2003ThemePlain object.


CXTPTaskPanelOffice2003ThemePlain::CXTPTaskPanelOffice2003ThemePlain Constructor

CXTPTaskPanelOffice2003ThemePlain Constructors, CXTPTaskPanelOffice2003ThemePlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOffice2003ThemePlain::CXTPTaskPanelOffice2003ThemePlain Constructor

Constructs a CXTPTaskPanelOffice2003ThemePlain object.

CXTPTaskPanelOffice2003ThemePlain();
Group

CXTPTaskPanelOffice2003ThemePlain Constructors


CXTPTaskPanelOfficeXPThemePlain Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelOfficeXPThemePlain Methods, CXTPTaskPanelOfficeXPThemePlain Constructors, CXTPTaskPanelOfficeXPThemePlain Constructors, CXTPTaskPanelOfficeXPThemePlain Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOfficeXPThemePlain Class

The CXTPTaskPanelOfficeXPThemePlain class is used to enable a classic Office XP style theme.

Class Hierarchy

class CXTPTaskPanelOfficeXPThemePlain : public CXTPTaskPanelPaintManagerPlain;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
CXTPTaskPanelOfficeXPThemePlain Constructors
CXTPTaskPanelOfficeXPThemePlain Constructors | Description
CXTPTaskPanelOfficeXPThemePlain | Constructs a CXTPTaskPanelOfficeXPThemePlain object.
CXTPTaskPanelOfficeXPThemePlain Methods
CXTPTaskPanelOfficeXPThemePlain Methods | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelOfficeXPThemePlain Methods

CXTPTaskPanelOfficeXPThemePlain Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOfficeXPThemePlain Methods
Class

CXTPTaskPanelOfficeXPThemePlain Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelOfficeXPThemePlain::RefreshMetrics Method

CXTPTaskPanelOfficeXPThemePlain Methods, CXTPTaskPanelOfficeXPThemePlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOfficeXPThemePlain::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelOfficeXPThemePlain Methods


CXTPTaskPanelOfficeXPThemePlain Constructors

CXTPTaskPanelOfficeXPThemePlain Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOfficeXPThemePlain Constructors
Class

CXTPTaskPanelOfficeXPThemePlain Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelOfficeXPThemePlain | Constructs a CXTPTaskPanelOfficeXPThemePlain object.


CXTPTaskPanelOfficeXPThemePlain::CXTPTaskPanelOfficeXPThemePlain Constructor

CXTPTaskPanelOfficeXPThemePlain Constructors, CXTPTaskPanelOfficeXPThemePlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelOfficeXPThemePlain::CXTPTaskPanelOfficeXPThemePlain Constructor

Constructs a CXTPTaskPanelOfficeXPThemePlain object.

CXTPTaskPanelOfficeXPThemePlain();
Group

CXTPTaskPanelOfficeXPThemePlain Constructors


CXTPTaskPanelPaintManager Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Constructors, CXTPTaskPanelPaintManager Destructors, CXTPTaskPanelPaintManager Constructors, CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Destructors, CXTPTaskPanelPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager Class

Standalone class used by CXTPTaskPanel as paint manager.

Class Hierarchy

class CXTPTaskPanelPaintManager;
File

XTPTaskPanelPaintManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPTaskPanelPaintManager Constructors
CXTPTaskPanelPaintManager Constructors | Description
CXTPTaskPanelPaintManager | Constructs a CXTPTaskPanelPaintManager object
CXTPTaskPanelPaintManager Data Members
CXTPTaskPanelPaintManager Data Members | Description
m_bBoldCaption | TRUE to display caption text in bold font, FALSE to display caption text in normal type.
m_bCaptionScrollButton | TRUE if group caption scroll button is visible, FALSE if it is hidden.
m_bEmbossedDisabledText | TRUE to draw disabled text embossed.
m_bEmulateEplorerTheme | TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
m_bInvertDragRect | Only used when theme is set to xtpTaskPanelThemeToolbox.
m_bLeftRoundedCorner | TRUE to round left corner of the group caption.
m_bmpGrippers | Bitmaps of alpha grippers.
m_bOfficeBorder | TRUE to use office borders.
m_bOfficeHighlight | TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED)
m_bRightRoundedCorner | TRUE to round right corner of the group caption.
m_bUseBitmapGrippers | TRUE to use alpha grippers.
m_bUseStandardCaptionFont | TRUE to use system font for group caption text.
m_bUseStandardItemsFont | TRUE to use system font for item caption text.
m_clrBackground | Background color of Task Panel.
m_clrHighlightBorder | Border color of items when they are "hot." This the border color of the item on mouseover if hot tracking is enabled.
m_clrHighlightHot | Color of items when they are "hot." This the color of the item on mouseover if hot tracking is enabled.
m_clrHighlightPressed | Color of items when they are pressed.
m_clrHighlightSelected | Color of items when they are selected.
m_eGripper | Gripper of the manager.
m_fntCaption | Caption font.
m_fntIcon | Normal Items font.
m_fntIconBold | Bold items font.
m_fntIconHot | Hot items font.
m_fntIconHotBold | Bold items font.
m_groupNormal | Normal colors set.
m_groupSpecial | Special colors set.
m_hGripperNormal | Icon of normal group header gripper
m_hGripperSpecial | Icon of special group header gripper.
m_nCaptionHeight | Caption height in pixels.
m_nCaptionTextFormat | Format flags of caption text.
m_nGroupSpacing | Amount of space placed between groups in the task panel.
m_nItemTextFormat | Format flags of item text.
m_rcControlMargins | Default margins for all groups.
m_rcGroupIconPadding | Padding around images for groups.
m_rcGroupInnerMargins | Inner margins of the group.
m_rcGroupOuterMargins | Outer margins of the group.
m_rcImageLayoutIconPadding | Padding around images for xtpTaskItemLayoutImages layout.
m_rcItemIconPadding | Padding around images for items.
m_rcItemInnerMargins | Inner margins of the group items.
m_rcItemOuterMargins | Outer margins of the group items.
rectDefault | System selected default margins.
CXTPTaskPanelPaintManager Destructors
CXTPTaskPanelPaintManager Destructors | Description
~CXTPTaskPanelPaintManager | Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation
CXTPTaskPanelPaintManager Methods
CXTPTaskPanelPaintManager Methods | Description
BlendColor | Call this member function to blend from one color to another color by the amount specified in nAlpha.
CreateGripperBitmaps | This method loads the group caption expand button bitmaps for the xtpTaskPanelThemeNativeWinXPPlain and xtpTaskPanelThemeNativeWinXP themes.
CreateGripperIcon | This method creates expand button icons for the xtpTaskPanelThemeNativeWinXPPlain and xtpTaskPanelThemeNativeWinXP themes when the current operation system used is not Windows Xp or if the OS is WinXP and Classic themes are used.
DrawCaptionGripper | This method is called to draw gripper of the caption.
DrawCaptionGripperBitmap | This method is called to draw the group caption expand button bitmap.
DrawCaptionGripperSigns | This method is used to draw the ">>" and "<<" of the group caption expand button for the xtpTaskPanelThemeOffice2000 theme.
DrawDragArrow | This method is called to draw the "drag arrow" while dragging an item.
DrawFocusRect | This method is called to draw rectangle around focused item.
DrawGroupCaption | This method is called to draw the caption of the group.
DrawGroupClient | This method is called to draw a single group of the control.
DrawGroupClientFace | This method is called to draw the face of the group.
DrawGroupClientItems | This method is called to draw the items of the group.
DrawGroupItem | This method is called to draw single item of control.
DrawGroupItemFrame | This member draws a rectangle around a group item when selected, pressed or highlighted.
DrawGroupItemImage | This member is called to a group item when the layout is xtpTaskItemLayoutImages.
DrawGroupItemImageWithText | This member is called to a group item when the layout is xtpTaskItemLayoutImagesWithText.
DrawGroupItemImageWithTextBelow | This member is called to a group item when the layout is xtpTaskItemLayoutImagesWithTextBelow.
DrawItemCaption | This method is called to draw text caption of the task panel item.
DrawItemImage | This method is called to draw the icon of the task panel item.
DrawScrollButton | The member is called to draw a group scroll button.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
FreeBitmaps | This method is called to free the memory used by the group caption bitmaps.
GetCaptionGripperWidth | This method is called to get width of caption's gripper.
GetControlMargins | Call this member to retrieve the default margins used for all groups.
GetGroupColors |
GetGroupInnerMargins | Call this member to retrieve the inner margins of a group.
GetGroupOuterMargins | Call this member to retrieve the outer margins of a group.
GetGroupSpacing | Call this member to return the spacing used between groups.
GetHighlightOffset | This method is called to retrieve the highlight offset of the text of an item.
GetItemFont | Call this member to retrieve the font used to display task panel item text.
GetItemIconPadding | Call this member to retrieve the padding around the image.
GetItemInnerMargins | Call this member to retrieve the inner margins of a group item.
GetItemOuterMargins | Call this member to retrieve the outer margins of a group item.
Rectangle | This method is only used when drawing hot, pressed and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
RefreshMetrics | This method is called to refresh the visual metrics of manager.
SetCaptionFontIndirect | Call this member to set the font used to display text in task panel group caption. Can use custom font or the standard caption font.
SetItemsFontIndirect | Call this member to set the font used to display task panel item text. Can use custom font or the standard item font.
SetTextFormat | Call this method to set format of drawn text for items and caption.


CXTPTaskPanelPaintManager Data Members

CXTPTaskPanelPaintManager Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager Data Members
Class

CXTPTaskPanelPaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bLeftRoundedCorner | TRUE to round left corner of the group caption.
m_bmpGrippers | Bitmaps of alpha grippers.
m_bOfficeBorder | TRUE to use office borders.
m_bRightRoundedCorner | TRUE to round right corner of the group caption.
m_bUseBitmapGrippers | TRUE to use alpha grippers.
m_bUseStandardCaptionFont | TRUE to use system font for group caption text.
m_bUseStandardItemsFont | TRUE to use system font for item caption text.
m_clrBackground | Background color of Task Panel.
m_clrHighlightBorder | Border color of items when they are "hot." This the border color of the item on mouseover if hot tracking is enabled.
m_clrHighlightHot | Color of items when they are "hot." This the color of the item on mouseover if hot tracking is enabled.
m_clrHighlightPressed | Color of items when they are pressed.
m_clrHighlightSelected | Color of items when they are selected.
m_fntCaption | Caption font.
m_fntIcon | Normal Items font.
m_fntIconBold | Bold items font.
m_fntIconHot | Hot items font.
m_fntIconHotBold | Bold items font.
m_groupNormal | Normal colors set.
m_groupSpecial | Special colors set.
m_hGripperNormal | Icon of normal group header gripper
m_hGripperSpecial | Icon of special group header gripper.
m_nCaptionHeight | Caption height in pixels.
m_nCaptionTextFormat | Format flags of caption text.
m_nItemTextFormat | Format flags of item text.
Public Data Members
Public Data Member | Description
m_bBoldCaption | TRUE to display caption text in bold font, FALSE to display caption text in normal type.
m_bCaptionScrollButton | TRUE if group caption scroll button is visible, FALSE if it is hidden.
m_bEmbossedDisabledText | TRUE to draw disabled text embossed.
m_bEmulateEplorerTheme | TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
m_bInvertDragRect | Only used when theme is set to xtpTaskPanelThemeToolbox.
m_bOfficeHighlight | TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED)
m_eGripper | Gripper of the manager.
m_nGroupSpacing | Amount of space placed between groups in the task panel.
m_rcControlMargins | Default margins for all groups.
m_rcGroupIconPadding | Padding around images for groups.
m_rcGroupInnerMargins | Inner margins of the group.
m_rcGroupOuterMargins | Outer margins of the group.
m_rcImageLayoutIconPadding | Padding around images for xtpTaskItemLayoutImages layout.
m_rcItemIconPadding | Padding around images for items.
m_rcItemInnerMargins | Inner margins of the group items.
m_rcItemOuterMargins | Outer margins of the group items.
rectDefault | System selected default margins.


CXTPTaskPanelPaintManager::m_bBoldCaption Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bBoldCaption Data Member

TRUE to display caption text in bold font, FALSE to display caption text in normal type.

BOOL m_bBoldCaption;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bCaptionScrollButton Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bCaptionScrollButton Data Member

TRUE if group caption scroll button is visible, FALSE if it is hidden.

BOOL m_bCaptionScrollButton;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bEmbossedDisabledText Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bEmbossedDisabledText Data Member

TRUE to draw disabled text embossed.

BOOL m_bEmbossedDisabledText;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bEmulateEplorerTheme Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bEmulateEplorerTheme Data Member

TRUE to use Explorer theme under WinXP and Office 2000 under older OS.

BOOL m_bEmulateEplorerTheme;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bInvertDragRect Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bInvertDragRect Data Member

Only used when theme is set to xtpTaskPanelThemeToolbox.

BOOL m_bInvertDragRect;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bLeftRoundedCorner Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bLeftRoundedCorner Data Member

TRUE to round left corner of the group caption.

BOOL m_bLeftRoundedCorner;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bmpGrippers Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bmpGrippers Data Member

Bitmaps of alpha grippers.

HBITMAP m_bmpGrippers[8];
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bOfficeBorder Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bOfficeBorder Data Member

TRUE to use office borders.

BOOL m_bOfficeBorder;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bOfficeHighlight Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bOfficeHighlight Data Member

TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED)

BOOL m_bOfficeHighlight;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bRightRoundedCorner Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bRightRoundedCorner Data Member

TRUE to round right corner of the group caption.

BOOL m_bRightRoundedCorner;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bUseBitmapGrippers Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bUseBitmapGrippers Data Member

TRUE to use alpha grippers.

BOOL m_bUseBitmapGrippers;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bUseStandardCaptionFont Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bUseStandardCaptionFont Data Member

TRUE to use system font for group caption text.

BOOL m_bUseStandardCaptionFont;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_bUseStandardItemsFont Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_bUseStandardItemsFont Data Member

TRUE to use system font for item caption text.

BOOL m_bUseStandardItemsFont;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_clrBackground Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_clrBackground Data Member

Background color of Task Panel.

CXTPPaintManagerColorGradient m_clrBackground;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_clrHighlightBorder Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_clrHighlightBorder Data Member

Border color of items when they are "hot." This the border color of the item on mouseover if hot tracking is enabled.

CXTPPaintManagerColorGradient m_clrHighlightBorder;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_clrHighlightHot Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_clrHighlightHot Data Member

Color of items when they are "hot." This the color of the item on mouseover if hot tracking is enabled.

CXTPPaintManagerColor m_clrHighlightHot;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_clrHighlightPressed Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_clrHighlightPressed Data Member

Color of items when they are pressed.

CXTPPaintManagerColor m_clrHighlightPressed;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_clrHighlightSelected Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_clrHighlightSelected Data Member

Color of items when they are selected.

CXTPPaintManagerColor m_clrHighlightSelected;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_eGripper Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_eGripper Data Member

Gripper of the manager.

XTPTaskPanelGripper m_eGripper;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_fntCaption Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_fntCaption Data Member

Caption font.

CFont m_fntCaption;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_fntIcon Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_fntIcon Data Member

Normal Items font.

CFont m_fntIcon;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_fntIconBold Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_fntIconBold Data Member

Bold items font.

CFont m_fntIconBold;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_fntIconHot Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_fntIconHot Data Member

Hot items font.

CFont m_fntIconHot;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_fntIconHotBold Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_fntIconHotBold Data Member

Bold items font.

CFont m_fntIconHotBold;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_groupNormal Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_groupNormal Data Member

Normal colors set.

XTP_TASKPANEL_GROUPCOLORS m_groupNormal;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_groupSpecial Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_groupSpecial Data Member

Special colors set.

XTP_TASKPANEL_GROUPCOLORS m_groupSpecial;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_hGripperNormal Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_hGripperNormal Data Member

Icon of normal group header gripper

HICON m_hGripperNormal;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_hGripperSpecial Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_hGripperSpecial Data Member

Icon of special group header gripper.

HICON m_hGripperSpecial;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_nCaptionHeight Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_nCaptionHeight Data Member

Caption height in pixels.

int m_nCaptionHeight;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_nCaptionTextFormat Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_nCaptionTextFormat Data Member

Format flags of caption text.

int m_nCaptionTextFormat;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_nGroupSpacing Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_nGroupSpacing Data Member

Amount of space placed between groups in the task panel.

int m_nGroupSpacing;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_nItemTextFormat Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_nItemTextFormat Data Member

Format flags of item text.

int m_nItemTextFormat;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_rcControlMargins Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_rcControlMargins Data Member

Default margins for all groups.

CRect m_rcControlMargins;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_rcGroupIconPadding Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_rcGroupIconPadding Data Member

Padding around images for groups.

CRect m_rcGroupIconPadding;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_rcGroupInnerMargins Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_rcGroupInnerMargins Data Member

Inner margins of the group.

CRect m_rcGroupInnerMargins;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_rcGroupOuterMargins Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_rcGroupOuterMargins Data Member

Outer margins of the group.

CRect m_rcGroupOuterMargins;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_rcImageLayoutIconPadding Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_rcImageLayoutIconPadding Data Member

Padding around images for xtpTaskItemLayoutImages layout.

CRect m_rcImageLayoutIconPadding;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_rcItemIconPadding Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_rcItemIconPadding Data Member

Padding around images for items.

CRect m_rcItemIconPadding;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_rcItemInnerMargins Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_rcItemInnerMargins Data Member

Inner margins of the group items.

CRect m_rcItemInnerMargins;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::m_rcItemOuterMargins Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::m_rcItemOuterMargins Data Member

Outer margins of the group items.

CRect m_rcItemOuterMargins;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager::rectDefault Data Member

CXTPTaskPanelPaintManager Data Members, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::rectDefault Data Member

System selected default margins.

const CRect rectDefault;
Group

CXTPTaskPanelPaintManager Data Members


CXTPTaskPanelPaintManager Methods

CXTPTaskPanelPaintManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager Methods
Class

CXTPTaskPanelPaintManager Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
BlendColor | Call this member function to blend from one color to another color by the amount specified in nAlpha.
CreateGripperBitmaps | This method loads the group caption expand button bitmaps for the xtpTaskPanelThemeNativeWinXPPlain and xtpTaskPanelThemeNativeWinXP themes.
CreateGripperIcon | This method creates expand button icons for the xtpTaskPanelThemeNativeWinXPPlain and xtpTaskPanelThemeNativeWinXP themes when the current operation system used is not Windows Xp or if the OS is WinXP and Classic themes are used.
DrawCaptionGripper | This method is called to draw gripper of the caption.
DrawCaptionGripperBitmap | This method is called to draw the group caption expand button bitmap.
DrawCaptionGripperSigns | This method is used to draw the ">>" and "<<" of the group caption expand button for the xtpTaskPanelThemeOffice2000 theme.
DrawDragArrow | This method is called to draw the "drag arrow" while dragging an item.
DrawFocusRect | This method is called to draw rectangle around focused item.
DrawGroupClientFace | This method is called to draw the face of the group.
DrawGroupClientItems | This method is called to draw the items of the group.
DrawGroupItemImage | This member is called to a group item when the layout is xtpTaskItemLayoutImages.
DrawGroupItemImageWithText | This member is called to a group item when the layout is xtpTaskItemLayoutImagesWithText.
DrawGroupItemImageWithTextBelow | This member is called to a group item when the layout is xtpTaskItemLayoutImagesWithTextBelow.
DrawItemCaption | This method is called to draw text caption of the task panel item.
DrawItemImage | This method is called to draw the icon of the task panel item.
FreeBitmaps | This method is called to free the memory used by the group caption bitmaps.
GetCaptionGripperWidth | This method is called to get width of caption's gripper.
GetHighlightOffset | This method is called to retrieve the highlight offset of the text of an item.
Rectangle | This method is only used when drawing hot, pressed and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
Public Methods
Public Methods
Public Method | Description
DrawGroupCaption | This method is called to draw the caption of the group.
DrawGroupClient | This method is called to draw a single group of the control.
DrawGroupItem | This method is called to draw single item of control.
DrawGroupItemFrame | This member draws a rectangle around a group item when selected, pressed or highlighted.
DrawScrollButton | The member is called to draw a group scroll button.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
GetControlMargins | Call this member to retrieve the default margins used for all groups.
GetGroupColors |
GetGroupInnerMargins | Call this member to retrieve the inner margins of a group.
GetGroupOuterMargins | Call this member to retrieve the outer margins of a group.
GetGroupSpacing | Call this member to return the spacing used between groups.
GetItemFont | Call this member to retrieve the font used to display task panel item text.
GetItemIconPadding | Call this member to retrieve the padding around the image.
GetItemInnerMargins | Call this member to retrieve the inner margins of a group item.
GetItemOuterMargins | Call this member to retrieve the outer margins of a group item.
RefreshMetrics | This method is called to refresh the visual metrics of manager.
SetCaptionFontIndirect | Call this member to set the font used to display text in task panel group caption. Can use custom font or the standard caption font.
SetItemsFontIndirect | Call this member to set the font used to display task panel item text. Can use custom font or the standard item font.
SetTextFormat | Call this method to set format of drawn text for items and caption.


CXTPTaskPanelPaintManager::BlendColor Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::BlendColor Method

Call this member function to blend from one color to another color by the amount specified in nAlpha.

COLORREF BlendColor(
    COLORREF clrFrom,
    COLORREF clrTo,
    int nAlpha
);
Parameters

clrFrom
RGB Start color
clrTo
Blend to this RGB color.
nAlpha
The amount of transparency.

Returns

COLORREF containing blended color.

Remarks

This function takes a blended color intensity which is (clrFrom * nAlpha + clrTo * (255 - nAlpha)) / 255

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::CreateGripperBitmaps Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::CreateGripperBitmaps Method

This method loads the group caption expand button bitmaps for the xtpTaskPanelThemeNativeWinXPPlain and xtpTaskPanelThemeNativeWinXP themes.

void CreateGripperBitmaps();
Remarks

If the current operating system is Windows Xp and the current theme is xtpSystemThemeBlue, xtpSystemThemeOlive, or xtpSystemThemeSilver then the gripper bitmap is loaded from the operating system. For all other OS and themes, CreateGripperIcon is used to create an emulated version of the Windows Xp gripper.

See Also

CreateGripperIcon

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::CreateGripperIcon Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::CreateGripperIcon Method

This method creates expand button icons for the xtpTaskPanelThemeNativeWinXPPlain and xtpTaskPanelThemeNativeWinXP themes when the current operation system used is not Windows Xp or if the OS is WinXP and Classic themes are used.

void CreateGripperIcon(
    HICON& hIcon,
    UINT nIDResource,
    COLORREF clrGripperBack
);
Parameters

hIcon
Specifies icon handle.
nIDResource
Specifies icon resource ID.
clrGripperBack
Background color of the expand button.

See Also

CreateGripperBitmaps

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawCaptionGripper Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawCaptionGripper Method

This method is called to draw gripper of the caption.

virtual CRect DrawCaptionGripper(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be drawn.

Returns

Rectangle of caption after draw.

Remarks

The caption gripper is the button that allows the group to be expanded and collapsed.

See Also

DrawCaptionGripperBitmap, DrawCaptionGripperSigns

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawCaptionGripperBitmap Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawCaptionGripperBitmap Method

This method is called to draw the group caption expand button bitmap.

CRect DrawCaptionGripperBitmap(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    BOOL bExpanded,
    BOOL bHot,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Pointer to group.
bExpanded
TRUE to draw the bitmap when group is expanded.
bHot
TRUE to draw the bitmap when the group id "hot". This is when the mouse pointer is positioned over the gripper.
rc
CRect object specifying size of area.

Returns

Bounding rectangle of group caption - gripper bitmap width.

See Also

CXTPTaskPanelGroup::SetSpecialGroup, CXTPTaskPanelGroup::IsSpecialGroup

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawCaptionGripperSigns Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawCaptionGripperSigns Method

This method is used to draw the ">>" and "<<" of the group caption expand button for the xtpTaskPanelThemeOffice2000 theme.

void DrawCaptionGripperSigns(
    CDC* pDC,
    CPoint pt,
    COLORREF clr,
    BOOL bExpanded
);
Parameters

pDC
Pointer to a valid device context
pt
CPoint object specifies x y coordinates.
clr
COLORREF specifies RGB color value.
bExpanded
TRUE to draw the expanded gripper ">>", FLASE to draw the retracted gripper "<<".

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawDragArrow Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawDragArrow Method

This method is called to draw the "drag arrow" while dragging an item.

virtual void DrawDragArrow(
    CDC* pDC,
    CXTPTaskPanelItem* pItem,
    CRect rc,
    BOOL bAfter = FALSE
);
Parameters

pDC
Pointer to a valid device context.
pItem
Pointer to the group item that the drag arrow (line) is drawn above if dragging up, and the group item that the drag arrow (line) is drawn below is dragging down.
rc
CRect object specifying size of area.
bAfter
TRUE to draw the drag arrow at the bottom of pItem, this is done when dragging in the down direction. FALSE to draw the drag arrow before pItem.

Remarks

The "drag arrow" is the line that is placed above or below a group item when dragging an item. The drag arrow is draw for all themes except xtpTaskPanelThemeToolbox.

See Also

CXTPTaskPanelToolboxTheme::DrawGroupCaption

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawFocusRect Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawFocusRect Method

This method is called to draw rectangle around focused item.

virtual void DrawFocusRect(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
rc
Bounding rectangle.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupCaption Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupCaption Method

This method is called to draw the caption of the group.

virtual int DrawGroupCaption(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
bDraw
TRUE to draw; FALSE to retrieve height of caption.

Returns

Height of the caption.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupClient Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupClient Method

This method is called to draw a single group of the control.

virtual void DrawGroupClient(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupClientFace Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupClientFace Method

This method is called to draw the face of the group.

virtual void DrawGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupClientItems Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupClientItems Method

This method is called to draw the items of the group.

virtual void DrawGroupClientItems(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object.
rc
Rectangle of group to be draw.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupItem Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupItem Method

This method is called to draw single item of control.

virtual CRect DrawGroupItem(
    CDC* pDC,
    CXTPTaskPanelGroupItem* pItem,
    CRect rc,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context.
pItem
Points to a CXTPTaskPanelGroupItem object.
rc
Rectangle of item to draw.
bDraw
TRUE to draw; FALSE to retrieve height of item

Returns

Height of item.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupItemFrame Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupItemFrame Method

This member draws a rectangle around a group item when selected, pressed or highlighted.

virtual void DrawGroupItemFrame(
    CDC* pDC,
    CXTPTaskPanelGroupItem* pItem,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pItem
Points to a CXTPTaskPanelGroupItem object.
rc
Bounding rectangle group to draw.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupItemImage Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupItemImage Method

This member is called to a group item when the layout is xtpTaskItemLayoutImages.

CRect DrawGroupItemImage(
    CDC* pDC,
    CXTPTaskPanelGroupItem* pItem,
    CRect rc,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context.
pItem
Points to a CXTPTaskPanelGroupItem object.
rc
Rectangle of group item to draw.
bDraw
TRUE to draw the item, FALSE to retrieve the item's bounding rectangle (no drawing is done).

Returns

Returns 0 if bDraw is TRUE and drawing is successful.

Returns the item's rectangle including the inner margins of the item. So the left and right margins of the item will be the left and right margins of the item + the left and right inner margins of the item.

DrawGroupItem calls this method to draw items with a layout if type xtpTaskItemLayoutImages.

See Also

DrawGroupItem, DrawGroupItemImageWithText, DrawGroupItemImageWithTextBelow, GetItemInnerMargins

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupItemImageWithText Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupItemImageWithText Method

This member is called to a group item when the layout is xtpTaskItemLayoutImagesWithText.

CRect DrawGroupItemImageWithText(
    CDC* pDC,
    CXTPTaskPanelGroupItem* pItem,
    CRect rc,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context.
pItem
Points to a CXTPTaskPanelGroupItem object.
rc
Rectangle of group item to draw.
bDraw
TRUE to draw the item, FALSE to retrieve the item's bounding rectangle (only the text is drawn).

Returns

Returns 0 if bDraw is TRUE and drawing is successful.

Returns the item's rectangle including the inner margins of the item. So the left and right margins of the item will be the left and right margins of the item + the left and right inner margins of the item.

DrawGroupItem calls this method to draw items with a layout if type xtpTaskItemLayoutImagesWithText.

See Also

DrawGroupItem, DrawGroupItemImageWithTextBelow, DrawGroupItemImage, GetItemInnerMargins

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawGroupItemImageWithTextBelow Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawGroupItemImageWithTextBelow Method

This member is called to a group item when the layout is xtpTaskItemLayoutImagesWithTextBelow.

CRect DrawGroupItemImageWithTextBelow(
    CDC* pDC,
    CXTPTaskPanelGroupItem* pItem,
    CRect rc,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context.
pItem
Points to a CXTPTaskPanelGroupItem object.
rc
Rectangle of group item to draw.
bDraw
TRUE to draw the item, FALSE to retrieve the item's bounding rectangle (only the text is drawn).

Returns

Returns 0 if bDraw is TRUE and drawing is successful.

Returns the item's rectangle including the inner margins of the item. So the left and right margins of the item will be the left and right margins of the item + the left and right inner margins of the item.

DrawGroupItem calls this method to draw items with a layout if type xtpTaskItemLayoutImagesWithTextBelow.

See Also

DrawGroupItem, DrawGroupItemImageWithText, DrawGroupItemImage, GetItemInnerMargins

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawItemCaption Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawItemCaption Method

This method is called to draw text caption of the task panel item.

virtual void DrawItemCaption(
    CDC* pDC,
    CXTPTaskPanelItem* pItem,
    CRect rcText,
    UINT nFormat
);
Parameters

pDC
Pointer to a valid device context
pItem
Points to a CXTPTaskPanelItem object.
rcText
Rectangle of item to draw.
nFormat
[in] Specifies the method of formatting the text.

Remarks

The nFormat parameter can be one or more of the following values:

  • DT_BOTTOM Justifies the text to the bottom of the rectangle. This value is used only with the DT_SINGLELINE value.
  • DT_CALCRECT Determines the width and height of the rectangle.
  • DT_CENTER Centers text horizontally in the rectangle.
  • DT_EDITCONTROL Duplicates the text-displaying characteristics of a multiline edit control. Specifically, the average character width is calculated in the same manner as for an edit control, and the function does not display a partially visible last line.
  • DT_END_ELLIPSIS For displayed text, if the end of a string does not fit in the rectangle, it is truncated and ellipses are added. If a word that is not at the end of the string goes beyond the limits of the rectangle, it is truncated without ellipses. The string is not modified unless the DT_MODIFYSTRING flag is specified.
  • DT_EXPANDTABS Expands tab characters. The default number of characters per tab is eight. The DT_WORD_ELLIPSIS, DT_PATH_ELLIPSIS, and DT_END_ELLIPSIS values cannot be used with the DT_EXPANDTABS value.
  • DT_EXTERNALLEADING Includes the font external leading in line height. Normally, external leading is not included in the height of a line of text.
  • DT_HIDEPREFIX Ignores the ampersand (&) prefix character in the text. The letter that follows will not be underlined, but other mnemonic-prefix characters are still processed.
  • DT_INTERNAL Uses the system font to calculate text metrics.
  • DT_LEFT Aligns text to the left.
  • DT_MODIFYSTRING Modifies the specified string to match the displayed text. This value has no effect unless DT_END_ELLIPSIS or DT_PATH_ELLIPSIS is specified.
  • DT_NOCLIP Draws without clipping.
  • DT_NOFULLWIDTHCHARBREAK Prevents a line break at a DBCS (double-wide character string), so that the line breaking rule is equivalent to SBCS strings. For example, this can be used in Korean windows, for more readability of icon labels. This value has no effect unless DT_WORDBREAK is specified.
  • DT_NOPREFIX Turns off processing of prefix characters.
  • DT_PATH_ELLIPSIS For displayed text, replaces characters in the middle of the string with ellipses so that the result fits in the specified rectangle. If the string contains backslash () characters, DT_PATH_ELLIPSIS preserves as much as possible of the text after the last backslash. The string is not modified unless the DT_MODIFYSTRING flag is specified.
  • DT_PREFIXONLY Draws only an underline at the position of the character following the ampersand (&) prefix character. Does not draw any other characters in the string.
  • DT_RIGHT Aligns text to the right.
  • DT_RTLREADING Layout in right-to-left reading order for bi-directional text when the font selected into the hdc is a Hebrew or Arabic font. The default reading order for all text is left-to-right.
  • DT_SINGLELINE Displays text on a single line only. Carriage returns and line feeds do not break the line.
  • DT_TABSTOP Sets tab stops. Bits 158 (high-order byte of the low-order word) of the uFormat parameter specify the number of characters for each tab. The default number of characters per tab is eight. The DT_CALCRECT, DT_EXTERNALLEADING, DT_INTERNAL, DT_NOCLIP, and DT_NOPREFIX values cannot be used with the DT_TABSTOP value.
  • DT_TOP Justifies the text to the top of the rectangle.
  • DT_VCENTER Centers text vertically. This value is used only with the DT_SINGLELINE value.
  • DT_WORDBREAK Breaks words. Lines are automatically broken between words if a word would extend past the edge of the rectangle specified by the lpRect parameter. A carriage return-line feed sequence also breaks the line. If this is not specified, output is on one line.
  • DT_WORD_ELLIPSIS Truncates any word that does not fit in the rectangle and adds ellipses.

DrawGroupCaption uses this method to draw the group caption with nFormat = DT_SINGLELINE | DT_LEFT | DT_END_ELLIPSIS | DT_VCENTER | DT_NOPREFIX

DrawGroupItemImageWithText and DrawGroupItemImageWithTextBelow use DrawItemCaption to draw the group item caption.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawItemImage Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawItemImage Method

This method is called to draw the icon of the task panel item.

virtual void DrawItemImage(
    CDC* pDC,
    CXTPTaskPanelItem* pItem,
    CPoint ptIcon,
    CXTPImageManagerIcon* pImage,
    CSize szIcon
);
Parameters

pDC
Pointer to a valid device context
pItem
Points to the item to draw the image on.
ptIcon
Top left corner to start drawing icon.
pImage
Pointer to the image to draw.
szIcon
Size of the image to draw.

Remarks

DrawItemImage is called by DrawGroupItemImageWithText, DrawGroupItemImageWithTextBelow, and DrawGroupCaption to draw the image for the item.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::DrawScrollButton Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::DrawScrollButton Method

The member is called to draw a group scroll button.

virtual void DrawScrollButton(
    CDC* pDC,
    CXTPTaskPanelScrollButton* pScrollButton
);
Parameters

pDC
Pointer to a valid device context
pScrollButton
Pointer to the scroll button to draw.

Remarks

DrawScrollButton only draws group scroll buttons, it does not draw group caption scroll buttons. DrawCaptionGripper draws the scroll button for the group caption.

See Also

DrawCaptionGripper

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::FillGroupClientFace Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::FillGroupClientFace Method

Fills group rectangle

virtual void FillGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

See Also

DrawGroupClientFace

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::FillTaskPanel Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::FillTaskPanel Method

This method is called to fill background of task panel control.

virtual void FillTaskPanel(
    CDC* pDC,
    CXTPTaskPanel* pTaskPanel
);
Parameters

pDC
Pointer to a valid device context
pTaskPanel
Points to a CXTPTaskPanel object

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::FreeBitmaps Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::FreeBitmaps Method

This method is called to free the memory used by the group caption bitmaps.

void FreeBitmaps();
Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetCaptionGripperWidth Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetCaptionGripperWidth Method

This method is called to get width of caption's gripper.

virtual int GetCaptionGripperWidth(
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be drawn.

Returns

Caption's gripper width.

Remarks

The caption gripper is the button that allows the group to be expanded and collapsed.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetControlMargins Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetControlMargins Method

Call this member to retrieve the default margins used for all groups.

virtual CRect GetControlMargins(
    const CXTPTaskPanel* pPanel
);
Parameters

pPanel
Pointer to a CXTPTaskPanel control

Returns

Default margins for all groups.

See Also

GetItemOuterMargins, GetItemInnerMargins, GetGroupOuterMargins, GetGroupInnerMargins

Group

CXTPTaskPanelPaintManager Methods


GetGroupColors Method

CXTPTaskPanelPaintManager Methods
GetGroupColors Method
Overload List
Methods
Method | Description
CXTPTaskPanelPaintManager::GetGroupColors (BOOL) | Retrieves group colors.
CXTPTaskPanelPaintManager::GetGroupColors (CXTPTaskPanelGroup*) | Retrieves group colors.
Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetGroupColors Method (BOOL)

GetGroupColors Method, CXTPTaskPanelPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetGroupColors Method (BOOL)

Retrieves group colors.

XTP_TASKPANEL_GROUPCOLORS* GetGroupColors(
    BOOL bSpecial
);
virtual XTP_TASKPANEL_GROUPCOLORS* GetGroupColors(
    CXTPTaskPanelGroup* pGroup
);
Parameters

bSpecial
TRUE if the special group color set should be returned, FASLE if the normal group color set should be returned.
pGroup
Pointer to a group to retrieve colors.

Returns

The color set stored in m_groupSpecial if bSpecial is TRUE else the m_groupNormal color set is returned.

Remarks

If a group is special, it will appear in a different color than the other groups. Groups marked as special will be displayed differently than normal groups drawing the users attention to that particular group. This is an excellent way to show the user the "default" or important items.

See Also

CXTPTaskPanelGroup::IsSpecialGroup, CXTPTaskPanelGroup::SetSpecialGroup

Body Source
XTP_TASKPANEL_GROUPCOLORS* CXTPTaskPanelPaintManager::GetGroupColors(BOOL bSpecial) {
    return bSpecial ? &m_groupSpecial : &m_groupNormal;
}
Group

GetGroupColors Method


CXTPTaskPanelPaintManager::GetGroupInnerMargins Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetGroupInnerMargins Method

Call this member to retrieve the inner margins of a group.

virtual CRect GetGroupInnerMargins(
    const CXTPTaskPanelGroup* pGroup
);
Parameters

pGroup
Points to a CXTPTaskPanelGroup object.

Returns

Inner margins of the specified group.

See Also

GetItemOuterMargins, GetItemInnerMargins, GetGroupOuterMargins, GetControlMargins

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetGroupOuterMargins Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetGroupOuterMargins Method

Call this member to retrieve the outer margins of a group.

virtual CRect GetGroupOuterMargins(
    const CXTPTaskPanelGroup* pGroup
);
Parameters

pGroup
Points to a CXTPTaskPanelGroup object.

Returns

Outer margins of the specified group.

See Also

GetItemOuterMargins, GetItemInnerMargins, GetGroupInnerMargins, GetControlMargins

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetGroupSpacing Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetGroupSpacing Method

Call this member to return the spacing used between groups.

virtual int GetGroupSpacing(
    const CXTPTaskPanel* pPanel
);
Parameters

pPanel
Pointer to a task panel control.

Returns

The amount of spacing placed between task panel groups.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetHighlightOffset Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetHighlightOffset Method

This method is called to retrieve the highlight offset of the text of an item.

virtual CPoint GetHighlightOffset(
    CXTPTaskPanelGroupItem* pItem
);
Parameters

pItem
Points to a CXTPTaskPanelGroupItem object.

Returns

If the item is selected, offset is (1, 1), else offset is (0, 0).

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetItemFont Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetItemFont Method

Call this member to retrieve the font used to display task panel item text.

virtual CFont* GetItemFont(
    CXTPTaskPanelItem* pItem
);
Parameters

pItem
Pointer to a valid task panel item.

Returns

Font used to display task panel item text.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetItemIconPadding Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetItemIconPadding Method

Call this member to retrieve the padding around the image.

virtual CRect GetItemIconPadding(
    const CXTPTaskPanelItem* pItem
);
Parameters

pItem
Points to a CXTPTaskPanelItem object.

Returns

padding around the image of the specified group.

See Also

GetItemOuterMargins, GetItemInnerMargins, GetGroupInnerMargins, GetControlMargins

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetItemInnerMargins Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetItemInnerMargins Method

Call this member to retrieve the inner margins of a group item.

virtual CRect GetItemInnerMargins(
    const CXTPTaskPanelGroupItem* pItem
);
Parameters

pItem
Points to a CXTPTaskPanelGroupItem object.

Returns

Inner margins of the specified group item.

See Also

GetItemOuterMargins, GetGroupOuterMargins, GetGroupInnerMargins, GetControlMargins

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::GetItemOuterMargins Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::GetItemOuterMargins Method

Call this member to retrieve the outer margins of a group item.

virtual CRect GetItemOuterMargins(
    const CXTPTaskPanelGroupItem* pItem
);
Parameters

pItem
Points to a CXTPTaskPanelGroupItem object.

Returns

Outer margins of the specified group item.

See Also

GetItemInnerMargins, GetGroupOuterMargins, GetGroupInnerMargins, GetControlMargins

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::Rectangle Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::Rectangle Method

This method is only used when drawing hot, pressed and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.

void Rectangle(
    CDC* pDC,
    CRect rc,
    COLORREF clrPen,
    COLORREF clrBrush
);
Parameters

pDC
Pointer to a valid device context
rc
CRect object specifying size of area.
clrPen
COLORREF specifying pen RGB color value.
clrBrush
COLORREF specifying brush RGB color value.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::RefreshMetrics Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::RefreshMetrics Method

This method is called to refresh the visual metrics of manager.

virtual void RefreshMetrics();
Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::SetCaptionFontIndirect Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::SetCaptionFontIndirect Method

Call this member to set the font used to display text in task panel group caption. Can use custom font or the standard caption font.

void SetCaptionFontIndirect(
    LOGFONT* pLogFont,
    BOOL bUseStandardCaptionFont = FALSE
);
Parameters

pLogFont
Font to use for task panel group caption text.
bUseStandardCaptionFont
TRUE to use standard caption font. FALSE to use font specified in pLogFont.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::SetItemsFontIndirect Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::SetItemsFontIndirect Method

Call this member to set the font used to display task panel item text. Can use custom font or the standard item font.

void SetItemsFontIndirect(
    LOGFONT* pLogFont,
    BOOL bUseStandardItemsFont = FALSE
);
Parameters

pLogFont
Font used to display task panel item text.
bUseStandardItemsFont
TRUE to use standard item font, FALSE to use font specified in pLogFont.

Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager::SetTextFormat Method

CXTPTaskPanelPaintManager Methods, CXTPTaskPanelPaintManager Class, Body Source, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::SetTextFormat Method

Call this method to set format of drawn text for items and caption.

void SetTextFormat(
    int nTextFormat,
    BOOL bCaption = FALSE
);
Parameters

nTextFormat
New format that will be used for CDC::DrawText calls
bCaption
TRUE to apply it for caption; FALSE for items.

Example
m_wndTaskPanel.GetPaintManager()->SetTextFormat(DT_SINGLELINE | DT_END_ELLIPSIS | DT_VCENTER | DT_NOPREFIX);
Body Source
void CXTPTaskPanelPaintManager::SetTextFormat(int nTextFormat, BOOL bCaption /*= FALSE*/) {
    if (bCaption) m_nCaptionTextFormat = nTextFormat; else m_nItemTextFormat = nTextFormat;
}
Group

CXTPTaskPanelPaintManager Methods


CXTPTaskPanelPaintManager Constructors

CXTPTaskPanelPaintManager Class, Legend, Public Methods
CXTPTaskPanelPaintManager Constructors
Class

CXTPTaskPanelPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelPaintManager | Constructs a CXTPTaskPanelPaintManager object


CXTPTaskPanelPaintManager::CXTPTaskPanelPaintManager Constructor

CXTPTaskPanelPaintManager Constructors, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::CXTPTaskPanelPaintManager Constructor

Constructs a CXTPTaskPanelPaintManager object

CXTPTaskPanelPaintManager();
Group

CXTPTaskPanelPaintManager Constructors


CXTPTaskPanelPaintManager Destructors

CXTPTaskPanelPaintManager Class, Legend, Public Methods
CXTPTaskPanelPaintManager Destructors
Class

CXTPTaskPanelPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPTaskPanelPaintManager | Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation


CXTPTaskPanelPaintManager::~CXTPTaskPanelPaintManager Destructor

CXTPTaskPanelPaintManager Destructors, CXTPTaskPanelPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManager::~CXTPTaskPanelPaintManager Destructor

Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation

virtual ~CXTPTaskPanelPaintManager();
Group

CXTPTaskPanelPaintManager Destructors


CXTPTaskPanelPaintManagerPlain Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelPaintManagerPlain Data Members, CXTPTaskPanelPaintManagerPlain Methods, CXTPTaskPanelPaintManagerPlain Constructors, CXTPTaskPanelPaintManagerPlain Constructors, CXTPTaskPanelPaintManagerPlain Data Members, CXTPTaskPanelPaintManagerPlain Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain Class

Base class theme that all other themes are derived from. Use this class when creating a custom theme.

Class Hierarchy

class CXTPTaskPanelPaintManagerPlain : public CXTPTaskPanelPaintManager;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme, CXTPTaskPanel::SetCustomTheme

Group

Classes

Legend
Data Member
protected
Method
CXTPTaskPanelPaintManagerPlain Constructors
CXTPTaskPanelPaintManagerPlain Constructors | Description
CXTPTaskPanelPaintManagerPlain | Constructs a CXTPTaskPanelPaintManagerPlain object.
CXTPTaskPanelPaintManagerPlain Data Members
CXTPTaskPanelPaintManagerPlain Data Members | Description
m_bOfficeCaption | FALSE to draw a rounded rectangle around caption.
m_bRoundedFrame | TRUE to draw a rounded frame around all of the groups in the task panel.
CXTPTaskPanelPaintManagerPlain Methods
CXTPTaskPanelPaintManagerPlain Methods | Description
DrawGroupCaption | This method is called to draw the caption of the group.
DrawGroupClientFace | This method is called to draw the face of the group.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelPaintManagerPlain Data Members

CXTPTaskPanelPaintManagerPlain Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain Data Members
Class

CXTPTaskPanelPaintManagerPlain Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bOfficeCaption | FALSE to draw a rounded rectangle around caption.
m_bRoundedFrame | TRUE to draw a rounded frame around all of the groups in the task panel.


CXTPTaskPanelPaintManagerPlain::m_bOfficeCaption Data Member

CXTPTaskPanelPaintManagerPlain Data Members, CXTPTaskPanelPaintManagerPlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain::m_bOfficeCaption Data Member

FALSE to draw a rounded rectangle around caption.

BOOL m_bOfficeCaption;
Group

CXTPTaskPanelPaintManagerPlain Data Members


CXTPTaskPanelPaintManagerPlain::m_bRoundedFrame Data Member

CXTPTaskPanelPaintManagerPlain Data Members, CXTPTaskPanelPaintManagerPlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain::m_bRoundedFrame Data Member

TRUE to draw a rounded frame around all of the groups in the task panel.

BOOL m_bRoundedFrame;
Group

CXTPTaskPanelPaintManagerPlain Data Members


CXTPTaskPanelPaintManagerPlain Methods

CXTPTaskPanelPaintManagerPlain Class, Legend, Public Methods
CXTPTaskPanelPaintManagerPlain Methods
Class

CXTPTaskPanelPaintManagerPlain Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawGroupCaption | This method is called to draw the caption of the group.
DrawGroupClientFace | This method is called to draw the face of the group.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelPaintManagerPlain::DrawGroupCaption Method

CXTPTaskPanelPaintManagerPlain Methods, CXTPTaskPanelPaintManagerPlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain::DrawGroupCaption Method

This method is called to draw the caption of the group.

int DrawGroupCaption(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
bDraw
TRUE to draw; FALSE to retrieve height of caption.

Returns

Height of the caption.

Group

CXTPTaskPanelPaintManagerPlain Methods


CXTPTaskPanelPaintManagerPlain::DrawGroupClientFace Method

CXTPTaskPanelPaintManagerPlain Methods, CXTPTaskPanelPaintManagerPlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain::DrawGroupClientFace Method

This method is called to draw the face of the group.

void DrawGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

Group

CXTPTaskPanelPaintManagerPlain Methods


CXTPTaskPanelPaintManagerPlain::FillGroupClientFace Method

CXTPTaskPanelPaintManagerPlain Methods, CXTPTaskPanelPaintManagerPlain Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain::FillGroupClientFace Method

Fills group rectangle

void FillGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

See Also

DrawGroupClientFace

Group

CXTPTaskPanelPaintManagerPlain Methods


CXTPTaskPanelPaintManagerPlain::FillTaskPanel Method

CXTPTaskPanelPaintManagerPlain Methods, CXTPTaskPanelPaintManagerPlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain::FillTaskPanel Method

This method is called to fill background of task panel control.

void FillTaskPanel(
    CDC* pDC,
    CXTPTaskPanel* pTaskPanel
);
Parameters

pDC
Pointer to a valid device context
pTaskPanel
Points to a CXTPTaskPanel object

Group

CXTPTaskPanelPaintManagerPlain Methods


CXTPTaskPanelPaintManagerPlain::RefreshMetrics Method

CXTPTaskPanelPaintManagerPlain Methods, CXTPTaskPanelPaintManagerPlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelPaintManagerPlain Methods


CXTPTaskPanelPaintManagerPlain Constructors

CXTPTaskPanelPaintManagerPlain Class, Legend, Public Methods
CXTPTaskPanelPaintManagerPlain Constructors
Class

CXTPTaskPanelPaintManagerPlain Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelPaintManagerPlain | Constructs a CXTPTaskPanelPaintManagerPlain object.


CXTPTaskPanelPaintManagerPlain::CXTPTaskPanelPaintManagerPlain Constructor

CXTPTaskPanelPaintManagerPlain Constructors, CXTPTaskPanelPaintManagerPlain Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelPaintManagerPlain::CXTPTaskPanelPaintManagerPlain Constructor

Constructs a CXTPTaskPanelPaintManagerPlain object.

CXTPTaskPanelPaintManagerPlain();
Group

CXTPTaskPanelPaintManagerPlain Constructors


CXTPTaskPanelScrollButton Class

XTPTaskPanel.h, Classes, Legend, Members, Topics, CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Methods, CXTPTaskPanelScrollButton Constructors, CXTPTaskPanelScrollButton Constructors, CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton Class

CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button.

Class Hierarchy

class CXTPTaskPanelScrollButton;
File

XTPTaskPanel.h

Remarks

The task panel uses a scroll button in the group caption if the group is expandable to expand and retract the group.

The task panel also uses scroll buttons in task panel group objects when there are more items in the group than can be viewed. Only the necessary buttons are displayed. If the items in the group can not be scrolled anymore, then that button is removed. Scroll buttons are only visible when using the xtpTaskPanelBehaviourList and xtpTaskPanelBehaviourToolbox task panel behaviors. The group scroll buttons are stored in m_pScrollButton.

See Also

m_pScrollButton

Group

Classes

Legend
Data Member
Method
CXTPTaskPanelScrollButton Constructors
CXTPTaskPanelScrollButton Constructors | Description
CXTPTaskPanelScrollButton | Constructs a CXTPTaskPanelScrollButton object.
CXTPTaskPanelScrollButton Data Members
CXTPTaskPanelScrollButton Data Members | Description
bEnabled | TRUE if the scroll button is enabled, FALSE if disabled.
bHot | TRUE if scroll button is "hot", FALSE otherwise.
bPressed | TRUE if scroll button is currently pressed, FALSE otherwise.
bScrollUp | If TRUE, the button is the "scroll up" button, If FALSE, the button is a "scroll down" button.
pGroupCaption | Pointer to the group that uses this group caption scroll button.
pGroupScroll | Pointer to the group that uses this group item scroll button.
rcButton | Bounding rectangle of the scroll button.
CXTPTaskPanelScrollButton Methods
CXTPTaskPanelScrollButton Methods | Description
IsVisible | Call this member to determine if the scroll button is visible.


CXTPTaskPanelScrollButton Data Members

CXTPTaskPanelScrollButton Class, Legend, Public Data Members
CXTPTaskPanelScrollButton Data Members
Class

CXTPTaskPanelScrollButton Class

Legend
Data Member
Public Data Members
Public Data Member | Description
bEnabled | TRUE if the scroll button is enabled, FALSE if disabled.
bHot | TRUE if scroll button is "hot", FALSE otherwise.
bPressed | TRUE if scroll button is currently pressed, FALSE otherwise.
bScrollUp | If TRUE, the button is the "scroll up" button, If FALSE, the button is a "scroll down" button.
pGroupCaption | Pointer to the group that uses this group caption scroll button.
pGroupScroll | Pointer to the group that uses this group item scroll button.
rcButton | Bounding rectangle of the scroll button.


CXTPTaskPanelScrollButton::bEnabled Data Member

CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::bEnabled Data Member

TRUE if the scroll button is enabled, FALSE if disabled.

BOOL bEnabled;
Group

CXTPTaskPanelScrollButton Data Members


CXTPTaskPanelScrollButton::bHot Data Member

CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::bHot Data Member

TRUE if scroll button is "hot", FALSE otherwise.

BOOL bHot;
Group

CXTPTaskPanelScrollButton Data Members


CXTPTaskPanelScrollButton::bPressed Data Member

CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::bPressed Data Member

TRUE if scroll button is currently pressed, FALSE otherwise.

BOOL bPressed;
Group

CXTPTaskPanelScrollButton Data Members


CXTPTaskPanelScrollButton::bScrollUp Data Member

CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::bScrollUp Data Member

If TRUE, the button is the "scroll up" button, If FALSE, the button is a "scroll down" button.

BOOL bScrollUp;
Group

CXTPTaskPanelScrollButton Data Members


CXTPTaskPanelScrollButton::pGroupCaption Data Member

CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::pGroupCaption Data Member

Pointer to the group that uses this group caption scroll button.

CXTPTaskPanelGroup* pGroupCaption;
Group

CXTPTaskPanelScrollButton Data Members


CXTPTaskPanelScrollButton::pGroupScroll Data Member

CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::pGroupScroll Data Member

Pointer to the group that uses this group item scroll button.

CXTPTaskPanelGroup* pGroupScroll;
Group

CXTPTaskPanelScrollButton Data Members


CXTPTaskPanelScrollButton::rcButton Data Member

CXTPTaskPanelScrollButton Data Members, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::rcButton Data Member

Bounding rectangle of the scroll button.

CRect rcButton;
Group

CXTPTaskPanelScrollButton Data Members


CXTPTaskPanelScrollButton Methods

CXTPTaskPanelScrollButton Class, Legend, Public Methods
CXTPTaskPanelScrollButton Methods
Class

CXTPTaskPanelScrollButton Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
IsVisible | Call this member to determine if the scroll button is visible.


CXTPTaskPanelScrollButton::IsVisible Method

CXTPTaskPanelScrollButton Methods, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::IsVisible Method

Call this member to determine if the scroll button is visible.

BOOL IsVisible() const;
Returns

TRUE is the scroll button is visible, FALSE is the scroll button is not visible.

Group

CXTPTaskPanelScrollButton Methods


CXTPTaskPanelScrollButton Constructors

CXTPTaskPanelScrollButton Class, Legend, Public Methods
CXTPTaskPanelScrollButton Constructors
Class

CXTPTaskPanelScrollButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelScrollButton | Constructs a CXTPTaskPanelScrollButton object.


CXTPTaskPanelScrollButton::CXTPTaskPanelScrollButton Constructor

CXTPTaskPanelScrollButton Constructors, CXTPTaskPanelScrollButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelScrollButton::CXTPTaskPanelScrollButton Constructor

Constructs a CXTPTaskPanelScrollButton object.

CXTPTaskPanelScrollButton(
    BOOL bScrollUp
);
Parameters

bScrollUp
If TRUE, the button is the "scroll up" button, If FALSE, the button is a "scroll down" button.

Group

CXTPTaskPanelScrollButton Constructors


CXTPTaskPanelShortcutBarOffice2003Theme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelShortcutBarOffice2003Theme Methods, CXTPTaskPanelShortcutBarOffice2003Theme Constructors, CXTPTaskPanelShortcutBarOffice2003Theme Constructors, CXTPTaskPanelShortcutBarOffice2003Theme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme Class

CXTPTaskPanelShortcutBarOffice2003Theme is a CXTPTaskPanelListViewOffice2003Theme derived class used to enable an Office 2003 ShortcutBar style theme.

Class Hierarchy

class CXTPTaskPanelShortcutBarOffice2003Theme : public CXTPTaskPanelListViewOffice2003Theme;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
protected
CXTPTaskPanelShortcutBarOffice2003Theme Constructors
CXTPTaskPanelShortcutBarOffice2003Theme Constructors | Description
CXTPTaskPanelShortcutBarOffice2003Theme | Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.
CXTPTaskPanelShortcutBarOffice2003Theme Methods
CXTPTaskPanelShortcutBarOffice2003Theme Methods | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
DrawGroupClientFace | This method is called to draw the face of the group.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelShortcutBarOffice2003Theme Methods

CXTPTaskPanelShortcutBarOffice2003Theme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme Methods
Class

CXTPTaskPanelShortcutBarOffice2003Theme Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
DrawGroupClientFace | This method is called to draw the face of the group.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelShortcutBarOffice2003Theme::DrawGroupCaptionBackground Method

CXTPTaskPanelShortcutBarOffice2003Theme Methods, CXTPTaskPanelShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme::DrawGroupCaptionBackground Method

This member is called to draw the background of the group caption.

CRect DrawGroupCaptionBackground(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
pGroup
Fill group caption of this group.
rc
Bounding rectangle of the group caption.

Returns

Bounding rectangle of text within group caption.

Remarks

This member will draw the normal, hot, and pressed background for the group caption. It will then fill the group caption with the Office 2003 color gradient.

This task panel theme looks similar to the ShortcutBar Office 2003 theme.

Group

CXTPTaskPanelShortcutBarOffice2003Theme Methods


CXTPTaskPanelShortcutBarOffice2003Theme::DrawGroupClientFace Method

CXTPTaskPanelShortcutBarOffice2003Theme Methods, CXTPTaskPanelShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme::DrawGroupClientFace Method

This method is called to draw the face of the group.

void DrawGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

Group

CXTPTaskPanelShortcutBarOffice2003Theme Methods


CXTPTaskPanelShortcutBarOffice2003Theme::FillGroupClientFace Method

CXTPTaskPanelShortcutBarOffice2003Theme Methods, CXTPTaskPanelShortcutBarOffice2003Theme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme::FillGroupClientFace Method

Fills group rectangle

void FillGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

See Also

DrawGroupClientFace

Group

CXTPTaskPanelShortcutBarOffice2003Theme Methods


CXTPTaskPanelShortcutBarOffice2003Theme::FillTaskPanel Method

CXTPTaskPanelShortcutBarOffice2003Theme Methods, CXTPTaskPanelShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme::FillTaskPanel Method

This method is called to fill background of task panel control.

void FillTaskPanel(
    CDC* pDC,
    CXTPTaskPanel* pTaskPanel
);
Parameters

pDC
Pointer to a valid device context
pTaskPanel
Points to a CXTPTaskPanel object

Group

CXTPTaskPanelShortcutBarOffice2003Theme Methods


CXTPTaskPanelShortcutBarOffice2003Theme::RefreshMetrics Method

CXTPTaskPanelShortcutBarOffice2003Theme Methods, CXTPTaskPanelShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelShortcutBarOffice2003Theme Methods


CXTPTaskPanelShortcutBarOffice2003Theme Constructors

CXTPTaskPanelShortcutBarOffice2003Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme Constructors
Class

CXTPTaskPanelShortcutBarOffice2003Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelShortcutBarOffice2003Theme | Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.


CXTPTaskPanelShortcutBarOffice2003Theme::CXTPTaskPanelShortcutBarOffice2003Theme Constructor

CXTPTaskPanelShortcutBarOffice2003Theme Constructors, CXTPTaskPanelShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2003Theme::CXTPTaskPanelShortcutBarOffice2003Theme Constructor

Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.

CXTPTaskPanelShortcutBarOffice2003Theme();
Group

CXTPTaskPanelShortcutBarOffice2003Theme Constructors


CXTPTaskPanelShortcutBarOffice2007Theme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelShortcutBarOffice2007Theme Methods, CXTPTaskPanelShortcutBarOffice2007Theme Constructors, CXTPTaskPanelShortcutBarOffice2007Theme Constructors, CXTPTaskPanelShortcutBarOffice2007Theme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme Class

CXTPTaskPanelShortcutBarOffice2007Theme is a CXTPTaskPanelShortcutBarOffice2003Theme derived class used to enable an Office 2007 ShortcutBar style theme.

Class Hierarchy

class CXTPTaskPanelShortcutBarOffice2007Theme : public CXTPTaskPanelShortcutBarOffice2003Theme;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
protected
CXTPTaskPanelShortcutBarOffice2007Theme Constructors
CXTPTaskPanelShortcutBarOffice2007Theme Constructors | Description
CXTPTaskPanelShortcutBarOffice2007Theme | Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.
CXTPTaskPanelShortcutBarOffice2007Theme Methods
CXTPTaskPanelShortcutBarOffice2007Theme Methods | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
DrawGroupClientFace | This method is called to draw the face of the group.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelShortcutBarOffice2007Theme Methods

CXTPTaskPanelShortcutBarOffice2007Theme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme Methods
Class

CXTPTaskPanelShortcutBarOffice2007Theme Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
DrawGroupClientFace | This method is called to draw the face of the group.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelShortcutBarOffice2007Theme::DrawGroupCaptionBackground Method

CXTPTaskPanelShortcutBarOffice2007Theme Methods, CXTPTaskPanelShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme::DrawGroupCaptionBackground Method

This member is called to draw the background of the group caption.

CRect DrawGroupCaptionBackground(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
pGroup
Fill group caption of this group.
rc
Bounding rectangle of the group caption.

Returns

Bounding rectangle of text within group caption.

Remarks

This member will draw the normal, hot, and pressed background for the group caption. It will then fill the group caption with the Office 2003 color gradient.

This task panel theme looks similar to the ShortcutBar Office 2003 theme.

Group

CXTPTaskPanelShortcutBarOffice2007Theme Methods


CXTPTaskPanelShortcutBarOffice2007Theme::DrawGroupClientFace Method

CXTPTaskPanelShortcutBarOffice2007Theme Methods, CXTPTaskPanelShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme::DrawGroupClientFace Method

This method is called to draw the face of the group.

void DrawGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

Group

CXTPTaskPanelShortcutBarOffice2007Theme Methods


CXTPTaskPanelShortcutBarOffice2007Theme::FillGroupClientFace Method

CXTPTaskPanelShortcutBarOffice2007Theme Methods, CXTPTaskPanelShortcutBarOffice2007Theme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme::FillGroupClientFace Method

Fills group rectangle

void FillGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

See Also

DrawGroupClientFace

Group

CXTPTaskPanelShortcutBarOffice2007Theme Methods


CXTPTaskPanelShortcutBarOffice2007Theme::FillTaskPanel Method

CXTPTaskPanelShortcutBarOffice2007Theme Methods, CXTPTaskPanelShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme::FillTaskPanel Method

This method is called to fill background of task panel control.

void FillTaskPanel(
    CDC* pDC,
    CXTPTaskPanel* pTaskPanel
);
Parameters

pDC
Pointer to a valid device context
pTaskPanel
Points to a CXTPTaskPanel object

Group

CXTPTaskPanelShortcutBarOffice2007Theme Methods


CXTPTaskPanelShortcutBarOffice2007Theme::RefreshMetrics Method

CXTPTaskPanelShortcutBarOffice2007Theme Methods, CXTPTaskPanelShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelShortcutBarOffice2007Theme Methods


CXTPTaskPanelShortcutBarOffice2007Theme Constructors

CXTPTaskPanelShortcutBarOffice2007Theme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme Constructors
Class

CXTPTaskPanelShortcutBarOffice2007Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelShortcutBarOffice2007Theme | Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.


CXTPTaskPanelShortcutBarOffice2007Theme::CXTPTaskPanelShortcutBarOffice2007Theme Constructor

CXTPTaskPanelShortcutBarOffice2007Theme Constructors, CXTPTaskPanelShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelShortcutBarOffice2007Theme::CXTPTaskPanelShortcutBarOffice2007Theme Constructor

Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.

CXTPTaskPanelShortcutBarOffice2007Theme();
Group

CXTPTaskPanelShortcutBarOffice2007Theme Constructors


CXTPTaskPanelToolboxTheme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelToolboxTheme Methods, CXTPTaskPanelToolboxTheme Constructors, CXTPTaskPanelToolboxTheme Constructors, CXTPTaskPanelToolboxTheme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxTheme Class

The CXTPTaskPanelToolboxTheme class is used to enable a Toolbox style theme.

Class Hierarchy

class CXTPTaskPanelToolboxTheme : public CXTPTaskPanelPaintManagerPlain;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
protected
virtual
CXTPTaskPanelToolboxTheme Constructors
CXTPTaskPanelToolboxTheme Constructors | Description
CXTPTaskPanelToolboxTheme | Constructs a CXTPTaskPanelToolboxTheme object.
CXTPTaskPanelToolboxTheme Methods
CXTPTaskPanelToolboxTheme Methods | Description
DrawGroupCaption | This method is called to draw the caption of the group.
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelToolboxTheme Methods

CXTPTaskPanelToolboxTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxTheme Methods
Class

CXTPTaskPanelToolboxTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
Public Methods
Public Methods
Public Method | Description
DrawGroupCaption | This method is called to draw the caption of the group.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelToolboxTheme::DrawGroupCaption Method

CXTPTaskPanelToolboxTheme Methods, CXTPTaskPanelToolboxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxTheme::DrawGroupCaption Method

This method is called to draw the caption of the group.

int DrawGroupCaption(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    BOOL bDraw
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
bDraw
TRUE to draw; FALSE to retrieve height of caption.

Returns

Height of the caption.

Group

CXTPTaskPanelToolboxTheme Methods


CXTPTaskPanelToolboxTheme::DrawGroupCaptionBackground Method

CXTPTaskPanelToolboxTheme Methods, CXTPTaskPanelToolboxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxTheme::DrawGroupCaptionBackground Method

This member is called to draw the background of the group caption.

virtual CRect DrawGroupCaptionBackground(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
pGroup
Fill group caption of this group.
rc
Bounding rectangle of the group caption.

Returns

Bounding rectangle of text within group caption.

Remarks

This member will draw the normal, hot, and pressed background for the group caption.

Group

CXTPTaskPanelToolboxTheme Methods


CXTPTaskPanelToolboxTheme::RefreshMetrics Method

CXTPTaskPanelToolboxTheme Methods, CXTPTaskPanelToolboxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelToolboxTheme Methods


CXTPTaskPanelToolboxTheme Constructors

CXTPTaskPanelToolboxTheme Class, Legend, Public Methods
CXTPTaskPanelToolboxTheme Constructors
Class

CXTPTaskPanelToolboxTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelToolboxTheme | Constructs a CXTPTaskPanelToolboxTheme object.


CXTPTaskPanelToolboxTheme::CXTPTaskPanelToolboxTheme Constructor

CXTPTaskPanelToolboxTheme Constructors, CXTPTaskPanelToolboxTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxTheme::CXTPTaskPanelToolboxTheme Constructor

Constructs a CXTPTaskPanelToolboxTheme object.

CXTPTaskPanelToolboxTheme();
Group

CXTPTaskPanelToolboxTheme Constructors


CXTPTaskPanelToolboxWhidbeyTheme Class

XTPTaskPanelPaintManager.h, Classes, Legend, Members, Topics, CXTPTaskPanelToolboxWhidbeyTheme Methods, CXTPTaskPanelToolboxWhidbeyTheme Constructors, CXTPTaskPanelToolboxWhidbeyTheme Constructors, CXTPTaskPanelToolboxWhidbeyTheme Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme Class

The CXTPTaskPanelToolboxWhidbeyTheme class is used to enable a VS.NET Whidbey style theme.

Class Hierarchy

class CXTPTaskPanelToolboxWhidbeyTheme : public CXTPTaskPanelToolboxTheme;
File

XTPTaskPanelPaintManager.h

See Also

CXTPTaskPanel::SetTheme

Group

Classes

Legend
Method
CXTPTaskPanelToolboxWhidbeyTheme Constructors
CXTPTaskPanelToolboxWhidbeyTheme Constructors | Description
CXTPTaskPanelToolboxWhidbeyTheme | Constructs a CXTPTaskPanelToolboxWhidbeyTheme object.
CXTPTaskPanelToolboxWhidbeyTheme Methods
CXTPTaskPanelToolboxWhidbeyTheme Methods | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
DrawGroupClientFace | This method is called to draw the face of the group.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelToolboxWhidbeyTheme Methods

CXTPTaskPanelToolboxWhidbeyTheme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme Methods
Class

CXTPTaskPanelToolboxWhidbeyTheme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawGroupCaptionBackground | This member is called to draw the background of the group caption.
DrawGroupClientFace | This method is called to draw the face of the group.
FillGroupClientFace | Fills group rectangle
FillTaskPanel | This method is called to fill background of task panel control.
RefreshMetrics | This method is called to refresh the visual metrics of task panel.


CXTPTaskPanelToolboxWhidbeyTheme::DrawGroupCaptionBackground Method

CXTPTaskPanelToolboxWhidbeyTheme Methods, CXTPTaskPanelToolboxWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme::DrawGroupCaptionBackground Method

This member is called to draw the background of the group caption.

CRect DrawGroupCaptionBackground(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context.
pGroup
Fill group caption of this group.
rc
Bounding rectangle of the group caption.

Returns

Bounding rectangle of text within group caption.

Remarks

This member will draw the Whidbey color gradient in the group caption rectangle.

Group

CXTPTaskPanelToolboxWhidbeyTheme Methods


CXTPTaskPanelToolboxWhidbeyTheme::DrawGroupClientFace Method

CXTPTaskPanelToolboxWhidbeyTheme Methods, CXTPTaskPanelToolboxWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme::DrawGroupClientFace Method

This method is called to draw the face of the group.

void DrawGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object.
rc
Rectangle of group to be draw.

Group

CXTPTaskPanelToolboxWhidbeyTheme Methods


CXTPTaskPanelToolboxWhidbeyTheme::FillGroupClientFace Method

CXTPTaskPanelToolboxWhidbeyTheme Methods, CXTPTaskPanelToolboxWhidbeyTheme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme::FillGroupClientFace Method

Fills group rectangle

void FillGroupClientFace(
    CDC* pDC,
    CXTPTaskPanelGroup* pGroup,
    CRect rc
);
Parameters

pDC
Pointer to a valid device context
pGroup
Points to a CXTPTaskPanelGroup object
rc
Rectangle of group to be draw.

See Also

DrawGroupClientFace

Group

CXTPTaskPanelToolboxWhidbeyTheme Methods


CXTPTaskPanelToolboxWhidbeyTheme::FillTaskPanel Method

CXTPTaskPanelToolboxWhidbeyTheme Methods, CXTPTaskPanelToolboxWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme::FillTaskPanel Method

This method is called to fill background of task panel control.

void FillTaskPanel(
    CDC* pDC,
    CXTPTaskPanel* pTaskPanel
);
Parameters

pDC
Pointer to a valid device context
pTaskPanel
Points to a CXTPTaskPanel object

Group

CXTPTaskPanelToolboxWhidbeyTheme Methods


CXTPTaskPanelToolboxWhidbeyTheme::RefreshMetrics Method

CXTPTaskPanelToolboxWhidbeyTheme Methods, CXTPTaskPanelToolboxWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme::RefreshMetrics Method

This method is called to refresh the visual metrics of task panel.

void RefreshMetrics();
Group

CXTPTaskPanelToolboxWhidbeyTheme Methods


CXTPTaskPanelToolboxWhidbeyTheme Constructors

CXTPTaskPanelToolboxWhidbeyTheme Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme Constructors
Class

CXTPTaskPanelToolboxWhidbeyTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelToolboxWhidbeyTheme | Constructs a CXTPTaskPanelToolboxWhidbeyTheme object.


CXTPTaskPanelToolboxWhidbeyTheme::CXTPTaskPanelToolboxWhidbeyTheme Constructor

CXTPTaskPanelToolboxWhidbeyTheme Constructors, CXTPTaskPanelToolboxWhidbeyTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPTaskPanelToolboxWhidbeyTheme::CXTPTaskPanelToolboxWhidbeyTheme Constructor

Constructs a CXTPTaskPanelToolboxWhidbeyTheme object.

CXTPTaskPanelToolboxWhidbeyTheme();
Group

CXTPTaskPanelToolboxWhidbeyTheme Constructors


Structs, Records, Enums

Enumerations, Legend, Task Panel, Structures
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPTaskPanelAnimation | XTPTaskPanelAnimation is an enumeration used by CXTPTaskPanel to set the animation of the control.
XTPTaskPanelBehaviour | XTPTaskPanelBehaviour is an enumeration used by CXTPTaskPanel and CXTPTaskPanelGroup to set the behavior of the groups in the TaskPanel.
XTPTaskPanelGripper | Enumeration used to indicate which type of gripper is drawn on task panel group headers. This can be used when creating custom themes or you can override the predefined themes to change there grippers if drawn in the group headers.
XTPTaskPanelHotTrackStyle | XTPTaskPanelHotTrackStyle is an enumeration used by CXTPTaskPanel to set the hot tracking style used for CXTPTaskPanelItems. Hot tracking is how the items look as you move the mouse pointer over them.
XTPTaskPanelItemAllowDrag | XTPTaskPanelItemAllowDrag is an enumeration used by CXTPTaskPanel to specify the drag options
XTPTaskPanelItemLayout | XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the items are laid out in the group(s). Each group can have a different layout or they can all be the same.
XTPTaskPanelItemType | XTPTaskPanelItemType is an enumeration used by CXTPTaskPanelItem to specify the type of the item.
XTPTaskPanelPaintTheme | XTPTaskPanelPaintTheme is an enumeration used by CXTPTaskPanel to set the theme of the control.
Module

Task Panel

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_TASKPANEL_GROUPCOLORS | Structure used to store task panel group colorization information for various parts of the group.
XTP_TPNENDLABELEDIT | This structure passed as parameter when XTP_TPN_ENDLABELEDIT event occur.
XTP_TPNGROUPEXPANDING | This structure passed as parameter when XTP_TPN_GROUPEXPANDING event occur.


XTP_TASKPANEL_GROUPCOLORS Structure

XTPTaskPanelPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_TASKPANEL_GROUPCOLORS Structure

Structure used to store task panel group colorization information for various parts of the group.

struct XTP_TASKPANEL_GROUPCOLORS {
  CXTPPaintManagerColorGradient clrHead;
  CXTPPaintManagerColorGradient clrClient;
  CXTPPaintManagerColor clrClientBorder;
  double dHeadGradientFactor;
  CXTPPaintManagerColor clrHeadTextNormal;
  CXTPPaintManagerColor clrHeadTextHot;
  CXTPPaintManagerColor clrClientText;
  CXTPPaintManagerColor clrClientLink;
  CXTPPaintManagerColor clrClientLinkHot;
  CXTPPaintManagerColor clrClientLinkSelected;
};
File

XTPTaskPanelPaintManager.h

Members

clrHead
Color gradient used for the background color of group headers.
clrClient
Background color of the client area of the group.
clrClientBorder
Color of the client group border.
dHeadGradientFactor
Value used in calculating the gradient of the group header.
clrHeadTextNormal
Color of normal text in the group header
clrHeadTextHot
Color of "hot" text in the group header, this is the color of text on mouse over
clrClientText
Color of text within the client or "body" of the group.
clrClientLink
Color of links within the client or "body" of the group.
clrClientLinkHot
Color of "hot" links within the client or "body" of the group.
clrClientLinkSelected
Color of links within the client or "body" of the group.

See Also

CXTPTaskPanelPaintManager::GetGroupColors, CXTPTaskPanelPaintManager::m_groupNormal, CXTPTaskPanelPaintManager::m_groupSpecial

Example
     m_wndTaskPanel.GetPaintManager()->GetGroupColors(FALSE)->clrClientLink = RGB(0, 0, 255);
Group

Structs, Records, Enums


XTP_TPNENDLABELEDIT Structure

XTPTaskPanelDefines.h, Structs, Records, Enums
XTP_TPNENDLABELEDIT Structure

This structure passed as parameter when XTP_TPN_ENDLABELEDIT event occur.

struct XTP_TPNENDLABELEDIT {
  CXTPTaskPanelItem* pItem;
  CString strNewString;
};
File

XTPTaskPanelDefines.h

Members

pItem
Item that caption is will be changed
strNewString
New Caption of the item

Group

Structs, Records, Enums


XTP_TPNGROUPEXPANDING Structure

XTPTaskPanelDefines.h, Structs, Records, Enums
XTP_TPNGROUPEXPANDING Structure

This structure passed as parameter when XTP_TPN_GROUPEXPANDING event occur.

struct XTP_TPNGROUPEXPANDING {
  CXTPTaskPanelGroup* pGroup;
  BOOL bExpanding;
};
File

XTPTaskPanelDefines.h

Members

pGroup
Group that is about to be expanded.
bExpanding
TRUE if group must be expanded.

Group

Structs, Records, Enums


XTPTaskPanelAnimation Enumeration

XTPTaskPanelDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTaskPanelAnimation Enumeration

XTPTaskPanelAnimation is an enumeration used by CXTPTaskPanel to set the animation of the control.

enum XTPTaskPanelAnimation {
  xtpTaskPanelAnimationYes,
  xtpTaskPanelAnimationNo,
  xtpTaskPanelAnimationSystem
};
File

XTPTaskPanelDefines.h

Members

xtpTaskPanelAnimationYes
Enable animation
xtpTaskPanelAnimationNo
Disable animation
xtpTaskPanelAnimationSystem
Use system settings to determine animation

See Also

CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation

Example
m_wndTaskPanel.SetAnimation(xtpTaskPanelAnimationYes);
Group

Structs, Records, Enums


XTPTaskPanelBehaviour Enumeration

XTPTaskPanelDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTaskPanelBehaviour Enumeration

XTPTaskPanelBehaviour is an enumeration used by CXTPTaskPanel and CXTPTaskPanelGroup to set the behavior of the groups in the TaskPanel.

enum XTPTaskPanelBehaviour {
  xtpTaskPanelBehaviourExplorer,
  xtpTaskPanelBehaviourList,
  xtpTaskPanelBehaviourToolbox
};
File

XTPTaskPanelDefines.h

Members

xtpTaskPanelBehaviourExplorer
TaskPanel will behave like Windows Explorer.
xtpTaskPanelBehaviourList
TaskPanel will behave like Windows List Box.
xtpTaskPanelBehaviourToolbox
TaskPanel will behave like VS.

See Also

CXTPTaskPanel::SetBehaviour, CXTPTaskPanelGroup::GetBehaviour.

Example
m_wndTaskPanel.SetBehaviour(xtpTaskPanelBehaviourToolbox);
Group

Structs, Records, Enums


XTPTaskPanelGripper Enumeration

XTPTaskPanelPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTaskPanelGripper Enumeration

Enumeration used to indicate which type of gripper is drawn on task panel group headers. This can be used when creating custom themes or you can override the predefined themes to change there grippers if drawn in the group headers.

enum XTPTaskPanelGripper {
  xtpTaskPanelGripperNone,
  xtpTaskPanelGripperBitmap,
  xtpTaskPanelGripperPlain,
  xtpTaskPanelGripperTriangle
};
File

XTPTaskPanelPaintManager.h

Members

xtpTaskPanelGripperNone
Do not draw a gripper in task panel group headers.
xtpTaskPanelGripperBitmap
Display a bitmap in task panel group header, I.e.
xtpTaskPanelGripperPlain
Display the default "classic" gripper in task panel group headers.
xtpTaskPanelGripperTriangle
Display a triangle gripper in task panel group headers.

Remarks

Depending on the theme and XTPTaskPanelGripper selection, the gripper can appear "hot" on mouse over, and display a different gripper then when the group is expanded and closed.

See Also

CXTPTaskPanelPaintManager::m_eGripper

Example
     m_wndTaskPanel.GetPaintManager()->m_eGripper = xtpTaskPanelGripperTriangle;
Group

Structs, Records, Enums


XTPTaskPanelHotTrackStyle Enumeration

XTPTaskPanelDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTaskPanelHotTrackStyle Enumeration

XTPTaskPanelHotTrackStyle is an enumeration used by CXTPTaskPanel to set the hot tracking style used for CXTPTaskPanelItems. Hot tracking is how the items look as you move the mouse pointer over them.

enum XTPTaskPanelHotTrackStyle {
  xtpTaskPanelHighlightDefault,
  xtpTaskPanelHighlightText,
  xtpTaskPanelHighlightImage,
  xtpTaskPanelHighlightItem,
  xtpTaskPanelHighlightNone
};
File

XTPTaskPanelDefines.h

Members

xtpTaskPanelHighlightDefault
Uses the default hot tracking style.
xtpTaskPanelHighlightText
Only text is highlighted on mouse over
xtpTaskPanelHighlightImage
Only Images are highlighted on mouse over.
xtpTaskPanelHighlightItem
The entire item is highlighted on mouse over.
xtpTaskPanelHighlightNone
No hot tracking is used, nothing will happen on mouse over.

See Also

CXTPTaskPanel::SetHotTrackStyle, CXTPTaskPanel::GetHotTrackStyle, CXTPTaskPanelItem::IsItemHot

Example
m_wndTaskPanel.SetHotTrackStyle(xtpTaskPanelHighlightItem);
Group

Structs, Records, Enums


XTPTaskPanelItemAllowDrag Enumeration

XTPTaskPanelDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTaskPanelItemAllowDrag Enumeration

XTPTaskPanelItemAllowDrag is an enumeration used by CXTPTaskPanel to specify the drag options

enum XTPTaskPanelItemAllowDrag {
  xtpTaskItemAllowDragNone = 0x00,
  xtpTaskItemAllowDragDefault = 0x01,
  xtpTaskItemAllowDragCopyWithinGroup = 0x02,
  xtpTaskItemAllowDragCopyWithinControl = 0x04,
  xtpTaskItemAllowDragCopyOutsideControl = 0x08,
  xtpTaskItemAllowDragCopy = 0x04+0x08,
  xtpTaskItemAllowDragMoveWithinGroup = 0x20,
  xtpTaskItemAllowDragMoveWithinControl = 0x40,
  xtpTaskItemAllowDragMoveOutsideControl = 0x80,
  xtpTaskItemAllowDragMove = 0x40+0x80,
  xtpTaskItemAllowDragWithinGroup = 0x02+0x20,
  xtpTaskItemAllowDragWithinControl = 0x04+0x40,
  xtpTaskItemAllowDrag = 0x04+0x08+0x40+0x80
};
File

XTPTaskPanelDefines.h

Members

xtpTaskItemAllowDragNone
Disable drag
xtpTaskItemAllowDragDefault
Default drag options (xtpTaskItemAllowDragAll)
xtpTaskItemAllowDragCopyWithinGroup
Allow copy within group only
xtpTaskItemAllowDragCopyWithinControl
Allow copy within task panel only
xtpTaskItemAllowDragCopyOutsideControl
Allow copy outside task panel only
xtpTaskItemAllowDragCopy
Allow copy operation
xtpTaskItemAllowDragMoveWithinGroup
Allow move within group only
xtpTaskItemAllowDragMoveWithinControl
Allow move within task panel only
xtpTaskItemAllowDragMoveOutsideControl
Allow move outside task panel only
xtpTaskItemAllowDragMove
Allow move operation
xtpTaskItemAllowDragWithinGroup
Allow drag within group only
xtpTaskItemAllowDragWithinControl
Allow drag within task panel only
xtpTaskItemAllowDrag
Allow all drag operations

See Also

CXTPTaskPanel::AllowDrag

Example
m_wndTaskPanel.AllowDrag(xtpTaskItemAllowDragCopyWithinGroup);
Group

Structs, Records, Enums


XTPTaskPanelItemLayout Enumeration

XTPTaskPanelDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTaskPanelItemLayout Enumeration

XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the items are laid out in the group(s). Each group can have a different layout or they can all be the same.

enum XTPTaskPanelItemLayout {
  xtpTaskItemLayoutDefault,
  xtpTaskItemLayoutImages,
  xtpTaskItemLayoutImagesWithText,
  xtpTaskItemLayoutImagesWithTextBelow
};
File

XTPTaskPanelDefines.h

Members

xtpTaskItemLayoutDefault
Default Layout.
xtpTaskItemLayoutImages
Only images are shown.
xtpTaskItemLayoutImagesWithText
Both images and text are shown.
xtpTaskItemLayoutImagesWithTextBelow
Images with the text shown below the image.

See Also

CXTPTaskPanel::SetItemLayout, CXTPTaskPanel::GetItemLayout, CXTPTaskPanelGroup::SetItemLayout, CXTPTaskPanelGroup::GetItemLayout

Example
pGroup->SetItemLayout(xtpTaskItemLayoutImagesWithText);
Group

Structs, Records, Enums


XTPTaskPanelItemType Enumeration

XTPTaskPanelDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTaskPanelItemType Enumeration

XTPTaskPanelItemType is an enumeration used by CXTPTaskPanelItem to specify the type of the item.

enum XTPTaskPanelItemType {
  xtpTaskItemTypeGroup,
  xtpTaskItemTypeLink,
  xtpTaskItemTypeText,
  xtpTaskItemTypeControl
};
File

XTPTaskPanelDefines.h

Members

xtpTaskItemTypeGroup
Item is group.
xtpTaskItemTypeLink
Item is link.
xtpTaskItemTypeText
Item is text.
xtpTaskItemTypeControl
Item is control.

See Also

CXTPTaskPanelItem::SetType, CXTPTaskPanelItem::GetType

Example
CXTPTaskPanelGroup* pGroupSystem = m_wndTaskPanel.AddGroup(ID_TASKGROUP_SYSTEM);
pGroupSystem->AddLinkItem(ID_TASKITEM_HIDECONTENTS, 0);
ASSERT(pGroupSystem->GetType() == xtpTaskItemTypeLink);
Group

Structs, Records, Enums


XTPTaskPanelPaintTheme Enumeration

XTPTaskPanelDefines.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPTaskPanelPaintTheme Enumeration

XTPTaskPanelPaintTheme is an enumeration used by CXTPTaskPanel to set the theme of the control.

enum XTPTaskPanelPaintTheme {
  xtpTaskPanelThemeOffice2000,
  xtpTaskPanelThemeOffice2003,
  xtpTaskPanelThemeNativeWinXP,
  xtpTaskPanelThemeOffice2000Plain,
  xtpTaskPanelThemeOfficeXPPlain,
  xtpTaskPanelThemeOffice2003Plain,
  xtpTaskPanelThemeNativeWinXPPlain,
  xtpTaskPanelThemeToolbox,
  xtpTaskPanelThemeToolboxWhidbey,
  xtpTaskPanelThemeListView,
  xtpTaskPanelThemeListViewOfficeXP,
  xtpTaskPanelThemeListViewOffice2003,
  xtpTaskPanelThemeShortcutBarOffice2003,
  xtpTaskPanelThemeShortcutBarOffice2007,
  xtpTaskPanelThemeCustom
};
File

XTPTaskPanelDefines.h

Members

xtpTaskPanelThemeOffice2000
Office 2000 theme
xtpTaskPanelThemeOffice2003
Office 2003 theme
xtpTaskPanelThemeNativeWinXP
Win XP theme
xtpTaskPanelThemeOffice2000Plain
Office 2000 classic theme
xtpTaskPanelThemeOfficeXPPlain
Office XP classic theme
xtpTaskPanelThemeOffice2003Plain
Office 2003 classic theme
xtpTaskPanelThemeNativeWinXPPlain
Win XP classic theme
xtpTaskPanelThemeToolbox
VS.NET style Toolbox theme.
xtpTaskPanelThemeToolboxWhidbey
Whidbey VS 2005 style Toolbox theme.
xtpTaskPanelThemeListView
Standard List View theme.
xtpTaskPanelThemeListViewOfficeXP
Office XP List View theme.
xtpTaskPanelThemeListViewOffice2003
Office 2003 List View theme.
xtpTaskPanelThemeShortcutBarOffice2003
ShortcutBar Office 2003 theme.
xtpTaskPanelThemeShortcutBarOffice2007
ShortcutBar Office 2007 theme.
xtpTaskPanelThemeCustom
User defined Custom theme is used.

See Also

CXTPTaskPanel::SetTheme, CXTPTaskPanel::GetCurrentTheme

Example
m_wndTaskPanel.SetTheme(xtpTaskPanelThemeOffice2000Plain);
Group

Structs, Records, Enums


Variables

Task Panel, Variables
Variables
Module

Task Panel

Variables
Variable | Description
XTP_ACTION_CANCEL | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_CLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_DBLCLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ENDLABELEDIT | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_FOCUSEDITEMCHANGED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_GROUPEXPANDED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_GROUPEXPANDING | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_HOTITEMCHANGED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ITEMDROP | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ITEMREMOVED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_RCLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_STARTDRAG | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTPWM_TASKPANEL_NOTIFY | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel


XTPWM_TASKPANEL_NOTIFY Variable

XTPTaskPanelDefines.h, Variables, Example, See Also
XTPWM_TASKPANEL_NOTIFY Variable

The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel

const UINT XTPWM_TASKPANEL_NOTIFY = (WM_USER + 9195 + 1);
File

XTPTaskPanelDefines.h

Parameters

nAction
Value of wParam specifies a TaskPanel value that indicates the user's request.
pItem
The value of lParam points to an CXTPTaskPanelItem object that contains information for the specified item. This pointer should never be NULL.

Returns

If the application is to process this message, the return value should be TRUE, otherwise the return value is FALSE.

Remarks
XTPWM_SHORTCUTBAR_NOTIFY
nAction = (int) wParam;             // TaskPanel action
pItem = (CXTPTaskPanelItem*) lParam;  // pointer to an CXTPTaskPanelItem object

nAction parameter can be one of the following values:

  • XTP_TPN_CLICK Indicates the user click TaskPanel item.
  • XTP_TPN_RCLICK Indicates the user presses the right mouse button on the TaskPanel item.
  • XTP_TPN_STARTDRAG Indicates the user start dragging item.
  • XTP_TPN_ENDLABELEDIT Indicates the user apply item rename.
  • XTP_TPN_ITEMDROP Indicates the user dropped item to task panel
  • XTP_TPN_GROUPEXPANDING Indicates the group is about to be expanded. lParam contains XTP_TPNGROUPEXPANDING pointer. You can return XTP_ACTION_CANCEL to ignore expanding.
  • XTP_TPN_GROUPEXPANDED Indicates the user expand group.
  • XTP_TPN_DBLCLICK Indicates the user double-clicks TaskPanel item.
  • XTP_TPN_FOCUSEDITEMCHANGED Focused item of control changed.
See Also

CXTPTaskPanel::NotifyOwner

Example
BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(XTPWM_TASKPANEL_NOTIFY, OnTaskPanelNotify)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTaskPanelNotify(WPARAM wParam, LPARAM lParam)
{
     switch (wParam)
     {
         case XTP_TPN_CLICK:
             {
                 CXTPTaskPanelGroupItem* pItem = (CXTPTaskPanelGroupItem*)lParam;
                 TRACE(_T("Click Event: pItem.Caption = %s, pItem.ID = %in"), pItem->GetCaption(), pItem->GetID());

                 if (IsToggleButtons())
                 {
                     pItem->SetItemSelected(!pItem->IsItemSelected());
                 }
             }
             break;

         case XTP_TPN_RCLICK:

             OnTaskPanelRButtonDown((CXTPTaskPanelItem*)lParam);
             return TRUE;

     }
     return 0;
}
Group

Variables


Files

Files, Task Panel
Files
Files
File | Description
XTPTaskPanel.h | XTPTaskPanel.h interface for the CXTPTaskPanel class.
XTPTaskPanelDefines.h | XTPTaskPanelDefines.h This file is a part of the XTREME TASKPANEL MFC class library.
XTPTaskPanelGroup.h | XTPTaskPanelGroup.h interface for the CXTPTaskPanelGroup class.
XTPTaskPanelGroupItem.h | XTPTaskPanelGroupItem.h interface for the CXTPTaskPanelGroupItem class.
XTPTaskPanelItem.h | XTPTaskPanelItem.h interface for the CXTPTaskPanelItem class.
XTPTaskPanelItems.h | XTPTaskPanelItems.h interface for the CXTPTaskPanelItems class.
XTPTaskPanelPaintManager.h | XTPTaskPanelPaintManager.h interface for the CXTPTaskPanelPaintManager class.
Module

Task Panel


XTPTaskPanel.h

Classes, Files
XTPTaskPanel.h

XTPTaskPanel.h interface for the CXTPTaskPanel class.

Classes
Class | Description
CXTPTaskPanel | CXTPTaskPanel is a CWnd derived class. It is used to implement an Explorer and Office-like Task Panel control.
CXTPTaskPanelScrollButton | CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button.
Group

Files


XTPTaskPanelDefines.h

Enumerations, Files, Legend, Variables, Structures
XTPTaskPanelDefines.h

XTPTaskPanelDefines.h

This file is a part of the XTREME TASKPANEL MFC class library.

Enumerations
Enumeration | Description
XTPTaskPanelAnimation | XTPTaskPanelAnimation is an enumeration used by CXTPTaskPanel to set the animation of the control.
XTPTaskPanelBehaviour | XTPTaskPanelBehaviour is an enumeration used by CXTPTaskPanel and CXTPTaskPanelGroup to set the behavior of the groups in the TaskPanel.
XTPTaskPanelHotTrackStyle | XTPTaskPanelHotTrackStyle is an enumeration used by CXTPTaskPanel to set the hot tracking style used for CXTPTaskPanelItems. Hot tracking is how the items look as you move the mouse pointer over them.
XTPTaskPanelItemAllowDrag | XTPTaskPanelItemAllowDrag is an enumeration used by CXTPTaskPanel to specify the drag options
XTPTaskPanelItemLayout | XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the items are laid out in the group(s). Each group can have a different layout or they can all be the same.
XTPTaskPanelItemType | XTPTaskPanelItemType is an enumeration used by CXTPTaskPanelItem to specify the type of the item.
XTPTaskPanelPaintTheme | XTPTaskPanelPaintTheme is an enumeration used by CXTPTaskPanel to set the theme of the control.
Group

Files

Variables
Variable | Description
XTP_ACTION_CANCEL | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_CLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_DBLCLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ENDLABELEDIT | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_FOCUSEDITEMCHANGED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_GROUPEXPANDED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_GROUPEXPANDING | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_HOTITEMCHANGED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ITEMDROP | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_ITEMREMOVED | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_RCLICK | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTP_TPN_STARTDRAG | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
XTPWM_TASKPANEL_NOTIFY | The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel
Legend
Structure
Enumeration
Structures
Structure | Description
XTP_TPNENDLABELEDIT | This structure passed as parameter when XTP_TPN_ENDLABELEDIT event occur.
XTP_TPNGROUPEXPANDING | This structure passed as parameter when XTP_TPN_GROUPEXPANDING event occur.


XTPTaskPanelGroup.h

Classes, Files
XTPTaskPanelGroup.h

XTPTaskPanelGroup.h interface for the CXTPTaskPanelGroup class.

Classes
Class | Description
CXTPTaskPanelGroup | CXTPTaskPanelGroup is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single group.
Group

Files


XTPTaskPanelGroupItem.h

Classes, Files
XTPTaskPanelGroupItem.h

XTPTaskPanelGroupItem.h interface for the CXTPTaskPanelGroupItem class.

Classes
Class | Description
CXTPTaskPanelGroupItem | CXTPTaskPanelGroupItem is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single item of the group.
Group

Files


XTPTaskPanelItem.h

Classes, Files
XTPTaskPanelItem.h

XTPTaskPanelItem.h interface for the CXTPTaskPanelItem class.

Classes
Class | Description
CXTPTaskPanelItem | CXTPTaskPanelItem is a CCmdTarget derived class. It is used in TaskPanel control as parent for CXTPTaskPanelGroupItem and CXTPTaskPanelGroup classes.
Group

Files


XTPTaskPanelItems.h

Classes, Files
XTPTaskPanelItems.h

XTPTaskPanelItems.h interface for the CXTPTaskPanelItems class.

Classes
Class | Description
CXTPTaskPanelGroupItems | CXTPTaskPanelGroupItems is a CXTPTaskPanelItems derived class. It is used as collection of items in the group.
CXTPTaskPanelGroups | CXTPTaskPanelGroups is a CXTPTaskPanelItems derived class. It is used as a collection of groups in the control.
CXTPTaskPanelItems | CXTPTaskPanelItems is a CCmdTarget derived class. It is used as collection of CXTPTaskPanelItem classes.
Group

Files


XTPTaskPanelPaintManager.h

Classes, Enumerations, Files, Legend, Structures
XTPTaskPanelPaintManager.h

XTPTaskPanelPaintManager.h interface for the CXTPTaskPanelPaintManager class.

Classes
Class | Description
CXTPTaskPanelExplorerTheme | Class that represents an Explorer style theme.
CXTPTaskPanelExplorerThemePlain | The CXTPTaskPanelExplorerThemePlain class is used to enable a classic Explorer style theme.
CXTPTaskPanelListViewOffice2003Theme | The CXTPTaskPanelListViewOffice2003Theme class is used to enable a List View Office 2003 style theme.
CXTPTaskPanelListViewOfficeXPTheme | The CXTPTaskPanelListViewOfficeXPTheme class is used to enable a List View Office XP style theme.
CXTPTaskPanelListViewTheme | The CXTPTaskPanelListViewTheme class is used to enable a List View style theme.
CXTPTaskPanelOffice2003Theme | Class that represents an Office 2003 style theme.
CXTPTaskPanelOffice2003ThemePlain | The CXTPTaskPanelOffice2003ThemePlain class is used to enable a classic Office 2003 style theme.
CXTPTaskPanelOfficeXPThemePlain | The CXTPTaskPanelOfficeXPThemePlain class is used to enable a classic Office XP style theme.
CXTPTaskPanelPaintManager | Standalone class used by CXTPTaskPanel as paint manager.
CXTPTaskPanelPaintManagerPlain | Base class theme that all other themes are derived from. Use this class when creating a custom theme.
CXTPTaskPanelShortcutBarOffice2003Theme | CXTPTaskPanelShortcutBarOffice2003Theme is a CXTPTaskPanelListViewOffice2003Theme derived class used to enable an Office 2003 ShortcutBar style theme.
CXTPTaskPanelShortcutBarOffice2007Theme | CXTPTaskPanelShortcutBarOffice2007Theme is a CXTPTaskPanelShortcutBarOffice2003Theme derived class used to enable an Office 2007 ShortcutBar style theme.
CXTPTaskPanelToolboxTheme | The CXTPTaskPanelToolboxTheme class is used to enable a Toolbox style theme.
CXTPTaskPanelToolboxWhidbeyTheme | The CXTPTaskPanelToolboxWhidbeyTheme class is used to enable a VS.NET Whidbey style theme.
Enumerations
Enumeration | Description
XTPTaskPanelGripper | Enumeration used to indicate which type of gripper is drawn on task panel group headers. This can be used when creating custom themes or you can override the predefined themes to change there grippers if drawn in the group headers.
Group

Files

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_TASKPANEL_GROUPCOLORS | Structure used to store task panel group colorization information for various parts of the group.


Shortcut Bar

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Structs, Records, Enums, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Shortcut Bar

Codejock Software's Xtreme ShortcutBar provides developers with full theme support giving their applications the closest, most exact Office style themes of any 3rd party tool available today.

Group

Xtreme Toolkit Pro v12.0

Legend
Enumeration
Classes
Class | Description
CXTPShortcutBar | CXTPShortcutBar is a CWnd derived class. It is used to implement an Outlook2003 ShortcutBar style control.
CXTPShortcutBarItem | CXTPShortcutBarItem is the base class representing an item of the ShortcutBar Control.
CXTPShortcutBarOffice2000Theme | CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarOffice2003Theme | CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarOffice2007Theme | CXTPShortcutBarOffice2007Theme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007 shortcut bar theme.
CXTPShortcutBarOfficeXPTheme | CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarPaintManager | Standalone class used by CXTPShortcutBar as paint manager.
CXTPShortcutBarPane | CXTPShortcutBarPane is a CWnd derived class. It is used as client area of ShortcutBar control.
CXTPShortcutBarPaneItem | CXTPShortcutBarPaneItem is the base class representing an item of the panes.
Files
File | Description
XTPShortcutBar.h | XTPShortcutBar.h interface for the CXTPShortcutBar class.
XTPShortcutBarPaintManager.h | XTPShortcutBarPaintManager.h interface for the CXTPShortcutBarPaintManager class.
XTPShortcutBarPane.h | XTPShortcutBarPane.h interface for the CXTPShortcutBarPane class.
Structs, Records, Enums
Struct, Record, Enum | Description
XTPShortcutBarPaintTheme | XTPShortcutBarPaintTheme is an enumeration used by CXTPShortcutBar to set the theme of the control.
Variables
Variable | Description
XTP_SBN_RCLICK | XTP_SBN_RCLICK is used to indicate that the user has pressed the right mouse button on a shortcut bar item.
XTP_SBN_SELECTION_CHANGED | XTP_SBN_SELECTION_CHANGING is used to indicate that value for the selection is currently changing.
XTP_SBN_SELECTION_CHANGING | XTP_SBN_SELECTION_CHANGED is used to indicate that the selection has changed in the shortcut bar.
XTPWM_SHORTCUTBAR_NOTIFY | The XTPWM_SHORTCUTBAR_NOTIFY message is sent to the CXTPShortcutBar owner window whenever an action occurs within the CXTPShortcutBar


Shortcut Bar Hierarchy

Shortcut Bar
Shortcut Bar Hierarchy

Module

Shortcut Bar


Classes

Classes, Shortcut Bar
Classes
Classes
Class | Description
CXTPShortcutBar | CXTPShortcutBar is a CWnd derived class. It is used to implement an Outlook2003 ShortcutBar style control.
CXTPShortcutBarItem | CXTPShortcutBarItem is the base class representing an item of the ShortcutBar Control.
CXTPShortcutBarOffice2000Theme | CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarOffice2003Theme | CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarOffice2007Theme | CXTPShortcutBarOffice2007Theme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007 shortcut bar theme.
CXTPShortcutBarOfficeXPTheme | CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarPaintManager | Standalone class used by CXTPShortcutBar as paint manager.
CXTPShortcutBarPane | CXTPShortcutBarPane is a CWnd derived class. It is used as client area of ShortcutBar control.
CXTPShortcutBarPaneItem | CXTPShortcutBarPaneItem is the base class representing an item of the panes.
Module

Shortcut Bar


CXTPShortcutBar Class

XTPShortcutBar.h, Classes, Legend, Members, Topics, CXTPShortcutBar Data Members, CXTPShortcutBar Methods, CXTPShortcutBar Constructors, CXTPShortcutBar Destructors, CXTPShortcutBar Nested Types, CXTPShortcutBar Constructors, CXTPShortcutBar Data Members, CXTPShortcutBar Destructors, CXTPShortcutBar Methods, CXTPShortcutBar Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar Class

CXTPShortcutBar is a CWnd derived class. It is used to implement an Outlook2003 ShortcutBar style control.

Class Hierarchy

class CXTPShortcutBar : public CWnd;
File

XTPShortcutBar.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPShortcutBar Constructors
CXTPShortcutBar Constructors | Description
CXTPShortcutBar | Constructs a CXTPShortcutBar object.
CXTPShortcutBar Data Members
CXTPShortcutBar Data Members | Description
m_arrItems | Array of items.
m_bAllowCollapse | TRUE to allow collapse items.
m_bAllowFreeResize | TRUE to allow resize gripper by pixel;
m_bAllowResize | TRUE to allow resize
m_bClientPaneVisible | TRUE is client Pane in ShortcutBar is visible
m_bPreSubclassWindow | True if PreSubclassWindow was called
m_bShowActiveItemOnTop | TRUE to show active item on top
m_bShowGripper | TRUE to show gripper.
m_bSingleSelection | TRUE to use single selected items.
m_bTrackingSize | TRUE if control in tracking mode.
m_hHandCursor | Hand cursor that is displayed when the cursor is positioned over a shortcut bar item.
m_hSizeCursor | Handle to the cursor displayed for the size icon.
m_hwndClient | Client window handle
m_nDesiredExpandedLinesHeight | Desired visible lines height height.
m_nExpandedLines | Number of lines currently visible
m_nMinClientHeight | The height of client area.
m_paintTheme | Current theme.
m_pHotItem | Pointer to hot item.
m_pImageManager | Current image manager.
m_pPaintManager | Current paint manager.
m_pPressedItem | Pointer to pressed item.
m_pSelectedItem | Pointer to selected item.
m_pToolTipContext | Tooltip Context.
m_rcClient | Client's rectangle.
m_rcGripper | Gripper's rectangle.
m_szItem | Size of items
CXTPShortcutBar Destructors
CXTPShortcutBar Destructors | Description
~CXTPShortcutBar | Destroys a CXTPShortcutBar object, handles cleanup and deallocation.
CXTPShortcutBar Methods
CXTPShortcutBar Methods | Description
AddItem | Call this method to add a new item.
AllowCollapse | Call this method to allow collapse items
AllowFreeResize | Call this method to allow resize gripper by pixel
AllowGripperResize | Call this method to enable/disable resize client area
Create | This method creates the ShortcutBar control
FindItem | Call this method to find an item with the specified identifier.
GetClientPaneRect | Retrieves bounding rectangle of shortcut bar client
GetCollapsedItemsCount | Call this method to determine the number of collapsed items
GetCurrentTheme | Call this member to get the current visual theme.
GetExpandedLinesCount | This method determines the count of visible lines in the ShortcutBar control.
GetExpandedLinesHeight | This method determines the height of visible lines in the ShortcutBar control.
GetGripperRect | Call this method to determine gripper rectangle.
GetHotItem | Returns the hot item in the ShortcutBar control.
GetImageManager | Call this method to get a pointer to the image manager of shortcut bar control.
GetItem | This method retrieves an item with specified index.
GetItemCount | Call this member to determine how many CXTPShortcutBarItem(s) are int he shortcut bar.
GetItemSize | Call this method to get size of items
GetPaintManager | Call this member to get the current paint manager.
GetPressedItem | Returns the pressed item in the ShortcutBar control.
GetSelectedItem | Returns the selected item in the ShortcutBar control.
GetToolTipContext | Call this method to get tooltip context pointer.
GetVisibleItemsCount | Call this method to determine the number of visible items
HitTest | This method determines where a point lies in a specified item.
IsAllowFreeResize | Determines if gripper allowed to resize by pixel.
IsClientPaneVisible | Determines visibility of client pane.
IsExpandButtonVisible | Determines if expand button visible
IsShowActiveItemOnTop | Call this method to get ShowActiveItemOnTop property of control.
IsSingleSelection | Call this method to get Single Selection property of control.
LoadState | Call this function to retrieve state information from the registry or .INI file.
OnExpandButtonDown | This method is called when expand button is pressed.
OnRepositionDone | This method is called when reposition is done.
RedrawControl | Call this method to redraw control.
RegisterWindowClass | Register the window class if it has not already been registered.
RemoveAllItems | Call this method to remove all items.
RemoveItem | Call this method to remove the item.
Reposition | Call this method to reposition items.
SaveState | Call this function to save the state information to the registry or .INI file.
SelectItem | Call this method to select the specified item.
SetClientPaneVisible | Call this member to show or hide client pane.
SetCustomTheme | Call this member to set a custom theme.
SetExpandedLinesCount | This method sets the count of lines that are visible in the ShortcutBar control.
SetExpandedLinesHeight | This method sets the the height of lines that are visible in the ShortcutBar control.
SetHotItem | Call this method to set hot item.
SetImageManager | Call this method to set new image manager.
SetItemSize | Call this method to set size of items
SetLayoutRTL | Call this member to set right-to-left mode.
SetMinimumClientHeight | This method sets the minimum height of the client area in a ShortcutBar control. The default value is 200.
SetSingleSelection | Call this method to allow only one item to be selected.
SetTheme | Call this member to switch the visual theme of the ShortcutBar control.
ShowActiveItemOnTop | Call this method to show active item on top of controls
ShowExpandButton | Call this method to show/hide expand button
ShowGripper | Call this method to show gripper.
CXTPShortcutBar Nested Types
CXTPShortcutBar Nested Types | Description
CShortcutArray | Array of CXTPShortcutBarItem objects


CXTPShortcutBar Data Members

CXTPShortcutBar Class, Legend, Protected Data Members
CXTPShortcutBar Data Members
Class

CXTPShortcutBar Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrItems | Array of items.
m_bAllowCollapse | TRUE to allow collapse items.
m_bAllowFreeResize | TRUE to allow resize gripper by pixel;
m_bAllowResize | TRUE to allow resize
m_bClientPaneVisible | TRUE is client Pane in ShortcutBar is visible
m_bPreSubclassWindow | True if PreSubclassWindow was called
m_bShowActiveItemOnTop | TRUE to show active item on top
m_bShowGripper | TRUE to show gripper.
m_bSingleSelection | TRUE to use single selected items.
m_bTrackingSize | TRUE if control in tracking mode.
m_hHandCursor | Hand cursor that is displayed when the cursor is positioned over a shortcut bar item.
m_hSizeCursor | Handle to the cursor displayed for the size icon.
m_hwndClient | Client window handle
m_nDesiredExpandedLinesHeight | Desired visible lines height height.
m_nExpandedLines | Number of lines currently visible
m_nMinClientHeight | The height of client area.
m_paintTheme | Current theme.
m_pHotItem | Pointer to hot item.
m_pImageManager | Current image manager.
m_pPaintManager | Current paint manager.
m_pPressedItem | Pointer to pressed item.
m_pSelectedItem | Pointer to selected item.
m_pToolTipContext | Tooltip Context.
m_rcClient | Client's rectangle.
m_rcGripper | Gripper's rectangle.
m_szItem | Size of items


CXTPShortcutBar::m_arrItems Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_arrItems Data Member

Array of items.

CShortcutArray m_arrItems;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bAllowCollapse Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bAllowCollapse Data Member

TRUE to allow collapse items.

BOOL m_bAllowCollapse;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bAllowFreeResize Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bAllowFreeResize Data Member

TRUE to allow resize gripper by pixel;

BOOL m_bAllowFreeResize;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bAllowResize Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bAllowResize Data Member

TRUE to allow resize

BOOL m_bAllowResize;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bClientPaneVisible Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bClientPaneVisible Data Member

TRUE is client Pane in ShortcutBar is visible

BOOL m_bClientPaneVisible;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bPreSubclassWindow Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bPreSubclassWindow Data Member

True if PreSubclassWindow was called

BOOL m_bPreSubclassWindow;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bShowActiveItemOnTop Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bShowActiveItemOnTop Data Member

TRUE to show active item on top

BOOL m_bShowActiveItemOnTop;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bShowGripper Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bShowGripper Data Member

TRUE to show gripper.

BOOL m_bShowGripper;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bSingleSelection Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bSingleSelection Data Member

TRUE to use single selected items.

BOOL m_bSingleSelection;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_bTrackingSize Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_bTrackingSize Data Member

TRUE if control in tracking mode.

BOOL m_bTrackingSize;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_hHandCursor Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_hHandCursor Data Member

Hand cursor that is displayed when the cursor is positioned over a shortcut bar item.

HCURSOR m_hHandCursor;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_hSizeCursor Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_hSizeCursor Data Member

Handle to the cursor displayed for the size icon.

HCURSOR m_hSizeCursor;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_hwndClient Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_hwndClient Data Member

Client window handle

HWND m_hwndClient;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_nDesiredExpandedLinesHeight Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_nDesiredExpandedLinesHeight Data Member

Desired visible lines height height.

int m_nDesiredExpandedLinesHeight;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_nExpandedLines Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_nExpandedLines Data Member

Number of lines currently visible

int m_nExpandedLines;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_nMinClientHeight Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_nMinClientHeight Data Member

The height of client area.

int m_nMinClientHeight;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_paintTheme Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_paintTheme Data Member

Current theme.

XTPShortcutBarPaintTheme m_paintTheme;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_pHotItem Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_pHotItem Data Member

Pointer to hot item.

CXTPShortcutBarItem* m_pHotItem;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_pImageManager Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_pImageManager Data Member

Current image manager.

CXTPImageManager* m_pImageManager;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_pPaintManager Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_pPaintManager Data Member

Current paint manager.

CXTPShortcutBarPaintManager* m_pPaintManager;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_pPressedItem Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_pPressedItem Data Member

Pointer to pressed item.

CXTPShortcutBarItem* m_pPressedItem;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_pSelectedItem Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_pSelectedItem Data Member

Pointer to selected item.

CXTPShortcutBarItem* m_pSelectedItem;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_pToolTipContext Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_pToolTipContext Data Member

Tooltip Context.

CXTPToolTipContext* m_pToolTipContext;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_rcClient Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_rcClient Data Member

Client's rectangle.

CRect m_rcClient;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_rcGripper Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_rcGripper Data Member

Gripper's rectangle.

CRect m_rcGripper;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar::m_szItem Data Member

CXTPShortcutBar Data Members, CXTPShortcutBar Class
CXTPShortcutBar::m_szItem Data Member

Size of items

CSize m_szItem;
Group

CXTPShortcutBar Data Members


CXTPShortcutBar Methods

CXTPShortcutBar Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar Methods
Class

CXTPShortcutBar Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnExpandButtonDown | This method is called when expand button is pressed.
OnRepositionDone | This method is called when reposition is done.
SetHotItem | Call this method to set hot item.
Public Methods
Public Methods
Public Method | Description
AddItem | Call this method to add a new item.
AllowCollapse | Call this method to allow collapse items
AllowFreeResize | Call this method to allow resize gripper by pixel
AllowGripperResize | Call this method to enable/disable resize client area
Create | This method creates the ShortcutBar control
FindItem | Call this method to find an item with the specified identifier.
GetClientPaneRect | Retrieves bounding rectangle of shortcut bar client
GetCollapsedItemsCount | Call this method to determine the number of collapsed items
GetCurrentTheme | Call this member to get the current visual theme.
GetExpandedLinesCount | This method determines the count of visible lines in the ShortcutBar control.
GetExpandedLinesHeight | This method determines the height of visible lines in the ShortcutBar control.
GetGripperRect | Call this method to determine gripper rectangle.
GetHotItem | Returns the hot item in the ShortcutBar control.
GetImageManager | Call this method to get a pointer to the image manager of shortcut bar control.
GetItem | This method retrieves an item with specified index.
GetItemCount | Call this member to determine how many CXTPShortcutBarItem(s) are int he shortcut bar.
GetItemSize | Call this method to get size of items
GetPaintManager | Call this member to get the current paint manager.
GetPressedItem | Returns the pressed item in the ShortcutBar control.
GetSelectedItem | Returns the selected item in the ShortcutBar control.
GetToolTipContext | Call this method to get tooltip context pointer.
GetVisibleItemsCount | Call this method to determine the number of visible items
HitTest | This method determines where a point lies in a specified item.
IsAllowFreeResize | Determines if gripper allowed to resize by pixel.
IsClientPaneVisible | Determines visibility of client pane.
IsExpandButtonVisible | Determines if expand button visible
IsShowActiveItemOnTop | Call this method to get ShowActiveItemOnTop property of control.
IsSingleSelection | Call this method to get Single Selection property of control.
LoadState | Call this function to retrieve state information from the registry or .INI file.
RedrawControl | Call this method to redraw control.
RegisterWindowClass | Register the window class if it has not already been registered.
RemoveAllItems | Call this method to remove all items.
RemoveItem | Call this method to remove the item.
Reposition | Call this method to reposition items.
SaveState | Call this function to save the state information to the registry or .INI file.
SelectItem | Call this method to select the specified item.
SetClientPaneVisible | Call this member to show or hide client pane.
SetCustomTheme | Call this member to set a custom theme.
SetExpandedLinesCount | This method sets the count of lines that are visible in the ShortcutBar control.
SetExpandedLinesHeight | This method sets the the height of lines that are visible in the ShortcutBar control.
SetImageManager | Call this method to set new image manager.
SetItemSize | Call this method to set size of items
SetLayoutRTL | Call this member to set right-to-left mode.
SetMinimumClientHeight | This method sets the minimum height of the client area in a ShortcutBar control. The default value is 200.
SetSingleSelection | Call this method to allow only one item to be selected.
SetTheme | Call this member to switch the visual theme of the ShortcutBar control.
ShowActiveItemOnTop | Call this method to show active item on top of controls
ShowExpandButton | Call this method to show/hide expand button
ShowGripper | Call this method to show gripper.


CXTPShortcutBar::AddItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::AddItem Method

Call this method to add a new item.

CXTPShortcutBarItem* AddItem(
    UINT nID,
    CWnd* pWnd = NULL
);
Parameters

nID
Identifier of item that is to be added.
pWnd
A Pointer to CWnd class associated with new item.

Returns

A pointer to a CXTPShortcutBarItem object.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::AllowCollapse Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::AllowCollapse Method

Call this method to allow collapse items

void AllowCollapse(
    BOOL bAllowCollapse
);
Parameters

bAllowCollapse
TRUE to allow collapse items

Body Source
void CXTPShortcutBar::AllowCollapse(BOOL bAllowCollapse) {
    m_bAllowCollapse = bAllowCollapse;
    Reposition();
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::AllowFreeResize Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::AllowFreeResize Method

Call this method to allow resize gripper by pixel

void AllowFreeResize(
    BOOL bAllowFreeResize
);
Parameters

bAllowFreeResize
TRUE to allow resize gripper by pixel

See Also

IsShowActiveItemOnTop

Body Source
void CXTPShortcutBar::AllowFreeResize(BOOL bAllowFreeResize) {
    m_bAllowFreeResize = bAllowFreeResize;
    Reposition();
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::AllowGripperResize Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::AllowGripperResize Method

Call this method to enable/disable resize client area

void AllowGripperResize(
    BOOL bAllowResize
);
Parameters

bAllowResize
TRUE to allow resize; FALSE to disable

See Also

SetExpandedLinesCount

Body Source
void CXTPShortcutBar::AllowGripperResize(BOOL bAllowResize) {
    m_bAllowResize = bAllowResize;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::Create Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::Create Method

This method creates the ShortcutBar control

BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
);
Parameters

dwStyle
Style for the ShortcutBar.
rect
Specifies the size and position of the ShortcutBar control.
pParentWnd
Specifies the parent window of the ShortcutBar control.
nID
Specifies the ShortcutBar control ID.

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::FindItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::FindItem Method

Call this method to find an item with the specified identifier.

CXTPShortcutBarItem* FindItem(
    int nID
) const;
Parameters

nID
Identifier of the item needed to find.

Returns

A pointer to a CXTPShortcutBarItem object.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetClientPaneRect Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::GetClientPaneRect Method

Retrieves bounding rectangle of shortcut bar client

CRect GetClientPaneRect() const;
Returns

Bounding rectangle of shortcut bar client

Body Source
CRect CXTPShortcutBar::GetClientPaneRect() const {
    return m_rcClient;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetCollapsedItemsCount Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::GetCollapsedItemsCount Method

Call this method to determine the number of collapsed items

int GetCollapsedItemsCount() const;
Returns

Number of collapsed items

Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetCurrentTheme Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::GetCurrentTheme Method

Call this member to get the current visual theme.

XTPShortcutBarPaintTheme GetCurrentTheme() const;
Returns

The current theme.

See Also

SetTheme, SetCustomTheme, XTPShortcutBarPaintTheme

Body Source
XTPShortcutBarPaintTheme CXTPShortcutBar::GetCurrentTheme() const{
    return m_paintTheme;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetExpandedLinesCount Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::GetExpandedLinesCount Method

This method determines the count of visible lines in the ShortcutBar control.

int GetExpandedLinesCount() const;
Returns

Count of visible lines

See Also

SetExpandedLinesCount

Body Source
int CXTPShortcutBar::GetExpandedLinesCount() const{
    return m_nExpandedLines;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetExpandedLinesHeight Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::GetExpandedLinesHeight Method

This method determines the height of visible lines in the ShortcutBar control.

int GetExpandedLinesHeight() const;
Returns

Height of visible lines

See Also

SetExpandedLinesHeight

Body Source
int CXTPShortcutBar::GetExpandedLinesHeight() const {
    return m_nDesiredExpandedLinesHeight;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetGripperRect Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::GetGripperRect Method

Call this method to determine gripper rectangle.

CRect GetGripperRect() const;
Returns

CRect object contains gripper bounding rectangle.

Body Source
CRect CXTPShortcutBar::GetGripperRect() const {
    return m_rcGripper;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetHotItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::GetHotItem Method

Returns the hot item in the ShortcutBar control.

CXTPShortcutBarItem* GetHotItem() const;
Returns

Pointer to the hot item.

Body Source
CXTPShortcutBarItem* CXTPShortcutBar::GetHotItem() const {
    return m_pHotItem;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetImageManager Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, See Also
CXTPShortcutBar::GetImageManager Method

Call this method to get a pointer to the image manager of shortcut bar control.

CXTPImageManager* GetImageManager() const;
Returns

Pointer to the image manager of shortcut bar control.

Remarks

The image manager is used to hold all of the icons displayed in the shortcut bar control.

See Also

SetImageManager

Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::GetItem Method

This method retrieves an item with specified index.

CXTPShortcutBarItem* GetItem(
    int nIndex
) const;
Parameters

nIndex
Specifies the zero-based index of the item to retrieve.

Returns

A pointer to a CXTPShortcutBarItem object.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetItemCount Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::GetItemCount Method

Call this member to determine how many CXTPShortcutBarItem(s) are int he shortcut bar.

int GetItemCount() const;
Returns

Number of shortcut bar items in the shortcut bar.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetItemSize Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::GetItemSize Method

Call this method to get size of items

CSize GetItemSize() const;
Returns

CSize object contains size of items

Body Source
CSize CXTPShortcutBar::GetItemSize() const {
    return m_szItem;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetPaintManager Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::GetPaintManager Method

Call this member to get the current paint manager.

CXTPShortcutBarPaintManager* GetPaintManager() const;
Returns

The current paint manager.

Body Source
CXTPShortcutBarPaintManager* CXTPShortcutBar::GetPaintManager() const{
    return m_pPaintManager;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetPressedItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::GetPressedItem Method

Returns the pressed item in the ShortcutBar control.

CXTPShortcutBarItem* GetPressedItem() const;
Returns

Pointer to the pressed item.

Body Source
CXTPShortcutBarItem* CXTPShortcutBar::GetPressedItem() const {
    return m_pPressedItem;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetSelectedItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::GetSelectedItem Method

Returns the selected item in the ShortcutBar control.

CXTPShortcutBarItem* GetSelectedItem() const;
Returns

Pointer to the selected item.

Body Source
CXTPShortcutBarItem* CXTPShortcutBar::GetSelectedItem() const {
    return m_pSelectedItem;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetToolTipContext Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::GetToolTipContext Method

Call this method to get tooltip context pointer.

CXTPToolTipContext* GetToolTipContext() const;
Group

CXTPShortcutBar Methods


CXTPShortcutBar::GetVisibleItemsCount Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::GetVisibleItemsCount Method

Call this method to determine the number of visible items

int GetVisibleItemsCount() const;
Returns

Number of visible items

Group

CXTPShortcutBar Methods


CXTPShortcutBar::HitTest Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::HitTest Method

This method determines where a point lies in a specified item.

CXTPShortcutBarItem* HitTest(
    CPoint pt
) const;
Parameters

pt
Specifies the point to be tested.

Returns

A pointer to a CXTPShortcutBarItem item that occupies the specified point or NULL if no item occupies the point.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::IsAllowFreeResize Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::IsAllowFreeResize Method

Determines if gripper allowed to resize by pixel.

BOOL IsAllowFreeResize() const;
See Also

ShowActiveItemOnTop

Body Source
BOOL CXTPShortcutBar::IsAllowFreeResize() const {
    return m_bAllowFreeResize;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::IsClientPaneVisible Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::IsClientPaneVisible Method

Determines visibility of client pane.

BOOL IsClientPaneVisible() const;
Returns

TRUE if client pane is visible.

Body Source
BOOL CXTPShortcutBar::IsClientPaneVisible() const{
    return m_bClientPaneVisible;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::IsExpandButtonVisible Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::IsExpandButtonVisible Method

Determines if expand button visible

BOOL IsExpandButtonVisible() const;
Returns

TRUE if expand button is visible; otherwise FALSE;

Group

CXTPShortcutBar Methods


CXTPShortcutBar::IsShowActiveItemOnTop Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::IsShowActiveItemOnTop Method

Call this method to get ShowActiveItemOnTop property of control.

BOOL IsShowActiveItemOnTop() const;
See Also

ShowActiveItemOnTop

Body Source
BOOL CXTPShortcutBar::IsShowActiveItemOnTop() const {
    return m_bShowActiveItemOnTop;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::IsSingleSelection Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::IsSingleSelection Method

Call this method to get Single Selection property of control.

BOOL IsSingleSelection() const;
See Also

SetSingleSelection, SetSelectItemOnFocus

Body Source
BOOL CXTPShortcutBar::IsSingleSelection() const{
    return m_bSingleSelection;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::LoadState Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::LoadState Method

Call this function to retrieve state information from the registry or .INI file.

void LoadState(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::OnExpandButtonDown Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::OnExpandButtonDown Method

This method is called when expand button is pressed.

virtual void OnExpandButtonDown(
    CXTPShortcutBarItem* pExpandButton
);
Parameters

pExpandButton
A pointer to expand button.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::OnRepositionDone Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::OnRepositionDone Method

This method is called when reposition is done.

virtual void OnRepositionDone();
Group

CXTPShortcutBar Methods


CXTPShortcutBar::RedrawControl Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::RedrawControl Method

Call this method to redraw control.

void RedrawControl();
Group

CXTPShortcutBar Methods


CXTPShortcutBar::RegisterWindowClass Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::RegisterWindowClass Method

Register the window class if it has not already been registered.

BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

TRUE if the window class was successfully registered.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::RemoveAllItems Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::RemoveAllItems Method

Call this method to remove all items.

void RemoveAllItems();
Group

CXTPShortcutBar Methods


CXTPShortcutBar::RemoveItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::RemoveItem Method

Call this method to remove the item.

void RemoveItem(
    int nID
);
Parameters

nID
Identifier of the item to delete.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::Reposition Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::Reposition Method

Call this method to reposition items.

void Reposition();
Group

CXTPShortcutBar Methods


CXTPShortcutBar::SaveState Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::SaveState Method

Call this function to save the state information to the registry or .INI file.

void SaveState(
    LPCTSTR lpszProfileName
);
Parameters

lpszProfileName
Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::SelectItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::SelectItem Method

Call this method to select the specified item.

void SelectItem(
    CXTPShortcutBarItem* pItem
);
Parameters

pItem
Item to be selected.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetClientPaneVisible Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::SetClientPaneVisible Method

Call this member to show or hide client pane.

void SetClientPaneVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE to show client pane; FALSE to hide.

Body Source
void CXTPShortcutBar::SetClientPaneVisible(BOOL bVisible) {
    m_bClientPaneVisible = bVisible;
    Reposition();
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetCustomTheme Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, See Also
CXTPShortcutBar::SetCustomTheme Method

Call this member to set a custom theme.

void SetCustomTheme(
    CXTPShortcutBarPaintManager* pPaintManager
);
Parameters

pPaintManager
New paint manager.

See Also

GetCurrentTheme, SetTheme, XTPShortcutBarPaintTheme

Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetExpandedLinesCount Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, See Also
CXTPShortcutBar::SetExpandedLinesCount Method

This method sets the count of lines that are visible in the ShortcutBar control.

void SetExpandedLinesCount(
    int nCount
);
Parameters

nCount
Number of visible lines.

See Also

GetExpandedLinesCount

Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetExpandedLinesHeight Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, See Also
CXTPShortcutBar::SetExpandedLinesHeight Method

This method sets the the height of lines that are visible in the ShortcutBar control.

void SetExpandedLinesHeight(
    int nHeight
);
Parameters

nHeight
Height of visible lines.

See Also

SetExpandedLinesCount, GetExpandedLinesCount

Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetHotItem Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::SetHotItem Method

Call this method to set hot item.

void SetHotItem(
    CXTPShortcutBarItem* pItem
);
Parameters

pItem
Item to be hot.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetImageManager Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::SetImageManager Method

Call this method to set new image manager.

void SetImageManager(
    CXTPImageManager* pImageManager
);
Parameters

pImageManager
Points to a CXTPImageManager object to be set

See Also

GetImageManager

Example
    CXTPImageManager* pImageManager = new CXTPImageManager();
    pImageManager->SetIcons(IDR_MAINFRAME);
    m_wndShortcutBar.SetImageManager(pImageManager);
Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetItemSize Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::SetItemSize Method

Call this method to set size of items

void SetItemSize(
    CSize szItem
);
Parameters

szItem
Size of the item.

Body Source
void CXTPShortcutBar::SetItemSize(CSize szItem) {
    m_szItem = szItem;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetLayoutRTL Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::SetLayoutRTL Method

Call this member to set right-to-left mode.

void SetLayoutRTL(
    BOOL bRightToLeft
);
Parameters

bRightToLeft
TRUE to set right-to-left reading-order properties.

Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetMinimumClientHeight Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::SetMinimumClientHeight Method

This method sets the minimum height of the client area in a ShortcutBar control. The default value is 200.

void SetMinimumClientHeight(
    int nMinHeight
);
Parameters

nMinHeight
Specifies the minimum height in pixels of the client.

Body Source
void CXTPShortcutBar::SetMinimumClientHeight(int nMinHeight) {
    m_nMinClientHeight = nMinHeight;
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetSingleSelection Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::SetSingleSelection Method

Call this method to allow only one item to be selected.

void SetSingleSelection(
    BOOL bSingleSelection = TRUE
);
Parameters

bSingleSelection
TRUE to use single selection.

See Also

IsSingleSelection, SetSelectItemOnFocus

Body Source
void CXTPShortcutBar::SetSingleSelection(BOOL bSingleSelection) {
    m_bSingleSelection = bSingleSelection;
    Reposition();
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::SetTheme Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, See Also
CXTPShortcutBar::SetTheme Method

Call this member to switch the visual theme of the ShortcutBar control.

void SetTheme(
    XTPShortcutBarPaintTheme paintTheme
);
Parameters

paintTheme
New visual theme. Can be any of the values listed in the Remarks section.

Remarks

paintTheme can be one of the following:

  • xtpShortcutThemeOffice2000 Enables Office 2000 style theme.
  • xtpShortcutThemeOfficeXP Enables Office XP style theme.
  • xtpShortcutThemeOffice2003 Enables Office 2003 style theme.
  • xtpTaskPanelThemeShortcutBarOffice2007 Enables Office 2007 style theme.
See Also

GetCurrentTheme, SetCustomTheme, XTPShortcutBarPaintTheme

Group

CXTPShortcutBar Methods


CXTPShortcutBar::ShowActiveItemOnTop Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBar::ShowActiveItemOnTop Method

Call this method to show active item on top of controls

void ShowActiveItemOnTop(
    BOOL bActiveItemOnTop
);
Parameters

bActiveItemOnTop
TRUE to show active item on top of controls

See Also

IsShowActiveItemOnTop

Body Source
void CXTPShortcutBar::ShowActiveItemOnTop(BOOL bActiveItemOnTop) {
    m_bShowActiveItemOnTop = bActiveItemOnTop;
    Reposition();
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar::ShowExpandButton Method

CXTPShortcutBar Methods, CXTPShortcutBar Class
CXTPShortcutBar::ShowExpandButton Method

Call this method to show/hide expand button

void ShowExpandButton(
    BOOL bShow
);
Parameters

bShow
TRUE to show; FALSE to hide

Group

CXTPShortcutBar Methods


CXTPShortcutBar::ShowGripper Method

CXTPShortcutBar Methods, CXTPShortcutBar Class, Body Source
CXTPShortcutBar::ShowGripper Method

Call this method to show gripper.

void ShowGripper(
    BOOL bShowGripper
);
Parameters

bShowGripper
TRUE to show gripper; FALSE to hide

Body Source
void CXTPShortcutBar::ShowGripper(BOOL bShowGripper) {
    m_bShowGripper = bShowGripper;
    Reposition();
}
Group

CXTPShortcutBar Methods


CXTPShortcutBar Constructors

CXTPShortcutBar Class, Legend, Public Methods
CXTPShortcutBar Constructors
Class

CXTPShortcutBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBar | Constructs a CXTPShortcutBar object.


CXTPShortcutBar::CXTPShortcutBar Constructor

CXTPShortcutBar Constructors, CXTPShortcutBar Class
CXTPShortcutBar::CXTPShortcutBar Constructor

Constructs a CXTPShortcutBar object.

CXTPShortcutBar();
Group

CXTPShortcutBar Constructors


CXTPShortcutBar Destructors

CXTPShortcutBar Class, Legend, Public Methods
CXTPShortcutBar Destructors
Class

CXTPShortcutBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPShortcutBar | Destroys a CXTPShortcutBar object, handles cleanup and deallocation.


CXTPShortcutBar::~CXTPShortcutBar Destructor

CXTPShortcutBar Destructors, CXTPShortcutBar Class
CXTPShortcutBar::~CXTPShortcutBar Destructor

Destroys a CXTPShortcutBar object, handles cleanup and deallocation.

virtual ~CXTPShortcutBar();
Group

CXTPShortcutBar Destructors


CXTPShortcutBar Nested Types

CXTPShortcutBar Class, Public Nested Types
CXTPShortcutBar Nested Types
Class

CXTPShortcutBar Class

Public Nested Types
Public Nested Type | Description
CShortcutArray | Array of CXTPShortcutBarItem objects


CXTPShortcutBar::CShortcutArray Nested Type

CXTPShortcutBar Nested Types, CXTPShortcutBar Class
CXTPShortcutBar::CShortcutArray Nested Type

Array of CXTPShortcutBarItem objects

typedef CArray<CXTPShortcutBarItem*, CXTPShortcutBarItem*> CShortcutArray;
Group

CXTPShortcutBar Nested Types


CXTPShortcutBarItem Class

XTPShortcutBar.h, Classes, Legend, Members, Topics, CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Methods, CXTPShortcutBarItem Constructors, CXTPShortcutBarItem Constructors, CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem Class

CXTPShortcutBarItem is the base class representing an item of the ShortcutBar Control.

Class Hierarchy

class CXTPShortcutBarItem;
File

XTPShortcutBar.h

Group

Classes

Legend
Data Member
protected
Method
CXTPShortcutBarItem Constructors
CXTPShortcutBarItem Constructors | Description
CXTPShortcutBarItem |
CXTPShortcutBarItem Data Members
CXTPShortcutBarItem Data Members | Description
m_bExpandButton | True if the item is expand button
m_bExpanded | TRUE if the item is expanded
m_bHidden | TRUE if the item is hidden
m_bSelected | TRUE if item selected
m_bVisible | TRUE if the item is visible
m_dwData | The 32-bit value associated with the item
m_hwndChild | Child window associated with the item
m_nIconId | Identifier of the item's image.
m_nID | Item's identifier.
m_pShortcutBar | Parent CXTPShortcutBar class
m_rcItem | Bounding rectangle of the item
m_strCaption | Caption for the item.
m_strTooltip | Tooltip for the item.
CXTPShortcutBarItem Methods
CXTPShortcutBarItem Methods | Description
GetCaption | Call this method to get the caption of the item.
GetClientWindow | Call this member to get child window of the item.
GetIconId | Call this member to get the icon's identifier.
GetID | Call this method to get the identifier of the item.
GetImage | Call this method to retrieve the image of this shortcut bar item.
GetItemData | This method retrieves the application-supplied 32-bit value associated with the item
GetItemRect | This method retrieves the dimensions of the rectangle that bounds the item.
GetShortcutBar | Call this member function to get the parent ShortcutBar class.
GetTooltip | Retrieves the ToolTip text associated with the item.
IsExpanded | Call this member function to determine if the item is expanded.
IsHidden | Call this member function to determine is the ShortcutBarItem is hidden. An item is hidden when there are more items then can be displayed in the bottom shortcut bar. As the shortcut bar is expanded, items that were hidden will become visible as more items are added to the expanded shortcut bar.
IsItemExpandButton | Call this member function to determine if the item is expand button.
IsSelected | Call this member to determine if the item is currently selected. Note that multiple items can be selected at one time, but only one can have focus.
IsVisible | Call this member function to determine if the item is visible.
SetCaption | Call this method to set the caption of the item.
SetClientWindow | Call this member to set child window that will be visible in client part of the shortcutbar when item is selected.
SetIconId | Call this member to set the icon's identifier.
SetID | Call this method to set the identifier of the item.
SetItemData | This method sets the 32-bit value associated with the item.
SetSelected | Call this member to select this item. Multiple items can have focus if CXTPShortcutBar::m_bSingleSelection is FALSE.
SetTooltip | Associates ToolTip text with the item.
SetVisible | Call this member function to set the visibility state of the item.


CXTPShortcutBarItem Data Members

CXTPShortcutBarItem Class, Legend, Protected Data Members
CXTPShortcutBarItem Data Members
Class

CXTPShortcutBarItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bExpandButton | True if the item is expand button
m_bExpanded | TRUE if the item is expanded
m_bHidden | TRUE if the item is hidden
m_bSelected | TRUE if item selected
m_bVisible | TRUE if the item is visible
m_dwData | The 32-bit value associated with the item
m_hwndChild | Child window associated with the item
m_nIconId | Identifier of the item's image.
m_nID | Item's identifier.
m_pShortcutBar | Parent CXTPShortcutBar class
m_rcItem | Bounding rectangle of the item
m_strCaption | Caption for the item.
m_strTooltip | Tooltip for the item.


CXTPShortcutBarItem::m_bExpandButton Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_bExpandButton Data Member

True if the item is expand button

BOOL m_bExpandButton;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_bExpanded Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_bExpanded Data Member

TRUE if the item is expanded

BOOL m_bExpanded;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_bHidden Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_bHidden Data Member

TRUE if the item is hidden

BOOL m_bHidden;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_bSelected Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_bSelected Data Member

TRUE if item selected

BOOL m_bSelected;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_bVisible Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_bVisible Data Member

TRUE if the item is visible

BOOL m_bVisible;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_dwData Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_dwData Data Member

The 32-bit value associated with the item

DWORD_PTR m_dwData;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_hwndChild Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_hwndChild Data Member

Child window associated with the item

HWND m_hwndChild;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_nIconId Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_nIconId Data Member

Identifier of the item's image.

int m_nIconId;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_nID Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_nID Data Member

Item's identifier.

int m_nID;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_pShortcutBar Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_pShortcutBar Data Member

Parent CXTPShortcutBar class

CXTPShortcutBar* m_pShortcutBar;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_rcItem Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_rcItem Data Member

Bounding rectangle of the item

CRect m_rcItem;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_strCaption Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_strCaption Data Member

Caption for the item.

CString m_strCaption;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem::m_strTooltip Data Member

CXTPShortcutBarItem Data Members, CXTPShortcutBarItem Class
CXTPShortcutBarItem::m_strTooltip Data Member

Tooltip for the item.

CString m_strTooltip;
Group

CXTPShortcutBarItem Data Members


CXTPShortcutBarItem Methods

CXTPShortcutBarItem Class, Legend, Public Methods
CXTPShortcutBarItem Methods
Class

CXTPShortcutBarItem Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetCaption | Call this method to get the caption of the item.
GetClientWindow | Call this member to get child window of the item.
GetIconId | Call this member to get the icon's identifier.
GetID | Call this method to get the identifier of the item.
GetImage | Call this method to retrieve the image of this shortcut bar item.
GetItemData | This method retrieves the application-supplied 32-bit value associated with the item
GetItemRect | This method retrieves the dimensions of the rectangle that bounds the item.
GetShortcutBar | Call this member function to get the parent ShortcutBar class.
GetTooltip | Retrieves the ToolTip text associated with the item.
IsExpanded | Call this member function to determine if the item is expanded.
IsHidden | Call this member function to determine is the ShortcutBarItem is hidden. An item is hidden when there are more items then can be displayed in the bottom shortcut bar. As the shortcut bar is expanded, items that were hidden will become visible as more items are added to the expanded shortcut bar.
IsItemExpandButton | Call this member function to determine if the item is expand button.
IsSelected | Call this member to determine if the item is currently selected. Note that multiple items can be selected at one time, but only one can have focus.
IsVisible | Call this member function to determine if the item is visible.
SetCaption | Call this method to set the caption of the item.
SetClientWindow | Call this member to set child window that will be visible in client part of the shortcutbar when item is selected.
SetIconId | Call this member to set the icon's identifier.
SetID | Call this method to set the identifier of the item.
SetItemData | This method sets the 32-bit value associated with the item.
SetSelected | Call this member to select this item. Multiple items can have focus if CXTPShortcutBar::m_bSingleSelection is FALSE.
SetTooltip | Associates ToolTip text with the item.
SetVisible | Call this member function to set the visibility state of the item.


CXTPShortcutBarItem::GetCaption Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::GetCaption Method

Call this method to get the caption of the item.

CString GetCaption() const;
Returns

A CString object containing the caption of the item.

Body Source
CString CXTPShortcutBarItem::GetCaption() const{
    return m_strCaption;
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::GetClientWindow Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::GetClientWindow Method

Call this member to get child window of the item.

CWnd* GetClientWindow() const;
Returns

CWnd pointer to child window

Body Source
CWnd* CXTPShortcutBarItem::GetClientWindow() const {
    return CWnd::FromHandle(m_hwndChild);
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::GetIconId Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::GetIconId Method

Call this member to get the icon's identifier.

int GetIconId() const;
Returns

An icon's identifier of the item.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::GetID Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::GetID Method

Call this method to get the identifier of the item.

int GetID() const;
Returns

Identifier of the item.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::GetImage Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::GetImage Method

Call this method to retrieve the image of this shortcut bar item.

CXTPImageManagerIcon* GetImage(
    int nWidth
) const;
Parameters

nWidth
Width of the icon to be retrieved. (CXTPImageManagerIcon can have multiple image sizes for the same item, the shortcut bar uses both 16x16 and 24x24 images depending on if the item is displayed in the extended shortcut list). If a 16x16 icon is to be retrieved, then pass in 16 for the width.

Returns

A pointer the CXTPImageManagerIcon object for this shortcut bar item.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::GetItemData Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::GetItemData Method

This method retrieves the application-supplied 32-bit value associated with the item

DWORD_PTR GetItemData() const;
Returns

The 32-bit value associated with the item

Body Source
DWORD_PTR CXTPShortcutBarItem::GetItemData() const {
    return m_dwData;
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::GetItemRect Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::GetItemRect Method

This method retrieves the dimensions of the rectangle that bounds the item.

CRect GetItemRect() const;
Returns

CRect object contains the bounding rectangle of the item.

Body Source
CRect CXTPShortcutBarItem::GetItemRect() const {
    return m_rcItem;
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::GetShortcutBar Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::GetShortcutBar Method

Call this member function to get the parent ShortcutBar class.

CXTPShortcutBar* GetShortcutBar() const;
Returns

A Pointer to the parent CXTPShortcutBar class.

Body Source
CXTPShortcutBar* CXTPShortcutBarItem::GetShortcutBar() const {
    return m_pShortcutBar;
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::GetTooltip Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::GetTooltip Method

Retrieves the ToolTip text associated with the item.

CString GetTooltip() const;
Returns

The ToolTip text for the item.

Body Source
CString CXTPShortcutBarItem::GetTooltip() const{
    return m_strTooltip;
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::IsExpanded Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::IsExpanded Method

Call this member function to determine if the item is expanded.

BOOL IsExpanded() const;
Returns

TRUE if the item is expanded; otherwise FALSE.

Body Source
BOOL CXTPShortcutBarItem::IsExpanded() const {
    return m_bExpanded;
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::IsHidden Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::IsHidden Method

Call this member function to determine is the ShortcutBarItem is hidden. An item is hidden when there are more items then can be displayed in the bottom shortcut bar. As the shortcut bar is expanded, items that were hidden will become visible as more items are added to the expanded shortcut bar.

BOOL IsHidden() const;
Returns

TRUE is the ShortcutBarItem is hidden, otherwise FALSE

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::IsItemExpandButton Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::IsItemExpandButton Method

Call this member function to determine if the item is expand button.

BOOL IsItemExpandButton() const;
Returns

TRUE if the item is expand button; otherwise FALSE.

Body Source
BOOL CXTPShortcutBarItem::IsItemExpandButton() const{
    return m_bExpandButton;
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::IsSelected Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::IsSelected Method

Call this member to determine if the item is currently selected. Note that multiple items can be selected at one time, but only one can have focus.

BOOL IsSelected() const;
Returns

TRUE if the item is currently selected.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::IsVisible Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::IsVisible Method

Call this member function to determine if the item is visible.

BOOL IsVisible() const;
Returns

TRUE if the item is visible; otherwise FALSE.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::SetCaption Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::SetCaption Method

Call this method to set the caption of the item.

void SetCaption(
    LPCTSTR strCaption
);
Parameters

strCaption
The new caption of the item.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::SetClientWindow Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::SetClientWindow Method

Call this member to set child window that will be visible in client part of the shortcutbar when item is selected.

void SetClientWindow(
    CWnd* pWnd
);
Parameters

pWnd
New child window to be set.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::SetIconId Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::SetIconId Method

Call this member to set the icon's identifier.

void SetIconId(
    int nId
);
Parameters

nId
Icon's identifier to be set.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::SetID Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::SetID Method

Call this method to set the identifier of the item.

void SetID(
    int nID
);
Parameters

nID
The new identifier of the item.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::SetItemData Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarItem::SetItemData Method

This method sets the 32-bit value associated with the item.

void SetItemData(
    DWORD_PTR dwData
);
Parameters

dwData
Contains the new value to associate with the item.

Body Source
void CXTPShortcutBarItem::SetItemData(DWORD_PTR dwData) {
    m_dwData = dwData;
}
Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::SetSelected Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::SetSelected Method

Call this member to select this item. Multiple items can have focus if CXTPShortcutBar::m_bSingleSelection is FALSE.

void SetSelected(
    BOOL bSelected
);
Parameters

bSelected
TRUE if the item will be selected, FALSE to no longer select the item.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::SetTooltip Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::SetTooltip Method

Associates ToolTip text with the item.

void SetTooltip(
    LPCTSTR strTooltip
);
Parameters

strTooltip
The ToolTip text to display when the mouse cursor is over the item.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem::SetVisible Method

CXTPShortcutBarItem Methods, CXTPShortcutBarItem Class
CXTPShortcutBarItem::SetVisible Method

Call this member function to set the visibility state of the item.

void SetVisible(
    BOOL bVisible
);
Parameters

bVisible
TRUE if the item is visible; otherwise FALSE.

Group

CXTPShortcutBarItem Methods


CXTPShortcutBarItem Constructors

CXTPShortcutBarItem Class, Legend, Protected Methods
CXTPShortcutBarItem Constructors
Class

CXTPShortcutBarItem Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPShortcutBarItem |


CXTPShortcutBarItem Constructor

CXTPShortcutBarItem Constructors
CXTPShortcutBarItem Constructor
Overload List
Constructors
Constructor | Description
CXTPShortcutBarItem::CXTPShortcutBarItem (CXTPShortcutBar*) | Constructs a CXTPShortcutBarItem object.
CXTPShortcutBarItem::CXTPShortcutBarItem (CXTPShortcutBar*, UINT, CWnd*) | Constructs a CXTPShortcutBarItem object.
Group

CXTPShortcutBarItem Constructors


CXTPShortcutBarItem::CXTPShortcutBarItem Constructor (CXTPShortcutBar*)

CXTPShortcutBarItem Constructor, CXTPShortcutBarItem Class
CXTPShortcutBarItem::CXTPShortcutBarItem Constructor (CXTPShortcutBar*)

Constructs a CXTPShortcutBarItem object.

CXTPShortcutBarItem(
    CXTPShortcutBar* pShortcutBar
);
CXTPShortcutBarItem(
    CXTPShortcutBar* pShortcutBar,
    UINT nID,
    CWnd* pWnd
);
Parameters

pShortcutBar
Points to the parent ShortcutBar class. Points to the parent ShortcutBar class.
nID
Identifier of the item.
pWnd
Client window of the item

Group

CXTPShortcutBarItem Constructor


CXTPShortcutBarOffice2000Theme Class

XTPShortcutBarPaintManager.h, Classes, Legend, Members, Topics, CXTPShortcutBarOffice2000Theme Methods, CXTPShortcutBarOffice2000Theme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2000Theme Class

CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.

Class Hierarchy

class CXTPShortcutBarOffice2000Theme : public CXTPShortcutBarPaintManager;
File

XTPShortcutBarPaintManager.h

Group

Classes

Legend
Method
CXTPShortcutBarOffice2000Theme Methods
CXTPShortcutBarOffice2000Theme Methods | Description
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawImage | This method is called to draw the image of a Shortcut Bar item.
DrawShortcutBarFrame | This method is called to draw the frame of the ShortcutBar control.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control.
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control.
Line | This method is called to draw the "gripper" lines in the gripper.
Rectangle | This method is called to draw a rectangle. The rectangle is used to draw the shortcut items.


CXTPShortcutBarOffice2000Theme Methods

CXTPShortcutBarOffice2000Theme Class, Legend, Public Methods
CXTPShortcutBarOffice2000Theme Methods
Class

CXTPShortcutBarOffice2000Theme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawImage | This method is called to draw the image of a Shortcut Bar item.
DrawShortcutBarFrame | This method is called to draw the frame of the ShortcutBar control.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control.
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control.
Line | This method is called to draw the "gripper" lines in the gripper.
Rectangle | This method is called to draw a rectangle. The rectangle is used to draw the shortcut items.


CXTPShortcutBarOffice2000Theme::DrawGripper Method

CXTPShortcutBarOffice2000Theme Methods, CXTPShortcutBarOffice2000Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2000Theme::DrawGripper Method

This method is called to draw gripper of the ShortcutBar control

int DrawGripper(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control
bDraw
TRUE to draw, FALSE to determine size of the gripper.

Returns

Size of the gripper, which is 4 pixels for the Office 2000 theme.

Group

CXTPShortcutBarOffice2000Theme Methods


CXTPShortcutBarOffice2000Theme::DrawImage Method

CXTPShortcutBarOffice2000Theme Methods, CXTPShortcutBarOffice2000Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2000Theme::DrawImage Method

This method is called to draw the image of a Shortcut Bar item.

void DrawImage(
    CDC* pDC,
    CPoint pt,
    CSize sz,
    CXTPImageManagerIcon* pImage,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked
);
Parameters

pDC
Points to the client device context.
pt
Location at which to draw the image within the specified device context.
sz
Size of the image.
pImage
Points to a CXTPImageManagerIcon object.
bSelected
TRUE if the shortcut bar item is selectedhas focus. I.e. When the user clicks on the item.
bPressed
TRUE if the shortcut bar item is currently pressed. I.e. The user is clicking on the item.
bChecked
TRUE if the shortcut bar item is checked. I.e. toggle buttons.

Remarks

This member draws the image of a shortcut bar item. The DrawShortcutItem method uses this method to draw shortcut bar images.

Group

CXTPShortcutBarOffice2000Theme Methods


CXTPShortcutBarOffice2000Theme::DrawShortcutBarFrame Method

CXTPShortcutBarOffice2000Theme Methods, CXTPShortcutBarOffice2000Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2000Theme::DrawShortcutBarFrame Method

This method is called to draw the frame of the ShortcutBar control.

void DrawShortcutBarFrame(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control.

Remarks

This is the border that is drawn around the entire shortcut bar.

Group

CXTPShortcutBarOffice2000Theme Methods


CXTPShortcutBarOffice2000Theme::FillShortcutBar Method

CXTPShortcutBarOffice2000Theme Methods, CXTPShortcutBarOffice2000Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2000Theme::FillShortcutBar Method

This method is called to fill the client area of the ShortcutBar control.

void FillShortcutBar(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control.

Group

CXTPShortcutBarOffice2000Theme Methods


CXTPShortcutBarOffice2000Theme::FillShortcutItemEntry Method

CXTPShortcutBarOffice2000Theme Methods, CXTPShortcutBarOffice2000Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2000Theme::FillShortcutItemEntry Method

This method is called to draw the specified item of the ShortcutBar control.

void FillShortcutItemEntry(
    CDC* pDC,
    CXTPShortcutBarItem* pItem
);
Parameters

pDC
Points to the client device context.
pItem
Item to be drawn.

Group

CXTPShortcutBarOffice2000Theme Methods


CXTPShortcutBarOffice2000Theme::Line Method

CXTPShortcutBarOffice2000Theme Methods, CXTPShortcutBarOffice2000Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2000Theme::Line Method

This method is called to draw the "gripper" lines in the gripper.

void Line(
    CDC* pDC,
    int x0,
    int y0,
    int x1,
    int y1,
    int nPen
);
Parameters

pDC
Points to the client device context.
x0
Specifies the logical x-coordinate of the start position.
y0
Specifies the logical y-coordinate of the start position.
x1
Specifies the logical x-coordinate of the endpoint for the line.
y1
Specifies the logical y-coordinate of the endpoint for the line.
nPen
Specifies the color used to paint the line.

Group

CXTPShortcutBarOffice2000Theme Methods


CXTPShortcutBarOffice2000Theme::Rectangle Method

CXTPShortcutBarOffice2000Theme Methods, CXTPShortcutBarOffice2000Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2000Theme::Rectangle Method

This method is called to draw a rectangle. The rectangle is used to draw the shortcut items.

void Rectangle(
    CDC* pDC,
    CRect rc,
    int nPen,
    int nBrush
);
Parameters

pDC
Pointer to a valid device context
rc
Specifies the rectangle in logical units.
nPen
Specifies the color used to paint the rectangle.
nBrush
Specifies the color used to fill the rectangle.

Remarks

Rectangle is used to draw the rectangle of the shortcut bar items in the Office XP theme. This will draw the normal, pressed, and hot versions of the item.

Group

CXTPShortcutBarOffice2000Theme Methods


CXTPShortcutBarOffice2003Theme Class

XTPShortcutBarPaintManager.h, Classes, Legend, Members, Topics, CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Constructors, CXTPShortcutBarOffice2003Theme Constructors, CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme Class

CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.

Class Hierarchy

class CXTPShortcutBarOffice2003Theme : public CXTPShortcutBarPaintManager;
File

XTPShortcutBarPaintManager.h

Group

Classes

Legend
Data Member
Method
CXTPShortcutBarOffice2003Theme Constructors
CXTPShortcutBarOffice2003Theme Constructors | Description
CXTPShortcutBarOffice2003Theme | Constructs a CXTPShortcutBarOffice2003Theme object.
CXTPShortcutBarOffice2003Theme Data Members
CXTPShortcutBarOffice2003Theme Data Members | Description
m_bShowTopLeftCaptionShadow | True to draw rectangle around items
m_clrCaptionText | Color of items text
m_clrItemCaptionShadow | Color of subcaption shadow
m_clrItemCaptionText | Color of subcaption text
m_clrItemCaptionTop | Color under subcaption rectangle
m_grcCaption | Caption color
m_grcItemCaption | Items color
m_grcItemHotCaption | Items color
CXTPShortcutBarOffice2003Theme Methods
CXTPShortcutBarOffice2003Theme Methods | Description
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawImage | This method is called to draw the image of a Shortcut Bar item.
DrawPaneCaption | This method is called to draw the caption of the specified pane.
DrawPaneItemCaption | This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.
DrawShortcutBarFrame | This method is called to draw the frame of the ShortcutBar control.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control.
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control.
RefreshMetrics | This method is called to refresh the visual metrics of the shortcut bar paint manager.


CXTPShortcutBarOffice2003Theme Data Members

CXTPShortcutBarOffice2003Theme Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme Data Members
Class

CXTPShortcutBarOffice2003Theme Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bShowTopLeftCaptionShadow | True to draw rectangle around items
m_clrCaptionText | Color of items text
m_clrItemCaptionShadow | Color of subcaption shadow
m_clrItemCaptionText | Color of subcaption text
m_clrItemCaptionTop | Color under subcaption rectangle
m_grcCaption | Caption color
m_grcItemCaption | Items color
m_grcItemHotCaption | Items color


CXTPShortcutBarOffice2003Theme::m_bShowTopLeftCaptionShadow Data Member

CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::m_bShowTopLeftCaptionShadow Data Member

True to draw rectangle around items

BOOL m_bShowTopLeftCaptionShadow;
Group

CXTPShortcutBarOffice2003Theme Data Members


CXTPShortcutBarOffice2003Theme::m_clrCaptionText Data Member

CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::m_clrCaptionText Data Member

Color of items text

CXTPPaintManagerColor m_clrCaptionText;
Group

CXTPShortcutBarOffice2003Theme Data Members


CXTPShortcutBarOffice2003Theme::m_clrItemCaptionShadow Data Member

CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::m_clrItemCaptionShadow Data Member

Color of subcaption shadow

CXTPPaintManagerColor m_clrItemCaptionShadow;
Group

CXTPShortcutBarOffice2003Theme Data Members


CXTPShortcutBarOffice2003Theme::m_clrItemCaptionText Data Member

CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::m_clrItemCaptionText Data Member

Color of subcaption text

CXTPPaintManagerColor m_clrItemCaptionText;
Group

CXTPShortcutBarOffice2003Theme Data Members


CXTPShortcutBarOffice2003Theme::m_clrItemCaptionTop Data Member

CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::m_clrItemCaptionTop Data Member

Color under subcaption rectangle

CXTPPaintManagerColor m_clrItemCaptionTop;
Group

CXTPShortcutBarOffice2003Theme Data Members


CXTPShortcutBarOffice2003Theme::m_grcCaption Data Member

CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::m_grcCaption Data Member

Caption color

CXTPPaintManagerColorGradient m_grcCaption;
Group

CXTPShortcutBarOffice2003Theme Data Members


CXTPShortcutBarOffice2003Theme::m_grcItemCaption Data Member

CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::m_grcItemCaption Data Member

Items color

CXTPPaintManagerColorGradient m_grcItemCaption;
Group

CXTPShortcutBarOffice2003Theme Data Members


CXTPShortcutBarOffice2003Theme::m_grcItemHotCaption Data Member

CXTPShortcutBarOffice2003Theme Data Members, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::m_grcItemHotCaption Data Member

Items color

CXTPPaintManagerColorGradient m_grcItemHotCaption;
Group

CXTPShortcutBarOffice2003Theme Data Members


CXTPShortcutBarOffice2003Theme Methods

CXTPShortcutBarOffice2003Theme Class, Legend, Public Methods
CXTPShortcutBarOffice2003Theme Methods
Class

CXTPShortcutBarOffice2003Theme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawImage | This method is called to draw the image of a Shortcut Bar item.
DrawPaneCaption | This method is called to draw the caption of the specified pane.
DrawPaneItemCaption | This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.
DrawShortcutBarFrame | This method is called to draw the frame of the ShortcutBar control.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control.
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control.
RefreshMetrics | This method is called to refresh the visual metrics of the shortcut bar paint manager.


CXTPShortcutBarOffice2003Theme::DrawGripper Method

CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::DrawGripper Method

This method is called to draw gripper of the ShortcutBar control

int DrawGripper(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control
bDraw
TRUE to draw, FALSE to determine size of the gripper.

Returns

Size of the gripper, which is 7 pixels for the Office 2003 theme.

Group

CXTPShortcutBarOffice2003Theme Methods


CXTPShortcutBarOffice2003Theme::DrawImage Method

CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::DrawImage Method

This method is called to draw the image of a Shortcut Bar item.

void DrawImage(
    CDC* pDC,
    CPoint pt,
    CSize sz,
    CXTPImageManagerIcon* pImage,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked
);
Parameters

pDC
Points to the client device context.
pt
Location at which to draw the image within the specified device context.
sz
Size of the image.
pImage
Points to a CXTPImageManagerIcon object.
bSelected
TRUE if the shortcut bar item is selectedhas focus. I.e. When the user clicks on the item.
bPressed
TRUE if the shortcut bar item is currently pressed. I.e. The user is clicking on the item.
bChecked
TRUE if the shortcut bar item is checked. I.e. toggle buttons.

Remarks

This member draws the image of a shortcut bar item. The DrawShortcutItem method uses this method to draw shortcut bar images.

Group

CXTPShortcutBarOffice2003Theme Methods


CXTPShortcutBarOffice2003Theme::DrawPaneCaption Method

CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::DrawPaneCaption Method

This method is called to draw the caption of the specified pane.

int DrawPaneCaption(
    CDC* pDC,
    CXTPShortcutBarPane* pPane,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pPane
Shortcut Pane to be drawn
bDraw
TRUE to draw pane, FALSE to determine size of the caption

Returns

Size of the caption. Which is 24 pixes.

Remarks

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has it's own caption and is drawn with the DrawPaneItemCaption method.

The caption of the shortcut bar pane is the bar on the top the pane. The caption of the pane is set when the pane is created in the CXTPShortcutBarPane::Create method.

The pane caption can be retrieved with CXTPShortcutBarPane::GetCaption

Shortcut bar pane's have sub-item's which also have a caption that is drawn with the DrawPaneItemCaption method.

Group

CXTPShortcutBarOffice2003Theme Methods


CXTPShortcutBarOffice2003Theme::DrawPaneItemCaption Method

CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::DrawPaneItemCaption Method

This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.

int DrawPaneItemCaption(
    CDC* pDC,
    CXTPShortcutBarPaneItem* pItem,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pItem
Shortcut item pane to be drawn
bDraw
TRUE to draw, FALSE to determine size of the shortcut pane caption.

Returns

Size of the pane item caption. This is retrieved from CXTPShortcutBarPaintManager::m_nPaneItemHeight.

Remarks

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has it's own caption and is drawn with the DrawPaneItemCaption method.

The caption of the pane item is set when the pane item is created in the CXTPShortcutBarPane::AddItem method.

The sub-items of a pane can be retrieved with the CXTPShortcutBarPane::GetItem method.

Group

CXTPShortcutBarOffice2003Theme Methods


CXTPShortcutBarOffice2003Theme::DrawShortcutBarFrame Method

CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::DrawShortcutBarFrame Method

This method is called to draw the frame of the ShortcutBar control.

void DrawShortcutBarFrame(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control.

Remarks

This is the border that is drawn around the entire shortcut bar.

Group

CXTPShortcutBarOffice2003Theme Methods


CXTPShortcutBarOffice2003Theme::FillShortcutBar Method

CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::FillShortcutBar Method

This method is called to fill the client area of the ShortcutBar control.

void FillShortcutBar(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control.

Group

CXTPShortcutBarOffice2003Theme Methods


CXTPShortcutBarOffice2003Theme::FillShortcutItemEntry Method

CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::FillShortcutItemEntry Method

This method is called to draw the specified item of the ShortcutBar control.

void FillShortcutItemEntry(
    CDC* pDC,
    CXTPShortcutBarItem* pItem
);
Parameters

pDC
Points to the client device context.
pItem
Item to be drawn.

Group

CXTPShortcutBarOffice2003Theme Methods


CXTPShortcutBarOffice2003Theme::RefreshMetrics Method

CXTPShortcutBarOffice2003Theme Methods, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of the shortcut bar paint manager.

void RefreshMetrics();
Remarks

This refreshes all the visual metrics of the shortcut bar such as the pane caption color, pane font, pane caption height, etc.

If luna colors are enabled, the the shortcut bar will be colored to match the current system them if the XTPCurrentSystemTheme is xtpSystemThemeBlue, xtpSystemThemeSilver, or xtpSystemThemeOlive.

Group

CXTPShortcutBarOffice2003Theme Methods


CXTPShortcutBarOffice2003Theme Constructors

CXTPShortcutBarOffice2003Theme Class, Legend, Public Methods
CXTPShortcutBarOffice2003Theme Constructors
Class

CXTPShortcutBarOffice2003Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBarOffice2003Theme | Constructs a CXTPShortcutBarOffice2003Theme object.


CXTPShortcutBarOffice2003Theme::CXTPShortcutBarOffice2003Theme Constructor

CXTPShortcutBarOffice2003Theme Constructors, CXTPShortcutBarOffice2003Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2003Theme::CXTPShortcutBarOffice2003Theme Constructor

Constructs a CXTPShortcutBarOffice2003Theme object.

CXTPShortcutBarOffice2003Theme();
Group

CXTPShortcutBarOffice2003Theme Constructors


CXTPShortcutBarOffice2007Theme Class

XTPShortcutBarPaintManager.h, Classes, Legend, Members, Topics, CXTPShortcutBarOffice2007Theme Methods, CXTPShortcutBarOffice2007Theme Constructors, CXTPShortcutBarOffice2007Theme Constructors, CXTPShortcutBarOffice2007Theme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2007Theme Class

CXTPShortcutBarOffice2007Theme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007 shortcut bar theme.

Class Hierarchy

class CXTPShortcutBarOffice2007Theme : public CXTPShortcutBarOffice2003Theme;
File

XTPShortcutBarPaintManager.h

Group

Classes

Legend
Method
virtual
CXTPShortcutBarOffice2007Theme Constructors
CXTPShortcutBarOffice2007Theme Constructors | Description
CXTPShortcutBarOffice2007Theme | Constructs a CXTPShortcutBarOffice2007Theme object.
CXTPShortcutBarOffice2007Theme Methods
CXTPShortcutBarOffice2007Theme Methods | Description
DrawExpandButton | This method is called to draw the expand button.
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawPaneItemCaption | This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control.
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control.
RefreshMetrics | This method is called to refresh the visual metrics of the shortcut bar paint manager.


CXTPShortcutBarOffice2007Theme Methods

CXTPShortcutBarOffice2007Theme Class, Legend, Public Methods
CXTPShortcutBarOffice2007Theme Methods
Class

CXTPShortcutBarOffice2007Theme Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
DrawExpandButton | This method is called to draw the expand button.
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawPaneItemCaption | This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control.
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control.
RefreshMetrics | This method is called to refresh the visual metrics of the shortcut bar paint manager.


CXTPShortcutBarOffice2007Theme::DrawExpandButton Method

CXTPShortcutBarOffice2007Theme Methods, CXTPShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2007Theme::DrawExpandButton Method

This method is called to draw the expand button.

virtual void DrawExpandButton(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Points to the client device context.
rc
Client rectangle of the expand button.

Group

CXTPShortcutBarOffice2007Theme Methods


CXTPShortcutBarOffice2007Theme::DrawGripper Method

CXTPShortcutBarOffice2007Theme Methods, CXTPShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2007Theme::DrawGripper Method

This method is called to draw gripper of the ShortcutBar control

int DrawGripper(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control
bDraw
TRUE to draw, FALSE to determine size of the gripper.

Returns

Size of the gripper, which is 7 pixels for the Office XP theme.

Group

CXTPShortcutBarOffice2007Theme Methods


CXTPShortcutBarOffice2007Theme::DrawPaneItemCaption Method

CXTPShortcutBarOffice2007Theme Methods, CXTPShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2007Theme::DrawPaneItemCaption Method

This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.

virtual int DrawPaneItemCaption(
    CDC* pDC,
    CXTPShortcutBarPaneItem* pItem,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pItem
Shortcut item pane to be drawn
bDraw
bDraw - TRUE to draw, FALSE to determine size of the shortcut pane caption.

Returns

Size of the pane item caption. This is retrieved from m_nPaneItemHeight.

Remarks

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has it's own caption and is drawn with the DrawPaneItemCaption method.

The caption of the pane item is set when the pane item is created in the CXTPShortcutBarPane::AddItem method.

The sub-items of a pane can be retrieved with the CXTPShortcutBarPane::GetItem method.

Group

CXTPShortcutBarOffice2007Theme Methods


CXTPShortcutBarOffice2007Theme::FillShortcutBar Method

CXTPShortcutBarOffice2007Theme Methods, CXTPShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2007Theme::FillShortcutBar Method

This method is called to fill the client area of the ShortcutBar control.

void FillShortcutBar(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control.

Group

CXTPShortcutBarOffice2007Theme Methods


CXTPShortcutBarOffice2007Theme::FillShortcutItemEntry Method

CXTPShortcutBarOffice2007Theme Methods, CXTPShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2007Theme::FillShortcutItemEntry Method

This method is called to draw the specified item of the ShortcutBar control.

void FillShortcutItemEntry(
    CDC* pDC,
    CXTPShortcutBarItem* pItem
);
Parameters

pDC
Points to the client device context.
pItem
Item to be drawn.

Group

CXTPShortcutBarOffice2007Theme Methods


CXTPShortcutBarOffice2007Theme::RefreshMetrics Method

CXTPShortcutBarOffice2007Theme Methods, CXTPShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2007Theme::RefreshMetrics Method

This method is called to refresh the visual metrics of the shortcut bar paint manager.

virtual void RefreshMetrics();
Remarks

This refreshes all the visual metrics of the shortcut bar such as the pane caption color, pane font, pane caption height, etc.

Group

CXTPShortcutBarOffice2007Theme Methods


CXTPShortcutBarOffice2007Theme Constructors

CXTPShortcutBarOffice2007Theme Class, Legend, Public Methods
CXTPShortcutBarOffice2007Theme Constructors
Class

CXTPShortcutBarOffice2007Theme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBarOffice2007Theme | Constructs a CXTPShortcutBarOffice2007Theme object.


CXTPShortcutBarOffice2007Theme::CXTPShortcutBarOffice2007Theme Constructor

CXTPShortcutBarOffice2007Theme Constructors, CXTPShortcutBarOffice2007Theme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOffice2007Theme::CXTPShortcutBarOffice2007Theme Constructor

Constructs a CXTPShortcutBarOffice2007Theme object.

CXTPShortcutBarOffice2007Theme();
Group

CXTPShortcutBarOffice2007Theme Constructors


CXTPShortcutBarOfficeXPTheme Class

XTPShortcutBarPaintManager.h, Classes, Legend, Members, Topics, CXTPShortcutBarOfficeXPTheme Methods, CXTPShortcutBarOfficeXPTheme Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOfficeXPTheme Class

CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.

Class Hierarchy

class CXTPShortcutBarOfficeXPTheme : public CXTPShortcutBarPaintManager;
File

XTPShortcutBarPaintManager.h

Group

Classes

Legend
Method
CXTPShortcutBarOfficeXPTheme Methods
CXTPShortcutBarOfficeXPTheme Methods | Description
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawImage | This method is called to draw the image of a Shortcut Bar item.
DrawShortcutBarFrame | This method is called to draw the frame of the ShortcutBar control.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control.
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control.


CXTPShortcutBarOfficeXPTheme Methods

CXTPShortcutBarOfficeXPTheme Class, Legend, Public Methods
CXTPShortcutBarOfficeXPTheme Methods
Class

CXTPShortcutBarOfficeXPTheme Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawImage | This method is called to draw the image of a Shortcut Bar item.
DrawShortcutBarFrame | This method is called to draw the frame of the ShortcutBar control.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control.
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control.


CXTPShortcutBarOfficeXPTheme::DrawGripper Method

CXTPShortcutBarOfficeXPTheme Methods, CXTPShortcutBarOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOfficeXPTheme::DrawGripper Method

This method is called to draw gripper of the ShortcutBar control

int DrawGripper(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control
bDraw
TRUE to draw, FALSE to determine size of the gripper.

Returns

Size of the gripper, which is 7 pixels for the Office XP theme.

Group

CXTPShortcutBarOfficeXPTheme Methods


CXTPShortcutBarOfficeXPTheme::DrawImage Method

CXTPShortcutBarOfficeXPTheme Methods, CXTPShortcutBarOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOfficeXPTheme::DrawImage Method

This method is called to draw the image of a Shortcut Bar item.

void DrawImage(
    CDC* pDC,
    CPoint pt,
    CSize sz,
    CXTPImageManagerIcon* pImage,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked
);
Parameters

pDC
Points to the client device context.
pt
Location at which to draw the image within the specified device context.
sz
Size of the image.
pImage
Points to a CXTPImageManagerIcon object.
bSelected
TRUE if the shortcut bar item is selectedhas focus. I.e. When the user clicks on the item.
bPressed
TRUE if the shortcut bar item is currently pressed. I.e. The user is clicking on the item.
bChecked
TRUE if the shortcut bar item is checked. I.e. toggle buttons.

Remarks

This member draws the image of a shortcut bar item. The DrawShortcutItem method uses this method to draw shortcut bar images.

Group

CXTPShortcutBarOfficeXPTheme Methods


CXTPShortcutBarOfficeXPTheme::DrawShortcutBarFrame Method

CXTPShortcutBarOfficeXPTheme Methods, CXTPShortcutBarOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOfficeXPTheme::DrawShortcutBarFrame Method

This method is called to draw the frame of the ShortcutBar control.

void DrawShortcutBarFrame(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control.

Remarks

This is the border that is drawn around the entire shortcut bar.

Group

CXTPShortcutBarOfficeXPTheme Methods


CXTPShortcutBarOfficeXPTheme::FillShortcutBar Method

CXTPShortcutBarOfficeXPTheme Methods, CXTPShortcutBarOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOfficeXPTheme::FillShortcutBar Method

This method is called to fill the client area of the ShortcutBar control.

void FillShortcutBar(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
);
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control.

Group

CXTPShortcutBarOfficeXPTheme Methods


CXTPShortcutBarOfficeXPTheme::FillShortcutItemEntry Method

CXTPShortcutBarOfficeXPTheme Methods, CXTPShortcutBarOfficeXPTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarOfficeXPTheme::FillShortcutItemEntry Method

This method is called to draw the specified item of the ShortcutBar control.

void FillShortcutItemEntry(
    CDC* pDC,
    CXTPShortcutBarItem* pItem
);
Parameters

pDC
Points to the client device context.
pItem
Item to be drawn.

Group

CXTPShortcutBarOfficeXPTheme Methods


CXTPShortcutBarPaintManager Class

XTPShortcutBarPaintManager.h, Classes, Legend, Members, Topics, CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Constructors, CXTPShortcutBarPaintManager Destructors, CXTPShortcutBarPaintManager Constructors, CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Destructors, CXTPShortcutBarPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager Class

Standalone class used by CXTPShortcutBar as paint manager.

Class Hierarchy

class CXTPShortcutBarPaintManager;
File

XTPShortcutBarPaintManager.h

Group

Classes

Legend
Data Member
Method
virtual
abstract
CXTPShortcutBarPaintManager Constructors
CXTPShortcutBarPaintManager Constructors | Description
CXTPShortcutBarPaintManager | Constructs a CXTPShortcutBarPaintManager object
CXTPShortcutBarPaintManager Data Members
CXTPShortcutBarPaintManager Data Members | Description
m_bBoldItemCaptionFont | TRUE to draw item with bold font
m_bClearTypeTextQuality | TRUE to use ClearType font
m_bUseStandardFont | TRUE to use standard font
m_clrHotText | Color of Caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
m_clrNormalText | Color of Caption text when an CXTPShortcutBarItem is displayed normally.
m_clrPushedText | Color of Caption text when an CXTPShortcutBarItem is pressed.
m_clrSelectedText | Color of Caption text when an CXTPShortcutBarItem is selected, this happens after the item is clicked.
m_clrShortcutItemShadow | Color of line border that goes around each item.
m_fntPaneCaption | Caption font.
m_fntPaneItemCaption | Sub-caption font.
m_fntText | Text font.
m_grcHot | Color gradient of "hot" items.
m_grcPushed | Color gradient of item when clicked on.
m_grcSelected | Color gradient of currently selected item,
m_grcShortcutBarGripper | Color Gradient used to draw the shortcut bar gripper.
m_grcShortcutItem | Color gradient of shortcut bar item's.
m_nExpandedIconWidth | Width of the expanded icons.
m_nNormalIconWidth | Width of the icons.
m_nPaneItemHeight | Height of sub-pane caption.
m_pExpandIcon | Pointer to expand icon
CXTPShortcutBarPaintManager Destructors
CXTPShortcutBarPaintManager Destructors | Description
~CXTPShortcutBarPaintManager | Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation
CXTPShortcutBarPaintManager Methods
CXTPShortcutBarPaintManager Methods | Description
DrawExpandButton | This method is called to draw the expand button.
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawImage | This method is called to draw the image of a Shortcut Bar item.
DrawPaneCaption | This method is called to draw the caption of the specified pane.
DrawPaneItemCaption | This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.
DrawShortcutBarFrame | This method is called to draw the frame of the ShortcutBar control.
DrawShortcutItem | This method is called to draw the specified item of the ShortcutBar item.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control
IsShortcutItemTruncated | This method is used to check whether the expanded shortcut item text item has been truncated because the shortcut item is not wide enough to display the entire string.
Line | This method is called to draw the "gripper" lines in the gripper.
Rectangle | This method is called to draw a rectangle. The rectangle is used to draw the shortcut items in the Office XP theme.
RefreshMetrics | This method is called to refresh the visual metrics of the shortcut bar paint manager.


CXTPShortcutBarPaintManager Data Members

CXTPShortcutBarPaintManager Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager Data Members
Class

CXTPShortcutBarPaintManager Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bBoldItemCaptionFont | TRUE to draw item with bold font
m_bClearTypeTextQuality | TRUE to use ClearType font
m_bUseStandardFont | TRUE to use standard font
m_clrHotText | Color of Caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
m_clrNormalText | Color of Caption text when an CXTPShortcutBarItem is displayed normally.
m_clrPushedText | Color of Caption text when an CXTPShortcutBarItem is pressed.
m_clrSelectedText | Color of Caption text when an CXTPShortcutBarItem is selected, this happens after the item is clicked.
m_clrShortcutItemShadow | Color of line border that goes around each item.
m_fntPaneCaption | Caption font.
m_fntPaneItemCaption | Sub-caption font.
m_fntText | Text font.
m_grcHot | Color gradient of "hot" items.
m_grcPushed | Color gradient of item when clicked on.
m_grcSelected | Color gradient of currently selected item,
m_grcShortcutBarGripper | Color Gradient used to draw the shortcut bar gripper.
m_grcShortcutItem | Color gradient of shortcut bar item's.
m_nExpandedIconWidth | Width of the expanded icons.
m_nNormalIconWidth | Width of the icons.
m_nPaneItemHeight | Height of sub-pane caption.
m_pExpandIcon | Pointer to expand icon


CXTPShortcutBarPaintManager::m_bBoldItemCaptionFont Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_bBoldItemCaptionFont Data Member

TRUE to draw item with bold font

BOOL m_bBoldItemCaptionFont;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_bClearTypeTextQuality Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_bClearTypeTextQuality Data Member

TRUE to use ClearType font

BOOL m_bClearTypeTextQuality;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_bUseStandardFont Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_bUseStandardFont Data Member

TRUE to use standard font

BOOL m_bUseStandardFont;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_clrHotText Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_clrHotText Data Member

Color of Caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.

CXTPPaintManagerColor m_clrHotText;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_clrNormalText Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_clrNormalText Data Member

Color of Caption text when an CXTPShortcutBarItem is displayed normally.

CXTPPaintManagerColor m_clrNormalText;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_clrPushedText Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_clrPushedText Data Member

Color of Caption text when an CXTPShortcutBarItem is pressed.

CXTPPaintManagerColor m_clrPushedText;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_clrSelectedText Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_clrSelectedText Data Member

Color of Caption text when an CXTPShortcutBarItem is selected, this happens after the item is clicked.

CXTPPaintManagerColor m_clrSelectedText;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_clrShortcutItemShadow Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_clrShortcutItemShadow Data Member

Color of line border that goes around each item.

CXTPPaintManagerColor m_clrShortcutItemShadow;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_fntPaneCaption Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_fntPaneCaption Data Member

Caption font.

CFont m_fntPaneCaption;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_fntPaneItemCaption Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_fntPaneItemCaption Data Member

Sub-caption font.

CFont m_fntPaneItemCaption;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_fntText Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_fntText Data Member

Text font.

CFont m_fntText;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_grcHot Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_grcHot Data Member

Color gradient of "hot" items.

CXTPPaintManagerColorGradient m_grcHot;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_grcPushed Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_grcPushed Data Member

Color gradient of item when clicked on.

CXTPPaintManagerColorGradient m_grcPushed;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_grcSelected Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_grcSelected Data Member

Color gradient of currently selected item,

CXTPPaintManagerColorGradient m_grcSelected;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_grcShortcutBarGripper Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_grcShortcutBarGripper Data Member

Color Gradient used to draw the shortcut bar gripper.

CXTPPaintManagerColorGradient m_grcShortcutBarGripper;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_grcShortcutItem Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_grcShortcutItem Data Member

Color gradient of shortcut bar item's.

CXTPPaintManagerColorGradient m_grcShortcutItem;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_nExpandedIconWidth Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_nExpandedIconWidth Data Member

Width of the expanded icons.

int m_nExpandedIconWidth;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_nNormalIconWidth Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_nNormalIconWidth Data Member

Width of the icons.

int m_nNormalIconWidth;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_nPaneItemHeight Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_nPaneItemHeight Data Member

Height of sub-pane caption.

int m_nPaneItemHeight;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager::m_pExpandIcon Data Member

CXTPShortcutBarPaintManager Data Members, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::m_pExpandIcon Data Member

Pointer to expand icon

CXTPImageManagerIcon* m_pExpandIcon;
Group

CXTPShortcutBarPaintManager Data Members


CXTPShortcutBarPaintManager Methods

CXTPShortcutBarPaintManager Class, Legend, Public Methods
CXTPShortcutBarPaintManager Methods
Class

CXTPShortcutBarPaintManager Class

Legend
Method
virtual
abstract
Public Methods
Public Methods
Public Method | Description
DrawExpandButton | This method is called to draw the expand button.
DrawGripper | This method is called to draw gripper of the ShortcutBar control
DrawImage | This method is called to draw the image of a Shortcut Bar item.
DrawPaneCaption | This method is called to draw the caption of the specified pane.
DrawPaneItemCaption | This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.
DrawShortcutBarFrame | This method is called to draw the frame of the ShortcutBar control.
DrawShortcutItem | This method is called to draw the specified item of the ShortcutBar item.
FillShortcutBar | This method is called to fill the client area of the ShortcutBar control
FillShortcutItemEntry | This method is called to draw the specified item of the ShortcutBar control
IsShortcutItemTruncated | This method is used to check whether the expanded shortcut item text item has been truncated because the shortcut item is not wide enough to display the entire string.
Line | This method is called to draw the "gripper" lines in the gripper.
Rectangle | This method is called to draw a rectangle. The rectangle is used to draw the shortcut items in the Office XP theme.
RefreshMetrics | This method is called to refresh the visual metrics of the shortcut bar paint manager.


CXTPShortcutBarPaintManager::DrawExpandButton Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::DrawExpandButton Method

This method is called to draw the expand button.

virtual void DrawExpandButton(
    CDC* pDC,
    CRect rc
);
Parameters

pDC
Points to the client device context.
rc
Client rectangle of the expand button.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::DrawGripper Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::DrawGripper Method

This method is called to draw gripper of the ShortcutBar control

virtual int DrawGripper(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar,
    BOOL bDraw
) = 0;
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control
bDraw
TRUE to draw, FALSE to determine size of the gripper.

Returns

Size of the gripper.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::DrawImage Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::DrawImage Method

This method is called to draw the image of a Shortcut Bar item.

virtual void DrawImage(
    CDC* pDC,
    CPoint pt,
    CSize sz,
    CXTPImageManagerIcon* pImage,
    BOOL bSelected,
    BOOL bPressed,
    BOOL bChecked
) = 0;
Parameters

pDC
Points to the client device context.
pt
Location at which to draw the image within the specified device context.
sz
Size of the image.
pImage
Points to a CXTPImageManagerIcon object.
bSelected
TRUE if the shortcut bar item is selectedhas focus. I.e. When the user clicks on the item.
bPressed
TRUE if the shortcut bar item is currently pressed. I.e. The user is clicking on the item.
bChecked
TRUE if the shortcut bar item is checked. I.e. toggle buttons.

Remarks

This member draws the image of a shortcut bar item. The DrawShortcutItem method uses this method to draw shortcut bar images.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::DrawPaneCaption Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::DrawPaneCaption Method

This method is called to draw the caption of the specified pane.

virtual int DrawPaneCaption(
    CDC* pDC,
    CXTPShortcutBarPane* pPane,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pPane
Shortcut Pane to be drawn
bDraw
TRUE to draw pane, FALSE to determine size of the caption

Returns

Size of the caption. Unless overridden, the default caption is 24 pixes.

Remarks

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has it's own caption and is drawn with the DrawPaneItemCaption method.

The caption of the shortcut bar pane is the bar on the top the pane. The caption of the pane is set when the pane is created in the CXTPShortcutBarPane::Create method.

The pane caption can be retrieved with CXTPShortcutBarPane::GetCaption

Shortcut bar pane's have sub-item's which also have a caption that is drawn with the DrawPaneItemCaption method.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::DrawPaneItemCaption Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::DrawPaneItemCaption Method

This method is called to draw the caption of the specified shortcut pane item. This is the sub-pane of a shortcut bar pane.

virtual int DrawPaneItemCaption(
    CDC* pDC,
    CXTPShortcutBarPaneItem* pItem,
    BOOL bDraw
);
Parameters

pDC
Points to the client device context.
pItem
Shortcut item pane to be drawn
bDraw
bDraw - TRUE to draw, FALSE to determine size of the shortcut pane caption.

Returns

Size of the pane item caption. This is retrieved from m_nPaneItemHeight.

Remarks

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has it's own caption and is drawn with the DrawPaneItemCaption method.

The caption of the pane item is set when the pane item is created in the CXTPShortcutBarPane::AddItem method.

The sub-items of a pane can be retrieved with the CXTPShortcutBarPane::GetItem method.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::DrawShortcutBarFrame Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::DrawShortcutBarFrame Method

This method is called to draw the frame of the ShortcutBar control.

virtual void DrawShortcutBarFrame(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
) = 0;
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control.

Remarks

This is the border that is drawn around the entire shortcut bar.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::DrawShortcutItem Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::DrawShortcutItem Method

This method is called to draw the specified item of the ShortcutBar item.

virtual void DrawShortcutItem(
    CDC* pDC,
    CXTPShortcutBarItem* pItem
);
Parameters

pDC
Points to the client device context.
pItem
Item to be drawn.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::FillShortcutBar Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::FillShortcutBar Method

This method is called to fill the client area of the ShortcutBar control

virtual void FillShortcutBar(
    CDC* pDC,
    CXTPShortcutBar* pShortcutBar
) = 0;
Parameters

pDC
Points to the client device context.
pShortcutBar
Points to the ShortcutBar control

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::FillShortcutItemEntry Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::FillShortcutItemEntry Method

This method is called to draw the specified item of the ShortcutBar control

virtual void FillShortcutItemEntry(
    CDC* pDC,
    CXTPShortcutBarItem* pItem
) = 0;
Parameters

pDC
Points to the client device context.
pItem
Item to be drawn.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::IsShortcutItemTruncated Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::IsShortcutItemTruncated Method

This method is used to check whether the expanded shortcut item text item has been truncated because the shortcut item is not wide enough to display the entire string.

BOOL IsShortcutItemTruncated(
    CDC* pDC,
    CXTPShortcutBarItem* pItem
);
Parameters

pDC
Points to the client device context.
pItem
Pointer to CXTPShortcutBarItem to check to see if the caption text has been truncated.

Returns

Returns False if pItem it is not expanded or if the caption of an expanded item is not truncated and fully displayed. returns True if the item is not expanded or the caption text has been truncated.

Remarks

Checks whether the caption text of an expanded item has been truncated because the caption width is too wide to display.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::Line Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::Line Method

This method is called to draw the "gripper" lines in the gripper.

void Line(
    CDC* pDC,
    int x0,
    int y0,
    int x1,
    int y1,
    int nPen
);
Parameters

pDC
Points to the client device context.
x0
Specifies the logical x-coordinate of the start position.
y0
Specifies the logical y-coordinate of the start position.
x1
Specifies the logical x-coordinate of the endpoint for the line.
y1
Specifies the logical y-coordinate of the endpoint for the line.
nPen
Specifies the color used to paint the line.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::Rectangle Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::Rectangle Method

This method is called to draw a rectangle. The rectangle is used to draw the shortcut items in the Office XP theme.

void Rectangle(
    CDC* pDC,
    CRect rc,
    int nPen,
    int nBrush
);
Parameters

pDC
Pointer to a valid device context
rc
Specifies the rectangle in logical units.
nPen
Specifies the color used to paint the rectangle.
nBrush
Specifies the color used to fill the rectangle.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager::RefreshMetrics Method

CXTPShortcutBarPaintManager Methods, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::RefreshMetrics Method

This method is called to refresh the visual metrics of the shortcut bar paint manager.

virtual void RefreshMetrics();
Remarks

This refreshes all the visual metrics of the shortcut bar such as the pane caption color, pane font, pane caption height, etc.

Group

CXTPShortcutBarPaintManager Methods


CXTPShortcutBarPaintManager Constructors

CXTPShortcutBarPaintManager Class, Legend, Public Methods
CXTPShortcutBarPaintManager Constructors
Class

CXTPShortcutBarPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBarPaintManager | Constructs a CXTPShortcutBarPaintManager object


CXTPShortcutBarPaintManager::CXTPShortcutBarPaintManager Constructor

CXTPShortcutBarPaintManager Constructors, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::CXTPShortcutBarPaintManager Constructor

Constructs a CXTPShortcutBarPaintManager object

CXTPShortcutBarPaintManager();
Group

CXTPShortcutBarPaintManager Constructors


CXTPShortcutBarPaintManager Destructors

CXTPShortcutBarPaintManager Class, Legend, Public Methods
CXTPShortcutBarPaintManager Destructors
Class

CXTPShortcutBarPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPShortcutBarPaintManager | Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation


CXTPShortcutBarPaintManager::~CXTPShortcutBarPaintManager Destructor

CXTPShortcutBarPaintManager Destructors, CXTPShortcutBarPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaintManager::~CXTPShortcutBarPaintManager Destructor

Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation

virtual ~CXTPShortcutBarPaintManager();
Group

CXTPShortcutBarPaintManager Destructors


CXTPShortcutBarPane Class

XTPShortcutBarPane.h, Classes, Legend, Members, Topics, CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Methods, CXTPShortcutBarPane Constructors, CXTPShortcutBarPane Destructors, CXTPShortcutBarPane Constructors, CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Destructors, CXTPShortcutBarPane Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPane Class

CXTPShortcutBarPane is a CWnd derived class. It is used as client area of ShortcutBar control.

Class Hierarchy

class CXTPShortcutBarPane : public CWnd;
File

XTPShortcutBarPane.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPShortcutBarPane Constructors
CXTPShortcutBarPane Constructors | Description
CXTPShortcutBarPane | Constructs a CXTPShortcutBarPane object.
CXTPShortcutBarPane Data Members
CXTPShortcutBarPane Data Members | Description
m_arrItems | Array of items.
m_bShowCaption | TRUE to show caption
m_hHandCursor | Hand cursor
m_nMinClientHeight | The minimum height of client area.
m_pShortcutBar | Parent CXTPShortcutBar class.
m_rcIndent | Indentationpadding around the client pane
m_strCaption | Caption of the pane.
CXTPShortcutBarPane Destructors
CXTPShortcutBarPane Destructors | Description
~CXTPShortcutBarPane | Destroys a CXTPShortcutBarPane object, handles cleanup and deallocation.
CXTPShortcutBarPane Methods
CXTPShortcutBarPane Methods | Description
AddItem | Call this method to add sub item of pane.
Create | This method creates the CXTPShortcutBarPane control.
GetCaption | Call this method to get the caption of the pane.
GetItem | This method retrieves item with specified index.
GetMinimumClientHeight | Determines the minimum height of the client area
SetCaption | This method sets the text caption of the CXTPShortcutBarPane.
SetIndent | Call this member function to set the indent placed around the client area of the ShortcutBar. The indent will be placed around the corresponding CXTPShortcutBarPaneItem when displayed.
SetMinimumClientHeight | This method sets the minimum height of the client area
ShowCaption | Call this method to show/hide caption


CXTPShortcutBarPane Data Members

CXTPShortcutBarPane Class, Legend, Protected Data Members
CXTPShortcutBarPane Data Members
Class

CXTPShortcutBarPane Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrItems | Array of items.
m_bShowCaption | TRUE to show caption
m_hHandCursor | Hand cursor
m_nMinClientHeight | The minimum height of client area.
m_pShortcutBar | Parent CXTPShortcutBar class.
m_rcIndent | Indentationpadding around the client pane
m_strCaption | Caption of the pane.


CXTPShortcutBarPane::m_arrItems Data Member

CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Class
CXTPShortcutBarPane::m_arrItems Data Member

Array of items.

CArray<CXTPShortcutBarPaneItem*, CXTPShortcutBarPaneItem*> m_arrItems;
Group

CXTPShortcutBarPane Data Members


CXTPShortcutBarPane::m_bShowCaption Data Member

CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Class
CXTPShortcutBarPane::m_bShowCaption Data Member

TRUE to show caption

BOOL m_bShowCaption;
Group

CXTPShortcutBarPane Data Members


CXTPShortcutBarPane::m_hHandCursor Data Member

CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Class
CXTPShortcutBarPane::m_hHandCursor Data Member

Hand cursor

HCURSOR m_hHandCursor;
Group

CXTPShortcutBarPane Data Members


CXTPShortcutBarPane::m_nMinClientHeight Data Member

CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Class
CXTPShortcutBarPane::m_nMinClientHeight Data Member

The minimum height of client area.

int m_nMinClientHeight;
Group

CXTPShortcutBarPane Data Members


CXTPShortcutBarPane::m_pShortcutBar Data Member

CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Class
CXTPShortcutBarPane::m_pShortcutBar Data Member

Parent CXTPShortcutBar class.

CXTPShortcutBar* m_pShortcutBar;
Group

CXTPShortcutBarPane Data Members


CXTPShortcutBarPane::m_rcIndent Data Member

CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Class
CXTPShortcutBarPane::m_rcIndent Data Member

Indentationpadding around the client pane

CRect m_rcIndent;
Group

CXTPShortcutBarPane Data Members


CXTPShortcutBarPane::m_strCaption Data Member

CXTPShortcutBarPane Data Members, CXTPShortcutBarPane Class
CXTPShortcutBarPane::m_strCaption Data Member

Caption of the pane.

CString m_strCaption;
Group

CXTPShortcutBarPane Data Members


CXTPShortcutBarPane Methods

CXTPShortcutBarPane Class, Legend, Public Methods
CXTPShortcutBarPane Methods
Class

CXTPShortcutBarPane Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AddItem | Call this method to add sub item of pane.
Create | This method creates the CXTPShortcutBarPane control.
GetCaption | Call this method to get the caption of the pane.
GetItem | This method retrieves item with specified index.
GetMinimumClientHeight | Determines the minimum height of the client area
SetCaption | This method sets the text caption of the CXTPShortcutBarPane.
SetIndent | Call this member function to set the indent placed around the client area of the ShortcutBar. The indent will be placed around the corresponding CXTPShortcutBarPaneItem when displayed.
SetMinimumClientHeight | This method sets the minimum height of the client area
ShowCaption | Call this method to show/hide caption


CXTPShortcutBarPane::AddItem Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class
CXTPShortcutBarPane::AddItem Method

Call this method to add sub item of pane.

CXTPShortcutBarPaneItem* AddItem(
    LPCTSTR lpszCaption,
    CWnd* pWnd,
    int nHeight
);
Parameters

lpszCaption
Caption of the item that is to be added.
pWnd
Associated child window of the item.
nHeight
Height of the item.

Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane::Create Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class
CXTPShortcutBarPane::Create Method

This method creates the CXTPShortcutBarPane control.

BOOL Create(
    LPCTSTR lpszCaption,
    CXTPShortcutBar* pParent
);
Parameters

lpszCaption
Caption of the pane.
pParent
parent CXTPShortcutBar class.

Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane::GetCaption Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPane::GetCaption Method

Call this method to get the caption of the pane.

CString GetCaption() const;
Body Source
CString CXTPShortcutBarPane::GetCaption() const {
    return m_strCaption;
}
Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane::GetItem Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class
CXTPShortcutBarPane::GetItem Method

This method retrieves item with specified index.

CXTPShortcutBarPaneItem* GetItem(
    int nIndex
) const;
Parameters

nIndex
Specifies the zero-based index of the item to retrieve.

Returns

A pointer to a CXTPShortcutBarPaneItem object.

Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane::GetMinimumClientHeight Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPane::GetMinimumClientHeight Method

Determines the minimum height of the client area

virtual int GetMinimumClientHeight() const;
Returns

minimum height in pixels of the client.

Body Source
int CXTPShortcutBarPane::GetMinimumClientHeight() const {
    return m_nMinClientHeight;
}
Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane::SetCaption Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class
CXTPShortcutBarPane::SetCaption Method

This method sets the text caption of the CXTPShortcutBarPane.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
New Caption of the pane.

Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane::SetIndent Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPane::SetIndent Method

Call this member function to set the indent placed around the client area of the ShortcutBar. The indent will be placed around the corresponding CXTPShortcutBarPaneItem when displayed.

void SetIndent(
    int left,
    int top,
    int right,
    int bottom
);
Parameters

left
Amount of space placed between the left client border and the left border of the ShortcutBar client area.
top
Amount of space placed between the top client border and the top border of the ShortcutBar client area.
right
Amount of space placed between the right client border and the right border of the ShortcutBar client area.
bottom
Amount of space placed between the bottom client border and the bottom border of the ShortcutBar client area.

Body Source
void CXTPShortcutBarPane::SetIndent(int left, int top, int right, int bottom) {
    m_rcIndent.SetRect(left, top, right, bottom);
}
Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane::SetMinimumClientHeight Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPane::SetMinimumClientHeight Method

This method sets the minimum height of the client area

void SetMinimumClientHeight(
    int nMinHeight
);
Parameters

nMinHeight
Specifies the minimum height in pixels of the client.

Body Source
void CXTPShortcutBarPane::SetMinimumClientHeight(int nMinHeight) {
    m_nMinClientHeight = nMinHeight;
}
Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane::ShowCaption Method

CXTPShortcutBarPane Methods, CXTPShortcutBarPane Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPane::ShowCaption Method

Call this method to show/hide caption

void ShowCaption(
    BOOL bShowCaption
);
Parameters

bShowCaption
TRUE to show caption; FALSE to hide

Body Source
void CXTPShortcutBarPane::ShowCaption(BOOL bShowCaption) {
    m_bShowCaption = bShowCaption;
}
Group

CXTPShortcutBarPane Methods


CXTPShortcutBarPane Constructors

CXTPShortcutBarPane Class, Legend, Public Methods
CXTPShortcutBarPane Constructors
Class

CXTPShortcutBarPane Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBarPane | Constructs a CXTPShortcutBarPane object.


CXTPShortcutBarPane::CXTPShortcutBarPane Constructor

CXTPShortcutBarPane Constructors, CXTPShortcutBarPane Class
CXTPShortcutBarPane::CXTPShortcutBarPane Constructor

Constructs a CXTPShortcutBarPane object.

CXTPShortcutBarPane();
Group

CXTPShortcutBarPane Constructors


CXTPShortcutBarPane Destructors

CXTPShortcutBarPane Class, Legend, Public Methods
CXTPShortcutBarPane Destructors
Class

CXTPShortcutBarPane Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPShortcutBarPane | Destroys a CXTPShortcutBarPane object, handles cleanup and deallocation.


CXTPShortcutBarPane::~CXTPShortcutBarPane Destructor

CXTPShortcutBarPane Destructors, CXTPShortcutBarPane Class
CXTPShortcutBarPane::~CXTPShortcutBarPane Destructor

Destroys a CXTPShortcutBarPane object, handles cleanup and deallocation.

virtual ~CXTPShortcutBarPane();
Group

CXTPShortcutBarPane Destructors


CXTPShortcutBarPaneItem Class

XTPShortcutBarPane.h, Classes, Legend, Members, Topics, CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Methods, CXTPShortcutBarPaneItem Constructors, CXTPShortcutBarPaneItem Constructors, CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem Class

CXTPShortcutBarPaneItem is the base class representing an item of the panes.

Class Hierarchy

class CXTPShortcutBarPaneItem;
File

XTPShortcutBarPane.h

Group

Classes

Legend
Data Member
protected
Method
CXTPShortcutBarPaneItem Constructors
CXTPShortcutBarPaneItem Constructors | Description
CXTPShortcutBarPaneItem | Constructs a CXTPShortcutBarPaneItem object.
CXTPShortcutBarPaneItem Data Members
CXTPShortcutBarPaneItem Data Members | Description
m_bExpandable | TRUE if pane is expandable
m_bExpanded | TRUE if pane is expanded
m_bShowCaption | TRUE to show caption
m_nHeight | Height of the item.
m_pPane | Parent pane object
m_pWndClient | Associated child window.
m_rcCaption | Rectangle of the caption.
m_rcClient | Bounding rectangle of the client area.
m_strCaption | Caption of the item
CXTPShortcutBarPaneItem Methods
CXTPShortcutBarPaneItem Methods | Description
GetCaption | Retrieves the caption of the pane.
GetCaptionRect | Returns rectangle of caption.
GetHeight | Call this method to determine height of the item.
SetCaption | This method sets the text caption of the CXTPShortcutBarPaneItem.
SetHeight | Call this method to set height of the item.
ShowCaption | Call this method to show/hide caption


CXTPShortcutBarPaneItem Data Members

CXTPShortcutBarPaneItem Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem Data Members
Class

CXTPShortcutBarPaneItem Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bExpandable | TRUE if pane is expandable
m_bExpanded | TRUE if pane is expanded
m_bShowCaption | TRUE to show caption
m_nHeight | Height of the item.
m_pPane | Parent pane object
m_pWndClient | Associated child window.
m_rcCaption | Rectangle of the caption.
m_rcClient | Bounding rectangle of the client area.
m_strCaption | Caption of the item


CXTPShortcutBarPaneItem::m_bExpandable Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_bExpandable Data Member

TRUE if pane is expandable

BOOL m_bExpandable;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem::m_bExpanded Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_bExpanded Data Member

TRUE if pane is expanded

BOOL m_bExpanded;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem::m_bShowCaption Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_bShowCaption Data Member

TRUE to show caption

BOOL m_bShowCaption;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem::m_nHeight Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_nHeight Data Member

Height of the item.

int m_nHeight;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem::m_pPane Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_pPane Data Member

Parent pane object

CXTPShortcutBarPane* m_pPane;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem::m_pWndClient Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_pWndClient Data Member

Associated child window.

CWnd* m_pWndClient;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem::m_rcCaption Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_rcCaption Data Member

Rectangle of the caption.

CRect m_rcCaption;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem::m_rcClient Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_rcClient Data Member

Bounding rectangle of the client area.

CRect m_rcClient;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem::m_strCaption Data Member

CXTPShortcutBarPaneItem Data Members, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::m_strCaption Data Member

Caption of the item

CString m_strCaption;
Group

CXTPShortcutBarPaneItem Data Members


CXTPShortcutBarPaneItem Methods

CXTPShortcutBarPaneItem Class, Legend, Public Methods
CXTPShortcutBarPaneItem Methods
Class

CXTPShortcutBarPaneItem Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetCaption | Retrieves the caption of the pane.
GetCaptionRect | Returns rectangle of caption.
GetHeight | Call this method to determine height of the item.
SetCaption | This method sets the text caption of the CXTPShortcutBarPaneItem.
SetHeight | Call this method to set height of the item.
ShowCaption | Call this method to show/hide caption


CXTPShortcutBarPaneItem::GetCaption Method

CXTPShortcutBarPaneItem Methods, CXTPShortcutBarPaneItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::GetCaption Method

Retrieves the caption of the pane.

CString GetCaption() const;
Body Source
CString CXTPShortcutBarPaneItem::GetCaption() const {
    return m_strCaption;
}
Group

CXTPShortcutBarPaneItem Methods


CXTPShortcutBarPaneItem::GetCaptionRect Method

CXTPShortcutBarPaneItem Methods, CXTPShortcutBarPaneItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::GetCaptionRect Method

Returns rectangle of caption.

CRect GetCaptionRect() const;
Body Source
CRect CXTPShortcutBarPaneItem::GetCaptionRect() const {
    return m_rcCaption;
}
Group

CXTPShortcutBarPaneItem Methods


CXTPShortcutBarPaneItem::GetHeight Method

CXTPShortcutBarPaneItem Methods, CXTPShortcutBarPaneItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::GetHeight Method

Call this method to determine height of the item.

int GetHeight() const;
Returns

Height of the item.

Body Source
int CXTPShortcutBarPaneItem::GetHeight() const {
    return m_nHeight;
}
Group

CXTPShortcutBarPaneItem Methods


CXTPShortcutBarPaneItem::SetCaption Method

CXTPShortcutBarPaneItem Methods, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::SetCaption Method

This method sets the text caption of the CXTPShortcutBarPaneItem.

void SetCaption(
    LPCTSTR lpszCaption
);
Parameters

lpszCaption
New Caption of the pane.

Group

CXTPShortcutBarPaneItem Methods


CXTPShortcutBarPaneItem::SetHeight Method

CXTPShortcutBarPaneItem Methods, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::SetHeight Method

Call this method to set height of the item.

void SetHeight(
    int nHeight
);
Parameters

nHeight
Height of client area of the item.

Group

CXTPShortcutBarPaneItem Methods


CXTPShortcutBarPaneItem::ShowCaption Method

CXTPShortcutBarPaneItem Methods, CXTPShortcutBarPaneItem Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::ShowCaption Method

Call this method to show/hide caption

void ShowCaption(
    BOOL bShowCaption
);
Parameters

bShowCaption
TRUE to show caption; FALSE to hide

Body Source
void CXTPShortcutBarPaneItem::ShowCaption(BOOL bShowCaption) {
    m_bShowCaption = bShowCaption;
}
Group

CXTPShortcutBarPaneItem Methods


CXTPShortcutBarPaneItem Constructors

CXTPShortcutBarPaneItem Class, Legend, Protected Methods
CXTPShortcutBarPaneItem Constructors
Class

CXTPShortcutBarPaneItem Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPShortcutBarPaneItem | Constructs a CXTPShortcutBarPaneItem object.


CXTPShortcutBarPaneItem::CXTPShortcutBarPaneItem Constructor

CXTPShortcutBarPaneItem Constructors, CXTPShortcutBarPaneItem Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPShortcutBarPaneItem::CXTPShortcutBarPaneItem Constructor

Constructs a CXTPShortcutBarPaneItem object.

CXTPShortcutBarPaneItem(
    LPCTSTR lpszCaption,
    CWnd* pWnd,
    int nHeight
);
Parameters

lpszCaption
Caption of the item
pWnd
Child window associated with item
nHeight
Height of the item

Group

CXTPShortcutBarPaneItem Constructors


Structs, Records, Enums

Enumerations, Legend, Shortcut Bar
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPShortcutBarPaintTheme | XTPShortcutBarPaintTheme is an enumeration used by CXTPShortcutBar to set the theme of the control.
Module

Shortcut Bar

Legend
Enumeration


XTPShortcutBarPaintTheme Enumeration

XTPShortcutBarPaintManager.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPShortcutBarPaintTheme Enumeration

XTPShortcutBarPaintTheme is an enumeration used by CXTPShortcutBar to set the theme of the control.

enum XTPShortcutBarPaintTheme {
  xtpShortcutThemeOffice2000,
  xtpShortcutThemeOfficeXP,
  xtpShortcutThemeOffice2003,
  xtpShortcutThemeOffice2007
};
File

XTPShortcutBarPaintManager.h

Members

xtpShortcutThemeOffice2000
Office 2000 style theme.
xtpShortcutThemeOfficeXP
Office XP style theme.
xtpShortcutThemeOffice2003
Office 2003 style theme.
xtpShortcutThemeOffice2007
Office 2007 style theme.

See Also

CXTPShortcutBar::GetCurrentTheme, CXTPShortcutBar::SetTheme, CXTPShortcutBar::SetCustomTheme

Example
    m_wndShortcutBar.SetTheme(xtpShortcutThemeOffice2003);
Group

Structs, Records, Enums


Variables

Shortcut Bar, Variables
Variables
Module

Shortcut Bar

Variables
Variable | Description
XTP_SBN_RCLICK | XTP_SBN_RCLICK is used to indicate that the user has pressed the right mouse button on a shortcut bar item.
XTP_SBN_SELECTION_CHANGED | XTP_SBN_SELECTION_CHANGING is used to indicate that value for the selection is currently changing.
XTP_SBN_SELECTION_CHANGING | XTP_SBN_SELECTION_CHANGED is used to indicate that the selection has changed in the shortcut bar.
XTPWM_SHORTCUTBAR_NOTIFY | The XTPWM_SHORTCUTBAR_NOTIFY message is sent to the CXTPShortcutBar owner window whenever an action occurs within the CXTPShortcutBar


XTP_SBN_RCLICK Variable

XTPShortcutBar.h, Variables, Example, See Also
XTP_SBN_RCLICK Variable

XTP_SBN_RCLICK is used to indicate that the user has pressed the right mouse button on a shortcut bar item.

const UINT XTP_SBN_RCLICK = 2;
File

XTPShortcutBar.h

Remarks

XTP_SBN_RCLICK is sent in the XTPWM_SHORTCUTBAR_NOTIFY message to the owner window when the user has right clicked on a shortcut bar item.

See Also

XTPWM_SHORTCUTBAR_NOTIFY, XTP_SBN_SELECTION_CHANGING

Example

See example of XTPWM_SHORTCUTBAR_NOTIFY

Group

Variables


XTP_SBN_SELECTION_CHANGED Variable

XTPShortcutBar.h, Variables, See Also
XTP_SBN_SELECTION_CHANGED Variable

XTP_SBN_SELECTION_CHANGING is used to indicate that value for the selection is currently changing.

const UINT XTP_SBN_SELECTION_CHANGED = 3;
File

XTPShortcutBar.h

Remarks

XTP_SBN_SELECTION_CHANGING is sent in the XTPWM_SHORTCUTBAR_NOTIFY message to the owner window when the selection is in the process of changing.

The selection changed when a user clicks on a shortcut bar item or the items are navigated with the arrow keys.

See Also

XTPWM_SHORTCUTBAR_NOTIFY, XTP_SBN_RCLICK

Group

Variables


XTP_SBN_SELECTION_CHANGING Variable

XTPShortcutBar.h, Variables, Example, See Also
XTP_SBN_SELECTION_CHANGING Variable

XTP_SBN_SELECTION_CHANGED is used to indicate that the selection has changed in the shortcut bar.

const UINT XTP_SBN_SELECTION_CHANGING = 1;
File

XTPShortcutBar.h

Remarks

XTP_SBN_SELECTION_CHANGED is sent in the XTPWM_SHORTCUTBAR_NOTIFY message to the owner window when the selection has changed.

The selection changed when a user clicks on a shortcut bar item or the items are navigated with the arrow keys.

See Also

XTPWM_SHORTCUTBAR_NOTIFY, XTP_SBN_RCLICK

Example

See example of XTPWM_SHORTCUTBAR_NOTIFY

Group

Variables


XTPWM_SHORTCUTBAR_NOTIFY Variable

XTPShortcutBar.h, Variables, Example, See Also
XTPWM_SHORTCUTBAR_NOTIFY Variable

The XTPWM_SHORTCUTBAR_NOTIFY message is sent to the CXTPShortcutBar owner window whenever an action occurs within the CXTPShortcutBar

const UINT XTPWM_SHORTCUTBAR_NOTIFY = (WM_USER + 9190 + 1);
File

XTPShortcutBar.h

Parameters

nAction
Value of wParam specifies a ShortcutBar value that indicates the user's request.
pItem
The value of lParam points to an CXTPShortcutBarItem object that contains information for the specified item. This pointer should never be NULL.

Returns

If the application is to process this message, the return value should be TRUE, otherwise the return value is FALSE.

Remarks

nAction parameter can be one of the following values:

  • XTP_SBN_SELECTION_CHANGING Indicates the selection has changed in the shortcut bar.
  • XTP_SBN_RCLICK Indicates the user pressed the right mouse button on the shortcut bar item.
See Also

XTP_SBN_SELECTION_CHANGING, XTP_SBN_RCLICK, CXTPShortcutBar

Example

Here is an example of how an application would process the XTPWM_SHORTCUTBAR_NOTIFY message.

BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(XTPWM_SHORTCUTBAR_NOTIFY, OnShortcutBarNotify)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnShortcutBarNotify(WPARAM wParam, LPARAM lParam)
{
     switch (wParam)
     {
         case XTP_SBN_SELECTION_CHANGING:
             {
                 CXTPShortcutBarItem* pItem = (CXTPShortcutBarItem*)lParam;
                 TRACE(_T("Selection Changing. Item.Caption = %sn"), pItem->GetCaption());

                 // TODO: You can return -1 to ignore changing

             }
             return TRUE;
         case XTP_SBN_RCLICK:
             {
                 CPoint point(lParam);
                 CXTPShortcutBarItem* pItem = m_wndShortcutBar.HitTest(point);
                 if (pItem)
                 {
                     TRACE(_T("RClick. Item.ID = %in"), pItem->GetID());

                     CMenu mnu;
                     mnu.LoadMenu(IDR_POPUP_MENU);

                     m_wndShortcutBar.ClientToScreen(&point);

                     CXTPCommandBars::TrackPopupMenu(mnu.GetSubMenu(0), 0, point.x, point.y, AfxGetMainWnd());

                 }
             }
             return TRUE;

     }
     return 0;
 }
Group

Variables


Files

Files, Shortcut Bar
Files
Files
File | Description
XTPShortcutBar.h | XTPShortcutBar.h interface for the CXTPShortcutBar class.
XTPShortcutBarPaintManager.h | XTPShortcutBarPaintManager.h interface for the CXTPShortcutBarPaintManager class.
XTPShortcutBarPane.h | XTPShortcutBarPane.h interface for the CXTPShortcutBarPane class.
Module

Shortcut Bar


XTPShortcutBar.h

Classes, Files, Variables
XTPShortcutBar.h

XTPShortcutBar.h interface for the CXTPShortcutBar class.

Classes
Class | Description
CXTPShortcutBar | CXTPShortcutBar is a CWnd derived class. It is used to implement an Outlook2003 ShortcutBar style control.
CXTPShortcutBarItem | CXTPShortcutBarItem is the base class representing an item of the ShortcutBar Control.
Group

Files

Variables
Variable | Description
XTP_SBN_RCLICK | XTP_SBN_RCLICK is used to indicate that the user has pressed the right mouse button on a shortcut bar item.
XTP_SBN_SELECTION_CHANGED | XTP_SBN_SELECTION_CHANGING is used to indicate that value for the selection is currently changing.
XTP_SBN_SELECTION_CHANGING | XTP_SBN_SELECTION_CHANGED is used to indicate that the selection has changed in the shortcut bar.
XTPWM_SHORTCUTBAR_NOTIFY | The XTPWM_SHORTCUTBAR_NOTIFY message is sent to the CXTPShortcutBar owner window whenever an action occurs within the CXTPShortcutBar


XTPShortcutBarPaintManager.h

Classes, Enumerations, Files, Legend
XTPShortcutBarPaintManager.h

XTPShortcutBarPaintManager.h interface for the CXTPShortcutBarPaintManager class.

Classes
Class | Description
CXTPShortcutBarOffice2000Theme | CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarOffice2003Theme | CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarOffice2007Theme | CXTPShortcutBarOffice2007Theme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007 shortcut bar theme.
CXTPShortcutBarOfficeXPTheme | CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarPaintManager | Standalone class used by CXTPShortcutBar as paint manager.
Enumerations
Enumeration | Description
XTPShortcutBarPaintTheme | XTPShortcutBarPaintTheme is an enumeration used by CXTPShortcutBar to set the theme of the control.
Group

Files

Legend
Enumeration


XTPShortcutBarPane.h

Classes, Files
XTPShortcutBarPane.h

XTPShortcutBarPane.h interface for the CXTPShortcutBarPane class.

Classes
Class | Description
CXTPShortcutBarPane | CXTPShortcutBarPane is a CWnd derived class. It is used as client area of ShortcutBar control.
CXTPShortcutBarPaneItem | CXTPShortcutBarPaneItem is the base class representing an item of the panes.
Group

Files


Skin Framework

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Functions, Structs, Records, Enums
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Skin Framework

Codejock Software's Xtreme Skin Framework allows Windows developers to fully skin their applications, including components such as title bar, scroll bars, buttons, checkboxes, and option buttons.

Group

Xtreme Toolkit Pro v12.0

Legend
Method
Enumeration
Classes
Class | Description
CXTPSkinImage | CXTPSkinImage class represents simple bitmap holder and draw operations for Skin Framework
CXTPSkinImages | CXTPSkinImages represents cashed collection of CXTPSkinImage classes
CXTPSkinManager | CXTPSkinManager is a standalone class that represents a global object managing skins.
CXTPSkinManagerClass | CXTPSkinManagerClass is a standalone class that represents a single visual class of skin manager.
CXTPSkinManagerMetrics | CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin
CXTPSkinManagerResourceFile | CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources
CXTPSkinManagerSchema | CXTPSkinManagerSchema is standalone class used to read visual styles schema file
CXTPSkinManagerSchemaDefault | CXTPSkinManagerSchemaDefault is CXTPSkinManagerSchema derived class is used to implement standard visual style.
CXTPSkinManagerSchemaProperty | CXTPSkinManagerSchemaProperty is standalone class represented single property of visual styles ini file
CXTPSkinObject | CXTPSkinObject is a CWnd derived class. It represents base class for all skinable windows.
CXTPSkinObjectButton | CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class. It implements standard buttons
CXTPSkinObjectClassMap | CXTPSkinObjectClassMap class is standalone class that help map windows controls to skin framework classes.
CXTPSkinObjectComboBox | CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class. It implements standard comboboxes
CXTPSkinObjectComCtl32Control | CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class. It is base class for all ComCtl32 defined controls
CXTPSkinObjectDateTime | CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class. It implements date time control
CXTPSkinObjectEdit | CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class. It implements standard edit control
CXTPSkinObjectFrame | CXTPSkinObjectFrame is a CXTPSkinObject derived class. It is parent control for all implementations that have border or scroll bars
CXTPSkinObjectHeader | CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class. It implements standard list header control
CXTPSkinObjectListBox | CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class. It implements standard list box control
CXTPSkinObjectListView | CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class. It implements standard listview control
CXTPSkinObjectMonthCal | CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class. It implements month calendar
CXTPSkinObjectProgress | CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class. It implements standard progress control
CXTPSkinObjectScrollBar | CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class. It implements standard scroll bar control
CXTPSkinObjectSpin | CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class. It implements standard spin control
CXTPSkinObjectStatusBar | CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class. It implements standard status bar control
CXTPSkinObjectTab | CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class. It implements standard tab control
CXTPSkinObjectToolBar | CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class. It implements standard toolbar control
CXTPSkinObjectTrackBar | CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class. It implements standard track bar control
CXTPSkinObjectTreeView | CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class. It implements standard tree view control
CXTPSkinObjectUser32Control | CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class. It is base class for all User32 defined controls
Files
File | Description
XTPSkinImage.h | XTPSkinImage.h: interface for the CXTPSkinImage class.
XTPSkinManager.h | XTPSkinManager.h: interface for the CXTPSkinManager class.
XTPSkinManagerApiHook.h | XTPSkinManagerApiHook.h: interface for the CXTPSkinManagerApiHook class.
XTPSkinManagerModuleList.h | XTPSkinManagerModuleList.h: interface for the CXTPSkinManagerModuleList class.
XTPSkinManagerResource.h | XTPSkinManagerResource.h: interface for the CXTPSkinManagerResourceFile class.
XTPSkinManagerSchema.h | XTPSkinManagerSchema.h: interface for the CXTPSkinManagerSchema class.
XTPSkinObject.h | XTPSkinObject.h: interface for the CXTPSkinObject class.
XTPSkinObjectButton.h | XTPSkinObjectButton.h: interface for the CXTPSkinObjectButton class.
XTPSkinObjectComboBox.h | XTPSkinObjectComboBox.h: interface for the CXTPSkinObjectComboBox class.
XTPSkinObjectEdit.h | XTPSkinObjectEdit.h: interface for the CXTPSkinObjectEdit class.
XTPSkinObjectFrame.h | XTPSkinObjectFrame.h: interface for the CXTPSkinObjectFrame class.
XTPSkinObjectHeader.h | XTPSkinObjectHeader.h: interface for the CXTPSkinObjectHeader class.
XTPSkinObjectListBox.h | XTPSkinObjectListBox.h: interface for the CXTPSkinObjectListBox class.
XTPSkinObjectListView.h | XTPSkinObjectListView.h: interface for the CXTPSkinObjectListView class.
XTPSkinObjectMDI.h | XTPSkinObjectMDI.h: interface for the CXTPSkinObjectMDI class.
XTPSkinObjectProgress.h | XTPSkinObjectProgress.h: interface for the CXTPSkinObjectProgress class.
XTPSkinObjectScrollBar.h | XTPSkinObjectScrollBar.h: interface for the CXTPSkinObjectScrollBar class.
XTPSkinObjectSpin.h | XTPSkinObjectSpin.h: interface for the CXTPSkinObjectSpin class.
XTPSkinObjectStatusBar.h | XTPSkinObjectStatusBar.h: interface for the CXTPSkinObjectStatusBar class.
XTPSkinObjectTab.h | XTPSkinObjectTab.h: interface for the CXTPSkinObjectTab class.
XTPSkinObjectToolBar.h | XTPSkinObjectToolBar.h: interface for the CXTPSkinObjectToolBar class.
XTPSkinObjectTrackBar.h | XTPSkinObjectTrackBar.h: interface for the CXTPSkinObjectTrackBar class.
XTPSkinObjectTreeView.h | XTPSkinObjectTreeView.h: interface for the CXTPSkinObjectTreeView class.
Functions
Function | Description
XTPSkinManager | Call this function to access CXTPSkinManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSkinManager.
Structs, Records, Enums
Struct, Record, Enum | Description
XTPSkinApplyOptions | Apply options of selected skin
XTPSkinManagerProperty | Available property for CXTPSkinManagerSchemaProperty class


Skin Framework Hierarchy

Skin Framework
Skin Framework Hierarchy

Module

Skin Framework


Classes

Classes, Skin Framework
Classes
Classes
Class | Description
CXTPSkinImage | CXTPSkinImage class represents simple bitmap holder and draw operations for Skin Framework
CXTPSkinImages | CXTPSkinImages represents cashed collection of CXTPSkinImage classes
CXTPSkinManager | CXTPSkinManager is a standalone class that represents a global object managing skins.
CXTPSkinManagerClass | CXTPSkinManagerClass is a standalone class that represents a single visual class of skin manager.
CXTPSkinManagerMetrics | CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin
CXTPSkinManagerResourceFile | CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources
CXTPSkinManagerSchema | CXTPSkinManagerSchema is standalone class used to read visual styles schema file
CXTPSkinManagerSchemaDefault | CXTPSkinManagerSchemaDefault is CXTPSkinManagerSchema derived class is used to implement standard visual style.
CXTPSkinManagerSchemaProperty | CXTPSkinManagerSchemaProperty is standalone class represented single property of visual styles ini file
CXTPSkinObject | CXTPSkinObject is a CWnd derived class. It represents base class for all skinable windows.
CXTPSkinObjectButton | CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class. It implements standard buttons
CXTPSkinObjectClassMap | CXTPSkinObjectClassMap class is standalone class that help map windows controls to skin framework classes.
CXTPSkinObjectComboBox | CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class. It implements standard comboboxes
CXTPSkinObjectComCtl32Control | CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class. It is base class for all ComCtl32 defined controls
CXTPSkinObjectDateTime | CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class. It implements date time control
CXTPSkinObjectEdit | CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class. It implements standard edit control
CXTPSkinObjectFrame | CXTPSkinObjectFrame is a CXTPSkinObject derived class. It is parent control for all implementations that have border or scroll bars
CXTPSkinObjectHeader | CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class. It implements standard list header control
CXTPSkinObjectListBox | CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class. It implements standard list box control
CXTPSkinObjectListView | CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class. It implements standard listview control
CXTPSkinObjectMonthCal | CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class. It implements month calendar
CXTPSkinObjectProgress | CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class. It implements standard progress control
CXTPSkinObjectScrollBar | CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class. It implements standard scroll bar control
CXTPSkinObjectSpin | CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class. It implements standard spin control
CXTPSkinObjectStatusBar | CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class. It implements standard status bar control
CXTPSkinObjectTab | CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class. It implements standard tab control
CXTPSkinObjectToolBar | CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class. It implements standard toolbar control
CXTPSkinObjectTrackBar | CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class. It implements standard track bar control
CXTPSkinObjectTreeView | CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class. It implements standard tree view control
CXTPSkinObjectUser32Control | CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class. It is base class for all User32 defined controls
Module

Skin Framework


CXTPSkinImage Class

XTPSkinImage.h, Classes, Legend, Members, Topics, CXTPSkinImage Data Members, CXTPSkinImage Methods, CXTPSkinImage Constructors, CXTPSkinImage Destructors, CXTPSkinImage Constructors, CXTPSkinImage Data Members, CXTPSkinImage Destructors, CXTPSkinImage Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinImage Class

CXTPSkinImage class represents simple bitmap holder and draw operations for Skin Framework

Class Hierarchy

class CXTPSkinImage;
File

XTPSkinImage.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSkinImage Constructors
CXTPSkinImage Constructors | Description
CXTPSkinImage | Constructs a CXTPSkinImage object.
CXTPSkinImage Data Members
CXTPSkinImage Data Members | Description
m_bAlpha | TRUE if bitmap has alpha pixels
m_bFiltered | TRUE if image was filtered
m_bMirrorImage | TRUE to Invert image in RTL mode
m_hBitmap | Bitmap handle
CXTPSkinImage Destructors
CXTPSkinImage Destructors | Description
~CXTPSkinImage | Destroys a CXTPSkinImage object, handles cleanup and deallocation.
CXTPSkinImage Methods
CXTPSkinImage Methods | Description
DrawImage |
GetExtent | Retrieves extent of the bitmap
GetHeight | Retrieves height of the bitmap
GetSource | Calculates position of image
GetWidth | Retrieves width of the bitmap
IsAlphaImage | Determines if bitmap has alpha pixels
LoadFile |
SetBitmap | Call this method to assign bitmap handle to CXTPSkinImage class


CXTPSkinImage Data Members

CXTPSkinImage Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinImage Data Members
Class

CXTPSkinImage Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bAlpha | TRUE if bitmap has alpha pixels
m_bFiltered | TRUE if image was filtered
m_hBitmap | Bitmap handle
Public Data Members
Public Data Member | Description
m_bMirrorImage | TRUE to Invert image in RTL mode


CXTPSkinImage::m_bAlpha Data Member

CXTPSkinImage Data Members, CXTPSkinImage Class
CXTPSkinImage::m_bAlpha Data Member

TRUE if bitmap has alpha pixels

BOOL m_bAlpha;
Group

CXTPSkinImage Data Members


CXTPSkinImage::m_bFiltered Data Member

CXTPSkinImage Data Members, CXTPSkinImage Class
CXTPSkinImage::m_bFiltered Data Member

TRUE if image was filtered

BOOL m_bFiltered;
Group

CXTPSkinImage Data Members


CXTPSkinImage::m_bMirrorImage Data Member

CXTPSkinImage Data Members, CXTPSkinImage Class
CXTPSkinImage::m_bMirrorImage Data Member

TRUE to Invert image in RTL mode

BOOL m_bMirrorImage;
Group

CXTPSkinImage Data Members


CXTPSkinImage::m_hBitmap Data Member

CXTPSkinImage Data Members, CXTPSkinImage Class
CXTPSkinImage::m_hBitmap Data Member

Bitmap handle

HBITMAP m_hBitmap;
Group

CXTPSkinImage Data Members


CXTPSkinImage Methods

CXTPSkinImage Class, Legend, Public Methods
CXTPSkinImage Methods
Class

CXTPSkinImage Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DrawImage |
GetExtent | Retrieves extent of the bitmap
GetHeight | Retrieves height of the bitmap
GetSource | Calculates position of image
GetWidth | Retrieves width of the bitmap
IsAlphaImage | Determines if bitmap has alpha pixels
LoadFile |
SetBitmap | Call this method to assign bitmap handle to CXTPSkinImage class


DrawImage Method

CXTPSkinImage Methods
DrawImage Method
Overload List
Methods
Method | Description
CXTPSkinImage::DrawImage (CDC*, const CRect&, const CRect&, const CRect&, COLORREF, int, BOOL) | Draws the image in specified location.
CXTPSkinImage::DrawImage (CDC*, const CRect&, const CRect&, const CRect&, int, BOOL) | Draws the image in specified location.
Group

CXTPSkinImage Methods


CXTPSkinImage::DrawImage Method (CDC*, const CRect&, const CRect&, const CRect&, int, BOOL)

DrawImage Method, CXTPSkinImage Class
CXTPSkinImage::DrawImage Method (CDC*, const CRect&, const CRect&, const CRect&, int, BOOL)

Draws the image in specified location.

void DrawImage(
    CDC* pDC,
    const CRect& rcDest,
    const CRect& rcSrc,
    const CRect& rcSizingMargins,
    int nSizingType,
    BOOL bBorderOnly
);
void DrawImage(
    CDC* pDC,
    const CRect& rcDest,
    const CRect& rcSrc,
    const CRect& rcSizingMargins,
    COLORREF clrTransparent,
    int nSizingType,
    BOOL bBorderOnly
);
Parameters

pDC
Destination device context.
rcDest
Specifies the location of the destination rectangle
rcSrc
Specifies the location of the source rectangle
rcSizingMargins
Specifies sizing margins
nSizingType
Stretch type
bBorderOnly
TRUE to draw only borders
clrTransparent
Transparent color

Group

DrawImage Method


CXTPSkinImage::GetExtent Method

CXTPSkinImage Methods, CXTPSkinImage Class
CXTPSkinImage::GetExtent Method

Retrieves extent of the bitmap

CSize GetExtent() const;
Group

CXTPSkinImage Methods


CXTPSkinImage::GetHeight Method

CXTPSkinImage Methods, CXTPSkinImage Class
CXTPSkinImage::GetHeight Method

Retrieves height of the bitmap

DWORD GetHeight() const;
Group

CXTPSkinImage Methods


CXTPSkinImage::GetSource Method

CXTPSkinImage Methods, CXTPSkinImage Class
CXTPSkinImage::GetSource Method

Calculates position of image

CRect GetSource(
    int nState = 0,
    int nCount = 1
) const;
Parameters

nState
Image index to retrieve
nCount
Total image count

Returns

Position of specified image

Group

CXTPSkinImage Methods


CXTPSkinImage::GetWidth Method

CXTPSkinImage Methods, CXTPSkinImage Class
CXTPSkinImage::GetWidth Method

Retrieves width of the bitmap

DWORD GetWidth() const;
Group

CXTPSkinImage Methods


CXTPSkinImage::IsAlphaImage Method

CXTPSkinImage Methods, CXTPSkinImage Class
CXTPSkinImage::IsAlphaImage Method

Determines if bitmap has alpha pixels

BOOL IsAlphaImage() const;
Group

CXTPSkinImage Methods


LoadFile Method

CXTPSkinImage Methods
LoadFile Method
Overload List
Methods
Method | Description
CXTPSkinImage::LoadFile (HMODULE, LPCTSTR) | This method is called to load bitmap from dll using its name identifier
CXTPSkinImage::LoadFile (LPCTSTR) | This method is called to load bitmap from dll using its name identifier
Group

CXTPSkinImage Methods


CXTPSkinImage::LoadFile Method (LPCTSTR)

LoadFile Method, CXTPSkinImage Class
CXTPSkinImage::LoadFile Method (LPCTSTR)

This method is called to load bitmap from dll using its name identifier

BOOL LoadFile(
    LPCTSTR lpszFileName
);
BOOL LoadFile(
    HMODULE hModule,
    LPCTSTR lpszBitmapFileName
);
Parameters

lpszFileName
File name on disk to load
hModule
Module handle
lpszBitmapFileName
Bitmap file name

Returns

TRUE if successful, otherwise returns FALSE

Group

LoadFile Method


CXTPSkinImage::SetBitmap Method

CXTPSkinImage Methods, CXTPSkinImage Class
CXTPSkinImage::SetBitmap Method

Call this method to assign bitmap handle to CXTPSkinImage class

void SetBitmap(
    HBITMAP hBitmap,
    BOOL bAlpha = FALSE
);
Parameters

hBitmap
Bitmap handle
bAlpha
TRUE if bitmap contains alpha pixels

Group

CXTPSkinImage Methods


CXTPSkinImage Constructors

CXTPSkinImage Class, Legend, Public Methods
CXTPSkinImage Constructors
Class

CXTPSkinImage Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinImage | Constructs a CXTPSkinImage object.


CXTPSkinImage::CXTPSkinImage Constructor

CXTPSkinImage Constructors, CXTPSkinImage Class
CXTPSkinImage::CXTPSkinImage Constructor

Constructs a CXTPSkinImage object.

CXTPSkinImage();
Group

CXTPSkinImage Constructors


CXTPSkinImage Destructors

CXTPSkinImage Class, Legend, Public Methods
CXTPSkinImage Destructors
Class

CXTPSkinImage Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinImage | Destroys a CXTPSkinImage object, handles cleanup and deallocation.


CXTPSkinImage::~CXTPSkinImage Destructor

CXTPSkinImage Destructors, CXTPSkinImage Class
CXTPSkinImage::~CXTPSkinImage Destructor

Destroys a CXTPSkinImage object, handles cleanup and deallocation.

virtual ~CXTPSkinImage();
Group

CXTPSkinImage Destructors


CXTPSkinImages Class

XTPSkinImage.h, Classes, Legend, Members, Topics, CXTPSkinImages Data Members, CXTPSkinImages Methods, CXTPSkinImages Constructors, CXTPSkinImages Destructors, CXTPSkinImages Constructors, CXTPSkinImages Data Members, CXTPSkinImages Destructors, CXTPSkinImages Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinImages Class

CXTPSkinImages represents cashed collection of CXTPSkinImage classes

Class Hierarchy

class CXTPSkinImages;
File

XTPSkinImage.h

Group

Classes

Legend
Data Member
protected
Method
CXTPSkinImages Constructors
CXTPSkinImages Constructors | Description
CXTPSkinImages | Constructs a CXTPSkinImages object.
CXTPSkinImages Data Members
CXTPSkinImages Data Members | Description
m_mapImages | Collection of images
CXTPSkinImages Destructors
CXTPSkinImages Destructors | Description
~CXTPSkinImages | Destroys a CXTPSkinImages object, handles cleanup and deallocation.
CXTPSkinImages Methods
CXTPSkinImages Methods | Description
GetExtent | Call this method to get extent of image in resource file.
LoadFile | Call this method to load image from resource file
RemoveAll | Call this method to remove all images


CXTPSkinImages Data Members

CXTPSkinImages Class, Legend, Protected Data Members
CXTPSkinImages Data Members
Class

CXTPSkinImages Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_mapImages | Collection of images


CXTPSkinImages::m_mapImages Data Member

CXTPSkinImages Data Members, CXTPSkinImages Class
CXTPSkinImages::m_mapImages Data Member

Collection of images

CMapStringToPtr m_mapImages;
Group

CXTPSkinImages Data Members


CXTPSkinImages Methods

CXTPSkinImages Class, Legend, Public Methods
CXTPSkinImages Methods
Class

CXTPSkinImages Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetExtent | Call this method to get extent of image in resource file.
LoadFile | Call this method to load image from resource file
RemoveAll | Call this method to remove all images


CXTPSkinImages::GetExtent Method

CXTPSkinImages Methods, CXTPSkinImages Class
CXTPSkinImages::GetExtent Method

Call this method to get extent of image in resource file.

CSize GetExtent(
    CXTPSkinManagerResourceFile* pResourceFile,
    LPCTSTR lpszImageFile
);
Parameters

pResourceFile
Resource file pointer
lpszImageFile
Path to Image

Returns

Extent of image.

Group

CXTPSkinImages Methods


CXTPSkinImages::LoadFile Method

CXTPSkinImages Methods, CXTPSkinImages Class
CXTPSkinImages::LoadFile Method

Call this method to load image from resource file

CXTPSkinImage* LoadFile(
    CXTPSkinManagerResourceFile* pResourceFile,
    LPCTSTR lpszImageFile
);
Parameters

pResourceFile
Resource file pointer
lpszImageFile
Path to Image

Returns

New CXTPSkinImage object if successful, otherwise returns NULL

Group

CXTPSkinImages Methods


CXTPSkinImages::RemoveAll Method

CXTPSkinImages Methods, CXTPSkinImages Class
CXTPSkinImages::RemoveAll Method

Call this method to remove all images

void RemoveAll();
Group

CXTPSkinImages Methods


CXTPSkinImages Constructors

CXTPSkinImages Class, Legend, Public Methods
CXTPSkinImages Constructors
Class

CXTPSkinImages Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinImages | Constructs a CXTPSkinImages object.


CXTPSkinImages::CXTPSkinImages Constructor

CXTPSkinImages Constructors, CXTPSkinImages Class
CXTPSkinImages::CXTPSkinImages Constructor

Constructs a CXTPSkinImages object.

CXTPSkinImages();
Group

CXTPSkinImages Constructors


CXTPSkinImages Destructors

CXTPSkinImages Class, Legend, Public Methods
CXTPSkinImages Destructors
Class

CXTPSkinImages Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinImages | Destroys a CXTPSkinImages object, handles cleanup and deallocation.


CXTPSkinImages::~CXTPSkinImages Destructor

CXTPSkinImages Destructors, CXTPSkinImages Class
CXTPSkinImages::~CXTPSkinImages Destructor

Destroys a CXTPSkinImages object, handles cleanup and deallocation.

~CXTPSkinImages();
Group

CXTPSkinImages Destructors


CXTPSkinManager Class

XTPSkinManager.h, Classes, Legend, Members, Topics, CXTPSkinManager Data Members, CXTPSkinManager Methods, CXTPSkinManager Constructors, CXTPSkinManager Destructors, CXTPSkinManager Constructors, CXTPSkinManager Data Members, CXTPSkinManager Destructors, CXTPSkinManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManager Class

CXTPSkinManager is a standalone class that represents a global object managing skins.

Class Hierarchy

class CXTPSkinManager;
File

XTPSkinManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSkinManager Constructors
CXTPSkinManager Constructors | Description
CXTPSkinManager | Constructs a CXTPSkinManager object.
CXTPSkinManager Data Members
CXTPSkinManager Data Members | Description
m_arrFilters | Array of filters to apply
m_bAutoApplyThreads | TRUE to auto skin all new windows
m_bAutoApplyWindows | TRUE to auto skin all new windows
m_bEnabled | TRIE if skinning is enabled
m_bWin9x | TRUE if OS is Win9x
m_dwApplyOptions | Apply options.
m_dwComCtrl | Version of ComCtl.dll
m_hWinEventHook | HWINEVENTHOOK value that identifies event hook instance
m_mapClasses | Classes collection
m_mapObjects | Collection of CXTPSkinObject classes
m_pClassMap | Class map helper
m_pMetrics | Skin metrics
m_pResourceFile | Resource file
m_pSchema | Current schema
s_pInstance | Instance of SkinManager
CXTPSkinManager Destructors
CXTPSkinManager Destructors | Description
~CXTPSkinManager | Destroys a CXTPSkinManager object, handles cleanup and deallocation.
CXTPSkinManager Methods
CXTPSkinManager Methods | Description
AddColorFilter | Adds new color filters
ApplyColorFilter | This method is called internally to transform color using installed color filters
ApplyWindow | Call this method to manually set window which appearance must be skinned.
EnableCurrentThread | Call this method for each thread in multi threaded application to enable skin framework for all threads
EnableThemeDialogTexture | Enables/disables dialog background theme. This method can be used to tailor dialog compatibility with child windows and controls that may or may not coordinate the rendering of their client area backgrounds with that of their parent dialog in a manner that supports seamless background texturing.
ExcludeModule | Exclude some dll from API hooking
FreeSkinData | This method is called to free skin resources
FromHandle | Returns CXTPSkinManagerClass class from specified HTHEME handle
GetApplyOptions | Retrieves what parts of application skin must apply.
GetAutoApplyNewThreads | Determines if all new threads will be automatically skinned
GetAutoApplyNewWindows | Determines if all new windows will be automatically skinned
GetClassMap | Retrieves class map object that porpoise to map window classes to skin framework classes
GetCurrentThemeName | Get the name of the current theme in-use.
GetMetrics | Call this method to get pointer to skin metrics
GetResourceFile | Call this method to get pointer to resource file
GetSchema | Call this method to get pointer to skin schema
GetSkinClass | Retrieves skin class by its name
GetThemeSysBool | Get the boolean value of specified System metric.
GetThemeSysColor | Get the value of the specified System color.
GetThemeSysFont | Get the LOGFONT for the specified System font.
GetThemeSysSize | Get the value of the specified System size metric. (scaled for the current logical screen dpi)
IsColorFilterExists | Determines if any color filter installed
IsComCtlV6 | Determines of ComCtl32.dll version 6.0 found
IsEnabled | Determines if skinning is currently enabled.
IsWin9x | Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 95 or a later version.
LoadSkin | Loads skin from cjstyles or msstyles file.
Lookup | Call this method to find CXTPSkinObject by its handle
OnSkinChanged | This method is called when skin is changed
ReadSkinData | This method is called to parse visual styles ini file
RedrawAllControls | Call this method to redraw all controls currently skinned
Remove | Removed hook for specified window
RemoveAll | Removes all hooks
RemoveColorFilters | Destroys all added color filters
SetApplyOptions | Call this method to set what parts of application skin must apply.
SetAutoApplyNewThreads | Call this method to enable/disable automatically apply each new thread with current skin
SetAutoApplyNewWindows | Call this method to enable/disable automatically apply each new window with current skin
SetHook | This method is called to create hook class for specified window
SetResourceFile | Call this method to set custom resource file
SetSkinManager | Call this method to set custom skin manager class


CXTPSkinManager Data Members

CXTPSkinManager Class, Legend, Protected Data Members
CXTPSkinManager Data Members
Class

CXTPSkinManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrFilters | Array of filters to apply
m_bAutoApplyThreads | TRUE to auto skin all new windows
m_bAutoApplyWindows | TRUE to auto skin all new windows
m_bEnabled | TRIE if skinning is enabled
m_bWin9x | TRUE if OS is Win9x
m_dwApplyOptions | Apply options.
m_dwComCtrl | Version of ComCtl.dll
m_hWinEventHook | HWINEVENTHOOK value that identifies event hook instance
m_mapClasses | Classes collection
m_mapObjects | Collection of CXTPSkinObject classes
m_pClassMap | Class map helper
m_pMetrics | Skin metrics
m_pResourceFile | Resource file
m_pSchema | Current schema
s_pInstance | Instance of SkinManager


CXTPSkinManager::m_arrFilters Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_arrFilters Data Member

Array of filters to apply

CArray<CXTPSkinManagerColorFilter*, CXTPSkinManagerColorFilter*> m_arrFilters;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_bAutoApplyThreads Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_bAutoApplyThreads Data Member

TRUE to auto skin all new windows

BOOL m_bAutoApplyThreads;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_bAutoApplyWindows Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_bAutoApplyWindows Data Member

TRUE to auto skin all new windows

BOOL m_bAutoApplyWindows;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_bEnabled Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_bEnabled Data Member

TRIE if skinning is enabled

BOOL m_bEnabled;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_bWin9x Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_bWin9x Data Member

TRUE if OS is Win9x

BOOL m_bWin9x;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_dwApplyOptions Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_dwApplyOptions Data Member

Apply options.

BOOL m_dwApplyOptions;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_dwComCtrl Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_dwComCtrl Data Member

Version of ComCtl.dll

DWORD m_dwComCtrl;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_hWinEventHook Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_hWinEventHook Data Member

HWINEVENTHOOK value that identifies event hook instance

HWINEVENTHOOK m_hWinEventHook;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_mapClasses Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_mapClasses Data Member

Classes collection

CMapStringToPtr m_mapClasses;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_mapObjects Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_mapObjects Data Member

Collection of CXTPSkinObject classes

CMap<HWND, HWND, CXTPSkinObject*, CXTPSkinObject*> m_mapObjects;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_pClassMap Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_pClassMap Data Member

Class map helper

CXTPSkinObjectClassMap* m_pClassMap;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_pMetrics Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_pMetrics Data Member

Skin metrics

CXTPSkinManagerMetrics* m_pMetrics;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_pResourceFile Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_pResourceFile Data Member

Resource file

CXTPSkinManagerResourceFile* m_pResourceFile;
Group

CXTPSkinManager Data Members


CXTPSkinManager::m_pSchema Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::m_pSchema Data Member

Current schema

CXTPSkinManagerSchema* m_pSchema;
Group

CXTPSkinManager Data Members


CXTPSkinManager::s_pInstance Data Member

CXTPSkinManager Data Members, CXTPSkinManager Class
CXTPSkinManager::s_pInstance Data Member

Instance of SkinManager

CXTPSkinManager* s_pInstance;
Group

CXTPSkinManager Data Members


CXTPSkinManager Methods

CXTPSkinManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManager Methods
Class

CXTPSkinManager Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
FreeSkinData | This method is called to free skin resources
OnSkinChanged | This method is called when skin is changed
ReadSkinData | This method is called to parse visual styles ini file
SetHook | This method is called to create hook class for specified window
Public Methods
Public Methods
Public Method | Description
AddColorFilter | Adds new color filters
ApplyColorFilter | This method is called internally to transform color using installed color filters
ApplyWindow | Call this method to manually set window which appearance must be skinned.
EnableCurrentThread | Call this method for each thread in multi threaded application to enable skin framework for all threads
EnableThemeDialogTexture | Enables/disables dialog background theme. This method can be used to tailor dialog compatibility with child windows and controls that may or may not coordinate the rendering of their client area backgrounds with that of their parent dialog in a manner that supports seamless background texturing.
ExcludeModule | Exclude some dll from API hooking
FromHandle | Returns CXTPSkinManagerClass class from specified HTHEME handle
GetApplyOptions | Retrieves what parts of application skin must apply.
GetAutoApplyNewThreads | Determines if all new threads will be automatically skinned
GetAutoApplyNewWindows | Determines if all new windows will be automatically skinned
GetClassMap | Retrieves class map object that porpoise to map window classes to skin framework classes
GetCurrentThemeName | Get the name of the current theme in-use.
GetMetrics | Call this method to get pointer to skin metrics
GetResourceFile | Call this method to get pointer to resource file
GetSchema | Call this method to get pointer to skin schema
GetSkinClass | Retrieves skin class by its name
GetThemeSysBool | Get the boolean value of specified System metric.
GetThemeSysColor | Get the value of the specified System color.
GetThemeSysFont | Get the LOGFONT for the specified System font.
GetThemeSysSize | Get the value of the specified System size metric. (scaled for the current logical screen dpi)
IsColorFilterExists | Determines if any color filter installed
IsComCtlV6 | Determines of ComCtl32.dll version 6.0 found
IsEnabled | Determines if skinning is currently enabled.
IsWin9x | Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 95 or a later version.
LoadSkin | Loads skin from cjstyles or msstyles file.
Lookup | Call this method to find CXTPSkinObject by its handle
RedrawAllControls | Call this method to redraw all controls currently skinned
Remove | Removed hook for specified window
RemoveAll | Removes all hooks
RemoveColorFilters | Destroys all added color filters
SetApplyOptions | Call this method to set what parts of application skin must apply.
SetAutoApplyNewThreads | Call this method to enable/disable automatically apply each new thread with current skin
SetAutoApplyNewWindows | Call this method to enable/disable automatically apply each new window with current skin
SetResourceFile | Call this method to set custom resource file
SetSkinManager | Call this method to set custom skin manager class


CXTPSkinManager::AddColorFilter Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::AddColorFilter Method

Adds new color filters

void AddColorFilter(
    CXTPSkinManagerColorFilter* pFilter
);
Parameters

pFilter
New filter to add

Group

CXTPSkinManager Methods


CXTPSkinManager::ApplyColorFilter Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::ApplyColorFilter Method

This method is called internally to transform color using installed color filters

void ApplyColorFilter(
    COLORREF& clr
);
Parameters

clr
Color to transform

Group

CXTPSkinManager Methods


CXTPSkinManager::ApplyWindow Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::ApplyWindow Method

Call this method to manually set window which appearance must be skinned.

void ApplyWindow(
    HWND hWnd
);
Parameters

hWnd
Handle of window which appearance must be skinned.

Group

CXTPSkinManager Methods


CXTPSkinManager::EnableCurrentThread Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::EnableCurrentThread Method

Call this method for each thread in multi threaded application to enable skin framework for all threads

void EnableCurrentThread();
Group

CXTPSkinManager Methods


CXTPSkinManager::EnableThemeDialogTexture Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::EnableThemeDialogTexture Method

Enables/disables dialog background theme. This method can be used to tailor dialog compatibility with child windows and controls that may or may not coordinate the rendering of their client area backgrounds with that of their parent dialog in a manner that supports seamless background texturing.

HRESULT EnableThemeDialogTexture(
    HWND hWnd,
    DWORD dwFlags
);
Parameters

hWnd
The window handle of the target dialog
dwFlags
One of the following

  • ETDT_ENABLE to enable the theme-defined dialog background texturing,
  • ETDT_DISABLE to disable background texturing,
  • ETDT_ENABLETAB to enable the theme-defined background texturing using the Tab texture

Returns

S_OK if successful

Group

CXTPSkinManager Methods


CXTPSkinManager::ExcludeModule Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::ExcludeModule Method

Exclude some dll from API hooking

void ExcludeModule(
    LPCTSTR lpszModule
);
Parameters

lpszModule
File name to exclude

Group

CXTPSkinManager Methods


CXTPSkinManager::FreeSkinData Method

CXTPSkinManager Methods, CXTPSkinManager Class, See Also
CXTPSkinManager::FreeSkinData Method

This method is called to free skin resources

void FreeSkinData();
See Also

ReadSkinData

Group

CXTPSkinManager Methods


CXTPSkinManager::FromHandle Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::FromHandle Method

Returns CXTPSkinManagerClass class from specified HTHEME handle

CXTPSkinManagerClass* FromHandle(
    HTHEME hTheme
);
Parameters

hTheme
Theme identifier

Returns

CXTPSkinManagerClass class if found.

Group

CXTPSkinManager Methods


CXTPSkinManager::GetApplyOptions Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManager::GetApplyOptions Method

Retrieves what parts of application skin must apply.

DWORD GetApplyOptions() const;
Returns

One or more of XTPSkinApplyOptions values

See Also

XTPSkinApplyOptions, SetApplyOptions

Body Source
DWORD CXTPSkinManager::GetApplyOptions() const {
    return m_dwApplyOptions;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::GetAutoApplyNewThreads Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source
CXTPSkinManager::GetAutoApplyNewThreads Method

Determines if all new threads will be automatically skinned

BOOL GetAutoApplyNewThreads() const;
Body Source
BOOL CXTPSkinManager::GetAutoApplyNewThreads()const {
    return m_bAutoApplyThreads;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::GetAutoApplyNewWindows Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source
CXTPSkinManager::GetAutoApplyNewWindows Method

Determines if all new windows will be automatically skinned

BOOL GetAutoApplyNewWindows() const;
Body Source
BOOL CXTPSkinManager::GetAutoApplyNewWindows() const {
    return m_bAutoApplyWindows;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::GetClassMap Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source
CXTPSkinManager::GetClassMap Method

Retrieves class map object that porpoise to map window classes to skin framework classes

CXTPSkinObjectClassMap* GetClassMap() const;
Body Source
CXTPSkinObjectClassMap* CXTPSkinManager::GetClassMap() const {
    return m_pClassMap;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::GetCurrentThemeName Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::GetCurrentThemeName Method

Get the name of the current theme in-use.

void GetCurrentThemeName(
    CString& strThemeFileName,
    CString& strColorBuff
);
Parameters

strThemeFileName
receives the theme path & filename
strColorBuff
receives the canonical color scheme name

Group

CXTPSkinManager Methods


CXTPSkinManager::GetMetrics Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source
CXTPSkinManager::GetMetrics Method

Call this method to get pointer to skin metrics

CXTPSkinManagerMetrics* GetMetrics() const;
Returns

Pointer to CXTPSkinManagerMetrics class contained metrics of the skin

Body Source
CXTPSkinManagerMetrics* CXTPSkinManager::GetMetrics() const {
    return m_pMetrics;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::GetResourceFile Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManager::GetResourceFile Method

Call this method to get pointer to resource file

CXTPSkinManagerResourceFile* GetResourceFile() const;
Returns

Pointer to CXTPSkinManagerResourceFile that managed resources of skins.

See Also

SetResourceFile

Body Source
CXTPSkinManagerResourceFile* CXTPSkinManager::GetResourceFile() const {
    return m_pResourceFile;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::GetSchema Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source
CXTPSkinManager::GetSchema Method

Call this method to get pointer to skin schema

CXTPSkinManagerSchema* GetSchema() const;
Returns

Pointer to CXTPSkinManagerSchema class used to draw window parts.

Body Source
CXTPSkinManagerSchema* CXTPSkinManager::GetSchema() const {
    return m_pSchema;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::GetSkinClass Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::GetSkinClass Method

Retrieves skin class by its name

virtual CXTPSkinManagerClass* GetSkinClass(
    CString strClassList
);
Parameters

strClassList
Name of the class

Returns

Pointer to CXTPSkinManagerClass class object.

Group

CXTPSkinManager Methods


CXTPSkinManager::GetThemeSysBool Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::GetThemeSysBool Method

Get the boolean value of specified System metric.

BOOL GetThemeSysBool(
    int iBoolId
);
Parameters

iBoolId
the TMT_XXX BOOL number (first BOOL is TMT_FLATMENUS)

Returns

BOOL value of specified System metric

Group

CXTPSkinManager Methods


CXTPSkinManager::GetThemeSysColor Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::GetThemeSysColor Method

Get the value of the specified System color.

COLORREF GetThemeSysColor(
    int iColorId
);
Parameters

iColorId
the system color index defined in winuser.h

Returns

COLORREF value if specified system color

Group

CXTPSkinManager Methods


CXTPSkinManager::GetThemeSysFont Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::GetThemeSysFont Method

Get the LOGFONT for the specified System font.

HRESULT GetThemeSysFont(
    int iFontId,
    LOGFONT * plf
);
Parameters

iFontId
The TMT_XXX font number (first font is TMT_CAPTIONFONT)
plf
Pointer to LOGFONT to receive the font value. (scaled for the current logical screen dpi)

Returns

S_OK if successful

Group

CXTPSkinManager Methods


CXTPSkinManager::GetThemeSysSize Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::GetThemeSysSize Method

Get the value of the specified System size metric. (scaled for the current logical screen dpi)

int GetThemeSysSize(
    int iSizeId
);
Parameters

iSizeId
The TMT_XXX size value.

Returns

Size value of the property

Group

CXTPSkinManager Methods


CXTPSkinManager::IsColorFilterExists Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::IsColorFilterExists Method

Determines if any color filter installed

BOOL IsColorFilterExists() const;
Group

CXTPSkinManager Methods


CXTPSkinManager::IsComCtlV6 Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManager::IsComCtlV6 Method

Determines of ComCtl32.dll version 6.0 found

BOOL IsComCtlV6() const;
Returns

TRUE if ComCtl32.dll has version 6.0 and above

See Also

IsWin9x

Body Source
BOOL CXTPSkinManager::IsComCtlV6() const {
    return m_dwComCtrl >= MAKELONG(0, 6);
}
Group

CXTPSkinManager Methods


CXTPSkinManager::IsEnabled Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source
CXTPSkinManager::IsEnabled Method

Determines if skinning is currently enabled.

BOOL IsEnabled() const;
Returns

TRUE if skinning is enabled.

Body Source
BOOL CXTPSkinManager::IsEnabled() const {
    return m_bEnabled;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::IsWin9x Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManager::IsWin9x Method

Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 95 or a later version.

BOOL IsWin9x() const;
Returns

TRUE if the OS is of the Windows 9x family, and is Windows 95 or a later version, otherwise returns false.

See Also

IsComCtlV6

Body Source
BOOL CXTPSkinManager::IsWin9x() const {
    return m_bWin9x;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::LoadSkin Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::LoadSkin Method

Loads skin from cjstyles or msstyles file.

BOOL LoadSkin(
    LPCTSTR lpszResourcePath,
    LPCTSTR lpszIniFileName = NULL
);
Parameters

lpszResourcePath
Path to skin file
lpszIniFileName
Ini file of skin to load

Returns

TRUE if successful; otherwise returns FALSE

Group

CXTPSkinManager Methods


CXTPSkinManager::Lookup Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::Lookup Method

Call this method to find CXTPSkinObject by its handle

CXTPSkinObject* Lookup(
    HWND hWnd
);
Parameters

hWnd
Handle of skinned window

Returns

Pointer to CXTPSkinObject that used to draw the window

Group

CXTPSkinManager Methods


CXTPSkinManager::OnSkinChanged Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::OnSkinChanged Method

This method is called when skin is changed

virtual void OnSkinChanged(
    BOOL bPrevState,
    BOOL bNewState
);
Parameters

bPrevState
TRUE if previously skin was installed
bNewState
TRUE if skin is installed

Group

CXTPSkinManager Methods


CXTPSkinManager::ReadSkinData Method

CXTPSkinManager Methods, CXTPSkinManager Class, See Also
CXTPSkinManager::ReadSkinData Method

This method is called to parse visual styles ini file

BOOL ReadSkinData(
    LPCTSTR lpszResourcePath,
    LPCTSTR lpszIniFileName
);
Parameters

lpszResourcePath
Resource file name
lpszIniFileName
Ini file name

Returns

TRUE if successful, otherwise returns FALSE.

See Also

FreeSkinData

Group

CXTPSkinManager Methods


CXTPSkinManager::RedrawAllControls Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::RedrawAllControls Method

Call this method to redraw all controls currently skinned

void RedrawAllControls();
Group

CXTPSkinManager Methods


CXTPSkinManager::Remove Method

CXTPSkinManager Methods, CXTPSkinManager Class, See Also
CXTPSkinManager::Remove Method

Removed hook for specified window

void Remove(
    HWND hWnd
);
Parameters

hWnd
Window handle to remove

See Also

RemoveAll

Group

CXTPSkinManager Methods


CXTPSkinManager::RemoveAll Method

CXTPSkinManager Methods, CXTPSkinManager Class, See Also
CXTPSkinManager::RemoveAll Method

Removes all hooks

void RemoveAll(
    BOOL bDetach = TRUE
);
Parameters

bDetach
TRUE to detach hooks before remove.

See Also

Remove

Group

CXTPSkinManager Methods


CXTPSkinManager::RemoveColorFilters Method

CXTPSkinManager Methods, CXTPSkinManager Class
CXTPSkinManager::RemoveColorFilters Method

Destroys all added color filters

void RemoveColorFilters();
Group

CXTPSkinManager Methods


CXTPSkinManager::SetApplyOptions Method

CXTPSkinManager Methods, CXTPSkinManager Class, See Also
CXTPSkinManager::SetApplyOptions Method

Call this method to set what parts of application skin must apply.

void SetApplyOptions(
    DWORD dwOptions
);
Parameters

dwOptions
combined by using the bitwise OR (|) operator of following:

  • xtpSkinApplyMetrics To apply skin metrics (caption height, scroll bar with, etc)
  • xtpSkinApplyFrame To apply window frames.

See Also

XTPSkinApplyOptions, GetApplyOptions

Group

CXTPSkinManager Methods


CXTPSkinManager::SetAutoApplyNewThreads Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source
CXTPSkinManager::SetAutoApplyNewThreads Method

Call this method to enable/disable automatically apply each new thread with current skin

void SetAutoApplyNewThreads(
    BOOL bAutoApply
);
Parameters

bAutoApply
TRUE to automatically apply each new thread.

Body Source
void CXTPSkinManager::SetAutoApplyNewThreads(BOOL bAutoApply) {
    m_bAutoApplyThreads = bAutoApply;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::SetAutoApplyNewWindows Method

CXTPSkinManager Methods, CXTPSkinManager Class, Body Source
CXTPSkinManager::SetAutoApplyNewWindows Method

Call this method to enable/disable automatically apply each new window with current skin

void SetAutoApplyNewWindows(
    BOOL bAutoApply
);
Parameters

bAutoApply
TRUE to automatically apply each new window.

Body Source
void CXTPSkinManager::SetAutoApplyNewWindows(BOOL bAutoApply) {
    m_bAutoApplyWindows = bAutoApply;
}
Group

CXTPSkinManager Methods


CXTPSkinManager::SetHook Method

CXTPSkinManager Methods, CXTPSkinManager Class, See Also
CXTPSkinManager::SetHook Method

This method is called to create hook class for specified window

virtual CXTPSkinObject* SetHook(
    HWND hWnd,
    LPCTSTR lpszClassName,
    LPCREATESTRUCT lpcs,
    BOOL bAuto
);
Parameters

hWnd
Window to hook
lpszClassName
Class name of specified window
style
Window style

Returns

New CXTPSkinObject file hooked specified window

See Also

CXTPSkinObject

Group

CXTPSkinManager Methods


CXTPSkinManager::SetResourceFile Method

CXTPSkinManager Methods, CXTPSkinManager Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManager::SetResourceFile Method

Call this method to set custom resource file

void SetResourceFile(
    CXTPSkinManagerResourceFile* pResourceFile
);
Parameters

pResourceFile
new resource file

See Also

GetResourceFile

Example
XTPSkinManager()->SetResourceFile(new CMySkinManagerResourceFile);
Group

CXTPSkinManager Methods


CXTPSkinManager::SetSkinManager Method

CXTPSkinManager Methods, CXTPSkinManager Class, Example
CXTPSkinManager::SetSkinManager Method

Call this method to set custom skin manager class

static void SetSkinManager(
    CXTPSkinManager* pSkinManager
);
Parameters

pSkinManager
new skin manager to be set

Example
CXTPSkinManager::SetSkinManager(new CMySkinManager());
Group

CXTPSkinManager Methods


CXTPSkinManager Constructors

CXTPSkinManager Class, Legend, Protected Methods
CXTPSkinManager Constructors
Class

CXTPSkinManager Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinManager | Constructs a CXTPSkinManager object.


CXTPSkinManager::CXTPSkinManager Constructor

CXTPSkinManager Constructors, CXTPSkinManager Class
CXTPSkinManager::CXTPSkinManager Constructor

Constructs a CXTPSkinManager object.

CXTPSkinManager();
Group

CXTPSkinManager Constructors


CXTPSkinManager Destructors

CXTPSkinManager Class, Legend, Public Methods
CXTPSkinManager Destructors
Class

CXTPSkinManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinManager | Destroys a CXTPSkinManager object, handles cleanup and deallocation.


CXTPSkinManager::~CXTPSkinManager Destructor

CXTPSkinManager Destructors, CXTPSkinManager Class
CXTPSkinManager::~CXTPSkinManager Destructor

Destroys a CXTPSkinManager object, handles cleanup and deallocation.

virtual ~CXTPSkinManager();
Group

CXTPSkinManager Destructors


CXTPSkinManagerClass Class

XTPSkinManager.h, Classes, Legend, Members, Topics, CXTPSkinManagerClass Data Members, CXTPSkinManagerClass Methods, CXTPSkinManagerClass Constructors, CXTPSkinManagerClass Destructors, CXTPSkinManagerClass Constructors, CXTPSkinManagerClass Data Members, CXTPSkinManagerClass Destructors, CXTPSkinManagerClass Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass Class

CXTPSkinManagerClass is a standalone class that represents a single visual class of skin manager.

Class Hierarchy

class CXTPSkinManagerClass;
File

XTPSkinManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSkinManagerClass Constructors
CXTPSkinManagerClass Constructors | Description
CXTPSkinManagerClass | Constructs a CXTPSkinManagerClass object.
CXTPSkinManagerClass Data Members
CXTPSkinManagerClass Data Members | Description
m_mapCachedProperties | Cached collection of class properties
m_nClassCode | Hashed value of class name
m_pImages | Image collection
m_pManager | Parent CXTPSkinManager object.
m_strClass | Class name
CXTPSkinManagerClass Destructors
CXTPSkinManagerClass Destructors | Description
~CXTPSkinManagerClass | Destroys a CXTPSkinManagerClass object, handles cleanup and deallocation.
CXTPSkinManagerClass Methods
CXTPSkinManagerClass Methods | Description
DrawThemeBackground | Draws the background image defined by the visual style for the specified control part.
DrawThemeText | Draws text using the color and font defined by the visual style.
GetClassCode | Retrieves hash value of class name
GetClassName | Retrieves class name
GetImages | Retrieves image collection of the class
GetProperty | Returns property value for specified part and state
GetThemeBool | Get the value for the specified BOOL property
GetThemeColor | Get the value for the specified color property
GetThemeEnumValue | Get the value for the specified ENUM property
GetThemeInt | Get the value for the specified int property
GetThemePartSize | Returns the specified size of the theme part
GetThemeRect | Get the value for the specified RECT property
GetThemeSize | Get the value for the specified Size property
GetThemeString | Get the value for the specified string property


CXTPSkinManagerClass Data Members

CXTPSkinManagerClass Class, Legend, Protected Data Members
CXTPSkinManagerClass Data Members
Class

CXTPSkinManagerClass Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_mapCachedProperties | Cached collection of class properties
m_nClassCode | Hashed value of class name
m_pImages | Image collection
m_pManager | Parent CXTPSkinManager object.
m_strClass | Class name


CXTPSkinManagerClass::m_mapCachedProperties Data Member

CXTPSkinManagerClass Data Members, CXTPSkinManagerClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::m_mapCachedProperties Data Member

Cached collection of class properties

CMap<UINT, UINT, CXTPSkinManagerSchemaProperty*, CXTPSkinManagerSchemaProperty*> m_mapCachedProperties;
Group

CXTPSkinManagerClass Data Members


CXTPSkinManagerClass::m_nClassCode Data Member

CXTPSkinManagerClass Data Members, CXTPSkinManagerClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::m_nClassCode Data Member

Hashed value of class name

UINT m_nClassCode;
Group

CXTPSkinManagerClass Data Members


CXTPSkinManagerClass::m_pImages Data Member

CXTPSkinManagerClass Data Members, CXTPSkinManagerClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::m_pImages Data Member

Image collection

CXTPSkinImages* m_pImages;
Group

CXTPSkinManagerClass Data Members


CXTPSkinManagerClass::m_pManager Data Member

CXTPSkinManagerClass Data Members, CXTPSkinManagerClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::m_pManager Data Member

Parent CXTPSkinManager object.

CXTPSkinManager* m_pManager;
Group

CXTPSkinManagerClass Data Members


CXTPSkinManagerClass::m_strClass Data Member

CXTPSkinManagerClass Data Members, CXTPSkinManagerClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::m_strClass Data Member

Class name

CString m_strClass;
Group

CXTPSkinManagerClass Data Members


CXTPSkinManagerClass Methods

CXTPSkinManagerClass Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass Methods
Class

CXTPSkinManagerClass Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
GetProperty | Returns property value for specified part and state
Public Methods
Public Methods
Public Method | Description
DrawThemeBackground | Draws the background image defined by the visual style for the specified control part.
DrawThemeText | Draws text using the color and font defined by the visual style.
GetClassCode | Retrieves hash value of class name
GetClassName | Retrieves class name
GetImages | Retrieves image collection of the class
GetThemeBool | Get the value for the specified BOOL property
GetThemeColor | Get the value for the specified color property
GetThemeEnumValue | Get the value for the specified ENUM property
GetThemeInt | Get the value for the specified int property
GetThemePartSize | Returns the specified size of the theme part
GetThemeRect | Get the value for the specified RECT property
GetThemeSize | Get the value for the specified Size property
GetThemeString | Get the value for the specified string property


CXTPSkinManagerClass::DrawThemeBackground Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::DrawThemeBackground Method

Draws the background image defined by the visual style for the specified control part.

BOOL DrawThemeBackground(
    CDC* pDC,
    int iPartId,
    int iStateId,
    const RECT * pRect
);
Parameters

pDC
Pointer to valid device context
iPartId
Value of type int that specifies the part to draw
iStateId
Value of type int that specifies the state of the part to draw.
pRect
Pointer to a RECT structure that contains the rectangle, in logical coordinates, in which the background image is drawn.

Returns

Returns TRUE if successful, FALSE otherwise.

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::DrawThemeText Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::DrawThemeText Method

Draws text using the color and font defined by the visual style.

BOOL DrawThemeText(
    CDC* pDC,
    int iPartId,
    int iStateId,
    const CString& strText,
    DWORD dwFormat,
    const RECT * pRect
);
Parameters

pDC
Pointer to valid device context
iPartId
Value of type int that specifies the part that contains the text.
iStateId
Value of type int that specifies the state of the part to draw.
strText
String that contains the text to draw.
dwFormat
DWORD that contains one or more values that specify the string's formatting.
pRect
Pointer to a RECT structure that contains the rectangle, in logical coordinates, in which the text is to be drawn.

Returns

Returns TRUE if successful, FALSE otherwise.

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetClassCode Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::GetClassCode Method

Retrieves hash value of class name

int GetClassCode() const;
Returns

Hash value of class name

Body Source
int CXTPSkinManagerClass::GetClassCode() const {
    return m_nClassCode;
}
Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetClassName Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::GetClassName Method

Retrieves class name

CString GetClassName() const;
Returns

CString value contained class name

Body Source
CString CXTPSkinManagerClass::GetClassName() const {
    return m_strClass;
}
Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetImages Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::GetImages Method

Retrieves image collection of the class

CXTPSkinImages* GetImages() const;
Returns

Pointer to image collection of the class.

Body Source
CXTPSkinImages* CXTPSkinManagerClass::GetImages() const {
    return m_pImages;
}
Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetProperty Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::GetProperty Method

Returns property value for specified part and state

CXTPSkinManagerSchemaProperty* GetProperty(
    XTPSkinManagerProperty propType,
    int iPartId,
    int iStateId,
    int iPropId
);
Parameters

propType
Property type
iPartId
Part number to retrieve size for
iStateId
State number of part
iPropId
The property number to get the value for

Returns

Returns CXTPSkinManagerSchemaProperty class contained value of the property

See Also

XTPSkinManagerProperty, CXTPSkinManagerSchemaProperty

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetThemeBool Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::GetThemeBool Method

Get the value for the specified BOOL property

BOOL GetThemeBool(
    int iPartId,
    int iStateId,
    int iPropId,
    BOOL bDefault = FALSE
);
Parameters

iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
bDefault
Default value

Returns

BOOL value for the specified property

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetThemeColor Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::GetThemeColor Method

Get the value for the specified color property

COLORREF GetThemeColor(
    int iPartId,
    int iStateId,
    int iPropId,
    COLORREF clrDefault = COLORREF_NULL
);
Parameters

iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
clrDefault
Default value

Returns

COLORREF value for the specified property

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetThemeEnumValue Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::GetThemeEnumValue Method

Get the value for the specified ENUM property

int GetThemeEnumValue(
    int iPartId,
    int iStateId,
    int iPropId,
    int nDefault = 0
);
Parameters

iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
nDefault
Default value

Returns

int value for the specified property

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetThemeInt Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::GetThemeInt Method

Get the value for the specified int property

int GetThemeInt(
    int iPartId,
    int iStateId,
    int iPropId,
    int nDefault = 0
);
Parameters

iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
nDefault
Default value

Returns

int value for the specified property

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetThemePartSize Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::GetThemePartSize Method

Returns the specified size of the theme part

BOOL GetThemePartSize(
    int iPartId,
    int iStateId,
    RECT * pRect,
    THEMESIZE eSize,
    SIZE* pSize
);
Parameters

iPartId
Part number to retrieve size for
iStateId
State number of part
pRect
rect for part drawing destination
eSize
the type of size to be retrieved
pSize
receives the specified size of the part

Returns

TRUE if successful, otherwise returns FALSE.

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetThemeRect Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::GetThemeRect Method

Get the value for the specified RECT property

CRect GetThemeRect(
    int iPartId,
    int iStateId,
    int iPropId,
    CRect rcDefault = CRect(0, 0, 0, 0)
);
Parameters

iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
rcDefault
Default value

Returns

CRect value for the specified RECT property

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetThemeSize Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::GetThemeSize Method

Get the value for the specified Size property

CSize GetThemeSize(
    int iPartId,
    int iStateId,
    int iPropId,
    CSize szDefault = CSize(0)
);
Parameters

iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
szDefault
Default value

Returns

CSize value for the specified property

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass::GetThemeString Method

CXTPSkinManagerClass Methods, CXTPSkinManagerClass Class
CXTPSkinManagerClass::GetThemeString Method

Get the value for the specified string property

CString GetThemeString(
    int iPartId,
    int iStateId,
    int iPropId,
    LPCTSTR lpszDefault = NULL
);
Parameters

iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
lpszDefault
Default value

Returns

CString value for the specified string property

Group

CXTPSkinManagerClass Methods


CXTPSkinManagerClass Constructors

CXTPSkinManagerClass Class, Legend, Protected Methods
CXTPSkinManagerClass Constructors
Class

CXTPSkinManagerClass Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinManagerClass | Constructs a CXTPSkinManagerClass object.


CXTPSkinManagerClass::CXTPSkinManagerClass Constructor

CXTPSkinManagerClass Constructors, CXTPSkinManagerClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerClass::CXTPSkinManagerClass Constructor

Constructs a CXTPSkinManagerClass object.

CXTPSkinManagerClass(
    CXTPSkinManager* pManager
);
Parameters

pManager
Parent skin manager class.

Group

CXTPSkinManagerClass Constructors


CXTPSkinManagerClass Destructors

CXTPSkinManagerClass Class, Legend, Protected Methods
CXTPSkinManagerClass Destructors
Class

CXTPSkinManagerClass Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPSkinManagerClass | Destroys a CXTPSkinManagerClass object, handles cleanup and deallocation.


CXTPSkinManagerClass::~CXTPSkinManagerClass Destructor

CXTPSkinManagerClass Destructors, CXTPSkinManagerClass Class
CXTPSkinManagerClass::~CXTPSkinManagerClass Destructor

Destroys a CXTPSkinManagerClass object, handles cleanup and deallocation.

virtual ~CXTPSkinManagerClass();
Group

CXTPSkinManagerClass Destructors


CXTPSkinManagerMetrics Class

XTPSkinManager.h, Classes, Legend, Members, Topics, CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Methods, CXTPSkinManagerMetrics Constructors, CXTPSkinManagerMetrics Destructors, CXTPSkinManagerMetrics Constructors, CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Destructors, CXTPSkinManagerMetrics Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics Class

CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin

Class Hierarchy

class CXTPSkinManagerMetrics;
File

XTPSkinManager.h

Group

Classes

Legend
Data Member
Method
virtual
CXTPSkinManagerMetrics Constructors
CXTPSkinManagerMetrics Constructors | Description
CXTPSkinManagerMetrics | Constructs a CXTPSkinManagerMetrics object.
CXTPSkinManagerMetrics Data Members
CXTPSkinManagerMetrics Data Members | Description
m_brTheme | Brushes of the theme
m_brushDialog | Dialog brush
m_brushTabControl | Tab Control brush;
m_clrEdgeDkShadow | Dark shadow edge color
m_clrEdgeHighLight | HighLight edge color
m_clrEdgeLight | Light edge color
m_clrEdgeShadow | Shadow edge color
m_clrTheme | Colors of the theme
m_cxBorder | SM_CXBORDER system metric
m_cxEdge | SM_CXEDGE system metric
m_cxHScroll | SM_CXHSCROLL system metric
m_cxVScroll | SM_CXVSCROLL system metric
m_cyBorder | SM_CYBORDER system metric
m_cyCaption | Height of captions
m_cyEdge | SM_CYEDGE system metric
m_cyHScroll | SM_CYHSCROLL system metric
m_cyOsCaption | System caption height
m_cyOsSmallCaption | System small caption height
m_cySmallCaption | Height of small captions
m_cyVScroll | SM_CYVSCROLL system metric
m_fntCaption | Caption font
m_fntMenu | Menu font
m_fntSmCaption | Small caption font
m_nBorderSize | Border size
m_pManager | Parent CXTPSkinManager object
CXTPSkinManagerMetrics Destructors
CXTPSkinManagerMetrics Destructors | Description
~CXTPSkinManagerMetrics | Destroys a CXTPSkinManagerMetrics object, handles cleanup and deallocation.
CXTPSkinManagerMetrics Methods
CXTPSkinManagerMetrics Methods | Description
RefreshMetrics | This method is called to refresh visual metrics.


CXTPSkinManagerMetrics Data Members

CXTPSkinManagerMetrics Class, Legend, Public Data Members
CXTPSkinManagerMetrics Data Members
Class

CXTPSkinManagerMetrics Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_brTheme | Brushes of the theme
m_brushDialog | Dialog brush
m_brushTabControl | Tab Control brush;
m_clrEdgeDkShadow | Dark shadow edge color
m_clrEdgeHighLight | HighLight edge color
m_clrEdgeLight | Light edge color
m_clrEdgeShadow | Shadow edge color
m_clrTheme | Colors of the theme
m_cxBorder | SM_CXBORDER system metric
m_cxEdge | SM_CXEDGE system metric
m_cxHScroll | SM_CXHSCROLL system metric
m_cxVScroll | SM_CXVSCROLL system metric
m_cyBorder | SM_CYBORDER system metric
m_cyCaption | Height of captions
m_cyEdge | SM_CYEDGE system metric
m_cyHScroll | SM_CYHSCROLL system metric
m_cyOsCaption | System caption height
m_cyOsSmallCaption | System small caption height
m_cySmallCaption | Height of small captions
m_cyVScroll | SM_CYVSCROLL system metric
m_fntCaption | Caption font
m_fntMenu | Menu font
m_fntSmCaption | Small caption font
m_nBorderSize | Border size
m_pManager | Parent CXTPSkinManager object


CXTPSkinManagerMetrics::m_brTheme Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_brTheme Data Member

Brushes of the theme

HBRUSH m_brTheme[XTP_SKINMETRICS_COLORTABLESIZE];
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_brushDialog Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_brushDialog Data Member

Dialog brush

HBRUSH m_brushDialog;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_brushTabControl Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_brushTabControl Data Member

Tab Control brush;

HBRUSH m_brushTabControl;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_clrEdgeDkShadow Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_clrEdgeDkShadow Data Member

Dark shadow edge color

COLORREF m_clrEdgeDkShadow;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_clrEdgeHighLight Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_clrEdgeHighLight Data Member

HighLight edge color

COLORREF m_clrEdgeHighLight;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_clrEdgeLight Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_clrEdgeLight Data Member

Light edge color

COLORREF m_clrEdgeLight;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_clrEdgeShadow Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_clrEdgeShadow Data Member

Shadow edge color

COLORREF m_clrEdgeShadow;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_clrTheme Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_clrTheme Data Member

Colors of the theme

COLORREF m_clrTheme[XTP_SKINMETRICS_COLORTABLESIZE];
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cxBorder Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cxBorder Data Member

SM_CXBORDER system metric

int m_cxBorder;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cxEdge Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cxEdge Data Member

SM_CXEDGE system metric

int m_cxEdge;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cxHScroll Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cxHScroll Data Member

SM_CXHSCROLL system metric

int m_cxHScroll;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cxVScroll Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cxVScroll Data Member

SM_CXVSCROLL system metric

int m_cxVScroll;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cyBorder Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cyBorder Data Member

SM_CYBORDER system metric

int m_cyBorder;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cyCaption Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cyCaption Data Member

Height of captions

int m_cyCaption;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cyEdge Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cyEdge Data Member

SM_CYEDGE system metric

int m_cyEdge;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cyHScroll Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cyHScroll Data Member

SM_CYHSCROLL system metric

int m_cyHScroll;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cyOsCaption Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cyOsCaption Data Member

System caption height

int m_cyOsCaption;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cyOsSmallCaption Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cyOsSmallCaption Data Member

System small caption height

int m_cyOsSmallCaption;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cySmallCaption Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cySmallCaption Data Member

Height of small captions

int m_cySmallCaption;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_cyVScroll Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_cyVScroll Data Member

SM_CYVSCROLL system metric

int m_cyVScroll;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_fntCaption Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_fntCaption Data Member

Caption font

CFont m_fntCaption;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_fntMenu Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_fntMenu Data Member

Menu font

CFont m_fntMenu;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_fntSmCaption Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_fntSmCaption Data Member

Small caption font

CFont m_fntSmCaption;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_nBorderSize Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_nBorderSize Data Member

Border size

int m_nBorderSize;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics::m_pManager Data Member

CXTPSkinManagerMetrics Data Members, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::m_pManager Data Member

Parent CXTPSkinManager object

CXTPSkinManager* m_pManager;
Group

CXTPSkinManagerMetrics Data Members


CXTPSkinManagerMetrics Methods

CXTPSkinManagerMetrics Class, Legend, Public Methods
CXTPSkinManagerMetrics Methods
Class

CXTPSkinManagerMetrics Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called to refresh visual metrics.


CXTPSkinManagerMetrics::RefreshMetrics Method

CXTPSkinManagerMetrics Methods, CXTPSkinManagerMetrics Class
CXTPSkinManagerMetrics::RefreshMetrics Method

This method is called to refresh visual metrics.

virtual void RefreshMetrics();
Group

CXTPSkinManagerMetrics Methods


CXTPSkinManagerMetrics Constructors

CXTPSkinManagerMetrics Class, Legend, Public Methods
CXTPSkinManagerMetrics Constructors
Class

CXTPSkinManagerMetrics Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerMetrics | Constructs a CXTPSkinManagerMetrics object.


CXTPSkinManagerMetrics::CXTPSkinManagerMetrics Constructor

CXTPSkinManagerMetrics Constructors, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::CXTPSkinManagerMetrics Constructor

Constructs a CXTPSkinManagerMetrics object.

CXTPSkinManagerMetrics(
    CXTPSkinManager* pManager
);
Parameters

pManager
Parent skin manager class.

Group

CXTPSkinManagerMetrics Constructors


CXTPSkinManagerMetrics Destructors

CXTPSkinManagerMetrics Class, Legend, Public Methods
CXTPSkinManagerMetrics Destructors
Class

CXTPSkinManagerMetrics Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinManagerMetrics | Destroys a CXTPSkinManagerMetrics object, handles cleanup and deallocation.


CXTPSkinManagerMetrics::~CXTPSkinManagerMetrics Destructor

CXTPSkinManagerMetrics Destructors, CXTPSkinManagerMetrics Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerMetrics::~CXTPSkinManagerMetrics Destructor

Destroys a CXTPSkinManagerMetrics object, handles cleanup and deallocation.

virtual ~CXTPSkinManagerMetrics();
Group

CXTPSkinManagerMetrics Destructors


CXTPSkinManagerResourceFile Class

XTPSkinManagerResource.h, Classes, Legend, Members, Topics, CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Constructors, CXTPSkinManagerResourceFile Destructors, CXTPSkinManagerResourceFile Constructors, CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Destructors, CXTPSkinManagerResourceFile Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile Class

CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources

Class Hierarchy

class CXTPSkinManagerResourceFile;
File

XTPSkinManagerResource.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSkinManagerResourceFile Constructors
CXTPSkinManagerResourceFile Constructors | Description
CXTPSkinManagerResourceFile | Constructs a CXTPSkinManagerResourceFile object.
CXTPSkinManagerResourceFile Data Members
CXTPSkinManagerResourceFile Data Members | Description
m_hInstance | Handle of the visual style
m_hModule | Handle of the visual style
m_lpTextFile | Pointer to next string
m_lpTextFileEnd | Pointer to end of the file
m_pIniFile | POinter to ini file on disk
m_pManager | Parent manager class.
m_strIniFileName | Ini file name.
m_strResourcePath | Resource path
CXTPSkinManagerResourceFile Destructors
CXTPSkinManagerResourceFile Destructors | Description
~CXTPSkinManagerResourceFile | Destroys a CXTPSkinManagerResourceFile object, handles cleanup and deallocation.
CXTPSkinManagerResourceFile Methods
CXTPSkinManagerResourceFile Methods | Description
Close | This method is called to close visual style file
CreateSchema | This method is called to create CXTPSkinManagerSchema class associated with loaded resources
GetIniFileName | Retrieves resource path
GetModuleHandle | Retrieves handle to visual style dll file handle.
GetResourcePath | Retrieves resource path
LoadImage | This method is called to load image from resource file
Open | This method is called to open visual style file
ReadString | This method is called to read ini file
SetModuleHandle | Call this method to set module with skin


CXTPSkinManagerResourceFile Data Members

CXTPSkinManagerResourceFile Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile Data Members
Class

CXTPSkinManagerResourceFile Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_hInstance | Handle of the visual style
m_hModule | Handle of the visual style
m_lpTextFile | Pointer to next string
m_lpTextFileEnd | Pointer to end of the file
m_pIniFile | POinter to ini file on disk
m_pManager | Parent manager class.
m_strIniFileName | Ini file name.
m_strResourcePath | Resource path


CXTPSkinManagerResourceFile::m_hInstance Data Member

CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::m_hInstance Data Member

Handle of the visual style

HMODULE m_hInstance;
Group

CXTPSkinManagerResourceFile Data Members


CXTPSkinManagerResourceFile::m_hModule Data Member

CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::m_hModule Data Member

Handle of the visual style

HMODULE m_hModule;
Group

CXTPSkinManagerResourceFile Data Members


CXTPSkinManagerResourceFile::m_lpTextFile Data Member

CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::m_lpTextFile Data Member

Pointer to next string

LPWSTR m_lpTextFile;
Group

CXTPSkinManagerResourceFile Data Members


CXTPSkinManagerResourceFile::m_lpTextFileEnd Data Member

CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::m_lpTextFileEnd Data Member

Pointer to end of the file

LPWSTR m_lpTextFileEnd;
Group

CXTPSkinManagerResourceFile Data Members


CXTPSkinManagerResourceFile::m_pIniFile Data Member

CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::m_pIniFile Data Member

POinter to ini file on disk

CStdioFile* m_pIniFile;
Group

CXTPSkinManagerResourceFile Data Members


CXTPSkinManagerResourceFile::m_pManager Data Member

CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::m_pManager Data Member

Parent manager class.

CXTPSkinManager* m_pManager;
Group

CXTPSkinManagerResourceFile Data Members


CXTPSkinManagerResourceFile::m_strIniFileName Data Member

CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::m_strIniFileName Data Member

Ini file name.

CString m_strIniFileName;
Group

CXTPSkinManagerResourceFile Data Members


CXTPSkinManagerResourceFile::m_strResourcePath Data Member

CXTPSkinManagerResourceFile Data Members, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::m_strResourcePath Data Member

Resource path

CString m_strResourcePath;
Group

CXTPSkinManagerResourceFile Data Members


CXTPSkinManagerResourceFile Methods

CXTPSkinManagerResourceFile Class, Legend, Public Methods
CXTPSkinManagerResourceFile Methods
Class

CXTPSkinManagerResourceFile Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Close | This method is called to close visual style file
CreateSchema | This method is called to create CXTPSkinManagerSchema class associated with loaded resources
GetIniFileName | Retrieves resource path
GetModuleHandle | Retrieves handle to visual style dll file handle.
GetResourcePath | Retrieves resource path
LoadImage | This method is called to load image from resource file
Open | This method is called to open visual style file
ReadString | This method is called to read ini file
SetModuleHandle | Call this method to set module with skin


CXTPSkinManagerResourceFile::Close Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::Close Method

This method is called to close visual style file

virtual void Close();
Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile::CreateSchema Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::CreateSchema Method

This method is called to create CXTPSkinManagerSchema class associated with loaded resources

virtual CXTPSkinManagerSchema* CreateSchema();
Returns

New CXTPSkinManagerSchema class that will be used to read resource

See Also

CXTPSkinManagerSchema

Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile::GetIniFileName Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::GetIniFileName Method

Retrieves resource path

CString GetIniFileName() const;
Body Source
CString CXTPSkinManagerResourceFile::GetIniFileName() const {
    return m_strIniFileName;
}
Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile::GetModuleHandle Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::GetModuleHandle Method

Retrieves handle to visual style dll file handle.

HMODULE GetModuleHandle() const;
Body Source
HMODULE CXTPSkinManagerResourceFile::GetModuleHandle() const {
    return m_hModule;
}
Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile::GetResourcePath Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::GetResourcePath Method

Retrieves resource path

CString GetResourcePath() const;
Body Source
CString CXTPSkinManagerResourceFile::GetResourcePath() const {
    return m_strResourcePath;
}
Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile::LoadImage Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::LoadImage Method

This method is called to load image from resource file

virtual CXTPSkinImage* LoadImage(
    CString strImageFile
);
Parameters

strImageFile
Path to specified image

Returns

New CXTPSkinImage contained loaded bitmap

Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile::Open Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::Open Method

This method is called to open visual style file

virtual BOOL Open(
    LPCTSTR lpszResourcePath,
    LPCTSTR lpszIniFileName
);
Parameters

lpszResourcePath
Path to specified visual style
lpszIniFileName
Name of the ini file to load

Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile::ReadString Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::ReadString Method

This method is called to read ini file

virtual BOOL ReadString(
    CString& str
);
Parameters

str
reference to the string used to load next line from resource file.

Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile::SetModuleHandle Method

CXTPSkinManagerResourceFile Methods, CXTPSkinManagerResourceFile Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::SetModuleHandle Method

Call this method to set module with skin

void SetModuleHandle(
    HMODULE hModule
);
Parameters

hModule
New module handler to set

Body Source
void CXTPSkinManagerResourceFile::SetModuleHandle(HMODULE hModule) {
    m_hInstance = hModule;
}
Group

CXTPSkinManagerResourceFile Methods


CXTPSkinManagerResourceFile Constructors

CXTPSkinManagerResourceFile Class, Legend, Public Methods
CXTPSkinManagerResourceFile Constructors
Class

CXTPSkinManagerResourceFile Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerResourceFile | Constructs a CXTPSkinManagerResourceFile object.


CXTPSkinManagerResourceFile::CXTPSkinManagerResourceFile Constructor

CXTPSkinManagerResourceFile Constructors, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::CXTPSkinManagerResourceFile Constructor

Constructs a CXTPSkinManagerResourceFile object.

CXTPSkinManagerResourceFile();
Group

CXTPSkinManagerResourceFile Constructors


CXTPSkinManagerResourceFile Destructors

CXTPSkinManagerResourceFile Class, Legend, Public Methods
CXTPSkinManagerResourceFile Destructors
Class

CXTPSkinManagerResourceFile Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinManagerResourceFile | Destroys a CXTPSkinManagerResourceFile object, handles cleanup and deallocation.


CXTPSkinManagerResourceFile::~CXTPSkinManagerResourceFile Destructor

CXTPSkinManagerResourceFile Destructors, CXTPSkinManagerResourceFile Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerResourceFile::~CXTPSkinManagerResourceFile Destructor

Destroys a CXTPSkinManagerResourceFile object, handles cleanup and deallocation.

virtual ~CXTPSkinManagerResourceFile();
Group

CXTPSkinManagerResourceFile Destructors


CXTPSkinManagerSchema Class

XTPSkinManagerSchema.h, Classes, Legend, Members, Topics, CXTPSkinManagerSchema Data Members, CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Constructors, CXTPSkinManagerSchema Destructors, CXTPSkinManagerSchema Constructors, CXTPSkinManagerSchema Data Members, CXTPSkinManagerSchema Destructors, CXTPSkinManagerSchema Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchema Class

CXTPSkinManagerSchema is standalone class used to read visual styles schema file

Class Hierarchy

class CXTPSkinManagerSchema;
File

XTPSkinManagerSchema.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSkinManagerSchema Constructors
CXTPSkinManagerSchema Constructors | Description
CXTPSkinManagerSchema | Constructs a CXTPSkinManagerSchema object.
CXTPSkinManagerSchema Data Members
CXTPSkinManagerSchema Data Members | Description
m_mapProperties | Properties collection
m_pManager | Parent CXTPSkinManager class
m_strSchemaName | Schema name
CXTPSkinManagerSchema Destructors
CXTPSkinManagerSchema Destructors | Description
~CXTPSkinManagerSchema | Destroys a CXTPSkinManagerSchema object, handles cleanup and deallocation.
CXTPSkinManagerSchema Methods
CXTPSkinManagerSchema Methods | Description
GetBoolProperty | Get the value for the specified BOOL property
GetClassCode | Returns class hash code
GetColorProperty | Get the value for the specified COLORREF property
GetEnumProperty | Get the value for the specified enum property
GetFontProperty | Get the value for the specified LOGFONT property
GetIntProperty | Get the value for the specified int property
GetRectProperty | Get the value for the specified rect property
GetSchemaName | Returns schema name
GetSizeProperty | Get the value for the specified CSize property
GetSkinManager | Retrieves parent skin manager object
GetStringProperty | Get the value for the specified string property
ReadProperties | This method is called to read all properties from resource file


CXTPSkinManagerSchema Data Members

CXTPSkinManagerSchema Class, Legend, Protected Data Members
CXTPSkinManagerSchema Data Members
Class

CXTPSkinManagerSchema Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_mapProperties | Properties collection
m_pManager | Parent CXTPSkinManager class
m_strSchemaName | Schema name


CXTPSkinManagerSchema::m_mapProperties Data Member

CXTPSkinManagerSchema Data Members, CXTPSkinManagerSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchema::m_mapProperties Data Member

Properties collection

CMap<UINT, UINT, CXTPSkinManagerSchemaProperty*, CXTPSkinManagerSchemaProperty*> m_mapProperties;
Group

CXTPSkinManagerSchema Data Members


CXTPSkinManagerSchema::m_pManager Data Member

CXTPSkinManagerSchema Data Members, CXTPSkinManagerSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchema::m_pManager Data Member

Parent CXTPSkinManager class

CXTPSkinManager* m_pManager;
Group

CXTPSkinManagerSchema Data Members


CXTPSkinManagerSchema::m_strSchemaName Data Member

CXTPSkinManagerSchema Data Members, CXTPSkinManagerSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchema::m_strSchemaName Data Member

Schema name

CString m_strSchemaName;
Group

CXTPSkinManagerSchema Data Members


CXTPSkinManagerSchema Methods

CXTPSkinManagerSchema Class, Legend, Public Methods
CXTPSkinManagerSchema Methods
Class

CXTPSkinManagerSchema Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetBoolProperty | Get the value for the specified BOOL property
GetClassCode | Returns class hash code
GetColorProperty | Get the value for the specified COLORREF property
GetEnumProperty | Get the value for the specified enum property
GetFontProperty | Get the value for the specified LOGFONT property
GetIntProperty | Get the value for the specified int property
GetRectProperty | Get the value for the specified rect property
GetSchemaName | Returns schema name
GetSizeProperty | Get the value for the specified CSize property
GetSkinManager | Retrieves parent skin manager object
GetStringProperty | Get the value for the specified string property
ReadProperties | This method is called to read all properties from resource file


CXTPSkinManagerSchema::GetBoolProperty Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetBoolProperty Method

Get the value for the specified BOOL property

HRESULT GetBoolProperty(
    UINT iClassId,
    int iPartId,
    int iStateId,
    int iPropId,
    BOOL& bVal
);
Parameters

iClassId
Class hash code
iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
bVal
receives the BOOL property value

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetClassCode Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetClassCode Method

Returns class hash code

static UINT GetClassCode(
    LPCTSTR strClass
);
Parameters

strClass
Class name

Returns

UINT class hash code

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetColorProperty Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetColorProperty Method

Get the value for the specified COLORREF property

HRESULT GetColorProperty(
    UINT iClassId,
    int iPartId,
    int iStateId,
    int iPropId,
    COLORREF& clrVal
);
Parameters

iClassId
Class hash code
iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
clrVal
receives the COLORREF property value

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetEnumProperty Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetEnumProperty Method

Get the value for the specified enum property

HRESULT GetEnumProperty(
    UINT iClassId,
    int iPartId,
    int iStateId,
    int iPropId,
    int& nVal
);
Parameters

iClassId
Class hash code
iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
nVal
receives the enum property value

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetFontProperty Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetFontProperty Method

Get the value for the specified LOGFONT property

HRESULT GetFontProperty(
    UINT iClassId,
    int iPartId,
    int iStateId,
    int iPropId,
    LOGFONT& lfVal
);
Parameters

iClassId
Class hash code
iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
lfVal
receives the LOGFONT property value

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetIntProperty Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetIntProperty Method

Get the value for the specified int property

HRESULT GetIntProperty(
    UINT iClassId,
    int iPartId,
    int iStateId,
    int iPropId,
    int& iVal
);
Parameters

iClassId
Class hash code
iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
iVal
receives the int property value

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetRectProperty Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetRectProperty Method

Get the value for the specified rect property

HRESULT GetRectProperty(
    UINT iClassId,
    int iPartId,
    int iStateId,
    int iPropId,
    CRect& rcVal
);
Parameters

iClassId
Class hash code
iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
rcVal
receives the rect property value

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetSchemaName Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchema::GetSchemaName Method

Returns schema name

CString GetSchemaName() const;
Returns

Selected schema name

Body Source
CString CXTPSkinManagerSchema::GetSchemaName() const {
    return m_strSchemaName;
}
Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetSizeProperty Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetSizeProperty Method

Get the value for the specified CSize property

HRESULT GetSizeProperty(
    UINT iClassId,
    int iPartId,
    int iStateId,
    int iPropId,
    CSize& szVal
);
Parameters

iClassId
Class hash code
iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
szVal
Receives the CSize property value

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetSkinManager Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchema::GetSkinManager Method

Retrieves parent skin manager object

CXTPSkinManager* GetSkinManager() const;
Returns

Pointer to CXTPSkinManager object

Body Source
CXTPSkinManager* CXTPSkinManagerSchema::GetSkinManager() const {
    return m_pManager;
}
Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::GetStringProperty Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::GetStringProperty Method

Get the value for the specified string property

HRESULT GetStringProperty(
    UINT iClassId,
    int iPartId,
    int iStateId,
    int iPropId,
    CString& strVal
);
Parameters

iClassId
Class hash code
iPartId
Part number
iStateId
State number of part
iPropId
The property number to get the value for
strVal
receives the string property value

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema::ReadProperties Method

CXTPSkinManagerSchema Methods, CXTPSkinManagerSchema Class
CXTPSkinManagerSchema::ReadProperties Method

This method is called to read all properties from resource file

HRESULT ReadProperties(
    CXTPSkinManagerResourceFile* pResourceFile
);
Parameters

pResourceFile
Resource file to read

Returns

S_OK if successful

Group

CXTPSkinManagerSchema Methods


CXTPSkinManagerSchema Constructors

CXTPSkinManagerSchema Class, Legend, Public Methods
CXTPSkinManagerSchema Constructors
Class

CXTPSkinManagerSchema Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerSchema | Constructs a CXTPSkinManagerSchema object.


CXTPSkinManagerSchema::CXTPSkinManagerSchema Constructor

CXTPSkinManagerSchema Constructors, CXTPSkinManagerSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchema::CXTPSkinManagerSchema Constructor

Constructs a CXTPSkinManagerSchema object.

CXTPSkinManagerSchema(
    CXTPSkinManager* pManager
);
Parameters

pManager
Parent skin manager class.

Group

CXTPSkinManagerSchema Constructors


CXTPSkinManagerSchema Destructors

CXTPSkinManagerSchema Class, Legend, Public Methods
CXTPSkinManagerSchema Destructors
Class

CXTPSkinManagerSchema Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinManagerSchema | Destroys a CXTPSkinManagerSchema object, handles cleanup and deallocation.


CXTPSkinManagerSchema::~CXTPSkinManagerSchema Destructor

CXTPSkinManagerSchema Destructors, CXTPSkinManagerSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchema::~CXTPSkinManagerSchema Destructor

Destroys a CXTPSkinManagerSchema object, handles cleanup and deallocation.

virtual ~CXTPSkinManagerSchema();
Group

CXTPSkinManagerSchema Destructors


CXTPSkinManagerSchemaDefault Class

XTPSkinManagerSchema.h, Classes, Legend, Members, Topics, CXTPSkinManagerSchemaDefault Data Members, CXTPSkinManagerSchemaDefault Constructors, CXTPSkinManagerSchemaDefault Destructors, CXTPSkinManagerSchemaDefault Constructors, CXTPSkinManagerSchemaDefault Data Members, CXTPSkinManagerSchemaDefault Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaDefault Class

CXTPSkinManagerSchemaDefault is CXTPSkinManagerSchema derived class is used to implement standard visual style.

Class Hierarchy

class CXTPSkinManagerSchemaDefault : public CXTPSkinManagerSchema;
File

XTPSkinManagerSchema.h

Group

Classes

Legend
Data Member
protected
Constructor
CXTPSkinManagerSchemaDefault Constructors
CXTPSkinManagerSchemaDefault Constructors | Description
CXTPSkinManagerSchemaDefault | Constructs a CXTPSkinManagerSchemaDefault object.
CXTPSkinManagerSchemaDefault Data Members
CXTPSkinManagerSchemaDefault Data Members | Description
m_arrFrameRegions | Frame region
m_nFrameButtonOffset | Frame Button offset
CXTPSkinManagerSchemaDefault Destructors
CXTPSkinManagerSchemaDefault Destructors | Description
~CXTPSkinManagerSchemaDefault | Destroys a CXTPSkinManagerSchemaDefault object, handles cleanup and deallocation.


CXTPSkinManagerSchemaDefault Data Members

CXTPSkinManagerSchemaDefault Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaDefault Data Members
Class

CXTPSkinManagerSchemaDefault Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrFrameRegions | Frame region
m_nFrameButtonOffset | Frame Button offset


CXTPSkinManagerSchemaDefault::m_arrFrameRegions Data Member

CXTPSkinManagerSchemaDefault Data Members, CXTPSkinManagerSchemaDefault Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaDefault::m_arrFrameRegions Data Member

Frame region

CArray<FRAMEREGION*, FRAMEREGION*> m_arrFrameRegions;
Group

CXTPSkinManagerSchemaDefault Data Members


CXTPSkinManagerSchemaDefault::m_nFrameButtonOffset Data Member

CXTPSkinManagerSchemaDefault Data Members, CXTPSkinManagerSchemaDefault Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaDefault::m_nFrameButtonOffset Data Member

Frame Button offset

int m_nFrameButtonOffset;
Group

CXTPSkinManagerSchemaDefault Data Members


CXTPSkinManagerSchemaDefault Constructors

CXTPSkinManagerSchemaDefault Class, Legend, Public Methods
CXTPSkinManagerSchemaDefault Constructors
Class

CXTPSkinManagerSchemaDefault Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerSchemaDefault | Constructs a CXTPSkinManagerSchemaDefault object.


CXTPSkinManagerSchemaDefault::CXTPSkinManagerSchemaDefault Constructor

CXTPSkinManagerSchemaDefault Constructors, CXTPSkinManagerSchemaDefault Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaDefault::CXTPSkinManagerSchemaDefault Constructor

Constructs a CXTPSkinManagerSchemaDefault object.

CXTPSkinManagerSchemaDefault(
    CXTPSkinManager* pManager
);
Parameters

pManager
Parent skin manager class.

Group

CXTPSkinManagerSchemaDefault Constructors


CXTPSkinManagerSchemaDefault Destructors

CXTPSkinManagerSchemaDefault Class, Legend, Public Methods
CXTPSkinManagerSchemaDefault Destructors
Class

CXTPSkinManagerSchemaDefault Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinManagerSchemaDefault | Destroys a CXTPSkinManagerSchemaDefault object, handles cleanup and deallocation.


CXTPSkinManagerSchemaDefault::~CXTPSkinManagerSchemaDefault Destructor

CXTPSkinManagerSchemaDefault Destructors, CXTPSkinManagerSchemaDefault Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaDefault::~CXTPSkinManagerSchemaDefault Destructor

Destroys a CXTPSkinManagerSchemaDefault object, handles cleanup and deallocation.

~CXTPSkinManagerSchemaDefault();
Group

CXTPSkinManagerSchemaDefault Destructors


CXTPSkinManagerSchemaProperty Class

XTPSkinManagerSchema.h, Classes, Legend, Members, Topics, CXTPSkinManagerSchemaProperty Data Members, CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Constructors, CXTPSkinManagerSchemaProperty Destructors, CXTPSkinManagerSchemaProperty Constructors, CXTPSkinManagerSchemaProperty Data Members, CXTPSkinManagerSchemaProperty Destructors, CXTPSkinManagerSchemaProperty Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty Class

CXTPSkinManagerSchemaProperty is standalone class represented single property of visual styles ini file

Class Hierarchy

class CXTPSkinManagerSchemaProperty;
File

XTPSkinManagerSchema.h

Group

Classes

Legend
Data Member
Method
CXTPSkinManagerSchemaProperty Constructors
CXTPSkinManagerSchemaProperty Constructors | Description
CXTPSkinManagerSchemaProperty | Constructs a CXTPSkinManagerSchemaProperty object.
CXTPSkinManagerSchemaProperty Data Members
CXTPSkinManagerSchemaProperty Data Members | Description
nPropertyCode | Property code
propType | Property type
CXTPSkinManagerSchemaProperty Destructors
CXTPSkinManagerSchemaProperty Destructors | Description
~CXTPSkinManagerSchemaProperty | Destroys a CXTPSkinManagerSchemaProperty object, handles cleanup and deallocation.
CXTPSkinManagerSchemaProperty Methods
CXTPSkinManagerSchemaProperty Methods | Description
SetPropertyBool | This method is called to convert string to BOOL property
SetPropertyColor | This method is called to convert string to Color property
SetPropertyEnum | This method is called to set enum property
SetPropertyFont | This method is called to convert string to LOGFONT property
SetPropertyInt | This method is called to convert string to int property
SetPropertyRect | This method is called to convert string to CRect property
SetPropertySize | This method is called to convert string to size property
SetPropertyString | This method is called to set string property


CXTPSkinManagerSchemaProperty Data Members

CXTPSkinManagerSchemaProperty Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty Data Members
Class

CXTPSkinManagerSchemaProperty Class

Legend
Data Member
Public Data Members
Public Data Member | Description
nPropertyCode | Property code
propType | Property type


CXTPSkinManagerSchemaProperty::nPropertyCode Data Member

CXTPSkinManagerSchemaProperty Data Members, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::nPropertyCode Data Member

Property code

int nPropertyCode;
Group

CXTPSkinManagerSchemaProperty Data Members


CXTPSkinManagerSchemaProperty::propType Data Member

CXTPSkinManagerSchemaProperty Data Members, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::propType Data Member

Property type

XTPSkinManagerProperty propType;
Group

CXTPSkinManagerSchemaProperty Data Members


CXTPSkinManagerSchemaProperty Methods

CXTPSkinManagerSchemaProperty Class, Legend, Public Methods
CXTPSkinManagerSchemaProperty Methods
Class

CXTPSkinManagerSchemaProperty Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
SetPropertyBool | This method is called to convert string to BOOL property
SetPropertyColor | This method is called to convert string to Color property
SetPropertyEnum | This method is called to set enum property
SetPropertyFont | This method is called to convert string to LOGFONT property
SetPropertyInt | This method is called to convert string to int property
SetPropertyRect | This method is called to convert string to CRect property
SetPropertySize | This method is called to convert string to size property
SetPropertyString | This method is called to set string property


CXTPSkinManagerSchemaProperty::SetPropertyBool Method

CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::SetPropertyBool Method

This method is called to convert string to BOOL property

void SetPropertyBool(
    LPCTSTR lpszValue
);
Parameters

lpszValue
String to convert property from

Group

CXTPSkinManagerSchemaProperty Methods


CXTPSkinManagerSchemaProperty::SetPropertyColor Method

CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::SetPropertyColor Method

This method is called to convert string to Color property

void SetPropertyColor(
    LPCTSTR lpszValue
);
Parameters

lpszValue
String to convert property from

Group

CXTPSkinManagerSchemaProperty Methods


CXTPSkinManagerSchemaProperty::SetPropertyEnum Method

CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::SetPropertyEnum Method

This method is called to set enum property

void SetPropertyEnum(
    int nEnumValue
);
Parameters

nEnumValue
Enumerator to set

Group

CXTPSkinManagerSchemaProperty Methods


CXTPSkinManagerSchemaProperty::SetPropertyFont Method

CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::SetPropertyFont Method

This method is called to convert string to LOGFONT property

void SetPropertyFont(
    LPCTSTR lpszValue
);
Parameters

lpszValue
String to convert property from

Group

CXTPSkinManagerSchemaProperty Methods


CXTPSkinManagerSchemaProperty::SetPropertyInt Method

CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::SetPropertyInt Method

This method is called to convert string to int property

void SetPropertyInt(
    LPCTSTR lpszValue
);
Parameters

lpszValue
String to convert property from

Group

CXTPSkinManagerSchemaProperty Methods


CXTPSkinManagerSchemaProperty::SetPropertyRect Method

CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::SetPropertyRect Method

This method is called to convert string to CRect property

void SetPropertyRect(
    LPCTSTR lpszValue
);
Parameters

lpszValue
String to convert property from

Group

CXTPSkinManagerSchemaProperty Methods


CXTPSkinManagerSchemaProperty::SetPropertySize Method

CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::SetPropertySize Method

This method is called to convert string to size property

void SetPropertySize(
    LPCTSTR lpszValue
);
Parameters

lpszValue
String to convert property from

Group

CXTPSkinManagerSchemaProperty Methods


CXTPSkinManagerSchemaProperty::SetPropertyString Method

CXTPSkinManagerSchemaProperty Methods, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::SetPropertyString Method

This method is called to set string property

void SetPropertyString(
    LPCTSTR lpszValue
);
Parameters

lpszValue
String to convert property from

Group

CXTPSkinManagerSchemaProperty Methods


CXTPSkinManagerSchemaProperty Constructors

CXTPSkinManagerSchemaProperty Class, Legend, Public Methods
CXTPSkinManagerSchemaProperty Constructors
Class

CXTPSkinManagerSchemaProperty Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerSchemaProperty | Constructs a CXTPSkinManagerSchemaProperty object.


CXTPSkinManagerSchemaProperty::CXTPSkinManagerSchemaProperty Constructor

CXTPSkinManagerSchemaProperty Constructors, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::CXTPSkinManagerSchemaProperty Constructor

Constructs a CXTPSkinManagerSchemaProperty object.

CXTPSkinManagerSchemaProperty();
Group

CXTPSkinManagerSchemaProperty Constructors


CXTPSkinManagerSchemaProperty Destructors

CXTPSkinManagerSchemaProperty Class, Legend, Public Methods
CXTPSkinManagerSchemaProperty Destructors
Class

CXTPSkinManagerSchemaProperty Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinManagerSchemaProperty | Destroys a CXTPSkinManagerSchemaProperty object, handles cleanup and deallocation.


CXTPSkinManagerSchemaProperty::~CXTPSkinManagerSchemaProperty Destructor

CXTPSkinManagerSchemaProperty Destructors, CXTPSkinManagerSchemaProperty Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinManagerSchemaProperty::~CXTPSkinManagerSchemaProperty Destructor

Destroys a CXTPSkinManagerSchemaProperty object, handles cleanup and deallocation.

~CXTPSkinManagerSchemaProperty();
Group

CXTPSkinManagerSchemaProperty Destructors


CXTPSkinObject Class

XTPSkinObject.h, Classes, Legend, Members, Topics, CXTPSkinObject Data Members, CXTPSkinObject Methods, CXTPSkinObject Constructors, CXTPSkinObject Destructors, CXTPSkinObject Constructors, CXTPSkinObject Data Members, CXTPSkinObject Destructors, CXTPSkinObject Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObject Class

CXTPSkinObject is a CWnd derived class. It represents base class for all skinable windows.

Class Hierarchy

class CXTPSkinObject : public CWnd;
File

XTPSkinObject.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSkinObject Constructors
CXTPSkinObject Constructors | Description
CXTPSkinObject | Constructs a CXTPSkinObject object.
CXTPSkinObject Data Members
CXTPSkinObject Data Members | Description
m_bActiveX | TRUE if ActiveX controls
m_bWindowsForms | TRUE if .NET controls
m_pManager | Parent CXTPSkinManager object
m_pOldWndProc | Old window window handler
m_strClassName | Own class name
m_wndDefProcAddr | Address of previous window procedure
CXTPSkinObject Destructors
CXTPSkinObject Destructors | Description
~CXTPSkinObject | Destroys a CXTPSkinObject object, handles cleanup and deallocation.
CXTPSkinObject Methods
CXTPSkinObject Methods | Description
GetClassName | Retrieves own classname.
GetColor | Retrieves system color used in skinmanager
GetMetrics | Call this method to get pointer to skin metrics
GetSkinClass | Retrieves CXTPSkinManagerClass object associated with class name
GetSkinManager | Retrieves parent CXTPSkinManager object
OnHookAttached | This method is called when hook is attached
OnHookDetached | This method is called when hook is detached
OnSkinChanged | This method is called when skin was changed
RefreshMetrics | This method is called when visual metrics was changed


CXTPSkinObject Data Members

CXTPSkinObject Class, Legend, Protected Data Members
CXTPSkinObject Data Members
Class

CXTPSkinObject Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bActiveX | TRUE if ActiveX controls
m_bWindowsForms | TRUE if .NET controls
m_pManager | Parent CXTPSkinManager object
m_pOldWndProc | Old window window handler
m_strClassName | Own class name
m_wndDefProcAddr | Address of previous window procedure


CXTPSkinObject::m_bActiveX Data Member

CXTPSkinObject Data Members, CXTPSkinObject Class
CXTPSkinObject::m_bActiveX Data Member

TRUE if ActiveX controls

BOOL m_bActiveX;
Group

CXTPSkinObject Data Members


CXTPSkinObject::m_bWindowsForms Data Member

CXTPSkinObject Data Members, CXTPSkinObject Class
CXTPSkinObject::m_bWindowsForms Data Member

TRUE if .NET controls

BOOL m_bWindowsForms;
Group

CXTPSkinObject Data Members


CXTPSkinObject::m_pManager Data Member

CXTPSkinObject Data Members, CXTPSkinObject Class
CXTPSkinObject::m_pManager Data Member

Parent CXTPSkinManager object

CXTPSkinManager* m_pManager;
Group

CXTPSkinObject Data Members


CXTPSkinObject::m_pOldWndProc Data Member

CXTPSkinObject Data Members, CXTPSkinObject Class
CXTPSkinObject::m_pOldWndProc Data Member

Old window window handler

WNDPROC m_pOldWndProc;
Group

CXTPSkinObject Data Members


CXTPSkinObject::m_strClassName Data Member

CXTPSkinObject Data Members, CXTPSkinObject Class
CXTPSkinObject::m_strClassName Data Member

Own class name

CString m_strClassName;
Group

CXTPSkinObject Data Members


CXTPSkinObject::m_wndDefProcAddr Data Member

CXTPSkinObject Data Members, CXTPSkinObject Class
CXTPSkinObject::m_wndDefProcAddr Data Member

Address of previous window procedure

WNDPROC m_wndDefProcAddr;
Group

CXTPSkinObject Data Members


CXTPSkinObject Methods

CXTPSkinObject Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObject Methods
Class

CXTPSkinObject Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
OnHookAttached | This method is called when hook is attached
OnHookDetached | This method is called when hook is detached
OnSkinChanged | This method is called when skin was changed
RefreshMetrics | This method is called when visual metrics was changed
Public Methods
Public Methods
Public Method | Description
GetClassName | Retrieves own classname.
GetColor | Retrieves system color used in skinmanager
GetMetrics | Call this method to get pointer to skin metrics
GetSkinClass | Retrieves CXTPSkinManagerClass object associated with class name
GetSkinManager | Retrieves parent CXTPSkinManager object


CXTPSkinObject::GetClassName Method

CXTPSkinObject Methods, CXTPSkinObject Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObject::GetClassName Method

Retrieves own classname.

CString GetClassName() const;
See Also

GetSkinClass

Body Source
CString CXTPSkinObject::GetClassName() const {
    return m_strClassName;
}
Group

CXTPSkinObject Methods


CXTPSkinObject::GetColor Method

CXTPSkinObject Methods, CXTPSkinObject Class, See Also
CXTPSkinObject::GetColor Method

Retrieves system color used in skinmanager

COLORREF GetColor(
    int nIndex
) const;
Parameters

nIndex
Index of color to retrieve

Returns

Color of selected skin

See Also

GetSysColor

Group

CXTPSkinObject Methods


CXTPSkinObject::GetMetrics Method

CXTPSkinObject Methods, CXTPSkinObject Class
CXTPSkinObject::GetMetrics Method

Call this method to get pointer to skin metrics

CXTPSkinManagerMetrics* GetMetrics() const;
Returns

Pointer to CXTPSkinManagerMetrics class contained metrics of the skin

Group

CXTPSkinObject Methods


CXTPSkinObject::GetSkinClass Method

CXTPSkinObject Methods, CXTPSkinObject Class, See Also
CXTPSkinObject::GetSkinClass Method

Retrieves CXTPSkinManagerClass object associated with class name

CXTPSkinManagerClass* GetSkinClass() const;
See Also

GetClassName

Group

CXTPSkinObject Methods


CXTPSkinObject::GetSkinManager Method

CXTPSkinObject Methods, CXTPSkinObject Class, Body Source
CXTPSkinObject::GetSkinManager Method

Retrieves parent CXTPSkinManager object

CXTPSkinManager* GetSkinManager() const;
Body Source
CXTPSkinManager* CXTPSkinObject::GetSkinManager() const {
    return m_pManager;
}
Group

CXTPSkinObject Methods


CXTPSkinObject::OnHookAttached Method

CXTPSkinObject Methods, CXTPSkinObject Class
CXTPSkinObject::OnHookAttached Method

This method is called when hook is attached

virtual void OnHookAttached(
    LPCREATESTRUCT lpcs,
    BOOL bAuto
);
Group

CXTPSkinObject Methods


CXTPSkinObject::OnHookDetached Method

CXTPSkinObject Methods, CXTPSkinObject Class
CXTPSkinObject::OnHookDetached Method

This method is called when hook is detached

virtual void OnHookDetached(
    BOOL bAuto
);
Group

CXTPSkinObject Methods


CXTPSkinObject::OnSkinChanged Method

CXTPSkinObject Methods, CXTPSkinObject Class
CXTPSkinObject::OnSkinChanged Method

This method is called when skin was changed

virtual void OnSkinChanged(
    BOOL bPrevState,
    BOOL bNewState
);
Parameters

bPrevState
TRUE if previously skin was installed
bNewState
TRUE if skin is installed

Group

CXTPSkinObject Methods


CXTPSkinObject::RefreshMetrics Method

CXTPSkinObject Methods, CXTPSkinObject Class
CXTPSkinObject::RefreshMetrics Method

This method is called when visual metrics was changed

virtual void RefreshMetrics();
Group

CXTPSkinObject Methods


CXTPSkinObject Constructors

CXTPSkinObject Class, Legend, Protected Methods
CXTPSkinObject Constructors
Class

CXTPSkinObject Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinObject | Constructs a CXTPSkinObject object.


CXTPSkinObject::CXTPSkinObject Constructor

CXTPSkinObject Constructors, CXTPSkinObject Class
CXTPSkinObject::CXTPSkinObject Constructor

Constructs a CXTPSkinObject object.

CXTPSkinObject();
Group

CXTPSkinObject Constructors


CXTPSkinObject Destructors

CXTPSkinObject Class, Legend, Protected Methods
CXTPSkinObject Destructors
Class

CXTPSkinObject Class

Legend
Destructor
protected
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPSkinObject | Destroys a CXTPSkinObject object, handles cleanup and deallocation.


CXTPSkinObject::~CXTPSkinObject Destructor

CXTPSkinObject Destructors, CXTPSkinObject Class
CXTPSkinObject::~CXTPSkinObject Destructor

Destroys a CXTPSkinObject object, handles cleanup and deallocation.

~CXTPSkinObject();
Group

CXTPSkinObject Destructors


CXTPSkinObjectButton Class

XTPSkinObjectButton.h, Classes, Legend, Members, Topics, CXTPSkinObjectButton Data Members, CXTPSkinObjectButton Constructors, CXTPSkinObjectButton Destructors, CXTPSkinObjectButton Constructors, CXTPSkinObjectButton Data Members, CXTPSkinObjectButton Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectButton Class

CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class. It implements standard buttons

Class Hierarchy

class CXTPSkinObjectButton : public CXTPSkinObjectFrame;
File

XTPSkinObjectButton.h

Group

Classes

Legend
Data Member
protected
Constructor
virtual
CXTPSkinObjectButton Constructors
CXTPSkinObjectButton Constructors | Description
CXTPSkinObjectButton | Constructs a CXTPSkinObjectButton object.
CXTPSkinObjectButton Data Members
CXTPSkinObjectButton Data Members | Description
m_bHot | TRUE if mouse under button
m_bPushed | TRUE if button was pressed
m_bStyle | Custom style of button
CXTPSkinObjectButton Destructors
CXTPSkinObjectButton Destructors | Description
~CXTPSkinObjectButton | Destroys a CXTPSkinObjectButton object, handles cleanup and deallocation.


CXTPSkinObjectButton Data Members

CXTPSkinObjectButton Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectButton Data Members
Class

CXTPSkinObjectButton Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bHot | TRUE if mouse under button
m_bPushed | TRUE if button was pressed
Public Data Members
Public Data Member | Description
m_bStyle | Custom style of button


CXTPSkinObjectButton::m_bHot Data Member

CXTPSkinObjectButton Data Members, CXTPSkinObjectButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectButton::m_bHot Data Member

TRUE if mouse under button

BOOL m_bHot;
Group

CXTPSkinObjectButton Data Members


CXTPSkinObjectButton::m_bPushed Data Member

CXTPSkinObjectButton Data Members, CXTPSkinObjectButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectButton::m_bPushed Data Member

TRUE if button was pressed

BOOL m_bPushed;
Group

CXTPSkinObjectButton Data Members


CXTPSkinObjectButton::m_bStyle Data Member

CXTPSkinObjectButton Data Members, CXTPSkinObjectButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectButton::m_bStyle Data Member

Custom style of button

BYTE m_bStyle;
Group

CXTPSkinObjectButton Data Members


CXTPSkinObjectButton Constructors

CXTPSkinObjectButton Class, Legend, Public Methods
CXTPSkinObjectButton Constructors
Class

CXTPSkinObjectButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectButton | Constructs a CXTPSkinObjectButton object.


CXTPSkinObjectButton::CXTPSkinObjectButton Constructor

CXTPSkinObjectButton Constructors, CXTPSkinObjectButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectButton::CXTPSkinObjectButton Constructor

Constructs a CXTPSkinObjectButton object.

CXTPSkinObjectButton();
Group

CXTPSkinObjectButton Constructors


CXTPSkinObjectButton Destructors

CXTPSkinObjectButton Class, Legend, Public Methods
CXTPSkinObjectButton Destructors
Class

CXTPSkinObjectButton Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectButton | Destroys a CXTPSkinObjectButton object, handles cleanup and deallocation.


CXTPSkinObjectButton::~CXTPSkinObjectButton Destructor

CXTPSkinObjectButton Destructors, CXTPSkinObjectButton Class
CXTPSkinObjectButton::~CXTPSkinObjectButton Destructor

Destroys a CXTPSkinObjectButton object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectButton();
Group

CXTPSkinObjectButton Destructors


CXTPSkinObjectClassMap Class

XTPSkinObject.h, Classes, Legend, Members, Topics, CXTPSkinObjectClassMap Data Members, CXTPSkinObjectClassMap Methods, CXTPSkinObjectClassMap Constructors, CXTPSkinObjectClassMap Destructors, CXTPSkinObjectClassMap Constructors, CXTPSkinObjectClassMap Data Members, CXTPSkinObjectClassMap Destructors, CXTPSkinObjectClassMap Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectClassMap Class

CXTPSkinObjectClassMap class is standalone class that help map windows controls to skin framework classes.

Class Hierarchy

class CXTPSkinObjectClassMap;
File

XTPSkinObject.h

Remarks

CXTPSkinManager class use this class to find what skin framework class need to apply to new window to skin it right For example, if new window created with class name "BUTTON", CXTPSkinObjectClassMap::Lookup will retrieve runtime class of CXTPSkinObjectButton to apply it to new window and skin it.

See Also

CXTPSkinManager, CXTPSkinObject, CXTPSkinManager::GetClassMap

Group

Classes

Legend
Data Member
protected
Method
CXTPSkinObjectClassMap Constructors
CXTPSkinObjectClassMap Constructors | Description
CXTPSkinObjectClassMap | Constructs a CXTPSkinObjectClassMap object.
CXTPSkinObjectClassMap Data Members
CXTPSkinObjectClassMap Data Members | Description
m_mapInfo | General map
CXTPSkinObjectClassMap Destructors
CXTPSkinObjectClassMap Destructors | Description
~CXTPSkinObjectClassMap | Destroys a CXTPSkinObjectClassMap object, handles cleanup and deallocation.
CXTPSkinObjectClassMap Methods
CXTPSkinObjectClassMap Methods | Description
AddClass | Call this method to map window class name to skin framework class
AddStandardClasses | This method called by framework to add all standard window classes
AddSynonymClass | Call this method to map one window class name to another
Lookup | This method map window class to skinframework class
RemoveAll | Call this method to remove all classed
RemoveClass |


CXTPSkinObjectClassMap Data Members

CXTPSkinObjectClassMap Class, Legend, Protected Data Members
CXTPSkinObjectClassMap Data Members
Class

CXTPSkinObjectClassMap Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_mapInfo | General map


CXTPSkinObjectClassMap::m_mapInfo Data Member

CXTPSkinObjectClassMap Data Members, CXTPSkinObjectClassMap Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectClassMap::m_mapInfo Data Member

General map

CMapStringToPtr m_mapInfo;
Group

CXTPSkinObjectClassMap Data Members


CXTPSkinObjectClassMap Methods

CXTPSkinObjectClassMap Class, Legend, Public Methods
CXTPSkinObjectClassMap Methods
Class

CXTPSkinObjectClassMap Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddClass | Call this method to map window class name to skin framework class
AddStandardClasses | This method called by framework to add all standard window classes
AddSynonymClass | Call this method to map one window class name to another
Lookup | This method map window class to skinframework class
RemoveAll | Call this method to remove all classed
RemoveClass |


CXTPSkinObjectClassMap::AddClass Method

CXTPSkinObjectClassMap Methods, CXTPSkinObjectClassMap Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectClassMap::AddClass Method

Call this method to map window class name to skin framework class

CXTPSkinObjectClassInfo* AddClass(
    LPCTSTR lpszClassName,
    CXTPSkinObjectClassInfo* pInfo
);
Parameters

lpszClassName
Window class name
pInfo
descriptor of skin framework class

See Also

AddSynonymClass, AddStandardClasses

Example
pClassMap->AddClass(_T("ListBox"), new CXTPSkinObjectClassInfo(RUNTIME_CLASS(CXTPSkinObjectListBox)));
Group

CXTPSkinObjectClassMap Methods


CXTPSkinObjectClassMap::AddStandardClasses Method

CXTPSkinObjectClassMap Methods, CXTPSkinObjectClassMap Class
CXTPSkinObjectClassMap::AddStandardClasses Method

This method called by framework to add all standard window classes

void AddStandardClasses();
Remarks

CXTPSkinManager call this method to add standard window classes like "BUTTON", "LISTBOX", "SCROLLBAR"

Group

CXTPSkinObjectClassMap Methods


CXTPSkinObjectClassMap::AddSynonymClass Method

CXTPSkinObjectClassMap Methods, CXTPSkinObjectClassMap Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectClassMap::AddSynonymClass Method

Call this method to map one window class name to another

void AddSynonymClass(
    LPCTSTR lpszClassNameSynonym,
    LPCTSTR lpszClassName
);
Parameters

lpszClassNameSynonym
New window class name
lpszClassName
Standard window class name

See Also

AddClass

Example
pClassMap->AddSynonymClass(_T("SysDateTimePick32"), _T("Edit"));
Group

CXTPSkinObjectClassMap Methods


CXTPSkinObjectClassMap::Lookup Method

CXTPSkinObjectClassMap Methods, CXTPSkinObjectClassMap Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectClassMap::Lookup Method

This method map window class to skinframework class

CXTPSkinObjectClassInfo* Lookup(
    LPCTSTR lpszClassName
);
Parameters

lpszClassName
Window Class name to map

See Also

AddClass

Group

CXTPSkinObjectClassMap Methods


CXTPSkinObjectClassMap::RemoveAll Method

CXTPSkinObjectClassMap Methods, CXTPSkinObjectClassMap Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectClassMap::RemoveAll Method

Call this method to remove all classed

void RemoveAll();
See Also

AddClass

Group

CXTPSkinObjectClassMap Methods


RemoveClass Method

CXTPSkinObjectClassMap Methods
RemoveClass Method
Overload List
Methods
Method | Description
CXTPSkinObjectClassMap::RemoveClass (CXTPSkinObjectClassInfo*) | Call this method to remove skin framework class
CXTPSkinObjectClassMap::RemoveClass (LPCTSTR) | Call this method to remove window class
Group

CXTPSkinObjectClassMap Methods


CXTPSkinObjectClassMap::RemoveClass Method (CXTPSkinObjectClassInfo*)

RemoveClass Method, CXTPSkinObjectClassMap Class, See Also
CXTPSkinObjectClassMap::RemoveClass Method (CXTPSkinObjectClassInfo*)

Call this method to remove skin framework class

void RemoveClass(
    CXTPSkinObjectClassInfo* pInfo
);
Parameters

pInfo
skin framework class name to remove

See Also

AddClass

Group

RemoveClass Method


CXTPSkinObjectClassMap::RemoveClass Method (LPCTSTR)

RemoveClass Method, CXTPSkinObjectClassMap Class, See Also
CXTPSkinObjectClassMap::RemoveClass Method (LPCTSTR)

Call this method to remove window class

void RemoveClass(
    LPCTSTR lpszClassName
);
Parameters

lpszClassName
Window class name to remove

See Also

AddClass

Group

RemoveClass Method


CXTPSkinObjectClassMap Constructors

CXTPSkinObjectClassMap Class, Legend, Public Methods
CXTPSkinObjectClassMap Constructors
Class

CXTPSkinObjectClassMap Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectClassMap | Constructs a CXTPSkinObjectClassMap object.


CXTPSkinObjectClassMap::CXTPSkinObjectClassMap Constructor

CXTPSkinObjectClassMap Constructors, CXTPSkinObjectClassMap Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectClassMap::CXTPSkinObjectClassMap Constructor

Constructs a CXTPSkinObjectClassMap object.

CXTPSkinObjectClassMap();
Group

CXTPSkinObjectClassMap Constructors


CXTPSkinObjectClassMap Destructors

CXTPSkinObjectClassMap Class, Legend, Public Methods
CXTPSkinObjectClassMap Destructors
Class

CXTPSkinObjectClassMap Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectClassMap | Destroys a CXTPSkinObjectClassMap object, handles cleanup and deallocation.


CXTPSkinObjectClassMap::~CXTPSkinObjectClassMap Destructor

CXTPSkinObjectClassMap Destructors, CXTPSkinObjectClassMap Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectClassMap::~CXTPSkinObjectClassMap Destructor

Destroys a CXTPSkinObjectClassMap object, handles cleanup and deallocation.

~CXTPSkinObjectClassMap();
Group

CXTPSkinObjectClassMap Destructors


CXTPSkinObjectComboBox Class

XTPSkinObjectComboBox.h, Classes, Legend, Members, Topics, CXTPSkinObjectComboBox Constructors, CXTPSkinObjectComboBox Destructors, CXTPSkinObjectComboBox Constructors, CXTPSkinObjectComboBox Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectComboBox Class

CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class. It implements standard comboboxes

Class Hierarchy

class CXTPSkinObjectComboBox : public CXTPSkinObjectFrame;
File

XTPSkinObjectComboBox.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectComboBox Constructors
CXTPSkinObjectComboBox Constructors | Description
CXTPSkinObjectComboBox | Constructs a CXTPSkinObjectComboBox object.
CXTPSkinObjectComboBox Destructors
CXTPSkinObjectComboBox Destructors | Description
~CXTPSkinObjectComboBox | Destroys a CXTPSkinObjectComboBox object, handles cleanup and deallocation.


CXTPSkinObjectComboBox Constructors

CXTPSkinObjectComboBox Class, Legend, Public Methods
CXTPSkinObjectComboBox Constructors
Class

CXTPSkinObjectComboBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectComboBox | Constructs a CXTPSkinObjectComboBox object.


CXTPSkinObjectComboBox::CXTPSkinObjectComboBox Constructor

CXTPSkinObjectComboBox Constructors, CXTPSkinObjectComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectComboBox::CXTPSkinObjectComboBox Constructor

Constructs a CXTPSkinObjectComboBox object.

CXTPSkinObjectComboBox();
Group

CXTPSkinObjectComboBox Constructors


CXTPSkinObjectComboBox Destructors

CXTPSkinObjectComboBox Class, Legend, Public Methods
CXTPSkinObjectComboBox Destructors
Class

CXTPSkinObjectComboBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectComboBox | Destroys a CXTPSkinObjectComboBox object, handles cleanup and deallocation.


CXTPSkinObjectComboBox::~CXTPSkinObjectComboBox Destructor

CXTPSkinObjectComboBox Destructors, CXTPSkinObjectComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectComboBox::~CXTPSkinObjectComboBox Destructor

Destroys a CXTPSkinObjectComboBox object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectComboBox();
Group

CXTPSkinObjectComboBox Destructors


CXTPSkinObjectComCtl32Control Class

XTPSkinObjectFrame.h, Classes, Legend, Members, Topics, CXTPSkinObjectComCtl32Control Methods, CXTPSkinObjectComCtl32Control Constructors, CXTPSkinObjectComCtl32Control Constructors, CXTPSkinObjectComCtl32Control Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectComCtl32Control Class

CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class. It is base class for all ComCtl32 defined controls

Class Hierarchy

class CXTPSkinObjectComCtl32Control : public CXTPSkinObjectUser32Control;
File

XTPSkinObjectFrame.h

Group

Classes

Legend
Method
protected
virtual
CXTPSkinObjectComCtl32Control Constructors
CXTPSkinObjectComCtl32Control Constructors | Description
CXTPSkinObjectComCtl32Control | Constructs a CXTPSkinObjectComCtl32Control object.
CXTPSkinObjectComCtl32Control Methods
CXTPSkinObjectComCtl32Control Methods | Description
CheckScrollBarsDraw | This method called to determine if scroll bar position was changed


CXTPSkinObjectComCtl32Control Methods

CXTPSkinObjectComCtl32Control Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectComCtl32Control Methods
Class

CXTPSkinObjectComCtl32Control Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CheckScrollBarsDraw | This method called to determine if scroll bar position was changed


CXTPSkinObjectComCtl32Control::CheckScrollBarsDraw Method

CXTPSkinObjectComCtl32Control Methods, CXTPSkinObjectComCtl32Control Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectComCtl32Control::CheckScrollBarsDraw Method

This method called to determine if scroll bar position was changed

virtual void CheckScrollBarsDraw();
Group

CXTPSkinObjectComCtl32Control Methods


CXTPSkinObjectComCtl32Control Constructors

CXTPSkinObjectComCtl32Control Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectComCtl32Control Constructors
Class

CXTPSkinObjectComCtl32Control Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinObjectComCtl32Control | Constructs a CXTPSkinObjectComCtl32Control object.


CXTPSkinObjectComCtl32Control::CXTPSkinObjectComCtl32Control Constructor

CXTPSkinObjectComCtl32Control Constructors, CXTPSkinObjectComCtl32Control Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectComCtl32Control::CXTPSkinObjectComCtl32Control Constructor

Constructs a CXTPSkinObjectComCtl32Control object.

CXTPSkinObjectComCtl32Control();
Group

CXTPSkinObjectComCtl32Control Constructors


CXTPSkinObjectDateTime Class

XTPSkinObjectComboBox.h, Classes, Legend, Members, Topics, CXTPSkinObjectDateTime Methods, CXTPSkinObjectDateTime Constructors, CXTPSkinObjectDateTime Constructors, CXTPSkinObjectDateTime Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectDateTime Class

CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class. It implements date time control

Class Hierarchy

class CXTPSkinObjectDateTime : public CXTPSkinObjectComboBox;
File

XTPSkinObjectComboBox.h

Group

Classes

Legend
Method
CXTPSkinObjectDateTime Constructors
CXTPSkinObjectDateTime Constructors | Description
CXTPSkinObjectDateTime | Constructs a CXTPSkinObjectDateTime object.
CXTPSkinObjectDateTime Methods
CXTPSkinObjectDateTime Methods | Description
RefreshMetrics | This method is called when visual metrics was changed


CXTPSkinObjectDateTime Methods

CXTPSkinObjectDateTime Class, Legend, Public Methods
CXTPSkinObjectDateTime Methods
Class

CXTPSkinObjectDateTime Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called when visual metrics was changed


CXTPSkinObjectDateTime::RefreshMetrics Method

CXTPSkinObjectDateTime Methods, CXTPSkinObjectDateTime Class
CXTPSkinObjectDateTime::RefreshMetrics Method

This method is called when visual metrics was changed

void RefreshMetrics();
Group

CXTPSkinObjectDateTime Methods


CXTPSkinObjectDateTime Constructors

CXTPSkinObjectDateTime Class, Legend, Public Methods
CXTPSkinObjectDateTime Constructors
Class

CXTPSkinObjectDateTime Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectDateTime | Constructs a CXTPSkinObjectDateTime object.


CXTPSkinObjectDateTime::CXTPSkinObjectDateTime Constructor

CXTPSkinObjectDateTime Constructors, CXTPSkinObjectDateTime Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectDateTime::CXTPSkinObjectDateTime Constructor

Constructs a CXTPSkinObjectDateTime object.

CXTPSkinObjectDateTime();
Group

CXTPSkinObjectDateTime Constructors


CXTPSkinObjectEdit Class

XTPSkinObjectEdit.h, Classes, Legend, Members, Topics, CXTPSkinObjectEdit Constructors, CXTPSkinObjectEdit Destructors, CXTPSkinObjectEdit Constructors, CXTPSkinObjectEdit Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectEdit Class

CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class. It implements standard edit control

Class Hierarchy

class CXTPSkinObjectEdit : public CXTPSkinObjectUser32Control;
File

XTPSkinObjectEdit.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectEdit Constructors
CXTPSkinObjectEdit Constructors | Description
CXTPSkinObjectEdit | Constructs a CXTPSkinObjectEdit object.
CXTPSkinObjectEdit Destructors
CXTPSkinObjectEdit Destructors | Description
~CXTPSkinObjectEdit | Destroys a CXTPSkinObjectEdit object, handles cleanup and deallocation.


CXTPSkinObjectEdit Constructors

CXTPSkinObjectEdit Class, Legend, Public Methods
CXTPSkinObjectEdit Constructors
Class

CXTPSkinObjectEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectEdit | Constructs a CXTPSkinObjectEdit object.


CXTPSkinObjectEdit::CXTPSkinObjectEdit Constructor

CXTPSkinObjectEdit Constructors, CXTPSkinObjectEdit Class
CXTPSkinObjectEdit::CXTPSkinObjectEdit Constructor

Constructs a CXTPSkinObjectEdit object.

CXTPSkinObjectEdit();
Group

CXTPSkinObjectEdit Constructors


CXTPSkinObjectEdit Destructors

CXTPSkinObjectEdit Class, Legend, Public Methods
CXTPSkinObjectEdit Destructors
Class

CXTPSkinObjectEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectEdit | Destroys a CXTPSkinObjectEdit object, handles cleanup and deallocation.


CXTPSkinObjectEdit::~CXTPSkinObjectEdit Destructor

CXTPSkinObjectEdit Destructors, CXTPSkinObjectEdit Class
CXTPSkinObjectEdit::~CXTPSkinObjectEdit Destructor

Destroys a CXTPSkinObjectEdit object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectEdit();
Group

CXTPSkinObjectEdit Destructors


CXTPSkinObjectFrame Class

XTPSkinObjectFrame.h, Classes, Legend, Members, Topics, CXTPSkinObjectFrame Classes, CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Constructors, CXTPSkinObjectFrame Destructors, CXTPSkinObjectFrame Classes, CXTPSkinObjectFrame Constructors, CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Destructors, CXTPSkinObjectFrame Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame Class

CXTPSkinObjectFrame is a CXTPSkinObject derived class. It is parent control for all implementations that have border or scroll bars

Class Hierarchy

class CXTPSkinObjectFrame : public CXTPSkinObject;
File

XTPSkinObjectFrame.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSkinObjectFrame Classes
CXTPSkinObjectFrame Classes | Description
CCaptionButton | Caption button class
CXTPSkinObjectFrame Constructors
CXTPSkinObjectFrame Constructors | Description
CXTPSkinObjectFrame | Constructs a CXTPSkinObjectFrame object.
CXTPSkinObjectFrame Data Members
CXTPSkinObjectFrame Data Members | Description
m_arrButtons | Caption buttons
m_bActive | TRUE if caption is active
m_bLockFrameDraw | TRUE to lock draw
m_bMDIClient | TRUE if frame is MDI client
m_bRegionChanged | TRUE if region was changed
m_dwDialogTexture | Dialog texture
m_dwExStyle | ExStyles of window
m_dwStyle | Styles of window
m_pButtonHot | Hot caption button
m_pButtonPressed | Pressed caption button
m_pSBTrack | Track info of scroll bars
m_rcBorders | Frame borders
m_spi | Scroll bar position info
m_szFrameRegion | Lase frame region
CXTPSkinObjectFrame Destructors
CXTPSkinObjectFrame Destructors | Description
~CXTPSkinObjectFrame | Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
CXTPSkinObjectFrame Methods
CXTPSkinObjectFrame Methods | Description
GetBorders | Retrieves borders of window
GetCaptionButtons | Retrieves collection of caption buttons
GetClientBrush | Call this method to get client brush
IsActive | Determines if caption currently active
OnHookAttached | This method is called when hook is attached
OnHookDetached | This method is called when hook is detached
OnSkinChanged | This method is called when skin was changed
RedrawScrollBar | This method is called to redraw scroll bar of the frame
RefreshMetrics | This method is called when visual metrics was changed


CXTPSkinObjectFrame Classes

Classes, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame Classes
Classes
Class | Description
CCaptionButton | Caption button class
Class

CXTPSkinObjectFrame Class


CXTPSkinObjectFrame::CCaptionButton Class

XTPSkinObjectFrame.h, CXTPSkinObjectFrame Classes, Legend, Members, Topics, CCaptionButton Data Members, CCaptionButton Methods, CCaptionButton Constructors, CCaptionButton Constructors, CCaptionButton Data Members, CCaptionButton Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton Class

Caption button class

Class Hierarchy

class CCaptionButton;
File

XTPSkinObjectFrame.h

Group

CXTPSkinObjectFrame Classes

Legend
Data Member
Method
CCaptionButton Constructors
CCaptionButton Constructors | Description
CCaptionButton | Constructs a CXTPSkinObject object.
CCaptionButton Data Members
CCaptionButton Data Members | Description
m_nClassPart | Class part
m_nCommand | Button Command
m_nHTCode | HitTest code
m_pFrame | Parent frame object
m_rcButton | Button bounding rectangle
CCaptionButton Methods
CCaptionButton Methods | Description
Draw | This method is called to draw caption button
IsHighlighted | Determines if button is highlighted
IsPressed | Determines if button is pressed


CCaptionButton Data Members

CXTPSkinObjectFrame::CCaptionButton Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CCaptionButton Data Members
Class

CXTPSkinObjectFrame::CCaptionButton Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_nClassPart | Class part
m_nCommand | Button Command
m_nHTCode | HitTest code
m_pFrame | Parent frame object
m_rcButton | Button bounding rectangle


CXTPSkinObjectFrame::CCaptionButton::m_nClassPart Data Member

CCaptionButton Data Members, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::m_nClassPart Data Member

Class part

int m_nClassPart;
Group

CCaptionButton Data Members


CXTPSkinObjectFrame::CCaptionButton::m_nCommand Data Member

CCaptionButton Data Members, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::m_nCommand Data Member

Button Command

int m_nCommand;
Group

CCaptionButton Data Members


CXTPSkinObjectFrame::CCaptionButton::m_nHTCode Data Member

CCaptionButton Data Members, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::m_nHTCode Data Member

HitTest code

UINT m_nHTCode;
Group

CCaptionButton Data Members


CXTPSkinObjectFrame::CCaptionButton::m_pFrame Data Member

CCaptionButton Data Members, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::m_pFrame Data Member

Parent frame object

CXTPSkinObjectFrame* m_pFrame;
Group

CCaptionButton Data Members


CXTPSkinObjectFrame::CCaptionButton::m_rcButton Data Member

CCaptionButton Data Members, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::m_rcButton Data Member

Button bounding rectangle

CRect m_rcButton;
Group

CCaptionButton Data Members


CCaptionButton Methods

CXTPSkinObjectFrame::CCaptionButton Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CCaptionButton Methods
Class

CXTPSkinObjectFrame::CCaptionButton Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Draw | This method is called to draw caption button
IsHighlighted | Determines if button is highlighted
IsPressed | Determines if button is pressed


CXTPSkinObjectFrame::CCaptionButton::Draw Method

CCaptionButton Methods, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::Draw Method

This method is called to draw caption button

void Draw(
    CDC* pDC,
    BOOL bFrameActive
);
Parameters

pDC
Pointer to device context
bFrameActive
TRUE if frame is active

Group

CCaptionButton Methods


CXTPSkinObjectFrame::CCaptionButton::IsHighlighted Method

CCaptionButton Methods, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::IsHighlighted Method

Determines if button is highlighted

BOOL IsHighlighted() const;
Group

CCaptionButton Methods


CXTPSkinObjectFrame::CCaptionButton::IsPressed Method

CCaptionButton Methods, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::IsPressed Method

Determines if button is pressed

BOOL IsPressed() const;
Group

CCaptionButton Methods


CCaptionButton Constructors

CXTPSkinObjectFrame::CCaptionButton Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CCaptionButton Constructors
Class

CXTPSkinObjectFrame::CCaptionButton Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CCaptionButton | Constructs a CXTPSkinObject object.


CXTPSkinObjectFrame::CCaptionButton::CCaptionButton Constructor

CCaptionButton Constructors, CXTPSkinObjectFrame::CCaptionButton Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::CCaptionButton::CCaptionButton Constructor

Constructs a CXTPSkinObject object.

CCaptionButton(
    int nCommand,
    CXTPSkinObjectFrame* pFrame,
    UINT nHTCode,
    int m_nClassPart
);
Parameters

nCommand
Command id of button
pFrame
Parent frame object
nHTCode
Hit test code of the button
m_nClassPart
Class part

Group

CCaptionButton Constructors


CXTPSkinObjectFrame Data Members

CXTPSkinObjectFrame Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame Data Members
Class

CXTPSkinObjectFrame Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrButtons | Caption buttons
m_bActive | TRUE if caption is active
m_bMDIClient | TRUE if frame is MDI client
m_bRegionChanged | TRUE if region was changed
m_dwExStyle | ExStyles of window
m_dwStyle | Styles of window
m_pButtonHot | Hot caption button
m_pButtonPressed | Pressed caption button
m_pSBTrack | Track info of scroll bars
m_rcBorders | Frame borders
m_spi | Scroll bar position info
m_szFrameRegion | Lase frame region
Public Data Members
Public Data Member | Description
m_bLockFrameDraw | TRUE to lock draw
m_dwDialogTexture | Dialog texture


CXTPSkinObjectFrame::m_arrButtons Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_arrButtons Data Member

Caption buttons

CCaptionButtons m_arrButtons;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_bActive Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_bActive Data Member

TRUE if caption is active

BOOL m_bActive;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_bLockFrameDraw Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_bLockFrameDraw Data Member

TRUE to lock draw

BOOL m_bLockFrameDraw;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_bMDIClient Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_bMDIClient Data Member

TRUE if frame is MDI client

BOOL m_bMDIClient;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_bRegionChanged Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_bRegionChanged Data Member

TRUE if region was changed

BOOL m_bRegionChanged;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_dwDialogTexture Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_dwDialogTexture Data Member

Dialog texture

DWORD m_dwDialogTexture;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_dwExStyle Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_dwExStyle Data Member

ExStyles of window

DWORD m_dwExStyle;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_dwStyle Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_dwStyle Data Member

Styles of window

DWORD m_dwStyle;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_pButtonHot Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_pButtonHot Data Member

Hot caption button

CCaptionButton* m_pButtonHot;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_pButtonPressed Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_pButtonPressed Data Member

Pressed caption button

CCaptionButton* m_pButtonPressed;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_pSBTrack Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_pSBTrack Data Member

Track info of scroll bars

XTP_SKINSCROLLBARTRACKINFO* m_pSBTrack;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_rcBorders Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_rcBorders Data Member

Frame borders

CRect m_rcBorders;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_spi Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_spi Data Member

Scroll bar position info

XTP_SKINSCROLLBARPOSINFO m_spi[2];
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame::m_szFrameRegion Data Member

CXTPSkinObjectFrame Data Members, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::m_szFrameRegion Data Member

Lase frame region

CSize m_szFrameRegion;
Group

CXTPSkinObjectFrame Data Members


CXTPSkinObjectFrame Methods

CXTPSkinObjectFrame Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame Methods
Class

CXTPSkinObjectFrame Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnHookAttached | This method is called when hook is attached
OnHookDetached | This method is called when hook is detached
OnSkinChanged | This method is called when skin was changed
RefreshMetrics | This method is called when visual metrics was changed
Public Methods
Public Methods
Public Method | Description
GetBorders | Retrieves borders of window
GetCaptionButtons | Retrieves collection of caption buttons
GetClientBrush | Call this method to get client brush
IsActive | Determines if caption currently active
RedrawScrollBar | This method is called to redraw scroll bar of the frame


CXTPSkinObjectFrame::GetBorders Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::GetBorders Method

Retrieves borders of window

CRect GetBorders() const;
Body Source
CRect CXTPSkinObjectFrame::GetBorders() const {
    return m_rcBorders;
}
Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame::GetCaptionButtons Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::GetCaptionButtons Method

Retrieves collection of caption buttons

CCaptionButtons* GetCaptionButtons();
Body Source
CXTPSkinObjectFrame::CCaptionButtons* CXTPSkinObjectFrame::GetCaptionButtons() {
    return &m_arrButtons;

}
Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame::GetClientBrush Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::GetClientBrush Method

Call this method to get client brush

virtual HBRUSH GetClientBrush(
    CDC* pDC
);
Parameters

pDC
Device context

Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame::IsActive Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectFrame::IsActive Method

Determines if caption currently active

BOOL IsActive() const;
Body Source
BOOL CXTPSkinObjectFrame::IsActive() const {
    return m_bActive;
}
Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame::OnHookAttached Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::OnHookAttached Method

This method is called when hook is attached

virtual void OnHookAttached(
    LPCREATESTRUCT lpcs,
    BOOL bAuto
);
Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame::OnHookDetached Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::OnHookDetached Method

This method is called when hook is detached

void OnHookDetached(
    BOOL bAuto
);
Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame::OnSkinChanged Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::OnSkinChanged Method

This method is called when skin was changed

virtual void OnSkinChanged(
    BOOL bPrevState,
    BOOL bNewState
);
Parameters

bPrevState
TRUE if previously skin was installed
bNewState
TRUE if skin is installed

Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame::RedrawScrollBar Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::RedrawScrollBar Method

This method is called to redraw scroll bar of the frame

void RedrawScrollBar(
    int nBar
);
Parameters

nBar
Scroll bar

Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame::RefreshMetrics Method

CXTPSkinObjectFrame Methods, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::RefreshMetrics Method

This method is called when visual metrics was changed

virtual void RefreshMetrics();
Group

CXTPSkinObjectFrame Methods


CXTPSkinObjectFrame Constructors

CXTPSkinObjectFrame Class, Legend, Public Methods
CXTPSkinObjectFrame Constructors
Class

CXTPSkinObjectFrame Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectFrame | Constructs a CXTPSkinObjectFrame object.


CXTPSkinObjectFrame::CXTPSkinObjectFrame Constructor

CXTPSkinObjectFrame Constructors, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::CXTPSkinObjectFrame Constructor

Constructs a CXTPSkinObjectFrame object.

CXTPSkinObjectFrame();
Group

CXTPSkinObjectFrame Constructors


CXTPSkinObjectFrame Destructors

CXTPSkinObjectFrame Class, Legend, Public Methods
CXTPSkinObjectFrame Destructors
Class

CXTPSkinObjectFrame Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectFrame | Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.


CXTPSkinObjectFrame::~CXTPSkinObjectFrame Destructor

CXTPSkinObjectFrame Destructors, CXTPSkinObjectFrame Class
CXTPSkinObjectFrame::~CXTPSkinObjectFrame Destructor

Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectFrame();
Group

CXTPSkinObjectFrame Destructors


CXTPSkinObjectHeader Class

XTPSkinObjectHeader.h, Classes, Legend, Members, Topics, CXTPSkinObjectHeader Constructors, CXTPSkinObjectHeader Destructors, CXTPSkinObjectHeader Constructors, CXTPSkinObjectHeader Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectHeader Class

CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class. It implements standard list header control

Class Hierarchy

class CXTPSkinObjectHeader : public CXTPSkinObjectFrame;
File

XTPSkinObjectHeader.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectHeader Constructors
CXTPSkinObjectHeader Constructors | Description
CXTPSkinObjectHeader | Constructs a CXTPSkinObjectHeader object.
CXTPSkinObjectHeader Destructors
CXTPSkinObjectHeader Destructors | Description
~CXTPSkinObjectHeader | Destroys a CXTPSkinObjectHeader object, handles cleanup and deallocation.


CXTPSkinObjectHeader Constructors

CXTPSkinObjectHeader Class, Legend, Public Methods
CXTPSkinObjectHeader Constructors
Class

CXTPSkinObjectHeader Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectHeader | Constructs a CXTPSkinObjectHeader object.


CXTPSkinObjectHeader::CXTPSkinObjectHeader Constructor

CXTPSkinObjectHeader Constructors, CXTPSkinObjectHeader Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectHeader::CXTPSkinObjectHeader Constructor

Constructs a CXTPSkinObjectHeader object.

CXTPSkinObjectHeader();
Group

CXTPSkinObjectHeader Constructors


CXTPSkinObjectHeader Destructors

CXTPSkinObjectHeader Class, Legend, Public Methods
CXTPSkinObjectHeader Destructors
Class

CXTPSkinObjectHeader Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectHeader | Destroys a CXTPSkinObjectHeader object, handles cleanup and deallocation.


CXTPSkinObjectHeader::~CXTPSkinObjectHeader Destructor

CXTPSkinObjectHeader Destructors, CXTPSkinObjectHeader Class
CXTPSkinObjectHeader::~CXTPSkinObjectHeader Destructor

Destroys a CXTPSkinObjectHeader object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectHeader();
Group

CXTPSkinObjectHeader Destructors


CXTPSkinObjectListBox Class

XTPSkinObjectListBox.h, Classes, Legend, Members, Topics, CXTPSkinObjectListBox Constructors, CXTPSkinObjectListBox Destructors, CXTPSkinObjectListBox Constructors, CXTPSkinObjectListBox Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectListBox Class

CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class. It implements standard list box control

Class Hierarchy

class CXTPSkinObjectListBox : public CXTPSkinObjectUser32Control;
File

XTPSkinObjectListBox.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectListBox Constructors
CXTPSkinObjectListBox Constructors | Description
CXTPSkinObjectListBox | Constructs a CXTPSkinObjectListBox object.
CXTPSkinObjectListBox Destructors
CXTPSkinObjectListBox Destructors | Description
~CXTPSkinObjectListBox | Destroys a CXTPSkinObjectListBox object, handles cleanup and deallocation.


CXTPSkinObjectListBox Constructors

CXTPSkinObjectListBox Class, Legend, Public Methods
CXTPSkinObjectListBox Constructors
Class

CXTPSkinObjectListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectListBox | Constructs a CXTPSkinObjectListBox object.


CXTPSkinObjectListBox::CXTPSkinObjectListBox Constructor

CXTPSkinObjectListBox Constructors, CXTPSkinObjectListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectListBox::CXTPSkinObjectListBox Constructor

Constructs a CXTPSkinObjectListBox object.

CXTPSkinObjectListBox();
Group

CXTPSkinObjectListBox Constructors


CXTPSkinObjectListBox Destructors

CXTPSkinObjectListBox Class, Legend, Public Methods
CXTPSkinObjectListBox Destructors
Class

CXTPSkinObjectListBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectListBox | Destroys a CXTPSkinObjectListBox object, handles cleanup and deallocation.


CXTPSkinObjectListBox::~CXTPSkinObjectListBox Destructor

CXTPSkinObjectListBox Destructors, CXTPSkinObjectListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectListBox::~CXTPSkinObjectListBox Destructor

Destroys a CXTPSkinObjectListBox object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectListBox();
Group

CXTPSkinObjectListBox Destructors


CXTPSkinObjectListView Class

XTPSkinObjectListView.h, Classes, Legend, Members, Topics, CXTPSkinObjectListView Constructors, CXTPSkinObjectListView Destructors, CXTPSkinObjectListView Constructors, CXTPSkinObjectListView Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectListView Class

CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class. It implements standard listview control

Class Hierarchy

class CXTPSkinObjectListView : public CXTPSkinObjectComCtl32Control;
File

XTPSkinObjectListView.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectListView Constructors
CXTPSkinObjectListView Constructors | Description
CXTPSkinObjectListView | Constructs a CXTPSkinObjectListView object.
CXTPSkinObjectListView Destructors
CXTPSkinObjectListView Destructors | Description
~CXTPSkinObjectListView | Destroys a CXTPSkinObjectListView object, handles cleanup and deallocation.


CXTPSkinObjectListView Constructors

CXTPSkinObjectListView Class, Legend, Public Methods
CXTPSkinObjectListView Constructors
Class

CXTPSkinObjectListView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectListView | Constructs a CXTPSkinObjectListView object.


CXTPSkinObjectListView::CXTPSkinObjectListView Constructor

CXTPSkinObjectListView Constructors, CXTPSkinObjectListView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectListView::CXTPSkinObjectListView Constructor

Constructs a CXTPSkinObjectListView object.

CXTPSkinObjectListView();
Group

CXTPSkinObjectListView Constructors


CXTPSkinObjectListView Destructors

CXTPSkinObjectListView Class, Legend, Public Methods
CXTPSkinObjectListView Destructors
Class

CXTPSkinObjectListView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectListView | Destroys a CXTPSkinObjectListView object, handles cleanup and deallocation.


CXTPSkinObjectListView::~CXTPSkinObjectListView Destructor

CXTPSkinObjectListView Destructors, CXTPSkinObjectListView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectListView::~CXTPSkinObjectListView Destructor

Destroys a CXTPSkinObjectListView object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectListView();
Group

CXTPSkinObjectListView Destructors


CXTPSkinObjectMonthCal Class

XTPSkinObjectComboBox.h, Classes, Legend, Members, Topics, CXTPSkinObjectMonthCal Methods, CXTPSkinObjectMonthCal Constructors, CXTPSkinObjectMonthCal Constructors, CXTPSkinObjectMonthCal Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectMonthCal Class

CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class. It implements month calendar

Class Hierarchy

class CXTPSkinObjectMonthCal : public CXTPSkinObjectFrame;
File

XTPSkinObjectComboBox.h

Group

Classes

Legend
Method
CXTPSkinObjectMonthCal Constructors
CXTPSkinObjectMonthCal Constructors | Description
CXTPSkinObjectMonthCal | Constructs a CXTPSkinObjectMonthCal object.
CXTPSkinObjectMonthCal Methods
CXTPSkinObjectMonthCal Methods | Description
RefreshMetrics | This method is called when visual metrics was changed


CXTPSkinObjectMonthCal Methods

CXTPSkinObjectMonthCal Class, Legend, Public Methods
CXTPSkinObjectMonthCal Methods
Class

CXTPSkinObjectMonthCal Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RefreshMetrics | This method is called when visual metrics was changed


CXTPSkinObjectMonthCal::RefreshMetrics Method

CXTPSkinObjectMonthCal Methods, CXTPSkinObjectMonthCal Class
CXTPSkinObjectMonthCal::RefreshMetrics Method

This method is called when visual metrics was changed

void RefreshMetrics();
Group

CXTPSkinObjectMonthCal Methods


CXTPSkinObjectMonthCal Constructors

CXTPSkinObjectMonthCal Class, Legend, Public Methods
CXTPSkinObjectMonthCal Constructors
Class

CXTPSkinObjectMonthCal Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectMonthCal | Constructs a CXTPSkinObjectMonthCal object.


CXTPSkinObjectMonthCal::CXTPSkinObjectMonthCal Constructor

CXTPSkinObjectMonthCal Constructors, CXTPSkinObjectMonthCal Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectMonthCal::CXTPSkinObjectMonthCal Constructor

Constructs a CXTPSkinObjectMonthCal object.

CXTPSkinObjectMonthCal();
Group

CXTPSkinObjectMonthCal Constructors


CXTPSkinObjectProgress Class

XTPSkinObjectProgress.h, Classes, Legend, Members, Topics, CXTPSkinObjectProgress Constructors, CXTPSkinObjectProgress Destructors, CXTPSkinObjectProgress Constructors, CXTPSkinObjectProgress Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectProgress Class

CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class. It implements standard progress control

Class Hierarchy

class CXTPSkinObjectProgress : public CXTPSkinObjectFrame;
File

XTPSkinObjectProgress.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectProgress Constructors
CXTPSkinObjectProgress Constructors | Description
CXTPSkinObjectProgress | Constructs a CXTPSkinObjectProgress object.
CXTPSkinObjectProgress Destructors
CXTPSkinObjectProgress Destructors | Description
~CXTPSkinObjectProgress | Destroys a CXTPSkinObjectProgress object, handles cleanup and deallocation.


CXTPSkinObjectProgress Constructors

CXTPSkinObjectProgress Class, Legend, Public Methods
CXTPSkinObjectProgress Constructors
Class

CXTPSkinObjectProgress Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectProgress | Constructs a CXTPSkinObjectProgress object.


CXTPSkinObjectProgress::CXTPSkinObjectProgress Constructor

CXTPSkinObjectProgress Constructors, CXTPSkinObjectProgress Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectProgress::CXTPSkinObjectProgress Constructor

Constructs a CXTPSkinObjectProgress object.

CXTPSkinObjectProgress();
Group

CXTPSkinObjectProgress Constructors


CXTPSkinObjectProgress Destructors

CXTPSkinObjectProgress Class, Legend, Public Methods
CXTPSkinObjectProgress Destructors
Class

CXTPSkinObjectProgress Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectProgress | Destroys a CXTPSkinObjectProgress object, handles cleanup and deallocation.


CXTPSkinObjectProgress::~CXTPSkinObjectProgress Destructor

CXTPSkinObjectProgress Destructors, CXTPSkinObjectProgress Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectProgress::~CXTPSkinObjectProgress Destructor

Destroys a CXTPSkinObjectProgress object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectProgress();
Group

CXTPSkinObjectProgress Destructors


CXTPSkinObjectScrollBar Class

XTPSkinObjectScrollBar.h, Classes, Legend, Members, Topics, CXTPSkinObjectScrollBar Constructors, CXTPSkinObjectScrollBar Destructors, CXTPSkinObjectScrollBar Constructors, CXTPSkinObjectScrollBar Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectScrollBar Class

CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class. It implements standard scroll bar control

Class Hierarchy

class CXTPSkinObjectScrollBar : public CXTPSkinObjectFrame;
File

XTPSkinObjectScrollBar.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectScrollBar Constructors
CXTPSkinObjectScrollBar Constructors | Description
CXTPSkinObjectScrollBar | Constructs a CXTPSkinObjectScrollBar object.
CXTPSkinObjectScrollBar Destructors
CXTPSkinObjectScrollBar Destructors | Description
~CXTPSkinObjectScrollBar | Destroys a CXTPSkinObjectScrollBar object, handles cleanup and deallocation.


CXTPSkinObjectScrollBar Constructors

CXTPSkinObjectScrollBar Class, Legend, Public Methods
CXTPSkinObjectScrollBar Constructors
Class

CXTPSkinObjectScrollBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectScrollBar | Constructs a CXTPSkinObjectScrollBar object.


CXTPSkinObjectScrollBar::CXTPSkinObjectScrollBar Constructor

CXTPSkinObjectScrollBar Constructors, CXTPSkinObjectScrollBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectScrollBar::CXTPSkinObjectScrollBar Constructor

Constructs a CXTPSkinObjectScrollBar object.

CXTPSkinObjectScrollBar();
Group

CXTPSkinObjectScrollBar Constructors


CXTPSkinObjectScrollBar Destructors

CXTPSkinObjectScrollBar Class, Legend, Public Methods
CXTPSkinObjectScrollBar Destructors
Class

CXTPSkinObjectScrollBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectScrollBar | Destroys a CXTPSkinObjectScrollBar object, handles cleanup and deallocation.


CXTPSkinObjectScrollBar::~CXTPSkinObjectScrollBar Destructor

CXTPSkinObjectScrollBar Destructors, CXTPSkinObjectScrollBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectScrollBar::~CXTPSkinObjectScrollBar Destructor

Destroys a CXTPSkinObjectScrollBar object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectScrollBar();
Group

CXTPSkinObjectScrollBar Destructors


CXTPSkinObjectSpin Class

XTPSkinObjectSpin.h, Classes, Legend, Members, Topics, CXTPSkinObjectSpin Constructors, CXTPSkinObjectSpin Destructors, CXTPSkinObjectSpin Constructors, CXTPSkinObjectSpin Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectSpin Class

CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class. It implements standard spin control

Class Hierarchy

class CXTPSkinObjectSpin : public CXTPSkinObjectFrame;
File

XTPSkinObjectSpin.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectSpin Constructors
CXTPSkinObjectSpin Constructors | Description
CXTPSkinObjectSpin | Constructs a CXTPSkinObjectSpin object.
CXTPSkinObjectSpin Destructors
CXTPSkinObjectSpin Destructors | Description
~CXTPSkinObjectSpin | Destroys a CXTPSkinObjectSpin object, handles cleanup and deallocation.


CXTPSkinObjectSpin Constructors

CXTPSkinObjectSpin Class, Legend, Public Methods
CXTPSkinObjectSpin Constructors
Class

CXTPSkinObjectSpin Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectSpin | Constructs a CXTPSkinObjectSpin object.


CXTPSkinObjectSpin::CXTPSkinObjectSpin Constructor

CXTPSkinObjectSpin Constructors, CXTPSkinObjectSpin Class
CXTPSkinObjectSpin::CXTPSkinObjectSpin Constructor

Constructs a CXTPSkinObjectSpin object.

CXTPSkinObjectSpin();
Group

CXTPSkinObjectSpin Constructors


CXTPSkinObjectSpin Destructors

CXTPSkinObjectSpin Class, Legend, Public Methods
CXTPSkinObjectSpin Destructors
Class

CXTPSkinObjectSpin Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectSpin | Destroys a CXTPSkinObjectSpin object, handles cleanup and deallocation.


CXTPSkinObjectSpin::~CXTPSkinObjectSpin Destructor

CXTPSkinObjectSpin Destructors, CXTPSkinObjectSpin Class
CXTPSkinObjectSpin::~CXTPSkinObjectSpin Destructor

Destroys a CXTPSkinObjectSpin object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectSpin();
Group

CXTPSkinObjectSpin Destructors


CXTPSkinObjectStatusBar Class

XTPSkinObjectStatusBar.h, Classes, Legend, Members, Topics, CXTPSkinObjectStatusBar Constructors, CXTPSkinObjectStatusBar Destructors, CXTPSkinObjectStatusBar Constructors, CXTPSkinObjectStatusBar Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectStatusBar Class

CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class. It implements standard status bar control

Class Hierarchy

class CXTPSkinObjectStatusBar : public CXTPSkinObjectFrame;
File

XTPSkinObjectStatusBar.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectStatusBar Constructors
CXTPSkinObjectStatusBar Constructors | Description
CXTPSkinObjectStatusBar | Constructs a CXTPSkinObjectStatusBar object.
CXTPSkinObjectStatusBar Destructors
CXTPSkinObjectStatusBar Destructors | Description
~CXTPSkinObjectStatusBar | Destroys a CXTPSkinObjectStatusBar object, handles cleanup and deallocation.


CXTPSkinObjectStatusBar Constructors

CXTPSkinObjectStatusBar Class, Legend, Public Methods
CXTPSkinObjectStatusBar Constructors
Class

CXTPSkinObjectStatusBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectStatusBar | Constructs a CXTPSkinObjectStatusBar object.


CXTPSkinObjectStatusBar::CXTPSkinObjectStatusBar Constructor

CXTPSkinObjectStatusBar Constructors, CXTPSkinObjectStatusBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectStatusBar::CXTPSkinObjectStatusBar Constructor

Constructs a CXTPSkinObjectStatusBar object.

CXTPSkinObjectStatusBar();
Group

CXTPSkinObjectStatusBar Constructors


CXTPSkinObjectStatusBar Destructors

CXTPSkinObjectStatusBar Class, Legend, Public Methods
CXTPSkinObjectStatusBar Destructors
Class

CXTPSkinObjectStatusBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectStatusBar | Destroys a CXTPSkinObjectStatusBar object, handles cleanup and deallocation.


CXTPSkinObjectStatusBar::~CXTPSkinObjectStatusBar Destructor

CXTPSkinObjectStatusBar Destructors, CXTPSkinObjectStatusBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectStatusBar::~CXTPSkinObjectStatusBar Destructor

Destroys a CXTPSkinObjectStatusBar object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectStatusBar();
Group

CXTPSkinObjectStatusBar Destructors


CXTPSkinObjectTab Class

XTPSkinObjectTab.h, Classes, Legend, Members, Topics, CXTPSkinObjectTab Constructors, CXTPSkinObjectTab Destructors, CXTPSkinObjectTab Constructors, CXTPSkinObjectTab Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectTab Class

CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class. It implements standard tab control

Class Hierarchy

class CXTPSkinObjectTab : public CXTPSkinObjectFrame;
File

XTPSkinObjectTab.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectTab Constructors
CXTPSkinObjectTab Constructors | Description
CXTPSkinObjectTab | Constructs a CXTPSkinObjectTab object.
CXTPSkinObjectTab Destructors
CXTPSkinObjectTab Destructors | Description
~CXTPSkinObjectTab | Destroys a CXTPSkinObjectTab object, handles cleanup and deallocation.


CXTPSkinObjectTab Constructors

CXTPSkinObjectTab Class, Legend, Public Methods
CXTPSkinObjectTab Constructors
Class

CXTPSkinObjectTab Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectTab | Constructs a CXTPSkinObjectTab object.


CXTPSkinObjectTab::CXTPSkinObjectTab Constructor

CXTPSkinObjectTab Constructors, CXTPSkinObjectTab Class
CXTPSkinObjectTab::CXTPSkinObjectTab Constructor

Constructs a CXTPSkinObjectTab object.

CXTPSkinObjectTab();
Group

CXTPSkinObjectTab Constructors


CXTPSkinObjectTab Destructors

CXTPSkinObjectTab Class, Legend, Public Methods
CXTPSkinObjectTab Destructors
Class

CXTPSkinObjectTab Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectTab | Destroys a CXTPSkinObjectTab object, handles cleanup and deallocation.


CXTPSkinObjectTab::~CXTPSkinObjectTab Destructor

CXTPSkinObjectTab Destructors, CXTPSkinObjectTab Class
CXTPSkinObjectTab::~CXTPSkinObjectTab Destructor

Destroys a CXTPSkinObjectTab object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectTab();
Group

CXTPSkinObjectTab Destructors


CXTPSkinObjectToolBar Class

XTPSkinObjectToolBar.h, Classes, Legend, Members, Topics, CXTPSkinObjectToolBar Constructors, CXTPSkinObjectToolBar Destructors, CXTPSkinObjectToolBar Constructors, CXTPSkinObjectToolBar Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectToolBar Class

CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class. It implements standard toolbar control

Class Hierarchy

class CXTPSkinObjectToolBar : public CXTPSkinObjectFrame;
File

XTPSkinObjectToolBar.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectToolBar Constructors
CXTPSkinObjectToolBar Constructors | Description
CXTPSkinObjectToolBar | Constructs a CXTPSkinObjectToolBar object.
CXTPSkinObjectToolBar Destructors
CXTPSkinObjectToolBar Destructors | Description
~CXTPSkinObjectToolBar | Destroys a CXTPSkinObjectToolBar object, handles cleanup and deallocation.


CXTPSkinObjectToolBar Constructors

CXTPSkinObjectToolBar Class, Legend, Public Methods
CXTPSkinObjectToolBar Constructors
Class

CXTPSkinObjectToolBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectToolBar | Constructs a CXTPSkinObjectToolBar object.


CXTPSkinObjectToolBar::CXTPSkinObjectToolBar Constructor

CXTPSkinObjectToolBar Constructors, CXTPSkinObjectToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectToolBar::CXTPSkinObjectToolBar Constructor

Constructs a CXTPSkinObjectToolBar object.

CXTPSkinObjectToolBar();
Group

CXTPSkinObjectToolBar Constructors


CXTPSkinObjectToolBar Destructors

CXTPSkinObjectToolBar Class, Legend, Public Methods
CXTPSkinObjectToolBar Destructors
Class

CXTPSkinObjectToolBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectToolBar | Destroys a CXTPSkinObjectToolBar object, handles cleanup and deallocation.


CXTPSkinObjectToolBar::~CXTPSkinObjectToolBar Destructor

CXTPSkinObjectToolBar Destructors, CXTPSkinObjectToolBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectToolBar::~CXTPSkinObjectToolBar Destructor

Destroys a CXTPSkinObjectToolBar object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectToolBar();
Group

CXTPSkinObjectToolBar Destructors


CXTPSkinObjectTrackBar Class

XTPSkinObjectTrackBar.h, Classes, Legend, Members, Topics, CXTPSkinObjectTrackBar Constructors, CXTPSkinObjectTrackBar Destructors, CXTPSkinObjectTrackBar Constructors, CXTPSkinObjectTrackBar Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectTrackBar Class

CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class. It implements standard track bar control

Class Hierarchy

class CXTPSkinObjectTrackBar : public CXTPSkinObjectFrame;
File

XTPSkinObjectTrackBar.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectTrackBar Constructors
CXTPSkinObjectTrackBar Constructors | Description
CXTPSkinObjectTrackBar | Constructs a CXTPSkinObjectTrackBar object.
CXTPSkinObjectTrackBar Destructors
CXTPSkinObjectTrackBar Destructors | Description
~CXTPSkinObjectTrackBar | Destroys a CXTPSkinObjectTrackBar object, handles cleanup and deallocation.


CXTPSkinObjectTrackBar Constructors

CXTPSkinObjectTrackBar Class, Legend, Public Methods
CXTPSkinObjectTrackBar Constructors
Class

CXTPSkinObjectTrackBar Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectTrackBar | Constructs a CXTPSkinObjectTrackBar object.


CXTPSkinObjectTrackBar::CXTPSkinObjectTrackBar Constructor

CXTPSkinObjectTrackBar Constructors, CXTPSkinObjectTrackBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectTrackBar::CXTPSkinObjectTrackBar Constructor

Constructs a CXTPSkinObjectTrackBar object.

CXTPSkinObjectTrackBar();
Group

CXTPSkinObjectTrackBar Constructors


CXTPSkinObjectTrackBar Destructors

CXTPSkinObjectTrackBar Class, Legend, Public Methods
CXTPSkinObjectTrackBar Destructors
Class

CXTPSkinObjectTrackBar Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectTrackBar | Destroys a CXTPSkinObjectTrackBar object, handles cleanup and deallocation.


CXTPSkinObjectTrackBar::~CXTPSkinObjectTrackBar Destructor

CXTPSkinObjectTrackBar Destructors, CXTPSkinObjectTrackBar Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectTrackBar::~CXTPSkinObjectTrackBar Destructor

Destroys a CXTPSkinObjectTrackBar object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectTrackBar();
Group

CXTPSkinObjectTrackBar Destructors


CXTPSkinObjectTreeView Class

XTPSkinObjectTreeView.h, Classes, Legend, Members, Topics, CXTPSkinObjectTreeView Constructors, CXTPSkinObjectTreeView Destructors, CXTPSkinObjectTreeView Constructors, CXTPSkinObjectTreeView Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectTreeView Class

CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class. It implements standard tree view control

Class Hierarchy

class CXTPSkinObjectTreeView : public CXTPSkinObjectComCtl32Control;
File

XTPSkinObjectTreeView.h

Group

Classes

Legend
Constructor
virtual
CXTPSkinObjectTreeView Constructors
CXTPSkinObjectTreeView Constructors | Description
CXTPSkinObjectTreeView | Constructs a CXTPSkinObjectTreeView object.
CXTPSkinObjectTreeView Destructors
CXTPSkinObjectTreeView Destructors | Description
~CXTPSkinObjectTreeView | Destroys a CXTPSkinObjectTreeView object, handles cleanup and deallocation.


CXTPSkinObjectTreeView Constructors

CXTPSkinObjectTreeView Class, Legend, Public Methods
CXTPSkinObjectTreeView Constructors
Class

CXTPSkinObjectTreeView Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectTreeView | Constructs a CXTPSkinObjectTreeView object.


CXTPSkinObjectTreeView::CXTPSkinObjectTreeView Constructor

CXTPSkinObjectTreeView Constructors, CXTPSkinObjectTreeView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectTreeView::CXTPSkinObjectTreeView Constructor

Constructs a CXTPSkinObjectTreeView object.

CXTPSkinObjectTreeView();
Group

CXTPSkinObjectTreeView Constructors


CXTPSkinObjectTreeView Destructors

CXTPSkinObjectTreeView Class, Legend, Public Methods
CXTPSkinObjectTreeView Destructors
Class

CXTPSkinObjectTreeView Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSkinObjectTreeView | Destroys a CXTPSkinObjectTreeView object, handles cleanup and deallocation.


CXTPSkinObjectTreeView::~CXTPSkinObjectTreeView Destructor

CXTPSkinObjectTreeView Destructors, CXTPSkinObjectTreeView Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectTreeView::~CXTPSkinObjectTreeView Destructor

Destroys a CXTPSkinObjectTreeView object, handles cleanup and deallocation.

virtual ~CXTPSkinObjectTreeView();
Group

CXTPSkinObjectTreeView Destructors


CXTPSkinObjectUser32Control Class

XTPSkinObjectFrame.h, Classes, Legend, Members, Topics, CXTPSkinObjectUser32Control Methods, CXTPSkinObjectUser32Control Constructors, CXTPSkinObjectUser32Control Constructors, CXTPSkinObjectUser32Control Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectUser32Control Class

CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class. It is base class for all User32 defined controls

Class Hierarchy

class CXTPSkinObjectUser32Control : public CXTPSkinObjectFrame;
File

XTPSkinObjectFrame.h

Group

Classes

Legend
Method
protected
virtual
CXTPSkinObjectUser32Control Constructors
CXTPSkinObjectUser32Control Constructors | Description
CXTPSkinObjectUser32Control | Constructs a CXTPSkinObjectUser32Control object.
CXTPSkinObjectUser32Control Methods
CXTPSkinObjectUser32Control Methods | Description
CheckScrollBarsDraw | This method called to determine if scroll bar position was changed


CXTPSkinObjectUser32Control Methods

CXTPSkinObjectUser32Control Class, Legend, Protected Methods
CXTPSkinObjectUser32Control Methods
Class

CXTPSkinObjectUser32Control Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CheckScrollBarsDraw | This method called to determine if scroll bar position was changed


CXTPSkinObjectUser32Control::CheckScrollBarsDraw Method

CXTPSkinObjectUser32Control Methods, CXTPSkinObjectUser32Control Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectUser32Control::CheckScrollBarsDraw Method

This method called to determine if scroll bar position was changed

virtual void CheckScrollBarsDraw();
Group

CXTPSkinObjectUser32Control Methods


CXTPSkinObjectUser32Control Constructors

CXTPSkinObjectUser32Control Class, Legend, Protected Methods
CXTPSkinObjectUser32Control Constructors
Class

CXTPSkinObjectUser32Control Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinObjectUser32Control | Constructs a CXTPSkinObjectUser32Control object.


CXTPSkinObjectUser32Control::CXTPSkinObjectUser32Control Constructor

CXTPSkinObjectUser32Control Constructors, CXTPSkinObjectUser32Control Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSkinObjectUser32Control::CXTPSkinObjectUser32Control Constructor

Constructs a CXTPSkinObjectUser32Control object.

CXTPSkinObjectUser32Control();
Group

CXTPSkinObjectUser32Control Constructors


Functions

Functions, Legend, Skin Framework
Functions
Functions
Function | Description
XTPSkinManager | Call this function to access CXTPSkinManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSkinManager.
Module

Skin Framework

Legend
Method


XTPSkinManager Function

XTPSkinManager.h, Functions, Example
XTPSkinManager Function

Call this function to access CXTPSkinManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSkinManager.

CXTPSkinManager* XTPSkinManager();
File

XTPSkinManager.h

Example
XTPSkinManager()->SetApplyOptions(xtpSkinApplyMetrics | xtpSkinApplyFrame | xtpSkinApplyColors);
Group

Functions


Structs, Records, Enums

Enumerations, Legend, Skin Framework
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPSkinApplyOptions | Apply options of selected skin
XTPSkinManagerProperty | Available property for CXTPSkinManagerSchemaProperty class
Module

Skin Framework

Legend
Enumeration


XTPSkinApplyOptions Enumeration

XTPSkinManager.h, Structs, Records, Enums, Example, See Also
XTPSkinApplyOptions Enumeration

Apply options of selected skin

enum XTPSkinApplyOptions {
  xtpSkinApplyMetrics = 1,
  xtpSkinApplyFrame = 2,
  xtpSkinApplyColors = 4
};
File

XTPSkinManager.h

Members

xtpSkinApplyMetrics
TRUE to apply frame metrics (Caption height/font, scrollbars width/with, etc)
xtpSkinApplyFrame
TRUE to apply frame skins.
xtpSkinApplyColors
TRUE to use skin colors.

See Also

CXTPSkinManager, CXTPSkinManager::SetApplyOptions

Example
XTPSkinManager()->SetApplyOptions(xtpSkinApplyMetrics | xtpSkinApplyFrame | xtpSkinApplyColors);
Group

Structs, Records, Enums


XTPSkinManagerProperty Enumeration

XTPSkinManagerSchema.h, Structs, Records, Enums, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTPSkinManagerProperty Enumeration

Available property for CXTPSkinManagerSchemaProperty class

enum XTPSkinManagerProperty {
  XTP_SKINPROPERTY_UNKNOWN,
  XTP_SKINPROPERTY_STRING,
  XTP_SKINPROPERTY_INT,
  XTP_SKINPROPERTY_BOOL,
  XTP_SKINPROPERTY_COLOR,
  XTP_SKINPROPERTY_RECT,
  XTP_SKINPROPERTY_FONT,
  XTP_SKINPROPERTY_INTLIST,
  XTP_SKINPROPERTY_ENUM,
  XTP_SKINPROPERTY_POSITION,
  XTP_SKINPROPERTY_FILENAME = XTP_SKINPROPERTY_STRING,
  XTP_SKINPROPERTY_MARGINS = XTP_SKINPROPERTY_RECT,
  XTP_SKINPROPERTY_SIZE = XTP_SKINPROPERTY_INT
};
File

XTPSkinManagerSchema.h

Members

XTP_SKINPROPERTY_UNKNOWN
Not defined
XTP_SKINPROPERTY_STRING
CString property
XTP_SKINPROPERTY_INT
int property
XTP_SKINPROPERTY_BOOL
BOOL property
XTP_SKINPROPERTY_COLOR
COLORREF property
XTP_SKINPROPERTY_RECT
CRect property
XTP_SKINPROPERTY_FONT
LOGFONT property
XTP_SKINPROPERTY_INTLIST
CIntArray property
XTP_SKINPROPERTY_ENUM
enum property
XTP_SKINPROPERTY_POSITION
int property
XTP_SKINPROPERTY_FILENAME
FileName property
XTP_SKINPROPERTY_MARGINS
Margins property
XTP_SKINPROPERTY_SIZE
Size property

See Also

CXTPSkinManagerSchemaProperty

Example
XTPSkinManager()->GetProperty(XTP_SKINPROPERTY_BOOL, iPartId, iStateId, TMT_TRANSPARENT);
Group

Structs, Records, Enums


Files

Files, Skin Framework
Files
Files
File | Description
XTPSkinImage.h | XTPSkinImage.h: interface for the CXTPSkinImage class.
XTPSkinManager.h | XTPSkinManager.h: interface for the CXTPSkinManager class.
XTPSkinManagerApiHook.h | XTPSkinManagerApiHook.h: interface for the CXTPSkinManagerApiHook class.
XTPSkinManagerModuleList.h | XTPSkinManagerModuleList.h: interface for the CXTPSkinManagerModuleList class.
XTPSkinManagerResource.h | XTPSkinManagerResource.h: interface for the CXTPSkinManagerResourceFile class.
XTPSkinManagerSchema.h | XTPSkinManagerSchema.h: interface for the CXTPSkinManagerSchema class.
XTPSkinObject.h | XTPSkinObject.h: interface for the CXTPSkinObject class.
XTPSkinObjectButton.h | XTPSkinObjectButton.h: interface for the CXTPSkinObjectButton class.
XTPSkinObjectComboBox.h | XTPSkinObjectComboBox.h: interface for the CXTPSkinObjectComboBox class.
XTPSkinObjectEdit.h | XTPSkinObjectEdit.h: interface for the CXTPSkinObjectEdit class.
XTPSkinObjectFrame.h | XTPSkinObjectFrame.h: interface for the CXTPSkinObjectFrame class.
XTPSkinObjectHeader.h | XTPSkinObjectHeader.h: interface for the CXTPSkinObjectHeader class.
XTPSkinObjectListBox.h | XTPSkinObjectListBox.h: interface for the CXTPSkinObjectListBox class.
XTPSkinObjectListView.h | XTPSkinObjectListView.h: interface for the CXTPSkinObjectListView class.
XTPSkinObjectMDI.h | XTPSkinObjectMDI.h: interface for the CXTPSkinObjectMDI class.
XTPSkinObjectProgress.h | XTPSkinObjectProgress.h: interface for the CXTPSkinObjectProgress class.
XTPSkinObjectScrollBar.h | XTPSkinObjectScrollBar.h: interface for the CXTPSkinObjectScrollBar class.
XTPSkinObjectSpin.h | XTPSkinObjectSpin.h: interface for the CXTPSkinObjectSpin class.
XTPSkinObjectStatusBar.h | XTPSkinObjectStatusBar.h: interface for the CXTPSkinObjectStatusBar class.
XTPSkinObjectTab.h | XTPSkinObjectTab.h: interface for the CXTPSkinObjectTab class.
XTPSkinObjectToolBar.h | XTPSkinObjectToolBar.h: interface for the CXTPSkinObjectToolBar class.
XTPSkinObjectTrackBar.h | XTPSkinObjectTrackBar.h: interface for the CXTPSkinObjectTrackBar class.
XTPSkinObjectTreeView.h | XTPSkinObjectTreeView.h: interface for the CXTPSkinObjectTreeView class.
Module

Skin Framework


XTPSkinImage.h

Classes, Files
XTPSkinImage.h

XTPSkinImage.h: interface for the CXTPSkinImage class.

Classes
Class | Description
CXTPSkinImage | CXTPSkinImage class represents simple bitmap holder and draw operations for Skin Framework
CXTPSkinImages | CXTPSkinImages represents cashed collection of CXTPSkinImage classes
Group

Files


XTPSkinManager.h

Classes, Enumerations, Functions, Files, Legend
XTPSkinManager.h

XTPSkinManager.h: interface for the CXTPSkinManager class.

Classes
Class | Description
CXTPSkinManager | CXTPSkinManager is a standalone class that represents a global object managing skins.
CXTPSkinManagerClass | CXTPSkinManagerClass is a standalone class that represents a single visual class of skin manager.
CXTPSkinManagerMetrics | CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin
Enumerations
Enumeration | Description
XTPSkinApplyOptions | Apply options of selected skin
Functions
Function | Description
XTPSkinManager | Call this function to access CXTPSkinManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSkinManager.
Group

Files

Legend
Enumeration
Method


XTPSkinManagerApiHook.h

Files
XTPSkinManagerApiHook.h

XTPSkinManagerApiHook.h: interface for the CXTPSkinManagerApiHook class.

Group

Files


XTPSkinManagerModuleList.h

Files
XTPSkinManagerModuleList.h

XTPSkinManagerModuleList.h: interface for the CXTPSkinManagerModuleList class.

Group

Files


XTPSkinManagerResource.h

Classes, Files
XTPSkinManagerResource.h

XTPSkinManagerResource.h: interface for the CXTPSkinManagerResourceFile class.

Classes
Class | Description
CXTPSkinManagerResourceFile | CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources
Group

Files


XTPSkinManagerSchema.h

Classes, Enumerations, Files, Legend
XTPSkinManagerSchema.h

XTPSkinManagerSchema.h: interface for the CXTPSkinManagerSchema class.

Classes
Class | Description
CXTPSkinManagerSchema | CXTPSkinManagerSchema is standalone class used to read visual styles schema file
CXTPSkinManagerSchemaDefault | CXTPSkinManagerSchemaDefault is CXTPSkinManagerSchema derived class is used to implement standard visual style.
CXTPSkinManagerSchemaProperty | CXTPSkinManagerSchemaProperty is standalone class represented single property of visual styles ini file
Enumerations
Enumeration | Description
XTPSkinManagerProperty | Available property for CXTPSkinManagerSchemaProperty class
Group

Files

Legend
Enumeration


XTPSkinObject.h

Classes, Files
XTPSkinObject.h

XTPSkinObject.h: interface for the CXTPSkinObject class.

Classes
Class | Description
CXTPSkinObject | CXTPSkinObject is a CWnd derived class. It represents base class for all skinable windows.
CXTPSkinObjectClassMap | CXTPSkinObjectClassMap class is standalone class that help map windows controls to skin framework classes.
Group

Files


XTPSkinObjectButton.h

Classes, Files
XTPSkinObjectButton.h

XTPSkinObjectButton.h: interface for the CXTPSkinObjectButton class.

Classes
Class | Description
CXTPSkinObjectButton | CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class. It implements standard buttons
Group

Files


XTPSkinObjectComboBox.h

Classes, Files
XTPSkinObjectComboBox.h

XTPSkinObjectComboBox.h: interface for the CXTPSkinObjectComboBox class.

Classes
Class | Description
CXTPSkinObjectComboBox | CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class. It implements standard comboboxes
CXTPSkinObjectDateTime | CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class. It implements date time control
CXTPSkinObjectMonthCal | CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class. It implements month calendar
Group

Files


XTPSkinObjectEdit.h

Classes, Files
XTPSkinObjectEdit.h

XTPSkinObjectEdit.h: interface for the CXTPSkinObjectEdit class.

Classes
Class | Description
CXTPSkinObjectEdit | CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class. It implements standard edit control
Group

Files


XTPSkinObjectFrame.h

Classes, Files
XTPSkinObjectFrame.h

XTPSkinObjectFrame.h: interface for the CXTPSkinObjectFrame class.

Classes
Class | Description
CXTPSkinObjectComCtl32Control | CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class. It is base class for all ComCtl32 defined controls
CXTPSkinObjectFrame | CXTPSkinObjectFrame is a CXTPSkinObject derived class. It is parent control for all implementations that have border or scroll bars
CXTPSkinObjectUser32Control | CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class. It is base class for all User32 defined controls
Group

Files


XTPSkinObjectHeader.h

Classes, Files
XTPSkinObjectHeader.h

XTPSkinObjectHeader.h: interface for the CXTPSkinObjectHeader class.

Classes
Class | Description
CXTPSkinObjectHeader | CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class. It implements standard list header control
Group

Files


XTPSkinObjectListBox.h

Classes, Files
XTPSkinObjectListBox.h

XTPSkinObjectListBox.h: interface for the CXTPSkinObjectListBox class.

Classes
Class | Description
CXTPSkinObjectListBox | CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class. It implements standard list box control
Group

Files


XTPSkinObjectListView.h

Classes, Files
XTPSkinObjectListView.h

XTPSkinObjectListView.h: interface for the CXTPSkinObjectListView class.

Classes
Class | Description
CXTPSkinObjectListView | CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class. It implements standard listview control
Group

Files


XTPSkinObjectMDI.h

Files
XTPSkinObjectMDI.h

XTPSkinObjectMDI.h: interface for the CXTPSkinObjectMDI class.

Group

Files


XTPSkinObjectProgress.h

Classes, Files
XTPSkinObjectProgress.h

XTPSkinObjectProgress.h: interface for the CXTPSkinObjectProgress class.

Classes
Class | Description
CXTPSkinObjectProgress | CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class. It implements standard progress control
Group

Files


XTPSkinObjectScrollBar.h

Classes, Files
XTPSkinObjectScrollBar.h

XTPSkinObjectScrollBar.h: interface for the CXTPSkinObjectScrollBar class.

Classes
Class | Description
CXTPSkinObjectScrollBar | CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class. It implements standard scroll bar control
Group

Files


XTPSkinObjectSpin.h

Classes, Files
XTPSkinObjectSpin.h

XTPSkinObjectSpin.h: interface for the CXTPSkinObjectSpin class.

Classes
Class | Description
CXTPSkinObjectSpin | CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class. It implements standard spin control
Group

Files


XTPSkinObjectStatusBar.h

Classes, Files
XTPSkinObjectStatusBar.h

XTPSkinObjectStatusBar.h: interface for the CXTPSkinObjectStatusBar class.

Classes
Class | Description
CXTPSkinObjectStatusBar | CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class. It implements standard status bar control
Group

Files


XTPSkinObjectTab.h

Classes, Files
XTPSkinObjectTab.h

XTPSkinObjectTab.h: interface for the CXTPSkinObjectTab class.

Classes
Class | Description
CXTPSkinObjectTab | CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class. It implements standard tab control
Group

Files


XTPSkinObjectToolBar.h

Classes, Files
XTPSkinObjectToolBar.h

XTPSkinObjectToolBar.h: interface for the CXTPSkinObjectToolBar class.

Classes
Class | Description
CXTPSkinObjectToolBar | CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class. It implements standard toolbar control
Group

Files


XTPSkinObjectTrackBar.h

Classes, Files
XTPSkinObjectTrackBar.h

XTPSkinObjectTrackBar.h: interface for the CXTPSkinObjectTrackBar class.

Classes
Class | Description
CXTPSkinObjectTrackBar | CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class. It implements standard track bar control
Group

Files


XTPSkinObjectTreeView.h

Classes, Files
XTPSkinObjectTreeView.h

XTPSkinObjectTreeView.h: interface for the CXTPSkinObjectTreeView class.

Classes
Class | Description
CXTPSkinObjectTreeView | CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class. It implements standard tree view control
Group

Files


Syntax Edit

Xtreme Toolkit Pro v12.0, Legend, Topics, Classes, Files, Functions, Macros, Structs, Records, Enums, Types, Variables
Xtreme Toolkit Pro v12.0
Previous | Up | Next
Syntax Edit

Codejock Software's Xtreme Edit Professional Edition provides Windows developers with a sophisticated Visual Studio.NET™ syntax highlight text editor.

Group

Xtreme Toolkit Pro v12.0

Legend
Template
Structure
Method
Enumeration
Classes
Class
Description
CXTPSyntaxEditAutoCompleteWnd
This class implements AutoComplete window. It provides facilities to display predefined strings of data in the sorted order. Then user can navigate over list of strings and choose desired text to complete his input. AutoComplete window provides some ways to navigate by using vertical scroll bar, up/down keys, mouse. If user types alphanumeric keys after AutoComplete window was appeared it uses user input as search criteria and tries to find text from its predefined strings of data that are like user input.
CXTPSyntaxEditBatchCommand
This class represents a pack of some commands in one. It stores commands in the list, and implements standard command execution interfaces on command (un)execution.
CXTPSyntaxEditBufferCommand
The base class for all edit commands related to CXTPSyntaxEditBufferManager. It stores handle of the buffer manager, and provides implementation of common buffer operations, such as text insertion or deletion.
CXTPSyntaxEditBufferManager
This class is the main class for buffer management. One instance of this class is attached with a CXTPSyntaxEditCtrl object. This class contains a list of CBufferIndex class which in turn contains a position in the file (In case of un-modified index) or a CEditBuffer pointer.
CXTPSyntaxEditColorComboBox
This class allow edit colors using combobox control. It display color name and draw rectangle for each item using item color.
CXTPSyntaxEditColorInfo
This storage class is designed to contain information from the color settings file section. It helps easy retrieve color information.
CXTPSyntaxEditColorInfoArray
CXTPSyntaxEditColorSampleText
This class, derived from CStatic, used to display sample of colored text.
CXTPSyntaxEditColorTheme
This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes color settings for corresponding lexical items for given language. You construct instance of CXTPSyntaxEditColorTheme by calling constructor. Then you should call Load() member function to read data from persistent storage (file for this implementation), CXTPSyntaxEditLexColorInfo structures.
CXTPSyntaxEditColorThemesManager
This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.
CXTPSyntaxEditCommand
This class represents abstract Edit Control command interface. Its descendants must implement custom Execute and UnExecute functionality depending on a command type.
This class is used internally by the library only.
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control. It worries about read configuration files from disk when the Edit control is starting, store it in internal structures and refresh parameters in case configuration files are changed after control was started.
CXTPSyntaxEditCtrl
This class is the main CWnd - based editor class. It is a rectangular child window in which the user can enter and edit text.
The control is also capable of enhance text coloring for a number of specific input file types, e.c. C/C++ source files, HTML files, etc. User can create and customize his own text files schemes - they are independent of source files. The control contains the main configuration file, which can contain references to any specific configuration files. By default, this file is placed in the same folder as the application executable and is called... more
CXTPSyntaxEditDeleteStringCommand
This class represents text deletion command. Command execution will delete text from the buffer between specified text positions, its un-execution will insert this text into the buffer.
CXTPSyntaxEditDoc
This class represents a Document portion of the Edit control. It extends functionality provided by CDocument class from MFC's document-view model implementation. CXTPSyntaxEditDoc class works together with CXTPSyntaxEditView and provides storage facilities for it.
CXTPSyntaxEditFileChangesMonitor
this class monitors files changes
CXTPSyntaxEditFindReplaceDlg
This class implements a Find and Replace dialogs for a SyntaxEdit control.
CXTPSyntaxEditGoToLineDlg
This class implements a GoToLine dialog for a SyntaxEdit control.
CXTPSyntaxEditInsertStringCommand
This class represents text insertion command. Command execution will insert a specified text string in the buffer, un-execution will delete this text from the buffer.
CXTPSyntaxEditLexCfgFileReader
This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes lex class instances that represent various lexical items for given language. You construct instance of CXTPSyntaxEditLexCfgFileReader by calling constructor. Then you should call ReadSource() member function to read data from persistent storage (file for this implementation), and process raw data into XTP_EDIT_LEXCLASSINFO structures. Call GetLexClassInfoArray() member function to return a pointer to an array of XTP_EDIT_LEXCLASSINFO data structures.
CXTPSyntaxEditLexClass
CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.
CXTPSyntaxEditLexOnScreenParseCnt
CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process.
CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in separate thread. It also control this working thread and provide interthread interaction.
CXTPSyntaxEditLexParserSchemaOptions
This class is designed to easily manipulate parser options.
CXTPSyntaxEditLexTextBlock
CXTPSyntaxEditLexTextBlock class represents a pice (block) of text which corresponds some lex class in a text schema. It stores start position, end position, pointer to the lex class object in a class schema and some other information. Text blocks organized as a bidirectional list and as tree structure.
CXTPSyntaxEditLexTextSchema
CXTPSyntaxEditLexTextSchema class is used to store data which necessary to parse a text and parsing results. It also contains methods to run lex classes from a class schema, methods to update text schema when text is edited, methods to reparse text, to get information which is necessary to draw colorized text and other helper methods.
CXTPSyntaxEditLexTokensDef
This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators.
CXTPSyntaxEditLexVariable
CXTPSyntaxEditLexVariable class is used to represent lexical variables. In the class schema variables begins from symbol @. Standard variables are: @alpha, @digit, @HexDigit, @specs, @EOL.
CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type.
CXTPSyntaxEditLexVariantPtrArrayExAutomatT
CXTPSyntaxEditLineMarksManager
CXTPSyntaxEditLineMarksManager class provides functionality to to manipulate marks on text lines. Used internally by the Smart Edit control.
CXTPSyntaxEditPaintManager
This class used by CXTPSyntaxEditCtrl as the paint manager.
CXTPSyntaxEditPropertiesDlg
This class provide a default dialog to edit syntax edit control settings.
CXTPSyntaxEditPropertiesPageColor
This class implements a property page colors options.
CXTPSyntaxEditPropertiesPageEdit
This class implements a property page for common edit options.
CXTPSyntaxEditPropertiesPageFont
This class implements a property page font options.
CXTPSyntaxEditReplaceStringCommand
This class represents text replacing command. Command execution will replace text from the buffer between specified text positions, un-execution will do contrary replacement.
CXTPSyntaxEditTextIterator
This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, determine control symbols like CRLF. When you create instance of CXTPSyntaxEditTextIterator class you should provide pointer to data storage, represented by CXTPSyntaxEditTextIterator class.
CXTPSyntaxEditTextRegion
This class is designed to store coordinates of text region.
CXTPSyntaxEditTextSchemesManager
This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.
CXTPSyntaxEditTipComboBox
This class implements a combo box with tooltip.
CXTPSyntaxEditTipListBox
This class implements a list box with tooltip.
CXTPSyntaxEditTipWnd
CXTPSyntaxEditTipWnd implements a tooltip window for CXTPSyntaxEditTipListBox class.
CXTPSyntaxEditToolTipCtrl
The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.
CXTPSyntaxEditToolTipCtrl provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip.
This class is used by the report control internally.
CXTPSyntaxEditUndoRedoManager
This class maintains the list of undo/redo commands. It is managed by CEditBufferManager class.
It allows adding new commands in the buffer (see AddCommand()), undoing last added operation (see DoUndo()), and redoing operations following the latest unexecuted (see DoRedo()).
It also allows checking for the possibility of performing undo/redo operations (see CanUndo() / CanRedo()).
It also allows marking current position of undo/redo operation queue as saved, and returns "modified" flag if the queue position will be changed (see MarkSaved() / IsModified()).
Another piece of the functionality is commands grouping. There are following methods... more
CXTPSyntaxEditView
This class represents a View portion of the Edit Control. It extends functionality provided by CView class from MFC's document-view model implementation. CXTPSyntaxEditView class works together with CXTPSyntaxEditDoc and provides facilities for it to be displayed on a screen or printed on a printer.
CXTPSyntaxEditViewPrintOptions
Describes printing options for the Calendar Control.
XTP_EDIT_ACDATA
XTP_EDIT_ACDATA structure defines items displayed data. Provides text and icon for each displayed line in Auto-complete window.
XTP_EDIT_COLLAPSEDBLOCK
Stores collapsed block parameters.
XTP_EDIT_COLORVALUES
XTP_EDIT_COLORVALUES struct stores the colors for different phrases
XTP_EDIT_FONTOPTIONS
XTP_EDIT_FONTOPTIONS struct is a self initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length.
XTP_EDIT_LINECOL
XTP_EDIT_LINECOL structure represents coordinates of text items on the displaying context in terms of line/column.
XTP_EDIT_ROWSBLOCK
XTP_EDIT_ROWSBLOCK struct
XTP_EDIT_TEXTBLOCK
XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing
Files
File | Description
XTPSyntaxEditAutoCompleteWnd.h | XTPSyntaxEditAutoCompleteWnd.h: interface for the CXTPSyntaxEditAutoCompleteWnd class.
XTPSyntaxEditBufferManager.h | XTPSyntaxEditBufferManager.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditColorComboBox.h | XTPSyntaxEditColorComboBox.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditColorSampleText.h | XTPSyntaxEditColorSampleText.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditCtrl.h | XTPSyntaxEditCtrl.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditDefines.h | XTPSyntaxEditDefines.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditDoc.h | XTPSyntaxEditDoc.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditFindReplaceDlg.h | XTPSyntaxEditFindReplaceDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditGoToLineDlg.h | XTPSyntaxEditGoToLineDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexCfgFileReader.h | XTPSyntaxEditLexCfgFileReader.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClass.h | XTPSyntaxEditLexClass.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClassSubObjDef.h | XTPSyntaxEditLexClassSubObjDef.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClassSubObjT.h | XTPSyntaxEditLexClassSubObjT.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexColorFileReader.h | XTPSyntaxEditLexColorFileReader.h: interface for the CXTLexColorFileReader class.
XTPSyntaxEditLexParser.h | XTPSyntaxEditLexParser.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexPtrs.h | XTPSyntaxEditLexPtrs.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLineMarksManager.h | XTPSyntaxEditLineMarksManager.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditPaintManager.h | XTPSyntaxEditPaintManager.h interface for the CXTPSyntaxEditPaintManager class.
XTPSyntaxEditPropertiesDlg.h | XTPSyntaxEditPropertiesDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditPropertiesPage.h | XTPSyntaxEditPropertiesPage.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditSectionManager.h | XTPSyntaxEditSectionManager.h: interface for the CXTPSyntaxEditSectionManager class.
XTPSyntaxEditStruct.h | XTPSyntaxEditStruct.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditTextIterator.h | XTPSyntaxEditTextIterator.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditToolTipCtrl.h | XTPSyntaxEditToolTipCtrl.h: interface for the CXTPSyntaxEditToolTipCtrl class.
XTPSyntaxEditUndoManager.h | XTPSyntaxEditUndoManager.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditView.h | XTPSyntaxEditView.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
Functions
Function | Description
DDX_CBSyntaxColor | Use this function to exchange currently selected color for CXTPSyntaxEditColorComboBox control.
Macros
Macro | Description
XTP_EDIT_AVELINELEN | Average length of line.
XTP_EDIT_DISABLED_COLOR_DARK | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_EDIT_DISABLED_COLOR_LIGHT | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_EDIT_EDITACTION_DELETEROW | Delete row
XTP_EDIT_EDITACTION_DELETEROW_FULL |
XTP_EDIT_EDITACTION_DELETETEXT | Generic delete text action
XTP_EDIT_EDITACTION_INSERTROW | Insert row
XTP_EDIT_EDITACTION_INSERTTEXT | Generic insert text action
XTP_EDIT_EDITACTION_MODIFYROW | Modify row #define XTP_EDIT_EDITACTION_SELECTIONCHANGED 0x08 // Selection changed
XTP_EDIT_FINDWORD_NEXT | Find start of the next word
XTP_EDIT_FINDWORD_PREV | Find start of the previous word
XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION | Used with XTP_EDIT_FONTOPTIONS struct and define unspecified member value.
XTP_EDIT_NM_DRAWBOOKMARK | This will be called while drawing the bookmarks
XTP_EDIT_NM_EDITCHANGED | This will be called if content has been changed
XTP_EDIT_NM_EDITCHANGING | Edit changing will be called before changing content
XTP_EDIT_NM_ENABLESCROLLBAR | Edit control scroll bar(s) state changed.
XTP_EDIT_NM_FIRST | First notification ID for SyntaxEdit
XTP_EDIT_NM_INSERTKEY | Update all of the vertical panes
XTP_EDIT_NM_LAST | Last notification ID for SyntaxEdit
XTP_EDIT_NM_LBUTTONDBLCLICK | Notify mouse Left button double click.
XTP_EDIT_NM_LBUTTONDOWN | Notify mouse Left button down.
XTP_EDIT_NM_LBUTTONUP | Notify mouse Left button up.
XTP_EDIT_NM_MARGINCLICKED | Left mouse button was clicked in the gutter area
XTP_EDIT_NM_MOUSEMOVE | Notify mouse movement.
XTP_EDIT_NM_PARSEEVENT | This notification used to reflect parser events.
XTP_EDIT_NM_RBUTTONDOWN | Notify mouse Right button down.
XTP_EDIT_NM_RBUTTONUP | Notify mouse Right button up.
XTP_EDIT_NM_ROWCOLCHANGED | This will be fired if row or col has been changed
XTP_EDIT_NM_SELINIT | Updates all the selections while one pane initiates one
XTP_EDIT_NM_SETDOCMODIFIED | Indicates if the document is modified
XTP_EDIT_NM_STARTOLEDRAG | Start OLE drag
XTP_EDIT_NM_UPDATESCROLLPOS | Edit control scroll positions changed.
XTP_EDIT_RGB_GETBLUE | Get blue color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_GETGREEN | Get green color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_GETRED | Get red color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_INT2CLR | Convert raw RGB color value like "0xAABBCC" to COLORREF.
XTP_EDIT_SYNTAXEDIT_DECLARE_SMART_PTR |
XTP_EDIT_XLC | max line: 1 048 575 max col: 4 095
Structs, Records, Enums
Struct, Record, Enum | Description
XTP_EDIT_NMHDR_DOCMODIFIED | Document notification structure Provided as LPARAM with WM_NOTIFY used to notify of a change in the document's modified state.
XTP_EDIT_NMHDR_EDITCHANGED | Structure to notify "Edit changed" event
XTP_EDIT_NMHDR_ENABLESCROLLBAR | Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event
XTP_EDIT_NMHDR_MARGINCLICKED | Structure to notify XTP_EDIT_NM_MARGINCLICKED event
XTP_EDIT_NMHDR_PARSEEVENT | Structure to notify XTP_EDIT_NM_PARSEEVENT event
XTP_EDIT_NMHDR_ROWCOLCHANGED | Row column notification structure Provided as LPARAM with WM_NOTIFY This is used to display current row and column
XTP_EDIT_NMHDR_SETSCROLLPOS | Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event
XTP_EDIT_ROWCOLRECT | This is used to define row and col selection rect
XTP_EDIT_SENMBOOKMARK | Bookmark notification structure Provided as LPARAM with WM_NOTIFY while bookmarks are needed to be drawn
XTPSyntaxEditCfgFlags | This enumeration describes allowable configuration managers flags.
XTPSyntaxEditCRLFStyle | Line endings types
XTPSyntaxEditDeletePos | Edit delete position
XTPSyntaxEditEditAction | This enum describes set of edit actions.
XTPSyntaxEditLexClass_OptChildren | Enumerates children classes relation for the Lex Class object.
XTPSyntaxEditLexClass_OptParent | Enumerates parent class relation for the Lex Class object.
XTPSyntaxEditLexParseResult | Enumerates flags which indicate results of parse functions calls.
XTPSyntaxEditLexVariantType | Enumerates types of values which supported by CXTPSyntaxEditLexVariant class.
XTPSyntaxEditLineMarksRefreshType | Enumerates types of mark refreshing
XTPSyntaxEditOnCfgChangedEvent | these events are sent from different threads. Its receiver must be thread safety.
XTPSyntaxEditOnParseEvent | these events are sent from different threads. Its receiver must be thread safety.
XTPSyntaxEditUpdateViewHint | View update action. Defines in which way the view should be updated.
Types
Type | Description
CTextIter |
CXTPSyntaxEditACDataArray | CXTPSyntaxEditACDataArray type defines a custom array to store AutoComplete items displayed data.
CXTPSyntaxEditACGrid | CXTPSyntaxEditACGrid type defines a custom array to store and manage visible rectangle arrays that represented lines of data in AutoComplete window.
Variables
Variable | Description
XTP_EDIT_ROWNODE_COLLAPSED | Define that row has collapsed node mark.
XTP_EDIT_ROWNODE_ENDMARK | Define that row has end node mark.
XTP_EDIT_ROWNODE_EXPANDED | Define that row has expanded node mark.
XTP_EDIT_ROWNODE_NODEDOWN | Define that row has down-line node mark.
XTP_EDIT_ROWNODE_NODEUP | Define that row has up-line node mark.
XTP_EDIT_ROWNODE_NOTHING | Define that row has no node mark.
xtpEditLMT_Bookmark | You can define your own line mark types (as string constants) Strings are case sensitive!
XTPLEX_ATTR_CASESENSITIVE | Lex Class CaseSensitive flag.
XTPLEX_ATTR_COLLAPSABLE | Lex Class Collapsable flag.
XTPLEX_ATTR_COLLAPSEDTEXT | Collapsed Lex Class mark text.
XTPLEX_ATTR_COLORPREFIX | Prefix of properties which value is color.
XTPLEX_ATTR_DISPLAYNAME | Friendly name to display in options dialog.
XTPLEX_ATTR_ENDCLASSPARENT | if set to 'this' the end block must have this class as parent.
XTPLEX_ATTR_PARSEONSCREEN | Parse Lex Class only for screen drawing.
XTPLEX_ATTR_RECURRENCEDEPTH | define depth of the recurrence blocks.
XTPLEX_ATTR_RESTARTRUNLOOP | if set to 1 - run children loop will be restarted from the beginning when class ended, otherwise next child class will run.
XTPLEX_ATTR_TXT_BOLD | Text font Bold flag.
XTPLEX_ATTR_TXT_COLORBK | Text back ground color
XTPLEX_ATTR_TXT_COLORFG | Text color
XTPLEX_ATTR_TXT_COLORSELBK | Selected text back ground color
XTPLEX_ATTR_TXT_COLORSELFG | Selected text color
XTPLEX_ATTR_TXT_ITALIC | Text font Italic flag.
XTPLEX_ATTR_TXT_UNDERLINE | Text font Underline flag.
XTPLEX_ATTR_TXTPREFIX | Text properties (like color, bold, ...) attributes prefix.
XTPLEX_ATTRCLASSID | Lex Class ID, unique for the classes tree.
XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS | time out for start reparse after last key was pressed.
XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_MAXBACKPARSEOFFSET | maximum back buffer size.
XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC | default= 180 sec; -1 and 0 means infinite; time out for on screen parsed pieces of text.
XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC | default=60 sec; -1 and 0 means infinite; time out for existing of parser thread when parser idle (no parse requests).


Syntax Edit Hierarchy

Syntax Edit
Syntax Edit Hierarchy

Module

Syntax Edit


Classes

Classes, Legend, Syntax Edit, Templates, Structures
Classes
Classes
Class
Description
CXTPSyntaxEditAutoCompleteWnd
This class implements AutoComplete window. It provides facilities to display predefined strings of data in the sorted order. Then user can navigate over list of strings and choose desired text to complete his input. AutoComplete window provides some ways to navigate by using vertical scroll bar, up/down keys, mouse. If user types alphanumeric keys after AutoComplete window was appeared it uses user input as search criteria and tries to find text from its predefined strings of data that are like user input.
CXTPSyntaxEditBatchCommand
This class represents a pack of some commands in one. It stores commands in the list, and implements standard command execution interfaces on command (un)execution.
CXTPSyntaxEditBufferCommand
The base class for all edit commands related to CXTPSyntaxEditBufferManager. It stores handle of the buffer manager, and provides implementation of common buffer operations, such as text insertion or deletion.
CXTPSyntaxEditBufferManager
This class is the main class for buffer management. One instance of this class is attached with a CXTPSyntaxEditCtrl object. This class contains a list of CBufferIndex class which in turn contains a position in the file (In case of un-modified index) or a CEditBuffer pointer.
CXTPSyntaxEditColorComboBox
This class allow edit colors using combobox control. It display color name and draw rectangle for each item using item color.
CXTPSyntaxEditColorInfo
This storage class is designed to contain information from the color settings file section. It helps easy retrieve color information.
CXTPSyntaxEditColorInfoArray
CXTPSyntaxEditColorSampleText
This class, derived from CStatic, used to display sample of colored text.
CXTPSyntaxEditColorTheme
This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes color settings for corresponding lexical items for given language. You construct instance of CXTPSyntaxEditColorTheme by calling constructor. Then you should call Load() member function to read data from persistent storage (file for this implementation), CXTPSyntaxEditLexColorInfo structures.
CXTPSyntaxEditColorThemesManager
This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.
CXTPSyntaxEditCommand
This class represents abstract Edit Control command interface. Its descendants must implement custom Execute and UnExecute functionality depending on a command type.
This class is used internally by the library only.
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control. It worries about read configuration files from disk when the Edit control is starting, store it in internal structures and refresh parameters in case configuration files are changed after control was started.
CXTPSyntaxEditCtrl
This class is the main CWnd - based editor class. It is a rectangular child window in which the user can enter and edit text.
The control is also capable of enhance text coloring for a number of specific input file types, e.c. C/C++ source files, HTML files, etc. User can create and customize his own text files schemes - they are independent of source files. The control contains the main configuration file, which can contain references to any specific configuration files. By default, this file is placed in the same folder as the application executable and is called... more
CXTPSyntaxEditDeleteStringCommand
This class represents text deletion command. Command execution will delete text from the buffer between specified text positions, its un-execution will insert this text into the buffer.
CXTPSyntaxEditDoc
This class represents a Document portion of the Edit control. It extends functionality provided by CDocument class from MFC's document-view model implementation. CXTPSyntaxEditDoc class works together with CXTPSyntaxEditView and provides storage facilities for it.
CXTPSyntaxEditFileChangesMonitor
this class monitors files changes
CXTPSyntaxEditFindReplaceDlg
This class implements a Find and Replace dialogs for a SyntaxEdit control.
CXTPSyntaxEditGoToLineDlg
This class implements a GoToLine dialog for a SyntaxEdit control.
CXTPSyntaxEditInsertStringCommand
This class represents text insertion command. Command execution will insert a specified text string in the buffer, un-execution will delete this text from the buffer.
CXTPSyntaxEditLexCfgFileReader
This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes lex class instances that represent various lexical items for given language. You construct instance of CXTPSyntaxEditLexCfgFileReader by calling constructor. Then you should call ReadSource() member function to read data from persistent storage (file for this implementation), and process raw data into XTP_EDIT_LEXCLASSINFO structures. Call GetLexClassInfoArray() member function to return a pointer to an array of XTP_EDIT_LEXCLASSINFO data structures.
CXTPSyntaxEditLexClass
CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.
CXTPSyntaxEditLexOnScreenParseCnt
CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process.
CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in separate thread. It also control this working thread and provide interthread interaction.
CXTPSyntaxEditLexParserSchemaOptions
This class is designed to easily manipulate parser options.
CXTPSyntaxEditLexTextBlock
CXTPSyntaxEditLexTextBlock class represents a pice (block) of text which corresponds some lex class in a text schema. It stores start position, end position, pointer to the lex class object in a class schema and some other information. Text blocks organized as a bidirectional list and as tree structure.
CXTPSyntaxEditLexTextSchema
CXTPSyntaxEditLexTextSchema class is used to store data which necessary to parse a text and parsing results. It also contains methods to run lex classes from a class schema, methods to update text schema when text is edited, methods to reparse text, to get information which is necessary to draw colorized text and other helper methods.
CXTPSyntaxEditLexTokensDef
This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators.
CXTPSyntaxEditLexVariable
CXTPSyntaxEditLexVariable class is used to represent lexical variables. In the class schema variables begins from symbol @. Standard variables are: @alpha, @digit, @HexDigit, @specs, @EOL.
CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type.
CXTPSyntaxEditLineMarksManager
CXTPSyntaxEditLineMarksManager class provides functionality to to manipulate marks on text lines. Used internally by the Smart Edit control.
CXTPSyntaxEditPaintManager
This class used by CXTPSyntaxEditCtrl as the paint manager.
CXTPSyntaxEditPropertiesDlg
This class provide a default dialog to edit syntax edit control settings.
CXTPSyntaxEditPropertiesPageColor
This class implements a property page colors options.
CXTPSyntaxEditPropertiesPageEdit
This class implements a property page for common edit options.
CXTPSyntaxEditPropertiesPageFont
This class implements a property page font options.
CXTPSyntaxEditReplaceStringCommand
This class represents text replacing command. Command execution will replace text from the buffer between specified text positions, un-execution will do contrary replacement.
CXTPSyntaxEditTextIterator
This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, determine control symbols like CRLF. When you create instance of CXTPSyntaxEditTextIterator class you should provide pointer to data storage, represented by CXTPSyntaxEditTextIterator class.
CXTPSyntaxEditTextRegion
This class is designed to store coordinates of text region.
CXTPSyntaxEditTextSchemesManager
This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.
CXTPSyntaxEditTipComboBox
This class implements a combo box with tooltip.
CXTPSyntaxEditTipListBox
This class implements a list box with tooltip.
CXTPSyntaxEditTipWnd
CXTPSyntaxEditTipWnd implements a tooltip window for CXTPSyntaxEditTipListBox class.
CXTPSyntaxEditToolTipCtrl
The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.
CXTPSyntaxEditToolTipCtrl provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip.
This class is used by the report control internally.
CXTPSyntaxEditUndoRedoManager
This class maintains the list of undo/redo commands. It is managed by CEditBufferManager class.
It allows adding new commands in the buffer (see AddCommand()), undoing last added operation (see DoUndo()), and redoing operations following the latest unexecuted (see DoRedo()).
It also allows checking for the possibility of performing undo/redo operations (see CanUndo() / CanRedo()).
It also allows marking current position of undo/redo operation queue as saved, and returns "modified" flag if the queue position will be changed (see MarkSaved() / IsModified()).
Another piece of the functionality is commands grouping. There are following methods... more
CXTPSyntaxEditView
This class represents a View portion of the Edit Control. It extends functionality provided by CView class from MFC's document-view model implementation. CXTPSyntaxEditView class works together with CXTPSyntaxEditDoc and provides facilities for it to be displayed on a screen or printed on a printer.
CXTPSyntaxEditViewPrintOptions
Describes printing options for the Calendar Control.
Module

Syntax Edit

Templates
Template | Description
CXTPSyntaxEditLexVariantPtrArrayExAutomatT |
Legend
Template
Structure
Structures
Structure | Description
XTP_EDIT_ACDATA | XTP_EDIT_ACDATA structure defines items displayed data. Provides text and icon for each displayed line in Auto-complete window.
XTP_EDIT_COLLAPSEDBLOCK | Stores collapsed block parameters.
XTP_EDIT_COLORVALUES | XTP_EDIT_COLORVALUES struct stores the colors for different phrases
XTP_EDIT_FONTOPTIONS | XTP_EDIT_FONTOPTIONS struct is a self initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length.
XTP_EDIT_LINECOL | XTP_EDIT_LINECOL structure represents coordinates of text items on the displaying context in terms of line/column.
XTP_EDIT_ROWSBLOCK | XTP_EDIT_ROWSBLOCK struct
XTP_EDIT_TEXTBLOCK | XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing


CXTPSyntaxEditAutoCompleteWnd Class

XTPSyntaxEditAutoCompleteWnd.h, Classes, Legend, Members, Topics, CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Constructors, CXTPSyntaxEditAutoCompleteWnd Destructors, CXTPSyntaxEditAutoCompleteWnd Constructors, CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Destructors, CXTPSyntaxEditAutoCompleteWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd Class

This class implements AutoComplete window. It provides facilities to display predefined strings of data in the sorted order. Then user can navigate over list of strings and choose desired text to complete his input. AutoComplete window provides some ways to navigate by using vertical scroll bar, up/down keys, mouse. If user types alphanumeric keys after AutoComplete window was appeared it uses user input as search criteria and tries to find text from its predefined strings of data that are like user input.

Class Hierarchy

class CXTPSyntaxEditAutoCompleteWnd : public CWnd;
File

XTPSyntaxEditAutoCompleteWnd.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditAutoCompleteWnd Constructors
CXTPSyntaxEditAutoCompleteWnd Constructors | Description
CXTPSyntaxEditAutoCompleteWnd | Default class constructor.
CXTPSyntaxEditAutoCompleteWnd Data Members
CXTPSyntaxEditAutoCompleteWnd Data Members | Description
m_arrACData | Stores list of choices (line of text and image)
m_arrACDataFiltered | Stores filtered list of choices (line of text and image)
m_arrGrid | Stores list of rectangle areas where were displayed textimage strings from m_arrACData
m_bActive | Active flag
m_bFilteredMode | Flag to identify is current mode (filtered/full);
m_bFixedBottom | Store autocomplete window position: above or below at the cursor.
m_bHighLight | This flag determines if selected string is highlighted.
m_clrHighLight | Standard window highlight color
m_clrHighLightText | Standard windows highlight text color
m_clrWindow | Standard window color
m_clrWindowText | Standard windows text color
m_fontBasic | Font to display text
m_ilACGlyphs | Images for AutoComplete list
m_nBordersHeight | Stores summary thickness of vertical window borders
m_nEndReplacePos | Position of last char in the Edit Control which will be replaced by the chosen text
m_nFirstDisplayedStr | Current first visible (upper) line
m_nHighLightLine | Current highlight line identifier
m_nLineHeight | Stores height of line
m_nLines | Number of visible lines
m_nStartReplacePos | Position of first char in the Edit Control which will be replaced by the chosen text
m_nWndHeight | Height of window
m_nWndWidth | Width of window
m_pParentWnd | Pointer to the parent window
m_strCloseTags | Stores set of closed tags divided by ~ input closed tags lead to close AutoComplete window
m_strDelims | stores char list that are tag delimiters
m_strOpenTags | Stores open tags
m_strSearch | Temporary stores chain of chars from user input to perform incremental search
m_strTmpCloseTag | Temporary stores chain of chars from user input to recognize close tags
m_strTmpOpenTag | Temporary stores chain of chars from user input to recognize Open tags
CXTPSyntaxEditAutoCompleteWnd Destructors
CXTPSyntaxEditAutoCompleteWnd Destructors | Description
~CXTPSyntaxEditAutoCompleteWnd | Destroys a CXTPSyntaxEditAutoCompleteWnd object, handles cleanup and de-allocation.
CXTPSyntaxEditAutoCompleteWnd Methods
CXTPSyntaxEditAutoCompleteWnd Methods | Description
Create | Creates AutoComplete window and sets predefined properties.
GetWndWidth | This member function is used to obtain width of the auto-complete window.
Hide | Hides AutoComplete window.
HitTest | Returns text line where user click mouse.
IsActive | Returns active flag for AutoComplete window.
IsCloseTag | Determines if user input is Close tag.
IsOpenTag | Determines if user input is open tag.
RefreshMetrics | Updates display settings from system settings.
RegisterWindowClass | This member function registers the window class if it has not already been registered.
SetCloseTags | Sets list of close tags for AutoComplete window.
SetList | Sets list of data to be displayed in AutoComplete window.
SetOpenTags | Sets list of open tags for AutoComplete window.
SetWndWidth | This member function is used to set width of the auto-complete window.
Show | Shows AutoComplete window.


CXTPSyntaxEditAutoCompleteWnd Data Members

CXTPSyntaxEditAutoCompleteWnd Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd Data Members
Class

CXTPSyntaxEditAutoCompleteWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arrACData | Stores list of choices (line of text and image)
m_arrACDataFiltered | Stores filtered list of choices (line of text and image)
m_arrGrid | Stores list of rectangle areas where were displayed textimage strings from m_arrACData
m_bActive | Active flag
m_bFilteredMode | Flag to identify is current mode (filtered/full);
m_bFixedBottom | Store autocomplete window position: above or below at the cursor.
m_bHighLight | This flag determines if selected string is highlighted.
m_clrHighLight | Standard window highlight color
m_clrHighLightText | Standard windows highlight text color
m_clrWindow | Standard window color
m_clrWindowText | Standard windows text color
m_fontBasic | Font to display text
m_ilACGlyphs | Images for AutoComplete list
m_nBordersHeight | Stores summary thickness of vertical window borders
m_nEndReplacePos | Position of last char in the Edit Control which will be replaced by the chosen text
m_nFirstDisplayedStr | Current first visible (upper) line
m_nHighLightLine | Current highlight line identifier
m_nLineHeight | Stores height of line
m_nLines | Number of visible lines
m_nStartReplacePos | Position of first char in the Edit Control which will be replaced by the chosen text
m_nWndHeight | Height of window
m_nWndWidth | Width of window
m_pParentWnd | Pointer to the parent window
m_strCloseTags | Stores set of closed tags divided by ~ input closed tags lead to close AutoComplete window
m_strDelims | stores char list that are tag delimiters
m_strOpenTags | Stores open tags
m_strSearch | Temporary stores chain of chars from user input to perform incremental search
m_strTmpCloseTag | Temporary stores chain of chars from user input to recognize close tags
m_strTmpOpenTag | Temporary stores chain of chars from user input to recognize Open tags


CXTPSyntaxEditAutoCompleteWnd::m_arrACData Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_arrACData Data Member

Stores list of choices (line of text and image)

CXTPSyntaxEditACDataArray m_arrACData;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_arrACDataFiltered Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_arrACDataFiltered Data Member

Stores filtered list of choices (line of text and image)

CXTPSyntaxEditACDataArray m_arrACDataFiltered;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_arrGrid Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_arrGrid Data Member

Stores list of rectangle areas where were displayed textimage strings from m_arrACData

CXTPSyntaxEditACGrid m_arrGrid;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_bActive Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_bActive Data Member

Active flag

BOOL m_bActive;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_bFilteredMode Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_bFilteredMode Data Member

Flag to identify is current mode (filtered/full);

BOOL m_bFilteredMode;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_bFixedBottom Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_bFixedBottom Data Member

Store autocomplete window position: above or below at the cursor.

BOOL m_bFixedBottom;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_bHighLight Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_bHighLight Data Member

This flag determines if selected string is highlighted.

BOOL m_bHighLight;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_clrHighLight Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_clrHighLight Data Member

Standard window highlight color

COLORREF m_clrHighLight;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_clrHighLightText Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_clrHighLightText Data Member

Standard windows highlight text color

COLORREF m_clrHighLightText;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_clrWindow Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_clrWindow Data Member

Standard window color

COLORREF m_clrWindow;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_clrWindowText Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_clrWindowText Data Member

Standard windows text color

COLORREF m_clrWindowText;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_fontBasic Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_fontBasic Data Member

Font to display text

CFont m_fontBasic;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_ilACGlyphs Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_ilACGlyphs Data Member

Images for AutoComplete list

CImageList m_ilACGlyphs;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nBordersHeight Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nBordersHeight Data Member

Stores summary thickness of vertical window borders

int m_nBordersHeight;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nEndReplacePos Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nEndReplacePos Data Member

Position of last char in the Edit Control which will be replaced by the chosen text

int m_nEndReplacePos;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nFirstDisplayedStr Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nFirstDisplayedStr Data Member

Current first visible (upper) line

int m_nFirstDisplayedStr;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nHighLightLine Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nHighLightLine Data Member

Current highlight line identifier

int m_nHighLightLine;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nLineHeight Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nLineHeight Data Member

Stores height of line

int m_nLineHeight;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nLines Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nLines Data Member

Number of visible lines

int m_nLines;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nStartReplacePos Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nStartReplacePos Data Member

Position of first char in the Edit Control which will be replaced by the chosen text

int m_nStartReplacePos;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nWndHeight Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nWndHeight Data Member

Height of window

int m_nWndHeight;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_nWndWidth Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_nWndWidth Data Member

Width of window

int m_nWndWidth;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_pParentWnd Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_pParentWnd Data Member

Pointer to the parent window

CXTPSyntaxEditCtrl* m_pParentWnd;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_strCloseTags Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_strCloseTags Data Member

Stores set of closed tags divided by ~ input closed tags lead to close AutoComplete window

CString m_strCloseTags;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_strDelims Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_strDelims Data Member

stores char list that are tag delimiters

CString m_strDelims;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_strOpenTags Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_strOpenTags Data Member

Stores open tags

CString m_strOpenTags;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_strSearch Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_strSearch Data Member

Temporary stores chain of chars from user input to perform incremental search

CString m_strSearch;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_strTmpCloseTag Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_strTmpCloseTag Data Member

Temporary stores chain of chars from user input to recognize close tags

CString m_strTmpCloseTag;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd::m_strTmpOpenTag Data Member

CXTPSyntaxEditAutoCompleteWnd Data Members, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::m_strTmpOpenTag Data Member

Temporary stores chain of chars from user input to recognize Open tags

CString m_strTmpOpenTag;
Group

CXTPSyntaxEditAutoCompleteWnd Data Members


CXTPSyntaxEditAutoCompleteWnd Methods

CXTPSyntaxEditAutoCompleteWnd Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd Methods
Class

CXTPSyntaxEditAutoCompleteWnd Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
HitTest | Returns text line where user click mouse.
Public Methods
Public Methods
Public Method | Description
Create | Creates AutoComplete window and sets predefined properties.
GetWndWidth | This member function is used to obtain width of the auto-complete window.
Hide | Hides AutoComplete window.
IsActive | Returns active flag for AutoComplete window.
IsCloseTag | Determines if user input is Close tag.
IsOpenTag | Determines if user input is open tag.
RefreshMetrics | Updates display settings from system settings.
RegisterWindowClass | This member function registers the window class if it has not already been registered.
SetCloseTags | Sets list of close tags for AutoComplete window.
SetList | Sets list of data to be displayed in AutoComplete window.
SetOpenTags | Sets list of open tags for AutoComplete window.
SetWndWidth | This member function is used to set width of the auto-complete window.
Show | Shows AutoComplete window.


CXTPSyntaxEditAutoCompleteWnd::Create Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::Create Method

Creates AutoComplete window and sets predefined properties.

virtual BOOL Create(
    CWnd* pParentWnd
);
Parameters

pParentWnd
[in] Pointer to the parent window.

Returns

TRUE if success; FALSE otherwise.

Remarks

Before create Auto-complete window you should construct CXTPSyntaxEditAutoCompleteWnd object by calling constrictor.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::GetWndWidth Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::GetWndWidth Method

This member function is used to obtain width of the auto-complete window.

int GetWndWidth() const;
Returns

A window width in pixels.

Body Source
int CXTPSyntaxEditAutoCompleteWnd::GetWndWidth() const {
    return m_nWndWidth;
}
Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::Hide Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::Hide Method

Hides AutoComplete window.

virtual void Hide();
Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::HitTest Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::HitTest Method

Returns text line where user click mouse.

int HitTest(
    CPoint ptTest
);
Parameters

ptTest
[in] tested point.

Returns

Integer identifier of affected text line.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::IsActive Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::IsActive Method

Returns active flag for AutoComplete window.

BOOL IsActive();
Returns

TRUE if window is visible and active; FALSE otherwise.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::IsCloseTag Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::IsCloseTag Method

Determines if user input is Close tag.

BOOL IsCloseTag(
    CString strToTest
);
Parameters

strToTest
[in] String to test.

Returns

TRUE if close tag detected; FALSE otherwise.

Remarks

Call this function to determine if user enters close tag. Function uses incremental search and temporary stores input that resembles initial part of close tags that consist of number of symbols.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::IsOpenTag Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::IsOpenTag Method

Determines if user input is open tag.

BOOL IsOpenTag(
    CString strToTest
);
Parameters

strToTest
[in] string to test.

Returns

TRUE if open tag detected; FALSE otherwise.

Remarks

Call this function to determine if user enters open tag. Function uses incremental search and temporary stores input that resembles initial part of open tags that consist of number of symbols.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::RefreshMetrics Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::RefreshMetrics Method

Updates display settings from system settings.

virtual void RefreshMetrics();
Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::RegisterWindowClass Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::RegisterWindowClass Method

This member function registers the window class if it has not already been registered.

virtual BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

A boolean value that specifies if the window is successfully registered.

TRUE if the window class is successfully registered.

Otherwise FALSE.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::SetCloseTags Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::SetCloseTags Method

Sets list of close tags for AutoComplete window.

virtual void SetCloseTags(
    CString strCloseTags
);
Parameters

strCloseTags
[in] string with new close tags.

Remarks

Close Tags are treated by AutoComplete window as command to be hidden and deactivated. Each tag may consists of one or more symbols. Tags must be separated by "~" sign. If AutoComplete window has already had a list of tags it will be replaced by new one.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::SetList Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::SetList Method

Sets list of data to be displayed in AutoComplete window.

virtual void SetList(
    CXTPSyntaxEditACDataArray& parrData
);
Parameters

parrData
[in] reference to array of data.

Remarks

AutoComplete window displays list of data for user choice.If AutoComplete window has already had a list of displayed data it will be replaced by new one. Before add to the AutoComplete window new data is sorted.

See Also

CXTPSyntaxEditACDataArray

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::SetOpenTags Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::SetOpenTags Method

Sets list of open tags for AutoComplete window.

virtual void SetOpenTags(
    CString strOpenTags
);
Parameters

strOpenTags
[in] string with new open tags.

Remarks

Open Tags are treated by AutoComplete window as command to be displayed and activated. Each tag may consists of one or more symbols. Tags must be separated by "~" sign. If AutoComplete window has already had a list of tags it will be replaced by new one.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::SetWndWidth Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::SetWndWidth Method

This member function is used to set width of the auto-complete window.

void SetWndWidth(
    int nWidth
);
Parameters

nWidth
A window width in pixels.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd::Show Method

CXTPSyntaxEditAutoCompleteWnd Methods, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::Show Method

Shows AutoComplete window.

virtual void Show(
    CPoint pt,
    CString strSearch = _T("")
);
Parameters

pt
[in] Point where left upper corner of AutoComplete window should appears.
strSearch
[in] Search string.

Remarks

Shows AutoComplete window at specified point and try to filter dataset by previously typed piece of word and highlighted line according search string.

Group

CXTPSyntaxEditAutoCompleteWnd Methods


CXTPSyntaxEditAutoCompleteWnd Constructors

CXTPSyntaxEditAutoCompleteWnd Class, Legend, Public Methods
CXTPSyntaxEditAutoCompleteWnd Constructors
Class

CXTPSyntaxEditAutoCompleteWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditAutoCompleteWnd | Default class constructor.


CXTPSyntaxEditAutoCompleteWnd::CXTPSyntaxEditAutoCompleteWnd Constructor

CXTPSyntaxEditAutoCompleteWnd Constructors, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::CXTPSyntaxEditAutoCompleteWnd Constructor

Default class constructor.

CXTPSyntaxEditAutoCompleteWnd();
Group

CXTPSyntaxEditAutoCompleteWnd Constructors


CXTPSyntaxEditAutoCompleteWnd Destructors

CXTPSyntaxEditAutoCompleteWnd Class, Legend, Public Methods
CXTPSyntaxEditAutoCompleteWnd Destructors
Class

CXTPSyntaxEditAutoCompleteWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditAutoCompleteWnd | Destroys a CXTPSyntaxEditAutoCompleteWnd object, handles cleanup and de-allocation.


CXTPSyntaxEditAutoCompleteWnd::~CXTPSyntaxEditAutoCompleteWnd Destructor

CXTPSyntaxEditAutoCompleteWnd Destructors, CXTPSyntaxEditAutoCompleteWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditAutoCompleteWnd::~CXTPSyntaxEditAutoCompleteWnd Destructor

Destroys a CXTPSyntaxEditAutoCompleteWnd object, handles cleanup and de-allocation.

virtual ~CXTPSyntaxEditAutoCompleteWnd();
Group

CXTPSyntaxEditAutoCompleteWnd Destructors


CXTPSyntaxEditBatchCommand Class

XTPSyntaxEditUndoManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditBatchCommand Data Members, CXTPSyntaxEditBatchCommand Methods, CXTPSyntaxEditBatchCommand Destructors, CXTPSyntaxEditBatchCommand Data Members, CXTPSyntaxEditBatchCommand Destructors, CXTPSyntaxEditBatchCommand Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand Class

This class represents a pack of some commands in one. It stores commands in the list, and implements standard command execution interfaces on command (un)execution.

Class Hierarchy

class CXTPSyntaxEditBatchCommand : public CXTPSyntaxEditCommand;
File

XTPSyntaxEditUndoManager.h

See Also

CXTPSyntaxEditCommand

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditBatchCommand Data Members
CXTPSyntaxEditBatchCommand Data Members | Description
m_CommandList | Commands buffer storage.
CXTPSyntaxEditBatchCommand Destructors
CXTPSyntaxEditBatchCommand Destructors | Description
~CXTPSyntaxEditBatchCommand | A default command destructor. Destroys the command object with all sub-commands, handles its cleanup and de-allocation.
CXTPSyntaxEditBatchCommand Methods
CXTPSyntaxEditBatchCommand Methods | Description
AddCommand | Adds a command to the batch buffer.
Clear | Clears batch command buffer and delete all commands.
Execute | Executes batch command by successive execution of all stored commands.
GetCommandsCount | Calculates a number of single command items inside the batch command buffer.
GetDataSize | This member function used to get undo command data size (in bytes).
UnExecute | Unexecutes batch command by successive undoing of all stored commands.


CXTPSyntaxEditBatchCommand Data Members

CXTPSyntaxEditBatchCommand Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand Data Members
Class

CXTPSyntaxEditBatchCommand Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_CommandList | Commands buffer storage.


CXTPSyntaxEditBatchCommand::m_CommandList Data Member

CXTPSyntaxEditBatchCommand Data Members, CXTPSyntaxEditBatchCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand::m_CommandList Data Member

Commands buffer storage.

CPtrList m_CommandList;
Group

CXTPSyntaxEditBatchCommand Data Members


CXTPSyntaxEditBatchCommand Methods

CXTPSyntaxEditBatchCommand Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand Methods
Class

CXTPSyntaxEditBatchCommand Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
Clear | Clears batch command buffer and delete all commands.
Public Methods
Public Methods
Public Method | Description
AddCommand | Adds a command to the batch buffer.
Execute | Executes batch command by successive execution of all stored commands.
GetCommandsCount | Calculates a number of single command items inside the batch command buffer.
GetDataSize | This member function used to get undo command data size (in bytes).
UnExecute | Unexecutes batch command by successive undoing of all stored commands.


CXTPSyntaxEditBatchCommand::AddCommand Method

CXTPSyntaxEditBatchCommand Methods, CXTPSyntaxEditBatchCommand Class, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand::AddCommand Method

Adds a command to the batch buffer.

POSITION AddCommand(
    CXTPSyntaxEditCommand* pCommand
);
Parameters

pCommand
[in] A pointer to the newly added command.

Returns

A position of the newly added command inside the internal list.

Example

pBatchCmd->AddCommand(new CXTPSyntaxEditDeleteStringCommand(...));

Group

CXTPSyntaxEditBatchCommand Methods


CXTPSyntaxEditBatchCommand::Clear Method

CXTPSyntaxEditBatchCommand Methods, CXTPSyntaxEditBatchCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand::Clear Method

Clears batch command buffer and delete all commands.

void Clear();
Group

CXTPSyntaxEditBatchCommand Methods


CXTPSyntaxEditBatchCommand::Execute Method

CXTPSyntaxEditBatchCommand Methods, CXTPSyntaxEditBatchCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand::Execute Method

Executes batch command by successive execution of all stored commands.

virtual int Execute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the actions chain.
lcTo
[out] End text position affected by the actions chain.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

UnExecute

Group

CXTPSyntaxEditBatchCommand Methods


CXTPSyntaxEditBatchCommand::GetCommandsCount Method

CXTPSyntaxEditBatchCommand Methods, CXTPSyntaxEditBatchCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand::GetCommandsCount Method

Calculates a number of single command items inside the batch command buffer.

int GetCommandsCount();
Returns

A number of single command items inside the batch command buffer.

Group

CXTPSyntaxEditBatchCommand Methods


CXTPSyntaxEditBatchCommand::GetDataSize Method

CXTPSyntaxEditBatchCommand Methods, CXTPSyntaxEditBatchCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand::GetDataSize Method

This member function used to get undo command data size (in bytes).

virtual int GetDataSize();
Returns

Undo command data size (in bytes).

Group

CXTPSyntaxEditBatchCommand Methods


CXTPSyntaxEditBatchCommand::UnExecute Method

CXTPSyntaxEditBatchCommand Methods, CXTPSyntaxEditBatchCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand::UnExecute Method

Unexecutes batch command by successive undoing of all stored commands.

virtual int UnExecute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the actions chain.
lcTo
[out] End text position affected by the actions chain.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

Execute

Group

CXTPSyntaxEditBatchCommand Methods


CXTPSyntaxEditBatchCommand Destructors

CXTPSyntaxEditBatchCommand Class, Legend, Public Methods
CXTPSyntaxEditBatchCommand Destructors
Class

CXTPSyntaxEditBatchCommand Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditBatchCommand | A default command destructor. Destroys the command object with all sub-commands, handles its cleanup and de-allocation.


CXTPSyntaxEditBatchCommand::~CXTPSyntaxEditBatchCommand Destructor

CXTPSyntaxEditBatchCommand Destructors, CXTPSyntaxEditBatchCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBatchCommand::~CXTPSyntaxEditBatchCommand Destructor

A default command destructor. Destroys the command object with all sub-commands, handles its cleanup and de-allocation.

~CXTPSyntaxEditBatchCommand();
Group

CXTPSyntaxEditBatchCommand Destructors


CXTPSyntaxEditBufferCommand Class

XTPSyntaxEditUndoManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditBufferCommand Classes, CXTPSyntaxEditBufferCommand Data Members, CXTPSyntaxEditBufferCommand Methods, CXTPSyntaxEditBufferCommand Constructors, CXTPSyntaxEditBufferCommand Destructors, CXTPSyntaxEditBufferCommand Classes, CXTPSyntaxEditBufferCommand Constructors, CXTPSyntaxEditBufferCommand Data Members, CXTPSyntaxEditBufferCommand Destructors, CXTPSyntaxEditBufferCommand Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand Class

The base class for all edit commands related to CXTPSyntaxEditBufferManager. It stores handle of the buffer manager, and provides implementation of common buffer operations, such as text insertion or deletion.

Class Hierarchy

class CXTPSyntaxEditBufferCommand : public CXTPSyntaxEditCommand;
File

XTPSyntaxEditUndoManager.h

See Also

CXTPSyntaxEditCommand, CXTPSyntaxEditInsertStringCommand, CXTPSyntaxEditDeleteStringCommand

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditBufferCommand Classes
CXTPSyntaxEditBufferCommand Classes | Description
CXTPSyntaxEditBufferKeepOverwriteSettings | Keeps buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime.
CXTPSyntaxEditBufferCommand Constructors
CXTPSyntaxEditBufferCommand Constructors | Description
CXTPSyntaxEditBufferCommand | Creates the buffer command object, initializes its members.
CXTPSyntaxEditBufferCommand Data Members
CXTPSyntaxEditBufferCommand Data Members | Description
m_lcFrom | Start edit position.
m_lcTo | End edit position.
m_pBufferMgr | Pointer to the associated text buffer.
m_strText | Stored changed text.
CXTPSyntaxEditBufferCommand Destructors
CXTPSyntaxEditBufferCommand Destructors | Description
~CXTPSyntaxEditBufferCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.
CXTPSyntaxEditBufferCommand Methods
CXTPSyntaxEditBufferCommand Methods | Description
DoDeleteText | Deletes text at the stored positions, and returns start and final affected text positions.
DoInsertText | Inserts stored text at the stored positions, and returns start and final affected text positions.
GetDataSize | This member function used to get undo command data size (in bytes).


CXTPSyntaxEditBufferCommand Classes

Classes, CXTPSyntaxEditBufferCommand Class
CXTPSyntaxEditBufferCommand Classes
Classes
Class | Description
CXTPSyntaxEditBufferKeepOverwriteSettings | Keeps buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime.
Class

CXTPSyntaxEditBufferCommand Class


CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class

XTPSyntaxEditUndoManager.h, CXTPSyntaxEditBufferCommand Classes, Legend, Members, Topics, CXTPSyntaxEditBufferKeepOverwriteSettings Constructors, CXTPSyntaxEditBufferKeepOverwriteSettings Destructors, CXTPSyntaxEditBufferKeepOverwriteSettings Constructors, CXTPSyntaxEditBufferKeepOverwriteSettings Destructors, Example
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class

Keeps buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime.

Class Hierarchy

class CXTPSyntaxEditBufferKeepOverwriteSettings;
File

XTPSyntaxEditUndoManager.h

Example

void DoSomething() { CXTPSyntaxEditBufferKeepOverwriteSettings bufOwr(m_pBufferMgr); ...

Group

CXTPSyntaxEditBufferCommand Classes

Legend
Constructor
virtual
CXTPSyntaxEditBufferKeepOverwriteSettings Constructors
CXTPSyntaxEditBufferKeepOverwriteSettings Constructors | Description
CXTPSyntaxEditBufferKeepOverwriteSettings | Creates the object and stores buffer overwrite settings.
CXTPSyntaxEditBufferKeepOverwriteSettings Destructors
CXTPSyntaxEditBufferKeepOverwriteSettings Destructors | Description
~CXTPSyntaxEditBufferKeepOverwriteSettings | Destroys the object and restore buffer overwrite settings.


CXTPSyntaxEditBufferKeepOverwriteSettings Constructors

CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferKeepOverwriteSettings Constructors
Class

CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditBufferKeepOverwriteSettings | Creates the object and stores buffer overwrite settings.


CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings::CXTPSyntaxEditBufferKeepOverwriteSettings Constructor

CXTPSyntaxEditBufferKeepOverwriteSettings Constructors, CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings::CXTPSyntaxEditBufferKeepOverwriteSettings Constructor

Creates the object and stores buffer overwrite settings.

CXTPSyntaxEditBufferKeepOverwriteSettings(
    CXTPSyntaxEditBufferManager* pBufferMgr
);
Parameters

pBufferMgr
[in] Pointer to the associated buffer manager object.

Group

CXTPSyntaxEditBufferKeepOverwriteSettings Constructors


CXTPSyntaxEditBufferKeepOverwriteSettings Destructors

CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferKeepOverwriteSettings Destructors
Class

CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditBufferKeepOverwriteSettings | Destroys the object and restore buffer overwrite settings.


CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings::~CXTPSyntaxEditBufferKeepOverwriteSettings Destructor

CXTPSyntaxEditBufferKeepOverwriteSettings Destructors, CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings::~CXTPSyntaxEditBufferKeepOverwriteSettings Destructor

Destroys the object and restore buffer overwrite settings.

virtual ~CXTPSyntaxEditBufferKeepOverwriteSettings();
Group

CXTPSyntaxEditBufferKeepOverwriteSettings Destructors


CXTPSyntaxEditBufferCommand Data Members

CXTPSyntaxEditBufferCommand Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand Data Members
Class

CXTPSyntaxEditBufferCommand Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_lcFrom | Start edit position.
m_lcTo | End edit position.
m_pBufferMgr | Pointer to the associated text buffer.
m_strText | Stored changed text.


CXTPSyntaxEditBufferCommand::m_lcFrom Data Member

CXTPSyntaxEditBufferCommand Data Members, CXTPSyntaxEditBufferCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::m_lcFrom Data Member

Start edit position.

XTP_EDIT_LINECOL m_lcFrom;
Group

CXTPSyntaxEditBufferCommand Data Members


CXTPSyntaxEditBufferCommand::m_lcTo Data Member

CXTPSyntaxEditBufferCommand Data Members, CXTPSyntaxEditBufferCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::m_lcTo Data Member

End edit position.

XTP_EDIT_LINECOL m_lcTo;
Group

CXTPSyntaxEditBufferCommand Data Members


CXTPSyntaxEditBufferCommand::m_pBufferMgr Data Member

CXTPSyntaxEditBufferCommand Data Members, CXTPSyntaxEditBufferCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::m_pBufferMgr Data Member

Pointer to the associated text buffer.

CXTPSyntaxEditBufferManager* m_pBufferMgr;
Group

CXTPSyntaxEditBufferCommand Data Members


CXTPSyntaxEditBufferCommand::m_strText Data Member

CXTPSyntaxEditBufferCommand Data Members, CXTPSyntaxEditBufferCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::m_strText Data Member

Stored changed text.

CString m_strText;
Group

CXTPSyntaxEditBufferCommand Data Members


CXTPSyntaxEditBufferCommand Methods

CXTPSyntaxEditBufferCommand Class, Legend, Protected Methods
CXTPSyntaxEditBufferCommand Methods
Class

CXTPSyntaxEditBufferCommand Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DoDeleteText | Deletes text at the stored positions, and returns start and final affected text positions.
DoInsertText | Inserts stored text at the stored positions, and returns start and final affected text positions.
GetDataSize | This member function used to get undo command data size (in bytes).


CXTPSyntaxEditBufferCommand::DoDeleteText Method

CXTPSyntaxEditBufferCommand Methods, CXTPSyntaxEditBufferCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::DoDeleteText Method

Deletes text at the stored positions, and returns start and final affected text positions.

int DoDeleteText(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

DoInsertText

Group

CXTPSyntaxEditBufferCommand Methods


CXTPSyntaxEditBufferCommand::DoInsertText Method

CXTPSyntaxEditBufferCommand Methods, CXTPSyntaxEditBufferCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::DoInsertText Method

Inserts stored text at the stored positions, and returns start and final affected text positions.

int DoInsertText(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

DoDeleteText

Group

CXTPSyntaxEditBufferCommand Methods


CXTPSyntaxEditBufferCommand::GetDataSize Method

CXTPSyntaxEditBufferCommand Methods, CXTPSyntaxEditBufferCommand Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::GetDataSize Method

This member function used to get undo command data size (in bytes).

virtual int GetDataSize();
Returns

Undo command data size (in bytes).

Body Source
int CXTPSyntaxEditBufferCommand::GetDataSize() {
    return m_strText.GetLength() * sizeof(TCHAR);
}
Group

CXTPSyntaxEditBufferCommand Methods


CXTPSyntaxEditBufferCommand Constructors

CXTPSyntaxEditBufferCommand Class, Legend, Protected Methods
CXTPSyntaxEditBufferCommand Constructors
Class

CXTPSyntaxEditBufferCommand Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSyntaxEditBufferCommand | Creates the buffer command object, initializes its members.


CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferCommand Constructor

CXTPSyntaxEditBufferCommand Constructors, CXTPSyntaxEditBufferCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferCommand Constructor

Creates the buffer command object, initializes its members.

CXTPSyntaxEditBufferCommand(
    CXTPSyntaxEditBufferManager* pMgr,
    LPCTSTR szText,
    const XTP_EDIT_LINECOL& lcFrom,
    const XTP_EDIT_LINECOL& lcTo
);
Parameters

pMgr
[in] Pointer to the associated buffer manager object.
szText
[in] A text which was changed during buffer operation. It will be used for insert/remove text operations.
lcFrom
[in] Start text position affected by the command.
lcTo
[in] End text position affected by the command.

Group

CXTPSyntaxEditBufferCommand Constructors


CXTPSyntaxEditBufferCommand Destructors

CXTPSyntaxEditBufferCommand Class, Legend, Public Methods
CXTPSyntaxEditBufferCommand Destructors
Class

CXTPSyntaxEditBufferCommand Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditBufferCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.


CXTPSyntaxEditBufferCommand::~CXTPSyntaxEditBufferCommand Destructor

CXTPSyntaxEditBufferCommand Destructors, CXTPSyntaxEditBufferCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferCommand::~CXTPSyntaxEditBufferCommand Destructor

A default command destructor. Destroys the command object, handles its cleanup and de-allocation.

virtual ~CXTPSyntaxEditBufferCommand();
Group

CXTPSyntaxEditBufferCommand Destructors


CXTPSyntaxEditBufferManager Class

XTPSyntaxEditBufferManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditBufferManager Classes, CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Constructors, CXTPSyntaxEditBufferManager Destructors, CXTPSyntaxEditBufferManager Classes, CXTPSyntaxEditBufferManager Constructors, CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Destructors, CXTPSyntaxEditBufferManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager Class

This class is the main class for buffer management. One instance of this class is attached with a CXTPSyntaxEditCtrl object. This class contains a list of CBufferIndex class which in turn contains a position in the file (In case of un-modified index) or a CEditBuffer pointer.

Class Hierarchy

class CXTPSyntaxEditBufferManager;
File

XTPSyntaxEditBufferManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditBufferManager Classes
CXTPSyntaxEditBufferManager Classes | Description
CXTPSyntaxEditStringsManager | This is helper class designed to manage a set of strings
CXTPSyntaxEditBufferManager Constructors
CXTPSyntaxEditBufferManager Constructors | Description
CXTPSyntaxEditBufferManager | Default object constructor.
CXTPSyntaxEditBufferManager Data Members
CXTPSyntaxEditBufferManager Data Members | Description
m_bIsParserEnabled | Stores flag of parser state (enabled/disabled)
m_bOverwrite | Overwrite mode status
m_bUnicodeFileFormat | Determine is file format Unicode or ASCII.
m_iCRLFStyle | CRLF style 0 - DOS, 1 - UNIX, 2 - MAC
m_nAverageLineLen | Stores average line length.
m_nCodePage | CodePage for text conversion
m_nTabSize | Tab size
m_pConnect | Connection object to send notifications.
m_pLexParser | Lexical parser
m_pLineMarksManager | line marks manager
m_ptrLexConfigurationManager | Pointer to the Lexical configuration manager
m_pUndoRedoManager | Undo / redo manager.
m_strFileExt | Stores file extension
m_Strings | A strings manager helper object
s_dwLexConfigurationManager_DefaultRefs | The reference count for common default Configuration Manager instance.
s_ptrLexConfigurationManager_Default | The common default Configuration Manager instance.
CXTPSyntaxEditBufferManager Destructors
CXTPSyntaxEditBufferManager Destructors | Description
~CXTPSyntaxEditBufferManager | Destroys a CXTPSyntaxEditBufferManager object, handles cleanup and de-allocation.
CXTPSyntaxEditBufferManager Methods
CXTPSyntaxEditBufferManager Methods | Description
CalcAveDataSize | Returns average data size.
CalcMaxLineTextLength | Returns a length for line of text either from file or buffer.
ChangeCase | Changes the case of the specified characters range in the specified row.
ChangeTabification | Changes the case of the specified characters range in the specified row.
CleanUp | Cleans up the buffer and all other allocated memories
Close | Cleans up all internal objects.
ColToStrPos | Converts column coordinates of text to string position coordinate.
DeleteText | Deletes a certain range of text
EnableParser | Enable or disable parser.
GetBuffer | Retrieve text from the buffer bounded between row1/col1 and row2/col2 (or lcStart and lcEnd) text coordinates.
GetCodePage | Determines if the file has been modified or not.
GetConfigFile | Get main configuration file name.
GetConnection | Returns events connection pointer.
GetCurCRLF | Returns the CRLF of the current document.
GetCurCRLFType | Returns the CRLF type of the current document.
GetFileExt | Returns file extension.
GetLexConfigurationManager | Returns pointer to the associated configuration manager.
GetLexParser | Returns pointer to the associated lexical parser.
GetLineMarksManager | Returns pointer to the associated line marks manager.
GetLineText |
GetLineTextLength | Returns a length for line of text in TCHARs.
GetLineTextLengthC | Returns a length for line of text in characters.
GetMasterTextSchema | Set the path to the main configuration file.
GetMaxLineTextLength | Returns the max allowable length for line of text.
GetOverwriteFlag | Returns the overwrite flag status.
GetRowCount | Returns the number of rows in the document.
GetTabSize | Returns the tab size for the current document.
GetUndoRedoManager | Returns pointer to the associated Undo/Redo manager.
InsertText | Inserts a text or text block.
InsertTextBlock | Inserts a text or text block.
IsModified | Determines if the file has been modified or not.
IsParserEnabled | Returns the parser status.
IsTextCRLF |
Load | Set the file pointer for the buffer.
RemoveLine | Deletes a certain range of text
Serialize | Serializes actual data.
SerializeEx | Serializes actual data.
SetConfigFile | Set the path to the main configuration file.
SetCRLFStyle | Set the current documents CRLF style.
SetFileExt | Sets file extension.
SetLexConfigurationManager | Set pointer to the configuration manager.
SetOverwriteFlag | Sets or resets the OVR flag.
SetTabSize | Set the tab size between 1-64.
StrPosToCol | Converts string position of text to column coordinates coordinate.


CXTPSyntaxEditBufferManager Classes

Classes, CXTPSyntaxEditBufferManager Class
CXTPSyntaxEditBufferManager Classes
Classes
Class | Description
CXTPSyntaxEditStringsManager | This is helper class designed to manage a set of strings
Class

CXTPSyntaxEditBufferManager Class


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class

XTPSyntaxEditBufferManager.h, CXTPSyntaxEditBufferManager Classes, Legend, Members, Topics, CXTPSyntaxEditStringsManager Classes, CXTPSyntaxEditStringsManager Data Members, CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditStringsManager Constructors, CXTPSyntaxEditStringsManager Destructors, CXTPSyntaxEditStringsManager Classes, CXTPSyntaxEditStringsManager Constructors, CXTPSyntaxEditStringsManager Data Members, CXTPSyntaxEditStringsManager Destructors, CXTPSyntaxEditStringsManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class

This is helper class designed to manage a set of strings

Class Hierarchy

class CXTPSyntaxEditStringsManager;
File

XTPSyntaxEditBufferManager.h

Group

CXTPSyntaxEditBufferManager Classes

Legend
Data Member
Method
virtual
CXTPSyntaxEditStringsManager Classes
CXTPSyntaxEditStringsManager Classes | Description
CStringPtrArray | Internal class, implement collection of strings.
CXTPSyntaxEditStringsManager Constructors
CXTPSyntaxEditStringsManager Constructors | Description
CXTPSyntaxEditStringsManager | Default object constructor.
CXTPSyntaxEditStringsManager Data Members
CXTPSyntaxEditStringsManager Data Members | Description
m_arStrings | String collection
CXTPSyntaxEditStringsManager Destructors
CXTPSyntaxEditStringsManager Destructors | Description
~CXTPSyntaxEditStringsManager | Default object destructor. Handles cleanup and deallocation
CXTPSyntaxEditStringsManager Methods
CXTPSyntaxEditStringsManager Methods | Description
DeleteText | Deletes text.
GetCount | Returns count of managed strings
GetStr | Returns string by given index.
GetStrData | Gets string by given index.
GetStrDataC | Gets string by given index.
GetStrLen | Returns length of string in TCHARs.
GetStrLenC | Returns length of string in characters.
InsertStr | Add string.
InsertText | Inserts text.
RemoveAllStrs | Removes all strings from collection.
RemoveStr | Removes string.
SetAtGrowStr |


CXTPSyntaxEditStringsManager Classes

Classes, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditStringsManager Classes
Classes
Class | Description
CStringPtrArray | Internal class, implement collection of strings.
Class

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class

XTPSyntaxEditBufferManager.h, CXTPSyntaxEditStringsManager Classes, Legend, Members, Topics, CStringPtrArray Methods, CStringPtrArray Constructors, CStringPtrArray Destructors, CStringPtrArray Constructors, CStringPtrArray Destructors, CStringPtrArray Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class

Internal class, implement collection of strings.

Class Hierarchy

class CStringPtrArray : public CArray<CString*, CString*>;
File

XTPSyntaxEditBufferManager.h

Group

CXTPSyntaxEditStringsManager Classes

Legend
Method
virtual
CStringPtrArray Constructors
CStringPtrArray Constructors | Description
CStringPtrArray | Default object constructor.
CStringPtrArray Destructors
CStringPtrArray Destructors | Description
~CStringPtrArray | Default object destructor. Handles cleanup and deallocation
CStringPtrArray Methods
CStringPtrArray Methods | Description
RemoveAll | This method used to delete all strings objects and remove them from array.


CStringPtrArray Methods

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CStringPtrArray Methods
Class

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
RemoveAll | This method used to delete all strings objects and remove them from array.


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::RemoveAll Method

CStringPtrArray Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::RemoveAll Method

This method used to delete all strings objects and remove them from array.

void RemoveAll();
Group

CStringPtrArray Methods


CStringPtrArray Constructors

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CStringPtrArray Constructors
Class

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CStringPtrArray | Default object constructor.


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::CStringPtrArray Constructor

CStringPtrArray Constructors, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::CStringPtrArray Constructor

Default object constructor.

CStringPtrArray();
Group

CStringPtrArray Constructors


CStringPtrArray Destructors

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CStringPtrArray Destructors
Class

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CStringPtrArray | Default object destructor. Handles cleanup and deallocation


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::~CStringPtrArray Destructor

CStringPtrArray Destructors, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::~CStringPtrArray Destructor

Default object destructor. Handles cleanup and deallocation

virtual ~CStringPtrArray();
Group

CStringPtrArray Destructors


CXTPSyntaxEditStringsManager Data Members

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditStringsManager Data Members
Class

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_arStrings | String collection


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::m_arStrings Data Member

CXTPSyntaxEditStringsManager Data Members, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::m_arStrings Data Member

String collection

CStringPtrArray m_arStrings;
Group

CXTPSyntaxEditStringsManager Data Members


CXTPSyntaxEditStringsManager Methods

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditStringsManager Methods
Class

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
DeleteText | Deletes text.
GetCount | Returns count of managed strings
GetStr | Returns string by given index.
GetStrData | Gets string by given index.
GetStrDataC | Gets string by given index.
GetStrLen | Returns length of string in TCHARs.
GetStrLenC | Returns length of string in characters.
InsertStr | Add string.
InsertText | Inserts text.
RemoveAllStrs | Removes all strings from collection.
RemoveStr | Removes string.
SetAtGrowStr |


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::DeleteText Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::DeleteText Method

Deletes text.

BOOL DeleteText(
    int nRow,
    int nPos,
    int nCount
);
Parameters

nRow
[in] String identifier.
nPos
[in] Start position in the string.
nCount
[in] Chars count to remove;

Returns

TRUE if text successfully deleted, FALSE otherwise.

See Also

InsertText

Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetCount Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetCount Method

Returns count of managed strings

int GetCount() const;
Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStr Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStr Method

Returns string by given index.

CString GetStr(
    int nRow
) const;
Parameters

nRow
[in] String identifier.

Returns

CString object.

Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrData Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrData Method

Gets string by given index.

CString* GetStrData(
    int nRow,
    BOOL bGrowArrayIfNeed = TRUE
);
Parameters

nRow
[in] id of string.
bGrowArrayIfNeed
[in] Flag to grow array of strings.Default is TRUE

Returns

CString pointer.

Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrDataC Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrDataC Method

Gets string by given index.

CString* GetStrDataC(
    int nRow
) const;
Parameters

nRow
[in] id of string.

Returns

CString pointer.

Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrLen Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrLen Method

Returns length of string in TCHARs.

int GetStrLen(
    int nRow
) const;
Parameters

nRow
[in] String identifier.

Returns

Integer value of length of string.

Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrLenC Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrLenC Method

Returns length of string in characters.

int GetStrLenC(
    int nRow
) const;
Parameters

nRow
[in] String identifier.

Returns

Integer value of length of string in characters.

Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::InsertStr Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::InsertStr Method

Add string.

void InsertStr(
    int nRow,
    const CString& strText
);
Parameters

nRow
[in] String identifier.
strText
[in] Reference to CString object with text to set.

Remarks

If given string id exists in collection function sets string to given id.

See Also

void SetAtGrowStr(int nRow, const CString& strText);

Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::InsertText Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::InsertText Method

Inserts text.

BOOL InsertText(
    int nRow,
    int nPos,
    LPCTSTR pcszText,
    BOOL bGrowArrayIfNeed = FALSE,
    TCHAR chLeftSpaceFiller = _T(' ')
);
Parameters

nRow
[in] String identifier.
nPos
[in] Start position in the string.
pcszText
[in] Text to insert.
bGrowArrayIfNeed
[in] If nRow greater than strings count and this parameter TRUE the strings array will be grown; if this parameter FALSE function will do nothing and return FALSE.
chLeftSpaceFiller
[in] if nPos parameter greater than string length the char specified in this parameter will be added to string until nPos.

Returns

TRUE if text successfully inserted, FALSE otherwise.

See Also

DeleteText

Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::RemoveAllStrs Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::RemoveAllStrs Method

Removes all strings from collection.

void RemoveAllStrs();
Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::RemoveStr Method

CXTPSyntaxEditStringsManager Methods, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::RemoveStr Method

Removes string.

BOOL RemoveStr(
    int nRow
);
Parameters

nRow
[in] String identifier.

Returns

TRUE if success; FALSE if given id doesn't exist.

Group

CXTPSyntaxEditStringsManager Methods


SetAtGrowStr Method

CXTPSyntaxEditStringsManager Methods
SetAtGrowStr Method
Overload List
Methods
Method | Description
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::SetAtGrowStr (int, LPCTSTR) | Sets string at given id.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::SetAtGrowStr (int, const CString&) | Sets string at given id.
Group

CXTPSyntaxEditStringsManager Methods


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::SetAtGrowStr Method (int, LPCTSTR)

SetAtGrowStr Method, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::SetAtGrowStr Method (int, LPCTSTR)

Sets string at given id.

void SetAtGrowStr(
    int nRow,
    LPCTSTR pcszText
);
Parameters

nRow
[in] String identifier.
pcszText
[in] Pointer to null terminated string with text to set.

Remarks

If given string id doesn't exist in collection function does nothing.

See Also

void SetAtGrowStr(int nRow, const CString& strText);

Group

SetAtGrowStr Method


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::SetAtGrowStr Method (int, const CString&)

SetAtGrowStr Method, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::SetAtGrowStr Method (int, const CString&)

Sets string at given id.

void SetAtGrowStr(
    int nRow,
    const CString& strText
);
Parameters

nRow
[in] String identifier.
strText
[in] Reference to CString object with text to set.

Remarks

If given string id doesn't exist in collection function does nothing.

See Also

void SetAtGrowStr(int nRow, LPCTSTR pcszText);

Group

SetAtGrowStr Method


CXTPSyntaxEditStringsManager Constructors

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditStringsManager Constructors
Class

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditStringsManager | Default object constructor.


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CXTPSyntaxEditStringsManager Constructor

CXTPSyntaxEditStringsManager Constructors, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CXTPSyntaxEditStringsManager Constructor

Default object constructor.

CXTPSyntaxEditStringsManager();
Group

CXTPSyntaxEditStringsManager Constructors


CXTPSyntaxEditStringsManager Destructors

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditStringsManager Destructors
Class

CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditStringsManager | Default object destructor. Handles cleanup and deallocation


CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::~CXTPSyntaxEditStringsManager Destructor

CXTPSyntaxEditStringsManager Destructors, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::~CXTPSyntaxEditStringsManager Destructor

Default object destructor. Handles cleanup and deallocation

virtual ~CXTPSyntaxEditStringsManager();
Group

CXTPSyntaxEditStringsManager Destructors


CXTPSyntaxEditBufferManager Data Members

CXTPSyntaxEditBufferManager Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager Data Members
Class

CXTPSyntaxEditBufferManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bIsParserEnabled | Stores flag of parser state (enabled/disabled)
m_bOverwrite | Overwrite mode status
m_bUnicodeFileFormat | Determine is file format Unicode or ASCII.
m_iCRLFStyle | CRLF style 0 - DOS, 1 - UNIX, 2 - MAC
m_nAverageLineLen | Stores average line length.
m_nCodePage | CodePage for text conversion
m_nTabSize | Tab size
m_pConnect | Connection object to send notifications.
m_pLexParser | Lexical parser
m_pLineMarksManager | line marks manager
m_ptrLexConfigurationManager | Pointer to the Lexical configuration manager
m_pUndoRedoManager | Undo / redo manager.
m_strFileExt | Stores file extension
m_Strings | A strings manager helper object
s_dwLexConfigurationManager_DefaultRefs | The reference count for common default Configuration Manager instance.
s_ptrLexConfigurationManager_Default | The common default Configuration Manager instance.


CXTPSyntaxEditBufferManager::m_bIsParserEnabled Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_bIsParserEnabled Data Member

Stores flag of parser state (enabled/disabled)

BOOL m_bIsParserEnabled;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_bOverwrite Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_bOverwrite Data Member

Overwrite mode status

BOOL m_bOverwrite;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_bUnicodeFileFormat Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_bUnicodeFileFormat Data Member

Determine is file format Unicode or ASCII.

BOOL m_bUnicodeFileFormat;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_iCRLFStyle Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_iCRLFStyle Data Member

CRLF style 0 - DOS, 1 - UNIX, 2 - MAC

int m_iCRLFStyle;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_nAverageLineLen Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_nAverageLineLen Data Member

Stores average line length.

int m_nAverageLineLen;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_nCodePage Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_nCodePage Data Member

CodePage for text conversion

UINT m_nCodePage;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_nTabSize Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_nTabSize Data Member

Tab size

int m_nTabSize;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_pConnect Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_pConnect Data Member

Connection object to send notifications.

CXTPNotifyConnection* m_pConnect;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_pLexParser Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_pLexParser Data Member

Lexical parser

CXTPSyntaxEditLexParser* m_pLexParser;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_pLineMarksManager Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_pLineMarksManager Data Member

line marks manager

CXTPSyntaxEditLineMarksManager* m_pLineMarksManager;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_ptrLexConfigurationManager Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_ptrLexConfigurationManager Data Member

Pointer to the Lexical configuration manager

CXTPSyntaxEditConfigurationManagerPtr m_ptrLexConfigurationManager;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_pUndoRedoManager Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_pUndoRedoManager Data Member

Undo / redo manager.

CXTPSyntaxEditUndoRedoManager* m_pUndoRedoManager;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_strFileExt Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_strFileExt Data Member

Stores file extension

CString m_strFileExt;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::m_Strings Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::m_Strings Data Member

A strings manager helper object

CXTPSyntaxEditStringsManager m_Strings;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::s_dwLexConfigurationManager_DefaultRefs Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::s_dwLexConfigurationManager_DefaultRefs Data Member

The reference count for common default Configuration Manager instance.

LONG s_dwLexConfigurationManager_DefaultRefs;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager::s_ptrLexConfigurationManager_Default Data Member

CXTPSyntaxEditBufferManager Data Members, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::s_ptrLexConfigurationManager_Default Data Member

The common default Configuration Manager instance.

CXTPSyntaxEditConfigurationManagerPtr s_ptrLexConfigurationManager_Default;
Group

CXTPSyntaxEditBufferManager Data Members


CXTPSyntaxEditBufferManager Methods

CXTPSyntaxEditBufferManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager Methods
Class

CXTPSyntaxEditBufferManager Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalcAveDataSize | Returns average data size.
CleanUp | Cleans up the buffer and all other allocated memories
Public Methods
Public Methods
Public Method | Description
CalcMaxLineTextLength | Returns a length for line of text either from file or buffer.
ChangeCase | Changes the case of the specified characters range in the specified row.
ChangeTabification | Changes the case of the specified characters range in the specified row.
Close | Cleans up all internal objects.
ColToStrPos | Converts column coordinates of text to string position coordinate.
DeleteText | Deletes a certain range of text
EnableParser | Enable or disable parser.
GetBuffer | Retrieve text from the buffer bounded between row1/col1 and row2/col2 (or lcStart and lcEnd) text coordinates.
GetCodePage | Determines if the file has been modified or not.
GetConfigFile | Get main configuration file name.
GetConnection | Returns events connection pointer.
GetCurCRLF | Returns the CRLF of the current document.
GetCurCRLFType | Returns the CRLF type of the current document.
GetFileExt | Returns file extension.
GetLexConfigurationManager | Returns pointer to the associated configuration manager.
GetLexParser | Returns pointer to the associated lexical parser.
GetLineMarksManager | Returns pointer to the associated line marks manager.
GetLineText |
GetLineTextLength | Returns a length for line of text in TCHARs.
GetLineTextLengthC | Returns a length for line of text in characters.
GetMasterTextSchema | Set the path to the main configuration file.
GetMaxLineTextLength | Returns the max allowable length for line of text.
GetOverwriteFlag | Returns the overwrite flag status.
GetRowCount | Returns the number of rows in the document.
GetTabSize | Returns the tab size for the current document.
GetUndoRedoManager | Returns pointer to the associated Undo/Redo manager.
InsertText | Inserts a text or text block.
InsertTextBlock | Inserts a text or text block.
IsModified | Determines if the file has been modified or not.
IsParserEnabled | Returns the parser status.
IsTextCRLF |
Load | Set the file pointer for the buffer.
RemoveLine | Deletes a certain range of text
Serialize | Serializes actual data.
SerializeEx | Serializes actual data.
SetConfigFile | Set the path to the main configuration file.
SetCRLFStyle | Set the current documents CRLF style.
SetFileExt | Sets file extension.
SetLexConfigurationManager | Set pointer to the configuration manager.
SetOverwriteFlag | Sets or resets the OVR flag.
SetTabSize | Set the tab size between 1-64.
StrPosToCol | Converts string position of text to column coordinates coordinate.


CXTPSyntaxEditBufferManager::CalcAveDataSize Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CalcAveDataSize Method

Returns average data size.

virtual UINT CalcAveDataSize(
    int nRowStart,
    int nRowEnd
);
Parameters

nRowStart
[in] Start row identifier.
nRowEnd
[in] End row identifier.

Returns

Average data size as integer value.

Remarks

Call this member function to calculate average data size based on average row length.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::CalcMaxLineTextLength Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CalcMaxLineTextLength Method

Returns a length for line of text either from file or buffer.

int CalcMaxLineTextLength(
    int nLineFrom = -1,
    int nLineTo = -1,
    BOOL bExpandTabs = FALSE
) const;
Parameters

nLineFrom
[in] Start line identifier.
nLineTo
[in] End line identifier.
bExpandTabs
[in] Expand tab characters.

Returns

Text length as integer value.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::ChangeCase Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::ChangeCase Method

Changes the case of the specified characters range in the specified row.

void ChangeCase(
    int nRow,
    int nDispFrom,
    int nDispTo,
    BOOL bUpper,
    BOOL bCanUndo = TRUE
);
Parameters

nRow
[in] A row to change case at.
nDispFrom
[in] Begin visible position where to change case at.
nDispTo
[in] End visible position where to change case at.
bUpper
[in] TRUE when changing selection case to Upper, FALSE when changing selection case to Lower.
bCanUndo
[in] Pass TRUE if this can be undone.

Remarks

Configuration will be reloaded.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::ChangeTabification Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::ChangeTabification Method

Changes the case of the specified characters range in the specified row.

void ChangeTabification(
    int nRow,
    int nDispFrom,
    int nDispTo,
    BOOL bTabify,
    BOOL bCanUndo = TRUE
);
Parameters

nRow
[in] A row to change case at.
nDispFrom
[in] Begin visible position where to change case at.
nDispTo
[in] End visible position where to change case at.
bTabify
[in] TRUE when changing spaces to tabs, FALSE when changing tabs to spaces.
bCanUndo
[in] Pass TRUE if this can be undone.

Remarks

Configuration will be reloaded.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::CleanUp Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CleanUp Method

Cleans up the buffer and all other allocated memories

void CleanUp();
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::Close Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::Close Method

Cleans up all internal objects.

void Close();
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::ColToStrPos Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::ColToStrPos Method

Converts column coordinates of text to string position coordinate.

virtual int ColToStrPos(
    int nLine,
    int nDispCol
) const;
Parameters

nLine
[in] Text line identifier.
nDispCol
[in] Column coordinate.

Returns

String position identifier corresponding to column identifier.

See Also

virtual int StrPosToCol(int nLine, int nStrPos) const;

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::DeleteText Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::DeleteText Method

Deletes a certain range of text

BOOL DeleteText(
    int iRowFrom,
    int iColFrom,
    int iRowTo,
    int iColTo,
    BOOL bCanUndo = TRUE,
    BOOL bDispCol = FALSE
);
Parameters

iRowFrom
[in] Start row for delete.
iColFrom
[in] Start col for delete.
iRowTo
[in] End row for delete.
iColTo
[in] End col for delete.
bCanUndo
[in] Pass TRUE if this can be undone.
bDispCol
[in] if TRUE iColFrom and iColTo are display cols, otherwise they are string cols.
pbRowFlagChanged
[out] Filled with TRUE if row flag has been changed.

Returns

TRUE if the succeeded, FALSE otherwise.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::EnableParser Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::EnableParser Method

Enable or disable parser.

void EnableParser(
    BOOL bEnable
);
Parameters

bEnable
[in] Pass TRUE to enable parser, FALSE to disable.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetBuffer Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetBuffer Method

Retrieve text from the buffer bounded between row1/col1 and row2/col2 (or lcStart and lcEnd) text coordinates.

BOOL GetBuffer(
    int row1,
    int col1,
    int row2,
    int col2,
    CMemFile& file,
    BOOL bColumnSelection = FALSE,
    BOOL bForceDOSStyleCRLF = FALSE
);
Parameters

row1
[in] Start line number.
col1
[in] Start column number.
row2
[in] End line number.
col2
[in] End column number.
file
[out] A reference to CMemFile object to receive text.
bColumnSelection
[in] If this parameter TRUE - the text block started from col1 and ended on col2 for each line between row1 and row2 copied, otherwise full row text copied for rows between row1 and row2.
bForceDOSStyleCRLF
[in] If this parameter TRUE the DOS Style carriage return chars will be used to end each line, otherwise current carriage return style is used.
lcStart
[in] Start text position.
lcEnd
[in] End text position.

Returns

TRUE if the succeeded, FALSE otherwise.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetCodePage Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetCodePage Method

Determines if the file has been modified or not.

UINT GetCodePage();
Returns

CodePage to be used for conversion.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetConfigFile Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetConfigFile Method

Get main configuration file name.

CString GetConfigFile();
Returns

Main configuration file name.

Remarks

Return configuration file name previously stored by SetConfigFile().

See Also

CXTPSyntaxEditBufferManager::SetConfigFile().

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetConnection Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetConnection Method

Returns events connection pointer.

CXTPNotifyConnection* GetConnection();
Body Source
CXTPNotifyConnection* CXTPSyntaxEditBufferManager::GetConnection()
{
    return m_pConnect;
}
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetCurCRLF Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetCurCRLF Method

Returns the CRLF of the current document.

CString GetCurCRLF() const;
Returns

Current CRLF text.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetCurCRLFType Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetCurCRLFType Method

Returns the CRLF type of the current document.

int GetCurCRLFType();
Returns

Current CRLF type.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetFileExt Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetFileExt Method

Returns file extension.

CString GetFileExt();
Returns

CString object with file extensions.

See Also

void SetFileExt(const CString& strExt);

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetLexConfigurationManager Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetLexConfigurationManager Method

Returns pointer to the associated configuration manager.

CXTPSyntaxEditConfigurationManager* GetLexConfigurationManager();
Body Source
CXTPSyntaxEditConfigurationManager* CXTPSyntaxEditBufferManager::GetLexConfigurationManager() {
    return m_ptrLexConfigurationManager;
}
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetLexParser Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetLexParser Method

Returns pointer to the associated lexical parser.

XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser* GetLexParser();
Returns

Pointer to a XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser object.

Body Source
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser* CXTPSyntaxEditBufferManager::GetLexParser() {
    return m_pLexParser;
}
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetLineMarksManager Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetLineMarksManager Method

Returns pointer to the associated line marks manager.

CXTPSyntaxEditLineMarksManager* GetLineMarksManager();
Returns

Pointer to a CXTPSyntaxEditLineMarksManager object.

Body Source
CXTPSyntaxEditLineMarksManager* CXTPSyntaxEditBufferManager::GetLineMarksManager() {
    return m_pLineMarksManager;
}
Group

CXTPSyntaxEditBufferManager Methods


GetLineText Method

CXTPSyntaxEditBufferManager Methods
GetLineText Method
Overload List
Methods
Method | Description
CXTPSyntaxEditBufferManager::GetLineText (int, BOOL, int) | Returns a line of text either from file or buffer.
CXTPSyntaxEditBufferManager::GetLineText (int, CString&, BOOL, int) | Gets a line of text either from file or buffer.
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetLineText Method (int, BOOL, int)

GetLineText Method, CXTPSyntaxEditBufferManager Class
CXTPSyntaxEditBufferManager::GetLineText Method (int, BOOL, int)

Returns a line of text either from file or buffer.

CString GetLineText(
    int iLine,
    BOOL bAddCRLF = FALSE,
    int iCRLFStyle = -1
);
Parameters

iLine
[in] The line for which to get the text.
bAddCRLF
[in] Pass TRUE to add CRLF (if exists), otherwise .
iCRLFStyle
[in] Specify the CRLF style.

Returns

CString object with text line.

Group

GetLineText Method


CXTPSyntaxEditBufferManager::GetLineText Method (int, CString&, BOOL, int)

GetLineText Method, CXTPSyntaxEditBufferManager Class
CXTPSyntaxEditBufferManager::GetLineText Method (int, CString&, BOOL, int)

Gets a line of text either from file or buffer.

void GetLineText(
    int iLine,
    CString& strText,
    BOOL bAddCRLF = FALSE,
    int iCRLFStyle = -1
);
Parameters

iLine
[in] The line for which to get the text.
strText
[out] A reference to CString object to be filled with text.
bAddCRLF
[in] Pass TRUE to add CRLF (if exists), otherwise .
iCRLFStyle
[in] Specify the CRLF style.

Group

GetLineText Method


CXTPSyntaxEditBufferManager::GetLineTextLength Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetLineTextLength Method

Returns a length for line of text in TCHARs.

int GetLineTextLength(
    int iLine,
    BOOL bAddCRLF = FALSE,
    int iCRLFStyle = -1
);
Parameters

iLine
[in] The line for which to get the text.
bAddCRLF
[in] Pass TRUE to add CRLF (if exsts), otherwise .
iCRLFStyle
[in] Specify the CRLF style.

Returns

Text line length as integer value.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetLineTextLengthC Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetLineTextLengthC Method

Returns a length for line of text in characters.

int GetLineTextLengthC(
    int iLine,
    BOOL bAddCRLF = FALSE,
    int iCRLFStyle = -1
);
Parameters

iLine
[in] The line for which to get the text.
bAddCRLF
[in] Pass TRUE to add CRLF (if exsts), otherwise .
iCRLFStyle
[in] Specify the CRLF style.

Returns

Text line length in characters as integer value.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetMasterTextSchema Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetMasterTextSchema Method

Set the path to the main configuration file.

CXTPSyntaxEditTextSchema* GetMasterTextSchema(
    const CString& strExt
);
Parameters

strExt
[in] file extension for for schema definition file.

Returns

CXTPSyntaxEditTextSchema

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetMaxLineTextLength Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetMaxLineTextLength Method

Returns the max allowable length for line of text.

int GetMaxLineTextLength() const;
Returns

Text line length as integer value.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetOverwriteFlag Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetOverwriteFlag Method

Returns the overwrite flag status.

BOOL GetOverwriteFlag();
Returns

TRUE if OVR mode is set, FALSE otherwise.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetRowCount Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetRowCount Method

Returns the number of rows in the document.

int GetRowCount() const;
Returns

Number of rows in the document.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetTabSize Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetTabSize Method

Returns the tab size for the current document.

int GetTabSize() const;
Returns

Selected tab size.

Body Source
int CXTPSyntaxEditBufferManager::GetTabSize() const {
    return m_nTabSize;
}
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::GetUndoRedoManager Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::GetUndoRedoManager Method

Returns pointer to the associated Undo/Redo manager.

CXTPSyntaxEditUndoRedoManager* GetUndoRedoManager();
Returns

Pointer to a CXTPSyntaxEditUndoRedoManager object.

Body Source
CXTPSyntaxEditUndoRedoManager* CXTPSyntaxEditBufferManager::GetUndoRedoManager() {
    return m_pUndoRedoManager;
}
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::InsertText Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::InsertText Method

Inserts a text or text block.

BOOL InsertText(
    LPCTSTR szText,
    int iRow,
    int iCol,
    BOOL bCanUndo = TRUE,
    XTP_EDIT_LINECOL* pFinalLC = NULL
);
BOOL InsertTextBlock(
    LPCTSTR szText,
    int nRow,
    int nCol,
    BOOL bCanUndo = TRUE,
    XTP_EDIT_LINECOL* pFinalLC = NULL
);
Parameters

szText
[in] Text to be inserted.
iRow
[in] Start row for delete.
iCol
[in] Start col for delete.
bCanUndo
[in] Pass TRUE if this can be undone.
pFinalLC
[out] A pointer to XTP_EDIT_LINECOL variable to receive operation final position in the text (to set caret).
pbRowFlagChanged
[out] Filled with TRUE if row flag has been changed.

Returns

TRUE if the succeeded, FALSE otherwise.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::IsModified Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::IsModified Method

Determines if the file has been modified or not.

BOOL IsModified();
Returns

TRUE if modified, FALSE otherwise.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::IsParserEnabled Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::IsParserEnabled Method

Returns the parser status.

BOOL IsParserEnabled();
Returns

TRUE if Parser is enabled, FALSE otherwise.

Group

CXTPSyntaxEditBufferManager Methods


IsTextCRLF Method

CXTPSyntaxEditBufferManager Methods
IsTextCRLF Method
Overload List
Methods
Method | Description
CXTPSyntaxEditBufferManager::IsTextCRLF (LPCSTR, BOOL) | Determines if the supplied text is a CRLF or not of the non-unicode string.
CXTPSyntaxEditBufferManager::IsTextCRLF (LPCTSTR, BOOL) | Determines if the supplied text is a CRLF or not
Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::IsTextCRLF Method (LPCSTR, BOOL)

IsTextCRLF Method, CXTPSyntaxEditBufferManager Class
CXTPSyntaxEditBufferManager::IsTextCRLF Method (LPCSTR, BOOL)

Determines if the supplied text is a CRLF or not of the non-unicode string.

BOOL IsTextCRLF(
    LPCSTR szCompText,
    BOOL bFindReverse = FALSE
);
Parameters

szCompText
[in] The text to be compared.
bFindReverse
[in] Should be match reverse.

Returns

TRUE if the supplied text is a CRLF, FALSE otherwise.

Group

IsTextCRLF Method


CXTPSyntaxEditBufferManager::IsTextCRLF Method (LPCTSTR, BOOL)

IsTextCRLF Method, CXTPSyntaxEditBufferManager Class
CXTPSyntaxEditBufferManager::IsTextCRLF Method (LPCTSTR, BOOL)

Determines if the supplied text is a CRLF or not

BOOL IsTextCRLF(
    LPCTSTR szCompText,
    BOOL bFindReverse = FALSE
);
Parameters

szCompText
[in] The text to be compared.
bFindReverse
[in] Should be match reverse.

Returns

TRUE if the supplied text is a CRLF, FALSE otherwise.

Group

IsTextCRLF Method


CXTPSyntaxEditBufferManager::Load Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::Load Method

Set the file pointer for the buffer.

void Load(
    CFile * pFile,
    LPCTSTR pcszFileExt = NULL
);
Parameters

pFile
[in] The file pointer to set.
pcszFileExt
[in] Number of lines (Not used).

See Also

SetFileExt()

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::RemoveLine Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::RemoveLine Method

Deletes a certain range of text

BOOL RemoveLine(
    int nRow,
    BOOL bCanUndo = TRUE,
    int nRowsCount = 1
);
Parameters

nRow
[in] Start row for delete.
bCanUndo
[in] Pass TRUE if this can be undone.
nRowsCount
[in] Rows count to delete.

Returns

TRUE if the succeeded, FALSE otherwise.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::Serialize Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::Serialize Method

Serializes actual data.

void Serialize(
    CArchive& ar
);
Parameters

ar
[in, out] The archive to save/load text.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::SerializeEx Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::SerializeEx Method

Serializes actual data.

void SerializeEx(
    CArchive & ar,
    BOOL bUnicode = -1,
    BOOL bWriteUnicodeFilePrefix = TRUE,
    UINT nCodePage = (UINT)-1,
    LPCTSTR pcszFileExt = NULL,
    int nDataSizeLimit = -1
);
Parameters

ar
[in, out] The archive to save/load text.
bUnicode
[in] Use UNICODE format for text in the archive.
bWriteUnicodeFilePrefix
[in] Write Unicode File Prefix.
nCodePage
[in] Text code page (or -1 to use default).
pcszFileExt
[in] File extension to select appropriate parser schema.
uDataSizeLimit
[in] The number of bytes to stop storing text to archive (or -1 to store all).

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::SetConfigFile Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::SetConfigFile Method

Set the path to the main configuration file.

BOOL SetConfigFile(
    LPCTSTR szPath
);
Parameters

szPath
[in] A valid path for searching the .ini files.

Returns

TRUE if path is found, FALSE otherwise.

Remarks

Configuration will be reloaded.

See Also

CXTPSyntaxEditBufferManager::GetConfigFile().

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::SetCRLFStyle Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::SetCRLFStyle Method

Set the current documents CRLF style.

void SetCRLFStyle(
    int nStyle
);
Parameters

nStyle
[in] The CRLF style to set

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::SetFileExt Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::SetFileExt Method

Sets file extension.

void SetFileExt(
    const CString& strExt
);
Parameters

strExt
[in] string of extension.

See Also

CString GetFileExt()

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::SetLexConfigurationManager Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::SetLexConfigurationManager Method

Set pointer to the configuration manager.

void SetLexConfigurationManager(
    CXTPSyntaxEditConfigurationManager* pMan
);
Parameters

pMan
[in] Pointer to CXTPSyntaxEditConfigurationManager.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::SetOverwriteFlag Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::SetOverwriteFlag Method

Sets or resets the OVR flag.

void SetOverwriteFlag(
    BOOL bOverwrite
);
Parameters

bOverwrite
[in] Pass TRUE to set OVR flag, FALSE to INS flag.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::SetTabSize Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::SetTabSize Method

Set the tab size between 1-64.

BOOL SetTabSize(
    int nTabSize,
    BOOL bUpdateReg = FALSE
);
Parameters

nTabSize
[in] The tab size to set.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager::StrPosToCol Method

CXTPSyntaxEditBufferManager Methods, CXTPSyntaxEditBufferManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::StrPosToCol Method

Converts string position of text to column coordinates coordinate.

virtual int StrPosToCol(
    int nLine,
    int nStrPos
) const;
Parameters

nLine
[in] Text line identifier.
nStrPos
[in] A string position.

Returns

Column identifier corresponding to string position identifier.

See Also

virtual int ColToStrPos(int nLine, int nDispCol) const;

Group

CXTPSyntaxEditBufferManager Methods


CXTPSyntaxEditBufferManager Constructors

CXTPSyntaxEditBufferManager Class, Legend, Public Methods
CXTPSyntaxEditBufferManager Constructors
Class

CXTPSyntaxEditBufferManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditBufferManager | Default object constructor.


CXTPSyntaxEditBufferManager::CXTPSyntaxEditBufferManager Constructor

CXTPSyntaxEditBufferManager Constructors, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::CXTPSyntaxEditBufferManager Constructor

Default object constructor.

CXTPSyntaxEditBufferManager();
Group

CXTPSyntaxEditBufferManager Constructors


CXTPSyntaxEditBufferManager Destructors

CXTPSyntaxEditBufferManager Class, Legend, Public Methods
CXTPSyntaxEditBufferManager Destructors
Class

CXTPSyntaxEditBufferManager Class

Legend
Destructor
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditBufferManager | Destroys a CXTPSyntaxEditBufferManager object, handles cleanup and de-allocation.


CXTPSyntaxEditBufferManager::~CXTPSyntaxEditBufferManager Destructor

CXTPSyntaxEditBufferManager Destructors, CXTPSyntaxEditBufferManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditBufferManager::~CXTPSyntaxEditBufferManager Destructor

Destroys a CXTPSyntaxEditBufferManager object, handles cleanup and de-allocation.

~CXTPSyntaxEditBufferManager();
Group

CXTPSyntaxEditBufferManager Destructors


CXTPSyntaxEditColorComboBox Class

XTPSyntaxEditColorComboBox.h, Classes, Legend, Members, Topics, CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Constructors, CXTPSyntaxEditColorComboBox Destructors, CXTPSyntaxEditColorComboBox Constructors, CXTPSyntaxEditColorComboBox Destructors, CXTPSyntaxEditColorComboBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox Class

This class allow edit colors using combobox control. It display color name and draw rectangle for each item using item color.

Class Hierarchy

class CXTPSyntaxEditColorComboBox : public CComboBox;
File

XTPSyntaxEditColorComboBox.h

Group

Classes

Legend
Method
protected
virtual
CXTPSyntaxEditColorComboBox Constructors
CXTPSyntaxEditColorComboBox Constructors | Description
CXTPSyntaxEditColorComboBox | Standard object constructor.
CXTPSyntaxEditColorComboBox Destructors
CXTPSyntaxEditColorComboBox Destructors | Description
~CXTPSyntaxEditColorComboBox | Standard object destructor.
CXTPSyntaxEditColorComboBox Methods
CXTPSyntaxEditColorComboBox Methods | Description
AddColor | Use this member to add new color.
DeleteColor | Use this member to remove color.
FindColor | Use this member to find color index.
GetAutoColor | Use this member to get auto color value.
GetLBCurSel | Use this member function to get list box selected item (works for dropped state only).
GetSelColor | Use this member to get selected color.
GetUserColor | Use this member to get user color value.
Init | Use this member to add default set of colors.
NotifyOwner | Send WM_COMMAND message to owner window.
SelectUserColor | Use this member to select a user color.
SetAutoColor | Use this member to set auto color value.
SetSelColor | Use this member to set selected color.
SetUserColor | Use this member to set user color value (and name).


CXTPSyntaxEditColorComboBox Methods

CXTPSyntaxEditColorComboBox Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox Methods
Class

CXTPSyntaxEditColorComboBox Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
AddColor | Use this member to add new color.
GetLBCurSel | Use this member function to get list box selected item (works for dropped state only).
NotifyOwner | Send WM_COMMAND message to owner window.
Public Methods
Public Methods
Public Method | Description
DeleteColor | Use this member to remove color.
FindColor | Use this member to find color index.
GetAutoColor | Use this member to get auto color value.
GetSelColor | Use this member to get selected color.
GetUserColor | Use this member to get user color value.
Init | Use this member to add default set of colors.
SelectUserColor | Use this member to select a user color.
SetAutoColor | Use this member to set auto color value.
SetSelColor | Use this member to set selected color.
SetUserColor | Use this member to set user color value (and name).


CXTPSyntaxEditColorComboBox::AddColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::AddColor Method

Use this member to add new color.

virtual int AddColor(
    COLORREF crColor,
    UINT nID
);
Parameters

crColor
A color value.
nID
A resource ID of a color name string.

Returns

New color index or CB_ERR.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::DeleteColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::DeleteColor Method

Use this member to remove color.

int DeleteColor(
    COLORREF crColor
);
Parameters

crColor
A color value.

Returns

Deleted color index or CB_ERR.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::FindColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::FindColor Method

Use this member to find color index.

int FindColor(
    COLORREF crColor
);
Parameters

crColor
A color value.

Returns

Color index or CB_ERR.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::GetAutoColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::GetAutoColor Method

Use this member to get auto color value.

COLORREF GetAutoColor() const;
Returns

A auto color value.

Body Source
COLORREF CXTPSyntaxEditColorComboBox::GetAutoColor() const {
    return m_crAuto;
}
Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::GetLBCurSel Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::GetLBCurSel Method

Use this member function to get list box selected item (works for dropped state only).

virtual int GetLBCurSel() const;
Returns

Currently selected item index or LB_ERR.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::GetSelColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::GetSelColor Method

Use this member to get selected color.

COLORREF GetSelColor();
Returns

Currently selected color or COLORREF_NULL if no selection.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::GetUserColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::GetUserColor Method

Use this member to get user color value.

COLORREF GetUserColor() const;
Returns

A user color value.

Body Source
COLORREF CXTPSyntaxEditColorComboBox::GetUserColor() const {
    return m_crUser;
}
Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::Init Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::Init Method

Use this member to add default set of colors.

virtual bool Init();
Returns

true if successful, false otherwise.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::NotifyOwner Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::NotifyOwner Method

Send WM_COMMAND message to owner window.

virtual void NotifyOwner(
    UINT nCode
);
Parameters

nCode
Notifuication code

Remarks

Default implementation send followin notifuications: CBN_SELENDCANCEL, CBN_SELENDOK

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::SelectUserColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::SelectUserColor Method

Use this member to select a user color.

int SelectUserColor();
Returns

Selected color index or CB_ERR.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::SetAutoColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::SetAutoColor Method

Use this member to set auto color value.

int SetAutoColor(
    COLORREF crColor,
    LPCTSTR lpszAutoText = NULL
);
Parameters

crColor
A color value.
lpszAutoText
A auto color name or NULL to use default.

Returns

Color index or CB_ERR.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::SetSelColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::SetSelColor Method

Use this member to set selected color.

int SetSelColor(
    COLORREF crColor
);
Parameters

crColor
A color value.

Returns

newly selected color item index.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox::SetUserColor Method

CXTPSyntaxEditColorComboBox Methods, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::SetUserColor Method

Use this member to set user color value (and name).

int SetUserColor(
    COLORREF crColor,
    LPCTSTR lpszUserText = NULL
);
Parameters

crColor
A color value.
lpszUserText
A user color name or NULL to use default.

Returns

Color index or CB_ERR.

Group

CXTPSyntaxEditColorComboBox Methods


CXTPSyntaxEditColorComboBox Constructors

CXTPSyntaxEditColorComboBox Class, Legend, Public Methods
CXTPSyntaxEditColorComboBox Constructors
Class

CXTPSyntaxEditColorComboBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorComboBox | Standard object constructor.


CXTPSyntaxEditColorComboBox::CXTPSyntaxEditColorComboBox Constructor

CXTPSyntaxEditColorComboBox Constructors, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::CXTPSyntaxEditColorComboBox Constructor

Standard object constructor.

CXTPSyntaxEditColorComboBox();
Group

CXTPSyntaxEditColorComboBox Constructors


CXTPSyntaxEditColorComboBox Destructors

CXTPSyntaxEditColorComboBox Class, Legend, Public Methods
CXTPSyntaxEditColorComboBox Destructors
Class

CXTPSyntaxEditColorComboBox Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditColorComboBox | Standard object destructor.


CXTPSyntaxEditColorComboBox::~CXTPSyntaxEditColorComboBox Destructor

CXTPSyntaxEditColorComboBox Destructors, CXTPSyntaxEditColorComboBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorComboBox::~CXTPSyntaxEditColorComboBox Destructor

Standard object destructor.

virtual ~CXTPSyntaxEditColorComboBox();
Group

CXTPSyntaxEditColorComboBox Destructors


CXTPSyntaxEditColorInfo Class

XTPSyntaxEditLexColorFileReader.h, Classes, Legend, Members, Topics, CXTPSyntaxEditColorInfo Methods, CXTPSyntaxEditColorInfo Constructors, CXTPSyntaxEditColorInfo Destructors, CXTPSyntaxEditColorInfo Constructors, CXTPSyntaxEditColorInfo Destructors, CXTPSyntaxEditColorInfo Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo Class

This storage class is designed to contain information from the color settings file section. It helps easy retrieve color information.

Class Hierarchy

class CXTPSyntaxEditColorInfo;
File

XTPSyntaxEditLexColorFileReader.h

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditColorInfo Constructors
CXTPSyntaxEditColorInfo Constructors | Description
CXTPSyntaxEditColorInfo |
CXTPSyntaxEditColorInfo Destructors
CXTPSyntaxEditColorInfo Destructors | Description
~CXTPSyntaxEditColorInfo | Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation
CXTPSyntaxEditColorInfo Methods
CXTPSyntaxEditColorInfo Methods | Description
AddParam | Adds parameter.
GetClassName | Use this function to get lex class name.
GetFirstParamNamePosition | Returns firs parameter position.
GetHexParam | Returns hexadecimal value.
GetNextParamName | Returns next parameter position.
GetParam | Returns string of parameter value.


CXTPSyntaxEditColorInfo Methods

CXTPSyntaxEditColorInfo Class, Legend, Public Methods
CXTPSyntaxEditColorInfo Methods
Class

CXTPSyntaxEditColorInfo Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddParam | Adds parameter.
GetClassName | Use this function to get lex class name.
GetFirstParamNamePosition | Returns firs parameter position.
GetHexParam | Returns hexadecimal value.
GetNextParamName | Returns next parameter position.
GetParam | Returns string of parameter value.


CXTPSyntaxEditColorInfo::AddParam Method

CXTPSyntaxEditColorInfo Methods, CXTPSyntaxEditColorInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::AddParam Method

Adds parameter.

void AddParam(
    const CString& strName,
    const CString& strValue
);
Parameters

strName
[in] Parameter name.
strValue
[in] Parameter value.

Group

CXTPSyntaxEditColorInfo Methods


CXTPSyntaxEditColorInfo::GetClassName Method

CXTPSyntaxEditColorInfo Methods, CXTPSyntaxEditColorInfo Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::GetClassName Method

Use this function to get lex class name.

const CString GetClassName() const;
Returns

A lex class name

Body Source
const CString CXTPSyntaxEditColorInfo::GetClassName() const {
    return m_strClassName;
}
Group

CXTPSyntaxEditColorInfo Methods


CXTPSyntaxEditColorInfo::GetFirstParamNamePosition Method

CXTPSyntaxEditColorInfo Methods, CXTPSyntaxEditColorInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::GetFirstParamNamePosition Method

Returns firs parameter position.

POSITION GetFirstParamNamePosition();
Returns

POSITION value.

Group

CXTPSyntaxEditColorInfo Methods


CXTPSyntaxEditColorInfo::GetHexParam Method

CXTPSyntaxEditColorInfo Methods, CXTPSyntaxEditColorInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::GetHexParam Method

Returns hexadecimal value.

DWORD GetHexParam(
    const CString& strName,
    BOOL bDynamic = TRUE
);
Parameters

strName
[in] Parameter name.
bDynamic
[in] If TRUE - search parameter value in parent themes (dynamically), otherwise it is searched only in the current theme.

Returns

DWORD parameter value.

Group

CXTPSyntaxEditColorInfo Methods


CXTPSyntaxEditColorInfo::GetNextParamName Method

CXTPSyntaxEditColorInfo Methods, CXTPSyntaxEditColorInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::GetNextParamName Method

Returns next parameter position.

const CString GetNextParamName(
    POSITION& pos
);
Parameters

pos
[in] position.

Returns

POSITION value.

Group

CXTPSyntaxEditColorInfo Methods


CXTPSyntaxEditColorInfo::GetParam Method

CXTPSyntaxEditColorInfo Methods, CXTPSyntaxEditColorInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::GetParam Method

Returns string of parameter value.

const CString GetParam(
    const CString& strName,
    BOOL bDynamic = TRUE
);
Parameters

strName
[in] Parameter name.
bDynamic
[in] If TRUE - search parameter value in parent themes (dynamically), otherwise it is searched only in the current theme.

Returns

CString object with parameter value.

Group

CXTPSyntaxEditColorInfo Methods


CXTPSyntaxEditColorInfo Constructors

CXTPSyntaxEditColorInfo Class, Legend, Public Methods
CXTPSyntaxEditColorInfo Constructors
Class

CXTPSyntaxEditColorInfo Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorInfo |


CXTPSyntaxEditColorInfo Constructor

CXTPSyntaxEditColorInfo Constructors
CXTPSyntaxEditColorInfo Constructor
Overload List
Constructors
Constructor | Description
CXTPSyntaxEditColorInfo::CXTPSyntaxEditColorInfo (CXTPSyntaxEditColorTheme*) | Object constructor.
CXTPSyntaxEditColorInfo::CXTPSyntaxEditColorInfo (const CString&, CXTPSyntaxEditColorTheme*) | Object constructor.
Group

CXTPSyntaxEditColorInfo Constructors


CXTPSyntaxEditColorInfo::CXTPSyntaxEditColorInfo Constructor (CXTPSyntaxEditColorTheme*)

CXTPSyntaxEditColorInfo Constructor, CXTPSyntaxEditColorInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::CXTPSyntaxEditColorInfo Constructor (CXTPSyntaxEditColorTheme*)

Object constructor.

CXTPSyntaxEditColorInfo(
    CXTPSyntaxEditColorTheme* pTheme
);
Parameters

pTheme
[in] Pointer to CXTPSyntaxEditColorTheme object (theme this color information belongs to)

Group

CXTPSyntaxEditColorInfo Constructor


CXTPSyntaxEditColorInfo::CXTPSyntaxEditColorInfo Constructor (const CString&, CXTPSyntaxEditColorTheme*)

CXTPSyntaxEditColorInfo Constructor, CXTPSyntaxEditColorInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::CXTPSyntaxEditColorInfo Constructor (const CString&, CXTPSyntaxEditColorTheme*)

Object constructor.

CXTPSyntaxEditColorInfo(
    const CString& strClassName,
    CXTPSyntaxEditColorTheme* pTheme
);
Parameters

strClassName
[in] Lex Class name
pTheme
[in] Pointer to CXTPSyntaxEditColorTheme object (theme this color information belongs to)

Group

CXTPSyntaxEditColorInfo Constructor


CXTPSyntaxEditColorInfo Destructors

CXTPSyntaxEditColorInfo Class, Legend, Public Methods
CXTPSyntaxEditColorInfo Destructors
Class

CXTPSyntaxEditColorInfo Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditColorInfo | Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation


CXTPSyntaxEditColorInfo::~CXTPSyntaxEditColorInfo Destructor

CXTPSyntaxEditColorInfo Destructors, CXTPSyntaxEditColorInfo Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorInfo::~CXTPSyntaxEditColorInfo Destructor

Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation

virtual ~CXTPSyntaxEditColorInfo();
Group

CXTPSyntaxEditColorInfo Destructors


CXTPSyntaxEditColorInfoArray Class

XTPSyntaxEditLexColorFileReader.h, Classes
CXTPSyntaxEditColorInfoArray Class
Class Hierarchy

class CXTPSyntaxEditColorInfoArray : public CArray<CXTPSyntaxEditColorInfo*, CXTPSyntaxEditColorInfo*>;
File

XTPSyntaxEditLexColorFileReader.h

Group

Classes


CXTPSyntaxEditColorSampleText Class

XTPSyntaxEditColorSampleText.h, Classes, Legend, Members, Topics, CXTPSyntaxEditColorSampleText Methods, CXTPSyntaxEditColorSampleText Constructors, CXTPSyntaxEditColorSampleText Destructors, CXTPSyntaxEditColorSampleText Constructors, CXTPSyntaxEditColorSampleText Destructors, CXTPSyntaxEditColorSampleText Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText Class

This class, derived from CStatic, used to display sample of colored text.

Class Hierarchy

class CXTPSyntaxEditColorSampleText : public CStatic;
File

XTPSyntaxEditColorSampleText.h

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditColorSampleText Constructors
CXTPSyntaxEditColorSampleText Constructors | Description
CXTPSyntaxEditColorSampleText | Default object constructor.
CXTPSyntaxEditColorSampleText Destructors
CXTPSyntaxEditColorSampleText Destructors | Description
~CXTPSyntaxEditColorSampleText | Default object destructor.
CXTPSyntaxEditColorSampleText Methods
CXTPSyntaxEditColorSampleText Methods | Description
GetBackColor | Get background color.
GetBorderColor | Get border color.
GetTextColor | Get text color.
Refresh | Redraw control.
SetBackColor | Set background color
SetBorderColor | Set border color.
SetTextColor | Set text color.


CXTPSyntaxEditColorSampleText Methods

CXTPSyntaxEditColorSampleText Class, Legend, Public Methods
CXTPSyntaxEditColorSampleText Methods
Class

CXTPSyntaxEditColorSampleText Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetBackColor | Get background color.
GetBorderColor | Get border color.
GetTextColor | Get text color.
Refresh | Redraw control.
SetBackColor | Set background color
SetBorderColor | Set border color.
SetTextColor | Set text color.


CXTPSyntaxEditColorSampleText::GetBackColor Method

CXTPSyntaxEditColorSampleText Methods, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::GetBackColor Method

Get background color.

COLORREF GetBackColor() const;
Returns

A color value.

Group

CXTPSyntaxEditColorSampleText Methods


CXTPSyntaxEditColorSampleText::GetBorderColor Method

CXTPSyntaxEditColorSampleText Methods, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::GetBorderColor Method

Get border color.

COLORREF GetBorderColor() const;
Returns

A color value.

Group

CXTPSyntaxEditColorSampleText Methods


CXTPSyntaxEditColorSampleText::GetTextColor Method

CXTPSyntaxEditColorSampleText Methods, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::GetTextColor Method

Get text color.

COLORREF GetTextColor() const;
Returns

A color value.

Group

CXTPSyntaxEditColorSampleText Methods


CXTPSyntaxEditColorSampleText::Refresh Method

CXTPSyntaxEditColorSampleText Methods, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::Refresh Method

Redraw control.

void Refresh();
Group

CXTPSyntaxEditColorSampleText Methods


CXTPSyntaxEditColorSampleText::SetBackColor Method

CXTPSyntaxEditColorSampleText Methods, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::SetBackColor Method

Set background color

void SetBackColor(
    COLORREF crBack
);
Parameters

crBack
A color value.

Group

CXTPSyntaxEditColorSampleText Methods


CXTPSyntaxEditColorSampleText::SetBorderColor Method

CXTPSyntaxEditColorSampleText Methods, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::SetBorderColor Method

Set border color.

void SetBorderColor(
    COLORREF crBorder
);
Parameters

crBorder
A color value.

Group

CXTPSyntaxEditColorSampleText Methods


CXTPSyntaxEditColorSampleText::SetTextColor Method

CXTPSyntaxEditColorSampleText Methods, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::SetTextColor Method

Set text color.

void SetTextColor(
    COLORREF crText
);
Parameters

crText
A color value.

Group

CXTPSyntaxEditColorSampleText Methods


CXTPSyntaxEditColorSampleText Constructors

CXTPSyntaxEditColorSampleText Class, Legend, Public Methods
CXTPSyntaxEditColorSampleText Constructors
Class

CXTPSyntaxEditColorSampleText Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorSampleText | Default object constructor.


CXTPSyntaxEditColorSampleText::CXTPSyntaxEditColorSampleText Constructor

CXTPSyntaxEditColorSampleText Constructors, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::CXTPSyntaxEditColorSampleText Constructor

Default object constructor.

CXTPSyntaxEditColorSampleText();
Group

CXTPSyntaxEditColorSampleText Constructors


CXTPSyntaxEditColorSampleText Destructors

CXTPSyntaxEditColorSampleText Class, Legend, Public Methods
CXTPSyntaxEditColorSampleText Destructors
Class

CXTPSyntaxEditColorSampleText Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditColorSampleText | Default object destructor.


CXTPSyntaxEditColorSampleText::~CXTPSyntaxEditColorSampleText Destructor

CXTPSyntaxEditColorSampleText Destructors, CXTPSyntaxEditColorSampleText Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorSampleText::~CXTPSyntaxEditColorSampleText Destructor

Default object destructor.

virtual ~CXTPSyntaxEditColorSampleText();
Group

CXTPSyntaxEditColorSampleText Destructors


CXTPSyntaxEditColorTheme Class

XTPSyntaxEditLexColorFileReader.h, Classes, Legend, Members, Topics, CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Constructors, CXTPSyntaxEditColorTheme Destructors, CXTPSyntaxEditColorTheme Nested Types, CXTPSyntaxEditColorTheme Constructors, CXTPSyntaxEditColorTheme Destructors, CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme Class

This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes color settings for corresponding lexical items for given language. You construct instance of CXTPSyntaxEditColorTheme by calling constructor. Then you should call Load() member function to read data from persistent storage (file for this implementation), CXTPSyntaxEditLexColorInfo structures.

Class Hierarchy

class CXTPSyntaxEditColorTheme;
File

XTPSyntaxEditLexColorFileReader.h

Group

Classes

Legend
Method
protected
virtual
CXTPSyntaxEditColorTheme Constructors
CXTPSyntaxEditColorTheme Constructors | Description
CXTPSyntaxEditColorTheme | Default object constructor.
CXTPSyntaxEditColorTheme Destructors
CXTPSyntaxEditColorTheme Destructors | Description
~CXTPSyntaxEditColorTheme | Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation.
CXTPSyntaxEditColorTheme Methods
CXTPSyntaxEditColorTheme Methods | Description
Cleanup | Cleans up collection.
GetColorInfo | Returns color information.
GetFileName | Returns configuration file name.
GetParentTheme | Returns parent schema.
GetParentThemeName | Returns name of the parent schema.
Load | Parses associated color schema file and fills internal color info structures.
ParseSection | Parses a single section and creates CXTPSyntaxEditColorInfo object from it.
WriteCfgFile | Use this method to save colors to configuration file.
CXTPSyntaxEditColorTheme Nested Types
CXTPSyntaxEditColorTheme Nested Types | Description
CXTPSyntaxEditMapLexColorInfo | Determines custom array type to store CXTPSyntaxEditColorInfo structures.


CXTPSyntaxEditColorTheme Methods

CXTPSyntaxEditColorTheme Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme Methods
Class

CXTPSyntaxEditColorTheme Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
Cleanup | Cleans up collection.
ParseSection | Parses a single section and creates CXTPSyntaxEditColorInfo object from it.
Public Methods
Public Methods
Public Method | Description
GetColorInfo | Returns color information.
GetFileName | Returns configuration file name.
GetParentTheme | Returns parent schema.
GetParentThemeName | Returns name of the parent schema.
Load | Parses associated color schema file and fills internal color info structures.
WriteCfgFile | Use this method to save colors to configuration file.


CXTPSyntaxEditColorTheme::Cleanup Method

CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::Cleanup Method

Cleans up collection.

void Cleanup();
Group

CXTPSyntaxEditColorTheme Methods


CXTPSyntaxEditColorTheme::GetColorInfo Method

CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::GetColorInfo Method

Returns color information.

CXTPSyntaxEditColorInfo* GetColorInfo(
    const CString& strLexClass,
    const CString& strThemeFilename,
    BOOL bDynamic = TRUE
);
Parameters

strLexClass
[in] Lex Class name string
strThemeFilename
[in] configuration file name string.
bDynamic
[in] If TRUE - search color info in parent themes (dynamically), otherwise it is searched only in this theme.

Returns

Pointer to CXTPSyntaxEditColorInfo object.

Remarks

strThemeFilename is required to avoid calling recursion.

Group

CXTPSyntaxEditColorTheme Methods


CXTPSyntaxEditColorTheme::GetFileName Method

CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::GetFileName Method

Returns configuration file name.

CString GetFileName();
Returns

CString containing file name.

Body Source
CString CXTPSyntaxEditColorTheme::GetFileName() {
    return m_csFileName;
}
Group

CXTPSyntaxEditColorTheme Methods


CXTPSyntaxEditColorTheme::GetParentTheme Method

CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::GetParentTheme Method

Returns parent schema.

CXTPSyntaxEditColorTheme* GetParentTheme();
Returns

Pointer to CXTPSyntaxEditColorTheme object if exists; NULL lf parent schema doesn't exist.

Group

CXTPSyntaxEditColorTheme Methods


CXTPSyntaxEditColorTheme::GetParentThemeName Method

CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::GetParentThemeName Method

Returns name of the parent schema.

const CString GetParentThemeName();
Returns

CString containing name of the parent schema.

Group

CXTPSyntaxEditColorTheme Methods


CXTPSyntaxEditColorTheme::Load Method

CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::Load Method

Parses associated color schema file and fills internal color info structures.

virtual void Load(
    const CString& csFileName
);
Parameters

csFileName
[in] configuration file name string.

Group

CXTPSyntaxEditColorTheme Methods


CXTPSyntaxEditColorTheme::ParseSection Method

CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::ParseSection Method

Parses a single section and creates CXTPSyntaxEditColorInfo object from it.

CXTPSyntaxEditColorInfo * ParseSection(
    const CString& csSection
);
Parameters

csSection
[in] section name (in configuration file) string.

Returns

Pointer to CXTPSyntaxEditColorInfo with resulting colors set.

Group

CXTPSyntaxEditColorTheme Methods


CXTPSyntaxEditColorTheme::WriteCfgFile Method

CXTPSyntaxEditColorTheme Methods, CXTPSyntaxEditColorTheme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::WriteCfgFile Method

Use this method to save colors to configuration file.

BOOL WriteCfgFile(
    CString strParentThemeName,
    CXTPSyntaxEditColorInfoArray* pColorInfoArray_new
);
Parameters

strParentThemeName
The parent theme name.
pColorInfoArray_new
Colors information array.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetFileName

Group

CXTPSyntaxEditColorTheme Methods


CXTPSyntaxEditColorTheme Constructors

CXTPSyntaxEditColorTheme Class, Legend, Public Methods
CXTPSyntaxEditColorTheme Constructors
Class

CXTPSyntaxEditColorTheme Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorTheme | Default object constructor.


CXTPSyntaxEditColorTheme::CXTPSyntaxEditColorTheme Constructor

CXTPSyntaxEditColorTheme Constructors, CXTPSyntaxEditColorTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::CXTPSyntaxEditColorTheme Constructor

Default object constructor.

CXTPSyntaxEditColorTheme(
    CXTPSyntaxEditColorThemesManager* pThemesManager
);
Parameters

pThemesManager
[in] Pointer to the parent themes manager.

Group

CXTPSyntaxEditColorTheme Constructors


CXTPSyntaxEditColorTheme Destructors

CXTPSyntaxEditColorTheme Class, Legend, Public Methods
CXTPSyntaxEditColorTheme Destructors
Class

CXTPSyntaxEditColorTheme Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditColorTheme | Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation.


CXTPSyntaxEditColorTheme::~CXTPSyntaxEditColorTheme Destructor

CXTPSyntaxEditColorTheme Destructors, CXTPSyntaxEditColorTheme Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::~CXTPSyntaxEditColorTheme Destructor

Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation.

virtual ~CXTPSyntaxEditColorTheme();
Group

CXTPSyntaxEditColorTheme Destructors


CXTPSyntaxEditColorTheme Nested Types

CXTPSyntaxEditColorTheme Class, Public Nested Types
CXTPSyntaxEditColorTheme Nested Types
Class

CXTPSyntaxEditColorTheme Class

Public Nested Types
Public Nested Type | Description
CXTPSyntaxEditMapLexColorInfo | Determines custom array type to store CXTPSyntaxEditColorInfo structures.


CXTPSyntaxEditColorTheme::CXTPSyntaxEditMapLexColorInfo Nested Type

CXTPSyntaxEditColorTheme Nested Types, CXTPSyntaxEditColorTheme Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorTheme::CXTPSyntaxEditMapLexColorInfo Nested Type

Determines custom array type to store CXTPSyntaxEditColorInfo structures.

typedef CMap<CString, LPCTSTR, CXTPSyntaxEditColorInfo *, CXTPSyntaxEditColorInfo *> CXTPSyntaxEditMapLexColorInfo;
See Also

CXTPSyntaxEditColorInfo.

Group

CXTPSyntaxEditColorTheme Nested Types


CXTPSyntaxEditColorThemesManager Class

XTPSyntaxEditLexColorFileReader.h, Classes, Legend, Members, Topics, CXTPSyntaxEditColorThemesManager Methods, CXTPSyntaxEditColorThemesManager Constructors, CXTPSyntaxEditColorThemesManager Destructors, CXTPSyntaxEditColorThemesManager Constructors, CXTPSyntaxEditColorThemesManager Destructors, CXTPSyntaxEditColorThemesManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager Class

This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.

Class Hierarchy

class CXTPSyntaxEditColorThemesManager;
File

XTPSyntaxEditLexColorFileReader.h

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditColorThemesManager Constructors
CXTPSyntaxEditColorThemesManager Constructors | Description
CXTPSyntaxEditColorThemesManager | Default object constructor.
CXTPSyntaxEditColorThemesManager Destructors
CXTPSyntaxEditColorThemesManager Destructors | Description
~CXTPSyntaxEditColorThemesManager | Destroys a CXTPSyntaxEditColorThemesManager() object, handles cleanup and de-allocation
CXTPSyntaxEditColorThemesManager Methods
CXTPSyntaxEditColorThemesManager Methods | Description
AddThemeInfo | Adds new entity to "theme name - configuration file" map.
GetTheme | Returns color theme by given name.
GetThemes | Returns CStringArray with themes names.
LoadTheme | Loads theme by given theme name and configuration file.
ReloadFile | Reloads configuration settings from the specified configuration file.
RemoveAll | Remove all loaded data.


CXTPSyntaxEditColorThemesManager Methods

CXTPSyntaxEditColorThemesManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager Methods
Class

CXTPSyntaxEditColorThemesManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddThemeInfo | Adds new entity to "theme name - configuration file" map.
GetTheme | Returns color theme by given name.
GetThemes | Returns CStringArray with themes names.
LoadTheme | Loads theme by given theme name and configuration file.
ReloadFile | Reloads configuration settings from the specified configuration file.
RemoveAll | Remove all loaded data.


CXTPSyntaxEditColorThemesManager::AddThemeInfo Method

CXTPSyntaxEditColorThemesManager Methods, CXTPSyntaxEditColorThemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager::AddThemeInfo Method

Adds new entity to "theme name - configuration file" map.

void AddThemeInfo(
    const CString& strThemeName,
    const CString& strThemeFilename
);
Parameters

strThemeName
[in] theme name string.
strThemeFilename
[in] configuration file name.

Group

CXTPSyntaxEditColorThemesManager Methods


CXTPSyntaxEditColorThemesManager::GetTheme Method

CXTPSyntaxEditColorThemesManager Methods, CXTPSyntaxEditColorThemesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager::GetTheme Method

Returns color theme by given name.

CXTPSyntaxEditColorTheme* GetTheme(
    const CString& strThemeName
);
Parameters

strThemeName
[in] theme name string.

Returns

Pointer to CXTPSyntaxEditColorTheme.

See Also

class CXTPSyntaxEditColorTheme

Group

CXTPSyntaxEditColorThemesManager Methods


CXTPSyntaxEditColorThemesManager::GetThemes Method

CXTPSyntaxEditColorThemesManager Methods, CXTPSyntaxEditColorThemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager::GetThemes Method

Returns CStringArray with themes names.

CStringArray& GetThemes();
Returns

CStringArray with themes names.

Group

CXTPSyntaxEditColorThemesManager Methods


CXTPSyntaxEditColorThemesManager::LoadTheme Method

CXTPSyntaxEditColorThemesManager Methods, CXTPSyntaxEditColorThemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager::LoadTheme Method

Loads theme by given theme name and configuration file.

void LoadTheme(
    const CString& strThemeName,
    const CString& strThemeFilename
);
Parameters

strThemeName
[in] theme name string.
strThemeFilename
[in] configuration file name.

Group

CXTPSyntaxEditColorThemesManager Methods


CXTPSyntaxEditColorThemesManager::ReloadFile Method

CXTPSyntaxEditColorThemesManager Methods, CXTPSyntaxEditColorThemesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager::ReloadFile Method

Reloads configuration settings from the specified configuration file.

CString ReloadFile(
    const CString& csFileName,
    int nCfgFlags = 0
);
Parameters

csFileName
[in] configuration file name.
nCfgFlags
[in] action flags.

Returns

Reloaded Theme name if found, or empty string if theme was not found.

Remarks

Does nothing if specified file is not found in the collection of files from the main configuration file.

See Also

enum XTPSyntaxEditCfgFileRemove.

Group

CXTPSyntaxEditColorThemesManager Methods


CXTPSyntaxEditColorThemesManager::RemoveAll Method

CXTPSyntaxEditColorThemesManager Methods, CXTPSyntaxEditColorThemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager::RemoveAll Method

Remove all loaded data.

void RemoveAll();
Group

CXTPSyntaxEditColorThemesManager Methods


CXTPSyntaxEditColorThemesManager Constructors

CXTPSyntaxEditColorThemesManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager Constructors
Class

CXTPSyntaxEditColorThemesManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorThemesManager | Default object constructor.


CXTPSyntaxEditColorThemesManager::CXTPSyntaxEditColorThemesManager Constructor

CXTPSyntaxEditColorThemesManager Constructors, CXTPSyntaxEditColorThemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager::CXTPSyntaxEditColorThemesManager Constructor

Default object constructor.

CXTPSyntaxEditColorThemesManager();
Group

CXTPSyntaxEditColorThemesManager Constructors


CXTPSyntaxEditColorThemesManager Destructors

CXTPSyntaxEditColorThemesManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager Destructors
Class

CXTPSyntaxEditColorThemesManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditColorThemesManager | Destroys a CXTPSyntaxEditColorThemesManager() object, handles cleanup and de-allocation


CXTPSyntaxEditColorThemesManager::~CXTPSyntaxEditColorThemesManager Destructor

CXTPSyntaxEditColorThemesManager Destructors, CXTPSyntaxEditColorThemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditColorThemesManager::~CXTPSyntaxEditColorThemesManager Destructor

Destroys a CXTPSyntaxEditColorThemesManager() object, handles cleanup and de-allocation

virtual ~CXTPSyntaxEditColorThemesManager();
Group

CXTPSyntaxEditColorThemesManager Destructors


CXTPSyntaxEditCommand Class

XTPSyntaxEditUndoManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditCommand Data Members, CXTPSyntaxEditCommand Methods, CXTPSyntaxEditCommand Constructors, CXTPSyntaxEditCommand Destructors, CXTPSyntaxEditCommand Constructors, CXTPSyntaxEditCommand Data Members, CXTPSyntaxEditCommand Destructors, CXTPSyntaxEditCommand Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand Class

This class represents abstract Edit Control command interface. Its descendants must implement custom Execute and UnExecute functionality depending on a command type.

This class is used internally by the library only.

Class Hierarchy

class CXTPSyntaxEditCommand : public CObject;
File

XTPSyntaxEditUndoManager.h

See Also

CXTPSyntaxEditUndoRedoManager, CXTPSyntaxEditBatchCommand, CXTPSyntaxEditBufferCommand

Group

Classes

Legend
Data Member
protected
Method
abstract
virtual
CXTPSyntaxEditCommand Constructors
CXTPSyntaxEditCommand Constructors | Description
CXTPSyntaxEditCommand | Protected constructor because this class could not be instantiated itself, only by its descendants
CXTPSyntaxEditCommand Data Members
CXTPSyntaxEditCommand Data Members | Description
m_strCommandText | A text description of the command.
CXTPSyntaxEditCommand Destructors
CXTPSyntaxEditCommand Destructors | Description
~CXTPSyntaxEditCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.
CXTPSyntaxEditCommand Methods
CXTPSyntaxEditCommand Methods | Description
Execute | This is an interface function for operation execution.
GetCommandText | This function is responsible for retrieving action description text. Each command have a string describing contained changes, for example for showing in the multiple Undo/Redo dialogs, i.e. "Typing: something", "Delete", "Paste", etc. This function allows a command to overwrite its own command text retrieving, for example for adding any specific suffix/prefix, etc.
GetDataSize | This member function used to get undo command data size (in bytes).
SetCommandText | This function is responsible for redefining action description text. It allows a command to overwrite command text setting behavior, for example making a text as a suffix/prefix of the description, etc.
SetPositionInternally | Sets line and a column position for the specified control using internal fast methods.
UnExecute | This is an interface function for operation undoing.


CXTPSyntaxEditCommand Data Members

CXTPSyntaxEditCommand Class, Legend, Protected Data Members
CXTPSyntaxEditCommand Data Members
Class

CXTPSyntaxEditCommand Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_strCommandText | A text description of the command.


CXTPSyntaxEditCommand::m_strCommandText Data Member

CXTPSyntaxEditCommand Data Members, CXTPSyntaxEditCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand::m_strCommandText Data Member

A text description of the command.

CString m_strCommandText;
Group

CXTPSyntaxEditCommand Data Members


CXTPSyntaxEditCommand Methods

CXTPSyntaxEditCommand Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand Methods
Class

CXTPSyntaxEditCommand Class

Legend
Method
abstract
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
SetPositionInternally | Sets line and a column position for the specified control using internal fast methods.
Public Methods
Public Methods
Public Method | Description
Execute | This is an interface function for operation execution.
GetCommandText | This function is responsible for retrieving action description text. Each command have a string describing contained changes, for example for showing in the multiple Undo/Redo dialogs, i.e. "Typing: something", "Delete", "Paste", etc. This function allows a command to overwrite its own command text retrieving, for example for adding any specific suffix/prefix, etc.
GetDataSize | This member function used to get undo command data size (in bytes).
SetCommandText | This function is responsible for redefining action description text. It allows a command to overwrite command text setting behavior, for example making a text as a suffix/prefix of the description, etc.
UnExecute | This is an interface function for operation undoing.


CXTPSyntaxEditCommand::Execute Method

CXTPSyntaxEditCommand Methods, CXTPSyntaxEditCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand::Execute Method

This is an interface function for operation execution.

virtual int Execute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
) = 0;
Parameters

lcFrom
[out] Start text position affected by the action.
lcTo
[out] End text position affected by the action.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

UnExecute

Group

CXTPSyntaxEditCommand Methods


CXTPSyntaxEditCommand::GetCommandText Method

CXTPSyntaxEditCommand Methods, CXTPSyntaxEditCommand Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand::GetCommandText Method

This function is responsible for retrieving action description text.

Each command have a string describing contained changes, for example for showing in the multiple Undo/Redo dialogs, i.e. "Typing: something", "Delete", "Paste", etc.

This function allows a command to overwrite its own command text retrieving, for example for adding any specific suffix/prefix, etc.

virtual LPCTSTR GetCommandText();
Returns

Command description string.

See Also

SetCommandText

Body Source
LPCTSTR CXTPSyntaxEditCommand::GetCommandText() {
    return m_strCommandText;
}
Group

CXTPSyntaxEditCommand Methods


CXTPSyntaxEditCommand::GetDataSize Method

CXTPSyntaxEditCommand Methods, CXTPSyntaxEditCommand Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand::GetDataSize Method

This member function used to get undo command data size (in bytes).

virtual int GetDataSize();
Returns

Undo command data size (in bytes).

Body Source
int CXTPSyntaxEditCommand::GetDataSize() {
    return 0;
}
Group

CXTPSyntaxEditCommand Methods


CXTPSyntaxEditCommand::SetCommandText Method

CXTPSyntaxEditCommand Methods, CXTPSyntaxEditCommand Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand::SetCommandText Method

This function is responsible for redefining action description text.

It allows a command to overwrite command text setting behavior, for example making a text as a suffix/prefix of the description, etc.

virtual void SetCommandText(
    LPCTSTR szText
);
Parameters

szText
[in] New description string for the command.

See Also

GetCommandText

Body Source
void CXTPSyntaxEditCommand::SetCommandText(LPCTSTR szText) {
    m_strCommandText = szText;
}
Group

CXTPSyntaxEditCommand Methods


CXTPSyntaxEditCommand::SetPositionInternally Method

CXTPSyntaxEditCommand Methods, CXTPSyntaxEditCommand Class
CXTPSyntaxEditCommand::SetPositionInternally Method

Sets line and a column position for the specified control using internal fast methods.

static void SetPositionInternally(
    CXTPSyntaxEditCtrl* pEditCtrl,
    const XTP_EDIT_LINECOL& lcPos
);
Parameters

pEditCtrl
[in] A pointer to edit control.
lcPos
[in] A text position to set to the edit control.

Group

CXTPSyntaxEditCommand Methods


CXTPSyntaxEditCommand::UnExecute Method

CXTPSyntaxEditCommand Methods, CXTPSyntaxEditCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand::UnExecute Method

This is an interface function for operation undoing.

virtual int UnExecute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
) = 0;
Parameters

lcFrom
[out] Start text position affected by the action.
lcTo
[out] End text position affected by the action.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

Execute

Group

CXTPSyntaxEditCommand Methods


CXTPSyntaxEditCommand Constructors

CXTPSyntaxEditCommand Class, Legend, Protected Methods
CXTPSyntaxEditCommand Constructors
Class

CXTPSyntaxEditCommand Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSyntaxEditCommand | Protected constructor because this class could not be instantiated itself, only by its descendants


CXTPSyntaxEditCommand::CXTPSyntaxEditCommand Constructor

CXTPSyntaxEditCommand Constructors, CXTPSyntaxEditCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand::CXTPSyntaxEditCommand Constructor

Protected constructor because this class could not be instantiated itself, only by its descendants

CXTPSyntaxEditCommand();
Group

CXTPSyntaxEditCommand Constructors


CXTPSyntaxEditCommand Destructors

CXTPSyntaxEditCommand Class, Legend, Public Methods
CXTPSyntaxEditCommand Destructors
Class

CXTPSyntaxEditCommand Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.


CXTPSyntaxEditCommand::~CXTPSyntaxEditCommand Destructor

CXTPSyntaxEditCommand Destructors, CXTPSyntaxEditCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCommand::~CXTPSyntaxEditCommand Destructor

A default command destructor. Destroys the command object, handles its cleanup and de-allocation.

virtual ~CXTPSyntaxEditCommand();
Group

CXTPSyntaxEditCommand Destructors


CXTPSyntaxEditConfigurationManager Class

XTPSyntaxEditLexColorFileReader.h, Classes, Legend, Members, Topics, CXTPSyntaxEditConfigurationManager Enumerations, CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Constructors, CXTPSyntaxEditConfigurationManager Destructors, CXTPSyntaxEditConfigurationManager Constructors, CXTPSyntaxEditConfigurationManager Destructors, CXTPSyntaxEditConfigurationManager Enumerations, CXTPSyntaxEditConfigurationManager Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager Class

This class manages all configuration parameters of the control. It worries about read configuration files from disk when the Edit control is starting, store it in internal structures and refresh parameters in case configuration files are changed after control was started.

Class Hierarchy

class CXTPSyntaxEditConfigurationManager;
File

XTPSyntaxEditLexColorFileReader.h

See Also

CXTPSyntaxEditFileChangesMonitor, CXTPSyntaxEditColorThemesManager

Group

Classes

Legend
Enumeration
Method
virtual
CXTPSyntaxEditConfigurationManager Constructors
CXTPSyntaxEditConfigurationManager Constructors | Description
CXTPSyntaxEditConfigurationManager | Default object constructor.
CXTPSyntaxEditConfigurationManager Destructors
CXTPSyntaxEditConfigurationManager Destructors | Description
~CXTPSyntaxEditConfigurationManager | Destroys a CXTPSyntaxEditConfigurationManager() object, handles cleanup and de-allocation
CXTPSyntaxEditConfigurationManager Enumerations
CXTPSyntaxEditConfigurationManager Enumerations | Description
XTPSyntaxEditCfgObjects | Configuration manager sub-objects
CXTPSyntaxEditConfigurationManager Methods
CXTPSyntaxEditConfigurationManager Methods | Description
Close | Closes configuration monitor session.
GetConfigFile | Get main configuration file name.
GetConnection | Returns notification connection.
GetCurrentTheme | Returns current theme name.
GetTextSchemesManager | Returns text theme manager.
GetThemeManager | Returns color theme manager.
ReloadConfig |
ReloadConfigAsync | Asynchronously reloads configuration settings from the stored main configuration file.
ReloadFile | Reloads configuration settings from the specified configuration file.
SetTheme | Use this member function to set current theme.


CXTPSyntaxEditConfigurationManager Enumerations

Enumerations, CXTPSyntaxEditConfigurationManager Class, Legend
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager Enumerations
Enumerations
Enumeration | Description
XTPSyntaxEditCfgObjects | Configuration manager sub-objects
Class

CXTPSyntaxEditConfigurationManager Class

Legend
Enumeration


CXTPSyntaxEditConfigurationManager::XTPSyntaxEditCfgObjects Enumeration

XTPSyntaxEditLexColorFileReader.h, CXTPSyntaxEditConfigurationManager Enumerations
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::XTPSyntaxEditCfgObjects Enumeration

Configuration manager sub-objects

enum XTPSyntaxEditCfgObjects {
  xtpEditCfgObjSchMan = 0x0001,
  xtpEditCfgObjThemeMan = 0x0002,
  xtpEditCfgObjMainConfig = 0x0004
};
File

XTPSyntaxEditLexColorFileReader.h

Members

xtpEditCfgObjSchMan
Schemes manager
xtpEditCfgObjThemeMan
Themes manager
xtpEditCfgObjMainConfig
Main configuration file

Group

CXTPSyntaxEditConfigurationManager Enumerations


CXTPSyntaxEditConfigurationManager Methods

CXTPSyntaxEditConfigurationManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager Methods
Class

CXTPSyntaxEditConfigurationManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Close | Closes configuration monitor session.
GetConfigFile | Get main configuration file name.
GetConnection | Returns notification connection.
GetCurrentTheme | Returns current theme name.
GetTextSchemesManager | Returns text theme manager.
GetThemeManager | Returns color theme manager.
ReloadConfig |
ReloadConfigAsync | Asynchronously reloads configuration settings from the stored main configuration file.
ReloadFile | Reloads configuration settings from the specified configuration file.
SetTheme | Use this member function to set current theme.


CXTPSyntaxEditConfigurationManager::Close Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::Close Method

Closes configuration monitor session.

void Close();
Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager::GetConfigFile Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::GetConfigFile Method

Get main configuration file name.

CString GetConfigFile() const;
Returns

Main configuration file name.

Remarks

Return configuration file name previously stored by ReloadConfig(configFile).

See Also

CXTPSyntaxEditConfigurationManager::ReloadConfig().

Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager::GetConnection Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::GetConnection Method

Returns notification connection.

CXTPNotifyConnection* GetConnection();
Returns

CXTPNotifyConnectionPtr pointer.

Body Source
CXTPNotifyConnection* CXTPSyntaxEditConfigurationManager::GetConnection() {
    return m_pConnectMT;
}
Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager::GetCurrentTheme Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::GetCurrentTheme Method

Returns current theme name.

const CString& GetCurrentTheme();
Body Source
const CString& CXTPSyntaxEditConfigurationManager::GetCurrentTheme() {
    return m_strCurrentThemeName;
}
Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager::GetTextSchemesManager Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::GetTextSchemesManager Method

Returns text theme manager.

CXTPSyntaxEditTextSchemesManager& GetTextSchemesManager();
Returns

Reference to CXTPSyntaxEditTextSchemesManager object.

Body Source
CXTPSyntaxEditTextSchemesManager& CXTPSyntaxEditConfigurationManager::GetTextSchemesManager() {
    return m_TextSchemesManager;
}
Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager::GetThemeManager Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::GetThemeManager Method

Returns color theme manager.

CXTPSyntaxEditColorThemesManager& GetThemeManager();
Returns

Reference to CXTPSyntaxEditColorThemesManager object.

Body Source
CXTPSyntaxEditColorThemesManager& CXTPSyntaxEditConfigurationManager::GetThemeManager() {
    return m_ColorThemeManager;
}
Group

CXTPSyntaxEditConfigurationManager Methods


ReloadConfig Method

CXTPSyntaxEditConfigurationManager Methods
ReloadConfig Method
Overload List
Methods
Method | Description
CXTPSyntaxEditConfigurationManager::ReloadConfig () | Reloads configuration settings from the stored main configuration file.
CXTPSyntaxEditConfigurationManager::ReloadConfig (const CString&) | Reloads settings from provided file.
Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager::ReloadConfig Method ()

ReloadConfig Method, CXTPSyntaxEditConfigurationManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::ReloadConfig Method ()

Reloads configuration settings from the stored main configuration file.

void ReloadConfig();
Group

ReloadConfig Method


CXTPSyntaxEditConfigurationManager::ReloadConfig Method (const CString&)

ReloadConfig Method, CXTPSyntaxEditConfigurationManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::ReloadConfig Method (const CString&)

Reloads settings from provided file.

void ReloadConfig(
    const CString& strConfigFilePath
);
Parameters

strConfigFilePath
string of file's full path.

Remarks

Reloads configuration settings from the specified new configuration file.

Group

ReloadConfig Method


CXTPSyntaxEditConfigurationManager::ReloadConfigAsync Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::ReloadConfigAsync Method

Asynchronously reloads configuration settings from the stored main configuration file.

void ReloadConfigAsync(
    int nAsyncThreadPriority = THREAD_PRIORITY_NORMAL
);
Parameters

nAsyncThreadPriority
The priority for the working thread which reloads configuration.

Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager::ReloadFile Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::ReloadFile Method

Reloads configuration settings from the specified configuration file.

void ReloadFile(
    CString csFileName,
    DWORD dwOwnerFlags,
    int nCfgFlags = 0
);
Parameters

csFileName
[in] configuration file name.
nCfgFlags
[in] action flags.

Returns

Reloaded Theme name if found, or empty string if theme was not found.

Remarks

Does nothing if specified file is not found in the collection of files from the main configuration file.

See Also

enum XTPSyntaxEditCfgFileRemove.

Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager::SetTheme Method

CXTPSyntaxEditConfigurationManager Methods, CXTPSyntaxEditConfigurationManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::SetTheme Method

Use this member function to set current theme.

void SetTheme(
    const CString& strThemeName,
    CXTPSyntaxEditTextSchema* pActiveSch = NULL
);
Parameters

strThemeName
[in] Theme name.
pActiveSch
[in] A pointer to active schema to apply current theme.

Group

CXTPSyntaxEditConfigurationManager Methods


CXTPSyntaxEditConfigurationManager Constructors

CXTPSyntaxEditConfigurationManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager Constructors
Class

CXTPSyntaxEditConfigurationManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditConfigurationManager | Default object constructor.


CXTPSyntaxEditConfigurationManager::CXTPSyntaxEditConfigurationManager Constructor

CXTPSyntaxEditConfigurationManager Constructors, CXTPSyntaxEditConfigurationManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::CXTPSyntaxEditConfigurationManager Constructor

Default object constructor.

CXTPSyntaxEditConfigurationManager();
Group

CXTPSyntaxEditConfigurationManager Constructors


CXTPSyntaxEditConfigurationManager Destructors

CXTPSyntaxEditConfigurationManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager Destructors
Class

CXTPSyntaxEditConfigurationManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditConfigurationManager | Destroys a CXTPSyntaxEditConfigurationManager() object, handles cleanup and de-allocation


CXTPSyntaxEditConfigurationManager::~CXTPSyntaxEditConfigurationManager Destructor

CXTPSyntaxEditConfigurationManager Destructors, CXTPSyntaxEditConfigurationManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditConfigurationManager::~CXTPSyntaxEditConfigurationManager Destructor

Destroys a CXTPSyntaxEditConfigurationManager() object, handles cleanup and de-allocation

virtual ~CXTPSyntaxEditConfigurationManager();
Group

CXTPSyntaxEditConfigurationManager Destructors


CXTPSyntaxEditCtrl Class

XTPSyntaxEditCtrl.h, Classes, Legend, Members, Topics, CXTPSyntaxEditCtrl Classes, CXTPSyntaxEditCtrl Enumerations, CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Constructors, CXTPSyntaxEditCtrl Destructors, CXTPSyntaxEditCtrl Operators, CXTPSyntaxEditCtrl Classes, CXTPSyntaxEditCtrl Constructors, CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Destructors, CXTPSyntaxEditCtrl Enumerations, Example, CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl Class

This class is the main CWnd - based editor class. It is a rectangular child window in which the user can enter and edit text.

The control is also capable of enhance text coloring for a number of specific input file types, e.c. C/C++ source files, HTML files, etc. User can create and customize his own text files schemes - they are independent of source files. The control contains the main configuration file, which can contain references to any specific configuration files. By default, this file is placed in the same folder as the application executable and is called EditControl.ini. The main configuration file contains 2 blocks with references to input file lexicographic schemes in the specific format (see below) and color themes for the editor, which could be applied to the control editing any file type. The format of the main configuration file is the following:

[Schemas]
FileType1=SchemaFileName1.schclass
FileType2=SchemaFileName2.schclass
...

[Themes]
ThemeName1=ThemeFileName1.ini
ThemeName2=ThemeFileName2.ini
...
Class Hierarchy

class CXTPSyntaxEditCtrl : public CWnd;
File

XTPSyntaxEditCtrl.h

See Also

LexSchemas

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
Operator
CXTPSyntaxEditCtrl Classes
CXTPSyntaxEditCtrl Classes | Description
CAverageVal | CXTPSyntaxEditCtrl::CAverageVal
CScreenSearchBlock | CXTPSyntaxEditCtrl::CScreenSearchBlock
CScreenSearchCache | CXTPSyntaxEditCtrl::CScreenSearchCache
CTextSearchCache | CXTPSyntaxEditCtrl::CTextSearchCache
CXTPSyntaxEditCtrl Constructors
CXTPSyntaxEditCtrl Constructors | Description
CXTPSyntaxEditCtrl | Default object constructor.
CXTPSyntaxEditCtrl Data Members
CXTPSyntaxEditCtrl Data Members | Description
m_arCollapsedTextRows | The array of rows with beginning of collapsed blocks.
m_arOnScreenSchCache | On-screen schema cache for this control.
m_arValidDispRows | An array with indexes of valid displayed rows.
m_bAutoIndent | Auto indentation is enabled or not
m_bCaseSensitive | Case sensitive
m_bCreateScrollbarOnParent | TRUE if parent window scroll bars are used, otherwise FALSE.
m_bDeleteOnFinalRelease | If TRUE - Delete self OnFinalRelease() call.
m_bDisableRedraw | If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).
m_bDragging | TRUE if in dragging mode
m_bDrawNodes | TRUE if Collapsible nodes signs are to be printed
m_bDroppable | TRUE if the current position is droppable
m_bEnableEditAccelerators | Enable/disable accelerators for Cut, Copy, Paste, Undo, Redoo and Select All operations.
m_bEnableOleDrag | Enables or disables OLE drag drop
m_bEnableWhiteSpace | Show white space
m_bFocused | States if focused or not
m_bHideCaret | Store is caret visible.
m_bHorzScrollBar | TRUE if vertical scrollbar is to be enabled
m_bIsActive | TRUE if application is active.
m_bIsDragging | TRUE if dragging, FALSE otherwise
m_bIsScrollingEndRow | Maintains a internal logic to draw the last row which is partly visible
m_bIsSmartIndent | Smart indentation is enabled or not
m_bLineNumbers | TRUE if line number is to be printed
m_bmpCache | Current view cached picture
m_bPageDirty | TRUE if the whole page is dirty
m_bReadOnly | Store ReadOnly mode.
m_bRightButtonDrag | TRUE if user is dragging through right button
m_bScrolling | Temporary variable to specify if scrolling by mouse wheel
m_bSelMargin | TRUE if selection margin is to be enabled or not
m_bSyntaxColor | Enables or disables syntax colorization
m_bTabWithSpace | Store tabulation width.
m_bTokensLoaded | Specifies if tokens are loaded or not
m_bVertScrollBar | TRUE if horizontal scrollbar is to be enabled
m_bVirtualSpace | TRUE if virtual space is enabled (cursor can be paced in any place after line end).
m_bWideCaret | Stored Overwrite Caret Style: Thin or Thick.
m_bWndCreateInProgress | Internal flag to indicate that windows creating is in progress.
m_chPrevLeadByte | For none-UNICODE version IME sends double byte chars as 2 WM_CHAR messages.
m_DrawTextProcessor |
m_dwAutoScrollDirection | Store active autoscroll direction.
m_dwInsertPos | Current insert position
m_dwLastRedrawTime | Stores last redrawing time
m_fcCollapsable | Collapsible rows cache
m_fcRowColors | Row colors cache
m_mapRowBkColor | The map for row back colors (cache)
m_mapRowColor | The map for row colors (cache)
m_nAutoIndentCol | Contains the column for auto indentation
m_nAverageLineLen | Average length of line
m_nBottomCalculatedRow | Bottom row of the last range of rows that have scrollbars properly calculated
m_nCollapsedTextRowsCount | The total amount of collapsed blocks in the document,
m_nCurrentCol | Current absolute column
m_nCurrentDocumentRow | Current row in the document
m_nDispCol | Current display column
m_nEditbarLength | Edit bar length including gutter and line number
m_nHScrollMaxWidth | Maximum horizontal scrollbar position.
m_nInsertSpaceCount | Temporarily stores the no of space to be inserted for auto indentation
m_nInsertTabCount | Temporarily stores the no of tabs to be inserted for auto indentation
m_nLineNumLength | Line numbers length
m_nMarginLength | Margin length
m_nNodesWidth | The width of the nodes signs
m_nTopCalculatedRow | Top row of the last range of rows that have scrollbars properly calculated
m_nTopRow | Top row for display
m_nWheelScroll | Lines to scroll on mouse wheel
m_pAutoComplete | Auto complete popup window.
m_pBuffer | The buffer manager
m_pPaintManeger | The paint manager
m_pParentWnd | Points to parent window.
m_ptDropPos | Specifies the drop position
m_pToolTip | Tool tip window for collapsed blocks text.
m_ptPrevMouse | Stored mouse position of the previous tip showing.
m_strDefaultCfgFilePath | Store configuration file full name.
m_strTmpLineTextBuff | Temporary text buffer
CXTPSyntaxEditCtrl Destructors
CXTPSyntaxEditCtrl Destructors | Description
~CXTPSyntaxEditCtrl | Destroys a CXTPSyntaxEditCtrl object, handles cleanup and de- allocation
CXTPSyntaxEditCtrl Enumerations
CXTPSyntaxEditCtrl Enumerations | Description
XTPScrolDirection | This enum defines flags for autoscroll direction.
CXTPSyntaxEditCtrl Methods
CXTPSyntaxEditCtrl Methods | Description
_EnableScrollBarNotify | This method used to notify parent window that scrollbar state changed.
_RecalcHScrollMaxWidth | Recalculates and set m_nHScrollMaxWidth member depending on the visible text size.
_RecalcScrollBars | Recalculates and set the scroll bars depending on the text size and current position.
_SubtractSelSizeFromPos | This method used to subtract selection size from the specified position.
_UpdateIMEStatus | This member function is called to update Is IME mode supported at the current time.
AddRemoveBookmark | Sets Bookmark shape at specified row.
AddRemoveBreakPoint | Sets Breakpoint shape at specified row.
ApplyTheme | Applies the theme with the specified name onto the editor.
CalcAbsCol |
CalcAveDataSize | Calculates an average line length from start row to end row.
CalcDispCol |
CalcEditRects | This method used to calculate the edit control regions.
CalcMaximumWidth | Calculates the maximum width for a text.
CalculateDocumentRow | Calculates document row basing in global visible row.
CalculateEditbarLength | Calculates the edit bar length and stores it into m_nEditbarLength member variable depending upon the gutter length and visibility and line number length and visibility.
CalculateVisibleRow | Calculates global visible row basing in document row.
CalcValidDispCol | Calculate and returns the display column for another display column specified in the iCol parameter.
CancelRightButtonDrag | Cancels right button drag.
CanEditDoc | Determines if a document can be modified by checking ReadOnly property value and sending XTP_EDIT_NM_EDITCHANGING notification to parent.
CanRedo | Returns flag which determines if Redo can be made.
CanUndo | Returns flag which determines if Undo can be made.
ClearOnScreenSchCache | Clears a screen schema cache.
CollapseAll | Collapses all expanded collapsible nodes.
CollapseExpandBlock | Expands/Collapses block at specified row.
Copy | Copies the selected text to clipboard.
CopyOrMoveText | Copy or move text after dragging.
Create | Creates the window
CreateInsertText | Fills and/or calculates number of tabs or blank spaces required.
Cut | Copies the selected text to clipboard and deletes it from document.
DecreaseIndent | Deletes tab from the front of a selection.
DeleteBookmark | Removes Breakpoint shape at specified row.
DeleteBreakpoint | Removes Breakpoint shape at specified row.
DeleteBuffer | Deletes a given range of text.
DeleteChar | Deletes a character at specified location.
DeleteSelectedLines | Deletes all the lines in a selection or a specific line in the case if no selection exists.
DeleteSelection | Deletes the currently selected text.
DoAutoIndentIfNeed | This method used to set variables for autoindent.
DoChangeSelectionCase | Changes the case of the selection.
DoChangeSelectionTabify | Changes the tabification of the selection.
DoUndoRedo | Performs Undo/Redo operations and common control properties adjustment.
Draw | This method used to draw the edit control client area.
EnableEditAccelerators | Call this member function to enable or disable standard editor accelerators processing. By default this feature is off.
EnableOleDrag | Enables or disables OLE drag drop mode.
EnableScrollBarCtrl | Enables or disables the scroll bar.
EnableVirtualSpace | Enables/disables a Virtual Space mode. Call tis member function to enable or disable showing white spaces facility. Pass TRUE if white space should be shown, FALSE otherwise.
EnableWhiteSpace | Enables/disables showing white spaces. Call tis member function to enable or disable showing white spaces facility. Pass TRUE if white space should be shown, FALSE otherwise.
EnsureVisibleCol |
EnsureVisibleRow | Scrolls the window to a specific location where the specified row or col are visible.
ExpandAll | Expands all collapsed nodes.
ExpandChars | Expands the character set by putting space in the position of tab.
FillTabs | Add number of tabs and spaces required to reach nDispColl.
Find | Finds a certain text with some parameters for find.
FindWord | Find the next(or previouse) word position depending on the parameter supplied.
FindWordEx |
FindWordEx_str |
GetAutoCompleteWnd | This method used to get Auto-Complete window.
GetAutoIndent | Returns state of auto intend.
GetAutoscrollDirection | This method used to determine scroll direction for automatic scrolling (when selecting by mouse).
GetBlockFromPt | Finds collapsed block on the specified point if exist.
GetCollapsableBlocksInfo | This member function is used to retrieve collapsable text blocks for the specified row. It is called by the edit control.
GetCollapsedBlockLen | Gets length of collapsed block.
GetCollapsedText | Returns a collapsed text for the specified collapsed block.
GetCollapsibleNodes | Determines if Collapsible Nodes is enabled or not.
GetConfigFile | Returns main configuration file name.
GetCurAbsCol | Returns the current absolute horizontal text position. Call this member function to determine the current absolute text position, mainly used in text insert or delete operations. Treats tabs as one character.
GetCurCol | Returns the current column.
GetCurrentDocumentRow | Returns current document row number.
GetCurrentTheme | Returns current theme name.
GetCurrentVisibleRow | Returns current visible row number.
GetCurRow | Returns the current document row
GetDefaultCfgFilePath | Returns a filename of the default ini configuration file.
GetDocumentRow | Calculates document row basing in visible row.
GetDrawTextProcessor | Use this method to get draw text processor object.
GetEditBuffer | Returns a buffer manager which maintains a buffer of a smart edit control.
GetEffectiveParent | Returns the effective parent.
GetHorzScrollBar | Returns the if horizontal scrollbar is enabled.
GetLexConfigurationManager | Use this method to get associated configuration manager.
GetLineMarksManager | Returns a pointer to the line marks manager associated with the current text buffer.
GetLineNodeRect | Calculates rect(s) for Collapsible node icon
GetLineNumbers | Determines if line numbering is enabled or not.
GetLineText |
GetModulePath | Returns a path of the executable file module.
GetOnScreenSch | Returns a pointer to the screen schema cache.
GetPaintManager | Use this method to get paint manager object.
GetRedoTextList | Returns the list of text for redo operations.
GetRegValues | Use this method to read options from the registry.
GetRowBkColor | Returns the background color of the specified row in the colors cache.
GetRowColor | Gets the text color of the specified row in the colors cache.
GetRowColors | This member function is used to retrieve text colors for the specified row. It is called by the edit control from drawing procedure.
GetRowCount | Returns the number of rows in the current document.
GetRowNodes | Gets the type of row node.
GetRowPerPage | Returns the number of rows can be printed per page.
GetScrollBarCtrl | Return pointer to the specified CScrollBar object.
GetScrollInfo | Retrieves the scrollbar information
GetScrollLimit | Returns max scroll position identifier.
GetScrollPos | Retrieves the position of the scroll box.
GetScrollRange | Retrieves the scroll bar range.
GetSelection | This method used to get current selection.
GetSelectionBuffer | Returns a handle of selection buffer. Call this member function get a handle of a selection buffer in the global memory in one of the clipboard format of CF_TEXT or CF_UNICODETEXT. Mainly used in OLE drag drop operation.
GetSelectionText | Returns the selected text.
GetSelMargin | Returns gutter state.
GetSyntaxColor | Return state of syntax colorization. Call this member function to determine current syntax colorization state.
GetTabSize | Returns the tab size.
GetTabWithSpace | Returns the status if tab should be replaced by space.
GetText |
GetThemes | Returns an array of available theme names from the configuration manager.
GetTopRow | Returns top row identifier.
GetUndoTextList | Returns the list of text for undo operations.
GetVertScrollBar | Returns the if vertical scrollbar is enabled.
GetVisibleRow | Calculates visible row basing in document row.
GetVisibleRowsCount | Returns maximum visible rows count.
GetWideCaret | Determines if thin caret is set for overwrite mode.
GoToRow | Call this method to move to the row
HandleDrop | Handle the drop operation within the same edit buffer.
HasBookmarks | Determines if the current document has bookmarks.
HasBreakpoints | Determines if the current document has breakpoints.
HasRowMark | Retrieves a row mark for the specified row.
IncreaseIndent | Inserts tab in front of a selection.
InsertRow | Use this member function to insert new row.
InsertString | Inserts a string at specified row and col.
InsertTextBlock | Inserts a vertical text block at specified row and col.
InvalidateRow | Invalidates required row.
InvalidateRows | Invalidates given set of rows
IsActive | Call this member function to determine if the edit control has been activated or deactivated.
IsCreateScrollbarOnParent | Call this member function to determine if the edit control create and use scroll bars on parent window.
IsEnabledEditAccelerators | Determines if editor internally catch standard editor accelerators: Ctrl+C, Ctrl+V, Ctrl+X, Ctrl+Y, Ctrl+Z, Ctrl+Shift+Z, Ctrl+A, Ctrl+Ins, Shift+Ins, Alt+Backspace.
IsEnabledVirtualSpace | Returns the status of Virtual Space mode.
IsEnabledWhiteSpace | Returns the status if white space should be shown or not.
IsHideCaret | Determines is the caret visible or not.
IsReadOnly | Determines if editor in read-only mode.
IsRightButtonDrag | Returns state flag of mouse right button for drag or not.
IsRowValid | Returns valid row flag.
IsRowVisible | Returns visibility status for given row.
IsSelectionExist | Returns boolean selection existence flag.
LowercaseSelection | Turns selected text to the lowercase.
MatchText | Try to match text on the supplied parameters.
MoveCurrentVisibleRowDown | Moves current row down on a number of rows.
MoveCurrentVisibleRowUp | Moves current row up on a number of rows.
NextBookmark | Moves the current position to the next bookmark.
NotifyCurRowCol | Sends notification when current text position was changed.
NotifyEditChanged | Send XTP_EDIT_NM_EDITCHANGED notification with specified parameters.
NotifyMarginLBtnClick | Send any notification to parent that user click in the bookmark area.
NotifyMouseEvent | Send any mouse notification to parent.
NotifyParent | Send any notification to parent.
NotifyParseEvent | Send WM_NOTIFY with XTP_EDIT_NM_PARSEEVENT code to parent window.
NotifySelInit | Initialize selection of all the sibling views.
OnBeforeEditChanged | Internal editing event handler.
OnEditChanged |
OnLexCfgWasChanged | Internal editing event handler.
OnParseEvent | Internal editing event handler.
Paste | Call this member function to paste from clipboard to the current document.
PrevBookmark | Moves the current position to the previous bookmark.
PrintPage | This method used to print the edit control page.
ProcessCollapsedBlockDblClick | Expand collapsed block if double clicked on it.
ProcessCollapsedText | Calculate collapsed text sign rect (like for [..])
ProcessCollapsedTextEx | The same functionality as for ProcessCollapsedText but performs some additional checks for input parameters.
RecalcHorzScrollPos | Recalculates horizontal scroll bar
RecalcScrollBars | Recalculates and set the scroll bars and other related areas depending on the text size and current position.
RecalcVertScrollPos | Recalculates vertical scroll bar
Redo | Re-does the last undone operation.
RedrawLineMarks | Redraws line marks.
RefreshColors | Refreshes colors for the current document.
RefreshLineMarks | Refreshes line marks depending on change type.
RegisterWindowClass | This member function registers the window class if it has not already been registered.
RemoveRow | Use this member function to remove row.
ReplaceAll | Replaces all occurrences of szFindText to szReplaceText.
ReplaceSel | Replaces a selection with the supplied text.
RepositionBars | Repositions and resizes control bars in the client area of a window.
RestoreCursor | Restores cursor, used mainly while changing font.
RowColFromPoint | Returns the row and col (Not validated) for a specific point. Use CalcValidDispCol for validation.
Scroll | Scrolls the window along with the contents for the specified x and y number of columns and rows.
ScrollWindow | Scrolls the specified client area.
ScrollWindowEx | Scrolls the specified client area with additional features.
Select | Selects a text bounded by given coordinates.
SelectAll | Selects all the text.
SelectWord | Selects the surrounding word of the point specified.
SetActive | This member function is called the the edit control is being activated or deactivated.
SetAutoCompleteList | Loads data into auto complete list.
SetAutoIndent | Sets auto indentation state.
SetCollapsibleNodes | Enables or disables Collapsible Nodes area.
SetConfigFile | Sets the path to the main configuration file.
SetCreateScrollbarOnParent | Call this member function to define where scrollbars are created - in SyntaxEdit control window or in parent window.
SetCurCaretPos | Sets the current caret position to the specified row and col.
SetCurPos | Sets the current cursor position to the specified row and col.
SetCurrentDocumentRow | Set row number as current document row.
SetDocModified | Sets or clears the modification flag for the currently opened document.
SetDropPos | Sets the drop position.
SetFontIndirect | Creates and applies the font for the edit control
SetHideCaret | Used to hide or show caret.
SetLineNumbers | Enables or disables line numbering.
SetOverwriteMode | Turns on/off overwrite mode.
SetPaintManager | Use this method to sett paint manager object.
SetReadOnly | Call this member function to set editor read-only mode.
SetRightButtonDrag | Sets right mouse button for dragging.
SetRowBkColor | Sets the background color of a specified row in the colors cache.
SetRowColor | Set the text color of the specified row in the colors cache.
SetRowText | Use this member function to set new text value for specified row.
SetRowValid | Sets valid flag for the row.
SetScrollBars | Sets scroll bars to enable/disable state. Call this member function to change state for scroll bars. This function operates on either vertical and horizontal scroll bars simultaneously. Disabled scroll bar is not visible.
SetScrollInfo | Sets the information that the SCROLLINFO structure maintains about a scroll bar.
SetScrollPos | Sets the current position of a scroll box and, if requested, redraws the scroll bar to reflect the new position of the scroll box
SetScrollRange | Sets minimum and maximum position values for the given scroll bar.
SetSelMargin | Sets gutter to enable/disable state. Call this member function to change state for gutter. Passing TRUE you enable gutter. Otherwise gutter is disabled. Disabled gutter is not visible.
SetSyntaxColor | Sets syntax colorization state.
SetTabSize | Sets the tab size.
SetTabWithSpace | Enables/disables replacing tabs with spaces.
SetText | Use this method to set editor text.
SetTopRow | Set the top row of the visible window.
SetWideCaret | Sets caret for overwrite mode.
ShiftCurrentVisibleRowDown | Shifts current row down on a number of rows.
ShiftCurrentVisibleRowUp | Shifts current row up on a number of rows.
ShowCollapsedToolTip | Shows tool tip with the text of the collapsed block on the specified point.
ShowDefaultContextMenu | Displays the default context menu.
ShowHScrollBar | Shows or hides the scroll bar.
ShowScrollBar | Shows or hides a scroll bar.
TabifySelection | Replaces all the blank spaces with tabs.
Undo | Un-does the current action.
Unselect | Cancels the previously selected rectangle area.
UnTabifySelection | Replaces all the tabs with blank spaces.
UpdateRowInfoInternally | Use this method to internally update drawing information (like each character position) in the draw text processor.
UpdateScrollPos | Updates the sibling views while in split mode.
UppercaseSelection | Turns selected text to the uppercase.
ValidateCol | Validates and set the row column to a valid one.
CXTPSyntaxEditCtrl Operators
CXTPSyntaxEditCtrl Operators | Description
= | Use this operator to copy control settings from other control.


CXTPSyntaxEditCtrl Classes

Classes, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl Classes
Classes
Class | Description
CAverageVal | CXTPSyntaxEditCtrl::CAverageVal
CScreenSearchBlock | CXTPSyntaxEditCtrl::CScreenSearchBlock
CScreenSearchCache | CXTPSyntaxEditCtrl::CScreenSearchCache
CTextSearchCache | CXTPSyntaxEditCtrl::CTextSearchCache
Class

CXTPSyntaxEditCtrl Class


CXTPSyntaxEditCtrl::CAverageVal Class

XTPSyntaxEditCtrl.h, CXTPSyntaxEditCtrl Classes
CXTPSyntaxEditCtrl::CAverageVal Class

CXTPSyntaxEditCtrl::CAverageVal

Class Hierarchy

class CAverageVal;
File

XTPSyntaxEditCtrl.h

Group

CXTPSyntaxEditCtrl Classes


CXTPSyntaxEditCtrl::CScreenSearchBlock Class

XTPSyntaxEditCtrl.h, CXTPSyntaxEditCtrl Classes
CXTPSyntaxEditCtrl::CScreenSearchBlock Class

CXTPSyntaxEditCtrl::CScreenSearchBlock

Class Hierarchy

class CScreenSearchBlock;
File

XTPSyntaxEditCtrl.h

Group

CXTPSyntaxEditCtrl Classes


CXTPSyntaxEditCtrl::CScreenSearchCache Class

XTPSyntaxEditCtrl.h, CXTPSyntaxEditCtrl Classes
CXTPSyntaxEditCtrl::CScreenSearchCache Class

CXTPSyntaxEditCtrl::CScreenSearchCache

Class Hierarchy

class CScreenSearchCache : public CScreenSearchBlockArray;
File

XTPSyntaxEditCtrl.h

Group

CXTPSyntaxEditCtrl Classes


CXTPSyntaxEditCtrl::CTextSearchCache Class

XTPSyntaxEditCtrl.h, CXTPSyntaxEditCtrl Classes
CXTPSyntaxEditCtrl::CTextSearchCache Class

CXTPSyntaxEditCtrl::CTextSearchCache

Class Hierarchy

class CTextSearchCache;
File

XTPSyntaxEditCtrl.h

Group

CXTPSyntaxEditCtrl Classes


CXTPSyntaxEditCtrl Enumerations

Enumerations, CXTPSyntaxEditCtrl Class, Legend
CXTPSyntaxEditCtrl Enumerations
Enumerations
Enumeration | Description
XTPScrolDirection | This enum defines flags for autoscroll direction.
Class

CXTPSyntaxEditCtrl Class

Legend
Enumeration


CXTPSyntaxEditCtrl::XTPScrolDirection Enumeration

XTPSyntaxEditCtrl.h, CXTPSyntaxEditCtrl Enumerations
CXTPSyntaxEditCtrl::XTPScrolDirection Enumeration

This enum defines flags for autoscroll direction.

enum XTPScrolDirection {
  xtpLeft = 0x0001,
  xtpRight = 0x0010,
  xtpTop = 0x0100,
  xtpBottom = 0x1000
};
File

XTPSyntaxEditCtrl.h

Members

xtpLeft
Defines left direction.
xtpRight
Defines right direction.
xtpTop
Defines top direction.
xtpBottom
Defines bottom direction.

Group

CXTPSyntaxEditCtrl Enumerations


CXTPSyntaxEditCtrl Data Members

CXTPSyntaxEditCtrl Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl Data Members
Class

CXTPSyntaxEditCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arCollapsedTextRows | The array of rows with beginning of collapsed blocks.
m_arOnScreenSchCache | On-screen schema cache for this control.
m_arValidDispRows | An array with indexes of valid displayed rows.
m_bAutoIndent | Auto indentation is enabled or not
m_bCaseSensitive | Case sensitive
m_bCreateScrollbarOnParent | TRUE if parent window scroll bars are used, otherwise FALSE.
m_bDragging | TRUE if in dragging mode
m_bDrawNodes | TRUE if Collapsible nodes signs are to be printed
m_bDroppable | TRUE if the current position is droppable
m_bEnableEditAccelerators | Enable/disable accelerators for Cut, Copy, Paste, Undo, Redoo and Select All operations.
m_bEnableOleDrag | Enables or disables OLE drag drop
m_bEnableWhiteSpace | Show white space
m_bFocused | States if focused or not
m_bHideCaret | Store is caret visible.
m_bHorzScrollBar | TRUE if vertical scrollbar is to be enabled
m_bIsActive | TRUE if application is active.
m_bIsDragging | TRUE if dragging, FALSE otherwise
m_bIsScrollingEndRow | Maintains a internal logic to draw the last row which is partly visible
m_bIsSmartIndent | Smart indentation is enabled or not
m_bLineNumbers | TRUE if line number is to be printed
m_bmpCache | Current view cached picture
m_bPageDirty | TRUE if the whole page is dirty
m_bReadOnly | Store ReadOnly mode.
m_bRightButtonDrag | TRUE if user is dragging through right button
m_bScrolling | Temporary variable to specify if scrolling by mouse wheel
m_bSelMargin | TRUE if selection margin is to be enabled or not
m_bSyntaxColor | Enables or disables syntax colorization
m_bTabWithSpace | Store tabulation width.
m_bTokensLoaded | Specifies if tokens are loaded or not
m_bVertScrollBar | TRUE if horizontal scrollbar is to be enabled
m_bVirtualSpace | TRUE if virtual space is enabled (cursor can be paced in any place after line end).
m_bWideCaret | Stored Overwrite Caret Style: Thin or Thick.
m_bWndCreateInProgress | Internal flag to indicate that windows creating is in progress.
m_chPrevLeadByte | For none-UNICODE version IME sends double byte chars as 2 WM_CHAR messages.
m_DrawTextProcessor |
m_dwAutoScrollDirection | Store active autoscroll direction.
m_dwInsertPos | Current insert position
m_dwLastRedrawTime | Stores last redrawing time
m_fcCollapsable | Collapsible rows cache
m_fcRowColors | Row colors cache
m_mapRowBkColor | The map for row back colors (cache)
m_mapRowColor | The map for row colors (cache)
m_nAutoIndentCol | Contains the column for auto indentation
m_nAverageLineLen | Average length of line
m_nBottomCalculatedRow | Bottom row of the last range of rows that have scrollbars properly calculated
m_nCollapsedTextRowsCount | The total amount of collapsed blocks in the document,
m_nCurrentCol | Current absolute column
m_nCurrentDocumentRow | Current row in the document
m_nDispCol | Current display column
m_nEditbarLength | Edit bar length including gutter and line number
m_nHScrollMaxWidth | Maximum horizontal scrollbar position.
m_nInsertSpaceCount | Temporarily stores the no of space to be inserted for auto indentation
m_nInsertTabCount | Temporarily stores the no of tabs to be inserted for auto indentation
m_nLineNumLength | Line numbers length
m_nMarginLength | Margin length
m_nNodesWidth | The width of the nodes signs
m_nTopCalculatedRow | Top row of the last range of rows that have scrollbars properly calculated
m_nTopRow | Top row for display
m_nWheelScroll | Lines to scroll on mouse wheel
m_pAutoComplete | Auto complete popup window.
m_pBuffer | The buffer manager
m_pPaintManeger | The paint manager
m_pParentWnd | Points to parent window.
m_ptDropPos | Specifies the drop position
m_pToolTip | Tool tip window for collapsed blocks text.
m_ptPrevMouse | Stored mouse position of the previous tip showing.
m_strDefaultCfgFilePath | Store configuration file full name.
m_strTmpLineTextBuff | Temporary text buffer
Public Data Members
Public Data Member | Description
m_bDeleteOnFinalRelease | If TRUE - Delete self OnFinalRelease() call.
m_bDisableRedraw | If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).


CXTPSyntaxEditCtrl::m_arCollapsedTextRows Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_arCollapsedTextRows Data Member

The array of rows with beginning of collapsed blocks.

CUIntArray m_arCollapsedTextRows;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_arOnScreenSchCache Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_arOnScreenSchCache Data Member

On-screen schema cache for this control.

CScreenSearchCache m_arOnScreenSchCache;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_arValidDispRows Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_arValidDispRows Data Member

An array with indexes of valid displayed rows.

CByteArray m_arValidDispRows;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bAutoIndent Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bAutoIndent Data Member

Auto indentation is enabled or not

BOOL m_bAutoIndent;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bCaseSensitive Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bCaseSensitive Data Member

Case sensitive

BOOL m_bCaseSensitive;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bCreateScrollbarOnParent Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bCreateScrollbarOnParent Data Member

TRUE if parent window scroll bars are used, otherwise FALSE.

BOOL m_bCreateScrollbarOnParent;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bDeleteOnFinalRelease Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bDeleteOnFinalRelease Data Member

If TRUE - Delete self OnFinalRelease() call.

BOOL m_bDeleteOnFinalRelease;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bDisableRedraw Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bDisableRedraw Data Member

If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).

BOOL m_bDisableRedraw;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bDragging Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bDragging Data Member

TRUE if in dragging mode

BOOL m_bDragging;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bDrawNodes Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bDrawNodes Data Member

TRUE if Collapsible nodes signs are to be printed

BOOL m_bDrawNodes;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bDroppable Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bDroppable Data Member

TRUE if the current position is droppable

BOOL m_bDroppable;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bEnableEditAccelerators Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bEnableEditAccelerators Data Member

Enable/disable accelerators for Cut, Copy, Paste, Undo, Redoo and Select All operations.

BOOL m_bEnableEditAccelerators;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bEnableOleDrag Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bEnableOleDrag Data Member

Enables or disables OLE drag drop

BOOL m_bEnableOleDrag;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bEnableWhiteSpace Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bEnableWhiteSpace Data Member

Show white space

BOOL m_bEnableWhiteSpace;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bFocused Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bFocused Data Member

States if focused or not

BOOL m_bFocused;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bHideCaret Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bHideCaret Data Member

Store is caret visible.

BOOL m_bHideCaret;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bHorzScrollBar Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bHorzScrollBar Data Member

TRUE if vertical scrollbar is to be enabled

BOOL m_bHorzScrollBar;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bIsActive Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bIsActive Data Member

TRUE if application is active.

BOOL m_bIsActive;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bIsDragging Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bIsDragging Data Member

TRUE if dragging, FALSE otherwise

BOOL m_bIsDragging;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bIsScrollingEndRow Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bIsScrollingEndRow Data Member

Maintains a internal logic to draw the last row which is partly visible

BOOL m_bIsScrollingEndRow;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bIsSmartIndent Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bIsSmartIndent Data Member

Smart indentation is enabled or not

BOOL m_bIsSmartIndent;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bLineNumbers Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bLineNumbers Data Member

TRUE if line number is to be printed

BOOL m_bLineNumbers;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bmpCache Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bmpCache Data Member

Current view cached picture

CBitmap m_bmpCache;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bPageDirty Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bPageDirty Data Member

TRUE if the whole page is dirty

BOOL m_bPageDirty;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bReadOnly Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bReadOnly Data Member

Store ReadOnly mode.

BOOL m_bReadOnly;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bRightButtonDrag Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bRightButtonDrag Data Member

TRUE if user is dragging through right button

BOOL m_bRightButtonDrag;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bScrolling Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bScrolling Data Member

Temporary variable to specify if scrolling by mouse wheel

BOOL m_bScrolling;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bSelMargin Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bSelMargin Data Member

TRUE if selection margin is to be enabled or not

BOOL m_bSelMargin;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bSyntaxColor Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bSyntaxColor Data Member

Enables or disables syntax colorization

BOOL m_bSyntaxColor;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bTabWithSpace Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bTabWithSpace Data Member

Store tabulation width.

BOOL m_bTabWithSpace;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bTokensLoaded Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bTokensLoaded Data Member

Specifies if tokens are loaded or not

BOOL m_bTokensLoaded;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bVertScrollBar Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bVertScrollBar Data Member

TRUE if horizontal scrollbar is to be enabled

BOOL m_bVertScrollBar;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bVirtualSpace Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bVirtualSpace Data Member

TRUE if virtual space is enabled (cursor can be paced in any place after line end).

BOOL m_bVirtualSpace;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bWideCaret Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bWideCaret Data Member

Stored Overwrite Caret Style: Thin or Thick.

BOOL m_bWideCaret;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_bWndCreateInProgress Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_bWndCreateInProgress Data Member

Internal flag to indicate that windows creating is in progress.

BOOL m_bWndCreateInProgress;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_chPrevLeadByte Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_chPrevLeadByte Data Member

For none-UNICODE version IME sends double byte chars as 2 WM_CHAR messages.

BYTE m_chPrevLeadByte;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_DrawTextProcessor Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_DrawTextProcessor Data Member
CXTPSyntaxEditDrawTextProcessor m_DrawTextProcessor;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_dwAutoScrollDirection Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_dwAutoScrollDirection Data Member

Store active autoscroll direction.

DWORD m_dwAutoScrollDirection;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_dwInsertPos Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_dwInsertPos Data Member

Current insert position

DWORD m_dwInsertPos;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_dwLastRedrawTime Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_dwLastRedrawTime Data Member

Stores last redrawing time

DWORD m_dwLastRedrawTime;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_fcCollapsable Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_fcCollapsable Data Member

Collapsible rows cache

CTextSearchCache m_fcCollapsable;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_fcRowColors Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_fcRowColors Data Member

Row colors cache

CTextSearchCache m_fcRowColors;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_mapRowBkColor Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_mapRowBkColor Data Member

The map for row back colors (cache)

CXTPSyntaxEditRowColorMap m_mapRowBkColor;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_mapRowColor Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_mapRowColor Data Member

The map for row colors (cache)

CXTPSyntaxEditRowColorMap m_mapRowColor;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nAutoIndentCol Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nAutoIndentCol Data Member

Contains the column for auto indentation

int m_nAutoIndentCol;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nAverageLineLen Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nAverageLineLen Data Member

Average length of line

int m_nAverageLineLen;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nBottomCalculatedRow Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nBottomCalculatedRow Data Member

Bottom row of the last range of rows that have scrollbars properly calculated

int m_nBottomCalculatedRow;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nCollapsedTextRowsCount Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nCollapsedTextRowsCount Data Member

The total amount of collapsed blocks in the document,

int m_nCollapsedTextRowsCount;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nCurrentCol Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nCurrentCol Data Member

Current absolute column

int m_nCurrentCol;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nCurrentDocumentRow Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nCurrentDocumentRow Data Member

Current row in the document

int m_nCurrentDocumentRow;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nDispCol Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nDispCol Data Member

Current display column

int m_nDispCol;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nEditbarLength Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nEditbarLength Data Member

Edit bar length including gutter and line number

int m_nEditbarLength;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nHScrollMaxWidth Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nHScrollMaxWidth Data Member

Maximum horizontal scrollbar position.

int m_nHScrollMaxWidth;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nInsertSpaceCount Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nInsertSpaceCount Data Member

Temporarily stores the no of space to be inserted for auto indentation

int m_nInsertSpaceCount;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nInsertTabCount Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nInsertTabCount Data Member

Temporarily stores the no of tabs to be inserted for auto indentation

int m_nInsertTabCount;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nLineNumLength Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nLineNumLength Data Member

Line numbers length

int m_nLineNumLength;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nMarginLength Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nMarginLength Data Member

Margin length

int m_nMarginLength;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nNodesWidth Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nNodesWidth Data Member

The width of the nodes signs

int m_nNodesWidth;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nTopCalculatedRow Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nTopCalculatedRow Data Member

Top row of the last range of rows that have scrollbars properly calculated

int m_nTopCalculatedRow;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nTopRow Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nTopRow Data Member

Top row for display

int m_nTopRow;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_nWheelScroll Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_nWheelScroll Data Member

Lines to scroll on mouse wheel

int m_nWheelScroll;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_pAutoComplete Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_pAutoComplete Data Member

Auto complete popup window.

CXTPSyntaxEditAutoCompleteWnd* m_pAutoComplete;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_pBuffer Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_pBuffer Data Member

The buffer manager

CXTPSyntaxEditBufferManager* m_pBuffer;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_pPaintManeger Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_pPaintManeger Data Member

The paint manager

CXTPSyntaxEditPaintManager* m_pPaintManeger;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_pParentWnd Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_pParentWnd Data Member

Points to parent window.

CWnd* m_pParentWnd;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_ptDropPos Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_ptDropPos Data Member

Specifies the drop position

CPoint m_ptDropPos;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_pToolTip Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_pToolTip Data Member

Tool tip window for collapsed blocks text.

CXTPSyntaxEditToolTipCtrl* m_pToolTip;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_ptPrevMouse Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_ptPrevMouse Data Member

Stored mouse position of the previous tip showing.

CPoint m_ptPrevMouse;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_strDefaultCfgFilePath Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_strDefaultCfgFilePath Data Member

Store configuration file full name.

CString m_strDefaultCfgFilePath;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl::m_strTmpLineTextBuff Data Member

CXTPSyntaxEditCtrl Data Members, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::m_strTmpLineTextBuff Data Member

Temporary text buffer

CString m_strTmpLineTextBuff;
Group

CXTPSyntaxEditCtrl Data Members


CXTPSyntaxEditCtrl Methods

CXTPSyntaxEditCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl Methods
Class

CXTPSyntaxEditCtrl Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
_EnableScrollBarNotify | This method used to notify parent window that scrollbar state changed.
_RecalcHScrollMaxWidth | Recalculates and set m_nHScrollMaxWidth member depending on the visible text size.
_RecalcScrollBars | Recalculates and set the scroll bars depending on the text size and current position.
_SubtractSelSizeFromPos | This method used to subtract selection size from the specified position.
_UpdateIMEStatus | This member function is called to update Is IME mode supported at the current time.
CalcAbsCol |
CalcAveDataSize | Calculates an average line length from start row to end row.
CalcDispCol |
CalcMaximumWidth | Calculates the maximum width for a text.
CalculateDocumentRow | Calculates document row basing in global visible row.
CalculateEditbarLength | Calculates the edit bar length and stores it into m_nEditbarLength member variable depending upon the gutter length and visibility and line number length and visibility.
CalculateVisibleRow | Calculates global visible row basing in document row.
CalcValidDispCol | Calculate and returns the display column for another display column specified in the iCol parameter.
ClearOnScreenSchCache | Clears a screen schema cache.
CreateInsertText | Fills and/or calculates number of tabs or blank spaces required.
DoAutoIndentIfNeed | This method used to set variables for autoindent.
DoChangeSelectionCase | Changes the case of the selection.
DoChangeSelectionTabify | Changes the tabification of the selection.
DoUndoRedo | Performs Undo/Redo operations and common control properties adjustment.
ExpandChars | Expands the character set by putting space in the position of tab.
FillTabs | Add number of tabs and spaces required to reach nDispColl.
FindWord | Find the next(or previouse) word position depending on the parameter supplied.
FindWordEx |
FindWordEx_str |
GetAutoscrollDirection | This method used to determine scroll direction for automatic scrolling (when selecting by mouse).
GetBlockFromPt | Finds collapsed block on the specified point if exist.
GetCollapsedBlockLen | Gets length of collapsed block.
GetCollapsedText | Returns a collapsed text for the specified collapsed block.
GetCurrentDocumentRow | Returns current document row number.
GetCurrentVisibleRow | Returns current visible row number.
GetDefaultCfgFilePath | Returns a filename of the default ini configuration file.
GetDocumentRow | Calculates document row basing in visible row.
GetEffectiveParent | Returns the effective parent.
GetLineNodeRect | Calculates rect(s) for Collapsible node icon
GetLineText |
GetOnScreenSch | Returns a pointer to the screen schema cache.
GetRegValues | Use this method to read options from the registry.
GetRowNodes | Gets the type of row node.
GetVisibleRow | Calculates visible row basing in document row.
GetVisibleRowsCount | Returns maximum visible rows count.
MatchText | Try to match text on the supplied parameters.
MoveCurrentVisibleRowDown | Moves current row down on a number of rows.
MoveCurrentVisibleRowUp | Moves current row up on a number of rows.
NotifyEditChanged | Send XTP_EDIT_NM_EDITCHANGED notification with specified parameters.
NotifyMarginLBtnClick | Send any notification to parent that user click in the bookmark area.
NotifyMouseEvent | Send any mouse notification to parent.
NotifyParent | Send any notification to parent.
NotifyParseEvent | Send WM_NOTIFY with XTP_EDIT_NM_PARSEEVENT code to parent window.
NotifySelInit | Initialize selection of all the sibling views.
OnBeforeEditChanged | Internal editing event handler.
OnEditChanged |
OnLexCfgWasChanged | Internal editing event handler.
OnParseEvent | Internal editing event handler.
ProcessCollapsedBlockDblClick | Expand collapsed block if double clicked on it.
ProcessCollapsedText | Calculate collapsed text sign rect (like for [..])
ProcessCollapsedTextEx | The same functionality as for ProcessCollapsedText but performs some additional checks for input parameters.
RecalcHorzScrollPos | Recalculates horizontal scroll bar
RecalcVertScrollPos | Recalculates vertical scroll bar
RedrawLineMarks | Redraws line marks.
RefreshLineMarks | Refreshes line marks depending on change type.
RegisterWindowClass | This member function registers the window class if it has not already been registered.
SetAutoCompleteList | Loads data into auto complete list.
SetCurrentDocumentRow | Set row number as current document row.
SetDocModified | Sets or clears the modification flag for the currently opened document.
ShiftCurrentVisibleRowDown | Shifts current row down on a number of rows.
ShiftCurrentVisibleRowUp | Shifts current row up on a number of rows.
ShowCollapsedToolTip | Shows tool tip with the text of the collapsed block on the specified point.
UpdateRowInfoInternally | Use this method to internally update drawing information (like each character position) in the draw text processor.
UpdateScrollPos | Updates the sibling views while in split mode.
Public Methods
Public Methods
Public Method | Description
AddRemoveBookmark | Sets Bookmark shape at specified row.
AddRemoveBreakPoint | Sets Breakpoint shape at specified row.
ApplyTheme | Applies the theme with the specified name onto the editor.
CalcEditRects | This method used to calculate the edit control regions.
CancelRightButtonDrag | Cancels right button drag.
CanEditDoc | Determines if a document can be modified by checking ReadOnly property value and sending XTP_EDIT_NM_EDITCHANGING notification to parent.
CanRedo | Returns flag which determines if Redo can be made.
CanUndo | Returns flag which determines if Undo can be made.
CollapseAll | Collapses all expanded collapsible nodes.
CollapseExpandBlock | Expands/Collapses block at specified row.
Copy | Copies the selected text to clipboard.
CopyOrMoveText | Copy or move text after dragging.
Create | Creates the window
Cut | Copies the selected text to clipboard and deletes it from document.
DecreaseIndent | Deletes tab from the front of a selection.
DeleteBookmark | Removes Breakpoint shape at specified row.
DeleteBreakpoint | Removes Breakpoint shape at specified row.
DeleteBuffer | Deletes a given range of text.
DeleteChar | Deletes a character at specified location.
DeleteSelectedLines | Deletes all the lines in a selection or a specific line in the case if no selection exists.
DeleteSelection | Deletes the currently selected text.
Draw | This method used to draw the edit control client area.
EnableEditAccelerators | Call this member function to enable or disable standard editor accelerators processing. By default this feature is off.
EnableOleDrag | Enables or disables OLE drag drop mode.
EnableScrollBarCtrl | Enables or disables the scroll bar.
EnableVirtualSpace | Enables/disables a Virtual Space mode. Call tis member function to enable or disable showing white spaces facility. Pass TRUE if white space should be shown, FALSE otherwise.
EnableWhiteSpace | Enables/disables showing white spaces. Call tis member function to enable or disable showing white spaces facility. Pass TRUE if white space should be shown, FALSE otherwise.
EnsureVisibleCol |
EnsureVisibleRow | Scrolls the window to a specific location where the specified row or col are visible.
ExpandAll | Expands all collapsed nodes.
Find | Finds a certain text with some parameters for find.
GetAutoCompleteWnd | This method used to get Auto-Complete window.
GetAutoIndent | Returns state of auto intend.
GetCollapsableBlocksInfo | This member function is used to retrieve collapsable text blocks for the specified row. It is called by the edit control.
GetCollapsibleNodes | Determines if Collapsible Nodes is enabled or not.
GetConfigFile | Returns main configuration file name.
GetCurAbsCol | Returns the current absolute horizontal text position. Call this member function to determine the current absolute text position, mainly used in text insert or delete operations. Treats tabs as one character.
GetCurCol | Returns the current column.
GetCurrentTheme | Returns current theme name.
GetCurRow | Returns the current document row
GetDrawTextProcessor | Use this method to get draw text processor object.
GetEditBuffer | Returns a buffer manager which maintains a buffer of a smart edit control.
GetHorzScrollBar | Returns the if horizontal scrollbar is enabled.
GetLexConfigurationManager | Use this method to get associated configuration manager.
GetLineMarksManager | Returns a pointer to the line marks manager associated with the current text buffer.
GetLineNumbers | Determines if line numbering is enabled or not.
GetModulePath | Returns a path of the executable file module.
GetPaintManager | Use this method to get paint manager object.
GetRedoTextList | Returns the list of text for redo operations.
GetRowBkColor | Returns the background color of the specified row in the colors cache.
GetRowColor | Gets the text color of the specified row in the colors cache.
GetRowColors | This member function is used to retrieve text colors for the specified row. It is called by the edit control from drawing procedure.
GetRowCount | Returns the number of rows in the current document.
GetRowPerPage | Returns the number of rows can be printed per page.
GetScrollBarCtrl | Return pointer to the specified CScrollBar object.
GetScrollInfo | Retrieves the scrollbar information
GetScrollLimit | Returns max scroll position identifier.
GetScrollPos | Retrieves the position of the scroll box.
GetScrollRange | Retrieves the scroll bar range.
GetSelection | This method used to get current selection.
GetSelectionBuffer | Returns a handle of selection buffer. Call this member function get a handle of a selection buffer in the global memory in one of the clipboard format of CF_TEXT or CF_UNICODETEXT. Mainly used in OLE drag drop operation.
GetSelectionText | Returns the selected text.
GetSelMargin | Returns gutter state.
GetSyntaxColor | Return state of syntax colorization. Call this member function to determine current syntax colorization state.
GetTabSize | Returns the tab size.
GetTabWithSpace | Returns the status if tab should be replaced by space.
GetText |
GetThemes | Returns an array of available theme names from the configuration manager.
GetTopRow | Returns top row identifier.
GetUndoTextList | Returns the list of text for undo operations.
GetVertScrollBar | Returns the if vertical scrollbar is enabled.
GetWideCaret | Determines if thin caret is set for overwrite mode.
GoToRow | Call this method to move to the row
HandleDrop | Handle the drop operation within the same edit buffer.
HasBookmarks | Determines if the current document has bookmarks.
HasBreakpoints | Determines if the current document has breakpoints.
HasRowMark | Retrieves a row mark for the specified row.
IncreaseIndent | Inserts tab in front of a selection.
InsertRow | Use this member function to insert new row.
InsertString | Inserts a string at specified row and col.
InsertTextBlock | Inserts a vertical text block at specified row and col.
InvalidateRow | Invalidates required row.
InvalidateRows | Invalidates given set of rows
IsActive | Call this member function to determine if the edit control has been activated or deactivated.
IsCreateScrollbarOnParent | Call this member function to determine if the edit control create and use scroll bars on parent window.
IsEnabledEditAccelerators | Determines if editor internally catch standard editor accelerators: Ctrl+C, Ctrl+V, Ctrl+X, Ctrl+Y, Ctrl+Z, Ctrl+Shift+Z, Ctrl+A, Ctrl+Ins, Shift+Ins, Alt+Backspace.
IsEnabledVirtualSpace | Returns the status of Virtual Space mode.
IsEnabledWhiteSpace | Returns the status if white space should be shown or not.
IsHideCaret | Determines is the caret visible or not.
IsReadOnly | Determines if editor in read-only mode.
IsRightButtonDrag | Returns state flag of mouse right button for drag or not.
IsRowValid | Returns valid row flag.
IsRowVisible | Returns visibility status for given row.
IsSelectionExist | Returns boolean selection existence flag.
LowercaseSelection | Turns selected text to the lowercase.
NextBookmark | Moves the current position to the next bookmark.
NotifyCurRowCol | Sends notification when current text position was changed.
Paste | Call this member function to paste from clipboard to the current document.
PrevBookmark | Moves the current position to the previous bookmark.
PrintPage | This method used to print the edit control page.
RecalcScrollBars | Recalculates and set the scroll bars and other related areas depending on the text size and current position.
Redo | Re-does the last undone operation.
RefreshColors | Refreshes colors for the current document.
RemoveRow | Use this member function to remove row.
ReplaceAll | Replaces all occurrences of szFindText to szReplaceText.
ReplaceSel | Replaces a selection with the supplied text.
RepositionBars | Repositions and resizes control bars in the client area of a window.
RestoreCursor | Restores cursor, used mainly while changing font.
RowColFromPoint | Returns the row and col (Not validated) for a specific point. Use CalcValidDispCol for validation.
Scroll | Scrolls the window along with the contents for the specified x and y number of columns and rows.
ScrollWindow | Scrolls the specified client area.
ScrollWindowEx | Scrolls the specified client area with additional features.
Select | Selects a text bounded by given coordinates.
SelectAll | Selects all the text.
SelectWord | Selects the surrounding word of the point specified.
SetActive | This member function is called the the edit control is being activated or deactivated.
SetAutoIndent | Sets auto indentation state.
SetCollapsibleNodes | Enables or disables Collapsible Nodes area.
SetConfigFile | Sets the path to the main configuration file.
SetCreateScrollbarOnParent | Call this member function to define where scrollbars are created - in SyntaxEdit control window or in parent window.
SetCurCaretPos | Sets the current caret position to the specified row and col.
SetCurPos | Sets the current cursor position to the specified row and col.
SetDropPos | Sets the drop position.
SetFontIndirect | Creates and applies the font for the edit control
SetHideCaret | Used to hide or show caret.
SetLineNumbers | Enables or disables line numbering.
SetOverwriteMode | Turns on/off overwrite mode.
SetPaintManager | Use this method to sett paint manager object.
SetReadOnly | Call this member function to set editor read-only mode.
SetRightButtonDrag | Sets right mouse button for dragging.
SetRowBkColor | Sets the background color of a specified row in the colors cache.
SetRowColor | Set the text color of the specified row in the colors cache.
SetRowText | Use this member function to set new text value for specified row.
SetRowValid | Sets valid flag for the row.
SetScrollBars | Sets scroll bars to enable/disable state. Call this member function to change state for scroll bars. This function operates on either vertical and horizontal scroll bars simultaneously. Disabled scroll bar is not visible.
SetScrollInfo | Sets the information that the SCROLLINFO structure maintains about a scroll bar.
SetScrollPos | Sets the current position of a scroll box and, if requested, redraws the scroll bar to reflect the new position of the scroll box
SetScrollRange | Sets minimum and maximum position values for the given scroll bar.
SetSelMargin | Sets gutter to enable/disable state. Call this member function to change state for gutter. Passing TRUE you enable gutter. Otherwise gutter is disabled. Disabled gutter is not visible.
SetSyntaxColor | Sets syntax colorization state.
SetTabSize | Sets the tab size.
SetTabWithSpace | Enables/disables replacing tabs with spaces.
SetText | Use this method to set editor text.
SetTopRow | Set the top row of the visible window.
SetWideCaret | Sets caret for overwrite mode.
ShowDefaultContextMenu | Displays the default context menu.
ShowHScrollBar | Shows or hides the scroll bar.
ShowScrollBar | Shows or hides a scroll bar.
TabifySelection | Replaces all the blank spaces with tabs.
Undo | Un-does the current action.
Unselect | Cancels the previously selected rectangle area.
UnTabifySelection | Replaces all the tabs with blank spaces.
UppercaseSelection | Turns selected text to the uppercase.
ValidateCol | Validates and set the row column to a valid one.


CXTPSyntaxEditCtrl::_EnableScrollBarNotify Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::_EnableScrollBarNotify Method

This method used to notify parent window that scrollbar state changed.

virtual void _EnableScrollBarNotify(
    DWORD dwScrollBar,
    DWORD dwState
);
Parameters

dwScrollBar
[in] Define the scroll bar(s) to change state as WS_HSCROLL and WS_VSCROLL flags.
dwState
[in] Define the scroll bar(s) state as WS_HSCROLL and WS_VSCROLL flags.

Remarks

Default implementation send XTP_EDIT_NM_ENABLESCROLLBAR notification to the parent.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::_RecalcHScrollMaxWidth Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::_RecalcHScrollMaxWidth Method

Recalculates and set m_nHScrollMaxWidth member depending on the visible text size.

void _RecalcHScrollMaxWidth();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::_RecalcScrollBars Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::_RecalcScrollBars Method

Recalculates and set the scroll bars depending on the text size and current position.

void _RecalcScrollBars();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::_SubtractSelSizeFromPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::_SubtractSelSizeFromPos Method

This method used to subtract selection size from the specified position.

XTP_EDIT_LINECOL _SubtractSelSizeFromPos(
    XTP_EDIT_LINECOL lcDispPos
);
Returns

A subtracted position.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::_UpdateIMEStatus Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::_UpdateIMEStatus Method

This member function is called to update Is IME mode supported at the current time.

void _UpdateIMEStatus();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::AddRemoveBookmark Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::AddRemoveBookmark Method

Sets Bookmark shape at specified row.

void AddRemoveBookmark(
    int nRow
);
Parameters

nRow
[in] A row identifier in document coordinates.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::AddRemoveBreakPoint Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::AddRemoveBreakPoint Method

Sets Breakpoint shape at specified row.

void AddRemoveBreakPoint(
    int nRow
);
Parameters

nRow
[in] A row identifier in document coordinates.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ApplyTheme Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ApplyTheme Method

Applies the theme with the specified name onto the editor.

void ApplyTheme(
    CString strTheme
);
Parameters

strTheme
[in] theme name.

Group

CXTPSyntaxEditCtrl Methods


CalcAbsCol Method

CXTPSyntaxEditCtrl Methods
CalcAbsCol Method
Overload List
Methods
Method | Description
CXTPSyntaxEditCtrl::CalcAbsCol (LPCTSTR, int) | Returns the absolute column for a display column.
CXTPSyntaxEditCtrl::CalcAbsCol (int, int) |
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CalcAbsCol Method (LPCTSTR, int)

CalcAbsCol Method, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalcAbsCol Method (LPCTSTR, int)

Returns the absolute column for a display column.

int CalcAbsCol(
    LPCTSTR szText,
    int nDispCol
);
Parameters

szText
[in] The text for which calculation is needed.
nDispCol
[in] The valid display column.
nTextRow
[in] The text row number.

Returns

The absolute column.

Group

CalcAbsCol Method


CXTPSyntaxEditCtrl::CalcAbsCol Method (int, int)

CalcAbsCol Method, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalcAbsCol Method (int, int)
int CalcAbsCol(
    int nTextRow,
    int nDispCol
);
Group

CalcAbsCol Method


CXTPSyntaxEditCtrl::CalcAveDataSize Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalcAveDataSize Method

Calculates an average line length from start row to end row.

virtual UINT CalcAveDataSize(
    int nRowStart,
    int nRowEnd
);
Parameters

nRowStart
[in] An integer index of a row where to calculate from.
nRowEnd
[in] An integer index of a row where to calculate to.

Returns

An average line length.

Group

CXTPSyntaxEditCtrl Methods


CalcDispCol Method

CXTPSyntaxEditCtrl Methods
CalcDispCol Method
Overload List
Methods
Method | Description
CXTPSyntaxEditCtrl::CalcDispCol (LPCTSTR, int) | Calculates and returns the display column for the specified absolute column.
CXTPSyntaxEditCtrl::CalcDispCol (int, int) |
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CalcDispCol Method (LPCTSTR, int)

CalcDispCol Method, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalcDispCol Method (LPCTSTR, int)

Calculates and returns the display column for the specified absolute column.

int CalcDispCol(
    LPCTSTR szText,
    int nActualCol
);
Parameters

szText
[in] The text for calculation.
nActualCol
[in] The actual (absolute) column position.
nTextRow
[in] The text row number.

Returns

The calculated display column.

Group

CalcDispCol Method


CXTPSyntaxEditCtrl::CalcDispCol Method (int, int)

CalcDispCol Method, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalcDispCol Method (int, int)
int CalcDispCol(
    int nTextRow,
    int nActualCol
);
Group

CalcDispCol Method


CXTPSyntaxEditCtrl::CalcEditRects Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalcEditRects Method

This method used to calculate the edit control regions.

virtual CRect CalcEditRects(
    CRect* prcBookMarks = NULL,
    CRect* prcLineNum = NULL,
    CRect* prcNodes = NULL,
    CRect* prcText = NULL,
    const CRect* prcClient = NULL
);
Parameters

prcBookMarks
[out] A pointer to CRect object to receive a Bookmarks area rectangle. May be NULL.
prcLineNum
[out] A pointer to CRect object to receive a Line Numbers area rectangle. May be NULL.
prcNodes
[out] A pointer to CRect object to receive a Line Nodes area rectangle. May be NULL.
prcText
[out] A pointer to CRect object to receive a Text area rectangle. May be NULL.
prcClient
[in] A pointer to CRect object which contains a base edit control rectangle to calculate other rectangles. Pass NULL to use edit control's window client rect.

Returns

Returns a base rectangle for which other rectangless where calculated (this is a window client rect or value from prcClient parameter).

Remarks

For invisible(diabled) areas - the empty rectangles returned.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CalcMaximumWidth Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalcMaximumWidth Method

Calculates the maximum width for a text.

int CalcMaximumWidth(
    LPCTSTR szText
);
Parameters

szText
[in] The text for calculation.

Returns

The maximum width.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CalculateDocumentRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalculateDocumentRow Method

Calculates document row basing in global visible row.

int CalculateDocumentRow(
    int nStartDocumentRow,
    int nRowDelta
);
Parameters

nStartDocumentRow
[in] Start document row.
nRowDelta
[in] Visible rows count.

Returns

Integer value of document row.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CalculateEditbarLength Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalculateEditbarLength Method

Calculates the edit bar length and stores it into m_nEditbarLength member variable depending upon the gutter length and visibility and line number length and visibility.

void CalculateEditbarLength(
    CDC* pDC = NULL
);
Parameters

pDC
[in] A pointer to device context to draw.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CalculateVisibleRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalculateVisibleRow Method

Calculates global visible row basing in document row.

int CalculateVisibleRow(
    int nStartDocumentRow,
    int nDocumentRow
);
Parameters

nStartDocumentRow
[in] Start row.
nDocumentRow
[in] Count of document rows.

Returns

Integer value of global visible row.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CalcValidDispCol Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CalcValidDispCol Method

Calculate and returns the display column for another display column specified in the iCol parameter.

int CalcValidDispCol(
    LPCTSTR szText,
    int iCol
);
Parameters

szText
[in] The text on which the calculation should be made.
iCol
[in] The display column for which calculation is needed.

Returns

The display column as integer value.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CancelRightButtonDrag Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::CancelRightButtonDrag Method

Cancels right button drag.

void CancelRightButtonDrag();
Remarks

Call this member function to cancel right button drag. It is mainly by by CXTPSyntaxEditView class.

See Also

void SetRightButtonDrag(BOOL bRightButtonDrag = TRUE), IsRightButtonDrag() CXTPSyntaxEditView

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CanEditDoc Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CanEditDoc Method

Determines if a document can be modified by checking ReadOnly property value and sending XTP_EDIT_NM_EDITCHANGING notification to parent.

virtual BOOL CanEditDoc();
Returns

TRUE if the document can be edited, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CanRedo Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::CanRedo Method

Returns flag which determines if Redo can be made.

BOOL CanRedo();
Returns

TRUE if redo can be made, FALSE otherwise.

Remarks

Call this member function to determine if redo can be made.

See Also

BOOL Redo(int nActionsCount = 1);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CanUndo Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::CanUndo Method

Returns flag which determines if Undo can be made.

BOOL CanUndo();
Returns

TRUE if any undo action pending, FALSE otherwise

Remarks

Call this member function to determine if undo can be made.

See Also

BOOL Undo(int nActionsCount = 1);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ClearOnScreenSchCache Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ClearOnScreenSchCache Method

Clears a screen schema cache.

void ClearOnScreenSchCache(
    int nRowFrom
);
Parameters

nRowFrom
[in] An integer index of a row where to clear cache from.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CollapseAll Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::CollapseAll Method

Collapses all expanded collapsible nodes.

void CollapseAll();
See Also

void ExpandAll();

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CollapseExpandBlock Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CollapseExpandBlock Method

Expands/Collapses block at specified row.

void CollapseExpandBlock(
    int nRow
);
Parameters

nRow
[in] A row identifier in document coordinates.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Copy Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::Copy Method

Copies the selected text to clipboard.

void Copy();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CopyOrMoveText Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CopyOrMoveText Method

Copy or move text after dragging.

void CopyOrMoveText(
    BOOL bCopy
);
Parameters

bCopy
[in] Set as TRUE to copy text, FALSE to move text.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Create Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::Create Method

Creates the window

BOOL Create(
    CWnd * pParent,
    BOOL bHorzScroll,
    BOOL bVertScroll,
    CXTPSyntaxEditBufferManager * pBuffer = NULL,
    CCreateContext * lpCS = NULL,
    UINT nID = 0
);
Parameters

pParent
[in] Parent window (Must not be NULL)
bHorzScroll
[in] TRUE if horizontal scroll bar is needed
bVertScroll
[in] TRUE if vertical scroll bar is needed
pBuffer
[in] A pointer to The buffer for the control (Used by splitter)
lpCS
[in] Specifies the create context of the window.
nID
[in] Specifies the control identifier.
bSplit
[in] TRUE if split bar is implemented

Returns

TRUE if created, FALSE otherwise

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::CreateInsertText Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CreateInsertText Method

Fills and/or calculates number of tabs or blank spaces required.

BOOL CreateInsertText(
    LPTSTR szText,
    CString& strTextToIns,
    int& iNewRow,
    int& iNewCol,
    int& iNewDispCol,
    int& iEditRowFrom,
    int& iEditRowTo,
    int& iChainActionCount
);
Parameters

szText
[in] Text to be inserted
strTextToIns
[out] Return string with all the indentation
iNewRow
[out] New row
iNewCol
[out] New col (absolute)
iNewDispCol
[out] New display col
iEditRowFrom
[out] Start row for XTP_EDIT_NM_EDITCHANGED
iEditRowTo
[out] End row for XTP_EDIT_NM_EDITCHANGED
iChainActionCount
[out] Chain action count for undo

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Cut Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::Cut Method

Copies the selected text to clipboard and deletes it from document.

void Cut();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DecreaseIndent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DecreaseIndent Method

Deletes tab from the front of a selection.

BOOL DecreaseIndent();
Returns

BOOL : True if successful, false if not.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DeleteBookmark Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DeleteBookmark Method

Removes Breakpoint shape at specified row.

void DeleteBookmark(
    int nRow
);
Parameters

nRow
[in] A row identifier in document coordinates.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DeleteBreakpoint Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DeleteBreakpoint Method

Removes Breakpoint shape at specified row.

void DeleteBreakpoint(
    int nRow
);
Parameters

nRow
[in] A row identifier in document coordinates.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DeleteBuffer Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::DeleteBuffer Method

Deletes a given range of text.

BOOL DeleteBuffer(
    int iRowFrom,
    int iColFrom,
    int iRowTo,
    int iColTo,
    int nFlags = 0
);
Parameters

iRowFrom
[in] Specifies start row in document coordinates.
iColFrom
[in] Specifies start col in document coordinates.
iRowTo
[in] Specifies end row in document coordinates.
iColTo
[in] Specifies end col in document coordinates.
nFlags
[in] mode flag, possible values : smfRedraw, smfForceRedraw, smfTextAsBlock.

Returns

TRUE if deleted, FALSE otherwise.

See Also

enum XTPSyntaxEditFlags.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DeleteChar Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::DeleteChar Method

Deletes a character at specified location.

BOOL DeleteChar(
    int iRow,
    int iCol,
    XTPSyntaxEditDeletePos pos
);
Parameters

iRow
[in] A row identifier in document coordinates.
iCol
[in] A column identifier in document coordinates.
pos
[in] A position qualifier.

Returns

TRUE if deleted, FALSE otherwise;

See Also

XTPSyntaxEditDeletePos enum.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DeleteSelectedLines Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DeleteSelectedLines Method

Deletes all the lines in a selection or a specific line in the case if no selection exists.

void DeleteSelectedLines(
    int iForceDeleteRow
);
Parameters

iForceDeleteRow
[in] The document row to delete.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DeleteSelection Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DeleteSelection Method

Deletes the currently selected text.

BOOL DeleteSelection();
Parameters

bRedraw
[in] If TRUE document should be redrawn. Default value is TRUE.

Returns

TRUE if deleted, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DoAutoIndentIfNeed Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DoAutoIndentIfNeed Method

This method used to set variables for autoindent.

virtual void DoAutoIndentIfNeed(
    int nBaseDocRow,
    int nDispCol_prev
);
Parameters

nBaseDocRow
[in] A text row to calculate autoindentstart.
nDispCol_prev
[in] A previouse display column (before enter pressed).

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DoChangeSelectionCase Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DoChangeSelectionCase Method

Changes the case of the selection.

BOOL DoChangeSelectionCase(
    BOOL bUpper
);
Parameters

bUpper
[in] TRUE when changing selection case to Upper, FALSE when changing selection case to Lower.

Returns

TRUE if performs successfully, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DoChangeSelectionTabify Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DoChangeSelectionTabify Method

Changes the tabification of the selection.

BOOL DoChangeSelectionTabify(
    BOOL bTabify
);
Parameters

bTabify
[in] TRUE when changing spaces to tabs, FALSE when changing tabs to spaces.

Returns

TRUE if performs successfully, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::DoUndoRedo Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::DoUndoRedo Method

Performs Undo/Redo operations and common control properties adjustment.

BOOL DoUndoRedo(
    int nActionsCount,
    BOOL bUndoRedo
);
Parameters

nActionsCount
[in] A number of actions to undo/redo.
bUndoRedo
[in] TRUE for performing Undo operations, FALSE for performing Redo operations.

Returns

TRUE if success, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Draw Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::Draw Method

This method used to draw the edit control client area.

virtual void Draw(
    CDC * pDC,
    const CRect& rcRect
);
Parameters

pDC
[in] A pointer to device context to print.
rcRect
[in] A rectangle to draw control.

See Also

PrintPage

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::EnableEditAccelerators Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::EnableEditAccelerators Method

Call this member function to enable or disable standard editor accelerators processing. By default this feature is off.

void EnableEditAccelerators(
    BOOL bEnable
);
Parameters

bEnable
Set as TRUE to enable accelerators, FALSE otherwise.

Body Source
void CXTPSyntaxEditCtrl::EnableEditAccelerators(BOOL bEnable) {
    m_bEnableEditAccelerators = bEnable;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::EnableOleDrag Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::EnableOleDrag Method

Enables or disables OLE drag drop mode.

void EnableOleDrag(
    BOOL bEnableDrag = TRUE
);
Parameters

bEnableDrag
[in] Determines state of OLE drag drop.

Remarks

CAll this member function toenablr/disable OLE drag drop. Pass TRUE to enable OLE drag drop, otherwise pass FALSE.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::EnableScrollBarCtrl Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::EnableScrollBarCtrl Method

Enables or disables the scroll bar.

void EnableScrollBarCtrl(
    int nBar,
    BOOL bEnable = TRUE
);
Parameters

nBar
[in] The scroll-bar identifier.
bEnable
[in] Specifies whether the scroll bar is to be enabled or disabled.

Remarks

If the window has a sibling scroll-bar control, that scroll bar is used; otherwise the window's own scroll bar is used.

See Also

void ShowScrollBar(UINT nBar, BOOL bShow = TRUE );

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::EnableVirtualSpace Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::EnableVirtualSpace Method

Enables/disables a Virtual Space mode.

Call tis member function to enable or disable showing white spaces facility. Pass TRUE if white space should be shown, FALSE otherwise.

void EnableVirtualSpace(
    BOOL bEnable,
    BOOL bUpdateReg = FALSE
);
Parameters

bEnable
[in] Set as TRUE to enable Virtual Space mode and as FALSE to disable.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

See Also

BOOL IsEnabledWhiteSpace()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::EnableWhiteSpace Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::EnableWhiteSpace Method

Enables/disables showing white spaces.

Call tis member function to enable or disable showing white spaces facility. Pass TRUE if white space should be shown, FALSE otherwise.

void EnableWhiteSpace(
    BOOL bShow = TRUE
);
Parameters

bShow
[in] Boolean flag determines if white space should be shown or not

See Also

BOOL IsEnabledWhiteSpace()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::EnsureVisibleCol Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::EnsureVisibleCol Method
BOOL EnsureVisibleCol(
    int nDispRow,
    int nDispCol
);
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::EnsureVisibleRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::EnsureVisibleRow Method

Scrolls the window to a specific location where the specified row or col are visible.

BOOL EnsureVisibleRow(
    int nTextRow
);
Parameters

nTextRow
[in] Row for lookup in document coordinates.
nDispRow
[in] Row for lookup in display coordinates.
nDispCol
[in] Column for lookup in display coordinates.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ExpandAll Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::ExpandAll Method

Expands all collapsed nodes.

void ExpandAll();
See Also

void CollapseAll();

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ExpandChars Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ExpandChars Method

Expands the character set by putting space in the position of tab.

int ExpandChars(
    CDC* pDC,
    LPCTSTR pszChars,
    int nCurPos,
    CString& strBufer
);
Parameters

pDC
[in] A pointer to CDC object.
pszChars
[in] The text to be processed.
nCurPos
[in] The current position in the line.
strBufer
[in] Buffer for text to be created after expansion.

Returns

The length of processed text after expansion.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::FillTabs Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::FillTabs Method

Add number of tabs and spaces required to reach nDispColl.

void FillTabs(
    CString & rstrTextToIns,
    int nDispColl
);
Parameters

rstrTextToIns
[in out] Text to be inserted
nDispColl
[in] A display column number to reach to.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Find Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::Find Method

Finds a certain text with some parameters for find.

BOOL Find(
    LPCTSTR szText,
    BOOL bMatchWholeWord,
    BOOL bMatchCase,
    BOOL bSearchDown,
    BOOL bRedraw = TRUE,
    int nStartRow = -1,
    int nStartCol = -1
);
Parameters

szText
[in] Pointer to a text string to be found.
bMatchWholeWord
[in] Find text matching the whole word.
bMatchCase
[in] Try to match case.
bSearchDown
[in] TRUE for searching downward.
bRedraw
[in] TRUE for redraw control after search.
nStartRow
[in] The row number to start search. Value -1 means start from current row.
nStartCol
[in] The column number to start search. Value -1 means start from current column.

Returns

TRUE if found, FALSE if not

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::FindWord Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::FindWord Method

Find the next(or previouse) word position depending on the parameter supplied.

void FindWord(
    UINT nFindWhat
);
Parameters

nFindWhat
[in] XTP_EDIT_FINDWORD_PREV to find previous and XTP_EDIT_FINDWORD_NEXT to find next word.
nTextRow
[in] A text row number to start finding.
nCol
[in] A column number to start finding (1 based value).
lcPos_str
[in] A text position to start finding (column is a 0 based value).
rlcWordStart
[out] A reference to XTP_EDIT_LINECOL object to receive word start position.
rlcWordEnd
[out] A reference to XTP_EDIT_LINECOL object to receive word end position.
rbOverSpace
[out] A reference to BOOL variable to receive if finding started from space or tab character.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::FindWordEx Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::FindWordEx Method
BOOL FindWordEx(
    UINT nFindWhat,
    int nTextRow,
    int nCol,
    XTP_EDIT_LINECOL& rlcWordStart,
    XTP_EDIT_LINECOL& rlcWordEnd,
    BOOL& rbOverSpace
);
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::FindWordEx_str Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::FindWordEx_str Method
BOOL FindWordEx_str(
    UINT nFindWhat,
    XTP_EDIT_LINECOL lcPos_str,
    XTP_EDIT_LINECOL& rlcWordStart,
    XTP_EDIT_LINECOL& rlcWordEnd,
    BOOL& rbOverSpace
);
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetAutoCompleteWnd Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetAutoCompleteWnd Method

This method used to get Auto-Complete window.

CXTPSyntaxEditAutoCompleteWnd* GetAutoCompleteWnd();
Returns

A pointer to CXTPSyntaxEditAutoCompleteWnd object.

See Also

CXTPSyntaxEditAutoCompleteWnd

Body Source
CXTPSyntaxEditAutoCompleteWnd* CXTPSyntaxEditCtrl::GetAutoCompleteWnd() {
    return m_pAutoComplete;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetAutoIndent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetAutoIndent Method

Returns state of auto intend.

BOOL GetAutoIndent() const;
Returns

TRUE if syntax auto indent is enabled, FALSE otherwise.

Remarks

Call this member function to determine current auto intend state.

See Also

void SetAutoIndent(BOOL bEnable = TRUE)

Body Source
BOOL CXTPSyntaxEditCtrl::GetAutoIndent() const {
    return m_bAutoIndent;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetAutoscrollDirection Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetAutoscrollDirection Method

This method used to determine scroll direction for automatic scrolling (when selecting by mouse).

virtual DWORD GetAutoscrollDirection(
    int* pnCols = NULL,
    int* pnRows = NULL
);
Parameters

pnCols
[out] A pointer to int variable to receive columns count to scroll. May be NULL.
pnRows
[out] A pointer to int variable to receive rows count to scroll. May be NULL.

Returns

A flags from enum CXTPSyntaxEditCtrl::XTPScrolDirection.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetBlockFromPt Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetBlockFromPt Method

Finds collapsed block on the specified point if exist.

XTP_EDIT_COLLAPSEDBLOCK* GetBlockFromPt(
    const CPoint& ptMouse
);
Parameters

ptMouse
[in] Mouse coordinates where to check for collapsed block.

Returns

Pointer to the XTP_EDIT_COLLAPSEDBLOCK structure with collapsed block parameters if it found, NULL otherwise.

See Also

struct XTP_EDIT_COLLAPSEDBLOCK.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCollapsableBlocksInfo Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetCollapsableBlocksInfo Method

This member function is used to retrieve collapsable text blocks for the specified row. It is called by the edit control.

virtual void GetCollapsableBlocksInfo(
    int nTextRow,
    CXTPSyntaxEditRowsBlockArray& rArBlocks
);
Parameters

rArBlocks
[out] A reference to CXTPSyntaxEditRowsBlockArray object to return collapsable text blocks.
nRow
[in] The row number to retrieve text colors.

Remarks

The default implementation call CXTPSyntaxEditLexTextSchema::GetCollapsableBlocksInfo. You may override this method and create own fast implementation.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCollapsedBlockLen Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetCollapsedBlockLen Method

Gets length of collapsed block.

BOOL GetCollapsedBlockLen(
    int nStartRow,
    int& rnLen
);
Parameters

nStartRow
[in] Start row of collapsed block.
rnLen
[out] Reference to store length value.

Returns

TRUE if success; FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCollapsedText Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetCollapsedText Method

Returns a collapsed text for the specified collapsed block.

CString GetCollapsedText(
    XTP_EDIT_COLLAPSEDBLOCK* pCoDrawBlk,
    int nMaxLinesCount = 150
);
Parameters

pCoDrawBlk
[in] XTP_EDIT_COLLAPSEDBLOCK structure.
nMaxLinesCount
[in] Max lines of text. Default is 150.

Returns

CString object with text for collapsed block.

See Also

struct XTP_EDIT_COLLAPSEDBLOCK

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCollapsibleNodes Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetCollapsibleNodes Method

Determines if Collapsible Nodes is enabled or not.

BOOL GetCollapsibleNodes() const;
Returns

TRUE if Collapsible Nodes area is enabled, FALSE otherwise.

Body Source
BOOL CXTPSyntaxEditCtrl::GetCollapsibleNodes() const {
    return m_bDrawNodes;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetConfigFile Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetConfigFile Method

Returns main configuration file name.

CString GetConfigFile();
Returns

CString object contains main configuration file name.

Remarks

Return configuration file name previously stored by SetConfigFile().

See Also

CXTPSyntaxEditCtrl::SetConfigFile().

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCurAbsCol Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetCurAbsCol Method

Returns the current absolute horizontal text position.

Call this member function to determine the current absolute text position, mainly used in text insert or delete operations. Treats tabs as one character.

int GetCurAbsCol();
Returns

Return absolute column position.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCurCol Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetCurCol Method

Returns the current column.

int GetCurCol();
Returns

An integer value of current document column identifier.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCurrentDocumentRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetCurrentDocumentRow Method

Returns current document row number.

int GetCurrentDocumentRow() const;
Returns

Current document row integer value.

See Also

void SetCurrentDocumentRow(int nRow);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCurrentTheme Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetCurrentTheme Method

Returns current theme name.

const CString& GetCurrentTheme();
Returns

A reference to CString object with active theme name.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCurrentVisibleRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetCurrentVisibleRow Method

Returns current visible row number.

int GetCurrentVisibleRow();
Returns

Integer value of current visible row.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetCurRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetCurRow Method

Returns the current document row

int GetCurRow() const;
Returns

An integer value of current document row identifier.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetDefaultCfgFilePath Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetDefaultCfgFilePath Method

Returns a filename of the default ini configuration file.

CString GetDefaultCfgFilePath();
Returns

CString objects with filename.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetDocumentRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetDocumentRow Method

Calculates document row basing in visible row.

int GetDocumentRow(
    int nVisibleRow
);
Parameters

nVisibleRow
[in] Visible row.

Returns

Integer value of document row.

See Also

int GetCurrentVisibleRow();

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetDrawTextProcessor Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetDrawTextProcessor Method

Use this method to get draw text processor object.

CXTPSyntaxEditDrawTextProcessor& GetDrawTextProcessor();
Returns

Returns pointer to CXTPSyntaxEditDrawTextProcessor object.

Body Source
CXTPSyntaxEditDrawTextProcessor& CXTPSyntaxEditCtrl::GetDrawTextProcessor() {
    return m_DrawTextProcessor;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetEditBuffer Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetEditBuffer Method

Returns a buffer manager which maintains a buffer of a smart edit control.

CXTPSyntaxEditBufferManager* GetEditBuffer();
Returns

Pointer to the CXTPSyntaxEditBufferManager object.

Body Source
CXTPSyntaxEditBufferManager* CXTPSyntaxEditCtrl::GetEditBuffer() {
    return m_pBuffer;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetEffectiveParent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetEffectiveParent Method

Returns the effective parent.

CWnd* GetEffectiveParent() const;
Returns

The parent window in form of CWnd*.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetHorzScrollBar Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetHorzScrollBar Method

Returns the if horizontal scrollbar is enabled.

BOOL GetHorzScrollBar() const;
Returns

TRUE if horizontal scrollbar is enabled, FALSE otherwise.

Body Source
BOOL CXTPSyntaxEditCtrl::GetHorzScrollBar() const {
    return m_bHorzScrollBar;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetLexConfigurationManager Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetLexConfigurationManager Method

Use this method to get associated configuration manager.

CXTPSyntaxEditConfigurationManager* GetLexConfigurationManager() const;
Returns

Returns pointer to configuration manager.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetLineMarksManager Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetLineMarksManager Method

Returns a pointer to the line marks manager associated with the current text buffer.

CXTPSyntaxEditLineMarksManager* GetLineMarksManager();
Returns

Pointer to CXTPSyntaxEditLineMarksManager

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetLineNodeRect Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetLineNodeRect Method

Calculates rect(s) for Collapsible node icon

void GetLineNodeRect(
    int nDispRow,
    CRect& rcNode,
    CRect* prcNodeFull = NULL
);
Parameters

nDispRow
[in] The window row number for which to print
rcNode
[out] Reference to CRect variable to receive node icon rect
prcNodeFull
[out] Pointer to CRect variable to receive full node area rect

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetLineNumbers Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetLineNumbers Method

Determines if line numbering is enabled or not.

BOOL GetLineNumbers() const;
Returns

TRUE if line numbering is enabled, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


GetLineText Method

CXTPSyntaxEditCtrl Methods
GetLineText Method
Overload List
Methods
Method | Description
CXTPSyntaxEditCtrl::GetLineText (int, BOOL, int) | Returns a text for the specified line.
CXTPSyntaxEditCtrl::GetLineText (int, CString&, BOOL, int) | Gets a text for the specified line.
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetLineText Method (int, BOOL, int)

GetLineText Method, CXTPSyntaxEditCtrl Class, See Also
CXTPSyntaxEditCtrl::GetLineText Method (int, BOOL, int)

Returns a text for the specified line.

const CString& GetLineText(
    int nRow,
    BOOL bAddCRLF = FALSE,
    int iCRLFStyle = -1
);
Parameters

nRow
[in] Row identifier.
bAddCRLF
[in] Boolean flag how to process end of text lines. Default is FALSE.
iCRLFStyle
[in] Style of end of text lines. Default is -1.

Returns

Reference to CString with text.

See Also

CXTPSyntaxEditBufferManager::GetLineText

Group

GetLineText Method


CXTPSyntaxEditCtrl::GetLineText Method (int, CString&, BOOL, int)

GetLineText Method, CXTPSyntaxEditCtrl Class, See Also
CXTPSyntaxEditCtrl::GetLineText Method (int, CString&, BOOL, int)

Gets a text for the specified line.

void GetLineText(
    int nRow,
    CString& strBuffer,
    BOOL bAddCRLF = FALSE,
    int iCRLFStyle = -1
);
Parameters

nRow
[in] Row identifier.
strBuffer
[out] Reference to text buffer to put returned text.
bAddCRLF
[in] Boolean flag how to process end of text lines. Default is FALSE.
iCRLFStyle
[in] Style of end of text lines. Default is -1.

See Also

CXTPSyntaxEditBufferManager::GetLineText

Group

GetLineText Method


CXTPSyntaxEditCtrl::GetModulePath Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetModulePath Method

Returns a path of the executable file module.

static CString GetModulePath();
Returns

CString objects with path.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetOnScreenSch Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetOnScreenSch Method

Returns a pointer to the screen schema cache.

CXTPSyntaxEditLexTextBlock* GetOnScreenSch(
    int nForRow
);
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetPaintManager Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetPaintManager Method

Use this method to get paint manager object.

virtual CXTPSyntaxEditPaintManager* GetPaintManager();
Returns

Returns pointer to associated CXTPSyntaxEditPaintManager object.

Body Source
CXTPSyntaxEditPaintManager* CXTPSyntaxEditCtrl::GetPaintManager() {
    return m_pPaintManeger;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetRedoTextList Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetRedoTextList Method

Returns the list of text for redo operations.

const CStringList& GetRedoTextList();
Returns

A reference to CStringList with strings of text for redo.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetRegValues Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetRegValues Method

Use this method to read options from the registry.

BOOL GetRegValues();
Returns

TRUE if performs successfully, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetRowBkColor Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetRowBkColor Method

Returns the background color of the specified row in the colors cache.

COLORREF GetRowBkColor(
    int nRow
);
Parameters

nRow
Specifies the document row.

Returns

COLORREF value of the current background color

See Also

void SetRowBkColor(int nRow, COLORREF crBack);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetRowColor Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetRowColor Method

Gets the text color of the specified row in the colors cache.

COLORREF GetRowColor(
    int nRow
);
Parameters

nRow
[in] A row identifier for getting the foreground color.

Returns

The actual text color foreground as a COLORREF value.

See Also

SetRowColor(int nRow);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetRowColors Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetRowColors Method

This member function is used to retrieve text colors for the specified row. It is called by the edit control from drawing procedure.

virtual void GetRowColors(
    int nTextRow,
    int nColFrom,
    int nColTo,
    const XTP_EDIT_COLORVALUES& clrDefault,
    CXTPSyntaxEditTextBlockList* rBlocks
);
Parameters

nColFrom
[in] The start column number (zero based).
nColTo
[in] The end column number (zero based). Value -1 means line end.
clrDefault
[in] A const reference to structure which contains default text colors. CXTPSyntaxEditPaintManager::m_clrValues passed by default.
rBlocks
[out] A pointer to CXTPSyntaxEditTextBlockList object to return text colors.
nRow
[in] The row number to retrieve text colors.

Remarks

The default implementation call CXTPSyntaxEditLexTextSchema::GetRowColors. You may override this method and create own fast implementation for the simple colors schemas.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetRowCount Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetRowCount Method

Returns the number of rows in the current document.

int GetRowCount() const;
Returns

Number of rows in the document.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetRowNodes Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetRowNodes Method

Gets the type of row node.

BOOL GetRowNodes(
    int nRow,
    DWORD& dwType
);
Parameters

nRow
[in] Row identifier.
dwType
[out] Reference to store row node type.

Returns

TRUE if success; FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetRowPerPage Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetRowPerPage Method

Returns the number of rows can be printed per page.

int GetRowPerPage();
Returns

int value determines the number of rows can be printed in current settings.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetScrollBarCtrl Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetScrollBarCtrl Method

Return pointer to the specified CScrollBar object.

virtual CScrollBar* GetScrollBarCtrl(
    int nBar
) const;
Parameters

nBar
[in] Specifies the type of scroll bar. The parameter can take one of the following values: [ul] [li]SB_HORZ - Retrieves the position of the horizontal scroll bar[/li] [li]SB_VERT - Retrieves the position of the vertical scroll bar[/li] [/ul]

Returns

A pointer to sibling scroll-bar control, or NULL if none.

Remarks

Call this member function to obtain a pointer to the specified sibling scroll bar. This member function does not operate on scroll bars created when the WS_HSCROLL or WS_VSCROLL bits are set during the creation of a window. The CWnd implementation of this function simply returns NULL. Derived classes, such as CView, implement the described functionality.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetScrollInfo Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetScrollInfo Method

Retrieves the scrollbar information

BOOL GetScrollInfo(
    int nBar,
    LPSCROLLINFO lpScrollInfo,
    UINT nMask = SIF_ALL
);
Parameters

nBar
[in] Specifies whether the scroll bar is a control or part of a window's non-client area. If it is part of the non-client area, nBar also indicates whether the scroll bar is positioned horizontally, vertically, or both. It must be one of the following: [ul] [li]SB_CTL - Contains the parameters for a scroll bar control. The m_hWnd data member must be the handle of the scroll bar control.[/li] [li]SB_HORZ - Specifies that the window is a horizontal scroll bar.[/li] [li]SB_VERT Specifies that the window is a vertical scroll bar.
lpScrollInfo
[out] A pointer to a SCROLLINFO structure. See the Platform SDK for more information about this structure.
nMask
[in] Specifies the scroll bar parameters to retrieve. The default specifies a combination of SIF_PAGE, SIF_POS, SIF_TRACKPOS, and SIF_RANGE. See SCROLLINFO for more information on the nMask values.

Returns

If the message retrieved any values, the return is TRUE. Otherwise, it is FALSE.

Remarks

Call this member function to retrieve the information that the SCROLLINFO structure maintains about a scroll bar. GetScrollInfo enables applications to use 32-bit scroll positions.

The SCROLLINFO structure contains information about a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (the thumb). See the SCROLLINFO structure topic in the Platform SDK for more information about changing the structure defaults.

The MFC Windows message handlers that indicate scroll-bar position, CWnd::OnHScroll and CWnd::OnVScroll, provide only 16 bits of position data. GetScrollInfo and SetScrollInfo provide 32 bits of scroll-bar position data. Thus, an application can call GetScrollInfo while processing either CWnd::OnHScroll or CWnd::OnVScroll to obtain 32-bit scroll-bar position data.

See Also

BOOL SetScrollInfo( int nBar, LPSCROLLINFO lpScrollInfo, BOOL bRedraw = TRUE );

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetScrollLimit Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetScrollLimit Method

Returns max scroll position identifier.

int GetScrollLimit(
    int nBar
);
Parameters

nBar
[in] Specifies the type of scroll bar. The parameter can take one of the following values: [ul] [li]SB_HORZ - Retrieves the scroll limit of the horizontal scroll bar.[/li] [li]SB_VERT Retrieves the scroll limit of the vertical scroll bar.[/li] [/ul]

Returns

An integer value which specifies the maximum position of a scroll bar if successful; otherwise 0.

Remarks

Call this member function to retrieve the maximum scrolling position of the scroll bar.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetScrollPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetScrollPos Method

Retrieves the position of the scroll box.

int GetScrollPos(
    int nBar
);
Parameters

nBar
[in] Specifies the scroll bar to examine. The parameter can take one of the following values: [ul] [li]SB_HORZ - Retrieves the position of the horizontal scroll bar.[/li] [li]SB_VERT - Retrieves the position of the vertical scroll bar.[/li] [/ul]

Returns

The current position of the scroll box in the scroll bar if it is successful; otherwise, it is zero.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetScrollRange Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetScrollRange Method

Retrieves the scroll bar range.

void GetScrollRange(
    int nBar,
    LPINT lpMinPos,
    LPINT lpMaxPos
) const;
Parameters

nBar
[in] Specifies the scroll bar to examine. The parameter can take one of the following values: [ul] [li]SB_HORZ - Retrieves the position of the horizontal scroll bar.[/li] [li]SB_VERT - Retrieves the position of the vertical scroll bar.[/li] [/ul]
lpMinPos
[out] Points to the integer variable that is to receive the minimum position.
lpMaxPos
[out] Points to the integer variable that is to receive the maximum position.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetSelection Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetSelection Method

This method used to get current selection.

CXTPSyntaxEditSelection& GetSelection();
Returns

A reference to CXTPSyntaxEditSelection object.

See Also

CXTPSyntaxEditSelection

Body Source
CXTPSyntaxEditSelection& CXTPSyntaxEditCtrl::GetSelection() {
    return m_Selection;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetSelectionBuffer Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetSelectionBuffer Method

Returns a handle of selection buffer.

Call this member function get a handle of a selection buffer in the global memory in one of the clipboard format of CF_TEXT or CF_UNICODETEXT. Mainly used in OLE drag drop operation.

HGLOBAL GetSelectionBuffer(
    UINT nFormat
);
Parameters

nFormat
[in] Determines clipboard format to be returned (CF_TEXT or CF_UNICODETEXT)

Returns

Handle of a globally allocated memory.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetSelectionText Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetSelectionText Method

Returns the selected text.

int GetSelectionText(
    CString& strText
);
Parameters

strText
[out] Reference to a CString object where returned text will be placed.

Returns

Number of character in the returned text.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetSelMargin Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetSelMargin Method

Returns gutter state.

BOOL GetSelMargin() const;
Returns

TRUE if gutter is enabled, FALSE otherwise

Remarks

Call this member function to determine current state of gutter. It may be enabled or disabled. Disabled gutter is not visible and inactive.

See Also

void SetSelMargin(BOOL bEnabled = TRUE)

Body Source
BOOL CXTPSyntaxEditCtrl::GetSelMargin() const {
    return m_bSelMargin;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetSyntaxColor Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetSyntaxColor Method

Return state of syntax colorization.

Call this member function to determine current syntax colorization state.

BOOL GetSyntaxColor() const;
Returns

TRUE if syntax colorization is enabled, FALSE otherwise.

See Also

void SetSyntaxColor(BOOL bEnable = TRUE)

Body Source
BOOL CXTPSyntaxEditCtrl::GetSyntaxColor() const {
    return m_bSyntaxColor;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetTabSize Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetTabSize Method

Returns the tab size.

int GetTabSize() const;
Returns

Actual tab size is number of character.

See Also

void SetTabSize(int iTabSize)

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetTabWithSpace Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetTabWithSpace Method

Returns the status if tab should be replaced by space.

BOOL GetTabWithSpace() const;
Returns

Returns TRUE if tab is enabled, FALSE otherwise.

See Also

void SetTabWithSpace(BOOL bReplace = TRUE);

Group

CXTPSyntaxEditCtrl Methods


GetText Method

CXTPSyntaxEditCtrl Methods
GetText Method
Overload List
Methods
Method | Description
CXTPSyntaxEditCtrl::GetText (CMemFile&, int) |
CXTPSyntaxEditCtrl::GetText (int) | Use this method to get editor text.
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetText Method (CMemFile&, int)

GetText Method, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetText Method (CMemFile&, int)
virtual BOOL GetText(
    CMemFile& memFile,
    int nMaxLen = -1
);
Group

GetText Method


CXTPSyntaxEditCtrl::GetText Method (int)

GetText Method, CXTPSyntaxEditCtrl Class, See Also
CXTPSyntaxEditCtrl::GetText Method (int)

Use this method to get editor text.

virtual CString GetText(
    int nMaxLen = -1
);
Parameters

nMaxLen
[in] The maximum text length to get (in TCHARs). Set as -1 to get all text. Default value -1.
memFile
[out] A reference to CMemFile object to receive a text.

Returns

First function returns a CString object wich contains an editor text (or empty string). Second function returns TRUE if succeeded, FALSE otherwise.

Remarks

Also CWnd::GetWindowText can be used to get editor text.

See Also

SetText, CWnd::SetWindowText

Group

GetText Method


CXTPSyntaxEditCtrl::GetThemes Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetThemes Method

Returns an array of available theme names from the configuration manager.

CStringArray& GetThemes();
Returns

A reference to CStringArray object containing available theme names.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetTopRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetTopRow Method

Returns top row identifier.

int GetTopRow();
Returns

An integer value of the current top row identifier.

See Also

SetTopRow(int iRow);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetUndoTextList Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetUndoTextList Method

Returns the list of text for undo operations.

const CStringList& GetUndoTextList();
Returns

A reference to CStringList with strings of text for undo.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetVertScrollBar Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::GetVertScrollBar Method

Returns the if vertical scrollbar is enabled.

BOOL GetVertScrollBar() const;
Returns

TRUE if vertical scrollbar is enabled, FALSE otherwise.

Body Source
BOOL CXTPSyntaxEditCtrl::GetVertScrollBar() const {
    return m_bVertScrollBar;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetVisibleRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetVisibleRow Method

Calculates visible row basing in document row.

int GetVisibleRow(
    int nDocumentRow
);
Parameters

nDocumentRow
[in] Document row.

Returns

Integer value of visible row.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetVisibleRowsCount Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetVisibleRowsCount Method

Returns maximum visible rows count.

int GetVisibleRowsCount(
    int nMaxDocRow = -1
);
Parameters

nMaxDocRow
[in] Max document row up to which calculate visible rows. If you pass -1 then calculate up to the end of the document. -1 is default value.

Returns

Integer value of maximum visible rows count.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GetWideCaret Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GetWideCaret Method

Determines if thin caret is set for overwrite mode.

BOOL GetWideCaret() const;
Returns

Boolean flag. TRUE if set, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::GoToRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::GoToRow Method

Call this method to move to the row

void GoToRow(
    int iRow,
    BOOL bSelectRow = FALSE
);
Parameters

iRow
[in] row index.
bSelectRow
[in] select row if TRUE.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::HandleDrop Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::HandleDrop Method

Handle the drop operation within the same edit buffer.

void HandleDrop(
    BOOL bCopy
);
Parameters

bCopy
[in] TRUE if drag is to copy, FALSE to specify a move.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::HasBookmarks Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::HasBookmarks Method

Determines if the current document has bookmarks.

BOOL HasBookmarks();
Returns

TRUE if bookmarks were set; FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::HasBreakpoints Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::HasBreakpoints Method

Determines if the current document has breakpoints.

BOOL HasBreakpoints();
Returns

TRUE if breakpoints were set; FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::HasRowMark Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::HasRowMark Method

Retrieves a row mark for the specified row.

BOOL HasRowMark(
    int nRow,
    const XTP_EDIT_LINEMARKTYPE& lmType,
    XTP_EDIT_LMPARAM* pParam = NULL
);
Parameters

nRow
[in] row identifier in document coordinates.
lmType
[in] type of line mark.
pParam
[in] a pointer to a parameter structure.

Returns

TRUE if specified row mark exists at the specified row, FALSE otherwise.

See Also

XTP_EDIT_LINEMARKTYPE, XTP_EDIT_LMPARAM

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IncreaseIndent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::IncreaseIndent Method

Inserts tab in front of a selection.

BOOL IncreaseIndent();
Returns

BOOL - True if successful, false if not.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::InsertRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::InsertRow Method

Use this member function to insert new row.

void InsertRow(
    int nRow,
    LPCTSTR pcszText,
    BOOL bCanUndo
);
Parameters

nRow
[in] The row number to insert at.
pcszText
[in] The new row text.
bCanUndo
[in] Pass TRUE if this can be undone.

Remarks

The parser is notified to reparse changed text.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::InsertString Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::InsertString Method

Inserts a string at specified row and col.

void InsertString(
    LPCTSTR szText,
    int iRow,
    int iCol,
    BOOL bDeleteSelection = TRUE
);
Parameters

szText
[in] A pointer to a text string to be inserted.
iRow
[in] A row identifier where text will be inserted.
iCol
[in] A column identifier where text will be inserted.
bDeleteSelection
[in] If TRUE selected text will be deleted at insertion. Default is TRUE.
bRedraw
[in] If TRUE document will be redrawn.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::InsertTextBlock Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::InsertTextBlock Method

Inserts a vertical text block at specified row and col.

void InsertTextBlock(
    LPCTSTR szText,
    int iRow,
    int iCol,
    BOOL bDeleteSelection = TRUE
);
Parameters

szText
[in] A pointer to a text string to be inserted.
iRow
[in] A row identifier where text will be inserted.
iCol
[in] A column identifier where text will be inserted.
bDeleteSelection
[in] If TRUE selected text will be deleted at insertion. Default is TRUE.
bRedraw
[in] If TRUE document will be redrawn.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::InvalidateRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::InvalidateRow Method

Invalidates required row.

void InvalidateRow(
    int nRow
);
Parameters

nRow
[in] row identifier in document coordinates.

Body Source
void CXTPSyntaxEditCtrl::InvalidateRow(int nDispRow) {
    InvalidateRows(nDispRow, nDispRow);
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::InvalidateRows Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::InvalidateRows Method

Invalidates given set of rows

void InvalidateRows(
    int nRowFrom = -1,
    int nRowTo = -1
);
Parameters

nRowFrom
[in] first row identifier in document coordinates.
nRowTo
[in] last row identifier in document coordinates.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsActive Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsActive Method

Call this member function to determine if the edit control has been activated or deactivated.

virtual BOOL IsActive() const;
Returns

TRUE if the edit control has been activated, otherwise FALSE.

Body Source
BOOL CXTPSyntaxEditCtrl::IsActive() const {
    return m_bIsActive;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsCreateScrollbarOnParent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsCreateScrollbarOnParent Method

Call this member function to determine if the edit control create and use scroll bars on parent window.

virtual BOOL IsCreateScrollbarOnParent() const;
Returns

TRUE if parent window scroll bars are used, otherwise FALSE.

Body Source
BOOL CXTPSyntaxEditCtrl::IsCreateScrollbarOnParent() const {
    return m_bCreateScrollbarOnParent;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsEnabledEditAccelerators Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsEnabledEditAccelerators Method

Determines if editor internally catch standard editor accelerators: Ctrl+C, Ctrl+V, Ctrl+X, Ctrl+Y, Ctrl+Z, Ctrl+Shift+Z, Ctrl+A, Ctrl+Ins, Shift+Ins, Alt+Backspace.

BOOL IsEnabledEditAccelerators();
Returns

TRUE if accelerators internally supported, FALSE otherwise.

Remarks

You can support any of these editing operations externally, by call of member functions. By default this feature is off.

Body Source
BOOL CXTPSyntaxEditCtrl::IsEnabledEditAccelerators() {
    return m_bEnableEditAccelerators;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsEnabledVirtualSpace Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsEnabledVirtualSpace Method

Returns the status of Virtual Space mode.

BOOL IsEnabledVirtualSpace() const;
Returns

TRUE if Virtual Space mode enabled, FALSE otherwise.

See Also

EnableVirtualSpace

Body Source
BOOL CXTPSyntaxEditCtrl::IsEnabledVirtualSpace() const {
    return m_bVirtualSpace;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsEnabledWhiteSpace Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsEnabledWhiteSpace Method

Returns the status if white space should be shown or not.

BOOL IsEnabledWhiteSpace();
Returns

TRUE if white space should be shown, FALSE otherwise.

Remarks

Call this member function to determine if currently white space should be shown or not.

See Also

void EnableWhiteSpace(BOOL bShow = TRUE)

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsHideCaret Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsHideCaret Method

Determines is the caret visible or not.

BOOL IsHideCaret();
Returns

TRUE if caret is hidden, FALSE otherwise.

Body Source
BOOL CXTPSyntaxEditCtrl::IsHideCaret() {
    return m_bHideCaret;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsReadOnly Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsReadOnly Method

Determines if editor in read-only mode.

virtual BOOL IsReadOnly();
Returns

TRUE if the editor in read-only mode, FALSE otherwise.

Body Source
BOOL CXTPSyntaxEditCtrl::IsReadOnly() {
    return m_bReadOnly;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsRightButtonDrag Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsRightButtonDrag Method

Returns state flag of mouse right button for drag or not.

BOOL IsRightButtonDrag();
Returns

TRUE if right button drag is enabled, FALSE otherwise.

Remarks

Call this member function to determine if mouse right button is currently enabled for dragging.

See Also

void SetRightButtonDrag(BOOL bRightButtonDrag = TRUE) void CancelRightButtonDrag();

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsRowValid Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::IsRowValid Method

Returns valid row flag.

BOOL IsRowValid(
    int nDispRow
);
Parameters

nDispRow
[in] row identifier in document coordinates.

Returns

TRUE if row valid; FALSE otherwise.

See Also

void SetRowValid(int nDispRow);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsRowVisible Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::IsRowVisible Method

Returns visibility status for given row.

BOOL IsRowVisible(
    int iRow
);
Parameters

iRow
[in] The document row number to be tested.

Returns

TRUE if the row is visible, FALSE otherwise.

Remarks

Call this member function to determine if a row of the document is visible or not.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::IsSelectionExist Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::IsSelectionExist Method

Returns boolean selection existence flag.

BOOL IsSelectionExist();
Returns

TRUE if selection exist, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::LowercaseSelection Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::LowercaseSelection Method

Turns selected text to the lowercase.

BOOL LowercaseSelection();
Returns

TRUE if performs successfully, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::MatchText Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::MatchText Method

Try to match text on the supplied parameters.

BOOL MatchText(
    int nRow,
    LPCTSTR szLineText,
    LPCTSTR szMatchText,
    int nStartPos,
    BOOL bMatchWholeWord,
    BOOL bMatchCase,
    BOOL bSearchForward,
    BOOL bRedraw = TRUE
);
Parameters

nRow
[in] Row to match for.
szLineText
[in] Line text.
szMatchText
[in] Text to be matched.
nStartPos
[in] Start position.
bMatchWholeWord
[in] Has to match whole word or not.
bMatchCase
[in] Case to be matched or not.
bSearchForward
[in] TRUE if it is to search forward.
bRedraw
[in] TRUE for redraw control after search.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::MoveCurrentVisibleRowDown Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::MoveCurrentVisibleRowDown Method

Moves current row down on a number of rows.

int MoveCurrentVisibleRowDown(
    int nCount
);
Parameters

nCount
[in] Count of rows.

Returns

Integer value of current visible row.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::MoveCurrentVisibleRowUp Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::MoveCurrentVisibleRowUp Method

Moves current row up on a number of rows.

int MoveCurrentVisibleRowUp(
    int nCount
);
Parameters

nCount
[in] Count of rows.

Returns

Integer value of current visible row.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::NextBookmark Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::NextBookmark Method

Moves the current position to the next bookmark.

void NextBookmark();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::NotifyCurRowCol Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::NotifyCurRowCol Method

Sends notification when current text position was changed.

void NotifyCurRowCol(
    int nRow,
    int nCol
);
Parameters

nRow
[in] Row to be notified in document coordinates.
nCol
[in] Column to be notified.

Remarks

Call this member function to send notification to the parent class about the row col changes.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::NotifyEditChanged Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::NotifyEditChanged Method

Send XTP_EDIT_NM_EDITCHANGED notification with specified parameters.

void NotifyEditChanged(
    int iRowFrom,
    int iRowTo,
    UINT nActions
);
Parameters

iRowFrom
[in] Start row identifier.
iRowTo
[in] End row identifier.
nActions
[in] Action mask.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::NotifyMarginLBtnClick Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::NotifyMarginLBtnClick Method

Send any notification to parent that user click in the bookmark area.

virtual BOOL NotifyMarginLBtnClick(
    int nRow,
    int nDispRow
);
Parameters

nRow
[in] Document row.
nDispRow
[in] Visible row.

Returns

TRUE if action was handled, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::NotifyMouseEvent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::NotifyMouseEvent Method

Send any mouse notification to parent.

virtual LRESULT NotifyMouseEvent(
    UINT uCode,
    UINT nFlags,
    const CPoint& point
);
Parameters

uCode
[in] A mouse event notify code (like XTP_EDIT_NM_LBUTTONDOWN or other).
nFlags
[in] A mouse event flags.
point
[in] A mouse event cursor position.

See Also

XTP_EDIT_NM_LBUTTONDOWN, XTP_EDIT_NM_LBUTTONDBLCLICK, XTP_EDIT_NM_LBUTTONUP, XTP_EDIT_NM_RBUTTONDOWN, XTP_EDIT_NM_RBUTTONUP, XTP_EDIT_NM_MOUSEMOVE.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::NotifyParent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::NotifyParent Method

Send any notification to parent.

virtual LRESULT NotifyParent(
    UINT uCode
);
Parameters

uCode
[in] The notification code to send.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::NotifyParseEvent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::NotifyParseEvent Method

Send WM_NOTIFY with XTP_EDIT_NM_PARSEEVENT code to parent window.

BOOL NotifyParseEvent(
    XTP_NOTIFY_CODE code,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

code
[in] Event code from XTPSyntaxEditOnParseEvent enum.
wParam
[in] Event parameter 1.
lParam
[in] Event parameter 2.

See Also

XTPSyntaxEditOnParseEvent

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::NotifySelInit Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::NotifySelInit Method

Initialize selection of all the sibling views.

virtual void NotifySelInit();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::OnBeforeEditChanged Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::OnBeforeEditChanged Method

Internal editing event handler.

void OnBeforeEditChanged(
    int nRow,
    int nCol
);
Parameters

nRow
[in] Row identifier.
nCol
[in] Column identifier.

Group

CXTPSyntaxEditCtrl Methods


OnEditChanged Method

CXTPSyntaxEditCtrl Methods
OnEditChanged Method
Overload List
Methods
Method | Description
CXTPSyntaxEditCtrl::OnEditChanged (const XTP_EDIT_LINECOL&, const XTP_EDIT_LINECOL&, int) | Internal editing event handler.
CXTPSyntaxEditCtrl::OnEditChanged (int, int, int, int, int) | Internal editing event handler.
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::OnEditChanged Method (const XTP_EDIT_LINECOL&, const XTP_EDIT_LINECOL&, int)

OnEditChanged Method, CXTPSyntaxEditCtrl Class, See Also
CXTPSyntaxEditCtrl::OnEditChanged Method (const XTP_EDIT_LINECOL&, const XTP_EDIT_LINECOL&, int)

Internal editing event handler.

void OnEditChanged(
    const XTP_EDIT_LINECOL& LCFrom,
    const XTP_EDIT_LINECOL& LCTo,
    int eEditAction
);
Parameters

LCFrom
[in] Start coordinates.
LCTo
[in] End coordinates.
eEditAction
[in] Action identifier.

See Also

struct XTP_EDIT_LINECOL

Group

OnEditChanged Method


CXTPSyntaxEditCtrl::OnEditChanged Method (int, int, int, int, int)

OnEditChanged Method, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::OnEditChanged Method (int, int, int, int, int)

Internal editing event handler.

void OnEditChanged(
    int nRowFrom,
    int nColFrom,
    int nRowTo,
    int nColTo,
    int eEditAction
);
Parameters

nRowFrom
[in] Start row identifier.
nColFrom
[in] Start column identifier.
nRowTo
[in] End row identifier.
nColTo
[in] End column identifier.
eEditAction
[in] Action identifier.

Group

OnEditChanged Method


CXTPSyntaxEditCtrl::OnLexCfgWasChanged Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::OnLexCfgWasChanged Method

Internal editing event handler.

void OnLexCfgWasChanged(
    XTP_NOTIFY_CODE code,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

code
[in] Event code from XTPSyntaxEditOnCfgChangedEvent enum.
wParam
[in] Event parameter 1.
lParam
[in] Event parameter 2.

See Also

XTPSyntaxEditOnCfgChangedEvent

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::OnParseEvent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::OnParseEvent Method

Internal editing event handler.

void OnParseEvent(
    XTP_NOTIFY_CODE code,
    WPARAM wParam,
    LPARAM lParam
);
Parameters

code
[in] Event code.
wParam
[in] Event parameter 1.
lParam
[in] Event parameter 2.

See Also

XTP_NOTIFY_CODE

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Paste Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::Paste Method

Call this member function to paste from clipboard to the current document.

void Paste();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::PrevBookmark Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::PrevBookmark Method

Moves the current position to the previous bookmark.

void PrevBookmark();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::PrintPage Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::PrintPage Method

This method used to print the edit control page.

virtual int PrintPage(
    CDC * pDC,
    const CRect& rcRect,
    int nFlags = 0
);
Parameters

pDC
[in] A pointer to device context to print.
rcRect
[in] A rectangle to draw control.
nFlags
[in] Additional printing options. The folowing are supported: DT_CALCRECT, DT_SINGLELINE, DT_WORDBREAK

Returns

Returns count of the printed rows.

Remarks

The TopRow is used as the first page line.

See Also

Draw

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ProcessCollapsedBlockDblClick Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::ProcessCollapsedBlockDblClick Method

Expand collapsed block if double clicked on it.

int ProcessCollapsedBlockDblClick(
    const CPoint& ptMouse
);
Parameters

ptMouse
[in] Mouse coordinates where to check for collapsed block.

Returns

A number of row where collapsed block was expanded, 0 if collapsed block was not expanded.

See Also

CXTPSyntaxEditToolTipCtrl

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ProcessCollapsedText Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::ProcessCollapsedText Method

Calculate collapsed text sign rect (like for [..])

void ProcessCollapsedText(
    CDC* pDC,
    XTP_EDIT_COLLAPSEDBLOCK* pCoDrawBlk,
    CRect& rcCoBlk
);
Parameters

pDC
[in] A pointer to CDC object.
pCoDrawBlk
[in] Pointer to XTP_EDIT_COLLAPSEDBLOCK structure.
rcCoBlk
[in, out] A reference to rectangle with collapced block text area. The right border is updated by this function.

See Also

struct XTP_EDIT_COLLAPSEDBLOCK

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ProcessCollapsedTextEx Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::ProcessCollapsedTextEx Method

The same functionality as for ProcessCollapsedText but performs some additional checks for input parameters.

BOOL ProcessCollapsedTextEx(
    CDC* pDC,
    XTP_EDIT_COLLAPSEDBLOCK* pCoDrawBlk,
    const XTP_EDIT_TEXTBLOCK& txtBlk,
    CRect& rcCoBlk
);
Parameters

pDC
[in] A pointer to CDC object.
pCoDrawBlk
[in] Pointer to XTP_EDIT_COLLAPSEDBLOCK structure.
txtBlk
[in] Pointer to XTP_EDIT_TEXTBLOCK structure.
rcCoBlk
[in, out] A reference to rectangle with collapced block text area. The right border is updated by this function.

See Also

struct XTP_EDIT_COLLAPSEDBLOCK, struct XTP_EDIT_TEXTBLOCK

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RecalcHorzScrollPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RecalcHorzScrollPos Method

Recalculates horizontal scroll bar

void RecalcHorzScrollPos();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RecalcScrollBars Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RecalcScrollBars Method

Recalculates and set the scroll bars and other related areas depending on the text size and current position.

void RecalcScrollBars();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RecalcVertScrollPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RecalcVertScrollPos Method

Recalculates vertical scroll bar

void RecalcVertScrollPos();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Redo Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::Redo Method

Re-does the last undone operation.

BOOL Redo(
    int nActionsCount = 1
);
Parameters

nActionsCount
[in] Specifies the number of actions to be redone simultaneously.

Returns

TRUE if success, FALSE otherwise.

See Also

BOOL CanRedo();

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RedrawLineMarks Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RedrawLineMarks Method

Redraws line marks.

virtual void RedrawLineMarks();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RefreshColors Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RefreshColors Method

Refreshes colors for the current document.

virtual void RefreshColors();
Remarks

Refreshing colors causes reread configuration files and reparsing the current document.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RefreshLineMarks Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::RefreshLineMarks Method

Refreshes line marks depending on change type.

virtual void RefreshLineMarks(
    XTP_EDIT_NMHDR_EDITCHANGED* pEditChanged
);
Parameters

pEditChanged
[in] Pointer to XTP_EDIT_NMHDR_EDITCHANGED structure.

See Also

LPXTP_EDIT_NMHDR_EDITCHANGED

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RegisterWindowClass Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RegisterWindowClass Method

This member function registers the window class if it has not already been registered.

BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

A boolean value that specifies if the window is successfully registered.

TRUE if the window class is successfully registered.

Otherwise FALSE.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RemoveRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RemoveRow Method

Use this member function to remove row.

void RemoveRow(
    int nRow,
    BOOL bCanUndo
);
Parameters

nRow
[in] The row number to remove.
bCanUndo
[in] Pass TRUE if this can be undone.

Remarks

The parser is notified to reparse changed text.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ReplaceAll Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ReplaceAll Method

Replaces all occurrences of szFindText to szReplaceText.

int ReplaceAll(
    LPCTSTR szFindText,
    LPCTSTR szReplaceText,
    BOOL bMatchWholeWord,
    BOOL bMatchCase
);
Parameters

szFindText
[in] Pointer to text to find.
szReplaceText
[in] Pointer to text which will replace.
bMatchWholeWord
[in] Boolean flag to match whole word.
bMatchCase
[in] Boolean flag to match case.

Returns

The number of founded matches.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ReplaceSel Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ReplaceSel Method

Replaces a selection with the supplied text.

BOOL ReplaceSel(
    LPCTSTR szNewText
);
Parameters

szNewText
[in] The text to be pasted into the selected part.

Returns

TRUE if replaced, FALSE otherwise

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RepositionBars Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RepositionBars Method

Repositions and resizes control bars in the client area of a window.

void RepositionBars(
    UINT nIDFirst,
    UINT nIDLast,
    UINT nIDLeftOver,
    UINT nFlag = CWnd::reposDefault,
    LPRECT lpRectParam = NULL,
    LPCRECT lpRectClient = NULL,
    BOOL bStretch = TRUE
);
Parameters

nIDFirst
[in] The ID of the first in a range of control bars to reposition and resize.
nIDLast
[in] The ID of the last in a range of control bars to reposition and resize.
nIDLeftOver
[in] Specifies ID of pane that fills the rest of the client area.
nFlag
[in] Can have one of the following values: [ul] [li]CWnd::reposDefault - Performs the layout of the control bars. lpRectParam is not used and can be NULL.[/li] [li]CWnd::reposQuery - The layout of the control bars is not done; instead lpRectParam is initialized with the size of the client area, as if the layout had actually been done.[/li] [li]CWnd::reposExtra Adds the values of lpRectParam to the client area of nIDLast and also performs the layout.[/li] [/ul]
lpRectParam
[in] Points to a RECT structure; the usage of which depends on the value of nFlag.
lpRectClient
[in] Points to a RECT structure containing the available client area. If NULL, the window's client area will be used.
bStretch
[in] Indicates whether the bar should be stretched to the size of the frame.

Remarks

The nIDFirst and nIDLast parameters define a range of control-bar IDs to be repositioned in the client area. The nIDLeftOver parameter specifies the ID of the child window (normally the view) which is repositioned and resized to fill the rest of the client area not filled by control bars.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RestoreCursor Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RestoreCursor Method

Restores cursor, used mainly while changing font.

void RestoreCursor();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::RowColFromPoint Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::RowColFromPoint Method

Returns the row and col (Not validated) for a specific point. Use CalcValidDispCol for validation.

BOOL RowColFromPoint(
    CPoint pt,
    int * pRow,
    int * pCol,
    int * pDispRow = NULL,
    int * pDispCol = NULL,
    BOOL bVirtualSpace = -1
);
Parameters

pt
[in] The point in client co-ordinate.
pRow
[out] The out parameter contains the calculated document row.
pCol
[out] The out parameter contains the calculated col.
pDispRow
[out] The out parameter contains the calculated visible row.
pDispCol
[out] The out parameter contains the calculated visible col.
bVirtualSpace
[in] Set TRUE if virtual space is enabled (cursor can be paced in any place after line end).

Returns

BOOL : True if point was out of bound and index was corrected

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Scroll Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::Scroll Method

Scrolls the window along with the contents for the specified x and y number of columns and rows.

void Scroll(
    int x,
    int y
);
Parameters

y
[in] Scroll vertically in rows.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ScrollWindow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ScrollWindow Method

Scrolls the specified client area.

void ScrollWindow(
    int xAmount,
    int yAmount,
    LPCRECT lpRect = NULL,
    LPCRECT lpClipRect = NULL
);
Parameters

xAmount
[in] Specifies the amount, in device units, of horizontal scrolling. This parameter must be a negative value to scroll to the left.
yAmount
[in] Specifies the amount, in device units, of vertical scrolling. This parameter must be a negative value to scroll up.
lpRect
[in] Points to a CRect object or RECT structure that specifies the portion of the client area to be scrolled. If lpRect is NULL, the entire client area is scrolled. The caret is repositioned if the cursor rectangle intersects the scroll rectangle.
lpClipRect
[in] Points to a CRect object or RECT structure that specifies the clipping rectangle to scroll. Only bits inside this rectangle are scrolled. Bits outside this rectangle are not affected even if they are in the lpRect rectangle. If lpClipRect is NULL, no clipping is performed on the scroll rectangle.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ScrollWindowEx Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ScrollWindowEx Method

Scrolls the specified client area with additional features.

int ScrollWindowEx(
    int dx,
    int dy,
    LPCRECT lpRectScroll,
    LPCRECT lpRectClip,
    CRgn* prgnUpdate,
    LPRECT lpRectUpdate,
    UINT flags
);
Parameters

dx
[in] Specifies the amount, in device units, of horizontal scrolling. This parameter must have a negative value to scroll to the left.
dy
[in] Specifies the amount, in device units, of vertical scrolling. This parameter must have a negative value to scroll up.
lpRectScroll
[in] Points to a RECT structure that specifies the portion of the client area to be scrolled. If this parameter is NULL, the entire client area is scrolled.
lpRectClip
[in] Points to a RECT structure that specifies the clipping rectangle to scroll. This structure takes precedence over the rectangle pointed to by lpRectScroll. Only bits inside this rectangle are scrolled. Bits outside this rectangle are not affected even if they are in the lpRectScroll rectangle. If this parameter is NULL, no clipping is performed on the scroll rectangle.
prgnUpdate
[in] Identifies the region that is modified to hold the region invalidated by scrolling. This parameter may be NULL.
lpRectUpdate
[out] Points to a RECT structure that will receive the boundaries of the rectangle invalidated by scrolling. This parameter may be NULL.
flags
[in] Can have one of the following values: [ul] [li]SW_ERASE When specified with SW_INVALIDATE, erases the newly invalidated region by sending a WM_ERASEBKGND message to the window. [/li] [li]SW_INVALIDATE Invalidates the region identified by prgnUpdate after scrolling.[/li] [li]SW_SCROLLCHILDREN Scrolls all child windows that intersect the rectangle pointed to by lpRectScroll by the number of pixels specified in dx and dy. Windows sends a WM_MOVE message to all child windows that intersect lpRectScroll, even if they do not move. The caret is repositioned when a child window is scrolled and the cursor rectangle intersects the scroll rectangle.[/li] [/ul]

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Select Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::Select Method

Selects a text bounded by given coordinates.

BOOL Select(
    int nRow1,
    int nDispCol1,
    int nRow2,
    int nDispCol2,
    BOOL bRedraw = TRUE
);
Parameters

nRow1
Start row of the text.
nRow2
End row of the text.
bRedraw
TRUE for redraw control after search.
nCol1
Start visible column (character) of the text.
nCol2
End visible column (character) of the text.

Returns

TRUE if found, FALSE if not.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SelectAll Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SelectAll Method

Selects all the text.

void SelectAll();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SelectWord Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SelectWord Method

Selects the surrounding word of the point specified.

void SelectWord(
    CPoint point
);
Parameters

point
[in] A point about which a word will be searched.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetActive Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetActive Method

This member function is called the the edit control is being activated or deactivated.

virtual void SetActive(
    BOOL bIsActive
);
Parameters

bIsActive
TRUE if the edit control has been activated, otherwise FALSE.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetAutoCompleteList Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetAutoCompleteList Method

Loads data into auto complete list.

virtual void SetAutoCompleteList();
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetAutoIndent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetAutoIndent Method

Sets auto indentation state.

BOOL SetAutoIndent(
    BOOL bAutoIndent,
    BOOL bUpdateReg = FALSE
);
Parameters

bAutoIndent
[in] boolean flag determines state auto indent.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Remarks

Call this member function change state of auto indentation. Passing TRUE you enable it, disable otherwise.

See Also

BOOL GetAutoIndent()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetCollapsibleNodes Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetCollapsibleNodes Method

Enables or disables Collapsible Nodes area.

void SetCollapsibleNodes(
    BOOL bDrawNodes,
    BOOL bUpdateReg = FALSE
);
Parameters

bDrawNodes
[in] Pass TRUE to show Collapsible Nodes area.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetConfigFile Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetConfigFile Method

Sets the path to the main configuration file.

BOOL SetConfigFile(
    LPCTSTR szPath
);
Parameters

szPath
[in] A pointer to a string containing a valid path for searching the control's .ini files.

Returns

TRUE if path is found, FALSE otherwise

Remarks

Configuration will be reloaded.

See Also

CXTPSyntaxEditCtrl::GetConfigFile().

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetCreateScrollbarOnParent Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetCreateScrollbarOnParent Method

Call this member function to define where scrollbars are created - in SyntaxEdit control window or in parent window.

virtual void SetCreateScrollbarOnParent(
    BOOL nSet
);
Parameters

nSet
TRUE if parent window scroll bars should be used, otherwise FALSE.

Body Source
void CXTPSyntaxEditCtrl::SetCreateScrollbarOnParent(BOOL bSet) {
    m_bCreateScrollbarOnParent = bSet;
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetCurCaretPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetCurCaretPos Method

Sets the current caret position to the specified row and col.

void SetCurCaretPos(
    int nTextRow,
    int nDispCol,
    BOOL bRowColNotify = TRUE,
    BOOL bEnsureVisible = TRUE
);
Parameters

nTextRow
[in] The text row number for the current caret position.
nDispCol
[in] The col for the current caret position.
bRowColNotify
[in] Pass TRUE to send XTP_EDIT_NM_ROWCOLCHANGED notification, FALSE otherwise.
bEnsureVisible
[in] Pass true if the set row col should be forcefully made visible.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetCurPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetCurPos Method

Sets the current cursor position to the specified row and col.

void SetCurPos(
    int nTextRow,
    int nDispCol,
    BOOL bRemainSelected = FALSE,
    BOOL bForceVisible = TRUE
);
Parameters

bRemainSelected
[in] FALSE determines to unselect the selected text.
bForceVisible
[in] Set TRUE to make current pos visible.
iRow
[in] A Row to set as the current cursor position document coordinates.
iCol
[in] A Col to set as the current cursor position in document coordinates.

See Also

int GetCurCol(), int GetCurRow()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetCurrentDocumentRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetCurrentDocumentRow Method

Set row number as current document row.

void SetCurrentDocumentRow(
    int nRow
);
Parameters

nRow
[in] row number.

See Also

int GetCurrentDocumentRow();

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetDocModified Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetDocModified Method

Sets or clears the modification flag for the currently opened document.

void SetDocModified(
    BOOL bModified = TRUE
);
Parameters

bModified
[in] TRUE if want to set the document modified. Default is TRUE.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetDropPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetDropPos Method

Sets the drop position.

void SetDropPos(
    int iRow,
    int iCol
);
Parameters

iRow
[in] Row of the drop position.
iCol
[in] Col of the drop position.

Remarks

Call this member function to set the drop position. Mainly used by CXTPSyntaxEditView during OLE drag drop operation.

See Also

CXTPSyntaxEditView class

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetFontIndirect Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetFontIndirect Method

Creates and applies the font for the edit control

void SetFontIndirect(
    LPLOGFONT pLogfont,
    BOOL bUpdateReg = FALSE
);
Parameters

bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.
pLogFont
[in] A pointer to LOGFONT structure.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetHideCaret Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetHideCaret Method

Used to hide or show caret.

void SetHideCaret(
    BOOL bHide
);
Remarks

May be useful to hide caret in the read-only mode.

Body Source
void CXTPSyntaxEditCtrl::SetHideCaret(BOOL bHide) {
    m_bHideCaret = bHide;
    if (m_hWnd)
        Invalidate(FALSE);
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetLineNumbers Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetLineNumbers Method

Enables or disables line numbering.

BOOL SetLineNumbers(
    BOOL bLineNumbers,
    BOOL bUpdateReg = FALSE
);
Parameters

bLineNumbers
[in] Pass TRUE to enable line numbering.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetOverwriteMode Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetOverwriteMode Method

Turns on/off overwrite mode.

void SetOverwriteMode(
    BOOL bOverwriteMode
);
Parameters

bOverwriteMode
[in] TRUE if INS is off, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetPaintManager Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetPaintManager Method

Use this method to sett paint manager object.

virtual void SetPaintManager(
    CXTPSyntaxEditPaintManager* pPaintManager
);
Parameters

pPaintManager
[in] A pointer CXTPSyntaxEditPaintManager object.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetReadOnly Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetReadOnly Method

Call this member function to set editor read-only mode.

virtual void SetReadOnly(
    BOOL bReadOnly = TRUE
);
Parameters

bReadOnly
Set as TRUE to switch editor in read-only mode, FALSE otherwise.

Body Source
void CXTPSyntaxEditCtrl::SetReadOnly(BOOL bReadOnly) {
    m_bReadOnly = bReadOnly;
    if (m_hWnd)
        Invalidate(FALSE);
}
Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetRightButtonDrag Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetRightButtonDrag Method

Sets right mouse button for dragging.

void SetRightButtonDrag(
    BOOL bRightButtonDrag = TRUE
);
Parameters

bRightButtonDrag
[in] Boolean state flag of right button drag mode.

Remarks

Mainly used by CXTPSyntaxEditView for setting right button drag mode. If parameter is TRUE function sets right button for dragging, otherwise dragging mode is disabled for right mouse button.

See Also

void CancelRightButtonDrag(), BOOL IsRightButtonDrag()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetRowBkColor Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetRowBkColor Method

Sets the background color of a specified row in the colors cache.

void SetRowBkColor(
    int nRow,
    COLORREF crBack
);
Parameters

nRow
[in] A row identifier to set the background color.
crBack
[in] A background color

See Also

COLORREF GetRowBkColor(int nRow);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetRowColor Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetRowColor Method

Set the text color of the specified row in the colors cache.

void SetRowColor(
    int nRow,
    COLORREF clrFront
);
Parameters

nRow
[in] A row identifier for changing the foreground color.
clrFront
[in] An actual text color foreground.

See Also

GetRowColor(int nRow);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetRowText Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetRowText Method

Use this member function to set new text value for specified row.

void SetRowText(
    int nRow,
    LPCTSTR pcszText,
    BOOL bCanUndo
);
Parameters

nRow
[in] The text row number.
pcszText
[in] The row text new value.
bCanUndo
[in] Pass TRUE if this can be undone.

Remarks

The parser is notified to reparse changed text.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetRowValid Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetRowValid Method

Sets valid flag for the row.

void SetRowValid(
    int nDispRow
);
Parameters

nDispRow
[in] row identifier in document coordinates.

See Also

BOOL IsRowValid(int nDispRow);

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetScrollBars Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetScrollBars Method

Sets scroll bars to enable/disable state.

Call this member function to change state for scroll bars. This function operates on either vertical and horizontal scroll bars simultaneously. Disabled scroll bar is not visible.

BOOL SetScrollBars(
    BOOL bHorzSBar,
    BOOL bVertSBar,
    BOOL bUpdateReg = FALSE
);
Parameters

bHorzSBar
[in] TRUE enables horizontal scroll bar; otherwise disables.
bVertSBar
[in] TRUE enables vertical scroll bar; otherwise disables.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Returns

TRUE if scrollbars were updated, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetScrollInfo Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetScrollInfo Method

Sets the information that the SCROLLINFO structure maintains about a scroll bar.

BOOL SetScrollInfo(
    int nBar,
    LPSCROLLINFO lpScrollInfo,
    BOOL bRedraw = TRUE
);
Parameters

nBar
[in] Specifies the scroll bar to be set. This parameter can be either of the following: [ul] [li]SB_HORZ - Sets the position of the scroll box in the horizontal scroll bar of the window.[/li] [li]SB_VERT Sets the position of the scroll box in the vertical scroll bar of the window.[/li] [/ul]
lpScrollInfo
[in] A pointer to a SCROLLINFO structure.
bRedraw
[in] Specifies whether the scroll bar should be redrawn to reflect the new information. If bRedraw is TRUE, the scroll bar is redrawn. If it is FALSE, it is not redrawn. The scroll bar is redrawn by default.

Returns

If successful, the return is TRUE. Otherwise, it is FALSE.

Remarks

You must provide the values required by the SCROLLINFO structure parameters, including the flag values.

The SCROLLINFO structure contains information about a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (the thumb). See the SCROLLINFO structure topic in the Platform SDK for more information about changing the structure defaults.

See Also

BOOL GetScrollInfo( int nBar, LPSCROLLINFO lpScrollInfo, UINT nMask = SIF_ALL ) int GetScrollLimit( int nBar )

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetScrollPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetScrollPos Method

Sets the current position of a scroll box and, if requested, redraws the scroll bar to reflect the new position of the scroll box

int SetScrollPos(
    int nBar,
    int nPos,
    BOOL bRedraw = TRUE
);
Parameters

nBar
[in] Specifies the scroll bar to be set. This parameter can be either of the following: [ul] [li]SB_HORZ - Sets the position of the scroll box in the horizontal scroll bar of the window.[/li] [li]SB_VERT - Sets the position of the scroll box in the vertical scroll bar of the window.[/li] [/ul]
nPos
[in] Specifies the new position of the scroll box. It must be within the scrolling range.
bRedraw
[in] Specifies whether the scroll bar should be repainted to reflect the new scroll-box position. If this parameter is TRUE, the scroll bar is repainted; if FALSE, the scroll bar is not repainted.

Returns

The previous position of the scroll box.

Remarks

Setting bRedraw to FALSE is useful whenever the scroll bar will be redrawn by a subsequent call to another function.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetScrollRange Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetScrollRange Method

Sets minimum and maximum position values for the given scroll bar.

void SetScrollRange(
    int nBar,
    int nMinPos,
    int nMaxPos,
    BOOL bRedraw = TRUE
);
Parameters

nBar
[in] Specifies the scroll bar to be set. This parameter can be either of the following values: [ul] [li]SB_HORZ - Sets the range of the horizontal scroll bar of the window.[/li] [li]SB_VERT - Sets the range of the vertical scroll bar of the window.[/li] [/ul]
nMinPos
[in] Specifies the minimum scrolling position.
nMaxPos
[in] Specifies the maximum scrolling position.
bRedraw
[in] Specifies whether the scroll bar should be redrawn to reflect the change. If bRedraw is TRUE, the scroll bar is redrawn; if FALSE, the scroll bar is not redrawn.

Remarks

It can also be used to hide or show standard scroll bars.

An application should not call this function to hide a scroll bar while processing a scroll-bar notification message.

If the call to SetScrollRange immediately follows a call to the SetScrollPos member function, the bRedraw parameter in the SetScrollPos member function should be 0 to prevent the scroll bar from being drawn twice.

The default range for a standard scroll bar is 0 through 100. The default range for a scroll bar control is empty (both the nMinPos and nMaxPos values are 0). The difference between the values specified by nMinPos and nMaxPos must not be greater than INT_MAX.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetSelMargin Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetSelMargin Method

Sets gutter to enable/disable state.

Call this member function to change state for gutter. Passing TRUE you enable gutter. Otherwise gutter is disabled. Disabled gutter is not visible.

BOOL SetSelMargin(
    BOOL bSelMargin,
    BOOL bUpdateReg = FALSE
);
Parameters

bSelMargin
[in] Boolean state flag of gutter.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

See Also

BOOL GetSelMargin()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetSyntaxColor Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetSyntaxColor Method

Sets syntax colorization state.

BOOL SetSyntaxColor(
    BOOL bSyntaxColor,
    BOOL bUpdateReg = FALSE
);
Parameters

bSyntaxColor
[in] Boolean flag determines if colorization is enabled or disabled.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Returns

Call this member function to change state syntax colorization. Passing TRUE you enable syntax colorization, otherwise it is disabled.

See Also

BOOL GetSyntaxColor()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetTabSize Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetTabSize Method

Sets the tab size.

BOOL SetTabSize(
    int nTabSize,
    BOOL bUpdateReg = FALSE
);
Parameters

nTabSize
[in] The tab size to set should be between 2 to 10.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Remarks

Call this member function to set tab size. Size is measured in space character and should be between 2 to 10.

See Also

int GetTabSize()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetTabWithSpace Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetTabWithSpace Method

Enables/disables replacing tabs with spaces.

BOOL SetTabWithSpace(
    BOOL bTabWithSpace,
    BOOL bUpdateReg = FALSE
);
Parameters

bTabWithSpace
[in] Boolean flag determines enable/disable state.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Remarks

Call this member function to enable/disable replacing tabs with space Pass TRUE if tab should be replaced with space, FALSE otherwise.

See Also

BOOL GetTabWithSpace()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetText Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetText Method

Use this method to set editor text.

virtual void SetText(
    LPCTSTR pcszText
);
Parameters

pcszText
[in] Pointer to a text string.

Remarks

Also CWnd::SetWindowText can be used to set editor text.

See Also

GetText, CWnd::GetWindowText

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetTopRow Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::SetTopRow Method

Set the top row of the visible window.

void SetTopRow(
    int iRow
);
Parameters

iRow
[in] An identifier of the top visible row in document coordinates.

See Also

int GetTopRow();

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::SetWideCaret Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::SetWideCaret Method

Sets caret for overwrite mode.

BOOL SetWideCaret(
    BOOL bWideCaret,
    BOOL bUpdateReg = FALSE
);
Parameters

bWideCaret
[in] TRUE if thin caret, FALSE otherwise.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ShiftCurrentVisibleRowDown Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ShiftCurrentVisibleRowDown Method

Shifts current row down on a number of rows.

BOOL ShiftCurrentVisibleRowDown(
    int nCount,
    BOOL bChangeCaret = FALSE
);
Parameters

nCount
[in] Count of rows.
bChangeCaret
[in] Caret movement flag, default is FALSE.

Returns

TRUE if screen is changed; FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ShiftCurrentVisibleRowUp Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ShiftCurrentVisibleRowUp Method

Shifts current row up on a number of rows.

BOOL ShiftCurrentVisibleRowUp(
    int nCount,
    BOOL bChangeCaret = FALSE
);
Parameters

nCount
[in] Count of rows.
bChangeCaret
[in] Caret movement flag, default is FALSE.

Returns

TRUE if screen is changed; FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ShowCollapsedToolTip Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::ShowCollapsedToolTip Method

Shows tool tip with the text of the collapsed block on the specified point.

void ShowCollapsedToolTip(
    const CPoint& ptMouse
);
Parameters

ptMouse
[in] Mouse coordinates where to check for tooltip.

See Also

CXTPSyntaxEditToolTipCtrl, m_wndToolTip

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ShowDefaultContextMenu Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::ShowDefaultContextMenu Method

Displays the default context menu.

void ShowDefaultContextMenu();
Remarks

This member function calls OnContextMenu().

See Also

OnContextMenu()

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ShowHScrollBar Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ShowHScrollBar Method

Shows or hides the scroll bar.

void ShowHScrollBar(
    BOOL bShow = TRUE
);
Parameters

bShow
[in] Determines if a horizontal scrollbar should be shown. Pass TRUE to show FALSE otherwise. Default value is TRUE.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ShowScrollBar Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::ShowScrollBar Method

Shows or hides a scroll bar.

void ShowScrollBar(
    UINT nBar,
    BOOL bShow = TRUE
);
Parameters

nBar
[in] Specifies whether the scroll bar is a control or part of a window's non-client area. If it is part of the non-client area, nBar also indicates whether the scroll bar is positioned horizontally, vertically, or both. It must be one of the following: [ul] [li]SB_BOTH - Specifies the horizontal and vertical scroll bars of the window.[/li] [li]SB_HORZ - Specifies that the window is a horizontal scroll bar.[/li] [li]SB_VERT - Specifies that the window is a vertical scroll bar.[/li]
bShow
[in] Specifies whether Windows shows or hides the scroll bar. If this parameter is TRUE, the scroll bar is shown; otherwise the scroll bar is hidden.

Remarks

An application should not call ShowScrollBar to hide a scroll bar while processing a scroll-bar notification message.

See Also

void EnableScrollBarCtrl( int nBar, BOOL bEnable = TRUE );

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::TabifySelection Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::TabifySelection Method

Replaces all the blank spaces with tabs.

BOOL TabifySelection();
Returns

TRUE if Tabify done successfully, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Undo Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::Undo Method

Un-does the current action.

BOOL Undo(
    int nActionsCount = 1
);
Parameters

nActionsCount
[in] Specifies the number of actions to be undone simultaneously.

Returns

TRUE if success, FALSE otherwise.

See Also

BOOL CanUndo();

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::Unselect Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditCtrl::Unselect Method

Cancels the previously selected rectangle area.

void Unselect();
See Also

void SetCurSel(int iRow1, int iCol1, int iRow2, int iCol2)

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::UnTabifySelection Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::UnTabifySelection Method

Replaces all the tabs with blank spaces.

BOOL UnTabifySelection();
Returns

TRUE if Untabify done successfully, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::UpdateRowInfoInternally Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::UpdateRowInfoInternally Method

Use this method to internally update drawing information (like each character position) in the draw text processor.

void UpdateRowInfoInternally(
    int nTextRow
);
Remarks

It just draw specified row on the memory device context.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::UpdateScrollPos Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::UpdateScrollPos Method

Updates the sibling views while in split mode.

void UpdateScrollPos(
    DWORD dwUpdate = XTP_EDIT_UPDATE_ALL
);
Parameters

dwUpdate
[in] Specifies the view update flags.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::UppercaseSelection Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::UppercaseSelection Method

Turns selected text to the uppercase.

BOOL UppercaseSelection();
Returns

TRUE if performs successfully, FALSE otherwise.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl::ValidateCol Method

CXTPSyntaxEditCtrl Methods, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::ValidateCol Method

Validates and set the row column to a valid one.

void ValidateCol(
    const int nRow,
    int& nCol,
    int& nAbsCol
);
Parameters

nRow
[in] Document row to be validated.
nCol
[in out] Col to be validated.
nAbsCol
[in out] Absolute col to be validated.

Group

CXTPSyntaxEditCtrl Methods


CXTPSyntaxEditCtrl Constructors

CXTPSyntaxEditCtrl Class, Legend, Public Methods
CXTPSyntaxEditCtrl Constructors
Class

CXTPSyntaxEditCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditCtrl | Default object constructor.


CXTPSyntaxEditCtrl::CXTPSyntaxEditCtrl Constructor

CXTPSyntaxEditCtrl Constructors, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::CXTPSyntaxEditCtrl Constructor

Default object constructor.

CXTPSyntaxEditCtrl();
Group

CXTPSyntaxEditCtrl Constructors


CXTPSyntaxEditCtrl Destructors

CXTPSyntaxEditCtrl Class, Legend, Public Methods
CXTPSyntaxEditCtrl Destructors
Class

CXTPSyntaxEditCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditCtrl | Destroys a CXTPSyntaxEditCtrl object, handles cleanup and de- allocation


CXTPSyntaxEditCtrl::~CXTPSyntaxEditCtrl Destructor

CXTPSyntaxEditCtrl Destructors, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::~CXTPSyntaxEditCtrl Destructor

Destroys a CXTPSyntaxEditCtrl object, handles cleanup and de- allocation

virtual ~CXTPSyntaxEditCtrl();
Group

CXTPSyntaxEditCtrl Destructors


CXTPSyntaxEditCtrl Operators

CXTPSyntaxEditCtrl Class, Legend, Public Operators
CXTPSyntaxEditCtrl Operators
Class

CXTPSyntaxEditCtrl Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Use this operator to copy control settings from other control.


CXTPSyntaxEditCtrl::= Operator

CXTPSyntaxEditCtrl Operators, CXTPSyntaxEditCtrl Class
CXTPSyntaxEditCtrl::= Operator

Use this operator to copy control settings from other control.

const CXTPSyntaxEditCtrl& operator =(
    const CXTPSyntaxEditCtrl& src
);
Parameters

src
A source syntax edit control.

Returns

A reference to this object.

Group

CXTPSyntaxEditCtrl Operators


CXTPSyntaxEditDeleteStringCommand Class

XTPSyntaxEditUndoManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditDeleteStringCommand Methods, CXTPSyntaxEditDeleteStringCommand Constructors, CXTPSyntaxEditDeleteStringCommand Destructors, CXTPSyntaxEditDeleteStringCommand Constructors, CXTPSyntaxEditDeleteStringCommand Destructors, CXTPSyntaxEditDeleteStringCommand Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDeleteStringCommand Class

This class represents text deletion command. Command execution will delete text from the buffer between specified text positions, its un-execution will insert this text into the buffer.

Class Hierarchy

class CXTPSyntaxEditDeleteStringCommand : public CXTPSyntaxEditBufferCommand;
File

XTPSyntaxEditUndoManager.h

See Also

CXTPSyntaxEditBufferCommand, CXTPSyntaxEditInsertStringCommand

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditDeleteStringCommand Constructors
CXTPSyntaxEditDeleteStringCommand Constructors | Description
CXTPSyntaxEditDeleteStringCommand | Creates the delete string command object, initializes its members.
CXTPSyntaxEditDeleteStringCommand Destructors
CXTPSyntaxEditDeleteStringCommand Destructors | Description
~CXTPSyntaxEditDeleteStringCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.
CXTPSyntaxEditDeleteStringCommand Methods
CXTPSyntaxEditDeleteStringCommand Methods | Description
Execute | Executes delete string command.
UnExecute | Unexecutes delete string command (i.e. inserts the string).


CXTPSyntaxEditDeleteStringCommand Methods

CXTPSyntaxEditDeleteStringCommand Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDeleteStringCommand Methods
Class

CXTPSyntaxEditDeleteStringCommand Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Execute | Executes delete string command.
UnExecute | Unexecutes delete string command (i.e. inserts the string).


CXTPSyntaxEditDeleteStringCommand::Execute Method

CXTPSyntaxEditDeleteStringCommand Methods, CXTPSyntaxEditDeleteStringCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDeleteStringCommand::Execute Method

Executes delete string command.

virtual int Execute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW

See Also

UnExecute

Group

CXTPSyntaxEditDeleteStringCommand Methods


CXTPSyntaxEditDeleteStringCommand::UnExecute Method

CXTPSyntaxEditDeleteStringCommand Methods, CXTPSyntaxEditDeleteStringCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDeleteStringCommand::UnExecute Method

Unexecutes delete string command (i.e. inserts the string).

virtual int UnExecute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

Execute

Group

CXTPSyntaxEditDeleteStringCommand Methods


CXTPSyntaxEditDeleteStringCommand Constructors

CXTPSyntaxEditDeleteStringCommand Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDeleteStringCommand Constructors
Class

CXTPSyntaxEditDeleteStringCommand Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditDeleteStringCommand | Creates the delete string command object, initializes its members.


CXTPSyntaxEditDeleteStringCommand::CXTPSyntaxEditDeleteStringCommand Constructor

CXTPSyntaxEditDeleteStringCommand Constructors, CXTPSyntaxEditDeleteStringCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDeleteStringCommand::CXTPSyntaxEditDeleteStringCommand Constructor

Creates the delete string command object, initializes its members.

CXTPSyntaxEditDeleteStringCommand(
    CXTPSyntaxEditBufferManager* pMgr,
    LPCTSTR szText,
    const XTP_EDIT_LINECOL& lcFrom,
    const XTP_EDIT_LINECOL& lcTo
);
Parameters

pMgr
[in] Pointer to the associated buffer manager object.
szText
[in] A text which was changed during buffer operation. It will be used for insert/remove text operations.
lcFrom
[in] Start text position affected by the command.
lcTo
[in] End text position affected by the command.

Group

CXTPSyntaxEditDeleteStringCommand Constructors


CXTPSyntaxEditDeleteStringCommand Destructors

CXTPSyntaxEditDeleteStringCommand Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDeleteStringCommand Destructors
Class

CXTPSyntaxEditDeleteStringCommand Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditDeleteStringCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.


CXTPSyntaxEditDeleteStringCommand::~CXTPSyntaxEditDeleteStringCommand Destructor

CXTPSyntaxEditDeleteStringCommand Destructors, CXTPSyntaxEditDeleteStringCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDeleteStringCommand::~CXTPSyntaxEditDeleteStringCommand Destructor

A default command destructor. Destroys the command object, handles its cleanup and de-allocation.

virtual ~CXTPSyntaxEditDeleteStringCommand();
Group

CXTPSyntaxEditDeleteStringCommand Destructors


CXTPSyntaxEditDoc Class

XTPSyntaxEditDoc.h, Classes, Legend, Members, Topics, CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Constructors, CXTPSyntaxEditDoc Destructors, CXTPSyntaxEditDoc Constructors, CXTPSyntaxEditDoc Destructors, CXTPSyntaxEditDoc Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditDoc Class

This class represents a Document portion of the Edit control. It extends functionality provided by CDocument class from MFC's document-view model implementation. CXTPSyntaxEditDoc class works together with CXTPSyntaxEditView and provides storage facilities for it.

Class Hierarchy

class CXTPSyntaxEditDoc : public CDocument;
File

XTPSyntaxEditDoc.h

See Also

CXTPSyntaxEditView

Group

Classes

Legend
Method
protected
virtual
CXTPSyntaxEditDoc Constructors
CXTPSyntaxEditDoc Constructors | Description
CXTPSyntaxEditDoc | Protected object constructor. Used by dynamic creation
CXTPSyntaxEditDoc Destructors
CXTPSyntaxEditDoc Destructors | Description
~CXTPSyntaxEditDoc | Destroys a CXTPSyntaxEditDoc object, handles cleanup and de-allocation.
CXTPSyntaxEditDoc Methods
CXTPSyntaxEditDoc Methods | Description
CheckFileModified | This method checks if current file externally modified and prompt user to reload it. Works only when AutoReload option enabled.
GetAutoReload | Determines if auto reload of external files has been enabled.
GetDataManager | Returns the edit buffer manager pointer.
GetFirstView | Use this function to get a first view for thye document object.
IsReadonly | Is current file read only.
ReOpen | ReOpens already opened file
SetAutoReload | Enables or disables automatic reloading of external files.
SetConfigFile | Set the INI file path and load the configuration.
SetDataManager | Set the buffer manager pointer.


CXTPSyntaxEditDoc Methods

CXTPSyntaxEditDoc Class, Legend, Public Methods
CXTPSyntaxEditDoc Methods
Class

CXTPSyntaxEditDoc Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
CheckFileModified | This method checks if current file externally modified and prompt user to reload it. Works only when AutoReload option enabled.
GetAutoReload | Determines if auto reload of external files has been enabled.
GetDataManager | Returns the edit buffer manager pointer.
GetFirstView | Use this function to get a first view for thye document object.
IsReadonly | Is current file read only.
ReOpen | ReOpens already opened file
SetAutoReload | Enables or disables automatic reloading of external files.
SetConfigFile | Set the INI file path and load the configuration.
SetDataManager | Set the buffer manager pointer.


CXTPSyntaxEditDoc::CheckFileModified Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class, See Also
CXTPSyntaxEditDoc::CheckFileModified Method

This method checks if current file externally modified and prompt user to reload it. Works only when AutoReload option enabled.

BOOL CheckFileModified(
    LPCTSTR lpszPathName
);
Parameters

lpszPathName
A full file name.

Returns

TRUE if file modified and reloaded, FALSE otherwise.

See Also

GetAutoReload, SetAutoReload

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc::GetAutoReload Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class
CXTPSyntaxEditDoc::GetAutoReload Method

Determines if auto reload of external files has been enabled.

BOOL GetAutoReload() const;
Returns

TRUE if auto reload is enabled, FALSE otherwise.

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc::GetDataManager Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class, See Also
CXTPSyntaxEditDoc::GetDataManager Method

Returns the edit buffer manager pointer.

CXTPSyntaxEditBufferManager * GetDataManager();
Returns

Buffer manager pointer.

See Also

class CXTPSyntaxEditBufferManager

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc::GetFirstView Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class, See Also
CXTPSyntaxEditDoc::GetFirstView Method

Use this function to get a first view for thye document object.

CXTPSyntaxEditView* GetFirstView();
Returns

A pinter to CXTPSyntaxEditView object.

See Also

CDocument::GetFirstViewPosition, CDocument::GetNextView

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc::IsReadonly Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class
CXTPSyntaxEditDoc::IsReadonly Method

Is current file read only.

BOOL IsReadonly();
Returns

TRUE if current file read only, FALSE otherwise.

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc::ReOpen Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class
CXTPSyntaxEditDoc::ReOpen Method

ReOpens already opened file

BOOL ReOpen();
Returns

TRUE if reopened successfully, FALSE otherwise

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc::SetAutoReload Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class
CXTPSyntaxEditDoc::SetAutoReload Method

Enables or disables automatic reloading of external files.

BOOL SetAutoReload(
    BOOL bAutoReload,
    BOOL bUpdateReg = FALSE
);
Parameters

bAutoReload
[in] TRUE to enable automatic reload of external files, FALSE otherwise.
bUpdateReg
[in] Set this parameter as TRUE to update this setting in the registry. It is FALSE by default.

Returns

TRUE if succeeded, FALSE otherwise.

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc::SetConfigFile Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class, See Also
CXTPSyntaxEditDoc::SetConfigFile Method

Set the INI file path and load the configuration.

void SetConfigFile(
    LPCTSTR szPath
);
Parameters

szPath
[in] A valid path for searching the .ini files.

Returns

TRUE if path is found, FALSE otherwise

Remarks

Configuration will be reloaded.

See Also

CXTPSyntaxEditCtrl::GetConfigFile().

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc::SetDataManager Method

CXTPSyntaxEditDoc Methods, CXTPSyntaxEditDoc Class, See Also
CXTPSyntaxEditDoc::SetDataManager Method

Set the buffer manager pointer.

void SetDataManager(
    CXTPSyntaxEditBufferManager * pBuffer
);
Parameters

pBuffer
[in] The buffer manager pointer to set.

See Also

class CXTPSyntaxEditBufferManager

Group

CXTPSyntaxEditDoc Methods


CXTPSyntaxEditDoc Constructors

CXTPSyntaxEditDoc Class, Legend, Protected Methods
CXTPSyntaxEditDoc Constructors
Class

CXTPSyntaxEditDoc Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSyntaxEditDoc | Protected object constructor. Used by dynamic creation


CXTPSyntaxEditDoc::CXTPSyntaxEditDoc Constructor

CXTPSyntaxEditDoc Constructors, CXTPSyntaxEditDoc Class
CXTPSyntaxEditDoc::CXTPSyntaxEditDoc Constructor

Protected object constructor. Used by dynamic creation

CXTPSyntaxEditDoc();
Group

CXTPSyntaxEditDoc Constructors


CXTPSyntaxEditDoc Destructors

CXTPSyntaxEditDoc Class, Legend, Protected Methods
CXTPSyntaxEditDoc Destructors
Class

CXTPSyntaxEditDoc Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPSyntaxEditDoc | Destroys a CXTPSyntaxEditDoc object, handles cleanup and de-allocation.


CXTPSyntaxEditDoc::~CXTPSyntaxEditDoc Destructor

CXTPSyntaxEditDoc Destructors, CXTPSyntaxEditDoc Class
CXTPSyntaxEditDoc::~CXTPSyntaxEditDoc Destructor

Destroys a CXTPSyntaxEditDoc object, handles cleanup and de-allocation.

virtual ~CXTPSyntaxEditDoc();
Group

CXTPSyntaxEditDoc Destructors


CXTPSyntaxEditFileChangesMonitor Class

XTPSyntaxEditLexCfgFileReader.h, Classes, Legend, Members, Topics, CXTPSyntaxEditFileChangesMonitor Methods, CXTPSyntaxEditFileChangesMonitor Constructors, CXTPSyntaxEditFileChangesMonitor Destructors, CXTPSyntaxEditFileChangesMonitor Constructors, CXTPSyntaxEditFileChangesMonitor Destructors, CXTPSyntaxEditFileChangesMonitor Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor Class

this class monitors files changes

Class Hierarchy

class CXTPSyntaxEditFileChangesMonitor;
File

XTPSyntaxEditLexCfgFileReader.h

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditFileChangesMonitor Constructors
CXTPSyntaxEditFileChangesMonitor Constructors | Description
CXTPSyntaxEditFileChangesMonitor | Default object constructor.
CXTPSyntaxEditFileChangesMonitor Destructors
CXTPSyntaxEditFileChangesMonitor Destructors | Description
~CXTPSyntaxEditFileChangesMonitor | Destroys a CXTPSyntaxEditFileChangesMonitor() object, handles cleanup and de-allocation. Stops monitoring if it doesn't stop yet.
CXTPSyntaxEditFileChangesMonitor Methods
CXTPSyntaxEditFileChangesMonitor Methods | Description
AddMonitorFile | Add file to to be monitored.
RefreshFiles | Refreshes contents in the folder, update file's status and re-read changed configuration files.
SetConfigurationManager | Sets associated ConfigurationManager object.
SetDefaultFolder | Sets default monitoring folder.
StartMonitoring | Starts thread which will be monitoring folder changes.
StopMonitoring | Stops thread which is monitoring folder changes.


CXTPSyntaxEditFileChangesMonitor Methods

CXTPSyntaxEditFileChangesMonitor Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor Methods
Class

CXTPSyntaxEditFileChangesMonitor Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddMonitorFile | Add file to to be monitored.
RefreshFiles | Refreshes contents in the folder, update file's status and re-read changed configuration files.
SetConfigurationManager | Sets associated ConfigurationManager object.
SetDefaultFolder | Sets default monitoring folder.
StartMonitoring | Starts thread which will be monitoring folder changes.
StopMonitoring | Stops thread which is monitoring folder changes.


CXTPSyntaxEditFileChangesMonitor::AddMonitorFile Method

CXTPSyntaxEditFileChangesMonitor Methods, CXTPSyntaxEditFileChangesMonitor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor::AddMonitorFile Method

Add file to to be monitored.

BOOL AddMonitorFile(
    CString& strFilename,
    DWORD dwOwnerFlags
);
Parameters

strFilename
[in] file name string.
dwOwnerFlags
[in] Additional flags (from enum XTPSyntaxEditCfgObjects).

Remarks

Add file to the bunch of files to monitor changes at. First, try to check file by provided file name string, then tries file in the default folder. Ignores bad file names.

See Also

CXTPSyntaxEditConfigurationManager

Group

CXTPSyntaxEditFileChangesMonitor Methods


CXTPSyntaxEditFileChangesMonitor::RefreshFiles Method

CXTPSyntaxEditFileChangesMonitor Methods, CXTPSyntaxEditFileChangesMonitor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor::RefreshFiles Method

Refreshes contents in the folder, update file's status and re-read changed configuration files.

void RefreshFiles();
Group

CXTPSyntaxEditFileChangesMonitor Methods


CXTPSyntaxEditFileChangesMonitor::SetConfigurationManager Method

CXTPSyntaxEditFileChangesMonitor Methods, CXTPSyntaxEditFileChangesMonitor Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor::SetConfigurationManager Method

Sets associated ConfigurationManager object.

void SetConfigurationManager(
    CXTPSyntaxEditConfigurationManager* pConfigMgr
);
Parameters

pConfigMgr
[in] Pointer to the CXTPSyntaxEditConfigurationManager object.

See Also

CXTPSyntaxEditConfigurationManager

Body Source
void CXTPSyntaxEditFileChangesMonitor::SetConfigurationManager(CXTPSyntaxEditConfigurationManager* pConfigMgr) {
    m_pConfigMgr = pConfigMgr;
}
Group

CXTPSyntaxEditFileChangesMonitor Methods


CXTPSyntaxEditFileChangesMonitor::SetDefaultFolder Method

CXTPSyntaxEditFileChangesMonitor Methods, CXTPSyntaxEditFileChangesMonitor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor::SetDefaultFolder Method

Sets default monitoring folder.

void SetDefaultFolder(
    const CString& strPath
);
Parameters

strPath
[in] path string.

Group

CXTPSyntaxEditFileChangesMonitor Methods


CXTPSyntaxEditFileChangesMonitor::StartMonitoring Method

CXTPSyntaxEditFileChangesMonitor Methods, CXTPSyntaxEditFileChangesMonitor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor::StartMonitoring Method

Starts thread which will be monitoring folder changes.

void StartMonitoring();
Group

CXTPSyntaxEditFileChangesMonitor Methods


CXTPSyntaxEditFileChangesMonitor::StopMonitoring Method

CXTPSyntaxEditFileChangesMonitor Methods, CXTPSyntaxEditFileChangesMonitor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor::StopMonitoring Method

Stops thread which is monitoring folder changes.

void StopMonitoring();
Group

CXTPSyntaxEditFileChangesMonitor Methods


CXTPSyntaxEditFileChangesMonitor Constructors

CXTPSyntaxEditFileChangesMonitor Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor Constructors
Class

CXTPSyntaxEditFileChangesMonitor Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditFileChangesMonitor | Default object constructor.


CXTPSyntaxEditFileChangesMonitor::CXTPSyntaxEditFileChangesMonitor Constructor

CXTPSyntaxEditFileChangesMonitor Constructors, CXTPSyntaxEditFileChangesMonitor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor::CXTPSyntaxEditFileChangesMonitor Constructor

Default object constructor.

CXTPSyntaxEditFileChangesMonitor();
Group

CXTPSyntaxEditFileChangesMonitor Constructors


CXTPSyntaxEditFileChangesMonitor Destructors

CXTPSyntaxEditFileChangesMonitor Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor Destructors
Class

CXTPSyntaxEditFileChangesMonitor Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditFileChangesMonitor | Destroys a CXTPSyntaxEditFileChangesMonitor() object, handles cleanup and de-allocation. Stops monitoring if it doesn't stop yet.


CXTPSyntaxEditFileChangesMonitor::~CXTPSyntaxEditFileChangesMonitor Destructor

CXTPSyntaxEditFileChangesMonitor Destructors, CXTPSyntaxEditFileChangesMonitor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFileChangesMonitor::~CXTPSyntaxEditFileChangesMonitor Destructor

Destroys a CXTPSyntaxEditFileChangesMonitor() object, handles cleanup and de-allocation. Stops monitoring if it doesn't stop yet.

virtual ~CXTPSyntaxEditFileChangesMonitor();
Group

CXTPSyntaxEditFileChangesMonitor Destructors


CXTPSyntaxEditFindReplaceDlg Class

XTPSyntaxEditFindReplaceDlg.h, Classes, Legend, Members, Topics, CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Methods, CXTPSyntaxEditFindReplaceDlg Constructors, CXTPSyntaxEditFindReplaceDlg Constructors, CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg Class

This class implements a Find and Replace dialogs for a SyntaxEdit control.

Class Hierarchy

class CXTPSyntaxEditFindReplaceDlg : public CDialog;
File

XTPSyntaxEditFindReplaceDlg.h

Group

Classes

Legend
Data Member
protected
Method
CXTPSyntaxEditFindReplaceDlg Constructors
CXTPSyntaxEditFindReplaceDlg Constructors | Description
CXTPSyntaxEditFindReplaceDlg | Default object constructor.
CXTPSyntaxEditFindReplaceDlg Data Members
CXTPSyntaxEditFindReplaceDlg Data Members | Description
m_bMatchCase | Store Match Case option.
m_bMatchWholeWord | Store Match Whole Words option.
m_bReplaceDlg | Stored dialog type.
m_csFindText | Store text to find.
m_csReplaceText | Store text to replace.
m_nSearchDirection | Store Search Direction: 0-up, 1-down.
m_pEditCtrl | Stored attached view.
m_ptWndPos | Stored window position.
CXTPSyntaxEditFindReplaceDlg Methods
CXTPSyntaxEditFindReplaceDlg Methods | Description
EnableControls | This method update controls state (enable or disable) for buttons: Find, Replace and ReplaceAll.
GetEdirControl | This method used to get attached edit control.
InitHistoryCombo | Use this method to initialize combobox from strings array.
IsReplaceDialog | This method used to determine is 'Find and Replace' or only 'Find' dialog was created.
LoadHistory | Use this method to load from application profile history for find and replace comboboxes and state for other dialog controls.
SaveHistory | Use this method to save to application profile history for find and replace comboboxes and state for other dialog controls.
ShowDialog | This method used to show find or replace dialog. If window is not created this method loads a dialog template from resources and created modeless dialog.
UpdateHistoryCombo |


CXTPSyntaxEditFindReplaceDlg Data Members

CXTPSyntaxEditFindReplaceDlg Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg Data Members
Class

CXTPSyntaxEditFindReplaceDlg Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bReplaceDlg | Stored dialog type.
m_pEditCtrl | Stored attached view.
m_ptWndPos | Stored window position.
Public Data Members
Public Data Member | Description
m_bMatchCase | Store Match Case option.
m_bMatchWholeWord | Store Match Whole Words option.
m_csFindText | Store text to find.
m_csReplaceText | Store text to replace.
m_nSearchDirection | Store Search Direction: 0-up, 1-down.


CXTPSyntaxEditFindReplaceDlg::m_bMatchCase Data Member

CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::m_bMatchCase Data Member

Store Match Case option.

BOOL m_bMatchCase;
Group

CXTPSyntaxEditFindReplaceDlg Data Members


CXTPSyntaxEditFindReplaceDlg::m_bMatchWholeWord Data Member

CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::m_bMatchWholeWord Data Member

Store Match Whole Words option.

BOOL m_bMatchWholeWord;
Group

CXTPSyntaxEditFindReplaceDlg Data Members


CXTPSyntaxEditFindReplaceDlg::m_bReplaceDlg Data Member

CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::m_bReplaceDlg Data Member

Stored dialog type.

BOOL m_bReplaceDlg;
Group

CXTPSyntaxEditFindReplaceDlg Data Members


CXTPSyntaxEditFindReplaceDlg::m_csFindText Data Member

CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::m_csFindText Data Member

Store text to find.

CString m_csFindText;
Group

CXTPSyntaxEditFindReplaceDlg Data Members


CXTPSyntaxEditFindReplaceDlg::m_csReplaceText Data Member

CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::m_csReplaceText Data Member

Store text to replace.

CString m_csReplaceText;
Group

CXTPSyntaxEditFindReplaceDlg Data Members


CXTPSyntaxEditFindReplaceDlg::m_nSearchDirection Data Member

CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::m_nSearchDirection Data Member

Store Search Direction: 0-up, 1-down.

int m_nSearchDirection;
Group

CXTPSyntaxEditFindReplaceDlg Data Members


CXTPSyntaxEditFindReplaceDlg::m_pEditCtrl Data Member

CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::m_pEditCtrl Data Member

Stored attached view.

CXTPSyntaxEditCtrl* m_pEditCtrl;
Group

CXTPSyntaxEditFindReplaceDlg Data Members


CXTPSyntaxEditFindReplaceDlg::m_ptWndPos Data Member

CXTPSyntaxEditFindReplaceDlg Data Members, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::m_ptWndPos Data Member

Stored window position.

CPoint m_ptWndPos;
Group

CXTPSyntaxEditFindReplaceDlg Data Members


CXTPSyntaxEditFindReplaceDlg Methods

CXTPSyntaxEditFindReplaceDlg Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg Methods
Class

CXTPSyntaxEditFindReplaceDlg Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
EnableControls | This method update controls state (enable or disable) for buttons: Find, Replace and ReplaceAll.
InitHistoryCombo | Use this method to initialize combobox from strings array.
LoadHistory | Use this method to load from application profile history for find and replace comboboxes and state for other dialog controls.
SaveHistory | Use this method to save to application profile history for find and replace comboboxes and state for other dialog controls.
UpdateHistoryCombo |
Public Methods
Public Methods
Public Method | Description
GetEdirControl | This method used to get attached edit control.
IsReplaceDialog | This method used to determine is 'Find and Replace' or only 'Find' dialog was created.
ShowDialog | This method used to show find or replace dialog. If window is not created this method loads a dialog template from resources and created modeless dialog.


CXTPSyntaxEditFindReplaceDlg::EnableControls Method

CXTPSyntaxEditFindReplaceDlg Methods, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::EnableControls Method

This method update controls state (enable or disable) for buttons: Find, Replace and ReplaceAll.

void EnableControls();
Group

CXTPSyntaxEditFindReplaceDlg Methods


CXTPSyntaxEditFindReplaceDlg::GetEdirControl Method

CXTPSyntaxEditFindReplaceDlg Methods, CXTPSyntaxEditFindReplaceDlg Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::GetEdirControl Method

This method used to get attached edit control.

CXTPSyntaxEditCtrl* GetEdirControl();
Returns

Pointer to CXTPSyntaxEditCtrl.

See Also

ShowDialog

Body Source
CXTPSyntaxEditCtrl* CXTPSyntaxEditFindReplaceDlg::GetEdirControl() {
    return m_pEditCtrl;
}
Group

CXTPSyntaxEditFindReplaceDlg Methods


CXTPSyntaxEditFindReplaceDlg::InitHistoryCombo Method

CXTPSyntaxEditFindReplaceDlg Methods, CXTPSyntaxEditFindReplaceDlg Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::InitHistoryCombo Method

Use this method to initialize combobox from strings array.

void InitHistoryCombo(
    CStringArray& arHistory,
    CComboBox& wndCombo
);
Parameters

arHistory
Array of strings.
wndCombo
A combobox control to add strings from array.

See Also

LoadHistory

Group

CXTPSyntaxEditFindReplaceDlg Methods


CXTPSyntaxEditFindReplaceDlg::IsReplaceDialog Method

CXTPSyntaxEditFindReplaceDlg Methods, CXTPSyntaxEditFindReplaceDlg Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::IsReplaceDialog Method

This method used to determine is 'Find and Replace' or only 'Find' dialog was created.

BOOL IsReplaceDialog();
Returns

TRUE for 'Find and Replace' dialog, FALSE for 'Find' dialog.

See Also

ShowDialog

Body Source
BOOL CXTPSyntaxEditFindReplaceDlg::IsReplaceDialog() {
    return m_bReplaceDlg;
}
Group

CXTPSyntaxEditFindReplaceDlg Methods


CXTPSyntaxEditFindReplaceDlg::LoadHistory Method

CXTPSyntaxEditFindReplaceDlg Methods, CXTPSyntaxEditFindReplaceDlg Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::LoadHistory Method

Use this method to load from application profile history for find and replace comboboxes and state for other dialog controls.

BOOL LoadHistory();
Returns

TRUE if successful, FALSE otherwise.

See Also

SaveHistory

Group

CXTPSyntaxEditFindReplaceDlg Methods


CXTPSyntaxEditFindReplaceDlg::SaveHistory Method

CXTPSyntaxEditFindReplaceDlg Methods, CXTPSyntaxEditFindReplaceDlg Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::SaveHistory Method

Use this method to save to application profile history for find and replace comboboxes and state for other dialog controls.

BOOL SaveHistory();
Returns

TRUE if successful, FALSE otherwise.

See Also

LoadHistory

Group

CXTPSyntaxEditFindReplaceDlg Methods


CXTPSyntaxEditFindReplaceDlg::ShowDialog Method

CXTPSyntaxEditFindReplaceDlg Methods, CXTPSyntaxEditFindReplaceDlg Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::ShowDialog Method

This method used to show find or replace dialog. If window is not created this method loads a dialog template from resources and created modeless dialog.

BOOL ShowDialog(
    CXTPSyntaxEditCtrl* pEditCtrl,
    BOOL bReplaceDlg = FALSE
);
Parameters

bReplaceDlg
Set TRUE to create replace dialog or FALSE to create find dialog.
pEditView
A pointer to CXTPSyntaxEditView.

Returns

TRUE if successful, FALSE otherwise.

See Also

ShowWindow

Group

CXTPSyntaxEditFindReplaceDlg Methods


UpdateHistoryCombo Method

CXTPSyntaxEditFindReplaceDlg Methods
UpdateHistoryCombo Method
Overload List
Methods
Method | Description
CXTPSyntaxEditFindReplaceDlg::UpdateHistoryCombo (const CString&, CStringArray&) | This function used to move or add string at the top of history items (item 0).
CXTPSyntaxEditFindReplaceDlg::UpdateHistoryCombo (const CString&, CStringArray&, CComboBox&) | This function used to move or add string at the top of history items (item 0).
Group

CXTPSyntaxEditFindReplaceDlg Methods


CXTPSyntaxEditFindReplaceDlg::UpdateHistoryCombo Method (const CString&, CStringArray&)

UpdateHistoryCombo Method, CXTPSyntaxEditFindReplaceDlg Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::UpdateHistoryCombo Method (const CString&, CStringArray&)

This function used to move or add string at the top of history items (item 0).

void UpdateHistoryCombo(
    const CString& csText,
    CStringArray& arHistory
);
void UpdateHistoryCombo(
    const CString& csText,
    CStringArray& arHistory,
    CComboBox& wndCombo
);
Parameters

csText
Text to move or add.
arHistory
History array.
wndCombo
History combobox.

Group

UpdateHistoryCombo Method


CXTPSyntaxEditFindReplaceDlg Constructors

CXTPSyntaxEditFindReplaceDlg Class, Legend, Public Methods
CXTPSyntaxEditFindReplaceDlg Constructors
Class

CXTPSyntaxEditFindReplaceDlg Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditFindReplaceDlg | Default object constructor.


CXTPSyntaxEditFindReplaceDlg::CXTPSyntaxEditFindReplaceDlg Constructor

CXTPSyntaxEditFindReplaceDlg Constructors, CXTPSyntaxEditFindReplaceDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditFindReplaceDlg::CXTPSyntaxEditFindReplaceDlg Constructor

Default object constructor.

CXTPSyntaxEditFindReplaceDlg(
    CWnd* pParentWnd = NULL
);
Parameters

pParentWnd
pointer to a parent window.

Group

CXTPSyntaxEditFindReplaceDlg Constructors


CXTPSyntaxEditGoToLineDlg Class

XTPSyntaxEditGoToLineDlg.h, Classes, Legend, Members, Topics, CXTPSyntaxEditGoToLineDlg Data Members, CXTPSyntaxEditGoToLineDlg Methods, CXTPSyntaxEditGoToLineDlg Constructors, CXTPSyntaxEditGoToLineDlg Constructors, CXTPSyntaxEditGoToLineDlg Data Members, CXTPSyntaxEditGoToLineDlg Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg Class

This class implements a GoToLine dialog for a SyntaxEdit control.

Class Hierarchy

class CXTPSyntaxEditGoToLineDlg : public CDialog;
File

XTPSyntaxEditGoToLineDlg.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditGoToLineDlg Constructors
CXTPSyntaxEditGoToLineDlg Constructors | Description
CXTPSyntaxEditGoToLineDlg | Default object constructor.
CXTPSyntaxEditGoToLineDlg Data Members
CXTPSyntaxEditGoToLineDlg Data Members | Description
m_bHideOnFind | Store Hide On Find option.
m_bSelectLine | Store Select Line option.
m_iMaxLineNo | Store a maximum line number.
m_pEditCtrl | Store attached edit control.
m_ptWndPos | Store window position.
CXTPSyntaxEditGoToLineDlg Methods
CXTPSyntaxEditGoToLineDlg Methods | Description
LoadPos | Load window position from application profile.
SavePos | Save window position to application profile.
ShowDialog | This method used to show dialog. If window is not created this method loads a dialog template from resources and created modeless dialog.


CXTPSyntaxEditGoToLineDlg Data Members

CXTPSyntaxEditGoToLineDlg Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg Data Members
Class

CXTPSyntaxEditGoToLineDlg Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bHideOnFind | Store Hide On Find option.
m_bSelectLine | Store Select Line option.
m_iMaxLineNo | Store a maximum line number.
m_pEditCtrl | Store attached edit control.
m_ptWndPos | Store window position.


CXTPSyntaxEditGoToLineDlg::m_bHideOnFind Data Member

CXTPSyntaxEditGoToLineDlg Data Members, CXTPSyntaxEditGoToLineDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::m_bHideOnFind Data Member

Store Hide On Find option.

BOOL m_bHideOnFind;
Group

CXTPSyntaxEditGoToLineDlg Data Members


CXTPSyntaxEditGoToLineDlg::m_bSelectLine Data Member

CXTPSyntaxEditGoToLineDlg Data Members, CXTPSyntaxEditGoToLineDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::m_bSelectLine Data Member

Store Select Line option.

BOOL m_bSelectLine;
Group

CXTPSyntaxEditGoToLineDlg Data Members


CXTPSyntaxEditGoToLineDlg::m_iMaxLineNo Data Member

CXTPSyntaxEditGoToLineDlg Data Members, CXTPSyntaxEditGoToLineDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::m_iMaxLineNo Data Member

Store a maximum line number.

int m_iMaxLineNo;
Group

CXTPSyntaxEditGoToLineDlg Data Members


CXTPSyntaxEditGoToLineDlg::m_pEditCtrl Data Member

CXTPSyntaxEditGoToLineDlg Data Members, CXTPSyntaxEditGoToLineDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::m_pEditCtrl Data Member

Store attached edit control.

CXTPSyntaxEditCtrl* m_pEditCtrl;
Group

CXTPSyntaxEditGoToLineDlg Data Members


CXTPSyntaxEditGoToLineDlg::m_ptWndPos Data Member

CXTPSyntaxEditGoToLineDlg Data Members, CXTPSyntaxEditGoToLineDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::m_ptWndPos Data Member

Store window position.

CPoint m_ptWndPos;
Group

CXTPSyntaxEditGoToLineDlg Data Members


CXTPSyntaxEditGoToLineDlg Methods

CXTPSyntaxEditGoToLineDlg Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg Methods
Class

CXTPSyntaxEditGoToLineDlg Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
LoadPos | Load window position from application profile.
SavePos | Save window position to application profile.
Public Methods
Public Methods
Public Method | Description
ShowDialog | This method used to show dialog. If window is not created this method loads a dialog template from resources and created modeless dialog.


CXTPSyntaxEditGoToLineDlg::LoadPos Method

CXTPSyntaxEditGoToLineDlg Methods, CXTPSyntaxEditGoToLineDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::LoadPos Method

Load window position from application profile.

virtual BOOL LoadPos();
Returns

TRUE if successful, FALSE otherwise.

Group

CXTPSyntaxEditGoToLineDlg Methods


CXTPSyntaxEditGoToLineDlg::SavePos Method

CXTPSyntaxEditGoToLineDlg Methods, CXTPSyntaxEditGoToLineDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::SavePos Method

Save window position to application profile.

virtual BOOL SavePos();
Returns

TRUE if successful, FALSE otherwise.

Group

CXTPSyntaxEditGoToLineDlg Methods


CXTPSyntaxEditGoToLineDlg::ShowDialog Method

CXTPSyntaxEditGoToLineDlg Methods, CXTPSyntaxEditGoToLineDlg Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::ShowDialog Method

This method used to show dialog. If window is not created this method loads a dialog template from resources and created modeless dialog.

BOOL ShowDialog(
    CXTPSyntaxEditCtrl* pEditCtrl,
    BOOL bSelectLine = FALSE,
    BOOL bHideOnFind = FALSE
);
Parameters

pEditCtrl
A pointer to CXTPSyntaxEditCtrl.
bSelectLine
Select Line option state.
bHideOnFind
Hide On Find option state.

Returns

TRUE if successful, FALSE otherwise.

See Also

ShowWindow

Group

CXTPSyntaxEditGoToLineDlg Methods


CXTPSyntaxEditGoToLineDlg Constructors

CXTPSyntaxEditGoToLineDlg Class, Legend, Public Methods
CXTPSyntaxEditGoToLineDlg Constructors
Class

CXTPSyntaxEditGoToLineDlg Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditGoToLineDlg | Default object constructor.


CXTPSyntaxEditGoToLineDlg::CXTPSyntaxEditGoToLineDlg Constructor

CXTPSyntaxEditGoToLineDlg Constructors, CXTPSyntaxEditGoToLineDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditGoToLineDlg::CXTPSyntaxEditGoToLineDlg Constructor

Default object constructor.

CXTPSyntaxEditGoToLineDlg(
    CWnd* pParent = NULL
);
Parameters

pParent
pointer to a parent window.

Group

CXTPSyntaxEditGoToLineDlg Constructors


CXTPSyntaxEditInsertStringCommand Class

XTPSyntaxEditUndoManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditInsertStringCommand Methods, CXTPSyntaxEditInsertStringCommand Constructors, CXTPSyntaxEditInsertStringCommand Destructors, CXTPSyntaxEditInsertStringCommand Constructors, CXTPSyntaxEditInsertStringCommand Destructors, CXTPSyntaxEditInsertStringCommand Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditInsertStringCommand Class

This class represents text insertion command. Command execution will insert a specified text string in the buffer, un-execution will delete this text from the buffer.

Class Hierarchy

class CXTPSyntaxEditInsertStringCommand : public CXTPSyntaxEditBufferCommand;
File

XTPSyntaxEditUndoManager.h

See Also

CXTPSyntaxEditBufferCommand, CXTPSyntaxEditDeleteStringCommand

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditInsertStringCommand Constructors
CXTPSyntaxEditInsertStringCommand Constructors | Description
CXTPSyntaxEditInsertStringCommand | Creates the insert string command object, initializes its members.
CXTPSyntaxEditInsertStringCommand Destructors
CXTPSyntaxEditInsertStringCommand Destructors | Description
~CXTPSyntaxEditInsertStringCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.
CXTPSyntaxEditInsertStringCommand Methods
CXTPSyntaxEditInsertStringCommand Methods | Description
Execute | Executes insert string command.
UnExecute | Unexecutes insert string command (i.e. deletes the string).


CXTPSyntaxEditInsertStringCommand Methods

CXTPSyntaxEditInsertStringCommand Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditInsertStringCommand Methods
Class

CXTPSyntaxEditInsertStringCommand Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Execute | Executes insert string command.
UnExecute | Unexecutes insert string command (i.e. deletes the string).


CXTPSyntaxEditInsertStringCommand::Execute Method

CXTPSyntaxEditInsertStringCommand Methods, CXTPSyntaxEditInsertStringCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditInsertStringCommand::Execute Method

Executes insert string command.

virtual int Execute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

UnExecute

Group

CXTPSyntaxEditInsertStringCommand Methods


CXTPSyntaxEditInsertStringCommand::UnExecute Method

CXTPSyntaxEditInsertStringCommand Methods, CXTPSyntaxEditInsertStringCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditInsertStringCommand::UnExecute Method

Unexecutes insert string command (i.e. deletes the string).

virtual int UnExecute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW

See Also

Execute

Group

CXTPSyntaxEditInsertStringCommand Methods


CXTPSyntaxEditInsertStringCommand Constructors

CXTPSyntaxEditInsertStringCommand Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditInsertStringCommand Constructors
Class

CXTPSyntaxEditInsertStringCommand Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditInsertStringCommand | Creates the insert string command object, initializes its members.


CXTPSyntaxEditInsertStringCommand::CXTPSyntaxEditInsertStringCommand Constructor

CXTPSyntaxEditInsertStringCommand Constructors, CXTPSyntaxEditInsertStringCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditInsertStringCommand::CXTPSyntaxEditInsertStringCommand Constructor

Creates the insert string command object, initializes its members.

CXTPSyntaxEditInsertStringCommand(
    CXTPSyntaxEditBufferManager* pMgr,
    LPCTSTR szText,
    const XTP_EDIT_LINECOL& lcFrom,
    const XTP_EDIT_LINECOL& lcTo
);
Parameters

pMgr
[in] Pointer to the associated buffer manager object.
szText
[in] A text which was changed during buffer operation. It will be used for insert/remove text operations.
lcFrom
[in] Start text position affected by the command.
lcTo
[in] End text position affected by the command.

Group

CXTPSyntaxEditInsertStringCommand Constructors


CXTPSyntaxEditInsertStringCommand Destructors

CXTPSyntaxEditInsertStringCommand Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditInsertStringCommand Destructors
Class

CXTPSyntaxEditInsertStringCommand Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditInsertStringCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.


CXTPSyntaxEditInsertStringCommand::~CXTPSyntaxEditInsertStringCommand Destructor

CXTPSyntaxEditInsertStringCommand Destructors, CXTPSyntaxEditInsertStringCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditInsertStringCommand::~CXTPSyntaxEditInsertStringCommand Destructor

A default command destructor. Destroys the command object, handles its cleanup and de-allocation.

virtual ~CXTPSyntaxEditInsertStringCommand();
Group

CXTPSyntaxEditInsertStringCommand Destructors


CXTPSyntaxEditLexCfgFileReader Class

XTPSyntaxEditLexCfgFileReader.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Destructors, CXTPSyntaxEditLexCfgFileReader Nested Types, CXTPSyntaxEditLexCfgFileReader Destructors, CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader Class

This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes lex class instances that represent various lexical items for given language. You construct instance of CXTPSyntaxEditLexCfgFileReader by calling constructor. Then you should call ReadSource() member function to read data from persistent storage (file for this implementation), and process raw data into XTP_EDIT_LEXCLASSINFO structures. Call GetLexClassInfoArray() member function to return a pointer to an array of XTP_EDIT_LEXCLASSINFO data structures.

Class Hierarchy

class CXTPSyntaxEditLexCfgFileReader;
File

XTPSyntaxEditLexCfgFileReader.h

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditLexCfgFileReader Destructors
CXTPSyntaxEditLexCfgFileReader Destructors | Description
~CXTPSyntaxEditLexCfgFileReader | Destroys a CXTPSyntaxEditLexCfgFileReader object, handles cleanup and de-allocation
CXTPSyntaxEditLexCfgFileReader Methods
CXTPSyntaxEditLexCfgFileReader Methods | Description
CleanInfoMap | Use this member function to clear map and delete its data.
CopyInfoMap | Use this member function to internal classes map and its data. Use CleanInfoMap to free (delete) map data.
ESToStr | Converts char to corresponding escape char sequences.
GetLexClassInfoArray | Returns pointer to the internal array with XTP_EDIT_LEXCLASSINFO structures.
GetLexClassInfoMap | Returns pointer to the internal map with CXTPSyntaxEditLexClassInfoArray objects.
ReadSource |
StrToES | Converts escape char sequences to corresponding char.
WriteCfgFile | Writes LexClasses to given schema configuration file
CXTPSyntaxEditLexCfgFileReader Nested Types
CXTPSyntaxEditLexCfgFileReader Nested Types | Description
CMapPtrToBool | A map describes whether property description has a flag or not.


CXTPSyntaxEditLexCfgFileReader Methods

CXTPSyntaxEditLexCfgFileReader Class, Legend, Public Methods
CXTPSyntaxEditLexCfgFileReader Methods
Class

CXTPSyntaxEditLexCfgFileReader Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
CleanInfoMap | Use this member function to clear map and delete its data.
CopyInfoMap | Use this member function to internal classes map and its data. Use CleanInfoMap to free (delete) map data.
ESToStr | Converts char to corresponding escape char sequences.
GetLexClassInfoArray | Returns pointer to the internal array with XTP_EDIT_LEXCLASSINFO structures.
GetLexClassInfoMap | Returns pointer to the internal map with CXTPSyntaxEditLexClassInfoArray objects.
ReadSource |
StrToES | Converts escape char sequences to corresponding char.
WriteCfgFile | Writes LexClasses to given schema configuration file


CXTPSyntaxEditLexCfgFileReader::CleanInfoMap Method

CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::CleanInfoMap Method

Use this member function to clear map and delete its data.

void CleanInfoMap(
    CMapStringToPtr& mapInfo
);
Parameters

mapInfo
A reference to map object.

See Also

CopyInfoMap

Group

CXTPSyntaxEditLexCfgFileReader Methods


CXTPSyntaxEditLexCfgFileReader::CopyInfoMap Method

CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::CopyInfoMap Method

Use this member function to internal classes map and its data. Use CleanInfoMap to free (delete) map data.

void CopyInfoMap(
    CMapStringToPtr& mapInfo
);
Parameters

mapInfo
[out] A reference to map object.

See Also

CleanInfoMap

Group

CXTPSyntaxEditLexCfgFileReader Methods


CXTPSyntaxEditLexCfgFileReader::ESToStr Method

CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::ESToStr Method

Converts char to corresponding escape char sequences.

CString ESToStr(
    CString strSrc,
    BOOL bQuoted
);
Parameters

strSrc
[in] CString with text to convert.
bQuoted
[in] Boolean flag determines that text should be interpreted as text enclosed by single quotes(')

Returns

CString with converted text.

Remarks

Use this member function to convert text with chars that are represented by escape sequences to corresponding escape char sequences (like \n, \t, etc)

Group

CXTPSyntaxEditLexCfgFileReader Methods


CXTPSyntaxEditLexCfgFileReader::GetLexClassInfoArray Method

CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::GetLexClassInfoArray Method

Returns pointer to the internal array with XTP_EDIT_LEXCLASSINFO structures.

CXTPSyntaxEditLexClassInfoArray& GetLexClassInfoArray();
Returns

Pointer to CXTPSyntaxEditLexClassInfoArray array.

Remarks

Use this member function to get pointer to the internal array with XTP_EDIT_LEXCLASSINFO structures, then you may operate with array members.

Group

CXTPSyntaxEditLexCfgFileReader Methods


CXTPSyntaxEditLexCfgFileReader::GetLexClassInfoMap Method

CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::GetLexClassInfoMap Method

Returns pointer to the internal map with CXTPSyntaxEditLexClassInfoArray objects.

CMapStringToPtr& GetLexClassInfoMap();
Returns

Pointer to CMapStringToPtr map.

Remarks

The key is lex class name, the data is pointer to CXTPSyntaxEditLexClassInfoArray object.

Body Source
CMapStringToPtr& GetLexClassInfoMap() {
    return m_mapLexClassInfo;
}
Group

CXTPSyntaxEditLexCfgFileReader Methods


ReadSource Method

CXTPSyntaxEditLexCfgFileReader Methods
ReadSource Method
Overload List
Methods
Method | Description
CXTPSyntaxEditLexCfgFileReader::ReadSource (UINT) | Reads data from resources.
CXTPSyntaxEditLexCfgFileReader::ReadSource (const CString&, BOOL) | Reads data from the configuration file.
Group

CXTPSyntaxEditLexCfgFileReader Methods


CXTPSyntaxEditLexCfgFileReader::ReadSource Method (UINT)

ReadSource Method, CXTPSyntaxEditLexCfgFileReader Class
CXTPSyntaxEditLexCfgFileReader::ReadSource Method (UINT)

Reads data from resources.

void ReadSource(
    UINT nResourceID
);
Parameters

nResourceID
[in] Resource ID of the HTML configuration data.

Remarks

Use this member function to read configuration data from application resources with predefined structure. Data loaded into internal data buffer.

Group

ReadSource Method


CXTPSyntaxEditLexCfgFileReader::ReadSource Method (const CString&, BOOL)

ReadSource Method, CXTPSyntaxEditLexCfgFileReader Class
CXTPSyntaxEditLexCfgFileReader::ReadSource Method (const CString&, BOOL)

Reads data from the configuration file.

void ReadSource(
    const CString& csFileName,
    BOOL bSaveInfo
);
Parameters

csFileName
[in] string, containing full path to the configuration file.
bSaveInfo
[in] Set as TRUE to save readed data in the LexClassInfoMap.

Remarks

Use this member function to read configuration data from configuration file with predefined structure. Data loaded into internal data buffer.

Group

ReadSource Method


CXTPSyntaxEditLexCfgFileReader::StrToES Method

CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::StrToES Method

Converts escape char sequences to corresponding char.

CString StrToES(
    CString strSrc,
    BOOL bQuoted
);
Parameters

strSrc
[in] CString with text to convert.
bQuoted
[in] Boolean flag determines that text should be interpreted as text enclosed by single quotes(')Boolean flag determines

Returns

CString with converted text.

Remarks

Use this member function to convert text with escape char sequences (like \n, \t, etc) to corresponding char

Group

CXTPSyntaxEditLexCfgFileReader Methods


CXTPSyntaxEditLexCfgFileReader::WriteCfgFile Method

CXTPSyntaxEditLexCfgFileReader Methods, CXTPSyntaxEditLexCfgFileReader Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::WriteCfgFile Method

Writes LexClasses to given schema configuration file

BOOL WriteCfgFile(
    const CString& csFileName,
    CXTPSyntaxEditLexClassInfoArray& arLexClassDesc
);
Parameters

csFileName
Configuration file name.
arLexClassDesc
Array with lex class data (description) to save.

Returns

TRUE if successful, FALSE otherwise.

Group

CXTPSyntaxEditLexCfgFileReader Methods


CXTPSyntaxEditLexCfgFileReader Destructors

CXTPSyntaxEditLexCfgFileReader Class, Legend, Public Methods
CXTPSyntaxEditLexCfgFileReader Destructors
Class

CXTPSyntaxEditLexCfgFileReader Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexCfgFileReader | Destroys a CXTPSyntaxEditLexCfgFileReader object, handles cleanup and de-allocation


CXTPSyntaxEditLexCfgFileReader::~CXTPSyntaxEditLexCfgFileReader Destructor

CXTPSyntaxEditLexCfgFileReader Destructors, CXTPSyntaxEditLexCfgFileReader Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::~CXTPSyntaxEditLexCfgFileReader Destructor

Destroys a CXTPSyntaxEditLexCfgFileReader object, handles cleanup and de-allocation

virtual ~CXTPSyntaxEditLexCfgFileReader();
Group

CXTPSyntaxEditLexCfgFileReader Destructors


CXTPSyntaxEditLexCfgFileReader Nested Types

CXTPSyntaxEditLexCfgFileReader Class, Public Nested Types
CXTPSyntaxEditLexCfgFileReader Nested Types
Class

CXTPSyntaxEditLexCfgFileReader Class

Public Nested Types
Public Nested Type | Description
CMapPtrToBool | A map describes whether property description has a flag or not.


CXTPSyntaxEditLexCfgFileReader::CMapPtrToBool Nested Type

CXTPSyntaxEditLexCfgFileReader Nested Types, CXTPSyntaxEditLexCfgFileReader Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexCfgFileReader::CMapPtrToBool Nested Type

A map describes whether property description has a flag or not.

typedef CMap<void*, void*, bool, bool> CMapPtrToBool;
Group

CXTPSyntaxEditLexCfgFileReader Nested Types


CXTPSyntaxEditLexClass Class

XTPSyntaxEditLexClass.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexClass Data Members, CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Constructors, CXTPSyntaxEditLexClass Destructors, CXTPSyntaxEditLexClass Nested Types, CXTPSyntaxEditLexClass Constructors, CXTPSyntaxEditLexClass Data Members, CXTPSyntaxEditLexClass Destructors, CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Nested Types, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass Class

CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.

Class Hierarchy

class CXTPSyntaxEditLexClass : protected CXTPSyntaxEditLexObj_SpecCollT< CXTPSyntaxEditLexObj_Previous, CXTPSyntaxEditLexObj_Start, CXTPSyntaxEditLexObj_End, CXTPSyntaxEditLexObj_Token, CXTPSyntaxEditLexObj_Skip, CXTPSyntaxEditLexObj_ActiveTags >;
File

XTPSyntaxEditLexClass.h

See Also

CXTPSyntaxEditLexClassSchema, CXTPSyntaxEditLexObj_SpecCollT.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditLexClass Constructors
CXTPSyntaxEditLexClass Constructors | Description
CXTPSyntaxEditLexClass | Default object constructor.
CXTPSyntaxEditLexClass Data Members
CXTPSyntaxEditLexClass Data Members | Description
m_nActiv_EndTags_Offset | First index of end active tags set in the Active Tags collection (m_ActiveTags member).
CXTPSyntaxEditLexClass Destructors
CXTPSyntaxEditLexClass Destructors | Description
~CXTPSyntaxEditLexClass | Default object destructor.
CXTPSyntaxEditLexClass Methods
CXTPSyntaxEditLexClass Methods | Description
Close | Close Lex Class.
CloseClasses | Close specified Lex Classes.
DumpOffset | Trace parsed lex classes. Write debug info to debug window.
GetActiveTags | Get active tags for the Lex Class.
GetAttribute | Get Lex Class attribute by attribute name.
GetAttribute_BOOL | Get Lex Class attribute by attribute name.
GetAttribute_int | Get Lex Class attribute by attribute name.
GetChildren | Get specified children for the Lex Class.
GetChildrenDyn | Get specified children for the Lex Class.
GetChildrenSelfRef | Get specified children for the Lex Class.
GetClassName | Get Lex Class name.
GetTextAttributes | Is Lex Class Collapsable.
IsCaseSensitive | Is Lex Class case sensitive.
IsCollapsable | Is Lex Class Collapsable.
PropV | Get object property by property name.
SetAttribute | Sets Lex Class attribute.
XTP_EDIT_LEX_CLASS_OBJ_MEMBER |
CXTPSyntaxEditLexClass Nested Types
CXTPSyntaxEditLexClass Nested Types | Description
TBase | CXTPSyntaxEditLexClass::TBase is the base collection type for CXTPSyntaxEditLexClass. It is used to access base members and types.


CXTPSyntaxEditLexClass Data Members

CXTPSyntaxEditLexClass Class, Legend, Protected Data Members
CXTPSyntaxEditLexClass Data Members
Class

CXTPSyntaxEditLexClass Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nActiv_EndTags_Offset | First index of end active tags set in the Active Tags collection (m_ActiveTags member).


CXTPSyntaxEditLexClass::m_nActiv_EndTags_Offset Data Member

CXTPSyntaxEditLexClass Data Members, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::m_nActiv_EndTags_Offset Data Member

First index of end active tags set in the Active Tags collection (m_ActiveTags member).

int m_nActiv_EndTags_Offset;
Group

CXTPSyntaxEditLexClass Data Members


CXTPSyntaxEditLexClass Methods

CXTPSyntaxEditLexClass Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass Methods
Class

CXTPSyntaxEditLexClass Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DumpOffset | Trace parsed lex classes. Write debug info to debug window.
GetActiveTags | Get active tags for the Lex Class.
GetChildren | Get specified children for the Lex Class.
GetChildrenDyn | Get specified children for the Lex Class.
GetChildrenSelfRef | Get specified children for the Lex Class.
SetAttribute | Sets Lex Class attribute.
XTP_EDIT_LEX_CLASS_OBJ_MEMBER |
Public Methods
Public Methods
Public Method | Description
Close | Close Lex Class.
CloseClasses | Close specified Lex Classes.
GetAttribute | Get Lex Class attribute by attribute name.
GetAttribute_BOOL | Get Lex Class attribute by attribute name.
GetAttribute_int | Get Lex Class attribute by attribute name.
GetClassName | Get Lex Class name.
GetTextAttributes | Is Lex Class Collapsable.
IsCaseSensitive | Is Lex Class case sensitive.
IsCollapsable | Is Lex Class Collapsable.
PropV | Get object property by property name.


CXTPSyntaxEditLexClass::Close Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::Close Method

Close Lex Class.

virtual void Close();
Remarks

Kill All relations between this class and parent and children. Close children classes. Clear internal collections. Close() must be called as first step in destroy object procedure. The second step is InternalRelease() call.

See Also

CXTPSyntaxEditLexClass::CloseClasses()

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::CloseClasses Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::CloseClasses Method

Close specified Lex Classes.

static void CloseClasses(
    CXTPSyntaxEditLexClassPtrArray* pArClasses
);
Parameters

pArClasses
[in] Pointer to the classes array.

Remarks

Call Close() method for every Lex Class in the specified array. Remove all objects from the array.

See Also

CXTPSyntaxEditLexClass::Close()

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::DumpOffset Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class
CXTPSyntaxEditLexClass::DumpOffset Method

Trace parsed lex classes. Write debug info to debug window.

void DumpOffset(
    CDumpContext& dc,
    LPCTSTR pcszOffset
);
Parameters

dc
[in] A reference to CDumpContext object.
pcszOffset
[in] user defined text.

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::GetActiveTags Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::GetActiveTags Method

Get active tags for the Lex Class.

------------------------------------------------------------------

virtual CXTPSyntaxEditLexVariantPtrArray* GetActiveTags();

virtual CXTPSyntaxEditLexObj_ActiveTags* GetActiveTags();
Body Source
CXTPSyntaxEditLexObj_ActiveTags* CXTPSyntaxEditLexClass::GetActiveTags()
{
    return  &m_ActiveTags;
}
Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::GetAttribute Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::GetAttribute Method

Get Lex Class attribute by attribute name.

virtual CXTPSyntaxEditLexVariantPtr GetAttribute(
    LPCTSTR strName,
    BOOL bDyn
) const;
virtual BOOL GetAttribute_BOOL(
    LPCTSTR strName,
    BOOL bDyn,
    BOOL bDefault = FALSE
) const;
virtual int GetAttribute_int(
    LPCTSTR strName,
    BOOL bDyn,
    int nDefault = 0
) const;
Parameters

strName
[in] Attribute name.
bDyn
[in] If FALSE - attribute value is searched only in this class attribute collection; If TRUE - attribute value is searched in this class attribute collection at the first and, if value is not finded, it is searched in parent(s) class(es) attribute collection(s).
bDefault
[in] Default BOOL value.
nDefault
[in] Default int value.

Returns

Attribute value or NULL or default value.

Remarks

Call this method to access Lex Classes attributes, like "txt:colorFG", ...

See Also

XTPLEX_ATTR_*, SetAttribute(), Classes schema syntax.

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::GetChildren Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::GetChildren Method

Get specified children for the Lex Class.

virtual CXTPSyntaxEditLexClassPtrArray* GetChildren();
virtual CXTPSyntaxEditLexClassPtrArray* GetChildrenDyn();
virtual CXTPSyntaxEditLexClassPtrArray* GetChildrenSelfRef();
Parameters

bWithAddRef
[in] If parameter value is TRUE InternalAddRef() is called for the returned object.

Remarks

Call this method(s) to get pointer to the array which contains children classes.

See Also

GetChildren(), GetChildrenDyn(), GetChildrenSelfRef().

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::GetClassName Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::GetClassName Method

Get Lex Class name.

virtual CString GetClassName() const;
Returns

Lex Class name.

Remarks

Lex Class name is specified in classes schema file by 'name' property.

See Also

Classes schema syntax.

Body Source
CString CXTPSyntaxEditLexClass::GetClassName() const {
    return m_strClassName;
}
Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::GetTextAttributes Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::GetTextAttributes Method

Is Lex Class Collapsable.

virtual void GetTextAttributes(
    XTP_EDIT_TEXTBLOCK& rTB
);
Parameters

rTB
[out] Pointer to the classes array.

Returns

"Collapsable" attribute value..

Remarks

Use this method instead of GetAttribute() to fast access "Collapsable" attribute value.

See Also

GetAttribute(), XTPLEX_ATTR_COLLAPSABLE, Classes schema syntax.

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::IsCaseSensitive Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::IsCaseSensitive Method

Is Lex Class case sensitive.

virtual BOOL IsCaseSensitive();
Returns

"CaseSensitive" attribute value..

Remarks

Use this method instead of GetAttribute() to fast access "CaseSensitive" attribute value.

See Also

GetAttribute(), XTPLEX_ATTR_CASESENSITIVE, Classes schema syntax.

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::IsCollapsable Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::IsCollapsable Method

Is Lex Class Collapsable.

virtual int IsCollapsable();
Returns

"Collapsable" attribute value..

Remarks

Use this method instead of GetAttribute() to fast access "Collapsable" attribute value.

See Also

GetAttribute(), XTPLEX_ATTR_COLLAPSABLE, Classes schema syntax.

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::PropV Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::PropV Method

Get object property by property name.

virtual CXTPSyntaxEditLexVariantPtr PropV(
    LPCTSTR pcszPropName
);
Parameters

pcszPropName
[in] Property name.

Returns

Smart pointer to CXTPSyntaxEditLexVariant object with type xtpEditLVT_LVArrayPtr.

Remarks

Property names are parent collection (TBase) sub-objects names; like "start:tag", "token:start:separators", ... For details see Classes schema syntax and CXTPSyntaxEditLexClass::TBase.

See Also

CXTPSyntaxEditLexClass::TBase, Classes schema syntax.

Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::SetAttribute Method

CXTPSyntaxEditLexClass Methods, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::SetAttribute Method

Sets Lex Class attribute.

virtual void SetAttribute(
    CString strName,
    const CXTPSyntaxEditLexVariant& rVal
);
Parameters

strName
[in] Attribute name.
rVal
[in] Attribute value.

Remarks

Call this method to set Lex Class attributes, like "txt:colorFG", ...

See Also

XTPLEX_ATTR_*, GetAttribute(), Classes schema syntax.

Group

CXTPSyntaxEditLexClass Methods


XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method

CXTPSyntaxEditLexClass Methods
XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method
Overload List
Methods
Method | Description
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER (0, m_previous) | 'previous' Lex Class property collection.
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER (1, m_start) | 'start' Lex Class property collection.
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER (2, m_end) | 'end' Lex Class property collection.
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER (3, m_token) | 'token' Lex Class property collection.
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER (4, m_skip) | 'skip' Lex Class property collection.
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER (5, m_ActiveTags) | Active Tags collection.
Group

CXTPSyntaxEditLexClass Methods


CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (0, m_previous)

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (0, m_previous)

'previous' Lex Class property collection.

XTP_EDIT_LEX_CLASS_OBJ_MEMBER(
    0,
    m_previous
);
Group

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method


CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (1, m_start)

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (1, m_start)

'start' Lex Class property collection.

XTP_EDIT_LEX_CLASS_OBJ_MEMBER(
    1,
    m_start
);
Group

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method


CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (2, m_end)

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (2, m_end)

'end' Lex Class property collection.

XTP_EDIT_LEX_CLASS_OBJ_MEMBER(
    2,
    m_end
);
Group

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method


CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (3, m_token)

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (3, m_token)

'token' Lex Class property collection.

XTP_EDIT_LEX_CLASS_OBJ_MEMBER(
    3,
    m_token
);
Group

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method


CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (4, m_skip)

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (4, m_skip)

'skip' Lex Class property collection.

XTP_EDIT_LEX_CLASS_OBJ_MEMBER(
    4,
    m_skip
);
Group

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method


CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (5, m_ActiveTags)

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method (5, m_ActiveTags)

Active Tags collection.

XTP_EDIT_LEX_CLASS_OBJ_MEMBER(
    5,
    m_ActiveTags
);
Group

XTP_EDIT_LEX_CLASS_OBJ_MEMBER Method


CXTPSyntaxEditLexClass Constructors

CXTPSyntaxEditLexClass Class, Legend, Public Methods
CXTPSyntaxEditLexClass Constructors
Class

CXTPSyntaxEditLexClass Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexClass | Default object constructor.


CXTPSyntaxEditLexClass::CXTPSyntaxEditLexClass Constructor

CXTPSyntaxEditLexClass Constructors, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::CXTPSyntaxEditLexClass Constructor

Default object constructor.

CXTPSyntaxEditLexClass();
Group

CXTPSyntaxEditLexClass Constructors


CXTPSyntaxEditLexClass Destructors

CXTPSyntaxEditLexClass Class, Legend, Public Methods
CXTPSyntaxEditLexClass Destructors
Class

CXTPSyntaxEditLexClass Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexClass | Default object destructor.


CXTPSyntaxEditLexClass::~CXTPSyntaxEditLexClass Destructor

CXTPSyntaxEditLexClass Destructors, CXTPSyntaxEditLexClass Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::~CXTPSyntaxEditLexClass Destructor

Default object destructor.

virtual ~CXTPSyntaxEditLexClass();
Group

CXTPSyntaxEditLexClass Destructors


CXTPSyntaxEditLexClass Nested Types

CXTPSyntaxEditLexClass Class, Public Nested Types
CXTPSyntaxEditLexClass Nested Types
Class

CXTPSyntaxEditLexClass Class

Public Nested Types
Public Nested Type | Description
TBase | CXTPSyntaxEditLexClass::TBase is the base collection type for CXTPSyntaxEditLexClass. It is used to access base members and types.


CXTPSyntaxEditLexClass::TBase Nested Type

CXTPSyntaxEditLexClass Nested Types, CXTPSyntaxEditLexClass Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexClass::TBase Nested Type

CXTPSyntaxEditLexClass::TBase is the base collection type for CXTPSyntaxEditLexClass. It is used to access base members and types.

typedef CXTPSyntaxEditLexObj_SpecCollT< CXTPSyntaxEditLexObj_Previous, CXTPSyntaxEditLexObj_Start, CXTPSyntaxEditLexObj_End, CXTPSyntaxEditLexObj_Token, CXTPSyntaxEditLexObj_Skip, CXTPSyntaxEditLexObj_ActiveTags > TBase;
See Also

CXTPSyntaxEditLexClassSchema, CXTPSyntaxEditLexObj_SpecCollT.

Group

CXTPSyntaxEditLexClass Nested Types


CXTPSyntaxEditLexOnScreenParseCnt Class

XTPSyntaxEditLexClass.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexOnScreenParseCnt Data Members, CXTPSyntaxEditLexOnScreenParseCnt Constructors, CXTPSyntaxEditLexOnScreenParseCnt Destructors, CXTPSyntaxEditLexOnScreenParseCnt Constructors, CXTPSyntaxEditLexOnScreenParseCnt Data Members, CXTPSyntaxEditLexOnScreenParseCnt Destructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt Class

CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process.

Class Hierarchy

class CXTPSyntaxEditLexOnScreenParseCnt;
File

XTPSyntaxEditLexClass.h

See Also

CXTPSyntaxEditLexClass, CXTPSyntaxEditLexTextSchema

Group

Classes

Legend
Data Member
Constructor
virtual
CXTPSyntaxEditLexOnScreenParseCnt Constructors
CXTPSyntaxEditLexOnScreenParseCnt Constructors | Description
CXTPSyntaxEditLexOnScreenParseCnt | Default object constructor.
CXTPSyntaxEditLexOnScreenParseCnt Data Members
CXTPSyntaxEditLexOnScreenParseCnt Data Members | Description
m_nRowEnd | End row for parse.
m_nRowStart | Start row for parse.
m_ptrTBLast | Latest found text block.
CXTPSyntaxEditLexOnScreenParseCnt Destructors
CXTPSyntaxEditLexOnScreenParseCnt Destructors | Description
~CXTPSyntaxEditLexOnScreenParseCnt | Default object destructor.


CXTPSyntaxEditLexOnScreenParseCnt Data Members

CXTPSyntaxEditLexOnScreenParseCnt Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt Data Members
Class

CXTPSyntaxEditLexOnScreenParseCnt Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_nRowEnd | End row for parse.
m_nRowStart | Start row for parse.
m_ptrTBLast | Latest found text block.


CXTPSyntaxEditLexOnScreenParseCnt::m_nRowEnd Data Member

CXTPSyntaxEditLexOnScreenParseCnt Data Members, CXTPSyntaxEditLexOnScreenParseCnt Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt::m_nRowEnd Data Member

End row for parse.

int m_nRowEnd;
Group

CXTPSyntaxEditLexOnScreenParseCnt Data Members


CXTPSyntaxEditLexOnScreenParseCnt::m_nRowStart Data Member

CXTPSyntaxEditLexOnScreenParseCnt Data Members, CXTPSyntaxEditLexOnScreenParseCnt Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt::m_nRowStart Data Member

Start row for parse.

int m_nRowStart;
Group

CXTPSyntaxEditLexOnScreenParseCnt Data Members


CXTPSyntaxEditLexOnScreenParseCnt::m_ptrTBLast Data Member

CXTPSyntaxEditLexOnScreenParseCnt Data Members, CXTPSyntaxEditLexOnScreenParseCnt Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt::m_ptrTBLast Data Member

Latest found text block.

CXTPSyntaxEditLexTextBlockPtr m_ptrTBLast;
Group

CXTPSyntaxEditLexOnScreenParseCnt Data Members


CXTPSyntaxEditLexOnScreenParseCnt Constructors

CXTPSyntaxEditLexOnScreenParseCnt Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt Constructors
Class

CXTPSyntaxEditLexOnScreenParseCnt Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexOnScreenParseCnt | Default object constructor.


CXTPSyntaxEditLexOnScreenParseCnt::CXTPSyntaxEditLexOnScreenParseCnt Constructor

CXTPSyntaxEditLexOnScreenParseCnt Constructors, CXTPSyntaxEditLexOnScreenParseCnt Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt::CXTPSyntaxEditLexOnScreenParseCnt Constructor

Default object constructor.

CXTPSyntaxEditLexOnScreenParseCnt();
Group

CXTPSyntaxEditLexOnScreenParseCnt Constructors


CXTPSyntaxEditLexOnScreenParseCnt Destructors

CXTPSyntaxEditLexOnScreenParseCnt Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt Destructors
Class

CXTPSyntaxEditLexOnScreenParseCnt Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexOnScreenParseCnt | Default object destructor.


CXTPSyntaxEditLexOnScreenParseCnt::~CXTPSyntaxEditLexOnScreenParseCnt Destructor

CXTPSyntaxEditLexOnScreenParseCnt Destructors, CXTPSyntaxEditLexOnScreenParseCnt Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexOnScreenParseCnt::~CXTPSyntaxEditLexOnScreenParseCnt Destructor

Default object destructor.

virtual ~CXTPSyntaxEditLexOnScreenParseCnt();
Group

CXTPSyntaxEditLexOnScreenParseCnt Destructors


CXTPSyntaxEditLexParser Class

XTPSyntaxEditLexParser.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Constructors, CXTPSyntaxEditLexParser Destructors, CXTPSyntaxEditLexParser Constructors, CXTPSyntaxEditLexParser Destructors, CXTPSyntaxEditLexParser Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser Class

This class used to 'run' lex schema parsing in separate thread. It also control this working thread and provide interthread interaction.

Class Hierarchy

class CXTPSyntaxEditLexParser;
File

XTPSyntaxEditLexParser.h

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditLexParser Constructors
CXTPSyntaxEditLexParser Constructors | Description
CXTPSyntaxEditLexParser | Default object constructor.
CXTPSyntaxEditLexParser Destructors
CXTPSyntaxEditLexParser Destructors | Description
~CXTPSyntaxEditLexParser | Object destructor. Handles clean up and deallocations.
CXTPSyntaxEditLexParser Methods
CXTPSyntaxEditLexParser Methods | Description
Close | Use this member function to stop parsing, destroy working thread and unadvise from all events.
CloseParseThread | Use this member function to stop parsing, destroy working thread.
GetConnection | Returns notification connection.
GetParseThreadPriority | Get priority for a working thread.
GetSchemaOptions | Use this member function to get text shema global options.
GetTextSchema | Use this member function to get active text shema.
GetTokensForAutoCompleate | Use this member function to get Auto Complete words for active text shema.
OnBeforeEditChanged | Use this member function to stop parsing in thread before call OnEditChanged.
OnEditChanged | Use this member function to reparse text after editing.
SetParseThreadPriority | Set priority for a working thread.
SetTextSchema | Use this member function to set active text shema.
StartParseInThread | Use this member function to start parsing of specified text range in separate (working) thread. If parser already running and parse other text range, the new range added to a queue.
StopParseInThread | Use this member function to stop parsing.


CXTPSyntaxEditLexParser Methods

CXTPSyntaxEditLexParser Class, Legend, Public Methods
CXTPSyntaxEditLexParser Methods
Class

CXTPSyntaxEditLexParser Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Close | Use this member function to stop parsing, destroy working thread and unadvise from all events.
CloseParseThread | Use this member function to stop parsing, destroy working thread.
GetConnection | Returns notification connection.
GetParseThreadPriority | Get priority for a working thread.
GetSchemaOptions | Use this member function to get text shema global options.
GetTextSchema | Use this member function to get active text shema.
GetTokensForAutoCompleate | Use this member function to get Auto Complete words for active text shema.
OnBeforeEditChanged | Use this member function to stop parsing in thread before call OnEditChanged.
OnEditChanged | Use this member function to reparse text after editing.
SetParseThreadPriority | Set priority for a working thread.
SetTextSchema | Use this member function to set active text shema.
StartParseInThread | Use this member function to start parsing of specified text range in separate (working) thread. If parser already running and parse other text range, the new range added to a queue.
StopParseInThread | Use this member function to stop parsing.


CXTPSyntaxEditLexParser::Close Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::Close Method

Use this member function to stop parsing, destroy working thread and unadvise from all events.

virtual void Close();
See Also

CloseParseThread, StopParseInThread

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::CloseParseThread Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::CloseParseThread Method

Use this member function to stop parsing, destroy working thread.

virtual void CloseParseThread();
See Also

Close, StopParseInThread

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::GetConnection Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::GetConnection Method

Returns notification connection.

virtual CXTPNotifyConnection* GetConnection();
Returns

CXTPNotifyConnectionPtr pointer.

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::GetParseThreadPriority Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::GetParseThreadPriority Method

Get priority for a working thread.

virtual int GetParseThreadPriority();
Returns

A working thread priority.

See Also

SetParseThreadPriority, CWinThread::GetThreadPriority

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::GetSchemaOptions Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::GetSchemaOptions Method

Use this member function to get text shema global options.

virtual const CXTPSyntaxEditLexParserSchemaOptions* GetSchemaOptions(
    const CString& strExt
);
Parameters

strExt
A file extension to lookup schema.

Returns

A pointer to CXTPSyntaxEditLexParserSchemaOptions.

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::GetTextSchema Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::GetTextSchema Method

Use this member function to get active text shema.

virtual CXTPSyntaxEditLexTextSchema* GetTextSchema();
Returns

A pointer to CXTPSyntaxEditLexTextSchema.

See Also

SetTextSchema

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::GetTokensForAutoCompleate Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::GetTokensForAutoCompleate Method

Use this member function to get Auto Complete words for active text shema.

virtual BOOL GetTokensForAutoCompleate(
    CXTPSyntaxEditLexTokensDefArray& rArTokens,
    BOOL bAppend
);
Parameters

rArTokens
An array to store Auto Complete words.
bAppend
If this parameter TRUE - array will be appended, otherwise previous items will be removed from array.

Returns

TRUE if successful, FALSE otherwise.

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::OnBeforeEditChanged Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::OnBeforeEditChanged Method

Use this member function to stop parsing in thread before call OnEditChanged.

virtual void OnBeforeEditChanged();
See Also

OnEditChanged

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::OnEditChanged Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::OnEditChanged Method

Use this member function to reparse text after editing.

virtual void OnEditChanged(
    const XTP_EDIT_LINECOL& posFrom,
    const XTP_EDIT_LINECOL& posTo,
    int eEditAction,
    CXTPSyntaxEditBufferManager* pBuffer
);
Parameters

posFrom
Start position for edit action.
posTo
End position for edit action.
eEditAction
Value from XTPSyntaxEditEditAction enum.
pBuffer
A pointer to CXTPSyntaxEditBufferManager object.

See Also

OnBeforeEditChanged

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::SetParseThreadPriority Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::SetParseThreadPriority Method

Set priority for a working thread.

virtual BOOL SetParseThreadPriority(
    int nPriority
);
Parameters

nPriority
A new working thread priority.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetParseThreadPriority, CWinThread::GetThreadPriority

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::SetTextSchema Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::SetTextSchema Method

Use this member function to set active text shema.

virtual void SetTextSchema(
    CXTPSyntaxEditLexTextSchema* pTextSchema
);
Parameters

pTextSchema
A pointer to CXTPSyntaxEditLexTextSchema.

See Also

GetTextSchema

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::StartParseInThread Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::StartParseInThread Method

Use this member function to start parsing of specified text range in separate (working) thread. If parser already running and parse other text range, the new range added to a queue.

virtual void StartParseInThread(
    CXTPSyntaxEditBufferManager* pBuffer,
    const XTP_EDIT_LINECOL* pLCStart = NULL,
    const XTP_EDIT_LINECOL* pLCEnd = NULL,
    int eEdinAction = 0,
    BOOL bRunWithoutWait = FALSE
);
Parameters

pBuffer
A pointer to CXTPSyntaxEditBufferManager object.
pLCStart
Start text position to reparse or NULL to start from begin.
pLCEnd
End text position to reparse or NULL to parse until end.
eEdinAction
Zero (0) or value from XTPSyntaxEditEditAction enum.
bRunWithoutWait
Start parse immediately or wait a timeout specified in global schema options.

See Also

StopParseInThread, CloseParseThread

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser::StopParseInThread Method

CXTPSyntaxEditLexParser Methods, CXTPSyntaxEditLexParser Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::StopParseInThread Method

Use this member function to stop parsing.

virtual void StopParseInThread();
See Also

Close, StartParseInThread

Group

CXTPSyntaxEditLexParser Methods


CXTPSyntaxEditLexParser Constructors

CXTPSyntaxEditLexParser Class, Legend, Public Methods
CXTPSyntaxEditLexParser Constructors
Class

CXTPSyntaxEditLexParser Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexParser | Default object constructor.


CXTPSyntaxEditLexParser::CXTPSyntaxEditLexParser Constructor

CXTPSyntaxEditLexParser Constructors, CXTPSyntaxEditLexParser Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::CXTPSyntaxEditLexParser Constructor

Default object constructor.

CXTPSyntaxEditLexParser();
Group

CXTPSyntaxEditLexParser Constructors


CXTPSyntaxEditLexParser Destructors

CXTPSyntaxEditLexParser Class, Legend, Public Methods
CXTPSyntaxEditLexParser Destructors
Class

CXTPSyntaxEditLexParser Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexParser | Object destructor. Handles clean up and deallocations.


CXTPSyntaxEditLexParser::~CXTPSyntaxEditLexParser Destructor

CXTPSyntaxEditLexParser Destructors, CXTPSyntaxEditLexParser Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParser::~CXTPSyntaxEditLexParser Destructor

Object destructor. Handles clean up and deallocations.

virtual ~CXTPSyntaxEditLexParser();
Group

CXTPSyntaxEditLexParser Destructors


CXTPSyntaxEditLexParserSchemaOptions Class

XTPSyntaxEditLexParser.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Constructors, CXTPSyntaxEditLexParserSchemaOptions Operators, CXTPSyntaxEditLexParserSchemaOptions Constructors, CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions Class

This class is designed to easily manipulate parser options.

Class Hierarchy

class CXTPSyntaxEditLexParserSchemaOptions;
File

XTPSyntaxEditLexParser.h

Group

Classes

Legend
Data Member
Constructor
Operator
CXTPSyntaxEditLexParserSchemaOptions Constructors
CXTPSyntaxEditLexParserSchemaOptions Constructors | Description
CXTPSyntaxEditLexParserSchemaOptions |
CXTPSyntaxEditLexParserSchemaOptions Data Members
CXTPSyntaxEditLexParserSchemaOptions Data Members | Description
m_bConfigChangedReparceInSeparateThread | 0,1} default=1
m_bEditReparceInSeparateThread | 0,1} default=1
m_bFirstParseInSeparateThread | 0,1} default=1
m_dwEditReparceTimeout_ms | default=500 ms; time out for start reparse after last key was pressed.
m_dwMaxBackParseOffset | default=100; maximum back buffer size.
m_dwOnScreenSchCacheLifeTime_sec | default=180 sec; time out for on screen parsed pices of text.
m_dwParserThreadIdleLifeTime_ms | default=60 sec; time out for existing of parser thread when parser idle (no parse requests).
CXTPSyntaxEditLexParserSchemaOptions Operators
CXTPSyntaxEditLexParserSchemaOptions Operators | Description
= | Overloaded equals operator.


CXTPSyntaxEditLexParserSchemaOptions Data Members

CXTPSyntaxEditLexParserSchemaOptions Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions Data Members
Class

CXTPSyntaxEditLexParserSchemaOptions Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_bConfigChangedReparceInSeparateThread | 0,1} default=1
m_bEditReparceInSeparateThread | 0,1} default=1
m_bFirstParseInSeparateThread | 0,1} default=1
m_dwEditReparceTimeout_ms | default=500 ms; time out for start reparse after last key was pressed.
m_dwMaxBackParseOffset | default=100; maximum back buffer size.
m_dwOnScreenSchCacheLifeTime_sec | default=180 sec; time out for on screen parsed pices of text.
m_dwParserThreadIdleLifeTime_ms | default=60 sec; time out for existing of parser thread when parser idle (no parse requests).


CXTPSyntaxEditLexParserSchemaOptions::m_bConfigChangedReparceInSeparateThread Data Member

CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::m_bConfigChangedReparceInSeparateThread Data Member

0,1} default=1

BOOL m_bConfigChangedReparceInSeparateThread;
Group

CXTPSyntaxEditLexParserSchemaOptions Data Members


CXTPSyntaxEditLexParserSchemaOptions::m_bEditReparceInSeparateThread Data Member

CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::m_bEditReparceInSeparateThread Data Member

0,1} default=1

BOOL m_bEditReparceInSeparateThread;
Group

CXTPSyntaxEditLexParserSchemaOptions Data Members


CXTPSyntaxEditLexParserSchemaOptions::m_bFirstParseInSeparateThread Data Member

CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::m_bFirstParseInSeparateThread Data Member

0,1} default=1

BOOL m_bFirstParseInSeparateThread;
Group

CXTPSyntaxEditLexParserSchemaOptions Data Members


CXTPSyntaxEditLexParserSchemaOptions::m_dwEditReparceTimeout_ms Data Member

CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::m_dwEditReparceTimeout_ms Data Member

default=500 ms; time out for start reparse after last key was pressed.

DWORD m_dwEditReparceTimeout_ms;
Group

CXTPSyntaxEditLexParserSchemaOptions Data Members


CXTPSyntaxEditLexParserSchemaOptions::m_dwMaxBackParseOffset Data Member

CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::m_dwMaxBackParseOffset Data Member

default=100; maximum back buffer size.

DWORD m_dwMaxBackParseOffset;
Group

CXTPSyntaxEditLexParserSchemaOptions Data Members


CXTPSyntaxEditLexParserSchemaOptions::m_dwOnScreenSchCacheLifeTime_sec Data Member

CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::m_dwOnScreenSchCacheLifeTime_sec Data Member

default=180 sec; time out for on screen parsed pices of text.

DWORD m_dwOnScreenSchCacheLifeTime_sec;
Group

CXTPSyntaxEditLexParserSchemaOptions Data Members


CXTPSyntaxEditLexParserSchemaOptions::m_dwParserThreadIdleLifeTime_ms Data Member

CXTPSyntaxEditLexParserSchemaOptions Data Members, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::m_dwParserThreadIdleLifeTime_ms Data Member

default=60 sec; time out for existing of parser thread when parser idle (no parse requests).

DWORD m_dwParserThreadIdleLifeTime_ms;
Group

CXTPSyntaxEditLexParserSchemaOptions Data Members


CXTPSyntaxEditLexParserSchemaOptions Constructors

CXTPSyntaxEditLexParserSchemaOptions Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions Constructors
Class

CXTPSyntaxEditLexParserSchemaOptions Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexParserSchemaOptions |


CXTPSyntaxEditLexParserSchemaOptions Constructor

CXTPSyntaxEditLexParserSchemaOptions Constructors
CXTPSyntaxEditLexParserSchemaOptions Constructor
Overload List
Constructors
Constructor | Description
CXTPSyntaxEditLexParserSchemaOptions::CXTPSyntaxEditLexParserSchemaOptions () | Default object constructor.
CXTPSyntaxEditLexParserSchemaOptions::CXTPSyntaxEditLexParserSchemaOptions (const CXTPSyntaxEditLexParserSchemaOptions&) | Object constructor.
Group

CXTPSyntaxEditLexParserSchemaOptions Constructors


CXTPSyntaxEditLexParserSchemaOptions::CXTPSyntaxEditLexParserSchemaOptions Constructor ()

CXTPSyntaxEditLexParserSchemaOptions Constructor, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::CXTPSyntaxEditLexParserSchemaOptions Constructor ()

Default object constructor.

CXTPSyntaxEditLexParserSchemaOptions();
Group

CXTPSyntaxEditLexParserSchemaOptions Constructor


CXTPSyntaxEditLexParserSchemaOptions::CXTPSyntaxEditLexParserSchemaOptions Constructor (const CXTPSyntaxEditLexParserSchemaOptions&)

CXTPSyntaxEditLexParserSchemaOptions Constructor, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::CXTPSyntaxEditLexParserSchemaOptions Constructor (const CXTPSyntaxEditLexParserSchemaOptions&)

Object constructor.

CXTPSyntaxEditLexParserSchemaOptions(
    const CXTPSyntaxEditLexParserSchemaOptions& rSrc
);
Parameters

rSrc
[in] Reference to source CXTPSyntaxEditLexParserSchemaOptions.

Group

CXTPSyntaxEditLexParserSchemaOptions Constructor


CXTPSyntaxEditLexParserSchemaOptions Operators

CXTPSyntaxEditLexParserSchemaOptions Class, Legend, Public Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions Operators
Class

CXTPSyntaxEditLexParserSchemaOptions Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Overloaded equals operator.


CXTPSyntaxEditLexParserSchemaOptions::= Operator

CXTPSyntaxEditLexParserSchemaOptions Operators, CXTPSyntaxEditLexParserSchemaOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexParserSchemaOptions::= Operator

Overloaded equals operator.

const CXTPSyntaxEditLexParserSchemaOptions& operator =(
    const CXTPSyntaxEditLexParserSchemaOptions& rSrc
);
Parameters

rSrc
[in] Reference to source CXTPSyntaxEditLexParserSchemaOptions.

Group

CXTPSyntaxEditLexParserSchemaOptions Operators


CXTPSyntaxEditLexTextBlock Class

XTPSyntaxEditLexParser.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Constructors, CXTPSyntaxEditLexTextBlock Destructors, CXTPSyntaxEditLexTextBlock Constructors, CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Destructors, CXTPSyntaxEditLexTextBlock Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock Class

CXTPSyntaxEditLexTextBlock class represents a pice (block) of text which corresponds some lex class in a text schema. It stores start position, end position, pointer to the lex class object in a class schema and some other information. Text blocks organized as a bidirectional list and as tree structure.

Class Hierarchy

class CXTPSyntaxEditLexTextBlock;
File

XTPSyntaxEditLexParser.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditLexTextBlock Constructors
CXTPSyntaxEditLexTextBlock Constructors | Description
CXTPSyntaxEditLexTextBlock | Default object constructor.
CXTPSyntaxEditLexTextBlock Data Members
CXTPSyntaxEditLexTextBlock Data Members | Description
m_bEndByParent | Text block ended when the parent block ended.
m_nEndTagXLCLen | End tag length in XLC form.
m_nStartTagLen | Start tag length.
m_PosEndLC | Text block start position.
m_PosStartLC | Text block start position.
m_ptrLastChild | for internal use only.
m_ptrLexClass | Pointer to the LexClass object.
m_ptrNext | Pointer to the next block.
m_ptrParent | Pointer to the parent block object.
m_ptrPrev | Pointer to the previous block.
CXTPSyntaxEditLexTextBlock Destructors
CXTPSyntaxEditLexTextBlock Destructors | Description
~CXTPSyntaxEditLexTextBlock | Object destructor. Handles clean up and deallocations.
CXTPSyntaxEditLexTextBlock Methods
CXTPSyntaxEditLexTextBlock Methods | Description
Close | Release references to other objects.
EndChildren | This method set end position to not ended children blocks.
GetEndTagBeginXLC | Get text block end tag begin position in the text.
GetEndTagEndXLC | Get text block end tag end position in the text.
GetPosEndLC | Get Text block end position.
GetPrevChild | This method searches previous child block for the specified child. This block is parent.
GetStartTagEndXLC | Get text block start tag end position in the text.
IsEqualLexClasses | This methods compare lex classes names for 2 text blocks.
IsInclude | This method determine is the specified text block included in the current text block.
IsLookLikeClosed | This method determine is text block look like closed or partly closed.


CXTPSyntaxEditLexTextBlock Data Members

CXTPSyntaxEditLexTextBlock Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock Data Members
Class

CXTPSyntaxEditLexTextBlock Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nEndTagXLCLen | End tag length in XLC form.
m_nStartTagLen | Start tag length.
m_ptrLastChild | for internal use only.
Public Data Members
Public Data Member | Description
m_bEndByParent | Text block ended when the parent block ended.
m_PosEndLC | Text block start position.
m_PosStartLC | Text block start position.
m_ptrLexClass | Pointer to the LexClass object.
m_ptrNext | Pointer to the next block.
m_ptrParent | Pointer to the parent block object.
m_ptrPrev | Pointer to the previous block.


CXTPSyntaxEditLexTextBlock::m_bEndByParent Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_bEndByParent Data Member

Text block ended when the parent block ended.

BOOL m_bEndByParent;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_nEndTagXLCLen Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_nEndTagXLCLen Data Member

End tag length in XLC form.

int m_nEndTagXLCLen;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_nStartTagLen Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_nStartTagLen Data Member

Start tag length.

int m_nStartTagLen;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_PosEndLC Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_PosEndLC Data Member

Text block start position.

XTP_EDIT_LINECOL m_PosEndLC;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_PosStartLC Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_PosStartLC Data Member

Text block start position.

XTP_EDIT_LINECOL m_PosStartLC;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_ptrLastChild Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_ptrLastChild Data Member

for internal use only.

CXTPSyntaxEditLexTextBlockPtr m_ptrLastChild;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_ptrLexClass Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_ptrLexClass Data Member

Pointer to the LexClass object.

CXTPSyntaxEditLexClassPtr m_ptrLexClass;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_ptrNext Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_ptrNext Data Member

Pointer to the next block.

CXTPSyntaxEditLexTextBlockPtr m_ptrNext;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_ptrParent Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_ptrParent Data Member

Pointer to the parent block object.

CXTPSyntaxEditLexTextBlockPtr m_ptrParent;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock::m_ptrPrev Data Member

CXTPSyntaxEditLexTextBlock Data Members, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::m_ptrPrev Data Member

Pointer to the previous block.

CXTPSyntaxEditLexTextBlockPtr m_ptrPrev;
Group

CXTPSyntaxEditLexTextBlock Data Members


CXTPSyntaxEditLexTextBlock Methods

CXTPSyntaxEditLexTextBlock Class, Legend, Public Methods
CXTPSyntaxEditLexTextBlock Methods
Class

CXTPSyntaxEditLexTextBlock Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Close | Release references to other objects.
EndChildren | This method set end position to not ended children blocks.
GetEndTagBeginXLC | Get text block end tag begin position in the text.
GetEndTagEndXLC | Get text block end tag end position in the text.
GetPosEndLC | Get Text block end position.
GetPrevChild | This method searches previous child block for the specified child. This block is parent.
GetStartTagEndXLC | Get text block start tag end position in the text.
IsEqualLexClasses | This methods compare lex classes names for 2 text blocks.
IsInclude | This method determine is the specified text block included in the current text block.
IsLookLikeClosed | This method determine is text block look like closed or partly closed.


CXTPSyntaxEditLexTextBlock::Close Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::Close Method

Release references to other objects.

virtual void Close();
Remarks

This method is used in text schema destruction process.

See Also

CXTPSyntaxEditLexTextSchema::Close().

Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::EndChildren Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::EndChildren Method

This method set end position to not ended children blocks.

virtual int EndChildren(
    CXTPSyntaxEditLexTextSchema* pTxtSch = NULL,
    BOOL bEndByParent = TRUE
);
Parameters

pTxtSch
[in] Text schema pointer to send notifications.

Returns

Ended children blocks count.

Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::GetEndTagBeginXLC Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::GetEndTagBeginXLC Method

Get text block end tag begin position in the text.

DWORD GetEndTagBeginXLC();
Returns

Text block end tag begin position in XLC form.

See Also

XTP_EDIT_LINECOL::GetXLC(), XTP_EDIT_XLC() macros.

Body Source
DWORD CXTPSyntaxEditLexTextBlock::GetEndTagBeginXLC() {
    return m_PosEndLC.GetXLC() - (m_nEndTagXLCLen > 0 ? m_nEndTagXLCLen : 0);
}
Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::GetEndTagEndXLC Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::GetEndTagEndXLC Method

Get text block end tag end position in the text.

DWORD GetEndTagEndXLC();
Returns

Text block end tag end position in XLC form.

See Also

XTP_EDIT_LINECOL::GetXLC(), XTP_EDIT_XLC() macros.

Body Source
DWORD CXTPSyntaxEditLexTextBlock::GetEndTagEndXLC() {
    return m_PosEndLC.GetXLC() - (m_nEndTagXLCLen < 0 ? m_nEndTagXLCLen : 0);
}
Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::GetPosEndLC Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::GetPosEndLC Method

Get Text block end position.

XTP_EDIT_LINECOL GetPosEndLC(
    BOOL bMaxIfInvalid = TRUE
);
Parameters

bMaxIfInvalid
[in] If TRUE returns XTP_EDIT_LINECOL::MAXPOS for invalid position. If FALSE returns XTP_EDIT_LINECOL::MINPOS for invalid position.

Returns

Value of m_PosEndLC if it is valid, otherwise maximum or minimum value depends on parameter bMaxIfInvalid.

See Also

XTP_EDIT_LINECOL, m_PosEndLC, m_PosStartLC.

Body Source
XTP_EDIT_LINECOL    CXTPSyntaxEditLexTextBlock::GetPosEndLC(BOOL bMaxIfInvalid)
{
    if(!m_PosEndLC.IsValidData()) {
        return bMaxIfInvalid ? XTP_EDIT_LINECOL::MAXPOS : XTP_EDIT_LINECOL::MINPOS;
    }
    return m_PosEndLC;
}
Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::GetPrevChild Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::GetPrevChild Method

This method searches previous child block for the specified child. This block is parent.

virtual CXTPSyntaxEditLexTextBlock* GetPrevChild(
    CXTPSyntaxEditLexTextBlock* pChild,
    BOOL bWithAddRef
);
Parameters

pChild
[in] Child block pointer.
bWithAddRef
[in] If TRUE - InternalAddRef() is called before

Returns

Previous child block pointer or NULL.

Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::GetStartTagEndXLC Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::GetStartTagEndXLC Method

Get text block start tag end position in the text.

DWORD GetStartTagEndXLC();
Returns

Text block start tag end position in XLC form.

See Also

XTP_EDIT_LINECOL::GetXLC(), XTP_EDIT_XLC() macros.

Body Source
DWORD CXTPSyntaxEditLexTextBlock::GetStartTagEndXLC() {
    return m_PosStartLC.GetXLC() + m_nStartTagLen;
}
Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::IsEqualLexClasses Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::IsEqualLexClasses Method

This methods compare lex classes names for 2 text blocks.

virtual BOOL IsEqualLexClasses(
    CXTPSyntaxEditLexTextBlock* pTB2
) const;
Parameters

pTB2
[in] Second text block to compare.

Returns

TRUE if lex classes names for 2 text blocks are equal, FALSE otherwise.

Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::IsInclude Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::IsInclude Method

This method determine is the specified text block included in the current text block.

virtual BOOL IsInclude(
    CXTPSyntaxEditLexTextBlock* pTB2
) const;
Parameters

pTB2
[in] Text block pointer.

Returns

TRUE if the specified text block included in the current text block, FALSE otherwise.

Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock::IsLookLikeClosed Method

CXTPSyntaxEditLexTextBlock Methods, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::IsLookLikeClosed Method

This method determine is text block look like closed or partly closed.

virtual BOOL IsLookLikeClosed() const;
Returns

TRUE if some or all references to other objects are NULL, FALSE otherwise.

Group

CXTPSyntaxEditLexTextBlock Methods


CXTPSyntaxEditLexTextBlock Constructors

CXTPSyntaxEditLexTextBlock Class, Legend, Public Methods
CXTPSyntaxEditLexTextBlock Constructors
Class

CXTPSyntaxEditLexTextBlock Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexTextBlock | Default object constructor.


CXTPSyntaxEditLexTextBlock::CXTPSyntaxEditLexTextBlock Constructor

CXTPSyntaxEditLexTextBlock Constructors, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::CXTPSyntaxEditLexTextBlock Constructor

Default object constructor.

CXTPSyntaxEditLexTextBlock();
Group

CXTPSyntaxEditLexTextBlock Constructors


CXTPSyntaxEditLexTextBlock Destructors

CXTPSyntaxEditLexTextBlock Class, Legend, Public Methods
CXTPSyntaxEditLexTextBlock Destructors
Class

CXTPSyntaxEditLexTextBlock Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexTextBlock | Object destructor. Handles clean up and deallocations.


CXTPSyntaxEditLexTextBlock::~CXTPSyntaxEditLexTextBlock Destructor

CXTPSyntaxEditLexTextBlock Destructors, CXTPSyntaxEditLexTextBlock Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextBlock::~CXTPSyntaxEditLexTextBlock Destructor

Object destructor. Handles clean up and deallocations.

virtual ~CXTPSyntaxEditLexTextBlock();
Group

CXTPSyntaxEditLexTextBlock Destructors


CXTPSyntaxEditLexTextSchema Class

XTPSyntaxEditLexParser.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexTextSchema Enumerations, CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Constructors, CXTPSyntaxEditLexTextSchema Destructors, CXTPSyntaxEditLexTextSchema Constructors, CXTPSyntaxEditLexTextSchema Destructors, CXTPSyntaxEditLexTextSchema Enumerations, CXTPSyntaxEditLexTextSchema Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema Class

CXTPSyntaxEditLexTextSchema class is used to store data which necessary to parse a text and parsing results. It also contains methods to run lex classes from a class schema, methods to update text schema when text is edited, methods to reparse text, to get information which is necessary to draw colorized text and other helper methods.

Class Hierarchy

class CXTPSyntaxEditLexTextSchema;
File

XTPSyntaxEditLexParser.h

Group

Classes

Legend
Enumeration
Method
virtual
protected
CXTPSyntaxEditLexTextSchema Constructors
CXTPSyntaxEditLexTextSchema Constructors | Description
CXTPSyntaxEditLexTextSchema | Default object constructor.
CXTPSyntaxEditLexTextSchema Destructors
CXTPSyntaxEditLexTextSchema Destructors | Description
~CXTPSyntaxEditLexTextSchema | Object destructor. Handles clean up and deallocations.
CXTPSyntaxEditLexTextSchema Enumerations
CXTPSyntaxEditLexTextSchema Enumerations | Description
XTPSyntaxEditUpdateTBRes | This enum describes set of UpdateTextBlocks() return results.
CXTPSyntaxEditLexTextSchema Methods
CXTPSyntaxEditLexTextSchema Methods | Description
ApplyTheme | Apply color theme to the text schema.
ApplyThemeRecursive | Apply color theme to specified lex classes.
BuildIfNeed | Call this member function before using schema object.
Clone | Create a new text schema object and init its internal infrastructure (like class schema) from the current schema.
Close |
GetBlocks | Get first text schema block..
GetBreakParsingEvent | Get event object to break parsing process.
GetClassSchema | Get Class Schema for this text schema..
GetClassSchLoker | Get critical section object to lock class schema.
GetCollapsableBlocksInfo | This method get row as list of collapsible blocks which include this row.
GetConnection | Returns notification connection.
GetDataLoker | Get critical section object to lock schema data (text blocks and others).
GetLastParsedBlock | Get text block by ID. Used together with xtpEditOnTextBlockParsed notification.
GetRowColors | This method get row as list of blocks with different colors to draw.
GetSchName | Get text schema name.
GetTextAttributes | This helper method read attributes of the text from lex class of specified text block.
GetTopClassForFileExt | Get top lex class for specified file extension.
GetUpdatedTextRegion | Returns text region for which schema was updated during last parse/reparse operation.
IsFileExtSupported | Determine is this schema support specified file extension.
LoadClassSchema | Load class schema.
RemoveAll | Remove all text block from the schema.
RunParseOnScreen | This method run parse for the text on screen.
RunParseUpdate | This method run parse for the text.
UpdateTextBlocks | Update text schema positions after editing action.


CXTPSyntaxEditLexTextSchema Enumerations

Enumerations, CXTPSyntaxEditLexTextSchema Class, Legend
CXTPSyntaxEditLexTextSchema Enumerations
Enumerations
Enumeration | Description
XTPSyntaxEditUpdateTBRes | This enum describes set of UpdateTextBlocks() return results.
Class

CXTPSyntaxEditLexTextSchema Class

Legend
Enumeration


CXTPSyntaxEditLexTextSchema::XTPSyntaxEditUpdateTBRes Enumeration

XTPSyntaxEditLexParser.h, CXTPSyntaxEditLexTextSchema Enumerations
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::XTPSyntaxEditUpdateTBRes Enumeration

This enum describes set of UpdateTextBlocks() return results.

enum XTPSyntaxEditUpdateTBRes {
  xtpEditUTBNothing = 0,
  xtpEditUTBError = 0x0001,
  xtpEditUTBReparse = 0x0002,
  xtpEditUTBNearestUpdated = 0x0100
};
File

XTPSyntaxEditLexParser.h

Members

xtpEditUTBNothing
void result
xtpEditUTBError
Error result.
xtpEditUTBReparse
one or few global blocks changed and reparse is need.
xtpEditUTBNearestUpdated
This flag returned from UpdateTBNearest() only.

Group

CXTPSyntaxEditLexTextSchema Enumerations


CXTPSyntaxEditLexTextSchema Methods

CXTPSyntaxEditLexTextSchema Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema Methods
Class

CXTPSyntaxEditLexTextSchema Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
ApplyThemeRecursive | Apply color theme to specified lex classes.
GetClassSchema | Get Class Schema for this text schema..
UpdateTextBlocks | Update text schema positions after editing action.
Public Methods
Public Methods
Public Method | Description
ApplyTheme | Apply color theme to the text schema.
BuildIfNeed | Call this member function before using schema object.
Clone | Create a new text schema object and init its internal infrastructure (like class schema) from the current schema.
Close |
GetBlocks | Get first text schema block..
GetBreakParsingEvent | Get event object to break parsing process.
GetClassSchLoker | Get critical section object to lock class schema.
GetCollapsableBlocksInfo | This method get row as list of collapsible blocks which include this row.
GetConnection | Returns notification connection.
GetDataLoker | Get critical section object to lock schema data (text blocks and others).
GetLastParsedBlock | Get text block by ID. Used together with xtpEditOnTextBlockParsed notification.
GetRowColors | This method get row as list of blocks with different colors to draw.
GetSchName | Get text schema name.
GetTextAttributes | This helper method read attributes of the text from lex class of specified text block.
GetTopClassForFileExt | Get top lex class for specified file extension.
GetUpdatedTextRegion | Returns text region for which schema was updated during last parse/reparse operation.
IsFileExtSupported | Determine is this schema support specified file extension.
LoadClassSchema | Load class schema.
RemoveAll | Remove all text block from the schema.
RunParseOnScreen | This method run parse for the text on screen.
RunParseUpdate | This method run parse for the text.


CXTPSyntaxEditLexTextSchema::ApplyTheme Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::ApplyTheme Method

Apply color theme to the text schema.

virtual void ApplyTheme(
    CXTPSyntaxEditColorTheme* pTheme
);
Parameters

pTheme
[in] A pointer to Color Theme object.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::ApplyThemeRecursive Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::ApplyThemeRecursive Method

Apply color theme to specified lex classes.

virtual void ApplyThemeRecursive(
    CXTPSyntaxEditColorTheme* pTheme,
    CXTPSyntaxEditLexClassPtrArray* ptrClasses
);
Parameters

pTheme
[in] A pointer to Color Theme object.
ptrClasses
[in] A pointer to lex classes array.

See Also

ApplyTheme().

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::BuildIfNeed Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::BuildIfNeed Method

Call this member function before using schema object.

void BuildIfNeed();
Remarks

To make edit control startup faster - schemas do not built during loading. This member function build the schema if necessary (or do nothing).

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::Clone Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::Clone Method

Create a new text schema object and init its internal infrastructure (like class schema) from the current schema.

virtual CXTPSyntaxEditLexTextSchema* Clone();
Returns

A new text schema object.

Remarks

Text blocks are not copied. The class schema is copied.

Group

CXTPSyntaxEditLexTextSchema Methods


Close Method

CXTPSyntaxEditLexTextSchema Methods
Close Method
Overload List
Methods
Method | Description
CXTPSyntaxEditLexTextSchema::Close () | Destroy all interlocked objects references and free all stored objects.
CXTPSyntaxEditLexTextSchema::Close (CXTPSyntaxEditLexTextBlock*) | Destroy text blocks list.
Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::Close Method ()

Close Method, CXTPSyntaxEditLexTextSchema Class, See Also
CXTPSyntaxEditLexTextSchema::Close Method ()

Destroy all interlocked objects references and free all stored objects.

virtual void Close();
Remarks

Call this method to delete schema.

See Also

RemoveAll(), CXTPSyntaxEditLexClassSchema::Close().

Group

Close Method


CXTPSyntaxEditLexTextSchema::Close Method (CXTPSyntaxEditLexTextBlock*)

Close Method, CXTPSyntaxEditLexTextSchema Class, See Also
CXTPSyntaxEditLexTextSchema::Close Method (CXTPSyntaxEditLexTextBlock*)

Destroy text blocks list.

static void Close(
    CXTPSyntaxEditLexTextBlock* pFirst
);
Parameters

pFirst
A pointer to the first element in the list to destroy.

Remarks

This helper method is called to destroy separately stored text blocks list (text schema).

See Also

CXTPSyntaxEditLexTextBlock::Close().

Group

Close Method


CXTPSyntaxEditLexTextSchema::GetBlocks Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetBlocks Method

Get first text schema block..

CXTPSyntaxEditLexTextBlock* GetBlocks();
Returns

Pointer to the text block or NULL.

Remarks

InternalAddRef() is called for the returned object.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetBreakParsingEvent Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetBreakParsingEvent Method

Get event object to break parsing process.

CEvent* GetBreakParsingEvent();
Returns

Pointer to the event object.

Body Source
CEvent* CXTPSyntaxEditLexTextSchema::GetBreakParsingEvent() {
    return  &m_evBreakParsing;
}
Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetClassSchema Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetClassSchema Method

Get Class Schema for this text schema..

CXTPSyntaxEditLexClassSchema* GetClassSchema();
Returns

Pointer to the Class Schema object.

Remarks

InternalAddRef() is called for the returned object.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetClassSchLoker Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetClassSchLoker Method

Get critical section object to lock class schema.

CMutex* GetClassSchLoker();
Returns

Pointer to the critical section object.

Body Source
CMutex* CXTPSyntaxEditLexTextSchema::GetClassSchLoker() {
    return &m_lockClassSch;
}
Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetCollapsableBlocksInfo Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetCollapsableBlocksInfo Method

This method get row as list of collapsible blocks which include this row.

virtual void GetCollapsableBlocksInfo(
    int nRow,
    CXTPSyntaxEditRowsBlockArray& rArBlocks,
    CXTPSyntaxEditLexTextBlockPtr* pptrTBStartCache = NULL
);
Parameters

nRow
[in] Row number. By Leva: passing nRow < 0 will cause to return block for all rows
rArBlocks
[out] List of collapsible blocks which include this row.
pptrTBStartCache
[in out] Cached text block to start search. May be NULL.

Remarks

This method build list of collapsible blocks which include the specified row using external or internal text schema.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetConnection Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetConnection Method

Returns notification connection.

virtual CXTPNotifyConnection* GetConnection();
Returns

CXTPNotifyConnectionPtr pointer.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetDataLoker Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetDataLoker Method

Get critical section object to lock schema data (text blocks and others).

CMutex* GetDataLoker();
Returns

Pointer to the critical section object.

Body Source
CMutex* CXTPSyntaxEditLexTextSchema::GetDataLoker() {
    return &m_lockData;
}
Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetLastParsedBlock Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetLastParsedBlock Method

Get text block by ID. Used together with xtpEditOnTextBlockParsed notification.

virtual CXTPSyntaxEditLexTextBlock* GetLastParsedBlock(
    WPARAM dwID = 0
);
Parameters

dwID
[in] ID from xtpEditOnTextBlockParsed notification.

Returns

Pointer to the text block or NULL.

Remarks

InternalAddRef() is called for the returned object.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetRowColors Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetRowColors Method

This method get row as list of blocks with different colors to draw.

virtual void GetRowColors(
    CTextIter* pTxtIter,
    int nRow,
    int nColFrom,
    int nColTo,
    const XTP_EDIT_COLORVALUES& clrDefault,
    CXTPSyntaxEditTextBlockList* rBlocks,
    CXTPSyntaxEditLexTextBlockPtr* pptrTBStartCache = NULL,
    CXTPSyntaxEditLexTextBlock* pFirstSchTB = NULL
);
Parameters

pTxtIter
[in] Text iterator object.
nRow
[in] Row number.
nColFrom
[in] Row col to get colors from.
nColTo
[in] Row col to get colors to.
clrDefault
[in] Default colors.
rBlocks
[out] List of color blocks.
pptrTBStartCache
[in out] Cached text block to start search. May be NULL.
pFirstSchTB
[in] External text schema first block or NULL. Used for OnScreen schemas.

Remarks

This method build list of color blocks for the specified row using external or internal text schema.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetSchName Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetSchName Method

Get text schema name.

virtual CString GetSchName() const;
Returns

Text schema name string.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetTextAttributes Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetTextAttributes Method

This helper method read attributes of the text from lex class of specified text block.

virtual void GetTextAttributes(
    XTP_EDIT_TEXTBLOCK& rTB,
    CXTPSyntaxEditLexTextBlock* pTextBlock
);
Parameters

rTB
[out] Draw text block object to fill text attributes.
pTextBlock
[in] Text block object.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetTopClassForFileExt Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetTopClassForFileExt Method

Get top lex class for specified file extension.

CXTPSyntaxEditLexClass* GetTopClassForFileExt(
    const CString& strExt
);
Parameters

strExt
[in] Extension string.

Returns

Pointer to the lex class or NULL.

Remarks

Extension string format: ".ext" For example: ".cpp" InternalAddRef() is called for the returned object.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::GetUpdatedTextRegion Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::GetUpdatedTextRegion Method

Returns text region for which schema was updated during last parse/reparse operation.

virtual const CXTPSyntaxEditTextRegion& GetUpdatedTextRegion() const;
Returns

CXTPSyntaxEditTextRegion object.

Body Source
const CXTPSyntaxEditTextRegion& CXTPSyntaxEditLexTextSchema::GetUpdatedTextRegion() const {
    return m_curInvalidZone;
}
Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::IsFileExtSupported Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::IsFileExtSupported Method

Determine is this schema support specified file extension.

BOOL IsFileExtSupported(
    const CString& strExt
);
Parameters

strExt
[in] Extension string.

Returns

TRUE if specified file extension is supported, FALSE otherwise.

Remarks

Extension string format: ".ext" For example: ".cpp"

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::LoadClassSchema Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::LoadClassSchema Method

Load class schema.

BOOL LoadClassSchema(
    CXTPSyntaxEditLexClassInfoArray* arClassInfo
);
Parameters

arClassInfo
[in] A reference to CXTPSyntaxEditLexClassInfoArray array.

Returns

TRUE if successful, FALSE otherwise

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::RemoveAll Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::RemoveAll Method

Remove all text block from the schema.

virtual void RemoveAll();
Remarks

Schema object is not destroyed, just only blocks are removed.

See Also

RemoveAll(), CXTPSyntaxEditLexClassSchema::Close().

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::RunParseOnScreen Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::RunParseOnScreen Method

This method run parse for the text on screen.

virtual BOOL RunParseOnScreen(
    CTextIter* pTxtIter,
    int nRowStart,
    int nRowEnd,
    CXTPSyntaxEditLexTextBlockPtr& rPtrScreenSchFirstTB
);
Parameters

pTxtIter
[in] Text iterator object.
nRowStart
[in] Start row for parse.
nRowEnd
[in] End row for parse.
rPtrScreenSchFirstTB
[out] Reference to store first text block of text schema which is built.

Returns

TRUE if successful, FALSE otherwise

Remarks

This method perform full parsing for the specified text region using previously parsed short text schema (or global blocks schema).

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::RunParseUpdate Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::RunParseUpdate Method

This method run parse for the text.

virtual int RunParseUpdate(
    BOOL bShort,
    CTextIter* pTxtIter,
    const XTP_EDIT_LINECOL* pLCStart = NULL,
    const XTP_EDIT_LINECOL* pLCEnd = NULL,
    BOOL bSendProgressEvents = FALSE
);
Parameters

bShort
[in] If TRUE the short (global blocks only) class schema is used, otherwise full (global and onscreen blocks) class schema is used.
pTxtIter
[in] Text iterator object.
pLCStart
[in] Start text position for parse/reparse.
pLCEnd
[in] End text position for parse/reparse.
bSendProgressEvents
[in] If TRUE the progress parsing events will be sent using connection object.

Returns

Parse result as flag from enum XTPSyntaxEditLexParseResult.

Remarks

Special parameters values: pLCStart = NULL, pLCEnd = NULL

  • parse from the last parsed block to the end of the text

pLCStart = XTP_EDIT_LINECOL::Pos1, pLCEnd = NULL

  • parse (reparse) all text from the begin
Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema::UpdateTextBlocks Method

CXTPSyntaxEditLexTextSchema Methods, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::UpdateTextBlocks Method

Update text schema positions after editing action.

int UpdateTextBlocks(
    XTP_EDIT_LINECOL posFrom,
    XTP_EDIT_LINECOL posTo,
    int eEditAction
);
Parameters

posFrom
[in] Start editing position.
posTo
[in] End editing position.
eEditAction
[in] Edit action. See XTPSyntaxEditEditAction.

Returns

Update result - values from enum XTPSyntaxEditUpdateTBRes.

Group

CXTPSyntaxEditLexTextSchema Methods


CXTPSyntaxEditLexTextSchema Constructors

CXTPSyntaxEditLexTextSchema Class, Legend, Public Methods
CXTPSyntaxEditLexTextSchema Constructors
Class

CXTPSyntaxEditLexTextSchema Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexTextSchema | Default object constructor.


CXTPSyntaxEditLexTextSchema::CXTPSyntaxEditLexTextSchema Constructor

CXTPSyntaxEditLexTextSchema Constructors, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::CXTPSyntaxEditLexTextSchema Constructor

Default object constructor.

CXTPSyntaxEditLexTextSchema(
    LPCTSTR pcszSchName
);
Parameters

pcszSchName
[in] Schema name.

Group

CXTPSyntaxEditLexTextSchema Constructors


CXTPSyntaxEditLexTextSchema Destructors

CXTPSyntaxEditLexTextSchema Class, Legend, Public Methods
CXTPSyntaxEditLexTextSchema Destructors
Class

CXTPSyntaxEditLexTextSchema Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexTextSchema | Object destructor. Handles clean up and deallocations.


CXTPSyntaxEditLexTextSchema::~CXTPSyntaxEditLexTextSchema Destructor

CXTPSyntaxEditLexTextSchema Destructors, CXTPSyntaxEditLexTextSchema Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTextSchema::~CXTPSyntaxEditLexTextSchema Destructor

Object destructor. Handles clean up and deallocations.

virtual ~CXTPSyntaxEditLexTextSchema();
Group

CXTPSyntaxEditLexTextSchema Destructors


CXTPSyntaxEditLexTokensDef Class

XTPSyntaxEditLexParser.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexTokensDef Data Members, CXTPSyntaxEditLexTokensDef Constructors, CXTPSyntaxEditLexTokensDef Destructors, CXTPSyntaxEditLexTokensDef Operators, CXTPSyntaxEditLexTokensDef Constructors, CXTPSyntaxEditLexTokensDef Data Members, CXTPSyntaxEditLexTokensDef Destructors, CXTPSyntaxEditLexTokensDef Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef Class

This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators.

Class Hierarchy

class CXTPSyntaxEditLexTokensDef;
File

XTPSyntaxEditLexParser.h

Group

Classes

Legend
Data Member
Constructor
virtual
Operator
CXTPSyntaxEditLexTokensDef Constructors
CXTPSyntaxEditLexTokensDef Constructors | Description
CXTPSyntaxEditLexTokensDef |
CXTPSyntaxEditLexTokensDef Data Members
CXTPSyntaxEditLexTokensDef Data Members | Description
m_arEndSeps | Stores list of end separators.
m_arStartSeps | Stores list of start separators.
m_arTokens | Stores list of tokens.
CXTPSyntaxEditLexTokensDef Destructors
CXTPSyntaxEditLexTokensDef Destructors | Description
~CXTPSyntaxEditLexTokensDef | Object destructor. Handles clean up and deallocations.
CXTPSyntaxEditLexTokensDef Operators
CXTPSyntaxEditLexTokensDef Operators | Description
= | Assignment operator for class.


CXTPSyntaxEditLexTokensDef Data Members

CXTPSyntaxEditLexTokensDef Class, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef Data Members
Class

CXTPSyntaxEditLexTokensDef Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_arEndSeps | Stores list of end separators.
m_arStartSeps | Stores list of start separators.
m_arTokens | Stores list of tokens.


CXTPSyntaxEditLexTokensDef::m_arEndSeps Data Member

CXTPSyntaxEditLexTokensDef Data Members, CXTPSyntaxEditLexTokensDef Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef::m_arEndSeps Data Member

Stores list of end separators.

CStringArray m_arEndSeps;
Group

CXTPSyntaxEditLexTokensDef Data Members


CXTPSyntaxEditLexTokensDef::m_arStartSeps Data Member

CXTPSyntaxEditLexTokensDef Data Members, CXTPSyntaxEditLexTokensDef Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef::m_arStartSeps Data Member

Stores list of start separators.

CStringArray m_arStartSeps;
Group

CXTPSyntaxEditLexTokensDef Data Members


CXTPSyntaxEditLexTokensDef::m_arTokens Data Member

CXTPSyntaxEditLexTokensDef Data Members, CXTPSyntaxEditLexTokensDef Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef::m_arTokens Data Member

Stores list of tokens.

CStringArray m_arTokens;
Group

CXTPSyntaxEditLexTokensDef Data Members


CXTPSyntaxEditLexTokensDef Constructors

CXTPSyntaxEditLexTokensDef Class, Legend, Public Methods
CXTPSyntaxEditLexTokensDef Constructors
Class

CXTPSyntaxEditLexTokensDef Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexTokensDef |


CXTPSyntaxEditLexTokensDef Constructor

CXTPSyntaxEditLexTokensDef Constructors
CXTPSyntaxEditLexTokensDef Constructor
Overload List
Constructors
Constructor | Description
CXTPSyntaxEditLexTokensDef::CXTPSyntaxEditLexTokensDef () | Default object constructor.
CXTPSyntaxEditLexTokensDef::CXTPSyntaxEditLexTokensDef (const CXTPSyntaxEditLexTokensDef&) | Copy object constructor.
Group

CXTPSyntaxEditLexTokensDef Constructors


CXTPSyntaxEditLexTokensDef::CXTPSyntaxEditLexTokensDef Constructor ()

CXTPSyntaxEditLexTokensDef Constructor, CXTPSyntaxEditLexTokensDef Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef::CXTPSyntaxEditLexTokensDef Constructor ()

Default object constructor.

CXTPSyntaxEditLexTokensDef();
Body Source
CXTPSyntaxEditLexTokensDef(){}
Group

CXTPSyntaxEditLexTokensDef Constructor


CXTPSyntaxEditLexTokensDef::CXTPSyntaxEditLexTokensDef Constructor (const CXTPSyntaxEditLexTokensDef&)

CXTPSyntaxEditLexTokensDef Constructor, CXTPSyntaxEditLexTokensDef Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef::CXTPSyntaxEditLexTokensDef Constructor (const CXTPSyntaxEditLexTokensDef&)

Copy object constructor.

CXTPSyntaxEditLexTokensDef(
    const CXTPSyntaxEditLexTokensDef& rSrc
);
Parameters

rSrc
[in] Reference to source CXTPSyntaxEditLexTokensDef object.

Group

CXTPSyntaxEditLexTokensDef Constructor


CXTPSyntaxEditLexTokensDef Destructors

CXTPSyntaxEditLexTokensDef Class, Legend, Public Methods
CXTPSyntaxEditLexTokensDef Destructors
Class

CXTPSyntaxEditLexTokensDef Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexTokensDef | Object destructor. Handles clean up and deallocations.


CXTPSyntaxEditLexTokensDef::~CXTPSyntaxEditLexTokensDef Destructor

CXTPSyntaxEditLexTokensDef Destructors, CXTPSyntaxEditLexTokensDef Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef::~CXTPSyntaxEditLexTokensDef Destructor

Object destructor. Handles clean up and deallocations.

virtual ~CXTPSyntaxEditLexTokensDef();
Group

CXTPSyntaxEditLexTokensDef Destructors


CXTPSyntaxEditLexTokensDef Operators

CXTPSyntaxEditLexTokensDef Class, Legend, Public Operators
CXTPSyntaxEditLexTokensDef Operators
Class

CXTPSyntaxEditLexTokensDef Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Assignment operator for class.


CXTPSyntaxEditLexTokensDef::= Operator

CXTPSyntaxEditLexTokensDef Operators, CXTPSyntaxEditLexTokensDef Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexTokensDef::= Operator

Assignment operator for class.

const CXTPSyntaxEditLexTokensDef& operator =(
    const CXTPSyntaxEditLexTokensDef& rSrc
);
Parameters

rSrc
[in] Reference to source CXTPSyntaxEditLexTokensDef object.

Returns

Reference to CXTPSyntaxEditLexTokensDef object.

Group

CXTPSyntaxEditLexTokensDef Operators


CXTPSyntaxEditLexVariable Class

XTPSyntaxEditLexClass.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexVariable Enumerations, CXTPSyntaxEditLexVariable Data Members, CXTPSyntaxEditLexVariable Methods, CXTPSyntaxEditLexVariable Constructors, CXTPSyntaxEditLexVariable Destructors, CXTPSyntaxEditLexVariable Operators, CXTPSyntaxEditLexVariable Constructors, CXTPSyntaxEditLexVariable Data Members, CXTPSyntaxEditLexVariable Destructors, CXTPSyntaxEditLexVariable Enumerations, CXTPSyntaxEditLexVariable Methods, CXTPSyntaxEditLexVariable Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable Class

CXTPSyntaxEditLexVariable class is used to represent lexical variables. In the class schema variables begins from symbol @. Standard variables are: @alpha, @digit, @HexDigit, @specs, @EOL.

Class Hierarchy

class CXTPSyntaxEditLexVariable;
File

XTPSyntaxEditLexClass.h

See Also

Classes schema syntax.

Group

Classes

Legend
Enumeration
Data Member
protected
Method
virtual
Operator
CXTPSyntaxEditLexVariable Constructors
CXTPSyntaxEditLexVariable Constructors | Description
CXTPSyntaxEditLexVariable | Default object constructor.
CXTPSyntaxEditLexVariable Data Members
CXTPSyntaxEditLexVariable Data Members | Description
m_nVarFlags | Additional lex variable properties (flags).
m_nVarID | Lex variable identifier.
s_bVarMapInitialized | Is initialized state of the lex variable name to ID map.
s_mapVar2ID | Lex variable name to ID map.
CXTPSyntaxEditLexVariable Destructors
CXTPSyntaxEditLexVariable Destructors | Description
~CXTPSyntaxEditLexVariable | Default object destructor.
CXTPSyntaxEditLexVariable Enumerations
CXTPSyntaxEditLexVariable Enumerations | Description
XTPSyntaxEditLexVarFlags | XTPSyntaxEditLexVarFlags type defines the constants used to specify additional lex variable properties.
XTPSyntaxEditLexVarID | XTPSyntaxEditLexVarID type defines the constants used to identify standard lexical variables: @alpha, @digit, @HexDigit, @specs, @EOL.
CXTPSyntaxEditLexVariable Methods
CXTPSyntaxEditLexVariable Methods | Description
GetVariableData | This method is used to get lex variable chars.
GetVarID | Determine standard lex variable ID using string lex variable representation.
InitStandartVarsIfNeed | Initialize internal Lex variable name to ID map.
SetVariable | Set object members using string lex variable representation.
CXTPSyntaxEditLexVariable Operators
CXTPSyntaxEditLexVariable Operators | Description
= | Copy operator.
== | Equal-to operator.


CXTPSyntaxEditLexVariable Enumerations

Enumerations, CXTPSyntaxEditLexVariable Class, Legend
CXTPSyntaxEditLexVariable Enumerations
Enumerations
Enumeration | Description
XTPSyntaxEditLexVarFlags | XTPSyntaxEditLexVarFlags type defines the constants used to specify additional lex variable properties.
XTPSyntaxEditLexVarID | XTPSyntaxEditLexVarID type defines the constants used to identify standard lexical variables: @alpha, @digit, @HexDigit, @specs, @EOL.
Class

CXTPSyntaxEditLexVariable Class

Legend
Enumeration


CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarFlags Enumeration

XTPSyntaxEditLexClass.h, CXTPSyntaxEditLexVariable Enumerations, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarFlags Enumeration

XTPSyntaxEditLexVarFlags type defines the constants used to specify additional lex variable properties.

enum XTPSyntaxEditLexVarFlags {
  xtpEditVarfNot = 0x001
};
File

XTPSyntaxEditLexClass.h

Members

xtpEditVarfNot
specify NOT operation for the lex variable.

See Also

CXTPSyntaxEditLexVariable::m_nVarFlags.

Group

CXTPSyntaxEditLexVariable Enumerations


CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID Enumeration

XTPSyntaxEditLexClass.h, CXTPSyntaxEditLexVariable Enumerations, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID Enumeration

XTPSyntaxEditLexVarID type defines the constants used to identify standard lexical variables: @alpha, @digit, @HexDigit, @specs, @EOL.

enum XTPSyntaxEditLexVarID {
  xtpEditVarID_Unknown = 0,
  xtpEditVarID_alpha = 1,
  xtpEditVarID_digit = 2,
  xtpEditVarID_HexDigit = 3,
  xtpEditVarID_specs = 4,
  xtpEditVarID_EOL = 5
};
File

XTPSyntaxEditLexClass.h

Members

xtpEditVarID_Unknown
Undefined value.
xtpEditVarID_alpha
ID for lex variable - @alpha
xtpEditVarID_digit
ID for lex variable - @digit
xtpEditVarID_HexDigit
ID for lex variable - @HexDigit
xtpEditVarID_specs
ID for lex variable - @specs
xtpEditVarID_EOL
ID for lex variable - @EOL

See Also

CXTPSyntaxEditLexVariable::m_nVarID

Group

CXTPSyntaxEditLexVariable Enumerations


CXTPSyntaxEditLexVariable Data Members

CXTPSyntaxEditLexVariable Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable Data Members
Class

CXTPSyntaxEditLexVariable Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
s_bVarMapInitialized | Is initialized state of the lex variable name to ID map.
s_mapVar2ID | Lex variable name to ID map.
Public Data Members
Public Data Member | Description
m_nVarFlags | Additional lex variable properties (flags).
m_nVarID | Lex variable identifier.


CXTPSyntaxEditLexVariable::m_nVarFlags Data Member

CXTPSyntaxEditLexVariable Data Members, CXTPSyntaxEditLexVariable Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::m_nVarFlags Data Member

Additional lex variable properties (flags).

int m_nVarFlags;
Group

CXTPSyntaxEditLexVariable Data Members


CXTPSyntaxEditLexVariable::m_nVarID Data Member

CXTPSyntaxEditLexVariable Data Members, CXTPSyntaxEditLexVariable Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::m_nVarID Data Member

Lex variable identifier.

int m_nVarID;
Group

CXTPSyntaxEditLexVariable Data Members


CXTPSyntaxEditLexVariable::s_bVarMapInitialized Data Member

CXTPSyntaxEditLexVariable Data Members, CXTPSyntaxEditLexVariable Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::s_bVarMapInitialized Data Member

Is initialized state of the lex variable name to ID map.

BOOL s_bVarMapInitialized;
Group

CXTPSyntaxEditLexVariable Data Members


CXTPSyntaxEditLexVariable::s_mapVar2ID Data Member

CXTPSyntaxEditLexVariable Data Members, CXTPSyntaxEditLexVariable Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::s_mapVar2ID Data Member

Lex variable name to ID map.

CMapStringToPtr s_mapVar2ID;
Group

CXTPSyntaxEditLexVariable Data Members


CXTPSyntaxEditLexVariable Methods

CXTPSyntaxEditLexVariable Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable Methods
Class

CXTPSyntaxEditLexVariable Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
InitStandartVarsIfNeed | Initialize internal Lex variable name to ID map.
Public Methods
Public Methods
Public Method | Description
GetVariableData | This method is used to get lex variable chars.
GetVarID | Determine standard lex variable ID using string lex variable representation.
SetVariable | Set object members using string lex variable representation.


CXTPSyntaxEditLexVariable::GetVariableData Method

CXTPSyntaxEditLexVariable Methods, CXTPSyntaxEditLexVariable Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::GetVariableData Method

This method is used to get lex variable chars.

static BOOL GetVariableData(
    int nVarID,
    CStringArray& rarVarData
);
Parameters

nVarID
[in] A value from CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID enum.
rarVarData
[out] A reference to CStringArray to get data.

Returns

TRUE if successful, otherwise - FALSE.

See Also

CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID

Group

CXTPSyntaxEditLexVariable Methods


CXTPSyntaxEditLexVariable::GetVarID Method

CXTPSyntaxEditLexVariable Methods, CXTPSyntaxEditLexVariable Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::GetVarID Method

Determine standard lex variable ID using string lex variable representation.

static int GetVarID(
    LPCTSTR pcszVarName
);
Parameters

pcszVarName
[in] string lex variable representation (without flags). Like "@alpha" or "@digit".

Returns

xtpEditVarID_Unknown if fails, otherwise, if successful, other value from enum XTPSyntaxEditLexVarID.

Remarks

This method determine standard lex variable ID using specified string.

See Also

CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID type, CXTPSyntaxEditLexVariable::SetVariable()

Group

CXTPSyntaxEditLexVariable Methods


CXTPSyntaxEditLexVariable::InitStandartVarsIfNeed Method

CXTPSyntaxEditLexVariable Methods, CXTPSyntaxEditLexVariable Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::InitStandartVarsIfNeed Method

Initialize internal Lex variable name to ID map.

static void InitStandartVarsIfNeed();
Remarks

This method initialize internal Lex variable name to ID map if it is not yet initialized.

See Also

CXTPSyntaxEditLexVariable::s_mapVar2ID, CXTPSyntaxEditLexVariable::s_bVarMapInitialized()

Group

CXTPSyntaxEditLexVariable Methods


CXTPSyntaxEditLexVariable::SetVariable Method

CXTPSyntaxEditLexVariable Methods, CXTPSyntaxEditLexVariable Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::SetVariable Method

Set object members using string lex variable representation.

virtual BOOL SetVariable(
    LPCTSTR pcszVarName
);
Parameters

pcszVarName
[in] string lex variable representation (with flags). Like "@alpha" or "@digit:not".

Returns

TRUE if successful, otherwise - FALSE.

Remarks

This method parse specified string and determine standard lex variable ID and additional flags.

See Also

CXTPSyntaxEditLexVariable::GetVarID()

Group

CXTPSyntaxEditLexVariable Methods


CXTPSyntaxEditLexVariable Constructors

CXTPSyntaxEditLexVariable Class, Legend, Public Methods
CXTPSyntaxEditLexVariable Constructors
Class

CXTPSyntaxEditLexVariable Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexVariable | Default object constructor.


CXTPSyntaxEditLexVariable::CXTPSyntaxEditLexVariable Constructor

CXTPSyntaxEditLexVariable Constructors, CXTPSyntaxEditLexVariable Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::CXTPSyntaxEditLexVariable Constructor

Default object constructor.

CXTPSyntaxEditLexVariable();
Group

CXTPSyntaxEditLexVariable Constructors


CXTPSyntaxEditLexVariable Destructors

CXTPSyntaxEditLexVariable Class, Legend, Public Methods
CXTPSyntaxEditLexVariable Destructors
Class

CXTPSyntaxEditLexVariable Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexVariable | Default object destructor.


CXTPSyntaxEditLexVariable::~CXTPSyntaxEditLexVariable Destructor

CXTPSyntaxEditLexVariable Destructors, CXTPSyntaxEditLexVariable Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::~CXTPSyntaxEditLexVariable Destructor

Default object destructor.

virtual ~CXTPSyntaxEditLexVariable();
Group

CXTPSyntaxEditLexVariable Destructors


CXTPSyntaxEditLexVariable Operators

CXTPSyntaxEditLexVariable Class, Legend, Public Operators
CXTPSyntaxEditLexVariable Operators
Class

CXTPSyntaxEditLexVariable Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Copy operator.
== | Equal-to operator.


CXTPSyntaxEditLexVariable::= Operator

CXTPSyntaxEditLexVariable Operators, CXTPSyntaxEditLexVariable Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::= Operator

Copy operator.

const CXTPSyntaxEditLexVariable& operator =(
    const CXTPSyntaxEditLexVariable& rSrc
);
Parameters

rSrc
[in] Constant reference to the source object.

Returns

Constant reference to the destination object.

Remarks

This operator fill object members using source object values.

See Also

Operator copy (=) in C++.

Group

CXTPSyntaxEditLexVariable Operators


CXTPSyntaxEditLexVariable::== Operator

CXTPSyntaxEditLexVariable Operators, CXTPSyntaxEditLexVariable Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariable::== Operator

Equal-to operator.

BOOL operator ==(
    const CXTPSyntaxEditLexVariable& rSrc
) const;
Parameters

rSrc
[in] Constant reference to the other object.

Returns

It returns TRUE if both operands have the same value; otherwise, it returns FALSE.

Remarks

This operator determine are objects equal.

See Also

Equality Operators in C++.

Group

CXTPSyntaxEditLexVariable Operators


CXTPSyntaxEditLexVariant Class

XTPSyntaxEditLexClass.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLexVariant Data Members, CXTPSyntaxEditLexVariant Methods, CXTPSyntaxEditLexVariant Constructors, CXTPSyntaxEditLexVariant Destructors, CXTPSyntaxEditLexVariant Operators, CXTPSyntaxEditLexVariant Constructors, CXTPSyntaxEditLexVariant Data Members, CXTPSyntaxEditLexVariant Destructors, CXTPSyntaxEditLexVariant Methods, CXTPSyntaxEditLexVariant Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant Class

CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type.

Class Hierarchy

class CXTPSyntaxEditLexVariant;
File

XTPSyntaxEditLexClass.h

See Also

XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

Group

Classes

Legend
Data Member
Method
virtual
Operator
CXTPSyntaxEditLexVariant Constructors
CXTPSyntaxEditLexVariant Constructors | Description
CXTPSyntaxEditLexVariant |
CXTPSyntaxEditLexVariant Data Members
CXTPSyntaxEditLexVariant Data Members | Description
m_arStrVals | Value storage for types xtpEditLVT_className , xtpEditLVT_valStr
m_nObjType | Object type value from XTPSyntaxEditLexVariantType.
m_nValue | Value storage for type xtpEditLVT_valInt
m_ptrClass | Value storage for type xtpEditLVT_classPtr
m_ptrLVArrayPtr | Value storage for type xtpEditLVT_LVArrayPtr
m_Variable | Value storage for type xtpEditLVT_valVar
CXTPSyntaxEditLexVariant Destructors
CXTPSyntaxEditLexVariant Destructors | Description
~CXTPSyntaxEditLexVariant | Default object destructor.
CXTPSyntaxEditLexVariant Methods
CXTPSyntaxEditLexVariant Methods | Description
Clone | Clone variant object.
Dump | Print stored object value(s) to the trace.
GetStr | Get string for the string type variant object.
IsStrType | Is variant object contains string(s).
SetVariable | Set object members using string lex variable representation.
CXTPSyntaxEditLexVariant Operators
CXTPSyntaxEditLexVariant Operators | Description
= |
== | Equal-to operator.


CXTPSyntaxEditLexVariant Data Members

CXTPSyntaxEditLexVariant Class, Legend, Public Data Members
CXTPSyntaxEditLexVariant Data Members
Class

CXTPSyntaxEditLexVariant Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_arStrVals | Value storage for types xtpEditLVT_className , xtpEditLVT_valStr
m_nObjType | Object type value from XTPSyntaxEditLexVariantType.
m_nValue | Value storage for type xtpEditLVT_valInt
m_ptrClass | Value storage for type xtpEditLVT_classPtr
m_ptrLVArrayPtr | Value storage for type xtpEditLVT_LVArrayPtr
m_Variable | Value storage for type xtpEditLVT_valVar


CXTPSyntaxEditLexVariant::m_arStrVals Data Member

CXTPSyntaxEditLexVariant Data Members, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::m_arStrVals Data Member

Value storage for types xtpEditLVT_className , xtpEditLVT_valStr

CStringArray m_arStrVals;
Group

CXTPSyntaxEditLexVariant Data Members


CXTPSyntaxEditLexVariant::m_nObjType Data Member

CXTPSyntaxEditLexVariant Data Members, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::m_nObjType Data Member

Object type value from XTPSyntaxEditLexVariantType.

int m_nObjType;
Group

CXTPSyntaxEditLexVariant Data Members


CXTPSyntaxEditLexVariant::m_nValue Data Member

CXTPSyntaxEditLexVariant Data Members, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::m_nValue Data Member

Value storage for type xtpEditLVT_valInt

int m_nValue;
Group

CXTPSyntaxEditLexVariant Data Members


CXTPSyntaxEditLexVariant::m_ptrClass Data Member

CXTPSyntaxEditLexVariant Data Members, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::m_ptrClass Data Member

Value storage for type xtpEditLVT_classPtr

CXTPSyntaxEditLexClassPtr m_ptrClass;
Group

CXTPSyntaxEditLexVariant Data Members


CXTPSyntaxEditLexVariant::m_ptrLVArrayPtr Data Member

CXTPSyntaxEditLexVariant Data Members, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::m_ptrLVArrayPtr Data Member

Value storage for type xtpEditLVT_LVArrayPtr

CXTPSyntaxEditLexVariantPtrArray* m_ptrLVArrayPtr;
Group

CXTPSyntaxEditLexVariant Data Members


CXTPSyntaxEditLexVariant::m_Variable Data Member

CXTPSyntaxEditLexVariant Data Members, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::m_Variable Data Member

Value storage for type xtpEditLVT_valVar

CXTPSyntaxEditLexVariable m_Variable;
Group

CXTPSyntaxEditLexVariant Data Members


CXTPSyntaxEditLexVariant Methods

CXTPSyntaxEditLexVariant Class, Legend, Public Methods
CXTPSyntaxEditLexVariant Methods
Class

CXTPSyntaxEditLexVariant Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
Clone | Clone variant object.
Dump | Print stored object value(s) to the trace.
GetStr | Get string for the string type variant object.
IsStrType | Is variant object contains string(s).
SetVariable | Set object members using string lex variable representation.


CXTPSyntaxEditLexVariant::Clone Method

CXTPSyntaxEditLexVariant Methods, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::Clone Method

Clone variant object.

virtual CXTPSyntaxEditLexVariant* Clone() const;
Returns

Pointer to the new object.

Remarks

Create a new CXTPSyntaxEditLexVariant object using new operator and initialize it using this object. New object reference counter is initialized by 1. InternalRelease() should be called to delete unused object.

Group

CXTPSyntaxEditLexVariant Methods


CXTPSyntaxEditLexVariant::Dump Method

CXTPSyntaxEditLexVariant Methods, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::Dump Method

Print stored object value(s) to the trace.

void Dump(
    CDumpContext& dc
) const;
Parameters

dc
A reference to CDumpContext object.

Remarks

Used for debug only.

Group

CXTPSyntaxEditLexVariant Methods


CXTPSyntaxEditLexVariant::GetStr Method

CXTPSyntaxEditLexVariant Methods, CXTPSyntaxEditLexVariant Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::GetStr Method

Get string for the string type variant object.

virtual LPCTSTR GetStr() const;
Returns

Value of m_arStrVals[0] if object is string type, otherwise - empty string.

Remarks

Call this method to get first string stored in the object ( m_arStrVals[0] member value).

See Also

CXTPSyntaxEditLexVariant::IsStrType(), XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexVariant::m_arStrVals.

Group

CXTPSyntaxEditLexVariant Methods


CXTPSyntaxEditLexVariant::IsStrType Method

CXTPSyntaxEditLexVariant Methods, CXTPSyntaxEditLexVariant Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::IsStrType Method

Is variant object contains string(s).

virtual BOOL IsStrType() const;
Returns

TRUE if object is string type: xtpEditLVT_valStr , xtpEditLVT_className , otherwise - FALSE.

Remarks

Call this method to determine is object has a string type. In this case m_arStrVals member is used to access data.

See Also

XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexVariant::m_arStrVals.

Group

CXTPSyntaxEditLexVariant Methods


CXTPSyntaxEditLexVariant::SetVariable Method

CXTPSyntaxEditLexVariant Methods, CXTPSyntaxEditLexVariant Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::SetVariable Method

Set object members using string lex variable representation.

virtual BOOL SetVariable(
    LPCTSTR pcszVarName
);
Parameters

pcszVarName
[in] string lex variable representation (with flags). Like "@alpha" or "@digit:not".

Returns

TRUE if successful, otherwise - FALSE.

Remarks

This method sets the object type to xtpEditLVT_valVar , and initialize m_Variable member using specified string lex variable representation.

See Also

CXTPSyntaxEditLexVariable::SetVariable()

Group

CXTPSyntaxEditLexVariant Methods


CXTPSyntaxEditLexVariant Constructors

CXTPSyntaxEditLexVariant Class, Legend, Public Methods
CXTPSyntaxEditLexVariant Constructors
Class

CXTPSyntaxEditLexVariant Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexVariant |


CXTPSyntaxEditLexVariant Constructor

CXTPSyntaxEditLexVariant Constructors
CXTPSyntaxEditLexVariant Constructor
Overload List
Constructors
Constructor | Description
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant () | Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant (CXTPSyntaxEditLexClass*) | Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant (CXTPSyntaxEditLexVariantPtrArray*) | Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant (LPCTSTR, int) | Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant (const CStringArray*) | Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant (const CXTPSyntaxEditLexVariable&) | Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant (const CXTPSyntaxEditLexVariant&) | Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant (int) | Object constructor.
Group

CXTPSyntaxEditLexVariant Constructors


CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant Constructor ()

CXTPSyntaxEditLexVariant Constructor, CXTPSyntaxEditLexVariant Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant Constructor ()

Object constructor.

CXTPSyntaxEditLexVariant();
CXTPSyntaxEditLexVariant(
    const CXTPSyntaxEditLexVariant& rSrc
);
CXTPSyntaxEditLexVariant(
    CXTPSyntaxEditLexClass* pClass
);
CXTPSyntaxEditLexVariant(
    CXTPSyntaxEditLexVariantPtrArray* pLVArray
);
CXTPSyntaxEditLexVariant(
    const CXTPSyntaxEditLexVariable& rSrcVar
);
CXTPSyntaxEditLexVariant(
    LPCTSTR pcszStr,
    int eType = xtpEditLVT_valStr
);
CXTPSyntaxEditLexVariant(
    const CStringArray* pArStrVals
);
CXTPSyntaxEditLexVariant(
    int nValue
);
Parameters

rSrc
[in] Initialize new object using other LexVariant object.
pClass
[in] Set new object type to xtpEditLVT_classPtr , and initialize m_ptrClass member using specified pointer. InternalAddRef() is called for the pClass object. InternalRelease() will be called in the destructor.
pLVArray
[in] Set new object type to xtpEditLVT_LVArrayPtr , and initialize m_ptrLVArrayPtr member using specified pointer. If bWithAddRef parameter value is TRUE InternalAddRef() is called for the pLVArray object.
rSrcVar
[in] Set new object type to xtpEditLVT_valVar , and initialize m_Variable member using specified object.
pcszStr
[in] Set new object type to eType parameter value, and initialize m_arStrVals[0] member using specified string. eType parameter value should be a string type: xtpEditLVT_valStr , xtpEditLVT_className .
eType
[in] Object type value from XTPSyntaxEditLexVariantType.
pArStrVals
[in] Set new object type to xtpEditLVT_valStr , and initialize m_arStrVals member using specified pointer.
nValue
[in] Set new object type to xtpEditLVT_valInt , and initialize m_nValue member using specified value.
bWithAddRef
[in] If parameter value is TRUE InternalAddRef() is called for the specified object.

Remarks

Construct an empty object, or initialize it using specified parameters.

See Also

XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

Group

CXTPSyntaxEditLexVariant Constructor


CXTPSyntaxEditLexVariant Destructors

CXTPSyntaxEditLexVariant Class, Legend, Public Methods
CXTPSyntaxEditLexVariant Destructors
Class

CXTPSyntaxEditLexVariant Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLexVariant | Default object destructor.


CXTPSyntaxEditLexVariant::~CXTPSyntaxEditLexVariant Destructor

CXTPSyntaxEditLexVariant Destructors, CXTPSyntaxEditLexVariant Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::~CXTPSyntaxEditLexVariant Destructor

Default object destructor.

virtual ~CXTPSyntaxEditLexVariant();
Group

CXTPSyntaxEditLexVariant Destructors


CXTPSyntaxEditLexVariant Operators

CXTPSyntaxEditLexVariant Class, Legend, Public Operators
CXTPSyntaxEditLexVariant Operators
Class

CXTPSyntaxEditLexVariant Class

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= |
== | Equal-to operator.


= Operator

CXTPSyntaxEditLexVariant Operators
= Operator
Overload List
Operators
Operator | Description
CXTPSyntaxEditLexVariant::= (const CXTPSyntaxEditLexVariable&) | Copy operator.
CXTPSyntaxEditLexVariant::= (const CXTPSyntaxEditLexVariant&) | Copy operator.
CXTPSyntaxEditLexVariant::= (int) | Copy operator.
Group

CXTPSyntaxEditLexVariant Operators


CXTPSyntaxEditLexVariant::= Operator (const CXTPSyntaxEditLexVariable&)

= Operator, CXTPSyntaxEditLexVariant Class, See Also
CXTPSyntaxEditLexVariant::= Operator (const CXTPSyntaxEditLexVariable&)

Copy operator.

const CXTPSyntaxEditLexVariant& operator =(
    const CXTPSyntaxEditLexVariable& rSrcVar
);
Parameters

rSrcVar
[in] Value to be stored in the lex variant object.

Returns

Constant reference to the destination object.

Remarks

This operator sets the object type to xtpEditLVT_valVar , and initialize m_Variable member using specified object.

See Also

Operator copy (=) in C++.

Group

= Operator


CXTPSyntaxEditLexVariant::= Operator (const CXTPSyntaxEditLexVariant&)

= Operator, CXTPSyntaxEditLexVariant Class, See Also
CXTPSyntaxEditLexVariant::= Operator (const CXTPSyntaxEditLexVariant&)

Copy operator.

const CXTPSyntaxEditLexVariant& operator =(
    const CXTPSyntaxEditLexVariant& rSrc
);
Parameters

rSrc
[in] Constant reference to the source object.

Returns

Constant reference to the destination object.

Remarks

This operator fill object members using source object values.

See Also

Operator copy (=) in C++.

Group

= Operator


CXTPSyntaxEditLexVariant::= Operator (int)

= Operator, CXTPSyntaxEditLexVariant Class, See Also
CXTPSyntaxEditLexVariant::= Operator (int)

Copy operator.

const CXTPSyntaxEditLexVariant& operator =(
    int nVal
);
Parameters

nVal
[in] Value to be stored in the lex variant object.

Returns

Constant reference to the destination object.

Remarks

This operator sets the object type to xtpEditLVT_valInt , and initialize m_nValue member using specified value.

See Also

Operator copy (=) in C++.

Group

= Operator


CXTPSyntaxEditLexVariant::== Operator

CXTPSyntaxEditLexVariant Operators, CXTPSyntaxEditLexVariant Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLexVariant::== Operator

Equal-to operator.

BOOL operator ==(
    const CXTPSyntaxEditLexVariant& rSrc
) const;
Parameters

rSrc
[in] Constant reference to the other object.

Returns

It returns TRUE if both operands have the same value; otherwise, it returns FALSE.

Remarks

This operator determine are objects equal.

See Also

Equality Operators in C++.

Group

CXTPSyntaxEditLexVariant Operators


CXTPSyntaxEditLexVariantPtrArrayExAutomatT Template

XTPSyntaxEditLexClassSubObjT.h, Classes
CXTPSyntaxEditLexVariantPtrArrayExAutomatT Template
Class Hierarchy

template <LPCTSTR (* _FuncName)(void) >
class CXTPSyntaxEditLexVariantPtrArrayExAutomatT : public CXTPSyntaxEditLexVariantPtrArrayExT<_FuncName>;
File

XTPSyntaxEditLexClassSubObjT.h

Group

Classes


CXTPSyntaxEditLineMarksManager Class

XTPSyntaxEditLineMarksManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Constructors, CXTPSyntaxEditLineMarksManager Destructors, CXTPSyntaxEditLineMarksManager Nested Types, CXTPSyntaxEditLineMarksManager Constructors, CXTPSyntaxEditLineMarksManager Destructors, CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Nested Types
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager Class

CXTPSyntaxEditLineMarksManager class provides functionality to to manipulate marks on text lines. Used internally by the Smart Edit control.

Class Hierarchy

class CXTPSyntaxEditLineMarksManager;
File

XTPSyntaxEditLineMarksManager.h

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditLineMarksManager Constructors
CXTPSyntaxEditLineMarksManager Constructors | Description
CXTPSyntaxEditLineMarksManager | Default object constructor.
CXTPSyntaxEditLineMarksManager Destructors
CXTPSyntaxEditLineMarksManager Destructors | Description
~CXTPSyntaxEditLineMarksManager | Destroys a CXTPSyntaxEditLineMarksManager object, handles cleanup and de-allocation.
CXTPSyntaxEditLineMarksManager Methods
CXTPSyntaxEditLineMarksManager Methods | Description
AddRemoveLineMark | Adds/removes required mark on given text line.
DeleteLineMark | Removes required mark on given text line.
FindNextLineMark | Returns identifier of the marked line.
FindPrevLineMark | Returns identifier of the marked line.
GetCount | Returns count of line marks of the specified type.
GetFirstLineMark | Returns reference to the of the first marked line position for the specific line marks type.
GetLastLineMark | Returns identifier of the marked line.
GetLineMarkAt | Returns mark from given position.
GetNextLineMark | Returns reference to the of the next marked line position for the specific line marks type.
HasRowMark | Determines if row has mark.
RefreshLineMarks | Updates line marks for given range of rows.
RemoveAll | Removes all line marks from the corresponding types list.
SetLineMark | Sets required mark on given text line.
CXTPSyntaxEditLineMarksManager Nested Types
CXTPSyntaxEditLineMarksManager Nested Types | Description
CLineMarksListPtr | SmartPointer for the class.


CXTPSyntaxEditLineMarksManager Methods

CXTPSyntaxEditLineMarksManager Class, Legend, Public Methods
CXTPSyntaxEditLineMarksManager Methods
Class

CXTPSyntaxEditLineMarksManager Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AddRemoveLineMark | Adds/removes required mark on given text line.
DeleteLineMark | Removes required mark on given text line.
FindNextLineMark | Returns identifier of the marked line.
FindPrevLineMark | Returns identifier of the marked line.
GetCount | Returns count of line marks of the specified type.
GetFirstLineMark | Returns reference to the of the first marked line position for the specific line marks type.
GetLastLineMark | Returns identifier of the marked line.
GetLineMarkAt | Returns mark from given position.
GetNextLineMark | Returns reference to the of the next marked line position for the specific line marks type.
HasRowMark | Determines if row has mark.
RefreshLineMarks | Updates line marks for given range of rows.
RemoveAll | Removes all line marks from the corresponding types list.
SetLineMark | Sets required mark on given text line.


CXTPSyntaxEditLineMarksManager::AddRemoveLineMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::AddRemoveLineMark Method

Adds/removes required mark on given text line.

void AddRemoveLineMark(
    int nRow,
    const XTP_EDIT_LINEMARKTYPE lmType,
    XTP_EDIT_LMPARAM* pParam = NULL
);
Parameters

nRow
[in] row number.
lmType
[in] mark type identifier.
pParam
[in] pointer to XTP_EDIT_LMPARAM. Default is NULL.

Remarks

Call this member function to add or remove mark on the given text line: if line don't have specified mark it will be added; otherwise mark will be deleted.

See Also

struct XTP_EDIT_LMPARAM.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::DeleteLineMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::DeleteLineMark Method

Removes required mark on given text line.

void DeleteLineMark(
    int nRow,
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

nRow
[in] row number.
lmType
[in] mark type identifier.

Remarks

Call this member function to remove mark on the given text line.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::FindNextLineMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::FindNextLineMark Method

Returns identifier of the marked line.

POSITION FindNextLineMark(
    int& nRow,
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

nRow
[in]row number.
lmType
[in]mark type identifier.

Returns

Number identifier of the marked line.

Remarks

Call this member function to get line identifier that have given mark type and following specified line number.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::FindPrevLineMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::FindPrevLineMark Method

Returns identifier of the marked line.

POSITION FindPrevLineMark(
    int& nRow,
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

nRow
[in]row number.
lmType
[in]mark type identifier.

Returns

Number identifier of the marked line.

Remarks

Call this member function to get line identifier that have given mark type and precedes specified line number.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::GetCount Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::GetCount Method

Returns count of line marks of the specified type.

int GetCount(
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

lmType
[in] pointer to null terminated string with types list.

Returns

Count of line marks as integer value.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::GetFirstLineMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::GetFirstLineMark Method

Returns reference to the of the first marked line position for the specific line marks type.

POSITION GetFirstLineMark(
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

lmType
[in]mark type identifier.

Returns

Number identifier of the marked line;

Remarks

Call this member function to get the first line identifier that have given mark type.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::GetLastLineMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::GetLastLineMark Method

Returns identifier of the marked line.

POSITION GetLastLineMark(
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

lmType
[in]mark type identifier.
nRow
[in]row number.

Returns

Number identifier of the marked line.

Remarks

Call this member function to get the last line identifier that have given mark type and following specified line number.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::GetLineMarkAt Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::GetLineMarkAt Method

Returns mark from given position.

XTP_EDIT_LMDATA* GetLineMarkAt(
    const POSITION pos,
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

pos
[in]Current POSITION value.
lmType
[in]mark type identifier.

Returns

Number identifier of the marked line.

Remarks

Call this member function to get the next line identifier that have given mark type.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::GetNextLineMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::GetNextLineMark Method

Returns reference to the of the next marked line position for the specific line marks type.

XTP_EDIT_LMDATA* GetNextLineMark(
    POSITION& pos,
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

pos
[in]Start POSITION value.
lmType
[in]mark type identifier.

Returns

Pointer to XTP_EDIT_LMDATA with number identifier of the marked line.

Remarks

Call this member function to get the next line identifier that have given mark type.

See Also

struct XTP_EDIT_LMDATA.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::HasRowMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::HasRowMark Method

Determines if row has mark.

BOOL HasRowMark(
    int nRow,
    const XTP_EDIT_LINEMARKTYPE& lmType,
    XTP_EDIT_LMPARAM* pParam = NULL
);
Parameters

nRow
[in]row number.
lmType
[in]mark type identifier.
pParam
[in] pointer to XTP_EDIT_LMPARAM. Default is NULL.

Returns

Returns TRUE if row has marked by the specified mark type; otherwise returns FALSE.

Remarks

Call this member function to determine if specified row has given type of mark.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::RefreshLineMarks Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::RefreshLineMarks Method

Updates line marks for given range of rows.

virtual void RefreshLineMarks(
    int nRowFrom,
    int nRowTo,
    int nRefreshType
);
Parameters

nRowFrom
[in] Start row identifier.
nRowTo
[in] End row identifier.
eRefreshType
[in] refresh type.

See Also

XTPSyntaxEditLineMarksRefreshType.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::RemoveAll Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::RemoveAll Method

Removes all line marks from the corresponding types list.

void RemoveAll(
    const XTP_EDIT_LINEMARKTYPE lmType
);
Parameters

lmType
[in] pointer to null terminated string with types list.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager::SetLineMark Method

CXTPSyntaxEditLineMarksManager Methods, CXTPSyntaxEditLineMarksManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::SetLineMark Method

Sets required mark on given text line.

void SetLineMark(
    int nRow,
    const XTP_EDIT_LINEMARKTYPE lmType,
    XTP_EDIT_LMPARAM* pParam = NULL
);
Parameters

nRow
[in]row number.
lmType
[in]mark type identifier.
pParam
[in] pointer to XTP_EDIT_LMPARAM. Default is NULL.

Remarks

Call this member function to add mark on the given text line.

See Also

struct XTP_EDIT_LMPARAM.

Group

CXTPSyntaxEditLineMarksManager Methods


CXTPSyntaxEditLineMarksManager Constructors

CXTPSyntaxEditLineMarksManager Class, Legend, Public Methods
CXTPSyntaxEditLineMarksManager Constructors
Class

CXTPSyntaxEditLineMarksManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLineMarksManager | Default object constructor.


CXTPSyntaxEditLineMarksManager::CXTPSyntaxEditLineMarksManager Constructor

CXTPSyntaxEditLineMarksManager Constructors, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::CXTPSyntaxEditLineMarksManager Constructor

Default object constructor.

CXTPSyntaxEditLineMarksManager();
Group

CXTPSyntaxEditLineMarksManager Constructors


CXTPSyntaxEditLineMarksManager Destructors

CXTPSyntaxEditLineMarksManager Class, Legend, Public Methods
CXTPSyntaxEditLineMarksManager Destructors
Class

CXTPSyntaxEditLineMarksManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditLineMarksManager | Destroys a CXTPSyntaxEditLineMarksManager object, handles cleanup and de-allocation.


CXTPSyntaxEditLineMarksManager::~CXTPSyntaxEditLineMarksManager Destructor

CXTPSyntaxEditLineMarksManager Destructors, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::~CXTPSyntaxEditLineMarksManager Destructor

Destroys a CXTPSyntaxEditLineMarksManager object, handles cleanup and de-allocation.

virtual ~CXTPSyntaxEditLineMarksManager();
Group

CXTPSyntaxEditLineMarksManager Destructors


CXTPSyntaxEditLineMarksManager Nested Types

CXTPSyntaxEditLineMarksManager Class, Public Nested Types
CXTPSyntaxEditLineMarksManager Nested Types
Class

CXTPSyntaxEditLineMarksManager Class

Public Nested Types
Public Nested Type | Description
CLineMarksListPtr | SmartPointer for the class.


CXTPSyntaxEditLineMarksManager::CLineMarksListPtr Nested Type

CXTPSyntaxEditLineMarksManager Nested Types, CXTPSyntaxEditLineMarksManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditLineMarksManager::CLineMarksListPtr Nested Type

SmartPointer for the class.

typedef CXTPSmartPtrInternalT<CLineMarksList> CLineMarksListPtr;
Group

CXTPSyntaxEditLineMarksManager Nested Types


CXTPSyntaxEditPaintManager Class

XTPSyntaxEditPaintManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Constructors, CXTPSyntaxEditPaintManager Destructors, CXTPSyntaxEditPaintManager Constructors, CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Destructors, CXTPSyntaxEditPaintManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager Class

This class used by CXTPSyntaxEditCtrl as the paint manager.

Class Hierarchy

class CXTPSyntaxEditPaintManager;
File

XTPSyntaxEditPaintManager.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditPaintManager Constructors
CXTPSyntaxEditPaintManager Constructors | Description
CXTPSyntaxEditPaintManager | Default object constructor.
CXTPSyntaxEditPaintManager Data Members
CXTPSyntaxEditPaintManager Data Members | Description
m_clrValues | Default color
m_font | Default font for normal text.
m_fontLineNumber | The font for line numbering
m_fontText | Current text font
m_fontToolTip | The font for tool tip text
m_hCurArrow | Standard ARROW cursor
m_hCurCopy | Cursor for copying text
m_hCurIBeam | Standard IBEAM cursor
m_hCurLine | Cursor to show on line selection area
m_hCurMove | Cursor for moving text
m_hCurNO | Standard NO cursor
m_ilBookmark | Image list with all bookmark images
m_penGray | Standard common gray pen
CXTPSyntaxEditPaintManager Destructors
CXTPSyntaxEditPaintManager Destructors | Description
~CXTPSyntaxEditPaintManager | Destroys a CXTPSyntaxEditPaintManager object, handles cleanup and deallocation.
CXTPSyntaxEditPaintManager Methods
CXTPSyntaxEditPaintManager Methods | Description
CreateFontIndirect | Set all editor fonts.
DrawCollapsedTextMarks | Draws frames around collapsed text blocks.
DrawLineCalcSel | Draws editor text line and calculates selection position.
DrawLineMark | Draws marks for line.
DrawLineMarks | Draws marks for line.
DrawLineNode | Draw the line Collapsible node icon
DrawLineNodeBackground | Fill the line node background.
DrawLineNumber | Draw the line numbers and returns the column position to start rest of the drawing.
DrawLineNumbersBorder | Draw the line numbers border .
DrawLineTextEx | Draws a single line.
GetBackColor | Get background color.
GetBackColorEx | Get corresponding background color for edit mode or for read-only mode.
GetBookmarks | Get Bookmarks image list.
GetCurArrow | Get standard ARROW cursor.
GetCurCopy | Get Cursor for copying text.
GetCurIBeam | Get standard IBEAM cursor.
GetCurLine | Get Cursor to show on line selection area.
GetCurMove | Get Cursor for moving text.
GetCurNO | Get standard NO cursor.
GetFont | Get common font.
GetFontLineNumber | Get line numbers font.
GetFontText | Get editor text font.
GetFontToolTip | ToolTip font.
GetHiliteBackColor | Get selected background color.
GetHiliteTextColor | Get selected text color.
GetInactiveHiliteBackColor | Get selected background color when control has no focus.
GetInactiveHiliteTextColor | Get selected text color when control has no focus.
GetLineNumberBackColor | Get Line Numbers background color.
GetLineNumberTextColor | Get Line Numbers text color.
GetTextColor | Get text color.
InitBitmaps | Initializes default paint manager bitmaps, should be called after creating control window.
PrintLineTextEx | Print a row text.
RefreshMetrics | This method is called to refresh the visual metrics of manager.
SetBackColor | Set background color.
SetCopyCursor | Sets cursor shape for "copy" cursor.
SetFont | Set common font.
SetFontLineNumber | Set line numbers font.
SetFontText | Set editor text font.
SetFontToolTip | Set ToolTip font.
SetHiliteBackColor | Set selected background color.
SetHiliteTextColor | Set selected text color.
SetInactiveHiliteBackColor | Set selected background color when control has no focus.
SetInactiveHiliteTextColor | Set selected text color when control has no focus.
SetLineNumberBackColor | Set Line Numbers background color.
SetLineNumberTextColor | Set Line Numbers text color.
SetLineSelCursor | Sets line selection cursor.
SetMoveCursor | Sets cursor shape for "move" cursor.
SetReadOnlyBackColor | Set background color for read-onlymode.
SetTextColor | Set text color.
UpdateTextFont | Update internal text font object (if need) and select it to DC.


CXTPSyntaxEditPaintManager Data Members

CXTPSyntaxEditPaintManager Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager Data Members
Class

CXTPSyntaxEditPaintManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_clrValues | Default color
m_font | Default font for normal text.
m_fontLineNumber | The font for line numbering
m_fontText | Current text font
m_fontToolTip | The font for tool tip text
m_hCurArrow | Standard ARROW cursor
m_hCurCopy | Cursor for copying text
m_hCurIBeam | Standard IBEAM cursor
m_hCurLine | Cursor to show on line selection area
m_hCurMove | Cursor for moving text
m_hCurNO | Standard NO cursor
m_ilBookmark | Image list with all bookmark images
m_penGray | Standard common gray pen


CXTPSyntaxEditPaintManager::m_clrValues Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_clrValues Data Member

Default color

XTP_EDIT_COLORVALUES m_clrValues;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_font Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_font Data Member

Default font for normal text.

CFont m_font;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_fontLineNumber Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_fontLineNumber Data Member

The font for line numbering

CFont m_fontLineNumber;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_fontText Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_fontText Data Member

Current text font

CFont m_fontText;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_fontToolTip Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_fontToolTip Data Member

The font for tool tip text

CFont m_fontToolTip;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_hCurArrow Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_hCurArrow Data Member

Standard ARROW cursor

HCURSOR m_hCurArrow;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_hCurCopy Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_hCurCopy Data Member

Cursor for copying text

HCURSOR m_hCurCopy;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_hCurIBeam Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_hCurIBeam Data Member

Standard IBEAM cursor

HCURSOR m_hCurIBeam;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_hCurLine Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_hCurLine Data Member

Cursor to show on line selection area

HCURSOR m_hCurLine;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_hCurMove Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_hCurMove Data Member

Cursor for moving text

HCURSOR m_hCurMove;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_hCurNO Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_hCurNO Data Member

Standard NO cursor

HCURSOR m_hCurNO;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_ilBookmark Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_ilBookmark Data Member

Image list with all bookmark images

CImageList m_ilBookmark;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager::m_penGray Data Member

CXTPSyntaxEditPaintManager Data Members, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::m_penGray Data Member

Standard common gray pen

CPen m_penGray;
Group

CXTPSyntaxEditPaintManager Data Members


CXTPSyntaxEditPaintManager Methods

CXTPSyntaxEditPaintManager Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager Methods
Class

CXTPSyntaxEditPaintManager Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
DrawLineMark | Draws marks for line.
DrawLineNumbersBorder | Draw the line numbers border .
GetBookmarks | Get Bookmarks image list.
Public Methods
Public Methods
Public Method | Description
CreateFontIndirect | Set all editor fonts.
DrawCollapsedTextMarks | Draws frames around collapsed text blocks.
DrawLineCalcSel | Draws editor text line and calculates selection position.
DrawLineMarks | Draws marks for line.
DrawLineNode | Draw the line Collapsible node icon
DrawLineNodeBackground | Fill the line node background.
DrawLineNumber | Draw the line numbers and returns the column position to start rest of the drawing.
DrawLineTextEx | Draws a single line.
GetBackColor | Get background color.
GetBackColorEx | Get corresponding background color for edit mode or for read-only mode.
GetCurArrow | Get standard ARROW cursor.
GetCurCopy | Get Cursor for copying text.
GetCurIBeam | Get standard IBEAM cursor.
GetCurLine | Get Cursor to show on line selection area.
GetCurMove | Get Cursor for moving text.
GetCurNO | Get standard NO cursor.
GetFont | Get common font.
GetFontLineNumber | Get line numbers font.
GetFontText | Get editor text font.
GetFontToolTip | ToolTip font.
GetHiliteBackColor | Get selected background color.
GetHiliteTextColor | Get selected text color.
GetInactiveHiliteBackColor | Get selected background color when control has no focus.
GetInactiveHiliteTextColor | Get selected text color when control has no focus.
GetLineNumberBackColor | Get Line Numbers background color.
GetLineNumberTextColor | Get Line Numbers text color.
GetTextColor | Get text color.
InitBitmaps | Initializes default paint manager bitmaps, should be called after creating control window.
PrintLineTextEx | Print a row text.
RefreshMetrics | This method is called to refresh the visual metrics of manager.
SetBackColor | Set background color.
SetCopyCursor | Sets cursor shape for "copy" cursor.
SetFont | Set common font.
SetFontLineNumber | Set line numbers font.
SetFontText | Set editor text font.
SetFontToolTip | Set ToolTip font.
SetHiliteBackColor | Set selected background color.
SetHiliteTextColor | Set selected text color.
SetInactiveHiliteBackColor | Set selected background color when control has no focus.
SetInactiveHiliteTextColor | Set selected text color when control has no focus.
SetLineNumberBackColor | Set Line Numbers background color.
SetLineNumberTextColor | Set Line Numbers text color.
SetLineSelCursor | Sets line selection cursor.
SetMoveCursor | Sets cursor shape for "move" cursor.
SetReadOnlyBackColor | Set background color for read-onlymode.
SetTextColor | Set text color.
UpdateTextFont | Update internal text font object (if need) and select it to DC.


CXTPSyntaxEditPaintManager::CreateFontIndirect Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::CreateFontIndirect Method

Set all editor fonts.

BOOL CreateFontIndirect(
    LPLOGFONT pLogfont,
    BOOL bUpdateReg = FALSE
);
Parameters

pLogfont
A pointer to LPLOGFONT structure.

Returns

TRUE if successful, FALSE otherwise.

See Also

SetFont, SetFontText, SetFontLineNumber, SetFontToolTip

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawCollapsedTextMarks Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawCollapsedTextMarks Method

Draws frames around collapsed text blocks.

virtual void DrawCollapsedTextMarks(
    CXTPSyntaxEditCtrl* pEditCtrl,
    CDC * pDC
);
Parameters

pEditCtrl
[in] A pointer to edit control.
pDC
[in] Pointer to device context.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawLineCalcSel Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawLineCalcSel Method

Draws editor text line and calculates selection position.

virtual void DrawLineCalcSel(
    const XTP_EDIT_TEXTBLOCK& txtBlk,
    int nSelStartX,
    int nSelEndX,
    XTP_EDIT_TEXTBLOCK (&arTxtBlk)[4],
    BOOL (&bUseBlk)[4]
);
Parameters

txtBlk
[in] Reference to XTP_EDIT_TEXTBLOCK structure.
nSelStartX
[in] Start coordinate.
nSelEndX
[in] End coordinate.
arTxtBlk
[in] Array of references to XTP_EDIT_TEXTBLOCK structures.
bUseBlk
[in] Array of references to BOOL.

See Also

struct XTP_EDIT_TEXTBLOCK

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawLineMark Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawLineMark Method

Draws marks for line.

virtual void DrawLineMark(
    CXTPSyntaxEditCtrl* pEditCtrl,
    XTP_EDIT_SENMBOOKMARK* pBookmark
);
Parameters

pEditCtrl
[in] A pointer to edit control.
pBookmark
[in] Pointer to structure with mark parameters.

See Also

LPXTP_EDIT_SENMBOOKMARK

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawLineMarks Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawLineMarks Method

Draws marks for line.

virtual void DrawLineMarks(
    CDC * pDC,
    const CRect& rcRect,
    int nTextRow,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

pDC
[in] Pointer to device context to draw to.
rcRect
[in] A rectangle to draw.
nTextRow
[in] The text row number for which to draw.
pEditCtrl
[in] A pointer to edit control.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawLineNode Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawLineNode Method

Draw the line Collapsible node icon

virtual void DrawLineNode(
    CDC * pDC,
    const CRect& rcNode,
    const CRect& rcNodeFull,
    DWORD dwType,
    int nTextRow,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

pDC
[in] Pointer to device context to draw to.
rcNode
[in] A rectangle to draw node.
rcNodeFull
[in] A full node area rectangle.
dwType
[in] Line Node type flags.
nTextRow
[in] The text row number for which to draw.
pEditCtrl
[in] A pointer to edit control.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawLineNodeBackground Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawLineNodeBackground Method

Fill the line node background.

virtual void DrawLineNodeBackground(
    CDC * pDC,
    const CRect& rcNodeFull,
    DWORD dwType,
    int nTextRow,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

pDC
[in] Pointer to device context to draw to.
rcNodeFull
[in] A full node area rectangle.
dwType
[in] Line Node type flags.
nTextRow
[in] The text row number for which to draw.
pEditCtrl
[in] A pointer to edit control.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawLineNumber Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawLineNumber Method

Draw the line numbers and returns the column position to start rest of the drawing.

virtual void DrawLineNumber(
    CDC * pDC,
    const CRect& rcRect,
    int nTextRow,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

pDC
[in] Pointer to device context to draw to.
rcRect
[in] A rectangle to draw.
nTextRow
[in] The text row number for which to draw.
pEditCtrl
[in] A pointer to edit control.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawLineNumbersBorder Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawLineNumbersBorder Method

Draw the line numbers border .

virtual void DrawLineNumbersBorder(
    CDC * pDC,
    const CRect& rcLineNum,
    const COLORREF clrBorder
);
Parameters

pDC
[in] Pointer to device context to print to
rcLineNum
[in] Line number rect
clrBorder
[in] Border color

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::DrawLineTextEx Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::DrawLineTextEx Method

Draws a single line.

virtual int DrawLineTextEx(
    CDC * pDC,
    const CRect& rcTextLine,
    int nTextRow,
    int nLine,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

pDC
[in] Pointer to device context to draw to.
rcTextLine
[in] A rectangle to draw.
nTextRow
[in] The text row number.
nLine
[in] The screen (page) line number.
pEditCtrl
[in] A pointer to edit control.

Returns

The height to draw row text.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetBackColor Method

Get background color.

COLORREF GetBackColor() const;
Returns

Background color.

See Also

SetBackColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetBackColor() const {
    return m_clrValues.crBack;
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetBackColorEx Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetBackColorEx Method

Get corresponding background color for edit mode or for read-only mode.

COLORREF GetBackColorEx(
    CXTPSyntaxEditCtrl* pEditCtrl
);
Returns

Background color.

See Also

SetBackColor, GetBackColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetBackColorEx(CXTPSyntaxEditCtrl* pEditCtrl) {
    return m_clrValues.GetBackColorEx(pEditCtrl);
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetBookmarks Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetBookmarks Method

Get Bookmarks image list.

virtual CImageList* GetBookmarks();
Returns

A pointer to CImageList.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetCurArrow Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetCurArrow Method

Get standard ARROW cursor.

HCURSOR GetCurArrow();
Returns

A HCURSOR handle to cursor.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetCurCopy Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetCurCopy Method

Get Cursor for copying text.

HCURSOR GetCurCopy();
Returns

A HCURSOR handle to cursor.

See Also

SetCopyCursor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetCurIBeam Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetCurIBeam Method

Get standard IBEAM cursor.

HCURSOR GetCurIBeam();
Returns

A HCURSOR handle to cursor.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetCurLine Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetCurLine Method

Get Cursor to show on line selection area.

HCURSOR GetCurLine();
Returns

A HCURSOR handle to cursor.

See Also

SetLineSelCursor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetCurMove Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetCurMove Method

Get Cursor for moving text.

HCURSOR GetCurMove();
Returns

A HCURSOR handle to cursor.

See Also

SetMoveCursor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetCurNO Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetCurNO Method

Get standard NO cursor.

HCURSOR GetCurNO();
Returns

A HCURSOR handle to cursor.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetFont Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetFont Method

Get common font.

CFont* GetFont();
Returns

A pointer to CFont object.

See Also

SetFont

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetFontLineNumber Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetFontLineNumber Method

Get line numbers font.

CFont* GetFontLineNumber();
Returns

A pointer to CFont object.

See Also

SetFontLineNumber

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetFontText Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetFontText Method

Get editor text font.

CFont* GetFontText();
Returns

A pointer to CFont object.

See Also

SetFontText

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetFontToolTip Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetFontToolTip Method

ToolTip font.

CFont* GetFontToolTip();
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetHiliteBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetHiliteBackColor Method

Get selected background color.

COLORREF GetHiliteBackColor() const;
Returns

Selected background color.

See Also

SetHiliteBackColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetHiliteBackColor() const {
    return m_clrValues.crHiliteBack;
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetHiliteTextColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetHiliteTextColor Method

Get selected text color.

COLORREF GetHiliteTextColor() const;
Returns

Selected text color.

See Also

SetHiliteTextColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetHiliteTextColor() const {
    return m_clrValues.crHiliteText;
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetInactiveHiliteBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetInactiveHiliteBackColor Method

Get selected background color when control has no focus.

COLORREF GetInactiveHiliteBackColor() const;
Returns

Selected background color when control has no focus.

See Also

SetInactiveHiliteBackColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetInactiveHiliteBackColor() const {
    return m_clrValues.crInactiveHiliteBack;
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetInactiveHiliteTextColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetInactiveHiliteTextColor Method

Get selected text color when control has no focus.

COLORREF GetInactiveHiliteTextColor() const;
Returns

Selected text color when control has no focus.

See Also

SetInactiveHiliteTextColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetInactiveHiliteTextColor() const {
    return m_clrValues.crInactiveHiliteText;
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetLineNumberBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetLineNumberBackColor Method

Get Line Numbers background color.

COLORREF GetLineNumberBackColor() const;
Returns

Line Numbers background color.

See Also

SetLineNumberBackColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetLineNumberBackColor() const {
    return m_clrValues.crLineNumberBack;
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetLineNumberTextColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetLineNumberTextColor Method

Get Line Numbers text color.

COLORREF GetLineNumberTextColor() const;
Returns

Line Numbers text color.

See Also

SetLineNumberTextColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetLineNumberTextColor() const {
    return m_clrValues.crLineNumberText;
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::GetTextColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::GetTextColor Method

Get text color.

COLORREF GetTextColor() const;
Returns

Text color.

See Also

SetTextColor

Body Source
COLORREF CXTPSyntaxEditPaintManager::GetTextColor() const {
    return m_clrValues.crText;
}
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::InitBitmaps Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::InitBitmaps Method

Initializes default paint manager bitmaps, should be called after creating control window.

virtual void InitBitmaps();
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::PrintLineTextEx Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::PrintLineTextEx Method

Print a row text.

virtual int PrintLineTextEx(
    CDC * pDC,
    const CRect& rcTextLine,
    int nTextRow,
    int nLine,
    CXTPSyntaxEditCtrl* pEditCtrl,
    int nFlags = 0
);
Parameters

pDC
[in] Pointer to device context to draw to.
rcTextLine
[in] A rectangle to draw.
nTextRow
[in] The text row number.
nLine
[in] The screen (page) line number.
pEditCtrl
[in] A pointer to edit control.
nFlags
[in] Additional printing options. The folowing are supported: DT_CALCRECT, DT_SINGLELINE, DT_WORDBREAK

Returns

The height to print row text.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::RefreshMetrics Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::RefreshMetrics Method

This method is called to refresh the visual metrics of manager.

virtual void RefreshMetrics();
Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetBackColor Method

Set background color.

BOOL SetBackColor(
    COLORREF crBack,
    BOOL bUpdateReg = FALSE
);
Parameters

crBack
A color value.
bUpdateReg
Set TRUE to save color in registry.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetBackColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetCopyCursor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetCopyCursor Method

Sets cursor shape for "copy" cursor.

HCURSOR SetCopyCursor(
    HCURSOR hCurCopy
);
Parameters

hCurCopy
[in] Handle to the cursor. The cursor must have been created by the CreateCursor function or loaded by the LoadCursor or LoadImage function.

Returns

Handle of previous cursor.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetFont Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetFont Method

Set common font.

BOOL SetFont(
    LPLOGFONT pLogfont
);
Parameters

pLogfont
A pointer to LPLOGFONT structure.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetFont

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetFontLineNumber Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetFontLineNumber Method

Set line numbers font.

BOOL SetFontLineNumber(
    LPLOGFONT pLogfont
);
Parameters

pLogfont
A pointer to LPLOGFONT structure.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetFontLineNumber

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetFontText Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetFontText Method

Set editor text font.

BOOL SetFontText(
    LPLOGFONT pLogfont
);
Parameters

pLogfont
A pointer to LPLOGFONT structure.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetFontText

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetFontToolTip Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetFontToolTip Method

Set ToolTip font.

BOOL SetFontToolTip(
    LPLOGFONT pLogfont
);
Parameters

pLogfont
A pointer to LPLOGFONT structure.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetFontToolTip

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetHiliteBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetHiliteBackColor Method

Set selected background color.

BOOL SetHiliteBackColor(
    COLORREF color,
    BOOL bUpdateReg = FALSE
);
Parameters

bUpdateReg
Set TRUE to save color in registry.
crText
A color value.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetHiliteBackColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetHiliteTextColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetHiliteTextColor Method

Set selected text color.

BOOL SetHiliteTextColor(
    COLORREF color,
    BOOL bUpdateReg = FALSE
);
Parameters

bUpdateReg
Set TRUE to save color in registry.
crText
A color value.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetHiliteTextColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetInactiveHiliteBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetInactiveHiliteBackColor Method

Set selected background color when control has no focus.

BOOL SetInactiveHiliteBackColor(
    COLORREF color,
    BOOL bUpdateReg = FALSE
);
Parameters

bUpdateReg
Set TRUE to save color in registry.
crText
A color value.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetInactiveHiliteBackColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetInactiveHiliteTextColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetInactiveHiliteTextColor Method

Set selected text color when control has no focus.

BOOL SetInactiveHiliteTextColor(
    COLORREF color,
    BOOL bUpdateReg = FALSE
);
Parameters

bUpdateReg
Set TRUE to save color in registry.
crText
A color value.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetInactiveHiliteTextColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetLineNumberBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetLineNumberBackColor Method

Set Line Numbers background color.

BOOL SetLineNumberBackColor(
    COLORREF color,
    BOOL bUpdateReg = FALSE
);
Parameters

bUpdateReg
Set TRUE to save color in registry.
crText
A color value.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetLineNumberBackColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetLineNumberTextColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetLineNumberTextColor Method

Set Line Numbers text color.

BOOL SetLineNumberTextColor(
    COLORREF color,
    BOOL bUpdateReg = FALSE
);
Parameters

bUpdateReg
Set TRUE to save color in registry.
crText
A color value.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetLineNumberTextColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetLineSelCursor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetLineSelCursor Method

Sets line selection cursor.

HCURSOR SetLineSelCursor(
    HCURSOR hCurLine
);
Parameters

hCurLine
[in] Handle to the cursor. The cursor must have been created by the CreateCursor function or loaded by the LoadCursor or LoadImage function.Cursor appears in lines selection area.

Returns

Handle of previous cursor.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetMoveCursor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetMoveCursor Method

Sets cursor shape for "move" cursor.

HCURSOR SetMoveCursor(
    HCURSOR hCurMove
);
Parameters

hCurMove
[in] Handle to the cursor. The cursor must have been created by the CreateCursor function or loaded by the LoadCursor or LoadImage function.

Returns

Handle of previous cursor.

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetReadOnlyBackColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetReadOnlyBackColor Method

Set background color for read-onlymode.

BOOL SetReadOnlyBackColor(
    COLORREF crBack,
    BOOL bUpdateReg = FALSE
);
Parameters

crBack
A color value.
bUpdateReg
Set TRUE to save color in registry.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetBackColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::SetTextColor Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::SetTextColor Method

Set text color.

BOOL SetTextColor(
    COLORREF crText,
    BOOL bUpdateReg = FALSE
);
Parameters

crText
A color value.
bUpdateReg
Set TRUE to save color in registry.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetTextColor

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager::UpdateTextFont Method

CXTPSyntaxEditPaintManager Methods, CXTPSyntaxEditPaintManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::UpdateTextFont Method

Update internal text font object (if need) and select it to DC.

virtual BOOL UpdateTextFont(
    CXTPSyntaxEditCtrl* pEditCtrl,
    const XTP_EDIT_FONTOPTIONS& lf
);
Parameters

pEditCtrl
[in] A pointer to edit control.
lf
[in] Reference to font options structure.

Returns

TRUE if the edit control font was updated, otherwise FALSE.

See Also

struct LOGFONT

Group

CXTPSyntaxEditPaintManager Methods


CXTPSyntaxEditPaintManager Constructors

CXTPSyntaxEditPaintManager Class, Legend, Public Methods
CXTPSyntaxEditPaintManager Constructors
Class

CXTPSyntaxEditPaintManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPaintManager | Default object constructor.


CXTPSyntaxEditPaintManager::CXTPSyntaxEditPaintManager Constructor

CXTPSyntaxEditPaintManager Constructors, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::CXTPSyntaxEditPaintManager Constructor

Default object constructor.

CXTPSyntaxEditPaintManager();
Group

CXTPSyntaxEditPaintManager Constructors


CXTPSyntaxEditPaintManager Destructors

CXTPSyntaxEditPaintManager Class, Legend, Public Methods
CXTPSyntaxEditPaintManager Destructors
Class

CXTPSyntaxEditPaintManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditPaintManager | Destroys a CXTPSyntaxEditPaintManager object, handles cleanup and deallocation.


CXTPSyntaxEditPaintManager::~CXTPSyntaxEditPaintManager Destructor

CXTPSyntaxEditPaintManager Destructors, CXTPSyntaxEditPaintManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPaintManager::~CXTPSyntaxEditPaintManager Destructor

Destroys a CXTPSyntaxEditPaintManager object, handles cleanup and deallocation.

virtual ~CXTPSyntaxEditPaintManager();
Group

CXTPSyntaxEditPaintManager Destructors


CXTPSyntaxEditPropertiesDlg Class

XTPSyntaxEditPropertiesDlg.h, Classes, Legend, Members, Topics, CXTPSyntaxEditPropertiesDlg Data Members, CXTPSyntaxEditPropertiesDlg Constructors, CXTPSyntaxEditPropertiesDlg Destructors, CXTPSyntaxEditPropertiesDlg Constructors, CXTPSyntaxEditPropertiesDlg Data Members, CXTPSyntaxEditPropertiesDlg Destructors
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesDlg Class

This class provide a default dialog to edit syntax edit control settings.

Class Hierarchy

class CXTPSyntaxEditPropertiesDlg : public CPropertySheet;
File

XTPSyntaxEditPropertiesDlg.h

Group

Classes

Legend
Data Member
protected
Constructor
virtual
CXTPSyntaxEditPropertiesDlg Constructors
CXTPSyntaxEditPropertiesDlg Constructors | Description
CXTPSyntaxEditPropertiesDlg | Default object constructor.
CXTPSyntaxEditPropertiesDlg Data Members
CXTPSyntaxEditPropertiesDlg Data Members | Description
m_Page1 | Property page for common edit options.
m_Page2 | Property page for font options.
m_Page3 | Property page for colors options.
CXTPSyntaxEditPropertiesDlg Destructors
CXTPSyntaxEditPropertiesDlg Destructors | Description
~CXTPSyntaxEditPropertiesDlg | Default object destructor.


CXTPSyntaxEditPropertiesDlg Data Members

CXTPSyntaxEditPropertiesDlg Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesDlg Data Members
Class

CXTPSyntaxEditPropertiesDlg Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_Page1 | Property page for common edit options.
m_Page2 | Property page for font options.
m_Page3 | Property page for colors options.


CXTPSyntaxEditPropertiesDlg::m_Page1 Data Member

CXTPSyntaxEditPropertiesDlg Data Members, CXTPSyntaxEditPropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesDlg::m_Page1 Data Member

Property page for common edit options.

CXTPSyntaxEditPropertiesPageEdit m_Page1;
Group

CXTPSyntaxEditPropertiesDlg Data Members


CXTPSyntaxEditPropertiesDlg::m_Page2 Data Member

CXTPSyntaxEditPropertiesDlg Data Members, CXTPSyntaxEditPropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesDlg::m_Page2 Data Member

Property page for font options.

CXTPSyntaxEditPropertiesPageFont m_Page2;
Group

CXTPSyntaxEditPropertiesDlg Data Members


CXTPSyntaxEditPropertiesDlg::m_Page3 Data Member

CXTPSyntaxEditPropertiesDlg Data Members, CXTPSyntaxEditPropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesDlg::m_Page3 Data Member

Property page for colors options.

CXTPSyntaxEditPropertiesPageColor m_Page3;
Group

CXTPSyntaxEditPropertiesDlg Data Members


CXTPSyntaxEditPropertiesDlg Constructors

CXTPSyntaxEditPropertiesDlg Class, Legend, Public Methods
CXTPSyntaxEditPropertiesDlg Constructors
Class

CXTPSyntaxEditPropertiesDlg Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPropertiesDlg | Default object constructor.


CXTPSyntaxEditPropertiesDlg::CXTPSyntaxEditPropertiesDlg Constructor

CXTPSyntaxEditPropertiesDlg Constructors, CXTPSyntaxEditPropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesDlg::CXTPSyntaxEditPropertiesDlg Constructor

Default object constructor.

CXTPSyntaxEditPropertiesDlg(
    CXTPSyntaxEditView* pEditView = NULL
);
Parameters

pEditView
Pointer to CXTPSyntaxEditView object.

Group

CXTPSyntaxEditPropertiesDlg Constructors


CXTPSyntaxEditPropertiesDlg Destructors

CXTPSyntaxEditPropertiesDlg Class, Legend, Public Methods
CXTPSyntaxEditPropertiesDlg Destructors
Class

CXTPSyntaxEditPropertiesDlg Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditPropertiesDlg | Default object destructor.


CXTPSyntaxEditPropertiesDlg::~CXTPSyntaxEditPropertiesDlg Destructor

CXTPSyntaxEditPropertiesDlg Destructors, CXTPSyntaxEditPropertiesDlg Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesDlg::~CXTPSyntaxEditPropertiesDlg Destructor

Default object destructor.

virtual ~CXTPSyntaxEditPropertiesDlg();
Group

CXTPSyntaxEditPropertiesDlg Destructors


CXTPSyntaxEditPropertiesPageColor Class

XTPSyntaxEditPropertiesPage.h, Classes, Legend, Members, Topics, CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Constructors, CXTPSyntaxEditPropertiesPageColor Destructors, CXTPSyntaxEditPropertiesPageColor Constructors, CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Destructors, CXTPSyntaxEditPropertiesPageColor Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor Class

This class implements a property page colors options.

Class Hierarchy

class CXTPSyntaxEditPropertiesPageColor : public CPropertyPage;
File

XTPSyntaxEditPropertiesPage.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditPropertiesPageColor Constructors
CXTPSyntaxEditPropertiesPageColor Constructors | Description
CXTPSyntaxEditPropertiesPageColor | Default object constructor.
CXTPSyntaxEditPropertiesPageColor Data Members
CXTPSyntaxEditPropertiesPageColor Data Members | Description
m_bModified | Store modified flag.
m_editFont | Store editor font.
m_mapLexClassInfo | Map lex schema name to schema classes array (CXTPSyntaxEditLexClassInfoArray*).
m_parLexClassInfo | Store currently selected schema classes.
m_pEditView | Store pointer to CXTPSyntaxEditView object.
m_pTextSchemesMgr | Store pointer to Schemes Manager.
m_ptrConfigMgr | Store pointer to Configuration Manager.
CXTPSyntaxEditPropertiesPageColor Destructors
CXTPSyntaxEditPropertiesPageColor Destructors | Description
~CXTPSyntaxEditPropertiesPageColor | Default object destructor.
CXTPSyntaxEditPropertiesPageColor Methods
CXTPSyntaxEditPropertiesPageColor Methods | Description
EnableControls | Update controls state (enabled/disabled).
GetDisplayName | Use this member function to retrieve a display name property value for a lex class.
GetPropValue | Use this member function to get lex property as a comma separated string.
InitClassData | Initialize dialog controls for specified lex class.
InitSchemaClasses | Initialize dialog controls for specified lex schema.
IsTopLevelClass | Determine is specified class a top level schema class.
PropExists | Use this member function to determine is specified properties data exists in the provided array.
SetDefaults | Set defaults controls state.
SetModified | Use this method to set or reset modified flag.
UpdateColorValue | Use this member function to update colors parameters for currently selected lex class.
UpdateFont | Use this member function to update font for a sample text control.
UpdateFontValue | Use this member function to update font parameters for currently selected lex class.
UpdateSampleColors | Use this member function to update font for a sample text control.
WriteRegistryValues | Use this method to save controls state (options) it the registry.


CXTPSyntaxEditPropertiesPageColor Data Members

CXTPSyntaxEditPropertiesPageColor Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor Data Members
Class

CXTPSyntaxEditPropertiesPageColor Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bModified | Store modified flag.
m_editFont | Store editor font.
m_mapLexClassInfo | Map lex schema name to schema classes array (CXTPSyntaxEditLexClassInfoArray*).
m_parLexClassInfo | Store currently selected schema classes.
m_pEditView | Store pointer to CXTPSyntaxEditView object.
m_pTextSchemesMgr | Store pointer to Schemes Manager.
m_ptrConfigMgr | Store pointer to Configuration Manager.


CXTPSyntaxEditPropertiesPageColor::m_bModified Data Member

CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::m_bModified Data Member

Store modified flag.

BOOL m_bModified;
Group

CXTPSyntaxEditPropertiesPageColor Data Members


CXTPSyntaxEditPropertiesPageColor::m_editFont Data Member

CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::m_editFont Data Member

Store editor font.

CFont m_editFont;
Group

CXTPSyntaxEditPropertiesPageColor Data Members


CXTPSyntaxEditPropertiesPageColor::m_mapLexClassInfo Data Member

CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::m_mapLexClassInfo Data Member

Map lex schema name to schema classes array (CXTPSyntaxEditLexClassInfoArray*).

CMapStringToPtr m_mapLexClassInfo;
Group

CXTPSyntaxEditPropertiesPageColor Data Members


CXTPSyntaxEditPropertiesPageColor::m_parLexClassInfo Data Member

CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::m_parLexClassInfo Data Member

Store currently selected schema classes.

CXTPSyntaxEditLexClassInfoArray* m_parLexClassInfo;
Group

CXTPSyntaxEditPropertiesPageColor Data Members


CXTPSyntaxEditPropertiesPageColor::m_pEditView Data Member

CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::m_pEditView Data Member

Store pointer to CXTPSyntaxEditView object.

CXTPSyntaxEditView* m_pEditView;
Group

CXTPSyntaxEditPropertiesPageColor Data Members


CXTPSyntaxEditPropertiesPageColor::m_pTextSchemesMgr Data Member

CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::m_pTextSchemesMgr Data Member

Store pointer to Schemes Manager.

CXTPSyntaxEditTextSchemesManager* m_pTextSchemesMgr;
Group

CXTPSyntaxEditPropertiesPageColor Data Members


CXTPSyntaxEditPropertiesPageColor::m_ptrConfigMgr Data Member

CXTPSyntaxEditPropertiesPageColor Data Members, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::m_ptrConfigMgr Data Member

Store pointer to Configuration Manager.

CXTPSyntaxEditConfigurationManagerPtr m_ptrConfigMgr;
Group

CXTPSyntaxEditPropertiesPageColor Data Members


CXTPSyntaxEditPropertiesPageColor Methods

CXTPSyntaxEditPropertiesPageColor Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor Methods
Class

CXTPSyntaxEditPropertiesPageColor Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
EnableControls | Update controls state (enabled/disabled).
GetDisplayName | Use this member function to retrieve a display name property value for a lex class.
GetPropValue | Use this member function to get lex property as a comma separated string.
InitClassData | Initialize dialog controls for specified lex class.
InitSchemaClasses | Initialize dialog controls for specified lex schema.
IsTopLevelClass | Determine is specified class a top level schema class.
PropExists | Use this member function to determine is specified properties data exists in the provided array.
SetDefaults | Set defaults controls state.
UpdateColorValue | Use this member function to update colors parameters for currently selected lex class.
UpdateFont | Use this member function to update font for a sample text control.
UpdateFontValue | Use this member function to update font parameters for currently selected lex class.
UpdateSampleColors | Use this member function to update font for a sample text control.
Public Methods
Public Methods
Public Method | Description
SetModified | Use this method to set or reset modified flag.
WriteRegistryValues | Use this method to save controls state (options) it the registry.


CXTPSyntaxEditPropertiesPageColor::EnableControls Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::EnableControls Method

Update controls state (enabled/disabled).

void EnableControls();
Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::GetDisplayName Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::GetDisplayName Method

Use this member function to retrieve a display name property value for a lex class.

CString GetDisplayName(
    const XTP_EDIT_LEXCLASSINFO& info
) const;
Parameters

info
A reference to XTP_EDIT_LEXCLASSINFO object.

Returns

Display name property value for a lex class.

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::GetPropValue Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::GetPropValue Method

Use this member function to get lex property as a comma separated string.

CString GetPropValue(
    const XTP_EDIT_LEXPROPINFO& infoProp
) const;
Parameters

infoProp
A reference to XTP_EDIT_LEXPROPINFO object.

Returns

A comma separated string.

See Also

XTP_EDIT_LEXPROPINFO

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::InitClassData Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::InitClassData Method

Initialize dialog controls for specified lex class.

void InitClassData(
    const XTP_EDIT_LEXCLASSINFO& infoClass
);
Parameters

infoClass
A reference to XTP_EDIT_LEXCLASSINFO object.

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::InitSchemaClasses Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::InitSchemaClasses Method

Initialize dialog controls for specified lex schema.

BOOL InitSchemaClasses(
    XTP_EDIT_SCHEMAFILEINFO* pSchemaInfo
);
Parameters

pSchemaInfo
A pointer to XTP_EDIT_SCHEMAFILEINFO object.

Returns

TRUE if successful, FALSE otherwise.

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::IsTopLevelClass Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::IsTopLevelClass Method

Determine is specified class a top level schema class.

BOOL IsTopLevelClass(
    const XTP_EDIT_LEXCLASSINFO& infoClass
);
Parameters

infoClass
A reference to XTP_EDIT_LEXCLASSINFO object.

Returns

TRUE if specified class is a top level schema class, FALSE otherwise.

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::PropExists Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::PropExists Method

Use this member function to determine is specified properties data exists in the provided array.

int PropExists(
    CXTPSyntaxEditLexPropInfoArray& arrProp,
    LPCTSTR lpszPropName
);
Parameters

arrProp
A properties data array.
lpszPropName
A lex property name.

Returns

Property data index in the array or -1

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::SetDefaults Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::SetDefaults Method

Set defaults controls state.

void SetDefaults();
Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::SetModified Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::SetModified Method

Use this method to set or reset modified flag.

void SetModified(
    BOOL bChanged = TRUE
);
Parameters

bChanged
TRUE if options where modified, FALSE otherwise.

See Also

CPropertyPage::SetModified

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::UpdateColorValue Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::UpdateColorValue Method

Use this member function to update colors parameters for currently selected lex class.

BOOL UpdateColorValue(
    CXTPSyntaxEditColorComboBox& combo,
    COLORREF& color,
    LPCTSTR lpszPropName
);
Parameters

combo
An edit color combo box.
color
A color value.
lpszPropName
A lex class property name (color attribute).

Returns

TRUE if successful, FALSE otherwise.

See Also

UpdateFontValue

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::UpdateFont Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::UpdateFont Method

Use this member function to update font for a sample text control.

void UpdateFont();
Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::UpdateFontValue Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::UpdateFontValue Method

Use this member function to update font parameters for currently selected lex class.

BOOL UpdateFontValue(
    BOOL& bValue,
    LPCTSTR lpszPropName
);
Parameters

bValue
A property value.
lpszPropName
A lex class property name (font attribute).

Returns

TRUE if successful, FALSE otherwise.

See Also

UpdateColorValue

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::UpdateSampleColors Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::UpdateSampleColors Method

Use this member function to update font for a sample text control.

void UpdateSampleColors();
Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor::WriteRegistryValues Method

CXTPSyntaxEditPropertiesPageColor Methods, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::WriteRegistryValues Method

Use this method to save controls state (options) it the registry.

BOOL WriteRegistryValues();
Returns

TRUE if successful, FALSE otherwise.

Group

CXTPSyntaxEditPropertiesPageColor Methods


CXTPSyntaxEditPropertiesPageColor Constructors

CXTPSyntaxEditPropertiesPageColor Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor Constructors
Class

CXTPSyntaxEditPropertiesPageColor Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPropertiesPageColor | Default object constructor.


CXTPSyntaxEditPropertiesPageColor::CXTPSyntaxEditPropertiesPageColor Constructor

CXTPSyntaxEditPropertiesPageColor Constructors, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::CXTPSyntaxEditPropertiesPageColor Constructor

Default object constructor.

CXTPSyntaxEditPropertiesPageColor(
    CXTPSyntaxEditView* pEditView = NULL
);
Parameters

pEditView
Pointer to CXTPSyntaxEditView object.

Group

CXTPSyntaxEditPropertiesPageColor Constructors


CXTPSyntaxEditPropertiesPageColor Destructors

CXTPSyntaxEditPropertiesPageColor Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor Destructors
Class

CXTPSyntaxEditPropertiesPageColor Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditPropertiesPageColor | Default object destructor.


CXTPSyntaxEditPropertiesPageColor::~CXTPSyntaxEditPropertiesPageColor Destructor

CXTPSyntaxEditPropertiesPageColor Destructors, CXTPSyntaxEditPropertiesPageColor Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageColor::~CXTPSyntaxEditPropertiesPageColor Destructor

Default object destructor.

virtual ~CXTPSyntaxEditPropertiesPageColor();
Group

CXTPSyntaxEditPropertiesPageColor Destructors


CXTPSyntaxEditPropertiesPageEdit Class

XTPSyntaxEditPropertiesPage.h, Classes, Legend, Members, Topics, CXTPSyntaxEditPropertiesPageEdit Data Members, CXTPSyntaxEditPropertiesPageEdit Methods, CXTPSyntaxEditPropertiesPageEdit Constructors, CXTPSyntaxEditPropertiesPageEdit Destructors, CXTPSyntaxEditPropertiesPageEdit Constructors, CXTPSyntaxEditPropertiesPageEdit Data Members, CXTPSyntaxEditPropertiesPageEdit Destructors, CXTPSyntaxEditPropertiesPageEdit Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit Class

This class implements a property page for common edit options.

Class Hierarchy

class CXTPSyntaxEditPropertiesPageEdit : public CPropertyPage;
File

XTPSyntaxEditPropertiesPage.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditPropertiesPageEdit Constructors
CXTPSyntaxEditPropertiesPageEdit Constructors | Description
CXTPSyntaxEditPropertiesPageEdit | Default object constructor.
CXTPSyntaxEditPropertiesPageEdit Data Members
CXTPSyntaxEditPropertiesPageEdit Data Members | Description
m_bModified | Store modified flag.
m_pEditView | Store pointer to CXTPSyntaxEditView object.
CXTPSyntaxEditPropertiesPageEdit Destructors
CXTPSyntaxEditPropertiesPageEdit Destructors | Description
~CXTPSyntaxEditPropertiesPageEdit | Default object destructor.
CXTPSyntaxEditPropertiesPageEdit Methods
CXTPSyntaxEditPropertiesPageEdit Methods | Description
ReadRegistryValues | Use this method to load controls state (options) from the registry.
SetModified | Use this method to set or reset modified flag.
WriteRegistryValues | Use this method to save controls state (options) it the registry.


CXTPSyntaxEditPropertiesPageEdit Data Members

CXTPSyntaxEditPropertiesPageEdit Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit Data Members
Class

CXTPSyntaxEditPropertiesPageEdit Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bModified | Store modified flag.
m_pEditView | Store pointer to CXTPSyntaxEditView object.


CXTPSyntaxEditPropertiesPageEdit::m_bModified Data Member

CXTPSyntaxEditPropertiesPageEdit Data Members, CXTPSyntaxEditPropertiesPageEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit::m_bModified Data Member

Store modified flag.

BOOL m_bModified;
Group

CXTPSyntaxEditPropertiesPageEdit Data Members


CXTPSyntaxEditPropertiesPageEdit::m_pEditView Data Member

CXTPSyntaxEditPropertiesPageEdit Data Members, CXTPSyntaxEditPropertiesPageEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit::m_pEditView Data Member

Store pointer to CXTPSyntaxEditView object.

CXTPSyntaxEditView* m_pEditView;
Group

CXTPSyntaxEditPropertiesPageEdit Data Members


CXTPSyntaxEditPropertiesPageEdit Methods

CXTPSyntaxEditPropertiesPageEdit Class, Legend, Protected Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit Methods
Class

CXTPSyntaxEditPropertiesPageEdit Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
ReadRegistryValues | Use this method to load controls state (options) from the registry.
SetModified | Use this method to set or reset modified flag.
WriteRegistryValues | Use this method to save controls state (options) it the registry.


CXTPSyntaxEditPropertiesPageEdit::ReadRegistryValues Method

CXTPSyntaxEditPropertiesPageEdit Methods, CXTPSyntaxEditPropertiesPageEdit Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit::ReadRegistryValues Method

Use this method to load controls state (options) from the registry.

BOOL ReadRegistryValues();
Returns

TRUE if successful, FALSE otherwise.

See Also

WriteRegistryValues

Group

CXTPSyntaxEditPropertiesPageEdit Methods


CXTPSyntaxEditPropertiesPageEdit::SetModified Method

CXTPSyntaxEditPropertiesPageEdit Methods, CXTPSyntaxEditPropertiesPageEdit Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit::SetModified Method

Use this method to set or reset modified flag.

void SetModified(
    BOOL bChanged = TRUE
);
Parameters

bChanged
TRUE if options where modified, FALSE otherwise.

See Also

CPropertyPage::SetModified

Group

CXTPSyntaxEditPropertiesPageEdit Methods


CXTPSyntaxEditPropertiesPageEdit::WriteRegistryValues Method

CXTPSyntaxEditPropertiesPageEdit Methods, CXTPSyntaxEditPropertiesPageEdit Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit::WriteRegistryValues Method

Use this method to save controls state (options) it the registry.

BOOL WriteRegistryValues();
Returns

TRUE if successful, FALSE otherwise.

See Also

ReadRegistryValues

Group

CXTPSyntaxEditPropertiesPageEdit Methods


CXTPSyntaxEditPropertiesPageEdit Constructors

CXTPSyntaxEditPropertiesPageEdit Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit Constructors
Class

CXTPSyntaxEditPropertiesPageEdit Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPropertiesPageEdit | Default object constructor.


CXTPSyntaxEditPropertiesPageEdit::CXTPSyntaxEditPropertiesPageEdit Constructor

CXTPSyntaxEditPropertiesPageEdit Constructors, CXTPSyntaxEditPropertiesPageEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit::CXTPSyntaxEditPropertiesPageEdit Constructor

Default object constructor.

CXTPSyntaxEditPropertiesPageEdit(
    CXTPSyntaxEditView* pEditView = NULL
);
Parameters

pEditView
Pointer to CXTPSyntaxEditView object.

Group

CXTPSyntaxEditPropertiesPageEdit Constructors


CXTPSyntaxEditPropertiesPageEdit Destructors

CXTPSyntaxEditPropertiesPageEdit Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit Destructors
Class

CXTPSyntaxEditPropertiesPageEdit Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditPropertiesPageEdit | Default object destructor.


CXTPSyntaxEditPropertiesPageEdit::~CXTPSyntaxEditPropertiesPageEdit Destructor

CXTPSyntaxEditPropertiesPageEdit Destructors, CXTPSyntaxEditPropertiesPageEdit Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageEdit::~CXTPSyntaxEditPropertiesPageEdit Destructor

Default object destructor.

virtual ~CXTPSyntaxEditPropertiesPageEdit();
Group

CXTPSyntaxEditPropertiesPageEdit Destructors


CXTPSyntaxEditPropertiesPageFont Class

XTPSyntaxEditPropertiesPage.h, Classes, Legend, Members, Topics, CXTPSyntaxEditPropertiesPageFont Data Members, CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Constructors, CXTPSyntaxEditPropertiesPageFont Destructors, CXTPSyntaxEditPropertiesPageFont Constructors, CXTPSyntaxEditPropertiesPageFont Data Members, CXTPSyntaxEditPropertiesPageFont Destructors, CXTPSyntaxEditPropertiesPageFont Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont Class

This class implements a property page font options.

Class Hierarchy

class CXTPSyntaxEditPropertiesPageFont : public CPropertyPage;
File

XTPSyntaxEditPropertiesPage.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditPropertiesPageFont Constructors
CXTPSyntaxEditPropertiesPageFont Constructors | Description
CXTPSyntaxEditPropertiesPageFont | Default object constructor.
CXTPSyntaxEditPropertiesPageFont Data Members
CXTPSyntaxEditPropertiesPageFont Data Members | Description
m_bModified | Store modified flag.
m_editFont | Store editor font.
m_iCharSet | Store char set.
m_pEditView | Store pointer to CXTPSyntaxEditView object.
m_uFaceSize | Store face name maximum string size.
CXTPSyntaxEditPropertiesPageFont Destructors
CXTPSyntaxEditPropertiesPageFont Destructors | Description
~CXTPSyntaxEditPropertiesPageFont | Default object destructor.
CXTPSyntaxEditPropertiesPageFont Methods
CXTPSyntaxEditPropertiesPageFont Methods | Description
CreateSafeFontIndirect | Use this method to change font in specified CFont object. The previous font deleted.
GetEditFont | Use this member function to get editor font.
GetLBText | Use this helper function to get currently selected list box item text and update combo box.
GetPaintManager | Use this function to get edit control paint manager.
GetSafeLogFont | Use this member function to get editor font.
InitColorComboxes | Initialize color combo box.
InitFontCombo | Initialize font name combo box.
InitScriptCombo | Initialize font script combo box.
InitSizeCombo | Initialize font size combo box.
InitStyleCombo | Initialize font style combo box.
ReadRegistryValues | Use this method to load controls state (options) from the registry.
SetModified | Use this method to set or reset modified flag.
UpdateSampleColors | Use this member function to update colors for a sample text control.
UpdateSampleFont | Use this member function to update font for a sample text control.
WriteRegistryValues | Use this method to save controls state (options) it the registry.


CXTPSyntaxEditPropertiesPageFont Data Members

CXTPSyntaxEditPropertiesPageFont Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont Data Members
Class

CXTPSyntaxEditPropertiesPageFont Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bModified | Store modified flag.
m_editFont | Store editor font.
m_iCharSet | Store char set.
m_pEditView | Store pointer to CXTPSyntaxEditView object.
m_uFaceSize | Store face name maximum string size.


CXTPSyntaxEditPropertiesPageFont::m_bModified Data Member

CXTPSyntaxEditPropertiesPageFont Data Members, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::m_bModified Data Member

Store modified flag.

BOOL m_bModified;
Group

CXTPSyntaxEditPropertiesPageFont Data Members


CXTPSyntaxEditPropertiesPageFont::m_editFont Data Member

CXTPSyntaxEditPropertiesPageFont Data Members, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::m_editFont Data Member

Store editor font.

CFont m_editFont;
Group

CXTPSyntaxEditPropertiesPageFont Data Members


CXTPSyntaxEditPropertiesPageFont::m_iCharSet Data Member

CXTPSyntaxEditPropertiesPageFont Data Members, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::m_iCharSet Data Member

Store char set.

BYTE m_iCharSet;
Group

CXTPSyntaxEditPropertiesPageFont Data Members


CXTPSyntaxEditPropertiesPageFont::m_pEditView Data Member

CXTPSyntaxEditPropertiesPageFont Data Members, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::m_pEditView Data Member

Store pointer to CXTPSyntaxEditView object.

CXTPSyntaxEditView* m_pEditView;
Group

CXTPSyntaxEditPropertiesPageFont Data Members


CXTPSyntaxEditPropertiesPageFont::m_uFaceSize Data Member

CXTPSyntaxEditPropertiesPageFont Data Members, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::m_uFaceSize Data Member

Store face name maximum string size.

const UINT m_uFaceSize;
Group

CXTPSyntaxEditPropertiesPageFont Data Members


CXTPSyntaxEditPropertiesPageFont Methods

CXTPSyntaxEditPropertiesPageFont Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont Methods
Class

CXTPSyntaxEditPropertiesPageFont Class

Legend
Method
protected
Protected Methods
Protected Methods
Protected Method | Description
GetLBText | Use this helper function to get currently selected list box item text and update combo box.
GetPaintManager | Use this function to get edit control paint manager.
InitColorComboxes | Initialize color combo box.
InitFontCombo | Initialize font name combo box.
InitScriptCombo | Initialize font script combo box.
InitSizeCombo | Initialize font size combo box.
InitStyleCombo | Initialize font style combo box.
ReadRegistryValues | Use this method to load controls state (options) from the registry.
SetModified | Use this method to set or reset modified flag.
UpdateSampleColors | Use this member function to update colors for a sample text control.
UpdateSampleFont | Use this member function to update font for a sample text control.
WriteRegistryValues | Use this method to save controls state (options) it the registry.
Public Methods
Public Methods
Public Method | Description
CreateSafeFontIndirect | Use this method to change font in specified CFont object. The previous font deleted.
GetEditFont | Use this member function to get editor font.
GetSafeLogFont | Use this member function to get editor font.


CXTPSyntaxEditPropertiesPageFont::CreateSafeFontIndirect Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::CreateSafeFontIndirect Method

Use this method to change font in specified CFont object. The previous font deleted.

BOOL CreateSafeFontIndirect(
    CFont& editFont,
    const LOGFONT& lf
);
Parameters

editFont
A reference to CFont object to set new font.
lf
A new font parameters.

Returns

TRUE if successful, FALSE otherwise.

See Also

CFont::CreateFontIndirect

Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::GetEditFont Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::GetEditFont Method

Use this member function to get editor font.

CFont& GetEditFont();
Returns

A reference to CFont object.

See Also

GetSafeLogFont

Body Source
CFont& CXTPSyntaxEditPropertiesPageFont::GetEditFont() {
    return m_editFont;
}
Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::GetLBText Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::GetLBText Method

Use this helper function to get currently selected list box item text and update combo box.

int GetLBText(
    CComboBox& comboBox,
    CString& csItemText
);
Parameters

comboBox
[in] A references to combobox object.
csItemText
[out] A references to CString to store text.

Returns

Selected item index or CB_ERR.

See Also

CComboBox::GetLBText

Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::GetPaintManager Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::GetPaintManager Method

Use this function to get edit control paint manager.

CXTPSyntaxEditPaintManager* GetPaintManager();
Returns

Pointer to CXTPSyntaxEditPaintManager object.

Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::GetSafeLogFont Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::GetSafeLogFont Method

Use this member function to get editor font.

BOOL GetSafeLogFont(
    LOGFONT& lf
);
Parameters

lf
A reference to LOGFONT structure.

Returns

TRUE if successful, FALSE otherwise.

See Also

GetEditFont

Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::InitColorComboxes Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::InitColorComboxes Method

Initialize color combo box.

void InitColorComboxes();
Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::InitFontCombo Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::InitFontCombo Method

Initialize font name combo box.

void InitFontCombo();
Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::InitScriptCombo Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::InitScriptCombo Method

Initialize font script combo box.

void InitScriptCombo();
Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::InitSizeCombo Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::InitSizeCombo Method

Initialize font size combo box.

void InitSizeCombo();
Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::InitStyleCombo Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::InitStyleCombo Method

Initialize font style combo box.

void InitStyleCombo();
Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::ReadRegistryValues Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::ReadRegistryValues Method

Use this method to load controls state (options) from the registry.

BOOL ReadRegistryValues();
Returns

TRUE if successful, FALSE otherwise.

See Also

WriteRegistryValues

Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::SetModified Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::SetModified Method

Use this method to set or reset modified flag.

void SetModified(
    BOOL bChanged = TRUE
);
Parameters

bChanged
TRUE if options where modified, FALSE otherwise.

See Also

CPropertyPage::SetModified

Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::UpdateSampleColors Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::UpdateSampleColors Method

Use this member function to update colors for a sample text control.

void UpdateSampleColors();
Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::UpdateSampleFont Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::UpdateSampleFont Method

Use this member function to update font for a sample text control.

void UpdateSampleFont();
Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont::WriteRegistryValues Method

CXTPSyntaxEditPropertiesPageFont Methods, CXTPSyntaxEditPropertiesPageFont Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::WriteRegistryValues Method

Use this method to save controls state (options) it the registry.

BOOL WriteRegistryValues();
Returns

TRUE if successful, FALSE otherwise.

See Also

ReadRegistryValues

Group

CXTPSyntaxEditPropertiesPageFont Methods


CXTPSyntaxEditPropertiesPageFont Constructors

CXTPSyntaxEditPropertiesPageFont Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont Constructors
Class

CXTPSyntaxEditPropertiesPageFont Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPropertiesPageFont | Default object constructor.


CXTPSyntaxEditPropertiesPageFont::CXTPSyntaxEditPropertiesPageFont Constructor

CXTPSyntaxEditPropertiesPageFont Constructors, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::CXTPSyntaxEditPropertiesPageFont Constructor

Default object constructor.

CXTPSyntaxEditPropertiesPageFont(
    CXTPSyntaxEditView* pEditView = NULL
);
Parameters

pEditView
Pointer to CXTPSyntaxEditView object.

Group

CXTPSyntaxEditPropertiesPageFont Constructors


CXTPSyntaxEditPropertiesPageFont Destructors

CXTPSyntaxEditPropertiesPageFont Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont Destructors
Class

CXTPSyntaxEditPropertiesPageFont Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditPropertiesPageFont | Default object destructor.


CXTPSyntaxEditPropertiesPageFont::~CXTPSyntaxEditPropertiesPageFont Destructor

CXTPSyntaxEditPropertiesPageFont Destructors, CXTPSyntaxEditPropertiesPageFont Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditPropertiesPageFont::~CXTPSyntaxEditPropertiesPageFont Destructor

Default object destructor.

virtual ~CXTPSyntaxEditPropertiesPageFont();
Group

CXTPSyntaxEditPropertiesPageFont Destructors


CXTPSyntaxEditReplaceStringCommand Class

XTPSyntaxEditUndoManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditReplaceStringCommand Data Members, CXTPSyntaxEditReplaceStringCommand Methods, CXTPSyntaxEditReplaceStringCommand Constructors, CXTPSyntaxEditReplaceStringCommand Destructors, CXTPSyntaxEditReplaceStringCommand Constructors, CXTPSyntaxEditReplaceStringCommand Data Members, CXTPSyntaxEditReplaceStringCommand Destructors, CXTPSyntaxEditReplaceStringCommand Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand Class

This class represents text replacing command. Command execution will replace text from the buffer between specified text positions, un-execution will do contrary replacement.

Class Hierarchy

class CXTPSyntaxEditReplaceStringCommand : public CXTPSyntaxEditBufferCommand;
File

XTPSyntaxEditUndoManager.h

See Also

CXTPSyntaxEditBufferCommand

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditReplaceStringCommand Constructors
CXTPSyntaxEditReplaceStringCommand Constructors | Description
CXTPSyntaxEditReplaceStringCommand | Creates the replace string command object, initializes its members.
CXTPSyntaxEditReplaceStringCommand Data Members
CXTPSyntaxEditReplaceStringCommand Data Members | Description
m_strReplacedText | Buffer which holds replaced text.
CXTPSyntaxEditReplaceStringCommand Destructors
CXTPSyntaxEditReplaceStringCommand Destructors | Description
~CXTPSyntaxEditReplaceStringCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.
CXTPSyntaxEditReplaceStringCommand Methods
CXTPSyntaxEditReplaceStringCommand Methods | Description
DoReplaceText | Performs text replacement operation.
Execute | Executes delete string command.
GetDataSize | This member function used to get undo command data size (in bytes).
UnExecute | Unexecutes delete string command (i.e. inserts the string).


CXTPSyntaxEditReplaceStringCommand Data Members

CXTPSyntaxEditReplaceStringCommand Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand Data Members
Class

CXTPSyntaxEditReplaceStringCommand Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_strReplacedText | Buffer which holds replaced text.


CXTPSyntaxEditReplaceStringCommand::m_strReplacedText Data Member

CXTPSyntaxEditReplaceStringCommand Data Members, CXTPSyntaxEditReplaceStringCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand::m_strReplacedText Data Member

Buffer which holds replaced text.

CString m_strReplacedText;
Group

CXTPSyntaxEditReplaceStringCommand Data Members


CXTPSyntaxEditReplaceStringCommand Methods

CXTPSyntaxEditReplaceStringCommand Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand Methods
Class

CXTPSyntaxEditReplaceStringCommand Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
DoReplaceText | Performs text replacement operation.
Public Methods
Public Methods
Public Method | Description
Execute | Executes delete string command.
GetDataSize | This member function used to get undo command data size (in bytes).
UnExecute | Unexecutes delete string command (i.e. inserts the string).


CXTPSyntaxEditReplaceStringCommand::DoReplaceText Method

CXTPSyntaxEditReplaceStringCommand Methods, CXTPSyntaxEditReplaceStringCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand::DoReplaceText Method

Performs text replacement operation.

int DoReplaceText(
    LPCTSTR szText,
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

szText
[in] A text to replace to.
lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_INSERTROW

Group

CXTPSyntaxEditReplaceStringCommand Methods


CXTPSyntaxEditReplaceStringCommand::Execute Method

CXTPSyntaxEditReplaceStringCommand Methods, CXTPSyntaxEditReplaceStringCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand::Execute Method

Executes delete string command.

virtual int Execute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW

See Also

UnExecute

Group

CXTPSyntaxEditReplaceStringCommand Methods


CXTPSyntaxEditReplaceStringCommand::GetDataSize Method

CXTPSyntaxEditReplaceStringCommand Methods, CXTPSyntaxEditReplaceStringCommand Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand::GetDataSize Method

This member function used to get undo command data size (in bytes).

virtual int GetDataSize();
Returns

Undo command data size (in bytes).

Body Source
int CXTPSyntaxEditReplaceStringCommand::GetDataSize() {
    return m_strReplacedText.GetLength() * sizeof(TCHAR) +
           CXTPSyntaxEditBufferCommand::GetDataSize();
}
Group

CXTPSyntaxEditReplaceStringCommand Methods


CXTPSyntaxEditReplaceStringCommand::UnExecute Method

CXTPSyntaxEditReplaceStringCommand Methods, CXTPSyntaxEditReplaceStringCommand Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand::UnExecute Method

Unexecutes delete string command (i.e. inserts the string).

virtual int UnExecute(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the happened edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

Execute

Group

CXTPSyntaxEditReplaceStringCommand Methods


CXTPSyntaxEditReplaceStringCommand Constructors

CXTPSyntaxEditReplaceStringCommand Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand Constructors
Class

CXTPSyntaxEditReplaceStringCommand Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditReplaceStringCommand | Creates the replace string command object, initializes its members.


CXTPSyntaxEditReplaceStringCommand::CXTPSyntaxEditReplaceStringCommand Constructor

CXTPSyntaxEditReplaceStringCommand Constructors, CXTPSyntaxEditReplaceStringCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand::CXTPSyntaxEditReplaceStringCommand Constructor

Creates the replace string command object, initializes its members.

CXTPSyntaxEditReplaceStringCommand(
    CXTPSyntaxEditBufferManager* pMgr,
    LPCTSTR szText,
    LPCTSTR szReplacedText,
    const XTP_EDIT_LINECOL& lcFrom,
    const XTP_EDIT_LINECOL& lcTo
);
Parameters

pMgr
[in] Pointer to the associated buffer manager object.
szText
[in] A text which was insert during buffer operation.
szReplacedText
[in] A text which was changed during buffer operation.
lcFrom
[in] Start text position affected by the command.
lcTo
[in] End text position affected by the command.

Group

CXTPSyntaxEditReplaceStringCommand Constructors


CXTPSyntaxEditReplaceStringCommand Destructors

CXTPSyntaxEditReplaceStringCommand Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand Destructors
Class

CXTPSyntaxEditReplaceStringCommand Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditReplaceStringCommand | A default command destructor. Destroys the command object, handles its cleanup and de-allocation.


CXTPSyntaxEditReplaceStringCommand::~CXTPSyntaxEditReplaceStringCommand Destructor

CXTPSyntaxEditReplaceStringCommand Destructors, CXTPSyntaxEditReplaceStringCommand Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditReplaceStringCommand::~CXTPSyntaxEditReplaceStringCommand Destructor

A default command destructor. Destroys the command object, handles its cleanup and de-allocation.

virtual ~CXTPSyntaxEditReplaceStringCommand();
Group

CXTPSyntaxEditReplaceStringCommand Destructors


CXTPSyntaxEditTextIterator Class

XTPSyntaxEditTextIterator.h, Classes, Legend, Members, Topics, CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Constructors, CXTPSyntaxEditTextIterator Destructors, CXTPSyntaxEditTextIterator Constructors, CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Destructors, CXTPSyntaxEditTextIterator Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator Class

This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, determine control symbols like CRLF. When you create instance of CXTPSyntaxEditTextIterator class you should provide pointer to data storage, represented by CXTPSyntaxEditTextIterator class.

Class Hierarchy

class CXTPSyntaxEditTextIterator;
File

XTPSyntaxEditTextIterator.h

See Also

CXTPSyntaxEditBufferManager.

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditTextIterator Constructors
CXTPSyntaxEditTextIterator Constructors | Description
CXTPSyntaxEditTextIterator | Default object constructor.
CXTPSyntaxEditTextIterator Data Members
CXTPSyntaxEditTextIterator Data Members | Description
m_arBuffer | buffer of chars
m_bEOF | flag end of file.
m_LCpos | current position in the text.
m_mapLine2Len | store map of line - length of line
m_nBufOffsetB | offset
m_nBufOffsetB_max | offset
m_nBufOffsetB_normal | offset
m_nBufSizeB | buffer length
m_nNextLine | next line id
m_nTmpOffsetB | offset
m_nTmpOffsetC | offset
m_pData | Pointer to used CXTPSyntaxEditBufferManager object
CXTPSyntaxEditTextIterator Destructors
CXTPSyntaxEditTextIterator Destructors | Description
~CXTPSyntaxEditTextIterator | Destroys a CXTPSyntaxEditTextIterator object, handles cleanup and de-allocation.
CXTPSyntaxEditTextIterator Methods
CXTPSyntaxEditTextIterator Methods | Description
GetBuffer | Get maximum buffer size for back text offset.
GetEOL | rn", "nr", "r
GetFileExt | Returns file name.
GetLineLen | Returns length of specified line.
GetLineLenBytes | Returns length of specified line in bytes.
GetMaxBackOffset | Get maximum buffer size for back text offset.
GetPosLC | Returns current position as XTP_EDIT_LINECOL structure.
GetPosLC_last | Returns last text position as XTP_EDIT_LINECOL structure.
GetText | don't remove line end chars
IsEOF | Determines if end of data is reached.
LCPosAdd | Increment of position.
LCPosDec | Decrement of position.
SeekBegin | Repositions the "current position pointer" in the internal data buffer to the begin.
SeekNext | Moves current position and return pointer to the text begin.
SeekPos | Repositions the "current position pointer" in the internal data buffer to the specified position.
SeekPrev | Moves current position back for 1 character, and return pointer to the text begin.
SetTxtOffset | Sets new offset value.


CXTPSyntaxEditTextIterator Data Members

CXTPSyntaxEditTextIterator Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator Data Members
Class

CXTPSyntaxEditTextIterator Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_arBuffer | buffer of chars
m_bEOF | flag end of file.
m_LCpos | current position in the text.
m_mapLine2Len | store map of line - length of line
m_nBufOffsetB | offset
m_nBufOffsetB_max | offset
m_nBufOffsetB_normal | offset
m_nBufSizeB | buffer length
m_nNextLine | next line id
m_nTmpOffsetB | offset
m_nTmpOffsetC | offset
m_pData | Pointer to used CXTPSyntaxEditBufferManager object


CXTPSyntaxEditTextIterator::m_arBuffer Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_arBuffer Data Member

buffer of chars

CArray<CHAR, CHAR> m_arBuffer;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_bEOF Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_bEOF Data Member

flag end of file.

BOOL m_bEOF;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_LCpos Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_LCpos Data Member

current position in the text.

XTP_EDIT_LINECOL m_LCpos;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_mapLine2Len Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_mapLine2Len Data Member

store map of line - length of line

CMap<DWORD, DWORD, int, int> m_mapLine2Len;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_nBufOffsetB Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_nBufOffsetB Data Member

offset

int m_nBufOffsetB;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_nBufOffsetB_max Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_nBufOffsetB_max Data Member

offset

int m_nBufOffsetB_max;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_nBufOffsetB_normal Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_nBufOffsetB_normal Data Member

offset

int m_nBufOffsetB_normal;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_nBufSizeB Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_nBufSizeB Data Member

buffer length

int m_nBufSizeB;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_nNextLine Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_nNextLine Data Member

next line id

int m_nNextLine;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_nTmpOffsetB Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_nTmpOffsetB Data Member

offset

int m_nTmpOffsetB;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_nTmpOffsetC Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_nTmpOffsetC Data Member

offset

int m_nTmpOffsetC;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator::m_pData Data Member

CXTPSyntaxEditTextIterator Data Members, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::m_pData Data Member

Pointer to used CXTPSyntaxEditBufferManager object

CXTPSyntaxEditBufferManager* m_pData;
Group

CXTPSyntaxEditTextIterator Data Members


CXTPSyntaxEditTextIterator Methods

CXTPSyntaxEditTextIterator Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator Methods
Class

CXTPSyntaxEditTextIterator Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
GetBuffer | Get maximum buffer size for back text offset.
Public Methods
Public Methods
Public Method | Description
GetEOL | rn", "nr", "r
GetFileExt | Returns file name.
GetLineLen | Returns length of specified line.
GetLineLenBytes | Returns length of specified line in bytes.
GetMaxBackOffset | Get maximum buffer size for back text offset.
GetPosLC | Returns current position as XTP_EDIT_LINECOL structure.
GetPosLC_last | Returns last text position as XTP_EDIT_LINECOL structure.
GetText | don't remove line end chars
IsEOF | Determines if end of data is reached.
LCPosAdd | Increment of position.
LCPosDec | Decrement of position.
SeekBegin | Repositions the "current position pointer" in the internal data buffer to the begin.
SeekNext | Moves current position and return pointer to the text begin.
SeekPos | Repositions the "current position pointer" in the internal data buffer to the specified position.
SeekPrev | Moves current position back for 1 character, and return pointer to the text begin.
SetTxtOffset | Sets new offset value.


CXTPSyntaxEditTextIterator::GetBuffer Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetBuffer Method

Get maximum buffer size for back text offset.

TCHAR* GetBuffer(
    int nOffcetB
);
Parameters

nOffcetB
[in] offest in bytes.

Returns

Pointer to TCHAR buffer.

Body Source
TCHAR* CXTPSyntaxEditTextIterator::GetBuffer(int nOffcetB) {
    return (TCHAR*)((CHAR*)m_arBuffer.GetData() + nOffcetB);
}
Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::GetEOL Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetEOL Method

rn", "nr", "r

virtual CString GetEOL();
Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::GetFileExt Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetFileExt Method

Returns file name.

virtual CString GetFileExt();
Returns

CString object containing file name.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::GetLineLen Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetLineLen Method

Returns length of specified line.

virtual int GetLineLen(
    int nLine,
    BOOL bWithEOL = FALSE
);
Parameters

nLine
[in] numeric line identifier.
bWithEOL
[in] boolean flag determines if end of line symbols are taken into account.

Returns

Length of specified line.

Remarks

Call this member function to determine length of line. You can request to ignore end of line characters.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::GetLineLenBytes Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetLineLenBytes Method

Returns length of specified line in bytes.

virtual int GetLineLenBytes(
    int nLine,
    BOOL bWithEOL
);
Parameters

nLine
[in] numeric line identifier.
bWithEOL
[in] boolean flag determines if end of line symbols are taken into account.

Returns

Length of specified line.

Remarks

Call this member function to determine length of line. You can request to ignore end of line characters.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::GetMaxBackOffset Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetMaxBackOffset Method

Get maximum buffer size for back text offset.

virtual int GetMaxBackOffset() const;
Returns

Back buffer size (chars).

See Also

SetTxtOffset()

Body Source
int CXTPSyntaxEditTextIterator::GetMaxBackOffset() const {
    return m_nBufOffsetB_normal;
}
Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::GetPosLC Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetPosLC Method

Returns current position as XTP_EDIT_LINECOL structure.

virtual XTP_EDIT_LINECOL GetPosLC();
Returns

XTP_EDIT_LINECOL structure with current position.

See Also

XTP_EDIT_LINECOL .

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::GetPosLC_last Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetPosLC_last Method

Returns last text position as XTP_EDIT_LINECOL structure.

virtual XTP_EDIT_LINECOL GetPosLC_last(
    BOOL bWithEOL
);
Returns

XTP_EDIT_LINECOL structure with current position.

See Also

XTP_EDIT_LINECOL .

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::GetText Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::GetText Method

don't remove line end chars

virtual LPCTSTR GetText(
    int nCharsBuf = 512
);
Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::IsEOF Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::IsEOF Method

Determines if end of data is reached.

virtual BOOL IsEOF();
Returns

Nonzero if the data buffer contains no records or if you have scrolled beyond the last position; otherwise 0

Remarks

Call this member function to determine if end of data is reached. You can also use IsEOF to determine whether the data buffer contains any data or is empty.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::LCPosAdd Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::LCPosAdd Method

Increment of position.

virtual void LCPosAdd(
    XTP_EDIT_LINECOL& rLC,
    int nCharsAdd
);
Parameters

rLC
[in] reference to position description structure.
nCharsAdd
[in] Chars count to add.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::LCPosDec Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::LCPosDec Method

Decrement of position.

virtual void LCPosDec(
    XTP_EDIT_LINECOL& rLC
);
Parameters

rLC
[in] reference to position description structure.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::SeekBegin Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::SeekBegin Method

Repositions the "current position pointer" in the internal data buffer to the begin.

virtual void SeekBegin();
Remarks

Call this member function to set the "current position pointer" in the internal data buffer to the begin. Besides it resets all others internal text counters.

See Also

SeekPos()

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::SeekNext Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::SeekNext Method

Moves current position and return pointer to the text begin.

virtual LPCTSTR SeekNext(
    DWORD dwChars = 1,
    int nCharsBuf = 512
);
Parameters

dwChars
[in] counts to move.
nCharsBuf
[in] length of the text in bytes to be returned.

Returns

Pointer to the character string.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::SeekPos Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::SeekPos Method

Repositions the "current position pointer" in the internal data buffer to the specified position.

virtual BOOL SeekPos(
    const XTP_EDIT_LINECOL& posLC,
    HANDLE hBreakEvent = NULL
);
Parameters

posLC
[in] Position in the text to set as current.
hBreakEvent
[in] Handle to the break event to stop function execution.

Returns

TRUE if successful< otherwise FALSE.

Remarks

Call this member function to set the "current position pointer" in the internal data buffer to the specified position. For big texts this operation may take a lot of time. hBreakEvent is used to to stop function execution without reaching the specified position.

See Also

SeekBegin()

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::SeekPrev Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::SeekPrev Method

Moves current position back for 1 character, and return pointer to the text begin.

virtual LPCTSTR SeekPrev();
Returns

Pointer to the character string or NULL if text begin is reached.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator::SetTxtOffset Method

CXTPSyntaxEditTextIterator Methods, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::SetTxtOffset Method

Sets new offset value.

virtual void SetTxtOffset(
    int nOffsetChars
);
Parameters

nOffsetChars
[in] new offset value.

Group

CXTPSyntaxEditTextIterator Methods


CXTPSyntaxEditTextIterator Constructors

CXTPSyntaxEditTextIterator Class, Legend, Public Methods
CXTPSyntaxEditTextIterator Constructors
Class

CXTPSyntaxEditTextIterator Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditTextIterator | Default object constructor.


CXTPSyntaxEditTextIterator::CXTPSyntaxEditTextIterator Constructor

CXTPSyntaxEditTextIterator Constructors, CXTPSyntaxEditTextIterator Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::CXTPSyntaxEditTextIterator Constructor

Default object constructor.

CXTPSyntaxEditTextIterator(
    CXTPSyntaxEditBufferManager* pData
);
Parameters

pData
[in] pointer to the CXTPSyntaxEditBufferManager object.

See Also

CXTPSyntaxEditBufferManager.

Group

CXTPSyntaxEditTextIterator Constructors


CXTPSyntaxEditTextIterator Destructors

CXTPSyntaxEditTextIterator Class, Legend, Public Methods
CXTPSyntaxEditTextIterator Destructors
Class

CXTPSyntaxEditTextIterator Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditTextIterator | Destroys a CXTPSyntaxEditTextIterator object, handles cleanup and de-allocation.


CXTPSyntaxEditTextIterator::~CXTPSyntaxEditTextIterator Destructor

CXTPSyntaxEditTextIterator Destructors, CXTPSyntaxEditTextIterator Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextIterator::~CXTPSyntaxEditTextIterator Destructor

Destroys a CXTPSyntaxEditTextIterator object, handles cleanup and de-allocation.

virtual ~CXTPSyntaxEditTextIterator(
    void
);
Group

CXTPSyntaxEditTextIterator Destructors


CXTPSyntaxEditTextRegion Class

XTPSyntaxEditLexParser.h, Classes, Legend, Members, Topics, CXTPSyntaxEditTextRegion Data Members, CXTPSyntaxEditTextRegion Methods, CXTPSyntaxEditTextRegion Data Members, CXTPSyntaxEditTextRegion Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextRegion Class

This class is designed to store coordinates of text region.

Class Hierarchy

class CXTPSyntaxEditTextRegion;
File

XTPSyntaxEditLexParser.h

See Also

XTP_EDIT_LINECOL

Group

Classes

Legend
Data Member
Method
CXTPSyntaxEditTextRegion Data Members
CXTPSyntaxEditTextRegion Data Members | Description
m_posEnd | end position in document coordinates.
m_posStart | start position in document coordinates.
CXTPSyntaxEditTextRegion Methods
CXTPSyntaxEditTextRegion Methods | Description
Clear | Clears coordinates.
Set | Sets coordinates.


CXTPSyntaxEditTextRegion Data Members

CXTPSyntaxEditTextRegion Class, Legend, Public Data Members
CXTPSyntaxEditTextRegion Data Members
Class

CXTPSyntaxEditTextRegion Class

Legend
Data Member
Public Data Members
Public Data Member | Description
m_posEnd | end position in document coordinates.
m_posStart | start position in document coordinates.


CXTPSyntaxEditTextRegion::m_posEnd Data Member

CXTPSyntaxEditTextRegion Data Members, CXTPSyntaxEditTextRegion Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextRegion::m_posEnd Data Member

end position in document coordinates.

XTP_EDIT_LINECOL m_posEnd;
Group

CXTPSyntaxEditTextRegion Data Members


CXTPSyntaxEditTextRegion::m_posStart Data Member

CXTPSyntaxEditTextRegion Data Members, CXTPSyntaxEditTextRegion Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextRegion::m_posStart Data Member

start position in document coordinates.

XTP_EDIT_LINECOL m_posStart;
Group

CXTPSyntaxEditTextRegion Data Members


CXTPSyntaxEditTextRegion Methods

CXTPSyntaxEditTextRegion Class, Legend, Public Methods
CXTPSyntaxEditTextRegion Methods
Class

CXTPSyntaxEditTextRegion Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
Clear | Clears coordinates.
Set | Sets coordinates.


CXTPSyntaxEditTextRegion::Clear Method

CXTPSyntaxEditTextRegion Methods, CXTPSyntaxEditTextRegion Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextRegion::Clear Method

Clears coordinates.

void Clear();
Group

CXTPSyntaxEditTextRegion Methods


CXTPSyntaxEditTextRegion::Set Method

CXTPSyntaxEditTextRegion Methods, CXTPSyntaxEditTextRegion Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextRegion::Set Method

Sets coordinates.

void Set(
    const XTP_EDIT_LINECOL* pLCStart,
    const XTP_EDIT_LINECOL* pLCEnd
);
Parameters

pLCStart
[in] start position in document coordinates.
pLCEnd
[in] end position in document coordinates.

Group

CXTPSyntaxEditTextRegion Methods


CXTPSyntaxEditTextSchemesManager Class

XTPSyntaxEditLexColorFileReader.h, Classes, Legend, Members, Topics, CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Constructors, CXTPSyntaxEditTextSchemesManager Destructors, CXTPSyntaxEditTextSchemesManager Constructors, CXTPSyntaxEditTextSchemesManager Destructors, CXTPSyntaxEditTextSchemesManager Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager Class

This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.

Class Hierarchy

class CXTPSyntaxEditTextSchemesManager;
File

XTPSyntaxEditLexColorFileReader.h

Group

Classes

Legend
Method
virtual
CXTPSyntaxEditTextSchemesManager Constructors
CXTPSyntaxEditTextSchemesManager Constructors | Description
CXTPSyntaxEditTextSchemesManager | Default object constructor.
CXTPSyntaxEditTextSchemesManager Destructors
CXTPSyntaxEditTextSchemesManager Destructors | Description
~CXTPSyntaxEditTextSchemesManager | Destroys a CXTPSyntaxEditTextSchemesManager() object, handles cleanup and de-allocation.
CXTPSyntaxEditTextSchemesManager Methods
CXTPSyntaxEditTextSchemesManager Methods | Description
AddTextSchemeInfo | Add information about text scheme.
FindSchema | Finds a schema by file extension.
GetSchema | Returns schema by its name.
GetSchemaFileName | Returns file name by its schema name.
GetSchemaList | Use this member function to get schemas list.
GetSchemaName | Returns schema name by its file name.
GetSchemes | Returns all schemes names
LoadTextScheme | Implements common logic on creating new text scheme object and loading it from file or resources.
ReloadFile | Reloads configuration settings from the specified configuration file.
RemoveAll | Remove all loaded data.
SetTheme | Applys theme to all text schemes.


CXTPSyntaxEditTextSchemesManager Methods

CXTPSyntaxEditTextSchemesManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager Methods
Class

CXTPSyntaxEditTextSchemesManager Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
AddTextSchemeInfo | Add information about text scheme.
FindSchema | Finds a schema by file extension.
GetSchema | Returns schema by its name.
GetSchemaFileName | Returns file name by its schema name.
GetSchemaList | Use this member function to get schemas list.
GetSchemaName | Returns schema name by its file name.
GetSchemes | Returns all schemes names
LoadTextScheme | Implements common logic on creating new text scheme object and loading it from file or resources.
ReloadFile | Reloads configuration settings from the specified configuration file.
RemoveAll | Remove all loaded data.
SetTheme | Applys theme to all text schemes.


CXTPSyntaxEditTextSchemesManager::AddTextSchemeInfo Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::AddTextSchemeInfo Method

Add information about text scheme.

void AddTextSchemeInfo(
    XTP_EDIT_SCHEMAFILEINFO& info
);
Parameters

info
[in] A reference to schema information.

Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::FindSchema Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::FindSchema Method

Finds a schema by file extension.

CXTPSyntaxEditTextSchemaPtr FindSchema(
    const CString& strFileExt
);
Parameters

strFileExt
[in] file extension string.

Returns

CXTPSyntaxEditTextSchemaPtr object.

See Also

CXTPSyntaxEditTextSchemaPtr.

Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::GetSchema Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::GetSchema Method

Returns schema by its name.

CXTPSyntaxEditTextSchemaPtr GetSchema(
    const CString& strSchemeName
);
Parameters

strSchemeName
[in] schema name.

Returns

CXTPSyntaxEditTextSchemaPtr object.

See Also

CXTPSyntaxEditTextSchemaPtr.

Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::GetSchemaFileName Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::GetSchemaFileName Method

Returns file name by its schema name.

const CString GetSchemaFileName(
    const CString& strSchemeName
);
Parameters

strSchemeName
[in] schema name.

Returns

CString object.

Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::GetSchemaList Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::GetSchemaList Method

Use this member function to get schemas list.

CXTPSyntaxEditSchemaFileInfoList& GetSchemaList();
Returns

A reference to CXTPSyntaxEditSchemaFileInfoList object.

Body Source
CXTPSyntaxEditSchemaFileInfoList& CXTPSyntaxEditTextSchemesManager::GetSchemaList() {
    return m_listSchemes;
}
Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::GetSchemaName Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::GetSchemaName Method

Returns schema name by its file name.

const CString GetSchemaName(
    const CString& csFileName
);
Parameters

csFileName
[in] file name.

Returns

CString object.

Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::GetSchemes Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::GetSchemes Method

Returns all schemes names

CStringArray& GetSchemes();
Returns

Reference to CStringArray.

Body Source
CStringArray& CXTPSyntaxEditTextSchemesManager::GetSchemes() {
    return m_arSchemeNames;
}
Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::LoadTextScheme Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::LoadTextScheme Method

Implements common logic on creating new text scheme object and loading it from file or resources.

void LoadTextScheme(
    XTP_EDIT_SCHEMAFILEINFO& info
);
Parameters

info
[in] A reference to schema information.

Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::ReloadFile Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::ReloadFile Method

Reloads configuration settings from the specified configuration file.

BOOL ReloadFile(
    const CString& csFileName,
    int nCfgFlags = 0
);
Parameters

csFileName
[in] configuration file name.
nCfgFlags
[in] action flags. Does nothing if specified file is not found in the collection of files from the main configuration file

Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::RemoveAll Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::RemoveAll Method

Remove all loaded data.

void RemoveAll();
Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager::SetTheme Method

CXTPSyntaxEditTextSchemesManager Methods, CXTPSyntaxEditTextSchemesManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::SetTheme Method

Applys theme to all text schemes.

void SetTheme(
    CXTPSyntaxEditColorTheme* pTheme
);
Parameters

pTheme
[in] Pointer to theme to be set.

See Also

class CXTPSyntaxEditColorTheme.

Group

CXTPSyntaxEditTextSchemesManager Methods


CXTPSyntaxEditTextSchemesManager Constructors

CXTPSyntaxEditTextSchemesManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager Constructors
Class

CXTPSyntaxEditTextSchemesManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditTextSchemesManager | Default object constructor.


CXTPSyntaxEditTextSchemesManager::CXTPSyntaxEditTextSchemesManager Constructor

CXTPSyntaxEditTextSchemesManager Constructors, CXTPSyntaxEditTextSchemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::CXTPSyntaxEditTextSchemesManager Constructor

Default object constructor.

CXTPSyntaxEditTextSchemesManager();
Group

CXTPSyntaxEditTextSchemesManager Constructors


CXTPSyntaxEditTextSchemesManager Destructors

CXTPSyntaxEditTextSchemesManager Class, Legend, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager Destructors
Class

CXTPSyntaxEditTextSchemesManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditTextSchemesManager | Destroys a CXTPSyntaxEditTextSchemesManager() object, handles cleanup and de-allocation.


CXTPSyntaxEditTextSchemesManager::~CXTPSyntaxEditTextSchemesManager Destructor

CXTPSyntaxEditTextSchemesManager Destructors, CXTPSyntaxEditTextSchemesManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTextSchemesManager::~CXTPSyntaxEditTextSchemesManager Destructor

Destroys a CXTPSyntaxEditTextSchemesManager() object, handles cleanup and de-allocation.

virtual ~CXTPSyntaxEditTextSchemesManager();
Group

CXTPSyntaxEditTextSchemesManager Destructors


CXTPSyntaxEditTipComboBox Class

XTPSyntaxEditPropertiesPage.h, Classes, Legend, Members, Topics, CXTPSyntaxEditTipComboBox Methods, CXTPSyntaxEditTipComboBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipComboBox Class

This class implements a combo box with tooltip.

Class Hierarchy

class CXTPSyntaxEditTipComboBox : public CComboBox;
File

XTPSyntaxEditPropertiesPage.h

Group

Classes

Legend
Method
CXTPSyntaxEditTipComboBox Methods
CXTPSyntaxEditTipComboBox Methods | Description
GetListBox | Use this member function to get an attached list box.


CXTPSyntaxEditTipComboBox Methods

CXTPSyntaxEditTipComboBox Class, Legend, Public Methods
CXTPSyntaxEditTipComboBox Methods
Class

CXTPSyntaxEditTipComboBox Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetListBox | Use this member function to get an attached list box.


CXTPSyntaxEditTipComboBox::GetListBox Method

CXTPSyntaxEditTipComboBox Methods, CXTPSyntaxEditTipComboBox Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipComboBox::GetListBox Method

Use this member function to get an attached list box.

CXTPSyntaxEditTipListBox& GetListBox();
Returns

A CXTPSyntaxEditTipListBox object reference.

See Also

CXTPSyntaxEditTipListBox

Body Source
CXTPSyntaxEditTipListBox& CXTPSyntaxEditTipComboBox::GetListBox() {
    return m_wndListBox;
}
Group

CXTPSyntaxEditTipComboBox Methods


CXTPSyntaxEditTipListBox Class

XTPSyntaxEditPropertiesPage.h, Classes, Legend, Members, Topics, CXTPSyntaxEditTipListBox Data Members, CXTPSyntaxEditTipListBox Methods, CXTPSyntaxEditTipListBox Constructors, CXTPSyntaxEditTipListBox Constructors, CXTPSyntaxEditTipListBox Data Members, CXTPSyntaxEditTipListBox Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipListBox Class

This class implements a list box with tooltip.

Class Hierarchy

class CXTPSyntaxEditTipListBox : public CListBox;
File

XTPSyntaxEditPropertiesPage.h

Group

Classes

Legend
Data Member
protected
Method
CXTPSyntaxEditTipListBox Constructors
CXTPSyntaxEditTipListBox Constructors | Description
CXTPSyntaxEditTipListBox | Default object constructor.
CXTPSyntaxEditTipListBox Data Members
CXTPSyntaxEditTipListBox Data Members | Description
m_dwIdx | Selection indexes: LOWORD - previous selection index, HIWORD - active selection index.
m_wndInfoTip | A tooltip window.
CXTPSyntaxEditTipListBox Methods
CXTPSyntaxEditTipListBox Methods | Description
HitTest |
SelChanged | Use this member function to determine is selection changed by the user.
ShowTip | Use this member function to show tooltip for specified point if necessary.


CXTPSyntaxEditTipListBox Data Members

CXTPSyntaxEditTipListBox Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipListBox Data Members
Class

CXTPSyntaxEditTipListBox Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_dwIdx | Selection indexes: LOWORD - previous selection index, HIWORD - active selection index.
m_wndInfoTip | A tooltip window.


CXTPSyntaxEditTipListBox::m_dwIdx Data Member

CXTPSyntaxEditTipListBox Data Members, CXTPSyntaxEditTipListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipListBox::m_dwIdx Data Member

Selection indexes: LOWORD - previous selection index, HIWORD - active selection index.

DWORD m_dwIdx;
Group

CXTPSyntaxEditTipListBox Data Members


CXTPSyntaxEditTipListBox::m_wndInfoTip Data Member

CXTPSyntaxEditTipListBox Data Members, CXTPSyntaxEditTipListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipListBox::m_wndInfoTip Data Member

A tooltip window.

CXTPSyntaxEditTipWnd m_wndInfoTip;
Group

CXTPSyntaxEditTipListBox Data Members


CXTPSyntaxEditTipListBox Methods

CXTPSyntaxEditTipListBox Class, Legend, Public Methods
CXTPSyntaxEditTipListBox Methods
Class

CXTPSyntaxEditTipListBox Class

Legend
Method
Public Methods
Public Methods
Public Method | Description
HitTest |
SelChanged | Use this member function to determine is selection changed by the user.
ShowTip | Use this member function to show tooltip for specified point if necessary.


HitTest Method

CXTPSyntaxEditTipListBox Methods
HitTest Method
Overload List
Methods
Method | Description
CXTPSyntaxEditTipListBox::HitTest (CPoint, BOOL) | This method used to determine a list box item for a specified point.
CXTPSyntaxEditTipListBox::HitTest (LPPOINT) | This method used to determine a list box item for a specified point.
Group

CXTPSyntaxEditTipListBox Methods


CXTPSyntaxEditTipListBox::HitTest Method (CPoint, BOOL)

HitTest Method, CXTPSyntaxEditTipListBox Class, See Also
CXTPSyntaxEditTipListBox::HitTest Method (CPoint, BOOL)

This method used to determine a list box item for a specified point.

int HitTest(
    CPoint point,
    BOOL bIsClient = FALSE
) const;
Parameters

point
A CPoint object.
bIsClient
Set as TRUE if point contains client coordinates or set as FALSE if screen.

Returns

Item index under specified point or LB_ERR.

See Also

HitTest@LPPOINT

Group

HitTest Method


CXTPSyntaxEditTipListBox::HitTest Method (LPPOINT)

HitTest Method, CXTPSyntaxEditTipListBox Class, See Also
CXTPSyntaxEditTipListBox::HitTest Method (LPPOINT)

This method used to determine a list box item for a specified point.

int HitTest(
    LPPOINT pPoint = NULL
) const;
Parameters

pPoint
A pointer to POINT object or NULL. If this parameter
NULL
current mouse coordinates are used.

Returns

Item index under specified point or LB_ERR.

See Also

HitTest@CPoint@BOOL

Group

HitTest Method


CXTPSyntaxEditTipListBox::SelChanged Method

CXTPSyntaxEditTipListBox Methods, CXTPSyntaxEditTipListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipListBox::SelChanged Method

Use this member function to determine is selection changed by the user.

BOOL SelChanged() const;
Returns

TRUE selection changed, FALSE otherwise.

Group

CXTPSyntaxEditTipListBox Methods


CXTPSyntaxEditTipListBox::ShowTip Method

CXTPSyntaxEditTipListBox Methods, CXTPSyntaxEditTipListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipListBox::ShowTip Method

Use this member function to show tooltip for specified point if necessary.

int ShowTip(
    CPoint point,
    BOOL bIsClient = FALSE
);
Parameters

point
A CPoint object.
bIsClient
Set as TRUE if point contains client coordinates or set as FALSE if screen.

Returns

Item index if tooltip showed, otherwise LB_ERR.

Group

CXTPSyntaxEditTipListBox Methods


CXTPSyntaxEditTipListBox Constructors

CXTPSyntaxEditTipListBox Class, Legend, Public Methods
CXTPSyntaxEditTipListBox Constructors
Class

CXTPSyntaxEditTipListBox Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditTipListBox | Default object constructor.


CXTPSyntaxEditTipListBox::CXTPSyntaxEditTipListBox Constructor

CXTPSyntaxEditTipListBox Constructors, CXTPSyntaxEditTipListBox Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipListBox::CXTPSyntaxEditTipListBox Constructor

Default object constructor.

CXTPSyntaxEditTipListBox();
Group

CXTPSyntaxEditTipListBox Constructors


CXTPSyntaxEditTipWnd Class

XTPSyntaxEditPropertiesPage.h, Classes, Legend, Members, Topics, CXTPSyntaxEditTipWnd Data Members, CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Constructors, CXTPSyntaxEditTipWnd Destructors, CXTPSyntaxEditTipWnd Constructors, CXTPSyntaxEditTipWnd Data Members, CXTPSyntaxEditTipWnd Destructors, CXTPSyntaxEditTipWnd Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd Class

CXTPSyntaxEditTipWnd implements a tooltip window for CXTPSyntaxEditTipListBox class.

Class Hierarchy

class CXTPSyntaxEditTipWnd : public CWnd;
File

XTPSyntaxEditPropertiesPage.h

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditTipWnd Constructors
CXTPSyntaxEditTipWnd Constructors | Description
CXTPSyntaxEditTipWnd | Default object constructor.
CXTPSyntaxEditTipWnd Data Members
CXTPSyntaxEditTipWnd Data Members | Description
m_iIndex | Current item index.
m_pListBox | Store pointer to attached list box.
m_ptCursor | Store cursor position.
m_rWindow | Store window rect.
CXTPSyntaxEditTipWnd Destructors
CXTPSyntaxEditTipWnd Destructors | Description
~CXTPSyntaxEditTipWnd | Default object destructor.
CXTPSyntaxEditTipWnd Methods
CXTPSyntaxEditTipWnd Methods | Description
CalcItemRect | Used to get rectangle for a specified item.
Create | Create a tooltip window.
DrawTip | This method used to draw tooltip.
GetBackColor | Get background color.
GetTextColor | Get text color.
HideTip | Use this member function to hide tooltip.
IsOwnerDrawn | Use this member function to determine is attached list box has owner draw flags (LBS_OWNERDRAWFIXED or LBS_OWNERDRAWVARIABLE).
OwnerDrawTip | This method used to draw tooltip for owner drawn list box.
RegisterWindowClass | Register the window class if it has not already been registered.
ShowTip | Use this member function to show tooltip for specified list box item.


CXTPSyntaxEditTipWnd Data Members

CXTPSyntaxEditTipWnd Class, Legend, Protected Data Members
CXTPSyntaxEditTipWnd Data Members
Class

CXTPSyntaxEditTipWnd Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_iIndex | Current item index.
m_pListBox | Store pointer to attached list box.
m_ptCursor | Store cursor position.
m_rWindow | Store window rect.


CXTPSyntaxEditTipWnd::m_iIndex Data Member

CXTPSyntaxEditTipWnd Data Members, CXTPSyntaxEditTipWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::m_iIndex Data Member

Current item index.

int m_iIndex;
Group

CXTPSyntaxEditTipWnd Data Members


CXTPSyntaxEditTipWnd::m_pListBox Data Member

CXTPSyntaxEditTipWnd Data Members, CXTPSyntaxEditTipWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::m_pListBox Data Member

Store pointer to attached list box.

CListBox* m_pListBox;
Group

CXTPSyntaxEditTipWnd Data Members


CXTPSyntaxEditTipWnd::m_ptCursor Data Member

CXTPSyntaxEditTipWnd Data Members, CXTPSyntaxEditTipWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::m_ptCursor Data Member

Store cursor position.

CPoint m_ptCursor;
Group

CXTPSyntaxEditTipWnd Data Members


CXTPSyntaxEditTipWnd::m_rWindow Data Member

CXTPSyntaxEditTipWnd Data Members, CXTPSyntaxEditTipWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::m_rWindow Data Member

Store window rect.

CRect m_rWindow;
Group

CXTPSyntaxEditTipWnd Data Members


CXTPSyntaxEditTipWnd Methods

CXTPSyntaxEditTipWnd Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd Methods
Class

CXTPSyntaxEditTipWnd Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CalcItemRect | Used to get rectangle for a specified item.
DrawTip | This method used to draw tooltip.
OwnerDrawTip | This method used to draw tooltip for owner drawn list box.
RegisterWindowClass | Register the window class if it has not already been registered.
Public Methods
Public Methods
Public Method | Description
Create | Create a tooltip window.
GetBackColor | Get background color.
GetTextColor | Get text color.
HideTip | Use this member function to hide tooltip.
IsOwnerDrawn | Use this member function to determine is attached list box has owner draw flags (LBS_OWNERDRAWFIXED or LBS_OWNERDRAWVARIABLE).
ShowTip | Use this member function to show tooltip for specified list box item.


CXTPSyntaxEditTipWnd::CalcItemRect Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class
CXTPSyntaxEditTipWnd::CalcItemRect Method

Used to get rectangle for a specified item.

virtual BOOL CalcItemRect(
    int iItem,
    CRect& rItem
);
Parameters

iItem
[in] A list box item index.
rItem
[out] Item rectangle.

Returns

TRUE if successful, FALSE otherwise.

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::Create Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::Create Method

Create a tooltip window.

virtual BOOL Create(
    CListBox* pListBox
);
Parameters

pListBox
A pointer to CListBox to attach.

Returns

TRUE if successful, FALSE otherwise.

See Also

ShowTip

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::DrawTip Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::DrawTip Method

This method used to draw tooltip.

virtual BOOL DrawTip(
    CDC* pDC,
    CRect rClient
);
Parameters

pDC
A pointer to device context.
rClient
Tooltip rect (in client coordinates of this window).

Returns

TRUE if successful, FALSE otherwise.

See Also

OwnerDrawTip

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::GetBackColor Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::GetBackColor Method

Get background color.

virtual COLORREF GetBackColor() const;
Returns

A tooltip background color.

See Also

GetTextColor

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::GetTextColor Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::GetTextColor Method

Get text color.

virtual COLORREF GetTextColor() const;
Returns

A tooltip text color.

See Also

GetBackColor

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::HideTip Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::HideTip Method

Use this member function to hide tooltip.

virtual BOOL HideTip();
Returns

TRUE if tooltip was visible and method hide it, FALSE if tooltip was not visible.

See Also

ShowTip

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::IsOwnerDrawn Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::IsOwnerDrawn Method

Use this member function to determine is attached list box has owner draw flags (LBS_OWNERDRAWFIXED or LBS_OWNERDRAWVARIABLE).

virtual BOOL IsOwnerDrawn();
Returns

TRUE if attached list box is owner drawn, FALSE otherwise.

See Also

CListBox, LBS_OWNERDRAWFIXED, LBS_OWNERDRAWVARIABLE

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::OwnerDrawTip Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::OwnerDrawTip Method

This method used to draw tooltip for owner drawn list box.

virtual BOOL OwnerDrawTip(
    CDC* pDC,
    CRect rClient
);
Parameters

pDC
A pointer to device context.
rClient
Tooltip rect (in client coordinates of this window).

Returns

TRUE if successful, FALSE otherwise.

See Also

DrawTip

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::RegisterWindowClass Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class
CXTPSyntaxEditTipWnd::RegisterWindowClass Method

Register the window class if it has not already been registered.

virtual BOOL RegisterWindowClass(
    HINSTANCE hInstance = NULL
);
Parameters

hInstance
Instance of resource where control is located

Returns

TRUE if the window class was successfully registered. FALSE otherwise.

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd::ShowTip Method

CXTPSyntaxEditTipWnd Methods, CXTPSyntaxEditTipWnd Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::ShowTip Method

Use this member function to show tooltip for specified list box item.

virtual BOOL ShowTip(
    int iIndex
);
Parameters

iIndex
A list box item index.

Returns

TRUE if successful, FALSE otherwise.

See Also

HideTip

Group

CXTPSyntaxEditTipWnd Methods


CXTPSyntaxEditTipWnd Constructors

CXTPSyntaxEditTipWnd Class, Legend, Public Methods
CXTPSyntaxEditTipWnd Constructors
Class

CXTPSyntaxEditTipWnd Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditTipWnd | Default object constructor.


CXTPSyntaxEditTipWnd::CXTPSyntaxEditTipWnd Constructor

CXTPSyntaxEditTipWnd Constructors, CXTPSyntaxEditTipWnd Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditTipWnd::CXTPSyntaxEditTipWnd Constructor

Default object constructor.

CXTPSyntaxEditTipWnd();
Group

CXTPSyntaxEditTipWnd Constructors


CXTPSyntaxEditTipWnd Destructors

CXTPSyntaxEditTipWnd Class, Legend, Public Methods
CXTPSyntaxEditTipWnd Destructors
Class

CXTPSyntaxEditTipWnd Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditTipWnd | Default object destructor.


CXTPSyntaxEditTipWnd::~CXTPSyntaxEditTipWnd Destructor

CXTPSyntaxEditTipWnd Destructors, CXTPSyntaxEditTipWnd Class
CXTPSyntaxEditTipWnd::~CXTPSyntaxEditTipWnd Destructor

Default object destructor.

virtual ~CXTPSyntaxEditTipWnd();
Group

CXTPSyntaxEditTipWnd Destructors


CXTPSyntaxEditToolTipCtrl Class

XTPSyntaxEditToolTipCtrl.h, Classes, Legend, Members, Topics, CXTPSyntaxEditToolTipCtrl Data Members, CXTPSyntaxEditToolTipCtrl Methods, CXTPSyntaxEditToolTipCtrl Constructors, CXTPSyntaxEditToolTipCtrl Destructors, CXTPSyntaxEditToolTipCtrl Constructors, CXTPSyntaxEditToolTipCtrl Data Members, CXTPSyntaxEditToolTipCtrl Destructors, CXTPSyntaxEditToolTipCtrl Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl Class

The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.

CXTPSyntaxEditToolTipCtrl provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip.

This class is used by the report control internally.

Class Hierarchy

class CXTPSyntaxEditToolTipCtrl : public CWnd;
File

XTPSyntaxEditToolTipCtrl.h

See Also

CXTPSyntaxEditCtrl

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditToolTipCtrl Constructors
CXTPSyntaxEditToolTipCtrl Constructors | Description
CXTPSyntaxEditToolTipCtrl | Constructs a CXTPSyntaxEditToolTipCtrl object.
CXTPSyntaxEditToolTipCtrl Data Members
CXTPSyntaxEditToolTipCtrl Data Members | Description
m_nDelayTime | Delay before showing the tooltip in milliseconds.
m_pParentWnd | Pointer to the parent report window.
m_rcHover | Hover window coordinates.
m_strToolTipText | ToolTip text to display.
CXTPSyntaxEditToolTipCtrl Destructors
CXTPSyntaxEditToolTipCtrl Destructors | Description
~CXTPSyntaxEditToolTipCtrl | Destroys a CXTPSyntaxEditToolTipCtrl object, handles cleanup and de-allocation
CXTPSyntaxEditToolTipCtrl Methods
CXTPSyntaxEditToolTipCtrl Methods | Description
Activate | Activates the tooltip window.
Create | Creates smart edit tip window.
GetDelay | Returns the delay time.
Hide | Hides the ToolTip Window.
OnNcHitTest | AFX_MSG(CXTPSyntaxEditToolTipCtrl)
SetDelay | Sets time to display the tip.
SetHoverRect | Sets coordinates of the tooltip hover rectangle.


CXTPSyntaxEditToolTipCtrl Data Members

CXTPSyntaxEditToolTipCtrl Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl Data Members
Class

CXTPSyntaxEditToolTipCtrl Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_nDelayTime | Delay before showing the tooltip in milliseconds.
m_pParentWnd | Pointer to the parent report window.
m_rcHover | Hover window coordinates.
m_strToolTipText | ToolTip text to display.


CXTPSyntaxEditToolTipCtrl::m_nDelayTime Data Member

CXTPSyntaxEditToolTipCtrl Data Members, CXTPSyntaxEditToolTipCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::m_nDelayTime Data Member

Delay before showing the tooltip in milliseconds.

int m_nDelayTime;
Group

CXTPSyntaxEditToolTipCtrl Data Members


CXTPSyntaxEditToolTipCtrl::m_pParentWnd Data Member

CXTPSyntaxEditToolTipCtrl Data Members, CXTPSyntaxEditToolTipCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::m_pParentWnd Data Member

Pointer to the parent report window.

CXTPSyntaxEditCtrl* m_pParentWnd;
Group

CXTPSyntaxEditToolTipCtrl Data Members


CXTPSyntaxEditToolTipCtrl::m_rcHover Data Member

CXTPSyntaxEditToolTipCtrl Data Members, CXTPSyntaxEditToolTipCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::m_rcHover Data Member

Hover window coordinates.

CRect m_rcHover;
Group

CXTPSyntaxEditToolTipCtrl Data Members


CXTPSyntaxEditToolTipCtrl::m_strToolTipText Data Member

CXTPSyntaxEditToolTipCtrl Data Members, CXTPSyntaxEditToolTipCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::m_strToolTipText Data Member

ToolTip text to display.

CString m_strToolTipText;
Group

CXTPSyntaxEditToolTipCtrl Data Members


CXTPSyntaxEditToolTipCtrl Methods

CXTPSyntaxEditToolTipCtrl Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl Methods
Class

CXTPSyntaxEditToolTipCtrl Class

Legend
Method
virtual
protected
Protected Methods
Protected Methods
Protected Method | Description
OnNcHitTest | AFX_MSG(CXTPSyntaxEditToolTipCtrl)
Public Methods
Public Methods
Public Method | Description
Activate | Activates the tooltip window.
Create | Creates smart edit tip window.
GetDelay | Returns the delay time.
Hide | Hides the ToolTip Window.
SetDelay | Sets time to display the tip.
SetHoverRect | Sets coordinates of the tooltip hover rectangle.


CXTPSyntaxEditToolTipCtrl::Activate Method

CXTPSyntaxEditToolTipCtrl Methods, CXTPSyntaxEditToolTipCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::Activate Method

Activates the tooltip window.

void Activate(
    const CString& strText
);
Parameters

strText
[in] Text to be shown in ToolTip window.

Group

CXTPSyntaxEditToolTipCtrl Methods


CXTPSyntaxEditToolTipCtrl::Create Method

CXTPSyntaxEditToolTipCtrl Methods, CXTPSyntaxEditToolTipCtrl Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::Create Method

Creates smart edit tip window.

virtual BOOL Create(
    CXTPSyntaxEditCtrl* pParentWnd
);
Parameters

pParentWnd
[in] Parent report control window.

Returns

TRUE if tip window created successfully, FALSE otherwise.

See Also

CXTPSyntaxEditCtrl::ShowCollapsedToolTip

Group

CXTPSyntaxEditToolTipCtrl Methods


CXTPSyntaxEditToolTipCtrl::GetDelay Method

CXTPSyntaxEditToolTipCtrl Methods, CXTPSyntaxEditToolTipCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::GetDelay Method

Returns the delay time.

int GetDelay();
Returns

Integer value of current delay.

See Also

void SetDelay(int nDelay);

Body Source
int CXTPSyntaxEditToolTipCtrl::GetDelay() {
    return m_nDelayTime;
}
Group

CXTPSyntaxEditToolTipCtrl Methods


CXTPSyntaxEditToolTipCtrl::Hide Method

CXTPSyntaxEditToolTipCtrl Methods, CXTPSyntaxEditToolTipCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::Hide Method

Hides the ToolTip Window.

void Hide();
Group

CXTPSyntaxEditToolTipCtrl Methods


CXTPSyntaxEditToolTipCtrl::OnNcHitTest Method

CXTPSyntaxEditToolTipCtrl Methods, CXTPSyntaxEditToolTipCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::OnNcHitTest Method

AFX_MSG(CXTPSyntaxEditToolTipCtrl)

afx_msg LRESULT OnNcHitTest(
    CPoint point
);
Group

CXTPSyntaxEditToolTipCtrl Methods


CXTPSyntaxEditToolTipCtrl::SetDelay Method

CXTPSyntaxEditToolTipCtrl Methods, CXTPSyntaxEditToolTipCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::SetDelay Method

Sets time to display the tip.

void SetDelay(
    int nDelay
);
Parameters

nDelay
[in] Display delay value for ToolTip.

See Also

int GetDelay();

Body Source
void CXTPSyntaxEditToolTipCtrl::SetDelay(int nDelay) {
    m_nDelayTime = nDelay;
}
Group

CXTPSyntaxEditToolTipCtrl Methods


CXTPSyntaxEditToolTipCtrl::SetHoverRect Method

CXTPSyntaxEditToolTipCtrl Methods, CXTPSyntaxEditToolTipCtrl Class, Body Source, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::SetHoverRect Method

Sets coordinates of the tooltip hover rectangle.

void SetHoverRect(
    CRect rc
);
Parameters

rc
[in] New tooltip hover rectangle in parent window coordinates.

Remarks

Should be called before activating tooltip window.

See Also

GetHoverRect()

Body Source
void CXTPSyntaxEditToolTipCtrl::SetHoverRect(CRect rc) {
    m_rcHover = rc;
}
Group

CXTPSyntaxEditToolTipCtrl Methods


CXTPSyntaxEditToolTipCtrl Constructors

CXTPSyntaxEditToolTipCtrl Class, Legend, Public Methods
CXTPSyntaxEditToolTipCtrl Constructors
Class

CXTPSyntaxEditToolTipCtrl Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditToolTipCtrl | Constructs a CXTPSyntaxEditToolTipCtrl object.


CXTPSyntaxEditToolTipCtrl::CXTPSyntaxEditToolTipCtrl Constructor

CXTPSyntaxEditToolTipCtrl Constructors, CXTPSyntaxEditToolTipCtrl Class, Example, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::CXTPSyntaxEditToolTipCtrl Constructor

Constructs a CXTPSyntaxEditToolTipCtrl object.

CXTPSyntaxEditToolTipCtrl();
Remarks

You construct a object object in two steps. First, call the constructor object and then call Create, which initializes the window and attaches it to the parent window.

See Also

Create, Activate

Example

// Declare a local CXTPSyntaxEditToolTipCtrl object. CXTPSyntaxEditToolTipCtrl wndTip;

// Declare a dynamic CXTPSyntaxEditToolTipCtrl object. CXTPSyntaxEditToolTipCtrl* pTipWnd = new CXTPSyntaxEditToolTipCtrl;

Group

CXTPSyntaxEditToolTipCtrl Constructors


CXTPSyntaxEditToolTipCtrl Destructors

CXTPSyntaxEditToolTipCtrl Class, Legend, Public Methods
CXTPSyntaxEditToolTipCtrl Destructors
Class

CXTPSyntaxEditToolTipCtrl Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditToolTipCtrl | Destroys a CXTPSyntaxEditToolTipCtrl object, handles cleanup and de-allocation


CXTPSyntaxEditToolTipCtrl::~CXTPSyntaxEditToolTipCtrl Destructor

CXTPSyntaxEditToolTipCtrl Destructors, CXTPSyntaxEditToolTipCtrl Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditToolTipCtrl::~CXTPSyntaxEditToolTipCtrl Destructor

Destroys a CXTPSyntaxEditToolTipCtrl object, handles cleanup and de-allocation

virtual ~CXTPSyntaxEditToolTipCtrl();
Group

CXTPSyntaxEditToolTipCtrl Destructors


CXTPSyntaxEditUndoRedoManager Class

XTPSyntaxEditUndoManager.h, Classes, Legend, Members, Topics, CXTPSyntaxEditUndoRedoManager Data Members, CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Constructors, CXTPSyntaxEditUndoRedoManager Destructors, CXTPSyntaxEditUndoRedoManager Constructors, CXTPSyntaxEditUndoRedoManager Data Members, CXTPSyntaxEditUndoRedoManager Destructors, CXTPSyntaxEditUndoRedoManager Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager Class

This class maintains the list of undo/redo commands. It is managed by CEditBufferManager class.

It allows adding new commands in the buffer (see AddCommand()), undoing last added operation (see DoUndo()), and redoing operations following the latest unexecuted (see DoRedo()).

It also allows checking for the possibility of performing undo/redo operations (see CanUndo() / CanRedo()).

It also allows marking current position of undo/redo operation queue as saved, and returns "modified" flag if the queue position will be changed (see MarkSaved() / IsModified()).

Another piece of the functionality is commands grouping. There are following methods related to this: SetGroupInsertMode() and ChainLastCommand(). The second one forces latest added undo command to be merged in group with the previous one. It could be useful for group operations like moving a selected text by mouse. In this case there will be 2 different commands added: remove selected text from its original position, and insert it into the new position. By using ChainLastCommand() methods both these operations will be merged into the single one, which will be further done/undone together. The first method SetGroupInsertMode() forces undo/redo manager to merge in the single chain all added operations. For example, it could be useful when the user is typing some text, which could be later done/undoe in the single word, instead of by each character.

Also, one more piece of functionality is related to the command description text management. Related functions allow setting the new text description for the last undo command (SetLastCommandText()). As an example, it could be used after ChainLastCommand() method for setting new description for the merged command ('Move' instead of 'Delete'+'Insert'). Another 2 functions allow retrieving string description lists for the list of undo and redo commands (GetUndoTextList() / GetRedoTextList()).

However, this class is used internally by the library only.

Class Hierarchy

class CXTPSyntaxEditUndoRedoManager;
File

XTPSyntaxEditUndoManager.h

See Also

CXTPSyntaxEditCommand

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditUndoRedoManager Constructors
CXTPSyntaxEditUndoRedoManager Constructors | Description
CXTPSyntaxEditUndoRedoManager | Creates the undo/redo manager object, initializes its members.
CXTPSyntaxEditUndoRedoManager Data Members
CXTPSyntaxEditUndoRedoManager Data Members | Description
m_bGroupInsertMode | TRUE if group insert mode is on, FALSE otherwise
m_CommandList | Commands buffer.
m_nDataSizeLimit | The memory limit for undo data.
m_posFirstUndo | Actual command position in the buffer.
m_posSavedMark | Last saved command position in the buffer.
CXTPSyntaxEditUndoRedoManager Destructors
CXTPSyntaxEditUndoRedoManager Destructors | Description
~CXTPSyntaxEditUndoRedoManager | Destroys the undo/redo manager object, handles its cleanup and de-allocation.
CXTPSyntaxEditUndoRedoManager Methods
CXTPSyntaxEditUndoRedoManager Methods | Description
AddCommand | Add command to the undo buffer. Delete all redo commands if exist.
CanRedo | Calculate possibility to perform redo action.
CanUndo | Calculate possibility to perform undo action.
ChainLastCommand | Forces latest Undo command to merge in batch command with the previous one.
Clear | Clears the undo manager buffer and delete all commands.
DoRedo | Perform single redo operation: Executes the next command.
DoUndo | Perform single undo operation: Unexecutes the latest command.
GetDataSize | This member function used to get undo buffer data size (in bytes).
GetRedoTextList | Returns the list of text for redo operations.
GetUndoTextList | Returns the list of text for undo operations.
IsModified | Checks whether the document was modified by any command from the buffer since the last document saving or loading.
LimitDataSize | This member function used to check undo buffer data size and remove old stored commands to clear memory if data size limit is reached.
MarkSaved | Marks current command buffer position as last saved. Used for the further calculating modified flag.
SetGroupInsertMode | Group insert mode is required when a user is typing certain text in normal INS mode. In the time of undo/redo a group of text is undone in a single shot. This setting is cleared in the case of overwrite mode or while user presses SPACE, TAB, ENTER etc.
SetLastCommandText |


CXTPSyntaxEditUndoRedoManager Data Members

CXTPSyntaxEditUndoRedoManager Class, Legend, Protected Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager Data Members
Class

CXTPSyntaxEditUndoRedoManager Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_bGroupInsertMode | TRUE if group insert mode is on, FALSE otherwise
m_CommandList | Commands buffer.
m_nDataSizeLimit | The memory limit for undo data.
m_posFirstUndo | Actual command position in the buffer.
m_posSavedMark | Last saved command position in the buffer.


CXTPSyntaxEditUndoRedoManager::m_bGroupInsertMode Data Member

CXTPSyntaxEditUndoRedoManager Data Members, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::m_bGroupInsertMode Data Member

TRUE if group insert mode is on, FALSE otherwise

BOOL m_bGroupInsertMode;
Group

CXTPSyntaxEditUndoRedoManager Data Members


CXTPSyntaxEditUndoRedoManager::m_CommandList Data Member

CXTPSyntaxEditUndoRedoManager Data Members, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::m_CommandList Data Member

Commands buffer.

CPtrList m_CommandList;
Group

CXTPSyntaxEditUndoRedoManager Data Members


CXTPSyntaxEditUndoRedoManager::m_nDataSizeLimit Data Member

CXTPSyntaxEditUndoRedoManager Data Members, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::m_nDataSizeLimit Data Member

The memory limit for undo data.

int m_nDataSizeLimit;
Group

CXTPSyntaxEditUndoRedoManager Data Members


CXTPSyntaxEditUndoRedoManager::m_posFirstUndo Data Member

CXTPSyntaxEditUndoRedoManager Data Members, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::m_posFirstUndo Data Member

Actual command position in the buffer.

POSITION m_posFirstUndo;
Group

CXTPSyntaxEditUndoRedoManager Data Members


CXTPSyntaxEditUndoRedoManager::m_posSavedMark Data Member

CXTPSyntaxEditUndoRedoManager Data Members, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::m_posSavedMark Data Member

Last saved command position in the buffer.

POSITION m_posSavedMark;
Group

CXTPSyntaxEditUndoRedoManager Data Members


CXTPSyntaxEditUndoRedoManager Methods

CXTPSyntaxEditUndoRedoManager Class, Legend, Public Methods
CXTPSyntaxEditUndoRedoManager Methods
Class

CXTPSyntaxEditUndoRedoManager Class

Legend
Method
virtual
Public Methods
Public Methods
Public Method | Description
AddCommand | Add command to the undo buffer. Delete all redo commands if exist.
CanRedo | Calculate possibility to perform redo action.
CanUndo | Calculate possibility to perform undo action.
ChainLastCommand | Forces latest Undo command to merge in batch command with the previous one.
Clear | Clears the undo manager buffer and delete all commands.
DoRedo | Perform single redo operation: Executes the next command.
DoUndo | Perform single undo operation: Unexecutes the latest command.
GetDataSize | This member function used to get undo buffer data size (in bytes).
GetRedoTextList | Returns the list of text for redo operations.
GetUndoTextList | Returns the list of text for undo operations.
IsModified | Checks whether the document was modified by any command from the buffer since the last document saving or loading.
LimitDataSize | This member function used to check undo buffer data size and remove old stored commands to clear memory if data size limit is reached.
MarkSaved | Marks current command buffer position as last saved. Used for the further calculating modified flag.
SetGroupInsertMode | Group insert mode is required when a user is typing certain text in normal INS mode. In the time of undo/redo a group of text is undone in a single shot. This setting is cleared in the case of overwrite mode or while user presses SPACE, TAB, ENTER etc.
SetLastCommandText |


CXTPSyntaxEditUndoRedoManager::AddCommand Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::AddCommand Method

Add command to the undo buffer. Delete all redo commands if exist.

void AddCommand(
    CXTPSyntaxEditCommand* pCommand
);
Parameters

pCommand
[in] A pointer of the command to add.

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::CanRedo Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::CanRedo Method

Calculate possibility to perform redo action.

BOOL CanRedo();
Returns

TRUE if performing redo action is possible, FALSE otherwise.

See Also

CanUndo

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::CanUndo Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::CanUndo Method

Calculate possibility to perform undo action.

BOOL CanUndo();
Returns

TRUE if performing undo action is possible, FALSE otherwise.

See Also

CanRedo

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::ChainLastCommand Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::ChainLastCommand Method

Forces latest Undo command to merge in batch command with the previous one.

void ChainLastCommand();
See Also

SetGroupInsertMode

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::Clear Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::Clear Method

Clears the undo manager buffer and delete all commands.

void Clear();
Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::DoRedo Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::DoRedo Method

Perform single redo operation: Executes the next command.

int DoRedo(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the affected edit actions. XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

DoUndo

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::DoUndo Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::DoUndo Method

Perform single undo operation: Unexecutes the latest command.

int DoUndo(
    XTP_EDIT_LINECOL& lcFrom,
    XTP_EDIT_LINECOL& lcTo,
    CXTPSyntaxEditCtrl* pEditCtrl
);
Parameters

lcFrom
[out] Start text position affected by the command.
lcTo
[out] End text position affected by the command.
pEditCtrl
[in] A pointer to edit control.

Returns

A bitwise combination of the affected edit actions. XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW

See Also

DoRedo

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::GetDataSize Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::GetDataSize Method

This member function used to get undo buffer data size (in bytes).

virtual int GetDataSize();
Returns

Undo buffer data size (in bytes).

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::GetRedoTextList Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::GetRedoTextList Method

Returns the list of text for redo operations.

const CStringList& GetRedoTextList();
Returns

The texts for redo.

See Also

GetUndoTextList, SetLastCommandText

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::GetUndoTextList Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::GetUndoTextList Method

Returns the list of text for undo operations.

const CStringList& GetUndoTextList();
Returns

The text list for undo operations.

See Also

GetRedoTextList, SetLastCommandText

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::IsModified Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::IsModified Method

Checks whether the document was modified by any command from the buffer since the last document saving or loading.

BOOL IsModified();
Returns

TRUE if any action was performed since last saving, FALSE otherwise.

See Also

MarkSaved

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::LimitDataSize Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::LimitDataSize Method

This member function used to check undo buffer data size and remove old stored commands to clear memory if data size limit is reached.

virtual void LimitDataSize(
    int nNewCommandData,
    int nDataSizeLimit
);
Parameters

nNewCommandData
The size of new undo command to be added (in bytes).
nDataSizeLimit
The maximum data size to store in undo buffer.

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::MarkSaved Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::MarkSaved Method

Marks current command buffer position as last saved. Used for the further calculating modified flag.

void MarkSaved();
See Also

IsModified

Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::SetGroupInsertMode Method

CXTPSyntaxEditUndoRedoManager Methods, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::SetGroupInsertMode Method

Group insert mode is required when a user is typing certain text in normal INS mode. In the time of undo/redo a group of text is undone in a single shot. This setting is cleared in the case of overwrite mode or while user presses SPACE, TAB, ENTER etc.

void SetGroupInsertMode(
    BOOL bInsertInGroup = TRUE
);
Parameters

bInsertInGroup
[in] Pass TRUE to switch group insert mode on, FALSE otherwise

See Also

ChainLastCommand

Group

CXTPSyntaxEditUndoRedoManager Methods


SetLastCommandText Method

CXTPSyntaxEditUndoRedoManager Methods
SetLastCommandText Method
Overload List
Methods
Method | Description
CXTPSyntaxEditUndoRedoManager::SetLastCommandText (LPCTSTR) | Changes the text for the last undo command in the stack.
CXTPSyntaxEditUndoRedoManager::SetLastCommandText (UINT) | Changes the text for the last undo command in the stack.
Group

CXTPSyntaxEditUndoRedoManager Methods


CXTPSyntaxEditUndoRedoManager::SetLastCommandText Method (LPCTSTR)

SetLastCommandText Method, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::SetLastCommandText Method (LPCTSTR)

Changes the text for the last undo command in the stack.

void SetLastCommandText(
    LPCTSTR szText
);
Parameters

szText
[in] A text to be set on the last undo command.

See Also

GetUndoTextList, GetRedoTextList

Group

SetLastCommandText Method


CXTPSyntaxEditUndoRedoManager::SetLastCommandText Method (UINT)

SetLastCommandText Method, CXTPSyntaxEditUndoRedoManager Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::SetLastCommandText Method (UINT)

Changes the text for the last undo command in the stack.

void SetLastCommandText(
    UINT nTextId
);
See Also

GetUndoTextList, GetRedoTextList

Group

SetLastCommandText Method


CXTPSyntaxEditUndoRedoManager Constructors

CXTPSyntaxEditUndoRedoManager Class, Legend, Public Methods
CXTPSyntaxEditUndoRedoManager Constructors
Class

CXTPSyntaxEditUndoRedoManager Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditUndoRedoManager | Creates the undo/redo manager object, initializes its members.


CXTPSyntaxEditUndoRedoManager::CXTPSyntaxEditUndoRedoManager Constructor

CXTPSyntaxEditUndoRedoManager Constructors, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::CXTPSyntaxEditUndoRedoManager Constructor

Creates the undo/redo manager object, initializes its members.

CXTPSyntaxEditUndoRedoManager();
Group

CXTPSyntaxEditUndoRedoManager Constructors


CXTPSyntaxEditUndoRedoManager Destructors

CXTPSyntaxEditUndoRedoManager Class, Legend, Public Methods
CXTPSyntaxEditUndoRedoManager Destructors
Class

CXTPSyntaxEditUndoRedoManager Class

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~CXTPSyntaxEditUndoRedoManager | Destroys the undo/redo manager object, handles its cleanup and de-allocation.


CXTPSyntaxEditUndoRedoManager::~CXTPSyntaxEditUndoRedoManager Destructor

CXTPSyntaxEditUndoRedoManager Destructors, CXTPSyntaxEditUndoRedoManager Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditUndoRedoManager::~CXTPSyntaxEditUndoRedoManager Destructor

Destroys the undo/redo manager object, handles its cleanup and de-allocation.

virtual ~CXTPSyntaxEditUndoRedoManager();
Group

CXTPSyntaxEditUndoRedoManager Destructors


CXTPSyntaxEditView Class

XTPSyntaxEditView.h, Classes, Legend, Members, Topics, CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Methods, CXTPSyntaxEditView Constructors, CXTPSyntaxEditView Destructors, CXTPSyntaxEditView Constructors, CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Destructors, CXTPSyntaxEditView Methods, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView Class

This class represents a View portion of the Edit Control. It extends functionality provided by CView class from MFC's document-view model implementation. CXTPSyntaxEditView class works together with CXTPSyntaxEditDoc and provides facilities for it to be displayed on a screen or printed on a printer.

Class Hierarchy

class CXTPSyntaxEditView : public CView;
File

XTPSyntaxEditView.h

See Also

CXTPSyntaxEditDoc

Group

Classes

Legend
Data Member
protected
Method
virtual
CXTPSyntaxEditView Constructors
CXTPSyntaxEditView Constructors | Description
CXTPSyntaxEditView | Protected object constructor. Used by dynamic creation.
CXTPSyntaxEditView Data Members
CXTPSyntaxEditView Data Members | Description
m_aPageStart | Stores Printed page start row indexes.
m_bDraggingOver | TRUE if dragover is going on, FALSE otherwise
m_bDraggingStartedHere | TRUE if dragging is started in this view, FALSE otherwise
m_bFilesDragging | TRUE when dragging files, FALSE otherwise.
m_bInitialUpdateWasCalled | Indicate that OnInitialUpdate was called.
m_bOleDragging | TRUE if OLE dragging is enabled, FALSE otherwise
m_bOnSizeRunning | Indicate that OnSize message handler is in progress.
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bResizeControlWithView | if FALSE - attached Calendar control will not be resized with view.
m_bScrollBars | Whether to create control with own scrollbars, or let to manage scrolling for parent window
m_dropTarget | OLE drop target
m_iTopRow | Top row for display
m_lfPrevFont | Temporarily stores editor font
m_nParserThreadPriority_WhenActive | Parser priority (active state).
m_nParserThreadPriority_WhenInactive | Parser priority (inactive state).
m_nPrevTopRow | Temporarily stores previous top row
m_pEditCtrl | Edit control instance
m_pFindReplaceDlg | Pointer to find or replace dialog.
m_pPrintOptions | Printing options.
m_szPage | Page size for printing or preview
m_wndEditCtrl | Default Edit control instance
ms_bDroppedHere | TRUE if text is dropped in this view, FALSE otherwise
ms_dwSignature | A signature used during drag-drop operation
ms_pTargetView | Target view pointer to be filled in by drag-drop routine
ms_ptDropPos | Stores drop mouse position.
CXTPSyntaxEditView Destructors
CXTPSyntaxEditView Destructors | Description
~CXTPSyntaxEditView | Destroys a CXTPSyntaxEditView() object, handles cleanup and de-allocation.
CXTPSyntaxEditView Methods
CXTPSyntaxEditView Methods | Description
CanChangeReadonlyFile | Overwrite this method to customize the read-only file handling
GetDataManager | Returns the edit buffer manager pointer.
GetDocument | Returns Document.
GetEditBuffer | Returns a buffer manager which maintains a buffer of a smart edit control.
GetEditCtrl | Returns the smart edit control pointer for this editor.
GetFindReplaceDlg | Returns pointer to the attached Find/Replace dialog object.
GetHorzScrollBar | Returns the if horizontal scrollbar is enabled.
GetLexConfigurationManager | Use this function to get associated configuration manager.
GetLexParser | Returns pointer to the associated lexical parser.
GetPageTitle | Used to get document title when printing.
GetPrintOptions | Call this method to access print options for this view.
GetSplitterView | Returns the view pointer of a certain pane of the splitter
GetTopRow | Return the topmost row.
GetVertScrollBar | Returns the if vertical scrollbar is enabled.
IsInitialUpdateWasCalled | Determines is initial update was made.
OnDrawBookmark | This function is a default handler for XTP_EDIT_NM_DRAWBOOKMARK message which sent before draw bookmark.
OnEditChanged | This function is a default handler for XTP_EDIT_NM_EDITCHANGED message which sent when editing applied.
OnEditChanging | This function is a default handler for XTP_EDIT_NM_EDITCHANGING message which sent before editing applied.
OnEnableScrollBar | This function is a default handler for XTP_EDIT_NM_ENABLESCROLLBAR message which sent scroll bar state changed.
OnInsertKey | This function is a default handler for XTP_EDIT_NM_INSERTKEY message which sent when 'Ins' (VK_INSERT) key down (insert mode changed).
OnMarginClicked | This function is a default handler for XTP_EDIT_NM_MARGINCLICKED message which sent when left mouse button clicked on bookmarks area.
OnParseEvent | This function is a default handler for XTP_EDIT_NM_PARSEEVENT message which reflect parser event.
OnRowColChanged | This function is a default handler for XTP_EDIT_NM_ROWCOLCHANGED message which sent current row or col changed.
OnSelInit | This function is a default handler for XTP_EDIT_NM_SELINIT message which sent when selection reseted.
OnSetDocModified | This function is a default handler for XTP_EDIT_NM_SETDOCMODIFIED message which sent when document (edit control) modified state changed.
OnStartOleDrag | This function is a default handler for XTP_EDIT_NM_STARTOLEDRAG message which sent when OLE dragging started.
OnUpdateScrollPos | This function is a default handler for XTP_EDIT_NM_UPDATESCROLLPOS message which sent scroll bar position changed.
Refresh | Refreshes the whole document, recalculates the scrollbar.
SetAutoIndent | Enable/disables auto indent.
SetDirty | Set the view ready for redraw.
SetEditCtrl | Set external smart edit control for the view.
SetFontIndirect | Set the font of the edit control pointer.
SetLineNumbers | Enable/Disable the line numbering.
SetScrollBars | Enable/disable scroll bar.
SetSelMargin | Enable/disables gutter.
SetSyntaxColor | Enable/disables syntax colorization.
SetTopRow | Set the current top row.
StartOleDrag | Starts OLE drag
UpdateAllViews | Updates all active sibling views.
UpdateScrollPos | Updates the sibling views while in split mode.
UpdateSiblings | Performs specific update for all sibling views.
UpdateSiblingScrollPos | Called when a sibling view is needed to be updated.


CXTPSyntaxEditView Data Members

CXTPSyntaxEditView Class, Legend, Protected Data Members, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView Data Members
Class

CXTPSyntaxEditView Class

Legend
Data Member
protected
Protected Data Members
Protected Data Member | Description
m_aPageStart | Stores Printed page start row indexes.
m_bDraggingOver | TRUE if dragover is going on, FALSE otherwise
m_bDraggingStartedHere | TRUE if dragging is started in this view, FALSE otherwise
m_bFilesDragging | TRUE when dragging files, FALSE otherwise.
m_bInitialUpdateWasCalled | Indicate that OnInitialUpdate was called.
m_bOleDragging | TRUE if OLE dragging is enabled, FALSE otherwise
m_bOnSizeRunning | Indicate that OnSize message handler is in progress.
m_bScrollBars | Whether to create control with own scrollbars, or let to manage scrolling for parent window
m_dropTarget | OLE drop target
m_iTopRow | Top row for display
m_lfPrevFont | Temporarily stores editor font
m_nParserThreadPriority_WhenActive | Parser priority (active state).
m_nParserThreadPriority_WhenInactive | Parser priority (inactive state).
m_nPrevTopRow | Temporarily stores previous top row
m_pEditCtrl | Edit control instance
m_pFindReplaceDlg | Pointer to find or replace dialog.
m_pPrintOptions | Printing options.
m_szPage | Page size for printing or preview
m_wndEditCtrl | Default Edit control instance
ms_bDroppedHere | TRUE if text is dropped in this view, FALSE otherwise
ms_dwSignature | A signature used during drag-drop operation
ms_pTargetView | Target view pointer to be filled in by drag-drop routine
ms_ptDropPos | Stores drop mouse position.
Public Data Members
Public Data Member | Description
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bResizeControlWithView | if FALSE - attached Calendar control will not be resized with view.


CXTPSyntaxEditView::m_aPageStart Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_aPageStart Data Member

Stores Printed page start row indexes.

CUIntArray m_aPageStart;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bDraggingOver Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bDraggingOver Data Member

TRUE if dragover is going on, FALSE otherwise

BOOL m_bDraggingOver;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bDraggingStartedHere Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bDraggingStartedHere Data Member

TRUE if dragging is started in this view, FALSE otherwise

BOOL m_bDraggingStartedHere;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bFilesDragging Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bFilesDragging Data Member

TRUE when dragging files, FALSE otherwise.

BOOL m_bFilesDragging;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bInitialUpdateWasCalled Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bInitialUpdateWasCalled Data Member

Indicate that OnInitialUpdate was called.

BOOL m_bInitialUpdateWasCalled;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bOleDragging Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bOleDragging Data Member

TRUE if OLE dragging is enabled, FALSE otherwise

BOOL m_bOleDragging;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bOnSizeRunning Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bOnSizeRunning Data Member

Indicate that OnSize message handler is in progress.

BOOL m_bOnSizeRunning;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bPrintDirect Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bPrintDirect Data Member

if TRUE - the Print Dialog is bypassed.

BOOL m_bPrintDirect;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bResizeControlWithView Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bResizeControlWithView Data Member

if FALSE - attached Calendar control will not be resized with view.

BOOL m_bResizeControlWithView;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_bScrollBars Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_bScrollBars Data Member

Whether to create control with own scrollbars, or let to manage scrolling for parent window

BOOL m_bScrollBars;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_dropTarget Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_dropTarget Data Member

OLE drop target

COleDropTarget m_dropTarget;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_iTopRow Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_iTopRow Data Member

Top row for display

int m_iTopRow;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_lfPrevFont Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_lfPrevFont Data Member

Temporarily stores editor font

LOGFONT m_lfPrevFont;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_nParserThreadPriority_WhenActive Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_nParserThreadPriority_WhenActive Data Member

Parser priority (active state).

int m_nParserThreadPriority_WhenActive;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_nParserThreadPriority_WhenInactive Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_nParserThreadPriority_WhenInactive Data Member

Parser priority (inactive state).

int m_nParserThreadPriority_WhenInactive;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_nPrevTopRow Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_nPrevTopRow Data Member

Temporarily stores previous top row

int m_nPrevTopRow;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_pEditCtrl Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_pEditCtrl Data Member

Edit control instance

CXTPSyntaxEditCtrl* m_pEditCtrl;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_pFindReplaceDlg Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_pFindReplaceDlg Data Member

Pointer to find or replace dialog.

CXTPSyntaxEditFindReplaceDlg* m_pFindReplaceDlg;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_pPrintOptions Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_pPrintOptions Data Member

Printing options.

CXTPSyntaxEditViewPrintOptions* m_pPrintOptions;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_szPage Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_szPage Data Member

Page size for printing or preview

CSize m_szPage;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::m_wndEditCtrl Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::m_wndEditCtrl Data Member

Default Edit control instance

CXTPSyntaxEditCtrl m_wndEditCtrl;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::ms_bDroppedHere Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::ms_bDroppedHere Data Member

TRUE if text is dropped in this view, FALSE otherwise

BOOL ms_bDroppedHere;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::ms_dwSignature Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::ms_dwSignature Data Member

A signature used during drag-drop operation

DWORD_PTR ms_dwSignature;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::ms_pTargetView Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::ms_pTargetView Data Member

Target view pointer to be filled in by drag-drop routine

CXTPSyntaxEditView * ms_pTargetView;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView::ms_ptDropPos Data Member

CXTPSyntaxEditView Data Members, CXTPSyntaxEditView Class
CXTPSyntaxEditView::ms_ptDropPos Data Member

Stores drop mouse position.

POINT ms_ptDropPos;
Group

CXTPSyntaxEditView Data Members


CXTPSyntaxEditView Methods

CXTPSyntaxEditView Class, Legend, Protected Methods, Public Methods
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView Methods
Class

CXTPSyntaxEditView Class

Legend
Method
protected
virtual
Protected Methods
Protected Methods
Protected Method | Description
CanChangeReadonlyFile | Overwrite this method to customize the read-only file handling
GetSplitterView | Returns the view pointer of a certain pane of the splitter
OnDrawBookmark | This function is a default handler for XTP_EDIT_NM_DRAWBOOKMARK message which sent before draw bookmark.
OnEditChanged | This function is a default handler for XTP_EDIT_NM_EDITCHANGED message which sent when editing applied.
OnEditChanging | This function is a default handler for XTP_EDIT_NM_EDITCHANGING message which sent before editing applied.
OnEnableScrollBar | This function is a default handler for XTP_EDIT_NM_ENABLESCROLLBAR message which sent scroll bar state changed.
OnInsertKey | This function is a default handler for XTP_EDIT_NM_INSERTKEY message which sent when 'Ins' (VK_INSERT) key down (insert mode changed).
OnMarginClicked | This function is a default handler for XTP_EDIT_NM_MARGINCLICKED message which sent when left mouse button clicked on bookmarks area.
OnParseEvent | This function is a default handler for XTP_EDIT_NM_PARSEEVENT message which reflect parser event.
OnRowColChanged | This function is a default handler for XTP_EDIT_NM_ROWCOLCHANGED message which sent current row or col changed.
OnSelInit | This function is a default handler for XTP_EDIT_NM_SELINIT message which sent when selection reseted.
OnSetDocModified | This function is a default handler for XTP_EDIT_NM_SETDOCMODIFIED message which sent when document (edit control) modified state changed.
OnStartOleDrag | This function is a default handler for XTP_EDIT_NM_STARTOLEDRAG message which sent when OLE dragging started.
OnUpdateScrollPos | This function is a default handler for XTP_EDIT_NM_UPDATESCROLLPOS message which sent scroll bar position changed.
StartOleDrag | Starts OLE drag
UpdateSiblings | Performs specific update for all sibling views.
UpdateSiblingScrollPos | Called when a sibling view is needed to be updated.
Public Methods
Public Methods
Public Method | Description
GetDataManager | Returns the edit buffer manager pointer.
GetDocument | Returns Document.
GetEditBuffer | Returns a buffer manager which maintains a buffer of a smart edit control.
GetEditCtrl | Returns the smart edit control pointer for this editor.
GetFindReplaceDlg | Returns pointer to the attached Find/Replace dialog object.
GetHorzScrollBar | Returns the if horizontal scrollbar is enabled.
GetLexConfigurationManager | Use this function to get associated configuration manager.
GetLexParser | Returns pointer to the associated lexical parser.
GetPageTitle | Used to get document title when printing.
GetPrintOptions | Call this method to access print options for this view.
GetTopRow | Return the topmost row.
GetVertScrollBar | Returns the if vertical scrollbar is enabled.
IsInitialUpdateWasCalled | Determines is initial update was made.
Refresh | Refreshes the whole document, recalculates the scrollbar.
SetAutoIndent | Enable/disables auto indent.
SetDirty | Set the view ready for redraw.
SetEditCtrl | Set external smart edit control for the view.
SetFontIndirect | Set the font of the edit control pointer.
SetLineNumbers | Enable/Disable the line numbering.
SetScrollBars | Enable/disable scroll bar.
SetSelMargin | Enable/disables gutter.
SetSyntaxColor | Enable/disables syntax colorization.
SetTopRow | Set the current top row.
UpdateAllViews | Updates all active sibling views.
UpdateScrollPos | Updates the sibling views while in split mode.


CXTPSyntaxEditView::CanChangeReadonlyFile Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::CanChangeReadonlyFile Method

Overwrite this method to customize the read-only file handling

virtual BOOL CanChangeReadonlyFile();
Returns

TRUE if read-only file can be changed, FALSE otherwise

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetDataManager Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::GetDataManager Method

Returns the edit buffer manager pointer.

CXTPSyntaxEditBufferManager * GetDataManager();
Returns

Buffer manager pointer.

See Also

class CXTPSyntaxEditBufferManager

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetDocument Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::GetDocument Method

Returns Document.

CXTPSyntaxEditDoc* GetDocument();
Returns

Pointer to CXTPSyntaxEditDoc.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetEditBuffer Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::GetEditBuffer Method

Returns a buffer manager which maintains a buffer of a smart edit control.

CXTPSyntaxEditBufferManager* GetEditBuffer();
Returns

Pointer to the CXTPSyntaxEditBufferManager object.

Body Source
CXTPSyntaxEditBufferManager* CXTPSyntaxEditView::GetEditBuffer() {
    return GetEditCtrl().GetEditBuffer();
}
Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetEditCtrl Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::GetEditCtrl Method

Returns the smart edit control pointer for this editor.

virtual CXTPSyntaxEditCtrl& GetEditCtrl();
Returns

Edit control pointer.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetFindReplaceDlg Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::GetFindReplaceDlg Method

Returns pointer to the attached Find/Replace dialog object.

virtual CXTPSyntaxEditFindReplaceDlg* GetFindReplaceDlg();
Returns

Pointer to a CXTPSyntaxEditFindReplaceDlg object.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetHorzScrollBar Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::GetHorzScrollBar Method

Returns the if horizontal scrollbar is enabled.

BOOL GetHorzScrollBar();
Returns

TRUE if horizontal scrollbar is enabled, FALSE otherwise.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetLexConfigurationManager Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::GetLexConfigurationManager Method

Use this function to get associated configuration manager.

CXTPSyntaxEditConfigurationManager* GetLexConfigurationManager();
Returns

Pointer to the associated configuration manager.

Body Source
CXTPSyntaxEditConfigurationManager* CXTPSyntaxEditView::GetLexConfigurationManager() {
    return GetEditCtrl().GetLexConfigurationManager();
}
Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetLexParser Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::GetLexParser Method

Returns pointer to the associated lexical parser.

XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser* GetLexParser();
Returns

Pointer to a XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser object.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetPageTitle Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::GetPageTitle Method

Used to get document title when printing.

virtual CString GetPageTitle();
Returns

Returns document title string.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetPrintOptions Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::GetPrintOptions Method

Call this method to access print options for this view.

CXTPSyntaxEditViewPrintOptions* GetPrintOptions();
Returns

Pointer to an object describing print options of this view.

Body Source
CXTPSyntaxEditViewPrintOptions* CXTPSyntaxEditView::GetPrintOptions() {
    return m_pPrintOptions;
}
Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetSplitterView Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::GetSplitterView Method

Returns the view pointer of a certain pane of the splitter

CXTPSyntaxEditView* GetSplitterView(
    int nRow,
    int nCol
);
Parameters

nRow
[in] Row of the splitter frame.
nCol
[in] Column of the splitter frame.

Returns

Pointer to CXTPSyntaxEditView.

See Also

class CXTPSyntaxEditView

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetTopRow Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::GetTopRow Method

Return the topmost row.

int GetTopRow();
Returns

The top row integer identifier.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::GetVertScrollBar Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::GetVertScrollBar Method

Returns the if vertical scrollbar is enabled.

BOOL GetVertScrollBar();
Returns

TRUE if vertical scrollbar is enabled, FALSE otherwise.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::IsInitialUpdateWasCalled Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::IsInitialUpdateWasCalled Method

Determines is initial update was made.

BOOL IsInitialUpdateWasCalled();
Returns

TRUE if initial update was made; FALSE otherwise.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnDrawBookmark Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnDrawBookmark Method

This function is a default handler for XTP_EDIT_NM_DRAWBOOKMARK message which sent before draw bookmark.

virtual BOOL OnDrawBookmark(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to XTP_EDIT_SENMBOOKMARK structure.
pResult
[out] Pointer to a LRESULT value. Set as TRUE to cancel default processing (bookmark drawing), or FALSE to allow default processing.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_DRAWBOOKMARK, XTP_EDIT_SENMBOOKMARK

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnEditChanged Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnEditChanged Method

This function is a default handler for XTP_EDIT_NM_EDITCHANGED message which sent when editing applied.

virtual BOOL OnEditChanged(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to XTP_EDIT_NMHDR_EDITCHANGED structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_EDITCHANGING, XTP_EDIT_NM_EDITCHANGED, XTP_EDIT_NMHDR_EDITCHANGED

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnEditChanging Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnEditChanging Method

This function is a default handler for XTP_EDIT_NM_EDITCHANGING message which sent before editing applied.

virtual BOOL OnEditChanging(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to NMHDR structure.
pResult
[out] Pointer to a LRESULT value. Set as TRUE to cancel editing or FALSE to allow editing.

Returns

TRUE is message handled, FALSE otherwise.

See Also

OnEditChanged, XTP_EDIT_NM_EDITCHANGING, XTP_EDIT_NM_EDITCHANGED

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnEnableScrollBar Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnEnableScrollBar Method

This function is a default handler for XTP_EDIT_NM_ENABLESCROLLBAR message which sent scroll bar state changed.

virtual BOOL OnEnableScrollBar(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to XTP_EDIT_NMHDR_ENABLESCROLLBAR structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_ENABLESCROLLBAR

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnInsertKey Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnInsertKey Method

This function is a default handler for XTP_EDIT_NM_INSERTKEY message which sent when 'Ins' (VK_INSERT) key down (insert mode changed).

virtual BOOL OnInsertKey(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to NMHDR structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_INSERTKEY

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnMarginClicked Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnMarginClicked Method

This function is a default handler for XTP_EDIT_NM_MARGINCLICKED message which sent when left mouse button clicked on bookmarks area.

virtual BOOL OnMarginClicked(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to XTP_EDIT_NMHDR_MARGINCLICKED structure.
pResult
[out] Pointer to a LRESULT value. Set as TRUE to cancel default processing (breakpoint set/reset), or FALSE to allow default processing.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_MARGINCLICKED, XTP_EDIT_NMHDR_MARGINCLICKED

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnParseEvent Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnParseEvent Method

This function is a default handler for XTP_EDIT_NM_PARSEEVENT message which reflect parser event.

virtual BOOL OnParseEvent(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to XTP_EDIT_NMHDR_PARSEEVENT structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_PARSEEVENT, XTP_EDIT_NMHDR_PARSEEVENT

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnRowColChanged Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnRowColChanged Method

This function is a default handler for XTP_EDIT_NM_ROWCOLCHANGED message which sent current row or col changed.

virtual BOOL OnRowColChanged(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to XTP_EDIT_NMHDR_ROWCOLCHANGED structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_ROWCOLCHANGED, XTP_EDIT_NMHDR_ROWCOLCHANGED

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnSelInit Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnSelInit Method

This function is a default handler for XTP_EDIT_NM_SELINIT message which sent when selection reseted.

virtual BOOL OnSelInit(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to NMHDR structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_SELINIT

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnSetDocModified Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnSetDocModified Method

This function is a default handler for XTP_EDIT_NM_SETDOCMODIFIED message which sent when document (edit control) modified state changed.

virtual BOOL OnSetDocModified(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to XTP_EDIT_NMHDR_DOCMODIFIED structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_SETDOCMODIFIED, XTP_EDIT_NMHDR_DOCMODIFIED

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnStartOleDrag Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnStartOleDrag Method

This function is a default handler for XTP_EDIT_NM_STARTOLEDRAG message which sent when OLE dragging started.

virtual BOOL OnStartOleDrag(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to NMHDR structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_STARTOLEDRAG

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::OnUpdateScrollPos Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::OnUpdateScrollPos Method

This function is a default handler for XTP_EDIT_NM_UPDATESCROLLPOS message which sent scroll bar position changed.

virtual BOOL OnUpdateScrollPos(
    NMHDR* pNMHDR,
    LRESULT* pResult
);
Parameters

pNMHDR
[in] Pointer to XTP_EDIT_NM_UPDATESCROLLPOS structure.
pResult
unused for this handler.

Returns

TRUE is message handled, FALSE otherwise.

See Also

XTP_EDIT_NM_UPDATESCROLLPOS

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::Refresh Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::Refresh Method

Refreshes the whole document, recalculates the scrollbar.

void Refresh();
Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetAutoIndent Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::SetAutoIndent Method

Enable/disables auto indent.

void SetAutoIndent(
    BOOL bEnable
);
Parameters

bEnable
[in] Pass TRUE/FALSE if auto indent is to be enabled/disbaled.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetDirty Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::SetDirty Method

Set the view ready for redraw.

void SetDirty();
Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetEditCtrl Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::SetEditCtrl Method

Set external smart edit control for the view.

virtual void SetEditCtrl(
    CXTPSyntaxEditCtrl* pControl
);
Parameters

pControl
A pointer to smart edit control object.

Remarks

Default edit control window is destroyed. InternalRelease will be called for external control object in the view object destructor.

See Also

GetEditCtrl

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetFontIndirect Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::SetFontIndirect Method

Set the font of the edit control pointer.

void SetFontIndirect(
    LOGFONT * pLogFont,
    BOOL bUpdateReg = FALSE
);
Parameters

bUpdateReg
[in] Set TRUE to save font in registry.
pLogfont
[in] The LOGFONT pointer to be set.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetLineNumbers Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::SetLineNumbers Method

Enable/Disable the line numbering.

void SetLineNumbers(
    BOOL bEnable
);
Parameters

bEnable
[in] The LOGFONT pointer to be set.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetScrollBars Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::SetScrollBars Method

Enable/disable scroll bar.

BOOL SetScrollBars(
    BOOL bHorz,
    BOOL bVert,
    BOOL bUpdateReg = FALSE,
    BOOL bRecalcLayout = TRUE
);
Parameters

bHorz
[in] TRUE if horizontal scroll bar need to be enabled/disabled.
bVert
[in] TRUE if vertical scroll bar need to be enabled/disabled.
bUpdateReg
[in] Set TRUE to save these options in registry.
bRecalcLayout
[in] Set TRUE to recalculate layout.

Returns

TRUE if scrollbars were updated, FALSE otherwise.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetSelMargin Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::SetSelMargin Method

Enable/disables gutter.

void SetSelMargin(
    BOOL bEnable
);
Parameters

bEnable
[in] Pass TRUE/FALSE if gutter is to be enabled/disbaled.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetSyntaxColor Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::SetSyntaxColor Method

Enable/disables syntax colorization.

void SetSyntaxColor(
    BOOL bEnable
);
Parameters

bEnable
[in] Pass TRUE/FALSE if syntax color is to be enabled/disbaled.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::SetTopRow Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::SetTopRow Method

Set the current top row.

BOOL SetTopRow(
    int iRow
);
Parameters

iRow
[in] Row to set as top row.

Returns

TRUE if successful, FALSE otherwise.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::StartOleDrag Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::StartOleDrag Method

Starts OLE drag

void StartOleDrag();
Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::UpdateAllViews Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::UpdateAllViews Method

Updates all active sibling views.

void UpdateAllViews();
Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::UpdateScrollPos Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::UpdateScrollPos Method

Updates the sibling views while in split mode.

void UpdateScrollPos(
    CView* pSender,
    DWORD dwUpdate = XTP_EDIT_UPDATE_ALL
);
Parameters

pSender
[in] Pointer to a sender object (or NULL).
dwUpdate
[in] Specifies the view update flags.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::UpdateSiblings Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class
CXTPSyntaxEditView::UpdateSiblings Method

Performs specific update for all sibling views.

void UpdateSiblings(
    XTP_EDIT_NMHDR_EDITCHANGED* pNMHDR_EC = NULL,
    BOOL bTextChanged = TRUE
);
Parameters

pNMHDR_EC
[in] Pointer to the parameters header.
bTextChanged
[in] This parameters is TRUE if document text was changed, FALSE otherwise.

Remarks

This method process events from parser, updates the editing results or selection for all sibling views. It is called when an user edits text or switches between views or parser is running.

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView::UpdateSiblingScrollPos Method

CXTPSyntaxEditView Methods, CXTPSyntaxEditView Class, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditView::UpdateSiblingScrollPos Method

Called when a sibling view is needed to be updated.

void UpdateSiblingScrollPos(
    CXTPSyntaxEditView* pSender,
    DWORD dwUpdate
);
Parameters

pSender
[in] The source to be updated from
dwUpdate
[in] Type of update. Allowed values are: XTP_EDIT_UPDATE_HORZ, XTP_EDIT_UPDATE_VERT, XTP_EDIT_UPDATE_DIAG.

See Also

class CXTPSyntaxEditView

Group

CXTPSyntaxEditView Methods


CXTPSyntaxEditView Constructors

CXTPSyntaxEditView Class, Legend, Protected Methods
CXTPSyntaxEditView Constructors
Class

CXTPSyntaxEditView Class

Legend
Constructor
protected
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSyntaxEditView | Protected object constructor. Used by dynamic creation.


CXTPSyntaxEditView::CXTPSyntaxEditView Constructor

CXTPSyntaxEditView Constructors, CXTPSyntaxEditView Class
CXTPSyntaxEditView::CXTPSyntaxEditView Constructor

Protected object constructor. Used by dynamic creation.

CXTPSyntaxEditView();
Group

CXTPSyntaxEditView Constructors


CXTPSyntaxEditView Destructors

CXTPSyntaxEditView Class, Legend, Protected Methods
CXTPSyntaxEditView Destructors
Class

CXTPSyntaxEditView Class

Legend
Destructor
protected
virtual
Protected Methods
Protected Destructors
Protected Destructor | Description
~CXTPSyntaxEditView | Destroys a CXTPSyntaxEditView() object, handles cleanup and de-allocation.


CXTPSyntaxEditView::~CXTPSyntaxEditView Destructor

CXTPSyntaxEditView Destructors, CXTPSyntaxEditView Class
CXTPSyntaxEditView::~CXTPSyntaxEditView Destructor

Destroys a CXTPSyntaxEditView() object, handles cleanup and de-allocation.

virtual ~CXTPSyntaxEditView();
Group

CXTPSyntaxEditView Destructors


CXTPSyntaxEditViewPrintOptions Class

XTPSyntaxEditView.h, Classes, Legend, Members, Topics, CXTPSyntaxEditViewPrintOptions Constructors, CXTPSyntaxEditViewPrintOptions Constructors, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditViewPrintOptions Class

Describes printing options for the Calendar Control.

Class Hierarchy

class CXTPSyntaxEditViewPrintOptions : public CXTPPrintOptions;
File

XTPSyntaxEditView.h

Remarks

Use this class when you want to programmatically customize printing options for the Calendar control.

See each property description to examine which customization options are available.

See Also

CXTPPrintOptions

Group

Classes

Legend
Constructor
CXTPSyntaxEditViewPrintOptions Constructors
CXTPSyntaxEditViewPrintOptions Constructors | Description
CXTPSyntaxEditViewPrintOptions | Default constructor.


CXTPSyntaxEditViewPrintOptions Constructors

CXTPSyntaxEditViewPrintOptions Class, Legend, Public Methods
CXTPSyntaxEditViewPrintOptions Constructors
Class

CXTPSyntaxEditViewPrintOptions Class

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditViewPrintOptions | Default constructor.


CXTPSyntaxEditViewPrintOptions::CXTPSyntaxEditViewPrintOptions Constructor

CXTPSyntaxEditViewPrintOptions Constructors, CXTPSyntaxEditViewPrintOptions Class
Xtreme Toolkit Pro v12.0
Previous | Up | Next
CXTPSyntaxEditViewPrintOptions::CXTPSyntaxEditViewPrintOptions Constructor

Default constructor.

CXTPSyntaxEditViewPrintOptions();
Group

CXTPSyntaxEditViewPrintOptions Constructors


XTP_EDIT_ACDATA Structure

XTPSyntaxEditAutoCompleteWnd.h, Classes, Legend, Members, Topics, XTP_EDIT_ACDATA Data Members, XTP_EDIT_ACDATA Constructors, XTP_EDIT_ACDATA Constructors, XTP_EDIT_ACDATA Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_ACDATA Structure

XTP_EDIT_ACDATA structure defines items displayed data. Provides text and icon for each displayed line in Auto-complete window.

Class Hierarchy

struct XTP_EDIT_ACDATA {
  int m_nIcon;
  CString m_strText;
};
File

XTPSyntaxEditAutoCompleteWnd.h

Group

Classes

Legend
Data Member
Constructor
XTP_EDIT_ACDATA Constructors
XTP_EDIT_ACDATA Constructors | Description
XTP_EDIT_ACDATA | Default class constructor.
XTP_EDIT_ACDATA Data Members
XTP_EDIT_ACDATA Data Members | Description
m_nIcon | The icon ID.
m_strText | The item text.


XTP_EDIT_ACDATA Data Members

XTP_EDIT_ACDATA Structure, Legend, Public Data Members
XTP_EDIT_ACDATA Data Members
Structure

XTP_EDIT_ACDATA Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
m_nIcon | The icon ID.
m_strText | The item text.


XTP_EDIT_ACDATA::m_nIcon Data Member

XTP_EDIT_ACDATA Data Members, XTP_EDIT_ACDATA Structure
XTP_EDIT_ACDATA::m_nIcon Data Member

The icon ID.

int m_nIcon;
Group

XTP_EDIT_ACDATA Data Members


XTP_EDIT_ACDATA::m_strText Data Member

XTP_EDIT_ACDATA Data Members, XTP_EDIT_ACDATA Structure
XTP_EDIT_ACDATA::m_strText Data Member

The item text.

CString m_strText;
Group

XTP_EDIT_ACDATA Data Members


XTP_EDIT_ACDATA Constructors

XTP_EDIT_ACDATA Structure, Legend, Public Methods
XTP_EDIT_ACDATA Constructors
Structure

XTP_EDIT_ACDATA Structure

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
XTP_EDIT_ACDATA | Default class constructor.


XTP_EDIT_ACDATA::XTP_EDIT_ACDATA Constructor

XTP_EDIT_ACDATA Constructors, XTP_EDIT_ACDATA Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_ACDATA::XTP_EDIT_ACDATA Constructor

Default class constructor.

XTP_EDIT_ACDATA(
    int nIcon,
    CString strText
);
Parameters

nIcon
The icon ID.
strText
The item text.

Body Source
XTP_EDIT_ACDATA(int nIcon, CString strText)
{
    m_nIcon = nIcon;
    m_strText = strText;
}
Group

XTP_EDIT_ACDATA Constructors


XTP_EDIT_COLLAPSEDBLOCK Structure

XTPSyntaxEditStruct.h, Classes, Legend, Members, Topics, XTP_EDIT_COLLAPSEDBLOCK Data Members, XTP_EDIT_COLLAPSEDBLOCK Destructors, XTP_EDIT_COLLAPSEDBLOCK Operators, XTP_EDIT_COLLAPSEDBLOCK Data Members, XTP_EDIT_COLLAPSEDBLOCK Destructors, XTP_EDIT_COLLAPSEDBLOCK Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLLAPSEDBLOCK Structure

Stores collapsed block parameters.

Class Hierarchy

struct XTP_EDIT_COLLAPSEDBLOCK {
  XTP_EDIT_ROWSBLOCK collBlock;
  CRect rcCollMark;
};
File

XTPSyntaxEditStruct.h

See Also

XTP_EDIT_ROWSBLOCK

Group

Classes

Legend
Data Member
Destructor
virtual
Operator
XTP_EDIT_COLLAPSEDBLOCK Data Members
XTP_EDIT_COLLAPSEDBLOCK Data Members | Description
collBlock | Collapsed block parameters
rcCollMark | Rectangle area to display collapsed block mark.
XTP_EDIT_COLLAPSEDBLOCK Destructors
XTP_EDIT_COLLAPSEDBLOCK Destructors | Description
~XTP_EDIT_COLLAPSEDBLOCK | Default destructor.Handles clean up and deallocation.
XTP_EDIT_COLLAPSEDBLOCK Operators
XTP_EDIT_COLLAPSEDBLOCK Operators | Description
= | Assign operator.


XTP_EDIT_COLLAPSEDBLOCK Data Members

XTP_EDIT_COLLAPSEDBLOCK Structure, Legend, Public Data Members
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLLAPSEDBLOCK Data Members
Structure

XTP_EDIT_COLLAPSEDBLOCK Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
collBlock | Collapsed block parameters
rcCollMark | Rectangle area to display collapsed block mark.


XTP_EDIT_COLLAPSEDBLOCK::collBlock Data Member

XTP_EDIT_COLLAPSEDBLOCK Data Members, XTP_EDIT_COLLAPSEDBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLLAPSEDBLOCK::collBlock Data Member

Collapsed block parameters

XTP_EDIT_ROWSBLOCK collBlock;
Group

XTP_EDIT_COLLAPSEDBLOCK Data Members


XTP_EDIT_COLLAPSEDBLOCK::rcCollMark Data Member

XTP_EDIT_COLLAPSEDBLOCK Data Members, XTP_EDIT_COLLAPSEDBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLLAPSEDBLOCK::rcCollMark Data Member

Rectangle area to display collapsed block mark.

CRect rcCollMark;
Group

XTP_EDIT_COLLAPSEDBLOCK Data Members


XTP_EDIT_COLLAPSEDBLOCK Destructors

XTP_EDIT_COLLAPSEDBLOCK Structure, Legend, Public Methods
XTP_EDIT_COLLAPSEDBLOCK Destructors
Structure

XTP_EDIT_COLLAPSEDBLOCK Structure

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~XTP_EDIT_COLLAPSEDBLOCK | Default destructor.Handles clean up and deallocation.


XTP_EDIT_COLLAPSEDBLOCK::~XTP_EDIT_COLLAPSEDBLOCK Destructor

XTP_EDIT_COLLAPSEDBLOCK Destructors, XTP_EDIT_COLLAPSEDBLOCK Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLLAPSEDBLOCK::~XTP_EDIT_COLLAPSEDBLOCK Destructor

Default destructor.Handles clean up and deallocation.

virtual ~XTP_EDIT_COLLAPSEDBLOCK();
Body Source
virtual ~XTP_EDIT_COLLAPSEDBLOCK(){}
Group

XTP_EDIT_COLLAPSEDBLOCK Destructors


XTP_EDIT_COLLAPSEDBLOCK Operators

XTP_EDIT_COLLAPSEDBLOCK Structure, Legend, Public Operators
XTP_EDIT_COLLAPSEDBLOCK Operators
Structure

XTP_EDIT_COLLAPSEDBLOCK Structure

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Assign operator.


XTP_EDIT_COLLAPSEDBLOCK::= Operator

XTP_EDIT_COLLAPSEDBLOCK Operators, XTP_EDIT_COLLAPSEDBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLLAPSEDBLOCK::= Operator

Assign operator.

const XTP_EDIT_COLLAPSEDBLOCK& operator =(
    const XTP_EDIT_COLLAPSEDBLOCK& src
);
Parameters

src
[in] Reference to source structure.

Returns

Reference to XTP_EDIT_COLORVALUES struct.

Group

XTP_EDIT_COLLAPSEDBLOCK Operators


XTP_EDIT_COLORVALUES Structure

XTPSyntaxEditStruct.h, Classes, Legend, Members, Topics, XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Methods, XTP_EDIT_COLORVALUES Operators, XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Methods, XTP_EDIT_COLORVALUES Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES Structure

XTP_EDIT_COLORVALUES struct stores the colors for different phrases

Class Hierarchy

struct XTP_EDIT_COLORVALUES {
  CXTPPaintManagerColor crText;
  CXTPPaintManagerColor crBack;
  CXTPPaintManagerColor crReadOnlyBack;
  CXTPPaintManagerColor crHiliteText;
  CXTPPaintManagerColor crHiliteBack;
  CXTPPaintManagerColor crInactiveHiliteText;
  CXTPPaintManagerColor crInactiveHiliteBack;
  CXTPPaintManagerColor crLineNumberText;
  CXTPPaintManagerColor crLineNumberBack;
};
File

XTPSyntaxEditStruct.h

Group

Classes

Legend
Data Member
Method
Operator
XTP_EDIT_COLORVALUES Data Members
XTP_EDIT_COLORVALUES Data Members | Description
crBack | back color
crHiliteBack | text color of selection back
crHiliteText | text color of selection
crInactiveHiliteBack | inactive text color of selection back
crInactiveHiliteText | inactive text color of selection
crLineNumberBack | Line numbers text and line color
crLineNumberText | Line numbers text and line color
crReadOnlyBack | back color for read only mode
crText | text color
XTP_EDIT_COLORVALUES Methods
XTP_EDIT_COLORVALUES Methods | Description
GetBackColorEx | Get corresponding background color for edit mode or for read-only mode (crBack or crReadOnlyBack member value).
XTP_EDIT_COLORVALUES Operators
XTP_EDIT_COLORVALUES Operators | Description
= | Assign operator needed for working with CList.


XTP_EDIT_COLORVALUES Data Members

XTP_EDIT_COLORVALUES Structure, Legend, Public Data Members
XTP_EDIT_COLORVALUES Data Members
Structure

XTP_EDIT_COLORVALUES Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
crBack | back color
crHiliteBack | text color of selection back
crHiliteText | text color of selection
crInactiveHiliteBack | inactive text color of selection back
crInactiveHiliteText | inactive text color of selection
crLineNumberBack | Line numbers text and line color
crLineNumberText | Line numbers text and line color
crReadOnlyBack | back color for read only mode
crText | text color


XTP_EDIT_COLORVALUES::crBack Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crBack Data Member

back color

CXTPPaintManagerColor crBack;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES::crHiliteBack Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crHiliteBack Data Member

text color of selection back

CXTPPaintManagerColor crHiliteBack;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES::crHiliteText Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crHiliteText Data Member

text color of selection

CXTPPaintManagerColor crHiliteText;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES::crInactiveHiliteBack Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crInactiveHiliteBack Data Member

inactive text color of selection back

CXTPPaintManagerColor crInactiveHiliteBack;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES::crInactiveHiliteText Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crInactiveHiliteText Data Member

inactive text color of selection

CXTPPaintManagerColor crInactiveHiliteText;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES::crLineNumberBack Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crLineNumberBack Data Member

Line numbers text and line color

CXTPPaintManagerColor crLineNumberBack;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES::crLineNumberText Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crLineNumberText Data Member

Line numbers text and line color

CXTPPaintManagerColor crLineNumberText;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES::crReadOnlyBack Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crReadOnlyBack Data Member

back color for read only mode

CXTPPaintManagerColor crReadOnlyBack;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES::crText Data Member

XTP_EDIT_COLORVALUES Data Members, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::crText Data Member

text color

CXTPPaintManagerColor crText;
Group

XTP_EDIT_COLORVALUES Data Members


XTP_EDIT_COLORVALUES Methods

XTP_EDIT_COLORVALUES Structure, Legend, Public Methods
XTP_EDIT_COLORVALUES Methods
Structure

XTP_EDIT_COLORVALUES Structure

Legend
Method
Public Methods
Public Methods
Public Method | Description
GetBackColorEx | Get corresponding background color for edit mode or for read-only mode (crBack or crReadOnlyBack member value).


XTP_EDIT_COLORVALUES::GetBackColorEx Method

XTP_EDIT_COLORVALUES Methods, XTP_EDIT_COLORVALUES Structure, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::GetBackColorEx Method

Get corresponding background color for edit mode or for read-only mode (crBack or crReadOnlyBack member value).

COLORREF GetBackColorEx(
    CXTPSyntaxEditCtrl* pEditCtrl
);
Returns

Background color.

See Also

crBack, crReadOnlyBack

Group

XTP_EDIT_COLORVALUES Methods


XTP_EDIT_COLORVALUES Operators

XTP_EDIT_COLORVALUES Structure, Legend, Public Operators
XTP_EDIT_COLORVALUES Operators
Structure

XTP_EDIT_COLORVALUES Structure

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Assign operator needed for working with CList.


XTP_EDIT_COLORVALUES::= Operator

XTP_EDIT_COLORVALUES Operators, XTP_EDIT_COLORVALUES Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_COLORVALUES::= Operator

Assign operator needed for working with CList.

const XTP_EDIT_COLORVALUES& operator =(
    const XTP_EDIT_COLORVALUES& src
);
Parameters

src
[in] Reference to source structure.

Returns

Reference to XTP_EDIT_COLORVALUES struct.

Group

XTP_EDIT_COLORVALUES Operators


XTP_EDIT_FONTOPTIONS Structure

XTPSyntaxEditStruct.h, Classes, Legend, Members, Topics, XTP_EDIT_FONTOPTIONS Constructors, XTP_EDIT_FONTOPTIONS Operators, XTP_EDIT_FONTOPTIONS Constructors, XTP_EDIT_FONTOPTIONS Operators, See Also
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_FONTOPTIONS Structure

XTP_EDIT_FONTOPTIONS struct is a self initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length.

Class Hierarchy

struct XTP_EDIT_FONTOPTIONS : public LOGFONT {
};
File

XTPSyntaxEditStruct.h

See Also

XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION

Group

Classes

Legend
Constructor
Operator
XTP_EDIT_FONTOPTIONS Constructors
XTP_EDIT_FONTOPTIONS Constructors | Description
XTP_EDIT_FONTOPTIONS | Default constructor.
XTP_EDIT_FONTOPTIONS Operators
XTP_EDIT_FONTOPTIONS Operators | Description
= | Assign operator.


XTP_EDIT_FONTOPTIONS Constructors

XTP_EDIT_FONTOPTIONS Structure, Legend, Public Methods
XTP_EDIT_FONTOPTIONS Constructors
Structure

XTP_EDIT_FONTOPTIONS Structure

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
XTP_EDIT_FONTOPTIONS | Default constructor.


XTP_EDIT_FONTOPTIONS::XTP_EDIT_FONTOPTIONS Constructor

XTP_EDIT_FONTOPTIONS Constructors, XTP_EDIT_FONTOPTIONS Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_FONTOPTIONS::XTP_EDIT_FONTOPTIONS Constructor

Default constructor.

XTP_EDIT_FONTOPTIONS();
Group

XTP_EDIT_FONTOPTIONS Constructors


XTP_EDIT_FONTOPTIONS Operators

XTP_EDIT_FONTOPTIONS Structure, Legend, Public Operators
XTP_EDIT_FONTOPTIONS Operators
Structure

XTP_EDIT_FONTOPTIONS Structure

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Assign operator.


XTP_EDIT_FONTOPTIONS::= Operator

XTP_EDIT_FONTOPTIONS Operators, XTP_EDIT_FONTOPTIONS Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_FONTOPTIONS::= Operator

Assign operator.

const XTP_EDIT_FONTOPTIONS& operator =(
    const XTP_EDIT_FONTOPTIONS& src
);
Parameters

src
[in] Reference to source structure.

Returns

Reference to XTP_EDIT_FONTOPTIONS struct.

Group

XTP_EDIT_FONTOPTIONS Operators


XTP_EDIT_LINECOL Structure

XTPSyntaxEditStruct.h, Classes, Legend, Members, Topics, XTP_EDIT_LINECOL Data Members, XTP_EDIT_LINECOL Methods, XTP_EDIT_LINECOL Operators, XTP_EDIT_LINECOL Data Members, XTP_EDIT_LINECOL Methods, XTP_EDIT_LINECOL Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_LINECOL Structure

XTP_EDIT_LINECOL structure represents coordinates of text items on the displaying context in terms of line/column.

Class Hierarchy

struct XTP_EDIT_LINECOL {
  int nLine;
  int nCol;
  const XTP_EDIT_LINECOL MAXPOS;
  const XTP_EDIT_LINECOL MINPOS;
  const XTP_EDIT_LINECOL Pos1;
};
File

XTPSyntaxEditStruct.h

Group

Classes

Legend
Data Member
Method
Operator
XTP_EDIT_LINECOL Data Members
XTP_EDIT_LINECOL Data Members | Description
MAXPOS | maximum position value
MINPOS | minimum position value
nCol | stores column identifier
nLine | stores line identifier
Pos1 | 1,0} position value
XTP_EDIT_LINECOL Methods
XTP_EDIT_LINECOL Methods | Description
Clear | Clears data members.
GetXLC | Returns coordinates in the packed form.
IsValidData | Returns data validation flag.
MakeLineCol | Constructs XTP_EDIT_LINECOL from the pair of coordinates (line and column).
max2 | This static functions are used to get minimum or maximum of 2 XTP_EDIT_LINECOL values.
min2 | This static functions are used to get minimum or maximum of 2 XTP_EDIT_LINECOL values.
XTP_EDIT_LINECOL Operators
XTP_EDIT_LINECOL Operators | Description
!= | Not Equal operator. Compares current struct with given.
< | Less than operator. Compares current struct with given.
<= | Less than or equal operator. Compares current struct with given.
== | Equal operator. Compares current struct with given.
> | Greater than operator. Compares current struct with given.
>= | Greater or equal operator. Compares current struct with given.


XTP_EDIT_LINECOL Data Members

XTP_EDIT_LINECOL Structure, Legend, Public Data Members
XTP_EDIT_LINECOL Data Members
Structure

XTP_EDIT_LINECOL Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
MAXPOS | maximum position value
MINPOS | minimum position value
nCol | stores column identifier
nLine | stores line identifier
Pos1 | 1,0} position value


XTP_EDIT_LINECOL::MAXPOS Data Member

XTP_EDIT_LINECOL Data Members, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::MAXPOS Data Member

maximum position value

const XTP_EDIT_LINECOL MAXPOS;
Group

XTP_EDIT_LINECOL Data Members


XTP_EDIT_LINECOL::MINPOS Data Member

XTP_EDIT_LINECOL Data Members, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::MINPOS Data Member

minimum position value

const XTP_EDIT_LINECOL MINPOS;
Group

XTP_EDIT_LINECOL Data Members


XTP_EDIT_LINECOL::nCol Data Member

XTP_EDIT_LINECOL Data Members, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::nCol Data Member

stores column identifier

int nCol;
Group

XTP_EDIT_LINECOL Data Members


XTP_EDIT_LINECOL::nLine Data Member

XTP_EDIT_LINECOL Data Members, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::nLine Data Member

stores line identifier

int nLine;
Group

XTP_EDIT_LINECOL Data Members


XTP_EDIT_LINECOL::Pos1 Data Member

XTP_EDIT_LINECOL Data Members, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::Pos1 Data Member

1,0} position value

const XTP_EDIT_LINECOL Pos1;
Group

XTP_EDIT_LINECOL Data Members


XTP_EDIT_LINECOL Methods

XTP_EDIT_LINECOL Structure, Legend, Public Methods
XTP_EDIT_LINECOL Methods
Structure

XTP_EDIT_LINECOL Structure

Legend
Method
Public Methods
Public Methods
Public Method | Description
Clear | Clears data members.
GetXLC | Returns coordinates in the packed form.
IsValidData | Returns data validation flag.
MakeLineCol | Constructs XTP_EDIT_LINECOL from the pair of coordinates (line and column).
max2 | This static functions are used to get minimum or maximum of 2 XTP_EDIT_LINECOL values.
min2 | This static functions are used to get minimum or maximum of 2 XTP_EDIT_LINECOL values.


XTP_EDIT_LINECOL::Clear Method

XTP_EDIT_LINECOL Methods, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::Clear Method

Clears data members.

void Clear();
Remarks

Call this member function to set line/column coordinates to 0.

Group

XTP_EDIT_LINECOL Methods


XTP_EDIT_LINECOL::GetXLC Method

XTP_EDIT_LINECOL Methods, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::GetXLC Method

Returns coordinates in the packed form.

DWORD GetXLC() const;
Returns

DWORD value.

Group

XTP_EDIT_LINECOL Methods


XTP_EDIT_LINECOL::IsValidData Method

XTP_EDIT_LINECOL Methods, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::IsValidData Method

Returns data validation flag.

BOOL IsValidData() const;
Returns

TRUE if line/column identifiers > 0; FALSE otherwise

Group

XTP_EDIT_LINECOL Methods


XTP_EDIT_LINECOL::MakeLineCol Method

XTP_EDIT_LINECOL Methods, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::MakeLineCol Method

Constructs XTP_EDIT_LINECOL from the pair of coordinates (line and column).

static const XTP_EDIT_LINECOL MakeLineCol(
    int nParamLine,
    int nParamCol
);
Parameters

nParamLine
[in] Line identifier.
nParamCol
[in] Column identifier.

Group

XTP_EDIT_LINECOL Methods


XTP_EDIT_LINECOL::min2 Method

XTP_EDIT_LINECOL Methods, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::min2 Method

This static functions are used to get minimum or maximum of 2 XTP_EDIT_LINECOL values.

static const XTP_EDIT_LINECOL min2(
    const XTP_EDIT_LINECOL& pos1,
    const XTP_EDIT_LINECOL& pos2
);
static const XTP_EDIT_LINECOL max2(
    const XTP_EDIT_LINECOL& pos1,
    const XTP_EDIT_LINECOL& pos2
);
Parameters

pos1
[in] First value.
pos2
[in] Second value.

Group

XTP_EDIT_LINECOL Methods


XTP_EDIT_LINECOL Operators

XTP_EDIT_LINECOL Structure, Legend, Public Operators
XTP_EDIT_LINECOL Operators
Structure

XTP_EDIT_LINECOL Structure

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
!= | Not Equal operator. Compares current struct with given.
< | Less than operator. Compares current struct with given.
<= | Less than or equal operator. Compares current struct with given.
== | Equal operator. Compares current struct with given.
> | Greater than operator. Compares current struct with given.
>= | Greater or equal operator. Compares current struct with given.


XTP_EDIT_LINECOL::!= Operator

XTP_EDIT_LINECOL Operators, XTP_EDIT_LINECOL Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_LINECOL::!= Operator

Not Equal operator. Compares current struct with given.

BOOL operator !=(
    const XTP_EDIT_LINECOL& pos2
) const;
Parameters

pos2
[in] Reference to struct to compare.

Returns

TRUE if current struct not equal given; FALSE otherwise

Body Source
BOOL operator != (const XTP_EDIT_LINECOL& pos2) const {
    return !operator==(pos2);
}
Group

XTP_EDIT_LINECOL Operators


XTP_EDIT_LINECOL::< Operator

XTP_EDIT_LINECOL Operators, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::< Operator

Less than operator. Compares current struct with given.

BOOL operator <(
    const XTP_EDIT_LINECOL& pos2
) const;
Parameters

pos2
[in] Reference to struct to compare.

Returns

TRUE if current struct less than given; FALSE otherwise

Group

XTP_EDIT_LINECOL Operators


XTP_EDIT_LINECOL::<= Operator

XTP_EDIT_LINECOL Operators, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::<= Operator

Less than or equal operator. Compares current struct with given.

BOOL operator <=(
    const XTP_EDIT_LINECOL& pos2
) const;
Parameters

pos2
[in] Reference to struct to compare.

Returns

TRUE if current struct less than or equal given; FALSE otherwise

Group

XTP_EDIT_LINECOL Operators


XTP_EDIT_LINECOL::== Operator

XTP_EDIT_LINECOL Operators, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::== Operator

Equal operator. Compares current struct with given.

BOOL operator ==(
    const XTP_EDIT_LINECOL& pos2
) const;
Parameters

pos2
[in] Reference to struct to compare.

Returns

TRUE if current struct equal given; FALSE otherwise

Group

XTP_EDIT_LINECOL Operators


XTP_EDIT_LINECOL::> Operator

XTP_EDIT_LINECOL Operators, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::> Operator

Greater than operator. Compares current struct with given.

BOOL operator >(
    const XTP_EDIT_LINECOL& pos2
) const;
Parameters

pos2
[in] Reference to struct to compare.

Returns

TRUE if current struct greater than given; FALSE otherwise.

Group

XTP_EDIT_LINECOL Operators


XTP_EDIT_LINECOL::>= Operator

XTP_EDIT_LINECOL Operators, XTP_EDIT_LINECOL Structure
XTP_EDIT_LINECOL::>= Operator

Greater or equal operator. Compares current struct with given.

BOOL operator >=(
    const XTP_EDIT_LINECOL& pos2
) const;
Parameters

pos2
[in] Reference to struct to compare.

Returns

TRUE if current struct greater than or equal given; FALSE otherwise

Group

XTP_EDIT_LINECOL Operators


XTP_EDIT_ROWSBLOCK Structure

XTPSyntaxEditStruct.h, Classes, Legend, Members, Topics, XTP_EDIT_ROWSBLOCK Data Members, XTP_EDIT_ROWSBLOCK Destructors, XTP_EDIT_ROWSBLOCK Operators, XTP_EDIT_ROWSBLOCK Data Members, XTP_EDIT_ROWSBLOCK Destructors, XTP_EDIT_ROWSBLOCK Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_ROWSBLOCK Structure

XTP_EDIT_ROWSBLOCK struct

Class Hierarchy

struct XTP_EDIT_ROWSBLOCK {
  XTP_EDIT_LINECOL lcStart;
  XTP_EDIT_LINECOL lcEnd;
  CString strCollapsedText;
};
File

XTPSyntaxEditStruct.h

Group

Classes

Legend
Data Member
Destructor
virtual
Operator
XTP_EDIT_ROWSBLOCK Data Members
XTP_EDIT_ROWSBLOCK Data Members | Description
lcEnd | End Position.
lcStart | Start position.
strCollapsedText | Collapsed text.
XTP_EDIT_ROWSBLOCK Destructors
XTP_EDIT_ROWSBLOCK Destructors | Description
~XTP_EDIT_ROWSBLOCK | Default destructor.Handles clean up and deallocation.
XTP_EDIT_ROWSBLOCK Operators
XTP_EDIT_ROWSBLOCK Operators | Description
= | Assign operator.


XTP_EDIT_ROWSBLOCK Data Members

XTP_EDIT_ROWSBLOCK Structure, Legend, Public Data Members
XTP_EDIT_ROWSBLOCK Data Members
Structure

XTP_EDIT_ROWSBLOCK Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
lcEnd | End Position.
lcStart | Start position.
strCollapsedText | Collapsed text.


XTP_EDIT_ROWSBLOCK::lcEnd Data Member

XTP_EDIT_ROWSBLOCK Data Members, XTP_EDIT_ROWSBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_ROWSBLOCK::lcEnd Data Member

End Position.

XTP_EDIT_LINECOL lcEnd;
Group

XTP_EDIT_ROWSBLOCK Data Members


XTP_EDIT_ROWSBLOCK::lcStart Data Member

XTP_EDIT_ROWSBLOCK Data Members, XTP_EDIT_ROWSBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_ROWSBLOCK::lcStart Data Member

Start position.

XTP_EDIT_LINECOL lcStart;
Group

XTP_EDIT_ROWSBLOCK Data Members


XTP_EDIT_ROWSBLOCK::strCollapsedText Data Member

XTP_EDIT_ROWSBLOCK Data Members, XTP_EDIT_ROWSBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_ROWSBLOCK::strCollapsedText Data Member

Collapsed text.

CString strCollapsedText;
Group

XTP_EDIT_ROWSBLOCK Data Members


XTP_EDIT_ROWSBLOCK Destructors

XTP_EDIT_ROWSBLOCK Structure, Legend, Public Methods
XTP_EDIT_ROWSBLOCK Destructors
Structure

XTP_EDIT_ROWSBLOCK Structure

Legend
Destructor
virtual
Public Methods
Public Destructors
Public Destructor | Description
~XTP_EDIT_ROWSBLOCK | Default destructor.Handles clean up and deallocation.


XTP_EDIT_ROWSBLOCK::~XTP_EDIT_ROWSBLOCK Destructor

XTP_EDIT_ROWSBLOCK Destructors, XTP_EDIT_ROWSBLOCK Structure, Body Source
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_ROWSBLOCK::~XTP_EDIT_ROWSBLOCK Destructor

Default destructor.Handles clean up and deallocation.

virtual ~XTP_EDIT_ROWSBLOCK();
Body Source
virtual ~XTP_EDIT_ROWSBLOCK(){}
Group

XTP_EDIT_ROWSBLOCK Destructors


XTP_EDIT_ROWSBLOCK Operators

XTP_EDIT_ROWSBLOCK Structure, Legend, Public Operators
XTP_EDIT_ROWSBLOCK Operators
Structure

XTP_EDIT_ROWSBLOCK Structure

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Assign operator.


XTP_EDIT_ROWSBLOCK::= Operator

XTP_EDIT_ROWSBLOCK Operators, XTP_EDIT_ROWSBLOCK Structure
XTP_EDIT_ROWSBLOCK::= Operator

Assign operator.

const XTP_EDIT_ROWSBLOCK& operator =(
    const XTP_EDIT_ROWSBLOCK& src
);
Parameters

src
[in] Reference to source structure.

Returns

Reference to XTP_EDIT_COLORVALUES struct.

Group

XTP_EDIT_ROWSBLOCK Operators


XTP_EDIT_TEXTBLOCK Structure

XTPSyntaxEditStruct.h, Classes, Legend, Members, Topics, XTP_EDIT_TEXTBLOCK Data Members, XTP_EDIT_TEXTBLOCK Constructors, XTP_EDIT_TEXTBLOCK Operators, XTP_EDIT_TEXTBLOCK Constructors, XTP_EDIT_TEXTBLOCK Data Members, XTP_EDIT_TEXTBLOCK Operators
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_TEXTBLOCK Structure

XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing

Class Hierarchy

struct XTP_EDIT_TEXTBLOCK {
  int nPos;
  int nNextBlockPos;
  XTP_EDIT_COLORVALUES clrBlock;
  XTP_EDIT_FONTOPTIONS lf;
};
File

XTPSyntaxEditStruct.h

Group

Classes

Legend
Data Member
Constructor
Operator
XTP_EDIT_TEXTBLOCK Constructors
XTP_EDIT_TEXTBLOCK Constructors | Description
XTP_EDIT_TEXTBLOCK | Default constructor.
XTP_EDIT_TEXTBLOCK Data Members
XTP_EDIT_TEXTBLOCK Data Members | Description
clrBlock | Color for this block
lf | Font options for this block;
nNextBlockPos | Position for the next block
nPos | Position
XTP_EDIT_TEXTBLOCK Operators
XTP_EDIT_TEXTBLOCK Operators | Description
= | Assign operator.


XTP_EDIT_TEXTBLOCK Data Members

XTP_EDIT_TEXTBLOCK Structure, Legend, Public Data Members
XTP_EDIT_TEXTBLOCK Data Members
Structure

XTP_EDIT_TEXTBLOCK Structure

Legend
Data Member
Public Data Members
Public Data Member | Description
clrBlock | Color for this block
lf | Font options for this block;
nNextBlockPos | Position for the next block
nPos | Position


XTP_EDIT_TEXTBLOCK::clrBlock Data Member

XTP_EDIT_TEXTBLOCK Data Members, XTP_EDIT_TEXTBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_TEXTBLOCK::clrBlock Data Member

Color for this block

XTP_EDIT_COLORVALUES clrBlock;
Group

XTP_EDIT_TEXTBLOCK Data Members


XTP_EDIT_TEXTBLOCK::lf Data Member

XTP_EDIT_TEXTBLOCK Data Members, XTP_EDIT_TEXTBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_TEXTBLOCK::lf Data Member

Font options for this block;

XTP_EDIT_FONTOPTIONS lf;
Group

XTP_EDIT_TEXTBLOCK Data Members


XTP_EDIT_TEXTBLOCK::nNextBlockPos Data Member

XTP_EDIT_TEXTBLOCK Data Members, XTP_EDIT_TEXTBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_TEXTBLOCK::nNextBlockPos Data Member

Position for the next block

int nNextBlockPos;
Group

XTP_EDIT_TEXTBLOCK Data Members


XTP_EDIT_TEXTBLOCK::nPos Data Member

XTP_EDIT_TEXTBLOCK Data Members, XTP_EDIT_TEXTBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_TEXTBLOCK::nPos Data Member

Position

int nPos;
Group

XTP_EDIT_TEXTBLOCK Data Members


XTP_EDIT_TEXTBLOCK Constructors

XTP_EDIT_TEXTBLOCK Structure, Legend, Public Methods
XTP_EDIT_TEXTBLOCK Constructors
Structure

XTP_EDIT_TEXTBLOCK Structure

Legend
Constructor
Public Methods
Public Constructors
Public Constructor | Description
XTP_EDIT_TEXTBLOCK | Default constructor.


XTP_EDIT_TEXTBLOCK::XTP_EDIT_TEXTBLOCK Constructor

XTP_EDIT_TEXTBLOCK Constructors, XTP_EDIT_TEXTBLOCK Structure
Xtreme Toolkit Pro v12.0
Previous | Up | Next
XTP_EDIT_TEXTBLOCK::XTP_EDIT_TEXTBLOCK Constructor

Default constructor.

XTP_EDIT_TEXTBLOCK();
Group

XTP_EDIT_TEXTBLOCK Constructors


XTP_EDIT_TEXTBLOCK Operators

XTP_EDIT_TEXTBLOCK Structure, Legend, Public Operators
XTP_EDIT_TEXTBLOCK Operators
Structure

XTP_EDIT_TEXTBLOCK Structure

Legend
Operator
Public Operators
Public Operators
Public Operator | Description
= | Assign operator.


XTP_EDIT_TEXTBLOCK::= Operator

XTP_EDIT_TEXTBLOCK Operators, XTP_EDIT_TEXTBLOCK Structure
XTP_EDIT_TEXTBLOCK::= Operator

Assign operator.

const XTP_EDIT_TEXTBLOCK& operator =(
    const XTP_EDIT_TEXTBLOCK& src
);
Parameters

src
[in] Reference to source structure.

Returns

Reference to XTP_EDIT_TEXTBLOCK struct.

Group

XTP_EDIT_TEXTBLOCK Operators


Functions

Functions, Legend, Syntax Edit
Functions
Functions
Function | Description
DDX_CBSyntaxColor | Use this function to exchange currently selected color for CXTPSyntaxEditColorComboBox control.
Module

Syntax Edit

Legend
Method


DDX_CBSyntaxColor Function

XTPSyntaxEditColorComboBox.h, Functions
DDX_CBSyntaxColor Function

Use this function to exchange currently selected color for CXTPSyntaxEditColorComboBox control.

void DDX_CBSyntaxColor(
    CDataExchange* pDX,
    int nIDC,
    COLORREF& value
);
File

XTPSyntaxEditColorComboBox.h

Parameters

pDX
A pointer to CDataExchange object.
nIDC
A control ID.
value
A reference to color value.

Group

Functions


Structs, Records, Enums

Enumerations, Legend, Syntax Edit, Structures
Structs, Records, Enums
Enumerations
Enumeration | Description
XTPSyntaxEditCfgFlags | This enumeration describes allowable configuration managers flags.
XTPSyntaxEditCRLFStyle | Line endings types
XTPSyntaxEditDeletePos | Edit delete position
XTPSyntaxEditEditAction | This enum describes set of edit actions.
XTPSyntaxEditLexClass_OptChildren | Enumerates children classes relation for the Lex Class object.
XTPSyntaxEditLexClass_OptParent | Enumerates parent class relation for the Lex Class object.
XTPSyntaxEditLexParseResult | Enumerates flags which indicate results of parse functions calls.
XTPSyntaxEditLexVariantType | Enumerates types of values which supported by CXTPSyntaxEditLexVariant class.
XTPSyntaxEditLineMarksRefreshType | Enumerates types of mark refreshing
XTPSyntaxEditOnCfgChangedEvent | these events are sent from different threads. Its receiver must be thread safety.
XTPSyntaxEditOnParseEvent | these events are sent from different threads. Its receiver must be thread safety.
XTPSyntaxEditUpdateViewHint | View update action. Defines in which way the view should be updated.
Module

Syntax Edit

Legend
Structure
Enumeration
Structures
Structure | Description
XTP_EDIT_NMHDR_DOCMODIFIED | Document notification structure Provided as LPARAM with WM_NOTIFY used to notify of a change in the document's modified state.
XTP_EDIT_NMHDR_EDITCHANGED | Structure to notify "Edit changed" event
XTP_EDIT_NMHDR_ENABLESCROLLBAR | Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event
XTP_EDIT_NMHDR_MARGINCLICKED | Structure to notify XTP_EDIT_NM_MARGINCLICKED event
XTP_EDIT_NMHDR_PARSEEVENT | Structure to notify XTP_EDIT_NM_PARSEEVENT event
XTP_EDIT_NMHDR_ROWCOLCHANGED | Row column notification structure Provided as LPARAM with WM_NOTIFY This is used to display current row and column
XTP_EDIT_NMHDR_SETSCROLLPOS | Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event
XTP_EDIT_ROWCOLRECT | This is used to define row and col selection rect
XTP_EDIT_SENMBOOKMARK | Bookmark notification structure Provided as LPARAM with WM_NOTIFY while bookmarks are needed to be drawn


XTP_EDIT_NMHDR_DOCMODIFIED Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_NMHDR_DOCMODIFIED Structure

Document notification structure Provided as LPARAM with WM_NOTIFY used to notify of a change in the document's modified state.

struct XTP_EDIT_NMHDR_DOCMODIFIED {
  NMHDR nmhdr;
  BOOL bModified;
};
File

XTPSyntaxEditStruct.h

Members

nmhdr
First param should be NMHDR
bModified
TRUE if the document was modified.

Group

Structs, Records, Enums


XTP_EDIT_NMHDR_EDITCHANGED Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_NMHDR_EDITCHANGED Structure

Structure to notify "Edit changed" event

struct XTP_EDIT_NMHDR_EDITCHANGED {
  NMHDR nmhdr;
  int nRowFrom;
  int nRowTo;
  int nAction;
};
File

XTPSyntaxEditStruct.h

Members

nmhdr
First param should be NMHDR
nRowFrom
The start row for the action
nRowTo
The end row for the action
nAction
The actual action

Group

Structs, Records, Enums


XTP_EDIT_NMHDR_ENABLESCROLLBAR Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_NMHDR_ENABLESCROLLBAR Structure

Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event

struct XTP_EDIT_NMHDR_ENABLESCROLLBAR {
  NMHDR nmhdr;
  DWORD dwScrollBar;
  DWORD dwState;
};
File

XTPSyntaxEditStruct.h

Members

nmhdr
First param should be NMHDR
dwScrollBar
Define the scroll bar(s) to change state as WS_HSCROLL and WS_VSCROLL flags.
dwState
Define the scroll bar(s) state as WS_HSCROLL and WS_VSCROLL flags.

Group

Structs, Records, Enums


XTP_EDIT_NMHDR_MARGINCLICKED Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_NMHDR_MARGINCLICKED Structure

Structure to notify XTP_EDIT_NM_MARGINCLICKED event

struct XTP_EDIT_NMHDR_MARGINCLICKED {
  NMHDR nmhdr;
  int nRow;
  int nDispRow;
};
File

XTPSyntaxEditStruct.h

Members

nmhdr
First param should be NMHDR
nRow
Document row number
nDispRow
Visible row number (start from 1);

Group

Structs, Records, Enums


XTP_EDIT_NMHDR_PARSEEVENT Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_NMHDR_PARSEEVENT Structure

Structure to notify XTP_EDIT_NM_PARSEEVENT event

struct XTP_EDIT_NMHDR_PARSEEVENT {
  NMHDR nmhdr;
  DWORD code;
  WPARAM wParam;
  LPARAM lParam;
};
File

XTPSyntaxEditStruct.h

Members

nmhdr
First param should be NMHDR
code
Parser event.
wParam
First event parameter.
lParam
Second event parameter.

Group

Structs, Records, Enums


XTP_EDIT_NMHDR_ROWCOLCHANGED Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_NMHDR_ROWCOLCHANGED Structure

Row column notification structure Provided as LPARAM with WM_NOTIFY This is used to display current row and column

struct XTP_EDIT_NMHDR_ROWCOLCHANGED {
  NMHDR nmhdr;
  int nRow;
  int nCol;
};
File

XTPSyntaxEditStruct.h

Members

nmhdr
First param should be NMHDR
nRow
Current document row
nCol
Current document col

Group

Structs, Records, Enums


XTP_EDIT_NMHDR_SETSCROLLPOS Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_NMHDR_SETSCROLLPOS Structure

Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event

struct XTP_EDIT_NMHDR_SETSCROLLPOS {
  NMHDR nmhdr;
  DWORD dwUpdate;
};
File

XTPSyntaxEditStruct.h

Members

nmhdr
First param should be NMHDR
dwUpdate
Scroll position update flags can be any combination of XTP_EDIT_UPDATE_HORZ, XTP_EDIT_UPDATE_VERT or XTP_EDIT_UPDATE_DIAG.

Group

Structs, Records, Enums


XTP_EDIT_ROWCOLRECT Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_ROWCOLRECT Structure

This is used to define row and col selection rect

struct XTP_EDIT_ROWCOLRECT {
  int nRow1;
  int nCol1;
  int nRow2;
  int nCol2;
};
File

XTPSyntaxEditStruct.h

Members

nRow1
First row index for a text block.
nCol1
First column index for a text block.
nRow2
Last row index for a text block.
nCol2
Last column index for a text block.

Group

Structs, Records, Enums


XTP_EDIT_SENMBOOKMARK Structure

XTPSyntaxEditStruct.h, Structs, Records, Enums
XTP_EDIT_SENMBOOKMARK Structure

Bookmark notification structure Provided as LPARAM with WM_NOTIFY while bookmarks are needed to be drawn

struct XTP_EDIT_SENMBOOKMARK {
  NMHDR nmhdr;
  HDC hDC;
  RECT rcBookmark;
  int nRow;
};
File

XTPSyntaxEditStruct.h

Members

nmhdr
First param should be NMHDR
hDC
HDC for drawing
rcBookmark
RECT for bookmark
nRow
The row number

Group

Structs, Records, Enums


XTPSyntaxEditCfgFlags Enumeration

XTPSyntaxEditLexColorFileReader.h, Structs, Records, Enums
XTPSyntaxEditCfgFlags Enumeration

This enumeration describes allowable configuration managers flags.

enum XTPSyntaxEditCfgFlags {
  xtpEditCfgFileAdd = 0x0001,
  xtpEditCfgFileRemove = 0x0002
};
File

XTPSyntaxEditLexColorFileReader.h

Members

xtpEditCfgFileAdd
file should be added
xtpEditCfgFileRemove
file should be removed

Group

Structs, Records, Enums


XTPSyntaxEditCRLFStyle Enumeration

XTPSyntaxEditDefines.h, Structs, Records, Enums
XTPSyntaxEditCRLFStyle Enumeration

Line endings types

enum XTPSyntaxEditCRLFStyle {
  xtpEditCRLFStyleUnknown = -1,
  xtpEditCRLFStyleDos = 0,
  xtpEditCRLFStyleUnix = 1,
  xtpEditCRLFStyleMac = 2
};
File

XTPSyntaxEditDefines.h

Members

xtpEditCRLFStyleUnknown
Used to indicate unknown or error value
xtpEditCRLFStyleDos
DOS style CRLF (0x0d0a)
xtpEditCRLFStyleUnix
UNIX style CRLF (0x0a0d)
xtpEditCRLFStyleMac
MAC style CRLF (0x0a)

Group

Structs, Records, Enums


XTPSyntaxEditDeletePos Enumeration

XTPSyntaxEditDefines.h, Structs, Records, Enums
XTPSyntaxEditDeletePos Enumeration

Edit delete position

enum XTPSyntaxEditDeletePos {
  xtpEditDelPosAfter,
  xtpEditDelPosBefore
};
File

XTPSyntaxEditDefines.h

Members

xtpEditDelPosAfter
Delete char(s) after specified position.
xtpEditDelPosBefore
Delete char(s) before specified position.

Group

Structs, Records, Enums


XTPSyntaxEditEditAction Enumeration

XTPSyntaxEditLexParser.h, Structs, Records, Enums
XTPSyntaxEditEditAction Enumeration

This enum describes set of edit actions.

enum XTPSyntaxEditEditAction {
  xtpEditActInsert = 1,
  xtpEditActDelete = 2
};
File

XTPSyntaxEditLexParser.h

Members

xtpEditActInsert
Edit action insert text.
xtpEditActDelete
Edit action delete text.

Group

Structs, Records, Enums


XTPSyntaxEditLexClass_OptChildren Enumeration

XTPSyntaxEditLexClass.h, Structs, Records, Enums, See Also
XTPSyntaxEditLexClass_OptChildren Enumeration

Enumerates children classes relation for the Lex Class object.

enum XTPSyntaxEditLexClass_OptChildren {
  xtpEditOptChildren_Unknown = 0,
  xtpEditOptChildren_No = 1,
  xtpEditOptChildren_Any = 2,
  xtpEditOptChildren_List = 3
};
File

XTPSyntaxEditLexClass.h

Members

xtpEditOptChildren_Unknown
Undefined value.
xtpEditOptChildren_No
Lex Class cannot have children.
xtpEditOptChildren_Any
Lex Class have children specified by their 'parent' property
xtpEditOptChildren_List
Lex Class can have only children from list and specified by their 'parent' property.

See Also

CXTPSyntaxEditLexClass::CXTPSyntaxEditChildren

Group

Structs, Records, Enums


XTPSyntaxEditLexClass_OptParent Enumeration

XTPSyntaxEditLexClass.h, Structs, Records, Enums, See Also
XTPSyntaxEditLexClass_OptParent Enumeration

Enumerates parent class relation for the Lex Class object.

enum XTPSyntaxEditLexClass_OptParent {
  xtpEditOptParent_Unknown = 0,
  xtpEditOptParent_Default = -1,
  xtpEditOptParent_file = 1,
  xtpEditOptParent_direct = 2,
  xtpEditOptParent_dyn = 3
};
File

XTPSyntaxEditLexClass.h

Members

xtpEditOptParent_Unknown
Undefined value.
xtpEditOptParent_Default
Use default relation value.
xtpEditOptParent_file
Lex Class is the top in classes hierarchy: level file.
xtpEditOptParent_direct
Lex Class can be child of specified parent class only directly.
xtpEditOptParent_dyn
Lex Class can be child of specified parent class dynamically.

See Also

CXTPSyntaxEditLexClass::CXTPSyntaxEditParent.

Group

Structs, Records, Enums


XTPSyntaxEditLexParseResult Enumeration

XTPSyntaxEditLexParser.h, Structs, Records, Enums, See Also
XTPSyntaxEditLexParseResult Enumeration

Enumerates flags which indicate results of parse functions calls.

enum XTPSyntaxEditLexParseResult {
  xtpEditLPR_Unknown = 0,
  xtpEditLPR_StartFound = 0x001,
  xtpEditLPR_EndFound = 0x002,
  xtpEditLPR_Iterated = 0x010,
  xtpEditLPR_TBpop1 = 0x020,
  xtpEditLPR_Error = 0x100,
  xtpEditLPR_RunFinished = 0x200,
  xtpEditLPR_RunBreaked = 0x400,
  xtpEditLPR_RunRestart = 0x800
};
File

XTPSyntaxEditLexParser.h

Members

xtpEditLPR_Unknown
Undefined value.
xtpEditLPR_StartFound
Start text block was found
xtpEditLPR_EndFound
End text block was found
xtpEditLPR_Iterated
Indicate that current text position has already moved to the next char inside a function call.
xtpEditLPR_TBpop1
Indicate that new found text block should be inserted before previous one and as a parent of it.
xtpEditLPR_Error
Iterated parse process breaked due to some error.
xtpEditLPR_RunFinished
Run iterated parse process (or some big part of it) is finished.
xtpEditLPR_RunBreaked
Run iterated parse process (or some big part of it) is breaked.
xtpEditLPR_RunRestart
Restart run children from the beginning.

See Also

CXTPSyntaxEditLexClass, CXTPSyntaxEditLexTextSchema

Group

Structs, Records, Enums


XTPSyntaxEditLexVariantType Enumeration

XTPSyntaxEditLexClass.h, Structs, Records, Enums, See Also
XTPSyntaxEditLexVariantType Enumeration

Enumerates types of values which supported by CXTPSyntaxEditLexVariant class.

enum XTPSyntaxEditLexVariantType {
  xtpEditLVT_Unknown = 0,
  xtpEditLVT_className = 0x0001,
  xtpEditLVT_classPtr = 0x0002,
  xtpEditLVT_LVArrayPtr = 0x0004,
  xtpEditLVT_valInt = 0x0100,
  xtpEditLVT_valStr = 0x0200,
  xtpEditLVT_valVar = 0x0400
};
File

XTPSyntaxEditLexClass.h

Members

xtpEditLVT_Unknown
designates unknown type of value
xtpEditLVT_className
designates value of lex class name (or class names array) type
xtpEditLVT_classPtr
designates value of lex class Pointer type
xtpEditLVT_LVArrayPtr
designates value of LexVariants array Pointer type
xtpEditLVT_valInt
designates value of integer type
xtpEditLVT_valStr
designates value of character string (or string array) type
xtpEditLVT_valVar
designates value of lex variable

See Also

CXTPSyntaxEditLexVariant

Group

Structs, Records, Enums


XTPSyntaxEditLineMarksRefreshType Enumeration

XTPSyntaxEditLineMarksManager.h, Structs, Records, Enums
XTPSyntaxEditLineMarksRefreshType Enumeration

Enumerates types of mark refreshing

enum XTPSyntaxEditLineMarksRefreshType {
  xtpEditLMRefresh_Unknown = 0,
  xtpEditLMRefresh_Insert = 0x01,
  xtpEditLMRefresh_Delete = 0x02,
  xtpEditLMRefresh_Delete_only1 = 0x10,
  xtpEditLMRefresh_Delete_only2 = 0x20,
  xtpEditLMRefresh_InsertAt0 = 0x40
};
File

XTPSyntaxEditLineMarksManager.h

Members

xtpEditLMRefresh_Unknown
unknown refresh state
xtpEditLMRefresh_Insert
mark inserted
xtpEditLMRefresh_Delete
mark deleted
xtpEditLMRefresh_Delete_only1
delete mark for first row of deleted text block;
xtpEditLMRefresh_Delete_only2
delete mark for last row of deleted text block;
xtpEditLMRefresh_InsertAt0
move mark for first row of inserted text block;

Group

Structs, Records, Enums


XTPSyntaxEditOnCfgChangedEvent Enumeration

XTPSyntaxEditDefines.h, Structs, Records, Enums
XTPSyntaxEditOnCfgChangedEvent Enumeration

these events are sent from different threads. Its receiver must be thread safety.

enum XTPSyntaxEditOnCfgChangedEvent {
  xtpEditClassSchWasChanged = 10,
  xtpEditThemeWasChanged = 11,
  xtpEditAllConfigWasChanged = 12
};
File

XTPSyntaxEditDefines.h

Members

xtpEditClassSchWasChanged
dwParam1 = LPCTSTR - Schema name; dwParam2 = CXTPSyntaxEditLexTextSchema* New text schema pointer, or NULL if it was removed.
xtpEditThemeWasChanged
dwParam1 = LPCTSTR - Theme name; dwParam2 = CXTPSyntaxEditColorTheme* New theme pointer, or NULL if it was removed.
xtpEditAllConfigWasChanged
dwParam1 - unused, dwParam2 - unused

Group

Structs, Records, Enums


XTPSyntaxEditOnParseEvent Enumeration

XTPSyntaxEditDefines.h, Structs, Records, Enums
XTPSyntaxEditOnParseEvent Enumeration

these events are sent from different threads. Its receiver must be thread safety.

enum XTPSyntaxEditOnParseEvent {
  xtpEditOnParserStarted = 1,
  xtpEditOnTextBlockParsed = 2,
  xtpEditOnParserEnded = 3
};
File

XTPSyntaxEditDefines.h

Members

xtpEditOnParserStarted
dwParam1 - unused
xtpEditOnTextBlockParsed
dwParam1 = Text Block ID
xtpEditOnParserEnded
dwParam1 = status flags : xtpEditLPR_RunFinished, xtpEditLPR_RunBreaked, xtpEditLPR_Error;

Group

Structs, Records, Enums


XTPSyntaxEditUpdateViewHint Enumeration

XTPSyntaxEditDoc.h, Structs, Records, Enums
XTPSyntaxEditUpdateViewHint Enumeration

View update action. Defines in which way the view should be updated.

enum XTPSyntaxEditUpdateViewHint {
  xtpEditHintUnknown,
  xtpEditHintRefreshView,
  xtpEditHintInitView,
  xtpEditHintSetFont,
  xtpEditHintSetLineNum,
  xtpEditHintSetSelMargin,
  xtpEditHintSetAutoIndent,
  xtpEditHintSetSyntaxColor,
  xtpEditHintUpdateScrollPos,
  xtpEditHintLast
};
File

XTPSyntaxEditDoc.h

Members

xtpEditHintUnknown
Updating action is unknown.
xtpEditHintRefreshView
The view should be refreshed.
xtpEditHintInitView
The view should be initialized.
xtpEditHintSetFont
The view should update the display font.
xtpEditHintSetLineNum
The view should update line number display.
xtpEditHintSetSelMargin
The view should update the selection margin display.
xtpEditHintSetAutoIndent
The view should update the auto-indent setting.
xtpEditHintSetSyntaxColor
The view should update the syntax color setting.
xtpEditHintUpdateScrollPos
The view should update scrollbars positions.
xtpEditHintLast
The last update code.

Group

Structs, Records, Enums


Types

Syntax Edit, Types
Types
Module

Syntax Edit

Types
Type | Description
CTextIter |
CXTPSyntaxEditACDataArray | CXTPSyntaxEditACDataArray type defines a custom array to store AutoComplete items displayed data.
CXTPSyntaxEditACGrid | CXTPSyntaxEditACGrid type defines a custom array to store and manage visible rectangle arrays that represented lines of data in AutoComplete window.


CTextIter Type

XTPSyntaxEditLexPtrs.h, Types
CTextIter Type
typedef CXTPSyntaxEditTextIterator CTextIter;
File

XTPSyntaxEditLexPtrs.h

Group

Types


CXTPSyntaxEditACDataArray Type

XTPSyntaxEditAutoCompleteWnd.h, Types, See Also
CXTPSyntaxEditACDataArray Type

CXTPSyntaxEditACDataArray type defines a custom array to store AutoComplete items displayed data.

typedef CArray<XTP_EDIT_ACDATA*, XTP_EDIT_ACDATA*> CXTPSyntaxEditACDataArray;
File

XTPSyntaxEditAutoCompleteWnd.h

See Also

PXTP_EDIT_ACDATA

Group

Types


CXTPSyntaxEditACGrid Type

XTPSyntaxEditAutoCompleteWnd.h, Types
CXTPSyntaxEditACGrid Type

CXTPSyntaxEditACGrid type defines a custom array to store and manage visible rectangle arrays that represented lines of data in AutoComplete window.

typedef CArray<CRect, CRect> CXTPSyntaxEditACGrid;
File

XTPSyntaxEditAutoCompleteWnd.h

Group

Types


Variables

Syntax Edit, Variables
Variables
Module

Syntax Edit

Variables
Variable | Description
XTP_EDIT_ROWNODE_COLLAPSED | Define that row has collapsed node mark.
XTP_EDIT_ROWNODE_ENDMARK | Define that row has end node mark.
XTP_EDIT_ROWNODE_EXPANDED | Define that row has expanded node mark.
XTP_EDIT_ROWNODE_NODEDOWN | Define that row has down-line node mark.
XTP_EDIT_ROWNODE_NODEUP | Define that row has up-line node mark.
XTP_EDIT_ROWNODE_NOTHING | Define that row has no node mark.
xtpEditLMT_Bookmark | You can define your own line mark types (as string constants) Strings are case sensitive!
XTPLEX_ATTR_CASESENSITIVE | Lex Class CaseSensitive flag.
XTPLEX_ATTR_COLLAPSABLE | Lex Class Collapsable flag.
XTPLEX_ATTR_COLLAPSEDTEXT | Collapsed Lex Class mark text.
XTPLEX_ATTR_COLORPREFIX | Prefix of properties which value is color.
XTPLEX_ATTR_DISPLAYNAME | Friendly name to display in options dialog.
XTPLEX_ATTR_ENDCLASSPARENT | if set to 'this' the end block must have this class as parent.
XTPLEX_ATTR_PARSEONSCREEN | Parse Lex Class only for screen drawing.
XTPLEX_ATTR_RECURRENCEDEPTH | define depth of the recurrence blocks.
XTPLEX_ATTR_RESTARTRUNLOOP | if set to 1 - run children loop will be restarted from the beginning when class ended, otherwise next child class will run.
XTPLEX_ATTR_TXT_BOLD | Text font Bold flag.
XTPLEX_ATTR_TXT_COLORBK | Text back ground color
XTPLEX_ATTR_TXT_COLORFG | Text color
XTPLEX_ATTR_TXT_COLORSELBK | Selected text back ground color
XTPLEX_ATTR_TXT_COLORSELFG | Selected text color
XTPLEX_ATTR_TXT_ITALIC | Text font Italic flag.
XTPLEX_ATTR_TXT_UNDERLINE | Text font Underline flag.
XTPLEX_ATTR_TXTPREFIX | Text properties (like color, bold, ...) attributes prefix.
XTPLEX_ATTRCLASSID | Lex Class ID, unique for the classes tree.
XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS | time out for start reparse after last key was pressed.
XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_MAXBACKPARSEOFFSET | maximum back buffer size.
XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC | default= 180 sec; -1 and 0 means infinite; time out for on screen parsed pieces of text.
XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC | default=60 sec; -1 and 0 means infinite; time out for existing of parser thread when parser idle (no parse requests).


XTP_EDIT_ROWNODE_COLLAPSED Variable

XTPSyntaxEditStruct.h, Variables
XTP_EDIT_ROWNODE_COLLAPSED Variable

Define that row has collapsed node mark.

const UINT XTP_EDIT_ROWNODE_COLLAPSED = 0x01;
File

XTPSyntaxEditStruct.h

Group

Variables


XTP_EDIT_ROWNODE_ENDMARK Variable

XTPSyntaxEditStruct.h, Variables
XTP_EDIT_ROWNODE_ENDMARK Variable

Define that row has end node mark.

const UINT XTP_EDIT_ROWNODE_ENDMARK = 0x04;
File

XTPSyntaxEditStruct.h

Group

Variables


XTP_EDIT_ROWNODE_EXPANDED Variable

XTPSyntaxEditStruct.h, Variables
XTP_EDIT_ROWNODE_EXPANDED Variable

Define that row has expanded node mark.

const UINT XTP_EDIT_ROWNODE_EXPANDED = 0x02;
File

XTPSyntaxEditStruct.h

Group

Variables


XTP_EDIT_ROWNODE_NODEDOWN Variable

XTPSyntaxEditStruct.h, Variables
XTP_EDIT_ROWNODE_NODEDOWN Variable

Define that row has down-line node mark.

const UINT XTP_EDIT_ROWNODE_NODEDOWN = 0x20;
File

XTPSyntaxEditStruct.h

Group

Variables


XTP_EDIT_ROWNODE_NODEUP Variable

XTPSyntaxEditStruct.h, Variables
XTP_EDIT_ROWNODE_NODEUP Variable

Define that row has up-line node mark.

const UINT XTP_EDIT_ROWNODE_NODEUP = 0x10;
File

XTPSyntaxEditStruct.h

Group

Variables


XTP_EDIT_ROWNODE_NOTHING Variable

XTPSyntaxEditStruct.h, Variables
XTP_EDIT_ROWNODE_NOTHING Variable

Define that row has no node mark.

const UINT XTP_EDIT_ROWNODE_NOTHING = 0x00;
File

XTPSyntaxEditStruct.h

Group

Variables


xtpEditLMT_Bookmark Variable

XTPSyntaxEditLineMarksManager.h, Variables
xtpEditLMT_Bookmark Variable

You can define your own line mark types (as string constants) Strings are case sensitive!

const XTP_EDIT_LINEMARKTYPE xtpEditLMT_Bookmark = _T("Bookmark");
File

XTPSyntaxEditLineMarksManager.h

Group

Variables


XTPLEX_ATTR_CASESENSITIVE Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_CASESENSITIVE Variable

Lex Class CaseSensitive flag.

const TCHAR XTPLEX_ATTR_CASESENSITIVE[] = _T("CaseSensitive");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_COLLAPSABLE Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_COLLAPSABLE Variable

Lex Class Collapsable flag.

const TCHAR XTPLEX_ATTR_COLLAPSABLE[] = _T("Collapsable");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_COLLAPSEDTEXT Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_COLLAPSEDTEXT Variable

Collapsed Lex Class mark text.

const TCHAR XTPLEX_ATTR_COLLAPSEDTEXT[] = _T("CollapsedText");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_COLORPREFIX Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_COLORPREFIX Variable

Prefix of properties which value is color.

const TCHAR XTPLEX_ATTR_COLORPREFIX[] = _T("txt:color");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_DISPLAYNAME Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_DISPLAYNAME Variable

Friendly name to display in options dialog.

const TCHAR XTPLEX_ATTR_DISPLAYNAME[] = _T("DisplayName");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_ENDCLASSPARENT Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_ENDCLASSPARENT Variable

if set to 'this' the end block must have this class as parent.

const TCHAR XTPLEX_ATTR_ENDCLASSPARENT[] = _T("End:Class:Parent");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_PARSEONSCREEN Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_PARSEONSCREEN Variable

Parse Lex Class only for screen drawing.

const TCHAR XTPLEX_ATTR_PARSEONSCREEN[] = _T("ParseOnScreen");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_RECURRENCEDEPTH Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_RECURRENCEDEPTH Variable

define depth of the recurrence blocks.

const TCHAR XTPLEX_ATTR_RECURRENCEDEPTH[] = _T("RecurrenceDepth");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_RESTARTRUNLOOP Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_RESTARTRUNLOOP Variable

if set to 1 - run children loop will be restarted from the beginning when class ended, otherwise next child class will run.

const TCHAR XTPLEX_ATTR_RESTARTRUNLOOP[] = _T("RestartRunLoop");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_TXT_BOLD Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_TXT_BOLD Variable

Text font Bold flag.

const TCHAR XTPLEX_ATTR_TXT_BOLD[] = _T("txt:Bold");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_TXT_COLORBK Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_TXT_COLORBK Variable

Text back ground color

const TCHAR XTPLEX_ATTR_TXT_COLORBK[] = _T("txt:colorBK");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_TXT_COLORFG Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_TXT_COLORFG Variable

Text color

const TCHAR XTPLEX_ATTR_TXT_COLORFG[] = _T("txt:colorFG");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_TXT_COLORSELBK Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_TXT_COLORSELBK Variable

Selected text back ground color

const TCHAR XTPLEX_ATTR_TXT_COLORSELBK[] = _T("txt:colorSelBK");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_TXT_COLORSELFG Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_TXT_COLORSELFG Variable

Selected text color

const TCHAR XTPLEX_ATTR_TXT_COLORSELFG[] = _T("txt:colorSelFG");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_TXT_ITALIC Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_TXT_ITALIC Variable

Text font Italic flag.

const TCHAR XTPLEX_ATTR_TXT_ITALIC[] = _T("txt:Italic");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_TXT_UNDERLINE Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_TXT_UNDERLINE Variable

Text font Underline flag.

const TCHAR XTPLEX_ATTR_TXT_UNDERLINE[] = _T("txt:Underline");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTR_TXTPREFIX Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTR_TXTPREFIX Variable

Text properties (like color, bold, ...) attributes prefix.

const TCHAR XTPLEX_ATTR_TXTPREFIX[] = _T("txt:");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTRCLASSID Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTRCLASSID Variable

Lex Class ID, unique for the classes tree.

const TCHAR XTPLEX_ATTRCLASSID[] = _T("ClassID");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD Variable

0,1} default=1

const TCHAR XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD[] = _T("global:ConfigChangedReparceInSeparateThread");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD Variable

0,1} default=1

const TCHAR XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD[] = _T("global:EditReparceInSeparateThread");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS Variable

time out for start reparse after last key was pressed.

const TCHAR XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS[] = _T("global:EditReparceTimeout_ms");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD Variable

0,1} default=1

const TCHAR XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD[] = _T("global:FirstParseInSeparateThread");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTRG_MAXBACKPARSEOFFSET Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTRG_MAXBACKPARSEOFFSET Variable

maximum back buffer size.

const TCHAR XTPLEX_ATTRG_MAXBACKPARSEOFFSET[] = _T("global:MaxBackParseOffset");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC Variable

default= 180 sec; -1 and 0 means infinite; time out for on screen parsed pieces of text.

const TCHAR XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC[] = _T("global:OnScreenSchCacheLifeTime_sec");
File

XTPSyntaxEditLexClass.h

Group

Variables


XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC Variable

XTPSyntaxEditLexClass.h, Variables
XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC Variable

default=60 sec; -1 and 0 means infinite; time out for existing of parser thread when parser idle (no parse requests).

const TCHAR XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC[] = _T("global:ParserThreadIdleLifeTime_sec");
File

XTPSyntaxEditLexClass.h

Group

Variables


Macros

Macros, Syntax Edit
Macros
Macros
Macro | Description
XTP_EDIT_AVELINELEN | Average length of line.
XTP_EDIT_DISABLED_COLOR_DARK | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_EDIT_DISABLED_COLOR_LIGHT | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_EDIT_EDITACTION_DELETEROW | Delete row
XTP_EDIT_EDITACTION_DELETEROW_FULL |
XTP_EDIT_EDITACTION_DELETETEXT | Generic delete text action
XTP_EDIT_EDITACTION_INSERTROW | Insert row
XTP_EDIT_EDITACTION_INSERTTEXT | Generic insert text action
XTP_EDIT_EDITACTION_MODIFYROW | Modify row #define XTP_EDIT_EDITACTION_SELECTIONCHANGED 0x08 // Selection changed
XTP_EDIT_FINDWORD_NEXT | Find start of the next word
XTP_EDIT_FINDWORD_PREV | Find start of the previous word
XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION | Used with XTP_EDIT_FONTOPTIONS struct and define unspecified member value.
XTP_EDIT_NM_DRAWBOOKMARK | This will be called while drawing the bookmarks
XTP_EDIT_NM_EDITCHANGED | This will be called if content has been changed
XTP_EDIT_NM_EDITCHANGING | Edit changing will be called before changing content
XTP_EDIT_NM_ENABLESCROLLBAR | Edit control scroll bar(s) state changed.
XTP_EDIT_NM_FIRST | First notification ID for SyntaxEdit
XTP_EDIT_NM_INSERTKEY | Update all of the vertical panes
XTP_EDIT_NM_LAST | Last notification ID for SyntaxEdit
XTP_EDIT_NM_LBUTTONDBLCLICK | Notify mouse Left button double click.
XTP_EDIT_NM_LBUTTONDOWN | Notify mouse Left button down.
XTP_EDIT_NM_LBUTTONUP | Notify mouse Left button up.
XTP_EDIT_NM_MARGINCLICKED | Left mouse button was clicked in the gutter area
XTP_EDIT_NM_MOUSEMOVE | Notify mouse movement.
XTP_EDIT_NM_PARSEEVENT | This notification used to reflect parser events.
XTP_EDIT_NM_RBUTTONDOWN | Notify mouse Right button down.
XTP_EDIT_NM_RBUTTONUP | Notify mouse Right button up.
XTP_EDIT_NM_ROWCOLCHANGED | This will be fired if row or col has been changed
XTP_EDIT_NM_SELINIT | Updates all the selections while one pane initiates one
XTP_EDIT_NM_SETDOCMODIFIED | Indicates if the document is modified
XTP_EDIT_NM_STARTOLEDRAG | Start OLE drag
XTP_EDIT_NM_UPDATESCROLLPOS | Edit control scroll positions changed.
XTP_EDIT_RGB_GETBLUE | Get blue color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_GETGREEN | Get green color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_GETRED | Get red color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_INT2CLR | Convert raw RGB color value like "0xAABBCC" to COLORREF.
XTP_EDIT_SYNTAXEDIT_DECLARE_SMART_PTR |
XTP_EDIT_XLC | max line: 1 048 575 max col: 4 095
Module

Syntax Edit


XTP_EDIT_AVELINELEN Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_AVELINELEN Macro

Average length of line.

#define XTP_EDIT_AVELINELEN 30 // Average length of line. Used as default value for CXTPSyntaxEditCtrl::m_nAverageLineLen.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_DISABLED_COLOR_LIGHT Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_DISABLED_COLOR_LIGHT Macro

Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.

#define XTP_EDIT_DISABLED_COLOR_LIGHT RGB(250, 250, 250)
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_EDITACTION_DELETEROW Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_EDITACTION_DELETEROW Macro

Delete row

#define XTP_EDIT_EDITACTION_DELETEROW 0x02 // Delete row
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_EDITACTION_DELETEROW_FULL Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_EDITACTION_DELETEROW_FULL Macro
#define XTP_EDIT_EDITACTION_DELETEROW_FULL 0x20 //
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_EDITACTION_DELETETEXT Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_EDITACTION_DELETETEXT Macro

Generic delete text action

#define XTP_EDIT_EDITACTION_DELETETEXT 0x200 // Generic delete text action
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_EDITACTION_INSERTROW Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_EDITACTION_INSERTROW Macro

Insert row

#define XTP_EDIT_EDITACTION_INSERTROW 0x01 // Insert row
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_EDITACTION_INSERTTEXT Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_EDITACTION_INSERTTEXT Macro

Generic insert text action

#define XTP_EDIT_EDITACTION_INSERTTEXT 0x100 // Generic insert text action
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_EDITACTION_MODIFYROW Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_EDITACTION_MODIFYROW Macro

Modify row #define XTP_EDIT_EDITACTION_SELECTIONCHANGED 0x08 // Selection changed

#define XTP_EDIT_EDITACTION_MODIFYROW 0x04 // Modify row
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_FINDWORD_NEXT Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_FINDWORD_NEXT Macro

Find start of the next word

#define XTP_EDIT_FINDWORD_NEXT 0x02 // Find start of the next word
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_FINDWORD_PREV Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_FINDWORD_PREV Macro

Find start of the previous word

#define XTP_EDIT_FINDWORD_PREV 0x01 // Find start of the previous word
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION Macro

XTPSyntaxEditStruct.h, Macros, See Also
XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION Macro

Used with XTP_EDIT_FONTOPTIONS struct and define unspecified member value.

#define XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION (BYTE)-1
File

XTPSyntaxEditStruct.h

See Also

XTP_EDIT_FONTOPTIONS

Group

Macros


XTP_EDIT_NM_DRAWBOOKMARK Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_DRAWBOOKMARK Macro

This will be called while drawing the bookmarks

#define XTP_EDIT_NM_DRAWBOOKMARK (XTP_EDIT_NM_FIRST + 3) // This will be called while drawing the bookmarks
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_EDITCHANGED Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_EDITCHANGED Macro

This will be called if content has been changed

#define XTP_EDIT_NM_EDITCHANGED (XTP_EDIT_NM_FIRST + 1) // This will be called if content has been changed
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_EDITCHANGING Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_EDITCHANGING Macro

Edit changing will be called before changing content

#define XTP_EDIT_NM_EDITCHANGING (XTP_EDIT_NM_FIRST + 0) // Edit changing will be called before changing content
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_ENABLESCROLLBAR Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_ENABLESCROLLBAR Macro

Edit control scroll bar(s) state changed.

#define XTP_EDIT_NM_ENABLESCROLLBAR (XTP_EDIT_NM_FIRST + 20) // Edit control scroll bar(s) state changed.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_FIRST Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_FIRST Macro

First notification ID for SyntaxEdit

#define XTP_EDIT_NM_FIRST (0U - 951U) // First notification ID for SyntaxEdit
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_INSERTKEY Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_INSERTKEY Macro

Update all of the vertical panes

#define XTP_EDIT_NM_INSERTKEY (XTP_EDIT_NM_FIRST + 8) // Update all of the vertical panes
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_LAST Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_LAST Macro

Last notification ID for SyntaxEdit

#define XTP_EDIT_NM_LAST (0U - 979U) // Last notification ID for SyntaxEdit
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_LBUTTONDBLCLICK Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_LBUTTONDBLCLICK Macro

Notify mouse Left button double click.

#define XTP_EDIT_NM_LBUTTONDBLCLICK (XTP_EDIT_NM_FIRST + 15) // Notify mouse Left button double click. NMMOUSE structure passed with this notification.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_LBUTTONDOWN Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_LBUTTONDOWN Macro

Notify mouse Left button down.

#define XTP_EDIT_NM_LBUTTONDOWN (XTP_EDIT_NM_FIRST + 14) // Notify mouse Left button down. NMMOUSE structure passed with this notification.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_LBUTTONUP Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_LBUTTONUP Macro

Notify mouse Left button up.

#define XTP_EDIT_NM_LBUTTONUP (XTP_EDIT_NM_FIRST + 16) // Notify mouse Left button up. NMMOUSE structure passed with this notification.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_MARGINCLICKED Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_MARGINCLICKED Macro

Left mouse button was clicked in the gutter area

#define XTP_EDIT_NM_MARGINCLICKED (XTP_EDIT_NM_FIRST + 11) // Left mouse button was clicked in the gutter area
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_MOUSEMOVE Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_MOUSEMOVE Macro

Notify mouse movement.

#define XTP_EDIT_NM_MOUSEMOVE (XTP_EDIT_NM_FIRST + 19) // Notify mouse movement. NMMOUSE structure passed with this notification.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_PARSEEVENT Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_PARSEEVENT Macro

This notification used to reflect parser events.

#define XTP_EDIT_NM_PARSEEVENT (XTP_EDIT_NM_FIRST + 13) // This notification used to reflect parser events. See XTPSyntaxEditOnParseEvent enum.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_RBUTTONDOWN Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_RBUTTONDOWN Macro

Notify mouse Right button down.

#define XTP_EDIT_NM_RBUTTONDOWN (XTP_EDIT_NM_FIRST + 17) // Notify mouse Right button down. NMMOUSE structure passed with this notification.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_RBUTTONUP Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_RBUTTONUP Macro

Notify mouse Right button up.

#define XTP_EDIT_NM_RBUTTONUP (XTP_EDIT_NM_FIRST + 18) // Notify mouse Right button up. NMMOUSE structure passed with this notification.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_ROWCOLCHANGED Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_ROWCOLCHANGED Macro

This will be fired if row or col has been changed

#define XTP_EDIT_NM_ROWCOLCHANGED (XTP_EDIT_NM_FIRST + 4) // This will be fired if row or col has been changed
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_SELINIT Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_SELINIT Macro

Updates all the selections while one pane initiates one

#define XTP_EDIT_NM_SELINIT (XTP_EDIT_NM_FIRST + 9) // Updates all the selections while one pane initiates one
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_SETDOCMODIFIED Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_SETDOCMODIFIED Macro

Indicates if the document is modified

#define XTP_EDIT_NM_SETDOCMODIFIED (XTP_EDIT_NM_FIRST + 2) // Indicates if the document is modified
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_STARTOLEDRAG Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_STARTOLEDRAG Macro

Start OLE drag

#define XTP_EDIT_NM_STARTOLEDRAG (XTP_EDIT_NM_FIRST + 10) // Start OLE drag
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_NM_UPDATESCROLLPOS Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_NM_UPDATESCROLLPOS Macro

Edit control scroll positions changed.

#define XTP_EDIT_NM_UPDATESCROLLPOS (XTP_EDIT_NM_FIRST + 12) // Edit control scroll positions changed.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_RGB_GETBLUE Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_RGB_GETBLUE Macro

Get blue color value for raw RGB color like "0xAABBCC".

#define XTP_EDIT_RGB_GETBLUE(rgb) ((rgb) & 0xff) // Get blue color value for raw RGB color like "0xAABBCC".
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_RGB_GETGREEN Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_RGB_GETGREEN Macro

Get green color value for raw RGB color like "0xAABBCC".

#define XTP_EDIT_RGB_GETGREEN(rgb) (((rgb) >> 8) & 0xff) // Get green color value for raw RGB color like "0xAABBCC".
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_RGB_GETRED Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_RGB_GETRED Macro

Get red color value for raw RGB color like "0xAABBCC".

#define XTP_EDIT_RGB_GETRED(rgb) (((rgb) >> 16) & 0xff) // Get red color value for raw RGB color like "0xAABBCC".
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_RGB_INT2CLR Macro

XTPSyntaxEditDefines.h, Macros
XTP_EDIT_RGB_INT2CLR Macro

Convert raw RGB color value like "0xAABBCC" to COLORREF.

#define XTP_EDIT_RGB_INT2CLR(rgb) RGB(XTP_EDIT_RGB_GETRED(rgb),XTP_EDIT_RGB_GETGREEN(rgb),XTP_EDIT_RGB_GETBLUE(rgb)) // Convert raw RGB color value like "0xAABBCC" to COLORREF.
File

XTPSyntaxEditDefines.h

Group

Macros


XTP_EDIT_SYNTAXEDIT_DECLARE_SMART_PTR Macro

XTPSyntaxEditLexPtrs.h, Macros
XTP_EDIT_SYNTAXEDIT_DECLARE_SMART_PTR Macro
#define XTP_EDIT_SYNTAXEDIT_DECLARE_SMART_PTR(_TClassName) class _TClassName; typedef CXTPSmartPtrInternalT<_TClassName> _TClassName##Ptr;
File

XTPSyntaxEditLexPtrs.h

Group

Macros


XTP_EDIT_XLC Macro

XTPSyntaxEditStruct.h, Macros
XTP_EDIT_XLC Macro

max line: 1 048 575 max col: 4 095

#define XTP_EDIT_XLC(nL, nC) ( (((DWORD)nL) << 12) | (((DWORD)nC) & 0x00000FFF))
File

XTPSyntaxEditStruct.h

Group

Macros


Files

Files, Syntax Edit
Files
Files
File | Description
XTPSyntaxEditAutoCompleteWnd.h | XTPSyntaxEditAutoCompleteWnd.h: interface for the CXTPSyntaxEditAutoCompleteWnd class.
XTPSyntaxEditBufferManager.h | XTPSyntaxEditBufferManager.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditColorComboBox.h | XTPSyntaxEditColorComboBox.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditColorSampleText.h | XTPSyntaxEditColorSampleText.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditCtrl.h | XTPSyntaxEditCtrl.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditDefines.h | XTPSyntaxEditDefines.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditDoc.h | XTPSyntaxEditDoc.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditFindReplaceDlg.h | XTPSyntaxEditFindReplaceDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditGoToLineDlg.h | XTPSyntaxEditGoToLineDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexCfgFileReader.h | XTPSyntaxEditLexCfgFileReader.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClass.h | XTPSyntaxEditLexClass.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClassSubObjDef.h | XTPSyntaxEditLexClassSubObjDef.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClassSubObjT.h | XTPSyntaxEditLexClassSubObjT.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexColorFileReader.h | XTPSyntaxEditLexColorFileReader.h: interface for the CXTLexColorFileReader class.
XTPSyntaxEditLexParser.h | XTPSyntaxEditLexParser.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexPtrs.h | XTPSyntaxEditLexPtrs.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLineMarksManager.h | XTPSyntaxEditLineMarksManager.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditPaintManager.h | XTPSyntaxEditPaintManager.h interface for the CXTPSyntaxEditPaintManager class.
XTPSyntaxEditPropertiesDlg.h | XTPSyntaxEditPropertiesDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditPropertiesPage.h | XTPSyntaxEditPropertiesPage.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditSectionManager.h | XTPSyntaxEditSectionManager.h: interface for the CXTPSyntaxEditSectionManager class.
XTPSyntaxEditStruct.h | XTPSyntaxEditStruct.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditTextIterator.h | XTPSyntaxEditTextIterator.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditToolTipCtrl.h | XTPSyntaxEditToolTipCtrl.h: interface for the CXTPSyntaxEditToolTipCtrl class.
XTPSyntaxEditUndoManager.h | XTPSyntaxEditUndoManager.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditView.h | XTPSyntaxEditView.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
Module

Syntax Edit


XTPSyntaxEditAutoCompleteWnd.h

Classes, Files, Legend, Types, Structures
XTPSyntaxEditAutoCompleteWnd.h

XTPSyntaxEditAutoCompleteWnd.h: interface for the CXTPSyntaxEditAutoCompleteWnd class.

Classes
Class | Description
CXTPSyntaxEditAutoCompleteWnd | This class implements AutoComplete window. It provides facilities to display predefined strings of data in the sorted order. Then user can navigate over list of strings and choose desired text to complete his input. AutoComplete window provides some ways to navigate by using vertical scroll bar, up/down keys, mouse. If user types alphanumeric keys after AutoComplete window was appeared it uses user input as search criteria and tries to find text from its predefined strings of data that are like user input.
Group

Files

Types
Type | Description
CXTPSyntaxEditACDataArray | CXTPSyntaxEditACDataArray type defines a custom array to store AutoComplete items displayed data.
CXTPSyntaxEditACGrid | CXTPSyntaxEditACGrid type defines a custom array to store and manage visible rectangle arrays that represented lines of data in AutoComplete window.
Legend
Structure
Structures
Structure | Description
XTP_EDIT_ACDATA | XTP_EDIT_ACDATA structure defines items displayed data. Provides text and icon for each displayed line in Auto-complete window.


XTPSyntaxEditBufferManager.h

Classes, Files
XTPSyntaxEditBufferManager.h

XTPSyntaxEditBufferManager.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditBufferManager | This class is the main class for buffer management. One instance of this class is attached with a CXTPSyntaxEditCtrl object. This class contains a list of CBufferIndex class which in turn contains a position in the file (In case of un-modified index) or a CEditBuffer pointer.
Group

Files


XTPSyntaxEditColorComboBox.h

Classes, Functions, Files, Legend
XTPSyntaxEditColorComboBox.h

XTPSyntaxEditColorComboBox.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditColorComboBox | This class allow edit colors using combobox control. It display color name and draw rectangle for each item using item color.
Functions
Function | Description
DDX_CBSyntaxColor | Use this function to exchange currently selected color for CXTPSyntaxEditColorComboBox control.
Group

Files

Legend
Method


XTPSyntaxEditColorSampleText.h

Classes, Files
XTPSyntaxEditColorSampleText.h

XTPSyntaxEditColorSampleText.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditColorSampleText | This class, derived from CStatic, used to display sample of colored text.
Group

Files


XTPSyntaxEditCtrl.h

Classes, Files
XTPSyntaxEditCtrl.h

XTPSyntaxEditCtrl.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditCtrl | This class is the main CWnd - based editor class. It is a rectangular child window in which the user can enter and edit text. The control is also capable of enhance text coloring for a number of specific input file types, e.c. C/C++ source files, HTML files, etc. User can create and customize his own text files schemes - they are independent of source files. The control contains the main configuration file, which can contain references to any specific configuration files. By default, this file is placed in the same folder as the application executable and is called... more
Group

Files


XTPSyntaxEditDefines.h

Enumerations, Files, Legend, Macros
XTPSyntaxEditDefines.h

XTPSyntaxEditDefines.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Enumerations
Enumeration | Description
XTPSyntaxEditCRLFStyle | Line endings types
XTPSyntaxEditDeletePos | Edit delete position
XTPSyntaxEditOnCfgChangedEvent | these events are sent from different threads. Its receiver must be thread safety.
XTPSyntaxEditOnParseEvent | these events are sent from different threads. Its receiver must be thread safety.
Group

Files

Macros
Macro | Description
XTP_EDIT_AVELINELEN | Average length of line.
XTP_EDIT_DISABLED_COLOR_DARK | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_EDIT_DISABLED_COLOR_LIGHT | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_EDIT_EDITACTION_DELETEROW | Delete row
XTP_EDIT_EDITACTION_DELETEROW_FULL |
XTP_EDIT_EDITACTION_DELETETEXT | Generic delete text action
XTP_EDIT_EDITACTION_INSERTROW | Insert row
XTP_EDIT_EDITACTION_INSERTTEXT | Generic insert text action
XTP_EDIT_EDITACTION_MODIFYROW | Modify row #define XTP_EDIT_EDITACTION_SELECTIONCHANGED 0x08 // Selection changed
XTP_EDIT_FINDWORD_NEXT | Find start of the next word
XTP_EDIT_FINDWORD_PREV | Find start of the previous word
XTP_EDIT_NM_DRAWBOOKMARK | This will be called while drawing the bookmarks
XTP_EDIT_NM_EDITCHANGED | This will be called if content has been changed
XTP_EDIT_NM_EDITCHANGING | Edit changing will be called before changing content
XTP_EDIT_NM_ENABLESCROLLBAR | Edit control scroll bar(s) state changed.
XTP_EDIT_NM_FIRST | First notification ID for SyntaxEdit
XTP_EDIT_NM_INSERTKEY | Update all of the vertical panes
XTP_EDIT_NM_LAST | Last notification ID for SyntaxEdit
XTP_EDIT_NM_LBUTTONDBLCLICK | Notify mouse Left button double click.
XTP_EDIT_NM_LBUTTONDOWN | Notify mouse Left button down.
XTP_EDIT_NM_LBUTTONUP | Notify mouse Left button up.
XTP_EDIT_NM_MARGINCLICKED | Left mouse button was clicked in the gutter area
XTP_EDIT_NM_MOUSEMOVE | Notify mouse movement.
XTP_EDIT_NM_PARSEEVENT | This notification used to reflect parser events.
XTP_EDIT_NM_RBUTTONDOWN | Notify mouse Right button down.
XTP_EDIT_NM_RBUTTONUP | Notify mouse Right button up.
XTP_EDIT_NM_ROWCOLCHANGED | This will be fired if row or col has been changed
XTP_EDIT_NM_SELINIT | Updates all the selections while one pane initiates one
XTP_EDIT_NM_SETDOCMODIFIED | Indicates if the document is modified
XTP_EDIT_NM_STARTOLEDRAG | Start OLE drag
XTP_EDIT_NM_UPDATESCROLLPOS | Edit control scroll positions changed.
XTP_EDIT_RGB_GETBLUE | Get blue color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_GETGREEN | Get green color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_GETRED | Get red color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_INT2CLR | Convert raw RGB color value like "0xAABBCC" to COLORREF.
Legend
Enumeration


XTPSyntaxEditDoc.h

Classes, Enumerations, Files, Legend
XTPSyntaxEditDoc.h

XTPSyntaxEditDoc.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditDoc | This class represents a Document portion of the Edit control. It extends functionality provided by CDocument class from MFC's document-view model implementation. CXTPSyntaxEditDoc class works together with CXTPSyntaxEditView and provides storage facilities for it.
Enumerations
Enumeration | Description
XTPSyntaxEditUpdateViewHint | View update action. Defines in which way the view should be updated.
Group

Files

Legend
Enumeration


XTPSyntaxEditFindReplaceDlg.h

Classes, Files
XTPSyntaxEditFindReplaceDlg.h

XTPSyntaxEditFindReplaceDlg.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditFindReplaceDlg | This class implements a Find and Replace dialogs for a SyntaxEdit control.
Group

Files


XTPSyntaxEditGoToLineDlg.h

Classes, Files
XTPSyntaxEditGoToLineDlg.h

XTPSyntaxEditGoToLineDlg.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditGoToLineDlg | This class implements a GoToLine dialog for a SyntaxEdit control.
Group

Files


XTPSyntaxEditLexCfgFileReader.h

Classes, Files
XTPSyntaxEditLexCfgFileReader.h

XTPSyntaxEditLexCfgFileReader.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditFileChangesMonitor | this class monitors files changes
CXTPSyntaxEditLexCfgFileReader | This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes lex class instances that represent various lexical items for given language. You construct instance of CXTPSyntaxEditLexCfgFileReader by calling constructor. Then you should call ReadSource() member function to read data from persistent storage (file for this implementation), and process raw data into XTP_EDIT_LEXCLASSINFO structures. Call GetLexClassInfoArray() member function to return a pointer to an array of XTP_EDIT_LEXCLASSINFO data structures.
Group

Files


XTPSyntaxEditLexClass.h

Classes, Enumerations, Files, Legend, Variables
XTPSyntaxEditLexClass.h

XTPSyntaxEditLexClass.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditLexClass | CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.
CXTPSyntaxEditLexOnScreenParseCnt | CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process.
CXTPSyntaxEditLexVariable | CXTPSyntaxEditLexVariable class is used to represent lexical variables. In the class schema variables begins from symbol @. Standard variables are: @alpha, @digit, @HexDigit, @specs, @EOL.
CXTPSyntaxEditLexVariant | CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type.
Enumerations
Enumeration | Description
XTPSyntaxEditLexClass_OptChildren | Enumerates children classes relation for the Lex Class object.
XTPSyntaxEditLexClass_OptParent | Enumerates parent class relation for the Lex Class object.
XTPSyntaxEditLexVariantType | Enumerates types of values which supported by CXTPSyntaxEditLexVariant class.
Group

Files

Variables
Variable | Description
XTPLEX_ATTR_CASESENSITIVE | Lex Class CaseSensitive flag.
XTPLEX_ATTR_COLLAPSABLE | Lex Class Collapsable flag.
XTPLEX_ATTR_COLLAPSEDTEXT | Collapsed Lex Class mark text.
XTPLEX_ATTR_COLORPREFIX | Prefix of properties which value is color.
XTPLEX_ATTR_DISPLAYNAME | Friendly name to display in options dialog.
XTPLEX_ATTR_ENDCLASSPARENT | if set to 'this' the end block must have this class as parent.
XTPLEX_ATTR_PARSEONSCREEN | Parse Lex Class only for screen drawing.
XTPLEX_ATTR_RECURRENCEDEPTH | define depth of the recurrence blocks.
XTPLEX_ATTR_RESTARTRUNLOOP | if set to 1 - run children loop will be restarted from the beginning when class ended, otherwise next child class will run.
XTPLEX_ATTR_TXT_BOLD | Text font Bold flag.
XTPLEX_ATTR_TXT_COLORBK | Text back ground color
XTPLEX_ATTR_TXT_COLORFG | Text color
XTPLEX_ATTR_TXT_COLORSELBK | Selected text back ground color
XTPLEX_ATTR_TXT_COLORSELFG | Selected text color
XTPLEX_ATTR_TXT_ITALIC | Text font Italic flag.
XTPLEX_ATTR_TXT_UNDERLINE | Text font Underline flag.
XTPLEX_ATTR_TXTPREFIX | Text properties (like color, bold, ...) attributes prefix.
XTPLEX_ATTRCLASSID | Lex Class ID, unique for the classes tree.
XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS | time out for start reparse after last key was pressed.
XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD | 0,1} default=1
XTPLEX_ATTRG_MAXBACKPARSEOFFSET | maximum back buffer size.
XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC | default= 180 sec; -1 and 0 means infinite; time out for on screen parsed pieces of text.
XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC | default=60 sec; -1 and 0 means infinite; time out for existing of parser thread when parser idle (no parse requests).
Legend
Enumeration


XTPSyntaxEditLexClassSubObjDef.h

Files
XTPSyntaxEditLexClassSubObjDef.h

XTPSyntaxEditLexClassSubObjDef.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Group

Files


XTPSyntaxEditLexClassSubObjT.h

Files, Legend, Templates
XTPSyntaxEditLexClassSubObjT.h

XTPSyntaxEditLexClassSubObjT.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Group

Files

Templates
Template | Description
CXTPSyntaxEditLexVariantPtrArrayExAutomatT |
Legend
Template


XTPSyntaxEditLexColorFileReader.h

Classes, Enumerations, Files, Legend
XTPSyntaxEditLexColorFileReader.h

XTPSyntaxEditLexColorFileReader.h: interface for the CXTLexColorFileReader class.

Classes
Class | Description
CXTPSyntaxEditColorInfo | This storage class is designed to contain information from the color settings file section. It helps easy retrieve color information.
CXTPSyntaxEditColorInfoArray |
CXTPSyntaxEditColorTheme | This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes color settings for corresponding lexical items for given language. You construct instance of CXTPSyntaxEditColorTheme by calling constructor. Then you should call Load() member function to read data from persistent storage (file for this implementation), CXTPSyntaxEditLexColorInfo structures.
CXTPSyntaxEditColorThemesManager | This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.
CXTPSyntaxEditConfigurationManager | This class manages all configuration parameters of the control. It worries about read configuration files from disk when the Edit control is starting, store it in internal structures and refresh parameters in case configuration files are changed after control was started.
CXTPSyntaxEditTextSchemesManager | This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.
Enumerations
Enumeration | Description
XTPSyntaxEditCfgFlags | This enumeration describes allowable configuration managers flags.
Group

Files

Legend
Enumeration


XTPSyntaxEditLexParser.h

Classes, Enumerations, Files, Legend
XTPSyntaxEditLexParser.h

XTPSyntaxEditLexParser.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditLexParser | This class used to 'run' lex schema parsing in separate thread. It also control this working thread and provide interthread interaction.
CXTPSyntaxEditLexParserSchemaOptions | This class is designed to easily manipulate parser options.
CXTPSyntaxEditLexTextBlock | CXTPSyntaxEditLexTextBlock class represents a pice (block) of text which corresponds some lex class in a text schema. It stores start position, end position, pointer to the lex class object in a class schema and some other information. Text blocks organized as a bidirectional list and as tree structure.
CXTPSyntaxEditLexTextSchema | CXTPSyntaxEditLexTextSchema class is used to store data which necessary to parse a text and parsing results. It also contains methods to run lex classes from a class schema, methods to update text schema when text is edited, methods to reparse text, to get information which is necessary to draw colorized text and other helper methods.
CXTPSyntaxEditLexTokensDef | This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators.
CXTPSyntaxEditTextRegion | This class is designed to store coordinates of text region.
Enumerations
Enumeration | Description
XTPSyntaxEditEditAction | This enum describes set of edit actions.
XTPSyntaxEditLexParseResult | Enumerates flags which indicate results of parse functions calls.
Group

Files

Legend
Enumeration


XTPSyntaxEditLexPtrs.h

Files, Macros, Types
XTPSyntaxEditLexPtrs.h

XTPSyntaxEditLexPtrs.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Group

Files

Macros
Macro | Description
XTP_EDIT_SYNTAXEDIT_DECLARE_SMART_PTR |
Types
Type | Description
CTextIter |


XTPSyntaxEditLineMarksManager.h

Classes, Enumerations, Files, Legend, Variables
XTPSyntaxEditLineMarksManager.h

XTPSyntaxEditLineMarksManager.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditLineMarksManager | CXTPSyntaxEditLineMarksManager class provides functionality to to manipulate marks on text lines. Used internally by the Smart Edit control.
Enumerations
Enumeration | Description
XTPSyntaxEditLineMarksRefreshType | Enumerates types of mark refreshing
Group

Files

Variables
Variable | Description
xtpEditLMT_Bookmark | You can define your own line mark types (as string constants) Strings are case sensitive!
Legend
Enumeration


XTPSyntaxEditPaintManager.h

Classes, Files
XTPSyntaxEditPaintManager.h

XTPSyntaxEditPaintManager.h interface for the CXTPSyntaxEditPaintManager class.

Classes
Class | Description
CXTPSyntaxEditPaintManager | This class used by CXTPSyntaxEditCtrl as the paint manager.
Group

Files


XTPSyntaxEditPropertiesDlg.h

Classes, Files
XTPSyntaxEditPropertiesDlg.h

XTPSyntaxEditPropertiesDlg.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditPropertiesDlg | This class provide a default dialog to edit syntax edit control settings.
Group

Files


XTPSyntaxEditPropertiesPage.h

Classes, Files
XTPSyntaxEditPropertiesPage.h

XTPSyntaxEditPropertiesPage.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditPropertiesPageColor | This class implements a property page colors options.
CXTPSyntaxEditPropertiesPageEdit | This class implements a property page for common edit options.
CXTPSyntaxEditPropertiesPageFont | This class implements a property page font options.
CXTPSyntaxEditTipComboBox | This class implements a combo box with tooltip.
CXTPSyntaxEditTipListBox | This class implements a list box with tooltip.
CXTPSyntaxEditTipWnd | CXTPSyntaxEditTipWnd implements a tooltip window for CXTPSyntaxEditTipListBox class.
Group

Files


XTPSyntaxEditSectionManager.h

Files
XTPSyntaxEditSectionManager.h

XTPSyntaxEditSectionManager.h: interface for the CXTPSyntaxEditSectionManager class.

Group

Files


XTPSyntaxEditStruct.h

Files, Legend, Macros, Variables, Structures
XTPSyntaxEditStruct.h

XTPSyntaxEditStruct.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Group

Files

Macros
Macro | Description
XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION | Used with XTP_EDIT_FONTOPTIONS struct and define unspecified member value.
XTP_EDIT_XLC | max line: 1 048 575 max col: 4 095
Variables
Variable | Description
XTP_EDIT_ROWNODE_COLLAPSED | Define that row has collapsed node mark.
XTP_EDIT_ROWNODE_ENDMARK | Define that row has end node mark.
XTP_EDIT_ROWNODE_EXPANDED | Define that row has expanded node mark.
XTP_EDIT_ROWNODE_NODEDOWN | Define that row has down-line node mark.
XTP_EDIT_ROWNODE_NODEUP | Define that row has up-line node mark.
XTP_EDIT_ROWNODE_NOTHING | Define that row has no node mark.
Legend
Structure
Structures
Structure | Description
XTP_EDIT_COLLAPSEDBLOCK | Stores collapsed block parameters.
XTP_EDIT_COLORVALUES | XTP_EDIT_COLORVALUES struct stores the colors for different phrases
XTP_EDIT_FONTOPTIONS | XTP_EDIT_FONTOPTIONS struct is a self initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length.
XTP_EDIT_LINECOL | XTP_EDIT_LINECOL structure represents coordinates of text items on the displaying context in terms of line/column.
XTP_EDIT_NMHDR_DOCMODIFIED | Document notification structure Provided as LPARAM with WM_NOTIFY used to notify of a change in the document's modified state.
XTP_EDIT_NMHDR_EDITCHANGED | Structure to notify "Edit changed" event
XTP_EDIT_NMHDR_ENABLESCROLLBAR | Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event
XTP_EDIT_NMHDR_MARGINCLICKED | Structure to notify XTP_EDIT_NM_MARGINCLICKED event
XTP_EDIT_NMHDR_PARSEEVENT | Structure to notify XTP_EDIT_NM_PARSEEVENT event
XTP_EDIT_NMHDR_ROWCOLCHANGED | Row column notification structure Provided as LPARAM with WM_NOTIFY This is used to display current row and column
XTP_EDIT_NMHDR_SETSCROLLPOS | Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event
XTP_EDIT_ROWCOLRECT | This is used to define row and col selection rect
XTP_EDIT_ROWSBLOCK | XTP_EDIT_ROWSBLOCK struct
XTP_EDIT_SENMBOOKMARK | Bookmark notification structure Provided as LPARAM with WM_NOTIFY while bookmarks are needed to be drawn
XTP_EDIT_TEXTBLOCK | XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing


XTPSyntaxEditTextIterator.h

Classes, Files
XTPSyntaxEditTextIterator.h

XTPSyntaxEditTextIterator.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditTextIterator | This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, determine control symbols like CRLF. When you create instance of CXTPSyntaxEditTextIterator class you should provide pointer to data storage, represented by CXTPSyntaxEditTextIterator class.
Group

Files


XTPSyntaxEditToolTipCtrl.h

Classes, Files
XTPSyntaxEditToolTipCtrl.h

XTPSyntaxEditToolTipCtrl.h: interface for the CXTPSyntaxEditToolTipCtrl class.

Classes
Class | Description
CXTPSyntaxEditToolTipCtrl | The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area. CXTPSyntaxEditToolTipCtrl provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip. This class is used by the report control internally.
Group

Files


XTPSyntaxEditUndoManager.h

Classes, Files
XTPSyntaxEditUndoManager.h

XTPSyntaxEditUndoManager.h

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class
Description
CXTPSyntaxEditBatchCommand
This class represents a pack of some commands in one. It stores commands in the list, and implements standard command execution interfaces on command (un)execution.
CXTPSyntaxEditBufferCommand
The base class for all edit commands related to CXTPSyntaxEditBufferManager. It stores handle of the buffer manager, and provides implementation of common buffer operations, such as text insertion or deletion.
CXTPSyntaxEditCommand
This class represents abstract Edit Control command interface. Its descendants must implement custom Execute and UnExecute functionality depending on a command type.
This class is used internally by the library only.
CXTPSyntaxEditDeleteStringCommand
This class represents text deletion command. Command execution will delete text from the buffer between specified text positions, its un-execution will insert this text into the buffer.
CXTPSyntaxEditInsertStringCommand
This class represents text insertion command. Command execution will insert a specified text string in the buffer, un-execution will delete this text from the buffer.
CXTPSyntaxEditReplaceStringCommand
This class represents text replacing command. Command execution will replace text from the buffer between specified text positions, un-execution will do contrary replacement.
CXTPSyntaxEditUndoRedoManager
This class maintains the list of undo/redo commands. It is managed by CEditBufferManager class.
It allows adding new commands in the buffer (see AddCommand()), undoing last added operation (see DoUndo()), and redoing operations following the latest unexecuted (see DoRedo()).
It also allows checking for the possibility of performing undo/redo operations (see CanUndo() / CanRedo()).
It also allows marking current position of undo/redo operation queue as saved, and returns "modified" flag if the queue position will be changed (see MarkSaved() / IsModified()).
Another piece of the functionality is commands grouping. There are following methods... more
Group

Files


XTPSyntaxEditView.h

Classes, Files
Previous | Up
XTPSyntaxEditView.h

XTPSyntaxEditView.h : header file

This file is a part of the XTREME TOOLKIT PRO MFC class library.

Classes
Class | Description
CXTPSyntaxEditView | This class represents a View portion of the Edit Control. It extends functionality provided by CView class from MFC's document-view model implementation. CXTPSyntaxEditView class works together with CXTPSyntaxEditDoc and provides facilities for it to be displayed on a screen or printed on a printer.
CXTPSyntaxEditViewPrintOptions | Describes printing options for the Calendar Control.
Group

Files


Variables

Common Files, Variables
Variables
Module

Common Files

Variables
Variable | Description
XPCOLOR_3DFACE | Retrieves the current color of the specified XP display element.
XPCOLOR_3DSHADOW | Retrieves the current color of the specified XP display element.
XPCOLOR_BASE | Retrieves the current color of the specified XP display element.
XPCOLOR_CHECKED_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_DISABLED | Retrieves the current color of the specified XP display element.
XPCOLOR_EDITCTRLBORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_FLOATBAR_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_FRAME | Retrieves the current color of the specified XP display element.
XPCOLOR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_CHECKED | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_CHECKED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_DISABLED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_PUSHED | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_PUSHED_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_HIGHLIGHT_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_ICONSHADDOW | Retrieves the current color of the specified XP display element.
XPCOLOR_LABEL | Retrieves the current color of the specified XP display element.
XPCOLOR_LAST | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_BORDER | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_EXPANDED | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_MENUBAR_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_PUSHED_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_SEPARATOR | Retrieves the current color of the specified XP display element.
XPCOLOR_SHADOW_FACTOR | Retrieves the current color of the specified XP display element.
XPCOLOR_SPLITTER_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_STATICFRAME | Retrieves the current color of the specified XP display element.
XPCOLOR_TAB_INACTIVE_BACK | Retrieves the current color of the specified XP display element.
XPCOLOR_TAB_INACTIVE_TEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_FACE | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_GRAYTEXT | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_GRIPPER | Retrieves the current color of the specified XP display element.
XPCOLOR_TOOLBAR_TEXT | Retrieves the current color of the specified XP display element.


Variables

Docking Panes, Variables
Variables
Module

Docking Panes

Variables
Variable | Description
WM_XTP_DOCKINGPANE_BASE | Base for all docking pane messages
XTP_ACTION_NOCLOSE | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_ACTION | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_CLOSEPANE | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_CONTEXTMENU | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_RCLICK | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.
XTP_DPN_SHOWWINDOW | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.


Classes

Classes
Classes
Classes
Class
Description
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
CXTPCalendarController
Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object.
CXTPCalendarControlView
The CXTPCalendarControlView class provides an implementation of the Calendar control as view class. Use GetCalendarCtrl() method to access methods of CXTPCalendarControl
CXTPCalendarControlViewPrintOptions
Describes printing options for the Calendar Control.
CXTPCalendarCustomDataProvider
Custom implementation of XTPCalendarData based on notifications.
CXTPCalendarCustomProperties
This class is used to store properties collection.
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added,
CXTPCalendarDatabaseDataProvider
This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
CXTPCalendarEventCategories
This class is used as a collection of CXTPCalendarEventCategory objects.
CXTPCalendarEventCategory
This class define Calendar Event Category properties. Visual effects for Event Categories (event and day's cells background colors) implemented in Office 2007 theme only. If one or more categories set for event - the category's colors are used, otherwise label's colors used (is label defined). For Office 2003 theme label's colors used in any case.
CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs.
CXTPCalendarEventLabel
This class define Calendar Event label properties.
CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects.
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
CXTPCalendarIconIDs
This class represents the collection of custom icons IDs.
CXTPCalendarMAPIDataProvider
This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.
CXTPCalendarMAPIWrapper
The CXTPCalendarMAPIWrapper class wraps the mapi32.dll API.
CXTPCalendarMemoryDataProvider
This class implements an abstract representation of the data used in the XTPCalendarData class.
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
CXTPCalendarMonthViewGroup
This class represents a single resource view portion of the Calendar Month View.
CXTPCalendarOccurSeriesChooseDlg
This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern).
CXTPCalendarOptions
Structure contains all calendar options.
CXTPCalendarPageSetupDialog
Customized Calendar control page setup dialog.
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build schedule for recurrence events.
CXTPCalendarReminder
This class describes a reminder for calendar event and implements base properties and operations on reminder.
CXTPCalendarReminderForOccurrence
This structure describes a reminder for an occurrence of a recurrence event.
CXTPCalendarReminderForOccurrenceArray
This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it.
CXTPCalendarReminders
This class represents a simple array collection of CXTPCalendarReminder objects.
CXTPCalendarRemindersManager
This class is used to monitor and manage calendar events reminders. It will send notifications when active reminders list is changed - new reminder(s) come or some reminder(s) goes away.
CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of persons or resources.
CXTPCalendarResourceDescription
This class is a wrapper for CXTPCalendarResource class. It is needed for easier processing in scope of CXTPCalendarResourcesManager
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
CXTPCalendarResourcesManager
This class is used as helper to manage calendar resources (and schedules) data configurations.
CXTPCalendarResourcesNf
This class implements CXTPCalendarResource functionality with addition of notifications mechanism implemented by CXTPNotifySink.
CXTPCalendarSchedule
Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc).
This class implements base properties of the Schedule and operations on it.
CXTPCalendarSchedules
This class represents a simple array collection of CXTPCalendarSchedule objects.
CXTPCalendarThemeBOOLValue
Helper class provides functionality to manage customized BOOL value objects.
CXTPCalendarThemeFontValue
Helper class provides functionality to manage font value objects.
CXTPCalendarThemeIntValue
Helper class provides functionality to manage customized int value objects.
CXTPCalendarThemeRectValue
Helper class provides functionality to manage customized CRect value objects.
CXTPCalendarThemeStringValue
Helper class provides functionality to manage customized string value objects.
CXTPCalendarTimeScalePropertiesDlg
CXTPCalendarTimeScalePropertiesDlg dialog
This dialog allows to customize Calendar Time Scale part, set a proper time zone and it's description.
CXTPCalendarTimeZone
This class extend TIME_ZONE_INFORMATION structure.
CXTPCalendarTimeZones
This class represents a simple array collection of CXTPCalendarTimeZone objects.
CXTPCalendarTip
The CXTPCalendarTip class emulates the functionality of a "tool tip" control.
CXTPCalendarUIntArray
This class represents the collection of UINT elements.
CXTPCalendarView
This class represents the view portion of the Calendar control.
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
CXTPCalendarViewEvents
This class used as collection of Event View object.
CXTPCalendarViewEventSubjectEditor
This class is used to edit event subject.
CXTPCalendarViewEventSubjectEditor2007
This class is used to edit event subject in Office 2007 Theme.
CXTPCalendarViewGroup
Regular schema:

  • CalendarView consists of CalendarView(s)Day
  • CalendarViewDay consists of CalendarView(s)Resource
  • CalendarViewGroup contains CalendarView(s)Event

ViewGroup draws a single resource depending on the type of parent day view.

CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager. objects.
CXTPCalendarViewPartBrushValue
Helper class provides functionality to manage brush value objects.
CXTPCalendarViewPartFontValue
Helper class provides functionality to manage font settings for various graphical elements of control.
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView.
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
CXTPCalendarWeekViewGroup
This class represents a single resource view portion of the Calendar Week View.
CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
CXTPDatePickerButton
This class represents a DatePicker button.
CXTPDatePickerButtons
Class CXTPDatePickerButtons represents a collection of buttons.
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
CXTPDatePickerDaysCollection
CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
CXTPDatePickerList
This class provides the functionality of a list control which displays month names.
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
CXTPDatePickerTheme
Abstract class CXTPDatePickerTheme is derived from CXTPDatePickerPaintManager and handles most of the drawing activities for the DatePicker control. This class must be used as a base to create different themes implementations (like CXTPDatePickerThemeOffice2007).
CXTPDatePickerThemeOffice2007
Class CXTPDatePickerThemeOffice2007 is derived from CXTPDatePickerTheme is implement Office 2007 style for DatePicker control.
CXTPTopLevelWndMsgNotifier
This class is used to catch windows messages, which system sends to top-level windows and to send them to subscribers windows. The following messages are supported: WM_TIMECHANGE WM_SYSCOLORCHANGE


Legend

Legend
Classes
Legend
Template
Structure


Classes Structures

Classes Structures
Classes | Legend
Structures
Structure
Description
XTP_CALENDAR_RECURRENCE_OPTIONS
This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data.
XTP_DAYITEM_METRICS
This structure represents a set of parameters which are used to display day items.

  1. There could be customized foreground and background colors.
  2. Also you can text font for the displayed day text.
  3. And as the last thing you can customize a day picture displayed there, using OLE PICTUREDISP interface and OleSetPicture method.


Structures

Legend
Legend
Structure


Classes Templates

Classes Templates
Classes | Legend
Templates
Template | Description
CXTPAutoResetValue | Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy. Can be useful to lock some data or actions via flags and unlock automatically.
CXTPCalendarPtrCollectionT | This class represents a simple array collection of objects.
CXTPCalendarThemeCustomizableXValueT | Helper class template provides functionality to manage customized value for the specified type.
CXTPCalendarTypedPtrAutoDeleteArray | This class represents a simple array collection of objects pointers.
CXTPCalendarTypedPtrAutoDeleteMap | This class represents a simple map of typed keys to typed objects pointers. Overridden methods SetAt, operator[], RemoveKey, RemoveAll, call delete for previously stored elements.
CXTPCalendarUtils | Helper class with static member functions to perform common tasks with dates, events and other objects.
CXTPCalendarViewDayT | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class.
CXTPCalendarViewEventT | This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.
CXTPCalendarViewGroupT | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class.
CXTPCalendarViewPartCustomizableValueT | Helper class template provides functionality to manage customized value for the specified class objects.
CXTPCalendarViewT | This template class represents a view portion of the Calendar control.


Templates

Legend
Legend
Template


Classes

Classes
Classes
Classes
Class | Description
CXTPCommandBar | CXTPCommandBar is a CWnd derived class. It represents the parent class for command bars.
CXTPCommandBarKeyboardTip | CXTPCommandBarKeyboardTip is CWnd derived class, represents Keyboard tip single window
CXTPCommandBarList | CXTPCommandBarList is a CList derived class. It is used as a collection of CXTPCommandBar classes.
CXTPCommandBars | CXTPCommandBars is standalone class. It allows developer manipulate toolbars and popupbars
CXTPCommandBarsContextMenus | CXTPCommandBarsContextMenus is CXTPCommandBarList derived class, represents collection of context menus
CXTPCommandBarsOptions | Options of the command bars.
CXTPControl | CXTPControl is a CCmdTarget derived class. It represents the parent class for the command bar's controls.
CXTPControlAction | CXTPControlAction is a CCmdTarget derived class. It represents the single action of controls.
CXTPControlActions | CXTPControlActions is a CCmdTarget derived class. It represents a collection of the actions.
CXTPControlBitmap | CXTPControlBitmap is a CXTPControlLabel derived class. It can be used to add bitmap to toolbar.
CXTPControlButton | CXTPControlButton is a CXTPControl derived class. It represents a button control.
CXTPControlButtonColor | CXTPControlButtonColor is a CXTPControlButton derived class. It represents a text button in the color picker popup.
CXTPControlCheckBox | CXTPControlCheckBox is a CXTPControlButton derived class. It represents a checkbox control.
CXTPControlColorSelector | CXTPControlColorSelector is a CXTPControl derived class. It represents a color selector control.
CXTPControlComboBox | CXTPControlComboBox is a CXTPControl derived class. It represents a combo box control.
CXTPControlComboBoxEditCtrl | Inplace Edit control of the combo.
CXTPControlComboBoxList | CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class. It represents a list box of CXTPControlComboBox control.
CXTPControlComboBoxPopupBar | CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class. It represents base class for combo popups.
CXTPControlCustom | CXTPControlCustom is a CXTPControlButton derived class. It represents the control with some child window.
CXTPControlEdit | CXTPControlEdit is a CXTPControl derived class. It represents an edit control.
CXTPControlEditCtrl | Inplace Edit control of CXTPControlEdit.
CXTPControlFontComboBox | CXTPControlFontComboBox is a CXTPControlComboBox derived class. It represents the font picker control.
CXTPControlFontComboBoxList | CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class. It represents the font picker popup.
CXTPControlGallery | CXTPControlGallery is a CXTPControlPopup derived class. It represents gallery control of toolbar.
CXTPControlGalleryItem | CXTPControlGalleryItem is a CCmdTarget derived class. It represents single item of gallery object.
CXTPControlGalleryItems | CXTPControlGalleryItems is a CCmdTarget derived class. It represents a collection of the items for gallery control.
CXTPControlGalleryPaintManager | CXTPControlGalleryPaintManager is standalone class used to draw CXTPControlGallery object
CXTPControlHyperlink | CXTPControlHyperlink is a CXTPControl derived class. It can be used to add hyperlink text.
CXTPControlLabel | CXTPControlLabel is a CXTPControl derived class. It represents a label control.
CXTPControlListBox | CXTPControlComboBox is a CXTPControl derived class. It represents a list box control.
CXTPControlMarkupLabel | CXTPControlMarkupLabel is a CXTPControlLabel derived class. It can be used to draw markup text
CXTPControlOleItems | CXTPControlOleItems is a CXTPControlButton derived class. It is used internally to create ole items.
CXTPControlPopup | CXTPControlPopup is a CXTPControl derived class. It represents a popup-able control.
CXTPControlPopupColor | CXTPControlPopupColor is a CXTPControlPopup derived class. It represents a color picker control.
CXTPControlRadioButton | CXTPControlRadioButton is a CXTPControlButton derived class. It represents a radio button control.
CXTPControlRecentFileList | CXTPControlRecentFileList is a CXTPControlButton derived class. It is used internally to create recent items list.
CXTPControls | CXTPControls is a CCmdTarget derived class. It represents a collection of the controls.
CXTPControlSelector | CXTPControlSelector is a CXTPControl derived class that represents a control selector.
CXTPControlSizeComboBox | CXTPControlSizeComboBox is a CXTPControlComboBox derived class. It represents the size picker.
CXTPControlStatic | CXTPControlStatic is a CXTPControl derived class. It represents a static text control.
CXTPControlToolbars | CXTPControlToolbars is a CXTPControlButton derived class. It is used internally to create toolbars list items.
CXTPControlWindowList | CXTPControlWindowList is a CXTPControlButton derived class. It is used internally to create window list items.
CXTPControlWorkspaceActions | CXTPControlWorkspaceActions is a CXTPControlButton derived class. It used internally to add workspace actions to window menu.
CXTPCustomizeCommandsListBox | List of the commands
CXTPCustomizeCommandsPage | CXTPCustomizeCommandsPage is a CPropertyPage derived class. It represents the Commands page of the Customize dialog.
CXTPCustomizeKeyboardPage | CXTPCustomizeKeyboardPage is a CPropertyPage derived class. It represents the Keyboard page of the Customize dialog.
CXTPCustomizeOptionsPage | CXTPCustomizeOptionsPage is a CPropertyPage derived class. It represents the Options page of the Customize dialog.
CXTPCustomizeSheet | CXTPCustomizeSheet is a CPropertySheet derived class. It represents the Customize dialog.
CXTPCustomizeToolbarsPage | CXTPCustomizeToolbarsPage is a CPropertyPage derived class. It represents the Toolbars page of the Customize dialog.
CXTPDefaultTheme | The CXTPDefaultTheme class is used to enable an Office 2000 style theme for Command Bars
CXTPDialog | CXTPDialog is a CXTPDialogBase derived class. Use this class in your dialog base application.
CXTPDialogBar | CXTPDialogBar is a CXTPToolBar derived class. It represents dockable container for child window
CXTPDockBar | CXTPDockBar is a CWnd derived class. It is used internally by CXTPCommandBars.
CXTPDockContext | CXTPDockContext is a stand alone class. It is used internally by CXTPToolBar.
CXTPDockState | CXTPDockState is a stand alone class. It is used internally by CXTPToolBar.
CXTPEdit | CXTPEdit is a CEdit derived class. It is for internal usage only.
CXTPFrameWnd | CXTPFrameWnd is a CXTPFrameWndBase derived class.
CXTPGroupLine | CXTPGroupLine is a CStatic derived class. It used in CXTPCustomizeOptionsPage page to draw group line static control.
CXTPImageEditorDlg | CXTPImageEditorDlg is a CDialog derived class. It represents the dialog for icons edition.
CXTPMDIFrameWnd | CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.
CXTPMenuBar | CXTPMenuBar is a CXTPToolBar derived class. It represents menu bar of frame window.
CXTPMenuBarMDIMenuInfo | CXTPMenuBarMDIMenuInfo structure used to describe parameters of application MDI menus.
CXTPMenuBarMDIMenus | CXTPMenuBarMDIMenus represents collection of MDI menus for CXTPMenuBar
CXTPMouseManager | CXTPMouseManager is standalone class. It used in CommandBars to manage mouse.
CXTPNativeXPTheme | The CXTPNativeXPTheme class is used to enable a Windows XP style theme for Command Bars
CXTPNewToolbarDlg | CXTPNewToolbarDlg is CDialog derived class. It used internally in customization sheet.
CXTPOffice2007Theme | The CXTPOffice2007Theme class is used to enable an Office 2007 style theme for Command Bars
CXTPOfficeTheme | The CXTPOfficeTheme class is used to enable an Office XP style theme for Command Bars
CXTPPaintManager | Paint manager of the command bars.
CXTPPaintManagerFont | PaintManagers used CFont wrapper.
CXTPPopupBar | CXTPPopupBar is a CXTPCommandBar derived class. It represents submenu of menu bar.
CXTPPopupToolBar | CXTPPopupToolBar is a CXTPPopupBar derived class.
CXTPReBar | The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring of band layouts.
CXTPRibbonBar | CXTPRibbonBar is a CXTPMenuBar derived class, It represents Ribbon control from Office 2007.
CXTPRibbonControls | CXTPRibbonControls is a CXTPControls derived class. It represents a collection of the controls for Ribbon Bar.
CXTPRibbonControlTab | CXTPRibbonControlTab is a CXTPTabManager derived class, It represents tabs of the ribbon bar
CXTPRibbonCustomizeQuickAccessPage | CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class. It represents the Quick Access page of the Customize dialog.
CXTPRibbonGroup | Represents a single group that is added to a CXTPRibbonTab.
CXTPRibbonGroups | Represents a collection of CXTPRibbonGroup objects.
CXTPRibbonQuickAccessControls | CXTPRibbonQuickAccessControls is a CXTPControls derived class. It represents a collection of the controls for quick access controls for Ribbon Bar.
CXTPRibbonTab | Represents a tab in the Ribbon Bar.
CXTPRibbonTheme | Standalone class used by the CXTPRibbonBar as a paint manager.
CXTPShortcutManager | CXTPShortcutManager is standalone class used to manipulate accelerators of frame.
CXTPSoundManager | CXTPSoundManager is standalone class. It used to play system sound.
CXTPStatusBar | CXTPStatusBar is a CControlBar derived class.
CXTPStatusBarPane | CXTPStatusBarPane is a CCmdTarget derived class. It represents single pane of status bar
CXTPStatusBarProgressPane | CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class. CXTPStatusBarProgressPane works with CXTStatusBar and allows you to create progress bar in your status bar area.
CXTPStatusBarScrollBarPane | CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class. CXTPStatusBarScrollBarPane works with CXTStatusBar and allows you to create themed ScrollBar in your status bar area.
CXTPStatusBarSliderPane | CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class. CXTPStatusBarSliderPane works with CXTStatusBar and allows you to create themed Slider in your status bar area.
CXTPStatusBarSwitchPane | CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class. CXTPStatusBarSwitchPane works with CXTStatusBar and allows you to create switches in your status bar area.
CXTPTabClientWnd | CXTPTabClientWnd is a CWnd derived class. It represents a tabbed workspace.
CXTPTabToolBar | CXTPTabToolBar is a CXTPToolBar derived class. It represents tabbable toolbar
CXTPToolBar | CXTPToolBar is a CXTPCommandBar derived class.


Legend

Legend
Classes
Legend
Template


Classes Templates

Classes Templates
Classes | Legend
Templates
Template | Description
CXTPCommandBarsSiteBase | CXTPCommandBarsSiteBase is a stand alone class. It represents site for Command Bars object
CXTPDialogBase | CXTPDialogBase is a TBase derived class. It represents the parent class for a CXTPDialog class .
CXTPFrameWndBase | CXTPFrameWndBase is a stand alone class. It represents the parent class for a CXTPMDIFrameWnd and CXTPFrameWnd classes .
CXTPReBarPaintManager | The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars


Classes

Classes
Classes
Classes
Class
Description
CXTPBitmapDC
CXTPBitmapDC is a helper class used to select a bitmap into the device context specified by hDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPBrushDC
CXTPBrushDC is a helper class used to create a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC. When destroyed, the class selects the previous brush back into the device context to handle GDI resource cleanup.
CXTPBufferDC
CXTPBufferDC is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPBufferDCEx
CXTPBufferDCEx is a helper class used to create a memory device context used to draw to an off-screen bitmap. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPClientCursorPos
CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates.
CXTPClientRect
CXTPClientRect is a helper class used to retrieve the client area for a specified window.
CXTPColorManager
CXTPColorManager is a stand alone class. This object is used for manipulation of RGB values.
CXTPCompatibleDC
CXTPCompatibleDC is a helper class used to create a memory device context (DC) compatible with the device specified by pDC. When destroyed, the class selects the previous bitmap back into the device context to handle GDI resource cleanup.
CXTPCriticalSection
Critical Section Wrapper
CXTPDrawHelpers
CXTPDrawHelpers is a helper class used to perform specialized drawing tasks. You can use this class to perform such tasks as gradient fills and blending colors.
CXTPEmptyRect
CXTPEmptyRect is a helper class used to instantiate an empty CRect object.
CXTPEmptySize
CXTPEmptySize is a helper class used to instantiate an empty CSize object.
CXTPFontDC
CXTPFontDC is a helper class used to select a font into the device context specified by pDC. When destroyed, the class selects the previous font back into the device context to handle GDI resource cleanup.
CXTPImageManager
CXTPImageManager is a stand alone class. It is used to manipulate icons.
CXTPImageManagerIcon
Icons holder class.
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is HICON wrapper class.
CXTPImageManagerIconSet
CXTPImageManagerIconSet represents the collection of icons for specified identifier.
CXTPLockGuard
Critical Sections Lock/Unlock helper
CXTPModuleHandle
CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods
CXTPMouseMonitor
The class CXTPMouseMonitor is a helper class that is used to monitor mouse messages for in-place controls. This class is used in XTPPropertyGridInPlaceList and XTPReportInplaceControls.
CXTPMultiMonitor
MultiMonitor API wrapper class
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and application defined colors.
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and dark gradient colors.
CXTPPenDC
CXTPPenDC is a helper class used to create a pen using the color specified by crColor. The pen is then selected into the device context specified by hDC. When destroyed, the class selects the previous pen back into the device context to handle GDI resource cleanup.
CXTPPrinterInfo
Helper class which provide currently selected printer information.
CXTPPrintOptions
This class used as a base class to store printing options. It contains a base properties and operations for printing tasks.
CXTPPrintPageHeaderFooter
This class used to define printed page header or footer. Also some calculation and drawing functionality are provided. Used as member of printing options.
CXTPPropExchange
CXTPPropExchange is standalone pure class. The CXTPPropExchange class allows you to save a complex network of objects in a permanent binary or text form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
You can use one of derived classes:

  • CXTPPropExchangeArchive to serialize to archive,
  • CXTPPropExchangeRegistry to serialize to registry key,
  • CXTPPropExchangeXMLNode to serialize to XML node.

CXTPPropExchangeArchive
CXTPPropExchangeArchive is CXTPPropExchange derived class. The CXTPPropExchangeArchive class allows you to save a complex network of objects in a permanent binary form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class. It used by CXTPPropExchange to enumerate child sections.
CXTPPropExchangeIniFile
CXTPPropExchangeIniFile is CXTPPropExchange derived class. The CXTPPropExchangeIniFile class allows you to save a complex network of objects in a ini file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeRegistry
CXTPPropExchangeRegistry is CXTPPropExchange derived class. The CXTPPropExchangeRegistry class allows you to save a complex network of objects in a system registry that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPPropExchangeSection
CXTPPropExchangeSection is standalone class. It is used to delete memory allocated by CXTPPropExchange::GetSection.
CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class. The CXTPPropExchangeXMLNode class allows you to save a complex network of objects in a XML file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'
CXTPResourceManager
Standalone class used to managed toolkit resources.
CXTPResourceManagerXML
Class used to managed toolkit resources from XML file
CXTPSplitterTracker
CXTPSplitterTracker is a stand alone class. It is used to track a splitter rectangle.
CXTPSystemVersion
CXTPSystemVersion is a OSVERSIONINFO derived class. This class wraps the Win32 API GetVersionEx(...), used to get the current Windows OS version. CXTPSystemVersion is a single instance, or "singleton" object, that is accessed with the Get() method.
CXTPTempColorMask
CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks. When the destructor is called the default mask is reset for XTPImageManager.
CXTPToolTipContext
CXTPToolTipContext is a CCmdTarget derived class. It allows to change options for tool tips of parent object.
CXTPToolTipContextToolTip
CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips.
CXTPTransparentBitmap
CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap. Also, this class is used to convert a transparent BitMap into a transparent icon.
CXTPWindowRect
CXTPWindowRect is a helper class used to retrieve the screen size for a specified window.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API. You can use this class for rendering Windows XP themes for owner drawn controls.


Classes Templates

Classes Templates
Classes | Legend
Templates
Template | Description
CXTMaskEditT | CXTMaskEditT is a template class. It allows text masking to be applied to the control to format it for special editing restrictions.
CXTPNoFlickerWnd | CXTPNoFlickerWnd is a TBase derived general purpose template helper class. CXTPNoFlickerWnd class is used for drawing flicker free controls. To use, instantiate the template using any CWnd derived class. For example, to create a tab control that is flicker free you would use the following declaration:
CXTPOfficeBorder | CXTPOfficeBorder is a template class used for windows that require a thin border. This class can be used as the base class for any CWnd derived class to display an Office style non-client border.


Classes

Classes
Classes
Classes
Class | Description
CXTPDockingPane | CXTPDockingPane is a CXTPDockingPaneBase derived class. It is used as a container for a user window.
CXTPDockingPaneAutoHidePanel | CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It is used internally as an auto-hide container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneAutoHideWnd | CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class. It is used internally by CXTPDockingPaneAutoHidePanel as a sliding auto-hide window for the hidden pane.
CXTPDockingPaneBase | CXTPDockingPaneBase is a stand alone class. It represents the parent class for a Docking Pane and its containers.
CXTPDockingPaneBaseContainer | CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class. It represents the parent class for a all virtual containers.
CXTPDockingPaneCaptionButton | CXTPDockingPaneCaptionButton is a stand alone internal class.
CXTPDockingPaneCaptionButtons | CXTPDockingPaneCaptionButtons is CArray derived class used for manipulate Caption Buttons.
CXTPDockingPaneContext | CXTPDockingPaneContext is a stand alone class. It is used internally for docking and sizing panes.
CXTPDockingPaneContextAlphaWnd | CXTPDockingPaneContextAlphaWnd is CWnd derived class represents alpha context helper window
CXTPDockingPaneContextStickerWnd | CXTPDockingPaneContextStickerWnd is CWnd derived class represents sticker window.
CXTPDockingPaneDefaultTheme | CXTPDockingPaneDefaultTheme is CXTPDockingPanePaintManager derived class, represents classic theme for docking panes.
CXTPDockingPaneExplorerTheme | CXTPDockingPaneExplorerTheme is CXTPDockingPaneDefaultTheme derived class, represents explorer theme for docking panes.
CXTPDockingPaneGripperedTheme | CXTPDockingPaneGripperedTheme is CXTPDockingPaneDefaultTheme derived class, represents gripper theme for docking panes.
CXTPDockingPaneLayout | CXTPDockingPaneLayout is a stand alone class. It is used to manipulate a pane's layouts.
CXTPDockingPaneManager | CXTPDockingPaneManager is a CWnd derived class. It is used to manipulate docking panes.
CXTPDockingPaneMiniWnd | CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase. It is used internally as a MiniWnd container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneNativeXPTheme | CXTPDockingPaneNativeXPTheme is CXTPDockingPaneOfficeTheme derived class, represents Win XP theme for docking panes.
CXTPDockingPaneOffice2003Theme | CXTPDockingPaneOffice2003Theme is CXTPDockingPaneOfficeTheme derived class, represents Office 2003 theme for docking panes.
CXTPDockingPaneOffice2007Theme | CXTPDockingPaneOffice2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2007 theme for docking panes.
CXTPDockingPaneOfficeTheme | CXTPDockingPaneOfficeTheme is CXTPDockingPaneGripperedTheme derived class, represents Office XP theme for docking panes.
CXTPDockingPanePaintManager | CXTPDockingPanePaintManager is a stand alone class. Override some virtual functions to get a new visual theme.
CXTPDockingPaneShortcutBar2003Theme | CXTPDockingPaneShortcutBar2003Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office 2003 theme for docking panes.
CXTPDockingPaneSplitterContainer | CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class. It is used internally as a splitter container for CXTPDockingPaneBase derived classes.
CXTPDockingPaneSplitterWnd | CXTPDockingPaneSplitterWnd is a CWnd derived class. It is used internally for splitting Panes.
CXTPDockingPaneTabbedContainer | CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. It represents a tabbed container for Docking Panes.
CXTPDockingPaneVisioTheme | CXTPDockingPaneVisioTheme is CXTPDockingPaneOfficeTheme derived class, represents Visio theme for docking panes.
CXTPDockingPaneVisualStudio2005SecondTheme | CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneWhidbeyTheme derived class, represents Visual Studio 2005 beta 2 theme for docking panes.
CXTPDockingPaneVisualStudio2005Theme | CXTPDockingPaneVisualStudio2005SecondTheme is CXTPDockingPaneVisualStudio2005SecondTheme derived class, represents Visual Studio 2005 theme for docking panes.
CXTPDockingPaneWhidbeyTheme | CXTPDockingPaneWhidbeyTheme is CXTPDockingPaneOfficeTheme derived class, represents Visual Studio 2005 theme for docking panes.
CXTPDockingPaneWord2007Theme | CXTPDockingPaneWord2007Theme is CXTPDockingPaneOffice2003Theme derived class, represents Office Word 2007 theme for docking panes.


Classes

Classes
Classes
Classes
Class | Description
CXTPPropertyGrid | CXTPPropertyGrid is a CWnd derived class. It is used to create a property grid control similar to the property window in VS.NET. See the "PropertyGrid" demo for an example of its usage.
CXTPPropertyGridCoolTheme | CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class. This represents a Cool style theme.
CXTPPropertyGridDelphiTheme | CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class. This represents a Delphi style theme.
CXTPPropertyGridInplaceButton | CXTPPropertyGridInplaceButton is a CCmdTarget derived class. It represents inplace button in Property Grid control.
CXTPPropertyGridInplaceButtons | CXTPPropertyGridInplaceButtons is a CCmdTarget derived class. It represents collection of inplace buttons for specified grid item
CXTPPropertyGridInplaceControl | CXTPPropertyGridInplaceControl is CWnd derived class, represents base class for all item in place controls.
CXTPPropertyGridInplaceControls | CXTPPropertyGridInplaceControls is standalone class it represents collection of CXTPPropertyGridInplaceControl classes.
CXTPPropertyGridInplaceEdit | CXTPPropertyGridInplaceEdit is a CEdit derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceList | CXTPPropertyGridInplaceList is a CListBox derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceMonthCal | Month calendar popup used for CXTPPropertyGridItemDate item.
CXTPPropertyGridInplaceMultilineEdit | CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class. It is an internal class used by Property Grid control.
CXTPPropertyGridInplaceSlider | CXTPPropertyGridInplaceSlider is CXTPPropertyGridInplaceControl derived class. It represents in-place slider of the items. Call CXTPPropertyGridItem::AddSliderControl() to add slider for property grid item
CXTPPropertyGridInplaceSpinButton | CXTPPropertyGridInplaceSpinButton is CXTPPropertyGridInplaceControl derived class. It represents in-place spin button of the items. Call CXTPPropertyGridItem::AddSpinButton() to add spin button for property grid item
CXTPPropertyGridItem | CXTPPropertyGridItem is the base class representing an item of the Property Grid Control.
CXTPPropertyGridItemBool | CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class. It is used to create a Boolean value item in a Property Grid control.
CXTPPropertyGridItemCategory | CXTPPropertyGridItemCategory is the CXTPPropertyGridItem derived class. Use it to add subcategory to property grid control.
CXTPPropertyGridItemColor | CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class. It is used to create an RGB value item in a Property Grid control.
CXTPPropertyGridItemConstraint | CXTPPropertyGridItemConstraint is a CCmdTarget derived class. It represents a single item constraints.
CXTPPropertyGridItemConstraints | CXTPPropertyGridItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.
CXTPPropertyGridItemDate | CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class. It is used to create Date item in a Property Grid control.
CXTPPropertyGridItemDouble | CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class. It is used to create an double value item in a Property Grid control.
CXTPPropertyGridItemEnum | CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class. It is used to create an Enum value item in a Property Grid control.
CXTPPropertyGridItemFlags | CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class. It is used to create a Flags value item in a Property Grid control.
CXTPPropertyGridItemFont | CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class. It is used to create a Font value item in a Property Grid control.
CXTPPropertyGridItemMetrics | Standalone class used by CXTPPropertyGridPaintManager as holder of item metrics
CXTPPropertyGridItemNumber | CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class. It is used to create an integer value item in a Property Grid control.
CXTPPropertyGridItems | CXTPPropertyGridItems is a CList derived class. It represents the items collection with some internal functionality.
CXTPPropertyGridItemSize | CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class. It is used to create a size value item in a Property Grid control.
CXTPPropertyGridNativeXPTheme | CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Native Windows XP style theme.
CXTPPropertyGridOffice2003Theme | CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class. This represents an Office 2003 style theme.
CXTPPropertyGridOfficeXPTheme | CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class. This represents a Office XP style theme.
CXTPPropertyGridPaintManager | Standalone class used by CXTPPropertyGrid as the paint manager.
CXTPPropertyGridSimpleTheme | CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class. This represents a Simple style theme.
CXTPPropertyGridToolBar | CXTPPropertyGridToolBar is a CToolBar derived class. It is an internal class used by Property Grid control
CXTPPropertyGridToolTip | CXTPPropertyGridToolTip is a CWnd derived class. It is an internal class used by Property Grid control
CXTPPropertyGridUpdateContext | CXTPPropertyGridUpdateContext is a CCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid. The property grid state information is stored in the CXTPPropertyGridUpdateContext object when CXTPPropertyGrid::BeginUpdate is called and after CXTPPropertyGrid::EndUpdate the expanding state of each item, selected item, and sort preference will be restored.
CXTPPropertyGridVerb | CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET. For example, when the DataGrid control is selected at design time in VS .NET, an AutoFormat link button appears in the Properties window just below the property grid and above the help panel. Verbs will be displayed in a separate panel just below the property grid. Verbs are links that can be used to perform actions in your application. When a verb is clicked, CXTPPropertyGrid::OnVerbClick is called by the framework. If both the verb panel and help panel are visible at the same... more
CXTPPropertyGridVerbs | A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel. See CXTPPropertyGridVerb for a description of verbs.
CXTPPropertyGridView | CXTPPropertyGridView is a CListBox derived class. It is an internal class used by Property Grid control
CXTPPropertyGridWhidbeyTheme | CXTPPropertyGridWhidbeyTheme is a CXTPPropertyGridPaintManager derived class. This represents a Visual Studio 2005 "Whidbey" style theme.


Classes

Classes
Classes
Classes
Class
Description
CXTPFormulaMulDivC
This class used to store MulDivC formula parameters and perform calculation. MulDivC formula if the folowing:

  • = y * Mul / Div + C

CXTPReportColumn
Represents report column item with its properties and operations.
CXTPReportColumnOrder
Represents column order, used for sorting and grouping.
CXTPReportColumns
This class is a collection of report columns objects, each of which can be referred to by its zero-based index.
CXTPReportControl
The CXTPReportControl class provides an implementation of the Report control.
CXTPReportControlLocale
Helper class with static member functions to control active locale for Report Control and perform some locale dependent tasks.
CXTPReportFilterEditControl
The CXTPReportFilterEditControl class provides the functionality of the filter string edit control, associated to the main Report control window.
CXTPReportGroupRow
This class represents a 'group row' of the report control view - that means a row which has no associated Record item, but has a special text caption instead.
CXTPReportHeader
A report header is a part of the report window positioned above columns of text or numbers. It contains a title for each column, and it can be divided into parts. The user can drag the dividers that separate the parts to set the width of each column.
CXTPReportHeaderDragWnd
CXTPReportHeaderDragWnd is CWnd derived class, it used internally to represent dragging column window.
CXTPReportHeaderDropWnd
CXTPReportHeaderDropWnd is CWnd derived class, it used internally to represent drop target arrows.
CXTPReportHyperlink
This class represents hyperlinks. It stores first position and length in the text for hyperlink and rectangle for drawing and identify clicks on hyperlink. To create an instance of its class, you simply call constructor with first position and length of the hyperlink's text
CXTPReportHyperlinks
This class represents array of pointers to CXTPReportHyperlink objects. InternalRelease is called for each item in the array destructor. Also serialization for array items is provided (see DoPropExchange method).
CXTPReportInplaceButton
CXTPReportInplaceButton is the CXTPReportInplaceControl derived class, it represents combo button and expand button of report cell.
CXTPReportInplaceButtons
This class represents collection of the in-place buttons of the single item of the report control.
CXTPReportInplaceControl
CXTPReportInplaceControl is the base class for all in-place controls of report control item.
CXTPReportInplaceEdit
CXTPReportInplaceEdit is the CXTPReportInplaceControl derived class, it represents edit control to allow users change cell of report control.
CXTPReportInplaceList
CXTPReportInplaceList is the CXTPReportInplaceControl derived class, it represents list box with constraints of item.
CXTPReportPageSetupDialog
Customized Calendar control page setup dialog.
CXTPReportPaintManager
Utility class, handling most of the drawing activities. It stores all settings, needed by a control to perform drawing operations: fonts, colors, styles for all other classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with device context.
CXTPReportRecord
CXTPReportRecord represents a collection of objects of CXTPReportRecordItem or objects of classes that are children of CXTPReportRecordItem. A collection of such items is one record in ReportControl list. You create an object of CXTPReportRecord by simply calling constructor. After it you can add items to the record.
CXTPReportRecordItem
Class for working with single list cell. Base class for extended list cells. It determines the behavior of all specific record items. You don't use its class directly in the control. If you wish to add your own Record Item to the control, you must inherit it from CXTPReportRecordItem. Most member functions in this class are virtual.
CXTPReportRecordItemConstraint
CXTPReportRecordItemConstraint is a CCmdTarget derived class. It represents a single item constraints.
CXTPReportRecordItemConstraints
CXTPReportRecordItemConstraints is a CCmdTarget derived class. It represents the item constraints collection.
CXTPReportRecordItemDateTime
Represents a time cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemEditOptions
This class represents edit options of the single item or column
CXTPReportRecordItemNumber
This class represents a numeric cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemPreview
This represents a preview cell and inherits basic functionality from CXTPReportRecordItem class.
CXTPReportRecordItemText
This Class represents a text-only cell and inherits basic functionality from CXTPReportRecordItem class. You create a text record item simply by calling a constructor with one parameter - text string
CXTPReportRecordItemVariant
Represents a variant item and inherits basic functionality from CXTPReportRecordItem class. You can create a bitmap record item simply by calling a constructor with the only one parameter - value of VARIANT type.
CXTPReportRecords
This class represents a records collection class. It supports an array of CXTPReportRecord pointers.
CXTPReportRow
CXTPReportRow class represents an row of the report control window.
CXTPReportRows
This class represents a rows collection class. It supports an array of CXTPReportRow pointers.
CXTPReportSelectedRows
Encapsulates a collection of CXTPReportRow pointers that represent the selected rows in a Report Control.
CXTPReportSubListControl
Field chooser list box control. This control allows the user to move column names from associated CXTPReportControl object from and to its header.
CXTPReportTip
The CXTPReportTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.
CXTPReportView
The CXTPReportView class provides an implementation of the Report control as view class. Use GetReportCtrl method to access methods of CXTPReportControl
CXTPReportViewPrintOptions
This class used to store printing options.


Classes

Classes
Classes
Classes
Class | Description
CXTPShortcutBar | CXTPShortcutBar is a CWnd derived class. It is used to implement an Outlook2003 ShortcutBar style control.
CXTPShortcutBarItem | CXTPShortcutBarItem is the base class representing an item of the ShortcutBar Control.
CXTPShortcutBarOffice2000Theme | CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarOffice2003Theme | CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarOffice2007Theme | CXTPShortcutBarOffice2007Theme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007 shortcut bar theme.
CXTPShortcutBarOfficeXPTheme | CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents the Office 2003 shortcut bar theme.
CXTPShortcutBarPaintManager | Standalone class used by CXTPShortcutBar as paint manager.
CXTPShortcutBarPane | CXTPShortcutBarPane is a CWnd derived class. It is used as client area of ShortcutBar control.
CXTPShortcutBarPaneItem | CXTPShortcutBarPaneItem is the base class representing an item of the panes.


Classes

Classes
Classes
Classes
Class | Description
CXTPSkinImage | CXTPSkinImage class represents simple bitmap holder and draw operations for Skin Framework
CXTPSkinImages | CXTPSkinImages represents cashed collection of CXTPSkinImage classes
CXTPSkinManager | CXTPSkinManager is a standalone class that represents a global object managing skins.
CXTPSkinManagerClass | CXTPSkinManagerClass is a standalone class that represents a single visual class of skin manager.
CXTPSkinManagerMetrics | CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin
CXTPSkinManagerResourceFile | CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources
CXTPSkinManagerSchema | CXTPSkinManagerSchema is standalone class used to read visual styles schema file
CXTPSkinManagerSchemaDefault | CXTPSkinManagerSchemaDefault is CXTPSkinManagerSchema derived class is used to implement standard visual style.
CXTPSkinManagerSchemaProperty | CXTPSkinManagerSchemaProperty is standalone class represented single property of visual styles ini file
CXTPSkinObject | CXTPSkinObject is a CWnd derived class. It represents base class for all skinable windows.
CXTPSkinObjectButton | CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class. It implements standard buttons
CXTPSkinObjectClassMap | CXTPSkinObjectClassMap class is standalone class that help map windows controls to skin framework classes.
CXTPSkinObjectComboBox | CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class. It implements standard comboboxes
CXTPSkinObjectComCtl32Control | CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class. It is base class for all ComCtl32 defined controls
CXTPSkinObjectDateTime | CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class. It implements date time control
CXTPSkinObjectEdit | CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class. It implements standard edit control
CXTPSkinObjectFrame | CXTPSkinObjectFrame is a CXTPSkinObject derived class. It is parent control for all implementations that have border or scroll bars
CXTPSkinObjectHeader | CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class. It implements standard list header control
CXTPSkinObjectListBox | CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class. It implements standard list box control
CXTPSkinObjectListView | CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class. It implements standard listview control
CXTPSkinObjectMonthCal | CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class. It implements month calendar
CXTPSkinObjectProgress | CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class. It implements standard progress control
CXTPSkinObjectScrollBar | CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class. It implements standard scroll bar control
CXTPSkinObjectSpin | CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class. It implements standard spin control
CXTPSkinObjectStatusBar | CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class. It implements standard status bar control
CXTPSkinObjectTab | CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class. It implements standard tab control
CXTPSkinObjectToolBar | CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class. It implements standard toolbar control
CXTPSkinObjectTrackBar | CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class. It implements standard track bar control
CXTPSkinObjectTreeView | CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class. It implements standard tree view control
CXTPSkinObjectUser32Control | CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class. It is base class for all User32 defined controls


Classes

Classes
Classes
Classes
Class | Description
CXTAnimationMemDC | CXTAnimationMemDC is a CXTMemDC derived class. This class can be used to render animation effects for the current device context.
CXTAuxData | CXTAuxData is a stand alone global item data structure class. It is used by the toolkit to initialize and store resource and item data shared by all objects. Items include system colors, icons, fonts and OS flags.
CXTAuxDataTheme | The CXTAuxDataTheme class is used by the CXTAuxData class to provide backward compatibility with older versions that still use bXPMode to provide Office XP theme support.
CXTBrowseButton | CXTBrowseButton is a CXTButton derived class that is used by CXTBrowseEdit to create the browse button that is used to display file dialogs and popup menus.
CXTBrowseDialog | CXTBrowseDialog is derived from the BROWSEINFO structure. It is used to display a directory chooser dialog using shell extensions.
CXTBrowseEdit | CXTBrowseEdit is a CXTEdit derived class. This class also has a push button associated with it. The control can be used to search for directories and files or activate a popup menu.
CXTButton | CXTButton is a CButton derived class. It is used to create flat style and image buttons. This control has several features including flat, semi-flat, and three dimensional borders.
CXTButtonTheme | CXTButtonTheme is used to draw the CXTButton object. All themes used for CXTButton should inherit from this base class.
CXTButtonThemeOffice2003 | CXTButtonThemeOffice2003 is a CXTButtonThemeOfficeXP derived class that is used to draw an Office 2003 style theme for the button.
CXTButtonThemeOfficeXP | CXTButtonThemeOfficeXP is a CXTButtonTheme derived class that is used to draw an Office XP style theme for the button.
CXTCaption | CXTCaption is a CStatic derived class. It is used to create caption or info bars similar to those in Microsoft(r) Outlook.
CXTCaptionButton | CXTCaptionButton is a CXTButton derived class. It is used by the CXTCaption class to activate a CXTCaptionPopupWnd window.
CXTCaptionButtonTheme | CXTCaptionButtonTheme is derived from CXTButtonTheme. This class is used to set the caption for buttons.
CXTCaptionButtonThemeOffice2003 | Class CXTCaptionButtonThemeOffice2003 is a CXTButtonThemeOffice2003 derived class. This class is used to create a button caption that resembles an Office 2003 button caption.
CXTCaptionButtonThemeOfficeXP | Class CXTCaptionButtonThemeOfficeXP is a CXTButtonThemeOfficeXP derived class. This class is used to create a button caption that resembles an Office XP button caption.
CXTCaptionPopupWnd | CXTCaptionPopupWnd is a CWnd derived class. It is used by the CXTCaption class to display a popup child window similar to Outlook(tm).
CXTCaptionTheme | CXTCaptionTheme is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.
CXTCaptionThemeOffice2003 | CXTCaptionThemeOffice2003 is derived from CXTCaptionTheme. It is used to set the caption to the Office 2003 theme.
CXTCaptionThemeOfficeXP | CXTCaptionThemeOfficeXP is a CXTThemeManagerStyle derived class. It is used to control the caption theme. It is used to control the theme of captions. Derive custom themes from CXTCaptionTheme.
CXTCheckListBox | The CXTCheckListBox class is a CXTListBox derived class. It provides the functionality of Office style checklist box. A "checklist box" displays a list of items such as filenames. Each item in the list has a check box next to it that the user can either check or clear.
CXTColorBase | CXTColorBase is a CStatic derived base class. It is used to create custom color selection windows.
CXTColorDialog | CXTColorDialog is a CPropertySheet derived class. It is an Office(tm) style color dialog and can be used as a drop in replacement for the MFC CColorDialog API.
CXTColorHex | CXTColorHex is a CStatic derived class. It displays a color selection grid used by CXTColorPageStandard.
CXTColorLum | CXTColorLum is a CXTColorBase derived class. It is used to create a color luminance selection bar.
CXTColorPageCustom | CXTColorPageCustom is derived from CXTThemePropertyPage. It is used to create a CXTColorPageCustom dialog.
CXTColorPageStandard | CXTColorPageStandard is derived from CXTThemePropertyPage, it is used to create a CXTColorPageStandard dialog.
CXTColorPicker | CXTColorPicker is a CXTButton derived class. It displays a color picker popup window (CXTColorPopup) for Office(tm) style color selection.
CXTColorPopup | CXTColorPopup is a CXTColorSelectorCtrl derived class. It is used to create a CXTColorPopup window that will allow a user to select colors and add custom colors to a color list.
CXTColorRef | CXTColorRef is a stand alone class. It is used to create a CXTColorRef object. This object is used for manipulation of RGB values.
CXTColorSelectorCtrl | CXTColorSelectorCtrl is a CWnd derived class. It is used to create a CXTColorSelectorCtrl control that will allow a user to select colors.
CXTColorSelectorCtrlTheme | CXTColorSelectorCtrlTheme is derived from CXTThemeManagerStyle to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorSelectorCtrlThemeOffice2003 | CXTColorSelectorCtrlThemeOffice2003 is derived from CXTColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorSelectorCtrlThemeOfficeXP | CXTColorSelectorCtrlThemeOfficeXP is derived from CXTColorSelectorCtrlTheme to handle theme specific visualizations for the CXTColorSelectorCtrl class.
CXTColorWnd | CXTColorWnd is a CXTColorBase derived class. It is used to create a color selection window.
CXTComboBoxEx | The CXTComboBoxEx class is a CComboBox derived class. It extends the combo box control by providing support for image lists.
CXTContextBkColorHandler | Background color context handler
CXTContextBkModeHandler | Background mode context handler
CXTContextTextColorHandler | Text color context handler
CXTContextViewPortOrgHandler | Handles viewport origin
CXTDateEdit | CXTDateEdit is a CXTMaskEdit derived class. It is specifically geared toward editing date fields.
CXTDateTimeCtrl | CXTDateTimeCtrl is a CWnd derived class. A CXTDateTimeCtrl object encapsulates the functionality of a date and time picker control.
CXTDirWatcher | The CXTDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur.
CXTDisabledButtonTheme | CXTDisabledButtonTheme is a CXTButtonTheme derived class that is used to draw 3D disabled icons for the button.
CXTDropSource | CXTDropSource class is derived from IDropSource. It is used by the shell list control to provide drag-and-drop operations in your application.
CXTEdit | CXTEdit is a CEdit derived class. The CXTEdit class provides the functionality of a Windows edit control. An edit control is a rectangular child window in which the user can enter text.
CXTEditListBox | CXTEditListBox is a CXTListBox derived class. It is used to create an editable list box. This list box can be configured to display a toolbar for editing. You can define browse styles to search for files or folders. Each entry is made editable with a double mouse click.
CXTEditListBoxToolBar | CXTEditListBoxToolBar is a CStatic derived class. It used by the CXTEditListBox class to create a toolbar above the edit list box to display icons for editing.
CXTExcelTabCtrl | CXTExcelTabCtrl is a CWnd derived class. It is used to create an Excel style sheet control. This control allows you to define if you want the control to have home, end, back, and next buttons.
CXTExcelTabCtrlButtonState | The CXTExcelTabCtrlButtonState class is used by the CXTExcelTabCtrl class to manage navigation button information. This class contains information about the state and command identifiers for the button.
CXTExcelTabCtrlTheme | CXTExcelTabCtrlTheme is used to draw the CXTExcelTabCtrl object. All themes used for CXTExcelTabCtrl should inherit from this base class.
CXTExcelTabCtrlThemeOffice2003 | CXTExcelTabCtrlThemeOffice2003 is used to draw the CXTExcelTabCtrl object.
CXTExcelTabCtrlThemeOfficeXP | CXTExcelTabCtrlThemeOfficeXP is used to draw the CXTExcelTabCtrl object.
CXTFlatComboBox | CXTFlatComboBox is a CComboBox derived class. The CXTFlatComboBox class can easily give your application's standard CComboBox control the Flat Look that is seen in many of the Microsoft(r) Office(tm) products.
CXTFlatComboBoxTheme | CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.
CXTFlatComboBoxThemeOffice2003 | CXTFlatComboBoxThemeOffice2003 class is derived from CXTFlatComboBoxThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.
CXTFlatComboBoxThemeOfficeXP | CXTFlatComboBoxThemeOfficeXP class is derived from CXTFlatComboBoxTheme. This class is used to create the Office 2000 Theme for flat controls.
CXTFlatEdit | CXTFlatEdit is a CXTEdit derived class. The CXTFlatEdit class can easily give your application's standard CEdit control the flat look that is seen in many of the Microsoft(r) Office(tm) products.
CXTFlatEditTheme | CXTFlatControlsTheme is used to draw the CXTTabCtrl object. All themes used for CXTTabCtrl should inherit from this base class.
CXTFlatEditThemeOffice2003 | CXTFlatEditThemeOffice2003 class is derived from CXTFlatEditThemeOfficeXP. This class is used to create the Office 2003 Theme for flat controls.
CXTFlatEditThemeOfficeXP | CXTFlatEditThemeOfficeXP class is derived from CXTFlatEditTheme. This class is used to create the Office 2000 Theme for flat controls.
CXTFlatHeaderCtrl | CXTFlatHeaderCtrl is a CHeaderCtrl derived class. It is used to create list box flat header controls that are similar to list box flat header controls seen in Visual Studio(tm) and Outlook(tm).
CXTFontCombo | CXTFontCombo is a CXTFlatComboBox derived class. It is used to create a combo box that displays a drop list of available fonts for your system. The fonts are displayed in their various styles.
CXTFontEnum | CXTFontEnum is a stand alone singleton font enumeration class. It is used to enumerate a list of fonts found installed for the operating system.
CXTFontListBox | CXTFontListBox is a CXTListBox derived class. It is used to create a font selection list box.
CXTHeaderCtrl | CXTHeaderCtrl is a CHeaderCtrl derived class. It is used to create a CXTHeaderCtrl window similar to CHeaderCtrl, but with additional functionality.
CXTHeaderCtrlTheme | CXTHeaderCtrlTheme is a theme class used to draw windows classic style theme for the header control.
CXTHeaderCtrlThemeExplorer | CXTHeaderCtrlThemeExplorer is a CXTHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control.
CXTHeaderCtrlThemeOffice2003 | CXTHeaderCtrlThemeOffice2003 is a CXTHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control.
CXTHeaderCtrlThemeOfficeXP | CXTHeaderCtrlThemeOfficeXP is a CXTHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control.
CXTHexEdit | CXTHexEdit is a CEdit derived class. It is used to create an edit control which will allow editing in hex display format.
CXTHtmlView | CXTHtmlView is a CFormView derived class. The CXTHtmlView class provides the functionality of the WebBrowser control within the context of MFC's document/view architecture. The WebBrowser control is a window in which the user can browse sites on the World Wide Web as well as folders in the local file system and on a network. The WebBrowser control supports hyperlinking, Uniform Resource Locator (URL) navigation, and maintains a history list.
CXTHyperLink | CXTHyperLink is a CStatic derived class. It is used to display a text string that is used as a hyperlink control. The link's active, hover, and selected color attributes are configurable.
CXTIconHandle | CXTIconHandle is a stand alone helper class. It is used to automatically destroy dynamically created hIcon handles.
CXTItemEdit | CXTItemEdit is a CXTBrowseEdit derived class. It is used to create a CXTItemEdit window that can be used as an "in-place" edit field that can be dynamically created for controls such as a list box.
CXTListBase | CXTListBase is a non-inherited class. It implements the extended list control services provided by the Xtreme Toolkit list control classes.
CXTListBox | CXTListBox is a CListBox derived class. CXTListBox extends the standard list box control to enable flicker free drawing.
CXTListCtrl | CXTListCtrl is a multiple inheritance class derived from CListCtrl and CXTListBase. This class implements flat header and generic sorting routines. See CXTListBase for additional functionality.
CXTListView | CXTListView is a multiple inheritance class derived from CListView and CXTListBase. This class implements flat header and generic sorting routines.
CXTListViewHelper | The CXTListViewHelper class is a helper class that provides helper functions for finding selected items for the MFC CListView class.
CXTLogFont | CXTLogFont is a self initializing LOGFONT derived class. It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.
CXTMaskEdit | CXTMaskEdit is a CEdit derived class. It allows text masking to be applied to the control to format it for special editing restrictions.
CXTMDIClientWnd | CXTMDIClientWnd is a CWnd derived helper class for the CXTMDIWndTab tab control. This class routes messages sent to the client window back to the tab control.
CXTMDIWndTab | CXTMDIWndTab class is used for creating a tabbed MDI document interface.
CXTMemDC | CXTMemDC is a CDC derived class. CXTMemDC is an extension of CDC that helps eliminate screen flicker when windows are resized, by painting to an off screen bitmap. The class then uses CDC::BitBlt to copy the bitmap back into the current device context after all items have been painted.
CXTMemFile | CXTMemFile is a CMemFile derived class. It is used to create a CXTMemFile object to support memory files.
CXTMenuListBox | CCXTMenuListBox is a CListBox derived class. It is used to implement an Outlook bar style control. It can only be used with the LBS_OWNERDRAWVARIABLE style bit set. This is a simpler version of CXTOutBarCtrl and does not allow for shortcut folders.
CXTMenuListBoxTheme | CXTMenuListBoxTheme is used to draw the CXTMenuListBox object. All themes used for CXTButton should inherit from this base class.
CXTMenuListBoxThemeOffice2003 | Class CXTMenuListBoxThemeOffice2003 is derived from CXTMenuListBoxThemeXP. This class is used to implement the Office 2003 theme for Menu List Boxes.
CXTMenuListBoxThemeOfficeXP | Class CXTMenuListBoxThemeOfficeXP is derived from CXTMenuListBoxTheme. This class is used to implement the Office XP theme for Menu List Boxes.
CXTMonthCalCtrl | CXTMonthCalCtrl is a CWnd derived class. A CXTMonthCalCtrl object encapsulates the functionality of a month calendar control.
CXTNonClientMetrics | CXTNonClientMetrics is a self initializing NONCLIENTMETRICS derived class. It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.
CXTOutBarCtrl | CXTOutBarCtrl is a CWnd derived class. It is used to create a shortcut bar window similar to the shortcut bar seen in Outlook(tm).
CXTOutBarCtrlTheme | CXTOutBarCtrlTheme is used to draw the CXTOutBarCtrl object. All themes used for CXTOutBarCtrl should inherit from this base class.
CXTOutBarCtrlThemeOffice2003 | Class CXTOutBarCtrlThemeOffice2003 is derived form CXTOutBarCtrlThemeXP. This class is used to draw an OutBar with the Office XP theme.
CXTOutBarCtrlThemeOfficeXP | Class CXTOutBarCtrlThemeOfficeXP is derived form CXTOutBarCtrlTheme. This class is used to draw an OutBar with the Office XP theme.
CXTOutBarEditItem | CXTOutBarEditItem is a helper class derived from CXTEdit. It is used by CXTOutBarCtrl, an Outlook like control, to create an in-place edit box that is used to modify a folder or an item within the control.
CXTOutBarFolder | CXTOutBarFolder is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder specified in the Outlook bar control.
CXTOutBarItem | CXTOutBarItem is a stand alone helper class. It is used by the CXTOutBarCtrl to maintain information about each folder item specified in the Outlook bar control.
CXTPagerCtrl | CXTPagerCtrl is a CWnd derived class. It is used to contain and scroll another window, and wraps the windows pager API.
CXTPPopupControl | CXTPPopupControl is a class for control of popup window
CXTPPopupItem | CXTPPopupItem is a class used to management popup item object
CXTPPopupPaintManager | CXTPPopupPaintManager is a class used to perform specialized drawing tasks.
CXTPPopupThemeMSN | CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks.
CXTPPopupThemeOffice2000 | CXTPPopupThemeOffice2000 is a class used to perform Office2000 drawing tasks.
CXTPPopupThemeOffice2003 | CXTPPopupThemeOffice2003 is a class used to perform Office2003 drawing tasks.
CXTPPopupThemeOffice2007 | CXTPPopupThemeOffice2007 is a class used to perform Office2007 drawing tasks.
CXTPPopupThemeOfficeXP | CXTPPopupThemeOfficeXP is a class used to perform OfficeXP drawing tasks.
CXTPPropertyPage | CXTPPropertyPage is a CPropertyPage derived class Objects of class CPropertyPage represent individual pages of a property sheet
CXTPPropertyPageControlNavigator | CXTPPropertyPageControlNavigator is CXTPPropertyPageNavigator derived class It represents base control property page navigator
CXTPPropertyPageListNavigator | CXTPPropertyPageListNavigator is CXTListBox and CXTPPropertyPageControlNavigator derived class It represents list property page navigator
CXTPPropertyPageNavigator | CXTPPropertyPageNavigator is a standalone class CXTPPropertyPageNavigator represents base navigator object for CXTPPropertySheet
CXTPPropertyPageTabNavigator | CXTPPropertyPageTabNavigator is CXTPTabControl and CXTPPropertyPageNavigator derived class It represents tabbed property page navigator
CXTPPropertyPageTreeNavigator | CXTPPropertyPageTreeNavigator is CTreeCtrl and CXTPPropertyPageControlNavigator derived class It represents tree property page navigator
CXTPPropertySheet | CXTPPropertySheet is a CDialog derived class It represents property sheet, otherwise known as tab dialog box. A property sheet consists of a CXTPPropertySheet object and one or more CXTPPropertyPage objects.
CXTPTaskDialog | The CXTPTaskDialog class creates, displays, and operates a task dialog. A task dialog is similar to, while much more flexible than, a basic message box. The task dialog contains application-defined messages, title, verification check box, command links and push buttons, plus any combination of predefined icons and push buttons.
CXTRegistryManager | CXTRegistryManager is a stand alone registry management class. You can use it to read and write values from your system's registry or an .INI file. Use CXTRegistryManager to read and write string, integer, and binary data to and from the registry. You can also specify an .INI file name, and have these values stored there instead.
CXTResize | CXTResize is a base class. It is used by resizing dialogs, property sheets, and form views. It acts as a manager to maintain size and location of the dialog and dialog items.
CXTResizeDialog | CXTResizeDialog is a multiple inheritance class derived from CDialog and CXTResize. CXTResizeDialog is used to create a resizable CDialog type object that allows its dialog items to be resized or moved dynamically.
CXTResizeFormView | CXTResizeFormView is a multiple inheritance class derived from CFormView and CXTResize. CXTResizeFormView is used to create a resizable CFormView type object that allows its form items to be resized or moved dynamically.
CXTResizeGroupBox | CXTResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing. This class is intended to only be used as a group box and only used on a CXTResize window. You can subclass or create this object the way you would any CButton.
CXTResizeItem | CXTResizeItem is a stand alone helper class. It is used by CXTResize to maintain information about each item to be sized or moved.
CXTResizePoint | CXTResizePoint is an XT_RESIZEPOINT structure derived class. The CXTResizePoint class is similar to the XT_RESIZEPOINT structure. It also includes member functions to manipulate CXTResizePoint and XT_RESIZEPOINT structures. A CXTResizePoint object can be used wherever an XT_RESIZEPOINT structure is used.
CXTResizePropertyPage | CXTResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTResize. CXTResizePropertyPage is used to create a resizable CPropertyPage type object that allows its dialog items to be resized or moved dynamically.
CXTResizePropertySheet | CXTResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTResize. CXTResizePropertySheet is used to create a resizable CPropertySheet type object that allows its dialog items to be resized or moved dynamically.
CXTResizeRect | CXTResizeRect is an XT_RESIZERECT structure derived class. The CXTResizeRect class is similar to an XT_RESIZERECT structure. CXTResizeRect also includes member functions to manipulate CXTResizeRect objects and XT_RESIZERECT structures.
CXTSearchOptionsCtrl | CXTSearchOptionsCtrl is a CStatic derived class. CXTSearchOptionsCtrl is used to create a control similar to the Search Options item found in the search pane of Windows Explorer as it is seen in Windows 2000 and later. This class allows you to associate a group of controls to be hidden or shown when the item is expanded and contracted and a set of controls that need to move depending on the CXTSearchOptionsCtrl state. Use with CXTSearchOptionsView form view class to create a pane similar to the Windows Explorer search pane. To use the control, define a set of controls that... more
CXTSearchOptionsView | CXTSearchOptionsView is a CFormView derived class. It is to be used with a CXTSearchOptionsCtrl object to paint the background and control background color white. It is also used for resizing and moving children of the form automatically.
CXTShellListBase | CXTShellListBase is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListBase class object.
CXTShellListCtrl | CXTShellListCtrl is a multiple inheritance class derived from CXTListCtrl and CXTShellPidl. It is used to create a CXTShellListCtrl window.
CXTShellListCtrlEx | CXTShellListCtrlEx is a CXTShellListCtrl derived class. It is used to create a stand-alone shell list control that is not dependent on a CXTShellTreeCtrl for initialization. It is used to create a CXTShellListCtrlEx window for displaying the contents of file folders.
CXTShellListView | CXTShellListView is a multiple inheritance class derived from CXTListView and CXTShellPidl. It is used to create a CXTShellListView class object.
CXTShellPidl | CXTShellPidl is a stand alone base class. This class is used by the shell tree and list controls to handle PIDL creation and management.
CXTShellSettings | CXTShellSettings is a SHELLFLAGSTATE struct derived class. CXTShellSettings extends the SHELLFLAGSTATE struct for easy access to the shell flag state settings.
CXTShellTreeBase | CXTShellTreeBase is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeBase class object.
CXTShellTreeCtrl | CXTShellTreeCtrl is a multiple inheritance class derived from CXTTreeCtrl and CXTShellPidl. CXTShellTreeCtrl is used to create a tree control that displays an explorer style tree, and can be associated with a combo box and list control.
CXTShellTreeView | CXTShellTreeView is a multiple inheritance class derived from CXTTreeView and CXTShellPidl. It is used to create a CXTShellTreeView class object.
CXTSizeIcon | The CXTSizeIcon class is a CStatic derived helper class. It is used by CXTResize to display the sizing grip in the lower right corner of a sizing window.
CXTSortClass | CXTSortClass is a stand alone class. This class will sort a list control by a column of text, integer, float or date/time type. It could be easily extended for other data types. To use this class, instantiate a CXTSortClass object, passing in a pointer to the list control as the first argument and the column index as the second argument.
CXTSplitPath | CXTSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension.
CXTSplitterWnd | CXTSplitterWnd is a CSplitterWnd derived class. It adds the ability to hide and show splitter panes based upon its index.
CXTSplitterWndEx | CXTSplitterWndEx is a CXTSplitterWnd derived class. It can be used with the CXTOutBarCtrl to display a gap between the top of the splitter and the toolbar area.
CXTSplitterWndTheme | Class CXTSplitterWndTheme is derived from CXTThemeManagerStyle. This class is used to apply a Theme to splitter windows.
CXTSplitterWndThemeOffice2003 | Class CXTSplitterWndThemeOffice2003 is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.
CXTSplitterWndThemeOfficeXP | Class CXTSplitterWndThemeOfficeXP is derived from CXTSplitterWndTheme. This class is used to implement the Office 2003 theme for splitter windows.
CXTTabBase | CXTTabBase is a stand alone base class. It is used to draw an XP style tab control.
CXTTabBaseTheme | CXTTabBaseTheme is used to draw the CXTTabBase object. All themes used for CXTTabBase should inherit from this base class.
CXTTabBaseThemeOffice2003 | Class CXTTabBaseThemeOffice2003 is derived from CXTTabBaseThemeOfficeXP.
CXTTabBaseThemeOfficeXP | Class CXTTabBaseThemeOfficeXP is derived from CXTTabBaseTheme. This class is used to implement the office XP theme for the tab controls.
CXTTabCtrl | CXTTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTTabCtrlBase. It is used to create a CXTTabCtrl class object. See CXTTabCtrlBase for additional functionality.
CXTTabCtrlButton | CXTTabCtrlButton is a stand alone structure class. It is internal used in CXTTabCtrlButtons class.
CXTTabCtrlButtons | CXTTabCtrlButtonsis a CWnd derived class. It is internally used in the CXTTabBase class.
CXTTabExBase | CXTTabExBase is a stand alone base class. It is used to draw an XP style tab control.
CXTTabView | CXTTabView is a multiple inheritance class derived from CCtrlView and CXTTabCtrlBaseEx. CXTTabView can be used to create a view that contains nested views displayed in a tab control. See CXTTabCtrlBaseEx for additional functionality.
CXTTcbItem | CXTTcbItem class is used to maintain information for a particular tab item in a CXTExcelTabCtrl, CXTTabCtrl and CXTTabView object.
CXTThemeManager | CXTThemeManager is standalone class used to manage the visual styles for your application.
CXTThemeManagerStyle | CXTThemeManagerStyle is standalone class used as base for any components theme.
CXTThemeManagerStyleFactory | CXTThemeManagerStyleFactory is CObject derived class. It managed themes of corresponded CXTThemeManagerStyleHost class
CXTThemeManagerStyleHost | CXTThemeManagerStyleHost is standalone class. It used as base class for all themed component.
CXTTimeEdit | CXTTimeEdit is a CXTDateEdit derived class. It is specifically geared toward editing time fields.
CXTTipOfTheDay | CXTTipOfTheDay is a CDialog derived class. CXTTipOfTheDay is used to create a Visual Studio(tm) style Tip Of The Day dialog. To use, place a file called "tips.txt" in the same directory as your application exe. Place each tip on its own line.
CXTTipWindow | CXTTipWindow is a CWnd derived class. It is used to create a CXTTipWindow object. CXTTipWindow objects are tooltip style popup windows that can display useful information to the end user. Possible options include shadows, borders, and background color settings.
CXTToolbarButtonTheme | CXTToolbarButtonTheme is a CXTDisabledButtonTheme derived class that is used to draw Windows XP style toolbar theme for the button.
CXTToolBox | CXTToolBox is a CXTOutBarCtrl derived class. It is used to create a toolbox control similar to the toolbox control seen in VisualStudio.NET.
CXTTrayIcon | CXTTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure. It is used to display a system tray icon with animation.
CXTTreeBase | CXTTreeBase is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.
CXTTreeCtrl | CXTTreeCtrl is a CTreeCtrl derived class. It extends the CTreeCtrl class to add additional functionality, including tree traversal, searching, color, and settings.
CXTTreeView | CXTTreeView is a CTreeView derived class. It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.
CXTWindowList | CXTWindowList dialog
CXTWindowPos | CXTWindowPos is a WINDOWPLACEMENT structure derived class. It extends the WINDOWPLACEMENT structure, and is used to save and restore window position.


Classes Templates

Classes Templates
Classes | Legend
Templates
Template | Description
CXTContextObjectHandler | Safely selects object into device context


Classes

Classes
Classes
Classes
Class
Description
CXTPSyntaxEditAutoCompleteWnd
This class implements AutoComplete window. It provides facilities to display predefined strings of data in the sorted order. Then user can navigate over list of strings and choose desired text to complete his input. AutoComplete window provides some ways to navigate by using vertical scroll bar, up/down keys, mouse. If user types alphanumeric keys after AutoComplete window was appeared it uses user input as search criteria and tries to find text from its predefined strings of data that are like user input.
CXTPSyntaxEditBatchCommand
This class represents a pack of some commands in one. It stores commands in the list, and implements standard command execution interfaces on command (un)execution.
CXTPSyntaxEditBufferCommand
The base class for all edit commands related to CXTPSyntaxEditBufferManager. It stores handle of the buffer manager, and provides implementation of common buffer operations, such as text insertion or deletion.
CXTPSyntaxEditBufferManager
This class is the main class for buffer management. One instance of this class is attached with a CXTPSyntaxEditCtrl object. This class contains a list of CBufferIndex class which in turn contains a position in the file (In case of un-modified index) or a CEditBuffer pointer.
CXTPSyntaxEditColorComboBox
This class allow edit colors using combobox control. It display color name and draw rectangle for each item using item color.
CXTPSyntaxEditColorInfo
This storage class is designed to contain information from the color settings file section. It helps easy retrieve color information.
CXTPSyntaxEditColorInfoArray
CXTPSyntaxEditColorSampleText
This class, derived from CStatic, used to display sample of colored text.
CXTPSyntaxEditColorTheme
This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes color settings for corresponding lexical items for given language. You construct instance of CXTPSyntaxEditColorTheme by calling constructor. Then you should call Load() member function to read data from persistent storage (file for this implementation), CXTPSyntaxEditLexColorInfo structures.
CXTPSyntaxEditColorThemesManager
This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.
CXTPSyntaxEditCommand
This class represents abstract Edit Control command interface. Its descendants must implement custom Execute and UnExecute functionality depending on a command type.
This class is used internally by the library only.
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control. It worries about read configuration files from disk when the Edit control is starting, store it in internal structures and refresh parameters in case configuration files are changed after control was started.
CXTPSyntaxEditCtrl
This class is the main CWnd - based editor class. It is a rectangular child window in which the user can enter and edit text.
The control is also capable of enhance text coloring for a number of specific input file types, e.c. C/C++ source files, HTML files, etc. User can create and customize his own text files schemes - they are independent of source files. The control contains the main configuration file, which can contain references to any specific configuration files. By default, this file is placed in the same folder as the application executable and is called... more
CXTPSyntaxEditDeleteStringCommand
This class represents text deletion command. Command execution will delete text from the buffer between specified text positions, its un-execution will insert this text into the buffer.
CXTPSyntaxEditDoc
This class represents a Document portion of the Edit control. It extends functionality provided by CDocument class from MFC's document-view model implementation. CXTPSyntaxEditDoc class works together with CXTPSyntaxEditView and provides storage facilities for it.
CXTPSyntaxEditFileChangesMonitor
this class monitors files changes
CXTPSyntaxEditFindReplaceDlg
This class implements a Find and Replace dialogs for a SyntaxEdit control.
CXTPSyntaxEditGoToLineDlg
This class implements a GoToLine dialog for a SyntaxEdit control.
CXTPSyntaxEditInsertStringCommand
This class represents text insertion command. Command execution will insert a specified text string in the buffer, un-execution will delete this text from the buffer.
CXTPSyntaxEditLexCfgFileReader
This class provides functionality to read configuration information from configuration files with predefined structure. Its information describes lex class instances that represent various lexical items for given language. You construct instance of CXTPSyntaxEditLexCfgFileReader by calling constructor. Then you should call ReadSource() member function to read data from persistent storage (file for this implementation), and process raw data into XTP_EDIT_LEXCLASSINFO structures. Call GetLexClassInfoArray() member function to return a pointer to an array of XTP_EDIT_LEXCLASSINFO data structures.
CXTPSyntaxEditLexClass
CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.
CXTPSyntaxEditLexOnScreenParseCnt
CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process.
CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in separate thread. It also control this working thread and provide interthread interaction.
CXTPSyntaxEditLexParserSchemaOptions
This class is designed to easily manipulate parser options.
CXTPSyntaxEditLexTextBlock
CXTPSyntaxEditLexTextBlock class represents a pice (block) of text which corresponds some lex class in a text schema. It stores start position, end position, pointer to the lex class object in a class schema and some other information. Text blocks organized as a bidirectional list and as tree structure.
CXTPSyntaxEditLexTextSchema
CXTPSyntaxEditLexTextSchema class is used to store data which necessary to parse a text and parsing results. It also contains methods to run lex classes from a class schema, methods to update text schema when text is edited, methods to reparse text, to get information which is necessary to draw colorized text and other helper methods.
CXTPSyntaxEditLexTokensDef
This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators.
CXTPSyntaxEditLexVariable
CXTPSyntaxEditLexVariable class is used to represent lexical variables. In the class schema variables begins from symbol @. Standard variables are: @alpha, @digit, @HexDigit, @specs, @EOL.
CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type.
CXTPSyntaxEditLineMarksManager
CXTPSyntaxEditLineMarksManager class provides functionality to to manipulate marks on text lines. Used internally by the Smart Edit control.
CXTPSyntaxEditPaintManager
This class used by CXTPSyntaxEditCtrl as the paint manager.
CXTPSyntaxEditPropertiesDlg
This class provide a default dialog to edit syntax edit control settings.
CXTPSyntaxEditPropertiesPageColor
This class implements a property page colors options.
CXTPSyntaxEditPropertiesPageEdit
This class implements a property page for common edit options.
CXTPSyntaxEditPropertiesPageFont
This class implements a property page font options.
CXTPSyntaxEditReplaceStringCommand
This class represents text replacing command. Command execution will replace text from the buffer between specified text positions, un-execution will do contrary replacement.
CXTPSyntaxEditTextIterator
This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, determine control symbols like CRLF. When you create instance of CXTPSyntaxEditTextIterator class you should provide pointer to data storage, represented by CXTPSyntaxEditTextIterator class.
CXTPSyntaxEditTextRegion
This class is designed to store coordinates of text region.
CXTPSyntaxEditTextSchemesManager
This class provides functionality to store set of all color themes that would be written from configuration files. For short it is custom collection class.
CXTPSyntaxEditTipComboBox
This class implements a combo box with tooltip.
CXTPSyntaxEditTipListBox
This class implements a list box with tooltip.
CXTPSyntaxEditTipWnd
CXTPSyntaxEditTipWnd implements a tooltip window for CXTPSyntaxEditTipListBox class.
CXTPSyntaxEditToolTipCtrl
The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the report area.
CXTPSyntaxEditToolTipCtrl provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip.
This class is used by the report control internally.
CXTPSyntaxEditUndoRedoManager
This class maintains the list of undo/redo commands. It is managed by CEditBufferManager class.
It allows adding new commands in the buffer (see AddCommand()), undoing last added operation (see DoUndo()), and redoing operations following the latest unexecuted (see DoRedo()).
It also allows checking for the possibility of performing undo/redo operations (see CanUndo() / CanRedo()).
It also allows marking current position of undo/redo operation queue as saved, and returns "modified" flag if the queue position will be changed (see MarkSaved() / IsModified()).
Another piece of the functionality is commands grouping. There are following methods... more
CXTPSyntaxEditView
This class represents a View portion of the Edit Control. It extends functionality provided by CView class from MFC's document-view model implementation. CXTPSyntaxEditView class works together with CXTPSyntaxEditDoc and provides facilities for it to be displayed on a screen or printed on a printer.
CXTPSyntaxEditViewPrintOptions
Describes printing options for the Calendar Control.


Classes Structures

Classes Structures
Classes | Legend
Structures
Structure | Description
XTP_EDIT_ACDATA | XTP_EDIT_ACDATA structure defines items displayed data. Provides text and icon for each displayed line in Auto-complete window.
XTP_EDIT_COLLAPSEDBLOCK | Stores collapsed block parameters.
XTP_EDIT_COLORVALUES | XTP_EDIT_COLORVALUES struct stores the colors for different phrases
XTP_EDIT_FONTOPTIONS | XTP_EDIT_FONTOPTIONS struct is a self initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length.
XTP_EDIT_LINECOL | XTP_EDIT_LINECOL structure represents coordinates of text items on the displaying context in terms of line/column.
XTP_EDIT_ROWSBLOCK | XTP_EDIT_ROWSBLOCK struct
XTP_EDIT_TEXTBLOCK | XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing


Classes Templates

Classes Templates
Classes | Legend
Templates
Template | Description
CXTPSyntaxEditLexVariantPtrArrayExAutomatT |


Classes

Classes
Classes
Classes
Class | Description
CXTPTabControl | CXTPTabControl is a multiple inheritance class derived from CXTPTabManager and CWnd. It is used to draw enhance tab control with Office 2003, Visual Studio, Win XP tabs.
CXTPTabManager | CXTPTabManager is a CXTPTabManagerAtom derived class. This is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
CXTPTabManagerAtom | CXTPTabManagerAtom is a class that has only one purpose, which is to catch the event when a property of the PaintManager has changed. When a property of the PaintManager has changed, the OnPropertyChanged event if called. When the OnPropertyChanged is caught, Reposition is called to recalculate self layout.
CXTPTabManagerItem | CXTPTabManagerItem is a CCmdTarget derived class that represents a tab item. This is the base class for the tabs that appear in the CommandBars TabWorkSpace, DockingPanes, and TabControl.
CXTPTabManagerNavigateButton | CXTPTabManagerNavigateButton is a class used to represent the tab navigation buttons.
CXTPTabPaintManager | CXTPTabPaintManager is a CCmdTarget derived class that is used to store the color and appearance information of the tabs in the tab manager.


Classes

Classes
Classes
Classes
Class | Description
CXTPTaskPanel | CXTPTaskPanel is a CWnd derived class. It is used to implement an Explorer and Office-like Task Panel control.
CXTPTaskPanelExplorerTheme | Class that represents an Explorer style theme.
CXTPTaskPanelExplorerThemePlain | The CXTPTaskPanelExplorerThemePlain class is used to enable a classic Explorer style theme.
CXTPTaskPanelGroup | CXTPTaskPanelGroup is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single group.
CXTPTaskPanelGroupItem | CXTPTaskPanelGroupItem is a CXTPTaskPanelItem derived class. It is used in TaskPanel control as single item of the group.
CXTPTaskPanelGroupItems | CXTPTaskPanelGroupItems is a CXTPTaskPanelItems derived class. It is used as collection of items in the group.
CXTPTaskPanelGroups | CXTPTaskPanelGroups is a CXTPTaskPanelItems derived class. It is used as a collection of groups in the control.
CXTPTaskPanelItem | CXTPTaskPanelItem is a CCmdTarget derived class. It is used in TaskPanel control as parent for CXTPTaskPanelGroupItem and CXTPTaskPanelGroup classes.
CXTPTaskPanelItems | CXTPTaskPanelItems is a CCmdTarget derived class. It is used as collection of CXTPTaskPanelItem classes.
CXTPTaskPanelListViewOffice2003Theme | The CXTPTaskPanelListViewOffice2003Theme class is used to enable a List View Office 2003 style theme.
CXTPTaskPanelListViewOfficeXPTheme | The CXTPTaskPanelListViewOfficeXPTheme class is used to enable a List View Office XP style theme.
CXTPTaskPanelListViewTheme | The CXTPTaskPanelListViewTheme class is used to enable a List View style theme.
CXTPTaskPanelOffice2003Theme | Class that represents an Office 2003 style theme.
CXTPTaskPanelOffice2003ThemePlain | The CXTPTaskPanelOffice2003ThemePlain class is used to enable a classic Office 2003 style theme.
CXTPTaskPanelOfficeXPThemePlain | The CXTPTaskPanelOfficeXPThemePlain class is used to enable a classic Office XP style theme.
CXTPTaskPanelPaintManager | Standalone class used by CXTPTaskPanel as paint manager.
CXTPTaskPanelPaintManagerPlain | Base class theme that all other themes are derived from. Use this class when creating a custom theme.
CXTPTaskPanelScrollButton | CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button.
CXTPTaskPanelShortcutBarOffice2003Theme | CXTPTaskPanelShortcutBarOffice2003Theme is a CXTPTaskPanelListViewOffice2003Theme derived class used to enable an Office 2003 ShortcutBar style theme.
CXTPTaskPanelShortcutBarOffice2007Theme | CXTPTaskPanelShortcutBarOffice2007Theme is a CXTPTaskPanelShortcutBarOffice2003Theme derived class used to enable an Office 2007 ShortcutBar style theme.
CXTPTaskPanelToolboxTheme | The CXTPTaskPanelToolboxTheme class is used to enable a Toolbox style theme.
CXTPTaskPanelToolboxWhidbeyTheme | The CXTPTaskPanelToolboxWhidbeyTheme class is used to enable a VS.NET Whidbey style theme.


Files

Files
Files
Files
File | Description
XTPCalendarControl.h | XTPCalendarControl.h: interface for the CXTPCalendarControl class.
XTPCalendarController.h | XTPCalendarController.h: interface for the CXTPCalendarController class.
XTPCalendarControlView.h | XTPCalendarControlView.h: interface for the CXTPCalendarControlView class.
XTPCalendarCustomDataProvider.h | XTPCalendarCustomDataProvider.h: interface for the CXTPCalendarCustomProperties class.
XTPCalendarCustomProperties.h | XTPCalendarCustomProperties.h: interface for the CXTPCalendarCustomProperties class.
XTPCalendarData.h | XTPCalendarData.h: interface for the CXTPCalendarData class.
XTPCalendarDatabaseDataProvider.h | XTPCalendarDatabaseDataProvider.h: interface for the CXTPCalendarDatabaseDataProvider class.
XTPCalendarDayView.h | XTPCalendarDayView.h: interface for the CXTPCalendarDayView class.
XTPCalendarDayViewDay.h | XTPCalendarDayViewDay.h: interface for the CXTPCalendarDayViewDay class.
XTPCalendarDayViewEvent.h | XTPCalendarDayViewEvent.h: interface for the CXTPCalendarDayViewEvent class.
XTPCalendarDayViewTimeScale.h | XTPCalendarDayViewTimeScale.h: interface for the CXTPCalendarDayViewTimeScale class.
XTPCalendarDefines.h | XTPCalendarDefines.h: interface for the CXTPCalendarEvent class.
XTPCalendarEvent.h | XTPCalendarEvent.h: interface for the CXTPCalendarEvent class.
XTPCalendarEventLabel.h | XTPCalendarEventLabel.h: interface for the CXTPCalendarEventLabel and CXTPCalendarEventLabels classes.
XTPCalendarEvents.h | XTPCalendarEvents.h: CXTPCalendarEvents template.
XTPCalendarMAPIDataProvider.h | XTPCalendarMAPIDataProvider.h: interface for the CXTPCalendarData class.
XTPCalendarMAPIWrapper.h | XTPCalendarMAPIWrapper.h: interface for the CXTPCalendarMAPIWrapper class.
XTPCalendarMemoryDataProvider.h | XTPCalendarMemoryDataProvider.h: interface for the CXTPCalendarMemoryDataProvider class.
XTPCalendarMonthView.h | XTPCalendarMonthView.h: interface for the CXTPCalendarMonthView class.
XTPCalendarMonthViewDay.h | XTPCalendarMonthViewDay.h: interface for the CXTPCalendarMonthViewDay class.
XTPCalendarMonthViewEvent.h | XTPCalendarMonthViewEvent.h: interface for the CXTPCalendarMonthViewEvent class.
XTPCalendarNotifications.h | XTPCalendarNotifications.h: unique notifications identifiers for CXTPCalendarControl class.
XTPCalendarOccurSeriesChooseDlg.h | XTPCalendarOccurSeriesChooseDlg.h interface for CXTPCalendarOccurSeriesChooseDlg class.
XTPCalendarOptions.h | XTPCalendarOptions.h: interface for the CXTPCalendarOptions class.
XTPCalendarPaintManager.h | XTPCalendarControlPaintManager.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarPtrCollectionT.h | XTPCalendarPtrCollectionT.h: CXTPCalendarPtrCollectionT template.
XTPCalendarPtrs.h | XtpCalendarPtrs.h: This file is a part of the XTREME CALENDAR MFC class library.
XTPCalendarRecurrencePattern.h | XTPCalendarRecurrencePattern.h: interface for the CXTPCalendarRecurrencePattern class.
XTPCalendarRemindersManager.h | XTPCalendarRemindersManager.h: interface for the CXTPCalendarRemindersManager class.
XTPCalendarResource.h | XTPCalendarResource.h: interface for the CXTPCalendarResource class.
XTPCalendarResourcesManager.h | XTPCalendarResourcesManager.h: interface for the CXTPCalendarResourcesManager class.
XTPCalendarTheme.h | XTPCalendarTheme.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarThemeOffice2007.h | XTPCalendarThemeOffice2007.h: interface for the CXTPCalendarControlPaintManager class.
XTPCalendarTimeZoneHelper.h | XTPCalendarTimeZoneHelper.h: interfaces for Time Zone Helper classes.
XTPCalendarTip.h | XTPCalendarTip.h: interface for the CXTPCalendarTip class.
XTPCalendarUtils.h | XTPCalendarUtils.h: interface for the CXTPCalendarUtils class.
XTPCalendarView.h | XTPCalendarView.h: interface for the CXTPCalendarView class.
XTPCalendarViewDay.h | XTPCalendarViewDay.h: interface for the CXTPCalendarViewDay class.
XTPCalendarViewEvent.h | XTPCalendarViewEvent.h: interface for the CXTPCalendarViewEvent class.
XTPCalendarViewPart.h | XTPCalendarViewPart.h: interface for the CXTPCalendarViewPart class.
XTPCalendarWeekView.h | XTPCalendarWeekView.h: interface for the CXTPCalendarWeekView class.
XTPCalendarWeekViewDay.h | XTPCalendarWeekViewDay.h: interface for the CXTPCalendarWeekViewDay class.
XTPCalendarWeekViewEvent.h | XTPCalendarWeekViewEvent.h: interface for the CXTPCalendarWeekViewEvent class.
XTPDatePickerControl.h | XTPDatePickerControl.h: interface for the CXTPDatePickerControl class.
XTPDatePickerDaysCollection.h | XTPDatePickerDaysCollection.h: interface for the CXTPDatePickerDaysCollection class.
XTPDatePickerItemDay.h | XTPDatePickerItemDay.h: interface for the CXTPDatePickerItemDay class.
XTPDatePickerItemMonth.h | XTPDatePickerItemMonth.h: interface for the CXTPDatePickerItemMonth class.
XTPDatePickerList.h | XTPDatePickerItemList.h: interface for the CXTPDatePickerItemList class.
XTPDatePickerNotifications.h | XTPDatePickerNotifications.h: interface for the CXTPDatePickerData class.
XTPDatePickerPaintManager.h | XTPDatePickerPaintManager.h: interface for the CXTPDatePickerPaintManager class.
XTPTopLevelWndMsgNotifier.h | XTPTopLevelWndMsgNotifier.h: interface for the CXTPTopLevelWndMsgNotifier class.


Files

Files
Files
Files
File | Description
XTPCommandBar.h | XTPCommandBar.h : interface for the CXTPCommandBar class.
XTPCommandBars.h | XTPCommandBars.h : interface for the CXTPCommandBars class.
XTPCommandBarsDefines.h | XTPCommandBarDefines.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControl.h | XTPControl.h : interface for the CXTPControl class.
XTPControlButton.h | XTPControlButton.h : interface for the CXTPControlButton class.
XTPControlComboBox.h | XTPControlComboBox.h : interface for the CXTPControlComboBox class.
XTPControlComboBoxExt.h | XTPControlComboBoxExt.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlCustom.h | XTPControlCustom.h : interface for the CXTPControlCustom class.
XTPControlEdit.h | XTPControlEdit.h : interface for the CXTPControlEdit class.
XTPControlExt.h | XTPControlExt.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlGallery.h | XTPControlGallery.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPControlListBox.h | XTPControlListBox.h : interface for the CXTPControlListBox class.
XTPControlPopup.h | XTPControlPopup.h : interface for the CXTPControlPopup class.
XTPControlPopupColor.h | XTPControlPopupColor.h : interface for the CXTPControlPopupColor class.
XTPControls.h | XTPControls.h : interface for the CXTPControls class.
XTPCustomizeCommandsPage.h | XTPCustomizeCommandsPage.h : interface for the CXTPCustomizeCommandsPage class.
XTPCustomizeKeyboardPage.h | XTPCustomizeKeyboardPage.h : interface for the CXTPCustomizeKeyboardPage class.
XTPCustomizeOptionsPage.h | XTPCustomizeOptionsPage.h : interface for the CXTPCustomizeOptionsPage class.
XTPCustomizeSheet.h | XTPCustomizeSheet.h : interface for the CXTPCustomizeSheet class.
XTPCustomizeToolbarsPage.h | XTPCustomizeToolbarsPage.h : interface for the CXTPCustomizeToolbarsPage class.
XTPCustomizeTools.h | XTPCustomizeTools.h This file is a part of the XTREME COMMANDBARS MFC class library.
XTPDialogBar.h | XTPToolBar.h : interface for the CXTPToolBar class.
XTPDialogBase.h | XTPFrameWnd.h : interface for the CXTPFrameWnd and CXTPMDIFrameWnd classes.
XTPDockBar.h | XTPDockBar.h : interface for the CXTPDockBar class.
XTPDockContext.h | XTPDockContext.h : interface for the CXTPDockContext class.
XTPDockState.h | XTPDockState.h : interface for the CXTPDockState class.
XTPFrameWnd.h | XTPFrameWnd.h : interface for the CXTPFrameWnd and CXTPMDIFrameWnd classes.
XTPImageEditor.h | XTPImageEditor.h : interface for the CXTPImageEditorDlg class.
XTPMenuBar.h | XTPMenuBar.h : interface for the CXTPMenuBar class.
XTPMouseManager.h | XTPMouseManager.h : interface for the CXTPMouseManager class.
XTPOffice2007Theme.h | XTPOffice2007Theme.h : interface for the CXTPOffice2007Theme class.
XTPPaintManager.h | XTPPaintManager.h : interface for the CXTPPaintManager class.
XTPPopupBar.h | XTPPopupBar.h : interface for the CXTPPopupBar class.
XTPReBar.h | XTPReBar.h : header file This file is a part of the XTREME COMMANDBARS MFC class library.
XTPRibbonBar.h | XTPRibbonBar.h: interface for the CXTPRibbonBar class.
XTPRibbonControlTab.h | XTPRibbonControlTab.h: interface for the CXTPRibbonControlTab class.
XTPRibbonCustomizeQuickAccessPage.h | XTPRibbonCustomizeQuickAccessPage.h: interface for the CXTPRibbonCustomizeQuickAccessPage class.
XTPRibbonGroup.h | XTPRibbonGroup.h: interface for the CXTPRibbonGroup class.
XTPRibbonGroups.h | XTPRibbonGroups.h: interface for the CXTPRibbonGroups class.
XTPRibbonQuickAccessControls.h | XTPRibbonQuickAccessControls.h: interface for the CXTPRibbonQuickAccessControls class.
XTPRibbonTab.h | XTPRibbonTab.h: interface for the CXTPRibbonTab class.
XTPRibbonTheme.h | XTPRibbonTheme.h: interface for the CXTPRibbonTheme class.
XTPShortcutManager.h | XTPShortcutManager.h : interface for the CXTPShortcutManager class.
XTPSoundManager.h | XTPSoundManager.h : interface for the CXTPSoundManager class.
XTPStatusBar.h | XTPStatusBar.h : interface for the CXTPStatusBar class.
XTPTabClientWnd.h | XTPTabClientWnd.h : interface for the CXTPTabClientWnd class.
XTPTabToolBar.h | XTPTabToolBar.h : interface for the CXTPTabToolBar class.
XTPToolBar.h | XTPToolBar.h : interface for the CXTPToolBar class.


Files

Files
Files
Files
File | Description
XTMaskEditT.h | XTMaskEditT.h interface for the CXTMaskEditT class.
XTPColorManager.h | XTPColorManager.h: interface for the CXTPColorManager class.
XTPDrawHelpers.h | XTPDrawHelpers.h: interface for the CXTPDrawHelpers class.
XTPImageManager.h | XTPImageManager.h : interface for the CXTPImageManager class.
XTPMacros.h | XTPMacros.h : common macros This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPPropExchange.h | XTPPropExchange.h: interface for the CXTPPropExchange class.
XTPResourceManager.h | XTPResourceManager.h: interface for the CXTPResourceManager class.
XTPSystemHelpers.h | XTPSystemHelpers This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPToolTipContext.h | XTPToolTipContext.h: interface for the CXTPToolTipContext class.
XTPWinThemeWrapper.h | XTPWinThemeWrapper.h: interface for the CXTPWinThemeWrapper class.


Files

Files
Files
Files
File | Description
XTPDockingPane.h | XTPDockingPane.h : interface for the CXTPDockingPane class.
XTPDockingPaneAutoHidePanel.h | XTPDockingPaneAutoHidePanel.h : interface for the CXTPDockingPaneAutoHidePanel class.
XTPDockingPaneBase.h | XTPDockingPaneBase.h : interface for the CXTPDockingPaneBase class.
XTPDockingPaneBaseContainer.h | XTPDockingPaneBaseContainer.h : interface for the CXTPDockingPaneBaseContainer class.
XTPDockingPaneContext.h | XTPDockingPaneContext.h : interface for the CXTPDockingPaneContext class.
XTPDockingPaneDefines.h | XTPDockingPaneDefines.h : public defines, structures and enumerations.
XTPDockingPaneLayout.h | XTPDockingPaneLayout.h : interface for the CXTPDockingPaneLayout class.
XTPDockingPaneManager.h | XTPDockingPaneManager.h : interface for the CXTPDockingPaneManager class.
XTPDockingPaneMiniWnd.h | XTPDockingPaneMiniWnd.h : interface for the CXTPDockingPaneMiniWnd class.
XTPDockingPanePaintManager.h | XTPDockingPanePaintManager.h : interface for the CXTPDockingPanePaintManager class.
XTPDockingPaneSplitterContainer.h | XTPDockingPaneSplitterContainer.h : interface for the CXTPDockingPaneSplitterContainer class.
XTPDockingPaneTabbedContainer.h | XTPDockingPaneTabbedContainer.h : interface for the CXTPDockingPaneTabbedContainer class.


Files

Files
Files
Files
File | Description
XTPPropertyGrid.h | XTPPropertyGrid.h interface for the CXTPPropertyGrid class.
XTPPropertyGridDefines.h | XTPPropertyGridDefines.h This file is a part of the XTREME PROPERTYGRID MFC class library.
XTPPropertyGridInplaceButton.h | XTPPropertyGridInplaceButton.h interface for the CXTPPropertyGridInplaceButton class.
XTPPropertyGridInplaceEdit.h | XTPPropertyGridInplaceEdit.h interface for the CXTPPropertyGridInplaceEdit class.
XTPPropertyGridInplaceList.h | XTPPropertyGridInplaceList.h interface for the CXTPPropertyGridInplaceList class.
XTPPropertyGridItem.h | XTPPropertyGridItem.h interface for the CXTPPropertyGridItem class.
XTPPropertyGridItemBool.h | XTPPropertyGridItemBool.h interface for the CXTPPropertyGridItemBool class.
XTPPropertyGridItemColor.h | XTPPropertyGridItemColor.h interface for the CXTPPropertyGridItemColor class.
XTPPropertyGridItemExt.h | XTPPropertyGridItemExt.h This file is a part of the XTREME PROPERTYGRID MFC class library.
XTPPropertyGridItemFont.h | XTPPropertyGridItemFont.h interface for the CXTPPropertyGridItemFont class.
XTPPropertyGridItemNumber.h | XTPPropertyGridItemNumber.h interface for the CXTPPropertyGridItemNumber class.
XTPPropertyGridItemSize.h | XTPPropertyGridItemSize.h interface for the CXTPPropertyGridItemSize class.
XTPPropertyGridPaintManager.h | XTPPropertyGridPaintManager.h interface for the CXTPPropertyGridPaintManager class.
XTPPropertyGridView.h | XTPPropertyGridView.h interface for the CXTPPropertyGridView class.


Files

Files
Files
Files
File | Description
XTPReportColumn.h | XTPReportColumn.h: interface for the CXTPReportColumn class.
XTPReportColumns.h | XTPReportColumns.h: interface for the CXTPReportColumns class.
XTPReportControl.h | XTPReportControl.h: interface for the CXTPReportControl class.
XTPReportDefines.h | XTPReportDefines.h This file is a part of the XTREME REPORTCONTROL MFC class library.
XTPReportDragDrop.h | XTPReportDragDrop.h: interface for the CXTPReportHeaderDragWnd and CXTPReportHeaderDropWnd classes.
XTPReportFilterEditControl.h | XTPReportFilterEditControl.h: interface for the CXTPReportFilterEditControl class.
XTPReportGroupRow.h | XTPReportGroupItem.h: interface for the CXTPReportGroupItem class.
XTPReportHeader.h | XTPReportHeader.h: interface for the CXTPReportHeader class.
XTPReportHyperlink.h | XTPReportHyperlink.h: interface for the CXTPReportHyperlink class.
XTPReportInplaceControls.h | XTPReportInplaceControls.h This file is a part of the XTREME REPORTCONTROL MFC class library.
XTPReportPaintManager.h | XTPReportPaintManager.h: interface for the CXTPReportPaintManager class.
XTPReportRecord.h | XTPReportRecord.h: interface for the CXTPReportRecord class.
XTPReportRecordItem.h | XTPReportRecordItem.h: interface for the CXTPReportRecordItem class.
XTPReportRecordItemText.h | XTPReportRecordItemText.h: interface for the CXTPReportRecordItemText class.
XTPReportRecords.h | XTPReportRecords.h: interface for the CXTPReportRecords class.
XTPReportRow.h | XTPReportRow.h: interface for the CXTPReportRow class.
XTPReportRows.h | XTPReportRows.h: interface for the CXTPReportRows class.
XTPReportSubListControl.h | XTPReportSubListControl.h: interface for the CXTPReportSubListControl class.
XTPReportTip.h | XTPReportTip.h: interface for the CXTPReportTip class.
XTPReportView.h | XTPReportView.h: interface for the CXTPReportView class.


Files

Files
Files
Files
File | Description
XTPShortcutBar.h | XTPShortcutBar.h interface for the CXTPShortcutBar class.
XTPShortcutBarPaintManager.h | XTPShortcutBarPaintManager.h interface for the CXTPShortcutBarPaintManager class.
XTPShortcutBarPane.h | XTPShortcutBarPane.h interface for the CXTPShortcutBarPane class.


Files

Files
Files
Files
File | Description
XTPSkinImage.h | XTPSkinImage.h: interface for the CXTPSkinImage class.
XTPSkinManager.h | XTPSkinManager.h: interface for the CXTPSkinManager class.
XTPSkinManagerApiHook.h | XTPSkinManagerApiHook.h: interface for the CXTPSkinManagerApiHook class.
XTPSkinManagerModuleList.h | XTPSkinManagerModuleList.h: interface for the CXTPSkinManagerModuleList class.
XTPSkinManagerResource.h | XTPSkinManagerResource.h: interface for the CXTPSkinManagerResourceFile class.
XTPSkinManagerSchema.h | XTPSkinManagerSchema.h: interface for the CXTPSkinManagerSchema class.
XTPSkinObject.h | XTPSkinObject.h: interface for the CXTPSkinObject class.
XTPSkinObjectButton.h | XTPSkinObjectButton.h: interface for the CXTPSkinObjectButton class.
XTPSkinObjectComboBox.h | XTPSkinObjectComboBox.h: interface for the CXTPSkinObjectComboBox class.
XTPSkinObjectEdit.h | XTPSkinObjectEdit.h: interface for the CXTPSkinObjectEdit class.
XTPSkinObjectFrame.h | XTPSkinObjectFrame.h: interface for the CXTPSkinObjectFrame class.
XTPSkinObjectHeader.h | XTPSkinObjectHeader.h: interface for the CXTPSkinObjectHeader class.
XTPSkinObjectListBox.h | XTPSkinObjectListBox.h: interface for the CXTPSkinObjectListBox class.
XTPSkinObjectListView.h | XTPSkinObjectListView.h: interface for the CXTPSkinObjectListView class.
XTPSkinObjectMDI.h | XTPSkinObjectMDI.h: interface for the CXTPSkinObjectMDI class.
XTPSkinObjectProgress.h | XTPSkinObjectProgress.h: interface for the CXTPSkinObjectProgress class.
XTPSkinObjectScrollBar.h | XTPSkinObjectScrollBar.h: interface for the CXTPSkinObjectScrollBar class.
XTPSkinObjectSpin.h | XTPSkinObjectSpin.h: interface for the CXTPSkinObjectSpin class.
XTPSkinObjectStatusBar.h | XTPSkinObjectStatusBar.h: interface for the CXTPSkinObjectStatusBar class.
XTPSkinObjectTab.h | XTPSkinObjectTab.h: interface for the CXTPSkinObjectTab class.
XTPSkinObjectToolBar.h | XTPSkinObjectToolBar.h: interface for the CXTPSkinObjectToolBar class.
XTPSkinObjectTrackBar.h | XTPSkinObjectTrackBar.h: interface for the CXTPSkinObjectTrackBar class.
XTPSkinObjectTreeView.h | XTPSkinObjectTreeView.h: interface for the CXTPSkinObjectTreeView class.


Files

Files
Files
Files
File | Description
XTAnimationMemDC.h | XTAnimationMemDC.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTBrowseDialog.h | XTBrowseDialog.h: interface for the CXTBrowseDialog class.
XTBrowseEdit.h | XTBrowseEdit.h : interface for the CXTBrowseEdit class.
XTButton.h | XTButton.h : interface for the CXTButton class.
XTButtonTheme.h | XTButtonTheme.h: interface for the CXTButtonTheme class.
XTCaption.h | XTCaption.h : interface for the CXTCaption class.
XTCaptionPopupWnd.h | XTCaptionPopupWnd.h : interface for the CXTCaptionPopupWnd class.
XTCaptionTheme.h | XTCaptionTheme.h: interface for the CXTCaptionTheme class.
XTCheckListBox.h | XTCheckListBox.h : interface for the CXTCheckListBox class.
XTColorDialog.h | XTColorDialog.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPageCustom.h | XTColorPageCustom.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPageStandard.h | XTColorPageStandard.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTColorPicker.h | XTColorPicker.h : interface for the CXTColorPicker class.
XTColorPopup.h | XTColorPopup.h : interface for the CXTColorPopup class.
XTColorRef.h | XTColorRef.h: interface for the CXTColorRef class.
XTColorSelectorCtrl.h | XTColorSelectorCtrl.h : interface for the CXTColorSelectorCtrl class.
XTComboBoxEx.h | XTComboBoxEx.h : interface for the CXTComboBoxEx class.
XTDateTimeCtrl.h | XTDateTimeCtrl.h interface for the CXTDateTimeCtrl class.
XTDefines.h | XTDefines.h interface for the CXTAuxData struct.
XTDirWatcher.h | XTDirWatcher.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTDropSource.h | XTDropSource.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTEditListBox.h | XTEditListBox.h interface for the CXTEditListBox class.
XTExcelTabCtrl.h | XTExcelTabCtrl.h interface for the CXTExcelTabCtrl class.
XTExcelTabCtrlTheme.h | XTExcelTabCtrlTheme.h: interface for the CXTExcelTabCtrlTheme class.
XTFlatComboBox.h | XTFlatComboBox.h interface for the CXTFlatComboBox class.
XTFlatControlsTheme.h | XTFlatControlsTheme.h: interface for the CXTFlatComboBoxTheme class.
XTFontCombo.h | XTFontCombo.h interface for the CXTFontCombo class.
XTFunctions.h | XTFunctions.h : global functions.
XTGlobal.h | XTGlobal.h interface for the CXTAuxData struct.
XTHeaderCtrl.h | XTHeaderCtrl.h interface for the CXTFlatHeaderCtrl class.
XTHeaderCtrlTheme.h | XTHeaderCtrlTheme.h: interface for the CXTHeaderCtrlTheme class.
XTHelpers.h | XTHelpers.h interface This file is a part of the XTREME CONTROLS MFC class library.
XTHexEdit.h | XTHexEdit.h interface for the CXTHexEdit class.
XTHtmlView.h | XTHtmlView.h interface for the CXTHtmlView class.
XTHyperLink.h | XTHyperLink.h interface for the CXTHyperLink class.
XTListBase.h | XTListBase.h interface for the CXTListCtrl class.
XTListBox.h | XTListBox.h interface for the CXTListBox class.
XTListCtrlView.h | XTListCtrlView.h interface for the CXTListView and CXTListCtrlView class.
XTMaskEdit.h | XTMaskEdit.h interface for the CXTMaskEdit class.
XTMDIWndTab.h | XTMDIWndTab.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTMemDC.h | XTMemDC.h interface for the CXTMemDC class.
XTMemFile.h | XTMemFile.h interface for the CXTMemFile class.
XTMenuListBox.h | XTMenuListBox.h interface for the CXTMenuListBox class.
XTMenuListBoxTheme.h | XTMenuListBoxTheme.h: interface for the CXTMenuListBoxTheme class.
XTNotify.h | XTNotify.h : notification handlers This file is a part of the XTREME CONTROLS MFC class library.
XTOutBarCtrl.h | XTOutBarCtrl.h interface for the CXTOutBarCtrl class.
XTOutBarCtrlTheme.h | XTOutBarCtrlTheme.h: interface for the CXTOutBarCtrlTheme class.
XTPagerCtrl.h | XTPagerCtrl.h interface for the CXTPagerCtrl class.
XTPPopupControl.h | XTPPopupControl.h: interface for the CXTPPopupControl class.
XTPPopupItem.h | XTPPopupItem.h: interface for the CXTPPopupItem class.
XTPPopupPaintManager.h | XTPPopupPaintManager.h: interface for the CXTPPopupPaintManager class.
XTPPropertyPage.h | XTPPropertyPage.h : interface for the CXTPPropertyPage class.
XTPPropertyPageNavigator.h | XTPPropertyPageNavigator.h : interface for the CXTPPropertyPageNavigator class.
XTPPropertySheet.h | XTPPropertySheet.h : interface for the CXTPPropertySheet class.
XTPTaskDialog.h | XTPTaskDialog.h: interface for the CXTPTaskDialog class.
XTRegistryManager.h | XTRegistryManager.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTResize.h | XTResize.h: interface for the CXTResize class.
XTResizeDialog.h | XTResizeDialog.h: interface for the CXTResizeDialog class.
XTResizeFormView.h | XTResizeFormView.h: interface for the CXTResizeFormView class.
XTResizeGroupBox.h | XTResizeGroupBox.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTResizePoint.h | XTResizePoint.h: interface for the CXTResizePoint class.
XTResizePropertyPage.h | XTResizePropertyPage.h: interface for the CXTResizePropertyPage class.
XTResizePropertySheet.h | XTResizePropertySheet.h: interface for the CXTResizePropertySheet class.
XTResizeRect.h | XTResizeRect.h: interface for the CXTResizeRect class.
XTSearchOptionsCtrl.h | XTSearchOptionsCtrl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellListBase.h | XTShellListBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellListCtrlView.h | XTShellListCtrlView.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellPidl.h | XTShellPidl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellSettings.h | XTShellSettings.h: interface for the CXTShellSettings class.
XTShellTreeBase.h | XTShellTreeBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTShellTreeCtrlView.h | XTShellTreeCtrl.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTSortClass.h | XTSortClass.h interface for the CXTSortClass class.
XTSplitterWnd.h | XTSplitterWnd.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTSplitterWndTheme.h | XTSplitterWndTheme.h: interface for the CXTSplitterWndTheme class.
XTTabBase.h | XTTabBase.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTTabBaseTheme.h | XTTabBaseTheme.h: interface for the CXTTabBaseTheme class.
XTTabCtrl.h | XTTabCtrl.h interface for the CXTTabCtrl class.
XTTabCtrlButtons.h | XTTabCtrlbuttons.h : interface for the CXTTabCtrlbuttons class.
XTTabView.h | XTTabView.h interface for the CXTTabView class.
XTThemeManager.h | XTThemeManager.h: interface for the CXTThemeManager class.
XTTipOfTheDay.h | XTTipOfTheDay.h interface for the CXTTipOfTheDay class.
XTTipWindow.h | XTTipWindow.h interface for the CXTTipWindow class.
XTTrayIcon.h | XTTrayIcon.h: interface for the CXTTrayIcon class.
XTTreeBase.h | XTTreeBase.h interface for the CXTTreeBase class.
XTTreeCtrlView.h | XTTreeView.h interface for the CXTTreeView class.
XTUtil.h | XTUtil.h: interface for utility classes.
XTVC50Helpers.h | XTVC50Helpers.h : Visual C++ 5.0 helpers This file is a part of the XTREME CONTROLS MFC class library.
XTWindowList.h | XTWindowList.h : header file This file is a part of the XTREME CONTROLS MFC class library.
XTWindowPos.h | XTWindowPos.h interface for the CXTWindowPos class.


Files

Files
Files
Files
File | Description
XTPSyntaxEditAutoCompleteWnd.h | XTPSyntaxEditAutoCompleteWnd.h: interface for the CXTPSyntaxEditAutoCompleteWnd class.
XTPSyntaxEditBufferManager.h | XTPSyntaxEditBufferManager.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditColorComboBox.h | XTPSyntaxEditColorComboBox.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditColorSampleText.h | XTPSyntaxEditColorSampleText.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditCtrl.h | XTPSyntaxEditCtrl.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditDefines.h | XTPSyntaxEditDefines.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditDoc.h | XTPSyntaxEditDoc.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditFindReplaceDlg.h | XTPSyntaxEditFindReplaceDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditGoToLineDlg.h | XTPSyntaxEditGoToLineDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexCfgFileReader.h | XTPSyntaxEditLexCfgFileReader.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClass.h | XTPSyntaxEditLexClass.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClassSubObjDef.h | XTPSyntaxEditLexClassSubObjDef.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexClassSubObjT.h | XTPSyntaxEditLexClassSubObjT.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexColorFileReader.h | XTPSyntaxEditLexColorFileReader.h: interface for the CXTLexColorFileReader class.
XTPSyntaxEditLexParser.h | XTPSyntaxEditLexParser.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLexPtrs.h | XTPSyntaxEditLexPtrs.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditLineMarksManager.h | XTPSyntaxEditLineMarksManager.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditPaintManager.h | XTPSyntaxEditPaintManager.h interface for the CXTPSyntaxEditPaintManager class.
XTPSyntaxEditPropertiesDlg.h | XTPSyntaxEditPropertiesDlg.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditPropertiesPage.h | XTPSyntaxEditPropertiesPage.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditSectionManager.h | XTPSyntaxEditSectionManager.h: interface for the CXTPSyntaxEditSectionManager class.
XTPSyntaxEditStruct.h | XTPSyntaxEditStruct.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditTextIterator.h | XTPSyntaxEditTextIterator.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditToolTipCtrl.h | XTPSyntaxEditToolTipCtrl.h: interface for the CXTPSyntaxEditToolTipCtrl class.
XTPSyntaxEditUndoManager.h | XTPSyntaxEditUndoManager.h This file is a part of the XTREME TOOLKIT PRO MFC class library.
XTPSyntaxEditView.h | XTPSyntaxEditView.h : header file This file is a part of the XTREME TOOLKIT PRO MFC class library.


Files

Files
Files
Files
File | Description
XTPTabControl.h | XTPTabControl.h: interface for the CXTPTabControl class.
XTPTabManager.h | XTPTabManager.h: interface for the CXTPTabManager class.
XTPTabPaintManager.h | XTPTabPaintManager.h: interface for the CXTPTabPaintManager class.


Files

Files
Files
Files
File | Description
XTPTaskPanel.h | XTPTaskPanel.h interface for the CXTPTaskPanel class.
XTPTaskPanelDefines.h | XTPTaskPanelDefines.h This file is a part of the XTREME TASKPANEL MFC class library.
XTPTaskPanelGroup.h | XTPTaskPanelGroup.h interface for the CXTPTaskPanelGroup class.
XTPTaskPanelGroupItem.h | XTPTaskPanelGroupItem.h interface for the CXTPTaskPanelGroupItem class.
XTPTaskPanelItem.h | XTPTaskPanelItem.h interface for the CXTPTaskPanelItem class.
XTPTaskPanelItems.h | XTPTaskPanelItems.h interface for the CXTPTaskPanelItems class.
XTPTaskPanelPaintManager.h | XTPTaskPanelPaintManager.h interface for the CXTPTaskPanelPaintManager class.


Functions

Functions
Functions | Legend
Functions
Function | Description
PX_Color | Call this function within your class's DoPropExchange member function to serialize or initialize a COLORREF property. The property's value is read from or written to the variable referenced by refColor, as appropriate.
PX_Color | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Color property. The property's value is read from or written to the variable referenced by refColor, as appropriate.
PX_Font | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Font property. The property's value is read from or written to the variable referenced by refFont, as appropriate.
PX_Font | Call this function within your class's DoPropExchange member function to serialize or initialize a LOGFONT property. The property's value is read from or written to the variable referenced by rLogFont, as appropriate.
PX_GrColor | Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property. The property's value is read from or written to the variable referenced by refGrColor, as appropriate.
xtpCalendarDateTime_max | Defines an upper bound of the time frame for the Calendar control.
xtpCalendarDateTime_min | Defines a lower bound of the time frame for the Calendar control.
XTPGetTopLevelWndMsgNotifier | This global function is used to get library static common top-level window object to catch windows messages, which system sends to top-level windows (like WM_TIMECHANGE, WM_SYSCOLORCHANGE).


Functions

Legend
Legend
Method


Legend

Legend
Functions
Legend
Method


Functions

Functions
Functions | Legend
Functions
Function | Description
XTPPaintManager | Call this function to access CXTPPaintManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPPaintManager.
XTPSoundManager | Call this function to access CXTPSoundManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSoundManager.


Functions

Functions
Functions | Legend
Functions
Function | Description
GetMSO2003Color | Call this function to get the MS Office color represented by nIndex.
GetXtremeColor | Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetColor for more details.
PX_Blob | Call this function within your class's DoPropExchange member function to serialize BYTE array.
PX_Bool | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Bool | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL. The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Bstr | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Byte | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BYTE. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DateTime | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleDateTime. The property's value is read from or written to the variable referenced by dtValue, as appropriate.
PX_Double | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Double | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double. The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DWord | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_DWord | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD. The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Float | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Float | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float. The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Int | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Int | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int. The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Long | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Long | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long. The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Point | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT. The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Rect | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT. The property's value is read from or written to the variable referenced by rcValue, as appropriate. If rcDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_RuntimeClass | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type CRuntimeClass. The property's value is read from or written to the variable referenced by pClass, as appropriate. If pDefaultClass is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Serialize | Call this function within your class's DoPropExchange member function to serialize object.
PX_Short | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Short | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short. The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Size | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE. The property's value is read from or written to the variable referenced by szValue, as appropriate. If szDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_String | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_String | Call this function within your class's DoPropExchange member function to serialize or initialize a character string property. The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UI8 | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONGLONG. The property's value is read from or written to the variable referenced by ullValue, as appropriate. If ullDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_ULong | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_ULong | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG. The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UShort | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_UShort | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT. The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
PX_Variant | Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleVariant. The property's value is read from or written to the variable referenced by variant, as appropriate. If variantDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.
RefreshXtremeColors | This global function will refresh the display element colors defined in the CXTPColorManager class.
XTPColorManager | Call this function to access CXTPColorManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPColorManager.
XTPDrawHelpers | Call this function to access CXTPDrawHelpers members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPDrawHelpers.
XTPGetPrinterDeviceDefaults | Prepare a printer device context for printing and calculates DEVMODE and DEVNAMES values.
XTPMultiMonitor | Call this function to access CXTPMultiMonitor members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPMultiMonitor.
XTPResourceManager | Call this function to access CXTPResourceManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPResourceManager.
XTPSystemVersion | The XTPSystemVersion function is used for access to the CXTPSystemVersion class.


Functions

Functions
Functions | Legend
Functions
Function | Description
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_ |


Functions

Functions
Functions | Legend
Functions
Function | Description
XTPSkinManager | Call this function to access CXTPSkinManager members. Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSkinManager.


Functions

Functions
Functions | Legend
Functions
Function | Description
DDV_XTMinMaxDateTime | Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxDateTime | Call DDV_XTMinMaxDateTime to verify that the time/date value in the date and time picker control (CXTDateTimeCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxMonth | Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDV_XTMinMaxMonth | Call DDV_XTMinMaxMonth to verify that the time/date value in the month calendar control (CXTMonthCalCtrl) associated with 'refValue' falls between 'pMinRange' and 'pMaxRange'.
DDX_XTColorPicker | The DDX_XTColorPicker function manages the transfer of integer data between a color picker control in a dialog box, form view, or control view object and a COLORREF data member of the dialog box, form view, or control view object. When DDX_XTColorPicker is called, 'value' is set to the current state of the color picker control.
DDX_XTDateTimeCtrl | The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object and a COleDateTime data member of the dialog box or form view object. When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.
DDX_XTDateTimeCtrl | The DDX_XTDateTimeCtrl function manages the transfer of date and/or time data between a date and time picker control (CXTDateTimeCtrl) in a dialog box or form view object, and a CTime data member of the dialog box or form view object. When DDX_XTDateTimeCtrl is called, 'value' is set to the current state of the date and time picker control, or the control is set to 'value', depending on the direction of the exchange.
DDX_XTMonthCalCtrl | The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl) in a dialog box, form view, or control view object, and a COleDateTime data member, of the dialog box, form view, or control view object. The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel. When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.
DDX_XTMonthCalCtrl | The DDX_XTMonthCalCtrl function manages the transfer of date data between a month calendar control (CXTMonthCalCtrl), in a dialog box, form view, or control view object, and a CTime data member of the dialog box, form view, or control view object. The control manages a date value only. The time fields in the time object are set to reflect the creation time of the control window, or whatever time was set in the control with a call to CXTMonthCalCtrl::SetCurSel. When DDX_XTMonthCalCtrl is called, 'value' is set to the current state of the month calendar control.
DDX_XTOleDateTime | The DDX_XTOleDateTime function manages the transfer of integer data between a date edit control, in a dialog box, form view, or control view object, and a COleDateTime data member of the dialog box, form view, or control view object. When DDX_XTOleDateTime is called, 'value' is set to the current state of the date edit control.
XTAuxData | The XTAuxData function is used for access to the CXTAuxData class.
XTFuncChangeWindowFont | The XTFuncChangeWindowFont function will set the font for the window specified by pWnd and all of the child windows owned by pWnd.
XTFuncChildWindowFromPoint | The XTFuncChildWindowFromPoint function will retrieve an HWND handle for the child window (if any) located directly under the cursor position specified by point.
XTFuncContextMenu | Call this member function to display a context menu that is compatible with both pro and standard versions.
XTFuncCreateView | Creates a view based on a CRuntimeClass object.
XTFuncDrawEmbossed | The XTFuncDrawEmbossed function will draw an embossed icon onto the specified device context from the image list imageList. It is typically used by toolbars and menus to draw a disabled icon in color.
XTFuncDrawShadedRect | Renders a shadow onto the specified device context.
XTFuncInitDLL | This member function will initialize the resources for the Xtreme Toolkit. If using the Xtreme Toolkit as an extension DLL within a regular DLL, add the following two lines to your stdafx.h file. This will give you access to the exported function InitXtremeExtDll():
XTFuncPathExists | The XTFuncPathExists function searches a directory for a file or subdirectory whose name matches the specified name.
XTThemeManager | The XTThemeManager function is used for access to the CXTThemeManager class.


Functions

Functions
Functions | Legend
Functions
Function | Description
DDX_CBSyntaxColor | Use this function to exchange currently selected color for CXTPSyntaxEditColorComboBox control.


Macros

Macros
Macros
Macros
Macro | Description
BEGIN_VIEW_PART | This helper macro is used to declare paint manager drawing parts. theClass - Part name. parentClass - Parent part name. There are two paint manager methods available to access declared part object: CPartName* GetPartName(); void SetPartName(CPartName* pPart); Where PartName is the name of the declared part.
END_VIEW_PART | This helper macro is used to declare paint manager drawing parts. theClass - Part name.
XTP_CALENDAR_DEFAULT_LABEL_ID | Define event label ID which is used by default for a new event. (Valid for default labels list only)
XTP_CALENDAR_DEFAULT_REMINDER_MINUTES | Define default reminders value minutes which is for a new event.
XTP_CALENDAR_DISABLED_COLOR_DARK | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_CALENDAR_DISABLED_COLOR_LIGHT | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX | Define maximum text length for calendar event subject, location or body which will be drawn on the screen. Used to optimize drawing performance.
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX | Define maximum count of weeks which can be shown in the Month View.
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN | Define minimum count of weeks which can be shown in the Month View.
XTP_CALENDAR_NONE_LABEL_ID | Define event label ID which signifies no label. (Valid for default labels list only)
XTP_CALENDAR_OFFICE2007_FONT_NAME | The font name for Office 2007 theme
XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS | Timeout before appearing event tool tip window.
XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS | Timeout before appearing event tool tip window.
XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS |
XTP_CALENDAR_TIMEZONESKEY_9X | The location in the registry that contains time zone information for Windows 9x family.
XTP_CALENDAR_TIMEZONESKEY_NT | The location in the registry that contains time zone information for Windows NT family (NT/2000/XP).
XTP_CALENDAR_TZIRegValName_DATA | Registry key name for some TIME_ZONE_INFORMATION structure members.
XTP_CALENDAR_TZIRegValName_DaylightName | Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_DaylightNameW | Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_DisplayStr | Registry key name for a time zone display string value. For example: "(GMT+02:00) Athens, Beirut, Istanbul, Minsk"
XTP_CALENDAR_TZIRegValName_Index | Registry key name for a time zone order index value.
XTP_CALENDAR_TZIRegValName_StandardName | Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_TZIRegValName_StandardNameW | Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
XTP_CALENDAR_UNKNOWN_EVENT_ID | Define unknown event ID.
XTP_CALENDAR_UNKNOWN_LABEL_ID | Define unknown event label ID.
XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID | Define an unknown recurrence pattern ID.
XTP_CALENDAR_UNKNOWN_SCHEDULE_ID | Define unknown schedule ID.
XTP_EVENTS_STORAGE_HASH_TABLE_SIZE | Define events storage hash table size. Should be a prime number! like: 503, 1021, 1511, 2003, 3001, 4001, 5003, 6007, 8009, 12007, 16001, 32003, 48017, 64007
XTP_HALF_SECOND |
XTP_OBJECT_CACHE_HASH_TABLE_SIZE | Cache table size.


Macros

Macros
Macros
Macros
Macro | Description
DECLARE_XTP_COMMANDBAR | This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be serialized.
DECLARE_XTP_CONTROL | This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serialized.
IMPLEMENT_XTP_COMMANDBAR | This macro generates the C++ code necessary for a CXTPCommandBar-derived class that can be serialized.
IMPLEMENT_XTP_CONTROL | This macro generates the C++ code necessary for a CXTPControl-derived class that can be serialized.
ON_XTP_AFTERCREATECONTROL | The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after new CXTPControl object is created.
ON_XTP_CREATECOMMANDBAR | The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when new CXTPCommandBars object is created.
ON_XTP_CREATECONTROL | The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when new CXTPControl object is created.
ON_XTP_EXECUTE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
ON_XTP_EXECUTE_RANGE | The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when user click item of CXTPCommandBar object
ON_XTP_INITCOMMANDSPOPUP | The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active
ON_XTP_UNINITCOMMANDSPOPUP | The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.
XTP_IDS_AUTOMATIC | Obsolete define
xtpComboLabel | Deprecated style for Combo control
xtpComboNormal | Deprecated style for Combo control


Macros

Macros
Macros
Macros
Macro | Description
SAFE_CALLPTR | Checks object pointer and if not NULL calls a specified function.
SAFE_DELETE | Frees dynamically allocated memory.
SAFE_DELETE_AR | Frees dynamically allocated memory for an array.
SAFE_DELETE_HICON | Destroys an icon and frees any memory the icon occupied.
SAFE_DELETE_OBJ | Destroys a GDI object and frees the handle.
SAFE_RELEASE | Decrements the reference count for the specified object.
XT_ASSERT_MSG | XT_ASSERT_MSG is similar to ASSERT, except that it allows a custom message to be specified.
XTOSVersionInfo | Depricated


Macros

Macros
Macros
Macros
Macro | Description
XTPWM_DOCKINGPANE_NOTIFY | The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.


Macros

Macros
Macros
Macros
Macro | Description
XTP_NM_REPORT_BEFORE_COPY_TOTEXT | Defines message for handling CXTPReportControl::OnBeforeCopyToText().
XTP_NM_REPORT_BEFORE_PASTE | Defines message for handling CXTPReportControl::OnBeforePaste().
XTP_NM_REPORT_BEFORE_PASTE_FROMTEXT | Defines message for handling CXTPReportControl::OnBeforePasteFromText().
XTP_NM_REPORT_BEGINDRAG | Indicates the user start dragging records.
XTP_NM_REPORT_BEGINEDIT | Defines message for in-place editing has just started. Send after XTP_NM_REPORT_REQUESTEDIT and when inplace editor has been created.
XTP_NM_REPORT_CHECKED | Defines message for handling row checking event.
XTP_NM_REPORT_COLUMNORDERCHANGED | Defines message for column changed event.
XTP_NM_REPORT_COLUMNWIDTHCHANGED | Defines message for handling CXTPReportHeader::AdjustColumnsWidth().
XTP_NM_REPORT_CONSTRAINT_SELECTING | Indicates the user changed a selected item in the combobox.
XTP_NM_REPORT_DRAGDROP_COMPLETED | Indicates the user completed drag&drop operation.
XTP_NM_REPORT_DRAGOVER | Indicates the user is dragging records over a control.
XTP_NM_REPORT_DROP | Indicates the user dropped records to report control.
XTP_NM_REPORT_EDIT_CANCELED | Defines message for in-place editing is canceled and value is not changed event.
XTP_NM_REPORT_FOCUS_CHANGING | Defines message for handling focus changing event.
XTP_NM_REPORT_GETITEMMETRICS | Defines message for handling CXTPReportControl::GetItemMetrics().
XTP_NM_REPORT_GETTOOLTIPINFO | Indicates the tooltip will be drawn.
XTP_NM_REPORT_GROUPORDERCHANGED | Defines message for column group order changed event.
XTP_NM_REPORT_HEADER_RCLICK | Defines message for header context menu
XTP_NM_REPORT_HYPERLINK | Defines message for handling hyperlink click event.
XTP_NM_REPORT_INPLACEBUTTONDOWN | Defines message for in-place button click event.
XTP_NM_REPORT_ITEMBUTTONCLICK | Defines message for item button click event.
XTP_NM_REPORT_LBUTTONDOWN | Defines message for left mouse button click.
XTP_NM_REPORT_PRESORTORDERCHANGED | Defines message when a column header has been clicked and the sort order has changed, but CXTPReportControl::Populate has NOT yet been called.
XTP_NM_REPORT_PREVIEWKEYDOWN | Defines message for handling CXTPReportControl::OnPreviewKeyDown().
XTP_NM_REPORT_RECORDS_DROPPED | Indicates the records were dropped to report control.
XTP_NM_REPORT_REQUESTEDIT | Defines message for handling CXTPReportControl::OnRequestEdit().
XTP_NM_REPORT_ROWEXPANDED | Defines message for row expand event.
XTP_NM_REPORT_SELCHANGED | Defines message for handling rows selection changed event.
XTP_NM_REPORT_SELCHANGING | Defines message for selected rows collection changing. Send for each row when it added/removed.
XTP_NM_REPORT_SORTORDERCHANGED | Defines message for sort changed event.
XTP_NM_REPORT_VALUECHANGED | Defines message for value changed event.


Macros

Macros
Macros
Macros
Macro | Description
BTNS_WHOLEDROPDOWN | draw dropdown arrow, but without split arrow section
CXTHeaderCtrlHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CHeaderCtrl.
CXTListCtrlHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CListCtrl.
CXTStringHelper | Helper macro used for compatibility with Visual C++ 5.0, Visual C++ 6.0 and later should use CString.
DECLARE_THEME_FACTORY | Use this macro to declare the factory class for specified theme
DECLATE_SHELLTREE_BASE | The DELCLATE_SHELLTREE_BASE class is a template class used by the CXTShellTreeView and CXTShellTreeCtrl class to declare a multiple inheritance base class so that both classes could share a common code base.
IMPLEMENT_THEME_FACTORY | Use this macro to implement factory class for specified theme.
ON_BEN_XT_LABELEDITCANCEL | BEN_XT_LABELEDITCANCEL notification message handler.
ON_BEN_XT_LABELEDITEND | BEN_XT_LABELEDITEND notification message handler.
ON_CPN_XT_CLOSEUP | CPN_XT_CLOSEUP notification message handler.
ON_CPN_XT_DROPDOWN | CPN_XT_DROPDOWN notification message handler.
ON_CPN_XT_SELCHANGE | CPN_XT_SELCHANGE notification message handler.
ON_CPN_XT_SELENDCANCEL | CPN_XT_SELENDCANCEL notification message handler.
ON_CPN_XT_SELENDOK | CPN_XT_SELENDOK notification message handler.
ON_CPN_XT_SELNOFILL | CPN_XT_SELNOFILL notification message handler.
ON_LBN_XT_DELETEITEM | LBN_XT_DELETEITEM notification message handler.
ON_LBN_XT_LABELEDITCANCEL | LBN_XT_LABELEDITCANCEL notification message handler.
ON_LBN_XT_LABELEDITEND | LBN_XT_LABELEDITEND notification message handler.
ON_LBN_XT_MOVEITEMDOWN | LBN_XT_MOVEITEMDOWN notification message handler.
ON_LBN_XT_MOVEITEMUP | LBN_XT_MOVEITEMUP notification message handler.
ON_LBN_XT_NEWITEM | LBN_XT_NEWITEM notification message handler.
ON_LBN_XT_ONBROWSE |
ON_LBN_XT_PREDELETEITEM | LBN_XT_PREDELETEITEM notification message handler.
ON_LBN_XT_PRENEWITEM | LBN_XT_PRENEWITEM notification message handler.
ON_SON_XT_ITEMCONTRACT | SON_XT_ITEMCONTRACT notification message handler.
ON_SON_XT_ITEMCONTRACTING | SON_XT_ITEMCONTRACTING notification message handler.
ON_SON_XT_ITEMEXPAND | SON_XT_ITEMEXPAND notification message handler.
ON_SON_XT_ITEMEXPANDING | SON_XT_ITEMEXPANDING notification message handler.
SZ_BOTTOM_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_BOTTOM_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_BOTTOM_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_HORREPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_HORRESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_MIDDLE_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_MIDDLE_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_REPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_RESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_TOP_CENTER | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_LEFT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_TOP_RIGHT | CXTResizePoint constants used by the CXTResize class for defining the anchor position for a child in a resizable window.
SZ_VERREPOS | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
SZ_VERRESIZE | CXTResizeRect constants used by the CXTResize class for defining the resize attributes for a child in a resizable window.
XTP_ID_POPUP_CLOSE | Cpecial Id for close item


Macros

Macros
Macros
Macros
Macro | Description
XTP_EDIT_AVELINELEN | Average length of line.
XTP_EDIT_DISABLED_COLOR_DARK | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_EDIT_DISABLED_COLOR_LIGHT | Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
XTP_EDIT_EDITACTION_DELETEROW | Delete row
XTP_EDIT_EDITACTION_DELETEROW_FULL |
XTP_EDIT_EDITACTION_DELETETEXT | Generic delete text action
XTP_EDIT_EDITACTION_INSERTROW | Insert row
XTP_EDIT_EDITACTION_INSERTTEXT | Generic insert text action
XTP_EDIT_EDITACTION_MODIFYROW | Modify row #define XTP_EDIT_EDITACTION_SELECTIONCHANGED 0x08 // Selection changed
XTP_EDIT_FINDWORD_NEXT | Find start of the next word
XTP_EDIT_FINDWORD_PREV | Find start of the previous word
XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION | Used with XTP_EDIT_FONTOPTIONS struct and define unspecified member value.
XTP_EDIT_NM_DRAWBOOKMARK | This will be called while drawing the bookmarks
XTP_EDIT_NM_EDITCHANGED | This will be called if content has been changed
XTP_EDIT_NM_EDITCHANGING | Edit changing will be called before changing content
XTP_EDIT_NM_ENABLESCROLLBAR | Edit control scroll bar(s) state changed.
XTP_EDIT_NM_FIRST | First notification ID for SyntaxEdit
XTP_EDIT_NM_INSERTKEY | Update all of the vertical panes
XTP_EDIT_NM_LAST | Last notification ID for SyntaxEdit
XTP_EDIT_NM_LBUTTONDBLCLICK | Notify mouse Left button double click.
XTP_EDIT_NM_LBUTTONDOWN | Notify mouse Left button down.
XTP_EDIT_NM_LBUTTONUP | Notify mouse Left button up.
XTP_EDIT_NM_MARGINCLICKED | Left mouse button was clicked in the gutter area
XTP_EDIT_NM_MOUSEMOVE | Notify mouse movement.
XTP_EDIT_NM_PARSEEVENT | This notification used to reflect parser events.
XTP_EDIT_NM_RBUTTONDOWN | Notify mouse Right button down.
XTP_EDIT_NM_RBUTTONUP | Notify mouse Right button up.
XTP_EDIT_NM_ROWCOLCHANGED | This will be fired if row or col has been changed
XTP_EDIT_NM_SELINIT | Updates all the selections while one pane initiates one
XTP_EDIT_NM_SETDOCMODIFIED | Indicates if the document is modified
XTP_EDIT_NM_STARTOLEDRAG | Start OLE drag
XTP_EDIT_NM_UPDATESCROLLPOS | Edit control scroll positions changed.
XTP_EDIT_RGB_GETBLUE | Get blue color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_GETGREEN | Get green color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_GETRED | Get red color value for raw RGB color like "0xAABBCC".
XTP_EDIT_RGB_INT2CLR | Convert raw RGB color value like "0xAABBCC" to COLORREF.
XTP_EDIT_SYNTAXEDIT_DECLARE_SMART_PTR |
XTP_EDIT_XLC | max line: 1 048 575 max col: 4 095


CXTCheckListBox Classes Classes

CXTCheckListBox Classes Classes
CXTCheckListBox Classes
Classes
Class | Description
CCheckListState | CCheckListState is a helper class used by CXTCheckListBox that contains information about the checkbox image that is used by the check list box.


CXTPCalendarControl Classes Classes

CXTPCalendarControl Classes Classes
CXTPCalendarControl Classes
Classes
Class | Description
CUpdateContext | Class CUpdateContext updates context and redraws control parts depending on input parameters.
CViewChanged_ContextData | Class CViewChanged_ContextData is used as locker context for CViewChangedContext.
CViewChangedContext | Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action.


CXTPCalendarData Classes Classes

CXTPCalendarData Classes Classes
CXTPCalendarData Classes
Classes
Class | Description
CXTPDPCache |


CXTPCalendarMAPIDataProvider Classes Classes

CXTPCalendarMAPIDataProvider Classes Classes
CXTPCalendarMAPIDataProvider Classes
Classes
Class | Description
CXTPCalendarMemDPInternal | Internal extension of the CXTPCalendarMemoryDataProvider used for handling all notifications.


CXTPCalendarMonthView Classes Classes

CXTPCalendarMonthView Classes Classes
CXTPCalendarMonthView Classes
Classes
Class | Description
CMonthViewGrid |


CXTPCalendarPaintManager Classes Classes

CXTPCalendarPaintManager Classes Classes
CXTPCalendarPaintManager Classes
Classes
Class | Description
CControlPart | Paint manager's ControlPart is used as parent for the other parts of the control.
CDayMonthViewHeaderPart | This paint manager part is used to draw days headers for the Day View.
CDayViewAllDayEventsPart | This paint manager part is used to draw all day events area for the Day View.
CDayViewCellPart | This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
CDayViewEventPart | This paint manager part is used to draw events for the Day View.
CDayViewGroupHeaderPart | This paint manager part is used to draw Groups headers for the Day View.
CDayViewHeaderPart | This paint manager part is used to draw days headers for the Day View.
CDayViewNonworkCellPart | This paint manager part is used to draw "no all day non-work" time cells for the Day View.
CDayViewTimeScaleCellPart | This paint manager part is used to draw time scale time cells for the Day View.
CDayViewTimeScaleHeaderPart | This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
CDayViewWorkCellPart | This paint manager part is used to draw a day view that contains no all day work time cells.
CMonthViewEventPart | This paint manager part is used to draw events and day dates for the Month View.
CMonthViewGridPart | This paint manager part is used to draw days grid and to fill days cells background for the Month View.
CMonthViewHeaderPart | This paint manager part is used to draw week days headers for the Month View.
CWeekViewEventPart | This paint manager part is used to draw events for the Week View.
CWeekViewPart | This paint manager part is used to draw week days grid and headers for the Week View.
CXTPShadowDrawer | This is a helper class which handles shadows drawing (for events, etc)


CXTPCalendarView Classes Classes

CXTPCalendarView Classes Classes
CXTPCalendarView Classes
Classes
Class | Description
CSelectionChanged_ContextData | This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary.
CSelectionChangedContext | Class CSelectionChangedContext used to avoid multiple sending of XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation.
CUndoBuffer | This helper class implements Undo/Redo events editing functionality.


CXTPControlToolbars Classes Classes

CXTPControlToolbars Classes Classes
CXTPControlToolbars Classes
Classes
Class | Description
CXTPControlToolbar | Represents single toolbar item.


CXTPMouseManager Classes Classes

CXTPMouseManager Classes Classes
CXTPMouseManager Classes
Classes
Class | Description
CTrackArray | Array of the tracking bars.


CXTPReportControl Classes Classes

CXTPReportControl Classes Classes
CXTPReportControl Classes
Classes
Class | Description
CUpdateContext | Internal report update helper.


CXTPResourceManager Classes Classes

CXTPResourceManager Classes Classes
CXTPResourceManager Classes
Classes
Class | Description
CManageState | CManageState is used internally by the toolkit to switch module states. Specifically, the class enables the toolkit to read its own .dll resources, and not that of the host application (or .dll). Future versions of the class may handle other such details


CXTPSkinObjectFrame Classes Classes

CXTPSkinObjectFrame Classes Classes
CXTPSkinObjectFrame Classes
Classes
Class | Description
CCaptionButton | Caption button class


CXTPSyntaxEditBufferCommand Classes Classes

CXTPSyntaxEditBufferCommand Classes Classes
CXTPSyntaxEditBufferCommand Classes
Classes
Class | Description
CXTPSyntaxEditBufferKeepOverwriteSettings | Keeps buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime.


CXTPSyntaxEditBufferManager Classes Classes

CXTPSyntaxEditBufferManager Classes Classes
CXTPSyntaxEditBufferManager Classes
Classes
Class | Description
CXTPSyntaxEditStringsManager | This is helper class designed to manage a set of strings


CXTPSyntaxEditStringsManager Classes Classes

CXTPSyntaxEditStringsManager Classes Classes
CXTPSyntaxEditStringsManager Classes
Classes
Class | Description
CStringPtrArray | Internal class, implement collection of strings.


CXTPSyntaxEditCtrl Classes Classes

CXTPSyntaxEditCtrl Classes Classes
CXTPSyntaxEditCtrl Classes
Classes
Class | Description
CAverageVal | CXTPSyntaxEditCtrl::CAverageVal
CScreenSearchBlock | CXTPSyntaxEditCtrl::CScreenSearchBlock
CScreenSearchCache | CXTPSyntaxEditCtrl::CScreenSearchCache
CTextSearchCache | CXTPSyntaxEditCtrl::CTextSearchCache


CXTPTabClientWnd Classes Classes

CXTPTabClientWnd Classes Classes
CXTPTabClientWnd Classes
Classes
Class | Description
CSingleWorkspace | CSingleWorkspace is a CWorkspace derived class. internal used.
CWorkspace | CWorkspace is a CXTPTabManager derived class. internal used.


CXTPTabManager Classes Classes

CXTPTabManager Classes Classes
CXTPTabManager Classes
Classes
Class | Description
CRowIndexer | Helper class used to collect indexes of rows for multirow tab manager


CXTPTabPaintManager Classes Classes

CXTPTabPaintManager Classes Classes
CXTPTabPaintManager Classes
Classes
Class | Description
CAppearanceSet | CAppearanceSet is a class that represents the appearance of all the components (tab button, tab caption font, button size, tab margins, etc) of the tab manager.
CAppearanceSetExcel | CAppearanceSetExcel is a CAppearanceSetFlat derived class that represents the Excel tab appearance.
CAppearanceSetFlat | CAppearanceSetFlat is a CAppearanceSet derived class that represents the "Flat" tab appearance.
CAppearanceSetPropertyPage | CAppearanceSetPropertyPage is a CAppearanceSet derived class that represents the Office 2000 tab appearance.
CAppearanceSetPropertyPage2003 | CAppearanceSetPropertyPage2003 is a CAppearanceSet derived class that represents the Office 2003 tab appearance.
CAppearanceSetPropertyPage2007 | CAppearanceSetPropertyPage2007 is a CAppearanceSet derived class that represents the Office 2007 tab appearance.
CAppearanceSetPropertyPageAccess2007 | CAppearanceSetPropertyPageAccess2007 is a CAppearanceSet derived class that represents the Office 2007 tab appearance.
CAppearanceSetPropertyPageFlat | CAppearanceSetPropertyPageFlat is a CAppearanceSetFlat derived class that represents the Office 2000 Flat tab appearance.
CAppearanceSetPropertyPageSelected | CAppearanceSetPropertyPageSelected is a CAppearanceSetPropertyPage derived class that represents the "Office 2000 Selected" tab appearance.
CAppearanceSetStateButtons | CAppearanceSetStateButtons is a CAppearanceSet derived class that represents the "State Button" tab appearance.
CAppearanceSetVisio | CAppearanceSetVisio is a CAppearanceSet derived class that represents the Visio tab appearance.
CAppearanceSetVisualStudio | CAppearanceSetVisualStudio is a CAppearanceSet derived class that represents the Visual Studio tab appearance.
CAppearanceSetVisualStudio2005 | CAppearanceSetVisualStudio2005 is a CAppearanceSetPropertyPage2003 derived class that represents the Visual Studio 2005 tab appearance.
CColorSet | CColorSet is a class that represents the colors of all the components (tab button, tab button border, etc) of the tab manager.
CColorSetAccess2007 | CColorSetAccess2007 is a CColorSetOffice2007 derived class that represents the Office 2007 tab color set.
CColorSetDefault | CColorSetDefault is a CColorSet derived class that represents the default tab color set.
CColorSetOffice2003 | CColorSetOffice2003 is a CColorSetDefault derived class that represents the Office 2003 tab color set.
CColorSetOffice2007 | CColorSetOffice2007 is a CColorSetOffice2003 derived class that represents the Office 2007 tab color set.
CColorSetVisualStudio | CColorSetVisualStudio is a CColorSetDefault derived class that represents the Visual Studio tab color set.
CColorSetVisualStudio2008 | CColorSetVisualStudio2008 is a CColorSetOffice2003 derived class that represents the Visual Studio 2008 tab color set.
CColorSetWhidbey | CColorSetWhidbey is a CColorSetOffice2003 derived class that represents the Visual Studio 2005 "Whidbey" tab color set.
CColorSetWinXP | CColorSetWinXP is a CColorSetDefault derived class that represents the Windows XP tab color set.


CXTPTaskPanel Classes Classes

CXTPTaskPanel Classes Classes
CXTPTaskPanel Classes
Classes
Class | Description
CRepositionContext | CRepositionContext is helper class to lock/unlock redraw of Task Panel


Legend

Legend
CXTAnimationMemDC Constructors
Legend
Constructor


CXTAnimationMemDC Constructors Public Methods

CXTAnimationMemDC Constructors Public Methods
CXTAnimationMemDC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTAnimationMemDC | Constructs a CXTAnimationMemDC object


Public Methods

Legend
Legend
Constructor


Legend

Legend
CXTBrowseButton Constructors
Legend
Constructor


CXTBrowseButton Constructors Public Methods

CXTBrowseButton Constructors Public Methods
CXTBrowseButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTBrowseButton | Constructs a CXTBrowseButton object


Legend

Legend
CXTBrowseDialog Constructors
Legend
Constructor


CXTBrowseDialog Constructors Public Methods

CXTBrowseDialog Constructors Public Methods
CXTBrowseDialog Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTBrowseDialog | Constructs a CXTBrowseDialog object


Legend

Legend
CXTBrowseEdit Constructors
Legend
Constructor


CXTBrowseEdit Constructors Public Methods

CXTBrowseEdit Constructors Public Methods
CXTBrowseEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTBrowseEdit | Constructs a CXTBrowseEdit object


Legend

Legend
CXTButton Constructors
Legend
Constructor


CXTButton Constructors Public Methods

CXTButton Constructors Public Methods
CXTButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTButton | Constructs a CXTButton object


Legend

Legend
CXTButtonTheme Constructors
Legend
Constructor


CXTButtonTheme Constructors Public Methods

CXTButtonTheme Constructors Public Methods
CXTButtonTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTButtonTheme | Constructs a CXTButtonTheme object.


Legend

Legend
CXTButtonThemeOffice2003 Constructors
Legend
Constructor


CXTButtonThemeOffice2003 Constructors Public Methods

CXTButtonThemeOffice2003 Constructors Public Methods
CXTButtonThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTButtonThemeOffice2003 | Constructs a CXTButtonThemeOfficeXP object.


Legend

Legend
CXTButtonThemeOfficeXP Constructors
Legend
Constructor


CXTButtonThemeOfficeXP Constructors Public Methods

CXTButtonThemeOfficeXP Constructors Public Methods
CXTButtonThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTButtonThemeOfficeXP | Constructs a CXTButtonThemeOfficeXP object.


Legend

Legend
CXTCaption Constructors
Legend
Constructor


CXTCaption Constructors Public Methods

CXTCaption Constructors Public Methods
CXTCaption Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTCaption | Constructs a CXTCaption object


Legend

Legend
CXTCaptionButton Constructors
Legend
Constructor


CXTCaptionButton Constructors Public Methods

CXTCaptionButton Constructors Public Methods
CXTCaptionButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionButton | Constructs a CXTCaptionButton object


Legend

Legend
CXTCaptionButtonTheme Constructors
Legend
Constructor


CXTCaptionButtonTheme Constructors Public Methods

CXTCaptionButtonTheme Constructors Public Methods
CXTCaptionButtonTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionButtonTheme | Default class constructor.


Legend

Legend
CXTCaptionButtonThemeOfficeXP Constructors
Legend
Constructor


CXTCaptionButtonThemeOfficeXP Constructors Public Methods

CXTCaptionButtonThemeOfficeXP Constructors Public Methods
CXTCaptionButtonThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionButtonThemeOfficeXP | Default class constructor. Call this member function to construct a CXTCaptionButtonThemeOfficeXP object.


Legend

Legend
CXTCaptionPopupWnd Constructors
Legend
Constructor


CXTCaptionPopupWnd Constructors Public Methods

CXTCaptionPopupWnd Constructors Public Methods
CXTCaptionPopupWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionPopupWnd | Constructs a CXTCaptionPopupWnd object


Legend

Legend
CXTCaptionTheme Constructors
Legend
Constructor


CXTCaptionTheme Constructors Public Methods

CXTCaptionTheme Constructors Public Methods
CXTCaptionTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionTheme | Constructs a CXTCaptionTheme object.


Legend

Legend
CXTCaptionThemeOffice2003 Constructors
Legend
Constructor


CXTCaptionThemeOffice2003 Constructors Public Methods

CXTCaptionThemeOffice2003 Constructors Public Methods
CXTCaptionThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTCaptionThemeOffice2003 | Default class constructor. Call this member function to construct a CXTCaptionThemeOffice2003 object.


Legend

Legend
CXTCheckListBox Constructors
Legend
Constructor


CXTCheckListBox Constructors Public Methods

CXTCheckListBox Constructors Public Methods
CXTCheckListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTCheckListBox | Constructs a CXTCheckListBox object


Legend

Legend
CCheckListState Constructors
Legend
Constructor


CCheckListState Constructors Public Methods

CCheckListState Constructors Public Methods
CCheckListState Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CCheckListState | Constructs a CCheckListState object


Legend

Legend
CXTColorBase Constructors
Legend
Constructor


CXTColorBase Constructors Public Methods

CXTColorBase Constructors Public Methods
CXTColorBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorBase | Constructs a CXTColorBase object


Legend

Legend
CXTColorDialog Constructors
Legend
Constructor


CXTColorDialog Constructors Public Methods

CXTColorDialog Constructors Public Methods
CXTColorDialog Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorDialog | Constructs a CXTColorDialog object


Legend

Legend
CXTColorHex Constructors
Legend
Constructor


CXTColorHex Constructors Public Methods

CXTColorHex Constructors Public Methods
CXTColorHex Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorHex | Constructs a CXTColorHex object


Legend

Legend
CXTColorLum Constructors
Legend
Constructor


CXTColorLum Constructors Public Methods

CXTColorLum Constructors Public Methods
CXTColorLum Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorLum | Constructs a CXTColorLum object


Legend

Legend
CXTColorPageCustom Constructors
Legend
Constructor


CXTColorPageCustom Constructors Public Methods

CXTColorPageCustom Constructors Public Methods
CXTColorPageCustom Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorPageCustom | Constructs a CXTColorPageCustom object


Legend

Legend
CXTColorPageStandard Constructors
Legend
Constructor


CXTColorPageStandard Constructors Public Methods

CXTColorPageStandard Constructors Public Methods
CXTColorPageStandard Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorPageStandard | Constructs a CXTColorPageStandard object


Legend

Legend
CXTColorPicker Constructors
Legend
Constructor


CXTColorPicker Constructors Public Methods

CXTColorPicker Constructors Public Methods
CXTColorPicker Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorPicker | Constructs a CXTColorPicker object


Legend

Legend
CXTColorPopup Constructors
Legend
Constructor


CXTColorPopup Constructors Public Methods

CXTColorPopup Constructors Public Methods
CXTColorPopup Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorPopup | Constructs a CXTColorPopup object.


Legend

Legend
CXTColorRef Constructors
Legend
Constructor


CXTColorRef Constructors Public Methods

CXTColorRef Constructors Public Methods
CXTColorRef Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorRef |


Legend

Legend
CXTColorSelectorCtrl Constructors
Legend
Constructor


CXTColorSelectorCtrl Constructors Public Methods

CXTColorSelectorCtrl Constructors Public Methods
CXTColorSelectorCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorSelectorCtrl | Constructs a CXTColorSelectorCtrl object


Legend

Legend
CXTColorSelectorCtrlTheme Constructors
Legend
Constructor


CXTColorSelectorCtrlTheme Constructors Public Methods

CXTColorSelectorCtrlTheme Constructors Public Methods
CXTColorSelectorCtrlTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorSelectorCtrlTheme | Constructs a CXTColorSelectorCtrlTheme object.


Legend

Legend
CXTColorSelectorCtrlThemeOffice2003 Constructors
Legend
Constructor


CXTColorSelectorCtrlThemeOffice2003 Constructors Public Methods

CXTColorSelectorCtrlThemeOffice2003 Constructors Public Methods
CXTColorSelectorCtrlThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorSelectorCtrlThemeOffice2003 | Constructs a CXTColorSelectorCtrlThemeOffice2003 object.


Legend

Legend
CXTColorSelectorCtrlThemeOfficeXP Constructors
Legend
Constructor


CXTColorSelectorCtrlThemeOfficeXP Constructors Public Methods

CXTColorSelectorCtrlThemeOfficeXP Constructors Public Methods
CXTColorSelectorCtrlThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorSelectorCtrlThemeOfficeXP | Constructs a CXTColorSelectorCtrlThemeOfficeXP object.


Legend

Legend
CXTColorWnd Constructors
Legend
Constructor


CXTColorWnd Constructors Public Methods

CXTColorWnd Constructors Public Methods
CXTColorWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTColorWnd | Constructs a CXTColorWnd object


Legend

Legend
CXTComboBoxEx Constructors
Legend
Constructor


CXTComboBoxEx Constructors Public Methods

CXTComboBoxEx Constructors Public Methods
CXTComboBoxEx Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTComboBoxEx | Constructs a CXTComboBoxEx object


Legend

Legend
CXTDateEdit Constructors
Legend
Constructor


CXTDateEdit Constructors Public Methods

CXTDateEdit Constructors Public Methods
CXTDateEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTDateEdit | Constructs a CXTDateEdit object


Legend

Legend
CXTDateTimeCtrl Constructors
Legend
Constructor


CXTDateTimeCtrl Constructors Public Methods

CXTDateTimeCtrl Constructors Public Methods
CXTDateTimeCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTDateTimeCtrl | Constructs a CXTDateTimeCtrl object


Legend

Legend
CXTDirWatcher Constructors
Legend
Constructor


CXTDirWatcher Constructors Public Methods

CXTDirWatcher Constructors Public Methods
CXTDirWatcher Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTDirWatcher | Constructs a CXTDirWatcher object


Legend

Legend
CXTDropSource Constructors
Legend
Constructor


CXTDropSource Constructors Public Methods

CXTDropSource Constructors Public Methods
CXTDropSource Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTDropSource | Constructs a CXTDropSource object


Legend

Legend
CXTEdit Constructors
Legend
Constructor


CXTEdit Constructors Public Methods

CXTEdit Constructors Public Methods
CXTEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTEdit | Constructs a CXTEdit object


Legend

Legend
CXTEditListBox Constructors
Legend
Constructor


CXTEditListBox Constructors Public Methods

CXTEditListBox Constructors Public Methods
CXTEditListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTEditListBox | Constructs a CXTEditListBox object


Legend

Legend
CXTEditListBoxToolBar Constructors
Legend
Constructor


CXTEditListBoxToolBar Constructors Public Methods

CXTEditListBoxToolBar Constructors Public Methods
CXTEditListBoxToolBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTEditListBoxToolBar | Constructs a CXTEditListBoxToolBar object


Legend

Legend
CXTExcelTabCtrl Constructors
Legend
Constructor


CXTExcelTabCtrl Constructors Public Methods

CXTExcelTabCtrl Constructors Public Methods
CXTExcelTabCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTExcelTabCtrl | Constructs a CXTExcelTabCtrl object


Legend

Legend
CXTExcelTabCtrlButtonState Constructors
Legend
Constructor


CXTExcelTabCtrlButtonState Constructors Public Methods

CXTExcelTabCtrlButtonState Constructors Public Methods
CXTExcelTabCtrlButtonState Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTExcelTabCtrlButtonState | Constructs a CXTExcelTabCtrlButtonState object.


Legend

Legend
CXTExcelTabCtrlTheme Constructors
Legend
Constructor


CXTExcelTabCtrlTheme Constructors Public Methods

CXTExcelTabCtrlTheme Constructors Public Methods
CXTExcelTabCtrlTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTExcelTabCtrlTheme | Constructs a CXTExcelTabCtrlTheme object.


Legend

Legend
CXTFlatComboBox Constructors
Legend
Constructor


CXTFlatComboBox Constructors Public Methods

CXTFlatComboBox Constructors Public Methods
CXTFlatComboBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatComboBox | Constructs a CXTFlatComboBox object


Legend

Legend
CXTFlatComboBoxTheme Constructors
Legend
Constructor


CXTFlatComboBoxTheme Constructors Public Methods

CXTFlatComboBoxTheme Constructors Public Methods
CXTFlatComboBoxTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatComboBoxTheme | Constructs a CXTFlatComboBoxTheme object.


Legend

Legend
CXTFlatComboBoxThemeOffice2003 Constructors
Legend
Constructor


CXTFlatComboBoxThemeOffice2003 Constructors Public Methods

CXTFlatComboBoxThemeOffice2003 Constructors Public Methods
CXTFlatComboBoxThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatComboBoxThemeOffice2003 | Constructs a CXTFlatComboBoxThemeOffice2003 object.


Legend

Legend
CXTFlatComboBoxThemeOfficeXP Constructors
Legend
Constructor


CXTFlatComboBoxThemeOfficeXP Constructors Public Methods

CXTFlatComboBoxThemeOfficeXP Constructors Public Methods
CXTFlatComboBoxThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatComboBoxThemeOfficeXP | Constructs a CXTFlatComboBoxThemeOfficeXP object.


Legend

Legend
CXTFlatEdit Constructors
Legend
Constructor


CXTFlatEdit Constructors Public Methods

CXTFlatEdit Constructors Public Methods
CXTFlatEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatEdit | Constructs a CXTFlatEdit object


Legend

Legend
CXTFlatEditTheme Constructors
Legend
Constructor


CXTFlatEditTheme Constructors Public Methods

CXTFlatEditTheme Constructors Public Methods
CXTFlatEditTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatEditTheme | Constructs a CXTFlatEditTheme object.


Legend

Legend
CXTFlatEditThemeOffice2003 Constructors
Legend
Constructor


CXTFlatEditThemeOffice2003 Constructors Public Methods

CXTFlatEditThemeOffice2003 Constructors Public Methods
CXTFlatEditThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatEditThemeOffice2003 | Constructs a CXTFlatEditThemeOffice2003 object.


Legend

Legend
CXTFlatEditThemeOfficeXP Constructors
Legend
Constructor


CXTFlatEditThemeOfficeXP Constructors Public Methods

CXTFlatEditThemeOfficeXP Constructors Public Methods
CXTFlatEditThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatEditThemeOfficeXP | Constructs a CXTFlatEditThemeOfficeXP object.


Legend

Legend
CXTFlatHeaderCtrl Constructors
Legend
Constructor


CXTFlatHeaderCtrl Constructors Public Methods

CXTFlatHeaderCtrl Constructors Public Methods
CXTFlatHeaderCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFlatHeaderCtrl | Constructs a CXTFlatHeaderCtrl object


Legend

Legend
CXTFontCombo Constructors
Legend
Constructor


CXTFontCombo Constructors Public Methods

CXTFontCombo Constructors Public Methods
CXTFontCombo Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFontCombo | Constructs a CXTFontCombo object


Legend

Legend
CXTFontEnum Constructors
Legend
Constructor
protected


CXTFontEnum Constructors Protected Methods

CXTFontEnum Constructors Protected Methods
CXTFontEnum Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTFontEnum | Constructs a CXTFontEnum object. CXTFontEnum is a singleton class, to instantiate an object, use the static method Get().


Protected Methods

Legend
Legend
Constructor
protected


Legend

Legend
CXTFontListBox Constructors
Legend
Constructor


CXTFontListBox Constructors Public Methods

CXTFontListBox Constructors Public Methods
CXTFontListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTFontListBox | Constructs a CXTFontListBox object


Legend

Legend
CXTHeaderCtrl Constructors
Legend
Constructor


CXTHeaderCtrl Constructors Public Methods

CXTHeaderCtrl Constructors Public Methods
CXTHeaderCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrl | Constructs a CXTHeaderCtrl object


Legend

Legend
CXTHeaderCtrlTheme Constructors
Legend
Constructor


CXTHeaderCtrlTheme Constructors Public Methods

CXTHeaderCtrlTheme Constructors Public Methods
CXTHeaderCtrlTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrlTheme | Constructs a CXTHeaderCtrlTheme object using the specified header control.


Legend

Legend
CXTHeaderCtrlThemeExplorer Constructors
Legend
Constructor


CXTHeaderCtrlThemeExplorer Constructors Public Methods

CXTHeaderCtrlThemeExplorer Constructors Public Methods
CXTHeaderCtrlThemeExplorer Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrlThemeExplorer | Constructs a CXTHeaderCtrlThemeExplorer object using the specified header control.


Legend

Legend
CXTHeaderCtrlThemeOffice2003 Constructors
Legend
Constructor


CXTHeaderCtrlThemeOffice2003 Constructors Public Methods

CXTHeaderCtrlThemeOffice2003 Constructors Public Methods
CXTHeaderCtrlThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrlThemeOffice2003 | Constructs a CXTHeaderCtrlThemeOffice2003 object using the specified header control.


Legend

Legend
CXTHeaderCtrlThemeOfficeXP Constructors
Legend
Constructor


CXTHeaderCtrlThemeOfficeXP Constructors Public Methods

CXTHeaderCtrlThemeOfficeXP Constructors Public Methods
CXTHeaderCtrlThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTHeaderCtrlThemeOfficeXP | Constructs a CXTHeaderCtrlThemeOfficeXP object using the specified header control.


Legend

Legend
CXTHexEdit Constructors
Legend
Constructor


CXTHexEdit Constructors Public Methods

CXTHexEdit Constructors Public Methods
CXTHexEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTHexEdit | Constructs a CXTHexEdit object


Legend

Legend
CXTHtmlView Constructors
Legend
Constructor
protected


CXTHtmlView Constructors Protected Methods

CXTHtmlView Constructors Protected Methods
CXTHtmlView Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTHtmlView | Constructs a CXTHtmlView object


Legend

Legend
CXTHyperLink Constructors
Legend
Constructor


CXTHyperLink Constructors Public Methods

CXTHyperLink Constructors Public Methods
CXTHyperLink Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTHyperLink | Constructs a CXTHyperLink object.


Legend

Legend
CXTIconHandle Constructors
Legend
Constructor


CXTIconHandle Constructors Public Methods

CXTIconHandle Constructors Public Methods
CXTIconHandle Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTIconHandle |


Legend

Legend
CXTItemEdit Constructors
Legend
Constructor


CXTItemEdit Constructors Public Methods

CXTItemEdit Constructors Public Methods
CXTItemEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTItemEdit | Constructs a CXTItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box


Legend

Legend
CXTListBase Constructors
Legend
Constructor


CXTListBase Constructors Public Methods

CXTListBase Constructors Public Methods
CXTListBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTListBase | Constructs a CXTListBase object


Legend

Legend
CXTListBox Constructors
Legend
Constructor


CXTListBox Constructors Public Methods

CXTListBox Constructors Public Methods
CXTListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTListBox | Constructs a CXTListBox object


Legend

Legend
CXTListCtrl Constructors
Legend
Constructor


CXTListCtrl Constructors Public Methods

CXTListCtrl Constructors Public Methods
CXTListCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTListCtrl | Constructs a CXTListCtrl object


Legend

Legend
CXTListView Constructors
Legend
Constructor


CXTListView Constructors Public Methods

CXTListView Constructors Public Methods
CXTListView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTListView | Constructs a CXTListView object


Legend

Legend
CXTLogFont Constructors
Legend
Constructor


CXTLogFont Constructors Public Methods

CXTLogFont Constructors Public Methods
CXTLogFont Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTLogFont |


Legend

Legend
CXTMaskEdit Constructors
Legend
Constructor


CXTMaskEdit Constructors Public Methods

CXTMaskEdit Constructors Public Methods
CXTMaskEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMaskEdit | Constructs a CXTMaskEdit object


Legend

Legend
CXTMaskEditT Constructors
Legend
Constructor


CXTMaskEditT Constructors Public Methods

CXTMaskEditT Constructors Public Methods
CXTMaskEditT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMaskEditT | Constructs a CXTMaskEditT object


Legend

Legend
CXTMDIClientWnd Constructors
Legend
Constructor


CXTMDIClientWnd Constructors Public Methods

CXTMDIClientWnd Constructors Public Methods
CXTMDIClientWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMDIClientWnd | Constructs a CXTMDIClientWnd object


Legend

Legend
CXTMDIWndTab Constructors
Legend
Constructor


CXTMDIWndTab Constructors Public Methods

CXTMDIWndTab Constructors Public Methods
CXTMDIWndTab Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMDIWndTab | Constructs a CXTMDIWndTab object


Legend

Legend
CXTMemDC Constructors
Legend
Constructor


CXTMemDC Constructors Public Methods

CXTMemDC Constructors Public Methods
CXTMemDC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMemDC | Constructs a CXTMemDC object used for flicker free drawing.


Legend

Legend
CXTMemFile Constructors
Legend
Constructor


CXTMemFile Constructors Public Methods

CXTMemFile Constructors Public Methods
CXTMemFile Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMemFile |


Legend

Legend
CXTMenuListBox Constructors
Legend
Constructor


CXTMenuListBox Constructors Public Methods

CXTMenuListBox Constructors Public Methods
CXTMenuListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMenuListBox | Constructs a CXTMenuListBox object


Legend

Legend
CXTMenuListBoxTheme Constructors
Legend
Constructor


CXTMenuListBoxTheme Constructors Public Methods

CXTMenuListBoxTheme Constructors Public Methods
CXTMenuListBoxTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMenuListBoxTheme | Constructs a CXTMenuListBoxTheme object.


Legend

Legend
CXTMenuListBoxThemeOffice2003 Constructors
Legend
Constructor


CXTMenuListBoxThemeOffice2003 Constructors Public Methods

CXTMenuListBoxThemeOffice2003 Constructors Public Methods
CXTMenuListBoxThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMenuListBoxThemeOffice2003 | Constructs a CXTMenuListBoxThemeOffice2003 object.


Legend

Legend
CXTMenuListBoxThemeOfficeXP Constructors
Legend
Constructor


CXTMenuListBoxThemeOfficeXP Constructors Public Methods

CXTMenuListBoxThemeOfficeXP Constructors Public Methods
CXTMenuListBoxThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMenuListBoxThemeOfficeXP | Constructs a CXTMenuListBoxThemeOfficeXP object.


Legend

Legend
CXTMonthCalCtrl Constructors
Legend
Constructor


CXTMonthCalCtrl Constructors Public Methods

CXTMonthCalCtrl Constructors Public Methods
CXTMonthCalCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTMonthCalCtrl | Constructs a CXTMonthCalCtrl object


Legend

Legend
CXTNonClientMetrics Constructors
Legend
Constructor


CXTNonClientMetrics Constructors Public Methods

CXTNonClientMetrics Constructors Public Methods
CXTNonClientMetrics Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTNonClientMetrics | Constructs an CXTNonClientMetrics object


Legend

Legend
CXTOutBarCtrl Constructors
Legend
Constructor


CXTOutBarCtrl Constructors Public Methods

CXTOutBarCtrl Constructors Public Methods
CXTOutBarCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarCtrl | Constructs a CXTOutBarCtrl object


Legend

Legend
CXTOutBarCtrlTheme Constructors
Legend
Constructor


CXTOutBarCtrlTheme Constructors Public Methods

CXTOutBarCtrlTheme Constructors Public Methods
CXTOutBarCtrlTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarCtrlTheme | Constructs a CXTOutBarCtrlTheme object.


Legend

Legend
CXTOutBarCtrlThemeOffice2003 Constructors
Legend
Constructor


CXTOutBarCtrlThemeOffice2003 Constructors Public Methods

CXTOutBarCtrlThemeOffice2003 Constructors Public Methods
CXTOutBarCtrlThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarCtrlThemeOffice2003 | Constructs a CXTOutBarCtrlThemeOffice2003 object.


Legend

Legend
CXTOutBarCtrlThemeOfficeXP Constructors
Legend
Constructor


CXTOutBarCtrlThemeOfficeXP Constructors Public Methods

CXTOutBarCtrlThemeOfficeXP Constructors Public Methods
CXTOutBarCtrlThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarCtrlThemeOfficeXP | Constructs a CXTOutBarCtrlThemeOfficeXP object.


Legend

Legend
CXTOutBarEditItem Constructors
Legend
Constructor


CXTOutBarEditItem Constructors Public Methods

CXTOutBarEditItem Constructors Public Methods
CXTOutBarEditItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarEditItem | Constructs a CXTOutBarEditItem object


Legend

Legend
CXTOutBarFolder Constructors
Legend
Constructor


CXTOutBarFolder Constructors Public Methods

CXTOutBarFolder Constructors Public Methods
CXTOutBarFolder Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarFolder | Constructs a CXTOutBarFolder object.


Legend

Legend
CXTOutBarItem Constructors
Legend
Constructor


CXTOutBarItem Constructors Public Methods

CXTOutBarItem Constructors Public Methods
CXTOutBarItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTOutBarItem | Constructs a CXTOutBarItem object


Legend

Legend
CXTPagerCtrl Constructors
Legend
Constructor


CXTPagerCtrl Constructors Public Methods

CXTPagerCtrl Constructors Public Methods
CXTPagerCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPagerCtrl | Constructs a CXTPagerCtrl object


Legend

Legend
CXTPAutoResetValue Constructors
Legend
Constructor


CXTPAutoResetValue Constructors Public Methods

CXTPAutoResetValue Constructors Public Methods
CXTPAutoResetValue Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPAutoResetValue |


Legend

Legend
CXTPBitmapDC Constructors
Legend
Constructor


CXTPBitmapDC Constructors Public Methods

CXTPBitmapDC Constructors Public Methods
CXTPBitmapDC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPBitmapDC |


Legend

Legend
CXTPBrushDC Constructors
Legend
Constructor


CXTPBrushDC Constructors Public Methods

CXTPBrushDC Constructors Public Methods
CXTPBrushDC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPBrushDC | Constructs a CXTPBrushDC object and creates a brush using the color specified by crColor. The brush is then selected into the device context specified by hDC.


Legend

Legend
CXTPBufferDC Constructors
Legend
Constructor


CXTPBufferDC Constructors Public Methods

CXTPBufferDC Constructors Public Methods
CXTPBufferDC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPBufferDC |


Legend

Legend
CXTPBufferDCEx Constructors
Legend
Constructor


CXTPBufferDCEx Constructors Public Methods

CXTPBufferDCEx Constructors Public Methods
CXTPBufferDCEx Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPBufferDCEx | Constructs a CXTPBufferDCEx object used to create a memory device context used to draw to an off-screen bitmap.


Legend

Legend
CXTPCalendarControl Constructors
Legend
Constructor


CXTPCalendarControl Constructors Public Methods

CXTPCalendarControl Constructors Public Methods
CXTPCalendarControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarControl | This member function constructs a CXTPCalendarControl object.


Legend

Legend
CUpdateContext Constructors
Legend
Constructor


CUpdateContext Constructors Public Methods

CUpdateContext Constructors Public Methods
CUpdateContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CUpdateContext | Constructs a CUpdateContext object.


Legend

Legend
CViewChanged_ContextData Constructors
Legend
Constructor


CViewChanged_ContextData Constructors Public Methods

CViewChanged_ContextData Constructors Public Methods
CViewChanged_ContextData Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CViewChanged_ContextData | Default object constructor.


Legend

Legend
CViewChangedContext Constructors
Legend
Constructor


CViewChangedContext Constructors Public Methods

CViewChangedContext Constructors Public Methods
CViewChangedContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CViewChangedContext |


Legend

Legend
CXTPCalendarController Constructors
Legend
Constructor


CXTPCalendarController Constructors Public Methods

CXTPCalendarController Constructors Public Methods
CXTPCalendarController Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarController | Constructs a CXTPCalendarController object.


Legend

Legend
CXTPCalendarControlView Constructors
Legend
Constructor
protected


CXTPCalendarControlView Constructors Protected Methods

CXTPCalendarControlView Constructors Protected Methods
CXTPCalendarControlView Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPCalendarControlView | Protected constructor used by dynamic creation


Legend

Legend
CXTPCalendarControlViewPrintOptions Constructors
Legend
Constructor


CXTPCalendarControlViewPrintOptions Constructors Public Methods

CXTPCalendarControlViewPrintOptions Constructors Public Methods
CXTPCalendarControlViewPrintOptions Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarControlViewPrintOptions | Default constructor.


Legend

Legend
CXTPCalendarCustomDataProvider Constructors
Legend
Constructor


CXTPCalendarCustomDataProvider Constructors Public Methods

CXTPCalendarCustomDataProvider Constructors Public Methods
CXTPCalendarCustomDataProvider Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarCustomDataProvider | Default constructor.


Legend

Legend
CXTPCalendarCustomProperties Constructors
Legend
Constructor


CXTPCalendarCustomProperties Constructors Public Methods

CXTPCalendarCustomProperties Constructors Public Methods
CXTPCalendarCustomProperties Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarCustomProperties | Default object constructor.


Legend

Legend
CXTPCalendarData Constructors
Legend
Constructor


CXTPCalendarData Constructors Public Methods

CXTPCalendarData Constructors Public Methods
CXTPCalendarData Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarData | Default constructor.


Legend

Legend
CXTPDPCache Constructors
Legend
Constructor


CXTPDPCache Constructors Public Methods

CXTPDPCache Constructors Public Methods
CXTPDPCache Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDPCache | Default class constructor.


Legend

Legend
EventsMapByID_T Constructors
Legend
Constructor


EventsMapByID_T Constructors Public Methods

EventsMapByID_T Constructors Public Methods
EventsMapByID_T Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
EventsMapByID_T | Default class constructor.


Legend

Legend
CXTPCalendarDatabaseDataProvider Constructors
Legend
Constructor


CXTPCalendarDatabaseDataProvider Constructors Public Methods

CXTPCalendarDatabaseDataProvider Constructors Public Methods
CXTPCalendarDatabaseDataProvider Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDatabaseDataProvider | Default constructor.


Legend

Legend
CXTPCalendarDayView Constructors
Legend
Constructor


CXTPCalendarDayView Constructors Public Methods

CXTPCalendarDayView Constructors Public Methods
CXTPCalendarDayView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayView | Default object constructor.


Legend

Legend
CXTPCalendarDayViewDay Constructors
Legend
Constructor


CXTPCalendarDayViewDay Constructors Public Methods

CXTPCalendarDayViewDay Constructors Public Methods
CXTPCalendarDayViewDay Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayViewDay | Default object constructor.


Legend

Legend
CXTPCalendarDayViewEvent Constructors
Legend
Constructor


CXTPCalendarDayViewEvent Constructors Public Methods

CXTPCalendarDayViewEvent Constructors Public Methods
CXTPCalendarDayViewEvent Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayViewEvent | Default object constructor.


Legend

Legend
CXTPCalendarDayViewGroup Constructors
Legend
Constructor


CXTPCalendarDayViewGroup Constructors Public Methods

CXTPCalendarDayViewGroup Constructors Public Methods
CXTPCalendarDayViewGroup Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayViewGroup | Default object constructor. Construct CXTPCalendarDayViewGroup object.


Legend

Legend
CXTPCalendarDayViewTimeScale Constructors
Legend
Constructor


CXTPCalendarDayViewTimeScale Constructors Public Methods

CXTPCalendarDayViewTimeScale Constructors Public Methods
CXTPCalendarDayViewTimeScale Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarDayViewTimeScale | Default object constructor.


Legend

Legend
CXTPCalendarEvent Constructors
Legend
Constructor


CXTPCalendarEvent Constructors Public Methods

CXTPCalendarEvent Constructors Public Methods
CXTPCalendarEvent Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEvent | Default object constructor.


Legend

Legend
CXTPCalendarEventCategories Constructors
Legend
Constructor


CXTPCalendarEventCategories Constructors Public Methods

CXTPCalendarEventCategories Constructors Public Methods
CXTPCalendarEventCategories Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventCategories | Default class constructor.


Legend

Legend
CXTPCalendarEventCategory Constructors
Legend
Constructor


CXTPCalendarEventCategory Constructors Public Methods

CXTPCalendarEventCategory Constructors Public Methods
CXTPCalendarEventCategory Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventCategory | Default class constructor.


Legend

Legend
CXTPCalendarEventCategoryIDs Constructors
Legend
Constructor


CXTPCalendarEventCategoryIDs Constructors Public Methods

CXTPCalendarEventCategoryIDs Constructors Public Methods
CXTPCalendarEventCategoryIDs Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventCategoryIDs | Default object constructor.


Legend

Legend
CXTPCalendarEventLabel Constructors
Legend
Constructor


CXTPCalendarEventLabel Constructors Public Methods

CXTPCalendarEventLabel Constructors Public Methods
CXTPCalendarEventLabel Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventLabel | Default class constructor.


Legend

Legend
CXTPCalendarEventLabels Constructors
Legend
Constructor


CXTPCalendarEventLabels Constructors Public Methods

CXTPCalendarEventLabels Constructors Public Methods
CXTPCalendarEventLabels Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEventLabels | Default class constructor.


Legend

Legend
CXTPCalendarEvents Constructors
Legend
Constructor


CXTPCalendarEvents Constructors Public Methods

CXTPCalendarEvents Constructors Public Methods
CXTPCalendarEvents Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarEvents | Default collection constructor.


Legend

Legend
CXTPCalendarIconIDs Constructors
Legend
Constructor


CXTPCalendarIconIDs Constructors Public Methods

CXTPCalendarIconIDs Constructors Public Methods
CXTPCalendarIconIDs Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarIconIDs | Default object constructor.


Legend

Legend
CXTPCalendarMAPIDataProvider Constructors
Legend
Constructor


CXTPCalendarMAPIDataProvider Constructors Public Methods

CXTPCalendarMAPIDataProvider Constructors Public Methods
CXTPCalendarMAPIDataProvider Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMAPIDataProvider | Default constructor.


Legend

Legend
CXTPCalendarMemDPInternal Constructors
Legend
Constructor


CXTPCalendarMemDPInternal Constructors Public Methods

CXTPCalendarMemDPInternal Constructors Public Methods
CXTPCalendarMemDPInternal Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMemDPInternal | Default constructor.


Legend

Legend
CXTPCalendarMAPIWrapper Constructors
Legend
Constructor


CXTPCalendarMAPIWrapper Constructors Public Methods

CXTPCalendarMAPIWrapper Constructors Public Methods
CXTPCalendarMAPIWrapper Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMAPIWrapper | Constructs a CXTPCalendarMAPIWrapper object.


Legend

Legend
CXTPCalendarMemoryDataProvider Constructors
Legend
Constructor


CXTPCalendarMemoryDataProvider Constructors Public Methods

CXTPCalendarMemoryDataProvider Constructors Public Methods
CXTPCalendarMemoryDataProvider Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMemoryDataProvider | Default constructor.


Legend

Legend
CXTPCalendarMonthView Constructors
Legend
Constructor


CXTPCalendarMonthView Constructors Public Methods

CXTPCalendarMonthView Constructors Public Methods
CXTPCalendarMonthView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMonthView | Default object constructor.


Legend

Legend
CMonthViewGrid Constructors
Legend
Constructor


CMonthViewGrid Constructors Public Methods

CMonthViewGrid Constructors Public Methods
CMonthViewGrid Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CMonthViewGrid | Default class constructor.


Legend

Legend
CXTPCalendarMonthViewDay Constructors
Legend
Constructor


CXTPCalendarMonthViewDay Constructors Public Methods

CXTPCalendarMonthViewDay Constructors Public Methods
CXTPCalendarMonthViewDay Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMonthViewDay | Default object constructor. Construct a CXTPCalendarMonthViewDay object.


Legend

Legend
CXTPCalendarMonthViewEvent Constructors
Legend
Constructor


CXTPCalendarMonthViewEvent Constructors Public Methods

CXTPCalendarMonthViewEvent Constructors Public Methods
CXTPCalendarMonthViewEvent Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMonthViewEvent | Default object constructor.


Legend

Legend
CXTPCalendarMonthViewGroup Constructors
Legend
Constructor


CXTPCalendarMonthViewGroup Constructors Public Methods

CXTPCalendarMonthViewGroup Constructors Public Methods
CXTPCalendarMonthViewGroup Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarMonthViewGroup | Default object constructor. Construct CXTPCalendarMonthViewGroup object.


Legend

Legend
CXTPCalendarOccurSeriesChooseDlg Constructors
Legend
Constructor


CXTPCalendarOccurSeriesChooseDlg Constructors Public Methods

CXTPCalendarOccurSeriesChooseDlg Constructors Public Methods
CXTPCalendarOccurSeriesChooseDlg Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarOccurSeriesChooseDlg | Default object constructor.


Legend

Legend
CXTPCalendarOptions Constructors
Legend
Constructor


CXTPCalendarOptions Constructors Public Methods

CXTPCalendarOptions Constructors Public Methods
CXTPCalendarOptions Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarOptions | Default object constructor.


Legend

Legend
CXTPCalendarPageSetupDialog Constructors
Legend
Constructor


CXTPCalendarPageSetupDialog Constructors Public Methods

CXTPCalendarPageSetupDialog Constructors Public Methods
CXTPCalendarPageSetupDialog Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarPageSetupDialog | Class constructor.


Legend

Legend
CXTPCalendarPaintManager Constructors
Legend
Constructor


CXTPCalendarPaintManager Constructors Public Methods

CXTPCalendarPaintManager Constructors Public Methods
CXTPCalendarPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarPaintManager | Default paint manager constructor.


Legend

Legend
CXTPCalendarPtrCollectionT Constructors
Legend
Constructor


CXTPCalendarPtrCollectionT Constructors Public Methods

CXTPCalendarPtrCollectionT Constructors Public Methods
CXTPCalendarPtrCollectionT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarPtrCollectionT | Default collection constructor.


Legend

Legend
CXTPCalendarRecurrencePattern Constructors
Legend
Constructor
protected


CXTPCalendarRecurrencePattern Constructors Protected Methods

CXTPCalendarRecurrencePattern Constructors Protected Methods
CXTPCalendarRecurrencePattern Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPCalendarRecurrencePattern | Protected pattern constructor.


Legend

Legend
CXTPCalendarReminder Constructors
Legend
Constructor


CXTPCalendarReminder Constructors Public Methods

CXTPCalendarReminder Constructors Public Methods
CXTPCalendarReminder Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarReminder | Default object constructor.


Legend

Legend
CXTPCalendarReminderForOccurrence Constructors
Legend
Constructor


CXTPCalendarReminderForOccurrence Constructors Public Methods

CXTPCalendarReminderForOccurrence Constructors Public Methods
CXTPCalendarReminderForOccurrence Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarReminderForOccurrence | Default object constructor.


Legend

Legend
CXTPCalendarReminderForOccurrenceArray Constructors
Legend
Constructor


CXTPCalendarReminderForOccurrenceArray Constructors Public Methods

CXTPCalendarReminderForOccurrenceArray Constructors Public Methods
CXTPCalendarReminderForOccurrenceArray Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarReminderForOccurrenceArray | Default collection constructor.


Legend

Legend
CXTPCalendarRemindersManager Constructors
Legend
Constructor


CXTPCalendarRemindersManager Constructors Public Methods

CXTPCalendarRemindersManager Constructors Public Methods
CXTPCalendarRemindersManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarRemindersManager | Default object constructor.


Legend

Legend
CXTPCalendarResource Constructors
Legend
Constructor


CXTPCalendarResource Constructors Public Methods

CXTPCalendarResource Constructors Public Methods
CXTPCalendarResource Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResource | Default object constructor. Construct CXTPCalendarResource object.


Legend

Legend
CXTPCalendarResourceDescription Constructors
Legend
Constructor


CXTPCalendarResourceDescription Constructors Public Methods

CXTPCalendarResourceDescription Constructors Public Methods
CXTPCalendarResourceDescription Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResourceDescription | Default object constructor.


Legend

Legend
CXTPCalendarResources Constructors
Legend
Constructor


CXTPCalendarResources Constructors Public Methods

CXTPCalendarResources Constructors Public Methods
CXTPCalendarResources Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResources | Default collection constructor.


Legend

Legend
CXTPCalendarResourcesManager Constructors
Legend
Constructor


CXTPCalendarResourcesManager Constructors Public Methods

CXTPCalendarResourcesManager Constructors Public Methods
CXTPCalendarResourcesManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResourcesManager | Default object constructor.


Legend

Legend
CXTPCalendarResourcesNf Constructors
Legend
Constructor


CXTPCalendarResourcesNf Constructors Public Methods

CXTPCalendarResourcesNf Constructors Public Methods
CXTPCalendarResourcesNf Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarResourcesNf | Default object constructor. Construct CXTPCalendarResourcesNf object.


Legend

Legend
CXTPCalendarSchedule Constructors
Legend
Constructor


CXTPCalendarSchedule Constructors Public Methods

CXTPCalendarSchedule Constructors Public Methods
CXTPCalendarSchedule Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarSchedule | Default object constructor. Construct CXTPCalendarSchedule object.


Legend

Legend
CXTPCalendarSchedules Constructors
Legend
Constructor


CXTPCalendarSchedules Constructors Public Methods

CXTPCalendarSchedules Constructors Public Methods
CXTPCalendarSchedules Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarSchedules | Default collection constructor.


Legend

Legend
CXTPCalendarThemeBOOLValue Constructors
Legend
Constructor


CXTPCalendarThemeBOOLValue Constructors Public Methods

CXTPCalendarThemeBOOLValue Constructors Public Methods
CXTPCalendarThemeBOOLValue Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeBOOLValue | Default object constructor.


Legend

Legend
CXTPCalendarThemeCustomizableXValueT Constructors
Legend
Constructor


CXTPCalendarThemeCustomizableXValueT Constructors Public Methods

CXTPCalendarThemeCustomizableXValueT Constructors Public Methods
CXTPCalendarThemeCustomizableXValueT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeCustomizableXValueT | Default object constructor.


Legend

Legend
CXTPCalendarThemeFontValue Constructors
Legend
Constructor


CXTPCalendarThemeFontValue Constructors Public Methods

CXTPCalendarThemeFontValue Constructors Public Methods
CXTPCalendarThemeFontValue Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeFontValue | Default constructor.


Legend

Legend
CXTPCalendarThemeIntValue Constructors
Legend
Constructor


CXTPCalendarThemeIntValue Constructors Public Methods

CXTPCalendarThemeIntValue Constructors Public Methods
CXTPCalendarThemeIntValue Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeIntValue | Default object constructor.


Legend

Legend
CXTPCalendarThemeRectValue Constructors
Legend
Constructor


CXTPCalendarThemeRectValue Constructors Public Methods

CXTPCalendarThemeRectValue Constructors Public Methods
CXTPCalendarThemeRectValue Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeRectValue | Default object constructor.


Legend

Legend
CXTPCalendarThemeStringValue Constructors
Legend
Constructor


CXTPCalendarThemeStringValue Constructors Public Methods

CXTPCalendarThemeStringValue Constructors Public Methods
CXTPCalendarThemeStringValue Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarThemeStringValue | Default constructor.


Legend

Legend
CXTPCalendarTimeScalePropertiesDlg Constructors
Legend
Constructor


CXTPCalendarTimeScalePropertiesDlg Constructors Public Methods

CXTPCalendarTimeScalePropertiesDlg Constructors Public Methods
CXTPCalendarTimeScalePropertiesDlg Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTimeScalePropertiesDlg | Dialog class constructor.


Legend

Legend
CXTPCalendarTimeZone Constructors
Legend
Constructor


CXTPCalendarTimeZone Constructors Public Methods

CXTPCalendarTimeZone Constructors Public Methods
CXTPCalendarTimeZone Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTimeZone |


Legend

Legend
CXTPCalendarTimeZones Constructors
Legend
Constructor


CXTPCalendarTimeZones Constructors Public Methods

CXTPCalendarTimeZones Constructors Public Methods
CXTPCalendarTimeZones Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTimeZones | Default object constructor.


Legend

Legend
CXTPCalendarTip Constructors
Legend
Constructor


CXTPCalendarTip Constructors Public Methods

CXTPCalendarTip Constructors Public Methods
CXTPCalendarTip Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTip | Constructs a CXTPCalendarTip object.


Legend

Legend
CXTPCalendarTypedPtrAutoDeleteArray Constructors
Legend
Constructor


CXTPCalendarTypedPtrAutoDeleteArray Constructors Public Methods

CXTPCalendarTypedPtrAutoDeleteArray Constructors Public Methods
CXTPCalendarTypedPtrAutoDeleteArray Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarTypedPtrAutoDeleteArray | Default object constructor.


Legend

Legend
CXTPCalendarView Constructors
Legend
Constructor


CXTPCalendarView Constructors Public Methods

CXTPCalendarView Constructors Public Methods
CXTPCalendarView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarView | Default object constructor.


Legend

Legend
CSelectionChanged_ContextData Constructors
Legend
Constructor


CSelectionChanged_ContextData Constructors Public Methods

CSelectionChanged_ContextData Constructors Public Methods
CSelectionChanged_ContextData Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CSelectionChanged_ContextData | Default object constructor.


Legend

Legend
CSelectionChangedContext Constructors
Legend
Constructor


CSelectionChangedContext Constructors Public Methods

CSelectionChangedContext Constructors Public Methods
CSelectionChangedContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CSelectionChangedContext | Constructs a CSelectionChangedContext object.


Legend

Legend
CUndoBuffer Constructors
Legend
Constructor


CUndoBuffer Constructors Public Methods

CUndoBuffer Constructors Public Methods
CUndoBuffer Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CUndoBuffer | Default class constructor.


Legend

Legend
SUndoAction Constructors
Legend
Constructor


SUndoAction Constructors Public Methods

SUndoAction Constructors Public Methods
SUndoAction Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
SUndoAction |


Legend

Legend
SEventTimeFormatInfo Constructors
Legend
Constructor


SEventTimeFormatInfo Constructors Public Methods

SEventTimeFormatInfo Constructors Public Methods
SEventTimeFormatInfo Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
SEventTimeFormatInfo | Default object constructor.


Legend

Legend
CXTPCalendarViewDay Constructors
Legend
Constructor


CXTPCalendarViewDay Constructors Public Methods

CXTPCalendarViewDay Constructors Public Methods
CXTPCalendarViewDay Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewDay | Default object constructor. Construct CXTPCalendarViewDay object.


Legend

Legend
CXTPCalendarViewDayT Constructors
Legend
Constructor


CXTPCalendarViewDayT Constructors Public Methods

CXTPCalendarViewDayT Constructors Public Methods
CXTPCalendarViewDayT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewDayT | Default object constructor.


Legend

Legend
CXTPCalendarViewEvent Constructors
Legend
Constructor


CXTPCalendarViewEvent Constructors Public Methods

CXTPCalendarViewEvent Constructors Public Methods
CXTPCalendarViewEvent Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEvent | Default object constructor.


Legend

Legend
CXTPCalendarViewEvents Constructors
Legend
Constructor


CXTPCalendarViewEvents Constructors Public Methods

CXTPCalendarViewEvents Constructors Public Methods
CXTPCalendarViewEvents Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEvents | Default class constructor.


Legend

Legend
CXTPCalendarViewEventSubjectEditor2007 Constructors
Legend
Constructor


CXTPCalendarViewEventSubjectEditor2007 Constructors Public Methods

CXTPCalendarViewEventSubjectEditor2007 Constructors Public Methods
CXTPCalendarViewEventSubjectEditor2007 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEventSubjectEditor2007 | Default object constructor.


Legend

Legend
CXTPCalendarViewEventSubjectEditor Constructors
Legend
Constructor


CXTPCalendarViewEventSubjectEditor Constructors Public Methods

CXTPCalendarViewEventSubjectEditor Constructors Public Methods
CXTPCalendarViewEventSubjectEditor Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEventSubjectEditor | Default object constructor.


Legend

Legend
CXTPCalendarViewEventT Constructors
Legend
Constructor


CXTPCalendarViewEventT Constructors Public Methods

CXTPCalendarViewEventT Constructors Public Methods
CXTPCalendarViewEventT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewEventT | Default object constructor.


Legend

Legend
CXTPCalendarViewGroup Constructors
Legend
Constructor


CXTPCalendarViewGroup Constructors Public Methods

CXTPCalendarViewGroup Constructors Public Methods
CXTPCalendarViewGroup Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewGroup | Default object constructor. Construct CXTPCalendarViewGroup object.


Legend

Legend
CXTPCalendarViewGroupT Constructors
Legend
Constructor


CXTPCalendarViewGroupT Constructors Public Methods

CXTPCalendarViewGroupT Constructors Public Methods
CXTPCalendarViewGroupT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewGroupT | Default object constructor.


Legend

Legend
CXTPCalendarViewPart Constructors
Legend
Constructor


CXTPCalendarViewPart Constructors Public Methods

CXTPCalendarViewPart Constructors Public Methods
CXTPCalendarViewPart Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewPart | Default constructor.


Legend

Legend
CXTPCalendarViewPartCustomizableValueT Constructors
Legend
Constructor


CXTPCalendarViewPartCustomizableValueT Constructors Public Methods

CXTPCalendarViewPartCustomizableValueT Constructors Public Methods
CXTPCalendarViewPartCustomizableValueT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewPartCustomizableValueT | Default object constructor.


Legend

Legend
CXTPCalendarViewPartFontValue Constructors
Legend
Constructor


CXTPCalendarViewPartFontValue Constructors Public Methods

CXTPCalendarViewPartFontValue Constructors Public Methods
CXTPCalendarViewPartFontValue Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewPartFontValue | Default constructor.


Legend

Legend
CXTPCalendarViewT Constructors
Legend
Constructor


CXTPCalendarViewT Constructors Public Methods

CXTPCalendarViewT Constructors Public Methods
CXTPCalendarViewT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarViewT | Default object constructor.


Legend

Legend
CXTPCalendarWeekView Constructors
Legend
Constructor


CXTPCalendarWeekView Constructors Public Methods

CXTPCalendarWeekView Constructors Public Methods
CXTPCalendarWeekView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWeekView | Default object constructor.


Legend

Legend
CXTPCalendarWeekViewDay Constructors
Legend
Constructor


CXTPCalendarWeekViewDay Constructors Public Methods

CXTPCalendarWeekViewDay Constructors Public Methods
CXTPCalendarWeekViewDay Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWeekViewDay | Default object constructor. Construct CXTPCalendarWeekViewDay object.


Legend

Legend
CXTPCalendarWeekViewEvent Constructors
Legend
Constructor


CXTPCalendarWeekViewEvent Constructors Public Methods

CXTPCalendarWeekViewEvent Constructors Public Methods
CXTPCalendarWeekViewEvent Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWeekViewEvent | Default object constructor.


Legend

Legend
CXTPCalendarWeekViewGroup Constructors
Legend
Constructor


CXTPCalendarWeekViewGroup Constructors Public Methods

CXTPCalendarWeekViewGroup Constructors Public Methods
CXTPCalendarWeekViewGroup Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWeekViewGroup | Default object constructor. Construct CXTPCalendarWeekViewGroup object.


Legend

Legend
CXTPCalendarWMHandler Constructors
Legend
Constructor


CXTPCalendarWMHandler Constructors Public Methods

CXTPCalendarWMHandler Constructors Public Methods
CXTPCalendarWMHandler Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCalendarWMHandler | Default object constructor.


Legend

Legend
CXTPClientCursorPos Constructors
Legend
Constructor


CXTPClientCursorPos Constructors Public Methods

CXTPClientCursorPos Constructors Public Methods
CXTPClientCursorPos Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPClientCursorPos | Constructs a CXTPClientCursorPos object used to retrieve the cursor position in client coordinates.


Legend

Legend
CXTPClientRect Constructors
Legend
Constructor


CXTPClientRect Constructors Public Methods

CXTPClientRect Constructors Public Methods
CXTPClientRect Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPClientRect |


Legend

Legend
CXTPCommandBar Constructors
Legend
Constructor
protected


CXTPCommandBar Constructors Protected Methods

CXTPCommandBar Constructors Protected Methods
CXTPCommandBar Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPCommandBar | Constructs a CXTPCommandBar object


Legend

Legend
CXTPCommandBarKeyboardTip Constructors
Legend
Constructor


CXTPCommandBarKeyboardTip Constructors Public Methods

CXTPCommandBarKeyboardTip Constructors Public Methods
CXTPCommandBarKeyboardTip Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarKeyboardTip | Constructs a CXTPCommandBarKeyboardTip object


Legend

Legend
CXTPCommandBarList Constructors
Legend
Constructor


CXTPCommandBarList Constructors Public Methods

CXTPCommandBarList Constructors Public Methods
CXTPCommandBarList Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarList | Constructs a CXTPCommandBarList object


Legend

Legend
CXTPCommandBars Constructors
Legend
Constructor
protected


CXTPCommandBars Constructors Protected Methods

CXTPCommandBars Constructors Protected Methods
CXTPCommandBars Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPCommandBars | Constructs a CXTPCommandBars object


Legend

Legend
CXTPCommandBarsContextMenus Constructors
Legend
Constructor


CXTPCommandBarsContextMenus Constructors Public Methods

CXTPCommandBarsContextMenus Constructors Public Methods
CXTPCommandBarsContextMenus Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarsContextMenus | Constructs a CXTPCommandBarsContextMenus object


Legend

Legend
CXTPCommandBarsOptions Constructors
Legend
Constructor


CXTPCommandBarsOptions Constructors Public Methods

CXTPCommandBarsOptions Constructors Public Methods
CXTPCommandBarsOptions Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarsOptions | Constructs an CXTPCommandBarsOptions object


Legend

Legend
CXTPCommandBarsSiteBase Constructors
Legend
Constructor


CXTPCommandBarsSiteBase Constructors Public Methods

CXTPCommandBarsSiteBase Constructors Public Methods
CXTPCommandBarsSiteBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCommandBarsSiteBase | Constructs a CXTPCommandBarsSiteBase object


Legend

Legend
CXTPCompatibleDC Constructors
Legend
Constructor


CXTPCompatibleDC Constructors Public Methods

CXTPCompatibleDC Constructors Public Methods
CXTPCompatibleDC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCompatibleDC |


Legend

Legend
CXTPControl Constructors
Legend
Constructor
protected


CXTPControl Constructors Protected Methods

CXTPControl Constructors Protected Methods
CXTPControl Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPControl | Constructs a CXTPControl object


Legend

Legend
CXTPControlAction Constructors
Legend
Constructor
protected


CXTPControlAction Constructors Protected Methods

CXTPControlAction Constructors Protected Methods
CXTPControlAction Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPControlAction | Constructs a CXTPControlAction object


Legend

Legend
CXTPControlActions Constructors
Legend
Constructor
protected


CXTPControlActions Constructors Protected Methods

CXTPControlActions Constructors Protected Methods
CXTPControlActions Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPControlActions | Constructs a CXTPControlActions object


Legend

Legend
CXTPControlButton Constructors
Legend
Constructor


CXTPControlButton Constructors Public Methods

CXTPControlButton Constructors Public Methods
CXTPControlButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlButton | Constructs a CXTPControlButton object


Legend

Legend
CXTPControlButtonColor Constructors
Legend
Constructor


CXTPControlButtonColor Constructors Public Methods

CXTPControlButtonColor Constructors Public Methods
CXTPControlButtonColor Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlButtonColor | Constructs a CXTPControlButtonColor object


Legend

Legend
CXTPControlCheckBox Constructors
Legend
Constructor


CXTPControlCheckBox Constructors Public Methods

CXTPControlCheckBox Constructors Public Methods
CXTPControlCheckBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlCheckBox | Constructs a CXTPControlCheckBox Object.


Legend

Legend
CXTPControlColorSelector Constructors
Legend
Constructor


CXTPControlColorSelector Constructors Public Methods

CXTPControlColorSelector Constructors Public Methods
CXTPControlColorSelector Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlColorSelector | Constructs a CXTPControlColorSelector object


Legend

Legend
CXTPControlComboBox Constructors
Legend
Constructor


CXTPControlComboBox Constructors Public Methods

CXTPControlComboBox Constructors Public Methods
CXTPControlComboBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlComboBox | Constructs a CXTPControlComboBox object


Legend

Legend
CXTPControlComboBoxList Constructors
Legend
Constructor


CXTPControlComboBoxList Constructors Public Methods

CXTPControlComboBoxList Constructors Public Methods
CXTPControlComboBoxList Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlComboBoxList | Constructs a CXTPControlButton object


Legend

Legend
CXTPControlComboBoxPopupBar Constructors
Legend
Constructor


CXTPControlComboBoxPopupBar Constructors Public Methods

CXTPControlComboBoxPopupBar Constructors Public Methods
CXTPControlComboBoxPopupBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlComboBoxPopupBar | Constructs a CXTPControlComboBoxPopupBar object


Legend

Legend
CXTPControlCustom Constructors
Legend
Constructor


CXTPControlCustom Constructors Public Methods

CXTPControlCustom Constructors Public Methods
CXTPControlCustom Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlCustom | Constructs a CXTPControlCustom object


Legend

Legend
CXTPControlEdit Constructors
Legend
Constructor


CXTPControlEdit Constructors Public Methods

CXTPControlEdit Constructors Public Methods
CXTPControlEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlEdit | Constructs a CXTPControlEdit object


Legend

Legend
CXTPControlFontComboBox Constructors
Legend
Constructor


CXTPControlFontComboBox Constructors Public Methods

CXTPControlFontComboBox Constructors Public Methods
CXTPControlFontComboBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlFontComboBox | Constructs a CXTPControlFontComboBox object


Legend

Legend
CXTPControlGallery Constructors
Legend
Constructor


CXTPControlGallery Constructors Public Methods

CXTPControlGallery Constructors Public Methods
CXTPControlGallery Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlGallery | Constructs a CXTPControlGallery object


Legend

Legend
CXTPControlGalleryItem Constructors
Legend
Constructor


CXTPControlGalleryItem Constructors Public Methods

CXTPControlGalleryItem Constructors Public Methods
CXTPControlGalleryItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlGalleryItem | Constructs a CXTPControlGalleryItem object


Legend

Legend
CXTPControlGalleryItems Constructors
Legend
Constructor
protected


CXTPControlGalleryItems Constructors Protected Methods

CXTPControlGalleryItems Constructors Protected Methods
CXTPControlGalleryItems Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPControlGalleryItems | Constructs a CXTPControlGalleryItems object.


Legend

Legend
CXTPControlGalleryPaintManager Constructors
Legend
Constructor


CXTPControlGalleryPaintManager Constructors Public Methods

CXTPControlGalleryPaintManager Constructors Public Methods
CXTPControlGalleryPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlGalleryPaintManager | Constructs a CXTPControlGalleryPaintManager object


Legend

Legend
CXTPControlLabel Constructors
Legend
Constructor


CXTPControlLabel Constructors Public Methods

CXTPControlLabel Constructors Public Methods
CXTPControlLabel Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlLabel | Constructs a CXTPControlLabel Object.


Legend

Legend
CXTPControlListBox Constructors
Legend
Constructor


CXTPControlListBox Constructors Public Methods

CXTPControlListBox Constructors Public Methods
CXTPControlListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlListBox | Constructs a CXTPControlListBox object


Legend

Legend
CXTPControlMarkupLabel Constructors
Legend
Constructor


CXTPControlMarkupLabel Constructors Public Methods

CXTPControlMarkupLabel Constructors Public Methods
CXTPControlMarkupLabel Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlMarkupLabel | Constructs a CXTPControlMarkupLabel Object.


Legend

Legend
CXTPControlPopup Constructors
Legend
Constructor


CXTPControlPopup Constructors Public Methods

CXTPControlPopup Constructors Public Methods
CXTPControlPopup Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlPopup | Constructs a CXTPControlPopup object


Legend

Legend
CXTPControlPopupColor Constructors
Legend
Constructor


CXTPControlPopupColor Constructors Public Methods

CXTPControlPopupColor Constructors Public Methods
CXTPControlPopupColor Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlPopupColor | Constructs a CXTPControlPopupColor object


Legend

Legend
CXTPControlRadioButton Constructors
Legend
Constructor


CXTPControlRadioButton Constructors Public Methods

CXTPControlRadioButton Constructors Public Methods
CXTPControlRadioButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlRadioButton | Constructs a CXTPControlRadioButton Object.


Legend

Legend
CXTPControls Constructors
Legend
Constructor


CXTPControls Constructors Public Methods

CXTPControls Constructors Public Methods
CXTPControls Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControls | Protected constructor used by dynamic creation


Legend

Legend
CXTPControlSelector Constructors
Legend
Constructor


CXTPControlSelector Constructors Public Methods

CXTPControlSelector Constructors Public Methods
CXTPControlSelector Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlSelector | Constructs a CXTPControlSelector object.


Legend

Legend
CXTPControlSizeComboBox Constructors
Legend
Constructor


CXTPControlSizeComboBox Constructors Public Methods

CXTPControlSizeComboBox Constructors Public Methods
CXTPControlSizeComboBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlSizeComboBox | Constructs a CXTPControlSizeComboBox object


Legend

Legend
CXTPControlStatic Constructors
Legend
Constructor


CXTPControlStatic Constructors Public Methods

CXTPControlStatic Constructors Public Methods
CXTPControlStatic Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlStatic | Constructs a CXTPControlStatic object


Legend

Legend
CXTPControlToolbars Constructors
Legend
Constructor


CXTPControlToolbars Constructors Public Methods

CXTPControlToolbars Constructors Public Methods
CXTPControlToolbars Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPControlToolbars | Constructs a CXTPControlToolbars object


Legend

Legend
CXTPCriticalSection Constructors
Legend
Constructor


CXTPCriticalSection Constructors Public Methods

CXTPCriticalSection Constructors Public Methods
CXTPCriticalSection Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCriticalSection | Constructs a CXTPCriticalSection object


Legend

Legend
CXTPCustomizeCommandsListBox Constructors
Legend
Constructor


CXTPCustomizeCommandsListBox Constructors Public Methods

CXTPCustomizeCommandsListBox Constructors Public Methods
CXTPCustomizeCommandsListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeCommandsListBox | Constructs a CXTPCustomizeCommandsListBox object


Legend

Legend
CXTPCustomizeCommandsPage Constructors
Legend
Constructor


CXTPCustomizeCommandsPage Constructors Public Methods

CXTPCustomizeCommandsPage Constructors Public Methods
CXTPCustomizeCommandsPage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeCommandsPage | Constructs a CXTPCustomizeCommandsPage object


Legend

Legend
CXTPCustomizeKeyboardPage Constructors
Legend
Constructor


CXTPCustomizeKeyboardPage Constructors Public Methods

CXTPCustomizeKeyboardPage Constructors Public Methods
CXTPCustomizeKeyboardPage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeKeyboardPage | Constructs a CXTPCustomizeKeyboardPage object


Legend

Legend
CXTPCustomizeOptionsPage Constructors
Legend
Constructor


CXTPCustomizeOptionsPage Constructors Public Methods

CXTPCustomizeOptionsPage Constructors Public Methods
CXTPCustomizeOptionsPage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeOptionsPage | Constructs a CXTPCustomizeOptionsPage object


Legend

Legend
CXTPCustomizeSheet Constructors
Legend
Constructor


CXTPCustomizeSheet Constructors Public Methods

CXTPCustomizeSheet Constructors Public Methods
CXTPCustomizeSheet Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeSheet | Constructs a CXTPCustomizeSheet object


Legend

Legend
CXTPCustomizeToolbarsPage Constructors
Legend
Constructor


CXTPCustomizeToolbarsPage Constructors Public Methods

CXTPCustomizeToolbarsPage Constructors Public Methods
CXTPCustomizeToolbarsPage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPCustomizeToolbarsPage | Constructs a CXTPCustomizeToolbarsPage object


Legend

Legend
CXTPDatePickerButton Constructors
Legend
Constructor


CXTPDatePickerButton Constructors Public Methods

CXTPDatePickerButton Constructors Public Methods
CXTPDatePickerButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerButton | Default button constructor.


Legend

Legend
CXTPDatePickerControl Constructors
Legend
Constructor


CXTPDatePickerControl Constructors Public Methods

CXTPDatePickerControl Constructors Public Methods
CXTPDatePickerControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerControl | Default constructor is used to construct a CXTPDatePickerControl object.


Legend

Legend
CXTPDatePickerDaysCollection Constructors
Legend
Constructor


CXTPDatePickerDaysCollection Constructors Public Methods

CXTPDatePickerDaysCollection Constructors Public Methods
CXTPDatePickerDaysCollection Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerDaysCollection | Default collection constructor.


Legend

Legend
CXTPDatePickerItemDay Constructors
Legend
Constructor


CXTPDatePickerItemDay Constructors Public Methods

CXTPDatePickerItemDay Constructors Public Methods
CXTPDatePickerItemDay Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerItemDay | Default collection constructor.


Legend

Legend
CXTPDatePickerItemMonth Constructors
Legend
Constructor


CXTPDatePickerItemMonth Constructors Public Methods

CXTPDatePickerItemMonth Constructors Public Methods
CXTPDatePickerItemMonth Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerItemMonth | Default CXTPDatePickerItemMonth object constructor.


Legend

Legend
CXTPDatePickerList Constructors
Legend
Constructor


CXTPDatePickerList Constructors Public Methods

CXTPDatePickerList Constructors Public Methods
CXTPDatePickerList Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerList | Constructs a CXTPDatePickerList object.


Legend

Legend
CXTPDatePickerPaintManager Constructors
Legend
Constructor


CXTPDatePickerPaintManager Constructors Public Methods

CXTPDatePickerPaintManager Constructors Public Methods
CXTPDatePickerPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDatePickerPaintManager | Default paint manager constructor.


Legend

Legend
CXTPDefaultTheme Constructors
Legend
Constructor


CXTPDefaultTheme Constructors Public Methods

CXTPDefaultTheme Constructors Public Methods
CXTPDefaultTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDefaultTheme | Constructs a CXTPDefaultTheme object.


Legend

Legend
CXTPDialog Constructors
Legend
Constructor


CXTPDialog Constructors Public Methods

CXTPDialog Constructors Public Methods
CXTPDialog Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDialog |


Legend

Legend
CXTPDialogBar Constructors
Legend
Constructor


CXTPDialogBar Constructors Public Methods

CXTPDialogBar Constructors Public Methods
CXTPDialogBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDialogBar | Constructs a CXTPDialogBar object


Legend

Legend
CXTPDialogBase Constructors
Legend
Constructor


CXTPDialogBase Constructors Public Methods

CXTPDialogBase Constructors Public Methods
CXTPDialogBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDialogBase |


Legend

Legend
CXTPDockBar Constructors
Legend
Constructor


CXTPDockBar Constructors Public Methods

CXTPDockBar Constructors Public Methods
CXTPDockBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockBar | Constructs a CXTPDockBar object


Legend

Legend
CXTPDockContext Constructors
Legend
Constructor


CXTPDockContext Constructors Public Methods

CXTPDockContext Constructors Public Methods
CXTPDockContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockContext | Constructs a CXTPDockContext object


Legend

Legend
CXTPDockingPane Constructors
Legend
Constructor
protected


CXTPDockingPane Constructors Protected Methods

CXTPDockingPane Constructors Protected Methods
CXTPDockingPane Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPane | Constructs a CXTPDockingPane object Protected constructor. Use CXTPDockingPaneManager::CreatePane() to create it.


Legend

Legend
CXTPDockingPaneAutoHidePanel Constructors
Legend
Constructor
protected


CXTPDockingPaneAutoHidePanel Constructors Protected Methods

CXTPDockingPaneAutoHidePanel Constructors Protected Methods
CXTPDockingPaneAutoHidePanel Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneAutoHidePanel | Constructs a CXTPDockingPaneAutoHidePanel object Protected constructor. Internally constructed only.


Legend

Legend
CXTPDockingPaneBase Constructors
Legend
Constructor
protected


CXTPDockingPaneBase Constructors Protected Methods

CXTPDockingPaneBase Constructors Protected Methods
CXTPDockingPaneBase Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneBase | Protected constructor. You cannot create this class.


Legend

Legend
CXTPDockingPaneBaseContainer Constructors
Legend
Constructor
protected


CXTPDockingPaneBaseContainer Constructors Protected Methods

CXTPDockingPaneBaseContainer Constructors Protected Methods
CXTPDockingPaneBaseContainer Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneBaseContainer | Protected constructor. You cannot create this class.


Legend

Legend
CXTPDockingPaneCaptionButton Constructors
Legend
Constructor


CXTPDockingPaneCaptionButton Constructors Public Methods

CXTPDockingPaneCaptionButton Constructors Public Methods
CXTPDockingPaneCaptionButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneCaptionButton | Constructs a CXTPDockingPaneCaptionButton object


Legend

Legend
CXTPDockingPaneContext Constructors
Legend
Constructor


CXTPDockingPaneContext Constructors Public Methods

CXTPDockingPaneContext Constructors Public Methods
CXTPDockingPaneContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneContext | Constructs a CXTPDockingPaneContext object


Legend

Legend
CXTPDockingPaneContextAlphaWnd Constructors
Legend
Constructor


CXTPDockingPaneContextAlphaWnd Constructors Public Methods

CXTPDockingPaneContextAlphaWnd Constructors Public Methods
CXTPDockingPaneContextAlphaWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneContextAlphaWnd | Constructs a CXTPDockingPaneContextAlphaWnd object.


Legend

Legend
CXTPDockingPaneContextStickerWnd Constructors
Legend
Constructor


CXTPDockingPaneContextStickerWnd Constructors Public Methods

CXTPDockingPaneContextStickerWnd Constructors Public Methods
CXTPDockingPaneContextStickerWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneContextStickerWnd | Constructs a CXTPDockingPaneContextStickerWnd object.


Legend

Legend
CXTPDockingPaneDefaultTheme Constructors
Legend
Constructor


CXTPDockingPaneDefaultTheme Constructors Public Methods

CXTPDockingPaneDefaultTheme Constructors Public Methods
CXTPDockingPaneDefaultTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneDefaultTheme | Constructs a CXTPDockingPaneDefaultTheme object.


Legend

Legend
CXTPDockingPaneExplorerTheme Constructors
Legend
Constructor


CXTPDockingPaneExplorerTheme Constructors Public Methods

CXTPDockingPaneExplorerTheme Constructors Public Methods
CXTPDockingPaneExplorerTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneExplorerTheme | Constructs a CXTPDockingPaneExplorerTheme object.


Legend

Legend
CXTPDockingPaneGripperedTheme Constructors
Legend
Constructor


CXTPDockingPaneGripperedTheme Constructors Public Methods

CXTPDockingPaneGripperedTheme Constructors Public Methods
CXTPDockingPaneGripperedTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneGripperedTheme | Constructs a CXTPDockingPaneGripperedTheme object.


Legend

Legend
CXTPDockingPaneLayout Constructors
Legend
Constructor


CXTPDockingPaneLayout Constructors Public Methods

CXTPDockingPaneLayout Constructors Public Methods
CXTPDockingPaneLayout Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneLayout | Constructs a CXTPDockingPaneLayout object.


Legend

Legend
CXTPDockingPaneManager Constructors
Legend
Constructor


CXTPDockingPaneManager Constructors Public Methods

CXTPDockingPaneManager Constructors Public Methods
CXTPDockingPaneManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneManager | Constructs a CXTPDockingPaneManager object


Legend

Legend
CXTPDockingPaneMiniWnd Constructors
Legend
Constructor
protected


CXTPDockingPaneMiniWnd Constructors Protected Methods

CXTPDockingPaneMiniWnd Constructors Protected Methods
CXTPDockingPaneMiniWnd Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneMiniWnd | Constructs a CXTPDockingPaneMiniWnd object.


Legend

Legend
CXTPDockingPaneNativeXPTheme Constructors
Legend
Constructor


CXTPDockingPaneNativeXPTheme Constructors Public Methods

CXTPDockingPaneNativeXPTheme Constructors Public Methods
CXTPDockingPaneNativeXPTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneNativeXPTheme | Constructs a CXTPDockingPaneNativeXPTheme object.


Legend

Legend
CXTPDockingPaneOffice2003Theme Constructors
Legend
Constructor


CXTPDockingPaneOffice2003Theme Constructors Public Methods

CXTPDockingPaneOffice2003Theme Constructors Public Methods
CXTPDockingPaneOffice2003Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneOffice2003Theme | Constructs a CXTPDockingPaneOffice2003Theme object.


Legend

Legend
CXTPDockingPaneOffice2007Theme Constructors
Legend
Constructor


CXTPDockingPaneOffice2007Theme Constructors Public Methods

CXTPDockingPaneOffice2007Theme Constructors Public Methods
CXTPDockingPaneOffice2007Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneOffice2007Theme | Constructs a CXTPDockingPaneOffice2007Theme object.


Legend

Legend
CXTPDockingPaneOfficeTheme Constructors
Legend
Constructor


CXTPDockingPaneOfficeTheme Constructors Public Methods

CXTPDockingPaneOfficeTheme Constructors Public Methods
CXTPDockingPaneOfficeTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneOfficeTheme | Constructs a CXTPDockingPaneOfficeTheme object.


Legend

Legend
CXTPDockingPanePaintManager Constructors
Legend
Constructor
protected


CXTPDockingPanePaintManager Constructors Protected Methods

CXTPDockingPanePaintManager Constructors Protected Methods
CXTPDockingPanePaintManager Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPanePaintManager | Constructs a CXTPDockingPanePaintManager object


Legend

Legend
CXTPDockingPaneShortcutBar2003Theme Constructors
Legend
Constructor


CXTPDockingPaneShortcutBar2003Theme Constructors Public Methods

CXTPDockingPaneShortcutBar2003Theme Constructors Public Methods
CXTPDockingPaneShortcutBar2003Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneShortcutBar2003Theme | Constructs a CXTPDockingPaneShortcutBar2003Theme object.


Legend

Legend
CXTPDockingPaneSplitterContainer Constructors
Legend
Constructor
protected


CXTPDockingPaneSplitterContainer Constructors Protected Methods

CXTPDockingPaneSplitterContainer Constructors Protected Methods
CXTPDockingPaneSplitterContainer Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneSplitterContainer | Constructs a CXTPDockingPaneSplitterContainer object.


Legend

Legend
CXTPDockingPaneSplitterWnd Constructors
Legend
Constructor
protected


CXTPDockingPaneSplitterWnd Constructors Protected Methods

CXTPDockingPaneSplitterWnd Constructors Protected Methods
CXTPDockingPaneSplitterWnd Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneSplitterWnd | Constructs a CXTPDockingPaneSplitterWnd object


Legend

Legend
CXTPDockingPaneTabbedContainer Constructors
Legend
Constructor
protected


CXTPDockingPaneTabbedContainer Constructors Protected Methods

CXTPDockingPaneTabbedContainer Constructors Protected Methods
CXTPDockingPaneTabbedContainer Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPDockingPaneTabbedContainer | Constructs a CXTPDockingPaneTabbedContainer object Protected constructor. Internally constructed only.


Legend

Legend
CXTPDockingPaneVisioTheme Constructors
Legend
Constructor


CXTPDockingPaneVisioTheme Constructors Public Methods

CXTPDockingPaneVisioTheme Constructors Public Methods
CXTPDockingPaneVisioTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneVisioTheme | Constructs a CXTPDockingPaneVisioTheme object.


Legend

Legend
CXTPDockingPaneVisualStudio2005SecondTheme Constructors
Legend
Constructor


CXTPDockingPaneVisualStudio2005SecondTheme Constructors Public Methods

CXTPDockingPaneVisualStudio2005SecondTheme Constructors Public Methods
CXTPDockingPaneVisualStudio2005SecondTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneVisualStudio2005SecondTheme | Constructs a CXTPDockingPaneVisualStudio2005SecondTheme object.


Legend

Legend
CXTPDockingPaneVisualStudio2005Theme Constructors
Legend
Constructor


CXTPDockingPaneVisualStudio2005Theme Constructors Public Methods

CXTPDockingPaneVisualStudio2005Theme Constructors Public Methods
CXTPDockingPaneVisualStudio2005Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneVisualStudio2005Theme | Constructs a CXTPDockingPaneVisualStudio2005Theme object.


Legend

Legend
CXTPDockingPaneWhidbeyTheme Constructors
Legend
Constructor


CXTPDockingPaneWhidbeyTheme Constructors Public Methods

CXTPDockingPaneWhidbeyTheme Constructors Public Methods
CXTPDockingPaneWhidbeyTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneWhidbeyTheme | Constructs a CXTPDockingPaneWhidbeyTheme object.


Legend

Legend
CXTPDockingPaneWord2007Theme Constructors
Legend
Constructor


CXTPDockingPaneWord2007Theme Constructors Public Methods

CXTPDockingPaneWord2007Theme Constructors Public Methods
CXTPDockingPaneWord2007Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockingPaneWord2007Theme | Constructs a CXTPDockingPaneWord2007Theme object.


Legend

Legend
CXTPDockState Constructors
Legend
Constructor


CXTPDockState Constructors Public Methods

CXTPDockState Constructors Public Methods
CXTPDockState Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDockState | Constructs a CXTPDockState object.


Legend

Legend
CXTPDrawHelpers Constructors
Legend
Constructor


CXTPDrawHelpers Constructors Public Methods

CXTPDrawHelpers Constructors Public Methods
CXTPDrawHelpers Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPDrawHelpers | Constructs a CXTPDrawHelpers object.


Legend

Legend
CXTPEdit Constructors
Legend
Constructor


CXTPEdit Constructors Public Methods

CXTPEdit Constructors Public Methods
CXTPEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPEdit | Constructs a CXTPEdit object


Legend

Legend
CXTPEmptyRect Constructors
Legend
Constructor


CXTPEmptyRect Constructors Public Methods

CXTPEmptyRect Constructors Public Methods
CXTPEmptyRect Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPEmptyRect | Constructs a CXTPEmptyRect object used to instantiate an empty CRect object.


Legend

Legend
CXTPEmptySize Constructors
Legend
Constructor


CXTPEmptySize Constructors Public Methods

CXTPEmptySize Constructors Public Methods
CXTPEmptySize Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPEmptySize | Constructs a CXTPEmptySize object used to instantiate an empty CSize object.


Legend

Legend
CXTPFontDC Constructors
Legend
Constructor


CXTPFontDC Constructors Public Methods

CXTPFontDC Constructors Public Methods
CXTPFontDC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPFontDC |


Legend

Legend
CXTPFormulaMulDivC Constructors
Legend
Constructor


CXTPFormulaMulDivC Constructors Public Methods

CXTPFormulaMulDivC Constructors Public Methods
CXTPFormulaMulDivC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPFormulaMulDivC | Default object constructor.


Legend

Legend
CXTPFrameWnd Constructors
Legend
Constructor


CXTPFrameWnd Constructors Public Methods

CXTPFrameWnd Constructors Public Methods
CXTPFrameWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPFrameWnd | Constructs a CXTPFrameWnd object


Legend

Legend
CXTPFrameWndBase Constructors
Legend
Constructor


CXTPFrameWndBase Constructors Public Methods

CXTPFrameWndBase Constructors Public Methods
CXTPFrameWndBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPFrameWndBase | Constructs a CXTPFrameWndBase object


Legend

Legend
CXTPGroupLine Constructors
Legend
Constructor


CXTPGroupLine Constructors Public Methods

CXTPGroupLine Constructors Public Methods
CXTPGroupLine Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPGroupLine | Constructs a CXTPGroupLine object


Legend

Legend
CXTPImageEditorDlg Constructors
Legend
Constructor


CXTPImageEditorDlg Constructors Public Methods

CXTPImageEditorDlg Constructors Public Methods
CXTPImageEditorDlg Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageEditorDlg | Constructs a CXTPImageEditorDlg object


Legend

Legend
CXTPImageManager Constructors
Legend
Constructor


CXTPImageManager Constructors Public Methods

CXTPImageManager Constructors Public Methods
CXTPImageManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageManager | Constructs a CXTPImageManager object.


Legend

Legend
CXTPImageManagerIcon Constructors
Legend
Constructor


CXTPImageManagerIcon Constructors Public Methods

CXTPImageManagerIcon Constructors Public Methods
CXTPImageManagerIcon Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageManagerIcon |


Legend

Legend
CXTPImageManagerIconHandle Constructors
Legend
Constructor


CXTPImageManagerIconHandle Constructors Public Methods

CXTPImageManagerIconHandle Constructors Public Methods
CXTPImageManagerIconHandle Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageManagerIconHandle |


Legend

Legend
CXTPImageManagerIconSet Constructors
Legend
Constructor


CXTPImageManagerIconSet Constructors Public Methods

CXTPImageManagerIconSet Constructors Public Methods
CXTPImageManagerIconSet Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPImageManagerIconSet | Constructs a CXTPImageManagerIconSet object.


Legend

Legend
CXTPLockGuard Constructors
Legend
Constructor


CXTPLockGuard Constructors Public Methods

CXTPLockGuard Constructors Public Methods
CXTPLockGuard Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPLockGuard | Constructs a CXTPLockGuard object


Legend

Legend
CXTPMDIFrameWnd Constructors
Legend
Constructor


CXTPMDIFrameWnd Constructors Public Methods

CXTPMDIFrameWnd Constructors Public Methods
CXTPMDIFrameWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPMDIFrameWnd | Constructs a CXTPMDIFrameWnd object


Legend

Legend
CXTPMenuBar Constructors
Legend
Constructor


CXTPMenuBar Constructors Public Methods

CXTPMenuBar Constructors Public Methods
CXTPMenuBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPMenuBar | Constructs a CXTPMenuBar object


Legend

Legend
CXTPMenuBarMDIMenus Constructors
Legend
Constructor


CXTPMenuBarMDIMenus Constructors Public Methods

CXTPMenuBarMDIMenus Constructors Public Methods
CXTPMenuBarMDIMenus Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPMenuBarMDIMenus | Constructs a CXTPMenuBarMDIMenus object.


Legend

Legend
CXTPModuleHandle Constructors
Legend
Constructor


CXTPModuleHandle Constructors Public Methods

CXTPModuleHandle Constructors Public Methods
CXTPModuleHandle Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPModuleHandle |


Legend

Legend
CXTPMouseManager Constructors
Legend
Constructor


CXTPMouseManager Constructors Public Methods

CXTPMouseManager Constructors Public Methods
CXTPMouseManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPMouseManager | Constructs a CXTPMouseManager object


Legend

Legend
CXTPNativeXPTheme Constructors
Legend
Constructor


CXTPNativeXPTheme Constructors Public Methods

CXTPNativeXPTheme Constructors Public Methods
CXTPNativeXPTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPNativeXPTheme | Constructs a CXTPNativeXPTheme object.


Legend

Legend
CXTPNewToolbarDlg Constructors
Legend
Constructor


CXTPNewToolbarDlg Constructors Public Methods

CXTPNewToolbarDlg Constructors Public Methods
CXTPNewToolbarDlg Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPNewToolbarDlg | Constructs a CXTPNewToolbarDlg object.


Legend

Legend
CXTPNoFlickerWnd Constructors
Legend
Constructor


CXTPNoFlickerWnd Constructors Public Methods

CXTPNoFlickerWnd Constructors Public Methods
CXTPNoFlickerWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPNoFlickerWnd | Constructs a CXTPNoFlickerWnd object.


Legend

Legend
CXTPOffice2007Theme Constructors
Legend
Constructor


CXTPOffice2007Theme Constructors Public Methods

CXTPOffice2007Theme Constructors Public Methods
CXTPOffice2007Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPOffice2007Theme | Constructs a CXTPOffice2007Theme object.


Legend

Legend
CXTPOfficeTheme Constructors
Legend
Constructor


CXTPOfficeTheme Constructors Public Methods

CXTPOfficeTheme Constructors Public Methods
CXTPOfficeTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPOfficeTheme | Constructs a CXTPOfficeTheme object.


Legend

Legend
CXTPPaintManager Constructors
Legend
Constructor
protected


CXTPPaintManager Constructors Protected Methods

CXTPPaintManager Constructors Protected Methods
CXTPPaintManager Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPPaintManager | Constructs a CXTPPaintManager object


Legend

Legend
CLogFont Constructors
Legend
Constructor


CLogFont Constructors Public Methods

CLogFont Constructors Public Methods
CLogFont Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CLogFont | Constructs an CLogFont object.


Legend

Legend
CNonClientMetrics Constructors
Legend
Constructor


CNonClientMetrics Constructors Public Methods

CNonClientMetrics Constructors Public Methods
CNonClientMetrics Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CNonClientMetrics | Constructs a CNonClientMetrics object


Legend

Legend
CXTPPaintManagerColor Constructors
Legend
Constructor


CXTPPaintManagerColor Constructors Public Methods

CXTPPaintManagerColor Constructors Public Methods
CXTPPaintManagerColor Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPaintManagerColor |


Legend

Legend
CXTPPaintManagerColorGradient Constructors
Legend
Constructor


CXTPPaintManagerColorGradient Constructors Public Methods

CXTPPaintManagerColorGradient Constructors Public Methods
CXTPPaintManagerColorGradient Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPaintManagerColorGradient |


Legend

Legend
CXTPPaintManagerFont Constructors
Legend
Constructor


CXTPPaintManagerFont Constructors Public Methods

CXTPPaintManagerFont Constructors Public Methods
CXTPPaintManagerFont Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPaintManagerFont | Constructs a CXTPPaintManagerFont object.


Legend

Legend
CXTPPenDC Constructors
Legend
Constructor


CXTPPenDC Constructors Public Methods

CXTPPenDC Constructors Public Methods
CXTPPenDC Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPenDC |


Legend

Legend
CXTPPopupBar Constructors
Legend
Constructor
protected


CXTPPopupBar Constructors Protected Methods

CXTPPopupBar Constructors Protected Methods
CXTPPopupBar Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPPopupBar | Constructs a CXTPPopupBar object


Legend

Legend
CXTPPopupControl Constructors
Legend
Constructor


CXTPPopupControl Constructors Public Methods

CXTPPopupControl Constructors Public Methods
CXTPPopupControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupControl | Constructs a CXTPPopupControl object.


Legend

Legend
CXTPPopupItem Constructors
Legend
Constructor


CXTPPopupItem Constructors Public Methods

CXTPPopupItem Constructors Public Methods
CXTPPopupItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupItem | Constructs a CXTPPopupItem object.


Legend

Legend
CXTPPopupPaintManager Constructors
Legend
Constructor


CXTPPopupPaintManager Constructors Public Methods

CXTPPopupPaintManager Constructors Public Methods
CXTPPopupPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupPaintManager | Constructs a CXTPPopupPaintManager object.


Legend

Legend
CXTPPopupThemeMSN Constructors
Legend
Constructor


CXTPPopupThemeMSN Constructors Public Methods

CXTPPopupThemeMSN Constructors Public Methods
CXTPPopupThemeMSN Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeMSN | Constructs a CXTPPopupThemeMSN object.


Legend

Legend
CXTPPopupThemeOffice2000 Constructors
Legend
Constructor


CXTPPopupThemeOffice2000 Constructors Public Methods

CXTPPopupThemeOffice2000 Constructors Public Methods
CXTPPopupThemeOffice2000 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeOffice2000 | Constructs a CXTPPopupThemeOffice2000 object.


Legend

Legend
CXTPPopupThemeOffice2003 Constructors
Legend
Constructor


CXTPPopupThemeOffice2003 Constructors Public Methods

CXTPPopupThemeOffice2003 Constructors Public Methods
CXTPPopupThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeOffice2003 | Constructs a CXTPPopupThemeOffice2003 object.


Legend

Legend
CXTPPopupThemeOffice2007 Constructors
Legend
Constructor


CXTPPopupThemeOffice2007 Constructors Public Methods

CXTPPopupThemeOffice2007 Constructors Public Methods
CXTPPopupThemeOffice2007 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeOffice2007 | Constructs a CXTPPopupThemeOffice2003 object.


Legend

Legend
CXTPPopupThemeOfficeXP Constructors
Legend
Constructor


CXTPPopupThemeOfficeXP Constructors Public Methods

CXTPPopupThemeOfficeXP Constructors Public Methods
CXTPPopupThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPopupThemeOfficeXP | Constructs a CXTPPopupThemeOfficeXP object.


Legend

Legend
CXTPPrinterInfo Constructors
Legend
Constructor


CXTPPrinterInfo Constructors Public Methods

CXTPPrinterInfo Constructors Public Methods
CXTPPrinterInfo Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPrinterInfo | Default object constructor.


Legend

Legend
CXTPPrintOptions Constructors
Legend
Constructor


CXTPPrintOptions Constructors Public Methods

CXTPPrintOptions Constructors Public Methods
CXTPPrintOptions Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPrintOptions | Default Object constructor.


Legend

Legend
CXTPPrintPageHeaderFooter Constructors
Legend
Constructor


CXTPPrintPageHeaderFooter Constructors Public Methods

CXTPPrintPageHeaderFooter Constructors Public Methods
CXTPPrintPageHeaderFooter Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPrintPageHeaderFooter | Object constructor.


Legend

Legend
CXTPPropertyGrid Constructors
Legend
Constructor


CXTPPropertyGrid Constructors Public Methods

CXTPPropertyGrid Constructors Public Methods
CXTPPropertyGrid Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGrid | Constructs a CXTPPropertyGrid object


Legend

Legend
CXTPPropertyGridCoolTheme Constructors
Legend
Constructor


CXTPPropertyGridCoolTheme Constructors Public Methods

CXTPPropertyGridCoolTheme Constructors Public Methods
CXTPPropertyGridCoolTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridCoolTheme | Constructs a CXTPPropertyGridCoolTheme object.


Legend

Legend
CXTPPropertyGridDelphiTheme Constructors
Legend
Constructor


CXTPPropertyGridDelphiTheme Constructors Public Methods

CXTPPropertyGridDelphiTheme Constructors Public Methods
CXTPPropertyGridDelphiTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridDelphiTheme | Constructs a CXTPPropertyGridDelphiTheme object.


Legend

Legend
CXTPPropertyGridInplaceButton Constructors
Legend
Constructor


CXTPPropertyGridInplaceButton Constructors Public Methods

CXTPPropertyGridInplaceButton Constructors Public Methods
CXTPPropertyGridInplaceButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceButton | Constructs a CXTPPropertyGridInplaceButton object


Legend

Legend
CXTPPropertyGridInplaceButtons Constructors
Legend
Constructor


CXTPPropertyGridInplaceButtons Constructors Public Methods

CXTPPropertyGridInplaceButtons Constructors Public Methods
CXTPPropertyGridInplaceButtons Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceButtons | Constructs a CXTPPropertyGridInplaceButtons object


Legend

Legend
CXTPPropertyGridInplaceControl Constructors
Legend
Constructor


CXTPPropertyGridInplaceControl Constructors Public Methods

CXTPPropertyGridInplaceControl Constructors Public Methods
CXTPPropertyGridInplaceControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceControl | Constructs a CXTPPropertyGridInplaceControl object


Legend

Legend
CXTPPropertyGridInplaceControls Constructors
Legend
Constructor


CXTPPropertyGridInplaceControls Constructors Public Methods

CXTPPropertyGridInplaceControls Constructors Public Methods
CXTPPropertyGridInplaceControls Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceControls | Constructs a CXTPPropertyGridInplaceControls object


Legend

Legend
CXTPPropertyGridInplaceEdit Constructors
Legend
Constructor


CXTPPropertyGridInplaceEdit Constructors Public Methods

CXTPPropertyGridInplaceEdit Constructors Public Methods
CXTPPropertyGridInplaceEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceEdit | Constructs a CXTPPropertyGridInplaceEdit object


Legend

Legend
CXTPPropertyGridInplaceList Constructors
Legend
Constructor


CXTPPropertyGridInplaceList Constructors Public Methods

CXTPPropertyGridInplaceList Constructors Public Methods
CXTPPropertyGridInplaceList Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceList | Constructs a CXTPPropertyGridInplaceList object


Legend

Legend
CXTPPropertyGridInplaceMonthCal Constructors
Legend
Constructor


CXTPPropertyGridInplaceMonthCal Constructors Public Methods

CXTPPropertyGridInplaceMonthCal Constructors Public Methods
CXTPPropertyGridInplaceMonthCal Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceMonthCal | Constructs a CXTPPropertyGridInplaceMonthCal object.


Legend

Legend
CXTPPropertyGridInplaceMultilineEdit Constructors
Legend
Constructor


CXTPPropertyGridInplaceMultilineEdit Constructors Public Methods

CXTPPropertyGridInplaceMultilineEdit Constructors Public Methods
CXTPPropertyGridInplaceMultilineEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceMultilineEdit | Constructs a CXTPPropertyGridInplaceList object


Legend

Legend
CXTPPropertyGridInplaceSlider Constructors
Legend
Constructor


CXTPPropertyGridInplaceSlider Constructors Public Methods

CXTPPropertyGridInplaceSlider Constructors Public Methods
CXTPPropertyGridInplaceSlider Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceSlider | Constructs a CXTPPropertyGridInplaceSlider object


Legend

Legend
CXTPPropertyGridInplaceSpinButton Constructors
Legend
Constructor


CXTPPropertyGridInplaceSpinButton Constructors Public Methods

CXTPPropertyGridInplaceSpinButton Constructors Public Methods
CXTPPropertyGridInplaceSpinButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridInplaceSpinButton | Constructs a CXTPPropertyGridInplaceSpinButton object


Legend

Legend
CXTPPropertyGridItem Constructors
Legend
Constructor


CXTPPropertyGridItem Constructors Public Methods

CXTPPropertyGridItem Constructors Public Methods
CXTPPropertyGridItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItem |


Legend

Legend
CXTPPropertyGridItemBool Constructors
Legend
Constructor


CXTPPropertyGridItemBool Constructors Public Methods

CXTPPropertyGridItemBool Constructors Public Methods
CXTPPropertyGridItemBool Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemBool |


Legend

Legend
CXTPPropertyGridItemCategory Constructors
Legend
Constructor


CXTPPropertyGridItemCategory Constructors Public Methods

CXTPPropertyGridItemCategory Constructors Public Methods
CXTPPropertyGridItemCategory Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemCategory |


Legend

Legend
CXTPPropertyGridItemColor Constructors
Legend
Constructor


CXTPPropertyGridItemColor Constructors Public Methods

CXTPPropertyGridItemColor Constructors Public Methods
CXTPPropertyGridItemColor Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemColor |


Legend

Legend
CXTPPropertyGridItemConstraint Constructors
Legend
Constructor


CXTPPropertyGridItemConstraint Constructors Public Methods

CXTPPropertyGridItemConstraint Constructors Public Methods
CXTPPropertyGridItemConstraint Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemConstraint | Constructs a CXTPPropertyGridItemConstraint object.


Legend

Legend
CXTPPropertyGridItemConstraints Constructors
Legend
Constructor
protected


CXTPPropertyGridItemConstraints Constructors Protected Methods

CXTPPropertyGridItemConstraints Constructors Protected Methods
CXTPPropertyGridItemConstraints Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPPropertyGridItemConstraints | Constructs a CXTPPropertyGridItemConstraints object.


Legend

Legend
CXTPPropertyGridItemDate Constructors
Legend
Constructor


CXTPPropertyGridItemDate Constructors Public Methods

CXTPPropertyGridItemDate Constructors Public Methods
CXTPPropertyGridItemDate Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemDate |


Legend

Legend
CXTPPropertyGridItemDouble Constructors
Legend
Constructor


CXTPPropertyGridItemDouble Constructors Public Methods

CXTPPropertyGridItemDouble Constructors Public Methods
CXTPPropertyGridItemDouble Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemDouble |


Legend

Legend
CXTPPropertyGridItemEnum Constructors
Legend
Constructor


CXTPPropertyGridItemEnum Constructors Public Methods

CXTPPropertyGridItemEnum Constructors Public Methods
CXTPPropertyGridItemEnum Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemEnum |


Legend

Legend
CXTPPropertyGridItemFlags Constructors
Legend
Constructor


CXTPPropertyGridItemFlags Constructors Public Methods

CXTPPropertyGridItemFlags Constructors Public Methods
CXTPPropertyGridItemFlags Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemFlags |


Legend

Legend
CXTPPropertyGridItemFont Constructors
Legend
Constructor


CXTPPropertyGridItemFont Constructors Public Methods

CXTPPropertyGridItemFont Constructors Public Methods
CXTPPropertyGridItemFont Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemFont |


Legend

Legend
CXTPPropertyGridItemMetrics Constructors
Legend
Constructor


CXTPPropertyGridItemMetrics Constructors Public Methods

CXTPPropertyGridItemMetrics Constructors Public Methods
CXTPPropertyGridItemMetrics Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemMetrics | Constructs a CXTPPropertyGridItemMetrics object.


Legend

Legend
CXTPPropertyGridItemNumber Constructors
Legend
Constructor


CXTPPropertyGridItemNumber Constructors Public Methods

CXTPPropertyGridItemNumber Constructors Public Methods
CXTPPropertyGridItemNumber Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemNumber |


Legend

Legend
CXTPPropertyGridItems Constructors
Legend
Constructor
protected


CXTPPropertyGridItems Constructors Protected Methods

CXTPPropertyGridItems Constructors Protected Methods
CXTPPropertyGridItems Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPPropertyGridItems | Constructs a CXTPPropertyGridItems object.


Legend

Legend
CXTPPropertyGridItemSize Constructors
Legend
Constructor


CXTPPropertyGridItemSize Constructors Public Methods

CXTPPropertyGridItemSize Constructors Public Methods
CXTPPropertyGridItemSize Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridItemSize |


Legend

Legend
CXTPPropertyGridNativeXPTheme Constructors
Legend
Constructor


CXTPPropertyGridNativeXPTheme Constructors Public Methods

CXTPPropertyGridNativeXPTheme Constructors Public Methods
CXTPPropertyGridNativeXPTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridNativeXPTheme | Constructs a CXTPPropertyGridNativeXPTheme object.


Legend

Legend
CXTPPropertyGridOffice2003Theme Constructors
Legend
Constructor


CXTPPropertyGridOffice2003Theme Constructors Public Methods

CXTPPropertyGridOffice2003Theme Constructors Public Methods
CXTPPropertyGridOffice2003Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridOffice2003Theme | Constructs a CXTPPropertyGridOffice2003Theme object.


Legend

Legend
CXTPPropertyGridOfficeXPTheme Constructors
Legend
Constructor


CXTPPropertyGridOfficeXPTheme Constructors Public Methods

CXTPPropertyGridOfficeXPTheme Constructors Public Methods
CXTPPropertyGridOfficeXPTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridOfficeXPTheme | Constructs a CXTPPropertyGridOfficeXPTheme object.


Legend

Legend
CXTPPropertyGridPaintManager Constructors
Legend
Constructor


CXTPPropertyGridPaintManager Constructors Public Methods

CXTPPropertyGridPaintManager Constructors Public Methods
CXTPPropertyGridPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridPaintManager | Constructs a CXTPPropertyGridPaintManager object.


Legend

Legend
CXTPPropertyGridSimpleTheme Constructors
Legend
Constructor


CXTPPropertyGridSimpleTheme Constructors Public Methods

CXTPPropertyGridSimpleTheme Constructors Public Methods
CXTPPropertyGridSimpleTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridSimpleTheme | Constructs a CXTPPropertyGridSimpleTheme object.


Legend

Legend
CXTPPropertyGridToolBar Constructors
Legend
Constructor


CXTPPropertyGridToolBar Constructors Public Methods

CXTPPropertyGridToolBar Constructors Public Methods
CXTPPropertyGridToolBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridToolBar | Constructs a CXTPPropertyGridToolBar object


Legend

Legend
CXTPPropertyGridToolTip Constructors
Legend
Constructor


CXTPPropertyGridToolTip Constructors Public Methods

CXTPPropertyGridToolTip Constructors Public Methods
CXTPPropertyGridToolTip Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridToolTip | Constructs a CXTPPropertyGridToolTip object


Legend

Legend
CXTPPropertyGridUpdateContext Constructors
Legend
Constructor


CXTPPropertyGridUpdateContext Constructors Public Methods

CXTPPropertyGridUpdateContext Constructors Public Methods
CXTPPropertyGridUpdateContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridUpdateContext | Constructs a CXTPPropertyGridUpdateContext object.


Legend

Legend
CXTPPropertyGridVerb Constructors
Legend
Constructor


CXTPPropertyGridVerb Constructors Public Methods

CXTPPropertyGridVerb Constructors Public Methods
CXTPPropertyGridVerb Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridVerb | Constructs a CXTPPropertyGridVerb object.


Legend

Legend
CXTPPropertyGridVerbs Constructors
Legend
Constructor


CXTPPropertyGridVerbs Constructors Public Methods

CXTPPropertyGridVerbs Constructors Public Methods
CXTPPropertyGridVerbs Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridVerbs | Constructs a CXTPPropertyGridVerbs object.


Legend

Legend
CXTPPropertyGridView Constructors
Legend
Constructor


CXTPPropertyGridView Constructors Public Methods

CXTPPropertyGridView Constructors Public Methods
CXTPPropertyGridView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridView | Constructs a CXTPPropertyGridView object


Legend

Legend
CXTPPropertyGridWhidbeyTheme Constructors
Legend
Constructor


CXTPPropertyGridWhidbeyTheme Constructors Public Methods

CXTPPropertyGridWhidbeyTheme Constructors Public Methods
CXTPPropertyGridWhidbeyTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyGridWhidbeyTheme | Constructs a CXTPPropertyGridWhidbeyTheme object.


Legend

Legend
CXTPPropertyPage Constructors
Legend
Constructor


CXTPPropertyPage Constructors Public Methods

CXTPPropertyPage Constructors Public Methods
CXTPPropertyPage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPage |


Legend

Legend
CXTPPropertyPageControlNavigator Constructors
Legend
Constructor


CXTPPropertyPageControlNavigator Constructors Public Methods

CXTPPropertyPageControlNavigator Constructors Public Methods
CXTPPropertyPageControlNavigator Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageControlNavigator | Constructs a CXTPPropertyPageControlNavigator object.


Legend

Legend
CXTPPropertyPageListNavigator Constructors
Legend
Constructor


CXTPPropertyPageListNavigator Constructors Public Methods

CXTPPropertyPageListNavigator Constructors Public Methods
CXTPPropertyPageListNavigator Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageListNavigator | Constructs a CXTPPropertyPageListNavigator object.


Legend

Legend
CXTPPropertyPageNavigator Constructors
Legend
Constructor


CXTPPropertyPageNavigator Constructors Public Methods

CXTPPropertyPageNavigator Constructors Public Methods
CXTPPropertyPageNavigator Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageNavigator | Constructs a CXTPPropertyPageNavigator object.


Legend

Legend
CXTPPropertyPageTabNavigator Constructors
Legend
Constructor


CXTPPropertyPageTabNavigator Constructors Public Methods

CXTPPropertyPageTabNavigator Constructors Public Methods
CXTPPropertyPageTabNavigator Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageTabNavigator | Constructs a CXTPPropertyPageTabNavigator object.


Legend

Legend
CXTPPropertyPageTreeNavigator Constructors
Legend
Constructor


CXTPPropertyPageTreeNavigator Constructors Public Methods

CXTPPropertyPageTreeNavigator Constructors Public Methods
CXTPPropertyPageTreeNavigator Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertyPageTreeNavigator | Constructs a CXTPPropertyPageTreeNavigator object.


Legend

Legend
CXTPPropertySheet Constructors
Legend
Constructor


CXTPPropertySheet Constructors Public Methods

CXTPPropertySheet Constructors Public Methods
CXTPPropertySheet Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropertySheet |


Legend

Legend
CXTPPropExchange Constructors
Legend
Constructor


CXTPPropExchange Constructors Public Methods

CXTPPropExchange Constructors Public Methods
CXTPPropExchange Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchange | Constructs a CXTPPropExchange object.


Legend

Legend
CXTPPropExchangeArchive Constructors
Legend
Constructor


CXTPPropExchangeArchive Constructors Public Methods

CXTPPropExchangeArchive Constructors Public Methods
CXTPPropExchangeArchive Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeArchive | Constructs a CXTPPropExchangeArchive object.


Legend

Legend
CXTPPropExchangeEnumerator Constructors
Legend
Constructor


CXTPPropExchangeEnumerator Constructors Public Methods

CXTPPropExchangeEnumerator Constructors Public Methods
CXTPPropExchangeEnumerator Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeEnumerator | Constructs a CXTPPropExchangeEnumerator object.


Legend

Legend
CXTPPropExchangeIniFile Constructors
Legend
Constructor


CXTPPropExchangeIniFile Constructors Public Methods

CXTPPropExchangeIniFile Constructors Public Methods
CXTPPropExchangeIniFile Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeIniFile | Constructs CXTPPropExchangeIniFile a object.


Legend

Legend
CXTPPropExchangeRegistry Constructors
Legend
Constructor


CXTPPropExchangeRegistry Constructors Public Methods

CXTPPropExchangeRegistry Constructors Public Methods
CXTPPropExchangeRegistry Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeRegistry | Constructs CXTPPropExchangeRegistry a object.


Legend

Legend
CXTPPropExchangeSection Constructors
Legend
Constructor


CXTPPropExchangeSection Constructors Public Methods

CXTPPropExchangeSection Constructors Public Methods
CXTPPropExchangeSection Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeSection |


Legend

Legend
CXTPPropExchangeXMLNode Constructors
Legend
Constructor


CXTPPropExchangeXMLNode Constructors Public Methods

CXTPPropExchangeXMLNode Constructors Public Methods
CXTPPropExchangeXMLNode Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPPropExchangeXMLNode | Constructs CXTPPropExchangeXMLNode a object.


Legend

Legend
CXTPReBar Constructors
Legend
Constructor


CXTPReBar Constructors Public Methods

CXTPReBar Constructors Public Methods
CXTPReBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReBar | Constructs a CXTPReBar object.


Legend

Legend
CXTPReBarPaintManager Constructors
Legend
Constructor


CXTPReBarPaintManager Constructors Public Methods

CXTPReBarPaintManager Constructors Public Methods
CXTPReBarPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReBarPaintManager | Constructs a CXTPReBarPaintManager object.


Legend

Legend
CXTPReportColumn Constructors
Legend
Constructor


CXTPReportColumn Constructors Public Methods

CXTPReportColumn Constructors Public Methods
CXTPReportColumn Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportColumn |


Legend

Legend
CXTPReportColumnOrder Constructors
Legend
Constructor


CXTPReportColumnOrder Constructors Public Methods

CXTPReportColumnOrder Constructors Public Methods
CXTPReportColumnOrder Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportColumnOrder | Default column order constructor.


Legend

Legend
CXTPReportColumns Constructors
Legend
Constructor


CXTPReportColumns Constructors Public Methods

CXTPReportColumns Constructors Public Methods
CXTPReportColumns Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportColumns | Constructs a CXTPReportColumns object


Legend

Legend
CXTPReportControl Constructors
Legend
Constructor


CXTPReportControl Constructors Public Methods

CXTPReportControl Constructors Public Methods
CXTPReportControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportControl | Constructs a CXTPReportControl object.


CUpdateContext Constructors Public Methods

CUpdateContext Constructors Public Methods
CUpdateContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CUpdateContext | Constructs a CXTPReportControlUpdateContext object.


Legend

Legend
CXTPReportFilterEditControl Constructors
Legend
Constructor


CXTPReportFilterEditControl Constructors Public Methods

CXTPReportFilterEditControl Constructors Public Methods
CXTPReportFilterEditControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportFilterEditControl | Constructs a CXTPReportFilterEditControl object.


Legend

Legend
CXTPReportGroupRow Constructors
Legend
Constructor


CXTPReportGroupRow Constructors Public Methods

CXTPReportGroupRow Constructors Public Methods
CXTPReportGroupRow Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportGroupRow | A constructor of the CXTPReportGroupRow object.


Legend

Legend
CXTPReportHeader Constructors
Legend
Constructor


CXTPReportHeader Constructors Public Methods

CXTPReportHeader Constructors Public Methods
CXTPReportHeader Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHeader | Constructs a CXTPReportHeader object.


Legend

Legend
CXTPReportHeaderDragWnd Constructors
Legend
Constructor


CXTPReportHeaderDragWnd Constructors Public Methods

CXTPReportHeaderDragWnd Constructors Public Methods
CXTPReportHeaderDragWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHeaderDragWnd | Creates CXTPReportHeaderDragWnd object.


Legend

Legend
CXTPReportHeaderDropWnd Constructors
Legend
Constructor


CXTPReportHeaderDropWnd Constructors Public Methods

CXTPReportHeaderDropWnd Constructors Public Methods
CXTPReportHeaderDropWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHeaderDropWnd | Creates CXTPReportHeaderDropWnd object.


Legend

Legend
CXTPReportHyperlink Constructors
Legend
Constructor


CXTPReportHyperlink Constructors Public Methods

CXTPReportHyperlink Constructors Public Methods
CXTPReportHyperlink Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHyperlink | Default CXTPReportHyperlink constructor.


Legend

Legend
CXTPReportHyperlinks Constructors
Legend
Constructor


CXTPReportHyperlinks Constructors Public Methods

CXTPReportHyperlinks Constructors Public Methods
CXTPReportHyperlinks Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportHyperlinks | Default CXTPReportHyperlink constructor.


Legend

Legend
CXTPReportInplaceButton Constructors
Legend
Constructor


CXTPReportInplaceButton Constructors Public Methods

CXTPReportInplaceButton Constructors Public Methods
CXTPReportInplaceButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceButton | Constructs a CXTPReportInplaceButton object


Legend

Legend
CXTPReportInplaceButtons Constructors
Legend
Constructor


CXTPReportInplaceButtons Constructors Public Methods

CXTPReportInplaceButtons Constructors Public Methods
CXTPReportInplaceButtons Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceButtons | Constructs a CXTPReportInplaceButtons object


Legend

Legend
CXTPReportInplaceControl Constructors
Legend
Constructor


CXTPReportInplaceControl Constructors Public Methods

CXTPReportInplaceControl Constructors Public Methods
CXTPReportInplaceControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceControl | Constructs a CXTPPropertyGridInplaceList object


Legend

Legend
CXTPReportInplaceEdit Constructors
Legend
Constructor


CXTPReportInplaceEdit Constructors Public Methods

CXTPReportInplaceEdit Constructors Public Methods
CXTPReportInplaceEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceEdit | Constructs a CXTPReportInplaceEdit object


Legend

Legend
CXTPReportInplaceList Constructors
Legend
Constructor


CXTPReportInplaceList Constructors Public Methods

CXTPReportInplaceList Constructors Public Methods
CXTPReportInplaceList Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportInplaceList | Constructs a CXTPReportInplaceList object


Legend

Legend
CXTPReportPageSetupDialog Constructors
Legend
Constructor


CXTPReportPageSetupDialog Constructors Public Methods

CXTPReportPageSetupDialog Constructors Public Methods
CXTPReportPageSetupDialog Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportPageSetupDialog | Class constructor.


Legend

Legend
CXTPReportPaintManager Constructors
Legend
Constructor


CXTPReportPaintManager Constructors Public Methods

CXTPReportPaintManager Constructors Public Methods
CXTPReportPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportPaintManager | Default paint manager constructor, handles properties initialization.


Legend

Legend
CXTPReportRecord Constructors
Legend
Constructor


CXTPReportRecord Constructors Public Methods

CXTPReportRecord Constructors Public Methods
CXTPReportRecord Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecord | Constructs a CXTPReportRecord object


Legend

Legend
CXTPReportRecordItem Constructors
Legend
Constructor


CXTPReportRecordItem Constructors Public Methods

CXTPReportRecordItem Constructors Public Methods
CXTPReportRecordItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItem | CXTPReportRecordItem default constructor


Legend

Legend
CXTPReportRecordItemConstraint Constructors
Legend
Constructor


CXTPReportRecordItemConstraint Constructors Public Methods

CXTPReportRecordItemConstraint Constructors Public Methods
CXTPReportRecordItemConstraint Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemConstraint | Constructs a CXTPPropertyGridItemConstraint object.


Legend

Legend
CXTPReportRecordItemConstraints Constructors
Legend
Constructor


CXTPReportRecordItemConstraints Constructors Public Methods

CXTPReportRecordItemConstraints Constructors Public Methods
CXTPReportRecordItemConstraints Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemConstraints | Constructs a CXTPReportRecordItemConstraints object.


Legend

Legend
CXTPReportRecordItemDateTime Constructors
Legend
Constructor


CXTPReportRecordItemDateTime Constructors Public Methods

CXTPReportRecordItemDateTime Constructors Public Methods
CXTPReportRecordItemDateTime Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemDateTime | Creates record date/time item.


Legend

Legend
CXTPReportRecordItemEditOptions Constructors
Legend
Constructor


CXTPReportRecordItemEditOptions Constructors Public Methods

CXTPReportRecordItemEditOptions Constructors Public Methods
CXTPReportRecordItemEditOptions Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemEditOptions | Constructs a CXTPReportRecordItemEditOptions object.


Legend

Legend
CXTPReportRecordItemNumber Constructors
Legend
Constructor


CXTPReportRecordItemNumber Constructors Public Methods

CXTPReportRecordItemNumber Constructors Public Methods
CXTPReportRecordItemNumber Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemNumber |


Legend

Legend
CXTPReportRecordItemPreview Constructors
Legend
Constructor


CXTPReportRecordItemPreview Constructors Public Methods

CXTPReportRecordItemPreview Constructors Public Methods
CXTPReportRecordItemPreview Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemPreview | Creates a new preview record item.


Legend

Legend
CXTPReportRecordItemText Constructors
Legend
Constructor


CXTPReportRecordItemText Constructors Public Methods

CXTPReportRecordItemText Constructors Public Methods
CXTPReportRecordItemText Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemText | Creates a record text item.


Legend

Legend
CXTPReportRecordItemVariant Constructors
Legend
Constructor


CXTPReportRecordItemVariant Constructors Public Methods

CXTPReportRecordItemVariant Constructors Public Methods
CXTPReportRecordItemVariant Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecordItemVariant | Creates a new variant record item.


Legend

Legend
CXTPReportRecords Constructors
Legend
Constructor


CXTPReportRecords Constructors Public Methods

CXTPReportRecords Constructors Public Methods
CXTPReportRecords Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRecords |


Legend

Legend
CXTPReportRow Constructors
Legend
Constructor


CXTPReportRow Constructors Public Methods

CXTPReportRow Constructors Public Methods
CXTPReportRow Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRow | A constructor of the CXTPReportRow object.


Legend

Legend
CXTPReportRows Constructors
Legend
Constructor


CXTPReportRows Constructors Public Methods

CXTPReportRows Constructors Public Methods
CXTPReportRows Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportRows | Constructs an empty CXTPReportRow pointer array.


Legend

Legend
CXTPReportSelectedRows Constructors
Legend
Constructor


CXTPReportSelectedRows Constructors Public Methods

CXTPReportSelectedRows Constructors Public Methods
CXTPReportSelectedRows Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportSelectedRows | Constructs an empty CXTPReportSelectedRows collection.


Legend

Legend
CXTPReportSubListControl Constructors
Legend
Constructor


CXTPReportSubListControl Constructors Public Methods

CXTPReportSubListControl Constructors Public Methods
CXTPReportSubListControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportSubListControl | Constructs a CXTPReportSubListControl object.


Legend

Legend
CXTPReportTip Constructors
Legend
Constructor


CXTPReportTip Constructors Public Methods

CXTPReportTip Constructors Public Methods
CXTPReportTip Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportTip | Constructs a CXTPReportTip object.


Legend

Legend
CXTPReportView Constructors
Legend
Constructor
protected


CXTPReportView Constructors Protected Methods

CXTPReportView Constructors Protected Methods
CXTPReportView Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPReportView | Protected constructor used by dynamic creation


Legend

Legend
CXTPReportViewPrintOptions Constructors
Legend
Constructor


CXTPReportViewPrintOptions Constructors Public Methods

CXTPReportViewPrintOptions Constructors Public Methods
CXTPReportViewPrintOptions Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPReportViewPrintOptions | Default Object constructor.


Legend

Legend
CXTPResourceManager Constructors
Legend
Constructor


CXTPResourceManager Constructors Public Methods

CXTPResourceManager Constructors Public Methods
CXTPResourceManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPResourceManager | Constructs a CXTPResourceManager object.


Legend

Legend
CManageState Constructors
Legend
Constructor


CManageState Constructors Public Methods

CManageState Constructors Public Methods
CManageState Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CManageState | Constructs a CManageState object


Legend

Legend
CXTPResourceManagerXML Constructors
Legend
Constructor


CXTPResourceManagerXML Constructors Public Methods

CXTPResourceManagerXML Constructors Public Methods
CXTPResourceManagerXML Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPResourceManagerXML |


Legend

Legend
CXTPRibbonBar Constructors
Legend
Constructor


CXTPRibbonBar Constructors Public Methods

CXTPRibbonBar Constructors Public Methods
CXTPRibbonBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonBar | Constructs a CXTPRibbonBar object


Legend

Legend
CXTPRibbonControls Constructors
Legend
Constructor


CXTPRibbonControls Constructors Public Methods

CXTPRibbonControls Constructors Public Methods
CXTPRibbonControls Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonControls | Constructs a CXTPRibbonControls object


Legend

Legend
CXTPRibbonControlTab Constructors
Legend
Constructor


CXTPRibbonControlTab Constructors Public Methods

CXTPRibbonControlTab Constructors Public Methods
CXTPRibbonControlTab Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonControlTab | Constructs a CXTPRibbonControlTab object


Legend

Legend
CXTPRibbonCustomizeQuickAccessPage Constructors
Legend
Constructor


CXTPRibbonCustomizeQuickAccessPage Constructors Public Methods

CXTPRibbonCustomizeQuickAccessPage Constructors Public Methods
CXTPRibbonCustomizeQuickAccessPage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonCustomizeQuickAccessPage | Constructs a CXTPRibbonCustomizeQuickAccessPage object


Legend

Legend
CXTPRibbonGroup Constructors
Legend
Constructor


CXTPRibbonGroup Constructors Public Methods

CXTPRibbonGroup Constructors Public Methods
CXTPRibbonGroup Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonGroup | Constructs a CXTPRibbonGroup object


Legend

Legend
CXTPRibbonGroups Constructors
Legend
Constructor


CXTPRibbonGroups Constructors Public Methods

CXTPRibbonGroups Constructors Public Methods
CXTPRibbonGroups Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonGroups | Constructs a CXTPRibbonGroups object


Legend

Legend
CXTPRibbonQuickAccessControls Constructors
Legend
Constructor


CXTPRibbonQuickAccessControls Constructors Public Methods

CXTPRibbonQuickAccessControls Constructors Public Methods
CXTPRibbonQuickAccessControls Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonQuickAccessControls | Constructs a CXTPRibbonQuickAccessControls object


Legend

Legend
CXTPRibbonTab Constructors
Legend
Constructor


CXTPRibbonTab Constructors Public Methods

CXTPRibbonTab Constructors Public Methods
CXTPRibbonTab Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonTab | Constructs a CXTPRibbonTab object


Legend

Legend
CXTPRibbonTheme Constructors
Legend
Constructor


CXTPRibbonTheme Constructors Public Methods

CXTPRibbonTheme Constructors Public Methods
CXTPRibbonTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPRibbonTheme | Constructs a CXTPRibbonTheme object


Legend

Legend
CXTPShortcutBar Constructors
Legend
Constructor


CXTPShortcutBar Constructors Public Methods

CXTPShortcutBar Constructors Public Methods
CXTPShortcutBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBar | Constructs a CXTPShortcutBar object.


Legend

Legend
CXTPShortcutBarItem Constructors
Legend
Constructor
protected


CXTPShortcutBarItem Constructors Protected Methods

CXTPShortcutBarItem Constructors Protected Methods
CXTPShortcutBarItem Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPShortcutBarItem |


Legend

Legend
CXTPShortcutBarOffice2003Theme Constructors
Legend
Constructor


CXTPShortcutBarOffice2003Theme Constructors Public Methods

CXTPShortcutBarOffice2003Theme Constructors Public Methods
CXTPShortcutBarOffice2003Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBarOffice2003Theme | Constructs a CXTPShortcutBarOffice2003Theme object.


Legend

Legend
CXTPShortcutBarOffice2007Theme Constructors
Legend
Constructor


CXTPShortcutBarOffice2007Theme Constructors Public Methods

CXTPShortcutBarOffice2007Theme Constructors Public Methods
CXTPShortcutBarOffice2007Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBarOffice2007Theme | Constructs a CXTPShortcutBarOffice2007Theme object.


Legend

Legend
CXTPShortcutBarPaintManager Constructors
Legend
Constructor


CXTPShortcutBarPaintManager Constructors Public Methods

CXTPShortcutBarPaintManager Constructors Public Methods
CXTPShortcutBarPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBarPaintManager | Constructs a CXTPShortcutBarPaintManager object


Legend

Legend
CXTPShortcutBarPane Constructors
Legend
Constructor


CXTPShortcutBarPane Constructors Public Methods

CXTPShortcutBarPane Constructors Public Methods
CXTPShortcutBarPane Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutBarPane | Constructs a CXTPShortcutBarPane object.


Legend

Legend
CXTPShortcutBarPaneItem Constructors
Legend
Constructor
protected


CXTPShortcutBarPaneItem Constructors Protected Methods

CXTPShortcutBarPaneItem Constructors Protected Methods
CXTPShortcutBarPaneItem Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPShortcutBarPaneItem | Constructs a CXTPShortcutBarPaneItem object.


Legend

Legend
CXTPShortcutManager Constructors
Legend
Constructor


CXTPShortcutManager Constructors Public Methods

CXTPShortcutManager Constructors Public Methods
CXTPShortcutManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPShortcutManager | Constructs a CXTPShortcutManager object.


Legend

Legend
CXTPSkinImage Constructors
Legend
Constructor


CXTPSkinImage Constructors Public Methods

CXTPSkinImage Constructors Public Methods
CXTPSkinImage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinImage | Constructs a CXTPSkinImage object.


Legend

Legend
CXTPSkinImages Constructors
Legend
Constructor


CXTPSkinImages Constructors Public Methods

CXTPSkinImages Constructors Public Methods
CXTPSkinImages Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinImages | Constructs a CXTPSkinImages object.


Legend

Legend
CXTPSkinManager Constructors
Legend
Constructor
protected


CXTPSkinManager Constructors Protected Methods

CXTPSkinManager Constructors Protected Methods
CXTPSkinManager Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinManager | Constructs a CXTPSkinManager object.


Legend

Legend
CXTPSkinManagerClass Constructors
Legend
Constructor
protected


CXTPSkinManagerClass Constructors Protected Methods

CXTPSkinManagerClass Constructors Protected Methods
CXTPSkinManagerClass Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinManagerClass | Constructs a CXTPSkinManagerClass object.


Legend

Legend
CXTPSkinManagerMetrics Constructors
Legend
Constructor


CXTPSkinManagerMetrics Constructors Public Methods

CXTPSkinManagerMetrics Constructors Public Methods
CXTPSkinManagerMetrics Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerMetrics | Constructs a CXTPSkinManagerMetrics object.


Legend

Legend
CXTPSkinManagerResourceFile Constructors
Legend
Constructor


CXTPSkinManagerResourceFile Constructors Public Methods

CXTPSkinManagerResourceFile Constructors Public Methods
CXTPSkinManagerResourceFile Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerResourceFile | Constructs a CXTPSkinManagerResourceFile object.


Legend

Legend
CXTPSkinManagerSchema Constructors
Legend
Constructor


CXTPSkinManagerSchema Constructors Public Methods

CXTPSkinManagerSchema Constructors Public Methods
CXTPSkinManagerSchema Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerSchema | Constructs a CXTPSkinManagerSchema object.


Legend

Legend
CXTPSkinManagerSchemaDefault Constructors
Legend
Constructor


CXTPSkinManagerSchemaDefault Constructors Public Methods

CXTPSkinManagerSchemaDefault Constructors Public Methods
CXTPSkinManagerSchemaDefault Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerSchemaDefault | Constructs a CXTPSkinManagerSchemaDefault object.


Legend

Legend
CXTPSkinManagerSchemaProperty Constructors
Legend
Constructor


CXTPSkinManagerSchemaProperty Constructors Public Methods

CXTPSkinManagerSchemaProperty Constructors Public Methods
CXTPSkinManagerSchemaProperty Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinManagerSchemaProperty | Constructs a CXTPSkinManagerSchemaProperty object.


Legend

Legend
CXTPSkinObject Constructors
Legend
Constructor
protected


CXTPSkinObject Constructors Protected Methods

CXTPSkinObject Constructors Protected Methods
CXTPSkinObject Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinObject | Constructs a CXTPSkinObject object.


Legend

Legend
CXTPSkinObjectButton Constructors
Legend
Constructor


CXTPSkinObjectButton Constructors Public Methods

CXTPSkinObjectButton Constructors Public Methods
CXTPSkinObjectButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectButton | Constructs a CXTPSkinObjectButton object.


Legend

Legend
CXTPSkinObjectClassMap Constructors
Legend
Constructor


CXTPSkinObjectClassMap Constructors Public Methods

CXTPSkinObjectClassMap Constructors Public Methods
CXTPSkinObjectClassMap Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectClassMap | Constructs a CXTPSkinObjectClassMap object.


Legend

Legend
CXTPSkinObjectComboBox Constructors
Legend
Constructor


CXTPSkinObjectComboBox Constructors Public Methods

CXTPSkinObjectComboBox Constructors Public Methods
CXTPSkinObjectComboBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectComboBox | Constructs a CXTPSkinObjectComboBox object.


Legend

Legend
CXTPSkinObjectComCtl32Control Constructors
Legend
Constructor
protected


CXTPSkinObjectComCtl32Control Constructors Protected Methods

CXTPSkinObjectComCtl32Control Constructors Protected Methods
CXTPSkinObjectComCtl32Control Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinObjectComCtl32Control | Constructs a CXTPSkinObjectComCtl32Control object.


Legend

Legend
CXTPSkinObjectDateTime Constructors
Legend
Constructor


CXTPSkinObjectDateTime Constructors Public Methods

CXTPSkinObjectDateTime Constructors Public Methods
CXTPSkinObjectDateTime Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectDateTime | Constructs a CXTPSkinObjectDateTime object.


Legend

Legend
CXTPSkinObjectEdit Constructors
Legend
Constructor


CXTPSkinObjectEdit Constructors Public Methods

CXTPSkinObjectEdit Constructors Public Methods
CXTPSkinObjectEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectEdit | Constructs a CXTPSkinObjectEdit object.


Legend

Legend
CXTPSkinObjectFrame Constructors
Legend
Constructor


CXTPSkinObjectFrame Constructors Public Methods

CXTPSkinObjectFrame Constructors Public Methods
CXTPSkinObjectFrame Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectFrame | Constructs a CXTPSkinObjectFrame object.


Legend

Legend
CCaptionButton Constructors
Legend
Constructor


CCaptionButton Constructors Public Methods

CCaptionButton Constructors Public Methods
CCaptionButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CCaptionButton | Constructs a CXTPSkinObject object.


Legend

Legend
CXTPSkinObjectHeader Constructors
Legend
Constructor


CXTPSkinObjectHeader Constructors Public Methods

CXTPSkinObjectHeader Constructors Public Methods
CXTPSkinObjectHeader Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectHeader | Constructs a CXTPSkinObjectHeader object.


Legend

Legend
CXTPSkinObjectListBox Constructors
Legend
Constructor


CXTPSkinObjectListBox Constructors Public Methods

CXTPSkinObjectListBox Constructors Public Methods
CXTPSkinObjectListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectListBox | Constructs a CXTPSkinObjectListBox object.


Legend

Legend
CXTPSkinObjectListView Constructors
Legend
Constructor


CXTPSkinObjectListView Constructors Public Methods

CXTPSkinObjectListView Constructors Public Methods
CXTPSkinObjectListView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectListView | Constructs a CXTPSkinObjectListView object.


Legend

Legend
CXTPSkinObjectMonthCal Constructors
Legend
Constructor


CXTPSkinObjectMonthCal Constructors Public Methods

CXTPSkinObjectMonthCal Constructors Public Methods
CXTPSkinObjectMonthCal Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectMonthCal | Constructs a CXTPSkinObjectMonthCal object.


Legend

Legend
CXTPSkinObjectProgress Constructors
Legend
Constructor


CXTPSkinObjectProgress Constructors Public Methods

CXTPSkinObjectProgress Constructors Public Methods
CXTPSkinObjectProgress Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectProgress | Constructs a CXTPSkinObjectProgress object.


Legend

Legend
CXTPSkinObjectScrollBar Constructors
Legend
Constructor


CXTPSkinObjectScrollBar Constructors Public Methods

CXTPSkinObjectScrollBar Constructors Public Methods
CXTPSkinObjectScrollBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectScrollBar | Constructs a CXTPSkinObjectScrollBar object.


Legend

Legend
CXTPSkinObjectSpin Constructors
Legend
Constructor


CXTPSkinObjectSpin Constructors Public Methods

CXTPSkinObjectSpin Constructors Public Methods
CXTPSkinObjectSpin Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectSpin | Constructs a CXTPSkinObjectSpin object.


Legend

Legend
CXTPSkinObjectStatusBar Constructors
Legend
Constructor


CXTPSkinObjectStatusBar Constructors Public Methods

CXTPSkinObjectStatusBar Constructors Public Methods
CXTPSkinObjectStatusBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectStatusBar | Constructs a CXTPSkinObjectStatusBar object.


Legend

Legend
CXTPSkinObjectTab Constructors
Legend
Constructor


CXTPSkinObjectTab Constructors Public Methods

CXTPSkinObjectTab Constructors Public Methods
CXTPSkinObjectTab Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectTab | Constructs a CXTPSkinObjectTab object.


Legend

Legend
CXTPSkinObjectToolBar Constructors
Legend
Constructor


CXTPSkinObjectToolBar Constructors Public Methods

CXTPSkinObjectToolBar Constructors Public Methods
CXTPSkinObjectToolBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectToolBar | Constructs a CXTPSkinObjectToolBar object.


Legend

Legend
CXTPSkinObjectTrackBar Constructors
Legend
Constructor


CXTPSkinObjectTrackBar Constructors Public Methods

CXTPSkinObjectTrackBar Constructors Public Methods
CXTPSkinObjectTrackBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectTrackBar | Constructs a CXTPSkinObjectTrackBar object.


Legend

Legend
CXTPSkinObjectTreeView Constructors
Legend
Constructor


CXTPSkinObjectTreeView Constructors Public Methods

CXTPSkinObjectTreeView Constructors Public Methods
CXTPSkinObjectTreeView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSkinObjectTreeView | Constructs a CXTPSkinObjectTreeView object.


Legend

Legend
CXTPSkinObjectUser32Control Constructors
Legend
Constructor
protected


CXTPSkinObjectUser32Control Constructors Protected Methods

CXTPSkinObjectUser32Control Constructors Protected Methods
CXTPSkinObjectUser32Control Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSkinObjectUser32Control | Constructs a CXTPSkinObjectUser32Control object.


Legend

Legend
CXTPSplitterTracker Constructors
Legend
Constructor


CXTPSplitterTracker Constructors Public Methods

CXTPSplitterTracker Constructors Public Methods
CXTPSplitterTracker Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSplitterTracker | Constructs a CXTPSplitterTracker object.


Legend

Legend
CXTPStatusBar Constructors
Legend
Constructor


CXTPStatusBar Constructors Public Methods

CXTPStatusBar Constructors Public Methods
CXTPStatusBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPStatusBar | Constructs a CXTPStatusBar object


Legend

Legend
CXTPStatusBarPane Constructors
Legend
Constructor


CXTPStatusBarPane Constructors Public Methods

CXTPStatusBarPane Constructors Public Methods
CXTPStatusBarPane Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPStatusBarPane | Constructs a CXTPStatusBarPane object


Legend

Legend
CXTPStatusBarProgressPane Constructors
Legend
Constructor


CXTPStatusBarProgressPane Constructors Public Methods

CXTPStatusBarProgressPane Constructors Public Methods
CXTPStatusBarProgressPane Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPStatusBarProgressPane | Constructs a CXTPStatusBarProgressPane object


Legend

Legend
CXTPSyntaxEditAutoCompleteWnd Constructors
Legend
Constructor


CXTPSyntaxEditAutoCompleteWnd Constructors Public Methods

CXTPSyntaxEditAutoCompleteWnd Constructors Public Methods
CXTPSyntaxEditAutoCompleteWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditAutoCompleteWnd | Default class constructor.


Legend

Legend
CXTPSyntaxEditBufferCommand Constructors
Legend
Constructor
protected


CXTPSyntaxEditBufferCommand Constructors Protected Methods

CXTPSyntaxEditBufferCommand Constructors Protected Methods
CXTPSyntaxEditBufferCommand Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSyntaxEditBufferCommand | Creates the buffer command object, initializes its members.


Legend

Legend
CXTPSyntaxEditBufferKeepOverwriteSettings Constructors
Legend
Constructor


CXTPSyntaxEditBufferKeepOverwriteSettings Constructors Public Methods

CXTPSyntaxEditBufferKeepOverwriteSettings Constructors Public Methods
CXTPSyntaxEditBufferKeepOverwriteSettings Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditBufferKeepOverwriteSettings | Creates the object and stores buffer overwrite settings.


Legend

Legend
CXTPSyntaxEditBufferManager Constructors
Legend
Constructor


CXTPSyntaxEditBufferManager Constructors Public Methods

CXTPSyntaxEditBufferManager Constructors Public Methods
CXTPSyntaxEditBufferManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditBufferManager | Default object constructor.


Legend

Legend
CXTPSyntaxEditStringsManager Constructors
Legend
Constructor


CXTPSyntaxEditStringsManager Constructors Public Methods

CXTPSyntaxEditStringsManager Constructors Public Methods
CXTPSyntaxEditStringsManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditStringsManager | Default object constructor.


Legend

Legend
CStringPtrArray Constructors
Legend
Constructor


CStringPtrArray Constructors Public Methods

CStringPtrArray Constructors Public Methods
CStringPtrArray Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CStringPtrArray | Default object constructor.


Legend

Legend
CXTPSyntaxEditColorComboBox Constructors
Legend
Constructor


CXTPSyntaxEditColorComboBox Constructors Public Methods

CXTPSyntaxEditColorComboBox Constructors Public Methods
CXTPSyntaxEditColorComboBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorComboBox | Standard object constructor.


Legend

Legend
CXTPSyntaxEditColorInfo Constructors
Legend
Constructor


CXTPSyntaxEditColorInfo Constructors Public Methods

CXTPSyntaxEditColorInfo Constructors Public Methods
CXTPSyntaxEditColorInfo Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorInfo |


Legend

Legend
CXTPSyntaxEditColorSampleText Constructors
Legend
Constructor


CXTPSyntaxEditColorSampleText Constructors Public Methods

CXTPSyntaxEditColorSampleText Constructors Public Methods
CXTPSyntaxEditColorSampleText Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorSampleText | Default object constructor.


Legend

Legend
CXTPSyntaxEditColorTheme Constructors
Legend
Constructor


CXTPSyntaxEditColorTheme Constructors Public Methods

CXTPSyntaxEditColorTheme Constructors Public Methods
CXTPSyntaxEditColorTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorTheme | Default object constructor.


Legend

Legend
CXTPSyntaxEditColorThemesManager Constructors
Legend
Constructor


CXTPSyntaxEditColorThemesManager Constructors Public Methods

CXTPSyntaxEditColorThemesManager Constructors Public Methods
CXTPSyntaxEditColorThemesManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditColorThemesManager | Default object constructor.


Legend

Legend
CXTPSyntaxEditCommand Constructors
Legend
Constructor
protected


CXTPSyntaxEditCommand Constructors Protected Methods

CXTPSyntaxEditCommand Constructors Protected Methods
CXTPSyntaxEditCommand Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSyntaxEditCommand | Protected constructor because this class could not be instantiated itself, only by its descendants


Legend

Legend
CXTPSyntaxEditConfigurationManager Constructors
Legend
Constructor


CXTPSyntaxEditConfigurationManager Constructors Public Methods

CXTPSyntaxEditConfigurationManager Constructors Public Methods
CXTPSyntaxEditConfigurationManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditConfigurationManager | Default object constructor.


Legend

Legend
CXTPSyntaxEditCtrl Constructors
Legend
Constructor


CXTPSyntaxEditCtrl Constructors Public Methods

CXTPSyntaxEditCtrl Constructors Public Methods
CXTPSyntaxEditCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditCtrl | Default object constructor.


Legend

Legend
CXTPSyntaxEditDeleteStringCommand Constructors
Legend
Constructor


CXTPSyntaxEditDeleteStringCommand Constructors Public Methods

CXTPSyntaxEditDeleteStringCommand Constructors Public Methods
CXTPSyntaxEditDeleteStringCommand Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditDeleteStringCommand | Creates the delete string command object, initializes its members.


Legend

Legend
CXTPSyntaxEditDoc Constructors
Legend
Constructor
protected


CXTPSyntaxEditDoc Constructors Protected Methods

CXTPSyntaxEditDoc Constructors Protected Methods
CXTPSyntaxEditDoc Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSyntaxEditDoc | Protected object constructor. Used by dynamic creation


Legend

Legend
CXTPSyntaxEditFileChangesMonitor Constructors
Legend
Constructor


CXTPSyntaxEditFileChangesMonitor Constructors Public Methods

CXTPSyntaxEditFileChangesMonitor Constructors Public Methods
CXTPSyntaxEditFileChangesMonitor Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditFileChangesMonitor | Default object constructor.


Legend

Legend
CXTPSyntaxEditFindReplaceDlg Constructors
Legend
Constructor


CXTPSyntaxEditFindReplaceDlg Constructors Public Methods

CXTPSyntaxEditFindReplaceDlg Constructors Public Methods
CXTPSyntaxEditFindReplaceDlg Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditFindReplaceDlg | Default object constructor.


Legend

Legend
CXTPSyntaxEditGoToLineDlg Constructors
Legend
Constructor


CXTPSyntaxEditGoToLineDlg Constructors Public Methods

CXTPSyntaxEditGoToLineDlg Constructors Public Methods
CXTPSyntaxEditGoToLineDlg Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditGoToLineDlg | Default object constructor.


Legend

Legend
CXTPSyntaxEditInsertStringCommand Constructors
Legend
Constructor


CXTPSyntaxEditInsertStringCommand Constructors Public Methods

CXTPSyntaxEditInsertStringCommand Constructors Public Methods
CXTPSyntaxEditInsertStringCommand Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditInsertStringCommand | Creates the insert string command object, initializes its members.


Legend

Legend
CXTPSyntaxEditLexClass Constructors
Legend
Constructor


CXTPSyntaxEditLexClass Constructors Public Methods

CXTPSyntaxEditLexClass Constructors Public Methods
CXTPSyntaxEditLexClass Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexClass | Default object constructor.


Legend

Legend
CXTPSyntaxEditLexOnScreenParseCnt Constructors
Legend
Constructor


CXTPSyntaxEditLexOnScreenParseCnt Constructors Public Methods

CXTPSyntaxEditLexOnScreenParseCnt Constructors Public Methods
CXTPSyntaxEditLexOnScreenParseCnt Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexOnScreenParseCnt | Default object constructor.


Legend

Legend
CXTPSyntaxEditLexParser Constructors
Legend
Constructor


CXTPSyntaxEditLexParser Constructors Public Methods

CXTPSyntaxEditLexParser Constructors Public Methods
CXTPSyntaxEditLexParser Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexParser | Default object constructor.


Legend

Legend
CXTPSyntaxEditLexParserSchemaOptions Constructors
Legend
Constructor


CXTPSyntaxEditLexParserSchemaOptions Constructors Public Methods

CXTPSyntaxEditLexParserSchemaOptions Constructors Public Methods
CXTPSyntaxEditLexParserSchemaOptions Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexParserSchemaOptions |


Legend

Legend
CXTPSyntaxEditLexTextBlock Constructors
Legend
Constructor


CXTPSyntaxEditLexTextBlock Constructors Public Methods

CXTPSyntaxEditLexTextBlock Constructors Public Methods
CXTPSyntaxEditLexTextBlock Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexTextBlock | Default object constructor.


Legend

Legend
CXTPSyntaxEditLexTextSchema Constructors
Legend
Constructor


CXTPSyntaxEditLexTextSchema Constructors Public Methods

CXTPSyntaxEditLexTextSchema Constructors Public Methods
CXTPSyntaxEditLexTextSchema Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexTextSchema | Default object constructor.


Legend

Legend
CXTPSyntaxEditLexTokensDef Constructors
Legend
Constructor


CXTPSyntaxEditLexTokensDef Constructors Public Methods

CXTPSyntaxEditLexTokensDef Constructors Public Methods
CXTPSyntaxEditLexTokensDef Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexTokensDef |


Legend

Legend
CXTPSyntaxEditLexVariable Constructors
Legend
Constructor


CXTPSyntaxEditLexVariable Constructors Public Methods

CXTPSyntaxEditLexVariable Constructors Public Methods
CXTPSyntaxEditLexVariable Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexVariable | Default object constructor.


Legend

Legend
CXTPSyntaxEditLexVariant Constructors
Legend
Constructor


CXTPSyntaxEditLexVariant Constructors Public Methods

CXTPSyntaxEditLexVariant Constructors Public Methods
CXTPSyntaxEditLexVariant Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLexVariant |


Legend

Legend
CXTPSyntaxEditLineMarksManager Constructors
Legend
Constructor


CXTPSyntaxEditLineMarksManager Constructors Public Methods

CXTPSyntaxEditLineMarksManager Constructors Public Methods
CXTPSyntaxEditLineMarksManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditLineMarksManager | Default object constructor.


Legend

Legend
CXTPSyntaxEditPaintManager Constructors
Legend
Constructor


CXTPSyntaxEditPaintManager Constructors Public Methods

CXTPSyntaxEditPaintManager Constructors Public Methods
CXTPSyntaxEditPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPaintManager | Default object constructor.


Legend

Legend
CXTPSyntaxEditPropertiesDlg Constructors
Legend
Constructor


CXTPSyntaxEditPropertiesDlg Constructors Public Methods

CXTPSyntaxEditPropertiesDlg Constructors Public Methods
CXTPSyntaxEditPropertiesDlg Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPropertiesDlg | Default object constructor.


Legend

Legend
CXTPSyntaxEditPropertiesPageColor Constructors
Legend
Constructor


CXTPSyntaxEditPropertiesPageColor Constructors Public Methods

CXTPSyntaxEditPropertiesPageColor Constructors Public Methods
CXTPSyntaxEditPropertiesPageColor Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPropertiesPageColor | Default object constructor.


Legend

Legend
CXTPSyntaxEditPropertiesPageEdit Constructors
Legend
Constructor


CXTPSyntaxEditPropertiesPageEdit Constructors Public Methods

CXTPSyntaxEditPropertiesPageEdit Constructors Public Methods
CXTPSyntaxEditPropertiesPageEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPropertiesPageEdit | Default object constructor.


Legend

Legend
CXTPSyntaxEditPropertiesPageFont Constructors
Legend
Constructor


CXTPSyntaxEditPropertiesPageFont Constructors Public Methods

CXTPSyntaxEditPropertiesPageFont Constructors Public Methods
CXTPSyntaxEditPropertiesPageFont Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditPropertiesPageFont | Default object constructor.


Legend

Legend
CXTPSyntaxEditReplaceStringCommand Constructors
Legend
Constructor


CXTPSyntaxEditReplaceStringCommand Constructors Public Methods

CXTPSyntaxEditReplaceStringCommand Constructors Public Methods
CXTPSyntaxEditReplaceStringCommand Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditReplaceStringCommand | Creates the replace string command object, initializes its members.


Legend

Legend
CXTPSyntaxEditTextIterator Constructors
Legend
Constructor


CXTPSyntaxEditTextIterator Constructors Public Methods

CXTPSyntaxEditTextIterator Constructors Public Methods
CXTPSyntaxEditTextIterator Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditTextIterator | Default object constructor.


Legend

Legend
CXTPSyntaxEditTextSchemesManager Constructors
Legend
Constructor


CXTPSyntaxEditTextSchemesManager Constructors Public Methods

CXTPSyntaxEditTextSchemesManager Constructors Public Methods
CXTPSyntaxEditTextSchemesManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditTextSchemesManager | Default object constructor.


Legend

Legend
CXTPSyntaxEditTipListBox Constructors
Legend
Constructor


CXTPSyntaxEditTipListBox Constructors Public Methods

CXTPSyntaxEditTipListBox Constructors Public Methods
CXTPSyntaxEditTipListBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditTipListBox | Default object constructor.


Legend

Legend
CXTPSyntaxEditTipWnd Constructors
Legend
Constructor


CXTPSyntaxEditTipWnd Constructors Public Methods

CXTPSyntaxEditTipWnd Constructors Public Methods
CXTPSyntaxEditTipWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditTipWnd | Default object constructor.


Legend

Legend
CXTPSyntaxEditToolTipCtrl Constructors
Legend
Constructor


CXTPSyntaxEditToolTipCtrl Constructors Public Methods

CXTPSyntaxEditToolTipCtrl Constructors Public Methods
CXTPSyntaxEditToolTipCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditToolTipCtrl | Constructs a CXTPSyntaxEditToolTipCtrl object.


Legend

Legend
CXTPSyntaxEditUndoRedoManager Constructors
Legend
Constructor


CXTPSyntaxEditUndoRedoManager Constructors Public Methods

CXTPSyntaxEditUndoRedoManager Constructors Public Methods
CXTPSyntaxEditUndoRedoManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditUndoRedoManager | Creates the undo/redo manager object, initializes its members.


Legend

Legend
CXTPSyntaxEditView Constructors
Legend
Constructor
protected


CXTPSyntaxEditView Constructors Protected Methods

CXTPSyntaxEditView Constructors Protected Methods
CXTPSyntaxEditView Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPSyntaxEditView | Protected object constructor. Used by dynamic creation.


Legend

Legend
CXTPSyntaxEditViewPrintOptions Constructors
Legend
Constructor


CXTPSyntaxEditViewPrintOptions Constructors Public Methods

CXTPSyntaxEditViewPrintOptions Constructors Public Methods
CXTPSyntaxEditViewPrintOptions Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPSyntaxEditViewPrintOptions | Default constructor.


Legend

Legend
CXTPTabClientWnd Constructors
Legend
Constructor


CXTPTabClientWnd Constructors Public Methods

CXTPTabClientWnd Constructors Public Methods
CXTPTabClientWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabClientWnd | Constructs a CXTPTabClientWnd object


Legend

Legend
CWorkspace Constructors
Legend
Constructor


CWorkspace Constructors Public Methods

CWorkspace Constructors Public Methods
CWorkspace Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CWorkspace | Constructs a CWorkspace object


Legend

Legend
CXTPTabControl Constructors
Legend
Constructor


CXTPTabControl Constructors Public Methods

CXTPTabControl Constructors Public Methods
CXTPTabControl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabControl | Constructs a CXTPTabControl object.


Legend

Legend
CXTPTabManager Constructors
Legend
Constructor


CXTPTabManager Constructors Public Methods

CXTPTabManager Constructors Public Methods
CXTPTabManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabManager | Constructs a CXTPTabManager object.


Legend

Legend
CRowIndexer Constructors
Legend
Constructor


CRowIndexer Constructors Public Methods

CRowIndexer Constructors Public Methods
CRowIndexer Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CRowIndexer | Constructs a CRowIndexer object.


Legend

Legend
CXTPTabManagerItem Constructors
Legend
Constructor
protected


CXTPTabManagerItem Constructors Protected Methods

CXTPTabManagerItem Constructors Protected Methods
CXTPTabManagerItem Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPTabManagerItem | Constructs a CXTPTabManagerItem object.


Legend

Legend
CXTPTabManagerNavigateButton Constructors
Legend
Constructor


CXTPTabManagerNavigateButton Constructors Public Methods

CXTPTabManagerNavigateButton Constructors Public Methods
CXTPTabManagerNavigateButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabManagerNavigateButton | Constructs a CXTPTabManagerNavigateButton object.


Legend

Legend
CXTPTabPaintManager Constructors
Legend
Constructor


CXTPTabPaintManager Constructors Public Methods

CXTPTabPaintManager Constructors Public Methods
CXTPTabPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabPaintManager | Constructs a CXTPTabPaintManager object.


Legend

Legend
CAppearanceSet Constructors
Legend
Constructor


CAppearanceSet Constructors Public Methods

CAppearanceSet Constructors Public Methods
CAppearanceSet Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSet | Constructs a CAppearanceSet object.


Legend

Legend
CAppearanceSetExcel Constructors
Legend
Constructor


CAppearanceSetExcel Constructors Public Methods

CAppearanceSetExcel Constructors Public Methods
CAppearanceSetExcel Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetExcel | Constructs a CAppearanceSetExcel object.


Legend

Legend
CAppearanceSetFlat Constructors
Legend
Constructor


CAppearanceSetFlat Constructors Public Methods

CAppearanceSetFlat Constructors Public Methods
CAppearanceSetFlat Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetFlat | Constructs a CAppearanceSetFlat object.


Legend

Legend
CAppearanceSetPropertyPage2003 Constructors
Legend
Constructor


CAppearanceSetPropertyPage2003 Constructors Public Methods

CAppearanceSetPropertyPage2003 Constructors Public Methods
CAppearanceSetPropertyPage2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPage2003 | Constructs a CAppearanceSetPropertyPage2003 object.


Legend

Legend
CAppearanceSetPropertyPage2007 Constructors
Legend
Constructor


CAppearanceSetPropertyPage2007 Constructors Public Methods

CAppearanceSetPropertyPage2007 Constructors Public Methods
CAppearanceSetPropertyPage2007 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPage2007 | Constructs a CAppearanceSetPropertyPage2003 object.


Legend

Legend
CAppearanceSetPropertyPage Constructors
Legend
Constructor


CAppearanceSetPropertyPage Constructors Public Methods

CAppearanceSetPropertyPage Constructors Public Methods
CAppearanceSetPropertyPage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPage | Constructs a CAppearanceSetPropertyPage object.


Legend

Legend
CAppearanceSetPropertyPageAccess2007 Constructors
Legend
Constructor


CAppearanceSetPropertyPageAccess2007 Constructors Public Methods

CAppearanceSetPropertyPageAccess2007 Constructors Public Methods
CAppearanceSetPropertyPageAccess2007 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPageAccess2007 | Constructs a CAppearanceSetPropertyPageAccess2007 object.


Legend

Legend
CAppearanceSetPropertyPageFlat Constructors
Legend
Constructor


CAppearanceSetPropertyPageFlat Constructors Public Methods

CAppearanceSetPropertyPageFlat Constructors Public Methods
CAppearanceSetPropertyPageFlat Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetPropertyPageFlat | Constructs a CAppearanceSetPropertyPageFlat object.


Legend

Legend
CAppearanceSetStateButtons Constructors
Legend
Constructor


CAppearanceSetStateButtons Constructors Public Methods

CAppearanceSetStateButtons Constructors Public Methods
CAppearanceSetStateButtons Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetStateButtons | Constructs a CAppearanceSetStateButtons object.


Legend

Legend
CAppearanceSetVisualStudio2005 Constructors
Legend
Constructor


CAppearanceSetVisualStudio2005 Constructors Public Methods

CAppearanceSetVisualStudio2005 Constructors Public Methods
CAppearanceSetVisualStudio2005 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetVisualStudio2005 | Constructs a CAppearanceSetVisualStudio2005 object.


Legend

Legend
CAppearanceSetVisualStudio Constructors
Legend
Constructor


CAppearanceSetVisualStudio Constructors Public Methods

CAppearanceSetVisualStudio Constructors Public Methods
CAppearanceSetVisualStudio Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CAppearanceSetVisualStudio | Constructs a CAppearanceSetVisualStudio object.


Legend

Legend
CColorSet Constructors
Legend
Constructor


CColorSet Constructors Public Methods

CColorSet Constructors Public Methods
CColorSet Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CColorSet | Constructs a CColorSet object.


Legend

Legend
CColorSetVisualStudio2008 Constructors
Legend
Constructor


CColorSetVisualStudio2008 Constructors Public Methods

CColorSetVisualStudio2008 Constructors Public Methods
CColorSetVisualStudio2008 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CColorSetVisualStudio2008 | Constructs a CColorSetVisualStudio2008 object.


Legend

Legend
CColorSetWhidbey Constructors
Legend
Constructor


CColorSetWhidbey Constructors Public Methods

CColorSetWhidbey Constructors Public Methods
CColorSetWhidbey Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CColorSetWhidbey | Constructs a CColorSetWhidbey object.


Legend

Legend
CXTPTabToolBar Constructors
Legend
Constructor


CXTPTabToolBar Constructors Public Methods

CXTPTabToolBar Constructors Public Methods
CXTPTabToolBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTabToolBar | Constructs a CXTPTabToolBar object


Legend

Legend
CXTPTaskDialog Constructors
Legend
Constructor


CXTPTaskDialog Constructors Public Methods

CXTPTaskDialog Constructors Public Methods
CXTPTaskDialog Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskDialog | Constructs a CXTPTaskDialog object.


Legend

Legend
CXTPTaskPanel Constructors
Legend
Constructor


CXTPTaskPanel Constructors Public Methods

CXTPTaskPanel Constructors Public Methods
CXTPTaskPanel Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanel | Constructs a TaskPanel object


Legend

Legend
CRepositionContext Constructors
Legend
Constructor


CRepositionContext Constructors Public Methods

CRepositionContext Constructors Public Methods
CRepositionContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CRepositionContext | Constructs a CRepositionContext object.


Legend

Legend
CXTPTaskPanelExplorerTheme Constructors
Legend
Constructor


CXTPTaskPanelExplorerTheme Constructors Public Methods

CXTPTaskPanelExplorerTheme Constructors Public Methods
CXTPTaskPanelExplorerTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelExplorerTheme | Constructs a CXTPTaskPanelExplorerTheme object.


Legend

Legend
CXTPTaskPanelExplorerThemePlain Constructors
Legend
Constructor


CXTPTaskPanelExplorerThemePlain Constructors Public Methods

CXTPTaskPanelExplorerThemePlain Constructors Public Methods
CXTPTaskPanelExplorerThemePlain Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelExplorerThemePlain | Constructs a CXTPTaskPanelExplorerThemePlain object.


Legend

Legend
CXTPTaskPanelGroup Constructors
Legend
Constructor


CXTPTaskPanelGroup Constructors Public Methods

CXTPTaskPanelGroup Constructors Public Methods
CXTPTaskPanelGroup Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelGroup | Constructs a CXTPTaskPanelGroup object


Legend

Legend
CXTPTaskPanelGroupItem Constructors
Legend
Constructor


CXTPTaskPanelGroupItem Constructors Public Methods

CXTPTaskPanelGroupItem Constructors Public Methods
CXTPTaskPanelGroupItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelGroupItem | Constructs a CXTPTaskPanelGroupItem object


Legend

Legend
CXTPTaskPanelGroupItems Constructors
Legend
Constructor


CXTPTaskPanelGroupItems Constructors Public Methods

CXTPTaskPanelGroupItems Constructors Public Methods
CXTPTaskPanelGroupItems Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelGroupItems | Constructs CXTPTaskPanelGroupItems object


Legend

Legend
CXTPTaskPanelGroups Constructors
Legend
Constructor


CXTPTaskPanelGroups Constructors Public Methods

CXTPTaskPanelGroups Constructors Public Methods
CXTPTaskPanelGroups Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelGroups | Constructs a CXTPTaskPanelGroups object


Legend

Legend
CXTPTaskPanelItem Constructors
Legend
Constructor
protected


CXTPTaskPanelItem Constructors Protected Methods

CXTPTaskPanelItem Constructors Protected Methods
CXTPTaskPanelItem Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTPTaskPanelItem | Constructs a CXTPTaskPanelItem object


Legend

Legend
CXTPTaskPanelItems Constructors
Legend
Constructor


CXTPTaskPanelItems Constructors Public Methods

CXTPTaskPanelItems Constructors Public Methods
CXTPTaskPanelItems Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelItems | Constructs a CXTPTaskPanelItems object.


Legend

Legend
CXTPTaskPanelListViewOffice2003Theme Constructors
Legend
Constructor


CXTPTaskPanelListViewOffice2003Theme Constructors Public Methods

CXTPTaskPanelListViewOffice2003Theme Constructors Public Methods
CXTPTaskPanelListViewOffice2003Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelListViewOffice2003Theme | Constructs a CXTPTaskPanelListViewOffice2003Theme object.


Legend

Legend
CXTPTaskPanelListViewOfficeXPTheme Constructors
Legend
Constructor


CXTPTaskPanelListViewOfficeXPTheme Constructors Public Methods

CXTPTaskPanelListViewOfficeXPTheme Constructors Public Methods
CXTPTaskPanelListViewOfficeXPTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelListViewOfficeXPTheme | Constructs a CXTPTaskPanelListViewOfficeXPTheme object.


Legend

Legend
CXTPTaskPanelListViewTheme Constructors
Legend
Constructor


CXTPTaskPanelListViewTheme Constructors Public Methods

CXTPTaskPanelListViewTheme Constructors Public Methods
CXTPTaskPanelListViewTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelListViewTheme | Constructs a CXTPTaskPanelListViewTheme object.


Legend

Legend
CXTPTaskPanelOffice2003Theme Constructors
Legend
Constructor


CXTPTaskPanelOffice2003Theme Constructors Public Methods

CXTPTaskPanelOffice2003Theme Constructors Public Methods
CXTPTaskPanelOffice2003Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelOffice2003Theme | Constructs a CXTPTaskPanelOffice2003Theme object.


Legend

Legend
CXTPTaskPanelOffice2003ThemePlain Constructors
Legend
Constructor


CXTPTaskPanelOffice2003ThemePlain Constructors Public Methods

CXTPTaskPanelOffice2003ThemePlain Constructors Public Methods
CXTPTaskPanelOffice2003ThemePlain Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelOffice2003ThemePlain | Constructs a CXTPTaskPanelOffice2003ThemePlain object.


Legend

Legend
CXTPTaskPanelOfficeXPThemePlain Constructors
Legend
Constructor


CXTPTaskPanelOfficeXPThemePlain Constructors Public Methods

CXTPTaskPanelOfficeXPThemePlain Constructors Public Methods
CXTPTaskPanelOfficeXPThemePlain Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelOfficeXPThemePlain | Constructs a CXTPTaskPanelOfficeXPThemePlain object.


Legend

Legend
CXTPTaskPanelPaintManager Constructors
Legend
Constructor


CXTPTaskPanelPaintManager Constructors Public Methods

CXTPTaskPanelPaintManager Constructors Public Methods
CXTPTaskPanelPaintManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelPaintManager | Constructs a CXTPTaskPanelPaintManager object


Legend

Legend
CXTPTaskPanelPaintManagerPlain Constructors
Legend
Constructor


CXTPTaskPanelPaintManagerPlain Constructors Public Methods

CXTPTaskPanelPaintManagerPlain Constructors Public Methods
CXTPTaskPanelPaintManagerPlain Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelPaintManagerPlain | Constructs a CXTPTaskPanelPaintManagerPlain object.


Legend

Legend
CXTPTaskPanelScrollButton Constructors
Legend
Constructor


CXTPTaskPanelScrollButton Constructors Public Methods

CXTPTaskPanelScrollButton Constructors Public Methods
CXTPTaskPanelScrollButton Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelScrollButton | Constructs a CXTPTaskPanelScrollButton object.


Legend

Legend
CXTPTaskPanelShortcutBarOffice2003Theme Constructors
Legend
Constructor


CXTPTaskPanelShortcutBarOffice2003Theme Constructors Public Methods

CXTPTaskPanelShortcutBarOffice2003Theme Constructors Public Methods
CXTPTaskPanelShortcutBarOffice2003Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelShortcutBarOffice2003Theme | Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.


Legend

Legend
CXTPTaskPanelShortcutBarOffice2007Theme Constructors
Legend
Constructor


CXTPTaskPanelShortcutBarOffice2007Theme Constructors Public Methods

CXTPTaskPanelShortcutBarOffice2007Theme Constructors Public Methods
CXTPTaskPanelShortcutBarOffice2007Theme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelShortcutBarOffice2007Theme | Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.


Legend

Legend
CXTPTaskPanelToolboxTheme Constructors
Legend
Constructor


CXTPTaskPanelToolboxTheme Constructors Public Methods

CXTPTaskPanelToolboxTheme Constructors Public Methods
CXTPTaskPanelToolboxTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelToolboxTheme | Constructs a CXTPTaskPanelToolboxTheme object.


Legend

Legend
CXTPTaskPanelToolboxWhidbeyTheme Constructors
Legend
Constructor


CXTPTaskPanelToolboxWhidbeyTheme Constructors Public Methods

CXTPTaskPanelToolboxWhidbeyTheme Constructors Public Methods
CXTPTaskPanelToolboxWhidbeyTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTaskPanelToolboxWhidbeyTheme | Constructs a CXTPTaskPanelToolboxWhidbeyTheme object.


Legend

Legend
CXTPTempColorMask Constructors
Legend
Constructor


CXTPTempColorMask Constructors Public Methods

CXTPTempColorMask Constructors Public Methods
CXTPTempColorMask Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTempColorMask | Constructs a CXTPTempColorMask object and initializes the application defined mask color and saves the default mask color used by XTPImageManager.


Legend

Legend
CXTPToolBar Constructors
Legend
Constructor


CXTPToolBar Constructors Public Methods

CXTPToolBar Constructors Public Methods
CXTPToolBar Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPToolBar | Constructs a CXTPToolBar object


Legend

Legend
CXTPToolTipContext Constructors
Legend
Constructor


CXTPToolTipContext Constructors Public Methods

CXTPToolTipContext Constructors Public Methods
CXTPToolTipContext Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPToolTipContext | Constructs a CXTPToolTipContext object.


Legend

Legend
CXTPToolTipContextToolTip Constructors
Legend
Constructor


CXTPToolTipContextToolTip Constructors Public Methods

CXTPToolTipContextToolTip Constructors Public Methods
CXTPToolTipContextToolTip Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPToolTipContextToolTip | Constructs a CXTPToolTipContextToolTip object


Legend

Legend
CXTPTopLevelWndMsgNotifier Constructors
Legend
Constructor


CXTPTopLevelWndMsgNotifier Constructors Public Methods

CXTPTopLevelWndMsgNotifier Constructors Public Methods
CXTPTopLevelWndMsgNotifier Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTopLevelWndMsgNotifier | Default object constructor.


Legend

Legend
CXTPTransparentBitmap Constructors
Legend
Constructor


CXTPTransparentBitmap Constructors Public Methods

CXTPTransparentBitmap Constructors Public Methods
CXTPTransparentBitmap Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPTransparentBitmap | Constructor. Construct a new CXTPTransparentBitmap from a handle to an existing BitMap.


Legend

Legend
CXTPWindowRect Constructors
Legend
Constructor


CXTPWindowRect Constructors Public Methods

CXTPWindowRect Constructors Public Methods
CXTPWindowRect Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPWindowRect |


Legend

Legend
CXTPWinThemeWrapper Constructors
Legend
Constructor


CXTPWinThemeWrapper Constructors Public Methods

CXTPWinThemeWrapper Constructors Public Methods
CXTPWinThemeWrapper Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTPWinThemeWrapper | Constructs a CXTPWinThemeWrapper object.


Legend

Legend
CXTRegistryManager Constructors
Legend
Constructor


CXTRegistryManager Constructors Public Methods

CXTRegistryManager Constructors Public Methods
CXTRegistryManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTRegistryManager | Constructs a CXTRegistryManager object


Legend

Legend
CXTResize Constructors
Legend
Constructor


CXTResize Constructors Public Methods

CXTResize Constructors Public Methods
CXTResize Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResize | Constructs a CXTResize object


Legend

Legend
CXTResizeDialog Constructors
Legend
Constructor


CXTResizeDialog Constructors Public Methods

CXTResizeDialog Constructors Public Methods
CXTResizeDialog Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeDialog |


Legend

Legend
CXTResizeFormView Constructors
Legend
Constructor


CXTResizeFormView Constructors Public Methods

CXTResizeFormView Constructors Public Methods
CXTResizeFormView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeFormView | Constructs a CXTResizeFormView object


Legend

Legend
CXTResizeGroupBox Constructors
Legend
Constructor


CXTResizeGroupBox Constructors Public Methods

CXTResizeGroupBox Constructors Public Methods
CXTResizeGroupBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeGroupBox | Constructs a CXTResizeGroupBox object


Legend

Legend
CXTResizeItem Constructors
Legend
Constructor


CXTResizeItem Constructors Public Methods

CXTResizeItem Constructors Public Methods
CXTResizeItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeItem | Constructs a CXTResizeItem object


Legend

Legend
CXTResizePoint Constructors
Legend
Constructor


CXTResizePoint Constructors Public Methods

CXTResizePoint Constructors Public Methods
CXTResizePoint Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResizePoint |


Legend

Legend
CXTResizePropertyPage Constructors
Legend
Constructor


CXTResizePropertyPage Constructors Public Methods

CXTResizePropertyPage Constructors Public Methods
CXTResizePropertyPage Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResizePropertyPage | Constructs a CXTResizePropertyPage object


Legend

Legend
CXTResizePropertySheet Constructors
Legend
Constructor


CXTResizePropertySheet Constructors Public Methods

CXTResizePropertySheet Constructors Public Methods
CXTResizePropertySheet Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResizePropertySheet |


Legend

Legend
CXTResizeRect Constructors
Legend
Constructor


CXTResizeRect Constructors Public Methods

CXTResizeRect Constructors Public Methods
CXTResizeRect Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTResizeRect |


Legend

Legend
CXTSearchOptionsCtrl Constructors
Legend
Constructor


CXTSearchOptionsCtrl Constructors Public Methods

CXTSearchOptionsCtrl Constructors Public Methods
CXTSearchOptionsCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTSearchOptionsCtrl | Constructs a CXTSearchOptionsCtrl object


Legend

Legend
CXTSearchOptionsView Constructors
Legend
Constructor
protected


CXTSearchOptionsView Constructors Protected Methods

CXTSearchOptionsView Constructors Protected Methods
CXTSearchOptionsView Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTSearchOptionsView |


Legend

Legend
CXTShellListBase Constructors
Legend
Constructor


CXTShellListBase Constructors Public Methods

CXTShellListBase Constructors Public Methods
CXTShellListBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellListBase | Constructs a CXTShellListBase object


Legend

Legend
CXTShellListCtrl Constructors
Legend
Constructor


CXTShellListCtrl Constructors Public Methods

CXTShellListCtrl Constructors Public Methods
CXTShellListCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellListCtrl | Constructs a CXTShellListCtrl object


Legend

Legend
CXTShellListCtrlEx Constructors
Legend
Constructor


CXTShellListCtrlEx Constructors Public Methods

CXTShellListCtrlEx Constructors Public Methods
CXTShellListCtrlEx Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellListCtrlEx | Constructs a CXTShellListCtrlEx object


Legend

Legend
CXTShellListView Constructors
Legend
Constructor


CXTShellListView Constructors Public Methods

CXTShellListView Constructors Public Methods
CXTShellListView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellListView | Constructs a CXTShellListView object


Legend

Legend
CXTShellPidl Constructors
Legend
Constructor


CXTShellPidl Constructors Public Methods

CXTShellPidl Constructors Public Methods
CXTShellPidl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellPidl | Constructs a CXTShellPidl object


Legend

Legend
CXTShellSettings Constructors
Legend
Constructor


CXTShellSettings Constructors Public Methods

CXTShellSettings Constructors Public Methods
CXTShellSettings Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellSettings | Constructs a CXTShellSettings object


Legend

Legend
CXTShellTreeBase Constructors
Legend
Constructor


CXTShellTreeBase Constructors Public Methods

CXTShellTreeBase Constructors Public Methods
CXTShellTreeBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellTreeBase | Constructs a CXTShellTreeBase object


Legend

Legend
CXTShellTreeCtrl Constructors
Legend
Constructor


CXTShellTreeCtrl Constructors Public Methods

CXTShellTreeCtrl Constructors Public Methods
CXTShellTreeCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellTreeCtrl | Constructs a CXTShellTreeCtrl object


Legend

Legend
CXTShellTreeView Constructors
Legend
Constructor


CXTShellTreeView Constructors Public Methods

CXTShellTreeView Constructors Public Methods
CXTShellTreeView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTShellTreeView | Constructs a CXTShellTreeView object


Legend

Legend
CXTSizeIcon Constructors
Legend
Constructor


CXTSizeIcon Constructors Public Methods

CXTSizeIcon Constructors Public Methods
CXTSizeIcon Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTSizeIcon | Constructs a CXTSizeIcon object


Legend

Legend
CXTSortClass Constructors
Legend
Constructor


CXTSortClass Constructors Public Methods

CXTSortClass Constructors Public Methods
CXTSortClass Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTSortClass | Constructs a CXTSortClass object


Legend

Legend
CXTSplitPath Constructors
Legend
Constructor


CXTSplitPath Constructors Public Methods

CXTSplitPath Constructors Public Methods
CXTSplitPath Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTSplitPath | Constructs a CXTSplitPath object and breaks a path into its four components.


Legend

Legend
CXTSplitterWnd Constructors
Legend
Constructor


CXTSplitterWnd Constructors Public Methods

CXTSplitterWnd Constructors Public Methods
CXTSplitterWnd Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTSplitterWnd | Constructs a CXTSplitterWnd object


Legend

Legend
CXTSplitterWndEx Constructors
Legend
Constructor


CXTSplitterWndEx Constructors Public Methods

CXTSplitterWndEx Constructors Public Methods
CXTSplitterWndEx Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTSplitterWndEx | Constructs a CXTSplitterWndEx object


Legend

Legend
CXTSplitterWndTheme Constructors
Legend
Constructor


CXTSplitterWndTheme Constructors Public Methods

CXTSplitterWndTheme Constructors Public Methods
CXTSplitterWndTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTSplitterWndTheme | Construct a CXTSplitterWndTheme object.


Legend

Legend
CXTTabBase Constructors
Legend
Constructor


CXTTabBase Constructors Public Methods

CXTTabBase Constructors Public Methods
CXTTabBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTabBase | Constructs a CXTTabBase object


Legend

Legend
CXTTabBaseTheme Constructors
Legend
Constructor


CXTTabBaseTheme Constructors Public Methods

CXTTabBaseTheme Constructors Public Methods
CXTTabBaseTheme Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTabBaseTheme | Construct a CXTTabBaseTheme object.


Legend

Legend
CXTTabBaseThemeOffice2003 Constructors
Legend
Constructor


CXTTabBaseThemeOffice2003 Constructors Public Methods

CXTTabBaseThemeOffice2003 Constructors Public Methods
CXTTabBaseThemeOffice2003 Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTabBaseThemeOffice2003 | Construct a CXTTabBaseThemeOffice2003 object.


Legend

Legend
CXTTabBaseThemeOfficeXP Constructors
Legend
Constructor


CXTTabBaseThemeOfficeXP Constructors Public Methods

CXTTabBaseThemeOfficeXP Constructors Public Methods
CXTTabBaseThemeOfficeXP Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTabBaseThemeOfficeXP | Construct a CXTTabBaseThemeOfficeXP object.


Legend

Legend
CXTTabCtrl Constructors
Legend
Constructor


CXTTabCtrl Constructors Public Methods

CXTTabCtrl Constructors Public Methods
CXTTabCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTabCtrl | Constructs a CXTTabCtrl object


Legend

Legend
CXTTabExBase Constructors
Legend
Constructor


CXTTabExBase Constructors Public Methods

CXTTabExBase Constructors Public Methods
CXTTabExBase Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTabExBase | Constructs a CXTTabExBase object


Legend

Legend
CXTTabView Constructors
Legend
Constructor


CXTTabView Constructors Public Methods

CXTTabView Constructors Public Methods
CXTTabView Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTabView | Constructs a CXTTabView object


Legend

Legend
CXTTcbItem Constructors
Legend
Constructor


CXTTcbItem Constructors Public Methods

CXTTcbItem Constructors Public Methods
CXTTcbItem Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTcbItem | Constructs an CXTTcbItem object


Legend

Legend
CXTThemeManager Constructors
Legend
Constructor


CXTThemeManager Constructors Public Methods

CXTThemeManager Constructors Public Methods
CXTThemeManager Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTThemeManager | Constructs a CXTThemeManager object.


Legend

Legend
CXTThemeManagerStyle Constructors
Legend
Constructor


CXTThemeManagerStyle Constructors Public Methods

CXTThemeManagerStyle Constructors Public Methods
CXTThemeManagerStyle Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTThemeManagerStyle | Construct a CXTThemeManagerStyle object.


Legend

Legend
CXTThemeManagerStyleFactory Constructors
Legend
Constructor


CXTThemeManagerStyleFactory Constructors Public Methods

CXTThemeManagerStyleFactory Constructors Public Methods
CXTThemeManagerStyleFactory Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTThemeManagerStyleFactory | Construct a CXTThemeManagerStyleFactory object.


Legend

Legend
CXTThemeManagerStyleHost Constructors
Legend
Constructor
protected


CXTThemeManagerStyleHost Constructors Protected Methods

CXTThemeManagerStyleHost Constructors Protected Methods
CXTThemeManagerStyleHost Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTThemeManagerStyleHost | Constructs a CXTThemeManagerStyleHost object.


Legend

Legend
CXTTimeEdit Constructors
Legend
Constructor


CXTTimeEdit Constructors Public Methods

CXTTimeEdit Constructors Public Methods
CXTTimeEdit Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTimeEdit | Constructs a CXTTimeEdit object


Legend

Legend
CXTTipOfTheDay Constructors
Legend
Constructor


CXTTipOfTheDay Constructors Public Methods

CXTTipOfTheDay Constructors Public Methods
CXTTipOfTheDay Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTipOfTheDay | Constructs a CXTTipOfTheDay object


Legend

Legend
CXTTipWindow Constructors
Legend
Constructor


CXTTipWindow Constructors Public Methods

CXTTipWindow Constructors Public Methods
CXTTipWindow Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTipWindow | Constructs a CXTTipWindow object


Legend

Legend
CXTToolBox Constructors
Legend
Constructor


CXTToolBox Constructors Public Methods

CXTToolBox Constructors Public Methods
CXTToolBox Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTToolBox | Constructs a CXTToolBox object


Legend

Legend
CXTTrayIcon Constructors
Legend
Constructor


CXTTrayIcon Constructors Public Methods

CXTTrayIcon Constructors Public Methods
CXTTrayIcon Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTrayIcon | Constructs a CXTTrayIcon object


Legend

Legend
CXTTreeBase Constructors
Legend
Constructor
protected


CXTTreeBase Constructors Protected Methods

CXTTreeBase Constructors Protected Methods
CXTTreeBase Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTTreeBase | Protected constructor used by dynamic creation. Constructs a CXTTreeBase object


Legend

Legend
CLRFONT Constructors
Legend
Constructor


CLRFONT Constructors Public Methods

CLRFONT Constructors Public Methods
CLRFONT Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CLRFONT | Constructs a CLRFONT struct and initializes member data.


Legend

Legend
CXTTreeCtrl Constructors
Legend
Constructor


CXTTreeCtrl Constructors Public Methods

CXTTreeCtrl Constructors Public Methods
CXTTreeCtrl Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTTreeCtrl | Constructs a CXTTreeCtrl object


Legend

Legend
CXTTreeView Constructors
Legend
Constructor
protected


CXTTreeView Constructors Protected Methods

CXTTreeView Constructors Protected Methods
CXTTreeView Constructors | Legend
Protected Methods
Protected Constructors
Protected Constructor | Description
CXTTreeView | Protected constructor used by dynamic creation. Constructs a CXTTreeView object


Legend

Legend
CXTWindowList Constructors
Legend
Constructor


CXTWindowList Constructors Public Methods

CXTWindowList Constructors Public Methods
CXTWindowList Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTWindowList | Constructs a CXTWindowList object.


Legend

Legend
CXTWindowPos Constructors
Legend
Constructor


CXTWindowPos Constructors Public Methods

CXTWindowPos Constructors Public Methods
CXTWindowPos Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
CXTWindowPos | Constructs a CXTWindowPos object


Legend

Legend
XTP_EDIT_ACDATA Constructors
Legend
Constructor


XTP_EDIT_ACDATA Constructors Public Methods

XTP_EDIT_ACDATA Constructors Public Methods
XTP_EDIT_ACDATA Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
XTP_EDIT_ACDATA | Default class constructor.


Legend

Legend
XTP_EDIT_FONTOPTIONS Constructors
Legend
Constructor


XTP_EDIT_FONTOPTIONS Constructors Public Methods

XTP_EDIT_FONTOPTIONS Constructors Public Methods
XTP_EDIT_FONTOPTIONS Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
XTP_EDIT_FONTOPTIONS | Default constructor.


Legend

Legend
XTP_EDIT_TEXTBLOCK Constructors
Legend
Constructor


XTP_EDIT_TEXTBLOCK Constructors Public Methods

XTP_EDIT_TEXTBLOCK Constructors Public Methods
XTP_EDIT_TEXTBLOCK Constructors | Legend
Public Methods
Public Constructors
Public Constructor | Description
XTP_EDIT_TEXTBLOCK | Default constructor.


Legend

Legend
CXTBrowseButton Data Members
Legend
Data Member
protected


CXTBrowseButton Data Members Protected Data Members

CXTBrowseButton Data Members Protected Data Members
CXTBrowseButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dwBStyle | Search type
m_hPopupIcon | Popup menu icon.
m_nID | Resource id for push button
m_nMenu | Popup menu id
m_nSubMenuIndx | Index of popup submenu.
m_pEditWnd | Parent edit control.


Protected Data Members

Legend
Legend
Data Member
protected


Legend

Legend
CXTBrowseDialog Data Members
Legend
Data Member
protected


CXTBrowseDialog Data Members Protected Data Members

CXTBrowseDialog Data Members Protected Data Members
CXTBrowseDialog Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_szSelPath | NULL terminated string that represents the selected directory


Legend

Legend
CXTBrowseEdit Data Members
Legend
Data Member
protected


CXTBrowseEdit Data Members Protected Data Members

CXTBrowseEdit Data Members Protected Data Members
CXTBrowseEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bBrowsing | true if in browse operation.
m_bOpenFileDialog | TRUE for Open File dialog, FALSE for Save as.
m_btnBrowse | Pointer to a push button.
m_dwBStyle | Search type.
m_dwFlags | File dialog styles.
m_nGap | Distance between the button and edit control.
m_nMenu | Popup menu ID.
m_nSubMenuIndx | Index of a popup submenu.
m_pFileDialog | Points to a valid CFileDialog object.
m_strDefExt | Default file extension.
m_strFileName | Default file name.
m_strFilter | Default file filter.
m_strTitle | Directory dialog title.


Legend

Legend
CXTButton Data Members
Legend
Data Member
protected


CXTButton Data Members Protected Data Members

CXTButton Data Members Protected Data Members
CXTButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bChecked | TRUE if the button is checked.
m_bHot | TRUE if mouse under button
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bPushed | TRUE if button was pressed
m_bUserPosition | TRUE if the user has defined the XY coordinates for the image and text.
m_dwxStyle | The style of the button, see SetXButtonStyle.
m_nBorderGap | Gap between the button edge and the image.
m_nImageGap | Gap between the button text and the image.
m_pIcon | Multiple state icon manager converts icon to different states.
m_ptImage | XY location of the button image.
m_ptText | XY location of the button text.
m_sizeImage | Initial size of the button.


Legend

Legend
CXTButtonTheme Data Members
Legend
Data Member
protected


CXTButtonTheme Data Members Protected Data Members

CXTButtonTheme Data Members Protected Data Members
CXTButtonTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bOffsetHiliteText | TRUE if highlighted text is animated.
m_bShowIcon | TRUE if the buttons displays an icon.
m_crBack | RGB value for background color.
m_crBorder3DHilite | RGB value for 3D border highlight color.
m_crBorder3DShadow | RGB value for 3D border shadow color.
m_crBorderHilite | RGB value for border highlight color.
m_crBorderShadow | RGB value for border shadow color.
m_crText | RGB value for text color.
m_crTextDisabled | RGB value for disabled text color.
m_pFont | Points to a user defined font for the theme.
m_themeWrapper | Wraps the Windows XP theme API that is used to display Windows XP themes.


Legend

Legend
CXTButtonThemeOfficeXP Data Members
Legend
Data Member
protected


CXTButtonThemeOfficeXP Data Members Protected Data Members

CXTButtonThemeOfficeXP Data Members Protected Data Members
CXTButtonThemeOfficeXP Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAnimateIcon | TRUE if the button animates on mouse over.
m_bFadedIcon | TRUE if the button uses faded icons.
m_bWordTheme | TRUE if MS Word theme is used.
m_crBackChecked | RGB value for when the control is checked.
m_crBackHilite | RGB value for highlighted background color.
m_crBackPushed | RGB value for pushed background color.
m_crTextHilite | RGB value for pushed text color.
m_crTextPushed | RGB value for highlighted text color.


Legend

Legend
CXTCaption Data Members
Legend
Data Member
protected


CXTCaption Data Members Protected Data Members

CXTCaption Data Members Protected Data Members
CXTCaption Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAppCaption | true if the caption is used as the application's primary caption.
m_btnCaption | Button used to 'tack' the popup window back in place.
m_bUserColors | true if the user has specified caption colors other than the default.
m_dwExStyle | Border style bits, either CPWS_EX_GROOVE_EDGE | CPWS_EX_RAISED_EDGE.
m_hIcon | User defined icon handle.
m_ilButton | Image list used to create the close button icon.
m_nOffset | Size in pixels that the child window should leave for its caption area.
m_pChildWnd | A CWnd pointer that represents the child window displayed in the popup window.
m_pParentView | A CWnd pointer that represents the child window's parent view.
m_pPopupWnd | Points to the popup window.
m_pSplitterWnd | A CWnd pointer that represents the splitter window.
m_rcChild | Size of the child window displayed in the popup.
m_rcParent | Size of the child's parent view.
m_rcSplitter | Size of the splitter window.
m_sizeIcon | Width and height of the caption icon area.
m_strCaption | Text that will be displayed in the caption.


CXTCaption Data Members Public Data Members

CXTCaption Data Members Public Data Members
CXTCaption Data Members | Legend
Public Data Members
Public Data Member | Description
m_nBorder | Size in pixels for the caption border.


Public Data Members

Legend
Legend
Data Member


Legend

Legend
CXTCaptionButton Data Members
Legend
Data Member
protected


CXTCaptionButton Data Members Protected Data Members

CXTCaptionButton Data Members Protected Data Members
CXTCaptionButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pCaption | A pointer to the parent CXTCaption.


Legend

Legend
CXTCaptionPopupWnd Data Members
Legend
Data Member
protected


CXTCaptionPopupWnd Data Members Protected Data Members

CXTCaptionPopupWnd Data Members Protected Data Members
CXTCaptionPopupWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_Caption | Caption that is displayed when the window is active.
m_CaptionButton | Close button associated with the caption.
m_hIconOff | Handle to a pressed button icon.
m_hIconOn | Handle to a normal button icon.
m_pChildParent | A CWnd pointer that represents the parent of the child window.
m_pChildWnd | A CWnd pointer that represents the child displayed in the popup.
m_pParentWnd | A CWnd pointer that represents the parent window.


Legend

Legend
CXTCaptionTheme Data Members
Legend
Data Member


CXTCaptionTheme Data Members Public Data Members

CXTCaptionTheme Data Members Public Data Members
CXTCaptionTheme Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrBorder | The system or user defined color of the border.
m_clrEdgeLight | The color of the edge light for the current theme.
m_clrEdgeShadow | The color of the edge shadow for the current theme.
m_clrFace | The system or user defined color of the background.
m_clrText | The system or user defined color of the font.


Legend

Legend
CXTCheckListBox Data Members
Legend
Data Member
protected


CXTCheckListBox Data Members Protected Data Members

CXTCheckListBox Data Members Protected Data Members
CXTCheckListBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_checkListState | Holds the check mark image information.
m_cyText | Represents the text height for the check list box.
m_nStyle | Specifies the style for the check list box.
m_themeHelper | Used for drawing Windows XP themed checkbox.


Legend

Legend
CCheckListState Data Members
Legend
Data Member


CCheckListState Data Members Public Data Members

CCheckListState Data Members Public Data Members
CCheckListState Data Members | Legend
Public Data Members
Public Data Member | Description
m_hbitmapCheck | Handle to the check mark image bitmap.
m_sizeCheck | Width and height of the check mark bitmap.


Legend

Legend
CXTColorBase Data Members
Legend
Data Member
protected


CXTColorBase Data Members Protected Data Members

CXTColorBase Data Members Protected Data Members
CXTColorBase Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_eHasFocus | Determines which property page has input focus.


CXTColorBase Data Members Public Data Members

CXTColorBase Data Members Public Data Members
CXTColorBase Data Members | Legend
Public Data Members
Public Data Member | Description
m_nHue | Current hue value.
m_nLum | Current illumination value.
m_nSat | Current saturation value.
m_ptMousePos | Current mouse position relative to the device context.


Legend

Legend
CXTColorDialog Data Members
Legend
Data Member
protected


CXTColorDialog Data Members Protected Data Members

CXTColorDialog Data Members Protected Data Members
CXTColorDialog Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrCurrent | A COLORREF value that contains the RGB information for the current color.
m_clrNew | A COLORREF value that contains the RGB information for the new color.
m_dwStyle | Styles for the dialog.
m_editHex | Edit window to display the color hex value.
m_rcCurrent | Size of the rectangle that represents the current color.
m_rcNew | Size of the rectangle that represents the new color.


Legend

Legend
CXTColorHex Data Members
Legend
Data Member
protected


CXTColorHex Data Members Protected Data Members

CXTColorHex Data Members Protected Data Members
CXTColorHex Data Members | Legend
Protected Data Members
Protected Data Member | Description
clrSelArray | Hex colors.
m_arCells | Array of HEXCOLOR_CELL structs that represent displayed color cells.
m_bLBtnDown | TRUE when the left mouse button is pressed.
m_bmpPicker | Background device context.
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bSmallCell | TRUE when a small color cell is selected.
m_clrColor | A COLORREF value that contains the RGB information for the current color.
m_ptCurrent | Holds the last known selection point.


Legend

Legend
CXTColorPageCustom Data Members
Legend
Data Member
protected


CXTColorPageCustom Data Members Protected Data Members

CXTColorPageCustom Data Members Protected Data Members
CXTColorPageCustom Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pParentSheet | Points to the parent property sheet


Legend

Legend
CXTColorPageStandard Data Members
Legend
Data Member
protected


CXTColorPageStandard Data Members Protected Data Members

CXTColorPageStandard Data Members Protected Data Members
CXTColorPageStandard Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_colorHex | ColorHex control.
m_pParentSheet | Points to the parent property sheet


Legend

Legend
CXTColorPicker Data Members
Legend
Data Member
protected


CXTColorPicker Data Members Protected Data Members

CXTColorPicker Data Members Protected Data Members
CXTColorPicker Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bColorText | TRUE if the color picker text is colorized; only valid if m_bShowText is TRUE.
m_bPopupActive | TRUE if the popup window is currently active.
m_bShowText | TRUE if the color picker displays text.
m_clrDefault | An RGB value that represents the color for the default color.
m_clrSelected | An RGB value that represents the color for the display color.
m_dwPopup | Represents the style for the color picker.
m_nCols | Number of columns in the color popup window.
m_nExtendedColors | Custom colors count
m_pExtendedColors | Custom colors


Legend

Legend
CXTColorPopup Data Members
Legend
Data Member
protected


CXTColorPopup Data Members Protected Data Members

CXTColorPopup Data Members Protected Data Members
CXTColorPopup Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoDelete | TRUE if the popup window is to be self deleting.
m_bDisplayShadow | TRUE if the popup window will render its shadow.
m_callerParam | Caller parameter that will be reported back as an LPARAM of all notification messages.
m_rcExclude | Area to exclude from shadow display.


Legend

Legend
CXTColorRef Data Members
Legend
Data Member
protected


CXTColorRef Data Members Protected Data Members

CXTColorRef Data Members Protected Data Members
CXTColorRef Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_ColorRef | Current RGB value for this object


CXTColorRef Data Members Public Data Members

CXTColorRef Data Members Public Data Members
CXTColorRef Data Members | Legend
Public Data Members
Public Data Member | Description
BLACK | RGB value that represents the color black.
GRAY_25 | RGB value that represents the 25% gray color.
GRAY_50 | RGB value that represents the 50% gray color.
GRAY_75 | RGB value that represents the 75% gray color.
WHITE | RGB value that represents the color white.


Legend

Legend
CXTColorSelectorCtrl Data Members
Legend
Data Member
protected


CXTColorSelectorCtrl Data Members Protected Data Members

CXTColorSelectorCtrl Data Members Protected Data Members
CXTColorSelectorCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arCells | Array of color items.
m_arUserDefColors | Array of user defined colors.
m_clrColor | An RGB value that represents the currently selected color.
m_clrDefault | An RGB value that represents the default color for the popup window.
m_dwPopup | Color popup window style.
m_listeners | Array of listener windows to be sent notifications.
m_nCols | Number of columns in the color popup window.
m_nCurSel | Currently selected index.
m_nExtendedColors | Custom colors count
m_nPressed | Pressed button.
m_pColorDlg | Points to the color selection dialog when visible.
m_pExtendedColors | Custom colors
m_point | Last known cursor position.
m_pParentWnd | Points to the parent window for the popup window.
m_rcBorders | Control borders
m_rcWnd | Rect for the popup window.
m_sizeButton | cx and cy size for a color picker button.
m_tooltip | Tooltip control.


Legend

Legend
CXTColorSelectorCtrlTheme Data Members
Legend
Data Member
protected


CXTColorSelectorCtrlTheme Data Members Protected Data Members

CXTColorSelectorCtrlTheme Data Members Protected Data Members
CXTColorSelectorCtrlTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_crBack | RGB value for background color.
m_crBorderHilight | RGB value for 3D border highlight color.
m_crBorderShadow | RGB value for 3D border shadow color.
m_crChecked | RGB value for checked background color.
m_crHilight | RGB value for hilight background color.
m_crPressed | RGB value for pressed background color.
m_crText | RGB value for text color.


Legend

Legend
CXTColorWnd Data Members
Legend
Data Member
protected


CXTColorWnd Data Members Protected Data Members

CXTColorWnd Data Members Protected Data Members
CXTColorWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bmpPicker | Background device context.


Legend

Legend
CXTDirWatcher Data Members
Legend
Data Member
protected


CXTDirWatcher Data Members Protected Data Members

CXTDirWatcher Data Members Protected Data Members
CXTDirWatcher Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dwMonitorEvents | Change event handles.
m_strFolderPath | Path that is monitored.
m_tvid | Tree view item data.


Legend

Legend
CXTDropSource Data Members
Legend
Data Member
protected


CXTDropSource Data Members Protected Data Members

CXTDropSource Data Members Protected Data Members
CXTDropSource Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_uiRefCount | Indicates the current reference count.


Legend

Legend
CXTEdit Data Members
Legend
Data Member
protected


CXTEdit Data Members Protected Data Members

CXTEdit Data Members Protected Data Members
CXTEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pParentWnd | Pointer to the parent of the edit control.


Legend

Legend
CXTEditListBox Data Members
Legend
Data Member
protected


CXTEditListBox Data Members Protected Data Members

CXTEditListBox Data Members Protected Data Members
CXTEditListBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bEnableEdit | True if editing is enabled.
m_bNewItem | TRUE if a new item is being entered into the list box.
m_dwLStyle | List edit styles.
m_editGroup | The edit group (toolbar) that appears above the list box.
m_nIndex | Current index when edit functions are performed.
m_pItemEdit | Points to the in-place edit item.
m_pParentWnd | Pointer to the parent window.
m_strFilter | Default file filter.
m_strInitialDir | Initial Dir.
m_strItemDefaultText | Default text used when new items are created.
m_strItemText | Current text of a selected item during edit.
m_strTitle | Caption area title.


Legend

Legend
CXTEditListBoxToolBar Data Members
Legend
Data Member
protected


CXTEditListBoxToolBar Data Members Protected Data Members

CXTEditListBoxToolBar Data Members Protected Data Members
CXTEditListBoxToolBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arButton | Array of toolbar buttons.
m_arClipRect | Array of toolbar button sizes.
m_arIcon | Array of toolbar button icons.
m_bEnableEdit | True if editing is enabled.
m_bShowNewDeleteButtons | Controls whether of not the up.down buttons are shown.
m_bShowUpDownButtons | Controls whether of not the up.down buttons are shown.
m_tooltip | Tooltip control for edit buttons.


Legend

Legend
CXTExcelTabCtrl Data Members
Legend
Data Member
protected


CXTExcelTabCtrl Data Members Protected Data Members

CXTExcelTabCtrl Data Members Protected Data Members
CXTExcelTabCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bManagingViews | true if the control is managing views.
m_bPainted | Set to TRUE to indicate that a button has been painted.
m_bTracking | Tracking state.
m_bUserColors | true if user defined colors are used.
m_buttons | Array of button information.
m_cx | Width for each arrow button.
m_cy | Height for each arrow button.
m_dwStyle | Tab control style.
m_iBtnEnd | Index of "end" button in button array.
m_iBtnHilight | Index of the button that has the mouse hovering over it.
m_iBtnHome | Index of "home" button in button array.
m_iBtnLeft | Index of "left" button in button array.
m_iBtnRight | Index of "right" button in button array.
m_iGripperPosPerCent | The current gripper position in percent of the control width.
m_nClientHeight | Height in pixels of the tab control client area.
m_nClientWidth | Width in pixels of the tab control client area.
m_nCurSel | Index of the currently selected tab.
m_nOffset | Amount in pixels of the displayed tab offset.
m_pBoldFont | Font that is used for selected tabs.
m_pNormFont | Font that is used for non-selected tabs.
m_pWndLastFocus | Last focused window.
m_rectGripper | Area occupied by the sizing gripper.
m_rectSB_H | Area occupied by the horizontal scroll bar.
m_rectTabs | Area occupied by tabs.
m_rectViews | Area occupied by managed views.
m_tcbItems | Template list containing tab information.
m_ToolTip | Tooltip for the flat tab control.
m_wndHScrollBar | The horizontal scroll bar (used with FTS_XT_HSCROLL).
m_xGripperPos | The current gripper position in pixels from the left.
m_xTrackingDelta | Tracking delta.


Legend

Legend
CXTExcelTabCtrlButtonState Data Members
Legend
Data Member


CXTExcelTabCtrlButtonState Data Members Public Data Members

CXTExcelTabCtrlButtonState Data Members Public Data Members
CXTExcelTabCtrlButtonState Data Members | Legend
Public Data Members
Public Data Member | Description
m_bEnabled | true if the button is enabled.
m_bHilight | true if the mouse if hovering.
m_bPressed | true if the button is pressed.
m_iCommand | Button command ID.
m_IconType | Icon style of the button.
m_rect | Size and location of the button.


Legend

Legend
CXTExcelTabCtrlTheme Data Members
Legend
Data Member


CXTExcelTabCtrlTheme Data Members Public Data Members

CXTExcelTabCtrlTheme Data Members Public Data Members
CXTExcelTabCtrlTheme Data Members | Legend
Public Data Members
Public Data Member | Description
m_clr3DFace | RGB value that represents the normal tab face color.
m_clr3DFaceHilite | RGB value for highlighted background color.
m_clr3DFacePushed | RGB value for pushed background color.
m_clr3DHilight | RGB value that represents the tab highlight color.
m_clr3DShadow | RGB value that represents the tab shadow color.
m_clrBorder3DHilite | RGB value for 3D border highlight color.
m_clrBorder3DShadow | RGB value for 3D border shadow color.
m_clrBtnText | RGB value that represents the tab outline color.
m_clrBtnTextGray | RGB value for disabled text color.
m_clrBtnTextHilite | RGB value for pushed text color.
m_clrBtnTextPushed | RGB value for highlighted text color.
m_clrWindow | RGB value that represents the selected tab face color.
m_clrWindowText | RGB value that represents the tab text color.
m_cx | Width for each arrow button.
m_cy | Height for each arrow button


Legend

Legend
CXTFlatComboBox Data Members
Legend
Data Member
protected


CXTFlatComboBox Data Members Protected Data Members

CXTFlatComboBox Data Members Protected Data Members
CXTFlatComboBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bHasFocus | TRUE if the control has the focus.
m_bPainted | Used during paint operations.
m_crBack | RGB color value representing background color.
m_crText | RGB color value representing text color.
m_nStyle | Stores the standard window styles for the control.
m_nStyleEx | Stores the extended window styles for the control.


CXTFlatComboBox Data Members Public Data Members

CXTFlatComboBox Data Members Public Data Members
CXTFlatComboBox Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAutoComp | Used by Auto completing.
m_bDisableAC | TRUE when auto complete is disabled internally.
m_bFlatLook | TRUE if the control is flat.


Legend

Legend
CXTFlatComboBoxTheme Data Members
Legend
Data Member
protected


CXTFlatComboBoxTheme Data Members Protected Data Members

CXTFlatComboBoxTheme Data Members Protected Data Members
CXTFlatComboBoxTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_cxArrow | This member variable contains the width of the drop down arrow.
m_sizeBorder | Stores dimensions, in pixels, of a 3-D window border.
m_sizeEdge | Stores dimensions, in pixels, of a 3-D window edge.
m_sizeThumb | Stores dimensions, in pixels, of a 3-D drop down arrow box.


Legend

Legend
CXTFlatEdit Data Members
Legend
Data Member
protected


CXTFlatEdit Data Members Protected Data Members

CXTFlatEdit Data Members Protected Data Members
CXTFlatEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bFlatLook | TRUE if the control is flat.
m_bHasFocus | TRUE if the control has focus.
m_bPainted | Used during paint operations.
m_nStyle | Stores the standard window styles for the control.
m_nStyleEx | Stores the extended window styles for the control.


Legend

Legend
CXTFlatEditThemeOfficeXP Data Members
Legend
Data Member


CXTFlatEditThemeOfficeXP Data Members Public Data Members

CXTFlatEditThemeOfficeXP Data Members Public Data Members
CXTFlatEditThemeOfficeXP Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrFrameEdit | Used to specify the color an edit frame.
m_clrFrameHighlight | Used to specify the color a highlighted frame.
m_clrFrameNormal | Used to specify the color a normal frame.
m_clrHighlight | Used to specify the color a highlighted object.
m_clrHighlightText | Used to specify the color of highlighted text.
m_clrNormal | Used to specify the color a normal object.
m_clrPushed | Used to specify the color a pushed object.
m_clrPushedText | Used to specify the color of pushed text.


Legend

Legend
CXTFontCombo Data Members
Legend
Data Member
protected


CXTFontCombo Data Members Protected Data Members

CXTFontCombo Data Members Protected Data Members
CXTFontCombo Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_csSymbol | String displayed for symbol characters.
m_dwStyle | Enumerated style indicating how to display the font list.
m_ilFontType | true type font image list.


Legend

Legend
CXTFontEnum Data Members
Legend
Data Member
protected


CXTFontEnum Data Members Protected Data Members

CXTFontEnum Data Members Protected Data Members
CXTFontEnum Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_listFonts | List of fonts found during enumeration


Legend

Legend
CXTFontListBox Data Members
Legend
Data Member
protected


CXTFontListBox Data Members Protected Data Members

CXTFontListBox Data Members Protected Data Members
CXTFontListBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_csSymbol | String displayed for the symbol characters.
m_dwStyle | Display style indicating how to render the font list.
m_ilFontType | True type font image list.


Legend

Legend
CXTHeaderCtrl Data Members
Legend
Data Member
protected


CXTHeaderCtrl Data Members Protected Data Members

CXTHeaderCtrl Data Members Protected Data Members
CXTHeaderCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arFrozenCols | List of columns that are not sizable.
m_bAscending | Used, when column is pressed, to draw a sort arrow.
m_bAutoSize | true if the header control columns are auto-sizing.
m_bEnableMenus | TRUE to disable the popup menu display.
m_bLBtnDown | TRUE if left mouse button is pressed.
m_bPainted | Used during paint operations.
m_bRTL | Used internally to determine if text is right-to-left or left-to-right (depends on system locale).
m_iMinSize | Minimum column size for an auto-size header control.
m_iOverIndex | Column mouse is currently hovering.
m_nPos | Index of the popup menu contained in the menu.
m_nSortedCol | Last column pressed during sort.
m_popupMenuID | Popup menu resource ID.
m_pt | Point where right click took place.


Legend

Legend
CXTHeaderCtrlTheme Data Members
Legend
Data Member
protected


CXTHeaderCtrlTheme Data Members Protected Data Members

CXTHeaderCtrlTheme Data Members Protected Data Members
CXTHeaderCtrlTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bUseWinThemes | TRUE to use Windows XP themes when available.
m_cr3DDkShadow | RGB value for border dark shadow color.
m_cr3DFace | RGB value for header background color.
m_cr3DHighLight | RGB value for border highlight color.
m_cr3DShadow | RGB value for border shadow color.
m_crText | RGB value for text color.
m_dwDrawStyle | Style flags used by theme, see CXTHeaderCtrlTheme::SetDrawStyle().
m_iArrowPadding | Spacing between text and sort arrow.
m_sizeArrow | Width and height of sort arrow.
m_sizePadding | Leading and trailing padding for text display.
m_themeWrapper | Wraps the Windows XP theme API that is used to display Windows XP themes.


Legend

Legend
CXTHexEdit Data Members
Legend
Data Member
protected


CXTHexEdit Data Members Protected Data Members

CXTHexEdit Data Members Protected Data Members
CXTHexEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bShowCaret | TRUE to display a flashing caret at the current caret position.
m_crBack | RGB value that represents the background color of the hex edit control.
m_crDisabledBack | RGB value that represents the disabled background color for the hex edit control.
m_crDisabledHighlightBack | RGB value that represents the disabled highlighted background color of the hex edit control.
m_crDisabledHighlightText | RGB value that represents the disabled highlighted text color of the hex edit control.
m_crDisabledText | RGB value that represents the disabled text color of the hex edit control.
m_crHighlightBack | RGB value that represents the highlighted background color of the hex edit control.
m_crHighlightText | RGB value that represents the highlighted text color of the hex edit control.
m_crText | RGB value that represents the text color of the hex edit control.
m_fontHex | Represents the default font used by the hex edit control.
m_szCaret | Current size of caret.


CXTHexEdit Data Members Public Data Members

CXTHexEdit Data Members Public Data Members
CXTHexEdit Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAddressIsWide | 4/8 byte address.
m_bAllowDeletes | A boolean value indicating whether or not deletions are allowed.
m_bDynamicBPR | Calculate bytes-per-row dynamically.
m_bShowAddress | TRUE when showing the address part.
m_bShowAscii | TRUE when showing the ASCII part.
m_bShowHex | TRUE when showing the hex part.
m_bUpdate | Value used internally to indicate that the font and size info need to be updated on the next paint cycle.
m_dwBaseAddress | Base address for data.
m_eEditMode | Current editing mode: address/hex/ASCII.
m_nBytePerRow | Bytes per row.
m_nCurrentAddress | Address under the cursor.
m_nLength | Length of data.
m_nLineHeight | Height in pixels of a single line displayed in the control.
m_nLinesPerPage | Lines per page.
m_nMaxLength | Maximum size of data.
m_nNullWidth | Width in pixels of a single character displayed in the control (uniform width).
m_nOffAddress | Internally used value - X position where address part starts.
m_nOffAscii | Internally used value - X position where ASCII part starts.
m_nOffHex | Internally used value - X position where hex part starts.
m_nSelEnd | End address of the selection.
m_nSelStart | Start address of the selection.
m_nTopIndex | Offset of first visible byte on the screen.
m_pData | Pointer to data.
m_ptEditPos | Current caret position.


Legend

Legend
CXTHtmlView Data Members
Legend
Data Member
protected


CXTHtmlView Data Members Protected Data Members

CXTHtmlView Data Members Protected Data Members
CXTHtmlView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bLoading | true when loading the browser.
m_bLoadingMessage | true to display a loading message while a page is updating.
m_pBrowserApp | Points to the IWebBrowser2 object associated with this view.
m_strLoading | Loading message string.


CXTHtmlView Data Members Public Data Members

CXTHtmlView Data Members Public Data Members
CXTHtmlView Data Members | Legend
Public Data Members
Public Data Member | Description
m_wndBrowser | CWnd object that represents the internet browser control associated with this view


Legend

Legend
CXTHyperLink Data Members
Legend
Data Member
protected


CXTHyperLink Data Members Protected Data Members

CXTHyperLink Data Members Protected Data Members
CXTHyperLink Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bMouseOver | Set to true when the cursor is hovering over the control.
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_bShellExec | true to cause the hyperlink to call ShellExecute for the specified URL.
m_bTipEnabled | Set to false to disable tooltips.
m_bUnderline | Set to true for underlined text.
m_bVisited | Set to true when the hyperlink has been activated.
m_clrBack | An RGB value representing the background fill color for the hyperlink control.
m_clrHover | An RGB value representing the color for the hyperlink text color when the mouse is hovering.
m_clrLink | An RGB value representing the color for the hyperlink text color.
m_clrVisited | An RGB value representing the color for the hyperlink text color when the URL has been visited.
m_font | Font used by hyperlink control.
m_hcurHand | Handle to the default cursor for this control.
m_strLink | String object that represents the URL for this control.
m_strTipText | String object that represents the tooltip text for this control.
m_toolTip | Tooltip to be displayed for the control.


Legend

Legend
CXTIconHandle Data Members
Legend
Data Member
protected


CXTIconHandle Data Members Protected Data Members

CXTIconHandle Data Members Protected Data Members
CXTIconHandle Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_hIcon | Handle to a dynamically created icon.


Legend

Legend
CXTItemEdit Data Members
Legend
Data Member
protected


CXTItemEdit Data Members Protected Data Members

CXTItemEdit Data Members Protected Data Members
CXTItemEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bClosePosted | Used internally to determine if a WM_CLOSE message has been sent.


CXTItemEdit Data Members Public Data Members

CXTItemEdit Data Members Public Data Members
CXTItemEdit Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAutoDelete | true if self deleting.
m_bEscapeKey | true if the edit window was closed with the escape key.
m_bModified | true if the item was modified.
m_strWindowText | The edit controls text.


Legend

Legend
CXTListBase Data Members
Legend
Data Member
protected


CXTListBase Data Members Protected Data Members

CXTListBase Data Members Protected Data Members
CXTListBase Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arRowColor | List of user defined text and background row colors.
m_bAscending | Flag to determine the sorting order.
m_bAutoFont | If true, the font will automatically be set for the control
m_bAutoSave | true if saving the column widths.
m_bListColor | true if user defined colors are used for background and text.
m_bNoColSizing | If true, column sizing is disabled.
m_bRowColor | true if rows are drawn with user defined colors.
m_bSortColor | true if the sorted column is drawn in color.
m_crListBack | RGB value representing the row text background color.
m_crListText | RGB value representing the row text color.
m_crSortBack | RGB value for sort column background color.
m_crSortText | RGB value for sort column text color.
m_flatHeader | Subclassed flat header control.
m_nMaxColWidth | Maximum width for columns.
m_nMinColWidth | Minimum width for columns.
m_nSortedCol | Index of the currently selected column.
m_pListCtrl | List control instance.
m_strDefault | Registry default value.
m_strEntry | Registry entry name.
m_strSection | Registry section name.


Legend

Legend
CXTListBox Data Members
Legend
Data Member
protected


CXTListBox Data Members Protected Data Members

CXTListBox Data Members Protected Data Members
CXTListBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nStyle | Listbox style;


Legend

Legend
CXTLogFont Data Members
Legend
Data Member


CXTLogFont Data Members Public Data Members

CXTLogFont Data Members Public Data Members
CXTLogFont Data Members | Legend
Public Data Members
Public Data Member | Description
dwType | Used to hold the font type, i.e.


Legend

Legend
CXTMaskEditT Data Members
Legend
Data Member
protected


CXTMaskEditT Data Members Protected Data Members

CXTMaskEditT Data Members Protected Data Members
CXTMaskEditT Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bModified | TRUE if mask edit has been modified.
m_bOverType | TRUE to over type the text, set with VK_INSERT key press.
m_bRedo | TRUE to redo, or FALSE to undo.
m_bUpdateUndo | TRUE to update undo
m_bUseMask | TRUE to use the edit mask.
m_chPrompt | Prompt character used to identify the text entry.
m_nEndChar | Current position of the first non-selected character past the end of the current selection.
m_nStartChar | Current position of the first character in the current selection.
m_strDefault | Contains the edit controls default display text.
m_strLiteral | Literal format that restricts where the user can enter text.
m_strMask | Buffer that holds the actual edit mask value.
m_strRedoBuffer | Holds the contents of the redo buffer.
m_strUndoBuffer | Holds the contents of the undo buffer.
m_strWindowText | Buffer that holds the actual edit text.


Legend

Legend
CXTMDIClientWnd Data Members
Legend
Data Member
protected


CXTMDIClientWnd Data Members Protected Data Members

CXTMDIClientWnd Data Members Protected Data Members
CXTMDIClientWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_iBorderGap | Amount in pixels between the client and the tab control.
m_pMDIWndTab | Pointer to the MDI tab control.


Legend

Legend
CXTMDIWndTab Data Members
Legend
Data Member
protected


CXTMDIWndTab Data Members Protected Data Members

CXTMDIWndTab Data Members Protected Data Members
CXTMDIWndTab Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arMDIChildern | Array of the MDI windows added to the tab control.
m_bNoIcons | TRUE if no icons are used.
m_dwInitSignature | Initialization state signature to synch up posted init requests.
m_hActiveChild | Active MDI child.
m_iBorderGap | Amount in pixels between the client and the tab control.
m_iHitTest | Index of the tab that received a right click.
m_imageList | Tab image list.
m_mapTabIcons | Hash table that maps icons to the MDI child frame windows.
m_mapTabLabels | Hash table that maps labels to the MDI child frame windows.
m_nDefCmd | Command ID of the default menu item for the popup menu.
m_nPos | Index of the popup menu contained in the menu.
m_pMDIClientWnd | Window that receives messages on behalf of the MDI client.
m_pMDIFrameWnd | Points to the owner frame.
m_popupMenuID | Popup menu resource ID.


Legend

Legend
CXTMemDC Data Members
Legend
Data Member
protected


CXTMemDC Data Members Protected Data Members

CXTMemDC Data Members Protected Data Members
CXTMemDC Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bitmap | Off screen bitmap.
m_bValid | Flag used for autodraw in destructor.
m_hOldBitmap | Original GDI object.
m_pDC | Saves the CDC passed in constructor.
m_rc | Rectangle of the drawing area.


Legend

Legend
CXTMenuListBox Data Members
Legend
Data Member
protected


CXTMenuListBox Data Members Protected Data Members

CXTMenuListBox Data Members Protected Data Members
CXTMenuListBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arContentItems | Array of CONTENT_ITEM structs that represent each item in the Outlook bar.
m_bHilight | true when the menu item is selected.
m_bHilightItemID | Index of the currently highlighted item, set to -1 if no selection.
m_bTimerActive | true if the redraw timer is active.
m_hCursor | Cursor display when item is hovered.
m_nPrevIndex | Previously selected menu index.
m_point | Holds the cursor position.


CXTMenuListBox Data Members Public Data Members

CXTMenuListBox Data Members Public Data Members
CXTMenuListBox Data Members | Legend
Public Data Members
Public Data Member | Description
m_bNoBorder | true to disable a border drawn around highlighted items.
m_bNoUnderline | true if the text is not drawn with a underline when no highlight border is displayed.


Legend

Legend
CXTMenuListBoxTheme Data Members
Legend
Data Member


CXTMenuListBoxTheme Data Members Public Data Members

CXTMenuListBoxTheme Data Members Public Data Members
CXTMenuListBoxTheme Data Members | Legend
Public Data Members
Public Data Member | Description
m_cxIcon | Width of the menu icon.
m_cyEdge | Height in pixels of the space between the icon an text.
m_cyIcon | Height of the menu icon.


Legend

Legend
CXTOutBarCtrl Data Members
Legend
Data Member
protected


CXTOutBarCtrl Data Members Protected Data Members

CXTOutBarCtrl Data Members Protected Data Members
CXTOutBarCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arFolder | Array of folders added to the outlook bar.
m_bDownArrow | TRUE when the down scroll arrow is displayed.
m_bDownPressed | TRUE when the down scroll arrow is selected.
m_bIconPressed | TRUE when the selected item's icon should be rendered selected.
m_bLooping | TRUE when scrolling to continue iteration.
m_bPressedHighlight | TRUE when the selected item should be rendered.
m_bUpArrow | TRUE when the up scroll arrow is displayed.
m_bUpPressed | TRUE when the up scroll arrow is selected.
m_dwFlags | Style for the Outlook bar.
m_font | Font used by the outlook bar.
m_nAnimationTickCount | Specifies the time in milliseconds between animation.
m_nFirstItem | Index of the first visible item.
m_nFolderHeight | Size in pixels of the folder caption bar.
m_nFolderHilighted | Index of the currently highlighted folder.
m_nHitInternal1 | Used internally to test folder and item indexes.
m_nHitInternal2 | Used internally to test folder and item indexes.
m_nIconSpacingLarge | Amount in pixels of the gap between large icons.
m_nIconSpacingSmall | Amount in pixels of the gap between small icons.
m_nItemHilighted | Index of the currently highlighted item.
m_nLastDragItemDraw | Insertion index for drag and drop operations.
m_nLastDragItemDrawType | Style of last drag item that was rendered.
m_nLastFolderSelected | Index of the last folder that was selected.
m_nLastItemSelected | Index of the last item that was selected.
m_nSelAnimCount | Selected item animation sequence count
m_nSelAnimTiming | Specifies the time in milliseconds that the selected item will animate.
m_nSelFolder | Index of the currently selected folder.
m_penBlack | Pen used to render drag arrow.
m_pLargeImageList | Points to the large image list for the outlook bar.
m_pSmallImageList | Points to the small image list for the outlook bar.
m_rcDownArrow | Size and location of the down scroll arrow.
m_rcUpArrow | Size and location of the up scroll arrow.
m_sizeMargin | Amount in pixels of the gap between the border and item text and icon.
m_sizeOffset | Amount in pixels of the gap between an item icon and text.


Legend

Legend
CXTOutBarCtrlTheme Data Members
Legend
Data Member
protected


CXTOutBarCtrlTheme Data Members Protected Data Members

CXTOutBarCtrlTheme Data Members Protected Data Members
CXTOutBarCtrlTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bFlatIcon | Set this to TRUE to draw flat icons.
m_bPlainText | Set to TRUE to draw plain text.


CXTOutBarCtrlTheme Data Members Public Data Members

CXTOutBarCtrlTheme Data Members Public Data Members
CXTOutBarCtrlTheme Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrBack | The color used to draw the background of the OutBar.
m_clrText | The color used to draw the text on the OutBar.


Legend

Legend
CXTOutBarCtrlThemeOffice2003 Data Members
Legend
Data Member
protected


CXTOutBarCtrlThemeOffice2003 Data Members Protected Data Members

CXTOutBarCtrlThemeOffice2003 Data Members Protected Data Members
CXTOutBarCtrlThemeOffice2003 Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bLunaTheme | TRUE if the current theme is a Luna Theme.
m_grcHot | The hot gradient color.
m_grcPushed | The pushed gradient color.
m_grcSelected | The selected gradient color.


Legend

Legend
CXTOutBarEditItem Data Members
Legend
Data Member
protected


CXTOutBarEditItem Data Members Protected Data Members

CXTOutBarEditItem Data Members Protected Data Members
CXTOutBarEditItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bEscapeKey | true if the escape key was pressed.
m_bIsFolder | true if the edit box is for a folder.
m_bSmallIcons | true if the folder is using small icons.
m_iIndex | Index of the folder or item.
m_pParentWnd | Parent Outlook bar control.
m_rcOriginal | Original size of the edit box when it was first created.
m_strText | Original string of the edit box when it was first created, and the new text on edit completion.


Legend

Legend
CXTOutBarFolder Data Members
Legend
Data Member
protected


CXTOutBarFolder Data Members Protected Data Members

CXTOutBarFolder Data Members Protected Data Members
CXTOutBarFolder Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_barItems | Folder items.
m_bSmallIcons | TRUE to use small icons.
m_dwData | Application data.
m_pChild | Child window pointer.
m_pControl | Pointer to the parent CXTOutBarCtrl object.
m_pLargeList | Image list for large icons.
m_pSmallList | Image list for small icons.
m_strName | Folder label.


Legend

Legend
CXTOutBarItem Data Members
Legend
Data Member
protected


CXTOutBarItem Data Members Protected Data Members

CXTOutBarItem Data Members Protected Data Members
CXTOutBarItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bEnabled | true if the icon is enabled.
m_bSelected | true if selected.
m_dwData | User data.
m_nIndex | Item index.
m_strName | label of the folder item.


Legend

Legend
CXTPBitmapDC Data Members
Legend
Data Member
protected


CXTPBitmapDC Data Members Protected Data Members

CXTPBitmapDC Data Members Protected Data Members
CXTPBitmapDC Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_hDC | Device context handle.
m_hOldBitmap | Handle to the previously selected bitmap.


Legend

Legend
CXTPBrushDC Data Members
Legend
Data Member
protected


CXTPBrushDC Data Members Protected Data Members

CXTPBrushDC Data Members Protected Data Members
CXTPBrushDC Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_brush | Brush selected into device context.
m_hDC | Device context handle.
m_hOldBrush | Handle to the previously selected brush.


Legend

Legend
CXTPBufferDC Data Members
Legend
Data Member
protected


CXTPBufferDC Data Members Protected Data Members

CXTPBufferDC Data Members Protected Data Members
CXTPBufferDC Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bitmap | Bitmap in memory device context
m_hDestDC | Handle to the destination device context.
m_hOldBitmap | Handle to the previously selected bitmap.
m_rect | Size of the area to paint.


Legend

Legend
CXTPBufferDCEx Data Members
Legend
Data Member
protected


CXTPBufferDCEx Data Members Protected Data Members

CXTPBufferDCEx Data Members Protected Data Members
CXTPBufferDCEx Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bitmap | Bitmap in memory device context
m_hDestDC | Handle to the destination device context.
m_hOldBitmap | Handle to the previously selected bitmap.
m_rect | Size of the area to paint.


Legend

Legend
CXTPCalendarControl Data Members
Legend
Data Member
protected


CXTPCalendarControl Data Members Protected Data Members

CXTPCalendarControl Data Members Protected Data Members
CXTPCalendarControl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bUpdateWhenEventChangedNotify | Whether to update control when notification comes about an event change.
m_cntViewChanged | Locker context for CViewChangedContext.
m_nRowsPerWheel | Amount of rows to scroll when using the mouse wheel.
m_pRemindersManager | Stores reminders manager object.
m_strRedoUIText | Text label for the Redo UI command.
m_strUndoUIText | Text label for the Undo UI command.


CXTPCalendarControl Data Members Public Data Members

CXTPCalendarControl Data Members Public Data Members
CXTPCalendarControl Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDeleteOnFinalRelease | If TRUE - Delete self OnFinalRelease() call.
m_bDisableRedraw | If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).
m_mouseMode | Current mouse operation mode.


Legend

Legend
CViewChanged_ContextData Data Members
Legend
Data Member


CViewChanged_ContextData Data Members Public Data Members

CViewChanged_ContextData Data Members Public Data Members
CViewChanged_ContextData Data Members | Legend
Public Data Members
Public Data Member | Description
m_bRequest | View change send notification request.
m_nLockCount | View change notification lock counter.


Legend

Legend
CXTPCalendarController Data Members
Legend
Data Member
protected


CXTPCalendarController Data Members Protected Data Members

CXTPCalendarController Data Members Protected Data Members
CXTPCalendarController Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bBoldDaysOnIdle | TRUE to retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
m_bBoldDaysWithEvents | TRUE to use Bold for days with events in the associated DatePicker.
m_bUseActiveViewResoucesForBold | If true - active view resources are used, if FALSE - calendar control Resources are used.
m_nBoldDaysIdleStepTime_ms | Time between idle steps to update days state (bold or regular) for the associated DatePicker.
m_nBoldDaysPerIdleStep | Amount of days for the associated DatePicker to update state in one idle step.
m_pCalendarCtrl | Pointer to the associated Calendar control.
m_pDatePickerCtrl | Pointer to the associated DatePicker control.


Legend

Legend
CXTPCalendarControlView Data Members
Legend
Data Member
protected


CXTPCalendarControlView Data Members Protected Data Members

CXTPCalendarControlView Data Members Protected Data Members
CXTPCalendarControlView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bShowCaptionBar | Store Office 2007 theme Calendar Caption Bar state.
m_pPrintOptions | Printing options.


CXTPCalendarControlView Data Members Public Data Members

CXTPCalendarControlView Data Members Public Data Members
CXTPCalendarControlView Data Members | Legend
Public Data Members
Public Data Member | Description
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bResizeControlWithView | if FALSE - attached Calendar control will not be resized with view.


Legend

Legend
CXTPCalendarControlViewPrintOptions Data Members
Legend
Data Member


CXTPCalendarControlViewPrintOptions Data Members Public Data Members

CXTPCalendarControlViewPrintOptions Data Members Public Data Members
CXTPCalendarControlViewPrintOptions Data Members | Legend
Public Data Members
Public Data Member | Description
m_bPrintDateHeader | Defines whether to print a date header or not.
m_bPrintFromToExactly | Defines whether to cut printing area by showing only area between m_dtPrintFrom and m_dtPrintTo
m_dtPrintFrom | Top bound of the printing area for a day view.
m_dtPrintTo | Bottom bound of the printing area for a day view.
m_lfDateHeaderCalendarFont | Font for day header small calendar.
m_lfDateHeaderFont | Font for day header caption (Day 1 - Day 2)
m_lfDateHeaderWeekDayFont | Font for day header week day(Monday, ...)


Legend

Legend
CXTPCalendarCustomProperties Data Members
Legend
Data Member
protected


CXTPCalendarCustomProperties Data Members Protected Data Members

CXTPCalendarCustomProperties Data Members Protected Data Members
CXTPCalendarCustomProperties Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bNameIgnoreCase | if TRUE - properties names are not case sensitive.
m_mapProperties | Properties storage map.


Legend

Legend
CXTPCalendarData Data Members
Legend
Data Member
protected


CXTPCalendarData Data Members Protected Data Members

CXTPCalendarData Data Members Protected Data Members
CXTPCalendarData Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bDisableNotificationsSending | Stores a flag whether notifications sending is disabled.
m_bOpened | Stores a flag whether a data source connection is open
m_cache | Common data provider cache.
m_pCalendarOptions | This member stores user's calendar view options.
m_pConnect | Connection object to send notifications.
m_pCustomProperties | Custom properties collection object.
m_pEventCategories | Store a collection of Event categories.
m_pLabelList | Event labels list.
m_pSchedules | Data source Schedules list
m_strConnectionString | default connection string;
m_typeProvider | Data provider type.
ms_dwNextFreeTempID | Next unique event ID.


Legend

Legend
CXTPDPCache Data Members
Legend
Data Member
protected


CXTPDPCache Data Members Protected Data Members

CXTPDPCache Data Members Protected Data Members
CXTPDPCache Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_mapIsDayInCache | whether events for this day are already stored in cache


CXTPDPCache Data Members Public Data Members

CXTPDPCache Data Members Public Data Members
CXTPDPCache Data Members | Legend
Public Data Members
Public Data Member | Description
m_eCacheMode | see XTPCalendarDataProviderCacheMode
m_pCacheDP | Cache Data Provider.


Legend

Legend
EventsMapByID_T Data Members
Legend
Data Member
protected


EventsMapByID_T Data Members Protected Data Members

EventsMapByID_T Data Members Protected Data Members
EventsMapByID_T Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_mapID2Object | The map of ID to object.


Legend

Legend
CXTPCalendarDatabaseDataProvider Data Members
Legend
Data Member
protected


CXTPCalendarDatabaseDataProvider Data Members Protected Data Members

CXTPCalendarDatabaseDataProvider Data Members Protected Data Members
CXTPCalendarDatabaseDataProvider Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bTraceOptions | Indicates whether there should be only one record in the options table, or every save should add the new one.


Legend

Legend
CXTPCalendarDayView Data Members
Legend
Data Member
protected


CXTPCalendarDayView Data Members Protected Data Members

CXTPCalendarDayView Data Members Protected Data Members
CXTPCalendarDayView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nMinColumnWidth | 0 means disabled; -1 use some default width for multiresources only; -N use for multiresources only (internally converted to +N); +N used always (in single and multi resources mode).
m_nScrollOffsetX | Stores horizontal left offset of visible day view part.


Legend

Legend
CXTPCalendarDayViewEvent Data Members
Legend
Data Member


CXTPCalendarDayViewEvent Data Members Public Data Members

CXTPCalendarDayViewEvent Data Members Public Data Members
CXTPCalendarDayViewEvent Data Members | Legend
Public Data Members
Public Data Member | Description
m_bHideEventTime | Flag determines if event time should not be displayed.
m_rcTimeframe | Rectangle area to display times.


Legend

Legend
CXTPCalendarDayViewGroup Data Members
Legend
Data Member
protected


CXTPCalendarDayViewGroup Data Members Protected Data Members

CXTPCalendarDayViewGroup Data Members Protected Data Members
CXTPCalendarDayViewGroup Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bExpandDOWN | Store is ExpandDOWN sign visible.
m_bExpandUP | Store is ExpandUP sign visible.
m_LayoutX | Store group view layout.


Legend

Legend
CXTPCalendarDayViewTimeScale Data Members
Legend
Data Member
protected


CXTPCalendarDayViewTimeScale Data Members Protected Data Members

CXTPCalendarDayViewTimeScale Data Members Protected Data Members
CXTPCalendarDayViewTimeScale Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bDrawNowLine | Specifies whether we should draw the "Now" line on the time scale.
m_bVisible | Show this timescale or not.
m_Layout | Store time scale layout.
m_nTimeshift_min | Time zone time shift in minutes.
m_pDayView | Pointer to the parent Calendar Day view object.
m_strCaption | Caption under time scale.


Legend

Legend
CXTPCalendarEvent Data Members
Legend
Data Member
protected


CXTPCalendarEvent Data Members Protected Data Members

CXTPCalendarEvent Data Members Protected Data Members
CXTPCalendarEvent Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAllDayEvent | Is this an all day event value.
m_bMeeting | Boolean flag that is used to indicate if an event is a meeting.
m_bPrivate | Boolean flag that is used to indicate if an event is a private meeting.
m_bReminder | This flag value indicates is the Reminder enabled or not.
m_bRExceptionDeleted | Is Recurrence Exception deleted.
m_dtCreationTime | Creation event time value.
m_dtEndTime | End event time value.
m_dtLastModificationTime | Last Modification event time value.
m_dtRException_EndTimeOrig | Original end time of Recurrence exception event.
m_dtRException_StartTimeOrig | Original start time of Recurrence exception event.
m_dtStartTime | Start event time value.
m_dwEventID | ID of this event object.
m_dwRecurrencePatternID | Recurrence Pattern ID.
m_dwRecurrencePatternID_ToUse | Previously used pattern ID.
m_nBusyStatus | Event Busy Status value.
m_nImportance | Event Importance value.
m_nLabelID | Label ID.
m_nRecurrenceState | Event Recurrence State.
m_nReminderMinutesBeforeStart | Reminder time value.
m_pCustomIconsIDs | An array to store custom icons id's assigned to event.
m_pCustomProperties | Custom properties collection object.
m_pDataProvider | Pointer to the owner data provider.
m_pEventCategoryIDs | An array to store categories id's assigned to event.
m_ptrRPattern | Recurrence Pattern object for a master event only.
m_strBody | Body value.
m_strLocation | Location value.
m_strReminderSoundFile | Reminder sound file path.
m_strSubject | Subject value.
m_uScheduleID | ID of the corresponding Schedule.


Legend

Legend
CXTPCalendarEventCategory Data Members
Legend
Data Member
protected


CXTPCalendarEventCategory Data Members Protected Data Members

CXTPCalendarEventCategory Data Members Protected Data Members
CXTPCalendarEventCategory Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrBkBase | Stores Base color to calculate few background colors for event background and other elements.
m_clrBorder | Stores Event border color.
m_grclrBackground | Stores an event background gradient color.
m_nID | Stores category identifier.
m_strName | Stores category name.


Legend

Legend
CXTPCalendarEventLabel Data Members
Legend
Data Member


CXTPCalendarEventLabel Data Members Public Data Members

CXTPCalendarEventLabel Data Members Public Data Members
CXTPCalendarEventLabel Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrColor | Label color used to fill the event background.
m_nLabelID | Label ID.
m_strName | Label name.


Legend

Legend
CXTPCalendarEvents Data Members
Legend
Data Member
protected


CXTPCalendarEvents Data Members Protected Data Members

CXTPCalendarEvents Data Members Protected Data Members
CXTPCalendarEvents Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arEvents | An internal storage for CXTPCalendarEvent pointers.


Legend

Legend
CXTPCalendarMonthView Data Members
Legend
Data Member
protected


CXTPCalendarMonthView Data Members Protected Data Members

CXTPCalendarMonthView Data Members Protected Data Members
CXTPCalendarMonthView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_DayPOS_LastSelected | Last selected day positions.
m_nEventCaptionFormat | Event caption format flags are stored in packed form by bitwise operations.
m_nEventTimeWidth | width of the area to display the event times.
m_pGrid | Pointer to the grid object.
m_strLongDateFormat | String of the long date format.
m_strSmallDateFormat | String of the short date format.


Legend

Legend
CMonthViewGrid Data Members
Legend
Data Member
protected


CMonthViewGrid Data Members Protected Data Members

CMonthViewGrid Data Members Protected Data Members
CMonthViewGrid Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arColHeaderText | Array of columns (week days) headers names.
m_arColsLeftX | Array of columns left borders positions.
m_arRowsTopY | Array of rows top borders positions.
m_dtBeginDate | First Cell (cell [0, 0]) date in the grid.
m_nColHeaderHeight | Column header height in pixels.
m_nFirstDayOfWeekIndex | First Day Of Week index: 1-Sunday, 2-Monday ...
m_nWeeksCount | The number of weeks that are displayed.
m_pView | Pointer to the parent view class.


Legend

Legend
CXTPCalendarMonthViewDay Data Members
Legend
Data Member
protected


CXTPCalendarMonthViewDay Data Members Protected Data Members

CXTPCalendarMonthViewDay Data Members Protected Data Members
CXTPCalendarMonthViewDay Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nWeekDayIndex | Day identifier.
m_nWeekIndex | Week identifier.


Legend

Legend
CXTPCalendarOccurSeriesChooseDlg Data Members
Legend
Data Member
protected


CXTPCalendarOccurSeriesChooseDlg Data Members Protected Data Members

CXTPCalendarOccurSeriesChooseDlg Data Members Protected Data Members
CXTPCalendarOccurSeriesChooseDlg Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_ctrlIcon | Dialog icon control.
m_ctrlMessage | Dialog message text control.
m_ctrlOccur | Occurrence radio button control.
m_ctrlSeries | Series radio button control.
m_hIcon | Dialog icon resource ID.
m_nIDResourceLabels | Dialog labels string resource ID.
m_strMessage | Dialog message text prepared string.
m_strOccur | Occurrence radio button label text string.
m_strSeries | Series radio button label text string.
m_strTitle | Dialog title string.


CXTPCalendarOccurSeriesChooseDlg Data Members Public Data Members

CXTPCalendarOccurSeriesChooseDlg Data Members Public Data Members
CXTPCalendarOccurSeriesChooseDlg Data Members | Legend
Public Data Members
Public Data Member | Description
m_bOccur | in/out] Contain default/selected choice.


Legend

Legend
CXTPCalendarOptions Data Members
Legend
Data Member
protected


CXTPCalendarOptions Data Members Protected Data Members

CXTPCalendarOptions Data Members Protected Data Members
CXTPCalendarOptions Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pDataProvider | A stored pointer to the owner data provider.


CXTPCalendarOptions Data Members Public Data Members

CXTPCalendarOptions Data Members Public Data Members
CXTPCalendarOptions Data Members | Legend
Public Data Members
Public Data Member | Description
bDayView_AutoResetBusyFlag | If TRUE - 'Busy' event status will be automatically set to 'Free' when moving event from hours area to all day events area and vice versa.
bDayView_Scale2Visible | TRUE when secondary time scale is visible in day view, FALSE otherwise.
bDayView_TimeScaleShowMinutes | If TRUE - minutes will be shown on time scale.
bEnableAddNewTooltip | TRUE when "add new appointment" tooltips appears, FALSE otherwise
bEnableInPlaceCreateEvent | Set TRUE to enable in-place event creation, FALSE otherwise.
bEnableInPlaceEditEventSubject_AfterEventResize | Set TRUE to enable in-place edit event subject after event resize, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByF2 | Set TRUE to enable in-place edit event subject by F2, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByMouseClick | Set TRUE to enable in-place edit event subject by Mouse Click, FALSE otherwise.
bEnableInPlaceEditEventSubject_ByTab | Set TRUE to enable in-place edit event subject by TAB, FALSE otherwise.
bEnablePrevNextEventButtons | TRUE when "Prev/Next Appointment" buttons are enabled, FALSE otherwise
bMonthView_CompressWeekendDays | TRUE when compressing weekend days in month view, FALSE otherwise.
bMonthView_ShowEndDate | TRUE when showing event end date in month view, FALSE otherwise.
bMonthView_ShowTimeAsClocks | TRUE when showing event time as graphical clocks in month view, FALSE otherwise.
bUseOutlookFontGlyphs | Set TRUE to use 'MS Outlook' font to display Glyps, otherwise bitmaps are used.
bWeekView_ShowEndDate | TRUE when showing event end date in week view, FALSE otherwise.
bWeekView_ShowTimeAsClocks | TRUE when showing event time as graphical clocks in week view, FALSE otherwise.
dtWorkDayEndTime | This member contains work day end time.
dtWorkDayStartTime | This member contains work day start time.
dwAdditionalOptions | Additional calendar options.
nDayView_CurrentTimeMarkVisible | A set of flags which define when Current Time Mark on the timescale is visible.
nDayView_ScaleInterval | DayView scale interval in minutes.
nFirstDayOfTheWeek | This member shows the first day of the week using XTPCalendarWeekDay enum.
nWorkWeekMask | This structure member represents week working days using XTPCalendarWeekDay enumeration.
strDayView_Scale2Label | Stores secondary time scale label (day view)
strDayView_ScaleLabel | Stores main time scale label (day view)
strTooltipAddNewText | Text for "add new appointment" tooltip.
tziDayView_Scale2TimeZone | Stores time zone information for the secondary time scale.


Legend

Legend
CXTPCalendarPageSetupDialog Data Members
Legend
Data Member
protected


CXTPCalendarPageSetupDialog Data Members Protected Data Members

CXTPCalendarPageSetupDialog Data Members Protected Data Members
CXTPCalendarPageSetupDialog Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_ctrlBlackWhitePrinting | A check box for editing CXTPCalendarControlViewPrintOptions::m_bBlackWhitePrinting value
m_ctrlDateHeaderFont | A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value
m_ctrlDateHeaderFontButton | A button for choosing CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value
m_ctrlDateHeaderFontLabel | A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont caption
m_ctrlFooterFormat | An edit for footer format string
m_ctrlFooterFormatBtn | A button to show footer specifiers menu
m_ctrlHeaderFormat | An edit for header format string
m_ctrlHeaderFormatBtn | A button to show header specifiers menu
m_ctrlPrintDateHeader | A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader value
m_ctrlPrintFromCmb | A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintFrom value
m_ctrlPrintFromTo | A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly value
m_ctrlPrintToCmb | A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintTo value
m_lfDateHeader | Date header font temporary storage
m_pOptions | Pointer to associated print options object.


Legend

Legend
CXTPCalendarPaintManager Data Members
Legend
Data Member
protected


CXTPCalendarPaintManager Data Members Protected Data Members

CXTPCalendarPaintManager Data Members Protected Data Members
CXTPCalendarPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arBusyStatusBrushes | Stores customizable brush values to draw Event Busy Status in the Day View.
m_bEnableTheme | True to enable Luna theme.
m_bmpTentativePattern | Stores standard bitmap pattern to draw Tentative event busy status.
m_brushTentative | Stores standard brush to draw Tentative event busy status.
m_clrUnderLineHdr | Color of header's underline.
m_CurrSystemTheme | Current theme flag.
m_dwAskItemTextFlags | Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.
m_ilExpandSigns | Stores standard Expand Signs icons.
m_ilGlyphs | Stores standard glyphs for displaying events.
m_lstViewParts | Collection to store ViewParts objects.
m_nPaintTheme | Store the Paint Theme;
m_pControl | Stores a pointer to a CXTPCalendarControl object.
m_pGlyphsFont | Stores standard glyphs font for displaying events.
m_szClockRect | Stores dimensions for a rectangle used to display the time as a clock glyph.


CXTPCalendarPaintManager Data Members Public Data Members

CXTPCalendarPaintManager Data Members Public Data Members
CXTPCalendarPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_clr3DShadow | Stores standard color to display shadow items.
m_clrButtonFace | Stores standard Button Face color.
m_clrButtonFaceText | Stores standard color to display text.
m_clrHighlight | Stores standard color to display highlighted items.
m_clrWindow | Stores standard windows color.
m_clrWindowText | Stores standard color to display window text.
m_grclrToday | Gradient color of today's header.


Legend

Legend
CDayMonthViewHeaderPart Data Members
Legend
Data Member


CDayMonthViewHeaderPart Data Members Public Data Members

CDayMonthViewHeaderPart Data Members Public Data Members
CDayMonthViewHeaderPart Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrTopLeftBorder | Top and Left borders color.


Legend

Legend
CDayViewCellPart Data Members
Legend
Data Member


CDayViewCellPart Data Members Public Data Members

CDayViewCellPart Data Members Public Data Members
CDayViewCellPart Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrHour | Cell border color.
m_clrShadow | Cell background color.


Legend

Legend
CDayViewTimeScaleCellPart Data Members
Legend
Data Member


CDayViewTimeScaleCellPart Data Members Public Data Members

CDayViewTimeScaleCellPart Data Members Public Data Members
CDayViewTimeScaleCellPart Data Members | Legend
Public Data Members
Public Data Member | Description
m_fntTimeText | Time text font.
m_nHourWidth | Width of hour part of the text in pixels.
m_nMinWidth | Width of minutes (am/pm) part of the text in pixels.


Legend

Legend
CMonthViewEventPart Data Members
Legend
Data Member


CMonthViewEventPart Data Members Public Data Members

CMonthViewEventPart Data Members Public Data Members
CMonthViewEventPart Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrClassicUnderline | Underline color for today day.
m_clrMultiDayEventFrameColor | Multi-day event frame color.
m_clrTextHighLightColor | Text color for the selected event.
m_grclrClassicSelDay | Gradient color for today day.


Legend

Legend
CMonthViewGridPart Data Members
Legend
Data Member


CMonthViewGridPart Data Members Public Data Members

CMonthViewGridPart Data Members Public Data Members
CMonthViewGridPart Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrBackground2 | Second background color which is used to fill days background.


Legend

Legend
CWeekViewEventPart Data Members
Legend
Data Member


CWeekViewEventPart Data Members Public Data Members

CWeekViewEventPart Data Members Public Data Members
CWeekViewEventPart Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrTextHighLightColor | Text color for the selected event.
m_clrTextNormalColor | Text color for the event.


Legend

Legend
CWeekViewPart Data Members
Legend
Data Member


CWeekViewPart Data Members Public Data Members

CWeekViewPart Data Members Public Data Members
CWeekViewPart Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrHeaderBottomLine | Text color for the day header bottom line.
m_clrTextHighLightColor | Text color for the selected day header.
m_clrTextNormalColor | Text color for the day header and some other elements.


Legend

Legend
CXTPShadowDrawer Data Members
Legend
Data Member
protected


CXTPShadowDrawer Data Members Protected Data Members

CXTPShadowDrawer Data Members Protected Data Members
CXTPShadowDrawer Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dMaxAlpha | maximal shadow alpha grade
m_pDC | drawing device context


Legend

Legend
CXTPCalendarPtrCollectionT Data Members
Legend
Data Member
protected


CXTPCalendarPtrCollectionT Data Members Protected Data Members

CXTPCalendarPtrCollectionT Data Members Protected Data Members
CXTPCalendarPtrCollectionT Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arElements | Objects storage.


Legend

Legend
CXTPCalendarReminder Data Members
Legend
Data Member
protected


CXTPCalendarReminder Data Members Protected Data Members

CXTPCalendarReminder Data Members Protected Data Members
CXTPCalendarReminder Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dtEventStartTime | Store related event start time.
m_dtNextReminderTime | Store reminder activation date and time.
m_eEventType | Define related event type: recurrence or non-recurrence.
m_nMinutesBeforeStart | Store minutes before start event to activate reminder.
m_pEventDataProvider | Store related event data provider.


Legend

Legend
CXTPCalendarReminderForOccurrence Data Members
Legend
Data Member


CXTPCalendarReminderForOccurrence Data Members Public Data Members

CXTPCalendarReminderForOccurrence Data Members Public Data Members
CXTPCalendarReminderForOccurrence Data Members | Legend
Public Data Members
Public Data Member | Description
m_dtNextReminderTime_Snoozed | Date/time of the next reminder event.
m_dtOccurrenceEndTime | End time of the described occurrence.
m_dtOccurrenceStartTime | Start time of the described occurrence.
m_nbIsReminder | XTPEnumCalendarReminderForOccurrenceParameters


Legend

Legend
CXTPCalendarRemindersManager Data Members
Legend
Data Member
protected


CXTPCalendarRemindersManager Data Members Protected Data Members

CXTPCalendarRemindersManager Data Members Protected Data Members
CXTPCalendarRemindersManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arActiveReminders | Active reminders collection.
m_arWaitingReminders | Waiting reminders collection.
m_bMonitoringRunning | Flag indicate that reminders manager is started;
m_dtLastUpdateTime | Store last time when reminders data was loaded from the calendar resources.
m_pConnection | A pointer to the notification connection object.
m_pResourcesNf | A collection of calendar resources to be monitored.
m_spPeriod2Cache | Time period to cache data from the calendar resources.


Legend

Legend
CXTPCalendarResource Data Members
Legend
Data Member
protected


CXTPCalendarResource Data Members Protected Data Members

CXTPCalendarResource Data Members Protected Data Members
CXTPCalendarResource Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arScheduleIDs | which schedules are used for this resource.
m_bCloseDataProviderWhenDestroy | If TRUE - call Close() method if the data provider when control is destroyed.
m_pCalendarCtrl | Parent Calendar control
m_pDataProvider | Associated data provider
m_strResourceName | Text name of the resource


Legend

Legend
CXTPCalendarResourceDescription Data Members
Legend
Data Member


CXTPCalendarResourceDescription Data Members Public Data Members

CXTPCalendarResourceDescription Data Members Public Data Members
CXTPCalendarResourceDescription Data Members | Legend
Public Data Members
Public Data Member | Description
m_bEnabled | This flag indicates is resource enabled.
m_bGenerateName | This flag indicates that resource name should be generated from the schedule(s) name(s).
m_ptrResource | A smart pointer to the resource object.


Legend

Legend
CXTPCalendarResourcesManager Data Members
Legend
Data Member
protected


CXTPCalendarResourcesManager Data Members Protected Data Members

CXTPCalendarResourcesManager Data Members Protected Data Members
CXTPCalendarResourcesManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arDataProviders | Data providers collection.
m_arResources | Resources collection.


Legend

Legend
CXTPCalendarSchedule Data Members
Legend
Data Member
protected


CXTPCalendarSchedule Data Members Protected Data Members

CXTPCalendarSchedule Data Members Protected Data Members
CXTPCalendarSchedule Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pCustomProperties | Stores custom properties collection for this Schedule
m_strScheduleName | Stores Schedule Name
m_uScheduleID | Stores numeric positive ID of the schedule


Legend

Legend
CXTPCalendarThemeCustomizableXValueT Data Members
Legend
Data Member
protected


CXTPCalendarThemeCustomizableXValueT Data Members Protected Data Members

CXTPCalendarThemeCustomizableXValueT Data Members Protected Data Members
CXTPCalendarThemeCustomizableXValueT Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoDestroy_Custom | Call DoDestroy for custom vale.
m_bAutoDestroy_Standard | Call DoDestroy for standard vale.
m_bIsCustomSet | Is custom value set.
m_bIsStandardSet | Is standard value set.
m_ValueCustom | Stores custom value.
m_ValueStandard | Stores default value.


Legend

Legend
CXTPCalendarTimeScalePropertiesDlg Data Members
Legend
Data Member
protected


CXTPCalendarTimeScalePropertiesDlg Data Members Protected Data Members

CXTPCalendarTimeScalePropertiesDlg Data Members Protected Data Members
CXTPCalendarTimeScalePropertiesDlg Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arTimeZones | A collection of timezones.
m_bAutoAdjustDayLight2 | A BOOL member which used to edit 'Auto Adjust Day Light' option for additional timezone
m_btnAutoAdjustDayLight1 | A check box control to show 'Auto Adjust Day Light' option for main timezone
m_btnAutoAdjustDayLight2 | A check box control to edit 'Auto Adjust Day Light' option for additional timezone
m_cmbZones1 | A combobox to display main time zone
m_cmbZones2 | A combobox to edit additional time zone
m_edtCaption1 | An edit control for main time zone caption
m_edtCaption2 | An edit control for additional time zone caption


CXTPCalendarTimeScalePropertiesDlg Data Members Public Data Members

CXTPCalendarTimeScalePropertiesDlg Data Members Public Data Members
CXTPCalendarTimeScalePropertiesDlg Data Members | Legend
Public Data Members
Public Data Member | Description
m_bShowScale2 | in, out] Store is additional timescale used or not.
m_strCaption1 | in, out] Store Caption string for main timescale.
m_strCaption2 | in, out] Store Caption string for additional timescale.
m_tziScale2 | in, out] Store additional timescale data.


Legend

Legend
CXTPCalendarTimeZone Data Members
Legend
Data Member
protected


CXTPCalendarTimeZone Data Members Protected Data Members

CXTPCalendarTimeZone Data Members Protected Data Members
CXTPCalendarTimeZone Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dwIndex | A time zone order index stored value.
m_strDisplayString | A time zone display string stored value.


Legend

Legend
CXTPCalendarTimeZones Data Members
Legend
Data Member
protected


CXTPCalendarTimeZones Data Members Protected Data Members

CXTPCalendarTimeZones Data Members Protected Data Members
CXTPCalendarTimeZones Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arTZInfo | Collection to store CXTPCalendarTimeZone object pointers;


Legend

Legend
CXTPCalendarTip Data Members
Legend
Data Member
protected


CXTPCalendarTip Data Members Protected Data Members

CXTPCalendarTip Data Members Protected Data Members
CXTPCalendarTip Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAdvancedMode | TRUE when advanced mode is on
m_pFont | Font for displaying tooltip text.
m_pParentWnd | Pointer to the parent report window.
m_pTheme | Pointer to associated Theme object
m_rcHover | Hover window coordinates.
m_strTooltipText | Tooltip text to display.


Legend

Legend
CXTPCalendarView Data Members
Legend
Data Member
protected


CXTPCalendarView Data Members Protected Data Members

CXTPCalendarView Data Members Protected Data Members
CXTPCalendarView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bResetUndoBuffer | Clean undo buffer before add next undo action.
m_bScrollH_Disabled | Is horizontal scrolling disabled for a view.
m_bScrollV_Disabled | Is vertical scrolling disabled for a view.
m_bStartedClickInside | Is OnLButtonDown was inside view rect.
m_cntSelChanged | Counter on selection changes, is needed to redraw a view when necessary.
m_eDraggingMode | Editing event mode.
m_eUndoMode | Undo mode, see XTPCalendarUndoMode.
m_EventTimeFormat | Information used to format events times.
m_LastHitInfo | Last HitInfo data.
m_Layout | Layout data.
m_nKeyStateTimerID | Timer ID to check Keys state (like Control).
m_nTimerID_ShowToolTip | Timer ID of start show tooltip request.
m_nTimerID_StartEditSubject | Timer ID of edit event subject request.
m_pControl | Pointer to the owner control object.
m_pResources | Resources array
m_PrevUndoBuffer | Undo buffer data after last undo buffer clean.
m_pSelectedEvents | Selected Events;
m_ptrDraggingEventNew | Editing event object.
m_ptrDraggingEventOrig | Event object before start event editing.
m_ptrEditingViewEvent | Currently editing subject event view or event view requested to edit subject by timeout.
m_ptStartDragging | Request to start dragging operation from this point.
m_rcTooltip | Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
m_rcView | Client rect.
m_selectedBlock | Current selection.
m_spDraggingStartOffset | Start dragging operation offset from the beginning of the event.
m_strDayHeaderFormatDefaultLong | Day header Long date format default string.
m_strDayHeaderFormatDefaultMiddle | Day header Middle date format default string.
m_strDayHeaderFormatDefaultShort | Day header Short date format default string.
m_strDayHeaderFormatDefaultShortest | Day header Shortest date format default string.
m_strDayHeaderFormatLong | Day header Long date format custom string.
m_strDayHeaderFormatMiddle | Day header Middle date format custom string.
m_strDayHeaderFormatShort | Day header Short date format custom string.
m_strDayHeaderFormatShortest | Day header Shortest date format custom string.
m_strHeaderFormat | Day header active date format string.
m_UndoBuffer | Undo buffer object.


Legend

Legend
CSelectionChanged_ContextData Data Members
Legend
Data Member


CSelectionChanged_ContextData Data Members Public Data Members

CSelectionChanged_ContextData Data Members Public Data Members
CSelectionChanged_ContextData Data Members | Legend
Public Data Members
Public Data Member | Description
m_bRequest_Day | Days selection change send notification request.
m_bRequest_Event | Events selection change send notification request.
m_nLockCount | Selection change notification global Lock counter.
m_nLockCount_Day | Days selection change notification Lock counter.
m_nLockCount_Event | Events selection change notification Lock counter.


Legend

Legend
CUndoBuffer Data Members
Legend
Data Member
protected


CUndoBuffer Data Members Protected Data Members

CUndoBuffer Data Members Protected Data Members
CUndoBuffer Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arUndoActions | Array of editing/undo actions.


Legend

Legend
SUndoAction Data Members
Legend
Data Member


SUndoAction Data Members Public Data Members

SUndoAction Data Members Public Data Members
SUndoAction Data Members | Legend
Public Data Members
Public Data Member | Description
ptrNew | Event instance after edit action.
ptrPrev | Event instance before edit action.


Legend

Legend
SEventTimeFormatInfo Data Members
Legend
Data Member


SEventTimeFormatInfo Data Members Public Data Members

SEventTimeFormatInfo Data Members Public Data Members
SEventTimeFormatInfo Data Members | Legend
Public Data Members
Public Data Member | Description
b24_HFormat | Is 24 hours time format.
strAM | AM symbol.
strFormat | Time format string.
strPM | PM symbol.


Legend

Legend
CXTPCalendarViewDay Data Members
Legend
Data Member
protected


CXTPCalendarViewDay Data Members Protected Data Members

CXTPCalendarViewDay Data Members Protected Data Members
CXTPCalendarViewDay Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dtDate | Day date.
m_Layout | Layout data.
m_pResources | Resources array


Legend

Legend
CXTPCalendarViewDayT Data Members
Legend
Data Member
protected


CXTPCalendarViewDayT Data Members Protected Data Members

CXTPCalendarViewDayT Data Members Protected Data Members
CXTPCalendarViewDayT Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arViewGroups | Storage for views of groups.


Legend

Legend
CXTPCalendarViewEvent Data Members
Legend
Data Member
protected


CXTPCalendarViewEvent Data Members Protected Data Members

CXTPCalendarViewEvent Data Members Protected Data Members
CXTPCalendarViewEvent Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bMultyDayTextAlign | Flag indicates special text alignment for multi day event.
m_bSelected | Event view selected flag.
m_bTextOutOfBorders | Flag indicates text out of event borders.
m_nEventPlaceNumber | Event view place number (sequential identifier).
m_nTimerID_ShowToolTip | Identifier of timer event to show tooltip with delay.
m_pMasterView | Pointer to Master event view object.
m_pSubjectEditor | Pointer to subject editor.
m_ptrEvent | Pointer to the displayed event object.


CXTPCalendarViewEvent Data Members Public Data Members

CXTPCalendarViewEvent Data Members Public Data Members
CXTPCalendarViewEvent Data Members | Legend
Public Data Members
Public Data Member | Description
m_nMultiDayEventFlags | Multi day event flags packed into integer by bitwise operations.
m_pUIElement | Store pointer to CXTPMarkupUIElement object.
m_rcEndTime | Rectangle to display end time event view.
m_rcEvent | Event view rectangle.
m_rcEventMax | Event view rectangle margins.
m_rcFirstClock | Rectangle to draw clock in the beginning of the first day of multi day event.
m_rcLastClock | Rectangle to draw clock at the end of the last day of multi day event.
m_rcMeetingGlyph | Rectangle to draw meeting glyph event view.
m_rcPrivateGlyph | Rectangle to draw private glyph event view.
m_rcRecurrenceGlyph | Rectangle to draw recurrence glyph event view.
m_rcReminderGlyph | Rectangle to draw reminder glyph event view.
m_rcStartTime | Rectangle to display start time day event view.
m_rcSubjectEditor | Subject editor rectangle.
m_rcText | Rectangle to display event text in event view.
m_rcToolTip | Tool tip rectangle.
m_strUIElementText | Store last markup text for which m_pUIElement object was updated.
m_szText | Sizes of displayed text.


Legend

Legend
CXTPCalendarViewEventSubjectEditor2007 Data Members
Legend
Data Member
protected


CXTPCalendarViewEventSubjectEditor2007 Data Members Protected Data Members

CXTPCalendarViewEventSubjectEditor2007 Data Members Protected Data Members
CXTPCalendarViewEventSubjectEditor2007 Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_grclrBk | Subject Editor background color (or gradient colors).
m_pTheme2007 | Stored pointer to the owner theme.
m_pViewEvent | Stored pointer to the editing event object.


Legend

Legend
CXTPCalendarViewEventSubjectEditor Data Members
Legend
Data Member
protected


CXTPCalendarViewEventSubjectEditor Data Members Protected Data Members

CXTPCalendarViewEventSubjectEditor Data Members Protected Data Members
CXTPCalendarViewEventSubjectEditor Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pOwner | Stored pointer to the owner calendar control object.


Legend

Legend
CXTPCalendarViewGroup Data Members
Legend
Data Member
protected


CXTPCalendarViewGroup Data Members Protected Data Members

CXTPCalendarViewGroup Data Members Protected Data Members
CXTPCalendarViewGroup Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_Layout | This group view client coordinates.
m_pResources | An associated resource object.


Legend

Legend
CXTPCalendarViewGroupT Data Members
Legend
Data Member
protected


CXTPCalendarViewGroupT Data Members Protected Data Members

CXTPCalendarViewGroupT Data Members Protected Data Members
CXTPCalendarViewGroupT Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arEvents | Storage for events views.


Legend

Legend
CXTPCalendarViewPart Data Members
Legend
Data Member
protected


CXTPCalendarViewPart Data Members Protected Data Members

CXTPCalendarViewPart Data Members Protected Data Members
CXTPCalendarViewPart Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrBackground | Stores color settings used to to fill background of UI item.
m_clrTextColor | Stores color settings used to display text.
m_fntText | Stores font settings used to display text.
m_pPaintManager | Pointer to containing CXTPCalendarPaintManager object
m_pParentPart | Pointer to the parent CXTPCalendarViewPart object.


Legend

Legend
CXTPCalendarViewPartCustomizableValueT Data Members
Legend
Data Member
protected


CXTPCalendarViewPartCustomizableValueT Data Members Protected Data Members

CXTPCalendarViewPartCustomizableValueT Data Members Protected Data Members
CXTPCalendarViewPartCustomizableValueT Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoDelete_Custom | Call operator delete for the custom value.
m_bAutoDelete_Standard | Call operator delete for the standard value.
m_pValueCustom | Stores custom value.
m_pValueStandard | Stores default value.


Legend

Legend
CXTPCalendarViewPartFontValue Data Members
Legend
Data Member
protected


CXTPCalendarViewPartFontValue Data Members Protected Data Members

CXTPCalendarViewPartFontValue Data Members Protected Data Members
CXTPCalendarViewPartFontValue Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_fntCustomValue | Stores custom font.
m_fntStandardValue | Stores default font.


Legend

Legend
CXTPCalendarViewT Data Members
Legend
Data Member
protected


CXTPCalendarViewT Data Members Protected Data Members

CXTPCalendarViewT Data Members Protected Data Members
CXTPCalendarViewT Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arDays | Stores the view day collection.


Legend

Legend
CXTPCalendarWeekView Data Members
Legend
Data Member
protected


CXTPCalendarWeekView Data Members Protected Data Members

CXTPCalendarWeekView Data Members Protected Data Members
CXTPCalendarWeekView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dtBeginDate | First date of week (Monday's date).
m_LayoutX | Layout data.
m_nCurrPos | Current scrollbar position.
m_nFirstDayOfWeekIndex | Index for first weekday.


Legend

Legend
CXTPColorManager Data Members
Legend
Data Member


CXTPColorManager Data Members Public Data Members

CXTPColorManager Data Members Public Data Members
CXTPColorManager Data Members | Legend
Public Data Members
Public Data Member | Description
grcCaption | Office 2003 Caption gradient color.
grcDockBar | Office 2003 Dockbar gradient color.
grcLunaChecked | Office 2003 checked button gradient color.
grcLunaPushed | Office 2003 pushed button gradient color.
grcLunaSelected | Office 2003 selected button gradient color.
grcMenu | Office 2003 Menu sidebar gradient color.
grcMenuExpanded | Office 2003 Expanded menu sidebar gradient color.
grcMenuItemPopup | Office 2003 Menu item popup gradient color.
grcShortcutBarGripper | Office 2003 Shortcut bar gripper.
grcToolBar | Office 2003 ToolBar gradient color.
m_bEnableLunaBlueForAeroTheme | TRUE if Office2003 blue theme will be used for xtpSystemThemeAero
m_bEnableLunaBlueForRoyaleTheme | TRUE if Office2003 blue theme will be used for xtpSystemThemeRoyale


Legend

Legend
CXTPCommandBar Data Members
Legend
Data Member
protected


CXTPCommandBar Data Members Protected Data Members

CXTPCommandBar Data Members Protected Data Members
CXTPCommandBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAnimatePopup | TRUE to animate popup bar.
m_barPosition | Position of the command bar.
m_barType | Type of the command bar.
m_bCloseable | TRUE if the CommandBar can be closed andor Hidden
m_bCustomizable | TRUE if command bar is customizable.
m_bCustomizeDialogPresent | TRUE if the command bar is present in Customize dialog.
m_bExecOnRButton | TRUE if the control button is executed on a right-click
m_bGrabFocus | TRUE to grab current focus.
m_bIgnoreUpdateHandler | TRUE to skip update handler for all child controls
m_bKeyboardSelect | TRUE if last item was selected by keyboard.
m_bMultiLine | True if multi line commandbar
m_bRecursePopup | TRUE if popup bar was opened recursively.
m_bTextBelow | TRUE if text is shown below the CommandBar buttons.
m_bTracking | TRUE if the command bar is in tracking mode.
m_buttonStyle | Default button Style
m_bVerticalMarker | TRUE to draw marker vertically.
m_bVisible | TRUE if the command bar is visible.
m_dwData | The 32-bit value associated with the command bar.
m_dwFlags | Command bar's flags.
m_dwStyle | Command bar's styles.
m_hwndFocus | The handle of the window that currently has focus.
m_nBarID | Command bar's identifier.
m_nIdleFlags | Idle flags.
m_nLockRecurse | TRUE if another popup bar is opened recursively.
m_nLockRedraw | TRUE if all drawing routines skipped
m_nMRUWidth | Recent width.
m_nPopuped | Popuped control index.
m_nSelected | Selected control index.
m_pAnimation | Animation context
m_pCommandBars | parent command bars class.
m_pControls | A pointer to controls collection.
m_pImageManager | Selected image manager for command bar
m_pOwner | Owner window.
m_pPaintManager | Selected paint manager for command bar
m_pReturnCmd | Return command holder.
m_pSite | Command bar's site.
m_pToolTipContext | Tool tip Context.
m_rcMarker | Marker position.
m_strTitle | Command bar's caption.
m_szButtons | Size of the command bar's icons.
m_szIcons | Size of the command bar's icons.


CXTPCommandBar Data Members Public Data Members

CXTPCommandBar Data Members Public Data Members
CXTPCommandBar Data Members | Legend
Public Data Members
Public Data Member | Description
m_bComboBar | TRUE if it is combo box list
m_bTrackOnHover | TRUE to select item if mouse stay over control
m_nStateFlags | State of the command bars.
s_nExpandDelay | Expand delay time
s_nExpandHoverDelay | Expand hover delay
s_nHoverDelay | Hover delay time


Legend

Legend
CXTPCommandBarKeyboardTip Data Members
Legend
Data Member


CXTPCommandBarKeyboardTip Data Members Public Data Members

CXTPCommandBarKeyboardTip Data Members Public Data Members
CXTPCommandBarKeyboardTip Data Members | Legend
Public Data Members
Public Data Member | Description
m_bEnabled | Enabled flag
m_bVisible | TRUE if visible
m_dwAlign | Tip align
m_pCommandBars | Parent CXTPCommandBars object
m_pOwner | Owner object
m_pt | Client coordinates
m_strCaption | Caption
m_strPrefix | Caption
m_strTip | Tooltip


Legend

Legend
CXTPCommandBarList Data Members
Legend
Data Member
protected


CXTPCommandBarList Data Members Protected Data Members

CXTPCommandBarList Data Members Protected Data Members
CXTPCommandBarList Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrBars | Array of CommandBars
m_pCommandBars | Parent CXTPCommandBars object


Legend

Legend
CXTPCommandBars Data Members
Legend
Data Member
protected


CXTPCommandBars Data Members Protected Data Members

CXTPCommandBars Data Members Protected Data Members
CXTPCommandBars Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrBars | Toolbars list.
m_bCustomizeAvail | TRUE if customize available.
m_bCustomizeMode | Customize mode.
m_bEnableActions | True if actions was enabled
m_bKeyboardCuesVisible | TRUE if menu underlines is currently visible
m_bQuickCustomizeMode | TRUE if command bars in quick customization mode
m_nDefaultMenuID | Default menu resource.
m_nIDHelpTracking | Selected control.
m_pActions | Actions collection
m_pContextMenus | Context menu collection
m_pDockBarClass | Default dockbar class
m_pDocks | DockBars list
m_pDragSelected | Customize control.
m_pDropSource | Customize helper class.
m_pFrame | Parent frame of command bars
m_pImageManager | Image manager
m_pKeyboardManager | Keyboard manager of command bars
m_pMenuBarClass | Default menubar class
m_pMouseManager | Mouse manager of command bars
m_pOptions | Command bars' options
m_pPaintManager | Paint manager.
m_pPopupBarClass | Default popupbar class
m_pPopupToolBarClass | Default popupbar class
m_pShortcutManager | Shortcut Manager of command bars.
m_pToolBarClass | Default toolbar class
m_pToolTipContext | Tooltip Context.
m_strControlsFileName | File name to be used to store user customization.


CXTPCommandBars Data Members Public Data Members

CXTPCommandBars Data Members Public Data Members
CXTPCommandBars Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDesignerMode | TRUE if command bars in designer mode.
m_bIgnoreShiftMenuKey | if set menus will ignore Shift+Alt key combinations
m_keyboardTips | Keyboard tips information
m_pDesignerControls | Designer controls if used.


Legend

Legend
CXTPCommandBarsOptions Data Members
Legend
Data Member


CXTPCommandBarsOptions Data Members Public Data Members

CXTPCommandBarsOptions Data Members Public Data Members
CXTPCommandBarsOptions Data Members | Legend
Public Data Members
Public Data Member | Description
animationType | Animation type.
bAltDragCustomization | Allows users to change a toolbar button's position by dragging it while holding down ALT.
bAlwaysShowFullMenus | TRUE to show full menus always.
bAutoHideUnusedPopups | TRUE to hide unused popup controls.
bAutoUpdateShortcuts | TRUE to update shortcuts from accelerator table
bDblClickFloat | TRUE to make toolbar floating be double-clicking.
bDirtyState | TRUE if the user has done any type of customization to menus or toolbars.
bDisableCommandIfNoHandler | TRUE to disable commands if no handler presented
bFlyByStatus | Status bar displays information about the button
bLargeIcons | TRUE to use large toolbars icons.
bShowExpandButtonAlways | TRUE to show expand buttons always.
bShowFullAfterDelay | TRUE to show full menus after short delay.
bShowKeyboardTips | TRUE to use keyboard tips.
bShowPopupBarToolTips | TRUE to display ToolTips for controls in popup menus.
bShowTextBelowIcons | TRUE to show captions below icons.
bSyncFloatingBars | TRUE to hide floating bars when site frame deactivated.
bToolBarAccelTips | TRUE to add accelerators to tooltips.
bToolBarScreenTips | TRUE to show toolbar's tooltips
bUseAltNumPadKeys | TRUE to allow activate menu with Alt + num pad key.
bUseSystemSaveBitsStyle | TRUE to use CS_SAVEBITS class style for popups and shadows
bWrapLargePopups | Wrap controls for large popups instead scroll them.
keyboardCuesUse | Keyboard cues using
m_mapHiddenCommands | Hidden command array.
m_mapUsedCommands | Used commands array.
szIcons | Size of the normal icons.
szLargeIcons | Size of the large icons.
szPopupIcons | Size of icons displayed in popup menus.


Legend

Legend
CXTPCompatibleDC Data Members
Legend
Data Member
protected


CXTPCompatibleDC Data Members Protected Data Members

CXTPCompatibleDC Data Members Protected Data Members
CXTPCompatibleDC Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_hOldBitmap | Pointer to the previously selected bitmap.


Legend

Legend
CXTPControl Data Members
Legend
Data Member
protected


CXTPControl Data Members Protected Data Members

CXTPControl Data Members Protected Data Members
CXTPControl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bBeginGroup | TRUE if the control starts new group.
m_bChecked | TRUE if the control is checked.
m_bCloseSubMenuOnClick | TRUE is sub-menus are closed as soon as a control is clicked.
m_bDefaultItem | TRUE if the item is default popup item;
m_bEnabled | TRUE if the control is enabled.
m_bExpanded | TRUE if the control is expanded.
m_bPressed | TRUE if the control is pushed.
m_bSelected | TRUE if the control is selected.
m_bTemporary | TRUE if the control is temporary.
m_buttonCustomStyle | User defined style of button.
m_buttonRibbonStyle | User defined style of button.
m_buttonStyle | Button Style.
m_bWrap | TRUE if the control is wrapped.
m_controlType | Type of the control.
m_dwFlags | Flags of the control.
m_dwHideFlags | Hidden flags.
m_mapDocTemplatesAssigned | Assigned templates.
m_mapDocTemplatesExcluded | Excluded templates.
m_nCustomIconId | Identifier of the control's custom image.
m_nExecuteOnPressInterval | Delay between each message when control is pressed.
m_nHeight | Height of the control.
m_nHelpId | Help identifier
m_nIconId | Identifier of the control's image.
m_nId | Identifier of the control.
m_nIndex | Index of the control.
m_nTag | Control tag.
m_nWidth | Width of the control.
m_pAction | Action of the control.
m_pControls | Parent control collection
m_pParent | The Parent command bar.
m_pRibbonGroup | Ribbon group of control
m_rcControl | Bounding rectangle of the control.
m_rcRow | Bounding rectangle of the control's row.
m_strCaption | Caption of the control.
m_strCategory | Category of the control.
m_strCustomCaption | User defined caption.
m_strDescriptionText | Description text.
m_strKeyboardTip | Keyboard tip
m_strParameter | Parameter text.
m_strShortcutText | Shortcut text.
m_strShortcutTextAuto | Shortcut text.
m_strTooltipText | Tooltip text.


Legend

Legend
CXTPControlAction Data Members
Legend
Data Member
protected


CXTPControlAction Data Members Protected Data Members

CXTPControlAction Data Members Protected Data Members
CXTPControlAction Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrControls | Associated controls
m_bChecked | TRUE if the action is checked.
m_bEnabled | TRUE if the action is enabled.
m_bVisible | TRUE if action is visible
m_nHelpId | Help identifier
m_nIconId | Identifier of the action's image.
m_nId | Identifier of the action.
m_nTag | Action tag.
m_pActions | Parent actions object
m_strCaption | Caption of the action.
m_strCategory | Category of the action.
m_strDescriptionText | Description text.
m_strEditHint | Edit Hint for Combo and Edit Controls
m_strKey | Key
m_strKeyboardTip | Keyboard tip
m_strShortcutText | Shortcut text
m_strTooltipText | Tooltip text.


CXTPControlAction Data Members Public Data Members

CXTPControlAction Data Members Public Data Members
CXTPControlAction Data Members | Legend
Public Data Members
Public Data Member | Description
m_pTarget | Parameter of action


Legend

Legend
CXTPControlActions Data Members
Legend
Data Member
protected


CXTPControlActions Data Members Protected Data Members

CXTPControlActions Data Members Protected Data Members
CXTPControlActions Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrActions | Actions array
m_pCommandBars | Parent CommandBars object


Legend

Legend
CXTPControlComboBox Data Members
Legend
Data Member
protected


CXTPControlComboBox Data Members Protected Data Members

CXTPControlComboBox Data Members Protected Data Members
CXTPControlComboBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoComplete | TRUE if Auto Complete enabled
m_bDelayDestroy | TRUE if need to recreate control.
m_bDelayReposition | Need to reposition control.
m_bDropDown | TRUE if the combo is dropdown.
m_bEditChanged | TRUE if Edit Text was changed.
m_bFocused | TRUE if control is focused
m_bIgnoreAutoComplete | TRUE to disable auto complete till next key event.
m_bSelEndOk | TRUE if user selects a list item.
m_comboStyle | Style of the combo box.
m_dwEditStyle | Edit style
m_dwShellAutoCompleteFlags | Shell auto complete flags.
m_nDropDownItemCount | Maximum drop down items
m_nEditIconId | Edit Icon identifier
m_nLabelWidth | Width of the label.
m_nLastSel | Last user selected index, (used during display of list box)
m_nThumbWidth | Width of the thumb area.
m_pAutoCompleteWnd | Auto Complete hook window.
m_pEdit | Child edit control.
m_strEditHint | Grayed-out text displayed in the edit control that displayed a helpful description
m_strEditText | Edit text.
m_strLastText | Last Text before user select focus and change it.


Legend

Legend
CXTPControlComboBoxEditCtrl Data Members
Legend
Data Member
protected


CXTPControlComboBoxEditCtrl Data Members Protected Data Members

CXTPControlComboBoxEditCtrl Data Members Protected Data Members
CXTPControlComboBoxEditCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pControl | Parent Combo Box.


Legend

Legend
CXTPControlCustom Data Members
Legend
Data Member
protected


CXTPControlCustom Data Members Protected Data Members

CXTPControlCustom Data Members Protected Data Members
CXTPControlCustom Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bControlVisible | TRUE if child window is visible.
m_hwndControl | The child window.
m_nControlID | Id of the custom control
m_rcBorders | Borders.
m_szControl | Size of the control.
m_verticalOptions | Vertical options.


Legend

Legend
CXTPControlEdit Data Members
Legend
Data Member
protected


CXTPControlEdit Data Members Protected Data Members

CXTPControlEdit Data Members Protected Data Members
CXTPControlEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bDelayDestroy | Need to reposition control.
m_bDelayReposition | Need to reposition control.
m_bEditChanged | TRUE if Edit Text was changed.
m_bFocused | TRUE if edit has focus
m_bLabel | TRUE if label is visible.
m_bReadOnly | TRUE if edit is readonly
m_bShowSpinButtons | TRUE to show spsin buttons
m_dwEditStyle | Edit style
m_dwShellAutoCompleteFlags | Shell auto complete flags.
m_nEditIconId | Edit Icon identifier
m_nLabelWidth | Width of the label.
m_pAutoCompleteWnd | Auto complete window hook.
m_pEdit | Inplace edit control.
m_strEditHint | Edit hint of the controls
m_strEditText | Edit text.
m_strLastText | Last entered text


Legend

Legend
CXTPControlEditCtrl Data Members
Legend
Data Member
protected


CXTPControlEditCtrl Data Members Protected Data Members

CXTPControlEditCtrl Data Members Protected Data Members
CXTPControlEditCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pControl | Parent edit control


Legend

Legend
CXTPControlFontComboBoxList Data Members
Legend
Data Member
protected


CXTPControlFontComboBoxList Data Members Protected Data Members

CXTPControlFontComboBoxList Data Members Protected Data Members
CXTPControlFontComboBoxList Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dwStyleListBox | Style of the control.


Legend

Legend
CXTPControlGallery Data Members
Legend
Data Member
protected


CXTPControlGallery Data Members Protected Data Members

CXTPControlGallery Data Members Protected Data Members
CXTPControlGallery Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrRects | bounding rectangles
m_bHideSelection | TRUE to hide selection
m_bKeyboardSelected | TRUE if item was selected using keyboard
m_bPressed | TRUE if item is pressed
m_bPreview | TRUE if control in preview mode
m_bShowBorders | TRUE to show borders
m_bShowLabels | TRUE to show labels
m_bShowScrollBar | TRUE to show scrollbars
m_nChecked | Checked id
m_nScrollPos | Scroll position
m_nScrollPosTarget | Scroll position
m_nSelected | Index of Selected item
m_nTotalHeight | Total height of items
m_ptPressed | Position of pressed item
m_rcMargin | Margins of gallery items


Legend

Legend
CXTPControlGalleryItem Data Members
Legend
Data Member
protected


CXTPControlGalleryItem Data Members Protected Data Members

CXTPControlGalleryItem Data Members Protected Data Members
CXTPControlGalleryItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bLabel | TRUE if item is label
m_dwData | 32-bit data
m_nId | Identifier
m_nImage | Image index
m_nIndex | Index of the item
m_pItems | Parent items collection
m_strCaption | Caption of the item
m_strDescriptionText | Description of the item
m_strToolTip | Tooltip of the item
m_szItem | Size of the item; CSize(0, 0) - to use default value


Legend

Legend
CXTPControlGalleryItems Data Members
Legend
Data Member
protected


CXTPControlGalleryItems Data Members Protected Data Members

CXTPControlGalleryItems Data Members Protected Data Members
CXTPControlGalleryItems Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrItems | Array of items
m_bClipItems | TRUE to clip items
m_pAction | Action of the items
m_pImageManager | Image manager of items
m_szItem | Size of the items


Legend

Legend
CXTPControlGalleryPaintManager Data Members
Legend
Data Member


CXTPControlGalleryPaintManager Data Members Public Data Members

CXTPControlGalleryPaintManager Data Members Public Data Members
CXTPControlGalleryPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_cxPopup | Width of arrows of in place scrollbar
m_cyPopupDown | Height of Down arrow of in place scrollbar
m_cyPopupUp | Height of Up arrow of in place scrollbar


Legend

Legend
CXTPControlListBox Data Members
Legend
Data Member
protected


CXTPControlListBox Data Members Protected Data Members

CXTPControlListBox Data Members Protected Data Members
CXTPControlListBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bMouseLocked | TRUE to lock mouse events.
m_bMultiplSel | Multiple selection style.
m_nListBoxLinesMax | Maximum lines.
m_nListBoxLinesMin | Minimum lines.
m_pListBox | List box control.


Legend

Legend
CXTPControlPopup Data Members
Legend
Data Member
protected


CXTPControlPopup Data Members Protected Data Members

CXTPControlPopup Data Members Protected Data Members
CXTPControlPopup Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bPopup | TRUE if popuped.
m_bShowShadow | TRUE to show shadow
m_dwCommandBarID | Child popup id.
m_pCommandBar | Child popup bar.


Legend

Legend
CXTPControls Data Members
Legend
Data Member
protected


CXTPControls Data Members Protected Data Members

CXTPControls Data Members Protected Data Members
CXTPControls Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrControls | Collection of controls
m_pCommandBars | Parent Command Bars
m_pOriginalControls | Original controls collection.
m_pParent | Parent Command Bar


Legend

Legend
CXTPControlSelector Data Members
Legend
Data Member


CXTPControlSelector Data Members Public Data Members

CXTPControlSelector Data Members Public Data Members
CXTPControlSelector Data Members | Legend
Public Data Members
Public Data Member | Description
m_szItem | Size of the items.
m_szItemsActive | Number of items currently "active", this is current number of items that are highlighted as the mouse moves across the control selector.
m_szItemsCount | Number of items to draw in the control selector's view.
m_szItemsMax | Maximum number of items to draw in the control selector.
m_szItemsVisible | Number of items currently visible.
m_szResult | Number of items that were selected from the control selector.


Legend

Legend
CXTPControlWindowList Data Members
Legend
Data Member


CXTPControlWindowList Data Members Public Data Members

CXTPControlWindowList Data Members Public Data Members
CXTPControlWindowList Data Members | Legend
Public Data Members
Public Data Member | Description
m_bShowRadioButtons | TRUE to show Radio buttons.
m_nFistMDIChild | First MDI child id.
m_nItemCount | Maximum allowed items.


Legend

Legend
CXTPCustomizeCommandsListBox Data Members
Legend
Data Member


CXTPCustomizeCommandsListBox Data Members Public Data Members

CXTPCustomizeCommandsListBox Data Members Public Data Members
CXTPCustomizeCommandsListBox Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDragable | TRUE if user can drag controls from list
m_pCommandBars | Parent CommandBars object


Legend

Legend
CXTPCustomizeCommandsPage Data Members
Legend
Data Member
protected


CXTPCustomizeCommandsPage Data Members Protected Data Members

CXTPCustomizeCommandsPage Data Members Protected Data Members
CXTPCustomizeCommandsPage Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrCategories | Array of categories.
m_lstCategories | List box of categories
m_lstCommands | List box of commands
m_pSheet | Parent Customize dialog


Legend

Legend
CXTPCustomizeKeyboardPage Data Members
Legend
Data Member
protected


CXTPCustomizeKeyboardPage Data Members Protected Data Members

CXTPCustomizeKeyboardPage Data Members Protected Data Members
CXTPCustomizeKeyboardPage Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrCategories | Array of categories
m_pSheet | Parent Customize dialog


CXTPCustomizeKeyboardPage Data Members Public Data Members

CXTPCustomizeKeyboardPage Data Members Public Data Members
CXTPCustomizeKeyboardPage Data Members | Legend
Public Data Members
Public Data Member | Description
m_comboCategory | Categories combo box
m_editShortcutKey | Shortcut edit control
m_iCategory | Selected category
m_lboxCommands | Commands list box
m_lboxKeys | Keys list box
m_strDesc | Description of selected control


Legend

Legend
CXTPCustomizeOptionsPage Data Members
Legend
Data Member
protected


CXTPCustomizeOptionsPage Data Members Protected Data Members

CXTPCustomizeOptionsPage Data Members Protected Data Members
CXTPCustomizeOptionsPage Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pSheet | Parent sheet.


CXTPCustomizeOptionsPage Data Members Public Data Members

CXTPCustomizeOptionsPage Data Members Public Data Members
CXTPCustomizeOptionsPage Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAlwaysShowFullMenus | TRUE to show full menus always
m_bLargeIcons | TRUE to show large icons
m_bShowFullAfterDelay | TRUE to show menus after delay
m_bToolBarAccelTips | TRUE to show accelerators with tool tips
m_bToolBarScreenTips | TRUE to show tool tips
m_comboAnimationType | Animation combo box
m_nAnimationType | Selected animation type
m_wndOtherGroup | Other group line
m_wndPersonalizedGroup | Personalized group line


Legend

Legend
CXTPCustomizeSheet Data Members
Legend
Data Member
protected


CXTPCustomizeSheet Data Members Protected Data Members

CXTPCustomizeSheet Data Members Protected Data Members
CXTPCustomizeSheet Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pCommandBars | Customized comamndBars.
m_pContextMenu | Context menu that is displayed in customization mode when a user right-clicks on a control.
m_pCustomIcons | Icons displayed in the "Change Button Image" popup of the context menu that is displayed when a user right-clicks on a control.
m_pPageCommands | Commands page.
m_pPageToolBars | Toolbar page.
m_pWndParent | Parent window.


Legend

Legend
CXTPCustomizeToolbarsPage Data Members
Legend
Data Member


CXTPCustomizeToolbarsPage Data Members Public Data Members

CXTPCustomizeToolbarsPage Data Members Public Data Members
CXTPCustomizeToolbarsPage Data Members | Legend
Public Data Members
Public Data Member | Description
m_btnDelete | Delete button
m_btnNew | New button
m_btnRename | Rename button
m_btnReset | Reset button
m_checkList | Toolbars list box
m_pSheet | Parent property sheet


Legend

Legend
CXTPDatePickerButton Data Members
Legend
Data Member
protected


CXTPDatePickerButton Data Members Protected Data Members

CXTPDatePickerButton Data Members Protected Data Members
CXTPDatePickerButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_strCaption | This member variable is used to specify the caption of the button.


CXTPDatePickerButton Data Members Public Data Members

CXTPDatePickerButton Data Members Public Data Members
CXTPDatePickerButton Data Members | Legend
Public Data Members
Public Data Member | Description
m_bHighlight | This member variable is used to indicate if a button is highlighted.
m_bPressed | This member variable is used to indicate if a button is pressed.
m_bVisible | This member variable is used to indicate if a button is visible.
m_nID | This member variable is used to specify the identifier of the button.
m_rcButton | This member variable is used to specify the bounding rectangle coordinates of a button.


Legend

Legend
CXTPDatePickerControl Data Members
Legend
Data Member
protected


CXTPDatePickerControl Data Members Protected Data Members

CXTPDatePickerControl Data Members Protected Data Members
CXTPDatePickerControl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arDayOfWeekNames | This member variable contains the day abbreviation for drawing in the month header.
m_arMonthNames | This member variable contains the localized month names values.
m_arrButtons | This member variable is an array of control buttons.
m_arrMonths | This member variable is an internal storage for the month items.
m_bAllowNoncontinuousSelection | TRUE to allow Noncontinuous selection
m_bAutoSize | This member variable is used as the AutoSize flag.
m_bChanged | This member variable is used to determine if the control requires redrawing.
m_bHighlightToday | This member variable is used as a flag to determine if the "Today" date is highlighted.
m_bIsModal | This member variable is used to specify if the control is used as a pop-up window.
m_bmpCache | This member variable is a cached window bitmap.
m_bMultiSelectionMode | TRUE if multiselection mode enabled (i.e.
m_borderStyle | This member variable is a flag that determines if the control displays a 3D border.
m_bRightToLeft | TRUE to display calendar components in Right-To-Left (RTL) format
m_bSelectWeek | TRUE when user is started selecting the whole week.
m_bShowNonMonthDays | This member variable is a flag that determines if the "non month days" are displayed.
m_bShowWeekNumbers | This member variable is a flag that determines if the "week numbers" are displayed.
m_dtFirstClicked | This member variable is used to specify the day that was clicked before starting the mouse selection.
m_dtFirstMonth | This member variable is used to specify the first month in the grid.
m_dtFocused | This member variable is used to specify the focused day.
m_dtFSelBase | This member variable is used to specify start day of the continuous selection.
m_dtLastClicked | This member variable is used to specify the day that was clicked last in the mouse selection.
m_dtMaxRange | This member variable specifies the maximum allowable date for a date picker control.
m_dtMinRange | This member variable specifies the minimum allowable date for a date picker control.
m_dtToday | This member variable is used to specify the "Today" date for a date picker control.
m_mouseMode | This member variable is used to specify the current Mouse operating mode.
m_nColumns | This member variable is used to specify the number of columns in the column month's grid.
m_nFirstDayOfWeek | This member variable is used to specify the first day of the week to display (1-Sunday, 2-Monday ...
m_nFirstWeekOfYearDays | This member variable is used to specify the number of days of the new year in the first week of this year.
m_nLockUpdateCount | This member variable is used as a counter that is used to count the update locks.
m_nMaxSelectionDays | This member variable is used to specify the maximum number of selected days.
m_nMonthDelta | This member variable is used to specify the number of months set as the control's scroll rate.
m_nRows | This member variable is used to specify the number of rows in the column month's grid.
m_nTimerID | This member variable is used to specify the control timer ID.
m_pButtonCaptured | Pointer to a date picker button
m_pCallbackParam | This member variable is a pointer to the user's additional parameter for the callback function.
m_pConnect | This member variable is a connection object that is used to send notifications.
m_pfnCallback | This member variable is a pointer to the user's IsSpecialDay function.
m_pListControl | This member variable is used to specify the "header month list" pop-up control.
m_pPaintManager | This member variable is a pointer to the paint manager.
m_pSelectedDays | This member variable is a collection of selected days.
m_rcControl | This data member is used to store the control drawing coordinates.
m_rcGrid | Months grid rect.


CXTPDatePickerControl Data Members Public Data Members

CXTPDatePickerControl Data Members Public Data Members
CXTPDatePickerControl Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDeleteOnFinalRelease | Delete self OnFinalRelease() call.


Legend

Legend
CXTPDatePickerDaysCollection Data Members
Legend
Data Member
protected


CXTPDatePickerDaysCollection Data Members Protected Data Members

CXTPDatePickerDaysCollection Data Members Protected Data Members
CXTPDatePickerDaysCollection Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrSelectedBlocks | Contains an array of the selected dates blocks.
m_pControl | This member variable is a pointer to the parent control.


Legend

Legend
CXTPDatePickerItemDay Data Members
Legend
Data Member
protected


CXTPDatePickerItemDay Data Members Protected Data Members

CXTPDatePickerItemDay Data Members Protected Data Members
CXTPDatePickerItemDay Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bVisible | This member variable is used as a flag to specify if the day item is visible.The flag values are TRUE if the day item is drawn, otherwise FALSE.
m_dtDay | This member variable is used to specify the visible day date, represented by this Day item.
m_pControl | This member variable is a pointer to the parent date picker control.
m_pMonth | This member variable is a pointer to the parent month item.
m_rcDay | This member variable is used to specify the coordinates of the day spot.


Legend

Legend
CXTPDatePickerItemMonth Data Members
Legend
Data Member
protected


CXTPDatePickerItemMonth Data Members Protected Data Members

CXTPDatePickerItemMonth Data Members Protected Data Members
CXTPDatePickerItemMonth Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrDays | This member variable is a CArray<CXTPDatePickerItemDay*, CXTPDatePickerItemDay*> object that is used as an internal storage area for the day items.
m_bShowDaysAfter | This member variable is a BOOL that is used to indicate if the "days after this month" are visible.
m_bShowDaysBefore | This member variable is a BOOL that is used to determine if the "days before this month" are visible.
m_bShowLeftScroll | This member variable is a BOOL that is used to determine if the "left scroll triangle" is visible.
m_bShowRightScroll | This member variable is a BOOL that is used to determine if the "right scroll triangle" is visible.
m_dtMonth | This member variable is COleDateTime object that is used as the date with the month definition for the month item.
m_nColumn | This member variable is an int that is used for the column month index.
m_nRow | This member variable is an int that is used for the row month index.
m_pControl | This member variable is a CXTPDatePickerControl object pointer to the parent control
m_rcDaysArea | This member variable is a CRect object that contains the coordinates of the month's "all days" area.
m_rcDaysOfWeek | This member variable is a CRect object that contains the coordinates of the month's "week days" area.
m_rcHeader | This member variable is a CRect object that contains the coordinates of the month's header area.
m_rcLeftScroll | This member variable is a CRect object that contains the coordinates of the left scroll triangle area.
m_rcMonth | This member variable is a CRect object that contains the coordinates of the total month's area.
m_rcRightScroll | This member variable is a CRect object that contains the coordinates of the right scroll triangle area.
m_rcWeekNumbers | This member variable is a CRect object that contains the coordinates of the month's week numbers area.


Legend

Legend
CXTPDatePickerPaintManager Data Members
Legend
Data Member
protected


CXTPDatePickerPaintManager Data Members Protected Data Members

CXTPDatePickerPaintManager Data Members Protected Data Members
CXTPDatePickerPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bEnableTheme | This member variable is a BOOL that is used to indicate if Luna colors are enabled.
m_clr3DLight | This member variable is a COLORREF object that is used to specify the color for light areas
m_clr3DShadow | This member variable is a COLORREF object that is used to specify the color for shadow areas.
m_clrBtnFace | This member variable is a COLORREF object that is used as the basic color for buttons.
m_clrBtnText | This member variable is a COLORREF object that is used as the color for the button text.
m_clrControlBack | This member variable is a COLORREF object that is used as the background color of the control.
m_clrDayBack | This member variable is a COLORREF object that is used as the background color of the normal day item.
m_clrDaysOfWeekBack | This member variable is a COLORREF object that is used for the background color of the days of weeks area.
m_clrDaysOfWeekText | This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
m_clrDayText | This member variable is a COLORREF object that is used as the color of the usual day item.
m_clrHeaderBack | This member variable is a COLORREF object that is used as the background color of the month header area.
m_clrHeaderText | This member variable is a COLORREF object that is used as the text color of the month header area.
m_clrHighlightToday | This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
m_clrListControlBack | This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
m_clrListControlText | This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
m_clrNonMonthDayBack | This member variable is a COLORREF object that is used as the background color of the non month day item.
m_clrNonMonthDayText | This member variable is a COLORREF object that is used as the color of the non month day item.
m_clrSelectedDayBack | This member variable is a COLORREF object that is used as the background color of the selected day item.
m_clrSelectedDayText | This member variable is a COLORREF object that is used as the color of the selected day item.
m_clrStaticBorder | Static border color
m_clrWeekNumbersBack | This member variable is a COLORREF object that is used as the background color of the week numbers area.
m_clrWeekNumbersText | This member variable is a COLORREF object that is used as the text color of the week numbers items.
m_clrWindow | This member variable is a COLORREF object that is used as the Color of the window.
m_fontButton | This member variable is a CFont object that is used as the font for the button text.
m_fontDay | This member variable is a CFont object that is used for the font of the usual day item.
m_fontDayBold | This member variable is a CFont object that is used for the font of the bold day item.
m_fontDaysOfWeek | This member variable is a CFont object that is used as the font for the days of weeks text.
m_fontHeader | This member variable is a CFont object that is used as the font for the header text.
m_fontListControl | This member variable is a CFont object that is used as the font for the pop-up month list control.
m_fontNonMonthDay | This member variable is a CFont object that is used as the font for the non month day item.
m_fontWeekNumbers | This member variable is a CFont object that is used as the font for the week number items text.
m_hCursorBack | Back cursor for week selection
m_nPaintTheme | Store the Paint Theme;
m_pControl | Stores a pointer to owner control.
m_themeButton | This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.


Legend

Legend
CXTPDefaultTheme Data Members
Legend
Data Member
protected


CXTPDefaultTheme Data Members Protected Data Members

CXTPDefaultTheme Data Members Protected Data Members
CXTPDefaultTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nPopupBarText | Popup bar text index.


Legend

Legend
CXTPDialogBar Data Members
Legend
Data Member
protected


CXTPDialogBar Data Members Protected Data Members

CXTPDialogBar Data Members Protected Data Members
CXTPDialogBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bActive | TRUE if dialog bar has active caption
m_bCaptionPopup | TRUE to use caption as popup control.
m_bCaptionVisible | TRUE if the caption popup control is visible.
m_bResizable | TRUE if the child window and dialog bar are re-sizable.
m_hwndChild | Child window handle.
m_nCaptionHeight | Caption height.
m_pPopupBar | Pointer to caption popup bar.
m_rcBorders | Borders size.
m_strCaption | Text that is displayed in the caption popup control.
m_szDockingClient | Docking client rectangle
m_szFloatingClient | Floating client rectangle
m_szMinTrackRect | Minimum tracking rectangle


Legend

Legend
CXTPDockBar Data Members
Legend
Data Member
protected


CXTPDockBar Data Members Protected Data Members

CXTPDockBar Data Members Protected Data Members
CXTPDockBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrBars | Toolbar list
m_dwStyle | Style of the control.
m_pCommandBars | Parent CommandBars object


Legend

Legend
CXTPDockContext Data Members
Legend
Data Member
protected


CXTPDockContext Data Members Protected Data Members

CXTPDockContext Data Members Protected Data Members
CXTPDockContext Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nHitTest | Hit Test code
m_pBar | Child toolbar.
m_ptLast | Last mouse position.
m_ptMRUFloatPos | Last floating rectangle
m_rectDragDock | Current docking rectangle
m_rectDragFrame | Current floating rectangle.
m_rectMRUDockPos | Last docking rectangle.
m_uMRUDockPosition | Last docking position.


Legend

Legend
CXTPDockingPane Data Members
Legend
Data Member
protected


CXTPDockingPane Data Members Protected Data Members

CXTPDockingPane Data Members Protected Data Members
CXTPDockingPane Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bEnabled | Pane enabled options
m_clrItemTab | Color used to fill the docking pane tab buttons.
m_dwData | User item data
m_dwOptions | Options of the pane.
m_hwndChild | Child window handle
m_nIconID | Icon identifier
m_nID | Pane identifier
m_nIDHelp | Context-sensitive help ID for a child pane
m_ptMaxTrackSize | Maximum pane size.
m_ptMinTrackSize | Minimum pane size.
m_strTitle | Caption of the pane


Legend

Legend
CXTPDockingPaneAutoHidePanel Data Members
Legend
Data Member
protected


CXTPDockingPaneAutoHidePanel Data Members Protected Data Members

CXTPDockingPaneAutoHidePanel Data Members Protected Data Members
CXTPDockingPaneAutoHidePanel Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_direction | Location of hidden panel
m_pActiveWnd | Active window


CXTPDockingPaneAutoHidePanel Data Members Public Data Members

CXTPDockingPaneAutoHidePanel Data Members Public Data Members
CXTPDockingPaneAutoHidePanel Data Members | Legend
Public Data Members
Public Data Member | Description
m_bCloseActiveWindow | TRUE to allow the AutoHide window to be closed.


Legend

Legend
CXTPDockingPaneAutoHideWnd Data Members
Legend
Data Member


CXTPDockingPaneAutoHideWnd Data Members Public Data Members

CXTPDockingPaneAutoHideWnd Data Members Public Data Members
CXTPDockingPaneAutoHideWnd Data Members | Legend
Public Data Members
Public Data Member | Description
m_dAnimationDelay | Animation delay
m_nAnimationDuration | Duration of sliding animation in ms
m_nAnimationInterval | Delay in ms between animation steps
m_nInactiveCollapseDelay | Delay before collapsing inactive.
m_nMouseHoverDelay | Duration of mouse hover before expanding


Legend

Legend
CXTPDockingPaneBase Data Members
Legend
Data Member
protected


CXTPDockingPaneBase Data Members Protected Data Members

CXTPDockingPaneBase Data Members Protected Data Members
CXTPDockingPaneBase Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pCaptionButtons | Collection of caption buttons.
m_pDockingSite | Parent frame.
m_pLayout | Parent layout.
m_pParentContainer | Parent container.
m_rcWindow | Position of the pane.
m_szDocking | Size of the pane.
m_type | Type of the pane.


Legend

Legend
CXTPDockingPaneBaseContainer Data Members
Legend
Data Member
protected


CXTPDockingPaneBaseContainer Data Members Protected Data Members

CXTPDockingPaneBaseContainer Data Members Protected Data Members
CXTPDockingPaneBaseContainer Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_lstPanes | Child panes collection


Legend

Legend
CXTPDockingPaneCaptionButton Data Members
Legend
Data Member
protected


CXTPDockingPaneCaptionButton Data Members Protected Data Members

CXTPDockingPaneCaptionButton Data Members Protected Data Members
CXTPDockingPaneCaptionButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bPressed | TRUE if button is pressed by user.
m_bSelected | TRUE if user move mouse cursor inside button rectangle
m_dwState | XTPDockingPanePinState of caption button.
m_nID | Identifier of the button.
m_pPane | Parent pane
m_rcButton | Bounding rectangle of the button


Legend

Legend
CXTPDockingPaneContext Data Members
Legend
Data Member
protected


CXTPDockingPaneContext Data Members Protected Data Members

CXTPDockingPaneContext Data Members Protected Data Members
CXTPDockingPaneContext Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bDragKeyboard | TRUE if keyboard used to drag pane
m_bUseAlphaContext | TRUE to use alpha context.
m_bUseDockingStickers | TRUE to use docking stickers.
m_lstStickers | List of the stickers
m_pfnSetLayeredWindowAttributes | Pointer to SetLayeredWindowAttributes method.
m_pLastStickerPane | Last Sticker Pane.
m_pManager | Parent pane manager.
m_pPane | Pointer to the associated pane.
m_pStickerPane | Sticker Pane.
m_ptLast | Holds the last selection point.
m_ptSticky | Position of the sticky control.
m_rectDragFrame | Area occupied by the drag frame.
m_rectDragFrameScreen | Screen drag frame
m_rectStickerPane | Area occupied by the sticker pane.
m_wndAttachedTab | Attached tab control.
m_wndContext | Alpha context control.


Legend

Legend
CXTPDockingPaneContextStickerWnd Data Members
Legend
Data Member


CXTPDockingPaneContextStickerWnd Data Members Public Data Members

CXTPDockingPaneContextStickerWnd Data Members Public Data Members
CXTPDockingPaneContextStickerWnd Data Members | Legend
Public Data Members
Public Data Member | Description
m_pContext | Pointer to docking pane context.
m_selectedSticker | Selected sticker part.
m_typeSticker | Type of the sticker.


Legend

Legend
CXTPDockingPaneExplorerTheme Data Members
Legend
Data Member
protected


CXTPDockingPaneExplorerTheme Data Members Protected Data Members

CXTPDockingPaneExplorerTheme Data Members Protected Data Members
CXTPDockingPaneExplorerTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_themeRebar | Rebar theme helper


Legend

Legend
CXTPDockingPaneManager Data Members
Legend
Data Member
protected


CXTPDockingPaneManager Data Members Protected Data Members

CXTPDockingPaneManager Data Members Protected Data Members
CXTPDockingPaneManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAlphaDockingContext | If TRUE, alpha docking context is used when dragging a pane, the shaded area indicates the panes new location of dropped.
m_bHideClient | If TRUE, the client area is hidden so that only the docking panes are visible and occupy the entire area.
m_bKeyboardEnabled | XTPDockingPaneKeyboardNavigate options
m_bLockSplitters | If TRUE, you can not resize the panes when they are docked.
m_bShowContentsWhileDragging | If TRUE, window contents is visible while dragging.
m_bShowDockingContextStickers | If TRUE, docking context stickers are drawn when the pane is being dragged and dropped.
m_bShowMaximizeButton | Allow panes to be maximized.
m_bStickyFloatingFrames | TRUE to enable sticky option for floating panes
m_bSyncActiveFloatingFrames | Synchronizes the activation of the mini-frame window to the activation of its parent window.
m_bThemedFloatingFrames | If TRUE, floating docking panes will use the currently set theme.
m_bUseSplitterTracker | If TRUE, splitter trackers are used.
m_captionDirection | Caption Direction
m_dwDefaultPaneOptions | Default Panes options.
m_nClientMargin | Client margins
m_nDockingContextStickerStyle | Sticker style.
m_nFloatingFramesOpacity | Opacity of floating frames
m_pActivePane | Current Active pane;
m_pDockingContext | Docking context helper.
m_pfnSetLayeredWindowAttributes | POinter to SetLayeredWindowAttributes API function
m_pImageManager | Image manager of docking panes.
m_pLayout | Selected layout.
m_pPaintManager | Current paint manager.
m_pPreviewLayout | Preview mode layout.
m_pSite | Parent window of docking manager.
m_pToolTipContext | Tooltip Context.
m_pWindowSelectClass | Runtime class of WindowSelect
m_strFloatingFrameCaption | The caption that is displayed in the title bar of a floating frame that has panes docked.


CXTPDockingPaneManager Data Members Public Data Members

CXTPDockingPaneManager Data Members Public Data Members
CXTPDockingPaneManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bCloseGroupOnButtonClick | If TRUE, when the close button on a group of panes is clicked, then the entire group of panes is closed.
m_bHideGroupOnButtonClick | If TRUE, when the hide button on a group of panes is clicked, then the entire group of panes is hidden.
m_bShowSizeCursorWhileDragging | TRUE to show size cursor while panes are dragged
m_nSplitterGap | Minimum available width of panes.
m_nStickyGap | Sticky gap
m_ptMinClientSize | Minimum client size


Legend

Legend
CXTPDockingPaneMiniWnd Data Members
Legend
Data Member
protected


CXTPDockingPaneMiniWnd Data Members Protected Data Members

CXTPDockingPaneMiniWnd Data Members Protected Data Members
CXTPDockingPaneMiniWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bCloseEnabled | Close button of frame is enabled.
m_bCollapsed | Pane is collapsed
m_bDelayInvalidate | True to redraw frame after small delay
m_bExpanded | Pane is collapsed but expanded now
m_bSlideOut | Pane is currently expanding.
m_nDeactivationCount | Deactivation counter.
m_nExpandedHeight | Expanded height of the frame.
m_nSlideStep | Current step of animation process
m_nStepsCount | Total steps of animation process
m_pTopContainer | Top level container.


CXTPDockingPaneMiniWnd Data Members Public Data Members

CXTPDockingPaneMiniWnd Data Members Public Data Members
CXTPDockingPaneMiniWnd Data Members | Legend
Public Data Members
Public Data Member | Description
m_bShowPinButton | TRUE to show pin button of the frame.


Legend

Legend
CXTPDockingPaneOffice2003Theme Data Members
Legend
Data Member
protected


CXTPDockingPaneOffice2003Theme Data Members Protected Data Members

CXTPDockingPaneOffice2003Theme Data Members Protected Data Members
CXTPDockingPaneOffice2003Theme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bRoundedCaption | TRUE to draw rounded caption


CXTPDockingPaneOffice2003Theme Data Members Public Data Members

CXTPDockingPaneOffice2003Theme Data Members Public Data Members
CXTPDockingPaneOffice2003Theme Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDrawGripper | TRUE to draw gripper


Legend

Legend
CXTPDockingPaneOfficeTheme Data Members
Legend
Data Member
protected


CXTPDockingPaneOfficeTheme Data Members Protected Data Members

CXTPDockingPaneOfficeTheme Data Members Protected Data Members
CXTPDockingPaneOfficeTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bGradientCaption | TRUE to draw gradient caption.


Legend

Legend
CXTPDockingPanePaintManager Data Members
Legend
Data Member
protected


CXTPDockingPanePaintManager Data Members Protected Data Members

CXTPDockingPanePaintManager Data Members Protected Data Members
CXTPDockingPanePaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrColor | Self colors array.
m_bLunaTheme | TRUE if luna colors user
m_bUseOfficeFont | TRUE to use Tahoma font.
m_bUseStandardFont | TRUE to use system icon font.
m_dwSplitterStyle | Splitter style
m_fntTitle | Title font.
m_fntTitleVertical | Title vertical font.
m_nCaptionButtonStyle | Caption button style
m_nCaptionFontGap | Additional gap of font.
m_nTabsHeight | Tab bar's height.
m_nTitleHeight | Title's height.
m_pPanelPaintManager | Paint Manager used to draw tabs for auto-hide panel
m_pTabPaintManager | Paint Manager used to draw tabs for tabbed container
m_rcCaptionMargin | Margins of caption.
m_strOfficeFont | Office font name.
m_systemTheme | Current system theme.
m_themeButton | WinXP Button theme helper
m_themeCurrent | Current theme.
m_themeExplorer | WinXP Explorer theme helper
m_themeToolbar | Toolbar theme helper
m_themeWindow | WinXP Window Theme helper.


CXTPDockingPanePaintManager Data Members Public Data Members

CXTPDockingPanePaintManager Data Members Public Data Members
CXTPDockingPanePaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDrawCaptionIcon | TRUE to draw caption icon
m_bDrawSingleTab | TRUE to draw single tab.
m_bHighlightActiveCaption | TRUE to highlight active caption.
m_bShowCaption | TRUE to draw captions of tabbed containers
m_bUseBoldCaptionFont | TRUE to use Bold font for caption
m_clrActiveCaption | Color of pane caption when active.
m_clrActiveCaptionText | Active caption text
m_clrDisabledCaptionText | Disabled caption text
m_clrNormalCaption | Color of pane caption when inactive.
m_clrNormalCaptionText | Color of pane caption text when the caption is inactive
m_clrSplitter | Splitter color
m_clrSplitterGradient | Splitter color
m_clrSplitterGripper | Splitter gripper color
m_nSplitterSize | Splitter size


Legend

Legend
CXTPDockingPaneSplitterContainer Data Members
Legend
Data Member
protected


CXTPDockingPaneSplitterContainer Data Members Protected Data Members

CXTPDockingPaneSplitterContainer Data Members Protected Data Members
CXTPDockingPaneSplitterContainer Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bHoriz | TRUE if the splitter orientation is horizontal
m_bRecalcLayout | TRUE if RecalcLayout method currently executed.
m_lstSpliters | List of splitter windows


Legend

Legend
CXTPDockingPaneVisualStudio2005SecondTheme Data Members
Legend
Data Member
protected


CXTPDockingPaneVisualStudio2005SecondTheme Data Members Protected Data Members

CXTPDockingPaneVisualStudio2005SecondTheme Data Members Protected Data Members
CXTPDockingPaneVisualStudio2005SecondTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrCaptionBorder | Color used to draw the border of the pane caption.


Legend

Legend
CXTPEdit Data Members
Legend
Data Member
protected


CXTPEdit Data Members Protected Data Members

CXTPEdit Data Members Protected Data Members
CXTPEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bComposited | TRUE if control is AERO composited.
m_bImeMode | TRUE if IME editor currently enabled.


Legend

Legend
CXTPFontDC Data Members
Legend
Data Member
protected


CXTPFontDC Data Members Protected Data Members

CXTPFontDC Data Members Protected Data Members
CXTPFontDC Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrOldTextColor | Stored an initial text color from the device context.
m_pDC | Stored pointer to a device context.
m_pOldFont | Stored pointer to an initial font from the device context.


Legend

Legend
CXTPFormulaMulDivC Data Members
Legend
Data Member
protected


CXTPFormulaMulDivC Data Members Protected Data Members

CXTPFormulaMulDivC Data Members Protected Data Members
CXTPFormulaMulDivC Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nConstant | Store a constant value.
m_nDivisor | Store a divisor value.
m_nMultiplier | Store a multiplier value.


Legend

Legend
CXTPImageManager Data Members
Legend
Data Member


CXTPImageManager Data Members Public Data Members

CXTPImageManager Data Members Public Data Members
CXTPImageManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAutoResample | TRUE to automatically re-sample alpha bitmaps if msimg32 not found.
m_bUseResources | TRUE to create single bitmap for all icons
m_dDisabledAlphaFactor | Alpha factor of disabled icons.
m_dDisabledBrightnessFactor | Brightness factor of disabled icons.
m_nAlphaClipFormat | Clipboard format of icons.
m_nImageClipFormat | Clipboard format of icons.


Legend

Legend
CXTPImageManagerIcon Data Members
Legend
Data Member


CXTPImageManagerIcon Data Members Public Data Members

CXTPImageManagerIcon Data Members Public Data Members
CXTPImageManagerIcon Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDrawComposited | Draw on Vista composited rects.


Legend

Legend
CXTPImageManagerIconHandle Data Members
Legend
Data Member
protected


CXTPImageManagerIconHandle Data Members Protected Data Members

CXTPImageManagerIconHandle Data Members Protected Data Members
CXTPImageManagerIconHandle Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bClearHandles | TRUE if object must destroy handlers.
m_hBitmap | The underlying Alpha bitmap handler for this CXTPImageManagerIconHandle object.
m_hIcon | The underlying HICON handler for this CXTPImageManagerIconHandle object.
m_pBits | Alpha bitmap bits;


Legend

Legend
CXTPMenuBar Data Members
Legend
Data Member
protected


CXTPMenuBar Data Members Protected Data Members

CXTPMenuBar Data Members Protected Data Members
CXTPMenuBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bMdiApp | TRUE if parent frame is CMDIFrameWnd derived.
m_hMenuDefault | Default menu handle.
m_hWndActiveChild | Active MDI window handle.
m_nIDResource | Resource of default menu.
m_nIDResourceCurrent | Currently active menu.
m_pMDIMenus | MDI menus.


Legend

Legend
CXTPMenuBarMDIMenuInfo Data Members
Legend
Data Member


CXTPMenuBarMDIMenuInfo Data Members Public Data Members

CXTPMenuBarMDIMenuInfo Data Members Public Data Members
CXTPMenuBarMDIMenuInfo Data Members | Legend
Public Data Members
Public Data Member | Description
m_bChanged | TRUE if menu was changed.
m_hIcon | Menu Icon
m_nIDResource | Template identifier
m_pControls | Menu controls
m_strDescription | Description of MDI menu
m_strTitle | Title of MDI menu


Legend

Legend
CXTPMenuBarMDIMenus Data Members
Legend
Data Member
protected


CXTPMenuBarMDIMenus Data Members Protected Data Members

CXTPMenuBarMDIMenus Data Members Protected Data Members
CXTPMenuBarMDIMenus Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_mapMenus | Menu map
m_pMenuBar | Parent Menu Bar


Legend

Legend
CXTPNativeXPTheme Data Members
Legend
Data Member
protected


CXTPNativeXPTheme Data Members Protected Data Members

CXTPNativeXPTheme Data Members Protected Data Members
CXTPNativeXPTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bFlatMenus | TRUE if OS flat menu option enabled
m_clrEdgeHighLightColor | Color of toolbar top line
m_clrEdgeShadowColor | Color of toolbar bottom line
m_themeCombo | ComboBox theme helper
m_themeMenu | Menu theme helper
m_themeRebar | Rebar theme helper
m_themeSpin | Window theme helper
m_themeToolbar | Toolbar theme helper
m_themeWindow | Window theme helper


Legend

Legend
CXTPNewToolbarDlg Data Members
Legend
Data Member


CXTPNewToolbarDlg Data Members Public Data Members

CXTPNewToolbarDlg Data Members Public Data Members
CXTPNewToolbarDlg Data Members | Legend
Public Data Members
Public Data Member | Description
m_nNewID | Toolbar identifier
m_pCommandBar | CommandBar to edit
m_pCommandBars | CommandBars class.
m_strToolbar | Caption of toolbar


Legend

Legend
CXTPNoFlickerWnd Data Members
Legend
Data Member
protected


CXTPNoFlickerWnd Data Members Protected Data Members

CXTPNoFlickerWnd Data Members Protected Data Members
CXTPNoFlickerWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_crBack | An RGB value.


Legend

Legend
CXTPOffice2007Theme Data Members
Legend
Data Member
protected


CXTPOffice2007Theme Data Members Protected Data Members

CXTPOffice2007Theme Data Members Protected Data Members
CXTPOffice2007Theme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nFrameCaptionHeight | Frame caption
m_nRibbonCaptionHeight | Ribbon caption height


CXTPOffice2007Theme Data Members Public Data Members

CXTPOffice2007Theme Data Members Public Data Members
CXTPOffice2007Theme Data Members | Legend
Public Data Members
Public Data Member | Description
m_bFrameStatusBar | TRUE if status bar used to draw.
m_fontFrameCaption | Font used to draw text in the frame caption


Legend

Legend
CXTPPaintManager Data Members
Legend
Data Member
protected


CXTPPaintManager Data Members Protected Data Members

CXTPPaintManager Data Members Protected Data Members
CXTPPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrColor | Self colors array.
m_bEmbossedDisabledText | TRUE to draw disabled text embossed
m_bShowKeyboardCues | TRUE to show keyboard cues - deprecated.
m_bUseOfficeFont | TRUE to use Tahoma font.
m_bUseStandardFont | TRUE to use system font.
m_fontRegular | Regular font.
m_fontRegularBold | Regular bold font.
m_fontVert | Vertical font.
m_fontVertBold | Vertical font.
m_iconsInfo | Specific icons options.
m_nAnimationSteps | Steps of the animation.
m_nAnimationTime | Time of the animation.
m_nEditHeight | Edit text height
m_nTextHeight | Text height of the regular font.
m_strOfficeFont | Office font
m_systemTheme | Current system theme.
m_themeButton | Buttons theme helper.
m_themeCurrent | Current theme.
m_themeStatusBar | StatusBar theme helper.
s_pInstance | Instance of the manager.


CXTPPaintManager Data Members Public Data Members

CXTPPaintManager Data Members Public Data Members
CXTPPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAutoResizeIcons | TRUE to automatically resize icons using current DPI
m_bClearTypeTextQuality | TRUE to enable ClearType text for the font.
m_bEnableAnimation | TRUE to enable animation for all toolbars
m_bFlatMenuBar | TRUE to draw menubar flat
m_bFlatToolBar | TRUE to draw toolbars flat
m_bOffice2007Padding | TRUE if Office2007 metrics used
m_bOffsetPopupLabelText | TRUE if labels in popups drawn with offset
m_bResourceCharSet | TRUE to use font CharSet from loaded resources.
m_bSelectImageInPopupBar | TRUE to select image as in explorer theme.
m_bShowShadow | TRUE to show shadow
m_bThemedCheckBox | TRUE to draw check box using WinXP theme.
m_bThemedStatusBar | TRUE to draw status bar using WinXP theme.
m_bThickCheckMark | TRUE to draw thick check mark
m_bWrapCaptionBelowText | Wrap text for xtpButtonIconAndCaptionBelow buttons
m_clrDisabledIcon | Disabled icons color
m_clrFloatingGripper | Gripper color of floating toolbar.
m_clrFloatingGripperText | Gripper text color of floating toolbar.
m_clrStatusTextColor | Status bar test color
m_fontIcon | Icon font.
m_fontIconBold | Icon bold font.
m_fontSmCaption | Small caption font.
m_fontToolTip | Tooltip font
m_nPopupBarTextPadding | Distance between gripper and control text.
m_nSplitButtonDropDownWidth | Split button drop down width in toolbars
m_nSplitButtonPopupWidth | Split button drop down width in popups
m_pfnSetLayeredWindowAttributes | point to Transparency proc in USER32.dll module
m_pGalleryPaintManager | Gallery paint manager


Legend

Legend
CXTPPaintManagerColor Data Members
Legend
Data Member
protected


CXTPPaintManagerColor Data Members Protected Data Members

CXTPPaintManagerColor Data Members Protected Data Members
CXTPPaintManagerColor Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrCustomValue | Application defined color
m_clrStandardValue | Standard color


Legend

Legend
CXTPPaintManagerColorGradient Data Members
Legend
Data Member


CXTPPaintManagerColorGradient Data Members Public Data Members

CXTPPaintManagerColorGradient Data Members Public Data Members
CXTPPaintManagerColorGradient Data Members | Legend
Public Data Members
Public Data Member | Description
clrDark | Dark color.
clrLight | Light color.
fGradientFactor | Gradient divider factor


Legend

Legend
CXTPPaintManagerFont Data Members
Legend
Data Member
protected


CXTPPaintManagerFont Data Members Protected Data Members

CXTPPaintManagerFont Data Members Protected Data Members
CXTPPaintManagerFont Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bStandardFont | TRUE to use standard font;


Legend

Legend
CXTPPenDC Data Members
Legend
Data Member
protected


CXTPPenDC Data Members Protected Data Members

CXTPPenDC Data Members Protected Data Members
CXTPPenDC Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_hDC | Device context handle.
m_hOldPen | Handle to the previously selected pen.
m_pen | Pen selected into device context.


Legend

Legend
CXTPPopupBar Data Members
Legend
Data Member
protected


CXTPPopupBar Data Members Protected Data Members

CXTPPopupBar Data Members Protected Data Members
CXTPPopupBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bCollapsed | TRUE if popupbar is collapsed.
m_bContextMenu | TRUE if popup bar is context menu
m_bDoubleGripper | TRUE if popup is state popup type
m_bDynamicLayout | TRUE if DynamicLayout routine executed.
m_bExpanded | TRUE if popupbar is expanded.
m_bExpanding | TRUE if popupbar is expanding.
m_bResizable | TRUE to allow resize
m_bShowShadow | TRUE to show the shadow.
m_bTearOffPopup | TRUE if popupbar has tear-off option.
m_bTearOffSelected | TRUE if gripper selected.
m_bTearOffTracking | Tear-off tracking mode.
m_nTearOffID | ID of the Tear-off toolbar.
m_nTearOffTimer | Tear-off timer.
m_nTearOffWidth | Width of the Tear-off toolbar.
m_pControlPopup | Control that popuped the bar.
m_popupFlags | Flags of the bar.
m_pTearOffBar | Tear-off toolbar pointer.
m_ptPopup | Position of the bar.
m_rcBorders | Borders of the bar.
m_rcExclude | Excluded area.
m_rcResizeGripper | Resizable gripper position.
m_rcTearOffGripper | Tear-off gripper position.
m_strTearOffCaption | Caption of the Tear-off toolbar.
m_szTearOffBar | Size of the bar.


CXTPPopupBar Data Members Public Data Members

CXTPPopupBar Data Members Public Data Members
CXTPPopupBar Data Members | Legend
Public Data Members
Public Data Member | Description
m_dMaxWidthDivisor | Maximum available width of popup


Legend

Legend
CXTPPopupControl Data Members
Legend
Data Member
protected


CXTPPopupControl Data Members Protected Data Members

CXTPPopupControl Data Members Protected Data Members
CXTPPopupControl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrItems | array for controlled items
m_bAllowMove | If TRUE, the user can click and drag the popup window anywhere on the screen.
m_bRightToLeft | Right-To-Left layout
m_nAnimationInterval | value of animation interval of a popup window
m_nStep | value of step animation of a popup window
m_nTransparency | current value transparency of a popup window
m_paintTheme | Currently used theme.
m_pImageManager | Images of popup items.
m_popupAnimation | current animation method
m_popupState | current popup state
m_pPaintManager | point to CXTPPopupPaintManager object
m_pPressed | point to pressed item
m_pSelected | point to selected item
m_ptPopup | current XY size of a popup window
m_stateCurrent | Current descriptor
m_stateTarget | Target descriptor
m_szPopup | current XY location of a popup window
m_uAnimationDelay | value of animation delay of a popup window
m_uShowDelay | value of show delay of a popup window


Legend

Legend
CXTPPopupItem Data Members
Legend
Data Member
protected


CXTPPopupItem Data Members Protected Data Members

CXTPPopupItem Data Members Protected Data Members
CXTPPopupItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bBold | Flag of bold state text
m_bButton | Flag of button state
m_bHyperLink | Flag of a hyperlink support
m_clrBackground | Background color
m_clrBorder | Border color
m_clrText | Text color
m_fntText | Font of an item text
m_nAlign | Alignment style of an item text
m_nIconIndex | Icon Index in parent image maanger;
m_nID | ID number of an item
m_nIndex | Index of item in parent list.
m_pControl | Point to CXTPPopupControl object containing this item
m_pRichRender | Richext Render
m_ptOffset | Icon offset
m_rcItem | Rectangular of an item
m_strCaption | Caption string


Legend

Legend
CXTPPopupPaintManager Data Members
Legend
Data Member


CXTPPopupPaintManager Data Members Public Data Members

CXTPPopupPaintManager Data Members Public Data Members
CXTPPopupPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrBackground | gradient background color
m_clrButtonPressed | color of pressed button
m_clrButtonPressedBorder | 3d border color of pressed button
m_clrButtonSelected | color of selected button
m_clrButtonSelectedBorder | 3d border color of selected button
m_clrFrame | 3d frame color
m_clrText | default color of text
m_fntText | default font of text


Legend

Legend
CXTPPopupThemeOffice2003 Data Members
Legend
Data Member


CXTPPopupThemeOffice2003 Data Members Public Data Members

CXTPPopupThemeOffice2003 Data Members Public Data Members
CXTPPopupThemeOffice2003 Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrGripper | Color of the popup gripper for the xtpPopupThemeOffice2003 paint theme.


Legend

Legend
CXTPPrintOptions Data Members
Legend
Data Member
protected


CXTPPrintOptions Data Members Protected Data Members

CXTPPrintOptions Data Members Protected Data Members
CXTPPrintOptions Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pPageFooter | A page Footer properties.
m_pPageHeader | A page Header properties.


CXTPPrintOptions Data Members Public Data Members

CXTPPrintOptions Data Members Public Data Members
CXTPPrintOptions Data Members | Legend
Public Data Members
Public Data Member | Description
m_bBlackWhitePrinting | Store printing mode: Color or Black&White.
m_nBlackWhiteContrast | Black&White printing contrast: 0 ...
m_rcMargins | Margins (mm*100 or inches*1000)


Legend

Legend
CXTPPrintPageHeaderFooter Data Members
Legend
Data Member
protected


CXTPPrintPageHeaderFooter Data Members Protected Data Members

CXTPPrintPageHeaderFooter Data Members Protected Data Members
CXTPPrintPageHeaderFooter Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bHeader | If TRUE object represents a Header, otherwise footer.
m_pOwner | Store pointer to owner object.


CXTPPrintPageHeaderFooter Data Members Public Data Members

CXTPPrintPageHeaderFooter Data Members Public Data Members
CXTPPrintPageHeaderFooter Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrColor | Text color
m_lfFont | Font details
m_strCenter | A string to show with center align
m_strFormatString | Text as Format string
m_strLeft | A string to show with left align
m_strRight | A string to show with right align


Legend

Legend
CXTPPropertyGrid Data Members
Legend
Data Member
protected


CXTPPropertyGrid Data Members Protected Data Members

CXTPPropertyGrid Data Members Protected Data Members
CXTPPropertyGrid Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bEnableTooltips | TRUE if tooltips enabled
m_bHelpVisible | TRUE if the help panel is visible.
m_bHighlightChanged | TRUE to highlight changed values
m_bMultiSelect | TRUE for MultiSelect;
m_bPreSubclassWindow | true' when initialized from PreSubclassWindow.
m_bShowInplaceButtonsAlways | TRUE to show all inplace buttons
m_bTabCaptions | TRUE to navigate items with the tab key.
m_bTabItems | TRUE to navigate items with the tab key.
m_bToolBarVisible | TRUE if the built in toolbar is visible.
m_bVariableItemsHeight | TRUE to allow variable items height
m_bVerbsVisible | TRUE if the verb panel is visible.
m_hCursorHand | Handle of the cursor.
m_hCursorSplit | Handle to the cursor when positioned over a splitter.
m_nFocusedVerb | Index of the currently focused verb within the collection of verbs.
m_pImageManager | Image manager of property grid
m_pInplaceEdit | In-place edit control.
m_pInplaceListBox | In-place list control.
m_pPaintManager | Current paint manager.
m_pToolTipContext | Tooltip context
m_pVerbs | Collection of verbs (links) displayed in the verb panel when the panel is visible.
m_pView | View pointer
m_themeCurrent | Currently set theme.
m_wndToolbar | Pointer to the "built-in" PropertyGrid toolbar.


CXTPPropertyGrid Data Members Public Data Members

CXTPPropertyGrid Data Members Public Data Members
CXTPPropertyGrid Data Members | Legend
Public Data Members
Public Data Member | Description
m_bHideSelection | TRUE to hide selection when control doesn't have focus;
m_nHelpHeight | Height of the description area (help panel).
m_nVerbsHeight | Height of the verbs panel.


Legend

Legend
CXTPPropertyGridInplaceControl Data Members
Legend
Data Member
protected


CXTPPropertyGridInplaceControl Data Members Protected Data Members

CXTPPropertyGridInplaceControl Data Members Protected Data Members
CXTPPropertyGridInplaceControl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nWidth | Width of in-place item
m_pItem | Parent item pointer


Legend

Legend
CXTPPropertyGridInplaceControls Data Members
Legend
Data Member
protected


CXTPPropertyGridInplaceControls Data Members Protected Data Members

CXTPPropertyGridInplaceControls Data Members Protected Data Members
CXTPPropertyGridInplaceControls Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrControls | Arraay of controls


Legend

Legend
CXTPPropertyGridInplaceMonthCal Data Members
Legend
Data Member
protected


CXTPPropertyGridInplaceMonthCal Data Members Protected Data Members

CXTPPropertyGridInplaceMonthCal Data Members Protected Data Members
CXTPPropertyGridInplaceMonthCal Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pItem | Parent item


Legend

Legend
CXTPPropertyGridInplaceSlider Data Members
Legend
Data Member
protected


CXTPPropertyGridInplaceSlider Data Members Protected Data Members

CXTPPropertyGridInplaceSlider Data Members Protected Data Members
CXTPPropertyGridInplaceSlider Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nMax | Upper range
m_nMin | Lower range
m_nValue | Value of slider


Legend

Legend
CXTPPropertyGridInplaceSpinButton Data Members
Legend
Data Member
protected


CXTPPropertyGridInplaceSpinButton Data Members Protected Data Members

CXTPPropertyGridInplaceSpinButton Data Members Protected Data Members
CXTPPropertyGridInplaceSpinButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nMax | Upper range
m_nMin | Lower range


Legend

Legend
CXTPPropertyGridItem Data Members
Legend
Data Member
protected


CXTPPropertyGridItem Data Members Protected Data Members

CXTPPropertyGridItem Data Members Protected Data Members
CXTPPropertyGridItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bCategory | TRUE if the item is category.
m_bConstraintEdit | TRUE to constraint edit.
m_bExpandable | TRUE if item can be expanded.
m_bExpanded | TRUE if item is expanded.
m_bHidden | TRUE if item is hidden
m_bPassword | TRUE to use a password mask.
m_bReadOnly | TRUE to disable item's edition.
m_bUseMask | TRUE to use and edit mask to display item data.
m_bVisible | Visibility of the item.
m_chPrompt | Character used as a space holder for a character.
m_dwData | The 32-bit value associated with the item
m_dwEditStyle | Edit style.
m_nDropDownItemCount | Maximum drop down items
m_nFlags | Item's flags.
m_nHeight | Item's height.
m_nID | Identifier of the item.
m_nIndent | Indent of the item.
m_nIndex | Index of the item.
m_nLinesCount | Count of lines of Multi line item.
m_pBindString | Binded string.
m_pCaptionMetrics | Caption part metrics
m_pChilds | Child items.
m_pConstraints | Item's constraints.
m_pGrid | Parent grid class.
m_pInplaceButtons | Inplace buttons array
m_pParent | Parent item.
m_pValueMetrics | Value part metrics
m_strCaption | Caption of the item.
m_strDefaultValue | Default value of the item.
m_strDescription | Description of the item.
m_strFormat | Format of the double value.
m_strLiteral | String to use as literal.
m_strMask | String to use as edit mask.
m_strValue | Value of the item.


Legend

Legend
CXTPPropertyGridItemBool Data Members
Legend
Data Member
protected


CXTPPropertyGridItemBool Data Members Protected Data Members

CXTPPropertyGridItemBool Data Members Protected Data Members
CXTPPropertyGridItemBool Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bCheckBoxStyle | Check box style
m_bValue | Value of the item.
m_pBindBool | Binded value.
m_strFalseText | Text of the FALSE label.
m_strTrueText | Text of the TRUE label.


Legend

Legend
CXTPPropertyGridItemColor Data Members
Legend
Data Member
protected


CXTPPropertyGridItemColor Data Members Protected Data Members

CXTPPropertyGridItemColor Data Members Protected Data Members
CXTPPropertyGridItemColor Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrValue | Color value of the item.
m_colorEditor | Editor type of color item
m_pBindColor | Pointer to variable bound to this item, this is the color of the bound item.


Legend

Legend
CXTPPropertyGridItemConstraint Data Members
Legend
Data Member
protected


CXTPPropertyGridItemConstraint Data Members Protected Data Members

CXTPPropertyGridItemConstraint Data Members Protected Data Members
CXTPPropertyGridItemConstraint Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nIndex | Index of constraint.
m_pItem | Parent item


CXTPPropertyGridItemConstraint Data Members Public Data Members

CXTPPropertyGridItemConstraint Data Members Public Data Members
CXTPPropertyGridItemConstraint Data Members | Legend
Public Data Members
Public Data Member | Description
m_dwData | The 32-bit value associated with the item.
m_nImage | Image index
m_strConstraint | Caption text of constraint.


Legend

Legend
CXTPPropertyGridItemDate Data Members
Legend
Data Member
protected


CXTPPropertyGridItemDate Data Members Protected Data Members

CXTPPropertyGridItemDate Data Members Protected Data Members
CXTPPropertyGridItemDate Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_oleDate | Currently selected date.
m_pBindDate | Pointer to variable bound to this item, this is the date of the bound item.
m_strNullValue | String value to be displayed for a Date Item when the current date is NULL.


Legend

Legend
CXTPPropertyGridItemDouble Data Members
Legend
Data Member
protected


CXTPPropertyGridItemDouble Data Members Protected Data Members

CXTPPropertyGridItemDouble Data Members Protected Data Members
CXTPPropertyGridItemDouble Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bUseSystemDecimalSymbol | TRUE to use system defined decimal symbol, FALSE to always use a decimal point ".".
m_fValue | Double value of item.
m_pBindDouble | Binded value.


Legend

Legend
CXTPPropertyGridItemEnum Data Members
Legend
Data Member
protected


CXTPPropertyGridItemEnum Data Members Protected Data Members

CXTPPropertyGridItemEnum Data Members Protected Data Members
CXTPPropertyGridItemEnum Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nValue | Value of the item.
m_pBindEnum | Binded value.


Legend

Legend
CXTPPropertyGridItemFlags Data Members
Legend
Data Member
protected


CXTPPropertyGridItemFlags Data Members Protected Data Members

CXTPPropertyGridItemFlags Data Members Protected Data Members
CXTPPropertyGridItemFlags Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nValue | Value of the item.
m_pBindFlags | Binded value.


Legend

Legend
CXTPPropertyGridItemFont Data Members
Legend
Data Member
protected


CXTPPropertyGridItemFont Data Members Protected Data Members

CXTPPropertyGridItemFont Data Members Protected Data Members
CXTPPropertyGridItemFont Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrValue | Font color.
m_lfValue | Value of the item, this holds the current font value.


Legend

Legend
CXTPPropertyGridItemMetrics Data Members
Legend
Data Member
protected


CXTPPropertyGridItemMetrics Data Members Protected Data Members

CXTPPropertyGridItemMetrics Data Members Protected Data Members
CXTPPropertyGridItemMetrics Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pPaintManager | Pointer to the paint manager used to draw the property grid.


CXTPPropertyGridItemMetrics Data Members Public Data Members

CXTPPropertyGridItemMetrics Data Members Public Data Members
CXTPPropertyGridItemMetrics Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrBack | Background color.
m_clrCategoryFore | Color of the category text.
m_clrFore | Color of the item's text.
m_clrHelpBack | Color of the description background.
m_clrHelpFore | Color of the description text.
m_clrLine | Line color.
m_clrReadOnlyFore | Color of read-only text.
m_clrVerbFace | Text color of verbs.
m_fontBold | Bold font.
m_fontNormal | Normal font.
m_nImage | Image index.
m_nMaxLength | Maximum number of characters that can be entered into an editable item (Edit limit).
m_uDrawTextFormat | Text formatting style for the property item.


Legend

Legend
CXTPPropertyGridItemNumber Data Members
Legend
Data Member
protected


CXTPPropertyGridItemNumber Data Members Protected Data Members

CXTPPropertyGridItemNumber Data Members Protected Data Members
CXTPPropertyGridItemNumber Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nValue | Value of the item.
m_pBindNumber | Binded object.


Legend

Legend
CXTPPropertyGridOffice2003Theme Data Members
Legend
Data Member
protected


CXTPPropertyGridOffice2003Theme Data Members Protected Data Members

CXTPPropertyGridOffice2003Theme Data Members Protected Data Members
CXTPPropertyGridOffice2003Theme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bLunaTheme | TRUE to use luna colors, FALSE otherwise


Legend

Legend
CXTPPropertyGridPaintManager Data Members
Legend
Data Member
protected


CXTPPropertyGridPaintManager Data Members Protected Data Members

CXTPPropertyGridPaintManager Data Members Protected Data Members
CXTPPropertyGridPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_fntVerbNormal | Font used to display the caption of verbs without underline
m_fntVerbUnderline | Font used to display the caption of verbs with underline
m_pGrid | Parent grid class.
m_pMetrics | Default metrics of the item


CXTPPropertyGridPaintManager Data Members Public Data Members

CXTPPropertyGridPaintManager Data Members Public Data Members
CXTPPropertyGridPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bTransparent | TRUE to draw background with parent color
m_buttonsStyle | TRUE to use WinXP themes.
m_clrFace | Face color.
m_clrHighlight | Highlight color.
m_clrHighlightText | Highlight text color.
m_clrShadow | Shadow color.
m_themeButton | Themes for button controls
m_themeCombo | Themes for combo button.
m_themeTree | Themes for Tree controls.


Legend

Legend
CXTPPropertyGridToolTip Data Members
Legend
Data Member
protected


CXTPPropertyGridToolTip Data Members Protected Data Members

CXTPPropertyGridToolTip Data Members Protected Data Members
CXTPPropertyGridToolTip Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_fnt | Font used to display the tool tip
m_pGrid | Parent window.


Legend

Legend
CXTPPropertyGridUpdateContext Data Members
Legend
Data Member
protected


CXTPPropertyGridUpdateContext Data Members Protected Data Members

CXTPPropertyGridUpdateContext Data Members Protected Data Members
CXTPPropertyGridUpdateContext Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_mapState | Stores the expanded state of each item in the grid before CXTPPropertyGrid::BeginUpdate.
m_nSelected | Stores the Id of the currently selected item before CXTPPropertyGrid::BeginUpdate.
m_nTopIndex | Stores the Index of the top-most visible item in the property grid.
m_propertySort | Stores the currently used sort method of the grid before CXTPPropertyGrid::BeginUpdate.


Legend

Legend
CXTPPropertyGridVerb Data Members
Legend
Data Member
protected


CXTPPropertyGridVerb Data Members Protected Data Members

CXTPPropertyGridVerb Data Members Protected Data Members
CXTPPropertyGridVerb Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nID | Id assigned this verb link.
m_nIndex | Index of this verb link in the collection of verbs.
m_ptClick | The last position the user clicked.
m_pVerbs | Collection of verb links.
m_rcPart | Bounding rectangle of verb.
m_strCaption | Text caption of this verb link.


Legend

Legend
CXTPPropertyGridVerbs Data Members
Legend
Data Member
protected


CXTPPropertyGridVerbs Data Members Protected Data Members

CXTPPropertyGridVerbs Data Members Protected Data Members
CXTPPropertyGridVerbs Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrVerbs | Collection of verb links.
m_pGrid | Pointer to the property grid that the verbs are drawn on.


Legend

Legend
CXTPPropertyGridView Data Members
Legend
Data Member
protected


CXTPPropertyGridView Data Members Protected Data Members

CXTPPropertyGridView Data Members Protected Data Members
CXTPPropertyGridView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoDivider | TRUE to auto calculate divider
m_bTracking | TRUE if grid in tracking mode.
m_bVariableSplitterPos | TRUE to allow the user to resize the splitter with the mouse.
m_dDivider | Divider position.
m_hCursor | Handle of the cursor.
m_nItemHeight | Default height of the item
m_nLockUpdate | TRUE to lock update.
m_pCategories | Collection of the categories.
m_pFocusedButton | Currently focused button
m_pGrid | Parent CXTPPropertyGrid class.
m_pHotButton | Currently highlighted button
m_properetySort | Current sort order.
m_pSelected | Current selected item.
m_rcToolTip | Position of the Tooltip.
m_strTipText | Tooltip text.
m_wndTip | Tooltip control.


Legend

Legend
CXTPPropertyPage Data Members
Legend
Data Member
protected


CXTPPropertyPage Data Members Protected Data Members

CXTPPropertyPage Data Members Protected Data Members
CXTPPropertyPage Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bModified | TRUE to indicate that the property page settings have been modified
m_pSheet | Parent CXTPPropertySheet object


CXTPPropertyPage Data Members Public Data Members

CXTPPropertyPage Data Members Public Data Members
CXTPPropertyPage Data Members | Legend
Public Data Members
Public Data Member | Description
m_dwData | Page specific 32-bit value


Legend

Legend
CXTPPropertyPageNavigator Data Members
Legend
Data Member
protected


CXTPPropertyPageNavigator Data Members Protected Data Members

CXTPPropertyPageNavigator Data Members Protected Data Members
CXTPPropertyPageNavigator Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pSheet | Parent property sheet object


CXTPPropertyPageNavigator Data Members Public Data Members

CXTPPropertyPageNavigator Data Members Public Data Members
CXTPPropertyPageNavigator Data Members | Legend
Public Data Members
Public Data Member | Description
m_rcButtonMargin | Total buttons margin
m_rcNavigatorMargin | Total navigator margin
m_rcPageMargin | Total page margin


Legend

Legend
CXTPPropertySheet Data Members
Legend
Data Member
protected


CXTPPropertySheet Data Members Protected Data Members

CXTPPropertySheet Data Members Protected Data Members
CXTPPropertySheet Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrButtons | Array of buttons of property sheet
m_arrPages | Array of propety pages
m_bAllowApply | TRUE to allow enable apply button
m_bModeless | TRUE if property sheet was created as modeless window
m_bResizable | TRUE if dialog can be resized
m_fntNormal | Font used to draw buttons and navigator
m_lpDlgTemplate | Dialog template
m_nPageBorderStyle | Client border style
m_pActivePage | Pointer to active property page
m_pNavigator | Currently used navigator
m_rcPage | Bounding rectangle of active page
m_scSizeIcon | Resize glyph
m_strCaption | Caption of the dialog
m_szButton | Button size
m_szWindow | Last window size of property sheet


CXTPPropertySheet Data Members Public Data Members

CXTPPropertySheet Data Members Public Data Members
CXTPPropertySheet Data Members | Legend
Public Data Members
Public Data Member | Description
m_psh | The Windows PROPSHEETHEADER structure.


Legend

Legend
CXTPPropExchange Data Members
Legend
Data Member
protected


CXTPPropExchange Data Members Protected Data Members

CXTPPropExchange Data Members Protected Data Members
CXTPPropExchange Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bChildSection | TRUE if section is child
m_bEmptySection | TRUE if EmptySection method was called.
m_bInitialized | TRUE if section was initialized.
m_bLoading | TRUE if properties are being loaded to the class.
m_bUseDefaultOnLoad | TRUE if default values must be used in load process.
m_bUseDefaultOnSave | TRUE if default values must be used in save process.
m_nSchema | Schema of object.


CXTPPropExchange Data Members Public Data Members

CXTPPropExchange Data Members Public Data Members
CXTPPropExchange Data Members | Legend
Public Data Members
Public Data Member | Description
m_dwData | User defined 32-bit value.
m_lcidDateTime | User regional language
m_pOwner | User defined Owner value.


Legend

Legend
CXTPPropExchangeArchive Data Members
Legend
Data Member
protected


CXTPPropExchangeArchive Data Members Protected Data Members

CXTPPropExchangeArchive Data Members Protected Data Members
CXTPPropExchangeArchive Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_ar | Contains the underlying CArchive for this CXTPPropExchangeArchive object.


Legend

Legend
CXTPPropExchangeEnumerator Data Members
Legend
Data Member
protected


CXTPPropExchangeEnumerator Data Members Protected Data Members

CXTPPropExchangeEnumerator Data Members Protected Data Members
CXTPPropExchangeEnumerator Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nCount | Count of items to load.
m_pContainer | Parent section of enumerator
m_strSectionName | Enumerator section name


Legend

Legend
CXTPPropExchangeIniFile Data Members
Legend
Data Member
protected


CXTPPropExchangeIniFile Data Members Protected Data Members

CXTPPropExchangeIniFile Data Members Protected Data Members
CXTPPropExchangeIniFile Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bTempFile | TRUE if temporary file was created.
m_strFileName | Temporary file name.
m_strSectionName | Section name.


Legend

Legend
CXTPPropExchangeRegistry Data Members
Legend
Data Member
protected


CXTPPropExchangeRegistry Data Members Protected Data Members

CXTPPropExchangeRegistry Data Members Protected Data Members
CXTPPropExchangeRegistry Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bCloseParentKey | TRUE to automatically close parent key
m_hParentKey | Parent registry key
m_hSectionKey | Current registry key
m_strSectionName | Section name


Legend

Legend
CXTPPropExchangeXMLNode Data Members
Legend
Data Member
protected


CXTPPropExchangeXMLNode Data Members Protected Data Members

CXTPPropExchangeXMLNode Data Members Protected Data Members
CXTPPropExchangeXMLNode Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bCompactMode | TRUE to use compact mode.
m_strEncoding | XML encoding.
m_strSectionName | Section name
m_xmlDocPtr | XML Document pointer
m_xmlParentNode | XML Parent node pointer
m_xmlSectionNode | XML Section node pointer


Legend

Legend
CXTPReBarPaintManager Data Members
Legend
Data Member
protected


CXTPReBarPaintManager Data Members Protected Data Members

CXTPReBarPaintManager Data Members Protected Data Members
CXTPReBarPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_themeRebar | ReBar theme helper.


Legend

Legend
CXTPReportColumn Data Members
Legend
Data Member
protected


CXTPReportColumn Data Members Protected Data Members

CXTPReportColumn Data Members Protected Data Members
CXTPReportColumn Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAllowDrag | Allow/disallow dragging of the column
m_bAllowRemove | TRUE to allow column remove
m_bAutoSize | TRUE if column auto sized.
m_bAutoSortWhenGrouped | If TRUE this column will be sortable when grouped by, otherwise it will grouped without sorting by it (sort by other columns wiil be applied).
m_bDrawFooterDivider | If TRUE - draw footer column right divider.
m_bDrawFooterRowsVGrid | Indicates whether to draw vertical grid for footers rows.
m_bDrawHeaderDivider | If TRUE - draw header column right divider.
m_bDrawHeaderRowsVGrid | Indicates whether to draw vertical grid for headers rows.
m_bEditable | Indicates whether an edit box should be added to the items in the column.
m_bFiltrable | Is filtering by this column allowed?.
m_bGroupable | Determines if the column could be grouped by.
m_bIsResizable | Indicates if the column allows width resizing
m_bShowInFieldChooser | Indicates if column is shown in the field chooser when the column is hidden or in the GroupBy Box.
m_bSortable | Determines if the column could be sortable by.
m_bSortIncreasing | Stores column sort direction (used when m_bSortable is TRUE).
m_bVisible | Visible state.
m_fontFooter | Column Footer font.
m_nAlignment | Alignment mode for column: DT_LEFT || DT_RIGHT || DT_CENTER
m_nBestFitMode | Best fit mode.
m_nColumnAutoWidth | The column a automatic width
m_nColumnStaticWidth | The user defined with.
m_nFooterAlignment | Alignment mode for column footer text: DT_LEFT || DT_RIGHT || DT_CENTER
m_nHeaderAlignment | Alignment mode for column text: DT_LEFT || DT_RIGHT || DT_CENTER
m_nIconID | Associated icon ID.
m_nItemIndex | Column index.
m_nMaxItemWidth | Contains maximal width of the corresponding item drawn in the column.
m_nMinWidth | Minimal column width.
m_pColumns | Stores a pointer to the parent columns collection.
m_pEditOptions | Edit options of the column
m_rcColumn | Saves rectangle where column was drawn last time.
m_rcGroupBy | Saves rectangle where column was drawn in group box.
m_strFooterText | Column Footer Text.
m_strInternalName | Internal column name (to serialize colunm options).
m_strName | Column name.
m_strTooltip | Column tooltip.


Legend

Legend
CXTPReportColumnOrder Data Members
Legend
Data Member
protected


CXTPReportColumnOrder Data Members Protected Data Members

CXTPReportColumnOrder Data Members Protected Data Members
CXTPReportColumnOrder Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrColumns | Storage for column items with the corresponding order.
m_pColumns | Parent columns array.


Legend

Legend
CXTPReportColumns Data Members
Legend
Data Member
protected


CXTPReportColumns Data Members Protected Data Members

CXTPReportColumns Data Members Protected Data Members
CXTPReportColumns Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrColumns | Storage for column items.
m_pControl | Pointer to the associated report control object.
m_pGroupsOrder | Container for the columns order in auto grouping mode.
m_pSortOrder | Container for the columns sort order.
m_pTreeColumn | Column containing tree view images.


Legend

Legend
CXTPReportControl Data Members
Legend
Data Member
protected


CXTPReportControl Data Members Protected Data Members

CXTPReportControl Data Members Protected Data Members
CXTPReportControl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrScreenRows | Rows currently presented on screen.
m_bAllowEdit | TRUE if sub-items can be edited.
m_bAutoCheckItems | TRUE to enable auto check mode, FALSE to disable auto check mode.
m_bChanged | Internal member for storing changed flag.
m_bDragMode | TRUE if records currently dragging
m_bEditOnClick | TRUE if sub-items become editable on a single-click
m_bFilterHiddenColumns | Search filter text in hidden columns too.
m_bFocusSubItems | TRUE if sub-items can receive focus.
m_bFooterAllowEdit | TRUE if sub-items of footer rows can be edited.
m_bFooterRecordsVisible | TRUE if footer records are visible.
m_bFooterRowsAllowAccess | TRUE if a footer row can be selected by user.
m_bFooterRowsSelectionEnable | TRUE if footer row selection enabled.
m_bFooterVisible | TRUE if column footer are visible.
m_bFullColumnScrolling | Store Full Column Scrolling mode for horizontal scrolling.
m_bGroupByEnabled | TRUE if Group By box is enabled
m_bHeaderAllowEdit | TRUE if sub-items of header rows can be edited.
m_bHeaderRecordsVisible | TRUE if header records are visible.
m_bHeaderRowsAllowAccess | TRUE if a header row can be selected by user.
m_bHeaderRowsSelectionEnable | TRUE if header row selection enabled.
m_bHeaderVisible | TRUE if column headers are visible.
m_bHScrollBarVisible | TRUE if horizontal scroll bar is visible
m_bmpCache | Cached window bitmap.
m_bMultipleSelection | TRUE if multiple selection enabled.
m_bMultiSelectionMode | TRUE if multiselection mode enabled (i.e.
m_bmWatermark | Watermark bitmap info.
m_bOnSizeRunning | TRUE if OnSize handler is entered, FALSE otherwise.
m_bPinFooterRecords | TRUE if footer records are drawn immediately after the body rows.
m_bPrepareDrag | TRUE if user click the report control and doesn't release button.
m_bRefreshIndexes | TRUE when it is required to refresh items indexes.
m_bRowFocusVisible | TRUE if showing focused row rectangle enabled.
m_bSelectionEnable | TRUE if selection enabled.
m_bShowTooltips | TRUE if showing tool tips enabled.
m_bSkipGroupsFocus | TRUE if group rows are skipped when navigating rows with the Up and Down arrow keys
m_bSortRecordChilds | TRUE to apply sort order for Record children.
m_bVScrollBarVisible | TRUE if vertical scroll bar is visible
m_cfReport | Report Clipboard format for drag/drop operations
m_dwDragDropFlags | Drag/drop flags.
m_hbmpWatermark | Watermark bitmap handle.
m_mouseMode | Current mouse operation mode
m_nDisableReorderColumnsCount | Count of columns at the left side where reordering is disabled.
m_nDropPos | Position of records to be dropped
m_nEnsureVisibleColumnIdx | Ensure visible column index.
m_nEnsureVisibleRowIdx | Ensure visible row index.
m_nFocusedFooterRow | Pointer to the currently focused footer row.
m_nFocusedHeaderRow | Pointer to the currently focused header row.
m_nFocusedRow | Pointer to the currently focused row.
m_nFreezeColumnsCount | Count of none-scrolled columns at the left side.
m_nHScrollStep | Horizontal scroll step (in pixels).
m_nLeftOffset | Horizontal scroll position.
m_nLockUpdateCount | A counter of the update locks.
m_nPopulatedRecordsCount | Current number of records in the report after using m_strFilterText.
m_nRowsPerWheel | Amount of rows to scroll by mouse wheel.
m_nTopRow | Current top row in the visible area.
m_pActiveItem | Pointer to the currently focused CXTPReportRecordItem.
m_pColumns | List columns container.
m_pDropRecords | Drop records.
m_pDropTarget | Internal drag/drop helper.
m_pFocusedColumn | Pointer to the currently focused CXTPReportColumn.
m_pFooterRecords | Footer records container.
m_pFooterRows | Virtual list of footer rows container.
m_pHeaderRecords | Header records container.
m_pHeaderRows | Virtual list of header rows container.
m_pHotRow | Hot row
m_pImageManager | Contains image list for report control
m_pInplaceButtons | In-place buttons pointer
m_pInplaceEdit | In-place edit pointer
m_pInplaceList | In-place list pointer
m_pNavigator | Navigator
m_pointDrag | Drag position
m_pPaintManager | Paint manager.
m_pPlainTree | Tree rows container.
m_pRecords | List records container.
m_pReportHeader | List header member.
m_pRows | Virtual list rows container.
m_pRowsCompareFunc | Pointer to rows compare function.
m_pSelectedRows | Container for the currently selected rows.
m_pSelectOnUpRow | Row to select on mouse up.
m_pToolTipContext | Tool tip Context.
m_ptrVirtualEditingRow | Currently editing row in virtual mode.
m_rcFooterArea | The area occupied by the footer.
m_rcFooterRecordsArea | The area occupied by the footer records.
m_rcFooterRecordsDividerArea | The area occupied by the footer records divider.
m_rcGroupByArea | The area occupied by Group By item.
m_rcHeaderArea | The area occupied by the header.
m_rcHeaderRecordsArea | The area occupied by the header records.
m_rcHeaderRecordsDividerArea | The area occupied by the header records divider.
m_rcReportArea | The area occupied by rows.
m_strFilterText | Filter text.
m_uAutoScrollTimerID | Auto scroll timer ID or 0.
m_WatermarkAlignment | Watermark alignment flags.
m_WatermarkTransparency | Watermark bitmap transparency value.
m_wndTip | Tip window.


Legend

Legend
CUpdateContext Data Members
Legend
Data Member
protected


CUpdateContext Data Members Protected Data Members

CUpdateContext Data Members Protected Data Members
CUpdateContext Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pControl | Updated report control pointer


Legend

Legend
CXTPReportFilterEditControl Data Members
Legend
Data Member
protected


CXTPReportFilterEditControl Data Members Protected Data Members

CXTPReportFilterEditControl Data Members Protected Data Members
CXTPReportFilterEditControl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pReportCtrl | Pointer to the main report control.
m_strHint | Grayed-out text displayed in the edit control to show a helpful description like "Enter filter text here".


Legend

Legend
CXTPReportGroupRow Data Members
Legend
Data Member
protected


CXTPReportGroupRow Data Members Protected Data Members

CXTPReportGroupRow Data Members Protected Data Members
CXTPReportGroupRow Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_strGroupText | group text label


Legend

Legend
CXTPReportHeader Data Members
Legend
Data Member
protected


CXTPReportHeader Data Members Protected Data Members

CXTPReportHeader Data Members Protected Data Members
CXTPReportHeader Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAllowColumnRemove | FALSE if columns removing is not allowed.
m_bAllowColumnReorder | FALSE if columns reordering is not allowed.
m_bAllowColumnResize | FALSE if columns resizing is not allowed.
m_bAllowColumnSort | FALSE if columns sorting is not allowed.
m_bAutoColumnSizing | TRUE if AutoColumnSizing should be used.
m_bDragGroupBox | Determines whether control is in group box dragging mode.
m_bDragHeader | Determines whether control is in header dragging mode or group by dragging mode.
m_bShowItemsInGroups | TRUE when showing items in groups, FALSE when grouping is not used.
m_dragMode | Column dragging mode.
m_hDontDropCursor | Handler of user's Don't Drop cursor.
m_hResizeCursor | Handler of user's Resizing cursor.
m_nDropIndex | Item index of the column to drop to.
m_nHeaderWidth | The combined width of all the visible column headers.
m_nIndentLevel | Width indent at the left of the column.
m_nResizeCaptureRange | Distance around column divider where column re-sizer is shown.
m_pColumns | Contains associated columns list.
m_pControl | Pointer to the parent Report control.
m_pDragColumn | Dragging column.
m_pDragWnd | Column drag window.
m_pDropWnd | Column drop window.
m_pFilterEdit | Filter edit control
m_pHotTrackingColumn | Hot column
m_pSubList | Field chooser list control.
m_ptMouse | Stores mouse coordinates for processing when required (resizing, etc).
m_rcGroupBy | Group By area coordinates.
m_rcHeader | Header coordinates.


CXTPReportHeader Data Members Public Data Members

CXTPReportHeader Data Members Public Data Members
CXTPReportHeader Data Members | Legend
Public Data Members
Public Data Member | Description
s_bSendContextMenuForWholeHeaderArea | If set as TRUE report control send ContextMenu event for clicks on whole header area (not only for columns) rectangles.
s_bShowItemsInGroupsPXDefault | Store default value of m_bShowItemsInGroups member for serialization (PropExchange).
s_nMinAutoScrollStep | Minimal horizontal autoscrolling step in pixels.


Legend

Legend
CXTPReportHeaderDragWnd Data Members
Legend
Data Member
protected


CXTPReportHeaderDragWnd Data Members Protected Data Members

CXTPReportHeaderDragWnd Data Members Protected Data Members
CXTPReportHeaderDragWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pColumn | Pointer to the associated report column object.
m_pHeader | Pointer to the associated report header object.
m_pPaintManager | Pointer to the associated paint manager object.


Legend

Legend
CXTPReportHeaderDropWnd Data Members
Legend
Data Member
protected


CXTPReportHeaderDropWnd Data Members Protected Data Members

CXTPReportHeaderDropWnd Data Members Protected Data Members
CXTPReportHeaderDropWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clr | Drawing brush.
m_nHeight | Height of the gap between 2 arrows.
m_rgn | Arrows region.


Legend

Legend
CXTPReportHyperlink Data Members
Legend
Data Member


CXTPReportHyperlink Data Members Public Data Members

CXTPReportHyperlink Data Members Public Data Members
CXTPReportHyperlink Data Members | Legend
Public Data Members
Public Data Member | Description
m_nHyperTextBegin | Start position of the hyperlink in the item text.
m_nHyperTextLen | The length of hyperlink text.
m_rcHyperSpot | Hyperlink draw place.


Legend

Legend
CXTPReportInplaceButton Data Members
Legend
Data Member
protected


CXTPReportInplaceButton Data Members Protected Data Members

CXTPReportInplaceButton Data Members Protected Data Members
CXTPReportInplaceButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bInsideCell | Store button place: inside the cell rect, or outside.
m_bOver | TRUE if the mouse cursor is over the button.
m_bPressed | TRUE if the button is pressed.
m_nFixedHeight | Width of the button.
m_nIconIndex | Icon index.
m_nID | Identifier of the button.
m_nSpinIncrement | Spin button only: increment value.
m_nSpinMax | Spin button only: maximum value.
m_nSpinMin | Spin button only: minimum value.
m_nSpinStep | Spin button only: step value.
m_nState | Button state.
m_nWidth | Width of the button.
m_unSpinTimerCnt | Spin button only: timer counter.
m_unSpinTimerId | Spin button only: timer identifier.


Legend

Legend
CXTPReportInplaceEdit Data Members
Legend
Data Member
protected


CXTPReportInplaceEdit Data Members Protected Data Members

CXTPReportInplaceEdit Data Members Protected Data Members
CXTPReportInplaceEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bSetWindowText | Indicates that text is being set with SetWindowText function.
m_clrText | Text color of in-place edit.
m_fntEdit | Font of in-place edit.
m_pSelectedConstraint | Selected constraint.
m_strText_prev | The text value from previous change.
m_strValue | The value of item before user change it.


Legend

Legend
CXTPReportPageSetupDialog Data Members
Legend
Data Member
protected


CXTPReportPageSetupDialog Data Members Protected Data Members

CXTPReportPageSetupDialog Data Members Protected Data Members
CXTPReportPageSetupDialog Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pOptions | Pointer to associated print options object.


Legend

Legend
CXTPReportPaintManager Data Members
Legend
Data Member
protected


CXTPReportPaintManager Data Members Protected Data Members

CXTPReportPaintManager Data Members Protected Data Members
CXTPReportPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bDrawGridForEmptySpace | TRUE if grid fills the empty space (if any) after the body rows.
m_bFixedInplaceButtonHeight | TRUE if fixed Inplace Buttons height used.
m_bFixedRowHeight | TRUE if fixed rows used.
m_bIsPreviewMode | Show or not show the item preview.
m_brushHorizontalGrid | Stores brush to draw horizontal grid lines
m_brushTreeStructure | Stores brush to draw tree nodes
m_brushVeriticalGrid | Stores brush to draw vertical grid lines
m_columnStyle | Contains column drawing style.
m_horizontalGridStyle | Stores current style for horizontal grid lines
m_ilGlyphs | Contains an additional image list for report control
m_nFooterHeight | Column footer height.
m_nFreezeColsDividerStyle | A set of flags from XTPReportFreezeColsDividerStyle
m_nGroupGridLineHeight | The height of the group grid line.
m_nHeaderHeight | Column header height.
m_nMaxPreviewLines | Restrict maximum lines for preview text
m_nResizingWidth | The width of the column resizing marker area.
m_nRowHeight | Report row default height.
m_pHeaderHeightFormula | MulDivC formula for header height calculation
m_szGlyph | Glyph size
m_themeButton | In-place button theme wrapper.
m_themeCombo | Combobox in-place button theme wrapper.
m_themeSpin | Spin in-place button theme wrapper.
m_themeWrapper | Header theme wrapper.
m_verticalGridStyle | Stores current style for vertical grid lines


CXTPReportPaintManager Data Members Public Data Members

CXTPReportPaintManager Data Members Public Data Members
CXTPReportPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDrawSortTriangleAlways | If TRUE, the sort triangle displayed in column headers when a column is sorted will always be displayed as long as the column size is large enough to drawn the triangle.
m_bGroupRowTextBold | TRUE to draw group rows with bold text.
m_bHideSelection | TRUE when hiding report control's selection by drawing selected items as others, FALSE otherwise.
m_bHotTracking | TRUE to allow column hot tracking
m_bInvertColumnOnClick | TRUE to invert column on click
m_bRevertAlignment | TRUE to revert column alignments
m_bShadeGroupHeadings | Show or not show the indentation shade.
m_bShadeSortColumn | Show or not show the items shade in the sorted by column.
m_bThemedInplaceButtons | Draw in-place buttons using current theme settings.
m_bUseColumnTextAlignment | TRUE to draw caption text accordingly to its alignment
m_bUseEditTextAlignment | TRUE to automatically apply edit alignment using column alignment
m_clrBtnFace | Standard button face color.
m_clrBtnText | Standard button text color.
m_clrCaptionText | Column header text color.
m_clrColumnOffice2007CustomTheme | Base color for Office2007 custom theme.
m_clrControlBack | Background color of the control report area.
m_clrControlDark | Dark background color of the report control (used on Group By area).
m_clrControlLightLight | Light background color used for drawing shades (used on column header area).
m_clrFooterRowsDivider | Color of footer divider.
m_clrFreezeColsDivider | Freeze Columns Divider color.
m_clrGradientColumnSeparator | Separator of column used with xtpReportColumnOffice2003 style
m_clrGradientColumnShadow | Bottom shadow of column used with xtpReportColumnOffice2003 style
m_clrGridLine | Grid lines color.
m_clrGroupBoxBack | Color of group box.
m_clrGroupRowText | Row text color.
m_clrGroupShadeBack | Group row background color when indentation shade is enabled.
m_clrGroupShadeBorder | Color for group border's shade.
m_clrGroupShadeText | Group row foreground color when indentation shade is enabled.
m_clrHeaderControl | Background color of the report header.
m_clrHeaderRowsDivider | Color of header divider.
m_clrHighlight | Background color of the highlighted row.
m_clrHighlightText | Text color of the highlighted text.
m_clrHotDivider | Color of the column hot divider window (2 arrows).
m_clrHyper | Hyperlink color.
m_clrIndentControl | Color of the tree indentation area.
m_clrItemShade | Color of the shade on sorted by column items.
m_clrPreviewText | Preview text color.
m_clrSelectedRow | Selected row background color.
m_clrSelectedRowText | Selected row text color.
m_clrWindowText | Report items default text color.
m_crlNoGroupByText | A color for "No items" text in GroupBy area (see m_strNoGroupBy member)
m_fontBoldText | Report items default bold text.
m_fontCaption | Column header caption font.
m_fontPreview | Column header caption font.
m_fontText | Report items default text.
m_FooterRowsDividerStyle | Style of a divider line between the footer and body rows.
m_grcGradientColumn | Color of column used with xtpReportColumnOffice2003 style
m_grcGradientColumnHot | HotTracking Color of column used with xtpReportColumnOffice2003 style
m_grcGradientColumnPushed | Pushed Color of column used with xtpReportColumnOffice2003 style
m_HeaderRowsDividerStyle | Style of a divider line between the header and body rows.
m_nTreeIndent | Tree indentation.
m_nTreeStructureStyle | Tree structure style.
m_rcPreviewIndent | Preview indentation.
m_strNoFieldsAvailable | A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
m_strNoGroupBy | A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
m_strNoItems | A string which contains customized "No Items" text for displaying in view when there are no visible rows.
m_strSortBy | A string which contains customized "Sort By" text for displaying in tooltip
m_treeStructureStyle | Tree structure style


Legend

Legend
CXTPReportRecord Data Members
Legend
Data Member
protected


CXTPReportRecord Data Members Protected Data Members

CXTPReportRecord Data Members Protected Data Members
CXTPReportRecord Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrItems | An internal storage for record items.
m_bEditable | TRUE if the record is editable, FALSE otherwise.
m_bExpanded | Contains record expanded state.
m_bLocked | Stores locked state for the record.
m_bVisible | Is this record visible or not
m_nIndex | Index of the record within the collection records.
m_pChildren | A collection of children records.
m_pPreviewItem | store Preview Item for record
m_pRecords | Parent records collection.


Legend

Legend
CXTPReportRecordItem Data Members
Legend
Data Member
protected


CXTPReportRecordItem Data Members Protected Data Members

CXTPReportRecordItem Data Members Protected Data Members
CXTPReportRecordItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_Alignment | Alignment style for item.
m_bBoldText | Is bold text.
m_bChecked | TRUE if item checked.
m_bEditable | Stores editable flag.
m_bFocusable | TRUE if item accept focus.
m_bHasCheckbox | TRUE if item has check box.
m_bItemControlUnderMouse | TRUE if an item control is under the mouse pointer.
m_clrBackground | Storage for item background color.
m_clrText | Storage for item text color.
m_dwData | The 32-bit value associated with the item.
m_nGroupPriority | Group priority
m_nIconIndex | ID of the bitmap from the application resources.
m_nSortPriority | Sort priority
m_pEditOptions | Edit options of the item.
m_pFocusedItemControl | Focused record item control.
m_pFontCaption | Storage for item caption font.
m_pHyperlinks | Array of the Item's hyperlinks
m_pItemControlHookWnd | Item control hook window.
m_pItemControls | Record item control list.
m_pRecord | Pointer to the associated record item, if any, or NULL otherwise.
m_rcGlyph | Coordinates of drawn glyph.
m_strCaption | Caption of the item
m_strFormatString | Stores string for extra formatting of item caption.
m_strGroupCaption | Caption of the group
m_strTooltip | Tooltip of the item.


Legend

Legend
CXTPReportRecordItemConstraint Data Members
Legend
Data Member
protected


CXTPReportRecordItemConstraint Data Members Protected Data Members

CXTPReportRecordItemConstraint Data Members Protected Data Members
CXTPReportRecordItemConstraint Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nIndex | Index of constraint.


CXTPReportRecordItemConstraint Data Members Public Data Members

CXTPReportRecordItemConstraint Data Members Public Data Members
CXTPReportRecordItemConstraint Data Members | Legend
Public Data Members
Public Data Member | Description
m_dwData | The 32-bit value associated with the item.
m_strConstraint | Caption text of constraint.


Legend

Legend
CXTPReportRecordItemConstraints Data Members
Legend
Data Member
protected


CXTPReportRecordItemConstraints Data Members Protected Data Members

CXTPReportRecordItemConstraints Data Members Protected Data Members
CXTPReportRecordItemConstraints Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrConstraints | Collection of constraints


Legend

Legend
CXTPReportRecordItemDateTime Data Members
Legend
Data Member
protected


CXTPReportRecordItemDateTime Data Members Protected Data Members

CXTPReportRecordItemDateTime Data Members Protected Data Members
CXTPReportRecordItemDateTime Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_odtValue | Cell value.


Legend

Legend
CXTPReportRecordItemEditOptions Data Members
Legend
Data Member


CXTPReportRecordItemEditOptions Data Members Public Data Members

CXTPReportRecordItemEditOptions Data Members Public Data Members
CXTPReportRecordItemEditOptions Data Members | Legend
Public Data Members
Public Data Member | Description
arrInplaceButtons | Array of in-place buttons.
m_bAllowEdit | TRUE to add an edit box to this item.
m_bConstraintEdit | If TRUE, then you can only choose from the list of constraints added, If FALSE, then you can type a custom response not listed in the list of constraints.
m_bSelectTextOnEdit | Select all text on edit
m_dwEditStyle | Edit Style (ES_MULTILINE, ES_NUMBER....)
m_nMaxLength | Maximum number of characters that can be entered into an editable item (Edit limit).
m_pConstraints | Constraint list.


Legend

Legend
CXTPReportRecordItemNumber Data Members
Legend
Data Member
protected


CXTPReportRecordItemNumber Data Members Protected Data Members

CXTPReportRecordItemNumber Data Members Protected Data Members
CXTPReportRecordItemNumber Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dValue | Cell value.


Legend

Legend
CXTPReportRecordItemPreview Data Members
Legend
Data Member
protected


CXTPReportRecordItemPreview Data Members Protected Data Members

CXTPReportRecordItemPreview Data Members Protected Data Members
CXTPReportRecordItemPreview Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_strPreviewText | Preview content.


Legend

Legend
CXTPReportRecordItemText Data Members
Legend
Data Member
protected


CXTPReportRecordItemText Data Members Protected Data Members

CXTPReportRecordItemText Data Members Protected Data Members
CXTPReportRecordItemText Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_strText | Item text value.


Legend

Legend
CXTPReportRecordItemVariant Data Members
Legend
Data Member


CXTPReportRecordItemVariant Data Members Public Data Members

CXTPReportRecordItemVariant Data Members Public Data Members
CXTPReportRecordItemVariant Data Members | Legend
Public Data Members
Public Data Member | Description
m_nSortLocale | Sort locale
m_oleValue | Item value.


Legend

Legend
CXTPReportRecords Data Members
Legend
Data Member
protected


CXTPReportRecords Data Members Protected Data Members

CXTPReportRecords Data Members Protected Data Members
CXTPReportRecords Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrRecords | Internal storage array for Record items.
m_bCaseSensitive | Indicating whether string comparisons are case-sensitive.
m_nVirtualRecordsCount | Virtual records count.
m_pMarkupContext | Markup Context;
m_pOwnerRecord | Store pointer to owner record object (or NULL);
m_pVirtualRecord | Virtual record.


Legend

Legend
CXTPReportRow Data Members
Legend
Data Member
protected


CXTPReportRow Data Members Protected Data Members

CXTPReportRow Data Members Protected Data Members
CXTPReportRow Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bExpanded | TRUE when row is expanded in a tree view, FALSE when row is collapsed.
m_bVisible | TRUE if this row should be visible, FALSE when row is hidden.
m_nChildIndex | Index of row inside parent rows.
m_nGroupLevel | Contains row depth level when row is a group row.
m_nIndex | Item index.
m_nPreviewHeight | Height of the preview item of this row.
m_nRowLevel | Row depth level in a tree.
m_nRowType | Row type from XTPReportRowType
m_pChilds | A collection of row children.
m_pControl | Pointer to the parent report control.
m_pParentRow | Pointer to the parent row in the tree.
m_pParentRows | Pointer to the parent rows in the tree.
m_pRecord | Pointer to the associated CXTPReportRecord object.
m_rcCollapse | A rectangle with coordinates of collapse/expand bitmap.
m_rcRow | A rectangle where a row is to be drawn.


Legend

Legend
CXTPReportRows Data Members
Legend
Data Member
protected


CXTPReportRows Data Members Protected Data Members

CXTPReportRows Data Members Protected Data Members
CXTPReportRows Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nVirtualRowsCount | Count of virtual rows.
m_pVirtualRow | Virtual row.


Legend

Legend
CXTPReportSubListControl Data Members
Legend
Data Member
protected


CXTPReportSubListControl Data Members Protected Data Members

CXTPReportSubListControl Data Members Protected Data Members
CXTPReportSubListControl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bSortAscending | TRUE to sort items in list.
m_nDropIndex | Drop item index.
m_pDragWnd | Pointer to the associated dragging window.
m_pReportCtrl | Pointer to the parent report control.
m_rcDragWnd | Coordinates of the associated dragging window.
m_rcDropTarget1 | Contains first drop target - the list window itself.
m_rcDropTarget2 | Contains second drop target - report header.


Legend

Legend
CXTPReportTip Data Members
Legend
Data Member
protected


CXTPReportTip Data Members Protected Data Members

CXTPReportTip Data Members Protected Data Members
CXTPReportTip Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bMultiline | Multiline tooltip flag.
m_fntToolTip | Font for displaying tooltip text.
m_nRowIndex | Index of item's row.
m_pItem | Item which tooltip is visible.
m_pParentWnd | Pointer to the parent report window.
m_rcHover | Hover window coordinates.
m_strTooltipText | Tooltip text to display.


Legend

Legend
CXTPReportView Data Members
Legend
Data Member
protected


CXTPReportView Data Members Protected Data Members

CXTPReportView Data Members Protected Data Members
CXTPReportView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_aPageStart | Printed indexes.
m_bmpGrayDC | A temporary bitmap to convert colored report control image to 'gray' colors when printing in black&while mode.
m_bPrintSelection | TRUE if only printing the currently selected rows in the report, FALSE if printing the entire report,
m_pPrintOptions | Printing options.
m_pReport | Child report control pointer.
m_pScrollBar | Store pointer to external scrollbar control.
m_wndReport | Child report control window.


CXTPReportView Data Members Public Data Members

CXTPReportView Data Members Public Data Members
CXTPReportView Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAllowCut | If TRUE the cut operation is allowed.
m_bAllowPaste | If TRUE the paste operation is allowed.
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bResizeControlWithView | if FALSE - attached Report control will not be resized with view.


Legend

Legend
CXTPReportViewPrintOptions Data Members
Legend
Data Member


CXTPReportViewPrintOptions Data Members Public Data Members

CXTPReportViewPrintOptions Data Members Public Data Members
CXTPReportViewPrintOptions Data Members | Legend
Public Data Members
Public Data Member | Description
m_bRepeatFooterRows | If TRUE - the footer rows will be printed on every page.
m_bRepeatHeaderRows | If TRUE - the header rows will be printed on every page.


Legend

Legend
CXTPResourceManager Data Members
Legend
Data Member
protected


CXTPResourceManager Data Members Protected Data Members

CXTPResourceManager Data Members Protected Data Members
CXTPResourceManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bValid | TRUE if Resource manager is valid.
m_hModXTResource | Handle to toolkit resource.
m_hResourceFile | Resource file handle.
m_pLanguageInfo | Resource language


CXTPResourceManager Data Members Public Data Members

CXTPResourceManager Data Members Public Data Members
CXTPResourceManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_managerInstance | Manager instance.


Legend

Legend
CManageState Data Members
Legend
Data Member
protected


CManageState Data Members Protected Data Members

CManageState Data Members Protected Data Members
CManageState Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bSet | true to set
m_hModOldResource | Handle to previous resource.


Legend

Legend
CXTPRibbonBar Data Members
Legend
Data Member
protected


CXTPRibbonBar Data Members Protected Data Members

CXTPRibbonBar Data Members Protected Data Members
CXTPRibbonBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAllowMinimize | TRUE to allow minimize ribbon
m_bAllowQuickAccessCustomization | TRUE to allow quick access customization
m_bAllowQuickAccessDuplicates | TRUE to allow quick access duplicates
m_bGroupReducedChanged | Some group appear in resize handler
m_bGroupsVisible | TRUE if groups is visible
m_bMinimized | TRUE if Ribbon currently minimized
m_bRibbonBarVisible | TRUE if ribbon bar visible
m_bShowCaptionAlways | TRUE to show caption even if EnableFrameTheme was not called.
m_bShowQuickAccess | TRUE to show quick access
m_bShowQuickAccessBelow | TRUE to show quick access controls below ribbon bar
m_bTabsVisible | TRUE if tabs are visible
m_nGroupsHeight | Custom groups height
m_nMinVisibleWidth | Minimum width before ribbon bar disappears
m_nQuickAccessHeight | Quick Access height
m_pContextHeaders | Context header collection
m_pControlQuickAccess | Quick Access menu control
m_pControlQuickAccessMore | Quick Access more control
m_pControlSystemButton | System button control
m_pControlTab | Control tab pointer
m_pFrameHook | Office 2007 Frame hook
m_pQuickAccessControls | Quick AccessControls (not used now)
m_rcCaption | Caption bounding rectangle
m_rcCaptionText | Caption text bounding rectangle
m_rcGroups | Groups bounding rectangle
m_rcHeader | Header bounding rectangle
m_rcQuickAccess | Quick access bounding rectangle
m_rcTabControl | Bounding rectangle of Tabs
m_strCaptionText | Caption text


Legend

Legend
CXTPRibbonControlTab Data Members
Legend
Data Member
protected


CXTPRibbonControlTab Data Members Protected Data Members

CXTPRibbonControlTab Data Members Protected Data Members
CXTPRibbonControlTab Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bFocused | TRUE if groups focused


Legend

Legend
CXTPRibbonCustomizeQuickAccessPage Data Members
Legend
Data Member
protected


CXTPRibbonCustomizeQuickAccessPage Data Members Protected Data Members

CXTPRibbonCustomizeQuickAccessPage Data Members Protected Data Members
CXTPRibbonCustomizeQuickAccessPage Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrCategories | Array of categories.
m_pCommandBars | Parent CommandBars object
m_pSheet | Parent Sheet window


CXTPRibbonCustomizeQuickAccessPage Data Members Public Data Members

CXTPRibbonCustomizeQuickAccessPage Data Members Public Data Members
CXTPRibbonCustomizeQuickAccessPage Data Members | Legend
Public Data Members
Public Data Member | Description
m_bShowQuickAccessBelow | TRUE to show quick access below ribbon
m_lstCategories | Categories list
m_lstCommands | Commands list
m_lstQuickAccess | Quick access list


Legend

Legend
CXTPRibbonGroup Data Members
Legend
Data Member
protected


CXTPRibbonGroup Data Members Protected Data Members

CXTPRibbonGroup Data Members Protected Data Members
CXTPRibbonGroup Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrControls | Collection of group's controls
m_bControlsCentering | TRUE to center controls inside groups
m_bControlsGrouping | TRUE to group controls
m_bReduced | TRUE if group was reduced
m_bShowOptionButton | TRUE to show option button
m_bVisible | TRUE if group is visible
m_nIconId | Icon index of the group
m_nId | Identifier of the group
m_nIndex | Index of the group
m_nRowCount | Total rows number of items
m_pControlGroupOption | Group option control
m_pControlGroupPopup | Group popup control
m_pGroups | Parent groups collection
m_pParent | Parent ribbon bar
m_pRibbonBar | Parent ribbon bar
m_rcGroup | Bounding rectangle of the group
m_strCaption | Caption of the group


Legend

Legend
CXTPRibbonGroups Data Members
Legend
Data Member
protected


CXTPRibbonGroups Data Members Protected Data Members

CXTPRibbonGroups Data Members Protected Data Members
CXTPRibbonGroups Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrGroups | Collection of groups.
m_nGroupsScrollPos | Scroll position
m_pParentTab | A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to.


Legend

Legend
CXTPRibbonTab Data Members
Legend
Data Member
protected


CXTPRibbonTab Data Members Protected Data Members

CXTPRibbonTab Data Members Protected Data Members
CXTPRibbonTab Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nContextColor | Context color
m_nId | Identifier of the tab.
m_pContextHeader | Context header
m_pGroups | Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
m_pRibbonBar | The CXTPRibbonBar object the CXTPRibbonTab belongs to.
m_strContextCaption | Context caption


Legend

Legend
CXTPRibbonTheme Data Members
Legend
Data Member
protected


CXTPRibbonTheme Data Members Protected Data Members

CXTPRibbonTheme Data Members Protected Data Members
CXTPRibbonTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrControlEditNormal | Edit control color
m_clrMinimizedFrameEdgeHighLight | Minimzed bottom edge
m_clrMinimizedFrameEdgeShadow | Minimzed bottom edge shadow
m_clrRibbonFace | Ribbon face color
m_clrRibbonGroupCaptionText | Ribbon group captions color
m_clrRibbonText | Ribbon text color
m_nFontHeight | Ribbon font height
m_nGroupCaptionHeight | Group caption bar height
m_pTabPaintManager | Tab paint manager


CXTPRibbonTheme Data Members Public Data Members

CXTPRibbonTheme Data Members Public Data Members
CXTPRibbonTheme Data Members | Legend
Public Data Members
Public Data Member | Description
m_bHotTrackingGroups | TRUE to highlight group under cursor
m_fontGroupCaption | Font used to draw text in the group caption
m_nTabsHeight | Tabs heights


Legend

Legend
CXTPShortcutBar Data Members
Legend
Data Member
protected


CXTPShortcutBar Data Members Protected Data Members

CXTPShortcutBar Data Members Protected Data Members
CXTPShortcutBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrItems | Array of items.
m_bAllowCollapse | TRUE to allow collapse items.
m_bAllowFreeResize | TRUE to allow resize gripper by pixel;
m_bAllowResize | TRUE to allow resize
m_bClientPaneVisible | TRUE is client Pane in ShortcutBar is visible
m_bPreSubclassWindow | True if PreSubclassWindow was called
m_bShowActiveItemOnTop | TRUE to show active item on top
m_bShowGripper | TRUE to show gripper.
m_bSingleSelection | TRUE to use single selected items.
m_bTrackingSize | TRUE if control in tracking mode.
m_hHandCursor | Hand cursor that is displayed when the cursor is positioned over a shortcut bar item.
m_hSizeCursor | Handle to the cursor displayed for the size icon.
m_hwndClient | Client window handle
m_nDesiredExpandedLinesHeight | Desired visible lines height height.
m_nExpandedLines | Number of lines currently visible
m_nMinClientHeight | The height of client area.
m_paintTheme | Current theme.
m_pHotItem | Pointer to hot item.
m_pImageManager | Current image manager.
m_pPaintManager | Current paint manager.
m_pPressedItem | Pointer to pressed item.
m_pSelectedItem | Pointer to selected item.
m_pToolTipContext | Tooltip Context.
m_rcClient | Client's rectangle.
m_rcGripper | Gripper's rectangle.
m_szItem | Size of items


Legend

Legend
CXTPShortcutBarItem Data Members
Legend
Data Member
protected


CXTPShortcutBarItem Data Members Protected Data Members

CXTPShortcutBarItem Data Members Protected Data Members
CXTPShortcutBarItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bExpandButton | True if the item is expand button
m_bExpanded | TRUE if the item is expanded
m_bHidden | TRUE if the item is hidden
m_bSelected | TRUE if item selected
m_bVisible | TRUE if the item is visible
m_dwData | The 32-bit value associated with the item
m_hwndChild | Child window associated with the item
m_nIconId | Identifier of the item's image.
m_nID | Item's identifier.
m_pShortcutBar | Parent CXTPShortcutBar class
m_rcItem | Bounding rectangle of the item
m_strCaption | Caption for the item.
m_strTooltip | Tooltip for the item.


Legend

Legend
CXTPShortcutBarOffice2003Theme Data Members
Legend
Data Member


CXTPShortcutBarOffice2003Theme Data Members Public Data Members

CXTPShortcutBarOffice2003Theme Data Members Public Data Members
CXTPShortcutBarOffice2003Theme Data Members | Legend
Public Data Members
Public Data Member | Description
m_bShowTopLeftCaptionShadow | True to draw rectangle around items
m_clrCaptionText | Color of items text
m_clrItemCaptionShadow | Color of subcaption shadow
m_clrItemCaptionText | Color of subcaption text
m_clrItemCaptionTop | Color under subcaption rectangle
m_grcCaption | Caption color
m_grcItemCaption | Items color
m_grcItemHotCaption | Items color


Legend

Legend
CXTPShortcutBarPaintManager Data Members
Legend
Data Member


CXTPShortcutBarPaintManager Data Members Public Data Members

CXTPShortcutBarPaintManager Data Members Public Data Members
CXTPShortcutBarPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bBoldItemCaptionFont | TRUE to draw item with bold font
m_bClearTypeTextQuality | TRUE to use ClearType font
m_bUseStandardFont | TRUE to use standard font
m_clrHotText | Color of Caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
m_clrNormalText | Color of Caption text when an CXTPShortcutBarItem is displayed normally.
m_clrPushedText | Color of Caption text when an CXTPShortcutBarItem is pressed.
m_clrSelectedText | Color of Caption text when an CXTPShortcutBarItem is selected, this happens after the item is clicked.
m_clrShortcutItemShadow | Color of line border that goes around each item.
m_fntPaneCaption | Caption font.
m_fntPaneItemCaption | Sub-caption font.
m_fntText | Text font.
m_grcHot | Color gradient of "hot" items.
m_grcPushed | Color gradient of item when clicked on.
m_grcSelected | Color gradient of currently selected item,
m_grcShortcutBarGripper | Color Gradient used to draw the shortcut bar gripper.
m_grcShortcutItem | Color gradient of shortcut bar item's.
m_nExpandedIconWidth | Width of the expanded icons.
m_nNormalIconWidth | Width of the icons.
m_nPaneItemHeight | Height of sub-pane caption.
m_pExpandIcon | Pointer to expand icon


Legend

Legend
CXTPShortcutBarPane Data Members
Legend
Data Member
protected


CXTPShortcutBarPane Data Members Protected Data Members

CXTPShortcutBarPane Data Members Protected Data Members
CXTPShortcutBarPane Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrItems | Array of items.
m_bShowCaption | TRUE to show caption
m_hHandCursor | Hand cursor
m_nMinClientHeight | The minimum height of client area.
m_pShortcutBar | Parent CXTPShortcutBar class.
m_rcIndent | Indentationpadding around the client pane
m_strCaption | Caption of the pane.


Legend

Legend
CXTPShortcutBarPaneItem Data Members
Legend
Data Member
protected


CXTPShortcutBarPaneItem Data Members Protected Data Members

CXTPShortcutBarPaneItem Data Members Protected Data Members
CXTPShortcutBarPaneItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bExpandable | TRUE if pane is expandable
m_bExpanded | TRUE if pane is expanded
m_bShowCaption | TRUE to show caption
m_nHeight | Height of the item.
m_pPane | Parent pane object
m_pWndClient | Associated child window.
m_rcCaption | Rectangle of the caption.
m_rcClient | Bounding rectangle of the client area.
m_strCaption | Caption of the item


Legend

Legend
CXTPShortcutManager Data Members
Legend
Data Member
protected


CXTPShortcutManager Data Members Protected Data Members

CXTPShortcutManager Data Members Protected Data Members
CXTPShortcutManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pAccelTable | Accelerator table
m_pKeyNameText | KeyNameText map.
m_pOriginalAccelTable | Original accelerator table.


CXTPShortcutManager Data Members Public Data Members

CXTPShortcutManager Data Members Public Data Members
CXTPShortcutManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAllowEscapeShortcut | TRUE to allow escape to use as shortcut
m_bUseSystemKeyNameText | TRUE to use localized shortcuts
m_nDisableShortcuts | Number of shortcuts that have been disabled.


Legend

Legend
CXTPSkinImage Data Members
Legend
Data Member
protected


CXTPSkinImage Data Members Protected Data Members

CXTPSkinImage Data Members Protected Data Members
CXTPSkinImage Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAlpha | TRUE if bitmap has alpha pixels
m_bFiltered | TRUE if image was filtered
m_hBitmap | Bitmap handle


CXTPSkinImage Data Members Public Data Members

CXTPSkinImage Data Members Public Data Members
CXTPSkinImage Data Members | Legend
Public Data Members
Public Data Member | Description
m_bMirrorImage | TRUE to Invert image in RTL mode


Legend

Legend
CXTPSkinImages Data Members
Legend
Data Member
protected


CXTPSkinImages Data Members Protected Data Members

CXTPSkinImages Data Members Protected Data Members
CXTPSkinImages Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_mapImages | Collection of images


Legend

Legend
CXTPSkinManager Data Members
Legend
Data Member
protected


CXTPSkinManager Data Members Protected Data Members

CXTPSkinManager Data Members Protected Data Members
CXTPSkinManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrFilters | Array of filters to apply
m_bAutoApplyThreads | TRUE to auto skin all new windows
m_bAutoApplyWindows | TRUE to auto skin all new windows
m_bEnabled | TRIE if skinning is enabled
m_bWin9x | TRUE if OS is Win9x
m_dwApplyOptions | Apply options.
m_dwComCtrl | Version of ComCtl.dll
m_hWinEventHook | HWINEVENTHOOK value that identifies event hook instance
m_mapClasses | Classes collection
m_mapObjects | Collection of CXTPSkinObject classes
m_pClassMap | Class map helper
m_pMetrics | Skin metrics
m_pResourceFile | Resource file
m_pSchema | Current schema
s_pInstance | Instance of SkinManager


Legend

Legend
CXTPSkinManagerClass Data Members
Legend
Data Member
protected


CXTPSkinManagerClass Data Members Protected Data Members

CXTPSkinManagerClass Data Members Protected Data Members
CXTPSkinManagerClass Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_mapCachedProperties | Cached collection of class properties
m_nClassCode | Hashed value of class name
m_pImages | Image collection
m_pManager | Parent CXTPSkinManager object.
m_strClass | Class name


Legend

Legend
CXTPSkinManagerMetrics Data Members
Legend
Data Member


CXTPSkinManagerMetrics Data Members Public Data Members

CXTPSkinManagerMetrics Data Members Public Data Members
CXTPSkinManagerMetrics Data Members | Legend
Public Data Members
Public Data Member | Description
m_brTheme | Brushes of the theme
m_brushDialog | Dialog brush
m_brushTabControl | Tab Control brush;
m_clrEdgeDkShadow | Dark shadow edge color
m_clrEdgeHighLight | HighLight edge color
m_clrEdgeLight | Light edge color
m_clrEdgeShadow | Shadow edge color
m_clrTheme | Colors of the theme
m_cxBorder | SM_CXBORDER system metric
m_cxEdge | SM_CXEDGE system metric
m_cxHScroll | SM_CXHSCROLL system metric
m_cxVScroll | SM_CXVSCROLL system metric
m_cyBorder | SM_CYBORDER system metric
m_cyCaption | Height of captions
m_cyEdge | SM_CYEDGE system metric
m_cyHScroll | SM_CYHSCROLL system metric
m_cyOsCaption | System caption height
m_cyOsSmallCaption | System small caption height
m_cySmallCaption | Height of small captions
m_cyVScroll | SM_CYVSCROLL system metric
m_fntCaption | Caption font
m_fntMenu | Menu font
m_fntSmCaption | Small caption font
m_nBorderSize | Border size
m_pManager | Parent CXTPSkinManager object


Legend

Legend
CXTPSkinManagerResourceFile Data Members
Legend
Data Member
protected


CXTPSkinManagerResourceFile Data Members Protected Data Members

CXTPSkinManagerResourceFile Data Members Protected Data Members
CXTPSkinManagerResourceFile Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_hInstance | Handle of the visual style
m_hModule | Handle of the visual style
m_lpTextFile | Pointer to next string
m_lpTextFileEnd | Pointer to end of the file
m_pIniFile | POinter to ini file on disk
m_pManager | Parent manager class.
m_strIniFileName | Ini file name.
m_strResourcePath | Resource path


Legend

Legend
CXTPSkinManagerSchema Data Members
Legend
Data Member
protected


CXTPSkinManagerSchema Data Members Protected Data Members

CXTPSkinManagerSchema Data Members Protected Data Members
CXTPSkinManagerSchema Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_mapProperties | Properties collection
m_pManager | Parent CXTPSkinManager class
m_strSchemaName | Schema name


Legend

Legend
CXTPSkinManagerSchemaDefault Data Members
Legend
Data Member
protected


CXTPSkinManagerSchemaDefault Data Members Protected Data Members

CXTPSkinManagerSchemaDefault Data Members Protected Data Members
CXTPSkinManagerSchemaDefault Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrFrameRegions | Frame region
m_nFrameButtonOffset | Frame Button offset


Legend

Legend
CXTPSkinManagerSchemaProperty Data Members
Legend
Data Member


CXTPSkinManagerSchemaProperty Data Members Public Data Members

CXTPSkinManagerSchemaProperty Data Members Public Data Members
CXTPSkinManagerSchemaProperty Data Members | Legend
Public Data Members
Public Data Member | Description
nPropertyCode | Property code
propType | Property type


Legend

Legend
CXTPSkinObject Data Members
Legend
Data Member
protected


CXTPSkinObject Data Members Protected Data Members

CXTPSkinObject Data Members Protected Data Members
CXTPSkinObject Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bActiveX | TRUE if ActiveX controls
m_bWindowsForms | TRUE if .NET controls
m_pManager | Parent CXTPSkinManager object
m_pOldWndProc | Old window window handler
m_strClassName | Own class name
m_wndDefProcAddr | Address of previous window procedure


Legend

Legend
CXTPSkinObjectButton Data Members
Legend
Data Member
protected


CXTPSkinObjectButton Data Members Protected Data Members

CXTPSkinObjectButton Data Members Protected Data Members
CXTPSkinObjectButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bHot | TRUE if mouse under button
m_bPushed | TRUE if button was pressed


CXTPSkinObjectButton Data Members Public Data Members

CXTPSkinObjectButton Data Members Public Data Members
CXTPSkinObjectButton Data Members | Legend
Public Data Members
Public Data Member | Description
m_bStyle | Custom style of button


Legend

Legend
CXTPSkinObjectClassMap Data Members
Legend
Data Member
protected


CXTPSkinObjectClassMap Data Members Protected Data Members

CXTPSkinObjectClassMap Data Members Protected Data Members
CXTPSkinObjectClassMap Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_mapInfo | General map


Legend

Legend
CXTPSkinObjectFrame Data Members
Legend
Data Member
protected


CXTPSkinObjectFrame Data Members Protected Data Members

CXTPSkinObjectFrame Data Members Protected Data Members
CXTPSkinObjectFrame Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrButtons | Caption buttons
m_bActive | TRUE if caption is active
m_bMDIClient | TRUE if frame is MDI client
m_bRegionChanged | TRUE if region was changed
m_dwExStyle | ExStyles of window
m_dwStyle | Styles of window
m_pButtonHot | Hot caption button
m_pButtonPressed | Pressed caption button
m_pSBTrack | Track info of scroll bars
m_rcBorders | Frame borders
m_spi | Scroll bar position info
m_szFrameRegion | Lase frame region


CXTPSkinObjectFrame Data Members Public Data Members

CXTPSkinObjectFrame Data Members Public Data Members
CXTPSkinObjectFrame Data Members | Legend
Public Data Members
Public Data Member | Description
m_bLockFrameDraw | TRUE to lock draw
m_dwDialogTexture | Dialog texture


Legend

Legend
CCaptionButton Data Members
Legend
Data Member


CCaptionButton Data Members Public Data Members

CCaptionButton Data Members Public Data Members
CCaptionButton Data Members | Legend
Public Data Members
Public Data Member | Description
m_nClassPart | Class part
m_nCommand | Button Command
m_nHTCode | HitTest code
m_pFrame | Parent frame object
m_rcButton | Button bounding rectangle


Legend

Legend
CXTPStatusBar Data Members
Legend
Data Member
protected


CXTPStatusBar Data Members Protected Data Members

CXTPStatusBar Data Members Protected Data Members
CXTPStatusBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrPanes | Array of panes
m_bDrawDisabledText | TRUE to draw disabled text
m_bShowSizeGripper | TRUE to show size gripper
m_fontStatus | Font of status bar
m_nMinHeight | Minimum client height
m_nRibbonDividerIndex | Position of dark part for Ribbon Theme
m_pHighlightedPane | Pane currently highlighted


Legend

Legend
CXTPStatusBarPane Data Members
Legend
Data Member
protected


CXTPStatusBarPane Data Members Protected Data Members

CXTPStatusBarPane Data Members Protected Data Members
CXTPStatusBarPane Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoDeleteWnd | TRUE to auto delete child.
m_bButton | TRUE if pane is clickable button
m_bPressed | TRUE if button was pressed
m_clrBackground | Background color
m_clrText | Text color
m_cxText | Width of the string area in pixels.
m_dwHideFlags | TRUE if pane is visible
m_fntText | Font of an item text
m_hWndPane | Child handle
m_nAlignment | Alignment of the item.
m_nIconIndex | Icon index of the pane
m_nID | IDC of indicator: 0 => normal text area.
m_nIndex | Index of the item
m_nStyle | Style flags (SBPS_*).
m_pStatusBar | Parent StatusBar object
m_rcMargins | Margins of the pane
m_rcPadding | Margins of the pane
m_strText | Text in the pane.
m_strToolTip | Tooltip text for the item..


Legend

Legend
CXTPSyntaxEditAutoCompleteWnd Data Members
Legend
Data Member
protected


CXTPSyntaxEditAutoCompleteWnd Data Members Protected Data Members

CXTPSyntaxEditAutoCompleteWnd Data Members Protected Data Members
CXTPSyntaxEditAutoCompleteWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrACData | Stores list of choices (line of text and image)
m_arrACDataFiltered | Stores filtered list of choices (line of text and image)
m_arrGrid | Stores list of rectangle areas where were displayed textimage strings from m_arrACData
m_bActive | Active flag
m_bFilteredMode | Flag to identify is current mode (filtered/full);
m_bFixedBottom | Store autocomplete window position: above or below at the cursor.
m_bHighLight | This flag determines if selected string is highlighted.
m_clrHighLight | Standard window highlight color
m_clrHighLightText | Standard windows highlight text color
m_clrWindow | Standard window color
m_clrWindowText | Standard windows text color
m_fontBasic | Font to display text
m_ilACGlyphs | Images for AutoComplete list
m_nBordersHeight | Stores summary thickness of vertical window borders
m_nEndReplacePos | Position of last char in the Edit Control which will be replaced by the chosen text
m_nFirstDisplayedStr | Current first visible (upper) line
m_nHighLightLine | Current highlight line identifier
m_nLineHeight | Stores height of line
m_nLines | Number of visible lines
m_nStartReplacePos | Position of first char in the Edit Control which will be replaced by the chosen text
m_nWndHeight | Height of window
m_nWndWidth | Width of window
m_pParentWnd | Pointer to the parent window
m_strCloseTags | Stores set of closed tags divided by ~ input closed tags lead to close AutoComplete window
m_strDelims | stores char list that are tag delimiters
m_strOpenTags | Stores open tags
m_strSearch | Temporary stores chain of chars from user input to perform incremental search
m_strTmpCloseTag | Temporary stores chain of chars from user input to recognize close tags
m_strTmpOpenTag | Temporary stores chain of chars from user input to recognize Open tags


Legend

Legend
CXTPSyntaxEditBatchCommand Data Members
Legend
Data Member
protected


CXTPSyntaxEditBatchCommand Data Members Protected Data Members

CXTPSyntaxEditBatchCommand Data Members Protected Data Members
CXTPSyntaxEditBatchCommand Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_CommandList | Commands buffer storage.


Legend

Legend
CXTPSyntaxEditBufferCommand Data Members
Legend
Data Member
protected


CXTPSyntaxEditBufferCommand Data Members Protected Data Members

CXTPSyntaxEditBufferCommand Data Members Protected Data Members
CXTPSyntaxEditBufferCommand Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_lcFrom | Start edit position.
m_lcTo | End edit position.
m_pBufferMgr | Pointer to the associated text buffer.
m_strText | Stored changed text.


Legend

Legend
CXTPSyntaxEditBufferManager Data Members
Legend
Data Member
protected


CXTPSyntaxEditBufferManager Data Members Protected Data Members

CXTPSyntaxEditBufferManager Data Members Protected Data Members
CXTPSyntaxEditBufferManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bIsParserEnabled | Stores flag of parser state (enabled/disabled)
m_bOverwrite | Overwrite mode status
m_bUnicodeFileFormat | Determine is file format Unicode or ASCII.
m_iCRLFStyle | CRLF style 0 - DOS, 1 - UNIX, 2 - MAC
m_nAverageLineLen | Stores average line length.
m_nCodePage | CodePage for text conversion
m_nTabSize | Tab size
m_pConnect | Connection object to send notifications.
m_pLexParser | Lexical parser
m_pLineMarksManager | line marks manager
m_ptrLexConfigurationManager | Pointer to the Lexical configuration manager
m_pUndoRedoManager | Undo / redo manager.
m_strFileExt | Stores file extension
m_Strings | A strings manager helper object
s_dwLexConfigurationManager_DefaultRefs | The reference count for common default Configuration Manager instance.
s_ptrLexConfigurationManager_Default | The common default Configuration Manager instance.


Legend

Legend
CXTPSyntaxEditStringsManager Data Members
Legend
Data Member


CXTPSyntaxEditStringsManager Data Members Public Data Members

CXTPSyntaxEditStringsManager Data Members Public Data Members
CXTPSyntaxEditStringsManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_arStrings | String collection


Legend

Legend
CXTPSyntaxEditCommand Data Members
Legend
Data Member
protected


CXTPSyntaxEditCommand Data Members Protected Data Members

CXTPSyntaxEditCommand Data Members Protected Data Members
CXTPSyntaxEditCommand Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_strCommandText | A text description of the command.


Legend

Legend
CXTPSyntaxEditCtrl Data Members
Legend
Data Member
protected


CXTPSyntaxEditCtrl Data Members Protected Data Members

CXTPSyntaxEditCtrl Data Members Protected Data Members
CXTPSyntaxEditCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arCollapsedTextRows | The array of rows with beginning of collapsed blocks.
m_arOnScreenSchCache | On-screen schema cache for this control.
m_arValidDispRows | An array with indexes of valid displayed rows.
m_bAutoIndent | Auto indentation is enabled or not
m_bCaseSensitive | Case sensitive
m_bCreateScrollbarOnParent | TRUE if parent window scroll bars are used, otherwise FALSE.
m_bDragging | TRUE if in dragging mode
m_bDrawNodes | TRUE if Collapsible nodes signs are to be printed
m_bDroppable | TRUE if the current position is droppable
m_bEnableEditAccelerators | Enable/disable accelerators for Cut, Copy, Paste, Undo, Redoo and Select All operations.
m_bEnableOleDrag | Enables or disables OLE drag drop
m_bEnableWhiteSpace | Show white space
m_bFocused | States if focused or not
m_bHideCaret | Store is caret visible.
m_bHorzScrollBar | TRUE if vertical scrollbar is to be enabled
m_bIsActive | TRUE if application is active.
m_bIsDragging | TRUE if dragging, FALSE otherwise
m_bIsScrollingEndRow | Maintains a internal logic to draw the last row which is partly visible
m_bIsSmartIndent | Smart indentation is enabled or not
m_bLineNumbers | TRUE if line number is to be printed
m_bmpCache | Current view cached picture
m_bPageDirty | TRUE if the whole page is dirty
m_bReadOnly | Store ReadOnly mode.
m_bRightButtonDrag | TRUE if user is dragging through right button
m_bScrolling | Temporary variable to specify if scrolling by mouse wheel
m_bSelMargin | TRUE if selection margin is to be enabled or not
m_bSyntaxColor | Enables or disables syntax colorization
m_bTabWithSpace | Store tabulation width.
m_bTokensLoaded | Specifies if tokens are loaded or not
m_bVertScrollBar | TRUE if horizontal scrollbar is to be enabled
m_bVirtualSpace | TRUE if virtual space is enabled (cursor can be paced in any place after line end).
m_bWideCaret | Stored Overwrite Caret Style: Thin or Thick.
m_bWndCreateInProgress | Internal flag to indicate that windows creating is in progress.
m_chPrevLeadByte | For none-UNICODE version IME sends double byte chars as 2 WM_CHAR messages.
m_DrawTextProcessor |
m_dwAutoScrollDirection | Store active autoscroll direction.
m_dwInsertPos | Current insert position
m_dwLastRedrawTime | Stores last redrawing time
m_fcCollapsable | Collapsible rows cache
m_fcRowColors | Row colors cache
m_mapRowBkColor | The map for row back colors (cache)
m_mapRowColor | The map for row colors (cache)
m_nAutoIndentCol | Contains the column for auto indentation
m_nAverageLineLen | Average length of line
m_nBottomCalculatedRow | Bottom row of the last range of rows that have scrollbars properly calculated
m_nCollapsedTextRowsCount | The total amount of collapsed blocks in the document,
m_nCurrentCol | Current absolute column
m_nCurrentDocumentRow | Current row in the document
m_nDispCol | Current display column
m_nEditbarLength | Edit bar length including gutter and line number
m_nHScrollMaxWidth | Maximum horizontal scrollbar position.
m_nInsertSpaceCount | Temporarily stores the no of space to be inserted for auto indentation
m_nInsertTabCount | Temporarily stores the no of tabs to be inserted for auto indentation
m_nLineNumLength | Line numbers length
m_nMarginLength | Margin length
m_nNodesWidth | The width of the nodes signs
m_nTopCalculatedRow | Top row of the last range of rows that have scrollbars properly calculated
m_nTopRow | Top row for display
m_nWheelScroll | Lines to scroll on mouse wheel
m_pAutoComplete | Auto complete popup window.
m_pBuffer | The buffer manager
m_pPaintManeger | The paint manager
m_pParentWnd | Points to parent window.
m_ptDropPos | Specifies the drop position
m_pToolTip | Tool tip window for collapsed blocks text.
m_ptPrevMouse | Stored mouse position of the previous tip showing.
m_strDefaultCfgFilePath | Store configuration file full name.
m_strTmpLineTextBuff | Temporary text buffer


CXTPSyntaxEditCtrl Data Members Public Data Members

CXTPSyntaxEditCtrl Data Members Public Data Members
CXTPSyntaxEditCtrl Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDeleteOnFinalRelease | If TRUE - Delete self OnFinalRelease() call.
m_bDisableRedraw | If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).


Legend

Legend
CXTPSyntaxEditFindReplaceDlg Data Members
Legend
Data Member
protected


CXTPSyntaxEditFindReplaceDlg Data Members Protected Data Members

CXTPSyntaxEditFindReplaceDlg Data Members Protected Data Members
CXTPSyntaxEditFindReplaceDlg Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bReplaceDlg | Stored dialog type.
m_pEditCtrl | Stored attached view.
m_ptWndPos | Stored window position.


CXTPSyntaxEditFindReplaceDlg Data Members Public Data Members

CXTPSyntaxEditFindReplaceDlg Data Members Public Data Members
CXTPSyntaxEditFindReplaceDlg Data Members | Legend
Public Data Members
Public Data Member | Description
m_bMatchCase | Store Match Case option.
m_bMatchWholeWord | Store Match Whole Words option.
m_csFindText | Store text to find.
m_csReplaceText | Store text to replace.
m_nSearchDirection | Store Search Direction: 0-up, 1-down.


Legend

Legend
CXTPSyntaxEditGoToLineDlg Data Members
Legend
Data Member
protected


CXTPSyntaxEditGoToLineDlg Data Members Protected Data Members

CXTPSyntaxEditGoToLineDlg Data Members Protected Data Members
CXTPSyntaxEditGoToLineDlg Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bHideOnFind | Store Hide On Find option.
m_bSelectLine | Store Select Line option.
m_iMaxLineNo | Store a maximum line number.
m_pEditCtrl | Store attached edit control.
m_ptWndPos | Store window position.


Legend

Legend
CXTPSyntaxEditLexClass Data Members
Legend
Data Member
protected


CXTPSyntaxEditLexClass Data Members Protected Data Members

CXTPSyntaxEditLexClass Data Members Protected Data Members
CXTPSyntaxEditLexClass Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nActiv_EndTags_Offset | First index of end active tags set in the Active Tags collection (m_ActiveTags member).


Legend

Legend
CXTPSyntaxEditLexOnScreenParseCnt Data Members
Legend
Data Member


CXTPSyntaxEditLexOnScreenParseCnt Data Members Public Data Members

CXTPSyntaxEditLexOnScreenParseCnt Data Members Public Data Members
CXTPSyntaxEditLexOnScreenParseCnt Data Members | Legend
Public Data Members
Public Data Member | Description
m_nRowEnd | End row for parse.
m_nRowStart | Start row for parse.
m_ptrTBLast | Latest found text block.


Legend

Legend
CXTPSyntaxEditLexParserSchemaOptions Data Members
Legend
Data Member


CXTPSyntaxEditLexParserSchemaOptions Data Members Public Data Members

CXTPSyntaxEditLexParserSchemaOptions Data Members Public Data Members
CXTPSyntaxEditLexParserSchemaOptions Data Members | Legend
Public Data Members
Public Data Member | Description
m_bConfigChangedReparceInSeparateThread | 0,1} default=1
m_bEditReparceInSeparateThread | 0,1} default=1
m_bFirstParseInSeparateThread | 0,1} default=1
m_dwEditReparceTimeout_ms | default=500 ms; time out for start reparse after last key was pressed.
m_dwMaxBackParseOffset | default=100; maximum back buffer size.
m_dwOnScreenSchCacheLifeTime_sec | default=180 sec; time out for on screen parsed pices of text.
m_dwParserThreadIdleLifeTime_ms | default=60 sec; time out for existing of parser thread when parser idle (no parse requests).


Legend

Legend
CXTPSyntaxEditLexTextBlock Data Members
Legend
Data Member
protected


CXTPSyntaxEditLexTextBlock Data Members Protected Data Members

CXTPSyntaxEditLexTextBlock Data Members Protected Data Members
CXTPSyntaxEditLexTextBlock Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nEndTagXLCLen | End tag length in XLC form.
m_nStartTagLen | Start tag length.
m_ptrLastChild | for internal use only.


CXTPSyntaxEditLexTextBlock Data Members Public Data Members

CXTPSyntaxEditLexTextBlock Data Members Public Data Members
CXTPSyntaxEditLexTextBlock Data Members | Legend
Public Data Members
Public Data Member | Description
m_bEndByParent | Text block ended when the parent block ended.
m_PosEndLC | Text block start position.
m_PosStartLC | Text block start position.
m_ptrLexClass | Pointer to the LexClass object.
m_ptrNext | Pointer to the next block.
m_ptrParent | Pointer to the parent block object.
m_ptrPrev | Pointer to the previous block.


Legend

Legend
CXTPSyntaxEditLexTokensDef Data Members
Legend
Data Member


CXTPSyntaxEditLexTokensDef Data Members Public Data Members

CXTPSyntaxEditLexTokensDef Data Members Public Data Members
CXTPSyntaxEditLexTokensDef Data Members | Legend
Public Data Members
Public Data Member | Description
m_arEndSeps | Stores list of end separators.
m_arStartSeps | Stores list of start separators.
m_arTokens | Stores list of tokens.


Legend

Legend
CXTPSyntaxEditLexVariable Data Members
Legend
Data Member
protected


CXTPSyntaxEditLexVariable Data Members Protected Data Members

CXTPSyntaxEditLexVariable Data Members Protected Data Members
CXTPSyntaxEditLexVariable Data Members | Legend
Protected Data Members
Protected Data Member | Description
s_bVarMapInitialized | Is initialized state of the lex variable name to ID map.
s_mapVar2ID | Lex variable name to ID map.


CXTPSyntaxEditLexVariable Data Members Public Data Members

CXTPSyntaxEditLexVariable Data Members Public Data Members
CXTPSyntaxEditLexVariable Data Members | Legend
Public Data Members
Public Data Member | Description
m_nVarFlags | Additional lex variable properties (flags).
m_nVarID | Lex variable identifier.


Legend

Legend
CXTPSyntaxEditLexVariant Data Members
Legend
Data Member


CXTPSyntaxEditLexVariant Data Members Public Data Members

CXTPSyntaxEditLexVariant Data Members Public Data Members
CXTPSyntaxEditLexVariant Data Members | Legend
Public Data Members
Public Data Member | Description
m_arStrVals | Value storage for types xtpEditLVT_className , xtpEditLVT_valStr
m_nObjType | Object type value from XTPSyntaxEditLexVariantType.
m_nValue | Value storage for type xtpEditLVT_valInt
m_ptrClass | Value storage for type xtpEditLVT_classPtr
m_ptrLVArrayPtr | Value storage for type xtpEditLVT_LVArrayPtr
m_Variable | Value storage for type xtpEditLVT_valVar


Legend

Legend
CXTPSyntaxEditPaintManager Data Members
Legend
Data Member
protected


CXTPSyntaxEditPaintManager Data Members Protected Data Members

CXTPSyntaxEditPaintManager Data Members Protected Data Members
CXTPSyntaxEditPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrValues | Default color
m_font | Default font for normal text.
m_fontLineNumber | The font for line numbering
m_fontText | Current text font
m_fontToolTip | The font for tool tip text
m_hCurArrow | Standard ARROW cursor
m_hCurCopy | Cursor for copying text
m_hCurIBeam | Standard IBEAM cursor
m_hCurLine | Cursor to show on line selection area
m_hCurMove | Cursor for moving text
m_hCurNO | Standard NO cursor
m_ilBookmark | Image list with all bookmark images
m_penGray | Standard common gray pen


Legend

Legend
CXTPSyntaxEditPropertiesDlg Data Members
Legend
Data Member
protected


CXTPSyntaxEditPropertiesDlg Data Members Protected Data Members

CXTPSyntaxEditPropertiesDlg Data Members Protected Data Members
CXTPSyntaxEditPropertiesDlg Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_Page1 | Property page for common edit options.
m_Page2 | Property page for font options.
m_Page3 | Property page for colors options.


Legend

Legend
CXTPSyntaxEditPropertiesPageColor Data Members
Legend
Data Member
protected


CXTPSyntaxEditPropertiesPageColor Data Members Protected Data Members

CXTPSyntaxEditPropertiesPageColor Data Members Protected Data Members
CXTPSyntaxEditPropertiesPageColor Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bModified | Store modified flag.
m_editFont | Store editor font.
m_mapLexClassInfo | Map lex schema name to schema classes array (CXTPSyntaxEditLexClassInfoArray*).
m_parLexClassInfo | Store currently selected schema classes.
m_pEditView | Store pointer to CXTPSyntaxEditView object.
m_pTextSchemesMgr | Store pointer to Schemes Manager.
m_ptrConfigMgr | Store pointer to Configuration Manager.


Legend

Legend
CXTPSyntaxEditPropertiesPageEdit Data Members
Legend
Data Member
protected


CXTPSyntaxEditPropertiesPageEdit Data Members Protected Data Members

CXTPSyntaxEditPropertiesPageEdit Data Members Protected Data Members
CXTPSyntaxEditPropertiesPageEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bModified | Store modified flag.
m_pEditView | Store pointer to CXTPSyntaxEditView object.


Legend

Legend
CXTPSyntaxEditPropertiesPageFont Data Members
Legend
Data Member
protected


CXTPSyntaxEditPropertiesPageFont Data Members Protected Data Members

CXTPSyntaxEditPropertiesPageFont Data Members Protected Data Members
CXTPSyntaxEditPropertiesPageFont Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bModified | Store modified flag.
m_editFont | Store editor font.
m_iCharSet | Store char set.
m_pEditView | Store pointer to CXTPSyntaxEditView object.
m_uFaceSize | Store face name maximum string size.


Legend

Legend
CXTPSyntaxEditReplaceStringCommand Data Members
Legend
Data Member
protected


CXTPSyntaxEditReplaceStringCommand Data Members Protected Data Members

CXTPSyntaxEditReplaceStringCommand Data Members Protected Data Members
CXTPSyntaxEditReplaceStringCommand Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_strReplacedText | Buffer which holds replaced text.


Legend

Legend
CXTPSyntaxEditTextIterator Data Members
Legend
Data Member
protected


CXTPSyntaxEditTextIterator Data Members Protected Data Members

CXTPSyntaxEditTextIterator Data Members Protected Data Members
CXTPSyntaxEditTextIterator Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arBuffer | buffer of chars
m_bEOF | flag end of file.
m_LCpos | current position in the text.
m_mapLine2Len | store map of line - length of line
m_nBufOffsetB | offset
m_nBufOffsetB_max | offset
m_nBufOffsetB_normal | offset
m_nBufSizeB | buffer length
m_nNextLine | next line id
m_nTmpOffsetB | offset
m_nTmpOffsetC | offset
m_pData | Pointer to used CXTPSyntaxEditBufferManager object


Legend

Legend
CXTPSyntaxEditTextRegion Data Members
Legend
Data Member


CXTPSyntaxEditTextRegion Data Members Public Data Members

CXTPSyntaxEditTextRegion Data Members Public Data Members
CXTPSyntaxEditTextRegion Data Members | Legend
Public Data Members
Public Data Member | Description
m_posEnd | end position in document coordinates.
m_posStart | start position in document coordinates.


Legend

Legend
CXTPSyntaxEditTipListBox Data Members
Legend
Data Member
protected


CXTPSyntaxEditTipListBox Data Members Protected Data Members

CXTPSyntaxEditTipListBox Data Members Protected Data Members
CXTPSyntaxEditTipListBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dwIdx | Selection indexes: LOWORD - previous selection index, HIWORD - active selection index.
m_wndInfoTip | A tooltip window.


Legend

Legend
CXTPSyntaxEditTipWnd Data Members
Legend
Data Member
protected


CXTPSyntaxEditTipWnd Data Members Protected Data Members

CXTPSyntaxEditTipWnd Data Members Protected Data Members
CXTPSyntaxEditTipWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_iIndex | Current item index.
m_pListBox | Store pointer to attached list box.
m_ptCursor | Store cursor position.
m_rWindow | Store window rect.


Legend

Legend
CXTPSyntaxEditToolTipCtrl Data Members
Legend
Data Member
protected


CXTPSyntaxEditToolTipCtrl Data Members Protected Data Members

CXTPSyntaxEditToolTipCtrl Data Members Protected Data Members
CXTPSyntaxEditToolTipCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nDelayTime | Delay before showing the tooltip in milliseconds.
m_pParentWnd | Pointer to the parent report window.
m_rcHover | Hover window coordinates.
m_strToolTipText | ToolTip text to display.


Legend

Legend
CXTPSyntaxEditUndoRedoManager Data Members
Legend
Data Member
protected


CXTPSyntaxEditUndoRedoManager Data Members Protected Data Members

CXTPSyntaxEditUndoRedoManager Data Members Protected Data Members
CXTPSyntaxEditUndoRedoManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bGroupInsertMode | TRUE if group insert mode is on, FALSE otherwise
m_CommandList | Commands buffer.
m_nDataSizeLimit | The memory limit for undo data.
m_posFirstUndo | Actual command position in the buffer.
m_posSavedMark | Last saved command position in the buffer.


Legend

Legend
CXTPSyntaxEditView Data Members
Legend
Data Member
protected


CXTPSyntaxEditView Data Members Protected Data Members

CXTPSyntaxEditView Data Members Protected Data Members
CXTPSyntaxEditView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_aPageStart | Stores Printed page start row indexes.
m_bDraggingOver | TRUE if dragover is going on, FALSE otherwise
m_bDraggingStartedHere | TRUE if dragging is started in this view, FALSE otherwise
m_bFilesDragging | TRUE when dragging files, FALSE otherwise.
m_bInitialUpdateWasCalled | Indicate that OnInitialUpdate was called.
m_bOleDragging | TRUE if OLE dragging is enabled, FALSE otherwise
m_bOnSizeRunning | Indicate that OnSize message handler is in progress.
m_bScrollBars | Whether to create control with own scrollbars, or let to manage scrolling for parent window
m_dropTarget | OLE drop target
m_iTopRow | Top row for display
m_lfPrevFont | Temporarily stores editor font
m_nParserThreadPriority_WhenActive | Parser priority (active state).
m_nParserThreadPriority_WhenInactive | Parser priority (inactive state).
m_nPrevTopRow | Temporarily stores previous top row
m_pEditCtrl | Edit control instance
m_pFindReplaceDlg | Pointer to find or replace dialog.
m_pPrintOptions | Printing options.
m_szPage | Page size for printing or preview
m_wndEditCtrl | Default Edit control instance
ms_bDroppedHere | TRUE if text is dropped in this view, FALSE otherwise
ms_dwSignature | A signature used during drag-drop operation
ms_pTargetView | Target view pointer to be filled in by drag-drop routine
ms_ptDropPos | Stores drop mouse position.


CXTPSyntaxEditView Data Members Public Data Members

CXTPSyntaxEditView Data Members Public Data Members
CXTPSyntaxEditView Data Members | Legend
Public Data Members
Public Data Member | Description
m_bPrintDirect | if TRUE - the Print Dialog is bypassed.
m_bResizeControlWithView | if FALSE - attached Calendar control will not be resized with view.


Legend

Legend
CXTPTabClientWnd Data Members
Legend
Data Member
protected


CXTPTabClientWnd Data Members Protected Data Members

CXTPTabClientWnd Data Members Protected Data Members
CXTPTabClientWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_afterCloseTabPosition | Tab to make active after the currently active tab is closed.
m_arrWorkspace | Array of workspaces.
m_bAllowReorder | TRUE to allow the user to reorder tabs.
m_bAutoTheme | TRUE to auto theme the TabWorkspace.
m_bEnableGroups | TRUE if TabWorkspace groups are enabled.
m_bHorizSplitting | TRUE if groups devided horizontally
m_bRefreshed | TRUE if Refresh currently executed.
m_bShowWorkspace | TRUE to show the TabWorkspace, FALSE to hide the TabWorkspace.
m_bThemedBackColor | TRUE if a themed backcolor will be used.
m_bUpdateContents | TRUE if UpdateContents executed.
m_bUserWorkspace | TRUE if custom workspace used
m_bUseSplitterTracker | If TRUE, splitter trackers are used.
m_dwFlags | Specifies which tab navigation buttons are displayed.
m_hCursorDelete | Remove item cursor handle
m_hCursorHoriz | Horizontal split cursor handle.
m_hCursorNew | New item cursor handle
m_hCursorVert | Vertical split cursor handle.
m_newTabPosition | New tab position.
m_nSplitterSize | Splitter size
m_pActiveWorkspace | Active workspace.
m_pPaintManager | Current paint manager.
m_pParentFrame | pointer to the corresponding parent MDIFrame window
m_pTabWorkspace | Custom workspace
m_pToolTipContext | Tooltip Context.
m_themeCommandBars | Theme set for the TabWorkspace (Can be different from CommandBars if m_bAutoTheme is FALSE)


CXTPTabClientWnd Data Members Public Data Members

CXTPTabClientWnd Data Members Public Data Members
CXTPTabClientWnd Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDelayLock | TRUE to lock update with small delay
m_bForceToRecalc | TRUE to recalculate in next idle event.
m_bLockReposition | TRUE to lock reposition.
m_bLockUpdate | TRUE to lock update tabs.


Legend

Legend
CWorkspace Data Members
Legend
Data Member
protected


CWorkspace Data Members Protected Data Members

CWorkspace Data Members Protected Data Members
CWorkspace Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_dHeight | Height of the workspace
m_pTabClientWnd | Parent tabbed client.
m_rcSplitter | Splitter position.


Legend

Legend
CXTPTabManager Data Members
Legend
Data Member
protected


CXTPTabManager Data Members Protected Data Members

CXTPTabManager Data Members Protected Data Members
CXTPTabManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrItems | Collection of tabs of this tab manager.
m_arrNavigateButtons | Collection of tab navigation buttons for this tab manager
m_bActive | TRUE if the MDITabClient tab group is active.
m_bAllowReorder | TRUE to allow tabs to be reordered.
m_bCloseItemButton | TRUE to show close button for tabs.
m_nHeaderOffset | Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
m_nScrollDelta | Scroll header delta
m_pHighlighted | Tab currently highlighted.
m_pHighlightedNavigateButton | Pointer to highlighted navigate button
m_pPressed | Tab currently pressed.
m_pRowIndexer | Row indexer;
m_pSelected | Tab currently selected.
m_rcClient | Bounding rectangle of the tab client area.
m_rcControl | Bounding rectangle of the tab manager control.
m_rcHeaderRect | Bounding rectangle of the tab header area.
m_themeTabControl | Internal helper for drawing XP interface parts.


Legend

Legend
CXTPTabManagerItem Data Members
Legend
Data Member
protected


CXTPTabManagerItem Data Members Protected Data Members

CXTPTabManagerItem Data Members Protected Data Members
CXTPTabManagerItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrNavigateButtons | Array of navigate buttons
m_bClosable | TRUE if item can be closed.
m_bEnabled | TRUE if the tab is enabled.
m_bVisible | TRUE if the tab is visible.
m_clrItem | Color of tab button.
m_dwData | Developer specific data
m_hIcon | Icon associated with the tab.
m_hWnd | A CWnd pointer to the window associated with a tab.
m_nButtonLength | Width of the tab button.
m_nContentLength | Width of the tab button.
m_nImage | Image index, this is the index of an image within a CXTPImageManger or CImageList object.
m_nIndex | Index of the tab within the collection of tabs.
m_nItemRow | Row of the item
m_pTabManager | Parent item.
m_rcItem | Rectangle of this tab.
m_strCaption | User specified label for the tab.
m_strToolTip | Tooltip text for the tab.


Legend

Legend
CXTPTabManagerNavigateButton Data Members
Legend
Data Member
protected


CXTPTabManagerNavigateButton Data Members Protected Data Members

CXTPTabManagerNavigateButton Data Members Protected Data Members
CXTPTabManagerNavigateButton Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bEnabled | TRUE if the navigation button is enables.
m_bPressed | TRUE if the navigation button is pressedclicked.
m_dwFlags | Flag that indicates when the navigation button will be drawn.
m_nID | Id of the navigation button.
m_pItem | Owner item.
m_pManager | Pointer to the TabManager the navigation buttons are drawn on.
m_rcButton | Bounding rectangle of the navigation button.
m_strToolTip | Tooltip for the button.


Legend

Legend
CXTPTabPaintManager Data Members
Legend
Data Member
protected


CXTPTabPaintManager Data Members Protected Data Members

CXTPTabPaintManager Data Members Protected Data Members
CXTPTabPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrObservers | List of controls that receive notification when a property of paint manager has changed.
m_bUseStandardFont | TRUE to use standard system "icon" font which is Tahoma 8pt.
m_fntBold | Font used to display bold text in the tab buttons.
m_fntNormal | Font used to display text in tab buttons.
m_fntVerticalBold | Font used to display bold text in the tab buttons when the tab position is vertical.
m_fntVerticalNormal | Font used to display tab button caption when the tab position is vertical.
m_pAppearanceSet | Currently set CAppearanceSet.
m_pColorSet | Currently used CColorSet.
m_tabAppearance | Currently set appearance style.
m_tabColor | Currently used color style.
m_tabLayout | Currently set tab button layout.
m_tabPosition | Currently set tab button position.


CXTPTabPaintManager Data Members Public Data Members

CXTPTabPaintManager Data Members Public Data Members
CXTPTabPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bBoldNormal | If TRUE, bold font will be used for all tab both selected and non-selected.
m_bBoldSelected | If TRUE, the text of selected tabs will be displayed in bold font
m_bClearTypeTextQuality | TRUE to enable ClearType text for the font.
m_bClipHeader | TRUE to select clip rectangle before draw tabs
m_bDisableLunaColors | If FALSE, Tabs will not use LunaColors, is the current theme uses LunaColors
m_bDrawFocusRect | TRUE to draw focus rect for focused item.
m_bDrawTextEndEllipsis | If TRUE, when the size of a tab button is too small to display the caption the end of the caption will be replaced with an ellipse "...", If FALSE, the the end of the caption will be replaced with the ellipse.
m_bDrawTextHidePrefix | If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
m_bDrawTextNoPrefix | If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
m_bDrawTextPathEllipsis | If TRUE, when the size of a tab button is too small to display the caption the middle of the caption will be replaced with an ellipse "...", If FALSE, the the end of the caption will be replaced with the ellipse.
m_bFillBackground | If TRUE, then the tab client space is filled using CXTPTabPaintManager.CColorSet.m_clrControlFace color.
m_bHotTracking | If TRUE, tab hot tracking will be enabled.
m_bInvertGradient | If TRUE, the colors passed into CXTPTabPaintManager::CColorSet::GradientFill will be swapped before the rectangle is filled with the gradient.
m_bMultiRowFixedSelection | FALSE to move row with selected item close to client pane.
m_bMultiRowJustified | Stretch each row of tabs to fill the entire width of the control.
m_bOneNoteColors | If TRUE, tabs will use OneNote colorization
m_bRotateImageOnVerticalDraw | TRUE to rotate image when tab located left or right
m_bSelectOnButtonDown | if TRUE, when tab selected on mouse button down.
m_bSelectOnDragOver | TRUE to activate tab when user drag files/text under it.
m_bShowIcons | If TRUE, tab icons will be drawn is icons were added
m_bShowTabs | TRUE to show tabs
m_bStaticFrame | If TRUE, a static frame will be drawn around the entire tab area
m_clientFrame | Frame style of tab client area.
m_nButtonExtraLength | Additional padding of tabs
m_nDrawTextFormat | Text format for tabs (default - DT_LEFT | DT_VCENTER)
m_nFixedTabWidth | Tabs width for fixed layout
m_nMaxTabWidth | Maximum tabs width
m_nMinTabWidth | Minimum tabs width
m_rcButtonMargin | Margin around the text in tab button.
m_rcButtonTextPadding | Margin around the text in tab button.
m_rcClientMargin | Margin around tab client area.
m_rcControlMargin | Margin around entire tab control (tab client header and tab client area).
m_szIcon | Size of icon displayed in tab button.
m_toolBehaviour | Tootips behaviour


Legend

Legend
CAppearanceSet Data Members
Legend
Data Member
protected


CAppearanceSet Data Members Protected Data Members

CAppearanceSet Data Members Protected Data Members
CAppearanceSet Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bButtonsReverseZOrder | Draw buttons in right to left order.
m_nButtonHeight | Current tab button height (without margins).
m_pPaintManager | Self paint manager pointer.


CAppearanceSet Data Members Public Data Members

CAppearanceSet Data Members Public Data Members
CAppearanceSet Data Members | Legend
Public Data Members
Public Data Member | Description
m_nRowMargin | Margin between rows
m_rcHeaderMargin | CRect struct containing the left, top, right, and bottom margins of the tab header.


Legend

Legend
CAppearanceSetPropertyPage2003 Data Members
Legend
Data Member


CAppearanceSetPropertyPage2003 Data Members Public Data Members

CAppearanceSetPropertyPage2003 Data Members Public Data Members
CAppearanceSetPropertyPage2003 Data Members | Legend
Public Data Members
Public Data Member | Description
m_bDoubleHighlightedBorder | TRUE to draw a double border on mouse over when hot tracking is enabled.


Legend

Legend
CAppearanceSetPropertyPageFlat Data Members
Legend
Data Member


CAppearanceSetPropertyPageFlat Data Members Public Data Members

CAppearanceSetPropertyPageFlat Data Members Public Data Members
CAppearanceSetPropertyPageFlat Data Members | Legend
Public Data Members
Public Data Member | Description
m_bBlurPoints | TRUE to smooth corners of flat tabs.
m_bVisualStudio2005Style | TRUE to draw with Visual Studio 2005 style


Legend

Legend
CColorSet Data Members
Legend
Data Member
protected


CColorSet Data Members Protected Data Members

CColorSet Data Members Protected Data Members
CColorSet Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pPaintManager | Self Paint Manager pointer.


CColorSet Data Members Public Data Members

CColorSet Data Members Public Data Members
CColorSet Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrAutoHideFace | Color set of the auto-hide panel background.
m_clrBorderHighlight | Color of highlight border
m_clrButtonHighlighted | Tab button color on mouse over when hot tracking is enabled.
m_clrButtonNormal | Color of normal tabs.
m_clrButtonPressed | Tab pressed button color
m_clrButtonSelected | Color of the currently selected tab.
m_clrControlFace | Color of the control foreground.
m_clrDisabledText | Color of text when a tab is disabled.
m_clrFrameBorder | Color of border placed around the tab buttons and tab client.
m_clrHeaderFace | Color set of the tab header background.
m_clrHighlightText | Color of text on mouse over when hot tracking is enabled.
m_clrInActiveText | Color of text for tabs in all non-active groups of tabs in MDITabClient.
m_clrNormalText | Color of text in a normal tab.
m_clrPaneFace | Color of the control pane foreground.
m_clrSelectedText | Color of text in a "selected" tab button.
m_csExcelNormal | Color set of Normal Excel style tabs.
m_csExcelSelected | Color set of Selected (focused) Excel style tabs.
m_csPropertyPage | Color set of visual studio style tabs.
m_csPropertyPage2003 | Color set of Office 2003 style tabs.
m_csStateButton | Color set of state button style tabs.


Legend

Legend
CColorSetOffice2003 Data Members
Legend
Data Member
protected


CColorSetOffice2003 Data Members Protected Data Members

CColorSetOffice2003 Data Members Protected Data Members
CColorSetOffice2003 Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bLunaTheme | TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive, or xtpSystemThemeOlive, FALSE otherwise.
m_clrNavigateButtonBorder | Border color of tab navigation buttons on mouse over.


Legend

Legend
CColorSetVisualStudio2008 Data Members
Legend
Data Member
protected


CColorSetVisualStudio2008 Data Members Protected Data Members

CColorSetVisualStudio2008 Data Members Protected Data Members
CColorSetVisualStudio2008 Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bGradientButton | TRUE if luna colors are enabled.


Legend

Legend
CColorSetWhidbey Data Members
Legend
Data Member
protected


CColorSetWhidbey Data Members Protected Data Members

CColorSetWhidbey Data Members Protected Data Members
CColorSetWhidbey Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bGradientButton | TRUE if luna colors are enabled.


Legend

Legend
CColorSetWinXP Data Members
Legend
Data Member
protected


CColorSetWinXP Data Members Protected Data Members

CColorSetWinXP Data Members Protected Data Members
CColorSetWinXP Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_themeTabButton | Internally used helper to draw PropertyPage Buttons using Windows XP color set.
m_themeToolbar | Internally used helper to draw State Button using Windows XP color set.


Legend

Legend
CXTPTaskDialog Data Members
Legend
Data Member
protected


CXTPTaskDialog Data Members Protected Data Members

CXTPTaskDialog Data Members Protected Data Members
CXTPTaskDialog Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrButtons | Array of TASKDIALOG_BUTTON structures containing the definition of the custom buttons that are to be displayed in the dialog.
m_arrRadioButtons | Array of TASKDIALOG_BUTTON structures containing the definition of the custom radio buttons that are to be displayed in the dialog.
m_config | Structure contains information used to display a task dialog
m_hwndTaskDialog |
m_nSelButtonID | ID of the button that was selected when the task dialog was closed.


Legend

Legend
CXTPTaskPanel Data Members
Legend
Data Member
protected


CXTPTaskPanel Data Members Protected Data Members

CXTPTaskPanel Data Members Protected Data Members
CXTPTaskPanel Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAcceptFocus | TRUE if control accept focus.
m_bAllowDrop | TRUE to allow task panel group items to be dropped inside the task panel, FALSE to only allow items to be dropped outside the task panel.
m_bAnimation | TRUE if animation enabled.
m_bDrawFocusRect | TRUE to draw focused rectangle drawn around the item when the Up and Down arrows are used to navigate the items in the TaskPanel.
m_bExpandable | TRUE if groups are expandable.
m_bGrabbingFocus | TRUE if control move focus to itself.
m_bInUpdateScrollBar | TRUE is the CXTPTaskPanel::UpdateScrollBar() method is currently in use (Scrollbar is currently being updated).
m_bMultiColumn | TRUE is multiple columns are used to display items in a group.
m_bScrollVisible | TRUE if scroll bar is visible.
m_bSelectItemOnFocus | TRUE if items receive focus when they are clicked.
m_bSingleSelection | TRUE to use focused item as selected.
m_bTimerGroupHover | TRUE if Timer for Hover event is currently set.
m_cfItem | Clipboard format.
m_eAnimation | Current animation state.
m_hHandCursor | Hand cursor.
m_hotTrackStyle | Currently set hot tracking style.
m_itemLayout | Currently set item layout.
m_nAllowDrag | TRUE to allow task panel group items to be dragged.
m_nAnimateTimer | Timer identifier for animation.
m_nAnimationStep | Current step of animation.
m_nClientHeight | Group client height.
m_nColumnWidth | Width of task panel columns when m_bMultiColumn is TRUE.
m_nGroupMinClientHeight | Group minimum client height
m_nGroupSpacing | Amount of space placed between groups.
m_nLockRedraw | TRUE when control is locked.
m_nOldClientHeight | Old group client height.
m_nOLEDropMode | TRUE if ActiveX OLEDropMode used
m_pActiveGroup | Pointer to currently active group.
m_paintTheme | Current theme.
m_panelBehaviour | Currently set TaskPanel behavior.
m_pAnimation | Animation context
m_pDropTarget | Internal drag'n'drop helper.
m_pGroups | Collection of groups.
m_pImageManager | Image manager of task panel.
m_pItemDragging | Pointer to item currently being dragged.
m_pItemDragOver | Pointer to item under mouse cursor with dragged icon.
m_pItemFocused | Currently focused item.
m_pItemHot | Currently hot item.
m_pItemPressed | Currently pressed item.
m_pPaintManager | Current Paint Manager.
m_pScrollButton | Scroll buttons of the task panel.
m_pToolTipContext | Tooltip Context.
m_ptPressed | Point on task panel that was clicked.
m_rcMargins | Outer margins of groups.
m_szGroupIcon | Size of icons displayed in group captions.
m_szItemIcon | Size of group item icons.


Legend

Legend
CRepositionContext Data Members
Legend
Data Member
protected


CRepositionContext Data Members Protected Data Members

CRepositionContext Data Members Protected Data Members
CRepositionContext Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pTaskPanel | Parent Task Panel class


Legend

Legend
CXTPTaskPanelExplorerTheme Data Members
Legend
Data Member


CXTPTaskPanelExplorerTheme Data Members Public Data Members

CXTPTaskPanelExplorerTheme Data Members Public Data Members
CXTPTaskPanelExplorerTheme Data Members | Legend
Public Data Members
Public Data Member | Description
m_bExplorerTheme | TRUE to use Explorer theme under WinXP and to use office 2000 under older OSes.


Legend

Legend
CXTPTaskPanelExplorerThemePlain Data Members
Legend
Data Member


CXTPTaskPanelExplorerThemePlain Data Members Public Data Members

CXTPTaskPanelExplorerThemePlain Data Members Public Data Members
CXTPTaskPanelExplorerThemePlain Data Members | Legend
Public Data Members
Public Data Member | Description
m_bExplorerTheme | TRUE to use Explorer theme under WinXP and to use Office 2000 under older OSes.


Legend

Legend
CXTPTaskPanelGroup Data Members
Legend
Data Member
protected


CXTPTaskPanelGroup Data Members Protected Data Members

CXTPTaskPanelGroup Data Members Protected Data Members
CXTPTaskPanelGroup Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bCaptionVisible | TRUE if caption is visible.
m_bExpandable | TRUE if group is expandable.
m_bExpanded | TRUE if group is expanded.
m_bExpanding | TRUE if group is expanding now.
m_bSpecial | TRUE if group is special.
m_itemLayout | Currently set layout for the group.
m_nCaptionHeight | Height of caption.
m_nExpandedClientHeight | Expanded client height.
m_nItemsInRow | Number of group items in a row when using the xtpTaskPanelBehaviourToolbox XTPTaskPanelBehaviour.
m_nMinClientHeight | Minimum client height.
m_nScrollOffset | Scroll offset of group.
m_pItems | Collection of items.
m_rcGroupCurrent | Current rectangle of group during animation.
m_rcGroupTarget | Target rectangle of group during animation.
m_rcMarginsInner | Inner margins.
m_rcMarginsOuter | Outer margins.
m_szItemIcon | Size of group item icons.


Legend

Legend
CXTPTaskPanelGroupItem Data Members
Legend
Data Member
protected


CXTPTaskPanelGroupItem Data Members Protected Data Members

CXTPTaskPanelGroupItem Data Members Protected Data Members
CXTPTaskPanelGroupItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoHeight | TRUE if item stretched inside its group.
m_bBold | TRUE to use bold font.
m_bmpPreview | Internally used.
m_bSelected | TRUE if the item is currently selected.
m_clrText | Text color
m_hWnd | Only used for items of type xtpTaskItemTypeControl, this is the control's child window
m_rcItem | Rectangle of the item.
m_rcMargins | Item's margins.
m_strDragText | Drag text of the item.
m_szItem | Size of item.
m_szPreview | Last preview bitmap size


Legend

Legend
CXTPTaskPanelItem Data Members
Legend
Data Member
protected


CXTPTaskPanelItem Data Members Protected Data Members

CXTPTaskPanelItem Data Members Protected Data Members
CXTPTaskPanelItem Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAllowDrop | TRUE if item can be dragged.
m_bEnabled | TRUE if item is enabled.
m_bVisible | TRUE if item is visible
m_dwData | The 32-bit value associated with the item
m_nAllowDrag | TRUE if item can be dropped.
m_nIconIndex | Icon index.
m_nID | Identifier.
m_nTextFormat | Format of caption text of item.
m_pItems | Collection of child items.
m_pPanel | Parent TaskPanel class
m_rcIconPadding | Paddingspacing placed around the item icon.
m_rcText | Size and location of caption text of item.
m_strCaption | Caption of the item.
m_strTooltip | Tooltip of the item.
m_typeItem | Type of the item.


Legend

Legend
CXTPTaskPanelItems Data Members
Legend
Data Member
protected


CXTPTaskPanelItems Data Members Protected Data Members

CXTPTaskPanelItems Data Members Protected Data Members
CXTPTaskPanelItems Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrItems | Array of items.
m_pOwner | Owner of items.
m_pPanel | Parent TaskPanel control.


Legend

Legend
CXTPTaskPanelListViewOffice2003Theme Data Members
Legend
Data Member


CXTPTaskPanelListViewOffice2003Theme Data Members Public Data Members

CXTPTaskPanelListViewOffice2003Theme Data Members Public Data Members
CXTPTaskPanelListViewOffice2003Theme Data Members | Legend
Public Data Members
Public Data Member | Description
m_grcHot | Color gradient used to colorize "hot" items for this theme.
m_grcPushed | Color gradient used to colorize "pushed" items for this theme.


Legend

Legend
CXTPTaskPanelPaintManager Data Members
Legend
Data Member
protected


CXTPTaskPanelPaintManager Data Members Protected Data Members

CXTPTaskPanelPaintManager Data Members Protected Data Members
CXTPTaskPanelPaintManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bLeftRoundedCorner | TRUE to round left corner of the group caption.
m_bmpGrippers | Bitmaps of alpha grippers.
m_bOfficeBorder | TRUE to use office borders.
m_bRightRoundedCorner | TRUE to round right corner of the group caption.
m_bUseBitmapGrippers | TRUE to use alpha grippers.
m_bUseStandardCaptionFont | TRUE to use system font for group caption text.
m_bUseStandardItemsFont | TRUE to use system font for item caption text.
m_clrBackground | Background color of Task Panel.
m_clrHighlightBorder | Border color of items when they are "hot." This the border color of the item on mouseover if hot tracking is enabled.
m_clrHighlightHot | Color of items when they are "hot." This the color of the item on mouseover if hot tracking is enabled.
m_clrHighlightPressed | Color of items when they are pressed.
m_clrHighlightSelected | Color of items when they are selected.
m_fntCaption | Caption font.
m_fntIcon | Normal Items font.
m_fntIconBold | Bold items font.
m_fntIconHot | Hot items font.
m_fntIconHotBold | Bold items font.
m_groupNormal | Normal colors set.
m_groupSpecial | Special colors set.
m_hGripperNormal | Icon of normal group header gripper
m_hGripperSpecial | Icon of special group header gripper.
m_nCaptionHeight | Caption height in pixels.
m_nCaptionTextFormat | Format flags of caption text.
m_nItemTextFormat | Format flags of item text.


CXTPTaskPanelPaintManager Data Members Public Data Members

CXTPTaskPanelPaintManager Data Members Public Data Members
CXTPTaskPanelPaintManager Data Members | Legend
Public Data Members
Public Data Member | Description
m_bBoldCaption | TRUE to display caption text in bold font, FALSE to display caption text in normal type.
m_bCaptionScrollButton | TRUE if group caption scroll button is visible, FALSE if it is hidden.
m_bEmbossedDisabledText | TRUE to draw disabled text embossed.
m_bEmulateEplorerTheme | TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
m_bInvertDragRect | Only used when theme is set to xtpTaskPanelThemeToolbox.
m_bOfficeHighlight | TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED)
m_eGripper | Gripper of the manager.
m_nGroupSpacing | Amount of space placed between groups in the task panel.
m_rcControlMargins | Default margins for all groups.
m_rcGroupIconPadding | Padding around images for groups.
m_rcGroupInnerMargins | Inner margins of the group.
m_rcGroupOuterMargins | Outer margins of the group.
m_rcImageLayoutIconPadding | Padding around images for xtpTaskItemLayoutImages layout.
m_rcItemIconPadding | Padding around images for items.
m_rcItemInnerMargins | Inner margins of the group items.
m_rcItemOuterMargins | Outer margins of the group items.
rectDefault | System selected default margins.


Legend

Legend
CXTPTaskPanelPaintManagerPlain Data Members
Legend
Data Member
protected


CXTPTaskPanelPaintManagerPlain Data Members Protected Data Members

CXTPTaskPanelPaintManagerPlain Data Members Protected Data Members
CXTPTaskPanelPaintManagerPlain Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bOfficeCaption | FALSE to draw a rounded rectangle around caption.
m_bRoundedFrame | TRUE to draw a rounded frame around all of the groups in the task panel.


Legend

Legend
CXTPTaskPanelScrollButton Data Members
Legend
Data Member


CXTPTaskPanelScrollButton Data Members Public Data Members

CXTPTaskPanelScrollButton Data Members Public Data Members
CXTPTaskPanelScrollButton Data Members | Legend
Public Data Members
Public Data Member | Description
bEnabled | TRUE if the scroll button is enabled, FALSE if disabled.
bHot | TRUE if scroll button is "hot", FALSE otherwise.
bPressed | TRUE if scroll button is currently pressed, FALSE otherwise.
bScrollUp | If TRUE, the button is the "scroll up" button, If FALSE, the button is a "scroll down" button.
pGroupCaption | Pointer to the group that uses this group caption scroll button.
pGroupScroll | Pointer to the group that uses this group item scroll button.
rcButton | Bounding rectangle of the scroll button.


Legend

Legend
CXTPToolBar Data Members
Legend
Data Member
protected


CXTPToolBar Data Members Protected Data Members

CXTPToolBar Data Members Protected Data Members
CXTPToolBar Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bBuiltIn | TRUE if toolbar is built-in.
m_bContextMenuPresent | TRUE if the command bar is present in context menu.
m_bInRecalcLayout | TRUE if RecalcLayout method is called
m_bPreviewMode | TRUE if Toolbar was visible in preview mode.
m_bPreviewVisible | TRUE if Toolbar was visible in preview mode.
m_bShowExpandButton | TRUE to show expand button of toolbar.
m_bTearOff | TRUE if toolbar is tear-offed.
m_bTemporary | TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)
m_pDockBar | Parent dock bar.
m_pDockContext | Docking context.


Legend

Legend
CXTPToolTipContext Data Members
Legend
Data Member
protected


CXTPToolTipContext Data Members Protected Data Members

CXTPToolTipContext Data Members Protected Data Members
CXTPToolTipContext Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bShowImage | TRUE to show images in tooltip
m_bShowTitleAndDescription | TRUE to show title and description for tooltip.
m_clrTipBkColor | Background color in a tooltip window
m_clrTipTextColor | Text color in a tooltip window.
m_dwComCtlVersion | CommCtrl.dll version
m_dwStyle | Tooltip style
m_fnt | Font of the tool tip
m_fntTitle | Font of the tool tip
m_lastInfo | Last tooltip info.
m_nDelayAutoPop | the length of time a tooltip window remains visible if the pointer is stationary within a tool's bounding rectangle.
m_nDelayInitial | The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.
m_nDelayReshow | The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.
m_nIconTitle | Icon title for extended tooltip
m_nImageBase | This value will be added to tool identifier to retrieve image for tip.
m_nImageSize | Size of images in tooltip
m_nMaxTipWidth | Maximum width of tooltip window
m_pModuleContext | Tooltip for current module
m_pToolTip | Owned Tooltip window
m_rcMargin | Margin or "padding" placed around the tooltip text.
m_toolStyle | Tooltip style


Legend

Legend
CXTPToolTipContextToolTip Data Members
Legend
Data Member
protected


CXTPToolTipContextToolTip Data Members Protected Data Members

CXTPToolTipContextToolTip Data Members Protected Data Members
CXTPToolTipContextToolTip Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrTools | Tool tips item array
m_bActive | TRUE if tracking is active
m_dwLastTip | Last tool tip time.
m_hHookMouse | Mouse hook
m_nDelayInitial | The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.
m_nDelayReshow | The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.
m_nDelayTimer | Hover timer
m_pContext | Pointer to parent context class
m_pIcon | Image
m_pWndMonitor | Mouse monitor pointer
m_strTitle | Title of tooltip if enabled.
m_toolDelay | Currently delayed tip
m_toolDisabled | Currently ignored tip
m_toolVisible | Currently visible tip


Legend

Legend
CXTPTransparentBitmap Data Members
Legend
Data Member
protected


CXTPTransparentBitmap Data Members Protected Data Members

CXTPTransparentBitmap Data Members Protected Data Members
CXTPTransparentBitmap Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_hBitmap | A handle to a BtiMap.


Legend

Legend
CXTRegistryManager Data Members
Legend
Data Member
protected


CXTRegistryManager Data Members Protected Data Members

CXTRegistryManager Data Members Protected Data Members
CXTRegistryManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_hKeyBase | Handle to the registry key to use.
m_pszProfileName | The application's .INI filename.
m_pszRegistryKey | Used to determine the full registry key for storing application profile settings.
m_strINIFileName | Name of an .INI file for registry settings.


Legend

Legend
CXTResize Data Members
Legend
Data Member
protected


CXTResize Data Members Protected Data Members

CXTResize Data Members Protected Data Members
CXTResize Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arrItems | array of controls
m_nFlagsXX | flags passed from constructor
m_pWnd | the associative relation to the window to be resized
m_scSizeIcon | size icon window
m_strSection | section in registry where window placement information is saved.
m_szInitWindow | Initial dialog size
m_szMax | largest size allowed
m_szMin | smallest size allowed
m_szWindow | last dialog size


Legend

Legend
CXTResizeDialog Data Members
Legend
Data Member
protected


CXTResizeDialog Data Members Protected Data Members

CXTResizeDialog Data Members Protected Data Members
CXTResizeDialog Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_nDialogID | Contains the ID number of a dialog box template resource


Legend

Legend
CXTResizeItem Data Members
Legend
Data Member


CXTResizeItem Data Members Public Data Members

CXTResizeItem Data Members Public Data Members
CXTResizeItem Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAutoDelete | TRUE if the window is to be deleted.
m_bInitialSize | Initial size/move has been completed.
m_bIsGroupBox | TRUE if the window is a group box.
m_pWnd | A pointer to the window to be sized or moved.
m_rrcInitWindow | Initial control size.
m_rrcSizing | Sizing option.
m_rrcWindow | Last control size.


Legend

Legend
CXTResizePropertyPage Data Members
Legend
Data Member


CXTResizePropertyPage Data Members Public Data Members

CXTResizePropertyPage Data Members Public Data Members
CXTResizePropertyPage Data Members | Legend
Public Data Members
Public Data Member | Description
m_nDialogID | ID of the template used for this page


Legend

Legend
CXTResizePropertySheet Data Members
Legend
Data Member


CXTResizePropertySheet Data Members Public Data Members

CXTResizePropertySheet Data Members Public Data Members
CXTResizePropertySheet Data Members | Legend
Public Data Members
Public Data Member | Description
m_tabCtrl | Tab control.


Legend

Legend
CXTSearchOptionsCtrl Data Members
Legend
Data Member
protected


CXTSearchOptionsCtrl Data Members Protected Data Members

CXTSearchOptionsCtrl Data Members Protected Data Members
CXTSearchOptionsCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arHideCtrls | List of controls to show or hide.
m_arMoveCtrls | List of controls to move when expanded or contracted.
m_bExpanded | true when the control is expanded.
m_bPreSubclassInit | true for initialization.
m_iMaxSize | Height of the control when expanded.
m_iMinSize | Height of the control when contracted.
m_rcLabel | Size of the label that is displayed.
m_strContractLabel | Label to display when the control is contracted.
m_strExpandLabel | Label to display when the control is expanded.


Legend

Legend
CXTSearchOptionsView Data Members
Legend
Data Member
protected


CXTSearchOptionsView Data Members Protected Data Members

CXTSearchOptionsView Data Members Protected Data Members
CXTSearchOptionsView Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arResizeWnd | Array of children to move or resize.
m_hBrush | Handle to the current background brush
m_rcWindow | Original size of the window.


Legend

Legend
CXTShellListBase Data Members
Legend
Data Member
protected


CXTShellListBase Data Members Protected Data Members

CXTShellListBase Data Members Protected Data Members
CXTShellListBase Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bContextMenu | TRUE to display the shell context menu on right item click.
m_csIncludeEXT | Comma delimited string of extensions to include in file display.
m_nNameColumnWidth | Size in pixels for the name column width.
m_pDirThread | Thread used to monitor directory activity.
m_pidlINet | Points to the CSIDL_INTERNET folder location.
m_shSettings | Contains SHELLFLAGSTATE info.
m_uFlags | Flags indicating which items to include in the enumeration.


Legend

Legend
CXTShellListCtrl Data Members
Legend
Data Member
protected


CXTShellListCtrl Data Members Protected Data Members

CXTShellListCtrl Data Members Protected Data Members
CXTShellListCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bInitControl | true if the control has not been initialized.
m_pTreeCtrl | Window that receives update notification, usually a CXTShellTreeCtrl.


Legend

Legend
CXTShellListCtrlEx Data Members
Legend
Data Member
protected


CXTShellListCtrlEx Data Members Protected Data Members

CXTShellListCtrlEx Data Members Protected Data Members
CXTShellListCtrlEx Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pSyncWnd | Points to the window to synchronize with the shell list control.
m_strItemPath | A NULL terminated string that represents the currently selected folder.


Legend

Legend
CXTShellTreeBase Data Members
Legend
Data Member
protected


CXTShellTreeBase Data Members Protected Data Members

CXTShellTreeBase Data Members Protected Data Members
CXTShellTreeBase Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bContextMenu | TRUE to display the shell context menu on right item click.
m_bShowFiles | FALSE to show only directories
m_bTunneling | true if tree is currently traversing.
m_nRootFolder | Root Folder CSIDL
m_pComboBox | CComboBox that is associated with this control.
m_shSettings | Contains SHELLFLAGSTATE info.
m_uFlags | Flags indicating which items to include in the enumeration.


Legend

Legend
CXTShellTreeCtrl Data Members
Legend
Data Member
protected


CXTShellTreeCtrl Data Members Protected Data Members

CXTShellTreeCtrl Data Members Protected Data Members
CXTShellTreeCtrl Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoInit | TRUE if the tree control is to initialize when created.
m_pListCtrl | Window that receives the update notification, usually a CXTShellListCtrl.


Legend

Legend
CXTSizeIcon Data Members
Legend
Data Member
protected


CXTSizeIcon Data Members Protected Data Members

CXTSizeIcon Data Members Protected Data Members
CXTSizeIcon Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_hCursor | Handle to the cursor displayed for the size icon


Legend

Legend
CXTSortClass Data Members
Legend
Data Member
protected


CXTSortClass Data Members Protected Data Members

CXTSortClass Data Members Protected Data Members
CXTSortClass Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_pListCtrl | Pointer to the CListCtrl object to perform the sort on


Legend

Legend
CXTSplitPath Data Members
Legend
Data Member
protected


CXTSplitPath Data Members Protected Data Members

CXTSplitPath Data Members Protected Data Members
CXTSplitPath Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_szDir | Optional directory path, including trailing slash.
m_szDrive | Optional drive letter, followed by a colon (:)
m_szExt | Optional filename extension, including leading period (.)
m_szFName | Base filename (no extension)


Legend

Legend
CXTSplitterWnd Data Members
Legend
Data Member
protected


CXTSplitterWnd Data Members Protected Data Members

CXTSplitterWnd Data Members Protected Data Members
CXTSplitterWnd Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bClipStyles | Clip styles before dragging.
m_bFlatSplit | TRUE if the flat splitter style is used.
m_bForceFullDrag | TRUE to use full drag always.
m_bFullDrag | TRUE if full window dragging is enabled.
m_dwxStyle | The style of the splitter window.
m_nHiddenCol | Index of the hidden column.
m_nHiddenRow | Index of the hidden row.
m_point | Previous cursor position.


Legend

Legend
CXTSplitterWndEx Data Members
Legend
Data Member
protected


CXTSplitterWndEx Data Members Protected Data Members

CXTSplitterWndEx Data Members Protected Data Members
CXTSplitterWndEx Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bShowTopBorder | true to draw a top border line.
m_cyTopBorderGap | Size in pixels of the top border.


Legend

Legend
CXTSplitterWndTheme Data Members
Legend
Data Member


CXTSplitterWndTheme Data Members Public Data Members

CXTSplitterWndTheme Data Members Public Data Members
CXTSplitterWndTheme Data Members | Legend
Public Data Members
Public Data Member | Description
m_clrSplitterBorders | The color of the splitter borders.
m_clrSplitterFace | The color of the splitter.


Legend

Legend
CXTTabBase Data Members
Legend
Data Member
protected


CXTTabBase Data Members Protected Data Members

CXTTabBase Data Members Protected Data Members
CXTTabBase Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bPreSubclassInit | true when initializing from PreSubclassWindow.
m_pNavBtns | Arrow buttons.
m_pTabCtrl | Pointer to the tab control associated with this object.


CXTTabBase Data Members Public Data Members

CXTTabBase Data Members Public Data Members
CXTTabBase Data Members | Legend
Public Data Members
Public Data Member | Description
m_bAutoCondensing | TRUE for auto-condensing tabs.
m_bBoldFont | true to set the selected tab font to bold.
m_bXPBorder | true to draw an XP border around the tab child window.


Legend

Legend
CXTTabBaseTheme Data Members
Legend
Data Member
protected


CXTTabBaseTheme Data Members Protected Data Members

CXTTabBaseTheme Data Members Protected Data Members
CXTTabBaseTheme Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrNormalText | Color of text in a normal tab.
m_clrSelectedText | Color of text in a "selected" tab button.
m_iEdge | The Y dimension of a 3D border.
m_wrapTheme | Windows Theme wrapper.


CXTTabBaseTheme Data Members Public Data Members

CXTTabBaseTheme Data Members Public Data Members
CXTTabBaseTheme Data Members | Legend
Public Data Members
Public Data Member | Description
m_bSystemDrawing | TRUE to perform system drawing.
m_bUseWinThemes | TRUE to use Windows XP themes when available.


Legend

Legend
CXTTabBaseThemeOffice2003 Data Members
Legend
Data Member
protected


CXTTabBaseThemeOffice2003 Data Members Protected Data Members

CXTTabBaseThemeOffice2003 Data Members Protected Data Members
CXTTabBaseThemeOffice2003 Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_clrButtonNormal | Represents the color used for normal buttons.
m_clrButtonSelected | Represents the color used for selected buttons.
m_clrDarkShadow | Represents the color used for dark shadows.
m_clrHeaderFace | Represents the gradient color of the header face.
m_clrHighlight | Represents the highlight color.
m_clrShadow | Represents the color used for shadows.


Legend

Legend
CXTTabExBase Data Members
Legend
Data Member
protected


CXTTabExBase Data Members Protected Data Members

CXTTabExBase Data Members Protected Data Members
CXTTabExBase Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bInitialUpdate | TRUE to send initial update to views when created.
m_nPos | Index of the popup menu contained in the menu.
m_pLastActiveView | Points to the last active view that belongs to the main frame window.
m_popupMenuID | Popup menu resource ID.
m_pParentFrame | Points to the parent frame.
m_pParentWnd | Points to the parent and will equal 'm_pParentFrame' in non-dialog applications.


CXTTabExBase Data Members Public Data Members

CXTTabExBase Data Members Public Data Members
CXTTabExBase Data Members | Legend
Public Data Members
Public Data Member | Description
m_tcbItems | Template list containing tab information.


Legend

Legend
CXTTcbItem Data Members
Legend
Data Member


CXTTcbItem Data Members Public Data Members

CXTTcbItem Data Members Public Data Members
CXTTcbItem Data Members | Legend
Public Data Members
Public Data Member | Description
crTabBack | Application defined tab background color.
crTabSelBack | Application defined selected tab background color.
crTabSelText | Application defined selected tab text color.
crTabText | Application defined tab text color.
dwExStyle | Stores the extended window style when the tab item was created.
dwStyle | Stores the window style when the tab item was created.
pWnd | A CWnd pointer to the window associated with a tab.
szCondensedLabel | The label actually being displayed for auto-condensing tabs.
szTabLabel | User specified label for the tab.
szToolTipLabel | Tooltip text for the tab.
uiToolTipId | Resource ID for the tooltip.


Legend

Legend
CXTThemeManager Data Members
Legend
Data Member
protected


CXTThemeManager Data Members Protected Data Members

CXTThemeManager Data Members Protected Data Members
CXTThemeManager Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_enumTheme | Default theme for all components
m_factoryList | Collection of all theme factories.
m_mapDefaultFactories | Default factories collection


Legend

Legend
CXTThemeManagerStyle Data Members
Legend
Data Member
protected


CXTThemeManagerStyle Data Members Protected Data Members

CXTThemeManagerStyle Data Members Protected Data Members
CXTThemeManagerStyle Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bmpSnapShot | Used for drawing transparent background.
m_enumTheme | Self theme enumerator.
m_pFactory | Self factory class.


Legend

Legend
CXTThemeManagerStyleHost Data Members
Legend
Data Member
protected


CXTThemeManagerStyleHost Data Members Protected Data Members

CXTThemeManagerStyleHost Data Members Protected Data Members
CXTThemeManagerStyleHost Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAutoDeleteCustomFactory | TRUE to delete custom theme factory.
m_pCustomFactory | Custom theme factory
m_pDefaultFactory | Default theme factory
m_pThemeFactoryClass | Runtime class of default theme factory.


Legend

Legend
CXTTimeEdit Data Members
Legend
Data Member
protected


CXTTimeEdit Data Members Protected Data Members

CXTTimeEdit Data Members Protected Data Members
CXTTimeEdit Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bMilitary | true if military time is used.
m_iHours | Represents the hours to display.
m_iMins | Represents the minutes to display.


Legend

Legend
CXTTipOfTheDay Data Members
Legend
Data Member
protected


CXTTipOfTheDay Data Members Protected Data Members

CXTTipOfTheDay Data Members Protected Data Members
CXTTipOfTheDay Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_fontTip | Default font used for tips.
m_fontTitle | Default font used for "Did you know..." text.
m_ilLightBulb | Bulb bitmap.
m_pFontTip | User defined font for tips.
m_pFontTitle | User defined font for "Did you know..." text.
m_pStream | A pointer to the open file stream.
m_rcBorder | Size of the total display area.
m_rcTipText | Size of the display area for tip text.
m_strTipFile | Represents the file name and path for the tips file.
m_strTipText | Represents the Tip Of The Day text.
m_strTipTitle | Represents the "Did you know" text.


CXTTipOfTheDay Data Members Public Data Members

CXTTipOfTheDay Data Members Public Data Members
CXTTipOfTheDay Data Members | Legend
Public Data Members
Public Data Member | Description
m_bClassicStyle | Classic Style


Legend

Legend
CXTTipWindow Data Members
Legend
Data Member
protected


CXTTipWindow Data Members Protected Data Members

CXTTipWindow Data Members Protected Data Members
CXTTipWindow Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_arStrings | Stores strings if the tip is multiline.
m_bCenterHorz | TRUE if the window is to be centered horizontally.
m_bDelayTimerRunning | TRUE if delay timer is running.
m_crBackColor | Background color for the tip window.
m_crTextColor | Text color for the tip window.
m_dwTipStyle | Initial style for the tip window.
m_nDelayTimerEventID | Delay timer event ID.
m_nElapseTimerEventID | Elapse timer event ID.
m_nLineSpace | Amount in pixels to space the title and description text.
m_nTabPositions | Specifies the number of tab-stop positions in the array pointed to by m_pnTabStopPositions.
m_pnTabStopPositions | Points to an array of integers containing the tab-stop positions in logical units.
m_pointTipOffsetPos | Specifies the offset to move the top window in relation to the mouse cursor.
m_pParentWnd | Parent window.
m_ptMousePos | Initial xy coordinates of the cursor when when tip window was created.
m_rcScreenWindow | Initial size of the desktop.
m_rcShadow | Initial size of the tip window shadow.
m_rcWindow | Initial size of the tip window.
m_rectTipArea | Size of the client area for the tip window.
m_sizeMargin | Amount in pixels of the tip and side margins of where the tip text is displayed.
m_sizeTitle | title text size.
m_strDescrip | Description text for the tip window.
m_strTitle | Title text for the tip window.


Legend

Legend
CXTToolBox Data Members
Legend
Data Member
protected


CXTToolBox Data Members Protected Data Members

CXTToolBox Data Members Protected Data Members
CXTToolBox Data Members | Legend
Protected Data Members
Protected Data Member | Description
m_bAnimating | true if the folder selection is changing.
m_iFirst | Index of the first visible item.
m_iLast | Index of the last visible item.


Legend

Legend
CXTTrayIcon Data Members
Legend
Data Member
protected